Subs » Субтитры - VobSub - подключаем или накладываем субтитры на фильм

Добавить в закладки
VobSub - подключаем или накладываем субтитры на фильм

Лучшая программа для просмотра фильмов с внешними субтитрами. Она имеет целый набор полезных функций для работы с титрами. Имеет фильтр "TextSub", с помощью которого можно наложить титры на фильм.
Homepage
VobSub - это лучшая программа для просмотра фильмов с внешними субтитрами. Она имеет целый набор полезных функций для работы с субтитрами. С помощью VobSub вы сможете просматривать фильм с субтитрами, не накладывая их на фильм. Вы также можете наложить ваши титры на фильм, с помощью фильтра TextSub.vdf, включенном в пакет VobSub (об этом чуть ниже).

Как подключать?
Чтобы VobSub включался автоматически при запуске фильма, надо дать субтитрам такое же имя, как у фильма.

Пример:
Имя фильма - Conspiracy Theory (1997) [DivX].avi
Имя субтитров - Conspiracy Theory (1997) [DivX].srt
Можно также - Conspiracy Theory (1997) [DivX].RUS.srt

Синхронизация:
Можно "на лету" сдвигать субтитры вперед/назад, если ваши субтитры не совпадают с фильмом.
Для более сложной синхронизации (когда субтитры сдвинуты, а так же растянуты или сжаты по времени потребуется другая программа. Лучшая из них - Subtitle Workshop.
О фильтре TextSub.vdf, и о склеивании титров с фильмом:
С помощью фильтра TextSub.vdf и VirtualDub'а можно легко наложить (некоторые говорят - "вшить") субтитры в форматах srt, sub, ssa, smi, pcb, ass на фильм. Если вы решите склеивать титры с фильмом, не забудьте при инсталляции VobSub'a указать, что вы желаете установить этот фильтр:

Затем вам нужно также указать директорию, в которой установлен VirtualDub.

Коротко о работе с программой:
1. Установите Скачайте фильтр и закиньте его в папку плагинов : VirtualDubMod/plugins.
3. Откройте нужный фильм: File > Open Video File.
4. Установите фильтр через меню Video > Filters > Add > TextSub 2.23. Если его нет в списке, просто жмите Load, и добавляйте его *.
5. Теперь нажмите Open, и добавьте сами субтитры.
6. Затем через Video>Compression выбираем кодек, битрейт и другие настройки, по вкусу. **
7. И наконец, сохраните фильм уже с титрами: File>Save as > "Full Processing Mode".
* Если вы увидите сообщение об отсутствии vobsub.dll, установите Bitrate Calculator v 0.4, либо вы можете задать тот же битрейт и кодек, который у вас был до добавки субтитров. Узнать старый битрейт можно с помощью программы Gspot.
Надеюсь, что все достаточно ясно и подробно, но если мини-руководства не достаточно, можно обратиться к читайте отдельную статью. Если при воспроизведении вместо титров видны одни закорючки:
В закладке Main в отделе Text Settings можно задать правильный язык.
1.) Правый клик мышкой на значок VobSub'а в правом нижнем углу (во время воспоизведения титров, конечно).
2.) Выберите вкладку "DirectVobSub".
3.) В правой стороне выскочившего окошка, в закладке "Text Settings" нажмите на настройки фонтов.
4.) Задать правильный фонт и язык.

Субтитры должны просматриваться нормально.

Download / Загрузить файл: page.php?al=vobsub&a=dl
Размер файла: 716KB, загружено 9704 раз

----------------------------------------------------------------------------
18.01.2004 02:19 | Автор: Antar | Добавил (а): Antar

Похожие страницы:
# | Название | Добавил | Категория | Затребовано | Дата
1. | Подгоняем субтитры под фильм с помощью программы Subtitle Workshop. | Antar | Справочник | 3874 (→) | 25.01.2004
2. | VobSub 2.23 | Antar | Титровальня | 49126 (→) | 12.03.2004
3. | VSFilter 2.39 (Vobsub 2.39, textsub.vdf) | Antar | Титровальня | 20748 (→) | 30.07.2008
4. | VSRip (VobSub Ripper Wizard) 1.0.0.6 | Antar | Титровальня | 3166 (→) | 21.10.2006

Комментарии:
1. rozik1965 21.04.2007 12:30
Уважаемый Антар!
У меня опять вопрос, извините за надоедливость. Хочу наложить субтитры на нужный мне фильм.Сначала, когда я его открываю, появляется окошко:"VBR audio stream detected" с предупреждением о том что у меня VBR битрейт, и с предложением его изменить (может я не точно поняла. но примерно это). Я продолжаю действовать по вашей статье, но когда я хочу сохранить фильм, по программа выдает ошибку:Сannon start video compression : An unknown error occurred (may be coppurt data) (error code-100)
Я изучила подробнее программу, и поняла, что она не может конвертировать VBR.Подскажите, как выйти из положения?
Мне просто необходимо это сделать [image]. Спасибо.
2. Antar 21.04.2007 21:40
Это значит, что звук в этом фильме в переменном битрейте (количество бит (единиц информации) в секунду). VirtualDub не очень их любит. Советую попробовать сохранить звук в отдельный фаил (Save wav...). В меню Audio -> Compression... укажи uncompressed (Wave PCM).
Потом обратно пришей звук (в меню Audio укажи на AVI audio, а WAV file, вроде так), и Compression не забудь указать, в mp3, например, ужми, а то неупакованный звук может на 700 Мб потянуть.
Возможно будут проблемы с синхронизацией, тогда придётся редактировать сначала аудио файл каким-нибудь редактором.
3. rozik1965 22.04.2007 10:00
Есть какая-то альтернативная версия: Nandub, из этой-же группы программ. Я ее установила, и она работает с VBR, но не могу понять, как с ее помощью наклеить субтитры. Нигде нет подробного описания [image]. Может ты в курсе?
И еще, если я конвертитрую звук по твоим указаниям, лучше пользоваться VirtualDub или VirtualDubMod?
спасибо
4. Antar 22.04.2007 10:41
NanDub может кодировать только DivX3 и MS MPEG4 V2. Используй лучше VidtualDubMod.
VDubMod нормально работает с VBR ауддио, и по умолчанию выставляет звук в"direct streaming", насколько помню, могу и ошибаться. Я давно перестал кодировать, пользуюсь внешними субтитрами, если надо, и даже если кодирую, то только в mp4 с помощью Nero Digital, хотя почти нет железных плееров, понимающих мп4.
5. rozik1965 23.04.2007 10:54
вроде получилось, спасибо за наводку!!!! Почерпнула информацию еще вот тут: http://kinozal.tv/forum/showthread.php?t=283 , может кому пригодится.
Там у человека точно такая же проблема с VBR и пишут как перейти сразу к CBR и далее...
6. Antar 23.04.2007 14:31
Пож-ста
7. akakaa 24.05.2007 20:50
zdraste :-)

polniy profan :-)

ob'asnite, plz,

В закладке <strong>Main</strong> в отделе <strong>Text Settings</strong> можно задать правильный язык.
1.) Правый клик мышкой на значок VobSub'а в правом нижнем углу (во время воспоизведения титров, конечно).
2.) Выберите вкладку "DirectVobSub".
...

gde eto konkretno? " znachok vobsub v pravom nijnem uglu (???) "

spasibo
8. Antar 26.05.2007 00:10
Не знаю, как это обьяснить еще проще. Надеюсь, что Vobsub установлен, и имя фильма и субтитров совпадает?

Специально для вас сделал небольшой видео-ролик [image], скачайте тут и посмотрите. Может, так яснее.
9. Malevich 11.07.2007 00:41
подскажите пожалуйста, можно ли наложить субтитры на нижнюю черную полосу, которая появляется, когда смотришь широкоформатный фильм на стандартном формате?. Если можно - расскажите пожалуйста как это сделать?
10. Kowarisuki 11.07.2007 06:08
Кажется, в программах наложения сабов при просмотре был пункт "Use black backgound for subtitles" или что-то вроде того. Или нужно вшить сабы в картинку? Так такой же пункт был и в Gordian Knot.
11. Kowarisuki 11.07.2007 06:09
А, понял, BSPlayer это может делать при открытии в полный экран - версия 2.21 опускает сабы в самый низ.
12. Antar 12.07.2007 13:45
Malevich
Есть продвинутые форматы субтитров, такие как ASS и SSA. Там можно указать точное место на экране для субтиров, размер, цвет, и многое другое. Анимешники часто пользуются этими возможностями (тайпсеттинг).
13. mr.smith 14.09.2007 22:55
Здравствуйте Антар!
Подскажите как сохранить субтитры в видео в Virtual Dub, в самой программе мне ничего делать не приходилось, т.к субтитры совпадают, но когда выбираешь всевозможные варианты сохранения, размер видео увеличивается в 10 раз, странно, но я никак не могу разобраться, премного благодарен...
14. Antar 19.09.2007 15:11
mr.smith
У вас пропущен пункт 6 статьи, пережатие фильма кодеком.
15. Ivga_Lis 05.01.2009 03:52
Здравствуйте, Antar!

Подскажите, пожалуйста, такую вещь: некоторые видео MKV (На данный момент - уже 5 из 7!!) не загружаются в программу, выдавая целый лог ошибок:
MKV: A frame of stream 1 (at X ms) had only a forvard reference (may be broken file).
А в конце -
Coudn't lokate decompressor for format "yyyy" (unknown).
VirtualDub requires a Video for Windows (VTW) compatible codec to decompress video. DirectShow codecs, such as those used by WMPlayer, are not suitable. Only "stream copy" is available for this video.

Что необходимо сделать? Установить еще пакет кодеков? Переконвертировать файлы? Настройки поменять? Так файлы спокойно воспроизводятся тем же WMPlayer-ом, и имеют самый разный объем...
Спасибо!
16. Antar 06.01.2009 17:39
см. тут http://forums.afterdawn.com/thread_view.cfm/630552
17. Vado1980 17.01.2009 10:27
подскажите как сделать чтобы после вшития субтитров видео осталось без изминений
а то VirtualDubMod не только вшивает субтитры а и конвертирует видео
изиенение настроек не помогает
18. undeddy 25.01.2009 16:03
Доброго дня.
При попытке наложения субтитров с помощью VirtualDubMod, как и у rozik1965 , возникла проблема с тем, что аудио в импортируемом avi-файле представлено в VBR. Если я делаю все по описанной схеме (т.е. когда появляется предупреждение о VBR, я не отменяю конвертацию фильма), то конвертация вроде бы осуществляется нормально. Но в конечном файле звук рассинхронизирован с видео, при этом рассинхронизация происходит не на постоянную величину, а изменятеся: в начале - одна, затем - другая. Как это можно исправить? Как Вы (Antar) объяснили, нужно как-то выделить звук, затем его наложить, но это не понятно. Если возможно, не могли бы объяснить более детально?
19. Rin_1 10.02.2009 18:59
Я поняла как работает прога, но она почемуто не на все видеофайлы расспространяется!
Обычно там 2 картинки 1-как есть 2-с сабами, а есть такие видео которые вставляешь и только одна картинка и сабы не подставишь почему???!!!
20. birubir 11.02.2009 19:13
Я когда вшиваю субтитры в VirtualDubMod, то делаю так:

1. Загружаю фильм;
2. Выдираю оттуда звук;
3. Конвертирую его в МР3;
4. Добавляю звук в фильм, при этом, естественно, отключив старый и синхронизировав новый с видео;
5. Добавляю субтитры и всё сразу пересохраняю как мне нужно.

Может быть что-то и слишком мудрённо и, вполне возможно, с потерей качества, но мне для Тюбика шибко хорошее качество не нужно...
21. kaname 13.03.2009 14:31
Здравствуйте! Подскажите пожалуйста, почему после установки этой программы половина из них шифруется и вместо нормальных русских слов появились разные непонятные значки?
22. Antar 13.03.2009 19:20
Изпользуется ли DirectVobSub (Vsfilter)?
Eсли да, то кодировка легко меняется:

Правой кнопкой на значок vobsub'a:

Жмешь на DirectVobSub, получаешь такое меню:

Жмешь на Arial, будет такое меню:

доп. инфо по VobSub:
http://subs.com.ru/page.php?al=vobsub
http://subs.com.ru/page.php?al=vsfilter
23. Jok3r 11.09.2009 11:43
Здраствуйте, у меня такая проблемка!!!! Постараюсь обяснить как-то проще.... Вообщем запускаю VirtualDubMod, открываю фильм, выбираю Видео--->Фильтры---->Добавить---->TextSub 2.23, выпригивает такое окошко---->

Жму кнопочку Open, вибираю субтитры и все.....и ничего не происходит!!!

Кнопка OK не стает активной!!! В чем проблема, и как ее решить???
24. Antar 12.09.2009 12:00
Формат субтитров какой?
Лучше всего открой их в Subtitle Workshop, и сохрани их в формате SubRip (srt).
Затем попробуй еще раз...
25. dodomenos 18.10.2009 21:18
всем привет! подскажите пожалуйста.
здесь уже задавался вопрос,но это было в 2007г.
может появилась более свежая инфо.
есть фильм,широкоформатный,и там такие полосы чёрные ,снизу и сверху.
вот на них то и хотелось наложить субтитры! Сам фильм предполагается смотреть потом на двд плеере!
с помощью каких программ сейчас это можно сделать и как?
спасибо!
26. A30T 07.11.2009 15:47
Antar, помоги пожалуйста, сделал все как написано, проблема с пунктом 3:
Когда пытаюсь открыть нужный фильм (формат avi) вылазиет ошибка - Вот ссылка.
После этой ошибки пытался зайти в Video - fillters, но меню фильтров просто не доступно, что делать?
27. Antar 07.11.2009 16:32
Тебе надо установить Divx кодек, a еще лучше сразу установить Klite codec pack
28. aaleg 04.02.2010 13:56
Дамы и Господа,очень прошу снисходительно отнестись к моей компьютерной безграмотности,однако,я не понимаю....
"Вшил" субтитры в видео.Начал сохранять,беларуский язчык отображается,однако....размер....из файла в 56.5 мб только на 47 секунде 1 Гб. получается....
В чём проблема и как её решить!?
Спасибо за понимание.
29. okpb 04.02.2010 15:24
При добавлении субтитров у меня происходила такая же ситуация как и у aaleg, и я уменьшала качество видео, после того как конвертация закончилась я получила видео в 2 слишним Гига и очень большими квадратиками. Можно расписать подробнее про битрейты?
30. Antar 04.02.2010 16:07
7. И наконец, сохраните фильм уже с титрами: File>Save as > "Full Processing Mode".

Этот пункт выполняете?
31. okpb 04.02.2010 16:30
да, только так и сохраняю. И еще во время того как идет это сохранение (я работаю с корейскими субтитрами) субтитры через некоторое время меняют кодировку, и появляются непонятные буквы вместо корейских иероглифов
я так понимаю что это происходит из-за того что я начинаю смотреть параллельно фильм, потому что когда я не трогала компьютер, как раз получились отличные субтитры, а вот качество видео очень сильно ухудшилось(
32. birubir 04.02.2010 21:11
Quote

я так понимаю что это происходит из-за того что я начинаю смотреть параллельно фильм, потому что когда я не трогала компьютер, как раз получились отличные субтитры, а вот качество видео очень сильно ухудшилось

Вот вы и сами ответили на свой вопрос, почему у Вас "слетают" субтитры. Обработка видео - это довольно-таки ресурсоёмкий процесс. Я несколько раз читал на разных форумах предупреждения, что если обрабатываете видео, то отключайте на компе всё лишнее, чтобы ненужные программы не работали, т.к. они "едят" рессурсы системы. Ежели на современных мощных компах это не так заметно, то на стареньких это заметно сильно. А Вы, получается, ещё решили параллельно и кино посмотреть...
Мой Вам совет: ежели Вы уже знаете, что если комп не трогать при обработке видео и получается при этом нормальный результат, то ставьте видео на обработку, а сами идите пить пиво. Плюсов - куча. Вы хорошо проводите время, пока комп пыхтит на Ваше благо.
33. okpb 05.02.2010 11:56
все равно ничего не получается, 45 минут видео шло отлично, потом кодировка опять слетела, хотя все это время я не трогала комп и закрыла все ненужное. Я уже столько времени потратила на это, что нет сил уже и решила разрезать видео на 2 части. Нашла даже инструцкию - http://www.pctuner.ru/page-id-215.html, захожу в capture avi - дальше выбираю куда сохранить - и следующий шаг никак не получается потому что кнопка "source" не активна. Что я делаю не так?
34. Antar 06.02.2010 13:43
Может, раз такие проблемы, стоит попробовать AviRecomp ?
35. aaleg 08.02.2010 10:20
Делаю,всё как написано,однако,размер видео огромен....
36. StNekroman 11.02.2010 12:40
"Делаю,всё как написано,однако,размер видео огромен.... "
Потому что не сжимаешь его.
Надо ещё один фильтр вкинуть на сжатие. (И там параметры его поклацать)
========================================================
У меня другой вопрос?
Почему VirtualDubMod не хавает видео в контейнере mp4????
И когда загружаешь видео в mkv, он слегка думает, идет загрузка ("Processing Matroska File"), потом жмешь Play и VirtualDubMod вылетает с внутренней ошибкой. И так с ЛЮБЫМ mkv-файлом!
А мне нужно на mp4/mkv отрендерить сабы.
И как это сделать без 10 тысяч перекодирований/перегонки формата специально для VirtualDub-а.?
37. Antar 11.02.2010 21:03
Есть плагины, для виртуал дуба, к примеру такой: http://www.virtualdub.org/beta/DShowInputDriver-0.5.zip

Читай тут: http://forum.videohelp.com/threads/286901-VirtualDub-Now-Has-a-Directshow-Driver-Plugin
38. In'nefirrouorr'e 08.03.2010 11:13
Приветствую. У меня серьёзная проблема: вобсаб не понимает скрипты и кодировки субтитров (как правило ass-формата). Все перечисленные методы, как то настройка на вкладке direct vobsub, не помогли. Суть непонимания скриптов заключается в сбое тайминга эффектов (эффект "караоке" в опениегах аниме сразу доходит до середины строчки и застывает). Есть ли какой-нибудь метод решения этой проблемы?
39. Antar 08.03.2010 15:06
для начала, я бы открыл и пересохранил субтитры в какой-нибудь программе, понимающей ass, к примеру в SubStation Alpha. Так можно хотя бы убедиться, что это не проблема скрипта...
40. In'nefirrouorr'e 09.03.2010 06:10
SubStation тоже не выдаёт правильную кодировку. Получается, проблема уже в скрипте?
41. samire 24.04.2010 17:05
У меня проблема с размерами сабов. перевела в ass и подправила по методу http://subs.com.ru/forums.php?m=posts&p=548#548. Но вшить его в ави не получается. После того как ++Теперь нажмите Open, и добавьте сами субтитры++ выбрала этот файл ass, OK, но после этого его в окне нет! Окно пусто!
42. angel756 17.09.2010 21:41
Используется ли DirectVobSub (Vsfilter)?
Eсли да, то кодировка легко меняется

Antar помоги плиз,у меня не используется DirectVobSub ,но я использую новую версию 2.39 открываю через команду,но там не написано Language Eng как у тебя на скрине(
и не чего не изменяется сабы в виде каких то непонятных символов.
пожалуйста помоги!заранее спасибо!
| English subtitles | English subtitles for russian films | English anime subtitles | English subtitles for russian cartoons |
© 2004-2010 «SUBS.COM.RU» | Powered by Seditio | Hosted by Dreamsee | Oнлайн: 1 пользователь(ей), 42 гость(ей)