Total Commander - Total Commander: Крутые советы

Крутые советы

Вход в самораспаковывающиеся архивы

Total Commander позволяет "заходить" в самораспаковывающиеся архивы (с расширениями EXE), как в обычные архивы, показывая их содержимое как обычный каталог с файлами. Для этого нужно нажать комбинацию клавиш Ctrl+PageDown, когда курсор установлен на файле архива. Этот же фокус применим и к любым другим архивам, которые однако имеют другое расширение.

Прислал Ergo

Быстрый переход в нужные каталоги

Существует удобная возможность быстро переходить в наиболее часто используемые каталоги — для этого нужно просто нажать комбинацию клавиш [Ctrl]+[D]. Если вы ранее не пользовались этой возможностью, то список каталогов будет пустым. В появившемся меню будет только два пункта: Добавить текущий каталог и Настройка. С помощью первого можно быстро добавить текущий каталог к списку часто используемых и дать ему содержательное имя, причем совсем не обязательно использовать его имя (предлагаемое по умолчанию) в качестве пункта меню. Вызвать это же меню можно и мышкой. Для этого нужно произвести двойной щелчок на заголовке панели, причем не важно, какой именно, — активной или пассивной.

Прислал Ergo

ToolTips без задержки

Можно уменьшить время, через которое появляются подсказки над кнопками в панели инструментов, кнопками дисков и т. п. Для этого в файл wincmd.ini в раздел [Configuration] добавьте строку: ToolTipDelay=100. Цифра после знака равенства означает время задержки подсказки в миллисекундах. По умолчанию установлено ее значение равным 500, т. е. подсказки появляются через полсекунды. После перезапуска Total Commander будет сразу подсказывать, что скрывается за выбранной кнопкой. Уменьшение времени задержки особенно полезно, если на панели инструментов расположено много кнопок-переходов в папки на дисках — выбор нужной кнопки будет происходить быстрее.

Прислал Ergo

Имена в буфер обмена

Часто бывает нужно скопировать в буфер обмена имя текущего файла, чтобы затем где-нибудь вставить его (например в командной строке). Для этого создайте на панели инструментов Total Commander кнопку с командой cm_CopyNames_ToClip или cm_CopyFullNames_ToClip. Первая — для копирования только имени, вторая — для копирования полного имени файла, включающего путь к нему. Если будут выделены несколько файлов, то в любом текстовом редакторе можно быстро создать список из этих файлов. Чтобы скопировать и потом вставить не имя, а сам файл, воспользуйтесь стандартными комбинациями клавиш Ctrl+C и Ctrl+V.

Не помню кто

Стандартные меню

Если вам нужно использовать стандартные контекстные меню Windows для файлов и папок, можно настроить Total Commander так, что это будет происходить сразу, как в Проводнике, а не через 2-3 секунды после удерживания нажатой правой кнопки мыши. Для этого нужно включить опцию Конфигурация|Настройка|Операции|Выделение мышью и выбрать опцию Левой кнопкой (как обычно). В английской версии это Configuration|Options|Operations|Mouse selection mode, и значение Left mouse button (Windows Standart). Другой способ - установить в разделе [Configuration] файла wincmd.ini значение оператора UseRightButton равным 1.

Прислал $corpio

Запуск одним щелчком

Если вы хотите запускать приложения и открывать файлы одним щелчком мыши (как это можно настроить в Проводнике Windows), поместите в файл wincmd.ini, расположенный в папке, где находится Windows, в раздел [Configuration] следующую строку: SingleClickStart=1. Если этот оператор уже есть — проверьте, чтобы его значение было равно 1, и перезапустите Total Commander. Теперь файлы на панелях будут активизироваться при наведении на них указателя мыши, а запускаться — одним щелчком.

Прислал $corpio

Переход в корневой каталог диска

А знаете ли вы, что, нажав Ctrl+\, вы переходите в корневой каталог диска

Переход на одну директорию вверх

А знаете ли вы, что, нажав BackSpace, вы переходите на один каталог вверх

Информация о размере

А знаете ли вы, что нажав на файле или директории Ctrl+L, вы получите полную информацию о количестве файлов и директорий, общем размере и фактически занимаемом размере, а так же о размере, который выделенный файлы и директории займут на получателе (например дискете)

Имя в строке статуса

Чтобы имя текущего файла/директории показывалось с строке статуса, нужно добавить в wincmd.ini в разделе [Configuration] строчку: LongInStatus=1

Прислал Константин Роганов

Крутые советы в почтовый ящик

А знаете ли вы, что если вы подпишитесь на рассылку новостей сайта "Все о Total Commander", то кроме своевременных новостей об обновлениях на сайте вы будете еженедельно получать все новые крутые советы и даже раньше чем они будут опубликованы здесь?

Убрать квадратные скобки!

Чтобы директории на панелях показывались не в скобках, нужно добавить в wincmd.ini в разделе [Configuration] строчку:
DirBrackets=0

Прислал Константин Роганов

Удобный быстрый поиск

Если вы при случайном нажатии вводите что-нибудь в командную строку, то поставьте в пункте настроек Operation (Операции) в поле Quick search (Поиск в текущем каталоге) галку в чек боксе Letter Only (Только буква). В этом случае вы не сможете ввести в командную строку что-нибудь при случайном нажатии на клаву, а также поиск необходимого файла будет осуществляться намного удобнее.

Прислал Black Dog

Размер всех каталогов

Если вы разобрались с предыдущим советом, то попробуйте нажать Shift+Alt+Enter. Теперь вы увидите сколько места на диске занимают все подкаталоги в текущем каталоге (диске).

Прислал Ergo

Быстрый размер каталогов

А знали ли вы, что нажав на каталоге пробел, каталог будет выбран и будет показано сколько он занимает места. Однако если такую процедуру необходимо повторить для нескольких каталогов, то неудобно, что курсор остается на месте. Исправить это можно, добавив в wincmd.ini в разделе [Configuration] строку:
spacemovesdown=1
Теперь при нажатии пробела курсор будет спускаться на одну строку вниз

Прислал Ergo

Подсказки к дискам

При нажатии Alt+F1(F2) открывается окно выбора дисков. По умолчанию в качестве подсказок используются метки дисков. Однако это можно обойти. Особенно это удобно, если дисков очень много, локальных и сетевых. Для этого в wincmd.ini необходимо создать новый радел [DriveHints] и в нем определить подсказки для дисков, например:
[DriveHints]
A=Floppy Disk
C=System Disk
D=Data Disk
E=Media Disk

Прислал Ergo

Всегда копировать в фоне

Для того чтобы копирование всегда осуществлялось в фоне необходимо в wincmd.ini в разделе [Configuration] добавить строчку:
AlwaysCopyInBackground=1

Прислал Ergo

Просмотр заархивированных html-страничек

Если html-страничка находится в архиве, то для ее просмотра не обязательно предварительно распаковать все содержимое архива в отдельный каталог. Выберите любой html-документ и запустите его непосредственно из архива. Появится окно в котором Total Commander вам предложит Закрыть, Распаковать и выполнить и Распаковать и выполнить все. Выбирайте последний пункт и Total Commander распакует все содержимое во временный архив, а в вашем браузере откроется страница. Но что самое главное, все картинки и ссылки будут работающими! После завершения просмотра нажмите в Total Commander ОК, и все распакованные файлы из временного каталога будут удалены.

Прислал Ergo

Трюк при распаковке архива

Если вы вошли в архив и хотите его распаковать в этот же каталог (как в ДОС навигаторе по F4). Войдя в архив выделяете все нужные файлы для распаковки, жмете F5, потом в строке копирования (куда стоит распаковать - другая панель) просто убираете всю строку. Жмете Enter и файлы распакованы в текущей директории.

Прислал Serj

Убрать сплэш-окно при загрузке

При загрузке Total Commander на экране появляется сплэш-окно. Это не очень удобно, поскольку не только замедляет загрузку Total Commander, но и засоряет память вашего компьютера. Однако этот параметр можно отключить. Для этого в файле wincmd.ini в разделе [Configuration] необходимо создать параметр:
StartupScreen=0

Прислал Ergo

Стрелка вниз-вверх возвращает в файловую панель

Если вы добавите в файл wincmd.ini в раздел [Configuration] строку CmdUpDown=1, то теперь если вы находитесь в командной строке (по нажатию стрелке вправо-влево, например), нажав стрелку вверх-вниз вы возвращаясь обратно в файловую панель.

Прислал Ergo

Уберите командную строку

Только если вы работаете в разрешении более чем 1024х768 вы можете себе позволить располагать на экране лишние панели. Мой совет - отключите командную строку, она просто занимает драгоценное место. Даже если вы отключите ее, то все равно вы без проблем можете вызвать ее всего лишь нажав в файловых панелях стрелку вправо или влево, вновь убрать ее можно нажав ESC.

Прислал Ergo

Архивирование с параметрами

Когда вызываешь окно архивирования там есть строка типа: "rar:D:\Downloads\1\1.RAR". Чтобы запустить архивирование с параметрами, необходимо их вставить после "rar:" и ограничить пробелами. Идеология такова: надпись "rar:" заменяется при архивировании на полный путь к архиватору.
Пример: "rar: -m5 -md1024 D:\Downloads\1\1.RAR"
В данном примере будет произведена архивация rar c максимальным уровнем компрессии и размером словаря 1024Кб.

Прислал $corpio

Запуск Lister-а с определенным файлом

На панели инструментов, или в меню запуск можно создать ярлык, по нажатию которого будет открыт определенный файл во встроенном в Total Commander Lister-е. Для этого необходимо в командной строке написать:
cm_List [полный путь к файлу],
например: cm_List c:\wincmd\history.txt

Прислал Ergo

Два одинаковых каталога в панелях

CTRL+LeftArrow или CTRL+RightArrow позволяет быстро выставить два одинаковых каталога в панелях, или открыть в противоположной панели содержимое каталога, на котором находиться курсор.

Прислал Seregey Yudin

Как сделать самораспаковывающийся архив

В WinCommander'e легко можно сделать самораспаковывающийся архив: нажать Shift+F6 на zip-файле и переименовать расширение с zip на exe.

Прислал Nohcha

Установка размера блока при копирования

Для копирования блока заданным размером надо прописать в разделе [Configuration] CopyBlockSize=64. При копировании по сети лучше поставить 32, а при работе с диском - 128.

Прислал Михаил

Настройка Lister-а для просмотра файлов в KOI8

Используя Lister встроенный в Total Commander можно просматривать файлы в кодировке KOI8. Для этого необходимо предварительно ставим в систему коишный шрифт. Затем заходим в настройки Листера и в части настроек шрифта (3-й "отдел") для пользовательского шрифта задаем наш коишный шрифт из системы. Теперь по нажатию "V" будет включаться кодировка КОИ. Фишка может не пройти (буквы будут "глючные"), тогда нужно попробовать поставить другой коишный шрифт. У меня не сразу нашелся "правильный".

Прислал Alexey Panteleev

Конвертирование архивов

Total Commander можно использовать как конвертер архивов. Открываете архивец..допустим zip выделяем все файлы и папки, нажимаем Alt+F5 выбираем тип архиватора - OK - и в другой панели получаем архивец другого типа с аналогичным содержанием. Если поставить Plug "мультиарк", то можно поизвращаться с типами архивов....

Прислал Extreme

Конвертирование архивов

Многие знают, что нажав Alt+Down можно вызвать список последних посещенных директорий (историю), однако не все знают, как вызвать этот список с помощью мыши. Можно конечно же создать кнопку на панели инструментов для этой команды, но тогда будет открываться история только активной панели. Но можно это сделать и проще. Для этого необходимо нажать правой клавишей мыши по заголовку панели и не отпускать кнопку некоторое время. Если отпустить сразу же, то будет вызвано обыкновенное контекстное меню.

Прислал Ergo

Быстрое изменение ширины панелей

Щелкнув по разделяющей две файловые панели полосе правой кнопкой мыши, вы получите выпавшее меню с дробями вида 20/80, 30/70, 40/60 и т.д. Это ни что иное как процентные соотношения ширины левой/правой панели. Границу двух панелей можно и просто таскать мышью вручную,при этом WinCom показывает текущее положение границы (в процентах).

Прислал Rodocop

Total Commander и WinAmp

Оказывается если перетащить папку с mp3 файлами на значок WinAmp-а на панели кнопок то WinAmp будет проигрывать все поддерживаемые им форматы файлов находящиеся в этой папке. Это равносильно тому, что вызвать контекстное меню папки и выбрать "Play in WinAmp", но намного удобнее.

Прислал Ergo

FTP и "Фавориты"

Очень удобно работать с часто используемыми директориями - "фаворитами". Эта опция вызывается через даблклик на строке с полным адресом к директории или ctrl+D. Очень удобна эта опция при работе по фтп со сложным сайтом. Можно группировать директории в отдельные разделы (например для каждого своего проекта), но что мне больше всего нравится - это возможность привязки к определенной папки в списке другой папки, которая автоматом открывается в другой панели. Очень удобно при необходимости быстро переходить между папками на сайте для заливки обновлений. В настройках "фаворитов" это делается довольно легко. Также очень часто использую опцию "Сравнить директории" - сразу видно какие новые файлы не залиты на фтп. Причем все новые файлы сразу выделяются для копирования - просто драг энд дроп :) Все эти возможности мне прекрасно помогли в процессе работе над такими разветвленными проектами как www.nasmnogo.ru и www.e95.ru. Мое глубокое убеждение, что WinComm - лучший файл-менеджер.

Прислал Игорь

Выделение файлов с расширением

Часто бывает необходимо выделить в директории все файлы с каким-нибудь расширением, или наоборот - снять выделение с определенного типа файлов. Для этого необходимо выделить один из файлов нужного типа и нажать: Alt + Grey "+" (на Keypad-e) для выделения и Alt + Grey "-" для снятия выделения.

Прислал Роман Боярчук

Еще один способ очистки корзины

Если на кнопке F8 Удалить нажать правую кнопку мыши, то откроется контекстное меню как у корзины.

Прислал Andy Bitoff

Еще один способ создания самораспаковывающегося архива

Чтобы быстро создать ЕХЕ'шник с помощью RAR'а. Создаем новую кнопочку и в поле Команда вводим: C:\ARCHIVES\WINRAR\WinRAR.exe s понятно, что путь к rar'у у каждого свой. В поле Параметры: %1 И теперь если перетащить любой архив на эту кнопку, в той же директории появится ЕХЕ'шник с тем же именем.

Прислал Andy Bitoff

Вездесущий Shift

А вы в курсе, что если перетаскивать файлы или папки мышкой с одной панели на другую и удерживая shift, вы переносите их.

Прислал Шурик

Еще один способ вызова контекстного меню

А вы наверное и не знали, что при нажатии комбинации shift-F9 выпадает контекстное меню, такое же, как и при нажатии правой кнопкой мыши.

Прислал Шурик

Удалять всегда в фоне

Говоря про фон,стоит заметить,что кроме того,что вы можете всегда копировать в фоне,еще стоит добавить в wincmd.ini в раздел [Configuration] строку AlwaysRemoveInBackground=1 для постоянного перемещения(F6)в фоне.Строку AlwaysDeleteInBackground не добавляйте,не поможет(я уже проверял:-)).

Прислал Deimos

Быстрый просмотр по Ctrl+Q рулит!

Если вы просматриваете содержимое файлов в режиме быстрого просмотра (Ctrl+Q), то независимо от того какая из панелей Total Commander активна клавиша N и P могут быть использованы для передвижения к следующему/предыдущему файлу.

Прислал Ergo

Total Commander как антивирусный сканер

Многие используют Total Commander не только как файл менеджер, но и как архиватор, проигрыватель различных файлов и т.д. Я предлагаю еще использовать его как антивирусный сканер! Если у вас установлен AVP монитор, то при поиске в каталоге файла (в архиве галка стоит), а лучше и фразы в этом файле происходит полная проверка на вирус всех файлов и архивов к которым обращается Wincmd. Очень удобно, быстрей чем запускать AVP Scaner и указывать этот каталог. Да можно и по контекстному меню запускать так. Но с помощью шаблона в меню поиска можно конкретно проверять только те файлы которые хочешь. Пример: только файлы за сегодня или за 10 дней, ну о типах даже и не говорим. Возможности WC в этом не ограничены! Попробуй это быстро сделать в AVP-scaner! Вот в чем фишка.

Прислал Михаил

Много интересных функций

Очень много интересных функций можно получить, создавая новые кнопки на панели кнопок (button bar) Для этого надо щелкнуть правой кнопкой мыши на этой панели, сказать Change и создать новую кнопку (Append). В строке Command можно из выпадающего списка выбрать одну из множества команд - среди них попадаются очень полезные.

Прислал Rodocop

Больше файлов на панели

Как известно, не у всех мониторы 17 дюймов и без ущерба для глаз держат расширение 1024х768. Возможно вам захочется чтобы в файловых панелях Total Commander одновременно без прокрутки показывалось больше файлов. Для этого необходимо зайти в Настройки - Шрифт и в маленьком непримечательном окошке выбрать размер значков. Можно установить размер значков или 32х32 или 16х16, но не все знают, что можно поставить любой другой размер иконок - 14х14, 50х50, 10х10, какой кому больше нравится

Свернуть Total Commander

Нажав Shift+Esc, можно быстро свернуть окно винкоммандера

Прислал Stas

Не закрывать окно эмуляции

Запуск ms-dos программы без последующего закрытия окна. Обычно после выполнения ms-dos программы она закрывается сама собой, и не видно результатов выполнения. Для того чтобы этого избежать необходимо вместо Enter'а нажать Shift+Enter. Проходит этот способ и из командной строки.

Прислал Max

Несколько вьюверов и редакторов

Очень удобно пользоваться несколькими различными вьюверами или редакторами (проходит так же и с архиваторами) если в панели инструментов для выбранной кнопки (например BRED 2, если он не установлен в качестве редактора по умолчанию)в строке параметры прописать %n. В этом случае при клике на указанной кнопке в окне редактора будет сразу появляться файл на котором установлен курсор.

Прислал VAN

Примечание: А можно это же самое сделать просто перетащив необходимый вам файл на созданную иконку для этого редактора или просмотрщика. Таким образом вы можете легко открывать один и тот же файл в любом количестве текстовых (графических, музыкальных и т.д.) редакторов или в любой другой программе.

Запуск программ из меню часто используемых каталогов

Все уже знают о комбинации Ctrl+D, но возможно не все знают, что кроме каталогов для быстрого перехода к ним можно закидывать и запуск определенных программ. Для этого нажмите Ctrl+D, затем [Configure] затем [Add Item] запишите название, [OK], теперь запишите в поле [Command] имя файла (если надо то и ключи к нему), а в поле [Target Path] - путь к файлу. Таким образом я экономлю на меню "Пуск", так как постоянно нахожусь в WC :) И не забывайте о создании подменю...

Прислал EX

Еще один способ сэкономить место на экране монитора

А что делает у вас на экране панель дисков. Ведь можно всегда поменять диски используя Alt+F1 и Alt+F2. А если с помощью мышки? Есть и для этого выход. Поместите все ваши диски в меню часто используемых каталогов (Ctrl+D) и тогда вы всегда сможете добраться до них через двойной щелчок мышкой по заголовку панели. А начиная с Windows Commander 4.54 можно на панели инструментов (панель кнопок) создать кнопку, которая будет вызывать меню выбора дисков аналогичное тому, которое вызывается по Alt+F1 и Alt+F2. Для этого необходимо использовать команды cm_SrcOpenDrives (для текущей файловой панели), cm_LeftOpenDrives (для левой файловой панели), cm_RightOpenDrives (для правой файловой панели). Этим вы сэкономите место у вас на мониторе.

Еще один способ открыть рабочий стол

Наберите в командной строке \\ и нажмите Ввод и вы откроете Рабочий стол (Только в Windows Commander 4.54 и старше)

Быстрый поиск по расширению

А знаете ли вы, что можно осуществлять быстрый поиск в текущей директории по расширению? Для этого необходимо нажать сначала точку, а потом и первые буквы расширения. Например ".t" переместит курсор на первый файл имеющий расширение, которое начинается на t. Если у вас отключено окно диалога при быстром поиске, то необходимо набирать очень быстро.

Ctrl-PgDn и Ctrl-PgUp на службе юзабилити

Ctrl-PgDn, Ctrl-PgUp - Весьма удобная и полезная комбинация клавиш, в свое время придуманная в NC Петей Нортоном и перекрчевавшая в WC. Служит для перехода на 1 уровень в старшую / младшую директорию.Нам Они могут оказать неоценимую помощь, кода надо заглянуть в старшую / младшую директорию и не активировать случайным нажатием Enter порой с таким трудом составленную командную строку.

Прислал Александр Вычугжанин

Еще раз про экономию

У меня куча иконок на панели инструментов, и при их добавлении они начали строиться в 2 ряда, занимая место на экране. Мне это ОЧЕНЬ не понравилось. И я нашел где надо подправить это дело... Нажимаете правой кнопкой мыши на свободном пространастве панели инструментов и выбираете "Изменить". В открывшемся диалоге в правом верхнем углу есть окошко размера кнопок. Ставьте любое число. P.S. не советую ставить число меньше 10 , плохо будет видно, хота кому как...

Прислал yurik

Удаляем минуя корзину

Для удаления файла, файлов или директорий минуя корзину используйте аккорд Shift+Del

Прислал SpaceR

И снова о клавише Shift!

Можно воспользоваться комбинацией клавиш Shif+F10 для вызова контекстного меню по любому из файлов или каталогов текущего рабочего окна WinCommander'a

Прислал Aleks

Решение вопросов

Если вам хочется реализовать что-то с помощью Total Commander, или у вас просто появился вопрос связанный с использованием Total Commander, то лучше всего задать его прямо на нашем форуме. Практика свидетельствует о том, что ответы как правило находятся.

Управление CD дисками

В wincmd.ini в разделе [Configuration] добавить строчку:
DriveisCD=FGH
Этот параметр пределяет диски F, G и H как CD. Это важно при копировании с этих дисководов, Wincmd не скопирует атрибут "Только для чтения". Особенно полезна эта функция Total Commander’a для сетевых дисководов CD, которые не обнаруживаются автоматически.

Прислал Aleks

Приемы копирования файлов более 10 MB

Для некоторого ускорения копирования файлов больших размеров (более 10 MB) в Total Commander предусмотрена возможность чтения и записи файлов непосредственно минуя (шунтирование) кеш-память диска. Для включения данной функции необходимо в wincmd.ini в разделе [Configuration] добавить строчку:
CopyHugeBlockSize=
Минимальный размер является 10MB. Только файлы большие чем этот блочный размер будет скопирован таким образом. Для меньших файлов по размеру (т.е. менее 10 MB), будет использована функция из раздела [Configuration] CopyBlockSize= с параметрами

Прислал Aleks

Установка размера блока для больших файлов

В wincmd.ini в разделе [Configuration] добавить строчку:
CopyHugeBlockSizeOther=
Данная функция устанавливает размер блока при копировании очень больших (более 10MB) файлов, между другими дисками. Минимальный размер блока: 256 kB.
Рекомендуемые величины (попробуйте другие сами):
CopyBlockSize=1024
CopyHugeBlockSize=10240
CopyBlockSizeOther=128
CopyHugeBlockSizeOther=1024

Прислал Aleks

О принадлежности логических дисков

Если у Вас на машине установлено несколько harddisk (винчестер), то функция в разделе [Configuration] файла wincmd.ini
SamePartitions=drives,drives
Позволяет устанавливать, какие логические диски (разделы) принадлежат тому же harddisk. Пример: У вас есть два harddisks, один с логическими дисками C,E и F, и другой с D, G и H. Тогда должна быть В wincmd.ini в разделе [Configuration] строчка:
SamePartitions=CEF,DGH
Тогда копирование (или перемещение) между E и F (один физический диск) сначала будет использоваться одни величины размеров блоков , а копируя между C и D (два физических диска) будут использованы другие величины размеров блоков. Что естественно ускоряет вашу работу при копировании или перемещении файлови папок (каталогов).

Прислал Aleks

Каждому аккаунту свой профиль

При работе в НТ/2000 можно сделать каждому аккаунту свой профиль. В каталоге winnt\profiles\all users\desktop\ создается ярлык, запускающий WC с ключом i: wincmd32 /i=%UserProfile%\wincmd.ini
Теперь у каждого пользователя своя настройка WC.

Прислал Sergius

А-ля проводник

В Total Commander'е легко организовать функции вырезать, копировать в буфер и вставить из буфера. Для этого нажмите правой кнопкой мыши на панели инструментов, выберите Изменить... (Change...). Теперь нажмите кнопку Добавить (Append), в выпадающем списке Команда (Command) выберите для функции вырезать команду cm_CutToClipboard, для копирования cm_CopyToClipboard, для вставки из буфера cm_PasteFromClipboard. Установите по желанию значки и пояснения для этих команд. Теперь вы можете выделив группу файлов в одной папке - скопировать в буфер, а в другой папке - вставить. Т.е. получаете такие же функции, как и в Проводнике. Примечание 1. Нажимайте кнопку Добавить (Append) для каждой из функций. Примечание 2. Эти функции не будут работать в Windows 3.xx.

Прислал Сергей

Показать-спрятать скрытые файлы

Для того, чтобы показать/спрятать скрытые и системные файлы необязательно пользоваться меню. Можно сделать проще. Для этого в меню Конфигурация (Configuration)|Настройка...(Options...) щелкните на вкладке Общие (Misc.)|Переопределить горячие клавиши (Redefine hotkeys) выберите сочетание клавиш, например [Ctrl]+[H], в выпадающем списке Команда (Command) выберите cm_SwitchHidSys и нажмите галочку. Теперь нажимая эту комбинацию клавиш вы можете показать скрытые файлы, а повторно нажав скрыть их.

Прислал Сергей

Расширенный поиск

Предположим, что вы работаете над определенной проблемой, ключевым словом которой явлется слово "слово". Теперь откройте инструмент поиска Alt+F7 и введите в строке поиска "слово" без кавычек. Теперь откройте закладку "Загрузить/Сохранить" и сохраните условия поиска. Теперь в одной из файловых панелей нажмите Ctrl+F12 и выберите только что сохраненное условие поиска. Теперь куда бы вы переходили, в этой файловой панели будут отображаться только те файлы, которые содеражат слово "слово". Чтобы вновь отображались все файлы используйте комбинацию Ctrl+F10. Подробнее про расширенный поиск читайте здесь.

Прислал Ergo

Исполняемые файлы

Нажмите Ctrl+F11 и вы увидите только исполняемые файлы (*.COM;*.BAT;*.EXE;*.PIF;*.CMD) в текущем каталоге (очень удобно, если надо быстро найти программу среди множества файлов). Ctrl+F10 возвращает обратно в режим просмотра всех файлов.

Прислал Ergo

История посещений папок (каталогов) активного окна

Для просмотра истории посещения папок (каталогов) активного окна Total Commander’a удобно воспользоваться комбинаций клавиш Alt+ CURSORDOWN (стрелка вниз клавиши управления курсором)

Прислал Aleks

Расширенный просмотр каталога

Для того чтобы увидеть все файлы в текущем каталоге и во всех его подкаталогах одним списком необходимо установить курсор на выбранный каталог и нажать комбинацию клавиш Ctrl+B

Прислал Aleks

Просмотр списка последних команд командной строки

Чтобы открыть список последних команд (WinCom в буфере их запоминает 20) необходимо удерживая клавишу CTRL сделать короткое нажатие на клавишу CURSORDOWN (вниз) или CURSORUP (вверх). Откроется окно со списком последних 5 команд командной строки Total Commander’a. Затем, используя клавиши вверх и вниз, можно выбрать команду из предложенных 5 или всех 20 команд. После выбора команды, нажимая клавиши влево/вправо, вы можете, при необходимости отредактировать командную строку. При этом автоматически закроется список всех команд, кроме выбранной.

Прислал Aleks

Полный путь к файлу в командной строке

Все наверное знают, что имя файла под курсором в активном окне WinCom’a можно добавить (перенести) в командную строку нажатием комбинации клавиш CTRL+ENTER. Но не все знают, что комбинация клавиш CTRL+SHIFT+ENTER добавляет (переносит) имя файл под курсором в командную строку, включая полный путь (т.е. имя диска, папки (каталога), всех подкаталогов) к выбранному файлу.

Прислал Aleks

Еще об окне эмуляции DOS

При запуске MS-DOS программы из командной строки Total Commander’a окно эмуляции по завершении работы программы закрывается само собой. Естественно пользователь не видит результатов работы. Для того чтобы этого избежать, необходимо вместо ENTER нажать Shift+Enter. Но есть одна маленькая неприятность! Это работает только в том случае, когда в каталоге Windows находится файл NOCLOSE.PIF! А иначе, увы…

Прислал Aleks

Быстрое сканирование папок (каталогов)

Нажатие комбинации клавиш ALT+SHIFT+ENTER приводит к тому, что сканируется содержимое всех папок (каталогов) с подкаталогами в текущем (активном) окне WinCom’a, и показываются их размеры на месте <DIR>. У папки (каталога) не содержащего файлов (пустые папки) остается <DIR>. Однако чтобы данная команда правильно отработала, необходимо активное окно WC привести к виду "Подробный" (комбинация CTRL+F2 или в МЕНЮ выбрать "Вид" - "Подробный"

Прислал Aleks

SHIFT+ F8 удаляет файл минуя корзину

Используя комбинацию из клавиш SHIFT+F8 Total Commander удаляет файл или папку целиком без сохранения копии для восстановления в корзине. Вы также можете достичь этого эффекта когда нажимаете SHIFT и бросаете файл на кнопку F8 панели функциональных клавиш. Предупреждение: Восстановить удаленный файл ни какими средствами уже не возможно! Пользуйтесь осторожно…!

Прислал Aleks

Новый пункт "ДИСКИ" в МЕНЮ Total Commander’a

В версии 4.54 Total Commander’a имеется возможность в МЕНЮ добавить новый пункт "ДИСКИ". Для этого в текстовый файл Wcmd_rus.mnu (размещается в каталоге Wincmd\Language) после раздела меню "ФАЙЛ" поместить раздел "ДИСКИ", который имеет следующее содержание:

POPUP "&Диски"

MENUITEM "&Рабочее окно...", cm_SrcOpenDrives

MENUITEM "&Левое окно\tALT+F1...", cm_LeftOpenDrives

MENUITEM "&Правое окно\tALT+F2...", cm_RightOpenDrives

END_POPUP

Сохранить файл Wcmd_rus.mnu, закрыть, а затем вновь запустить менеджер Total Commander. В Главном МЕНЮ будет добавлен новый пункт "ДИСКИ". Теперь смело можно убрать "Кнопки дисков" и "Окно выбора дисков" с рабочей панели WC, и как результат увеличится место для размещения большего числа папок и файлов на рабочих панелях.

Прислал Aleks

По поводу экономии

По поводу экономии, стоит ли мельчить с размером кнопок? Ведь проше создать новую панель кнопок (у меня их 5) и помещать на них кнопки по типу задач. 1-я панель - часто используемые проги, 2-я панель - утилиты ... Чтобы создать панель кликни правой кнопкой на свободном месте панели - изменить - новая панель, назови как хочеш и пользуйся

Прислал Serg

О выделении файлов и папок на панели WC

Используя комбинацию клавиш Shift+UP ИЛИ Shift+Down ВЫДЕЛЯЕМ файлы или папки в рабочем окне WinCom'a ОТ текущей позиции курсора до конца просматриваемой страницы в окна (вверх или вниз). А используя комбинацию Shift+End ИЛИ Shift+Home ВЫДЕЛЯЕМ все файлы или папки в рабочем окне WinCom'a от текущей позиции курсора до конца или начала страницы вообще. Попробуйте.

Прислал Aleks

Учите горячие комбинации

Alt+Enter - горячая комбинация на свойства файла.

Прислал benadin

Учите горячие комбинации

Если по дир-рии нажать ctrl+enter, а потом enter - то она откроется проводником; Если по архиву - то он откроется соотв. зарегестрированной за ним программой.

Прислал benadin

Что умеет панель инструментов

  • Если перетащить любой файл на иконку The Bat! на панели инструментов, то будет создано новое письмо со вложенным этим файлом.
  • Если перетащить любой файл на кнопку Lister-а (cm_List), то это равносильно F3 (бывает ведь не охота тянуться к клавиатуре).
  • Если перетащить любой файл или папку на кнопку Удаления (ее естественно предварительно необходимо создать - cm_Delete), то это равносильно Del\F8
  • Если на панели инструментов создать

Отредактировано SHULC SOFT.


Total Commander - Total Commander: Крутые советы-2

Начальная Download Плагины Текстовые редакторы Иконки FAQ (New!!!) Статьи (New!!!) Крутые советы Ссылки Партнеры Эхоконференция WinCE/PocketPC Разработчику Гостевая книга

Друзья

Крутые советы-2

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Убрать квадратные скобки!

Чтобы директории на панелях показывались не в скобках, нужно добавить в wincmd.ini в разделе [Configuration] строчку:
DirBrackets=0

Прислал Константин Роганов

Удобный быстрый поиск

Если вы при случайном нажатии вводите что-нибудь в командную строку, то поставьте в пункте настроек Operation (Операции) в поле Quick search (Поиск в текущем каталоге) галку в чек боксе Letter Only (Только буква). В этом случае вы не сможете ввести в командную строку что-нибудь при случайном нажатии на клаву, а также поиск необходимого файла будет осуществляться намного удобнее.

Прислал Black Dog

Размер всех каталогов

Если вы разобрались с предыдущим советом, то попробуйте нажать Shift+Alt+Enter. Теперь вы увидите сколько места на диске занимают все подкаталоги в текущем каталоге (диске).

Прислал Ergo

Быстрый размер каталогов

А знали ли вы, что нажав на каталоге пробел, каталог будет выбран и будет показано сколько он занимает места. Однако если такую процедуру необходимо повторить для нескольких каталогов, то неудобно, что курсор остается на месте. Исправить это можно, добавив в wincmd.ini в разделе [Configuration] строку:
spacemovesdown=1
Теперь при нажатии пробела курсор будет спускаться на одну строку вниз

Прислал Ergo

Подсказки к дискам

При нажатии Alt+F1(F2) открывается окно выбора дисков. По умолчанию в качестве подсказок используются метки дисков. Однако это можно обойти. Особенно это удобно, если дисков очень много, локальных и сетевых. Для этого в wincmd.ini необходимо создать новый радел [DriveHints] и в нем определить подсказки для дисков, например:
[DriveHints]
A=Floppy Disk
C=System Disk
D=Data Disk
E=Media Disk

Прислал Ergo

Всегда копировать в фоне

Для того чтобы копирование всегда осуществлялось в фоне необходимо в wincmd.ini в разделе [Configuration] добавить строчку:
AlwaysCopyInBackground=1

Прислал Ergo

Просмотр заархивированных html-страничек

Если html-страничка находится в архиве, то для ее просмотра не обязательно предварительно распаковать все содержимое архива в отдельный каталог. Выберите любой html-документ и запустите его непосредственно из архива. Появится окно в котором Total Commander вам предложит Закрыть, Распаковать и выполнить и Распаковать и выполнить все. Выбирайте последний пункт и Total Commander распакует все содержимое во временный архив, а в вашем браузере откроется страница. Но что самое главное, все картинки и ссылки будут работающими! После завершения просмотра нажмите в Total Commander ОК, и все распакованные файлы из временного каталога будут удалены.

Прислал Ergo

Трюк при распаковке архива

Если вы вошли в архив и хотите его распаковать в этот же каталог (как в ДОС навигаторе по F4). Войдя в архив выделяете все нужные файлы для распаковки, жмете F5, потом в строке копирования (куда стоит распаковать - другая панель) просто убираете всю строку. Жмете Enter и файлы распакованы в текущей директории.

Прислал Serj

Убрать сплэш-окно при загрузке

При загрузке Total Commander на экране появляется сплэш-окно. Это не очень удобно, поскольку не только замедляет загрузку Total Commander, но и засоряет память вашего компьютера. Однако этот параметр можно отключить. Для этого в файле wincmd.ini в разделе [Configuration] необходимо создать параметр:
StartupScreen=0

Прислал Ergo

Стрелка вниз-вверх возвращает в файловую панель

Если вы добавите в файл wincmd.ini в раздел [Configuration] строку CmdUpDown=1, то теперь если вы находитесь в командной строке (по нажатию стрелке вправо-влево, например), нажав стрелку вверх-вниз вы возвращаясь обратно в файловую панель.

Прислал Ergo

Рейтинг

Japan Used Cars
Used Car Pricing

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Реклама на сайте

Все о Total Commander © 2001-2003
Идея, программирование, дизайн и поддержка, © Андрей Пясецкий
JPartner Ltd.


Total Commander - Total Commander: Крутые советы-3

Крутые советы-3

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Уберите командную строку

Только если вы работаете в разрешении более чем 1024х768 вы можете себе позволить располагать на экране лишние панели. Мой совет - отключите командную строку, она просто занимает драгоценное место. Даже если вы отключите ее, то все равно вы без проблем можете вызвать ее всего лишь нажав в файловых панелях стрелку вправо или влево, вновь убрать ее можно нажав ESC.

Прислал Ergo

Архивирование с параметрами

Когда вызываешь окно архивирования там есть строка типа: "rar:D:\Downloads\1\1.RAR". Чтобы запустить архивирование с параметрами, необходимо их вставить после "rar:" и ограничить пробелами. Идеология такова: надпись "rar:" заменяется при архивировании на полный путь к архиватору.
Пример: "rar: -m5 -md1024 D:\Downloads\1\1.RAR"
В данном примере будет произведена архивация rar c максимальным уровнем компрессии и размером словаря 1024Кб.

Прислал $corpio

Запуск Lister-а с определенным файлом

На панели инструментов, или в меню запуск можно создать ярлык, по нажатию которого будет открыт определенный файл во встроенном в Total Commander Lister-е. Для этого необходимо в командной строке написать:
cm_List [полный путь к файлу],
например: cm_List c:\wincmd\history.txt

Прислал Ergo

Два одинаковых каталога в панелях

CTRL+LeftArrow или CTRL+RightArrow позволяет быстро выставить два одинаковых каталога в панелях, или открыть в противоположной панели содержимое каталога, на котором находиться курсор.

Прислал Seregey Yudin

Как сделать самораспаковывающийся архив

В WinCommander'e легко можно сделать самораспаковывающийся архив: нажать Shift+F6 на zip-файле и переименовать расширение с zip на exe.

Прислал Nohcha

Установка размера блока при копирования

Для копирования блока заданным размером надо прописать в разделе [Configuration] CopyBlockSize=64. При копировании по сети лучше поставить 32, а при работе с диском - 128.

Прислал Михаил

Настройка Lister-а для просмотра файлов в KOI8

Используя Lister встроенный в Total Commander можно просматривать файлы в кодировке KOI8. Для этого необходимо предварительно ставим в систему коишный шрифт. Затем заходим в настройки Листера и в части настроек шрифта (3-й "отдел") для пользовательского шрифта задаем наш коишный шрифт из системы. Теперь по нажатию "V" будет включаться кодировка КОИ. Фишка может не пройти (буквы будут "глючные"), тогда нужно попробовать поставить другой коишный шрифт. У меня не сразу нашелся "правильный".

Прислал Alexey Panteleev

Конвертирование архивов

Total Commander можно использовать как конвертер архивов. Открываете архивец..допустим zip выделяем все файлы и папки, нажимаем Alt+F5 выбираем тип архиватора - OK - и в другой панели получаем архивец другого типа с аналогичным содержанием. Если поставить Plug "мультиарк", то можно поизвращаться с типами архивов....

Прислал Extreme

Конвертирование архивов

Многие знают, что нажав Alt+Down можно вызвать список последних посещенных директорий (историю), однако не все знают, как вызвать этот список с помощью мыши. Можно конечно же создать кнопку на панели инструментов для этой команды, но тогда будет открываться история только активной панели. Но можно это сделать и проще. Для этого необходимо нажать правой клавишей мыши по заголовку панели и не отпускать кнопку некоторое время. Если отпустить сразу же, то будет вызвано обыкновенное контекстное меню.

Прислал Ergo

Быстрое изменение ширины панелей

Щелкнув по разделяющей две файловые панели полосе правой кнопкой мыши, вы получите выпавшее меню с дробями вида 20/80, 30/70, 40/60 и т.д. Это ни что иное как процентные соотношения ширины левой/правой панели. Границу двух панелей можно и просто таскать мышью вручную,при этом WinCom показывает текущее положение границы (в процентах).

Прислал Rodocop

Рейтинг

Japan Used Cars
Used Car Pricing

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Реклама на сайте

Все о Total Commander © 2001-2003
Идея, программирование, дизайн и поддержка, © Андрей Пясецкий


Total Commander - Total Commander: Крутые советы-4

Крутые советы-4

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Total Commander и WinAmp

Оказывается если перетащить папку с mp3 файлами на значок WinAmp-а на панели кнопок то WinAmp будет проигрывать все поддерживаемые им форматы файлов находящиеся в этой папке. Это равносильно тому, что вызвать контекстное меню папки и выбрать "Play in WinAmp", но намного удобнее.

Прислал Ergo

FTP и "Фавориты"

Очень удобно работать с часто используемыми директориями - "фаворитами". Эта опция вызывается через даблклик на строке с полным адресом к директории или ctrl+D. Очень удобна эта опция при работе по фтп со сложным сайтом. Можно группировать директории в отдельные разделы (например для каждого своего проекта), но что мне больше всего нравится - это возможность привязки к определенной папки в списке другой папки, которая автоматом открывается в другой панели. Очень удобно при необходимости быстро переходить между папками на сайте для заливки обновлений. В настройках "фаворитов" это делается довольно легко. Также очень часто использую опцию "Сравнить директории" - сразу видно какие новые файлы не залиты на фтп. Причем все новые файлы сразу выделяются для копирования - просто драг энд дроп :) Все эти возможности мне прекрасно помогли в процессе работе над такими разветвленными проектами как www.nasmnogo.ru и www.e95.ru. Мое глубокое убеждение, что WinComm - лучший файл-менеджер.

Прислал Игорь

Выделение файлов с расширением

Часто бывает необходимо выделить в директории все файлы с каким-нибудь расширением, или наоборот - снять выделение с определенного типа файлов. Для этого необходимо выделить один из файлов нужного типа и нажать: Alt + Grey "+" (на Keypad-e) для выделения и Alt + Grey "-" для снятия выделения.

Прислал Роман Боярчук

Еще один способ очистки корзины

Если на кнопке F8 Удалить нажать правую кнопку мыши, то откроется контекстное меню как у корзины.

Прислал Andy Bitoff

Еще один способ создания самораспаковывающегося архива

Чтобы быстро создать ЕХЕ'шник с помощью RAR'а. Создаем новую кнопочку и в поле Команда вводим: C:\ARCHIVES\WINRAR\WinRAR.exe s понятно, что путь к rar'у у каждого свой. В поле Параметры: %1 И теперь если перетащить любой архив на эту кнопку, в той же директории появится ЕХЕ'шник с тем же именем.

Прислал Andy Bitoff

Вездесущий Shift

А вы в курсе, что если перетаскивать файлы или папки мышкой с одной панели на другую и удерживая shift, вы переносите их.

Прислал Шурик

Еще один способ вызова контекстного меню

А вы наверное и не знали, что при нажатии комбинации shift-F9 выпадает контекстное меню, такое же, как и при нажатии правой кнопкой мыши.

Прислал Шурик

Удалять всегда в фоне

Говоря про фон,стоит заметить,что кроме того,что вы можете всегда копировать в фоне,еще стоит добавить в wincmd.ini в раздел [Configuration] строку AlwaysRemoveInBackground=1 для постоянного перемещения(F6)в фоне.Строку AlwaysDeleteInBackground не добавляйте,не поможет(я уже проверял:-)).

Прислал Deimos

Быстрый просмотр по Ctrl+Q рулит!

Если вы просматриваете содержимое файлов в режиме быстрого просмотра (Ctrl+Q), то независимо от того какая из панелей Total Commander активна клавиша N и P могут быть использованы для передвижения к следующему/предыдущему файлу.

Прислал Ergo

Total Commander как антивирусный сканер

Многие используют Total Commander не только как файл менеджер, но и как архиватор, проигрыватель различных файлов и т.д. Я предлагаю еще использовать его как антивирусный сканер! Если у вас установлен AVP монитор, то при поиске в каталоге файла (в архиве галка стоит), а лучше и фразы в этом файле происходит полная проверка на вирус всех файлов и архивов к которым обращается Wincmd. Очень удобно, быстрей чем запускать AVP Scaner и указывать этот каталог. Да можно и по контекстному меню запускать так. Но с помощью шаблона в меню поиска можно конкретно проверять только те файлы которые хочешь. Пример: только файлы за сегодня или за 10 дней, ну о типах даже и не говорим. Возможности WC в этом не ограничены! Попробуй это быстро сделать в AVP-scaner! Вот в чем фишка.

Прислал Михаил

Рейтинг

Japan Used Cars
Used Car Pricing

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Реклама на сайте

Все о Total Commander © 2001-2003
Идея, программирование, дизайн и поддержка, © Андрей Пясецкий


Total Commander - Total Commander: Крутые советы-5

Крутые советы-5

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Много интересных функций

Очень много интересных функций можно получить, создавая новые кнопки на панели кнопок (button bar) Для этого надо щелкнуть правой кнопкой мыши на этой панели, сказать Change и создать новую кнопку (Append). В строке Command можно из выпадающего списка выбрать одну из множества команд - среди них попадаются очень полезные.

Прислал Rodocop

Больше файлов на панели

Как известно, не у всех мониторы 17 дюймов и без ущерба для глаз держат расширение 1024х768. Возможно вам захочется чтобы в файловых панелях Total Commander одновременно без прокрутки показывалось больше файлов. Для этого необходимо зайти в Настройки - Шрифт и в маленьком непримечательном окошке выбрать размер значков. Можно установить размер значков или 32х32 или 16х16, но не все знают, что можно поставить любой другой размер иконок - 14х14, 50х50, 10х10, какой кому больше нравится

Свернуть Total Commander

Нажав Shift+Esc, можно быстро свернуть окно винкоммандера

Прислал Stas

Не закрывать окно эмуляции

Запуск ms-dos программы без последующего закрытия окна. Обычно после выполнения ms-dos программы она закрывается сама собой, и не видно результатов выполнения. Для того чтобы этого избежать необходимо вместо Enter'а нажать Shift+Enter. Проходит этот способ и из командной строки.

Прислал Max

Несколько вьюверов и редакторов

Очень удобно пользоваться несколькими различными вьюверами или редакторами (проходит так же и с архиваторами) если в панели инструментов для выбранной кнопки (например BRED 2, если он не установлен в качестве редактора по умолчанию)в строке параметры прописать %n. В этом случае при клике на указанной кнопке в окне редактора будет сразу появляться файл на котором установлен курсор.

Прислал VAN

Примечание: А можно это же самое сделать просто перетащив необходимый вам файл на созданную иконку для этого редактора или просмотрщика. Таким образом вы можете легко открывать один и тот же файл в любом количестве текстовых (графических, музыкальных и т.д.) редакторов или в любой другой программе.

Запуск программ из меню часто используемых каталогов

Все уже знают о комбинации Ctrl+D, но возможно не все знают, что кроме каталогов для быстрого перехода к ним можно закидывать и запуск определенных программ. Для этого нажмите Ctrl+D, затем [Configure] затем [Add Item] запишите название, [OK], теперь запишите в поле [Command] имя файла (если надо то и ключи к нему), а в поле [Target Path] - путь к файлу. Таким образом я экономлю на меню "Пуск", так как постоянно нахожусь в WC :) И не забывайте о создании подменю...

Прислал EX

Еще один способ сэкономить место на экране монитора

А что делает у вас на экране панель дисков. Ведь можно всегда поменять диски используя Alt+F1 и Alt+F2. А если с помощью мышки? Есть и для этого выход. Поместите все ваши диски в меню часто используемых каталогов (Ctrl+D) и тогда вы всегда сможете добраться до них через двойной щелчок мышкой по заголовку панели. А начиная с Windows Commander 4.54 можно на панели инструментов (панель кнопок) создать кнопку, которая будет вызывать меню выбора дисков аналогичное тому, которое вызывается по Alt+F1 и Alt+F2. Для этого необходимо использовать команды cm_SrcOpenDrives (для текущей файловой панели), cm_LeftOpenDrives (для левой файловой панели), cm_RightOpenDrives (для правой файловой панели). Этим вы сэкономите место у вас на мониторе.

Еще один способ открыть рабочий стол

Наберите в командной строке \\ и нажмите Ввод и вы откроете Рабочий стол (Только в Windows Commander 4.54 и старше)

Быстрый поиск по расширению

А знаете ли вы, что можно осуществлять быстрый поиск в текущей директории по расширению? Для этого необходимо нажать сначала точку, а потом и первые буквы расширения. Например ".t" переместит курсор на первый файл имеющий расширение, которое начинается на t. Если у вас отключено окно диалога при быстром поиске, то необходимо набирать очень быстро.

Рейтинг

Japan Used Cars
Used Car Pricing

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Реклама на сайте

Все о Total Commander © 2001-2003
Идея, программирование, дизайн и поддержка, © Андрей Пясецкий


Total Commander - Total Commander: Крутые советы-6

Крутые советы-6

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Ctrl-PgDn и Ctrl-PgUp на службе юзабилити

Ctrl-PgDn, Ctrl-PgUp - Весьма удобная и полезная комбинация клавиш, в свое время придуманная в NC Петей Нортоном и перекрчевавшая в WC. Служит для перехода на 1 уровень в старшую / младшую директорию.Нам Они могут оказать неоценимую помощь, кода надо заглянуть в старшую / младшую директорию и не активировать случайным нажатием Enter порой с таким трудом составленную командную строку.

Прислал Александр Вычугжанин

Еще раз про экономию

У меня куча иконок на панели инструментов, и при их добавлении они начали строиться в 2 ряда, занимая место на экране. Мне это ОЧЕНЬ не понравилось. И я нашел где надо подправить это дело... Нажимаете правой кнопкой мыши на свободном пространастве панели инструментов и выбираете "Изменить". В открывшемся диалоге в правом верхнем углу есть окошко размера кнопок. Ставьте любое число. P.S. не советую ставить число меньше 10 , плохо будет видно, хота кому как...

Прислал yurik

Удаляем минуя корзину

Для удаления файла, файлов или директорий минуя корзину используйте аккорд Shift+Del

Прислал SpaceR

И снова о клавише Shift!

Можно воспользоваться комбинацией клавиш Shif+F10 для вызова контекстного меню по любому из файлов или каталогов текущего рабочего окна WinCommander'a

Прислал Aleks

Решение вопросов

Если вам хочется реализовать что-то с помощью Total Commander, или у вас просто появился вопрос связанный с использованием Total Commander, то лучше всего задать его прямо на нашем форуме. Практика свидетельствует о том, что ответы как правило находятся.

Управление CD дисками

В wincmd.ini в разделе [Configuration] добавить строчку:
DriveisCD=FGH
Этот параметр пределяет диски F, G и H как CD. Это важно при копировании с этих дисководов, Wincmd не скопирует атрибут "Только для чтения". Особенно полезна эта функция Total Commander’a для сетевых дисководов CD, которые не обнаруживаются автоматически.

Прислал Aleks

Приемы копирования файлов более 10 MB

Для некоторого ускорения копирования файлов больших размеров (более 10 MB) в Total Commander предусмотрена возможность чтения и записи файлов непосредственно минуя (шунтирование) кеш-память диска. Для включения данной функции необходимо в wincmd.ini в разделе [Configuration] добавить строчку:
CopyHugeBlockSize=
Минимальный размер является 10MB. Только файлы большие чем этот блочный размер будет скопирован таким образом. Для меньших файлов по размеру (т.е. менее 10 MB), будет использована функция из раздела [Configuration] CopyBlockSize= с параметрами

Прислал Aleks

Установка размера блока для больших файлов

В wincmd.ini в разделе [Configuration] добавить строчку:
CopyHugeBlockSizeOther=
Данная функция устанавливает размер блока при копировании очень больших (более 10MB) файлов, между другими дисками. Минимальный размер блока: 256 kB.
Рекомендуемые величины (попробуйте другие сами):
CopyBlockSize=1024
CopyHugeBlockSize=10240
CopyBlockSizeOther=128
CopyHugeBlockSizeOther=1024

Прислал Aleks

О принадлежности логических дисков

Если у Вас на машине установлено несколько harddisk (винчестер), то функция в разделе [Configuration] файла wincmd.ini
SamePartitions=drives,drives
Позволяет устанавливать, какие логические диски (разделы) принадлежат тому же harddisk. Пример: У вас есть два harddisks, один с логическими дисками C,E и F, и другой с D, G и H. Тогда должна быть В wincmd.ini в разделе [Configuration] строчка:
SamePartitions=CEF,DGH
Тогда копирование (или перемещение) между E и F (один физический диск) сначала будет использоваться одни величины размеров блоков , а копируя между C и D (два физических диска) будут использованы другие величины размеров блоков. Что естественно ускоряет вашу работу при копировании или перемещении файлови папок (каталогов).

Прислал Aleks

Каждому аккаунту свой профиль

При работе в НТ/2000 можно сделать каждому аккаунту свой профиль. В каталоге winnt\profiles\all users\desktop\ создается ярлык, запускающий WC с ключом i: wincmd32 /i=%UserProfile%\wincmd.ini
Теперь у каждого пользователя своя настройка WC.

Прислал Sergius

Рейтинг

Japan Used Cars
Used Car Pricing

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Реклама на сайте

Все о Total Commander © 2001-2003
Идея, программирование, дизайн и поддержка, © Андрей Пясецкий


Total Commander - Total Commander: Крутые советы-7

Крутые советы-7

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

А-ля проводник

В Total Commander'е легко организовать функции вырезать, копировать в буфер и вставить из буфера. Для этого нажмите правой кнопкой мыши на панели инструментов, выберите Изменить... (Change...). Теперь нажмите кнопку Добавить (Append), в выпадающем списке Команда (Command) выберите для функции вырезать команду cm_CutToClipboard, для копирования cm_CopyToClipboard, для вставки из буфера cm_PasteFromClipboard. Установите по желанию значки и пояснения для этих команд. Теперь вы можете выделив группу файлов в одной папке - скопировать в буфер, а в другой папке - вставить. Т.е. получаете такие же функции, как и в Проводнике. Примечание 1. Нажимайте кнопку Добавить (Append) для каждой из функций. Примечание 2. Эти функции не будут работать в Windows 3.xx.

Прислал Сергей

Показать-спрятать скрытые файлы

Для того, чтобы показать/спрятать скрытые и системные файлы необязательно пользоваться меню. Можно сделать проще. Для этого в меню Конфигурация (Configuration)|Настройка...(Options...) щелкните на вкладке Общие (Misc.)|Переопределить горячие клавиши (Redefine hotkeys) выберите сочетание клавиш, например [Ctrl]+[H], в выпадающем списке Команда (Command) выберите cm_SwitchHidSys и нажмите галочку. Теперь нажимая эту комбинацию клавиш вы можете показать скрытые файлы, а повторно нажав скрыть их.

Прислал Сергей

Расширенный поиск

Предположим, что вы работаете над определенной проблемой, ключевым словом которой явлется слово "слово". Теперь откройте инструмент поиска Alt+F7 и введите в строке поиска "слово" без кавычек. Теперь откройте закладку "Загрузить/Сохранить" и сохраните условия поиска. Теперь в одной из файловых панелей нажмите Ctrl+F12 и выберите только что сохраненное условие поиска. Теперь куда бы вы переходили, в этой файловой панели будут отображаться только те файлы, которые содеражат слово "слово". Чтобы вновь отображались все файлы используйте комбинацию Ctrl+F10. Подробнее про расширенный поиск читайте здесь.

Прислал Ergo

Исполняемые файлы

Нажмите Ctrl+F11 и вы увидите только исполняемые файлы (*.COM;*.BAT;*.EXE;*.PIF;*.CMD) в текущем каталоге (очень удобно, если надо быстро найти программу среди множества файлов). Ctrl+F10 возвращает обратно в режим просмотра всех файлов.

Прислал Ergo

История посещений папок (каталогов) активного окна

Для просмотра истории посещения папок (каталогов) активного окна Total Commander’a удобно воспользоваться комбинаций клавиш Alt+ CURSORDOWN (стрелка вниз клавиши управления курсором)

Прислал Aleks

Расширенный просмотр каталога

Для того чтобы увидеть все файлы в текущем каталоге и во всех его подкаталогах одним списком необходимо установить курсор на выбранный каталог и нажать комбинацию клавиш Ctrl+B

Прислал Aleks

Просмотр списка последних команд командной строки

Чтобы открыть список последних команд (WinCom в буфере их запоминает 20) необходимо удерживая клавишу CTRL сделать короткое нажатие на клавишу CURSORDOWN (вниз) или CURSORUP (вверх). Откроется окно со списком последних 5 команд командной строки Total Commander’a. Затем, используя клавиши вверх и вниз, можно выбрать команду из предложенных 5 или всех 20 команд. После выбора команды, нажимая клавиши влево/вправо, вы можете, при необходимости отредактировать командную строку. При этом автоматически закроется список всех команд, кроме выбранной.

Прислал Aleks

Полный путь к файлу в командной строке

Все наверное знают, что имя файла под курсором в активном окне WinCom’a можно добавить (перенести) в командную строку нажатием комбинации клавиш CTRL+ENTER. Но не все знают, что комбинация клавиш CTRL+SHIFT+ENTER добавляет (переносит) имя файл под курсором в командную строку, включая полный путь (т.е. имя диска, папки (каталога), всех подкаталогов) к выбранному файлу.

Прислал Aleks

Еще об окне эмуляции DOS

При запуске MS-DOS программы из командной строки Total Commander’a окно эмуляции по завершении работы программы закрывается само собой. Естественно пользователь не видит результатов работы. Для того чтобы этого избежать, необходимо вместо ENTER нажать Shift+Enter. Но есть одна маленькая неприятность! Это работает только в том случае, когда в каталоге Windows находится файл NOCLOSE.PIF! А иначе, увы…

Прислал Aleks

Быстрое сканирование папок (каталогов)

Нажатие комбинации клавиш ALT+SHIFT+ENTER приводит к тому, что сканируется содержимое всех папок (каталогов) с подкаталогами в текущем (активном) окне WinCom’a, и показываются их размеры на месте <DIR>. У папки (каталога) не содержащего файлов (пустые папки) остается <DIR>. Однако чтобы данная команда правильно отработала, необходимо активное окно WC привести к виду "Подробный" (комбинация CTRL+F2 или в МЕНЮ выбрать "Вид" - "Подробный"

Прислал Aleks

Рейтинг

Japan Used Cars
Used Car Pricing

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Реклама на сайте

Все о Total Commander © 2001-2003
Идея, программирование, дизайн и поддержка, © Андрей Пясецкий


Total Commander - Total Commander: Крутые советы-8

Крутые советы-8

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

SHIFT+ F8 удаляет файл минуя корзину

Используя комбинацию из клавиш SHIFT+F8 Total Commander удаляет файл или папку целиком без сохранения копии для восстановления в корзине. Вы также можете достичь этого эффекта когда нажимаете SHIFT и бросаете файл на кнопку F8 панели функциональных клавиш. Предупреждение: Восстановить удаленный файл ни какими средствами уже не возможно! Пользуйтесь осторожно…!

Прислал Aleks

Новый пункт "ДИСКИ" в МЕНЮ Total Commander’a

В версии 4.54 Total Commander’a имеется возможность в МЕНЮ добавить новый пункт "ДИСКИ". Для этого в текстовый файл Wcmd_rus.mnu (размещается в каталоге Wincmd\Language) после раздела меню "ФАЙЛ" поместить раздел "ДИСКИ", который имеет следующее содержание:

POPUP "&Диски"

MENUITEM "&Рабочее окно...", cm_SrcOpenDrives

MENUITEM "&Левое окно\tALT+F1...", cm_LeftOpenDrives

MENUITEM "&Правое окно\tALT+F2...", cm_RightOpenDrives

END_POPUP

Сохранить файл Wcmd_rus.mnu, закрыть, а затем вновь запустить менеджер Total Commander. В Главном МЕНЮ будет добавлен новый пункт "ДИСКИ". Теперь смело можно убрать "Кнопки дисков" и "Окно выбора дисков" с рабочей панели WC, и как результат увеличится место для размещения большего числа папок и файлов на рабочих панелях.

Прислал Aleks

По поводу экономии

По поводу экономии, стоит ли мельчить с размером кнопок? Ведь проше создать новую панель кнопок (у меня их 5) и помещать на них кнопки по типу задач. 1-я панель - часто используемые проги, 2-я панель - утилиты ... Чтобы создать панель кликни правой кнопкой на свободном месте панели - изменить - новая панель, назови как хочеш и пользуйся

Прислал Serg

О выделении файлов и папок на панели WC

Используя комбинацию клавиш Shift+UP ИЛИ Shift+Down ВЫДЕЛЯЕМ файлы или папки в рабочем окне WinCom'a ОТ текущей позиции курсора до конца просматриваемой страницы в окна (вверх или вниз). А используя комбинацию Shift+End ИЛИ Shift+Home ВЫДЕЛЯЕМ все файлы или папки в рабочем окне WinCom'a от текущей позиции курсора до конца или начала страницы вообще. Попробуйте.

Прислал Aleks

Учите горячие комбинации

Alt+Enter - горячая комбинация на свойства файла.

Прислал benadin

Учите горячие комбинации

Если по дир-рии нажать ctrl+enter, а потом enter - то она откроется проводником; Если по архиву - то он откроется соотв. зарегестрированной за ним программой.

Прислал benadin

Что умеет панель инструментов

  • Если перетащить любой файл на иконку The Bat! на панели инструментов, то будет создано новое письмо со вложенным этим файлом.
  • Если перетащить любой файл на кнопку Lister-а (cm_List), то это равносильно F3 (бывает ведь не охота тянуться к клавиатуре).
  • Если перетащить любой файл или папку на кнопку Удаления (ее естественно предварительно необходимо создать - cm_Delete), то это равносильно Del\F8
  • Если на панели инструментов создать

Рейтинг
Japan Used Cars
Used Car Pricing

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |

Реклама на сайте
Все о Total Commander © 2001-2003
Идея, программирование, дизайн и поддержка, © Андрей Пясецкий