MPC - Media Player Classic

Параметры командной строки

Некоторые операции Media Player Classic можно выполнить, задавая соответствующие параметры командной строки. Справку по командам можно получить, набрав mplayerc.exe /? (или mplayerc.exe /h, или mplayerc.exe /help).

Использование: mplayerc.exe "путь" [переключатели]

"путь" - Файл или каталог для загрузки (разрешены маски).

/dub "имя файла" - Загрузить дополнительный звуковой файл.

/sub "имя файла" - Загрузить дополнительные субтитры.

/filter "имя файла" - Загрузить фильтр(ы) DirectShow из библиотек(и) (*.ax или *.dll, разрешены маски).

/dvd - Запуск в режиме DVD, параметр "путь" задает каталог с DVD (опционально).

/cd - Загрузить все дорожки Audio CD или (S)VCD, параметр "путь" задает путь к диску (опционально).

/open - Открыть файл, но не начинать воспроизведение.

/play - Начинать воспроизведение сразу после запуска.

/close - Закрыть по окончании воспроизведения (работает только с параметром /play).

/shutdown - Выключить компьютер по окончании воспроизведения.

/fullscreen - Запуск в полноэкранном режиме.

/minimized - Запуск в свернутом виде.

/new - Открыть новую копию проигрывателя.

/regvid - Регистрировать видеоформаты.

/regaud - Регистрировать аудиоформаты.

/unregvid - Разрегистрировать видеоформаты.

/unregaud - Разрегистрировать аудиоформаты.

/start ms - Воспроизводить с позиции "ms" (= миллисекунды)

/add - Добавить "путь" в плейлист, можно использовать совместно с /open и /play.

©2003 YDY


Работа с Избранным

Как дань моде (а может быть, следуя традициям WMP 6.4), Media Player Classic имеет функцию "Избранное". В меню "Favorites" находятся управляющие пункты "Add to Favorites...", "Organize Favorites..." и список добавленных вами ссылок. Например, так:

Если во время воспроизведения файла или DVD-диска, в главном или контекстном меню выбрать пункт Favorites → Add to Favorites..., то откроется следующее окно:

Здесь можно задать имя пункта, который появится в меню "Favorites". По-умолчанию используется имя файла или DVD. Можно поставить галку "Remember position": в этом случае также запоминается и позиция в файле или DVD.

Если ссылок набралось достаточно много, то можно их упорядочить. Для этого нужно выбрать пункт меню Favorites → Organize Favorites...

Здесь можно переименовать ссылки, поменять их местами или удалить. Для файлов и DVD есть отдельные вкладки.


  • Проигрывает любые форматы, для которых установлен DirectShow плагин.
  • Работает как полнофункциональный DVD-плеер, без необходимости установки дополнительных фильтров!
  • Корректно работает со всеми функциями OGM и MKV.
  • Позволяет произвольно перемещать и масштабировать изображение.
  • Удобная реализация полноэкранного управления.
  • Меньшая, чем у других проигрывателей загрузка памяти (на 10 - 30%).
  • Малый размер, вся программа представляет собой один исполняемый файл.
  • При установленном ActiveX плагине проигрывает Macromedia Flash, причем позволяет перематывать их!
  • При установленом RealPlayer9 или RealOnePlayer проигрывает файлы Real Media!
  • При установленом QuickTime проигрывает файлы QuickTime!
  • Версии до 6.4.7.5 при наличии необходимых библиотек проигрывали файлы Smacker/Bink.
  • Встроенный переключатель аудиодорожек.
  • Мощнейший встроенный движок отображения субтитров.
  • При наличии TV-тюнера или VIVO-видеокарты позволяет просматривать и даже захватывать видео!
  • Воспроизведение AudioCD (под Win2k/XP)
  • Возможность сохранения декодированного потока (например, MPEG2 с защищенных DVD).
  • Подключение второй звуковой дорожки (в любом поддерживаемом формате) для дубляжа.
  • Избранное, с возможностью сохранения позиции в фильме.
  • Работа с плейлистами, поддерживает M3U, PLS и ASX (открытие и сохранение).
  • Подключение DS-плагинов без установки в систему!
  • Наложение субтитров на любой поддерживаемый формат.
  • Поддержка систем управления WinLirc и uICE.
  • Настраиваемые горячие клавиши.
  • Сохранение конфигурации как в реестре, так и в ini-файле.
  • Открытие неполных AVI-файлов.
  • Возможность просмотра фильмов в разрешении, отличном от текущего.
  • Множество встроенных фильтров: MPEG Video, MPEG Audio, VCD, XCD, FLIC, DVD, SHOUCast и т.д.
  • Поддержка параметров командной строки.

Помимо обычных функций, имеющихся в большинстве плееров, MPC включает множество уникальных. Остановимся на них подробнее.

Режим воспроизведения DVD

Media Player Classic может работать как полнофункциональный DVD-плеер. Начиная с версии 6.4.6.0 имеется встроенный декодер MPEG2, с 6.4.6.3 - декодер звука MPEG Layer-1,2,3, с 6.4.7.4 - декодер AC3/LPCM, а с 6.4.7.8 - декодер DTS. Так что для просмотра DVD нужен только сам Media Palyer Classic. Звук также можно выводить и через S/PDIF. Поддерживаются все функции навигации DVD.

Встроенный Ogg-сплиттер

Начиная с версии 6.4.7.0 Media Player Classic имеет свой встроенный Ogg-сплиттер, отличающийся лучшей интеграцией с программой, возможностью использвания библиотек CoreVorbis и точным позиционированием при перемотке.
Тем не менее, для воспроизведения звука Vorbis всё равно нужны библиотеки, которые можно взять у меня.

Рендеринг видео с использованием Direct3D

На мой взгляд, это одна из самых интересных возможностей плеера. Начиная с версии 6.4.6.6, при наличии видеокарты с поддержкой Direct3D, Media Player Classic может накладывать видео в виде текстуры на поверхность (surface) и производить рендеринг в 3D, примерно так, как обрабатываются текстуры в 3D-играх. В результате одним выстрелом убивается два зайца: обходится одна ошибка DirectX, вызывающая некорректное масшабирование изображения, и существенно повышается качество изображения при масштабировании. Всё это работает в режимах VMR7 (renderless) или VMR9 (renderless).

Воспроизведение Flash-анимации

Flash-анимация получила чрезвычайно широкое распространение в последние пару лет. Появилось огромное количество мультфильмов, сделанных с ее помощью. При этом, фактически единственным проигрывателем для формата является стандартный плеер от Macromedia! И все бы ничего, но он даже не умеет (а скорее всего, его авторы умышленно не включили такую возможность) проматывать файл! Вот и приходится пользователям при просмотре Flash-роликов терпеливо ждать, когда пройдет вся реклама, которую разработчики заботливо включили в них.

Что же, с Media Player Classic ждать больше не придется! Начиная с версии 6.4.3.0 MPC проигрывает swf-файлы (конечно, для этого должен быть установлен ActiveX плагин, его вы можете скачать у меня или установить с сайта Macromedia). При этом вся функциональность Flash-ролика сохраняется, но вы можете при желании промотать его!

Воспроизведение Smacker/Bink

C версии 6.4.6.6 до 6.4.7.5 Media Player Classic воспроизводил файлы Smacker (*.smk) и Bink (*.bik). Эти форматы, разработанные фирмой Rad Tools, в основном используются для изготовления видеороликов в играх и для демонстраций. Оба формата обеспечивают очень высокую степень сжатия и четкость изображения, а различаются числом воспроизводимых цветов: Smacker работает только с палитрой 256 цветов, тогда как Bink - полноцветный формат. На сайте фирмы доступны бесплатные для персонального использования инструменты, позводяющие сжимать видео в эти форматы. Однако для их воспроизведения ранее можно было использовать только примитивный "родной" плеер, не имеющий перемотки и не умеющий масштабировать изображение.

К сожалению, Gabest'a вынудили убрать поддержку этих форматов из плеера, но старые версии никто не отменял :) Для воспроизведения этих форматов вам понадобится MPC версии 6.4.7.5 и библиотеки smackw32.dll и binkw32.dll, которые идут в комплекте с многими играми. Всё это вы можете скачать у меня. И не забывайте, что Media Player Classic сможет воспроизводить эти форматы, даже если они идут в виде cамопроигрывающегося *.exe файла.

Воспроизведение Real Media

C самого момента создания, Media Player Classic умел проигрывать файлы Real Media. Разумеется, для этого тоже должен быть установлен кодек. Есть специальный дистрибутив, включающий только необходимые файлы. Какие же это дает преимущества, спросите вы? Их много: плеер не будет лезть без спроса в сеть, как это делает RealOne Player, не будет ничего отсылать на сайт Real Networks, при воспризведении доступны все удобства Media Player Classic, возможно наложение субтитров, быстрая загрузка плеера.

В случае проблем с дистрибутивом, можно установить RealOne Player. Media Player Classic все равно будет использовать только кодеки.

Воспроизведение Quick Time

Начиная с версии 6.4.3.0 Media Player Classic умеет проигрывать файлы Quick Time. Опять же, для этого должен быть установлен Quick Time Player или, что лучше, QuickTime Alternative. Преимуществ в использовании MPC для воспроизведения Quick Time еще больше, чем в случае с Real Media. Стандартный плеер Quick Time громоздкий, неудобный, плохо масштабирует изображение на полный экран.

Воспроизведение источника "Live" ("Живой")

Media Player Classic умеет работать с различными устройствами ввода и захвата изображения, например, TV-тюнерами или VIVO-видеокартами. Для устройства должен быть корректно установлен WDM-драйвер. При этом возможен не только просмотр, но и захват изображения и звука в AVI или OGM. Возможно также сжатие на лету. В некоторых случаях бывает очень полезна возможность захватывать видео и аудио раздельно, что может помочь при проблемах с синхронизацией захвата в других программах.

Подключение фильтров

Начиная с версии 6.4.4.2 возможно подключение DirectShow фильтров и кодеков из файла, зная их CLSID (c версии 6.4.5.0 в этом уже нет необходимости, определение CLSID и типов происходит автоматически). Это очень удобно при размещении плеера на CD: пользователю нет необходимости устанавливать в систему фильтры и кодеки, необходимые для воспроизведения фильма.

Также возможно добавление в цепочку фильтров зарегистрированных в системе типов.

Воспроизведение неполных AVI-файлов

Как известно, AVI-файлы в содержат в конце индекс, без которого файл открыть обычными средствами невозможно (нужно восстанавливать индекс). С версии 6.4.5.0 MPC умеет открывать такие файлы, а некоторые даже перематывать. Это очень удобно для открытия файлов, находящихся в процессе закачки из сети.

С версии 6.4.7.3 внутренний AVI-сплиттер был полностью переписан. Теперь он сразу выполняет быструю реиндексацию файла, что обычно занимает несколько секунд (~30с на полном фильме в MPEG4 размером 700 Мб). Зато в дальнейшем возможна перемотка, как в любом нормальном AVI.

Сохранение конфигурации

Media Player Classic позволяет сохранять конфигурацию как в реестре, так и в ini-файле. Использование ini-файла удобно при записи плеера вместе с фильмом на CD: в этом случае настройки и список загружаемых фильтров будет браться из него.

Встроенный переключатель аудиодорожек

Media Player Classic имеет встроенный переключатель аудиодорожек, что удобно при воспроизведении файла с несколькими аудиодорожками. Переключатель также поддерживает даунсэмплинг с 48000 на 41000 Гц (для кривых аудиокарт), задание задержки для аудио и произвольный маппинг каналов для многоканального звука.

Коррекция размеров изображения

Media Player Classic позволяет произвольно изменять размер изображения (с сохранением пропорций и произвольно) и его положение. Удобно использовать для MPEG-4 фильмов, в которых недобросовестные пираты нередко не соблюдают пропорции. Чаще всего, изображение бывает вытянуто по вертикали (халтурное пережатие с анаморфированного DVD). С помощью MPC эти дефекты легко исправить.

Движок субтитров

Media Player Classic имеет мощнейший встроенный движок для отображения субтитров (который, что неудивительно, основан на VobSub). Субтитры выглядят очень четко, гладко и могут накладываться на любой видеоформат, поддерживаемый MPC.

Сохранение декодированного потока

Начиная с версии 6.4.4.0 появилась возможность сохранять декодированный видеопоток, прошедший через фильтры. Это позволяет, например, сохранить декодированный MPEG2 при воспроизведении защищенных DVD. К сожалению, я не имею возможности проверить, будет ли это работать для защищенных от сохранения Real Media потоков.

Поддержка систем управления WinLirc и uICE

Это системы управления компьютером при помощи пульта управления от любой бытовой аудио/видео техники. Для этого к COM-порту подключается несложное устройство (человек, знающий за какой конец держать паяльник, соберет его за час). Если вам это интересно, подробности смотрите на сайтах WinLirc и uICE.

Просмотр фильмов в разрешении, отличном от текущего

Известно, что наилучшее качество фильма можно получить, просматривая его в разрешении, при котором не требуется масштабирование фильма. Например, оптимальным разрешением для фильма с шириной 640 пикселов является 640х480. Media Player Classic может переходить в требуемое разрешение в полноэкранном режиме.


Что такое Media Player Classic?

Media Player Classic (MPC) - мощный мультимедийный проигрыватель, впервые появившийся в июле 2002 года. Создал его венгерский разработчик, известный под ником Gabest, автор ряда известных DirectShow фильтров.

Media Player Classic не повторяет путь развития других проигрывателей. Традиционный удобный интерфейс, почти полностью повторяющий интерфейс легендарного Windows Media Player 6.4, сочетается с вполне современным, но без излишеств, набором функций. В результате - мощный медиаплеер и полноценный DVD-плеер размером менее мегабайта.

Об этой справке

Наверное, можно понять автора, полностью сосредоточившегося на разработке программы, и даже и не думающего сделать хоть какую-нибудь документацию. Это вообще удел многих хороших бесплатных программ. В принципе, интерфейс плеера, что называется, проверен годами (мало кто не пользовался Windows Media Player 6.4) и интуитивно понятен - в отличие от многих плееров с поддержкой скинов :) Но все же для людей, никогда ранее WMP не пользовавшихся, некоторые настройки могут быть сразу неочевидны. Более того, в плеере присутствует ряд новых и уникальных возможностей и тонкостей, работа с которыми может оказаться не сразу понятной и для более искушенного пользователя.

Таким образом, справка была полностью написана с нуля. В ней не использовались никакие переводные материалы, а вся информация основана исключительно на моем личном опыте и сборе информации на форумах. Предупреждая законный вопрос - "А зачем тебе это надо?" - сразу отвечу: мне просто захотелось. Так уж вышло, что MPC идеально подошел под мои понятия о том, как должны писаться программы. Но как оказалось, мои потенциальные единомышленники даже и не подозревают о существовании этой замечательной программы; более того, в России MPC вообще практически неизвестен. Так почему бы не дать хорошей программе дополнительный шанс на жизнь?..

Ну и напоследок, хочу предупредить пользователей этой справки: некоторые опции все же остались не освещенными или освещенными не полностью. Это означает, что либо я пока не знаю, что означает данная опция, либо не имею возможности ее проверить ввиду отсутствия нужного оборудования или условий. Если у вас есть возможность проверить такие опции - буду очень признателен, если вы пришлете мне информацию. Информация по замеченным неточностям также приветствуется.

Сразу сделаю необходимые оговорки и отговорки:

  • Для всех горячих клавиш, упоминающихся в справке, указаны значения по-умолчанию.
  • Некоторые картинки могут немного не совпадать с текущим видом плеера.
  • Данная версия справки (1.0.78) актуализирована для Media Player Classic 6.4.7.8.
  • Использование материалов справки в целях, отличных от ознакомления с Media Player Classic, возможно только после согласования с автором.
  • Что бы ни случилось в результате пользования справкой - я за это не отвечаю :)


Интерфейс Media Player Classic

При первом взгляде на плеер его практически невозможно отличить от Windows Media Player 6.4. Но простота эта кажущаяся: в меню и на страницах опций скрыто огромное количество функций. Примерно так выглядит главное окно сразу после открытия фильма:

Полоса поиска

Самая обычная полоса поиска, служащая для перемещения по фильму. При нажатой клавише Shift перемещение будет происходить по ключевым кадрам.

Кнопки управления

Кнопки управления похожи на кнопки из Windows Media Player 6.4, но часть из них выполняет другие функции. Слева направо:

  • Запуск воспроизведения
  • Пауза
  • Остановка воспроизведения
  • Предыдущий файл или фрагмент
  • Уменьшение скорости воспроизведения
  • Увеличение скорости воспроизведения
  • Следующий файл или фрагмент
  • Покадровое воспроизведение

Информационная панель

В информационной панели показывается информация о фильме или звуковом файле, взятая из тегов. Если информация отстутствует, панель не отображается.

Статусная строка

В статусной строке показывается полезная информация о режимах плеера. В обычном режиме показывется значок типа файла, состояние плеера, прошедшее/общее время файла (или число кадров для Macromedia Flash), значок звука (отсутствует/моно/стерео). В строке также отображается различная информация о производимых операциях: например, при изменении размера кадра показываются относительные позиция, масштаб и соотношение сторон. Эта информация пропадает через ~ 4 с и статусная строка возвращается к обычному режиму.

Управление звуком

Кнопка полностью отключает или включает звук. Регулятор, соответственно, его плавно регулирует :)


Режим "Live"

В MPC есть особый режим, называемый "Live" ("Живой"). В этом режиме Media Player Classic "воспроизводит" видео и звук с устройств захвата - TV-тюнеров, web-камер, VIVO-видеокарт и т.д. Режим работает с любыми устройствами, для которых установлен WDM-драйвер.

Чтобы включить режим, идите в меню File → Open Device. Откроется окно, похожее на показанное ниже, со списком устройств, установленных в вашей системе:

Выберите нужное устройство и намите ОК. Должно появиться изображение, выдаваемое устройством. Переключение каналов осуществляется кнопками перехода по сценам/файлам плейлиста. К сожалению, в настоящее время настройка каналов осуществляется только через интерфейс WDM-драйвера.

Видеозахват

MPC также позволяет производить видеозахват в AVI или OGM. Для этого нужно открыть панель захвата (View → Capture или Ctrl-8)

Группа Video

Здесь можно задать устройство ввода, частоту кадров, цветовое пространство, выбрать стандартный размер кадра для захвата или задать свой. В случае ручного задания размера не забудьте зафиксировать изменения нажатием кнопки Set. В силу определенных проблем, заданный размер захвата не сохраняется между запусками. Надеюсь, это будет решено в будущем.

Группа Audio

Здесь задается вход микшера (например, TV-тюнер обычно подключен к Line-In или Aux), формат и параметры звука.

Группа Output

Чтобы производить захват видео и аудио нужно установить галки Record Video и Record Audio соответственно. Галки Preview служат для включения предварительного (в реальном времени) просмотра захватываемого материала.
Имейте в виду, что при определенных настройках звуковой карты, может появиться эффект реверберации (эха), за счет отставания звука, проходящего через программу. В этом случае галку Preview для звука нужно снять.

Как для видео, так и для звука можно задать кодек, установленный в системе. Параметры кодека задаются либо в полях ниже списка кодеков, либо в окне, открываемом при выборе кодека (зависит от конкретного кодека).

В случае проблем с захватом (выпадение кадров) можно попробовать увеличить число V/A буферов (по-умолчанию 50), что, однако, приведет к большой загрузке памяти. Галка Output Audio Separately может помочь в случае, если звук плохо синхронизируется с видео (нередкая проблема на некоторых конфигурациях).

Примечание: ввиду недостаточной доработанности DS кодеков для OGM захват в этот формат может быть некорректным.


Меню "File"

Open File... - открывает стандартное и, надо признать, не слишком удобное окно, пришедшее из WMP6.4.

Впрочем, его оправдывает возможность ввести не только файл, но и URL, a также открытие дополнительной звуковой дорожки (например, перевода), которая будет накладываться на основную.

Open DVD... - открывает DVD в соответствии с настройками на вкладке DVD/OGM.

Open Device - открывает "живой" источник (TV-тюнер, плата видеозахвата, web-камера и т.д., ). Подробно о режиме см. Режим "Live".

Open CD-ROM - если в дисковод вставлен Audio CD или (S)VCD, то при наведении открывается список всех треков на диске.

Close - закрывает текущий файл или плейлист.

Save As... - опция, которую мне так и не удалось проверить. Должна сохранять декодированные или потоковые данные на диск.

Save Image... - сохраняет текущий кадр в формате bmp. Это можно сделать и с помощью горячих клавиш.

Load Subtitle - загружает файл субтитров.

Save Subtitle - сохраняет файл субтитров после ресинхронизации.

Properties - показывает свойства файла: размер, разрешение, информацию из тегов и т.д.

Exit - этот пункт требует столь сложного объяснения, что я решил его оставить на потом... :)


Меню "Navigate"

Меню предназначено для навигации по форматам, которые эту навигацию поддерживают. На сегодняшний день это DVD и OGM (в будущем - MKV). Пункты этого меню достаточно очевидны.

Previous, Next - переход на предыдущий или следующий эпизод.

Jump To... - в этом меню при воспроизведении появляется список эпизодов и разделов DVD.

Audio/Subtitle Language - список доступных аудиодорожек и субтитров. По-умолчанию устанавливается язык, заданный на вкладке DVD/OGM.

Video Angle - угол видео (фактически, видеопоток).

Title/Root/Subtitle/Audio/Angle/Chapter Menu - быстрый переход к соответствующему меню DVD. Работает только в том случае, если эти меню были включены при премастеринге DVD.

Состав меню MPC для выбора языка субтитров и звука, глав, угла видео зависит от конкретного DVD или OGM. На картинке выше показан пример меню выбора субтитров.


Меню "Play"

Play/Pause, Stop - думаю, эти пункты в объяснениях не нуждаются.

Frame Step - воспроизведение видео по одному кадру.

Go To... - открывает следующее окно:

В верхнем поле ввода можно задать точку перехода в виде временного кода. Разделитель - точка. Одно число задает миллисекунды, два - секунды и.тд. В нижнем поле можно задать номер кадра, к которому нужно перейти, и через запятую - число кадров в секунду фильма.

Decrease/Increase Rate - уменьшает или увеличивает скорость воспроизведения фильма.

Filters - показывает список фильтров, применяющихся для воспроизведения. Состав списка зависит от конкретного фильма и может выглядеть примерно так:

Audio, Subtitles - показывает список доступных аудиодорожек и субтитров, соответственно.

Volume - Открывает список с командами управления громкостью.


Меню "View"

Caption Menu - вкл/откл главное меню.

Seek Bar - вкл/откл полосу поиска.

Controls - вкл/откл органы управления.

Information - вкл/откл информацию о файле (берется из тегов).

Statistics - вкл/откл некоторую статистическую служебную информацию.

Status - вкл/откл статусную строку.

Subresync - вкл/откл окно ресинхронизации субтитров.

Playlist - вкл/откл окно редактора плейлистов.

Presets - открывает список возможных предустановок вида интерфейса.

Full Screen - переход в полноэкранный режим и обратно.

Zoom - в этом подменю задается размер окна плеера, размер самого кадра меняется отдельно.

Video Frame - открывает список опций, определяющих параметры видеокадра.

Pan&Scan - открывает список опций для смещения и масштабирования изображения.

Always On Top - открывает список опций всегда сверху.

Options... - открывает диалог настроек.

Подменю "Presets..."

Minimal - самый спартанский вид интерфейса. Не остается ничего, кроме самого кадра. Доступ ко всем функциям производится из контекстного меню.

Compact - остаются только заголовок, меню и кнопки управления.

Normal - показываются все элементы интерфейса, кроме статистики.

Подменю "Video Frame"

В этом подменю задается размер видеокадра и то, как плеер будет отображать видеокадр на экране.

Half Size, Normal Size, Double Size - соотвеетственно: половинный, нормальный и двойной размер кадра.

Stretch To Window - растягивает изображение до размера окна (на полном экране).

Touch Window From Inside - ограничивает размер кадра по ширине экрана.

Touch Window From Outside - ограничивает размер кадра по высоте экрана.

Keep Aspect Ratio - сохранять соотношение сторон неизменным (со "Stretch To Window" не работает).

Correct Monitor/Desktop AR Diff - что делает эта опция я не знаю.

Подменю "Pan&Scan"

В этом подменю находятся команды для произвольного задания размера и смещения кадра, а также настройки соотношения сторон видео.

Increase/Decrease Size - изменяет размер изображения, сохраняя соотношения сторон.

Increase/Decrease Width - изменяет ширину изображения (может не работать с некоторыми кодеками).

Increase/Decrease Height - изменяет высоту изображения (может не работать с некоторыми кодеками).

Move Right/Left/Up/Down - перемещает изображение соответственно вправо, влево, вверх и вниз.

Edit... - открывает следующее окно, где можно задать свои установки масштаба и смещения:

Стандартные и пользовательские установки будут размещаться над кнопкой "Edit..." в меню.

Reset - возвращает размер и положение кадра в исходное состояние.

Подменю "On Top"

В этом подменю находятся команды для задания параметров "всегда сверху".

Never - опция отключена.

Always - плеер всегда будет располагаться поверх всех окон.

While Playing - плеер будет располагаться поверх всех окон только во время воспроизведения.


• Введение
- Введение
- Возможности
• Интерфейс
- Интерфейс
- Меню "File"
- Меню "View"
- Меню "Play"
- Меню "Navigate"
- Избранное
- Плейлист
• Настройки
- Проигрыватель
- Форматы
- Клавиши
- Логотип
- Web-интерфейс
- Воспроизведение
- DVD/OGM
- Вывод
- Фильтры
- Аудиопереключатель
- Аудиодекодеры
- Декодер MPEG
- Внешние фильтры
- Субтитры
- Стиль субтитров
- Дополнительно
• Прочее
- Режим "Live"
- Синхронизация субтитров
- Командная строка


Вкладка "Audio Switcher"

На этой вкладке настраивается специальный встроенный фильтр - аудиопереключатель.

Аудиопереключатель служит для работы с файлами, в которые включено две или более звуковых дорожек. Это может быть AVI, OGM, VOB, MKV и, возможно, некоторые другие. Если аудиопереключатель выключен, то при воспроизведении таких файлов все звуковые дорожки будут звучать одновременно. Как ясно из названия, аудиопереключатель помогает воспроизводить только одну дорожку, и переключаться между ними.

Enable built-in audio switcher filter... - включает фильтр.

Down-sample to 44100 Hz - снижает частоту дискретизации звука до 44100 Гц, что может помочь на некоторых кривых звуковых картах (в частности, встроенных), не поддерживающих частот дискретизации больше 44100 Гц.

Audio time shift - задается смещение звука относительно видео. Очень полезная функция, если звук в фильме отстает от видео или опережает его. Начиная с версии 6.4.6.4 смещение звука можно регулировать клавишами +/- на цифровой клавиатуре с шагом 10 мс. Тем не менее, в некоторых случаях эта опция все еще может быть полезна.

Enable custom channel mapping - в некоторых случаях может понадобиться поменять распределение входящих звуковых каналов на колонки. Например, распределение стереозвука на 4 колонки будет выглядеть так:

Смешение 5.1 каналов в 2 передние колонки, теоретически (ввиду отсутствия карты 5.1 этот вариант я достоверно описать не смогу, если кто может провести исследования - пишите), должно выглядеть так:

Разумеется, возможны и другие варианты.


Вкладка Audio Decoders

На этой вкладке задаются параметры встроенного аудиодекодера.

Output sample format for the MPEG Audio, LPSM, AC3 Decoders - задает формат вывода звука с декодера. Расположены слева направо в порядке улучшения качества.

Decode to speakers - задает количество колонок, на которые будет производиться декодирование.

S/PDIF - декодирование производиться не будет, звук напрямую поступает на S/PDIF (например, для подключения к ресиверу).

Dynamic Range Control - контроль за динамическим диапазоном, часто эту опцию называют "Сжатие динамического диапазона". В этом случае уровень самых громких звуков будет понижаться, а уровень самых тихих - повышаться, чтобы "уместить" огромный динамический диапазон AC3 в рамки более низкой разрядности звуковых карт, не теряя при этом звук. Рекомендуется устанавливать для дешевых 16-ти битных звуковых карт.


Вкладка DVD/OGM

На этой вкладке задаются параметры и умолчания для DVD и OGM.

Location of the DVD drive or the "VIDEO_TS" folder - определяет расположения DVD привода или место на диске, где находится стандартный каталог DVD "VIDEO_TS". При значении "Default" MPC автоматически ищет DVD в приводах.
Следует отметить, что в отличие от многих программ MPC может воспроизводить DVD, даже если файлы *.IFO и *. VOB находятся в папке с произвольным именем.

Prefered language for DVD Navigator and OGM Splitter - определяет, какой язык будет устанавливаться по-умолчанию для форматов, которые это поддерживают. Сейчас это DVD (полная поддержка) и OGM (кроме меню). Раздельно задается язык для меню, звука и субтитров.

Automatically set speaker count for the ivideo ac3 decoder - для AC3 декодера от WinDVD можно автоматически установить число колонок.


Вкладка "Фильтры"

На этой вкладке расположены встроенные фильтры.

Установленная галка обозначает, что будет использоваться тот или иной фильтр, встроенный в программу. Если вы хотите использовать внешний фильтр (с большей функциональностью или по причине некорректной работы встроенного), то снятие галки отключает встроенный фильтр для типа данных.

AVI Splitter - фильтр, отвечающий за разделение потоков в AVI. В отличие от системного, встроенный умеет открывать неполные файлы и имеет более высокую скорость поиска.

Matroska Splitter - фильтр для окрытия нового контейнера Matroska. Его качество лучше, чем у официального разработчика :)

RealMedia Splitter, RealVideo Decoder, RealAudio Decoder - набор фильтров для открытия файлов RealMedia.

MPEG-1 Video Decoder, MPEG-2 Video Decoder - фильтры для воспроизведения MPEG1 и MPEG2. Последний позволяет просматривать DVD без необходимости наличия установленной коммерческой программы для DVD (WinDVD, PowerDVD, NVDVD и т.д.).

MPEG Audio Decoder - декодер звука в формате MPEG Layer 1,2,3 (mpa, mp2, mp3 и т.д.)

AC3 Decoder - декодер звука в формате AC3

LPCM Decoder - декодер звука в формате LPCM (несжатый PCM звук в DVD)

Ogg Splitter - фильтр, отвечающий за разделение потоков в Ogg (OGM). От обычного пока отличается лучшей интеграцией с MPC.

Audio CD Reader - фильтр для воспроизведения Audio CD.

VCD/SVCD/XCD Reader - фильтр для воспроизведения VideoCD, Super VideoCD и eXtended VideoCD (форматы, записывающиеся без включения данных для коррекции ошибок, что позволяет умещать ~800 Мб данных на диск 700 Мб).

DVD Video Title Set Reader - позволяет открывать DVD и использовать его навигационную систему.

FLI/FLC Decoder - декодер очень старых (многие о них и не слышали) форматах анимации.

DVD2AVI Project File Decoder - декодер для воспроизведения проектов DVD2AVI. Этот формат известен только в узких кругах людей, занимающихся пережатием DVD в MPEG4.

DTS/AC3 Parser - обеспечивает открытие (не декодирование!) звука в форматах AC3 и DTS.

SHOUTcast Receiver - фильтр для приема потокового формата SHOUTcast.

Smacker & Bink Decoder - фильтр для воспроизведения видео и звука в форматах Smacker/Bink. Увы, сейчас он отключен.

RoQ Decoder (ID Software) - фильтр для воспроизведения видео в формате движка Quake 3 и других игр на его основе.

DTS Decoder - декодер звука в формате DTS.

Nut Splitter - экспериментальный сплиттер для нового контейнера Nut.


Вкладка "Formats"

На этой вкладке можно задать, какие типы файлов будут воспроизводиться с помощью Media Player Classic.

Для каждого типа файлов можно задать тип интерфейса, через который он будет воспроизводиться. Например, файл .snd может воспроизводиться как через DirectShow, так и через QuickTime. Через тип Shockwave может воспроизводиться только Flash.

При выборе типа из списка в группе "File Extensions", в поле ввода показываются стандартные расширения, которые соответствуют этому типу. При необходимости, вы можете добавить туда свои расширения. Для сохранения изменений нужно нажать кнопку "Set". Кнопка "Default" убирает пользовательские расширения и возвращает список к исходному виду.

Кнопки "Video" "Audio" и "All" выбирают соответственно видеоформаты, форматы звука и весь список.

Группа Real-Time Streaming Protocol handler (for rtsp://... URLs) определяет, каким способом будут открываться данные, передаваемые по протоколу rtsp - RealMedia, QuickTime и DirectShow. Look file extension first пытаться открывать способом, установленным для соответствующего расширения, а если расширение определить невозможно, то одним трех способов, что описаны выше.

Под Windows XP Media Player Classic может зарегистрироваться для автоматического воспроизведения видео, музыки, DVD и Audio CD при вставке носителя в дисковод. Для этого установите соответствующие галки в разделе "Autoplay".

На сегодняшний день список официально поддерживаемых форматов:

  • AIFF Format Sound - стандартный формат звука на Macintosh.
  • AU Format Sound - стандартный формат звука на Macintosh.
  • Audio File - стандартный звуковой формат Windows (RIFF).
  • CD Audio Track - не формат, как таковой, просто ссылка на трек на Audio CD.
  • DVD Audio File - звуковые файлы, используемые для DVD (ac3, dts).
  • DVD File - форматы DVD: видеофайлы (vob) и файлы навигации (ifo).
  • DVD2AVI Project File - довольно экзотичный формат, проект для DVD2AVI.
  • FLIC file - очень старый анимационный формат (fli, flc)
  • Indeo Video File - файл со сжатием Intel Indeo.
  • Matroska Audio File - расширение нового контейнера Matroska, для звука (mka).
  • Matroska Video File - расширение нового контейнера Matroska, для видео (mkv).
  • MIDI File - музыкальный файл MIDI, стандарт Windows (mid, rmi).
  • Movie audio file (MPEG) - звук в формате MPEG Layer-1 или 2 (mpa, mp2, m2a).
  • Movie file (MPEG) - видео в формате MPEG1 или MPEG2 (mpg, mpv, m2v).
  • MP3 Format Sound - нужны комментарии? :) Звук в формате MPEG Layer-3.
  • MPEG4 Audio File - стандартный формат звука MPEG4 (aac).
  • MPEG4 file - расширение официального контейнера для MPEG4 (mp4).
  • Ogg Media File - альтернативный контейнер для видео, основанный на Ogg (ogm).
  • Ogg Vorbis Audio file - современный формат звука Ogg Vorbis (ogg).
  • Other - специальный раздел для произвольных форматов (для удобства ассоциирования).
  • Playlist File - различные форматы списков воспроизведения (плейлистов) (m3u, pls, asx).
  • Quicktime file - стандартный формат видео (а также звука и midi) на Macintosh (mov, qt).
  • Real Audio file - формат звука Real Audio (ra, ram).
  • Real Media file - контейнер для видео и звука Real Audio и Real Video (rm, smi).
  • RoQ Media file - видеоформат, применяемый в Quake 3 и других играх на его движке.
  • Shockwave Flash File - анимация в формате Macromedia Flash (swf).
  • Video File - стандартный контейнер для видео в Windows (avi).
  • Windows Media Audio File - звук в формате Windows Media (wma).
  • Windows Media File - видео в формате Windows Media (wmv, asf).

В принципе, при наличии соответствующих DirectShow фильтров, можно воспроизводить любой формат, несмотря на его отсутствие в списке. Просто добавьте нужное расширение в специальный раздел Other, либо к одному из наиболее близких типов данных с категорией "DirectShow".


Вкладка "Keys"

На этой вкладке можно настроить действия клавиш и мыши при работе с Media Player Classic.

Command - имя внутренней команды MPC.

Modifier - модификатор основной клавиши: Ctrl, Alt, Shift, Ctrl-Alt, и т.д.

Key - основная клавиша действия. Могут задаваться обычные буквенные и цифровые клавиши, специальные (функциональные, Enter, Esc и т.д.) и кнопки мыши.

Type - задается метод сканирования клавиши: ASCII сканкод или виртуальная клавиатура Windows (VIRTKEY).

ID - информационное поле, показывает код диспетчера сообщений.

Mouse - позволяет задать управление с помощью клавиш мыши, колёсика и т.д.

App Command - позволяет управлять некоторыми функциями плеера из внешних приложений путем подачи системных команд.

RemoteCmd - код, выдаваемый WinLIRC или uICE как реакция на нажатие клавиш пульта ДУ.

RepCnt - число повторов?

С помощью кнопки "Reset Selected" можно сбросить клавиши в их исходные значения. Кнопка "Select All" позволяет выбрать все клавиши в списке.

Галки WinLIRC и uICE включают соответствующую систему поддержки ДУ. Подробнее об этих системах можно узнать, кликнув на их название в окне опций.


Вкладка "Logo"

Здесь особенно объяснять нечего, картинка говорит сама за себя.

В режиме "Internal" cтрелками можно выбрать встроенный логотип, в режиме "External" - внешний файл в формате .bmp, .jpg, .gif, .png.


Вкладка Mpeg Decoder

На этой вкладке задаются параметры встроенного MPEG декодера.

Enable planar YUV media types (VY12, I420, IYUY) - по возможности, будут использоваться такие типы цветового пространства, работа с которыми обеспечивает наибольшую скорость.

Always display forced subtitles - всегда отображать "неотключаемые" субтитры. Такие субтитры нередко бывают на DVD с китайскими и японскими фильмами - отключить их из навигационного меню DVD нельзя. Если опция снята, такие субтитры будут отображаться только после их включения вручную.

Deinterlacing method - метод устранения чересстрочной развертки (в просторечии - гребёнки). Более качественным считается "Blend" (взаимное смешение полей), но можно оставить эту опцию как "Auto".

Brightness, Contrast, Hue, Saturation - яркость, контраст, оттенок и насыщенность - думаю, комментарии излишни.

Y: 16-235 -> 0-255 - расширяет диапазон яркостной составляющей с 16-235 до 0-255. Многие DVD сжимаются с ограничением яркости до диапазона 16-235 (зачем - не знаю). Эта опция устанавливает движки оптимальным образом для обратной коррекции.


Вкладка Output

На этой вкладке задаются параметры вывода видео и звука.

В группе DirectShow Video задается рендер для всех типов файлов, кроме RealMedia и QuickTime.

  • System Default - видеорендер по-умолчанию для DirectShow. Этот режим всегда включается в тех случаях, когда другие рендеры не могут загрузиться. На Windown XP аналогичен VMR7 (windowed).
  • Old Renderer - видеорендер по-умолчанию для Windows 9x/ME/2K. В зависимости от видимости видеоокна и возможностей видеокарты, режим динамически переключается между методами GDI, DirectDraw и Overlay.
  • Overlay Mixer - рендеринг всегда производится в оверлее. Обычно доступны только форматы YUV, но они представляются напрямую, без преобразования в RGB. Это самый быстрый метод из всех, и только здесь стопроцентно работает "зеркальный" вывод видео (на TV-OUT).
  • WMR7 (windowed) - видеорендер по-умолчанию для Windows XP. Очень стабильный и лишь немного медленнее метода Overlay mixer. Использует DirectDraw и по-возможности запускается в оверлее.
  • WMR9 (windowed) - доступен только при установленном DirectX 9. Возможности аналогичны VMR7 (windowed), но никогда не использует оверлей, а потому может быть немного медленнее, чем VMR7 (windowed).
  • WMR7 (renderless) - то же, что и VMR7 (windowed), но с плагином MPC Allocator-Presenter для вывода субтитров. "Зеркальное" отображение видео в оверлее работать НЕ БУДЕТ. Глубину цвета рекомендуется установить в 'True Color'.
  • WMR7 (renderless) - то же, что и VMR9 (windowed), но с плагином MPC Allocator-Presenter для вывода субтитров. "Зеркальное" отображение видео в оверлее МОЖЕТ работать. Глубину цвета рекомендуется установить в 'True Color'.
  • Null - подключается к любому типу видеоданных и отсылает входящие кадры в никуда. Режим может пригодиться для сохранения ресурсов процессора в случае, если нужен только звук.
  • Null (unc[ompressed]) - то же, что и нормальный Null-рендер, но подключается только к несжатым типам данных.

В группе RealMedia Video задается рендер для видео в формате RealMedia.

  • System Default - собственный рендер RealMedia. Скрипты SMIL будут работать, но без интерактивности. Использует DirectDraw и по-возможности запускается в оверлее.
  • DirectX 7 - вывод RealMedia обрабатывается с помощью плагина Allocator-Presenter в VMR7 (renderless).
  • DirectX 9 - вывод RealMedia обрабатывается с помощью плагина Allocator-Presenter в VMR9 (renderless).

В группе QuickTime Video задается рендер для видео в формате QuickTime.

  • System Default - собственный рендер QuickTime. Замедляется при изменении размера видеокадра или если окно частично закрыто другим окном. Если оверлей недоступен возвращается к методу GDI.
  • DirectX 7 - вывод QuickTime обрабатывается с помощью плагина Allocator-Presenter в VMR7 (renderless).
  • DirectX 9 - вывод QuickTime обрабатывается с помощью плагина Allocator-Presenter в VMR9 (renderless).

В группе WMR7/9 (renderless) & DirectX 7/9 задаются параметры обработки видео.

  • Use regular offscreen plain surfaces - поверхность для видео выделяется как обычная поверхность вне экрана.
  • Use texture surfaces and render video in 2d - поверхность для видео выделяется как текстура, но для копирования и растяжения видео в буфер используются функции 2D. Требует наличия видеокарты, которая может выделять 32bit RGBA текстуры, с размерами не кратными 2, хотя бы в разрешении видео.
  • Use texture surfaces and render video in 3d - поверхность для видео выделяется как текстура и рисуется как два треугольника в 3D. Включение антиалиасинга в настройках видеокарты может существенно замедлить скорость рендеринга.

В списке DirectShow Audio - задает, через какое устройство будет выводиться звук. Можно оставить System Default или установить один из вариантов вывода через Direct Sound. На разных системах эти параметры различны, кроме двух:

  • Null Audio Renderer (any) - звук не выводится, при этом ресурсы процессора практически не используются. Режим может пригодиться в случае, если нужно только видео.
  • Null Audio Renderer (uncompressed) - то же, что и выше, но работает только для несжатых типов данных (PCM/IEEE и т.д.).


Вкладка Overrides

На этой вкладке можно подключить внешние фильтры - как установленные в системе, так и из файлов.

Эта вкладка открывает широчайшие возможности. Здесь можно напрямую подключить файлы фильтров, не устанавливая их в систему. Это позволяет использовать Media Player Classic для записи на CD-ROM и последующего просмотра фильмов на любом компьютере, даже не имеющем установленных декодеров.

Add filter... - добавить фильтр в список. После нажатия кнопки откроется примерно такое окно:

Это список всех фильтров, установленных в системе. Полагаю, что выбирать фильтры из этого списка может понадобиться только в одном случае: чтобы изменить его "значение" (Merit) или заблокировать совсем. Гораздо интереснее кнопка Browse..., которая позволяет выбрать и подключить фильтр прямо из файла.

Remove - удаляет фильтр из списка.

Prefer/Block/Set merit - в этой группе задается способ работы с фильтром. "Prefer" включает предпочтение для фильтра, т.е. вне зависимости от приоритетов установленных в системе фильтров будет всегда работать этот фильтр. "Block" - блокирует фильтр, установленный в системе. "Set merit" - задает приоритет (значение) фильтра. Чем выше приоритет фильтра, тем вероятнее он будет использоваться.

Up/Down - меняет фильтры местами. Сделано для удобства, так как на приоритет фильтра не влияет.

Add Media Type... - для выбранного фильтра задает дополнительные глобальные типы данных (Video, Audio, Midi и т.д. или CLSID типа - если известен).

Add Sub Type... Задает конкретный тип (субтип) для предыдущего параметра. Обычно это FOURCC кодека, контейнера или их CLSID - если известен.

Delete - удаляет тип или субтип.

Reset List - сбрасывает список к начальным значениям.


Вкладка "Воспроизведение"

На этой вкладке задаются параметры воспроизведения.

Volume - задает громкость воспроизведения. Эта настройка явная дань традиции WMP 6.4, поскольку повторяет регулятор громкости в главном окне программы и, по-моему, большого смысла не имеет.

Balance - аналогично предыдущему регулятору, особенно неясно его назначение в случае с многоканальным звуком.

Playback - эта группа также полностью повторяет настройки WMP 6.4.

Play # times - сколько раз будет повторено воспроизведение.

Repeat forever - бесконечное повторение.

Rewind when done playing - перемотать в начало по окончании воспроизведения.

Output - группа, отвечающая за параметры вывода изображения.

Auto Zoom - автоматическое масштабирование до значения, задаваемого в поле справа.

Change fullscreen resolution - известно, что наилучшее качество фильма можно получить, просматривая его в разрешении, при котором не требуется масштабирование фильма. Например, оптимальным разрешением для фильма с шириной 640 пикселов является 640х480. MPC может переходить в требуемое разрешение в полноэкранном режиме.

Use worker thread to construct the filter graph - использовать рабочий поток для построения цепочки фильтров, т.е. фильтры загружаются отдельно от программы. Рекомендуется оставить опцию включенной, так как это существенно повышает скорость загрузки программы.

Report pins which fail to render - выводит подробную информацию о потоках, которые MPC не смог воспроизвести. В открывающемся в таких случаях диалоговом окне (см. скриншот) можно просмотреть информацию о потоке и сразу попытаться найти кодек для него в Интернет.

Если опция снята, то будет выводиться только короткое сообщение об ошибке в статусной строке.

Auto-load audio files - автоматически загружает звук (в любом поддерживаемом формате) с тем же именем, что и видеофайл. Функция удобна для синхронного воспроизведения видео и звка, если он в разных файлах, например, после захвата с включенной опцией "Audio to wave". В обычных условиях опцию можно снять.

Auto-load subtitles - автоматически загружает субтитры (в любом поддерживаемом формате) с тем же именем, что и видеофайл. Примите во внимание, что функция будет работать только если включен один из видеорежимов "Renderless".


Вкладка "Player"

Вкладка "Player" во многом повторяет вид Windows Media Player 6.4.

Open options - здесь можно выбрать, каким способом будут открываться файлы в MPC: в одном и том же процессе, или для каждого файла будет открыта новая копия плеера. Title Bar - опции, определяющие содержимое заголовка программы. Dispaly Full Path - отображать полный путь к воспроизводимому файлу; File Name Only - отображать только имя воспроизводимого файла; Don't prefix anything - не отображать ничего, кроме названия программы; Other - прочие опции.

Always on top - плеер находится поверх всех окон;

Tray Icon - сворачиваться не в таскбар, а в трей;

Show controls in fullscreen for - задает время в секндах, сколько в полноэкранном режиме будет выводиться панель с кнопками управления, информацией и т.д. При задании 0, панель будет скрываться сразу после того, как с нее убран курсор мыши, при задании -1 панель будет постоянно открыта.

В режиме автоскрытия панель появляется при подведении курсора мыши к невидимому краю панели. Исключение сделано для меню DVD: чтобы была возможность добраться до кнопок управления в нижней части экрана, панель появляется только при подведении курсора к нижнему краю экрана.

Exit fullscreen at the end of palyback - плеер выходит из полноэкранного режима по окончании воспоизведения.

Remember last window position - запоминает положение плеера в последнем запуске.

Remember last window size - запоминает размер окна плеера в последнем запуске.

Store settings in .ini file - плеер сохраняет настройки в .ini файле с именем программы, а не в реестре. Очень удобно для создания автозапуска с заранее установленными параметрами.

Keep history of recently opened files - сохраняет список последних открытых файлов. Для повышения безопасности можно снять.

Hide CD-ROMs menu - при вставленном музыкальном CD или VideoCD MPC требуется прочитать диск при открытии меню File, что иногда вызывает заметные задержки. Эта опция отключает пункт меню File "Open CD-ROM".


Вкладка "Default Style"

На вкладке устанавливаются настройки вида субтитров по-умолчанию.

Вкладка просто изобилует опциями, позволяющими очень гибко настроить внешний вид субтитров.

Font - в этой группе задается шрифт и его параметры. В выпадающем списке нужно выбрать набор символов, для России - RUSSIAN (204).

Spacing - интервал между символами.

Angle z,° - угол поворота текста (правда неясно, зачем это может понадобиться...)

Scale x,% - масштаб по горизонтали.

Scale y,% - масштаб по вертикали.

Border - в этой группе задаются параметры границы текста.

Outline - контур вокруг букв.

Opaque box - непрозрачный прямоугольник, поверх которого будет расположен текст.

Border width - ширина границы.

Shadow depth - глубина (фактически, смещение от основных символов) тени.

Screen Aligment & Margins - задается положение субтитров и отступы от краев экрана (в пикселах). Если планируется просматривать фильм на телевизоре, то возможно, придется увеличить эти значения.

Colors & Transparency - задает цвета и прозрачность. Можно задать параметры для первичного и вторичного цвета, границы и тени. При нажатии на цветные квадраты появляется стандартный диалог для выбора цвета. Расположенные рядом бегунки изменяют прозрачность соответствующего цвета.

Link alpha channels - при установке опции прозрачность для всех параметров будет одинакова и будет меняться одновременно.


Вкладка "Subtitles"

На этой вкладке можно настроить основные параметры субтиров.

Override Placement - по-умолчанию, Media Player Classic располагает субтитры в позиции 50% от левого края (т.е. в центре) и 90% сверху. Если вы хотите расположить их в другом месте, установите эту галку и выберите нужное положение.

Number of subpictures to buffer ahead - количество кешируемых страниц субтитров, по-умолчанию - 3. Установка 0 отключает кеширование (не рекомендуется, возможны "провалы" и звдержки в отображении). Требует перезагрузки видеофайла.

Maximum texture resolution - для отображения субтитров Media Player Classic использует возможности рендеринга DirectX7 или выше (VMR7 или VMR9). Фактически, текстовые субтитры преобразуются в картинку (текстуру), которая потом, при помощи Direct3D-видеокарты, аппаратно накладывается на изображение. Таким образом, скорость обработки субтитров напрямую зависит от мощности процессора. Если мощности процессора не хватает, снизьте разрешение текстуры. Опция также требует перезагрузки видеофайла.


Вкладка "Tweaks"

На вкладке задаются некоторые дополнительные опции для тонкой настройки.

Don't use XP-theming on the player controls - запрещает использование тем Windows XP, даже если их использование в системе включено. Всем противникам закругленных окошек посвящается :) Опция требует перезапуска программы.

Use the WM ASF reader for Windows Media files - опция, позволяющая проматывать ASF и WMV файлы с большей скоростью. Однако, если файл неполный (например, недокачанный), то перемотка не будет работать совсем :(

Jump distances - перемотка в плеере может производиться дискретно с клавиатуры или пульта ДУ. Всего возможно три варианта перехода: маленький, средний и большой, отличающихся длительностью. По-умолчанию, длительности перехода 1000, 5000 и 20000 мс соответственно. Кнопкой "Default" можно вернуть стандартные значения.


Вкладка "Web Interface"

На этой вкладке находятся настройки web-интерфейса. И пока что это самая маленькая вкладка. Начиная с версии 6.4.6.8 Media Player Classic имеет небольшой встроенный web-сервер. Его назначение мне пока не совсем ясно. Но, например, можно управлять плеером дистанционно по локальной сети. Возможно, еще что-нибудь. Надеюсь, в будущем этот вопрос прояснится.

Listen on port - задается порт, который плеер будет "слушать" в ожидании команд. После включения сервера обращаться к нему (при настройках, показанных на картинке) можно по адресу localhost:13579 (либо 127.0.0.1:13579) или обратиться с другого компьютера по адресу машины, где установлен плеер, например 192.168.0.1:13579.

Launch in web browser... - запускает браузер, установленный в системе по-умолчанию и открывает в нем адрес своего сервера. Пока сервер выглядит так:

При выборе команды из списка и нажатии кнопки "Go!" плеер выполняет заданную команду. Есть также две ссылки "The file browser!" и "The media player intrface!". Первая открывает файловый браузер, где можно выбрать файл с диска, вторая - web-интерфейс для управления плеером.

Внимание! Если вы уже открывали интерфейс в предыдущих версиях плеера, возможно, вам придется полностью обновить страницу, чтобы увидеть изменения (например, в Internet Explorer для этого надо нажать Ctrl-F5).

Enable compression - включает GZIP-сжатие данных для снижения трафика.

Print debug info - включает показ отладочной информации (HTTP-заголовки, cookie и т.д.)


Список воспроизведения (плейлист)

Надо признать, что сейчас работа с плейлистами в Media Player Classic реализована не самым лучшим образом. Тем не менее, свои функции она выполняет. Чтобы открыть окно работы с плейлистами, выберите пункт меню View → Playlist или нажмите комбинацию клавиш Ctrl+7. Откроется примерно такое окно:

Окно можно прикреплять к другим сторонам окна программы, а можно вынести за его пределы и отделить совсем.

Добавить элементы в список можно через главное меню File → Open File... или просто бросив на окно программы из файлового менеджера. Перемещение элемента в списке осуществляется его простым перетаскиванием.

В контекстном меню также есть несколько пунктов для работы с элементами плейлиста.

Open - невзирая на то, что она "Open", эта кнопка начинает воспроизведение выбранного элемента.

Remove From List - убирает элемент из списка.

Copy path to clipboard - копирует путь элемента в буфер обмена.

Save Playlist - сохраняет список в одном из поддерживаемых форматов.

Sort by label - сортирует элементы по названию.

Sort by path - сортирует элементы по пути.

Randomize - перемешивает элементы в случайном порядке.

Restore - функция, обратная Randomize.


Ресинхронизация субтитров

Довольно специализированная функция, но для любителей просмотра фильмов с оригинальным звуком и субтитрами она может оказаться просто незаменимой. Скажу честно: мне этой функцией пользоваться не приходилось, поэтому описание краткое и неполное. После вызова функции из меню открывается такое окно (пример на основе субтитров для фильма "Мышиная охота"):

При двойном клике на строке списка MPC переходит к кадру, с которого начинается отображение данной реплики. Красным цветом выделяются активные реплики.

Контекстное меню различается на разных ячейках строки. Для всех строк есть только три общих пункта:

Separator - вставляет разделитель (вот только зачем?..)

Dupliсate - дублирует строку и все ее атрибуты. Это может понадобиться для создания продвинутых субтитров, когда два актера говорят одновременно, их реплики также отображаются одновременно, но их визуальный стиль может быть различным.

Delete - удаляет строку.

При клике на строках "Time" и "End" появляются пункты:

Current - устанавливает текущее время в фильме для выбранной реплики.

Original - возвращает оригинальное время для выбранной реплики.

Reset - назначение неясно.

В колонке "Style" задается стиль для текущей реплики. Список всех доступных стилей находится в контекстном меню, там же есть пункт "Edit", нажатие на который приводит к открытию окна, в точности повторяющего окно настроек стандартного стиля субтитров, за исключением того, что в нем сверху находятся вкладки с названием доступных стилей. Переходя по этим вкладкам можно редактировать каждый из стилей.

Колонки "Font" и "CharSet" чисто информационные, в них показываются шрифт и кодировка для реплики (задаются эти параметры в редакторе стилей). Они могут различаться, например, реплики на русском и французском будут иметь свои кодировки, и символы с одинаковым кодом, но разным начертанием будут отображаться правильно. Разумеется, такой вариант возможен только в случае поддержки системой юникода (Win2k/XP).

В колонке "Unicode" появляются две опции: "Yes" и "No", определяющие, юникодовая ли строка, или нет.

В колонке "Layer" можно задавать слой реплики. Это тоже связано с выводом нескольких реплик одновременно, при этом можно иметь перекрывающиеся реплики. В контекстном меню есть пункты "Decrease" и "Increase", соответственно уменьшающие или увеличивающие номер слоя. Слой с бОльшим номером будет располагаться поверх слоев более низкими номерами.

Actor - по-видимому, это просто своего рода комментарий (либо MPC не поддерживает эту функцию), здесь задается актер, произносящий реплику. Тем не менее, в контекстном меню находится список доступных актеров.

Effect - аналогично предыдущему пункту, назначение этого до конца неясно. В контекстном меню список доступных эффектов.

Итак, что же нам всё это дает? На первом скриншоте видно (верхняя половина), что я разделил реплики двух актеров и задал для них разные стили (Default и Yellow), во второй половине показано, как было раньше. Обратите внимание, что таймкод обеих реплик одинаковый. Вот как это выглядит:

Здорово? Я тоже так думаю.

После завершения работы осталось только сохранить результат. Имейте в виду, что сохранение стилей поддерживается только форматом (Advanced) SubStation Alpha (*.ssa, *.ass), для всех остальных форматов стили будут сохранены в отдельный файл с именем субтитров и расширением *.style