Вкладка «Пользовательский DSN»

Используется для добавления, удаления и настройки источников данных с пользовательскими именами источников данных (DSN). Эти источники данных используются на локальном компьютере текущим пользователем.

Элемент управления | Описание
Источники данных пользователя | Список всех пользовательских источников данных, включая все имена и связанные с ними драйверы. После двойного щелчка источника данных откроется диалоговое окно настройки этого источника.
Добавить | Добавление нового источника данных пользователя. После нажатия открывается диалоговое окно Создание нового источника данных. Выберите в нем драйвер, для которого добавляется источник данных пользователя и нажмите кнопку Готово. Будет отображено диалоговое окно настройки соответствующего драйвера.
Удалить | Нажмите эту кнопку, чтобы удалить выбранный источник данных пользователя из списка Источники данных пользователя.
Настройка | Нажмите эту кнопку, чтобы изменить настройки выбранного источника данных пользователя. Откроется диалоговое окно настройки этого источника.
OK | Закрытие диалогового окна Администратор источников данных ODBC. Для сохранения изменений в списке Источники данных пользователя нажимать кнопку OK не требуется. Изменения сохраняются при нажатии кнопки OK в диалоговом окне настройки источника данных.
Отмена | Закрытие диалогового окна Администратор источников данных ODBC. Изменения, внесенные с помощью элементов управления других диалоговых окон, не отменяются.
Справка | Вызов справки.


.topic 902
Список всех пользовательских источников данных, включая все имена и связанные с ними драйверы. После двойного щелчка источника данных откроется диалоговое окно настройки этого источника.

.topic 903
Нажмите эту кнопку, чтобы изменить настройки выбранного источника данных пользователя.

.topic 904
Добавление нового источника данных пользователя.

.topic 905
Удаление выбранного источника данных пользователя.

.topic 910
Список всех системных источников данных, включая все имена и связанные с ними драйверы. После двойного щелчка источника данных откроется диалоговое окно настройки этого источника.

.topic 911
Нажмите эту кнопку, чтобы изменить настройки выбранного системного источника данных.

.topic 912
Добавление нового системного источника данных.

.topic 913
Удаление выбранного системного источника данных.

.topic 915
Список имен всех файловых источников данных и подкаталогов каталога, указанного в поле Папка. После двойного щелчка источника данных откроется диалоговое окно настройки этого источника.

.topic 916
Нажмите эту кнопку, чтобы изменить настройки выбранного файлового источника данных.

.topic 917
Добавление нового файлового источника данных.

.topic 918
Удаление выбранного файлового источника данных.

.topic 919
Нажмите эту кнопку, чтобы каталог, выбранный в поле Папка, использовался по умолчанию при выполнении администратора ODBC.

.topic 920
Каталог, в котором содержатся файловые источники данных и подкаталоги, перечисленные в расположенной ниже области.

.topic 921
Нажмите эту кнопку, чтобы заменить каталог, показанный в поле Папка, на каталог, расположенный на один уровень выше.

.topic 969
Список всех установленных драйверов ODBC с параметрами времени ожидания группировки подключений. Чтобы установить значение этого параметра, дважды щелкните имя драйвера ODBC.

.topic 965
Имя, версия, компания, имя файла, дата выпуска каждого установленного драйвера ODBC.

.topic 924
Задание параметров трассировки для приложения.

.topic 926
Включение непрерывной динамической трассировки, вне зависимости от наличия подключения. Трассировка продолжается до закрытия диалогового окна администратора источников данных ODBC или до нажатия кнопки окончания трассировки. (Надпись изменяется с запуска трассировки на остановку трассировки.)

.topic 923
Включение анализатора Visual Studio. Отслеживание проводится до нажатия кнопки остановки анализатора Visual Studio. (Надпись на кнопке меняется с запуска анализатора на остановку анализатора.)

.topic 927
Путь и имя файла сведений о трассировке. По умолчанию используется файл sql.log.

.topic 968
Выберите путь и имя для файла журнала.

.topic 928
Введите нужный путь и имя файла, чтобы выбрать свой файл библиотеки трассировки .dll.

.topic 929
Обзор структуры каталогов для поиска файла библиотеки трассировки.

.topic 952
Список имен всех файловых источников данных и подкаталогов, содержащихся в каталоге, указанном в поле Папка. Подключение осуществляется по двойному щелчку нужного источника.

.topic 953
Каталог, в котором содержатся файловые источники данных и подкаталоги, перечисленные в расположенной ниже области.

.topic 954
Нажмите эту кнопку, чтобы заменить каталог, показанный в поле Папка, на каталог, расположенный на один уровень выше.

.topic 955
Имя файлового источника данных, выбранного из списка файловых источников данных, или введенное вручную.

.topic 957
Добавление нового файлового источника данных.

.topic 961
Список всех пользовательских и системных источников данных, включая их имена и типы. Подключение осуществляется по двойному щелчку нужного источника.

.topic 970
Отображение времени ожидания (в секундах) для выбранного драйвера.

.topic 974
Задание наблюдения за быстродействием подключений для отладки; влияет на быстродействие приложения.

.topic 971
Включение режима наблюдений за быстродействием подключений.

.topic 972
Выключение режима наблюдений за быстродействием подключений.

.topic 973
Интервал времени в секундах между повторными попытками установки соединения.

.topic 962
Добавление нового источника данных компьютера.


Вкладка «О программе»

Сведения о внутренних компонентах ODBC, включающих диспетчер драйверов, библиотеку курсоров, модуль .dll установки и остальные файлы компонентов.

Элемент управления | Описание
Основные компоненты | Описание, версия, имя и расположение файла каждого из компонентов ODBC.
OK | Закрытие диалогового окна Администратор источников данных ODBC.
Отмена | Закрытие диалогового окна Администратор источников данных ODBC. Изменения, внесенные с помощью элементов управления других диалоговых окон, не отменяются.


Вкладка «Группировка подключений»

Позволяет изменять время между повторами подключений и ожидания подключения для выбранного драйвера при использовании группировки подключений, а также включать и отключать мониторинг быстродействия (запись статистики подключений). Группировка подключений позволяет приложению использовать одно из подключений в группе, не устанавливая его повторно при каждом обращении. После создания подключения и размещения его в группе для его повторного использования приложение не должно выполнять весь процесс подключения, что увеличивает быстродействие.

Элемент управления | Описание
Драйверы ODBC | Для каждого установленного в системе драйвера ODBC определяется допустимое время отсутствия группировки подключений. Чтобы установить значение этого параметра, дважды щелкните имя драйвера ODBC.
Время ожидания группировки подключений | Установка времени ожидания подключения в секундах для выбранного драйвера. Щелкнув дважды имя соответствующего драйвера, можно задать атрибуты группировки соединения. При этом отображается диалоговое окно Атрибуты группировки подключений. В нем можно указать время сохранения неиспользуемых подключений в группе, а также включить группировку подключений для выбранного драйвера.
Включить | Включение счетчиков мониторинга быстродействия для группировки подключений. Дополнительные сведения о мониторинге быстродействия см. в Руководстве программиста по ODBC.
Отключить | Отключение счетчиков мониторинга быстродействия для группировки подключений. Дополнительные сведения о мониторинге быстродействия см. в Руководстве программиста по ODBC.
Повтор через | Время ожидания (в секундах, не более шести знаков), после которого диспетчер драйверов ODBC повторяет попытку подключения к серверу базы данных.
OK | Учет всех изменений, сделанных в окне Администратор источников данных ODBC, и закрытие окна.
Отмена | Закрытие диалогового окна Администратор источников данных ODBC без сохранения сделанных в нем изменений.
Применить | Учет всех изменений, сделанных в окне Администратор источников данных ODBC, без его закрытия.


Вкладка «Файловый источник данных»

Используется для подключения к источнику данных, содержащему имена файловых источников данных. Файловый источник данных не обязательно должен быть назначен конкретному пользователю и располагаться на локальном компьютере, к нему могут получать совместный доступ все пользователи, у которых установлены необходимые драйверы.

Элемент управления | Описание
Файловый источник данных | Список имен всех файловых источников данных и подкаталогов каталога, указанного в поле Папка. Подключение осуществляется по двойному щелчку нужного источника.
Папка | Каталог, в котором содержатся файловые источники данных и подкаталоги, перечисленные в расположенной ниже области. Для просмотра структуры каталогов нажмите стрелку справа от поля ввода.
Значок перехода на один уровень вверх | Нажмите эту кнопку, чтобы заменить каталог, показанный в поле Папка, на каталог, расположенный на один уровень выше.
Имя DSN | Имя файлового источника данных, выбранного в области Файловый источник данных, или введенное вручную.
Создать | Добавление нового файлового источника данных. После нажатия этой кнопки появится диалоговое окно Создание нового источника данных со списком драйверов, в котором следует выбрать драйвер для добавляемого источника данных, а затем нажать кнопку Далее, чтобы указать имя или расположение нового источника данных. Еще раз нажмите кнопку Далее для просмотра общих сведений о новом источнике данных. Для отображения диалогового окна настройки конкретного драйвера нажмите кнопку Готово.
OK | Закрытие диалогового окна Выбора источников данных и подключение к источнику данных, выбранному в текстовом поле Имя DSN. Для сохранения изменений в списке Файловые источники данных нажимать кнопку OK не требуется. Изменения сохраняются при нажатии кнопки OK в диалоговом окне настройки источника данных.
Отмена | Закрытие диалогового окна Выбор источников данных. Подключение к файловому источнику данных не выполняется. Изменения, внесенные с помощью элементов управления других диалоговых окон, не отменяются.


Вкладка «Файловый DSN»

Используется для добавления, удаления и настройки файловых источников данных, которые могут совместно использоваться всеми пользователями, у которых установлены необходимые драйверы. Назначение таких источников данных конкретному пользователю или привязка к локальному компьютеру не производится.

Элемент управления | Описание
Файловые источники данных | Список имен всех файловых источников данных и подкаталогов каталога, указанного в поле Папка. После двойного щелчка источника данных откроется диалоговое окно настройки этого источника.
Добавить | Добавление нового файлового источника данных. После нажатия этой кнопки появится диалоговое окно Создание нового источника данных со списком драйверов, в котором следует выбрать драйвер для добавляемого источника данных, а затем нажать кнопку Далее, чтобы указать имя или расположение нового источника данных. Еще раз нажмите кнопку Далее для просмотра общих сведений о новом источнике данных. Для отображения диалогового окна настройки конкретного драйвера нажмите кнопку Готово.
Удалить | Удаление выбранного файлового источника данных. Перед нажатием данной кнопки следует выбрать имя источника данных в списке.
Настройка | Нажмите эту кнопку, чтобы изменить настройки выбранного файлового источника данных. Перед нажатием данной кнопки следует выбрать имя источника данных в списке. Откроется диалоговое окно настройки этого источника.
Каталог | Нажмите эту кнопку, чтобы каталог, выбранный в поле Папка, использовался по умолчанию при выполнении администратора ODBC.
Папка | Каталог, в котором содержатся файловые источники данных и подкаталоги, перечисленные в расположенной ниже области. Для просмотра структуры каталогов нажмите стрелку справа от поля ввода. Выводимый по умолчанию каталог, который отображался при первом запуске администратора ODBC, указан в сведениях о системе. Чтобы изменить его, нажмите кнопку Каталог.
Значок перехода на один уровень вверх | Нажмите эту кнопку, чтобы заменить каталог, показанный в поле Папка, на каталог, расположенный на один уровень выше.
OK | Закрытие диалогового окна Администратор источников данных ODBC. Для сохранения изменений в списке Файловые источники данных нажимать кнопку OK не требуется. Изменения сохраняются при нажатии кнопки OK в диалоговом окне настройки источника данных.
Отмена | Закрытие диалогового окна Администратор источников данных ODBC. Изменения, внесенные с помощью элементов управления других диалоговых окон, не отменяются.


Вкладка «Источник данных компьютера»

Предназначается для подключения к пользовательскому или системному источнику данных. Совместное использование источников данных компьютера невозможно, поскольку они привязаны к данному компьютеру.

Элемент управления | Описание
Источник данных компьютера | Список всех пользовательских и системных источников данных, включая их имена и типы. Подключение осуществляется по двойному щелчку нужного источника.
Создать | Добавление нового источника данных компьютера. После нажатия этой кнопки появится диалоговое окно Создание нового источника данных со списком драйверов, в котором следует выбрать драйвер для добавляемого источника данных, а затем нажать кнопку Далее, чтобы указать имя или расположение нового источника данных. Еще раз нажмите кнопку Далее для просмотра общих сведений о новом источнике данных. Для отображения диалогового окна настройки конкретного драйвера нажмите кнопку Готово.
OK | Закрытие диалогового окна Выбор источников данных и подключение к выбранному файловому источнику данных. При нажатии этой кнопки изменения, внесенные в список источников данных компьютера, не сохраняются. Изменения сохраняются при нажатии кнопки OK в диалоговом окне настройки источника данных.
Отмена | Закрытие диалогового окна Выбор источников данных. Подключение к файловому источнику данных не выполняется. Изменения, внесенные с помощью элементов управления других диалоговых окон, не отменяются.


Вкладка «Драйверы»

Содержит список установленных на компьютере драйверов ODBC. На этой вкладке не могут выполняться операции. Для добавления и удаления драйверов ODBC используются программы настройки соответствующих драйверов.

Элемент управления | Описание
Драйверы ODBC | Имя, версия, компания, имя файла, дата создания файла каждого драйвера ODBC, установленного в системе.
OK | Закрытие диалогового окна Администратор источников данных ODBC.
Отмена | Закрытие диалогового окна Администратор источников данных ODBC.


Вкладка «Системный DSN»

Используется для добавления, удаления и настройки источников данных с системными именами источников данных (DSN). Эти источники хранятся на локальном компьютере, но не назначаются конкретным пользователям; доступ к ним может получить любой пользователь с необходимыми правами.

Элемент управления | Описание
Системные источники данных | Список всех системных источников данных, включая все имена и связанные с ними драйверы. После двойного щелчка источника данных откроется диалоговое окно настройки этого источника.
Добавить | Добавление нового системного источника данных. После нажатия открывается диалоговое окно Создание нового источника данных. Выберите в нем драйвер, для которого добавляется системный источник данных и нажмите кнопку Готово. Будет отображено диалоговое окно настройки соответствующего драйвера.
Удалить | Нажмите эту кнопку, чтобы удалить выбранный системный источник данных из списка Системные источники данных.
Настройка | Нажмите эту кнопку, чтобы изменить настройки выбранного системного источника данных. Открытие диалогового окна настройки существующего системного источника данных. Перед нажатием данной кнопки следует выбрать имя источника данных в списке.
OK | Закрытие диалогового окна Администратор источников данных ODBC. Для сохранения изменений в списке Системные источники данных нажимать кнопку OK не требуется. Изменения сохраняются при нажатии кнопки OK в диалоговом окне настройки источника данных.
Отмена | Закрытие диалогового окна Администратор источников данных ODBC. Изменения, внесенные с помощью элементов управления других диалоговых окон, не отменяются.


Вкладка «Трассировка»

Позволяет определить способ отслеживания вызовов функций ODBC диспетчером драйверов. Диспетчер драйверов может отслеживать вызовы постоянно или только для одного подключения; отслеживание может вестись динамически и с помощью какой-нибудь другой библиотеки .dll.

Элемент управления | Описание
Начать трассировку/Закончить трассировку (переключатель) | Включение непрерывной динамической трассировки, вне зависимости от наличия подключения. Трассировка продолжается до закрытия диалогового окна Администратор источников данных ODBC или до нажатия кнопки Закончить трассировку.
Запустить анализатор Visual Studio/Остановить анализатор Visual Studio (переключатель) | Включение анализатора Visual Studio. Отслеживание проводится до нажатия кнопки Остановить анализатор Visual Studio. Анализатор Visual Studio - средство, предназначенное для отладки и анализа распределенного приложения. Дополнительные сведения об анализаторе Visual Studio см. в документации в библиотеке MSDN.
Путь к файлу журнала | Путь и имя файла сведений о трассировке. Могут использоваться путь и файл (\sql.log), предлагаемые по умолчанию файл, но их можно изменить, введя вручную новый путь и имя файла, либо выбрав файл из списка с помощью кнопки Обзор.
Обзор | Выбор файла журнала в списке каталогов системы.
Библиотека трассировки | Выбор файла .dll для трассировки. По умолчанию используется файл Odbctrac.dll. Для этого следует ввести путь и имя файла .dll или либо выбрать его из списка с помощью кнопки Выбор DLL. Поставляемый в комплекте MDAC SDK файл Odbctrac.dll можно заменить другим файлом .dll по вашему выбору.
Выбор DLL | Поиск файла библиотеки отслеживания в списке каталогов. Путь и имя выбранного файла .dll отображаются в текстовом поле Библиотека трассировки.
OK | Сохранение изменений в полях Путь к файлу журнала и Библиотека трассировки и закрытие диалогового окна Администратор источников данных ODBC.
Отмена | Закрытие диалогового окна Администратор источников данных ODBC без сохранения сделанных в нем изменений.
Применить | Учет всех изменений, сделанных в окне Администратор источников данных ODBC, без его закрытия.


Диалоговое окно «Выбор транслятора»

В диалоговом окне Выбор транслятора содержится список установленных файлов .dll для трансляции. В нем может быть выбран один из этих файлов, позволяющих драйверу преобразовывать данные из одного набора знаков в другой. Данные в приложении и в источнике данных часто хранятся в разных наборах знаков. В ODBC имеется общий механизм, позволяющий драйверу преобразовывать данные из одного набора знаков в другой.

После указания файла .dll для трансляции он загружается драйвером и вызывается для преобразования всех данных, передаваемых между приложением и источником данных. Преобразуются знаки всех SQL-выражений и параметров, отправляемых в источник данных, а также всех результатов, метаданных (например имен столбцов) и сообщений об ошибках, загружаемых из источника данных. Данные подключения не преобразуются, поскольку .dll для трансляции загружается только после подключения приложения к источнику данных.

Файлы .dll для трансляции, внедряющие функции трансляции SQLDriverToDataSource и SQLDataSourceToDriver, которые вызываются драйвером, могут создаваться разработчиком приложения, разработчиком приложения или сторонним разработчиком.

Дополнительные сведения о файлах .dll для трансляции см. в Руководстве программиста по ODBC.