Краткое руководство по сетевому администрированию

Подготовка к развертыванию
Руководство сетевого администратора по AutoCAD 2009 >
Краткое руководство по сетевому администрированию

Сетевое развертывание этой программы должно быть тщательно спланировано и выполнено аккуратно. В данном разделе приводится краткое описание процедур подготовки развертывания, настройки сервера лицензий, настройки и распространения программы.

При отсутствии опыта администрирования и развертывания сети перед развертыванием и настройкой программы в сети следует внимательно прочитать Руководство сетевого администратора.

Темы в этом разделе

  • Подготовка к развертыванию
  • Настройка сервера лицензий
  • Настройка и распространение программы
  • Функции, для которых требуется программа Design Review
Отправьте ваши комментарии по поводу этой страницы


Подготовка к развертыванию

Краткое руководство по сетевому администрированию
Краткое руководство по сетевому администрированию
Выбор варианта установки
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию >
Подготовка к развертыванию

Для подготовки к развертыванию необходимо выбрать тип установки и модель сервера лицензий.

Темы в этом разделе

  • Выбор варианта установки
  • Выбор модели сервера лицензий


Выбор варианта установки

Подготовка к развертыванию
Подготовка к развертыванию
Выбор модели сервера лицензий
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Подготовка к развертыванию >
Выбор варианта установки

Вариант установки необходимо выбрать во время настройки параметров развертывания. В окне Мастера установки AutoCAD 2009 необходимо задать один из следующих вариантов установки:

Установка c сетевой лицензией

При этом программа устанавливается на рабочие станции вместе с файлами и параметрами реестра, которые обеспечивают взаимодействие с Диспетчером сетевых лицензий Network License Manager. В программе Network License Manager можно разрешить доступ к лицензиям. Для работы программы после ее сетевой установки на рабочую станцию не требуется индивидуальная активация. Лицензии на программу распределяются, по крайней мере, с одного сервера.

Основным преимуществом является возможность установки AutoCAD на большем количестве компьютеров, чем число приобретенных лицензий (например, приобретая 25 лицензий, можно установить программный продукт на 40 рабочих станциях). В любой момент AutoCAD может быть запущена на максимальном количестве систем, для которых имеются лицензии. Это означает, что полученная лицензия является плавающей.

Установка отдельной версии на несколько рабочих мест (локальная лицензия)

Этот тип установки используется для однопользовательской установки, когда один серийный номер используется для нескольких рабочих мест. При установке отдельной версии на несколько рабочих мест нельзя использовать Network License Manager для управления лицензиями на использование программы; однако для создания установочных образов и организации развертывания можно все же использовать Мастер установки AutoCAD 2009. Процедура регистрации и активации отдельной версии на несколько рабочих мест является более автоматизированной. После первой активации с помощью серийного номера для однопользовательской установки на несколько рабочих мест активация выполняется автоматически для всех рабочих станций в зависимости от развертывания, если эти рабочие станции подключены к Интернету.

Однопользовательская установка (локальная лицензия)

Этот тип установки следует выбирать для однопользовательской установки, когда один серийный номер используется для одного рабочего места. Как и в случае однопользовательской установки на несколько рабочих мест, для управления лицензией на использование программы при данном типе установки нельзя использовать Network License Manager, но установка, регистрация и активация происходит на каждой рабочей станции.

Более подробную информацию о типах установки с локальной лицензией см. в разделе Настройка и распространение программы.


Выбор модели сервера лицензий

Выбор варианта установки
Подготовка к развертыванию
Настройка сервера лицензий
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Подготовка к развертыванию >
Выбор модели сервера лицензий

Если выбран вариант сетевой установки продукта, следует выбрать модель сервера лицензий для распространения лицензий.

СоветВ случае развертывания однопользовательской установки или однопользовательской установки на несколько рабочих мест модель сервера лицензий не и используется. См. раздел Настройка и распространение программы.

При сетевой установке доступны следующие модели серверов лицензий:

  • Модель с одним сервером лицензий. Network License Manager (Диспетчер сетевых лицензий) устанавливается на одном сервере, на котором и осуществляется вся деятельность по управлению лицензиями. Все лицензии, доступные на сервере, представлены в едином файле лицензий.
  • Модель с несколькими серверами лицензий. Для управления лицензиями используется несколько серверов. Для каждого сервера необходим собственный уникальный файл лицензий. Для создания нескольких серверов лицензий необходимо запустить Network License Manager на каждом из серверов, входящих в серверный пул.
  • Модель с резервными серверами лицензий.Для работы с единственным файлом лицензий используются три сервера. Один из них является основным, а два других — резервными, используемыми при сбое основного сервера. В этой конфигурации выдача лицензий не прекращается, если функционируют хотя бы два из этих трех серверов. Файл лицензий одинаков на всех трех серверах. На каждом из серверов необходимо установить Network License Manager.

Каждая из моделей серверов лицензий подробно описана в Руководстве по сетевому лицензированию. Настоятельно рекомендуется ознакомиться с этим руководством перед развертыванием программы. С текстом Руководства по сетевому лицензированию можно ознакомиться, перейдя по ссылке "Документация" в левом нижнем углу окна Мастера установки AutoCAD 2009 или в справочной системе программы.


Настройка сервера лицензий

Выбор модели сервера лицензий
Краткое руководство по сетевому администрированию
Установка программы Network License Manager
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию >
Настройка сервера лицензий

Если планируется работа пользователей с сетевыми лицензиями на программный продукт, следует воспользоваться Диспетчером сетевых лицензий Network License Manager и программой активации сетевой лицензии.

Диспетчер сетевых лицензий Network License Manager служит для настройки серверов лицензий и управления ими. Программа активации сетевой лицензии позволяет получать и регистрировать лицензии через Интернет.

Темы в этом разделе

  • Установка программы Network License Manager
  • Установка и использование программы активации сетевой лицензии
  • Настройка сервера лицензий


Установка программы Network License Manager

Настройка сервера лицензий
Настройка сервера лицензий
Установка и использование программы активации сетевой лицензии
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Настройка сервера лицензий >
Установка программы Network License Manager

Network License Manager служит для настройки серверов лицензий и управления ими.

Для установки Network License Manager

  1. В окне Мастера установки AutoCAD 2009 нажмите кнопку "Install Tools and Utilities" (Установка инструментов и утилит).
  2. На странице "Select the Products to Install" ("Выберите устанавливаемые программы") выберите Autodesk Network License Manager и нажмите "Next" (Далее).
  3. Прочитайте лицензионный договор на использование программных средств Autodesk для вашей страны или области. Для продолжения установки необходимо принять условия договора. Выберите страну или область, нажмите "I Accept" (Принимаю) и нажмите "Next" (Далее).
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  4. На странице "Review - Configure - Install" (Обзор - Настройка - Установка) проверьте данные о выборе продукта и текущие настройки. Если вносить какие-либо изменения нет необходимости, нажмите "Install" (Установить). Если необходимо изменить вариант установки или путь к программе, нажмите "Configure" (Настройка).
  5. На странице "Select the Installation Type" (Выбор варианта установки) выберите вариант "Typical" (Типовая) или "Custom" (Выборочная) и примите путь к программе, принятый по умолчанию (C:\Program Files\Autodesk Network License Manager\) или нажмите "Browse" (Обзор), чтобы указать другой путь. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажмите "Next" (Далее).
    ПредупреждениеNetwork License Manager не может быть установлен на сетевом диске. Папка для установки Network License Manager должна быть локальной. Необходимо явно указывать букву имени диска; формат универсального именования (UNC) здесь не подходит.
  6. На странице "Configuration Complete" (Настройка завершена) нажмите кнопку "Configuration Complete" (Настройка завершена), чтобы вернуться на страницу подтверждения.
  7. На странице "Review - Configure - Install" (Обзор - Настройка - Установка) нажмите "Install" (Установка).
  8. После вывода на экран страницы "Installation Complete" (Завершение установки) нажмите кнопку "Finish" (Готово).


Установка и использование программы активации сетевой лицензии

Установка программы Network License Manager
Настройка сервера лицензий
Настройка сервера лицензий
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Настройка сервера лицензий >
Установка и использование программы активации сетевой лицензии

Программа активации сетевой лицензии служит для получения лицензий через Интернет. Тем самым экономятся время и силы, затрачиваемые на подготовку программы к работе в сетевой среде. Кроме того, утилита позволяет зарегистрировать программу, получить поддержку по электронной почте (в случаях, когда не удается получить лицензию через Интернет), а также автоматически сохранять и переносить файлы лицензий.

Для установки программы активации сетевой лицензии

  1. В окне Мастера установки AutoCAD 2009 нажмите кнопку "Install Tools and Utilities" (Установка инструментов и утилит).
  2. На странице "Select the Products to Install" (Выберите устанавливаемые программы) выберите Autodesk Network License Manager и нажмите "Next" (Далее).
  3. Прочитайте лицензионный договор на использование программных средств Autodesk для вашей страны или области. Для продолжения установки необходимо принять условия договора. Выберите страну или область, нажмите "I Accept" (Принимаю) и нажмите "Next" (Далее).
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  4. На странице "Review - Configure - Install" (Обзор - Настройка - Установка) проверьте данные о выборе продукта и текущие настройки. Если вносить какие-либо изменения нет необходимости, нажмите "Install" (Установка). Если необходимо изменить вариант установки или путь к программе, нажмите "Configure" (Настройка).
  5. На странице "Select the Installation Type" (Выбор варианта установки) выберите вариант "Typical" (Типовая) или "Custom" (Выборочная) и примите путь к программе, принятый по умолчанию (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility\enu\) или нажмите "Browse" (Обзор), чтобы указать другой путь. Если папка с указанным пользователем именем не существует, Мастер создает ее. Нажмите "Next" (Далее).
  6. На странице "Configuration Complete" (Настройка завершена) нажмите кнопку "Configuration Complete" (Настройка завершена), чтобы вернуться на страницу подтверждения.
  7. На странице "Review - Configure - Install" (Обзор - Настройка - Установка) нажмите "Install" (Установка).
  8. После вывода на экран страницы "Installation Complete" (Завершение установки) нажмите кнопку "Finish" (Готово).

Для использования программы активации сетевой лицензии

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] Autodesk [image] Network License Manager [image] AutoCAD 2009 "Программа активации сетевой лицензии".
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) ознакомьтесь с принципами работы утилиты и системными требованиями к ее использованию. Затем нажмите "Next" (Далее).
  3. На странице "Server Information" (Сведения о сервере) введите серийный номер продукта.
    ПримечаниеВ случае изменения существующего файла лицензии или получения новой лицензии для существующего продукта может отобразиться ранее введенная информация. Убедитесь, что отображается именно тот серийный номер, который необходимо лицензировать. Если это не так, введите правильный серийный номер.
  4. В разделе "License Server Model" (Модель сервера лицензий) выберите модель сервера лицензий. Более подробную информацию об имеющихся вариантах модели можно узнать, нажав на кнопку с вопросительным знаком.
  5. В поле "Server Host Name" (Имя хоста) введите имя хоста сервера или воспользуйтесь кнопкой [...] для получения имен из сети.
  6. Для каждого имени хоста, введенного на предыдущем этапе, заполните поле "Host ID" (ID хоста) с помощью кнопки " Lookup" (Выбрать) или введите значения вручную.
    ПримечаниеЕсли на сервере установлено несколько сетевых адаптеров, необходимо выбрать тот из них, который соответствует физическому устройству. Чтобы определить, какие адаптеры являются физическими, в командной строке Windows введите ipconfig/all и просмотрите содержание поля "Description" (Описание), расположенного выше каждого физического адреса. Если физических сетевых адаптеров несколько, можно использовать любой из них; для этого необходимо, чтобы его имя выводилось в список командой ipconfig /all. Логические устройства (VPN-адаптеры, PPP-адаптеры, модемы и др.) могут также попасть в указанный выше список, но для работы с лицензиями не годятся.
  7. Если в пункте 4 было выбрано "Distributed Server" (Распределенный сервер), появляется поле "Seats" (Рабочие места). В этом поле нужно ввести количество рабочих мест, обслуживаемых каждым сервером лицензий, а затем нажать кнопку "Next" (Далее).
  8. На странице "Confirm Server Information" (Подтверждение сведений о сервере) просмотрите введенную информацию и нажмите "Next" (Далее).
  9. Если отобразится страница "Register and License Your Autodesk Product" (Регистрация продукта Autodesk и получение лицензии на него), выполнить следующие действия, после чего нажмите кнопку "Next" (Далее).
    • Для параметра "This Product Is To Be Registered To" (Регистрация продукта выполняется на) установите значение "Company" (Организация) или "Individual" (Частное лицо).
    • В поле "Select Country or Region" (Выбор страны или территории) выберите страну или территорию проживания.
    • Установите опцию "Is This an Upgrade" (Продукт обновляется с прежней версии) в положение "Yes" (Да) или "No" (Нет).
  10. Если отобразится страница "Registration Information" (Регистрационные данные), введите пользовательские регистрационные данные и нажмите "Next" (Далее).
  11. Если отобразится страница "Confirm Information" (Подтверждение данных), проверьте регистрационные данные и нажмите "Next" (Далее).
  12. Если отобразится страница "Connecting" (Связь с Интернетом), нажмите "Next" (Далее), чтобы подключиться к Интернету и получить сетевую лицензию.
  13. На странице "Полученные лицензии" введите имя папки для сохранения файла лицензии в поле "Сохранить файл лицензий для [computer name] в" или найдите ее на диске с помощью кнопки "Обзор".
    ПримечаниеРекомендуется сохранять файл лицензий там же, где установлен Network License Manager.
  14. Если уже имеется файл лицензий от другого продукта Autodesk, выберите одну из следующих опций:
    • Вставить информацию о новой лицензии в него. Информация о новой лицензии добавляется в существующий файл лицензий.
    • Заменить существующий файл лицензий. Выполняется полная замена содержимого существующего файла лицензий на информацию о новой лицензии. Этот параметр следует выбирать только в том случае, если все остальные лицензии в файле действительно больше не нужны.
  15. Нажмите "Next" (Далее).
  16. На странице "Активация лицензии успешно выполнена" нажмите кнопку "Печать", чтобы вывести информацию о лицензии на печать, или нажмите "Готово" для завершения групповой операции и выхода из программы активации сетевой лицензии.


Настройка сервера лицензий

Установка и использование программы активации сетевой лицензии
Настройка сервера лицензий
Настройка и распространение программы
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Настройка сервера лицензий >
Настройка сервера лицензий

Настройка сервера лицензий осуществляется таким образом, чтобы можно было управлять лицензиями на продукт Autodesk, полученными с помощью программы активации сетевой лицензии. Для настройки параметров сервера используется утилита lmtools.exe.

Для настройки параметров сервера лицензий

Для работы с утилитой LMTOOLS необходимо войти в систему с правами администратора.

  1. Выполните одно из следующих действий:
    • Выберите меню "Пуск" (Windows XP и 2000) [image] "Все программы" (или "Программы") [image] Autodesk [image] Network License Manager [image] LMTOOLS.
    • Щелкните правой кнопкой мыши на значке LMTOOLS (Windows Vista) на рабочем столе и выберите "Run As Administrator" (Запустить с правами администратора).
  2. На вкладке "Service/License File" (Службы/Файлы лицензии) программы Lmtools установите переключатель в положение "Configure Using Services" (Настроить, используя службы).
  3. Перейдите на вкладку "Config Services" (Настроить службу).
  4. На вкладке "Config Services" (Настроить службу) в списке "Service Name" (Имя службы) выберите службу или выполните одно из следующих действий:
    • Убедитесь, что в списке выбрана именно та служба, которую предполагается использовать для управления лицензиями.
    • Если список пуст, ввести имя службы, которую предполагается использовать для управления лицензиями.
    ПримечаниеЕсли для управления лицензиями имеется несколько поставщиков программного обеспечения, использующего FLEXlm®, в списке "Service Name" (Имя службы) отображается несколько опций.
  5. В поле "Path to Lmgrd.exe File" (Путь к файлу Lmgrd.exe) задайте путь к демону Network License Manager (lmgrd.exe) или найдите его с помощью кнопки "Browse" (Обзор).

    По умолчанию этот демон устанавливается в папку \Program Files\Autodesk Network License Manager.

  6. В поле "Path to the License File" (Путь к файлу лицензий) введите путь к файлу лицензий или найдите его с помощью кнопки "Browse" (Обзор).
  7. В поле "Path to the Debug Log File" (Путь к файлу отладочного журнала) введите путь, по которому формируется отладочный журнал, или найдите существующий журнал с помощью кнопки "Browse" (Обзор).
  8. Для запуска lmgrd.exe в качестве службы установите флажок "Use Services".
  9. Для автоматической загрузки lmgrd.exe при запуске системы установите флажок "Start Server at Power Up".
  10. Для сохранения настроек с именем, заданным в пункте 4, нажмите кнопку "Save Service" (Сохранить службу). Затем нажмите "Да".
  11. Перейдите на вкладку "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз).
  12. На вкладке "Start/Stop/Reread" (Запустить/Остановить/Прочитать еще раз) выполните одно из следующих действий:
    • Если службы для продуктов Autodesk еще не созданы, нажмите кнопку "Start Server" (Запустить сервер) для запуска сервера лицензий.
    • Если служба для продукта Autodesk уже создана и запущена, нажмите кнопку "ReRead" (Прочитать еще раз) для обновления Network License Manager всеми изменениями, внесенными в файл лицензий или параметров.

      Сервер лицензий запускается и готов обрабатывать запросы клиентов.

  13. Закройте lmtools.exe.


Настройка и распространение программы

Настройка сервера лицензий
Краткое руководство по сетевому администрированию
Создание общего сетевого ресурса
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию >
Настройка и распространение программы

После подготовки к развертыванию и запуска программы Network License Manager и программы активации сетевой лицензии можно приступить к настройке и распространению этой программы с помощью Мастера сетевой установки AutoCAD 2009 с учетом выбора способа развертывания.

Темы в этом разделе

  • Создание общего сетевого ресурса
  • Использование Мастера установки для настройки развертывания
  • Развертывание этой программы


Создание общего сетевого ресурса

Настройка и распространение программы
Настройка и распространение программы
Использование Мастера установки для настройки развертывания
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Настройка и распространение программы >
Создание общего сетевого ресурса

Общий сетевой ресурс представляет собой папку установки, доступную для пользователей компьютеров в сети. О местоположении папки пользователям сообщается при установке программы. Создайте сетевую папку с общим доступом, которая будет использоваться Мастером развертывания AutoCAD 2009 при создании развертывания на компьютере-клиенте.

ПримечаниеВ случае создания образов развертывания необходимо установить уровень прав "Full Control" (Полный доступ) для папки общего доступа. Права на чтение необходимы для доступа к общему сетевому ресурсу и административным правам на рабочей станции, на которой выполнено развертывание программы.

Для создания общего сетевого ресурса

  1. На рабочем столе сетевого сервера нужно создать папку с именем Autodesk.
  2. Щелкните правой кнопкой мыши на папке Autodesk и выберите пункт "Share and Security" (Общий доступ и безопасность) (или "Sharing" (Общий доступ)).
  3. В диалоговом окне "Properties" (Свойства) <имя папки> на вкладке "Sharing" (Общий доступ) выберите параметр "Share This Folder" (Открыть общий доступ к этой папке).
  4. Установите имя папки (Share Name), например,AutodeskилиMyDeployments, если это необходимо.
  5. Нажмите кнопку "Permissions" (Права доступа). В диалоговом окне "Permissions" (Права доступа) нужно проверить, что установлен флажок "Full Control" (Полный доступ). Нажмите "ОК".

    Если используется ОС Vista, щелкните правой кнопкой мыши на папке Autodesk и выберите пункт "Share" (Общий доступ). В диалоговом окне "Properties" (Свойства) выберите "Sharing" (Общий доступ) и затем "Advanced Sharing" (Дополнительные параметры общего доступа). Нажмите кнопку "Permissions" (Права доступа) и убедитесь в том, что флажок "Full Control" (Полный доступ) установлен. Нажмите "ОК".

    Эти действия имеют большое значение для процесса создания образа развертывания.

  6. Для закрытия диалогового окна "Properties" (Свойства) нажмите "OK" или "Close" (Закрыть).
  7. Для каждого устанавливаемого продукта создайте вложенную папку в папке Autodesk. Имя каждой папки должно совпадать с соответствующим именем продукта.


Использование Мастера установки для настройки развертывания

Создание общего сетевого ресурса
Настройка и распространение программы
Развертывание этой программы
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Настройка и распространение программы >
Использование Мастера установки для настройки развертывания

Имеется возможность создать развертывание непосредственно из Мастера установки AutoCAD 2009. На основе созданного развертывания пользователи могут установить программу на свои компьютеры.

ПримечаниеПриведенная ниже процедура показывает один из путей, с помощью которого можно настроить развертывание. Приводится описание процедуры сетевого развертывания с одним сервером для типовой клиентской установки без адаптаций. Дополнительную информацию по установке развертывания см. в разделе Использование Мастера установки для настройки развертывания .

Использование Мастера установки для создания развертывания с параметрами по умолчанию

  1. В окне Мастера установки AutoCAD 2009 нажать кнопку "Создание развертываний".
  2. На странице "Begin Deployment" (Начало развертывания) должно быть указано следующее: папка установочного образа, имя развертывания и какая (32-разрядная или 64-разрядная) операционная система станет целевой системой.
    • В поле "Administrative image" (Установочный образ) введите имя существующей сетевой папки с общим доступом, в которой будет создан установочный образ, или нажмите кнопку "Browse" (Обзор) для выбора сетевой папки с общим доступом. Из этой папки пользователи будут устанавливать программу на свои рабочие станции.
      ПримечаниеПодробную информацию о создании общих сетевых ресурсов см. в разделе Создание общего сетевого ресурса.
    • В поле "Deployment name" (Имя развертывания) введите имя нового развертывания. Это имя будет присвоено ярлыку, с помощью которого пользователи будут устанавливать продукт.
    • В группе "This Is To Be A" (Платформа) выберите разрядность целевой операционной системы (32-разрядная или 64-разрядная). Этот выбор относится не к системе, в которой развертывание было создано, а определяет целевую систему.

    Нажмите "Next" (Далее).

  3. На странице "Select the Products to Include in the Deployment" (Выберите программы, включаемые в развертывание) выберите программы, подлежащие развертыванию, и нажмите "Next" (Далее).
    ПримечаниеAutoCAD Design Review 2009 не устанавливается по умолчанию при установке AutoCAD. Для правильного выполнения некоторых функций AutoCAD требуется установка программы Design Review. Программа Design Review - это программа просмотра, являющаяся заменой программы DWF Viewer. Подробные сведения о функциях, на которые оказывает влияние эта программа, см. в разделе Функции, для которых требуется программа Design Review.
  4. Прочитайте лицензионный договор на использование программных средств Autodesk для вашей страны или области. Для продолжения установки необходимо принять условия договора. Выберите страну или область, нажмите "I Accept" (Принимаю) и нажмите "Next" (Далее).
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  5. На странице "Product and User Information" (Информация о программе и сведения о пользователе) введите серийный номер и сведения о пользователе и нажмите "Next" (Далее).
    ВниманиеВведенные сведения не могут быть изменены в дальнейшем. Просмотреть их можно в окне AutoCAD 2009, которое вызывается с помощью Обозревателя меню [image] "Справка" [image] "О программе". Так как изменить эту информацию можно только путем переустановки программы, необходимо сразу же удостовериться, что вводимые данные верны.
  6. На странице "General Deployment Settings" (Общие параметры развертывания) укажите, следует ли при развертывании создать сетевой и/или клиентский журнал, запустить развертывание по клиентам в недиалоговом режиме и должны ли пользователи участвовать в Программе вовлечения пользователей.
    • Если было выбрано создание файла журнала сетевой установки, также необходимо определить, где будет создан журнал, задав UNC-имя (универсальное соглашение об именовании) или жестко заданный сетевой путь в данной сети. Файл сетевого журнала использовать не обязательно.
      ПримечаниеСетевой журнал должен располагаться в общедоступной сетевой папке. Пользователи, устанавливающие программу, должны иметь разрешение на изменение файлов в этой папке. При отсутствии такого разрешения запись в файл журнала невозможна.
    • Выберите, нужно ли создавать файл журнала на компьютере-клиенте.
    • Для предотвращения изменения настроек программы пользователями в процессе ее установки выберите недиалоговый режим.
    • Если выбрано участие в Программе вовлечения пользователей, Autodesk высылает пользователям полезные сведения о данном программном продукте.

    Более подробную информацию о файлах журнала см. в разделе Указание пути к файлу журнала.

    Нажмите "Next" (Далее).

  7. На странице "Review - Configure - Create Deployment" (Просмотр - Настройка - Создание развертывания) нажать кнопку "Configure" (Настройка).

    При нажатии кнопки "Create Deployment" (Создание развертывания) в папке с общим доступом создается установочный образ на основе опций развертывания, перечисленных в поле "Current Settings" (Текущие параметры).

  8. На странице "Deployment Complete" (Развертывание завершено) нажмите кнопку "Finish" (Готово).

Использование Мастера установки для создания сконфигурированного развертывания

  1. В окне Мастера установки AutoCAD 2009 нажмите кнопку "Create Deployments" (Создать развертывания).
  2. На странице "Begin Deployment" (Начало развертывания) должно быть указано следующее: папка установочного образа, имя развертывания и какая (32-разрядная или 64-разрядная) операционная система станет целевой системой.
    • В поле "Administrative Image" (Установочный образ) введите имя существующей сетевой папки с общим доступом, в которой будет создан установочный образ, или нажмите кнопку "Browse" (Обзор) для выбора сетевой папки с общим доступом. Из этой папки пользователи будут устанавливать программу на свои рабочие станции.
      ПримечаниеПодробную информацию о создании общих сетевых ресурсов см. в разделе Создание общего сетевого ресурса.
    • В поле "Deployment name" (Имя развертывания) введите имя нового развертывания. Это имя будет присвоено ярлыку, с помощью которого пользователи будут устанавливать продукт.
    • В группе "This Is To Be A" (Платформа) выберите разрядность целевой операционной системы (32-разрядная или 64-разрядная). Этот выбор относится не к системе, в которой развертывание было создано, а определяет целевые системы.

    Нажмите "Next" (Далее).

  3. На странице "Select the Products to Include in the Deployment" (Выберите программы, включаемые в развертывание) выберите программы, подлежащие развертыванию, и нажмите "Next" (Далее).
    ПримечаниеAutoCAD Design Review 2009 не устанавливается по умолчанию при установке AutoCAD. Для правильного выполнения·некоторых функций AutoCAD требуется установка программы Design Review. Программа Design Review - это программа просмотра, являющаяся заменой программы DWF Viewer. Подробные сведения о функциях, на которые оказывает влияние эта программа, см. в Функции, для которых требуется программа Design Review.
  4. Прочитайте лицензионный договор на использование программных средств Autodesk для вашей страны или области. Для продолжения установки необходимо принять условия договора. Выберите страну или область, нажмите "I Accept" (Принимаю) и нажмите "Next" (Далее).
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  5. На странице "Product and User Information" (Информация о программе и сведения о пользователе) введите серийный номер и сведения о пользователе и нажмите "Next" (Далее).
    Внимание Введенные сведения не могут быть изменены в дальнейшем. Просмотреть их можно в окне AutoCAD 2009, которое вызывается с помощью Обозревателя меню [image] "Справка" [image] "О программе". Так как изменить эту информацию можно только путем переустановки программы, необходимо сразу же удостовериться, что вводимые данные верны.
  6. На странице "General Deployment Settings" (Общие параметры развертывания) укажите, следует ли при развертывании создать сетевой и/или клиентский журнал, запустить развертывание по клиентам в недиалоговом режиме и должны ли пользователи участвовать в Программе вовлечения пользователей.
    • Если было выбрано создание файла журнала сетевой установки, также необходимо определить, где будет создан журнал, задав UNC-имя (универсальное соглашение об именовании) или жестко заданный сетевой путь в данной сети. Файл сетевого журнала использовать не обязательно.
      ПримечаниеСетевой журнал должен располагаться в общедоступной сетевой папке. Пользователи, устанавливающие программу, должны иметь разрешение на изменение файлов в этой папке. При отсутствии такого разрешения запись в файл журнала невозможна.
    • Выберите, нужно ли создавать файл журнала на компьютере-клиенте.
    • Для предотвращения изменения настроек программы пользователями в процессе ее установки выберите недиалоговый режим.
    • Если выбрано участие в Программе вовлечения пользователей, Autodesk высылает пользователям полезные сведения о данном программном продукте.

    Для получения более подробной информации о файлах журнала см. Указание пути к файлу журнала.

    Нажмите "Next" (Далее).

  7. На странице "Review - Configure - Create Deployments" (Просмотр - Настройка - Создание развертываний) нажмите кнопку "Configure" (Настройка) для внесения изменений в установочный образ.
  8. На странице "Select the License Type" (Выберите тип лицензии) необходимо выбрать вариант "Stand-alone" (Однопользовательская лицензия) или "Network" (Сетевая лицензия).
  9. На странице "Select the Installation Type" (Выбор типа установки) можно выбрать следующие изменения конфигурации:
    • Типовая - устанавливаются общеупотребительные компоненты приложения.
    • Выборочная - Устанавливает только прикладные компоненты, которые выбираются из списка "Select Features To Install" (Выбор компонентов для установки):
      Стандарты оформления | Содержит средства проверки графических файлов на соответствие заданным стандартам.
      База данных | Содержит средства доступа к базам данных.
      Словари | Содержит орфографические словари с поддержкой различных языков.
      Шифрование чертежей | Предоставляет возможность защиты чертежей паролем с помощью диалогового окна "Security Options" (Параметры безопасности).
      Дополнительные утилиты Express Tools | Содержит средства поддержки и утилиты для AutoCAD.
      Шрифты | Содержит используемые в программе шрифты. (Шрифты True Type устанавливаются автоматически вместе с программой.)
      Панель инструментов Autodesk Impression | Панель инструментов Impression позволяет экспортировать любой вид для придания линиям дополнительных эффектов.
      Библиотека материалов | Содержит свыше 300 профессионально созданных материалов, которые можно применить к модели.
      Семинар по новым возможностям | Содержит видеоролики, практические упражнения и файлы примеров, предназначенные для изучения пользователями новых возможностей.
      Утилита перемещения лицензий | Содержит возможность перемещения однопользовательских лицензий на другие компьютеры.
      Перенос пользовательских настроек | Возможность переноса пользовательских настроек и адаптированных файлов из прежних версий. Дополнительную информацию см. в разделе Migrate Custom Settings.
      Диспетчер ссылок | Позволяет просматривать и редактировать пути к внешним файлам ссылок, связанных с чертежом.
      Примеры | Содержит файлы примеров для различных компонентов.
      Учебные пособия | Содержит уроки по продуктам.
      Поддержка VBA | Содержатся служебные файлы Microsoft Visual Basic for Applications.
      ПримечаниеПриложение Autodesk Impression доступно не во всех странах. Зайдите на веб-узел местного представительства компании Autodesk и узнайте, распространяется ли приложение Impression в Вашей стране.
    • Product Install Path (Путь установки программы) - задает диск и папку, где будет установлена программа AutoCAD.

    Нажмите кнопку "Next" (Далее) для продолжения процесса настройки.

  10. На странице "Define Search Paths and File Locations" (Определение путей поиска и папок для файлов) задайте пути поиска, имена файлов и папки хранения файлов, затем нажмите "Next" (Далее).
    ПредупреждениеПуть DRV удалять не следует, пути всегда добавляются в качестве дополнительных.
  11. Для добавления в развертывание дополнительных файлов следует на странице "Install Additional Files" (Установка дополнительных файлов) выбрать имена этих файлов и папки их расположения. Выбрав параметры, нажмите "Next" (Далее).
  12. На странице "Specify User Preferences" (Указание пользовательских настроек) укажите, следует ли использовать Internet Explorer, установите имя профиля по умолчанию и укажите, следует ли создать ярлык программы на рабочем столе. Нажмите "Next" (Далее).
  13. На странице "Include Service Packs" (Установка пакетов обновления) можно назначить необходимость вложения пакетов обновления в случае их наличия для данного развертывания.

    Программа установки автоматически проверяет наличие обновлений на веб-узле autodesk.com. При наличии обновлений отображается ссылка. Если обновления отсутствуют, ссылка не отображается.

  14. На странице "Configure InfoCenter Communications Center" (Настройка Коммуникационного центра Инфоцентра) можно предоставить пользователям доступ к самой последней информации и к посвященным программе форумам, разрешив обновления по сети от Autodesk, по информационным каналам, каналам CAD Manager и RSS. Выбрав параметры, нажмите "Next" (Далее).
  15. Кроме того, на странице "Configure Access to Online Resources" (Настройка доступа к интерактивным ресурсам) пользователям можно разрешить доступ к таким интерактивным инструментам, как Центр управления, сообщения об ошибках и поиск средствами Инфоцентра. Выбрав параметры, нажмите "Next" (Далее).
  16. На странице "Configuration Complete" (Настройка завершена) выберите вкладку другой программы для ее настройки и затем нажмите "Next" (Далее) или нажмите кнопку "Configuration Complete" (Настройка завершена), чтобы просмотреть заданные параметры.
  17. На странице "Review - Configure - Create Deployment" (Просмотр - Настройка - Создание развертывания) нажать кнопку "Configure" (Настройка).
  18. На странице "Deployment Complete" (Развертывание завершено) нажмите кнопку "Finish" (Готово).


Развертывание этой программы

Использование Мастера установки для настройки развертывания
Настройка и распространение программы
Функции, для которых требуется программа Design Review
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию > Настройка и распространение программы >
Развертывание этой программы

Пользователь может выбрать несколько методов развертывания программы. По умолчанию папка развертывания размещается в сети.

  • Общая папка развертывания.Пользователи запускают эту программу с помощью ярлыка, созданного в шаге 3 процедуры установки при работе с Мастером установкиИспользование Мастера установки для настройки развертывания . Программа устанавливается на локальных компьютерах пользователей, на рабочих столах этих компьютеров появляется ярлык программы.
    ПримечаниеПользователи должны иметь разрешение на чтение из общего сетевого ресурса и права администратора на рабочей станции, на которую устанавливается программа.
  • Использование сценариев. См. раздел Использование сценариев для развертывания программы.
  • Объекты групповой политики (GPO). См. раздел Использование групповой политики для установки из папки развертывания.
  • Программа создания образов. См. раздел Распространения программы с использованием программы создания образов.


Функции, для которых требуется программа Design Review

Развертывание этой программы
Краткое руководство по сетевому администрированию
Требования к системе
Руководство сетевого администратора по AutoCAD 2009 > Краткое руководство по сетевому администрированию >
Функции, для которых требуется программа Design Review

Программа Design Review является инструментом, предназначенным для просмотра и работы с файлами DWF. Файлы DWF - это файлы чертежей, преобразованные для передачи через Интернет и последующего совместного использования. Для работы с файлами DWF необходимо установить программу Design Review.

Чтобы использовать при работе с файлом DWF любую из приведенных ниже команд или функций, необходимо установить программу Design Review.

  • ПУБЛ
  • ПЕЧАТЬ
  • 3DДВФ
  • ПУБЛИКАЦИЯ В ИНТЕРНЕТЕ
  • ЭКСПОРТ
  • ПМТНАБОР
  • DWFUNDERLAY
  • АВТОПУБЛ
  • ДП


Требования к системе

Функции, для которых требуется программа Design Review
Требования к системе для данной программы
Руководство сетевого администратора по AutoCAD 2009 >
Требования к системе

В данной главе приведены требования к системе, необходимые для создания установочных образов, а также требования к серверу сетевых лицензий и рабочим станциям.

Темы в этом разделе

  • Требования к системе для данной программы


Требования к системе для данной программы

Требования к системе
Требования к системе
Развертывание программы
Руководство сетевого администратора по AutoCAD 2009 > Требования к системе >
Требования к системе для данной программы

Перед установкой программы в сети необходимо убедиться, что серверы и клиентские рабочие станции удовлетворяют, по крайней мере, минимальным требованиям, рекомендуемым для создания развертывания.

При установке AutoCAD автоматически выявляется версия операционной системы Windows (32- или 64-разрядная версия). При этом будет установлена соответствующая версия AutoCAD. Если Windows представляет собой 64-разрядную версию, 32-разрядная версия AutoCAD установлена быть не может.

Требования к системе для создания установочных образов, серверу лицензий и клиентским рабочим станциям приведены ниже.

Требования к аппаратным средствам и программному обеспечению для создания главного установочного образа
Элемент | Требования | Замечания
Жесткий диск | 1 Гбайт или более (рекомендуется) | Установочный образ следует создавать на сетевом диске, доступном для всех пользователей, которым необходим AutoCAD.

Требования к аппаратным средствам и программному обеспечению сервера лицензий
Элемент | Требования | Замечания
Операционная система | Windows Vista, 32-разрядная версия Windows XP, 32-разрядная версия Windows 2003 Server Edition Windows 2000 Professional Windows 2000 Server Edition | Network License Manager поддерживает только сети Ethernet.
Компьютер/процессор | Pentium III или выше 450 МГц (минимум) |
Сетевой адаптер | Совместимый с имеющейся инфраструктурой сети Ethernet | Network License Manager поддерживает различные сетевые карты.
Коммуникационный протокол | TCP/IP | Network License Manager работает с пакетами типа TCP.

Требования к аппаратному и программному обеспечению

Элемент

Требования

Замечания

Операционная система

32-разрядная версия

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate

Windows Vista Home Premium

Windows XP Professional с пакетом обновления SP2

Windows XP Home с пакетом обновления SP2

64-разрядная версия

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate

Windows Vista Home Premium

WIndows XP Professional

Рекомендуется устанавливать локализованные версии AutoCAD на операционные системы, язык интерфейса которых совпадает по кодовой странице с языком AutoCAD. Кодовая страница обеспечивает поддержку наборов символов, используемых в различных языках.

Обозреватель Интернета

32-разрядная версия

Internet Explorer 6.0 SP1 или более поздняя версия

64-разрядная версия

Internet Explorer 7.0 или более поздняя версия

Невозможно установить AutoCAD, если на рабочей станции не установлен обозреватель Microsoft Internet Explorer 6.0 с пакетом обновления SP1 (или более поздней версии). Загрузить программу Internet Explorer можно с веб-узла корпорации Microsoft по адресу: http://www.microsoft.com/downloads/

Процессор

32-разрядный

Процессор Intel® Pentium® 4 или AMD® Athlon, 2,2 ГГц или выше

или

Процессор Intel или AMD Dual Core, 1.6 ГГц или больше

64-разрядный

AMD 64 или·Intel EM64T

ОЗУ

32-разрядное

1 Гбайт (Windows XP SP2)

2 Гбайт или больше (Windows Vista)

64-разрядное

2 Гбайт

Плата графического адаптера

32-разрядный видеоадаптер с экранным разрешением 1280 x 1024 (в режиме True Color), память не менее 128 Мбайт, видеокарта с поддержкой OpenGL® или Direct3D®.

Для·Windows Vista, видеокарта с поддержкой Direct3D и памятью не менее 128 Мбайт, видеоадаптер с экранным разрешением 1024 x 768 в режиме True Color (минимум)

  • Видеоадаптер должен поддерживаться системой Windows.
  • Для графических адаптеров, поддерживающих аппаратное ускорение, следует установить DirectX 9.0c или более позднюю версию.
  • Установка из файла ACAD.msi не предусматривает установку пакета DirectX версии 9.0c или выше. Для конфигурации, предусматривающей аппаратное ускорение, требуется установка DirectX вручную.

Жесткий диск

750 Мбайт для установки (Windows XP SP2)

2 Гбайт свободного места на диске, не считая места, необходимого для установки. (Windows Vista)

Устройство указания

Мышь, трекбол или иное устройство

DVD/CD-ROM

Любой (только для установки программы)

32-разрядный

Загрузка (ESD) и установка с помощью устройства для чтения CD- или DVD-дисков

64-разрядный

Загрузка или DVD

Дополнительное оборудование

Принтер или плоттер

Дигитайзер

Модем или подключение к Интернету через локальную сеть

Сетевой адаптер

Дополнительные рекомендации по использованию 3D среды

Элемент

Требования

Замечания

Операционная система

32-разрядная версия

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate

Windows Vista Home Premium

Windows XP Professional с пакетом обновления SP2

Windows XP Home с пакетом обновления SP2

64-разрядная версия

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate

Windows Vista Home Premium

WIndows XP Professional

Рекомендуется устанавливать локализованные версии AutoCAD на операционные системы, язык интерфейса которых совпадает по кодовой странице с языком AutoCAD. Кодовая страница обеспечивает поддержку наборов символов, используемых в различных языках.

При установке AutoCAD автоматически выявляется версия операционной системы Windows (32- или 64-разрядная версия). При этом будет установлена соответствующая версия AutoCAD. 32-разрядную версию AutoCAD невозможно установить на платформе 64-разрядной версии Windows.

Процессор

Процессор Intel® Pentium® 4 или AMD® Athlon, 2,2 ГГц или выше

или

Процессор Intel или AMD Dual Core, 1.6 ГГц или выше

ОЗУ

2 Гбайт (или более)

Плата графического адаптера

32-разрядный видеоадаптер с экранным разрешением 1280 x 1024 (в режиме True Color), память не менее 128 Мбайт, видеокарта с поддержкой OpenGL® или Direct3D®.

Для·Windows Vista, видеокарта с поддержкой Direct3D и памятью не менее 128 Мб, видеоадаптер с экранным разрешением 1024 x 768 в режиме True Color (минимум)

  • Для графических адаптеров, поддерживающих аппаратное ускорение, следует установить DirectX 9.0c или более позднюю версию.
  • Установка из файла ACAD.msi не предусматривает установку пакета DirectX версии 9.0c или выше. Для конфигурации, предусматривающей аппаратное ускорение, требуется установка DirectX вручную.

Дополнительную информацию о проверенных и сертифицированных графических платах см. на веб-узле http://www.autodesk.com/autocad-graphicscard

Жесткий диск

2 Гбайт (в дополнение к требуемому для установки 1 Гбайт или более)


Развертывание программы

Требования к системе для данной программы
Подготовка к сетевому развертыванию
Руководство сетевого администратора по AutoCAD 2009 >
Развертывание программы

В этом разделе можно найти более подробную информацию по использованию Мастера установки для создания или модификации развертывания.

Темы в этом разделе

  • Подготовка к сетевому развертыванию
  • Использование Мастера установки для настройки развертывания
  • Представление установочного образа
  • Удаление программы


Подготовка к сетевому развертыванию

Развертывание программы
Развертывание программы
Минимизация возможностей возникновения сбоев при установке
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы >
Подготовка к сетевому развертыванию

Установка этой программы в сети должна быть тщательно спланирована и выполнена аккуратно. В контрольном списке развертывания приведена сводка по информации, знакомство с которой необходимо для выполнения процедуры развертывания.

Контрольный список развертывания
 | Необходимо ознакомиться требованиями к системе. Необходимо убедиться в том, что сеть, серверы и клиентские рабочие станции соответствуют требованиям к системе. См. раздел Требования к системе для данной программы.
 | Следует убедиться, что закрыты все программы и отключено антивирусное программное обеспечение. См. раздел Минимизация возможностей возникновения сбоев при установке .
 | Необходимо определить, где будет постоянно находиться развертывание, - например, в папке общего доступа для каждой программы, которую планируется развернуть. См. раздел Создание папок общего доступа для развертывания.
 | Были установлены все средства поддержки и утилиты и проведена их активация. См. раздел Установка и активация средств и утилит.
 | Если план развертывания включает использование программ создания образов для распространения программы (программ) по клиентским рабочим станциям, необходимо ознакомиться с разделом Распространения программы с использованием программы создания образов.
 | Необходимо указать, следует ли создать файлы журнала, содержащие данные о развертывании и об установке, запустить ли развертывание в недиалоговом режиме и принимать ли участие в Программе вовлечения пользователей. См. раздел Указание пути к файлу журнала.
 | Необходимо хорошо понять особенности типа приобретенной лицензии. Если планируется развертывание на основе сетевой лицензии, необходимо знать тип модели сервера лицензии, который будет использован, и имя (имена) сервера лицензий. См. раздел Выбор типа лицензии (дополнительно).
 | Необходимо знать, установка какого типа будет предпринята - типовая или выборочная. См. раздел Выбор варианта установки (дополнительно).
 | Можно также изменить пути поиска для пользовательских файлов или найти расположение файлов, которое, возможно, изменилось в этой версии программного обеспечения. См. раздел Задание путей поиска и папок для файлов (необязательное) .
 | Следует решить, будут ли в развертывание добавлены дополнительные файлы, например, файлы чертежей, процедуры AutoLISP или файлы сценариев. См. раздел Установка дополнительных файлов (необязательная).
 | Надо проверить наличие пакетов обновлений, которые могут быть доступны для данного продукта. Если доступен пакет обновления, надо загрузить его и извлечь файл MSP. См. раздел Включение пакетов обновлений (дополнительно).
 | Следует настроить доступ к Коммуникационному центру. Уведомления при обновлениях по сети, если продукт обновился, посылаются по электронной почте, а Коммуникационный центр предоставляет пользователям доступ к технической информации. См. раздел Настройка Коммуникационного центра Инфоцентра (дополнительно).
 | Следует установить доступ и участие в работе таких систем, как Интернет-модуль Центра управления, Центр подписки и пользовательский отчет об ошибках. См. раздел Разрешение допуска пользователей к сетевым ресурсам (дополнительно).
 | Необходимо заранее подготовить персональные данные, которые будут использованы в процессе регистрации программы (программ). Очень важно предоставление при регистрации непротиворечивых данные. См. раздел Регистрация программного продукта.

Если подготовительный этап закончен, можно начать создание развертывания с помощью Мастера установки.

Темы в этом разделе

  • Минимизация возможностей возникновения сбоев при установке
  • Создание папок общего доступа для развертывания
  • Установка и активация средств и утилит


Минимизация возможностей возникновения сбоев при установке

Подготовка к сетевому развертыванию
Подготовка к сетевому развертыванию
Создание папок общего доступа для развертывания
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Подготовка к сетевому развертыванию >
Минимизация возможностей возникновения сбоев при установке

Установка AutoCAD 2009 может прерваться, если на компьютере одновременно с созданием развертывания работают некоторые приложения, например, Microsoft Outlook или антивирусные программы. Рекомендуется закрыть все запущенные приложения и временно запретить работу антивирусных утилит.


Создание папок общего доступа для развертывания

Минимизация возможностей возникновения сбоев при установке
Подготовка к сетевому развертыванию
Установка и активация средств и утилит
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Подготовка к сетевому развертыванию >
Создание папок общего доступа для развертывания

И для установки на основе сетевой лицензии, и для установки по методу развертывания отдельной версии на несколько пользователей необходимо создать папки общего доступа. Папка общего доступа, в которой сохраняются развертывания продукта (общие сетевые ресурсы), создается до запуска Мастера установки.

Совместно используемой сетевой папке (на рабочем столе системы), в которой требуется хранить развертывания, рекомендуется присвоить имя Deployments. Затем в папке общего доступа Deployments можно создать подпапки, имена которых отражали бы названия программных продуктов, которые планируется развернуть. Создавать такие подпапки рекомендуется при планировании развертывания нескольких программных продуктов.

Все подпапки, помещенные в папку общего доступа, автоматически имеют общий доступ.

СоветНеобходимо установить разрешение "Полное управление" для папки общего доступа в случае создания образов развертывания. Разрешения на чтение необходимы для доступа к сетевым ресурсам и правам администратора на рабочей станции, на которой развернута программа.

Для создания совместно используемой папки

  1. На сетевом сервере нужно создать папку, которая будет иметь имя "Развертывания".
  2. Щелкните правой кнопкой мыши на папке Deploymentsи выберите пункт "Share and Security" (Общий доступ и безопасность) или "Sharing" (Общий доступ).

    Если используется ОС Vista, щелкните правой кнопкой мыши на папке Deployments и выберите пункт "Share" (Общий доступ). Нажмите кнопку "Permissions" (Права доступа) и убедитесь в том, что флажок "Full Control" (Полный доступ) установлен.

  3. В диалоговом окне "Properties" (Свойства) <имя папки> на вкладке "Sharing" (Общий доступ) выберите параметр "Share This Folder" (Открыть общий доступ к этой папке).

    Если используется ОС Vista, в диалоговом окне "Properties" (Свойства) выберите "Sharing" (Общий доступ) и затем "Advanced Sharing" (Дополнительные параметры общего доступа).

  4. Укажите имя папки (Share Name), например,MyDeployments, если это необходимо.
  5. Нажмите кнопку "Permissions" (Права доступа). В диалоговом окне "Permissions" (Права доступа) нужно проверить, что установлен флажок "Full Control" (Полный доступ). Нажмите "ОК".
  6. Для закрытия диалогового окна "Properties" (Свойства) нажмите "OK" или "Close" (Закрыть).
  7. Для каждого устанавливаемого продукта нужно создать подпапку в папке Autodesk. Название каждой подпапки должно соответствовать названию программного продукта.


Установка и активация средств и утилит

Создание папок общего доступа для развертывания
Подготовка к сетевому развертыванию
Использование Мастера установки для настройки развертывания
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Подготовка к сетевому развертыванию >
Установка и активация средств и утилит

Необходимо установить некоторые средства поддержки и утилиты, если планируется, что пользователи будут запускать программу (программы) с сетевыми лицензиями. Можно установить следующие вспомогательные программы:

  • Network License Manager
  • Программа активации сетевой лицензии
  • CAD Manager Tools
  • SAMreport Lite

Для получения дополнительной информации о процессе установки серверов лицензий см. Руководство по сетевому лицензированию. Руководство по сетевому лицензированию можно найти в справочной системе и на вкладке "Документация" в Мастере установки.


Использование Мастера установки для настройки развертывания

Установка и активация средств и утилит
Развертывание программы
Запуск процесса развертывания
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы >
Использование Мастера установки для настройки развертывания

Процесс развертывания запускается с помощью Мастера установки. Развертывание представляет собой источник, из которого пользователи могут установить программу на свои компьютеры. Для создания различных образов и типов развертывания, удовлетворяющих требованиям пользователей и нуждам организации, в Мастере можно выбирать соответствующие параметры.

Процесс развертывания позволяет выполнять следующие операции:

  • Создание развертывания.
  • Применение пакета обновления к развертыванию.
  • Добавление адаптированных файлов в развертывание.
  • Изменение путей поиска и расположения файлов.
  • Разрешение пользователям доступа к интерактивным ресурсам.
ПримечаниеВ силу большого количества параметров создания и настройки развертываний существует множество страниц, необходимых для выбора. Поэтому следует заранее выделить достаточное количество времени для запуска Мастера развертывания за один сеанс.

Темы в этом разделе

  • Запуск процесса развертывания
  • Создание развертывания
  • Ввод информации о программе и сведений о пользователе
  • Указание пути к файлу журнала
  • О недиалоговом режиме
  • Программа вовлечения пользователей (CIP)
  • Выбор типа лицензии (дополнительно)
  • Выбор варианта установки (дополнительно)
  • Задание путей поиска и папок для файлов (необязательное)
  • Установка дополнительных файлов (необязательная)
  • Установка пользовательских настроек (дополнительно)
  • Включение пакетов обновлений (дополнительно)
  • Настройка Коммуникационного центра Инфоцентра (дополнительно)
  • Разрешение допуска пользователей к сетевым ресурсам (дополнительно)
  • Окончательный обзор и завершение установки
  • Регистрация программного продукта
  • Модификация развертывания (дополнительно)


Запуск процесса развертывания

Использование Мастера установки для настройки развертывания
Использование Мастера установки для настройки развертывания
Создание развертывания
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Запуск процесса развертывания

Как только запускается Мастер установки, происходит инициализация процесса установки развертывания.

Чтобы запустить процесс развертывания, нужно:

  • В окне Мастера установки AutoCAD 2009 нажать кнопку "Создание развертываний".


Создание развертывания

Запуск процесса развертывания
Использование Мастера установки для настройки развертывания
Ввод информации о программе и сведений о пользователе
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Создание развертывания

Папка развертывания содержит набор MST-файлов, с помощью которых можно изменять параметры установки программы. Начиная развертывание, следует выбрать папку установочного образа, имя развертывания и разрядность целевых операционных систем (32- или 64-разрядные).

Для создания папки развертывания

  1. В окне Мастера установки нажмите кнопку "Создание развертываний".
  2. На странице "Начало развертывания" введите имя папки установочного образа или найдите ее с помощью кнопки "Найти". Введите имя развертывания и укажите, 32-разрядные или 64-разрядные операционные системы станут целевыми.
    Примечание Расположением развертывания должна быть сетевая папка c общим доступом. Информацию о создании папки c общим доступом см. в разделе Создание папок общего доступа для развертывания.
  3. На странице "Products to Include in the Deployment" (Выберите программы, включаемые в развертывание) выберите программы и нажмите "Next" (Далее).
  4. Прочитайте лицензионный договор на использование программных средств Autodesk для вашей страны или области. Для продолжения установки необходимо принять условия договора. Выберите страну или регион, щелкните на варианте "Принимаю" и нажмите "Далее".
    ПримечаниеВ случае несогласия с условиями договора и необходимости прервать установку нажмите "Cancel" (Отмена).
  5. На странице "Product and User Information" (Информация о программе и сведения о пользователе) введите серийный номер и сведения о пользователе. Нажмите "Далее".
  6. На странице "General Deployment Settings" (Общие параметры развертывания) укажите, следует ли создать сетевой журнал и папку для него и клиентский журнал. Также можно запустить развертывание по клиентам в недиалоговом режиме и указать, будут ли пользователи участвовать в Программе вовлечения пользователей. Нажмите "Далее".
  7. Если вносить изменения в настройки на странице "Review - Configure - Install" (Обзор - Настройка - Установка) не требуется, нажмите "Create Deployment" (Создание развертывания). Затем нажмите "Yes" (Да) для продолжения процесса установки с принятыми по умолчанию настройками.

  8. Для регистрации и активации программы нажмите на ссылку регистрации программ через Интернет или нажмите кнопку "Finish" (Готово), чтобы выполнить регистрацию и активацию программы позднее.


Ввод информации о программе и сведений о пользователе

Создание развертывания
Использование Мастера установки для настройки развертывания
Указание пути к файлу журнала
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Ввод информации о программе и сведений о пользователе

Страница "Product and User Information" (Информация о программе и сведения о пользователе) используется для ввода сведений о пользователе программы в пределах·данной организации. Введенные сведения не могут быть изменены в дальнейшем. Просмотреть их можно в окне "О программе AutoCAD 2009" (которое вызывается с помощью Обозревателя меню [image] "Справка" [image] "О программе") на всех рабочих станциях, на которых выполняется развертывание. Так как изменить эту информацию можно только путем переустановки программы, необходимо сразу же удостовериться в том, что вводимые данные верны.

Для запуска программного продукта необходимо также ввести его серийный номер. Серийный номер продукта можно найти на упаковке. Серийный номер состоит из префикса (трехзначное число), дефиса и кода (восьмизначное число).

Для ввода серийного номера и сведений о пользователе

  1. На странице "Product and User Information" (Информация о программе и сведения о пользователе) введите серийный номер программного продукта и требуемые сведения о пользователе.
    ПримечаниеТребуется заполнить все поля на данной странице, но вводить в них можно любые сведения, которые предполагается сообщить пользователям, устанавливающим AutoCAD из данной папки развертывания.
  2. Нажмите "Далее".


Указание пути к файлу журнала

Ввод информации о программе и сведений о пользователе
Использование Мастера установки для настройки развертывания
О недиалоговом режиме
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Указание пути к файлу журнала

Программа поддерживает два типа файлов журнала, с помощью которых можно просматривать информацию о развертывании и установке.

  • Сетевой журнал. Файл сетевого журнала содержит записи о всех рабочих станциях, использующих развертывание. На странице "General Deployment Settings" (Общие параметры развертывания) процесса развертывания укажите, следует ли создать файл сетевого журнала. В журнале содержатся имена пользователей, имена рабочих станций и сведения о состоянии установки. Содержимое этого файла отражает текущее состояние и сведения о неполадках в процессе установки (например, о нехватке пространства на диске или о недостаточных полномочиях). Сетевому журналу присваивается имя, совпадающее с именем папки развертывания. Можно указать папку для создания журнала, задав UNC-имя (универсальное соглашение об именовании) или жестко заданный сетевой путь, например, \\MyComputer\Autodesk\AutoCAD 2009.
    ПримечаниеСетевой журнал должен располагаться в общедоступной сетевой папке. Пользователи, устанавливающие программу, должны иметь разрешение на изменение файлов в этой папке. При отсутствии такого разрешения запись в файл журнала невозможна.
  • Клиентский журнал. Клиентский журнал содержит подробные сведения об установке по каждой рабочей станции. Эта информация может быть полезна для диагностики ошибок установки. Файл клиентского журнала находится в папке Temp каждой рабочей станции.

Для задания пути к файлу журнала

  1. При создании развертывания на странице "General Deployment Settings" (Общие параметры развертывания) установите флажок рядом с полем "Create Network Log" (Создать сетевой журнал). Введите имя папки, где будет расположен файл сетевого журнала.
  2. Если нужно создать клиентский журнал, следует установить флажок "Вести клиентский журнал".
  3. Нажмите "Далее".


О недиалоговом режиме

Указание пути к файлу журнала
Использование Мастера установки для настройки развертывания
Программа вовлечения пользователей (CIP)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
О недиалоговом режиме

При активации недиалогового режима и инициализации пользователем развертывания, установка будет выполняться без какого-либо вмешательства со стороны пользователя.\\ Во время процесса установки диалоговые окна не выводятся.


Программа вовлечения пользователей (CIP)

О недиалоговом режиме
Использование Мастера установки для настройки развертывания
Выбор типа лицензии (дополнительно)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Программа вовлечения пользователей (CIP)

Если указана необходимость участия клиентов в Программе вовлечения пользователей, AutoCAD автоматически отправляет в Autodesk информацию о конфигурации системы, о том, какие функции используются чаще всего, о любых возникающих проблемах, а также другую информацию, полезную для развития программы в будущем.

ПримечаниеКроме того, имеется возможность включить или отключить участие в Программе вовлечения пользователей из утилиты Диспетчера интернет-компонентов.


Выбор типа лицензии (дополнительно)

Программа вовлечения пользователей (CIP)
Использование Мастера установки для настройки развертывания
Выбор варианта установки (дополнительно)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Выбор типа лицензии (дополнительно)

Тип установки задается при настройке параметров развертывания на основании того, лицензия какого типа на пакет программ приобретена: однопользовательская или сетевая. Кроме того, следует выбрать модель сервера сетевых лицензий, который будет использоваться для распределения лицензий на пользование программой.

Задание типа лицензии для использования в процессе развертывания

Однопользовательская лицензия (один серийный номер на одно рабочие место)

При наличии однопользовательской лицензии установка, регистрация и активизация программы производится на каждой рабочей станции.

Сетевая лицензия

При этом программа устанавливается на рабочие станции вместе с файлами и параметрами реестра, которые обеспечивают взаимодействие с Диспетчером сетевых лицензий Network License Manager. В программе Network License Manager можно разрешить доступ к лицензиям. Для работы программы после ее сетевой установки на рабочую станцию не требуется индивидуальная активация. Лицензии на программу распределяются, по крайней мере, с одного сервера.

Для развертывания однопользовательской лицензии

  1. При создании развертывания на странице "Select the License Type" (Выбор типа лицензии) необходимо выбрать опцию "Stand-alone license" (Однопользовательская лицензия).

  2. Нажмите "Далее".

Указание модели сервера лицензий при развертывании

Если выбрана опция "Сетевая лицензия", необходимо определить, какая модель сервера лицензий будет использоваться для распределения лицензий на пользование программой - конфигурация с одним сервером, с несколькими серверами или с резервными серверами лицензий.

В случае развертывания однопользовательской установки или однопользовательской установки на несколько рабочих мест модель сервера лицензий не и используется. Дополнительную информацию о моделях сервера см. в разделе Выбор модели сервера лицензий.

Развертывание на основе сетевой лицензии при использовании модели сервера лицензий

  1. При создании развертывания на странице "Выбор типа лицензии" необходимо выбрать опцию "Сетевая лицензия".
  2. В качестве модели сервера лицензий надо выбрать cервер однопользовательской лицензии, который будет использоваться для Диспетчера сетевых лицензий (Network License Manager).

    Если Network License Manager уже использовался для создания конфигурации серверов лицензий, следует выбирать ту же конфигурацию. Если же конфигурация создается впервые, следует иметь в виду, что в Network License Manager и в Мастере сетевой установки она должна быть одинаковой.

    Более подробную информацию о моделях серверов лицензий см. в разделе “"Модели серверов лицензий"” в Руководстве по сетевому лицензированию в справочной системе и на вкладке "Документация" в Мастере установки.

  3. Введите имя сервера, на котором будет запускаться Network License Manager, или выберите сервер, нажав кнопку "Browse " (Обзор). Нажмите "Далее".

Развертывание на основе сетевой лицензии при использовании модели распределенного сервера лицензий

  1. При создании развертывания на странице "Выбор типа лицензии", необходимо выбрать опцию "Сетевая лицензия".
  2. В качестве модели сервера лицензий надо выбрать несколько серверов лицензий, которые будут использоваться для Диспетчера сетевых лицензий (Network License Manager).

    Если Network License Manager уже использовался для создания конфигурации серверов лицензий, следует выбирать ту же конфигурацию. Если же конфигурация создается впервые, следует иметь в виду, что в Network License Manager и в Мастере сетевой установки она должна быть одинаковой.

    Более подробную информацию о моделях серверов лицензий см. в разделе “"Модели серверов лицензий"” в Руководстве по сетевому лицензированию в справочной системе и на вкладке "Документация" в Мастере установки.

  3. Введите имя одного из серверов, на которых будет запускаться Network License Manager, или выберите сервер, нажав кнопку "Browse " (Обзор). Нажмите кнопку "Добавить" для добавления сервера к списку "Пул серверов". Как только все серверы будут добавлены к списку "Пул серверов", можно использовать кнопки "Перемещение вверх" и "Перемещение вниз" для упорядочения серверов в том порядке, который будет соблюдаться при обращении рабочей станцией пользователя. Для данной конфигурации требуется указать по крайней мере два сервера. Нажмите "Далее".

Развертывание с сетевой лицензией при использовании резервных серверов лицензий

  1. При создании развертывания на странице "Выбор типа лицензии", необходимо выбрать опцию "Сетевая лицензия".
  2. В качестве модели сервера лицензий надо выбрать резервный сервер лицензий, который будет использоваться для Диспетчера сетевых лицензий (Network License Manager).

    Если Network License Manager уже использовался для создания конфигурации серверов лицензий, следует выбирать ту же конфигурацию. Если же конфигурация создается впервые, следует иметь в виду, что в Network License Manager и в Мастере сетевой установки она должна быть одинаковой.

    Более подробную информацию о моделях серверов лицензий см. в разделе “"Модели серверов лицензий"” в Руководстве по сетевому лицензированию в справочной системе и на вкладке "Документация" в Мастере установки.

  3. В поле "Имя первого сервера" введите имя того сервера, на котором будет запущен Network License Manager, или нажмите кнопку "Browse" (Обзор), чтобы определить расположение сервера. Затем введите имена и идентификаторы хостов остальных двух серверов, тех, которые будут использоваться в качестве резервных. Нажмите "Далее".

    ПримечаниеЕсли неизвестны имя и идентификатор узла сервера, см. раздел “Планирование конфигурации сервера лицензий” в Руководстве по сетевому лицензированию. Руководство можно найти в справочной системе и на вкладке "Документация" в Мастере установки.


Выбор варианта установки (дополнительно)

Выбор типа лицензии (дополнительно)
Использование Мастера установки для настройки развертывания
Задание путей поиска и папок для файлов (необязательное)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Выбор варианта установки (дополнительно)

При выборе вариантов создания развертывания нужно выбрать тип установки, который будет реализован пользователями при установке программы, произвести включение дополнительных средств или функций и установить расположение установки продукта на каждой рабочей станции.

  • Типовая. Установка наиболее часто используемых компонентов. Рекомендуется для большинства пользователей.
  • Выборочная. Установка только выбранных пользователем компонентов.

Можно также выбрать включение в это развертывание Express Tools и Библиотеки материалов.

  • Express Tools. Дополнительные утилиты Express Tools доступны в оригинальном виде (только на английском языке) и не поддерживаются. Обновления средств не производились. Двухбайтовые символы не поддерживаются.
    ПримечаниеНекоторые средства Express Tools были интегрированы в AutoCAD 2009. Полный список интегрированных средств см. в разделе ответов на наиболее часто задаваемые вопросы в справочной системе дополнительных утилит Express Tools. Сведения о встроенных командах можно найти в справочной системе программы.
  • Библиотека материалов. Библиотека материалов содержит свыше 300 материалов, которые можно применять к моделям. Библиотека построена как набор палитр инструментов.

Надо выбрать расположение установки файлов программы на клиентской рабочей станции в поле "Путь установки продукта". Выводится схема дисков и дискового пространства, чтобы облегчить принятие решения о том, куда устанавливать продукт.

Чтобы обеспечить развертывание для типовой установки нужно выбрать дополнительные средства и определить расположение продукта.

  1. В процессе развертывания на странице "Select the Installation Type" (Выбор типа установки) выберите опцию "Typical" (Типовая).

  2. Снимите флажок установки дополнительных утилит Express Tools, если эти утилиты не требуется включать в развертывание. Утилиты Express Tools устанавливаются по умолчанию.
  3. Если необходимо установить Библиотеку материалов, надо установить флажок для опции "Библиотека материалов". По умолчанию флажок опции "Библиотека материалов" снят.
  4. Введите путь к клиентской рабочей станции, на которой будет установлена программа, например C:\Program Files\AutoCAD 2009, или нажмите кнопку "Browse" (Обзор), чтобы указать папку для установки.

    Схема требуемого дискового пространства позволяет оценить доступные диски и дисковое пространство.

  5. Нажмите "Далее".

Чтобы обеспечить развертывание для выборочной установки нужно выбрать дополнительные средства и определить расположение продукта

  1. В процессе развертывания на странице "Выбор типа установки" нужно выбрать опцию "Выборочная" в качестве выбранного типа установки.

  2. Выбор требуемых для установки компонентов осуществляется из списка "Выбор устанавливаемых компонентов".

    Доступны следующие конфигурации:

    Стандарты оформления | Содержит средства проверки графических файлов на соответствие заданным стандартам.
    База данных | Содержит средства доступа к базам данных.
    Словари | Содержит многоязычные словари.
    Шифрование чертежей | Возможность защиnы данных чертежа с помощью пароля, используя диалоговое окно "Параметры безопасности".
    Дополнительные утилиты Express Tools | Содержит инструменты и утилиты поддержки AutoCAD (не поддерживаемые Autodesk).
    Шрифты | Содержит шрифты AutoCAD и True Type.
    Панель инструментов Autodesk Impression | Панель инструментов Impression позволяет быстро экспортировать в Autodesk Impression любой вид для придания линиям дополнительных эффектов.
    Библиотека материалов | Библиотека материалов содержит свыше 300 профессионально созданных материалов, которые можно применить к модели.
    Семинар по новым возможностям | Содержит видеоролики, практические упражнения и файлы примеров, предназначенные для изучения пользователями новых возможностей.
    Утилита перемещения лицензий | Содержит инструменты управления перемещением лицензий.
    Перенос пользовательских настроек | Осуществляет перенос пользовательских настроек и файлов из прежних версий установленной на данном компьютере программы в нынешнюю версию. См. раздел Migrate Custom Settings.
    Диспетчер ссылок | Позволяет просматривать и редактировать пути к внешним файлам ссылок, связанных с чертежом.
    Примеры | Содержатся файлы с примерами для различных функций.
    Учебные пособия | Содержит учебные пособия.
    Поддержка VBA | Содержит вспомогательные файлы Microsoft Visual Basic for Applications.
    ПримечаниеПриложение Autodesk Impression доступно не во всех странах. Зайдите на веб-узел местного представительства компании Autodesk и узнайте, распространяется ли приложение Impression в Вашей стране.

    Если после выбора измененного набора компонентов требуется вернуться к исходному набору, следует нажать кнопку "Восстановить значения по умолчанию".

  3. Введите путь к клиентской рабочей станции, на которой будет установлена программа, например C:\Program Files\AutoCAD 2009, или нажмите кнопку "Browse" (Обзор), чтобы указать папку для установки.

    Схема требуемого дискового пространства позволяет оценить доступные диски и дисковое пространство.

  4. Нажмите "Далее".


Задание путей поиска и папок для файлов (необязательное)

Выбор варианта установки (дополнительно)
Использование Мастера установки для настройки развертывания
Установка дополнительных файлов (необязательная)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Задание путей поиска и папок для файлов (необязательное)

На странице "Пути поиска и папки для файлов" можно изменить пути поиска и доступа к некоторым файлам программы, которые используются по умолчанию. Необходимость изменения установок по умолчанию может возникнуть по следующим причинам:

  • Если в среде САПР используется файл (например файл адаптации или надстройки), отличный от файла, установленного программой по умолчанию, его можно указать на этой странице и не добавлять для каждой рабочей станции.
  • Пути к некоторым файлам, заданные по умолчанию, изменились в этой версии программы. С помощью этой страницы можно переместить файлы в те же папки, что и в более ранней версии программы.
ПримечаниеПути поиска и папки файлов можно изменить для отдельных рабочих станций и после установки программы. Это делается с помощью диалогового окна "Настройка". Подробная информация приведена в разделе Укажите "Пути поиска" и "Местоположения файлов" в Руководстве пользователя.

Чтобы использовать настройки по умолчанию для путей поиска и папок файлов

  • Во время создания развертывания на странице "Определение путей поиска и расположения файлов" нажмите кнопку "Далее".

Чтобы изменить настройки по умолчанию для путей поиска и папок файлов

  1. Во время создания развертывания на странице "Определение путей поиска и расположения файлов" в списке "Определение путей поиска, имен файлов и расположения файлов" щелкните на значке "плюс" (+) слева от пути поиска или расположения файла, чтобы выбрать и развернуть его.

  2. Выберите элемент списка, далее выполнить одно из следующих действий:
    • Нажмите кнопку "Обзор" для выбора папки.
    • Для добавления нового элемента в список нажмите кнопку "Добавить".
    • Для удаления выбранного элемента из списка нажмите кнопку "Удалить".
    • Для перемещения выбранного элемента в списке на один уровень вверх или вниз нажмите соответственно кнопку "Вверх" или "Вниз".
    ПримечаниеЭти кнопки доступны в зависимости от того, какой элемент был выбран в предыдущем пункте.
  3. После того как все пути к файлам будут настроены, нажмите кнопку "Далее".


Установка дополнительных файлов (необязательная)

Задание путей поиска и папок для файлов (необязательное)
Использование Мастера установки для настройки развертывания
Установка пользовательских настроек (дополнительно)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Установка дополнительных файлов (необязательная)

На странице "Установка дополнительных файлов" при нажатии кнопки "Обзор" можно добавить файлы в развертывание. По умолчанию при развертывании эти файлы устанавливаются в папку установки программы на рабочей станции-клиенте. Если требуется, можно установить файлы в несколько папок.

На данной странице пользователь может выполнить следующие операции:

  • Задать дополнительные файлы (например, файлы чертежей, процедуры AutoLISP® или файлы сценариев), которые следует включить в папку развертывания.
  • Установить файлы различных типов в разные папки на рабочих станциях.
  • Добавить в папку установки вложенные папки (например папку с именем LSP с пользовательскими процедурами AutoLISP).
  • Добавить файлы в ту же папку, что и файлы программы (например примеры чертежей для проекта).
  • Добавить файлы в корневую папку установки.
ПримечаниеЭти файлы рекомендуется устанавливать в папку, входящую в структуру папок программы. При этом имена дополнительных файлов не могут совпадать с именами файлов установленной программы. Например, невозможно включить в развертывание файл acad.cui.

Для установки дополнительных файлов

  1. Во время создания развертывания на странице "Установка дополнительных файлов" нужно задать расположение, куда будет установлен файл.

  2. Выполните одно из следующих действий:
    • Нажмите кнопку "Browse" (Обзор) для открытия диалогового окна "Выбор файлов для добавления", в котором можно выбрать файлы для добавления в папку установки.
    • Нажмите кнопку "Добавить папку" для создания новой вложенной папки в папке установки.
    • Нажмите "Добавить диск" для добавления имени диска в путь к папке файла. Имя диска должно состоять из буквы, являющейся действительным обозначением этого диска, и двоеточия, например, C: или F:. Пути, созданные на основании универсального соглашения об именовании (UNC), не поддерживаются.
    • Нажмите кнопку "Исключить" для исключения файла, папки или имени диска из места установки.
  3. Нажмите "Далее".


Установка пользовательских настроек (дополнительно)

Установка дополнительных файлов (необязательная)
Использование Мастера установки для настройки развертывания
Включение пакетов обновлений (дополнительно)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Установка пользовательских настроек (дополнительно)

На странице "Установка пользовательских персональных настроек" можно указать, будет ли продолжена установка, основанная на этом развертывании, если не установлен Microsoft Internet Explorer, установить имя профиля по умолчанию, указать, отображать ли ярлык продукта на рабочем столе компьютера, или создать пользовательский ярлык на рабочем столе.

Установка пользовательских персональных настроек

  1. На странице "Установка пользовательских персональных настроек" снимите флажок для опции "Internet Explorer", если не требуется предварительной установки Microsoft Internet Explorer до установки AutoCAD.

  2. В поле "Имя стандартного профиля" укажите имя профиля, который станет текущим для всех пользователей, выполняющих развертывание, и текстовый редактор, используемый по умолчанию.
  3. Снимите флажок "Поместить ярлык AutoCAD 2009 на рабочий стол", если не требуется размещать ярлык программы на рабочем столе.
  4. Если требуется создать пользовательский ярлык на рабочем столе, задайте имя ярлыка и любые параметры, например переключатели, которые будут вызывать определенные профили, сценарии запуска и т.д.

  5. Нажмите "Далее".


Включение пакетов обновлений (дополнительно)

Установка пользовательских настроек (дополнительно)
Использование Мастера установки для настройки развертывания
Настройка Коммуникационного центра Инфоцентра (дополнительно)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Включение пакетов обновлений (дополнительно)

Во время создания развертывания в процесс установки можно включить пакеты обновления для вашего продукта, которые были получены по электронной почте. Программа установки автоматически проверяет наличие обновлений на веб-узле autodesk.com. При наличии обновлений отображается ссылка ("Updates are available" (Имеются обновления)). Если обновления отсутствуют, ссылка не отображается.

При включении пакета обновления можно также задать способ его обработки. Можно выбрать следующее:

  • Присоединение пакетов обновлений к развертыванию. В случае присоединения пакета обновления он присоединяется только к текущему развертыванию. К развертыванию могут быть присоединены несколько пакетов обновления. Файл пакета обновления включается в развертывание, и он используется уже после развертывания продукта.
  • Объединение пакетов обновлений в файле MSI установочного образа. Если выполняется объединение пакета обновления, он включается в установочный образ. Из установочного образа после объединения пакет обновления удалить нельзя. В единственный установочный образ можно включить несколько пакетов.

Извлечение файла MSP из пакета обновления

  1. Загрузите пакет обновления с сайта поддержки продуктов Autodesk.
  2. Просмотрите файл Readme пакета обновления для получения информации об использовании пакета.
  3. Откройте командную строку Windows и введите имя файла обновления вместе с ключом /e и имя целевого файла, например:

    ProductSP1.exe /e ./ProductSP1.msp

    где <ProductSP1.exe> - имя загруженного обновления, а <ProductSP1.msp> - имя извлеченного файла. Использование `. /’ перед именем извлеченного файла помещает извлеченный файл в ту же самую папку, где находится исходный исполняемый файл.

    ПримечаниеО наличии доступных пакетов обновления можно узнать на странице поддержки программ Autodesk по адресу http://support.autodesk.com/.

Включение пакета обновления с развертыванием

Для включения пакета обновления с развертыванием, файл MSP нужно извлечь из загруженного исполняемого файла пакета обновления.

  1. На странице "Включение пакетов обновления" нажмите кнопку "Browse" (Обзор).
  2. В диалоговом окне "Открыть" задайте расположение пакета обновления, который нужно включить в развертывание.
  3. Задайте файл MSP и нажмите кнопку "Открыть".
  4. Укажите, нужно ли присоединить пакет обновления к развертыванию или следует объединить его с установочным образом.
  5. Нажмите "Далее".


Настройка Коммуникационного центра Инфоцентра (дополнительно)

Включение пакетов обновлений (дополнительно)
Использование Мастера установки для настройки развертывания
Разрешение допуска пользователей к сетевым ресурсам (дополнительно)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Настройка Коммуникационного центра Инфоцентра (дополнительно)

Доступ к Коммуникационному центру осуществляется через Инфоцентр. Продукты Autodesk можно обновлять через Интернет, загружая процедуры обновления при помощи Коммуникационного центра. Обновления по сети, другие информационные каналы и линии передачи могут отображаться с помощью Коммуникационного центра.

Ниже приведены настройки Коммуникационного центра, которые можно изменять:

  • Разрешить обновление по сети После подключения к Интернету пользователь может проверить наличие обновлений. Если доступен пакет обновления, в строке состояние программы появляется соответствующее уведомление, пакет обновления можно загрузить непосредственно с сервера Autodesk или его можно изменить перед копированием на рабочие станции пользователей. Чтобы пользователи не получали обновлений или уведомлений, обновление по сети можно отключить.
    ПримечаниеТакже можно включить или выключить опцию "Обновление по сети" в утилите Диспетчера Интернет-компонентов. См. раздел Установка и запуск "Диспетчера Интернет-компонентов"
  • Включить информационные каналы. Когда опция включена, информационные каналы предоставляют пользователям различную информации, например объявления о подписке и информацию по поддержке программы.
  • Включение CAD Manager Channel. Управляет отображением CAD Manager Channels в Инфоцентре. Кроме того, для получения возможности переключать CAD Manager Channels, можно также определить расположение канала CAD Manager и установить выводимое имя для CAD Manager Channels.
  • Включить RSS-каналы. Пользователи могут подписаться на любое число RSS-каналов. Каждый канал содержится внутри отдельной категории в Инфоцентре. Кроме того, можно указать, могут ли пользователи добавлять RSS-каналы.

Настройка Коммуникационного центра

  1. В процессе создания развертывания на странице "Настройка Коммуникационного центра Инфоцентра" выполните следующие настройки обновлений по сети:
    • Разрешить обновление по сети Пользователи могут получать обновления или поддерживать получение объявлений с серверов Autodesk.
    • Получать обновления с сервера Autodesk. При выборе этой опции пользователи смогут получать обновления продукта и уведомления о них с сервера Autodesk.
    • Получать обновления с внешнего сервера. Можно вести список обновлений на локальном сервере. При выборе этой опции поле "Local Patch List Location" (Расположение локального списка обновлений) становится активным. С помощью кнопки "Browse" (Обзор) определите путь к серверу, на котором будет храниться список обновлений. Подробную информацию об использовании локального списка обновлений можно узнать при установке Autodesk CAD Manager Tools 4.0, запустив утилиту Диспетчера интернет-компонентов, нажав кнопку "Справка" в окне утилиты Диспетчера интернет-компонентов.
      ПримечаниеМожно присвоить имя какому-либо файлу, который будет использоваться для хранения информации об обновлениях. При присвоении файлу имени с расширением n .npl создается файл-заменитель, а не собственно файл. В папке, заданной в поле "Путь к локальному списку обновлений", нужно создать текстовый файл с таким же именем, что было введено на данной странице.
  2. Указать, нужно ли разрешать работу информационных каналов.
  3. Указать, нужно ли разрешать работу каналов CAD Manager. В случае активирования опции можно выполнить следующие настройки:
    • Адрес RSS-канала Определяет расположение RSS-канала CAD Manager channel. RSS-каналы имеют формат XML.
    • Выводимое имя. Задает выводимое имя CAD Manager channel.
  4. Задает, разрешается ли работа RSS-канала и разрешается ли пользователям добавлять RSS-каналы.
  5. Нажмите "Далее".


Разрешение допуска пользователей к сетевым ресурсам (дополнительно)

Настройка Коммуникационного центра Инфоцентра (дополнительно)
Использование Мастера установки для настройки развертывания
Окончательный обзор и завершение установки
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Разрешение допуска пользователей к сетевым ресурсам (дополнительно)

На странице "Configure Access to Online Resources" (Настройка доступа к интерактивным ресурсам) можно определить, будут ли пользователи иметь доступ к таким интерактивным ресурсам, как получение обновлений по сети от Autodesk, использование информационных каналов, каналов CAD Manager и RSS. Здесь же можно разрешить доступ к Центру управления, Центру подписки, установить настройки для пользовательского отчета об ошибках и для пользования услугами Инфоцентра.

Центр Управления и Центр подписки

Вкладка "Интернет-модуль Центра управления" в Центре управления DesignCenter® предоставляет доступ к следующим элементам проектного содержимого: блоки, библиотеки компонентов, каталоги производителей и интернет-каталоги. Эти элементы могут использоваться в совместном проектировании, что повышает эффективность процесса создания чертежей. При отключении Интернет-модуля Центра управления его вкладка удаляется из всех установок, осуществляемых из данной папки развертывания. Включение Интернет-модуль Центра управления происходит по умолчанию.

Центр подписки предоставляет подписчикам доступ к различным ресурсам, например к материалам e-Learning (интерактивным урокам с индивидуально определяемыми сроками) и службе веб-поддержки (в которую пользователи могут в интерактивном режиме направлять технические вопросы, адресованные специалистам по поддержке Autodesk).

Чтобы определить, будут ли пользователи, имеющие право на использование ресурсов, предоставляемых по подписке, иметь к ним доступ, необходимо выбрать "Справка", а затем "Ресурсы подписки" (пользователи, не имеющие такого доступа, все равно могут узнать о ресурсах подписки, используя тот же элемент в меню "Справка").

ПримечаниеИмеется возможность также разрешить или запретить доступ к Центру управления и Центру подписки из утилиты Диспетчера интернет-компонентов.

Пользовательский отчет об ошибках (CER)

Если AutoCAD неожиданное закрывается, пользователи могут отправить отчет об ошибке непосредственно в компанию Autodesk, что поможет выявить и устранить проблему. Имеется также возможность указать, могут ли пользователи получать уведомление от Autodesk об обработке отчетов об ошибках.

ПримечаниеИмеется также возможность включения или выключения Пользовательского отчета об ошибках в утилите Диспетчера Интернет-компонентов.

Настройка параметров поиска Инфоцентра

На вкладке "Результаты поиска Инфоцентра" можно осуществить настройку отображения содержания из различных источников, например из справочной системы программы, CAD Manager Channels или Интернета.

Есть возможность указать, могут ли пользователи, которые устанавливают программный продукт из развертывания, настроить доступ к его областям поиска Инфоцентра.

Настройка доступа к сетевым ресурсам

  1. При создания развертывания на странице "Configure Access to Online Resources" (Настройка доступа к сетевым ресурсам)необходимо выполнить одну из следующих операций для настройки Интернет-модуля Центра управления:
    • Отключая Интернет-модуль Центра управления, убедитесь, что флажок "Включить Интернет-модуль Центра управления" снят.
    • Для подключения Интернет-модуля Центра управления установите флажок "Включить Интернет-модуль Центра управления".
  2. Для получения доступа к центру подписки установите или снимите флажок "Разрешить доступ к Центру подписки из продукта Autodesk (рекомендуется)". Данная опция включена по умолчанию.
  3. Если вы хотите получать уведомления о решении проблем, сделайте следующее:
    • Установите флажок "Разрешить пользователям получать уведомления", чтобы пользователи знали о решении проблем и могли загрузить соответствующее обновление Autodesk. Данная опция включена по умолчанию.
      ПримечаниеДля установки обновлений компании Autodesk пользователи должны иметь права администратора.
    • Установите флажок "Включить имя компьютера", чтобы включить в отчет имя компьютера пользователя. Имя компьютера включается в уведомления пользователям и отчеты, доступные для администратором подписки. Данная опция отключена по умолчанию.
  4. И наконец, укажите, будут ли пользователи иметь возможность настраивать папки поиска Инфоцентра. Данная опция включена по умолчанию.
  5. Нажмите кнопку "Завершение настройки".


Окончательный обзор и завершение установки

Разрешение допуска пользователей к сетевым ресурсам (дополнительно)
Использование Мастера установки для настройки развертывания
Регистрация программного продукта
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Окончательный обзор и завершение установки

Подтвердите выбранные настройки для завершения установки развертывания.

Подтверждение и завершение установки сетевого развертывания

  1. После установки всех параметров настройки развертывания на странице "Обзор - Настройка - Создание развертывания", просмотрите список текущих настроек и проверьте выбранные параметры установки.

  2. Если требуется изменить какие-либо из заданных настроек, сделанных во время развертывания, нажмите кнопку "Настройка".
  3. Если необходимо получить бумажную копию отображенной на этой странице информации по установке, нажмите кнопку "Печать".
  4. Для завершения развертывания нажмите кнопку "Создать развертывание".
  5. На странице "Развертывание завершено" нажмите кнопку "Готово".

Подтверждение и завершение установки развертывания отдельной версии на несколько пользователей

  1. После установки всех параметров настройки развертывания на странице "Обзор - Настройка - Создание развертывания", просмотрите список текущих настроек и проверьте выбранные параметры установки.

  2. Если требуется изменить какие-либо из заданных настроек, сделанных во время развертывания, нажмите кнопку "Настройка".
  3. Если необходимо получить бумажную копию отображенной на этой странице информации по установке, нажмите кнопку "Печать".
  4. Для завершения развертывания нажать кнопку "Создать развертывание".
  5. На странице "Deployment Complete" (Развертывание завершено) нажмите кнопку "Зарегистрировать продукты в оперативном режиме".

    В целях упрощения активации продукта на данном этапе процесса регистрации проверяется непротиворечивость используемых данных. При установке пользователем программы из этого развертывания и запуске продукта создается автоматическая ссылка на регистрационные данные, и продукт активируется. См. раздел Регистрация программного продукта.

  6. Нажмите "Готово".

Итак, в результате выполненных действий создана папка развертывания для продукта Autodesk с настройками, соответствующими нуждам конкретной группы пользователей. Теперь можно оповестить пользователей о расположении созданного установочного образа, для того чтобы они могли установить из него программу.


Регистрация программного продукта

Окончательный обзор и завершение установки
Использование Мастера установки для настройки развертывания
Модификация развертывания (дополнительно)
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Регистрация программного продукта

Очень важно, чтобы сообщаемые при регистрации и активации данные (например, название компании и контактная информация) данного программного продукта не противоречили аналогичным данным для всех устанавливаемых продуктов Autodesk. Неправильный ввод этих данных или их несовместимость могут вызвать проблемы при активации.

Способ регистрации программных продуктов зависит от типа выбранной лицензии при создании развертывания. Для получения кода активации продукт должен быть зарегистрирован.

Для регистрации развертывания с сетевой лицензией

  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") [image] Autodesk [image] Network License Manager [image] AutoCAD 2009 "Программа активации сетевой лицензии".
  2. На странице "Obtain a Network License" (Получение сетевой лицензии) ознакомьтесь с принципами работы утилиты и системными требованиями к ее использованию. Затем нажмите "Next" (Далее).
  3. При завершении процессов регистрации и активации руководствуйтесь инструкциями на экране.

Для регистрации развертывания отдельной версии на несколько пользователей

  1. На странице "Завершение развертывания" нажмите кнопку "Зарегистрировать продукты в оперативном режиме".

    Появится страница "Регистрация". На этом этапе нужно заполнить регистрационную форму таким образом, чтобы все пользователи имели одинаковые регистрационные данные.

  2. При завершении регистрации необходимо следовать инструкциям Мастера регистрации.
ПримечаниеЭтот процесс осуществляет только регистрацию продукта. Если пользователи подключены к Интернету, то активация выполняется автоматически при запуске программы.


Модификация развертывания (дополнительно)

Регистрация программного продукта
Использование Мастера установки для настройки развертывания
Представление установочного образа
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы > Использование Мастера установки для настройки развертывания >
Модификация развертывания (дополнительно)

После создания развертывания, возможно, придется модифицировать развертывание для некоторых клиентских рабочих станций. На этом этапе можно применить процедуру обновления или несколько дополнительных файлов, которые не являются частью главного установочного образа. Можно также изменить каталог установки с диска C на диск D.

Для редактирования папки развертывания

  1. Откройте сетевую папку общего доступа, в которой первоначально размещено развертывание продукта.
  2. В папке "Инструменты" дважды щелкните на ярлыке "Создание и редактирование развертывания".

    При этом повторно открывается Мастер установки.

  3. Просмотрите страницы Мастера развертывания и сделайте необходимые изменения.
  4. После завершения всех изменений нажмите кнопку "Создать развертывание".


Представление установочного образа

Модификация развертывания (дополнительно)
Развертывание программы
Удаление программы
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы >
Представление установочного образа

После завершения процесса развертывания пользователи могут установить программу из только что созданной или отредактированной папки развертывания. Администратор должен предоставить установочный образ пользователям, оповестив их о наличии ярлыка для установки. Имя ярлыка совпадает с указанным при создании развертывания. Подробную информацию о задании имен см. в разделе Создание развертывания.

Для представления установочного образа пользователям

  • Самый простой способ уведомления пользователей об установке программы из папки развертывания - это отправка письма по электронной почте с разъяснениями, как запустить процесс установки с помощью ярлыка. Письмо, как минимум, должно содержать информацию о пути к папке развертывания и необходимости двойного нажатия на ярлыке для запуска установки.
ПримечаниеПодробную информацию о способах запуска развертывания с помощью ярлыка см. в разделах Использование сценариев для развертывания программы, Использование групповой политики для установки из папки развертывания или Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания.


Удаление программы

Представление установочного образа
Развертывание программы
Использование сценариев для развертывания программы
Руководство сетевого администратора по AutoCAD 2009 > Развертывание программы >
Удаление программы

При удалении AutoCAD 2009 удаляются все установленные компоненты. Это происходит даже в том случае, если при предыдущем вызове программы установки производилось добавление или удаление компонентов, переустановка или восстановление программы. Из системы удаляются все файлы программы.

ПримечаниеЕсли в дальнейшем планируется редактировать установочный образ (например добавить в него файл обновления), этот образ удалять не следует.

Чтобы удалить программу

  1. В панели управления Windows выберите "Установка и удаление программ".
  2. В диалоговом окне "Установка и удаление программ" выберите AutoCAD 2009 и нажмите "Изменить Удалить".
  3. Когда открывается Мастер установки, нужно выбрать "Удалить AutoCAD 2009".
  4. На странице "Удаление AutoCAD 2009" нажмите "Далее" для удаления AutoCAD из системы.
  5. При появлении сообщения о том, что программный продукт полностью удален, нажмите "Готово".
ПримечаниеПрограммы Autodesk, используемые вместе с какой-либо программой (например Autodesk Design Review Review 2009), при удалении AutoCAD не удаляются автоматически. Их необходимо удалить отдельно с помощью окна "Установки и удаления программ".


Использование сценариев для развертывания программы

Удаление программы
Создание сценариев установки продукта
Руководство сетевого администратора по AutoCAD 2009 >
Использование сценариев для развертывания программы

Сценарий выполняет команду или набор команд. Сценарии во многом сходны с командными файлами, но являются более гибкими. Сценарии установки лучше всего использовать при автономной установке программ на подключенные к сети компьютеры. Их также применяют для установки пакетов обновления, расширений и адаптеров объектов в сети.

Для обеспечения успешной работы AutoCAD на том компьютере, на котором устанавливается эта программа, необходимо установить следующее программное обеспечение и обеспечить выполнение следующих условий:

  • Microsoft Internet Explorer версии 6.0 с пакетом обновления 1 или более поздней версии (можно загрузить Microsoft Internet Explorer с веб-узла корпорации Microsoft www.microsoft.com)
  • Microsoft Scripting Engine

    Примеры сценариев, которые можно найти в данном разделе, созданы в Microsoft Scripting Engine 5.6, работающем как с JavaScript, так и с VBS-сценариями Если обработчик сценариев не установлен, его можно бесплатно загрузить с веб-сайта компании Microsoft по адресу www.msdn.microsoft.com/scripting. Здесь также доступны для загрузки примеры сценариев и файлы справки.

  • Права администратора

Темы в этом разделе

  • Создание сценариев установки продукта
  • Пример сценария установки
  • Использование переключателей и флагов в сценариях
  • Запуск сценариев


Создание сценариев установки продукта

Использование сценариев для развертывания программы
Использование сценариев для развертывания программы
Пример сценария установки
Руководство сетевого администратора по AutoCAD 2009 > Использование сценариев для развертывания программы >
Создание сценариев установки продукта

Сценарий создается в текстовом редакторе (например, в Блокноте Windows), а затем сохраняется в формате ASCII в файле с расширением .vbs. Сценарий может состоять из одной или нескольких команд, а также параметров, задающих определенные опции, и флагов, изменяющих эти опции. Сценарий установки также содержит имена путей.

Сценарий установки указывает местоположение файла программы setup.exe. Необходимо выбрать файл setup.exe на компакт-диске. Например:

AutoCAD 2009 CDROM1\setup.exe


Пример сценария установки

Создание сценариев установки продукта
Использование сценариев для развертывания программы
Использование переключателей и флагов в сценариях
Руководство сетевого администратора по AutoCAD 2009 > Использование сценариев для развертывания программы >
Пример сценария установки

В примере сценария в этом разделе программа устанавливается в типовой конфигурации Для упрощения копирования этого примера сценария и подстановки собственной информации во всех пунктах используются одинаковые имена. Имя файла журнала определяется устанавливаемым продуктом. Имя файла журнала в сценарии можно оставить неизменным или заменить на другое.

Префикс серийного номера: 123

Серийный номер: 12345678

Имя: Ваше имя

Фамилия: Ваша фамилия

Организация: Название компании

В примере сценария автоматической установки этой программы используется синтаксис, описанный в данном разделе

Пакетная установка для AutoCAD 2009

' Пакетная установка для AutoCAD 2009
option explicit (явно заданные опции)
'
' Создание переменных
dim x64bit
dim shell
dim productType
dim featuresToInstall
dim strADSKFirstName
dim strADSKLastName
dim strADSKOrganization
dim strADSKSercirity
dim strADSKSerialIsvalid
dim strADSKAccept
dim strADSKEula
dim strADSKReInstall
dim strADSKRemove
dim strADSKSNPrefix
dim strADSKSNNumber
dim strInstallLevel
dim strACADStandaloneNetworkType
dim strADSKLicenseServerType
dim strADSKLicenseType
dim strADSKServerFmtPath
dim strADSKServerPath
dim strADSKServerHostID
dim strADSKPath
dim strSourcePath
dim strAdditionalStuff
'
' Инициализация пакета
Set shell = CreateObject("WScript.Shell")
productType = "acad"
'
' Информация об Организации и Имени
strADSKFirstName = "Ваше имя"
strADSKLastName = "Ваша фамилия"
strADSKOrganization = "Наименование организации"
'
' Информация о серийном номере
strADSKSNPrefix = "123"
strADSKSNNumber = "45678901"
'
Источник для установки находится на (например, предполагается, что на D: находится носитель для установки)
strSourcePath = "D:\"
' Размещение устанавливаемого продукта в
strADSKPath = Shell.ExpandEnvironmentStrings("%ProgramFiles%") + "\AutoCAD 2009"
'
Функции для установки
' ACS - AutoCAD Примеры
' CADStandards - Стандарты оформления
' ContentSearch - Поиск содержимого
' Database - базы данных (DBCONNECT)
' DCS - Примеры для DesignCenter
' DigSig - Цифровые подписи
' Dictionaries - Словари
' DrawingEncryption - Шифрование чертежей
' Express_Tools - Express Tools
' Fonts - Шрифты
' Impression - Панель инструментов Autodesk Impression
' Materials - Библиотека материалов
' Migrate - Перенос пользовательских настроек
' NFW - Семинар по новым возможностям
' PLM - Утилита перемещения лицензий
' RefMan - Диспетчер ссылок
' System_Files - Требуемые системные файлы (должны быть установлены по умолчанию в данном сценарии)
' TM - Текстуры
' VBA - Visual Basic for Applications
' VLS - Примеры Visual LISP
' VLT - Учебные пособия по Visual LISP
'
' Примеры ниже - Примечания предваряются запятой на первом знакоместе в строке
featuresToInstall = ",DigSig,TM,CADStandards,ContentSearch,Database,Dictionaries,DrawingEncryption,Express_Tools,Fonts,NFW,Migrate,RefMan,Samples,ACS,DCS,VBA,Materials,PLM,VLS,VLT"
strInstallLevel=3 ' 5 устанавливает все - 3 типовая установка - 0 использование featuresToInstall
'''''' Снимите обозначение комментария с определенной версии вашей установки - по умолчанию это Однопользовательская
' для  Однопользовательской
RunStandaloneInstall()
'
' Для сервера однопользовательской сетевой  лицензии
'RunSingleLicenseServerInstall()
'
' Для серверов избыточной сетевой лицензии
'RunRedundantLicenseServerInstall()
'
' Для серверов распределенной сетевой лицензии
'RunDistributedLicenseServerInstall()
'
' Конец пакета
Wscript.quit()
'
Function RunStandaloneInstall
shell.run DefaultCommand(),2,1
end function
'
Function RunSingleLicenseServerInstall
' Обновить правильной информацией для сервера лицензий
strACADStandaloneNetworkType = "3"
strADSKLicenseServerType = "Single Server License"
strADSKLicenseType = "Network License"
strADSKServerPath = "myFlexServer"
' адрес HOSTID или MAC
strADSKServerHOSTID = "000000000000"
'
' Объединение двух величин
strADSKServerPath = strADSKServerPath & " " & strADSKServerHOSTID
shell.run MakeCommand(),2,1
end function
'
Function RunRedundantLicenseServerInstall
' Обновить правильной информацией для сервера лицензий
strACADStandaloneNetworkType = "3"
strADSKLicenseServerType = "Redundant Server License"
strADSKLicenseType = "Network License"
'
' Формат -  SERVERNAME1 MACADDR1 PORT1;SERVERNAME2 MACADDR2 PORT2; SERVERNAME3 MACADDR3 PORT3; - Для избыточныз серверов допускается только 3
strADSKServerPath = " myflex1 000000000000 27005; myflex2 000000000000 27005; myflex3 000000000000 27005;"
shell.run MakeCommand(),2,1
end function
'
Function RunDistributedLicenseServerInstall
' Обновить правильной информацией для сервера лицензий
strACADStandaloneNetworkType = "3"
strADSKLicenseServerType = "Distributed Server License"
strADSKLicenseType = "Network License"
'
' Формат - @SERVERNAME1;SERVERNAME2;SERVERNAME3;
strADSKServerPath = "@ myFlexServer;@ myFlexServer2;@ myFlexServer3;"
'
shell.run MakeCommand() & "ACAD_LICENSESERVER_DISTRIBUTED=1",2,1
end function
'
Function DefaultCommand
dim retString
' /q для автоматической установки, ' /c [key] - замена параметров ключа
retString = """" & strSourcePath & "D:\setup.exe" & """" & " /t /q /c " & productType & ": "
retString = retString & "INSTALLDIR=" & """" & strADSKPath & """" & " "
retString = retString & "ACADSERIALPREFIX=" & strADSKSNPrefix & " "
retString = retString & "ACADSERIALNUMBER=" & strADSKSNNumber & " "
retString = retString & "ACADFIRSTNAME=" & """" & strADSKFirstName & """" & " "
retString = retString & "ACADLASTNAME=" & """" & strADSKLastName & """" & " "
retString = retString & "ACADORGANIZATION=" & """" & strADSKOrganization & """" & " "
если strInstallLevel = 0, то
retString = retString & "ADDLOCAL=" & """" & "System_Files" & featuresToInstall & """" & " "
или
retString = retString & "InstallLevel=" & strInstallLevel & " "
DefaultCommand = retString & " "
end if
DefaultCommand = retString & " "
end function
'
Function MakeCommand
dim retString
retString = DefaultCommand() & " "
retString = retString & "ACADSTANDALONENETWORKTYPE=" & """" & strACADStandaloneNetworkType & """" & " "
retString = retString & "ACADLICENSESERVERTYPE=" & """" & strADSKLicenseServerType & """" & " "
retString = retString & "ACADLICENSETYPE=" & """" & strADSKLicenseType & """" & " "
retString = retString & "ACADSERVERPATH=" & """" & strADSKServerPath & """" & " "
MakeCommand = retString
end function


Использование переключателей и флагов в сценариях

Пример сценария установки
Использование сценариев для развертывания программы
Запуск сценариев
Руководство сетевого администратора по AutoCAD 2009 > Использование сценариев для развертывания программы >
Использование переключателей и флагов в сценариях

В помещенной ниже таблице приведены переключатели и флаги, которые необходимы для установки

Примечание Параметр установки INSTALLDIR= обязателен. Иначе программы, запускаемые извне (не из AutoCAD), такие как утилита перемещения лицензий, не установятся.

Параметры в сценариях установки

Параметр

Описание

INSTALLDIR=

Папка для установки продукта.

ACADSERIALPREFIX=

Начальный фрагмент серийного номера (префикс).

ACADSERIALNUMBER=

Серийный номер.

ACADLASTNAME=

Вариант установки: 3=типовая

ACADFIRSTNAME=

Имя для ввода в персональные данные.

ACADLASTNAME=

Фамилия для ввода в персональные данные.

ACADORGANIZATION=

Название организации.

ADDLOCAL=

Используется для пользовательских установок, когда надо обозначить определенные компоненты для установки.

См. раздел Scripts for Custom Installations.

Флаги пользовательского интерфейса
Флаг | Описание
q | Обозначает, что установка осуществляется в недиалоговом режиме


Запуск сценариев

Использование переключателей и флагов в сценариях
Использование сценариев для развертывания программы
Использование групповой политики для установки из папки развертывания
Руководство сетевого администратора по AutoCAD 2009 > Использование сценариев для развертывания программы >
Запуск сценариев

После создания сценария переместите его на сервер или используйте обозначение сетевого диска или UNC-путь (универсальное соглашение об именовании). В случае расположения сценария на сервере для запуска пользователями создайте совместно используемый ресурс на сервере и добавьте пользователей с необходимыми правами доступа к этому ресурсу. Так как все, что нужно таким пользователям, это запустить сценарий, установите у каталога совместного ресурса параметр "Только для чтения".

Затем (на том же или на другом сервере) создайте папку для каждой устанавливаемой программы. Выберите неизменяемое местоположение папки, чтобы указать на файлы MSI в сценариях. Скопируйте установочные диски программ в эту папку. Возможно, возникнет желание создать директории для пакетов обновления, приложений и своих собственных средств адаптации.

Для запуска сценария установки можно использовать любой из описанных ниже способов.

  • Запустите сценарий вручную на каждой рабочей станции. Для запуска установки вставьте сценарий в диалоговое окно "Запуск" или запустите его из командной строки Windows.
  • Передайте по электронной почте каждому пользователю, который должен запустить сценарий, сообщение с указанием пути в формате UNC. Для запуска сценария пользователь выполняет инструкции.
  • Передайте по электронной почте каждому пользователю сообщение с инструкциями.
  • Настройте сценарий так, чтобы он запускался при регистрации пользователя.


Использование групповой политики для установки из папки развертывания

Запуск сценариев
Введение
Руководство сетевого администратора по AutoCAD 2009 >
Использование групповой политики для установки из папки развертывания

С помощью групповой политики можно анонсировать эту программу, назначая развертывание на компьютерах.

Для обеспечения успешной работы AutoCAD на том компьютере, на котором устанавливается эта программа, необходимо установить следующее программное обеспечение:

  • Microsoft .NET 3.0 (находится на установочном диске программы)
  • Microsoft Internet Explorer версии 6.0 с пакетом обновления 1 или более поздней версии (можно загрузить Microsoft Internet Explorer с веб-узла корпорации Майкрософт www.microsoft.com).
  • Microsoft Installer Package (MSI) 3.1
  • Microsoft Windows Media Format 9.5 (необходимо для 64-разрядной системы )
  • Macromedia Flash Player 9.0 (по умолчанию не устанавливается)
  • Autodesk Design Review 2009 (по умолчанию не устанавливается)
  • Компоненты VC runtime для x86 и x64 для 64-разрядных развертываний

Темы в этом разделе

  • Введение
  • Распространение развертывания с помощью групповой политики
  • Назначение развертывания компьютерам
  • Подтверждение установки программы из папки развертывания


Введение

Использование групповой политики для установки из папки развертывания
Использование групповой политики для установки из папки развертывания
Назначение развертывания с помощью групповой политики
Руководство сетевого администратора по AutoCAD 2009 > Использование групповой политики для установки из папки развертывания >
Введение

С помощью объектов групповой политики эту программу можно анонсировать на любом компьютере, который входит в среду Active Directory систем Windows 2000, Windows XP и Windows 2003 Server.

Темы в этом разделе

  • Назначение развертывания с помощью групповой политики
  • Преимущества и недостатки групповой политики


Назначение развертывания с помощью групповой политики

Введение
Введение
Преимущества и недостатки групповой политики
Руководство сетевого администратора по AutoCAD 2009 > Использование групповой политики для установки из папки развертывания > Введение >
Назначение развертывания с помощью групповой политики

Назначает для компьютера развертывание, созданное в процессе развертывания с помощью Мастера установки. Назначение развертывания позволяет установить программу на компьютер пользователя при следующем запуске компьютера.

Развертывание, назначенное компьютеру, доступно всем пользователям этого компьютера. Как правило, программу необходимо назначать компьютеру, если на нем работает большое количество пользователей.

ПримечаниеУстановка продуктов Autodesk разработана таким образом, что любой пользователь, который входит в систему, может запустить программу. При попытке назначить программу определенному пользователю, а не компьютеру, возможно, возникнут проблемы, когда другой пользователь данного компьютера попытается установить или удалить копию этой программы.


Преимущества и недостатки групповой политики

Назначение развертывания с помощью групповой политики
Введение
Распространение развертывания с помощью групповой политики
Руководство сетевого администратора по AutoCAD 2009 > Использование групповой политики для установки из папки развертывания > Введение >
Преимущества и недостатки групповой политики

В приведенной ниже таблице выделены преимущества и недостатки использования групповой политики.

Преимущества и недостатки групповой политики

Преимущества

Недостатки

  • Совместима с функциональными возможностями Мастера установки.
  • Нельзя передать параметры командной строки в исполняемый MSI-файл. Решение проблемы - в использовании сценариев.
  • С помощью функциональных возможностей Мастера установки можно просто добавить пользовательские файлы.
  • Развертывается на рабочую станцию.
  • Не может адаптировать настройки приложения, отличающиеся от установленных при создании развертывания с помощью Мастера установки.
  • Легко использовать.


Распространение развертывания с помощью групповой политики

Преимущества и недостатки групповой политики
Использование групповой политики для установки из папки развертывания
Назначение развертывания компьютерам
Руководство сетевого администратора по AutoCAD 2009 > Использование групповой политики для установки из папки развертывания >
Распространение развертывания с помощью групповой политики

Для распространения программы с помощью групповой политики необходимо выполнить три шага.

  1. Задание пункта распространения приложения. Пункт распространения приложения создан с помощью Мастера развертывания. В разделе Использование Мастера установки для настройки развертывания приведены инструкции по выполнению развертывания.
  2. Назначение программы компьютеру.
  3. Проверка установки. Убедитесь, что программа установлена правильно.


Назначение развертывания компьютерам

Распространение развертывания с помощью групповой политики
Использование групповой политики для установки из папки развертывания
Подтверждение установки программы из папки развертывания
Руководство сетевого администратора по AutoCAD 2009 > Использование групповой политики для установки из папки развертывания >
Назначение развертывания компьютерам

Когда программа назначается для компьютера, то она становится доступной для всех пользователей этого компьютера. Чтобы назначить программу для компьютеров, на сервере, который имеет доступ к среде Active Directory в системе Windows 2003 Server, Windows XP или Windows 2000, следует выполнить описанные ниже действия.

Для назначения развертывания компьютеру

  1. В меню "Пуск" (Windows) выбрать "Все программы" (или "Программы") [image] "Администрирование" [image] "Active Directory: пользователи и компьютеры".
  2. В окне "Active Directory: пользователи и компьютеры" нажмите правой кнопкой мыши на организационном подразделении, для которого нужно создать объект групповой политики. Затем выберите команду "Свойства".

    Открывается диалоговое окно "Свойства" для выбранного организационного подразделения.

    ПримечаниеДля того чтобы параметры создаваемого объекта групповой политики вступили в силу, необходимо, чтобы объекты-компьютеры принадлежали к выбранному сайту, домену или подразделению.
  3. На вкладке "Групповая политика" диалогового окна "Свойства" нажмите кнопку "Создать". Введите имя объекта групповой политики. Например, введите AutoCAD Computer Assigned Installation.

    Создается новый объект групповой политики, который добавляется в список "Ссылки на объекты групповой политики".

  4. В списке записей в окне "Ссылки на объекты групповой политики" выберите созданный объект групповой политики и нажать кнопку "Изменить".
  5. Выполните одно из следующих действий:
    • Для Windows 2003 Active Directory: В окне "Редактирование объектов групповой политики" на вкладке "Конфигурация компьютера" щелкните на значке "плюс" (+) рядом с папкой Конфигурация программ для раскрытия списка.
    • Для Windows 2000 Active Directory: В окне "Групповая политика" на вкладке "Конфигурация компьютера" щелкните на значке "плюс" (+) рядом с папкой Конфигурация программ для раскрытия списка.
  6. В разделе "Конфигурация программ" щелкните правой кнопкой вкладку "Установка программ", а затем выберите "Свойства".
  7. В диалоговом окне "Свойства: установка программ" на вкладке "Общие" нажмите "Обзор".
  8. В диалоговом окне "Обзор папок" перейдите к пункту распространения приложения, созданному с помощью Мастера развертывания, и выберите папку AdminImage. Затем нажмите "OK".

    В диалоговом окне "Свойства: Установка программ" отображаются заданный по умолчанию путь к программному пакету (в UNC-формате), имя сервера, выбранная папка общего доступа и папка AdminImage. Например:

    \\server123\Deployment\AdminImage\x86 или x64, в зависимости от типа процесса

  9. Выполните одно из следующих действий:
    • Для Windows 2003 Active Directory. На вкладке "Общие" в разделе "Новые пакеты" выберите параметр "Дополнительно" для выбора способа, используемого при создании нового пакета. Этот способ позволяет также выбрать файл преобразования, созданный Мастером развертывания.
    • Для Windows 2000 Active Directory: На вкладке "Общие" в разделе "Новые пакеты" выберите параметр "Разрешать расширенную публикацию/назначение" для выбора способа, используемого при создании нового пакета. Этот способ позволяет также выбрать файл преобразования, созданный Мастером развертывания.
  10. Нажмите "OK", чтобы закрыть диалоговое окно "Свойства: Установка программ".
  11. Выполните одно из следующих действий:
    • Для Windows 2003 Active Directory: в диалоговом окне "Редактор объектов групповой политики" в области "Параметры программ"нажмите правую кнопку мыши на пункте "Установка программы" и выберите "Создать" [image] "Комплект".
    • Для Windows 2000 Active Directory: В диалоговом окне "Групповая политика" в области "Параметры программ" нажмите правую кнопку мыши на пункте "Установка программы" и выберите "Создать" [image] "Комплект".
  12. В диалоговом окне "Открыть" убедитесь, что выбран файл пакетов Windows Installer (acad.msi) и нажмите кнопку "Открыть". Диалоговое окно "Открыть" показывает те пакеты, которые расположены в пункте распространения программного обеспечения, выбранном по умолчанию.

    Если установочный образ был создан не в пункте распространения программного обеспечения, нужно найти его файлы и выбрать среди них файл acad.msi.

  13. В диалоговом окне "Свойства: <имя продукта>" перейдите на вкладку "Развертывание". Убедитесь, что в группе "Тип развертывания" выбран параметр "Назначенный".
  14. На вкладке "Модификации" нажмите кнопку "Добавить".
  15. В диалоговом окне "Открыть" выберите файл преобразования (файл с расширением MST), созданный Мастером развертывания. Затем нажмите кнопку "Открыть".

    Если установочный образ был создан не в пункте распространения программного обеспечения, нужно найти его файлы и выбрать среди них файл преобразования (файл с расширением .mst).

  16. В диалоговом окне "Свойства: <product name>" на вкладке "Модификации" выбранный файл преобразования добавляется в список "Модификации". Нажмите "ОК".
    ПримечаниеЕсли создан объект групповой политики, необходимо выбрать файл преобразования, созданный Мастером развертывания. После создания объекта групповой политики добавить или удалить пакетные файлы преобразований невозможно. Если не выбрать файл преобразования, программу не удастся установить на клиент-компьютере.
  17. Выполните одно из следующих действий:
    • Для Windows 2003 Active Directory. В окне "Редактирование объектов групповой политики" на вкладке "Конфигурация компьютера" нажмите "Установка программ". Только что созданный пакет программы отобразится в правой области окна.
    • Для Windows 2000 Active Directory. В окне "Групповая политика" на вкладке "Конфигурация компьютера" нажмите "Установка программ". Только что созданный пакет программы отобразится в правой области окна.
  18. Выполните одно из следующих действий:
    • Для Windows 2003 Active Directory: закройте окно "Редактирование объектов групповой политики" и все окна, относящиеся к "Active Directory".
    • Для Windows 2000 Active Directory: закройте окно "Групповая политика" и все окна, относящиеся к "Active Directory".

Эта программа назначается для всех компьютеров, входящих в состав организационного подразделения, для которого был создан объект групповой политики. При следующем запуске компьютера программа будет установлена и доступна для всех пользователей этого компьютера. Информацию о подтверждении правильности создания объекта групповой политики см. в разделе Подтверждение установки программы из папки развертывания.


Подтверждение установки программы из папки развертывания

Назначение развертывания компьютерам
Использование групповой политики для установки из папки развертывания
Проверка назначения программы для компьютера
Руководство сетевого администратора по AutoCAD 2009 > Использование групповой политики для установки из папки развертывания >
Подтверждение установки программы из папки развертывания

После перезагрузки компьютера выводятся сообщения операционной системы о групповой политике - обычно они появляются до диалогового окна 'Вход в Windows' или сразу после него. Выводятся сообщения о следующих процессах:

  • Запуск Windows.
  • Применение параметров компьютера
  • Установка программы <приложения>
  • Применение параметров установки программного обеспечения
  • Загрузка личных параметров
  • Применение личных параметров

Пользователи рабочих станций, работающих в Windows XP или Windows 2000, регистрируются в организационном подразделении или на компьютере, для которого была создана групповая политика.

ПримечаниеПри возникновении проблем в средстве просмотра событий в разделе "Приложения" регистрируются соответствующая запись.

Темы в этом разделе

  • Проверка назначения программы для компьютера


Проверка назначения программы для компьютера

Подтверждение установки программы из папки развертывания
Подтверждение установки программы из папки развертывания
Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания
Руководство сетевого администратора по AutoCAD 2009 > Использование групповой политики для установки из папки развертывания > Подтверждение установки программы из папки развертывания >
Проверка назначения программы для компьютера

Для того чтобы убедиться, что эта программа правильно назначена для компьютера, нужно перезапустить компьютер, входящий в состав организационного подразделения, для которой была создана групповая политика. Программа устанавливается до отображения приглашения на вход в систему. После входа в систему дважды нажмите кнопку мыши на ярлыке программы на рабочем столе. Начнется процесс вторичной установки. Программа запустится после завершения установки.


Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания

Проверка назначения программы для компьютера
Введение
Руководство сетевого администратора по AutoCAD 2009 >
Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания

В приложении имеется подробное описание по развертыванию программного обеспечения Autodesk с помощью пакета Microsoft® System Center Configuration Manager (SCCM). Система SCCM позволяет осуществлять удаленное управление распределением программ среди выбранных целевых систем.

Темы в этом разделе

  • Введение
  • Подготовка к развертыванию продуктов Autodesk с помощью SCCM
  • Настройка исходной папки с помощью Мастера развертывания
  • Создание SCCM-пакета установки программного обеспечения


Введение

Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания
Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания
Подготовка к развертыванию продуктов Autodesk с помощью SCCM
Руководство сетевого администратора по AutoCAD 2009 > Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания >
Введение

Для развертывания продуктов Autodesk необходимо иметь представление о процедуре распространения программ SCCM/SMS. Более подробную информацию по данному вопросу можно найти в документации по SCCM Microsoft и вспомогательным ресурсам.


Подготовка к развертыванию продуктов Autodesk с помощью SCCM

Введение
Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания
Настройка исходной папки с помощью Мастера развертывания
Руководство сетевого администратора по AutoCAD 2009 > Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания >
Подготовка к развертыванию продуктов Autodesk с помощью SCCM

Для развертывания программ Autodesk с помощью SCCM рекомендуется выполнить следующие действия:

  • Определить или создать группу целевых систем, на которых будет установлен данный пакет программ
  • С помощью Мастера развертывания создать исходную папку
  • Создать пакет SCCM для развертывания на целевых системах
  • Указать путь к исходным файлам
  • Распределить пакет SCCM по целевым пунктам
  • Создать анонс для информирования пользователей о наличии данного пакета программ


Настройка исходной папки с помощью Мастера развертывания

Подготовка к развертыванию продуктов Autodesk с помощью SCCM
Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания
Создание SCCM-пакета установки программного обеспечения
Руководство сетевого администратора по AutoCAD 2009 > Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания >
Настройка исходной папки с помощью Мастера развертывания

При использовании SCCM для развертывания продуктов Autodesk нужно настроить исходную папку с помощью Мастера развертывания.

Мастер развертывания создает установочный образ, который используется Диспетчером SCCM для распространения программного обеспечения Autodesk по целевым системам. Папка, в которой выполняется административная установка, становится исходной папкой пакета.

Подробные сведения о развертываниях и об установке исходной папки для программ Autodesk см. в следующих разделах Руководства сетевого администратора:

  • Подготовка к сетевому развертыванию
  • Создание развертывания
  • Использование Мастера установки для настройки развертывания
  • Модификация развертывания (дополнительно)
ПримечаниеЧтобы избежать проблем, связанных с установочным образом и с развертыванием, рекомендуется до настройки SCCM для развертывания программы протестировать созданное с помощью Мастера развертывания.

Для тестирования пакета развертывания, созданного Мастером развертывания

  1. Войдите в рабочую станцию Windows XP Professional или Vista как пользователь с правами администратора.
  2. Перейдите к исходной папке, в которой было создано развертывание.
  3. Дважды нажмите кнопку мыши на ярлыке, созданном Мастером развертывания.

    Либо программа установится, либо в файл журнала в %temp% будет записана информация об ошибке.


Создание SCCM-пакета установки программного обеспечения

Настройка исходной папки с помощью Мастера развертывания
Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания
Распространения программы с использованием программы создания образов
Руководство сетевого администратора по AutoCAD 2009 > Использование Диспетчера конфигурации системного центра Microsoft System Center Configuration Manager для установки развертывания >
Создание SCCM-пакета установки программного обеспечения

После создания исходной папки с помощью Мастера развертывания нужно создать SCCM-пакет установки программного обеспечения. Пакет SCCM содержит файлы и инструкции, используемые системой SCCM для распределения программ и анонсирования пакета. Набор файлов и инструкций создается Мастером развертывания, но SCCM необходимо настроить для использования этих файлов.

Для создания пакета установки программного обеспечения с помощью SCCM

  1. В меню "Пуск" (Windows), выберите "Все программы" (или "Программы") [image] Microsoft System Center [image] Configuration Manager 2007 [image] ConfigMgr.
  2. В окне "Configuration Manager Console" (Консоль диспетчера настройки) разверните окно "Распределение программного обеспечения" (Software Distribution).
  3. Правой кнопкой щелкните Packages (Пакеты) [image] Distribute (Распределить) [image] Software (Программы).
  4. В Мастере распределения программ (Distribute Software Wizard) нажмите "Далее".
  5. В диалоговом окне "Package" (Пакет) выберите "Create a new package and program without a definition file" (Создать новый пакет и программу без файла определения). Нажмите Next (Далее).
  6. В диалоговом окне "Package Identification" ("Определение пакета") введите сведения в поля "Name" (Имя), "Version" (Версия), "Publisher" (Разработчик), "Language" (Язык) и необходимые пояснения. Нажмите Next (Далее).
  7. В диалоговом окне "Source Files" (Исходные файлы) определяется папка, из которой SCCM извлекает файлы, и способ управления этими файлами. Выбрав нужные варианты, нажмите "Далее".
    ПримечаниеВ данной процедуре была выбрана опция "Always obtain files from a source directory" (Всегда извлекать файлы из исходной папки).
  8. В диалоговом окне "Source Directory" (Исходная папка) укажите папку хранения исходных файлов. Путь к исходной папке должен содержать "AdminImage" в качестве имени последней папки Нажмите Next (Далее).
  9. В диалоговом окне "Distribution Points" (Пункты распределения) выберите пункт (пункты) распределения. Это место из которого пакет программного обеспечения будет распределен в целевых системах. Нажмите Next (Далее).
  10. В диалоговом окне "Program Identification" (Определение программы) введите имя программы. Именно это имя отображается в области "Установка и удаление программ" панели управления. В поле командной строки введите setup.exe /i <deployment name>.ini. В этом случае развертывание имеет название AutoCAD 2009, поэтому следует ввести setup.exe /i AutoCAD 2009.ini. Нажмите Next (Далее).
  11. В диалоговом окне "Свойства программы" в раскрывающемся списке "Требования запуска" необходимо выбрать способ установки требуемой программы. Имеются следующие варианты:
    • Только при входе пользователя в систему
    • Независимо от входа пользователя в систему
    • Только при отсутствии вошедших в систему пользователей
  12. В раскрывающемся списке "After Running" (После выполнения) необходимо выбрать действие, которое будет выполняться после развертывания программы. Имеются следующие варианты:
    • "No action required" (Действия не требуются)
    • "Program restarts computer" (Программа выполняет перезагрузку компьютера)
    • "ConfigMgr restarts computer" (ConfigMgr выполняет перезагрузку компьютера)
    • "ConfigMgr logs user off" (ConfigMgr завершает сеанс работы пользователя)
    Примечание"AutoCAD 2009 requires you to restart your system after installation" (AutoCAD 2009 требует перезапустить систему после установки).
    Нажмите Next (Далее).
  13. В диалоговом окне "Advertise Program" (Анонсировать программу) выберите "Yes" (Да) для анонсирования программы. Нажмите Next (Далее).
  14. В диалоговом окне "Select a Program to Advertise" (Выбор программы для анонсирования) выберите пакет, подлежащий анонсированию. Нажмите Next (Далее).
  15. В диалоговом окне "Select Program [image] Advertisement Target" (Выбор программы - Цель анонсирования) выберите группу, для которой требуется выполнить анонсирование, либо создайте новую группу.
  16. В диалоговом окне "Select Program [image] Advertisement Name" (Выбор программы - Имя анонсирования) выберите или измените имя анонсирования. Добавьте комментарии для дополнительного описания анонсирования. Нажмите Next (Далее).
  17. В диалоговом окне "Select Program [image] Advertisement Subcollection" (Выбор программы - Подгруппа анонсирования) выберите одну из следующих возможностей:
    • Анонсирование этой программы для существующей группы.
    • Создание новой группы и анонсирование этой программы для нее
  18. Нажмите Next (Далее).
  19. В диалоговом окне "Select Program [image] Advertisement Schedule" (Выбор программы - План анонсирования) по желанию выполните требуемые настройки для анонсирования программы при наступлении каких-либо конкретных даты и времени или задайте дату прекращения действия. Нажмите Next (Далее).
  20. В диалоговом окне "Select Program [image] Assign Program" (Выбор программы - Назначение программы) выберите одну из следующих возможностей:
    • Если процедура установки является обязательной, выберите "Yes, assign the program" (Да, назначить программу).
    • Если процедура установки не является обязательной, выберите "No, do not assign the program" (Нет, не назначать программу).
    Нажмите Next (Далее).
  21. В диаловом окне "Summary" (Сводка) проверьте анонсируемую информацию. Для внесения в них каких-либо изменений используйте кнопку "Назад". Для завершения нажмите "Далее".


Распространения программы с использованием программы создания образов

Создание SCCM-пакета установки программного обеспечения
Использование главного образа для распространения отдельной версии на несколько пользователей в многоэлементных системах
Руководство сетевого администратора по AutoCAD 2009 >
Распространения программы с использованием программы создания образов

Следующая информация предназначена для тех, кто при распространении программ Autodesk использует программы создания образов, например Norton Ghost, для создания главного образа. Будучи один раз созданными, главные образы затем тиражируются на другие компьютеры с помощью своих функций.

Необходимо соблюдать осторожность, так как использование программ создания образов может приводить к следующим ситуациям:

  • Конфликты с лицензированием программного продукта
  • Незавершенная установка и проблемы с активацией
Примечание Если в среде RAID SATA возникает неустойчивость лицензирования, то при использовании программ создания образов для распространения программных продуктов Autodesk могут возникать проблемы, связанные с активацией продукта; например, при попытке активации появляется сообщение "Activation code limit exceeded" ("Превышен предел кода активации").

Темы в этом разделе

  • Использование главного образа для распространения отдельной версии на несколько пользователей в многоэлементных системах
  • Использование главного образа для распространения программных продуктов с сетевой лицензией в многоэлементных системах
  • Восстановление главного образа
  • Очистите основную систему и восстановите операционную систему


Использование главного образа для распространения отдельной версии на несколько пользователей в многоэлементных системах

Распространения программы с использованием программы создания образов
Распространения программы с использованием программы создания образов
Использование главного образа для распространения программных продуктов с сетевой лицензией в многоэлементных системах
Руководство сетевого администратора по AutoCAD 2009 > Распространения программы с использованием программы создания образов >
Использование главного образа для распространения отдельной версии на несколько пользователей в многоэлементных системах

Отдельную версию программы для нескольких рабочих мест можно распространять с помощью главного образа.

ПримечаниеПри использовании Norton Ghost нужно установить переключатель -ib , чтобы включить загрузочный сектор в главный образ. Для получения дополнительной информации по включению загрузочного сектора в качестве части главного образа ознакомьтесь с документацией по программе создания образов.

Главные образы нельзя создавать, если на главном компьютере ранее были запущены программные продукты Autodesk. Может возникнуть необходимость очистить систему. См. раздел Очистите основную систему и восстановите операционную систему .

Распространение отдельной версии программы Autodesk на несколько рабочих мест с помощью главного образа

  1. Создайте сетевое развертывание для отдельной версии программы на несколько рабочих мест. Более подробную информацию см. в разделе Использование Мастера установки для настройки развертывания .
  2. Установите путем развертывания программу Autodesk на основной компьютер.
  3. На основном компьютере выполните одно из следующих действий:
    • Создайте главный образ, включая загрузочный сектор. Протестируйте программу на другом компьютере перед ее распространением. Запустите программу на другом компьютере, зарегистрируйте и активируйте ее. Для регистрации и активации программы на компьютерах пользователя отводится 30-дневный период.
    • Запустите и адаптируйте программу (если требуется). Создайте главный образ и распространите его среди пользователей. Если компьютеры пользователей подключены к сети Интернет, производится автоматическая активация программного продукта. Пользователи, чьи компьютеры не подключены к сети Интернет, должны выполнить регистрацию и активацию продукта в течение 7 дней.
  4. Примените главный образ к компьютеру-приемнику.


Использование главного образа для распространения программных продуктов с сетевой лицензией в многоэлементных системах

Использование главного образа для распространения отдельной версии на несколько пользователей в многоэлементных системах
Распространения программы с использованием программы создания образов
Восстановление главного образа
Руководство сетевого администратора по AutoCAD 2009 > Распространения программы с использованием программы создания образов >
Использование главного образа для распространения программных продуктов с сетевой лицензией в многоэлементных системах

Сетевую лицензированную версию программы можно распространять с помощью главного образа.

Распространение сетевого развертывания программы Autodesk на несколько рабочих мест с помощью главного образа

  1. Создайте сетевое развертывания для сетевой лицензионной программы. Более подробную информацию см. в разделе Использование Мастера установки для настройки развертывания .
  2. Установите путем развертывания программу Autodesk на основной компьютер.
    ПримечаниеСервер лицензий должен быть запущен, и все компьютеры должны быть подключены к сети для получения лицензии на программу.
  3. После установки программного продукта Autodesk можно использовать программы создания образов для создания главного образа жесткого диска системы.
  4. Примените главный образ к компьютеру-приемнику.


Восстановление главного образа

Использование главного образа для распространения программных продуктов с сетевой лицензией в многоэлементных системах
Распространения программы с использованием программы создания образов
Очистите основную систему и восстановите операционную систему
Руководство сетевого администратора по AutoCAD 2009 > Распространения программы с использованием программы создания образов >
Восстановление главного образа

В следующей процедуре предполагается, что перед форматированием диска рабочей станции имеется сохраненная копия папки Software Licenses (и папкиProduct Licenses) для всех рабочих станций на другой рабочей станции или на диске DVD.

Восстановление программы с помощью главного образа

  1. Закройте приложение. Не запускайте его до полного завершения данной процедуры.
  2. В Windows Explorer скопируйте папку Software Licenses из расположения, путь к которому показан ниже, в другое место вне диска, который будет восстановлен.

    C:\Documents and Settings\All Users\Application Data\Autodesk\Software Licenses

  3. Отформатируйте диски рабочей станции и восстановите систему с главного образа.
    ПримечаниеНе следует выполнять низкоуровневое форматирование жесткого диска.
  4. Скопируйте папку Software Licenses, которая была создана на этапе 2, на исходную рабочую станцию и в ее исходное место на диске этой станции.
ПримечаниеПри восстановлении образа диска все измененные файлы помещаются обратно в своем исходном состоянии. Файлы лицензий сохраняются, повторная активация программ не требуется.


Очистите основную систему и восстановите операционную систему

Восстановление главного образа
Распространения программы с использованием программы создания образов
Глоссарий
Руководство сетевого администратора по AutoCAD 2009 > Распространения программы с использованием программы создания образов >
Очистите основную систему и восстановите операционную систему

Если программа Autodesk уже запускалась на основном компьютере, то этот компьютер следует тщательно очистить.

Чистка основного компьютера и восстановление операционной системы

  1. Удалите все с жесткого диска, включая загрузочный сектор.

    Например, для утилиты Norton’s GDISK используется следующая команда:

    gdisk 1 /diskwipe

    Если указано 1, то это дисковое пространство, которое будет очищено.

    ПримечаниеЕсли используется другая программа, необходимо убедиться, что очищается загрузочный сектор. В противном случае будет невозможно активировать программы Autodesk.
  2. Создайте новый раздел, с резервного или установочного диска установите операционную систему.


Глоссарий

Очистите основную систему и восстановите операционную систему
Руководство сетевого администратора по AutoCAD 2009 >
Глоссарий
Active Directory

Служба каталогов компании Microsoft, которая используется в операционных системах Windows 2000 и Windows 2003 Server.

FLEXlm

Технология управления лицензиями компании Macrovision Software, Inc. FLEXlm предоставляет средства администрирования, которые позволяют упростить управление сетевыми лицензиями. Средства FLEXlm можно использовать для просмотра статуса сетевых лицензий, восстановления лицензий, потерянных вследствие сбоев системы, устранения ошибок на серверах лицензий, а также обновления существующих файлов лицензий.

MSI

Установщик программ Microsoft installer. Поддерживает большой набор параметров, которые можно использовать в сценариях установки.

MSP

Файл обновлений, разработанный Microsoft (см. также обновление)

MST

Файл преобразования. Производит настройку компонентов, установленных MSI-файлом. Например, Мастер развертывания создает MST-файл с заданными настройками. Созданное Мастером развертывание использует MST-файл совместно с файлами MSI и MSIEXEC для установки программы на локальные рабочие станции.

SMS

Systems Management Server (Система управления сетями). Средство администрирования сетевых компьютеров с помощью удаленной настройки, принудительного развертывания и администрирования пользователей. SMS является довольно дорогой технологией, которую нужно приобретать отдельно как дополнительный сервер.

автономная установка на несколько пользователей

Тип установки, в котором устанавливаются автономные версии программ для нескольких пользователей с использованием одного серийного номера.

активация

Этап процесса регистрации программ Autodesk, позволяющий запускать программу в соответствии с лицензионным договором.

анонсирование

Технология передачи данных по требованию, которая позволяет уведомлять пользователей о доступных для установки обновлениях программных продуктов. Для завершения установки анонсируемого продукта пользователь должен дважды нажать кнопку мыши на ярлыке программы (или выполнить аналогичную операцию, открывающую приложение).

Быстрый запуск AutoCAD (acstart17.exe)

Оперативная процедура, которая позволяет ускорить первоначальный запуск AutoCAD.

главный установочный образ

Набор доступных для пользователей сети файлов, созданный Мастером развертывания и используемый для установки программы на рабочие станции. С помощью Мастера развертывания в главный установочный образ могут включаться пакеты обновлений и отдельные обновления.

групповая политика

Серверная технология Microsoft, служащая для выполнения принудительных установок и установок на основе анонсирования при помощи стандартных компонентов администрирования Microsoft 2000 Server.

исправление

Программное обновление для приложения.

опытный пользователь

Пользователь, обладающий правами на доступ и запись в папку Program Files и раздел реестра HKEY_Local_Machine.

пакет обновления

Термин, использующийся для обозначения файлов обновления продуктов Autodesk.

преобразование

См. MST.

процесс развертывания

Процесс установки продуктов Autodesk на один или несколько компьютеров в сети.

работа со сценариями

Процедура использования языков сценариев, например VB Script, для облегчения развертывания пакетов программного обеспечения.

развертывание

Ссылка на уникальный MST-файл, служащий основой для установки. С помощью Мастера развертывания администратор может создать несколько развертываний, предназначенных для разных типов установки для пользователей.

служба каталогов

Сетевая служба, которая хранит сведения о ресурсах сети и предоставляет возможность пользователям и приложениям легко находить и использовать эти данные. К ресурсам сети в данном случае относятся адреса электронной почты, учетные записи компьютеров и периферийные устройства, такие как принтеры. В идеале, служба каталога должна делать топологию физической сети и используемые протоколы настолько прозрачными, чтобы пользователи могли получить доступ к любому сетевому ресурсу вне зависимости от того, где он физически расположен. Все службы каталогов основаны на стандарте X.500 ITU.

технология передачи данных по требованию

Технология установки, требующая от пользователя определенных действий для завершения процесса установки.

технология принудительной передачи данных

Технология установки, не требующая участия пользователя в установке файлов на рабочий стол удаленной рабочей станции.

установка в недиалоговом режиме

Режим установки, не требующий от пользователя ввода информации. Во время процесса установки диалоговые окна не выводятся.

установочный образ

Развертывание, состоящее из файла MSI, всех связанных преобразований, выбранных пользователем дополнительных нестандартных файлов, профиля и параметров реестра.

частичный профиль

Профиль, содержащий значения некоторых параметров реестра, которые заданы в соответствии с набором опций, доступных на вкладке "Файлы" диалогового окна "Настройка".


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!