Утилита "Диспетчер Интернет-компонентов"

Диспетчер Интернет-компонентов позволяет менеджерам САПР выборочно предоставлять пользователям доступ к ресурсам сети Интернет и информации в DesignCenter Online, Коммуникационном центре и Центре подписки. Также можно определить, будут ли пользователи получать уведомления об обработке отчетов об ошибках.

Окно "Диспетчер Интернет-компонентов" содержит следующие вкладки:

  • Коммуникационный центр
  • Design Center Online
  • Центр подписки
  • Отчет об ошибках

Установка утилиты "Диспетчер Интернет-компонентов" выполняется на вкладке "Установка" обозревателя диска.

Установка Диспетчера Интернет-компонентов
  1. Вставьте установочный диск программы в дисковод CD-ROM.
  2. В обозревателе диска перейдите на вкладку "Установка".
  3. Установите флажок "Автономная установка на несколько пользователей" или "Сетевое развертывание" (не доступно для AutoCAD LT).
  4. В разделе "Установка дополнительных средств" выберите Autodesk CAD Manager Tools 4.0.
  5. В области Autodesk CAD Manager Tools 4.0 нажмите кнопку "Установить".

    6. После установки утилиты "Диспетчер Интернет-компонентов" ее можно запустить из меню "Пуск" (Windows).

Запуск Диспетчера Интернет-компонентов
  1. В меню "Пуск" (Windows) выберите "Все программы" (или "Программы") » Autodesk » CAD Manager Tools » "Диспетчер Интернет-компонентов".
  2. Выберите программу, которую требуется изменить. Нажмите "ОК".

Темы:

  • Вкладка "Коммуникационный центр"
  • Вкладка "Design Center Online"
  • Вкладка "Центр подписки"
  • Вкладка "Отчет об ошибках"
Ваш комментарий об этой странице


Вкладка "Коммуникационный центр"

Вкладка "Коммуникационный центр"

На вкладке "Коммуникационный центр" отображается последняя информация о программе, обновлениях, объявления служб технической поддержки и подписки и другие объявления, связанные с программой. Обновление программ выполняется с помощью функции "Обновление по сети". Данная функция уведомляет пользователей о доступных технических обновлениях.

На вкладке "Коммуникационный центр" имеются опции доступа к Коммуникационному центру.

Можно включить или отключить обновление по сети, указать местоположение для обновлений программ и включить доступ к информационным каналам.

Включить Коммуникационный центр

Возможность доступа к Коммуникационному центру из строки состояния и получение обновлений программ, статей и объявлений служб технической поддержки.

Отключить Коммуникационный центр

Отключение доступа пользователей к Коммуникационному центру.

Настройка обновления по сети

Включение или отключение обновления по сети. Если обновление по сети включено, можно выбрать получение списка обновлений с серверов Autodesk или из сетевой папки.

Если требуется, чтобы пользователи получали уведомления о технических обновлениях, можно указать список обновлений на веб-сервере или на локальном сервере. В зависимости от версии настраиваемой программы список обновлений представляется в виде текстового или XML-файла, определяющего список обновлений, доступных для установки.

Программы на основе AutoCAD 2007

Если утилита "Диспетчер Интернет-компонентов" используется с программами на основе AutoCAD 2007, файл списка обновлений представляет собой XML-файл, не требующий редактирования. Если выбрана опция "Получать обновления из локальной сети" и в диалоговом окне "Обзор папок" указано местоположение локального списка обновлений, в папке списка обновлений автоматически создается файл с именем patchlist.npl, если в папке нет файла с расширением .npl.

Если указана папка списка обновлений, содержащая несколько списков, в диалоговом окне "Статус папки обновлений" отображается предложение выбрать список обновлений.

Примечание В диалоговое окно "Обзор папок" можно вставить путь, использующий соглашение об универсальном именовании (UNC).

Если выбрать файл списка обновлений с расширением .txt, в диалоговом окне "Статус папки обновлений" отображается предупредительное сообщение о неверном формате файле и предложение выбрать файл с расширением .npl.

После выбора местоположения списка обновлений становится доступной кнопка "Управление обновлениями". Эта кнопка позволяет проверить наличие технических обновлений на сервере обновлений Autodesk для программы, выбранной при запуске Диспетчера Интернет-компонентов.

При обнаружении обновлений в диалоговом окне "Статус Коммуникационного центра" сообщается об установлении соединения с сервером Autodesk. После получения обновления включаются в список в диалоговом окне "Управление папкой обновлений". Если технические обновления недоступны, в диалоговом окне "Статус Коммуникационного центра" выводится предложение проверить наличие обновлений позднее.

Диалоговое окно "Управление папкой обновлений"

Диалоговое окно "Управление папкой обновлений" представляет собой интерфейс управления обновлениями программ на основе AutoCAD 2007. Строка заголовка окна включает название программы, выбранной при запуске Диспетчера Интернет-компонентов. Технические обновления, полученные с сервера обновления Autodesk, перечисляются в списке раздела "Управление обновлениями". Можно просмотреть сведения о каждом обновлении, загрузить обновления в локальную папку обновлений или удалить их из списка.

Местоположение списка обновлений

Имя файла списка обновлений и путь к нему в локальной сети.

Управление обновлениями

Список обновлений, полученных с сервера обновлений Autodesk. Справа от названия обновления расположен значок состояния, информирующий о готовности обновления для загрузки, окончании загрузки или неудачном выполнении загрузки.

В столбце "Тип операции" находится кнопка операции каждого обновления. С помощью этой кнопки можно добавить обновление для загрузки или удалить его из папки обновлений.

В столбце "Название пакета обновления" название отображается в виде ссылки. Нажмите на ссылку, чтобы просмотреть сведения об обновление в области "Подробности".

В столбце "Статус" справа от названия каждого обновления находится значок положения. Значок положения информирует о готовности обновления для загрузки, окончании загрузки или неудачной загрузке обновления.

Папка пакета обновления

Если нажать кнопку "Папка пакета обновления", запускается процесс загрузки обновлений с типом действия "Для загрузки в папку обновлений". Во время загрузки наименование кнопки временно заменяется на "Отменить". Если нажать кнопку "Отменить", загрузка прерывается.

Подробности

Отображение подробных сведений о выбранном пакете обновления. В подробности входят описание состояния обновления (загружено, доступно для загрузки или не удалось выполнить загрузку), название пакета обновления и ссылка на файл Readme, а также дата выпуска обновления, тип и размер файла.

После загрузки обновления в области "Подробности" отображается отчет о его положении. Если обновление не удалось загрузить, рядом с его именем отображается "Не выполнено". После загрузки в диалоговом окне "Статус папки обновлений" отображается сообщение об обновлении локальной папки обновлений. После закрытия диалогового окна, область "Подробности" возвращается к исходному состоянию, в области "Управление обновлениями" обновляются значки положения каждого пакета обновлений.

Программы на основе AutoCAD 2004 - AutoCAD 2006

При использовании утилиты "Диспетчер Интернет-компонентов" с предыдущими версиями программы необходимо создать текстовый файл со списком обновлений, доступных для установки на компьютере.

В следующей таблице описаны позиции, необходимые для списка обновлений.

Свойства и их значения в списке обновлений |
Свойство | Значение
ProductCode | Основной уникальный идентификатор программного продукта
ProductVersionCandidate | Разделенный точкой с запятой список версий программы, к которым можно применить обновление
PatchGUID | Уникальный идентификатор обновления
PatchFileLocation | Местоположение папки (можно изменить)
PatchSize | Размер пакета обновлений к килобайтах
PatchDescLocation | Местоположение файла Readme (можно изменить, может быть пустым)
PatchTitle | Название пакета обновления (можно изменить)
PatchDesc | Краткое описание обновления (с возможностью редактирования; длина - не более 1024 символов)
Локальный список обновлений

Локальный список обновлений можно использовать для указания пакетов обновления, предоставляемых пользователям по сети. Прежде всего необходимо создать пустой текстовый файл (TXT). Затем загрузите с веб-сайта Autodesk (http://www.autodesk.com/)пакет обновлений для распределения пользователям, извлеките из него PatchGUID и другие сведения. Затем вставьте эти сведения в список локальных обновлений. Такой метод можно использовать для вставки в список локальных обновлений сведений из нескольких пакетов обновлений, а затем с помощью Коммуникационного центра устанавливать обновления из списка на компьютеры пользователей.

Если используется локальный список обновлений, извлеките информацию о пакете обновления, введя в командной строке DOS имя файла обновления и

  • аргумент командной строки /p (обновление).
  • Имя текстового файла для добавления сведений о пакете обновления (не обязательно)

Если не использовать после имени файла обновления аргумент командной строки, пакет обновления будет применен немедленно. Аргумент командной строки предотвращает применение обновления до создания с помощью Диспетчера Интернет-компонентов локального списка обновлений и компьютеров пользователей. Например, для извлечения сведений об обновлении в файл MyTextFile.txt введите в командной строке:

ProgramPatch.exe /p MyTextFile.txt

Если имя файла после аргумента командной строки не указано, будет создан файл, содержащий сведения об обновлении. После извлечения вставьте сведения об обновлении в локальный список обновлений, обновите значение локального местоположения пакета обновления PatchFileLocation и настройте компьютеры пользователей для обновления по сети.

Настройка информационных каналов

Включение или отключение доступа к объявлениям служб технической поддержки и подписки, статьям и другой информации.

Если установлен флажок "Включить доступ к информационным каналам", задайте, следует ли пользователям получать уведомления Центра подписки о технических обновлениях программы.

Включение доступа и настройка Коммуникационного центра
  1. В окне утилиты "Диспетчер Интернет-компонентов" перейдите на вкладку "Коммуникационный центр"
  2. Чтобы пользователи получали уведомления о доступных в сети технических обновлениях, установите флажок "Включить Коммуникационный центр".
  3. В области "Настройка обновления по сети" установите один из флажков:
    • "Получать обновления по сети от Autodesk". Пользователи будут получать уведомления об обновлениях по сети непосредственно от компании Autodesk.
    • "Получать обновления по локальной сети". Пользователи будут получать уведомления об обновлениях по локальной сети. В области "Расположение локального списка обновлений" задайте местоположение локального списка обновлений.
    • "Отключить обновление". Пользователи не будут получать уведомлений об обновлениях.
  4. В области "Настройка информационных каналов" установите флажок "Включить доступ к информационным каналам", если требуется предоставить пользователям доступ к информации Центра подписки, технической поддержки и др. Затем пользователи сами могут выбрать каналы для просмотра. Если требуется закрыть пользователям доступ к этой информации, установите флажок "Отключить доступ к информационным каналам".
  5. После настройки Коммуникационного центра необходимо решить, как сохранить настройки: только на данном компьютере или в виде файла реестра (.reg), который можно распространить на другие компьютеры. В списке внизу окна утилиты "Диспетчер Интернет-компонентов" установите флажок "Изменить системные настройки" для применения настроек на данном компьютере или "Создать файл реестра (.reg)" для изменения настроек других компьютеров.
  6. Нажмите "Применить". При создании файла реестра необходимо задать его имя и местоположение.

    7. Примечание Кнопка "Применить" используется для сохранения изменений, выполненных на всех вкладках Диспетчера Интернет-компонентов.

Отключение доступа к Коммуникационному центру
  1. В окне утилиты "Диспетчер Интернет-компонентов" перейдите на вкладку "Коммуникационный центр"
  2. Чтобы пользователи не получали уведомления о доступных в сети технических обновлениях, установите флажок "Отключить Коммуникационный центр".
  3. После отключение доступа к Коммуникационному центру необходимо решить, как сохранить настройку: только на данном компьютере или в виде файла реестра (.reg), который можно распространить на другие компьютеры. В списке внизу окна утилиты "Диспетчер Интернет-компонентов" установите флажок "Изменить системные настройки" для применения настроек на данном компьютере или "Создать файл реестра (.reg)" для изменения настроек других компьютеров.
  4. Нажмите "Применить". При создании файла реестра необходимо задать его имя и местоположение.

    5. Примечание Кнопка "Применить" используется для сохранения изменений, выполненных на всех вкладках Диспетчера Интернет-компонентов.

Проверка доступных обновлений для программ на основе AutoCAD 2007
  1. В окне утилиты "Диспетчер Интернет-компонентов" перейдите на вкладку "Коммуникационный центр"
  2. В области "Настройка обновления по сети" установите флажок "Получать обновления по локальной сети".
  3. Если локальный список обновлений не задан, найдите папку в локальной сети, содержащую файл со списком обновлений или выберите папку, в которой будет создан файл по умолчанию.
  4. Нажмите кнопку "Управление обновлениями".

    5. Если доступны обновления для программы, выбранной при запуске Диспетчера Интернет-компонентов, они отображаются в списке с именами обновлений в диалоговом окне "Управление папкой обновлений".

    Если доступных пакетов обновлений нет, в диалоговом окне "Статус Коммуникационного центра" отображается соответствующее сообщение.

Загрузка пакета обновления в диалоговом окне "Управление папкой обновлений"
  1. В диалоговом окне "Управление папкой обновлений" в области "Управление обновлениями" нажмите кнопку "Тип операции" для обновления, которое требуется загрузить в папку обновлений. Установите флажок "Для загрузки в папку обновлений". Повторите эту операцию с дополнительными пакетами обновлений для загрузки.
  2. Нажмите кнопку "Папка пакета обновления".

    3. В области "Подробности" отображается отчет о состоянии для каждого пакета обновления.


Вкладка "Design Center Online"

Вкладка "Design Center Online"

Design Center Online предоставляет доступ к символам, информации производителей по программам и содержимому объединенных узлов в Интернете. Доступ пользователей к DesignCenter Online осуществляется через вкладку "DC Online" в DesignCenter.

На вкладке "Design Center Online" содержатся опции доступа к DesignCenter Online.

Включить вкладку "DC Online" Центра управления DesignCenter

Доступ пользователей к вкладке "DC Online" в DesignCenter.

Отключить вкладку "DC Online" Центра управления DesignCenter

Скрытие вкладки "DC Online" в DesignCenter, пользователи не могут загружать содержимое DesignCenter Online в DesignCenter.

С помощью Диспетчера Интернет-компонентов можно управлять отображением вкладки "DC Online" в Design Center.

Управление отображением вкладки "DC Online" в DesignCenter
  1. В окне утилиты "Диспетчер Интернет-компонентов" перейдите на вкладку "DesignCenter Online".
  2. Для включения отображения вкладки "DC Online" в DesignCenter и предоставления пользователям доступа к ее содержимому в Интернете установите флажок "Включить вкладку Интернет-модуля Центра управления DesignCenter".
  3. Для отключения DesignCenter Online и удаления вкладки "DC Online" в DesignCenter установите флажок "Отключить вкладку Интернет-модуля Центра управления DesignCenter".

    4. После изменения настройки доступа к DesignCenter Online необходимо решить, как сохранить настройку: только на данном компьютере или в виде файла реестра (.reg), который можно распространить на другие компьютеры. В списке внизу окна утилиты "Диспетчер Интернет-компонентов" установите флажок "Изменить системные настройки" для применения настроек на данном компьютере или "Создать файл реестра (.reg)" для изменения настроек других компьютеров.

  4. Нажмите "Применить". При создании файла реестра необходимо задать его имя и местоположение.

    5. Примечание Кнопка "Применить" используется для сохранения изменений, выполненных на всех вкладках Диспетчера Интернет-компонентов.

Установка пакета обновления на компьютеры с помощью локального списка обновлений
  1. Создайте текстовый файл, который будет использоваться как локальный список обновлений.
  2. Загрузите файл обновления для установки.
  3. Просмотрите связанный файл Readme и сохраните файл обновления в общей папке.
  4. Извлеките сведения об обновлении. Для этого в командной строке DOS введите имя файла обновления, затем аргумент командной строки /p и имя текстового файла.

    5. Сведения об обновлении добавляются в конец текстового файла. Например, чтобы извлечь сведения об обновлении из файла ProgramPatch.exe в файл MyTextFile.txt, введите в командной строке:

    ProgramPatch.exe /p MyTextFile.txt

    Аргумент командной строки предотвращает установку обновления до создания с помощью Диспетчера Интернет-компонентов локального списка обновлений и компьютеров пользователей. Если имя файла после аргумента командной строки не указано, будет создан файл, содержащий сведения об обновлении.

  5. Вставьте текст, извлеченный из файла обновления, в локальный список обновлений.
  6. Затем измените в списке значение PatchFileLocation на местоположение сохраненного файла обновления.
  7. На вкладке "Коммуникационный центр" утилиты "Диспетчер Интернет-компонентов" включите доступ пользователей к Коммуникационному центру, в области "Настройка обновления по сети" установите флажок "Использовать локальный список обновлений" и введите путь к локальному списку обновлений.
  8. После настройки Коммуникационного центра необходимо решить, как сохранить настройки: только на данном компьютере или в виде файл реестра (.reg), который можно распространить на другие компьютеры. В списке внизу окна утилиты "Диспетчер Интернет-компонентов" установите флажок "Изменить системные настройки" для применения настроек на данном компьютере или "Создать файл реестра (.reg)" для изменения настроек других компьютеров.
  9. Нажмите "Применить". При создании файла реестра необходимо задать его имя и местоположение.

    10. Изменение настроек обновления по сети основано на том, сохраняются ли настройки только для данного компьютера или создается файл реестра (.reg), который можно распространять на другие компьютеры.

    Примечание Кнопка "Применить" используется для сохранения изменений, выполненных на всех вкладках Диспетчера Интернет-компонентов.


Вкладка "Центр подписки"

Вкладка "Центр подписки"

Центр подписки предоставляет подписчикам доступ к различным ресурсам, например к материалам e-Learning (интерактивным урокам с индивидуально определяемыми сроками) и службе веб-поддержки (в которую пользователи могут в интерактивном режиме направлять технические вопросы, адресованные специалистам по поддержке Autodesk)

На вкладке "Центр подписки" содержатся опции доступа к Центру подписки.

Разрешить доступ к Центру подписки из программы компании Autodesk (рекомендуется)

Включение или отключение доступа к Центру подписки и меню "Справка" программы. Если доступ включен, подписчики получают доступ к следующим опциям:

  • Каталог e-Learning по подписке.Интерактивные уроки, организованные в каталоги программ. В каждом уроке длительностью 15-30 минут содержатся практические упражнения с возможностью использования вместо программы эмулятора. Пользователи могут использовать интерактивное средство оценки знаний, позволяющее выявить пробелы знаний и определить, какие уроки будут наиболее полезными, и отслеживать процесс обучения.
  • Создать запрос о поддержке. Обеспечивает пользователям прямое общение со специалистами по технической поддержке Autodesk. Пользователь быстро получает исчерпывающие ответы на вопросы, связанные с установкой, настройкой и устранением неполадок.
  • Просмотреть запросы о поддержке. Позволяет пользователям отслеживать и управлять вопросами и ответами с помощью современной системы поддержки Autodesk.
  • Изменить профиль центра подписки. Предоставляет возможность пользователям создавать и управлять учетными записями своих подписок.
Включение доступа к Центру подписки в программах Autodesk
  1. В окне утилиты "Диспетчер Интернет-компонентов" перейдите на вкладку "Центр подписки".
  2. Установите флажок "Разрешить доступ к центру подписки из продукта Autodesk (рекомендуется)".
  3. Нажмите "Применить". При создании файла реестра необходимо задать его имя и местоположение.

    4. Примечание Кнопка "Применить" используется для сохранения изменений, выполненных на всех вкладках Диспетчера Интернет-компонентов.


Вкладка "Отчет об ошибках"

Вкладка "Отчет об ошибках"

Если AutoCAD неожиданное закрывается, пользователи могут отправить отчет об ошибке непосредственно в компанию Autodesk, что поможет выявить и устранить проблему.

На вкладке "Отчет об ошибках" можно задать возможность получения пользователями уведомления об устранении ошибок, а также включение имени компьютера в отчет об ошибках и уведомления.

Включить имя компьютера

Включение имени компьютера в отчет об ошибках. Имя компьютера включается в уведомления пользователям и отчеты, доступные для администратора подписки.

Получать уведомления

Пользователи получают уведомления об обработке отчетов об ошибках и ссылки на соответствующие обновления Autodesk.

Пользователи получают уведомления об обработке отчетов об ошибках
  1. В окне утилиты "Диспетчер Интернет-компонентов" выполните следующее:
    • Установите флажок "Включить имя компьютера" для включения в отчет имени компьютера пользователя. Имя компьютера включается в уведомления пользователям и отчеты, доступные для администратора подписки. По умолчанию этот флажок установлен.
    • Установите флажок "Пользователи получают уведомления", чтобы пользователи знали о решении проблемы и могли загрузить соответствующее обновление Autodesk. По умолчанию этот флажок установлен.

    Примечание Для установки обновлений компании Autodesk пользователи должны иметь права администратора.

  2. Нажмите "Применить".

    3. Примечание Кнопка "Применить" используется для сохранения изменений, выполненных на всех вкладках утилиты "Диспетчер Интернет-компонентов".


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!