Юрий Богославец - Программы

Богославец Юрий Николаевич

Программы

Ниже Вы можете ознакомиться со списком программ, написанных мной в свободное время в процессе изучения различных языков программирования. Их можно свободно скачивать и распространять, изучать и использовать. Предложения по улучшению представленных программ можете оставлять на форуме поддержки, но я не обещаю, что все их внедрю, хотя познакомиться было бы неплохо.

Обычно я пишу программы для собственных нужд и заканчиваю их разработку, когда довожу до более-менее работающего состояния.

Перейти к программе:

Программа | Краткое описание
INTERCOM | Чат и передача файлов, картинок, документов по локальной сети.
YCHAT | Программа для общения и передачи файлов по модему под WINDOWS 95, 98, ME, 2000, XP.
YTERM | Терминальная программа для MS DOS.

INTERCOM

Последняя версия 8.06.67
от 27 апреля 2004 (что нового).

Intercom

Чат-программа для общения по локальной сети или интернет не требующая выделенного сервера. Кроме передачи сообщений она позволяет обмениваться файлами и картинками. Прямо в текст сообщения Вы можете вставлять смайлики, картинки или файлы из буфера обмена. Текст может иметь разные шрифты, цвета, размеры. Также программа ведёт лог файлы, сворачивается в системный трей и имеет автоответчик. Интерфейс у программы представляет собой гибрид таких программ как icq и mirc. Имеется звуковое и визуальное оформление событий (приход сообщений, файлов). Хорошо работает в сетях со сложной топологией, где возникают сложности с рассылкой широковещательных пакетов. По умолчанию программа позволяет общаться 99-и пользователям. Передает информацию по протоколу tcp/ip и работает в операционных системах Windows 95, 98, NT4, 2000, XP.

YCHAT

Версия 3.0

chat

Программа для общения и передачи файлов по модему в среде Windows. Не секрет, что обмениваться файлами с друзьями через терминальные программы очень не удобно. А Интернет есть не у всех, и порой гораздо быстрее передать файлик, прямо переслав его со своего модема на модем друга. Эта программа позволяет удобно передавать файлы и обмениваться текстовыми сообщениями. Причем обмениваться сообщениями можно прямо во время передачи или приема файлов. Программа умеет работать с модемами, которые настроены на COM порты с номерами от 1 до 4. Работает в Windows 95/NT/XP/2003.

П.С.: Программе пять лет в обед, поэтому не требуйте у неё особой безглючности, эта версия уже переделываться и исправляться не будет. Сейчас я пишу новую, работающую через TAPI интерфейс Windows, что позволит программе работать с любым модемом, который опознается виндами.

Кстати, программу можно улучшить, если Вы программист и знаете язык C++, то можете скачать исходники программы.

YTERM

Версия 1.71

Yterm

Терминальная программа с поддержкой ANSI, IEMSI (быстрый вход), знает различные списки ББС (по Санкт-Петербургу) распознает время работы ББС, включая выходные дни. Работает в текстовом режиме под MS DOS или в консольном окне в Windows 95, 98, NT4, 2000, XP.

© Богославец Юрий Николаевич