Обзор программы программы TrafficCompressor

Обзор программы TrafficCompressor

TrafficCompressor сжимает данные, полученные и отправленные через Интернет, например, веб-страницы, e-mail, Usenet, ICQ, IRC сообщения и многие другие виды трафика. В результате ваш Интернет трафик может быть значительно уменьшен. Уменьшение трафика может достигать 40% - 60% от вашего общего трафика, если вы используете Интернет в основном для просмотра сайтов и обмена сообщениями.

TrafficCompressor может быть особенно полезен для пользователей, которые оплачивают доступ в Интернет в зависимости от объёма полученного трафика, например, для пользователей GPRS и ADSL Интернет соединений. TrafficCompressor помогает вам экономить деньги, экономя ваш Интернет трафик.
Также TrafficCompressor может быть полезен пользователям медленных и низкокачественных Интернет соединений, т.к. TrafficCompressor позволяет увеличить скорость загрузки страниц и других данных за счёт уменьшения их размера.

Конечно, TrafficCompressor не способен уменьшить абсолютно любые типы Интернет трафика, но он поможет вам уменьшить ваш трафик насколько это возможно. Наилучшая степень сжатия достигается на страницах, файлах и сообщениях, которые имеют текстовый формат, например HTML или XML, а также на трафике некоторых онлайн-игр (MMORPG).
TrafficCompressor не способен сжать EXE, ZIP, RAR, музыкальные и видео файлы, картинки и некоторые другие виды файлов.
Более подробная информация о том, какие виды трафика может уменьшить TrafficCompressor.


Системные требования

Системные требования программы TrafficCompressor

  • Windows 98, ME, 2000, XP или 2003.
  • Dial-up, GSM/GPRS/EDGE, ISDN, cable modem, Radio Ethernet, Wi-Fi, ADSL или спутниковое Интернет-соединение.
  • Прямое Интернет-соединение без использования прокси сервера.


Как работает TrafficCompressor?

TrafficCompressor сжимает данные, загруженные или отправленные через Интернет. Когда вы открываете веб-страницу или получаете электронную почту, используя TrafficCompressor, данные не передаются напрямую с веб или e-mail сервера на ваш компьютер. Данные передаются через один из серверов сервиса TrafficCompressor, которые расположены на высокоскоростных Интернет-каналах в разных странах мира. Сервер сжимает данные и посылает их в сжатом виде на ваш компьютер через ваше GRPS, ADSL или другое Интернет соединение. В результат объём вашего трафика снижается, и вы платите за Интернет доступ меньше.
Программа TrafficCompressor работает на вашем компьютере. Она получает сжатые данные от своего сервера, преобразует их в первоначальный несжатый формат и передаёт их веб-браузеру, почтовой программе или другой программе, которая сделала запрос на получение данных из Интернет.

Неподдерживаемый трафик (ZIP, MP3, EXE файлы, FTP, HTTPS, SMTP трафик и т.д.) передаётся напрямую, минуя сервера сервиса TrafficCompressor, и не сжимается.

Рассмотрим детально на примере, как работает TrafficCompressor, когда вы открывает в вашем веб-браузере, например, страницу http://www.TCompressor.ru.

  1. Вы набираете в адресной строке вашего браузера адрес www.tcompressor.ru.
  2. Программа TrafficCompressor посылает запрос на получение страницы на один из своих серверов.
  3. Сервер скачивает страницу с сайта www.TCompressor.ru.
  4. Сервер сжимает страницу и посылает её на ваш компьютер программе TrafficCompressor.
  5. Программа TrafficCompressor получает сжатую страницу, преобразует её в исходный несжатый формат и передаёт вашему веб-браузеру.

Процесс получения или отправки данных по другим протоколам полностью аналогичен.

Процесс сжатия трафика наглядно представлен на диаграмме на этой веб-странице.


Какие виды Интернет трафика может уменьшить TrafficCompressor?

TrafficCompressor сжимает данные, получаемые или отправляемые через Интернет. TrafficCompressor способен уменьшить размер веб-страниц, текстовых и XML файлов, файлов в формате Microsoft Word или Microsoft Excel, текстовых сообщений и т.п., получаемых с веб, e-mail, игровых и других видов Интернет-серверов.

В данной таблице приведена подробная информация о тех видах трафика, которые TrafficCompressor способен или не способен уменьшить.
TrafficCompressor способен уменьшить
(на 25% - 80%) 		TrafficCompressor НЕ способен уменьшить
  • Веб: веб-страницы, скрипты (JavaScript/VBScript), CSS файлы (cascading style sheets), текстовые файлы.
  • E-mail: любые e-mail сообщения, полученные по протоколам POP3 или IMAP4, как с вложенными файлам, так и без них. Сжатые вложенные файлы (такие как ZIP, MP3, JPEG, GIF и другие) могут быть уменьшены в размере на 25%-30% (более подробно).
  • Трафик программ обмена сообщениями: ICQ, Windows Messenger, AIM, Yahoo! Messenger, Jabber, Gadu-Gadu.
  • Usenet(News) трафик.
  • IRC трафик при использовании портов 6667-6670.
  • Трафик некоторых онлайн-игр (MMORPG/MPOG): World of Warcraft, Ragnarok Online, Lineage II (на ~10%), Gambler и некоторых других при использовании стандартных портов.
  • Веб: картинки, Flash ролики, ActiveX, Java аплеты, ZIP, EXE, MP3 и другие сжатые файлы, страницы, сжатые самими веб-сайтами с помощью gzip.
  • Данные, передаваемые по любым сетевым протоколам, которые не перечислены в правой части таблицы, например, FTP, HTTPS, SMTP, UDP.
  • IRC трафик при использовании портов отличных от 6667-6670.
  • Трафик онлайн-игр при использовании серверов с нестандартными портами.
  • Файлы и голосовые сообщения, передаваемые через программы обмена сообщениями, перечисленные в правой части таблицы.
  • Потоковое video и audio.

Сжатые файлы, вложенные в e-mail сообщения.

E-mail сообщения с вложенными сжатыми файлами, таких типов как ZIP, RAR, MP3, JPEG, GIF и т.д., могут быть уменьшены TrafficCompressor'ом в размере на 25% - 30%. Такой коэффициент сжатия возможен из-за того, что прикреплённые файлы хранятся внутри e-mail сообщений в формате, похожем на текстовый. В результате любое e-mail сообщение всегда больше, чем вложенные в него файлы. И такое сообщение можно уменьшить с помощью сжатия.

Например, при пересылке по e-mail файла TrafficCompressor.zip формат e-mail сообщения будет таким:

Привет, Алекс,

Посмотри, какая классная программа.

Сергей.
------------FD19D14312B5FC48
Content-Type: APPLICATION/X-ZIP-COMPRESSED; name="TrafficCompressor.zip"
Content-transfer-encoding: base64
Content-Disposition: attachment; filename="TrafficCompressor.zip"

UEsDBAoAAAAAAPYqRjEAAAAAAAAAAAAAAAANAAAAc2VydmVyU2NyaXB0L1BLAwQKAAAAAAD2
KkYxAAAAAAAAAAAAAAAAGwAAAHNlcnZlclNjcmlwdC9Eb2N1bWVudGF0aW9uL1BLAwQKAAAA
AAD2KkYxAAAAAAAAAAAAAAAAIgAAAHNlcnZlclNjcmlwdC9Eb2N1bWVudGF0aW9uL0ltYWdl
cy9QSwMEFAACAAgA2RSpMHBeuLhNAQAAWAEAACoAAABzZXJ2ZXJTY3JpcHQvRG9jdW1lbnRh
dGlvbi9JbWFnZXMvcGx1cy5naWZz93SzsEwUYBBguGrO8OzZM0VFRTY2tsuXL//48ePdu3ef
Pn26fv36v3//7t69++fPHyYmpt+/f3/9+vXv37/fvn17/fr1+/fv37x5c/Xq1UePHomLi9+/
f5+VlVVJSUlaWlpQUPDx48efP39WUFCQkZGRkJDg5+eXlJR88ODBly9frly58vLlyxcvXnz4
8OHjx4/Xrl27c+eOrKwsDw+PqKgoCwuLsrIyNze3lJSUiIgIOzv7z58/////z8DAACGxAsWf
LIwMDOYMOiAOyE8MbKUHZhd46Ej1n0gxFK5gDdvo7314lijz1hyxhQsEWVx7zF4vsHWbnpSe
k2wT0Op68fAySRXVaMMpW3/+ZZCuchHl4OMxMRNkUOJsdjaK5WUzY+Bk1+x3UjDhVRdgEGNn
Zp5lbsAiw6omoiXMrLKMiUmPu367185dTo4M1gBQSwMECgACAAAAfbqoMDkkQvx5AAAAeQAA
ACsAAABzZXJ2ZXJTY3JpcHQvRG9jdW1lbnRhdGlvbi9JbWFnZXMvYXJyb3cuZ2lmR0lGODlh
EAAQAPIGAAICAhgYGCEhIdfX1/7+/vPz8+jo6AAAACH5BAEAAAQALAAAAAAQABAAAAM+SLrc
...


Что обозначает значок программы в нижнем правом углу экрана (в system tray)?

TrafficCompressor показывает своё текущее состояние с помощью значка в нижнем правом углу экрана (system tray). Цвет или изображение значка меняются при изменении состояния программы.
Вы можете получить доступ к настройкам программы, окну статистики сжатия и другим функциям программы, кликнув правой кнопкой мыши на значок и выбрав соответствующий пункт меню. 		System tray icon
Значок в system tray | Значение
Зелёный значок | Программа TrafficCompressor включена и работает корректно. Сжатие Интернет-трафика активно. Обратите внимание, что TrafficCompressor сжимает только тот трафик, для которого включено сжатие в окне настроек на страницах "Протоколы", "Веб", "Адреса" и "Программы".
Анимированный зелёный значок или Сжатый зелёный значок | TrafficCompressor в данный момент сжимает входящий или исходящий трафик.
Восклицательный знак | Программа TrafficCompressor потеряла соединение со своим сервером, например, потому что ваше Интернет-соединение было отключено. Ваши текущие Интернет сеансы (TCP соединения) (такие как, открытие веб-страницы, получение почты и т.п.), которые сжимает TrafficCompressor, не будут разорваны в течение 2-х минут. Если TrafficCompressor сможет восстановить соединение со своим сервером в течение 2-х минут, то упомянутые выше TCP соединения будут возобновлены. Т.е. веб-браузер продолжит открывать страницу, почтовая программа продолжит получать почту с того места, когда произошёл разрыв связи, и т.д.
Песочные часы | Сервера программы заняты и временно не принимают новые соединения. Интернет-трафик не сжимается. Когда один из серверов станет доступен, программа автоматически соединится с ним и сжатие трафика включится.
Красный значок | Программа не может соединиться со своим сервером. Интернет-трафик не сжимается. Программа периодически пытается установить соединение с одним из серверов. Как только соединение удастся установить, сжатие трафика будет включено автоматически. Обычно такой значок появляется, когда ваше Интернет-соединение отключено.
Белый значок | Программа отключена. Интернет-трафик не сжимается. Чтобы включить сжатие, кликните правой кнопкой мыши на значок и выберите из меню команду "Включить TrafficCompressor".


Часто задаваемые вопросы

  • Почему мой трафик не сжимается (значок программы красный Красный значок)?
  • Почему мой трафик не сжимается (значок программы красный с изображением песочных часов Песочные часы)?
  • Почему мой трафик не сжимается (значок программы зелёный Красный значок)?
  • Почему мой трафик не сжимается (значок программы белый Белый значок )?
  • Я включил сжатие трафика моей любимой онлайн-игры, но игровой трафик всё равно не сжимается, хотя другие виды трафика сжимаются.
  • Почему бы ни добавить в программу возможность самому выбирать любые порты для сжатия трафика?
  • Как настроить TrafficCompressor на работу через прокси сервер?
  • Почему статистика сжатия не совпадает со статистикой трафика моего провайдера и статистикой программ учёта трафика?
  • Почему при использовании программы TrafficCompressor я не могу получать или отправлять почту с помощью моей почтовой программы?
  • Как настроить firewall для корректной работы программы TrafficCompressor?
  • Мой провайдер предоставляет льготные тарифы на трафик с локальных ресурсов (т.е. ресурсов моего города, моего провайдера и т.п.). Как будет тарифицироваться мой трафик у провайдера при использовании программы TrafficCompressor?
  • Способна ли программа TrafficCompressor сжимать трафик при использовании спутникового Интернет-соединения?
  • Будет ли TrafficCompressor сжимать трафик всей локальной сети, если установить программу на сервер, через который локальная сеть подключена к Интернет?

Почему мой трафик не сжимается (значок программы красный Красный значок)?

Красный значок означает, что TrafficCompressor не может соединиться со своим сервером.
  • Проверьте, не блокирует ли ваш firewall доступ в Интернет для программы TrafficCompressor.
  • Если у вас на компьютере, в вашей сети или у вашего провайдера закрыт порт 47901, то можно настроить TrafficCompressor на использование другого порта (окно "Настройки" - "Другие" - "Порт сервера").
  • Обратите внимание, что TrafficCompressor не работает через прокси сервера, поэтому, если у вас доступ в Интернет возможен только через прокси сервер, то TrafficCompressor не сможет подключиться к своему серверу и не сможет сжимать трафик.

Почему мой трафик не сжимается (значок программы красный с изображением песочных часов Песочные часы)?

Изображение песочных часов означает, что все сервера программы в данный момент заняты. Вам нужно подождать, пока один из серверов освободится и сможет принять соединение от нового пользователя. Или же вы можете воспользоваться платным приоритетным доступом к сервису TrafficCompressor, чтобы избежать подобных задержек.

Почему мой трафик не сжимается (значок программы зелёный Красный значок)?

  • Если вы используете прокси сервер в веб-браузере или других сетевых программах, то вам нужно отключить использование прокси сервера. TrafficComporessor не поддерживает сжатие трафика при использовании прокси серверов в сетевых программах.
  • TrafficCompressor поддерживает только стандартные порты для каждого протокола. Например, если игровой сервер World of Warcraft использует нестандартный порт (т.е. отличный от 3724), то такой трафик сжиматься не будет.
  • Возможно, вы отключили сжатие для каких-то IP адресов, протоколов, программ или типов файлов, на которых проверяете сжатие трафика. Проверьте настройки программы TrafficCompressor. Удалите все программы из списка "Программы, для которых отключено сжатие трафика".
  • При использовании стандартных настроек TrafficCompressor не сжимает те веб-страницы, которые уже сжаты веб-серверами. Возможно, вы проверяете сжатие трафика на сайте, который сам сжимает страницы.

Почему мой трафик не сжимается (значок программы белый Белый значок )?

Белый значок означает, что TrafficCompressor отключен. Чтобы включить сжатие трафика, кликните правой кнопкой мыши на значок и выберите из меню команду "Включить TrafficCompressor".

Я включил сжатие трафика моей любимой онлайн-игры, но игровой трафик всё равно не сжимается, хотя другие виды трафика сжимаются.

Скорее всего, игровой сервер использует нестандартный порт. К сожалению, TrafficCompressor поддерживает сжатие игрового трафика только при использовании стандартных портов в онлайн-играх.

Почему бы ни добавить в программу возможность самому выбирать любые порты для сжатия трафика?

К сожалению, такая функция противоречит политике безопасности сервиса TrafficCompressor. Мы добавляем поддержку сжатия только для тех портов, для которых имеет смысл сжимать трафик, и поддержка которых необходима многим пользователям.
Но мы всегда открыты для ваших предложений по добавлению поддержки новых портов. Вы можете сообщить ваши пожелания на этой странице.

Как настроить TrafficCompressor на работу через прокси сервер?

К сожалению, TrafficCompressor не имеет функции работы через прокси сервер.

Почему статистика сжатия не совпадает со статистикой трафика моего провайдера и статистикой программ учёта трафика?

Статистика сжатия не учитывает весь ваш трафик. Например, в статистике сжатия не учитываются картинки (при использовании стандартных настроек программы).
Главная функция данной статистики - это показать, какой объём трафика был сэкономлен. Статистика сжатия учитывает только трафик, переданный через сервера программы TrafficCompressor, т.е. только тот трафик, который был сжат программой. Также статистика сжатия не включает в себя накладные издержки протоколов TCP/IP. Более подробную информацию о том, какой трафик не учитывается в статистике сжатия, смотрите в описании окна "Статистика сжатия".

Почему при использовании программы TrafficCompressor я не могу получать или отправлять почту с помощью моей почтовой программы?

  • Если вы используете почтовый сервер вашего провайдера, то, возможно, что почтовый сервер разрешает доступ только с IP адресов, принадлежащих вашему провайдеру. При использовании программы TrafficCompressor почтовый сервер "видит" IP адрес сервера программы TrafficCompressor, и поэтому почтовый сервер не разрешает вам доступ. В таком случае вам нужно отключить сжатие для вашего POP3 сервера в окне настроек на странице "Адреса".
  • Возможно, ваш почтовый сервер в целях дополнительной безопасности требует, чтобы вы получали и отправляли почту с одного и того же IP адреса. Когда вы используете TrafficCompressor, то при отправке почты почтовый сервер "видит" ваш IP адрес, при получении почты - IP адрес сервера программы TrafficCompressor, поэтому доступ может быть запрещён. В таком случае вам также нужно отключить сжатие для вашего POP3 сервера.
Если вы всё же желаете использовать сжатие для e-mail трафика, то можно посоветовать такой вариант: вы можете завести второй почтовый ящик на сервере, который не накладывает ограничений на IP адреса (например, mail.ru, yandex.ru). На основном почтовом ящике вы можете настроить переадресацию всех писем на второй ящик и получать почту со второго ящика в сжатом виде. Конечно, функция перенаправления писем поддерживается не всеми почтовыми серверами.

Как настроить firewall для корректной работы программы TrafficCompressor?

Самый удобный и простой способ настроить firewall - это переключить его в режим обучения. Многие firewall'ы после установки начинают работу именно в таком режиме, и вам не придётся включать режим обучения вручную. В таком режиме firewall будет выдавать запрос на каждое неизвестное сетевое соединение (TCP соединение), и вы сможете решить, разрешать или нет каждое соединение.

Если же вы желаете вручную настроить ваш firewall, то при использовании программы TrafficCompressor вам нужно разрешить в firewall'е следующие виды сетевой активности:

  • TrafficCompressor соединяется со своими серверами, используя порт 47901. IP адреса серверов время от времени меняются, поэтому желательно разрешить доступ к порту 47901 любого IP адреса.
    Обратите внимание, что вы можете изменить порт, используемый программой. В таком случае нужно будет внести соответствующие изменения в настройки firewall'а.
  • TrafficCompressor перенаправляет сетевые соединения (TCP соединения) локальных программ на адрес 127.0.0.1 (localhost) на один из портов 47900, 47902-47905, 80, 110 и некоторые другие, поэтому ваш firewall может выдавать запросы на разрешение таких соединений.
  • TrafficCompressor открывает для прослушивания локальные порты 47900, 80, 110 и некоторые другие поэтому ваш firewall может выдавать сообщение о том, что программа TrafficCompressor работает в режиме сервера.
  • Те локальные программы, которые используют протокол HTTP (по порту 80), например, веб-браузеры, могут открывать локальные порты 47902-47905 для прослушивания. Ваш firewall может выдавать сообщение о том, что такие программы работают в режиме сервера.

Мой провайдер предоставляет льготные тарифы на трафик с локальных ресурсов (т.е. ресурсов моего города, моего провайдера и т.п.). Как будет тарифицироваться мой трафик у провайдера при использовании программы TrafficCompressor?

Весь трафик, который сжимается программой TrafficCompressor, будет тарифицироваться вашим провайдером, как внешний, т.е. по более высоким тарифам по сравнению с локальным трафиком. Чтобы этого не произошло, вам нужно отключить сжатие для всех IP адресов, для которых предоставляются льготные тарифы на трафик. Вы можете это сделать в окне настроек на странице "Адреса". Полный список IP адресов с льготной тарификацией вы можете узнать в службе техподдержки или на веб-сайте вашего провайдера.

Провайдеры Украины, как правило, предоставляют льготную тарификацию для всех украинских IP адресов. Полный список украинских IP адресов находится на этих страницах:
http://www.cyfra.net/foruaix.php?ep=46
http://uatele.com/cgi-bin/foruaix_iprt.cgi

Способна ли программа TrafficCompressor сжимать трафик при использовании спутникового Интернет-соединения?

TrafficCompressor будет сжимать входящий и исходящий трафик при использовании спутникового Интернет-соединения, если у вас возможен доступ в Интернет без использования прокси сервера, например, при использовании технологии VPN.

Если вы используете локальный прокси-сервер с поддержкой функции port mapping, то вы сможете использовать TrafficCompressor. Для этого потребуются дополнительные настройки.

Будет ли TrafficCompressor сжимать трафик всей локальной сети, если установить программу на сервер, через который локальная сеть подключена к Интернет?

Возможность сжатия трафика всей локальной сети сильно зависит от типа программного обеспечения, используемого на вашем сервере. Как правило, при подключении локальной сети через прокси-сервер, трафик будет сжиматься (трафик Kerio WinRoute Firewall, работающего в режиме прокси-сервера, сжиматься не будет). При подключении через NAT-шлюз, скоре всего, трафик сжиматься не будет.
Самый лучший способ узнать, будет ли сжиматься трафик всей сети, - это установить TrafficCompressor на сервер и проверить работу программы на практике.
Сервер должен работать под управлением Windows.


Окно "Статистика сжатия"

Окно "Статистика сжатия" отображает информацию о трафике, сжатом программой TrafficCompressor. Статистика показана за период с даты, когда сбор статистики был начат, до текущей даты.
Статистика включает в себя суммарную информацию о сжатии входящего и исходящего трафика.

Обратите внимание на то, что статистика сжатия не предназначена для подсчёта объёма трафика, реально переданного через ваше Интернет-соединение. Статистика учитывает только тот трафик, который был передан через сервера сервиса TrafficCompressor. Также статистика сжатия не учитывает некоторый служебный трафик (издержки протоколов TCP/IP). Поэтому объём сжатого трафика, показанный в окне статистики сжатия, будет всегда меньше, чем показания статистики трафика вашего провайдера доступа в Интернет или показания Windows в свойствах сетевого соединения.
Статистика сжатия предназначена только для того, чтобы показать, сколько трафика было сэкономлено программой TrafficCompressor.

Для подсчёта объёма трафика, реально переданного через ваше Интернет-соединение, и для подсчёта затрат на Интернет-доступ, рекомендуется использовать программы, специально разработанные для учёта трафика.

Какие виды Интернет-трафика не учитываются в статистике сжатия?

В окне статистики сжатия не учитываются следующие виды трафика:
  • Издержки протоколов TCP/IP. Издержки сетевого протокола - это служебный трафик, который не передаёт данных, которые вы загружаете или отправляете через Интернет. Этот вид трафика требуется для обеспечения надёжной передачи данных через Интернет и для некоторых других технических целей. Издержки протоколов TCP/IP включают в себя заголовки сетевых пакетов, данные, переданные повторно из-за потерь пакетов в сети, и некоторые другие служебные данные.
    Издержки протоколов TCP/IP могут составлять до 10%-30% от общего объёма трафика. Например, если вы загрузите файл размером 100 KB (без программы TrafficCompressor), ваш реальный общий трафик составит около 110 KB - 130 KB, за счёт издержек сетевых протоколов.
  • UDP трафик. Объём UDP трафика обычно очень мал. Протокол UDP используется для DNS запросов, некоторыми программами передачи потокового видео и звукового трафика, некоторыми онлайн-играми, а также некоторыми другими программами.
  • Любой трафик протоколов, которые отсутствуют или отключены в окне настроек.
  • Любой трафик с IP адресов, для которых отключено сжатие в окне настроек.
  • Любой трафик программ, для которых отключено сжатие в окне настроек.
  • Файлы, загруженные по протоколу HTTP тех типов, для которых отключено сжатие в окне настроек. По умолчанию сжатие отключено для типов GIF, JPG, ZIP, EXE, MP3 и других типов файлов, которые используют сжатие.
  • Любой трафик, переданный через Интернет-соединение в то время, когда сжатие трафика было неактивно или программа была закрыта.

Описание полей и элементов управления окна "Статистика сжатия".

Сэкономлено:
Объём трафика, который был сэкономлен программой.

Статистика с:
Дата, с которой был начат сбор статистики, т.е. дата, когда программа TrafficCompressor была установлена на ваш компьютер, или когда статистика была сброшена.

Учитывать трафик:
Тип трафика, который учитывается в статистике сжатия.
Выбранный тип трафика влияет также на отображение объёма сэкономленного трафика в всплывающей подсказке в system tray.

Кнопка "Сбросить":
При нажатии этой кнопки все данные в данном окне сбрасываются в ноль, и дата начала сбора статистики устанавливается на текущую дату.

Кнопка "Настройки":
Открывает окно настроек программы.

Кнопка "Подробнее":
Нажмите эту кнопку для того, чтобы открыть или скрыть подробную статистику сжатия по каждому сетевому протоколу отдельно.

Поля таблицы со отдельной статистикой сжатия по каждому протоколу.

Трафик до сжатия:
Объём трафика в несжатом виде. Такой объём трафика был бы передан через Интернет-соединение, если бы вы не использовали программу TrafficCompressor.

Трафик после сжатия:
Объём трафика, реально переданного через Интернет-соединение в сжатом виде.

Сэкономленно:
Объём сэкономленного трафика.

Коэффициент сжатия:
Коэффициент сжатия трафика. Например, если программа сжала 300 KB трафика до размера 100 KB, то значит трафик был сжат в 3 раза, и коэффициент сжатия составляет 66.7%.
Коэффициент сжатия в процентах означает, сколько процентов от объёма несжатого трафика составляет объём сэкономленного трафика.


Настройки: Основные

Запускать TrafficCompressor при загрузке Windows
При включении данного режима программа TrafficCompressor будет автоматически запускаться при загрузке Windows. Данная функция может быть изменена только пользователем с правами администратора.

Включить TrafficCompressor
Включает сжатие Интернет-трафика.
Обратите внимание, что отключение или включение сжатия трафика будет действовать только для новых сетевых соединений. Для тех сетевых соединений, которые уже были установлены на момент изменения этой настройки, нельзя включить или отключить сжатие трафика.
Например, если вы отключите сжатие трафика во время получения электронной почты, то весь трафик в текущем сеансе связи с почтовым сервером будет сжатым. Сжатие почтового трафика будет отключено только при последующем подключении к почтовому серверу.

Анимированный значок в system tray
Если этот значок включен, то значок программы TrafficCompressor в нижнем правом углу экрана (в system tray) двигается, когда происходит сжатие входящего или исходящего трафика.

Язык(Language)
Выбор языка, на котором будут показываться все окна и сообщения программы.

Всплывающие сообщения (Balloon Tips)

В этом разделе настраиваются всплывающие сообщения (Balloon Tips), которые показываются в нижнем правом углу экрана и отображают различную информацию о работе программы.
Если какие-то из сообщений вам не нужны, Вы можете отключить их.
Данные сообщения показываются только на операционных системах Windows 2000 или более поздних.

Соединение с сервером установлено
Показывает сообщение, когда программа установила соединение со своим сервером.

Соединение с сервером потеряно
Показывает сообщение, когда программа потеряла соединение со своим сервером.

TrafficCompressor отключен
Показывает сообщение, когда происходит отключение сжатия трафика.

Каждые 10 MB сэкономленного трафика
Показывает общий объём сэкономленного трафика через каждые 10 MB сэкономленного трафика.

Учётная запись

Содержит ваше имя пользователя и пароль, под которыми вы зарегистрированы в сервисе TrafficCompressor. Если у Вас ещё нет имени пользователя и пароль, то вам нужно зарегистрироваться на веб-сайте сервиса.

Зарегистрироваться
Кликните на эту ссылку, чтобы открыть страницу регистрации на веб-сайте сервиса TrafficCompressor.

Забыли свой пароль?
Кликните на эту ссылку, чтобы открыть страницу восстановления пароля на веб-сайте сервиса TrafficCompressor. С помощью этой страницы Вы сможете создать новый пароль, если Вы забыли старый пароль или если Вы хотите сменить свой пароль.

Уведомлять за N дн. до окончания платного доступа
Если этот флажок включен, то TrafficCompressor будет показывать предупреждающее сообщение за несколько дней до окончания платного доступа. Это позволит продлить платный доступ заранее.

Количеcтво дней
Это поле определяет, за сколько дней до окончания платного доступа нужно показывать уведомление.


Настройки: Протоколы

Данные настройки позволяют отключить или включить сжатие для любого из поддерживаемых Интернет-протоколов.

TrafficCompressor определяет вид протокола только по номеру порта. TrafficCompressor поддерживает только стандартные порты для каждого протокола. Например, если игровой сервер World of Warcraft использует нестандартный порт (т.е. отличный от 3724), то такой трафик сжиматься не будет. Для некоторых протоколов порты, поддерживаемые программой TrafficCompressor, указаны в скобках после названия протокола.
TrafficCompressor не поддерживает сжатие трафика при использовании прокси серверов в сетевых программах.

Обратите внимание, что тот трафик, для которого отключено сжатие, передаётся из Интернета или в Интернет напрямую, минуя сервера программы TrafficCompressor.

Замечание по сжатию трафика Mail.Ru Agent
Для сжатия трафика Mail.Ru Agent нужно включить в настройках Mail.Ru Agent обычное подключение без использования протокола HTTPS и прокси сервера. Также нужно отключить флажок "Разрешить автоматическое определение параметров подключения".

Дополнительная информация о том, какой трафик сжимает программа TrafficCompressor


Настройки: Адреса

Данные настройки позволяют включить или отключить сжатие трафика выборочно для отдельных IP адресов, диапазонов IP адресов и адресов IP подсетей.

Независимо от данных настроек программа не сжимает трафик для адресов 127.0.0.1, 10.0.0.0-10.255.255.255, 172.16.0.0-172.31.255.255, 192.168.0.0-192.168.255.255, 169.254.0.0-169.254.255.255, т.к. эти адреса используются только для внутренних сетей и они недоступны из Интернет.

Обратите внимание, что тот трафик, для которого отключено сжатие, передаётся из Интернета или в Интернет напрямую, минуя сервера программы TrafficCompressor.

ЛЮБЫХ адресов Internet
Данный режим включает сжатие Интернет-трафика для любых IP адресов.

ТОЛЬКО нижеперечисленных адресов Internet
Данный режим включает сжатие Интернет-трафика только для тех IP адресов, которые указаны в списке. Вы можете добавлять в список отдельные IP адреса, диапазоны IP адресов и адреса IP подсетей.
При добавлении в список имени сервера (доменного имени) программа определяет IP адрес сервера и использует в дальнейшем только IP адрес. Имена серверов не используются для определения того, нужно ли сжимать трафик.

Любых адресов Internet КРОМЕ нижеперечисленных
Данный режим включает сжатие Интернет-трафика для любых IP адресов, кроме тех, которые указаны в списке. Вы можете добавлять в список отдельные IP адреса, диапазоны IP адресов и адреса IP подсетей.
При добавлении в список имени сервера программа определяет IP адрес сервера и использует в дальнейшем только IP адрес. Имена серверов не используются для определения того, нужно ли сжимать трафик.


Настройки: Веб

Данные настройки позволяют отключить сжатие веб-трафика для некоторых типов файлов и для тех веб-страниц, которые уже сжаты веб-серверами с помощью алгоритма gzip.
По некоторым статистическим данным около 5% веб-сайтов в Интернете сжимают свои страницы с помощью gzip. Обычно это сайты поисковых систем и форумов.

По умолчанию сжатие отключено для многих типов файлов, которые сами используют сжатие (например, .ZIP, .JPG, .GIF, .MP3, .AVI и т.д.). Такие файлы нет смысла сжимать повторно, т.к. дополнительной экономии трафика это не даст.

Обратите внимание, что тот трафик, для которого отключено сжатие, передаётся из Интернета или в Интернет напрямую, минуя сервера программы TrafficCompressor.

Не сжимать файлы следующих типов
Отключает сжатие для файлов с расширениями, которые указаны в списке.

Не сжимать страницы, уже сжатые с помощью gzip
Отключает сжатие для веб-страниц, которые уже сжаты веб-серверами.


Настройки: Программы

Данные настройки позволяют включить или отключить сжатие трафика выборочно для отдельных локальных программ.

Обратите внимание, что программа TrafficCompressor сжимается трафик только тех протоколов, которые поддерживаются программой.

Обратите внимание, что тот трафик, для которого отключено сжатие, передаётся из Интернета или в Интернет напрямую, минуя сервера программы TrafficCompressor.

ВСЕ программы
Данный режим включает сжатие Интернет-трафика для любых локальных программ.

ТОЛЬКО нижеперечисленные программы
Данный режим включает сжатие Интернет-трафика только для тех локальных программ, которые указаны в списке.

Режим обучения
В этом режиме TrafficCompressor спрашивает Вас, нужно ли сжимать трафик для каждой сетевой программы в отдельности. Когда TrafficCompressor обнаруживает трафик новой программы, который можно сжать, TrafficCompressor выдаёт запрос на сжатие трафика.
Рекомендуется включать сжатие трафика только для тех программ, которым Вы доверяете, т.к. программы, трафик которых сжимается, получают доступ в Интернет не напрямую, а через TrafficCompressor. Поэтому Ваш firewall не сможет заблокировать сетевую активность таких программ, и безопасность Вашего компьютера может быть нарушена.
Те программы, для которых сжатие не включено, получают доступ в Интернет обычным способом, минуя TrafficCompressor, и firewall имеет возможность заблокировать трафик таких программ.

Все программы КРОМЕ нижеперечисленных
Данный режим включает сжатие Интернет-трафика для любых локальных программ, кроме тех, которые указаны в списке.

Список программ
Вы можете задавать в именах файлов маски * и ?. Данные маски действуют так же, как в файловых командах в командной строке Windows. Маска ? означает ровно один любой символ. Маска * означает несколько любых символов (или не одного). Например, маска файла ie*.exe соответствует таким файлам: ie.exe, iexplore.exe и т.д.

Программы, для которых отключено сжатие трафика
Данная ссылка открывает окно со списком программ, для которых Вы отключили сжатие трафика, кликнув на кнопку "Нет" в режиме обучения.


Настройки: Другие

Порт сервера
Номер TCP порта, который использует TrafficCompressor для соединения со своим сервером. Смена порта может помочь вам, если доступ в Интернет через стандартный порт 47901 по какой-то причине закрыт у вашего провайдера, в вашей сети или на вашем компьютере.
Номер порта рекомендуется менять только в случае необходимости, т.к. при использовании портов, отличных от 47901, TrafficCompressor может дольше соединяться со своим сервером или не соединяться вообще.

Оптимизация сетевого протокола

Данные настройки меняют некоторые параметры сетевого протокола программы TrafficCompressor, но не меняют алгоритм сжатия или настройки алгоритма сжатия.

Сетевой протокол программы TrafficCompressor может быть оптимизирован для лучшей скорости передачи данных с небольшим увеличением объёма трафика или для лучшей экономии трафика. Вы можете выбрать, что для вас важнее, экономия трафика или скорость передачи данных.

Обратите внимание, что разные режимы оптимизации могут привести к сильно различающимся результатам на различных Интернет-соединениях и при использовании различных сетевых программ. Поэтому для достижения лучшего для вас результата рекомендуется протестировать все режимы и выбрать тот, который лучше всего подходит для ваших нужд в плане экономии трафика и скорости передачи данных. Если вы затрудняетесь выбрать оптимальный для вас режим, то мы рекомендуем выбрать режим "Для лучшей экономии трафика".

Для лучшей скорости передачи данных
Этот режим может привести в некоторых случаях к увеличению объёма трафика на 10%-20% по сравнению с режимом "Для максимальной экономии трафика". При этом скорость передачи данных может быть увеличена на некоторых медленных Интернет-соединениях на 50% и больше, но в большинстве случаев выигрыша в скорости вы не получите.

Для лучшей экономии трафика
Этот режим может привести в некоторых случаях к увеличению объёма трафика на 5%-8% по сравнению с режимом "Для максимальной экономии трафика". При этом скорость передачи данных может быть увеличена на некоторых медленных Интернет-соединениях на несколько процентов, но в большинстве случаев выигрыша в скорости вы не получите.

Для максимальной экономии трафика
При использовании данного режима экономия трафика максимальна.

Количество соединений с сервером
Задаёт количество одновременных соединений с сервером программы.
Программа TrafficCompressor может установить несколько одновременных TCP соединений со своим сервером и передавать данные по всем соединения параллельно. Похожая технология используется менеджерами загрузки (download managers) и может иногда увеличить скорость передачи данных на медленных Интернет-соединениях.

По умолчанию
Устанавливает стандартное количество соединений для выбранного режима оптимизации протокола.


Политика конфиденциальности сервиса TrafficCompressor

Версия: 30 июня 2006

Администрация сервиса TrafficCompressor относится с уважением к конфиденциальности пользователей сервиса TrafficCompressor. Программное обеспечение сервиса TrafficCompressor не содержит Spyware, Adware и любого другого вредоносного программного кода.

  1. Мы не собираем персональную информацию (такую как, телефонные номера, e-mail адреса, номера кредитных карт, пароли и т.д.) о пользователях сервиса TrafficCompressor и посетителей сайтов в доменах TCompressor.com и TCompressor.ru без явного уведомления и их осведомлённости.
  2. Мы не продаём и не предоставляем третьим лицам никакую информацию, как личного характера, так и любую другую о пользователях сервиса TrafficCompressor. Но мы можем раскрывать информацию о пользователях сервиса TrafficCompressor только, если это требуется по закону, или это необходимо для судебного процесса, или это необходимо для ответа на любые жалобы или для защиты прав, собственности или безопасности сервиса TrafficCompressor.
  3. Мы не используем никакую информацию о пользователях сервиса TrafficCompressor для рассылки спама или для наших или сторонних рекламных компаний.

Какую информацию собирает сервис TrafficCompressor?

Программное обеспечение сервиса TrafficCompressor собирает два вида информации о своих пользователях:
  • TrafficCompressor назначает уникальное число каждому компьютеру, на котором используется программа TrafficCompressor. Это число необходимо для корректной работы сетевого протокола программы TrafficCompressor и не содержит никакой личной информации о пользователе. Это число хранится на компьютере пользователя и передаётся на сервер сервиса TrafficCompressor вместе с именем учётной записи и паролем пользователя для идентификации сетевых соединений пользователя.
  • Сервис TrafficCompressor хранит в лог-файлах IP адреса пользователей и IP адреса Интернет-серверов, к которым пользователи подключаются через сервис TrafficCompressor. Эта информация собирается для технических целей, и на неё распространяются утверждения параграфов 2 и 3 данного документа.
Когда Вы просматриваете веб-сайты с использованием программы TrafficCompressor, Ваш IP адрес передаётся на просматриваемые веб-сайты сервером сервиса TrafficCompressor. Это является стандартной функцией любого неанонимного HTTP прокси сервера.

Дополнительные меры по обеспечению Вашей конфиденциальности.

Если Вы имеете повышенное беспокойство о конфиденциальности какого-либо конкретного сетевого соединения, Вы можете отключить программу TrafficCompressor для определённого сетевого протокола, определённых адресов Интернет-серверов или определённой программы. Вы можете сделать это, открыв окно "Настройки" в программе TrafficCompressor, и выбрав страницу настроек "Протоколы", "Адреса" или "Программы".
Кроме того, Вы можете временно отключить сжатие трафика, кликнув правой кнопкой мыши на значок TrafficCompressor в system tray и выбрав пункт меню "Выключить TrafficCompressor".

Изменения в данном документе.
Пожалуйста, обратите внимание, что данный документ может быть изменён в будущем. Последняя версия этого документа всегда доступна по адресу: http://www.TCompressor.ru/Privacy.aspx


Совместное использование программ TrafficCompressor и NVIDIA ActiveArmor Firewall

При совместном использовании программ TrafficCompressor и NVIDIA ActiveArmor Firewall возможны зависания компьютера во время просмотра веб-сайтов. Для того чтобы избежать зависаний, установите последнюю версию программы TrafficCompressor и последнюю версию драйверов для вашей материнской платы и включите режим "Not Offloadable" в настройках NVIDIA ActiveArmor Firewall.

Как включить режим "Not Offloadable"?

Чтобы включить режим "Not Offloadable",

  • кликните правой кнопкой мыши на значок ActiveArmor Firewall в правом нижнем углу экрана (в system tray),
  • выберите из меню команду "ActiveArmor Firewall Summary",
  • кликните на ссылку "View the Current Profile",
  • выберите в левой части окна пункт "Secure Networking Engine" (в старых версиях драйверов этот пункт называется "ActiveArmor"),
  • выберите пункт "Application",
  • в поле "Offload Default" установите режим "Not Offloadable",
  • Кликните на кнопку "Apply".
Если в этом окне или в окне "Secure Networking Engine"-"Port" содержатся дополнительные правила фильтрации, то убедитесь, что во всех правилах также установлен режим "Not Offloadable".

Что означает режим "Not Offloadable"?

При использовании режима "Not Offloadable" некоторые функции firewall'а выполняются на программном, а не на аппаратнои уровне. Это может несколько повысить нагрузку на центральный процессор (CPU). На функционирование firewall'а этот режим не повлияет, но сделает работу компьютера более стабильной.


Совместное использование программы TrafficCompressor и Apache HTTP Server

При использовании программы TrafficCompressor иногда возможны неполадки в работе локального веб-сервера Apache. Это может быть вызвано конфликтом какой-то программы с программой TrafficCompressor.

Если при использовании программы TrafficCompressor не отображаются веб-страницы, загружаемые с локального веб-сервера Apache, то попробуйте выполнить следующие инструкции:

  • Установите самую последнюю версию программы TrafficCompressor.
  • Если после установки последней версии программы TrafficCompressor работа локального веб-сервера Apache не восстановлена, то добавьте в файл настроек Apache (файл httpd.conf в папке conf) директиву Win32DisableAcceptEx. После этого перезапустите Apache.
    Директива Win32DisableAcceptEx поддерживается в версии Apache 2.0.49 и в более поздних версиях.
  • Если после выполнения предыдущих пунктов работа локального веб-сервера Apache не восстановлена, то откройте окно "О системе" в программе TrafficCompressor. Для этого в окне "О программе TrafficCompressor" кликните на кнопку "О системе".
    В этом окне будут показаны файлы, которые могут потенциально вызывать программный конфликт. Деинсталлируйте программы или компоненты программ, к которым относятся показанные файлы (файл TCompLsp.dll относится к программе TrafficCompressor, и его удалять не нужно).
    После этого перезапустите Apache.