QIP - Contacts Manager

QIP Contacts Manager Download - Скачать (519 Kb)

Менеджер контактов QIP - программа-инструмент, помогающий вам за считанные секунды сделать резервную копию своего серверного списка контактов или наоборот восстановить свой серверный список контактов из резервной копии. Также программа вам покажет полное содержимое вашего серверного списка, которое обычно недоступно для пользовательских глаз. Для тех, у кого проблема с отображением списка контактов в виде номеров, программа также поможет добавить имена всем контактам через функцию импорта. Импорт списка контактов доступен в нескольких вариантах. Из файла списка контактов QIP с расширением (*.cl), из файла списка контактов ICQ Pro с расширением (*.clb), из файла резервной копии программы с расширением (*.cmb). Последний файл (*.cmb) будет хранить весь ваш текущей список контактов в зашифрованном виде, включая списки видимости, невидимости, игнорируемых и других. Программа поддерживает все типы прокси серверов, которые возможны в QIP.

Описание.

Вся предоставленная ниже информация является личным мнением автора программы и НЕ МОЖЕТ расцениваться как официальная информация.
При копировании описания или его частей, ссылка на сайт qip.ru обязательна.

После того как вы введете данные своей учетной записи и подключитесь, то увидите свой серверный список контактов (пунктов), в котором будут следующие пункты (описания пунктов и их максимальное количество ниже в окне "Selected item info". А "Selected item hex view" - окно показывающее более подробную техническую информацию, для продвинутых пользователей):

- Items count - общее количество пунктов вашего списка.

- Last Modified - дата и время последней операции над списком (операция добавления, удаления, переименования и др.). Эти параметры хранятся на сервере и недоступны для редактирования.

- [root] - корневая группа, в которой содержатся все группы, на которые разбиты ваши контакты. Также этот пункт содержит данные, которые просто вам для справки, количество групп и количество контактов (номеров icq и ников aim). Раскрыв группы, вы увидите ваши контакты в том виде, в котором они хранятся на сервере, которые могут содержать в себе следующее:

(Auth) - красный круг с восклицательным знаком напротив контакта означает, что этот контакт должен вас авторизовать, и только после этого сервер будет оповещать вас о смене статусов этого контакта (в QIP, о статусах таких контактов сервер и так оповещает, но все равно желательно запросить авторизацию).

(Alias) - ник/псевдоним вашего контакта, с которым вы его видите в списке контактов QIP.

(Email, Mobile, Note) - адрес электронной почты, номер мобильного, заметка этого контакта.

(Time) - в этом поле показывается дата и время последнего изменения данных контакта, также официальные клиенты добавляют эту дату после отправки первого сообщения этому контакту. Поэтому конкретно сказать, что означает этот параметр, не представляется возможным.

(Type) - тип пункта хранящегося в вашем списке. Кроме групп и контактов, ваш серверный список может хранить еще порядка 25 различных типов пунктов, которые не будут вам показываться, так как они не требуют особого вмешательства пользователя.

- Visible, Invisible, Ignore List - в этих пунктах показываются все контакты приватных списков, т.е. списка видимости/невидимости/игнорируемых, которые также хранятся на сервере. Очень часто пользователи жалуются, что не хватает места в списке игнорируемых (макс. 128 контактов). А я отвечаю, что список игнорируемых сделан не для того, чтобы добавлять туда спамеров, а для людей, которые вас как-либо достали, надоели и тд. Добавляя спамерские номера icq в список игнорируемых, вы просто его переполняете, так как такие номера достаточно быстро удаляются и ими пользуются обычно всего один раз. Для борьбы со спамом пользуйтесь анти-спам ботом. И не забудьте почистить список игнорируемых.

- Other Items - все остальные пункты вашего списка. Достаточно интересный пункт, в котором иногда могут храниться сотни "непонятных" контактов и данных. Привожу описания часто-встречающихся пунктов:

([no name] - Bitmask) - пункт, который хранит настройки вашего приватного статуса и различные настройки взаимодействия сетей aim и icq. Этот пункт не рекомендуется удалять, так как он создается клиентом при каждом новом подключении.

(LastUpdateDate) - пункт, который может в себе содержать дату и время по усмотрению клиентской программы. Например, официальные клиенты icq добавляют этот пункт после каких-либо манипуляций со своими деталями/данными.

(Import Time) - этот пункт показывает дату и время последнего импорта контактов. О нем стоит рассказать немного подробнее. Дело в том, что при отсутствии этого пункта в вашем списке, вы можете один раз импортировать любые контакты, и они все добавятся без авторизации, что очень удобно при импорте сотни контактов (вам после импорта просто не придется у всех неавторизованных просить заново авторизацию). До некоторого времени, этот пункт можно было удалять, и заново импортировать контакты без запросов авторизации. Теперь же, после первого импорта, сервер сам добавляет этот пункт, и ставит атрибут "Только для чтения", что не позволит второй раз произвести импорт контактов без запроса авторизаций. Сама то процедура импорта произойдет, и контакты добавятся в список, но у некоторых вам придется в дальнейшем просить авторизацию. Очень удобно импортировать контакты в новую зарегистрированную учетную запись, так как в ней нет еще этого пункта и это вам позволит добавить всех без авторизации.

(External) или (NonBuddy) - это схожие типы пунктов и у большинства пользователей они могут отсутствовать. Их смысл- это хранить в себе данные контактов, которые не пользуются сетями icq или aim, к примеру в типе пункта NonBuddy может быть указан email адрес, а в External (к примеру пункт 1#EXT) может быть запись имени человека с номером мобильного телефона.

(Saved) - таких пунктов может быть очень много. Этот пункт хранит в себе имя или номер учетной записи, которая была удалена, но с владельцем которой вы хоть раз обменивались сообщениями. Своего рода резервное копирование со стороны сервера. Только непонятно для какой цели, так как механизм их восстановления не наблюдался. Но эти пункты удаляются, если вы заново добавите контакты в список. Но в принципе их можно спокойно удалять и сервер это позволяет делать.

(PreAuthed) - таких пунктов также может быть много. Этот пункт сам добавляется сервером после того как удаленный пользователь позволит вам добавить себя в ваш список. Этот пункт хранит в себе также имя или номер учетной записи. Эти пункты с одной стороны полезны тем, что вы можете такие контакты добавлять без авторизации в любое время, пока у вас есть эти пункты. Ну и неудобны тем, что при их большом количестве и при получении списка контактов они съедают свою долю трафика. Но в принципе их можно спокойно удалять и сервер это также позволяет делать.

Все остальные пункты встречаются не так часто, но все они будут показываться в списке, и к ним будет идти снизу пояснение.

В программе есть два режима работы:

1. Режим просмотра (View Mode), где вы просто просматриваете содержимое своего серверного списка.

2. Режим редактирования (Edit Mode), где вы можете производить различные операции, такие как:

[Delete checked] - удаление тех пунктов, перед которыми стоит галочка.

[Clear list] - очистка всего списка (точнее говоря, удаление всего, что будет позволено сервером).

[Import] - импорт списка из файлов различных форматов.

[Export] - экспорт списка в файлы различных форматов.

Также в одну учетную запись вы можете импортировать сразу несколько файлов различных списков. К примеру, у вас две учетные записи, и вы теперь хотите объединить списки контактов в одну, то ничего вам не помешает сделать это при помощи данной программы. Все одинаковые контакты двух списков разных учетных записей при этом останутся как есть.

Еще вы можете сами отредактировать файлы импорта (касается только файлов с расширениями cl или clb) и изменить там никнеймы/псевдонимы ваших контактов и обновить их на сервере через процедуру импорта. Таким образом, процедура импорта служит не только добавлением в серверный список недостающих контактов, но и обновлением текущих, которые уже в серверном списке. Это очень пригодиться тем, у кого серверный список показывается в QIP только в виде номеров. Вам надо будет сделать экспорт списка контактов в формат ICQ (*.clb) из клиента, которым вы пользовались до этого и произвести импорт с помощью этой программы. Если такой возможности клиент не предоставляет, то вам в этой программе надо будет вначале сделать экспорт в файл формата ICQ plain text, в этом файле добавить никнеймы/псевдонимы и произвести процедуру импорта.

Если во время процедуры импорта программа показывает вам, что превышены лимиты количества пунктов/контактов, то скорее всего у вас переполняется какая-либо группа. Так как во время написания этой справки, для учетной записи icq, максимум контактов в одной группе может быть 200. Максимум групп 50. Максимум контактов по всем группам суммарно 600.

По всем возникшим вопросам, обращайтесь на наш форум в раздел QIP Contacts Manager.