О программе IDM

Об Internet Download Manager
версия 5.08
Internet Download Manager (IDM) – удобный инструмент, позволяющий увеличить скорость загрузки до 500 процентов, поддерживающий докачку и загрузку по расписанию. Согласно мнениям пользователей, Internet Download Manager – отличная программа, позволяющая загружать ваше любимое программное обеспечение, игры, cd, dvd и mp3-музыку, фильмы, бесплатные и условно бесплатные программы намного быстрее!
Internet Download Manager имеет встроенный логический ускоритель загрузки, включающий интеллектуальную динамическую сегментацию файла и безопасную многослойную технологию загрузки, что способствует ускорению загрузки. В отличие от других ускорителей и менеджеров загрузки, где файлы сегментируются перед началом загрузки, Internet Download Manager сегментирует загружаемые файлы динамически во время процесса загрузки. К тому же, Internet Download Manager многократно использует имеющиеся соединения, минуя дополнительные стадии подключения и авторизации для достижения лучших скоростных характеристик.
Комплексная система анализа ошибок и возможность докачки, поможет продолжить загрузку, прерванную из-за потери соединения, проблем в сети, выключения компьютера или перепадов в подаче электроэнергии. Простой графический интерфейс делает IDM удобным и дружественным к пользователю.
Internet Download Manager имеет мультиязычный интерфейс, широкие возможности по настройке, загрузке скинов, поддерживает прокси-серверы, протоколы FTP, HTTP и HTTPS, работу за файерволом, переадресацию файлов, работу с файлами cookie, загрузку с авторизацией, предосмотр содержимого файлов ZIP, категории, обрабатывает содержание MP3-аудио и MPEG-видео и поддерживает большое количество серверных платформ. IDM без проблем интегрируется в такие браузеры как Microsoft Internet Explorer, Netscape, AOL, MSN Explorer, Opera, и Mozilla для автоматической обработки ссылок. Вы можете также перетаскивать файлы или запускать Internet Download Manager из командной строки. Internet Download Manager может подключить Ваш модем к сети в установленное время, загрузить указанные Вами файлы, после чего разорвать соединение и даже выключить компьютер.
IDM проверяет наличие новой версии раз в неделю. Как только она становится доступна, IDM показывает диалог, описывающий новые возможности и предлагает Вам произвести обновление. Вы можете также загрузить последнюю версию IDM, используя опцию Быстрого Обновления.
Когда IDM запущен, он отображает свою иконку с пирамидкой на панели задач. Меню IDM может быть вызвано нажатием правой кнопки мыши на иконке. Вы можете закрыть IDM, выбрав пункт "Выход" в этом меню.
Некоторые функции IDM доступны только в зарегистрированной версии. Пожалуйста, прочтите о регистрации, нажав здесь.


Что нового?

Что нового в версии 5.08

Мы добавили множество функций по просьбам пользователей IDM

Новые возможности версии 5.08:
1. Улучшена обработка URL на иностранных языках в IE. IDM использует текущую кодировку веб-страницы, чтобы предложить правильные имена файлов при сохранении загруженных файлов.
2. Усовершенствован механизм загрузки в сторону увеличения скорости загрузки.
3. Исправлены ошибки при отправке запросов серверам на иностранных языках.
4. Улучшена обработка загрузки для премиум-аккаунтов популярных rapidshare-сайтов.
Версия 5.08 содержит все последние исправления ошибок

Новые возможности версии 5.07:
1. Добавлена полная совместимость с Windows Vista.
2. Решено несколько проблем с IE 7.
3. Устранены конфликты "Расширенной интеграции в браузеры" с Windows Vista, Windows 2003 и некоторыми интернет-приложениями.
4. Функция отслеживания нажатия в браузерах на основе IE (MSN Explorer, Avant, MyIE, некоторые версии AOL и пр.) была перемещена из процесса idman в отдельный exe-модуль. Этот модуль может быть включен/отключен в "Опции->Общее".

Новые возможности версии 5.05:
1. Добавлена поддержка браузера Firefox 2.0.
2. Добавлен диалог, позволяющий выбрать одно из нескольких действий в случае, если добавлен дубликат уже имеющейся ссылки.

Новые возможности версии 5.04:
1. Изменена базовая интеграция в браузеры. Добавлены расширения для браузеров, основанных на Mozilla (Mozilla Firefox, Floc, пр.) для лучшего перехвата загрузок в этих браузерах, нежели это возможно при расширенной интеграции. Также, в контекстное меню этих браузеров были добавлены "Download with IDM" ("Загрузить с помощью IDM") и "Download All Links IDM" ("Загрузить все ссылки помощью IDM").
2. Вкладка "Общее" в опциях IDM разделена на вкладки "Общее" и "Типы Файлов".
3. В диалог "Загрузка завершена" добавлена кнопка "Открыть как..." и пункт меню "Открыть как..."

Новые возможности версии 5.03:
1. Добавлена поддержка протокола MMS. Ссылки MMS могут быть загружены только вручную с помощью кнопки "Добавить" или при использовании пункта "Download with IDM" в меню по нажатию правой кнопкой мыши в IE.
2. Изменен диалог настроек. Вкладка "Загрузка" разделена на вкладки "Загрузка" и "Сохранение". Добавлена опция отключения загрузки во время демонстрации диалога "Информация о Загружаемом Файле".

Новые возможности версии 5.02:
1. IDM может исправить все ошибки объединения и восстановить файл, когда происходивший процесс объединения загруженных частей был прерван вследствие падения напряжения или остановки/завершения процесса IDM.
2. Улучшен диалог прогреcса загрузки. Теперь его размер может быть изменен или он может быть свернут в Панель задач.
3. Окно сообщения о завершении загрузки было заменено диалогом завершения загрузки, предоставляющем несколько полезных функций, например, открытие папки, куда загружен файл.
4. Улучшен диалог начала загрузки. Теперь Вы без труда сможете выбрать папку, куда сохранять файл, непосредственно в этом диалоге.

Новые возможности версии 5.01:
1. Добавлен предосмотр эскизов в Граббере Сайтов IDM.
2. Добавлен Планировщик в Граббер Сайтов. Имеется возможность запланировать множество проектов Граббера для запуска единожды в указанное время, остановки в указанное время или выполнения периодически для синхронизации изменений.
3. Добавлена возможность обновления в Граббер Сайтов IDM. Возможность начать изучение сайта снова со стартовой страницы, для обновления файлов проекта, которые были изменены на сервере.

Новые возможности версии 5.0:
1. Добавлена функция Граббера Сайтов. Эта функция не только поможет загружать требуемые файлы, определенные фильтрами, например, все изображения с вебсайта или все аудиофайлы с вебсайта, но и позволит Вам загружать подмножества вебсайтов, или загружать вебсайты для автономного просмотра или создания зеркал.
2. Улучшены визуальное оформление и пользовательский интерфейс. Панель инструментов корректнее отображает различные визуальные стили XP.
3. Переработан и усовершенствован механизм загрузки IDM.

Новые возможности версии 4.07:
1. Добавлена функция групповой загрузки, для загрузки файлов в использованием подстановочных символов. Для использования функции, выберите пункт меню "Задачи->Добавить групповую загрузку".
2. Улучшен интерфейс пользователя для основного диалога IDM, добавлен статус "Ошибка" и возможность использовать кнопку "Старт" для нескольких выбранных загрузок.
3. Улучшен интерфейс пользователя для диалога "Загрузить все с помощью IDM".
4. Улучшена загрузка по протоколу https.

Новые возможности версии 4.06:
1. Улучшена общая защита Internet Download Manager.
2. Исправлена ошибка переполнения буфера, появлявшаяся при загрузке с длинных URL.
3. Добавлен диалог авторизации для случаев, когда идентификационная информация не верна.
4. Улучшена обработка сайтов, требующих особую идентификационную информацию.
5. Добавлено несколько улучшений к логике механизма загрузки.

Новые возможности версии 4.05:
1. Улучшен интерфейс пользователя.
2. Добавлена поддержка визуальных стилей XP.
3. Добавлены иконки для настроек IDM в диалог опций IDM.
4. Улучшена интеграция в браузеры.
5. Улучшена загрузка с сайтов http/https, где необходимо использование cookie.

Новые возможности версии 4.04:
1. Улучшена интеграция в браузер Internet Explorer.
2. Все связи заложенные в расширенную интеграцию в браузеры включены в базовую интеграцию в Internet Explorer. Если Вы используете только Internet Explorer и имеете пробемы с расширенной интеграцией в браузеры, Вы можете спокойно отключить расширенную интеграцию в браузеры.
3. Улучшен перехват защищенных http-ссылок от Internet Explorer. Теперь IDM способен перехватить запущенную опосредственно https-загрузку.

Новые возможности версии 4.03:
1. Доработана функция браузера Internet Explorer "Download with IDM" ("Загрузить с помощью IDM"). Теперь IDM подхватывает все необходимые запросы от Internet Explorer и начинает загрузку. Теперь пользователи могут выделить текст в Internet Explorer и выбрать "Download with IDM" ("Загрузить с помощью IDM") в контекстном меню по нажатию правой кнопки мыши, чтобы добавить все ссылки из выделенного текста в IDM
2. Улучшена логика перехвата загрузочных ссылок. Теперь IDM может производить загрузку с сайтов, имеющих защиту от загрузки с помощью менеджеров загрузки
3. Разработана технология перехвата ссылок зашифрованных с помощью антилич-плагинов
4. Добавлена защита от очистителей реестра, оптимизаторов, ремонтных программ и пр., которые повреждают ключи реестра Internet Download Manager

Новые возможности версии 4.02:
1. Добавлена возможность настройки просмотра Панели Инструментов. Можно настроить стиль Панели инструментов, порядок расположения и размер кнопок панели.
2. Разработаны новые объемные значки. Пользователи, привыкшие к старому стилю, могут вернуться к Классическим значкам в меню настройки Панели инструментов
3. IDM предоставляет возможность выбора 4 различных видов Панели инструментов, возможность загрузить новые скины Панели инструментов с официального сайта программы или разработать новые скины самому, если Вы знакомы с основами графического дизайна
4. Оптимизирован механизм загрузки для нескольких типов серверов FTP/HTTP

Новые возможности версии 4.01:
1. Добавлена возможность переключения между старой и новой интеграцией в браузеры. В некоторых случаях новая расширенная интеграция в браузеры вызывала конфликт в работе со сторонними приложениями Интернет.
2. Улучшена опция "Загрузить все"
3. Добавлена поддержка большего числа FTP и HTTP серверов, не совместимых с RFS

Новые возможности версии 4.00:
1. Полностью переработан основной механизм загрузки. Увеличены скорость загрузки и надежность
2. Улучшен интерфейс пользователя. В Панель инструментов IDM добавлены кнопки "Запуск" и "Остановка" для обработки очереди загрузки. Дерево "Все загрузки" теперь включает файлы всех категорий загрузки, независимо от того, завершена ли загрузка этих файлов
3. Полностью переработана интеграция в браузеры. IDM теперь может перехватывать загрузки от любых браузеров
4. Добавлена возможность настройки сочетания клавиш для предотвращения или принудительной загрузки с помощью Internet Download Manager. Эта возможность должна теперь работать в любых браузерах, а не только в Internet Explorer, как это было прежде
5. Добавлен список игнорируемых сайтов, с которых Internet Download Manager не будет перехватывать загрузки
6. Улучшена опция "Загрузить все". Размер основного окна может быть изменен. Это полезно для выбора пути к сохраняемым файлам
7. Добавлена возможность повторной загрузки, для загрузки снова уже загруженных ранее файлов
8. Добавлен пункт "Открыть папку" в меню по нажатию правой кнопкой мыши
9. Добавлено несколько новых методов для авторизации на FTP-прокси
10. Добавлена возможность не использовать прокси для указанных адресов Интернет
11. Добавлена возможность загрузки файлов объемом более 4Гб

Новые возможности версии 3.18:
1. Добавлена опция "Загрузить все с помощью IDM"
2. Переработан файл справки IDM

Новые возможности версии 3.17:
1. Добавлена возможность настройки колонок и панели инструментов
2. Добавлены новые колонки: Источник Ссылки, Дата Последней Попытки, Сохранить как, Дата Добавления
3. Расширены возможности вкладки "Соединение" в опциях IDM
4. Добавлена возможность загрузки в один поток
5. Добавлена возможность устанавливать макс. количество потоков для конкретных серверов
6. Улучшен внешний вид, изменены иконки для категорий загрузки
7. Добавлена возможность сохранения размеров колонок и диалогов
8. Добавлена возможность настройки порядка отображения колонок
9. Улучшен Планировщик. Добавлена возможность мультисессийной загрузки
10. Добавлена возможность интеграции в Mozilla Firebird

Новые возможности версии 3.16:
1. Поддержка мультиязычного интерфейса. Добавлены Французский, Немецкий, Итальянский, Датский, Японский, Арабский, Испанский и другие языки
2. Добавлена поддержка Microsoft ISA server

Новые возможности версии 3.15:
1. Добавлен предосмотр содержимого ZIP-архивов перед загрузкой
2. Добавлены категории загрузки
3. Усовершенствован интерфейс пользователя (сортировка по столбцам, возможность изменять URL в процессе загрузки)
4. Улучшена интеграция со всеми браузерами

Новые возможности версии 3.14:
1. Добавлена поддержка HTTPS
2. Добавлено звуковое сопровождение различных событий
3. Добавлено больше типов идентификации
4. Улучшен планировщик загрузки

Новые возможности версии 3.13:
1. Улучшена интеграция в Internet Explorer
2. Добавлена поддержка большего количества серверных платформ
3. Добавлена возможность переключения фокусировки клавишей табуляции
4. Увеличено количество параметров командной строки
5. Оптимизирован интерфейс пользователя

Новые возможности версии 3.12:
1. Улучшен встроенный ускоритель загрузки
2. Увеличена скорость загрузки по HTTP
3. Добавлена конвейерная обработка команд FTP
4. Добавлена функция многократного использования соединений FTP

Новые возможности версии 3.11:
1. Добавлены справка и руководство в формате HTML
2. Оптимизированы коды библиотеки и исполняемого файла IDM, снижена загрузка процессора
3. Добавлена поддержка дополнительных серверных платформ

Новые возможности версии 3.10:
1. Добавлены параметры командной строки для управления загрузкой
2. Усовершенствован планировщик загрузки
3. Улучшена обработка очереди загрузки
4. Добавленные квоты и пределы загрузки. Это полезно для соединений, которые используют какую-либо политику доступа, например, Direcway, Direct PC, Hughes, и т.д.
5. Улучшен интерфейс пользователя, добавленный "тихий" режим, добавлена опция отключения диалога начала загрузки

Новые возможности версии 3.09:
1. Улучшена интеграция в браузер. Теперь IDM может загружать файлы с серверов, которые не позволяют пользоваться ускорителями и менеджерами загрузки
2. Интерфейс пользователя стал более удобным
3. Добавлены "Советы Дня"

Новые возможности версии 3.08:
1. Добавлена опция для интеграции в MSN Explorer и в браузеры, являющиеся надстройками над Internet Explorer
2. Добавлена возможность редактирования списка расширений для перехвата загрузок из браузеров Netscape, Mozilla и Opera
3. Добавленные новые форматы для контроля содержимого

Новые возможности версии 3.07:
1. Добавлено извлечение и ускоренная загрузка потоков аудио данных
2. Добавлена поддержка большего количества платформ FTP и HTTP серверов

Новые возможности версии 3.06:
1. Добавлен импорт/экспорт списков загрузки
2. Добавлены усовершенствования в оптимизатор логики загрузки, что немного увеличило скорость загрузки
3. Добавлена поддержка большего количества серверных платформ FTP и HTTP

Новые возможности версии 3.05:
1. Улучшена скорость загрузки. Последняя часть файла не замедляет процесс загрузки
2. Добавлена функция контроля содержимого файлов
3. IDM показывает полезную информацию о медиа-файлах (mp3, avi, mpeg...) в ходе процесса загрузки
4. Добавлена возможность интеграции в браузеры Netscape 6, Netscape 7, Mozilla и Opera
5. Улучшена обработка файлов cookie
6. Добавлена полная поддержка перетаскивания файлов

Новые возможности версии 3.04:
1. Добавлена поддержка дозвона
2. Добавлена корзина
3. Оптимизирована логика загрузки
4. Изменена графика кнопок и внешний вид
5. Оптимизирован поиск по зеркалам

Новые возможности версии 3.03:
1. Добавлены настройки появления диалога загрузки
2. Добавлена возможность проверки на вирусы
3. Изменена графика кнопок и внешний вид
4. Добавлено множество возможностей для более удобной работы с IDM

Новые возможности версии 3.02:
1. Добавлен планировщик и очередь загрузки
2. Добавлено больше оптимизаций и усовершенствований в логику загрузки

Новые возможности версии 3.01:
1. Добавлена возможность слежения за буфером обмена
2. Добавлено сохранение информации о паролях (доступно только в зарегистрированной версии). IDM сохраняет список информации о паролях для сайтов, которые требуют авторизации
3. Добавлена поддержка большего количества FTP и HTTPD серверов. Теперь поддерживается больше форматов листинга. Модуль реализации протокола был улучшен, теперь он более надежен и не чувствителен к нестандартным ответам сервера
4. Добавлена поддержка файлов cookie
5. Логика загрузки файла была оптимизирована. Это увеличило скорость загрузки примерно на 5%
6. Добавлена полная поддержка FTP/HTTP

Внимательно следите за обновлениями IDM. Вы можете всегда найти последнюю версию IDM здесь.

Версия 3.01 содержит все последние исправления ошибок.
-утечка памяти при сборке частей файла
-поддержка ранних версий Windows 95


Часто Задаваемые Вопросы

ВОПРОСЫ ПОКУПКИ И РЕГИСТРАЦИИ

 Как мне зарегистрировать/купить Internet Download Manager?
 Я потерял серийный номер и все данные регистрации. Как мне снова зарегистрировать IDM?
 У меня есть кредитная карта, но я не хочу информацию с нее передавать через Интернет.
 Я хочу приобрести IDM, но у меня нет кредитной карты. Как мне купить программу?
 Я хочу приобрести IDM на CD. Это возможно?
 В чем разница между пробной и зарегистрированной версией?
 Когда я пытаюсь зарегистрировать продукт, серийный номер не срабатывает. Что я делаю неправильно?
 Я переустановил полную версию IDM, но не смог ее зарегистрировать, поскольку пункт меню “Регистрация->Регистрация” неактивен.
 Мой испытательный период использования IDM истек, и я не хочу покупать программу. Как мне удалить IDM?

ВОПРОСЫ ИНТЕГРАЦИИ В БРАУЗЕРЫ

 Я не могу интегрировать IDM в мой браузер Opera (или Mozilla, Netscape, FireFox, Firebird). Internet Download Manager перехватывает загрузку от этих браузеров?
 IDM пытается загрузить некие файлы всякий раз, когда я запускаю Internet Explorer (или когда включаю компьютер), даже если я жму “Отмена”.

ВОПРОСЫ ЗАГРУЗКИ С ПОМОЩЬЮ IDM

 Я не могу загрузить файл без задействования IDM. Диалог загрузки IDM появляется всякий раз, даже если я отключаю IDM. Как мне быть?
 Я хочу отключить загрузку с помощью IDM. Как мне это сделать?
 Internet Download Manager не перехватывает загрузку от MSN Explorer. Что не так?
 Internet Download Manager не перехватывает загрузку. Что не так?
 Моя скорость загрузки в IDM не особо велика. Как мне это исправить?
 Я указал пароль к сайту в “Опции->Пароли Сайтов”, но IDM не использует его, когда я пытаюсь произвести загрузку с этого сайта.
 IDM пытается загружать обновления Windows. Как мне отключить это?
 IDM загрузил файл, но не объединяет загруженные временные куски. Что мне делать?
 Попытка IDM объединить временные куски вызывает ошибку распределения памяти. Что мне делать?

ВОПРОСЫ НАСТРОЙКИ

 Я указал папку, куда помещать загруженные файлы, но IDM тем не менее кладет их в другую папку. Что я делаю неправильно?
 Я не знаю какой файл указывать для моего антивируса в диалоге "Опции->Загрузка".

ОБЩИЕ ВОПРОСЫ

 У меня проблемы с удалением программы. Что мне делать?
 Мой Internet Download Manager после обновления версии (или после покупки полнофункциональной версии) не может соединиться с сетью Интернет, и я не могу ничего загрузить. Я получаю следующие сообщения: "Предложенное имя сервера существует, но не содержит доступных корректно связанных данных (сам хост существует, но прямого доступа к нему нет)", "Сервер не найден" или "Не удалось соединиться с сервером".
 У меня конфликтуют IDM и Google Search Desktop. Что мне сделать, чтобы установить и запускать одновременно IDM и Google Search Desktop.
 После того, как я установил IDM, я не могу выйти в Интернет, или некоторые из моих интернет-приложений не работают должным образом.
 Мой Антивирус/Антишпион сообщает, что файл IDM idmmkb.dll прислушивается к нажатия клавиш на клавиатуре и может являться угрозой для моего компьютера. Пожалуйста, разъясните эту ситуацию.
 Microsoft Antispyware говорит, что IDM добавил новый Winsocks LSP (layered service provider) 'idmmbc.dll', который просматривает данные сети и может оказаться шпионским модулем. Idmmbc.dll является шпионским модулем?
 Я отправил e-mail, но Вы не ответили. Почему?
 Я хочу предложить новую опцию. Как мне отправить предложение?
 Я обнаружил ошибку. Как мне сообщить о ней?

ВОПРОСЫ ПОКУПКИ И РЕГИСТРАЦИИ

 В. Как мне зарегистрировать/купить Internet Download Manager?

Вы можете оплатить регистрацию Вашей копии Internet Download Manager через Интернет с помощью кредитной карты. Принимаются следующие кредитные карты: Visa, Mastercard, Eurocard, Amex, JCB, Visa Delta, Visa Purchasing, Diners, Switch/Solo. Как только платеж будет зачислен, система немедленно отправит Вам инструкции по регистрации. Вы, также, можете произвести заказ по телефону, факсу или отправив письмо. Также, возможна оплата телеграфным переводом. Если Вы произвели оплату чеком (заказ по почте), срок обработки заказа может быть увеличен на время проверки корректности банковской операции.

В. Я потерял серийный номер и все данные регистрации. Как мне снова зарегистрировать IDM?

Если Вы потеряли серийный номер или инструкции по загрузке Internet Download Manager, мы можем Вам переслать в автоматическом режиме Ваши данные регистрации. Воспользуйтесь этой формой для восстановления Ваших регистрационных данных.

В. У меня есть кредитная карта, но я не хочу информацию с нее передавать через Интернет.

Вы можете отправить нам данные с Вашей кредитной карты по почте, факсу или телефону. Для оформления покупки с помощью факса, нажмите здесь, с помощью почты, нажмите здесь, с помощью телефона, нажмите здесь.
Заказ по факсу
Заказ по почте
Заказ по телефону

В. Я хочу приобрести IDM, но у меня нет кредитной карты. Как мне купить программу?

Только использование кредитной карты гарантирует моментальную активацию полной версии Internet Download Manager. Но если у Вас нет кредитной карты, Вы можете приобрести IDM, воспользовавшись почтой, оплатив заказ чеком, или телеграфным переводом. Пожалуйста, посетите форму продажи, выберите наверху страницы форму оплаты и следуйте инструкциям.

В. Я хочу приобрести IDM на CD. Это возможно?

Да. Приобретение CD добавляет к цене продукта дополнительно $10, взимаемые за расходы на транспортировку. Пожалуйста, свяжитесь с нами, если Вы хотите купить IDM на CD.

В. В чем разница между пробной и зарегистрированной версией?

Зарегистрированная версия имеет ряд дополнительных возможностей: отсутствие лимитов на использование, управление паролями сайтов, кнопка Очистить, улучшенная пропускная способность за счет встроенного оптимизатора логики загрузки. После приобретения Вы получите приоритет в технической поддержке и право БЕСПЛАТНОГО обновления всех версий IDM в течение года со дня регистрации.

В. Когда я пытаюсь зарегистрировать продукт, серийный номер не срабатывает. Что я делаю неправильно?

Перед вводом серийного номера Вы должны установить полнофункциональную версию Internet Download Manager. Также, удостоверьтесь, что Вы вводите правильный серийный номер. Пожалуйста, не путайте символы 0 и O, I и 1. Лучше скопировать и вставить серийный номер в окно регистрации.

В. Я переустановил полную версию IDM, но не смог ее зарегистрировать, поскольку пункт меню “Регистрация->Регистрация” неактивен.

Если пункт меню "Регистрация" неактивен, значит Ваша версия IDM уже зарегистрирована, и Вам не нужно делать это повторно. Вы можете увидеть свое имя в "Справка->О программе IDM" в строке "Этот продукт зарегистрирован на:".

В. Мой испытательный период использования IDM истек, и я не хочу покупать программу. Как мне удалить IDM?

Более 200,000 зарегистрированных пользователей наслаждаются использование IDM! Пожалуйста, ознакомьтесь с мнениями пользователей. Если Вы все еще хотите удалить IDM, обратитесь к документации Windows для ознакомления с информацией по удалению программ. Обычно нужно запустить "Установку и удаление программ" из "Панели управления". Удаление на 100% работоспособно. Если у Вас возникли проблемы с удалением ранних версий IDM, загрузите и запустите эту программу для удаления интеграции в браузеры. После чего просто удалите папку IDM.

ВОПРОСЫ ИНТЕГРАЦИИ В БРАУЗЕРЫ

 В. Я не могу интегрировать IDM в мой браузер Opera (или Mozilla, Netscape, FireFox, Firebird). Internet Download Manager перехватывает загрузку от этих браузеров?

Internet Download Manager поддерживает все эти браузеры. Обратите внимание, что если Вы хотите использовать IDM совместно с Mozilla или Opera, то Вам необходимо включить опцию "Использовать расширенную интеграцию в браузеры". Если это не помогает, пожалуйста, проверьте, находятся ли файлы NPIDMan1.dll и NPIDMan2.dll в субпапке “\Plugins” (для Opera "Program\Plugins\") головной папки Mozilla. Если эти файлы отсутствуют, пожалуйста, скопируйте их из головной папки IDM (по умолчанию это “C:\Program Files\Internet Download Manager”) в папку “\Plugins” браузера. Удостоверьтесь, что в IDM пункт, соответствующий Вашему браузеру отмечен в блоке "Интегрировать IDM в браузеры" в "Опции->Общее". Для ранних версий браузера Opera Вам может потребоваться задать параметры в "Opera->Файл->Настройки->Мультимедия->Найти плагины..."

В. IDM пытается загрузить некие файлы всякий раз, когда я запускаю Internet Explorer (или когда включаю компьютер), даже если я жму “Отмена” .

Вероятнее всего, некое интернет-приложение на Вашем компьютере пытается загрузить эти файлы, и IDM перехватывает их загрузку. IDM не знает, куда поместить загруженное или как запустить эти файлы. Интернет-приложение может заметить, что файлы не там, где они должны быть и попытаться загрузить их снова. Для решения этой проблемы, пожалуйста, посмотрите, с какого сервера IDM пытается произвести загрузку и добавьте этот сервер в список исключений в "Опции->Общее".

ВОПРОСЫ ЗАГРУЗКИ С ПОМОЩЬЮ IDM

 В. Я не могу загрузить файл без задействования IDM. Диалог загрузки IDM появляется всякий раз, даже если я отключаю IDM. Как мне быть?

Если Вы временно для единичной загрузки хотите отключить IDM, Вы можете, удерживая клавишу ALT, нажать на ссылку, тем самым воспрепятствовав перехвату загрузки IDM. Отметьте, что удерживая клавишу ALT Вы позволяете загружать файл браузеру. Вы можете переопределить эту клавишу, воспользовавшись кнопкой Клавиши в "Опции IDM->Общее". Вы также можете удалить этот тип файла из списка "автозагрузки" в диалоге "Опции->Общее". Или же можно добавить этот сайт в список исключений в том же диалоге.

В. Я хочу отключить загрузку с помощью IDM. Как мне это сделать?

Если Вы хотите, чтобы IDM не перехватывал ни одной загрузки от браузера, отключите интеграцию в браузер в опциях IDM. После включения/отключения интеграции в "Опции IDM->Общее" не забудьте перезапустить браузер.

В. Internet Download Manager не перехватывает загрузку от MSN Explorer. Что не так?

Удостоверьтесь, что пункт "Интеграция в Microsoft Internet Explorer" отмечен в "Опции IDM->Общее". Также, если Вы хотите, чтобы IDM перехватывал загрузку от MSN Explorer или браузеров, базирующихся на Internet Explorer, значок IDM должен оставаться в Панели задач.

В. Internet Download Manager не перехватывает загрузку. Что не так?

IDM перехватывает загрузку, если ее тип соответствует списку типов или расширений. Вы можете редактировать список расширений в "Опции IDM->Общее". Если это не помогает, попробуйте нажимая на загрузочную ссылку, удерживать клавишу CTRL.

В. Моя скорость загрузки в IDM не особо велика. Как мне это исправить?

Пожалуйста, попробуйте задать высокоскоростной тип подключения в диалоге "Опции->Соединение". Вы, также, можете попробовать "поиграть" с параметром "По умолчанию макс. количество потоков" в том же диалоге. Пожалуйста, примите к сведению, что скорость загрузки сильно зависит от сервера, с которого происходит загрузка, а также от ваших текущих сетевых настроек.

В. Я указал пароль к сайту в “Опции->Пароли Сайтов”, но IDM не использует его, когда я пытаюсь произвести загрузку с этого сайта.

Пожалуйста, удостоверьтесь, что в диалоге "Опции->Пароли Сайтов" Вы выбрали сетевой протокол, соответствующий вашему URL. Заметьте, что загрузка может иметь URL, отличный от базового сервера. Например, Вы просматриваете сайт "http://www.mysite.com", но вся загрузка по ссылкам с него производится с "http://members.mysite.com". Пожалуйста, введите корректное имя сервера в список паролей сайтов. Если это не решает Вашу проблему, попробуйте подставить звездочку в URL, например "*mysite.com".

В. IDM пытается загружать обновления Windows. Как мне отключить это?

Пожалуйста, попробуйте установить/добавить следующее значение в исключающий список в диалоге "Опции->Общее": *.update.microsoft.com *download.windowsupdate.com.

В. IDM загрузил файл, но не объединяет загруженные временные куски. Что мне делать?

Обычно подобная ошибка появляется, когда временный файл используется другим приложением. Это может быть некий антивирус или программа просмотра файлов. Пожалуйста, попробуйте перезагрузить Ваш компьютер и затем продолжить загрузку. С большой вероятностью IDM восстановит временные файлы. Если это не помогает, пожалуйста, найдите журнал загрузки и отправьте его нам для анализа.

В. Попытка IDM объединить временные куски вызывает ошибку распределения памяти. Что мне делать?

Пожалуйста, обновите программу до последней версии. Пожалуйста, попробуйте перезагрузить Ваш компьютер и затем продолжить загрузку. После этого с большой вероятностью IDM восстановит временные файлы.

ВОПРОСЫ НАСТРОЙКИ

 В. Я указал папку, куда помещать загруженные файлы, но IDM тем не менее кладет их в другую папку. Что я делаю неправильно?

Пожалуйста, примите к сведению, что IDM имеет категории для организации Вашей загрузки. Каждая категория имеет свой собственный путь загрузки. Вы должны указать путь для каждой категории. Воспользуйтесь диалогом "Опции->Загрузка" и выберите категорию в выпадающем меню. Если Вы не хотите использовать категории, просто удалите их - нажмите правой кнопкой мыши на имени категории в основном окне IDM и выберите "Удалить" в выпадающем меню.

В. Я не знаю какой файл указывать для моего антивируса в диалоге "Опции->Загрузка".

Обычно, Вы должны указывать тот же исполняемый файл, который используется, когда Вы запускаете свой антивирусный сканнер из меню "Кнопка "Пуск"->Программы". Правой кнопкой мыши нажмите на ярлык в меню и выберите в выпадающем меню "Свойства". Затем обратите внимание какой исполняемый файл указан в поле "Объект".Откройте диалог "Опции IDM->Загрузка". Вам необходимо прописать полный путь к исполняемому файлу Вашего антивирусного сканера в поле "Антивирусная программа" в диалоге "Опции->Загрузка". Потом введите опции командной строки в поле ниже. Замените имя файла в командной сроке параметром "[File]". К примеру, для Norton Antivirus Вы должны ввести “C:\Program Files\Norton AntiVirus\NAVW32.EXE” в поле "Антивирусная программа" и “[File] /s” в "Параметры командной строки".

ОБЩИЕ ВОПРОСЫ

 В. У меня проблемы с удалением программы. Что мне делать?

Более 200,000 зарегистрированных пользователей наслаждаются использование IDM! Пожалуйста, ознакомьтесь с мнениями пользователей. Если Вы все еще хотите удалить IDM, обратитесь к документации Windows для ознакомления с информацией по удалению программ. Обычно нужно запустить "Установку и удаление программ" из "Панели управления". Удаление на 100% работоспособно. Если у Вас возникли проблемы с удалением ранних версий IDM, загрузите и запустите эту программу для удаления интеграции в браузеры. После чего просто удалите папку IDM.

В. Мой Internet Download Manager после обновления версии (или после покупки полнофункциональной версии) не может соединиться с сетью Интернет, и я не могу ничего загрузить. Я получаю следующие сообщения: "Предложенное имя сервера существует, но не содержит доступных корректно связанных данных (сам хост существует, но прямого доступа к нему нет)", "Сервер не найден" или "Не удалось соединиться с сервером".

Пожалуйста, проверьте, активно ли Ваше сетевое подключение. Такая проблема также может возникнуть, если на Вашем компьютере установлен файервол. После обновления или установки новой версии, размер исполняемого файла IDM меняется. Большинство файерволов проверяет размеры файлов интернет-приложений, так как троянская программа может заменить приложение и получить доступ в Интернет. Вероятно, когда Вы обновляли IDM, размер его исполняемого файла изменился и Ваш файервол заблокировал Internet Download Manager.
Если у Вас установлен файервол, убедитесь, что IDM имеет соответствующие права доступа в Интернет.
Если у Вас установлен Norton Internet Security, пожалуйста, постарайтесь удалить правило для IDM из NIS (Norton Internet Security) полностью. Много пользователей имело проблемы с имеющимся правилом. Вы должны выбрать вкладку Personal Firewall, затем перейти на Internet Access Control, найти Internet Download Manager и удалить это правило. Когда IDM попытается загрузить файл, NIS снова задаст вопрос, на который Вы должны ответить утвердительно.

В. У меня конфликтуют IDM и Google Search Desktop. Что мне сделать, чтобы установить и запускать одновременно IDM и Google Search Desktop.

Спасибо за то, что сообщили о проблеме. Мы уже изучили эту проблему и выяснили, что она явилась причиной ошибки в программном обеспечении Google. По некоторым причинам, все прочие приложения, использующие технологию Service Provide Interface, объявляются как конфликтующие и отказываются устанавливаться. Фактически, IDM не имеет никаких конфликтов с Google Search Desktop. И Вы легко можете это проверить.
Чтобы установить Google Search Desktop, пожалуйста, отключите расширенную интеграцию в браузеры в "Опции IDM->Общее", затем установите Google Search Desktop и снова включите расширенную интеграцию. При каждом запуске Google Search Desktop будет выводить сообщение о конфликте с IDM, однако работать будет без каких-либо проблем. Примите во внимание факт, что Google Search Desktop - бета-версия, и множество ошибок еще необходимо будет выявить. Команда Google обещала нам устранить этот конфликт в одном из будущих выпусков Google Search Desktop. Мы уже связались с Google по поводу этой проблемы и получили ответ, что "заплатка" для Internet Download Manager будет доступна в очень скором времени. Вы, также, можете самостоятельно связаться с Google, для решения этой проблемы.

В. После того, как я установил IDM, я не могу выйти в Интернет, или некоторые из моих интернет-приложений не работают должным образом.

Расширенная интеграция в браузеры может конфликтовать с другими интернет-приложениями на Вашем компьютере. Вам нужно попробовать отключить опцию "Использовать расширенную интеграцию в браузеры" в диалоге "Опции->Общее". Это вернет базовую интеграцию в браузеры из версии 3.хх, которая не должна вызывать никаких конфликтов. Пожалуйста, воспользуйтесь пунктом меню "Справка->Быстрое Обновление" для получения последней версий.

В. Мой Антивирус/Антишпион сообщает, что файл IDM idmmkb.dll прислушивается к нажатия клавиш на клавиатуре и может являться угрозой для моего компьютера. Пожалуйста, разъясните эту ситуацию.

Этот файл проверяет только состояние клавиш ALT и CTRL, нажаты они или нет. ОС Windows доводит информацию о состоянии клавиш только до активных windows-процессов, но IDM необходимо знать состояние клавиш независимо от этого. Именно по этой причине стало необходимым встроить этот dll в цепь сообщений. И это - единственная цель. Если у Вас достаточно знаний, Вы можете дизасемблировать этот dll и лично убедиться в истинности этого утверждения.

В. Microsoft Antispyware говорит, что IDM добавил новый Winsocks LSP (layered service provider) 'idmmbc.dll', который просматривает данные сети и может оказаться шпионским модулем. Idmmbc.dll является шпионским модулем?

Microsoft Antispyware находится в стадии бета-тестиррования и еще не различает плохие и хорошие LSP. Он говорит то же самое для всех LSP прочих установщиков программ, например для Google Search Desktop или ZoneAlarm Security Suite.
Idmmbc.dll связан с расширенной интеграцией в браузеры. Это функция Internet Download Manager, не доступная в других менеджерах загрузки. Этот dll прослушивает запросы загрузки от любого, выбранного Вами приложения. Как только он отслеживает запрос, то сразу перехватывает загрузку. Этим путем IDM перехватывает почти 100% ссылок от любого браузера и почти любого интернет-приложения. Вы можете указать от каких приложений IDM следует перехватывать ссылки на вкладке "Опции->Общее".
Idmmbc.dll - системная служба, перехватывающая попытки загрузки, и перенаправляющая их к IDM для дальнейшей загрузки. Это - обычная задача, выполняемая менеджерами загрузки. Idmmbc.dll не включает в себя никакого злонамеренного программного кода, и не выполняет никаких троянских функций. Этот dll не имеет никакого отношения к Вирусам, Trojan-, Spyware-, Adware-модулям и прочему. Вы можете проверить истинность этого утверждения, любым антишпионским инструментом, включая полное системное сканирование Microsoft Antispyware.
Эта функция может быть отключена в Опциях IDM. Вам необходимо будет перезагрузить Ваш компьютер, чтобы удалить LSP из цепи. Вы ни в коем случае не должны удалять этот файл вручную, пока данная функция включена, так как цепь будет разорвана и все интернет-приложения могут прекратить работу. Для удаления этого dll всегда используйте переключатель на вкладке "Опции IDM->Общее".
Единственный риск использования этой функции в том, что ее применение может вызвать конфликты с malware LSP от сторонних продавцов программного обеспечения, которые не могут корректно работать в цепочке LSP. Они также воспрепятствуют выстраиванию иерархии в цепи и не смогут правильно рассортировать LSP. Заметьте, что Вы можете отключить расширенную интеграцию в браузеры впоследствии, когда Вы столкнетесь с проблемой или избавиться от конфликта с LSP.
Если Вы используете главным образом Internet Explorer, Вы не нуждаетесь в расширенной интеграции в браузеры. Базовая интеграция для Internet Explorer все равно имеет расширенные функции.

В. Я отправил e-mail, но Вы не ответили. Почему?

Вы (Ваш провайдер) имеет неправильно сконфигурированный фильтрующий почту антиспамерный модуль, вследствие чего блокируются наши ответы Вам. Пожалуйста, проверьте параметры настройки Вашего фильтра, или свяжитесь с Вашим провайдером, или попробуйте связаться с нами с другого почтового ящика.

В. Я хочу предложить новую опцию. Как мне отправить предложение?

Пожалуйста, напишите по электронной почте на support@internetdownloadmanager.com или воспользуйтесь нашей интерактивной формой.

В. Я обнаружил ошибку. Как мне сообщить о ней?

Пожалуйста, напишите по электронной почте на support@internetdownloadmanager.com

Мы хотели бы услышать Ваши вопросы/комментарии/предложения. Пишите по электронной почте на support@internetdownloadmanager.com или воспользуйтесь нашей интерактивной формой!


Динамическая Сегментация и Эффективность
Особенности IDM:
  • Динамическая сегментация файла, которая использует правило деления на две части
  • Многократное использование соединений, закончивших загрузку своих частей файла без дополнительных стадий входа в систему
  • Настраиваемое время таймаута и количество подключений для настройки IDM под ваш тип соединения
Динамическая сегментация файла и многократное использование соединений
Internet Download Manager имеет оптимизированную логику загрузки. IDM делит загружаемый файл на части динамически, в отличие от других акселераторов загрузки, которые делят загружаемый файл на части один раз, перед запуском процесса загрузки. Динамическая сегментация дает существенное ускорение процесса загрузки. Когда начинается загрузка файла, неизвестно, сколько соединений может быть создано. Когда становится доступно новое соединение, IDM находит наибольшую загружаемую часть файла и разделяет ее пополам. Таким образом, новое соединение начинает загружать файл с середины наибольшей части файла. IDM минимизирует время, необходимое для диалога с сервером и заставляет работать все соединения.
На диаграмме состояния розовые линии обозначают начальные точки загрузки, синие полосы - загруженные участки, белые полосы - незагруженные участки файла.
Когда соединение закончило загрузку одной части файла (когда синяя полоса доходит до розовой линии), и если следующее соединение еще не начало загрузку своей части, IDM переназначает эту часть первому соединению. Если следующее соединение уже начало загрузку своей части, первое соединение помогает другим медленно работающим соединениям, разделяя наибольшую часть пополам. IDM не сможет разделить часть пополам, только если ее размер является слишком маленьким для данного типа соединения.
Когда все части файла загружены, IDM объединяет их в единый файл.
IDM сохраняет все части файла несколько раз в минуту. Таким образом, после того, как Вы остановили загрузку или даже после неожиданного отключения электроэнергии, IDM возобновит загрузку и соберет итоговый файл правильно.
Розовые линии на диаграмме - новые начальные точки после возобновления загрузки.


Регистрация

Обратите внимание, что Вы должны прекратить использование демонстрационной версии программы по истечении 30 дней. Если Вы хотите продолжить использование IDM, Вы должны зарегистрироваться, чтобы получить полнофункциональную версию IDM.

После регистрации Вы получите:

  • Дополнительные возможности, не доступные в демонстрационной версии (см. ниже)
  • Лицензия для использования в любых целях Internet Download Manager на одном компьютере
  • Приоритет при технической поддержке
  • БЕСПЛАТНОЕ получение всех обновлений IDM в течение одного года после регистрации
  • Вы поддержите развитие IDM, чтобы сделать его еще лучше

После регистрации будут доступны дополнительные возможности (не доступные в демонстрационной версии):

  • Никаких ограничений на использование программы
  • Управление паролями сайтов
  • Наличие кнопки "Очистить"
  • Лучшее использование доступной полосы пропускания
  • Встроенный оптимизатор логики загрузки

Загрузите полнофункциональную версию IDM, заказав ее онлайн, используя защищенную форму. Вся необходимая информация будет отправлена немедленно после оплаты.

Домашняя страница программы: http://www.internetdownloadmanager.com
Страница регистрации/покупки: http://www.internetdownloadmanager.com/purchase.html


Основной Диалог

Основное окно программы
Основное окно показывает список загружаемых файлов. Этот список содержит дополнительную информацию о загружаемых файлах, такую как состояние загрузки, расчетное время до завершения, текущую скорость и описание загрузки. Вы можете отсортировать список по любому столбцу, нажав на заголовок столбца.
Кнопки управления загрузкой (Добавить, Старт, Стоп, Стоп Всем, Удалить, Очистить, Опции, Очередь, Запуск, Остановка, Поведать) расположены над списком. Они могут быть как в активном, так и в неактивном состоянии в зависимости от того, какие действия возможны для текущей загрузки.
Нажмите кнопку Поведать для отправки письма об Internet Download Manager вашим друзьям!
Вы можете добавить новый файл для загрузки, нажав кнопку Добавить. Вы можете ввести новый URL или выбрать URL из существующего списка. Вы также можете ввести информацию о входе в систему, если сервер требует авторизацию, включив опцию "Использовать авторизацию".
Если URL введен корректно, появится диалог свойств загрузки, где Вы сможете добавить описание к файлу и выбрать путь, куда файл будет сохранен. Вы также можете добавить описание файла позже. В нижней части диалога свойств загрузки имеются три кнопки. Если Вы хотите отменить загрузку, нажмите кнопку Отмена.
Если Вы хотите начать загрузку немедленно, нажмите кнопку Начать Загрузку. Появится диалог загрузки файла. Этот диалог предоставляет Вам дополнительные средства управления загрузкой. Он показывает среднюю скорость загрузки, расчетное время до завершения, текущее состояние загрузки, поддерживается ли докачка сервером, и т.д. Диалог также содержит диаграмму, отображающую состояние загрузки каждого отдельного сегмента файла.
Вы можете нажать кнопку Загрузить Позже, чтобы отложить загрузку, или Отмена, чтобы отменить загрузку и закрыть диалог. Вы можете возобновить загрузку в любое время. Обратите внимание, что кнопка Старт запускает загрузку с последней сохраненной позиции, только если удаленный сервер поддерживает эту функцию.
Кнопка Стоп останавливает загрузку выделенных файлов. Вы можете также остановить загрузку, нажав кнопку Отмена в диалоге загрузки файла или просто закрыв диалог. Кнопка Стоп Всем останавливает загрузку всех файлов.
Кнопка Удалить удаляет выбранные файлы из списка загрузки. Это допустимо только для завершенных или приостановленных загрузок. Если загрузка файла еще не завершена, IDM запросит подтверждение на удаление загрузки из списка.
Кнопка Очистить (доступная только в зарегистрированной версии) очищает список от уже загруженных файлов.
Кнопка Очередь запускает диалог Планировщика, где Вы можете установить таймер для запуска загрузок. Столбец О (от «Очередь») показывает, находится ли файл в очереди загрузки. Вы можете добавить или удалить файл из очереди, нажав правой кнопкой мыши на имени файла и выбрав пункт меню "Добавить в очередь загрузки" или "Удалить из очереди загрузки". Вы можете запустить очередь Планировшика нажав кнопку Запуск. Вы можете остановить очередь, нажав кнопку Остановка. Если Вы нажмете кнопку Стоп Всем, то активная загрузка будет остановлена, но Планировщик вскоре снова начнет загрузку, если Вы не нажмете кнопку Остановка.
Все основные элементы управления также доступны в меню "Файл" и в контекстном меню по нажатию правой кнопки мыши на файле в списке загрузки.
Вы можете выбрать пункт "Свойства" в контекстном меню для просмотра/редактирования свойств выбранного файла. Вы можете изменить путь сохранения файла, добавить к нему описание, изменить URL загрузки или информацию по идентификации на сервере (логин и пароль).
Категории
В левой части основного окна расположено дерево категорий загрузки. Internet Download Manager предлагает использовать категории для сортировки и управления Вашими файлами. Если Вы не нуждаетесь в этом, Вы можете просто закрыть окно "Категории" и не выбирать никаких категории при загрузке файлов. Каждая категория загрузки имеет название, заданную по умолчанию папку загрузки и список связанных с ней типов файлов. IDM имеет несколько предустановленных категорий, таких как "Музыка", "Видео", "Программы", "Документы" и пр. Вы можете удалять их, редактировать или добавлять свои собственные категории.
Нажав правой кнопкой мыши на категории, Вы увидите меню, благодаря которому Вы сможете добавить новую категорию или редактировать или удалить существующую. При добавлении категории, Вы сможете выбрать расширения файлов, которые будут связаны с данной категорией, а также, заданную по умолчанию папку загрузки, для хранения файлов связанных с этой категорией.
Например, категория "Documents" могла бы иметь следующие расширения: "doc pdf xls txt", и заданную по умолчанию папку загрузки "C:\Downloads\Documents".
При загрузке или сохранении файлов с расширениями, перечисленными в списке, IDM сам предложит нужную категорию и папку загрузки. Если Вы отключите отображение диалога сохранения файла в настройках IDM, папка загрузки будет определяться автоматически.


Внешний Вид IDM

Настройка отображения главного окна IDM
Internet Download Manager имеет опции по настройке столбцов и отображению Панели инструментов.
Стандартная версия Internet Download Manager 4 встроенных варианта Панели инструментов: Большие объемные кнопки, Маленькие объемные кнопки, Большие классические кнопки и Маленькие классические конки. Вы можете выбрать понравившийся Вам вид Панели инструментов из вышеперечисленного или загрузить другие варианты с официального сайта программы. Если Вы знакомы с основами графического дизайна, Вы можете нарисовать собственный вариант Панели инструментов для своего Internet Download Manager.
Для настройки отображения Панели инструментов IDM, пожалуйста, нажмите правой кнопкой мыши на Панель инструментов и выберите необходимые опции в появившемся меню (смотрите ниже).
Вы можете выбрать стиль Панели инструментов и размер кнопок из вариантов, доступных в этом меню. Если Вам необходимо загрузить новый вариант Панели инструментов для Internet Download Manager, пожалуйста, выберите пункт меню "Узнать, что нового".
Для настройки кнопок панели, пожалуйста, выберите пункт меню "Выбор...".
При помощи этого диалога Вы можете выбрать, какие кнопки и в каком порядке должны находиться на Панели инструментов. Левая область окна показывает список доступных кнопок. Правая область окна показывает список кнопок на Панели инструментов IDM. Вы можете изменять порядок отображения кнопок в этом списке, нажимая Вверх или Вниз. Вы можете добавить или удалить кнопки, нажимая Добавить или Удалить.
Для настройки столбцов в главном окне IDM, нажмите правой кнопкой мыши на заголовок столбца.
Вы можете выбрать, какие столбцы должны быть видны, их ширину и порядок отображения. Для отображения столбца Вы должны поставить галочку напротив необходимого столбца. Вы можете поменять местоположение столбца, нажимая Вверх или Вниз. Вы также можете поменять порядок отображения столбцов путем перетаскивания заголовка столбца на необходимое место в главном окне IDM.


Начало Загрузки

Начало Загрузки с помощью IDM
Есть несколько способов начала загрузки с помощью Internet Download Manager.
  • Автоматический Режим. Этот метод самый простой. Если Вы нажимаете на загрузочной ссылке в Internet Explorer или в другом браузере, IDM перехватит и ускорит эту загрузку
  • Правая Кнопка Мыши в Internet Explorer. Если Вы нажмете правой кнопкой мыши на ссылке в Internet Explorer, Вы увидите пункт меню "Download with IDM"
  • Перетаскивание Мышью. Вы можете перетаскивать ссылки для начала загрузки с помощью IDM
  • Кнопка "Добавить". Вы можете вручную ввести URL в IDM нажав кнопку Добавить
  • Ссылки из Буфера Обмена. IDM может перехватывать загрузочные ссылки из буфера обмена
  • Командная Строка. IDM может быть запущен из командной строки
  • Импорт Ссылок. IDM может импортировать загрузочные ссылки из файла


Автоматический Режим

Загрузки с помощью IDM в автоматическом режиме.

Этот метод запуска загрузки самый простой. IDM перехватывает загрузки из браузеров Internet Explorer, MSN Explorer, AOL, Opera, Mozilla и Netscape и автоматически загружает файлы, как только пользователь нажмет на загрузочную ссылку.

Если Вы нажимаете на загрузочной ссылке в Internet Explorer или в другом браузере, IDM перехватит и ускорит эту загрузку. В этом случае Вам не нужно делать ничего особенного, просто работать в Интернет, как Вы обычно это делаете. IDM перехватит загрузку из Internet Explorer, если тип загружаемого файла соответствует списку расширений в IDM. Список расширений файлов для загрузки при помощи IDM может быть отредактирован в диалоге "Опции->Общее". Если IDM перехватил загрузку, он покажет следующий диалог:

Диалог "Информации о загружаемом файле"
Если Вы нажмете кнопку Загрузить Позже, файл будет добавлен в список загрузки, но процесс загрузки не начнется. Если Вы нажмете кнопку Начать Загрузку, IDM начнет загрузку файла немедленно. IDM позволяет Вам сортировать ваши загрузки по категориям. IDM предлагает категорию и заданную по умолчанию папку для сохранения загруженного файла согласно его типу. Вы можете редактировать категории, удалять и добавлять новые категории в Основном окне IDM. Если Вы хотите увидеть содержимое ZIP-файла перед загрузкой, Вы можете нажать кнопку Предосмотр.

Если Вы будете удерживать клавишу CTRL при нажатии мышью на ссылке в Internet Explorer, IDM перехватит любую загрузку (для этого Вы должны включить опцию "Использовать CTRL для принудительной загрузки с помощью IDM" в диалоге "Опции->Общее").

Если Вы будете удерживать клавишу ALT при нажатии мышью на ссылке, IDM не будет перехватывать загрузку и позволит Internet Explorer загрузить этот файл (для этого Вы должны включить опцию "Использовать ALT для запрета загрузки ссылок с помощью IDM" в диалоге "Опции->Общее").

Если Вы не хотите, чтобы IDM перехватывал загрузку из браузера, выключите интеграцию в браузер в настройках IDM. После отключения интеграции в диалоге "Опции->Общее" не забудьте перезапустить браузер.

Запомните, что если у Internet Download Manager возникли проблемы с загрузкой файла, Вы должны удерживать ALT при нажатии кнопкой мыши на ссылке, чтобы позволить браузеру самому загрузить файл.


Правая кнопка мыши в IE

Интеграция IDM в меню IE по нажатию правой кнопки мыши.
1. Загрузка специфических ссылок или всех ссылок из выделенного текста на веб-страницы.
Если Вы нажмете правой кнопкой мыши на ссылке в Internet Explorer, Вы увидите пункт меню Download with IDM . Просто нажмите на нем для начал загрузки ссылки с помощью IDM. Вы также можете выделить текст в Internet Explorer и выбрать Download with IDM , чтобы добавить все ссылки из выделенного текста в IDM.
Эта возможность загрузки файлов полезна, когда IDM не может начать загрузку автоматически.
2. Загрузка нескольких файлов с веб-страницы.
Вы можете загрузить несколько файлов с веб-страницы. IDM может импортировать все, или только выбранные ссылки с веб-страницы в основной список загрузки. Просто нажмите правой кнопкой мыши на веб-странице и выберите в выпадающем меню пункт Download All Links with IDM . Смотрите ниже.
После выбора пункта Download All Links with IDM в меню по нажатию в любом месте страницы, IDM выведет диалог импорта ссылок с этой страницы. Смотрите ниже.
Через некоторое время IDM запустит проверку ссылок для определения размера и типов файлов. Вы можете подождать, пока IDM закончит, и ознакомиться результатами проверки.
Отметьте галочками те файлы, которые Вы хотите загрузить с помощью IDM. Вы можете воспользоваться опцией Скрыть файлы HTML для отфильтровывания html-страниц, и кнопками Выбрать Все, Убрать Все для выделения или снятия выделения со всех ссылок списка. Смотрите ниже.
Вы можете выделить ссылку и нажать кнопку Правка для изменения места загрузки, описания, пути сохранения, имени файла и других атрибутов.
После выбора и редактирования ссылок, нажмите кнопку OK для передачи ссылок в основной список загрузок Internet Download Manager. IDM также автоматически добавит эти ссылки в очередь загрузки. Вы можете начать загрузку как выбранных ссылок с помощью нажатия кнопки Старт, так и всех ссылок выбрав пункт "Загрузка->Начать загрузку очереди" в главном меню.
Если Вы хотите какие-то файлы скачать раньше, Вы легко можете переместить импортированные ссылки вверх очереди. Нажмите кнопку Очередь, выберите необходимые ссылки, используя клавиши Ctrl или Shift и мышь, и переместите выбранные ссылки вверх, используя кнопку со стрелкой вверх.


Перетаскивание Мышью

Перетаскивание ссылок из Internet Explorer в основное окно IDM или загрузочную корзину.
Загрузочная корзина - это окно, принимающее гиперссылки из браузеров Internet Explorer, Netscape, Mozilla, AOL или Opera. Вы можете перетащить ссылку из своего браузера в это окно для начала загрузки с помощью IDM.
Вы также можете перетащить ссылку непосредственно в основное окно программы.
Если хотите скрыть данное окно, просто закройте его. Позже, если захотите, Вы сможете восстановить его снова, нажав в главном меню "Задачи->Показывать корзину".


Кнопка "Добавить"

Использование Кнопки "Добавить".
Вы можете вручную ввести URL в IDM, нажав кнопку Добавить.
Подробнее смотрите в разделе Основное окно программы.


Ссылки в Буфера Обмена

IDM следит за буфером обмена на предмет поиска "правильных" URL (веб-адресов).
IDM следит за буфером обмена на предмет поиска URL по специальным типам расширений. Как только веб-адреса попадают в буфер обмена, IDM отображает диалог начала загрузки.
Если Вы нажмете кнопку OK, IDM начнет загрузку. Вы можете также ввести информацию для авторизации в случае, если ее затребует сервер.


Запуск из Командной Строки

Запуск IDM из Командной строки
Вы можете запустить IDM из командной строки со следующими параметрами:
idman /s
или idman /d URL [/p локальный_путь] [/f локальное_имя_файла] [/q] [/h] [/n] [/a]
Параметры:
/d URL - загрузка файла
Пример IDMan.exe /d "http://www.internetdownloadmanager.com/path/File Name.zip"
/s - запуск очереди из Планировщика
/p локальный_путь - задание локального пути для сохранения файла
/f локальное_имя_файла - задание локального имени для сохранения файла
/q - IDM будет закрыт по завершении загрузки. Этот параметр работает только для первой копии
/h - IDM прервет ваше соединение по завершении загрузки
/n - переключение в "тихий" режим, когда IDM не задает ни каких вопросов
/a - передает файл, указанный в /d в очередь загрузки, но не начинает загрузку
Параметры /a, /h, /n, /q, /f локальное_имя_файла, /p локальный_путь работают только, если указанный файл загружен через /d URL
Примеры
C:\>idman.exe /n /d http://www.tonec.com/download/idman403.exe


Импорт Ссылок
Вы можете импортировать списки загрузки в Internet Download Manager. Нажмите "Адрес->Импорт->Из текстового файла" в основном меню IDM.
IDM обнаружит все адреса Интернет (URL) в предоставленном файле и отобразит их в виде списка. Вы можете удалять или редактировать эти ссылки перед импортированием их в Internet Download Manager.


Диалог "Свойства файла"
Диалог "Свойства файла" вызывается из контекстного меню по нажатию правой кнопки мыши, или двойным нажатием на нужном имени файла в списке загрузки. Этот диалог показывает информацию о файле, и позволять Вам изменить местоположение файла на жестком диске, его описание и адрес загрузки в Интернет. Вы можете открыть загруженный файл, нажав кнопку Открыть.


Опции

Диалог "Опции"
В диалоге "Опции" Вы можете настраивать все параметры IDM. Диалог имеет девять вкладок:
Общее
Типы Файлов
Соединение
Сохранение
Загрузка
Прокси
Пароли сайтов
Dial Up
Звуки

Вкладка "Общее"
Вкладка "Общее" может использоваться для изменения параметров интеграции IDM в систему: автоматический запуск, интеграция в браузеры, отслеживание попадающих в буфер обмена URL. IDM по умолчанию интегрируется в Internet Explorer, Opera, Mozilla, Netscape и множество других популярных браузеров.
IDM поддерживает базовый и расширенный тип интеграции в браузеры. При базовой интеграции в браузеры Вы можете проверить, какой тип интеграции использует конкретный браузер. Для этого выберите браузер и нажмите кнопку Детали. Добавить браузер для базовой интеграции Вы можете с помощью кнопки Добавить браузер. IDM определит версию браузера и произведет интеграцию в него.
IDM имеет специальный модуль (IEMonitor.exe) для отслеживания нажатий в браузерах на основе IE (MSN Explorer, Avant, MyIE, некоторые версии AOL, пр.), работающий отдельно от основного процесса IDM. Данный модуль может быть вкл./откл. с помощью опции "Отслеживать нажатия в браузерах на основе IE".
Расширенная интеграция в браузеры может быть применена для интеграции IDM в приложения использующие протоколы FTP или HTTP. Если у Вас возникли проблемы при использовании расширенной интеграции в браузеры, Вы можете отключить ее, перейдя к базовой интеграции.
Если Вам необходимо интегрировать IDM в новый браузер или какое-нибудь приложение, использующее протоколы загрузки HTTP или FTP, пожалуйста, включите опцию "Обнаруживать новые приложения". Тогда, когда Вы запустите это приложение и попробуете загрузить файл, имеющий расширение, соответствующее списку автоматической загрузки, IDM перехватит загрузку от этого приложения и добавит приложение к списку браузеров.
Настройка специальных клавиш позволит Вам установить различные клавиши для принудительной загрузки или предотвращения оной с помощью IDM. После нажатия кнопки Клавиши откроется диалог "Использование специальных клавиш". Вы можете выбрать комбинацию из одной или более клавиш, подходящих для Вашего браузера. Знайте, что IDM может быть интегрирован в Opera и СТАРЫЕ браузеры, основанные на Mozilla, с помощью плагинов. Но данная интеграция не поддерживает специальные клавиши принудительной загрузки или ее предотвращения. Если Вы хотите использовать данные специальные клавиши, воспользуйтесь расширенной интеграцией в браузеры.

Вкладка " Типы Файлов"
Вкладка "Типы Файлов" может использоваться для изменения списка типов файлов, которые будут перехвачены от браузера и загружены с помощью IDM.
Вы можете воспрепятствовать загрузке с помощью IDM с указанных сайтов. Если Вы не хотите, чтобы IDM перехватывал загрузку со специфического сайта, Вы можете добавить его в список "Не начинать автоматическую загрузку со следующих сайтов". Для замещения любого числа символов можно воспользоваться звездочкой .Например, *.tonec.com будет соответствовать ftp.tonec.com, www.tonec.com, www.games.tonec.com и т.д.
Вы, также, можете воспрепятствовать загрузке с помощью IDM с указанных веб-адресов. Вы можете добавить/удалить веб-адреса в "Списке исключаемых адресов", доступном по нажатию кнопки Редактировать список.

Вкладка "Соединение"
На вкладке "Соединение" Вы должны определить скорость вашего соединения с Интернет. Это необходимо для оптимального использования пропускной способности. Постарайтесь не устанавливать значение "Макс. количество потоков" больше, чем четыре. Большое количество потоков (частей файла) может ухудшить процесс передачи файла и привести к перегрузке использования ресурса на сервере, с которого Вы загружаете. Это может вызвать применение каких-либо ограничений или других защитных мер системными администраторами. С другой стороны, большее количество соединений может очень значительно увеличить скорость загрузки, если Вы используете кабельный модем или высокоскоростное подключение к Интернет.
Вы можете индивидуально установить число соединений (количество потоков загрузки) для серверов в таблице Исключений. Вам может потребоваться это для серверов, у которых установлен лимит соединений для одного клиента. Это также полезно для ftp-серверов, где разрешены только 1 или 2 одновременных соединения.
Если Вы хотите установить квоты на использование вашего соединения с Интернет, выберите опцию "Ограничения по загрузке". Это полезно для ссылок, которые имеют какую-либо специальную политику доступа (например, Direcway, Direct PC, Hughes, и т.д.). Скажем, Вы устанавливаете 40 Мб/час или не более 150 Мб каждые 4 часа, тогда IDM закачает указанный объем информации, приостановит закачку, и затем продолжит ее автоматически через некоторое время. Таким образом, Вы можете закачивать большие файлы с максимально возможной скоростью.

Вкладка "Сохранение"
"Сохранить в" помогает настроить папку сохранения по умолчанию для каждой категории. Вы также можете переопределить эту папку, выбрав элемент "Свойства" в контекстном меню по нажатию правой кнопки мыши в выбранной категории в основном окне IDM. Загруженные файлы будут сохранены в папке по умолчанию соответствующей категории. Но Вы можете изменить папку для сохранения файла перед загрузкой в диалоге Информация о загружаемом файле. Если опция "Запомнить последний сохраненный путь к категории" включена и Вы изменили папку в диалоге Информация о загружаемом файле, папка по умолчанию в "Сохранить в" будет изменена для всех последующих загрузок данной категории.
Папка для хранения временных файлов определяет путь, где будут храниться все временные файлы. Вы можете изменить путь к этой папке только в том случае, если в месте, определенном по умолчанию, недостаточно свободного места.

Вкладка "Загрузка"
В группе "Диалоги" Вы можете выбрать, как будут отображаться диалоги IDM. Выберите пункт "Не показывать" в списке "Прогресс загрузки", если Вы не хотите видеть диалог прогресса загрузки вообще. Если Вам не нравится диалог прогресса загрузки, появляющийся поверх всех остальных окон, выберите пункт "Минимизировать". Вы также можете отключить отображение диалогов начала и окончания загрузки.
Internet Download Manager также поддерживает тихий режим, когда все закачиваемые файлы автоматически сохраняются в папку по умолчанию. Если Вы не хотите видеть диалоги начала, окончания и прогресса загрузки, Вы можете отключить их. Для этого просто отключите опции "Показать диалог начала загрузки ", "Показать диалог конца загрузки" и выберите пункт "Не показывать" в списке "Прогресс загрузки".
IDM оптимизирован под скорость и начинает загружать файл еще во время демонстрации диалога "Информация о загружаемом файле". Таким образом, пока Вы размышляете, что указать в диалоге "Информация о загружаемом файле" в качестве места размещения файла после загрузки, файл может быть загружен частично или полностью. Если Вы используете Планировщик IDM, и хотите загрузить файл позже, или же просто хотите добавить его в очередь, Вам эта предварительная загрузка может быть не нужной. В этом случае Вам необходимо отключить опцию "Запускать загрузку немедленно, еще во время демонстрации диалога "Информация о загружаемом файле".
Иногда интернет-серверы ошибочно изменяют время последнего изменения файла с каждым запросом загрузки. В этом случае Планировщик IDM начнет загружать данный файл сначала. Чтобы избежать этого и корректно продолжить загрузку, необходимо включить опцию "При докачке игнорировать смену даты изменения файла".
Если Вы хотите выполнять проверку на вирусы по завершении загрузки, Вы должны указать полный путь к исполняемому файлу антивирусного сканера (см. рисунок). Если IDM знает необходимые параметры для данной программы, он укажет их автоматически. Иначе Вы должны указать их вручную в "Параметрах командной строки" согласно документации к антивирусной программе. Если параметры не установлены, IDM запустит антивирусный сканер, добавив в конец полный путь к загруженному файлу.

Вкладка "Прокси"
Вкладка "Прокси" используется для настройки используемых Вами прокси-серверов. Кнопка Взять из IE может использоваться для копирования параметров прокси-серверов из настроек Netscape Communicator или Internet Explorer. Опция "Использовать FTP в режиме PASV" включает или отключает использование пассивного режима для протокола FTP. Вы должны включить эту опцию при использовании файервола или прокси-сервера. Вы можете также указать информацию для входа в систему, если ваш прокси-сервер требует авторизации.
Вы можете указать адреса Интернет, для которых IDM не будет использовать прокси-сервера. Вы можете использовать звездочку, соответствующую любому количеству символов. Например, *.tonec.com будет соответствовать ftp.tonec.com, www.tonec.com, www.games.tonec.com, и т.д.

Вкладка "Пароли Сайтов"
Вкладка "Пароли сайтов" (доступная только в зарегистрированной версии) используется для создания списка логинов и паролей для сайтов, требующих авторизации. Вы можете добавить различные логины и пароли для различных каталогов одного и того же сайта. Нажмите кнопку Новый, чтобы добавить новый URL и информацию о логине/пароле.

Вкладка "Dial Up"
Если используется стандартная служба дозвона Windows, IDM может перебирать записи Вашей телефонной книги для подключения к Интернет. В списке Вы можете выбрать соединение, которое будет использовать IDM. Если Ваш компьютер подключен к Интернет, то IDM выберет это соединение по умолчанию. В противном случае IDM выберет последнее использованное соединение. Если Вы запустили IDM в первый раз, IDM выберет первую запись Вашей телефонной книги.
После выбора соединения, Вы можете изменить логин и пароль. Можно сохранить логин и пароль в телефонной книге, нажав кнопку Применить. Выберите опцию "Сохранить пароль", если Вы не хотите вводить пароль каждый раз в начале дозвона. Вы можете также установить количество попыток набора номера (0 - бесконечно) и интервала времени между ними. Нажмите кнопку OK, чтобы сохранить изменения или Отмена, чтобы отказаться от них.

Вкладка "Звуки"
IDM может воспроизводить различные звуки для различных событий загрузки. На этой вкладке Вы можете выбрать звуковые файлы и определить события.
Совет: Вы можете использовать стандартные звуки Windows, сохраненные в папке Windows/Media. Чтобы установить звук, выберите событие, нажмите кнопку Обзор, выберите файл и затем отметьте событие галочкой. Вы можете прослушать выбранный звук, используя кнопку Тест.


Планировщик
IDM может поставить загружаемые файлы в очередь и распланировать их загрузку. Вы можете нажать кнопку Очередь или пункт меню "Загрузка->Планировщик", чтобы открыть окно планировщика.
IDM автоматически ставит загружаемые файлы в очередь при добавлении новых URL в список. Как только файл загружен, он удаляется из очереди. Столбец "О" (от «Очередь») в основном окне программы показывает, находится ли файл в очереди загрузки. Вы можете добавить или удалить файл из очереди, нажав правой кнопкой мыши на имени файла и выбрав "Добавить в очередь загрузки" или "Удалить из очереди загрузки". Вы можете изменить порядок загрузки, используя кнопки со стрелками. Вы можете также удалить ссылки из очереди с помощью кнопки с крестом. Позже Вы можете добавить файл обратно в очередь в основном окне, нажав правой кнопкой мыши на имени файла и выбрав "Добавить в очередь загрузки". Вы также можете установить количество одновременно закачиваемых файлов. Обычно оптимальное количество составляет 4-5 файлов.
При запуске очереди загрузки, IDM пытается загрузить выбранное количество файлов. Диалог окончания загрузки, сообщения об ошибках и предупреждения не отображаются, если процесс загрузки был инициирован Планировщиком. Каждые 30 секунд IDM проверяет состояние поставленных в очередь файлов. Если файл был загружен успешно, он удаляется из очереди, в противном случае он помещается в конец очереди.
Вы можете инициировать запуск очереди вручную, нажав кнопку Запустить или выбрав пункт меню "Загрузка->Начать загрузку очереди". Вы можете также задать время начала и завершения загрузки очереди. Чтобы отключить модем по завершении загрузки очереди, выберите опцию "Отключить модем от сети по завершении". Если Вы используете опцию "Выключить компьютер по завершении", по завершении очереди, компьютер будет выключен. Используйте опцию "Завершить все программы" с осторожностью, так как это может привести к потере данных в других приложениях. Вы можете остановить очередь, нажав кнопку Остановить в окне Планировщика или выбрав пункт в главном меню "Загрузка->Остановить загрузку очереди".
Если Вы хотите установить квоты на использование вашего соединения с Интернет, выберите опцию "Ограничения по загрузке". Это полезно для интернет-соединений, которые имеют какую-либо политику доступа (например, Direcway, Direct PC, Hughes, и пр.). Скажем, Вы устанавливаете 40 Мб/час или не более 150 Мб каждые 4 часа, тогда IDM загрузит максимум от этого, приостановит загрузку и, затем продолжит ее автоматически через некоторое время. Таким образом, Вы можете загружать большие файлы с максимально возможной скоростью.


Download Complete Dialog

Диалог "Загрузка завершена"
По окончании загрузки, IDM выводит диалог "Загрузка завершена". Вы можете выбрать несколько путей открытия загруженного файла.
Вы можете отказаться от показа данного диалога, выбрав опцию "Больше не показывать этот диалог". Позже Вы сможете изменить свой выбор на вкладке "Опции->Загрузка".
Начиная с версии 5.05 build 2 в этот диалог включена иконка "drag & drop" для запуска процесса по перетаскиванию загруженного файла. Иногда очень удобно без непосредственного открытия файла перетащить его из IDM в другую программу.
Например, если Вы слушаете музыку с помощью программы Winamp, и для того, чтобы прослушать mp3, откроете файл кнопкой "Открыть", это приведет к очистке текущего плейлиста с заменой его единственным файлом. Но если Вы перетащите файл в плеер, то он будет добавлен в текущий плейлист.


Диалог "О программе"
Диалог "О программе" отображает подробную информацию о версии программы. Отсюда Вы можете отправить письмо в службу поддержки IDM, посетить домашнюю страницу программы, запустить процесс регистрации или проверить доступность новой версии IDM.


Диалог "Регистрация"
Этот диалог используется для регистрации вашей копии Internet Download Manager. Вы можете подробно узнать, как это делается, на странице регистрации программы.


Быстрое Обновление
IDM раз в неделю проверяет наличие обновленной версии на сайте и предлагает обновить программу, как только становится доступна новая версия.
Диалог "Быстрое обновление" предлагает обновить программу, показывая усовершенствования новой версии и дату ее выпуска. Вы можете также проверить наличие более обновленной версии, выбрав пункт меню "Справка->Быстрое Обновление".