О программе SuperCopy 2.0

SuperCopy 2.1

Назначение и основные функции

Программа предназначена для копирования файлов с поврежденных носителей информации. В процессе копирования, повреждённые участки заменяются нулями, не изменяя при этом размер и структуру копируемого файла. Например, программу можно использовать для копирования фильмов или музыки с "битых" компакт-дисков. На воспроизведении фильма или музыки это почти никак не отразится. Возможно, вы потеряете несколько cекунд видео или звука. Программа позволяет скопировать фильм, даже с дырявого компакт-диска, разумеется с частичной потерей кадров.

Меню

С помощью меню "Файл" осуществляется выбор файлов: для копирования и сохранения. После выбора файла для копирования, файл для сохранения автоматически будет назван именем исходного файла с перфиксом "_Fix", и сохранен директории программы. Изменить имя и путь файла для сохранения можно используя пункт меню "Выбрать файл для сохранения".

С помощью меню "Копирование" начинается и прерывается процесс копирования. Если в момент копирования нажать на единственный пункт меню "Начать / Остановить", то процесс копирования будет прерван.

С помощью меню "Настройка" осуществляется настройка параметров работы программы. В программе SuperCopy 2.1 предусмотрена возможность обхода ошибок несколькими методами. Подробно об этом ниже.

С помощью меню "Справка" вы можете узнать о программе, её разработчике, версии, а также посетить сайт, посмотреть обновления.

Настройка параметров программы

Программа SuperCopy 2.1 может осуществлять процесс копирования несколькими методами. Каким из них воспользоваться, зависит от конкретной ситуации. Вы можете задать область чтения (файл целиком или до первой ошибки). Также можно задать и направление чтения файла. Если поставить флажек "Читать со старших адресов", чтение блока начнется не с начала а с конца, что существенно замедлит процесс чтения файлов, но сократит количество ошибок. Если поставить флажек "Прерывать чтение через ... сек.", программа будет следить извне за процессом чтения и прерывать его через заданное количество времени. Это очень полезная функция т.к. некоторые драйвера устройств очень долго обрабатывают ошибки. Т.е. когда программа долгое время пытается безуспешно прочитать один и тот же участок, процесс чтения пренудительно будет прерван, через установленное вами время. Если же этого не происходит, не прерывая процесс копирования необходимо вынуть носитель информации из устройства чтения и после появления сообщения, вставить его обратно.

Методы копирования

Метод чтения файла целиком в прямом направлении. Файл условно делится на блоки. Блоки читаются только последовательно в прямом направлении и все без исключиния. Чтение в блоке происходит до появления первой ошибки. Например, такой метод подходит для чтения маленьких файлов или для подробного анализа повреждений.

Метод чтения файла целиком в обратном направлении. Файл условно делится на блоки. Блоки читаются только последовательно в обратном направлении и все без исключиния. Чтение в блоке происходит до появления первой ошибки. Например, такой метод подходит для чтения маленьких файлов или для подробного анализа повреждений. Если установлен флажек "Обратное чтение при чтении назад", чтение блока идет задом наперед т.е. от больших адресов к меньшим. Это позволяет сократить количество ошибок.

Метод чтения файла целиком сначала в прямом, затем в обратном направлении. Файл условно делится на блоки. Блоки читаются только последовательно в прямом направлении и все без исключиния, затем те блоки, которые неудалось прочитать при чтении вперед, программа попытается прочитать чтением назад. Флажек "Читать со старших адресов" должен быть установлен. Такой метод подходит для чтения маленьких файлов или при незначительных повреждениях носителя.

Метод чтения файла до появления первой ошибки в прямом направлении. Файл условно делится на блоки. Блоки читаются только последовательно в прямом направлении до появления первой ошибке в блоке. Такой метод подходит для чтения сильно поврежденных носителей.

Метод чтения файла до появления первой ошибки в обратном направлении. Файл условно делится на блоки. Блоки читаются только последовательно в обратном направлении до появления первой ошибке в блоке. Если установлен флажек "Читать со старших адресов", чтение блока идет задом наперед т.е. от больших адресов к меньшим. Это позволяет сократить количество ошибок. Такой метод подходит для чтения сильно поврежденных носителей.

Метод чтения файла в прямом, затем в обратном направлении до появления первой ошибки. Файл условно делится на блоки. Блоки читаются последовательно, до появления первой ошибки в прямом направлении, затем до появления первой ошибки в обратном. Флажек "Обратное чтение при чтении назад" должен быть установлен. Такой метод подходит для чтения сильно поврежденных носителей.

Пример

На рисунке изображен компакт-диск c фильмом "Осень в Нью-Йорке", который просверлен насквозь сверлом 8мм. Читая файл с помощью программы SuperCopy 2.1, до появления первой ошибки сначала в прямом, затем в обратном направлении, удалось прочитать его за 20мин, потеряв при этом ~25мин. видео. Флажек "Читать со старших адресов" установлен не был. Флажек "Прерывать чтение" был установлен, а время прерывания составляло 30сек.

Прошу вас сообщать мне о работе программы, об ошибках и удачной работе; о том, как улучшить программу, что добавить и т.д. Помните, хороший продукт создаётся благодаря отзывам пользователей.

Хирург