Тренинго-тестирующая система

Тренинго-тестирующая система. Версия 2.0

I. Назначение ТТС

Тренинго-тестирующая система (далее ТТС) предназначена для обучения, а также закрепления и контроля знаний по курсу "Введение в правовую информатику. СПС КонсультантПлюс".


II. Типы тестовых заданий

ТТС содержит более 200 тестовых заданий следующих типов:

  • Задания на выбор правильного ответа из предложенного списка. Включают в себя одновариантные и многовариантные (фасетные) задания;
  • Задания на установление последовательности;
  • Задания на выбор соответствий.


III. Режимы работы в ТТС

В ТТС предусмотрены два режима работы с тестовыми заданиями: режим "Самоподготовка" (тренинг) и режим "Тестирование" (контроль знаний).

При входе в систему открывается окно Главного меню. Для начала работы с системой пользователю необходимо в поле "Представьтесь, пожалуйста" ввести имя, под которым впоследствии будут сохранены результаты данного сеанса работы с системой. Имя следует вводить только латинскими буквами без пробелов и без использования специальных символов (допускается использовать подчеркивание). Если имя введено с учетом описанных правил, то кнопки перехода к режимам "Самоподготовка" и "Тестирование" становятся активными, и при нажатии на одну из этих кнопок происходит переход в соответствующий режим. Если имя не было введено или введено недопустимым образом (например, с пробелами), то кнопки перехода к режимам остаются неактивными и дальнейшая работа с системой невозможна до момента, пока имя не будет введено правильным образом.

Выход из системы может быть осуществлен в любой момент работы. Для этого необходимо закрыть окно системы с помощью символа [image] в правом верхнем углу окна, после этого система запрашивает подтверждения или отмены данного действия. При положительном ответе на запрос система закрывается, при отрицательном ответе с системой никаких изменений не происходит.


IV. Режим "Самоподготовка"

IV.1. Назначение режима "Самоподготовка" (переход к тексту)

Режим "Самоподготовка" предназначен для самостоятельного изучения материала и проверки собственных знаний.

При входе в режим открывается окно настроек. В этом окне можно самостоятельно из общего банка заданий формировать группы тестовых заданий, отмечая щелчком мыши требуемые параметры режима. Настройка режима осуществляется по следующим параметрам:

  • Порядок заданий: "последовательный" или "случайный";
  • Уровни сложности: "простой", "средний" и "сложный";
  • Разделы заданий (в соответствии с главами курса).

IV.2. Выбор порядка заданий

При выборе в окне "Настройки режима самоподготовки" последовательного порядка заданий, задания во время сеанса работы будут предлагаться в порядке изложения материала в соответствующих разделах курса "Введение в правовую информатику", с учетом выбранных разделов и уровней сложности. Последовательный порядок предлагается по умолчанию.

При выборе случайного порядка заданий в режиме "Самоподготовка" задания будут предлагаться в порядке, не зависящем от последовательности изложения материала курса. В то же время, порядок заданий зависит от уровня сложности: сначала предлагаются задания наименьшего из выбранных для сеанса уровней сложности, и далее – по возрастанию. Повтор одного и того же задания в одном сеансе работы при случайном порядке заданий в режиме "Самоподготовка" исключен.

IV.3. Выбор разделов заданий

Разделы выбираются щелчком мыши в окошке рядом с требуемым разделом. Можно выбрать один раздел, несколько разделов или выбрать одновременно все разделы, щелкнув мышкой в соответствующем окошке. Повторный щелчок мышью в одном и том же окошке отменяет сделанный выбор. В случае, если не будет выбран ни один раздел, система не допустит к работе в режиме "Самоподготовка", и при нажатии кнопки [image] появится окно с сообщением об ошибке: "Вы должны выбрать хотя бы один раздел".

Примечание. В ТТС предусмотрен раздел 4а с заданиями, предназначенными только для студентов финансовых специальностей. Использование данного раздела для студентов не финансовых специальностей не рекомендуется.

IV.4. Выбор сложности заданий

Выбор сложности заданий осуществляется щелчком мыши в трех окошках значений: "простой", "средний" и "сложный". Для выбора заданий одного или двух уровней сложности необходимо щелкнуть мышью в окошке у значения требуемого уровня. При задании двух уровней сложности система позволяет выбрать только значения "простой" и "средний" или "средний" и "сложный". Только значения "простой" и "сложный" выбрать нельзя, в этом случае активизируются все три уровня сложности. Если не будет выбран ни один уровень сложности, то система не допустит к работе в режиме "Самоподготовка", и при нажатии кнопки [image] появится окно с сообщением об ошибке: "Вы должны выбрать хотя бы один уровень сложности".

Во время выбора настроек режима "Самоподготовка" в нижней части экрана информационная строка "Выбранным настройкам соответствует N заданий" сообщает, сколько заданий из общего числа заданий соответствует помеченным разделам и уровням сложности. Максимальному количеству заданий соответствует настройка режима "Самоподготовка", когда помечены все уровни сложности и все разделы.

После формирования группы заданий можно перейти непосредственно к сеансу работы в режиме "Самоподготовка", нажав кнопку [image]. Из окна "Настройки режима самоподготовки" предусмотрена возможность возврата в окно выбора режимов с помощью кнопки "Главное меню".

IV.5. Сеанс работы в режиме "Самоподготовка"

IV.5.1. Типы окон

В режиме "Самоподготовка" предусмотрены три типа основных окон:

  • Окно задания;
  • Окно анализа задания;
  • Окно таблицы результатов.

IV.5.2. Окна задания и анализа задания

IV.5.2.a. Свойства окон

В верхней части окон задания и анализа задания отображается информация о текущем задании:

  • имя пользователя;
  • номер рассматриваемого задания;
  • общее количество заданий в сеансе;
  • номер раздела;
  • сложность.

В режиме "Самоподготовка" задания предлагаются в зависимости от выбранной последовательности - либо все подряд, либо в случайном порядке.

Многовариантные задания представлены всеми вариантами, и каждый вариант задания воспринимается системой как отдельное полноценное задание. При выборе случайной последовательности многовариантное задание не разбивается на отдельные задания-варианты и представлено всей группой.

В окне анализа задания предусмотрена возможность вызова окна с комментарием к текущему заданию (только для заданий, комментарий к которым имеется в системе).

Если текст в окнах задания и позиций ответов не помещается в выделенном для него пространстве, то появляется возможность просмотра текста с помощью полос прокрутки.

IV.5.2.б. Назначение кнопок
  • - кнопка "Ответить" позволяет после выбора ответа перейти к окну анализа ответа. При входе в задание кнопка не активна. Кнопка активизируется только после выбора ответа.
  • - кнопки "Предыдущий" и "Следующий" позволяют перейти от одного задания к другому. В крайних положениях (первое или последнее задание) данные кнопки, соответственно, неактивны. В случае, если на задание дается ответ (например, выбирается щелчком мыши один из вариантов ответа), то данные кнопки становятся неактивными.
Примечание: если переход осуществляется к заданию, на которое в текущем сеансе уже был дан ответ, то этот переход происходит в окно анализа задания.

· [image] - кнопка "Результаты" позволяет перейти из любого задания к таблице результатов, где отражена статистика работы в текущем сеансе. В таблице результатов предусмотрена возможность возврата к заданию, из которого произошел переход в таблицу, с помощью кнопки "Возврат".

  • - кнопка "Очистить" позволяет отменить произведенный выбор ответа (но только до того момента, пока не нажата кнопка "Ответить"), если пользователь сомневается в правильности выбранного варианта ответа и хочет его изменить. В окне анализа задания данная кнопка неактивна.
  • - кнопка "Комментарий" позволяет из окна анализа выполнения задания вызвать окно с комментарием к текущему заданию. Для заданий, комментарии к которым не приводятся, кнопка неактивна.
  • - кнопка "Завершить" позволяет перейти к окну "Настройки режима самоподготовки". При нажатии на эту кнопку система запрашивает подтверждения или отмены данного действия. При положительном ответе на запрос система закрывается, а из таблицы результатов удаляются данные текущего сеанса, при отрицательном ответе с системой никаких изменений не происходит.

IV.5.3. Окно таблицы результатов

IV.5.3.a. Свойства окна

В таблице результатов отображается статистика работы с тестовыми заданиями в текущем сеансе.

В режиме "Самоподготовка" переход в таблицу результатов возможен в любой момент работы с системой. Переход осуществляется с помощью кнопки [image] в окне задания или окне анализа задания. Также возможен переход из таблицы результатов к текущему заданию (из которого произошел переход в таблицу результатов) либо к любому другому заданию сеанса.

В верхней части окна таблицы результатов отображены следующие параметры, по которым осуществлялся данный сеанс работы в режиме "Самоподготовка":

  • имя пользователя;
  • номера разделов;
  • уровни сложности.

В колонках таблицы для каждого задания приводятся:

  • N п/п - порядковый номер задания для данного сеанса.
  • Раздел – номер раздела, к которому относится задание.
  • Сложность – уровень сложности задания (1 – простой; 2 – средний; 3 – сложный).
  • Ваш ответ – вариант ответа, выбранный пользователем. Если вариант ответа правильный, то графа таблицы для данного задания подсвечена зеленым цветом, если вариант ответа неправильный - красным. Задания, для которых вариант ответа не был выбран, помечены надписью "Нет ответа".
  • Правильный ответ – вариант ответа, являющийся правильным для данного задания. Задания, для которых вариант ответа не был выбран, также помечены надписью "Нет ответа".

В нижней части окна таблицы результатов отображается суммарная статистика работы в сеансе, в которой представлены:

  • общее количество вопросов в сеансе;
  • количество правильных ответов;
  • количество неправильных ответов;
  • количество заданий, на которые ответ не был дан.

Примечание: для заданий, на которые в данном сеансе работы ответ не был дан, правильный ответ в таблице результатов не показывается.

С помощью кнопки [image] можно вернуться к заданию, из которого произошел переход в таблицу результатов, а с помощью кнопки [image] можно перейти в любое задание сеанса.

Примечание: если переход осуществляется к заданию, на которое в текущем сеансе уже был дан ответ, то этот переход происходит в окно анализа задания.

Затем, находясь в окне задания или окне анализа задания, можно закончить сеанс работы в режиме "Самоподготовка" с помощью кнопки "Завершить". В этом случае происходит переход в окно "Настройки режима самоподготовки", а данные из таблицы результатов текущего сеанса удаляются.

IV.5.3.б. Назначение кнопок
  • - кнопка "Возврат" позволяет вернуться к заданию, из которого произошел переход в таблицу результатов.
  • - кнопка "Переход к заданию" позволяет перейти к любому заданию в текущем сеансе. Для перехода к заданию необходимо установить курсор на графу таблицы результатов с требуемым номером задания и нажать на данную кнопку.
  • - кнопка "Сохранить" позволяет сохранить результаты текущего сеанса в виде html-файла с именем, введенным пользователем в "Главном меню". При нажатии на кнопку открывается дополнительное окно с указанием имени файла. Для сохранения результатов необходимо подтвердить данное действие, в противном случае – отказаться. Html-файл сохраняется в корневую директорию, из которой производился запуск ТТС, иных мест для сохранения результатов в системе не предусмотрено.
  • - кнопка "Главное меню" позволяет завершить текущий сеанс и перейти в "Главное меню" системы. При нажатии на эту кнопку система запрашивает подтверждения или отмены данного действия. При положительном ответе на запрос происходит переход к "Главному меню", а из таблицы результатов удаляются данные текущего сеанса, при отрицательном ответе с системой никаких изменений не происходит.
  • * - кнопки "Предыдущая" и "Следующая" позволяют переходить по страницам таблицы результатов в случае, если количество заданий в сеансе больше, чем их можно разместить на одной странице.

IV.5.4. Особенности работы с заданиями разных типов

IV.5.4.а. Задания на выбор правильного ответа из предложенного списка

Для таких заданий необходимо из представленных четырех вариантов ответа выбрать один правильный. В верхней части окна задания всегда отображается надпись "Выберите номер правильного ответа", ниже, в отдельном поле, приводится текст задания, а также четыре текстовых поля с вариантами ответа.

Для выбора номера ответа, который пользователь считает правильным, необходимо щелкнуть мышью в окошке рядом с выбранным вариантом. Правильный ответ всегда только один, поэтому система не разрешает выбрать более одного варианта.

Исправить выбранный вариант ответа можно только до нажатия на кнопку [image] (т.е. пока ответ не принят системой), щелкнув мышкой у другого варианта ответа, либо, используя кнопку [image], привести задание к первоначальному виду и выбрать другой вариант ответа.

Если не выбран ни один вариант, то кнопка [image] неактивна.

После выбора нужного варианта и нажатия на кнопку [image] задание считается выполненным, и в текущем сеансе дать повторный ответ на это задание нельзя.

После нажатия кнопки [image] происходит переход к окну анализа выполнения данного задания, в котором сообщается, правильный ответ был дан или неправильный, также отображается номер правильного ответа. Результат заносится в таблицу результатов, где останется без изменений до окончания сеанса работы в режиме "Самоподготовка".

Для многих заданий приводится комментарий, окно с которым можно вызвать с помощью кнопки [image].

Переход к следующему или предыдущему заданиям осуществляется с помощью соответствующих кнопок [image] и [image].

Примечание: если переход осуществляется к заданию, на которое в текущем сеансе уже был дан ответ, то этот переход происходит в окно анализа задания.
IV.5.4.б. Задания на установление правильной последовательности

Для этого типа в окне текста задания предлагается сформировать из предложенных позиций последовательность, которую пользователь считает правильной. Это делается с помощью кнопок с порядковым номером справа от каждой позиции. Сначала выделяется позиция, которая должна быть первой в последовательности, затем второй и т.д. для всех позиций.

В нижней части экрана в поле "Ваш ответ:" будет отображена сформированная последовательность из выбранных номеров позиций в виде, например: "4, 1, 3, 2" и т.п.

Если в процессе выбора последовательности допущена ошибка, то с помощью кнопки [image] можно привести задание к исходному виду и сформировать последовательность заново. Кнопку [image] можно использовать на любой стадии работы с данным заданием, пока не будет нажата копка [image].

Как только последовательность полностью сформирована, кнопка [image] становится активной. После нажатия на нее задание считается выполненным и происходит переход к окну анализа данного задания.

После нажатия кнопки [image] происходит переход к окну анализа выполнения данного задания, в котором сообщается, правильный ответ был дан или неправильный, также отображается номер правильного ответа. Результат заносится в таблицу результатов, где останется без изменений до окончания сеанса работы в режиме "Самоподготовка".

Для многих заданий приводится комментарий, окно с которым можно вызвать с помощью кнопки [image].

Переход к следующему или предыдущему заданиям осуществляется с помощью соответствующих кнопок [image] и [image].

Примечание: если переход осуществляется к заданию, на которое в текущем сеансе уже был дан ответ, то этот переход происходит в окно анализа задания.
Примечание: для данного типа заданий в каждом новом сеансе работы в режиме "Самоподготовка" порядковые номера позиций будут заново сформированы случайным образом.
IV.5.4.в. Задания на выбор соответствий

Для этого типа заданий предусмотрены два окна с позициями для выбора соответствий. В верхней части окна задания всегда отображается надпись: "Для каждой позиции слева отметьте соответствующую ей позицию справа".

В левом окне последовательно, начиная с первой, система активизирует позиции задания (они помечены цифрами). В правом окне расположены позиции, помеченные буквами. Среди этих позиций находятся правильные варианты соответствий (ровно такое же количество, сколько позиций находится в левом окне), а также несколько неправильных вариантов. Выбор позиции осуществляется нажатием на кнопку с буквенным обозначением. По мере выбора соответствующей позиции справа позиции слева затеняются и становятся неактивными.

Если позиций в одном из окон задания больше, чем можно отразить на экране, предусмотрены полосы прокрутки изображения.

В нижней левой части окна задания после надписи "Ваш ответ:" отображаются выбранные соответствия в виде, например: "1-б, 2-д" и т.п. После того как каждому элементу слева выбрано соответствие справа, кнопка [image] становится активной. После нажатия на нее задание считается выполненным и происходит переход к окну анализа задания.

Если в процессе выбора соответствий допущена ошибка, то с помощью кнопки [image] можно формировать соответствия заново. Кнопку [image] можно использовать на любой стадии работы с данным заданием, пока не будет нажата копка [image].

После нажатия кнопки [image] происходит переход к окну анализа выполнения данного задания, в котором сообщается, правильный ответ был дан или неправильный, также отображается номер правильного ответа. Результат заносится в таблицу результатов, где останется без изменений до окончания сеанса работы в режиме "Самоподготовка".

Для многих заданий приводится комментарий, окно с которым можно вызвать с помощью кнопки [image].

Переход к следующему или предыдущему заданиям осуществляется с помощью соответствующих кнопок [image] и [image].

Примечание: если переход осуществляется к заданию, на которое в текущем сеансе уже был дан ответ, то этот переход происходит в окно анализа задания.


V. Режим "Тестирование"

V.1. Назначение режима "Тестирование"

Режим "Тестирование" предназначен для контроля знаний по курсу "Введение в правовую информатику".

При входе в режим открывается окно настроек. В этом окне можно из общего банка заданий формировать группы тестовых заданий, исходя из предложенных видов настройки:

  • Разделы заданий (в соответствии с главами курса);
  • Сложность заданий: "простой", "средний" и "сложный" уровни.

V.2. Настройки режима "Тестирование"

В окне настроек режима "Тестирование" первым этапом является выбор разделов. Таким действием задается максимальное количество заданий в сеансе, при этом общее количество заданий в сеансе затем можно уточнить с помощью ввода новых значений для каждого уровня сложности.

Выбор разделов осуществляется щелчком мыши в окошке слева от нужного раздела. Можно выбрать один или несколько разделов, также система позволяет выделить все разделы с помощью щелчка мыши у специального окошка. Пометки снимаются повторным щелчком мыши в окошке слева от каждого раздела.

По мере того как выбираются разделы, в нижней части окна настроек отображается количество заданий, соответствующее выбранным разделам. Это количество отображается в трех полях:

  • В поле "Уровни сложности:" - в окошках после соответствующих уровней в виде: "простой n1 средний n2 сложный n3", где n1, n2 и n3 – максимальное количество заданий каждого из трех уровней сложности для выбранных разделов. Эти значения доступны для изменения путем ввода новых значений.
  • В поле "Выбрано:" – также после соответствующих уровней сложности в виде: "простых n1*из n1 средних n2* из n2 сложных n3* из n3", где n1*, n2* и n3* - количество заданий для каждого из трех уровней сложности, соответствующее количеству заданий в окошках поля "Уровни сложности"; n1, n2 и n3 – максимальное количество заданий каждого из трех уровней сложности для выбранных разделов. На первом этапе выбора настроек значения n1*, n2* и n3* равны значениям n1, n2 и n3 соответственно.
  • В поле "Всего N заданий", где N – сумма выбранных заданий (значений n1*, n2* и n3*). На первом этапе равняется максимальному количеству заданий для выбранных разделов.
Примечание: если суммарное количество заданий, выбранных на первом этапе, устраивает пользователя, то можно ограничиться только этим этапом.

Система позволяет регулировать количество заданий в сеансе с помощью изменения значений для каждого уровня сложности. Эти изменения можно производить в сторону уменьшения до нулевого значения.

Таким образом, вторым этапом выбора настроек сеанса является выбор количества заданий в сеансе путем ввода новых значений в соответствующих окошках поля "Уровни сложности:". Новые значения могут вводиться в диапазоне от "0" до максимального значения, которое первоначально отображалось в данном окошке. По мере того как пользователем вводятся новые значения, в поле "Выбрано:" соответственно изменяются значения n1*, n2* и n3*, также изменяется суммарное количество (значение N) заданий в поле "Всего N заданий".

Рекомендуемое количество заданий в сеансе - 30-40, оно рассчитано для работы в течение 1-1,5 часов. Для нормального распределения заданий по уровням сложности целесообразно задавать во всех трех окошках одинаковые значения, ориентируясь на минимальное значение заданий для какого-либо уровня сложности и на суммарное количество заданий, которое пользователь хочет получить.

Если новое значение превышает максимально допустимое количество заданий для выбранных режимов, либо введено значение, содержащее некорректный символ, то в поле "Выбрано:" для этого уровня сложности цвет значений изменяется на красный, а при нажатии на кнопку "ОК" появляется окно с сообщением об ошибке: "Некорректный выбор количества заданий".

После формирования группы заданий можно перейти непосредственно к сеансу работы в режиме "Тестирование", нажав кнопку "OK". Из окна "Настройки режима тестирования" предусмотрена возможность возврата в окно выбора режимов с помощью кнопки "Главное меню".

V.3. Сеанс работы в режиме "Тестирование"

V.3.1. Типы окон

В режиме "Тестирование" предусмотрены четыре типа основных окон:

  • Окно задания;
  • Окно анализа задания;
  • Таблица результатов;
  • Окно анализа задания при переходе из таблицы результатов.

V.3.2. Окна задания и анализа задания

V.3.2.а. Свойства окон

В верхней части окон задания и анализа задания отображается информация о текущем задании:

  • имя пользователя;
  • номер рассматриваемого задания;
  • общее количество заданий в сеансе;
  • номер раздела;
  • сложность.

Задания и типы этих заданий аналогичны рассмотренным заданиям для режима "Самоподготовка".

При работе с тестовыми заданиями в режиме "Тестирование" существуют следующие отличия от работы в режиме "Самоподготовка":

  • переход к следующему заданию можно осуществить, только дав ответ к текущему заданию;
  • в окне анализа задания отображается только информация – правильный был дан ответ или неправильный;
  • комментарий к заданию в окне анализа не приводится. Комментарий к заданию приводится только в окне анализа задания при переходе из таблицы результатов.

Задания в режиме "Тестирование" предлагаются только в случайном порядке, не зависящем от последовательности изложения материала курса. Но порядок заданий зависит от уровня сложности – сначала предлагаются задания наименьшего из выбранных для сеанса уровней сложности, и далее – по возрастанию. Многовариантные задания представлены только одним вариантом. При повторном сеансе формируется новая группа заданий, соответствующая текущей настройке. Порядок подачи и содержание заданий будут изменены случайным образом. Повтор одного и того же задания в одном сеансе работы в режиме "Тестирование" исключен.

V.3.2.б. Назначение кнопок
  • - кнопка "Ответить" находится в окне задания и позволяет после выбора ответа перейти к окну анализа ответа. При входе в задание кнопка не активна. Кнопка активизируется только после выбора ответа.
  • - кнопка "Очистить" позволяет отменить произведенный выбор ответа (но только до того момента, пока не нажата кнопка "Ответить"), если пользователь сомневается в правильности выбранного варианта ответа и хочет его изменить. В окне анализа задания данная кнопка неактивна.
  • - кнопка "Завершить тестирование" завершает текущий сеанс с переходом к окну таблицы результатов этого сеанса тестирования. При нажатии на эту кнопку система запрашивает подтверждения или отмены данного действия с предупреждением, что продолжение работы с заданиями в данном сеансе будет невозможно. При положительном ответе на запрос происходит переход к таблице результатов, в которой отражена статистика незаконченного сеанса, при отрицательном ответе с системой никаких изменений не происходит.
  • - кнопка "Продолжить" находится в окне анализа ответа, при нажатии происходит переход к следующему заданию в сеансе.
  • - кнопка "Результаты" находится только в окне анализа ответа последнего задания в сеансе, при нажатии на кнопку происходит переход в таблицу результатов.

V.3.3. Окна таблицы результатов и анализа задания при переходе из таблицы результатов

V.3.3.а. Свойства окон

В таблице результатов отображается статистика работы с тестовыми заданиями в текущем сеансе.

Из таблицы результатов возможен переход только к окнам анализа заданий текущего сеанса (а не к самим заданиям). В окне анализа задания при переходе из таблицы результатов сообщается, правильный ответ был дан или неправильный, также отображается номер правильного ответа. Для многих заданий предусмотрена возможность просмотра комментариев. Исключение составляет случай, когда сеанс тестирования был прерван и остались задания, на которые ответ не был дан: для таких заданий в окне анализа не приводится правильный ответ и комментарий к заданию также получить нельзя.

В верхней части окна таблицы результатов отображены следующие параметры, по которым осуществлялся данный сеанс работы в режиме "Самоподготовка":

  • имя пользователя;
  • номера разделов;
  • уровни сложности.

В колонках таблицы для каждого задания приводятся:

  • N п/п - порядковый номер задания для данного сеанса.
  • Раздел – номер раздела, к которому относится задание.
  • Сложность – уровень сложности задания (1 – простой; 2 – средний; 3 – сложный).
  • Ваш ответ – вариант ответа, выбранный пользователем для задания. Если вариант ответа правильный, то графа таблицы для данного задания подсвечена зеленым цветом, если вариант ответа неправильный - красным. Задания, для которых вариант ответа не был выбран, помечены надписью "Нет ответа".
  • Правильный ответ – вариант ответа, являющийся правильным для данного задания. Задания, для которых вариант ответа не был выбран, также помечены надписью "Нет ответа".

В нижней части окна таблицы результатов отображается суммарная статистика работы в сеансе, в которой представлены:

  • общее количество вопросов в сеансе;
  • количество правильных ответов;
  • количество неправильных ответов;
  • количество заданий, на которые ответ не был дан.
Примечание: для заданий, на которые в данном сеансе работы ответ не был дан, правильный ответ в таблице результатов не показывается.
V.3.3.б. Назначение кнопок
  • - кнопка "Сохранить" находится в окне таблицы результатов и позволяет сохранить результаты текущего сеанса в виде html-файла с именем, введенным пользователем в "Главном меню". При нажатии на кнопку открывается дополнительное окно с указанием имени файла. Для сохранения результатов необходимо подтвердить данное действие, в противном случае – отказаться. Html-файл сохраняется в корневую директорию, из которой производился запуск ТТС, иных мест для сохранения результатов в системе не предусмотрено.
  • - кнопка "Переход к заданию" позволяет перейти из таблицы результатов к окну анализа любого задания в текущем сеансе. Для перехода к окну анализа задания необходимо установить курсор на графу таблицы результатов с требуемым номером задания и нажать на данную кнопку. Кнопка присутствует также в окне анализа задания, но является неактивной.
  • - кнопка "Возврат" позволяет вернуться из окна анализа задания в таблицу результатов. Кнопка присутствует также в таблице результатов, но является неактивной.
  • - кнопка "Комментарий" находится только в окне анализа задания, при нажатии на кнопку открывается окно с комментарием к текущему заданию. Для заданий, к которым комментарии не приводятся, кнопка неактивна.
  • - кнопка "Главное меню" позволяет завершить текущий сеанс и перейти в "Главное меню" системы. При нажатии на эту кнопку система запрашивает подтверждения или отмены данного действия. При положительном ответе на запрос происходит переход к "Главному меню", а из таблицы результатов удаляются данные текущего сеанса, при отрицательном ответе с системой никаких изменений не происходит.
  • * - кнопки "Предыдущая" и "Следующая" находятся только в окне таблицы результатов и позволяют переходить по страницам таблицы в случае, если количество заданий в сеансе больше, чем их можно разместить на одной странице.

V.3.4. Особенности работы с заданиями разных типов

V.3.4.а. Задания на выбор правильного ответа из предложенного списка

Для таких заданий необходимо из представленных четырех вариантов ответа выбрать один правильный. В верхней части окна задания всегда отображается надпись "Выберите номер правильного ответа", ниже, в отдельном поле, приводится текст задания, а также четыре текстовых поля с вариантами ответа.

Для выбора номера ответа, который пользователь считает правильным, необходимо щелкнуть мышью в окошке рядом с выбранным вариантом. Правильный ответ всегда только один, поэтому система не разрешает выбрать более одного варианта.

Исправить выбранный вариант ответа можно только до нажатия на кнопку [image] (т.е. пока ответ не принят системой), щелкнув мышкой у другого варианта ответа, либо, используя кнопку [image], привести задание к первоначальному виду и выбрать другой вариант ответа.

Если не выбран ни один вариант, то кнопка [image] неактивна.

После выбора нужного варианта и нажатия на кнопку [image] задание считается выполненным, и в текущем сеансе дать повторный ответ на это задание нельзя.

После нажатия кнопки [image] происходит переход к окну анализа выполнения данного задания, в котором сообщается, правильный ответ был дан или неправильный. Результат заносится в таблицу результатов, где останется без изменений до окончания сеанса работы в режиме "Тестирование".

Переход к следующему заданию осуществляется из окна анализа задания с помощью кнопки [image].

V.3.4.б. Задания на установление правильной последовательности

Для этого типа в окне текста задания предлагается сформировать из предложенных позиций последовательность, которую пользователь считает правильной. Это делается с помощью кнопок с порядковым номером справа от каждой позиции. Сначала выделяется позиция, которая должна быть первой в последовательности, затем второй и т.д. для всех позиций.

В нижней части экрана в поле "Ваш ответ:" будет отображена сформированная последовательность из выбранных номеров позиций в виде, например: "4, 1, 3, 2" и т.п.

Если в процессе выбора последовательности допущена ошибка, то с помощью кнопки [image] можно привести задание к исходному виду и сформировать последовательность заново. Кнопку [image] можно использовать на любой стадии работы с данным заданием, пока не будет нажата копка [image].

Как только последовательность полностью сформирована, кнопка [image] становится активной. После нажатия на нее задание считается выполненным и происходит переход к окну анализа данного задания.

После нажатия кнопки [image] происходит переход к окну анализа выполнения данного задания, в котором сообщается, правильный ответ был дан или неправильный. Результат заносится в таблицу результатов, где останется без изменений до окончания сеанса работы в режиме "Тестирование".

Переход к следующему заданию осуществляется из окна анализа задания с помощью кнопки [image].

Примечание: для данного типа заданий в каждом новом сеансе работы в режиме "Тестирование" порядковые номера позиций будут заново сформированы случайным образом.
V.3.4.в. Задания на выбор соответствий

Для этого типа заданий предусмотрены два окна с позициями для выбора соответствий. В верхней части окна задания всегда отображается надпись: "Для каждой позиции слева отметьте соответствующую ей позицию справа".

В левом окне последовательно, начиная с первой, система активизирует позиции задания (они помечены цифрами). В правом окне расположены позиции, помеченные буквами. Среди этих позиций находятся правильные варианты соответствий (ровно такое же количество, сколько позиций находится в левом окне), а также несколько неправильных вариантов. Выбор позиции осуществляется нажатием на кнопку с буквенным обозначением. По мере выбора соответствующей позиции справа позиции слева затеняются и становятся неактивными.

Если позиций в одном из окон задания больше, чем можно отразить на экране, предусмотрены полосы прокрутки изображения.

В нижней левой части окна задания после надписи "Ваш ответ:" отображаются выбранные соответствия в виде, например: "1-б, 2-д" и т.п. После того как каждому элементу слева выбрано соответствие справа, кнопка [image] становится активной. После нажатия на нее задание считается выполненным и происходит переход к окну анализа задания.

Если в процессе выбора соответствий допущена ошибка, то с помощью кнопки [image] можно формировать соответствия заново. Кнопку [image] можно использовать на любой стадии работы с данным заданием, пока не будет нажата копка [image].

После нажатия кнопки [image] происходит переход к окну анализа выполнения данного задания, в котором сообщается, правильный ответ был дан или неправильный. Результат заносится в таблицу результатов, где останется без изменений до окончания сеанса работы в режиме "Тестирование".

Переход к следующему заданию осуществляется из окна анализа задания с помощью кнопки [image].


ТТС 2.0. Руководство по установке

Минимальные технические требования

  • Pentium 133
  • 32 MB RAM
  • 500 кб свободного места на жестком диске
  • видеорежим 800x600x256
  • Windows 9x/ME/NT/2000/XP или любая другая ОС, поддерживающая SUN JVM
  • SUN JVM 1.1.x

Внимание!

С виртуальной машиной Microsoft, являющейся необязательным компонентом MSIE, ТТС работать не будет! Для установки виртуальной машины JAVA нажмите кнопку "Установить JAVA" в разделе "Учимся работать с системой КонсультантПлюс".


Внимание!
Внимание! При незапуске системы ТТС необходимо установить виртуальную машину JAVA. Для этого нажмите кнопку "Установить JAVA" в разделе "Учимся работать с системой КонсультантПлюс".

Тренинго-тестирующая система. Версия 2.0

I. Назначение ТТС

II. Типы тестовых заданий

III. Режимы работы в ТТС

IV. Режим "Самоподготовка"

IV.1. Назначение режима "Самоподготовка"

IV.2. Выбор порядка заданий

IV.3. Выбор разделов заданий

IV.4. Выбор сложности заданий

IV.5. Сеанс работы в режиме "Самоподготовка"

IV.5.1. Типы окон

IV.5.2. Окна задания и анализа задания

IV.5.2.a. Свойства окон
IV.5.2.б. Назначение кнопок
IV.5.3.a. Свойства окна
IV.5.3.б. Назначение кнопок

IV.5.4. Особенности работы с заданиями разных типов

IV.5.4.а. Задания на выбор правильного ответа из предложенного списка
IV.5.4.б. Задания на установление правильной последовательности
IV.5.4.в. Задания на выбор соответствий

V. Режим "Тестирование"

V.1. Назначение режима "Тестирование"

V.2. Настройки режима "Тестирование"

V.3. Сеанс работы в режиме "Тестирование"

V.3.1. Типы окон

V.3.2. Окна задания и анализа задания

V.3.2.а. Свойства окон
V.3.2.б. Назначение кнопок

V.3.3. Окна таблицы результатов и анализа задания при переходе из таблицы результатов

V.3.3.а. Свойства окон
V.3.3.б. Назначение кнопок

V.3.4. Особенности работы с заданиями разных типов

V.3.4.а. Задания на выбор правильного ответа из предложенного списка
V.3.4.б. Задания на установление правильной последовательности
V.3.4.в. Задания на выбор соответствий

VI. Минимальные системные требования