Kassy

1. Введение

1.1. О программе Kassy

Программа Kassy является информационной базой по кассовым аппаратам, включающая в себя общую информацию, сферу применения, техническую информацию, цену и вид чека на множество кассовых аппаратов РФ. При помощи этой программы вы всегда сможете определиться с выбором кассового аппарата для вашей деятельности, подобрать оптимальные характеристики, сочетание цены и качества, а так же посмотреть как будет выглядеть чек нужной вам ККМ. Главной особенностью программы является то, что она проста в использовании и ей может воспользоваться любой пользователь ПК.

1.2. Технические требования

Программа совместима со следующими операционными системами Windows 95/98/2000/20003/Me/NT/XP/Vista

Для работы программы требуется не менее:
300 Mhz процессор
64 Мб оперативной памяти (RAM)

Программа совместима с любыми типами принтеров настроенных в системе Windows.

1.3. Ограничения в демо-версии. Отличия версий Lite от Professional

В демо-версии программы отсутствуют примерные цены на кассовые аппараты и каждый чётный символ из шрифтов.
Версия Lite - это упрощённая версия программы, в ней ограничена база кассовых аппаратов (всего 16 штук), в ней перечислены более дешевые модели кассовых аппаратов. Полный список:
  • АМС-100
  • АСТРА-100
  • МЕРКУРИЙ-112
  • МЕРКУРИЙ-115
  • МЕРКУРИЙ-130
  • МИКРО-103
  • МИКРО-104
  • МИКРО-105
  • МИНИКА-1102
  • МИНИКА-1103
  • ОКА-102
  • ОКА-ПК
  • ЭКР-2102
  • ЭКР-3102
  • ЭЛВЕС-МИКРО
  • SAMSUNG ER4615RF(K)
Так же в Lite версии не доступен новый метод распечатки на Матричных и Термо-принтерах (Метод Автосмещения).

В Professional версии полная база кассовых аппаратов (всего 61 штука) и доступен при распечатки Метод Автосмещения:
  • АМС-100
  • АМС-101
  • АМС-110
  • АМС-200
  • АРКУС-КАСБИ 01Ф
  • АСТРА-100
  • АСТРА-200
  • БИС-01
  • БПМ-3Ф
  • ЕЛКА-82
  • КАСБИ-02
  • КАСБИ-03
  • ЛАДОГА
  • МЕРКУРИЙ-112
  • МЕРКУРИЙ-114.1-ТОРНАДО
  • МЕРКУРИЙ-115
  • МЕРКУРИЙ-120
  • МЕРКУРИЙ-130
  • МЕРКУРИЙ-140
  • МЕРКУРИЙ-180
  • МЕРКУРИЙ-MS-К
  • МИКРО-103
  • МИКРО-104
  • МИКРО-105
  • МИНИКА-1101
  • МИНИКА-1102
  • МИНИКА-1103
  • ОКА-102
  • ОКА-2000
  • ОКА-500
  • ОКА-600
  • ОКА-ПК
  • ОРИОН-100
  • ПРИМ-07
  • ПРИМ-08
  • СТАЕР-01Ф
  • ТРИУМ-Ф
  • ТВЕС-МИНИ
  • ФЕЛИКС-РК
  • ФЕЛИКС-02К
  • ШТРИХ-950
  • ШТРИХ-2000
  • ШТРИХ-ФР
  • ШТРИХ-КОМБО-ФР
  • ШТРИХ-МИКРО
  • ШТРИХ-МИНИ
  • ШТРИХ-МИНИ-ФР
  • ЭВКМ-15Ф
  • ЭКР-2102
  • ЭКР-3102
  • ЭЛЕКТРОНИКА92-06Ф
  • ЭЛВЕС-01-02Ф
  • ЭЛВЕС-01-03Ф
  • ЭЛВЕС-МИКРО
  • ЭЛВЕС-МИНИ-ФР
  • ЭЛВЕС-МИНИ
  • ЭЛВЕС-ФР
  • FUJISU-G880RF
  • SAMSUNG ER250RF(K)
  • SAMSUNG ER4615RF(K)
  • SHARP ER-A250RF

1.4. Регистрация

Все условия приобретения программы вы можете найти на http://www.stampz.ru/reg2.php
При регистрации обязательно нужно выслать на e-mail: kassyreg@stampz.ru ваш ключ 1, который вы можете найти в демо-версии программы. После выполнения всех требований, вам будет выслан ключ 2 для завершения регистрации. Программа предназначена для работы на одном компьютере, для работы на другом компьютере потребуется приобрести ещё одну копию программы.

После завершения регистрации вам будет предоставлена техническая поддержка по любым вопросам использования программы через e-mail: kassy@stampz.ru или по телефонам (4232) 722-158, (4232) 519-490.

При приобретении версий Lite или Professional, обновления на соответствующие версии вы будете получать бесплатно.

1.5. История

Kassy v.0.71 от 23.10.2005
  • Добавлен быстрый метод подачи информации на принтер и выставлен по умолчанию
  • Добавлена возможность открытия текстов и параметров с предыдущих версий Kassy
  • Добавлена возможность печати чека в рамке
  • Исправлены некоторые недочёты
Kassy v.0.7 от 14.10.2005
  • Полностью переработан код программы, поэтому
  • Добавлено множество новых кассовых аппаратов (всего 61) и новых шрифтов(около 70 уникальных)
  • Изменена максимальная матрица символов с 9*9 на 32*32
  • Добавлены новые методы печати для матричных и термо-принтеров
  • Добавлена возможность задавать отдельные параметры для любого символа чека
  • Добавлена возможность менять размер "точки" в процентах
  • Добавлены возможности наклона и инверсии символов
  • Добавлена возможность создавать чек, задавая размеры в миллиметрах и пикселях
  • Добавлены образцы чеков и их вставка
  • Добавлена возможность вставки чека в MS Word
  • Программа разделена на 2 лицензии Lite(16 ККМ) и Professional(61 ККМ)
Kassy v.0.3 от 14.07.2003
  • Внесены некоторые изменения в шрифт и параметры ККМ АМС-100Ф
  • Добавлена функция оптимизации чека для печати на матричном принтере
  • Добавлен редактор шрифтов
  • Добавлена возможность вырезания, копирования и вставки текстов (Функция вызывается нажатием правой кнопки мыши на тексте)
  • Исправлена ошибка возникающая при вставке символов под Windows NT/2000/XP
  • В информационную базу добавлено 18 ККМ
  • Обновилась информационная база по ККМ
Kassy v.0.2 от 12.11.2002
  • Исправлена ошибка при отображение на экране чека
  • Исправлена ошибка печати в цветном режиме
  • Добавлена проверка наличия файлов параметров и шрифтов
  • Добавлена функция сохранения и открытия текста для чеков
  • Добавлен ККМ АМС-100Ф
  • Внесены некоторые изменения в шрифт ККМ ЭКР 2102Ф и ККМ МИНИКА 1102Ф
Kassy v.0.1 от 06.10.2002
- Самая первая версия программы, поддерживает 8 ККМ:
  • SAMSUNG ER-4615RF
  • АСТРА 100Ф
  • МЕРКУРИЙ 115Ф
  • МИКРО 103Ф
  • ОКА 102Ф
  • ЭКР 2102Ф
  • МИНИКА 1102Ф
  • ЭЛВЕС-МИКРО-Ф

1.6. Техническая поддержка

Для получения технической поддержки обратитесь по следующим адресам:
Телефоны: (4232) 722-158, (4232) 519-940
E-mail: kassy@stampz.ru
Сайт: http://www.stampz.ru

2. Начало работы

2.1. Просмотр кассовых аппаратов

  1. Выберите закладку Информация по ККМ
  2. Выберите интересующий вас Кассовый аппарат из списка "Выбор кассового аппарата"
  3. На экране появиться картинка кассового аппарата, общее описание, техническое описание и, если у вас Зарегистрированная версия, цена кассового аппарата.

Для переключения баз Lite и Professional воспользуйтесь списком "Выбор текущей базы".

2.2. Печать пробного чека

  1. Выберете закладку "Печать тест-чека"
  2. Выберите интересующий вас кассовый аппарат из списка "Выбор кассового аппарата"
  3. Выберите закладку "Редактирование текста"
  4. Если имеется кнопка "Вставить образец чека", то при её нажатии в поле текста чека вставиться пример чека от данной ККМ. Так же текст чека можно набрать вручную в окне текста чека.
  5. Перейдите в закладку "Вывод на печать".
  6. Нажмите "Распечатать"

Здесь описан первый шаг печати пробного чека. Более подробно возможности программы будут описаны ниже.

3. Описание меню и функций программы

3.1. Меню

3.1.1. Файл

Открыть параметры - открывает преднастроенные параметры создания чека
Открыть текст - открывает ранее набранный текст чека
Сохранить параметры - сохраняет настроенные вами параметры в отдельный файл
Сохранить текст - сохраняет набранный вами текст чека в отдельный файл
Сохранить рисунок чека - сохраняет готовый рисунок чека в графическом BMP-формате

3.1.2. О программе

Документация - показывает документацию программы
Об авторе - показывает информацию о создателе программы

3.1.3. Регистрация

Меню регистрации для ввода ключа 2.

3.2. Информация по ККМ

В данной закладке отображается информация по кассовым аппаратам. Здесь вы можете выбрать интересующий вас ККМ из списка "Выбор кассового аппарата" и увидеть общую информацию о нём, сферу применения, техническое описание и, если у вас зарегистрированная версия, цену. Смена баз по кассовым аппаратам осуществляется из списка "Выбор текущей базы"

3.3. Печать тест-чека

3.3.1. Общая информация

Принцип работы с чеком прост. Вы выбираете интересующую вас модель ККМ, выбираете вариант шрифта (если их несколько), вариант настроек и размеры в мм или в пикселях (Размеры в мм рекомендуется использовать при печати на лазерных и струйных принтерах, размеры в пикселях на матричных и термо-принтерах). Далее в поле для текста чека вводим текст или вставляем образец чека (если у вас слабый компьютер, рекомендуется вводить текст в "Упрощённом Виде" для этого пометьте Вид -> "Упрощённый"). Далее выбираем "Вывод на печать". Если у вас матричный или термопринтер, выбираем метод печати "Точка в точку" или "Метод Автосмещения". Печатаем, нажатием кнопки "Распечатать".

Внимание! Если в "вариантах настроек" отображён текст "Неточная настройка", значит выводимый на принтер чек не будет гарантированно соответствовать по размерам. Шрифт будет такой, но размеры возможно другие.
Если у вас имеется образец чека, у которого в программе указана "Неточная настройка" или не имеется кнопка "Вставить образец чека", вы можете отсканировать этот чек и выслать его на E-mail: add@stampz.ru и он будет добавлен в базу данных для следующей версии.

3.3.2. Редактирование текста

Вид - "Авто" автоматическое масштабирование, Вид число% масштабирование рисунка чека в процентах.
Упрощенный - упрощенный набор текста в RTF формате TTF-шрифтом. Рекомендуется при наборе объемных чеков и на слабых ПК.
Кнопка B - набор утолщённого текста
Кнопка I - набор текста с наклоном
Закрашенная кнопка I - набор инверсионного текста (белый текст на чёрном фоне)
Белая область - область редактирования текста чека
Вставить образец чека - вставка заложенного в базе образца чека
Вставить символ - вставка символа в текст чека из таблицы символов ККМ. Выбирается путём двойного клика по символу из появившейся таблицы или при нажатии кнопки Вставить.

Вариант шрифта - выбор имеющегося в базе шрифта к текущему ККМ.
Варианты настроек - выбор имеющейся в базе настройки вывода на печать к текущему ККМ. Если установлена "Неточная настройка", тогда выводимый на принтер чек не будет гарантированно соответствовать по размерам.
Единица измерения - размеры в мм все параметры будут задаваться в миллиметрах (рекомендуется для лазерных и струйных принтеров), размеры в пикселях все задаваемые параметры будут задаваться в количествах пикселей (рекомендуется для матричных и термо-принтеров).

Интервал между точками - установка интервала между точками в чеке
Размер точки - установка размеров точки
Настройки строк:
Интервал между строк - установка интервала между строк в чеке
Интервал между символов - установка интервала между символами в чеке
Смещение чётных строк - установка размера смещения каждой чётной строки
Смещение строки № - установка размера смещения для определённой строки
Варианты:
Размер как есть - задание размеров смещений и интервалов межстрочных и межсимвольных в мм или пикселях, как есть
Размер как "точка" - задание размеров смещений в точках чека, т.е. единица точка = размер точки + интервал между точками

Настройки утолщения:
Утолщение по X, Y - устанавливает на сколько точек утолщать символ при применении утолщения (B)
Интервал по X, Y - интервалы между точками при утолщении
Отступ - смещение по горизонтали символа при утолщении
Наклон с - номер точки с которой начинается наклон чека при применении наклона (I)

Настройки точки:
Вид точки - отображает примерный вид точки
Округлость - устанавливает величину округления точки
Размер в % - изменения размера точки в процентах. Если, при печати на лазерных, струйных принтерах, выходит слишком жирный или слишком тонкий шрифт, рекомендуется соответственно изменить размер точки в процентах.
Цвет - выбор цвета символов чека
R (красный), G (зелёный), B (синий) - альтернативный выбор цвета

Настройки эмуляции:
Разрешение ККМ по X, Y (DPI) - предполагаемое разрешение ККМ в точках на дюйм, используется при размерах в мм
Ширина чековой ленты (мм) - собственно ширина чековой ленты ККМ в миллиметрах
Качество (DPI) - качество картинки создаваемого чека. Иногда для струйных и лазерных принтеров рекомендуется установить качество 1200 и выше

Другие настройки:
Смещение по X, Y (мм) - смещение текста чека в миллиметрах от угла
Варианты:
Настройки для текста - применяет изменение настроек и шрифта для всего текста
Настройки для символа - применяет изменение настроек и шрифта для отдельного символа

3.3.3. Вывод на печать

Отступы при распечатке (мм) - смещение левого верхнего угла чека при распечатке в мм
Экспорт:
Метод печати - выбор метода передачи чека на принтер:
1) Обычная печать - стандартный метод печати подстраивающийся под разрешение принтера;
2) Точка в точку - печать получившейся картинки чека без внутреннего масштабировании при передачи на принтер, рекомендуется для матричных и термопринтеров;
3) Метод автосмещения - новый метод печати для матричных и термопринтеров. Доступен только при использовании базы Professional. Эффективность метода заключается в том, что он сохраняет размеры чека при любом разрешении матричного или термо-принтера, при этом практически не теряя качества.

3.3.4. Редактор символов

Вариант шрифта - выбор имеющегося варианта шрифта текущей ККМ для редактирования
Символ №N - выбор символа под номером N для редактирования
Размер X, Y - изменение размеров в точках матрицы символов текущего шрифта
Матрица символа - отображение матрицы символа. Изменение в матрице вносятся кликом мышки по нужной клетке
Сбросить шрифты - восстановить заданные в базе по умолчанию шрифты
Сохранить шрифты - сохранить измененные шрифты

4. Заключение

В данной документации были описаны основные возможности программы Kassy.

Благодарим вас за проявленный интерес к продукту Kassy.

Желаем вам приятной работы!

Контактная информация:
E-mail: kassy@stampz.ru
Телефоны: (4232) 722-158; (4232) 519-490
Сайт: http://www.stampz.ru

Автор Седых Максим Валентинович
14.10.2005
Stampz.ru