New Page 1

Определение корней алгебраического уравнения F(x)=0

Определение корней трансцендентного уравнения F(x)=0

Решение системы линейных уравнений

Разложение функции в степенной ряд

Разложение функции на элементарные дроби

Дифференцирование функций

Интегрирование функций

Назад


new_page_2

Определение корней алгебраического уравнения F(x)=0

Способы:

  1. Средствами символьной математики (прием 6)
  2. Путем обращения к встроенной функции (прием 2)

Пример: Найти корни кубического уравнения x3+3x2-972=0

Прием 6.

- Записать многочлен на рабочий лист

- Выделить переменную х в любом месте выражения.

- Вызвать команду меню Symbolic ® Variable ® Solve (Символы ® Переменные ® Вычислить).

Ответ появится в виде вектора

Прием 2.

- Записать многочлен на рабочий лист

- Выделить переменную х в любом месте выражения.

- С помощью команды Symbolic ® PolinomialCoefficients (Символы ® КоэффициентыПолинома) записать вектор коэффициентов многочлена.

- Переменной V присвоить его значение

- Вызвать встроенную функцию нахождения корней по команде меню f(x) ® poliroots(v).

Задание 1

Дано уравнение ax5 + bx4 + cx3 + dx2 + ex + f=0. Найти его корни и осуществить проверку методом подстановки.

Вариант

a

b

c

d

e

f

1

0

3

7

11

-44652

2

1

0

8

-12

15674

1

2

2

-4

70

3167

1,5

-2

-4

7

33

-9876

2

1

0

-12

-22

-23232

3

0

3

-23

5

42844

2

-1

4

11

0

55345

1

2

-1

8

17

4321

3

-3

2

7

-13

-9876

2

0

1

12

0

10784


new_page_3

Определение корней трансцендентного уравнения F(x)=0

Пример: Найти решение уравнения F(x)=3x-(4x-2)*2x=0

Последовательность действий:

  1. Определить наличие действительно решения (построить график функции и найти место пересечения графика с осью абсцисс). Для этого надо записать выражение на лист, затем вызвать панель инструментов меню Graph (График) и построить график функции в декартовых координатах.

Из графика видно, что действительный корень существует и равен » 3.

  2. Найти решение, используя 6 прием. Для этого надо записать многочлен на лист, выделить х, вызвать команду Symbolic ® Variable ® Solve (Символы ® Переменные ® Вычислить)

  3. Найти решение, используя 2 прием. Для этого надо записать уравнение на лист, выделить х, вызвать команду Symbolic ® Variable ® Solve (Символы ® Переменные ® Вычислить), вызвать встроенную функцию нахождения корней по команде меню f(x) ® root(F(x),x,a,b). Параметры этой функции х – аргумент, F(x) - функция, a и b - границы интервала, где ищется решение.

Задание 2

Дано трансцендентное уравнение. Найти его решение и осуществить проверку методом подстановки.

Вариант

Уравнение

F(x) = sin(x) - cos(x2) + 1/4 = 0

F(x) = cos (x) - sin (x2) + 1/4 = 0

F(x) = sin(x) - cos(x2) + 1/8 = 0

F(x) = cos (x) - sin (x2) + 1/8= 0

F(x) = 12(x - cos (x) ) - 1/4 = 0

F(x) = 12(x - cos (x) ) - 3/4 = 0

F(x) = 12(x - sin (x) ) - 1/4 = 0

F(x) = 12(x - sin (x) ) - 3/4 = 0

F(x) = 12(x - cos (x) ) - x = 0

F(x) = 12(x - cos (x) ) + 2x = 0


New Page 4

Решение системы линейных уравнений

a11x + a12x + …+ a1n = b1

a21x + a22x + …+ a2n = b2

………………………….

An1x + an2x + …+ amn = bn

Известно, что в матричной форме справедливо A x X = B X = A-1 x B.

Тогда

Правило Крамера: Соответствующий столбец матрицы А заменяется столбцом свободных членов В. Далее ищется частное от деления определителя этой матрицы на определитель матрицы А, это и будет один из корней системы.

Тогда

Встроенная функция для нахождения корней системы уравнений lsolve, тогда

Задание 3

Решить систему линейных уравнений

Вариант

Система

X + y – z + t = 4

2x – y + 3z – 2t =1

x – y + 2t =6

3x – y + z – t = 0

2x + y – z =5

x – 2y + 2z = -5

7x + y – z = 10

X + y – z + t = 4

2x – y + 3z – 2t = 1

x –y + 2t =6

3x – y + z – t = 0

0.04x – 0.08y + 4z = 20

4x + 0.24y – 0.08z = 8

0.09x + 3y – 0.15z = 9

6x – 5y +7z + 8t = 3

3x + 11y + 2z + 4t = 6

3x + 2y + 3z + 4t = 1

x + y + z = 0

X + y – z + t = 4

2x – y + 3z – 2t = 1

x – y + 2t = 6

3x – y +z – t = 0

6x – 5y + 7z + 8t = 3

3x + 11y + 2z + 4t = 6

3x + 2y +3z + 4t = 1

x + y + z = 0

X – y + z – t = -2

X = 2y – 2z – t = -5

2x – y – 3z + 2t = -1

x + 2y + 3z – 6t = -10

X – y + z – t = -2

X + 2y – 2z – t = -5

2x – y – 3z + 2t = -1

x + 2y +3z – 6t = -10

3x1 –x2 + x3 + 2x5 = 18

2x1 – 5x2 + x4 + x5 = -7

x1 – x4 + 2x5 = 8

2x2 + x3 + x4 – x5 = 10

x1 + x2 – 3x3 + x4 = 1


New Page 5

Разложение функции в степенной ряд

Часто возникает необходимость в представлении определенных функций F(x) в виде степенного ряда. В одних случаях число членов ряда конечно (бином Ньютона), в других – бесконечно (элементарные функции).

Способы:

  1. Средствами символьной математики (прием 6)
  2. Путем обращения к встроенной функции (прием 2)

Прием 6

На лист вывести выражение, выделить переменную, по которой будет производится разложение, после чего выполнить команду меню Symbolic ® Variable ® Expand to Series (Символы ® Переменные ® Разложить на составляющие).

Прием 2

На лист вывести выражение, а затем воспользоваться панелью инструментов Symbolic (Символы), а именно кнопками series (■,■) ® (бесконечный ряд: первый параметр – переменная, по которой идет разложение, второй – максимальная степень разложения) или expand,■ ® (конечный ряд: парметр - переменная, по которой идет разложение).

Задание 4

Вариант

Функция

(x6 – y6) / (x – y)

(x5 – y5) / (x – y)

(x5 + y5) / (x + y)

Cos(x)

ex

Sin(x)

Sin(x) * cos(x)

6 * sin(x)

Sin(x) + cos(x)

5 * cos(x)


New Page 6

Разложение функции на элементарные дроби

Любое отношение двух функций, представляющих многочлены, может быть разложено на элементарные дроби. Для этого функция записывается на лист, выделяется аргумент, после чего выполняется группа команд Symbolic ® Variable ® Convent to partial Fractions (Символы ® Переменные ® Преобразование в частичные доли)

Задание 5

Разложить функцию на элементарные дроби

Вариант

Функция


new_page_7

Дифференцирование функций

Дифференцирование можно осуществить следующими способами:

- численно с помощью инструментальной панели Calculus (Исчисления);

- символьно с помощью инструментальных панелей Calculus (Исчисления) и Symbolic (Символы);

- символьно с помощью инструментальной панели Calculus (Исчисления) и меню Symbolic ® Evalution ® Symbolically (Символы ® Расчеты ® Символические);

- символьно с помощью меню Symbolic ® Variable ® Differentiate (Символы ® Переменные ® Дифференциалы (перед обращением к меню переменную, по которой идет дифференцирование, необходимо выделить).

Задание 6

Произвести дифференцирование функции (численно и символьно), при численном дифференцировании значение Х задать самостоятельно.

Вариант | Функция
1. |
2. |
3. |
4. |
5. |
6. |
7. |
8. |
9. |
10. |


New Page 8

Интегрирование функций

Интегрирование можно осуществить следующими способами:

- численно с помощью инструментальной панели Calculus (Исчисления) задавая пределы интегрирования;

- символьно с помощью инструментальных панелей Calculus (Исчисления) и Symbolic (Символы);

- символьно с помощью инструментальной панели Calculus (Исчисления) и меню Symbolic ® Evalution ® Symbolically (Символы ® Расчеты ® Символические);

- символьно с помощью меню Symbolic ® Variable ® Differentiate (Символы ® Переменные ® Дифференциалы (перед обращением к меню переменную, по которой идет дифференцирование, необходимо выделить).

Задание 7

Произвести интегрирование функции (численно и символьно). В формулах c, t, a рассматривать как параметры, пределы интегрирования задать самостоятельно.

Вариант | Функция
1. | x^2exp(-x^2)
2. | (x-t)/(x^2+c)
3. | (ln(x))^3
4. | atan(x/5)*x
5. | X/(1+exp(x))^2
6. | X*sinh(a*x)
7. | Sin(ln(x))
8. | X^3exp(x)
9. | X/(1+exp(x))
10. | X*atan(x/a)