Получение информации

Поиск необходимой информации
Получение информации

Темы в этом разделе

  • Поиск необходимой информации

    Существуют разные способы поиска информации о том, как пользоваться данной программой. Доступен ряд ресурсов.

  • Получение сведений из чертежей

    Можно извлекать общие сведения из чертежа, в том числе идентификационные сведения и количество содержащихся в чертеже объектов.

Отправьте ваши комментарии по поводу этой страницы


Поиск необходимой информации

Получение информации
Получение информации
Поиск и получение информации
Получение информации >
Поиск необходимой информации

Существуют разные способы поиска информации о том, как пользоваться данной программой. Доступен ряд ресурсов.

Темы в этом разделе

  • Поиск и получение информации

    Для поиска разнообразных источников информации с помощью одного запроса можно использовать Инфоцентр в верхней правой части окна приложения. Также легко доступны обновления продукта и уведомления.

  • Эффективное использование справочной системы

    Умение эффективно использовать справочную систему может быть полезным при использовании программы.

  • Подробнее о новых функциях

    Раздел "Новые возможности" знакомит пользователя с новыми возможностями в AutoCAD.

  • Обучение работе с программой

    Обучающие программы и продукты от Autodesk помогают пользователям осваивать ключевые технические характеристики и повышать производительность. Для получения последних сведений об обучающих программах Autodesk см. http://www.autodesk.com/training-rus или свяжитесь со своим местным офисом Autodesk.

  • Доступ к Центру подписки

    Подписчики могут обращаться в Центр подписки непосредственно из программы. Подписчик может получить доступ к услугам по подписке, нажав кнопку "Коммуникационный центр" на поле "Инфоцентр" в верхней правой части окна приложения и щелкнув затем ссылку "Центр подписки". Дополнительные сведения об участии в программе подписки Autodesk представлены на веб-узле по адресу http://www.autodesk.com/subscription-rus.

  • Просмотр файла дополнительных сведений (Readme)

    Последние сведения об этой программе см. в файле Readme.

  • Где найти AutoCAD Express Tools, тома 1-9

    Тома 1-9 Express Tools AutoCAD содержат библиотеку инструментов повышения производительности, предназначенных для расширения функциональных возможностей AutoCAD. Они легки в использовании, их легко интегрировать в пользовательские меню и панели инструментов. Они охватывают широкий диапазон функций AutoCAD (включая задание размеров, построение, выбор и изменение объектов).

  • Присоединяйтесь к программе вовлечения пользователей

    Предлагается принять участие в содействии разработке чертежного программного обеспечения САПР корпорации Autodesk.


Поиск и получение информации

Поиск необходимой информации
Поиск необходимой информации
Обзор поиска и получения информации
Получение информации > Поиск необходимой информации >
Поиск и получение информации
Понятие Процедура

Для поиска разнообразных источников информации с помощью одного запроса можно использовать Инфоцентр в верхней правой части окна приложения. Также легко доступны обновления продукта и уведомления.

Темы в этом разделе

  • Обзор поиска и получения информации

    Можно воспользоваться Инфоцентром, находящемся в верхней правой части окна приложения, для поиска сведений с помощью ключевых слов (или фраз), отобразить панель коммуникационного центра для обновления продукта и получения уведомлений, или вывести на экран панель избранного для доступа к сохраненным разделам.

  • Поиск информации

    Инфоцентр можно использовать для одновременного поиска в нескольких источниках (например, в Справке, в Семинаре по новым возможностям, веб-ресурсах и в указанных файлах) или для поиска в отдельно взятом файле или местоположении.

  • Получение новостей и обновлений программы

    Коммуникационный центр обеспечивает доступ к новейшим сведениям о продукте, обновлениям программного обеспечения, уведомлениям службы поддержки продукта и другим уведомлениям, имеющим отношение к продукту.

  • Сохранение избранных разделов и переход к ним

    В Инфоцентре можно сохранять ссылки в качестве избранных и легко обращаться к ним в дальнейшем.

  • Задание параметров Инфоцентра

    Параметры поиска Инфоцентра и Коммуникационного центра можно задать в диалоговом окне "Параметры Инфоцентра".


Поиск и получение информации (Процедура)

Поиск и получение информации
Обзор поиска и получения информации
Получение информации > Поиск необходимой информации > Поиск и получение информации >
Поиск и получение информации
Понятие Процедура

Переупорядочение разделов, отображаемых на панели

Обзор результатов поиска, отображаемых на панели

Поиск информации в нескольких источниках

Поиск информации в одной области

Добавление области для поиска

Вывод панели "Избранное Инфоцентра"

Сохранение ссылки в Инфоцентре в качестве избранной

Удаление избранной ссылки с панели "Избранное Инфоцентра"

Указание области для поиска информации

Добавление новой области для поиска информации

Удаление области для поиска информации

Указание области и имени канала CAD Manager

Указание каналов для отображения на панели "Коммуникационный центр"

Задание параметров всплывающих уведомлений Инфоцентра

Включение отображения скрытых сообщений с полезными советами

Добавление RSS-канала в Коммуникационный центр

Удаление RSS-канала из Коммуникационного центра


Обзор поиска и получения информации (Понятие)

Поиск и получение информации
Поиск и получение информации
Поиск информации
Получение информации > Поиск необходимой информации > Поиск и получение информации >
Обзор поиска и получения информации
Понятие Процедура

Можно воспользоваться Инфоцентром, находящемся в верхней правой части окна приложения, для поиска сведений с помощью ключевых слов (или фраз), отобразить панель коммуникационного центра для обновления продукта и получения уведомлений, или вывести на экран панель избранного для доступа к сохраненным разделам.

Чтобы свернуть окно Инфоцентра достаточно щелкнуть стрелку слева от поля "Инфоцентр". При вводе ключевых слов или фразы и последующем нажатии клавиши ENTER или кнопки "Инфоцентр" [image] выполняется поиск в нескольких справочных ресурсах, а также во всех файлах, указанных в диалоговом окне "Параметры Инфоцентра". Результаты отображаются в виде ссылок на панели. На любой из этих ссылок можно щелкнуть для вывода раздела справки, статьи или документа.

ПримечаниеРекомендуется для поиска информации использовать ключевые слова, так как именно они часто приводят к лучшим результатам. При наличии в слове орфографических ошибок отображаются варианты правильного написания.

Показать: получение информации с помощью Инфоцентра

Для запуска анимации нажмите на стрелку "Показать".

При нажатии кнопки "Коммуникационный центр" [image] выводится панель "Коммуникационный центр". Она отображает ссылки на информацию об обновлениях продукта и уведомлениях, а также может включать ссылки на Центр подписки, определенные файлы CAD Manager и RSS-каналы.

При нажатии кнопки "Избранное" [image] на панели отображаются сохраненные ссылки на разделы или веб-ресурсы.

Для просмотра результатов поиска пользуйтесь кнопками "Следующий" и "Предыдущий". Категории и группы можно переупорядочивать с помощью перетаскивания.

См. также

    • Эффективное использование справочной системы

    • Подробнее о новых функциях


Обзор поиска и получения информации (Процедура)

Поиск и получение информации
На уровень вверх ..
Обзор поиска и получения информации
Получение информации > Поиск необходимой информации > Поиск и получение информации > Обзор поиска и получения информации >
Обзор поиска и получения информации
Понятие Процедура

Переупорядочение разделов, отображаемых на панели

Обзор результатов поиска, отображаемых на панели


Переупорядочение разделов, отображаемых на панели (Процедура)

Обзор поиска и получения информации
На уровень вверх ..
Обзор поиска и получения информации
Получение информации > Поиск необходимой информации > Поиск и получение информации > Обзор поиска и получения информации >
Обзор поиска и получения информации
Понятие Процедура

Переупорядочение разделов, отображаемых на панели

  1. Выведите панель, выполнив одно из следующих действий:
    • В верхней правой части окна приложения в поле "Инфоцентр" введите ключевое слово или фразу. Затем нажмите клавишу ENTER или кнопку "Инфоцентр" [image].
    • В верхней правой части окна приложения в поле "Инфоцентр" нажмите кнопку "Коммуникационный центр" [image].
    • В верхней правой части окна приложения в поле "Инфоцентр" нажмите кнопку "Избранное" [image].
  2. Перетащите категорию или заголовок группы в нужное положение.
  3. Отпустите кнопку мыши.
ПримечаниеКатегории можно переупорядочить только в пределах группы и нельзя переместить в другие группы.


Обзор результатов поиска, отображаемых на панели (Процедура)

Обзор поиска и получения информации
На уровень вверх ..
Поиск информации
Получение информации > Поиск необходимой информации > Поиск и получение информации > Обзор поиска и получения информации >
Обзор поиска и получения информации
Понятие Процедура

Обзор результатов поиска, отображаемых на панели

  1. На панели "Результаты поиска" Инфоцентра, "Коммуникационный центр" или "Избранное" в правой части заголовка категории выполните одно из следующих действий:
    • Нажмите кнопку "Следующий" [image].
    • Нажмите кнопку "Предыдущий" [image].


Поиск информации (Понятие)

Обзор поиска и получения информации
Поиск и получение информации
Получение новостей и обновлений программы
Получение информации > Поиск необходимой информации > Поиск и получение информации >
Поиск информации
Понятие Процедура

Инфоцентр можно использовать для одновременного поиска в нескольких источниках (например, в Справке, в Семинаре по новым возможностям, веб-ресурсах и в указанных файлах) или для поиска в отдельно взятом файле или местоположении.

При вводе ключевых слов или фразы в поле "Инфоцентр" в правой верхней части окна приложения и последующем нажатии клавиши ENTER или кнопки "Инфоцентр" выполняется поиск в содержимом нескольких справочных ресурсов, а также во всех дополнительных документах и веб-ресурсах, указанных в диалоговом окне "Параметры Инфоцентра" или с помощью диспетчера Интернет-компонентов. Результаты отображаются в виде ссылок на панели "Результаты поиска" Инфоцентра. На любой из этих ссылок можно щелкнуть для вывода раздела справки, статьи или документа. Для отображения результатов интерактивного поиска Autodesk необходимо иметь доступ в Интернет.

ПримечаниеРекомендуется для поиска информации использовать ключевые слова, так как именно они часто приводят к лучшим результатам. При наличии в слове орфографических ошибок отображаются варианты правильного написания.

Показать: получение информации с помощью Инфоцентра

Для запуска анимации нажмите на стрелку "Показать".

Также можно выполнить поиск в отдельной папке, щелкнув на стрелке рядом с кнопкой "Инфоцентр" и выбрав из списка папку или файл.

Кроме того, можно добавить область для поиска (файла или документа), щелкнув на стрелке рядом с кнопкой "Инфоцентр" и выбрав из списка пункт "Добавление области поиска".

При поиске информации с помощью Инфоцентра можно использовать указанные ниже специальные символы (подстановочные знаки) в своем запросе для его уточнения или расширения. Эти символы могут использоваться как по отдельности, так и совместно.

Обозначение | Описание
* | Заменяет один или несколько символов при использовании в начале, середине или конце слова. Например, по "*lish", "p*lish" или "pub*" будет найдено "publish". Точно также по "anno*" будут найдены "annotative", "annotation", "annoupdate", "annoreset", и т. д.
? | Заменяет один символ. Например, по "cop?" отыщется "copy", но не отыщется "copybase".
~ | Расширяет понятие грамматического времени слова в начале или конце слова. Например, по "plotting~" найдутся "plots", "plotted" и т. д. Точно также по "~plot" найдутся "preplot", "replot" и т. д.

При поиске нескольких слов в разделах следует заключать в кавычки (" ") те слова, которые должны находиться рядом друг с другом в указанной последовательности. Например, для поиска разделов, в которых содержится фраза "задающий единицы измерения", следует ввести данные слова именно в этом порядке. Упомянутые выше символы (подстановочные знаки) также можно использовать в текстовой строке, заключаемой в двойные кавычки.

См. также

    • Задание параметров Инфоцентра

    • Эффективное использование справочной системы


Поиск информации (Процедура)

Обзор поиска и получения информации
На уровень вверх ..
Поиск информации
Получение информации > Поиск необходимой информации > Поиск и получение информации > Поиск информации >
Поиск информации
Понятие Процедура

Поиск информации в нескольких источниках

Поиск информации в одной области

Добавление области для поиска


Поиск информации в нескольких источниках (Процедура)

Поиск информации
На уровень вверх ..
Поиск информации
Получение информации > Поиск необходимой информации > Поиск и получение информации > Поиск информации >
Поиск информации
Понятие Процедура

Поиск информации в нескольких источниках

  1. В верхней правой части приложения в поле "Инфоцентр" введите ключевое слово или фразу.
  2. Нажмите клавишу ENTER, затем кнопку "Инфоцентр" или щелкните на стрелке рядом с кнопкой "Инфоцентр" и выберите "Все области поиска".

    Результаты поиска отображаются на панели "Результаты поиска".


Поиск информации в одной области (Процедура)

Поиск информации
На уровень вверх ..
Поиск информации
Получение информации > Поиск необходимой информации > Поиск и получение информации > Поиск информации >
Поиск информации
Понятие Процедура

Поиск информации в одной области

  1. В верхней правой части приложения в поле "Инфоцентр" введите ключевое слово или фразу.
  2. Щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  3. Выберите область из списка для поиска.

  4. Результаты поиска из данной области отображаются на панели "Результаты поиска".


Добавление области для поиска (Процедура)

Поиск информации
На уровень вверх ..
Сохранение избранных разделов и переход к ним
Получение информации > Поиск необходимой информации > Поиск и получение информации > Поиск информации >
Поиск информации
Понятие Процедура

Добавление области для поиска

  1. В верхней правой части приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Щелкните "Добавление области поиска".
  3. В диалоговом окне "Добавление области поиска" укажите область документа или файла для поиска.
  4. Нажать "Добавить".


Получение новостей и обновлений программы

Поиск информации
Поиск и получение информации
Коммуникационный центр
Получение информации > Поиск необходимой информации > Поиск и получение информации >
Получение новостей и обновлений программы

Коммуникационный центр обеспечивает доступ к новейшим сведениям о продукте, обновлениям программного обеспечения, уведомлениям службы поддержки продукта и другим уведомлениям, имеющим отношение к продукту.

Темы в этом разделе

  • Коммуникационный центр
  • Получение уведомлений о наличии новой информации

    Каждый раз при появлении новой информации Коммуникационный центр уведомляет пользователя, выводя всплывающее сообщение под кнопкой "Коммуникационный центр" в поле "Инфоцентр".


Коммуникационный центр

Получение новостей и обновлений программы
Получение новостей и обновлений программы
Получение уведомлений о наличии новой информации
Получение информации > Поиск необходимой информации > Поиск и получение информации > Получение новостей и обновлений программы >
Коммуникационный центр

Чтобы открыть коммуникационный центр, нажмите кнопку "Коммуникационный центр" [image] на поле "Инфоцентр", расположенном в верхней правой части приложения.

Показать: переход к Коммуникационному центру

Для запуска анимации нажмите на стрелку "Показать".

С помощью Коммуникационного центра можно получать следующую информацию:

  • Информация о поддержке программы. Последние новости от службы поддержки программы Autodesk, в том числе при выпуске обновлений по сети.
  • Объявления о подпискеПолучение объявлений о подписке и новостей о программе подписки, а также ссылок на уроки e-Learning, если пользователь является подписчиком Autodesk (доступно в странах/регионах, в которых предлагается подписка Autodesk). Для получения подробной информации о подписке Autodesk см. Доступ к Центру подписки.
  • Статьи и советы. Уведомления о появлении свежих статей и советов на веб-сайте Autodesk.
  • Канал CAD Manager.Получение информации (по RSS-каналам), публикуемой CAD manager.
  • RSS-каналы.Получение информации от RSS-каналов по подписке. (RSS-канал является информацией, которую публикует веб-узел по подписке. RSS-каналы, как правило, уведомляют пользователя о появлении нового содержимого.) Несколько RSS-каналов по умолчанию автоматически подписываются при установке программы.
  • Вставки техобслуживания для обновлений по сети Получение автоматических уведомлений о новых вставках техобслуживания, выпускаемых Autodesk.
  • Технологии и содержимое Подробнее о содержимом и приложениях сторонних разработчиков

Пользователь может настраивать элементы, отображаемые на панели "Коммуникационный центр". Для получения дополнительной информации см. раздел Задание параметров Инфоцентра.

Политика конфиденциальности в Коммуникационном центре

Коммуникационный центр является интерактивным средством, которое должно быть подключено к Интернету для доставки содержимого и информации. Каждый раз при подключении к Интернету Коммуникационный центр посылает данные в корпорацию Autodesk, так что пользователь получает корректную информацию. При этом частные права владельца экземпляра программного продукта не нарушаются, так как обмен информацией происходит анонимно.

В Autodesk отправляются следующие сведения:

  • Наименование продукта (в котором используется Коммуникационный центр)
  • Номер версии продукта
  • Язык продукта
  • Страна/регион (указывается в параметрах Коммуникационного центра)
  • Номер договора подписки пользователя (если пользователь — подписчик)

Autodesk ведет статистику информации, передаваемой Коммуникационным центром для контроля его использования и определения направлений его усовершенствования. Autodesk использует информацию, предоставленную пользователем или полученную от него, в соответствии с политикой конфиденциальности Autodesk, с которой можно ознакомиться на веб-узле http://www.autodesk.com/privacy-rus.

См. также

    • Задание параметров Инфоцентра

    • Доступ к Центру подписки


Получение уведомлений о наличии новой информации

Коммуникационный центр
Получение новостей и обновлений программы
Сохранение избранных разделов и переход к ним
Получение информации > Поиск необходимой информации > Поиск и получение информации > Получение новостей и обновлений программы >
Получение уведомлений о наличии новой информации

Каждый раз при появлении новой информации Коммуникационный центр уведомляет пользователя, выводя всплывающее сообщение под кнопкой "Коммуникационный центр" в поле "Инфоцентр".

Чтобы открыть статью или уведомление, щелкните на ссылке во всплывающем сообщении. Если в уведомлении от Коммуникационного центра нет необходимости, можно отключить "Всплывающие уведомления" в диалоговом окне "Параметры Инфоцентра". Можно также настроить прозрачность всплывающих сообщений и продолжительность их отображения.

См. также

    • Задание параметров Инфоцентра


Сохранение избранных разделов и переход к ним (Понятие)

Получение уведомлений о наличии новой информации
Поиск и получение информации
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации >
Сохранение избранных разделов и переход к ним
Понятие Процедура

В Инфоцентре можно сохранять ссылки в качестве избранных и легко обращаться к ним в дальнейшем.

Любая ссылка, которая отображается на панели "Результаты поиска" Инфоцентра или Коммуникационного центра, может быть отмечена в качестве избранной. Ссылки, отмеченные в качестве избранных, отображаются на панели "Избранное". Панель "Избранное" отображается путем нажатия кнопки "Избранное" [image] в поле "Инфоцентр", расположенном в верхней правой части приложения.

Показать: сохранение избранных разделов и переход к ним с помощью Инфоцентра

Для запуска анимации нажмите на стрелку "Показать".

На панелях "Результаты поиска" и "Коммуникационный центр" рядом со ссылками, помеченными как избранные, отображается значок в виде звездочки [image]. Для снятия состояния ссылки как "избранной" можно щелкнуть на значке звездочки. При этом ссылка удаляется с панели "Избранное".


Сохранение избранных разделов и переход к ним (Процедура)

Поиск информации
На уровень вверх ..
Сохранение избранных разделов и переход к ним
Получение информации > Поиск необходимой информации > Поиск и получение информации > Сохранение избранных разделов и переход к ним >
Сохранение избранных разделов и переход к ним
Понятие Процедура

Вывод панели "Избранное Инфоцентра"

Сохранение ссылки в Инфоцентре в качестве избранной

Удаление избранной ссылки с панели "Избранное Инфоцентра"


Вывод панели "Избранное Инфоцентра" (Процедура)

Сохранение избранных разделов и переход к ним
На уровень вверх ..
Сохранение избранных разделов и переход к ним
Получение информации > Поиск необходимой информации > Поиск и получение информации > Сохранение избранных разделов и переход к ним >
Сохранение избранных разделов и переход к ним
Понятие Процедура

Вывод панели "Избранное Инфоцентра"

  • В верхней правой части приложения в поле "Инфоцентр" нажмите кнопку "Избранное" [image], чтобы отобразить панель "Избранное".
ПримечаниеСсылки, отображаемые на панели "Избранное", упорядочиваются в те же группы или категории, из которых они были добавлены.


Сохранение ссылки в Инфоцентре в качестве избранной (Процедура)

Сохранение избранных разделов и переход к ним
На уровень вверх ..
Сохранение избранных разделов и переход к ним
Получение информации > Поиск необходимой информации > Поиск и получение информации > Сохранение избранных разделов и переход к ним >
Сохранение избранных разделов и переход к ним
Понятие Процедура

Сохранение ссылки в Инфоцентре в качестве избранной

  1. Выведите панель, выполнив одно из следующих действий:
    • В верхней правой части приложения в поле "Инфоцентр" введите ключевое слово или фразу. Затем нажмите клавишу ENTER или кнопку "Инфоцентр".
    • В верхней правой части приложения в поле "Инфоцентр" нажмите кнопку "Коммуникационный центр".
  2. Щелкните значок звездочки [image], отображающийся рядом со ссылкой, которую требуется сохранить в качестве избранной.


Удаление избранной ссылки с панели "Избранное Инфоцентра" (Процедура)

Сохранение избранных разделов и переход к ним
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Сохранение избранных разделов и переход к ним >
Сохранение избранных разделов и переход к ним
Понятие Процедура

Удаление избранной ссылки с панели "Избранное Инфоцентра"

  1. В верхней правой части окна приложения в поле "Инфоцентр" нажмите кнопку "Избранное" [image], чтобы отобразить панель "Избранное".
  2. Щелкните значок звездочки [image], отображающийся рядом со ссылкой, которую требуется удалить с панели "Избранное".


Задание параметров Инфоцентра (Понятие)

Сохранение избранных разделов и переход к ним
Поиск и получение информации
Эффективное использование справочной системы
Получение информации > Поиск необходимой информации > Поиск и получение информации >
Задание параметров Инфоцентра
Понятие Процедура

Параметры поиска Инфоцентра и Коммуникационного центра можно задать в диалоговом окне "Параметры Инфоцентра".

В диалоговом окне "Параметры Инфоцентра" можно задать следующие параметры:

  • Общие Текущие области пользователя, периодичность проверки на наличие нового интерактивного содержимого, анимационные переходные эффекты для панелей.
  • Области поиска. Области (документы, веб-ресурсы и файлы) для поиска информации, а также имена, отображаемые для каждой области, и количество результатов, отображаемых для каждой области. К тому же, можно добавлять и удалять области поиска. Флажок "Веб-ресурсы" предоставляет доступ к важным сведениям на веб-сайте Autodesk, включая базу знаний и группы обсуждения. При добавлении областей документов можно указывать файлы на локальном диске или файлы в сети.
    ПримечаниеУказываемые пользователем файлы CHM должны находиться на его локальном диске. Инфоцентр позволяет искать CHM-файлы, расположенные на сетевых дисках.
  • Коммуникационный центр. Максимальный возраст статей, отображаемых на панели "Коммуникационный центр", а также область и имя канала CAD Manager.
  • Каналы Autodesk. Каналы, отображаемые на панели "Коммуникационный центр", а также количество статей, отображаемых для каждого канала.
  • Всплывающие уведомления. Уведомления об информации по новым продуктам, обновления программ, новости службы технической поддержки и сообщения с полезными советами. К тому же, можно настроить прозрачность и время отображения всплывающей подсказки.
    ПримечаниеПодсказки с полезными советами, отображающиеся под кнопкой коммуникационного центра в поле "Инфоцентр", предоставляют сведения базы знаний и обучающие сообщения общего характера, например, советы. Для просмотра подробных сведений щелкните текст или значок "Развернуть" [image], чтобы развернуть всплывающую подсказку.
  • RSS-каналы. Подписка RSS-каналов. RSS-каналы можно добавлять и удалять. (RSS-канал является информацией, которую публикует веб-узел по подписке. RSS-каналы, как правило, уведомляют пользователя о появлении нового содержимого.) Несколько RSS-каналов по умолчанию автоматически подписываются при установке программы.

Для запуска анимации нажмите на стрелку "Показать".

Для задания параметров поиска Инфоцентра и Коммуникационного центра можно использовать Диспетчер Интернет-компонентов. Для задания параметров каналов CAD Manager используется Диспетчер Интернет-компонентов. Для получения подробной информации об установке и запуске утилиты см. Установка и запуск "Диспетчера Интернет-компонентов". Щелкните "Справка" в окне "Диспетчер Интернет-компонентов" для получения информации по управляемым настройкам.


Задание параметров Инфоцентра (Процедура)

Сохранение избранных разделов и переход к ним
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Указание области для поиска информации

Добавление новой области для поиска информации

Удаление области для поиска информации

Указание области и имени канала CAD Manager

Указание каналов для отображения на панели "Коммуникационный центр"

Задание параметров всплывающих уведомлений Инфоцентра

Включение отображения скрытых сообщений с полезными советами

Добавление RSS-канала в Коммуникационный центр

Удаление RSS-канала из Коммуникационного центра


Указание области для поиска информации (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Указание области для поиска информации

  1. В верхней правой части окна приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Выберите щелчком "Параметры поиска".
  3. На панели "Области поиска" диалогового окна "Параметры Инфоцентра" в правой панели выберите или уберите области поиска, которые требуется включить или исключить при поиске информации.
    ПримечаниеМожно непосредственно щелкнуть имя области поиска, чтобы изменить имя в правой панели диалогового окна "Параметры".
  4. Нажать "ОК".
ПримечаниеС помощью параметра "Поиск всех имеющихся языков" можно указать, следует ли искать язык по умолчанию или все доступные языки. Данный параметр не задан по умолчанию.


Добавление новой области для поиска информации (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Добавление новой области для поиска информации

  1. В верхней правой части приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Выберите щелчком "Параметры поиска".
  3. В диалоговом окне "Параметры Инфоцентра" выполните одно из следующих действий:
    • На панели "Области поиска" в правой части щелкните "Добавить".
    • На панели "Области поиска" в правой части щелкните правой кнопкой мыши в любом месте. Нажать "Добавить".
  4. В диалоговом окне "Добавление RSS-канала" укажите местоположение файла для поиска.
    ПримечаниеМожно указать файл на локальном диске или в сети.
  5. Нажать "Добавить".
  6. Нажать "ОК".


Удаление области для поиска информации (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Удаление области для поиска информации

  1. В верхней правой части приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Выберите щелчком "Параметры поиска".
  3. В диалоговом окне "Параметры Инфоцентра" выполните одно из следующих действий:
    • Выберите область для удаления и щелкните на "Удалить".
    • Щелкните правой кнопкой мыши на области поиска. Нажмите кнопку "Исключить".
  4. Для удаления выбранной области щелкните на "Да" в диалоговом окне "Исключение области для поиска".
  5. Нажмите ОК.


Указание области и имени канала CAD Manager (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Указание области и имени канала CAD Manager

  1. Нажмите кнопку "Пуск" (Windows) и последовательно выберите пункты меню "Все программы" (или "Программы"), "Autodesk", "CAD Manager Tools", "Диспетчер Интернет-компонентов".
  2. Выберите продукт, который требуется изменить. Нажмите ОК.
  3. В окне "Диспетчер Интернет-компонентов" на вкладке "Инфоцентр" включите канал CAD Manager.
  4. Введите подходящий канал в группе "Адрес RSS-канала".
  5. Введите для CAD Manager отображаемое имя и щелкните "Применить". Нажмите ОК.
  6. Перезапустите AutoCAD.
  7. В верхней правой части окна приложения в поле "Инфоцентр" щелкните стрелку рядом с кнопкой "Инфоцентр".
  8. Выберите щелчком "Параметры поиска".
  9. В диалоговом окне "Параметры Инфоцентра" в левой части выберите щелчком "Коммуникационный центр": Отобразятся местоположение и имя канала CAD Manager.
ПримечаниеЕсли канал может быть найден, отображается зеленая галочка. Если канал не может быть найден, отображается желтый предупреждающий знак.


Указание каналов для отображения на панели "Коммуникационный центр" (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Указание каналов для отображения на панели "Коммуникационный центр"

  1. В верхней правой части окна приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Выберите щелчком "Параметры поиска".
  3. В диалоговом окне "Параметры Инфоцентра" в левой части щелкните "Каналы Autodesk":
  4. В правой части выберите или исключите каналы, отображаемые на панели "Коммуникационный центр".
  5. Нажмите ОК.


Задание параметров всплывающих уведомлений Инфоцентра (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Задание параметров всплывающих уведомлений Инфоцентра

  1. В верхней правой части окна приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Выберите щелчком "Параметры поиска".
  3. В диалоговом окне "Параметры Инфоцентра" в левой части выберите щелчком "Всплывающие уведомления":
  4. В правой части выберите или отключите настройку для включения или отключения всплывающих уведомлений.
    ПримечаниеВсплывающее уведомление для сообщений с полезными советами можно отключить в диалоговом окне "Параметры Инфоцентра".
  5. Введите количество секунд, установив тем самым продолжительность отображения всплывающих уведомлений.
    ПримечаниеВремя отображения всплывающего уведомления установлено по умолчанию равным 5 секундам.
  6. Введите значение прозрачности всплывающего элемента или задайте значение с помощью регулятора.
  7. Нажмите ОК.


Включение отображения скрытых сообщений с полезными советами (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Включение отображения скрытых сообщений с полезными советами

  1. Выберите меню Сервис [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Параметры" на вкладке "Система" в группе "Общие параметры" нажмите кнопку "Параметры скрытых сообщений".
  3. Чтобы включить отображение всех скрытых сообщений, в диалоговом окне "Параметры скрытых сообщений" выберите параметр "Всплывающие сообщения Инфоцентра". Нажмите "ОК".
  4. Нажмите ОК.


Добавление RSS-канала в Коммуникационный центр (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Задание параметров Инфоцентра
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Добавление RSS-канала в Коммуникационный центр

  1. В верхней правой части окна приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Выберите щелчком "Параметры поиска".
  3. В диалоговом окне "Параметры Инфоцентра" в левой части выберите щелчком "RSS-каналы":
  4. В правой части выполните одно из следующих действий:
    • Нажать "Добавить".
    • Щелкните правой кнопкой мыши на любом месте в правой части. Нажать "Добавить".
  5. В диалоговом окне "Добавление RSS-канала" введите область RSS-канала, который требуется добавить.
  6. Нажать "Добавить".
  7. Нажать "ОК".


Удаление RSS-канала из Коммуникационного центра (Процедура)

Задание параметров Инфоцентра
На уровень вверх ..
Эффективное использование справочной системы
Получение информации > Поиск необходимой информации > Поиск и получение информации > Задание параметров Инфоцентра >
Задание параметров Инфоцентра
Понятие Процедура

Удаление RSS-канала из Коммуникационного центра

  1. В верхней правой части окна приложения в поле "Инфоцентр" щелкните на стрелке рядом с кнопкой "Инфоцентр" [image].
  2. Выберите щелчком "Параметры поиска".
  3. В диалоговом окне "Параметры Инфоцентра" в левой части выберите щелчком "RSS-каналы":
  4. В правой части выполните одно из следующих действий:
    • Нажмите кнопку "Исключить".
    • Нажмите правую кнопку мыши на RSS-канале. Нажмите кнопку "Исключить".
  5. В диалоговом окне "Удаление подписки на RSS" нажмите "Да" для удаления выбранного поля RSS.
  6. Нажмите ОК.


Эффективное использование справочной системы

Задание параметров Инфоцентра
Поиск необходимой информации
Поиск информации в справочной системе
Получение информации > Поиск необходимой информации >
Эффективное использование справочной системы
Понятие Процедура

Умение эффективно использовать справочную систему может быть полезным при использовании программы.

Справка содержит полную информацию об этой программе. Для выбора темы служит левая область окна справочной системы. С помощью вкладок в верхней части левой области можно выбирать способ поиска информации. В правой области окна выводится справочная информация по выбранной теме.

Темы в этом разделе

  • Поиск информации в справочной системе

    Поиск информации может выполняться различными способами в зависимости от того, какая вкладка активна в левой области окна.

  • Средства поиска

    Вкладка "Поиск" служит для поиска требуемых разделов по ключевым словам, введенным пользователем.

  • Организация разделов справочной системы

    В большинстве разделов справки в верхней части правой панели окна справки есть три вкладки. На вкладках отображаются различные виды информации.

  • Печать разделов справочной системы

    Самый простой способ печати текущего раздела - нажмите на нем правую кнопку мыши и выберите "Печать".

  • Показ и скрытие панели содержания

    Кнопкой "Скрыть" на панели инструментов справочной системы окно справки уменьшается до компактных размеров за счёт исчезновения панели, содержащей вкладки "Содержание", "Указатель" и "Поиск".

  • Получение дополнительной информации

    Существует ряд дополнительных способов получения справочной информации.


Эффективное использование справочной системы (Процедура)

Задание параметров Инфоцентра
Эффективное использование справочной системы
Поиск информации в справочной системе
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы >
Эффективное использование справочной системы
Понятие Процедура

Вызов справочной системы

Использование панели содержания справочной системы

Для поиска информации в справочной системе

Смена типа отображаемой справочной информации

Печать раздела справочной системы

Печать выбранного раздела и всех вложенных разделов


Поиск информации в справочной системе (Понятие)

Эффективное использование справочной системы
Эффективное использование справочной системы
Средства поиска
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы >
Поиск информации в справочной системе
Понятие Процедура Краткий справочник

Поиск информации может выполняться различными способами в зависимости от того, какая вкладка активна в левой области окна.

Для поиска определенного слова или фразы в текущем разделе выберите раздел и нажмите клавиши CTRL+F.

Вкладка "Содержание"

  • На этой вкладке представлен список глав и разделов, дающий общее представление о содержании справочной системы.
  • Перемещение по темам осуществляется путем выбора и разворачивания разделов.
  • Благодаря структурированности содержания пользователь не теряет ориентации и может быстро найти нужный раздел.

Вкладка "Указатель"

  • На этой вкладке представлен алфавитный список ключевых слов для всех разделов, перечисленных на вкладке "Содержание".
  • Информацию можно найти быстро, если известно название функции, команды или операции или пользователь знает, какое действие необходимо выполнить программе.

Вкладка "Поиск"

  • Служит для поиска информации по ключевым словам во всех разделах, указанных на вкладке "Содержание".
  • Можно применять логические операторы И, ИЛИ, НЕ и ОКОЛО.
  • Можно применять подстановочные знаки *, ? и ~.
  • Можно выполнить поиск фразы, заключив ее в двойные кавычки.
  • Результатом поиска является отсортированный список разделов, в которых встречаются заданные слова.
  • Для отображения результатов в алфавитном порядке по названию или по местоположению следует щелкнуть на заголовке столбца "Название" или "Расположение".


Поиск информации в справочной системе (Процедура)

Эффективное использование справочной системы
На уровень вверх ..
Поиск информации в справочной системе
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Поиск информации в справочной системе >
Поиск информации в справочной системе
Понятие Процедура Краткий справочник

Вызов справочной системы

Использование панели содержания справочной системы


Вызов справочной системы (Процедура)

Поиск информации в справочной системе
На уровень вверх ..
Поиск информации в справочной системе
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Поиск информации в справочной системе >
Поиск информации в справочной системе
Понятие Процедура Краткий справочник

Вызов справочной системы

  • Для перехода к справке пользователя выберите меню "Справка" [image] "Справка".Для перехода к справке пользователя в командной строке введите "справка".
  • Для доступа к документации для разработчиков выберите меню "Справка" [image] "Дополнительные ресурсы" [image] "Документация для разработчиков".
ПримечаниеСправочную информацию можно вывести, нажав клавишу F1 в командной строке, в диалоговом окне или при выводе приглашения во время выполнения команды.


Использование панели содержания справочной системы (Процедура)

Поиск информации в справочной системе
На уровень вверх ..
Средства поиска
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Поиск информации в справочной системе >
Поиск информации в справочной системе
Понятие Процедура Краткий справочник

Использование панели содержания справочной системы

  1. Если требуется, нажмите кнопку "Показать" для отображения левой области окна справочной системы. Затем для отображения содержания справочной системы выберите вкладку "Содержание".
  2. Чтобы развернуть список разделов по какой-либо теме, применяется любой из перечисленных ниже способов:
    • Дважды нажмите на значке закрытой книги или рядом с ним на значке "+".
    • Нажмите правую кнопку мыши на панели содержания справки. Выберите "Открыть все".
  3. Чтобы свернуть список разделов, можно применить любой из перечисленных ниже способов:
    • Дважды нажмите на значке открытой книги или рядом с ним на значке "-".
    • Нажмите правую кнопку мыши на панели содержания справки. Выберите "Закрыть все".
  4. Чтобы просмотреть раздел, можно применить любой из перечисленных ниже способов:
    • В содержании справочной системы нажмите на имени раздела.
    • Внутри раздела нажмите на любой подчеркнутый текст синего цвета.


Поиск информации в справочной системе (Краткий справочник)

Поиск информации в справочной системе
Средства поиска
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Поиск информации в справочной системе >
Поиск информации в справочной системе
Понятие Процедура Краткий справочник

Команды

СПРАВКА

Вызов справочной системы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Средства поиска (Понятие)

Поиск информации в справочной системе
Эффективное использование справочной системы
Организация разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы >
Средства поиска
Понятие Процедура Краткий справочник

Вкладка "Поиск" служит для поиска требуемых разделов по ключевым словам, введенным пользователем.

Для простого поиска существуют следующие правила:

  • Ключевые слова можно вводить в верхнем или нижнем регистре; в процессе поиска регистр не учитывается.
  • Можно использовать любую комбинацию из букв (a-z) и цифр (0-9).
  • Не следует использовать такие знаки препинания, как точка, двоеточие, точка с запятой, запятая, дефис и одинарные кавычки; они игнорируются при поиске.
  • Чтобы поиск проводился по отдельным словам, а не по целой фразе, каждое слово следует заключить в двойные кавычки или скобки.

Использование подстановочных знаков

В любом ключевом слове можно ввести указанные ниже подстановочные знаки.

Обозначение | Описание
* | Заменяет один или несколько символов при использовании в начале, середине или конце слова. Например, по "*lish", "p*lish" или "pub*" будет найдено "publish". Точно также по "anno*" будут найдены "annotative", "annotation", "annoupdate", "annoreset", и т. д.
? | Заменяет один символ. Например, по "cop?" отыщется "copy", но не отыщется "copybase".
~ | Расширяет понятие грамматического времени слова в начале или конце слова. Например, по "plotting~" найдутся "plots", "plotted" и т. д. Точно также по "~plot" найдутся "preplot", "replot" и т. д.

Поиск фраз

Если требуется найти фразу, т.е. несколько слов, следующих непосредственно друг за другом в заданном порядке, заключите эти слова в двойные кавычки. Например, для поиска разделов, в которых содержится фраза "задающий единицы измерения", следует ввести данные слова именно в этом порядке. Если вокруг этого текста не поставить кавычек, отыскиваются все разделы, в которых встречается любое из перечисленных слов, т.е. все разделы, содержащие "задающий", все разделы, содержащие "единицы" и все разделы, содержащие "измерения".

ПримечаниеЕсли с помощью функцию поиска невозможно найти требуемую информацию, попробуйте воспользоваться вкладкой "Содержание".

Применение логических операторов

Более точно условия поиска можно задать с помощью логических операторов И, ИЛИ, НЕ и ОКОЛО. Правила и примеры использования операторов приведены в таблице. Если оператор не задан, подразумевается И. Например, запрос интервал рант печать равнозначен запросу интервал И рант И печать.

Что искать | Пример | Результат
Оба термина в одном разделе | "просмотр структуры" И палитра "просмотр структуры" + палитра | Разделы, в которых встречаются как слова "просмотр структуры", так и "палитра".
Любой из терминов в разделе | растровый ИЛИ векторный | Разделы, в которых встречается хотя бы одно (или оба) из слов "растровый" и "векторный".
Первый термин без второго | ole НЕ dde ole -dde | Разделы, содержащие слово "OLE", но не содержащие слова "DDE".
Оба термина в одном разделе, один вблизи другого | "пользовательское" ОКОЛО "ядро" | Разделы, в которых слова "пользовательское" и "ядро" отстоят друг от друга не более чем на 8 слов.
ПримечаниеСимволы |, & и ! не являются логическими операторами. Необходимо использовать операторы И (также +), ИЛИ и НЕ (также -). Если требуется найти версию команды для командной строки, например, -ПЕЧАТЬ, не используйте знак минус (-), так как он интерпретируется как логический оператор НЕ.


Для поиска информации в справочной системе (Процедура)

Поиск информации в справочной системе
На уровень вверх ..
Организация разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Средства поиска >
Средства поиска
Понятие Процедура Краткий справочник

Для поиска информации в справочной системе

  1. Выбрать вкладку "Поиск". Введите слова или фразы, которые требуется найти.
  2. (Необязательно) Уточните поиск с помощью логических операторов, вставляемых между словами и фразами.
  3. Нажмите "Список разделов" и выберите нужный раздел. Нажмите кнопку "Показать".
  4. Для сортировки результатов по названию, расположению и значимости нажать соответственно на заголовке столбца "Заголовок", "Местонахождение" или "Ранг".


Средства поиска (Краткий справочник)

Поиск информации в справочной системе
Средства поиска
Организация разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Средства поиска >
Средства поиска
Понятие Процедура Краткий справочник

Команды

СПРАВКА

Вызов справочной системы

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Организация разделов справочной системы (Понятие)

Средства поиска
Эффективное использование справочной системы
Печать разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы >
Организация разделов справочной системы
Понятие Процедура Краткий справочник

В большинстве разделов справки в верхней части правой панели окна справки есть три вкладки. На вкладках отображаются различные виды информации.

  • Вкладка "Понятие".Описание функции При переходе на вкладку "Понятие" раскрывается список разделов справки в левой части окна "Справка" и выделяется текущий раздел. На вкладке "Содержание" отображается структура справочной системы по данному разделу. Нажав кнопку мыши на соседних с выбранным разделах, можно отобразить их структуру.
  • Вкладка "Процедура". Содержит пошаговые инструкции для выполнения стандартных процедур, относящихся к текущему разделу. После вывода на экран процедуры можно перейти на вкладку "Процедура" для повторного вывода текущего списка процедур.
  • Вкладка "Быстрое ознакомление". Содержит список команд и системных переменных, относящихся к данному разделу, со ссылками на подробное описание команд. При переходе на вкладку "Быстрое ознакомление" открывается "Справочник команд" с выбранной командой или системной переменной.

При смене вкладки не происходит перехода к другому разделу; Различается только тип отображаемой информации: понятие, процедуры или ссылки для быстрого ознакомления.

Организация вкладки "Понятие"

На вкладке "Понятие" есть два типа информации, которую можно выводить: навигационный текст и конечный текст. Навигационный текст представляет собой ссылки с краткими описаниями. Навигационный текст помогает выполнить пошаговый переход к необходимой информации. Ссылки на навигационных страницах ведут к более глубоко расположенным навигационным страницам справочной системы до тех пор, пока не будет достигнута искомая страница. В каждой последующей ссылке содержится более подробная информация.

Структура вкладок "Процедура" и "Быстрое ознакомление"

При переходе на каждый следующий уровень справки на вкладке "Содержание" информация на вкладках "Процедура" и "Быстрое ознакомление", соответствующая запросу, становится более конкретной, а количество отображаемых записей уменьшается.


Смена типа отображаемой справочной информации (Процедура)

Средства поиска
На уровень вверх ..
Печать разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Организация разделов справочной системы >
Организация разделов справочной системы
Понятие Процедура Краткий справочник

Смена типа отображаемой справочной информации

  • Для изменения типа информации, отображаемой в правой части окна "Справка", перейдите на вкладку "Понятие", "Процедура" или "Быстрое ознакомление".


Организация разделов справочной системы (Краткий справочник)

Средства поиска
Организация разделов справочной системы
Печать разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Организация разделов справочной системы >
Организация разделов справочной системы
Понятие Процедура Краткий справочник

Команды

СПРАВКА

Вызов справочной системы

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Печать разделов справочной системы (Понятие)

Организация разделов справочной системы
Эффективное использование справочной системы
Показ и скрытие панели содержания
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы >
Печать разделов справочной системы
Понятие Процедура Краткий справочник

Самый простой способ печати текущего раздела - нажмите на нем правую кнопку мыши и выберите "Печать".

Кнопка "Печать" на панели инструментов предоставляет следующие возможности:

  • Печать выбранного раздела (рекомендуется).
  • Печать выбранного раздела и всех вложенных разделов.
ПримечаниеЕсли текущий раздел имеет много вложенных, выбор второго варианта может привести к печати большого числа страниц.


Печать разделов справочной системы (Процедура)

Организация разделов справочной системы
На уровень вверх ..
Печать разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Печать разделов справочной системы >
Печать разделов справочной системы
Понятие Процедура Краткий справочник

Печать раздела справочной системы

Печать выбранного раздела и всех вложенных разделов


Печать раздела справочной системы (Процедура)

Печать разделов справочной системы
На уровень вверх ..
Печать разделов справочной системы
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Печать разделов справочной системы >
Печать разделов справочной системы
Понятие Процедура Краткий справочник

Печать раздела справочной системы

  1. Выведите раздел, который нужно напечатать.
  2. Щелкните правой кнопкой мыши в области разделов. Выберите в контекстном меню команду "Печать".
  3. Нажмите кнопку "Печать" в диалоговом окне вывода на печать.


Печать выбранного раздела и всех вложенных разделов (Процедура)

Печать разделов справочной системы
На уровень вверх ..
Доступ к Центру подписки
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Печать разделов справочной системы >
Печать разделов справочной системы
Понятие Процедура Краткий справочник

Печать выбранного раздела и всех вложенных разделов

  1. Выведите раздел, который нужно напечатать, и убедитесь, что отображается вкладка "Содержимое".
  2. На панели инструментов окна "Справка" нажмите кнопку "Печать".
  3. В диалоговом окне "Печать разделов" выберите "Печать выбранного раздела и всех подразделов".
  4. Нажмите "OK".


Печать разделов справочной системы (Краткий справочник)

Организация разделов справочной системы
Печать разделов справочной системы
Показ и скрытие панели содержания
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Печать разделов справочной системы >
Печать разделов справочной системы
Понятие Процедура Краткий справочник

Команды

СПРАВКА

Вызов справочной системы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Показ и скрытие панели содержания (Понятие)

Печать разделов справочной системы
Эффективное использование справочной системы
Получение дополнительной информации
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы >
Показ и скрытие панели содержания
Понятие Краткий справочник

Кнопкой "Скрыть" на панели инструментов справочной системы окно справки уменьшается до компактных размеров за счёт исчезновения панели, содержащей вкладки "Содержание", "Указатель" и "Поиск".

Такой размер окна предпочтителен для отображения процедур во время работы.

Кнопкой "Показать" окно справки увеличивается для отображения панели, содержащей вкладки "Содержание", "Указатель" и "Поиск". Такой размер окна предпочтителен при поиске информации.


Показ и скрытие панели содержания (Краткий справочник)

Печать разделов справочной системы
Показ и скрытие панели содержания
Получение дополнительной информации
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Показ и скрытие панели содержания >
Показ и скрытие панели содержания
Понятие Краткий справочник

Команды

СПРАВКА

Вызов справочной системы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Получение дополнительной информации (Понятие)

Показ и скрытие панели содержания
Эффективное использование справочной системы
Подробнее о новых функциях
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы >
Получение дополнительной информации
Понятие Краткий справочник

Существует ряд дополнительных способов получения справочной информации.

  • В строке меню используйте Инфоцентр. Выполните поиск по ключевым словам или введите вопрос для справки, выведите панель "Коммуникационный центр" для получения информации по обновлениям продукта и уведомлениям или выведите панель "Избранное" для перехода к сохраненным разделам. Отображаются ссылки на разделы справки, RSS-каналы, обновления продукта и уведомления.
  • Нажать клавишу F1 в процессе выполнения команды, работы с системной переменной или в диалоговом окне. Отображается полная информация из Справочника команд.
  • Нажать имеющуюся во многих диалоговых окнах кнопку с вопросительным знаком. Отображается описание выбранного параметра диалогового окна.
  • Получить информацию из раздела "Дополнительные сведения" справки (Readme). Отображаются последние сведения об этом продукте.

Информацию о продуктах Autodesk и помощь при работе с данной программой можно получить с помощью других ресурсов.

  • Веб-сайт компании Autodesk. См. http://www.autodesk.com.
  • Местная служба поддержки.Обратитесь к дилеру или в региональный офис Autodesk.
См. также

    • Поиск и получение информации


Получение дополнительной информации (Краткий справочник)

Показ и скрытие панели содержания
Получение дополнительной информации
Обучение работе с программой
Получение информации > Поиск необходимой информации > Эффективное использование справочной системы > Получение дополнительной информации >
Получение дополнительной информации
Понятие Краткий справочник

Команды

СПРАВКА

Вызов справочной системы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подробнее о новых функциях

Получение дополнительной информации
Поиск необходимой информации
Обучение работе с программой
Получение информации > Поиск необходимой информации >
Подробнее о новых функциях

Раздел "Новые возможности" знакомит пользователя с новыми возможностями в AutoCAD.

Семинар по новым возможностям

Для доступа к семинару по новым возможностям можно воспользоваться меню "Справка" или щелкнуть по следующей ссылке.

  • Откройте Новые возможности.


Обучение работе с программой (Понятие)

Подробнее о новых функциях
Поиск необходимой информации
Доступ к Центру подписки
Получение информации > Поиск необходимой информации >
Обучение работе с программой
Понятие Краткий справочник

Обучающие программы и продукты от Autodesk помогают пользователям осваивать ключевые технические характеристики и повышать производительность. Для получения последних сведений об обучающих программах Autodesk см. http://www.autodesk.com/training-rus или свяжитесь со своим местным офисом Autodesk.

Авторизованные учебные центры Autodesk

Сеть учебных центров Autodesk® Authorized Training Center (ATC®) предоставляет авторизованный курс обучения с инструктором для профессиональных конструкторов, использующих программное обеспечение Autodesk. В авторизованных учебных центрах Autodesk преподают опытные и знающие специалисты. Во всем мире насчитывается более 1200 Авторизованных учебных центров для организации профильного локального обучения.

Для поиска ближайшего центра обучения обратитесь в локальный офис Autodesk или зайдите на сайт http://www.autodesk.com/atc.

Официальные учебные материалы Autodesk

Официальные учебные материалы Autodesk (Autodesk Official Training Courseware; AOTC) являются пособием по техническому обучению, разработанным в Autodesk. Пособие AOTC, ориентированное на обучение длительностью от 1/2 до 5 дней в классе под руководством преподавателя и применяемое авторизованными центрами обучения и другими партнерами Autodesk, хорошо адаптируется к нужным темпам индивидуального обучения. В пособиях излагаются ключевые понятия и функциональные возможности программного обеспечения на практических примерах пошаговой работы в реальном окружении. Официальные учебные материалы (AOTC) можно приобрести у местного торгового посредника или дистрибьютора или заказать в Интернет-магазине Autodesk по адресу http://www.autodesk.com/aotc .

Обучение через Интернет (e-Learning)

Обучение через Интернет для пользователей службы подписки на Autodesk организовано в виде интерактивных уроков, приводимых в каталогах на продукты. В течение каждого урока продолжительностью от 20 до 40 минут пользователь выполняет практические упражнения на программном продукте или в режиме эмулирования. Интерактивный оценочный инструмент позволяет пользователю выявлять пробелы в его подготовке, определять наиболее насущные для него упражнения и оценивать свои успехи.

Если пользователь является подписчиком Autodesk, то с помощью используемого продукта Autodesk можно получить доступ к электронным учебникам e-Learning и другим услугам, предоставляемым по подписке. Дополнительную информацию о получении доступа к электронным учебникам e-Learning в программе см. в разделе Доступ к Центру подписки. Дополнительные сведения о подписке на ресурсы Autodesk представлена на веб-узле по адресу http://www.autodesk.com/subscription-rus.

Autodesk Developer Network

Программа Autodesk Developer (ADN) для подписчиков ADN является средством поддержки профессиональных разработчиков, специализирующихся на создании программного обеспечения на основе продуктов Autodesk. Подписчику ADN предоставляются деловые инструменты, программы, поддержка и обучение, необходимые для решения его задач. Разработчики могут посетить сайт http://www.autodesk.com/adn.

Autodesk Consulting

Autodesk Consulting предоставляет услуги по организации процессов обучения, включая обучение по критическим предметам, способствующее повышению производительности с целью получения прибыли за счет ценности выпускаемых изделий. Подробную информацию об общем консалтинге, интеграции систем и услугам по обучению пользователей см. на сайтеhttp://www.autodesk.com/consulting.

Услуги и программные продукты партнёров

Autodesk работает по всему миру совместно с тысячами партнёров, выпускающими программные продукты. Партнёрские компании предоставляют профессиональным конструкторам программы и услуги, расширяющие возможности программного обеспечения Autodesk. Список ресурсов для используемой программы Autodesk и для применения в конкретной отрасли промышленности можно найти на странице "Продукты и услуги партнеров" на веб-узле http://www.autodesk.com/partnerproducts.


Обучение работе с программой (Краткий справочник)

Получение дополнительной информации
Обучение работе с программой
Центр подписки
Получение информации > Поиск необходимой информации > Обучение работе с программой >
Обучение работе с программой
Понятие Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Доступ к Центру подписки

Обучение работе с программой
Поиск необходимой информации
Центр подписки
Получение информации > Поиск необходимой информации >
Доступ к Центру подписки
Понятие Процедура

Подписчики могут обращаться в Центр подписки непосредственно из программы. Подписчик может получить доступ к услугам по подписке, нажав кнопку "Коммуникационный центр" на поле "Инфоцентр" в верхней правой части окна приложения и щелкнув затем ссылку "Центр подписки". Дополнительные сведения об участии в программе подписки Autodesk представлены на веб-узле по адресу http://www.autodesk.com/subscription-rus.

Темы в этом разделе

  • Центр подписки
  • Управление файлами с помощью Autodesk Vault


Доступ к Центру подписки (Процедура)

Печать разделов справочной системы
Доступ к Центру подписки
Центр подписки
Получение информации > Поиск необходимой информации > Доступ к Центру подписки >
Доступ к Центру подписки
Понятие Процедура

Вызов "Центра подписки" из программы


Центр подписки (Понятие)

Доступ к Центру подписки
Доступ к Центру подписки
Управление файлами с помощью Autodesk Vault
Получение информации > Поиск необходимой информации > Доступ к Центру подписки >
Центр подписки
Понятие Процедура Краткий справочник

Программа подписки Autodesk обеспечивает доступ к последним версиям программных продуктов Autodesk, программам-расширениям, технической поддержке через Интернет и электронному самообучению (e-Learning). Услуги по подписке предоставляются только подписчикам.

Нажав кнопку "Коммуникационный центр" [image] в верхней правой части приложения на поле "Инфоцентр", участники программы подписки получают доступ к следующим возможностям (в центре подписки):

  • Статус по подписке. Проверка статуса по подписке.
  • Создание запроса о поддержке Обеспечивается прямое общение со специалистами технической поддержки Autodesk. Пользователь быстро получает исчерпывающие ответы на вопросы по установке, настройке и устранению неполадок программы.
  • Просмотр запросов о поддержке. Отслеживание и контроль вопросов и ответов через современную систему поддержки компании Autodesk.
  • Изменение профиля центра подписки. Создание и поддержка учетной записи подписки.
  • Просмотр каталога e-Learning.Содержит интерактивные уроки, упорядоченные по каталогам программ.
  • Уроки e-Learning(Только для подписчиков). Продолжительность каждого урока от 15 до 30 минут; в урок включены практические упражнения, которые можно выполнять, используя эмуляцию приложения. С помощью интерактивного средства оценки результатов пользователь может выявить пробелы в своей подготовке, определить, какие ему необходимы упражнения и оценить свои успехи.

Ресурсы по подписке и конфиденциальная информация

По подписке через Интернет можно получить интерактивные компоненты продукта. Каждый раз при обращении к ресурсам по подписке (например, к электронным учебникам или службе технической поддержки) из Коммуникационного центра в продукте Autodesk информация о программе (серийный номер, версия, язык и идентификационный номер договора подписки) отправляется в Autodesk для проверки, обслуживается ли данная программа по подписке.

Autodesk ведет статистику информации, отправляемой при обращении к ресурсам по подписке для контроля их использования и определения направления их усовершенствования. Autodesk использует информацию, предоставленную пользователем или полученную от него, в соответствии с политикой конфиденциальности Autodesk, с которой можно ознакомиться на веб-узле http://www.autodesk.com/privacy-rus

Включение ресурсов по подписке

Для включения и отключения ресурсов по подписке в меню "Справка" можно использовать Диспетчер Интернет-компонентов. Для получения подробной информации об установке и запуске утилиты см. Установка и запуск "Диспетчера Интернет-компонентов". Для получения подробной информации по управляемым настройкам щелкните "Справка" в окне "Диспетчер Интернет-компонентов".


Вызов "Центра подписки" из программы (Процедура)

Доступ к Центру подписки
На уровень вверх ..
Где найти AutoCAD Express Tools, тома 1-9
Получение информации > Поиск необходимой информации > Доступ к Центру подписки > Центр подписки >
Центр подписки
Понятие Процедура Краткий справочник

Вызов "Центра подписки" из программы

  1. В верхней правой части окна приложения в поле "Инфоцентр" нажмите кнопку "Коммуникационный центр".
  2. На панели "Коммуникационный центр" в разделе "Центр подписки" щелкните на ресурсе по подписке, к которому хотите обратиться.
ПримечаниеНе все пользователи программы могут обращаться в "Центр подписки". Если ресурсы по подписке недоступны в продукте пользователя, это означает, что данная программа не обслуживается по подписке.


Центр подписки (Краткий справочник)

Обучение работе с программой
Центр подписки
Управление файлами с помощью Autodesk Vault
Получение информации > Поиск необходимой информации > Доступ к Центру подписки > Центр подписки >
Центр подписки
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление файлами с помощью Autodesk Vault (Понятие)

Центр подписки
Доступ к Центру подписки
Просмотр файла дополнительных сведений (Readme)
Получение информации > Поиск необходимой информации > Доступ к Центру подписки >
Управление файлами с помощью Autodesk Vault
Понятие Краткий справочник

Пользователь службы подписки имеет доступ к Autodesk Vault, утилите управления файлами, предоставляющей хранилище, в котором можно хранить документы и файлы и управлять ими. Autodesk Vault предоставляет мощные средства управления файлами и отслеживания изменений в них. Поддерживается архив копий главных файлов, что облегчает возврат к более ранним версиям файлов. Предусмотрена возможность выборки файлов для внесения изменений и последующего возврата их в архив. Главная копия недоступна для непосредственного редактирования. Во время процедуры возврата файла его можно снабдить комментариями, относящимися к внесённым изменениям, для информирования других пользователей о выполненных изменениях. Это обеспечивает возможность быстро ознакомиться с этапами разработки проекта и его журналом.

Autodesk Vault содержит два необходимых компонента: сервер Autodesk Data Management и клиент Vault. Дополнительно можно установить Vault Office Add-in.

За информацией об использовании системы Vault обратитесь к справочной системе Vault.

ПримечаниеВозможна загрузка основных компонентов для Autodesk Vault из узла Autodesk Subscription.

Сервер Vault Data Management

На сервере Vault Data Management хранятся главные копии всех пользовательских документов и проектов. Благодаря централизованному хранению всех данных в одном месте группа пользователей получает удобную возможность совместного использования информации и управления ею.

Клиент Vault

В клиентское ПО Vault входит средство Autodesk Vault Explorer. Vault Explorer является автономным приложением, предоставляющим инструменты для доступа к данным, хранящимся в сервере Autodesk Data Management. Работая в программе AutoCAD, можно войти в систему Vault, открыть в ней файлы, вставить их и выйти из Vault. Предусмотрена также возможность доступа к Vault с помощью Vault Explorer. С помощью Vault Explorer можно выполнять следующие действия:

  • Управлять системой Vault.
  • Управлять учётными записями пользователей Vault.
  • Задавать рабочие папки.
  • Создавать папки в системе Vault.
  • Добавлять, извлекать и возвращать файлы (включая файлы, отличные от файлов Inventor и DWG; исключением являются файлы AutoCAD Electrical)
  • Перемещать файлы в системе Vault.
  • Переименовывать файлы в системе Vault.
  • Просматривать журнал учёта изменений в проекте.
  • Создавать объединения файлов в рамках системы Vault, связывая два или более файлов.
  • Выбирать самую последнюю версию файла.
  • Упаковывать файлы с помощью команд "Упаковать" и "Выполнить".

Vault Office Add-in (возможное дополнение)

Дополнительный компонент обеспечивает доступ из системы Vault в продукты пакета программ Microsoft® Office (Word, Excel). Доступ из системы Vault в программы Microsoft Office осуществляется аналогично доступу из AutoCAD. Для использования этого компонента необходимо произвести установку клиента Vault.


Управление файлами с помощью Autodesk Vault (Краткий справочник)

Центр подписки
Управление файлами с помощью Autodesk Vault
Просмотр файла дополнительных сведений (Readme)
Получение информации > Поиск необходимой информации > Доступ к Центру подписки > Управление файлами с помощью Autodesk Vault >
Управление файлами с помощью Autodesk Vault
Понятие Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Просмотр файла дополнительных сведений (Readme) (Понятие)

Управление файлами с помощью Autodesk Vault
Поиск необходимой информации
Где найти AutoCAD Express Tools, тома 1-9
Получение информации > Поиск необходимой информации >
Просмотр файла дополнительных сведений (Readme)
Понятие Краткий справочник

Последние сведения об этой программе см. в файле Readme.

Рекомендуется прочитать файл Readme для получения обновленных инструкций по установке, сведений о требуемом аппаратном обеспечении и об известных неполадках программы.

  • Просмотр файла ознакомительных сведений Readme


Просмотр файла дополнительных сведений (Readme) (Краткий справочник)

Управление файлами с помощью Autodesk Vault
Просмотр файла дополнительных сведений (Readme)
Получение общих сведений из чертежа
Получение информации > Поиск необходимой информации > Просмотр файла дополнительных сведений (Readme) >
Просмотр файла дополнительных сведений (Readme)
Понятие Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Где найти AutoCAD Express Tools, тома 1-9 (Понятие)

Просмотр файла дополнительных сведений (Readme)
Поиск необходимой информации
Присоединяйтесь к программе вовлечения пользователей
Получение информации > Поиск необходимой информации >
Где найти AutoCAD Express Tools, тома 1-9
Понятие Процедура

Тома 1-9 Express Tools AutoCAD содержат библиотеку инструментов повышения производительности, предназначенных для расширения функциональных возможностей AutoCAD. Они легки в использовании, их легко интегрировать в пользовательские меню и панели инструментов. Они охватывают широкий диапазон функций AutoCAD (включая задание размеров, построение, выбор и изменение объектов).

Тома 1-9 компонента AutoCAD Express Tools устанавливаются в процессе стандартной установки AutoCAD. Если установка этих томов не требуется, отключите их в процессе установки AutoCAD, выбрав параметр "Express Tools" на странице "Выбор типа установки".

Подробную информацию по использованию Express Tools можно найти в справочной системе AutoCAD Express Tools, которая находится в меню Express.

ПримечаниеExpress Tools доступны в своей исходной форме, только на английском языке, и не поддерживаются. Двухбайтовые символы не поддерживаются.


Где найти AutoCAD Express Tools, тома 1-9 (Процедура)

Центр подписки
Где найти AutoCAD Express Tools, тома 1-9
Где найти AutoCAD Express Tools, тома 1-9
Получение информации > Поиск необходимой информации > Где найти AutoCAD Express Tools, тома 1-9 >
Где найти AutoCAD Express Tools, тома 1-9
Понятие Процедура

Проверка на то, загружены ли Express Tools

Переход к Express Tools и их панелям инструментов


Проверка на то, загружены ли Express Tools (Процедура)

Где найти AutoCAD Express Tools, тома 1-9
Где найти AutoCAD Express Tools, тома 1-9
Где найти AutoCAD Express Tools, тома 1-9
Получение информации > Поиск необходимой информации > Где найти AutoCAD Express Tools, тома 1-9 >
Где найти AutoCAD Express Tools, тома 1-9
Понятие Процедура

Проверка на то, загружены ли Express Tools

  • В командной строке введите EXPRESSTOOLS для включения инструментов.

    Пользователь может установить AutoCAD Express Tools в качестве компонента при установке AutoCAD или добавить их позднее с помощью пункта "Установка и удаление программ" на панели управления.


Переход к Express Tools и их панелям инструментов (Процедура)

Где найти AutoCAD Express Tools, тома 1-9
Где найти AutoCAD Express Tools, тома 1-9
Присоединяйтесь к программе вовлечения пользователей
Получение информации > Поиск необходимой информации > Где найти AutoCAD Express Tools, тома 1-9 >
Где найти AutoCAD Express Tools, тома 1-9
Понятие Процедура

Переход к Express Tools и их панелям инструментов

  • Для вывода меню "Express" введите EXPRESSMENU в командной строке.
  • Для вывода панелей инструментов "Express" щелкните правой кнопкой мыши рядом с любой закрепленной панелью инструментов. Щелкните на "EXPRESS" и выберите панель инструментов "Express". Повторяйте эти шаги, пока не будут выведены все необходимые панели инструментов Express.
    СоветНа экране с выведенными панелями инструментов Express выберите рабочее пространство и сохраните его. В дальнейшем панели инструментов Express Tools будут всегда включаться с данным рабочим пространством.


Присоединяйтесь к программе вовлечения пользователей (Понятие)

Где найти AutoCAD Express Tools, тома 1-9
Поиск необходимой информации
Получение сведений из чертежей
Получение информации > Поиск необходимой информации >
Присоединяйтесь к программе вовлечения пользователей
Понятие Процедура

Предлагается принять участие в содействии разработке чертежного программного обеспечения САПР корпорации Autodesk.

Если вы участвуете в программе вовлечения пользователей, в компанию Autodesk направляются специальные сведения о том, как вы используете AutoCAD. Эти сведения включают информацию о наиболее часто используемых вами элементах, о возникающих в процессе работы проблемах и прочую информацию, которая будет учтена в ходе разработки данного программного продукта в будущем.

Вот перечень сведений, автоматически отправляемых в компанию Autodesk:

  • Название и версия продукта Autodesk
  • Используемые команды AutoCAD и количество времени, потраченного в AutoCAD
  • Возможность возникновения ошибок, неустранимых и устранимых.
  • Форматы файлов, импортируемых или экспортируемых с помощью AutoCAD
  • Имя и версия операционной системы
  • Данные по конфигурации системы, например процессору, объеме памяти и видеокарте
  • IP-адрес, используемый для определения страны или региона пользователя

Чего не может программа вовлечения пользователей

Программа вовлечения пользователей обязана защищать конфиденциальность информации пользователя. Программа не может выполнить ни одного из следующих действий:

  • Получить данные любого чертежа или конструкции
  • Получить любую персональную информацию, например имя, адрес или номер телефона
  • Отправить пользователю сообщение электронной почты или связаться с ним каким-либо иным образом

Для получения дополнительной информации щелкните на ссылках в диалоговом окне "Программа вовлечения пользователей".

Почему стоит задуматься об участии

Программа вовлечения пользователей вовлекает пользователя в диалог с компанией Autodesk по следующим пунктам:

  • Команды и функции, на которых должна сосредоточиться компания Autodesk
  • Наиболее часто используемые команды и функции
  • Наиболее распространенные проблемные области
  • Аппаратное обеспечение, обычно используемое с AutoCAD
ПримечаниеПользователь может принять участие в программе или выйти из нее в любой момент. Получить доступ к элементам управления можно из меню AutoCAD "Справка". При сетевой установке системный администратор может выбрать, делать ли программу CIP доступной или нет.


Включение и отключение CIP (Процедура)

Где найти AutoCAD Express Tools, тома 1-9
Присоединяйтесь к программе вовлечения пользователей
Подсчет объектов в чертеже
Получение информации > Поиск необходимой информации > Присоединяйтесь к программе вовлечения пользователей >
Присоединяйтесь к программе вовлечения пользователей
Понятие Процедура

Включение и отключение CIP

  1. Выберите меню "Справка" [image] "Программа вовлечения пользователей".
  2. В диалоговом окне "Программа вовлечения пользователей" выберите уровень участия и нажмите "OK".


Получение сведений из чертежей

Присоединяйтесь к программе вовлечения пользователей
Получение информации
Получение общих сведений из чертежа
Получение информации >
Получение сведений из чертежей

Можно извлекать общие сведения из чертежа, в том числе идентификационные сведения и количество содержащихся в чертеже объектов.

В чертеже хранятся сведения таких типов, которые не относятся к определенным объектам в чертеже, но содержат полезную информацию, помогающую понять поведение чертежа, настройки системных переменных, количество объектов, описания и т. д.

Темы в этом разделе

  • Получение общих сведений из чертежа

    Можно извлекать общие сведения о файле чертежа и его параметрах.

  • Подсчет объектов в чертеже

    Можно подсчитывать количество объектов в чертеже с помощью команды БВЫБОР.


Получение общих сведений из чертежа (Понятие)

Получение сведений из чертежей
Получение сведений из чертежей
Подсчет объектов в чертеже
Получение информации > Получение сведений из чертежей >
Получение общих сведений из чертежа
Понятие Краткий справочник

Можно извлекать общие сведения о файле чертежа и его параметрах.

Эти сведения включают в себя следующее:

  • Пользовательская описательная информация о чертеже (СВОЙСТВАРИС)
  • Общие параметры чертежа (СТАТУС)
  • Количество потраченного на чертеж времени (ВРЕМЯ)

Эти сведения могут помочь при составлении документации к чертежу, выводе множества параметров чертежа, например общего количества объектов в чертеже и свободного места на диске пользователя, а также общего количества времени, потраченного на файл чертежа.

См. также

    • Ввод значений системных переменных в командной строке

    • Добавление идентификационных сведений к чертежам
    • Получение геометрической информации от объектов
    • Сравнение размерных стилей и переменных


Получение общих сведений из чертежа (Краткий справочник)

Просмотр файла дополнительных сведений (Readme)
Получение общих сведений из чертежа
Подсчет объектов в чертеже
Получение информации > Получение сведений из чертежей > Получение общих сведений из чертежа >
Получение общих сведений из чертежа
Понятие Краткий справочник

Команды

СВОЙСТВАРИС

Задание и просмотр свойств текущего чертежа

УСТПЕРЕМ

Вывод списка системных переменных, изменение их значений

СТАТУС

Вывод на экран статистической информации о чертеже, режимах и границах

ВРЕМЯ

Получение сведений о дате и времени чертежа

Системные переменные

CDATE

Сохранение текущих значений даты и времени в десятичном формате

DATE

Сохранение текущих значений даты и времени в формате модифицированной даты по юлианскому календарю

SAVENAME

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подсчет объектов в чертеже (Понятие)

Получение общих сведений из чертежа
Получение сведений из чертежей
Пользовательский интерфейс
Получение информации > Получение сведений из чертежей >
Подсчет объектов в чертеже
Понятие Процедура Краткий справочник

Можно подсчитывать количество объектов в чертеже с помощью команды БВЫБОР.

Команда БВЫБОР выводит диалоговое окно "Быстрый выбор", которое позволяет создавать набор объектов на основе критериев фильтрации. Наборы объектов можно фильтровать по свойству, например по цвету или типу линии, а также по типу объекта.

Создание набора объектов на основе критериев фильтрации в диалоговом окне "Быстрый выбор" позволяет подсчитывать объекты указанных типов в чертеже.


Подсчет объектов указанных типов в чертеже (Процедура)

Присоединяйтесь к программе вовлечения пользователей
Подсчет объектов в чертеже
Лента
Получение информации > Получение сведений из чертежей > Подсчет объектов в чертеже >
Подсчет объектов в чертеже
Понятие Процедура Краткий справочник

Подсчет объектов указанных типов в чертеже

  1. Откройте вкладку "Главная" [image] , панель "Утилиты" [image] , раздел "Быстрый выбор". В командной строке введите БВЫБОР.
  2. В диалоговом окне "Быстрый выбор" выполните одно из следующих действий:
    • В "Применить к списку" выберите "Весь чертеж".
    • Нажмите кнопку "Выбрать объекты" для выбора группы объектов. Нажать ENTER. В "Применить к списку" выберите "К текущему набору".
  3. В списке "Тип объекта" выберите тип объекта для подсчета.
  4. В списке "Свойства" выберите свойство, относящееся к типу объектов для подсчета.
  5. В списке "Оператор" выберите "= (равно)".
  6. В списке значений выберите значение свойства для типа объектов, которые требуется подсчитать.
  7. Нажмите ОК.

Количество объектов отображается в командной строке.

Меню: "Сервис" [image] "Быстрый выбор"Пункт отсутствует в меню.
Ввод команды: БВЫБОР
Контекстное меню:Завершите выполнение всех активных команд, нажмите правую кнопку мыши в области рисования и выберите "Быстрый выбор".


Подсчет объектов в чертеже (Краткий справочник)

Получение общих сведений из чертежа
Подсчет объектов в чертеже
Организация ленты
Получение информации > Получение сведений из чертежей > Подсчет объектов в чертеже >
Подсчет объектов в чертеже
Понятие Процедура Краткий справочник

Команды

БВЫБОР

Быстрое создание набора объектов на основе заданных критериев фильтрации

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Пользовательский интерфейс

Подсчет объектов в чертеже
Местоположение ленты, меню и других инструментов
Пользовательский интерфейс

Темы в этом разделе

  • Местоположение ленты, меню и других инструментов

    Лента и меню служат для доступа к часто используемым командам

  • Окно команд

    Возможно отображение команд, системных переменных и опций, сообщений и подсказок в закрепляемом и изменяемом по размеру окне, именуемом окном команд.

  • Инструменты навигации

    Инструменты навигации предназначены для изменения ориентации и вида модели.

  • Адаптация рабочей среды

    Различные элементы рабочей среды могут быть адаптированы под нужды пользователя.

  • Макросы операций

    Макросы операций можно использовать для автоматизации повторяющихся задач путем записи последовательности команд и вводимых значений.


Местоположение ленты, меню и других инструментов

Пользовательский интерфейс
Пользовательский интерфейс
Лента
Пользовательский интерфейс >
Местоположение ленты, меню и других инструментов

Лента и меню служат для доступа к часто используемым командам

Темы в этом разделе

  • Лента

    Лента — это палитра, отображающая в рабочем пространстве кнопки и элементы управления на основе выполняемых задач.

  • Доступ к меню

    Доступ к меню можно получить из обозревателя меню, расположенного вверху области чертежа.

  • Местоположение других инструментов

    Чтобы найти дополнительные команды, параметры и режимы, используйте обычные инструменты в окне приложения, панели инструментов, инструментальные палитры, строки состояния, контекстные меню и Центр управления.


Лента

Местоположение ленты, меню и других инструментов
Местоположение ленты, меню и других инструментов
Обзор ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов >
Лента
Понятие Процедура

Лента — это палитра, отображающая в рабочем пространстве кнопки и элементы управления на основе выполняемых задач.

Темы в этом разделе

  • Обзор ленты
  • Отображение и организация ленты

    Лента отображается по горизонтально, вертикально, или как плавающая палитра.

  • Адаптация ленты

    Ленту можно настроить в соответствии с потребностями.


Лента (Процедура)

Подсчет объектов в чертеже
Лента
Отображение и организация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента >
Лента
Понятие Процедура

Связывание группы инструментальных палитр с панелью ленты

Отображение группы инструментальных палитр, связанной с панелью ленты


Обзор ленты

Лента
Лента
Отображение и организация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента >
Обзор ленты

Лента служит единым компактным местом размещения операций, относящихся к текущему рабочему пространству. Лента позволяет исключить необходимость отображения нескольких панелей инструментов, уменьшая беспорядок в приложении и максимизируя область, доступную для работы с помощью единого компактного интерфейса.

Лента содержит многие из тех же самых команд, которые ранее были доступны на пульте управления. Например, команда РЗМЛИНЕЙНЫЙ была ранее доступна на панели управления "Размеры" пульта управления. На ленте команда РЗМЛИНЕЙНЫЙ находится на вкладке "Аннотирование" панели "Размеры".

Лента отображается автоматически при создании или открытии чертежа с помощью рабочего пространства "2D рисование и аннотации" или рабочего пространства "3D моделирование". Ленту можно открыть вручную, выполнив одно из следующих действий:

  • Выберите в меню "Сервис" пункты [image] "Палитры", [image] "Лента".
  • В командной строке введите лента.

Чтобы закрыть ленту, введите лентазакр в командной строке.


Отображение и организация ленты

Обзор ленты
Лента
Организация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента >
Отображение и организация ленты
Понятие Процедура

Лента отображается по горизонтально, вертикально, или как плавающая палитра.

Темы в этом разделе

  • Организация ленты

    Лента состоит из последовательности панелей, которые организованы в виде вкладок, помеченных названием задачи.

  • Горизонтальная лента

    Горизонтальная лента располагается в верхней части окна чертежа.

  • Вертикальная лента


Отображение и организация ленты (Процедура)

Лента
На уровень вверх ..
Организация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты >
Отображение и организация ленты
Понятие Процедура

Связывание группы инструментальных палитр с панелью ленты

Отображение ленты

Закрытие ленты

Отображение и скрытие текстовых меток на панелях ленты

Свертывание ленты

Отображение или скрытие панели ленты

Отображение ленты

Закрытие ленты

Отображение и скрытие текстовых меток на панелях ленты

Отображение или скрытие панели ленты


Организация ленты (Понятие)

Отображение и организация ленты
Отображение и организация ленты
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты >
Организация ленты
Понятие Процедура Краткий справочник

Лента состоит из последовательности панелей, которые организованы в виде вкладок, помеченных названием задачи.

Панели ленты содержат многие из тех же инструментов и элементов управления, которые доступны на панелях инструментов и в диалоговых окнах.

Для запуска анимации нажмите на стрелку "Показать".

При создании или открытии чертежа горизонтальная лента отображается по умолчанию вверху окна чертежа. Ленту можно также поместить внизу окна чертежа.

Для запуска анимации нажмите на стрелку "Показать".

Чтобы изменить порядок вкладок, щелкните вкладку, которую хотите переместить, и перетащите ее в требуемое положение.

Любую группу инструментальных палитр можно связать с каждой панелью ленты. Для отображения соответствующей группы инструментальных палитр выберите инструмент или откройте всплывающую панель.


Связывание группы инструментальных палитр с панелью ленты (Процедура)

Отображение и организация ленты
На уровень вверх ..
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Организация ленты >
Организация ленты
Понятие Процедура Краткий справочник

Связывание группы инструментальных палитр с панелью ленты

  1. Выберите в меню "Сервис" пункты [image] "Палитры" [image] "Инструментальные палитры".В командной строке введите ИНСТРПАЛВКЛ
  2. Щелкните на ленте панель правой кнопкой мыши и выберите в контекстном меню команду "Группа инструментальных палитр".
  3. Выберите в списке группу инструментальных палитр.
  4. Выберите меню"Сервис" [image] "Рабочие пространства" [image] "Сохранить текущее как"В командной строке введите РПСОХРАНИТЬ.
  5. В диалоговом окне "Сохранить рабочее пространство" введите имя нового рабочего пространства или выберите имя из раскрывающегося списка.
  6. Нажмите кнопку "Сохранить".


Организация ленты (Краткий справочник)

Подсчет объектов в чертеже
Организация ленты
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Организация ленты >
Организация ленты
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

ЛЕНТА

Вызов окна ленты

ЛЕНТАЗАКР

Закрытие окна ленты

Системные переменные

MTEXTTOOLBAR

Управление отображением инструментальной панели "Форматирование текста"

RIBBONSTATE

Указание на открытое или закрытое состояние палитры ленты

TABLETOOLBAR

Управление отображением панели "Таблица"

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Горизонтальная лента (Понятие)

Организация ленты
Отображение и организация ленты
Вертикальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты >
Горизонтальная лента
Понятие Процедура Краткий справочник

Горизонтальная лента располагается в верхней части окна чертежа.

Когда лента отображается горизонтально, каждая вкладка идентифицируется с помощью текстовой метки. На каждой панели отображается по умолчанию текстовая метка.

Стрелка в нижнем правом углу панели указывает, что панель можно развернуть для отображения дополнительных инструментов и элементов управления. По умолчанию развернутая панель автоматически закрывается при щелчке на другой панели. Чтобы оставить панель развернутой, щелкните значок булавки в нижнем правом углу развернутой панели.


Горизонтальная лента (Процедура)

Организация ленты
На уровень вверх ..
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Горизонтальная лента >
Горизонтальная лента
Понятие Процедура Краткий справочник

Отображение ленты

Закрытие ленты

Отображение и скрытие текстовых меток на панелях ленты

Свертывание ленты

Отображение или скрытие панели ленты


Отображение ленты (Процедура)

Горизонтальная лента
На уровень вверх ..
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Горизонтальная лента >
Горизонтальная лента
Понятие Процедура Краткий справочник

Отображение ленты

  • Выберите в меню "Сервис" пункты [image] "Палитры", [image] "Лента".
    ПримечаниеНа ленте отображаются панели ленты, связанные с рабочим пространством, использовавшимся последним. Для отображения панелей ленты, связанных с определенным рабочим пространством, выберите в меню "Сервис" пункт [image] "Рабочие пространства". Затем выберите рабочее пространство.
Ввод команды: ЛЕНТА


Закрытие ленты (Процедура)

Горизонтальная лента
На уровень вверх ..
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Горизонтальная лента >
Горизонтальная лента
Понятие Процедура Краткий справочник

Закрытие ленты

  • В командной строке введите лентазакр.
Ввод команды: ЛЕНТАЗАКР


Отображение и скрытие текстовых меток на панелях ленты (Процедура)

Горизонтальная лента
На уровень вверх ..
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Горизонтальная лента >
Горизонтальная лента
Понятие Процедура Краткий справочник

Отображение и скрытие текстовых меток на панелях ленты

  • Щелкните панель ленты правой кнопкой мыши и выберите в контекстном меню команду "Показать названия панелей".


Свертывание ленты (Процедура)

Горизонтальная лента
На уровень вверх ..
Горизонтальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Горизонтальная лента >
Горизонтальная лента
Понятие Процедура Краткий справочник

Свертывание ленты

  1. Щелкните кнопку свертывания ленты справа от вкладок ленты.
  2. Процедура свертывания выполняется циклически через следующие режимы свертывания:
    • Свертывание до вкладок: лента сворачивается так, что видны только заголовки вкладок.
    • Свертывание до панелей: лента сворачивается так, что видны только заголовки вкладок и панелей.
    • Отображение всей ленты: отображаются вкладки и полные панели, включая элементы управления.
Контекстное меню:Щелкните ленту правой кнопкой мыши, в контекстном меню выберите команду "Свернуть", а затем выберите один из приведенных выше режимов свертывания.
Указательное устройство:Дважды щелкните имя активной вкладки ленты.
ПримечаниеПроцедура свертывания доступна только для горизонтальной ленты.


Отображение или скрытие панели ленты (Процедура)

Горизонтальная лента
На уровень вверх ..
Вертикальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Горизонтальная лента >
Горизонтальная лента
Понятие Процедура Краткий справочник

Отображение или скрытие панели ленты

  • Щелкните правой кнопкой мыши где-нибудь внутри ленты. В группе "Панели" установите или снимите флажок рядом с именем панели.


Горизонтальная лента (Краткий справочник)

Организация ленты
Горизонтальная лента
Вертикальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Горизонтальная лента >
Горизонтальная лента
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

ЛЕНТА

Вызов окна ленты

ЛЕНТАЗАКР

Закрытие окна ленты

Системные переменные

MTEXTTOOLBAR

Управление отображением инструментальной панели "Форматирование текста"

RIBBONSTATE

Указание на открытое или закрытое состояние палитры ленты

TABLETOOLBAR

Управление отображением панели "Таблица"

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вертикальная лента (Понятие)

Горизонтальная лента
Отображение и организация ленты
Адаптация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты >
Вертикальная лента
Понятие Процедура Краткий справочник

При отображении ленты по вертикали каждая вкладка идентифицируется значком.

Стрелка в нижнем левом углу панели указывает, что панель можно развернуть для отображения дополнительных инструментов и элементов управления. Когда щелкают другую панель, развернутая панель на вертикальной ленте остается по умолчанию открытой. Чтобы свернуть развернутую панель, щелкните стрелку в нижнем левом углу панели. Чтобы отобразить заголовки панелей, щелкните панель ленты правой кнопкой мыши и выберите в контекстном меню команду "Показать названия панелей".

См. также
    • Создание рабочего пространства для конкретной задачи


Вертикальная лента (Процедура)

Горизонтальная лента
На уровень вверх ..
Вертикальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Вертикальная лента >
Вертикальная лента
Понятие Процедура Краткий справочник

Отображение ленты

Закрытие ленты

Отображение и скрытие текстовых меток на панелях ленты

Отображение или скрытие панели ленты


Отображение ленты (Процедура)

Вертикальная лента
На уровень вверх ..
Вертикальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Вертикальная лента >
Вертикальная лента
Понятие Процедура Краткий справочник

Отображение ленты

  • Выберите в меню "Сервис" пункты [image] "Палитры", [image] "Лента".
    ПримечаниеНа ленте отображаются панели ленты, связанные с рабочим пространством, использовавшимся последним. Для отображения панелей ленты, связанных с определенным рабочим пространством, выберите в меню "Сервис" пункт [image] "Рабочие пространства". Затем выберите рабочее пространство.
Ввод команды: ЛЕНТА


Закрытие ленты (Процедура)

Вертикальная лента
На уровень вверх ..
Вертикальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Вертикальная лента >
Вертикальная лента
Понятие Процедура Краткий справочник

Закрытие ленты

  • В командной строке введите лентазакр.
Ввод команды: ЛЕНТАЗАКР


Отображение и скрытие текстовых меток на панелях ленты (Процедура)

Вертикальная лента
На уровень вверх ..
Вертикальная лента
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Вертикальная лента >
Вертикальная лента
Понятие Процедура Краткий справочник

Отображение и скрытие текстовых меток на панелях ленты

  • Щелкните панель ленты правой кнопкой мыши и выберите в контекстном меню команду "Показать названия панелей".


Отображение или скрытие панели ленты (Процедура)

Вертикальная лента
На уровень вверх ..
Адаптация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Вертикальная лента >
Вертикальная лента
Понятие Процедура Краткий справочник

Отображение или скрытие панели ленты

  • Щелкните правой кнопкой мыши где-нибудь внутри ленты. В группе "Панели" установите или снимите флажок рядом с именем панели.


Вертикальная лента (Краткий справочник)

Горизонтальная лента
Вертикальная лента
Адаптация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Отображение и организация ленты > Вертикальная лента >
Вертикальная лента
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

ЛЕНТА

Вызов окна ленты

ЛЕНТАЗАКР

Закрытие окна ленты

Системные переменные

MTEXTTOOLBAR

Управление отображением инструментальной панели "Форматирование текста"

RIBBONSTATE

Указание на открытое или закрытое состояние палитры ленты

TABLETOOLBAR

Управление отображением панели "Таблица"

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Адаптация ленты (Понятие)

Вертикальная лента
Лента
Доступ к меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента >
Адаптация ленты
Понятие Процедура Краткий справочник

Ленту можно настроить в соответствии с потребностями.

Существуют следующие способы адаптации ленты:

  • Можно создать и изменить панели ленты с помощью редактора "Адаптация интерфейса пользователя". См. раздел Настройка панелей и вкладок ленты Руководства по адаптации.
  • Можно указать, какие вкладки и панели ленты отображать, щелкнув ленту правой кнопкой мыши и установив или сняв флажки рядом с именами вкладок или панелей в контекстном меню.
  • С каждой панелью на ленте можно связать настраиваемую группу инструментальных палитр. По щелчку панели ленты правой кнопкой мыши отображается список доступных групп инструментальных палитр.
  • Панель можно скопировать с одной вкладки ленты на другую, перетащив панель на требуемую вкладку при нажатой клавише CTRL.
  • Панели инструментов можно преобразовать в панели ленты с помощью редактора адаптации интерфейса пользователя. См. раздел Настройка панелей и вкладок ленты Руководства по адаптации.
См. также

    • Настройка панелей и вкладок ленты


Адаптация ленты (Процедура)

Вертикальная лента
На уровень вверх ..
Адаптация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Адаптация ленты >
Адаптация ленты
Понятие Процедура Краткий справочник

Связывание группы инструментальных палитр с панелью ленты

Отображение группы инструментальных палитр, связанной с панелью ленты


Связывание группы инструментальных палитр с панелью ленты (Процедура)

Адаптация ленты
На уровень вверх ..
Адаптация ленты
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Адаптация ленты >
Адаптация ленты
Понятие Процедура Краткий справочник

Связывание группы инструментальных палитр с панелью ленты

  1. Выберите в меню "Сервис" пункты [image] "Палитры" [image] "Инструментальные палитры".В командной строке введите ИНСТРПАЛВКЛ
  2. Щелкните на ленте панель правой кнопкой мыши и выберите в контекстном меню команду "Группа инструментальных палитр".
  3. Выберите в списке группу инструментальных палитр.


Отображение группы инструментальных палитр, связанной с панелью ленты (Процедура)

Адаптация ленты
На уровень вверх ..
Доступ к меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Адаптация ленты >
Адаптация ленты
Понятие Процедура Краткий справочник

Отображение группы инструментальных палитр, связанной с панелью ленты

  • Щелкните панель ленты правой кнопкой мыши и выберите в контекстном меню команду "Показать связанную группу инструментальных палитр".


Адаптация ленты (Краткий справочник)

Вертикальная лента
Адаптация ленты
Обзор доступа к меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Лента > Адаптация ленты >
Адаптация ленты
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

ЛЕНТА

Вызов окна ленты

ЛЕНТАЗАКР

Закрытие окна ленты

Системные переменные

MTEXTTOOLBAR

Управление отображением инструментальной панели "Форматирование текста"

RIBBONSTATE

Указание на открытое или закрытое состояние палитры ленты

TABLETOOLBAR

Управление отображением панели "Таблица"

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Доступ к меню

Адаптация ленты
Местоположение ленты, меню и других инструментов
Обзор доступа к меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов >
Доступ к меню
Понятие Процедура

Доступ к меню можно получить из обозревателя меню, расположенного вверху области чертежа.

Темы в этом разделе

  • Обзор доступа к меню

    Доступ к меню можно получить с помощью обозревателя меню или через классическую строку меню.

  • Поиск в обозревателе меню

    Выполните в обозревателе меню поиск меню и операций меню в реальном времени.

  • Назначение ярлыков поиска

    Создайте ярлыки поиска для любой команды меню, чтобы сделать поиск более эффективным.

  • Обзор файлов

    Просмотрите, отсортируйте и проверьте с точки зрения доступа поддерживаемые файлы, которые недавно открывались в AutoCAD.

  • Просмотр последних операций

    Отобразите и выполните команды, к которым недавно обращались из обозревателя меню.


Доступ к меню (Процедура)

Адаптация ленты
Доступ к меню
Обзор доступа к меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню >
Доступ к меню
Понятие Процедура

Отображение обозревателя меню

Отображение классической строки меню

Очистка поля поиска в обозревателе меню

Назначение ярлыка команде меню

Удаление ярлыка, назначенного команде меню

Изменение количества последних операций в списке

Очистка списка последних операций


Обзор доступа к меню (Понятие)

Доступ к меню
Доступ к меню
Поиск в обозревателе меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню >
Обзор доступа к меню
Понятие Процедура Краткий справочник

Доступ к меню можно получить с помощью обозревателя меню или через классическую строку меню.

Для запуска анимации нажмите на стрелку "Показать".

Обозреватель меню по умолчанию доступен в рабочих пространствах "2D рисование и аннотации" и "3D моделирование". В классическом рабочем пространстве AutoCAD доступны как обозреватель меню, так и классическая строка меню.

Меню, которые должны отображаться в обозревателе меню для всех рабочих пространств, можно указать в настройках файла АПИ при загрузке его в программу.

См. также
    • Создание рабочего пространства для конкретной задачи

    • См. раздел Создание раскрывающихся и контекстных меню Руководства по адаптации


Обзор доступа к меню (Процедура)

Доступ к меню
На уровень вверх ..
Обзор доступа к меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор доступа к меню >
Обзор доступа к меню
Понятие Процедура Краткий справочник

Отображение обозревателя меню

Отображение классической строки меню


Отображение обозревателя меню (Процедура)

Обзор доступа к меню
На уровень вверх ..
Обзор доступа к меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор доступа к меню >
Обзор доступа к меню
Понятие Процедура Краткий справочник

Отображение обозревателя меню

  • Нажмите кнопку обозревателя меню, расположенную в верхнем левом углу окна приложения.


Отображение классической строки меню (Процедура)

Обзор доступа к меню
На уровень вверх ..
Поиск в обозревателе меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор доступа к меню >
Обзор доступа к меню
Понятие Процедура Краткий справочник

Отображение классической строки меню

  • Щелкните правой кнопкой мыши на панели быстрого доступа и в контекстном меню выберите команду "Показать строку меню".
Ввод команды: MENUBAR


Обзор доступа к меню (Краткий справочник)

Адаптация ленты
Обзор доступа к меню
Поиск в обозревателе меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор доступа к меню >
Обзор доступа к меню
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

MENUBAR

Управление отображением строки меню

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Поиск в обозревателе меню (Понятие)

Обзор доступа к меню
Доступ к меню
Назначение ярлыков поиска
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню >
Поиск в обозревателе меню
Понятие Процедура Краткий справочник

Выполните в обозревателе меню поиск меню и операций меню в реальном времени.

Поле поиска отображается вверху обозревателя меню. Результаты поиска могут содержать команды меню, основные подсказки, текстовые строки запросов команд или ярлыки. Искомый термин можно ввести на любом языке. Команды меню отображаются в списке с меткой "Корневые меню", тогда как текстовые строки команд и ярлыки отображаются в списке, помеченном как "Связанные результаты".

Чтобы открыть обозреватель меню с активным полем поиска, нажмите сочетание клавиш ALT+S.

Для запуска анимации нажмите на стрелку "Показать".

В поиск можно включить любой текстовый знак или специальный символ. Результаты поиска меню отображаются в том же порядке, что и меню за исключением результата "Наилучшее соответствие" вверху списка. Чтобы выполнить команду меню, щелкните в списке требуемый результат поиска. Список результатов поиска содержит отключенные операции меню; однако эти операции меню невозможно выполнить.

См. также
    • Назначение ярлыков поиска


Очистка поля поиска в обозревателе меню (Процедура)

Обзор доступа к меню
На уровень вверх ..
Назначение ярлыков поиска
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Поиск в обозревателе меню >
Поиск в обозревателе меню
Понятие Процедура Краткий справочник

Очистка поля поиска в обозревателе меню

  1. Введите текст в поле поиска. Кнопка с изображением бинокля, расположенная справа от поля поиска, принимает вид значка [X].
  2. Щелкните значок [X] справа от поля поиска. Поле поиска очищается, и значок [X] принимает вид бинокля.
Контекстное меню:Когда текст введен, щелкните правой кнопкой мыши поле "Меню поиска" и в контекстном меню выберите команду "Удалить результаты".


Поиск в обозревателе меню (Краткий справочник)

Обзор доступа к меню
Поиск в обозревателе меню
Назначение ярлыков поиска
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Поиск в обозревателе меню >
Поиск в обозревателе меню
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Назначение ярлыков поиска (Понятие)

Поиск в обозревателе меню
Доступ к меню
Обзор файлов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню >
Назначение ярлыков поиска
Понятие Процедура Краткий справочник

Создайте ярлыки поиска для любой команды меню, чтобы сделать поиск более эффективным.

С помощью ярлыков можно объединять команды в соответствии с потребностями. Например, можно назначить группе команд меню, часто используемых для проекта, ярлык с именем для этого проекта. Создание и изменение ярлыков с помощью диалогового окна "Адаптация пользовательского интерфейса".

Любой ярлык, назначенный команде меню, отображается в подсказке для этой команды в обозревателе меню. Одной команде меню можно назначить любое число ярлыков.

См. также

    • Диалоговое окно "Редактор ярлыков" в документе Руководство по адаптации .


Назначение ярлыков поиска (Процедура)

Поиск в обозревателе меню
На уровень вверх ..
Назначение ярлыков поиска
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Назначение ярлыков поиска >
Назначение ярлыков поиска
Понятие Процедура Краткий справочник

Назначение ярлыка команде меню

Удаление ярлыка, назначенного команде меню


Назначение ярлыка команде меню (Процедура)

Назначение ярлыков поиска
На уровень вверх ..
Назначение ярлыков поиска
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Назначение ярлыков поиска >
Назначение ярлыков поиска
Понятие Процедура Краткий справочник

Назначение ярлыка команде меню

  1. Откройте вкладку "Инструменты" на [image] панели адаптации [image] пользовательского интерфейса. Введите в командной строке НПИ.
  2. В редакторе адаптации пользовательского интерфейса на вкладке "Адаптация" в области "Список команд" выберите команду, для которой требуется добавить ярлык.
  3. В области "Свойства" выделите поле "Ярлыки" и нажмите кнопку […].
  4. В диалоговом окне "Редактор ярлыков" в текстовом поле "Ярлыки" введите ярлык.

    При вводе ярлыка может появиться всплывающее окно, в котором будет отображаться список ранее использовавшихся ярлыков. Щелкните один из ярлыков в меню для использования вместо него введенного ярлыка. Для команды можно добавить более одного ярлыка; ярлыки следует разделять запятыми.

  5. Чтобы добавить другой ярлык для команды, нажмите клавишу СТРЕЛКА ВЛЕВО и введите ярлык. Повторите необходимое количество раз.
  6. Нажмите "ОК".
  7. В редакторе адаптации пользовательского интерфейса нажмите кнопку "OK".


Удаление ярлыка, назначенного команде меню (Процедура)

Назначение ярлыков поиска
На уровень вверх ..
Обзор файлов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Назначение ярлыков поиска >
Назначение ярлыков поиска
Понятие Процедура Краткий справочник

Удаление ярлыка, назначенного команде меню

  1. Откройте вкладку "Инструменты" на [image] панели адаптации [image] пользовательского интерфейса. Введите в командной строке НПИ.
  2. В редакторе адаптация пользовательского интерфейса на вкладке "Адаптация" в области "Список команд" выберите команду, из которой хотите удалить ярлык.
  3. В области "Свойства" выделите поле "Ярлыки" и нажмите кнопку […].
  4. В диалоговом окне "Редактор ярлыков" щелкните ярлык, который требуется удалить. Нажмите клавишу DELETE.
  5. Нажмите "ОК".
  6. В редакторе адаптации пользовательского интерфейса нажмите кнопку "OK".


Назначение ярлыков поиска (Краткий справочник)

Поиск в обозревателе меню
Назначение ярлыков поиска
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Назначение ярлыков поиска >
Назначение ярлыков поиска
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Обзор файлов

Назначение ярлыков поиска
Доступ к меню
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню >
Обзор файлов
Понятие Процедура

Просмотрите, отсортируйте и проверьте с точки зрения доступа поддерживаемые файлы, которые недавно открывались в AutoCAD.

Темы в этом разделе

  • Последние документы

    Выберите пункт "Последние документы" в обычных меню чертежей, чтобы просмотреть список недавно сохраненных файлов.

  • Открытые документы

    Выберите режим "Открытые документы" в обычных меню чертежей, чтобы просмотреть список файлов, которые в текущий момент открыты в AutoCAD.


Обзор файлов (Процедура)

Назначение ярлыков поиска
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов >
Обзор файлов
Понятие Процедура

Открытие документа, находящегося в списке "Последние документы"

Частичное открытие документа, находящегося в списке "Последние документы"

Открытие/частичное открытие документа в списке "Последние документы" только для чтения

Изменение параметров отображения предварительного просмотра последних документов

Изменение количества последних документов в списке

Удерживание документа в списке "Последние документы"

Просмотр списка последних документов по дате

Просмотр списка последних документов по типу

Очистка списка последних документов

Изменение параметров отображения предварительного просмотра открытых документов


Последние документы (Понятие)

Обзор файлов
Обзор файлов
Открытые документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов >
Последние документы
Понятие Процедура Краткий справочник

Выберите пункт "Последние документы" в обычных меню чертежей, чтобы просмотреть список недавно сохраненных файлов.

В меню "Последние документы" отображаются недавно использовавшиеся файлы, причем последний сохраненный файл показывается вверху списка. В списке последних документов можно просмотреть миниатюры файлов вместо значков, связанных с типами файлов.

Чтобы открыть обозреватель меню с активным меню "Последние документы", нажмите сочетание клавиш ALT+R.

Для запуска анимации нажмите на стрелку "Показать".

Закрепленные документы

Значок булавки, расположенный справа от имени файла, позволяет удерживать файл в списке независимо от файлов, сохраненных позже. Файл отображается внизу списка последних документов до тех пор, пока не будет отключена кнопка в виде булавки. Чтобы зафиксировать документ в списке "Последние документы", щелкните кнопку в виде булавки или выберите команду "Закрепить".

Параметры группы

Файлы можно сгруппировать по дате или типу. Чтобы просмотреть альтернативные параметры группирования, щелкните режим "Последние документы" над списком файлов или щелкните правой кнопкой мыши в пустой области списка.

Можно вывести список документов в соответствии с днем недели, когда файл был открыт или сохранен в последний раз.

См. также
    • Открытие или сохранение чертежа


Последние документы (Процедура)

Обзор файлов
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Открытие документа, находящегося в списке "Последние документы"

Частичное открытие документа, находящегося в списке "Последние документы"

Открытие/частичное открытие документа в списке "Последние документы" только для чтения

Изменение параметров отображения предварительного просмотра последних документов

Изменение количества последних документов в списке

Удерживание документа в списке "Последние документы"

Просмотр списка последних документов по дате

Просмотр списка последних документов по типу

Очистка списка последних документов


Открытие документа, находящегося в списке "Последние документы" (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Открытие документа, находящегося в списке "Последние документы"

  • Щелкните документ.
Контекстное меню:Щелкните документ правой кнопкой мыши и выберите в контекстном меню команду "Открыть".


Частичное открытие документа, находящегося в списке "Последние документы" (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Частичное открытие документа, находящегося в списке "Последние документы"

  • Щелкните документ правой кнопкой мыши и выберите в контекстном меню команду "Открыть часть".


Открытие/частичное открытие документа в списке "Последние документы" только для чтения (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Открытие/частичное открытие документа в списке "Последние документы" только для чтения

  • Щелкните документ правой кнопкой мыши и выберите в контекстном меню команду "Открыть для чтения" или "Открыть для чтения частично".


Изменение параметров отображения предварительного просмотра последних документов (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Изменение параметров отображения предварительного просмотра последних документов

  1. Нажмите кнопку "Обозреватель меню" и наведите указатель на "Последние документы".
  2. Под текстовым полем "Поиск" откройте меню "Параметры отображения".
  3. Выберите параметр отображения.

ПримечаниеВыбранный параметр отображения предварительного просмотра действует как в быстром меню "Последние документы", так и в быстром меню "Открытые документы".
Контекстное меню:Щелкните правой кнопкой мыши в пустом месте области просмотра последних документов. Выберите параметр отображения.


Изменение количества последних документов в списке (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Изменение количества последних документов в списке

  1. Выберите в меню "Сервис" пункт [image] "Настройка".Введите в командной строке настройка.
  2. В диалоговом окне "Настройка" щелкните вкладку "Открытие/Сохранение".
  3. В текстовом поле [image] "Количество последних файлов в меню" обозревателя меню введите количество последних документов, указываемых в списке. Допускается выбрать любое число между 0 и 50.


Удерживание документа в списке "Последние документы" (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Удерживание документа в списке "Последние документы"

  • Нажмите кнопку в виде булавки справа от документа.
Контекстное меню:Щелкните документ правой кнопкой мыши и выберите в контекстном меню команду "Закрепить".


Просмотр списка последних документов по дате (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Просмотр списка последних документов по дате

  • В верхнем левом углу области просмотра последних документов в раскрывающемся списке выберите пункт "Группировка по дате".


Просмотр списка последних документов по типу (Процедура)

Последние документы
На уровень вверх ..
Последние документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Просмотр списка последних документов по типу

  • В верхнем левом углу области просмотра последних документов в раскрывающемся списке выберите пункт "Группировка по типу".


Очистка списка последних документов (Процедура)

Последние документы
На уровень вверх ..
Открытые документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Очистка списка последних документов

  • Щелкните правой кнопкой мыши в быстром меню последних документов и выберите в контекстном меню команду "Очистить список последних документов".


Последние документы (Краткий справочник)

Назначение ярлыков поиска
Последние документы
Открытые документы
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Последние документы >
Последние документы
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Открытые документы (Понятие)

Последние документы
Обзор файлов
Просмотр последних операций
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов >
Открытые документы
Понятие Процедура Краткий справочник

Выберите режим "Открытые документы" в обычных меню чертежей, чтобы просмотреть список файлов, которые в текущий момент открыты в AutoCAD.

В списке "Открытые документы" последний открытый файл отображается вверху списка. Текущий файл отображается с переключателем слева от имени файла. В списке открытых документов можно просмотреть небольшие образцы файлов вместо значков, связанных с типами файлов.

Чтобы открыть обозреватель меню с активным быстрым меню открытых документов, нажмите сочетание клавиш ALT+C.

Для запуска анимации нажмите на стрелку "Показать".


Изменение параметров отображения предварительного просмотра открытых документов (Процедура)

Последние документы
На уровень вверх ..
Просмотр последних операций
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Открытые документы >
Открытые документы
Понятие Процедура Краткий справочник

Изменение параметров отображения предварительного просмотра открытых документов

  1. Нажмите кнопку "Обозреватель меню" и наведите указатель на пункт "Открытые документы".
  2. Под текстовым полем "Поиск" откройте меню "Параметры отображения".
  3. Выберите параметр отображения.

ПримечаниеВыбранный параметр отображения предварительного просмотра действует как в быстром меню "Последние документы", так и в быстром меню "Открытые документы".
Контекстное меню:Щелкните правой кнопкой мыши в пустом месте области просмотра открытых документов. Выберите параметр отображения.


Открытые документы (Краткий справочник)

Последние документы
Открытые документы
Просмотр последних операций
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Обзор файлов > Открытые документы >
Открытые документы
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Просмотр последних операций (Понятие)

Открытые документы
Доступ к меню
Местоположение других инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню >
Просмотр последних операций
Понятие Процедура Краткий справочник

Отобразите и выполните команды, к которым недавно обращались из обозревателя меню.

Выберите режим "Последние операции" в обычных меню чертежей, чтобы просмотреть список последних команд, к которым обращались из обозревателя меню. Команды меню отображаются с последней выполнявшейся командой вверху списка.

Чтобы открыть обозреватель меню с активным быстрым меню "Последние операции", нажмите сочетание клавиш ALT+A.

Для запуска анимации нажмите на стрелку "Показать".

Закрепленные команды

Щелкните кнопку в виде булавки справа от команды меню в списке, чтобы она отображалась независимо от команд, выполнявшихся позже. Команда отображается внизу списка последних операций до тех пор, пока не будет откреплена.


Просмотр последних операций (Процедура)

Открытые документы
На уровень вверх ..
Просмотр последних операций
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Просмотр последних операций >
Просмотр последних операций
Понятие Процедура Краткий справочник

Изменение количества последних операций в списке

Очистка списка последних операций


Изменение количества последних операций в списке (Процедура)

Просмотр последних операций
На уровень вверх ..
Просмотр последних операций
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Просмотр последних операций >
Просмотр последних операций
Понятие Процедура Краткий справочник

Изменение количества последних операций в списке

  1. Выберите в меню "Сервис" пункт [image] "Настройка".Введите в командной строке настройка.
  2. В диалоговом окне "Настройка" щелкните вкладку "Открытие/Сохранение".
  3. В текстовом поле [image] "Количество последних операций" обозревателя меню введите количество последних операций, указываемых в списке. Допускается выбрать любое число между 0 и 50.


Очистка списка последних операций (Процедура)

Просмотр последних операций
На уровень вверх ..
Местоположение других инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Просмотр последних операций >
Просмотр последних операций
Понятие Процедура Краткий справочник

Очистка списка последних операций

  • Щелкните правой кнопкой мыши в быстром меню последних операций и выберите в контекстном меню команду "Очистить список последних операций".


Просмотр последних операций (Краткий справочник)

Открытые документы
Просмотр последних операций
Инструменты в окне приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Доступ к меню > Просмотр последних операций >
Просмотр последних операций
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Местоположение других инструментов

Просмотр последних операций
Местоположение ленты, меню и других инструментов
Инструменты в окне приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов >
Местоположение других инструментов
Понятие Процедура

Чтобы найти дополнительные команды, параметры и режимы, используйте обычные инструменты в окне приложения, панели инструментов, инструментальные палитры, строки состояния, контекстные меню и Центр управления.

Темы в этом разделе

  • Инструменты в окне приложения

    В верхней части окна приложения отображаются часто применяемые инструменты, такие как обозреватель меню, панель быстрого доступа и Инфоцентр.

  • Панель быстрого доступа

    На панели быстрого доступа хранятся часто используемые команды. Это настраиваемая панель инструментов, которая содержит набор команд, определяемый рабочим пространством.

  • Панели

    Кнопки панелей используются для выполнения команд, вызова подменю и отображения всплывающих подсказок. Пользователь может выводить на экран и скрывать панели инструментов, закреплять их, изменять размер панелей.

  • Инструментальные палитры

    Инструментальные палитры представлены отдельными вкладками в окне "Палитры инструментов - все палитры". Они являются эффективным средством упорядочения, распределения и размещения блоков, штриховок и других инструментов. Палитры могут содержать инструменты, предоставленные сторонними разработчиками.

  • Строки состояния

    Строки состояний приложения и чертежа предоставляют полезные сведения, а также кнопки для включения и выключения инструментов рисования.

  • Контекстные меню

    Контекстные меню используются для быстрого доступа к командам, относящимся к текущим операциям.

  • Центр управления

    С помощью Центра управления осуществляется управление вхождениями блоков, внешними ссылками и другими элементами содержимого чертежей, такими как описания слоёв, листы и текстовые стили.


Местоположение других инструментов (Процедура)

Просмотр последних операций
Местоположение других инструментов
Панель быстрого доступа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Местоположение других инструментов
Понятие Процедура

Добавление команды на панель быстрого доступа

Удаление команды с панели быстрого доступа

Отображение панели

Закрепление панели

Открепление панели

Изменение размеров панели

Закрытие панели

Вызов контекстного меню

Отключение вызова контекстных меню в области построения чертежа

Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия

Управление отображением последних введенных команд


Инструменты в окне приложения (Понятие)

Местоположение других инструментов
Местоположение других инструментов
Панель быстрого доступа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Инструменты в окне приложения
Понятие Краткий справочник

В верхней части окна приложения отображаются часто применяемые инструменты, такие как обозреватель меню, панель быстрого доступа и Инфоцентр.

С помощью обозревателя меню можно просмотреть все меню в приложении. Дополнительные сведения об обозревателе меню см. в Обзор доступа к меню.

Панель быстрого доступа можно настроить для получения доступа к часто используемым командам. Для получения дополнительных сведений см. раздел Панель быстрого доступа.

В Инфоцентре можно искать источники информации и получать уведомления по продуктам. Дополнительные сведения о поиске и получении информации см. в Обзор поиска и получения информации

Строка поиска по содержимому

Строка поиска по содержимому позволяет искать в Интернете файлы чертежей производителей и других сторонних организаций.

ПримечаниеСтрока поиска доступна только на английском языке (США).


Инструменты в окне приложения (Краткий справочник)

Просмотр последних операций
Инструменты в окне приложения
Панель быстрого доступа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструменты в окне приложения >
Инструменты в окне приложения
Понятие Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Панель быстрого доступа (Понятие)

Инструменты в окне приложения
Местоположение других инструментов
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Панель быстрого доступа
Понятие Процедура Краткий справочник

На панели быстрого доступа хранятся часто используемые команды. Это настраиваемая панель инструментов, которая содержит набор команд, определяемый рабочим пространством.

На панели быстрого доступа можно добавлять, удалять команды и изменять их расположение. Допускается добавлять сколько угодно команд. Если места не хватает, команды сворачиваются во всплывающие кнопки.

Для запуска анимации нажмите на стрелку "Показать".

На панели быстрого доступа по умолчанию находятся следующие команды:

  • Новый
  • Открыть
  • Сохранить
  • Печать
  • Отменить
  • Повтор

Панель быстрого доступа можно настроить в соответствии с рабочим пространством. Для ознакомления с более подробной информацией см. Настройка панели инструментов быстрого доступа. Панели инструментов можно также отобразить с помощью контекстного меню панели быстрого доступа. Дополнительные сведения о панелях инструментов см. в разделе Панели.

ПримечаниеКогда открытых чертежей нет, на панели быстрого доступа отображаются только значки "Новый", "Открыть", "Диспетчер подшивок".


Панель быстрого доступа (Процедура)

Местоположение других инструментов
На уровень вверх ..
Панель быстрого доступа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панель быстрого доступа >
Панель быстрого доступа
Понятие Процедура Краткий справочник

Добавление команды на панель быстрого доступа

Удаление команды с панели быстрого доступа


Добавление команды на панель быстрого доступа (Процедура)

Панель быстрого доступа
На уровень вверх ..
Панель быстрого доступа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панель быстрого доступа >
Панель быстрого доступа
Понятие Процедура Краткий справочник

Добавление команды на панель быстрого доступа

  1. Щелкните панель быстрого доступа правой кнопкой мыши.
  2. Выберите в контекстном меню команду "Адаптация панели быстрого доступа".
  3. В редакторе адаптации пользовательского интерфейса перетащите команду из списка команд в требуемое место на панели быстрого доступа.
    СоветДля добавления нескольких команд удерживайте нажатой клавишу CTRL и выберите команды.
  4. Нажмите "ОК".
    ПримечаниеЕсли не нажать кнопку "ОК", команда не будет сохранена в рабочем пространстве. Команда отображается на панели инструментов только в текущем сеансе работы.


Удаление команды с панели быстрого доступа (Процедура)

Панель быстрого доступа
На уровень вверх ..
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панель быстрого доступа >
Панель быстрого доступа
Понятие Процедура Краткий справочник

Удаление команды с панели быстрого доступа

  1. Откройте вкладку "Инструменты" на [image] панели адаптации [image] пользовательского интерфейса. Введите в командной строке НПИ.
  2. В редакторе адаптации пользовательского интерфейса на вкладке "Адаптация" разверните в области "Адаптации в <имя файла>" узел "Рабочие пространства", щелкнув на знаке "плюс" (+) рядом с этим узлом.
  3. Выберите рабочее пространство, содержащее панель быстрого доступа, которую требуется изменить.
  4. В области "Содержимое рабочего пространства" щелкните на знаке "плюс" (+) рядом с панелью быстрого доступа, чтобы развернуть ее.
  5. Щелкните правой кнопкой мыши команду, которую надо удалить. В контекстном меню выберите команду "Удалить из рабочего пространства".
  6. Нажмите ОК.


Панель быстрого доступа (Краткий справочник)

Инструменты в окне приложения
Панель быстрого доступа
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панель быстрого доступа >
Панель быстрого доступа
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Панели (Понятие)

Панель быстрого доступа
Местоположение других инструментов
Инструментальные палитры
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Панели
Понятие Процедура Краткий справочник

Кнопки панелей используются для выполнения команд, вызова подменю и отображения всплывающих подсказок. Пользователь может выводить на экран и скрывать панели инструментов, закреплять их, изменять размер панелей.

Панели инструментов содержат кнопки, которые служат для запуска команд. Если на кнопку панели навести курсор мыши или другое устройство указания, выводится всплывающая подсказка с именем указанной кнопки. С кнопками, имеющими в своем правом нижнем углу маленький черный треугольник, связаны подменю, содержащие наборы родственных команд. Для вызова всплывающей панели необходимо подвести курсор к значку всплывающей панели и удерживать нажатой левую кнопку мыши.

По умолчанию панель быстрого доступа отображается вверху окна приложения. Эта панель инструментов подобна панелям программ Microsoft® Office. Она содержит такие часто используемые команды AutoCAD®, как ПЕЧАТЬ, ОТМЕНИТЬ и ПОВТОРИТЬ, а также такие стандартные команды Microsoft Office, как "Создать", "Открыть" и "Сохранить". Дополнительные сведения о панели быстрого доступа см. в разделе Панель быстрого доступа.

ПримечаниеПанель инструментов можно преобразовать в панель ленты с помощью диалогового окна "Адаптация интерфейса пользователя".

Отображение, скрытие, закрепление и изменение размеров панелей

Панели инструментов можно отобразить или скрыть и сохранить сделанные настройки в качестве рабочего пространства. Существует также возможность создания новых панелей.

Панель инструментов отображается как плавающая или закрепленная. Плавающая панель может находиться в любом месте области рисования, её можно перемещать в пределах этой области, изменять её размеры или закреплять. Закреплённые панели примыкают к одному из краев области построения чертежа. Панель, закрепленная на верхнем краю области чертежа, расположена под лентой. Закреплённую панель можно перетаскивать в другие зоны закрепления.

См. также

    • Создание рабочего пространства для конкретной задачи

    • Адаптация панелей инструментов в документе Руководство по адаптации

    • См. раздел Настройка панелей и вкладок ленты Руководства по адаптации


Панели (Процедура)

Панель быстрого доступа
На уровень вверх ..
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панели >
Панели
Понятие Процедура Краткий справочник

Отображение панели

Закрепление панели

Открепление панели

Изменение размеров панели

Закрытие панели


Отображение панели (Процедура)

Панели
На уровень вверх ..
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панели >
Панели
Понятие Процедура Краткий справочник

Отображение панели

Отображение панели инструментов с помощью одного из следующих методов

  • Нажмите правую кнопку мыши на любой панели инструментов и выберите панель в контекстном меню.
  • Щелкните панель быстрого доступа правой кнопкой мыши и выберите в контекстном меню панель.
  • Откройте меню "Сервис" [image] , щелкните пункт "Панели" и выберите панель для отображения на экране.


Закрепление панели (Процедура)

Панели
На уровень вверх ..
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панели >
Панели
Понятие Процедура Краткий справочник

Закрепление панели

  1. Поместите курсор на заголовок панели или в любом свободном от кнопок месте. Нажмите и удерживайте нажатой кнопку устройства указания.
  2. Перетащите панель в одну из зон закрепления вверху, внизу окна или у любого края области рисования.
  3. Когда контур панели появится в зоне закрепления, отпустите кнопку.

    Для перемещения панели в область закрепления без выполнения закрепления нужно во время перетаскивания удерживать нажатой клавишу CTRL.


Открепление панели (Процедура)

Панели
На уровень вверх ..
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панели >
Панели
Понятие Процедура Краткий справочник

Открепление панели

  1. Поместите курсор на ручку переноса на краю панели, нажмите и удерживайте нажатой кнопку устройства указания.
  2. Перетащите панель из места закрепления, затем отпустите кнопку.


Изменение размеров панели (Процедура)

Панели
На уровень вверх ..
Панели
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панели >
Панели
Понятие Процедура Краткий справочник

Изменение размеров панели

  1. Поместите курсор на край плавающей панели таким образом, чтобы курсор принял форму горизонтальной или вертикальной двойной стрелки.
  2. Удерживайте нажатой кнопку устройства указания и перемещайте курсор, пока панель не примет требуемые размеры.


Закрытие панели (Процедура)

Панели
На уровень вверх ..
Инструментальные палитры
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панели >
Панели
Понятие Процедура Краткий справочник

Закрытие панели

  1. Если панель закреплена, то открепите ее.
  2. Нажмите кнопку "Закрыть" в верхнем правом углу панели.


Панели (Краткий справочник)

Панель быстрого доступа
Панели
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Панели >
Панели
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

Системные переменные

TOOLTIPS

Управление отображением подсказок в инструментальных панелях

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструментальные палитры

Панели
Местоположение других инструментов
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Инструментальные палитры
Понятие Процедура

Инструментальные палитры представлены отдельными вкладками в окне "Палитры инструментов - все палитры". Они являются эффективным средством упорядочения, распределения и размещения блоков, штриховок и других инструментов. Палитры могут содержать инструменты, предоставленные сторонними разработчиками.

Темы в этом разделе

  • Создание инструментов из объектов и работа с ними

    Инструмент может быть создан простым перетаскиванием объектов из чертежа в область инструментальной палитры. С помощью такого инструмента можно впоследствии быстро строить объекты с теми же свойствами, что и исходный объект.

  • Создание и использование инструментов-команд

    На палитрах можно создавать инструменты, выполняющие одну команду или последовательность команд.

  • Изменение настроек инструментальных палитр

    Параметры и настройки инструментальных палитр могут быть изменены с помощью контекстных меню. Следует отметить, что вид контекстных меню зависит от того, в какой области инструментальной палитры нажать кнопку мыши.

  • Изменение свойств инструментов

    Можно изменять свойства любого из инструментов на палитре.

  • Адаптация инструментальных палитр

    Существует несколько способов добавления инструментов в палитру.

  • Организация инструментальных палитр

    Инструментальные палитры можно группировать по темам, а также задавать, какая группа палитр будет отображаться на экране.

  • Сохранение и совместное использование инструментальных палитр

    Можно сохранить инструментальную палитру и обмениваться ей с помощью ее экспорта и импорта как файла.


Инструментальные палитры (Процедура)

Панели
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Инструментальные палитры
Понятие Процедура

Открытие окна "Инструментальные палитры"

Создание инструмента из объекта текущего чертежа

Использование инструмента, созданного из геометрического объекта

Использование инструмента, созданного из размера

Использование инструмента из подменю палитры

Добавление или удаление подменю

Адаптация подменю инструмента

Использование инструмента, созданного из штриховки

Использование инструмента, созданного из градиентной заливки

Использование инструмента, созданного из блока, внешней ссылки или растрового изображения

Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры

Создание инструмента-команды на основе кнопки инструментальной панели.

Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные)

Использование инструмента-команды

Изменение степени прозрачности окна инструментальных палитр

Изменение стиля отображения значков в окне инструментальных палитр

Вывод информации о свойствах инструмента из палитры

Изменение свойства инструмента на палитре

Обновление изображения инструмента-блока на инструментальной палитре

Изменение изображения инструмента на палитре

Возврат к используемым по умолчанию изображению, названию и описанию для инструмента-подменю

Создание инструментальной палитры

Создание инструментальной палитры из папки или чертежа

Связывание группы инструментальных палитр с панелью ленты

Отображение группы инструментальных палитр, связанной с панелью ленты

Переименование инструментальной палитры

Удаление инструментальной палитры

Изменение расположения инструментальной палитры

Добавление текста на инструментальную палитру

Добавление разделительной линии на инструментальную палитру

Сортировка элементов на инструментальной палитре

Создание группы инструментальных палитр

Добавление инструментальной палитры в группу палитр

Исключение инструментальной палитры из группы палитр

Вывод группы инструментальных палитр на экран

Удаление группы инструментальных палитр

Удаление всех групп инструментальных палитр

Переименование группы инструментальных палитр

Переупорядочение группы палитр

Создание группы инструментальных палитр, вложенной в другую группу

Копирование и вставка палитры из одной группы в другую

Изменение порядка расположения палитр внутри группы

Изменение порядка расположения палитр, когда все они выведены на экран

Вывод всех инструментальных палитр на экран

Обмен инструментальной палитрой

Обмен группой инструментальных палитр


Создание инструментов из объектов и работа с ними (Понятие)

Инструментальные палитры
Инструментальные палитры
Создание и использование инструментов-команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Инструмент может быть создан простым перетаскиванием объектов из чертежа в область инструментальной палитры. С помощью такого инструмента можно впоследствии быстро строить объекты с теми же свойствами, что и исходный объект.

Инструментальные палитры представлены отдельными вкладками в специальном окне. Каждая инструментальная палитра содержит один или более инструментов. Инструменты можно создавать перетаскиванием объектов следующих типов (по одному объекту за одно перетаскивание):

  • отрезки, круги, полилинии и другие геометрические объекты
  • размеры
  • блоки
  • штриховки
  • сплошные заливки
  • градиентные заливки
  • растровые изображения
  • внешние ссылки
ПримечаниеПри перетаскивании объекта на инструментальную панель можно перейти на другую вкладку, удерживая курсор мыши на требуемой вкладке в течение нескольких секунд.

С помощью такого инструмента можно впоследствии быстро строить объекты с теми же свойствами, что и исходный объект. Примером инструмента, созданного с помощью перетаскивания объекта, может служить круг красного цвета, имеющий вес линий 0,05 мм. Так же можно создавать инструменты из имеющихся блоков и внешних ссылок.

При перетаскивании геометрического объекта или размера на палитру автоматически создается новый инструмент с соответствующим подменю. Например, инструменты, созданные на основе размеров, содержат подменю, с помощью которого можно наносить размеры различных типов. Подменю раскрываются нажатием на символе стрелки справа от значка инструмента на палитре. При использовании инструмента из всплывающего меню объект чертежа имеет те же свойства, что и исходный инструмент на инструментальной палитре.

Вставка блоков и ссылок

Можно выбрать режим, в котором при щелчке мышью для размещения блока или внешней ссылки отображается запрос на ввод угла поворота (начиная с 0). В этом режиме игнорируется угол, заданный в поле "Поворот" диалогового окна "Свойства инструмента". Запрос угла поворота не отображается, если перетащить блок или внешнюю ссылку либо если ввести поворот в командной строке при вставке начальной точки.

Блоки, которые пользователь перетаскивает мышью из палитры в область рисования, можно масштабировать и поворачивать после того, как они станут объектами чертежа. При перетаскивании блоков из инструментальной палитры можно использовать объектную привязку; шаговая привязка при этом подавляется. При использовании инструмента блока или инструмента штриховки можно установить вспомогательный масштаб для переопределения настройки обычного масштаба. (Во вспомогательном масштабе значение текущей настройки масштаба умножается на масштаб чертежа или масштаб размера.)

Блоки, перетаскиваемые с инструментальной палитры, автоматически масштабируются в соответствии с отношением единиц измерения в блоке и текущем чертеже. Например, если в текущем чертеже используются метры в качестве единиц измерения, а в блоке используются сантиметры, отношение единиц измерения равно 1 м/100 см. При перетаскивании блока в чертеж он вставляется с масштабом 1/100.

ПримечаниеВ диалоговом окне "Настройка" на вкладке "Пользовательские" находятся раскрывающиеся списки "Единицы исходного чертежа" и "Единицы целевого чертежа". Выбранные в них единицы используются в том случае, когда единицы вставки не заданы в исходном блоке или целевом чертеже.

Обновление определений блоков на инструментальных панелях

Когда блок изменяют в исходном чертеже, определение блока в текущем чертеже не обновляется автоматически. Чтобы обновить определение блока в текущем чертеже, щелкните правой кнопкой мыши инструмент блока на инструментальной палитре и выберите в контекстном меню команду "Переопределить".

Если команда "Переопределить" недоступна, источником определения блока является файл чертежа, а не блок, вставленный в файл чертежа. Для обновления определения блока, созданного с помощью вставки файла чертежа, следует использовать Центр управления. Дополнительную информацию см. в разделе Добавление содержимого с помощью Центра управления.

ПримечаниеЕсли исходный файл чертежа для инструмента работы с блоками переместить в другую папку, необходимо изменить инструмент, который ссылается на него, щелкнув инструмент правой кнопкой мыши и указав новую папку исходного файла в диалоговом окне "Свойства инструмента".
См. также

    • Изменение свойств инструментов

    • Адаптация инструментальных палитр

    • Создание рабочего пространства для конкретной задачи

    • Добавление содержимого с помощью Центра управления


Создание инструментов из объектов и работа с ними (Процедура)

Инструментальные палитры
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Открытие окна "Инструментальные палитры"

Создание инструмента из объекта текущего чертежа

Использование инструмента, созданного из геометрического объекта

Использование инструмента, созданного из размера

Использование инструмента из подменю палитры

Добавление или удаление подменю

Адаптация подменю инструмента

Использование инструмента, созданного из штриховки

Использование инструмента, созданного из градиентной заливки

Использование инструмента, созданного из блока, внешней ссылки или растрового изображения

Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры


Открытие окна "Инструментальные палитры" (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Открытие окна "Инструментальные палитры"

  • Выберите меню "Сервис" [image] "Палитры" [image] "Инструментальные палитры".В командной строке введите ИнстрПалОткл.
  • Можно также нажать комбинацию клавиш CTRL+3.
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Создание инструмента из объекта текущего чертежа (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Создание инструмента из объекта текущего чертежа

  1. Выберите объект в текущем чертеже, например размер, блок, штриховку, градиентную заливку, растровое изображение, внешнюю ссылку или любой геометрический объект.
  2. Перетащите объект из области рисования на инструментальную палитру и, не отпуская кнопку мыши, укажите местоположение инструмента на палитре.

    Можно перейти на другую вкладку, удерживая курсор мыши на требуемой вкладке в течение нескольких секунд. Черная линия указывает местоположение инструмента.

  3. Отпустите кнопку мыши.
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из геометрического объекта (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Использование инструмента, созданного из геометрического объекта

  1. Нажмите кнопку мыши на инструменте-объекте, расположенном на палитре.
  2. Следуйте подсказкам в командной строке и используйте инструмент, как если был бы выбран соответствующий параметр из меню "Рисование" или нажата соответствующая кнопка на панели "Рисование".

    Построенный геометрический объект имеет те же свойства, что и выбранный инструмент в палитре.

Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из размера (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Использование инструмента, созданного из размера

  1. Нажмите кнопку мыши на инструменте-размере, расположенном на палитре.
  2. Следуйте подсказкам в командной строке и используйте инструмент, как если был бы выбран соответствующий параметр из меню "Размеры" или нажата соответствующая кнопка на панели "Размеры".

    Построенный размер имеет те же свойства и стиль, что и выбранный инструмент в палитре.

Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента из подменю палитры (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Использование инструмента из подменю палитры

  1. На палитре нажмите кнопку мыши на символе стрелки справа от нужного инструмента-размера или инструмента-объекта.
  2. Из раскрывшегося подменю выберите инструмент.
  3. Следуйте подсказкам в командной строке и используйте инструмент, как если был бы выбран соответствующий параметр из меню или нажата соответствующая кнопка на панели.

    Построенный объект имеет те же свойства, что и выбранный из всплывающего меню инструмент.

Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Добавление или удаление подменю (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Добавление или удаление подменю

  1. Нажмите правую кнопку мыши на инструменте-объекте, расположенном на палитре, к которому необходимо добавить (или удалить) подменю. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе команд нажмите кнопку мыши в поле "Использование подменю".
  3. Из раскрывающегося списка выберите "Да", если нужно добавить подменю, и "Нет", если нужно удалить его.
  4. Нажмите "ОК".
    ПримечаниеЕсли удалить всплывающее меню инструмента, а затем вновь добавить его, изображение значка, название и описание (всплывающая подсказка) для этого инструмента могут измениться по сравнению с исходными. В этом случае следует восстановить стандартные значения параметров: значок, название и описание инструмента. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Возврат к используемым по умолчанию изображению, названию и описанию для инструмента-подменю .
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Адаптация подменю инструмента (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Адаптация подменю инструмента

  1. На палитре нажмите правую кнопку мыши на инструменте-объекте или инструменте-размере, подменю которого нужно настроить. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе команд нажмите кнопку мыши в поле "Настройка". Нажмите кнопку [...].
  3. В диалоговом окне "Параметры" выберите инструменты, которые должны отображаться во всплывающем меню. Нажмите "ОК". (Необходимо выбрать хотя бы один инструмент.)
  4. В диалоговом окне "Свойства инструмента" нажмите "ОК".
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из штриховки (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Использование инструмента, созданного из штриховки

  1. С помощью мыши перетащите инструмент-штриховку из палитры на чертёж в пределы объекта, который необходимо заштриховать.
  2. Отпустите кнопку мыши для выполнения штриховки объекта.

    Нанесенная штриховка имеет те же свойства и стиль, что и выбранный инструмент в палитре.

Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из градиентной заливки (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Использование инструмента, созданного из градиентной заливки

  1. С помощью мыши перетащите инструмент градиентной заливки из палитры на чертёж в пределы объекта, к которому её следует применить.
  2. Отпустите кнопку мыши для применения градиентной заливки к объекту чертежа.

    Градиентная заливка имеет те же свойства и стиль, что и выбранный инструмент в палитре.

Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Использование инструмента, созданного из блока, внешней ссылки или растрового изображения (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание инструментов из объектов и работа с ними
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Использование инструмента, созданного из блока, внешней ссылки или растрового изображения

  1. На инструментальной палитре нажмите кнопку мыши на элементе, который нужно вставить в чертёж: блоке, внешней ссылке или растровом изображении.
  2. Перетащите блок, ссылку или растровое изображение в нужное место чертежа.
  3. Отпустите кнопку мыши.

    Вставленный блок, внешняя ссылка или растровое изображение имеют те же свойства, что и выбранный инструмент в палитре.

Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание и использование инструментов-команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Запрос угла поворота при вставке блока или внешней ссылки из инструментальной палитры

  1. Нажмите правую кнопку мыши на инструменте, созданном из блока или внешней ссылки. Выберите "Свойства".
  2. В группе "Вставка" диалогового окна "Свойства инструмента" нажмите кнопку мыши в строке "Запрос угла поворота".
  3. Выберите "Да" в раскрывающемся списке.
  4. Нажмите "ОК".
    ПримечаниеВ этом режиме игнорируется угол, заданный в поле "Поворот" диалогового окна "Свойства инструмента". Запрос угла поворота не отображается, если перетащить блок или внешнюю ссылку, либо если ввести поворот в командной строке при вставке начальной точки.
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Создание инструментов из объектов и работа с ними (Краткий справочник)

Панели
Создание инструментов из объектов и работа с ними
Создание и использование инструментов-команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание инструментов из объектов и работа с ними >
Создание инструментов из объектов и работа с ними
Понятие Процедура Краткий справочник

Команды

АДАПТАЦИЯ

Адаптация инструментальных палитр

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ИНСТРПАЛОТКЛ

Закрытие окна инструментальных палитр

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

INSUNITSDEFSOURCE

Задание единиц измерения исходного содержимого, когда переменная INSUNITS имеет значение равное 0

INSUNITSDEFTARGET

Задание единиц измерения в целевом чертеже, когда переменная INSUNITS имеет значение равное 0

PALETTEOPAQUE

Управление прозрачностью окон

TPSTATE

Указание на открытое или закрытое состояние инструментальной палитры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и использование инструментов-команд (Понятие)

Создание инструментов из объектов и работа с ними
Инструментальные палитры
Изменение настроек инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Создание и использование инструментов-команд
Понятие Процедура Краткий справочник

На палитрах можно создавать инструменты, выполняющие одну команду или последовательность команд.

Часто используемые команды можно помещать на инструментальную палитру. Если открыто диалоговое окно "Адаптация", инструменты можно перетаскивать на инструментальную палитру с панели инструментов или из редактора "Адаптация интерфейса пользователя" (АПИ).

После того, как команда помещена на палитру в качестве инструмента, её можно вызывать нажатием кнопки мыши на инструменте. Например, можно поместить на палитру команду сохранения чертежа. Тогда эта команда при вызове с палитры будет выполняться так же, как если бы она была вызвана с помощью кнопки стандартной панели инструментов.

Можно также создать инструмент, выполняющий цепочку команд или специально настроенных команд, например процедуру на языке AutoLISP®, макрос, приложение или сценарий на языке VBA.

ПримечаниеХотя инструменты на палитрах можно активизировать при открытом редакторе "Адаптация интерфейса пользователя" (АПИ), конечные результаты могут оказаться непредсказуемыми. Рекомендуется отказаться от использования инструментов палитры на то время, пока отображается редактор "Адаптация интерфейса пользователя" (АПИ).


Создание и использование инструментов-команд (Процедура)

Создание инструментов из объектов и работа с ними
На уровень вверх ..
Создание и использование инструментов-команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание и использование инструментов-команд >
Создание и использование инструментов-команд
Понятие Процедура Краткий справочник

Создание инструмента-команды на основе кнопки инструментальной панели.

Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные)

Использование инструмента-команды


Создание инструмента-команды на основе кнопки инструментальной панели. (Процедура)

Создание и использование инструментов-команд
На уровень вверх ..
Создание и использование инструментов-команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание и использование инструментов-команд >
Создание и использование инструментов-команд
Понятие Процедура Краткий справочник

Создание инструмента-команды на основе кнопки инструментальной панели.

  1. Убедитесь, что отображена панель инструментов, содержащая команду, которую необходимо добавить в палитру.

    Если требуемая панель инструментов не отображается, нажмите правую кнопку мыши на любой отображенной панели и выберите в списке другую панель.

  2. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
    ПримечаниеДаже если во время этой процедуры не требуется выполнять никаких изменений в диалоговом окне "Адаптация", оно должно быть отображено во время добавления инструментов-команд на инструментальную палитру.
  3. В программе перетащите команду (кнопку), не отпуская кнопку мыши, с панели инструментов на инструментальную палитру; поместите курсор в то место палитры, куда требуется поместить инструмент.

    Черная горизонтальная линия указывает возможное местоположение инструмента.

  4. Отпустите кнопку мыши.
  5. В диалоговом окне "Адаптация" нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Создание и использование инструментов-команд (Процедура)

Создание и использование инструментов-команд
На уровень вверх ..
Создание и использование инструментов-команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание и использование инструментов-команд >
Создание и использование инструментов-команд
Понятие Процедура Краткий справочник

Создание инструмента-команды из окна "Адаптация интерфейса пользователя"

  1. Откройте вкладку "Инструменты" на [image] панели адаптации [image] пользовательского интерфейса. Введите в командной строке "НПИ".

    Если окно "Палитры инструментов - все палитры" перекрывается, сместите в сторону окно АПИ.

  2. Из области "Списка команд" перетащите команду на инструментальную палитру и, не отпуская кнопку мыши, переместите курсор в то место палитры, куда требуется поместить инструмент.

    Черная горизонтальная линия указывает возможное местоположение инструмента.

  3. Отпустите кнопку мыши.
  4. В диалоговом окне АПИ нажмите кнопку "Закрыть".
Ввод команды: НПИ


Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные) (Процедура)

Создание и использование инструментов-команд
На уровень вверх ..
Создание и использование инструментов-команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание и использование инструментов-команд >
Создание и использование инструментов-команд
Понятие Процедура Краткий справочник

Для создания инструмента-команды, выполняющего несколько команд или специальные команды (расширенные)

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В программе перетащите команду, не отпуская кнопку мыши, с панели инструментов на инструментальную палитру; поместите курсор в то место палитры, куда требуется поместить инструмент.
  3. Отпустите кнопку мыши.
  4. На инструментальной палитре щелкните инструмент правой кнопкой мыши. Выберите "Свойства".
  5. В диалоговом окне "Свойства инструмента" измените имя и описание последовательности команд на подходящее имя и описание строки, процедуры AutoLISP или сценария.
  6. В разделе команд, в поле "Командная строка", введите последовательность команд или специальные команды, такие как процедура AutoLISP, макрос или приложение VBA, или сценарий.
  7. Нажмите "ОК".
Ввод команды: АДАПТАЦИЯ


Использование инструмента-команды (Процедура)

Создание и использование инструментов-команд
На уровень вверх ..
Изменение настроек инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание и использование инструментов-команд >
Создание и использование инструментов-команд
Понятие Процедура Краткий справочник

Использование инструмента-команды

  1. Нажмите на инструменте-команде, расположенной на палитре.
  2. Следуйте всем подсказкам, отображаемым в командной строке.


Создание и использование инструментов-команд (Краткий справочник)

Создание инструментов из объектов и работа с ними
Создание и использование инструментов-команд
Изменение настроек инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Создание и использование инструментов-команд >
Создание и использование инструментов-команд
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

АДАПТАЦИЯ

Адаптация инструментальных палитр

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ИНСТРПАЛОТКЛ

Закрытие окна инструментальных палитр

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение настроек инструментальных палитр (Понятие)

Создание и использование инструментов-команд
Инструментальные палитры
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Изменение настроек инструментальных палитр
Понятие Процедура Краткий справочник

Параметры и настройки инструментальных палитр могут быть изменены с помощью контекстных меню. Следует отметить, что вид контекстных меню зависит от того, в какой области инструментальной палитры нажать кнопку мыши.

Можно закрепить окно инструментальных палитр у правого или левого края окна приложения. Для того, чтобы избежать закрепления окна, при его перемещении нужно держать нажатой клавишу CTRL .

Настройки инструментальной палитры сохраняются в профиле.

К этим настройкам относятся:

  • Разрешить закрепление. Включение/отключение возможности закрепления или привязки окон палитр. Если выбран этот режим, окно закрепляется, когда его перетаскивают в область закрепления на одной из сторон чертежа. Зафиксированное окно сцепляется с боковой стороной окна приложения и вызывает изменение размера области рисования. При выборе этого режима становятся доступными пункты "Прикрепить якорем справа" и "Прикрепить якорем слева".
  • Прикрепить якорем слева или Прикрепить якорем справа. Палитра прикрепляется к базовой точке значка якоря с левой или правой стороны области рисования. Палитра сворачивается и разворачивается, когда её пересекает курсор. Когда привязанная палитра открыта, её содержимое перекрывает область рисования. Не существует настройки, позволяющей держать открытой привязанную палитру.
  • Авто-скрытие.Управление отображением плавающей палитры. Если выбран этот режим, то при уходе курсора за пределы палитры на экране остается только заголовок палитры. Если этот режим отменен, палитра все время остается открытой. Строка заголовка инструментальной палитры может иметь вид значков или текста в меню быстрого вызова строки заголовка.
  • Прозрачность. Задаётся параметр прозрачности окна "Палитры инструментов - все палитры", чтобы оно не скрывало находящиеся под ним объекты.
  • Виды. Изменение стиля отображения и размера значков на инструментальной палитре.


Изменение настроек инструментальных палитр (Процедура)

Создание и использование инструментов-команд
На уровень вверх ..
Изменение настроек инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение настроек инструментальных палитр >
Изменение настроек инструментальных палитр
Понятие Процедура Краткий справочник

Изменение степени прозрачности окна инструментальных палитр

Изменение стиля отображения значков в окне инструментальных палитр


Изменение настроек инструментальных палитр (Процедура)

Изменение настроек инструментальных палитр
На уровень вверх ..
Изменение настроек инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение настроек инструментальных палитр >
Изменение настроек инструментальных палитр
Понятие Процедура Краткий справочник

Изменение режима сворачивания и разворачивания окна инструментальных палитр

  • Нажмите кнопку "Авто-скрытие" в нижней части заголовка окна инструментальных палитр.

Режим разворачивания/сворачивания включён.

Режим разворачивания/сворачивания отключен.

ПримечаниеРежим разворачивания/сворачивания доступен только в случае, когда окно инструментальных палитр не закреплено.


Изменение степени прозрачности окна инструментальных палитр (Процедура)

Изменение настроек инструментальных палитр
На уровень вверх ..
Изменение настроек инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение настроек инструментальных палитр >
Изменение настроек инструментальных палитр
Понятие Процедура Краткий справочник

Изменение степени прозрачности окна инструментальных палитр

  1. Щелкните правой кнопкой мыши строку заголовка окна инструментальных палитр. Выберите в контекстном меню пункт "Прозрачность".
  2. В диалоговом окне "Прозрачность" задайте степень прозрачности для окна инструментальных палитр. Нажмите "ОК".
    ПримечаниеПараметр прозрачности доступен только в том случае, когда окно инструментальных палитр не закреплено.


Изменение стиля отображения значков в окне инструментальных палитр (Процедура)

Изменение настроек инструментальных палитр
На уровень вверх ..
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение настроек инструментальных палитр >
Изменение настроек инструментальных палитр
Понятие Процедура Краткий справочник

Изменение стиля отображения значков в окне инструментальных палитр

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Параметры отображения".
  2. В диалоговом окне "Параметры отображения" выберите вариант отображения элементов, который требуется задать. Можно также изменять размер значков.
  3. В списке "Применить для" выберите "Палитра - текущая" или "Палитры - все".
  4. Нажмите "ОК".


Изменение настроек инструментальных палитр (Краткий справочник)

Создание и использование инструментов-команд
Изменение настроек инструментальных палитр
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение настроек инструментальных палитр >
Изменение настроек инструментальных палитр
Понятие Процедура Краткий справочник

Команды

АДАПТАЦИЯ

Адаптация инструментальных палитр

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ИНСТРПАЛОТКЛ

Закрытие окна инструментальных палитр

Системные переменные

PALETTEOPAQUE

Управление прозрачностью окон

TPSTATE

Указание на открытое или закрытое состояние инструментальной палитры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение свойств инструментов (Понятие)

Изменение настроек инструментальных палитр
Инструментальные палитры
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Можно изменять свойства любого из инструментов на палитре.

После создания инструмента на палитре его свойства можно изменять. К таким свойствам, например, относятся масштаб блока при вставке в чертёж и угол поворота образца штриховки.

Для изменения свойств инструмента нажмите на нем правую кнопку мыши и в контекстном меню выберите пункт "Свойства объекта". Появляется диалоговое окно "Свойства инструмента". Это диалоговое окно содержит две категории свойств:

  • Свойства вставки или образца. Свойства, относящиеся к управлению объектом, например масштаб, поворот и угол.
  • Общие свойства.Отмена текущих настроек, относящихся к свойствам чертежа, например слой, цвет и тип линии.

Можно сворачивать и разворачивать категории свойств, нажимая на кнопках со стрелками.

Задание другого значка для инструмента

Можно заменить значок инструмента на указанное пользователем изображение. Это полезно тогда, когда автоматически создаваемый значок слишком сложен, чтобы его можно было легко опознать.

Для замены изображения нажмите правую кнопку мыши на инструменте на инструментальной панели и выберите "Указать изображение" в контекстном меню.

Для восстановления изображения инструмента по умолчанию нажмите правую кнопку мыши на инструменте и выберите "Удалить указанное изображение".

Обновление значков инструментов

Значки инструментов палитры, созданных из блоков, внешних ссылок или растровых изображений, не обновляются автоматически при изменении их описаний. При изменении определения блока, внешней ссылки или растрового изображения можно обновить значок, нажав правую кнопку мыши на инструменте в палитре и щелкнув "Обновить изображение инструмента". Перед обновлением изображения инструмента чертёж необходимо сохранить.

Другой способ заключается в удалении инструмента и последующей замене его с помощью модуля Центра управления™.

Переопределения свойств инструментов

В некоторых случаях бывает необходимо присвоить инструменту специфические переопределения свойств. Например, может возникнуть необходимость автоматического размещения штриховки на определённом слое, независимо от того, какой слой является текущим. Эта возможность помогает сэкономить время и уменьшить количество ошибок.

С помощью диалогового окна "Свойства инструмента" можно переопределить любое свойство.

Переопределение свойств слоя может повлиять на цвет, тип линий, вес линий, стиль печати и саму печать. Переопределение свойств слоя происходит следующим образом:

  • Если слой отсутствует в чертеже, то он автоматически создается.
  • Если слой отключён или заморожен, то он временно включается или размораживается.


Изменение свойств инструментов (Процедура)

Изменение настроек инструментальных палитр
На уровень вверх ..
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение свойств инструментов >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Вывод информации о свойствах инструмента из палитры

Изменение свойства инструмента на палитре

Обновление изображения инструмента-блока на инструментальной палитре

Изменение изображения инструмента на палитре

Возврат к используемым по умолчанию изображению, названию и описанию для инструмента-подменю


Вывод информации о свойствах инструмента из палитры (Процедура)

Изменение свойств инструментов
На уровень вверх ..
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение свойств инструментов >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Вывод информации о свойствах инструмента из палитры

  1. На инструментальной палитре нажмите на инструменте правой кнопкой мыши. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента", используя полосу прокрутки, просмотрите все свойства инструмента.

    Можно изменять размер диалогового окна с помощью мыши или сворачивать и разворачивать категории свойств, нажимая кнопку мыши на двойных стрелках рядом с их названиями.

  3. Нажмите "ОК".


Изменение свойства инструмента на палитре (Процедура)

Изменение свойств инструментов
На уровень вверх ..
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение свойств инструментов >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Изменение свойства инструмента на палитре

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" выберите свойство из списка и задайте новое значение.
    • Свойства, перечисленные в категории "Вставка" или "Образец", задают такие специфические свойства объекта, как масштаб, поворот и угол.
    • Свойства, перечисленные в категории "Общие", переопределяют настройки текущих свойств чертежа, таких как слой, цвет и тип линий.
    • При использовании инструмента вспомогательный масштаб для блока или инструмента штриховки переопределяет значение обычного масштаба. (Во вспомогательном масштабе значение текущей настройки масштаба умножается на масштаб чертежа или масштаб размера.)

    Можно изменять размер диалогового окна с помощью мыши или сворачивать и разворачивать категории свойств, нажимая мышью на двойных стрелках рядом с их названиями.

  3. Нажмите "ОК".
    ПримечаниеЕсли для инструмента, имеющего подменю, задать изображение значка, название и описание, то они отображаются для каждого из инструментов подменю. Для восстановления стандартных изображений значка, названия и описания следует оставить незаполненными соответствующие текстовые поля диалогового окна "Свойства инструмента".
Панель:Стандартный
Ввод команды: ИНСТРПАЛВКЛ


Обновление изображения инструмента-блока на инструментальной палитре (Процедура)

Изменение свойств инструментов
На уровень вверх ..
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение свойств инструментов >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Обновление изображения инструмента-блока на инструментальной палитре

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши.
  2. Выберите "Обновить изображение инструмента".
    ПримечаниеПеред обновлением изображения инструмента чертеж необходимо сохранить.
Панель:Стандартный
Ввод команды: ИНСТРПАЛВКЛ


Изменение изображения инструмента на палитре (Процедура)

Изменение свойств инструментов
На уровень вверх ..
Изменение свойств инструментов
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение свойств инструментов >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Изменение изображения инструмента на палитре

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши.
  2. В контекстном меню выберите "Указать изображение".
  3. В диалоговом окне "Выбор файла изображения" выберите файл изображения для значка.
  4. Для вставки нового изображения нажмите кнопку "Открыть".
    ПримечаниеЕсли для инструмента, имеющего подменю, задать изображение значка, то оно отображается для каждого инструмента из подменю. Подробнее о восстановлении стандартных значков для инструментов подменю см. раздел Возврат к используемым по умолчанию изображению, названию и описанию для инструмента-подменю .
Панель:Стандартный
Ввод команды: ИНСТРПАЛВКЛ


Возврат к используемым по умолчанию изображению, названию и описанию для инструмента-подменю (Процедура)

Изменение свойств инструментов
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение свойств инструментов >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Возврат к используемым по умолчанию изображению, названию и описанию для инструмента-подменю

  1. На инструментальной палитре нажмите на инструменте правую кнопку мыши. Выберите "Свойства".
  2. В диалоговом окне "Свойства инструмента" щелкните правой кнопкой мыши в области изображения. В контекстном меню выберите команду "Удалить изображение".
  3. Поместите курсор в поле "Название" и удалите текст.
  4. Поместите курсор в поле "Описание" и удалите текст.
  5. Нажмите "ОК".
    ПримечаниеЗадание пустых значений в полях "Значок", "Название" и "Описание" диалогового окна "Свойства инструмента" вызывает возврат к стандартным значениям для значка, названия и описания.
Панель:Стандартный
Ввод команды: ИНСТРПАЛВКЛ


Изменение свойств инструментов (Краткий справочник)

Изменение настроек инструментальных палитр
Изменение свойств инструментов
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Изменение свойств инструментов >
Изменение свойств инструментов
Понятие Процедура Краткий справочник

Команды

АДАПТАЦИЯ

Адаптация инструментальных палитр

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ИНСТРПАЛОТКЛ

Закрытие окна инструментальных палитр

ИППЕРЕЙТИ

Отображение заданной инструментальной палитры или группы палитр

Системные переменные

PALETTEOPAQUE

Управление прозрачностью окон

TPSTATE

Указание на открытое или закрытое состояние инструментальной палитры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Адаптация инструментальных палитр (Понятие)

Изменение свойств инструментов
Инструментальные палитры
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Существует несколько способов добавления инструментов в палитру.

Новую палитра создаётся с помощью кнопки "Свойства" в заголовке окна "Инструментальные палитры - все палитры". Добавление инструментов в инструментальную палитру подразумевает следующие методы:

  • Перетаскивание на палитру любого из следующих элементов чертежа: геометрических объектов (отрезков, кругов и полилиний), размеров, штриховок, градиентных заливок, блоков, внешних ссылок, растровых изображений.
  • Перетаскивание чертежей, блоков и штриховок из Центра управления. Если на палитру добавлен целый чертеж, то при перетаскивании его из палитры в графическую область он вставляется как блок.
  • Для перетаскивания команд на инструментальную палитру (так же, как и на панели инструментов) следует использовать диалоговое окно "Адаптация".
  • Для перетаскивания команд из области "Список команд" на инструментальную палитру следует использовать редактор "Адаптация интерфейса пользователя".
  • Копирование и перемещение инструментов с других палитр. Для этого служат пункты контекстного меню "Вырезать", "Копировать" и "Вставить".
  • Управление инструментальными палитрами путём создания новых палитр с нуля, переименования, удаления или перемещения палитр с помощью контекстного меню.
    ПримечаниеНе рекомендуется создавать или переименовывать инструментальные палитры, когда отображается редактор "Адаптация интерфейса пользователя" (АПИ).
  • Для создания палитры, заполненной предусмотренными инструментами, нажмите правую кнопку мыши на папке, файле чертежа или блоке в области структуры Центра управления, затем в контекстном меню выберите пункт "Создать инструментальную палитру".

  • С каждой панелью на ленте можно связать настраиваемую группу инструментальных палитр. По щелчку панели ленты правой кнопкой мыши отображается список доступных групп инструментальных палитр.
ПримечаниеЕсли исходный файл чертежа, из которого создан инструмент в виде блока, внешней ссылки или растрового изображения, перемещён в другую папку, необходимо изменить параметры инструмента, который ссылается на него. Для этого нажмите правую кнопку мыши на инструменте и задайте новый путь к папке исходного файла в окне "Свойства инструмента".

Переупорядочение инструментов и инструментальных палитр

После того как инструменты помещены на инструментальную палитру, их можно переупорядочить. Для этого перетащите их в нужные положения или отсортируйте. В инструментальные палитры можно также добавлять текст и разделительные линии.

Любую инструментальную палитру можно перемещать вверх или вниз в последовательности вкладок с помощью контекстного меню или вкладки "Палитры инструментов - все палитры" диалогового окна "Адаптация". Инструментальные палитры, необходимость в которых отпала, можно удалить. Удаленные инструментальные палитры легко восстанавливаются, если перед удалением они были экспортированы в файл. Путь поиска инструментальных палитр задается на вкладке "Файлы" диалогового окна "Настройка". Данный путь может вести и к сетевому источнику.

Инструментальные палитры только для чтения

Если файлу инструментальной палитры присвоен атрибут "только чтение", в нижнем углу палитры высвечивается значок замка. Это означает, что разрешены только изменения, ограничивающиеся заданием параметров отображения и переупорядочением значков инструментов.

Для присвоения инструментальной палитре атрибута "только чтение" щелкните правой кнопкой мыши файл инструментальной палитры (ATC) в следующей папке: C:\documents and settings\<имя пользователя>\application data\autodesk\AutoCAD 2009\r17.2\enu\support\ToolPalette\Palettes. В контекстном меню выберите "Свойства". На вкладке "Общие" выберите "Только для чтения" и нажмите кнопку "ОК".


Адаптация инструментальных палитр (Процедура)

Изменение свойств инструментов
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Создание инструментальной палитры

Создание инструментальной палитры из папки или чертежа

Связывание группы инструментальных палитр с панелью ленты

Отображение группы инструментальных палитр, связанной с панелью ленты

Переименование инструментальной палитры

Удаление инструментальной палитры

Изменение расположения инструментальной палитры

Добавление текста на инструментальную палитру

Добавление разделительной линии на инструментальную палитру

Сортировка элементов на инструментальной палитре


Создание инструментальной палитры (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Создание инструментальной палитры

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Новая палитра".
  2. В текстовое поле введите имя для новой палитры.
  3. Если нужно изменить последовательность вкладок, нажмите на вкладке правую кнопку мыши и выберите "Вверх" или "Вниз".
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Создание инструментальной палитры из папки или чертежа (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Создание инструментальной палитры из папки или чертежа

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления".Если Центр управления еще не открыт, введите в командной строке ЦУОТКЛ.
  2. В области структуры или в области содержимого Центра управления нажмите правую кнопку мыши на папке, файле чертежа или блоке. Выберите "Создать инструментальную палитру".

    Создается новая палитра, включающая все блоки и штриховки, которые имелись в выбранной папке или чертеже.

Панель:Стандарт
Ввод команды: ЦУВКЛ


Связывание группы инструментальных палитр с панелью ленты (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Связывание группы инструментальных палитр с панелью ленты

  1. Выберите в меню "Сервис" пункты [image] "Палитры" [image] "Инструментальные палитры".В командной строке введите ИНСТРПАЛВКЛ
  2. Щелкните на ленте панель правой кнопкой мыши и выберите в контекстном меню команду "Группа инструментальных палитр".
  3. Выберите в списке группу инструментальных палитр.


Отображение группы инструментальных палитр, связанной с панелью ленты (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Отображение группы инструментальных палитр, связанной с панелью ленты

  • Щелкните панель ленты правой кнопкой мыши и выберите в контекстном меню команду "Показать связанную группу инструментальных палитр".


Переименование инструментальной палитры (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Переименование инструментальной палитры

  1. Нажмите правой кнопкой мыши в незаполненной части окна инструментальных палитр. Выберите "Переименовать палитру".
  2. В текстовое поле введите новое имя для палитры.
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Удаление инструментальной палитры (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Удаление инструментальной палитры

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Удалить палитру".
  2. Для удаления инструментальной палитры нажмите "OK" в окне сообщения "Палитра - подтверждение удаления".
    ПримечаниеОтмена выполненного удаления инструментальной палитры невозможна. Перед любыми удалениями рекомендуется экспортировать инструментальную палитру. Используйте опцию "Экспорт" в диалоговом окне "Адаптация".
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Изменение расположения инструментальной палитры (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Изменение расположения инструментальной палитры

  1. Нажмите правую кнопку мыши на вкладке, отображающей инструментальную палитру, которую следует переместить, в окне инструментальных палитр. Выберите "Вверх" или "Вниз".
  2. Повторяйте шаг 1 до тех пор, пока инструментальная палитра не окажется на нужном месте.
    ПримечаниеТакже можно изменить порядок инструментальной палитры, нажав правую кнопку мыши на строке заголовка инструментальной палитры и после этого щелкнуть "Адаптация инструментальных палитр".
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Добавление текста на инструментальную палитру (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Добавление текста на инструментальную палитру

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Добавить текст".
  2. В текстовое поле вставьте текст, который должен отображаться в окне.
  3. При необходимости перетащите текст в соответствующее положение в окне.
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Добавление разделительной линии на инструментальную палитру (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Адаптация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Добавление разделительной линии на инструментальную палитру

  1. Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Добавить разделитель".
  2. При необходимости перетащите разделитель в соответствующее положение в окне.
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Сортировка элементов на инструментальной палитре (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Сортировка элементов на инструментальной палитре

  • Нажмите правую кнопку мыши в незаполненной части окна инструментальных палитр. Выберите "Сортировать по" [image] "Имя" или "Сортировать по" [image] "Тип".
    ПримечаниеЭлементы сортируются по порядку, тексту, разделителю и инструменту.
Панель:Стандарт
Ввод команды: ИНСТРПАЛВКЛ


Адаптация инструментальных палитр (Краткий справочник)

Изменение свойств инструментов
Адаптация инструментальных палитр
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Адаптация инструментальных палитр >
Адаптация инструментальных палитр
Понятие Процедура Краткий справочник

Команды

АДАПТАЦИЯ

Адаптация инструментальных палитр

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ИНСТРПАЛОТКЛ

Закрытие окна инструментальных палитр

Системные переменные

PALETTEOPAQUE

Управление прозрачностью окон

TPSTATE

Указание на открытое или закрытое состояние инструментальной палитры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Организация инструментальных палитр (Понятие)

Адаптация инструментальных палитр
Инструментальные палитры
Сохранение и совместное использование инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Инструментальные палитры можно группировать по темам, а также задавать, какая группа палитр будет отображаться на экране.

Например, если есть несколько инструментальных палитр с образцами штриховки, то можно использовать команду АДАПТАЦИЯ для создания новой группы "Образцы штриховки". Впоследствии можно добавлять любые инструментальные палитры с образцами штриховки в группу "Образец штриховки".

Если сделать группу палитр "Штриховка" активной, то окно будет содержать только палитры из этой группы.


Организация инструментальных палитр (Процедура)

Адаптация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Создание группы инструментальных палитр

Добавление инструментальной палитры в группу палитр

Исключение инструментальной палитры из группы палитр

Вывод группы инструментальных палитр на экран

Удаление группы инструментальных палитр

Удаление всех групп инструментальных палитр

Переименование группы инструментальных палитр

Переупорядочение группы палитр

Создание группы инструментальных палитр, вложенной в другую группу

Копирование и вставка палитры из одной группы в другую

Изменение порядка расположения палитр внутри группы

Изменение порядка расположения палитр, когда все они выведены на экран

Вывод всех инструментальных палитр на экран


Создание группы инструментальных палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Создание группы инструментальных палитр

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в разделе "Группы палитр" щелкните правой кнопкой мыши в нижней незаполненной области. Выберите "Новая группа".

    Если в списке "Группы палитр" пока нет ни одной группы, группу можно создать путем перетаскивания инструментальной палитры из списка "Палитры инструментов - все палитры " в список "Группы палитр".

  3. Введите имя группы.
  4. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Добавление инструментальной палитры в группу палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Добавление инструментальной палитры в группу палитр

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" перетащите палитру инструментов из области "Инструментальные палитры" в группу, расположенную в области "Группы палитр".
  3. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Исключение инструментальной палитры из группы палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Исключение инструментальной палитры из группы палитр

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Группы палитр" щелкните правой кнопкой мыши на группе палитр инструментов, которую требуется исключить. Выберите "Исключить".

    Для исключения палитры из группы можно также перетащить её обратно в область "Палитры инструментов".

  3. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Вывод группы инструментальных палитр на экран (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Вывод группы инструментальных палитр на экран

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры.
  2. Выберите имя группы инструментальных палитр, которую требуется отобразить.

Это можно сделать также с помощью диалогового окна "Адаптация". В области "Группы палитр" щелкните правой кнопкой мыши на группе, которую требуется показать. Выберите "Установить". Для указания группы инструментальных палитр также можно использовать команду ИППЕРЕЙТИ.

Ввод команды: АДАПТАЦИЯ


Удаление группы инструментальных палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Удаление группы инструментальных палитр

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Группы палитр" щелкните правой кнопкой мыши на группе палитр инструментов, которую требуется удалить. Нажмите кнопку "Удалить".
    ПримечаниеНельзя удалить группу палитр, которая является текущей в данный момент. В этом случае сначала нужно сделать текущей другую группу.
  3. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Удаление всех групп инструментальных палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Удаление всех групп инструментальных палитр

  1. Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Все палитры".
    ПримечаниеНеобходимо вывести на экран все палитры, чтобы ни одна группа палитр не являлась текущей.
  2. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  3. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры ". В списке "Группы палитр" нажмите правую кнопку мыши на названии группы палитр. Нажмите кнопку "Удалить".
  4. Повторите шаг 3 для всех групп палитр.
  5. По завершении нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Переименование группы инструментальных палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Переименование группы инструментальных палитр

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Группы палитр" щелкните правой кнопкой мыши на группе палитр инструментов, которую требуется переименовать. Выберите "Переименовать".
  3. Введите новое имя группы.
  4. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Переупорядочение группы палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Переупорядочение группы палитр

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Группы палитр" щелкните на группе палитр инструментов и перетащите ее в новое местоположение.

    Все группы, вложенные в перемещаемую группу, также передвигаются на новое место.

  3. Нажмите кнопку "Закрыть".
    ПримечаниеНельзя перетащить группу палитр в группу, вложенную в нее.
Ввод команды: АДАПТАЦИЯ


Создание группы инструментальных палитр, вложенной в другую группу (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Создание группы инструментальных палитр, вложенной в другую группу

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Группы палитр" щелкните правой кнопкой мыши на группе палитр инструментов, к которой требуется добавить новую группу. Выберите "Новая группа".
  3. Введите имя для новой группы.
  4. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Копирование и вставка палитры из одной группы в другую (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Копирование и вставка палитры из одной группы в другую

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Группы палитр" выберите палитру инструментов, которую требуется скопировать.
  3. Нажмите клавишу CTRL и, удерживая ее, перетащите выбранную палитру в другую группу.

    Отпустите кнопку мыши. Копия палитры появляется в новом месте.

  4. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Изменение порядка расположения палитр внутри группы (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Изменение порядка расположения палитр внутри группы

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Группы палитр" перетащите палитру инструментов в новое местоположение в пределах той же группы палитр инструментов.
  3. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Изменение порядка расположения палитр, когда все они выведены на экран (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Организация инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Изменение порядка расположения палитр, когда все они выведены на экран

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в области "Инструментальные палитры" перетащите палитру инструментов в требуемое местоположение.

    Когда все палитры выведены на экран, они отображаются в том порядке, в котором они находятся в списке.

  3. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Вывод всех инструментальных палитр на экран (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Сохранение и совместное использование инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Вывод всех инструментальных палитр на экран

  • Нажмите правую кнопку мыши на заголовке окна инструментальной палитры. Выберите "Все палитры".


Организация инструментальных палитр (Краткий справочник)

Адаптация инструментальных палитр
Организация инструментальных палитр
Сохранение и совместное использование инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Организация инструментальных палитр >
Организация инструментальных палитр
Понятие Процедура Краткий справочник

Команды

АДАПТАЦИЯ

Адаптация инструментальных палитр

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ИНСТРПАЛОТКЛ

Закрытие окна инструментальных палитр

ИППЕРЕЙТИ

Отображение заданной инструментальной палитры или группы палитр

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение и совместное использование инструментальных палитр (Понятие)

Организация инструментальных палитр
Инструментальные палитры
Строки состояния
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры >
Сохранение и совместное использование инструментальных палитр
Понятие Процедура Краткий справочник

Можно сохранить инструментальную палитру и обмениваться ей с помощью ее экспорта и импорта как файла.

Инструментальные палитры можно экспортировать и импортировать как файлы. Файлы инструментальных палитр имеют расширение .xtp.

Аналогично можно сохранить группу инструментальных палитр и обмениваться ей с помощью ее экспорта и импорта как файла группы палитр. Файлы инструментальных палитр имеют расширение .xpg.

В некоторых случаях при экспорте настроенной инструментальной палитры в том же месте, где и файл XTP, автоматически создаётся папка с изображениями, имеющая такое же имя, как экспортируемая инструментальная палитра. В папке с изображениями содержатся изображения значков, используемых экспортируемой инструментальной палитрой. Такая папка создаётся, если экспортируется инструментальная палитра, содержащая какой-нибудь из следующих элементов:

  • созданные пользователем инструменты содержимого;
  • инструменты-команды, содержащие заданные пользователем (пользовательские) значки палитры (изображения).

Чтобы на импортированной инструментальной палитре присутствовали значки, при импорте настроенной инструментальной палитры папка с изображениями должна находиться в том же месте, что и импортируемый файл XTP.

Инструментальные палитры можно использовать только в версии AutoCAD, в которой они были созданы. Например, невозможно работать с палитрой инструментов, созданной в AutoCAD 2009 в AutoCAD 2005.

Путь к файлам инструментальных палитр по умолчанию задаётся элементом "Папки с файлами инструментальных палитр" на вкладке "Файлы" диалогового окна "Настройка".

Группы инструментальных палитр сохраняются в профилях.

При использовании в AutoCAD LT инструментальных палитр, созданных в AutoCAD, следует помнить о том, что работа некоторых инструментов в этих продуктах различается. Обратите внимание на следующие ограничения:

  • цвет в инструменте должен быть задан по индексу цветов AutoCAD (ACI). Иначе при использовании инструмента в AutoCAD LT для цвета инструмента будет использоваться значение ПОСЛОЮ.
  • Инструменты, созданные из градиентных заливок, преобразуются в AutoCAD LT в инструменты-штриховки.
  • Инструменты, созданные из растровых изображений, в AutoCAD LT не работают.
ПримечаниеЕсли файлу инструментальной палитры присвоен атрибут "только чтение", в нижнем углу палитры высвечивается значок замка. Это означает, что разрешены только изменения, ограничивающиеся заданием параметров отображения и переупорядочением значков инструментов.
См. также

    • Сохранение и восстановление параметров интерфейса (профилей)


Сохранение и совместное использование инструментальных палитр (Процедура)

Организация инструментальных палитр
На уровень вверх ..
Сохранение и совместное использование инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Сохранение и совместное использование инструментальных палитр >
Сохранение и совместное использование инструментальных палитр
Понятие Процедура Краткий справочник

Обмен инструментальной палитрой

Обмен группой инструментальных палитр


Обмен инструментальной палитрой (Процедура)

Сохранение и совместное использование инструментальных палитр
На уровень вверх ..
Сохранение и совместное использование инструментальных палитр
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Сохранение и совместное использование инструментальных палитр >
Сохранение и совместное использование инструментальных палитр
Понятие Процедура Краткий справочник

Обмен инструментальной палитрой

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" в разделе "Палитры" нажмите правую кнопку мыши на инструментальной палитре. В контекстном меню выберите "Экспорт".
  3. В диалоговом окне "Экспорт группы" введите имя файла и щелкните "Сохранить".
  4. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Обмен группой инструментальных палитр (Процедура)

Сохранение и совместное использование инструментальных палитр
На уровень вверх ..
Строки состояния
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Сохранение и совместное использование инструментальных палитр >
Сохранение и совместное использование инструментальных палитр
Понятие Процедура Краткий справочник

Обмен группой инструментальных палитр

  1. Откройте вкладку "Инструменты", [image] панель "Адаптация", [image] раздел "Инструментальные палитры". Введите в командной строке адаптация.
  2. В диалоговом окне "Адаптация" перейдите на вкладку "Палитры инструментов - все палитры ". В списке "Группы палитр" нажмите правую кнопку мыши на названии группы палитр. Нажмите кнопку "Экспорт".
  3. В диалоговом окне "Экспорт группы" введите имя файла и щелкните "Сохранить".
  4. Нажмите кнопку "Закрыть".
Ввод команды: АДАПТАЦИЯ


Сохранение и совместное использование инструментальных палитр (Краткий справочник)

Организация инструментальных палитр
Сохранение и совместное использование инструментальных палитр
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Инструментальные палитры > Сохранение и совместное использование инструментальных палитр >
Сохранение и совместное использование инструментальных палитр
Понятие Процедура Краткий справочник

Команды

АДАПТАЦИЯ

Адаптация инструментальных палитр

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ИНСТРПАЛОТКЛ

Закрытие окна инструментальных палитр

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Строки состояния

Сохранение и совместное использование инструментальных палитр
Местоположение других инструментов
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Строки состояния
Понятие Процедура

Строки состояний приложения и чертежа предоставляют полезные сведения, а также кнопки для включения и выключения инструментов рисования.

Отображением строк состояний приложения и чертежа можно управлять, используя системную переменную STATUSBAR, или с помощью рабочего пространства. Дополнительные сведения об управлении отображением строк состояний с помощью рабочего пространства см. в Настройка рабочего пространства.

Темы в этом разделе

  • Строка состояния приложения

    В строке состояния приложения отображаются значения координат курсора, инструментов рисования, а также инструментов масштабирования быстрого просмотра и аннотаций.

  • Строка состояния чертежа

    В строке состояния чертежа отображаются несколько инструментов для масштабирования аннотаций.


Строки состояния (Процедура)

Сохранение и совместное использование инструментальных палитр
На уровень вверх ..
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния >
Строки состояния
Понятие Процедура

Отображение строки состояния приложения

Для управления выводом значков и уведомлений в лотке строки состояния

Управление отображением кнопок в строке состояния

Отображение координат в строке состояния

Отображение инструментов рисование в виде текста

Включение и отключение строки состояния чертежа

Управление отображением кнопок в строке состояния чертежа


Строка состояния приложения (Понятие)

Строки состояния
Строки состояния
Строка состояния чертежа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния >
Строка состояния приложения
Понятие Процедура Краткий справочник

В строке состояния приложения отображаются значения координат курсора, инструментов рисования, а также инструментов масштабирования быстрого просмотра и аннотаций.

Кнопки инструментов рисования отображаются как значки или текст. Настройки инструментов "Шаг", "Отс-поляр", "Привязка" и "Отс-объект" можно легко изменить в контекстных меню этих инструментов рисования.

С помощью средства быстрого просмотра можно просматривать открытые чертежи и листы в чертеже, а также переключаться между ними. Дополнительные сведения см. в разделе Предварительный просмотр открытых чертежей и листов. Для переключения между открытыми чертежами и просмотра модели в чертеже используются инструменты навигации. Дополнительные сведения см. в разделе Инструменты навигации. Можно также отобразить на экране инструменты для масштабирования аннотаций. Подробнее о масштабировании аннотаций см. Масштабирование аннотаций.

С помощью кнопки "Рабочее пространство" можно переключаться между рабочими пространствами. Кнопка блокировки блокирует текущие положения панелей инструментов и окон. Чтобы расширить отображаемую область чертежа, нажмите кнопку "Очистить экран". Дополнительные сведения см. в разделе Задание параметров интерфейса.

Добавление и удаление кнопок на строке состояния приложения выполняется в контекстном меню строки состояния.

ПримечаниеКогда строка состояния приложения выключена, на экране не отображается кнопка "Очистить экран".
См. также

    • Строка состояния чертежа


Строка состояния приложения (Процедура)

Строки состояния
На уровень вверх ..
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния приложения >
Строка состояния приложения
Понятие Процедура Краткий справочник

Отображение строки состояния приложения

Для управления выводом значков и уведомлений в лотке строки состояния

Управление отображением кнопок в строке состояния

Отображение координат в строке состояния

Отображение инструментов рисование в виде текста


Отображение строки состояния приложения (Процедура)

Строка состояния приложения
На уровень вверх ..
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния приложения >
Строка состояния приложения
Понятие Процедура Краткий справочник

Отображение строки состояния приложения

  • Введите в командной строке STATUSBAR и установите значение равное 1 или 2.
Ввод команды: STATUSBAR


Для управления выводом значков и уведомлений в лотке строки состояния (Процедура)

Строка состояния приложения
На уровень вверх ..
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния приложения >
Строка состояния приложения
Понятие Процедура Краткий справочник

Для управления выводом значков и уведомлений в лотке строки состояния

  1. Щелкните на стрелке меню строки состояния в правом конце строки состояния и выберите щелчком "Настройка области уведомлений".
  2. В диалоговом окне "Установки области уведомлений" установите или снимите следующие флажки:
    • Показывать значки служб. Подключается отображение области уведомлений в правой части строки состояния и отображение в ней значков служб. Если этот флажок снят, область уведомлений не отображается.
    • Показывать уведомления от служб. Подключается вывод уведомлений, получаемых от служб, например от Коммуникационного центра. Если флажок "Показывать значки служб" снят, данная возможность не доступна.
  3. Если флажок "Показывать уведомления от служб" установлен, следует задать время отображения уведомлений, или выбрать "До явного закрытия".
  4. Нажмите "ОК".
Контекстное меню:Щелкните правой кнопкой мыши на пустой области строки состояния. В контекстном меню выберите команду "Настройка области уведомлений…".
Ввод команды: ЛОТОКНАСТР


Управление отображением кнопок в строке состояния (Процедура)

Строка состояния приложения
На уровень вверх ..
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния приложения >
Строка состояния приложения
Понятие Процедура Краткий справочник

Управление отображением кнопок в строке состояния

  • Для изменения отображения щелкните на стрелке, находящейся в правом конце строки состояния, и щелкните на имени любой кнопки.

В строке состояния отображаются элементы, около имен которых стоят галочки в меню.

Контекстное меню:Щелкните правой кнопкой мыши на пустой области строки состояния. Щелкните имя кнопки.


Отображение координат в строке состояния (Процедура)

Строка состояния приложения
На уровень вверх ..
Строка состояния приложения
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния приложения >
Строка состояния приложения
Понятие Процедура Краткий справочник

Отображение координат в строке состояния

  • Щелкните на стрелке, находящейся в правом конце строки состояния, и выберите пункт "Координаты курсора".

В строке состояния отображаются элементы, около имен которых стоят галочки в меню.

Контекстное меню:Щелкните правой кнопкой мыши на пустой области строки состояния. Выберите в контекстном меню пункт "Координаты курсора".


Отображение инструментов рисование в виде текста (Процедура)

Строка состояния приложения
На уровень вверх ..
Строка состояния чертежа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния приложения >
Строка состояния приложения
Понятие Процедура Краткий справочник

Отображение инструментов рисование в виде текста

  • Щелкните правой кнопкой мыши любой инструмент рисования. Выберите в контекстном меню команду "Использовать значки".


Строка состояния приложения (Краткий справочник)

Сохранение и совместное использование инструментальных палитр
Строка состояния приложения
Строка состояния чертежа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния приложения >
Строка состояния приложения
Понятие Процедура Краткий справочник

Команды

ЛОТОКНАСТР

Управление отображением значков и уведомлений в области уведомлений строки состояния

Системные переменные

STATUSBAR

Управление отображением строки состояния приложения и чертежа

TRAYICONS

Управление отображением области уведомлений в строке состояния

TRAYNOTIFY

Управление отображением уведомлений служб в области уведомлений строки состояния

TRAYTIMEOUT

Управление временем (в секундах), в течение которого отображаются уведомления служб

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Строка состояния чертежа (Понятие)

Строка состояния приложения
Строки состояния
Контекстные меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния >
Строка состояния чертежа
Понятие Процедура Краткий справочник

В строке состояния чертежа отображаются несколько инструментов для масштабирования аннотаций.

Различное отображение инструментов в пространстве модели и на пространстве листа.

Когда строка состояния чертежа включена, она отображается в нижней части области рисования. Если строка состояния чертежа отключена, то инструменты, находящиеся в ней, перемещаются в строку состояния приложения.

Когда строка состояния чертежа включена, можно использовать меню строки состояния чертежа для выбора инструментов, показываемых на строке состояния.

См. также

    • Масштабирование аннотаций

    • Строка состояния приложения


Строка состояния чертежа (Процедура)

Строка состояния приложения
На уровень вверх ..
Строка состояния чертежа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния чертежа >
Строка состояния чертежа
Понятие Процедура Краткий справочник

Включение и отключение строки состояния чертежа

Управление отображением кнопок в строке состояния чертежа


Включение и отключение строки состояния чертежа (Процедура)

Строка состояния чертежа
На уровень вверх ..
Строка состояния чертежа
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния чертежа >
Строка состояния чертежа
Понятие Процедура Краткий справочник

Включение и отключение строки состояния чертежа

Выполнить одно из следующих действий:

  • Откройте меню "Сервис" и выберите пункт [image] "Настройка". Введите в командной строке НПИ. В диалоговом окне "Настройка" на вкладке "Отображение" установите или снимите флажок "Отображать строку состояния чертежа".
  • Щелкните на стрелке, находящейся в правом конце строки состояния, и выберите пункт "Строка состояния чертежа".

    Флажок рядом со строкой состояния чертежа указывает на то, что строка состояния чертежа включена.

  • На ленте щелкните панель "Элемент окна" на вкладке "Вид". Щелкните пункт "Строка состояния чертежа".


Управление отображением кнопок в строке состояния чертежа (Процедура)

Строка состояния чертежа
На уровень вверх ..
Контекстные меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния чертежа >
Строка состояния чертежа
Понятие Процедура Краткий справочник

Управление отображением кнопок в строке состояния чертежа

  • Щелкните на стрелке, находящейся в правом конце строки состояния чертежа, и выберите имя любой настройки для изменения отображения.

    В строке состояния чертежа отображаются элементы с флажками рядом с ними.


Строка состояния чертежа (Краткий справочник)

Строка состояния приложения
Строка состояния чертежа
Контекстные меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Строки состояния > Строка состояния чертежа >
Строка состояния чертежа
Понятие Процедура Краткий справочник

Команды

ЛОТОКНАСТР

Управление отображением значков и уведомлений в области уведомлений строки состояния

Системные переменные

STATUSBAR

Управление отображением строки состояния приложения и чертежа

TRAYICONS

Управление отображением области уведомлений в строке состояния

TRAYNOTIFY

Управление отображением уведомлений служб в области уведомлений строки состояния

TRAYTIMEOUT

Управление временем (в секундах), в течение которого отображаются уведомления служб

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Контекстные меню (Понятие)

Строка состояния чертежа
Местоположение других инструментов
Центр управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Контекстные меню
Понятие Процедура Краткий справочник

Контекстные меню используются для быстрого доступа к командам, относящимся к текущим операциям.

Контекстные меню вызываются нажатием правой кнопки мыши в различных зонах экрана, таких как:

  • область построения чертежа с выбранными объектами или без них
  • область построения во время выполнения команд
  • текстовое окно и окно команд
  • области и значки Центра управления
  • область контекстного редактора, включая текст
  • Панель инструментов или инструментальная палитра
  • Вкладки "Модель" или "Разметка листа"
  • Строка состояния или кнопки строки состояния
  • Некоторые диалоговые окна

Как правило, контекстные меню предлагают следующие действия:

  • повтор последней команды
  • прерывание текущей команды
  • отображение списка последних команд, введенных пользователем
  • вырезание, копирование и вставка из буфера обмена
  • выбор различных вариантов команды
  • вызов диалоговых окон, таких как "Настройка" или "Адаптация"
  • отмена результата действия последней выполненной команды

Существует возможность настройки реакции системы на длительность нажатия правой кнопки мыши, чтобы быстрое нажатие (щелчок) срабатывало так же, как нажатие клавиши ENTER, а более длительное нажатие приводило к отображению контекстного меню.

Контекстные меню можно адаптировать с помощью файла адаптации (АПИ). По умолчанию главному файлу АПИ присвоено имя.

См. также

    • Создание вложенных меню в документе Руководство по адаптации


Контекстные меню (Процедура)

Строка состояния чертежа
На уровень вверх ..
Контекстные меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Контекстные меню >
Контекстные меню
Понятие Процедура Краткий справочник

Вызов контекстного меню

Отключение вызова контекстных меню в области построения чертежа

Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия

Управление отображением последних введенных команд


Вызов контекстного меню (Процедура)

Контекстные меню
На уровень вверх ..
Контекстные меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Контекстные меню >
Контекстные меню
Понятие Процедура Краткий справочник

Вызов контекстного меню

  1. В ответ на запрос поместите курсор в нужной области экрана.
  2. Нажмите правую кнопку мыши или нажмите эквивалентную кнопку на устройстве указания.

    Тип контекстного меню зависит от местонахождения курсора при вызове меню. Если меню вызвано в области построения с выделенными объектами, то в контекстном меню предлагаются функции редактирования. Контекстное меню можно вызвать также при работе в режиме "Панорамирование" или "Зумирование".


Отключение вызова контекстных меню в области построения чертежа (Процедура)

Контекстные меню
На уровень вверх ..
Контекстные меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Контекстные меню >
Контекстные меню
Понятие Процедура Краткий справочник

Отключение вызова контекстных меню в области построения чертежа

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите настройка.
  2. В диалоговом окне "Настройка" выберите вкладку "Пользовательские". В разделе "Соответствие стандартам Windows" снимите флажок "Контекстные меню в области рисования".
  3. Чтобы по отдельности управлять контекстными меню, такими как "По умолчанию", "Редактирование" и "Команды", установите флажок "Контекстные меню в области чертежа". Адаптация правой кнопки мыши.
  4. В диалоговом окне "Адаптация правой кнопки мыши" в группе "Режим по умолчанию" или группе "Режим редактирования" выберите один из указанных вариантов реакции программы на нажатие правой кнопки мыши в области чертежа в тот момент, когда системой не выполняются никакие команды:
    • Повтор последней команды.Повторяется последняя команда. При выборе этого варианта отключается возможность вызова контекстных меню "По умолчанию" и "Редактирование". Кратковременное нажатие правой кнопки мыши соответствует нажатию клавиши ENTER.
    • Контекстное меню.Включается возможность вызова контекстного меню обычного режима и режима редактирования.
  5. В группе "Командный режим" для задания реакции на нажатие правой кнопки мыши, осуществленного в области построения чертежа, выберите один из следующих вариантов:
    • Ввод. Отключается возможность вызова контекстного меню командного режима. Кратковременное нажатие правой кнопки мыши соответствует нажатию клавиши ENTER.
    • Контекстное меню: всегда доступно.Включается возможность вызова контекстного меню командного режима.
    • Контекстное меню: доступно, если у команды есть параметры. Контекстное меню командного режима вызывается только в том случае, если в текущий момент в командной строке доступны какие-либо параметры. В командной строке параметры команд заключаются в квадратные скобки. Если параметров нет, нажатие правой кнопки мыши соответствует нажатию клавиши ENTER.

    Кроме включения/отключения контекстных меню режима по умолчанию, режима редактирования и командного режима, можно настраивать перечень режимов, доступных в этих меню. Например, в контекстное меню режима редактирования можно добавить функции, которые отображаются только при выборе объектов-окружностей.


Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия (Процедура)

Контекстные меню
На уровень вверх ..
Контекстные меню
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Контекстные меню >
Контекстные меню
Понятие Процедура Краткий справочник

Включение вариативности реакции на нажатие правой кнопки мыши в зависимости от длительности нажатия

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите настройка.
  2. В диалоговом окне "Настройка" выберите вкладку "Пользовательские". В разделе "Соответствие стандартам Windows" нажмите "Адаптация правой кнопки мыши...".
  3. В диалоговом окне "Адаптация правой кнопки мыши" установите флажок "Учитывать длительность нажатия".

    Можно задать продолжительность нажатия, при которой оно считается долгим. По умолчанию действует значение 250 миллисекунд.

  4. Выберите "Принять".
  5. В диалоговом окне "Настройка" нажмите "OK".
Ввод команды: НАСТРОЙКА


Управление отображением последних введенных команд (Процедура)

Контекстные меню
На уровень вверх ..
Центр управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Контекстные меню >
Контекстные меню
Понятие Процедура Краткий справочник

Управление отображением последних введенных команд

  1. В командной строке введите inputhistorymode.
  2. Введите сумму из одного или нескольких указанных значений:
    • 0. Последние введенные команды не отображаются.
    • 1. Последние введенные команды отображаются в командной строке; просматривать и выбирать их можно с помощью клавиш СТРЕЛКА ВВЕРХ, СТРЕЛКА ВНИЗ.
    • 2. Последняя введенная текущая команда отображается в контекстном меню.
    • 4. Все последние введенные команды в текущем сеансе отображаются в контекстном меню.
    • 8. Маркеры для последнего ввода местоположений точки отображаются на чертеже.

    По умолчанию используется значение 15.

  3. (Дополнительно) В командной строке введите cmdinputhistorymax.
  4. Введите значение, задающее число уникальных значений, введенных в командной строке, которые система будет запоминать и отображать как последние введенные команды.


Контекстные меню (Краткий справочник)

Строка состояния чертежа
Контекстные меню
Краткий обзор Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Контекстные меню >
Контекстные меню
Понятие Процедура Краткий справочник

Команды

КБУФЕР

Копирование выбранных объектов в буфер обмена

КПРОТОКОЛ

Копирование текста из окна журнала командной строки в буфер обмена

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

ВБУФЕР

Перемещение выбранных объектов в буфер обмена и удаление их из чертежа

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПАН

Перемещение изображения на текущем видовом экране

ВСТБУФЕР

Вставка содержимого буфера обмена

ОКНОСВ

Управление свойствами объектов

ЛОТОКНАСТР

Управление отображением значков и уведомлений в области уведомлений строки состояния

О

Отмена самой последней операции

ПОКАЗАТЬ

Увеличение или уменьшение видимого размера объектов на текущем видовом экране

Системные переменные

CMDINPUTHISTORYMAX

Задание максимального числа предыдущих значений введенных данных, которые хранятся в команде для запроса

INPUTHISTORYMODE

Управление содержанием и положением отображения последних введенных пользователем команд

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

SHORTCUTMENU

Управление доступностью контекстных меню (стандартного, режимов редактирования и команд) в области рисования

TRAYICONS

Управление отображением области уведомлений в строке состояния

TRAYNOTIFY

Управление отображением уведомлений служб в области уведомлений строки состояния

TRAYTIMEOUT

Управление временем (в секундах), в течение которого отображаются уведомления служб

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Центр управления

Контекстные меню
Местоположение других инструментов
Краткий обзор Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов >
Центр управления
Понятие Процедура

С помощью Центра управления осуществляется управление вхождениями блоков, внешними ссылками и другими элементами содержимого чертежей, такими как описания слоёв, листы и текстовые стили.

Темы в этом разделе

  • Краткий обзор Центра управления
  • Приёмы работы в окне "Центр управления"

    Пользователь может управлять размерами, местоположением и видом окна "Центр управления".

  • Доступ к содержимому с помощью Центра управления

    Область структуры в левой части окна "Центр управления" и четыре вкладки Центра управления позволяют находить и заносить элементы в область содержимого.

  • Добавление содержимого с помощью Центра управления

    Правая область окна "Центр управления" предназначена для работы с отображаемым содержимым.

  • Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления

    Вкладка Центра управления "Интернет-модуль Центра управления" предоставляет доступ к таким элементам содержимого, как блоки, библиотеки компонентов, каталоги производителей и Интернет-каталоги.


Центр управления (Процедура)

Контекстные меню
На уровень вверх ..
Приёмы работы в окне "Центр управления"
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления >
Центр управления
Понятие Процедура

Изменение режима разворачивания/сворачивания окна "Центр управления"

Для запрета закрепления окна "Центр управления"

Отображение и скрытие области структуры Центра управления

Для изменения источника содержимого, отображаемого в окне Центра управления

Изменение папки, назначенной в Центре управления для кнопки "Домой"

Добавление элементов в папку "Избранное" в Центре управления

Отображение содержимого папки "Избранное" в Центре управления

Упорядочение элементов в папке "Избранное" Центра управления

Создание инструментальной палитры из содержимого Центра управления

Загрузка области содержимого из диалогового окна "Поиск" Центра управления

Загрузка библиотеки обозначений в область содержимого Центра управления

Загрузка образцов штриховки в область содержимого Центра управления

Открытие чертежа из Центра управления

Обновление определения блока с помощью Центра управления


Краткий обзор Центра управления (Понятие)

Центр управления
Центр управления
Приёмы работы в окне "Центр управления"
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления >
Краткий обзор Центра управления
Понятие Краткий справочник

С помощью Центра управления можно организовать доступ к чертежам, блокам, штриховкам и другим типам графического содержимого. С его помощью можно перетащить в текущий чертёж содержимое из любого другого чертежа. Чертежи, блоки и штриховки можно также перемещать на инструментальную палитру. Чертёж, из которого осуществляется перенос содержимого, может как находиться на локальном компьютере, так и на веб-узле. Кроме того, если в сеансе открыто несколько чертежей, Центр управления даёт возможность ускорить процесс рисования за счёт копирования и вставки таких элементов, как слои, листы и текстовые стили, из одного чертежа в другой.

Центр управления даёт возможность:

  • Просматривать содержимое чертежей, включая библиотеки компонентов, на локальном диске, сетевом диске и веб-страницах.
  • Просматривать таблицы описаний таких именованных объектов, как блоки и слои в любом файле чертежа; вставлять и копировать эти описания в текущий чертеж.
  • Обновлять (переопределять) определения блоков.
  • Создавать ярлыки для часто используемых чертежей, папок и Интернет-адресов.
  • Дополнять содержимое чертежа блоками, внешними ссылками, образцами штриховки и т.п.
  • Открывать файлы чертежей в новом окне.
  • Перетаскивать чертежи, блоки и штриховки на инструментальные палитры для быстрого доступа к ним.


Краткий обзор Центра управления (Краткий справочник)

Контекстные меню
Краткий обзор Центра управления
Приёмы работы в окне "Центр управления"
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Краткий обзор Центра управления >
Краткий обзор Центра управления
Понятие Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

ЦУПЕРЕЙТИ

Загрузка указанного файла чертежа, папки или сетевого пути Центра управления

Системные переменные

ADCSTATE

Указание состояния Центра управления: активен или нет

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Приёмы работы в окне "Центр управления" (Понятие)

Краткий обзор Центра управления
Центр управления
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления >
Приёмы работы в окне "Центр управления"
Понятие Процедура Краткий справочник

Пользователь может управлять размерами, местоположением и видом окна "Центр управления".

Структура окна "Центр управления"

Окно "Центр управления" состоит из двух частей. Левая часть называется областью структуры, правая часть - областью содержимого. В области структуры отображаются всевозможные источники содержимого. Для добавления элементов в чертёж или на инструментальную палитру используется правая часть окна.

Незакреплённое окно "Центр управления" имеет следующий вид.

В части окна, расположенной под областью содержимого, можно просматривать образец и описание к выбранному чертёжу, блоку, штриховке или внешней ссылке. Панель инструментов вверху окна предоставляет доступ к набору режимов и операций.

Изменение размеров и местоположения окна "Центр управления"

Пользователь может изменять размеры и местоположение окна "Центр управления", а также включать и отключать его. Многие из этих параметров настраиваются с помощью контекстного меню, вызываемого правой кнопкой мыши, и выбора в нём одной из возможностей.

  • Размеры окна "Центр управления" изменяются путём перетаскивания разделителя между областью содержимого и областью дерева папок или с помощью перетаскивания края окна.
  • Для закрепления окна "Центр управления" нужно перетаскивать его в левую или правую область закрепления до тех пор, пока оно не окажется в зафиксированном положении. Можно также дважды нажать кнопку мыши на заголовке плавающего окна "Центр управления" .
  • Для открепления окна "Центр управления" нажмите кнопку мыши в области над панелью инструментов окна и перетащите окно за пределы зоны закрепления. Нажатие клавиши CTRL в процессе перетаскивания предотвращает закрепление.
  • Привязка окна "Центр управления" осуществляется выбором в контекстном меню пункта "Прикрепить якорем справа" или "Прикрепить якорем слева". Когда курсор пересекает привязанное окно, оно разворачивается или сворачивается. Содержимое открытого прикрепленного якорем окна "Центр управления" перекрывает область рисования. Не существует настройки, позволяющей держать открытым такое окно.
  • чтобы плавающее окно "Центр управления" сворачивалось и разворачивалось при пересечении его курсором, используется настройка "Авто-скрытие".

Панель инструментов Центра управления

С помощью панели осуществляется навигация внутри окна "Центр управления" и просмотр информации в области структуры и области содержимого. Подробнее о возможностях панели см. команду ЦУВКЛ . Точно такие же режимы навигации и отображения присутствуют в контекстном меню. Для открытия меню нажмите правую кнопку мыши в области содержимого окна "Центр управления".


Приёмы работы в окне "Центр управления" (Процедура)

Центр управления
На уровень вверх ..
Приёмы работы в окне "Центр управления"
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Приёмы работы в окне "Центр управления" >
Приёмы работы в окне "Центр управления"
Понятие Процедура Краткий справочник

Изменение режима разворачивания/сворачивания окна "Центр управления"

Для запрета закрепления окна "Центр управления"

Отображение и скрытие области структуры Центра управления


Изменение режима разворачивания/сворачивания окна "Центр управления" (Процедура)

Приёмы работы в окне "Центр управления"
На уровень вверх ..
Приёмы работы в окне "Центр управления"
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Приёмы работы в окне "Центр управления" >
Приёмы работы в окне "Центр управления"
Понятие Процедура Краткий справочник

Изменение режима разворачивания/сворачивания окна "Центр управления"

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. Щелкните правой кнопкой мыши строку заголовка Центра управления. Выберите "Авто-скрытие".

    Если режим разворачивания/сворачивания включен, окно "Центр управления" исчезает при уходе курсора из него; видимым остается только заголовок. Окно Центра управления восстанавливается при возврате курсора в строку заголовка.

Панель:Стандарт
Ввод команды: ЦУВКЛ


Для запрета закрепления окна "Центр управления" (Процедура)

Приёмы работы в окне "Центр управления"
На уровень вверх ..
Приёмы работы в окне "Центр управления"
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Приёмы работы в окне "Центр управления" >
Приёмы работы в окне "Центр управления"
Понятие Процедура Краткий справочник

Для запрета закрепления окна "Центр управления"

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. На заголовке Центра управления нажмите кнопку мыши и удерживайте её нажатой. Начав перемещение мыши, нажмите клавишу CTRL.
Панель:Стандарт
Ввод команды: ЦУВКЛ


Отображение и скрытие области структуры Центра управления (Процедура)

Приёмы работы в окне "Центр управления"
На уровень вверх ..
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Приёмы работы в окне "Центр управления" >
Приёмы работы в окне "Центр управления"
Понятие Процедура Краткий справочник

Отображение и скрытие области структуры Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. На панели окна "Центр управления" нажмите кнопку "Область структуры".
Панель:Стандарт
Ввод команды: ЦУВКЛ
Контекстное меню:Нажмите правую кнопку мыши в незаполненной части области содержимого и выберите из контекстного меню пункт "Область структуры".


Приёмы работы в окне "Центр управления" (Краткий справочник)

Краткий обзор Центра управления
Приёмы работы в окне "Центр управления"
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Приёмы работы в окне "Центр управления" >
Приёмы работы в окне "Центр управления"
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

ЦУПЕРЕЙТИ

Загрузка указанного файла чертежа, папки или сетевого пути Центра управления

Системные переменные

ADCSTATE

Указание состояния Центра управления: активен или нет

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Доступ к содержимому с помощью Центра управления (Понятие)

Приёмы работы в окне "Центр управления"
Центр управления
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Область структуры в левой части окна "Центр управления" и четыре вкладки Центра управления позволяют находить и заносить элементы в область содержимого.

Вкладка "Папки"

На вкладке "Папки" отображается дерево иерархической структуры папок, по которой можно передвигаться. В структуре отображаются значки следующих элементов:

  • сети и компьютеры
  • веб-адреса
  • диски компьютера
  • папки
  • чертежи и связанные с ними вспомогательные файлы
  • внешние ссылки, листы, стили штриховок и именованные объекты, включая блоки, слои, типы линий, текстовые стили, стили размеров, стили таблиц, стили мультивыносок, а также стили печати, хранимые внутри чертежей

Содержимое выбранного мышью в области структуры элемента отображается в области содержимого. Нажатие на знаке "плюс" (+) или "минус" (-) соответственно разворачивает и сворачивает вложенные уровни структуры. Развернуть один вложенный уровень можно также двойным нажатием кнопки мыши на имени элемента. Нажатие правой кнопкой мыши в области структуры открывает контекстное меню, содержащее несколько соответствующих режимов.

Вкладки "Открытые чертежи", "Журнал" и "Интернет-модуль центра управления"

Вкладки "Открытые чертежи", "Журнал" и "Интернет-модуль Центра управления" предоставляют альтернативные способы поиска содержимого.

  • Открытые чертежи. Отображение списка чертежей, открытых в текущий момент. Для загрузки элементов в область содержимого необходимо выбрать файл чертежа, а затем выбрать из списка одну из таблиц описаний.
  • Журнал. Список последних файлов, открывавшихся с помощью Центра управления. Двойное нажатие в списке на файле чертежа открывает этот чертёж во вкладке "Папки" и загружает его элементы в область содержимого.
  • Интернет-модуль центра управления. Обеспечивается доступ к содержимому на веб-страницах, включая блоки, библиотеки компонентов, библиотеки разработчиков и Интернет-каталоги Центра управления.

Обеспечение быстрого доступа к часто используемому содержимому

Центр управления позволяет упростить обращение к элементам содержимого, требующим регулярного и быстрого доступа. Как в области структуры, так и в области содержимого предусмотрены режимы, позволяющие работать с папкой "Избранное". В папке "Избранное" можно хранить ярлыки для доступа к содержимому, находящемуся на локальных и сетевых дисках, а также в Интернете.

Если в центре управления выделить папку, чертёж или другой элемент содержимого и выбрать в контекстном меню пункт "Добавить в Избранное", ярлык для доступа к этому элементу заносится в папку "Избранное". Команды ЦУВКЛ


Доступ к содержимому с помощью Центра управления (Процедура)

Приёмы работы в окне "Центр управления"
На уровень вверх ..
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Доступ к содержимому с помощью Центра управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Для изменения источника содержимого, отображаемого в окне Центра управления

Изменение папки, назначенной в Центре управления для кнопки "Домой"

Добавление элементов в папку "Избранное" в Центре управления

Отображение содержимого папки "Избранное" в Центре управления

Упорядочение элементов в папке "Избранное" Центра управления


Для изменения источника содержимого, отображаемого в окне Центра управления (Процедура)

Доступ к содержимому с помощью Центра управления
На уровень вверх ..
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Доступ к содержимому с помощью Центра управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Для изменения источника содержимого, отображаемого в окне Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. В окне Центра управления перейдите на одну из вкладок:
    • Папки. Отображается перечень локальных и сетевых дисков.
    • Открытые чертежи. Отображается перечень чертежей, открытых в текущий момент.
    • Журнал. Отображается перечень последних 20 элементов, открытых с помощью Центра управления.
    • Интернет-модуль. Отображается перечень содержимого из Интернета.
Панель:Стандарт
Ввод команды: ЦУВКЛ


Изменение папки, назначенной в Центре управления для кнопки "Домой" (Процедура)

Доступ к содержимому с помощью Центра управления
На уровень вверх ..
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Доступ к содержимому с помощью Центра управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Изменение папки, назначенной в Центре управления для кнопки "Домой"

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. В области структуры центра управления найдите папку, которую требуется сделать основной.
  3. Щелкните папку правой кнопкой мыши. Выберите "Сделать основной папкой".

При нажатии кнопки "Домой" Центр управления будет автоматически переходить в эту папку.

Панель:Стандарт
Ввод команды: ЦУВКЛ


Добавление элементов в папку "Избранное" в Центре управления (Процедура)

Доступ к содержимому с помощью Центра управления
На уровень вверх ..
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Доступ к содержимому с помощью Центра управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Добавление элементов в папку "Избранное" в Центре управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. Нажмите правую кнопку мыши на элементе в области структуры или области содержимого Центра управления. Выберите "Добавить в Избранное".
Панель:Стандарт
Ввод команды: ЦУВКЛ


Отображение содержимого папки "Избранное" в Центре управления (Процедура)

Доступ к содержимому с помощью Центра управления
На уровень вверх ..
Доступ к содержимому с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Доступ к содержимому с помощью Центра управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Отображение содержимого папки "Избранное" в Центре управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. В Центре управления нажмите кнопку "Избранное".

    В области структуры переход к папке "Избранное" осуществляется с помощью вкладки "Папки".

Панель:Стандарт
Ввод команды: ЦУВКЛ


Упорядочение элементов в папке "Избранное" Центра управления (Процедура)

Доступ к содержимому с помощью Центра управления
На уровень вверх ..
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Доступ к содержимому с помощью Центра управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Упорядочение элементов в папке "Избранное" Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. В Центре управления нажмите кнопку "Избранное".
  3. Нажмите правую кнопку мыши в области содержимого. Выберите "Упорядочить Избранное".

    В окне откроется папка "Autodesk", вложенная в папку "Избранное".

Панель:Стандарт
Ввод команды: ЦУВКЛ


Доступ к содержимому с помощью Центра управления (Краткий справочник)

Приёмы работы в окне "Центр управления"
Доступ к содержимому с помощью Центра управления
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Доступ к содержимому с помощью Центра управления >
Доступ к содержимому с помощью Центра управления
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

ЦУПЕРЕЙТИ

Загрузка указанного файла чертежа, папки или сетевого пути Центра управления

Системные переменные

ADCSTATE

Указание состояния Центра управления: активен или нет

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Добавление содержимого с помощью Центра управления (Понятие)

Доступ к содержимому с помощью Центра управления
Центр управления
Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Правая область окна "Центр управления" предназначена для работы с отображаемым содержимым.

Двойным нажатием на элементе в области содержимого разворачиваются вложенные уровни, детализирующие данный элемент. Например, после двойного нажатия на значке чертежа появляются значки элементов содержимого - "Блоки" и др. Далее двойное нажатие на значке "Блоки" приводит к выводу изображений всех блоков в чертеже.

Добавление содержимого в чертеж

Существует несколько способов добавления элементов из области содержимого в текущий чертеж:

  • Для вставки содержимого с параметрами по умолчанию (если они есть) элемент нужно перетащить в графическую область чертежа.
  • Нажатием правой кнопки на элементе в области содержимого вызывается контекстное меню, содержащее несколько вариантов действий.
  • Для отображения диалогового окна "Вставка" дважды нажмите кнопку мыши на блоке; для отображения диалогового окна "Штриховка контура и заливка" дважды нажмите на штриховке.

В области содержимого можно просматривать такие графические элементы содержимого, как чертежи, внешние ссылки и блоки, включая имеющиеся текстовые описания к ним.

Обновление определений блоков с помощью Центра управления

В отличие от внешних ссылок, описания блоков, вставленных в чертеж, не обновляются автоматически при изменении определения блока в файле источника. Однако с помощью Центра управления можно применить изменения в описании блока к текущему чертежу. Источником определения блока может быть файл чертежа или вложенный блок, размещенный в библиотеке компонентов чертежа.

Нажав правую кнопку мыши на блоке или файле чертежа в области содержимого, выберите в контекстном меню "Переопределить" или "Вставить с переопределением" для обновления выбранного блока.

Открытие чертежей с помощью Центра управления

В окне "Центр управления" можно открыть чертёж из области содержимого, используя контекстное меню, перетаскивая чертёж при нажатой клавише CTRL, или перетаскивая значок чертежа в любое место за пределами графической области. Имя загружаемого чертежа сохраняется в журнале Центра управления для быстрого доступа к нему в дальнейшем.

Добавление элементов в инструментальные палитры с помощью Центра управления

Из Центра управления можно перетаскивать чертежи, блоки и штриховки на текущую инструментальную палитру.

  • На текущую инструментальную палитру из области содержимого Центра управления можно перетащить один или несколько элементов.
  • Нажмите правую кнопку мыши в области структуры Центра управления, затем с помощью контекстного меню создайте новую палитру из текущей папки, файла чертежа или значка блока.

Если на инструментальную палитру добавляются чертежи, то при перетаскивании их из палитры в текущий чертёж они вставляются в виде блоков.

ПримечаниеБлоки или штриховки можно добавлять на инструментальную палитру целыми группами.


Добавление содержимого с помощью Центра управления (Процедура)

Доступ к содержимому с помощью Центра управления
На уровень вверх ..
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Создание инструментальной палитры из содержимого Центра управления

Загрузка области содержимого из диалогового окна "Поиск" Центра управления

Загрузка библиотеки обозначений в область содержимого Центра управления

Загрузка образцов штриховки в область содержимого Центра управления

Открытие чертежа из Центра управления

Обновление определения блока с помощью Центра управления


Создание инструментальной палитры из содержимого Центра управления (Процедура)

Добавление содержимого с помощью Центра управления
На уровень вверх ..
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Создание инструментальной палитры из содержимого Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. Выполните одно из следующих действий:
    • Щелкните правой кнопкой мыши элемент в области структуры Центра управления. Выберите "Создать инструментальную палитру". Новая палитра содержит чертежи, блоки или штриховки из выбранного элемента.
    • Щелкните правой кнопкой мыши в области содержимого Центра управления. Выберите "Создать инструментальную палитру". Новая палитра содержит чертежи, блоки или штриховки из области содержимого Центра управления.
    • Щелкните правой кнопкой мыши чертеж в области структуры или области содержимого Центра управления. В контекстном меню выберите команду "Создать палитру блоков". Новая палитра содержит блоки из выбранного чертежа.

    Впоследствии на палитру можно перетащить другие чертежи, блоки или штриховки из области содержимого Центра управления.

Панель:Стандарт
Ввод команды: ЦУВКЛ


Загрузка области содержимого из диалогового окна "Поиск" Центра управления (Процедура)

Добавление содержимого с помощью Центра управления
На уровень вверх ..
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Загрузка области содержимого из диалогового окна "Поиск" Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. Воспользуйтесь одним из следующих способов:
    • Перетащите элемент из списка результатов поиска в область содержимого.
    • Дважды нажмите на элементе в списке результатов поиска.
    • Нажмите правую кнопку мыши на элементе в списке результатов поиска. Выберите "Загрузить в содержимое".
  3. Дважды нажмите на значке "Блоки" в области содержимого Центра управления.
Панель:Стандарт
Ввод команды: ЦУВКЛ


Загрузка библиотеки обозначений в область содержимого Центра управления (Процедура)

Добавление содержимого с помощью Центра управления
На уровень вверх ..
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Загрузка библиотеки обозначений в область содержимого Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. На панели Центра управления нажмите кнопку "Домой".
  3. В области содержимого дважды нажмите на чертеже библиотеки компонентов, которую необходимо загрузить в Центре управления, затем дважды нажмите кнопку мыши на значке "Блоки".

    Библиотека обозначений загружается в область содержимого Центра управления.

ПримечаниеЛюбую папку, содержащую библиотеку компонентов, можно сделать основной. Если задан другой путь к основной папке, перейдите в папку, содержащую чертежи библиотеки компонентов, и дважды нажмите на ней мышью. Выберите "Сделать основной папкой".
Панель:Стандарт
Ввод команды: ЦУВКЛ


Загрузка образцов штриховки в область содержимого Центра управления (Процедура)

Добавление содержимого с помощью Центра управления
На уровень вверх ..
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Загрузка образцов штриховки в область содержимого Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. На панели Центра управления нажмите кнопку "Поиск".
  3. В диалоговом окне "Поиск" щелкните поле "Найти". Щелкните "Файлы образцов штриховки".
  4. На вкладке "Файлы образцов штриховки" в поле "Искать имя" введите *.
  5. Нажмите кнопку "Поиск".
  6. Нажмите два раза кнопку мыши на одном из найденных файлов образцов штриховки.

    Выбранный файл с образцами штриховки загружается в Центр управления.

Панель:Стандарт
Ввод команды: ЦУВКЛ


Открытие чертежа из Центра управления (Процедура)

Добавление содержимого с помощью Центра управления
На уровень вверх ..
Добавление содержимого с помощью Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Открытие чертежа из Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. Воспользуйтесь одним из следующих способов:
    • Нажмите правую кнопку мыши на значке чертежа в области содержимого Центра управления. Выберите "Открыть в окне приложения".
    • Нажмите клавишу CTRL и перетащите значок из области содержимого Центра управления в область рисования.
    • Перетащите значок чертежа из области содержимого Центра управления за пределы графической области в окне приложения. (При перемещении значка чертежа в область рисования он вставляется в текущий чертёж как блок.)
Панель:Стандарт
Ввод команды: ЦУВКЛ


Обновление определения блока с помощью Центра управления (Процедура)

Добавление содержимого с помощью Центра управления
На уровень вверх ..
Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Обновление определения блока с помощью Центра управления

  1. Если Центр управления еще не открыт, откройте меню "Сервис" [image] "Палитры" [image] "Центр управления"Введите в командной строке ЦУВКЛ.
  2. Нажмите правую кнопку мыши на блоке в области содержимого Центра управления. Выберите "Переопределить" или "Вставить с переопределением".
    ПримечаниеЕсли источником блока, который необходимо обновить, является целый файл чертежа, а не описание отдельного блока в файле чертежа, нажмите правую кнопку мыши на значке чертежа в области содержимого Центра управления. Выберите "Вставить как блок".
Панель:Стандарт
Ввод команды: ЦУВКЛ


Добавление содержимого с помощью Центра управления (Краткий справочник)

Доступ к содержимому с помощью Центра управления
Добавление содержимого с помощью Центра управления
Краткий обзор Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Добавление содержимого с помощью Центра управления >
Добавление содержимого с помощью Центра управления
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

ЦУПЕРЕЙТИ

Загрузка указанного файла чертежа, папки или сетевого пути Центра управления

Системные переменные

ADCSTATE

Указание состояния Центра управления: активен или нет

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления

Добавление содержимого с помощью Центра управления
Центр управления
Краткий обзор Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления >
Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Понятие Процедура

Вкладка Центра управления "Интернет-модуль Центра управления" предоставляет доступ к таким элементам содержимого, как блоки, библиотеки компонентов, каталоги производителей и Интернет-каталоги.

Темы в этом разделе

  • Краткий обзор Интернет-модуля Центра управления
  • Типы содержимого Интернет-модуля Центра управления

    В модуле содержимое распределено по отдельным папкам в зависимости от категории.

  • Загрузка содержимого из Интернета

    Можно загружать содержимое из Интернета и использовать его для чертежей.


Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления (Процедура)

Добавление содержимого с помощью Центра управления
На уровень вверх ..
Краткий обзор Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления >
Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Понятие Процедура

Установка утилиты "Диспетчер Интернет-компонентов"

Просмотр папок Интернет-содержимого в списке категорий

Поиск содержимого в Интернет-модуле Центра управления

Задание коллекций содержимого

Загрузка содержимого на компьютер

Загрузка содержимого в чертеж


Краткий обзор Интернет-модуля Центра управления (Понятие)

Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Типы содержимого Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления >
Краткий обзор Интернет-модуля Центра управления
Понятие Процедура Краткий справочник

Вкладка Центра управления "Интернет-модуль" предоставляет доступ к таким элементам содержимого, как блоки, библиотеки компонентов, каталоги производителей и Интернет-каталоги. Эти элементы могут использоваться при коллективной разработке проекта, что повышает эффективность процесса создания чертежей.

Для доступа к модулю Центра управления нужно перейти в центре управления на вкладку "Интернет-модуль Центра управления". После открытия окна "Интернет-модуль Центра управления", можно просматривать, искать и загружать содержимое в чертёж.

В окне "Интернет-модуль Центра управления" отображаются две панели—правая и левая. Правая область называется областью содержимого. В ней отображаются элементы или папки, выбранные в левой области. Левая область может иметь четыре вида:

  • Список по категориям. Папки, содержащие библиотеки стандартных деталей, специализированное содержимое и каталоги поставщиков.
  • Поиск. Поиск содержимого в Интернете. Можно задать запрос с помощью логических операций или строк поиска их нескольких слов.
  • Установки. Управление количеством категорий и элементов, отображаемых на каждой странице при поиске или навигации по папкам.
  • Коллекции. Задание содержимого для различных отраслей, отображаемого в модуле Центра управления.

Вид выбирается нажатием кнопки мыши в верхней части левой области.

После выбора папки в левой области все её элементы загружаются в область содержимого. В области содержимого можно выбрать элемент и загрузить его в область предварительного просмотра. Элементы из области предварительного просмотра можно перетаскивать мышью в область построения или на инструментальные палитры, а также сохранять их на диске компьютера.

ПримечаниеЕсли в Центре управления отсутствует вкладка "Интернет-модуль Центр управления", необходимо обратиться к сетевому администратору или администратору САПР.

Политика конфиденциальности при использовании Интернет-модуля Центра управления

Для обновления информации и содержимого Интернет-модуля Центра управления его необходимо подключить к Интернету. При подключении к Интернету Центр управления посылает некоторые данные в компанию Autodesk, для того чтобы получаемая в ответ информация была более конкретной. При этом частные права владельца экземпляра программного продукта никоим образом не нарушаются, так как обмен информацией происходит анонимно.

В Autodesk отправляются следующие сведения:

  • Название программного продукта. Название программного продукта, в котором используется Интернет-модуль Центра управления
  • Номер версии продукта. Номер версии устанавливаемого продукта
  • Язык пользовательского интерфейса. Код языка пользовательского интерфейса установленной программы
  • Идентификационный код. Интернет-Модуль Центра управления присваивает каждому пользователю идентификационный код в виде псевдослучайного числа. Код помогает выбрать необходимые для пользователя наборы данных и настройки.

На основе информации, посылаемой из Интернет-модуля, компания Autodesk ведет статистический учёт использования модуля с целью его усовершенствования. Autodesk будет использовать информацию, предоставленную пользователем или полученную от него, в соответствии с политикой конфиденциальности компании, с которой можно ознакомиться на веб-узле http://www.autodesk.com/privacy-rus.

Включение и отключение вкладки "Интернет-модуль Центра управления"

Включение и отключение вкладки "Интернет-модуль" окна "Центр управления" выполняется с помощью утилиты "Диспетчер Интернет-компонентов". После установки этой утилиты с помощью мастера установки можно просмотреть информацию о работе с утилитой; для этого следует запустить утилиту и в окне "Диспетчер Интернет-компонентов" выбрать "Справка".


Установка утилиты "Диспетчер Интернет-компонентов" (Процедура)

Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
На уровень вверх ..
Типы содержимого Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Краткий обзор Интернет-модуля Центра управления >
Краткий обзор Интернет-модуля Центра управления
Понятие Процедура Краткий справочник

Установка утилиты "Диспетчер Интернет-компонентов"

  1. Вставьте DVD-диск или первый CD-диск в дисковод своего компьютера.
  2. В мастере установки выберите щелчком "Установить инструменты и утилиты".
  3. На странице "Добро пожаловать в мастер установки" щелкните "Далее".
  4. Выберите Autodesk CAD Manager Tools на странице "Выбор устанавливаемых программ". Нажмите "Далее".
  5. Просмотрите лицензионное соглашение по программным продуктам Autodesk для своей страны или территории. Для продолжения установки надо принять данное соглашение. Выберите свою страну или территорию, щелкните "Я согласен" и нажмите кнопку "Далее".
    ПримечаниеПри несогласии с условиями лицензии и намерении прекратить установку нажмите кнопку "Отмена".
  6. На странице "Обзор - Настройка - Установить" щелкните "Установить" при намерении согласиться с местом установки по умолчанию.

    Если утилита должна быть установлена по другому пути, то щелкните "Настройка", после чего щелкните "Настройка завершена" и нажмите кнопку "Установить".

  7. Щелкните "Готово" после вывода страницы "Установка завершена".


Краткий обзор Интернет-модуля Центра управления (Краткий справочник)

Добавление содержимого с помощью Центра управления
Краткий обзор Интернет-модуля Центра управления
Типы содержимого Интернет-модуля Центра управления
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Краткий обзор Интернет-модуля Центра управления >
Краткий обзор Интернет-модуля Центра управления
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Типы содержимого Интернет-модуля Центра управления (Понятие)

Краткий обзор Интернет-модуля Центра управления
Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Загрузка содержимого из Интернета
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления >
Типы содержимого Интернет-модуля Центра управления
Понятие Процедура Краткий справочник

В модуле содержимое распределено по отдельным папкам в зависимости от категории.

Из папок Интернет-модуля Центра управления можно загружать содержимое для различных отраслей. Содержимое включает в себя следующее:

  • Стандартные детали. Стандартные детали, которые часто используются в проектировании. Эти детали включают в себя архитектурные, машиностроительные и ГИС-блоки.
  • Каталоги производителей. Блоки и 3D модели, которые можно найти и загрузить, перейдя по ссылке на сайт производителя.
  • Каталоги поставщиков. Список библиотек поставщиков коммерческих каталогов, в которых можно найти детали и блоки.

Чтобы выбрать категории Интернет-содержимого для отображения в списке категорий, используйте вид "Коллекции".


Просмотр папок Интернет-содержимого в списке категорий (Процедура)

Краткий обзор Интернет-модуля Центра управления
На уровень вверх ..
Загрузка содержимого из Интернета
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Типы содержимого Интернет-модуля Центра управления >
Типы содержимого Интернет-модуля Центра управления
Понятие Процедура Краткий справочник

Просмотр папок Интернет-содержимого в списке категорий

  • Нажмите кнопку мыши на заголовке в верхней части левой области Интернет-модуля Центра управления, затем выберите "Список категорий".

Папки категорий отображаются в левой области окна.


Типы содержимого Интернет-модуля Центра управления (Краткий справочник)

Краткий обзор Интернет-модуля Центра управления
Типы содержимого Интернет-модуля Центра управления
Загрузка содержимого из Интернета
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Типы содержимого Интернет-модуля Центра управления >
Типы содержимого Интернет-модуля Центра управления
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Загрузка содержимого из Интернета (Понятие)

Типы содержимого Интернет-модуля Центра управления
Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления
Окно команд
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления >
Загрузка содержимого из Интернета
Понятие Процедура Краткий справочник

Можно загружать содержимое из Интернета и использовать его для чертежей.

Обзор содержимого

При активном виде "Список категорий" в правой части окна можно просмотреть содержимое папок из левой области. В эти папки могут вкладываться другие папки.

Нажатие кнопки мыши на папке или элементе внутри папки позволяет увидеть то, чем она наполнена, в области содержимого. Нажатие кнопки мыши на блоке приводит к отображению информации графического или описательного характера о нём в области предварительного просмотра.

Поиск содержимого

При поиске содержимого в Интернете с помощью Интернет-модуля Центра управления можно в окне "Поиск" задавать критерии поиска с использованием логических операторов и строк, состоящих из нескольких слов. Доступ к функции поиска осуществляется через кнопку в виде лупы или посредством выбора пункта "Поиск" в раскрывающемся заголовке вверху левой области окна модуля.

Управление количеством категорий и элементов на странице

С помощью вида "Параметры" можно управлять количеством категорий и элементов, отображаемых при поиске или навигации по папкам на каждой странице.

Коллекции

Можно выбирать тип содержимого для навигации и поиска. Тип содержимого, отображаемого в Интернет-модуле Центра управления, можно задавать в области "Коллекции". Например, при использовании архитектурных блоков в чертежах можно выбирать коллекции архитектурных элементов. Указанные при выборе категории отображаются всякий раз при открытии модуля.

Загрузка содержимого

Для загрузки содержимого из Интернета следует выбрать папку, содержащую необходимую информацию. Далее нажмите кнопку мыши на образце изображения содержимого в области содержимого. В области предварительного просмотра появится содержимое и информация о нем. Из области предварительного просмотра можно перетащить блок непосредственно в чертёж или на инструментальную палитру, либо сохранить его на диске компьютера для использования в дальнейшем.

Подробнее о загрузке содержимого из Интернета см. раздел Вставка содержимого с веб-страниц.


Загрузка содержимого из Интернета (Процедура)

Типы содержимого Интернет-модуля Центра управления
На уровень вверх ..
Загрузка содержимого из Интернета
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Загрузка содержимого из Интернета >
Загрузка содержимого из Интернета
Понятие Процедура Краткий справочник

Поиск содержимого в Интернет-модуле Центра управления

Задание коллекций содержимого

Загрузка содержимого на компьютер

Загрузка содержимого в чертеж


Поиск содержимого в Интернет-модуле Центра управления (Процедура)

Загрузка содержимого из Интернета
На уровень вверх ..
Загрузка содержимого из Интернета
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Загрузка содержимого из Интернета >
Загрузка содержимого из Интернета
Понятие Процедура Краткий справочник

Поиск содержимого в Интернет-модуле Центра управления

  1. В окне Интернет-модуля Центра управления нажмите кнопку мыши на заголовке вверху левой области, затем выберите "Поиск".
  2. Введите в строку поиска слово или словосочетание.
    ПримечаниеБолее подробная информация о поиске, включая примеры с поиском логических операторов, дана в справочной системе.


Задание коллекций содержимого (Процедура)

Загрузка содержимого из Интернета
На уровень вверх ..
Загрузка содержимого из Интернета
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Загрузка содержимого из Интернета >
Загрузка содержимого из Интернета
Понятие Процедура Краткий справочник

Задание коллекций содержимого

  1. Нажмите кнопку мыши на заголовке вверху левой области окна модуля Центра управления Online, затем выберите "Коллекции".
  2. В окне "Коллекции" выберите нужные коллекции.
  3. Нажмите кнопку "Обновить коллекции".

    Выбранные категории отображаются в левой области.


Загрузка содержимого на компьютер (Процедура)

Загрузка содержимого из Интернета
На уровень вверх ..
Загрузка содержимого из Интернета
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Загрузка содержимого из Интернета >
Загрузка содержимого из Интернета
Понятие Процедура Краткий справочник

Загрузка содержимого на компьютер

  1. Нажмите кнопку мыши на заголовке вверху левой области окна Интернет-модуля Центра управления, затем выберите "Список категорий".
  2. В папке категорий выберите элемент содержимого.
  3. В области предварительного просмотра под изображением элемента содержимого выберите "Сохранить это обозначение как".
  4. В диалоговом окне сохранения файла задайте имя файла и путь к нему.
  5. Нажмите кнопку "Сохранить".

    Содержимое загружается на компьютер.


Загрузка содержимого в чертеж (Процедура)

Загрузка содержимого из Интернета
На уровень вверх ..
Ввод команд в командной строке
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Загрузка содержимого из Интернета >
Загрузка содержимого из Интернета
Понятие Процедура Краткий справочник

Загрузка содержимого в чертеж

  1. Нажмите кнопку мыши на заголовке вверху части левой области окна Интернет-модуля Центра управления, затем выберите "Список категорий".
  2. Для отображения элемента содержимого в области предварительного просмотра выберите его мышью в папке категорий.
  3. Перетащите изображение из области предварительного просмотра в чертёж или на инструментальную палитру.


Загрузка содержимого из Интернета (Краткий справочник)

Типы содержимого Интернет-модуля Центра управления
Загрузка содержимого из Интернета
Ввод команд в командной строке
Пользовательский интерфейс > Местоположение ленты, меню и других инструментов > Местоположение других инструментов > Центр управления > Загрузка содержимого из Интернета с помощью Интернет-модуля Центра управления > Загрузка содержимого из Интернета >
Загрузка содержимого из Интернета
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Окно команд

Загрузка содержимого из Интернета
Пользовательский интерфейс
Ввод команд в командной строке
Пользовательский интерфейс >
Окно команд

Возможно отображение команд, системных переменных и опций, сообщений и подсказок в закрепляемом и изменяемом по размеру окне, именуемом окном команд.

Темы в этом разделе

  • Ввод команд в командной строке

    Команда вызывается с помощью клавиатуры. Некоторые команды имеют также сокращённые псевдонимы.

  • Ввод значений системных переменных в командной строке

    Значения системных переменных определяют характер работы определённых команд.

  • Перемещение и редактирование в окне команд

    В окне команд можно перемещаться и выполнять редактирование текста для исправления и повторного ввода команд.

  • Переключение между диалоговыми окнами и командной строкой

    С некоторыми командами можно работать как в командной строке, так в диалоговых окнах. Эта возможность особенно полезна при использовании сценариев.

  • Закрепление, изменение размера и скрытие окна команд

    Необходимость открытия окна команд и изменения его положения определяется характером работы пользователя.


Ввод команд в командной строке (Понятие)

Окно команд
Окно команд
Ввод значений системных переменных в командной строке
Пользовательский интерфейс > Окно команд >
Ввод команд в командной строке
Понятие Процедура Краткий справочник

Команда вызывается с помощью клавиатуры. Некоторые команды имеют также сокращённые псевдонимы.

Для ввода команды с клавиатуры наберите полное имя команды в командной строке и нажмите клавишу ENTER или ПРОБЕЛ.

ПримечаниеКогда включён параметр "Динамический ввод" и подключено отображение динамических подсказок, можно ввести несколько команд из подсказок рядом с курсором.

Некоторые команды имеют также сокращённые имена. Например, вместо того, чтобы вводить слово отрезок для выполнения команды ОТРЕЗОК, можно ввести l. Сокращенные имена команд называются псевдонимами команд; они определены в файле acad.pgp.

Подробнее о создании новых псевдонимов команд см. раздел Псевдонимы команд в документе Руководство по адаптации.

Чтобы найти команду, введите букву в командной строке и нажмите клавишу TAB для циклического переключения между всеми командами, начинающимися с этой буквы. Нажмите клавишу ENTER или ПРОБЕЛ. Повторно запустите недавно использованную команду нажатием правой кнопкой мыши в командной строке.

Задание параметров команд

При вводе команд в командной строке отображается либо набор параметров, либо диалоговое окно. Например, при вводе в командной строке команды круг отображается подсказка следующего вида:

Центр круга или [3Т/2Т/ККР (кас, кас, радиус)]:

Для задания центра круга можно ввести значения координат X,Y или указать нужную точку на экране с помощью устройства указания.

Выбор другого параметра выполняется вводом соответствующих прописных букв, перечисленных в квадратных скобках. Эти буквы можно вводить в любом регистре. Например, для выбора параметра "три точки" (3Т) введите 3р.

Выполнение команд

Для выполнения команды нажмите клавишу ПРОБЕЛ или ENTER или нажмите правую кнопку устройства указания после ввода имени команды или ответов на запросы. В инструкциях справочной системы подразумевается выполнение этих действий пользователем и отсутствует напоминание о необходимости нажатия клавиши ENTER после каждого ввода.

Повтор и отмена команд

Для повторного вызова последней команды нажмите клавишу ENTER или ПРОБЕЛ либо щелкните правой кнопкой указательное устройство на индикаторе подсказки команды.

Кроме того, для повтора команды можно ввести несколько и, через пробел, имя нужной команды так, как это показано в следующем примере:

Команда: несколько круг

Для отмены выполняющейся команды нажмите клавишу ESC.

Прерывание выполнения команды вводом другой команды или изменением значения системной переменной

Многие команды можно использовать в прозрачном режиме, т.е. вызывать их в ходе выполнения другой команды. Прозрачные команды, например СЕТКА или ПОКАЗАТЬ, обычно предназначены для изменения параметров чертежа или параметров отображения. В Справочнике команд прозрачные команды отмечены апострофом перед именем команды.

Для использования команды в прозрачном режиме нужно нажать соответствующую кнопку на панели инструментов или перед вводом команды в ответ на любую из подсказок программы введите апостроф ('). В командной строке перед подсказками, которые отображаются для прозрачных команд, выводятся двойные угловые скобки (>>). После завершения прозрачной команды возобновляется работа исходной. Например, для включения сетки с интервалом в 1 единицу в ходе рисования отрезка нужно ввести:

Команда: отрезок

Первая точка: 'сетка

>>Интервал сетки (X) или [Вкл/Откл/Шаг/Аспект] <0,000>: 1

Возобновляется команда ОТРЕЗОК

Первая точка:

Как правило, в прозрачном режиме можно пользоваться командами, которые не выполняют выбора объектов, не создают новых объектов или не завершают сеанс работы. В прозрачном режиме можно открывать некоторые из диалоговых окон, но произведённые с их помощью изменения не вступают в силу до завершения приостановленной команды. Точно так же, если при выполнении некоторой команды в прозрачном режиме изменяется значение системной переменной, её новое значение проявляется только в следующей команде.

См. также

    • Задание клавиш быстрого вызова и временной замены в документе Руководство по адаптации


Копирование недавно использованной команды (Процедура)

Загрузка содержимого из Интернета
Ввод команд в командной строке
Ввод значений системных переменных в командной строке
Пользовательский интерфейс > Окно команд > Ввод команд в командной строке >
Ввод команд в командной строке
Понятие Процедура Краткий справочник

Копирование недавно использованной команды

  1. Нажмите на командной строке правую кнопку мыши. Выберите "Журнал последних команд".
  2. Выберите нужную команду.


Ввод команд в командной строке (Краткий справочник)

Загрузка содержимого из Интернета
Ввод команд в командной строке
Ввод значений системных переменных в командной строке
Пользовательский интерфейс > Окно команд > Ввод команд в командной строке >
Ввод команд в командной строке
Понятие Процедура Краткий справочник

Команды

МНОГОРАЗ

Многократное (до отмены) повторение последующей команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ВСТБУФЕР

Вставка содержимого буфера обмена

Системные переменные

CMDNAMES

Отображение имен активной и прозрачной команд

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Ввод значений системных переменных в командной строке (Понятие)

Ввод команд в командной строке
Окно команд
Перемещение и редактирование в окне команд
Пользовательский интерфейс > Окно команд >
Ввод значений системных переменных в командной строке
Понятие Процедура Краткий справочник

Значения системных переменных определяют характер работы определённых команд.

С их помощью осуществляется включение и отключение различных режимов, например "Шаг", "Сетка" или "Орто". Они задают используемые по умолчанию масштабы для образцов штриховки. Они используются для хранения сведений о текущем чертеже или настройке программы. Системные переменные могут использоваться для изменения настроек или для отображения информации о текущем состоянии.

Например, изменение значения системной переменной GRIDMODE приводит к включению и отключению режима отображения сетки в виде точек. В этом случае воздействие, оказываемое системной переменной GRIDMODE, эквивалентно команде СЕТКА. DATE, являясь системной переменной, допускает только чтение и предназначена для хранения текущей даты. Значение даты можно вывести, но нельзя изменить.

Битовые коды переменных

Некоторые системные переменные управляются с помощью битовых кодов. С помощью этих системных переменных добавляются значения для указания уникальной комбинации режимов. Например, системная переменная LOCKUI предоставляет следующие значения битового кода:

0 | Панели инструменты и окна не заблокированы
1 | Закрепленные панели инструментов заблокированы
2 | Заблокированы закрепленные или имеющие якорь окна
4 | Плавающие панели инструментов заблокированы
8 | Плавающие окна заблокированы

Таким образом, если системная переменная LOCKUI установлена равной 1 + 4 = 5, заблокированы только закрепленные и плавающие панели; закрепленные, закрепленные якорем и плавающие окна остаются незаблокированными.

ПримечаниеПроверять или изменять значения системной переменной можно в прозрачном режиме, т.е. во время выполнения другой команды; однако новые значения вступают в силу только после завершения приостановленной команды.


Ввод значений системных переменных в командной строке (Процедура)

Ввод команд в командной строке
Ввод значений системных переменных в командной строке
Ввод значений системных переменных в командной строке
Пользовательский интерфейс > Окно команд > Ввод значений системных переменных в командной строке >
Ввод значений системных переменных в командной строке
Понятие Процедура Краткий справочник

Изменение значения системной переменной

Вывод списка всех системных переменных


Изменение значения системной переменной (Процедура)

Ввод значений системных переменных в командной строке
Ввод значений системных переменных в командной строке
Ввод значений системных переменных в командной строке
Пользовательский интерфейс > Окно команд > Ввод значений системных переменных в командной строке >
Ввод значений системных переменных в командной строке
Понятие Процедура Краткий справочник

Изменение значения системной переменной

  1. В командной строке введите имя системной переменной. Например, для переключения режима сетки введите gridmode.
  2. Для изменения состояния переменной GRIDMODE введите 1 , чтобы включить сетку, или 0 для её отключения. Для сохранения текущего значения системной переменной нажмите клавишу ENTER.


Вывод списка всех системных переменных (Процедура)

Ввод значений системных переменных в командной строке
Ввод значений системных переменных в командной строке
Перемещение и редактирование в окне команд
Пользовательский интерфейс > Окно команд > Ввод значений системных переменных в командной строке >
Ввод значений системных переменных в командной строке
Понятие Процедура Краткий справочник

Вывод списка всех системных переменных

  1. Выберите меню "Сервис" [image] "Сведения" [image] "Переменные".Введите в командной строке УСТПЕРЕМ.
  2. В ответ на запрос имени переменной введите ?.
  3. В ответ на подсказку "Список переменных для вывода" нажмите клавишу ENTER.
Ввод команды: УСТПЕРЕМ


Ввод значений системных переменных в командной строке (Краткий справочник)

Ввод команд в командной строке
Ввод значений системных переменных в командной строке
Перемещение и редактирование в окне команд
Пользовательский интерфейс > Окно команд > Ввод значений системных переменных в командной строке >
Ввод значений системных переменных в командной строке
Понятие Процедура Краткий справочник

Команды

УСТПЕРЕМ

Вывод списка системных переменных, изменение их значений

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Перемещение и редактирование в окне команд (Понятие)

Ввод значений системных переменных в командной строке
Окно команд
Переключение между диалоговыми окнами и командной строкой
Пользовательский интерфейс > Окно команд >
Перемещение и редактирование в окне команд
Понятие Процедура Краткий справочник

В окне команд можно перемещаться и выполнять редактирование текста для исправления и повторного ввода команд.

Для этого используются стандартные клавиши:

  • СТРЕЛКИ ВВЕРХ, ВНИЗ, ВЛЕВО и ВПРАВО
  • INSERT, DELETE
  • PAGE UP, PAGE DOWN
  • HOME, END
  • ПРОБЕЛ

Допускается повторение любых команд, использованных в текущем сеансе, путем циклического прохода по командам в окне команд с помощью клавиш СТРЕЛКА ВВЕРХ, СТРЕЛКА ВНИЗ и ENTER. По умолчанию нажатием сочетания клавиш CTRL+C выполняется копирование выделенного текста в буфер обмена. При нажатии сочетания клавиш CTRL+V текст из буфера обмена вставляется в текстовое или командное окно.

При нажатии правой кнопки мыши в области окна команд или текстового окна отображается контекстное меню, в котором содержатся шесть недавно использованных команд, можно скопировать выделенный текст или весь протокол команд, вставить текст, а также открыть диалоговое окно "Настройка".

Для большинства команд вполне достаточно видеть в командном окне текущую командную строку и две-три предыдущих (так называемый протокол команд). Перемещаясь по окну команд, можно просматривать несколько строк протокола команд. Размеры окна команд изменяются путем растягивания его рамки. Для команд, осуществляющих вывод текстовой информации, например СПИСОК, можно увеличить размер окна команд или, нажав клавишу F2, направить вывод в текстовое окно.

Использование текстового окна

Текстовое окно подобно окну команд; в нём также можно вводить команды и наблюдать подсказки и сообщения. В текстовом окне отображается полный протокол команд текущего сеанса работы. Текстовое окно используется для просмотра результатов работы команд с большим объёмом вывода, таких как СПИСОК, в котором приводится подробная информация о выбранных объектах. Для перемещения по протоколу команд служат стрелки для прокрутки на правом краю окна.

Выделение текста выполняется с помощью клавиши SHIFT и стандартных клавиш перемещения. Например, комбинация клавиш SHIFT+HOME позволяет выделить текст от позиции курсора до начала строки.

Для копирования в буфер обмена всего содержимого текстового окна используется команда КПРОТОКОЛ.

Для сохранения команд в файле журнала следует использовать команду ЖУРНАЛВКЛ. Для файлов журнала, совместимых с форматом Unicode, следует использовать системную переменную TEXTOUTPUTFILEFORMAT.

См. также

    • Закрепление, изменение размера и скрытие окна команд

    • Использование динамического ввода


Перемещение и редактирование в окне команд (Процедура)

Ввод значений системных переменных в командной строке
Перемещение и редактирование в окне команд
Перемещение и редактирование в окне команд
Пользовательский интерфейс > Окно команд > Перемещение и редактирование в окне команд >
Перемещение и редактирование в окне команд
Понятие Процедура Краткий справочник

Копирование текста из текстового окна в командную строку


Перемещение и редактирование в окне команд (Процедура)

Перемещение и редактирование в окне команд
Перемещение и редактирование в окне команд
Перемещение и редактирование в окне команд
Пользовательский интерфейс > Окно команд > Перемещение и редактирование в окне команд >
Перемещение и редактирование в окне команд
Понятие Процедура Краткий справочник

Открытие текстового окна

  • Последовательно щелкните вкладку "Вид", [image] панель "Элементы окон", [image] пункт "Текстовое окно". Введите в командной строке ТЕКСТЭКР.

Текстовое окно отображается перед областью построения.

Ввод команды: ТЕКСТЭКР


Перемещение и редактирование в окне команд (Процедура)

Перемещение и редактирование в окне команд
Перемещение и редактирование в окне команд
Перемещение и редактирование в окне команд
Пользовательский интерфейс > Окно команд > Перемещение и редактирование в окне команд >
Перемещение и редактирование в окне команд
Понятие Процедура Краткий справочник

Закрытие текстового окна

  • Находясь в текстовом окне, нажмите клавишу F2.

Текстовое окно закрывается. Для этих же целей можно использовать и стандартные средства Windows.

Ввод команды: ГРАФЭКР


Копирование текста из текстового окна в командную строку (Процедура)

Перемещение и редактирование в окне команд
Перемещение и редактирование в окне команд
Переключение между диалоговыми окнами и командной строкой
Пользовательский интерфейс > Окно команд > Перемещение и редактирование в окне команд >
Перемещение и редактирование в окне команд
Понятие Процедура Краткий справочник

Копирование текста из текстового окна в командную строку

  1. Если текстовое окно не отображается, последовательно щелкните вкладку "Сервис", [image] панель "Элементы окон", [image] пункт "Текстовое окно". Введите в командной строке ТЕКСТЭКР.
  2. Выделите текст, который нужно скопировать.
  3. Щелкните правой кнопкой мыши в окне команд или текстовом окне. В контекстном меню выберите пункт "Вставка в командную строку".

    Текст копируется в буфер обмена, а затем вставляется в командную строку. После нажатия клавиши ENTER команды выполняются по порядку, как сценарий. Для копирования и вставки текста используются также сочетания клавиш CTRL+C и CTRL+V.

    Ввод команды: КБУФЕР, ВСТБУФЕР


Перемещение и редактирование в окне команд (Краткий справочник)

Ввод значений системных переменных в командной строке
Перемещение и редактирование в окне команд
Переключение между диалоговыми окнами и командной строкой
Пользовательский интерфейс > Окно команд > Перемещение и редактирование в окне команд >
Перемещение и редактирование в окне команд
Понятие Процедура Краткий справочник

Команды

КБУФЕР

Копирование выбранных объектов в буфер обмена

КПРОТОКОЛ

Копирование текста из окна журнала командной строки в буфер обмена

ГРАФЭКР

Переключение из текстового окна в область рисования

ЖУРНАЛОТКЛ

Закрытие текстового окна файла журнала, открытого командой ЖУРНАЛВКЛ

ЖУРНАЛВКЛ

Включение записи содержимого текстового окна в файл

ВСТБУФЕР

Вставка содержимого буфера обмена

ТЕКСТЭКР

Открытие текстового окна

Системные переменные

LOGFILEMODE

Признак записи содержимого текстового окна в файл журнала

LOGFILENAME

Путь и имя файла журнала текстового окна для текущего чертежа

LOGFILEPATH

Путь к файлам журналов текстового окна для всех чертежей в сеансе

TEXTFILEOUTPUTFORMAT

Служит для хранения параметров Unicode для печати и текстовых файлов журналов

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Переключение между диалоговыми окнами и командной строкой (Понятие)

Перемещение и редактирование в окне команд
Окно команд
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд >
Переключение между диалоговыми окнами и командной строкой
Понятие Процедура Краткий справочник

С некоторыми командами можно работать как в командной строке, так в диалоговых окнах. Эта возможность особенно полезна при использовании сценариев.

С некоторыми командами можно работать как в командной строке, так в диалоговых окнах. Для многих команд отмена открытия диалогового окна и переход к работе в командной строке осуществляется путем ввода дефиса перед именем команды. Например, ввод команды слой в командной строке приводит к открытию диалогового окна "Диспетчер свойств слоев". Если же ввести -слой, эквивалентный набор параметров для управления свойствами слоёв выводится в командной строке. Подавление вывода диалоговых окон полезно для обеспечения совместимости с более ранними версиями AutoCAD® и для использования пакетных файлов. Параметры, отображаемые в диалоговом окне, могут незначительно отличаться от выводимых в командной строке.

Следующие системные переменные оказывают влияние на открытие диалоговых окон:

  • ATTDIA указывает, должно ли использоваться диалоговое окно для ввода атрибутов команды ВСТАВКА.
  • CMDNAMES задаёт вывод имён (английских) текущей активной команды и прозрачной команды.
  • EXPERT указывает, нужно ли выводить диалоговые окна с предупреждениями.
  • FILEDIA управляет появлением диалоговых окон для чтения и записи файлов. Например, если для переменной FILEDIA задано значение 1, при выполнении командыСОХРАНИТЬКАК открывается диалоговое окно "Сохранение чертежа". Если для переменной FILEDIA задано значение 0, выполнение команды СОХРАН В приводит к отображению подсказки в командной строке. При описании процедур в этом документе предполагается, что переменная FILEDIA равна 1. Даже если FILEDIA равна 0, можно открыть диалоговое окно, введя тильду (~) в ответ на первую подсказку.

Переменные FILEDIA и EXPERT полезны при выполнении команд с помощью сценариев.


Выполнение команд в режиме командной строки (Процедура)

Перемещение и редактирование в окне команд
Переключение между диалоговыми окнами и командной строкой
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд > Переключение между диалоговыми окнами и командной строкой >
Переключение между диалоговыми окнами и командной строкой
Понятие Процедура Краткий справочник

Выполнение команд в режиме командной строки

  • Для большинства команд нужно вводить знак минус (-) перед именем команды.
  • Для работы с диалоговыми окнами, в которых выполняется открытие и сохранение файлов, системная переменная FILEDIA должна иметь значение 0.


Переключение между диалоговыми окнами и командной строкой (Краткий справочник)

Перемещение и редактирование в окне команд
Переключение между диалоговыми окнами и командной строкой
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд > Переключение между диалоговыми окнами и командной строкой >
Переключение между диалоговыми окнами и командной строкой
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

ATTDIA

Признак использования диалогового окна для указания значения атрибута при выполнении команды ВСТАВИТЬ

CMDNAMES

Отображение имен активной и прозрачной команд

EXPERT

Управление отображением определенных подсказок

FILEDIA

Подавление отображения диалоговых окон навигации к файлу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Закрепление, изменение размера и скрытие окна команд (Понятие)

Переключение между диалоговыми окнами и командной строкой
Окно команд
Инструменты навигации
Пользовательский интерфейс > Окно команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Необходимость открытия окна команд и изменения его положения определяется характером работы пользователя.

Закрепление окна команд

По умолчанию окно команд закреплено. Ширина закреплённого окна команд совпадает с шириной окна AutoCAD. Если текстовая строка не помещается в командной строке, то выводится всплывающее окошко с полным содержимым строки.

Открепление окна команд (оно становится плавающим) выполняется путем его перетаскивания из зоны закрепления. Зоной закрепления является кромка окна приложения AutoCAD, к которой можно прикреплять панель инструментов, палитру или окно команд. Плавающее окно можно перемещать в любое место экрана; пользователь может произвольно изменять его ширину и высоту.

Повторное закрепление окна команд выполняется путем его перетаскивания в зону закрепления окна AutoCAD.

Якорная привязка окна команд

Возможна якорная привязка окна команд к левой или правой стороне окна AutoCAD. После якорной привязки окно команд остается на экране (но в минимизированном состоянии), что позволяет при необходимости восстановить его. Это способствует также увеличению видимой области рисования. Перед выбором стороны якорной привязки необходимо обеспечить плавающее состояние окна команд. Перед якорной привязкой окна команд необходимо убедиться в его плавающем состоянии, далее нажать правую кнопку мыши на его заголовке и выбрать опцию "Якорь слева" или "Якорь справа".

Изменение размера окна команд

Возможно изменение размера окна команд по вертикали путем перетаскивания разделительной черты, расположенной на верхней кромке окна, когда окно команд закреплено внизу, и на нижней кромке окна, когда окно закреплено вверху.

Скрытие окна команд

Скройте и повторно выведите командную строку, выполнив одно из следующих действий:

  • Выберите меню "Сервис" [image] "Командная строка".
  • Нажмите CTRL+9.

Если скрыть командную строку, ввод команд по-прежнему возможен. Однако некоторые команды и системные переменные возвращают значения в командную строку, поэтому в этих случаях может потребоваться повторный вывод командной строки.

ПримечаниеДля получения сведений о параметрах отображения (таких, как "автоматически убирать с экрана" или "прозрачность") для закрепляемых окон см. "Управление отображением закрепляемых окон" в разделе Задание параметров интерфейса.


Закрепление, изменение размера и скрытие окна команд (Процедура)

Переключение между диалоговыми окнами и командной строкой
Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд > Закрепление, изменение размера и скрытие окна команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Открепление окна команд

Включение режима прозрачности плавающего окна команд

Закрепление окна команд

Изменение размеров закрепленного окна команд

Скрытие окна команд


Открепление окна команд (Процедура)

Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд > Закрепление, изменение размера и скрытие окна команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Открепление окна команд

  • Нажмите на ручке переноса (двойная полоса) на левом ребре закреплённого окна команд и перетаскивайте его из области закрепления до тех пор, пока не появится утолщённая контурная рамка. Расположите окно команд в области построения окна AutoCAD.


Включение режима прозрачности плавающего окна команд (Процедура)

Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд > Закрепление, изменение размера и скрытие окна команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Включение режима прозрачности плавающего окна команд

  1. Щелкните правой кнопкой мыши в плавающем окне команд. Выберите в контекстном меню пункт "Прозрачность".
  2. В диалоговом окне "Прозрачность" переместите указатель шкалы влево, чтобы сделать окно команд менее прозрачным или вправо, чтобы сделать его более прозрачным.

    Степень прозрачности окна может варьироваться от полной непрозрачности до полной прозрачности. Окно команд нельзя сделать прозрачным, если включён режим "Отключить режим прозрачности окна".


Закрепление окна команд (Процедура)

Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд > Закрепление, изменение размера и скрытие окна команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Закрепление окна команд

  • Нажмите на заголовке окна команд и, удерживая кнопку, перетащите его в верхнюю или нижнюю зону закрепления окна AutoCAD. Когда окно команд сравнивается по ширине с окном AutoCAD, отпустите кнопку мыши для закрепления окна.

    Зоной закрепления является кромка окна приложения AutoCAD, что позволяет закреплять панель, палитру или окно команд.

  • Нажмите правую кнопку мыши на заголовке окна "Команда" и выберите "Разрешить закрепление".
    ПримечаниеДля управления закреплением окна команд можно нажать правую кнопку мыши на заголовке окна команд и далее нажать левую кнопку на "Разрешить закрепление".


Изменение размеров закрепленного окна команд (Процедура)

Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс > Окно команд > Закрепление, изменение размера и скрытие окна команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Изменение размеров закрепленного окна команд

  1. Расположите курсор на горизонтальной разделительной черте, чтобы курсор принял форму двойной черты со стрелками.
  2. Перетащите разделительную черту по вертикали, пока не будет достигнут нужный размер.


Скрытие окна команд (Процедура)

Закрепление, изменение размера и скрытие окна команд
Закрепление, изменение размера и скрытие окна команд
Видовой куб
Пользовательский интерфейс > Окно команд > Закрепление, изменение размера и скрытие окна команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Скрытие окна команд

  • Выберите меню "Сервис" [image] "Командная строка".В командной строке введите комстр.
    ПримечаниеДля некоторых команд и системных переменных в командную строку выводятся значения, поэтому в этих случаях может потребоваться отобразить командную строку. Для вывода скрытой командной строки нажмите CTRL+9. Альтернативный метод: Выберите меню "Сервис" [image] "Командная строка".


Закрепление, изменение размера и скрытие окна команд (Краткий справочник)

Переключение между диалоговыми окнами и командной строкой
Закрепление, изменение размера и скрытие окна команд
Обзор видового куба
Пользовательский интерфейс > Окно команд > Закрепление, изменение размера и скрытие окна команд >
Закрепление, изменение размера и скрытие окна команд
Понятие Процедура Краткий справочник

Команды

КОМСТР

Отображение командной строки

СКРЫТЬКОМАНДНУЮСТРОКУ

Скрытие командной строки

Системные переменные

PALETTEOPAQUE

Управление прозрачностью окон

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструменты навигации

Закрепление, изменение размера и скрытие окна команд
Пользовательский интерфейс
Видовой куб
Пользовательский интерфейс >
Инструменты навигации

Инструменты навигации предназначены для изменения ориентации и вида модели.

Степень детализации отображения модели может быть настроена путем изменения коэффициента увеличения. Можно создавать виды, определяющие область модели, и использовать стандартные виды для восстановления известной точки зрения и ориентации.

Темы в этом разделе

  • Видовой куб

    Видовой куб дает визуальное представление текущей о ориентации модели. Видовой куб можно использовать для корректировки точки зрения модели.

  • Штурвалы

    Штурвалы содержат меню отслеживания и обеспечивают из одной точки доступ к различным инструментам 2D и 3D навигации.

  • ShowMotion ("Аниматор движения")

    Аниматор движения можно использовать для создания и воспроизведения анимационных роликов, созданных с помощью камеры. Эти ролики можно использовать для презентаций и для навигации в рамках проекта.


Видовой куб

Инструменты навигации
Инструменты навигации
Обзор видового куба
Пользовательский интерфейс > Инструменты навигации >
Видовой куб
Понятие Процедура

Видовой куб дает визуальное представление текущей о ориентации модели. Видовой куб можно использовать для корректировки точки зрения модели.

Темы в этом разделе

  • Обзор видового куба

    Видовой куб представляет собой инструмент 3D навигации, отображающийся при активной системе 3D графики. С помощью видового куба можно переключаться между стандартными и изометрическими видами.

  • Меню видового куба

    Меню видового куба содержит команды для определения ориентации видового куба, переключения между параллельной и перспективной проекцией, для определения исходного вида вид для модели, и для управления внешним видом видового куба.

  • Изменение вида модели с помощью видового куба

    Можно изменить вид модели с помощью восстановления стандартного вида или перетаскивания видового куба, поворота текущего вида на 90 градусов, переключения на вид соседней грани, переключения между режимами проекции и определения и восстановления исходного вида.

  • Изменение ПСК с помощью видового куба

    Видовой куб позволяет изменить текущую ПСК модели на одну из именованных ПСК, сохраненных в модели, или определить новую ПСК.


Видовой куб (Процедура)

Закрепление, изменение размера и скрытие окна команд
Видовой куб
Обзор видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб >
Видовой куб
Понятие Процедура

Отображение или скрытие видового куба

Настройка положения видового куба

Настройка размера видового куба

Настройка непрозрачности неактивного видового куба

Отображение компаса видового куба

Отображение меню видового куба

Управление отображением меню ПСК

Определение текущей ПСК

Переключение на другую ПСК

Переключение на МСК.

Задание ориентации видового куба на основе текущей ПСК или МСК


Обзор видового куба (Понятие)

Видовой куб
Видовой куб
Меню видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб >
Обзор видового куба
Понятие Процедура Краткий справочник

Видовой куб представляет собой инструмент 3D навигации, отображающийся при активной системе 3D графики. С помощью видового куба можно переключаться между стандартными и изометрическими видами.

При вызове видовой куб отображается в неактивном состоянии одного из углов окна чертежа над моделью. В неактивном состоянии видовой куб отображает текущую точку зрения модели, основанную на текущей ПСК и направлении на север, определяемым МСК модели. При наведении курсора на видовой куб он становится активным. Можно переключиться на один из доступных стандартных видов, наклонить текущий вид или перейти к исходному виду модели.

Настройка отображения видового куба

Видовой куб отображается в двух состояниях: активном и неактивном. Неактивный видовой куб является прозрачным, располагается над окном чертежа и по умолчанию не закрывает полностью вид модели. Активный видовой куб становится непрозрачным и закрывает вид объектов в модели.

Помимо настройки уровня прозрачности неактивного видового куба можно также задать размер, положение на экране и отображение меню ПСК и компаса. Параметры для настройки отображения видового куба находятся в диалоговом окне "Параметры видового куба".

Использование компаса

Компас видового куба указывает направление на север, определенное для модели. Направление на север, указываемое компасом, основано на направлении на север и вверх, определенных в МСК модели. Диалоговое окно "Географическое положение" используется для определения направления на север и вверх модели. Отображение компаса ниже видового куба задается в диалоговом окне "Параметры видового куба".


Обзор видового куба (Процедура)

Видовой куб
На уровень вверх ..
Обзор видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Обзор видового куба >
Обзор видового куба
Понятие Процедура Краткий справочник

Отображение или скрытие видового куба

Настройка положения видового куба

Настройка размера видового куба

Настройка непрозрачности неактивного видового куба

Отображение компаса видового куба


Отображение или скрытие видового куба (Процедура)

Обзор видового куба
На уровень вверх ..
Обзор видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Обзор видового куба >
Обзор видового куба
Понятие Процедура Краткий справочник

Отображение или скрытие видового куба

  1. Перейдите на вкладку "Вид" [image] панель "Навигация" [image] "Отображение видового куба". В командной строке введите "наввкуб".
  2. Задайте текущий 3D визуальный стиль.

    Перейдите на вкладку "Визуализация" [image] панель "Визуальные стили" [image] "Управление визуальными стилями".В командной строке введите "визстили". Нажмите кнопку мыши на видовом экране для установки его в качестве текущего. В Диспетчере визуальных стилей дважды щелкните один из образцов доступных визуальных стилей, но не "2D каркас".

Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Настройка положения видового куба (Процедура)

Обзор видового куба
На уровень вверх ..
Обзор видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Обзор видового куба >
Обзор видового куба
Понятие Процедура Краткий справочник

Настройка положения видового куба

  1. Щелкните на видовом кубе правой кнопкой мыши и выберите "Параметры.
  2. В диалоговом окне "Параметры видового куба" в области "Отображение" выберите в раскрывающемся списке "Положение на экране" одно из доступных значений.
  3. Нажмите "ОК".
Ввод команды: НАВВКУБ
Меню: Вид [image] Отображение [image] Видовой куб [image] ПараметрыПункт отсутствует в меню.


Настройка размера видового куба (Процедура)

Обзор видового куба
На уровень вверх ..
Обзор видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Обзор видового куба >
Обзор видового куба
Понятие Процедура Краткий справочник

Настройка размера видового куба

  1. Щелкните на видовом кубе правой кнопкой мыши и выберите "Параметры.
  2. В диалоговом окне "Настройки видового куба" в области "Отображение" перетащите влево или вправо регулятор "Размер видового куба".

    Перемещение регулятора влево соответствует уменьшению размера видового куба, перемещение вправо - увеличению.

  3. Нажмите "ОК".
Ввод команды: НАВВКУБ
Меню: Вид [image] Отображение [image] Видовой куб [image] ПараметрыПункт отсутствует в меню.


Настройка непрозрачности неактивного видового куба (Процедура)

Обзор видового куба
На уровень вверх ..
Обзор видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Обзор видового куба >
Обзор видового куба
Понятие Процедура Краткий справочник

Настройка непрозрачности неактивного видового куба

  1. Щелкните на видовом кубе правой кнопкой мыши и выберите "Параметры.
  2. В диалоговом окне "Настройки видового куба" в области "Отображение" перетащите влево или вправо регулятор "Непрозрачность при неактивности".

    Перемещение регулятора влево соответствует увеличению прозрачности видового куба, перемещение вправо - увеличению непрозрачности.

  3. Нажмите "ОК".
Ввод команды: НАВВКУБ
Меню: Вид [image] Отображение [image] Видовой куб [image] ПараметрыПункт отсутствует в меню.


Отображение компаса видового куба (Процедура)

Обзор видового куба
На уровень вверх ..
Меню видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Обзор видового куба >
Обзор видового куба
Понятие Процедура Краткий справочник

Отображение компаса видового куба

  1. Щелкните на видовом кубе правой кнопкой мыши и выберите "Параметры.
  2. В диалоговом окне "Параметры видового куба" установите флажок "Показать компас под видовым кубом".

    Компас отображается под видовым кубом и указывает направление на север в модели.

  3. Нажмите "ОК".
Ввод команды: НАВВКУБ
Меню: Вид [image] Отображение [image] Видовой куб [image] ПараметрыПункт отсутствует в меню.


Обзор видового куба (Краткий справочник)

Закрепление, изменение размера и скрытие окна команд
Обзор видового куба
Меню видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Обзор видового куба >
Обзор видового куба
Понятие Процедура Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

NAVVCUBEDISPLAY

Управление отображением видового куба для текущего видового экрана при активной системе 3D графики

NAVVCUBELOCATION

Определение угла видового экрана, в котором отображается видовой куб

NAVVCUBEOPACITY

Управление прозрачностью неактивного видового куба

NAVVCUBESIZE

Задание размера видового куба

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Меню видового куба (Понятие)

Обзор видового куба
Видовой куб
Изменение вида модели с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб >
Меню видового куба
Понятие Процедура Краткий справочник

Меню видового куба содержит команды для определения ориентации видового куба, переключения между параллельной и перспективной проекцией, для определения исходного вида вид для модели, и для управления внешним видом видового куба.

Контекстное меню видового куба содержит следующие команды:

  • вид. Восстановление исходного вида, сохраненного в модели.
  • Параллельная. Переключение текущего вида на параллельную проекцию.
  • Перспективная. Переключение текущего вида на перспективную проекцию.
  • Перспективная с ортогональными гранями. Переключение текущего вида на перспективную проекцию, пока текущий вид не будет выровнен по грани вида, определенной на видовом кубе.
  • Текущий вид как исходный. Определение исходного вида модели на основе текущего вида.
  • Ориентация камеры в соответствии с углом выбранного вида (план, уровень, сечение или 3D вид).
  • Параметры видового куба. Вызов диалогового окна регулировки отображения и поведения видового куба.
  • Справка.Вызов интерактивной справочной системы и отображение справки для видового куба.


Отображение меню видового куба (Процедура)

Обзор видового куба
На уровень вверх ..
Изменение текущего вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Меню видового куба >
Меню видового куба
Понятие Процедура Краткий справочник

Отображение меню видового куба

  • Щелкните правой кнопкой мыши компас, значок исходного вида или основную область видового куба.
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Меню видового куба (Краткий справочник)

Обзор видового куба
Меню видового куба
Изменение вида модели с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Меню видового куба >
Меню видового куба
Понятие Процедура Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

PERSPECTIVE

Признак отображения вида в перспективе в текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменениевида модели с помощью видового куба (Понятие)

Меню видового куба
Видовой куб
Изменение текущего вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб >
Изменениевида модели с помощью видового куба
Понятие Краткий справочник

Можно изменить вид модели с помощью восстановления стандартного вида или перетаскивания видового куба, поворота текущего вида на 90 градусов, переключения на вид соседней грани, переключения между режимами проекции и определения и восстановления исходного вида.

Темы в этом разделе

  • Изменение текущего вида

    Можно изменить текущий вид модели, щелкнув предварительно определенные области на видовом кубе или перетащив видовой куб.

  • Задание режима проекции вида

    Проекция вида применяется для создания реалистичных визуальных эффектов модели.

  • Определение исходного вида

    Для модели можно определить исходный вид, чтобы затем при использовании инструментов навигации можно было восстановить знакомый вид.

  • Просмотр отдельных объектов с помощью видового куба

    С помощью видового куба можно просматривать отдельные объекты модели.


Изменениевида модели с помощью видового куба (Краткий справочник)

Меню видового куба
Изменение вида модели с помощью видового куба
Изменение текущего вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба >
Изменениевида модели с помощью видового куба
Понятие Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

NAVVCUBEDISPLAY

Управление отображением видового куба для текущего видового экрана при активной системе 3D графики

PERSPECTIVE

Признак отображения вида в перспективе в текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение текущего вида (Понятие)

Изменение вида модели с помощью видового куба
Изменение вида модели с помощью видового куба
Задание режима проекции вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба >
Изменение текущего вида
Понятие Процедура Краткий справочник

Можно изменить текущий вид модели, щелкнув предварительно определенные области на видовом кубе или перетащив видовой куб.

Видовой куб содержит двадцать шесть определенных областей для изменения текущего вида модели. Эти двадцать шесть областей разделены на три группы: угол, кромка и грань. Из двадцати шести областей шесть соответствуют стандартным ортогональным видам модели: сверху, снизу, спереди, сзади, слева и справа. Ортогональные виды задаются с помощью щелчка на одной из граней видового куба.

Остальные двадцать областей используются для доступа к угловым видам модели. Щелчок на один из углов видового куба приводит к изменению текущего вида модели на вид в три четверти, основанный на точке зрения, определенной тремя сторонами модели. Щелчок на одной из кромок приводит к изменению вида модели на вид в три четверти, основанный на двух сторонах модели.

Изменение вида модели с помощью видового куба можно выполнить не только щелчком на определенной области видового куба, можно щелкнуть и перетащить видовой куб. Щелчок и перетаскивание видового куба позволяют изменить вид модели на пользовательскую точку зрения, отличную от одной из двадцати шести доступных стандартных точек зрения.

Для запуска анимации нажмите стрелку "Воспроизведение".

Наклонить вид грани

При просмотре модели в одном из видов грани рядом с видовым кубом отображаются два дополнительных значка. Это стрелки наклона. Стрелки наклона можно использовать для наклона или поворота текущего вида на 90 градусов в обоих направлениях вокруг центра вида.

Переключиться на соседнюю грань

При просмотре модели в одном из видов грани видовой куб можно использовать для переключения на один из соседних видов грани без предварительного выбора вида модели для просмотра соседнего вида. При активном видовом кубе и текущем виде грани отображаются четыре треугольника, по одному с каждой стороны видового куба. Эти треугольники позволяют вращать текущий вид для просмотра вида грани, определяемого треугольником.


Изменение текущего вида (Процедура)

Меню видового куба
Изменение текущего вида
Изменение текущего вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Изменение текущего вида >
Изменение текущего вида
Понятие Процедура Краткий справочник

Переход от текущего вида к стандартному виду

Вид соседней грани

Наклон вида грани

Интерактивное изменение вида


Переход от текущего вида к стандартному виду (Процедура)

Изменение текущего вида
Изменение текущего вида
Изменение текущего вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Изменение текущего вида >
Изменение текущего вида
Понятие Процедура Краткий справочник

Переход от текущего вида к стандартному виду

  1. Активизация видового куба.
  2. Щелкните одну из граней, кромок или углов видового куба.
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Вид соседней грани (Процедура)

Изменение текущего вида
Изменение текущего вида
Изменение текущего вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Изменение текущего вида >
Изменение текущего вида
Понятие Процедура Краткий справочник

Вид соседней грани

  1. Активизация видового куба.
    ПримечаниеУбедитесь, что вид грани является текущим.
  2. Щелкните на одном из треугольников, расположенных рядом с кромками видового куба.
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Наклон вида грани (Процедура)

Изменение текущего вида
Изменение текущего вида
Изменение текущего вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Изменение текущего вида >
Изменение текущего вида
Понятие Процедура Краткий справочник

Наклон вида грани

  1. Активизация видового куба.
    ПримечаниеУбедитесь, что вид грани является текущим.
  2. Щелкните одну из стрелок наклона, которые отображаются справа над видовым кубом.

    Щелкните стрелку наклона влево для поворота вида на 90 градусов против часовой стрелки или щелкните стрелку наклона вправо для поворота вида на 90 градусов по часовой стрелке.

Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Интерактивное изменение вида (Процедура)

Изменение текущего вида
Изменение текущего вида
Задание режима проекции вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Изменение текущего вида >
Изменение текущего вида
Понятие Процедура Краткий справочник

Интерактивное изменение вида

  • Щелкните на видовом кубе и, удерживая нажатой кнопку мыши, перетащите его на орбиту модели.

    Перетаскивайте видовой куб в направлении обхода модели по орбите.

Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Изменение текущего вида (Краткий справочник)

Изменение вида модели с помощью видового куба
Изменение вида модели с помощью видового куба
Задание режима проекции вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Изменение текущего вида >
Изменение текущего вида
Понятие Процедура Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание режима проекции вида (Понятие)

Изменение текущего вида
Изменение вида модели с помощью видового куба
Определение исходного вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба >
Задание режима проекции вида
Понятие Процедура Краткий справочник

Проекция вида применяется для создания реалистичных визуальных эффектов модели.

Видовой куб поддерживает две различных проекции вида: перспективную и параллельную. Перспективные виды проекции вычисляются на основе расстояния от теоретической точки расположения камеры до целевой точки. Чем короче расстояние между камерой и целевой точкой, тем сильнее отображается эффект перспективы. При больших расстояниях эффект перспективы влияет на модель в меньшей степени. Параллельные виды проекции содержат все точки модели, проецируемые параллельно экрану.

На следующем рисунке представлена та же модель, рассматриваемая при том же направлении взгляда, но с различными проекциями видов.

При изменении вида для модели, вид обновляется с использованием последнего режима проекции, если для видового куба не задан режим проекции "Перспективная с ортогональными гранями". В режиме "Перспективная с ортогональными гранями" все виды отображаются в перспективной проекции, если модель рассматривается в одном из видов граней: сверху, снизу, спереди, сзади, слева или справа.

При закрытии видового куба режим проекции, используемый для вида модели, сохраняется в текущем виде, если только последним не был режим "Перспективная с ортогональными гранями". Если последним использовался режим "Перспективная с ортогональными гранями", виду назначается параллельная или перспективная проекция. При повторном вызове видового куба, сохраненные проекции видов восстанавливаются.


Изменение режима проекции вида (Процедура)

Изменение текущего вида
Задание режима проекции вида
Определение исходного вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Задание режима проекции вида >
Задание режима проекции вида
Понятие Процедура Краткий справочник

Изменение режима проекции вида

  1. Щелкните правой кнопкой мыши на видовом кубе и выберите одну из следующих опций:
    • Параллельная
    • Перспективная
    • Перспективная с ортогональными гранями
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Задание режима проекции вида (Краткий справочник)

Изменение текущего вида
Изменение вида модели с помощью видового куба
Определение исходного вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Задание режима проекции вида >
Задание режима проекции вида
Понятие Процедура Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

NAVVCUBEDISPLAY

Управление отображением видового куба для текущего видового экрана при активной системе 3D графики

PERSPECTIVE

Признак отображения вида в перспективе в текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Определение исходного вида (Понятие)

Задание режима проекции вида
Изменение вида модели с помощью видового куба
Просмотр отдельных объектов с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба >
Определение исходного вида
Понятие Процедура Краткий справочник

Для модели можно определить исходный вид, чтобы затем при использовании инструментов навигации можно было восстановить знакомый вид.

Исходный вид представляет собой особый вид модели. Границы модели используются как вид по умолчанию для исходного вида моделей, созданных до AutoCAD 2008. Для всех новых моделей используется вид модели в три четверти, определенный по ориентации "Сверху/Слева/Спереди". Вид модели также можно определить в качестве исходного. Позже для возврата к знакомому виду щелкните значок "Исходный вид" или выберите команду "Исходный вид" в контекстном меню.

Исходный вид можно использовать для возврата во время навигации к знакомому виду, также можно создать образец для просмотра при сохранении модели вместо использования последнего сохраненного вида. Диалоговое окно "Настройка образцов для просмотра" применяется для задания вида (исходный или последний сохраненный) при генерации образцов для просмотра при сохранении модели. Вместе с определением используемого для образцов для просмотра вида при сохранении модели, восстановить исходный вид можно в диалоговом окне "Настройка образцов для просмотра".


Определение исходного вида (Процедура)

Задание режима проекции вида
Определение исходного вида
Определение исходного вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Определение исходного вида >
Определение исходного вида
Понятие Процедура Краткий справочник

Определение исходного вида

Восстановление исходного вида

Восстановление исходного вида по умолчанию


Определение исходного вида (Процедура)

Определение исходного вида
Определение исходного вида
Определение исходного вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Определение исходного вида >
Определение исходного вида
Понятие Процедура Краткий справочник

Определение исходного вида

  • Щелкните правой кнопкой мыши на видовом кубе и выберите "Текущий вид как исходный".
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Восстановление исходного вида (Процедура)

Определение исходного вида
Определение исходного вида
Определение исходного вида
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Определение исходного вида >
Определение исходного вида
Понятие Процедура Краткий справочник

Восстановление исходного вида

Для восстановления исходного вида воспользуйтесь одним из следующих способов:

  • Щелкните значок "Исходный вид", расположенный рядом с видовым кубом.
  • Щелкните правой кнопкой мыши на видовом кубе и выберите вид".
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Восстановление исходного вида по умолчанию (Процедура)

Определение исходного вида
Определение исходного вида
Просмотр отдельных объектов с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Определение исходного вида >
Определение исходного вида
Понятие Процедура Краткий справочник

Восстановление исходного вида по умолчанию

  1. Выберите меню Сервис [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Настройки" на вкладке "Открытие и сохранение" в области "Сохранение файла" щелкните "Настройка образцов для просмотра".
  3. В диалоговом окне "Настройка образцов для просмотра" установите флажок "Восстановить исходный вид по умолчанию".
  4. Нажмите "ОК" для закрытия диалогового окна "Настройка образцов для просмотра".
  5. Нажмите кнопку "OK", чтобы закрыть диалоговое окно "Настройка".
Ввод команды: НАСТРОЙКА


Определение исходного вида (Краткий справочник)

Задание режима проекции вида
Изменение вида модели с помощью видового куба
Просмотр отдельных объектов с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Определение исходного вида >
Определение исходного вида
Понятие Процедура Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Просмотр отдельных объектов с помощью видового куба (Понятие)

Определение исходного вида
Изменение вида модели с помощью видового куба
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба >
Просмотр отдельных объектов с помощью видового куба
Понятие Процедура Краткий справочник

С помощью видового куба можно просматривать отдельные объекты модели.

Видовой куб позволяет определить центр вида на основе одного или нескольких выбранных объектов. После выбора объектов и изменения вида из видового куба модель поворачивается вокруг центра вида, вычисленного по границам выбранных объектов.


Просмотр отдельных объектов с помощью видового куба (Процедура)

Определение исходного вида
Просмотр отдельных объектов с помощью видового куба
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Просмотр отдельных объектов с помощью видового куба >
Просмотр отдельных объектов с помощью видового куба
Понятие Процедура Краткий справочник

Просмотр отдельных объектов с помощью видового куба

  1. Выберите в модели один или несколько объектов для определения центральной точки вида.
  2. Выберите одно из стандартных расположений на видовом кубе или перетащите видовой куб для изменения вида модели.

    Видовой куб изменяет вид модели в зависимости от центральной точки выбранных объектов.

Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Просмотр отдельных объектов с помощью видового куба (Краткий справочник)

Определение исходного вида
Изменение вида модели с помощью видового куба
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение вида модели с помощью видового куба > Просмотр отдельных объектов с помощью видового куба >
Просмотр отдельных объектов с помощью видового куба
Понятие Процедура Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение ПСК с помощью видового куба (Понятие)

Просмотр отдельных объектов с помощью видового куба
Видовой куб
Штурвалы
Пользовательский интерфейс > Инструменты навигации > Видовой куб >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Видовой куб позволяет изменить текущую ПСК модели на одну из именованных ПСК, сохраненных в модели, или определить новую ПСК.

В меню ПСК, расположенное под видовым кубом, указано имя текущей ПСК в модели. Это меню позволяет восстановить одну из именованных ПСК, сохраненных в модели, или переключиться на МСК, или определить новую ПСК. Если в меню выбрать пункт "МСК", можно переключить систему координат из ПСК в МСК. Команда "Новая ПСК" позволяет поворачивать текущую ПСК на основе одной, двух или трех точек для определения новой ПСК. Если выбрать команду "Новая ПСК", определяется новая ПСК, которой по умолчанию задается имя "Без имени". Для сохранения ПСК под именем с возможностью ее восстановления используйте опцию "Имя".

Видовой куб можно ориентировать по текущей ПСК или МСК. При ориентации видового куба по текущей ПСК будет известно направления моделирования. При ориентации видового куба по МСК можно просматривать модель на основе направлений на север и на юг модели. Параметры управления ориентацией видового куба содержатся в диалоговом окне "Параметры видового куба".


Изменение ПСК с помощью видового куба (Процедура)

Просмотр отдельных объектов с помощью видового куба
На уровень вверх ..
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение ПСК с помощью видового куба >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Управление отображением меню ПСК

Определение текущей ПСК

Переключение на другую ПСК

Переключение на МСК.

Задание ориентации видового куба на основе текущей ПСК или МСК


Управление отображением меню ПСК (Процедура)

Изменение ПСК с помощью видового куба
На уровень вверх ..
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение ПСК с помощью видового куба >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Управление отображением меню ПСК

  1. Щелкните на видовом кубе правой кнопкой мыши и выберите "Параметры.
  2. В диалоговом окне "Параметры видового куба" в области "Отображение" установите флажок "Показать меню ПСК".

    Если флажок "Показать меню ПСК" установлен, меню ПСК отображается под видовым кубом. Можно просмотреть, какая ПСК является текущий и переключиться на другую именованную ПСК. Если флажок не установлен, меню ПСК не отображается.

Ввод команды: НАВВКУБ
Меню: Вид [image] Отображение [image] Видовой куб [image] ПараметрыПункт отсутствует в меню.


Определение текущей ПСК (Процедура)

Изменение ПСК с помощью видового куба
На уровень вверх ..
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение ПСК с помощью видового куба >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Определение текущей ПСК

  • Текущая ПСК представлена в меню ПСК под видовым кубом.
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Переключение на другую ПСК (Процедура)

Изменение ПСК с помощью видового куба
На уровень вверх ..
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение ПСК с помощью видового куба >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Переключение на другую ПСК

  1. В меню ПСК, расположенном под видовым кубом, щелкните стрелку рядом с именем текущей ПСК.
  2. Выберите из списка именованную ПСК.
Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Переключение на МСК. (Процедура)

Изменение ПСК с помощью видового куба
На уровень вверх ..
Изменение ПСК с помощью видового куба
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение ПСК с помощью видового куба >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Переключение на МСК.

  1. В меню ПСК, расположенном под видовым кубом, щелкните стрелку рядом с именем текущей ПСК.
  2. Выберите из списка МСК.


Задание ориентации видового куба на основе текущей ПСК или МСК (Процедура)

Изменение ПСК с помощью видового куба
На уровень вверх ..
Штурвалы
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение ПСК с помощью видового куба >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Задание ориентации видового куба на основе текущей ПСК или МСК

  1. Щелкните на видовом кубе правой кнопкой мыши и выберите "Параметры.
  2. В диалоговом окне "Параметры видового куба" установить флажок "Ориентировать видовой куб по текущей ПСК".

    Если флажок "Ориентировать видовой куб по текущей ПСК" установлен, видовой куб привязывается к текущей ПСК. Если флажок не установлен, видовой куб привязан к МСК модели.

Ввод команды: НАВВКУБ
Лента:Вкладка "Главная" [image] панель "Вид" [image] "Отображение видового куба".
Меню: Вид [image] Отображение [image] Видовой куб [image] ВклПункт отсутствует в меню.


Изменение ПСК с помощью видового куба (Краткий справочник)

Просмотр отдельных объектов с помощью видового куба
Изменение ПСК с помощью видового куба
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Видовой куб > Изменение ПСК с помощью видового куба >
Изменение ПСК с помощью видового куба
Понятие Процедура Краткий справочник

Команды

НАВВКУБ

Управление видимостью и параметрами отображения видового куба

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПСК

Управление пользовательскими системами координат

Системные переменные

NAVVCUBEORIENT

Управление отображением текущей ПСК или МСК в видовом кубе

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Штурвалы

Изменение ПСК с помощью видового куба
Инструменты навигации
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации >
Штурвалы
Понятие Процедура

Штурвалы содержат меню отслеживания и обеспечивают из одной точки доступ к различным инструментам 2D и 3D навигации.

Темы в этом разделе

  • Обзор штурвалов

    Штурвалы содержат меню отслеживания, они разделенные на секции, называемые сегментами. Каждый сегмент штурвала представляет собой отдельный инструмент навигации. Можно выполнять панорамирование, зумирование или изменение текущего вида модели различными способами.

  • Меню штурвалов

    В меню штурвалов можно выбирать различные штурвалы и изменять поведение некоторых инструментов навигации текущего штурвала.

  • Штурвалы

    Имеется несколько различных штурвалов. У каждого штурвала имеется своя тема. Некоторые штурвалы предназначены для 2D навигации, другие лучше подходят для 3D навигации.

  • Инструменты навигации

    Инструменты навигации изменяют текущий вид модели.


Штурвалы (Процедура)

Изменение ПСК с помощью видового куба
Штурвалы
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы >
Штурвалы
Понятие Процедура

Отображение штурвала

Закрытие штурвала

Изменение размера штурвала

Изменение непрозрачности штурвалов

Управление размещением штурвалов при запуске

Включение подсказок для штурвалов

Включение информации об инструментах

Отображение меню штурвалов


Обзор штурвалов (Понятие)

Штурвалы
Штурвалы
Меню штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы >
Обзор штурвалов
Понятие Процедура Краткий справочник

Штурвалы содержат меню отслеживания, они разделенные на секции, называемые сегментами. Каждый сегмент штурвала представляет собой отдельный инструмент навигации. Можно выполнять панорамирование, зумирование или изменение текущего вида модели различными способами.

Штурвалы позволяют экономить время за счет объединения в одном интерфейсе различных инструментов навигации. Штурвалы зависят от контекста, представленного в модели.

Уведомление о неактивном штурвале

Если штурвал при запуске закреплен, он не перемещается вслед за курсором. Для штурвалов отображается уведомление о неактивном состоянии Уведомление о неактивном штурвале служит для описания назначения штурвалов и способов их применения. Изменить поведение штурвалов при запуске можно в диалоговом окне "Параметры штурвалов".

Отображение и использование штурвалов

Вызвать штурвал можно из контекстного меню, инструментальной панели или меню. После вызова штурвала можно активизировать один из доступных инструментов навигации с помощью щелчка на одном из сегментов штурвала или нажатия и удержания нажатой кнопки мыши. Затем нужно перетащить курсор на окна чертежа так, чтобы изменился текущий вид. При отпускании кнопки мыши открывается штурвал.

Для запуска анимации нажмите стрелку "Воспроизведение".

Управление отображением штурвалов

Управлять отображением штурвалов можно с помощью изменения текущего режима или регулировки размера и непрозрачности штурвалов. Для штурвалов (за исключением штурвалов 2D навигации) доступно два режима: большой и мини. Для изменения текущего режима штурвала щелкните штурвал правой кнопкой мыши и выберите другой режим.

Помимо изменения текущего режима можно изменить непрозрачность и размер штурвалов. Размер штурвала управляет размером его сегментов и меток на штурвале, уровень непрозрачности контролирует видимость объектов в модели, расположенных за штурвалом. Параметры для настройки отображением штурвалов находятся в диалоговом окне "Параметры штурвалов".

Подсказки для штурвалов и информация об инструментах

Подсказки отображаются для каждого сегмента и кнопки, расположенных на штурвале, при наведении курсора. Подсказки отображаются под штурвалом и определяют операцию, которая будет выполнена при щелчке на сегменте или при нажатии кнопки. Включить или отключить отображение подсказок можно в диалоговом окне "Параметры штурвалов".

Информация об инструментах подобна подсказкам и отображается при использовании одного из инструментов навигации штурвала. Информация об инструментах отображается над окном чертежа и содержит инструкции по использованию активного инструмента навигации. Как и в случае подсказок включить и отключить информацию об инструментах можно в диалоговом окне "Параметры штурвалов". Отключение информации об инструментах влияет только на сообщения, которые отображаются при использовании суперштурвалов.


Обзор штурвалов (Процедура)

Штурвалы
На уровень вверх ..
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Отображение штурвала

Закрытие штурвала

Изменение размера штурвала

Изменение непрозрачности штурвалов

Управление размещением штурвалов при запуске

Включение подсказок для штурвалов

Включение информации об инструментах


Отображение штурвала (Процедура)

Обзор штурвалов
На уровень вверх ..
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Отображение штурвала

  • В меню "Вид" выберите [image] "Штурвалы".В командной строке введите "навштурвал".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.


Закрытие штурвала (Процедура)

Обзор штурвалов
На уровень вверх ..
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Закрытие штурвала

Для закрытия штурвалов используйте один из следующих способов:

  • Нажмите клавишу ESC или ENTER.
  • Нажмите кнопку "Закрыть".
  • Щелкните на штурвале правой кнопкой мыши и выберите "Закрыть штурвал".


Изменение размера штурвала (Процедура)

Обзор штурвалов
На уровень вверх ..
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Изменение размера штурвала

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Большие штурвалы" или "Мини-штурвалы" передвиньте регулятор "Размер штурвала" влево или вправо.

    Перемещение регулятора влево соответствует уменьшению размера штурвала, перемещение вправо - увеличению.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Изменение непрозрачности штурвалов (Процедура)

Обзор штурвалов
На уровень вверх ..
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Изменение непрозрачности штурвалов

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Большие штурвалы" или "Мини-штурвалы" передвиньте регулятор "Непрозрачность штурвала" влево или вправо.

    Перемещение регулятора влево соответствует увеличению прозрачности штурвала, перемещение вправо - уменьшению прозрачности.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Управление размещением штурвалов при запуске (Процедура)

Обзор штурвалов
На уровень вверх ..
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Управление размещением штурвалов при запуске

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Отображение" установите флажок "Показать при запуске прикрепленный штурвал".

    Штурвалы открываются прикрепленными. Если флажок снять, штурвалы перемещаются за курсором.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Включение подсказок для штурвалов (Процедура)

Обзор штурвалов
На уровень вверх ..
Обзор штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Включение подсказок для штурвалов

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Отображение" установите флажок "Показывать подсказки".

    Подсказки отображаются для сегментов и кнопок штурвала при наведении курсора.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Включение информации об инструментах (Процедура)

Обзор штурвалов
На уровень вверх ..
Меню штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Включение информации об инструментах

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Отображение" установите флажок "Показывать информацию об инструментах".

    Информация отображается при использовании инструментов навигации.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Обзор штурвалов (Краткий справочник)

Изменение ПСК с помощью видового куба
Обзор штурвалов
Меню штурвалов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Обзор штурвалов >
Обзор штурвалов
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

NAVSWHEELMODE

Задание текущего режима штурвала

NAVSWHEELOPACITYBIG

Управление прозрачностью большого штурвала

NAVSWHEELOPACITYMINI

Управление прозрачностью мини-штурвала

NAVSWHEELSIZEBIG

Задание размера большого штурвала

NAVSWHEELSIZEMINI

Задание размера мини-штурвала

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Меню штурвалов (Понятие)

Обзор штурвалов
Штурвалы
Штурвалы
Пользовательский интерфейс > Инструменты навигации > Штурвалы >
Меню штурвалов
Понятие Процедура Краткий справочник

В меню штурвалов можно выбирать различные штурвалы и изменять поведение некоторых инструментов навигации текущего штурвала.

Меню штурвалов используется для переключения между доступными большими и мини-штурвалами, перехода к исходному виду, изменения параметров текущего штурвала и управления инструментами 3D навигации: орбиты, осмотра и обхода. Команды в меню "Штурвал" зависят от текущего штурвала.

В меню "Штурвал" имеются следующие команды:

  • Мини-штурвал для объектов Отображение мини-версии штурвала для объектов.
  • Мини-штурвал для зданий. Отображение мини-версии штурвала для зданий.
  • Мини-суперштурвал. Отображение мини-версии суперштурвала.
  • Суперштурвал. Отображение суперштурвала.
  • Основные штурвалы. Отображение большой версии штурвала для объектов или зданий.
  • Исходный вид. Восстановление исходного вида, сохраненного в модели.
  • Вписать в окно. Изменение размера и центра текущего вида для отображения всех объектов.
  • Восстановить исходный центр. Восстановление центральной точки вида по границам модели.
  • Выровнять камеру. Поворот текущего вида относительно нулевой плоскости XY.
  • Увеличить скорость обхода. Увеличение скорости обхода для инструмента обхода в два раза.
  • Уменьшить скорость обхода. Уменьшение скорости обхода для инструмента обхода в два раза.
  • Справка. Вызов интерактивной справочной системы и отображение справки для штурвалов.
  • Параметры штурвалов Вызов диалогового окна, в котором можно изменить параметры штурвалов.
  • Закрыть штурвал. Закрытие штурвала.


Отображение меню штурвалов (Процедура)

Обзор штурвалов
На уровень вверх ..
Штурвал для объектов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Меню штурвалов >
Меню штурвалов
Понятие Процедура Краткий справочник

Отображение меню штурвалов

  • Щелкните на стрелке "вниз" в правом нижнем углу штурвала или щелкните штурвал правой кнопкой мыши.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Меню штурвалов (Краткий справочник)

Обзор штурвалов
Меню штурвалов
Штурвалы
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Меню штурвалов >
Меню штурвалов
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

NAVSWHEELMODE

Задание текущего режима штурвала

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Штурвалы (Понятие)

Меню штурвалов
Штурвалы
Штурвал для 2D навигации
Пользовательский интерфейс > Инструменты навигации > Штурвалы >
Штурвалы
Понятие Краткий справочник

Имеется несколько различных штурвалов. У каждого штурвала имеется своя тема. Некоторые штурвалы предназначены для 2D навигации, другие лучше подходят для 3D навигации.

Штурвалы доступны в двух размерах: большие и мини. Большой штурвал больше курсора. На каждом сегменте штурвала имеется метка. Размер мини-штурвала примерно соответствует размеру курсора. На сегментах штурвала метки не отображаются. Штурвалы для 2D навигации доступны только в большом виде.

Можно выбрать следующие штурвалы:

  • 2D навигация
  • Объект
  • Здание
  • Суперштурвал

Темы в этом разделе

  • Штурвал для 2D навигации

    Штурвал для 2D навигации предназначен для основной навигации по модели.

  • Штурвал для объектов

    Штурвал для объектов предназначен для 3D навигации, он включает инструмент навигации 3D орбиты. Используйте штурвал для объектов для просмотра 3D объектов.

  • Штурвалы для зданий

    Штурвалы для зданий предназначены для 3D навигации. Штурвалы для зданий используются для навигации внутри модели.

  • Суперштурвал

    Суперштурвал объединяет инструменты 2D и 3D навигации штурвалов для объектов и зданий.


Штурвалы (Краткий справочник)

Меню штурвалов
Штурвалы
Штурвал для 2D навигации
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы >
Штурвалы
Понятие Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

NAVSWHEELMODE

Задание текущего режима штурвала

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Штурвал для 2D навигации (Понятие)

Штурвалы
Штурвалы
Штурвал для объектов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы >
Штурвал для 2D навигации
Понятие Краткий справочник

Штурвал для 2D навигации предназначен для основной навигации по модели.

Штурвал для 2D навигации разделен на следующие сегменты:

  • Панорамирование. Изменение положения текущего вида с помощью панорамирования.
  • Зумирование. Изменение масштаба текущего вида.
  • Перемотка. Восстановление последнего вида. Можно перемещаться вперед и назад по предыдущим видам.
ПримечаниеВ отличие от других штурвал для 2D навигации является контекстно-зависимым и отображается при активной вкладке листа, или если системной переменной NAVSWHEELMODE задано значение 3.


Штурвал для 2D навигации (Краткий справочник)

Штурвалы
Штурвалы
Штурвал для объектов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвал для 2D навигации >
Штурвал для 2D навигации
Понятие Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

NAVSWHEELMODE

Задание текущего режима штурвала

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Штурвал для объектов (Понятие)

Штурвал для 2D навигации
Штурвалы
Штурвалы для зданий
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы >
Штурвал для объектов
Понятие Процедура Краткий справочник

Штурвал для объектов предназначен для 3D навигации, он включает инструмент навигации 3D орбиты. Используйте штурвал для объектов для просмотра 3D объектов.

Большой штурвал для объектов разделен на следующие сегменты:

  • Центр. Указывает точку на модели для корректировки центра текущего вида или для изменения целевой точки, используемой для некоторых инструментов навигации.
  • Зумирование. Изменение масштаба текущего вида.
  • Перемотка. Восстановление последнего вида. Можно перемещаться вперед и назад по предыдущим видам.
  • Орбита. Поворот текущего вида вокруг фиксированной точки вращения.

Мини-штурвал для объектов разделен на следующие сегменты:

  • Зумирование (верхний сегмент). Изменение масштаба текущего вида.
  • Перемотка (правый сегмент). Восстановление последнего вида. Можно перемещаться вперед и назад по предыдущим видам.
  • Панорамирование (нижний сегмент). Изменение положения текущего вида с помощью панорамирования.
  • Орбита (левый сегмент). Поворот текущего вида вокруг фиксированной точки вращения.


Штурвал для объектов (Процедура)

Меню штурвалов
Штурвал для объектов
Штурвал для объектов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвал для объектов >
Штурвал для объектов
Понятие Процедура Краткий справочник

Переключение на большой штурвал для объектов

Переключение на мини-штурвал для объектов.


Переключение на большой штурвал для объектов (Процедура)

Штурвал для объектов
Штурвал для объектов
Штурвал для объектов
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвал для объектов >
Штурвал для объектов
Понятие Процедура Краткий справочник

Переключение на большой штурвал для объектов

  • Щелкните штурвал правой кнопкой мыши и выберите "Основные штурвалы" [image] "Штурвал для объектов".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Переключение на мини-штурвал для объектов. (Процедура)

Штурвал для объектов
Штурвал для объектов
Штурвалы для зданий
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвал для объектов >
Штурвал для объектов
Понятие Процедура Краткий справочник

Переключение на мини-штурвал для объектов.

  • Щелкните штурвал правой кнопкой мыши и выберите "Мини-штурвал для объектов".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Штурвал для объектов (Краткий справочник)

Штурвал для 2D навигации
Штурвалы
Штурвалы для зданий
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвал для объектов >
Штурвал для объектов
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

NAVSWHEELMODE

Задание текущего режима штурвала

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Штурвалы для зданий (Понятие)

Штурвал для объектов
Штурвалы
Суперштурвал
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы >
Штурвалы для зданий
Понятие Процедура Краткий справочник

Штурвалы для зданий предназначены для 3D навигации. Штурвалы для зданий используются для навигации внутри модели.

Большой штурвал для зданий разделен на следующие сегменты:

  • Вперед. Корректировка расстояния между текущей точкой зрения и заданной точкой вращения модели.
  • Осмотр. Поворот текущего вида.
  • Перемотка. Восстановление последнего вида. Можно перемещаться вперед и назад по предыдущим видам.
  • Вверх/Вниз. Перемещение текущего вида модели вдоль оси Y на экране.

Мини-штурвал для зданий разделен на следующие сегменты:

  • Обход (верхний сегмент). Моделирование обхода модели.
  • Перемотка (правый сегмент). Восстановление последнего вида. Можно перемещаться вперед и назад по предыдущим видам.
  • Вверх/Вниз (нижний сегмент). Перемещение текущего вида модели вдоль оси Y на экране.
  • Осмотр (левый сегмент). Поворот текущего вида.


Штурвалы для зданий (Процедура)

Штурвал для объектов
Штурвалы для зданий
Штурвалы для зданий
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвалы для зданий >
Штурвалы для зданий
Понятие Процедура Краткий справочник

Переключение на большой штурвал для зданий

Переключение на мини-штурвал для зданий


Переключение на большой штурвал для зданий (Процедура)

Штурвалы для зданий
Штурвалы для зданий
Штурвалы для зданий
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвалы для зданий >
Штурвалы для зданий
Понятие Процедура Краткий справочник

Переключение на большой штурвал для зданий

  • Щелкните штурвал правой кнопкой мыши и выберите "Основные штурвалы" [image] "Штурвал для зданий".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Переключение на мини-штурвал для зданий (Процедура)

Штурвалы для зданий
Штурвалы для зданий
Суперштурвал
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвалы для зданий >
Штурвалы для зданий
Понятие Процедура Краткий справочник

Переключение на мини-штурвал для зданий

  • Щелкните штурвал правой кнопкой мыши и выберите "Мини-штурвал для зданий".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Штурвалы для зданий (Краткий справочник)

Штурвал для объектов
Штурвалы
Суперштурвал
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Штурвалы для зданий >
Штурвалы для зданий
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

NAVSWHEELMODE

Задание текущего режима штурвала

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Суперштурвал (Понятие)

Штурвалы для зданий
Штурвалы
Инструменты навигации
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы >
Суперштурвал
Понятие Процедура Краткий справочник

Суперштурвал объединяет инструменты 2D и 3D навигации штурвалов для объектов и зданий.

Большой суперштурвал разделен на следующие сегменты:

  • Зумирование. Изменение масштаба текущего вида.
  • Перемотка. Восстановление последнего вида. Можно перемещаться вперед и назад по предыдущим видам.
  • Панорамирование. Изменение положения текущего вида с помощью панорамирования.
  • Орбита. Поворот текущего вида вокруг фиксированной точки вращения.
  • Центр. Указывает точку на модели для корректировки центра текущего вида или для изменения целевой точки, используемой для некоторых инструментов навигации.
  • Обход. Моделирование обхода модели.
  • Осмотр. Поворот текущего вида.
  • Вверх/Вниз. Перемещение текущего вида модели вдоль оси Y на экране.

Мини-суперштурвал разделен на следующие сегменты:

  • Зумирование (верхний сегмент). Изменение масштаба текущего вида.
  • Обход (правый верхний сегмент). Моделирование обхода модели.
  • Перемотка (правый сегмент). Восстановление последнего вида. Можно перемещаться вперед и назад по предыдущим видам.
  • Вверх/Вниз (правый нижний сегмент). Перемещение текущего вида модели вдоль оси Y на экране.
  • Панорамирование (нижний сегмент). Изменение положения текущего вида с помощью панорамирования.
  • Осмотр (левый нижний сегмент). Поворот текущего вида.
  • Орбита (левый сегмент). Поворот текущего вида вокруг фиксированной точки вращения.
  • Центр (левый верхний сегмент). Указывает точку на модели для корректировки центра текущего вида или для изменения целевой точки, используемой для некоторых инструментов навигации.


Суперштурвал (Процедура)

Штурвалы для зданий
Суперштурвал
Суперштурвал
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Суперштурвал >
Суперштурвал
Понятие Процедура Краткий справочник

Переключение на большой суперштурвал

Переключение на мини-суперштурвал


Переключение на большой суперштурвал (Процедура)

Суперштурвал
Суперштурвал
Суперштурвал
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Суперштурвал >
Суперштурвал
Понятие Процедура Краткий справочник

Переключение на большой суперштурвал

  • Щелкните на штурвале правой кнопкой мыши и выберите "Суперштурвал".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Переключение на мини-суперштурвал (Процедура)

Суперштурвал
Суперштурвал
Инструмент задания центра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Суперштурвал >
Суперштурвал
Понятие Процедура Краткий справочник

Переключение на мини-суперштурвал

  • Щелкните на штурвале правой кнопкой мыши и выберите Мини-
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Суперштурвал (Краткий справочник)

Штурвалы для зданий
Штурвалы
Инструменты навигации
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Штурвалы > Суперштурвал >
Суперштурвал
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

NAVSWHEELMODE

Задание текущего режима штурвала

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструменты навигации (Понятие)

Суперштурвал
Штурвалы
Инструмент задания центра
Пользовательский интерфейс > Инструменты навигации > Штурвалы >
Инструменты навигации
Понятие Краткий справочник

Инструменты навигации изменяют текущий вид модели.

Доступность инструментов навигации зависит от текущего режима штурвала. Имеются следующие средства навигации:

  • Центр
  • Вперед
  • Осмотр
  • Орбита
  • Панорамирование
  • Перемотка
  • Вверх/Вниз
  • Обход
  • Зумирование

Темы в этом разделе

  • Инструмент задания центра

    Инструмент задания центра служит для задания точки на модели в качестве центра текущего вида. Инструмент также изменяет целевую точку для некоторых инструментов навигации.

  • Инструмент перемещения вперед

    Инструмент перемещения вперед служит для корректировки расстояния между текущей точкой зрения и заданной точкой вращения модели.

  • Инструмент осмотра

    Инструмент осмотра поворачивает вид по горизонтали и по вертикали вокруг фиксированной точки.

  • Инструмент орбиты

    Инструмент орбиты поворачивает текущий вид вокруг модели относительно фиксированной точки вращения.

  • Инструмент панорамирования

    Инструмент панорамирования служит для перемещения текущего вида модели с помощью панорамирования.

  • Инструмент перемотки

    Инструмент перемотки служит для восстановления последнего вида. Можно также перемещаться вперед и назад по предыдущим видам.

  • Инструмент перемещения вверх/вниз

    Инструмент перемещения вверх/вниз служит для перемещения текущего вида модели на экране по оси Y.

  • Инструмент обхода

    Инструмент обхода моделирует обход модели.

  • Инструмент зумирования

    Инструмент зумирования служит для изменения масштаба текущего вида модели.


Инструменты навигации (Краткий справочник)

Суперштурвал
Инструменты навигации
Инструмент задания центра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструменты навигации
Понятие Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

CAPTURETHUMBNAILS

Указание, следует ли создавать эскизы для инструмента перемотки и когда их создавать

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент задания центра (Понятие)

Инструменты навигации
Инструменты навигации
Инструмент перемещения вперед
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент задания центра
Понятие Процедура Краткий справочник

Инструмент задания центра служит для задания точки на модели в качестве центра текущего вида. Инструмент также изменяет целевую точку для некоторых инструментов навигации.

При использовании инструмента задания центра изменить местоположение центра текущего вида можно с помощью перетаскивания. При перетаскивании форма курсор изменяется на сферу, указывающую, где будет расположен новый центр модели при отпускании кнопки мыши. При отпускании кнопки мыши выполняется панорамирование модели до тех пор, пока сфера в виде не будет отцентрована, затем фокус передается в штурвал.

Центральная точка, определенная с помощью инструмента задания центра, используется для ограничения инструмента зумирования и для определения точки вращения для инструмента орбиты. Инструмент зумирования ограничен центральной точкой только при его использовании из штурвала для объектов. Если инструмент зумирования используется из суперштурвала при нажатой клавише CTRL, ограничение снимается.


Инструмент задания центра (Процедура)

Суперштурвал
Инструмент задания центра
Инструмент задания центра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент задания центра >
Инструмент задания центра
Понятие Процедура Краткий справочник

Задание точки на модели в качестве центральной точки вида

Задания точки цели для инструментов зумирования и орбиты


Задание точки на модели в качестве центральной точки вида (Процедура)

Инструмент задания центра
Инструмент задания центра
Инструмент задания центра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент задания центра >
Инструмент задания центра
Понятие Процедура Краткий справочник

Задание точки на модели в качестве центральной точки вида

  1. Откройте штурвал с инструментом задания центра.
  2. Щелкните на сегменте "Центр". Удерживая нажатой кнопку мыши, перетащите курсор на поверхность модели.
  3. Когда курсор пример форму сферы, отпустите кнопку мыши.

    Выполняется панорамирование модели до тех пор, пока сфера не будет расположена по центру.

  4. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Задания точки цели для инструментов зумирования и орбиты (Процедура)

Инструмент задания центра
Инструмент задания центра
Инструмент перемещения вперед
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент задания центра >
Инструмент задания центра
Понятие Процедура Краткий справочник

Задания точки цели для инструментов зумирования и орбиты

  1. Откройте штурвал с инструментом задания центра.
  2. Щелкните на сегменте "Центр". Удерживая нажатой кнопку мыши, перетащите курсор на поверхность модели.
  3. Когда курсор пример форму сферы, отпустите кнопку мыши.

    Выполняется панорамирование модели до тех пор, пока сфера не будет расположена по центру.

  4. Используйте инструмент зумирования или орбиты для изменения вида модели.
  5. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент задания центра (Краткий справочник)

Инструменты навигации
Инструменты навигации
Инструмент перемещения вперед
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент задания центра >
Инструмент задания центра
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент перемещения вперед (Понятие)

Инструмент задания центра
Инструменты навигации
Инструмент осмотра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент перемещения вперед
Понятие Процедура Краткий справочник

Инструмент перемещения вперед служит для корректировки расстояния между текущей точкой зрения и заданной точкой вращения модели.

Инструмент перемещения вперед позволяет изменить масштаб модели с помощью увеличения или уменьшения расстояния между текущей точкой зрения и точкой вращения. Расстояние перемещения вперед и назад ограничено положением точки вращения.

Для изменения расстояния между текущей точкой зрения и точкой вращения перетащите курсор вверх или вниз после задания точки вращения. При перетаскивании курсора текущее расстояние до точки вращения отображается в графическом элементе, называемом индикатором расстояния при перетаскивании. На индикаторе расстояния при перетаскивании имеется два маркера, показывающих начальное и конечное расстояние от текущей точки взгляда. При изменении расстояния с помощью индикатора расстояния при перетаскивании текущее расстояние показано ярко-оранжевым индикатором.


Изменение вида путем приближения или удаления от моделиLW: added a different step 1 for Revit (Display the Tour Building wheel). 1/28/08 (Процедура)

Инструмент задания центра
Инструмент перемещения вперед
Инструмент осмотра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемещения вперед >
Инструмент перемещения вперед
Понятие Процедура Краткий справочник

Изменение вида путем приближения или удаления от модели

  1. Откройте штурвал с инструментом перемещения вперед.
  2. Щелкните на сегменте "Вперед". Удерживайте нажатой кнопку мыши.
  3. При отображении индикатора расстоянии при перетаскивании для изменения расстояния от точки взгляда до модели перетащите курсов вверх или вниз.
  4. Для возврата к штурвалу отпустите кнопку мыши.
  5. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент перемещения вперед (Краткий справочник)

Инструмент задания центра
Инструменты навигации
Инструмент осмотра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемещения вперед >
Инструмент перемещения вперед
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент осмотра (Понятие)

Инструмент перемещения вперед
Инструменты навигации
Инструмент орбиты
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент осмотра
Понятие Процедура Краткий справочник

Инструмент осмотра поворачивает вид по горизонтали и по вертикали вокруг фиксированной точки.

С помощью инструмента осмотра можно поворачивать текущий вид по горизонтали или по вертикали. При повороте вида модель поворачивается вокруг фиксированной точки, определяемой центром текущего вида,. Инструмент осмотра можно сравнить с человеком, стоящим к одном положении, который смотрит вверх и вниз и при этом его поворачивают вокруг фиксированной точки.

При использовании инструмента осмотра вид модели можно изменить с помощью операции перетаскивания. При перетаскивании значок курсора изменяется на курсор осмотра, модель поворачивается вокруг местоположения текущего вида.

Обход модели

При использовании инструмента осмотра из суперштурвала можно выполнить обход модели с помощью клавиш-стрелок на клавиатуре. Скорость обхода определяется параметрами инструмента обхода. Задать скорость обхода можно в диалоговом окне "Параметры штурвала" или в меню "Штурвал" с помощью команд "Увеличить скорость обхода" и "Уменьшить скорость обхода".

Инвертировать вертикальную ось

При перетаскивании курсора вверх точка цели вида опускается, при перетаскивании курсора вниз точка цели вида поднимается. Можно задать режим подъема точки цели вида при перемещении курсора вверх и снижении точки цели вида при перемещении курсора вниз. Инвертировать вертикальную ось для инструмента осмотра можно в диалоговом окне "Параметры штурвалов".


Инструмент осмотра (Процедура)

Инструмент перемещения вперед
Инструмент осмотра
Инструмент осмотра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент осмотра >
Инструмент осмотра
Понятие Процедура Краткий справочник

Осмотр вида

Осмотр вида и обход модели

Инвертирование вертикальной оси для инструмента осмотра


Осмотр вида (Процедура)

Инструмент осмотра
Инструмент осмотра
Инструмент осмотра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент осмотра >
Инструмент осмотра
Понятие Процедура Краткий справочник

Осмотр вида

  1. Откройте штурвал с инструментом осмотра.
  2. Щелкните сегмент "Осмотр". Удерживайте нажатой кнопку мыши.
  3. При отображении курсора осмотра для изменения направления взгляда перетаскивайте курсор вверх, вниз, влево и вправо.
  4. Для возврата к штурвалу отпустите кнопку мыши.
  5. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Осмотр вида и обход модели (Процедура)

Инструмент осмотра
Инструмент осмотра
Инструмент осмотра
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент осмотра >
Инструмент осмотра
Понятие Процедура Краткий справочник

Осмотр вида и обход модели

  1. Откройте суперштурвал.
  2. Щелкните сегмент "Осмотр". Удерживайте нажатой кнопку мыши.
  3. При отображении курсора осмотра для изменения направления взгляда перетаскивайте курсор вверх, вниз, влево и вправо.
  4. Удерживая нажатой кнопку мыши, для обхода модели используйте клавиши-стрелки.
  5. Для возврата к штурвалу отпустите кнопку мыши.
  6. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инвертирование вертикальной оси для инструмента осмотра (Процедура)

Инструмент осмотра
Инструмент осмотра
Инструмент орбиты
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент осмотра >
Инструмент осмотра
Понятие Процедура Краткий справочник

Инвертирование вертикальной оси для инструмента осмотра

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" установите флажок "Инвертировать вертикальную ось для инструмента осмотра".

    При перетаскивании курсора вниз точка цели вида поднимается; при перетаскивании курсора вверх точка цели вида опускается.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент осмотра (Краткий справочник)

Инструмент перемещения вперед
Инструменты навигации
Инструмент орбиты
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент осмотра >
Инструмент осмотра
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент орбиты (Понятие)

Инструмент осмотра
Инструменты навигации
Инструмент панорамирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент орбиты
Понятие Процедура Краткий справочник

Инструмент орбиты поворачивает текущий вид вокруг модели относительно фиксированной точки вращения.

Инструмент орбиты используется для изменения ориентации модели. Курсор принимает форму курсора орбиты. При перетаскивании курсора модель поворачивается относительно точки вращения, вид при этом остается фиксированным.

Задание точки вращения

Точка вращения представляет собой базовую точку, используемую при повороте модели с помощью инструмента орбиты. Задать точку вращения можно различными способами:

  • Точка вращения по умолчанию. При первом открытии модели в качестве точки вращения для инструмента орбиты используется точка цели текущего вида.
  • Выбрать объекты.При включенной чувствительности выбора для вычисления точки вращения выбрать объекты до использования инструмента орбиты. Точка вращения вычисляется на основе центра для границ выбранных объектов.
  • Инструмент задания центра. Можно задать точку на модели для использования в качестве точки вращения с помощью инструмента задания центра для перемещения с помощью инструмента орбиты.

Сохранить направление вверх

Можно контролировать вращение модели по орбите вокруг точки вращения с помощью установки флажка "Сохранить направление вверх". Если направление вверх сохраняется, перемещение по орбите ограничивается осью XY и направлением Z. При перетаскивании курсора по горизонтали камера перемещается параллельно плоскости XY. При перемещении курсора вертикально камера перемещается вдоль оси Z. Для контроля сохранения направления вверх для инструмента орбиты используется диалоговое окно "Параметры штурвалов"


Инструмент орбиты (Процедура)

Инструмент осмотра
Инструмент орбиты
Инструмент орбиты
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент орбиты >
Инструмент орбиты
Понятие Процедура Краткий справочник

Перемещение по орбите вокруг центра вида

Перемещение по орбите вокруг объекта

Включение чувствительности выбора для инструмента орбиты

Сохранение направления вверх для инструмента орбиты


Перемещение по орбите вокруг центра вида (Процедура)

Инструмент орбиты
Инструмент орбиты
Инструмент орбиты
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент орбиты >
Инструмент орбиты
Понятие Процедура Краткий справочник

Перемещение по орбите вокруг центра вида

  1. Откройте штурвал с инструментом орбиты.
  2. Щелкните сегмент "Орбита". Удерживайте нажатой кнопку мыши.
  3. Когда курсор примет форму курсора орбиты, перетаскивайте его для поворота модели.
    ПримечаниеПри необходимости для изменения части модели, которая не отображается в центре вида, воспользуйтесь инструментом задания центра.
  4. Для возврата к штурвалу отпустите кнопку мыши.
  5. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Перемещение по орбите вокруг объекта (Процедура)

Инструмент орбиты
Инструмент орбиты
Инструмент орбиты
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент орбиты >
Инструмент орбиты
Понятие Процедура Краткий справочник

Перемещение по орбите вокруг объекта

  1. Нажмите клавишу ESC для отключения всех активных команд и снятия выделения.
  2. Выберите объекты в модели, по которым требуется определить точку вращения.
  3. Откройте штурвал с инструментом орбиты.
  4. Щелкните сегмент "Орбита". Удерживайте нажатой кнопку мыши.
  5. Когда курсор примет форму курсора орбиты, перетаскивайте его для поворота модели.
  6. Для возврата к штурвалу отпустите кнопку мыши.
  7. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Включение чувствительности выбора для инструмента орбиты (Процедура)

Инструмент орбиты
Инструмент орбиты
Инструмент орбиты
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент орбиты >
Инструмент орбиты
Понятие Процедура Краткий справочник

Включение чувствительности выбора для инструмента орбиты

  1. Откройте штурвал с инструментом орбиты.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" установите флажок "Использовать чувствительность выбора для инструмента орбиты".

    Для определения точки вращения для инструмента орбиты используются границы объектов, выбранных до отображения штурвала. Если объекты не были выбраны, в качестве точки вращения для инструмента орбиты используется точка, заданная инструментов задания центра.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Сохранение направления вверх для инструмента орбиты (Процедура)

Инструмент орбиты
Инструмент орбиты
Инструмент панорамирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент орбиты >
Инструмент орбиты
Понятие Процедура Краткий справочник

Сохранение направления вверх для инструмента орбиты

  1. Откройте штурвал с инструментом орбиты.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" установите для инструмента орбиты флажок "Сохранить направление вверх".

    Перемещение по орбите вокруг модели ограничено плоскостью XY и направлением Z.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент орбиты (Краткий справочник)

Инструмент осмотра
Инструменты навигации
Инструмент панорамирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент орбиты >
Инструмент орбиты
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент панорамирования (Понятие)

Инструмент орбиты
Инструменты навигации
Инструмент перемотки
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент панорамирования
Понятие Процедура Краткий справочник

Инструмент панорамирования служит для перемещения текущего вида модели с помощью панорамирования.

При активном инструменте панорамирования курсор принимает форму четырехсторонней стрелки. При перетаскивании курсора модель перемещается в том же направлении. Например, при перетаскивании курсора вверх модель перемещается вверх, при перетаскивании вниз - модель перемещается вниз.

СоветЕсли курсор достигает границы экрана, можно продолжить панорамирование перетаскивая курсор далее.


Панорамирование вида с помощью инструмента панорамирования (Процедура)

Инструмент орбиты
Инструмент панорамирования
Инструмент перемотки
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент панорамирования >
Инструмент панорамирования
Понятие Процедура Краткий справочник

Панорамирование вида с помощью инструмента панорамирования

  1. Откройте штурвал с инструментом панорамирования.
  2. Щелкните сегмент "Панорамирование". Удерживайте нажатой кнопку мыши, перетащите модель.
  3. Для возврата к штурвалу отпустите кнопку мыши.
  4. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент панорамирования (Краткий справочник)

Инструмент орбиты
Инструменты навигации
Инструмент перемотки
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент панорамирования >
Инструмент панорамирования
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент перемотки (Понятие)

Инструмент панорамирования
Инструменты навигации
Инструмент перемещения вверх/вниз
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент перемотки
Понятие Процедура Краткий справочник

Инструмент перемотки служит для восстановления последнего вида. Можно также перемещаться вперед и назад по предыдущим видам.

При панорамировании, зумировании, перемещении по орбите или при использовании одного из других инструментов навигации для изменения вида модели предыдущий вид сохраняется в журнале навигации. Журнал навигации содержит представление предыдущих видов модели, а также их образцы. Отдельный журнал навигации ведется для каждого окна модели открытого в AutoCAD; после закрытия модели журнал не сохраняется.

Для запуска анимации нажмите стрелку "Воспроизведение".

С помощью инструмента перемотки можно просмотреть журнал навигации модели. Можно восстановить предыдущий вид или перейти к любому из видов, сохраненных в журнале навигации.

При удерживании нажатой кнопки мыши на инструменте перемотки на штурвале открывается диалоговое окно перемотки. Можно просматривать журнал навигации. Для восстановления одного из предыдущих видов в журнале навигации перетащите скобки влево в окне перемотки.

При изменении вида предыдущий вид записывается в журнал навигации. Если изменение вида выполнено с помощью штурвала, автоматически создается образец для просмотра, который добавляется в окно перемотки. Для изменений видов, сделанных не с помощью штурвала, образцы для просмотра создаются только в том случае, если системной переменной CAPTURETHUMBNAILS задано значение 2. Созданием образцов для просмотра изменений вида можно управлять в диалоговом окне "Параметры штурвалов".


Инструмент перемотки (Процедура)

Инструмент панорамирования
Инструмент перемотки
Инструмент перемотки
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемотки >
Инструмент перемотки
Понятие Процедура Краткий справочник

Восстановление предыдущего вида

Восстановление предыдущего вида с помощью окна перемотки

Задание отображения образцов для просмотра перемотки


Восстановление предыдущего вида (Процедура)

Инструмент перемотки
Инструмент перемотки
Инструмент перемотки
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемотки >
Инструмент перемотки
Понятие Процедура Краткий справочник

Восстановление предыдущего вида

  1. Вызовите штурвал.
  2. Щелкните сегмент "Перемотка".
  3. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Восстановление предыдущего вида с помощью окна перемотки (Процедура)

Инструмент перемотки
Инструмент перемотки
Инструмент перемотки
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемотки >
Инструмент перемотки
Понятие Процедура Краткий справочник

Восстановление предыдущего вида с помощью окна перемотки

  1. Вызовите штурвал.
  2. Щелкните сегмент "Перемотка". Удерживайте нажатой кнопку мыши.

    Открывается окно перемотки.

  3. Удерживая нажатой кнопку мыши, для восстановления предыдущего вида перетащите курсор влево или вправо.

    При перетаскивании курсора влево восстанавливается более старый вид. При перетаскивании курсора вправо выполняется переход к более поздним видам. Текущее положение в журнале навигации указано оранжевым прямоугольником, который можно перетаскивать в окне перемотки.

  4. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Задание отображения образцов для просмотра перемотки (Процедура)

Инструмент перемотки
Инструмент перемотки
Инструмент перемещения вверх/вниз
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемотки >
Инструмент перемотки
Понятие Процедура Краткий справочник

Задание отображения образцов для просмотра перемотки

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" выберите один из следующих параметров:
    • Никогда - Отображение образцов для просмотра только для изменений видов, выполненных с помощью штурвалов.
    • По запросу, если рамка перемещается над пустым кадром - Отображение образцов для просмотра по запросу для предыдущего изменения вида при использовании окна перемотки.
    • Автоматически при изменении вида - Отображение образцов для просмотра для всех изменений видов, сохраненных в журнале навигации.
  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент перемотки (Краткий справочник)

Инструмент панорамирования
Инструменты навигации
Инструмент перемещения вверх/вниз
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемотки >
Инструмент перемотки
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

CAPTURETHUMBNAILS

Указание, следует ли создавать эскизы для инструмента перемотки и когда их создавать

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент перемещения вверх/вниз (Понятие)

Инструмент перемотки
Инструменты навигации
Инструмент обхода
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент перемещения вверх/вниз
Понятие Процедура Краткий справочник

Инструмент перемещения вверх/вниз служит для перемещения текущего вида модели на экране по оси Y.

В отличие от инструмента панорамирования инструмент перемещения вверх/вниз незначительно искажает модель, поскольку точка зрения перемещается по оси Y экрана. Перемещение вида вверх или вниз. Инструмент перемещения вверх/вниз можно рассматривать как взгляд в фиксированном направлении при подъеме в стеклянном лифте.

Для изменения текущего уровня взгляда по вертикали перетащите курсов вверх или вниз. При перетаскивании текущий уровень и диапазон перемещения отображаются в графическом элементе, называемом индикатором расстояния по вертикали. На индикаторе расстояния по вертикали имеются два маркера, показывающие максимальный верхний (верх) и максимальный нижний (низ) уровень вида. При изменении уровня вида с помощью индикатора расстояния по вертикали текущий уровень отображается ярко-оранжевым индикаторов, предыдущий уровень - тусклым оранжевым индикатором.


Изменение уровня вида (Процедура)

Инструмент перемотки
Инструмент перемещения вверх/вниз
Инструмент обхода
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемещения вверх/вниз >
Инструмент перемещения вверх/вниз
Понятие Процедура Краткий справочник

Изменение уровня вида

  1. Откройте штурвал с инструментом перемещения вверх/вниз.
  2. Щелкните сегмент "Вверх/Вниз". Удерживайте нажатой кнопку мыши.
  3. После отображения индикатора расстояния по вертикали перетащите курсор вверх или вниз для изменения уровня вида.
  4. Для возврата к штурвалу отпустите кнопку мыши.
  5. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент перемещения вверх/вниз (Краткий справочник)

Инструмент перемотки
Инструменты навигации
Инструмент обхода
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент перемещения вверх/вниз >
Инструмент перемещения вверх/вниз
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент обхода (Понятие)

Инструмент перемещения вверх/вниз
Инструменты навигации
Инструмент зумирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент обхода
Понятие Процедура Краткий справочник

Инструмент обхода моделирует обход модели.

Инструмент обхода позволяет выполнить навигацию в модели. После активации инструмента обхода рядом с центром вида отображается значок центральной окружности, курсор принимает форму стрелок. Для обхода модели перетаскивайте курсор в направлении перемещения.

Ограничение угла обхода

При обходе модели угол перемещения можно ограничить нулевой плоскостью. Если установлен флажок "Ограничить угол обхода нулевой плоскостью" можно свободно перемещать курсор, текущий вид будет перемещаться только параллельно нулевой плоскости. Если угол обхода не ограничен, вы будете как бы "летать" в направлении взгляда. Ограничить угол перемещения нулевой плоскостью можно в диалоговом окне "Параметры штурвалов".

Скорость перемещения

При обходе или "облете" модели можно управлять скоростью перемещения. Скорость перемещения задается расстоянием, на которое курсов смещается от значка центральной окружности. Задать скорость перемещения можно в диалоговом окне "Параметры штурвала" или в меню "Штурвал" с помощью команд "Увеличить скорость обхода" и "Уменьшить скорость обхода".

Изменение уровня вида

При использовании инструмента обхода изменить уровень вида можно при нажатой клавише SHIFT. При этом выполняется временное переключение на инструмент перемещения вверх/вниз. Для изменения текущего уровня вида модели перетащите курсор вверх или вниз.


Инструмент обхода (Процедура)

Инструмент перемещения вверх/вниз
Инструмент обхода
Инструмент обхода
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент обхода >
Инструмент обхода
Понятие Процедура Краткий справочник

Использование инструмента обхода для перемещения по модели

Изменение скорости перемещения для инструмента обхода

Ограничение угла обхода нулевой плоскостью


Использование инструмента обхода для перемещения по модели (Процедура)

Инструмент обхода
Инструмент обхода
Инструмент обхода
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент обхода >
Инструмент обхода
Понятие Процедура Краткий справочник

Использование инструмента обхода для перемещения по модели

  1. Откройте штурвал с инструментом обхода.
  2. Щелкните сегмент "Обход". Удерживайте нажатой кнопку мыши.
  3. При отображении значка центральной окружности перетащите курсов в направлении обхода.
  4. Для возврата к штурвалу отпустите кнопку мыши.
  5. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Изменение скорости перемещения для инструмента обхода (Процедура)

Инструмент обхода
Инструмент обхода
Инструмент обхода
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент обхода >
Инструмент обхода
Понятие Процедура Краткий справочник

Изменение скорости перемещения для инструмента обхода

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Инструмент обхода" перетащите регулятор "Скорость обхода" влево для уменьшения скорости обхода или вправо для увеличения скорости обхода.

    Или можно задать скорость обхода в диапазоне от 0,1 и 10 в текстовом поле, расположенном справа от регулятора "Скорость обхода".

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Ограничение угла обхода нулевой плоскостью (Процедура)

Инструмент обхода
Инструмент обхода
Инструмент зумирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент обхода >
Инструмент обхода
Понятие Процедура Краткий справочник

Ограничение угла обхода нулевой плоскостью

  1. Вызовите штурвал.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Инструмент обхода" установите флажок "Ограничить нулевой плоскостью".

    Перемещение при обходе выполняется параллельно нулевой плоскости модели.

  4. Нажмите "ОК".
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент обхода (Краткий справочник)

Инструмент перемещения вверх/вниз
Инструменты навигации
Инструмент зумирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент обхода >
Инструмент обхода
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Инструмент зумирования (Понятие)

Инструмент обхода
Инструменты навигации
ShowMotion ("Аниматор движения")
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации >
Инструмент зумирования
Понятие Процедура Краткий справочник

Инструмент зумирования служит для изменения масштаба текущего вида модели.

Инструмент зумирования позволяет изменять масштаб модели следующим образом:

  • Щелчок. Если щелкнуть инструмент зумирования на штурвале, масштаб текущего вида увеличивается на 25%. Если используется суперштурвал, в диалоговом окне "Параметры штурвалов" должен быть установлен флажок "Разрешить инкрементное зумирование по одному щелчку".
  • SHIFT + щелчок. Если удерживать нажатой клавишу SHIFT при щелчке на инструменте зумирования на штурвале, масштаб текущего вида уменьшается на 25 процентов.
  • CTRL + щелчок. Если удерживать нажатой клавишу CTRL при щелчке на инструменте зумирования на штурвале, масштаб текущего вида увеличивается на 25 процентов.
  • Щелчок и перетаскивание. Если выбрать инструмент зумирования и удержать нажатой кнопку мыши, можно изменить масштаб модели при перетаскивании курсора вверх или вниз.

Ограничения зумирования

При изменении масштаба модели с помощью инструмента зумирования невозможно сделать модель больше точки фокуса или менее границ модели. Направление увеличения и уменьшения управляется центральной точкой, заданной с помощью инструмента задания центра.

ПримечаниеВ отличие от инструмента зумирования в штурвалах для объектов инструмент зумирования в суперштурвалах не имеет ограничений.


Инструмент зумирования (Процедура)

Инструмент обхода
Инструмент зумирования
Инструмент зумирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент зумирования >
Инструмент зумирования
Понятие Процедура Краткий справочник

Зумирование вида по одному щелчку

Увеличение и уменьшение вида с помощью перетаскивания

Переключение зумирования по одному щелчку для штурвалов


Зумирование вида по одному щелчку (Процедура)

Инструмент зумирования
Инструмент зумирования
Инструмент зумирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент зумирования >
Инструмент зумирования
Понятие Процедура Краткий справочник

Зумирование вида по одному щелчку

  1. Убедитесь, что установлен флажок "Разрешить инкрементное зумирование по одному щелчку". Если флажок не установлен, то выполните следующие действия:
    • Откройте суперштурвал.
    • Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
    • В диалоговом окне "Параметры штурвалов" в области "Инструмент зумирования" установите флажок "Разрешить инкрементное зумирование по одному щелчку".
    • Нажмите "ОК".
  2. Откройте штурвал с инструментом зумирования.
  3. Щелкните сегмент "Зумирование".

    Масштаб модели увеличивается, модель становится более крупной. Если при щелчке сегмента "Зумирование" удерживать нажатой клавишу SHIFT, масштаб модели уменьшается, для увеличения масштаба модели удерживайте нажатой клавишу CTRL.

  4. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Увеличение и уменьшение вида с помощью перетаскивания (Процедура)

Инструмент зумирования
Инструмент зумирования
Инструмент зумирования
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент зумирования >
Инструмент зумирования
Понятие Процедура Краткий справочник

Увеличение и уменьшение вида с помощью перетаскивания

  1. Откройте штурвал.
  2. Щелкните сегмент "Зумирование". Удерживайте нажатой кнопку мыши и перемещайте курсор вертикально для увеличения и уменьшения.
  3. Для возврата к штурвалу отпустите кнопку мыши.
  4. Нажмите "Закрыть" для закрытия штурвала.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Переключение зумирования по одному щелчку для штурвалов (Процедура)

Инструмент зумирования
Инструмент зумирования
ShowMotion ("Аниматор движения")
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент зумирования >
Инструмент зумирования
Понятие Процедура Краткий справочник

Переключение зумирования по одному щелчку для штурвалов

  1. Откройте штурвал с инструментом зумирования.
  2. Щелкните на штурвале правой кнопкой мыши и выберите "Параметры.
  3. В диалоговом окне "Параметры штурвалов" в области "Инструмент зумирования" установите флажок "Разрешить инкрементное зумирование по одному щелчку".

    Если установлен флажок "Разрешить инкрементное зумирование по одному щелчку", масштаб модели увеличивается при щелчке на сегменте "Зумирование".

  4. Нажмите "ОК".
ПримечаниеСнятие этого флажка для инструмента зумирования действует только для суперштурвалов.
Ввод команды: НАВШТУРВАЛ
Лента:Вкладка "Исходный вид" [image] панель "Вид" [image] Штурвалы. Нет на ленте.
Меню: "Вид" [image] "Штурвалы"Пункт отсутствует в меню.


Инструмент зумирования (Краткий справочник)

Инструмент обхода
Инструменты навигации
Краткий обзор Аниматора движения
Пользовательский интерфейс > Инструменты навигации > Штурвалы > Инструменты навигации > Инструмент зумирования >
Инструмент зумирования
Понятие Процедура Краткий справочник

Команды

НАВШТУРВАЛ

Отображение штурвала

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


ShowMotion ("Аниматор движения")

Инструмент зумирования
Инструменты навигации
Краткий обзор Аниматора движения
Пользовательский интерфейс > Инструменты навигации >
ShowMotion ("Аниматор движения")
Понятие Процедура

Аниматор движения можно использовать для создания и воспроизведения анимационных роликов, созданных с помощью камеры. Эти ролики можно использовать для презентаций и для навигации в рамках проекта.

Темы в этом разделе

  • Краткий обзор Аниматора движения

    Имеется возможность записать несколько видов, называемых снимками, которые затем можно менять местами или располагать последовательно. Каждый тип уникален.

  • Создание и редактирование анимированных видов

    Анимированные виды можно изменить с помощью образцов.

  • Воспроизведение снимка посредством Аниматора движения

    С помощью элементов управления, имеющихся на каждом образце, можно просматривать отдельные снимки или их последовательности.


ShowMotion ("Аниматор движения") (Процедура)

Инструмент зумирования
ShowMotion ("Аниматор движения")
Краткий обзор Аниматора движения
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") >
ShowMotion ("Аниматор движения")
Понятие Процедура

Чтобы запустить Аниматор движения

Чтобы создать снимок типа "Статический"

Чтобы создать снимок типа "Запись обхода"

Чтобы создать кинематографический снимок

Чтобы изменить снимок

Для воспроизведения снимка

Для воспроизведения всех снимков данной категории видов

Для повтора воспроизведения снимка


Краткий обзор Аниматора движения (Понятие)

ShowMotion ("Аниматор движения")
ShowMotion ("Аниматор движения")
Создание и редактирование анимированных видов
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") >
Краткий обзор Аниматора движения
Понятие Процедура Краткий справочник

Имеется возможность записать несколько видов, называемых снимками, которые затем можно менять местами или располагать последовательно. Каждый тип уникален.

С помощью Аниматора движения можно имитировать движение и переходы к фиксированным положениям камеры, похожим на кадры телевизионной рекламы. Эти анимированные виды называются снимками. Существует три вида снимков. Типы снимков:

  • Статический: эти снимки состоят из одного сохраненного положения камеры.
  • Кинематографический: в этих снимках используется одно положение камеры и добавляется ее кинематографическое движение.
  • Запись обхода: эти снимки можно выбирать и перетаскивать вдоль желаемой траектории анимации.

Снимки можно группировать, формируя последовательности. Эти последовательности называются категориями видов.


Чтобы запустить Аниматор движения (Процедура)

ShowMotion ("Аниматор движения")
На уровень вверх ..
Создание и редактирование анимированных видов
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Краткий обзор Аниматора движения >
Краткий обзор Аниматора движения
Понятие Процедура Краткий справочник

Чтобы запустить Аниматор движения

  • Выберите меню "Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Краткий обзор Аниматора движения (Краткий справочник)

Инструмент зумирования
Краткий обзор Аниматора движения
Создание и редактирование анимированных видов
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Краткий обзор Аниматора движения >
Краткий обзор Аниматора движения
Понятие Процедура Краткий справочник

Команды

НАВПОКАЗДВИЖЕНИЕ

Вызов диалогового окна ShowMotion (Аниматор движения)

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и редактирование анимированных видов (Понятие)

Краткий обзор Аниматора движения
ShowMotion ("Аниматор движения")
Воспроизведение снимка посредством Аниматора движения
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") >
Создание и редактирование анимированных видов
Понятие Процедура Краткий справочник

Анимированные виды можно изменить с помощью образцов.

Образцы снимков

При создании снимку присваевается имя и образец. Их повторная фиксация может быть произведена в любой момент. Имена снимков отображаются в чертеже под соответствующими образцами.

Для удаления снимка нажмите правую кнопку мыши на его образце и выберите "Удалить". Удаленный снимок не может быть восстановлен.

Образцы категорий видов

При создании категории видов ей присваивается имя и образец. Имена категорий видов отображаются в чертеже под соответствующием образцами. Каждый образец категории видов идентичен образцу первого вида в категории.

Порядок снимков внутри категории видов можно изменять. Нажмите правую кнопку мыши на образце, который необходимо переместить. Для изменения порядка следования снимков выберите перемещение влево или вправо.

Чтобы удалить категорию видов и содержащиеся в ней снимки, нажмите правую кнопку мыши на образце этой категории и выберите "Удалить". Удаленная категория видов не может быть восстановлена.


Создание и редактирование анимированных видов (Процедура)

Краткий обзор Аниматора движения
На уровень вверх ..
Создание и редактирование анимированных видов
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Создание и редактирование анимированных видов >
Создание и редактирование анимированных видов
Понятие Процедура Краткий справочник

Чтобы создать снимок типа "Статический"

Чтобы создать снимок типа "Запись обхода"

Чтобы создать кинематографический снимок

Чтобы изменить снимок


Чтобы создать снимок типа "Статический" (Процедура)

Создание и редактирование анимированных видов
На уровень вверх ..
Создание и редактирование анимированных видов
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Создание и редактирование анимированных видов >
Создание и редактирование анимированных видов
Понятие Процедура Краткий справочник

Чтобы создать снимок типа "Статический"

  1. Выберите меню"Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
  2. В диалоговом окне "Новый вид / Свойства снимка" в поле имени вида введите имя.
  3. Выберите категорию видов в соответствующем раскрывающемся списке.
  4. Выберите тип снимка в соответствующем раскрывающемся списке.
  5. Перейдите на вкладку "Свойства снимка".
  6. В области "Переход" в раскрывающемся списке "Тип перехода" выберите тип перехода.
  7. В области "Переход" выберите значение длительности перехода.
  8. Нажмите "ОК". На экране появится новый образец снимка.
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Чтобы создать снимок типа "Запись обхода" (Процедура)

Создание и редактирование анимированных видов
На уровень вверх ..
Создание и редактирование анимированных видов
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Создание и редактирование анимированных видов >
Создание и редактирование анимированных видов
Понятие Процедура Краткий справочник

Чтобы создать снимок типа "Запись обхода"

  1. Выберите меню"Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
  2. В диалоговом окне "Новый вид / Свойства снимка" в поле имени вида введите имя.
  3. Выберите категорию видов в соответствующем раскрывающемся списке.
  4. В раскрывающемся списке "Тип вида" выберите "Запись обхода".
  5. Перейдите на вкладку "Свойства снимка".
  6. В области "Переход" в раскрывающемся списке "Тип перехода" выберите тип перехода.
  7. В области "Переход" выберите значение длительности перехода.
  8. В области "Движение" нажмите кнопку "Начать запись".
  9. Нажмите "3D полотно" и перетащите указатель мыши вдоль желаемой траектории анимации. Чтобы остановить запись, отпустите кнопку мыши.
  10. Нажмите "ОК". На экране появится новый образец снимка.
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Чтобы создать кинематографический снимок (Процедура)

Создание и редактирование анимированных видов
На уровень вверх ..
Создание и редактирование анимированных видов
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Создание и редактирование анимированных видов >
Создание и редактирование анимированных видов
Понятие Процедура Краткий справочник

Чтобы создать кинематографический снимок

  1. Выберите меню"Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
  2. В диалоговом окне "Новый вид / Свойства снимка" в поле имени вида введите имя.
  3. Выберите категорию видов в соответствующем раскрывающемся списке.
  4. В раскрывающемся списке "Тип вида" выберите "Кинематографический".
  5. Перейдите на вкладку "Свойства снимка".
  6. В области "Переход" в раскрывающемся списке "Тип перехода" выберите тип перехода.
  7. В области "Переход" выберите значение длительности перехода.
  8. Задайте положение камеры.
  9. Задайте длительность снимка.
  10. Задайте расстояние для камеры.
  11. Нажмите "ОК". На экране появится новый образец снимка.
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Чтобы изменить снимок (Процедура)

Создание и редактирование анимированных видов
На уровень вверх ..
Воспроизведение снимка посредством Аниматора движения
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Создание и редактирование анимированных видов >
Создание и редактирование анимированных видов
Понятие Процедура Краткий справочник

Чтобы изменить снимок

  1. Выберите меню"Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
  2. Щелкните мышью на пустом кадре справа от снимка. Откроется диалоговое окно "Вид / Свойства снимка".
  3. В диалоговом окне "Вид / Свойства снимка" в поле имени вида введите имя снимка, который необходимо изменить.
  4. На вкладке "Свойства снимка" измените необходимые настройки. Набор доступных параметров изменяется в зависимости от выбранного типа снимка. При изменении типа снимка изменятся и эти параметры.
  5. На вкладке "Свойства снимка" в области "Движение" нажмите кнопку "Просмотр". Проверьте результаты изменения снимка. Если результаты неудовлетворительны, внесите дополнительные изменения.
  6. Нажмите "ОК".
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Создание и редактирование анимированных видов (Краткий справочник)

Краткий обзор Аниматора движения
Создание и редактирование анимированных видов
Воспроизведение снимка посредством Аниматора движения
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Создание и редактирование анимированных видов >
Создание и редактирование анимированных видов
Понятие Процедура Краткий справочник

Команды

НАВПОКАЗДВИЖЕНИЕ

Вызов диалогового окна ShowMotion (Аниматор движения)

НОВСНИМОК

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Воспроизведение снимка посредством Аниматора движения (Понятие)

Создание и редактирование анимированных видов
ShowMotion ("Аниматор движения")
Адаптация рабочей среды
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") >
Воспроизведение снимка посредством Аниматора движения
Понятие Процедура Краткий справочник

С помощью элементов управления, имеющихся на каждом образце, можно просматривать отдельные снимки или их последовательности.

Когда снимок создан в Аниматоре движения, просмотреть его несложно. Элементы управления просмотром имеются на каждом образце. Они включают:

  • Кнопка "Воспроизвести" позволяет воспроизводить снимки и категории снимков. Когда курсор наведен на какой-либо образец, в центре этого образца появляется кнопка "Воспроизвести".
  • Во время воспроизведения кнопку "Воспроизвести" сменяет кнопка "Пауза". Для приостановки воспроизведения нажмите кнопку "Пауза". Если воспроизведение приостановлено, кнопку "Пауза" сменяет кнопка "Воспроизвести".
  • Кнопка "Переход вида" позволяет в процессе редактирования снимков или категорий снимков перемещать камеру в ключевые положения. Когда курсор наведен на образец какой-либо категории видов, в правом верхнем углу этого образца отображается кнопка "Переход вида". Чтобы переместить камеру в ключевое положение первого снимка в данной категории, нажмите кнопку "Переход вида". Ключевые положения определяются настройкой параметра "Текущее использование камеры" на вкладке "Свойства снимка".


Воспроизведение снимка посредством Аниматора движения (Процедура)

Создание и редактирование анимированных видов
На уровень вверх ..
Воспроизведение снимка посредством Аниматора движения
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Воспроизведение снимка посредством Аниматора движения >
Воспроизведение снимка посредством Аниматора движения
Понятие Процедура Краткий справочник

Для воспроизведения снимка

Для воспроизведения всех снимков данной категории видов

Для повтора воспроизведения снимка


Для воспроизведения снимка (Процедура)

Воспроизведение снимка посредством Аниматора движения
На уровень вверх ..
Воспроизведение снимка посредством Аниматора движения
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Воспроизведение снимка посредством Аниматора движения >
Воспроизведение снимка посредством Аниматора движения
Понятие Процедура Краткий справочник

Для воспроизведения снимка

  1. Выберите меню"Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
  2. Перетащите курсор к тому образцу снимка, который необходимо просмотреть.
  3. На образце снимка нажмите кнопку "Воспроизвести", которая расположена в верхней части образца слева. Будет воспроизведен только выбранный снимок.
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Для воспроизведения всех снимков данной категории видов (Процедура)

Воспроизведение снимка посредством Аниматора движения
На уровень вверх ..
Воспроизведение снимка посредством Аниматора движения
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Воспроизведение снимка посредством Аниматора движения >
Воспроизведение снимка посредством Аниматора движения
Понятие Процедура Краткий справочник

Для воспроизведения всех снимков данной категории видов

  1. Выберите меню"Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
  2. Перетащите курсор к образцу категории видов, которую необходимо просмотреть.
  3. На этом образце нажмите кнопку "Воспроизвести", которая расположена в левом верхнем углу образца. Будут воспроизведены все снимки данной категории видов.
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Для повтора воспроизведения снимка (Процедура)

Воспроизведение снимка посредством Аниматора движения
На уровень вверх ..
Задание параметров интерфейса
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Воспроизведение снимка посредством Аниматора движения >
Воспроизведение снимка посредством Аниматора движения
Понятие Процедура Краткий справочник

Для повтора воспроизведения снимка

  1. Выберите меню"Вид" [image] "Аниматор движения"В командной строке введите "навпоказдвижение".
  2. В области заголовка образца нажмите "Повтор".
ПримечаниеЕсли функция повтора включена, воспроизведение снимка будет повторяться до нажатия кнопки "Остановить" или клавиши ESC.
Ввод команды: НАВПОКАЗДВИЖЕНИЕ


Воспроизведение снимка посредством Аниматора движения (Краткий справочник)

Создание и редактирование анимированных видов
Воспроизведение снимка посредством Аниматора движения
Задание параметров интерфейса
Пользовательский интерфейс > Инструменты навигации > ShowMotion ("Аниматор движения") > Воспроизведение снимка посредством Аниматора движения >
Воспроизведение снимка посредством Аниматора движения
Понятие Процедура Краткий справочник

Команды

НАВПОКАЗДВИЖЕНИЕ

Вызов диалогового окна ShowMotion (Аниматор движения)

КВИДУ

Восстановление именованного вида

ВИДЗАПУСК

Воспроизведение анимации, связанной с именованным видом

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Адаптация рабочей среды

Воспроизведение снимка посредством Аниматора движения
Пользовательский интерфейс
Задание параметров интерфейса
Пользовательский интерфейс >
Адаптация рабочей среды

Различные элементы рабочей среды могут быть адаптированы под нужды пользователя.

Темы в этом разделе

  • Задание параметров интерфейса

    Пользователь может настраивать интерфейс приложения в соответствии с характером работы.

  • Создание рабочего пространства для конкретной задачи

    Рабочие пространства представляют собой наборы меню, панелей, палитр и панелей управления ленты, сгруппированных и упорядоченных для работы в пользовательской, задачно-ориентированной среде чертежа.

  • Сохранение и восстановление параметров интерфейса (профилей)

    В профилях хранятся параметры среды рисования. Можно создать профили для разных пользователей или проектов и организовать их совместное использование посредством импорта и экспорта их в виде файлов.

  • Адаптация запуска

    Индивидуальную процедуру запуска программы для каждого проекта можно настроить с помощью аргументов командной строки.


Задание параметров интерфейса (Понятие)

Адаптация рабочей среды
Адаптация рабочей среды
Создание рабочего пространства для конкретной задачи
Пользовательский интерфейс > Адаптация рабочей среды >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Пользователь может настраивать интерфейс приложения в соответствии с характером работы.

Доступ ко различным настройкам обеспечивается контекстными меню и диалоговым окном "Настройка". Некоторые элементы рабочего пространства, такие как вид и положение панелей и палитр, задаются и сохраняются с помощью диалогового окна "Адаптация интерфейса пользователя".

Настройка области построения чертежа

Некоторые параметры определяют способ работы в области черчения:

  • Цветовая схема (диалоговое окно "Настройка", вкладка "Экран", кнопка "Цвета"). Для всего пользовательского интерфейса задается темная или светлая цветовая схема. Параметры влияют на фон рамки окна, строку состояния, строку заголовка, рамку обозревателя меню, панели инструментов и палитры.
  • Цвет фона (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Можно задать цвета фона для использования в пространстве модели, на листах и в редакторе блоков. Цвета фона на вкладке "Модель" меняются, указывая на вариант работы с проектом: 2D моделирование, 3D моделирование с параллельным проецированием или 3D моделирование с перспективным проецированием.
  • Значок ПСК и курсор в виде перекрестия (диалоговое окно "Настройка", вкладка "3D моделирование"). Можно указать, что опции 3D отображения и метки для знака ПСК могут быть заданы во вкладке "3D моделирование" диалогового окна "Настройка".
  • Назначение цвета для осей X, Y, и Z (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). На 3D видах в любых элементах интерфейса, связанных с X-, Y- и Z-осью ПСК, используются специальные назначения цвета. Оси X назначается красный цвет или оттенок, ось Y имеет зеленый, а ось Z - синий цвет или оттенок. Включение и отключение использования этих оттенков выполняется в диалоговом окне "Цветовая гамма окна чертежа".
  • Очистить экран. Для отображения только строки меню, строки состояния и окна команд можно расширить область отображения чертежа с помощью кнопки "Очистить экран", находящейся в строке состояния приложения. Нажмите кнопку "Очистить экран" ещё раз, чтобы восстановить предыдущий вид.
  • Просмотр переходов. При панорамировании, зумировании или смены одного вида на другой (команда ПАРАМЕТРЫПВ) можно задавать характер перехода: плавный или мгновенный. По умолчанию используется плавный переход.
  • Всплывающие подсказки. Предусмотрено несколько типов всплывающих подсказок для отображения информации о работе с панелями инструментов, объектной привязке и операциях построения. Подсказки видны на панелях инструментов, в обозревателе меню, на ленте и в диалоговых окнах. Первоначально показывается основная подсказка. Если продолжать наводить указатель мыши, подсказка развернется для отображения дополнительной информации. Вид и содержимое подсказки можно настроить. Дополнительные сведения о настройке отображения подсказок см. на вкладке "Экран" (диалогового окна "Настройка"). Для настраиваемых команд можно также создать дополнительные подсказки. Дополнительные сведения о настройке подсказок для команд см. в разделе Создание всплывающих подсказок и дополнительной справки для команд. Дополнительные сведения о настройке подсказок ролловеров см. в разделе Настройка подсказок для ролловеров.

    Для запуска анимации нажмите стрелку "Воспроизведение".

3D моделирование с перспективным проецированием

  • Нулевая плоскость (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Если включено перспективное проецирование, плоскость ПСК XY отображается в виде нулевой плоскости с градиентным цветом. На нулевой плоскости отображается градиент от опущенного дальнего плана до опущенного ближнего плана.
  • Цвет неба (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Область, не покрытая нулевой плоскостью, является небом, на котором отображается градиентный цвет от дальнего плана неба до ближнего плана неба.
  • Поднятая нулевая плоскость(диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Если нулевая плоскость рассматривается снизу, на ней отображается градиент от поднятого дальнего плана до поднятого ближнего плана.
  • Сетка нулевой плоскости (диалоговое окно "Настройка", вкладка "Экран", "Цвета"). Если перспективное проецирование включено, сетка отображается в виде сетки нулевой плоскости. Цвета задаются для линий основной сетки, линий малой сетки и линий осей.

Переключение между режимами "Пространство модели" и "Листы"

Пользователь имеет возможность переключения между пространством модели и одной или несколькими разметками листа. Классический интерфейс содержит вкладку "Модель" и одну или несколько вкладок разметки листа. Для оптимального использования области рисования можно отключить эти вкладки и пользоваться эквивалентными кнопками в строке состояния. Элемент управления для переключения между двумя вариантами интерфейса включён одним из пунктов в контекстное меню вкладок "Модель" и "Разметки листа", а также в контекстное меню кнопки "Модель/Разметка листа" в строке состояния.

ПримечаниеДоступ ко всем опциям контекстного меню возможен только из вкладок.

Задание шрифтов приложения

  • Шрифт (диалоговое окно "Настройка", вкладка "Экран"). Изменение шрифтов, используемых в окне приложения и в текстовом окне. Данная настройка не влияет на отображение текста внутри чертежа.

Управление отображением закрепляемых окон

Закрепляемыми являются многие окна, включая палитру "Свойства", палитру инструментов и Центр управления. Это означает, что их можно закреплять, прикреплять якорями или откреплять.

Изменения настроек для этих и других режимов обычно выполняются в контекстном меню, открывающемся нажатием правой кнопки на заголовке палитры или окна.

  • Изменение размера Чтобы изменить размер окна, перетащите кромку панели. Если окно разделено на области, то для изменения их размера перетаскивается разделитель областей.
  • Разрешить закрепление. Выберите этот вариант, если требуется закрепить или прикрепить якорем окно. Закреплённое окно присоединяется к одной стороне окна приложения, приводя к необходимости изменения размеров области рисования.
  • Закрепление якорем. Закрепление или прикрепление якорем окна или палитры к левой или правой стороне области рисования. Прикрепляемое якорем окно сворачивается и разворачивается, когда его пересекает курсор. Когда прикрепленное якорем окно открыто, его содержимое перекрывает область рисования. Не существует настройки, позволяющей держать открытым прикрепленное якорем окно. Перед тем как прикрепить якорем окно, необходимо выбрать режим "Разрешить закрепление").
  • Автоскрытие. Плавающее окно открывается и закрывается по мере перемещения по нему курсора. Если этот режим отменён, окно всё время остаётся открытым. Закрепленные окна с функцией автоматического скрытия отображаются в виде строки внутри приложения.
  • Прозрачность. Устанавливает степень прозрачности для окна и для режима наведения указателя мыши на объект. Окно становится прозрачным, и через него видны находящиеся под ним объекты. Окно становится более непрозрачным, когда на него наводится указатель мыши. Этот параметр доступен не для всех окон.

Можно скрыть все палитры сразу при помощи СКРЫТЬПАЛИТРЫ и вывести все палитры, которые были скрыты, при помощи ПОКАЗАТЬПАЛИТРЫ. Если одна из палитр уже была включена вручную и перемещена, то команда ПОКАЗАТЬПАЛИТРЫ на нее не действует.

Управление отображением панелей

Чтобы отобразить или скрыть панели инструментов, нажмите правую кнопку мыши на любой из панелей инструментов для отображения их списка. Если после имени панели инструментов стоит флажок, панель отображается. Нажмите на имени панели в списке, чтобы установить или снять флажок.

Панель инструментов может быть плавающей или закрепленной. Закрепленные панели примыкают к одному из краев области рисования. Панель, закрепленная на верхнем краю области чертежа, расположена под лентой. Открепите панель, нажав кнопку мыши на ручке переноса (двойная полоса) и перетащив её в область рисования. Нажав кнопку мыши на заголовке, можно переместить панель или закрепить её. Измените размер плавающей панели инструментов, перетащив мышью кромку панели.

Фиксация местоположения панелей инструментов и закрепляемых окон

После того как панели упорядочены и окна закреплены, назначены плавающими или привязаны нужным образом, можно зафиксировать их положение. Зафиксированные панели инструментов и окна могут оставаться открытыми и закрытыми, к ним можно добавлять элементы или удалять их. Чтобы временно их разблокировать, удерживайте нажатой клавишу CTRL.

См. также

    • Вкладка "Экран" (диалоговое окно "Настройка") в справочнике команд

    • Адаптация интерфейса пользователя в документе Руководство по адаптации

    • Настройка подсказок для ролловеров в документе Руководство по адаптации

    • Создание всплывающих подсказок и дополнительной справки для команд в документе Руководство по адаптации


Задание параметров интерфейса (Процедура)

Воспроизведение снимка посредством Аниматора движения
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Настройка параметров

Для адаптации цветов элементов окна приложения

Перевод вкладок "Модель" и "Лист" в кнопки строки состояния

Включение режима использования вкладок "Модель" и "Лист"

Изменение шрифта в окне команд

Фиксация положения и размеров панелей инструментов и закрепляемых окон

Привязка закрепляемого окна

Перевод привязанного окна в плавающее

Изменение вида базовой точки значка якоря

Закрепление окна или палитры

Открепление окна или палитры

Включение и отключение режима "Авто-скрытие" для плавающей палитры или окна.

Изменение вида окна "Просмотр переходов"

Включение и отключение подсказок

Отображение скрытых диалоговых окон с сообщениями


Настройка параметров (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Настройка параметров

  1. Выбрать меню "Сервис" [image] "Настройка".В командной строке введите НАСТРОЙКА.
  2. В диалоговом окне "Настройка" выберите нужную вкладку.
  3. Настройте параметры, как это требуется для работы.
  4. Выполните одно или оба следующих действия:
    • Нажмите кнопку "Применить" для сохранения текущих настроек в системном реестре.
    • Нажмите кнопку "OK" для сохранения текущих настроек в системном реестре и закрытия диалогового окна "Настройка".
Ввод команды: НАСТРОЙКА


Для адаптации цветов элементов окна приложения (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Для адаптации цветов элементов окна приложения

  1. Выбрать меню "Сервис" [image] "Настройка".В командной строке введите НАСТРОЙКА.
  2. На вкладке "Экран" диалогового окна "Настройка" выберите "Цвета".
  3. В диалоговом окне "Цветовая гамма окна чертежа" выберите контекст, а затем элемент интерфейса, который нужно изменить.
  4. Выберите нужный цвет в списке "Цвета".

    Для задания пользовательского цвета выберите параметр "Выбор цвета..." из списка цветов.

  5. Если требуется заменить цвета на цвета по умолчанию, выберите "Восстановить текущий элемент", "Восстановить текущий контекст" или "Восстановить все контексты"
  6. Нажмите кнопки "Применить" и "Закрыть" для сохранения текущих настроек в системном реестре и закрытия диалогового окна.
  7. Нажмите кнопку "OK", чтобы закрыть диалоговое окно "Настройка".
Ввод команды: НАСТРОЙКА


Перевод вкладок "Модель" и "Лист" в кнопки строки состояния (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Перевод вкладок "Модель" и "Лист" в кнопки строки состояния

  • Нажмите правую кнопку мыши на вкладке модели или вкладке листа. Выберите опцию "Скрыть вкладки разметки листа и модели".


Включение режима использования вкладок "Модель" и "Лист" (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Включение режима использования вкладок "Модель" и "Лист"

  • На строке состояния щелкните правой кнопкой мыши кнопку "Модель" или "Лист". Выберите в контекстном меню пункт "Показывать вкладки 'Лист' и 'Модель'".


Изменение шрифта в окне команд (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Изменение шрифта в окне команд

  1. Выбрать меню "Сервис" [image] "Настройка".В командной строке введите НАСТРОЙКА.
  2. На вкладке "Экран" диалогового окна "Настройка" нажмите кнопку "Шрифты", находящуюся под элементами окна.
  3. В диалоговом окне "Шрифт командной строки" выберите подходящий шрифт, начертание и размер.

    Образец текущих настроек отображается под заголовком "Образец шрифта командной строки".

  4. Нажмите кнопки "Применить" и "Закрыть" для сохранения текущих настроек в системном реестре и закрытия диалогового окна.
  5. Нажмите кнопку "OK", чтобы закрыть диалоговое окно "Настройка".
Ввод команды: НАСТРОЙКА


Фиксация положения и размеров панелей инструментов и закрепляемых окон (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Фиксация положения и размеров панелей инструментов и закрепляемых окон

  • Выполнить одно из следующих действий:
    • Выбрать меню "Окно" [image] "Место фиксации" [image] "Плавающие панели инструментов".В командной строке введите lockui.
    • Выбрать меню "Окно" [image] "Место фиксации" [image] "Закрепленные панели инструментов".В командной строке введите lockui.
    • Выбрать меню "Окно" [image] "Место фиксации" [image] "Плавающие окна".В командной строке введите lockui.
    • Выбрать меню "Окно" [image] "Место фиксации" [image] "Закрепленные окна".В командной строке введите lockui.
    • Выбрать меню "Окно" [image] "Место фиксации" [image] "Все" [image] "Заблокировать".В командной строке введите lockui.

Значок фиксации в области уведомлений указывает, зафиксированы ли панели инструментов или закрепляемые окна. Для временной отмены их фиксации нужно удерживать нажатой клавишу CTRL.

Ввод команды: LOCKUI
Контекстное меню:Нажмите правую кнопку мыши на значке фиксации в панели задач. Установите флажок рядом с одним или несколькими параметрами или выберите "Все" [image] "Заблокировать".


Привязка закрепляемого окна (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Привязка закрепляемого окна

  1. Нажмите правую кнопку мыши на плавающем окне или заголовке палитры. Выберите "Разрешить закрепление".
  2. Нажмите правую кнопку мыши на окне или заголовке палитры. Выберите "Прикрепить якорем справа" или "Прикрепить якорем слева".


Перевод привязанного окна в плавающее (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Перевод привязанного окна в плавающее

Выполните одно из следующих действий:

  • Если привязанное окно открыто, оттащите заголовок окна от базовой точки значка якоря.
  • Нажмите дважды на значке якоря.
  • Правую кнопку мыши нажмите на заголовке окна. Снимите флажок "Разрешить закрепление".

Окно отделяется от соответствующей стороны области рисования.


Изменение вида базовой точки значка якоря (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Изменение вида базовой точки значка якоря

Выполните одно из следующих действий:

  • Для представления привязанных окон в виде значка нажмите правую кнопку мыши на базовой точке значка якоря. Выберите "Только значки".
  • Для отображения как значка, так и текста для заякоренных окон, нажмите правую кнопку мыши на базовой точке значка якоря. Выберите "Значок и текст".


Закрепление окна или палитры (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Закрепление окна или палитры

  1. Нажмите правую кнопку мыши на плавающем окне или заголовке палитры. Убедитесь в том, что выбран режим "Разрешить закрепление".
  2. Поместите курсор на заголовок и удерживайте левую кнопку устройства указания.
  3. Перетащите окно или палитру в место закрепления в правой или левой стороне области рисования.
  4. Когда контур окна отобразится в области закрепления, отпустите кнопку.
    ПримечаниеДля помещения панели в область закрепления без выполнения закрепления нужно во время перетаскивания удерживать нажатой клавишу CTRL.


Открепление окна или палитры (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Открепление окна или палитры

Воспользуйтесь одним из следующих способов:

  • Дважды нажмите кнопку мыши на ручке переноса (двойная полоса) вверху или внизу окна.
  • Поместите курсор на ручке переноса вверху или внизу окна, удерживайте левую кнопку устройства указания и перетащите окно из места закрепления.


Включение и отключение режима "Авто-скрытие" для плавающей палитры или окна. (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Включение и отключение режима "Авто-скрытие" для плавающей палитры или окна.

Выполните одно из следующих действий:

  • Нажмите правую кнопку мыши на плавающей палитре или окне. Выберите "Авто-скрытие".
  • На заголовке плавающей палитры или окна нажмите кнопку "Авто-скрытие".

    Если выбран режим "Авто-скрытие", плавающие окна разворачиваются и сворачиваются при пересечении их курсором. Если этот режим отменён, постоянно отображается полностью открытое окно.

    ПримечаниеЭта процедура применима к инструментальной палитре, Центру управления, палитре свойств и нескольким другим палитрам.


Изменение вида окна "Просмотр переходов" (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Изменение вида окна "Просмотр переходов"

  1. В командной строке введите параметрыпв.
  2. В диалоговом окне "Просмотр переходов" выберите один или несколько параметров из числа указанных ниже.
    • Включить анимацию для перемещения и увеличения. Включается плавный переход из одного вида в другой при панорамировании и увеличении.
    • Включить анимацию при повороте вида. Включается плавный переход при изменении угла обзора.
    • Включить анимацию во время сценариев. Включается плавный переход во время выполнения сценариев.
  3. Задайте скорость перехода, перемещая ползунок.
  4. Чтобы производительность не уменьшилась, установите для отображения плавной смены вида минимальную частоту кадров в секунду. Если отображение плавных переходов не поддерживает эту скорость, используется мгновенный переход.
  5. Нажмите "ОК".


Включение и отключение подсказок (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Задание параметров интерфейса
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Включение и отключение подсказок

  1. Выбрать меню "Сервис" [image] "Настройка".В командной строке введите команду "настройка".
  2. На вкладке "Экран" диалогового окна "Настройка" щелкните пункт "Всплывающие подсказки", находящийся в группе "Элементы окна".
  3. Нажмите "ОК".


Отображение скрытых диалоговых окон с сообщениями (Процедура)

Задание параметров интерфейса
Задание параметров интерфейса
Создание рабочего пространства для конкретной задачи
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Отображение скрытых диалоговых окон с сообщениями

  1. Выбрать меню "Сервис" [image] "Настройка".В командной строке введите НАСТРОЙКА.
  2. В диалоговом окне "Настройка" на вкладке "Система" в группе "Общие параметры" нажмите кнопку "Параметры скрытых сообщений".
  3. Отобразится диалоговое окно "Параметры скрытых сообщений".
  4. Пометьте галочкой имя соответствующего диалогового окна из каталога дерева.
  5. Нажмите "ОК".


Задание параметров интерфейса (Краткий справочник)

Воспроизведение снимка посредством Аниматора движения
Задание параметров интерфейса
Создание рабочего пространства для конкретной задачи
Пользовательский интерфейс > Адаптация рабочей среды > Задание параметров интерфейса >
Задание параметров интерфейса
Понятие Процедура Краткий справочник

Команды

ГРАФНАСТР

Настройка параметров трехмерной графики

ЧИСТЭКРВКЛ

Убирает с экрана панели инструментов и закрепляемые окна (за исключением командной строки)

ЧИСТЭКРОТКЛ

Восстанавливает отображение панели инструментов и закрепляемых окон (за исключением командной строки)

СЛЕДИТЬ

Управление отображением объектов при перетаскивании

СКРЫТЬПАЛИТРЫ

Скрытие отображаемых палитр (включая командную строку)

ЖУРНАЛОТКЛ

Закрытие текстового окна файла журнала, открытого командой ЖУРНАЛВКЛ

ЖУРНАЛВКЛ

Включение записи содержимого текстового окна в файл

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

REVDATE

Вставка или обновление блока штемпеля, содержащего имя пользователя, текущую дату и текущее время, а также имя чертежа

ПОКАЗАТЬПАЛИТРЫ

Восстановление отображения скрытых палитр

НАСТРВИД

Задание точности аппроксимации объектов на текущем видовом экране

ПАРАМЕТРЫПВ

Отображение изменения в виде плавного перехода

Системные переменные

АAPERTURE

Установка размера прицела объектной привязки, в пикселах

CALCINPUT

Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных

CLEANSCREENSTATE

Признак включения или отключения состояния очистки экрана

CURSORSIZE

Определение размера перекрестья в процентном отношении от размера экрана

DCTCUST

Отображение пути и имени файла текущего пользовательского орфографического словаря

DCTMAIN

Отображение трехбуквенного ключевого слова для текущего основного орфографического словаря

DEFPLSTYLE

Определение стиля печати по умолчанию для новых объектов в чертеже при открытии чертежа, созданного в версиях, предшествующих AutoCAD 2000, или при создании нового чертежа без использования шаблонов

DRAGMODE

Управление отображением объектов при перетаскивании

EXEDIR

Отображение имени папки исполняемого файла AutoCAD LT

EXTNAMES

Задание параметров для имен именованных объектов (например, типов линий и слоев), которые хранятся в таблицах описаний

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

GRIPBLOCK

Управление ручками внутри блоков

GRIPCOLOR

Управление цветом невыбранных ручек

GRIPHOT

Управление цветом выбранных ручек

GRIPS

Управление использованием ручек набора объектов при их растягивании, перемещении, повороте, масштабировании и зеркальном отображении

INSUNITS

Значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок

INSUNITSDEFSOURCE

Задание единиц измерения исходного содержимого, когда переменная INSUNITS имеет значение равное 0

INSUNITSDEFTARGET

Задание единиц измерения в целевом чертеже, когда переменная INSUNITS имеет значение равное 0

INTELLIGENTUPDATE

Управление скоростью обновления графики

ISAVEBAK

Повышает скорость сохранения, особенно для больших чертежей

ISAVEPERCENT

Количество неиспользуемого дискового пространства, допустимого в файле чертежа

LAYOUTREGENCTL

Задание режима обновления списка отображения на вкладке "Модель" и вкладках "Лист"

LOCALE

Код языка (по ISO) текущей версии AutoCAD

LOCALROOTPREFIX

Полный путь к корневой папке, в которую были установлены локальные адаптируемые файлы

LOCKUI

Фиксация положения и размера панелей инструментов и плавающих окон, таких как Центр управления и "Палитра свойств"

LOGFILEMODE

Признак записи содержимого текстового окна в файл журнала

LOGFILENAME

Путь и имя файла журнала текстового окна для текущего чертежа

LOGFILEPATH

Путь к файлам журналов текстового окна для всех чертежей в сеансе

MTEXTED

Задание приложения для редактирования многострочных текстовых объектов

OLEQUALITY

Значение по умолчанию для качества печати объектов OLE

OLESTARTUP

Управление загрузкой исходного приложения, в котором был создан внедренный OLE объект, для его печати

OSNAPCOORD

Управление приоритетом ввода координат с клавиатуры над текущими режимами привязки

PAPERUPDATE

Управление выводом диалогового окна предупреждения при попытке вывести на печать лист, формат которого не совпадает с форматом, заданным по умолчанию в файле параметров плоттера

PALETTEOPAQUE

Управление прозрачностью окон

PICKADD

Управление дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)

PICKAUTO

Управление автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты"

PICKBOX

Размер прицела выбора объектов (в пикселах)

PICKDRAG

Управление способом создания рамки выбора

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

PICKSTYLE

Управление выбором групп и ассоциативной штриховки

PSTYLEPOLICY

Управление режимом стилей печати (цветозависимый или именованный), используемым при открытии чертежа, созданного в версиях, предшествующих AutoCAD 2000, или при создании нового чертежа без использования шаблонов

QTEXTMODE

Управление отображением текста

RASTERPREVIEW

Управление сохранением образцов для просмотра в формате BMP вместе с чертежом

ROLLOVERTIPS

Управление отображением подсказок ролловеров в приложении

SAVEFILE

Имя текущего файла автоматического сохранения

SAVEFILEPATH

Путь к папке всех файлов автоматического сохранения для текущего сеанса

SAVETIME

Интервал автоматического сохранения (в минутах)

SPLINESEGS

Количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД

TDUSRTIMER

Значение счетчика времени работы пользователя

TOOLTIPMERGE

Объединение подсказок на чертеже в одну подсказку

TOOLTIPS

Управление отображением подсказок в инструментальных панелях

USERNAME

Имя пользователя

VISRETAIN

Управление свойствами слоев, зависящих от внешних ссылок

VTDURATION

Длительность плавного перехода видов в миллисекундах

VTENABLE

Управление использованием плавной смены вида

VTFPS

Минимальная скорость плавного перехода видов в кадрах в секунду

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание рабочего пространства для конкретной задачи (Понятие)

Задание параметров интерфейса
Адаптация рабочей среды
Сохранение и восстановление параметров интерфейса (профилей)
Пользовательский интерфейс > Адаптация рабочей среды >
Создание рабочего пространства для конкретной задачи
Понятие Процедура Краткий справочник

Рабочие пространства представляют собой наборы меню, панелей, палитр и панелей управления ленты, сгруппированных и упорядоченных для работы в пользовательской, задачно-ориентированной среде чертежа.

При использовании рабочего пространства отображаются только необходимые для конкретной задачи меню, инструментальные панели и палитры. Кроме того, рабочее пространство может автоматически отображать ленту, специальную палитру с панелями управления, специализированными под решение определенных задач.

Дополнительные сведения об использовании ленты см. в раделе Лента.

Предусмотрено удобное переключение между рабочими пространствами. В программном продукте заранее определены следующие рабочие пространства, ориентированные на конкретную задачу:

  • 2D рисование и аннотации
  • 3D моделирование
  • Классический AutoCAD

Например, при создании 3D моделей можно использовать рабочее пространство "3D моделирование", содержащее только ориентированные на работу с 3D объектами инструментальные панели, меню и палитры. Элементы интерфейса, не являющиеся необходимыми для 3D моделирования, скрываются, максимально освобождая область экрана, доступную для работы.

Для запуска анимации нажмите стрелку "Воспроизведение".

После того, как в область построения чертежа внесены изменения (например перемещены, скрыты, отображены панели инструментов или группы палитр) и требуется сохранить настройки отображения для последующего использования, можно сохранить текущие параметры рабочего пространства.

Переключение рабочих пространств

С помощью значка "Рабочее пространство" [image] на строке состояния можно в любой момент переключиться в другое рабочее пространство, когда требуется работать над другой задачей.

Для запуска анимации нажмите стрелку "Воспроизведение".

Создание и изменение рабочих пространств

Предусмотрена возможность создания собственных рабочих пространств и изменение рабочих пространств по умолчанию. Для создания или изменения рабочего пространства применяется любой из следующих способов:

  • Выведите на экран, уберите с экрана и переупорядочите инструментальные панели и окна, измените настройки ленты, затем сохраните текущее рабочее пространство с помощью значка "Рабочие пространства" на строке состояния, из панели "Рабочие пространства" или из меню "Окно" либо с помощью команды РАБОЧЕЕПРОСТРАНСТВО.
  • Для более обширных изменений откройте диалоговое окно "Адаптация интерфейса пользователя".

В диалоговом окне "Параметры рабочего пространства" предусмотрена возможность управления порядком отображения сохранённых рабочих пространств и других настроек.

ПримечаниеДля получения подробной информации о создании или редактировании рабочих пространств и о том, как панели инструментов и меню взаимодействуют с рабочими пространствами, см. Настройка рабочего пространства в Руководстве по адаптации.

Выберите "Образец рабочего пространства"

Поэкспериментируйте с образцом рабочего пространства, входящего в программный продукт. Это стандартное рабочее пространство иллюстрирует возможность использования рабочего пространства для ускорения работы.

Образец рабочего пространства находится в:

C:\Documents and Settings\<имя пользователя>\Application Data\Autodesk\AutoCAD 2009\R17.2\<язык пользовательского интерфейса программы>\Support\acadSampleWorkspaces.CUI

Для использования образца рабочего пространства нужно сначала перенести его в главный файл адаптации (АПИ). Для получения дополнительной информации о переносе рабочего пространства см. раздел Перенос и передача адаптаций в документе Руководство по адаптации.

Рабочие пространства и профили

Рабочие пространства работают со средствами управления средой рисования, обеспечиваемыми профилями, и дополняют эти средства.

Рабочие пространства управляют отображением в области рисования меню, панелей и инструментальных палитр. При включении или переключении рабочего пространства изменяется внешний вид области построения чертежа. Управление рабочими пространствами осуществляется из диалогового окна "Адаптация интерфейса пользователя".

Профили сохраняют параметры среды, включая разные пользовательские параметры, настройки режимов рисования, пути и другие значения. Профили обновляются при каждом изменении параметра, настройки или другого значения. Управление пользовательскими профилями выполняется в диалоговом окне "Настройка".

ПримечаниеПри внесении изменений в область построения изменения сохраняются в профиле и, независимо от параметров рабочего пространства, отображаются после следующего запуска программы. Изменения профиля не будут автоматически сохраняться в рабочем пространстве до тех пор, пока в диалоговом окне "Параметры рабочего пространства" не будет выбран параметр "Автоматически сохранять изменения". Для сохранения настроек профиля в рабочем пространстве введите в командной строке РПСОХРАНИТЬ.

Дополнительную информацию о профилях см. в Сохранение и восстановление параметров интерфейса (профилей).


Создание рабочего пространства для конкретной задачи (Процедура)

Задание параметров интерфейса
Создание рабочего пространства для конкретной задачи
Создание рабочего пространства для конкретной задачи
Пользовательский интерфейс > Адаптация рабочей среды > Создание рабочего пространства для конкретной задачи >
Создание рабочего пространства для конкретной задачи
Понятие Процедура Краткий справочник

Переключение рабочих пространств

Изменение параметров рабочего пространства

Сохранение рабочего пространства


Переключение рабочих пространств (Процедура)

Создание рабочего пространства для конкретной задачи
Создание рабочего пространства для конкретной задачи
Создание рабочего пространства для конкретной задачи
Пользовательский интерфейс > Адаптация рабочей среды > Создание рабочего пространства для конкретной задачи >
Создание рабочего пространства для конкретной задачи
Понятие Процедура Краткий справочник

Переключение рабочих пространств

  1. На строке состояния щелкните "Переключение рабочих пространств" [image].
  2. Выберите из списка рабочее пространство, на которое необходимо переключиться.

    Рабочее пространство, помеченное галочкой, является текущим.

Меню: "Сервис" [image] "Рабочие пространства"
Ввод команды: РАБОЧЕЕ ПРОСТРАНСТВО


Изменение параметров рабочего пространства (Процедура)

Создание рабочего пространства для конкретной задачи
Создание рабочего пространства для конкретной задачи
Создание рабочего пространства для конкретной задачи
Пользовательский интерфейс > Адаптация рабочей среды > Создание рабочего пространства для конкретной задачи >
Создание рабочего пространства для конкретной задачи
Понятие Процедура Краткий справочник

Изменение параметров рабочего пространства

  1. На строке состояния щелкните "Переключение рабочих пространств" [image].
  2. Выберите в контекстном меню пункт "Параметры рабочего пространства".
  3. В диалоговом окне "Параметры рабочего пространства" внесите необходимые изменения в параметры.
  4. Нажмите "ОК".
Меню: "Сервис" [image] "Рабочие пространства" [image] "Параметры рабочего пространства"
Ввод команды: РАБОЧЕЕ ПРОСТРАНСТВО
Ввод команды: РППАРАМЕТРЫ


Сохранение рабочего пространства (Процедура)

Создание рабочего пространства для конкретной задачи
Создание рабочего пространства для конкретной задачи
Сохранение и восстановление параметров интерфейса (профилей)
Пользовательский интерфейс > Адаптация рабочей среды > Создание рабочего пространства для конкретной задачи >
Создание рабочего пространства для конкретной задачи
Понятие Процедура Краткий справочник

Сохранение рабочего пространства

  1. В области рисования создайте среду рисования путем перемещения, удаления или отображения тех панелей инструментов и закрепляемых окон, которые потребуются в будущем.
  2. На строке состояния щелкните "Переключение рабочих пространств" [image].
  3. Выберите в контекстном меню пункт "Параметры рабочего пространства".
  4. В диалоговом окне "Сохранить рабочее пространство" введите имя нового рабочего пространства или выберите имя из раскрывающегося списка.
  5. Нажмите кнопку "Сохранить".
Меню: "Сервис" [image] "Рабочие пространства" [image] "Сохранить текущее как"
Ввод команды: РАБОЧЕЕ ПРОСТРАНСТВО
Ввод команды: РПСОХРАНИТЬ


Создание рабочего пространства для конкретной задачи (Краткий справочник)

Задание параметров интерфейса
Создание рабочего пространства для конкретной задачи
Сохранение и восстановление параметров интерфейса (профилей)
Пользовательский интерфейс > Адаптация рабочей среды > Создание рабочего пространства для конкретной задачи >
Создание рабочего пространства для конкретной задачи
Понятие Процедура Краткий справочник

Команды

РАБОЧЕЕ ПРОСТРАНСТВО

Создание, изменение и сохранение рабочего пространства, а также назначение его текущим

РПСОХРАНИТЬ

Сохранение рабочего пространства

РППАРАМЕТРЫ

Задание параметров рабочих пространств

Системные переменные

WSCURRENT

Возврат имени текущего рабочего пространства в интерфейс командной строки и назначение этого пространства текущим

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение и восстановление параметров интерфейса (профилей) (Понятие)

Создание рабочего пространства для конкретной задачи
Адаптация рабочей среды
Адаптация запуска
Пользовательский интерфейс > Адаптация рабочей среды >
Сохранение и восстановление параметров интерфейса (профилей)
Понятие Процедура Краткий справочник

В профилях хранятся параметры среды рисования. Можно создать профили для разных пользователей или проектов и организовать их совместное использование посредством импорта и экспорта их в виде файлов.

Параметры хранятся в профилях в следующем виде:

  • Пути по умолчанию для поиска файлов и для файла проекта
  • Местоположение файла шаблона
  • Исходная папка, выбираемая в диалоговых окнах навигации к файлам
  • Файл типов линий по умолчанию и файл образцов штриховки по умолчанию
  • Настройки по умолчанию для принтера

Информация о профиле обычно задаётся на вкладке "Профили" диалогового окна "Настройка", хранится в системном реестре и может быть экспортирована в текстовый файл (файл ARG).

Применение профилей для компьютеров общего пользования или разных проектов

На вкладке "Профили" в диалоговом окне "Настройка" задайте параметры среды рисования и сохраните в качестве профиля. Различные пользователи, входящие в систему под одним именем, могут загружать свои настройки из различных профилей. Профили можно использовать также для сохранения настроек, присущих различным проектам. По умолчанию текущие параметры хранятся в профиле с именем UNNAMEDPROFILE. Имена текущего профиля и чертежа отображаются в диалоговом окне "Настройка".

Обмен профилями между компьютерами

Данные из сохраненного профиля можно экспортировать или импортировать в виде файла формата ARG на различные компьютеры. Это удобно для копирования, восстановления или стандартизации проектно-ориентированных рабочих сред по сети.

Если изменения, внесённые в текущий профиль в сеансе работы, нужно сохранить в файле формата ARG, необходимо выполнить повторный экспорт профиля. При экспорте профиля в текущий файл профиля файл ARG обновляется, и в него записываются новые параметры.

Подробнее о профилях см. описание команды НАСТРОЙКА в документе Справочник команд.


Сохранение и восстановление параметров интерфейса (профилей) (Процедура)

Создание рабочего пространства для конкретной задачи
Сохранение и восстановление параметров интерфейса (профилей)
Сохранение и восстановление параметров интерфейса (профилей)
Пользовательский интерфейс > Адаптация рабочей среды > Сохранение и восстановление параметров интерфейса (профилей) >
Сохранение и восстановление параметров интерфейса (профилей)
Понятие Процедура Краткий справочник

Назначение текущего профиля

Сохранение профиля

Назначение текущего профиля до запуска программы


Назначение текущего профиля (Процедура)

Сохранение и восстановление параметров интерфейса (профилей)
Сохранение и восстановление параметров интерфейса (профилей)
Сохранение и восстановление параметров интерфейса (профилей)
Пользовательский интерфейс > Адаптация рабочей среды > Сохранение и восстановление параметров интерфейса (профилей) >
Сохранение и восстановление параметров интерфейса (профилей)
Понятие Процедура Краткий справочник

Назначение текущего профиля

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите НАСТРОЙКА.
  2. На вкладке "Профили" диалогового окна "Настройка" выберите профиль, который нужно сделать текущим.
  3. Нажмите кнопку "Установить".
  4. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Сохранение профиля (Процедура)

Сохранение и восстановление параметров интерфейса (профилей)
Сохранение и восстановление параметров интерфейса (профилей)
Сохранение и восстановление параметров интерфейса (профилей)
Пользовательский интерфейс > Адаптация рабочей среды > Сохранение и восстановление параметров интерфейса (профилей) >
Сохранение и восстановление параметров интерфейса (профилей)
Понятие Процедура Краткий справочник

Сохранение профиля

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите НАСТРОЙКА.
  2. На вкладке "Профили" диалогового окна "Настройка" выберите "Добавить в список".
  3. В диалоговом окне "Добавление профиля" введите имя профиля и его описание.
  4. Нажмите кнопки "Применить" и "Закрыть" для сохранения текущих настроек в системном реестре и закрытия диалогового окна.
  5. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Назначение текущего профиля до запуска программы (Процедура)

Сохранение и восстановление параметров интерфейса (профилей)
Сохранение и восстановление параметров интерфейса (профилей)
Адаптация запуска
Пользовательский интерфейс > Адаптация рабочей среды > Сохранение и восстановление параметров интерфейса (профилей) >
Сохранение и восстановление параметров интерфейса (профилей)
Понятие Процедура Краткий справочник

Назначение текущего профиля до запуска программы

  1. На рабочем столе Windows нажмите правую кнопку мыши на значке программы. Выберите "Свойства".
  2. В поле "Объект" вкладки "Ярлык" диалогового окна "Свойства " программы AutoCAD после текущей целевой папки введите/p текущий профиль. Например, чтобы сделать текущим профиль User12, следует ввести в поле "Объект" следующую строку.

    "c:\Program Files\<имя текущей версии>\acad.exe"/p user12

  3. Нажмите "ОК".

    Указанный таким образом профиль будет текущим при каждом запуске программы.


Сохранение и восстановление параметров интерфейса (профилей) (Краткий справочник)

Создание рабочего пространства для конкретной задачи
Сохранение и восстановление параметров интерфейса (профилей)
Адаптация запуска
Пользовательский интерфейс > Адаптация рабочей среды > Сохранение и восстановление параметров интерфейса (профилей) >
Сохранение и восстановление параметров интерфейса (профилей)
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

CPROFILE

Отображение имени текущего профиля

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Адаптация запуска (Понятие)

Сохранение и восстановление параметров интерфейса (профилей)
Адаптация рабочей среды
Макросы операций
Пользовательский интерфейс > Адаптация рабочей среды >
Адаптация запуска
Понятие Процедура Краткий справочник

Индивидуальную процедуру запуска программы для каждого проекта можно настроить с помощью аргументов командной строки.

Параметры для запуска программы задаются с помощью аргументов командной строки. Например, можно запустить сценарий, открыть новый чертёж на основе указанного шаблона и отобразить заданный вид при открытии чертежа. При помощи аргументов командной строки можно также создать несколько ярлыков с различными параметрами запуска программы.

Переключатели командной строки - это параметры, которые можно добавлять к командной строке acad.exe, связанной со значком ярлыка Microsoft® Windows® или с диалоговым окном "Выполнить" ОС Windows. В одной командной строке может присутствовать несколько аргументов. Все допустимые аргументы перечислены ниже.

/b

Имя файла сценария

Указывает сценарий, который запускается после запуска программы (b указывает на процесс пакетной обработки). В сценариях может выполняться настройка параметров для нового чертежа. Файл должен иметь расширение SCR.

/t

Имя файла шаблона

Создаётся новый чертёж на основе шаблона или прототипа чертежа. Файл должен иметь расширение DWT.

/c

Папка конфигурации

Указывается путь к файлу конфигурации оборудования, который должен использоваться. Можно задать здесь папку или конкретное имя файла. Файл должен иметь расширение CFG.

Если переключатель /c не указан, то происходит поиск в папке самого приложения, и для определения файла конфигурации и пути к нему используются переменные среды ACADCFGW или ACADCFG.

/v

Имя вида

Задаётся вид чертежа, отображаемый при запуске.

/ld

Приложение ARX или DBX

Загружается приложение ARX или DBX. Нужно использовать следующий формат:

<путь>\<имя_файла>.ARX

Если имя файла или путь содержат пробелы, следует заключить их в двойные кавычки. Если путь не указан, для поиска используется путь к программе.

/s

Папки вспомогательных файлов

Задаются папки вспомогательных файлов, отличные от текущей. Во вспомогательных файлах хранятся текстовые шрифты, меню, AutoLISP-программы, типы линий и образцы штриховок, используемые в чертежах. Максимальное количество папок, которое можно указать в пути, равно 15. Имена папок разделяются точками с запятыми.

/r

Устройство указания по

умолчанию

Восстановление системного устройства указания, принятого по умолчанию. Создается новый файл настройки (acad2009.cfg), а предыдущий файл acad2009.cfg переименовывается в acad.bak.

/nologo

Отключение экрана с логотипом AutoCAD

Программа запускается программу без вывода экрана с логотипом.

/p

Заданный пользователем профиль реестра

профиль для запуска

программы

Задаётся определяемый пользователем профиль реестра для запуска программы. Указанный профиль действует только в текущем сеансе программы. В данном сеансе можно задать другой текущий профиль в диалоговом окне "Настройка".

Для этого в диалоговом окне "Настройка" предназначена вкладка "Профили", где можно создавать и импортировать файлы профилей. С помощью параметра /p можно задавать только профили, отображающиеся в списке диалогового окна "Настройка". Если указанный профиль не существует, используется текущий профиль.

/nohardware

Отключает аппаратное обеспечение.

ускорение

Отключает аппаратное ускорение при запуске.

/nossm

Без окна

"Диспетчер подшивок"

Подавляется вывод на экран диалогового окна "Диспетчер подшивок" при запуске программы.

/set

Подшивка

Загружается указанная подшивка при запуске программы. Нужно использовать следующий формат:

<путь>\<файл_данных_подшивки>.DST

/w

Рабочее пространство по умолчанию

Определяется, какое рабочее пространство из загруженных файлов АПИ должно быть восстановлено при запуске.

/pl

Фоновая печать/публикация

Публикуется файл описаний наборов чертежей (DSD) в фоновом режиме. Нужно использовать следующий формат:

<путь>\<файл описаний наборов чертежей>.DSD

Командная строка вызова программы с использованием аргументов выглядит следующим образом:

"дисковод:имя_пути\acad.exe" ["имячертежа"] [/переключатель "имя"]

За каждым аргументом должен следовать символ пробела, а затем - имя файла, пути или вида в кавычках. Приведённая в следующем примере командная строка запускает программу из папки AutoCAD 2009, после чего открывается шаблон arch1.dwt, при этом восстанавливается именованный вид PLAN1 и выполняется запуск файла сценария.scr.

"d:\ AutoCAD 2009\acad.exe”/t "d:\AutoCAD 2009\template\arch1" /v "plan1" /b "startup"

Параметры среды обрабатываются следующим образом:

  • Если параметр задается аргументом в командной строке, то его значение имеет приоритет перед значениями, установленными в диалоговом окне "Настройка" или с помощью переменной среды.
  • Если аргумент в командной строке не задан, используется значение соответствующего параметра диалогового окна "Настройка".
  • Если параметр не задан ни в командной строке, ни в диалоговом окне "Настройка", то используется значение соответствующей переменной среды.
ПримечаниеАргументы командной строки и переменные среды изменяют параметры, заданные с помощью диалогового окна "Настройка", только для текущего сеанса работы. Эти изменения не отражаются в системном реестре.


Запуск программы с аргументом командной строки (Процедура)

Сохранение и восстановление параметров интерфейса (профилей)
Адаптация запуска
Обзор макросов операций
Пользовательский интерфейс > Адаптация рабочей среды > Адаптация запуска >
Адаптация запуска
Понятие Процедура Краткий справочник

Запуск программы с аргументом командной строки

  1. На рабочем столе Windows нажмите правую кнопку мыши на значке программы. Выберите "Свойства".
  2. В поле "Объект " вкладки "Ярлык" диалогового окна "Свойства" программы AutoCAD измените параметры атрибута, используя следующий синтаксис.

    "дисковод:имя_пути\acad.exe" ["имя чертежа"] [/переключатель "имя"]

    Допустимы следующие аргументы:

    /b

    Имя сценария (b обозначает пакетный процесс)

    /t

    Имя файла шаблона

    /c

    Папка конфигурации

    /v

    Имя вида

    /s

    Папки вспомогательных файлов

    /r

    Стандартное системное устройство указания

    /nologo

    Отключение экрана с логотипом AutoCAD

    /nohardware

    Отключает аппаратное ускорение.

    /p

    Задаваемый пользователем профиль реестра

    /nossm

    Без диалогового окна "Диспетчер подшивок"

    /set

    Имя подшивки

    /w

    Рабочее пространство по умолчанию

    /pl

    Фоновая печать/публикация для файла описаний наборов чертежей (DSD)

    Например, введите "d:\AutoCAD 2009\acad.exe" /t "d:\AutoCAD 2009\template\arch1" /v "plan1" /b "startup"

  3. Нажмите ОК.


Адаптация запуска (Краткий справочник)

Сохранение и восстановление параметров интерфейса (профилей)
Адаптация запуска
Обзор макросов операций
Пользовательский интерфейс > Адаптация рабочей среды > Адаптация запуска >
Адаптация запуска
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Макросы операций

Адаптация запуска
Пользовательский интерфейс
Обзор макросов операций
Пользовательский интерфейс >
Макросы операций

Макросы операций можно использовать для автоматизации повторяющихся задач путем записи последовательности команд и вводимых значений.

Темы в этом разделе

  • Обзор макросов операций

    Макросы операций позволяют автоматизировать повторяющиеся задачи при отсутствии опыта программирования.

  • Работа с Рекордером операций

    Рекордер операций позволяет создавать макросы операций, которые используются для автоматического выполнения повторяющихся задач.

  • Запись макроса операций

    Рекордер операций позволяет записывать большинство команд, которые могут вызываться из командной строки и из уже известных элементов пользовательского интерфейса.

  • Изменение макроса операции

    Можно переименовать, скопировать или удалить макрос операции. Можно также изменить макрос операции с помощью удаления операций из дерева операции, добавления пользовательских сообщений и запросов значений или редактирования и изменения поведения операции.

  • Воспроизведение макроса операции

    После записи макроса операции с помощью Рекордера операций можно воспроизвести последовательность записанных команд и значений ввода.

  • Подсказки по использованию Рекордера операций

    Рекордер операций представляет собой интуитивно понятное средство и позволяет создавать пользовательские команды, способные сократить количество операций, необходимых для выполнения повторяющихся задач. При записи макроса операции необходимо учесть несколько моментов.

  • Примеры макросов операций

    В следующих примерах показаны некоторые способы автоматизации повторяющихся задач с помощью макросов операций. В примерах показаны различные способы записи операций в Рекордере операций.


Обзор макросов операций (Понятие)

Макросы операций
Макросы операций
Работа с Рекордером операций
Пользовательский интерфейс > Макросы операций >
Обзор макросов операций
Понятие Процедура Краткий справочник

Макросы операций позволяют автоматизировать повторяющиеся задачи при отсутствии опыта программирования.

Для записи макроса операций используется Рекордер операций. После записи макроса операции и команды, и данные ввода записываются в файл макроса операции с расширением ACTM.

Рекордер операций представляет собой панель на ленте и содержит инструменты записи, воспроизведения и изменения макросов операции. Задать параметры Рекордера операций также можно в диалоговом окне "Установки рекордера операций". Во время воспроизведения, редактирования или записи макроса операций можно развернуть панель Рекордера операций для доступа к отдельным операциям текущего макроса в дереве операций.

В дереве операций можно изменять и удалять узлы операций макроса операций. Узлы операций представляют записанные команды или введенные значения макроса операций. В процессе воспроизведения в узел значения также можно вставлять пользовательские сообщения и запросы значений. Узел значений в макросе операций представляет ввод данных, для которого предоставляется подсказка команды во время воспроизведения. Узлы значений могут содержать полученные точки, текстовые строки, числа, ключевые слова или другие значения, которые можно вводить при записи команды.


Изменение настроек Рекордера операций (Процедура)

Адаптация запуска
Обзор макросов операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций > Обзор макросов операций >
Обзор макросов операций
Понятие Процедура Краткий справочник

Изменение настроек Рекордера операций

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций [image] Установки.
  2. В диалоговом окне "Установки рекордера операций" выполните следующие действия:
    • Установите флажок "Развернуть при воспроизведении" для открытия панели Рекордера операций при воспроизведении макроса операции.
    • Установите флажок "Развернуть при записи" для открытия панели Рекордера операций при записи макроса операции.
    • Установите флажок "Запрос имени макроса операции" для вызова диалогового окна "Макрос операции" при остановке записи макроса. Если этот флажок не установлен, при сохранении записанному макросу операции будет присвоено имя по умолчанию.
  3. Нажмите "ОК".


Обзор макросов операций (Краткий справочник)

Адаптация запуска
Обзор макросов операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций > Обзор макросов операций >
Обзор макросов операций
Понятие Процедура Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ОПЕРСТОП

Останов работы рекордера операций и предоставление возможности сохранения записанных операций в файле макроса операции

ОПЕРПВВОД

Вставка запроса значения в макрос операции

ОПЕРПСООБЩЕНИЕ

Вставка пользовательского сообщения в макрос операции

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ЛЕНТА

Вызов окна ленты

Системные переменные

ACTPATH

Задание дополнительных путей поиска макросов операций, воспроизведение которых возможно

ACTRECORDERSTATE

Задание текущего состояния рекордера операций

ACTRECPATH

Задание пути для хранения новых макросов операций

ACTUI

Управление поведением панели рекордера операций при записи и воспроизведении макросов

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с Рекордером операций

Обзор макросов операций
Макросы операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций >
Работа с Рекордером операций

Рекордер операций позволяет создавать макросы операций, которые используются для автоматического выполнения повторяющихся задач.

Записываемые операции, команды и значения ввода регистрируются и отображаются в дереве операций. После остановки записи можно сохранить записанные команды и значения в файл макроса операций, а позднее этот файл можно будет воспроизвести. В сохраненном макросе операций можно добавить пользовательские сообщения или изменить поведение записанных значений ввода с запросом нового значения при воспроизведении.


Запись макроса операций (Понятие)

Работа с Рекордером операций
Макросы операций
Значки узла операций
Пользовательский интерфейс > Макросы операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Рекордер операций позволяет записывать большинство команд, которые могут вызываться из командной строки и из уже известных элементов пользовательского интерфейса.

Рекордер операций используется для записи команды и значений ввода в макросы операций. При записи макроса операций рядом с перекрестьем отображается красный круглый значок записи, указывающий, что Рекордер операции активен, и идет запись команд и значений ввода.

Для запуска анимации нажмите стрелку "Воспроизведение".

В файл записываются все команды и значения, вводимые в командной строке, за исключением команд открытия и закрытия файлов чертежей. Если при записи макроса операции вызывается диалоговое окно, записывается только отображение диалогового окна, но не изменения, вносимые в этом окне. При записи макросов операций рекомендуется не использовать диалоговые окна. Вместо них используйте версию команды, вызываемую из командной строки. Например, используйте команду -ШТРИХ вместо команды ШТРИХ, вызывающей диалоговое окно "Штриховка и градиент".

После завершения записи макроса операций имеется возможность сохранить или отказаться от записанного макроса. При сохранении макроса операций необходимо задать имя, а также можно добавить описание и параметры воспроизведения макроса операций. Параметры воспроизведения определяют, следует ли восстанавливать вид до воспроизведения макроса операций при запросе значения или при завершении воспроизведения.

Если Рекордер операций настроен для проверки несовместимости, выполняется сравнение параметров среды чертежа во время записи макроса операций с текущими параметрами среды. Например, Рекордер операций проверяет значение системной переменной INSUNITS в текущем чертеже и сравнивает его со значением, которое использовалось при записи макроса операций. При обнаружении несовместимости можно продолжить или остановить воспроизведение макроса операции. Если продолжить воспроизведение, выполнение макроса операций может привести к неожиданным результатам.

Использование макросов операций во время записи

Можно воспроизводить макрос операций при записи макроса операций. Можно объединить несколько макросов операций для создания нового макроса операций. Для использования существующего макроса операций при записи другого макроса макрос операции, который необходимо воспроизвести, должен находиться в одной из папок, определяемых системными переменными ACTPATH или ACTRECPATH. Если макрос операции находится по одному из заданных путей, для воспроизведения введите его имя в командной строке.

Пользовательские команды и процедуры в макросах операций

При записи команд и вводимых значений можно использовать стандартные команды из AutoCAD и уже созданные пользовательские команды. Пользовательские команды, которые можно использовать, не ограничены командами, определенными с помощью AutoLISP или ObjectARX, они также могут включать команды, определенные с помощью .NET, и макросы VBA.

Перед воспроизведением макроса операций, содержащего ссылки на пользовательские команды и макросы, необходимо загрузить в AutoCAD исходные программы, в которых были определены команды. Это необходимо для правильного воспроизведения макроса операций. Убедиться в доступности пользовательских команд при воспроизведении макроса операций можно с помощью одного из вариантов:

  • Автозагрузка - Для загрузки файлов, содержащих пользовательские команды, можно использовать функцию "Автозагрузка" в диалоговом окне "Загрузка/выгрузка приложений".
  • Файл ACAD.lsp или ACADDOC.lsp - Для автоматической загрузки файлов с пользовательскими командами можно использовать файл acad.lsp или acaddoc.lsp.
  • Файл меню AutoLISP (MNL) - Для загрузки файлов с пользовательскими командами, связанными с файлом АПИ, можно использовать файл MNL.
  • Файл адаптации пользовательского интерфейса (АПИ) - Файлы AutoLISP, определяющие пользовательские команды, можно связать с файлом АПИ, добавляя их к узлу LISP в редакторе АПИ.
  • Файлы сценариев - Для загрузки файлов AutoLISP, ObjectARX, VBA или .NET можно использовать файлы сценариев. Для записи выполнения файла сценария перед использованием команды ПАКЕТ задайте переменной FILEDIA значение 0.

Сохранение записанных макросов операций

После остановки записи можно сохранить записанный макрос операции. При сохранении записанного макроса операций имя команды, заданной для этого макроса, также используется в качестве имени файла макроса операций. Файл макроса операций сохраняется в папке, определяемой системной переменной ACTRECPATH. Изменить папку можно в диалоговом окне "Настройка".

Темы в этом разделе

  • Значки узла операций

    Если макрос операции записывается или является текущим, каждая операция в файле макроса соответствует узлу в дереве операций.

  • Элементы пользовательского интерфейса

    При записи макроса операции можно использовать многие общие элементы пользовательского интерфейса.


Запись макроса операций (Процедура)

Обзор макросов операций
Запись макроса операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Начало записи макроса операций

Остановка записи макроса операций

Отмена записи макроса операций

Копирование макроса операции для создания нового макроса операции

Изменение папки для сохранения записанных макросов операций


Начало записи макроса операций (Процедура)

Запись макроса операций
Запись макроса операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Начало записи макроса операций

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций [image] "Запись".
  2. Используйте команды и введите значения, которые необходимы для выполнения автоматизируемой задачи.
Ввод команды: ОПЕРЗАПИСЬ
Меню: "Сервис" [image] "Рекордер операций" [image] "Запись"
Контекстное меню:Щелкните правой кнопкой мыши на чертеже. Выберите "Рекордер операций" [image] "Запись".


Остановка записи макроса операций (Процедура)

Запись макроса операций
Запись макроса операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Остановка записи макроса операций

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций [image] "Остановить".
  2. В диалоговом окне "Макрос операции" введите имя в поле "Имя команды макроса операции".
  3. Дополнительно выполните следующие действия:
    • Введите описание макроса операций в текстовом поле "Описание".
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "При запросе ввода значения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "После завершения воспроизведения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • Установите флажок "Проверка несогласованности в начале воспроизведения", чтобы Рекордер операций перед воспроизведением выполнял проверку макроса операций.
  4. Нажмите "ОК".
Ввод команды: ОПЕРСТОП
Меню: "Сервис" [image] "Рекордер операций" [image] "Остановить"
Контекстное меню:Щелкните правой кнопкой мыши на чертеже. Выберите "Рекордер операций" [image] "Остановить".


Отмена записи макроса операций (Процедура)

Запись макроса операций
Запись макроса операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Отмена записи макроса операций

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций [image] "Остановить".
  2. В диалоговом окне "Макрос операции" нажмите кнопку "Отмена".
Ввод команды: ОПЕРСТОП
Меню: "Сервис" [image] "Рекордер операций" [image] "Остановить"
Контекстное меню:Щелкните правой кнопкой мыши на чертеже. Выберите "Рекордер операций" [image] "Остановить".


Копирование макроса операции для создания нового макроса операции (Процедура)

Запись макроса операций
Запись макроса операций
Запись макроса операций
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Копирование макроса операции для создания нового макроса операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции для копирования.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на верхнем узле и выберите "Копировать".
  5. В диалоговом окне "Макрос операции" введите имя в поле "Имя макроса операции".
  6. Дополнительно выполните следующие действия:
    • Введите имя команды для макроса операции в поле "Имя команды макроса операции".
    • Введите описание макроса операций в текстовом поле "Описание".
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "При запросе ввода значения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "После завершения воспроизведения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • Установите флажок "Проверка несогласованности в начале воспроизведения", чтобы Рекордер операций перед воспроизведением выполнял проверку макроса операций.
  7. Нажмите "ОК".


Изменение папки для сохранения записанных макросов операций (Процедура)

Запись макроса операций
Запись макроса операций
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Изменение папки для сохранения записанных макросов операций

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите настройка.
  2. В диалоговом окне "Настройка" откройте вкладку "Файлы" и в списке узлов щелкните на значке "плюс" (+) рядом с элементом "Параметры Рекордера операций".
  3. Щелкните на значке "плюс" (+) рядом с элементом "Местоположение файла записи операций" и укажите путь к папке.
  4. Нажмите "ОК".
Ввод команды: НАСТРОЙКА
Контекстное меню:Щелкните правой кнопкой мыши на чертеже. Выберите "Настройка".


Запись макроса операций (Краткий справочник)

Обзор макросов операций
Запись макроса операций
Значки узла операций
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Запись макроса операций
Понятие Процедура Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ОПЕРСТОП

Останов работы рекордера операций и предоставление возможности сохранения записанных операций в файле макроса операции

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ЛЕНТА

Вызов окна ленты

Системные переменные

ACTPATH

Задание дополнительных путей поиска макросов операций, воспроизведение которых возможно

ACTRECORDERSTATE

Задание текущего состояния рекордера операций

ACTRECPATH

Задание пути для хранения новых макросов операций

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Значки узла операций (Понятие)

Запись макроса операций
Запись макроса операций
Элементы пользовательского интерфейса
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Значки узла операций
Понятие Краткий справочник

Если макрос операции записывается или является текущим, каждая операция в файле макроса соответствует узлу в дереве операций.

Для облегчения определения типа операции или ввода значения, используемого при записи макроса операции, рядом с каждым узлом дерева операций отображается соответствующий значок. В следующей таблице объясняется, что представляют различные узлы операций и соответствующие им значки в дереве операций.

Значок | Имя узла операции | Описание
 | Запрос значения | Запрос ввода значения пользователем при воспроизведении операции.
 | Пользовательское сообщение | Во время воспроизведения для этой операции отображается пользовательское сообщение.
 | Команда | Узел, содержащий все записанные введенные значения для команды.
 | Макрос операции | Узел верхнего уровня, содержащий все операции, связан с текущим макросом операции.
 | Точка абсолютных координат | Значение абсолютных координат основано на точке, полученной во время записи.
 | Точка относительных координат | Значение относительных координат основано на предыдущем значении координат в макросе операций.
 | Взаимодействие/ключевое слово для запросов | Взаимодействие запроса/ключевого слова. Данный узел операции невозможно изменить на запрос значения.
 | Угол | Значение угла.
 | Расстояние | Значение расстояния.
 | Вещественное (двойное) | Вещественное или двойное числовое значение.
 | Целое | Целое числовое значение.
 | Строка | Значение текстовой строки.
 | Масштабный коэффициент | Процентное значение масштаба.
 | Цвет | Значение цвета.
 | Результаты выбора | Заключительный набор объектов, используемый командой. Набор содержит узел для каждого поднабора.
 | Набор объектов, созданный макросом. | В наборе содержатся только объекты, созданные в текущем макросе операции.
 | Использование набора объектов предварительного выбора | Существующий набор объектов заменяется объектами, выбранными до начала воспроизведения макроса операции.
 | Запрос значения (выбор) | Запрос на новый выбор объектов.
 | Палитры свойств | Указание на изменение на палитре свойств или панели быстрых свойств.
 | Свойство | Изменение свойства в палитре свойств или панели быстрых свойств.
 | Фильтрация объектов | Выбор с фильтром объектов, применяемым из палитры свойств или палитры быстрых свойств. Указывает тип используемого фильтра объектов.
 | Модальное диалоговое окно | Модальное диалоговое окно.
 | Изменение наблюдения | Изменение вида, выполненное неявно с помощью команды или изменения координат.
 | Изменение ПСК | Изменение ПСК, выполненное неявно с помощью команды или изменения координат.


Значки узла операций (Краткий справочник)

Запись макроса операций
Запись макроса операций
Элементы пользовательского интерфейса
Пользовательский интерфейс > Макросы операций > Запись макроса операций > Значки узла операций >
Значки узла операций
Понятие Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Элементы пользовательского интерфейса (Понятие)

Значки узла операций
Запись макроса операций
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Запись макроса операций >
Элементы пользовательского интерфейса
Понятие Краткий справочник

При записи макроса операции можно использовать многие общие элементы пользовательского интерфейса.

Некоторые элементы использовать невозможно. При записи макроса операции можно использовать следующие элементы пользовательского интерфейса:

  • Панели инструментов и панель быстрого доступа
  • Всплывающие и контекстные меню
  • Лента
  • Обозреватель меню
  • Устаревшие элементы пользовательского интерфейса (экраны, значки и меню планшета)
  • Строки состояния приложений и чертежей
  • Палитра свойств и панель быстрых свойств
  • Окно палитры инструментов
  • Центр управления

Элементы пользовательского интерфейса, которые невозможно использовать при записи

Можно записывать не все операции, выполняемые с помощью палитры свойств и панели быстрых свойств. Следующие действия записать невозможно:

  • Изменения свойств, выполненные в палитре свойств или панели быстрых свойств.
  • Изменения значений, выполненные для свойств вершин граней 3D тел, и свойств полилиний, выполненных в палитре свойств или панели быстрых свойств.
  • Операции, которые не выполняют команды из строки состояния.

Записываются не все операции, выполняемые из строки состояния. Записываются только элементы, выполняющие команды. Записываются действия, выполняемые со следующими кнопками в строке состояния:

  • Быстрые свойства
  • Модель и лист
  • Быстрый просмотр листов (ограничение записи при переключении листов)
  • Панорамирование
  • Зумирование
  • Штурвалы
  • ShowMotion (ограничено воспроизведением и восстановлением видов)
  • Развернуть/свернуть видовой экран
  • Масштаб аннотаций/видовых экранов
  • Синхронизация масштаба аннотаций/видовых экранов
  • Видимость аннотаций
  • Автоматическое добавление масштабов
  • Блокировка элементов пользовательского интерфейса
  • Очистить экран

Можно записывать не все операции, выполняемые в Центре управления. Следующие действия записать невозможно:

  • Вставка блоков из вкладки интернет-модуля ЦУ.
  • Все операций из контекстных меню, за исключением "Вставить как ссылку" и "Вставить как блок".
  • Перетаскивание именованных объектов (например, слоев и типов линий).


Элементы пользовательского интерфейса (Краткий справочник)

Значки узла операций
Запись макроса операций
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Запись макроса операций > Элементы пользовательского интерфейса >
Элементы пользовательского интерфейса
Понятие Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение макроса операции (Понятие)

Элементы пользовательского интерфейса
Макросы операций
Вставка пользовательских сообщений
Пользовательский интерфейс > Макросы операций >
Изменение макроса операции
Понятие Процедура Краткий справочник

Можно переименовать, скопировать или удалить макрос операции. Можно также изменить макрос операции с помощью удаления операций из дерева операции, добавления пользовательских сообщений и запросов значений или редактирования и изменения поведения операции.

В панели Рекордера операций можно изменить операции в макросе операции и выполнить некоторые основные действия с файлом макроса операции. Изменение и управление файлом макроса операции осуществляется из дерева операций, которое отображается в панели Рекордера операций. Следующие функции изменения доступны из контекстного меню узла макроса операции в дереве операций:

  • Переименовать.Изменение имени команды макроса операции.
  • Удалить. Удаление файла макроса операции из списка макроса операций и помещение этого файла в "Корзину" Windows.
  • Копировать. Создание копии макроса операции. Для копии макроса операции можно задать новое имя команды и имя файла.
  • Свойства. Изменение имени команды и параметров воспроизведения макроса операции.

Узлы операций, соответствующие командам, можно удалять, узлы значений можно редактировать. Изменить узлы операций в макросе операции можно в дереве операций, которое отображается в развернутой панели Рекордера операций. Следующие опции изменения доступны из контекстного меню узла операции в дереве операций:

  • Удалить. Удаление узла операции из текущего макроса операции.
  • Редактировать. Изменение текущего значения.

Темы в этом разделе

  • Вставка пользовательских сообщений

    Пользовательские сообщения можно вставлять в макросы операций для предоставления информации о макросе или определенных инструкций при воспроизведении макроса операции.

  • Запрос значения

    Операции в макросе операции можно изменить для воспроизведения с учетом записанных значений или значений, введенных пользователем во время воспроизведения.

  • Работа с координатами

    Для полученных точек в макросах операций можно использовать абсолютные или относительные координаты.

  • Выбор объектов

    Узлы выбора в дереве операций можно изменить в соответствии с тем, какие объекты следует использовать для команд в макросе операции.


Изменение макроса операции (Процедура)

Запись макроса операций
Изменение макроса операции
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Переименование макроса операции

Удаление записанного макроса операции

Копирование макроса операции

Изменение свойств макроса операции

Удаление операции из макроса операции

Редактирование узла значений в макросе операции


Переименование макроса операции (Процедура)

Изменение макроса операции
Изменение макроса операции
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Переименование макроса операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции для переименования.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на верхнем узле и выберите "Переименовать".
  5. В диалоговом окне "Макрос операции" в поле "Имя команды макроса операции" введите новое имя.
  6. Нажмите "ОК".


Удаление записанного макроса операции (Процедура)

Изменение макроса операции
Изменение макроса операции
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Удаление записанного макроса операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции для удаления.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на верхнем узле и выберите "Удалить".
  5. В диалоговом окне "Макрос операции - Подтверждение удаления" нажмите кнопку "Удалить файл".
ПримечаниеПри удалении макроса операции файл, в котором хранился этот макрос, перемещается в "Корзину". Если этот файл может потребоваться позднее, переместите его из папки "Actions" в другую папку.


Копирование макроса операции (Процедура)

Изменение макроса операции
Изменение макроса операции
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Копирование макроса операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции для копирования.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на верхнем узле и выберите "Копировать".
  5. В диалоговом окне "Макрос операции" в поле "Имя команды макроса операции" введите новое имя и дополнительно выполните следующие действия:
    • Введите описание макроса операций в текстовом поле "Описание".
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "При запросе ввода значения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "После завершения воспроизведения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • Установите флажок "Проверка несогласованности в начале воспроизведения", чтобы Рекордер операций перед воспроизведением выполнял проверку макроса операций.
  6. Нажмите "ОК".


Изменение свойств макроса операции (Процедура)

Изменение макроса операции
Изменение макроса операции
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Изменение свойств макроса операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, для которого требуется изменить свойства.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на верхнем узле и выберите "Свойства".
  5. В диалоговом окне "Макрос операции" измените свойства макроса операции:
    • Введите имя команды для макроса операции в поле "Имя команды макроса операции".
    • Введите описание макроса операций в текстовом поле "Описание".
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "При запросе ввода значения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • В области "Восстановление предшествующего воспроизведению вида" установите флажок "После завершения воспроизведения" для восстановления вида, предшествующего воспроизведению макроса операций.
    • Установите флажок "Проверка несогласованности в начале воспроизведения", чтобы Рекордер операций перед воспроизведением выполнял проверку макроса операций.
  6. Нажмите "ОК".


Удаление операции из макроса операции (Процедура)

Изменение макроса операции
Изменение макроса операции
Изменение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Удаление операции из макроса операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, для которого требуется удалить операцию.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле операции и выберите "Удалить".
  5. В диалоговом окне "Макрос операции - Подтверждение удаления элемента" нажмите кнопку "Удалить".
ПримечаниеПри записи макроса операции удалить операцию невозможно.


Редактирование узла значений в макросе операции (Процедура)

Изменение макроса операции
Изменение макроса операции
Вставка пользовательских сообщений
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Редактирование узла значений в макросе операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, для которого требуется отредактировать узел значения.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле значения и выберите "Редактировать".
  5. Введите новое значение и нажмите ENTER.


Изменение макроса операции (Краткий справочник)

Элементы пользовательского интерфейса
Изменение макроса операции
Вставка пользовательских сообщений
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Изменение макроса операции
Понятие Процедура Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ЛЕНТА

Вызов окна ленты

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка пользовательских сообщений (Понятие)

Изменение макроса операции
Изменение макроса операции
Запрос значения
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Вставка пользовательских сообщений
Понятие Процедура Краткий справочник

Пользовательские сообщения можно вставлять в макросы операций для предоставления информации о макросе или определенных инструкций при воспроизведении макроса операции.

При записи макроса операции в него можно вставить пользовательское сообщение, которое будет отображаться при воспроизведении макроса операции. Сообщение может описывать цель макроса операции или параметры, необходимые для воспроизведения макроса операции. В макрос операции можно вставлять сколько угодно пользовательских сообщений, сообщения можно вставлять до или после операции в макросе операции.

При отображении сообщения можно продолжить воспроизведение, нажав кнопку "Да", или отменить воспроизведение, нажав кнопку "Нет". При отмене воспроизведения все изменения, выполненные до сообщения, сохраняются. Для отмены любого из изменений, выполненных макросом операции, можно использовать команды "О" или "ОТМЕНИТЬ".


Вставка пользовательских сообщений (Процедура)

Изменение макроса операции
Изменение макроса операции
Вставка пользовательских сообщений
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Вставка пользовательских сообщений >
Вставка пользовательских сообщений
Понятие Процедура Краткий справочник

Вставка пользовательского сообщения в макрос операции

Редактирование пользовательского сообщения, вставленного в макрос операции


Вставка пользовательского сообщения в макрос операции (Процедура)

Вставка пользовательских сообщений
Изменение макроса операции
Вставка пользовательских сообщений
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Вставка пользовательских сообщений >
Вставка пользовательских сообщений
Понятие Процедура Краткий справочник

Вставка пользовательского сообщения в макрос операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, в который требуется вставить пользовательское сообщение.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле и выберите "Вставить пользовательское сообщение".
    ПримечаниеВставить пользовательское сообщение можно только до или после узла, расположенного под узлом макроса операции в дереве операций.
  5. В диалоговом окне "Вставить пользовательское сообщение" введите текст сообщения, которое будет отображаться при воспроизведении макроса операции.
  6. Нажмите "ОК".
Ввод команды: ОПЕРПСООБЩЕНИЕ


Редактирование пользовательского сообщения, вставленного в макрос операции (Процедура)

Вставка пользовательских сообщений
Изменение макроса операции
Запрос значения
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Вставка пользовательских сообщений >
Вставка пользовательских сообщений
Понятие Процедура Краткий справочник

Редактирование пользовательского сообщения, вставленного в макрос операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, для которого требуется отредактировать пользовательское сообщение.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле "Текстовое сообщение" и выберите "Редактировать сообщение".
  5. В диалоговом окне "Вставить пользовательское сообщение" измените текст сообщения.
  6. Нажмите "ОК".
Ввод команды: ОПЕРПСООБЩЕНИЕ


Вставка пользовательских сообщений (Краткий справочник)

Изменение макроса операции
Изменение макроса операции
Запрос значения
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Вставка пользовательских сообщений >
Вставка пользовательских сообщений
Понятие Процедура Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ОПЕРПСООБЩЕНИЕ

Вставка запроса значения в макрос операции

ЛЕНТА

Вызов окна ленты

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Запрос значения (Понятие)

Вставка пользовательских сообщений
Изменение макроса операции
Работа с координатами
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Запрос значения
Понятие Процедура Краткий справочник

Операции в макросе операции можно изменить для воспроизведения с учетом записанных значений или значений, введенных пользователем во время воспроизведения.

При записи макроса операции можно выбрать точку или задать значение ввода, чтобы при каждом воспроизведении макроса операции не производить запрос значений. Можно переключить поведение узла значений в текущем макросе операции так, чтобы во время воспроизведения отображался запрос на ввод значения. Узел значений может содержать полученную точку, текстовую строку, число, параметр команды или выбор объектов. Если макрос операции содержит запрос значений, можно использовать записанное значение или предоставить возможность ввода значения при воспроизведении макроса.


Переключение запроса ввода значения во время воспроизведения макроса операции (Процедура)

Вставка пользовательских сообщений
Изменение макроса операции
Работа с координатами
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Запрос значения >
Запрос значения
Понятие Процедура Краткий справочник

Переключение запроса ввода значения во время воспроизведения макроса операции

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, содержащий узел значений, для которого во время воспроизведения требуется выполнить запрос значения.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле значений и выберите "Запрос значения".
Ввод команды: ОПЕРПВВОД


Запрос значения (Краткий справочник)

Вставка пользовательских сообщений
Изменение макроса операции
Работа с координатами
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Запрос значения >
Запрос значения
Понятие Процедура Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ОПЕРПВВОД

Вставка пользовательского сообщения в макрос операции

ЛЕНТА

Вызов окна ленты

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с координатами (Понятие)

Запрос значения
Изменение макроса операции
Выбор объектов
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Работа с координатами
Понятие Процедура Краткий справочник

Для полученных точек в макросах операций можно использовать абсолютные или относительные координаты.

При записи макроса операции записанные значения координат представлены как абсолютные или относительные координаты. Хотя значение координат может быть абсолютным или относительным, сохраненное значение для всех записанных значений координат является абсолютным. Поскольку все значения координат хранятся в макросе операции как абсолютные, при воспроизведении можно переключать абсолютные или относительные координаты, связанные со значением точки для записанного значения координат. Абсолютным всегда считается первое записанное значение координат или значение координат после изменения ПСК. Абсолютное значение координат в макросе операции используется в качестве базовой точки для всех последующих относительных значений координат.

Переключать поведение значения координат можно в дереве операций в Рекордере операций. В верхнем узле дерева операций можно также изменить все значения координат в макросе операций на относительные или абсолютные.


Работа с координатами (Процедура)

Запрос значения
Изменение макроса операции
Работа с координатами
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Работа с координатами >
Работа с координатами
Понятие Процедура Краткий справочник

Переключение значения координат - абсолютные или относительно предыдущей точки

Переключение всех значений координат - абсолютные или относительно предыдущей точки


Переключение значения координат - абсолютные или относительно предыдущей точки (Процедура)

Работа с координатами
Изменение макроса операции
Работа с координатами
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Работа с координатами >
Работа с координатами
Понятие Процедура Краткий справочник

Переключение значения координат - абсолютные или относительно предыдущей точки

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, содержащий узел значения координат, которое требуется изменить.
  3. Разверните панель Рекордера операций.
  4. В панели операций щелкните правой кнопкой мыши на узле значения координат и выберите "Относительно предыдущих".
    • Для переключения значения координат на абсолютные снимите флажок "Относительно предыдущих". Если флажок не установлен, используются абсолютные значения координат.
    • Для переключения на значения координат относительно предыдущей точки установите флажок "Относительно предыдущих". Если флажок уже установлен, то всегда используется значение координат относительно предыдущей точки.


Переключение всех значений координат - абсолютные или относительно предыдущей точки (Процедура)

Работа с координатами
Изменение макроса операции
Выбор объектов
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Работа с координатами >
Работа с координатами
Понятие Процедура Краткий справочник

Переключение всех значений координат - абсолютные или относительно предыдущей точки

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, содержащий узел значения координат, в котором требуется использовать абсолютные координаты или координаты относительно предыдущих координат.
  3. Разверните панель Рекордера операций.
  4. В списке дерева операций щелкните правой кнопкой мыши на верхнем узле и выберите "Все точки относительные".
    • Для переключения всех значений координат на абсолютные снимите флажок "Все точки относительные". Если флажок не установлен, возможно, уже используются абсолютные значения координат. Макрос может содержать абсолютные и относительные значения координат.
      ПримечаниеЧтобы гарантированно использовались только абсолютные значения координат при снятом флажке "Все точки относительные", установите и снимите этот флажок еще раз для исключения ситуации, когда некоторые значения координат являются абсолютными, а другие - относительны при отсчете от предыдущей точки.
    • Для использования всех значений координат относительно предыдущей точки, за исключением первого значения координат, установите флажок "Относительно предыдущих". Если флажок уже установлен, все значения координат используются относительно предыдущей точки, за исключением первого значения координат, которое всегда абсолютно.


Работа с координатами (Краткий справочник)

Запрос значения
Изменение макроса операции
Выбор объектов
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Работа с координатами >
Работа с координатами
Понятие Процедура Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ЛЕНТА

Вызов окна ленты

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор объектов (Понятие)

Работа с координатами
Изменение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции >
Выбор объектов
Понятие Процедура Краткий справочник

Узлы выбора в дереве операций можно изменить в соответствии с тем, какие объекты следует использовать для команд в макросе операции.

При изменении макроса операции можно задать способ выбора, используемый при воспроизведении макроса операции. Для изменения поведения выбора объектов в узле результатов выбора макроса операции можно использовать следующие опции:

  • Использовать предварительный выбор.Используются объекты, выбранные до начала воспроизведения макроса операции.
  • Запрос значения.Запрос на новый набор объектов.
  • Использовать набор объектов, созданный макросом. Выбираются все объекты, созданные при воспроизведении макроса операции.


Выбор объектов (Процедура)

Работа с координатами
Изменение макроса операции
Выбор объектов
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Выбор объектов >
Выбор объектов
Понятие Процедура Краткий справочник

Запрос значения на выбор во время воспроизведения

Переключение во время воспроизведения использования набора объектов, созданных макросом

Использование предварительного выбора во время воспроизведения


Запрос значения на выбор во время воспроизведения (Процедура)

Выбор объектов
Изменение макроса операции
Выбор объектов
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Выбор объектов >
Выбор объектов
Понятие Процедура Краткий справочник

Запрос значения на выбор во время воспроизведения

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, содержащий узел результатов выбора, для которого во время воспроизведения требуется выполнить запрос значения.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле результатов выбора и выберите "Запрос значения".


Переключение во время воспроизведения использования набора объектов, созданных макросом (Процедура)

Выбор объектов
Изменение макроса операции
Выбор объектов
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Выбор объектов >
Выбор объектов
Понятие Процедура Краткий справочник

Переключение во время воспроизведения использования набора объектов, созданных макросом

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, содержащий узел результатов выбора, который будет представлять выбор всех объектов, созданных при воспроизведении макроса.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле результатов выбора и выберите "Выбор созданных макросами объектов".


Использование предварительного выбора во время воспроизведения (Процедура)

Выбор объектов
Изменение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Выбор объектов >
Выбор объектов
Понятие Процедура Краткий справочник

Использование предварительного выбора во время воспроизведения

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните на значке со стрелкой вниз рядом со списком "Макрос операции".
  2. В списке "Макрос операции" выберите макрос операции, содержащий узел результатов выбора, который будет представлять предварительный выбор всех объектов, выбранных до начала воспроизведения макросов.
  3. Разверните панель Рекордера операций.
  4. В дереве операций щелкните правой кнопкой мыши на узле результатов выбора и выберите "Использовать предварительно выбранные объекты".


Выбор объектов (Краткий справочник)

Работа с координатами
Изменение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Изменение макроса операции > Выбор объектов >
Выбор объектов
Понятие Процедура Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ЛЕНТА

Вызов окна ленты

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Воспроизведение макроса операции (Понятие)

Выбор объектов
Макросы операций
Подсказки по использованию Рекордера операций
Пользовательский интерфейс > Макросы операций >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

После записи макроса операции с помощью Рекордера операций можно воспроизвести последовательность записанных команд и значений ввода.

Воспроизвести макрос операции можно из панели Рекордера операций. Также можно ввести имя макроса операции в командной строке. При воспроизведении макроса операции, возможно, появится запрос на ввод значений или потребуется выполнить действие в ответ на сообщение.

В зависимости от текущей операции или запроса на действия пользователя в макросе операции рядом с курсором отображается значок, указывающий, требуется ли ввод значений для продолжения выполнения макроса операции. Возможно, будет открыто диалоговое окно для ввода значения или будет использоваться записанное значение.

Для запуска анимации нажмите стрелку "Воспроизведение".

При воспроизведении макроса операции выполняется последовательность команд до полного завершения воспроизведения или до возникновения ошибки. Некоторые причины остановки воспроизведения или неполадки:

  • Недопустимая команда. Команда, определенная в макросе операции, неизвестна в AutoCAD. Возможно, макрос операции записан в другой программе или содержит пользовательские команды или не загруженный макрос.
  • Пустой набор. Для выполнения текущей операции требуется набор объектов, но выбранных объектов нет.
  • Отмена макроса. В одном из диалоговых окон нажата кнопка "Отмена".

Местоположение макросов операций

При записи макрос операции сохраняется в папку, определяемую системной переменной ACTRECPATH. Папки для воспроизведения определяются системной переменной ACTPATH.

При загрузке и воспроизведении макросов операций используются оба набора папок. В узле параметров рекордера операций на вкладке "Файлы" в диалоговом окне "Настройка" можно задать пути, используемые для записи и чтения файлов макросов операций.


Воспроизведение макроса операции (Процедура)

Выбор объектов
Воспроизведение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Воспроизведение макроса операции >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

Воспроизведение макроса операции из панели Рекордера операций

Воспроизведение макроса операции из обозревателя меню

Воспроизведение макроса операции из командной строки

Применение пользовательского ввода во время воспроизведения

Изменение папки для поиска записанных макросов операций


Воспроизведение макроса операции из панели Рекордера операций (Процедура)

Воспроизведение макроса операции
Воспроизведение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Воспроизведение макроса операции >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

Воспроизведение макроса операции из панели Рекордера операций

  1. На ленте выберите вкладку "Сервис" [image] панель Рекордера операций. Щелкните значок стрелки "вниз" рядом со списком "Макрос операции" и выберите макрос операции для воспроизведения.
  2. Нажмите "Воспроизведение".
  3. Для завершения макроса операции выполняйте все запросы команд и диалоговых окон.


Воспроизведение макроса операции из обозревателя меню (Процедура)

Воспроизведение макроса операции
Воспроизведение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Воспроизведение макроса операции >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

Воспроизведение макроса операции из обозревателя меню

  1. Выберите меню "Сервис" [image] "Рекордер операций" [image] "Воспроизведение". Выберите макрос операции для воспроизведения.В командной строке введите имя макроса операции, который требуется воспроизвести, и нажмите ENTER.
  2. Для завершения макроса операции выполняйте все запросы команд и диалоговых окон.


Воспроизведение макроса операции из командной строки (Процедура)

Воспроизведение макроса операции
Воспроизведение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Воспроизведение макроса операции >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

Воспроизведение макроса операции из командной строки

  • В командной строке введите имя макроса операции, который требуется воспроизвести, и нажмите ENTER.

    Например, если имя команды макроса операции DRAWLINE, введите в командной строке drawline и нажмите ENTER.


Применение пользовательского ввода во время воспроизведения (Процедура)

Воспроизведение макроса операции
Воспроизведение макроса операции
Воспроизведение макроса операции
Пользовательский интерфейс > Макросы операций > Воспроизведение макроса операции >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

Применение пользовательского ввода во время воспроизведения

  1. Запустите воспроизведение макроса операции.
  2. В диалоговом окне "Макрос операции - Запрос значения" нажмите "Предоставить значение".
  3. Следуйте запросам в командной строке.


Изменение папки для поиска записанных макросов операций (Процедура)

Воспроизведение макроса операции
Воспроизведение макроса операции
Использование простейшего шаблона
Пользовательский интерфейс > Макросы операций > Воспроизведение макроса операции >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

Изменение папки для поиска записанных макросов операций

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" откройте вкладку "Файлы" и в списке узлов щелкните значок "плюс" (+) рядом с элементом "Параметры Рекордера операций".
  3. Щелкните значок "плюс" (+) рядом с элементом "Местоположение дополнительных файлов операций" и укажите путь к папке.
  4. Нажмите "ОК".
Ввод команды: НАСТРОЙКА
Контекстное меню:Щелкните правой кнопкой мыши на чертеже. Выберите "Настройка".


Воспроизведение макроса операции (Краткий справочник)

Выбор объектов
Воспроизведение макроса операции
Подсказки по использованию Рекордера операций
Пользовательский интерфейс > Макросы операций > Воспроизведение макроса операции >
Воспроизведение макроса операции
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ЛЕНТА

Вызов окна ленты

Системные переменные

ACTPATH

Задание дополнительных путей поиска макросов операций, воспроизведение которых возможно

ACTRECPATH

Задание пути для хранения новых макросов операций

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подсказки по использованию Рекордера операций (Понятие)

Воспроизведение макроса операции
Макросы операций
Примеры макросов операций
Пользовательский интерфейс > Макросы операций >
Подсказки по использованию Рекордера операций
Понятие Краткий справочник

Рекордер операций представляет собой интуитивно понятное средство и позволяет создавать пользовательские команды, способные сократить количество операций, необходимых для выполнения повторяющихся задач. При записи макроса операции необходимо учесть несколько моментов.

Запись макросов операций

При записи макроса операции необходимо убедиться в следующем:

  • Текущие параметры чертежа, используемые при записи макроса операции, не полностью сохраняются при выполнении макроса операции. Для обеспечения использования параметров чертежа при воспроизведении запишите эти параметры как часть макроса операции. Для этого используйте системную переменную или команду УСТПЕРЕМ.
  • Хотя можно записать большинство команд, некоторые команды записать невозможно. Команды, которые не записываются, связаны с операциями над файлами чертежей, использованием Рекордера операций и редактированием ручками. В следующей таблице представлены команды, которые не записываются Рекордером операций.
    ОПЕРСТОП | ОПЕРПВВОД
    ОПЕРПСООБЩЕНИЕ | -ОПЕРПСООБЩЕНИЕ
    ИМПОРТА | ОТКРЫТЬФАЙЛ
    НОВЫЙ | ОТКРЫТЬ
    ОТКРЧАСТЬ | ВЫДАВГРАНЬ
    БСОЗДАТЬ | ВОССТАН
    ТАБЛРЕД | VBAIDE
    -VBALOAD | VBALOAD
    VBAMAN | VBANEW
    VBAPREF | -VBARUN
    VBARUN | VBASTMT
    VBAUNLOAD | ССОТКРЫТЬ
  • Операции, записанные в Рекордере операций, ограничены взаимодействием с палитрой свойств, панелью быстрых свойств, немодальным диалоговым окном "Слой" и любым элементом пользовательского интерфейса, запускающим команду.

    Некоторые элементы пользовательского интерфейса, запускающие команды: большинство инструментов на инструментальных палитрах, некоторые операции в Центре управления и некоторые инструменты в строке состояния.

  • Изменения в диалоговых окнах не записываются, хотя диалоговые окна при воспроизведении отображаются. Вместо использования диалоговых окон при записи используйте версии команд в командной строке. Это обеспечит согласованное поведение макросов операций при воспроизведении.
  • В макрос операции можно записывать команды, определенные с помощью AutoLISP и ObjectARX, но эти команды необходимо загрузить до воспроизведения макроса операции. Макросы VBA и сборки .NET также можно записывать в макрос операции, но их необходимо загрузить для воспроизведения.
  • Макросы операций не должны иметь такие же имена, как заданные команды, уже загруженные в AutoCAD.
  • В ходе записи команд ОТРЕЗОК и ДУГА не рекомендуется нажимать "ENTER" при запросе на ввод первой точки отрезка или дуги. Нажатие "ENTER" для продолжения работы от последнего начерченного отрезка или дуги может привести к неправильному воспроизведению макроса операции.
  • Направление сегмента дуги, созданного с помощью опции "Дуга" команды ПЛИНИЯ, не воспроизводится правильно, если для определения сегмента дуги не используется параметр "Направление".
  • При записи команды ТАБЛИЦА записывается создание таблицы, но любые операции редактирования ячеек таблицы не записываются.

Редактирование макроса операции

При редактировании макроса операции AutoCAD загружает файлы макросов операций, найденные в папках, определяемых системными переменными ACTRECPATH и ACTPATH. Если несколько файлов макросов операций имеют одинаковое имя, в Рекордер операций загружается первый файл макроса операции, найденный AutoCAD. Другие файлы с этим же именем игнорируются и не загружаются.

Для определения пути загруженного макроса операции выберите макрос операции в раскрывающемся списке "Макрос операции" и разверните панель Рекордера операций. Щелкните правой кнопкой мыши на узле макроса операции в дереве операций и выберите "Свойства". В диалоговом окне "Макрос операции" путь к файлу макроса операции отображается в поле "Путь к папке".

Воспроизведение макроса операции

При воспроизведении макроса операции необходимо убедиться в следующем:

  • При воспроизведении макроса операции результаты могут отличаться от результатов, полученных при исходной записи макроса операции. Это обусловлено различиями параметров текущего чертежа и параметров чертежа, открытого при записи макроса операции.
  • При воспроизведении макроса операции, вызывающего диалоговое окно, макрос переходит в режим паузы и ожидает закрытия диалогового окна после внесения изменений. Если диалоговое окно просто закрыть без внесения изменений, воспроизведение макроса продолжится, но результаты будут отличаться от ожидаемых.
  • При воспроизведении макроса операции, содержащего команды, определенные в AutoLISP, ObjectARX или сборках .NET, воспроизведение макроса операции приводит к неполадке, если файлы, определяющие команды, не загружены. Если макрос операции ссылается на макрос VBA, воспроизведение макроса операции приведет к неполадке, если файл проекта не будет загружен.

Обмен макросами операций

При обмене макросами операций с другими пользователями учтите следующее.

  • Макросы операций, записанные с помощью одного из вертикальных продуктов AutoCAD, могут воспроизводиться неправильно на основе команд, используемых при записи макроса операции.
  • Макросы операций могут воспроизводиться неправильно, если они записаны на одном языке AutoCAD, а воспроизводятся на другом языке AutoCAD.


Подсказки по использованию Рекордера операций (Краткий справочник)

Воспроизведение макроса операции
Подсказки по использованию Рекордера операций
Создание нового слоя и объектов чертежа
Пользовательский интерфейс > Макросы операций > Подсказки по использованию Рекордера операций >
Подсказки по использованию Рекордера операций
Понятие Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ЛЕНТА

Вызов окна ленты

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Примеры макросов операций

Подсказки по использованию Рекордера операций
Макросы операций
Создание нового слоя и объектов чертежа
Пользовательский интерфейс > Макросы операций >
Примеры макросов операций

В следующих примерах показаны некоторые способы автоматизации повторяющихся задач с помощью макросов операций. В примерах показаны различные способы записи операций в Рекордере операций.

Темы в этом разделе

  • Создание нового слоя и объектов чертежа

    В данном примере создадим макрос операции, создающий новый слой, а затем объекты на слое, необходимые для создания двухмерного вида сверху шестигранного болта.

  • Вставка блока и изменение значения динамического свойства

    В данном примере показано, как вставлять из инструментальной палитры динамический блок и как изменять его динамические свойства с помощью палитры свойств.

  • Изменение окружностей в палитре свойств

    В данном примере показано, как применять фильтр для выбора объектов и изменять свойство цвета выбранных объектов.


Создание нового слоя и объектов чертежа (Понятие)

Примеры макросов операций
Примеры макросов операций
Вставка блока и изменение значения динамического свойства
Пользовательский интерфейс > Макросы операций > Примеры макросов операций >
Создание нового слоя и объектов чертежа
Понятие Краткий справочник

В данном примере создадим макрос операции, создающий новый слой, а затем объекты на слое, необходимые для создания двухмерного вида сверху шестигранного болта.

В данном примере рассматриваются следующие вопросы:

  • Запись и сохранение макроса операции
  • Запись операций в Диспетчере свойств слоев
  • Запись команд и значений ввода для создания и изменения объектов
  • Вставка пользовательского сообщения
  • Вставка запроса значения
  • Воспроизведение макроса операции

Начало записи макроса операции

Начало записи операций выполняется в Рекордере операций. Для отображения панели Рекордера операций и начала записи выполните следующие действия:

  1. На ленте выберите вкладку "Инструменты".
  2. На панели Рекордера операций нажмите "Запись".

Запись операций из палитры Диспетчера свойств слоев

После включения записи в Рекордере операций для создания нового слоя воспользуйтесь Диспетчером свойств слоев. Выполните следующие действия:

  1. В командной строке введите СЛОЙ и нажмите ENTER.
  2. В "Диспетчере свойств слоев" нажмите кнопку "Создать слой".
  3. В контекстном редакторе, который вызывается для изменения имени нового слоя, введите "Болт" и нажмите ENTER.
  4. В столбце "Цвет" слоя "Болт" дважды щелкните на образце цвета.
  5. В диалоговом окне "Выбор цвета" щелкните на образце цвета для цвета 1 (красный) и нажмите "ОК".
  6. В "Диспетчере свойств слоев" нажмите кнопку "Установить".

Запись команд и значений ввода для создания и изменения объектов

Создание слоя "Болт" записано. Далее создадим окружность, а затем на основе этой окружности шестигранный многоугольник, необходимый для болта с шестигранной головкой. После построения окружности и многогранника с помощью команды МАСШТАБ изменим размер шестигранного болта при воспроизведении макроса операции. Выполните следующие действия:

  1. В командной строке введите круг и нажмите ENTER.
  2. В ответ на запрос

    Центр окружности или [3Т/2Т/ККР (кас, кас, радиус)]:

    щелкните в окне чертежа.
  3. В ответ на запрос

    Радиус окружности [Диаметр]:

    введите 0,9 и нажмите ENTER.
  4. В командной строке введите мн-угол и нажмите ENTER.
  5. В ответ на запрос

    Количество сторон <4>:

    введите 6 и нажмите ENTER.
  6. В ответ на запрос

    Центр многоугольника или [Кромка]:

    включите привязку к центру объекта и выберите кромку окружности.
  7. В ответ на запрос

    Задайте опцию размещения [Вписанный в окружность/Описанный вокруг окружности] <О>:

    введите О для выбора опции "Описанный вокруг окружности" и нажмите ENTER.
  8. В ответ на запрос

    Радиус окружности:

    введите 1 и нажмите ENTER.
  9. В командной строке введите масштаб и нажмите ENTER.
  10. В ответ на запрос

    Выбрать объекты:

    выберите окружность и многоугольник и нажмите ENTER.
  11. В ответ на запрос

    Базовая точка:

    включите привязку к центру объекта и выберите кромку окружности.
  12. В ответ на запрос

    Масштаб или [Копия/Опорный отрезок] <1.0000>:

    введите 1 и нажмите ENTER.

Остановка записи и сохранение макроса операции

После записи всех операций остановите запись и сохраните записанные операции в файл макроса операции. Выполните следующие действия:

  1. В панели Рекордера операций нажмите "Остановить".
  2. В диалоговом окне "Макрос операции" выполните следующие действия:
    • В поле "Имя команды макроса операции" введите CreateBolt.
    • В поле "Описание" введите "Создание болта с шестигранной головкой".
  3. Нажмите "ОК".

Вставка пользовательского сообщения

Пользовательские сообщения позволяют оставлять пользователям инструкции или общие сведения о макросе операции до выполнения изменений в чертеже при воспроизведении. Для вставки в макрос операции пользовательского сообщения выполните следующие действия:

  1. В панели Рекордера операций щелкните на заголовке для раскрытия панели.
  2. В дереве операций выберите узел CreateBolt и щелкните правой кнопкой мыши. Выберите "Вставить пользовательское сообщение".
  3. В диалоговом окне "Вставить пользовательское сообщение" введите "Создание болта с шестигранной головкой с помощью построения окружности и многоугольника". Во время воспроизведения выдается запрос на задание центральной точки окружности и размера болта. Нажмите "ОК".

Вставка запроса значения

Запрос значения позволяет при воспроизведении макроса операции вводить значения вместо использования записанных значений. В данном макросе операции изменим значение координат центральной точки окружности и масштабный коэффициент для команды МАСШТАБ с помощью запроса значений во время воспроизведения. Выполните следующие действия:

  1. В панели Рекордера операций щелкните на заголовке для раскрытия панели.
  2. В дереве операций выберите узел значения "Абсолютные координаты точки" в узле операций "Окружность" и щелкните правой кнопкой мыши. Выберите "Запрос значения".
  3. Выберите узел значения "Масштабный коэффициент" в узле операций "Масштаб" и щелкните правой кнопкой мыши. Выберите "Запрос значения".

Воспроизведение макроса операции

При воспроизведении макроса операций выдается запрос на задание центральной точки окружности, а затем запрос на задание масштабного коэффициента для команды МАСШТАБ. Для просмотра результатов макроса операции выполните следующие действия:

  1. В панели Рекордера операций в списке "Макрос операции" выберите CreateBolt.
  2. Нажмите "Воспроизведение".
  3. В диалоговом окне "Пользовательское сообщение" нажмите "Да".
  4. В диалоговом окне "Макрос операции - Запрос значения" нажмите "Предоставить значение".
  5. При запросе на указание точки щелкните в окне чертежа.

    Создаются окружность и многоугольник.

  6. В диалоговом окне "Макрос операции - Запрос значения" нажмите "Предоставить значение".
  7. При запросе масштабного коэффициента введите в командной строке числовое значение (например, 1 или 0,25) и нажмите ENTER.

    Окружность и многоугольник масштабируются в соответствии с заданным масштабным коэффициентом.

  8. В диалоговом окне "Макрос операции – Воспроизведение завершено" нажмите "ОК".


Создание нового слоя и объектов чертежа (Краткий справочник)

Подсказки по использованию Рекордера операций
Создание нового слоя и объектов чертежа
Вставка блока и изменение значения динамического свойства
Пользовательский интерфейс > Макросы операций > Примеры макросов операций > Создание нового слоя и объектов чертежа >
Создание нового слоя и объектов чертежа
Понятие Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ОПЕРСТОП

Останов работы рекордера операций и предоставление возможности сохранения записанных операций в файле макроса операции

ОПЕРПВВОД

Вставка запроса значения в макрос операции

ОПЕРПСООБЩЕНИЕ

Вставка пользовательского сообщения в макрос операции

КРУГ

Построение окружностей

СЛОЙ

Управление слоями и их свойствами

МН-УГОЛ

Построение равносторонних многоугольников в виде замкнутых полилиний

ЛЕНТА

Вызов окна ленты

МАСШТАБ

Увеличение или уменьшение выбранных объектов с сохранением пропорций

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка блока и изменение значения динамического свойства (Понятие)

Создание нового слоя и объектов чертежа
Примеры макросов операций
Изменение окружностей в палитре свойств
Пользовательский интерфейс > Макросы операций > Примеры макросов операций >
Вставка блока и изменение значения динамического свойства
Понятие Краткий справочник

В данном примере показано, как вставлять из инструментальной палитры динамический блок и как изменять его динамические свойства с помощью палитры свойств.

В данном примере рассматриваются следующие вопросы:

  • Запись и сохранение макроса операции
  • Запись операций из окна инструментальных палитр
  • Изменение объекта с помощью палитры свойств
  • Удаление узла операции из макроса операции
  • Вставка запроса значения
  • Воспроизведение макроса операции

Начало записи макроса операции

Начало записи операций выполняется в Рекордере операций. Для отображения панели Рекордера операций и начала записи выполните следующие действия:

  1. На ленте выберите вкладку "Инструменты".
  2. В панели Рекордера операций нажмите "Запись".

Запись операций из окна инструментальных палитр

Можно использовать инструменты из инструментальной палитры, а затем воспроизводить операцию, выполненную с помощью инструмента. В окно инструментальных палитр поместите из инструментальной палитры "Несущие элементы" динамический блок "Двутавровая балка - британские". Выполните следующие действия:

  1. В командной строке введите инстрпалвкл для вызова окна инструментальных палитр.
  2. В командной строке введите окносв для отображения палитры "Свойства".
  3. В окне инструментальных палитр в группе "Все палитры" выберите вкладку "Несущие элементы".
  4. На вкладке несущие элементы выберите инструмент "Двутавровая балка - британские".
  5. В палитре свойств в категории "Пользовательские" щелкните в поле "Размеры балки".
  6. В раскрывающемся списке "Размеры балки" выберите IPE A 140.
  7. В окне чертежа укажите точку вставки блока.

Остановка записи и сохранение макроса операции

После записи всех операций остановите запись и сохраните записанные операции в файл макроса операции. Выполните следующие действия:

  1. В панели Рекордера операций нажмите "Остановить".
  2. В диалоговом окне "Макрос операции" выполните следующие действия:
    • В поле "Имя команды макроса операции" введите InsertIPEA140.
    • В поле "Описание" введите "Вставка балки IPE A 140".
  3. Нажмите "ОК".

Удаление узлов операций

При записи макроса операции иногда записываются лишние операции. Например, при записи макроса операции выполняется вызов окна инструментальных палитр и палитры свойств. Эти узлы операций не требуются для воспроизведения макроса операции. Для удаления узлов операций из макроса операции выполните следующие действия:

  1. В панели Рекордера операций щелкните заголовок для раскрытия панели.
  2. В дереве операций выберите узел операции ИНСТРПАЛВКЛ в узле "Макрос операции" и щелкните правой кнопкой мыши. Выберите "Удалить".
  3. Выберите узел операции "Свойства" и щелкните правой кнопкой мыши. Выберите "Удалить".

Вставка запроса значения

Запрос значения позволяет при воспроизведении макроса операции вводить значения вместо использования записанных значений. В этом макросе операции запрашивается значение для изменения значения координат точки вставки блока. Выполните следующие действия:

  1. В панели Рекордера операций щелкните заголовок для раскрытия панели.
  2. В дереве операций выберите узел значения "Абсолютные координаты точки" в узле операций EXECUTETOOL и щелкните правой кнопкой мыши. Выберите "Запрос значения".

Воспроизведение макроса операции

При воспроизведении макроса операции выдается запрос на указание точки вставки блока. Для просмотра результатов макроса операции выполните следующие действия:

  1. В панели Рекордера операций в списке "Макрос операции" выберите InsertIPEA140.
  2. Нажмите "Воспроизведение".
  3. В диалоговом окне "Макрос операции - Запрос значения" нажмите "Предоставить значение".
  4. При запросе указания точки щелкните в окне чертежа для вставки блока.

    При вставке блока размер балки на экране изменяется на размер, заданный в палитре свойств.

  5. В диалоговом окне "Макрос операции – Воспроизведение завершено" нажмите "ОК".


Вставка блока и изменение значения динамического свойства (Краткий справочник)

Создание нового слоя и объектов чертежа
Вставка блока и изменение значения динамического свойства
Изменение окружностей в палитре свойств
Пользовательский интерфейс > Макросы операций > Примеры макросов операций > Вставка блока и изменение значения динамического свойства >
Вставка блока и изменение значения динамического свойства
Понятие Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ОПЕРСТОП

Останов работы рекордера операций и предоставление возможности сохранения записанных операций в файле макроса операции

ОПЕРПВВОД

Вставка запроса значения в макрос операции

ОКНОСВ

Управление свойствами объектов

ЛЕНТА

Вызов окна ленты

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение окружностей в палитре свойств (Понятие)

Вставка блока и изменение значения динамического свойства
Примеры макросов операций
Создание, организация и сохранение чертежей
Пользовательский интерфейс > Макросы операций > Примеры макросов операций >
Изменение окружностей в палитре свойств
Понятие Краткий справочник

В данном примере показано, как применять фильтр для выбора объектов и изменять свойство цвета выбранных объектов.

В данном примере рассматриваются следующие вопросы:

  • Запись и сохранение макроса операции
  • Изменение объекта с помощью палитры свойств
  • Выбор объектов и использование фильтра выбора объектов
  • Использование предварительного выбора
  • Воспроизведение макроса операции

Начало записи макроса операции

Начало записи операций выполняется в Рекордере операций. Для отображения панели Рекордера операций и начала записи выполните следующие действия:

  1. На ленте выберите вкладку "Инструменты".
  2. В панели Рекордера операций нажмите "Запись".

Изменение объектов с помощью палитры свойств и фильтра выбора объектов

С помощью палитры свойств можно выбирать объекты для изменения, применяя к выбранным объектам фильтр выбора объектов. Выполните следующие действия:

  1. Выберите объекты на чертеже, которые требуется изменить, и щелкните правой кнопкой мыши. Выберите "Свойства".
  2. В палитре свойств в раскрывающемся списке "Объекты" выберите "Окружности".
  3. В категории "Общие" выберите поле "Цвет".
  4. В раскрывающемся списке "Цвет" выберите "Синий".

Остановка записи и сохранение макроса операции

После записи всех операций остановите запись и сохраните записанные операции в файл макроса операции. Выполните следующие действия:

  1. В панели Рекордера операций нажмите "Остановить".
  2. В диалоговом окне "Макрос операции" выполните следующие действия:
    • В поле "Имя команды макроса операции" введите BlueCircles.
    • В поле "Описание" введите "Изменение цвета выбранных окружностей на синий".
  3. Нажмите "ОК".

Изменение набора объектов для использования набора объектов предварительного выбора

Запрос значения позволяет при воспроизведении макроса операции вводить значения вместо использования записанных значений. В данном макросе операций измените набор объектов, созданный для использования предварительного выбора. Выполните следующие действия:

  1. В панели Рекордера операций щелкните на заголовке для раскрытия панели.
  2. В дереве операций в узле "Макрос операции" выберите узел значений "Предварительный выбор" и щелкните правой кнопкой мыши. Выберите "Использовать предварительно выбранные объекты".

Воспроизведение макроса операции

При воспроизведении макроса операции выдается запрос на выбор объектов. Для просмотра результатов макроса операции выполните следующие действия:

  1. Постройте в чертеже несколько окружностей и других объектов. Измените цвет объектов на цвета, отличные от синего.
  2. В панели Рекордера операций в списке "Макрос операции" выберите BlueCircles.
  3. Нажмите "Воспроизведение".
  4. В диалоговом окне "Макрос операции – Объекты не выбраны" нажмите "Выбрать объекты и продолжить"
  5. При запросе на выбор объектов выберите окружности другие объекты на чертеже. Для завершения выбора объектов нажмите клавишу ENTER.

    Цвет окружностей в наборе объектов изменяется на синий.

  6. Если отображается диалоговое окно "Макрос операции – Воспроизведение завершено", нажмите "ОК".

Отмените изменения, выполненные макросом операции. Для этого нажмите кнопку "Отменить" в панели быстрого доступа. Теперь выберите несколько объектов на чертеже и воспроизведите макрос операции BlueCircles. В этом случае макрос операций использует предварительный выбор и запрос на выбор объектов при воспроизведении макроса операции не выдается.


Изменение окружностей в палитре свойств (Краткий справочник)

Вставка блока и изменение значения динамического свойства
Изменение окружностей в палитре свойств
Использование простейшего шаблона
Пользовательский интерфейс > Макросы операций > Примеры макросов операций > Изменение окружностей в палитре свойств >
Изменение окружностей в палитре свойств
Понятие Краткий справочник

Команды

ОПЕРЗАПИСЬ

Запуск рекордера операций

ОПЕРСТОП

Останов работы рекордера операций и предоставление возможности сохранения записанных операций в файле макроса операции

ОКНОСВ

Управление свойствами объектов

ЛЕНТА

Вызов окна ленты

Системные переменные

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание, организация и сохранение чертежей

Изменение окружностей в палитре свойств
Создание чертежа
Создание, организация и сохранение чертежей

Темы в этом разделе

  • Создание чертежа

    Новый чертёж можно создать несколькими способами: с использованием простейшего шаблона или с помощью файла шаблона. В обоих случаях можно выбрать единицы измерения и соглашения по формату единиц.

  • Открытие или сохранение чертежа

    Существуют различные способы поиска и открытия чертежей, в том числе поврежденных. Чертежи можно сохранять и архивировать автоматически.

  • Восстановление файлов чертежей

    В случае повреждения файла чертежа или аварийного завершения работы программы можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки или вернуться к файлу резервной копии.

  • Соблюдение стандартов в чертежах

    Для удобства чтения чертежей задаются стандарты, обеспечивающие единство их оформления. Пользователь может устанавливать стандарты для имён слоев, размерных стилей и других элементов, проверять чертежи на соответствие этим стандартам и, в случае обнаружения нарушений, изменять свойства.


Создание чертежа

Создание, организация и сохранение чертежей
Создание, организация и сохранение чертежей
Использование простейшего шаблона
Создание, организация и сохранение чертежей >
Создание чертежа

Новый чертёж можно создать несколькими способами: с использованием простейшего шаблона или с помощью файла шаблона. В обоих случаях можно выбрать единицы измерения и соглашения по формату единиц.

Темы в этом разделе

  • Использование простейшего шаблона

    Простейший шаблон позволяет быстро подготовить и начать новый чертёж со стандартными параметрами, содержащимися в файле шаблона чертежа.

  • Использование Мастера для создания чертежа

    С помощью Мастера подготовки выполняется пошаговая настройка параметров создаваемого чертежа.

  • Использование файла шаблона для создания чертежа

    В файле шаблона чертежа хранятся стандартные параметры. Файл шаблона можно выбрать из комплекта поставки или создать новый.

  • Задание единиц и формата единиц

    Прежде чем начать рисование, определите единицы измерения, которые будут использоваться для чертежа, и установите формат, точность и другие соглашения для координат и расстояний.

  • Добавление идентификационных сведений к чертежам

    Поиск, учет и обработку чертежей можно упростить, если добавить к ним ключевые слова или другие данные.

  • Ввод информации о географическом местоположении в чертеж


Использование простейшего шаблона (Понятие)

Создание чертежа
Создание чертежа
Использование Мастера для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа >
Использование простейшего шаблона
Понятие Процедура Краткий справочник

Простейший шаблон позволяет быстро подготовить и начать новый чертёж со стандартными параметрами, содержащимися в файле шаблона чертежа.

Создать чертёж на основе простейшего шаблона можно с помощью диалогового окна "Создание нового чертежа" или диалогового окна "Выбор шаблона", а также без использования диалоговых окон. В любом случае можно использовать как команду НОВЫЙ, так и команду СОЗДАТЬ.

Использование диалогового окна "Создание нового чертежа"

Для того чтобы было возможно отображение диалогового окна "Создание нового чертежа", должны быть выполнены следующие условия:

  • Системной переменной STARTUP присваивается значение 1 (вкл.).
  • Системной переменной FILEDIA присвоено значение 1 (вкл.).

Если в диалоговом окне "Настройка" не указан файл шаблона чертежа, то диалоговое окно можно открыть одним из следующих способов:

  • Выберите на панели быстрого доступа [image] "Создать".Введите новый в командной строке.
  • Выберите меню "Файл" [image] "Создать".В командной строке введите "новый".
  • Выберите щелчком "Создать" на панели "Стандартная".

Используя диалоговое окно "Создание нового чертежа", можно создать новый чертёж несколькими способами.

При создании чертежа на основе простейшего шаблона выбирается британская или метрическая система единиц. Этим выбором определяются значения по умолчанию многих системных переменных, отвечающих за управление текстом, размерами, сеткой, шагом и файлом типа линий по умолчанию и файлом образцов штриховки.

  • Британские. Создание нового чертежа на основе британской системы измерений. При создании чертежа используются внутренние значения по умолчанию, а для контура отображения сетки, называемого границамисетки, устанавливаются значения, равные 12 х 9 дюймов.
  • Метрические. Создание нового чертежа на основе метрической системы измерений. При создании чертежа используются внутренние значения по умолчанию, а для контура отображения сетки по умолчанию устанавливаются значения, равные 420 х 290 миллиметров.

Использование диалогового окна "Выбор шаблона"

Диалоговое окно "Выбор шаблона" отображается при выполнении следующих условий:

  • Системной переменной STARTUP присваивается значение 0 (откл.).
  • Системной переменной FILEDIA присваивается значение 1 (вкл.).

Диалоговое окно можно открыть одним из следующих способов:

  • Выберите на панели быстрого доступа [image] "Создать".Введите новый в командной строке.
  • Выберите меню "Файл" [image] "Создать".В командной строке введите "новый".
  • Выберите щелчком "Создать" на панели "Стандартная".

В правом нижнем углу диалогового окна "Выбор шаблона" находится кнопка "Открыть" со стрелкой. Нажав на стрелку, можно выбрать один из двух стандартных шаблонов чертежа: на основе метрических единиц или на основе британских единиц.

Использование файла шаблона по умолчанию

С помощью файла шаблона по умолчанию можно автоматически создать новый чертеж. Диалоговые окна в данном методе не используются.

  • Системной переменной STARTUP присваивается значение 0 (откл.).
  • Системной переменной FILEDIA присваивается значение 1 (вкл.).
  • Задайте файл шаблона чертежа по умолчанию в диалоговом окне "Настройка" на вкладке "Файлы". Щелкните на элементе «Параметры шаблона чертежа» и укажите файл шаблона чертежа и путь к нему.
  • Выберите щелчком "Создать" на панели "Стандартная".

После этого новые чертежи автоматически базируются на указанном файле шаблона чертежа по умолчанию.

Если в диалоговом окне "Настройка" не указан файл шаблона, то командой СОЗДАТЬ вызывается диалоговое окно "Выбор шаблона".


Использование простейшего шаблона (Процедура)

Воспроизведение макроса операции
Использование простейшего шаблона
Использование простейшего шаблона
Создание, организация и сохранение чертежей > Создание чертежа > Использование простейшего шаблона >
Использование простейшего шаблона
Понятие Процедура Краткий справочник

Создание чертежа на основе простейшего шаблона с помощью диалогового окна "Создание чертежа"

Создание чертежа по простейшему шаблону с помощью файла шаблона по умолчанию


Создание чертежа на основе простейшего шаблона с помощью диалогового окна "Создание чертежа" (Процедура)

Использование простейшего шаблона
Использование простейшего шаблона
Использование простейшего шаблона
Создание, организация и сохранение чертежей > Создание чертежа > Использование простейшего шаблона >
Использование простейшего шаблона
Понятие Процедура Краткий справочник

Создание чертежа на основе простейшего шаблона с помощью диалогового окна "Создание чертежа"

  1. При необходимости системным переменным STARTUP и FILEDIA присваивается значение 1. В командной строке введите "startup" и "1", затем введите "filedia" и 1.
  2. Выберите на панели быстрого доступа [image] "Создать".Введите новый в командной строке.
  3. В диалоговом окне "Создание нового чертежа" выберите "Простейший шаблон".
  4. Установите переключатель "Единицы по умолчанию" в положение "Британские" или "Метрические".

    Создаётся новый чертёж с именем drawing1.dwg. Имя, предлагаемое по умолчанию при создании нового чертежа, основано на его порядковом номере в последовательности начатых новых чертежей. Например, для следующего чертежа по умолчанию предлагается имя drawing2.dwg.

Ввод команды: НОВЫЙ
Меню: Файл [image] Создать


Создание чертежа по простейшему шаблону с помощью файла шаблона по умолчанию (Процедура)

Использование простейшего шаблона
Использование простейшего шаблона
Использование Мастера для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Использование простейшего шаблона >
Использование простейшего шаблона
Понятие Процедура Краткий справочник

Создание чертежа по простейшему шаблону с помощью файла шаблона по умолчанию

  1. При необходимости следует присвоить системной переменной STARTUP значение 0, а системной переменной FILEDIA - значение 1. В командной строке введите "startup" и "0", затем введите "filedia" и 1.
  2. Выберите меню "Сервис" [image] "Настройка".В командной строке введите команду "настройка".
  3. В диалоговом окне "Настройка" откройте вкладку "Файлы" и в списке узлов нажмите кнопку мыши на значке "плюс" (+) рядом с элементом "Параметры шаблонов". Нажмите на значке "плюс" (+) рядом с элементом параметра "Папка для шаблона чертежа" и укажите путь к папке.
  4. Нажмите на значке "плюс" (+) для параметра "Шаблон по умолчанию для команды БСОЗДАТЬ" и укажите имя файла с шаблоном по умолчанию.
  5. Нажмите "ОК".
  6. Выберите на панели быстрого доступа [image] "Создать".Введите новый в командной строке.

    Создается новый чертёж с именем drawing1.dwg. Имя, предлагаемое по умолчанию при создании нового чертежа, основано на его порядковом номере в последовательности начатых новых чертежей. Например, для следующего чертежа по умолчанию предлагается имя drawing2.dwg.

Панель:Стандартный
Ввод команды: БСОЗДАТЬ


Использование простейшего шаблона (Краткий справочник)

Изменение окружностей в палитре свойств
Использование простейшего шаблона
Использование Мастера для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Использование простейшего шаблона >
Использование простейшего шаблона
Понятие Процедура Краткий справочник

Команды

НОВЫЙ

Создание нового чертежа

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

БСОЗДАТЬ

Создает новый чертеж с помощью файла шаблона по умолчанию

Системные переменные

FILEDIA

Подавление отображения диалоговых окон навигации к файлу

MEASUREINIT

Признак используемой по умолчанию системы единиц (британская или метрическая) в чертеже, созданном на основе простейшего шаблона

MEASUREMENT

Признак использования британских или метрических единиц в файлах образцов штриховки или типов линий текущего чертежа

STARTUP

Управление отображением диалогового окна "Создание нового чертежа" при создании нового чертежа с помощью команды НОВЫЙ или БСОЗДАТЬ

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование Мастера для создания чертежа (Понятие)

Использование простейшего шаблона
Создание чертежа
Использование файла шаблона для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа >
Использование Мастера для создания чертежа
Понятие Процедура Краткий справочник

С помощью Мастера подготовки выполняется пошаговая настройка параметров создаваемого чертежа.

Существует два вида Мастеров подготовки.

  • Мастер быстрой подготовки.Устанавливает единицы измерения, точность отображаемых единиц и границы сетки.
  • Мастер детальной подготовки. Устанавливает единицы измерения, точность отображаемых единиц и границы сетки. Кроме того, обеспечивает задание параметров угловых величин, таких как формат и точность представления углов, направление нулевого угла и направление отсчета углов.

Эти мастера доступны в диалоговом окне "Создание нового чертежа".


Создание чертежа с помощью Мастера (Процедура)

Использование простейшего шаблона
Использование Мастера для создания чертежа
Использование файла шаблона для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Использование Мастера для создания чертежа >
Использование Мастера для создания чертежа
Понятие Процедура Краткий справочник

Создание чертежа с помощью Мастера

  1. Если необходимо, присвойте системным переменным STARTUP и FILEDIA значение 1.
  2. Выберите на панели быстрого доступа [image] "Создать".Введите новый в командной строке.
  3. В диалоговом окне "Создание нового чертежа" нажмите кнопку "Вызов мастера".
  4. Выберите "Быстрая подготовка" или "Детальная подготовка".
  5. Задайте нужные значения параметров, используя кнопки "Назад" и "Далее" для перехода между страницами Мастера.
  6. На последней странице нажмите кнопку "Готово".
Меню: Файл [image] Создать
Ввод команды: НОВЫЙ


Использование Мастера для создания чертежа (Краткий справочник)

Использование простейшего шаблона
Использование Мастера для создания чертежа
Использование файла шаблона для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Использование Мастера для создания чертежа >
Использование Мастера для создания чертежа
Понятие Процедура Краткий справочник

Команды

НОВЫЙ

Создание нового чертежа

Системные переменные

MEASUREINIT

Признак используемой по умолчанию системы единиц (британская или метрическая) в чертеже, созданном на основе простейшего шаблона

MEASUREMENT

Признак использования британских или метрических единиц в файлах образцов штриховки или типов линий текущего чертежа

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование файла шаблона для создания чертежа (Понятие)

Использование Мастера для создания чертежа
Создание чертежа
Задание единиц и формата единиц
Создание, организация и сохранение чертежей > Создание чертежа >
Использование файла шаблона для создания чертежа
Понятие Процедура Краткий справочник

В файле шаблона чертежа хранятся стандартные параметры. Файл шаблона можно выбрать из комплекта поставки или создать новый.

Файл шаблона чертежа имеет расширение .dwt.

Изменения, вносимые в созданный на основе шаблона чертеж, на сам шаблон влияния не оказывают. Можно использовать один из файлов шаблонов, прилагаемых к программе , или создавать собственные файлы шаблонов.

Создание файла шаблона чертежа

Вместо того, чтобы каждый раз задавать параметры при создании однотипных чертежей, достаточно один раз создать файл шаблона. Обычно в шаблоне хранятся следующие соглашения и параметры:

  • тип и точность представления единиц
  • основные надписи, рамки и логотипы
  • имена слоев
  • значения параметров "Шаг", "Сетка" и "Орто"
  • границы сетки
  • размерные стили
  • текстовые стили
  • типы линий

По умолчанию файлы шаблонов хранятся в папке template, поэтому их достаточно просто найти.

Восстановление файла шаблонов чертежа по умолчанию

Если исходные значения по умолчанию параметров файла шаблона чертежа acad.dwt или acadiso.dwt были изменены, их можно восстановить, создав новый чертёж без шаблона, а затем сохранить его как файл шаблона чертежа, заменяя файлы acad.dwt или acadiso.dwt.

Если пользователем задано рабочее пространство 3D моделирования, то файлами шаблона чертежа по умолчанию являются acad3d.dwt и acadiso3d.dwt.

Можно создать новый чертёж с исходными параметрами по умолчанию, используя команду НОВЫЙ для вызова диалогового окна "Выбор шаблона". Для этого нажать стрелку у кнопки «Открыть» и выбрать из списка одну из опций «Открыть без шаблона».

См. также
    • Использование гиперссылок для создания новых чертежей


Использование файла шаблона для создания чертежа (Процедура)

Использование Мастера для создания чертежа
Использование файла шаблона для создания чертежа
Использование файла шаблона для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Использование файла шаблона для создания чертежа >
Использование файла шаблона для создания чертежа
Понятие Процедура Краткий справочник

Создание чертежа на основе выбранного шаблона

Создание шаблона на основе чертежа

Восстановление параметров простейших шаблонов


Создание чертежа на основе выбранного шаблона (Процедура)

Использование файла шаблона для создания чертежа
Использование файла шаблона для создания чертежа
Использование файла шаблона для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Использование файла шаблона для создания чертежа >
Использование файла шаблона для создания чертежа
Понятие Процедура Краткий справочник

Создание чертежа на основе выбранного шаблона

  1. Выберите на панели быстрого доступа [image] "Создать".Введите новый в командной строке.
  2. В диалоговом окне "Выбор шаблона" выберите шаблон из списка.
  3. Нажмите кнопку "Открыть".

    Создаётся чертёж с именем drawing1.dwg. Имя, предлагаемое по умолчанию при создании нового чертежа, основано на его порядковом номере среди нескольких созданных чертежей. Например, имя, предложенное по умолчанию для следующего чертежа, созданного на основе шаблона, будет drawing2.dwg.

    Для создания чертежа без использования файла шаблона щелкните на стрелке рядом с кнопкой "Открыть". Выберите в списке один из параметров "без шаблона".

Меню: Файл [image] Создать
Ввод команды: НОВЫЙ


Создание шаблона на основе чертежа (Процедура)

Использование файла шаблона для создания чертежа
Использование файла шаблона для создания чертежа
Использование файла шаблона для создания чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Использование файла шаблона для создания чертежа >
Использование файла шаблона для создания чертежа
Понятие Процедура Краткий справочник

Создание шаблона на основе чертежа

  1. Выберите на панели быстрого доступа [image] "Открыть".В командной строке введите "открыть".
  2. В диалоговом окне "Выбор файла" выберите файл, который будет использоваться в качестве шаблона.
  3. Нажмите "ОК".
  4. Для удаления содержимого существующего файла выберите меню "Редактирование" [image] "Стереть".Для удаления содержимого существующего файла в командной строке введите "стереть".
  5. На запрос "Выберите объекты" введите all, чтобы выбрать все объекты, затем введите r (для удаления) и выберите рамку и основную надпись, чтобы исключить их из набора.
  6. Выберите меню "Файл" [image] "Сохранить как".В командной строке введите "сохранитькак".
  7. В диалоговом окне "Сохранение чертежа" в списке "Тип файла" выберите тип файла шаблона чертежа.

    DWT-файлы необходимо сохранять в формате текущей версии программы. Чтобы создать файл DWT в формате предыдущей версии, сначала сохраните чертёж в формате DWG, а затем переименуйте его, сменив расширение .dwg на .dwt.

  8. В поле "Имя файла" введите имя шаблона.
  9. Нажмите кнопку "Сохранить".
  10. Введите описание шаблона.
  11. Нажмите "ОК".

    Созданный шаблон сохраняется в папке template.

Панель:Стандартный
Ввод команды: ОТКРЫТЬ


Восстановление параметров простейших шаблонов (Процедура)

Использование файла шаблона для создания чертежа
Использование файла шаблона для создания чертежа
Задание единиц и формата единиц
Создание, организация и сохранение чертежей > Создание чертежа > Использование файла шаблона для создания чертежа >
Использование файла шаблона для создания чертежа
Понятие Процедура Краткий справочник

Восстановление параметров простейших шаблонов

  1. Выберите на панели быстрого доступа [image] "Создать".Введите новый в командной строке.
  2. В диалоговом окне "Выбор шаблона" выберите стрелку, следующую за кнопкой "Открыть". Выберите в списке один из шаблонов.
    • "Открыть без шаблона - британские" для восстановления acad.dwt
    • "Открыть без шаблона - метрические" для восстановления acadiso.dwt

    Создаётся чертёж с параметрами по умолчанию.

  3. Выберите меню "Файл" [image] "Сохранить как".В командной строке введите "сохранитькак".
  4. В диалоговом окне "Сохранение чертежа" в качестве типа файла выберите "Шаблон чертежа". Сохраните чертёж под исходным именем или под именем acad.dwt с британскими единицами измерения или acadiso.dwt - с метрическими.
  5. Нажмите кнопку "Сохранить".
    ПримечаниеДля рабочего пространства 3D моделирования файлами шаблона чертежа по умолчанию являются acad3d.dwt и acadiso3d.dwt
Ввод команды: НОВЫЙ


Использование файла шаблона для создания чертежа (Краткий справочник)

Использование Мастера для создания чертежа
Использование файла шаблона для создания чертежа
Определение единиц измерения
Создание, организация и сохранение чертежей > Создание чертежа > Использование файла шаблона для создания чертежа >
Использование файла шаблона для создания чертежа
Понятие Процедура Краткий справочник

Команды

НОВЫЙ

Создание нового чертежа

ОТКРЫТЬ

Открытие существующего файла чертежа

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

СОХРАН В

Сохранение копии текущего чертежа под новым именем

Системные переменные

MEASUREMENT

Признак использования британских или метрических единиц в файлах образцов штриховки или типов линий текущего чертежа

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание единиц и формата единиц

Использование файла шаблона для создания чертежа
Создание чертежа
Определение единиц измерения
Создание, организация и сохранение чертежей > Создание чертежа >
Задание единиц и формата единиц
Понятие Процедура

Прежде чем начать рисование, определите единицы измерения, которые будут использоваться для чертежа, и установите формат, точность и другие соглашения для координат и расстояний.

Темы в этом разделе

  • Определение единиц измерения

    Перед началом рисования необходимо указать физический смысл единицы чертежа, исходя из того, какой чертёж требуется создать. Можно преобразовать чертёж в соответствии с различными системами измерения, изменив его масштаб.

  • Соглашения по линейным единицам

    Перед началом рисования необходимо установить формат и количество десятичных знаков для ввода и отображения линейных единиц.

  • Соглашения по угловым единицам

    Соглашения по угловым единицам определяют нулевой угол и направление измерений: по часовой стрелке или против часовой стрелки. Кроме того, следует задать тип единиц и точность представления значений.


Задание единиц и формата единиц (Процедура)

Использование файла шаблона для создания чертежа
Задание единиц и формата единиц
Определение единиц измерения
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц >
Задание единиц и формата единиц
Понятие Процедура

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы

Для задания формата и точности измерения углов


Определение единиц измерения (Понятие)

Задание единиц и формата единиц
Задание единиц и формата единиц
Соглашения по линейным единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц >
Определение единиц измерения
Понятие Процедура Краткий справочник

Перед началом рисования необходимо указать физический смысл единицы чертежа, исходя из того, какой чертёж требуется создать. Можно преобразовать чертёж в соответствии с различными системами измерения, изменив его масштаб.

Каждый создаваемый объект измеряется в единицах чертежа. Перед началом рисования необходимо указать физический смысл единицы чертежа, исходя из того, какой чертёж требуется создать. Затем на основе этого соглашения создается чертёж в натуральную величину. Например, расстояние одной единицы чертежа, как правило, соответствует одному миллиметру, сантиметру, дюйму или футу.

Преобразование единиц чертежа

Если чертёж создан в одной системе измерений (британской или метрической), а затем необходимо перейти в другую систему, с помощью команды МАСШТАБ измените масштаб модели с соответствующим коэффициентом преобразования, чтобы получить правильные значения расстояний и размеров.

Например, чтобы преобразовать чертеж, созданный в дюймах, в чертеж в сантиметрах, нужно изменить масштаб модели с коэффициентом 2,54. Для преобразования сантиметров в дюймы масштабный коэффициент должен быть равен 1/2,54 или 0,3937.

См. также

    • Задание масштаба размеров


Определение единиц измерения (Процедура)

Задание единиц и формата единиц
На уровень вверх ..
Определение единиц измерения
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Определение единиц измерения >
Определение единиц измерения
Понятие Процедура Краткий справочник

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы


Задание формата и точности единиц (Процедура)

Определение единиц измерения
На уровень вверх ..
Определение единиц измерения
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Определение единиц измерения >
Определение единиц измерения
Понятие Процедура Краткий справочник

Задание формата и точности единиц

  1. Выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Единицы". В командной строке введите "единицы".
  2. В диалоговом окне "Единицы чертежа" на вкладке "Длина" выберите формат и точность единицы.

    Параметры единиц и точность иллюстрируются в группе "Пример".

  3. Нажмите "ОК".
Ввод команды: ЕДИНИЦЫ


Преобразование дюймов в сантиметры (Процедура)

Определение единиц измерения
На уровень вверх ..
Определение единиц измерения
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Определение единиц измерения >
Определение единиц измерения
Понятие Процедура Краткий справочник

Преобразование дюймов в сантиметры

  1. Выберите меню "Редактирование" [image] "Масштаб".
  2. В ответ на запрос "Выберите объекты" введите все.

    Выделяются все объекты чертежа для масштабирования.

  3. Введите координаты базовой точки *0,0.

    Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  4. Введите масштабный коэффициент 2,54 (так как 1 дюйм равен 2,54 сантиметра).

    Все объекты чертежа увеличиваются с коэффициентом 2,54 для приведения к размерам в сантиметрах.

Панель:Изменить
Ввод команды: МАСШТАБ


Преобразование сантиметров в дюймы (Процедура)

Определение единиц измерения
На уровень вверх ..
Соглашения по линейным единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Определение единиц измерения >
Определение единиц измерения
Понятие Процедура Краткий справочник

Преобразование сантиметров в дюймы

  1. Выберите меню "Редактирование" [image] "Масштаб".
  2. В ответ на запрос "Выберите объекты" введите все.

    Выделяются все объекты чертежа для масштабирования.

  3. Введите координаты базовой точки *0,0.

    Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  4. Введите масштабный коэффициент 0,3937 (величину, обратную значению 2,54 - количеству сантиметров в 1 дюйме ).

    Все объекты чертежа уменьшаются для приведения к размерам в дюймах.

Панель:Изменить
Ввод команды: МАСШТАБ


Определение единиц измерения (Краткий справочник)

Использование файла шаблона для создания чертежа
Определение единиц измерения
Соглашения по линейным единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Определение единиц измерения >
Определение единиц измерения
Понятие Процедура Краткий справочник

Команды

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

LUNITS

Задание линейных единиц

LUPREC

Количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых не превышает значение текущей системной переменной LUPREC

MEASUREINIT

Признак используемой по умолчанию системы единиц (британская или метрическая) в чертеже, созданном на основе простейшего шаблона

MEASUREMENT

Признак использования британских или метрических единиц в файлах образцов штриховки или типов линий текущего чертежа

UNITMODE

Управление отображением формата единиц

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Соглашения по линейным единицам (Понятие)

Определение единиц измерения
Задание единиц и формата единиц
Соглашения по угловым единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц >
Соглашения по линейным единицам
Понятие Процедура Краткий справочник

Перед началом рисования необходимо установить формат и количество десятичных знаков для ввода и отображения линейных единиц.

Представление стиля отображения и точности расстояний и координат можно выбрать исходя из определенных общепринятых соглашений. Для ввода и отображения значений можно использовать десятичный формат, формат обычной дроби или другое обозначение. Эти параметры влияют на следующие элементы интерфейса

  • Палитра свойств
  • Динамический ввод
  • Команда СПИСОК
  • Команда КООРД
  • Отображение координат в строке состояния
  • Диалоговые окна, в которых отображаются координаты

Тип единиц и точность задаются в диалоговом окне "Единицы чертежа", с помощью Мастера быстрой подготовки или Мастера детальной подготовки.

Округление и точность.

При задании точности единиц значения координат и расстояний округляются. Однако внутренняя точность координат и расстояний всегда сохраняется независимо от отображаемой точности.

Например, если задается точность отображения единиц в десятичном формате, равная 1 (или 0,0), то координаты округляются до одного знака после запятой. Так координаты 0,000, 1,375 отображаются как 0,0, 1,4, но внутренняя точность при этом сохраняется.

Ввод значений расстояния в британском архитектурном формате

При использовании архитектурного формата, чтобы ввести футы и дюймы, после значения футов нужно поставить апостроф ('), например, 72'3. Символ двойной кавычки (") после значения дюймов ставить не обязательно.

ПримечаниеФормат единиц для представления размерных величин задается отдельно от форматов для построения объектов, измерения расстояний и отображения координат точек.
См. также

    • Задание масштаба размеров


Соглашения по линейным единицам (Процедура)

Определение единиц измерения
На уровень вверх ..
Соглашения по линейным единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Соглашения по линейным единицам >
Соглашения по линейным единицам
Понятие Процедура Краткий справочник

Задание формата и точности единиц

Преобразование дюймов в сантиметры

Преобразование сантиметров в дюймы


Задание формата и точности единиц (Процедура)

Соглашения по линейным единицам
На уровень вверх ..
Соглашения по линейным единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Соглашения по линейным единицам >
Соглашения по линейным единицам
Понятие Процедура Краткий справочник

Задание формата и точности единиц

  1. Выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Единицы" . В командной строке введите "единицы".
  2. В диалоговом окне "Единицы чертежа" на вкладке "Длина" выберите формат и точность единицы.

    Параметры единиц и точность иллюстрируются в группе "Пример".

  3. Нажмите "ОК".
Ввод команды: ЕДИНИЦЫ


Преобразование дюймов в сантиметры (Процедура)

Соглашения по линейным единицам
На уровень вверх ..
Соглашения по линейным единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Соглашения по линейным единицам >
Соглашения по линейным единицам
Понятие Процедура Краткий справочник

Преобразование дюймов в сантиметры

  1. Если необходимо, выберите вкладку "Модель", чтобы сделать её текущей.
  2. Выберите меню "Редактирование" [image] "Масштаб".
  3. В ответ на запрос "Выберите объекты" введите все.

    Выделяются все объекты чертежа для масштабирования.

  4. Введите координаты базовой точки *0,0.

    Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  5. Введите масштабный коэффициент 2,54 (так как 1 дюйм равен 2,54 сантиметра).

    Все объекты чертежа увеличиваются с коэффициентом 2,54 для приведения к размерам в сантиметрах.

Панель:Изменить
Ввод команды: МАСШТАБ


Преобразование сантиметров в дюймы (Процедура)

Соглашения по линейным единицам
На уровень вверх ..
Соглашения по угловым единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Соглашения по линейным единицам >
Соглашения по линейным единицам
Понятие Процедура Краткий справочник

Преобразование сантиметров в дюймы

  1. Если необходимо, выберите вкладку "Модель", чтобы сделать ее текущей.
  2. Выберите меню "Редактирование" [image] "Масштаб".
  3. В ответ на запрос "Выберите объекты" введите "all".

    Выделяются все объекты чертежа для масштабирования.

  4. Введите координаты базовой точки *0,0.

    Масштабирование выполняется относительно Мировой системы координат, и в дальнейшем базовые точки чертежа и МСК совпадают.

  5. Введите масштабный коэффициент 0,3937 (величину, обратную значению 2,54 - количеству сантиметров в 1 дюйме ).

    Все объекты чертежа уменьшаются для приведения к размерам в дюймах.

Панель:Изменить
Ввод команды: МАСШТАБ


Соглашения по линейным единицам (Краткий справочник)

Определение единиц измерения
Соглашения по линейным единицам
Соглашения по угловым единицам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Соглашения по линейным единицам >
Соглашения по линейным единицам
Понятие Процедура Краткий справочник

Команды

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

LUNITS

Задание линейных единиц

LUPREC

Количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых не превышает значение текущей системной переменной LUPREC

MEASUREINIT

Признак используемой по умолчанию системы единиц (британская или метрическая) в чертеже, созданном на основе простейшего шаблона

MEASUREMENT

Признак использования британских или метрических единиц в файлах образцов штриховки или типов линий текущего чертежа

UNITMODE

Управление отображением формата единиц

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Соглашения по угловым единицам (Понятие)

Соглашения по линейным единицам
Задание единиц и формата единиц
Добавление идентификационных сведений к чертежам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц >
Соглашения по угловым единицам
Понятие Процедура Краткий справочник

Соглашения по угловым единицам определяют нулевой угол и направление измерений: по часовой стрелке или против часовой стрелки. Кроме того, следует задать тип единиц и точность представления значений.

Представление отображения углов на чертеже можно выбрать исходя из определенных общепринятых соглашений. Можно указать, что измерение положительных значений для углов производится по часовой стрелке или против часовой стрелки, а для нулевого угла может быть задано любое направление (обычно "на восток" или "на север"). Значения углов могут вводиться в градах, радианах, топографических единицах, а также в градусах, минутах и секундах.

Работа с топографическими углами

При использовании топографических единиц измерения углов нужно указывать буквы, обозначающие граничные направления квадранта, в котором находится румб (север, юг, восток, запад). Например, для указания относительных координат конца отрезка длиной 72 фута 8 дюймов с румбом направления N 45° 20'6"E, нужно ввести

@72'8"<n45d20'6"e


Для задания формата и точности измерения углов (Процедура)

Соглашения по линейным единицам
На уровень вверх ..
Добавление идентификационных сведений к чертежам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Соглашения по угловым единицам >
Соглашения по угловым единицам
Понятие Процедура Краткий справочник

Для задания формата и точности измерения углов

  1. Выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Единицы". В командной строке введите "единицы".
  2. В диалоговом окне "Единицы чертежа" на вкладке "Угол" выберите тип угла и точность.

    Тип угла и точность иллюстрируются в группе "Пример".

  3. Для задания направления отсчета угла нажмите кнопку "Направление".

    Направление отсчета определяет точку, от которой измеряются все остальные углы, и направление, в котором они измеряются. По умолчанию нулевым считается направление вправо, а положительное значение угла - против часовой стрелки.

  4. Выберите требуемые параметры.
  5. Нажмите "OK" для закрытия каждого диалогового окна.
Ввод команды: ЕДИНИЦЫ


Соглашения по угловым единицам (Краткий справочник)

Соглашения по линейным единицам
Соглашения по угловым единицам
Добавление идентификационных сведений к чертежам
Создание, организация и сохранение чертежей > Создание чертежа > Задание единиц и формата единиц > Соглашения по угловым единицам >
Соглашения по угловым единицам
Понятие Процедура Краткий справочник

Команды

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

ANGBASE

Задание для базового угла значения 0 в соответствии с текущей ПСК

ANGDIR

Направление отсчета положительных углов

AUNITS

Задание единиц измерения углов

AUPREC

Задание количества десятичных знаков для всех значений углов со статусом "только для чтения", отображаемых в строке состояния, а также для всех редактируемых значений углов, точность которых не превышает текущее значение AUPREC

UNITMODE

Управление отображением формата единиц

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Добавление идентификационных сведений к чертежам (Понятие)

Соглашения по угловым единицам
Создание чертежа
Ввод информации о географическом местоположении в чертеж
Создание, организация и сохранение чертежей > Создание чертежа >
Добавление идентификационных сведений к чертежам
Понятие Процедура Краткий справочник

Поиск, учет и обработку чертежей можно упростить, если добавить к ним ключевые слова или другие данные.

Использование проводника Windows

Свойства чертежа помогают распознать его среди остальных. Некоторые свойства чертежа хранятся в операционной системе; например, тип чертежа, его расположение и размер. В файле чертежа эти значения доступны только для чтения, а изменить их можно только из проводника Windows.

Использование инструмента "Найти"

Инструмент "Найти" может использовать данную информацию в стандартном диалоговом окне выбора файла. Например, возможен поиск всех файлов, созданных в определенный день, или файлов, измененных вчера.

Использование Центра управления

В файлах чертежей можно создавать дополнительные свойства. Файл может содержать сведения об авторе, заголовке, теме, о присвоенных ключевые словах, адресах гиперссылок или путях к папкам, а также прочие свойства. Эти свойства могут использоваться при поиске файлов с помощью вкладки "Дополнительно" окна поиска в Центре управления. Для получения дополнительных сведений о Центре управления см. раздел, посвященный команде ЦУВКЛ, и Доступ к содержимому с помощью Центра управления.

Использование свойств модуля "Диспетчер подшивок"

С помощью "Диспетчера подшивок" можно присваивать название, номер и описание любому листу в подшивке. Дополнительные информацию о подшивках см. в разделе Добавление дополнительных сведений для листов и подшивок.

Отображение свойств в полях

Все эти свойства чертежа могут быть заданы в поле текстового объекта. Дополнительную информацию о полях см. в разделе Использование полей в тексте.


Добавление идентификационных сведений к чертежам (Процедура)

Соглашения по угловым единицам
Добавление идентификационных сведений к чертежам
Добавление идентификационных сведений к чертежам
Создание, организация и сохранение чертежей > Создание чертежа > Добавление идентификационных сведений к чертежам >
Добавление идентификационных сведений к чертежам
Понятие Процедура Краткий справочник

Для просмотра свойств активного чертежа

Описание свойств чертежа


Для просмотра свойств активного чертежа (Процедура)

Добавление идентификационных сведений к чертежам
Добавление идентификационных сведений к чертежам
Добавление идентификационных сведений к чертежам
Создание, организация и сохранение чертежей > Создание чертежа > Добавление идентификационных сведений к чертежам >
Добавление идентификационных сведений к чертежам
Понятие Процедура Краткий справочник

Для просмотра свойств активного чертежа

  1. Выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Свойства чертежа". В командной строке введите "свойстварис".
  2. В диалоговом окне свойств чертежа для получения сведений о свойствах чертежа выберите нужную вкладку.
Ввод команды: СВОЙСТВАРИС


Описание свойств чертежа (Процедура)

Добавление идентификационных сведений к чертежам
Добавление идентификационных сведений к чертежам
Ввод информации о географическом местоположении в чертеж
Создание, организация и сохранение чертежей > Создание чертежа > Добавление идентификационных сведений к чертежам >
Добавление идентификационных сведений к чертежам
Понятие Процедура Краткий справочник

Описание свойств чертежа

  1. Выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Свойства чертежа". В командной строке введите "свойстварис".
  2. Введите информацию о свойствах чертежа на следующих вкладках диалогового окна "Свойства чертежа":
    • Вкладка "Документ".Введите название чертежа, тему, автора, ключевые слова, пояснения и адрес по умолчанию для гиперссылок чертежа. Например, можно указать для чертежей ключевое слово Autodesk, а затем найти все файлы с этим ключевым словом с помощью Центра управления. В качестве базы гиперссылки можно указать адрес в Интернете или путь к папке на сетевом диске.
    • Вкладка "Прочие".Нажмите кнопку "Добавить". В диалоговом окне "Новое свойство" введите имя и значение для свойства, определяемого пользователем. Нажмите "ОК". Новое свойство и его значение отображаются на вкладке "Прочие". Эти сведения могут использоваться для расширенного поиска с помощью Центра управления.
  3. Нажмите "ОК".
Ввод команды: СВОЙСТВАРИС


Добавление идентификационных сведений к чертежам (Краткий справочник)

Соглашения по угловым единицам
Добавление идентификационных сведений к чертежам
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа > Добавление идентификационных сведений к чертежам >
Добавление идентификационных сведений к чертежам
Понятие Процедура Краткий справочник

Команды

СВОЙСТВАРИС

Задание и просмотр свойств текущего чертежа

Системные переменные

CDATE

Сохранение текущих значений даты и времени в десятичном формате

DATE

Сохранение текущих значений даты и времени в формате модифицированной даты по юлианскому календарю

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Ввод информации о географическом местоположении в чертеж

Добавление идентификационных сведений к чертежам
Создание чертежа
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа >
Ввод информации о географическом местоположении в чертеж
Понятие Процедура

Информация о географическом местоположении геометрических элементов может быть вставлена в чертеж.

Темы в этом разделе

  • Обзор использования географического местоположения
  • Задание географического положения для DWG файла

    Информация о географическом положении может быть вставлена в чертеж из приложения Google Earth или путем импорта файлов .kml или .kmz, а также введена вручную.

  • Просмотр информации о географическом положении

    Маркер, описывающий географическое положение, может быть представлен в графической форме (в виде пространства модели) или посредством координат в строке состояния.


Ввод информации о географическом местоположении в чертеж (Процедура)

Добавление идентификационных сведений к чертежам
Ввод информации о географическом местоположении в чертеж
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж >
Ввод информации о географическом местоположении в чертеж
Понятие Процедура

Для импорта файл kml или kmz в чертеж выберите

Для импорта текущего положения из Google Earth выполните следующие действия:

Для ввода географического положения вручную выполните следующие действия:

Просмотр географического маркера возможен следующими способами:

Для просмотра строки состояния координат

Для импорта в чертеж файла .kml или .kmz нужно выполнить следующие действия

Для импорта текущего местоположения из Google Earth необходимо выполнить следующие действия

Для ввода географического положения вручную выполните следующие действия:

Для редактирования географического маркера необходимо выполнить следующие действия:

Для удаления географического маркера необходимо выполнить следующие действия:

Для импорта чертежа, выполненного в системе координат, определенной в другом приложении, необходимо выполнить следующие действия:

Просмотр географического маркера возможен следующими способами:

Для просмотра строки состояния координат


Обзор использования географического местоположения (Понятие)

Ввод информации о географическом местоположении в чертеж
Ввод информации о географическом местоположении в чертеж
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

В чертеж могут вставляться ссылки на географическое местоположение, выраженные в виде реальных координат (X, Y и Z).

Такие чертежи могут пересылаться в другие приложения для просмотра.

Например, имеются следующие возможности:

  • Поместить чертеж на карту, используя AutoCAD Map 3D.
  • Увидеть проект в контексте конкретного пейзажа, используя AutoCAD.

При добавлении географического местоположения в чертеж создается географический маркер.

Такой маркер служит для визуального представления информации о местоположении и помещается в заданную точку чертежа.

Для ввода информации о географическом местоположении могут использоваться следующие средства:

  • Импорт файлов KML или KMZ, содержащих соответствующую информацию.
  • Импорт координат из Google Earth.
  • Использование диалогового окна "Географическое положение".

Информация о местоположении в чертеже представляется следующими данными:

  • Направление на север — вектор, определяющий направление на северный полюс относительно плоскостиXY.
  • Направление вверх — вектор, перпендикулярный плоскостиXY.
  • Данные о географическом местоположении.
См. также
    • Задание географического положения для DWG файла
    • Просмотр информации о географическом положении


Обзор использования географического местоположения (Процедура)

Ввод информации о географическом местоположении в чертеж
На уровень вверх ..
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Обзор использования географического местоположения >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

Для импорта файл kml или kmz в чертеж выберите

Для импорта текущего положения из Google Earth выполните следующие действия:

Для ввода географического положения вручную выполните следующие действия:

Просмотр географического маркера возможен следующими способами:

Для просмотра строки состояния координат


Для импорта файл kml или kmz в чертеж выберите (Процедура)

Обзор использования географического местоположения
На уровень вверх ..
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Обзор использования географического местоположения >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

Для импорта файл kml или kmz в чертеж выберите

  1. Введитегеоположение в командной строке.

    Появляется диалоговое окно "Определение географического положения".

  2. Выберите "Импорт файла .kml или .kmz"

    Появляется диалоговое окно "Импорт файла .kml или .kmz".

  3. Перейдите к нужному файлу KML или KMZ и нажмите "Открыть".

    Импортируется только первое положение из файла KML или KMZ, содержащего информацию о нескольких местоположениях.

    В таком случае нажмите "Закрыть" в появившемся диалоговом окне "Найдено несколько положений".

  4. Выберите или введите точку/значение для положения, используя формат X, Y, Z Мировой системы координат (МСК).
  5. Выберите значение для направления на север.

    После выполнения вышеописанных действий в заданную точку чертежа будет помещен географический маркер для визуального представления информации о местоположении.

    Данный маркер отображается неодинаково на 2D ( [image]) и 3D ( [image]) видах.


Для импорта текущего положения из Google Earth выполните следующие действия: (Процедура)

Обзор использования географического местоположения
На уровень вверх ..
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Обзор использования географического местоположения >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

Для импорта текущего положения из Google Earth выполните следующие действия:

  1. Введитегеоположение в командной строке.

    Появляется диалоговое окно "Определение географического положения".

    ПримечаниеДальнейшие действия возможны при установленном и открытом приложении Google Earth, в котором выбрано конкретное географическое положение.
  2. Выберите импорт текущего положения из Google Earth.

    Появляется диалоговое окно "Импорт из Google Earth".

  3. Нажмите кнопку "Продолжить".
  4. Выберите или введите точку/значение для положения, используя формат X, Y, Z Мировой системы координат (МСК).
  5. Выберите значение для направления на север.

    Географический маркер помещается в указанную точку на чертеже.

    Данный маркер отображается неодинаково на 2D ( [image]) и 3D ( [image]) видах.


Для ввода географического положения вручную выполните следующие действия: (Процедура)

Обзор использования географического местоположения
На уровень вверх ..
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Обзор использования географического местоположения >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

Для ввода географического положения вручную выполните следующие действия:

  1. Введитегеоположение в командной строке.

    Появляется диалоговое окно "Определение географического положения".

  2. Выберите "Ввести значения положения".

    Появляется диалоговое окно "Географическое положение".

  3. Выберите формат отображения широты и долготы (не обязательно).

    Значения широты, долготы и часового пояса можно ввести вручную или нажать кнопку "Использовать карту" (шаги с четвертого по восьмой) для визуального выбора значений.

  4. Выберите "Использовать карту" (не обязательно).

    Появляется диалоговое окно "Выбор географического положения".

  5. Из раскрывающегося списка "Область" выберите подходящую область.
  6. Из раскрывающегося списка "Ближайший город" выберите ближайший город, находящийся в нужном часовом поясе.

    Значение "Часовой пояс" обновляется автоматически, исходя из выбора значения "Ближайший город".

  7. Нажмите "ОК".

    Появляется диалоговое окно "Часовой пояс обновлен".

  8. Выберите "Принять обновленный часовой пояс" для подтверждения выбора. Выберите "Вернуться в предыдущее диалоговое окно" для выбора другого часового пояса.

    Исходя из величин, указанных в диалоговом окне "Выбор географического положения", автоматически формируются значения широты, долготы, направления и часового пояса.

  9. Выберите "Указать точку" ( [image]) для задания координат X, Y, Z.

    Данные значения можно также ввести вручную.

  10. Воспользуйтесь стрелками "вверх" и "вниз" для задания уровня.
  11. Выберите кнопку "Указать точку" ( [image]) для задания угла.

    Угол направления на север вычисляется при выборе точки со ссылкой на географическое положение.

  12. Также для задания угла можно перетащить стрелку компаса [image].

    При выборе угла значение задается в градусах.

  13. При необходимости задайте направление вверх.
  14. Нажмите "ОК".

  15. Географический маркер помещается в указанную точку на чертеже.

    Данный маркер отображается неодинаково на 2D ( [image]) и 3D ( [image]) видах.


Просмотр географического маркера возможен следующими способами: (Процедура)

Обзор использования географического местоположения
На уровень вверх ..
Обзор использования географического местоположения
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Обзор использования географического местоположения >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

Просмотр географического маркера возможен следующими способами:

  1. Введите в командной строке "GEOMARKERVISIBILITY".
  2. Введите 1 в качестве параметра и нажмите клавишу "Enter".
  3. Введите геоположение в командной строке.

    Географический маркер можно вставить следующим образом.

    Географический маркер вставляется по заданным координатам.


Для просмотра строки состояния координат (Процедура)

Обзор использования географического местоположения
На уровень вверх ..
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Обзор использования географического местоположения >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

Для просмотра строки состояния координат

  1. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Вставьте географический маркер любым из возможных способов.

  2. Выберите правой кнопкой мыши строку состояния. Выберите "Географический".

    В строке состояния отобразятся значения широты и долготы для данного географического положения.


Обзор использования географического местоположения (Краткий справочник)

Добавление идентификационных сведений к чертежам
Обзор использования географического местоположения
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Обзор использования географического местоположения >
Обзор использования географического местоположения
Понятие Процедура Краткий справочник

Команда

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

Системные переменные

GEOLATLONGFORMAT

Управление форматом значений широты и долготы в диалоговом окне "Географическое положение" и в строке состояния координат в географическом режиме

GEOMARKERVISIBILITY

Управление отображением географических маркеров


Задание географического положения для DWG файла (Понятие)

Обзор использования географического местоположения
Ввод информации о географическом местоположении в чертеж
Просмотр информации о географическом положении
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Информация о географическом положении может быть вставлена в чертеж из приложения Google Earth или путем импорта файлов .kml или .kmz, а также введена вручную.

Импорт файлов KML или KMZ

Возможен импорт информации о местоположении (широта, долгота и высота), указанной в файлах KML или KMZ.

После импорта задайте положение на чертеже и направление на север или угол.

ПримечаниеИз файлов KML или KMZ, определяющих несколько положений, используются координаты только первой позиции.

Импорт местоположения из Google Earth

Можно перейти к определенному местоположению в Google Earth и импортировать информацию о местоположении в файл чертежа.

ПримечаниеДальнейшие действия возможны при установленном и открытом приложении Google Earth, в котором выбрано конкретное географическое положение.

На чертеже нужно указать точку для привязки координат местоположения, взятых из Google Earth.

Используйте диалоговое окно "Географическое положение".

Значения широты, долготы, направления на север, уровня и направления вверх могут быть введены вручную.

Для запуска анимации нажмите стрелку "Воспроизведение".

В диалоговом окне "Выбор географического положения" для вставки местоположения также можно использовать название города или другого известного географического объекта.

Широта и долгота могут задаваться в десятичных долях градуса или в градусах, минутах и секундах.


Задание географического положения для DWG файла (Процедура)

Обзор использования географического местоположения
На уровень вверх ..
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Для импорта в чертеж файла .kml или .kmz нужно выполнить следующие действия

Для импорта текущего местоположения из Google Earth необходимо выполнить следующие действия

Для ввода географического положения вручную выполните следующие действия:

Для редактирования географического маркера необходимо выполнить следующие действия:

Для удаления географического маркера необходимо выполнить следующие действия:

Для импорта чертежа, выполненного в системе координат, определенной в другом приложении, необходимо выполнить следующие действия:


Для импорта в чертеж файла .kml или .kmz нужно выполнить следующие действия (Процедура)

Задание географического положения для DWG файла
На уровень вверх ..
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Для импорта в чертеж файла .kml или .kmz нужно выполнить следующие действия

  1. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Появляется диалоговое окно "Определение географического положения".

  2. Выберите "Импорт файла .kml или .kmz"

    Появляется диалоговое окно "Импорт файла .kml или .kmz".

  3. Перейдите к нужному файлу KML или KMZ и нажмите "Открыть".

    Импортируется только первое положение из файла KML или KMZ, содержащего информацию о нескольких местоположениях.

    В таком случае нажмите "Закрыть" в появившемся диалоговом окне "Найдено несколько положений".

  4. Выберите или введите точку/значение для положения, используя формат X, Y, Z Мировой системы координат (МСК).
  5. Выберите значение для направления на север.

    После выполнения вышеописанных действий в заданную точку чертежа будет помещен географический маркер для визуального представления информации о местоположении.

    Данный маркер отображается неодинаково на 2D ( [image]) и 3D ( [image]) видах.


Для импорта текущего местоположения из Google Earth необходимо выполнить следующие действия (Процедура)

Задание географического положения для DWG файла
На уровень вверх ..
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Для импорта текущего местоположения из Google Earth необходимо выполнить следующие действия

  1. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Появляется диалоговое окно "Определение географического положения".

    ПримечаниеДальнейшие действия возможны при установленном и открытом приложении Google Earth, в котором выбрано конкретное географическое положение.
  2. Выберите импорт текущего положения из Google Earth.

    Появляется диалоговое окно "Импорт из Google Earth".

  3. Нажмите кнопку "Продолжить".
  4. Выберите или введите точку/значение для положения, используя формат X, Y, Z Мировой системы координат (МСК).
  5. Выберите значение для направления на север.

    После выполнения вышеописанных действий в заданную точку чертежа будет помещен географический маркер для визуального представления информации о местоположении.

    Данный маркер отображается неодинаково на 2D ( [image]) и 3D ( [image]) видах.


Для ввода географического положения вручную выполните следующие действия: (Процедура)

Задание географического положения для DWG файла
На уровень вверх ..
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Для ввода географического положения вручную выполните следующие действия:

  1. Выберите вкладку "Визуализация" [image] панель "Время и расположение" [image] "Расположение".В командной строке введите "геоположение".

    Появляется диалоговое окно "Определение географического положения".

  2. Выберите "Ввести значения положения".

    Появляется диалоговое окно "Географическое положение".

  3. Выберите формат отображения широты и долготы (не обязательно).

    Значения широты, долготы и часового пояса можно ввести вручную или нажать кнопку "Использовать карту" (шаги с четвертого по восьмой) для визуального выбора значений.

  4. Выберите "Использовать карту" (не обязательно).

    Появляется диалоговое окно "Выбор географического положения".

  5. Из раскрывающегося списка "Область" выберите подходящую область.
  6. Из раскрывающегося списка "Ближайший город" выберите ближайший город, находящийся в нужном часовом поясе.

    Значение "Часовой пояс" обновляется автоматически, исходя из выбора значения "Ближайший город".

  7. Нажмите "ОК".

    Появляется диалоговое окно "Часовой пояс обновлен".

  8. Выберите "Принять обновленный часовой пояс" для подтверждения выбора. Выберите "Вернуться в предыдущее диалоговое окно" для выбора другого часового пояса.

    Исходя из величин, указанных в диалоговом окне "Выбор географического положения", автоматически формируются значения широты, долготы, направления и часового пояса.

  9. Выберите "Указать точку" ( [image]) для задания координат X, Y, Z.

    Для ввода значений вручную необходимо выполнить следующие действия.

  10. Воспользуйтесь стрелками "вверх" и "вниз" для задания уровня.
  11. Выберите кнопку "Указать точку" ( [image]) для задания угла.

    Угол направления на север вычисляется при выборе точки со ссылкой на географическое положение.

  12. Также для задания угла можно перетащить стрелку компаса [image].

    При выборе угла значение задается в градусах.

  13. При необходимости задайте направление вверх.
  14. Нажмите "ОК".

  15. Географический маркер помещается в указанную точку на чертеже.

    Данный маркер отображается неодинаково на 2D ( [image]) и 3D ( [image]) видах.


Для редактирования географического маркера необходимо выполнить следующие действия: (Процедура)

Задание географического положения для DWG файла
На уровень вверх ..
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Для редактирования географического маркера необходимо выполнить следующие действия:

  1. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Появляется диалоговое окно "Положение уже существует".

  2. Выберите "Редактировать существующее географическое положение".

    Появляется диалоговое окно "Географическое положение".

  3. Поправьте существующие значения требуемым образом.
  4. Нажмите "ОК".


Для удаления географического маркера необходимо выполнить следующие действия: (Процедура)

Задание географического положения для DWG файла
На уровень вверх ..
Задание географического положения для DWG файла
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Для удаления географического маркера необходимо выполнить следующие действия:

  1. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Появляется диалоговое окно "Положение уже существует".

  2. Выберите "Удалить географическое положение".

    Появляется диалоговое окно "Удаление".

  3. Нажмите "Да" в соответствующем диалоговом окне.


Для импорта чертежа, выполненного в системе координат, определенной в другом приложении, необходимо выполнить следующие действия: (Процедура)

Задание географического положения для DWG файла
На уровень вверх ..
Просмотр информации о географическом положении
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Для импорта чертежа, выполненного в системе координат, определенной в другом приложении, необходимо выполнить следующие действия:

  1. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Появляется диалоговое окно "Система координат уже существует".

  2. Выберите одну из следующих опций:
    • "Оставить существующую систему координат" — в AutoCAD не выполняется преобразование внешней системы координат в систему координат LL84.
    • "Преобразовать в AutoCAD и редактировать" — выполняется преобразование системы координат в систему LL84, и отображается диалоговое окно "Положение уже существует".
  3. Отредактируйте географическое положение, используя имеющиеся опции.


Задание географического положения для DWG файла (Краткий справочник)

Обзор использования географического местоположения
Задание географического положения для DWG файла
Просмотр информации о географическом положении
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Задание географического положения для DWG файла >
Задание географического положения для DWG файла
Понятие Процедура Краткий справочник

Команда

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

Системные переменные

GEOLATLONGFORMAT

Управление форматом значений широты и долготы в диалоговом окне "Географическое положение" и в строке состояния координат в географическом режиме

GEOMARKERVISIBILITY

Управление отображением географических маркеров


Просмотр информации о географическом положении (Понятие)

Задание географического положения для DWG файла
Ввод информации о географическом местоположении в чертеж
Открытие или сохранение чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж >
Просмотр информации о географическом положении
Понятие Процедура Краткий справочник

Маркер, описывающий географическое положение, может быть представлен в графической форме (в виде пространства модели) или посредством координат в строке состояния.

Просмотр географического маркера осуществляется одним из способов:

  • Изображение положения географического маркера в Мировой системе координат (МСК), наложенное на вид пространства модели.

    Данный маркер отображается неодинаково на 2D ( [image]) и 3D ( [image]) видах.

    Примечание Присвойте системной переменной GEOMARKERVISIBILITY значение 1 для просмотра изображения географического маркера в чертеже.
  • Координаты в строке состояния соответствуют значениям широты или долготы позиции курсора в МСК.


Просмотр информации о географическом положении (Процедура)

Задание географического положения для DWG файла
На уровень вверх ..
Просмотр информации о географическом положении
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Просмотр информации о географическом положении >
Просмотр информации о географическом положении
Понятие Процедура Краткий справочник

Просмотр географического маркера возможен следующими способами:

Для просмотра строки состояния координат


Просмотр географического маркера возможен следующими способами: (Процедура)

Просмотр информации о географическом положении
На уровень вверх ..
Просмотр информации о географическом положении
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Просмотр информации о географическом положении >
Просмотр информации о географическом положении
Понятие Процедура Краткий справочник

Просмотр географического маркера возможен следующими способами:

  1. Введите в командной строке "GEOMARKERVISIBILITY".
  2. Введите 1 в качестве значения.
  3. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Вставьте географический маркер любым из возможных способов.

    Географический маркер вставляется в точку с указанными координатами.


Для просмотра строки состояния координат (Процедура)

Просмотр информации о географическом положении
На уровень вверх ..
Открытие чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Просмотр информации о географическом положении >
Просмотр информации о географическом положении
Понятие Процедура Краткий справочник

Для просмотра строки состояния координат

  1. ВведитеГЕОПОЛОЖЕНИЕ в командной строке.

    Вставьте географический маркер любым из возможных способов.

  2. Щелкните правой кнопкой мыши в строке состояния. Выберите "Географический".

    В строке состояния отобразятся значения широты и долготы для данного географического положения.


Просмотр информации о географическом положении (Краткий справочник)

Задание географического положения для DWG файла
Просмотр информации о географическом положении
Открытие чертежа
Создание, организация и сохранение чертежей > Создание чертежа > Ввод информации о географическом местоположении в чертеж > Просмотр информации о географическом положении >
Просмотр информации о географическом положении
Понятие Процедура Краткий справочник

Команда

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

Системные переменные

GEOLATLONGFORMAT

Управление форматом значений широты и долготы в диалоговом окне "Географическое положение" и в строке состояния координат в географическом режиме

GEOMARKERVISIBILITY

Управление отображением географических маркеров


Открытие или сохранение чертежа

Просмотр информации о географическом положении
Создание, организация и сохранение чертежей
Открытие чертежа
Создание, организация и сохранение чертежей >
Открытие или сохранение чертежа

Существуют различные способы поиска и открытия чертежей, в том числе поврежденных. Чертежи можно сохранять и архивировать автоматически.

Темы в этом разделе

  • Открытие чертежа

    Открытие чертежей выполняется так же, как и в других приложениях Windows. Кроме того, возможен выбор одного из альтернативных методов.

  • Частичное открытие и частичная загрузка

    Для увеличения производительности при работе с большими чертежами можно открывать только отдельные слои и виды чертежа.

  • Работа с несколькими чертежами

    Имеется возможность предварительного просмотра и переключения между открытыми чертежами и листами чертежа. Также предусмотрена возможность передачи информации между чертежами.

  • Сохранение чертежей

    Сохранение чертежей для дальнейшего использования выполняется так же, как и в других приложениях Microsoft Windows. Можно установить режим автоматического сохранения файлов и резервных копий, а также сохранения только выбранных объектов.

  • Поиск чертежей

    С помощью фильтров, задающих имя искомого файла, папку, дату, а также значения определенных свойств, таких как ключевые слова в чертежах, можно выполнять поиск чертежей или текстовых строк, содержащих определенное слово или фразу.

  • Укажите "Пути поиска" и "Местоположения файлов"

    Имеется возможность задания путей доступа для поиска вспомогательных файлов, таких как шрифты, чертежи, типы линий, образцы штриховки и т.д. Можно также указать папку для хранения временных файлов, что важно при работе в сети.


Открытие чертежа (Понятие)

Открытие или сохранение чертежа
Открытие или сохранение чертежа
Частичное открытие и частичная загрузка
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа >
Открытие чертежа
Понятие Процедура Краткий справочник

Открытие чертежей выполняется так же, как и в других приложениях Windows. Кроме того, возможен выбор одного из альтернативных методов.

Для открытия чертежа можно

  • Использовать команду "Открыть" в меню "Файл" или панель быстрого доступа, чтобы вывести диалоговое окно "Выбор файла". При отключении системной переменной FILEDIA (присвоено значение 0) вместо диалогового окна навигации по файлам отображается командная строка.
  • Дважды нажать на чертеже в проводнике Windows, чтобы запустить AutoCAD® и открыть чертеж. Если программа уже запущена, то чертеж откроется в текущем, а не во втором сеансе.
  • Перетащить чертеж из проводника Windows в AutoCAD.

    Если расположить чертеж за пределами области рисования, например, в командной строке или в пустом месте рядом с панелями инструментов, то чертеж откроется. Если же перетащить чертеж в область рисования другого, уже открытого чертежа, то произойдет его вставка в текущий чертеж в качестве блока.

  • Для открытия чертежей используйте Центр управления.
  • Для поиска и открытия чертежей в подшивке используйте Диспетчер подшивок.

Работа с чертежами в процессе загрузки

Работа с чертежами может выполняться до завершения загрузки. Это особенно удобно при работе с большими чертежами и позволяет немедленно приступить к работе с ними. Чтобы воспользоваться данной возможностью, необходимо выполнение следующих трех условий.

  • Чертеж должен быть сохранен в пространстве листа.
  • Системная переменная OPENPARTIAL должна быть включена (присвоено значение 1).
  • Системной переменной INDEXCTL должно быть присвоено значение, отличное от нуля.

При соблюдении данных условий возможно создание и изменение видимых объектов, панорамирование или зумирование, выключение или замораживание слоев, а также выполнение любых других операций, не требующих отображения невидимых при последнем сохранении чертежа.

ПримечаниеПри соблюдении данных условий не гарантируется корректная работа средства быстрого просмотра.

Файлы чертежей TrustedDWG™

Файлы DWG, DWT и DWS, созданные в приложениях Autodesk и в приложениях на основе RealDWG™, являются доверяемыми файлами в Autodesk. При открытии файла TrustedDWG в строке состояния приложения или строке состояния чертежа отображается указанный ниже значок.

Если системной переменной DWGCHECK присвоено значение "Вкл." (1), то открывается окно предупреждения, если

  • Формат файла чертежа — это формат версии 14 AutoCAD или более поздней версии и
  • Файл чертежа не был сохранен в приложении Autodesk или приложении на базе RealDWG.

Для получения подробной информации по TrustedDWG щелкните на значке TrustedDWG.

Восстановление поврежденных файлов чертежей

При определенных обстоятельствах возможно повреждение файла чертежа. Это может привести к аппаратным проблемам или ошибкам при передаче. Если файл чертежа поврежден, то его можно восстановить. См. раздел Восстановление файлов чертежей .

Изменение папки чертежей, используемой по умолчанию

При работе с AutoCAD папка Мои документы является путем по умолчанию во всех стандартных диалоговых окнах выбора файлов. Кроме того, можно настроить в AutoCAD путь по умолчанию, заменив стандартную папку чертежа с помощью системной переменной REMEMBERFOLDERS.

См. также

    • Краткий обзор Центра управления

    • Открытие и сохранение файлов в Интернете

    • Работа с листами в подшивке


Открытие чертежа (Процедура)

Просмотр информации о географическом положении
Открытие чертежа
Открытие чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Открытие чертежа >
Открытие чертежа
Понятие Процедура Краткий справочник

Открытие чертежа

Изменение папки чертежей, используемой по умолчанию


Открытие чертежа (Процедура)

Открытие чертежа
Открытие чертежа
Открытие чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Открытие чертежа >
Открытие чертежа
Понятие Процедура Краткий справочник

Открытие чертежа

  1. Выберите на панели быстрого доступа [image] "Открыть".Введите в командной строке "открыть".
  2. В диалоговом окне "Выбор файла" выделите один или несколько файлов. Нажмите кнопку "Открыть".

    Для быстрого доступа к часто используемым файлам и папкам можно использовать значки в левой части диалогового окна. Путем перетаскивания значков можно изменять порядок их расположения. Добавление, редактирование и удаление значков выполняется с помощью контекстного меню, вызываемого щелчком правой кнопки мыши на нужном значке.

Меню: Выберите пункт меню "Файл" [image] "Открыть".
Панель:Стандартный
Ввод команды: ОТКРЫТЬ


Изменение папки чертежей, используемой по умолчанию (Процедура)

Открытие чертежа
Открытие чертежа
Частичное открытие и частичная загрузка
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Открытие чертежа >
Открытие чертежа
Понятие Процедура Краткий справочник

Изменение папки чертежей, используемой по умолчанию

  1. В командной строке введите "rememberfolders", а затем введите 0.
  2. На рабочем столе Windows нажмите правой кнопкой мыши на значке AutoCAD. Выберите "Свойства".
  3. Перейдите на вкладку "Ярлык".
  4. В поле "Рабочий каталог" введите путь, который должен устанавливаться текущим по умолчанию при открытии или сохранении чертежей.
  5. Нажмите "ОК".


Открытие чертежа (Краткий справочник)

Просмотр информации о географическом положении
Открытие чертежа
Частичное открытие и частичная загрузка
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Открытие чертежа >
Открытие чертежа
Понятие Процедура Краткий справочник

Команды

КЕМОТКРЫТ

Вывод информации о том, кем открыт тот или иной файл чертежа

ОТКРЫТЬ

Открытие существующего файла чертежа

Системные переменные

DWGCHECK

Управление проверкой чертежей на потенциальные ошибки при их открытии

FILEDIA

Подавление отображения диалоговых окон навигации к файлу

INDEXCTL

Управление созданием слоевых и пространственных индексов и сохранением их в файле чертежа

OPENPARTIAL

Управление возможностью работать с файлом чертежа до его полного открытия

REMEMBERFOLDERS

Управление путем по умолчанию, который отображается в стандартных диалоговых окнах выбора файлов

ROAMABLEROOTPREFIX

Полный путь к корневой папке, в которую были установлены перемещаемые адаптируемые файлы

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Частичное открытие и частичная загрузка (Понятие)

Открытие чертежа
Открытие или сохранение чертежа
Работа с несколькими чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа >
Частичное открытие и частичная загрузка
Понятие Процедура Краткий справочник

Для увеличения производительности при работе с большими чертежами можно открывать только отдельные слои и виды чертежа.

При работе с большими чертежами можно пользоваться режимом "Открыть частично" команды ОТКРЫТЬ, чтобы выбрать геометрию вида и слоя (только графические объекты), с которыми предполагается работать в чертеже. Например, при загрузке геометрической структуры из вида ГРАНИЦЫ и слоя SITE, в чертёж загружаются все объекты этого слоя, попадающие в вид "Границы".

Редактировать можно только те объекты, которые загружены в файл чертежа, но доступны все именованные объекты частично открытого чертежа. К именованным объектам относятся слои, виды, блоки, размерные стили, текстовые стили, конфигурации видовых экранов, описания компоновки листов, ПСК и типы линий.

Разделив большой чертёж на секторы, можно загружать и редактировать отдельные части чертежа. Например, пусть на карте города необходимо отредактировать юго-восточный сектор (сектор D3 на рисунке). Задание отдельного вида для этого сектора избавляет пользователя от необходимости загружать весь чертёж целиком. Другой пример: чтобы изменить номера земельных участков на карте, можно загрузить информацию только с одного конкретного слоя.

Использование команды ЗАГРЧАСТЬ позволяет загружать в частично открытый чертёж дополнительные объекты из вида, выбранной области или слоя. Настройка "Частичное открытие" доступна только для чертежей формата AutoCAD 2000 или формата более поздней версии.


Частичное открытие и частичная загрузка (Процедура)

Открытие чертежа
Частичное открытие и частичная загрузка
Частичное открытие и частичная загрузка
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Частичное открытие и частичная загрузка >
Частичное открытие и частичная загрузка
Понятие Процедура Краткий справочник

Частичное открытие чертежа

Загрузка дополнительной геометрии в частично открытый чертеж


Частичное открытие чертежа (Процедура)

Частичное открытие и частичная загрузка
Частичное открытие и частичная загрузка
Частичное открытие и частичная загрузка
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Частичное открытие и частичная загрузка >
Частичное открытие и частичная загрузка
Понятие Процедура Краткий справочник

Частичное открытие чертежа

  1. Выберите на панели быстрого доступа [image] "Открыть". Введите в командной строке "открыть".
  2. В диалоговом окне "Выбор файла" выберите чертеж.
  3. Нажмите на стрелке рядом с кнопкой "Открыть". Выберите "Открыть частично".
  4. В диалоговом окне "Частичное открытие" выберите вид. По умолчанию предлагается вид ГРАНИЦЫ.

    Геометрию можно загрузить только из видов пространства модели, имеющихся в данном чертеже.

  5. Выберите один или несколько слоев.

    Если не выбран ни один слой, загружается только структура слоёв чертежа, но не объекты, содержащиеся в нем. Если не заданы слои, объекты не загружаются даже в том случае, если указан вид для загрузки. Следует иметь в виду, что создавая объекты на слое, геометрия с которого не загружена, пользователь может осуществлять построения поверх имеющихся, но не загруженных в чертёж объектов.

    ПримечаниеСлои, зависимые от внешних ссылок, появляются в списке "Загрузка объектов по слоям", только если при сохранении выбранного чертежа системной переменной VISRETAIN было присвоено значение 1. Слои, созданные во внешнем файле после загрузки ссылки в чертеж, в этом списке не выводятся.
  6. Если чертёж содержит пространственный индекс, можно установить флажок "По пространственному индексу".

    Пространственный индекс - это список объектов и их положений в пространстве. Пространственный индекс используется для поиска фрагмента считываемого чертежа. Это сокращает время, необходимое для открытия чертежа.

  7. Если в чертеже есть внешние ссылки, но загружать их не требуется, установите флажок "Выгрузить ссылки при открытии".
    ПримечаниеЕсли частично открывается чертеж, содержащий внедренную внешнюю ссылку, то только загруженная ее часть (определяемая выбранным видом) связывается с частично открытым чертежом.
  8. Нажмите кнопку "Открыть".

    В частично открытый чертёж можно загружать дополнительную информацию.

Меню: Выберите пункт меню "Файл" [image] "Открыть".
Ввод команды: ОТКРЧАСТЬ


Загрузка дополнительной геометрии в частично открытый чертеж (Процедура)

Частичное открытие и частичная загрузка
Частичное открытие и частичная загрузка
Работа с несколькими чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Частичное открытие и частичная загрузка >
Частичное открытие и частичная загрузка
Понятие Процедура Краткий справочник

Загрузка дополнительной геометрии в частично открытый чертеж

  1. Выберите меню "Файл" [image] "Частичная загрузка".В командной строке введите "загрчасть".

    Пункт меню "Частичная загрузка" становится доступен только после выполнения частичного открытия текущего чертежа.

  2. В диалоговом окне "Частичная загрузка" выберите вид или нажмите кнопку "Указать рамкой" для задания вида.

    По умолчанию предлагается вид "Границы". Геометрию можно загрузить только из видов пространства модели, имеющихся в данном чертеже.

  3. Выберите один или несколько слоев.

    Если не выбрано ни одного слоя для загрузки, геометрия слоев в чертёж не загружается, но все слои присутствуют в чертеже. Если не задана геометрия слоя для загрузки в чертёж, геометрия не загружается даже в том случае, если для загрузки задана геометрия из вида. Следует иметь в виду, что создавая объекты на слое, геометрия с которого не загружена, пользователь может осуществлять построения поверх имеющейся, но не загруженной в чертёж геометрии. Выгрузить геометрию, загруженную в текущий чертеж, нельзя.

  4. Нажмите кнопку "Открыть".
Ввод команды: ЗАГРЧАСТЬ


Частичное открытие и частичная загрузка (Краткий справочник)

Открытие чертежа
Частичное открытие и частичная загрузка
Предварительный просмотр открытых чертежей и листов
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Частичное открытие и частичная загрузка >
Частичное открытие и частичная загрузка
Понятие Процедура Краткий справочник

Команды

ЗАГРЧАСТЬ

Дополнительная загрузка геометрии в частично открытый чертеж

ОТКРЧАСТЬ

Загрузка геометрии и именованных объектов в чертеж из выбранного вида или слоя

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с несколькими чертежами

Частичное открытие и частичная загрузка
Открытие или сохранение чертежа
Предварительный просмотр открытых чертежей и листов
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа >
Работа с несколькими чертежами
Понятие Процедура

Имеется возможность предварительного просмотра и переключения между открытыми чертежами и листами чертежа. Также предусмотрена возможность передачи информации между чертежами.

Темы в этом разделе

  • Предварительный просмотр открытых чертежей и листов

    Используя быстрый просмотр, можно легко осуществлять предварительный просмотр и переключение между открытыми чертежами, а также между пространством модели и листами открытого чертежа. Чертежи и листы отображаются в виде графических образцов, называемых эскизами быстрого просмотра, в нижней части главного окна приложения.

  • Переключение между открытыми чертежами

    Средство быстрого просмотра чертежей формирует двухуровневую структуру для предварительного просмотра и переключения между всеми открытыми чертежами и листами чертежей.

  • Переключение между листами текущего чертежа

    Предварительный просмотр и переключение между пространством модели и листами текущего чертежа средствами быстрого просмотра листов.

  • Передача информации между открытыми чертежами

    Информацию можно легко перемещать между чертежами, открытыми в одном сеансе.


Работа с несколькими чертежами (Процедура)

Частичное открытие и частичная загрузка
Работа с несколькими чертежами
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами >
Работа с несколькими чертежами
Понятие Процедура

Для отображения чертежей для быстрого просмотра

Для предварительного просмотра и переключения между открытыми чертежами

Для просмотра и переключения между листами в чертеже

Для изменения размера эскиза быстрого просмотра

Для просмотра эскиза быстрого просмотра, не отображенного в области окна приложения

Для закрепления строки эскизов быстрого просмотра

Для создания чертежа средствами быстрого просмотра

Для открытия чертежа средствами быстрого просмотра

Для сохранения чертежа средствами быстрого просмотра

Для сохранения всех открытых чертежей средствами быстрого просмотра

Для закрытия чертежа средствами быстрого просмотра

Для закрытия всех чертежей средствами быстрого просмотра

Для закрытия средствами быстрого просмотра всех чертежей за исключением текущего рабочего чертежа

Для предварительного просмотра пространства модели и листов чертежа

Для обновления образца следует

Для задания пространства модели или листа в качестве текущего

Для задания параметров листа средствами быстрого просмотра

Для создания листа средствами быстрого просмотра

Для переименования листа средствами быстрого просмотра

Для импорта листа из шаблона средствами быстрого просмотра

Для упорядочивания листов средствами быстрого просмотра

Для копирования листа средствами быстрого просмотра

Для упорядочивания листов средствами быстрого просмотра

Для активации предыдущего листа средствами быстрого просмотра

Для выбора всех листов средствами быстрого просмотра

Для экспорта листа в пространство модели средствами быстрого просмотра

Для печати листа средствами быстрого просмотра

Для публикации листа средствами быстрого просмотра

Переключение между открытыми чертежами

Для отображения только активного чертежа


Предварительный просмотр открытых чертежей и листов (Понятие)

Работа с несколькими чертежами
Работа с несколькими чертежами
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами >
Предварительный просмотр открытых чертежей и листов
Понятие Краткий справочник

Используя быстрый просмотр, можно легко осуществлять предварительный просмотр и переключение между открытыми чертежами, а также между пространством модели и листами открытого чертежа. Чертежи и листы отображаются в виде графических образцов, называемых эскизами быстрого просмотра, в нижней части главного окна приложения.

Средства быстрого просмотра в строке состояния приложения позволяют выполнить следующее:

  • Быстрый просмотр чертежей

    Все открытые в данный момент чертежи отображаются в строке эскизов быстрого просмотра чертежей. Предварительный просмотр и переключение между пространством модели и листами открытого чертежа осуществляется при перемещении курсора по эскизам быстрого просмотра чертежей. Дополнительную информацию см. в разделе Переключение между открытыми чертежами.

  • Быстрый просмотр листов

    Пространство модели и листы текущего чертежа отображаются в строке эскизов быстрого просмотра листов. Для просмотра параметров листа необходимо щелкнуть правой кнопкой мыши на эскизе быстрого просмотра листа. Дополнительную информацию см. в разделе Переключение между листами текущего чертежа.

Поддерживаются следующие форматы файлов: DWG, DWT, DXF и DWS.

ПримечаниеСредства быстрого просмотра отображаются в строке состояния.


Предварительный просмотр открытых чертежей и листов (Краткий справочник)

Частичное открытие и частичная загрузка
Предварительный просмотр открытых чертежей и листов
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Предварительный просмотр открытых чертежей и листов >
Предварительный просмотр открытых чертежей и листов
Понятие Краткий справочник

Команды

БВЧЕРТЕЖ

Отображение открытых чертежей и листов в чертеже как образцов для просмотра

БВЧЕРТЕЖЗАКРЫТЬ

Закрытие образцов для просмотра открытых чертежей и листов в чертеже

БВЛИСТ

Отображение образцов для просмотра пространства модели и листов в чертеже

БВЛИСТЗАКРЫТЬ

Закрытие образцов для просмотра пространства модели и листов в чертеже

Системные переменные

STATUSBAR

Управление отображением строки состояния приложения и чертежа

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Переключение между открытыми чертежами (Понятие)

Предварительный просмотр открытых чертежей и листов
Работа с несколькими чертежами
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Средство быстрого просмотра чертежей формирует двухуровневую структуру для предварительного просмотра и переключения между всеми открытыми чертежами и листами чертежей.

Первый уровень отображает эскизы быстрого просмотра открытых чертежей, второй уровень - эскизы пространства модели и всех листов чертежа.

Нажатие кнопки быстрого просмотра чертежей в строке состояния приводит к отображению всех открытых чертежей в строке образцов изображений. Эскиз быстрого просмотра текущего чертежа выделяется по умолчанию. При наведении курсора на эскиз быстрого просмотра все листы и модель для соответствующего чертежа отображаются в строке эскизов над строкой быстрого просмотра чертежей.

Панель, отображаемая ниже строки быстрого просмотра чертежей, содержит следующие элементы:

  • Закрепление чертежей для быстрого просмотра

    Закрепляет строку эскизов быстрого просмотра чертежей, обеспечивая постоянную видимость данной строки при работе в редакторе чертежей.

  • Создать

    Создает чертеж, который отображается в конце строки эскизов быстрого просмотра.

  • Открыть

    Открывает существующий чертеж, который отображается в конце строки эскизов быстрого просмотра.

  • Закрыть

    Закрывает все эскизы быстрого просмотра.

Используя средства быстрого просмотра чертежей, можно выполнять следующие действия:

  • Делать чертеж текущим путем выбора значка эскиза быстрого просмотра чертежа.
  • Перемещать курсор по эскизу быстрого просмотра чертежа для отображения в верхних углах эскиза кнопок "Сохранить" и "Закрыть", позволяющих сохранить или закрыть данный чертеж.
  • Выполнять предварительный просмотр пространства модели и листов чертежей, перемещая курсор по эскизу быстрого просмотра чертежа.
  • Закрывать все чертежи, за исключением текущего рабочего чертежа, с помощью контекстного меню.
  • Закрывать и сохранять все открытые чертежи.
  • Управлять расположением окон чертежей (вертикально, горизонтально или каскадом).

Эскиз быстрого просмотра листа позволяет получить доступ к дополнительным параметрам листа. Дополнительную информацию см. в разделе Переключение между листами текущего чертежа.

В случае выхода строк эскизов быстрого просмотра за пределы видимой области строка снабжается стрелками прокрутки. Для просмотра остальных изображений используется прокрутка. Размер эскиза быстрого просмотра можно изменять динамически при помощи колесика прокрутки мыши совместно с клавишей CTRL.

СоветДля удобства работы с несколькими одновременно открытыми чертежами или слоями чертежа можно использовать технологию нескольких мониторов, что позволяет отобразить полную строку эскизов быстрого просмотра.

При сохранении чертежа в формате DXF в нем не содержится изображение чертежа. Изображение не обновляется даже при использовании команды ОБНОБРАЗЦЫ. Вместо этого выводится статическое изображение.


Переключение между открытыми чертежами (Процедура)

Работа с несколькими чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для отображения чертежей для быстрого просмотра

Для предварительного просмотра и переключения между открытыми чертежами

Для просмотра и переключения между листами в чертеже

Для изменения размера эскиза быстрого просмотра

Для просмотра эскиза быстрого просмотра, не отображенного в области окна приложения

Для закрепления строки эскизов быстрого просмотра

Для создания чертежа средствами быстрого просмотра

Для открытия чертежа средствами быстрого просмотра

Для сохранения чертежа средствами быстрого просмотра

Для сохранения всех открытых чертежей средствами быстрого просмотра

Для закрытия чертежа средствами быстрого просмотра

Для закрытия всех чертежей средствами быстрого просмотра

Для закрытия средствами быстрого просмотра всех чертежей за исключением текущего рабочего чертежа


Для отображения чертежей для быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для отображения чертежей для быстрого просмотра

Выполните одно из следующих действий:

  • Выберите [image] в строке состояния
  • Введите бвчертеж в командной строке.
Ввод команды: БВЧЕРТЕЖ


Для предварительного просмотра и переключения между открытыми чертежами (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для предварительного просмотра и переключения между открытыми чертежами

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Выберите необходимый эскиз быстрого просмотра.
Ввод команды: БВЧЕРТЕЖ


Для просмотра и переключения между листами в чертеже (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для просмотра и переключения между листами в чертеже

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Перемещайте курсор по эскизам быстрого просмотра чертежей для предварительного просмотра модели и листов чертежа.
  3. Щелкните на эскизе быстрого просмотра, чтобы сделать данный чертеж или лист текущим.
Ввод команды: БВЧЕРТЕЖ


Для изменения размера эскиза быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для изменения размера эскиза быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Размер эскиза быстрого просмотра можно изменять при помощи колесика прокрутки мыши совместно с клавишей CTRL.
Ввод команды: БВЧЕРТЕЖ


Для просмотра эскиза быстрого просмотра, не отображенного в области окна приложения (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для просмотра эскиза быстрого просмотра, не отображенного в области окна приложения

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Нажмите левую или правую стрелку в строке прокрутки, чтобы просмотреть эскиз быстрого просмотра, не показанный в области окна приложения.
Ввод команды: БВЧЕРТЕЖ


Для закрепления строки эскизов быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для закрепления строки эскизов быстрого просмотра

  1. Выберите [image] в строке состояния.

    Ниже строки эскизов быстрого просмотра отображается панель.

  2. Нажмите на панели кнопку "Закрепить чертежи для быстрого просмотра" [image].

    Эскизы быстрого просмотра будут отображаться, пока не будет отменено закрепление. Для отмены закрепления повторно выберите кнопку "Закрепить чертежи для быстрого просмотра".


Для создания чертежа средствами быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для создания чертежа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Ниже строки эскизов быстрого просмотра отображается панель.

  2. На панели выберите кнопку "Создать" [image].

    Среди эскизов быстрого просмотра отобразится новый чертеж.


Для открытия чертежа средствами быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для открытия чертежа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Ниже строки эскизов быстрого просмотра отображается панель.

  2. На панели выберите "Открыть" [image].
  3. В диалоговом окне "Выбор файла" выделите один или несколько файлов.
  4. Нажмите кнопку "Открыть".


Для сохранения чертежа средствами быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для сохранения чертежа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Наведите курсор на необходимый эскиз.
  3. Выберите [image] на эскизе.


Для сохранения всех открытых чертежей средствами быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для сохранения всех открытых чертежей средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Щелкните правой кнопкой мыши на любом эскизе быстрого просмотра чертежа и нажмите "Сохранить все".


Для закрытия чертежа средствами быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для закрытия чертежа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Щелкните правой кнопкой мыши на необходимом эскизе быстрого просмотра чертежа и нажмите "Закрыть".


Для закрытия всех чертежей средствами быстрого просмотра (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для закрытия всех чертежей средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Щелкните правой кнопкой мыши на любом эскизе быстрого просмотра чертежа и нажмите "Закрыть все".


Для закрытия средствами быстрого просмотра всех чертежей за исключением текущего рабочего чертежа (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Для закрытия средствами быстрого просмотра всех чертежей за исключением текущего рабочего чертежа

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра отобразится внизу окна приложения.

  2. Щелкните правой кнопкой мыши на эскизе быстрого просмотра текущего рабочего чертежа. Выберите "Закрыть другие файлы".


Переключение между открытыми чертежами (Краткий справочник)

Предварительный просмотр открытых чертежей и листов
Переключение между открытыми чертежами
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между открытыми чертежами >
Переключение между открытыми чертежами
Понятие Процедура Краткий справочник

Команды

БВЧЕРТЕЖ

Отображение открытых чертежей и листов в чертеже как образцов для просмотра

БВЧЕРТЕЖЗАКРЫТЬ

Закрытие образцов для просмотра открытых чертежей и листов в чертеже

ОКНО

Упорядочивает окна и значки при совместном использовании окна приложения с внешними приложениями

ОБНОБРАЗЦЫ

Обновление образцов листов, видов листов и видов пространства модели в диспетчере подшивок вручную

Системные переменные

QVDRAWINGPIN

Управление состоянием отображения по умолчанию для предварительного просмотра изображений чертежей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Переключение между листами текущего чертежа (Понятие)

Переключение между открытыми чертежами
Работа с несколькими чертежами
Передача информации между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Предварительный просмотр и переключение между пространством модели и листами текущего чертежа средствами быстрого просмотра листов.

Для запуска анимации нажмите стрелку "Воспроизведение".

После нажатия кнопки "Быстрый просмотр листов" [image] в строке состояния пространство модели и листы чертежа отображаются в горизонтальной строке

В процессе перемещения курсора по эскизам быстрого просмотра листов возможна печать или публикация. Панель, отображаемая под эскизами быстрого просмотра чертежей, включает следующие элементы:

  • Прикрепление листов для быстрого просмотра

    Закрепляет строку эскизов быстрого просмотра чертежей, обеспечивая постоянную видимость данной строки при работе в редакторе чертежей.

  • Новый лист

    Создает новый лист, который также отображается в конце строки эскизов быстрого просмотра.

  • Публикация

    Вызывается диалоговое окно "Публикация" для публикации листа.

  • Закрыть быстрый просмотр листов

    Закрывает все эскизы быстрого просмотра листов.

Для запуска анимации нажмите стрелку "Воспроизведение".

С использованием эскизов быстрого просмотра листов можно выполнить следующее:

  • Сделать лист текущим, щелкнув на его эскизе
  • Перемещать курсор по эскизу быстрого просмотра чертежа для отображения в верхних углах эскиза кнопок "Печать" и "Публикация", позволяющих напечатать или опубликовать данный чертеж.
  • Перемещение и копирование листов из контекстного меню.
  • Доступ к диспетчеру параметров листов из контекстного меню.
  • Импорт листа в подшивку из контекстного меню.
  • Экспорт листа в пространство модели нового чертежа.

Размер эскиза быстрого просмотра может изменяться динамически с использованием колесика мыши совместно с клавишей CTRL.

СоветДля удобства работы с несколькими одновременно открытыми чертежами или слоями чертежа можно использовать технологию нескольких мониторов, что позволяет отобразить полную строку эскизов быстрого просмотра.

В случае выхода строк эскизов быстрого просмотра за пределы видимой области строка снабжается стрелками прокрутки. Для просмотра остальных изображений используется прокрутка.

ПримечаниеДля частично открытых или загруженных изображений не гарантируется корректная работа средства быстрого просмотра.

Обновить эскизы быстрого просмотра

Системная переменная UPDATETHUMBNAIL и команда ОБНОБРАЗЦЫ управляют хранением и обновлением эскизов быстрого просмотра.

  • В эскизе быстрого просмотра для пространства модели всегда отображается статическое изображение. Предварительный просмотр пространства модели не сохраняется в файле чертежа.
  • Эскизы быстрого просмотра для листов чертежа обновляются только при переключении между листами. Они не обновляются динамически при работе над листом.

Если в чертеже отсутствует сохраненное изображение листа, то вместо этого отображается заместитель места.

Заместитель места выводится в следующих случаях:

  • При создании нового чертежа
  • Если лист не инициализирован
  • Если чертеж не сохранен
  • При задании для системной переменной UPDATETHUMBNAIL значения 0. В этом случае изображение не обновляется даже при использовании команды ОБНОБРАЗЦЫ.


Переключение между листами текущего чертежа (Процедура)

Переключение между открытыми чертежами
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для предварительного просмотра пространства модели и листов чертежа

Для обновления образца следует

Для задания пространства модели или листа в качестве текущего

Для задания параметров листа средствами быстрого просмотра

Для создания листа средствами быстрого просмотра

Для переименования листа средствами быстрого просмотра

Для импорта листа из шаблона средствами быстрого просмотра

Для упорядочивания листов средствами быстрого просмотра

Для копирования листа средствами быстрого просмотра

Для упорядочивания листов средствами быстрого просмотра

Для активации предыдущего листа средствами быстрого просмотра

Для выбора всех листов средствами быстрого просмотра

Для экспорта листа в пространство модели средствами быстрого просмотра

Для печати листа средствами быстрого просмотра

Для публикации листа средствами быстрого просмотра


Для предварительного просмотра пространства модели и листов чертежа (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для предварительного просмотра пространства модели и листов чертежа

  • Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

Ввод команды: БВЛИСТ


Для обновления образца следует (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для обновления образца следует

  1. Убедиться, что значение UPDATETHUMBNAIL не установлено на 0.
  2. Ввести значение ОБНОБРАЗЦЫ в командной строке.

    Эта команда обеспечивает обновление образцов.

  3. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.


Для задания пространства модели или листа в качестве текущего (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для задания пространства модели или листа в качестве текущего

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Выберите эскиз пространства модели или листа для задания в качестве текущего.
Ввод команды: БВЛИСТ


Для задания параметров листа средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для задания параметров листа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Правой кнопкой мыши щелкните на эскизе быстрого просмотра. Выберите "Параметры листа".
Ввод команды: БВЛИСТ


Для создания листа средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для создания листа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения. Ниже эскизов быстрого просмотра отобразится панель.

  2. Выполните одно из следующих действий:
    • Правой кнопкой мыши щелкните на эскизе быстрого просмотра. Выберите "Новый лист".
    • На панели нажмите [image].

    Отобразится эскиз быстрого просмотра нового листа.

Ввод команды: БВЛИСТ


Для переименования листа средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для переименования листа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Дважды щелкните на листе, имя которого требуется изменить.
  3. Введите новое имя для листа.
Ввод команды: БВЛИСТ


Для импорта листа из шаблона средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для импорта листа из шаблона средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Правой кнопкой мыши щелкните на эскизе быстрого просмотра. Выберите в контекстном меню "По шаблону".
  3. В диалоговом окне "Выбор файла" выбрать файл DWT или DWG, из которого необходимо импортировать лист. Нажмите "Открыть". В диалоговом окне "Вставка листов" выберите импортируемый лист.
  4. Введите новое имя для листа.
  5. Нажмите "ОК".
Ввод команды: БВЛИСТ


Для упорядочивания листов средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для упорядочивания листов средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Правой кнопкой мыши щелкните на эскизе быстрого просмотра, который необходимо переместить. Выберите "Переместить/Копировать".
  3. В диалоговом окне "Перемещение/Копирование" выберите новую позицию для эскиза быстрого просмотра модели или листа. Размещение эскиза производится непосредственно после перемещения или копирования листа. Для перемещения листа в конец списка установите флажок "Переместить в конец".
  4. Нажмите "ОК".
Ввод команды: БВЛИСТ


Для копирования листа средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для копирования листа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Правой кнопкой мыши щелкните на эскизе быстрого просмотра, который необходимо переместить. Выберите "Переместить/Копировать".
  3. В диалоговом окне "Перемещение/копирование" указать новое позицию для эскиза быстрого просмотра нового листа.
  4. Нажмите "ОК".
ПримечаниеДанная функция недоступна для пространства модели.
Ввод команды: БВЛИСТ


Для активации предыдущего листа средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для активации предыдущего листа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Правой кнопкой мыши щелкните на эскизе быстрого просмотра.
  3. Выберите "Активизировать последний лист".
Ввод команды: БВЛИСТ


Для выбора всех листов средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для выбора всех листов средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Правой кнопкой мыши щелкните на эскизе быстрого просмотра.
  3. Выберите в контекстном меню "Выбрать все листы".
Ввод команды: БВЛИСТ


Для экспорта листа в пространство модели средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для экспорта листа в пространство модели средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. Правой кнопкой мыши щелкните на эскизе быстрого просмотра.
  3. Выберите "Экспорт листа в модель"
  4. В диалоговом окне "Экспорт листа в чертеж пространства модели" введите имя нового файла.
  5. Нажмите "Сохранить".
Ввод команды: БВЛИСТ


Для печати листа средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Переключение между листами текущего чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для печати листа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. В верхнем левом углу эскиза быстрого просмотра листа выберите [image].
  3. В диалоговом окне "Печать" выберите "Параметры печати".
  4. Нажмите "ОК".
Ввод команды: БВЛИСТ


Для публикации листа средствами быстрого просмотра (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Передача информации между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Для публикации листа средствами быстрого просмотра

  1. Выберите [image] в строке состояния.

    Строка эскизов быстрого просмотра пространства модели и листов чертежа отображается внизу окна приложения.

  2. В верхнем левом углу эскиза быстрого просмотра листа выберите [image].
  3. В диалоговом окне "Публикация" выберите "Параметры публикации".
  4. Нажмите ОК.
Ввод команды: БВЛИСТ


Переключение между листами текущего чертежа (Краткий справочник)

Переключение между открытыми чертежами
Переключение между листами текущего чертежа
Передача информации между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Переключение между листами текущего чертежа >
Переключение между листами текущего чертежа
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

БВЛИСТ

Отображение образцов для просмотра пространства модели и листов в чертеже

БВЛИСТЗАКРЫТЬ

Закрытие образцов для просмотра пространства модели и листов в чертеже

Системные переменные

QVLAYOUTPIN

Управление состоянием отображения по умолчанию для предварительного просмотра изображений пространства модели и листов в чертеже

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Передача информации между открытыми чертежами (Понятие)

Переключение между листами текущего чертежа
Работа с несколькими чертежами
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами >
Передача информации между открытыми чертежами
Понятие Процедура Краткий справочник

Информацию можно легко перемещать между чертежами, открытыми в одном сеансе.

При открытии нескольких чертежей в одном сеансе можно

  • Быстро просматривать другие чертежи.
  • Копировать и вставлять элементы из одного чертежа в другой.
  • С помощью правой кнопки мыши перетаскивать выделенные объекты из одного чертежа в другой.
  • Использовать функцию "Копирование свойств" (КОПИРОВАТЬСВ) для копирования свойств из объектов одного чертежа в объекты другого.
  • Использовать объектные привязки, команду копирования с запоминанием базовой точки (БТКОПИРОВАТЬ), а также команду "Вставить с исходными координатами" (ВСТИСХОД) для точного позиционирования объектов.


Передача информации между открытыми чертежами (Процедура)

Переключение между листами текущего чертежа
На уровень вверх ..
Передача информации между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Передача информации между открытыми чертежами >
Передача информации между открытыми чертежами
Понятие Процедура Краткий справочник

Переключение между открытыми чертежами

Для отображения только активного чертежа


Переключение между открытыми чертежами (Процедура)

Передача информации между открытыми чертежами
На уровень вверх ..
Передача информации между открытыми чертежами
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Передача информации между открытыми чертежами >
Передача информации между открытыми чертежами
Понятие Процедура Краткий справочник

Переключение между открытыми чертежами

Для переключения между открытыми чертежами выполните одно из следующих действий:

  • Выберите средство быстрого просмотра чертежей в строке состояния для предварительного просмотра и переключения между чертежами.
  • Нажмите в любом месте чертежа для его активации.
  • Используйте сочетания клавиш CTRL+F6 или CTRL+TAB.
  • Задайте для команды ПАНЗАДАЧ значение 1, чтобы несколько открытых чертежей отобразить в виде отдельных элементов на панели задач Windows. После этого быстрое переключение между чертежами осуществляется нажатием сочетания клавиш Alt+TAB.
Ввод команды: ПАНЗАДАЧ


Для отображения только активного чертежа (Процедура)

Передача информации между открытыми чертежами
На уровень вверх ..
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Передача информации между открытыми чертежами >
Передача информации между открытыми чертежами
Понятие Процедура Краткий справочник

Для отображения только активного чертежа

  • Установите для команды "ПАНЗАДАЧ" значение 0 для отображения только активного чертежа в панели задач
Ввод команды: ПАНЗАДАЧ


Передача информации между открытыми чертежами (Краткий справочник)

Переключение между листами текущего чертежа
Передача информации между открытыми чертежами
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Работа с несколькими чертежами > Передача информации между открытыми чертежами >
Передача информации между открытыми чертежами
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПАНЗАДАЧ

Управление отображением чертежей на панели задач Windows

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение чертежей (Понятие)

Передача информации между открытыми чертежами
Открытие или сохранение чертежа
Поиск чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа >
Сохранение чертежей
Понятие Процедура Краткий справочник

Сохранение чертежей для дальнейшего использования выполняется так же, как и в других приложениях Microsoft Windows. Можно установить режим автоматического сохранения файлов и резервных копий, а также сохранения только выбранных объектов.

При работе с чертежом рекомендуется периодически сохранять его. Это позволит избежать потери данных при возникновении непредвиденных ситуаций, например, при сбое питания. Если требуется создать новую версию чертежа, можно сохранить исходный чертёж под другим именем.

Расширением имени файла для файлов чертежей является .dwg и, пока пользователь не изменит формат файла по умолчанию, в котором сохраняются чертежи, они сохраняются в последнем заданном формате файла чертежа. Этот формат имеет высокую степень сжатия и хорошо подходит для использования в сети.

Длина имени файла DWG (включая путь) не может превышать 256 символов.

ПримечаниеПри отключении системной переменной FILEDIA (установлено значение 0) вместо диалогового окна навигации по файлам отображается командная строка.

Сохранение части чертежа

Для сохранения части имеющегося чертежа в новом файле используются команды БЛОК и ПБЛОК. С помощью этих команд можно выделить несколько объектов или определить блок, а затем сохранить их в новом файле чертежа. Кроме того, наряду с новым чертежом можно сохранить текстовое описание.

Сохранение чертежа в различных форматах

Чертежи можно сохранять в прежних версиях формата чертежа (DWG) и формата графического обмена (DXF), а также в виде шаблонов. Формат сохраняемого файла чертежа задается в списке "Тип файла" диалогового окна "Сохранение чертежа".

Сохранение с визуальной четкостью аннотативных объектов

Этот параметр обеспечивает визуальную четкость воспроизведения объектов аннотативный при их просмотре в AutoCAD 2007 и в более ранних версиях программы. Управление режимом визуальной четкости осуществляется с помощью системной переменной SAVEFIDELITY .

Если работа выполняется главным образом в пространстве модели, то рекомендуется отключить режим визуальной четкости (присвоить переменной SAVEFIDELITY значение 0). Однако если есть необходимость в обмене чертежами с другими пользователями и важнейшее значение имеет четкость листа, то следует включить режим визуальной четкости (присвоить переменной SAVEFIDELITY значение 1).

У аннотативного объекта может быть несколько масштабируемых представлений. Если режим визуальной четкости включен, то аннотативные объекты разделяются и масштабируемые представления сохраняются (в неименованный блок ) в отдельных слоях, имена которых образуются путем присоединения номера к имени исходного слоя. Если расчленить блок в AutoCAD 2007 или в более ранней версии программы, а затем открыть чертеж в AutoCAD 2008 или более поздней версии, то каждое масштабируемое представление становится отдельным аннотативным объектом, для которого задан один масштаб аннотаций. Не рекомендуется редактировать и создавать объекты в этих слоях при работе с чертежом, созданным в AutoCAD 2008 и более поздних версиях в AutoCAD 2007, а также в более ранних версиях.

Если эта настройка не выбрана, то на вкладке "Модель" отображается пространство одной модели. В зависимости от параметра ANNOALLVISIBLE на вкладке "Модель" может отображаться большее количество объектов аннотаций. Также на видовых экранах пространства листа может отображаться большее количество объектов с размерами, отличными от размеров в AutoCAD 2008 и более поздних версиях.

Повышение скорости сохранения чертежей

Для повышения скорости сохранения файлов чертежей можно использовать режим сохранения изменений вместо режима полной записи. В режиме сохранения изменений обновляются только те фрагменты сохраненного файла чертежа, которые подверглись изменениям.

При использовании режима сохранения изменений файлы чертежей содержат определенный процент неиспользуемого дискового пространства. Этот процент увеличивается с каждым сохранением, пока не достигнет установленного максимума, после чего производится полное сохранение. Процент неиспользуемого дискового пространства, допустимый в файле чертежа, можно установить на вкладке "Открытие/Сохранение" диалогового окна "Настройка" или с помощью присвоения значения системной переменной ISAVEPERCENT. Если переменной ISAVEPERCENT присвоено значение 0, то файлы всегда сохраняются полностью.

Для уменьшения размера файлов чертежей рекомендуется производить полное сохранение (переменной ISAVEPERCENT должно быть присвоено значение 0) перед передачей или архивацией файлов.

Международное сотрудничество

При совместном использовании файлов чертежей с иностранными компаниями имена файлов чертежей могут содержать символы, отсутствующие в других языках.

Если файл чертежа создан в версии Windows с другим языком, происходит следующее:

  • Если установлена поддержка соответствующего языка, символы имени файла видны в проводнике Windows.
  • Если поддержка языка не установлена, то символы имени файла отображаются в проводнике Windows в форме прямоугольников и на экран выводится диалоговое окно с запросом установки языкового пакета.

В любом случае пользователь имеет возможность открыть начало файла чертежа с помощью AutoCAD 2007 или AutoCAD LT 2007, поскольку эти продукты являются приложениями, поддерживающими кодовую таблицу Unicode.

ПримечаниеЕсли файлы чертежей используются совместно с компаниями, работающими с более ранними версиями продукта, предусмотрена возможность избежать проблем с именами файлов для азиатских языков и языков, использующих диакритические знаки. В этих условиях нельзя использовать символы с большими значениями кодов ASCII или значениями, равными или превышающими шестнадцатеричное значение 80, при создании имени файла.
См. также

    • Сохранение чертежей в форматах прежних версий

    • Работа с чертежами в более ранних версиях

    • Создание файлов в других форматах

    • Сохранение блока в отдельном файле

    • Добавление идентификационных сведений к чертежам

    • Создание файлов архива и восстановление

    • Совместное использование файлов пользователями из разных стран

    • Открытие и сохранение файлов в Интернете


Сохранение чертежей (Процедура)

Передача информации между открытыми чертежами
Сохранение чертежей
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Сохранение чертежа

Автоматическое сохранение чертежа

Сохранение резервных копий чертежей

Сохранение выбранных объектов в новом файле

Сохранение определения блока в новом файле чертежа

Сохранение чертежей с визуальной четкостью аннотативных объектов


Сохранение чертежа (Процедура)

Сохранение чертежей
Сохранение чертежей
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Сохранение чертежа

  1. Выполните одно из следующих действий:
  2. Выберите на панели быстрого доступа [image] "Сохранить" [image] .Введите в командной строке "бсохранить".

    Если данный чертеж сохраняется не в первый раз, то все выполненные изменения сохраняются, и снова отображается командная строка. При первом сохранении вызывается диалоговое окно "Сохранение чертежа".

  3. В диалоговом окне "Сохранение чертежа" в поле "Имя файла" введите имя чертежа. Ввод расширения не требуется. Нажмите кнопку "Сохранить".
Меню: Файл [image] Сохранить
Панель:Стандартный
Ввод команды: СОХРАНИТЬ


Автоматическое сохранение чертежа (Процедура)

Сохранение чертежей
Сохранение чертежей
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Автоматическое сохранение чертежа

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" установите флажок "Автосохранение".
  3. Введите значение временного интервала сохранения в минутах.
  4. Нажмите "ОК".


Сохранение резервных копий чертежей (Процедура)

Сохранение чертежей
Сохранение чертежей
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Сохранение резервных копий чертежей

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" установите флажок "Создавать резервные копии".
  3. Нажмите "ОК".


Сохранение выбранных объектов в новом файле (Процедура)

Сохранение чертежей
Сохранение чертежей
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Сохранение выбранных объектов в новом файле

  1. В командной строке введите пблок.
  2. В группе "Объекты" диалогового окна "Запись блока на диск" выберите параметр "Объекты".
  3. В группе "Базовая точка" нажмите кнопку "Указать".
  4. Выберите базовую точку в области рисования или введите значения координат в поля X, Y и Z.
  5. В группе "Объекты" нажмите кнопку "Выбрать объекты".
  6. Выберите объекты в области рисования.
  7. В группе "Объекты" выберите вариант обработки выбранных объектов (оставить, сделать блоком или удалить из чертежа).
  8. В поле "Имя файла" введите имя нового файла чертежа.
  9. В поле "Размещение" укажите папку для сохранения нового файла чертежа.
  10. В раскрывающемся списке "Единицы измерения" можно выбрать другую базовую единицу. Этот параметр позволяет автоматически задавать масштаб объектов в новом файле чертежа.
  11. Нажмите "ОК".

    Выбранные объекты сохраняются в новом файле чертежа.

Ввод команды: ПБЛОК


Сохранение определения блока в новом файле чертежа (Процедура)

Сохранение чертежей
Сохранение чертежей
Сохранение чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Сохранение определения блока в новом файле чертежа

  1. В командной строке введите пблок.
  2. В диалоговом окне "Запись блока на диск" выберите "Блок".
  3. Выберите окно рядом с блоком. Выберите определение блока, которое необходимо сохранить.
  4. В поле "Имя файла" введите имя нового файла чертежа.
  5. В поле "Размещение" укажите папку для сохранения нового файла чертежа.
  6. В раскрывающемся списке "Единицы измерения" можно выбрать другую базовую единицу. Этот параметр позволяет автоматически задавать масштаб объектов в новом файле чертежа.
  7. Нажмите "ОК".

    Объекты выбранного определения блока сохраняются в новом файле чертежа. Базовая точка вставки определения блока имеет в новом чертеже координаты (0, 0, 0).

Ввод команды: ПБЛОК


Сохранение чертежей с визуальной четкостью аннотативных объектов (Процедура)

Сохранение чертежей
Сохранение чертежей
Поиск чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Сохранение чертежей с визуальной четкостью аннотативных объектов

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" в разделе "Сохранение файлов" выбрать "Поддержка визуальной четкости аннотативных объектов".
  3. Нажмите ОК.
Ввод команды: SAVEFIDELITY


Сохранение чертежей (Краткий справочник)

Передача информации между открытыми чертежами
Сохранение чертежей
Поиск чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Сохранение чертежей >
Сохранение чертежей
Понятие Процедура Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

БСОХРАНИТЬ

Быстрое сохранение текущего чертежа в формате, заданном в диалоговом окне "Настройка"

ПОКИНУТЬ

Закрытие программы

СОХРАНИТЬ

Сохранение чертежа под текущим или заданным именем

СОХРАН В

Сохранение копии текущего чертежа под новым именем

ПБЛОК

Запись объектов или блока в новый файл чертежа

Системные переменные

DWGCHECK

Управление проверкой чертежей на потенциальные ошибки при их открытии

DWGNAME

Имя текущего чертежа

DWGPREFIX

Хранение префикса диска и папки для чертежа

DWGTITLED

Код, определяющий, присвоено ли текущему чертежу имя

FILEDIA

Подавление отображения диалоговых окон навигации к файлу

ISAVEBAK

Повышает скорость сохранения, особенно для больших чертежей

ISAVEPERCENT

Количество неиспользуемого дискового пространства, допустимого в файле чертежа

RASTERPREVIEW

Управление сохранением образцов для просмотра в формате BMP вместе с чертежом

SAVEFIDELITY

Управление сохранением чертежа с точностью отображения

SAVEFILE

Имя текущего файла автоматического сохранения

SAVEFILEPATH

Путь к папке всех файлов автоматического сохранения для текущего сеанса

SAVENAME

Отображение имени и пути к файлу последнего сохраненного чертежа

SAVETIME

Интервал автоматического сохранения (в минутах)

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Поиск чертежей (Понятие)

Сохранение чертежей
Открытие или сохранение чертежа
Укажите "Пути поиска" и "Местоположения файлов"
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа >
Поиск чертежей
Понятие Процедура Краткий справочник

С помощью фильтров, задающих имя искомого файла, папку, дату, а также значения определенных свойств, таких как ключевые слова в чертежах, можно выполнять поиск чертежей или текстовых строк, содержащих определенное слово или фразу.

  • Чтобы выполнить поиск чертежей по фильтрам имен, папок и дат создания, следует использовать инструмент поиска в Microsoft® Windows®. Можно также указать слово или фразу, содержащуюся в файле чертежа. Можно выполнить поиск любой текстовой информации, кроме текста в таблицах и полях, а также внешних ссылок в файлах чертежей. Поддерживаются следующие типы файлов чертежей: DWG, DWF, DWT и DWS.
  • Используйте диалоговое окно поиска для Центра управления™, чтобы выполнить поиск свойств файлов Microsoft Windows, например заголовков или ключевых слов, имеющихся в чертежах.
  • Для предварительного просмотра файла чертежа с помощью команды ОТКРЫТЬ используйте диалоговое окно "Выбор файла". Если системная переменная RASTERPREVIEW имеет значение "Вкл", то при сохранении чертежей автоматически создаются и сохраняются растровые изображения предварительного просмотра.
См. также

    • Добавление идентификационных сведений к чертежам

    • Доступ к содержимому с помощью Центра управления

    • Работа с листами в подшивке


Поиск файлов (Процедура)

Сохранение чертежей
Поиск чертежей
Укажите "Пути поиска" и "Местоположения файлов"
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Поиск чертежей >
Поиск чертежей
Понятие Процедура Краткий справочник

Поиск файлов

  1. Выберите на панели быстрого доступа [image] "Открыть".В командной строке введите "открыть".
  2. В диалоговом окне "Выбор файла" выберите "Сервис" [image] "Найти".
  3. В диалоговом окне "Поиск файлов" перейдите на вкладку "Имя и размещение" и укажите тип искомого файла, его имя и путь поиска.

    Для указания имен файлов можно использовать символы-шаблоны.

  4. Для выполнения поиска по дате выберите на вкладке "Дата" параметр "Все файлы" или "Найти все файлы, созданные или измененные".

    Для поиска можно указать период между датами или число последних месяцев или дней.

  5. Нажмите кнопку "Найти".
  6. В результатах поиска выберите один или несколько файлов. Нажмите "ОК".
  7. В окне "Выбор файла" нажмите кнопку "Открыть".
Панель:Стандартный
Ввод команды: ОТКРЫТЬ


Поиск чертежей (Краткий справочник)

Сохранение чертежей
Поиск чертежей
Укажите "Пути поиска" и "Местоположения файлов"
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Поиск чертежей >
Поиск чертежей
Понятие Процедура Краткий справочник

Команды

ОТКРЫТЬ

Открытие существующего файла чертежа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Укажите "Пути поиска" и "Местоположения файлов" (Понятие)

Поиск чертежей
Открытие или сохранение чертежа
Восстановление файлов чертежей
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа >
Укажите "Пути поиска" и "Местоположения файлов"
Понятие Процедура Краткий справочник

Имеется возможность задания путей доступа для поиска вспомогательных файлов, таких как шрифты, чертежи, типы линий, образцы штриховки и т.д. Можно также указать папку для хранения временных файлов, что важно при работе в сети.

На вкладке "Файлы" диалогового окна "Настройка" указывается путь поиска, который используется программой для поиска файлов поддержки чертежей, например шрифтов, чертежей, типов линий и образцов штриховки. В системной переменной MYDOCUMENTSPREFIX хранится путь к папке Мои документы для текущего пользователя.

На вкладке "Файлы" также представлены все пути доступа к папкам, которые существуют в текущей структуре папок локальных и сетевых дисков. Использование этих параметров позволяет увеличить эффективность загрузки файлов.

На вкладке "Файлы" диалогового окна "Настройка" задается также путь доступа к временным файлам. Временные файлы создаются на диске, а затем удаляются при выходе из программы. Временные файлы помещаются в ту же папку, где хранятся временные файлы Microsoft Windows. Если предполагается запуск этой программы из папки, защищенной от записи (например, по сети или с компакт-диска), то для временных файлов следует назначить другую папку.

Необходимо, чтобы в эту временную папку была разрешена запись. Нужно также убедиться в том, что на выбранном диске достаточно места для размещения временных файлов. Рекомендуется вручную регулярно удалять файлы из этой папки, чтобы для временных файлов всегда было достаточно свободного места на диске. Если на диске недостаточно места для временных файлов, то при работе программы могут возникать сбои и ошибки.

Если требуется использовать файл, который содержит специальные элементы интерфейса, укажите его в элементе "Файлы адаптаций" на вкладке "Файлы" диалогового окна "Настройка". По умолчанию применяется файл адаптации acad.cui.


Изменение пути поиска (Процедура)

Поиск чертежей
Укажите "Пути поиска" и "Местоположения файлов"
Восстановление поврежденного файла чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Укажите "Пути поиска" и "Местоположения файлов" >
Укажите "Пути поиска" и "Местоположения файлов"
Понятие Процедура Краткий справочник

Изменение пути поиска

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" нажмите кнопку мыши на значке "плюс" (+) слева от заголовка пути доступа, который нужно изменить.
  3. Выберите путь, который требуется изменить.
  4. Нажмите "Обзор", а затем выполните поиск нужных дисков и папок.
  5. Выберите нужный диск и папку.
  6. Нажмите ОК.
Ввод команды: НАСТРОЙКА


Укажите "Пути поиска" и "Местоположения файлов" (Краткий справочник)

Поиск чертежей
Укажите "Пути поиска" и "Местоположения файлов"
Восстановление поврежденного файла чертежа
Создание, организация и сохранение чертежей > Открытие или сохранение чертежа > Укажите "Пути поиска" и "Местоположения файлов" >
Укажите "Пути поиска" и "Местоположения файлов"
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

MYDOCUMENTSPREFIX

Полный путь к папке "Мои документы" текущего пользователя

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Восстановление файлов чертежей

Укажите "Пути поиска" и "Местоположения файлов"
Создание, организация и сохранение чертежей
Восстановление поврежденного файла чертежа
Создание, организация и сохранение чертежей >
Восстановление файлов чертежей

В случае повреждения файла чертежа или аварийного завершения работы программы можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки или вернуться к файлу резервной копии.

Темы в этом разделе

  • Восстановление поврежденного файла чертежа

    В случае повреждения файла чертежа можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки.

  • Создание файлов архива и восстановление

    Файлы архива гарантируют безопасность хранения данных чертежа. При возникновении проблем можно восстановить чертёж с помощью файла архива.

  • Восстановление после системного сбоя

    Неполадки в работе оборудования или программного обеспечения и перебои в питании могут привести к аварийному завершению работы программы. Если это случится, файлы чертежей, которые были открыты, можно восстановить.


Восстановление поврежденного файла чертежа (Понятие)

Восстановление файлов чертежей
Восстановление файлов чертежей
Создание файлов архива и восстановление
Создание, организация и сохранение чертежей > Восстановление файлов чертежей >
Восстановление поврежденного файла чертежа
Понятие Процедура Краткий справочник

В случае повреждения файла чертежа можно восстановить все данные или их часть с помощью команд, позволяющих найти и исправить ошибки.

Исправление и восстановление

При возникновении ошибки диагностические сведения записываются в файл acad.err, который затем можно использовать для описания проблемы.

Если обнаружены поврежденные данные или запрос на сохранение чертежа осуществляется после программного сбоя, файл чертежа помечается как поврежденный. Если повреждение незначительно, то иногда чертёж автоматически восстанавливается при следующем открытии. В противном случае можно использовать следующие команды:

  • ВОССТАН. Выполняет проверку и пытается открыть любой файл чертежа.
  • ВОССТВСЕ По аналогии с восстановлением эта функция работает на всех вложенных внешних ссылках. Результаты отображаются в окне "Журнал восстановления чертежей".
  • ПРОВЕРИТЬ. Находит и исправляет ошибки в текущем открытом файле чертежа.

Пример: проверка файлов

В результате проверки файла создается отчёт с описанием ошибок в файле чертежа и рекомендациями по их устранению. При запуске проверки пользователь может указать, должна ли программа пытаться исправить имеющиеся ошибки. Отчёт может выглядеть следующим образом:

Проверка заголовка

ИМЯ DXF Текущее значение Проверка По умолчанию

PDMODE 990 - 2040

UCSFOLLOW 811 or 0

При проверке переменных заголовка обнаружена ошибка

Проверено блоков: 4

Проход 1: проверено объектов: 4

Проход 2: проверено объектов: 4

Всего найдено ошибок: 2, исправлено: 2

Если проверка выполняется без устранения ошибок, то вместо последнего блока сообщений будет выведено:

Всего найдено ошибок: 2, исправлено: 0

Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (Вкл).

Полное восстановление поврежденных файлов не гарантировано. Программа, насколько это возможно, восстанавливает данные поврежденных файлов.

См. также

    • Создание файлов архива и восстановление


Восстановление поврежденного файла чертежа (Процедура)

Укажите "Пути поиска" и "Местоположения файлов"
Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление поврежденного файла чертежа >
Восстановление поврежденного файла чертежа
Понятие Процедура Краткий справочник

Восстановление поврежденного файла чертежа

Восстановление файла чертежа, повреждённого в результате системного сбоя

Восстановление открытого чертежа

Восстановление чертежа из файла архива


Восстановление поврежденного файла чертежа (Процедура)

Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление поврежденного файла чертежа >
Восстановление поврежденного файла чертежа
Понятие Процедура Краткий справочник

Восстановление поврежденного файла чертежа

  1. Выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Восстановить". В командной строке введите "восстан".
  2. В диалоговом окне "Выбор файла" выберите файл. Нажмите "Открыть".

    После проверки все объекты с ошибками размещаются в наборе объектов "Предыдущий" для облегчения доступа. Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (вкл).

Ввод команды: ВОССТАН, ВОССТВСЕ


Восстановление файла чертежа, повреждённого в результате системного сбоя (Процедура)

Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление поврежденного файла чертежа >
Восстановление поврежденного файла чертежа
Понятие Процедура Краткий справочник

Восстановление файла чертежа, повреждённого в результате системного сбоя

  1. Если программа обнаруживает ошибку и не может продолжать работу, то появляется сообщение об ошибке, а для некоторых ошибок - код ошибки. Запишите числовой код ошибки, затем, если это возможно, сохраните изменения чертежа и выйдите из программы.
  2. Перезапустите программу.
  3. В окне "Восстановление чертежа", в разделе "Файлы архива", дважды нажмите кнопку мыши на элементе чертежа, чтобы его развернуть. В списке дважды нажмите на одном из файлов чертежей или архива, чтобы его открыть.

    Если программа обнаружит, что чертёж поврежден, появится соответствующее сообщение с запросом о продолжении работы.

  4. Для продолжения введите д.

    После попытки восстановления чертежа, предпринятой программой, появится диагностический отчёт о проверке. Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (вкл).

  5. В зависимости от степени успеха восстановления выполните следующее:
    • Если восстановление полностью завершено, чертёж открывается. Сохраните файл чертежа.
    • Если программе не удастся восстановить файл, появится сообщение. В этом случае, начиная с шага 3, выберите другой файл чертежа или архива из списка "Восстановление чертежа".
Ввод команды: ВОССТАН


Восстановление открытого чертежа (Процедура)

Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление поврежденного файла чертежа >
Восстановление поврежденного файла чертежа
Понятие Процедура Краткий справочник

Восстановление открытого чертежа

  1. Выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Проверить". В командной строке введите "проверить".
  2. Обнаружены ошибки при исправлении? командная строка, введите д или н.

    Для удобного доступа к объектам, в которых обнаружены ошибки, команда ПРОВЕРИТЬ помещает их все в предыдущий набор объектов. Выходные данные аудита восстановления записываются в файл регистрационного журнала аудита (ADT) в случае, если системная переменная AUDITCTL равняется 1 (вкл).

    ПримечаниеЕсли с помощью команды ПРОВЕРИТЬ не удаётся исправить ошибки в чертеже, следует воспользоваться командой ВОССТАН. Команда ВОССТАН восстанавливает любой указанный DWG-файл, не являющийся текущим файлом чертежа.
Ввод команды: ПРОВЕРИТЬ


Восстановление чертежа из файла архива (Процедура)

Восстановление поврежденного файла чертежа
Восстановление поврежденного файла чертежа
Создание файлов архива и восстановление
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление поврежденного файла чертежа >
Восстановление поврежденного файла чертежа
Понятие Процедура Краткий справочник

Восстановление чертежа из файла архива

  1. С помощью Проводника Windows найдите файл резервной копии чертежа с расширением .bak.
  2. Нажмите правую кнопку мыши на файле архива. Выберите "Переименовать".
  3. Введите новое имя с расширением dwg.
  4. Откройте файл как обычный файл чертежа.


Восстановление поврежденного файла чертежа (Краткий справочник)

Укажите "Пути поиска" и "Местоположения файлов"
Восстановление поврежденного файла чертежа
Создание файлов архива и восстановление
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление поврежденного файла чертежа >
Восстановление поврежденного файла чертежа
Понятие Процедура Краткий справочник

Команды

ПРОВЕРИТЬ

Проверка целостности чертежа и исправление отдельных ошибок

ВОССТАНЧЕРТЕЖА

Отображение списка имен файлов чертежей, подлежащих восстановлению после сбоя системы

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ВОССТАН

Восстановление поврежденного чертежа

ВОССТВСЕ

Восстановление поврежденного чертежа

Системные переменные

AUDITCTL

Управление созданием файла отчета проверки (ADT) с помощью команды ПРОВЕРИТЬ

REPORTERROR

Управление возможностью отправки отчета об ошибке в компанию Autodesk при неожиданном закрытии программы

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание файлов архива и восстановление (Понятие)

Восстановление поврежденного файла чертежа
Восстановление файлов чертежей
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей >
Создание файлов архива и восстановление
Понятие Процедура Краткий справочник

Файлы архива гарантируют безопасность хранения данных чертежа. При возникновении проблем можно восстановить чертёж с помощью файла архива.

При работе над чертежом могут возникать различные сбои, вызванные неполадками оборудования или программного обеспечения, неожиданным отключением питания или неверными действиями самого пользователя. Потери данных в таких случаях можно свести к минимуму, если периодически выполнять сохранение результатов работы. При возникновении проблем можно восстановить чертёж с помощью файла архива.

Создание резервных копий файлов

В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" можно указать, что при сохранении чертежей должны создаваться файлы архива. В этом случае при каждом сохранении чертежа предыдущая его версия сохраняется в файле с тем же именем с расширением .bak. Файл архива располагается в той же папке, что и файл чертежа.

Чтобы выполнить восстановление из архивной версии, можно переименовать .bak-файл в проводнике Windows в файл с расширением .dwg. В этом случае, если необходимо сохранить последнюю версию чертежа, резервную копию можно скопировать в другую папку.

Периодическое автосохранение чертежа.

Если режим автосохранения включён, чертёж сохраняется периодически по истечении установленного интервала времени. По умолчанию автосохранение происходит во временные файлы с именем в виде имя_a_b_nnnn.sv$.

  • Имя - это текущее название чертежа.
  • a - это число открытых копий одного и того же файла чертежа в одном сеансе.
  • b - это число открытых копий одного и того же чертежа в разных сеансах.
  • nnnn - произвольное число.

При успешном закрытии чертежа удаляются все временные файлы, созданные в результате автосохранения. В случае программного сбоя или перебоя в энергоснабжении эти файлы не удаляются.

Чтобы восстановить предыдущую версию чертежа из автоматически сохраненного файла, необходимо до завершения работы программы переименовать файл, используя расширение .dwg вместо расширения .sv$.

См. также

    • Восстановление после системного сбоя


Восстановление чертежа из файла архива (Процедура)

Восстановление поврежденного файла чертежа
Создание файлов архива и восстановление
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Создание файлов архива и восстановление >
Создание файлов архива и восстановление
Понятие Процедура Краткий справочник

Восстановление чертежа из файла архива

  1. С помощью Проводника Windows найдите файл резервной копии чертежа с расширением .bak.
  2. Выделите найденный файл. Открывать его не обязательно.
  3. Выберите пункт меню "Файл" [image] "Переименовать".
  4. Введите новое имя с расширением .dwg.
  5. Откройте файл как обычный файл чертежа.


Создание файлов архива и восстановление (Краткий справочник)

Восстановление поврежденного файла чертежа
Создание файлов архива и восстановление
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Создание файлов архива и восстановление >
Создание файлов архива и восстановление
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

ISAVEBAK

Повышает скорость сохранения, особенно для больших чертежей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Восстановление после системного сбоя (Понятие)

Создание файлов архива и восстановление
Восстановление файлов чертежей
Соблюдение стандартов в чертежах
Создание, организация и сохранение чертежей > Восстановление файлов чертежей >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Неполадки в работе оборудования или программного обеспечения и перебои в питании могут привести к аварийному завершению работы программы. Если это случится, файлы чертежей, которые были открыты, можно восстановить.

В случае сбоя программы результаты выполненной работы могут быть сохранены в другом файле. Для этого файла используется формат DrawingFileName_recover.dwg, где DrawingFileName - это имя файла текущего чертежа.

Решение проблем файлов чертежей

После программного или системного сбоя при следующем запуске AutoCAD открывается "Диспетчер восстановления чертежей". Модуль "Диспетчер восстановления чертежей" отображает список всех файлов чертежей, которые были открыты, включая файлы чертежей следующих типов.

  • Файлы чертежей (DWG)
  • Файлы шаблонов чертежей (DWT)
  • Файлы стандартов оформления (DWS)
ПримечаниеНесохраненные чертежи, открытые в момент сбоя, модулем "Диспетчер восстановления чертежей" не отслеживаются. Обязательно сохраняйте файл после начала работы и регулярно во время работы над ним.

Для каждого чертежа можно открыть и выбрать какой-нибудь из следующих файлов, если они существуют:

  • DrawingFileName_recover.dwg
  • DrawingFileName_a_b_nnnn.sv$
  • DrawingFileName.dwg
  • DrawingFileName.bak
ПримечаниеФайлы чертежей, архива и восстановления указаны в списке по порядку в соответствии с отметками времени их последнего сохранения.

Дважды нажмите на элементе чертежа верхнего уровня, указанного в разделе "Файлы архива", чтобы отобразить до четырех файлов, перечисленных выше. Нажмите правую кнопку мыши на любом элементе в разделе "Файлы архива" для отображения параметров контекстного меню.

Если окно "Восстановление чертежа" закрыто до разрешения проблем во всех поврежденных файлах, его можно открыть позже с помощью команды ВОССТАНЧЕРТЕЖА.

Автоматическая отправка отчёта об ошибке в компанию Autodesk

В программе имеется возможность послать отчёт об ошибке в компанию Autodesk, где он будет использован для устранения подобных проблем в будущем. Отчёт об ошибке содержит информацию о состоянии системы на момент сбоя. Кроме того, можно ввести дополнительную информацию, например, о действиях пользователя, предшествовавших сбою. Системная переменная REPORTERROR управляет возможностью отправки в Autodesk отчётов об ошибках в работе AutoCAD.


Восстановление после системного сбоя (Процедура)

Создание файлов архива и восстановление
Восстановление после системного сбоя
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление после системного сбоя >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Восстановление чертежа с помощью модуля "Диспетчер восстановления чертежей"

Удаление чертежа из окна "Диспетчер восстановления чертежей"

Для активизации/отключения возможности отправки в компанию Autodesk отчётов об ошибках


Восстановление после системного сбоя (Процедура)

Восстановление после системного сбоя
Восстановление после системного сбоя
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление после системного сбоя >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Открытие модуля "Диспетчер восстановления чертежей"

  • Выберитевкладку "Сервис" [image] панель "Утилиты" [image] "Диспетчер восстановления". В командной строке введите "восстанчертежа".

    В разделе "Файлы архива" указаны чертежи, которые требуется восстановить после неожиданного программного или системного сбоя.

Ввод команды: ВОССТАНЧЕРТЕЖА


Восстановление чертежа с помощью модуля "Диспетчер восстановления чертежей" (Процедура)

Восстановление после системного сбоя
Восстановление после системного сбоя
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление после системного сбоя >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Восстановление чертежа с помощью модуля "Диспетчер восстановления чертежей"

  1. В случае необходимости откройте окно "Диспетчер восстановления чертежей".
  2. В окне "Диспетчер восстановления чертежей", в разделе "Файлы архива", дважды нажмите на элементе чертежа, чтобы отобразился список всех имеющихся файлов чертежей и архива.
  3. Дважды нажмите на файле, чтобы его открыть.

    Если файл чертежа поврежден, исправления в чертеже по возможности выполняются автоматически.

Ввод команды: ВОССТАНЧЕРТЕЖА


Удаление чертежа из окна "Диспетчер восстановления чертежей" (Процедура)

Восстановление после системного сбоя
Восстановление после системного сбоя
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление после системного сбоя >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Удаление чертежа из окна "Диспетчер восстановления чертежей"

  1. В случае необходимости выберите вкладку "Сервис" [image] панель "Утилиты" [image] "Диспетчер восстановления". В командной строке введите "восстанчертежа".
  2. Выполните одно из следующих действий:
    • Восстановите чертеж, а затем сохраните его.
    • Нажмите правую кнопку мыши на элементе чертежа. Выберите "Исключить".
Ввод команды: ВОССТАНЧЕРТЕЖА


Восстановление после системного сбоя (Процедура)

Восстановление после системного сбоя
Восстановление после системного сбоя
Восстановление после системного сбоя
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление после системного сбоя >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Развертывание или свёртывание всех элементов в окне "Диспетчер восстановления чертежей"

  • Нажмите правую кнопку мыши в области раздела "Файлы архива" ниже последнего элемента чертежа в списке. Выберите "Свернуть все".
Ввод команды: ВОССТАНЧЕРТЕЖА


Для активизации/отключения возможности отправки в компанию Autodesk отчётов об ошибках (Процедура)

Восстановление после системного сбоя
Восстановление после системного сбоя
Описание стандартов
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление после системного сбоя >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Для активизации/отключения возможности отправки в компанию Autodesk отчётов об ошибках

  1. В командной строке введите reporterror.
  2. Введите 0 для отключения возможности отправки отчетов об ошибках; введите 1 для активизации возможности отправки отчетов об ошибках.


Восстановление после системного сбоя (Краткий справочник)

Создание файлов архива и восстановление
Восстановление после системного сбоя
Обзор стандартов оформления
Создание, организация и сохранение чертежей > Восстановление файлов чертежей > Восстановление после системного сбоя >
Восстановление после системного сбоя
Понятие Процедура Краткий справочник

Команды

ВОССТАНЧЕРТЕЖА

Отображение списка имен файлов чертежей, подлежащих восстановлению после сбоя системы

СКРЫТЬВОССТАНЧЕРТЕЖА

Закрытие Диспетчера восстановления чертежей

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ВОССТАН

Системные переменные

DRSTATE

Указание на открытое или закрытое состояние окна Диспетчера восстановления чертежей

ISAVEBAK

Повышает скорость сохранения, особенно для больших чертежей

RECOVERYMODE

Управление записью информации о восстановлении чертежа после системного сбоя

REPORTERROR

Управление возможностью отправки отчета об ошибке в компанию Autodesk при неожиданном закрытии программы

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Соблюдение стандартов в чертежах

Восстановление после системного сбоя
Создание, организация и сохранение чертежей
Обзор стандартов оформления
Создание, организация и сохранение чертежей >
Соблюдение стандартов в чертежах

Для удобства чтения чертежей задаются стандарты, обеспечивающие единство их оформления. Пользователь может устанавливать стандарты для имён слоев, размерных стилей и других элементов, проверять чертежи на соответствие этим стандартам и, в случае обнаружения нарушений, изменять свойства.

Темы в этом разделе

  • Обзор стандартов оформления
  • Описание стандартов

    Задаваемые стандарты сохраняются в виде файла стандартов, описывающего свойства слоев, размерных стилей, типов линий и текстовых стилей.Стандарты сохраняются в файле с расширением dws.

  • Проверка чертежей на соответствие стандартам

    Файлы чертежей можно проверять на соответствие стандартам и затем корректировать, устраняя нарушения. Утилита пакетного нормоконтроля позволяет одновременно проверять несколько файлов.

  • Преобразование имен и свойств слоев

    Слои чертежа можно переупорядочить для согласования с набором стандартов слоев.


Обзор стандартов оформления (Понятие)

Соблюдение стандартов в чертежах
Соблюдение стандартов в чертежах
Описание стандартов
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах >
Обзор стандартов оформления
Понятие Краткий справочник

Файл стандартов, в котором определяются общие свойства, служит для обеспечения единства оформления файлов чертежей. С помощью стандартов определяются наборы общих свойств именованных объектов, таких как слои и текстовые стили. Пользователь или администратор может создавать, использовать и проверять стандарты, заданные в чертежах . Применение стандартов особенно рекомендуется при совместной работе коллектива над одним проектом, так как стандарты упрощают понимание чертежей другими членами коллектива.

Проверка именованных объектов на соответствие стандартам

Стандарты можно создавать для следующих именованных объектов:

  • слои
  • текстовые стили
  • типы линий
  • размерные стили

Файл стандартов

После того как стандарт определен, его следует сохранить в файле стандартов. Файл стандартов может быть связан с несколькими файлами чертежей. Чертеж, связанный с файлом стандартов, следует периодически проверять на соответствие этим стандартам.

Процедура проверки на соответствие стандартам

При проверке чертежа на соответствие стандартам параметры каждого именованного объекта определенного типа сравниваются с соответствующими параметрами в соответствующих файлах стандартов. Например, параметры каждого слоя чертежа проверяются на соответствие параметрам слоев, заданным в файле стандартов.

В результате проверки могут быть выявлены два типа ошибок:

  • Нестандартное имя объекта в проверяемом чертеже. Например, слой с именем WALL присутствует в чертеже, но не найден ни в одном связанном файле стандартов.
  • Именованный объект со стандартным именем обладает нестандартными свойствами. Например, в чертеже слой WALL имеет желтый цвет, в то время как в файле стандартов для слоя WALL задан красный цвет.

Обнаруженные элементы с нестандартными именами удаляются из чертежа. Все объекты, имевшие связь с нестандартным элементом, связываются с другим элементом, который заменяет удаляемый. Например, при обнаружении нестандартного слоя WALL можно заменить его стандартным слоем АRCH-WALL. В этом случае в режиме "Исправить" диалогового окна "Нормоконтроль" все объекты со слоя WALL переносятся на слой АRCH-WALL, затем слой WALL удаляется из чертежа.

Надстройки для работы со стандартами

Для проверки используются подключаемые модули нормоконтроля, т.е. приложения, описывающие правила проверки свойств именованных объектов. Таким образом, слои, размерные стили, типы линий и текстовые стили проверяются на соответствие стандартам, задаваемым подключаемыми модулями, соответствующими данному типу объекта. Можно указывать, какие подключаемые модули следует использовать при проверке чертежа на соответствие стандартам. Autodesk или другие разработчики имеют возможность добавлять подключаемые модули стандартов для проверки дополнительных свойств чертежа.

Все подключаемые модули (кроме подключаемого модуля проверки слоев) проверяют все свойства каждого именованного объекта на соответствие стандартам. При проверке с использованием подключаемого модуля слоёв проверяются следующие свойства слоев:

  • цвет
  • тип линий
  • вес линий
  • режим стилей печати
  • имя стиля печати (если системная переменная PSTYLEMODE равна 0)

Следующие свойства слоёв не проверяются подключаемым модулем проверки слоев:

  • вкл/откл
  • заморозить/разморозить
  • блокировать
  • печатать/не печатать

Параметры нормоконтроля

С помощью диалогового окна "Параметры нормоконтроля" менеджер по САПР может изменять множество параметров. Для вызова диалогового окна "Параметры нормоконтроля" следует выбрать "Параметры" в диалоговом окне "Нормоконтроль" или "Настройка стандартов".


Обзор стандартов оформления (Краткий справочник)

Восстановление после системного сбоя
Обзор стандартов оформления
Описание стандартов
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Обзор стандартов оформления >
Обзор стандартов оформления
Понятие Краткий справочник

Команды

НОРМОКОНТРОЛЬ

Проверка текущего чертежа на соответствие установленным стандартам оформления

СТАНДАРТЫ

Управление подключением файлов стандартов к чертежам

Системные переменные

STANDARDSVIOLATION

Указание режима оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта

Утилиты

Утилита пакетного нормоконтроля

Проверка набора чертежей на соблюдение стандартов оформления

Ключевые слова для команд

Нет записей


Описание стандартов (Понятие)

Обзор стандартов оформления
Соблюдение стандартов в чертежах
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах >
Описание стандартов
Понятие Процедура Краткий справочник

Задаваемые стандарты сохраняются в виде файла стандартов, описывающего свойства слоев, размерных стилей, типов линий и текстовых стилей.Стандарты сохраняются в файле с расширением dws.

В зависимости от метода организации работы над проектом для одного чертежа можно создать и назначить несколько файлов стандартов. В связи с этим, во время проверки чертежа могут возникать конфликты между параметрами в разных файлах стандартов. Например, пусть в одном файле стандартов для слоя WALL задан желтый цвет, а в другом файле - красный. В таких случаях больший приоритет имеет первый файл стандартов, связанный с чертежом. При необходимости можно поменять порядок файлов стандартов для изменения приоритета параметров.

Когда требуется проверить чертежи на соответствие стандартам с использованием определенного подключаемого модуля, можно указать этот подключаемый модуль при описании файла стандартов. Например, если последние изменения, внесённые в чертеж, касались только текста, то для экономии времени можно ограничиться проверкой чертежа с помощью подключаемых модулей слоёв и подключаемого модуля текстовых стилей. По умолчанию для проверки чертежей на соответствие стандартам используются все подключаемые модули.


Описание стандартов (Процедура)

Восстановление после системного сбоя
Описание стандартов
Описание стандартов
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Описание стандартов >
Описание стандартов
Понятие Процедура Краткий справочник

Создание файла стандартов

Связывание файла стандартов с текущим чертежом

Для разрыва связи текущего чертежа с файлом стандартов

Изменение порядка файлов стандартов, связанных с текущим чертежом

Выбор подключаемых модулей для проверки чертежей на соответствие стандартам


Создание файла стандартов (Процедура)

Описание стандартов
Описание стандартов
Описание стандартов
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Описание стандартов >
Описание стандартов
Понятие Процедура Краткий справочник

Создание файла стандартов

  1. Выберите меню "Файл" [image] "Создать".В командной строке введите "новый".
  2. Введите имя файла шаблона или нажмите клавишу ENTER для продолжения.
  3. В новом чертеже создайте необходимые слои, размерные стили, типы линий и текстовые стили, которые должны храниться в файле стандартов.
  4. Выберите меню "Файл" [image] "Сохранить как".В командной строке введите "сохранитькак".
  5. В поле "Имя файла" введите имя файла стандартов.
  6. В списке "Тип файла" выберите "Стандарты оформления AutoCAD (*.dws)".

    DWS-файлы необходимо сохранять в формате текущей версии программы. Для сохранения DWS-файла в формате предыдущей версии необходимо сначала сохранить файл в DWG-формате требуемой версии, а затем переименовать его, сменив расширение .dwg на .dws.

  7. Нажмите кнопку "Сохранить".


Связывание файла стандартов с текущим чертежом (Процедура)

Описание стандартов
Описание стандартов
Описание стандартов
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Описание стандартов >
Описание стандартов
Понятие Процедура Краткий справочник

Связывание файла стандартов с текущим чертежом

  1. В командной строке введите стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Стандарты" нажмите кнопку "+" ("Добавить файл стандартов").
  3. В диалоговом окне "Выбор файла стандартов" найдите и выберите файл стандартов.
  4. Нажмите кнопку "Открыть".
  5. (Не обязательно) Повторите пункты 2 и 3, если нужно связать дополнительные файлы стандартов с текущим чертежом.
  6. Нажмите "ОК".
Панель:Стандарты оформления


Для разрыва связи текущего чертежа с файлом стандартов (Процедура)

Описание стандартов
Описание стандартов
Описание стандартов
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Описание стандартов >
Описание стандартов
Понятие Процедура Краткий справочник

Для разрыва связи текущего чертежа с файлом стандартов

  1. В командной строке введите стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Стандарты" выберите файл стандартов из списка "Файлы стандартов, подключенные к текущему чертежу".
  3. Нажмите кнопку "Отключить файл стандартов".
  4. (Не обязательно) Повторите пункты 2 и 3, если нужно разорвать связи с другими файлами стандартов.
  5. Нажмите "ОК".
Панель:Стандарты оформления


Изменение порядка файлов стандартов, связанных с текущим чертежом (Процедура)

Описание стандартов
Описание стандартов
Описание стандартов
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Описание стандартов >
Описание стандартов
Понятие Процедура Краткий справочник

Изменение порядка файлов стандартов, связанных с текущим чертежом

  1. В командной строке введите стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Стандарты" из списка "Файлы стандартов, подключенные к текущему чертежу" выберите файл стандартов, положение которого нужно изменить.
  3. Выполните одно из следующих действий:
    • Нажмите кнопку со стрелкой вверх ("Вверх") для перемещения файла стандартов в списке на одну позицию вверх.
    • Нажмите кнопку со стрелкой вниз ("Вниз") для перемещения файла стандартов в списке на одну позицию вниз.
  4. (Не обязательно) Повторите пункты 2 и 3, если нужно изменить положение в списке других файлов стандартов.
  5. Нажмите "ОК".
Панель:Стандарты оформления


Выбор подключаемых модулей для проверки чертежей на соответствие стандартам (Процедура)

Описание стандартов
Описание стандартов
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Описание стандартов >
Описание стандартов
Понятие Процедура Краткий справочник

Выбор подключаемых модулей для проверки чертежей на соответствие стандартам

  1. В командной строке введите стандарты.
  2. В диалоговом окне "Настройка стандартов" на вкладке "Надстройки" выполнить одно из следующих действий:
    • Установить флажок для одного или нескольких подключаемых модулей, которые необходимо задействовать при проверке чертежей на соответствие стандартам.
    • Для выбора всех подключаемых модулей щелкните правой кнопкой мыши в списке подключаемых модулей. Установите флажок "Выбрать все". (Для отмены выбора всех подключаемых модулей нажмите правую кнопку мыши в списке надстроек и выберите элемент "Отменить выбор".)
  3. Нажмите "ОК".
Панель:Стандарты оформления


Описание стандартов (Краткий справочник)

Обзор стандартов оформления
Описание стандартов
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Описание стандартов >
Описание стандартов
Понятие Процедура Краткий справочник

Команды

НОРМОКОНТРОЛЬ

Проверка текущего чертежа на соответствие установленным стандартам оформления

СТАНДАРТЫ

Управление подключением файлов стандартов к чертежам

Системные переменные

STANDARDSVIOLATION

Указание режима оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Проверка чертежей на соответствие стандартам (Понятие)

Описание стандартов
Соблюдение стандартов в чертежах
Преобразование имен и свойств слоев
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Файлы чертежей можно проверять на соответствие стандартам и затем корректировать, устраняя нарушения. Утилита пакетного нормоконтроля позволяет одновременно проверять несколько файлов.

Чертеж, связанный с файлом стандартов, следует периодически проверять на соответствие этим стандартам. Это особенно важно в тех случаях, когда над проектом работает целый коллектив. Например, может возникнуть ситуация, когда один из проектировщиков создаёт новые слои, которые не соответствуют стандартам, принятым его коллегами. Поэтому необходимо иметь возможность обнаружения и исправления нестандартных слоев.

Существует возможность уведомления пользователя о возникающих нарушениях стандартов непосредственно во время работы над чертежом. Эта функция позволяет исправлять нарушения стандартов сразу после их возникновения, что намного облегчает соблюдение соответствия стандартам.

Проверка одного чертежа

Для выявления нарушений стандартов в текущем чертеже используется команда НОРМОКОНТРОЛЬ. Перечень нестандартных объектов и варианты исправления нарушений отображаются в диалоговом окне "Нормоконтроль".

Каждое обнаруженное нарушение можно исправить или оставить без изменений. Сведения о каждом обнаруженном, но не исправленном нарушении стандартов сохраняются в чертеже. Можно отключить вывод сведений о таких проигнорированных объектах при последующих проверках чертежа.

Если для текущего нарушения стандартов нет предпочтительного варианта исправления, то в списке "Заменить на" не будет отмеченных вариантов, а кнопка "Исправить" будет недоступна. Если исправляется нарушение, которое в данный момент выведено в диалоговом окне "Нормоконтроль", то это нарушение будет отображаться в нём, пока не нажата кнопка "Исправить" или "Далее".

После того как весь чертёж проверен, отображается окно "Проверка завершена". В этом окне выводится отчёт о всех нарушениях стандартов, обнаруженных в чертеже, а также подробная информация по нарушениям: исправленным автоматически, исправленным вручную, проигнорированным.

ПримечаниеЕсли нестандартный слой содержит несколько нарушений (например, такое нарушение, когда есть одно имя нестандартного слоя и другое имя для свойств нестандартного слоя), то отображается первое обнаруженное нарушение. Последующие нарушения на нестандартном слое не оцениваются и, следовательно, не отображаются. Для проверки на наличие дополнительных нарушений команду необходимо выполнить снова.

Проверка нескольких чертежей

Для проверки нескольких чертежей применяется утилита пакетного нормоконтроля, которая объединяет все обнаруженные нарушения стандартов в один отчёт, помещаемый в HTML-файл. Перед запуском утилиты необходимо создать файл нормоконтроля (с расширением CHX). CHX-файл предназначен для настройки и отчётности; он содержит список файлов чертежей и стандартов, а также отчёт о результатах проверки чертежей на соответствие стандартам.

По умолчанию для проверки каждого чертежа используются связанные с ним файлы стандартов. Можно также задать иной набор файлов стандартов, отличный от принятого по умолчанию.

После завершения пакетной проверки результаты можно просмотреть в HTML-файле отчёта. Кроме того, в этот отчёт можно включить комментарии. Отчёт можно экспортировать и распечатать. Подобные отчёты с комментариями передаются другим разработчикам проекта для устранения ими нарушений, имеющих отношение к данному участку проекта.

Использование уведомлений о нарушениях стандартов при работе над чертежом

Параметры уведомлений задаются в диалоговом окне "Параметры нормоконтроля" и с помощью системной переменной STANDARDSVIOLATION. Если в диалоговом окне "Параметры нормоконтроля" отмечен пункт "Предупреждать при нарушениях стандартов", то уведомления о нарушениях будут выводиться при обнаружении нарушений стандартов во время работы над чертежом. Если отмечен пункт "Отображать значок стандартов в строке состояния", то в строке состояния будет отображаться значок при открытии файла, связанного с файлом стандартов, и при создании или изменении нестандартных объектов.

По умолчанию, если связанный файл стандартов не найден или обнаружено нарушение стандартов во время работы, в нижнем правом углу окна программы (в строке состояния) появляется сообщение.

Перед началом использования режимов уведомления следует проверить чертёж на соответствие стандартам с помощью диалогового окна "Нормоконтроль". В этом случае предупреждающие сообщения, перешедшие из предыдущего сеанса работы, не выводятся. После того как чертёж прошел проверку и были внесены исправления, предупреждающие сообщения выводятся только при обнаружении новых нарушений стандартов.

Вывод предупреждающих сообщений о нарушениях стандартов для именованных объектов

Если в диалоговом окне "Параметры нормоконтроля" установлен флажок "Предупреждать при нарушениях стандартов", то уведомления о нарушениях выводятся только при работе с именованными объектами (типы линий, текстовые стили, слои, размерные стили). Уведомления не выводятся в случае появления нарушений стандартов, не относящихся к именованным объектам. Кроме того, если в диалоговом окне "Нормоконтроль" именованный объект был помечен как "игнорируемый", то относительно этого объекта также не выводятся уведомления об обнаруженных нарушениях. При изменении нестандартных именованных объектов (например, при задании нестандартного слоя текущим) предупреждающее сообщение выводится.

После появления предупреждающего сообщения можно сделать выбор: исправить нарушение или оставить его без изменений. Если выбрано исправление нарушения, то открывается диалоговое окно "Нормоконтроль". Если оно уже открыто, то исправляться будут только что обнаруженные нарушения. После исправления нарушений можно продолжить прерванную работу в диалоговом окне "Нормоконтроль". Если исправлять нарушение не требуется, то при появлении предупреждающего сообщения следует выбрать "Не исправлять".

При открытии чертежа с одним или несколькими связанными файлами стандартов в строке состояния появляется значок связи с файлом стандартов. Если связанный файл стандартов не найден, то в строке состояния появляется значок отсутствия файла стандартов. Если дважды нажать на значке отсутствия файла стандартов, а затем восстановить или разорвать связи с не найденными файлами стандартов, то вместо значка отсутствия файла стандартов появляется значок связи с файлом стандартов.

ПримечаниеЕсли в диалоговом окне "Нормоконтроль" выбрать режим "Предупреждать при нарушениях стандартов" и исправить нарушение, то можно вернуться к процедуре исправления на том месте, где она была прервана. Если же активна режим "Отображать значок стандартов в строке состояния", а нарушение исправляется нажатием на значке, то процедуру исправления необходимо начать сначала.


Проверка чертежей на соответствие стандартам (Процедура)

Описание стандартов
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Проверка чертежа на соответствие стандартам

Включение и отключение показа проигнорированных нарушений

Включение и отключение показа уведомлений о нарушениях стандартов

Запуск утилиты пакетного нормоконтроля

Создание файла нормоконтроля для утилиты пакетного нормоконтроля

Открытие существующего файла нормоконтроля

Переопределение стандартов в файле нормоконтроля

Проверка нескольких чертежей на соответствие стандартам

Добавление комментариев к отчёту

Просмотр отчёта о ранее проведённом нормоконтроле

Экспорт отчёта о пакетном нормоконтроле


Проверка чертежа на соответствие стандартам (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Проверка чертежа на соответствие стандартам

  1. Откройте чертёж с одним или несколькими связанными файлами стандартов.

    В строке состояния появляется значок связи с файлом стандартов. Если связанный файл стандартов не найден, то в строке состояния появляется значок отсутствия файла стандартов.

    ПримечаниеЕсли нажать на значке отсутствия файла стандартов, а затем восстановить или разорвать связи с не найденными файлами стандартов, то вместо значка отсутствия файла стандартов появляется значок связи с файлом стандартов.
  2. В чертежах с подключенными файлами стандартов выберите вкладку "Сервис" [image] панель "Стандарты" [image] "Проверить". Введите "нормоконтроль" в командной строке.

    В диалоговом окне "Нормоконтроль" в группе "Нарушение" появляется сообщение о первом обнаруженном нарушении.

  3. Выполните одно из следующих действий:
    • Если необходимо исправить нарушение, используя выделенный вариант из списка "Заменить на", то нажмите кнопку "Исправить". Если в списке "Заменить на" имеется рекомендуемый вариант исправления, то слева от него устанавливается флажок. Если рекомендуемых вариантов исправления для данного нарушения нет, то кнопка "Исправить" недоступна.

      В группе "Нарушение" автоматически выводится сообщение о следующем обнаруженном нарушении стандартов.

    • Устраните нарушения стандартов вручную. Нажмите кнопку "Далее" для вывода информации о следующем нарушении.
    • Выберите "Игнорировать нарушение в дальнейшем". Нажмите кнопку "Далее" для вывода информации о следующем нарушении.

      Выбор значения "Игнорировать нарушение в дальнейшем" позволяет подавлять вывод сообщения о данном нарушении при очередной проверке командой НОРМОКОНТРОЛЬ.

    • Нажмите кнопку "Далее" для вывода информации о следующем нарушении.
  4. Повторяйте пункты 2 и 3, пока не будут обработаны все нарушения стандартов.
  5. Нажмите кнопку "Закрыть".
Панель:Стандарты оформления


Включение и отключение показа проигнорированных нарушений (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Включение и отключение показа проигнорированных нарушений

  1. В чертежах с подключенными файлами стандартов выберите вкладку "Сервис" [image] панель "Стандарты" [image] "Проверить". введите "нормоконтроль" в командной строке.
  2. В диалоговом окне "Нормоконтроль" выберите "Параметры".
  3. В диалоговом окне "Параметры нормоконтроля" установите или снимите флажок "Показывать проигнорированные нарушения".
  4. Нажмите "ОК".
Панель:Стандарты оформления


Включение и отключение показа уведомлений о нарушениях стандартов (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Включение и отключение показа уведомлений о нарушениях стандартов

  1. Выберите вкладку "Сервис" [image] панель "Стандарты" [image] "Настройка". Введите стандартыв командной строке.
  2. В диалоговом окне "Настройка стандартов" выберите "Параметры".
  3. Выполните одно из следующих действий:
    • Для отключения уведомлений выберите "Отменить уведомления о стандартах".
    • Для включения уведомлений-предупреждений выберите "Предупреждать при нарушениях стандартов".
    • Для включения уведомлений через значок в строке состояния выберите "Отображать значок стандарта в строке состояния".
  4. Нажмите "ОК".
Панель:Стандарты оформления


Запуск утилиты пакетного нормоконтроля (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Запуск утилиты пакетного нормоконтроля

  • Выберите меню "Пуск" (Windows) [image] "Все программы" [image] "Autodesk" [image] "ProductNameLong" [image] "Пакетный нормоконтроль".
ПримечаниеПри запуске утилиты пакетного нормоконтроля из командной строки DOS командой DWGCHECKSTANDARDS можно указывать различные параметры командной строки, используемые при выполнении пакетной проверки на соответствие стандартам.


Создание файла нормоконтроля для утилиты пакетного нормоконтроля (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Создание файла нормоконтроля для утилиты пакетного нормоконтроля

  1. Запустите утилиту пакетного нормоконтроля.
  2. В окне "Пакетный нормоконтроль" выберите пункт меню "Файл" [image] "Новый файл проверки". (Можно также нажать кнопку "Создать" на панели утилиты пакетного нормоконтроля.)
  3. На вкладке "Чертежи" нажмите кнопку "+" ("Добавить чертеж").
  4. В диалоговом окне "Открытие файла" выберите файл, который нужно проверить.
  5. (Не обязательно) Повторите пункты 3 и 4, если нужно добавить другие чертежи в файл нормоконтроля.
  6. Выберите меню "Файл" [image] "Сохранить как".В командной строке введите "сохранитькак". (Можно также нажать кнопку "Сохранить как" на панели "Пакетная проверка стандартов".)
  7. В диалоговом окне "Сохранение файла" введите имя файла в соответствующем поле.
  8. Нажмите кнопку "Сохранить".


Открытие существующего файла нормоконтроля (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Открытие существующего файла нормоконтроля

  1. Запустите утилиту пакетного нормоконтроля.
  2. В окне "Пакетный нормоконтроль" выберите меню "Файл" [image] "Открыть файл нормоконтроля". (Можно также нажать кнопку "Открыть" на панели утилиты пакетного нормоконтроля.)
  3. В диалоговом окне "Открытие файла" найдите и выберите файл нормоконтроля.
  4. Нажмите кнопку "Открыть".


Переопределение стандартов в файле нормоконтроля (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Переопределение стандартов в файле нормоконтроля

  1. Запустите утилиту пакетного нормоконтроля.
  2. Создайте новый или откройте существующий файл нормоконтроля.
  3. В окне утилиты пакетного нормоконтроля на вкладке "Стандарты" выберите параметр "Использовать для проверки всех чертежей следующие файлы стандартов".
  4. Нажмите кнопку "+" ("Добавить файл стандартов").
  5. В диалоговом окне "Открытие файла" выберите файл стандартов, используемых для замены. Нажмите кнопку "Открыть".
  6. (Не обязательно) Повторите пункты 5 и 6, если нужно добавить другие файлы нормоконтроля для задания переопределений.
  7. В окне "Пакетный нормоконтроль" выберите меню "Файл" [image] "Сохранить файл нормоконтроля". (Можно также нажать кнопку "Сохранить" на панели утилиты пакетного нормоконтроля.)


Проверка нескольких чертежей на соответствие стандартам (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Проверка нескольких чертежей на соответствие стандартам

  1. Запустите утилиту пакетного нормоконтроля.
  2. Откройте существующий или создать новый файл нормоконтроля.
  3. В окне "Пакетный нормоконтроль" выберите меню "Проверка" [image] "Начать проверку. (Можно также нажать кнопку "Сохранить" на панели утилиты пакетного нормоконтроля.)

    Результаты проверки появляются в окне просмотра.

    Процесс пакетной проверки можно прервать в любое время нажатием кнопки "Остановить проверку".

    ПримечаниеУтилита пакетного нормоконтроля не может проверять зашифрованные файлы.


Добавление комментариев к отчёту (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Добавление комментариев к отчёту

  1. Запустите утилиту пакетного нормоконтроля.
  2. Создайте новый или откройте существующий файл нормоконтроля.
  3. В окне утилиты пакетного нормоконтроля на вкладке "Замечания" введите текст комментария, включаемого в отчёт.
  4. Выберите меню "Файл" [image] "Сохранить файл нормоконтроля". (Можно также нажать кнопку "Сохранить" на панели утилиты пакетного нормоконтроля.)


Просмотр отчёта о ранее проведённом нормоконтроле (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Просмотр отчёта о ранее проведённом нормоконтроле

  1. Запустите утилиту пакетного нормоконтроля.
  2. Откройте файл нормоконтроля, который ранее использовался для проверки.
  3. В окне "Пакетный нормоконтроль" выберите меню "Проверка" [image] "Просмотреть отчёт".(Можно также нажать кнопку "Просмотреть отчёт" на панели утилиты пакетного нормоконтроля.)

    В окне просмотра появляется отчёт.

  4. Для задания фильтра отображения отчёта выберите один из следующих вариантов:
    • Общие сведения. Вывод общих данных о количестве нарушений в каждом проверяемом чертеже.
    • Надстройки. Вывод сведений об установленных в системе подключаемых модулей для пакетного нормоконтроля.
    • Стандарты. Вывод сведений о файлах стандартов, используемых для пакетного нормоконтроля.
    • Нарушения. Вывод подробных сведений о каждом нарушении, обнаруженном в чертежах.
    • Проигнорированные нарушения. Вывод подробных сведений обо всех проигнорированных нарушениях.
    • Все. Вывод всех имеющихся данных о проверке на соответствие стандартам.
  5. Для показа отчёта по отдельному чертежу в списке "Включая:" выберите нужный чертеж.


Экспорт отчёта о пакетном нормоконтроле (Процедура)

Проверка чертежей на соответствие стандартам
Проверка чертежей на соответствие стандартам
Преобразование имен и свойств слоев
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Экспорт отчёта о пакетном нормоконтроле

  1. Запустите утилиту пакетного нормоконтроля.
  2. Создайте новый или откройте существующий файл нормоконтроля.
  3. В окне "Пакетный нормоконтроль" выберите меню "Проверка" [image] "Вывести отчет". (Можно также нажать кнопку "Экспорт отчета" на панели утилиты пакетного нормоконтроля.)


Проверка чертежей на соответствие стандартам (Краткий справочник)

Описание стандартов
Проверка чертежей на соответствие стандартам
Преобразование имен и свойств слоев
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Проверка чертежей на соответствие стандартам >
Проверка чертежей на соответствие стандартам
Понятие Процедура Краткий справочник

Команды

НОРМОКОНТРОЛЬ

Проверка текущего чертежа на соответствие установленным стандартам оформления

СТАНДАРТЫ

Управление подключением файлов стандартов к чертежам

Системные переменные

STANDARDSVIOLATION

Указание режима оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта

Утилиты

Утилита пакетного нормоконтроля

Проверка набора чертежей на соблюдение стандартов оформления

Ключевые слова для команд

Нет записей


Преобразование имен и свойств слоев (Понятие)

Проверка чертежей на соответствие стандартам
Соблюдение стандартов в чертежах
Управление видами чертежей
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах >
Преобразование имен и свойств слоев
Понятие Процедура Краткий справочник

Слои чертежа можно переупорядочить для согласования с набором стандартов слоев.

Преобразование слоёв в соответствии с заданными стандартами

С помощью Транслятора слоев можно привести слои одного чертежа к тем стандартам слоев, которые определил пользователь.

Например, если чертеж получен из компании, в которой приняты обозначения слоев, не соответствующие стандартам вашей компании, то имена и свойства слоев чертежа можно изменить. Слои текущего чертежа можно поставить в соответствие слоям другого чертежа или файла стандартов, а затем выполнить преобразование текущих слоев. Если чертеж содержит слои с тем же именем, "Транслятор слоев" может автоматически привести свойства слоёв текущего чертежа в соответствие со свойствами этих слоев.

Заданные соответствия для преобразования слоёв можно сохранить в файле и затем повторно использовать при работе с другими чертежами.

Просмотр выбранных слоёв чертежа

С помощью модуля "Транслятор слоев" можно указывать слои, которые должны отображаться в области рисования.

Таким образом, можно просматривать объекты как на всех слоях чертежа, так и только на заданных слоях. Это позволяет визуально контролировать содержимое отдельных слоев.

Очистка чертежа от неиспользуемых слоев

С помощью Транслятора слоев можно удалять из чертежа все неиспользуемые слои.

Часто так поступают со слоями, которые были созданы для каких-либо целей, но более не нужны. Уменьшение числа слоев облегчает управление ими при дальнейшей работе над чертежом.


Преобразование имен и свойств слоев (Процедура)

Проверка чертежей на соответствие стандартам
Преобразование имен и свойств слоев
Преобразование имен и свойств слоев
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Преобразование имен и свойств слоев >
Преобразование имен и свойств слоев
Понятие Процедура Краткий справочник

Преобразование слоёв чертежа в соответствии с заданными стандартами

Выбор слоя для отображения его в области рисования

Очистка чертежа от всех неиспользуемых слоев


Преобразование слоёв чертежа в соответствии с заданными стандартами (Процедура)

Преобразование имен и свойств слоев
Преобразование имен и свойств слоев
Преобразование имен и свойств слоев
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Преобразование имен и свойств слоев >
Преобразование имен и свойств слоев
Понятие Процедура Краткий справочник

Преобразование слоёв чертежа в соответствии с заданными стандартами

  1. Выберитевкладку "Сервис" [image] панель "Стандарты" [image] "Транслятор слоев". В командной строке введите "слойтранс".
  2. В окне "Транслятор слоев" выполните одно из следующих действий:
    • Нажмите кнопку "Загрузить" для загрузки слоёв из чертежа, шаблона или файла стандартов оформления. В диалоговом окне "Выбор файла чертежа" выберите необходимый файл. Нажмите кнопку "Открыть".
    • Нажмите кнопку "Создать", чтобы задать новый слой. В диалоговом окне "Новый слой" введите имя нового слоя и выберите его свойства. Нажмите "ОК".

    При необходимости, пункт 2 можно повторить несколько раз. При загрузке файлов с одноименными стандартными слоями в список "Слои назначения" для определения стандартов используются свойства слоя из файла, загруженного первым; свойства одноименных слоёв из последующих файлов игнорируются.

  3. Для выполнения преобразований слои текущего чертежа поставьте в соответствие стандартным слоям. Можно использовать один или оба из следующих методов назначения слоев:
    • Для сопоставления всех одноименных слоёв одного списка со слоями другого списка выберите "Одноименные".
    • Для сопоставления отдельных слоёв в списке "Исходные слои" выберите один или несколько слоев. В списке "Слои назначения" выберите слой, свойства которого требуется использовать. Нажмите "Сопоставить" для выполнения сопоставления. Данный метод можно использовать для каждого слоя или группы слоев, которые необходимо преобразовать.

    Для исключения сопоставления выберите соответствующий элемент в списке "Таблица соответствий слоев". Выберите "Исключить". Для исключения всех сопоставлений нажмите правой кнопкой мыши в этом списке. Выберите "Исключить все".

  4. (Не обязательно) С помощью модуля "Транслятор слоев" можно выполнять следующие задачи:
    • Для изменения свойств назначаемого слоя в списке "Таблица соответствий слоев" выберите необходимое сопоставление. Нажмите кнопку "Изменить". В диалоговом окне "Редактирование слоя" измените тип, цвет и толщину линий или стиль печати назначаемого слоя. Нажмите "ОК".
    • Для адаптации процесса преобразования слоёв нажмите кнопку "Параметры". В диалоговом окне "Параметры" выберите необходимые значения параметров. Нажмите "ОК".
    • Для сохранения соответствий слоёв в файле нажмите кнопку "Сохранить". В диалоговом окне "Сохранение соответствий слоев" введите имя файла. Нажмите "ОК".
  5. Нажмите кнопку "Преобразовать" для запуска процедуры преобразования.
Панель:Стандарты оформления
Ввод команды: СЛОЙТРАНС


Выбор слоя для отображения его в области рисования (Процедура)

Преобразование имен и свойств слоев
Преобразование имен и свойств слоев
Преобразование имен и свойств слоев
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Преобразование имен и свойств слоев >
Преобразование имен и свойств слоев
Понятие Процедура Краткий справочник

Выбор слоя для отображения его в области рисования

  1. Выберитевкладку "Сервис" [image] панель "Стандарты" [image] "Транслятор слоев". В командной строке введите "слойтранс".
  2. В окне "Транслятор слоев" выберите "Параметры".
  3. В диалоговом окне "Параметры" выполнить одно из действий:
    • Для отображения объектов на выбранных слоях чертежа установите флажок "Показывать содержимое выбранного слоя". В области рисования будут отображены только те слои, которые выбраны в диалоговом окне "Транслятор слоев".
    • Для отображения объектов всех слоёв чертежа отключите режим "Показывать содержимое выбранного слоя".
  4. Нажмите "ОК".
Панель:Стандарты оформления
Ввод команды: СЛОЙТРАНС


Очистка чертежа от всех неиспользуемых слоев (Процедура)

Преобразование имен и свойств слоев
Преобразование имен и свойств слоев
Панорамирование или зумирование вида
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Преобразование имен и свойств слоев >
Преобразование имен и свойств слоев
Понятие Процедура Краткий справочник

Очистка чертежа от всех неиспользуемых слоев

  1. Выберитевкладку "Сервис" [image] панель "Стандарты" [image] "Транслятор слоев". В командной строке введите "слойтранс".
  2. В окне "Транслятор слоев" нажмите правой кнопкой мыши в списке "Исходные слои". Выберите "Удалить неиспользуемые". Все неиспользуемые слои удаляются из текущего чертежа.
Панель:Стандарты оформления
Ввод команды: СЛОЙТРАНС


Преобразование имен и свойств слоев (Краткий справочник)

Проверка чертежей на соответствие стандартам
Преобразование имен и свойств слоев
Панорамирование или зумирование вида
Создание, организация и сохранение чертежей > Соблюдение стандартов в чертежах > Преобразование имен и свойств слоев >
Преобразование имен и свойств слоев
Понятие Процедура Краткий справочник

Команды

СЛОЙТРАНС

Изменение системы слоев чертежа в соответствии с установленными пользователем стандартами

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление видами чертежей

Преобразование имен и свойств слоев
Изменение видов
Управление видами чертежей

Темы в этом разделе

  • Изменение видов

    Можно изменять экранное увеличение выводимого изображения для более детального его рассмотрения или перемещать чертеж по видовому экрану. Виды, сохраненные с заданием имени, впоследствии могут быть восстановлены на экране.

  • Использование инструментов 3D просмотра

    При работе в 3D часто требуется отображение различных видов, позволяющее просматривать и проверять 3D эффекты в пользовательском чертеже.

  • Работа с несколькими видами в пространстве модели

    Для того чтобы одновременно просматривать несколько видов одного чертежа, область построения чертежа на вкладке "Модель" можно разбить на отдельные области просмотра, называемые видовыми экранами пространства модели. Конфигурации видовых экранов пространства модели можно сохранять для повторного использования.


Изменение видов

Управление видами чертежей
Управление видами чертежей
Панорамирование или зумирование вида
Управление видами чертежей >
Изменение видов

Можно изменять экранное увеличение выводимого изображения для более детального его рассмотрения или перемещать чертеж по видовому экрану. Виды, сохраненные с заданием имени, впоследствии могут быть восстановлены на экране.

Темы в этом разделе

  • Панорамирование или зумирование вида

    Можно использовать панорамирование для перемещения вида по области рисования или зумирование для изменения экранного увеличения.

  • Панорамирование и зумирование в окне "Общий вид"

    При работе с большим чертежом для выполнения зумирования и панорамирования можно воспользоваться окном, в котором схематично отображается чертеж целиком.

  • Сохранение и восстановление видов

    При сохранении конкретных видов по имени можно восстанавливать их для разметки или распечатки либо при необходимости соотнесения их с конкретными деталями. Можно создавать и сохранять виды с помощью команд ВИД или КАМЕРА.

  • Управление стилем 3D проекции

    Можно просматривать как параллельную, так и перспективную проекцию 3D модели.

  • Раскраска модели и использование эффектов кромок

    Скрытие линий улучшает чертеж и проясняет конструкцию. При добавлении теней создается более реалистичное изображение модели.


Панорамирование или зумирование вида (Понятие)

Изменение видов
Изменение видов
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Можно использовать панорамирование для перемещения вида по области рисования или зумирование для изменения экранного увеличения.

С помощью параметра "В реальном времени" команды ПАН можно просматривать различные участки чертежа, перемещая курсор в нужном направлении. Команда ПАН, как при панорамировании камерой, не изменяет расположения и абсолютных размеров объектов; изменяются лишь размеры отображаемой части чертежа, т. е. вида.

Увеличение или уменьшение вида достигается путем изменения коэффициента экранного увеличения, как и при увеличении или уменьшении камерой. ПОКАЗАТЬ не изменяет абсолютных размеров объектов; изменяется лишь кратность увеличения вида на экране, т.е. размеры отображаемого фрагмента чертежа.

При работе с мелкими деталями чертежа часто возникает необходимость уменьшить чертеж, чтобы просмотреть сделанные изменения на общем виде. Для быстрого возврата к предыдущему виду служит команда ПОКАЗАТЬ с параметром "Предыдущий".

Здесь даются описания функций, наиболее часто используемых в работе. Подробнее обо всех параметрах команды ПОКАЗАТЬ см. Справочник команд.

Показ прямоугольной области крупным планом

Зумирование определенной прямоугольной области удобно выполнять, указывая два противоположных угла этой области.

Нижний левый угол заданной области становится нижним левым углом вида. Другой указанный угол может не совпадать с углом нового вида, так как вид приобретает такие размеры, чтобы точно покрывать область видового экрана.

Показать в реальном времени

С помощью функции "Реальное время" можно динамически зумировать вид, перемещая курсор вверх или вниз. Нажатием правой кнопки мыши можно вызвать контекстное меню с дополнительными параметрами управления видом.

Показ увеличенного изображения одного или нескольких объектов

ПОКАЗАТЬ с параметром "Объекты" - вывод с максимальным возможным коэффициентом экранного увеличения всех выбранных объектов так, чтобы они заполнили графическую область или текущий видовой экран.

Отображение всего чертежа

Показать до границ - вывод с максимальным возможным коэффициентом экранного увеличения всех объектов чертежа так, чтобы они заполнили графическую область или текущий видовой экран. Расчет коэффициента выполняется с учетом объектов на отключенных слоях. Объекты на замороженных слоях не учитываются.

ПОКАЗАТЬ с параметром "Все" - вывод пользовательских лимитов чертежа или границ чертежа, в зависимости от того, какой вид больше.

См. также

    • “Pointing Device Buttons” on page 1

    • Масштабирование видов на видовых экранах листа

    • Панели


Панорамирование или зумирование вида (Процедура)

Преобразование имен и свойств слоев
Панорамирование или зумирование вида
Панорамирование или зумирование вида
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Панорамирование перетаскиванием

Панорамирование путем указания точек

Зумирование в реальном времени

Для зумирования с помощью рамки

Отображение чертежа в его границах

Отображение чертежа в его границах

Восстановление предыдущего вида


Панорамирование перетаскиванием (Процедура)

Панорамирование или зумирование вида
Панорамирование или зумирование вида
Панорамирование или зумирование вида
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Панорамирование перетаскиванием

  1. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Пан". В командной строке введите "пан".
  2. Когда отображается курсор в виде кисти руки, удерживайте нажатой кнопку устройства указания при перемещении.

    Для мыши с функцией прокрутки при перемещении следует удерживать в нажатом состоянии кнопку-колесико.

  3. Нажмите ENTER, ESC или правую кнопку мыши для выхода.
Панель:Стандартный
Ввод команды: ПАН


Панорамирование путем указания точек (Процедура)

Панорамирование или зумирование вида
Панорамирование или зумирование вида
Панорамирование или зумирование вида
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Панорамирование путем указания точек

  1. Выберите меню "Вид" [image] "Панорамирование" [image] "Точка".
  2. Укажите базовую точку. Эта точка будет сдвинута в новое положение.
  3. Укажите вторую точку для выполнения панорамирования. Заданная до этого базовая точка смещается в нее.
Ввод команды: ПАН


Зумирование в реальном времени (Процедура)

Панорамирование или зумирование вида
Панорамирование или зумирование вида
Панорамирование или зумирование вида
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Зумирование в реальном времени

  1. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Зумирование". В командной строке введите "показать".
  2. Когда отображается курсор в виде кисти руки, удерживайте нажатой кнопку устройства указания и перемещайте его вертикально для увеличения и уменьшения.
  3. Нажмите ENTER, ESC или правую кнопку мыши для выхода.
Панель:Стандартный
Ввод команды: ПОКАЗАТЬ


Для зумирования с помощью рамки (Процедура)

Панорамирование или зумирование вида
Панорамирование или зумирование вида
Панорамирование или зумирование вида
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Для зумирования с помощью рамки

  1. Выберите меню "Вид" [image] "Зумирование" [image] "Окно".В командной строке введите "показать".
  2. Укажите первый угол области вида.
  3. Укажите противоположный угол.

    Команда ПОКАЗАТЬ автоматически переходит в режим "Рамка", если сразу после вызова команды указать точку.

Панель:Стандартный
Ввод команды: ПОКАЗАТЬ
Контекстное меню:Когда активна команда ПОКАЗАТЬ, щелкните правой кнопкой мыши в области рисования. Нажмите "Показать рамкой".


Отображение чертежа в его границах (Процедура)

Панорамирование или зумирование вида
Панорамирование или зумирование вида
Панорамирование или зумирование вида
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Отображение чертежа в его границах

  • Выберите меню "Вид" [image] "Зумирование" [image] "Границы".В командной строке введите "показать".

Выводятся все объекты с максимально возможным коэффициентом экранного увеличения так, чтобы не выходить за пределы графической области или текущего видового экрана.

Панель:Стандартный
Ввод команды: ПОКАЗАТЬ
Контекстное меню:Когда активна команда ПОКАЗАТЬ, щелкните правой кнопкой мыши в области рисования. Нажмите "Показать до границ".


Отображение чертежа в его границах (Процедура)

Панорамирование или зумирование вида
Панорамирование или зумирование вида
Панорамирование или зумирование вида
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Отображение чертежа в его границах

  • Выберите меню "Вид" [image] "Зумирование" [image] "Все".В командной строке введите "показать".

Весь чертеж в его лимитах отображается на текущем видовом экране или в графической области. Если имеются объекты, выходящие за лимиты, область вида увеличивается так, чтобы вместить и эти объекты.

Панель:Стандартный
Ввод команды: ПОКАЗАТЬ


Восстановление предыдущего вида (Процедура)

Панорамирование или зумирование вида
Панорамирование или зумирование вида
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Восстановление предыдущего вида

  • Выберите меню "Вид" [image] "Зумирование" [image] "Предыдущий".В командной строке введите "показать".

Команда ПОКАЗАТЬ с параметром "Предыдущий" восстанавливает только экранное увеличение и положение вида, но не предыдущее содержимое редактируемого чертежа.

Панель:Стандартный
Ввод команды: ПОКАЗАТЬ
Контекстное меню:Когда активна команда ПОКАЗАТЬ, щелкните правой кнопкой мыши в области рисования. Выберите "Показать исходный".


Панорамирование или зумирование вида (Краткий справочник)

Преобразование имен и свойств слоев
Панорамирование или зумирование вида
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование или зумирование вида >
Панорамирование или зумирование вида
Понятие Процедура Краткий справочник

Команды

ГЛАЗ

Вызов окна "Общий вид"

ПАН

Перемещение изображения на текущем видовом экране

ОТМЕНИТЬ

Отмена действия команд

НАСТРВИД

Задание точности аппроксимации объектов на текущем видовом экране

ПАРАМЕТРЫПВ

Отображение изменения в виде плавного перехода

ПОКАЗАТЬ

Увеличение или уменьшение видимого размера объектов на текущем видовом экране

Системные переменные

EXTMAX

Координаты верхней правой точки границ чертежа

EXTMIN

Координаты левой нижней точки границ чертежа

MBUTTONPAN

Управление действиями третьей кнопки или колесика на устройстве указания

RTDISPLAY

Управление отображением растровых изображений и объектов OLE при выполнении команды ПОКАЗАТЬ или ПАН в режиме реального времени

VTENABLE

Управление использованием плавной смены вида

VTDURATION

Длительность плавного перехода видов в миллисекундах

VTFPS

Минимальная скорость плавного перехода видов в кадрах в секунду

WHIPARC

Управление сглаживанием кругов и дуг на экране

WHIPTHREAD

Управление использованием дополнительного процессора для повышения скорости операций (например ПОКАЗАТЬ), выполняющих перерисовку или регенерацию чертежа

ZOOMFACTOR

Управление степенью изменения масштаба изображения при прокрутке колесика мыши

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Панорамирование и зумирование в окне "Общий вид" (Понятие)

Панорамирование или зумирование вида
Изменение видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

При работе с большим чертежом для выполнения зумирования и панорамирования можно воспользоваться окном, в котором схематично отображается чертеж целиком.

Окно "Общий вид" отображает общий вид чертежа и служит для быстрого перемещения в любую его часть на текущем видовом экране. В ходе работы в окне "Общий вид" можно производить панорамирование и зумирование, не прерывая выполнения текущей команды. Кроме того, можно задавать новые виды, не прибегая к выбору вариантов меню и не вводя команд.

Использование рамки вида для панорамирования и зумирования

Внутри окна "Общий вид" имеется рамка вида в форме жирного прямоугольника, задающая границы вида на текущем видовом экране. Изменение вида может выполняться путем изменения рамки вида в окне "Общий вид". Для увеличения видимых размеров чертежа рамка вида должна быть сделана меньше. Для уменьшения видимых размеров чертежа рамка вида должна быть сделана больше. Все действия, связанные с панорамированием и зумированием, выполняются при нажатии левой кнопки мыши. При нажатии правой кнопки мыши действия панорамирования и зумирования завершаются.

Панорамирование чертежа выполняется перемещением рамки вида.

Изменение размера изображения в окне "Общий вид"

С помощью кнопок на панели окна "Общий вид" можно изменять экранное увеличение его изображения, а также выполнять постепенное увеличение или уменьшение. Эти изменения не отражаются на виде в области построения чертежа.

Использование окна "Общий вид" при наличии нескольких видовых экранов

В окне "Общий вид" можно управлять видом только текущего видового экрана.

Изображение окна "Общий вид" каждый раз обновляется при внесении изменений в чертеж или переключении на другой видовой экран. При работе со сложными чертежами для повышения производительности можно отключить динамическое обновление изображения в окне "Общий вид". Если отключить эту функцию, изображение "Общий вид" обновляется только при активации окна "Общий вид".


Панорамирование и зумирование в окне "Общий вид" (Процедура)

Панорамирование или зумирование вида
Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Зумирование с помощью окна "Общий вид"

Панорамирование с помощью окна "Общий вид"

Отображение всего чертежа в окне "Общий вид"

Увеличение или уменьшение изображения в окне "Общий вид"

Включение и отключения динамического обновления

Включение и отключение динамического обновления


Зумирование с помощью окна "Общий вид" (Процедура)

Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Зумирование с помощью окна "Общий вид"

  1. Выберите меню "Вид" [image] "Общий вид".В командной строке введите "глаз".
  2. В окне "Общий вид" нажимайте кнопку мыши внутри рамки вида до тех пор, пока не появится стрелка.
  3. Переместите курсор вправо для уменьшения видимых размеров объектов. Переместите курсор влево для увеличения видимых размеров объектов.
  4. Нажмите правую кнопку мыши для завершения операции зумирования.
Ввод команды: ГЛАЗ


Панорамирование с помощью окна "Общий вид" (Процедура)

Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Панорамирование с помощью окна "Общий вид"

  1. Выберите меню "Вид" [image] "Общий вид".В командной строке введите "глаз".
  2. В окне "Общий вид" нажимайте кнопку мыши внутри рамки вида до тех пор, пока не появится перекрестье.
  3. Переместите курсор для смены вида.
  4. Нажмите правую кнопку мыши для завершения операции панорамирования.
Ввод команды: ГЛАЗ


Отображение всего чертежа в окне "Общий вид" (Процедура)

Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Отображение всего чертежа в окне "Общий вид"

  1. Выберите меню "Вид" [image] "Общий вид".В командной строке введите "глаз".
  2. В окне "Общий вид" выберите меню "Вид" [image] "Полный".
Ввод команды: ГЛАЗ


Увеличение или уменьшение изображения в окне "Общий вид" (Процедура)

Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Увеличение или уменьшение изображения в окне "Общий вид"

  1. Выберите пункт меню "Вид" [image] "Общий вид".В командной строке введите "глаз".
  2. На панели окна "Общий вид" нажмите кнопку "Увеличить" или "Уменьшить".
ПримечаниеЕсли в окне "Общий вид" виден чертеж полностью, пункт меню "Уменьшить" и соответствующая кнопка панели становятся недоступны. Если текущий вид примерно совпадает с показанной в окне частью чертежа, недоступными становятся пункт и кнопка "Увеличить".
Ввод команды: ГЛАЗ


Включение и отключения динамического обновления (Процедура)

Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Включение и отключения динамического обновления

  • В окне "Общий вид" выберите пункт меню "Параметры" [image] "Динамическое обновление".

    Установленный флажок указывает на то, что изображение в окне "Общий вид" обновляется по мере внесения изменений в чертеж.


Включение и отключение динамического обновления (Процедура)

Панорамирование и зумирование в окне "Общий вид"
Панорамирование и зумирование в окне "Общий вид"
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Включение и отключение динамического обновления

  • В окне "Общий вид" выберите пункт меню "Параметры" [image] "Автоматическое обновление видовых экранов".

    Установленный флажок указывает, что изображение в окне "Общий вид" обновляется по мере переключения видовых экранов.


Панорамирование и зумирование в окне "Общий вид" (Краткий справочник)

Панорамирование или зумирование вида
Панорамирование и зумирование в окне "Общий вид"
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Панорамирование и зумирование в окне "Общий вид" >
Панорамирование и зумирование в окне "Общий вид"
Понятие Процедура Краткий справочник

Команды

ГЛАЗ

Вызов окна "Общий вид"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение и восстановление видов (Понятие)

Панорамирование и зумирование в окне "Общий вид"
Изменение видов
Управление стилем 3D проекции
Управление видами чертежей > Изменение видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

При сохранении конкретных видов по имени можно восстанавливать их для разметки или распечатки либо при необходимости соотнесения их с конкретными деталями. Можно создавать и сохранять виды с помощью команд ВИД или КАМЕРА.

Именованный вид, созданный с помощью команды ВИД, содержит указанное увеличение, положение и ориентацию. В каждом сеансе работы с чертежом на любом видовом экране можно легко восстановить вид, который отображался там ранее, а также последовательно до 10 предыдущих видов.

Именованные виды и камеры сохраняются с чертежом и могут использоваться в любой момент. При компоновке листа можно восстановить именованный вид или камеру на видовом экране листа.

Сохранение вида

При присвоении виду имени и его сохранении запоминаются следующие параметры:

  • экранное увеличение вида, его центральная точка и направление взгляда;
  • категория вида, назначенная виду (не обязательно);
  • местоположение вида: вкладка "Модель" или вкладка определенной разметки листа;
  • видимость слоев в чертеже на момент сохранения вида;
  • пользовательская система координат;
  • 3D перспектива;
  • псевдоразрез;
  • визуальный стиль;
  • фон.

Восстановление именованного вида

Восстановление именованного вида происходит на текущем видовом экране. Именованные виды можно использовать для следующих целей:

  • Компоновка листа.
  • Восстановление вида, часто используемого при работе в пространстве модели.
  • Задание начального вида модели при открытии чертежа.


Сохранение и восстановление видов (Процедура)

Панорамирование и зумирование в окне "Общий вид"
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Отображение предыдущего вида

Отображение предыдущего вида во время панорамирования или зумирования в реальном времени

Сохранение вида с присвоением имени

Восстановление сохраненного вида

Переименование вида

Изменение свойств вида

Удаление именованного вида

Просмотр списка конфигураций видовых экранов


Отображение предыдущего вида (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Отображение предыдущего вида

  • На панели "Стандартная" нажмите кнопку "Показать предыдущий".
Ввод команды: ПОКАЗАТЬ


Отображение предыдущего вида во время панорамирования или зумирования в реальном времени (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Отображение предыдущего вида во время панорамирования или зумирования в реальном времени

  • Нажмите правую кнопку мыши в области построения. Выберите "Показать исходный".


Сохранение вида с присвоением имени (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Сохранение вида с присвоением имени

  1. Выполните одно из следующих действий:
    • Если в пространстве модели используется несколько видовых экранов, нажмите кнопку мыши в пределах видового экрана, в котором содержится сохраняемый вид.
    • При работе на листе выберите видовой экран.
  2. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  3. В диалоговом окне "Диспетчер видов" нажмите "Создать".
  4. В диалоговом окне "Новый вид" в поле "Имя вида" введите имя вида.

    Если чертеж входит в подшивку, выводится список категорий видов для этой подшивки. Можно добавить новую категорию или выбрать в списке существующую.

  5. В разделе "Границы" выберите одну из следующих функций для задания области вида:
    • Текущий экран. Включает всю видимую часть чертежа.
    • Задать рамкой. Сохранение части текущего вида. Диалоговое окно закрывается на время указания на чертеже двух противоположных углов вида. Для переопределения окна нажмите кнопку "Задать окно вида".
  6. Дважды нажмите "ОК" для сохранения нового вида.
Ввод команды: ВИД


Восстановление сохраненного вида (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Восстановление сохраненного вида

  1. Выполните одно из следующих действий:
    • Если в пространстве модели используется несколько видовых экранов, нажмите кнопку мыши в пределах видового экрана, в котором содержится восстанавливаемый вид.
    • При работе с разметкой листа выберите видовой экран.
  2. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  3. В диалоговом окне "Диспетчер видов" в списке "Виды" выберите вид, который требуется восстановить.
  4. Нажмите кнопку "Установить".
  5. Нажмите ОК.
Панель:Вид
Ввод команды: ВИД


Переименование вида (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Переименование вида

  1. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  2. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  3. В разделе "Общие" на панели "Свойства" выберите имя вида. Введите новое имя.
  4. Нажмите "ОК".
Панель:Вид
Ввод команды: ВИД


Изменение свойств вида (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Изменение свойств вида

  1. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  2. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  3. На панели "Свойства" нажмите свойство, которое требуется изменить.
  4. Укажите новое значение свойства, введя новое значение или выбрав его в списке значений.
  5. Нажмите "ОК".
Панель:Вид
Ввод команды: ВИД


Удаление именованного вида (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Сохранение и восстановление видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Удаление именованного вида

  1. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  2. В диалоговом окне "Диспетчер видов" выберите вид и затем нажмите "Удалить".
  3. Нажмите "ОК".
Панель:Вид
Ввод команды: ВИД


Просмотр списка конфигураций видовых экранов (Процедура)

Сохранение и восстановление видов
Сохранение и восстановление видов
Управление стилем 3D проекции
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Просмотр списка конфигураций видовых экранов

  • Выберите вкладку "Вид" [image] панель "Видовые экраны" [image] "Именованные ВЭ". В командной строке введите "вэкран".

Список сохраненных видовых экранов отображается в диалоговом окне "Видовые экраны", вкладка "Именованные ВЭ".

Панель:Видовые экраны
Ввод команды: ВЭКРАН


Сохранение и восстановление видов (Краткий справочник)

Панорамирование и зумирование в окне "Общий вид"
Сохранение и восстановление видов
Обзор параллельных и перспективных видов
Управление видами чертежей > Изменение видов > Сохранение и восстановление видов >
Сохранение и восстановление видов
Понятие Процедура Краткий справочник

Команды

ВИД

Сохранение и восстановление именованных видов, видов камеры, видов листов и стандартных видов

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

ПОКАЗАТЬ

Увеличение или уменьшение видимого размера объектов на текущем видовом экране

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление стилем 3D проекции

Сохранение и восстановление видов
Изменение видов
Обзор параллельных и перспективных видов
Управление видами чертежей > Изменение видов >
Управление стилем 3D проекции
Понятие Процедура

Можно просматривать как параллельную, так и перспективную проекцию 3D модели.

Темы в этом разделе

  • Обзор параллельных и перспективных видов

    На чертеже можно создавать реалистичные визуальные эффекты, задавая параллельные или перспективные проекции модели.

  • Определение перспективной проекции (ДВИД)

    Для перспективной проекции требуется указать расстояние между камерой и целью. Малое расстояние позволяет усилить эффект перспективы; и наоборот, большое расстояние снижает эффект.

  • Определение параллельной проекции

    Можно задать параллельную проекцию.

  • Выбор установленных 3D видов

    Существует несколько стандартных ортогональных и изометрических видов, которые можно выбирать по именам или по определениям.

  • Задание координат и углов для 3D видов

    Направление взгляда можно задать либо координатами точки зрения, либо двумя углами относительно координатных осей и плоскостей.

  • Выберите вид в плоскости XY

    Изменив положение текущей точки зрения, можно установить вид в плане текущей ПСК, предварительно сохраненной ПСК или МСК.


Управление стилем 3D проекции (Процедура)

Сохранение и восстановление видов
Управление стилем 3D проекции
Определение перспективной проекции (ДВИД)
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции >
Управление стилем 3D проекции
Понятие Процедура

Определение вида в перспективе 3D модели с помощью команды ДВИД

Отключение вида в перспективе с помощью команды ДВИД

Динамическая установка параллельной проекции

Установка стандартного 3D вида

Установка вида указанием координат точки зрения

Установка вида заданием двух углов поворота

Установка видов командой ТЗРЕНИЯ (архитектурный стиль)

Установка видов командой ТЗРЕНИЯ (технический стиль)

Изменение текущего вида на вид в планеXY.


Обзор параллельных и перспективных видов (Понятие)

Управление стилем 3D проекции
Управление стилем 3D проекции
Определение перспективной проекции (ДВИД)
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции >
Обзор параллельных и перспективных видов
Понятие Краткий справочник

На чертеже можно создавать реалистичные визуальные эффекты, задавая параллельные или перспективные проекции модели.

Разница между видом в перспективе и параллельной проекцией заключается в том, что для создания перспективной проекции дополнительно требуется информация о расстоянии между камерой и целью. Малое расстояние позволяет усилить эффект перспективы; и наоборот, большое расстояние снижает эффект.

На следующем рисунке показана одна и та же модель в параллельной проекции и в перспективе. Оба вида сформированы с одинаковым направлением взгляда.


Обзор параллельных и перспективных видов (Краткий справочник)

Сохранение и восстановление видов
Обзор параллельных и перспективных видов
Определение перспективной проекции (ДВИД)
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Обзор параллельных и перспективных видов >
Обзор параллельных и перспективных видов
Понятие Краткий справочник

Команды

3DОРБИТА

Управление интерактивным просмотром объектов в 3D пространстве

ДВИД

Установка параллельной проекции или вида в перспективе с помощью камеры и цели

Системные переменные

BACKZ
FRONTZ
LENSLENGTH

Значение фокусное расстояние объектива (в мм), используемого при построении вида в перспективе

TARGET

Положение точки цели (в координатах ПСК) на текущем видовом экране

VIEWDIR

Сохранение направления взгляда в текущем видовом экране, выраженного в координатах ПСК

VIEWMODE

Сохранение режима "Вид" для текущего видового экрана

VIEWTWIST

Хранение значения угла поворота вида для текущего видового экрана, измеренного относительно МСК

WORLDVIEW

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Определение перспективной проекции (ДВИД) (Понятие)

Обзор параллельных и перспективных видов
Управление стилем 3D проекции
Определение параллельной проекции
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции >
Определение перспективной проекции (ДВИД)
Понятие Процедура Краткий справочник

Для перспективной проекции требуется указать расстояние между камерой и целью. Малое расстояние позволяет усилить эффект перспективы; и наоборот, большое расстояние снижает эффект.

Режим перспективы можно отключить или отменить установкой иного вида.


Определение перспективной проекции (ДВИД) (Процедура)

Управление стилем 3D проекции
На уровень вверх ..
Определение перспективной проекции (ДВИД)
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Определение перспективной проекции (ДВИД) >
Определение перспективной проекции (ДВИД)
Понятие Процедура Краткий справочник

Определение вида в перспективе 3D модели с помощью команды ДВИД

Отключение вида в перспективе с помощью команды ДВИД


Определение вида в перспективе 3D модели с помощью команды ДВИД (Процедура)

Определение перспективной проекции (ДВИД)
На уровень вверх ..
Определение перспективной проекции (ДВИД)
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Определение перспективной проекции (ДВИД) >
Определение перспективной проекции (ДВИД)
Понятие Процедура Краткий справочник

Определение вида в перспективе 3D модели с помощью команды ДВИД

  1. В командной строке введите "двид".
  2. Выберите объекты для отображения.
  3. Введите к (Камера).

    По умолчанию камера установлена в центре чертежа.

  4. Настройте вид, указав положение и направление камеры.

    Стандартная модель домика иллюстрирует текущее направление взгляда. Настройка вида может осуществляться динамически перемещением перекрестья курсора и нажатием кнопки устройства указания.

  5. Для выбора режима ввода углов введите п (переключение).

    Настройка вида выполняется в одном из двух режимов ввода углов.

    • В ответ на приглашение "Введите угол от плоскости XY" введите значение угла для установки положения камеры относительно плоскости XY текущей ПСК. Угол 90 градусов, принятый по умолчанию, направлен сверху вниз.

      После ввода угла камера устанавливается на заданной высоте. Можно поворачивать камеру вокруг цели на углом поворота, измеренный относительно оси X в текущей ПСК.

    • В ответ на приглашение "Введите угол в плоскости XY от оси X" поверните камеру относительно цели, если угол поворота измерен относительно оси X текущей ПСК.
  6. Для включения перспективы вида введите d (distance -расстояние).
  7. Укажите расстояние или нажмите ENTER для включения перспективного вида.

    Расстояние от камеры до выбранных объектов можно устанавливать на скользящей шкале или путем ввода вещественного числового значения. При близко расположенных камере и цели или при большом фокусном расстоянии после задания нового расстояния на экране может оказаться видна лишь небольшая часть чертежа.

Ввод команды: ДВИД


Отключение вида в перспективе с помощью команды ДВИД (Процедура)

Определение перспективной проекции (ДВИД)
На уровень вверх ..
Определение параллельной проекции
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Определение перспективной проекции (ДВИД) >
Определение перспективной проекции (ДВИД)
Понятие Процедура Краткий справочник

Отключение вида в перспективе с помощью команды ДВИД

  1. В командной строке введите "двид".
  2. Выберите объекты для отображения.
  3. Введите о (Откл).

    Вид в перспективе отключается, и восстанавливается параллельная проекция.

Ввод команды: ДВИД


Определение перспективной проекции (ДВИД) (Краткий справочник)

Обзор параллельных и перспективных видов
Определение перспективной проекции (ДВИД)
Определение параллельной проекции
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Определение перспективной проекции (ДВИД) >
Определение перспективной проекции (ДВИД)
Понятие Процедура Краткий справочник

Команды

3DОРБИТА

Управление интерактивным просмотром объектов в 3D пространстве

ДВИД

Установка параллельной проекции или вида в перспективе с помощью камеры и цели

Системные переменные

BACKZ
FRONTZ
LENSLENGTH

Значение фокусное расстояние объектива (в мм), используемого при построении вида в перспективе

PERSPECTIVE
PERSPECTIVECLIP

Определение местоположения секущей плоскости базовой точки визуализации. Значение в процентах определяет нахождение секущей плоскости базовой точки визуализации. Доступный диапазон значений - 0,01-10,0. Если выбрать меньшее значение, значения объектов по оси z будут стягиваться к целевому виду и за него. При выбранном значении 0,5% плоскость подрезки будет находиться очень близко к базовой точке визуализации. В исключительных случаях можно использовать значение 0,1%, но все же рекомендуется увеличить значение, например, до 5%

TARGET

Положение точки цели (в координатах ПСК) на текущем видовом экране

VIEWDIR

Сохранение направления взгляда в текущем видовом экране, выраженного в координатах ПСК

VIEWMODE

Сохранение режима "Вид" для текущего видового экрана

VIEWTWIST

Хранение значения угла поворота вида для текущего видового экрана, измеренного относительно МСК

WORLDVIEW

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Определение параллельной проекции (Понятие)

Определение перспективной проекции (ДВИД)
Управление стилем 3D проекции
Выбор установленных 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции >
Определение параллельной проекции
Понятие Процедура Краткий справочник

Можно задать параллельную проекцию.

Задание точки зрения и направления в пространстве модели

  • Выберите один из стандартных 3D видов на панели "Вид".
  • Введите координаты или углы, описывающие положение точки зрения в 3D пространстве.
  • Выберите вид в плане (т.е. перпендикулярно плоскости XY) текущей ПСК, сохраненной ПСК или МСК.
  • Измените динамический 3D вид с помощью устройства указания.
  • Задайте переднюю и заднюю секущие плоскости для ограничения отображаемых объектов.

Просмотр 3D проекций возможен только в пространстве модели. В пространстве листа нельзя задавать виды с помощью таких команд работы с 3D видами, как ТЗРЕНИЯ, ДВИД или ПЛАН. В пространстве листа чертеж всегда отображается в плане.


Динамическая установка параллельной проекции (Процедура)

Определение перспективной проекции (ДВИД)
На уровень вверх ..
Выбор установленных 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Определение параллельной проекции >
Определение параллельной проекции
Понятие Процедура Краткий справочник

Динамическая установка параллельной проекции

  1. В командной строке введите "двид".
  2. Выполните одно из следующих действий:
    • Выберите объекты для отображения и нажмите ENTER.
    • Нажмите ENTER без выбора объекта; при этом стандартная модель домика иллюстрирует текущее направление взгляда.
  3. Введите к (камера).

    По умолчанию камера установлена в центре чертежа.

  4. Настройте вид, указав положение и направление камеры.

    Настройка вида может осуществляться динамически перемещением перекрестья курсора и нажатием кнопки устройства указания.

  5. Для выбора режима ввода углов введите п (переключение угла).

    Настройка вида выполняется в одном из двух режимов ввода углов.

    • В ответ на приглашение "Введите угол от плоскости XY" введите значение угла для установки положения камеры относительно плоскости XY текущей ПСК. Угол 90 градусов, принятый по умолчанию, направлен сверху вниз.

      После ввода угла камера устанавливается на заданной высоте. Можно поворачивать камеру вокруг цели на углом поворота, измеренный относительно оси X в текущей ПСК.

    • В ответ на приглашение "Введите угол в плоскости XY от оси X" поверните камеру относительно цели, если угол поворота измерен относительно оси X текущей ПСК.
  6. По завершении установки параллельной проекции нажмите ENTER.
Ввод команды: ДВИД


Определение параллельной проекции (Краткий справочник)

Определение перспективной проекции (ДВИД)
Определение параллельной проекции
Выбор установленных 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Определение параллельной проекции >
Определение параллельной проекции
Понятие Процедура Краткий справочник

Команды

ДВИД

Установка параллельной проекции или вида в перспективе с помощью камеры и цели

ПЛАН

Отображение вида в плане указанной ПСК

ТЗРЕНИЯ

Задание направления взгляда для 3D визуализации чертежа

Системные переменные

PERSPECTIVE
VIEWDIR

Сохранение направления взгляда в текущем видовом экране, выраженного в координатах ПСК

WORLDVIEW

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор установленных 3D видов (Понятие)

Определение параллельной проекции
Управление стилем 3D проекции
Задание координат и углов для 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции >
Выбор установленных 3D видов
Понятие Процедура Краткий справочник

Существует несколько стандартных ортогональных и изометрических видов, которые можно выбирать по именам или по определениям.

Быстрый способ установки вида заключается в выборе его из числа уже имеющихся стандартных 3D видов. Существует несколько стандартных ортогональных и изометрических видов, которые можно выбирать по именам или по определениям. Ортогональные виды отображают модель в проекциях сверху, снизу, спереди, слева, справа и сзади. Изометрические виды позволяют рассматривать следующие проекции: ЮЗ (юго-западная), ЮВ (юго-восточная), СВ (северо-восточная) и СЗ (северо-западная).

Для понимания сущности изометрических видов можно представить себе прямоугольный ящик, рассматриваемый сверху. Если, например, сместить точку зрения к нижнему левому углу ящика, получится изометрический юго-западный вид (ЮЗ). Если же сместить точку зрения к переднему верхнему углу ящика, получится изометрический северо-восточный вид (СВ).


Установка стандартного 3D вида (Процедура)

Определение параллельной проекции
На уровень вверх ..
Задание координат и углов для 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Выбор установленных 3D видов >
Выбор установленных 3D видов
Понятие Процедура Краткий справочник

Установка стандартного 3D вида

  • Выберите пункт меню "Вид" [image] "Трехмерные виды". Выберите стандартный вид ("Сверху", "Снизу", "Слева" и т.д.).
Панель:Вид
Ввод команды: ВИД


Выбор установленных 3D видов (Краткий справочник)

Определение параллельной проекции
Выбор установленных 3D видов
Задание координат и углов для 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Выбор установленных 3D видов >
Выбор установленных 3D видов
Понятие Процедура Краткий справочник

Команды

ВИД

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание координат и углов для 3D видов (Понятие)

Выбор установленных 3D видов
Управление стилем 3D проекции
Выберите вид в плоскости XY
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции >
Задание координат и углов для 3D видов
Понятие Процедура Краткий справочник

Направление взгляда можно задать либо координатами точки зрения, либо двумя углами относительно координатных осей и плоскостей.

Точка зрения задает положение в 3D пространстве, откуда направляется взгляд при рассмотрении модели в сторону точки начала координат (0,0,0). Координаты точки зрения задаются в Мировой системе координат, если не изменено значение системной переменной WORLDVIEW. Для стандартных видов предусмотрено два стиля: архитектурный (AEC) и технический. В архитектурном конструировании нормальный вид к плоскости XY - это вид сверху или план; в механическом конструировании нормальный вид к плоскости XY - это вид спереди.

Можно повернуть вид с помощью ДИАЛТЗР. На следующем чертеже показан вид, определенный двумя углами относительно оси X и плоскости XY МСК.


Задание координат и углов для 3D видов (Процедура)

Выбор установленных 3D видов
На уровень вверх ..
Задание координат и углов для 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Задание координат и углов для 3D видов >
Задание координат и углов для 3D видов
Понятие Процедура Краткий справочник

Установка вида указанием координат точки зрения

Установка вида заданием двух углов поворота

Установка видов командой ТЗРЕНИЯ (архитектурный стиль)

Установка видов командой ТЗРЕНИЯ (технический стиль)


Установка вида указанием координат точки зрения (Процедура)

Задание координат и углов для 3D видов
На уровень вверх ..
Задание координат и углов для 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Задание координат и углов для 3D видов >
Задание координат и углов для 3D видов
Понятие Процедура Краткий справочник

Установка вида указанием координат точки зрения

  1. Выберите меню "Вид" [image] "3D виды" [image] "Точка зрения".В командной строке введите "тзрения".
  2. Задайте точку зрения нажав кнопку мыши внутри компаса. Заданная точка зрения определяет направление взгляда на чертеж в сторону точки (0,0,0).
Ввод команды: ТЗРЕНИЯ


Установка вида заданием двух углов поворота (Процедура)

Задание координат и углов для 3D видов
На уровень вверх ..
Задание координат и углов для 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Задание координат и углов для 3D видов >
Задание координат и углов для 3D видов
Понятие Процедура Краткий справочник

Установка вида заданием двух углов поворота

  1. В командной строке введите "тзрения".
  2. Введите п (повернуть) для задания нового направления двумя углами.
  3. Введите угол с положительной осью X в плоскости XY.
  4. Введите угол с плоскостью XY для указания положения при рассмотрении модели в сторону точки (0,0,0).
Ввод команды: ТЗРЕНИЯ


Установка видов командой ТЗРЕНИЯ (архитектурный стиль) (Процедура)

Задание координат и углов для 3D видов
На уровень вверх ..
Задание координат и углов для 3D видов
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Задание координат и углов для 3D видов >
Задание координат и углов для 3D видов
Понятие Процедура Краткий справочник

Установка видов командой ТЗРЕНИЯ (архитектурный стиль)

  1. В командной строке введите "тзрения".
  2. Введите координаты необходимой точки зрения.
    • Введите 0,0,1 для задания вида сверху (плана).
    • Введите 0,-1,0 для задания вида спереди.
    • Введите 1,0,0 для задания вида справа.
    • Введите 1,-1,1 для задания изометрического вида.
Ввод команды: ТЗРЕНИЯ


Установка видов командой ТЗРЕНИЯ (технический стиль) (Процедура)

Задание координат и углов для 3D видов
На уровень вверх ..
Выберите вид в плоскости XY
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Задание координат и углов для 3D видов >
Задание координат и углов для 3D видов
Понятие Процедура Краткий справочник

Установка видов командой ТЗРЕНИЯ (технический стиль)

  1. В командной строке введите "тзрения".
  2. Введите координаты необходимой точки зрения.
    • Введите 0,0,1 для задания вида сверху (плана).
    • Введите 0,-1,0 для задания вида спереди.
    • Введите 1,0,0 для задания вида справа.
    • Введите 1,-1,1 для задания изометрического вида. Точка зрения для этого вида смещена вправо на 45 градусов и вверх на 35,267 градуса.
Ввод команды: ТЗРЕНИЯ


Задание координат и углов для 3D видов (Краткий справочник)

Выбор установленных 3D видов
Задание координат и углов для 3D видов
Выберите вид в плоскости XY
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Задание координат и углов для 3D видов >
Задание координат и углов для 3D видов
Понятие Процедура Краткий справочник

Команды

ВИД

Системные переменные

WORLDVIEW

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выберите вид в плоскости XY (Понятие)

Задание координат и углов для 3D видов
Управление стилем 3D проекции
Раскраска модели и использование эффектов кромок
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции >
Выберите вид в плоскости XY
Понятие Процедура Краткий справочник

Изменив положение текущей точки зрения, можно установить вид в плане текущей ПСК, предварительно сохраненной ПСК или МСК.

Вид сверху - это вид, полученный при взгляде из любой точки положительной половины оси Z в сторону точки начала координат (0,0,0). Полученный таким образом вид ортогонален плоскости XY.

Вид и систему координат, принятые по умолчанию во многих чертежах, можно восстановить с помощью установки для ориентации ПСК значения МСК, а затем установки вида сверху вместо 3D вида.


Изменение текущего вида на вид в планеXY. (Процедура)

Задание координат и углов для 3D видов
На уровень вверх ..
Раскраска модели и использование эффектов кромок
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Выберите вид в плоскости XY >
Выберите вид в плоскости XY
Понятие Процедура Краткий справочник

Изменение текущего вида на вид в плане XY.

  1. Выберите меню "Вид" [image] "3D виды".Нажмите "Вид сверху".
  2. Выберите одну из следующих функций:
    • Текущая ПСК
    • МСК
    • По имени (для сохраненного ранее вида)
    ПримечаниеКоманда ПЛАН изменяет направление взгляда и отключает перспективу и сечение, но не меняет текущую ПСК. Все координаты, вводимые или отображаемые после команды ПЛАН, отсчитываются относительно текущей ПСК.
Ввод команды: ПЛАН


Выберите вид в плоскости XY (Краткий справочник)

Задание координат и углов для 3D видов
Выберите вид в плоскости XY
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов > Управление стилем 3D проекции > Выберите вид в плоскости XY >
Выберите вид в плоскости XY
Понятие Процедура Краткий справочник

Команды

ДВИД

Установка параллельной проекции или вида в перспективе с помощью камеры и цели

ПЛАН

Отображение вида в плане указанной ПСК

Системные переменные

BACKZ
FRONTZ
VIEWDIR

Сохранение направления взгляда в текущем видовом экране, выраженного в координатах ПСК

VIEWTWIST

Хранение значения угла поворота вида для текущего видового экрана, измеренного относительно МСК

WORLDVIEW

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Раскраска модели и использование эффектов кромок

Выберите вид в плоскости XY
Изменение видов
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов >
Раскраска модели и использование эффектов кромок
Понятие Процедура

Скрытие линий улучшает чертеж и проясняет конструкцию. При добавлении теней создается более реалистичное изображение модели.

Темы в этом разделе

  • Использование стиля отображения для модели

    Стиль отображения - это набор параметров, который управляет отображением кромок и теней на видовом экране. Вместо использования команд и установки системных переменных можно изменять свойства стиля отображения. При применении стиля отображения или изменении параметров результат сразу виден на видовом экране.

  • Адаптация стиля отображения

    Можно создавать собственные стили отображения, изменяя настройки граней и кромок и используя затенение и фон.

  • Управление производительностью

    Отображение 3D графики и распределение памяти могут замедлить работу пользовательской системы. Адаптивное ухудшение качества, оптимизация параметров и настройка памяти - это разные подходы к обеспечению максимально возможной производительности.


Раскраска модели и использование эффектов кромок (Процедура)

Выберите вид в плоскости XY
Раскраска модели и использование эффектов кромок
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок >
Раскраска модели и использование эффектов кромок
Понятие Процедура

Применение стиля отображения к видовому экрану

Сохранение стиля отображения на панели инструментов

Использование стиля отображения в различных чертежах

Восстановление исходных параметров стиля отображения по умолчанию


Использование стиля отображения для модели (Понятие)

Раскраска модели и использование эффектов кромок
Раскраска модели и использование эффектов кромок
Адаптация стиля отображения
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Стиль отображения - это набор параметров, который управляет отображением кромок и теней на видовом экране. Вместо использования команд и установки системных переменных можно изменять свойства стиля отображения. При применении стиля отображения или изменении параметров результат сразу виден на видовом экране.

На рисунке Диспетчер визуальных стилей показаны примеры изображений со стилями отображения, доступными на чертеже. Выбранный стиль отображения обозначается желтой рамкой, а его параметры отображаются на панели под примерами изображений.

Когда отображается лента, можно непосредственно изменять наиболее часто используемые параметры, либо открыть "Диспетчер визуальных стилей".

В состав продукта входит пять стилей отображения по умолчанию:

  • 2D каркас. Объекты представляются в виде отрезков и кривых (как кромки граней и тел). Видны растровые и OLE-объекты, учитываются типы и веса линий.
  • 3D каркас (вверху слева на рисунке) Объекты представляются в виде отрезков и кривых (как кромки граней и тел).
  • 3D скрытые (вверху справа) Объекты представляются в каркасном виде; линии, относящиеся к задним граням, не отображаются.
  • Реалистичные (внизу слева) Раскрашиваются объекты и сглаживаются кромки между гранями многоугольника. Отображаются материалы объектов.
  • Концептуальные (внизу справа) Раскрашиваются объекты и сглаживаются кромки между гранями многоугольника. Для раскрашивания используется стиль грани "по Гучу" с переходом не от тени к свету, а между холодным и теплым цветовыми тонами. Этот эффект менее реалистичен, но он лучше отображает подробности модели.

В стилях отображения с раскрашиванием грань освещается двумя удаленными источниками, которые перемещаются при изменении направления взгляда на модель. Освещение по умолчанию предназначено для такого освещения всех граней модели, чтобы они были визуально различимы. Освещение по умолчанию доступно только тогда, когда все остальные источники света, включая солнечный цвет, выключены.

В любой момент можно выбрать стиль отображения или изменить его параметры. Вносимые изменения отражаются на видовых экранах при применении этого стиля отображения. Подробнее о параметрах граней, параметрах среды и параметрах кромок см. Адаптация стиля отображения. Все вносимые в стиль отображения изменения сохраняются на чертеже.


Использование стиля отображения для модели (Процедура)

Раскраска модели и использование эффектов кромок
На уровень вверх ..
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Использование стиля отображения для модели >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Применение стиля отображения к видовому экрану

Сохранение стиля отображения на панели инструментов

Использование стиля отображения в различных чертежах

Восстановление исходных параметров стиля отображения по умолчанию


Использование стиля отображения для модели (Процедура)

Использование стиля отображения для модели
На уровень вверх ..
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Использование стиля отображения для модели >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Сохранение стиля отображения в чертеже

  • Введите вссохранить в командной строке.


Применение стиля отображения к видовому экрану (Процедура)

Использование стиля отображения для модели
На уровень вверх ..
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Использование стиля отображения для модели >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Применение стиля отображения к видовому экрану

  1. Введите визстили в командной строке.
  2. Нажмите кнопку мыши на видовом экране для установки его в качестве текущего.
  3. В "Диспетчере стилей отображения" дважды нажмите кнопку мыши на примере изображения для требуемого стиля отображения.

    Выбранный стиль отображения применяется к модели на видовом экране.

    Значок на примере изображения указывает, что этот стиль отображения используется на текущем видовом экране. При изменении видового экрана значок изменяется и указывает, что этот стиль отображения используется на текущем чертеже.

    Панель:Визуальные стили
    Контекстное меню:Щелкните правой кнопкой мыши на визуальных стилях в Диспетчере визуальных стилей. Выберите "Применить к текущему видовому экрану".
    Ввод команды: ВИЗСТИЛИ


Сохранение стиля отображения на панели инструментов (Процедура)

Использование стиля отображения для модели
На уровень вверх ..
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Использование стиля отображения для модели >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Сохранение стиля отображения на панели инструментов

  1. Введите визстили в командной строке.
  2. Выберите меню "Сервис" [image] "Палитры" [image] "Инструментальные палитры".В командной строке введите "ИНСТРПАЛОТКЛ".
  3. В окне "Инструментальные палитры" выберите вкладку "Стили отображения".
  4. В "Диспетчере стилей отображения" выберите пример изображения для требуемого стиля отображения.
  5. Нажмите кнопку "Экспортировать выбранный визуальный стиль в инструментальную палитру" под изображениями.
    Панель:Визуальные стили
    Контекстное меню:Щелкните правой кнопкой мыши на визуальных стилях в Диспетчере визуальных стилей. Выберите "Экспортировать в активную инструментальную палитру"
    Ввод команды: ВИЗСТИЛИ


Использование стиля отображения в различных чертежах (Процедура)

Использование стиля отображения для модели
На уровень вверх ..
Использование стиля отображения для модели
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Использование стиля отображения для модели >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Использование стиля отображения в различных чертежах

  1. Откройте чертеж со стилем отображения, который следует использовать.
  2. Введите визстили в командной строке.
  3. Выберите в меню "Сервис" [image] "Палитры" [image] "Инструментальные палитры".В командной строке введите "ИНСТРПАЛОТКЛ".
  4. В окне "Инструментальные палитры" выберите вкладку "Стили отображения".
  5. В "Диспетчере стилей отображения" выберите пример изображения для требуемого стиля отображения.
  6. Нажмите кнопку "Экспортировать выбранный визуальный стиль в инструментальную палитру" под изображениями.
  7. Откройте чертеж, в котором требуется использовать этот стиль отображения.
  8. На панели инструментов выберите стиль отображения.
  9. Нажмите правую кнопку мыши и нажмите "Добавить к текущему чертежу".

    Стиль отображения добавляется к изображениям примеров в "Диспетчере стилей отображения" и на ленте.

    Панель:Визуальные стили
    Контекстное меню:Щелкните правой кнопкой мыши на визуальных стилях в Диспетчере визуальных стилей. Выберите "Экспорт в активную инструментальную палитру"
    Ввод команды: ВИЗСТИЛИ


Восстановление исходных параметров стиля отображения по умолчанию (Процедура)

Использование стиля отображения для модели
На уровень вверх ..
Адаптация стиля отображения
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Использование стиля отображения для модели >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Восстановление исходных параметров стиля отображения по умолчанию

  1. Введите визстили в командной строке.
  2. Выберите стиль отображения по умолчанию.

    Для стиля отображения по умолчанию в левом нижнем углу изображения примера отображается значок чертежа.

  3. Нажмите правую кнопку мыши и нажмите "Восстановить значения по умолчанию".
    Панель:Визуальные стили
    Ввод команды: ВИЗСТИЛИ


Использование стиля отображения для модели (Краткий справочник)

Выберите вид в плоскости XY
Использование стиля отображения для модели
Затенение и цвет граней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Использование стиля отображения для модели >
Использование стиля отображения для модели
Понятие Процедура Краткий справочник

Команды

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

ВИЗСТИЛИ

Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану

Системные переменные

ВИЗСТИЛИЗАКР

Закрытие Диспетчера визуальных стилей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Адаптация стиля отображения

Использование стиля отображения для модели
Раскраска модели и использование эффектов кромок
Затенение и цвет граней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок >
Адаптация стиля отображения
Понятие Процедура

Можно создавать собственные стили отображения, изменяя настройки граней и кромок и используя затенение и фон.

Темы в этом разделе

  • Затенение и цвет граней

    Эффекты затенения и цвета управляют отображением граней модели.

  • Отображение фонов и теней

    Стиль отображения определяет также отображение фонов и теней на видовом экране.

  • Управление отображением кромок

    Кромки разных типов отображаются с использованием линий различного типа и цвета. Можно также указать специальные эффекты, например дрожание и выступ за кромки.


Адаптация стиля отображения (Процедура)

Использование стиля отображения для модели
На уровень вверх ..
Затенение и цвет граней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения >
Адаптация стиля отображения
Понятие Процедура

Изменение отображения граней со сглаженного на фасетное

Управление стилем грани

Управление отображением цветов на гранях

Обеспечение прозрачности всех граней на видовом экране

Управление отображением теней на видовом экране

Установка сплошной заливки в качестве фона видового экрана

Установка градиента в качестве фона видового экрана

Установка изображения в качестве фона видового экрана

Установка Солнца или Неба в качестве фона видового экрана

Управление отображением ребер и цветом ребер

Добавление эффекта выступания к ребрам

Добавление эффекта дрожания к ребрам

Управление отображением кромок силуэта


Затенение и цвет граней (Понятие)

Адаптация стиля отображения
Адаптация стиля отображения
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения >
Затенение и цвет граней
Понятие Процедура Краткий справочник

Эффекты затенения и цвета управляют отображением граней модели.

Стили граней

Стиль грани определяет затенение грани. Реальный (см. внизу слева) означает создание реалистичного эффекта. Гуч (см. внизу справа) лучше отображает детали, смягчая контраст между освещенными и затененными областями. В освещенных областях используются теплые оттенки, а в темных областях - холодные оттенки.

При выбранном значении "Нет" для стиля граней не используется раскрашивание. Ребра в данном случае отображаются, если в параметрах ребер задано значение "Кромки граней" или "Изолинии".

Качество освещения

При использовании неравномерного освещения для каждой грани вычисляется один цвет. Окраска получается более единообразной. Равномерное освещение сглаживает ребра между многоугольными гранями путем вычисления цветов как градиентов между вершинами граней. Плавность раскраски в этом случае более высокая. Для повышения плавности необходимо включить пиксельное освещение в Диалоговое окно "Ручная оптимизация параметров". Цвета вычисляются для отдельных пикселов, что создает более плавные переходы. В противном случае используются параметры сглаживания.

Подсветка

Размер источников подсветки объекта влияет на ощущение блеска (см. ниже). При использовании меньших и более ярких источников подсветки объекты выглядят блестящими. Интенсивность подсветки, установленная в стиле отображения, не применяется к объекту с наложенными материалами.

Прозрачность

Свойство непрозрачности определяет кажущуюся степень прозрачности объекта (см. ниже).

Режимы цвета грани

Цвет может отображаться, как обычно, либо можно изменить режим цвета грани. В монохромном режиме все грани отображаются одним и тем же цветом с одинаковым оттенком. В режиме цветовых оттенков используется один и тот же цвет для раскрашивания всех граней с изменением значений оттенка и интенсивности цвета. Режим разбавления смягчает цвета.


Затенение и цвет граней (Процедура)

Адаптация стиля отображения
На уровень вверх ..
Затенение и цвет граней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Затенение и цвет граней >
Затенение и цвет граней
Понятие Процедура Краткий справочник

Изменение отображения граней со сглаженного на фасетное

Управление стилем грани

Управление отображением цветов на гранях

Обеспечение прозрачности всех граней на видовом экране


Изменение отображения граней со сглаженного на фасетное (Процедура)

Затенение и цвет граней
На уровень вверх ..
Затенение и цвет граней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Затенение и цвет граней >
Затенение и цвет граней
Понятие Процедура Краткий справочник

Изменение отображения граней со сглаженного на фасетное

  1. Выберите меню "Сервис" [image] "Палитры" [image] "Визуальные стили".
  2. Для текущего стиля отображения, выбранного в примерах изображений, замените "Сглаженное" на "Фасетное" в пункте "Качество освещения" в "Параметрах грани".
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Управление стилем грани (Процедура)

Затенение и цвет граней
На уровень вверх ..
Затенение и цвет граней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Затенение и цвет граней >
Затенение и цвет граней
Понятие Процедура Краткий справочник

Управление стилем грани

  1. Введите визстили в командной строке.
  2. Для текущего стиля отображения, выбранного в примерах изображений, выберите одну из указанных ниже опций в меню "Стиль грани" в "Параметрах грани".
    • Опция "Реалистичная" (по умолчанию) с максимально возможным приближением отображает то, как грань выглядит на самом деле.
    • Опция "Гуч" определяет использование гаммы холодных и теплых цветов вместо темных и светлых для улучшения отображения граней, которые могли бы быть затенены и плохо видимы в реалистичном представлении.
    • "Нет" не применяется к стилю грани. Другие параметры грани заблокированы.
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Управление отображением цветов на гранях (Процедура)

Затенение и цвет граней
На уровень вверх ..
Затенение и цвет граней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Затенение и цвет граней >
Затенение и цвет граней
Понятие Процедура Краткий справочник

Управление отображением цветов на гранях

  1. Для текущего стиля отображения, выбранного в примерах изображений, выберите одну из указанных ниже опций в меню "Режим цвета грани" раздела "Материалы и цвет" в "Параметрах грани".
    • Нормальный Не применяется к модификатору цвета грани.
    • Монохромное Модель отображается в оттенках заданного пользователем цвета.
    • Оттенок Изменяются оттенок и насыщенность цвета грани.
    • Уменьшение насыщенности Цвет смягчается путем сокращения компоненты его насыщенности на 30 процентов.
  2. Если выбран "Монохромный" или "Оттенок", укажите цвет. При выборе цвета открывается диалоговое окно "Выбор цвета".
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Обеспечение прозрачности всех граней на видовом экране (Процедура)

Затенение и цвет граней
На уровень вверх ..
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Затенение и цвет граней >
Затенение и цвет граней
Понятие Процедура Краткий справочник

Обеспечение прозрачности всех граней на видовом экране

  1. Выберите пункт меню "Сервис" [image] "Палитры" [image] "Лента".
  2. На панели управления "Стиль отображения" нажмите на "Режим рентгеновских лучей".


Затенение и цвет граней (Краткий справочник)

Использование стиля отображения для модели
Затенение и цвет граней
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Затенение и цвет граней >
Затенение и цвет граней
Понятие Процедура Краткий справочник

Команды

ВИЗСТИЛИ

Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану

Системные переменные

VISUALSTYLESCLOSE

Закрытие Диспетчера визуальных стилей

VSFACECOLORMODE

Управление вычислением цвета граней

VSFACEHIGHLIGHT

Управление отображением бликующей подсветки на гранях, не заполненных материалом, в текущем видовом экране

VSFACESTYLE

Управление отображением граней в текущем видовом экране

VSLIGHTINGQUALITY

Задание качества освещения в текущем видовом экране

VSMONOCOLOR

Задание цвета монохромного и тонированного отображения граней в стиле отображения, примененном к текущему видовому экрану

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Отображение фонов и теней (Понятие)

Затенение и цвет граней
Адаптация стиля отображения
Управление отображением кромок
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Стиль отображения определяет также отображение фонов и теней на видовом экране.

Фон

В качестве фона на видовом экране можно использовать цвет, градиентную заливку, изображение или солнце и небо в любом из 3D визуальных стилей, даже в стиле без затенения объектов. Чтобы использовать фон, необходимо вначале создать именованный вид с фоном и установить именованный вид в качестве текущего вида на видовом экране. Если "Фон" активизирован (Вкл) в текущем стиле отображения, отображается фон.

С тенями

Для затеняемых объектов на видовом экране возможно отображение теней. Тени на земле представляют собой тени, отбрасываемые объектами на землю. Полными тенями считаются тени, отбрасываемые объектами на другие объекты. Для отображения полных теней на видовом экране требуется освещенность в направлении от создаваемого пользователем источника света или от солнца. Тени, накладываемые одна на другую, выглядят затемненными.

ПримечаниеДля отображения полных теней требуется аппаратное ускорение. При отключенной улучшенной производительности 3D графики невозможно использовать режим полных теней. (Для доступа к эти установкам введите в командной строке графнастр. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка.)

Отображение теней может привести к замедлению работы. Можно отключать тени в текущем стиле отображения на время работы и затем восстанавливать их при появлении необходимости в них.

В палитре "Свойства" можно задать свойство "Отображение тени" для объекта: "отбрасываемая тень", "принимаемая тень", "отбрасываемая и принимаемая тень" или "игнорирует тени".

Для теней, используемых в тонировании, имеются дополнительные опции.

См. также

    • Тонирование с тенями


Отображение фонов и теней (Процедура)

Затенение и цвет граней
На уровень вверх ..
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Отображение фонов и теней >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Управление отображением теней на видовом экране

Установка сплошной заливки в качестве фона видового экрана

Установка градиента в качестве фона видового экрана

Установка изображения в качестве фона видового экрана

Установка Солнца или Неба в качестве фона видового экрана


Управление отображением теней на видовом экране (Процедура)

Отображение фонов и теней
На уровень вверх ..
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Отображение фонов и теней >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Управление отображением теней на видовом экране

  1. Введите визстили в командной строке.
  2. Для текущего стиля отображения из образцов изображений, выберите "Откл", "Полные тени" или "Тени на земле" в меню "Отображение теней" в "Параметрах среды".
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Установка сплошной заливки в качестве фона видового экрана (Процедура)

Отображение фонов и теней
На уровень вверх ..
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Отображение фонов и теней >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Установка сплошной заливки в качестве фона видового экрана

  1. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  2. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  3. На панели "Свойства" щелкните на поле "Переопределение фона".
  4. Выберите "Сплошная" из раскрывающегося списка "Переопределение фона".
  5. В диалоговом окне "Фон" щелкните на образце в разделе "Цвет".
  6. В диалоговом окне "Выбор цвета" укажите цвет, который будет использоваться для фона.
  7. Нажмите ОК.
  8. В диалоговом окне "Фон" нажмите "ОК".
  9. В окне "Диспетчер видов" щелчком выберите "Установить".
  10. Нажмите ОК.
Панель:Вид
Ввод команды: ВИД


Установка градиента в качестве фона видового экрана (Процедура)

Отображение фонов и теней
На уровень вверх ..
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Отображение фонов и теней >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Установка градиента в качестве фона видового экрана

  1. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  2. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  3. На панели "Свойства" щелкните на поле "Переопределение фона".
  4. Выберите "Градиент" из раскрывающегося списка "Переопределение фона".
  5. В диалоговом окне "Фон" задайте нужные настройки градиентной заливки.
    • Выберите "Три цвета" для использования 2- или 3-цветной градиентной заливки.
    • Щелкните на образцах цвета для вывода диалогового окна "Выбор цвета" и указания цветов, которые будут использоваться для градиентной заливки.
    • Введите значение угла поворота для градиентной заливки в текстовом поле "Угол поворота".
  6. В диалоговом окне "Фон" нажмите "ОК".
  7. В окне "Диспетчер видов" щелчком выберите "Установить".
  8. Нажмите ОК.
Панель:Вид
Ввод команды: ВИД


Установка изображения в качестве фона видового экрана (Процедура)

Отображение фонов и теней
На уровень вверх ..
Отображение фонов и теней
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Отображение фонов и теней >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Установка изображения в качестве фона видового экрана

  1. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  2. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  3. На панели "Свойства" щелкните на поле "Переопределение фона".
  4. Выберите "Изображение" из раскрывающегося списка "Переопределение фона".
  5. В диалоговом окне "Фон" щелчком выберите "Обзор" и укажите изображение фона.
  6. Выберите "Регулировка изображения".
  7. В диалоговом окне "Настройка фонового изображения" задайте нужные настройки изображения.
    • Укажите точку вставки изображения, выбрав вариант из раскрывающего списка "Точка вставки изображения".
    • Выберите щелчком "Смещение или масштабирование" для настройки функциональных возможностей регуляторов.
    • Выберите щелчком "Сохранять пропорции при масштабировании" для равномерного масштабирования изображения.
    • Перетащите регуляторы для настройки смещения или масштабирования изображения, исходя из текущей настройки.
  8. В диалоговом окне "Настройка фонового изображения" нажмите "ОК".
  9. В диалоговом окне "Фон" нажмите "ОК".
  10. В окне "Диспетчер видов" щелкните "Установить".
  11. Нажмите ОК.
Панель:Вид
Ввод команды: ВИД


Установка Солнца или Неба в качестве фона видового экрана (Процедура)

Отображение фонов и теней
На уровень вверх ..
Управление отображением кромок
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Отображение фонов и теней >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Установка Солнца или Неба в качестве фона видового экрана

  1. До того как менять фон, убедитесь в том, что включено фотометрическое освещение.
    • Используйте команду ЕДИНИЦЫ или установите "Освещение" в положение "Международные" или "Американские".
    • Введите LIGHTINGUNITS в командной строке, затем введите 1 или 2, после чего нажмите клавишу ENTER.
  2. Выберите меню "Вид" [image] "Именованные виды".В командной строке введите "вид".
  3. В диалоговом окне "Диспетчер видов" нажмите имя вида, которое требуется изменить. Если вид не отображается, разверните соответствующий список "Вид" и нажмите имя вида.
  4. На панели "Свойства" щелкните на поле "Переопределение фона".
  5. Выберите "Солнце_небо" из раскрывающегося списка "Переопределение фона".
  6. В диалоговом окне "Регулировка фона "Солнце и небо" задайте нужные настройки фона.
  7. Нажмите ОК.
  8. В окне "Диспетчер видов" щелкните "Установить".
  9. Нажмите ОК.
Панель:Вид
Ввод команды: ВИД


Отображение фонов и теней (Краткий справочник)

Затенение и цвет граней
Отображение фонов и теней
Управление отображением кромок
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Отображение фонов и теней >
Отображение фонов и теней
Понятие Процедура Краткий справочник

Команды

ВИД
ВИЗСТИЛИ

Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану

Системные переменные

CSHADOW

Задание свойства отображения теней для 3D объекта

SHADOWPLANELOCATION

Управление положением невидимой нулевой плоскости, используемой для отображения теней

VSBACKGROUNDS

Управление отображением фонов в стиле отображения, применяемом к текущему видовому экрану

VSSHADOWS

Управление отображением теней в стиле отображения

VISUALSTYLESCLOSE

Закрытие Диспетчера визуальных стилей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление отображением кромок (Понятие)

Отображение фонов и теней
Адаптация стиля отображения
Управление производительностью
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения >
Управление отображением кромок
Понятие Процедура Краткий справочник

Кромки разных типов отображаются с использованием линий различного типа и цвета. Можно также указать специальные эффекты, например дрожание и выступ за кромки.

Для модели с тенями или каркасной модели стиль отображения устанавливает видимость и вид изолиний, кромок граней, контуров, скрытых кромок и кромок пересечений. Кромки граней (ребра между плоскими гранями, представляющими поверхность) отображаются только в том случае, когда угол между гранями меньше заданного значения угла сгиба.

Модификаторы ребер, создающие эффекты дрожания и выступания, позволяют просмотреть модель на этапе разработки проектного решения. Дрожание придает линиям вид карандашного наброска. Выступание создает еще один эффект рисования от руки.

ПримечаниеСтили печати не доступны для объектов, к которым применяется модификатор ребра с дрожанием.


Управление отображением кромок (Процедура)

Отображение фонов и теней
На уровень вверх ..
Управление отображением кромок
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Управление отображением кромок >
Управление отображением кромок
Понятие Процедура Краткий справочник

Управление отображением ребер и цветом ребер

Добавление эффекта выступания к ребрам

Добавление эффекта дрожания к ребрам

Управление отображением кромок силуэта


Управление отображением ребер и цветом ребер (Процедура)

Управление отображением кромок
На уровень вверх ..
Управление отображением кромок
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Управление отображением кромок >
Управление отображением кромок
Понятие Процедура Краткий справочник

Управление отображением ребер и цветом ребер

  1. Введите визстили в командной строке.
  2. Для текущего стиля отображения, выбранного в примерах изображения, выберите "Кромки граней", "Изолинии" или "Нет" в пункте "Режим ребер" в "Параметрах ребер".
  3. Если выбраны "Изолинии", укажите число линий.
  4. В пункте "Цвет" укажите цвет. При выборе цвета открывается диалоговое окно "Выбор цвета".
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Добавление эффекта выступания к ребрам (Процедура)

Управление отображением кромок
На уровень вверх ..
Управление отображением кромок
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Управление отображением кромок >
Управление отображением кромок
Понятие Процедура Краткий справочник

Добавление эффекта выступания к ребрам

  1. Введите визстили в командной строке.
  2. Для текущего стиля отображения, выбранного в примерах изображений, нажмите кнопку "Выступающие ребра" в окне "Модификаторы ребер" и откорректируйте величину выступа в пункте "Выступание".
ПримечаниеВыступание масштабируется так, чтобы оно адекватно выглядело на видовых экранах различных размеров. Эффект выступания не применяется к линиям, которые короче удвоенной величины выступа.
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Добавление эффекта дрожания к ребрам (Процедура)

Управление отображением кромок
На уровень вверх ..
Управление отображением кромок
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Управление отображением кромок >
Управление отображением кромок
Понятие Процедура Краткий справочник

Добавление эффекта дрожания к ребрам

  1. Введите визстили в командной строке.
  2. Для текущего стиля отображения из образцов изображений, нажмите кнопку "Дрожащие ребра" в окне "Модификаторы ребер" и откорректируйте степень дрожания в соответствующем пункте.
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Управление отображением кромок силуэта (Процедура)

Управление отображением кромок
На уровень вверх ..
Управление производительностью
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Управление отображением кромок >
Управление отображением кромок
Понятие Процедура Краткий справочник

Управление отображением кромок силуэта

  1. Введите визстили в командной строке.
  2. Для текущего стиля отображения, выбранного в примерах изображений, выберите "Да" или "Нет" в пункте "Ребра быстрых силуэтов, Видимые".
  3. Если выбрано "Да", укажите ширину для кромок силуэта.
Панель:Визуальные стили
Ввод команды: ВИЗСТИЛИ


Управление отображением кромок (Краткий справочник)

Отображение фонов и теней
Управление отображением кромок
Адаптивное ухудшение
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Адаптация стиля отображения > Управление отображением кромок >
Управление отображением кромок
Понятие Процедура Краткий справочник

Команды

ВИЗСТИЛИ

Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану

Системные переменные

FACETRES

Регулировка гладкости раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями

INTERSECTIONCOLOR
INTERSECTIONCOLOR

Задание отображения полилиний пересечения

VISUALSTYLESCLOSE

Закрытие Диспетчера визуальных стилей

VSEDGECOLOR

Задание цвета граней в стиле отображения текущего видового экрана

VSEDGEJITTER

Управление степенью проявления линий сквозь карандашную зарисовку

VSEDGEOVERHANG

Отрезки продлеваются за их пересечения для создания эффекта рисования от руки

VSEDGES

Управление типом граней, отображаемых в видовом экране

VSEDGESMOOTH

Задание угла, под которым отображаются загнутые грани

VSHALOGAP

Задание коэффициента недовода в стиле отображения, примененном к текущему видовому экрану

SINTERSECTIONEDGES

Управление отображением ребер пересечения в стиле отображения, примененном к текущему видовому экрану

VSINTERSECTIONCOLOR

Указание цвета полилиний пересечения в стиле отображения, примененном к текущему видовому экрану

VSINTERSECTIONLTYPE

Задание типа линии для линий пересечения в визуальном стиле, примененном к текущему видовому экрану

VSOBSCUREDEDGES

Управление отображением граней заднего плана (скрытых)

VSOBSCUREDCOLOR

Задание цвета скрытых линий в визуальном стиле, примененном к текущему видовому экрану

VSOBSCUREDLTYPE

Определение типа скрытых линий в визуальном стиле, примененном к текущему видовому экрану

VSSILHEDGES

Управление отображением кромок силуэта твердотельных объектов в визуальном стиле, применяемом к текущему видовому экрану

VSSILHWIDTH

Управление шириной кромок силуэта в текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление производительностью

Управление отображением кромок
Раскраска модели и использование эффектов кромок
Адаптивное ухудшение
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок >
Управление производительностью
Понятие Процедура

Отображение 3D графики и распределение памяти могут замедлить работу пользовательской системы. Адаптивное ухудшение качества, оптимизация параметров и настройка памяти - это разные подходы к обеспечению максимально возможной производительности.

Темы в этом разделе

  • Адаптивное ухудшение

    Адаптивное ухудшение - это способ управления производительностью функций по мере их использования.

  • Оптимизация параметров

    Проверка видеокарты и драйвера 3D отображения и принятие решения о том, использовать ли применяемое программное или аппаратное обеспечение с точки зрения поддерживаемых функций.

  • Настройка памяти

    Производительность может быть повышена также путем увеличения объема памяти системы. Это особенно справедливо при работе с крупногабаритными моделями.


Управление производительностью (Процедура)

Управление отображением кромок
На уровень вверх ..
Адаптивное ухудшение
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью >
Управление производительностью
Понятие Процедура

Установка уровня производительности для адаптивного ухудшения качества

Изменение порядка адаптивного ухудшения

Просмотр протокола мастера оптимизации параметров

Оптимизация параметров вручную

Проверка обновлений графической карты и сертификации драйверов

Проверка физической памяти (RAM)

Проверка распределения файла подкачки


Адаптивное ухудшение (Понятие)

Управление производительностью
Управление производительностью
Оптимизация параметров
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью >
Адаптивное ухудшение
Понятие Процедура Краткий справочник

Адаптивное ухудшение - это способ управления производительностью функций по мере их использования.

Если производительность падает ниже указанного уровня при включенной функции адаптивного ухудшения качества, использование эффектов отключается или сокращается в определенном порядке до тех пор, пока производительность не восстановится до приемлемого уровня. В каждом стиле отображения устанавливается порядок ухудшения, соответствующий стилю, на базе основного порядка, который можно настраивать вручную.

Уровень производительности устанавливается в кадрах в секунду в диалоговом окне " Адаптивное ухудшение и оптимизация параметров". Можно также менять порядок отключения функций при снижении производительности. Например, при работе на модели со стилем отображения, содержащим тени и фон, можно переместить операции затенения и фона в верхнюю часть списка для того, чтобы они отключались первыми и сохраняли эффекты краев, необходимые для работы.


Адаптивное ухудшение (Процедура)

Управление производительностью
На уровень вверх ..
Адаптивное ухудшение
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Адаптивное ухудшение >
Адаптивное ухудшение
Понятие Процедура Краткий справочник

Установка уровня производительности для адаптивного ухудшения качества

Изменение порядка адаптивного ухудшения


Установка уровня производительности для адаптивного ухудшения качества (Процедура)

Адаптивное ухудшение
На уровень вверх ..
Адаптивное ухудшение
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Адаптивное ухудшение >
Адаптивное ухудшение
Понятие Процедура Краткий справочник

Установка уровня производительности для адаптивного ухудшения качества

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Система" выберите щелчком "Настройка производительности".
  3. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Адаптивное ухудшение".
  4. Введите или выберите значение в кадрах в секунду. Ухудшение отображения начинается, когда производительность опускается ниже этого значения.
  5. Нажмите "ОК".
Ввод команды: графнастр


Изменение порядка адаптивного ухудшения (Процедура)

Адаптивное ухудшение
На уровень вверх ..
Оптимизация параметров
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Адаптивное ухудшение >
Адаптивное ухудшение
Понятие Процедура Краткий справочник

Изменение порядка адаптивного ухудшения

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Система" выберите щелчком "Настройка производительности".
  3. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" выберите функцию в списке.
  4. Нажмите "Вверх" или "Вниз" для изменения ее положения в списке.

    Ухудшение начинается сверху и выполняется по списку.

  5. Нажмите "ОК".
Ввод команды: графнастр


Адаптивное ухудшение (Краткий справочник)

Управление отображением кромок
Адаптивное ухудшение
Оптимизация параметров
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Адаптивное ухудшение >
Адаптивное ухудшение
Понятие Процедура Краткий справочник

Команды

ГРАФНАСТР

Настройка параметров трехмерной графики

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

VSBACKGROUNDS

Управление отображением фонов в стиле отображения, применяемом к текущему видовому экрану

VSFACEOPACITY

Управление прозрачностью граней в текущем видовом экране

SINTERSECTIONEDGES

Управление отображением ребер пересечения в стиле отображения, примененном к текущему видовому экрану

VSSHADOWS

Управление отображением теней в стиле отображения

VSSILHEDGES

Управление отображением кромок силуэта твердотельных объектов в визуальном стиле, применяемом к текущему видовому экрану

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Оптимизация параметров (Понятие)

Адаптивное ухудшение
Управление производительностью
Настройка памяти
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью >
Оптимизация параметров
Понятие Процедура Краткий справочник

Проверка видеокарты и драйвера 3D отображения и принятие решения о том, использовать ли применяемое программное или аппаратное обеспечение с точки зрения поддерживаемых функций.

Функции, которые не могут правильно работать в данной системе, отключаются. Возможно, некоторые функции могут работать, но не рекомендуются для использовании с данной графической платой или драйвером графического 3D дисплея. Эти функции можно включить на свой риск.

ПримечаниеПри использовании видеокарты, которая поддерживает не все доступные аппаратные эффекты, чертеж можно печатать с помощью программной эмуляции. (Для включения эмуляции аппаратных эффектов в программном обеспечении введите "графнастр" в командной строке. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка". Затем выберите щелчком "Эмулировать при печати неподдерживаемые аппаратные эффекты в программе".)

Мастер оптимизации параметров создает журнал, в котором регистрируются графическая карта и драйвер 3D отображения, имеющиеся в текущей системе, и включенное или выключенное состояние эффектов. В разделе "Текущее состояние эффектов" отображаются настройки текущего драйвера монитора. Раздел "Текущее состояние эффектов" может выглядеть следующим образом:

Улучшенная производительность 3D графики: имеется и включено.
Отображение сглаженной линии: имеется и включено
Модуль тонирования Гуч: имеется и использует аппаратные средства
Полнотеневое отображение: имеется и включено
Пиксельное освещение: имеется и включено.
Сжатие текстур: доступно и включено

Можно вручную включать и отключать поддерживаемые системой функции, как рекомендованные, так и не рекомендованные.

В журнале, который создается мастером оптимизации параметров, отображается информация не только о текущем драйвере приложения, но также о всех доступных драйверах приложений и поддерживаемых эффектах. Эта информация находится в разделе "Доступные драйверы приложений и поддержка эффектов". Используя отображаемую информацию, можно принять наилучшее решение о том, какой драйвер приложения использовать для своей видеокарты, например Open GL, Direct 3D или драйвер программного обеспечения. Раздел "Доступные драйверы приложений и поддержка эффектов" может выглядеть следующим образом:

Драйвер программного обеспечения
Поддержка эффектов:
Улучшенная производительность 3D графики: не применяется.
Отображение сглаженных линий: не применяется.
Раскрашивание по Гучу: доступна только программная эмуляция.
Пиксельное освещение: имеется и включено.
Полное отображение теней: не применяется.
Сжатие текстур: не применяется.
драйвер OpenGL: сертифицировано
Поддержка эффектов:
Улучшенная производительность 3D графики: доступно.
Отображение линий со сглаживанием: доступно
Раскрашивание по Гучу: доступно
Пиксельное освещение: не применяется.
Полнотеневое отображение: доступно
Сжатие текстур: доступно
драйвер Direct3D: сертифицировано
Поддержка эффектов:
Улучшенная производительность 3D графики: доступно.
Отображение сглаженных линий: не применяется.
Раскрашивание по Гучу: доступно
Пиксельное освещение: имеется и включено.
Полнотеневое отображение: доступно
Сжатие текстур: доступно
ПримечаниеДля отображения полных теней на видовых экранах и для использования пиксельного освещения требуется аппаратное ускорение. При отключенной улучшенной производительности 3D графики полные тени не могут отображаться на видовых экранах. (Для доступа к эти установкам введите в командной строке графнастр. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка.)
ПримечаниеЕсли "Сжатие текстур" включено, то уменьшается объем видеопамяти, необходимый для открытия чертежа, который содержит материалы с изображениями или вставленные изображения. Используя этот эффект, можно уменьшить объем видеопамяти, необходимой для отображения чертежа, но недостатком этого эффекта является то, что он может увеличить время загрузки изображений при первом к ним обращении. Качество изображений снижается также при их отображении на видовом экране или при печати. (Для доступа к эти установкам введите в командной строке графнастр. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка".)

Обновления сертификации

Протестированные графические карты и драйверы 3D отображения добавляются в список на веб-узле Autodesk. Можно контролировать обновления и в любой момент загружать последний по времени список. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Проверка обновлений".


Оптимизация параметров (Процедура)

Адаптивное ухудшение
На уровень вверх ..
Оптимизация параметров
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Оптимизация параметров >
Оптимизация параметров
Понятие Процедура Краткий справочник

Просмотр протокола мастера оптимизации параметров

Оптимизация параметров вручную

Проверка обновлений графической карты и сертификации драйверов


Просмотр протокола мастера оптимизации параметров (Процедура)

Оптимизация параметров
На уровень вверх ..
Оптимизация параметров
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Оптимизация параметров >
Оптимизация параметров
Понятие Процедура Краткий справочник

Просмотр протокола мастера оптимизации параметров

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Система" выберите щелчком "Настройка производительности".
  3. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Просмотр протокола оптимизации".
  4. Для выхода из каждого диалогового окна нажмите "ОК".
Ввод команды: графнастр


Оптимизация параметров вручную (Процедура)

Оптимизация параметров
На уровень вверх ..
Оптимизация параметров
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Оптимизация параметров >
Оптимизация параметров
Понятие Процедура Краткий справочник

Оптимизация параметров вручную

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Система" выберите щелчком "Настройка производительности".
  3. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка".
  4. В диалоговом окне "Ручная оптимизация параметров" можно вводить в действие аппаратное ускорение, если значком по соседству с флажком является зеленая контрольная метка или желтый предупредительный знак.
  5. В окне "Общие параметры" можно отменять параметры или изменять их значения для повышения производительности.
  6. (Дополнительно) Использовать опцию "Сброс до рекомендуемых значений"
  7. Для выхода из каждого диалогового окна нажмите "ОК".
Ввод команды: графнастр


Проверка обновлений графической карты и сертификации драйверов (Процедура)

Оптимизация параметров
На уровень вверх ..
Настройка памяти
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Оптимизация параметров >
Оптимизация параметров
Понятие Процедура Краткий справочник

Проверка обновлений графической карты и сертификации драйверов

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Система" выберите щелчком "Настройка производительности".
  3. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Проверка обновлений".

    Откроется веб-узел с описанием программы сертификации.

  4. Найдите в списке свою графическую карту и драйвер. Если они имеются в списке, следуйте инструкциям по загрузке.
  5. Для выхода из каждого диалогового окна нажмите "ОК".
Ввод команды: графнастр


Оптимизация параметров (Краткий справочник)

Адаптивное ухудшение
Оптимизация параметров
Настройка памяти
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Оптимизация параметров >
Оптимизация параметров
Понятие Процедура Краткий справочник

Команды

ГРАФНАСТР

Настройка параметров трехмерной графики

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

VSSHADOWS

Управление отображением теней в стиле отображения

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка памяти (Понятие)

Оптимизация параметров
Управление производительностью
Использование инструментов 3D просмотра
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью >
Настройка памяти
Понятие Процедура Краткий справочник

Производительность может быть повышена также путем увеличения объема памяти системы. Это особенно справедливо при работе с крупногабаритными моделями.

Системные требования для AutoCAD составляют не менее 512 Мб физической памяти (ОЗУ) для работы в 2D. Для создания 3D-моделей и работы с ними требуется ОЗУ объемом не менее 2 Гб.

Эффективность работы приложения часто определяется размером и сложностью модели. Повышенная активность дисковода жесткого диска указывает на превышение лимита физической памяти и на перенос данных в файл подкачки (виртуальную память).

Файл подкачки является областью в накопителе на жестком диске, используемой системой Windows в качестве замены физической памяти. Объем файла подкачки является фактически лимитом, ограничивающим суммарный виртуальный размер процесса AutoCAD. На практике рекомендуется выбирать объем файла подкачки равным трехкратному объему физической памяти в пользовательской системе. Данный лимит является обычно достаточно высоким для того, чтобы система AutoCAD не выходила за пределы пространства подкачки.

Как правило, объем виртуальной памяти ограничивается для систем максимумом 2 Гбайт. В некоторых системах можно устанавливать переключатель /3GB, предоставляющий приложениям виртуальную память объемом до 3 Гбайт. Перед установкой переключателя необходимо выяснить следующее:

  • поддерживает ли используемая система данный переключатель;
  • не помешает ли установка переключателя работе других драйверов устройств (драйверов плоттера, видеокарты и др.).
  • Установка переключателя

Переключатель /3GB подробно описывается на веб-узле Microsoft.


Настройка памяти (Процедура)

Оптимизация параметров
На уровень вверх ..
Настройка памяти
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Настройка памяти >
Настройка памяти
Понятие Процедура Краткий справочник

Проверка физической памяти (RAM)

Проверка распределения файла подкачки


Проверка физической памяти (RAM) (Процедура)

Настройка памяти
На уровень вверх ..
Настройка памяти
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Настройка памяти >
Настройка памяти
Понятие Процедура Краткий справочник

Проверка физической памяти (RAM)

  1. В меню "Пуск" (Windows) выберите "Панель управления" (или "Настройка" [image] "Панель управления").
  2. На панели управления выберите щелчком "Система". При необходимости щелкните "Быстродействие", а затем "Система".
  3. На вкладке "Общие" просмотрите информацию о своем компьютере. На данной вкладке должен быть указан объем RAM.


Проверка распределения файла подкачки (Процедура)

Настройка памяти
На уровень вверх ..
Определение 3D видов
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Настройка памяти >
Настройка памяти
Понятие Процедура Краткий справочник

Проверка распределения файла подкачки

  1. В меню "Пуск" (Windows) выберите "Панель управления" (или "Настройка" [image] "Панель управления").
  2. На панели управления выберите щелчком "Система". При необходимости щелкните "Быстродействие", а затем "Система".
  3. Перейдите на вкладку "Дополнительно" и нажмите кнопку "Параметры" (или "Настройка быстродействия") в разделе "Быстродействие".
  4. Проверьте объем, выделенный под группу виртуальной памяти. Размер файла приводится после текста "Общий размер файла подкачки для всех устройств". При необходимости вначале перейдите на вкладку "Дополнительно", чтобы увидеть выделенный объем.


Настройка памяти (Краткий справочник)

Оптимизация параметров
Настройка памяти
Обзор 3D видов
Управление видами чертежей > Изменение видов > Раскраска модели и использование эффектов кромок > Управление производительностью > Настройка памяти >
Настройка памяти
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование инструментов 3D просмотра

Настройка памяти
Управление видами чертежей
Определение 3D видов
Управление видами чертежей >
Использование инструментов 3D просмотра

При работе в 3D часто требуется отображение различных видов, позволяющее просматривать и проверять 3D эффекты в пользовательском чертеже.

Темы в этом разделе

  • Определение 3D видов

    Можно управлять инструментами отображения 3D навигации, проекции и визуализации.

  • Определение трехмерного вида с помощью камеры

    Для определения 3D вида поместите камеру в пространство модели и откорректируйте параметры камеры для привязки к своим потребностям.

  • Создание анимаций предварительного просмотра

    Перед созданием анимаций перемещения по траектории можно создавать анимации 3D просмотра и корректировать параметры.

  • Создание анимации перемещением по траектории

    Анимации перемещением по траектории, например трехмерные анимации обхода модели, позволяют демонстрировать модель техническим специалистам и другим зрителям. Можно записывать и воспроизводить перемещение с целью динамического доведения цели своего проекта до других пользователей.


Определение 3D видов

Использование инструментов 3D просмотра
Использование инструментов 3D просмотра
Обзор 3D видов
Управление видами чертежей > Использование инструментов 3D просмотра >
Определение 3D видов
Понятие Процедура

Можно управлять инструментами отображения 3D навигации, проекции и визуализации.

Темы в этом разделе

  • Обзор 3D видов

    На текущем видовом экране можно создать интерактивный вид чертежа.

  • Использование инструментов 3D перемещения

    Инструменты 3D навигации позволяют просматривать объекты в чертежах под различными углами, с различных высот и с различных расстояний.

  • Обход и облет всего чертежа

    Возможна имитация обхода и облета всего 3D чертежа.

  • Создание трехмерного динамического вида

    Вид можно изменять с помощью функции, объединяющей в себе панорамирование и зумирование, без прерывания текущих операций.


Определение 3D видов (Процедура)

Настройка памяти
Определение 3D видов
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов >
Определение 3D видов
Понятие Процедура

Запуск 3D орбитального вида

Включение режима 3D навигации

Выбор параллельной или перспективной проекции на трехмерном виде

Изменение стиля отображения на трехмерном виде

Для запуска постоянного вращения по орбите

Восстановление начального вида

Использование стандартных видов

Отображение именованного вида

Запуск режима обхода

Запуск режима облета

Задание параметров обхода или облета

Изменение позиции просмотра в окне "Локатор положения"

Отключение окна "Локатор положения"

Установка секущих плоскостей (ДВИД)

Восстановление вида по умолчанию и ПСК


Обзор 3D видов (Понятие)

Определение 3D видов
Определение 3D видов
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов >
Обзор 3D видов
Понятие Краткий справочник

На текущем видовом экране можно создать интерактивный вид чертежа.

С помощью инструментов 3D просмотра и навигации пользователь может перемещаться по чертежу, настраивать камеру на определенный вид и создавать анимации для обеспечения параллельного доступа к своему проекту другим пользователям. Можно перемещаться по всей 3D модели в режиме движения по кругу, разворота, обхода или облета, настраивать камеру, создавать файл предварительного просмотра анимации и записывать анимации траектории перемещения, которые можно передавать другим пользователям для визуального ознакомления с целями своего проекта.


Обзор 3D видов (Краткий справочник)

Настройка памяти
Обзор 3D видов
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обзор 3D видов >
Обзор 3D видов
Понятие Краткий справочник

Команды

3DСЕКПЛ

Установка режима интерактивного 3D просмотра и открытие окна "Регулировка секущих плоскостей"

3DПОРБИТА

Установка режима интерактивного 3D просмотра и задание непрерывного движения объектов

3DРАССТ

Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них

3DОБЛЕТ

Интерактивное изменение пользовательского вида 3D чертежей, имитируя пролет наблюдателя сквозь модель

3DСОРБИТА

Управление интерактивным просмотром объектов в 3D режиме при использовании независимой орбиты

3DОРБИТА

Управление интерактивным просмотром объектов в 3D пространстве

3DORBITCTR

Задание центра вращения на 3D орбитальных видах

3-ПАН

Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально

3DОРБЦЕНТР

Изменение цели вида в направлении перетаскивания мыши

3DОБХОД

Интерактивное изменение вида 3D чертежа, имитируя обход модели наблюдателем

3DПОКАЗАТЬ

Увеличение или уменьшение изображения, если чертеж имеет вид "Перспектива"

АНИМТРАЕКТ

Сохранение анимации вдоль траектории в 3D модели

КАМЕРА

Установка камеры и положения цели для создания и сохранения 3D вида объектов в перспективе

ВИД
ОБХОДОБЛЕТНАСТР

Задание параметров обхода и облета

Системные переменные

CAMERADISPLAY

Включение или выключение отображения объектов камеры

CAMERAHEIGHT

Задание значения высоты по умолчанию для новых объектов камеры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование инструментов 3D перемещения (Понятие)

Обзор 3D видов
Определение 3D видов
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Инструменты 3D навигации позволяют просматривать объекты в чертежах под различными углами, с различных высот и с различных расстояний.

Указанные ниже 3D инструменты используются для движения по кругу, разворота, корректировки расстояний, зумирования и панорамирования на 3D виде.

  • 3D орбита. Перемещение вокруг цели. Цель на изображении остается неподвижной, тогда как камера (точка зрения) перемещается. Точкой цели считается не центр совокупности рассматриваемых объектов, а центр видового экрана.
  • Ограниченная орбита. Ограниченная 3D орбита в плоскости XY или вокруг оси Z. (3DОРБИТА)
  • Свободная орбита. Движение по кругу в любом направлении без привязки к плоскости. Точка зрения не ограничена плоскостью XY или осью Z. (3DСОРБИТА)
  • Непрерывная орбита Непрерывное движение по кругу. Нажмите кнопку мыши и перетащите в направлении требуемого непрерывного движения, затем отпустите кнопку мыши. Движение по кругу продолжается в этом направлении. (3DПОРБИТА)
  • Регулировка расстояния Изменение расстояния до объектов при вертикальном перемещении курсора. Можно увеличивать и уменьшать изображение объектов и настраивать расстояние до них. (3DРАССТ)
  • Шарнир Имитация панорамирования камерой в направлении перетаскивания. Направление обзора изменяется. Можно выполнять шарнирное перемещение камеры в плоскости XY или вдоль оси Z. (3DШАРНИР)
  • Зумирование. Имитация приближения камеры к объекту или отдаления от объекта. При приближении объектов их видимые размеры увеличиваются. (3DПОКАЗАТЬ)
  • Панорамирование. Установка режима интерактивного 3D просмотра с возможностью перетаскивания вида по горизонтали и по вертикали. (3DПАН)

Анимация перемещения

Возможно создание анимации предварительного просмотра Перед созданием анимации перемещения по траектории необходимо создавать образец предварительного просмотра с целью точной настройки своей анимации. Можно создавать, записывать, воспроизводить и сохранять анимации. Дополнительные сведения о предварительном просмотре анимации см. Создание анимаций предварительного просмотра Дополнительные сведения о создании анимаций перемещения по траектории см.Создание анимации перемещением по траектории


Использование инструментов 3D перемещения (Процедура)

Определение 3D видов
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Запуск 3D орбитального вида

Включение режима 3D навигации

Выбор параллельной или перспективной проекции на трехмерном виде

Изменение стиля отображения на трехмерном виде

Для запуска постоянного вращения по орбите

Восстановление начального вида

Использование стандартных видов

Отображение именованного вида


Запуск 3D орбитального вида (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Запуск 3D орбитального вида

  1. Выберите один или несколько объектов, просматриваемых с помощью 3DОРБИТА, либо не выбирайте объекты, если требуется просмотр чертежа в целом.
    ПримечаниеOLE-объекты и растровые объекты не отображаются на орбитальных видах.
  2. Введите 3dпорбита в командной строке.
  3. Для перемещения вокруг объектов используйте один из следующих способов:
    • Для поворота в плоскости XY нажмите кнопку мыши на чертеже и переместите курсор влево или вправо.
    • Для поворота вокруг оси Z нажмите кнопку мыши на чертеже и переместите курсор вверх или вниз.
    • Для обеспечения вращения по кругу в плоскости XY и вокруг оси Z удерживайте нажатой клавишу SHIFT во время перетаскивания курсора. Появляется орбитальное кольцо, позволяющее использовать команды режима свободной трехмерной орбиты (3DСОРБИТА).
  4. Нажмите ENTER.
Панель:3D навигация
Ввод команды: 3DОРБИТА


Включение режима 3D навигации (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Включение режима 3D навигации

  • Введите любую команду 3D навигации и щелкните правой кнопкой мыши в области рисования. Нажмите "Другие режимы перемещения" и выберите другой режим перемещения.
Ввод команды: 3DОРБИТА


Выбор параллельной или перспективной проекции на трехмерном виде (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Выбор параллельной или перспективной проекции на трехмерном виде

  1. Введите любую команду 3D навигации и щелкните правой кнопкой мыши в области рисования. Нажмите "Параллельная" или "Перспективная".

    Рядом с текущим типом проекции устанавливается флажок.

Ввод команды: 3DОРБИТА, PERSPECTIVE


Изменение стиля отображения на трехмерном виде (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Изменение стиля отображения на трехмерном виде

  1. Введите любую команду 3D навигации и щелкните правой кнопкой мыши в области рисования. Нажмите "Стили отображения".
  2. Выберите стиль отображения.

Дополнительные сведения о стилях отображения см. Использование стиля отображения для модели.

Ввод команды: 3DОРБИТА


Для запуска постоянного вращения по орбите (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Для запуска постоянного вращения по орбите

  1. Введите 3dпорбита в командной строке.
  2. Нажмите кнопку мыши на чертеже и переместите курсор для запуска непрерывного движения. При отпускании курсора движение по орбите продолжается в направлении перемещения.
Ввод команды: 3DПОРБИТА


Восстановление начального вида (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Восстановление начального вида

  • Введите любую команду 3D навигации и щелкните правой кнопкой мыши в области рисования. Нажмите "Восстановить вид".

Восстанавливается вид, который отображался перед входом в режим 3D навигации.

Ввод команды: 3DОРБИТА


Использование стандартных видов (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Использование инструментов 3D перемещения
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Использование стандартных видов

  1. Введите любую команду 3D навигации и щелкните правой кнопкой мыши в области рисования. Нажмите "Стандартные виды".
  2. Нажмите вид.
Ввод команды: 3DОРБИТА


Отображение именованного вида (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Отображение именованного вида

  1. Введите любую команду 3D навигации и щелкните правой кнопкой мыши в области рисования. Нажмите "Именованные виды".
  2. Выберите именованный вид или камеру.
Ввод команды: 3DОРБИТА


Использование инструментов 3D перемещения (Краткий справочник)

Обзор 3D видов
Использование инструментов 3D перемещения
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Использование инструментов 3D перемещения >
Использование инструментов 3D перемещения
Понятие Процедура Краткий справочник

Команды

3DПОРБИТА

Установка режима интерактивного 3D просмотра и задание непрерывного движения объектов

3DРАССТ

Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них

3DСОРБИТА

Управление интерактивным просмотром объектов в 3D режиме при использовании независимой орбиты

3DОРБИТА

Управление интерактивным просмотром объектов в 3D пространстве

3DОРБЦЕНТР

Задание центра вращения на 3D орбитальных видах

3DПАН

Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально

3DШАРНИР

Изменение цели вида в направлении перетаскивания мыши

3DПОКАЗАТЬ

Увеличение или уменьшение изображения, если чертеж имеет вид "Перспектива"

Системные переменные

PERSPECTIVE
PERSPECTIVECLIP

Определение местоположения секущей плоскости базовой точки визуализации. Значение в процентах определяет нахождение секущей плоскости базовой точки визуализации. Доступный диапазон значений - 0,01-10,0. Если выбрать меньшее значение, значения объектов по оси z будут стягиваться к целевому виду и за него. При выбранном значении 0,5% плоскость подрезки будет находиться очень близко к базовой точке визуализации. В исключительных случаях можно использовать значение 0,1%, но все же рекомендуется увеличить значение, например, до 5%

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Обход и облет всего чертежа (Понятие)

Использование инструментов 3D перемещения
Определение 3D видов
Создание трехмерного динамического вида
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Возможна имитация обхода и облета всего 3D чертежа.

Обход всей модели выполняется перемещением в плоскости XY. Облет всей модели не ограничивается перемещением в плоскости XY, поэтому создается ощущение "полета" над площадью модели.

"Показать: Обход всего чертежа"

Нажмите стрелку "Просмотр" для запуска анимации.

Использование клавиатуры и манипуляций мышью для обхода и облета

Для обхода и облета всего чертежа можно использовать стандартный набор клавиш и манипуляций мышью. Используются четыре клавиши "стрелка" или клавиши W, A, S и В для перемещения вверх, вниз, влево или вправо. Переключение между режимами обхода и облета осуществляется нажатием клавиши F. Чтобы указать направление вида, пользователь должен перетащить мышь в требуемом направлении просмотра.

ПримечаниеУведомление "Навигационные преобразования обхода и облета" отображает информацию о действиях клавиатуры и мыши, которые управляют режимами обхода и облета. Режим возникновения уведомления определяется опцией отображения, выбранной в диалоговом окне "Параметры обхода и облета".

Отображение вида на модель сверху во время обхода или облета

AutoCAD предоставляет пользователю удобный способ отслеживания текущей позиции на 3D модели в процессе обхода или облета модели. Когда запускается команда 3DОБХОД или 3DОБЛЕТ, в окне "Локатор положения" отображается вид на модель сверху. Указатель положения отображает текущую позицию в привязке к модели, а указатель цели отображает модель, по которой выполняется обход или облет. Перед запуском режима обхода или облета либо во время перемещения по модели можно редактировать установки позиции в окне "Локатор положения".

ПримечаниеЕсли при отображении окна "Локатор положения" замедляется работа, можно закрыть это окно.

Задание параметров обхода и облета

Задайте параметры обхода и облета в панели "3D Навигация" на ленте либо в диалоговом окне "Параметры обхода и облета". Можно установить размер шага по умолчанию, количество шагов в секунду и другие параметры для отображения.

Анимации перемещений при обходе и облете

Можно создать анимацию предварительного просмотра любого перемещения, включая обход и облет чертежа. Перед созданием анимации перемещения по траектории необходимо создать образец предварительного просмотра с целью точной настройки своей анимации. Можно создавать, записывать, воспроизводить и сохранять анимации. Дополнительные сведения о предварительном просмотре анимации см. Создание анимаций предварительного просмотра Дополнительные сведения о создании анимаций перемещения по траектории см. Создание анимации перемещением по траектории.


Обход и облет всего чертежа (Процедура)

Использование инструментов 3D перемещения
На уровень вверх ..
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обход и облет всего чертежа >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Запуск режима обхода

Запуск режима облета

Задание параметров обхода или облета

Изменение позиции просмотра в окне "Локатор положения"

Отключение окна "Локатор положения"


Запуск режима обхода (Процедура)

Обход и облет всего чертежа
На уровень вверх ..
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обход и облет всего чертежа >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Запуск режима обхода

  • Выберите "Вид" [image] "Обход и облет" [image] "Обход".Введите "3dобход" в командной строке.
Панель:3D навигация
Контекстное меню:Подайте любую команду 3D навигации, щелкните правой кнопкой мыши в области рисования и выберите "Другие навигационные режимы" [image] "Обход".
Ввод команды: 3DОБХОД


Запуск режима облета (Процедура)

Обход и облет всего чертежа
На уровень вверх ..
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обход и облет всего чертежа >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Запуск режима облета

  • Введите 3dоблетв командной строке.
Панель:3D навигация
Контекстное меню:Подайте любую команду 3D навигации, щелкните правой кнопкой мыши в области рисования и выберите "Другие режимы навигации" [image] "Облет".
Ввод команды: 3DОБЛЕТ


Задание параметров обхода или облета (Процедура)

Обход и облет всего чертежа
На уровень вверх ..
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обход и облет всего чертежа >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Задание параметров обхода или облета

  1. Введите обходоблетнастр в командной строке.
  2. В диалоговом окне "Параметры обхода и облета" в разделе "Параметры" выполните следующие действия:
    • Нажмите кнопку рядом с позицией всплывающего сообщения "Показывать подсказки команд".
    • Снимите флажок опции "Отображать окно локатора положения", если не требуется отображать это окно. Если при отображении этого окна производительность снижается, окно "Локатор положения" можно закрыть.
  3. В разделе "Параметры текущего чертежа" выполните следующие действия:
    • В поле "Величина шага обхода/облета" введите число для размера шага в единицах чертежа.
    • В поле "Шагов в секунду" введите число от 1 до 30.
  4. Нажмите "ОК".
Панель:3D навигация
Ввод команды: ОБХОДОБЛЕТНАСТР


Изменение позиции просмотра в окне "Локатор положения" (Процедура)

Обход и облет всего чертежа
На уровень вверх ..
Обход и облет всего чертежа
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обход и облет всего чертежа >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Изменение позиции просмотра в окне "Локатор положения"

  1. Выберите меню "Вид" [image] "Обход и облет" [image] "Обход или облет".
  2. В области предварительного просмотра в окне "Локатор положения" нажмите на указатель положения (цветную точку) и перетащите его на новую позицию.
  3. Если отображается указатель цели, нажмите на указатель и перетащите его на позицию новой цели.
  4. В разделе "Общие" внесите требуемые изменения в текущие установки.
  5. Продолжите обход или облет модели.
Ввод команды: 3DОБХОД, 3DОБЛЕТ


Отключение окна "Локатор положения" (Процедура)

Обход и облет всего чертежа
На уровень вверх ..
Создание трехмерного динамического вида
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обход и облет всего чертежа >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Отключение окна "Локатор положения"

  1. Введите обходоблетнастр в командной строке.
  2. В диалоговом окне "Параметры обхода и облета" снимите флажок рядом с "Локатором положения".
  3. Нажмите "ОК".
Панель:3D навигация
Контекстное меню:щелкните правой кнопкой мыши в любом из режимов 3D навигации. Выберите "Параметры обхода и облета".
Ввод команды: ОБХОДОБЛЕТНАСТР


Обход и облет всего чертежа (Краткий справочник)

Использование инструментов 3D перемещения
Обход и облет всего чертежа
Создание трехмерного динамического вида
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Обход и облет всего чертежа >
Обход и облет всего чертежа
Понятие Процедура Краткий справочник

Команды

3DОБЛЕТ

Интерактивное изменение пользовательского вида 3D чертежей, имитируя пролет наблюдателя сквозь модель

3DОБХОД

Интерактивное изменение вида 3D чертежа, имитируя обход модели наблюдателем

ОБХОДОБЛЕТНАСТР

Задание параметров обхода и облета

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание трехмерного динамического вида (Понятие)

Обход и облет всего чертежа
Определение 3D видов
Определение трехмерного вида с помощью камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов >
Создание трехмерного динамического вида
Понятие Процедура Краткий справочник

Вид можно изменять с помощью функции, объединяющей в себе панорамирование и зумирование, без прерывания текущих операций.

Динамический вид позволяет сразу же наблюдать результаты перемещения точки зрения. Для того, чтобы упростить расчет экранного представления объектов при динамической смене вида, повысив тем самым производительность, можно задать лишь отдельные объекты для рассмотрения. Если же нажать ENTER без выбора объектов, в режиме трехмерного динамического вида вместо элементов текущего чертежа отображается стандартная модель домика. Модель домика можно использовать для задания угла и расстояния для рассмотрения модели. По окончании настройки и завершении команды изменения применяются ко всей 3D модели текущего вида.

ПримечаниеВ команде 3DОРБИТА имеются дополнительные эффективные опции для динамического просмотра в 3D. Дополнительные сведения см. в разделе Использование инструментов 3D перемещения.

Задание секущих плоскостей

На видах можно устанавливать переднюю и заднюю секущие плоскости для того, чтобы отображались только объекты, расположенные в пределах определенного расстояния от камеры. Секущие плоскости можно перемещать, сохраняя их нормальное положение относительно линии, соединяющей цель с направленной на нее камерой. Отображение объектов, которые расположены вне пространства между этими плоскостями, подавляется. Следующий чертеж иллюстрирует работу с секущими плоскостями:

ПримечаниеМожно также задать секущие плоскости при создании изображения символа камеры. Дополнительные сведения см. в разделе Изменение свойств камеры.


Создание трехмерного динамического вида (Процедура)

Обход и облет всего чертежа
На уровень вверх ..
Создание трехмерного динамического вида
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Создание трехмерного динамического вида >
Создание трехмерного динамического вида
Понятие Процедура Краткий справочник

Установка секущих плоскостей (ДВИД)

Восстановление вида по умолчанию и ПСК


Создание трехмерного динамического вида (Процедура)

Создание трехмерного динамического вида
На уровень вверх ..
Создание трехмерного динамического вида
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Создание трехмерного динамического вида >
Создание трехмерного динамического вида
Понятие Процедура Краткий справочник
Ввод команды: ДВИД


Установка секущих плоскостей (ДВИД) (Процедура)

Создание трехмерного динамического вида
На уровень вверх ..
Создание трехмерного динамического вида
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Создание трехмерного динамического вида >
Создание трехмерного динамического вида
Понятие Процедура Краткий справочник

Установка секущих плоскостей (ДВИД)

  1. В командной строке введите "двид".
  2. Выбрать объекты для включения в вид.
  3. В командной строке введите "к" (Clip).
  4. Введите п для установки передней секущей плоскости или з для установки задней секущей плоскости, или нажмите ENTER.
  5. Расположить секущую плоскость с помощью бегунка или путем ввода расстояния от цели.
  6. Для выхода из команды нажмите ENTER.
    ПримечаниеМожно также задать секущие плоскости при создании изображения символа камеры. Дополнительные сведения см. в разделе Изменение свойств камеры.
Ввод команды: ДВИД


Восстановление вида по умолчанию и ПСК (Процедура)

Создание трехмерного динамического вида
На уровень вверх ..
Определение трехмерного вида с помощью камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Создание трехмерного динамического вида >
Создание трехмерного динамического вида
Понятие Процедура Краткий справочник

Восстановление вида по умолчанию и ПСК

  1. Выберите пункт меню "Вид" [image] "Трехмерные виды" [image] "Вид в плане" [image] "МСК".
Ввод команды: ПЛАН


Создание трехмерного динамического вида (Краткий справочник)

Обход и облет всего чертежа
Создание трехмерного динамического вида
Обзор камер
Управление видами чертежей > Использование инструментов 3D просмотра > Определение 3D видов > Создание трехмерного динамического вида >
Создание трехмерного динамического вида
Понятие Процедура Краткий справочник

Команды

ДВИД

Установка параллельной проекции или вида в перспективе с помощью камеры и цели

ПЛАН

Отображение вида в плане указанной ПСК

Системные переменные

VIEWDIR

Сохранение направления взгляда в текущем видовом экране, выраженного в координатах ПСК

VIEWTWIST

Хранение значения угла поворота вида для текущего видового экрана, измеренного относительно МСК

WORLDVIEW

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Определение трехмерного вида с помощью камеры

Создание трехмерного динамического вида
Использование инструментов 3D просмотра
Обзор камер
Управление видами чертежей > Использование инструментов 3D просмотра >
Определение трехмерного вида с помощью камеры
Понятие Процедура

Для определения 3D вида поместите камеру в пространство модели и откорректируйте параметры камеры для привязки к своим потребностям.

Темы в этом разделе

  • Обзор камер

    Для определения трехмерного вида можно поместить камеру на чертеж.

  • Создание камеры

    Установка местоположения камеры и цели для создания трехмерных перспективных видов объектов.

  • Изменение свойств камеры

    Можно изменять фокусное расстояние объектива камеры, местоположение передней и задней секущей плоскости, имя камеры, а также включать и отключать отображение камер на чертеже.


Определение трехмерного вида с помощью камеры (Процедура)

Создание трехмерного динамического вида
Определение трехмерного вида с помощью камеры
Создание камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры >
Определение трехмерного вида с помощью камеры
Понятие Процедура

Создание камеры

Создание камеры на панели инструментов

Отображение камеры

Изменение фокусного расстояния объектива камеры

Установка секущих плоскостей камеры

Переименование камеры

Изменение местоположения камеры

Изменение цели камеры

Указание печати изображения символа камеры


Обзор камер (Понятие)

Определение трехмерного вида с помощью камеры
Определение трехмерного вида с помощью камеры
Создание камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры >
Обзор камер
Понятие Краткий справочник

Для определения трехмерного вида можно поместить камеру на чертеж.

На чертеже можно включать и выключать камеру, использовать ручки для изменения местоположения камеры и цели или фокусного расстояния объектива. Камера определяется координатами ее местоположения XYZ, местоположения цели XYZ и полем зрения или фокусным расстоянием объектива, который определяет увеличение или коэффициент масштабирования. Можно также определить секущие плоскости, которые устанавливают переднюю и заднюю границу соответствующего вида.

  • Расположение. Определяет точку, из которой рассматривается трехмерная модель.
  • Цель. Определяет рассматриваемую точку: координаты центра вида.
  • Фокусное расстояние. Определяет свойства объектива камеры. Чем больше фокусное расстояние объектива, тем ближе поле зрения.
  • Передняя и задняя секущие плоскости. Указывает положение секущих плоскостей. Секущие плоскости - это границы, которые определяют (отсекают) вид. На виде камеры все объекты, расположенные между камерой и передней секущей плоскостью, не отображаются. Аналогичным образом не отображаются объекты, расположенные за задней секущей плоскостью.

По умолчанию сохраненные камеры получают имена, например Камера1, Камера2 и т. д. Для лучшего описания вида можно переименовать камеру. Диспетчер видов содержит список камер, имеющихся на чертеже, а также на других именованных видах.

Используйте диалоговое окно "Вид изображения символа камеры" служит для настройки цвета и размера изображения символа камеры.


Обзор камер (Краткий справочник)

Создание трехмерного динамического вида
Обзор камер
Создание камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Обзор камер >
Обзор камер
Понятие Краткий справочник

Команды

КАМЕРА

Установка камеры и положения цели для создания и сохранения 3D вида объектов в перспективе

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

CAMERADISPLAY

Включение или выключение отображения объектов камеры

CAMERAHEIGHT

Задание значения высоты по умолчанию для новых объектов камеры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание камеры (Понятие)

Обзор камер
Определение трехмерного вида с помощью камеры
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры >
Создание камеры
Понятие Процедура Краткий справочник

Установка местоположения камеры и цели для создания трехмерных перспективных видов объектов.

Для создания камеры определите ее местоположение и цель, затем задайте ее имя, высоту, фокусное расстояние объектива и секущие плоскости. Можно также использовать один или несколько предварительно определенных типов камеры, предусмотренных на панели инструментов.


Создание камеры (Процедура)

Определение трехмерного вида с помощью камеры
На уровень вверх ..
Создание камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Создание камеры >
Создание камеры
Понятие Процедура Краткий справочник

Создание камеры

Создание камеры на панели инструментов

Отображение камеры


Создание камеры (Процедура)

Создание камеры
На уровень вверх ..
Создание камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Создание камеры >
Создание камеры
Понятие Процедура Краткий справочник

Создание камеры

  1. Введите камера в командной строке.
  2. Нажмите кнопку мыши на чертеже для указания местоположения камеры.
  3. Нажмите кнопку мыши на чертеже еще раз для указания местоположения цели.
  4. Выполнить одно из следующих действий:
    • Если установка камеры завершена, нажмите ENTER.
    • Для определения дополнительных свойств камеры нажимайте правую кнопку мыши и выбирайте параметры в списке. Затем нажмите ENTER для завершения установки камеры.
    Панель:Вид
    Ввод команды: КАМЕРА


Создание камеры на панели инструментов (Процедура)

Создание камеры
На уровень вверх ..
Создание камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Создание камеры >
Создание камеры
Понятие Процедура Краткий справочник

Создание камеры на панели инструментов

  1. Введите инстрпалоткл в командной строке.
  2. Нажмите вкладку "Инструмент камеры" и активизируйте ее.
  3. Выберите тип камеры. Перетащите значок камеры с панели инструментов и нажмите кнопку мыши на чертеже в том месте, куда требуется ее поместить.
  4. Нажмите кнопку мыши еще раз в том месте, куда требуется поместить цель.
Ввод команды: КАМЕРА


Отображение камеры (Процедура)

Создание камеры
На уровень вверх ..
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Создание камеры >
Создание камеры
Понятие Процедура Краткий справочник

Отображение камеры

  • Выберите "Вид" [image] "Отображение" [image] "Камеры".
    Ввод команды: CAMERADISPLAY


Создание камеры (Краткий справочник)

Обзор камер
Создание камеры
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Создание камеры >
Создание камеры
Понятие Процедура Краткий справочник

Команды

КАМЕРА

Установка камеры и положения цели для создания и сохранения 3D вида объектов в перспективе

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

CAMERADISPLAY

Включение или выключение отображения объектов камеры

CAMERAHEIGHT

Задание значения высоты по умолчанию для новых объектов камеры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение свойств камеры (Понятие)

Создание камеры
Определение трехмерного вида с помощью камеры
Создание анимаций предварительного просмотра
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Можно изменять фокусное расстояние объектива камеры, местоположение передней и задней секущей плоскости, имя камеры, а также включать и отключать отображение камер на чертеже.

При выборе камеры открывается диалоговое окно "Предварительный просмотр камеры" для просмотра вида камеры.

Предусмотрено несколько способов изменения параметров камеры:

  • Нажмите и перетащите ручки для изменения размера, положения, фокусного расстояния объектива или поля зрения.

  • Для ввода значений координат Х, Y, Z служит всплывающая подсказка "Динамический ввод".

  • Для изменения свойств камеры служит панель "Свойства камеры".


Изменение свойств камеры (Процедура)

Создание камеры
На уровень вверх ..
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Изменение фокусного расстояния объектива камеры

Установка секущих плоскостей камеры

Переименование камеры

Изменение местоположения камеры

Изменение цели камеры

Указание печати изображения символа камеры


Изменение фокусного расстояния объектива камеры (Процедура)

Изменение свойств камеры
На уровень вверх ..
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Изменение фокусного расстояния объектива камеры

  1. Если камеры еще не отображаются на чертеже, выберите меню "Вид" [image] "Отображение" [image] "Камеры".
  2. Нажмите кнопку мыши на изображении символа камеры.
  3. Нажмите инструмент ручки "Фокусное расстояние/Поле зрения".
  4. Переместите курсор и нажмите кнопку мыши в требуемом положении объектива.
  5. Нажмите ENTER.
    ПримечаниеДля точной настройки фокусного расстояния дважды нажмите кнопку мыши на изображении символа камеры для открытия панели "Свойства". В разделе "Камеры" введите числовое значение в поле "Фокусное расстояние (мм)".
Ввод команды: CAMERADISPLAY


Установка секущих плоскостей камеры (Процедура)

Изменение свойств камеры
На уровень вверх ..
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Установка секущих плоскостей камеры

  1. Если камеры еще не отображаются на чертеже, выберите меню "Вид" [image] "Отображение" [image] "Камеры".
  2. Дважды нажмите кнопку мыши на камере, для которой требуется установить секущие плоскости.
  3. На панели "Свойства" в разделе "Подрезка" для параметра "Секущие плоскости" выберите "Передняя вкл", "Задняя вкл" или "Передняя и задняя вкл".
  4. В поле "Передняя плоскость" или "Задняя плоскость" введите числовое значение.
  5. Нажмите ENTER.
    Ввод команды: CAMERADISPLAY


Переименование камеры (Процедура)

Изменение свойств камеры
На уровень вверх ..
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Переименование камеры

  1. Если камеры еще не отображаются на чертеже, выберите меню "Вид" [image] "Отображение" [image] "Камеры".
  2. Дважды нажмите кнопку мыши на изображении символа камеры.
  3. Введите новое имя в поле "Имя", расположенное на панели "Свойства" в разделе "Общие".
  4. Нажмите ENTER.
Ввод команды: CAMERADISPLAY


Изменение местоположения камеры (Процедура)

Изменение свойств камеры
На уровень вверх ..
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Изменение местоположения камеры

  1. Если камеры еще не отображаются на чертеже, выберите меню "Вид" [image] "Отображение" [image] "Камеры".
  2. Нажмите кнопку мыши на изображении символа камеры, перетащите его в новое местоположение и нажмите кнопку мыши для размещения камеры.
  3. Нажмите ENTER.
Ввод команды: CAMERADISPLAY


Изменение цели камеры (Процедура)

Изменение свойств камеры
На уровень вверх ..
Изменение свойств камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Изменение цели камеры

  1. Если камеры еще не отображаются на чертеже, выберите меню "Вид" [image] "Отображение" [image] "Камеры".
  2. Нажмите кнопку мыши на изображении символа камеры, цель которой требуется изменить.
  3. Нажмите ручку "Расстояние до цели" (синяя ручка в центре), перетащите ее в новое положение и нажмите кнопку мыши для размещения цели.
  4. Нажмите ENTER.
Ввод команды: CAMERADISPLAY


Указание печати изображения символа камеры (Процедура)

Изменение свойств камеры
На уровень вверх ..
Создание анимаций предварительного просмотра
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Указание печати изображения символа камеры

  1. Если камеры еще не отображаются на чертеже, выберите меню "Вид" [image] "Отображение" [image] "Камеры".
  2. Дважды нажмите кнопку мыши на камере.
  3. На панели "Свойства" в разделе "Камера" выберите для параметра "Печатать" значение "Да" или "Нет".
Ввод команды: CAMERADISPLAY


Изменение свойств камеры (Краткий справочник)

Создание камеры
Изменение свойств камеры
Создание анимаций предварительного просмотра
Управление видами чертежей > Использование инструментов 3D просмотра > Определение трехмерного вида с помощью камеры > Изменение свойств камеры >
Изменение свойств камеры
Понятие Процедура Краткий справочник

Команды

КАМЕРА

Установка камеры и положения цели для создания и сохранения 3D вида объектов в перспективе

Системные переменные

CAMERADISPLAY

Включение или выключение отображения объектов камеры

CAMERAHEIGHT

Задание значения высоты по умолчанию для новых объектов камеры

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание анимаций предварительного просмотра (Понятие)

Изменение свойств камеры
Использование инструментов 3D просмотра
Создание анимации перемещением по траектории
Управление видами чертежей > Использование инструментов 3D просмотра >
Создание анимаций предварительного просмотра
Понятие Процедура Краткий справочник

Перед созданием анимаций перемещения по траектории можно создавать анимации 3D просмотра и корректировать параметры.

Предварительный просмотр анимации создается с использованием элементов управления панели "Анимация", находящейся на ленте и инструментов 3D навигации. После активизации инструментов 3D навигации на панели "Анимация" разрешается доступ к элементам управления записью анимации.

Для создания анимации используются следующие команды

  • 3DПОРБИТА
  • 3DРАССТ
  • 3DОБЛЕТ
  • 3DСОРБИТА
  • 3DОРБИТА
  • 3DПАН
  • 3DШАРНИР
  • 3DОБХОД
  • 3DПОКАЗАТЬ

Дополнительная информация об инструментах 3D навигации доступных при создании анимации приведена в разделе Использование инструментов 3D перемещения.


Создание анимаций предварительного просмотра (Процедура)

Изменение свойств камеры
Создание анимаций предварительного просмотра
Создание анимаций предварительного просмотра
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимаций предварительного просмотра >
Создание анимаций предварительного просмотра
Понятие Процедура Краткий справочник

Создание предварительного просмотра анимации

Запись предварительного просмотра анимации


Создание предварительного просмотра анимации (Процедура)

Создание анимаций предварительного просмотра
Создание анимаций предварительного просмотра
Создание анимаций предварительного просмотра
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимаций предварительного просмотра >
Создание анимаций предварительного просмотра
Понятие Процедура Краткий справочник

Создание предварительного просмотра анимации

  1. Запустите любую команду 3D навигации и выберите панель "Анимация" на ленте.
  2. На панели "Анимация" выберите кнопку "Старт".
  3. Перемещение по модели чертежа В режиме обхода или облета можно использовать окно "Локатор положения" в качестве визуального руководства.
  4. (Дополнительно) Выполните одно из следующих действий:
    • щелкните правой кнопкой мыши на чертеже и выберите "Другие режимы перемещения". Выберите другой режим перемещения.
    • Нажмите кнопку "Приостановить запись анимации" для установки нового режима перемещения или корректировки параметров анимации. В режиме обхода или облета можно также корректировать установки для окна "Локатор положения".
  5. Выберите кнопку "Воспроизведение".
  6. В диалоговом окне "Предварительный просмотр анимации" просмотрите анимацию и выполните следующие операции:
    • Если необходимо просмотреть анимацию в другом стиле отображения, выберите из списка новый стиль.
    • При удовлетворительном качестве воспроизводимой анимации нажмите кнопку "Сохранить".
  7. В диалоговом окне "Сохранить как" выберите местоположение файла, имя файла и тип файла (AVI, MPG, MOV или WMV)
  8. Нажмите кнопку "Сохранить".
Ввод команды: 3DОРБИТА, ЛЕНТА


Запись предварительного просмотра анимации (Процедура)

Создание анимаций предварительного просмотра
Создание анимаций предварительного просмотра
Создание анимации перемещением по траектории
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимаций предварительного просмотра >
Создание анимаций предварительного просмотра
Понятие Процедура Краткий справочник

Запись предварительного просмотра анимации

  1. Запустите любую команду навигации и выберите панель "Анимации" на ленте.
  2. Выберите кнопку "Старт" на ленте.
  3. Перемещайтесь по модели для записи перемещения.
  4. По окончании записи анимации нажмите кнопку "Приостановить запись анимации".
  5. Выберите кнопку "Воспроизведение". В диалоговом окне "Предварительный просмотр анимации" просмотрите запись и проверьте, что анимация подходит для презентации.
    ПримечаниеПри воспроизведении анимации дается общее представление об окончательном результате. При этом может не воспроизводиться стиль отображения или отображаться с качеством окончательного вывода.
  6. При удовлетворительном качестве анимации нажмите кнопку "Сохранить анимацию".
  7. В диалоговом окне "Сохранить как" выберите местоположение и имя файла.
    ПримечаниеДля изменения типа файла нажмите кнопку "Параметры анимации". В диалоговом окне "Параметры анимации" для параметра "Формат" выберите тип файла. Нажмите "OK" для возврата в диалоговое окно "Сохранить как".
  8. Нажмите кнопку "Сохранить".
Ввод команды: 3DОРБИТА, ЛЕНТА


Создание анимаций предварительного просмотра (Краткий справочник)

Изменение свойств камеры
Создание анимаций предварительного просмотра
Управление траекторией перемещения камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимаций предварительного просмотра >
Создание анимаций предварительного просмотра
Понятие Процедура Краткий справочник

Команды

3DСЕКПЛ

Установка режима интерактивного 3D просмотра и открытие окна "Регулировка секущих плоскостей"

3DПОРБИТА

Установка режима интерактивного 3D просмотра и задание непрерывного движения объектов

3-РАССТ

Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них

3DОБЛЕТ

Интерактивное изменение пользовательского вида 3D чертежей, имитируя пролет наблюдателя сквозь модель

3DСОРБИТА

Управление интерактивным просмотром объектов в 3D режиме при использовании независимой орбиты

3DОРБИТА

Управление интерактивным просмотром объектов в 3D пространстве

3DОРБЦЕНТР

Задание центра вращения на 3D орбитальных видах

3DПАН

Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально

3DШАРНИР

Изменение цели вида в направлении перетаскивания мыши

3DОБХОД

Интерактивное изменение вида 3D чертежа, имитируя обход модели наблюдателем

3DПОКАЗАТЬ

Увеличение или уменьшение изображения, если чертеж имеет вид "Перспектива"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание анимации перемещением по траектории

Создание анимаций предварительного просмотра
Использование инструментов 3D просмотра
Управление траекторией перемещения камеры
Управление видами чертежей > Использование инструментов 3D просмотра >
Создание анимации перемещением по траектории
Понятие Процедура

Анимации перемещением по траектории, например трехмерные анимации обхода модели, позволяют демонстрировать модель техническим специалистам и другим зрителям. Можно записывать и воспроизводить перемещение с целью динамического доведения цели своего проекта до других пользователей.

Настраивая анимацию перемещения по траектории, можно:

  • Указать начальную точку или траекторию
  • Указать точку или траекторию назначения (цели)
  • Просматривать соотношение между текущей камерой и траекторией
  • Корректировать параметры анимации
  • Записывать анимацию

Дополнительные сведения приведены в последующих разделах.

Темы в этом разделе

  • Управление траекторией перемещения камеры

    Движением камеры (а следовательно, и анимацией) можно управлять, привязывая камеру и ее цель к точке или траектории.

  • Указание параметров траектории движения

    Формат файла анимации перемещения по траектории определяется указанием параметров в диалоговом окне "Анимация перемещением по траектории".

  • Запись анимации перемещения по траектории

    Перед записью анимации ее можно просмотреть и затем сохранить в требуемом формате.


Создание анимации перемещением по траектории (Процедура)

Создание анимаций предварительного просмотра
Создание анимации перемещением по траектории
Управление траекторией перемещения камеры
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории >
Создание анимации перемещением по траектории
Понятие Процедура

Создание анимации перемещения по траектории

Просмотр анимации обратного перемещения по траектории

Управление скоростью и длительностью анимации.

Установка разрешения анимации

Задание формата видео

Просмотр и сохранение анимации перемещения по траектории


Управление траекторией перемещения камеры (Понятие)

Создание анимации перемещением по траектории
Создание анимации перемещением по траектории
Указание параметров траектории движения
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории >
Управление траекторией перемещения камеры
Понятие Процедура Краткий справочник

Движением камеры (а следовательно, и анимацией) можно управлять, привязывая камеру и ее цель к точке или траектории.

Для создания анимации с использованием траектории движения необходимо привязать камеру и ее цель к точке или траектории. Если камера должна быть неподвижной, необходима ее привязка к точке Если требуется перемещение камеры вдоль траектории, необходима ее привязка к траектории.

Если цель должна быть неподвижной, необходима ее привязка к точке Если требуется перемещение цели, необходима ее привязка к траектории. Одновременная привязка к точке и камеры, и цели не допускается.

Одна и та же траектория используется в том случае, когда анимационный вид должен проходить по траектории камеры. В этом случае для параметра траектории цели установите значение "Нет" в диалоговом окне "Анимация перемещением по траектории". Данная опция используется по умолчанию.

ПримечаниеДля привязки камеры или цели к траектории необходимо создать объект траектории перед созданием анимации перемещения по траектории. Траектория может представлять собой отрезок, дугу, эллиптическую дугу, окружность, полилинию, трехмерную полилинию или сплайн.


Создание анимации перемещения по траектории (Процедура)

Создание анимации перемещением по траектории
На уровень вверх ..
Указание параметров траектории движения
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Управление траекторией перемещения камеры >
Управление траекторией перемещения камеры
Понятие Процедура Краткий справочник

Создание анимации перемещения по траектории

  1. На чертеже создайте объект траектории либо для камеры, либо для цели. Траектория может представлять собой отрезок, дугу, эллиптическую дугу, окружность, полилинию, трехмерную полилинию или сплайн.
    ПримечаниеСозданная траектория не отображается в анимации.
  2. Выберитевкладку "Сервис" [image] панель "Анимация" [image] "Анимация перемещения по траектории". В командной строке введите "анимтраект".
  3. В разделе "Камера" диалогового окна "Анимация перемещения по траектории" выберите либо "Точку", либо "Траекторию".
  4. Выполните одно из следующих действий:
    • Для обозначения новой точки камеры нажмите кнопку "Указать точку" и укажите точку на чертеже. Введите имя для точки. Нажмите "ОК".
    • Для обозначения новой траектории камеры нажмите кнопку "Указать траекторию" и укажите траекторию на чертеже. Введите имя для траектории. Нажмите "ОК".
    • Для обозначения имеющейся точки или траектории камеры выберите точку или траекторию из раскрывающегося списка.
  5. В разделе "Цель" диалогового окна "Анимация перемещения по траектории" выберите "Точку" или "Траектории".
  6. Выполнить одно из следующих действий:
    • Для обозначения новой точки цели нажмите кнопку "Указать точку" и укажите точку на чертеже. Введите имя для точки. Нажмите "ОК".
    • Для обозначения новой траектории цели нажмите кнопку "Указать траекторию" и укажите траекторию на чертеже. Введите имя для траектории. Нажмите "ОК".
    • Для обозначения имеющейся точки или траектории цели выберите точку или траекторию из ниспадающего списка.
  7. В разделе "Параметры анимации" откорректируйте параметры анимации с целью создания анимации в соответствии со своими потребностям.
  8. По окончании корректировки точек, траекторий и параметров нажмите "Просмотр" для просмотра анимации или "OK" для ее сохранения.
Ввод команды: АНИМТРАЕКТ


Управление траекторией перемещения камеры (Краткий справочник)

Создание анимаций предварительного просмотра
Управление траекторией перемещения камеры
Указание параметров траектории движения
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Управление траекторией перемещения камеры >
Управление траекторией перемещения камеры
Понятие Процедура Краткий справочник

Команды

АНИМТРАЕКТ

Сохранение анимации вдоль траектории в 3D модели

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Указание параметров траектории движения (Понятие)

Управление траекторией перемещения камеры
Создание анимации перемещением по траектории
Запись анимации перемещения по траектории
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории >
Указание параметров траектории движения
Понятие Процедура Краткий справочник

Формат файла анимации перемещения по траектории определяется указанием параметров в диалоговом окне "Анимация перемещением по траектории".

Предусмотрено несколько параметров: частота кадров, длительность, разрешение, стиль отображения, формат файла и сжатие.


Указание параметров траектории движения (Процедура)

Управление траекторией перемещения камеры
На уровень вверх ..
Указание параметров траектории движения
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Указание параметров траектории движения >
Указание параметров траектории движения
Понятие Процедура Краткий справочник

Просмотр анимации обратного перемещения по траектории

Управление скоростью и длительностью анимации.

Установка разрешения анимации

Задание формата видео


Просмотр анимации обратного перемещения по траектории (Процедура)

Указание параметров траектории движения
На уровень вверх ..
Указание параметров траектории движения
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Указание параметров траектории движения >
Указание параметров траектории движения
Понятие Процедура Краткий справочник

Просмотр анимации обратного перемещения по траектории

  1. Выберитевкладку "Сервис" [image] панель "Анимация" [image] "Анимация перемещения по траектории". В командной строке введите "анимтраект".
  2. В разделе "Параметры анимации" диалогового окна "Анимация перемещения по траектории" установите флажок "Обратное".
  3. Нажмите "ОК".
Ввод команды: АНИМТРАЕКТ


Управление скоростью и длительностью анимации. (Процедура)

Указание параметров траектории движения
На уровень вверх ..
Указание параметров траектории движения
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Указание параметров траектории движения >
Указание параметров траектории движения
Понятие Процедура Краткий справочник

Управление скоростью и длительностью анимации.

  1. Выберитевкладку "Сервис" [image] панель "Анимация" [image] "Анимация перемещения по траектории". В командной строке введите "анимтраект".
  2. В разделе "Параметры анимации" диалогового окна "Анимация перемещения по траектории" укажите частоту кадров (кадр/с).
  3. Выполните одно из следующих действий:
    • Укажите число кадров.
    • Укажите длительность в секундах.
  4. Нажмите "Просмотр" или "OK".
    Ввод команды: АНИМТРАЕКТ


Установка разрешения анимации (Процедура)

Указание параметров траектории движения
На уровень вверх ..
Указание параметров траектории движения
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Указание параметров траектории движения >
Указание параметров траектории движения
Понятие Процедура Краткий справочник

Установка разрешения анимации

  1. Выберитевкладку "Сервис" [image] панель "Анимация" [image] "Анимация перемещения по траектории". В командной строке введите "анимтраект".
  2. В диалоговом окне "Анимация перемещения по траектории" в разделе "Параметры анимации" укажите разрешение, выбрав его в раскрывающемся списке "Разрешение".
Ввод команды: АНИМТРАЕКТ


Задание формата видео (Процедура)

Указание параметров траектории движения
На уровень вверх ..
Запись анимации перемещения по траектории
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Указание параметров траектории движения >
Указание параметров траектории движения
Понятие Процедура Краткий справочник

Задание формата видео

  1. Выберитевкладку "Сервис" [image] панель "Анимация" [image] "Анимация перемещения по траектории". В командной строке введите "анимтраект".
  2. В разделе "Параметры анимации" диалогового окна "Анимация перемещения по траектории" выберите видеоформат (AVI, MPG, MOV или WMV) из раскрывающегося списка "Формат".
Ввод команды: АНИМТРАЕКТ


Указание параметров траектории движения (Краткий справочник)

Управление траекторией перемещения камеры
Указание параметров траектории движения
Запись анимации перемещения по траектории
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Указание параметров траектории движения >
Указание параметров траектории движения
Понятие Процедура Краткий справочник

Команды

АНИМТРАЕКТ

Сохранение анимации вдоль траектории в 3D модели

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Запись анимации перемещения по траектории (Понятие)

Указание параметров траектории движения
Создание анимации перемещением по траектории
Работа с несколькими видами в пространстве модели
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории >
Запись анимации перемещения по траектории
Понятие Процедура Краткий справочник

Перед записью анимации ее можно просмотреть и затем сохранить в требуемом формате.


Просмотр и сохранение анимации перемещения по траектории (Процедура)

Указание параметров траектории движения
На уровень вверх ..
Видовые экраны пространства модели
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Запись анимации перемещения по траектории >
Запись анимации перемещения по траектории
Понятие Процедура Краткий справочник

Просмотр и сохранение анимации перемещения по траектории

  1. Выберитевкладку "Сервис" [image] панель "Анимация" [image] "Анимация перемещения по траектории". В командной строке введите "анимтраект".
  2. В диалоговом окне "Анимации перемещения по траектории" выполните следующие операции:
    • Укажите точку или траекторию для камеры.
    • Укажите точку или траекторию для цели.
    • Откорректируйте любые требуемые параметры анимации.
  3. Для просмотра анимации нажмите кнопку "Просмотр".
  4. В окне "Предварительный просмотр анимации" просмотрите анимацию. Закончив предварительный просмотр анимации, закройте окно "Предварительный просмотр анимации".
  5. В диалоговом окне "Анимации перемещения по траектории" нажмите "OK".
  6. В диалоговом окне "Сохранить как" укажите имя и адрес для сохранения файла анимации.
  7. Нажмите кнопку "Сохранить".
Ввод команды: АНИМТРАЕКТ


Запись анимации перемещения по траектории (Краткий справочник)

Указание параметров траектории движения
Запись анимации перемещения по траектории
Видовые экраны пространства модели
Управление видами чертежей > Использование инструментов 3D просмотра > Создание анимации перемещением по траектории > Запись анимации перемещения по траектории >
Запись анимации перемещения по траектории
Понятие Процедура Краткий справочник

Команды

АНИМТРАЕКТ

Сохранение анимации вдоль траектории в 3D модели

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с несколькими видами в пространстве модели

Запись анимации перемещения по траектории
Управление видами чертежей
Видовые экраны пространства модели
Управление видами чертежей >
Работа с несколькими видами в пространстве модели

Для того чтобы одновременно просматривать несколько видов одного чертежа, область построения чертежа на вкладке "Модель" можно разбить на отдельные области просмотра, называемые видовыми экранами пространства модели. Конфигурации видовых экранов пространства модели можно сохранять для повторного использования.

Темы в этом разделе

  • Видовые экраны пространства модели

    Графическую область на вкладке "Модель" можно разбить на несколько неперекрывающихся прямоугольных областей, называемых видовыми экранами пространства модели.

  • Выбор текущего видового экрана и работа с ним

    При использовании нескольких видовых экранов один из них является текущим; именно он воспринимает команды управления видом и действия с применением курсора.

  • Сохранение и восстановление конфигураций видовых экранов

    Конфигурации видовых экранов пространства модели можно сохранять, присваивая им имена, и впоследствии восстанавливать их.


Видовые экраны пространства модели (Понятие)

Работа с несколькими видами в пространстве модели
Работа с несколькими видами в пространстве модели
Выбор текущего видового экрана и работа с ним
Управление видами чертежей > Работа с несколькими видами в пространстве модели >
Видовые экраны пространства модели
Понятие Процедура Краткий справочник

Графическую область на вкладке "Модель" можно разбить на несколько неперекрывающихся прямоугольных областей, называемых видовыми экранами пространства модели.

На видовых экранах отображаются различные виды модели. Графическую область на вкладке "Модель" можно разбить на несколько неперекрывающихся прямоугольных областей, называемых видовыми экранами пространства модели. В больших или сложных чертежах использование различных видов позволяет избежать частого выполнения операций зумирования и панорамирования. Кроме того, ошибки, незаметные на одном виде, могут быть обнаружены на другом.

Видовые экраны на вкладке "Модель" полностью занимают графическую область, не перекрывая друг друга. Во время редактирования чертежа на одном видовом экране тут же происходит обновление изображений на других видовых экранах. На следующей иллюстрации показаны три видовых экрана на вкладке "Модель".

На вкладке разметки листа также можно создавать видовые экраны. Эти видовые экраны, называемые видовыми экранами разметки листа, используются для компоновки чертежа, выводимого на печать. Видовые экраны листа можно перемещать, можно также изменять их размеры. Возможности управления видовыми экранами на листе достаточно разнообразны. Подробнее о листах и видовых экранах листа см. Создание многовидовых чертежей (в пространстве листа).

Работа с видовым экраном пространства модели

На видовом экране пространства модели можно:

  • Выполнять панорамирование, зумирование, задавать режимы сетки, шаговой привязки и изображения знака ПСК, а также восстанавливать именованные виды.
  • Сохранять расположение системы координат для каждого видового экрана.
  • Переключаться с одного видового экрана на другой в ходе выполнения команд построения чертежа.
  • Сохранять именованную конфигурацию видовых экранов и повторно использовать ее на вкладке "Модель" или применять на вкладке разметки листа.

Задание различных систем координат для отдельных видовых экранов обычно требуется при работе с трехмерными моделями. См. Назначение пользовательской системы координат видовому экрану.

Разделение и объединение видовых экранов пространства модели

На следующей иллюстрации показано несколько стандартных конфигураций видовых экранов пространства модели.

Видовые экраны пространства модели можно изменять, разбивая их на части и объединяя друг с другом. Объединяемые видовые экраны должны иметь общую границу одной длины.


Видовые экраны пространства модели (Процедура)

Запись анимации перемещения по траектории
Видовые экраны пространства модели
Видовые экраны пространства модели
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Видовые экраны пространства модели >
Видовые экраны пространства модели
Понятие Процедура Краткий справочник

Разделение видового экрана пространства модели

Объединение двух видовых экранов на вкладке "Модель"

Восстановление одного видового экрана на вкладке "Модель"

Перехода со вкладки разметки листа на вкладку "Модель"


Разделение видового экрана пространства модели (Процедура)

Видовые экраны пространства модели
Видовые экраны пространства модели
Видовые экраны пространства модели
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Видовые экраны пространства модели >
Видовые экраны пространства модели
Понятие Процедура Краткий справочник

Разделение видового экрана пространства модели

  1. Если имеется насколько видовых экранов, нажмите кнопку мыши внутри видового экрана, который требуется разделить.
  2. Для указания количества создаваемых видовых экранов пространства модели выполните одно из следующих действий:
    • Выберите меню "Вид" [image] "Видовые экраны" [image] "2 ВЭкрана".В командной строке введите "вэкран".
    • Выберите в меню "Вид" [image] "Видовые экраны" [image] "3 ВЭкрана".В командной строке введите "вэкран".
    • Выберите в меню "Вид" [image] "Видовые экраны" [image] "4 ВЭкрана"В командной строке введите "вэкран".
  3. На запрос в командной строке укажите порядок расположения новых видовых экранов.
Ввод команды: ВЭКРАН


Объединение двух видовых экранов на вкладке "Модель" (Процедура)

Видовые экраны пространства модели
Видовые экраны пространства модели
Видовые экраны пространства модели
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Видовые экраны пространства модели >
Видовые экраны пространства модели
Понятие Процедура Краткий справочник

Объединение двух видовых экранов на вкладке "Модель"

  1. Выберите меню "Вид" [image] "Видовые экраны" [image] "Соединить".В командной строке введите "вэкран".
  2. Нажмите кнопку мыши на видовом экране пространства модели, содержащем сохраняемый вид.
  3. Нажмите кнопку мыши внутри смежного видового экрана, который требуется присоединить к первому.
Ввод команды: ВЭКРАН


Восстановление одного видового экрана на вкладке "Модель" (Процедура)

Видовые экраны пространства модели
Видовые экраны пространства модели
Видовые экраны пространства модели
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Видовые экраны пространства модели >
Видовые экраны пространства модели
Понятие Процедура Краткий справочник

Восстановление одного видового экрана на вкладке "Модель"

  • Выберите меню "Вид" [image] "Видовые экраны" [image] "1 ВЭкран".
Ввод команды: ВЭКРАН


Перехода со вкладки разметки листа на вкладку "Модель" (Процедура)

Видовые экраны пространства модели
Видовые экраны пространства модели
Выбор текущего видового экрана и работа с ним
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Видовые экраны пространства модели >
Видовые экраны пространства модели
Понятие Процедура Краткий справочник

Перехода со вкладки разметки листа на вкладку "Модель"

  • Нажмите вкладку "Модель" внизу области рисования.
Ввод команды: TILEMODE


Видовые экраны пространства модели (Краткий справочник)

Запись анимации перемещения по траектории
Видовые экраны пространства модели
Выбор текущего видового экрана и работа с ним
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Видовые экраны пространства модели >
Видовые экраны пространства модели
Понятие Процедура Краткий справочник

Команды

РМОДЕЛЬ

Переключение с вкладки "Лист" на вкладку "Модель"

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

Системные переменные

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

CTAB

Отображение имени текущей вкладки (модель или лист) в чертеже

TILEMODE

Назначение вкладки "Модель" или последней вкладки "Лист" текущей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор текущего видового экрана и работа с ним (Понятие)

Видовые экраны пространства модели
Работа с несколькими видами в пространстве модели
Сохранение и восстановление конфигураций видовых экранов
Управление видами чертежей > Работа с несколькими видами в пространстве модели >
Выбор текущего видового экрана и работа с ним
Понятие Процедура Краткий справочник

При использовании нескольких видовых экранов один из них является текущим; именно он воспринимает команды управления видом и действия с применением курсора.

На текущем видовом экране курсор меняет свою форму со стрелки на перекрестье, а граница видового экрана выделена. Переключиться с одного видового экрана на другой можно в любой момент, кроме тех случаев, когда выполняется какая-либо команда работы с видами.

Для установки видового экрана текущим, нажмите кнопку мыши на нем или нажмите CTRL + R для переключения между существующими видовыми экранами.

Например, в случае построения отрезка можно указать его начало на первом видовом экране пространства модели, затем переключиться нажатием кнопки мыши на второй видовой экран и указать на нем конечную точку отрезка. Этот метод особенно удобен на больших чертежах, когда требуется построить отрезок, соединяющий удаленные точки.


Выбор текущего видового экрана и работа с ним (Процедура)

Видовые экраны пространства модели
Выбор текущего видового экрана и работа с ним
Выбор текущего видового экрана и работа с ним
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Выбор текущего видового экрана и работа с ним >
Выбор текущего видового экрана и работа с ним
Понятие Процедура Краткий справочник

Установка видового экрана текущим

Циклический перебор видовых экранов без нажатия


Установка видового экрана текущим (Процедура)

Выбор текущего видового экрана и работа с ним
Выбор текущего видового экрана и работа с ним
Выбор текущего видового экрана и работа с ним
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Выбор текущего видового экрана и работа с ним >
Выбор текущего видового экрана и работа с ним
Понятие Процедура Краткий справочник

Установка видового экрана текущим

  • Нажмите кнопку мыши в пределах видового экрана.


Циклический перебор видовых экранов без нажатия (Процедура)

Выбор текущего видового экрана и работа с ним
Выбор текущего видового экрана и работа с ним
Сохранение и восстановление конфигураций видовых экранов
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Выбор текущего видового экрана и работа с ним >
Выбор текущего видового экрана и работа с ним
Понятие Процедура Краткий справочник

Циклический перебор видовых экранов без нажатия

  • Нажимайте CTRL + R.


Выбор текущего видового экрана и работа с ним (Краткий справочник)

Видовые экраны пространства модели
Выбор текущего видового экрана и работа с ним
Сохранение и восстановление конфигураций видовых экранов
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Выбор текущего видового экрана и работа с ним >
Выбор текущего видового экрана и работа с ним
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

CVPORT

Отображение идентификационного номера текущего видового экрана

VIEWCTR

Хранение центра вида на текущем видовом экране

VIEWSIZE

Хранение значения высоты вида на текущем видовом экране, выраженного в единицах чертежа

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение и восстановление конфигураций видовых экранов (Понятие)

Выбор текущего видового экрана и работа с ним
Работа с несколькими видами в пространстве модели
Выбор рабочего процесса перед началом работы
Управление видами чертежей > Работа с несколькими видами в пространстве модели >
Сохранение и восстановление конфигураций видовых экранов
Понятие Процедура Краткий справочник

Конфигурации видовых экранов пространства модели можно сохранять, присваивая им имена, и впоследствии восстанавливать их.

Избегайте необходимости каждый раз заново настраивать видовые экраны и виды на чертеже. С помощью команды ВЭКРАН конфигурации видовых экранов могут быть сохранены и позже восстановлены по имени. К характеристикам сохраняемых конфигураций видовых экранов относятся:

  • число видовых экранов и их расположение
  • виды, установленные внутри видовых экранов
  • сетка и шаг привязки для каждого видового экрана
  • Настройки знака ПСК для каждого видового экрана

Сохраненные конфигурации видовых экранов можно просматривать в списке, восстанавливать и удалять. Конфигурация видовых экранов, сохраненная на вкладке "Модель", может применяться и на вкладке разметки листа.


Сохранение и восстановление конфигураций видовых экранов (Процедура)

Выбор текущего видового экрана и работа с ним
Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Сохранение и восстановление конфигураций видовых экранов >
Сохранение и восстановление конфигураций видовых экранов
Понятие Процедура Краткий справочник

Сохранение именованной конфигурации видовых экранов

Восстановление именованной конфигурации видовых экранов

Удаление именованной конфигурации видовых экранов

Просмотр списка конфигураций видовых экранов


Сохранение именованной конфигурации видовых экранов (Процедура)

Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Сохранение и восстановление конфигураций видовых экранов >
Сохранение и восстановление конфигураций видовых экранов
Понятие Процедура Краткий справочник

Сохранение именованной конфигурации видовых экранов

  1. Выберите меню "Вид" [image] "Видовые экраны" [image] "Новые ВЭкраны".В командной строке введите "вэкран".
  2. В диалоговом окне "Видовые экраны" на вкладке "Новые ВЭкраны" введите имя сохраняемой конфигурации.

    Имя должно иметь в длину не более 255 символов; оно может состоять из букв, цифр и специальных символов (знак доллара ($), минус (-) и знак подчеркивания (_)).

  3. Нажмите "ОК".
ПримечаниеКонфигурацию видовых экранов можно сохранять только на вкладке "Модель".
Ввод команды: ВЭКРАН


Восстановление именованной конфигурации видовых экранов (Процедура)

Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Сохранение и восстановление конфигураций видовых экранов >
Сохранение и восстановление конфигураций видовых экранов
Понятие Процедура Краткий справочник

Восстановление именованной конфигурации видовых экранов

  1. Выберите вкладку "Вид" [image] панель "Видовые экраны" [image] "Именованные". В командной строке введите "вэкран".
  2. В диалоговом окне "Видовые экраны" на вкладке "Именованные ВЭкраны" выберите конфигурацию видовых экранов в списке.
  3. Нажмите "ОК".
Ввод команды: ВЭКРАН


Удаление именованной конфигурации видовых экранов (Процедура)

Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Сохранение и восстановление конфигураций видовых экранов >
Сохранение и восстановление конфигураций видовых экранов
Понятие Процедура Краткий справочник

Удаление именованной конфигурации видовых экранов

  1. Выберите вкладку "Вид" [image] панель "Видовые экраны" [image] "Именованные". В командной строке введите "вэкран".
  2. В диалоговом окне "Видовые экраны" на вкладке "Именованные ВЭкраны" выберите имя конфигурации видовых экранов в списке.
  3. Нажмите клавишу Delete.
Ввод команды: ВЭКРАН


Просмотр списка конфигураций видовых экранов (Процедура)

Сохранение и восстановление конфигураций видовых экранов
Сохранение и восстановление конфигураций видовых экранов
Рисование, масштабирование и аннотирование в пространстве модели
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Сохранение и восстановление конфигураций видовых экранов >
Сохранение и восстановление конфигураций видовых экранов
Понятие Процедура Краткий справочник

Просмотр списка конфигураций видовых экранов

  • Выберите вкладку "Вид" [image] панель "Видовые экраны" [image] "Именованные". В командной строке введите "вэкран".

    Открывается диалоговое окно "Видовые экраны".

На вкладке "Именованные ВЭкраны" диалогового окна "Видовые экраны" отображается список всех именованных конфигураций видовых экранов чертежа.

Ввод команды: ВЭКРАН


Сохранение и восстановление конфигураций видовых экранов (Краткий справочник)

Выбор текущего видового экрана и работа с ним
Сохранение и восстановление конфигураций видовых экранов
Коротко о черчении в пространстве модели
Управление видами чертежей > Работа с несколькими видами в пространстве модели > Сохранение и восстановление конфигураций видовых экранов >
Сохранение и восстановление конфигураций видовых экранов
Понятие Процедура Краткий справочник

Команды

НОВОЕИМЯ

Изменение имен именованных объектов

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор рабочего процесса перед началом работы

Сохранение и восстановление конфигураций видовых экранов
Создание одновидовых чертежей (в пространстве модели)
Выбор рабочего процесса перед началом работы

Темы в этом разделе

  • Создание одновидовых чертежей (в пространстве модели)

    Для создания двумерного чертежа, имеющего один вид, и нанесения всех пояснительных элементов достаточно пространства модели. Это обычный метод создания чертежей в AutoCAD®.

  • Создание многовидовых чертежей (в пространстве листа)

    Пространство листа - это среда листа, в которой можно задавать формат, добавлять основную надпись, отображать различные виды модели, а также наносить размеры и примечания к чертежу.

  • Работа с листами в подшивке

    С помощью Диспетчера подшивок пользователь может организовывать листы чертежей в именованные подшивки. Листы в подшивке можно передавать, публиковать и архивировать как одно целое.


Создание одновидовых чертежей (в пространстве модели)

Выбор рабочего процесса перед началом работы
Выбор рабочего процесса перед началом работы
Коротко о черчении в пространстве модели
Выбор рабочего процесса перед началом работы >
Создание одновидовых чертежей (в пространстве модели)

Для создания двумерного чертежа, имеющего один вид, и нанесения всех пояснительных элементов достаточно пространства модели. Это обычный метод создания чертежей в AutoCAD®.

Темы в этом разделе

  • Коротко о черчении в пространстве модели

    Процесс создания и вывода на печать файла чертежа в пространстве модели отличается от процесса черчения вручную.

  • Рисование, масштабирование и аннотирование в пространстве модели

    При создании чертежа и вывода его на печать из пространства модели необходимо перед выводом на печать задать и применить масштабный коэффициент к аннотационным объектам.


Коротко о черчении в пространстве модели (Понятие)

Создание одновидовых чертежей (в пространстве модели)
Создание одновидовых чертежей (в пространстве модели)
Рисование, масштабирование и аннотирование в пространстве модели
Выбор рабочего процесса перед началом работы > Создание одновидовых чертежей (в пространстве модели) >
Коротко о черчении в пространстве модели
Понятие Краткий справочник

Процесс создания и вывода на печать файла чертежа в пространстве модели отличается от процесса черчения вручную.

В AutoCAD имеются две различные рабочие среды, отображаемые на вкладках модели и разметки листа. Эти вкладки расположены внизу окна.

Двумерный чертеж, имеющий один вид, может быть полностью создан в пространстве модели. Здесь же, без использования пространства листа, к нему можно добавлять аннотации. Это обычный метод создания чертежей AutoCAD. Данный способ очень прост, однако имеет ряд ограничений:

  • Он применяется только для двумерных чертежей
  • Он не позволяет создавать несколько видов или использовать настройки слоев, зависимые от вида
  • Если не используются объекты типа "аннотативный ", для масштабирования аннотации и основной надписи необходимы вычисления.

При использовании данного способа геометрические объекты рисуются в масштабе 1:1, а текст, размеры и аннотации - в том масштабе, который будет соответствовать печатной версии чертежа.

Дополнительные сведения о работе с аннотативными объектами и автоматическом масштабировании аннотаций см. Масштабирование аннотаций.

См. также

    • Создание многовидовых чертежей (в пространстве листа)

    • Работа с листами в подшивке


Коротко о черчении в пространстве модели (Краткий справочник)

Сохранение и восстановление конфигураций видовых экранов
Коротко о черчении в пространстве модели
Рисование, масштабирование и аннотирование в пространстве модели
Выбор рабочего процесса перед началом работы > Создание одновидовых чертежей (в пространстве модели) > Коротко о черчении в пространстве модели >
Коротко о черчении в пространстве модели
Понятие Краткий справочник

Команды

РМОДЕЛЬ

Переключение с вкладки "Лист" на вкладку "Модель"

НОВОЕИМЯ

Изменение имен именованных объектов

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

Системные переменные

CVPORT

Отображение идентификационного номера текущего видового экрана

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

TILEMODE

Назначение вкладки "Модель" или последней вкладки "Лист" текущей

VIEWCTR

Хранение центра вида на текущем видовом экране

VIEWSIZE

Хранение значения высоты вида на текущем видовом экране, выраженного в единицах чертежа

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Рисование, масштабирование и аннотирование в пространстве модели (Понятие)

Коротко о черчении в пространстве модели
Создание одновидовых чертежей (в пространстве модели)
Создание многовидовых чертежей (в пространстве листа)
Выбор рабочего процесса перед началом работы > Создание одновидовых чертежей (в пространстве модели) >
Рисование, масштабирование и аннотирование в пространстве модели
Понятие Процедура Краткий справочник

При создании чертежа и вывода его на печать из пространства модели необходимо перед выводом на печать задать и применить масштабный коэффициент к аннотационным объектам.

Для создания чертежа и вывода его на печать можно пользоваться только пространством модели. Данный способ применим для двумерных чертежей, имеющих один вид. Он включает в себя следующие действия:

  • Установка единиц измерения (единиц чертежа) для чертежа.
  • Установка режима отображения единиц чертежа.
  • Вычисление и задание масштаба размеров, аннотаций и блоков.
  • Построение чертежа в масштабе 1:1 в пространстве модели.
  • Создание аннотаций и вставка блоков в пространстве модели.
  • Вывод чертежа на печать в заранее заданном масштабе.

Если требуется автоматическое масштабирование аннотаций, можно также воспользоваться объектами типа "аннотативный ". Дополнительные сведения о работе с аннотативными объектами и автоматическом масштабировании аннотаций см. Масштабирование аннотаций.

Установка единиц изменения

Перед началом работы в пространстве модели необходимо определить, какие будут использоваться единицы изменения (единицы чертежа). Единицей чертежа может быть дюйм, миллиметр, километр и т.д. Например, при вычерчивании детали двигателя единица чертежа может соответствовать одному миллиметру, а при составлении карты местности — одному километру.

Режим отображения единиц чертежа

После выбора единицы чертежа необходимо задать режим ее отображения, включающий в себя тип единицы и точность. Например, значение 14,5 может отображаться как 14,500, 14-1/2, или 1'2-1/2".

Режим отображения единиц чертежа задается с помощью команды ЕДИНИЦЫ. По умолчанию тип единиц чертежа задается как десятичный.

Задание масштаба для аннотаций и блоков

Прежде чем приступить к работе над чертежом, следует задать масштаб для размеров, аннотаций и блоков. Необходимые размеры этих элементов сохраняются и после масштабирования при выводе окончательного чертежа на печать.

Масштаб задается для следующих объектов:

  • Текст. Высота символов задается при создании текста или заданием фиксированного размера в текстовом стиле (СТИЛЬ).
  • Размеры. Масштаб размеров задается в размерном стиле (команда РЗМСТИЛЬ) или с помощью системной переменной DIMSCALE.
  • Типы линий. Масштаб прерывистых линий задается системными переменными CELTSCALE и LTSCALE.
  • Образцы штриховок. Масштаб образцов штриховок задается в диалоговом окне "Штриховка и градиент" (ШТРИХ) или с помощью системной переменной HPSCALE.
  • Блоки. Масштаб вставки блоков задается непосредственно при их вставке, либо в диалоговом окне "Вставка" (ВСТАВИТЬ), либо в Центр управления (ЦУВКЛ). Для вставки блоков используются системные переменные INSUNITS, INSUNITSDEFSOURCE и INSUNITSDEFTARGET. То же самое относится к границам и основной надписи чертежа.

Если требуется автоматическое масштабирование аннотаций, можно также воспользоваться объектами типа "аннотативный ". Дополнительные сведения о работе с аннотативными объектами и автоматическом масштабировании аннотаций см. Масштабирование аннотаций.

Задание масштаба вывода на печать

Для вывода чертежа в пространстве модели на печать можно точно вычислить масштабный коэффициент, выразив масштаб чертежа в виде отношения 1:n. Это отношение показывает связь между единицей получаемого при печати чертежа и единицей чертежа, отражающей реальные размеры изображаемых объектов.

Например, если чертеж выводится на печать при масштабе 1/4 дюйма = 1 фут, то масштабный коэффициент равен 48. Расчеты выглядят следующим образом:

1/4" = 12"

1 = 12 x 4

1 (единица чертежа на бумаге) = 48 (единиц чертежа)

Аналогичным образом можно убедиться, что для масштаба 1 сантиметр = 1 метр масштабный коэффициент равен 100, а для масштаба 1 дюйм = 20 футов масштабный коэффициент равен 240.

Примеры масштабных коэффициентов

В следующей таблице приводятся примеры масштабных коэффициентов, которые можно использовать для расчета размера текста в архитектурном формате единиц в пространстве модели.

Масштаб | Масштабный коэффициент | Для печати текста с размером | Установите размер текста чертежа равным
1 см = 1 м | 100 | 3 мм | 30 см
1/8" = 1'-0" | 96 | 1/8" | 12"
3/16" = 1'-0" | 64 | 1/8" | 8"
1/4" = 1'-0" | 48 | 1/8" | 6"
3/8" = 1'-0" | 32 | 1/8" | 4"
1/2" = 1'-0" | 24 | 1/8" | 3"
3/4" = 1'-0" | 16 | 1/8" | 2"
1" = 1'-0" | 12 | 1/8" | 1.5"
1 1/2" = 1'-0" | 8 | 1/8" | 1,0"

При использовании метрических единиц для формата листа 210 x 297 мм (A4) масштабный коэффициент будет составлять 20. Расчет лимитов сетки:

210 x 20 = 4200 мм

297 x 20 = 5900 мм

См. также

    • Задание единиц и формата единиц


Определение режима отображения единиц чертежа (Процедура)

Сохранение и восстановление конфигураций видовых экранов
Рисование, масштабирование и аннотирование в пространстве модели
Работа в пространствах модели и листа
Выбор рабочего процесса перед началом работы > Создание одновидовых чертежей (в пространстве модели) > Рисование, масштабирование и аннотирование в пространстве модели >
Рисование, масштабирование и аннотирование в пространстве модели
Понятие Процедура Краткий справочник

Определение режима отображения единиц чертежа

  1. Выберите меню "Формат" [image] "Единицы".В командной строке введите "единицы".
  2. В диалоговом окне "Единицы чертежа" задайте значения единиц для чертежа.
  3. Изменения параметров единиц отображаются в группе "Пример".
    • В группе "Линейные" выберите формат единиц и уровень точности. Это задает режим отображения линейных единиц чертежа.
    • В группе "Единицы для масштабирования блоков при вставке" выберите единицы, которые необходимо использовать для масштабирования блоков, изображений и других элементов, вставляемых в чертеж. Если масштабировать вставляемые элементы не требуется, выберите "Безразмерный".
    • В группе "Угловые" выберите формат угловых единиц и уровень точности. Это задает режим отображения угловых единиц чертежа. По умолчанию нулевым считается направление вправо.
    • Для задания направления угла нажмите кнопку "Направление", а затем в диалоговом окне "Выбор направления" выберите базовый угол. Направление угла управляет точкой и направлением, относительно которых измеряются углы. При выборе "Другой" можно ввести угол или нажать кнопку "Угол", чтобы задать его с помощью устройства указания. По умолчанию углы отсчитываются против часовой стрелки.
  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".
Ввод команды: ЕДИНИЦЫ


Рисование, масштабирование и аннотирование в пространстве модели (Краткий справочник)

Коротко о черчении в пространстве модели
Рисование, масштабирование и аннотирование в пространстве модели
Коротко о работе на листах
Выбор рабочего процесса перед началом работы > Создание одновидовых чертежей (в пространстве модели) > Рисование, масштабирование и аннотирование в пространстве модели >
Рисование, масштабирование и аннотирование в пространстве модели
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

РЗМСТИЛЬ

Создание и модификация размерных стилей

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

ТИПЛИН

Загрузка, установка и изменение типов линий

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

СТИЛЬ

Создание, изменение или определение стилей текста

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

CELTSCALE

Задание текущего коэффициента масштабирования для типа линий объекта

DIMSCALE

Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения

HPSCALE

Масштабный коэффициент образца штриховки, который должен быть больше нуля

HPSPACE

Расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть больше нуля

INSUNITS

Значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок

INSUNITSDEFSOURCE

Задание единиц измерения исходного содержимого, когда переменная INSUNITS имеет значение равное 0

INSUNITSDEFTARGET

Задание единиц измерения в целевом чертеже, когда переменная INSUNITS имеет значение равное 0

LTSCALE

Глобальный масштаб типов линий

LUNITS

Задание линейных единиц

TEXTSIZE

Значение высоты по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание многовидовых чертежей (в пространстве листа)

Рисование, масштабирование и аннотирование в пространстве модели
Выбор рабочего процесса перед началом работы
Коротко о работе на листах
Выбор рабочего процесса перед началом работы >
Создание многовидовых чертежей (в пространстве листа)

Пространство листа - это среда листа, в которой можно задавать формат, добавлять основную надпись, отображать различные виды модели, а также наносить размеры и примечания к чертежу.

Темы в этом разделе

  • Коротко о работе на листах

    Создавать объекты на чертеже можно в двух различных рабочих средах, или "пространствах". Эти пространства представлены на вкладке "Модель" и вкладке компоновки.

  • Процесс работы с листами

    Процесс подготовки чертежа к печати из вкладки "Лист" подразделяется на несколько этапов.

  • Работа в пространствах модели и листа

    Возможность переключаться между пространством модели и пространством листа для выполнении определенных задач дает пользователю целый ряд преимуществ. Для создания и редактирования модели используется пространство модели. Для компоновки листа и установки видов используется пространство листа.

  • Создание и изменение видовых экранов листа

    На листе может создаваться один видовой экран, занимающий весь лист, или несколько видовых экранов. Размеры, свойства, масштаб и расположение видовых экранов могут меняться.

  • Управление видами на видовых экранах листа

    В процессе создания листа можно создавать видовые экраны, которые рассматриваются как "окна" в пространстве модели. Отображаемым видом каждого видового экрана можно управлять.

  • Повторное использование листов и их параметров

    При создании листа можно использовать информацию из существующего шаблона.


Коротко о работе на листах (Понятие)

Создание многовидовых чертежей (в пространстве листа)
Создание многовидовых чертежей (в пространстве листа)
Процесс работы с листами
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) >
Коротко о работе на листах
Понятие Краткий справочник

Создавать объекты на чертеже можно в двух различных рабочих средах, или "пространствах". Эти пространства представлены на вкладке "Модель" и вкладке компоновки.

Обычно модель, состоящая из геометрических объектов, создается в трехмерном пространстве, называемом пространством модели. Готовый лист чертежа с определенными видами и надписями создается в двумерном пространстве, называемом пространством листа. Переключение между данными пространствами осуществляется с помощью вкладок, расположенных в нижней части окна чертежа: вкладка "Модель" и одна или несколько вкладок "Лист".

ПримечаниеЭти вкладки могут быть скрыты и отображаться в виде кнопок в строке состояния в центре внизу окна приложения.

На вкладке "Модель" создание чертежа выполняется в масштабе 1:1. На вкладке "Лист" можно создать один или несколько видовых экранов листа, задавать размеры, создавать замечания и блок заголовка, представляющий лист чертежа.

Каждый видовой экран листа представляет собой своего рода кадр изображения с “фотографией” модели в пространстве модели. Каждый видовой экран содержит вид, отображающий модель с заданным масштабом и ориентацией. Для каждого видового экрана задаются свои видимые слои.

После завершения компоновки листа можно отключить слой, содержащий объекты видового экрана листа. Виды остаются видимыми, и лист можно распечатать, не отображая границ видового экрана.


Коротко о работе на листах (Краткий справочник)

Рисование, масштабирование и аннотирование в пространстве модели
Коротко о работе на листах
Процесс работы с листами
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Коротко о работе на листах >
Коротко о работе на листах
Понятие Краткий справочник

Команды

РЛИСТ

Создание и изменение вкладок "Лист" в чертеже

МАСТЕРЛИСТ

Создание нового листа, задание параметров листа и печати

РМОДЕЛЬ

Переключение с вкладки "Лист" на вкладку "Модель"

МОДЕЛЬ

Переключение из пространства листа в видовой экран пространства модели

СВИД

Создание видовых экранов на листах и управление ими

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ИМПОРТПЛ

Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист

ЛИСТ

Переключение видовых экранов из пространства модели в пространство листа

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

ВСЛОЙ

Управление видимостью слоев для отдельных видовых экранов

Системные переменные

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

PSLTSCALE

Управление масштабированием типов линий в пространстве листа

TILEMODE

Назначение вкладки "Модель" или последней вкладки "Лист" текущей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Процесс работы с листами (Понятие)

Коротко о работе на листах
Создание многовидовых чертежей (в пространстве листа)
Работа в пространствах модели и листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) >
Процесс работы с листами
Понятие Краткий справочник

Процесс подготовки чертежа к печати из вкладки "Лист" подразделяется на несколько этапов.

Чертеж обычно создается в пространстве модели, а к печати подготавливается в пространстве листа.

В нижней части экрана имеется одна вкладка "Модель" и одна или несколько вкладок "Лист".

ПримечаниеЭти вкладки могут быть скрыты и отображаться в виде кнопок в строке состояния в центре внизу окна приложения.

Инициализация листов возможна путем выбора их вкладок, так производится активизация ранее неиспользуемых листов. Перед инициализацией лист не содержит параметров печати. После инициализации листы могут быть извлечены, опубликованы и добавлены в подшивку (после сохранения чертежа).

Краткий обзор процесса

Весь процесс подготовки листа сводится к следующим этапам:

  • Создание модели во вкладке "Модель".
  • Перейдите на вкладку разметки листа.
  • Задание параметров печати: устройство печати, формат, область печати, масштаб, ориентация чертежа.
  • Вставка основной надписи на лист (если при создании чертежа не использовался шаблон, в котором уже имеется основная надпись).
  • Создание нового слоя для видового экрана листа.
  • Создание и размещение на листе видовых экранов.
  • Установка ориентации, масштаба и видимых слоев для каждого видового экрана листа.
  • Нанесение размеров и аннотаций на лист, если это необходимо.
  • Отключение слоя, содержащего видовые экраны листа.
  • Печать листа.

Если требуется аннотировать чертежи в пространстве модели с автоматическим масштабированием аннотаций, можно также воспользоваться объектами типа "аннотативный ". Подробнее о работе с аннотативными объектами и автоматическом масштабировании аннотаций см. Масштабирование аннотаций.


Процесс работы с листами (Краткий справочник)

Коротко о работе на листах
Процесс работы с листами
Работа на вкладке "Модель"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Процесс работы с листами >
Процесс работы с листами
Понятие Краткий справочник

Команды

РЛИСТ

Создание и изменение вкладок "Лист" в чертеже

МАСТЕРЛИСТ

Создание нового листа, задание параметров листа и печати

РМОДЕЛЬ

Переключение с вкладки "Лист" на вкладку "Модель"

МОДЕЛЬ

Переключение из пространства листа в видовой экран пространства модели

СВИД

Создание видовых экранов на листах и управление ими

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ИМПОРТПЛ

Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист

ЛИСТ

Переключение видовых экранов из пространства модели в пространство листа

ВСЛОЙ

Управление видимостью слоев для отдельных видовых экранов

ВЭКРМАКС

Развертывание текущего видового экрана листа для редактирования

ВЭКРМИН

Восстановление текущего видовой экрана листа

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

Системные переменные

LAYOUTREGENCTL

Задание режима обновления списка отображения на вкладке "Модель" и вкладках "Лист"

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

TILEMODE

Назначение вкладки "Модель" или последней вкладки "Лист" текущей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа в пространствах модели и листа

Процесс работы с листами
Создание многовидовых чертежей (в пространстве листа)
Работа на вкладке "Модель"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) >
Работа в пространствах модели и листа
Понятие Процедура

Возможность переключаться между пространством модели и пространством листа для выполнении определенных задач дает пользователю целый ряд преимуществ. Для создания и редактирования модели используется пространство модели. Для компоновки листа и установки видов используется пространство листа.

Темы в этом разделе

  • Работа на вкладке "Модель"

    Вкладка "Модель" обеспечивает доступ к безграничной области, называемой пространством модели. В пространстве модели можно создавать, просматривать и редактировать модель.

  • Работа на вкладке "Лист"

    Набор вкладок "Лист" обеспечивает доступ к пространству, называемому пространством листа. В пространстве листа можно размещать основную надпись, создавать видовые экраны листа для отображения различных видов, задавать размеры чертежа, а также добавлять примечания.

  • Переход в пространство модели из видового экрана листа

    Для редактирования объектов, замораживания и размораживания слоев, а также изменения вида необходимо перейти из видового экрана в пространство модели.

  • Экспорт листа в пространство модели

    Все видимые объекты могут быть экспортированы из текущего листа в пространство модели.


Работа в пространствах модели и листа (Процедура)

Рисование, масштабирование и аннотирование в пространстве модели
Работа в пространствах модели и листа
Работа на вкладке "Модель"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа >
Работа в пространствах модели и листа
Понятие Процедура

Выбор вкладки "Модель"

Указание параметров текущего листа

Создание нового листа

Импорт листа из шаблона

Создание листа с помощью Мастера

Создание копии листа

Переименование листа

Удаление листа

Перемещение вкладок листов

Установка листа текущим

Перемещение объекта из пространства модели в пространство листа (или наоборот)

Переход к предыдущему листу

Выделение всех листов

Печать листа

Переключение между пространством модели и пространством листа

Редактирование объектов в развернутом видовом экране листа

Для экспорта листа в пространство модели чертежа

Для достижения лучшего визуального соответствия в случае содержащих объекты AEC чертежей


Работа на вкладке "Модель" (Понятие)

Работа в пространствах модели и листа
Работа в пространствах модели и листа
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа >
Работа на вкладке "Модель"
Понятие Процедура Краткий справочник

Вкладка "Модель" обеспечивает доступ к безграничной области, называемой пространством модели. В пространстве модели можно создавать, просматривать и редактировать модель.

В пространстве модели можно чертить модель в масштабе 1:1, и задавать значение одной единицы чертежа - один миллиметр, сантиметр, метр и т.д.

На вкладке "Модель" пользователь может просматривать и редактировать объекты модели. При этом манипуляции выполняются с помощью перекрестья курсора, действующего в графической области окна.

В пространстве модели можно также задавать те виды, которые будут отображаться в видовых экранах на листе.


Выбор вкладки "Модель" (Процедура)

Работа в пространствах модели и листа
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Модель" >
Работа на вкладке "Модель"
Понятие Процедура Краткий справочник

Выбор вкладки "Модель"

Выполнить одно из следующих действий:

  • Перейти на вкладку "Модель".
  • Нажать правую кнопку мыши на любой вкладке "Модель" или "Лист". Выбрать "Активизировать модель".
  • Если вкладки "Модель" и "Лист" скрыты, нажмите кнопку "Модель" в строке состояния в нижней части экрана приложения.


Работа на вкладке "Модель" (Краткий справочник)

Процесс работы с листами
Работа на вкладке "Модель"
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Модель" >
Работа на вкладке "Модель"
Понятие Процедура Краткий справочник

Команды

РМОДЕЛЬ

Переключение с вкладки "Лист" на вкладку "Модель"

МОДЕЛЬ

Переключение из пространства листа в видовой экран пространства модели

ЛИСТ

Переключение видовых экранов из пространства модели в пространство листа

Системные переменные

LAYOUTREGENCTL

Задание режима обновления списка отображения на вкладке "Модель" и вкладках "Лист"

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

TILEMODE

Назначение вкладки "Модель" или последней вкладки "Лист" текущей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа на вкладке "Лист" (Понятие)

Работа на вкладке "Модель"
Работа в пространствах модели и листа
Переход в пространство модели из видового экрана листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Набор вкладок "Лист" обеспечивает доступ к пространству, называемому пространством листа. В пространстве листа можно размещать основную надпись, создавать видовые экраны листа для отображения различных видов, задавать размеры чертежа, а также добавлять примечания.

В пространстве листа одна единица соответствует расстоянию на распечатанном листе. Единицы задаются в миллиметрах или дюймах, в зависимости от настроек печати плоттера.

На вкладке "Лист" можно просматривать чертеж и редактировать объекты пространства листа, такие как видовые экраны листа и основные надписи. Можно также перемещать объект (например, выноску или основную надпись) из пространства модели в пространство листа и обратно. При этом манипуляции выполняются с помощью перекрестья курсора, действующего в пространстве листа.

ПримечаниеЭти вкладки могут быть скрыты и отображаться в виде кнопок в строке состояния в центре внизу окна приложения. Для отображения вкладок щелкните правой кнопкой мыши на кнопке "Модель" или "Лист" и выберите "Отображать вкладки листа и модели" в контекстном меню.

Создание дополнительной вкладки "Лист"

По умолчанию новый чертеж содержит две вкладки листов - "Лист1" и "Лист2". При использовании шаблона чертежа или открытии существующего чертежа вкладки листов могут называться иначе.

Для создания новой вкладки "Лист" можно использовать один из следующих способов:

  • Создать новую вкладку "Лист" без параметров, затем установить параметры с помощью Диспетчера параметров листа.
  • Использовать Мастер компоновки листа для создания новой вкладки "Лист" и установки параметров.
  • Копировать вкладку "Лист" и ее параметры из текущего файла чертежа.
  • Импортировать вкладку "Лист" из существующего шаблона чертежа (DWT-файла) или ранее созданного файла чертежа (DWG-файла).
ПримечаниеВ чертеже можно создавать несколько листов, причем листы могут иметь разные параметры и соответствовать разным форматам бумаги. Однако во избежание недоразумений при передаче и распечатке чертежа рекомендуется создавать по одному листу для каждого чертежа.

Задание параметров листа с помощью Мастера компоновки листа

Новый лист можно создать с помощью Мастера компоновки листа. При использовании Мастера процесс создания разметки листа разбивается на несколько этапов, при прохождении которых пользователь задает следующие параметры:

  • Имя нового листа
  • Принтер, назначаемый листу
  • Формат бумаги, используемый для листа
  • ориентация чертежа на листе бумаги
  • основная надпись
  • параметры видового экрана
  • Расположение видового экрана на листе

Информацию, введенную с помощью мастера, можно отредактировать позднее. После выбора компоновки выберите пункт меню "Файл" [image] "Диспетчер наборов параметров листов".


Работа на вкладке "Лист" (Процедура)

Работа на вкладке "Модель"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Указание параметров текущего листа

Создание нового листа

Импорт листа из шаблона

Создание листа с помощью Мастера

Создание копии листа

Переименование листа

Удаление листа

Перемещение вкладок листов

Установка листа текущим

Перемещение объекта из пространства модели в пространство листа (или наоборот)

Переход к предыдущему листу

Выделение всех листов

Печать листа


Указание параметров текущего листа (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Указание параметров текущего листа

  • Щелкните правой кнопкой мыши на вкладке текущего листа. Выберите "Параметры листа".
Панель:Листы
Ввод команды: ПАРАМЛИСТ


Создание нового листа (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Создание нового листа

  1. Выберите меню "Вставка" [image] "Лист" [image] "Новый лист".В командной строке введите "рлист".
  2. В командной строке введите имя нового листа.

    Появляется новая вкладка "Лист". Для перехода на новый лист выберите его вкладку.

Также можно щелкнуть правой кнопкой мыши на вкладке существующего листа и щелкнуть "Новый лист". Для переименования листа дважды щелкните на вкладке "Лист".

Панель:Листы
Ввод команды: РЛИСТ


Импорт листа из шаблона (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Импорт листа из шаблона

  1. Выберите меню "Вставка" [image] "Лист" [image] "Лист по шаблону.В командной строке введите "рлист".
  2. В диалоговом окне "Выбор файла" выбрать файл DWT или DWG, из которого необходимо импортировать лист.
  3. Нажмите "Открыть".
  4. В диалоговом окне "Вставка листов" выбрать импортируемый лист.

    Появляется новая вкладка "Лист". Для перехода на новый лист выберите вкладку листа.

Панель:Листы
Ввод команды: РЛИСТ


Создание листа с помощью Мастера (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Создание листа с помощью Мастера

  1. Выберите меню "Вставка" [image] "Лист" [image] "Мастер компоновки листа".
  2. На каждой странице Мастера создания листа необходимо задать соответствующие настройки для нового листа.

    После завершения работы Мастера вновь созданный лист станет текущим.

Ввод команды: МАСТЕРЛИСТ


Создание копии листа (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Создание копии листа

  1. Нажать правую кнопку мыши на вкладке листа, который необходимо скопировать. Выберите "Переместить/Копировать".
  2. В диалоговом окне "Перемещение/копирование" указать положение новой вкладки листа.
  3. Установить флажок "Создать копию".
  4. Нажмите "ОК".

Также можно нажать CTRL и выполнить перетаскивание для создания копии выбранного листа или группы выбранных листов.

ПримечаниеК вкладке "Модель" операция создания копии не применима.
Ввод команды: РЛИСТ


Переименование листа (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Переименование листа

  1. Нажать правую кнопку мыши на вкладке листа, который необходимо переименовать. Выбрать "Переименовать".
  2. В диалоговом окне "Переименование листа" ввести новое имя листа.
  3. Нажмите "ОК".

Также можно дважды щелкнуть на вкладке "Лист" для листа, который требуется переименовать, и сразу ввести новое имя листа.

ПримечаниеК вкладке "Модель" операция переименования не применима.
Ввод команды: РЛИСТ


Удаление листа (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Удаление листа

  1. Щелкните правой кнопкой мыши на вкладке листа, который необходимо удалить. Нажать кнопку "Удалить".
  2. В окне предупреждения нажать "OK" для удаления листа.

    При удалении листа автоматически удаляются все связанные с ним виды.

ПримечаниеК вкладке "Модель" такая операция неприменима.
Ввод команды: РЛИСТ


Перемещение вкладок листов (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Перемещение вкладок листов

  1. Нажать правую кнопку мыши на вкладке листа, который необходимо переместить. Выберите "Переместить/Копировать".
  2. В диалоговом окне "Перемещение/копирование" выбрать лист, перед которым должен быть установлен перемещаемый лист. Для перемещения листа в конец списка установите флажок "Переместить в конец".
  3. Нажмите "ОК".

Также можно перетащить вкладку "Лист" для листа, положение которого требуется изменить, и поместить лист в нужное положение.

ПримечаниеК вкладке "Модель" операция перемещения не применима.
Ввод команды: РЛИСТ


Установка листа текущим (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Установка листа текущим

Выполните одно из следующих действий:

  • Нажать кнопку мыши на ярлыке вкладки листа, который требуется установить текущим.
  • Нажимайте CTRL+Page Down для циклического перемещения по вкладкам листов слева направо, или CTRL+Page Up для циклического перемещения по вкладкам листов справа налево. Остановиться на вкладке нужного листа.


Перемещение объекта из пространства модели в пространство листа (или наоборот) (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Перемещение объекта из пространства модели в пространство листа (или наоборот)

  1. Выберите меню "Изменить" [image] "Смена пространства".В командной строке введите команду "сменапростр".
  2. Выберите один или несколько объектов для перемещения.
  3. Нажмите ENTER для завершения команды.
Ввод команды: СМЕНАПРОСТР


Переход к предыдущему листу (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Переход к предыдущему листу

  1. Нажать правую кнопку мыши на любой вкладке "Модель" или "Лист".
  2. Выберите "Активизировать последний лист".


Выделение всех листов (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Работа на вкладке "Лист"
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Выделение всех листов

  • Нажать правую кнопку мыши на вкладке любого листа. Выбрать в контекстном меню "Выбрать все листы".
Ввод команды: РЛИСТ


Печать листа (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Переход в пространство модели из видового экрана листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Печать листа

  1. Выполнить одно из следующих действий:
    • Щелкните правой кнопкой мыши на вкладке разметки листа. Нажмите "Печать".
    • Удерживая нажатой клавишу SHIFT, выбрать несколько вкладок листов. Щелкните правой кнопкой мыши на вкладке разметки листа. Выбрать в контекстном меню "Опубликовать выбранные листы".
  2. В диалоговом окне "Печать или публикация" выбрать необходимые параметры. Нажмите "OK" или "Опубликовать".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Работа на вкладке "Лист" (Краткий справочник)

Работа на вкладке "Модель"
Работа на вкладке "Лист"
Переход в пространство модели из видового экрана листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Работа на вкладке "Лист" >
Работа на вкладке "Лист"
Понятие Процедура Краткий справочник

Команды

РЛИСТ

Создание и изменение вкладок "Лист" в чертеже

МАСТЕРЛИСТ

Создание нового листа, задание параметров листа и печати

РМОДЕЛЬ

Переключение с вкладки "Лист" на вкладку "Модель"

МОДЕЛЬ

Переключение из пространства листа в видовой экран пространства модели

СВИД

Создание видовых экранов на листах и управление ими

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ИМПОРТПЛ

Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист

ЛИСТ

Переключение видовых экранов из пространства модели в пространство листа

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

ВСЛОЙ

Управление видимостью слоев для отдельных видовых экранов

Системные переменные

CTAB

Отображение имени текущей вкладки (модель или лист) в чертеже

CVPORT

Отображение идентификационного номера текущего видового экрана

LAYOUTREGENCTL

Задание режима обновления списка отображения на вкладке "Модель" и вкладках "Лист"

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

PLOTROTMODE

Управление ориентацией чертежа при выводе на печать

TILEMODE

Назначение вкладки "Модель" или последней вкладки "Лист" текущей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Переход в пространство модели из видового экрана листа (Понятие)

Работа на вкладке "Лист"
Работа в пространствах модели и листа
Экспорт листа в пространство модели
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа >
Переход в пространство модели из видового экрана листа
Понятие Процедура Краткий справочник

Для редактирования объектов, замораживания и размораживания слоев, а также изменения вида необходимо перейти из видового экрана в пространство модели.

После создания объектов видового экрана можно перейти в пространство модели для выполнения следующих действий:

  • Создание и изменение объектов в пространстве модели внутри видового экрана.
  • Панорамирование вида внутри видового экрана и изменение режима видимости слоя.

Способ переключения из видового экрана в пространство модели зависит от дальнейших планируемых действий.

Создание и изменение объектов внутри видового экрана

Для создания и изменения объектов видовой экран разворачивается на все окно с помощью кнопки на панели состояния. Видовой экран занимает всю область рисования. Настройки видимости слоев и центральных точек видового экрана сохраняются, при этом также отображаются соседние объекты.

При работе в пространстве модели можно панорамировать и зумировать объекты, однако при восстановлении видового экрана и возврате в пространство листа расположение и масштаб объектов на видовом экране листа восстанавливаются.

ПримечаниеЕсли в режиме развернутого видового экрана задается команда "Печать", размеры вкладки "Лист" восстанавливаются до появления диалогового окна "Печать". Если сохранить и закрыть чертеж в режиме развернутого видового экрана, при последующем открытии чертежа вкладка "Лист" восстанавливается.

При переключении в пространство модели для внесения изменений, настройки видимости слоев применяются ко всему чертежу, а не только к отдельному видовому экрану. При этом вид не центрируется и не увеличивается, как это происходит в видовом экране.

Выравнивание вида на видовом экране листа

Для панорамирования вида и изменения видимости слоев дважды нажмите кнопку мыши на видовом экране и перейдите в пространство модели. Границы видового экрана становятся толще, а перекрестье курсора видимым только в текущем видовом экране. Все видовые экраны слоя остаются видимыми. В текущем видовом экране можно замораживать и размораживать слои с помощью Диспетчера свойств слоев, а также можно панорамировать вид. Для возврата в пространство листа дважды нажмите кнопку мыши на пустой области листа вне видового экрана. Все изменения будут отображаться в видовом экране.

Если до переключения в пространство модели в видовом экране листа задан определенный масштаб, его можно заблокировать во избежание изменений. При блокировке масштабе из пространства модели не доступна команда ПОКАЗАТЬ.


Переход в пространство модели из видового экрана листа (Процедура)

Работа на вкладке "Лист"
На уровень вверх ..
Переход в пространство модели из видового экрана листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Переход в пространство модели из видового экрана листа >
Переход в пространство модели из видового экрана листа
Понятие Процедура Краткий справочник

Переключение между пространством модели и пространством листа

Редактирование объектов в развернутом видовом экране листа


Переключение между пространством модели и пространством листа (Процедура)

Переход в пространство модели из видового экрана листа
На уровень вверх ..
Переход в пространство модели из видового экрана листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Переход в пространство модели из видового экрана листа >
Переход в пространство модели из видового экрана листа
Понятие Процедура Краткий справочник

Переключение между пространством модели и пространством листа

На листе можно воспользоваться любым из следующих способов:

  • В пространстве листа дважды нажать кнопку мыши на видовом экране.

    Это вызывает пространство модели. Выбранный видовой экран листа становится текущим, и в нем можно панорамировать вид или изменять свойства слоя. Для внесения серьезных изменений в модель рекомендуется развернуть видовой экрана листа на весь экран с помощью команды ВЭКРМАКС, либо переключиться на вкладку "Модель".

  • В пространстве модели дважды нажать кнопку мыши вне видового экрана.

    Это вызывает пространство листа. На листе можно создавать и изменять объекты.

  • Если необходимо перейти на другой видовой экран листа из пространства модели, дважды нажмите кнопку мыши на другом видовом экране листа или нажмите CTRL + R для циклического прохода по имеющимся видовым экранам листов.


Редактирование объектов в развернутом видовом экране листа (Процедура)

Переход в пространство модели из видового экрана листа
На уровень вверх ..
Экспорт листа в пространство модели
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Переход в пространство модели из видового экрана листа >
Переход в пространство модели из видового экрана листа
Понятие Процедура Краткий справочник

Редактирование объектов в развернутом видовом экране листа

  1. Для активизации видового экрана листа нажать кнопку мыши на его границе.
    ПримечаниеБлокированный видовой экран можно развернуть для редактирования в нем объектов. При восстановлении размеров видового экрана он вновь блокируется.
  2. В строке состояния нажать кнопку "Развернуть видовой экран".

    Стрелки рядом с кнопкой "Развернуть видовой экран" используются для восстановления текущего и развертывания другого видового экрана.

  3. Внести любые изменения.
  4. Для возврата в видовой экран листа нажать кнопку "Восстановить видовой экран".

    При этом восстанавливаются прежние значения центральной точки и коэффициента экранного увеличения.

Ввод команды: ВЭКРМАКС, ВЭКРМИН
Контекстное меню:Щелкните правой кнопкой мыши. Выбрать в контекстном меню "Развернуть ВЭкран".


Переход в пространство модели из видового экрана листа (Краткий справочник)

Работа на вкладке "Лист"
Переход в пространство модели из видового экрана листа
Экспорт листа в пространство модели
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Переход в пространство модели из видового экрана листа >
Переход в пространство модели из видового экрана листа
Понятие Процедура Краткий справочник

Команды

РМОДЕЛЬ

Переключение с вкладки "Лист" на вкладку "Модель"

МОДЕЛЬ

Переключение из пространства листа в видовой экран пространства модели

ЛИСТ

Переключение видовых экранов из пространства модели в пространство листа

ВЭКРМАКС

Развертывание текущего видового экрана листа для редактирования

ВЭКРМИН

Восстановление текущего видовой экрана листа

Системные переменные

VPMAXIMIZEDSTATE

Указание на развернутое состояние видового экрана

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт листа в пространство модели (Понятие)

Переход в пространство модели из видового экрана листа
Работа в пространствах модели и листа
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа >
Экспорт листа в пространство модели
Понятие Процедура Краткий справочник

Все видимые объекты могут быть экспортированы из текущего листа в пространство модели.

Все видимые объекты из текущего листа могут быть экспортированы в пространство модели с использованием команды ЭКСПОРТВЭЛИСТА. Объекты, находящиеся за границами "бумаги" на листе, также могут быть экспортированы.

Некоторые объекты не экспортируются в пространство модели чертежа. Список неэкспортируемых объектов

  • Материалы
  • Камеры
  • Источники света
  • Именованные виды
  • Объекты, находящиеся на отключенных и замороженных слоях
  • Объекты пространства модели, не видимые на данном видовом экране

Изменения в экспортированных объектах

При экспорте для некоторых объектов изменяется тип или производится модификация для получения максимального соответствия представлению на листе.

Тип объекта | Представление в чертеже после экспорта
Размеры | Размеры, выходящие за границы видового экрана, расчленяются.
Стандартный или динамический блок (с атрибутами или без) | Стандартные или динамические блоки, с атрибутами или без них, выходящие за границы видового экрана листа, преобразуются в новые анонимные блоки. Атрибуты преобразуются в текстовые объекты в блоке. ПримечаниеПараметр "Разрешить расчленение" в блоке определения игнорируется, если блок выходит за границы видового экрана листа.
Аннотативные объекты | Объекты становятся неаннотативными
Внешняя ссылка | Ссылка с вложенными объектами, выходящими за границы видового экрана листа, преобразуется во вхождение блока и расчленяется.
Видовой экран листа | Видовые экраны листа представляются либо полилинией, либо подрезанным объектом - видовым экраном.
Пользовательские объекты | Пользовательские объекты расчленяются и преобразуются в анонимные блоки.
Ссылки, подрезанные командой ССПОДРЕЗАТЬ | Ссылки, подрезанные командой ССПОДРЕЗАТЬ, преобразуются в подрезанное вхождение блока.
Визуальные стили | Используется стиль "2D каркас".
Видовые экраны с видом в перспективе | Объекты в пределах видового экрана в перспективе будут в параллельной проекции
ПримечаниеОбъекты, которые могут быть обрезаны без изменения типа, в таблице не приводятся.

Визуальные изменения объектов

После экспорта визуальное представление некоторых объектов может изменяться. Изменения затрагивают следующие моменты (список неполный):

  • Один объект, отображаемый на нескольких видовых экранах, после экспорта представляется несколькими объектами в пространстве модели. Кроме того, объекты преобразовываются и часто масштабируются. Вышесказанное может повлиять на извлечение данных из блоков.
  • Некоторые объекты преобразуются или расчленяются для обрезки.
  • Для видовых экранов на листе могут использоваться различные визуальные стили; в пространстве модели возможно использование только одного стиля.
  • Не всегда корректно осуществляется подрезка толстых полилиний, пересекающих границы видового экрана.

Рекомендации

При экспорте листа в пространство модели необходимо учитывать следующее:

  • Производительность команды ЭКСПОРТВЭЛИСТА может снижаться при активном видовом экране пространства модели.
  • В экспортированном чертеже на видовом экране отображается исходный тип линий, что может привести к изменению визуального представления исходного чертежа. В таком случае необходимо назначить признак "Цепь" типу линий на видовом экране исходного чертежа.
  • Не всегда корректно может поддерживаться масштабирование типа линий для объектов во внешних ссылках и блоках при PSLTSCALE равном 0.
  • В случае возникновения при экспорте проблем с внешними ссылками необходимо удалить необработанные внешние ссылки или вручную внедрить внешние ссылки и только после этого воспользоваться командой ЭКСПОРТВЭЛИСТА.
  • Объекты "Суперштрих" (из Express Tools) экспортируются, но штриховка может выйти за пределы исходных границ. Для устранения любых неполадок, связанных с визуальным представлением, возникших при экспорте, можно использовать команду ОБРЕЗАТЬ.


Экспорт листа в пространство модели (Процедура)

Переход в пространство модели из видового экрана листа
На уровень вверх ..
Экспорт листа в пространство модели
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Экспорт листа в пространство модели >
Экспорт листа в пространство модели
Понятие Процедура Краткий справочник

Для экспорта листа в пространство модели чертежа

Для достижения лучшего визуального соответствия в случае содержащих объекты AEC чертежей


Для экспорта листа в пространство модели чертежа (Процедура)

Экспорт листа в пространство модели
На уровень вверх ..
Экспорт листа в пространство модели
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Экспорт листа в пространство модели >
Экспорт листа в пространство модели
Понятие Процедура Краткий справочник

Для экспорта листа в пространство модели чертежа

  1. Выбрать вкладку "Вывод" [image] "Переслать панель" [image] "Экспорт листа в модель".
    ПримечаниеКоманда ЭКСПОРТВЭЛИСТА может использоваться только со вкладки листа.
  2. В диалоговом окне "Экспорт листа в пространство модели чертежа" введите имя файла.
  3. Задайте папку для сохранения файла. По умолчанию используется папка, в которой расположен текущий чертеж.
  4. Нажмите "Сохранить".
Ввод команды: ЭКСПОРТВЭЛИСТА


Для достижения лучшего визуального соответствия в случае содержащих объекты AEC чертежей (Процедура)

Экспорт листа в пространство модели
На уровень вверх ..
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Экспорт листа в пространство модели >
Экспорт листа в пространство модели
Понятие Процедура Краткий справочник

Для достижения лучшего визуального соответствия в случае содержащих объекты AEC чертежей

  1. В открытом чертеже введите aectoacad. Данная команда создает новый файл DWG, в котором объекты AEC расчленены на базовые объекты AutoCAD.
    ПримечаниеПри выполнении команды AECTOACAD рекомендуется выбрать опцию "Внедрить" с параметром "Вставка".
  2. Перейдите к преобразованному чертежу. Нажмите "Открыть".
  3. Введите в командной строке экспортвэлиста.
Ввод команды: ЭКСПОРТВЭЛИСТА


Экспорт листа в пространство модели (Краткий справочник)

Переход в пространство модели из видового экрана листа
Экспорт листа в пространство модели
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Работа в пространствах модели и листа > Экспорт листа в пространство модели >
Экспорт листа в пространство модели
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТВЭЛИСТА

Экспорт текущего листа в пространство модели нового чертежа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и изменение видовых экранов листа (Понятие)

Экспорт листа в пространство модели
Создание многовидовых чертежей (в пространстве листа)
Управление видами на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

На листе может создаваться один видовой экран, занимающий весь лист, или несколько видовых экранов. Размеры, свойства, масштаб и расположение видовых экранов могут меняться.

ПримечаниеВидовой экран листа должен создаваться на определенном слое. При выводе листа на печать слой можно отключить, и границы видового экрана не будут отображаться при печати.

Команда СВИД позволяет получить несколько вариантов создания одного или нескольких видовых экранов листа. Для создания нескольких видовых экранов листа могут также использоваться команды КОПИРОВАТЬ и МАССИВ.

Создание видовых экранов произвольной формы на листах

С помощью преобразования объекта пространства листа пользователь может получить видовой экран произвольной формы на листе.

Для создания непрямоугольного видового экрана используется командаСВИД.

  • Опция "Объект" позволяет преобразовать в видовой экран замкнутый объект из пространства листа, например, окружность или полилинию. После создания видового экрана с ним связывается объект, определяющий границы видового экрана.
  • Используя опцию "Многоугольный" можно создать непрямоугольный видовой экран листа по заданным точкам. Последовательность действий такая же, как и при создании полилинии.
ПримечаниеДля подавления отображения границ видового экрана листа можно просто отключить слой видового экрана неправильной формы, вместо того, чтобы замораживать его. При замораживании слоя непрямоугольного видового экрана не обеспечивается корректная обрезка последнего.

Переопределение границ видового экрана листа

Границы видового экрана листа можно переопределить с помощью команды ВЭКРЕЗ. Можно либо выбрать существующий объект для использования в качестве новой границы, либо задать точки новой границы. Новая граница используется для переопределения, а не для подрезки старой.

Непрямоугольный видовой экран состоит из двух объектов: собственно видовой экран и обрезающая граница. Можно изменить видовой экран, обрезающую границу или оба параметра вместе.

ПримечаниеВ палитре свойств для непрямоугольного видового экрана стандартно задано "Видовой экран". Это объясняется тем, что чаще изменяются свойства видового экрана, а не обрезающей границы.

Изменение размеров видовых экранов листа

Как и любые другие объекты, границы видовых экранов произвольной формы можно редактировать с помощью ручек.


Создание и изменение видовых экранов листа (Процедура)

Экспорт листа в пространство модели
Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Создание и изменение видовых экранов листа >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

Создание нового видового экрана на листе

Создание конфигурации видового экрана на листе

Вставка на лист именованной конфигурации видовых экранов

Для изменения свойств видового экрана листа используется палитра свойств

Подрезка границ видового экрана листа


Создание нового видового экрана на листе (Процедура)

Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Создание и изменение видовых экранов листа >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

Создание нового видового экрана на листе

  1. На вкладке "Лист" выберите меню "Вид" [image] "Видовые экраны" [image] "1 ВЭкран".
  2. Задать первый угол видового экрана.
  3. Задать противоположный угол видового экрана.

    Новый объект видового экрана листа создан и отображается на виде по умолчанию. Для регулировки вида дважды нажать кнопку мыши на видовом экране листа, чтобы перейти в пространство модели.

Панель:Видовые экраны
Ввод команды: ВЭКРАН, СВИД


Создание конфигурации видового экрана на листе (Процедура)

Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Создание и изменение видовых экранов листа >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

Создание конфигурации видового экрана на листе

  1. Перейдите на вкладку разметки листа.
  2. Выберите меню "Вид" [image] "Видовые экраны" [image] "Новые ВЭкраны".В командной строке введите "вэкран".
  3. В диалоговом окне "Видовые экраны" на вкладке "Новые ВЭ" выбрать конфигурацию видовых экранов из списка.
  4. В опции "Настройка" выбрать 2D или 3D.

    Если выбран 3D-режим, на создаваемых видовых экранах сразу же будут установлены стандартные виды модели.

  5. В опции "Расстояние" задать расстояние между видовыми экранами.
  6. Для изменения вида выбрать видовой экран в режиме предварительного просмотра. В опции "Сменить вид на" выбрать вид из списка.

    Список включает в себя вид сверху, снизу, спереди, сзади, слева, справа, а также изометрические и любые другие виды. Выбранный вид отображается в области предварительного просмотра.

  7. Нажмите "ОК".
  8. В области рисования задать две точки для обозначения области, содержащей конфигурацию видового экрана.
Панель:Видовые экраны
Ввод команды: ВЭКРАН


Вставка на лист именованной конфигурации видовых экранов (Процедура)

Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Создание и изменение видовых экранов листа >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

Вставка на лист именованной конфигурации видовых экранов

  1. Перейдите на вкладку разметки листа.
  2. Выберите вкладку "Вид" [image] панель "Видовые экраны" [image] "Именованные". В командной строке введите "вэкран".
  3. В диалоговом окне "Видовые экраны" на вкладке "Именованные ВЭ" выбрать именованную конфигурацию видового экрана из списка.
  4. Нажмите "ОК".
  5. Указать положение вставляемой конфигурации на листе.
Панель:Видовые экраны
Ввод команды: ВЭКРАН


Для изменения свойств видового экрана листа используется палитра свойств (Процедура)

Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Создание и изменение видовых экранов листа >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

Для изменения свойств видового экрана листа используется палитра свойств

  1. Выбрать границу видового экрана листа, свойства которой необходимо изменить.
  2. Нажать правую кнопку мыши и выбрать в контекстном меню "Свойства".
  3. В палитре свойств выбрать значение, которое необходимо изменить. Ввести новое значение или выбрать новый параметр из списка.

    Новые параметры или значение свойства присваиваются выбранному видовому экрану листа.

Панель:Стандартный
Ввод команды: СВОЙСТВА
Контекстное меню:Выберите видовой экран и щелкните правой кнопкой мыши в области рисования. Нажмите "Свойства".


Подрезка границ видового экрана листа (Процедура)

Создание и изменение видовых экранов листа
Создание и изменение видовых экранов листа
Управление видами на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Создание и изменение видовых экранов листа >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

Подрезка границ видового экрана листа

  1. Выберите вкладку "Вид" [image] панель "Видовой экран" [image] "Подрезка видового экрана". Введите вэкрез в командной строке.
  2. Выберите видовой экран для подрезки.
  3. (Не обязательно) Введите у (удалить) для удаления существующей обрезающей границы.
  4. Выполните одно из следующих действий:
    • Введитеp(Polygonal - многоугольный) для задания последовательности точек, определяющих многоугольную границу.
    • Выберите объект пространства листа, который будет определять новую границу видового экрана.
Ввод команды: Выбрать видовой экран, который необходимо подрезать и нажать правую кнопку мыши в области рисования. Выбрать в контекстном меню "Подрезать видовой экран".


Создание и изменение видовых экранов листа (Краткий справочник)

Экспорт листа в пространство модели
Создание и изменение видовых экранов листа
Масштабирование видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Создание и изменение видовых экранов листа >
Создание и изменение видовых экранов листа
Понятие Процедура Краткий справочник

Команды

СВИД

Создание видовых экранов на листах и управление ими

ОКНОСВ

Управление свойствами объектов

ВЭКРЕЗ

Подрезка объектов на видовых экранах и границ видового экрана

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

Системные переменные

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление видами на видовых экранах листа

Создание и изменение видовых экранов листа
Создание многовидовых чертежей (в пространстве листа)
Масштабирование видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) >
Управление видами на видовых экранах листа
Понятие Процедура

В процессе создания листа можно создавать видовые экраны, которые рассматриваются как "окна" в пространстве модели. Отображаемым видом каждого видового экрана можно управлять.

Темы в этом разделе

  • Масштабирование видов на видовых экранах листа

    Для точного масштабирования каждого отображаемого вида в печатаемом чертеже установить масштаб каждого вида в соответствии с пространством листа.

  • Управление видимостью на видовых экранах листа

    Существует несколько способов управления видимостью объектов на видовом экране. С их помощью можно сократить число обновлений экрана, а также выделить или скрыть различные элементы чертежа.

  • Масштабирование типов линий на видовых экранах листа

    В пространстве листа масштаб типа линий может быть задан на основе единиц измерения чертежа пространства, где был создан объект или на основе единиц пространства листа.

  • Выравнивание видов на видовых экранах листа

    В целях улучшения внешнего вида чертежа можно выровнять (горизонтально, вертикально или под углом) виды на различных видовых экранах друг относительно друга.

  • Поворот видов на видовых экранах листа

    Можно выполнять поворот всего вида на видовом экране листа путем изменения ПСК или с помощью команды ПЛАН.


Управление видами на видовых экранах листа (Процедура)

Создание и изменение видовых экранов листа
Управление видами на видовых экранах листа
Масштабирование видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа >
Управление видами на видовых экранах листа
Понятие Процедура

Изменение масштаба видового экрана с помощью палитры "Свойства"

Включение блокирования масштаба на видовом экране

Установка единого масштаба линий в пространстве листа

Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии

Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ

Поворот вида путем изменения ПСК

Поворот вида листа с помощью команды ФОРМАТЛ


Масштабирование видов на видовых экранах листа (Понятие)

Управление видами на видовых экранах листа
Управление видами на видовых экранах листа
Управление видимостью на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа >
Масштабирование видов на видовых экранах листа
Понятие Процедура Краткий справочник

Для точного масштабирования каждого отображаемого вида в печатаемом чертеже установить масштаб каждого вида в соответствии с пространством листа.

Масштаб вида используемого видового экрана может быть изменен

  • Палитра свойств
  • Опция XP командыПОКАЗАТЬ
  • Панель видового экрана
ПримечаниеМожно изменить список масштабов, отображающихся во всех списках видов и масштабов печати, с помощью команды СПИСМАСШТРЕД.

При работе на листе масштабный коэффициент вида на видовом экране листа представляет соотношение действительного размера модели, отображаемой на видовом экране, и размера листа. Для определения величины коэффициента разделите единицу длины пространства листа на единицу длины пространства модели. Например, чтобы вывести чертеж в масштабе 1:4, в качестве коэффициента указывается отношение одной единицы пространства листа к четырем единицам пространства модели.

Масштаб вида внутри видового экрана не зависит от масштабирования или растягивания границы видового экрана листа.

Блокирование масштаба на видовых экранах листа

После установки масштаба видового экрана выполнять увеличение на видовом экране невозможно, не изменив масштаб видового экрана. Для того, чтобы зумирование внутри видового экрана не влияло на ранее заданный масштаб, можно заблокировать масштаб выбранного видового экрана.

Блокирование масштаба оставляет неизменным заданный масштаб видового экрана. После того как масштаб блокирован, можно изменять геометрию видового экрана, не влияя на его размеры. При включении функции блокировки масштаба большинство команд (например, ТЗРЕНИЯ, ДВИД, 3DОРБИТА, ПЛАН и ВИД) перестает действовать.

ПримечаниеБлокирование масштаба можно выполнять и на видовых экранах произвольной формы. Для этого необходимо произвести дополнительные действия на палитре "Свойства", связанные с выбором видового экрана до блокирования масштаба в нем.


Масштабирование видов на видовых экранах листа (Процедура)

Управление видами на видовых экранах листа
На уровень вверх ..
Масштабирование видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Масштабирование видов на видовых экранах листа >
Масштабирование видов на видовых экранах листа
Понятие Процедура Краткий справочник

Изменение масштаба видового экрана с помощью палитры "Свойства"

Включение блокирования масштаба на видовом экране


Изменение масштаба видового экрана с помощью палитры "Свойства" (Процедура)

Масштабирование видов на видовых экранах листа
На уровень вверх ..
Масштабирование видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Масштабирование видов на видовых экранах листа >
Масштабирование видов на видовых экранах листа
Понятие Процедура Краткий справочник

Изменение масштаба видового экрана с помощью палитры "Свойства"

  1. Перейти на вкладку "Лист" в пространстве листа.
  2. Выбрать границу видового экрана, масштаб которого необходимо изменить.
  3. Нажать правую кнопку мыши и выбрать в контекстном меню "Свойства".
  4. На вкладке "Свойства" выбрать "Стандартный масштаб", далее выбрать новый масштаб из списка.

    Выбранный масштаб будет применен к видовому экрану.

    ПримечаниеДля использования пользовательского масштаба введите масштаб в поле "Пользовательский масштаб" на панели "Свойства".
Панель:Стандартный
Ввод команды: СВОЙСТВА
Контекстное меню:Выберите видовой экран и щелкните правой кнопкой мыши в области рисования. Нажмите "Свойства".


Включение блокирования масштаба на видовом экране (Процедура)

Масштабирование видов на видовых экранах листа
На уровень вверх ..
Управление видимостью на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Масштабирование видов на видовых экранах листа >
Масштабирование видов на видовых экранах листа
Понятие Процедура Краткий справочник

Включение блокирования масштаба на видовом экране

  1. Выбрать на листе видовой экран, масштаб которого необходимо блокировать.
  2. Если необходимо, откройте палитру свойств.
  3. На палитре "Свойства" выполнить одно из следующих действий:
    • Для прямоугольного видового экрана выбрать свойство "Показ блокированного" и присвоить ему значение "Да".
    • На палитре "Свойства", "Показ блокированного" нажать "Да". Затем выбрать "Показ блокированного" и нажать "Да".

    Масштаб текущего видового экрана блокирован. Теперь любые операции зумирования и панорамирования будут действовать только на объекты пространства листа.

Панель:Стандартный
Ввод команды: СВОЙСТВА
Контекстное меню:Выберите видовой экран и щелкните правой кнопкой мыши в области рисования. Нажмите "Свойства".


Масштабирование видов на видовых экранах листа (Краткий справочник)

Создание и изменение видовых экранов листа
Масштабирование видов на видовых экранах листа
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Масштабирование видов на видовых экранах листа >
Масштабирование видов на видовых экранах листа
Понятие Процедура Краткий справочник

Команды

СПИСМАСШТРЕД

Управление списком доступных значений масштаба для видовых экранов, листа и печати

СВИД

Создание видовых экранов на листах и управление ими

ОКНОСВ

Управление свойствами объектов

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

ПОКАЗАТЬ

Увеличение или уменьшение видимого размера объектов на текущем видовом экране

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление видимостью на видовых экранах листа

Масштабирование видов на видовых экранах листа
Управление видами на видовых экранах листа
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа >
Управление видимостью на видовых экранах листа
Понятие Процедура

Существует несколько способов управления видимостью объектов на видовом экране. С их помощью можно сократить число обновлений экрана, а также выделить или скрыть различные элементы чертежа.

Темы в этом разделе

  • Замораживание слоев на видовых экранах листа

    Преимуществом использования видовых экранов листа является возможность выборочного замораживания различных слоев на любом из видовых экранов. Настройки видимости для новых видовых экранов и для новых слоев могут задаваться по умолчанию. Как следствие этого, в каждом из видовых экранов листа можно просматривать различные объекты.

  • Изменение интенсивности света объектов на видовых экранах листа

    Интенсивность регулирует количество красящего вещества, которое затрачивается на печать объекта. Это позволяет представлять объекты на экране и на бумаге в разных оттенках серого цвета, не изменяя при этом их цветовых свойств.

  • Включение и отключение видовых экранов листа

    Отключение некоторых видовых экранов листа или ограничение числа активных видовых экранов позволяет сэкономить время.


Управление видимостью на видовых экранах листа (Процедура)

Масштабирование видов на видовых экранах листа
На уровень вверх ..
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа >
Управление видимостью на видовых экранах листа
Понятие Процедура

Замораживание или размораживание слоев на текущем видовом экране листа

Просмотр списка слоев, замороженных на текущем экране

Замораживание или размораживание слоев на всех видовых экранах

Замораживание или размораживание слоев в пространстве листа

Замораживание или размораживание слоев на новых видовых экранах

Создание новых слоев, замороженных на всех видовых экранах

Задание интенсивности вывода объектам на видовом экране листа

Включение и отключение видовых экранов с помощью палитры "Свойства"


Замораживание слоев на видовых экранах листа (Понятие)

Управление видимостью на видовых экранах листа
Управление видимостью на видовых экранах листа
Изменение интенсивности света объектов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Преимуществом использования видовых экранов листа является возможность выборочного замораживания различных слоев на любом из видовых экранов. Настройки видимости для новых видовых экранов и для новых слоев могут задаваться по умолчанию. Как следствие этого, в каждом из видовых экранов листа можно просматривать различные объекты.

Можно заморозить или разморозить слои на текущем или последующем видовом экране, не меняя видимости слоев на других видовых экранах. Замороженные слои невидимы, объекты на замороженных слоях не выводятся на экран, не печатаются и не регенерируются. На чертеже показан результат замораживания слоя с изображением ландшафта на одном из видовых экранов.

При размораживании восстанавливается видимость слоя. Наиболее простой способ замораживания и размораживания слоев на текущем видовом экране обеспечивает Диспетчер свойств слоев.

В правой части окна "Диспетчер свойств слоев" установите или снимите флажок "Замороженный на ВЭ" для замораживания одного или нескольких слоев на текущем видовом экране листа. Для отображения столбца "Замороженный на ВЭ" необходимо находиться на вкладке "Лист". Сделать активным видовой экран листа, дважды нажав на нем кнопку мыши.

Автоматическое замораживание и размораживание слоев на новых видовых экранах

При создании новых видовых экранов листа можно автоматически замораживать на них определенные слои. Например, можно скрыть размеры путем замораживания слоя РАЗМЕРЫ для всех новых видовых экранов. Если же на одном из видовых экранов размеры должны присутствовать, то для этого видового экрана можно переопределить установленные ранее настройки. Включение или отключение замораживания слоев для новых видовых экранов не изменяет видимость слоев на уже имеющихся видовых экранах.

Создание новых слоев, замороженных на всех видовых экранах

Можно создавать слои, которые будут заморожены на всех имеющихся и вновь создаваемых видовых экранах листа. В дальнейшем эти слои можно разморозить на определенных видовых экранах. Таким способом можно быстро создать новый слой, который должен быть видимым только на одном видовом экране.


Замораживание слоев на видовых экранах листа (Процедура)

Управление видимостью на видовых экранах листа
На уровень вверх ..
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Замораживание или размораживание слоев на текущем видовом экране листа

Просмотр списка слоев, замороженных на текущем экране

Замораживание или размораживание слоев на всех видовых экранах

Замораживание или размораживание слоев в пространстве листа

Замораживание или размораживание слоев на новых видовых экранах

Создание новых слоев, замороженных на всех видовых экранах


Замораживание или размораживание слоев на текущем видовом экране листа (Процедура)

Замораживание слоев на видовых экранах листа
На уровень вверх ..
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Замораживание или размораживание слоев на текущем видовом экране листа

  1. Дважды нажать кнопку мыши на видовом экране листа для установки его в качестве текущего.
  2. Выберите меню "Формат" [image] "Слой".В командной строке введите "слой".
  3. В окне "Диспетчер свойств слоев" выделить слои, которые необходимо заморозить или разморозить.

    Для выбора нескольких слоев удерживайте нажатой клавишу CTRL. Для выбора нескольких слоев, идущих в списке один за другим, удерживайте нажатой клавишу SHIFT.

  4. Щелкните на значке в столбце "Замороженный на ВЭ" для одного из выбранных слоев.
  5. Нажмите ОК.
Панель:Слои
Ввод команды: СЛОЙ


Просмотр списка слоев, замороженных на текущем экране (Процедура)

Замораживание слоев на видовых экранах листа
На уровень вверх ..
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Просмотр списка слоев, замороженных на текущем экране

  1. Перейдите на вкладку разметки листа.
  2. Дважды нажать кнопку мыши на видовом экране листа для установки его в качестве текущего.
  3. Выберите меню "Формат" [image] "Слой".В командной строке введите "слой".
  4. В столбце "Замороженный на ВЭ" Диспетчера свойств слоев посмотрите на значок, обозначающий замороженное/размороженное состояние слоя на текущем видовом экране.

  5. Нажмите ОК.
Панель:Слои
Ввод команды: СЛОЙ, ВСЛОЙ


Замораживание или размораживание слоев на всех видовых экранах (Процедура)

Замораживание слоев на видовых экранах листа
На уровень вверх ..
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Замораживание или размораживание слоев на всех видовых экранах

  1. Перейдите на вкладку разметки листа.
  2. Выберите меню "Формат" [image] "Слой".В командной строке введите "слой".
  3. В окне "Диспетчер свойств слоев" выделить один или несколько слоев, которые необходимо заморозить или разморозить.

    Для выбора нескольких слоев удерживайте нажатой клавишу CTRL. Для выбора нескольких слоев, идущих в списке один за другим, удерживайте нажатой клавишу SHIFT.

  4. В столбце "Заморозить" нажмите кнопку мыши на значке для замораживания/размораживания.
Панель:Слои
Ввод команды: СЛОЙ


Замораживание или размораживание слоев в пространстве листа (Процедура)

Замораживание слоев на видовых экранах листа
На уровень вверх ..
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Замораживание или размораживание слоев в пространстве листа

  1. Перейдите на вкладку разметки листа.
  2. Убедитесь, что находитесь в пространстве листа. (В строке состояния включено ЛИСТ)
  3. Выберите в меню "Формат" [image] "Слой".В командной строке введите "слой".
  4. В окне "Диспетчер свойств слоев" выделить слои, которые необходимо заморозить или разморозить.
  5. В столбце "Заморозить" нажмите значок для замораживания или размораживания слоя. Значок с изображением солнца означает, что слой разморожен; значок со снежинкой - слой заморожен.

  6. Нажмите "ОК".
Панель:Слои
Ввод команды: СЛОЙ


Замораживание или размораживание слоев на новых видовых экранах (Процедура)

Замораживание слоев на видовых экранах листа
На уровень вверх ..
Замораживание слоев на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Замораживание или размораживание слоев на новых видовых экранах

  1. Перейдите на вкладку разметки листа.
  2. Выберите меню "Формат" [image] "Слой".В командной строке введите "слой".
  3. В окне "Диспетчер свойств слоев" выделить слои, которые необходимо заморозить или разморозить на новых видовых экранах.

    Для выбора нескольких слоев удерживайте нажатой клавишу CTRL. Для выбора нескольких слоев, идущих в списке один за другим, удерживайте нажатой клавишу SHIFT.

  4. В столбце "Замороженный на новых ВЭ" нажмите значок для изменения состояния слоя. Значок с изображением солнца означает, что слой разморожен; значок со снежинкой - слой заморожен.
  5. Нажмите "ОК".
Панель:Слои
Ввод команды: СЛОЙ


Создание новых слоев, замороженных на всех видовых экранах (Процедура)

Замораживание слоев на видовых экранах листа
На уровень вверх ..
Изменение интенсивности света объектов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Создание новых слоев, замороженных на всех видовых экранах

  1. Перейдите на вкладку разметки листа.
  2. Выберите меню "Формат" [image] "Слой".В командной строке введите "слой".
  3. Нажать кнопку "Новый" и создать слой.
  4. Ввести новое имя слоя.
  5. В столбце "Заморозить" нажмите значок для изменения состояния слоя на замороженное. Значок с изображением солнца означает, что слой разморожен; значок со снежинкой - слой заморожен.
  6. Нажмите "ОК".
Панель:Слои
Ввод команды: СЛОЙ, ВСЛОЙ


Замораживание слоев на видовых экранах листа (Краткий справочник)

Масштабирование видов на видовых экранах листа
Замораживание слоев на видовых экранах листа
Изменение интенсивности света объектов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Замораживание слоев на видовых экранах листа >
Замораживание слоев на видовых экранах листа
Понятие Процедура Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

ВСЛОЙ

Управление видимостью слоев для отдельных видовых экранов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение интенсивности света объектов на видовых экранах листа (Понятие)

Замораживание слоев на видовых экранах листа
Управление видимостью на видовых экранах листа
Включение и отключение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа >
Изменение интенсивности света объектов на видовых экранах листа
Понятие Процедура Краткий справочник

Интенсивность регулирует количество красящего вещества, которое затрачивается на печать объекта. Это позволяет представлять объекты на экране и на бумаге в разных оттенках серого цвета, не изменяя при этом их цветовых свойств.

Для присвоения объекту значения интенсивности необходимо назначить ему тип печати, а затем значение интенсивности вывода для данного стиля.

Значение интенсивности задается в пределах от 0 до 100. По умолчанию задается значение 100, которое соответствует полной интенсивности. Значение интенсивности 0 соответствует выводу белым цветом.

См. также

    • Задание параметров печати объектов


Задание интенсивности вывода объектам на видовом экране листа (Процедура)

Замораживание слоев на видовых экранах листа
На уровень вверх ..
Включение и отключение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Изменение интенсивности света объектов на видовых экранах листа >
Изменение интенсивности света объектов на видовых экранах листа
Понятие Процедура Краткий справочник

Задание интенсивности вывода объектам на видовом экране листа

  1. Выберите меню "Файл" [image] "Диспетчер стилей печати".В командной строке введите "диспстиль".
  2. Щелкните правой кнопкой мыши на файле CTB или STB. Нажмите "Открыть".
  3. На вкладке "Карточка" Редактора таблиц стилей печати выбрать стиль для редактирования.
  4. В поле параметра "Интенсивность" указать значение от 1 до 100.
  5. Нажать кнопку "Принять".
  6. На листе выберите меню "Файл" [image] "Параметры листа".
  7. В диалоговом окне "Диспетчер параметров листов" нажать кнопку "Изменить". В открывшемся диалоговом окне "Параметры листа" выбрать из списка "Таблица стилей печати" отредактированный стиль печати.
  8. Дважды нажать кнопку мыши на видовом экране листа, содержащем объекты, интенсивность которых необходимо изменить.
  9. Выбрать объекты, стиль печати которых необходимо изменить.
  10. Нажать правую кнопку мыши в области рисования и выбрать из контекстного меню "Свойства".
  11. На палитре "Свойства" воспользоваться одним их следующих приемов:
    • При использовании именованных таблиц стилей печати установить для свойства "Стиль печати" отредактированный стиль печати. Если этот стиль печати отсутствует в списке, выбрать пункт "Другой" и установить текущей таблицу, в которой содержится ранее отредактированный стиль печати. В диалоговом окне "Выбор стиля печати" из списка "Стили печати" выбрать требуемый стиль печати.
    • При использовании цветозависимых таблиц стилей печати для свойства "Цвет" установить цвет, для которого и был отредактирован стиль печати.


Изменение интенсивности света объектов на видовых экранах листа (Краткий справочник)

Замораживание слоев на видовых экранах листа
Изменение интенсивности света объектов на видовых экранах листа
Включение и отключение видовых экранов листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Изменение интенсивности света объектов на видовых экранах листа >
Изменение интенсивности света объектов на видовых экранах листа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Включение и отключение видовых экранов листа (Понятие)

Изменение интенсивности света объектов на видовых экранах листа
Управление видимостью на видовых экранах листа
Масштабирование типов линий на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа >
Включение и отключение видовых экранов листа
Понятие Процедура Краткий справочник

Отключение некоторых видовых экранов листа или ограничение числа активных видовых экранов позволяет сэкономить время.

Большое число активных видовых экранов может замедлять работу системы, так как значительное время тратится на регенерацию изображений. Отключение некоторых видовых экранов листа или ограничение числа активных видовых экранов позволяет сэкономить время. На следующей иллюстрации показан результат отключения двух видовых экранов.

Вновь создаваемые видовые экраны по умолчанию включены. Отключив видимость не используемых в данный момент видовых экранов, можно перемещать видовые экраны и изменять их размеры, не тратя время на ожидание завершения регенерации.

Кроме того, видовой экран можно отключить, если он не должен вычерчиваться на плоттере.


Включение и отключение видовых экранов с помощью палитры "Свойства" (Процедура)

Изменение интенсивности света объектов на видовых экранах листа
На уровень вверх ..
Масштабирование типов линий на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Включение и отключение видовых экранов листа >
Включение и отключение видовых экранов листа
Понятие Процедура Краткий справочник

Включение и отключение видовых экранов с помощью палитры "Свойства"

  1. Перейти на вкладку "Лист" в пространстве листа.
  2. Выбрать границу видового экрана, который необходимо включить или выключить.
  3. Нажать правую кнопку мыши и выбрать в контекстном меню "Свойства".
  4. На палитре "Свойства" в группе "Разное" выбрать свойство "Вкл" и присвоить ему значение "Да" или "Нет".

    Для изменения свойств непрямоугольного видового экрана на палитре "Свойства" следует сначала из списка, где отображается значение "Все (2)", выбрать элемент "ВЭкран (1)".

Панель:Стандартный
Ввод команды: СВОЙСТВА
Контекстное меню:Выберите видовой экран и щелкните правой кнопкой мыши в области рисования. Выбрать в контекстном меню "Видимость объектов на ВЭкранах".


Включение и отключение видовых экранов листа (Краткий справочник)

Изменение интенсивности света объектов на видовых экранах листа
Включение и отключение видовых экранов листа
Масштабирование типов линий на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Управление видимостью на видовых экранах листа > Включение и отключение видовых экранов листа >
Включение и отключение видовых экранов листа
Понятие Процедура Краткий справочник

Команды

СВИД

Создание видовых экранов на листах и управление ими

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ОКНОСВ

Управление свойствами объектов

ВЭКРАН

Создание нескольких видовых экранов в пространстве модели и в пространстве листа

Системные переменные

MAXACTVP

Максимальное количество видовых экранов, которые могут быть активны одновременно

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Масштабирование типов линий на видовых экранах листа (Понятие)

Включение и отключение видовых экранов листа
Управление видами на видовых экранах листа
Выравнивание видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа >
Масштабирование типов линий на видовых экранах листа
Понятие Процедура Краткий справочник

В пространстве листа масштаб типа линий может быть задан на основе единиц измерения чертежа пространства, где был создан объект или на основе единиц пространства листа.

Для сохранения одинакового масштаба типа линий у объектов, которые отображаются с различным масштабом на листе и в видовом экране, можно использовать системную переменную PSLTSCALE. Например, если системной переменной PSLTSCALE задано значение 1 (по умолчанию), можно установить текущий тип линий как штрихованный, а затем провести отрезок в пространстве листа. После этого на листе создается видовой экран с коэффициентом экранного увеличения 1x. Он устанавливается текущим, и на нем тем же самым штриховым типом линий проводится отрезок. Обе штриховые линии должны выглядеть одинаково. Если изменить коэффициент экранного увеличения видового экрана на 2x, масштаб типа линий у обоих отрезков останется одинаковым, несмотря на различие в коэффициентах экранного увеличения.

При включенной функции PSLTSCALE можно управлять длиной штриховки с помощью системных переменных LTSCALE и CELTSCALE. На левом чертеже установлен одинаковый масштаб типа линии, независимо от масштабов видов. На правом чертеже масштаб типа линии соответствует масштабу вида.

См. также

    • Задание масштаба весов линий


Установка единого масштаба линий в пространстве листа (Процедура)

Включение и отключение видовых экранов листа
На уровень вверх ..
Выравнивание видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Масштабирование типов линий на видовых экранах листа >
Масштабирование типов линий на видовых экранах листа
Понятие Процедура Краткий справочник

Установка единого масштаба линий в пространстве листа

  1. Выберите меню "Формат" [image] "Типы линий".В командной строке введите "типлин".
  2. В окне "Диспетчер типов линий" выбрать "Вкл подробности".
  3. Ввести значение глобального масштаба в поле "Глобальный масштаб".
  4. Нажмите "ОК".
Ввод команды: ТИПЛИН


Масштабирование типов линий на видовых экранах листа (Краткий справочник)

Включение и отключение видовых экранов листа
Масштабирование типов линий на видовых экранах листа
Выравнивание видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Масштабирование типов линий на видовых экранах листа >
Масштабирование типов линий на видовых экранах листа
Понятие Процедура Краткий справочник

Команды

ТИПЛИН

Загрузка, установка и изменение типов линий

Системные переменные

PSLTSCALE

Управление масштабированием типов линий в пространстве листа

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выравнивание видов на видовых экранах листа (Понятие)

Масштабирование типов линий на видовых экранах листа
Управление видами на видовых экранах листа
Поворот видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа >
Выравнивание видов на видовых экранах листа
Понятие Процедура Краткий справочник

В целях улучшения внешнего вида чертежа можно выровнять (горизонтально, вертикально или под углом) виды на различных видовых экранах друг относительно друга.

Это достигается панорамированием вида на одном видовом экране относительно базовой точки, расположенной на другом.

Для точного выравнивания видов на листе можно воспользоваться вспомогательной геометрией, объектной привязкой к объектам пространства модели, отображаемым на видовых экранах листа, или любым из режимов ограничения передвижения курсора, включаемым с помощью панели состояния.


Выравнивание видов на видовых экранах листа (Процедура)

Масштабирование типов линий на видовых экранах листа
На уровень вверх ..
Выравнивание видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Выравнивание видов на видовых экранах листа >
Выравнивание видов на видовых экранах листа
Понятие Процедура Краткий справочник

Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии

Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ


Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии (Процедура)

Выравнивание видов на видовых экранах листа
На уровень вверх ..
Выравнивание видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Выравнивание видов на видовых экранах листа >
Выравнивание видов на видовых экранах листа
Понятие Процедура Краткий справочник

Выравнивание объектов на разных видовых экранах с помощью вспомогательной линии

  1. Перейти на вкладку "Лист".
  2. Выберите меню "Рисование" [image] "Прямая".В командной строке введите "прямая".
  3. Указать точку на первом видовом экране. Указать вторую точку для определения вспомогательной линии выравнивания.

    Указать точку для выравнивания объектов на втором видовом экране. Для обеспечения точности указания можно использовать объектную привязку.

  4. Выберите меню "Изменить" [image] "Перенести".
  5. Выбрать видовой экран для выравнивания относительно первого видового экрана. Нажмите ENTER.
  6. На запрос базовой точки указать точку на втором видовом экране. Указать точку, соответствующую заданной точке на первом видовом экране.
  7. При появлении запроса на ввод второй точки нажмите клавишу SHIFT и, не отпуская, щелкните правой кнопкой мыши. Выберите "Объектная привязка" [image] "Нормаль".Выберите построенную вспомогательную линию.

    Два заданных видовых экрана и объекты на них выравниваются.

    ПримечаниеДля выравнивания объектов масштабы выравниваемых видовых экранов должны быть одинаковыми.


Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ (Процедура)

Выравнивание видов на видовых экранах листа
На уровень вверх ..
Поворот видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Выравнивание видов на видовых экранах листа >
Выравнивание видов на видовых экранах листа
Понятие Процедура Краткий справочник

Выравнивание объектов на разных видовых экранах с помощью команды ФОРМАТЛ

  1. В командной строке введите форматл.
  2. Ввести в (Выровнять).
  3. Выбрать один из следующих способов выравнивания.
    • Горизонтальное. Выравнивание по горизонтали точки на одном видовом экране с базовой точкой на другом видовом экране.
    • Вертикальное. Выравнивание по вертикали точки на одном видовом экране с базовой точкой на другом видовом экране.
    • Угловое. Выравнивание точки на одном видовом экране на заданном расстоянии и под заданным углом от базовой точки на другом видовом экране.
  4. Сделать текущим видовой экран, относительно которого будут выравниваться все остальные. Указать базовую точку.
  5. Выбрать выравниваемый видовой экран. Затем указать на нем точку для выравнивания.
  6. Если производится угловое выравнивание, задать для выравниваемой точки расстояние и угол относительно базовой.


Выравнивание видов на видовых экранах листа (Краткий справочник)

Масштабирование типов линий на видовых экранах листа
Выравнивание видов на видовых экранах листа
Поворот видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Выравнивание видов на видовых экранах листа >
Выравнивание видов на видовых экранах листа
Понятие Процедура Краткий справочник

Команды

ПЕРЕНЕСТИ

Перемещение объектов на заданное расстояние в указанном направлении

ФОРМАТЛ

Задание параметров чертежа

ПСК

Управление пользовательскими системами координат

ЗНАКПСК

Управление видимостью и расположением знака ПСК

ДИСПСК

Управление заданными пользовательскими системами координат

Системные переменные

ЗНАКПСК

Управление видимостью и расположением знака ПСК

UCSVP

Определение, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Поворот видов на видовых экранах листа (Понятие)

Выравнивание видов на видовых экранах листа
Управление видами на видовых экранах листа
Повторное использование листов и их параметров
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа >
Поворот видов на видовых экранах листа
Понятие Процедура Краткий справочник

Можно выполнять поворот всего вида на видовом экране листа путем изменения ПСК или с помощью команды ПЛАН.

С помощью команды ПСК можно поворачивать плоскость XY на любой угол вокруг оси Z. При вводе команды ПЛАН выполняется поворот вида в соответствии с ориентацией плоскости XY.

Для ускорения процесса можно использовать параметры "Выровнять" и "Повернуть вид" команды ФОРМАТЛ.

ПримечаниеКоманда ПОВЕРНУТЬ поворачивает только отдельные объекты и не может использоваться для поворота всего вида.


Поворот видов на видовых экранах листа (Процедура)

Выравнивание видов на видовых экранах листа
На уровень вверх ..
Поворот видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Поворот видов на видовых экранах листа >
Поворот видов на видовых экранах листа
Понятие Процедура Краткий справочник

Поворот вида путем изменения ПСК

Поворот вида листа с помощью команды ФОРМАТЛ


Поворот вида путем изменения ПСК (Процедура)

Поворот видов на видовых экранах листа
На уровень вверх ..
Поворот видов на видовых экранах листа
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Поворот видов на видовых экранах листа >
Поворот видов на видовых экранах листа
Понятие Процедура Краткий справочник

Поворот вида путем изменения ПСК

  1. Перейти на вкладку "Лист".
  2. Дважды нажать кнопку мыши на видовом экране, объекты которого необходимо повернуть.
  3. Убедитесь в том, что текущая ПСК параллельна плоскости вращения (значок ПСК должен иметь нормальный вид). Если ПСК не параллельна плоскости вращения, то выберите "Сервис" [image] "Новая ПСК" [image] "Вид".Если ПСК не параллельна плоскости вращения, то в командной строке введите "пск".
  4. Выберите в меню "Сервис" [image] "Новая ПСК" [image] "Z".В командной строке введите "пск". Для поворота вида на 90 градусов по часовой стрелке введите 90. Для поворота вида на 90 градусов против часовой стрелки введите -90.
  5. Выберите меню "Вид" [image] "3D виды" [image] "Вид в плане" [image] "Текущая ПСК".В командной строке введите "план".

    Происходит поворот вида в целом внутри видового экрана. Может потребоваться повторно указать масштаб видового экрана.

Панель:ПСК
Ввод команды: ПСК


Поворот вида листа с помощью команды ФОРМАТЛ (Процедура)

Поворот видов на видовых экранах листа
На уровень вверх ..
Повторное использование листов и их параметров
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Поворот видов на видовых экранах листа >
Поворот видов на видовых экранах листа
Понятие Процедура Краткий справочник

Поворот вида листа с помощью команды ФОРМАТЛ

  1. На листе введитеформатлв командной строке.
  2. Ввести в (Выровнять).
  3. Введите "п" (Повернуть) для поворота вида на определенный угол или по двум точкам.
  4. Если на листе есть несколько видовых экранов, щелкните на том экране, вид которого требуется повернуть.
  5. Указать базовую точку поворота.
  6. Задайте угол поворота или вторую точку для определения угла поворота.

    Происходит поворот вида в целом внутри видового экрана.

  7. Для восстановления предыдущей ПСК введите "пск" и "п" (Предыдущая СК).


Поворот видов на видовых экранах листа (Краткий справочник)

Выравнивание видов на видовых экранах листа
Поворот видов на видовых экранах листа
Повторное использование листов и их параметров
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Управление видами на видовых экранах листа > Поворот видов на видовых экранах листа >
Поворот видов на видовых экранах листа
Понятие Процедура Краткий справочник

Команды

ФОРМАТЛ

Задание параметров чертежа

ПЛАН

Отображение вида в плане указанной ПСК

ПСК

Управление пользовательскими системами координат

ЗНАКПСК

Управление видимостью и расположением знака ПСК

ДИСПСК

Управление заданными пользовательскими системами координат

Системные переменные

ЗНАКПСК

Управление видимостью и расположением знака ПСК

UCSVP

Определение, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана

VIEWTWIST

Хранение значения угла поворота вида для текущего видового экрана, измеренного относительно МСК

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Повторное использование листов и их параметров (Понятие)

Поворот видов на видовых экранах листа
Создание многовидовых чертежей (в пространстве листа)
Работа с листами в подшивке
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) >
Повторное использование листов и их параметров
Понятие Процедура Краткий справочник

При создании листа можно использовать информацию из существующего шаблона.

Шаблон листа это лист, импортированный из DWG- или DWT-файла. При создании листа можно использовать информацию из существующего шаблона. В программе содержатся шаблоны для использования при разработке новой среды листа. На новый лист переносятся все объекты пространства листа и все параметры листа. В число используемых объектов здесь включаются и видовые экраны. Пользователь может по своему усмотрению сохранить импортированные объекты или удалить их. Объекты пространства модели из шаблона не импортируются.

Файлы шаблонов листов имеют расширение .dwt. В текущий чертеж можно импортировать любой шаблон листа из любого другого чертежа.

Сохранение шаблона листа

Любой чертеж, включая все объекты и параметры листа, можно сохранить как шаблон (файл DWT). Отдельно сохранить лист в новом шаблоне можно с помощью функции "Сохранить" команды РЛИСТ. DWT-файл записывается в папку, отведенную для шаблонов в диалоговом окне "Настройка" на вкладке "Файлы". Файл шаблона листа, как и файл чертежа или шаблона чертежа, имеет расширение .dwt или .dwg и содержит, помимо прочего, некоторый объем информации, не используемый листом.

При создании нового шаблона листа в него записываются все именованные объекты, такие как блоки, слои и размерные стили, используемые на листе. Все эти объекты в виде описаний символьных таблиц импортируются с шаблоном как часть параметров листа при создании нового листа. Для создания нового шаблона листа рекомендуется использовать команду РЛИСТ с параметром "Сохранить как". Только в этом случае гарантируется, что в шаблоне не будут присутствовать неиспользуемые описания символьных таблиц, которые окажутся совершенно бесполезными и будут только загромождать базу данных чертежа при дальнейшем импорте.

Если шаблон сохранен без использования параметра "Сохранить как" команды РЛИСТ, то при вставке листа из такого шаблона импортируются все неиспользуемые на листе описания символьных таблиц. Для удаления неиспользуемых описаний символьных таблиц применяется команда ОЧИСТИТЬ.

Вставка листа с помощью Центра управления

Центр управления™ позволяет перетащить в текущий чертеж лист вместе с находящимися на нем объектами.

Физически процесс вставки листа с помощью Центра управления сводится к созданию в чертеже нового листа, на который копируются все объекты, символьные таблицы и описания блоков из исходного. После этого можно удалить ненужные объекты пространства листа. Для того, чтобы удалить из созданного листа неиспользуемые элементы символьных таблиц, следует применить команду ОЧИСТИТЬ.


Повторное использование листов и их параметров (Процедура)

Поворот видов на видовых экранах листа
Повторное использование листов и их параметров
Повторное использование листов и их параметров
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Повторное использование листов и их параметров >
Повторное использование листов и их параметров
Понятие Процедура Краткий справочник

Создание листа на основе шаблона

Сохранение шаблона листа

Вставка листа с помощью Центра управления


Создание листа на основе шаблона (Процедура)

Повторное использование листов и их параметров
Повторное использование листов и их параметров
Повторное использование листов и их параметров
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Повторное использование листов и их параметров >
Повторное использование листов и их параметров
Понятие Процедура Краткий справочник

Создание листа на основе шаблона

  1. Выберите меню "Вставка" [image] "Лист" [image] "Лист по шаблону.В командной строке введите "рлист".
  2. В диалоговом окне "Выбор файла" выбрать файл шаблона из списка.
  3. Нажмите "Открыть".
  4. В диалоговом окне "Вставка листов" выбрать шаблон листа из списка. Нажмите "ОК".

    Новый лист создается на основе выбранного шаблона. Новому листу автоматически присваивается имя, состоящее из слова "Лист", первого незанятого порядкового номера, а также (через дефис) имени листа в шаблоне.

    Например, если в чертеже, где уже имеются листы "Лист1" и "Лист2", вставляется третий лист из шаблона, где лист имеет имя "ANSI D", то новому листу присваивается имя "Лист3 - ANSI D".

Панель:Листы
Ввод команды: РЛИСТ
Контекстное меню:Нажать правую кнопку мыши на вкладке листа. Выбрать в контекстном меню "По шаблону".


Сохранение шаблона листа (Процедура)

Повторное использование листов и их параметров
Повторное использование листов и их параметров
Повторное использование листов и их параметров
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Повторное использование листов и их параметров >
Повторное использование листов и их параметров
Понятие Процедура Краткий справочник

Сохранение шаблона листа

  1. В командной строке введите рлист.
  2. В ответ на запрос команды ввести с для сохранения текущего листа в качестве шаблона.
  3. Ввести имя сохраняемого листа.
  4. В диалоговом окне "Создание файла чертежа" указать имя, под которым должен быть сохранен шаблон.
  5. В списке "Тип файла" выбрать "Шаблоны чертежей (*.dwt)".
  6. Нажмите "Сохранить".


Вставка листа с помощью Центра управления (Процедура)

Повторное использование листов и их параметров
Повторное использование листов и их параметров
Создание и управление подшивкой
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Повторное использование листов и их параметров >
Повторное использование листов и их параметров
Понятие Процедура Краткий справочник

Вставка листа с помощью Центра управления

  1. Выберите меню "Сервис" [image] "Центр управления".
  2. В дереве вида найти чертеж, содержащий лист, который требуется повторно использовать.
  3. Дважды нажать кнопку мыши на имени чертежа, чтобы развернуть меню опций.
  4. Выбрать значок "Лист" для отображения листов в области содержимого.
  5. Воспользоваться одним из следующих способов для вставки листа в текущий чертеж:
    • Перетащить значок листа из области содержимого в чертеж.
    • Выбрать лист в области содержимого и нажать правую кнопку мыши. Выбрать в контекстном меню "Добавить листы".
    • Дважды нажать кнопку мыши на листе в области содержимого.
Панель:Стандартный
Ввод команды: ЦУВКЛ


Повторное использование листов и их параметров (Краткий справочник)

Поворот видов на видовых экранах листа
Повторное использование листов и их параметров
Быстрый запуск подшивок
Выбор рабочего процесса перед началом работы > Создание многовидовых чертежей (в пространстве листа) > Повторное использование листов и их параметров >
Повторное использование листов и их параметров
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

РЛИСТ

Создание и изменение вкладок "Лист" в чертеже

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

МАСТЕРПЕЧ

Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

Системные переменные

TDCREATE

Значения даты и времени (местного) создания чертежа

TDUCREATE

Значения даты и времени (всемирного) создания чертежа

TDUPDATE

Значения даты и времени (местного) последнего сохранения/обновления

TDUPDATE

Значения даты и времени (всемирного) последнего сохранения/обновления

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с листами в подшивке

Повторное использование листов и их параметров
Выбор рабочего процесса перед началом работы
Быстрый запуск подшивок
Выбор рабочего процесса перед началом работы >
Работа с листами в подшивке

С помощью Диспетчера подшивок пользователь может организовывать листы чертежей в именованные подшивки. Листы в подшивке можно передавать, публиковать и архивировать как одно целое.

Темы в этом разделе

  • Быстрый запуск подшивок

    Подшивка представляет собой организованный особым образом набор листов, принадлежащих различным файлам чертежей. Каждый лист подшивки представляет собой определенный лист-вкладку из файла чертежа.

  • Интерфейс Диспетчера подшивок

    Диспетчер подшивок позволяет создавать и организовывать листы в подшивках.

  • Создание и управление подшивкой

    Существует несколько способов настройки и организации подшивки. В подшивку можно включить информацию о самой подшивке или ее компонентах.

  • Публикация, комплектование и архивация подшивок

    Готовую подшивку можно опубликовать, укомплектовать для пересылки или заархивировать.

  • Коллективная работа с подшивками

    Коллективная работа с подшивками может осуществляться по локальной сети, через Интернет или по электронной почте. В группу могут также входить пользователи, использующие программное обеспечение без Диспетчера подшивок.


Быстрый запуск подшивок (Понятие)

Работа с листами в подшивке
Работа с листами в подшивке
Интерфейс Диспетчера подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке >
Быстрый запуск подшивок
Понятие Краткий справочник

Подшивка представляет собой организованный особым образом набор листов, принадлежащих различным файлам чертежей. Каждый лист подшивки представляет собой определенный лист-вкладку из файла чертежа.

Наборы чертежей являются основным итогом работы большинства проектных коллективов. Наборы чертежей представляют все содержание проекта вместе с его техническим описанием. В то же время управлять наборами чертежей вручную довольно сложно.

Управлять подшивками листов можно с помощью Диспетчера подшивок. Подшивка представляет собой организованный особым образом именованный набор листов из нескольких файлов чертежей. Каждый лист подшивки представляет собой определенный лист-вкладку из файла чертежа. Пользователь может импортировать в подшивку и пронумеровать любой лист из любого чертежа.

Подшивки можно передавать, публиковать и архивировать как единое целое.


Быстрый запуск подшивок (Краткий справочник)

Повторное использование листов и их параметров
Быстрый запуск подшивок
Интерфейс Диспетчера подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Быстрый запуск подшивок >
Быстрый запуск подшивок
Понятие Краткий справочник

Команды

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMPOLLTIME

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Интерфейс Диспетчера подшивок (Понятие)

Быстрый запуск подшивок
Работа с листами в подшивке
Создание и управление подшивкой
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке >
Интерфейс Диспетчера подшивок
Понятие Краткий справочник

Диспетчер подшивок позволяет создавать и организовывать листы в подшивках.

В Диспетчере подшивок имеются следующие вкладки и настройки:

Меню команд. Содержит список параметров меню для создания новой подшивки, открытия существующей подшивки или переключения между открытыми подшивками.

Вкладка "Список листов". Содержит организованный список всех листов в подшивке. Каждый лист в подшивке представляет собой определенный лист-вкладку в файле чертежа.

Вкладка "Виды листа". Содержит организованный список всех видов на листах, включенных в подшивку. В списке отображаются только те виды, которые были созданы AutoCAD 2005 или более поздних версиях.

Вкладка "Виды моделей". Содержит список путей и имен папок для чертежей, содержащих виды пространства модели, используемые в подшивке.

  • Нажмите кнопку мыши на папке для просмотра списка файлов чертежей, которые расположены в данной папке.
  • Выберите файл чертежа для просмотра списка именованных видов в пространстве модели, которые можно расположить на текущем листе.
  • Дважды нажмите кнопку мыши на виде для открытия чертежа, содержащего этот вид.
  • Щелкните правой кнопкой мыши или перетащите вид для расположения его на текущем листе.

Кнопки. Обеспечивает удобный доступ к наиболее часто используемым операциям для выбранной вкладки.

Область структуры. Представляет содержание вкладки.

Подробности/Просмотр. Представляет либо описательную информацию, либо образец для просмотра текущего выбранного в области структуры элемента.

Действия, используемые в области структуры

В области структуры можно выполнить следующие действия:

  • Используйте команды контекстного меню, относящиеся к текущему выделенному элементу.
  • Дважды нажмите кнопку мыши на элементе для его открытия. Этим способом удобно открывать файлы чертежей, перечисленные на вкладке списка листов или на вкладке видов модели. Для того, чтобы развернуть или свернуть элемент в области структуры, дважды нажмите на нем кнопку мыши.
  • Выделите один или несколько элементов и выполните с ними такие операции, как открытие, публикация или передача.
  • Выберите отдельный элемент для просмотра описательной информации или отображения образца для просмотра выбранного листа, вида или файла чертежа.
  • Перетащите элементы внутри области структуры и измените их порядок.
ПримечаниеДля удобства в Диспетчере подшивок предусмотрено контекстное меню, вызываемое по нажатию правой кнопки мыши на элементе в области структуры. Для доступа к контекстным меню в области рисования, необходимым для работы с подшивками, в диалоговом окне "Параметры" на вкладке "Пользовательские" установите флажок "Контекстные меню в области рисования".


Интерфейс Диспетчера подшивок (Краткий справочник)

Быстрый запуск подшивок
Интерфейс Диспетчера подшивок
Создание подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Интерфейс Диспетчера подшивок >
Интерфейс Диспетчера подшивок
Понятие Краткий справочник

Команды

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMPOLLTIME

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и управление подшивкой

Интерфейс Диспетчера подшивок
Работа с листами в подшивке
Создание подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке >
Создание и управление подшивкой
Понятие Процедура

Существует несколько способов настройки и организации подшивки. В подшивку можно включить информацию о самой подшивке или ее компонентах.

Темы в этом разделе

  • Создание подшивки

    Подшивка создается с помощью Мастера создания подшивок. Мастер позволяет создать подшивку с самого начала на основе существующих чертежей, либо по образцу другой подшивки.

  • Организация подшивки

    При работе с большой подшивкой может потребоваться структурировать листы и виды посредством древовидного представления.

  • Создание и изменение листов

    В диспетчере подшивок предусмотрено несколько вариантов создания листов и добавления видов с помощью контекстного меню или одной из кнопок вкладок. Изменение листа должно всегда проводиться из открытой подшивки.

  • Добавление дополнительных сведений для листов и подшивок

    В подшивках, группах и листах содержится информация различного типа. Эта информация называется свойствами и включает в себя названия, описания, пути к папкам с файлами, а также иные дополнительные сведения.


Создание и управление подшивкой (Процедура)

Повторное использование листов и их параметров
Создание и управление подшивкой
Создание подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой >
Создание и управление подшивкой
Понятие Процедура

Открытие Диспетчера подшивок

Создание новой подшивки

Открытие подшивки

Закрытие подшивки

Перегруппирование листов в списке листов

Создание новой группы в списке листов

Создание новой категории видов в списке видов

Удаление группы из списка листов

Удаление категории видов из списка видов

Импорт листа из текущего чертежа

Импорт листов из нескольких чертежей

Создание нового листа

Открытие файла чертежа в подшивке

Открытие файла чертежа в подшивке в режиме "только чтение"

Исключение листа из подшивки

Повторное прикрепление листа к подшивке

Добавление вида на лист

Добавление ведомости листов

Изменение ведомости листов

Обновление ведомости листов

Добавление блока, используемого для идентификаторов видов листов

Изменение блока, используемого по умолчанию для меток видов листов

Добавление на лист блока-идентификатора

Создание ведомости листов на титульном листе

Изменение свойств подшивки, группы листов, листа или категории вида

Создание дополнительного свойства для подшивки

Создание дополнительного свойства листа


Создание подшивки (Понятие)

Создание и управление подшивкой
Создание и управление подшивкой
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой >
Создание подшивки
Понятие Процедура Краткий справочник

Подшивка создается с помощью Мастера создания подшивок. Мастер позволяет создать подшивку с самого начала на основе существующих чертежей, либо по образцу другой подшивки.

Листы из указанных файлов чертежей импортируются в подшивку. Информация, описывающая подшивку, хранится в файле данных подшивки (с расширением DST).

При создании новой подшивки с помощью Мастера создания пошивок для ее хранения создается новая папка. Эта новая папка, именуемая Подшивки AutoCAD, располагается в папке Мои документы. Местоположение файла подшивки по умолчанию можно изменить. Файл DST рекомендуется хранить вместе с файлами проекта.

ПримечаниеФайл DST должен храниться в папке, доступной всем пользователям подшивки в сети, и быть подключенным с использованием одного логического диска. Настоятельно рекомендуется хранить файл DST и чертежи в одной папке. При перемещении всей подшивки или изменении имени сервера или папки, файл DST сможет найти листы подшивки по информации об их относительном пути.

Подготовительные действия.

Перед созданием подшивки необходимо предпринять следующие действия:

  • Компактное размещение файлов чертежей. Соберите файлы чертежей, которые будут использоваться в подшивке, в небольшом числе папок. Это упростит администрирование подшивки.
  • Исключение многолистовых чертежей. Используйте только по одному листу из каждого чертежа в подшивке. Это важно для обеспечения многопользовательского доступа к листам. Одновременно в чертеже может быть открыт только один лист.
  • Создание файла шаблона чертежа. Создайте или укажите файл шаблона чертежа (DWT), используемый подшивкой для создания новых листов. Этот файл шаблона чертежа называется шаблоном для создания листов. Укажите файл шаблона в диалоговом окне "Свойства подшивки" или "Свойства группы листов".
  • Создание файла переопределения параметров листа. Создайте или укажите файл DWT для хранения параметров страницы для печати или публикации. Этот файл, называемый файлом переопределения параметров листов, может быть использован для применения одних и тех же параметров листа ко всем листам в подшивке, независимо от индивидуальных настроек листов, хранящихся в каждом чертеже.
ПримечаниеНе рекомендуется использовать в подшивке несколько листов из одного и того же файла чертежа, несмотря на то, что такая организация подшивки возможна. В этом случае параллельная работа с листами нескольких пользователей невозможна. Кроме того, это усложняет организацию подшивок и затрудняет работу с ними.

Создание подшивки по образцу

Функция создания подшивки по образцу в Мастере создания подшивок позволяет использовать в новой подшивке структуру и настройки образца. Можно также создавать папки в соответствии с путями к группам листов подшивки.

Листы для созданной с помощью этой функции пустой подшивки можно импортировать из чертежей или создать отдельно.

Создание подшивки из существующих файлов чертежей

При выборе в Мастере создания подшивок функции создания подшивки из существующих файлов чертежей укажите одну или несколько папок, содержащих файлы чертежей. При этом подшивку можно организовать таким образом, чтобы структура групп листов подшивки дублировала структуру папок файлов чертежей. Листы из этих чертежей могут быть импортированы в подшивку автоматически.

Для добавления дополнительных папок с чертежами можно воспользоваться кнопкой "Обзор".

Резервное копирование и восстановление файлов данных подшивки

Данные, хранящиеся в файлах данных подшивок, представляют собой значительную часть работы. Поэтому для файлов DST, так же как и для файлов чертежей следует создавать резервные копии.

В случае повреждения файла DST или серьезной ошибки пользователя предварительно сохраненный файл данных подшивки может быть восстановлен. Каждый раз при открытии файла данных подшивки текущий файл данных подшивки копируется в файл резервной копии (DS$). Этот резервный файл имеет то же имя файла и расположен в той же папке, что и текущий файл данных подшивки.

Для восстановления предыдущей версии файла данных подшивки сначала необходимо убедиться, что с данной подшивкой никто не работает. Затем рекомендуется скопировать существующий файл DST под другим именем. И, наконец, измените расширение резервного файла с DS$ на DST.


Создание подшивки (Процедура)

Создание и управление подшивкой
На уровень вверх ..
Создание подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание подшивки >
Создание подшивки
Понятие Процедура Краткий справочник

Открытие Диспетчера подшивок

Создание новой подшивки

Открытие подшивки

Закрытие подшивки


Открытие Диспетчера подшивок (Процедура)

Создание подшивки
На уровень вверх ..
Создание подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание подшивки >
Создание подшивки
Понятие Процедура Краткий справочник

Открытие Диспетчера подшивок

  • Выберите меню "Сервис" [image] "Палитры" [image] "Диспетчер подшивок".В командной строке введите "подшивкаоткл".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание новой подшивки (Процедура)

Создание подшивки
На уровень вверх ..
Создание подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание подшивки >
Создание подшивки
Понятие Процедура Краткий справочник

Создание новой подшивки

  1. Для создания новой подшивки необходимо выполнить одно из следующих действий:
    • Выберите меню "Файл" [image] "Новая подшивка".В командной строке введите "пшсоздать".
    • В Диспетчере подшивок выберите меню команд. Выберите в контекстном меню "Создать подшивку".
  2. Следуйте инструкциям Мастера создания подшивок.
Ввод команды: ПШСОЗДАТЬ


Открытие подшивки (Процедура)

Создание подшивки
На уровень вверх ..
Создание подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание подшивки >
Создание подшивки
Понятие Процедура Краткий справочник

Открытие подшивки

  1. Для открытия подшивки необходимо выполнить одно из следующих действий:
    • Выберите меню "Файл" [image] "Открыть подшивку".В командной строке введите "пшоткрыть".
    • В Диспетчере подшивок выберите меню команд. Нажмите "Открыть".
    • Дважды нажмите кнопку мыши на файле данных подшивки (DST).
  2. В диалоговом окне "Открыть подшивку" перейти к папке, содержащей файл DST. Выберите файл DST и затем нажмите "Открыть".

    В Диспетчере подшивок открываются данные подшивки.

    ПримечаниеМожно открыть несколько подшивок и переключаться между ними с помощью меню команд.
Панель:Стандартный
Ввод команды: ПОДШИВКА


Закрытие подшивки (Процедура)

Создание подшивки
На уровень вверх ..
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание подшивки >
Создание подшивки
Понятие Процедура Краткий справочник

Закрытие подшивки

  1. В Диспетчере подшивок на вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки (наверху листа). Выберите в контекстном меню "Закрыть подшивку".

    Данная подшивка исключается из Диспетчера подшивок.

    ПримечаниеЧтобы уменьшить количество подшивок в списке меню команд, рекомендуется закрыть неиспользуемые подшивки. Но если закрыть подшивку, у которой остались открыты листы, невозможно будет обновить ведомость листов и некоторые поля.
Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание подшивки (Краткий справочник)

Интерфейс Диспетчера подшивок
Создание подшивки
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание подшивки >
Создание подшивки
Понятие Процедура Краткий справочник

Команды

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMPOLLTIME

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Организация подшивки (Понятие)

Создание подшивки
Создание и управление подшивкой
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой >
Организация подшивки
Понятие Процедура Краткий справочник

При работе с большой подшивкой может потребоваться структурировать листы и виды посредством древовидного представления.

На вкладке "Список листов" листы можно объединять в группы. На вкладке "Виды листов" виды можно объединять в категории.

Использование групп листов

Логика формирования групп листов часто определяется дисциплинарной спецификой проекта. Например, в архитектуре пользователь может использовать группу с именем "Несущие элементы"; а в машиностроении - группу с именем "Стандартный крепеж". В некоторых случаях бывает полезной организация групп листов по состоянию их готовности (на стадии рассмотрения или завершения).

При необходимости группы могут быть вложены в другие группы. После создания или импорта листов или групп листов можно перегруппировать их путем перетаскивания в области структуры.

Использование категорий вида

Категории видов часто определяются функционально. Например, в архитектуре уместна категория видов с названием "Уровни"; а в машиностроении - категория видов с названием "Расчлененные".

Виды можно отображать по категориям или по листам, на которых они расположены.

При необходимости категории могут быть вложены в другие категории. Для перемещения вида в другую категорию его можно перетащить в области структуры или использовать команду контекстном меню "Установить категорию".


Организация подшивки (Процедура)

Создание подшивки
На уровень вверх ..
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Организация подшивки >
Организация подшивки
Понятие Процедура Краткий справочник

Перегруппирование листов в списке листов

Создание новой группы в списке листов

Создание новой категории видов в списке видов

Удаление группы из списка листов

Удаление категории видов из списка видов


Перегруппирование листов в списке листов (Процедура)

Организация подшивки
На уровень вверх ..
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Организация подшивки >
Организация подшивки
Понятие Процедура Краткий справочник

Перегруппирование листов в списке листов

  • В Диспетчере подшивок на вкладке "Список листов" перетащить лист в списке вверх или вниз.

Лист будет перемещен выше или ниже своего предшествующего положения в списке листов. Лист также может быть перемещен в группу листов или из нее.

Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание новой группы в списке листов (Процедура)

Организация подшивки
На уровень вверх ..
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Организация подшивки >
Организация подшивки
Понятие Процедура Краткий справочник

Создание новой группы в списке листов

  1. В Диспетчере подшивок на вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки (наверху листа) или существующей группы листов. Выберите в контекстном меню "Создать группу".
  2. В диалоговом окне "Свойства группы листов" введите имя новой группы в соответствующем поле. Нажмите "ОК".

    Можно перетащить новую группу листов в любое место в списке листов, или даже поместить ее в другие группы листов.

    ПримечаниеДля создания подгруппы в существующей группе листов щелкните правой кнопкой мыши на существующей группе и выберите в контекстном меню "Создать группу".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание новой категории видов в списке видов (Процедура)

Организация подшивки
На уровень вверх ..
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Организация подшивки >
Организация подшивки
Понятие Процедура Краткий справочник

Создание новой категории видов в списке видов

  1. В режиме "Диспетчер подшивок" на вкладке "Виды листов" нажмите кнопку "Просмотр по категориям".
  2. Щелкните правой кнопкой мыши на узле подшивки (наверху листа) и выберите в контекстном меню "Создать категорию видов".
  3. В диалоговом окне "Категория видов" в поле "Имя категории" введите имя новой категории вида.
  4. Если имеется список блоков-идентификаторов, то необходимо выбрать блоки, которые должны использоваться для видов в данной категории. Пользователь может добавить блоки в данный список, нажав кнопку "Добавить блоки".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Удаление группы из списка листов (Процедура)

Организация подшивки
На уровень вверх ..
Организация подшивки
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Организация подшивки >
Организация подшивки
Понятие Процедура Краткий справочник

Удаление группы из списка листов

  1. В Диспетчере подшивок на вкладке "Список листов" перетащить все листы из группы, которую необходимо удалить.
  2. Нажмите правую кнопки мыши на группе, которую надо удалить и выберите в контекстном меню "Удалить группу".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Удаление категории видов из списка видов (Процедура)

Организация подшивки
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Организация подшивки >
Организация подшивки
Понятие Процедура Краткий справочник

Удаление категории видов из списка видов

  1. В режиме "Диспетчер подшивок" на вкладке "Виды листов" нажмите кнопку "Просмотр по категориям".
  2. Перетащить все листы из категории видов, которую необходимо удалить.
  3. Щелкните правой кнопкой мыши на категории видов, которую требуется удалить. Выберите в контекстном меню "Удалить категорию".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Организация подшивки (Краткий справочник)

Создание подшивки
Организация подшивки
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Организация подшивки >
Организация подшивки
Понятие Процедура Краткий справочник

Команды

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMPOLLTIME

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и изменение листов (Понятие)

Организация подшивки
Создание и управление подшивкой
Добавление дополнительных сведений для листов и подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой >
Создание и изменение листов
Понятие Процедура Краткий справочник

В диспетчере подшивок предусмотрено несколько вариантов создания листов и добавления видов с помощью контекстного меню или одной из кнопок вкладок. Изменение листа должно всегда проводиться из открытой подшивки.

Далее представлено описание часто выполняемых операций с листами. Доступ к командам можно получить с помощью контекстного меню для элемента в области структуры.

  • Импорт листа. После создания подшивки можно импортировать один или несколько листов из существующих чертежей. Инициализация листов возможна путем выбора их вкладок, так производится активизация ранее неиспользуемых листов. Перед инициализацией лист не содержит параметров печати. После инициализации листы могут быть извлечены, опубликованы и добавлены в подшивку (после сохранения чертежа). Это быстрый способ создания нескольких листов из листов нескольких чертежей. В текущем чертеже можно перетащить вкладку "Лист" прямо на область "Листы" на вкладке "Список листов" в Диспетчере подшивок.
  • Создание нового листа. В качестве альтернативы импорту существующих листов можно создать новый лист. При расположении видов на таком листе, файлы чертежей, связанные с видами, вставляются на лист чертежа как внешние ссылки. Файл чертежа листа создается с использованием либо формата AutoCAD 2004, либо формата AutoCAD 2007 в зависимости от того, какой формат указан во вкладке "Открытие/Сохранение" в диалоговом окне "Настройка".
  • Редактирование листа. Дважды нажмите кнопку мыши на листе на вкладке "Список листов" для открытия чертежа из подшивки. Для выбора нескольких листов используются клавиши SHIFT или CTRL. Для просмотра листа откройте чертеж с помощью контекстного меню в режиме "только чтение".
    ПримечаниеПри редактировании листа подшивка, в которую он входит, должна быть открыта в Диспетчере подшивок. Это обеспечит обновление всех данных, связанных с листом.
  • Переименование и перенумерация листов После создания листа можно изменять заголовок и номер листа. Можно также задавать другой файл чертежа, связываемый с листом.
    ПримечаниеПри изменении имени листа чертежа обновляется заголовок соответствующего листа в подшивке и наоборот.
  • Исключение листа из подшивки. Удаление листа из подшивки разрывает связь листа с подшивкой, но не удаляет файл чертежа или лист.
  • Повторное прикрепление листа. Если лист был перемещен в другую папку, его необходимо заново связать с подшивкой в диалоговом окне "Свойства листа" для того, чтобы указать правильный путь. Для перемещенных чертежей их пути указаны в диалоговом окне "Свойства листа" в полях "Ожидаемый лист чертежа" и "Реальный лист чертежа". Для повторного прикрепления листа выберите путь в поле "Ожидаемый лист чертежа" и укажите новое местоположение листа.
    ПримечаниеПоле "Подробности", расположенное внизу вкладки "Список листов" позволяет быстро узнать, находится ли лист в ожидаемой папке. Если выбранный лист не найден по ожидаемому пути, то информация об ожидаемой и реальной папке отобразится в поле "Подробности".
  • Добавление вида на лист. На вкладке "Виды моделей" можно удобно добавлять вид на лист, помещая именованный вид пространства модели или весь чертеж на текущий лист.
    ПримечаниеПосле создания именованного вида пространства модели и сохранения чертежа вид добавляется на вкладку "Виды моделей". Нажмите "Обновить" на вкладке "Чертежи с ресурсами" для обновления области структуры Диспетчера подшивок.
  • Добавление блоков-меток для видов. С помощью Диспетчера подшивок можно автоматически присваивать метки видам и деталям при размещении их на листе. Каждая метка содержит данные о соответствующем виде.

  • Добавление блоков-идентификаторов для видов. Блоками-идентификаторами называются обозначения, которые ссылаются на другие листы. Блоки-идентификаторы могут называться по-разному (в зависимости от отрасли промышленности): ссылочные метки, коды выносных элементов, метки выносных элементов, коды разрезов зданий и т.д. Блоки-идентификаторы содержат данные, связанные с листом и видом, на которые происходит ссылка.
    ПримечаниеПри размещении на листе блока-идентификатора с полями или видом следует убедиться, что текущий слой разблокирован.

  • Создание титульного листа и оглавления. Первым листом в подшивке обычно является титульный лист, содержащий описание подшивки и таблицу с перечнем всех листов подшивки. Пользователь может создать такую таблицу, называемую ведомостью листов, на открытом листе. В ведомость автоматически включаются все листы подшивки. Создать ведомость листов с помощью контекстного меню подшивки можно только при открытом листе. После создания ведомости листов подшивки можно использовать опции для изменения, обновления или удаления содержимого ячеек ведомости.
    ПримечаниеДля доступа к контекстным меню в области рисования, необходимым для операций с перечнем списком листов, в диалоговом окне "Параметры" на вкладке "Пользовательские" необходимо установить флажок "Контекстные меню в области рисования".

Создание блоков-идентификаторов и блоков меток (дополнительно)

При создании блока, который будет использоваться как блок-идентификатор или блок метки, можно использовать поле заменителя для отображения такой информации, как название вида или номер листа. Блок-идентификатор или блок метки необходимо определить в файле DWG или DWT, указанном в диалоговом окне "Свойства подшивки". В дальнейшем блок-идентификатор или блок метки можно вставить с помощью контекстных меню на вкладке "Виды листов" Диспетчера подшивок.

Для отображения в поле правильной информации о виде или листах, на которых в дальнейшем оно будет размещено, при определении блока поле должно быть включено в атрибут блока, а не в текст. Для определения атрибута блока вставить в качестве значения поле заменитель, выберите параметр "Установленный" и задать метку.

ПримечаниеПри создании пользовательских меток и блоков-идентификаторов во избежание выдачи запросов при размещении этих блоков на чертеже, в описании атрибутов необходимо установить стандартные параметры.

Дополнительную информацию о полях см. в разделе Вставка полей.

Размещение вида на листе (дополнительно)

Диспетчер подшивок автоматизирует и облегчает процесс добавления видов на листы подшивки. Вид на листе, называемый видом листа, состоит из нескольких согласованных объектов: внешней ссылки или геометрического объекта в пространстве модели, видового экрана листа и именованного вида в пространстве листа.

  • Вид листа может представлять пространство модели из внешнего файла чертежа. В этом случае внешний чертеж вставляется в текущий как файл с внешней ссылкой. Слои файла внешнего чертежа отображаются только в создаваемом виде листа.
    ПримечаниеВнешняя ссылка подключается с использованием относительного пути. Если требуется замена пути на полностью заданный (абсолютный) путь, используйте палитру "Внешние ссылки".
  • На текущем листе создается видовой экран листа, отображающий вид пространства модели.
  • В пространстве листа создается именованный вид, охватывающий область видового экрана листа.

При помещении вида листа на лист все слои текущего чертежа (включая слой 0) замораживаются в новом видовом экране, созданном видом. Слои отображаются в замороженном виде в столбце "Замороженный на ВЭ" Диспетчера свойств слоев.

Для удаления вида листа из листа подшивки можно удалить видовой экран листа. Однако для удаления всех неиспользуемых элементов необходимо отсоединить внешнюю ссылку и удалить именованный вид пространства листа.

ПримечаниеПроще всего удалить вид листа сразу же после его размещения с помощью команды ОТМЕНИТЬ.
См. также

    • Создание многовидовых чертежей (в пространстве листа)


Создание и изменение листов (Процедура)

Организация подшивки
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Импорт листа из текущего чертежа

Импорт листов из нескольких чертежей

Создание нового листа

Открытие файла чертежа в подшивке

Открытие файла чертежа в подшивке в режиме "только чтение"

Исключение листа из подшивки

Повторное прикрепление листа к подшивке

Добавление вида на лист

Добавление ведомости листов

Изменение ведомости листов

Обновление ведомости листов

Добавление блока, используемого для идентификаторов видов листов

Изменение блока, используемого по умолчанию для меток видов листов

Добавление на лист блока-идентификатора

Создание ведомости листов на титульном листе


Импорт листа из текущего чертежа (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Импорт листа из текущего чертежа

  1. Если вкладки "Модель" и "Лист" не отображаются в нижней части области чертежа, щелкните правой кнопкой мыши на кнопке "Модель" в строке состояния и выберите "Отображение вкладок "Лист" и "Модель".
  2. Выполнить одно из следующих действий:
    • Щелкните правой кнопкой мыши на вкладке "Лист" и выберите "Импорт листа в подшивку".
    • Перетащите вкладку "Лист" в Диспетчер подшивок, вкладку "Список листов", область "Листы".
  3. Нажмите кнопку "Импорт".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Импорт листов из нескольких чертежей (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Импорт листов из нескольких чертежей

  1. В Диспетчере подшивок на вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки, узле группы или узле листа. Выберите в контекстном меню "Импортировать лист".
  2. В диалоговом окне "Импорт листов в подшивку" нажмите кнопку "Поиск чертежей" и выберите требуемый чертеж.

    Выбор нескольких чертежей выполняется с помощью клавиш SHIFT или CTRL.

  3. Установить флажки для листов, которые необходимо импортировать в текущую подшивку. Нажмите кнопку "Импорт".
  4. (Дополнительно) На вкладке "Список листов" щелкните правой кнопкой мыши на импортированном листе. Выберите в контекстном меню "Сменить название и номер".
  5. (Дополнительно) В диалоговом окне "Смена названия и номера листа" внести изменения в номер и заголовок листа. Нажмите "ОК".
    ПримечаниеИзменение номера и названия листа не влияет на имя файла чертежа, если не установлен флажок для параметра переименования файла.
Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание нового листа (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Создание нового листа

  1. В Диспетчере подшивок на вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки, узле группы или узле листа. Выберите "Новый лист".
  2. В диалоговом окне "Новый лист" введите номер и название листа. Нажмите "ОК".

    По умолчанию новый лист создается на основе файла шаблона чертежа, заданного в диалоговом окне "Свойства подшивки".

    ПримечаниеИ местоположение по умолчанию папки для новых листов можно в диалоговых окнах "Свойства подшивки" или "Свойства группы листов".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Открытие файла чертежа в подшивке (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Открытие файла чертежа в подшивке

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" дважды нажмите кнопку мыши на листе. Выбор нескольких чертежей выполняется с помощью клавиш SHIFT или CTRL.

    Открывается выбранный файл чертежа. Любые изменения, сделанные в чертеже и относящиеся к списку листов, сохраняются в файле данных подшивки (DST).

Панель:Стандартный
Ввод команды: ПОДШИВКА


Открытие файла чертежа в подшивке в режиме "только чтение" (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Открытие файла чертежа в подшивке в режиме "только чтение"

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" щелкните правой кнопкой мыши на листе. Выберите "Открыть только для чтения".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Исключение листа из подшивки (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Исключение листа из подшивки

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" щелкните правой кнопкой мыши на листе, который надо исключить. Выберите в контекстном меню "Исключить лист".

    Указанный лист будет удален из списка листов. Однако сам лист и файл чертежа при этом не удаляются. Этот лист можно добавить в другую подшивку.

    ПримечаниеФайл DWG, связанный с листом, не будет доступен для удаляемого из подшивки листа.
Панель:Стандартный
Ввод команды: ПОДШИВКА


Повторное прикрепление листа к подшивке (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Повторное прикрепление листа к подшивке

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" откройте лист, который требуется прикрепить.
  3. В Диспетчере подшивок нажмите на листе правую кнопку мыши. Выберите в контекстном меню "Исключить лист".
  4. Сохранить чертеж.
  5. В Диспетчере подшивок нажмите на подшивке правую кнопку мыши. Выберите в контекстном меню "Импортировать лист".
  6. В диалоговом окне "Импорт листов в подшивку" нажмите "Поиск чертежей". Выберите требуемый чертеж.
  7. Установить флажок для листа, который требуется повторно прикрепить в текущей подшивке. Нажмите кнопку "Импорт".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Добавление вида на лист (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Добавление вида на лист

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" необходимо выполнить одно из следующих действий:
    • Дважды нажмите кнопку мыши на листе для его открытия.
    • Создайте подшивку и откройте ее.
  3. Для просмотра чертежей в папке на вкладке "Виды моделей" нажмите знак плюс (+) рядом с папкой.
  4. В списке файлов чертежей необходимо выполнить одно из следующих действий:
    • Для добавления вида пространства модели на лист нажмите знак плюс (+) около файла чертежа с целью просмотра списка именованных видов пространства модели. Щелкните правой кнопкой мыши на требуемом виде пространства модели.
    • Для добавления на лист подшивки всего чертежа в качестве вида щелкните правой кнопкой мыши на файле чертежа.
  5. Выберите в контекстном меню "Вставить на лист".
    ПримечаниеВ качестве альтернативы можно перетащить на лист подшивки вид пространства модели или чертеж из вкладки "Виды моделей".
  6. Нажмите на листе правую кнопку мыши. Выберите масштаб для вида листа.
  7. Указать точку вставки для вида листе.

    Заданный вид будет добавлен на лист. Если в свойствах подшивки задана блок-метка, то на листе автоматически располагается метка вида, содержащая информацию о виде.

Панель:Стандартный
Ввод команды: ПОДШИВКА


Добавление ведомости листов (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Добавление ведомости листов

  1. В Диспетчере подшивок откройте подшивку.
  2. Щелкните правой кнопкой мыши на имени подшивки. Выберите в контекстном меню "Вставить ведомость листов".
  3. В диалоговом окне "Вставить ведомость листов" выполните следующие действия:
    • Установите "Стиль таблицы" в группе "Параметры стиля таблицы".
    • Укажите "Текст заголовка" для таблицы в группе "Параметры данных таблицы".
    • Добавьте, удалите или измените порядок записей столбцов.
  4. Нажмите "ОК" для закрытия диалогового окна и добавления таблицы в чертеж.
Панель:Стандартный
Ввод команды: ПОДШИВКА


Изменение ведомости листов (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Изменение ведомости листов

  1. Выберите ячейку в существующей ведомости листов.
  2. Щелкните правой кнопкой мыши на ячейке. Выберите "Изменить параметры ведомости листов".
  3. В диалоговом окне "Изменить параметры ведомости листов" выполните одно или несколько из следующих действий:
    • Измените "Стиль таблицы", если текущий формат не нравится.
    • Измените "Текст заголовка" таблицы.
    • Добавьте, удалите или измените порядок записей столбцов.
    • Измените тип данных или текст заголовков столбцов.
  4. Нажмите "ОК" для закрытия диалогового окна и изменения таблицы в чертеже.
Контекстное меню:Выберите любую ячейку в ведомости листов [image] Щелкните правой кнопкой мыши для открытия контекстного меню [image] Измените параметры ведомости листов".


Обновление ведомости листов (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Обновление ведомости листов

  1. Выберите ячейку в существующей ведомости листов.
  2. Щелкните правой кнопкой мыши на ячейке. Выберите "Обновить ведомость листов".
Контекстное меню:Выберите любую ячейку в ведомости листов [image] Щелкните правой кнопкой мыши для открытия контекстного меню [image] Обновите ведомость листов.


Добавление блока, используемого для идентификаторов видов листов (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Добавление блока, используемого для идентификаторов видов листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Виды листов" выберите правой кнопкой мыши узел подшивки.
  3. В диалоговом окне "Свойства подшивки" нажмите "Блоки-идентификаторы". Нажмите кнопку [...].
  4. В диалоговом окне "Список блоков" необходимо выполнить одно из следующих действий:
    • Выберите блок из списка блоков.
    • Нажмите кнопку "Добавить" и задать новый блок для добавления в список.
  5. Нажмите "OK".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Изменение блока, используемого по умолчанию для меток видов листов (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Изменение блока, используемого по умолчанию для меток видов листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Виды листов" выберите правой кнопкой мыши узел подшивки.
  3. В диалоговом окне "Свойства подшивки" выберите "Блок метки для видов". Нажмите кнопку [...].
  4. В диалоговом окне "Выбор блока" задать новый блок, который должен использоваться по умолчанию в качестве блока-метки вида.
  5. Нажмите "OK".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Добавление на лист блока-идентификатора (Процедура)

Создание и изменение листов
На уровень вверх ..
Создание и изменение листов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Добавление на лист блока-идентификатора

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Виды листов" щелкните правой кнопкой мыши на виде, с которым необходимо связать идентификатор. Выберите в контекстном меню "Вставить блок-идентификатор".
  3. Задать точку вставки блока-идентификатора.

    Блок-идентификатор вставляется на лист. Блок-идентификатор автоматически отображает информацию о виде, с которым он связан.

Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание ведомости листов на титульном листе (Процедура)

Создание и изменение листов
На уровень вверх ..
Добавление дополнительных сведений для листов и подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Создание ведомости листов на титульном листе

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" дважды нажмите кнопку мыши на листе, который должен использоваться в качестве титульного.
  3. Щелкните правой кнопкой мыши на узле подшивки. Выберите в контекстном меню "Вставить ведомость листов".
  4. В диалоговом окне "Ведомость листов" введите название таблицы. Произведите необходимые изменения форматирования.
  5. Нажмите "ОК".
  6. Указать точку вставки ведомости.

    Автоматически генерируется ведомость листов, содержащая сведения о всех листах подшивки.

Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание и изменение листов (Краткий справочник)

Организация подшивки
Создание и изменение листов
Добавление дополнительных сведений для листов и подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Создание и изменение листов >
Создание и изменение листов
Понятие Процедура Краткий справочник

Команды

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMPOLLTIME

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Добавление дополнительных сведений для листов и подшивок (Понятие)

Создание и изменение листов
Создание и управление подшивкой
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой >
Добавление дополнительных сведений для листов и подшивок
Понятие Процедура Краткий справочник

В подшивках, группах и листах содержится информация различного типа. Эта информация называется свойствами и включает в себя названия, описания, пути к папкам с файлами, а также иные дополнительные сведения.

Различные свойства для различных уровней (владельцев)

Подшивки, группы и листы представляют собой различные уровни организации и содержат различные типы свойств. Значения этих свойств задаются при создании подшивки, группы или листа.

Кроме того, пользователь может определить дополнительные свойства для листа и подшивки. Значения дополнительных свойств для листов обычно индивидуальны для каждого листа. Например, в качестве дополнительного свойства для листа можно указать имя разработчика. Значения дополнительных свойств для подшивки обычно индивидуальны для каждого проекта. Например, в качестве дополнительного свойства для подшивки можно указать номер контракта.

Нельзя создать дополнительные свойства для групп.

Просмотр и изменение свойств

Просмотреть и изменить свойства можно на вкладке "Список листов", нажав правой кнопкой мыши на имени подшивки, группы или листа В контекстном меню выберите "Свойства". Свойства и их значения, отображаемые в диалоговом окне "Свойства", зависят от выбора пользователя. Для изменения значения нужно нажать на нем кнопку мыши.


Добавление дополнительных сведений для листов и подшивок (Процедура)

Создание и изменение листов
На уровень вверх ..
Добавление дополнительных сведений для листов и подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Добавление дополнительных сведений для листов и подшивок >
Добавление дополнительных сведений для листов и подшивок
Понятие Процедура Краткий справочник

Изменение свойств подшивки, группы листов, листа или категории вида

Создание дополнительного свойства для подшивки

Создание дополнительного свойства листа


Изменение свойств подшивки, группы листов, листа или категории вида (Процедура)

Добавление дополнительных сведений для листов и подшивок
На уровень вверх ..
Добавление дополнительных сведений для листов и подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Добавление дополнительных сведений для листов и подшивок >
Добавление дополнительных сведений для листов и подшивок
Понятие Процедура Краткий справочник

Изменение свойств подшивки, группы листов, листа или категории вида

  1. В Диспетчере подшивок откройте подшивку.
  2. Выполнить одно из следующих действий:
    • На вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки, группы или листа.
    • На вкладке "Список видов" щелкните правой кнопкой мыши на категории вида.
  3. Нажмите "Свойства".
  4. В открывшемся диалоговом окне нажмите кнопку мыши на любом поле и введите изменения.
  5. Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание дополнительного свойства для подшивки (Процедура)

Добавление дополнительных сведений для листов и подшивок
На уровень вверх ..
Добавление дополнительных сведений для листов и подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Добавление дополнительных сведений для листов и подшивок >
Добавление дополнительных сведений для листов и подшивок
Понятие Процедура Краткий справочник

Создание дополнительного свойства для подшивки

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки. Нажмите "Свойства".
  3. В диалоговом окне "Свойства подшивки" нажмите кнопку "Дополнительные свойства".
  4. В диалоговом окне "Дополнительные свойства" необходимо выполнить одно из следующих действий:
    • Нажмите кнопку "Добавить" для создания нового дополнительного свойства для подшивки. В поля имени и значения по умолчанию введите новые данные. Для назначения нового свойства подшивке необходимо убедиться, что в группе "Владелец" установлен флажок "Подшивка".
    • В поля имени и значения по умолчанию введите новые данные.
    • Выберите свойство из списка. Нажмите "Удалить" для удаления свойства.
  5. Нажмите "OK".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Создание дополнительного свойства листа (Процедура)

Добавление дополнительных сведений для листов и подшивок
На уровень вверх ..
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Добавление дополнительных сведений для листов и подшивок >
Добавление дополнительных сведений для листов и подшивок
Понятие Процедура Краткий справочник

Создание дополнительного свойства листа

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки.
  3. В диалоговом окне "Свойства подшивки" нажмите кнопку "Дополнительные свойства".
  4. В диалоговом окне "Дополнительные свойства" необходимо выполнить одно из следующих действий:
    • Нажмите кнопку "Добавить" для создания нового пользовательского свойства для листа. В поля имени и значения по умолчанию введите новые данные. Для назначения нового свойства подшивке необходимо убедиться, что в группе "Владелец" установлен флажок "Подшивка".
    • В поля имени и значения по умолчанию введите новые данные. Таким образом можно изменить значение для каждого листа в подшивке.
    • Выберите свойство из списка. Нажмите "Удалить" для удаления свойства.
  5. Нажмите "OK".
Панель:Стандартный
Ввод команды: ПОДШИВКА


Добавление дополнительных сведений для листов и подшивок (Краткий справочник)

Создание и изменение листов
Добавление дополнительных сведений для листов и подшивок
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Создание и управление подшивкой > Добавление дополнительных сведений для листов и подшивок >
Добавление дополнительных сведений для листов и подшивок
Понятие Процедура Краткий справочник

Команды

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMPOLLTIME

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация, комплектование и архивация подшивок (Понятие)

Добавление дополнительных сведений для листов и подшивок
Работа с листами в подшивке
Коллективная работа с подшивками
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Готовую подшивку можно опубликовать, укомплектовать для пересылки или заархивировать.

  • Публикация подшивки: Функция "Публикация" используется для вывода подшивки на плоттер в прямом или обратном порядке. Дополнительные сведения см. в разделе Публикация подшивки. Имеется возможность создания файлов DWF или DWFx для одного или нескольких листов с использованием подшивки или части подшивки.

    Дополнительные сведения о DWF-файлах см. в разделе Печать в DWF-файлы.

    Дополнительные сведения о DWFx-файлах см. в разделе Печать файлов DWFx

  • Выбор свойств, включаемых в публикуемые файлы DWF или DWFx :Пользователь имеет возможность определить, какая информация будет опубликована в файлах DWF или DWFx. В метаданные, которые можно включить в файл, входят свойства листа и подшивки, свойства и атрибуты блока, свойства и атрибуты динамических блоков и свойства настраиваемых объектов. Метаданные можно включить в файлы DWF или DWFx только при публикации. При печати такая возможность недоступна.
  • Передача подшивок: Архивация и отправка подшивки или части подшивки через Интернет. Дополнительные сведения см. в разделе Формирование комплектов файлов.
  • Архивация подшивок: Архивация подшивки или части подшивки для хранения. Данная команда действует так же, как и команда передачи подшивки, за исключением того, что здесь пользователь должен определить папку для архива, а не посылает полученный пакет. Подробнее см. команду АРХИВАЦИЯ.

Использование параметров листов

Параметры листов предоставляют собой настройки, используемые для публикации и печати. При создании подшивки пользователь задает файл шаблона чертежа (DWT), содержащий один или более наборов параметров листов для всех новых листов. Этот файл DWT называется шаблоном для создания листов.

Другой DWT файл, называемый файлом переопределения параметров листа, содержит параметры, переопределяющие индивидуальные настройки листов подшивки. Файл переопределения параметров листа задается пользователем в диалоговом окне "Свойства подшивки".

При публикации подшивки можно использовать параметры страницы, определенные в каждом файле чертежа, применить для всех файлов переопределения параметров страницы или опубликовать в файл DWF или DWFx. Дополнительную информацию о параметрах страницы см. в разделе Использование наборов параметров листов в подшивках.

ПримечаниеС помощью переопределений параметров листа можно использовать системную переменную PUBLISHCOLLATE для управления с возможностью прерывания печати подшивки в пользу других заданий на печать.

Сохранение набора листов

Пользователь может выбрать часть подшивки для публикации или передачи. На вкладке "Список листов" можно выбрать отдельные листы с использованием стандартных способов выбора в системе Microsoft® Windows®: при выборе используйте клавиши CTRL или SHIFT. Можно указать все листы в группе листов, нажав кнопку мыши на узле группы.

Как правило, операции с одной и той же выборкой листов в подшивке приходится выполнять неоднократно. Для ускорения выбора листов и обеспечения единообразия в Диспетчере подшивок предусмотрена возможность выбора подмножества листов по имени. Именованное подмножество листов подшивки называется набором листов. Для создания наборов листов подшивки и управления ими используется кнопка "Наборы листов", расположенная наверху вкладки "Список листов".


Публикация, комплектование и архивация подшивок (Процедура)

Добавление дополнительных сведений для листов и подшивок
Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Сохранение набора листов подшивки

Восстановление набора листов

Переименование или удаление набора листов

Изменение существующего набора листов

Публикация файла DWF или DWFx с включением сведений о слоях, блоках, подшивках и листах

Публикация файла DWF или DWFx с помощью файла шаблона блока с включением сведений о свойствах и атрибутах блоков


Сохранение набора листов подшивки (Процедура)

Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Сохранение набора листов подшивки

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" выберите листы и группы листов, которые требуется включить в набор листов.

    Для выбора нескольких элементов в списке используются клавиши CTRL или SHIFT.

  3. В Диспетчере подшивок нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Создать".
  4. В диалоговом окне "Новый набор листов" введите имя набора листов. Нажмите "ОК".
Панель:Окно "Диспетчер подшивок"
Ввод команды: ПОДШИВКА


Восстановление набора листов (Процедура)

Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Восстановление набора листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Выберите имя набора листов, который требуется восстановить.

    Выбранный набор листов становится доступным для операций публикации и комплектования.

Панель:Окно "Диспетчер подшивок"
Ввод команды: ПОДШИВКА


Переименование или удаление набора листов (Процедура)

Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Переименование или удаление набора листов

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Управление".
  3. В диалоговом окне "Набор листов" выберите имя набора листов и выполнить одно из следующих действий:
    • Нажмите "Переименовать" для переименования набора листов. Введите новое имя для набора листов.
    • Нажмите "Удалить" для удаления имени набора листов из списка. Нажмите "Да" для подтверждения удаления набора листов.
  4. Нажмите "ОК".
Панель:Окно "Диспетчер подшивок"
Ввод команды: ПОДШИВКА


Изменение существующего набора листов (Процедура)

Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Изменение существующего набора листов

ПримечаниеИзменить набор листов непосредственно невозможно. Вместо этого необходимо активировать набор листов и изменить его, а затем удалить имя набора листов и создать вместо него новый набор листов.
  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Выберите имя набора листов, который требуется изменить.
  3. Для добавления и удаления элементов в наборе листов можно использовать клавишу CTRL.
  4. В Диспетчере подшивок нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Управление".
  5. Нажмите "Удалить" для удаления имени набора листов из списка. Нажмите "Да" для подтверждения удаления набора листов.
  6. Нажмите "OK" для закрытия диалогового окна "Наборы листов".
  7. В Диспетчере подшивок нажмите кнопку "Наборы листов", расположенную в правом верхнем углу. Нажмите "Создать".
  8. В диалоговом окне "Новый набор листов" введите имя набора листов. Нажмите "ОК".
Панель:Окно "Диспетчер подшивок"
Ввод команды: ПОДШИВКА


Публикация файла DWF или DWFx с включением сведений о слоях, блоках, подшивках и листах (Процедура)

Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Публикация файла DWF или DWFx с включением сведений о слоях, блоках, подшивках и листах

  1. В Диспетчере подшивок на вкладке "Список листов" выберите подшивку для публикации в файл DWF или DWFx.
  2. Нажмите кнопку "Публикация". Нажмите "Параметры публикации подшивки".
  3. В диалоговом окне "Параметры публикации подшивки" в поле "Параметры данных DWF" выберите значение включаемого параметра в зависимости от того, что требуется включить в публикуемый файл DWF или DWFx.”
    • Информация о слоях
    • Сведения о подшивке (для включения можно выбрать описание и настраиваемые свойства)
    • Сведения о подшивке (для включения можно выбрать название листа, номер листа, описание, подшивку, группу и настраиваемые свойства листа)
    • Сведения о блоке
      ПримечаниеНекоторые свойства листа всегда публикуются в файле DWF или DWFx (независимо от того, установлен флажок "Параметры публикации подшивки" или нет). Это имя листа, формат листа, автор, создатель, время создания и время изменения.
  4. Нажмите "ОК".
Панель:Окно "Диспетчер подшивок"
Ввод команды: ПОДШИВКА


Публикация файла DWF или DWFx с помощью файла шаблона блока с включением сведений о свойствах и атрибутах блоков (Процедура)

Публикация, комплектование и архивация подшивок
Публикация, комплектование и архивация подшивок
Коллективная работа с подшивками
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Публикация файла DWF или DWFx с помощью файла шаблона блока с включением сведений о свойствах и атрибутах блоков

  1. В Диспетчере подшивок на вкладке "Список листов" выберите подшивку для публикации в файл DWF или DWFx.
  2. Нажмите кнопку "Публикация". Нажмите "Параметры публикации подшивки".
  3. В диалоговом окне "Параметры публикации подшивки" нажмите в разделах "Параметры данных DWF" и "Сведения о блоке" для отображения раскрывающегося списка и выберите "Включить".”
  4. В группах "Параметры данных DWF" и "Файл шаблона блока" выберите требуемый файл шаблона блока или создать новый. Нажмите "ОК".

    Файл шаблона блока, определяющий блоки, их свойства и атрибуты, будет включен в публикуемый файл DWF или DWFx.

Панель:Окно "Диспетчер подшивок"
Ввод команды: ПОДШИВКА


Публикация, комплектование и архивация подшивок (Краткий справочник)

Добавление дополнительных сведений для листов и подшивок
Публикация, комплектование и архивация подшивок
Коллективная работа с подшивками
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Публикация, комплектование и архивация подшивок >
Публикация, комплектование и архивация подшивок
Понятие Процедура Краткий справочник

Команды

АРХИВАЦИЯ

Упаковка файлов текущей подшивки для архивирования

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

PUBLISHCOLLATE

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Коллективная работа с подшивками (Понятие)

Публикация, комплектование и архивация подшивок
Работа с листами в подшивке
Создание и редактирование объектов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке >
Коллективная работа с подшивками
Понятие Процедура Краткий справочник

Коллективная работа с подшивками может осуществляться по локальной сети, через Интернет или по электронной почте. В группу могут также входить пользователи, использующие программное обеспечение без Диспетчера подшивок.

Работа в группе с использованием Диспетчера подшивок

Для совместной работы с подшивками каждый участник проектной группы должен иметь доступ к файлу данных подшивки (DST) и связанным файлам шаблонов чертежей (DWT) по локальной сети. Каждый проектировщик может загрузить в Диспетчер подшивок информацию о подшивке из файла DST.

При внесении в проект кем-либо из членов команды изменений файл DST кратковременно открывается, а информация, хранящаяся в этом файле, обновляется. При открытии файла DST рядом с именем подшивки в левом верхнем углу окна Диспетчера подшивок отображается значок блокировки.

Зеленая точка в значке блокировки указывает, что в сеансе Диспетчера подшивок на данном компьютере временно заблокирован доступ к файлу DST.

Красная точка указывает, что в сеансе Диспетчера подшивок на компьютерах рабочей группы временно заблокирован доступ к файлу DST.

Желтая точка на значке блокировки означает, что лист находится в специальном состоянии, например, для свойств его файла установлен атрибут "Только чтение".

Другие члены группы автоматически могут просматривать изменения в подшивке в области структуры Диспетчере подшивок .

Если доступ к файлам DWT подшивки имеется у всех участников группы, новые файлы чертежей и их листы создаются с помощью одних и тех же файлов шаблонов чертежей. Параметры страницы для этих чертежей также стандартизированы.

ПримечаниеЕсли одни и те же файлы листов, расположенные на разных логических диска локальной сети, запрошены несколькими пользователями, каждый из них получит запрос на сохранение подшивки на логических дисках своих компьютеров. Во избежание излишнего сохранения пользователи должны по возможности подключать одинаковые логические диски.

Другие пользователя также имеют доступ к данным о состоянии для листов в текущей подшивке. Данные о состоянии отображаются в области структуры и указывают на одно из следующих состояний.

Лист доступен для изменения.

Лист заблокирован.

Лист отсутствует или находится в неизвестной папке.

Опрос активных листов других участников коллектива выполняется автоматически; область структуры обновляется в сеансе пользователя Диспетчера подшивок. Если команда активна, в цикле опроса интервал в сеансе пользователя пропускается. Для принудительного обновления состояния листа на вкладке "Список листов" нажмите "Обновить состояние листа".

Для отображения дополнительной информации в области "Подробности" Диспетчера подшивок выберите любой лист.

ПримечаниеВ случае сбоя сетевого соединения или неожиданного завершения работы программы может отображаться ложный значок блокировки. Если есть подозрения на наличие неполадок, выберите лист для отображения дополнительной информации.

Работа в группе без использования Диспетчера подшивок

При определенных ограничениях можно работать с подшивками в группах, в которых не все члены имеют доступ к локальной сети или к Диспетчеру подшивок. Возможно, эти участники команды используют программу AutoCAD LT или более раннюю версию AutoCAD. Это значит, что не все члены группы будут иметь доступ к файлу DST. Однако соответствующая информация из файла DST хранится (кэшируется) в каждом файле чертежа, а информация о подшивке, например настраиваемые свойства, сохраняется при совместном использовании файла чертежа членами группы.

При изменении информации в DST-файле членом группы может понадобиться обновление сведений в нескольких файлах чертежей. Для обновления листа подшивки следует при открытой подшивке открыть и сохранить этот лист.

Обновить все листы в подшивке автоматически можно с помощью команды контекстного меню подшивки "Сохранить все листы". Файлы чертежей, хранящиеся в формате предыдущего файла DWG, сохраняются без изменения формата.

ПримечаниеПри работе в сетевом окружении перед выполнением операции "Сохранить все листы" следует убедиться, что все файлы чертежей в текущей подшивке закрыты.


Сохранение всех листов в подшивке (Процедура)

Публикация, комплектование и архивация подшивок
Коллективная работа с подшивками
Работа со свойствами объектов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Коллективная работа с подшивками >
Коллективная работа с подшивками
Понятие Процедура Краткий справочник

Сохранение всех листов в подшивке

  1. В Диспетчере подшивок откройте подшивку.
  2. На вкладке "Список листов" щелкните правой кнопкой мыши на узле подшивки. Выберите в контекстном меню "Сохранить все листы".

    Все листы подшивки сохраняются. Эта операция приводит к обновлению хранимой в каждом файле чертежа информации, относящейся к подшивке.

Панель:Стандартный
Ввод команды: ПОДШИВКА


Коллективная работа с подшивками (Краткий справочник)

Публикация, комплектование и архивация подшивок
Коллективная работа с подшивками
Коротко о свойствах объектов
Выбор рабочего процесса перед началом работы > Работа с листами в подшивке > Коллективная работа с подшивками >
Коллективная работа с подшивками
Понятие Процедура Краткий справочник

Команды

ПШСОЗДАТЬ

Создание новой подшивки

ПШОТКРЫТЬ

Открытие выбранной подшивки

ПОДШИВКА

Вызов Диспетчера подшивок

ПОДШИВКАОТКЛ

Закрытие Диспетчера подшивок

Системные переменные

SSFOUND

Отображение имени файла и пути, полученных при успешном поиске подшивки

SSLOCATE

Управление местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа

SSMAUTOOPEN

Управление режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой

SSMPOLLTIME

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

SSMSHEETSTATUS

Управление способом обновления данных о состоянии в подшивке

SSMSTATE

Указание на открытое или закрытое состояние окна Диспетчера подшивок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и редактирование объектов

Коллективная работа с подшивками
Свойства объектов
Создание и редактирование объектов

Темы в этом разделе

  • Свойства объектов

    Управление объектами чертежа, их отображением и выводом на печать осуществляется путем изменения свойств объектов: слоя, типа линии, цвета, веса линии и стиля печати.

  • Средства обеспечения точности

    В распоряжении пользователя имеются различные средства, обеспечивающие быстрое и точное построение чертежей без выполнения утомительных расчетов.

  • Построение геометрических объектов

    Все чертежи состоят из объектов. Как правило, построение объектов выполняется путем задания точек либо с помощью устройства указания, либо вводом значений координат в командной строке.

  • Создание и использование блоков (обозначений)

    Блоком называется совокупность связанных объектов чертежа, обрабатываемых как единый объект. Объединение объектов в блоки облегчает повторное использование их как внутри одного чертежа, так и в других чертежах.

  • Методы редактирования

    В данной главе описывается, как выбирать объекты, просматривать и редактировать их свойства, а также выполнять различные действия по редактированию объектов.


Свойства объектов

Создание и редактирование объектов
Создание и редактирование объектов
Работа со свойствами объектов
Создание и редактирование объектов >
Свойства объектов

Управление объектами чертежа, их отображением и выводом на печать осуществляется путем изменения свойств объектов: слоя, типа линии, цвета, веса линии и стиля печати.

Слои подобны лежащим друг на друге прозрачным листам кальки, на которых размещаются различные группы данных чертежа. Любой графический объект чертежа обладает такими свойствами, как цвет, тип и вес линий. Можно назначить объекту либо свойства слоя, на котором он находится, либо специальные свойства. Цвет упрощает распознавание сходных элементов на чертеже, а тип линий - разграничение различных элементов построения. Веса линий отражают размер или тип начертания объекта и используются для повышения наглядности чертежа. Расположение объектов на различных слоях позволяет упростить многие операции по управлению данными чертежа.

Темы в этом разделе

  • Работа со свойствами объектов

    Свойства объектов чертежа можно изменять с помощью палитры свойств или панели быстрых свойств.

  • Работа со слоями

    Слои подобны лежащим друг на друге прозрачным листам кальки, на которых размещаются группы объектов чертежа.

  • Работа с цветом

    Цвет помогает группировать объекты визуально. Пользователь может назначать цвета объектам по слоям или индивидуально.

  • Работа с типами линий

    Типы линий применяются для того, чтобы можно было отличить один объект от другого, тем самым, делая работу с чертежом более удобной.

  • Работа с весами линий

    Пользователь может управлять толщиной линий объектов как при отображении чертежа на экране, так и при выводе его на печать.

  • Управление отображением отдельных объектов

    Пользователь имеет возможность управлять экранным отображением и выводом на печать объектов (включая перекрывающиеся).


Работа со свойствами объектов

Свойства объектов
Свойства объектов
Коротко о свойствах объектов
Создание и редактирование объектов > Свойства объектов >
Работа со свойствами объектов
Понятие Процедура

Свойства объектов чертежа можно изменять с помощью палитры свойств или панели быстрых свойств.

Темы в этом разделе

  • Коротко о свойствах объектов
  • Отображение и редактирование свойств объектов

    Пользователь имеет возможность просматривать и редактировать текущие значения свойств любого объекта чертежа.

  • Копирование свойств объектов

    Для частичного или полного копирования свойств одного объекта в другой или несколько других объектов используется функция "Копирование свойств".


Работа со свойствами объектов (Процедура)

Коллективная работа с подшивками
Работа со свойствами объектов
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов >
Работа со свойствами объектов
Понятие Процедура

Включение и отключение панели быстрых свойств

Изменение параметров панели быстрых свойств

Отображение панели быстрых свойств всегда в полностью развернутом состоянии

Для отключения области описаний на палитре "Свойства"

Для просмотра свойств одного объекта

Для получения информации из базы данных чертежа о нескольких выбранных объектах

Для отображения координат точки

Для изменения свойств объектов в палитре "Свойства"

Для изменения параметра свойства объекта на значения ПоСлою

Для изменения параметра объекта ПоБлоку на значение ПоСлою

Для копирования свойств объекта в другие объекты


Коротко о свойствах объектов (Понятие)

Работа со свойствами объектов
Работа со свойствами объектов
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов >
Коротко о свойствах объектов
Понятие Краткий справочник

Все объекты обладают теми или иными свойствами. Некоторые свойства являются общими для большинства объектов - например, слой, цвет, тип линий и стиль печати. Другие же свойства характерны только для определенных объектов - например, окружность характеризуется радиусом и площадью, а отрезок - длиной и углом наклона.

Общие свойства объекта определяются либо описанием слоя, на котором он создается, либо задаются пользователем.

  • В случае, когда установлено значение ПОСЛОЮ, свойства объекта определяются свойствами слоя, на котором он создается.

    Например, если отрезок создан на слое 0 и этому слою присвоен красный цвет, то при значении цвета ПОСЛОЮ отрезок также будет красным.

  • В случае, когда свойство задается явно, оно обладает преимуществом перед свойством, унаследованным от слоя.

    Например, если отрезку, созданному на слое 0, явно назначен синий цвет, а слою 0 назначен красный цвет, то отрезок будет синим.

См. также

    • Цвета и типы линий объектов в блоках


Коротко о свойствах объектов (Краткий справочник)

Коллективная работа с подшивками
Коротко о свойствах объектов
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Коротко о свойствах объектов >
Коротко о свойствах объектов
Понятие Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

ОКНОСВЗАКР

Закрытие палитры свойств

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Отображение и редактирование свойств объектов (Понятие)

Коротко о свойствах объектов
Работа со свойствами объектов
Копирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Пользователь имеет возможность просматривать и редактировать текущие значения свойств любого объекта чертежа.

Для просмотра и редактирования текущих значений свойств любого объекта чертежа имеются следующие способы:

  • Откройте панель быстрых свойств, просмотрите и при необходимости измените значения выбранных свойств объекта.
  • Откройте палитру свойств; просмотрите и при необходимости внесите изменения в свойства объекта.
  • Просмотрите и внесите необходимые изменения в списке "Слои" панели "Слои", а также при необходимости измените цвет, тип линий, вес линий и стиль печати в списках панели "Свойства".
  • Воспользуйтесь командой СПИСОК для просмотра данных в текстовом окне.
  • Воспользуйтесь командой КООРД для просмотра координат объектов.

Использование панели быстрых свойств

В панели быстрых свойств указаны наиболее часто используемые свойства для каждого типа объектов или набора объектов. Выбрать "быстрые свойства" для любого объекта можно в окне редактора адаптации интерфейса пользователя (АПИ). См. раздел Настройка быстрых свойств Руководства по адаптации.

  • При выборе одного или нескольких объектов одного и того же типа в панели быстрых свойств отображаются выбранные свойства этого типа объектов.
  • При выборе одного или нескольких объектов разных типов в панели быстрых свойств отображаются свойства, общие для всех объектов в наборе, если такие свойства есть.

Панель быстрых свойств отображается при выборе любого объекта, когда для системной переменной QPMODE установлено значение 1. Когда системная переменная QPMODE имеет значение 2, панель быстрых свойств отображается только при условии, что в редакторе адаптации интерфейса пользователя для выбранного объекта определены "быстрые свойства". Варьируя значение системной переменной QPLOCATION, можно отображать панель быстрых свойств в плавающем режиме или в режиме привязки к курсору. Кроме того, управлять параметрами отображения панели быстрых свойств позволяет Диалоговое окно "Режимы рисования".

Воспользуйтесь палитрой свойств

В палитре "Свойства" указаны текущие свойства выбранного объекта или набора объектов. Любое свойство объекта может быть изменено путем задания нового значения.

  • В случае, когда выбраны несколько объектов, палитра "Свойства" отображает только свойства, характерные для всех выбранных объектов.
  • В случае, когда не выбран ни один объект, палитра "Свойства" отображает общие свойства текущего слоя, название таблицы стилей печати, подключенной к слою, а также свойства вида и данные о ПСК.

Если для системной переменной DBLCLKEDIT установлено значение "ВКЛ" (по умолчанию), для большинства объектов можно открывать палитру свойств двойным щелчком на объекте. Исключением являются блоки и атрибуты, штриховка, градиентная заливка, текст, мультилинии и внешние ссылки. При двойном щелчке мышью на любом из этих объектов вместо палитры свойств будет вызвано диалоговое окно для данного объекта.

ПримечаниеДвойной щелчок действует при условии, что системная переменная DBLCLKEDIT имеет значение "ВКЛ", а системная переменная PICKFIRST равна 1 (значение по умолчанию).

Изменение параметров свойства объекта или параметров ПоБлоку на значения ПоСлою

С помощью команды УСТПОСЛОЮ можно изменять указанные свойства выбранных объектов на значения ПоСлою. Значения параметра ПоБлоку для объектов также могут быть изменены на значения ПоСлою. Объекты, для свойств которых не установлен параметр ПоСлою, не отображают переопределения свойств слоев, установленные видовым экраном.

Для задания свойств объекта, изменяемых на значение ПоСлою, служит диалоговое окно "Настройки установки ПоСлою".

Свойства, которые должны быть изменены при использовании команды УСТПОСЛОЮ, хранятся в системной переменной SETBYLAYERMODE .

См. также

    • Цвета и типы линий объектов в блоках

    • Фильтрация наборов объектов

    • Задание параметров интерфейса

    • См. раздел Настройка быстрых свойств Руководства по адаптации


Отображение и редактирование свойств объектов (Процедура)

Работа со свойствами объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Включение и отключение панели быстрых свойств

Изменение параметров панели быстрых свойств

Отображение панели быстрых свойств всегда в полностью развернутом состоянии

Для отключения области описаний на палитре "Свойства"

Для просмотра свойств одного объекта

Для получения информации из базы данных чертежа о нескольких выбранных объектах

Для отображения координат точки

Для изменения свойств объектов в палитре "Свойства"

Для изменения параметра свойства объекта на значения ПоСлою

Для изменения параметра объекта ПоБлоку на значение ПоСлою


Включение и отключение панели быстрых свойств (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Включение и отключение панели быстрых свойств

  • Нажмите кнопку "Быстрые свойства" в строке состояния.

    Чтобы временно скрыть панель быстрых свойств, нажмите ESC.


Изменение параметров панели быстрых свойств (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Изменение параметров панели быстрых свойств

  1. Выберите меню "Сервис" [image] "Режимы рисования". В командной строке введите "режимрис".
  2. В диалоговом окне "Режимы рисования" на вкладке "Быстрые свойства" установите флажок "Быстрые свойства Вкл.".
  3. Выберите режим местоположения панели быстрых свойств.
  4. В разделе "Параметры размеров" установите или снимите флажок "Свернуть автоматически", позволяющий разворачивать или сворачивать панель быстрых свойств. Если флажок установлен, введите в текстовом поле значение высоты.
  5. Нажмите "ОК".
Ввод команды: РЕЖИМРИС


Отображение панели быстрых свойств всегда в полностью развернутом состоянии (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Отображение панели быстрых свойств всегда в полностью развернутом состоянии

  1. На панели быстрых свойств нажмите кнопку "Параметры".
  2. Снимите флажок "Свернуть автоматически".


Для отключения области описаний на палитре "Свойства" (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Для отключения области описаний на палитре "Свойства"

  1. На палитре свойств щелкните правой кнопкой мыши на строке заголовка.
  2. Щелкните в поле "Описание", чтобы снять флажок.


Для просмотра свойств одного объекта (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Для просмотра свойств одного объекта

  1. Выберите объект.
  2. Нажмите правой кнопкой мыши на чертеже. Нажмите кнопку "Свойства".

    В палитре "Свойства" отображаются свойства выбранного объекта.

    Для большинства объектов палитру "Свойства" можно также вызвать двойным щелчком на объекте.

Панель:Стандартная
Ввод команды: ОКНОСВ


Для получения информации из базы данных чертежа о нескольких выбранных объектах (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Для получения информации из базы данных чертежа о нескольких выбранных объектах

  1. Выберите вкладку "Главная" [image] панель "Свойства" [image] "Список". В командной строке введите команду "Список".
  2. Выберите один или несколько объектов и нажмите ENTER.

    Сведения о выбранных объектах выводятся в текстовое окно.

Панель:Сведения
Ввод команды: СПИСОК


Для отображения координат точки (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Для отображения координат точки

  1. Выберите вкладку "Инструменты" [image] панель "Сведения" [image] "Координаты". В командной строке введите команду "Коорд".
  2. Укажите точку, значения координат которой необходимо отобразить.

    Значения координат X, Y и Z выводятся в командной строке.

Панель:Сведения
Ввод команды: КООРД


Для изменения свойств объектов в палитре "Свойства" (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Для изменения свойств объектов в палитре "Свойства"

  1. Выберите один или несколько объектов.
  2. Нажмите правой кнопкой мыши на чертеже. Нажмите кнопку "Свойства".
  3. Для просмотра перечня свойств можно пользоваться полосой прокрутки, которая расположена в палитре "Свойства" рядом со строкой заголовка. Нажатие стрелки справа от каждой категории сворачивает и разворачивает перечень относящихся к ней свойств.
  4. Выберите значение, которое требуется изменить; для его изменения воспользуйтесь одним из следующих способов:
    • Введите новое значение.
    • Нажать на "стрелку вниз" справа от свойства для раскрытия списка и выбрать необходимое значение.
    • Нажать кнопку "Указать" и с помощью курсора изменить значения координат.
    • Нажать кнопку калькулятора БыстрКальк, чтобы вычислить новое значение.
    • Чтобы увеличить или уменьшить значение, нажмите стрелку влево или вправо.
    • Нажмите кнопку [...] и измените значение свойства в диалоговом окне.

    Вносимые изменения тут же отображаются на чертеже.

  5. Чтобы отменить изменение, щелкните правой кнопкой мыши в пустой области в палитре "Свойства". Выберите команду "Отменить".
  6. Для отмены выбора нажмите ESC.
Панель:Стандартная
Ввод команды: ОКНОСВ


Для изменения параметра свойства объекта на значения ПоСлою (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Отображение и редактирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Для изменения параметра свойства объекта на значения ПоСлою

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Установить "ПоСлою". В командной строке введите "устпослою".
  2. Введите н, чтобы указать, какие свойства нужно изменить на ПоСлою или выберите объекты с помощью стандартного способа выбора и нажмите клавишу ENTER.
Ввод команды: УСТПОСЛОЮ


Для изменения параметра объекта ПоБлоку на значение ПоСлою (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Копирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Для изменения параметра объекта ПоБлоку на значение ПоСлою

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Установить "ПоСлою". В командной строке введите "устпослою".
  2. Выберите объекты с помощью стандартного способа выбора и нажмите ENTER.
  3. При отображении запроса введите Y для перехода из режима "ПоБлоку" в режим "ПоСлою".
  4. По запросу укажите, должны ли быть выбраны также и блоки.
Ввод команды: УСТПОСЛОЮ


Отображение и редактирование свойств объектов (Краткий справочник)

Коротко о свойствах объектов
Отображение и редактирование свойств объектов
Копирование свойств объектов
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Отображение и редактирование свойств объектов >
Отображение и редактирование свойств объектов
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

КООРД

Определение координат точек

СПИСОК

Отображение свойств для выбранных объектов

ОКНОСВ

Управление свойствами объектов

ОКНОСВЗАКР

Закрытие палитры свойств

УСТПОСЛОЮ

Изменение переопределения свойств выбранных объектов на ПоСлою

Системные переменные

DBLCLKEDIT

Определение действия по редактированию, выполняемого при двойном нажатии левой кнопки мыши в области рисования

LUPREC

Количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых не превышает значение текущей системной переменной LUPREC

OPMSTATE

Указание на открытое, закрытое или скрытое состояние палитры свойств

PALETTEOPAQUE

Управление прозрачностью окон

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

QPLOCATION

Задание режима местоположения панели быстрых свойств

QPMODE

Задание включенного или отключенного состояния панели быстрых свойств

SETBYLAYERMODE

Управление свойствами, выбираемыми командой УСТПОСЛОЮ

Утилиты

Нет

Ключевые слова для команд

Нет


Копирование свойств объектов (Понятие)

Отображение и редактирование свойств объектов
Работа со свойствами объектов
Работа со слоями
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов >
Копирование свойств объектов
Понятие Процедура Краткий справочник

Для частичного или полного копирования свойств одного объекта в другой или несколько других объектов используется функция "Копирование свойств".

Можно копировать такие свойства, как цвет, слой, тип линий, масштаб типа линий, вес линий, стиль печати, переопределения свойств видового экрана, трехмерную высоту и другие свойства.

По умолчанию все переносимые свойства копируются из первого выбранного объекта в другие объекты. Для того чтобы запретить копирование определенных свойств, можно воспользоваться опцией "Настройки", указав свойства, которые нельзя копировать. Опцию "Настройки" можно применять в любое время выполнения команды копирования свойств.


Для копирования свойств объекта в другие объекты (Процедура)

Отображение и редактирование свойств объектов
На уровень вверх ..
Работа со слоями
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Копирование свойств объектов >
Копирование свойств объектов
Понятие Процедура Краткий справочник

Для копирования свойств объекта в другие объекты

  1. Выберите вкладку "Главная" [image] панель "Свойства" [image] "Копирование свойств". В командной строке введите копироватьсв
  2. Выберите объект, свойства которого необходимо скопировать.
  3. Если необходимо, для задания копируемых свойств введите н (Настройки). В диалоговом окне "Настройки свойств" сбросьте флажки свойств, которые не должны копироваться. По умолчанию все флажки установлены. Нажмите "ОК".
  4. Укажите объекты, к которым будут применены выбранные свойства, и нажмите ENTER.
Панель:Стандартная
Ввод команды: КОПИРОВАТЬСВ


Копирование свойств объектов (Краткий справочник)

Отображение и редактирование свойств объектов
Копирование свойств объектов
Коротко о слоях
Создание и редактирование объектов > Свойства объектов > Работа со свойствами объектов > Копирование свойств объектов >
Копирование свойств объектов
Понятие Процедура Краткий справочник

Команды

КОПИРОВАТЬСВ

Копирование свойств выбранного объекта в другие объекты

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Работа со слоями

Копирование свойств объектов
Свойства объектов
Коротко о слоях
Создание и редактирование объектов > Свойства объектов >
Работа со слоями
Понятие Процедура

Слои подобны лежащим друг на друге прозрачным листам кальки, на которых размещаются группы объектов чертежа.

Темы в этом разделе

  • Коротко о слоях

    Слои позволяют структурировать чертеж, что упрощает управление данными чертежа и различными свойствами, такими как типы линий, цвета и др.

  • Применение слоев для организации чертежей

    С помощью слоев можно управлять свойствами и отображением объектов. Блокируя отдельные слои, можно запрещать редактирование объектов.

  • Создание и именование слоев

    Для каждой связанной группы элементов чертежа (стен, размеров и т.п.) можно создать новый слой, присвоить ему имя и назначить каждому слою определенные свойства.

  • Редактирование параметров и свойств слоев

    Пользователь имеет возможность изменять имя слоя и его свойства, такие как цвет и тип линий. Кроме того, объекты, расположенные на слое, можно перенести на другой слой.

  • Переопределение свойств слоя в видовых экранах

    Можно отображать объекты различным образом путем задания переопределений для таких свойств, как цвет, тип линий, вес линий и стиль печати. Такие переопределения можно применять к отдельным видовым экранам листа.

  • Фильтрация и сортировка слоев в списке

    Диспетчер свойств слоев позволяет задавать условия для ограничения числа отображаемых слоев в списке, а также сортировать слои по именам или свойствам (например, по цвету или по признаку видимости).

  • Уведомления о новых слоях

    Перед выполнением определенных задач, например, печатью, сохранением или восстановлением конфигурации слоя, программа может выводить уведомления о новых слоях, добавленных в чертеж.

  • Работа с конфигурациями слоев

    Параметры слоев можно сохранять в виде именованных конфигураций слоев. Такие конфигурации слоев можно восстанавливать, редактировать и импортировать из других чертежей и файлов, а также экспортировать их для использования в других чертежах.


Работа со слоями (Процедура)

Копирование свойств объектов
Работа со слоями
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Работа со слоями
Понятие Процедура

Для назначения выбранного слоя текущим

Копирование объекта на другой слой

Динамическое отображение слоев

Фильтры списка слоев

Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя"

Включение или выключение активного фильтра слоев

Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя"

Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя"

Перемещение объекта в текущий слой

Удаление слоя методом выбора объекта слоя

Замораживание слоя методом выбора объекта слоя

Размораживание всех слоев

Отображение выбранных слоев и отключение всех остальных слоев

Восстановление параметров слоя при закрытии диалогового окна "Обход слоя"

Восстановление состояний слоя чертежа после изолирования слоя

Изолирование слоя объекта в текущий видовой экран

Включение и отключение слоя с помощью панели "Слои"

Включение всех слоев

Отключение слоя путем выбора объекта слоя

Копирование свойств слоя в другие слои

Объединение выбранных слоев в слое назначения

Для назначения цвета слою

Для изменения свойств нескольких слоев

Скрытие области структуры в окне "Диспетчер свойств слоев"

Для перемещения столбца в окне "Диспетчер свойств слоев"

Скрытие столбца в окне "Диспетчер свойств слоев"

Для изменения порядка столбцов в окне "Диспетчер свойств слоев"

Для восстановления настроек по умолчанию для всех столбцов в "Диспетчере свойств слоев"

Для блокирования и разблокирования слоя с помощью панели инструментов "Слои"

Для создания нового слоя

Для удаления неиспользуемого слоя

Для удаления всех неиспользуемых слоев

Для изменения слоя одного или нескольких объектов

Для назначения слою типа линий, которые будут использоваться по умолчанию

Для переименования слоя

Для переименования более одного слоя

Для отмены изменений параметров слоя

Для включения и отключения режима отслеживания состояний слоев

Для назначения переопределений свойств текущему видовому экрану листа

Процедура удаления переопределения из слоя для текущего видового экрана компоновки

Процедура удаления переопределения из слоя для всех видовых экранов компоновки

Для удаления всех переопределений из слоя для текущего видового экрана листа

Для удаления всех переопределений для всех видовых экранов листа

Для проверки наличия переопределений свойств в текущем видовом экране листа

Для выключения отображения или печати переопределений видового экрана слоя

Для изменения цвета фона в переопределении свойств

Для сохранения переопределений видового экрана в конфигурации слоев

Для быстрой фильтрации отображения слоев по именам

Для фильтрации отображения слоев по свойствам

Для фильтрации отображения имен слоев путем явного выбора

Для вложения фильтра слоев в другой фильтр слоев

Для сортировки списка слоев в "Диспетчере свойств слоев"

Для удаления слоя из группового фильтра слоев

Для включения и отключения уведомлений о новых слоях

Для указания времени отображения уведомлений о новых слоях


Коротко о слоях (Понятие)

Работа со слоями
Работа со слоями
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Коротко о слоях
Понятие Краткий справочник

Слои позволяют структурировать чертеж, что упрощает управление данными чертежа и различными свойствами, такими как типы линий, цвета и др.

Слои напоминают лежащие друг на друге прозрачные листы кальки. Слои являются основным средством упорядочения на чертеже. Они позволяют сгруппировать информацию по функциям и упрощают управление различными свойствами, такими как типы линий, цвета и др.

Слои позволяют группировать однотипные объекты. Например, такие объекты, как вспомогательные линии, тексты, размеры и основные надписи можно разместить на отдельных слоях. Послойная организация объектов позволяет:

  • Показывать видимые и затененные объекты слоя на видовых экранах
  • Разрешать, запрещать и настраивать вывод объектов на печать
  • Назначать цвет одновременно всем объектам слоя
  • Задавать тип и вес линий по умолчанию для всех объектов слоя
  • Разрешать или запрещать редактирование объектов слоя
  • Указывать, должны ли объекты отображаться с различными свойствами слоев в отдельных видовых экранах листа

Каждый чертеж имеет слой с именем 0. Слой 0 не может быть ни удален, ни переименован. Он предназначен для двух целей:

  • Обеспечение того, чтобы каждый чертеж содержал, по крайней мере, один слой
  • Предоставление специального слоя, связанного с управлением цветами в блоках
ПримечаниеВместо того чтобы создавать весь чертеж на слое 0, рекомендуется для организации чертежа создать несколько новых слоев.


Коротко о слоях (Краткий справочник)

Копирование свойств объектов
Коротко о слоях
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Коротко о слоях >
Коротко о слоях
Понятие Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

КЛСЛОЙ

Системные переменные

SHOWLAYERUSAGE

Отображение значков в Диспетчере свойств слоев, чтобы показать, используются ли слои

Утилиты

Нет

Ключевые слова для команд

Нет


Применение слоев для организации чертежей (Понятие)

Коротко о слоях
Работа со слоями
Создание и именование слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

С помощью слоев можно управлять свойствами и отображением объектов. Блокируя отдельные слои, можно запрещать редактирование объектов.

Пользователь имеет возможность управлять сложностью отображения чертежа и ускорять прорисовку путем указания способа отображения или печати объектов. Например, слои позволяют работать со свойствами и отображением однотипных объектов, таких, например, как детали электрических цепей или размеры. Кроме того, выборочное блокирование слоев позволяет предотвратить случайный выбор и редактирование тех или иных объектов.

Управление видимостью объектов на слое

Отключая или замораживая слои чертежа, можно подавлять их отображение. Это позволяет упростить вид для работы с определенным слоем или упростить выводимый на печать чертеж, запретив, например, вывод вспомогательных линий. Выбор способа отключения видимости слоев зависит от характера использования слоев и от сложности чертежа.

  • Вкл/Откл. Объекты на отключенных слоях невидимы, но они по-прежнему скрывают объекты при использовании команды СКРЫТЬ. При включении или отключении слоев чертеж не регенерируется.
  • Замораживание/Размораживание. Объекты на замороженных слоях невидимы и не скрывают другие объекты. Замораживание ненужных слоев в больших чертежах позволяет ускорить операции, связанные с отображением и регенерацией. Размораживание одного или нескольких слоев может привести к регенерации чертежа. Операции замораживания и размораживания слоев отнимает больше времени, чем простое включение и отключение слоев.

На листе можно заморозить слои в отдельных видовых экранах листа.

ПримечаниеВместо выключения или замораживания слоя его можно затенить путем блокирования. См. ниже раздел "Блокирование объектов на слое"

Задание слою цвета и типа линий по умолчанию

Любому слою можно назначить такие свойства, как цвет и тип линий, которые наследуются всеми объектами данного слоя при включении параметра ПоСлою. Например, если на панели свойств в списке "Цвет" указать значение ПОСЛОЮ, цвет новых объектов определяется настройкой цвета слоя в Диспетчер свойств слоев.

Если в управляющем списке "Цвета" задать определенный цвет, то он будет назначаться всем новым объектам вместо цвета, назначенного текущему слою. То же самое можно сказать и об управляющих списках "Типы линий", "Веса линий" и "Стили печати" панели "Свойства".

Значение ПОБЛОКУ можно использовать только при создании блоков. См. раздел Цвета и типы линий объектов в блоках.

Переопределение свойств слоя в видовом экране листа

Некоторые свойства слоя могут быть изменены в листах с помощью переопределения на видовом экране. Переопределение свойств слоя является эффективным способом отображения объектов с различными настройками свойств для цвета, типа линий, веса линий и стиля печати. Переопределения свойств слоя применяются к текущему видовому экрану листа.

Например, если нужно выделить объекты слоя "Электричество" в одном из двух видовых экранов листа, следует установить на слое "Электричество" переопределение свойства "Цвет" для каждого из двух видовых экранов. Эта цель легко достигается путем установки значения красного цвета для одного видового экрана и серого цвета для другого экрана - без изменения свойства глобального цвета, назначенного этому слою. Более подробную информацию см. в разделе Переопределение свойств слоя в видовых экранах.

Блокирование объектов на слое

Блокирование слоя позволяет запретить редактирование всех объектов на слое до тех пор, пока слой не будет разблокирован. Таким образом можно устанавливать защиту чертежа от случайного внесения в него нежелательных изменений. На блокированных слоях по-прежнему имеется возможность использования режимов объектной привязки и выполнения других операций, не связанных с редактированием объектов.

Также можно затенить объекты на заблокированном слое. Это служит двум целям:

  • Пользователь может легко видеть, какие объекты находятся на заблокированном слое.
  • Пользователь имеет возможность управлять сложностью отображения чертежа при сохранении возможности визуальной ориентации относительно этих объектов и функции привязки объектов.

Для управления затенением заблокированных слоев служит системная переменная LAYLOCKFADECTL . Затененные заблокированные слои выводятся на печать в обычном виде.

ПримечаниеДля объектов, расположенных на заблокированных слоях, ручки не отображаются.


Применение слоев для организации чертежей (Процедура)

Работа со слоями
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для назначения выбранного слоя текущим

Копирование объекта на другой слой

Динамическое отображение слоев

Фильтры списка слоев

Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя"

Включение или выключение активного фильтра слоев

Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя"

Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя"

Перемещение объекта в текущий слой

Удаление слоя методом выбора объекта слоя

Замораживание слоя методом выбора объекта слоя

Размораживание всех слоев

Отображение выбранных слоев и отключение всех остальных слоев

Восстановление параметров слоя при закрытии диалогового окна "Обход слоя"

Восстановление состояний слоя чертежа после изолирования слоя

Изолирование слоя объекта в текущий видовой экран

Включение и отключение слоя с помощью панели "Слои"

Включение всех слоев

Отключение слоя путем выбора объекта слоя

Копирование свойств слоя в другие слои

Объединение выбранных слоев в слое назначения

Для назначения цвета слою

Для изменения свойств нескольких слоев

Скрытие области структуры в окне "Диспетчер свойств слоев"

Для перемещения столбца в окне "Диспетчер свойств слоев"

Скрытие столбца в окне "Диспетчер свойств слоев"

Для изменения порядка столбцов в окне "Диспетчер свойств слоев"

Для восстановления настроек по умолчанию для всех столбцов в "Диспетчере свойств слоев"

Для блокирования и разблокирования слоя с помощью панели инструментов "Слои"


Для назначения выбранного слоя текущим (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для назначения выбранного слоя текущим

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Сменить на текущий слой". В командной строке введите слойтек
  2. Выберите объект на слое, который нужно сделать текущим.
Панель:Слои
Ввод команды: СЛОЙТЕК


Копирование объекта на другой слой (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Копирование объекта на другой слой

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Копировать объекты в новый слой". В командной строке введите "копиявслой".
  2. Выберите объекты для копирования.
  3. Нажмите ENTER.
  4. Выберите объект на слое, в который требуется поместить скопированный объект.
  5. Выполните одно из следующих действий:
    • Для размещения объекта на слое назначения укажите базовую точку, затем вторую точку.
    • Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. На запрос второй точки смещения нажмите ENTER.
Панель:Слои-2
Ввод команды: КОПИЯВСЛОЙ


Динамическое отображение слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Динамическое отображение слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Обход слоев". В командной строке введите "слойобх".
  2. Чтобы просмотреть объекты слоя, выберите его в диалоговом окне "Обход слоя". Для просмотра нескольких слоев, выберите их при нажатой клавише CTRL.

    На чертеже отображаются объекты на выбранных слоях.

  3. Нажмите кнопку "Закрыть".
Панель:Слои-2
Ввод команды: СЛОЙОБХ


Фильтры списка слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Фильтры списка слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Обход слоев". В командной строке введите "слойобх".
  2. В списке "Фильтр" диалогового окна "Обход слоя" выполните одно из следующих действий:
    • Введите имя существующего фильтра или выберите фильтр в раскрывающемся списке "Фильтр".
    • Введите критерии фильтра (используя специальные символы) для создания списка требуемых слоев. Например, если требуется показать слои с именами от 0 до 3, введите критерий фильтра [0-3]*.
      ПримечаниеПодробней об использовании специальных символов см. раздел "Специальные символы" в Фильтрация и сортировка слоев в списке.

    Список слоев содержит слои, определенные фильтром.

  3. Нажмите кнопку "Закрыть".
Панель:Слои-2
Ввод команды: СЛОЙОБХ


Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Создание и сохранение фильтра слоев в диалоговом окне "Обход слоя"

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Обход слоев". В командной строке введите "слойобх".
  2. В списке "Фильтр" диалогового окна "Обход слоя" введите (используя специальные символы) критерии фильтра для отображения нужных слоев. Например, если требуется показать слои с именами от 0 до 3, введите критерий фильтра [0-3]*.
    ПримечаниеПодробней об использовании специальных символов см. раздел "Специальные символы" в Фильтрация и сортировка слоев в списке.
  3. Нажмите правую кнопку мыши, затем выберите "Сохранить текущий фильтр".
  4. Нажмите кнопку "Закрыть".
Панель:Слои-2
Ввод команды: СЛОЙОБХ


Включение или выключение активного фильтра слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Включение или выключение активного фильтра слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Обход слоев". В командной строке введите "слойобх".
  2. В списке "Фильтр" диалогового окна "Обход слоя" введите имя существующего фильтра или выберите фильтр в раскрывающемся списке "Фильтр".
  3. Чтобы отобразить или скрыть слои в списке слоев текущего фильтра, установите или снимите флажок "Фильтр". Отображение слоев в чертеже при этом не меняется.
  4. Нажмите кнопку "Закрыть".
Панель:Слои-2
Ввод команды: СЛОЙОБХ


Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Включение или выключение опции "Показывать всегда" в диалоговом окне "Обход слоя"

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Обход слоев". В командной строке введите "слойобх".
  2. В списке "Слои" диалогового окна "Обход слоя" дважды нажмите имя слоя, для которого нужно установить опцию "Показывать всегда". Для выбора нескольких слоев, нажмите SHIFT и дважды нажмите на дополнительных слоях.

    Слева от слоя с включенной опцией "Показывать всегда" отображается символ звездочки (*). Эти слои отображаются в чертеже независимо от условий активного фильтра.

  3. Нажмите кнопку "Закрыть".
Панель:Слои-2
Ввод команды: СЛОЙОБХ


Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Очистка неиспользуемых слоев с помощью диалогового окна "Обход слоя"

  1. Откройте чертеж с одним или несколькими неиспользуемыми слоями, которые требуется очистить.
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Обход слоев". В командной строке введите "слойобх".
  3. В диалоговом окне "Обход слоев" щелкните правой кнопкой мыши. Выберите "Выбрать неиспользуемые".

    Выбираются все неиспользуемые слои.

    ПримечаниеКнопка "Очистить" активна только в том случае, если выбранные слои являются неиспользуемыми.
  4. Нажмите "Очистить".
  5. Нажмите кнопку "Закрыть".
ПримечаниеКроме того, очистку слоев можно выполнить с помощью "Диспетчера свойств слоев". См. раздел "Удаление неиспользуемых слоев"
Ввод команды: СЛОЙОБХ
Панель:Слои-2


Перемещение объекта в текущий слой (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Перемещение объекта в текущий слой

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Сменить на текущий слой". В командной строке введите слойтек.
  2. Выберите объекты, которые нужно переместить в текущий слой.
  3. Нажмите ENTER.
Панель:Слои-2
Ввод команды: СЛОЙТЕК


Удаление слоя методом выбора объекта слоя (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Удаление слоя методом выбора объекта слоя

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Удалить". В командной строке введите "слойудал".
  2. Выберите объект на слое, который требуется удалить.
  3. Нажмите ENTER.

    Все объекты на выбранном слое, а также сам слой, будут удалены.

Ввод команды: СЛОЙУДАЛ


Замораживание слоя методом выбора объекта слоя (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Замораживание слоя методом выбора объекта слоя

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Заморозить". В командной строке введите "слойзмр".
  2. Выберите объекты на слое, который требуется заморозить.
  3. Нажмите ENTER.

    Выбранный слой заморожен.

Панель:Слои-2
Ввод команды: СЛОЙЗМР


Размораживание всех слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Размораживание всех слоев

  • Выберите вкладку "Главная" [image] панель "Слои" [image] "Разморозить все слои". В командной строке введите "слойрмр".

    Все слои (кроме замороженных в видовом экране) размораживаются.

Ввод команды: СЛОЙРМР


Отображение выбранных слоев и отключение всех остальных слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Отображение выбранных слоев и отключение всех остальных слоев

  1. Выберите вкладку "Главная" [image] Панель "Слои" [image] "Изолировать". В командной строке введите "слойотд".
  2. Выберите объект на слое, который требуется изолировать.
  3. Нажмите ENTER.

    Выбранный слой изолируется.

    ПримечаниеДля восстановления исходного состояния слоев (до изолирования) используется команда СЛОЙОТДОТМ. Все измененные параметры слоя сохраняются.
Панель:Слои-2
Ввод команды: СЛОЙОТД


Восстановление параметров слоя при закрытии диалогового окна "Обход слоя" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Восстановление параметров слоя при закрытии диалогового окна "Обход слоя"

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Обход". В командной строке введите "слойобх".
  2. В диалоговом окне "Обход слоя" выберите слой для просмотра его объектов. Для выбора нескольких слоев нажмите слой в списке и протащите курсор по слоям, которые требуется просмотреть.
  3. Выполните одно из следующих действий:
    • Для возврата к первоначальному виду при закрытии диалогового окна установите флажок "Восстановить при выходе".
    • Для отображения только выбранных слоев при возврате к чертежу, снимите флажок "Восстановить при выходе".
  4. Нажмите кнопку "Закрыть".
Панель:Слои-2
Ввод команды: СЛОЙОБХ


Восстановление состояний слоя чертежа после изолирования слоя (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Восстановление состояний слоя чертежа после изолирования слоя

  • После изолирования слоя и (при необходимости) внесения других изменений в параметры слоев выберите вкладку "Главная" [image] панель "Слои" [image] "Отключить изоляцию". в командной строке введите "слойотдотм".

    Чертеж будет восстановлен до конфигурации слоев, сохраненной перед изолированием.

Панель:Слои-2
Ввод команды: СЛОЙОТДОТМ


Изолирование слоя объекта в текущий видовой экран (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Изолирование слоя объекта в текущий видовой экран

  1. Перейдите на вкладку "Лист".
  2. Выберите вкладку "Главная" [image] Панель "Слои" [image] "Изолировать в текущий видовой экран". В командной строке введите "слойовэ".
  3. Выберите объект на слое, который требуется изолировать. Нажмите ENTER.

    Выбранный слой изолируется во всех видовых экранах, кроме текущего.

Ввод команды: СЛОЙОВЭ


Включение и отключение слоя с помощью панели "Слои" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Включение и отключение слоя с помощью панели "Слои"

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" нажмите значок с изображением лампочки у имени того слоя, который требуется включить или отключить.

    Если значок желтый, то слой включен.

Панель:Слои
Ввод команды: СЛОЙ


Включение всех слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Включение всех слоев

  • Выберите вкладку "Главная" [image] панель "Слои" [image] "Включить все слои". В командной строке введите "слойвкл".

    Все слои в чертеже включаются.

Ввод команды: СЛОЙВКЛ


Отключение слоя путем выбора объекта слоя (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Отключение слоя путем выбора объекта слоя

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Откл". В командной строке введите "слойоткл".
  2. Выберите объект на слое, который требуется отключить. Нажмите ENTER.
Панель:Слои-2
Ввод команды: СЛОЙОТКЛ


Копирование свойств слоя в другие слои (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Копирование свойств слоя в другие слои

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Соответствие". В командной строке введите "слойизмнеск".
  2. Выберите объекты на слое, который требуется изменить. Нажмите ENTER.
  3. Выберите объект на слое, на который требуется переместить объект.

    Объект перемещается на выбранный слой.

Панель:Слои-2
Ввод команды: СЛОЙИЗМНЕСК


Объединение выбранных слоев в слое назначения (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Объединение выбранных слоев в слое назначения

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Объединить". В командной строке введите "слойобъед".
  2. Выберите объект на слое, который требуется удалить. Нажмите ENTER.
  3. Выберите объект слоя, на котором требуется объединить все объекты из первого слоя.

    Объекты из первого слоя перемещаются на выбранный слой, а первый слой удаляется.

Ввод команды: СЛОЙОБЪЕД


Для назначения цвета слою (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для назначения цвета слою

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В окне Диспетчера свойств слоев выберите слой. Щелкните значок цвета.
  3. В диалоговом окне "Выбор цвета" выберите цвет.
  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Для изменения свойств нескольких слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для изменения свойств нескольких слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В списке окна "Диспетчер свойств слоев" для выбора нескольких слоев можно воспользоваться одним из следующих способов:
    • Нажмите клавишу CTRL и выберите имена нужных слоев.
    • Нажмите правую кнопку мыши. Выберите "Показать фильтры в списке", чтобы появился флажок, а затем выберите фильтр слоев.
  3. Выберите значки свойств, которые требуется изменить.
  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Скрытие области структуры в окне "Диспетчер свойств слоев" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Скрытие области структуры в окне "Диспетчер свойств слоев"

  • Щелкните правой кнопкой мыши на списке. Снимите флажок "Показать дерево фильтров".


Для перемещения столбца в окне "Диспетчер свойств слоев" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для перемещения столбца в окне "Диспетчер свойств слоев"

  • Нажмите на имени любого столбца и перетащите его в новое место.
  • Нажмите правую кнопку мыши на имени любого столбца и выберите "Адаптация". В диалоговом окне "Адаптация столбцов слоев" выделите столбцы, которые требуется переместить, и нажмите "Вверх" для перемещения столбцов влево в окне "Диспетчер свойств слоев". Для перемещения столбцов вправо в окне "Диспетчер свойств слоев" нажмите "Вниз".
ПримечаниеНастройки столбца принадлежат пространству чертежа, в котором они были заданы. Например, настройки столбца, примененные в пространстве модели, не применяются к "Диспетчеру свойств слоев" при открытии из пространства листа.
Панель:Слои
Ввод команды: СЛОЙ


Скрытие столбца в окне "Диспетчер свойств слоев" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Скрытие столбца в окне "Диспетчер свойств слоев"

Выполните одно из следующих действий:

  • Нажмите правую кнопку мыши на имени любого столбца и выберите в контекстном меню отмеченный флажком столбец.
  • Нажмите правую кнопку мыши на имени любого столбца и выберите "Адаптация". В диалоговом окне "Адаптация столбцов слоев" снимите флажки около столбцов, которые нужно скрыть.

Имена столбцов, у которых в контекстном меню сняты флажки, скрыты. Для отображения столбца нужно нажать правой кнопкой мыши на имени любого столбца и выбрать имя столбца в контекстном меню. Столбец "Имя" скрыть нельзя.

ПримечаниеНастройки столбца принадлежат пространству чертежа, в котором они были заданы. Например, настройки столбца, примененные в пространстве модели, не применяются к "Диспетчеру свойств слоев" при открытии из пространства листа.
Панель:Слои
Ввод команды: СЛОЙ


Для изменения порядка столбцов в окне "Диспетчер свойств слоев" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для изменения порядка столбцов в окне "Диспетчер свойств слоев"

Выполните одно из следующих действий:

  • Нажмите на имени конкретного столбца и перетащите его в нужное место.
  • Нажмите правую кнопку мыши на имени любого столбца и выберите "Адаптация". В диалоговом окне "Адаптация столбцов слоев" установите флажки около тех столбцов, которые нужно переместить, и нажмите "Вверх" или "Вниз".
Панель:Слои
Ввод команды: СЛОЙ


Для восстановления настроек по умолчанию для всех столбцов в "Диспетчере свойств слоев" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Применение слоев для организации чертежей
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для восстановления настроек по умолчанию для всех столбцов в "Диспетчере свойств слоев"

  • Нажмите правую кнопку мыши на имени любого столбца и выберите в контекстном меню "Восстановление параметров по умолчанию для всех столбцов".

Исходные значения ширины столбцов, их положение и состояние отображения будут восстановлены.

ПримечаниеНастройки столбца принадлежат пространству чертежа, в котором они были заданы. Например, настройки столбца, примененные в пространстве модели, не применяются к "Диспетчеру свойств слоев" при открытии из пространства листа.
Панель:Слои
Ввод команды: СЛОЙ


Для блокирования и разблокирования слоя с помощью панели инструментов "Слои" (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Создание и именование слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Для блокирования и разблокирования слоя с помощью панели инструментов "Слои"

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" нажмите значок с изображением замка у имени того слоя, который требуется заблокировать или разблокировать.

    Если замок изображен открытым, слой разблокирован.

  3. Если необходимо, задайте степень слияния с фоном для всех заблокированных слоев с помощью системной переменной LAYLOCKFADECTL.
Панель:Слои
Ввод команды: СЛОЙ, LAYLOCKFADECTL


Применение слоев для организации чертежей (Краткий справочник)

Коротко о слоях
Применение слоев для организации чертежей
Создание и именование слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Применение слоев для организации чертежей >
Применение слоев для организации чертежей
Понятие Процедура Краткий справочник

Команды

КЛСЛОЙ
КОПИЯВСЛОЙ

Копирование одного или нескольких объектов в другой слой

СЛОЙТЕК

Назначение слоя выбранных объектов текущим

СЛОЙУДАЛ

Удаление всех объектов на слое и очистка слоя

СЛОЙ

Управление слоями и их свойствами

СЛОЙЗМР

Замораживание слоя выбранных объектов

СЛОЙОТД

Скрытие или блокировка всех слоев, отличных от слоев с выбранными объектами

СЛОЙИЗМНЕСК

Изменение слоя выбранного объекта в соответствии со слоем назначения

СЛОЙОБЪЕД

Объединение выбранных слоев в целевой слой и удаление предыдущих слоев из чертежа

СЛОЙОТКЛ

Отключение слоя выбранного объекта

СЛОЙВКЛ

Включение всех слоев в чертеже

СЛОЙРМР

Размораживание всех слоев в чертеже

СЛОЙОТДОТМ

Восстановление всех слоев, скрытых или заблокированных с помощью команды СЛОЙОТД

СЛОЙОБХ

Отображение объектов на выбранных слоях и скрытие объектов на всех других слоях

Системные переменные

LAYLOCKFADECTL

Управление затенением объектов на заблокированных слоях

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание и именование слоев (Понятие)

Применение слоев для организации чертежей
Работа со слоями
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Создание и именование слоев
Понятие Процедура Краткий справочник

Для каждой связанной группы элементов чертежа (стен, размеров и т.п.) можно создать новый слой, присвоить ему имя и назначить каждому слою определенные свойства.

Организация объектов в слои позволяет управлять отображением и свойствами большого количества объектов отдельно для каждого слоя и быстро вносить изменения.

ПримечаниеЧисло слоев, которое можно создать в чертеже, и количество объектов, которое можно создать на каждом из слоев, практически неограниченно.

Правила выбора имен слоев

Имя слоя может содержать до 255 символов (двухбайтовых или буквенно-цифровых): букв, цифр, пробелов и нескольких специальных символов. Имена слоев не могут содержать следующие символы:

< > / \ “ : ; ? * | = ‘

Во многих случаях имена слоев задаются согласно определенным соглашениям, принятым в организации, отрасли или у заказчика.

В списке "Диспетчера свойств слоев" имена слоев сортируются в алфавитном порядке. При организации пользователем собственной схемы слоев следует выбирать имена слоев внимательно. Используйте общие префиксы в именах слоев для связанных компонентов чертежа. Для быстрого поиска таких слоев можно использовать символы шаблона в фильтрах имен слоев.

ПримечаниеЕсли в различных чертежах приходится часто применять один и тот же набор слоев с определенными параметрами (цветами, типами, толщиной линий, стилями печати), то этот набор слоев целесообразно сохранить в шаблоне. Дополнительную информацию о создании шаблонов см. в разделе Использование файла шаблона для создания чертежа.

Копирование слоев из других чертежей

Центр управления™ позволяет копировать слои из чертежа в чертеж путем перетаскивания. Пусть, например, имеется базовый чертеж, в котором уже созданы все необходимые для проекта слои. Пользователь может создать новый чертеж и с помощью Центра управления перетащить в новый чертеж все описания слоев из базового. Это экономит время и гарантирует соблюдение установленной системы слоев во всем проекте.

Перетаскивать слои или копировать слои можно также двойным нажатием мыши или путем выбора команды "Вставить" в контекстном меню.

ПримечаниеПри перетаскивании слоев из Центра управления AutoCAD необходимо разрешать конфликты, связанные с повторяющимися именами.

Выбор слоя для рисования

В процессе рисования вновь создаваемые объекты располагаются на текущем слое. Текущим может быть слой 0 или любой другой слой, созданный и именованный пользователем. Пользователь может переключаться с одного слоя на другой, меняя тем самым текущий слой; все создаваемые далее объекты размещаются на новом текущем слое и используют его цвет, тип линий и другие свойства. Замороженные слои и слои, описанные во внешних ссылках, нельзя сделать текущими.

Удаление слоев

Неиспользуемые слои можно удалять командой ОЧИСТИТЬ или удалением их имен из списка в "Диспетчере свойств слоев". Можно удалять только неиспользуемые слои. Невозможно удалить слои 0 и DEFPOINTS, слои с объектами (включая объекты в определениях блоков), текущий слой, а также слои, зависимые от внешних ссылок.

ПредупреждениеСледует с особой осторожностью удалять слои, совместно используемые несколькими пользователями, или применяемые в качестве стандартных.


Создание и именование слоев (Процедура)

Применение слоев для организации чертежей
На уровень вверх ..
Создание и именование слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Создание и именование слоев >
Создание и именование слоев
Понятие Процедура Краткий справочник

Для создания нового слоя

Для удаления неиспользуемого слоя

Для удаления всех неиспользуемых слоев


Для создания нового слоя (Процедура)

Создание и именование слоев
На уровень вверх ..
Создание и именование слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Создание и именование слоев >
Создание и именование слоев
Понятие Процедура Краткий справочник

Для создания нового слоя

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Свойства слоя". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Создать слой".

    В список слоев автоматически добавляется слой, например, СЛОЙ1.

  3. Введите новое имя вместо предложенного по умолчанию.
  4. Для изменения свойств слоя щелкните мышью на нужном значке.

    Нажатие значков "Цвет", "Тип линий", "Вес линий" или "Стиль печати" приводит к вызову соответствующего диалогового окна.

  5. (Если требуется) Выберите столбец "Описание" и введите текст.
  6. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Свойства слоя
Ввод команды: СЛОЙ


Для удаления неиспользуемого слоя (Процедура)

Создание и именование слоев
На уровень вверх ..
Создание и именование слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Создание и именование слоев >
Создание и именование слоев
Понятие Процедура Краткий справочник

Для удаления неиспользуемого слоя

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В окне Диспетчера свойств слоев выберите слой. Нажмите кнопку "Удалить слой".

    Слой, на котором размещаются объекты, удалить нельзя. Необходимо сначала перенести объекты на другой слой или стереть их. Слои 0 и DEFPOINTS, а также текущий слой, удалить нельзя.

  3. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.

    Выбранный слой удаляется.

Панель:Слои
Ввод команды: СЛОЙ


Для удаления всех неиспользуемых слоев (Процедура)

Создание и именование слоев
На уровень вверх ..
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Создание и именование слоев >
Создание и именование слоев
Понятие Процедура Краткий справочник

Для удаления всех неиспользуемых слоев

  1. Выберите вкладку "Инструменты" [image] панель "Утилиты" [image] "Очистить". В командной строке введите "очистить".

    Открывается диалоговое окно "Очистка чертежа", отображающее дерево объектов, которые можно удалить из чертежа.

  2. Для удаления неиспользуемых слоев можно воспользоваться одним из следующих способов:
    • Для очистки чертежа от всех неиспользуемых слоев выберите "Слои".
    • Для очистки чертежа от определенных слоев дважды щелкните на элементе "Слои" для раскрытия следующего уровня. Выберите слои для удаления из списка.
  3. Если нужные элементы отсутствуют в списке, включите опцию "Просмотреть элементы, которые нельзя удалить", выберите слой и прочитайте объяснение.
  4. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  5. Нажать "Удалить".
  6. В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.
  7. Нажмите кнопку "Закрыть".
Ввод команды: ОЧИСТИТЬ


Создание и именование слоев (Краткий справочник)

Применение слоев для организации чертежей
Создание и именование слоев
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Создание и именование слоев >
Создание и именование слоев
Понятие Процедура Краткий справочник

Команды

КЛСЛОЙ
СЛОЙ

Управление слоями и их свойствами

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

Системные переменные

CLAYER

Установка имени текущего слоя

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование параметров и свойств слоев (Понятие)

Создание и именование слоев
Работа со слоями
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Пользователь имеет возможность изменять имя слоя и его свойства, такие как цвет и тип линий. Кроме того, объекты, расположенные на слое, можно перенести на другой слой.

Поскольку все элементы чертежа связаны со слоями, при планировании и создании чертежа, возможно, потребуется изменить состав элементов, размещаемых на слоях или способ просмотра комбинации слоев. Пользователь может:

  • Переносить объекты с одного слоя на другой.
  • Изменять имя слоя.
  • Изменять принятые по умолчанию цвет, тип линий и другие свойства слоя.

Возможность переноса объектов может оказаться полезной в случае создания объекта не на том слое или при необходимости перераспределения объектов между слоями. Если свойства объекта не заданы явно, то после переноса он получает свойства того слоя, на котором он теперь расположен.

Свойства слоя можно изменять в "Диспетчере свойств слоев" или в управляющем списке "Слои" на панели "Слои". Для этого следует выбрать соответствующий значок. Для редактирования имен и цветов слоев использовать управляющий список "Слои" нельзя. Эти операции выполняются только в "Диспетчере свойств слоев".

Отмена изменений параметров слоя

Изменения параметров слоя можно отменить командой возврата к предыдущему состоянию слоев (СЛОЙП). Например, с ее помощью после замораживания слоев и редактирования каких-то геометрических объектов чертежа можно достаточно просто разморозить слои, не затрагивая изменений геометрии. Команда также полезна, если изменено множество свойств слоев (цвета, типы линий и др.), но затем принято решение о возврате к исходным параметрам.

Команда возврата к предыдущему состоянию слоев позволяет отменить самые последние изменения, внесенные в параметры и свойства слоев с помощью управляющего списка "Слои" или "Диспетчера свойств слоев". Это возможно благодаря постоянному отслеживанию каждого вносимого в параметры слоя изменения. Когда отслеживать изменения не нужно, - например, при работе со сценариями большого размера, - отслеживание можно отключить с помощью команды СЛОЙПРЕЖИМ. Отключение отслеживания несколько увеличивает производительность.

Команда возврата к предыдущему состоянию слоев не может отменять следующие действия:

  • Переименование слоев. После переименования слоя и изменения его свойств команда "Предыдущее состояние слоев" восстанавливает исходные свойства, но не имя слоя.
  • Удаление слоев. После удаления или очистки слоя он не восстанавливается с помощью команды "Предыдущее состояние слоев".
  • Создание слоев. После создания нового слоя он не удаляется с помощью команды "Предыдущее состояние слоев".

Изменения, сделанные в Диспетчере свойств слоев, можно группировать. Для этого нужно установить флажок "Объединить изменение свойств слоя" на вкладке "Пользовательские" диалогового окна "Настройка".. Создание и удаление слоя фиксируются как отдельные действия в списке команды "Отменить".


Редактирование параметров и свойств слоев (Процедура)

Создание и именование слоев
На уровень вверх ..
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Для изменения слоя одного или нескольких объектов

Для назначения слою типа линий, которые будут использоваться по умолчанию

Для переименования слоя

Для переименования более одного слоя

Для отмены изменений параметров слоя

Для включения и отключения режима отслеживания состояний слоев


Для изменения слоя одного или нескольких объектов (Процедура)

Редактирование параметров и свойств слоев
На уровень вверх ..
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Для изменения слоя одного или нескольких объектов

  1. Выберите объекты, которые необходимо перенести на другой слой.
  2. На панели "Слои" щелкнуть на управляющем списке "Слой".
  3. Выберите слой, на который требуется перенести объекты.
  4. Нажмите ESC для отмены выделения.
Панель:Слои


Для назначения слою типа линий, которые будут использоваться по умолчанию (Процедура)

Редактирование параметров и свойств слоев
На уровень вверх ..
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Для назначения слою типа линий, которые будут использоваться по умолчанию

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В окне "Диспетчер свойств слоев" выберите заменяемый тип линий для слоя.
  3. Если необходимого типа линий нет в диалоговом окне "Выбор типа линий", нажмите кнопку "Загрузить" и используйте один из следующих способов:
    • В диалоговом окне "Загрузка или перезагрузка типов линий" выберите один или несколько типов линий для загрузки. Нажмите "OK" для возврата в диалоговое окно "Выбрать тип линий".
    • В диалоговом окне "Загрузка/перезагрузка типов линий" нажмите кнопку "Файл" для открытия дополнительных файлов определения типов линий (LIN). Выберите один или несколько типов линий для загрузки. Нажмите "OK" для возврата в диалоговое окно "Выбрать тип линий".
  4. Выберите необходимый тип линии. Нажмите кнопку "ОК" для возврата в "Диспетчер свойств слоев".
  5. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Для переименования слоя (Процедура)

Редактирование параметров и свойств слоев
На уровень вверх ..
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Для переименования слоя

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В окне Диспетчера свойств слоев выберите слой. Щелкните имя или нажмите клавишу F2.
  3. Введите новое имя.
  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Для переименования более одного слоя (Процедура)

Редактирование параметров и свойств слоев
На уровень вверх ..
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Для переименования более одного слоя

  1. Выберите вкладку "Инструменты" [image] панель "Утилиты" [image] "Переименовать". В командной строке введитеновоеимя.
  2. В диалоговом окне "Задание нового имени" в списке именованных объектов выберите "Слои".
  3. В поле "Старое имя" введите старое имя, используя специальные символы; например, введите stairs$*.
  4. В поле "Новое имя" введите новое имя, используя специальные символы; например, введите s_*.

    В этом примере будут следующие результаты: слои STAIR$LEVEL-1, STAIR$LEVEL-2, STAIR$LEVEL-3 будут переименованы в S_LEVEL-1, S_LEVEL-2, S_LEVEL-3.

  5. Нажмите кнопку "Новое имя" для применения изменений и продолжения операции для других слоев, или нажмите "ОК".
Ввод команды: НОВОЕИМЯ


Для отмены изменений параметров слоя (Процедура)

Редактирование параметров и свойств слоев
На уровень вверх ..
Редактирование параметров и свойств слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Для отмены изменений параметров слоя

  • Выберите вкладку "Главная" [image] панель "Слои" [image] "Предыдущий". В командной строке введите слойп.

В командной строке появляется сообщение "Восстановлено предыдущее состояние слоя".

ПримечаниеКоманда СЛОЙП не восстанавливает удаленные или очищенные слои и не удаляет добавленные в чертеж слои. После переименования слоя и изменения его свойств команда СЛОЙП восстанавливает исходные свойства, но не имя слоя.
Панель:Слои
Ввод команды: СЛОЙП


Для включения и отключения режима отслеживания состояний слоев (Процедура)

Редактирование параметров и свойств слоев
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Для включения и отключения режима отслеживания состояний слоев

  1. В командной строке введите слойпрежим.

    Выводится текущее состояние режима отслеживания.

  2. Введите вкл для включения режима слежения за состоянием слоев или откл для его отключения.
Ввод команды: СЛОЙПРЕЖИМ


Редактирование параметров и свойств слоев (Краткий справочник)

Создание и именование слоев
Редактирование параметров и свойств слоев
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Редактирование параметров и свойств слоев >
Редактирование параметров и свойств слоев
Понятие Процедура Краткий справочник

Команды

ИЗМЕНИТЬ

Управление свойствами объектов

СВОЙСТВА

Изменение свойств объекта

КЛСЛОЙ
СЛОЙ

Управление слоями и их свойствами

СЛОЙП

Отмена последних изменений состояний и свойств слоев

СЛОЙПРЕЖИМ

Включение и отключение режима записи последовательности изменений свойств слоев

ОКНОСВ

Управление свойствами объектов

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

НОВОЕИМЯ

Изменение имен именованных объектов

УСТПОСЛОЮ

Изменение переопределения свойств выбранных объектов на ПоСлою

Системные переменные

CLAYER

Установка имени текущего слоя

LAYERMANAGERSTATE

Возвращение текущего состояния Диспетчера свойств слоев

SETBYLAYERMODE

Управление свойствами, выбираемыми командой УСТПОСЛОЮ

Утилиты

Нет

Ключевые слова для команд

Нет


Переопределение свойств слоя в видовых экранах (Понятие)

Редактирование параметров и свойств слоев
Работа со слоями
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Можно отображать объекты различным образом путем задания переопределений для таких свойств, как цвет, тип линий, вес линий и стиль печати. Такие переопределения можно применять к отдельным видовым экранам листа.

Переопределение свойств — эффективный способ отображения объектов с разными значениями свойств в разных видовых экранах без изменения свойств, которым присвоены значения "ПоСлою" или "ПоБлоку". Например, можно выделить объекты, изменив их цвет. Поскольку при переопределении свойств слоя его глобальные свойства не изменяются, то можно получить различные отображения объектов в разных видовых экранах без необходимости создания дублирующей геометрии или использования внешних ссылок с другими параметрами слоя.

Для изображенного слева видового экрана слоя "Проводка" были заданы параметры переопределения свойств цвета и веса линий. Обратите внимание на то, что цвет и вес линий проводки отличаются от показанных на правом видовом экране.

Если обращение к диспетчеру свойств слоев выполняется с вкладки компоновки, отображаются четыре столбца для переопределений свойств слоев.

  • Цвет ВЭ
  • Вес линий ВЭ
  • Тип линий ВЭ
  • Стиль печати ВЭ (отображается только в чертежах с именованными стилями печати)

Когда для слоя установлено переопределение свойства, в "Диспетчере свойств слоев" автоматически создается фильтр "Переопределения видового экрана".

Если переопределения свойств не требуется отображать или выводить на печать, установите для системной переменной VPLAYEROVERRIDESMODE значение 0. Объекты будут отображаться и выводиться на печать с использованием глобальных свойств слоя.

ПримечаниеПереопределения свойств могут быть заданы, даже если для переменной VPLAYEROVERRIDESMODE установлено значение 0.

Когда для системной переменной VISRETAIN установлено значение 0, переопределения свойств на слоях внешних ссылок не сохраняются.

Переопределения свойств видовых экранов и визуальные стили

Переопределения свойств слоя для цвета, типа линий и веса линий отображаются в видовых экранах независимо от того, какой визуальный стиль является текущим. Хотя переопределения стиля печати могут устанавливаться для визуальных стилей "Концептуальный" или "Реалистичный", однако такие переопределения не отображаются и не выводятся на печать.

Обозначение слоев, имеющих переопределения свойств

Слои, имеющие переопределения свойств, определяются в "Диспетчере свойств слоев" при открытии его с вкладки "Лист". Посмотреть, какие слои имеют переопределения, можно следующим образом:

  • Каждое имя слоя, переопределение и соответствующий параметр глобального свойства обозначено фоновым цветом.
  • При наведении курсора на значок состояния слоя, содержащего переопределения, отображается всплывающая подсказка со сведениями о переопределении свойства.
  • Еще один значок отображается в столбце "Состояние".
  • В области структуры, где перечислены все слои, содержащие переопределения видовых экранов, отображается предварительно определенный фильтр "Переопределения видового экрана".

Слои, которым назначены переопределения свойств, обозначены также вне "Диспетчера свойств слоев". Определить,, каким слоям назначены переопределения свойств, можно также в следующих зонах пользовательского интерфейса:

  • панель "Слои" Имена слоев текущего видового экрана выделены фоновым цветом. Для переопределений цвета вместо глобального цвета отображается цвет переопределения.
  • панель "Свойства" Отображается значение ПоСлою (ВЭ) и фоновый цвет для слоев или объектов, которым назначены переопределения свойств. Вместо глобальных свойств цвета, типа линий и веса линий отображаются цвета свойства переопределения.
  • Панель "Слои" на ленте. В ниспадающем списке "Слой" после имен слоев отображается цвет фона. Вместо глобальных свойств цвета, типа линий и веса линий отображаются цвета свойства переопределения.
  • Панель "Свойства" на ленте. Элементы управления цветом, типом линий, весом линий и стилем печати выделены фоновым цветом. Вместо глобальных свойств цвета, типа линий и веса линий отображаются цвета свойства переопределения.
  • Палитра "Свойства". Отображается значение ПоСлою (ВЭ) и фоновый цвет для слоев или объектов, которым назначены переопределения свойств. Вместо глобальных свойств цвета, типа линий и веса линий отображаются цвета свойства переопределения.
ПримечаниеФоновый цвет для переопределений видовых экранов можно изменить в диалоговом окне Параметры слоя.

Переопределения свойств, заданные на слое "Освещение" для текущего видового экрана обозначены синим цветом фона.

Обозначение видовых экранов, имеющих переопределения свойств

Когда текущий видовой экран в пространстве листа содержит переопределения свойств слоя, в строке состояния отображается значок "Переопределения видового экрана". Если строка состояния чертежа не отображается, то этот значок отображается в строке состояния приложения.

Для проверки наличия переопределений свойств слоев в текущем видовом экране используется системная переменная VPLAYEROVERRIDES . Если системная переменная VPLAYEROVERRIDES имеет значение 1, то этот видовой экран содержит переопределения.

Кроме того, для проверки наличия переопределений в видовом экране можно воспользоваться командой "Свойства". В палитре "Свойства" отображается поле "Переопределения свойств слоев". Отображаемое здесь значение совпадает со значением системной переменной VPLAYEROVERRIDES.

Удаление переопределений свойств слоев

Если в диспетчере свойств слоев щелкнуть на слое правой кнопкой мыши, отображается контекстное меню со списком команд для удаления переопределений свойств. Удалить можно:

  • Отдельное переопределение свойства в выбранном слое для одного или всех выбранных видовых экранов.
  • Все переопределения свойств в выбранном слое для одного или всех выбранных видовых экранов.
  • Все переопределения свойств во всех слоях в выбранном видовом экране или во всех выбранных видовых экранах.
ПримечаниеДругой способ удаления переопределений свойств - воспользоваться контекстным меню, которое отображается при нажатии правой кнопки мыши на рамке выбранного видового экрана или видовых экранов. Пользователь может удалить переопределения видового экрана во всех слоях этого видового экрана.


Переопределение свойств слоя в видовых экранах (Процедура)

Редактирование параметров и свойств слоев
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для назначения переопределений свойств текущему видовому экрану листа

Процедура удаления переопределения из слоя для текущего видового экрана компоновки

Процедура удаления переопределения из слоя для всех видовых экранов компоновки

Для удаления всех переопределений из слоя для текущего видового экрана листа

Для удаления всех переопределений для всех видовых экранов листа

Для проверки наличия переопределений свойств в текущем видовом экране листа

Для выключения отображения или печати переопределений видового экрана слоя

Для изменения цвета фона в переопределении свойств

Для сохранения переопределений видового экрана в конфигурации слоев


Для назначения переопределений свойств текущему видовому экрану листа (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для назначения переопределений свойств текущему видовому экрану листа

  1. На вкладке "Лист" дважды нажмите в пределах видового экрана, чтобы сделать его текущим.
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  3. В "Диспетчере свойств слоев", в столбцах "Цвет ВЭ", "Тип линии ВЭ", "Вес линии ВЭ" и "Стиль печати ВЭ", выберите глобальные свойства, которые требуется переопределить.
  4. Нажмите кнопку "Применить".
Панель:Слои
Ввод команды: СЛОЙ


Процедура удаления переопределения из слоя для текущего видового экрана компоновки (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Процедура удаления переопределения из слоя для текущего видового экрана компоновки

  1. На вкладке "Лист" дважды нажмите в пределах видового экрана, чтобы сделать его текущим.
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  3. В диспетчере свойств слоев щелкните правой кнопкой мыши на переопределении свойства в слое, которое требуется удалить.
  4. Выберите "Удаление переопределений видового экрана" [image] "Переопределение свойства (цвет, тип линии, вес линии, стиль печати)" [image] "Только на текущем видовом экране".
  5. Нажмите кнопку "Применить".
Панель:Слои
Ввод команды: СЛОЙ


Процедура удаления переопределения из слоя для всех видовых экранов компоновки (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Процедура удаления переопределения из слоя для всех видовых экранов компоновки

  1. На вкладке "Лист" дважды нажмите в пределах видового экрана, чтобы сделать его текущим.
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  3. В диспетчере свойств слоев щелкните правой кнопкой мыши на переопределении свойства в слое, которое требуется удалить.
  4. Выберите "Удаление переопределений видового экрана" [image] "Переопределение свойства (цвет, тип линии, вес линии, стиль печати)" [image] "На всех видовых экранах".
  5. Нажмите кнопку "Применить".
Панель:Слои
Ввод команды: СЛОЙ


Для удаления всех переопределений из слоя для текущего видового экрана листа (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для удаления всех переопределений из слоя для текущего видового экрана листа

  1. На вкладке "Лист" дважды нажмите в пределах видового экрана, чтобы сделать его текущим.
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  3. В окне "Диспетчер свойств слоев" выберите конкретный слой и нажмите правой кнопкой мыши.
  4. Выберите "Удаление переопределений видового экрана" [image] "Выбранные слои" [image] "Только на текущем видовом экране".
  5. Нажмите кнопку "Применить".
Панель:Слои
Ввод команды: СЛОЙ


Для удаления всех переопределений для всех видовых экранов листа (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для удаления всех переопределений для всех видовых экранов листа

  1. Перейдите на вкладку "Лист".
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  3. В "Диспетчере свойств слоев" выберите фильтр "Переопределения видового экрана".
  4. Щелкните на любом слое правой кнопкой мыши. Выберите "Удаление переопределений видового экрана" [image] "Все слои" [image] "На всех видовых экранах".
  5. Нажмите кнопку "Применить".
Панель:Слои
Ввод команды: СЛОЙ


Для проверки наличия переопределений свойств в текущем видовом экране листа (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для проверки наличия переопределений свойств в текущем видовом экране листа

  1. Дважды нажмите в пределах видового экрана или нажмите на его рамку, чтобы сделать видовой экран текущим.
  2. В командной строке введите vplayeroverrides.

Если для VPLAYEROVERRIDES отображается значение 1, то выбранный видовой экран содержит переопределения. Значение 0 свидетельствует о том, что переопределения не обнаружены.

Ввод команды: VPLAYEROVERRIDES


Для выключения отображения или печати переопределений видового экрана слоя (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для выключения отображения или печати переопределений видового экрана слоя

  1. В командной строке введите "vplayeroverrides".
  2. Введите 0.
Ввод команды: VPLAYEROVERRIDESMODE


Для изменения цвета фона в переопределении свойств (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Переопределение свойств слоя в видовых экранах
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для изменения цвета фона в переопределении свойств

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" выберите "Параметры".
  3. В диалоговом окне "Параметры слоя" выберите цвет фона для переопределений видового экрана.
  4. Нажмите ОК.
  5. Нажмите "ОК" для выхода из "Диспетчера свойств слоев".
Панель:Слои
Ввод команды: СЛОЙ


Для сохранения переопределений видового экрана в конфигурации слоев (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Для сохранения переопределений видового экрана в конфигурации слоев

  1. На вкладке "Лист" дважды нажмите в пределах видового экрана, чтобы сделать его активным.
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  3. В "Диспетчере конфигураций слоев" нажмите кнопку "Создать".
  4. В диалоговом окне "Сохранение новой конфигурации слоев" введите имя новой конфигурации слоев или выберите имя из списка. (Не обязательно) Добавьте текстовое описание.
  5. Нажмите кнопку "Закрыть".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера конфигураций слоев.
Панель:Слои
Ввод команды: СЛОЙСОСТ


Переопределение свойств слоя в видовых экранах (Краткий справочник)

Редактирование параметров и свойств слоев
Переопределение свойств слоя в видовых экранах
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Переопределение свойств слоя в видовых экранах >
Переопределение свойств слоя в видовых экранах
Понятие Процедура Краткий справочник

Команды

СВОЙСТВА

Изменение свойств объекта

КЛСЛОЙ
СЛОЙ

Управление слоями и их свойствами

СЛОЙП

Отмена последних изменений состояний и свойств слоев

СЛОЙПРЕЖИМ

Включение и отключение режима записи последовательности изменений свойств слоев

ОКНОСВ

Управление свойствами объектов

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

НОВОЕИМЯ

Изменение имен именованных объектов

Системные переменные

CLAYER

Установка имени текущего слоя

VPLAYEROVERRIDES

Указание на наличие слоев с переопределениями свойств видовых экранов для текущего видового экрана листа

VPLAYEROVERRIDESMODE

Управление отображением и печатью переопределений свойств слоев для видовых экранов листа

Утилиты

Нет

Ключевые слова для команд

Нет


Фильтрация и сортировка слоев в списке (Понятие)

Переопределение свойств слоя в видовых экранах
Работа со слоями
Уведомления о новых слоях
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Диспетчер свойств слоев позволяет задавать условия для ограничения числа отображаемых слоев в списке, а также сортировать слои по именам или свойствам (например, по цвету или по признаку видимости).

Фильтр слоев ограничивает отображение имен слоев в окне "Диспетчера свойств слоев" и в управляющем списке слоев на панели "Слои". В большом чертеже пользователь может использовать фильтры слоев для отображения только тех слоев, которые нужны для работы.

Есть два типа фильтров слоев:

  • Фильтр свойств слоя содержит слои с общими именами или другими свойствами. Например, пользователь может определить фильтр, который включает все красные слои, в чьих именах есть последовательность mech.
  • Фильтр группы слоев содержит слои, независимо от их имен или свойств, включенные в фильтр при его определении. Выбранные слои могут быть добавлены в фильтр из списка слоев путем перетаскивания.

В области структуры "Диспетчера свойств слоев" отображены стандартные фильтры слоев и все именованные фильтры, созданные и сохраненные в текущем чертеже. Тип фильтра обозначается значком около фильтра слоев. Отображаются пять стандартных фильтров

  • Все. Задает отображение всех слоев текущего чертежа. Этот фильтр отображается всегда.
  • Все используемые слои. Задает отображение всех слоев текущего чертежа, на которых нарисованы объекты. Этот фильтр отображается всегда.
  • Внешние ссылки. Если в чертеж вставлены внешние ссылки, фильтр задает отображение всех определенных в них слоев.
  • Переопределения видового экрана При наличии слоев с переопределениями текущего видового экрана фильтр отображает все слои, содержащие переопределения свойств.
  • Несогласованные новые слои При наличии новых слоев, добавленных после последнего открытия, сохранения, перезагрузки или печати чертежа, отображается список новых несогласованных слоев. Подробные сведения см. в разделе Согласование новых слоев.
ПримечаниеСтандартные фильтры нельзя переименовать, редактировать или удалить.

Задав имя и определив фильтр слоев, пользователь может выбрать его в области структуры для отображения слоев, удовлетворяющих фильтру, в списке. Можно применить фильтр к панели "Слои", чтобы в списке "Слой" отображались только те слои, которые определяются текущим фильтром.

При выборе фильтра в области структуры и нажатии правой кнопкой мыши появляется контекстное меню, опции которого можно использовать для удаления, переименования и изменения фильтров. Например, пользователь может преобразовать какой-либо фильтр слоев по свойствам в групповой фильтр. Пользователь может также изменить свойства всех слоев в фильтре. Опция "Выделить группу" отключает все слои чертежа, которые не находятся в выбранном фильтре.

Определение фильтра слоев по свойствам

Фильтр по свойствам определяется в диалоговом окне "Свойства фильтра слоев", где пользователь может выбрать любые из следующих свойств, определяющих фильтр:

  • Имена, цвета, типы линий, веса линий и стили печати
  • Используются ли слои
  • Включены/отключены ли слои
  • Заморожены/разморожены ли слои в активном видовом экране или во всех видовых экранах
  • Блокированы/разблокированы
  • Печатаемые/не печатаемые

Для фильтрации слоев по именам можно использовать специальные символы. Например, если необходимо отобразить только те слои, имена которых начинаются с символов mech, то надо ввести mech*. Полный список символов-шаблонов см. в разделе «Символы-шаблоны».

Набор слоев в фильтре по свойствам может меняться при изменения свойств слоев. Например, если пользователь определил фильтр по свойствам с именем "Участок", включающий все слои с именами, где есть подстрока участок, и типом линий CONTINUOUS, а затем изменил тип линий некоторых из этих слоев, то слои с измененными типами линий уже не будут входить в фильтр "Участок" и не будут отображаться при использовании данного фильтра.

Фильтры по свойствам могут быть вложенными в другие фильтры по свойствам или в групповые фильтры.

Определение группового фильтра слоев

Групповой фильтр слоев включает только те слои, которые были явно занесены туда пользователем. Если свойства слоев, назначенных данному фильтру, были изменены, то, несмотря на это, данные слои будут продолжать входить в этот фильтр. Групповые фильтры слоев могут быть вложенными, но только в другие групповые фильтры (а не в фильтры по свойствам).

СоветЛюбые слои из списка слоев могут быть включены в фильтр путем их перетаскивания в этот фильтр.

Инвертирование фильтра слоев

Пользователь может инвертировать фильтр слоев. Например, если все элементы плана участка располагаются на слоях, имена которых содержат слово участок, то для отображения всех остальных слоев необходимо создать фильтр, который отфильтровывает слои по строке *участок*, и установить флажок "Инвертировать фильтр".

Сортировка слоев

Создав слои, пользователь может отсортировать их по именам или по другим свойствам. Для сортировки списка следует в "Диспетчере свойств слоев" нажать на заголовке столбца того свойства, по которому должны сортироваться слои. Имена слоев могут быть отсортированы по возрастанию или по убыванию.

Специальные символы

Для сортировки слоев по именам можно использовать специальные символы.

Символ | Определение
# (решетка) | Соответствует любой одиночной цифре
@ (коммерческое "при") | Соответствует любой одиночной букве
. (десятичная точка) | Соответствует любому символу, кроме букв и цифр
* (звездочка) | Соответствует любой последовательности символов. Может использоваться в любой позиции строки
? (знак вопроса) | Соответствует любому одиночному символу; например, ?BC соответствует ABC, 3BC и т.п.
~ (тильда) | Соответствует всем строкам, кроме отвечающих следующему после тильды шаблону; например, ~*AB* соответствует всем строкам, не содержащим последовательности AB
[ ] | Соответствует любому из символов в скобках; например, [AB]C соответствует AC и BC
[~] | Соответствует любому из символов, кроме заключенных в скобки; например, [~AB]C соответствует XC, но не соответствует BC
[-] | Задает диапазон для одиночного символа; например, [A-G]C соответствует AC, BC и так далее до GC, но не соответствует HC
` (обратный апостроф) | Следующий за ним специальный символ трактуется как обычный; например, '~AB соответствует ~AB
ПримечаниеДля того, чтобы при фильтрации имени слоя, содержащего символы шаблона, эти символы не распознавались как специальные, перед ними следует ставить обратный апостроф (`).
См. также
    • Согласование новых слоев


Фильтрация и сортировка слоев в списке (Процедура)

Переопределение свойств слоя в видовых экранах
На уровень вверх ..
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Для быстрой фильтрации отображения слоев по именам

Для фильтрации отображения слоев по свойствам

Для фильтрации отображения имен слоев путем явного выбора

Для вложения фильтра слоев в другой фильтр слоев

Для сортировки списка слоев в "Диспетчере свойств слоев"

Для удаления слоя из группового фильтра слоев


Для быстрой фильтрации отображения слоев по именам (Процедура)

Фильтрация и сортировка слоев в списке
На уровень вверх ..
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Для быстрой фильтрации отображения слоев по именам

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" нажмите в поле "Поиск слоя" под областью структуры.
  3. (Если потребуется) Для ограничения поиска выберите фильтр в области структуры.
  4. Введите текст для поиска, включая специальные символы.

    В списке отображаются только те слои, имена которых совпадают с введенной строкой. Например, если ввести *mech*, то отобразятся все слои, имена которых содержат подстроку mech.

    Этот быстрый фильтр сбрасывается при закрытии Диспетчера свойств слоев.

Панель:Слои
Ввод команды: СЛОЙ


Для фильтрации отображения слоев по свойствам (Процедура)

Фильтрация и сортировка слоев в списке
На уровень вверх ..
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Для фильтрации отображения слоев по свойствам

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Новый фильтр по свойствам".
  3. В диалоговом окне "Свойства фильтра слоев" введите имя фильтра.
  4. В области "Описание фильтра" установите свойства слоя, которые необходимо использовать для определения фильтра.
    • Для фильтрации по именам можно использовать специальные символы.
    • Для фильтрации по свойствам следует нажать соответствующий столбец таблицы.

      При нажатии на кнопку [...] около некоторых свойств происходит вызов диалогового окна.

    • Чтобы выбрать для свойства несколько значений, щелкните правой кнопкой мыши на строке в определении фильтра. Выберите "Создать копию строки". Выберите другое значение для этого свойства в следующей строке.

      Например, определение для фильтра, отображающего только включенные и либо желтые, либо красные слои, имеет две строки. Первая строка определения фильтра имеет значок "Вкл", а в качестве цвета в ней установлен красный. Вторая строка имеет значок "Вкл", а в качестве цвета в ней установлен желтый.

  5. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Для фильтрации отображения имен слоев путем явного выбора (Процедура)

Фильтрация и сортировка слоев в списке
На уровень вверх ..
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Для фильтрации отображения имен слоев путем явного выбора

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" нажмите кнопку "Новый групповой фильтр".

    В области структуры создается новый групповой фильтр слоев с именем ГРУППОВОЙ ФИЛЬТР1.

  3. Введите имя фильтра.
  4. В области структуры щелкнуть на узле "Все" или одном из других узлов для отображения слоев в списке.
  5. В списке выделите слои, которые надо добавить в фильтр, и перетащите их на имя фильтра в области структуры.
  6. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Для вложения фильтра слоев в другой фильтр слоев (Процедура)

Фильтрация и сортировка слоев в списке
На уровень вверх ..
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Для вложения фильтра слоев в другой фильтр слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В области структуры окна "Диспетчер свойств слоев" выделите фильтр слоев.
    • Фильтр слоев по свойствам может быть вложен в групповой фильтр или другой фильтр по свойствам.
    • Групповой фильтр слоев может быть вложен только в другой групповой фильтр.
  3. Нажмите правую кнопку мыши. Выберите "Новый фильтр по свойствам" или "Новый групповой фильтр".
  4. Воспользуйтесь одним из следующих способов:
    • Для нового фильтра по свойствам открывается диалоговое окно "Свойства фильтра слоев". В области "Описание фильтра" установите свойства слоя, которые необходимо использовать для определения фильтра. Нажмите "ОК".
    • Для нового группового фильтра в области структуры добавляется новый фильтр. Следует задать ему имя, выбрать фильтр, в который он вкладывается (для отображения его слоев в списке), и затем перетащить слои из списка в новый групповой фильтр слоев.
  5. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Для сортировки списка слоев в "Диспетчере свойств слоев" (Процедура)

Фильтрация и сортировка слоев в списке
На уровень вверх ..
Фильтрация и сортировка слоев в списке
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Для сортировки списка слоев в "Диспетчере свойств слоев"

  • Нажмите на заголовке любого столбца.

Для изменения порядка сортировки на обратный нажмите второй раз.

Панель:Слои
Ввод команды: СЛОЙ


Для удаления слоя из группового фильтра слоев (Процедура)

Фильтрация и сортировка слоев в списке
На уровень вверх ..
Уведомления о новых слоях
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Для удаления слоя из группового фильтра слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В области структуры окна "Диспетчер свойств слоев" выделите групповой фильтр.
  3. Выберите слой для удаления.
  4. Щелкните правой кнопкой мыши на списке. Выберите "Удалить из группового фильтра".
Панель:Слои
Ввод команды: СЛОЙ


Фильтрация и сортировка слоев в списке (Краткий справочник)

Переопределение свойств слоя в видовых экранах
Фильтрация и сортировка слоев в списке
Уведомления о новых слоях
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Фильтрация и сортировка слоев в списке >
Фильтрация и сортировка слоев в списке
Понятие Процедура Краткий справочник

Команды

КЛСЛОЙ
СЛОЙ

Управление слоями и их свойствами

Системные переменные

MAXSORT

Максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков

Утилиты

Нет

Ключевые слова для команд

Нет


Уведомления о новых слоях (Понятие)

Фильтрация и сортировка слоев в списке
Работа со слоями
Согласование новых слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Уведомления о новых слоях
Понятие Процедура Краткий справочник

Перед выполнением определенных задач, например, печатью, сохранением или восстановлением конфигурации слоя, программа может выводить уведомления о новых слоях, добавленных в чертеж.

Пользователю чрезвычайно полезно знать о наличии новых слоев, добавленных без его ведома в чертеж или прикрепленные внешние ссылки. Это поможет избежать потенциальных проблем, таких, например, как вывод на печать объектов, добавленных в чертеж посредством добавления нового слоя.

Пользователь может определять, когда нужно проверить чертеж на наличие новых слоев. Пользователь может указать, какие команды (например, СОХРАНИТЬ или ПЕЧАТЬ) используются для проверки списка слоев и вывода уведомлений о новых слоях. Это касается и новых слоев, добавленных к прикрепленным внешним ссылкам.

За выполнение проверки списка слоев и вывод уведомлений совместно отвечают системные переменные LAYEREVAL и LAYERNOTIFY . Обе эти системные переменные хранятся в конкретном чертеже, поэтому пользователь может определять, какие чертежи проверены на наличие новых слоев. В начале работы над проектом информация о создании новых слоев обычно не требуется. Когда работа над проектом близка к завершению, важно знать о новой информации, внесенной в конкретный чертеж при добавлении новых слоев.

LAYEREVALCTL управляет общим списком фильтра "Несогласованные новые слои" в Диспетчере свойств слоев, который проверяется на наличие новых слоев. Когда флажок "Уведомление о новых слоях" установлен (LAYEREVALCTL = 1), включается функция уведомления о новых слоях, работа которой зависит от системных переменных LAYEREVAL и LAYERNOTIFY данного чертежа. При LAYEREVALCTL = 0 фильтр несогласованных слоев отображаться не должен. Если фильтр отображается, он будет отключен.

По умолчанию системная переменная LAYEREVAL используется для обнаружения новых слоев, которые были добавлены в прикрепленные внешние ссылки (но не в чертеж). С помощью системной переменной LAYERNOTIFY происходит уведомление пользователя о новых слоях при открытии чертежа, а также при загрузке, перезагрузке, прикреплении внешних ссылок или при восстановлении конфигурации слоев. Для внесения изменений в эти параметры можно воспользоваться системными переменными или диалоговым окном Параметры слоя.

Если режим уведомления о слоях включен, в строке состояния отображается значок "Несогласованные новые слои".

В этот момент для просмотра новых слоев можно нажать на этом значке правой кнопкой мыши и выбрать в меню ссылку "Просмотр несогласованных новых слоев". При нажатии ссылки открывается "Диспетчер свойств слоев" и автоматически выбирается фильтр "Несогласованные новые слои". Все новые слои, добавленные в чертеж или в прикрепленные внешние ссылки, отображаются в виде списка.

Новые слои считаются несогласованными, поскольку пользователь еще не просмотрел их. Выполняемый вручную процесс маркировки слоев в качестве согласованных приводит к удалению их из списка "Несогласованные новые слои". (Дополнительные сведения см. в Согласование новых слоев). До маркировки слоев в качестве согласованных всплывающее уведомление будет отображаться при каждом использовании команды, инициирующей уведомление.

С помощью системной переменной LAYERNOTIFY или диалогового окна "Параметры слоев" можно отключить уведомление о новых слоях, но при этом все же проверять список слоев на наличие новых. Хотя всплывающее уведомление не будет отображаться, пользователь сможет запускать проверку наличия новых слоев путем наведения курсора на значок предупреждения (в строке состояния) и нажатия правой кнопки мыши. Выберите строку "Просмотр несогласованных новых слоев" в контекстном меню.

Уведомления о новых слоях при печати

Если при выполнении команды "ПЕЧАТЬ" задано отображение нового уведомления о слоях в диалоговом окне "Параметры слоя", вместо значка в строке состояния отображается диалоговое окно. Выводится сообщение о появлении в чертеже новых слоев со времени последней проверки на наличие новых слоев. Для просмотра в "Диспетчере свойств слоев" списка новых слоев перед выводом их на печать необходимо нажать в диалоговом окне кнопку "Да".

Сохранение файла шаблона (DWT)

При сохранении чертежа в виде файла шаблона (dwt) в диалоговом окне "Параметры шаблона" можно выбрать отображение слоев на чертеже как согласованных или как несогласованных. По умолчанию все слои сохраняются как несогласованные, поэтому при запуске нового чертежа с помощью шаблона базовая линия слоя не создается до первого сохранения чертежа вфайле .dwg.

Если файл шаблона сохраняется со всеми согласованными слоями, базовая линия слоя создается. Таким образом, при добавлении новых слоев в чертеж, созданный из файла шаблона, все создаваемые новые слои являются несогласованными. Поэтому при первом сохранении или печати чертежа отображается уведомление о новом слое.

Открытие нескольких чертежей

При одновременном открытии нескольких чертежей предупреждение отображается для каждого чертежа, содержащего новые слои. Это происходит, если для каждого чертежа была включена функция предупреждения о новых слоях и была указана команда ОТКРЫТЬ в системной переменной LAYERNOTIFY .

Темы в этом разделе

  • Согласование новых слоев

    Несогласованными считаются новые слои, добавленные в чертеж, но еще не принятые пользователем к сведению и не помеченные им вручную в качестве согласованных.


Уведомления о новых слоях (Процедура)

Фильтрация и сортировка слоев в списке
На уровень вверх ..
Уведомления о новых слоях
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Уведомления о новых слоях >
Уведомления о новых слоях
Понятие Процедура Краткий справочник

Для включения и отключения уведомлений о новых слоях

Для указания времени отображения уведомлений о новых слоях


Для включения и отключения уведомлений о новых слоях (Процедура)

Уведомления о новых слоях
На уровень вверх ..
Уведомления о новых слоях
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Уведомления о новых слоях >
Уведомления о новых слоях
Понятие Процедура Краткий справочник

Для включения и отключения уведомлений о новых слоях

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" выберите "Параметры".
  3. В диалоговом окне "Параметры слоя" выберите "Выявлять новые слои, добавляемые в чертеж".
  4. Нажмите "Уведомление о наличии новых слоев". Выберите одну или несколько опций.
  5. Нажмите ОК.
  6. Нажмите "ОК" для выхода из "Диспетчера свойств слоев".
Панель:Слои
Ввод команды: СЛОЙ


Для указания времени отображения уведомлений о новых слоях (Процедура)

Уведомления о новых слоях
На уровень вверх ..
Работа с конфигурациями слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Уведомления о новых слоях >
Уведомления о новых слоях
Понятие Процедура Краткий справочник

Для указания времени отображения уведомлений о новых слоях

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В "Диспетчере свойств слоев" выберите "Параметры".
  3. В диалоговом окне "Параметры слоя" выберите "Выявлять новые слои, добавляемых в чертеж".
  4. Выберите "Уведомление о наличии новых слоев".
  5. Выберите команды, используемые для проверки списка слоев на наличие новых слоев.
  6. Нажмите "ОК".
Панель:Слои
Ввод команды: СЛОЙ


Уведомления о новых слоях (Краткий справочник)

Фильтрация и сортировка слоев в списке
Уведомления о новых слоях
Согласование новых слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Уведомления о новых слоях >
Уведомления о новых слоях
Понятие Процедура Краткий справочник

Команды

КЛСЛОЙ
СЛОЙ

Управление слоями и их свойствами

Системные переменные

LAYEREVALCTL

Управление общим списком фильтров новых несогласованных слоев в Диспетчере свойств слоев, в котором оцениваются новые слои

LAYERNOTIFY

Определение условий отображения предупреждения при обнаружении несогласованных новых слоев

LAYEREVAL

Признак оценки списка слоев при добавлении новых слоев в чертеж или во вставленные внешние ссылки

Утилиты

Нет

Ключевые слова для команд

Нет


Согласование новых слоев (Понятие)

Уведомления о новых слоях
Уведомления о новых слоях
Работа с конфигурациями слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Уведомления о новых слоях >
Согласование новых слоев
Понятие Краткий справочник

Несогласованными считаются новые слои, добавленные в чертеж, но еще не принятые пользователем к сведению и не помеченные им вручную в качестве согласованных.

Согласование новых слоев - это выполняемый вручную процесс просмотра новых слоев с целью избежать ошибок перед печатью чертежа или восстановлением конфигурации слоев.

Несогласованными являются новые слои, добавленные в чертеж или в прикрепленные внешние ссылки после последней проверки списка слоев. Проверка списка слоев на наличие новых слоев выполняется при запуске определенной команды, например, ПЕЧАТЬ. В новых чертежах базовая линия слоя создается при первом сохранении или печати чертежа. При первом сохранении чертежа создается базовая линия слоя и все слои, присутствующие в сохраненном чертеже становятся согласованными (не новыми). Слои, добавленные после первого сохранения чертежа, считаются новыми несогласованными слоями.

ПримечаниеБазовая линия слоя создается в том случае, если для системной переменной LAYEREVAL задано значение 1 или 2.

При использовании команды, указанной в диалоговом окне "Параметры слоя" или в системной переменной LAYEREVAL, выполняется проверка списка слоев и сравнение его с базовой линией. При наличии новых слоев отображается уведомление, а в "Диспетчере свойств слоев" автоматически создается и активируется фильтр "Несогласованные новые слои".

Чтобы сделать несогласованный слой согласованным, нужно нажать правую кнопку мыши на этом слое и выбрать строку "Согласование слоя". После того, как слой стал согласованным, он удаляется из фильтра "Несогласованные новые слои". После согласования всех слоев фильтр "Несогласованные новые слои" удаляется.

ПримечаниеПользователь имеет возможность согласовать несколько несогласованных слоев одновременно.


Согласование новых слоев (Краткий справочник)

Уведомления о новых слоях
Уведомления о новых слоях
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Уведомления о новых слоях > Согласование новых слоев >
Согласование новых слоев
Понятие Краткий справочник

Команды

КЛСЛОЙ
СЛОЙ

Управление слоями и их свойствами

Системные переменные

LAYERNOTIFY

Определение условий отображения предупреждения при обнаружении несогласованных новых слоев

LAYEREVAL

Признак оценки списка слоев при добавлении новых слоев в чертеж или во вставленные внешние ссылки

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с конфигурациями слоев

Согласование новых слоев
Работа со слоями
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями >
Работа с конфигурациями слоев
Понятие Процедура

Параметры слоев можно сохранять в виде именованных конфигураций слоев. Такие конфигурации слоев можно восстанавливать, редактировать и импортировать из других чертежей и файлов, а также экспортировать их для использования в других чертежах.

Темы в этом разделе

  • Сохранение, восстановление и редактирование конфигураций слоев

    Пользователь может сохранять текущие параметры слоя в конфигурации слоя, вносить изменения в эту конфигурацию и впоследствии восстанавливать эти параметры в чертеже.

  • Импорт и экспорт конфигураций слоев

    Пользователь может импортировать параметры слоев из других чертежей и экспортировать конфигурации слоев.


Работа с конфигурациями слоев (Процедура)

Уведомления о новых слоях
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев >
Работа с конфигурациями слоев
Понятие Процедура

Для сохранения параметров слоя в именованной конфигурации слоев

Для восстановления конфигурации слоев

Для добавления слоев в конфигурацию слоев

Для удаления слоев из конфигурации слоев

Для изменения именованной конфигурации слоев

Для переименования именованной конфигурации слоев

Для удаления именованной конфигурации слоев

Для включения описания и свойств материалов в конфигурацию слоев, импортированную из предыдущей версии программы,

Выбор конфигурации слоев для восстановления

Для восстановления переопределений видового экрана слоя

Для импорта сохраненных параметров слоев из другого чертежа

Для импорта сохраненных параметров слоя из файла конфигурации слоев (LAS)

Для экспорта сохраненной конфигурации слоев


Сохранение, восстановление и редактирование конфигураций слоев (Понятие)

Работа с конфигурациями слоев
Работа с конфигурациями слоев
Импорт и экспорт конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Пользователь может сохранять текущие параметры слоя в конфигурации слоя, вносить изменения в эту конфигурацию и впоследствии восстанавливать эти параметры в чертеже.

Имеется возможность сохранения конфигураций слоев в чертеже в виде состояний слоев и их последующего восстановления. Сохранение конфигурации слоев удобно, когда есть необходимость в быстром возвращении к конкретным настройкам всех слоев в ходе различных этапов создания чертежа или для печати.

Сохранение конфигураций слоев

Конфигурации слоев включают такие настройки, как состояние включенности или блокировки, и такие свойства слоев, как цвет или тип линий. В именованной конфигурации слоев пользователь может выбрать состав запоминаемых состояний и свойств слоев, которые необходимо будет восстановить позднее. Например, можно сохранять только признак замороженности слоя, игнорируя все остальные параметры. В этом случае при восстановлении все параметры слоев, кроме признака замороженности каждого слоя, останутся без изменений.

Сохранение параметров переопределения свойств слоев

Параметры слоев, которые содержат переопределения свойств видового экрана, сохраняются в конфигурации слоев, если видовой экран, содержащий переопределения, активен.

Если конфигурация слоев сохраняется из пространства модели, параметры переопределения состояния слоя не сохраняются. Это происходит потому, что для каждого свойства слоя в конфигурации слоев сохраняется только одно значение. Если в конфигурации слоев все же требуется сохранить переопределения свойств, сделайте видовой экран активным на вкладке "Лист", а затем сохраните конфигурацию слоев.

Восстановление параметров слоев

При восстановлении конфигурации слоев те настройки слоев (конфигурации слоев и свойства слоев), которые были указаны при сохранении этой конфигурации слоев, восстанавливаются. Указать, какие именно параметры следует восстанавливать, можно в Диспетчер конфигураций слоев. Невыбранные параметры свойств слоев остаются в чертеже неизменными.

Пользователь может включить в конфигурацию слои, добавленные после ее сохранения, если чертеж содержит таковые. Слои для добавления можно выбрать путем редактирования конфигурации слоев или с помощью диалогового окна Выбор слоев для добавления в конфигурацию.

ПримечаниеДля настройки уведомлений о добавлении новых слоев используются системные переменные LAYEREVAL и LAYERNOTIFY .

При восстановлении конфигураций слоев возможны следующие случаи

  • Слой, который был текущим при сохранении конфигурации, становится текущим и при ее восстановлении. Если этот слой уже не существует, то текущий слой не изменяется.
  • Если во время восстановления конфигурации видовой экран листа активен, а опция "Видимость в текущем ВЭ" включена, все слои, которые должны быть видимыми в видовом экране, включаются и размораживаются в пространстве модели. Для всех слоев, которые не должны быть видимыми в видовом экране, в текущем экране устанавливается опция "Замороженный на ВЭ". При этом видимость пространства модели остается неизменной.

Панель "Слои" на ЛЕНТА содержит элементы управления для выбора и восстановления сохраненных конфигураций слоев, в том числе кнопку для вызова Диспетчера конфигураций слоев. Имя последней восстановленной конфигурации слоев отображается на панели "Слои". Если в результате изменения слоев текущее состояние слоя перестает быть текущим, вместо имени последнего восстановленного состояния слоя отображается текст "Несохраненная конфигурация слоев".

Восстановление параметров переопределения свойств

Если в Диспетчер конфигураций слоев выбран параметр восстановления "Применять свойства в качестве переопределений видового экрана", переопределения видовых экранов восстанавливаются в соответствии с тем видовым экраном, который является текущим на момент восстановления состояния слоя.

Когда конфигурация слоев сохранена в пространстве модели и восстанавливается в пространстве листа,

  • Пользователь может указать, должны ли в качестве переопределений видового экрана восстанавливаться цвет, тип линии, вес линии или свойства стиля печати.
  • Переопределения видового экрана применяются к текущему видовому экрану листа.
  • Слои, отключенные или замороженные в пространстве модели, указываются как "Замороженные на ВЭ" в "Диспетчере свойств слоев" (для активного видового экрана листа).

Когда конфигурация слоев сохранена в пространстве листа и восстанавливается в пространстве модели,

  • Переопределения свойств слоев восстанавливаются как глобальные свойства слоя в пространстве модели.
  • Слои, замороженные в видовом экране листа замораживаются также и в пространстве модели.

Редактирование сохраненных параметров слоя

С помощью диалогового окна Редактирование конфигурации слоев пользователь может изменять свойства каждого слоя, сохраненного в конфигурации.

Редактировать можно все свойства, кроме имени слоя. Свойства нескольких слоев можно изменять одновременно.

Пользователь может также добавлять слои в конфигурацию с помощью диалогового окна "Выбор слоев для добавления к конфигурации слоев". Например, можно добавить в конфигурацию новые слои, появившиеся после сохранения конфигурации, и повторно сохранить ее. Для удаления слоев используется кнопка "Удалить" в диалоговом окне "Редактирование конфигурации слоев".

Конфигурации слоев во внешних ссылках

При вставке чертежа, содержащего конфигурации слоев, в главный чертеж, конфигурации слоев внешних ссылок отображаются в "Диспетчере конфигураций слоев". Конфигурации слоев, которые перечислены по именам, можно просмотреть в диалоговом окне "Редактирование конфигурации слоев".

Когда внешняя ссылка, содержащая конфигурации слоев, прикрепляется к главному чертежу, то эти конфигурации перечисляются также в "Диспетчере конфигураций слоев". Их можно восстановить, но нельзя редактировать. Конфигурации слоев, принадлежащие внешним ссылкам, легко идентифицировать: перед именем такой конфигурации слоев ставится имя чертежа внешней ссылки и два символа подчеркивания. (Пример: имя внешней ссылки__имя конфигурации слоев.) Когда внешняя ссылка привязана к главному чертежу, конфигурации слоев распознаются с помощью символов $0$, которые отображаются между именем внешней ссылки и именем конфигурации слоев (Например, Имя внешней ссылки$0$Имя конфигурации слоев

Это касается и конфигураций слоев из вложенных внешних ссылок. Конфигурации слоев из внешних ссылок удаляются из главного чертежа, когда внешняя ссылка открепляется или выгружается.


Сохранение, восстановление и редактирование конфигураций слоев (Процедура)

Работа с конфигурациями слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для сохранения параметров слоя в именованной конфигурации слоев

Для восстановления конфигурации слоев

Для добавления слоев в конфигурацию слоев

Для удаления слоев из конфигурации слоев

Для изменения именованной конфигурации слоев

Для переименования именованной конфигурации слоев

Для удаления именованной конфигурации слоев

Для включения описания и свойств материалов в конфигурацию слоев, импортированную из предыдущей версии программы,

Выбор конфигурации слоев для восстановления

Для восстановления переопределений видового экрана слоя


Для сохранения параметров слоя в именованной конфигурации слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для сохранения параметров слоя в именованной конфигурации слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" нажмите кнопку "Создать".
  3. В диалоговом окне "Сохранение новой конфигурации слоев" введите имя новой конфигурации слоев или выберите имя из списка.
  4. (Не обязательно) Добавьте текстовое описание.
  5. Нажмите кнопку "Закрыть".
  6. В "Диспетчере конфигураций слоев" выберите свойства слоев, для которых впоследствии будут восстанавливаться значения по умолчанию.
  7. (Не обязательно) Выберите опцию "Отключить слои, отсутствующие в конфигурации".

    Если эта опция выбрана, то при восстановлении именованной конфигурации слоев чертеж будет выглядеть так же, как он выглядел при сохранении именованной конфигурации слоев.

  8. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для восстановления конфигурации слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для восстановления конфигурации слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев.
  3. Чтобы восстановить отдельные свойства слоев, нажмите кнопку "Дополнительно".
  4. Нажмите "Восстановить".

    Диспетчер конфигураций слоев закрывается.

Панель:Слои
Ввод команды: СЛОЙСОСТ


Для добавления слоев в конфигурацию слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для добавления слоев в конфигурацию слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев, в которую надо добавить слои.
  3. Нажмите кнопку "Изменить".
  4. В диалоговом окне "Редактирование конфигурации слоев" нажмите "Добавить".
  5. В диалоговом окне "Выбор слоев для добавления к конфигурации слоев" выберите слои для добавления.
  6. Нажмите "ОК".
  7. Нажмите "ОК", чтобы выйти из диалогового окна "Редактирование конфигурации слоев".
  8. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для удаления слоев из конфигурации слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для удаления слоев из конфигурации слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев, из которую надо удалить слои.
  3. Нажмите кнопку "Изменить".
  4. В диалоговом окне "Редактирование конфигурации слоев" выберите слои для удаления и нажмите кнопку "Удалить".
  5. Нажмите "ОК".
  6. Нажмите "ОК", чтобы выйти из диалогового окна "Редактирование конфигурации слоев".
  7. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для изменения именованной конфигурации слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для изменения именованной конфигурации слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев, которую надо изменить.
  3. Нажмите кнопку "Изменить".
  4. В диалоговом окне "Редактирование конфигурации слоев" выберите ячейки свойства, которые нужно изменить.
  5. Нажмите "ОК".
  6. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для переименования именованной конфигурации слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для переименования именованной конфигурации слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев, которую надо переименовать.
  3. Выберите "Переименовать".
  4. В поле "Имя" введите новое имя.
  5. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
ПримечаниеЕсть и другой способ: выбрать имя конфигурации слоев и нажать клавишу F2 для контекстного редактирования
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для удаления именованной конфигурации слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для удаления именованной конфигурации слоев

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев, которую надо удалить.
  3. Нажать кнопку "Удалить".
  4. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для включения описания и свойств материалов в конфигурацию слоев, импортированную из предыдущей версии программы, (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для включения описания и свойств материалов в конфигурацию слоев, импортированную из предыдущей версии программы,

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите конфигурацию, импортированную из предыдущей версии программы.
  3. Нажмите кнопку "Восстановить", чтобы восстановить конфигурацию слоев.
  4. Откройте "Диспетчер конфигураций слоев". Выберите "Создать".
  5. В диалоговом окне "Сохранение новой конфигурации слоев" введите новое имя конфигурации. Введите текст описания параметров слоев в поле "Описание".
  6. Нажмите ОК.
  7. (При необходимости) нажмите кнопку "Удалить" для удаления конфигурации устаревшей версии.
  8. Нажмите кнопку "Закрыть".

Описание и свойства материала будут сохранены с обновленной конфигурацией слоев.

Панель:Слои
Ввод команды: СЛОЙСОСТ


Выбор конфигурации слоев для восстановления (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Сохранение, восстановление и редактирование конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Выбор конфигурации слоев для восстановления

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите конфигурацию слоев, которую надо восстановить.
  3. Нажмите кнопку "Дополнительно" и выберите отдельные свойства слоев, которые нужно восстановить,
  4. Нажмите "Восстановить".

    Диспетчер конфигураций слоев закрывается.

Панель:Слои
Ввод команды: СЛОЙСОСТ


Для восстановления переопределений видового экрана слоя (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Импорт и экспорт конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Для восстановления переопределений видового экрана слоя

  1. Выберите видовой экран разметки листа.
  2. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  3. В "Диспетчере конфигураций слоев" выберите именованную конфигурацию слоев, которую надо восстановить.
  4. Выберите "Переопределения ВЭ"
  5. Нажмите "Восстановить".

    Диспетчер конфигураций слоев закрывается. Сохраненные значения цвета, типа линий, веса линий и стиля печати применяются как переопределения к слоям в текущем видовом экране.

Панель:Слои
Ввод команды: СЛОЙСОСТ


Сохранение, восстановление и редактирование конфигураций слоев (Краткий справочник)

Согласование новых слоев
Сохранение, восстановление и редактирование конфигураций слоев
Импорт и экспорт конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Сохранение, восстановление и редактирование конфигураций слоев >
Сохранение, восстановление и редактирование конфигураций слоев
Понятие Процедура Краткий справочник

Команды

СЛОЙСОСТ

Сохранение, восстановление именованных состояний слоев и управление ими

Системные переменные

LAYERNOTIFY

Определение условий отображения предупреждения при обнаружении несогласованных новых слоев

LAYEREVAL

Признак оценки списка слоев при добавлении новых слоев в чертеж или во вставленные внешние ссылки

Утилиты

Нет

Ключевые слова для команд

Нет


Импорт и экспорт конфигураций слоев (Понятие)

Сохранение, восстановление и редактирование конфигураций слоев
Работа с конфигурациями слоев
Работа с цветом
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев >
Импорт и экспорт конфигураций слоев
Понятие Процедура Краткий справочник

Пользователь может импортировать параметры слоев из других чертежей и экспортировать конфигурации слоев.

Импортировать можно конфигурации слоев, сохраненные в файлах чертежей (DWG, DWS и DWT) и в файлах конфигураций слоев (LAS). При импорте конфигураций слоев из файла чертежа можно выбрать несколько конфигураций для импорта в диалоговом окне Выбор конфигураций слоев При экспорте конфигураций слоев создаются файлы LAS.

Если конфигурация слоев импортируется из чертежа, который содержит свойство слоя (например, тип линии или стиль печати), незагруженное или недоступное в текущем чертеже, это свойство автоматически импортируется из исходного чертежа.

Если конфигурация слоев импортируется из файла LAS и содержит свойства типа линии или стиля печати, несуществующие в чертеже, выводится сообщение о том, что свойство не может быть восстановлено.

ПримечаниеКогда конфигурация слоев содержит несколько свойств, которые не могут быть восстановлены из файла LAS, в отображаемом сообщении лишь указывается первое обнаруженное такое свойство.

При импорте из файла LAS или из другого чертежа конфигурации слоев, дублирующей конфигурации слоев текущего чертежа, можно перезаписать существующую конфигурацию или не импортировать ее.

Конфигурации слоев можно импортировать в предыдущие версии программы.

Конфигурации слоев LMAN

Конфигурации слоев, созданные с помощью утилиты LMAN Express Tool, импортировать нельзя. Отображается сообщение о том, что конфигураций, доступных для импорта, нет.

В чертеже конфигурации слоев LMAN доступны из "Диспетчера конфигураций слоев". При первом открытии "Диспетчера конфигураций слоев" в чертеже, содержащем конфигурации слоев LMAN, эти конфигурации автоматически преобразуются в конфигурации слоев AutoCAD. В диалоговом окне отображается количество преобразованных конфигураций слоев.

Если в текущем чертеже нет именованных конфигураций слоев, используются имена конфигураций слоев LMAN. Если текущий чертеж содержит конфигурации слоев, имена конфигурации слоев LMAN отображаются с префиксом "LMAN".


Импорт и экспорт конфигураций слоев (Процедура)

Сохранение, восстановление и редактирование конфигураций слоев
На уровень вверх ..
Импорт и экспорт конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Импорт и экспорт конфигураций слоев >
Импорт и экспорт конфигураций слоев
Понятие Процедура Краткий справочник

Для импорта сохраненных параметров слоев из другого чертежа

Для импорта сохраненных параметров слоя из файла конфигурации слоев (LAS)

Для экспорта сохраненной конфигурации слоев


Для импорта сохраненных параметров слоев из другого чертежа (Процедура)

Импорт и экспорт конфигураций слоев
На уровень вверх ..
Импорт и экспорт конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Импорт и экспорт конфигураций слоев >
Импорт и экспорт конфигураций слоев
Понятие Процедура Краткий справочник

Для импорта сохраненных параметров слоев из другого чертежа

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" нажмите кнопку "Импорт".
  3. В диалоговом окне "Импорт конфигурации слоев" выберите имя файлас расширением .dwg, .dws или .dwt. Нажмите "Открыть".
  4. В диалоговом окне "Выбор конфигурации слоев" выберите конфигурации слоев для импортирования. Нажмите ОК.
  5. Чтобы сразу восстановить именованную конфигурацию слоев, выберите ее название в "Диспетчере конфигураций слоев" и нажмите кнопку "Восстановить". Если восстановление не требуется, нажмите "Закрыть".

    Если было выбрано восстановление именованной конфигурации слоев, то "Диспетчер конфигураций слоев" закрывается.

  6. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для импорта сохраненных параметров слоя из файла конфигурации слоев (LAS) (Процедура)

Импорт и экспорт конфигураций слоев
На уровень вверх ..
Импорт и экспорт конфигураций слоев
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Импорт и экспорт конфигураций слоев >
Импорт и экспорт конфигураций слоев
Понятие Процедура Краткий справочник

Для импорта сохраненных параметров слоя из файла конфигурации слоев (LAS)

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" нажмите кнопку "Импорт".
  3. В диалоговом окне "Импорт конфигурации слоев" выберите файл LAS, из которого требуется импортировать конфигурации слоев. Нажмите "Открыть".
  4. Нажмите "Да", чтобы восстановить эту конфигурацию слоев сейчас. Нажмите "Нет", чтобы добавить конфигурацию слоев в Диспетчер конфигураций слоев, не восстанавливая ее при этом.

    Если было выбрано восстановление именованной конфигурации слоев, то "Диспетчер конфигураций слоев" закрывается.

  5. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Для экспорта сохраненной конфигурации слоев (Процедура)

Импорт и экспорт конфигураций слоев
На уровень вверх ..
Работа с цветом
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Импорт и экспорт конфигураций слоев >
Импорт и экспорт конфигураций слоев
Понятие Процедура Краткий справочник

Для экспорта сохраненной конфигурации слоев

  1. Выберите вкладку "Главная" [image] панель "Слои [image] "Диспетчер конфигураций слоев". В командной строке введите "слойсост".
  2. В "Диспетчере конфигураций слоев" выберите файл именованной конфигурации слоев (LAS), который надо экспортировать. Нажмите кнопку "Экспорт".
  3. В диалоговом окне "Экспорт конфигурации слоев" укажите, куда нужно экспортировать файл конфигурации слоев.
  4. Для выхода из диалогового окна нажмите кнопку "Сохранить".
  5. Нажмите "Закрыть", чтобы выйти из "Диспетчера конфигураций слоев".
Панель:Слои
Ввод команды: СЛОЙСОСТ


Импорт и экспорт конфигураций слоев (Краткий справочник)

Сохранение, восстановление и редактирование конфигураций слоев
Импорт и экспорт конфигураций слоев
Установка текущего цвета
Создание и редактирование объектов > Свойства объектов > Работа со слоями > Работа с конфигурациями слоев > Импорт и экспорт конфигураций слоев >
Импорт и экспорт конфигураций слоев
Понятие Процедура Краткий справочник

Команды

СЛОЙСОСТ

Сохранение, восстановление именованных состояний слоев и управление ими

Системные переменные

LAYERNOTIFY

Определение условий отображения предупреждения при обнаружении несогласованных новых слоев

LAYEREVAL

Признак оценки списка слоев при добавлении новых слоев в чертеж или во вставленные внешние ссылки

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с цветом

Импорт и экспорт конфигураций слоев
Свойства объектов
Установка текущего цвета
Создание и редактирование объектов > Свойства объектов >
Работа с цветом
Понятие Процедура

Цвет помогает группировать объекты визуально. Пользователь может назначать цвета объектам по слоям или индивидуально.

Темы в этом разделе

  • Установка текущего цвета

    Использование различных цветов позволяет визуально идентифицировать объекты, облегчая тем самым работу с чертежом. Цвета можно присваивать как слоям, так и отдельным объектам чертежа.

  • Изменение цвета объекта

    Цвет объекта можно изменять, перенося объект на другой слой, изменяя цвет слоя, на котором расположен объект, или явно присваивая цвет самому объекту.

  • Работа с альбомами цветов

    При назначении цвета объектам можно пользоваться альбомами цветов. Работа с альбомами цветов позволяет оперировать широкой палитрой цвета. Альбомы цветов представляют собой файлы от стороннего производителя или пользовательские файлы, которые содержат именованные образцы цветов. Использование цветов из альбомов позволяет улучшить вид чертежа и готовить высококачественные презентационные материалы. Назначение цвета объекту осуществляется с помощью вкладки "Альбомы цветов" в диалоговом окне "Выбор цвета".


Работа с цветом (Процедура)

Импорт и экспорт конфигураций слоев
Работа с цветом
Установка текущего цвета
Создание и редактирование объектов > Свойства объектов > Работа с цветом >
Работа с цветом
Понятие Процедура

Для задания цвета создаваемых объектов по ИЦА

Для задания цвета создаваемых объектов из полной палитры

Для задания цвета создаваемых объектов из альбома

Перенос объекта на другой слой

Для назначения цвета слою

Для явного назначения цвета объекту

Для подключения альбома цветов

Для поиска цвета в альбоме

Для изменения местоположения альбома цветов, принятого по умолчанию

Для задания нескольких папок с альбомами цветов


Установка текущего цвета (Понятие)

Работа с цветом
Работа с цветом
Изменение цвета объекта
Создание и редактирование объектов > Свойства объектов > Работа с цветом >
Установка текущего цвета
Понятие Процедура Краткий справочник

Использование различных цветов позволяет визуально идентифицировать объекты, облегчая тем самым работу с чертежом. Цвета можно присваивать как слоям, так и отдельным объектам чертежа.

Цвета можно присваивать как слоям, так и отдельным объектам чертежа. Назначение определенного цвета каждому слою помогает идентифицировать слои в чертеже. Для того, чтобы создать дополнительные визуальные различия между объектами одного слоя, можно присвоить отдельные цвета объектам и их группам. Использование цветов позволяет идентифицировать линии различного назначения, когда чертеж выводится на плоттер с использованием цветозависимых стилей печати.

При назначении цвета объекту можно использовать разнообразные палитры. К ним относятся

  • &Индекс цветов AutoCAD (ИЦА)
  • Полная палитра®, PANTONE®
  • Альбомы цветов RAL™ Classic and RAL Design
  • DIC® Color Guide (Руководство по выбору цвета)
  • Цвета из импортированных альбомов цветов.

Цвета по ИЦА

ИЦА это стандартный набор цветов, используемых в AutoCAD. Задание цвета производится по стандартному имени или с помощью индекса цветов AutoCAD (ИЦА) в виде целого числового значения от 1 до 255. Стандартные имена присвоены только цветам с номерами от 1 до 7. Цвета назначаются следующим образом: 1 красный, 2 желтый, 3 зеленый, 4 голубой, 5 синий, 6 фиолетовый, 7 белый/черный.

Полная палитра цветов True Color

Полноцветный режим дает возможность выбора из 16 миллионов цветов. При назначении цвета в полноцветном режиме можно воспользоваться цветовой моделью RGB и HSL. В цветовой модели RGB задаются красная, зеленая, и синяя составляющие цвета; в цветовой модели HSL задаются оттенок, насыщенность и яркость цвета.

Альбомы цветов

Эта программа включает в себя несколько стандартных альбомов цветов Pantone. Пользователь также может импортировать другие альбомы, такие как цветовой справочник DIC или набор цветов RAL. Импортирование дополнительных альбомов цветов позволяет расширить палитру доступных цветов.

ПримечаниеPantone содержит новые описания цветов для альбомов цветов Architectural & Interiors Cotton и Architectural & Interiors Paper. Если вы использовали эти альбомы цветов в версиях до AutoCAD 2006, то вы можете заметить изменения в цветах.

Подключение альбомов цветов осуществляется с помощью вкладки "Файл" в диалоговом окне "Настройка". После загрузки альбома цветов выбранный цвет можно применить к любому объекту на чертеже.

Все новые объекты создаются с использованием текущего цвета, установленного в управляющем списке "Цвета" панели "Свойства". Текущий цвет можно установить не только с помощью управляющего списка "Цвета", но и в диалоговом окне "Выбор цвета".

Если установлен текущий цвет ПОСЛОЮ, то все вновь создаваемые объекты используют цвет, присвоенный текущему слою. Вместо того, чтобы использовать текущий цвет слоя, можно назначать цвета явным образом.

Если установлен текущий цвет ПОБЛОКУ, то объекты имеют цвет 7 (белый или черный) до тех пор, пока не будут объединены в блок. Вставляемым в чертеж блокам присваивается текущий цвет.


Установка текущего цвета (Процедура)

Работа с цветом
На уровень вверх ..
Установка текущего цвета
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Установка текущего цвета >
Установка текущего цвета
Понятие Процедура Краткий справочник

Для задания цвета создаваемых объектов по ИЦА

Для задания цвета создаваемых объектов из полной палитры

Для задания цвета создаваемых объектов из альбома


Для задания цвета создаваемых объектов по ИЦА (Процедура)

Установка текущего цвета
На уровень вверх ..
Установка текущего цвета
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Установка текущего цвета >
Установка текущего цвета
Понятие Процедура Краткий справочник

Для задания цвета создаваемых объектов по ИЦА

  1. На панели "Свойства" выберите управляющий список "Цвета".
  2. Выберите нужный цвет для использования при создании новых объектов или нажмите на пункте "Выбор цвета" для вызова одноименного диалогового окна, где выполните одно из действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" имя или порядковый номер цвета.
    • На вкладке "Номер цвета" выберите значение ПОСЛОЮ для построения новых объектов с текущим цветом слоя.
    • На вкладке "Номер цвета" выберите значение ПОБЛОКУ для построения новых объектов с текущим цветом слоя до их объединения в блок. При вставке блока его объектам присваивается текущий цвет, заданный в чертеже.
  3. Нажать "ОК".

    Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Для задания цвета создаваемых объектов из полной палитры (Процедура)

Установка текущего цвета
На уровень вверх ..
Установка текущего цвета
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Установка текущего цвета >
Установка текущего цвета
Понятие Процедура Краткий справочник

Для задания цвета создаваемых объектов из полной палитры

  1. На панели "Свойства" выберите управляющий список "Цвета".
  2. Нажмите на пункте "Выбор цвета" для вызова окна "Выбор цвета".
  3. В диалоговом окне "Выбор цвета" на вкладке "Вся палитра" выполните следующее:
    • Выберите цветовую модель HSL в списке "Цветовая модель". Задайте цвет путем введения его значения в поле "Цвет" или введением значений в полях "Оттенок", "Насыщенность" и "Яркость".
    • Выберите цветовую модель RGB в списке "Цветовая модель". Задайте цвет путем введения его значения в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
  4. Нажмите "ОК".

    Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Для задания цвета создаваемых объектов из альбома (Процедура)

Установка текущего цвета
На уровень вверх ..
Изменение цвета объекта
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Установка текущего цвета >
Установка текущего цвета
Понятие Процедура Краткий справочник

Для задания цвета создаваемых объектов из альбома

  1. На панели "Свойства" выберите управляющий список "Цвета".
  2. Нажмите на пункте "Выбор цвета".
  3. В диалоговом окне "Выбор цвета" на вкладке "Альбомы цветов" выберите нужный альбом.
  4. Щелчком мыши выберите требуемый цвет. Просмотр всей палитры цветов осуществляется с помощью полос прокрутки окна.
  5. Нажмите "ОК".

    Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Установка текущего цвета (Краткий справочник)

Импорт и экспорт конфигураций слоев
Установка текущего цвета
Изменение цвета объекта
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Установка текущего цвета >
Установка текущего цвета
Понятие Процедура Краткий справочник

Команды

ЦВЕТ

Задание цвета для вновь создаваемых объектов

Системные переменные

CECOLOR

Задание цвета для новых объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение цвета объекта (Понятие)

Установка текущего цвета
Работа с цветом
Работа с альбомами цветов
Создание и редактирование объектов > Свойства объектов > Работа с цветом >
Изменение цвета объекта
Понятие Процедура Краткий справочник

Цвет объекта можно изменять, перенося объект на другой слой, изменяя цвет слоя, на котором расположен объект, или явно присваивая цвет самому объекту.

Цвет объекта можно изменить тремя способами:

  • Перенести объект на другой слой, для которого установлен иной цвет. Если цвет объекта имеет значение ПОСЛОЮ, то после переноса на другой слой объект примет цвет нового слоя.
  • Изменить цвет слоя, на котором расположен объект. Если в свойствах объекта задан цвет ПОСЛОЮ, объект примет цвет слоя. При изменении цвета слоя все объекты, цвета которых заданы значением ПОСЛОЮ, автоматически обновляются, приобретая измененный цвет слоя.
  • Явно присвоить цвет самому объекту вместо того, чтобы использовать цвет слоя. Каждому объекту можно явно присвоить цвет. Если требуется заменить цвет объекта, заданный на уровне слоя, другим цветом, измените значение цвета объекта с "ПОСЛОЮ" на конкретный цвет, например, красный.

Для установки цвета, назначаемого всем вновь создаваемым объектам, следует воспользоваться панелью свойств, указав нужный цвет вместо значения ПОСЛОЮ.

См. также
    • Переопределение свойств слоя в видовых экранах


Изменение цвета объекта (Процедура)

Установка текущего цвета
На уровень вверх ..
Изменение цвета объекта
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Изменение цвета объекта >
Изменение цвета объекта
Понятие Процедура Краткий справочник

Перенос объекта на другой слой

Для назначения цвета слою

Для явного назначения цвета объекту


Перенос объекта на другой слой (Процедура)

Изменение цвета объекта
На уровень вверх ..
Изменение цвета объекта
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Изменение цвета объекта >
Изменение цвета объекта
Понятие Процедура Краткий справочник

Перенос объекта на другой слой

  1. Выбрать объекты, которые необходимо перенести на другой слой.
  2. На панели "Слои" щелкнуть на управляющем списке "Слой".
  3. Выбрать слой, на который требуется перенести объекты.
Панель:Слои


Для назначения цвета слою (Процедура)

Изменение цвета объекта
На уровень вверх ..
Изменение цвета объекта
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Изменение цвета объекта >
Изменение цвета объекта
Понятие Процедура Краткий справочник

Для назначения цвета слою

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В окне "Диспетчера свойств слоев" выберите цвет, который нужно изменить.
  3. В диалоговом окне "Выбор цвета" выполните одну из следующих операций:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255). Нажмите "ОК".
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" в списке "Цветовая модель" и задайте цвет путем ввода значения цвета в поле "Цвет" или задания значений в полях "H" (Цвет), "S" (Насыщенность) и "L" (Яркость). Нажмите "ОК".
    • На вкладке "Альбомы цветов" выберите из списка альбом цветов и выберите цвет нажатием на цветовой полоске при перемещении по альбому цветов (с помощью стрелок вверх или вниз). Нажмите "ОК".
  4. Нажмите "OK" для закрытия каждого диалогового окна.
Панель:Слои
Ввод команды: СЛОЙ


Для явного назначения цвета объекту (Процедура)

Изменение цвета объекта
На уровень вверх ..
Работа с альбомами цветов
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Изменение цвета объекта >
Изменение цвета объекта
Понятие Процедура Краткий справочник

Для явного назначения цвета объекту

  1. Выберите объекты, цвета которых необходимо изменить.
  2. Щелкните правой кнопкой мыши на одном из объектов. Выберите "Свойства".
  3. В панели "Свойства" выберите свойство "Цвет".

    Справа от поля располагается кнопка со стрелкой.

  4. Нажмите на кнопку и выберите цвет из списка или воспользуйтесь пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В этом случае выполните одно из следующих действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255).
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" в списке "Цветовая модель" и задайте цвет путем ввода значения цвета в поле "Цвет" или задания значений в полях "H" (Цвет), "S" (Насыщенность) и "L" (Яркость). Нажмите "ОК".
    • На вкладке "Вся палитра" выберите цветовую модель "RGB" в списке "Цветовая модель". Задайте цвет путем введения его значения в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
    • На вкладке "Альбомы цветов" выберите из списка альбом цветов и выберите цвет нажатием на цветовой полоске при перемещении по альбому цветов (с помощью стрелок вверх или вниз). Нажмите "ОК".
Ввод команды: ОКНОСВ


Изменение цвета объекта (Краткий справочник)

Установка текущего цвета
Изменение цвета объекта
Работа с альбомами цветов
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Изменение цвета объекта >
Изменение цвета объекта
Понятие Процедура Краткий справочник

Команды

ИЗМЕНИТЬ

Управление свойствами объектов

СВОЙСТВА

Изменение свойств объекта

ЦВЕТ

Задание цвета для вновь создаваемых объектов

ОКНОСВ

Управление свойствами объектов

Системные переменные

CECOLOR

Задание цвета для новых объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с альбомами цветов (Понятие)

Изменение цвета объекта
Работа с цветом
Работа с типами линий
Создание и редактирование объектов > Свойства объектов > Работа с цветом >
Работа с альбомами цветов
Понятие Процедура Краткий справочник

При назначении цвета объектам можно пользоваться альбомами цветов. Работа с альбомами цветов позволяет оперировать широкой палитрой цвета. Альбомы цветов представляют собой файлы от стороннего производителя или пользовательские файлы, которые содержат именованные образцы цветов. Использование цветов из альбомов позволяет улучшить вид чертежа и готовить высококачественные презентационные материалы. Назначение цвета объекту осуществляется с помощью вкладки "Альбомы цветов" в диалоговом окне "Выбор цвета".

Подключение альбомов цветов

Данная программа распознает файлы альбомов цветов только с расширением .acb. Для того, чтобы иметь доступ к цветам из альбомов, необходимо сначала скопировать файлы альбомов в предназначенную для них папку. Расположение альбомов цветов указывается на вкладке "Файлы" диалогового окна "Настройка". Альбомы цветов могут находиться в нескольких папках. Пути к альбомам сохраняются в профиле пользователя.

После подключения нового альбома цветов необходимо закрыть диалоговое окно "Выбор цвета" и открыть его снова. Новый альбом цветов появляется на вкладке "Альбомы цветов". Загрузив альбом цветов, пользователь может применить любой цвет, определенный в этом альбоме цветов, к объектам в своем чертеже.

Просмотр альбомов цветов

Страницы альбомов цветов расположены в порядке возрастания их номеров. На каждой странице представлено до десяти цветов. Если используемый альбом представлен не в виде страниц, цвета распределятся по страницам, при этом на каждой странице будет представлено до семи цветов.


Работа с альбомами цветов (Процедура)

Изменение цвета объекта
На уровень вверх ..
Работа с альбомами цветов
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Работа с альбомами цветов >
Работа с альбомами цветов
Понятие Процедура Краткий справочник

Для подключения альбома цветов

Для поиска цвета в альбоме

Для изменения местоположения альбома цветов, принятого по умолчанию

Для задания нескольких папок с альбомами цветов


Для подключения альбома цветов (Процедура)

Работа с альбомами цветов
На уровень вверх ..
Работа с альбомами цветов
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Работа с альбомами цветов >
Работа с альбомами цветов
Понятие Процедура Краткий справочник

Для подключения альбома цветов

  1. Выберите меню Сервис [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" выберите "Папки для альбомов цветов".
  3. Выберите "Добавить".
  4. Введите новое местоположение альбома.
  5. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Для поиска цвета в альбоме (Процедура)

Работа с альбомами цветов
На уровень вверх ..
Работа с альбомами цветов
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Работа с альбомами цветов >
Работа с альбомами цветов
Понятие Процедура Краткий справочник

Для поиска цвета в альбоме

  1. Выберите меню Формат [image] Цвет.В командной строке введите "цвет".
  2. В диалоговом окне "Цвет", на вкладке "Альбомы цветов" выберите необходимый альбом в списке "Альбом цветов".

    Для активизации текстового поля "Цвет" необходимо выбрать образец цвета из альбома.

  3. Введите номер образца цвета и нажмите ТАВ.

    В альбоме выделяется требуемый цвет или цвет, наиболее близкий к требуемому.

  4. Нажмите "ОК".
Ввод команды: ЦВЕТ


Для изменения местоположения альбома цветов, принятого по умолчанию (Процедура)

Работа с альбомами цветов
На уровень вверх ..
Работа с альбомами цветов
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Работа с альбомами цветов >
Работа с альбомами цветов
Понятие Процедура Краткий справочник

Для изменения местоположения альбома цветов, принятого по умолчанию

  1. Выберите меню Сервис [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" дважды нажмите "Папки для альбомов цветов".
  3. Выберите следующее местоположение альбома цветов:

    C:\Program Files\[текущий номер версии AutoCAD]\support\color

  4. Выберите имя папки для редактирования адреса.
  5. Введите новое местоположение альбома.
  6. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Для задания нескольких папок с альбомами цветов (Процедура)

Работа с альбомами цветов
На уровень вверх ..
Работа с типами линий
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Работа с альбомами цветов >
Работа с альбомами цветов
Понятие Процедура Краткий справочник

Для задания нескольких папок с альбомами цветов

  1. Выберите меню Сервис [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Файлы" выберите "Папки для альбомов цветов".
  3. Выберите "Добавить".
  4. Введите новое местоположение альбома.
  5. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Работа с альбомами цветов (Краткий справочник)

Изменение цвета объекта
Работа с альбомами цветов
Коротко о типах линий
Создание и редактирование объектов > Свойства объектов > Работа с цветом > Работа с альбомами цветов >
Работа с альбомами цветов
Понятие Процедура Краткий справочник

Команды

ИЗМЕНИТЬ

Управление свойствами объектов

СВОЙСТВА

Изменение свойств объекта

ЦВЕТ

Задание цвета для вновь создаваемых объектов

ОКНОСВ

Управление свойствами объектов

Системные переменные

CECOLOR

Задание цвета для новых объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с типами линий

Работа с альбомами цветов
Свойства объектов
Коротко о типах линий
Создание и редактирование объектов > Свойства объектов >
Работа с типами линий
Понятие Процедура

Типы линий применяются для того, чтобы можно было отличить один объект от другого, тем самым, делая работу с чертежом более удобной.

Темы в этом разделе

  • Коротко о типах линий
  • Загрузка типов линий

    В начале работы с проектом происходит загрузка всех типов линий, используемых в чертеже.

  • Установка текущего типа линий

    Все новые объекты создаются с использованием текущего типа линий, установленного в управляющем списке "Типы линий" панели "Свойства".

  • Изменение типа линий объекта

    Тип линий объекта можно изменять, перенося объект на другой слой, изменяя тип линий слоя, где расположен объект, или явно присваивая тип линий самому объекту.

  • Масштабирование типов линий

    Один и тот же тип линий может использоваться в различных масштабах. При этом коэффициент масштабирования пользователь может задавать как для всех объектов сразу, так и отдельно для каждого объекта.

  • Отображение типов линий для коротких сегментов и полилиний

    Пользователь имеет возможность центрировать образец типа линий в пределах каждого сегмента полилинии, а также задавать способ отображения типов линий для коротких сегментов.


Работа с типами линий (Процедура)

Работа с альбомами цветов
Работа с типами линий
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий >
Работа с типами линий
Понятие Процедура

Загрузка типа линий

Для получения списка типов линий, загруженных в текущий чертеж

Для получения списка типов линий из файла описаний типов линий

Для удаления неиспользуемого типа линий

Для очистки чертежа от неиспользуемых типов линий

Для задания типа линий вновь создаваемых объектов

Для назначения типа линий слою

Для назначения слою типа линий, которые будут использоваться по умолчанию

Для назначения типа линий объекту для использования вместо типа линий слоя

Для изменения масштаба типа линий объектов

Для задания масштаба типа линий новых объектов

Для задания глобального масштаба типов линий

Для задания режима генерации типов линий во вновь создаваемых полилиниях

Для изменения режима генерации типов линий в имеющихся полилиниях


Коротко о типах линий (Понятие)

Работа с типами линий
Работа с типами линий
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий >
Коротко о типах линий
Понятие Краткий справочник

Тип линий описывается повторяющейся последовательностью штрихов, точек и пробелов, наносимых вдоль прямой или кривой. Типы линий можно присваивать как слоям, так и отдельным объектам чертежа.

В описании типа линий можно задавать масштаб для регулирования относительных длин штрихов и пробелов. Пользователь имеет возможность создавать собственные типы линий.

ПримечаниеВстроенные в продукт типы линий не следует путать со штриховыми линиями, которые позволяют чертить некоторые типы плоттеров. Штриховая линия AutoCAD и штриховая линия плоттера выглядят одинаково, однако одновременно их использовать не следует, так как результат может оказаться непредсказуемым.
См. также

    • См. раздел Настройка типов линий в документе Руководство по адаптации


Коротко о типах линий (Краткий справочник)

Работа с альбомами цветов
Коротко о типах линий
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Коротко о типах линий >
Коротко о типах линий
Понятие Краткий справочник

Команды

ТИПЛИН

Загрузка, установка и изменение типов линий

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Загрузка типов линий (Понятие)

Коротко о типах линий
Работа с типами линий
Установка текущего типа линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

В начале работы с проектом происходит загрузка всех типов линий, используемых в чертеже.

При необходимости можно получить список всех типов линий, загруженных в чертеж или содержащихся в LIN-файле описаний типов линий.

В комплект этой программы входят файлы определения типов линий acad.lin и acad.lin. Каждый из них предназначен для определенной системы измерений (британской или метрической).

  • В случае британской системы единиц следует работать с файлом acad.lin.
  • В случае метрической системы единиц следует работать с файлом acad.lin.

Оба файла содержат несколько сложных типов линий.

При выборе типа линий, имя которого начинается с ACAD_ISO, во время печати можно устанавливать толщину пера по ISO.

Неиспользуемые типы линий можно удалять командой ОЧИСТИТЬ или с помощью Диспетчера типов линий. Нельзя удалить типы линий ПОБЛОКУ, ПОСЛОЮ и CONTINUOUS.


Загрузка типов линий (Процедура)

Работа с типами линий
На уровень вверх ..
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Загрузка типов линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

Загрузка типа линий

Для получения списка типов линий, загруженных в текущий чертеж

Для получения списка типов линий из файла описаний типов линий

Для удаления неиспользуемого типа линий

Для очистки чертежа от неиспользуемых типов линий


Загрузка типа линий (Процедура)

Загрузка типов линий
На уровень вверх ..
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Загрузка типов линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

Загрузка типа линий

  1. Выберите меню Формат [image] Тип линий.В командной строке введите "типлин".
  2. В "Диспетчере типов линий" нажмите кнопку "Загрузить".
  3. В диалоговом окне "Загрузка/перезагрузка типов линий" выберите тип линий. Нажмите "ОК".

    Если в списке отсутствует необходимый тип линий, щелкнуть "Файл". В диалоговом окне "Выбор файла типов линий" выберите LIN-файл, список типов линий которого нужно получить, и нажмите. Типы линий из выбранного LIN-файла появляются в списке. Выберите тип линий. Нажмите "ОК".

    Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - SHIFT.

  4. Нажмите "ОК".
Ввод команды: ТИПЛИН


Для получения списка типов линий, загруженных в текущий чертеж (Процедура)

Загрузка типов линий
На уровень вверх ..
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Загрузка типов линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

Для получения списка типов линий, загруженных в текущий чертеж

  1. Выберите управляющий список "Типы линий" панели "Свойства".

    Все загруженные типы линий отображаются в виде списка. Для просмотра всего списка можно воспользоваться полосой прокрутки.

  2. Для закрытия списка щелкните мышью вне области списка.


Для получения списка типов линий из файла описаний типов линий (Процедура)

Загрузка типов линий
На уровень вверх ..
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Загрузка типов линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

Для получения списка типов линий из файла описаний типов линий

  1. Выберите меню Формат [image] Тип линий.В командной строке введите "типлин".
  2. В "Диспетчере типов линий" нажмите кнопку "Загрузить".
  3. В диалоговом окне "Загрузка или перезагрузка типов линий" нажмите "Файл".
  4. В диалоговом окне "Выбор файла типов линий" выберите LIN-файл описаний, список типов линий которого нужно получить. Нажмите "Открыть".

    Типы линий из выбранного LIN-файла появляются в списке.

  5. В диалоговом окне "Загрузка/перезагрузка типов линий" нажмите "Отмена".
  6. Нажмите "Отмена" для закрытия "Диспетчера типов линий".
Ввод команды: ТИПЛИН


Для удаления неиспользуемого типа линий (Процедура)

Загрузка типов линий
На уровень вверх ..
Загрузка типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Загрузка типов линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

Для удаления неиспользуемого типа линий

  1. Выберите меню Формат [image] Тип линий.В командной строке введите "типлин".
  2. В списке окна Диспетчера типов линий выберите тип линий. Нажать кнопку "Удалить".

    Выбранный тип линий удаляется. Некоторые типы линий нельзя выгрузить: ПОСЛОЮ, ПОБЛОКУ, CONTINUOUS и все типы линий, которые в настоящий момент используются.

Ввод команды: ТИПЛИН


Для очистки чертежа от неиспользуемых типов линий (Процедура)

Загрузка типов линий
На уровень вверх ..
Установка текущего типа линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Загрузка типов линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

Для очистки чертежа от неиспользуемых типов линий

  1. Выберите вкладку "Инструменты" [image] панель "Утилиты" [image] "Очистить". В командной строке введите "очистить".

    Появляется диалоговое окно "Очистка чертежа", отображающее дерево объектов, которые можно удалить.

  2. Для удаления неиспользуемых типов линий воспользоваться одним из способов:
    • Для очистки чертежа от всех неиспользуемых типов линий выберите "Типы линий".
    • Для очистки чертежа от определенных типов линий дважды нажмите на пункте "Типы линий" для раскрытия списка следующего уровня. Затем выделите типы линий для удаления.

    Если нужные элементы отсутствуют в списке, включить опцию "Просмотреть элементы, которые нельзя удалить".

  3. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  4. Нажмите "Удалить".

    В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.

  5. Нажмите кнопку "Закрыть".
Ввод команды: ОЧИСТИТЬ


Загрузка типов линий (Краткий справочник)

Коротко о типах линий
Загрузка типов линий
Установка текущего типа линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Загрузка типов линий >
Загрузка типов линий
Понятие Процедура Краткий справочник

Команды

ТИПЛИН

Загрузка, установка и изменение типов линий

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

НОВОЕИМЯ

Изменение имен именованных объектов

Системные переменные

MEASUREINIT

Признак используемой по умолчанию системы единиц (британская или метрическая) в чертеже, созданном на основе простейшего шаблона

MEASUREMENT

Признак использования британских или метрических единиц в файлах образцов штриховки или типов линий текущего чертежа

Утилиты

Нет

Ключевые слова для команд

Нет


Установка текущего типа линий (Понятие)

Загрузка типов линий
Работа с типами линий
Изменение типа линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с типами линий >
Установка текущего типа линий
Понятие Процедура Краткий справочник

Все новые объекты создаются с использованием текущего типа линий, установленного в управляющем списке "Типы линий" панели "Свойства".

С помощью управляющего списка типов линий пользователь может установить текущий тип линий.

Если установлен текущий тип линий ПОСЛОЮ, то все создаваемые объекты используют тип линий, присвоенный текущему слою.

Если установлен текущий тип линий ПОБЛОКУ, то объекты имеют тип линий CONTINUOUS, пока они не объединены в блок. Объектам вставляемых в чертеж блоков присваивается текущий тип линий.

Вместо использования текущего типа линий слоя можно назначать тип линий явным образом.

Программа не отображает тип линии определенных объектов: текст, точки, видовые экраны, штриховки и блоки.


Установка текущего типа линий (Процедура)

Загрузка типов линий
На уровень вверх ..
Установка текущего типа линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Установка текущего типа линий >
Установка текущего типа линий
Понятие Процедура Краткий справочник

Для задания типа линий вновь создаваемых объектов

Для назначения типа линий слою


Для задания типа линий вновь создаваемых объектов (Процедура)

Установка текущего типа линий
На уровень вверх ..
Установка текущего типа линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Установка текущего типа линий >
Установка текущего типа линий
Понятие Процедура Краткий справочник

Для задания типа линий вновь создаваемых объектов

  1. Выберите меню Формат [image] Тип линий. В командной строке введите "типлин".
  2. Если необходимо загрузить дополнительные типы линий, нажмите "Загрузить" и выберите один или несколько типов линий. Нажмите "ОК".

    Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - клавиша SHIFT.

  3. В окне Диспетчера типов линий выполнить одно из следующих действий:
    • Выделить тип линий и нажать кнопку "Текущий" для назначения выбранного типа линий всем вновь создаваемым объектам.
    • Выберите значение ПОСЛОЮ для построения новых объектов с текущим типом линий слоя.
    • Выберите значение ПОБЛОКУ для построения новых объектов с типом линий текущего слоя, пока они не объединены в блок. При вставке блока объектам присваивается текущий тип линий, заданный в чертеже.
  4. Нажмите "ОК".
ПримечаниеУстановленный текущий тип линий отображается в управляющем списке "Типы линий". Для установки текущим уже загруженного типа линий нужно раскрыть управляющий список "Типы линий" и выберите нужный тип линий.
Ввод команды: ТИПЛИН


Для назначения типа линий слою (Процедура)

Установка текущего типа линий
На уровень вверх ..
Изменение типа линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Установка текущего типа линий >
Установка текущего типа линий
Понятие Процедура Краткий справочник

Для назначения типа линий слою

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В окне "Диспетчер свойств слоев" выберите заменяемый тип линий.
  3. В диалоговом окне "Выбор типа линий" выберите нужный тип линий. Нажмите "ОК".
  4. Нажмите "ОК" еще раз.
Панель:Слои
Ввод команды: СЛОЙ


Установка текущего типа линий (Краткий справочник)

Загрузка типов линий
Установка текущего типа линий
Изменение типа линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Установка текущего типа линий >
Установка текущего типа линий
Понятие Процедура Краткий справочник

Команды

ТИПЛИН

Загрузка, установка и изменение типов линий

Системные переменные

CELTYPE

Задание типа линий для новых объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение типа линий объекта (Понятие)

Установка текущего типа линий
Работа с типами линий
Масштабирование типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий >
Изменение типа линий объекта
Понятие Процедура Краткий справочник

Тип линий объекта можно изменять, перенося объект на другой слой, изменяя тип линий слоя, где расположен объект, или явно присваивая тип линий самому объекту.

Тип линий объекта можно изменить тремя способами:

  • Перенести объект на другой слой, для которого установлен иной тип линий. Если тип линий объекта имеет значение ПОСЛОЮ, то после переноса на другой слой объект примет тип линий нового слоя.
  • Изменить тип линий слоя, на котором расположен объект. Объект примет тип линий слоя, если в свойствах объекта для типа линий установлено значение ПОСЛОЮ. При изменении типа линий слоя все объекты слоя, типы линий которых заданы значением ПОСЛОЮ, автоматически обновляются с учетом вновь назначенного слою типа линий.
  • Явно присвоить тип линий самому объекту. Каждому объекту можно явно присвоить тип линий. Если требуется переопределить тип линий объекта, назначенный слоем, следует изменить существующий тип линий объекта ПОСЛОЮ на другой тип линий, например, ШТРИХОВАЯ.

Для установки типа линий, назначаемого всем вновь создаваемым объектам, следует воспользоваться панелью "Свойства", указав нужный тип линий вместо значения ПОСЛОЮ.

См. также
    • Переопределение свойств слоя в видовых экранах


Изменение типа линий объекта (Процедура)

Установка текущего типа линий
На уровень вверх ..
Изменение типа линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Изменение типа линий объекта >
Изменение типа линий объекта
Понятие Процедура Краткий справочник

Для назначения слою типа линий, которые будут использоваться по умолчанию

Для назначения типа линий объекту для использования вместо типа линий слоя


Для назначения слою типа линий, которые будут использоваться по умолчанию (Процедура)

Изменение типа линий объекта
На уровень вверх ..
Изменение типа линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Изменение типа линий объекта >
Изменение типа линий объекта
Понятие Процедура Краткий справочник

Для назначения слою типа линий, которые будут использоваться по умолчанию

  2. В окне "Диспетчер свойств слоев" выберите заменяемый тип линий.
  3. В диалоговом окне "Выбор типа линий" выберите тип линий.

    Если в списке отсутствует необходимый тип линий, нажмите кнопку "Загрузить". Выберите тип линий и нажмите "OK", либо нажмите кнопку "Файл" для открытия дополнительных LIN-файлов описаний типов линий.

  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".
Панель:Слои
Ввод команды: СЛОЙ


Для назначения типа линий объекту для использования вместо типа линий слоя (Процедура)

Изменение типа линий объекта
На уровень вверх ..
Масштабирование типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Изменение типа линий объекта >
Изменение типа линий объекта
Понятие Процедура Краткий справочник

Для назначения типа линий объекту для использования вместо типа линий слоя

  1. Выбрать объекты, типы линий которых необходимо изменить.
  2. Выберите управляющий список "Типы линий" панели "Свойства".
  3. Выберите тип линий для назначения объектам.
Ввод команды: ТИПЛИН


Изменение типа линий объекта (Краткий справочник)

Установка текущего типа линий
Изменение типа линий объекта
Масштабирование типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Изменение типа линий объекта >
Изменение типа линий объекта
Понятие Процедура Краткий справочник

Команды

ИЗМЕНИТЬ

Управление свойствами объектов

СВОЙСТВА

Изменение свойств объекта

СЛОЙ

Управление слоями и их свойствами

ТИПЛИН

Загрузка, установка и изменение типов линий

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Масштабирование типов линий (Понятие)

Изменение типа линий объекта
Работа с типами линий
Отображение типов линий для коротких сегментов и полилиний
Создание и редактирование объектов > Свойства объектов > Работа с типами линий >
Масштабирование типов линий
Понятие Процедура Краткий справочник

Один и тот же тип линий может использоваться в различных масштабах. При этом коэффициент масштабирования пользователь может задавать как для всех объектов сразу, так и отдельно для каждого объекта.

По умолчанию коэффициенты масштабирования равны 1.0, как глобально, так и по отдельности. Чем меньше масштаб, тем больше повторений элементарного фрагмента линии генерируется на единицу чертежа. Так, например, при коэффициенте 0.5 в одной единице длины умещается два элементарных фрагмента типа линий. Если длина объекта меньше длины элементарного фрагмента типа линий, то такой объект отрисовывается сплошной линией. В таких случаях для отображения слишком коротких отрезков можно использовать малые значения коэффициента масштабирования типов линий.

В "Диспетчере типов линий" отображаются значения глобального масштаба и масштаба текущего объекта.

  • Глобальный коэффициент масштабирования управляет системной переменной LTSCALE, которая используется для глобального изменения масштаба типа линий для всех объектов - как новых, так и существовавших до этого.
  • Значение масштаба текущего объекта управляет системной переменной CELTSCALE, которая задает изменяет масштаб типа линий новых объектов.

Отображаемый масштаб типов линий определяется путем умножения значения CELTSCALE на значение LTSCALE. Пользователь может легко изменять в чертеже как текущий, так и глобальный масштабы типов линий.

Настройка масштаба типов линий на различных видовых экранах листа выполняется с помощью системной переменной PSLTSCALE.


Масштабирование типов линий (Процедура)

Изменение типа линий объекта
На уровень вверх ..
Масштабирование типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Масштабирование типов линий >
Масштабирование типов линий
Понятие Процедура Краткий справочник

Для изменения масштаба типа линий объектов

Для задания масштаба типа линий новых объектов

Для задания глобального масштаба типов линий


Для изменения масштаба типа линий объектов (Процедура)

Масштабирование типов линий
На уровень вверх ..
Масштабирование типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Масштабирование типов линий >
Масштабирование типов линий
Понятие Процедура Краткий справочник

Для изменения масштаба типа линий объектов

  1. Выберите объекты, масштаб типов линий которых необходимо изменить.
  2. Нажмите правую кнопку мыши на одном из объектов. Нажмите кнопку "Свойства".
  3. В палитре "Свойства" в поле "Масштаб типа линий" введите новое значение.
Панель:Стандартная
Ввод команды: ОКНОСВ


Для задания масштаба типа линий новых объектов (Процедура)

Масштабирование типов линий
На уровень вверх ..
Масштабирование типов линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Масштабирование типов линий >
Масштабирование типов линий
Понятие Процедура Краткий справочник

Для задания масштаба типа линий новых объектов

  1. Выберите меню Формат [image] Тип линий.В командной строке введите "типлин".
  2. В окне "Диспетчер типов линий" нажмите кнопку "Вкл подробности".
  3. Ввести значение в поле "Текущий масштаб".
  4. Нажмите "ОК".
Ввод команды: ТИПЛИН


Для задания глобального масштаба типов линий (Процедура)

Масштабирование типов линий
На уровень вверх ..
Отображение типов линий для коротких сегментов и полилиний
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Масштабирование типов линий >
Масштабирование типов линий
Понятие Процедура Краткий справочник

Для задания глобального масштаба типов линий

  1. Выберите меню Формат [image] Тип линий.В командной строке введите "типлин".
  2. В окне "Диспетчер типов линий" нажмите кнопку "Вкл подробности".
  3. Введите значение в поле "Глобальный масштаб".
  4. Нажмите "ОК".
Ввод команды: ТИПЛИН


Масштабирование типов линий (Краткий справочник)

Изменение типа линий объекта
Масштабирование типов линий
Отображение типов линий для коротких сегментов и полилиний
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Масштабирование типов линий >
Масштабирование типов линий
Понятие Процедура Краткий справочник

Команды

ТИПЛИН

Загрузка, установка и изменение типов линий

Системные переменные

CELTSCALE

Задание текущего коэффициента масштабирования для типа линий объекта

LTSCALE

Глобальный масштаб типов линий

PSLTSCALE

Управление масштабированием типов линий в пространстве листа

Утилиты

Нет

Ключевые слова для команд

Нет


Отображение типов линий для коротких сегментов и полилиний (Понятие)

Масштабирование типов линий
Работа с типами линий
Работа с весами линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий >
Отображение типов линий для коротких сегментов и полилиний
Понятие Процедура Краткий справочник

Пользователь имеет возможность центрировать образец типа линий в пределах каждого сегмента полилинии, а также задавать способ отображения типов линий для коротких сегментов.

Если линия слишком коротка для того, чтобы вместить одну штриховую последовательность, то между двумя конечными точками будет проведена непрерывная линия, как показано на иллюстрации ниже.

Рекомендуется уменьшать масштаб типов линий для подобных сегментов. Дополнительные сведения см. в разделе Масштабирование типов линий.

Для полилинии имеется возможность центрировать образец типа линий в пределах каждого сегмента, либо размещать его непрерывно по всей ее длине. Управляет этими режимами системная переменная PLINEGEN.


Отображение типов линий для коротких сегментов и полилиний (Процедура)

Масштабирование типов линий
На уровень вверх ..
Отображение типов линий для коротких сегментов и полилиний
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Отображение типов линий для коротких сегментов и полилиний >
Отображение типов линий для коротких сегментов и полилиний
Понятие Процедура Краткий справочник

Для задания режима генерации типов линий во вновь создаваемых полилиниях

Для изменения режима генерации типов линий в имеющихся полилиниях


Для задания режима генерации типов линий во вновь создаваемых полилиниях (Процедура)

Отображение типов линий для коротких сегментов и полилиний
На уровень вверх ..
Отображение типов линий для коротких сегментов и полилиний
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Отображение типов линий для коротких сегментов и полилиний >
Отображение типов линий для коротких сегментов и полилиний
Понятие Процедура Краткий справочник

Для задания режима генерации типов линий во вновь создаваемых полилиниях

  1. В командной строке введите plinegen.
  2. Введите 1 для разрешения непрерывной генерации образца типа линий по всей длине двумерной полилинии. Чтобы расположить образец типа линии по центру на каждом сегмента, введите 0.
Ввод команды: PLINEGEN


Для изменения режима генерации типов линий в имеющихся полилиниях (Процедура)

Отображение типов линий для коротких сегментов и полилиний
На уровень вверх ..
Работа с весами линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Отображение типов линий для коротких сегментов и полилиний >
Отображение типов линий для коротких сегментов и полилиний
Понятие Процедура Краткий справочник

Для изменения режима генерации типов линий в имеющихся полилиниях

  1. Двойным щелчком выберите полилинию, для которой нужно изменить режим генерации типа линий.
  2. В палитре "Свойства" задайте для свойства "Генерация типа линий" значение "Вкл" или "Откл".
Панель:Стандартная
Ввод команды: ОКНОСВ


Отображение типов линий для коротких сегментов и полилиний (Краткий справочник)

Масштабирование типов линий
Отображение типов линий для коротких сегментов и полилиний
Коротко о весах линий
Создание и редактирование объектов > Свойства объектов > Работа с типами линий > Отображение типов линий для коротких сегментов и полилиний >
Отображение типов линий для коротких сегментов и полилиний
Понятие Процедура Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

Системные переменные

PLINEGEN

Управление созданием типа линии вокруг вершин двумерных полилиний

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с весами линий

Отображение типов линий для коротких сегментов и полилиний
Свойства объектов
Коротко о весах линий
Создание и редактирование объектов > Свойства объектов >
Работа с весами линий
Понятие Процедура

Пользователь может управлять толщиной линий объектов как при отображении чертежа на экране, так и при выводе его на печать.

Темы в этом разделе

  • Коротко о весах линий
  • Отображение весов линий

    В чертеже веса линий можно включать и отключать. При этом они по разному отображаются в пространствах модели и листа.

  • Установка текущего веса линий

    Текущий вес линий используется при построении всех объектов.

  • Изменение веса линий объекта

    Вес линий объекта можно изменять, перенося объект на другой слой, изменяя вес линий слоя, на котором расположен объект, или явно присваивая вес линий самому объекту.


Работа с весами линий (Процедура)

Отображение типов линий для коротких сегментов и полилиний
Работа с весами линий
Коротко о весах линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий >
Работа с весами линий
Понятие Процедура

Для назначения ширины полилиниям

Назначение веса линий слою

Для задания масштаба экранного отображения весов линий в пространстве модели

Для показа или скрытия весов линий

Для установки веса линий вновь создаваемых объектов

Изменение толщины линий, из которых состоят полилинии, кольца, прямоугольники и многоугольники


Коротко о весах линий (Понятие)

Работа с весами линий
Работа с весами линий
Отображение весов линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий >
Коротко о весах линий
Понятие Процедура Краткий справочник

Веса линий представляют собой значения ширины, назначаемые графическим объектам и некоторым типам текста.

Веса линий позволяют получать тонкие и толстые линии, что полезно при оформлении чертежей (построение разрезов и сечений, показ уровней, нанесение размеров, засечек, отображение различий в деталях). Например, назначив слоям различные веса линий, можно облегчить идентификацию зданий, находящихся в эксплуатации, строящихся или подлежащих сносу. Для отображения линий по весам следует включить кнопку "ВЕС" в строке состояния.

В шрифтах True Type, растровых изображениях, точках и заливках (для 2D фигур) веса линий не используются. В широких полилиниях веса линий используются при отображении, но только не в виде сверху. Информация о весе линий сохраняется при экспорте чертежа в другие форматы и при копировании объектов в буфер обмена.

В пространстве модели каждому значению веса линий соответствует определенное число пикселов, определяющих видимую на экране толщину линий, независимую от выполнения зумирования. В связи с этим, в пространстве модели видимая толщина линий может не соответствовать их действительной толщине. Так, например, для отображения полилинии с действительной толщиной 5 миллиметров следует устанавливать не вес линий, а толщину полилинии в соответствующее значение.

Веса линий можно также использовать для управления выводом объектов на печать. Это делается с помощью Редактора таблиц стилей печати.

Масштабирование весов линий в чертежах

При выводе на печать толщина начертания объекта определяется назначенным ему весом линий. Стандартные параметры для этих значений: ПОСЛОЮ, ПОБЛОКУ и "По умолчанию". Значения весов линий могут выражаться в миллиметрах или дюймах (по умолчанию используются миллиметры). Начальный вес линий для всех слоев определяется системной переменной LWDEFAULT и по умолчанию равен 0.25 мм.

В пространстве модели значение веса линий, равное или меньшее 0.025 мм, соответствует линии толщиной в один пиксел, а при выводе на печать - наименьшей величине, обеспечиваемой данным печатающим устройством. Значения весов линий, вводимые в командной строке, округляются до ближайшего стандартного значения.

Выберите единицы представления веса линий и задайте значение для веса ОБЫЧНЫЙ можно в диалоговом окне "Параметры весов линий". К диалоговому окну "Параметры весов линий" можно получить доступ с помощью команды ВЕСЛИН, нажав правую кнопку мыши на кнопке "Вес" в строке состояния и выбрав "Параметры", или выбрав "Параметры весов линий" в таблице "Предпочтения пользователя" диалогового окна "Настройка".

См. также

    • Построение полилиний


Коротко о весах линий (Процедура)

Работа с весами линий
На уровень вверх ..
Коротко о весах линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Коротко о весах линий >
Коротко о весах линий
Понятие Процедура Краткий справочник

Для назначения ширины полилиниям

Назначение веса линий слою

Для задания масштаба экранного отображения весов линий в пространстве модели


Для назначения ширины полилиниям (Процедура)

Коротко о весах линий
На уровень вверх ..
Коротко о весах линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Коротко о весах линий >
Коротко о весах линий
Понятие Процедура Краткий справочник

Для назначения ширины полилиниям

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку первого сегмента полилинии.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Введите значение ширины в конце линейного сегмента.
  6. Укажите конечную точку первого сегмента полилинии.
  7. Введите ш для задания ширины следующего сегмента или нажмите ENTER для завершения команды.
Панель:Рисование
Ввод команды: ПЛИНИЯ


Назначение веса линий слою (Процедура)

Коротко о весах линий
На уровень вверх ..
Коротко о весах линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Коротко о весах линий >
Коротко о весах линий
Понятие Процедура Краткий справочник

Назначение веса линий слою

  1. Выберите вкладку "Главная" [image] панель "Слои" [image] "Слой". В командной строке введите "слой".
  2. В окне Диспетчера свойств слоев выберите слой. Щелкните вес линий, связанный с этим слоем.
  3. В диалоговом окне "Вес линий" выберите из списка вес линий.
  4. Нажмите "OK" для закрытия каждого диалогового окна.
Ввод команды: СЛОЙ


Для задания масштаба экранного отображения весов линий в пространстве модели (Процедура)

Коротко о весах линий
На уровень вверх ..
Отображение весов линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Коротко о весах линий >
Коротко о весах линий
Понятие Процедура Краткий справочник

Для задания масштаба экранного отображения весов линий в пространстве модели

  1. Выберите меню Формат [image] Вес линий.В командной строке введите "веслин".
  2. В диалоговом окне "Параметры весов линий" в группе "Масштаб экранного отображения" изменить положение указателя скользящей шкалы.
  3. Нажмите "ОК".
Ввод команды: СЛОЙ, ВЕСЛИН


Коротко о весах линий (Краткий справочник)

Отображение типов линий для коротких сегментов и полилиний
Коротко о весах линий
Отображение весов линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Коротко о весах линий >
Коротко о весах линий
Понятие Процедура Краткий справочник

Команды

ВЕСЛИН

Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий

ПЛИНИЯ

Создание 2D полилинии

Системные переменные

LWDEFAULT

Значение для веса линий по умолчанию

LWDISPLAY

Управление отображением веса линий

LWUNITS

Единицы измерения для весов линий (дюймы или миллиметры)

Утилиты

Нет

Ключевые слова для команд

Нет


Отображение весов линий (Понятие)

Коротко о весах линий
Работа с весами линий
Установка текущего веса линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий >
Отображение весов линий
Понятие Процедура Краткий справочник

В чертеже веса линий можно включать и отключать. При этом они по разному отображаются в пространствах модели и листа.

  • Значению веса линий 0 в пространстве модели всегда соответствует линия толщиной в один пиксел. Толщина отображения остальных весов линий (в пикселах) устанавливается пропорционально их точным значениям.
  • В пространстве листа видимая на экране толщина начертания объекта устанавливается равной точному значению его веса линий.

Следует отметить, что если используемые веса линий представляются более чем одним пикселом, то время регенерации чертежа возрастает. Чтобы оптимизировать производительность программы, отключите отображение толщины линий.

Включать и отключать отображение весов линий можно нажатием кнопки "ВЕС" в строке состояния. Данная опция не влияет на вывод весов линий при печати.

Отображение весов линий в пространстве модели

В пространстве модели в режиме отображения весов линий толщина начертания любого объекта не зависит от коэффициента масштабирования. Например, если весу линий соответствует толщина в четыре пиксела, то объекты с таким весом всегда отрисовываются линией толщиной четыре пиксела, даже при увеличении экранного изображения до максимально возможного значения. Для изменения масштаба отображения веса линий в пространстве модели следует использовать команду ВЕСЛИН. Изменение масштаба отображения не влияет на толщину линий при выводе на печать.

В пространстве модели соединения отрезков, отображаемых с учетом весов линий, строятся в виде скосов без использования торцевых ограничителей. Однако при выводе на печать с использованием стилей печати можно задавать различные типы соединений и окончаний линий для различных весов линий.

ПримечаниеКорректное экранное отображение участков соединений и окончаний объектов с весом линий возможно лишь при выполнении полного просмотра.

Отображение весов линий в пространстве листа

В пространстве листа и в режиме предварительного просмотра видимая на экране толщина начертания отдельного объекта пропорциональна значению веса линий и текущему коэффициенту масштабирования. Поэтому при зумировании видимая толщина объектов изменяется. Учет весов линий при выводе чертежа на печать можно включать/отключать на вкладке "Параметры печати" диалогового окна "Печать".


Для показа или скрытия весов линий (Процедура)

Коротко о весах линий
На уровень вверх ..
Установка текущего веса линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Отображение весов линий >
Отображение весов линий
Понятие Процедура Краткий справочник

Для показа или скрытия весов линий

Воспользуйтесь одним из следующих способов:

  • Нажмите кнопку "ВЕС" в строке состояния.
  • Установите или сбросьте флажок "Отображать линии в соответствии с весами" в диалоговом окне "Параметры весов линий".
  • Задайте для системной переменной LWDISPLAY значение 0 или 1
Ввод команды: ВЕСЛИН


Отображение весов линий (Краткий справочник)

Коротко о весах линий
Отображение весов линий
Установка текущего веса линий
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Отображение весов линий >
Отображение весов линий
Понятие Процедура Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

ВЕСЛИН

Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ПЛИНИЯ

Создание 2D полилинии

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

LWDEFAULT

Значение для веса линий по умолчанию

LWDISPLAY

Управление отображением веса линий

LWUNITS

Единицы измерения для весов линий (дюймы или миллиметры)

PLINEWID

Значение по умолчанию для ширины полилинии

Утилиты

Нет

Ключевые слова для команд

Нет


Установка текущего веса линий (Понятие)

Отображение весов линий
Работа с весами линий
Изменение веса линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с весами линий >
Установка текущего веса линий
Понятие Процедура Краткий справочник

Текущий вес линий используется при построении всех объектов.

Все новые объекты создаются с использованием текущего веса линий, установленного в управляющем списке "Веса линий" панели "Свойства". Пользователь может также установить текущий вес линий с помощью управляющего списка весов линий.

Если установлен текущий вес линий ПОСЛОЮ, то все создаваемые объекты используют вес линий, присвоенный текущему слою.

Если установлен текущий вес линий ПОБЛОКУ, то объекты, пока они не объединены в блок, создаются с весом линий, установленным по умолчанию. Вставляемым в чертеж блокам присваивается текущий вес линий.

Вместо того, чтобы строить объекты, наследуя вес линий слоя, можно назначать вес линий явным образом.

Объектам чертежей, созданных в предыдущих версиях AutoCAD, назначается вес линий ПОСЛОЮ, а всем слоям таких чертежей назначается вес линий ОБЫЧНЫЙ. Отображение объекта с использованием присвоенного ему веса линий подобно включению закрашивания, которое поддерживают некоторые типы объектов.


Для установки веса линий вновь создаваемых объектов (Процедура)

Отображение весов линий
На уровень вверх ..
Изменение веса линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Установка текущего веса линий >
Установка текущего веса линий
Понятие Процедура Краткий справочник

Для установки веса линий вновь создаваемых объектов

  1. Выберите меню Формат [image] Вес линий.В командной строке введите "веслин".
  2. В диалоговом окне "Параметры весов линий" выберите в списке вес линий.
  3. Нажмите "ОК".
ПримечаниеДля отображения текущего значения веса линий установите флажок "Отображать линии в соответствии с весами" в диалоговом окне "Параметры весов линий".
Ввод команды: СЛОЙ, ВЕСЛИН


Установка текущего веса линий (Краткий справочник)

Отображение весов линий
Установка текущего веса линий
Изменение веса линий объекта
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Установка текущего веса линий >
Установка текущего веса линий
Понятие Процедура Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

ВЕСЛИН

Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ПЛИНИЯ

Создание 2D полилинии

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

LWDEFAULT

Значение для веса линий по умолчанию

LWDISPLAY

Управление отображением веса линий

LWUNITS

Единицы измерения для весов линий (дюймы или миллиметры)

PLINEWID

Значение по умолчанию для ширины полилинии

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение веса линий объекта (Понятие)

Установка текущего веса линий
Работа с весами линий
Управление отображением отдельных объектов
Создание и редактирование объектов > Свойства объектов > Работа с весами линий >
Изменение веса линий объекта
Понятие Процедура Краткий справочник

Вес линий объекта можно изменять, перенося объект на другой слой, изменяя вес линий слоя, на котором расположен объект, или явно присваивая вес линий самому объекту.

Вес линий объекта можно изменить тремя способами:

  • Перенести объект на другой слой, для которого установлен иной вес линий. В этом случае, если вес линий объекта имеет значение ПОСЛОЮ, то после переноса объект примет вес линий нового слоя.
  • Изменить вес линий слоя, на котором расположен объект. Объект примет вес линий слоя, если в свойствах объекта установлено значение веса линий ПОСЛОЮ. При изменении веса линий слоя все объекты, веса линий которых заданы значением ПОСЛОЮ, обновляются с учетом измененного веса линий.
  • Явно присвоить вес линий самому объекту. Каждому объекту можно явно присвоить вес линий. Если требуется переопределить вес линий, назначенный слоем, следует изменить существующий вес линий объекта ПОСЛОЮ на другой.

Для установки веса линий, назначаемого всем вновь создаваемым объектам, следует воспользоваться панелью "Свойства", указав нужный вес линий вместо значения ПОСЛОЮ.

См. также
    • Переопределение свойств слоя в видовых экранах


Изменение толщины линий, из которых состоят полилинии, кольца, прямоугольники и многоугольники (Процедура)

Установка текущего веса линий
На уровень вверх ..
Управление отображением отдельных объектов
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Изменение веса линий объекта >
Изменение веса линий объекта
Понятие Процедура Краткий справочник

Изменение толщины линий, из которых состоят полилинии, кольца, прямоугольники и многоугольники

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Редактировать полилинию". В командной строке введите "полред".
  2. Выберите одну или несколько полилиний.
  3. Введите ш (Ширина), затем укажите значение ширины для всех сегментов.
  4. Нажмите ENTER для завершения команды.
Панель:Редактирование-2
Ввод команды: ПОЛРЕД


Изменение веса линий объекта (Краткий справочник)

Установка текущего веса линий
Изменение веса линий объекта
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Создание и редактирование объектов > Свойства объектов > Работа с весами линий > Изменение веса линий объекта >
Изменение веса линий объекта
Понятие Процедура Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

ВЕСЛИН

Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ПЛИНИЯ

Создание 2D полилинии

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

LWDEFAULT

Значение для веса линий по умолчанию

LWDISPLAY

Управление отображением веса линий

LWUNITS

Единицы измерения для весов линий (дюймы или миллиметры)

PLINEWID

Значение по умолчанию для ширины полилинии

Утилиты

Нет

Ключевые слова для команд

Нет


Управление отображением отдельных объектов

Изменение веса линий объекта
Свойства объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Создание и редактирование объектов > Свойства объектов >
Управление отображением отдельных объектов
Понятие Процедура

Пользователь имеет возможность управлять экранным отображением и выводом на печать объектов (включая перекрывающиеся).

Темы в этом разделе

  • Отображение полилиний, штриховок, градиентных заливок, весов линий и текста

    Для повышения производительности можно упростить отображение некоторых объектов.

  • Управление отображением перекрывающихся объектов

    Пользователь имеет возможность указывать, какие из перекрывающихся объектов должны располагаться на переднем плане.


Управление отображением отдельных объектов (Процедура)

Изменение веса линий объекта
Управление отображением отдельных объектов
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов >
Управление отображением отдельных объектов
Понятие Процедура

Для включения и отключения заливки

Включение и отключение вывода текста

Включение и отключение весов линий

Для изменения порядка следования перекрывающихся объектов


Отображение полилиний, штриховок, градиентных заливок, весов линий и текста (Понятие)

Управление отображением отдельных объектов
Управление отображением отдельных объектов
Управление отображением перекрывающихся объектов
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов >
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятие Процедура Краткий справочник

Для повышения производительности можно упростить отображение некоторых объектов.

Производительность отображения можно повысить за счет упрощения отображения широких полилиний, колец, закрашенных двумерных многоугольников (фигур), штриховок, градиентных заливок и текста. В таком виде чертеж вполне пригоден для печати черновых экземпляров.

Отключение режима заливки

При отключении режима заливки широкие полилинии, закрашенные многоугольники, градиентные заливки и штриховки отображаются в виде контуров. На видах с подавленными скрытыми линиями, а также на видах, не являющихся видами в плане, отображение заливки (кроме штриховок по образцам и градиентных закрасок) автоматически отключается.

Использование режима контурного текста

Если включить режим контурного текста в чертеже, содержащем текстовые надписи, то на экран и на печать будут выводиться только их ограничивающие прямоугольники.

Отключение весов линий

Все линии на экране, имеющие более одного пиксела в ширину, замедляют производительность обработки чертежа. Если необходимо повысить производительность отображения, то можно отключить веса линий. Веса линий можно включать и отключать, нажимая кнопку "ВЕС" в строке состояния или используя диалоговое окно "Параметры весов линий". На печать веса линий выводятся всегда, отображая тем самым действительную толщину линий на чертеже.

Обновление экрана

При создании новых объектов автоматически используются текущие настройки отображения заливки и текста. Но для изменения свойств отображения (кроме весов линий) уже имеющихся объектов требуется вызвать команду РЕГЕН.

См. также

    • Применение слоев для организации чертежей

    • Отображение весов линий

    • Использование шрифтов TrueType


Отображение полилиний, штриховок, градиентных заливок, весов линий и текста (Процедура)

Управление отображением отдельных объектов
На уровень вверх ..
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов > Отображение полилиний, штриховок, градиентных заливок, весов линий и текста >
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятие Процедура Краткий справочник

Для включения и отключения заливки

Включение и отключение вывода текста

Включение и отключение весов линий


Для включения и отключения заливки (Процедура)

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
На уровень вверх ..
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов > Отображение полилиний, штриховок, градиентных заливок, весов линий и текста >
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятие Процедура Краткий справочник

Для включения и отключения заливки

  1. Выберите меню Сервис [image] Настройка. В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Отображение" в разделе "Производительность отображения" выберите "Показывать заливку".

    Если флажок установлен, режим заливки включен.

  3. Нажмите "ОК".
  4. Для отображения изменений выберите меню Вид [image] Регенерировать.Для отображения изменений введите в командной строке "реген".
Ввод команды: НАСТРОЙКА, РЕГЕН


Включение и отключение вывода текста (Процедура)

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
На уровень вверх ..
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов > Отображение полилиний, штриховок, градиентных заливок, весов линий и текста >
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятие Процедура Краткий справочник

Включение и отключение вывода текста

  1. Выберите меню Сервис [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Отображение" в разделе "Производительность отображения" выберите "Только границы текстов".

    Если флажок активен, вместо текста выводится окружающая его рамка.

  3. Нажмите "ОК".
  4. Для отображения изменений выберите меню Вид [image] Регенерировать.Для отображения изменений введите в командной строке "реген".
Ввод команды: НАСТРОЙКА, РЕГЕН


Включение и отключение весов линий (Процедура)

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
На уровень вверх ..
Управление отображением перекрывающихся объектов
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов > Отображение полилиний, штриховок, градиентных заливок, весов линий и текста >
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятие Процедура Краткий справочник

Включение и отключение весов линий

  1. Выберите меню Формат [image] Вес линий.В командной строке введите "веслин".
  2. Установите или сбросьте флажок "Отображать линии в соответствии с весами" в диалоговом окне "Параметры весов линий".
  3. Нажмите "ОК".
Ввод команды: ВЕСЛИН


Отображение полилиний, штриховок, градиентных заливок, весов линий и текста (Краткий справочник)

Изменение веса линий объекта
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Управление отображением перекрывающихся объектов
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов > Отображение полилиний, штриховок, градиентных заливок, весов линий и текста >
Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Понятие Процедура Краткий справочник

Команды

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

ЗАКРАШИВАНИЕ

Управление закрашиванием таких объектов, как штриховки, 2D фигуры и широкие полилинии

ВЕСЛИН

Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий

КТЕКСТ

Управление отображением и выводом на плоттер текста и атрибутов

РЕГЕН

Регенерация чертежа и перерисовка содержимого текущего видового экрана

Системные переменные

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

LWDISPLAY

Управление отображением веса линий

QTEXTMODE

Управление отображением текста

TEXTFILL

Управление заливкой шрифтов TrueType во время печати или тонирования

TEXTQLTY

Задание качества начертания контуров текста

Утилиты

Нет

Ключевые слова для команд

Нет


Управление отображением перекрывающихся объектов (Понятие)

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Управление отображением отдельных объектов
Средства обеспечения точности
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов >
Управление отображением перекрывающихся объектов
Понятие Процедура Краткий справочник

Пользователь имеет возможность указывать, какие из перекрывающихся объектов должны располагаться на переднем плане.

Как правило, такие объекты, как тексты, широкие полилинии и закрашенные многоугольники выводятся на экран в порядке их создания, т.е. ранее созданные объекты отображаются позади новых объектов. Команда ПОРЯДОК изменяет порядок прорисовки (т.е. отображения на экране и вывода на плоттер) всех текстов и размеров в чертеже. ТЕКСТПЕРПЛАН изменяет порядок прорисовки всех текстовых и размерных надписей на чертеже.

ПримечаниеЗадание порядка вывода перекрывающихся объектов, общего для пространств модели и листа, невозможно. Для каждого пространства порядок вывода объектов устанавливается отдельно.


Для изменения порядка следования перекрывающихся объектов (Процедура)

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
На уровень вверх ..
Координаты и системы координат (ПСК)
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов > Управление отображением перекрывающихся объектов >
Управление отображением перекрывающихся объектов
Понятие Процедура Краткий справочник

Для изменения порядка следования перекрывающихся объектов

  1. На панели "Порядок прорисовки" выберите одну из опций порядка следования.
  2. Выберите объекты, чей порядок прорисовки необходимо изменить и нажмите ENTER.
  3. Выберите объекты, относительно которых устанавливается порядок и нажмите ENTER. (Этот шаг необходим только для опций "Перед объектами" и "За объектами".)
Панель: Порядок прорисовки
Ввод команды: ПОРЯДОК
Контекстное меню:Выберите объект и нажмите на нем правой кнопкой мыши. Выберите "Порядок прорисовки"


Управление отображением перекрывающихся объектов (Краткий справочник)

Отображение полилиний, штриховок, градиентных заливок, весов линий и текста
Управление отображением перекрывающихся объектов
Методы записи координат
Создание и редактирование объектов > Свойства объектов > Управление отображением отдельных объектов > Управление отображением перекрывающихся объектов >
Управление отображением перекрывающихся объектов
Понятие Процедура Краткий справочник

Команды

ПОРЯДОК

Изменение порядка прорисовки растровых изображений и других объектов на экране

БВЫБОР

Быстрое создание набора объектов на основе заданных критериев фильтрации

РЕГЕН

Регенерация чертежа и перерисовка содержимого текущего видового экрана

ВЫБРАТЬ

Занесение выбранных объектов в текущий набор

ТЕКСТПЕРПЛАН

Размещение текста и размеров поверх всех остальных объектов чертежа

ПБЛОК

Запись объектов или блока в новый файл чертежа

Системные переменные

DRAWORDERCTL

Управление порядком отображения перекрывающихся объектов

HPDRAWORDER

Управление порядком прорисовки штриховки или заливки

SORTENTS

Управление сортировкой объектов в соответствии с порядком прорисовки для некоторых операций

Утилиты

Нет

Ключевые слова для команд

Нет


Средства обеспечения точности

Управление отображением перекрывающихся объектов
Создание и редактирование объектов
Координаты и системы координат (ПСК)
Создание и редактирование объектов >
Средства обеспечения точности

В распоряжении пользователя имеются различные средства, обеспечивающие быстрое и точное построение чертежей без выполнения утомительных расчетов.

Темы в этом разделе

  • Координаты и системы координат (ПСК)

    Для точного ввода координат можно использовать методы записи в нескольких системах координат. Можно также использовать перемещаемую систему координат, пользовательскую систему координат (ПСК), обеспечивающую удобство записи координат и размещения плоскостей видов чертежа.

  • Использование динамического ввода

    Функция динамического ввода обеспечивает командный интерфейс в области курсора, позволяющий удерживать фокус в области построения.

  • Объектная привязка

    Вместо ввода значений координат пользователь имеет возможность задавать точки, привязывая курсор к характерным точками имеющихся объектов (к конечным точкам отрезков, центрам кругов и т.д.).

  • Ограничение перемещения курсора

    Пользователю предоставляются различные средства для ограничения и блокирования перемещения курсора.

  • Комбинирование и смещение точек и координат

    Чтобы задать новое положение точки, можно объединить координатные значения из нескольких точек или указать смещения от существующих объектов.

  • Задание расстояний

    При указании точек можно вводить значения расстояний, смещений и интервалов.

  • Получение геометрической информации от объектов

    Пользователю предоставлен ряд команд для получения справочной информации об объектах чертежа и выполнения математических расчетов.

  • Использование калькулятора

    При работе с программой можно пользоваться функциями калькулятора. Предусмотрено два варианта калькулятора: калькулятор с графическим интерфейсом БыстрКальк и калькулятор командной строки.


Координаты и системы координат (ПСК)

Средства обеспечения точности
Средства обеспечения точности
Методы записи координат
Создание и редактирование объектов > Средства обеспечения точности >
Координаты и системы координат (ПСК)
Понятие Процедура

Для точного ввода координат можно использовать методы записи в нескольких системах координат. Можно также использовать перемещаемую систему координат, пользовательскую систему координат (ПСК), обеспечивающую удобство записи координат и размещения плоскостей видов чертежа.

Темы в этом разделе

  • Методы записи координат
  • 2D декартовы координаты

    С помощью абсолютных и относительных декартовых и полярных 2D координат определяются точные положения объектов на чертеже.

  • 3D координаты

    При создании объектов в 3D пространстве для указания точек используются декартовы, цилиндрические или сферические координаты.

  • Понятие о пользовательской системе координат (ПСК)

    Пользовательскую систему координат можно перемещать и поворачивать для обеспечения удобства записи координат, отображения сетки, привязки к сетке, реализации режима "Орто" и использования других инструментов создания чертежей.

  • Задание плоскостей видов чертежа в 3D (ПСК)

    Возможность управления пользовательской системой координат (ПСК) является важным условием для эффективного построения моделей в трехмерном пространстве.

  • Назначение пользовательской системы координат видовому экрану

    Чтобы облегчить редактирование объектов на различных видах, можно определить отличную от других ориентацию ПСК для каждого вида.

  • Знак пользовательской системы координат

    Для облегчения работы с ПСК можно воспользоваться знаком пользовательской системы координат. Имеется несколько вариантов этого знака. Можно изменять его размеры, расположение и цвет.


Координаты и системы координат (ПСК) (Процедура)

Управление отображением перекрывающихся объектов
Координаты и системы координат (ПСК)
Методы записи координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
Координаты и системы координат (ПСК)
Понятие Процедура

Для отображения координат точки

Для визуального определения местоположения точки

Для переключения режима отображения координат в строке состояния

Определение новой исходной точки ПСК в 2D

Изменение угла поворота ПСК

Восстановление ПСК для совмещения с МСК

Для восстановления предыдущей ПСК

Для сохранения ПСК

Для восстановления именованной ПСК

Для переименования ПСК

Удаление именованной ПСК

Для включения и отключения знака ПСК

Для установки знака ПСК в начало координат

Для настройки параметров знака ПСК


Методы записи координат (Понятие)

Координаты и системы координат (ПСК)
Координаты и системы координат (ПСК)
2D декартовы координаты
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
Методы записи координат
Понятие Процедура Краткий справочник

В ответ на запросы ввода координат пользователь имеет возможность указывать точки с помощью устройства указания или путем ввода значений координат в командной строке. Когда включен параметр "Динамический ввод", можно ввести значения координат в подсказках рядом с курсором. Двумерные координаты могут вводиться как в декартовой (прямоугольной), так и в полярной системе.

Декартовы и полярные координаты

Декартова система координат представляет собой три взаимно перпендикулярные оси: X, Y и Z. При вводе значений координат указывается расстояние для точки (в единицах) и его направление (+ или -) по осям X, Y и Z относительно исходной точки системы координат (0,0,0).

В системе 2D указываются точки в плоскости XY, именуемой также плоскостью видов чертежа. Плоскость видов чертежа подобна листу бумаги в клетку. Значение X в декартовых координатах определяет расстояние по горизонтали, а значение Y определяет расстояние по вертикали. Началом координат считается точка пересечения координатных осей, имеющая координаты (0,0).

В полярной системе координаты точки представляют собой расстояние и угол, отсчитываемые от начала координат. В обоих случаях координаты можно задавать либо в абсолютной, либо в относительной форме. Абсолютные координаты отсчитываются от начала координат (0,0). Относительные координаты отсчитываются от последней указанной точки.

Относительные координаты могут также задаваться путем указания направления с помощью курсора и ввода значения расстояния. Такой способ называется методом "направление-расстояние".

Имеется возможность вводить координаты в следующих форматах: научном, десятичном, инженерном, архитектурном и дробном. Углы могут вводиться в градах, радианах, топографических единицах (в виде румбов), а также в градусах, минутах и секундах. Управление форматом единиц осуществляется командой ЕДИНИЦЫ.

Вывод координат в строке состояния

Текущее положение курсора отображается в виде значения координаты в строке состояния.

В строке состояния координаты могут отображаться в следующих режимах: статическом, динамическом и с представлением линейных и угловых единиц.

  • Статическое отображение. Обновляется только при указании точки.
  • Динамическое отображение. Обновляется по мере движения курсора.
  • Отображение расстояния и угла.Относительное расстояние (расстояние<угол) обновляется по мере движения курсора. Этот режим доступен только при рисовании отрезков и других объектов, требующих ввода более одной точки.
См. также

    • Задание декартовых координат

    • Задание полярных координат

    • 3D координаты

    • Использование динамического ввода


Методы записи координат (Процедура)

Координаты и системы координат (ПСК)
На уровень вверх ..
Методы записи координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Методы записи координат >
Методы записи координат
Понятие Процедура Краткий справочник

Для отображения координат точки

Для визуального определения местоположения точки

Для переключения режима отображения координат в строке состояния


Для отображения координат точки (Процедура)

Методы записи координат
На уровень вверх ..
Методы записи координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Методы записи координат >
Методы записи координат
Понятие Процедура Краткий справочник

Для отображения координат точки

  1. Выберите вкладку "Инструменты" [image] панель "Сведения" [image] "Координаты". В командной строке введите "коорд".
  2. Укажите точку, координаты которой нужно определить.

    Значения координат X,Y,Z выводятся в командной строке.

Панель:Сведения
Ввод команды: КООРД


Для визуального определения местоположения точки (Процедура)

Методы записи координат
На уровень вверх ..
Методы записи координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Методы записи координат >
Методы записи координат
Понятие Процедура Краткий справочник

Для визуального определения местоположения точки

  1. Выберите вкладку "Инструменты" [image] панель "Сведения" [image] "Координаты". В командной строке введите "коорд".
  2. В командной строке введите значения координат точки, местоположение которой нужно визуально определить.

    Если системная переменная BLIPMODE активна, в заданной точке ставится маркер в виде маленького крестика.

Панель:Сведения
Ввод команды: КООРД


Для переключения режима отображения координат в строке состояния (Процедура)

Методы записи координат
На уровень вверх ..
2D декартовы координаты
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Методы записи координат >
Методы записи координат
Понятие Процедура Краткий справочник

Для переключения режима отображения координат в строке состояния

Воспользоваться одним из следующих способов:

  • В ответ на запрос следующей точки, отображаемый в командной строке, нажмите мышью на индикаторе координат в строке состояния.
  • Нажмите CTRL+L.
  • Установите системную переменную COORDS равной 0 для статического отображения, 1 для динамического отображения или равной 2 для отображения расстояния и угла.


Методы записи координат (Краткий справочник)

Управление отображением перекрывающихся объектов
Методы записи координат
Задание декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Методы записи координат >
Методы записи координат
Понятие Процедура Краткий справочник

Команды

BLIPMODE

Управление простановкой маркеров при рисовании

КООРД

Определение координат точек

СПИСОК

Отображение свойств для выбранных объектов

Системные переменные

BLIPMODE

Управление простановкой маркеров при рисовании

COORDS

Управление форматом и частотой обновления координат в строке состояния

LASTPOINT

Последняя введенная точка, выраженная в координатах ПСК в текущем пространстве. Для того чтобы координаты отсчитывались от нее, необходимо начать ввод с клавиатуры с символа @

Утилиты

Нет

Ключевые слова для команд

Нет


2D декартовы координаты

Методы записи координат
Координаты и системы координат (ПСК)
Задание декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
2D декартовы координаты
Понятие Процедура

С помощью абсолютных и относительных декартовых и полярных 2D координат определяются точные положения объектов на чертеже.

Темы в этом разделе

  • Задание декартовых координат

    Для указания точек при создании объектов можно вводить абсолютные и относительные декартовы (прямоугольные) координаты.

  • Задание полярных координат

    Для указания точек при создании объектов можно вводить абсолютные и относительные полярные координаты.


2D декартовы координаты (Процедура)

Методы записи координат
На уровень вверх ..
Задание декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты >
2D декартовы координаты
Понятие Процедура

Для ввода абсолютных декартовых координат (2D)

Для ввода абсолютных полярных координат (2D)

Для ввода относительных полярных координат (2D)


Задание декартовых координат (Понятие)

2D декартовы координаты
2D декартовы координаты
Задание полярных координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты >
Задание декартовых координат
Понятие Процедура Краткий справочник

Для указания точек при создании объектов можно вводить абсолютные и относительные декартовы (прямоугольные) координаты.

Чтобы воспользоваться декартовыми координатами для задания точки, введите значения X и Y, разделенные запятой (X,Y). Координата X определяет расстояние от начала координат по горизонтали, Y - по вертикали. Значения расстояний могут быть положительными или отрицательными.

Абсолютные координаты базируются на исходной точке ПСК (0,0), которая является пересечением осей X и Y. Такой способ ввода можно применять, если известны точные координаты X и Y точки.

При использовании динамического ввода можно задавать абсолютные координаты с префиксом #. Если координаты вводятся не в подсказке, а в командной строке, префикс # не используется. Например, ввод значения #3,4 указывает на точку, удаленную от исходной точки ПСК на 3 единицы по оси X и на 4 единицы по оси Y. Дополнительную информацию о динамическом вводе см. в разделе Использование динамического ввода .

В приведенном ниже примере проводится линия с началом в точке X= -2 и Y= 1 и с конечной точкой (3,4). Введите в подсказке следующее:

Команда: отрезок

От точки: #-2,1

К точке: #3,4

Линия располагается следующим образом:

Относительные координаты отсчитываются относительно последней введенной точки. Относительные декартовы координаты применяются, если известны значения смещений координат точки относительно предыдущей точки.

Для обозначения относительных координат используется знак @ перед числовыми значениями. Например, чтобы указать точку, удаленную от последней заданной точки по оси X на 3 единицы и по оси Y на 4 единицы, необходимо ввести @3,4.

В приведенном ниже примере показано построение сторон треугольника. Первая сторона представляет собой линию с началом в точке с абсолютными координатами (-2,1) и с конечной точкой, удаленной от начальной точки на 5 единиц по оси X и на 0 единиц по оси Y. Вторая сторона представляет собой линию, начинающуюся в конечной точке первой линии и заканчивающуюся в точке 0 единиц по оси X и 3 единицы по оси Y. Для возврата в начальную точку в конечном сегменте линии используются относительные координаты.

Команда: отрезок

От точки: #-2,1

К точке: @5,0

К точке: @0,3

К точке: @-5,-3


Задание декартовых координат (Процедура)

2D декартовы координаты
На уровень вверх ..
Задание декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание декартовых координат >
Задание декартовых координат
Понятие Процедура Краткий справочник

Для ввода абсолютных декартовых координат (2D)


Для ввода абсолютных декартовых координат (2D) (Процедура)

Задание декартовых координат
На уровень вверх ..
Задание декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание декартовых координат >
Задание декартовых координат
Понятие Процедура Краткий справочник

Для ввода абсолютных декартовых координат (2D)

  • На запрос координат точки введите координаты в подсказке, используя следующий формат:

    #x,y

    Если динамический ввод отключен, введите координаты в командной строке, используя следующий формат:

    x,y


Задание декартовых координат (Процедура)

Задание декартовых координат
На уровень вверх ..
Задание полярных координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание декартовых координат >
Задание декартовых координат
Понятие Процедура Краткий справочник

Для ввода относительных декартовых координат (2D)

  • На запрос координат точки в командной строке ввести значения координат в формате:

    @x,y


Задание декартовых координат (Краткий справочник)

Методы записи координат
Задание декартовых координат
Задание полярных координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание декартовых координат >
Задание декартовых координат
Понятие Процедура Краткий справочник

Команды

Нет

Системные переменные

COORDS

Управление форматом и частотой обновления координат в строке состояния

Утилиты

Нет

Ключевые слова для команд

Нет


Задание полярных координат (Понятие)

Задание декартовых координат
2D декартовы координаты
3D координаты
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты >
Задание полярных координат
Понятие Процедура Краткий справочник

Для указания точек при создании объектов можно вводить абсолютные и относительные полярные координаты.

Чтобы воспользоваться полярными координатами для задания точки, введите значения расстояния и угла, отделяемые друг от друга символом угловой скобки (<).

По умолчанию в AutoCAD возрастание величин углов происходит при движении против часовой стрелки. Чтобы указать направление по часовой стрелке, введите отрицательное значение для угла. Например, введенные значения 1<315 эквивалентны точке со значениями 1<-45. Порядок угловых измерений можно изменять с помощью команды ЕДИНИЦЫ.

Абсолютные полярные координаты измеряются от исходной точки ПСК (0,0), которая является пересечением осей X и Y. Абсолютные полярные координаты используются в том случае, когда известны точные координаты точки, выраженные линейными и угловыми единицами.

При использовании динамического ввода можно задавать абсолютные координаты с префиксом #. Если координаты вводятся не в подсказке, а в командной строке, префикс # не используется. Например, чтобы указать точку, удаленную от начала координат на 3 единицы и под углом 45 градусов от оси X, необходимо ввести #3<45. Дополнительную информацию о динамическом вводе см. в разделе Использование динамического ввода .

Следующий пример иллюстрирует построение двух отрезков в абсолютных полярных координатах с использованием текущего направления отсчета углов. Введите в подсказке следующее:

Команда: отрезок

От точки: #0,0

К точке: #4<120

К точке: #5<30

Относительные координаты отсчитываются относительно последней введенной точки. Относительные декартовы координаты применяются, если известны значения смещений координат точки относительно предыдущей точки.

Для обозначения относительных координат используется знак @ перед числовыми значениями. Например, чтобы указать точку, удаленную от последней заданной точки на 1 единицу и находящуюся под углом 45 градусов от оси X, необходимо ввести @1<45.

Следующий пример иллюстрирует построение двух отрезков в относительных полярных координатах. В каждой иллюстрации отрезок начинается в местоположении, обозначенном как предыдущая точка.

Команда: отрезок

От точки: @3<45

К точке: @5<285


Задание полярных координат (Процедура)

Задание декартовых координат
На уровень вверх ..
Задание полярных координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание полярных координат >
Задание полярных координат
Понятие Процедура Краткий справочник

Для ввода абсолютных полярных координат (2D)

Для ввода относительных полярных координат (2D)


Для ввода абсолютных полярных координат (2D) (Процедура)

Задание полярных координат
На уровень вверх ..
Задание полярных координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание полярных координат >
Задание полярных координат
Понятие Процедура Краткий справочник

Для ввода абсолютных полярных координат (2D)

  • На запрос координат точки введите координаты в подсказке, используя следующий формат:

    #расстояние<угол

    Если динамический ввод отключен, введите координаты в командной строке, используя следующий формат:

    расстояние<угол


Для ввода относительных полярных координат (2D) (Процедура)

Задание полярных координат
На уровень вверх ..
3D координаты
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание полярных координат >
Задание полярных координат
Понятие Процедура Краткий справочник

Для ввода относительных полярных координат (2D)

  • На запрос координат точки в командной строке ввести значения координат в формате:

    @расстояние<угол


Задание полярных координат (Краткий справочник)

Задание декартовых координат
Задание полярных координат
Задание 3D декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 2D декартовы координаты > Задание полярных координат >
Задание полярных координат
Понятие Процедура Краткий справочник

Команды

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

COORDS

Управление форматом и частотой обновления координат в строке состояния

Утилиты

Нет

Ключевые слова для команд

Нет


3D координаты

Задание полярных координат
Координаты и системы координат (ПСК)
Задание 3D декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
3D координаты
Понятие Процедура

При создании объектов в 3D пространстве для указания точек используются декартовы, цилиндрические или сферические координаты.

Темы в этом разделе

  • Задание 3D декартовых координат

    3D декартовы координаты указывают на точное расположение с помощью трех координат: X, Y и Z.

  • Задание цилиндрических координат

    3D цилиндрические координаты описывают точное местоположение по расстоянию от начала ПСК в плоскости XY, углу относительно оси X в плоскости XY и значению Z.

  • Задание сферических координат

    3D сферические координаты задают расположение от начала координат текущей ПСК, угол к оси X в плоскости XY и угол в плоскости XY.


3D координаты (Процедура)

Задание полярных координат
На уровень вверх ..
Задание 3D декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты >
3D координаты
Понятие Процедура

Для ввода абсолютных координат (3D)

Для ввода относительных координат (3D)

Для ввода относительных цилиндрических координат

Для ввода относительных сферических координат


Задание 3D декартовых координат (Понятие)

3D координаты
3D координаты
Задание цилиндрических координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты >
Задание 3D декартовых координат
Понятие Процедура Краткий справочник

3D декартовы координаты указывают на точное расположение с помощью трех координат: X, Y и Z.

Трехмерные декартовы координаты (X,Y,Z) задаются аналогично двумерным (X,Y) координатам. К двум составляющим по осям X и Y добавляется третья по оси Z. Таким образом, 3D координаты вводятся в формате:

X,Y,Z

ПримечаниеВ следующих примерах предполагается, что этот динамический вид отключен или что координаты введены в командной строке. При использовании динамического ввода можно задавать абсолютные координаты с префиксом #.

В приведенной ниже иллюстрации значения координат 3,2,5 определяют точку в следующем местоположении: 3 единицы вдоль положительной оси X, 2 единицы вдоль положительной оси Y и 5 единиц вдоль положительной оси Z.

Использование значения по оси Z по умолчанию

Если координаты вводятся в формате X,Y, значение Z копируется из ввода для последней точки. В результате, можно ввести местонахождение в формате X,Y,Z, а затем ввести последующие местоположения с использованием формата X,Y со значением Z, которое остается постоянным. Например, для построения отрезка можно ввести следующие координаты:

От точки: 0,0,5

К точке: 3,4

Обе конечные точки отрезка будут иметь одинаковое значение координаты Z, равное 5 единицам. Когда пользователь начинает или открывает любой чертеж, исходное значение по умолчанию координаты Z превышает 0.

Использование абсолютных и относительных координат

Как и в случае 2D координат, можно вводить как абсолютные координаты (отсчитываемые от начала координат), так и относительные (отсчитываемые от последней указанной точки). Для ввода координат в относительной форме используется знак @, указываемый перед числовыми значениями координат. Например, для указания точки, смещенной от предыдущей точки на одну единицу по оси X, следует ввести @1,0,0. Для ввода абсолютных координат никаких предваряющих знаков не требуется. Для ввода абсолютных координат в командной строке никаких предваряющих знаков не требуется.

Задание координат с помощью дигитайзера

При вводе координат дигитайзером координата Z ПСК сохраняет значение 0. Для задания иного значения Z по умолчанию, отличного от 0, без перемещения ПСК можно воспользоваться командой УРОВЕНЬ.


Задание 3D декартовых координат (Процедура)

3D координаты
На уровень вверх ..
Задание 3D декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание 3D декартовых координат >
Задание 3D декартовых координат
Понятие Процедура Краткий справочник

Для ввода абсолютных координат (3D)

Для ввода относительных координат (3D)


Для ввода абсолютных координат (3D) (Процедура)

Задание 3D декартовых координат
На уровень вверх ..
Задание 3D декартовых координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание 3D декартовых координат >
Задание 3D декартовых координат
Понятие Процедура Краткий справочник

Для ввода абсолютных координат (3D)

  • На запрос координат точки введите координаты в подсказке, используя следующий формат:

    #x,y,z

    Если динамический ввод отключен, введите координаты в командной строке, используя следующий формат:

    x,y,z


Для ввода относительных координат (3D) (Процедура)

Задание 3D декартовых координат
На уровень вверх ..
Задание цилиндрических координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание 3D декартовых координат >
Задание 3D декартовых координат
Понятие Процедура Краткий справочник

Для ввода относительных координат (3D)

  • На запрос координат точки в командной строке ввести значения координат в формате:

    @x,y,z


Задание 3D декартовых координат (Краткий справочник)

Задание полярных координат
Задание 3D декартовых координат
Задание цилиндрических координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание 3D декартовых координат >
Задание 3D декартовых координат
Понятие Процедура Краткий справочник

Команды

СЕТКА

Отображение точечной сетки на текущем видовом экране, которая не выводится на печать

ШАГ

Ограничение перемещения курсора определенными интервалами

ПЛАНШЕТ

Настройка, калибровка, включение и отключение графического планшета

ПСК

Управление пользовательскими системами координат

ЗНАКПСК

Управление видимостью и расположением знака ПСК

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

COORDS

Управление форматом и частотой обновления координат в строке состояния

ELEVATION

Текущий уровень новых объектов относительно текущей ПСК

TABMODE

Управление использованием режима "Планшет"

Утилиты

Нет

Ключевые слова для команд

Нет


Задание цилиндрических координат (Понятие)

Задание 3D декартовых координат
3D координаты
Задание сферических координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты >
Задание цилиндрических координат
Понятие Процедура Краткий справочник

3D цилиндрические координаты описывают точное местоположение по расстоянию от начала ПСК в плоскости XY, углу относительно оси X в плоскости XY и значению Z.

Задание цилиндрических координат аналогично заданию полярных координат для 2D пространства. Дополнительно добавляется значение расстояния от указанной полярной координаты до требуемой точки пространства перпендикулярно плоскости XY. Цилиндрические координаты определяют расстояние от начала координат ПСК до проекции точки на плоскость XY, угол относительно оси X и расстояние от точки до плоскости XYпо оси Z. Цилиндрические координаты точки указываются в формате: Для задания точки в абсолютных цилиндрических координатах применяется следующий синтаксис:

X<[угол к оси X],Z

ПримечаниеВ следующих примерах предполагается, что этот динамический вид отключен или что координаты введены в командной строке. При использовании динамического ввода можно задавать абсолютные координаты с префиксом #.

На следующем рисунке запись "5<30,6" обозначает точку, смещенную на 6 единиц по оси Z от точки в плоскости XY, которая расположена на расстоянии 5 единиц от начала текущей ПСК под углом 30 градусов к оси X.

Если требуется задать положение точки относительно предыдущей точки, а не относительно начала ПСК, можно ввести относительные значения цилиндрических координат с префиксом @. Например, запись "@4<45,5" обозначает точку, смещенную на 5 единиц в положительном направлении оси Z от точки в плоскости XY, которая расположена на расстоянии 4 единиц от последней введенной точки под углом 45 градусов к положительному направлению оси X.


Для ввода относительных цилиндрических координат (Процедура)

Задание 3D декартовых координат
На уровень вверх ..
Задание сферических координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание цилиндрических координат >
Задание цилиндрических координат
Понятие Процедура Краткий справочник

Для ввода относительных цилиндрических координат

  • На запрос координат точки в командной строке ввести значения координат в формате:

    @x<угол к оси X,z

Например, координаты @4<60,2 задают точку, лежащую от последней измеренной точки на расстоянии 4 единицы по оси X под углом 60 от положительного направления оси X и на 2 единицы в положительном направлении оси Z .


Задание цилиндрических координат (Краткий справочник)

Задание 3D декартовых координат
Задание цилиндрических координат
Задание сферических координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание цилиндрических координат >
Задание цилиндрических координат
Понятие Процедура Краткий справочник

Команды

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

COORDS

Управление форматом и частотой обновления координат в строке состояния

Утилиты

Нет

Ключевые слова для команд

Нет


Задание сферических координат (Понятие)

Задание цилиндрических координат
3D координаты
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты >
Задание сферических координат
Понятие Процедура Краткий справочник

3D сферические координаты задают расположение от начала координат текущей ПСК, угол к оси X в плоскости XY и угол в плоскости XY.

Ввод сферических координат в 3D пространстве подобен вводу полярных координат в двумерном. Положение точки определяется ее расстоянием от начала координат текущей ПСК, углом к оси X в плоскости XY и углом к плоскости XY.

X<[угол к оси X]<[угол к плоскости XY]

ПримечаниеВ следующих примерах предполагается, что этот динамический вид отключен или что координаты введены в командной строке. При использовании динамического ввода можно задавать абсолютные координаты с префиксом #.

В приведенной ниже иллюстрации координатами 8<60<30 определяется точка, лежащая на расстоянии 8 единиц от начала текущей ПСК в плоскости XY, под углом 60 градусов к оси X в плоскости XY и под углом 30 градусов выше оси Z от плоскости XY. Координатами 5<45<15 определяется точка, лежащая на расстоянии 5 единиц от начала координат, под углом 45 градусов к оси X в плоскости XY и под углом 15 градусов к этой плоскости.

Для задания координат относительно предыдущей точки можно использовать относительные сферические координаты, предваряя числовые значения знаком @.


Для ввода относительных сферических координат (Процедура)

Задание цилиндрических координат
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание сферических координат >
Задание сферических координат
Понятие Процедура Краткий справочник

Для ввода относительных сферических координат

  • На запрос координат точки в командной строке ввести значения координат в формате:

    @x<угол к оси X<угол к плоскости XY

Например, координаты @4<60<30 задают точку, лежащую на расстоянии 4 единицы от последней измеренной точки под углом 60 градусов положительного направления оси X в плоскости XY и под углом 30 градусов к плоскости XY.


Задание сферических координат (Краткий справочник)

Задание цилиндрических координат
Задание сферических координат
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > 3D координаты > Задание сферических координат >
Задание сферических координат
Понятие Процедура Краткий справочник

Команды

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

COORDS

Управление форматом и частотой обновления координат в строке состояния

Утилиты

Нет

Ключевые слова для команд

Нет


Понятие о пользовательской системе координат (ПСК) (Понятие)

Задание сферических координат
Координаты и системы координат (ПСК)
Задание плоскостей видов чертежа в 3D (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Пользовательскую систему координат можно перемещать и поворачивать для обеспечения удобства записи координат, отображения сетки, привязки к сетке, реализации режима "Орто" и использования других инструментов создания чертежей.

Понятие о мировой и пользовательской системах координат

Существует две системы координат: неподвижная мировая система координат (МСК) и подвижная пользовательская система координат (ПСК). По умолчанию, в новом чертеже две эти системы совпадают между собой.

Как правило, на 2D видах в МСК ось X является горизонтальной осью, а ось Y является вертикалью. Началом ПСК является точка, в которой пересекаются ось X и ось Y (точка 0,0). Все объекты в файле чертежа определяются их МСК-координатами. Однако, более удобным является обычно создание и редактирование объектов на основе перемещаемой ПСК.

Работа с пользовательской системой координат (ПСК)

Практически все записи координат, а также многие другие инструменты и операции соотносятся с текущей ПСК. К 2D инструментам и операциям, зависимым от местоположения и ориентации ПСК, относятся следующие:

  • Запись в абсолютных и относительных координатах
  • Абсолютные углы отсчета
  • Определение горизонтали и вертикали для режима "Орто", полярное отслеживание, отслеживание объектной привязки, отображение сетки и привязка к сетке
  • Ориентация размеров по горизонтали и вертикали
  • Ориентация текстовых объектов
  • Поворот вида с использованием команды ПЛАН

Перемещение или вращение ПСК способно облегчить работу на конкретных площадях чертежа.

Для перемещения пользовательской системы координат можно использовать, например, следующие методы:

  • Перемещение ПСК путем определения новой исходной точки.
  • Выравнивание ПСК по существующему объекту.
  • Поворот ПСК путем обозначения новой исходной точки и точки на новой оси X.
  • Поворот текущей ПСК на указанный угол вокруг оси Z.
  • Возврат к предыдущей ПСК
  • Восстановление ПСК для совмещения с МСК.

Каждому из этих методов соответствует опция в команде ПСК. ПСК можно присваивать имя для возможности ее повторного использования в дальнейшем (восстановления).


Понятие о пользовательской системе координат (ПСК) (Процедура)

Задание сферических координат
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Определение новой исходной точки ПСК в 2D

Изменение угла поворота ПСК

Восстановление ПСК для совмещения с МСК

Для восстановления предыдущей ПСК

Для сохранения ПСК

Для восстановления именованной ПСК

Для переименования ПСК

Удаление именованной ПСК


Определение новой исходной точки ПСК в 2D (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Определение новой исходной точки ПСК в 2D

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "Начало".В командной строке введите "пск".
  2. Укажите точку, в которую нужно переместить начало координат.

    Исходная точка ПСК (0,0) заново определяется в точке, указанной пользователем.

Панель:ПСК
Ввод команды: ПСК


Изменение угла поворота ПСК (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Изменение угла поворота ПСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "Z".В командной строке введите "пск".
  2. Укажите угол поворота.
Панель:ПСК
Ввод команды: ПСК


Восстановление ПСК для совмещения с МСК (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Восстановление ПСК для совмещения с МСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "По имени".В командной строке введите "диспск".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" выделите "Мировая СК".
  3. Нажмите кнопку "Установить".
  4. Нажмите ОК.
Панель:ПСК-2
Ввод команды: ДИСПСК


Для восстановления предыдущей ПСК (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Для восстановления предыдущей ПСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "По имени".В командной строке введите "диспск".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" выберите "Предыдущая".
  3. Нажмите кнопку "Установить".
  4. Нажмите ОК.
Панель:ПСК-2
Ввод команды: ДИСПСК


Для сохранения ПСК (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Для сохранения ПСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "По имени".В командной строке введите "диспск".

    Новая ПСК отображается в списке ПСК в качестве системы БЕЗ ИМЕНИ.

  2. Во вкладке "Именованные ПСК" диалогового окна "ПСК" выберите "БЕЗ ИМЕНИ" и введите новое имя. (Можно выбрать также опцию БЕЗ ИМЕНИ и нажать правую кнопку мыши. Выберите "Переименовать".)
  3. Нажать "ОК".

    Имя может быть длиной до 255 символов, содержать буквенные символы, цифры и специальные символы (знак доллара ($), минус (-) и знак подчеркивания (_)). Все имена ПСК преобразуются в верхний регистр.

Панель:ПСК-2
Ввод команды: ДИСПСК


Для восстановления именованной ПСК (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Для восстановления именованной ПСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "По имени".В командной строке введите "диспск".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" пользователь может увидеть начало координат и направление осей указанной ПСК. Выберите имя ПСК. Щелкните "Подробности".

    Нажмите кнопку "OK" для завершения просмотра данных о ПСК и возврата в диалоговое окно "ПСК".

  3. Выберите систему координат, которую требуется восстановить. Нажмите кнопку "Установить".
  4. Нажмите ОК.
Панель:ПСК-2
Ввод команды: ДИСПСК


Для переименования ПСК (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Для переименования ПСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "По имени".В командной строке введите "диспск".
  2. В диалоговом окне "ПСК" на вкладке "Именованные ПСК" выделите ПСК, которую нужно переименовать. (Можно выбрать также опцию БЕЗ ИМЕНИ и нажать правую кнопку мыши. Выбрать "Переименовать".)
  3. Введите новое имя.
  4. Нажмите "ОК".
Панель:ПСК-2
Ввод команды: ДИСПСК


Удаление именованной ПСК (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Задание плоскостей видов чертежа в 3D (ПСК)
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Удаление именованной ПСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "По имени".В командной строке введите "диспск".
  2. В диалоговом окне "ПСК" перейдите на вкладку "Именованные ПСК" и выделите ПСК, которую нужно удалить.
  3. Нажмите клавишу Delete.

    Нельзя удалять текущую ПСК и ПСК с именем по умолчанию БЕЗ ИМЕНИ.

Панель:ПСК-2
Ввод команды: ДИСПСК


Понятие о пользовательской системе координат (ПСК) (Краткий справочник)

Задание сферических координат
Понятие о пользовательской системе координат (ПСК)
Понятие о пользовательской системе координат в 3D
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Понятие о пользовательской системе координат (ПСК) >
Понятие о пользовательской системе координат (ПСК)
Понятие Процедура Краткий справочник

Команды

ПСК

Управление пользовательскими системами координат

ЗНАКПСК

Управление видимостью и расположением знака ПСК

ДИСПСК

Управление заданными пользовательскими системами координат

Системные переменные

ERRNO

Отображение номера соответствующего кода ошибки, когда вызов функции AutoLISP приводит к ошибке, выявленной AutoCAD

PUCSBASE

Хранит имя ПСК, которая определяет параметры исходной точки и ориентации ортогональной ПСК (только для пространства листа)

UCSFOLLOW

Установка вида в плане при переходе от одной ПСК к другой

UCSNAME

Имя текущей системы координат для текущего видового экрана в текущем пространстве

UCSORG

Хранение исходной точки текущей системы координат для текущего видового экрана в текущем пространстве

UCSORTHO

Определение режима восстановления ортогональной ПСК в момент установки соответствующего ортогонального вида

UCSXDIR

Хранение направления X текущей ПСК на текущем видовом экране в текущем пространстве

UCSYDIR

Хранение направления Y текущей ПСК на текущем видовом экране в текущем пространстве

Утилиты

Нет

Ключевые слова для команд

Нет


Задание плоскостей видов чертежа в 3D (ПСК)

Понятие о пользовательской системе координат (ПСК)
Координаты и системы координат (ПСК)
Понятие о пользовательской системе координат в 3D
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
Задание плоскостей видов чертежа в 3D (ПСК)
Понятие Процедура

Возможность управления пользовательской системой координат (ПСК) является важным условием для эффективного построения моделей в трехмерном пространстве.

Темы в этом разделе

  • Понятие о пользовательской системе координат в 3D

    При работе в 3D пользовательская система координат полезна для записи координат, создания 3D объектов на 2D плоскостях видов чертежа и для поворота объектов в 3D.

  • Задание пользовательской системы координат в 3D пространстве

    Существует несколько способов задания пользовательской системы координат. Положение координатной системы можно сохранять и восстанавливать.

  • Использование динамической ПСК с моделями тел

    С помощью функции динамической ПСК можно на время автоматически выровнять XY-плоскость ПСК по плоскости в модели тела при создании объектов.


Задание плоскостей видов чертежа в 3D (ПСК) (Процедура)

Понятие о пользовательской системе координат (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат в 3D
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) >
Задание плоскостей видов чертежа в 3D (ПСК)
Понятие Процедура

Для ввода координат относительно МСК

Определение новой ПСК заданием трех точек

Поворот ПСК вокруг большой оси

Определение новой исходной точки ПСК в 3D

Z- ось

Определение новой ПСК с заданными осямиXиY

Для переноса плоскостиXY

Для установки стандартной ПСК

Для восстановления местоположения и ориентации предыдущей ПСК

Замена ПСК динамическим способом


Понятие о пользовательской системе координат в 3D (Понятие)

Задание плоскостей видов чертежа в 3D (ПСК)
Задание плоскостей видов чертежа в 3D (ПСК)
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) >
Понятие о пользовательской системе координат в 3D
Понятие Процедура Краткий справочник

При работе в 3D пользовательская система координат полезна для записи координат, создания 3D объектов на 2D плоскостях видов чертежа и для поворота объектов в 3D.

При создании или редактировании объектов в 3D среде можно перемещать и переориентировать ПСК в 3D пространстве модели с целью упрощения работы. XY-плоскость ПСК именуется плоскостью видов чертежа.

Важными операциями на объектах в 3D среде, зависимыми от местоположения и ориентации ПСК, являются следующие:

  • Определение плоскости видов чертежа для создания и редактирования объектов
  • Определение плоскости видов чертежа, содержащей отображение сетки и привязку к сетке
  • Определение новой Z-оси ПСК в качестве оси для вращения объектов в 3D
  • Определение направлений вверх и вниз, а также горизонтального и вертикального направлений для режима "Орто", полярного отслеживания и отслеживания объектной привязки
  • Определение 3D вида напрямую в плоскости видов чертежа с помощью команды ПЛАН

Правило правой руки

Правило правой руки позволяет задать положительное направление оси Z, если в 3D системе координат известны направления осей X и Y. Кроме того, данное правило определяет положительное направление вращения вокруг любой из 3D осей координат. Если ориентировать большой палец правой руки согласно положительному направлению оси и согнуть остальные пальцы, то положительное направление вращения будет совпадать с направлением, указываемым согнутыми пальцами. Средний палец указывает на направление положительной оси Z. При повороте кисти руки можно наблюдать, как меняется положение осей X, Y и Z во время аналогичного вращения ПСК.

Кроме того, правило правой руки можно использовать с целью определения положительного направления вращения по умолчанию вокруг оси в 3D пространстве. Если ориентировать большой палец правой руки согласно положительному направлению оси и согнуть остальные пальцы, то положительное направление вращения будет совпадать с направлением, указываемым согнутыми пальцами.

ПримечаниеПо умолчанию, определяемый в 3D вид устанавливается по отношению не к перемещаемой ПСК, а к неподвижной МСК.


Понятие о пользовательской системе координат в 3D (Процедура)

Задание плоскостей видов чертежа в 3D (ПСК)
На уровень вверх ..
Понятие о пользовательской системе координат в 3D
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Понятие о пользовательской системе координат в 3D >
Понятие о пользовательской системе координат в 3D
Понятие Процедура Краткий справочник

Для ввода координат относительно МСК

Определение новой ПСК заданием трех точек

Поворот ПСК вокруг большой оси


Для ввода координат относительно МСК (Процедура)

Понятие о пользовательской системе координат в 3D
На уровень вверх ..
Понятие о пользовательской системе координат в 3D
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Понятие о пользовательской системе координат в 3D >
Понятие о пользовательской системе координат в 3D
Понятие Процедура Краткий справочник

Для ввода координат относительно МСК

  • Поместите перед значениями координат символ звездочки (*).

Ввод @*2,0,0 указывает на точку, отстоящую на 2 единицы в направлении X от последней точки, введенной относительно МСК. Ввод @2,0,0 указывает на точку, отстоящую на 2 единицы в направлении X от последней точки, введенной относительно ПСК.

Как правило, в большинстве случаев координаты задаются не относительно МСК, а относительно ПСК.


Определение новой ПСК заданием трех точек (Процедура)

Понятие о пользовательской системе координат в 3D
На уровень вверх ..
Понятие о пользовательской системе координат в 3D
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Понятие о пользовательской системе координат в 3D >
Понятие о пользовательской системе координат в 3D
Понятие Процедура Краткий справочник

Определение новой ПСК заданием трех точек

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "3 точки".В командной строке введите "пск".
  2. Укажите новую исходную точку. Это точка (0,0,0) в новой ПСК.
  3. Укажите точку на положительной оси X новой ПСК.
  4. Укажите точку в положительной плоскости XY новой ПСК.
    Панель:ПСК


Поворот ПСК вокруг большой оси (Процедура)

Понятие о пользовательской системе координат в 3D
На уровень вверх ..
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Понятие о пользовательской системе координат в 3D >
Понятие о пользовательской системе координат в 3D
Понятие Процедура Краткий справочник

Поворот ПСК вокруг большой оси

  1. Выполните одно из следующих действий:

    • Выберите вкладку "Вид" [image] панель "ПСК" [image] "Z".В командной строке введите "пск".
    • Выберите вкладку "Вид" [image] панель "ПСК" [image] "X".В командной строке введите "пск".
    • Выберите вкладку "Вид" [image] панель "ПСК" [image] "Y".В командной строке введите "пск".
  2. Введите угол поворота. Угол поворота обычно равен 90.


Понятие о пользовательской системе координат в 3D (Краткий справочник)

Понятие о пользовательской системе координат (ПСК)
Понятие о пользовательской системе координат в 3D
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Понятие о пользовательской системе координат в 3D >
Понятие о пользовательской системе координат в 3D
Понятие Процедура Краткий справочник

Команды

ПСК

Управление пользовательскими системами координат

ЗНАКПСК

Управление видимостью и расположением знака ПСК

ДИСПСК

Управление заданными пользовательскими системами координат

Системные переменные

ЗНАКПСК

Знак ПСК для текущего видового экрана или листа

UCSVP

Определение, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана

Утилиты

Нет

Ключевые слова для команд

Нет


Задание пользовательской системы координат в 3D пространстве (Понятие)

Понятие о пользовательской системе координат в 3D
Задание плоскостей видов чертежа в 3D (ПСК)
Использование динамической ПСК с моделями тел
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Существует несколько способов задания пользовательской системы координат. Положение координатной системы можно сохранять и восстанавливать.

Пользователь определяет пользовательскую систему координат (ПСК) с целью изменить местоположение исходной точки 0,0,0, местоположение и угол поворота плоскости XY и ориентацию плоскости XY или оси Z. Пользователь может расположить и сориентировать ПСК на любом месте в 3D пространстве и может определить, сохранить и заново вызвать такое количество сохраненных адресов ПСК, какое ему требуется.

Если на экране монитора располагается несколько видовых экранов, на каждом из них можно установить свою ПСК. Присваивая системной переменной UCSVP значение 1 (Вкл), можно сохранять положение ПСК для каждого видового экрана.

Задание ПСК

Задание новой ПСК может быть осуществлено следующими способами:

  • Задать новую исходную точку (одну), новую ось X (две точки) или новую плоскость XY (три точки).

  • Выровнять ПСК путем выбора грани на объекте 3D тела. Выбор может быть сделан на грани или на ребре тела.

  • Совместить новую ПСК с существующим объектом. Исходная точка ПСК расположена в вершине, максимально приближенной к позиции, на которой был выбран объект.

  • Совместить новую ПСК с текущим направлением взгляда

  • Повернуть текущую ПСК вокруг любой из трех ее больших осей.

  • Переориентировать плоскость XY путем задания новой оси Z.

Стандартные ПСК

Существует возможность установки любой из стандартных координатных систем, Доступные варианты выбора указаны в изображениях на вкладке "Ортогональные ПСК" диалогового окна "(Именованные) ПСК".

Изменение текущего уровня

Командой УРОВЕНЬ задается значение Z по умолчанию для новых объектов, находящихся выше или ниже плоскости XY в текущей ПСК. Эти сведения хранятся в системной переменной ELEVATION.

Примечание Обычно рекомендуется оставлять уровень равным нулю и управлять положением плоскости построений (XY) с помощью команды ПСК.

Задание ПСК в пространстве листа

В пространстве листа новая ПСК может быть определена таким же образом, как и в пространстве модели; однако здесь разрешены только 2D операции с ПСК. Несмотря на возможность ввода 3D координат в пространство листа, не разрешается использовать такие команды 3D просмотра, как ПЛАН и ТЗРЕНИЯ.

Сохранение ПСК с присвоением имени и последующее восстановление

При интенсивном 3D моделировании полезно именовать и сохранять ПСК с различными точками начала и ориентацией. Определять, сохранять и восстанавливать различные ПСК можно неограниченное число раз.


Задание пользовательской системы координат в 3D пространстве (Процедура)

Понятие о пользовательской системе координат в 3D
На уровень вверх ..
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Определение новой исходной точки ПСК в 3D

Z - ось

Определение новой ПСК с заданными осями X и Y

Для переноса плоскости XY

Для установки стандартной ПСК

Для восстановления местоположения и ориентации предыдущей ПСК


Определение новой исходной точки ПСК в 3D (Процедура)

Задание пользовательской системы координат в 3D пространстве
На уровень вверх ..
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Определение новой исходной точки ПСК в 3D

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "Начало".В командной строке введите "пск".
  2. Укажите точку, в которую нужно переместить начало координат.

    Исходная точка ПСК (0,0,0) заново определяется в указанной здесь точке.

Панель:ПСК
Ввод команды: ПСК


Z- ось (Процедура)

Задание пользовательской системы координат в 3D пространстве
На уровень вверх ..
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Z - ось

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "Z".В командной строке введите "пск".
  2. Укажите точку, в которую нужно переместить начало координат.

    Исходная точка ПСК (0,0,0) заново определяется в указанной здесь точке.

  3. Укажите точку, находящуюся на положительной оси Z.

Панель:ПСК
Ввод команды: ПСК


Определение новой ПСК с заданными осямиXиY (Процедура)

Задание пользовательской системы координат в 3D пространстве
На уровень вверх ..
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Определение новой ПСК с заданными осями X и Y

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "3 точки".В командной строке введите "пск".
  2. Укажите точку, в которую нужно переместить начало координат.

    Исходная точка ПСК (0,0,0) заново определяется в указанной здесь точке.

  3. Укажите точку, находящуюся на положительной оси X.
  4. Укажите точку, находящуюся на положительной оси Y.

Панель:ПСК
Ввод команды: ПСК


Для переноса плоскостиXY (Процедура)

Задание пользовательской системы координат в 3D пространстве
На уровень вверх ..
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Для переноса плоскости XY

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "3 точки".В командной строке введите "пск".
  2. Укажите точку, куда нужно переместить начало координат новой ПСК (1).

    В крупном чертеже, например, имеет смысл устанавливать начало координат ПСК в той части, где предполагается выполнение построений.

  3. Укажите точку для задания горизонтальной ориентации новой ПСК (2). Эта точка будет определять положительное направление оси X новой ПСК.
  4. Укажите точку для задания вертикальной ориентации ПСК (3). Эта точка будет определять положительное направление оси Y новой ПСК.

    ПСК (вместе с сеткой) изменяет положение в соответствии с заданными параметрами.

Панель:ПСК
Ввод команды: ПСК


Для установки стандартной ПСК (Процедура)

Задание пользовательской системы координат в 3D пространстве
На уровень вверх ..
Задание пользовательской системы координат в 3D пространстве
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Для установки стандартной ПСК

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "По имени".В командной строке введите "диспск".
  2. В диалоговом окне "ПСК" на вкладке "Ортогональные ПСК" выберите ПСК из списка.
  3. Нажмите кнопку "Установить".
  4. Нажмите "ОК".

    Устанавливается ПСК в соответствии с заданными параметрами.

Панель:ПСК-2
Ввод команды: ДИСПСК


Для восстановления местоположения и ориентации предыдущей ПСК (Процедура)

Задание пользовательской системы координат в 3D пространстве
На уровень вверх ..
Использование динамической ПСК с моделями тел
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Для восстановления местоположения и ориентации предыдущей ПСК

  • Выберите вкладку "Вид" [image] панель "ПСК" [image] "Предыдущий".В командной строке введите пск. Затем введите п (Предыдущая).

Восстанавливается предыдущая ПСК.

Панель:ПСК
Ввод команды: ПСК


Задание пользовательской системы координат в 3D пространстве (Краткий справочник)

Понятие о пользовательской системе координат в 3D
Задание пользовательской системы координат в 3D пространстве
Использование динамической ПСК с моделями тел
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Задание пользовательской системы координат в 3D пространстве >
Задание пользовательской системы координат в 3D пространстве
Понятие Процедура Краткий справочник

Команды

УРОВЕНЬ

Задание уровня и трехмерной высоты для вновь создаваемых объектов

ПСК

Управление пользовательскими системами координат

ДИСПСК

Управление заданными пользовательскими системами координат

Системные переменные

ELEVATION

Текущий уровень новых объектов относительно текущей ПСК

UCSVP

Определение, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана

Утилиты

Нет

Ключевые слова для команд

Нет


Использование динамической ПСК с моделями тел (Понятие)

Задание пользовательской системы координат в 3D пространстве
Задание плоскостей видов чертежа в 3D (ПСК)
Назначение пользовательской системы координат видовому экрану
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) >
Использование динамической ПСК с моделями тел
Понятие Процедура Краткий справочник

С помощью функции динамической ПСК можно на время автоматически выровнять XY-плоскость ПСК по плоскости в модели тела при создании объектов.

Во время выполнения команды рисования выравнивание ПСК обеспечивается не использованием команды ПСК, а перемещением пользовательского указателя на ребро грани. Когда выполнение команды завершается, ПСК возвращается на свое предыдущее место с сохранением прежней ориентации.

Показать: Использование динамической ПСК с моделями тел

Нажмите на стрелку "Просмотр" для запуска анимации.

Например, можно использовать динамическую ПСК с целью создания прямоугольника над расположенной под углом грани модели тела, как показано на рисунке.

На левом рисунке ПСК не выровнена по расположенной под углом грани. Вместо перемещения ПСК выполняется активизация динамической ПСК на строке состояния или нажатием F6.

Как показано на среднем рисунке, при перемещении указателя по всему ребру курсор изменяется для отображения направления осей динамической ПСК. Далее можно легко создавать объекты на расположенной под углом грани, как показано на правом рисунке.

ПримечаниеДля отображения меток XYZ на курсоре нажмите правую кнопку мыши на кнопке ДПСК и нажмите на "Отобразить метки на перекрестьях".

Ось X динамической ПСК располагается вдоль ребра грани, и положительное направление оси X всегда указывает на правую половину экрана. Динамическая ПСК способна обнаружить только передние грани тела.

Ниже указаны типы команд, в которых можно использовать динамическую ПСК.

  • Простая геометрияЛиния, полилиния, прямоугольник, дуга, окружность
  • Текст.Текст, многострочный текст, таблица
  • Ссылки.Вставка, внешняя ссылка
  • Тела.Примитивные тела и ПОЛИТЕЛО
  • Редактирование.Поворот, зеркальное отражение, выравнивание
  • Прочее.ПСК, площадь, манипулирование ручками
СоветМожно легко выровнять ПСК по плоскости в модели тела путем активизации функции динамической ПСК с последующим использованием команды ПСК для определения исходной точки в данной плоскости.

Если активны режимы "Сетка" и "Привязка", они на время выравниваются по динамической ПСК. Лимиты отображения сетки устанавливаются автоматически.

Можно на время отключить динамическую ПСК нажатием F6 или SHIFT+Z во время перемещения указателя по грани.

ПримечаниеДинамическая ПСК доступна только при активной команде.


Замена ПСК динамическим способом (Процедура)

Задание пользовательской системы координат в 3D пространстве
На уровень вверх ..
Знак пользовательской системы координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Использование динамической ПСК с моделями тел >
Использование динамической ПСК с моделями тел
Понятие Процедура Краткий справочник

Замена ПСК динамическим способом

  1. Вызовите команду, поддерживаемую динамической ПСК.
  2. Если требуется, заново активизируйте ПСК нажатием ДПСК на строке состояния.
  3. Переместите текущий указатель на ребро грани на модели тела.
  4. Завершите выполнение команды.


Использование динамической ПСК с моделями тел (Краткий справочник)

Задание пользовательской системы координат в 3D пространстве
Использование динамической ПСК с моделями тел
Назначение пользовательской системы координат видовому экрану
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Задание плоскостей видов чертежа в 3D (ПСК) > Использование динамической ПСК с моделями тел >
Использование динамической ПСК с моделями тел
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

OSOPTIONS

Автоматическое подавление объектной привязки на объектах штриховки и геометрии с отрицательными значениями Z при использовании динамической ПСК

UCSDETECT

Управление активностью сбора данных динамической ПСК

Утилиты

Нет

Ключевые слова для команд

Нет


Назначение пользовательской системы координат видовому экрану (Понятие)

Использование динамической ПСК с моделями тел
Координаты и системы координат (ПСК)
Знак пользовательской системы координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
Назначение пользовательской системы координат видовому экрану
Понятие Краткий справочник

Чтобы облегчить редактирование объектов на различных видах, можно определить отличную от других ориентацию ПСК для каждого вида.

На видовые экраны можно выводить различные виды модели. Один из примеров возможных конфигураций - виды сверху, спереди, справа и в изометрии. Чтобы повысить удобство работы, для каждого видового экрана можно задать и сохранить отдельную ПСК. В этом случае при переключении между видовыми экранами не происходит потери информации о ПСК каждого из них.

Сохранением ПСК для каждого видового экрана управляет системная переменная UCSVP. На видовых экранах, где UCSVP равна 1, ПСК, использованная непосредственно перед переходом на другой видовой экран, запоминается; при возврате на данный видовой экран происходит ее восстановление. Если для видового экрана системная переменная UCSVP установлена равной 0, то ПСК этого видового экрана всегда совпадает с ПСК текущего активного видового экрана.

Например, можно задать три видовых экрана: с видами сверху, спереди и изометрическим. Если системная переменная UCSVP устанавливается равной 0 на изометрическом видовом экране, можно использовать ПСК, соответствующую виду сверху, и на видовом экране вида сверху, и на изометрическом видовом экране. Когда видовой экран вида сверху становится текущим видовым экраном, то в ПСК изометрического видового экрана отражается ПСК видового экрана вида сверху. Аналогично, когда текущим становится видовой экран вида спереди, то ПСК изометрического видового экрана переключается для согласования с ПСК видового экрана вида спереди.

Ниже приведены иллюстрации к рассмотренному примеру. На первом чертеже текущим является левый верхний видовой экран (с видом сверху). На изометрическом видовом экране устанавливается ПСК, определенная на этом виде.

На следующем чертеже текущим является левый нижний видовой экран (с видом спереди). ПСК на изометрическом виде изменяется, и теперь соответствует системе координат вида спереди.

В предыдущих версиях AutoCAD установка ПСК была глобальной и действовала для всех видовых экранов как в пространстве модели, так и в пространстве листа. Если необходимо восстановить характеристики из предыдущих версий, можно присвоить переменной UCSVP значение 0 на всех активных видовых экранах.


Назначение пользовательской системы координат видовому экрану (Краткий справочник)

Использование динамической ПСК с моделями тел
Назначение пользовательской системы координат видовому экрану
Знак пользовательской системы координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Назначение пользовательской системы координат видовому экрану >
Назначение пользовательской системы координат видовому экрану
Понятие Краткий справочник

Команды

ПСК

Управление пользовательскими системами координат

Системные переменные

UCSVP

Определение, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана

Утилиты

Нет

Ключевые слова для команд

Нет


Знак пользовательской системы координат (Понятие)

Назначение пользовательской системы координат видовому экрану
Координаты и системы координат (ПСК)
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) >
Знак пользовательской системы координат
Понятие Процедура Краткий справочник

Для облегчения работы с ПСК можно воспользоваться знаком пользовательской системы координат. Имеется несколько вариантов этого знака. Можно изменять его размеры, расположение и цвет.

Для обозначения местоположения и ориентации ПСК ее значок отображается либо в начале ПСК, либо в левом нижнем углу текущего видового экрана.

Для представления ПСК можно выбрать один из трех знаков.

Команда ЗНАКПСК используется для выбора между отображением 2D или 3D знака ПСК. Затененный знак ПСК отображается для затененного 3D вида. Для обозначения местоположения и ориентации ПСК можно отобразить значок ПСК в исходной точке ПСК с помощью команды ЗНАКПСК.

Если знак находится в точке начала координат текущей ПСК, он помечается крестиком (+). Если же знак расположен в левом нижнем углу видового экрана, крестик не ставится.

При наличии нескольких видовых экранов на каждом из них отображается свой знак ПСК.

Знак ПСК отображается по-разному, что облегчает визуальное представление ориентации плоскости видов чертежа. Некоторые из возможных вариантов представлены на чертеже.

Для переключения между двумерным и трехмерным знаками ПСК можно использовать команду ЗНАКПСК. Для трехмерного знака ПСК также можно изменять размер, цвет, тип стрелок осей и толщину линий.

Знак ПСК с изображением сломанного карандаша заменяет 2D знак ПСК, когда направление взгляда находится в плоскости, параллельной XY-плоскости ПСК. Знак с изображением сломанного карандаша указывает на то, что ребро плоскости XY почти перпендикулярно текущему направлению взгляда. В данном случае использование указывающего устройства для задания координат невозможно.

Обычно считается, что точки, выбираемые с помощью устройства указания, располагаются в плоскости XY. Если ПСК повернута так, что ось Z лежит в плоскости, параллельной плоскости взгляда, то есть если видно только кромку плоскости XY, достаточно трудно определить положение точки. В этом случае точки будут проецироваться на плоскость, параллельную плоскости вида и проходящую через начало координат. Например, если направление взгляда параллельно оси X, указанная на экране точка проецируется на плоскость YZ, содержащую начало ПСК.

Для определения плоскости проекции координат следует использовать режим 3D знака ПСК.


Знак пользовательской системы координат (Процедура)

Использование динамической ПСК с моделями тел
На уровень вверх ..
Знак пользовательской системы координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Знак пользовательской системы координат >
Знак пользовательской системы координат
Понятие Процедура Краткий справочник

Для включения и отключения знака ПСК

Для установки знака ПСК в начало координат

Для настройки параметров знака ПСК


Для включения и отключения знака ПСК (Процедура)

Знак пользовательской системы координат
На уровень вверх ..
Знак пользовательской системы координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Знак пользовательской системы координат >
Знак пользовательской системы координат
Понятие Процедура Краткий справочник

Для включения и отключения знака ПСК

  • Выберите вкладку "Вид" [image] панель "ПСК" [image] "Показывать знак ПСК".В командной строке введите знакпск.

    Наличие пометки в этом пункте свидетельствует о том, что знак включен.

Ввод команды: ЗНАКПСК


Для установки знака ПСК в начало координат (Процедура)

Знак пользовательской системы координат
На уровень вверх ..
Знак пользовательской системы координат
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Знак пользовательской системы координат >
Знак пользовательской системы координат
Понятие Процедура Краткий справочник

Для установки знака ПСК в начало координат

  • Выберите вкладку "Вид" [image] панель "ПСК" [image] "Начало".В командной строке введите знакпск.

    Знак ПСК смещается в начало координат. Наличие пометки около пункта "Начало" свидетельствует о том, что знак находится в начале координат.

Ввод команды: ЗНАКПСК


Для настройки параметров знака ПСК (Процедура)

Знак пользовательской системы координат
На уровень вверх ..
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Знак пользовательской системы координат >
Знак пользовательской системы координат
Понятие Процедура Краткий справочник

Для настройки параметров знака ПСК

  1. Выберите меню Вид [image] Отображение [image] Знак ПСК [image] Свойства.В командной строке введите "знакпск".
  2. В диалоговом окне "Знак ПСК" настройте параметры.
  3. Нажать "ОК".
Ввод команды: ЗНАКПСК


Знак пользовательской системы координат (Краткий справочник)

Назначение пользовательской системы координат видовому экрану
Знак пользовательской системы координат
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Координаты и системы координат (ПСК) > Знак пользовательской системы координат >
Знак пользовательской системы координат
Понятие Процедура Краткий справочник

Команды

ЗНАКПСК

Управление видимостью и расположением знака ПСК

Системные переменные

ЗНАКПСК

Знак ПСК для текущего видового экрана или листа

Утилиты

Нет

Ключевые слова для команд

Нет


Использование динамического ввода (Понятие)

Знак пользовательской системы координат
Средства обеспечения точности
Объектная привязка
Создание и редактирование объектов > Средства обеспечения точности >
Использование динамического ввода
Понятие Процедура Краткий справочник

Функция динамического ввода обеспечивает командный интерфейс в области курсора, позволяющий удерживать фокус в области построения.

Когда параметр "Динамический ввод" включен, сведения, отображаемые в подсказках, рядом с курсором динамически обновляются по мере перемещения курсора. Когда команда активна, подсказки обеспечивают место для ввода, осуществляемого пользователем.

Если ввести значение в поле ввода и нажать клавишу TAB, в поле отображается значок блокировки, привязанный к введенному значению. После этого можно вводить значение для второго поля ввода. Если же ввести значение и нажать ENTER, второе поле игнорируется и это значение интерпретируется как ввод методом "направление-расстояние".

Для выполнения команды или использования ручек необходимы действия, аналогичные действиям для командной строки. Разница заключается в том, что внимание сосредоточено возле курсора.

Динамический ввод не является полной заменой окна команды. Можно скрыть окно команды, чтобы добавить для чертежа дополнительную область экрана, но оно может потребоваться для некоторых операций. При необходимости нажмите F2 для скрытия и отображения подсказок команд и сообщений об ошибках. Можно также открепить окно команды и использовать параметр "Автоматически убирать с экрана" для разворачивания и сворачивания окна.

Включение и отключение функции динамического ввода

Для включения или отключения функции динамического ввода нажмите кнопку динамического ввода [image] в строке состояния. Временно отключить динамический ввод можно нажатием клавиши F12. Функция динамического ввода содержит три компонента: ввод с помощью мыши, ввод размеров и динамические подсказки. Для настройки отображаемых каждым компонентом запросов и подсказок щелкните правой кнопкой мыши на кнопке [image] и выберите "Режимы".

Ввод с помощью мыши

Когда ввод с помощью мыши включен и команда активна, положение курсоров в форме перекрестия отображается в виде координат в подсказке возле курсора. Значения координат можно вводить не в подсказке, а в командной строке.

Значением по умолчанию для второй и последующих точек являются относительные полярные координаты (относительная декартова координата для ПРЯМОУГ). Знак @ не требуется вводить. Если требуется использовать абсолютные координаты, используйте префикс решетка (#). Например, для перемещения объекта в исходную точку при запросе второй точки введите #0,0.

Воспользуйтесь настройками ввода с помощью мыши для изменения формата по умолчанию, используемого в координатах, и для управления отображением подсказок при вводе с помощью мыши.

Ввод размеров

Когда функция ввода размеров включена, в ответ на запросе второй точки подсказки отображают линейные и угловые значения. Значения в размерных подсказках изменяются по мере перемещения курсора. Для перехода к значению, которое нужно изменить, нажмите клавишу TAB. Ввод размеров возможен для команд ДУГА, КРУГ, ЭЛЛИПС, ОТРЕЗОК и ПЛИНИЯ.

В случае использования ручек для редактирования объекта, подсказки для ввода размеров могут отображать следующую информацию:

  • Исходная длина
  • Длина, которая обновляется при перемещении ручки
  • Изменение длины
  • Угол
  • Изменение угла при перемещении ручки
  • Радиус дуги

Воспользуйтесь настройками ввода размеров для отображения только необходимой информации.

При использовании ручек для растяжения объектов или при создании новых объектов во время ввода размеров отображаются только острые углы, то есть все углы, равные или меньше 180 градусов. Таким образом, угол 270 градусов отображается как угол, равный 90 градусам, независимо от установки системной переменной ANGDIR (установленной в диалоговом окне "Единицы чертежа"). При определении направления положительного угла углы, заданные при создании новых объектов, основываются на местоположении курсора.

Динамические подсказки

Когда функция динамических подсказок включена, запросы отображаются в подсказке возле курсора. Ответ можно вводить не в подсказке, а в командной строке. Нажмите клавишу СТРЕЛКА ВНИЗ для просмотра и выбора параметров. Нажмите клавишу СТРЕЛКА ВВЕРХ для отображения последних введенных команд.

Примечание Чтобы воспользоваться командой ВСТБУФЕР в динамической подсказке, прежде чем вставить запись, введите любую букву, а затем удалите ее клавишей Backspace. Иначе запись будет вставлена в чертеж как текст.


Использование динамического ввода (Процедура)

Знак пользовательской системы координат
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для ввода значений координат в подсказках динамического ввода

Для исправления ошибок ввода в подсказках динамического ввода

Для указания относительных или абсолютных координат в подсказках для ввода с помощью мыши

Для выбора параметров в динамической подсказке

Для изменения цвета, размера или прозрачности подсказок

Объединение информации из всех подсказок о построениях в одну подсказку.

Для включения или отключения динамического ввода

Для изменения настроек ввода с помощью мыши

Для изменения настроек ввода размеров

Для отображения запросов в подсказках


Для ввода значений координат в подсказках динамического ввода (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для ввода значений координат в подсказках динамического ввода

  1. Проверьте, что кнопка динамического ввода [image] в строке состояния нажата.
  2. Для ввода значений координат или выбора параметров используйте любой из следующих способов:
    • Чтобы ввести полярные координаты, введите расстояние от первой точки и нажмите клавишу TAB, затем введите значение угла и нажмите клавишу ENTER.
    • Чтобы ввести декартовы координаты, введите значение координаты оси X, запятую (,), затем введите значение координаты Y и нажмите клавишу ENTER.
    • Если после запроса следует значок стрелки вниз, нажимайте клавишу "СТРЕЛКА ВНИЗ", пока рядом с параметром не отобразится точка. Нажать ENTER.
    • Чтобы использовать последние координаты, нажмите клавишу СТРЕЛКА ВВЕРХ или нажмите правой кнопкой мыши. Чтобы использовать координаты из контекстного меню, нажмите "Последний ввод".
ПримечаниеПри вводе размеров после ввода значения в поле для ввода и нажатия клавиши TAB в поле отображается значок блокировки, а курсор ограничен введенным значением.


Для исправления ошибок ввода в подсказках динамического ввода (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для исправления ошибок ввода в подсказках динамического ввода

  • Если в подсказке о динамическом вводе отображается красный контур ошибки, выбирается текущая запись. Замените выбранный текст подстановкой с клавиатуры. Для исправления введенной записи можно также использовать клавиши СТРЕЛКА ВПРАВО, СТРЕЛКА ВЛЕВО, ОБРАТНЫЙ ПРОБЕЛ и DELETE. После того, как исправление выполнено, для удаления красного контура и завершения построения координат нажмите клавишу TAB, введите запятую (,) или символ знака «меньше» (<).
  • Если в подсказке для ввода с помощью мыши нужно изменить введенные символы @, # или *, просто введите нужный символ. Необязательно пользоваться клавишей Backspace.


Для указания относительных или абсолютных координат в подсказках для ввода с помощью мыши (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для указания относительных или абсолютных координат в подсказках для ввода с помощью мыши

  • Чтобы ввести абсолютные координаты, когда в подсказке отображаются относительные координаты, введите символ # для временного отключения системной переменной DYNPICOORDS.
  • Чтобы ввести относительные координаты, когда отображаются абсолютные координаты, введите символ @ для временного отключения системной переменной DYNPICOORDS.
  • Для ввода координат, заданных в мировой системе координат (МСК), введите *.
ПримечаниеВо время ввода с помощью мыши для доступа к префиксам # и * можно использовать контекстное меню.


Для выбора параметров в динамической подсказке (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для выбора параметров в динамической подсказке

  1. Вызовите команду.

    Подсказки возле курсоров в форме перекрестия отображают координаты положения курсора и подсказки.

  2. Если подсказка отображается, нажмите клавишу СТРЕЛКА ВНИЗ для отображения параметров.
  3. Нажмите клавишу СТРЕЛКА ВНИЗ или СТРЕЛКА ВВЕРХ, чтобы поместить точку рядом с нужным параметром. Нажать ENTER.

    Нажмите клавишу ESC, чтобы отменить последнее действие.

  4. Укажите точки и введите параметры для выполнения команды.


Для изменения цвета, размера или прозрачности подсказок (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для изменения цвета, размера или прозрачности подсказок

  1. Щелкните правой кнопкой мыши на кнопке динамического ввода [image] в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" щелкните "Внешний вид подсказок на чертеже".
  3. В диалоговом окне "Внешний вид подсказок" в разделе "Цвет" щелкните "Цвет модели" или "Цвет листа", чтобы отобразилось диалоговое окно Выбор цвета, в котором можно задать цвет для подсказок в выбранном пространстве.
  4. В разделе "Размер" переместите указатель шкалы вправо, чтобы увеличить подсказки, или влево, чтобы уменьшить их. Значение по умолчанию, 0, находится посередине.
  5. В разделе "Прозрачность" переместите указатель шкалы. Чем меньше значение настройки, тем прозрачнее подсказка. При значении, равном 100 единицам, подсказка становится непрозрачной.
  6. В разделе "Применить" выберите параметр:
    • Заменить параметры ОС для всех подсказок на чертеже. Настройки применяются ко всем подсказкам; при этом настройки в операционной системе отменяются.
    • Заменить параметры только для подсказок динамического ввода. Настройки применяются только к подсказкам на чертеже, используемым в динамическом вводе.
  7. Нажать "ОК".
Ввод команды: DYNTOOLTIPS


Объединение информации из всех подсказок о построениях в одну подсказку. (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Объединение информации из всех подсказок о построениях в одну подсказку.

  • В командной строке введите команду tooltipmerge.

Подсказки, содержащие информацию о построениях, объединяются в одну подсказку.


Для включения или отключения динамического ввода (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для включения или отключения динамического ввода

  • Нажмите кнопку динамического ввода [image] в строке состояния или клавишу F12.

Для временного отключения динамического ввода нажмите и удерживайте клавишу F12 во время работы.

Примечание Клавиша F12 не включает функцию динамического ввода - она используется для временного отключения этого режима.


Для изменения настроек ввода с помощью мыши (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для изменения настроек ввода с помощью мыши

  1. Щелкните правой кнопкой мыши на кнопке динамического ввода [image] в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" в разделе "Ввод с помощью мыши" нажмите кнопку "Настройки".
  3. В диалоговом окне "Параметры ввода с помощью мыши" выберите формат полярных или декартовых координат в качестве настройки по умолчанию.
  4. Выберите формат относительных или абсолютных координат в качестве настройки по умолчанию.
  5. В разделе "Видимость" выберите один из следующих параметров:
    • Одновременно с вводом координатных данных. Когда ввод с помощью мыши включен, подсказки отображаются только в момент начала ввода координатных данных.
    • Когда команда содержит запрос для точки. Когда ввод с помощью мыши включен, подсказки отображаются, когда команда запрашивает точку.
    • Всегда—даже не в составе команды. Подсказки отображаются всегда, когда ввод с помощью мыши включен.
  6. Нажать "OK" для закрытия каждого диалогового окна.
Ввод команды: РЕЖИМРИС


Для изменения настроек ввода размеров (Процедура)

Использование динамического ввода
Использование динамического ввода
Использование динамического ввода
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для изменения настроек ввода размеров

  1. Щелкните правой кнопкой мыши на кнопке динамического ввода [image] в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" в разделе "Ввод размеров" нажмите кнопку "Настройки".
  3. В диалоговом окне "Параметры ввода размеров" выберите формат полярных или декартовых координат в качестве настройки по умолчанию.
  4. В разделе "Видимость" выберите один из следующих параметров:
    • Показывать одновременно только 1 поле для ввода размеров. Когда для растягивания объекта используется редактирование с помощью ручек, отображается только подсказка ввода размеров для линейных значений.
    • Показывать одновременно 2 поля для ввода размеров. Когда для растягивания объекта используется редактирование с помощью ручек, отображаются подсказки ввода размеров для линейных и угловых значений.
    • Показывать одновременно следующие поля для ввода размеров. Когда для растягивания объекта используется редактирование с помощью ручек, отображаются выбранные подсказки ввода размеров. Установите один или несколько флажков.
  5. Нажать "OK" для закрытия каждого диалогового окна.
Ввод команды: РЕЖИМРИС


Для отображения запросов в подсказках (Процедура)

Использование динамического ввода
Использование динамического ввода
Объектная привязка
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Для отображения запросов в подсказках

  1. Щелкните правой кнопкой мыши на кнопке динамического ввода [image] в строке состояния. Выберите "Настройки".
  2. В диалоговом окне "Режимы рисования" на вкладке "Динамический ввод" в разделе "Динамические подсказки" установите флажок "Показывать подсказку для ввода команды и вводимую команду рядом с перекрестьем".
  3. Нажать "ОК".
Ввод команды: РЕЖИМРИС


Использование динамического ввода (Краткий справочник)

Знак пользовательской системы координат
Использование динамического ввода
Использование объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Использование динамического ввода >
Использование динамического ввода
Понятие Процедура Краткий справочник

Команды

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

Системные переменные

DYNDIGRIP

Управление отображением динамических размеров во время растягивания ручками

DYNDIVIS

Управление отображением количества динамических размеров во время растягивания ручками

DYNMODE

Включение и отключение функций динамического ввода

DYNPICOORDS

Признак использования абсолютных или относительных координат для ввода с помощью мыши

DYNPIFORMAT

Признак использования формата полярных или декартовых координат для ввода с помощью мыши

DYNPIVIS

Управление отображением ввода с помощью мыши

DYNPROMPT

Управление отображением подсказок динамического ввода

DYNTOOLTIPS

Управление выбором подсказок, на которые влияют параметры внешнего вида подсказок

TEMPOVERRIDES

Включение и отключение клавиш временной отмены

TOOLTIPMERGE

Объединение подсказок на чертеже в одну подсказку

Утилиты

Нет

Ключевые слова для команд

Нет


Объектная привязка

Использование динамического ввода
Средства обеспечения точности
Использование объектной привязки
Создание и редактирование объектов > Средства обеспечения точности >
Объектная привязка
Понятие Процедура

Вместо ввода значений координат пользователь имеет возможность задавать точки, привязывая курсор к характерным точками имеющихся объектов (к конечным точкам отрезков, центрам кругов и т.д.).

Темы в этом разделе

  • Использование объектной привязки

    Использование объектных привязок для указания точных положений на объектах. Например, включив объектную привязку, можно быстро построить отрезок от центра круга к середине сегмента полилинии.

  • Меню объектной привязки

    Контекстное меню объектной привязки позволяет быстро устанавливать необходимый режим объектной привязки.

  • Автопривязка

    Для объектной привязки имеются специальные средства визуализации, называемые автопривязкой AutoSnap™. Эти средства повышают наглядность и эффективность использования объектной привязки. Автопривязка отображает маркер и всплывающую подсказку при подведении курсора к какой-либо точке объектной привязки.

  • Переопределение параметров объектной привязки

    Во время работы можно временно включить или отключить текущие режимы объектной привязки с помощью клавиши отмены. Клавиши временной отмены можно использовать для других режимов рисования, например, для режима "Орто" и полярного режима.


Объектная привязка (Процедура)

Использование динамического ввода
Объектная привязка
Использование объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка >
Объектная привязка
Понятие Процедура

Для включения привязки к характерным точкам объектов

Для задания текущих режимов объектной привязки

Для включения и отключения текущих режимов объектной привязки в процессе работы

Для игнорирования объектов штриховки объектными привязками

Для вызова контекстного меню объектной привязки

Для изменения параметров автопривязки

Для временной отмены текущих настроек объектной привязки

Изменение времени реакции клавиатуры для кнопок временного переопределения


Использование объектной привязки (Понятие)

Объектная привязка
Объектная привязка
Меню объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка >
Использование объектной привязки
Понятие Процедура Краткий справочник

Использование объектных привязок для указания точных положений на объектах. Например, включив объектную привязку, можно быстро построить отрезок от центра круга к середине сегмента полилинии.

Объектную привязку можно включать во время любого запроса указания точек. По умолчанию при перемещении курсора над объектной привязкой на объекте отображаются маркер и подсказка. Эта функция называется AutoSnap™ (Автопривязка); она обеспечивает визуальное отображение текущего режима объектной привязки.

Подробные сведения о режимах объектной привязки см. в описании команды ПРИВЯЗКА.

Задание объектной привязки

Для задания объектной привязки в запросе точки

  • Для вызова контекстного меню объектной привязки нажмите правую кнопку мыши при нажатой клавише SHIFT.
  • Нажмите кнопку объектной привязки на панели "Объектная привязка"
  • В командной строке введите имя режима объектной привязки.
  • Щелкните правой кнопкой мыши на кнопке объектной привязки в строке состояния.

Когда объектная привязка задается в запросе точки, то она действует только для указания следующей точки.

ПримечаниеОбъектная привязка работает только при запросах на указание точек. При попытке использования объектной привязки в ответ на подсказку "команда" возникает сообщение об ошибке.

Использование текущего режима объектной привязки

Если есть необходимость использовать один или несколько режимов объектной привязки более одного раза, то можно установить эти режимы в качестве текущих. Например, для того, чтобы соединить центры нескольких окружностей, можно установить режим "Центр" текущим режимом объектной привязки.

Пользователь может задать один или несколько текущих режимов объектной привязки на вкладке "Объектная привязка" в диалоговом окне "Режимы рисования", доступ к которому можно получить из меню "Сервис". Если включено несколько режимов объектной привязки, в выбранном положении может существовать более одной объектной привязки. До задания точки нажмите клавишу TAB для циклического просмотра возможностей.

Нажмите кнопку ПРИВЯЗКА в строке состояния или клавишу F3 для включения или выключения текущих объектных привязок.

ПримечаниеЕсли необходимо, чтобы объекты штриховки игнорировались объектными привязками, установите системную переменную OSNAPHATCH равной 1.

Использование объектных привязок в 3D пространстве

По умолчанию Z-значение положения объектной привязки определяется положением объекта в пространстве. Однако если работа с объектными привязками ведется на плане здания или на виде сверху детали, удобнее будет воспользоваться постоянным Z-значением.

Если системная переменная OSNAPZ включена, все объектные привязки проецируются на плоскость XY текущей ПСК или, если для ELEVATION установлено не нулевое значение, - на плоскость, параллельную плоскости XY на заданном уровне.

ПримечаниеПри создании или изменении объектов необходимо знать, включена или выключена переменная OSNAPZ. Поскольку визуальные напоминания отсутствуют, могут быть получены неожиданные результаты.


Использование объектной привязки (Процедура)

Объектная привязка
На уровень вверх ..
Использование объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Использование объектной привязки >
Использование объектной привязки
Понятие Процедура Краткий справочник

Для включения привязки к характерным точкам объектов

Для задания текущих режимов объектной привязки

Для включения и отключения текущих режимов объектной привязки в процессе работы

Для игнорирования объектов штриховки объектными привязками


Для включения привязки к характерным точкам объектов (Процедура)

Использование объектной привязки
На уровень вверх ..
Использование объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Использование объектной привязки >
Использование объектной привязки
Понятие Процедура Краткий справочник

Для включения привязки к характерным точкам объектов

  1. По запросу указания точки нажмите правую кнопку мыши в области чертежа при нажатой клавише SHIFT. Выберите объектную привязку, которой нужно воспользоваться.
  2. Переместите курсор в нужное положение объектной привязки.

    Если режим автопривязки включен, то при наведении курсора на характерную точку появляется маркер объектной привязки и соответствующая подсказка.

  3. Выберите объект.

    Происходит выбор самой близкой к курсору точки привязки указанного объекта.


Для задания текущих режимов объектной привязки (Процедура)

Использование объектной привязки
На уровень вверх ..
Использование объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Использование объектной привязки >
Использование объектной привязки
Понятие Процедура Краткий справочник

Для задания текущих режимов объектной привязки

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. На вкладке "Объектная привязка" диалогового окна "Режимы рисования" выберите необходимые режимы объектной привязки.
  3. Нажать "ОК".
Ввод команды: ПРИВЯЗКА

Контекстное меню:Щелкните правой кнопкой мыши на кнопке объектной привязки [image] в строке состояния. Выберите "Настройки".


Для включения и отключения текущих режимов объектной привязки в процессе работы (Процедура)

Использование объектной привязки
На уровень вверх ..
Использование объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Использование объектной привязки >
Использование объектной привязки
Понятие Процедура Краткий справочник

Для включения и отключения текущих режимов объектной привязки в процессе работы

  • Нажмите кнопку объектной привязки [image] в строке состояния или клавишу F13.

Если текущие режимы объектной привязки были заданы, происходит их включение или отключение.

Для временного включения и выключения текущих объектных привязок нажмите и удерживайте клавишу F3 во время работы.

Ввод команды: ПРИВЯЗКА


Для игнорирования объектов штриховки объектными привязками (Процедура)

Использование объектной привязки
На уровень вверх ..
Меню объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Использование объектной привязки >
Использование объектной привязки
Понятие Процедура Краткий справочник

Для игнорирования объектов штриховки объектными привязками

  1. В командной строке введите osoptions.
  2. Введите 1.


Использование объектной привязки (Краткий справочник)

Использование динамического ввода
Использование объектной привязки
Меню объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Использование объектной привязки >
Использование объектной привязки
Понятие Процедура Краткий справочник

Команды

АПЕРТУРА

Установка размера прицела объектной привязки, в пикселах

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПРИВЯЗКА

Установка текущих режимов объектной привязки

Системные переменные

APBOX

Включение и отключение отображения прицела автопривязки

AUTOSNAP

Управление отображением маркера, всплывающей подсказки и магнита автопривязки

OSMODE

Битовый код текущих режимов объектной привязки

OSNAPZ

Управление автоматической проекцией объектной привязки на плоскость, параллельную плоскости XY текущей ПСК, на текущем уровне

OSNAPCOORD

Управление приоритетом ввода координат с клавиатуры над текущими режимами привязки

OSOPTIONS

Автоматическое подавление объектной привязки на объектах штриховки и геометрии с отрицательными значениями Z при использовании динамической ПСК

Утилиты

Нет

Ключевые слова для команд

СДТ

Указание расположения точки посредине между двумя другими точками


Меню объектной привязки (Понятие)

Использование объектной привязки
Объектная привязка
Автопривязка
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка >
Меню объектной привязки
Понятие Процедура Краткий справочник

Контекстное меню объектной привязки позволяет быстро устанавливать необходимый режим объектной привязки.

Меню объектной привязки отображается на текущей позиции курсора, когда пользователь нажимает правую кнопку мыши (либо эквивалентную кнопку или другое устройство указания) при нажатой клавише SHIFT.

По умолчанию меню объектной привязки предлагает список опций объектной привязки и отслеживания. Если нужно изменить эти параметры, внесите изменения в файл адаптации. Основному файлу адаптации, поставляемому вместе с программой, присвоено имя acad.cui.

См. также

    • См. раздел Создание раскрывающихся и контекстных меню в документе Руководство по адаптации

    • Использование объектной привязки


Для вызова контекстного меню объектной привязки (Процедура)

Использование объектной привязки
На уровень вверх ..
Автопривязка
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Меню объектной привязки >
Меню объектной привязки
Понятие Процедура Краткий справочник

Для вызова контекстного меню объектной привязки

  1. Введите любую команду, которая требует указания точки. Например, введите отрезок
  2. По подсказке "От точки" нажмите правую кнопку мыши при нажатой клавише SHIFT.

    Появляется меню объектной привязки, где можно выбрать необходимый режим.

Контекстное меню:Щелкните правой кнопкой мыши на кнопке объектной привязки [image] в строке состояния. Выберите "Настройки".


Меню объектной привязки (Краткий справочник)

Использование объектной привязки
Меню объектной привязки
Автопривязка
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Меню объектной привязки >
Меню объектной привязки
Понятие Процедура Краткий справочник

Команды

ПРИВЯЗКА

Установка текущих режимов объектной привязки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Автопривязка (Понятие)

Меню объектной привязки
Объектная привязка
Переопределение параметров объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка >
Автопривязка
Понятие Процедура Краткий справочник

Для объектной привязки имеются специальные средства визуализации, называемые автопривязкой AutoSnap™. Эти средства повышают наглядность и эффективность использования объектной привязки. Автопривязка отображает маркер и всплывающую подсказку при подведении курсора к какой-либо точке объектной привязки.

Элементы автопривязки

Средства автопривязки включают в себя следующие элементы:

  • Маркеры. Указывают на ближайшую к курсору точку привязки с помощью соответствующего символа. Форма маркера зависит от режима привязки.
  • Всплывающие подсказки автопривязки. Поясняют режим объектной привязки в точке привязки ниже позиции курсора.
  • Магнит. Автоматически перемещает курсор в точку привязки, если курсор находится около возможной точки привязки. если курсор находится около возможной точки привязки.
  • Прицел. Окружает перекрестье курсора и ограничивает область, в которой производится оценка объектных привязок. Показ прицела можно включать и отключать, а его размер - изменять.

По умолчанию включены следующие элементы автопривязки: маркеры, всплывающие подсказки и магнит. Настройки автопривязки можно изменять на вкладке "Построения" диалогового окна "Параметры".

Использование автопривязки для контроля и смены режима объектной привязки

Если задано несколько текущих объектных привязок, можно нажатием клавиши TAB перебирать все точки объектных привязок, доступные для определенного объекта.


Для изменения параметров автопривязки (Процедура)

Меню объектной привязки
На уровень вверх ..
Переопределение параметров объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Автопривязка >
Автопривязка
Понятие Процедура Краткий справочник

Для изменения параметров автопривязки

  1. В меню Сервис выберите [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Параметры" на вкладке "Построения" установите нужные настройки:
    • Маркеры. Включение и отключение маркеров.
    • Магнит. Включение и отключение магнита.
    • Всплывающие подсказки автопривязки. Включение и отключение подсказок.
    • Прицел автопривязки. Включение и отключение отображения прицела в режиме объектной привязки. Если автопривязка отключена, то эта опция не действует.
    • Цвет маркера автопривязки. Изменение цвета маркера.
    • Размер маркера автопривязки. Настройка размера маркера.
  3. Нажать "ОК".
Ввод команды: НАСТРОЙКА


Автопривязка (Краткий справочник)

Меню объектной привязки
Автопривязка
Переопределение параметров объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Автопривязка >
Автопривязка
Понятие Процедура Краткий справочник

Команды

АПЕРТУРА

Установка размера прицела объектной привязки, в пикселах

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПРИВЯЗКА

Установка текущих режимов объектной привязки

Системные переменные

APBOX

Включение и отключение отображения прицела автопривязки

AUTOSNAP

Управление отображением маркера, всплывающей подсказки и магнита автопривязки

OSMODE

Битовый код текущих режимов объектной привязки

Утилиты

Нет

Ключевые слова для команд

Нет


Переопределение параметров объектной привязки (Понятие)

Автопривязка
Объектная привязка
Ограничение перемещения курсора
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка >
Переопределение параметров объектной привязки
Понятие Процедура Краткий справочник

Во время работы можно временно включить или отключить текущие режимы объектной привязки с помощью клавиши отмены. Клавиши временной отмены можно использовать для других режимов рисования, например, для режима "Орто" и полярного режима.

Например, если заданы текущие объектные привязки, но их необходимо отключить для одной точки, нажмите и удерживайте клавишу F3. Когда клавиша отмены будет освобождена, текущие режимы объектной привязки будут восстановлены.

Существуют также клавиши временной отмены для отдельных объектных привязок. Клавиши отмены задаются таким образом, чтобы можно было легко найти их на ощупь, не отрывая взгляда от чертежа.

Клавиши на следующем чертеже являются клавишами по умолчанию, однако при необходимости можно изменить назначение клавиш и добавить собственные.

Нажмите и удерживайте клавишу SHIFT и одну из клавиш временной отмены, изображенных на чертеже:
1 | Отмена объектной привязки: конечная точка | 5 | Отключение привязки и отслеживания
2 | Принудительный выбор объектной привязки | 6 | Отмена объектной привязки: по центру
3 | Включение/отключение режима отслеживания объектной привязки | 7 | Отмена объектной привязки: средняя точка
4 | Включение/отключение режима объектной привязки (ПРИВЯЗКА) |  |

Клавиши временной отмены можно использовать для других режимов рисования, заданных в диалоговом окне Режимы рисования.

См. также

    • Настройка сетки и шаговой привязки

    • Ортогональное рисование

    • Полярные отслеживание и привязка

    • Использование динамического ввода

    • См. раздел Задание клавиш быстрого вызова и временной замены в документе Руководстве по адаптации


Переопределение параметров объектной привязки (Процедура)

Автопривязка
На уровень вверх ..
Переопределение параметров объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Переопределение параметров объектной привязки >
Переопределение параметров объектной привязки
Понятие Процедура Краткий справочник

Для временной отмены текущих настроек объектной привязки

Изменение времени реакции клавиатуры для кнопок временного переопределения


Для временной отмены текущих настроек объектной привязки (Процедура)

Переопределение параметров объектной привязки
На уровень вверх ..
Переопределение параметров объектной привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Переопределение параметров объектной привязки >
Переопределение параметров объектной привязки
Понятие Процедура Краткий справочник

Для временной отмены текущих настроек объектной привязки

  • Нажмите и удерживайте клавишу F3 во время работы.

    Когда клавиша будет освобождена, текущие настройки объектной привязки будут восстановлены.


Изменение времени реакции клавиатуры для кнопок временного переопределения (Процедура)

Переопределение параметров объектной привязки
На уровень вверх ..
Ограничение перемещения курсора
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Переопределение параметров объектной привязки >
Переопределение параметров объектной привязки
Понятие Процедура Краткий справочник

Изменение времени реакции клавиатуры для кнопок временного переопределения

  1. В панели управления Windows выберите опцию "Клавиатура".
  2. На вкладке "Скорость" диалогового окна "Свойства клавиатуры" передвиньте регулятор "Частота повторения" для корректировки времени реакции клавиатуры. Затем нажмите "OK".


Переопределение параметров объектной привязки (Краткий справочник)

Автопривязка
Переопределение параметров объектной привязки
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Объектная привязка > Переопределение параметров объектной привязки >
Переопределение параметров объектной привязки
Понятие Процедура Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

АДАПТАЦИЯ

Адаптация инструментальных палитр

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПРИВЯЗКА

Установка текущих режимов объектной привязки

Системные переменные

OSMODE

Битовый код текущих режимов объектной привязки

TEMPOVERRIDES

Включение и отключение клавиш временной отмены

Утилиты

Нет

Ключевые слова для команд

Нет


Ограничение перемещения курсора

Переопределение параметров объектной привязки
Средства обеспечения точности
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности >
Ограничение перемещения курсора
Понятие Процедура

Пользователю предоставляются различные средства для ограничения и блокирования перемещения курсора.

Темы в этом разделе

  • Настройка сетки и шаговой привязки

    Для повышения скорости и эффективности построения объектов можно включить прямоугольную сетку на экране и привязку к сетке. Шаг и ориентацию сетки можно изменять.

  • Ортогональное рисование

    Для точного построения объектов можно ограничить перемещение курсора горизонтальным и вертикальным направлениями.

  • Полярные отслеживание и привязка

    Полярное отслеживание ограничивает перемещение курсора направлением под заданным углом. Полярная привязка задает шаг перемещения курсора в заданном направлении.

  • Разовое задание угла отслеживания (Угол)

    Имеется возможность разового задания угла отслеживания, действующего до указания очередной точки.


Ограничение перемещения курсора (Процедура)

Переопределение параметров объектной привязки
Ограничение перемещения курсора
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора >
Ограничение перемещения курсора
Понятие Процедура

Для включения сетки и задания ее шага

Для включения режима шаговой привязки и задания шага

Установка границ сетки

Для временной отмены режима привязки

Поворот угла привязки и сетки и изменение базовой точки

Изменение отображения сетки в виде линий и точек

Изменение частоты главных линий сетки

Для включения и отключения режима "Орто"

Для включения и отключения полярного отслеживания

Для задания шага полярной привязки

Для построения объектов с помощью полярного отслеживания

Для построения объектов с помощью полярной привязки

Для задания углов полярного отслеживания


Настройка сетки и шаговой привязки (Понятие)

Ограничение перемещения курсора
Ограничение перемещения курсора
Ортогональное рисование
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Для повышения скорости и эффективности построения объектов можно включить прямоугольную сетку на экране и привязку к сетке. Шаг и ориентацию сетки можно изменять.

Сетка представляет собой прямоугольную комбинацию точек или отрезков, расположенных на площади в заданных пользователем границах сетки. Сетка заменяет листок бумаги, расчерченный в клетку, который подкладывают под чертеж для облегчения построений. Она помогает выравнивать объекты и оценивать расстояние между ними. На печать сетка не выводится.

Шаговая привязка позволяет ограничить передвижение курсора только узлами воображаемой решетки. При включенном режиме шаговой привязки движение курсора становится скачкообразным, он как бы "прилипает" к узлам решетки. Шаговая привязка обычно используется для безошибочного указания точек с помощью клавиатуры или устройства указания.

Режим сетки и режим привязки не зависят один от другого, но часто включаются одновременно.

Управление стилем экранного представления и площадью сетки

Сетку можно отображать в виде прямоугольной комбинации точек или прямоугольной комбинации линий. Сетка отображается в виде точек только в случае, если текущим стилем отображения является "2D Каркас"; иначе сетка отображается в виде линий. Сетка в виде линий отображается для всех стилей отображения при работе в 3D. Имеется несколько методов изменения текущего стиля отображения, включая вызов команды ТЕКВИЗСТИЛЬ.

По умолчанию, X- и Y-оси ПСК отображаются в цвете, отличном от цвета линий сетки. Для определения цвета можно использовать диалоговое окно "Цвета окна чертежа". Данное диалоговое окно доступно через вкладку "Построения" в диалоговом окне "Настройка".

Площадь чертежа, покрываемая сеткой, определяется командой ЛИМИТЫ. Имеется опция переопределения лимитов таким образом, чтобы сетка покрывала всю плоскость XY пользовательской системы координат (ПСК). Для получения доступа к данной опции можно воспользоваться диалоговым окном "Режимы рисования" или использовать системную переменную GRIDDISPLAY.

ПримечаниеЕсли используется динамическая ПСК, лимиты сетки устанавливаются автоматически по отношению к размеру выбранной грани тела и доступной площади чертежа.

Управление частотой больших линий сетки

Если сетка отображается не в виде точек, а в виде линий, то затемненные линии, именуемые главными линиями сетки, отображаются с определенными интервалами. Главные линии сетки особенно полезны для быстрого вычисления расстояний, измеряемых в десятичных единицах, футах или дюймах. Частоту расположения главных линий сетки можно задать в диалоговом окне "Режимы рисования".

Для отключения отображения главных линий сетки следует установить частоту главных линий сетки равной 1.

ПримечаниеЕсли сетка отображается в виде линий, лимиты сетки также отображаются в виде затемненных линий. Нельзя путать эти граничные линии с главными линиями сетки.
ПримечаниеЕсли сетка представлена в виде линий и для SNAPANG установлено значение, отличное от нуля, сетка не отображается. SNAPANG не влияет на отображение сетки в виде точек.

Динамическое изменение сетки при зумировании

Если видимые размеры чертежа уменьшаются или увеличиваются путем зумирования, то шаг сетки автоматически корректируется для согласования с новым масштабом изображения. Это именуется адаптивным отображением сетки.

Например, при увеличении видимого размера чертежа плотность расположения отображаемых линий сетки автоматически уменьшается. Напротив, если видимый размер чертежа уменьшается, дополнительные линии сетки отображаются в той же пропорции, что и главные линии сетки.

Изменение шага сетки и привязки

В процессе работы режимы "Сетка" и "Шаг" можно включать/отключать, а также изменять шаг привязки и сетки. Режим привязки можно временно включить или отключить с помощью клавиши отмены.

Шаг привязки и шаг сетки могут не совпадать. Например, сетка, используемая исключительно для наглядности, может иметь достаточно большой шаг. При этом шаг привязки может быть более мелким, чтобы пользователь имел возможность указывать точки с большей точностью.

Изменение базы и угла привязки и сетки

Если требуется создание чертежа с определенным выравниванием или под определенным углом, можно изменить угол привязки и сетки путем поворота пользовательской системы координат (ПСК). При этом вид перекрестья и ориентация сетки также изменятся. Приведенный ниже пример иллюстрирует поворот ПСК на 30 градусов для согласования с углом анкерного кронштейна.

Точки привязки и сетки всегда совмещаются с исходной точкой ПСК. Если необходимо сдвинуть исходную точку сетки и шага сетки, следует переместить ПСК.

См. также

    • Задание изометрического стиля шаговой привязки и сетки

    • Переопределение параметров объектной привязки

    • Использование стиля отображения для модели


Настройка сетки и шаговой привязки (Процедура)

Ограничение перемещения курсора
На уровень вверх ..
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Для включения сетки и задания ее шага

Для включения режима шаговой привязки и задания шага

Установка границ сетки

Для временной отмены режима привязки

Поворот угла привязки и сетки и изменение базовой точки

Изменение отображения сетки в виде линий и точек

Изменение частоты главных линий сетки


Для включения сетки и задания ее шага (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Для включения сетки и задания ее шага

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. Во вкладке "Шаг и сетка" диалогового окна "Режимы рисования" выберите "Сетка Вкл" с целью отображения сетки.
  3. Убедитесь, что в группе "Тип привязки" включены опции "Шаговая привязка" и "Ортогональная привязка".
  4. В качестве X-шага сетки введите значение шага сетки по горизонтали в указанных единицах.
  5. Чтобы использовать это же значение для шага сетки по вертикали, нажмите ENTER. Иначе, введите новое значение для Y-шага сетки.
  6. Нажмите "ОК".
Ввод команды: РЕЖИМРИС
Контекстное меню:Щелкните правой кнопкой мыши на кнопке привязки [image] в строке состояния. Выберите "Настройки".


Для включения режима шаговой привязки и задания шага (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Для включения режима шаговой привязки и задания шага

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. На вкладке "Шаг и сетка" диалогового окна "Режимы рисования" выберите "Шаг Вкл".
  3. Убедитесь, что в группе "Тип привязки" выбраны опции "Шаговая привязка" и "Ортогональная привязка".
  4. В качестве X-шага привязки введите значение шага привязки по горизонтали в указанных единицах.
  5. Чтобы использовать это же значение для шага привязки по вертикали, нажмите ENTER Иначе, введите новое значение расстояния в окно Y-шага привязки.
  6. Нажать "ОК".
Ввод команды: РЕЖИМРИС
Контекстное меню:Щелкните правой кнопкой мыши на кнопке привязки [image] в строке состояния. Выберите "Настройки".


Установка границ сетки (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Установка границ сетки

  1. Выберите меню Формат [image] Лимиты.В командной строке введите "лимиты".
  2. В командной строке введите значения координат для точки в нижнем левом углу границ сетки.
  3. Введите значения координат для точки в верхнем правом углу границ сетки.

Границы сетки устанавливаются равными площади, определяемой двумя точками.

Ввод команды: ЛИМИТЫ


Для временной отмены режима привязки (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Для временной отмены режима привязки

  • Нажмите и удерживайте клавишу F9 во время работы.

    Когда клавиша будет освобождена, режим привязки будет восстановлен.


Поворот угла привязки и сетки и изменение базовой точки (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Поворот угла привязки и сетки и изменение базовой точки

  1. Выберите вкладку "Вид" [image] панель "ПСК" [image] "Z".В командной строке введите "пск".
  2. Введите угол поворота для ПСК.
  3. Выберите вкладку "Вид" [image] панель "ПСК" [image] "Начало".В командной строке введите "пск".
  4. Укажите новую исходную точку для ПСК.
  5. Нажмите "ОК".
Ввод команды: ПСК


Изменение отображения сетки в виде линий и точек (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Настройка сетки и шаговой привязки
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Изменение отображения сетки в виде линий и точек

  1. В командной строке введите ТЕКВИЗСТИЛЬ.
  2. Выполните одно из следующих действий:
    • Для отображения сетки в виде точек укажите опцию "2D Каркас".
    • Для отображения сетки в виде линий укажите другую опцию.
Ввод команды: ТЕКВИЗСТИЛЬ


Изменение частоты главных линий сетки (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Ортогональное рисование
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Изменение частоты главных линий сетки

  1. Если необходимо, введите в командной строке ТЕКВИЗСТИЛЬ и выберите любой стиль отображения, кроме "2D Каркас".
  2. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  3. Во вкладке "Шаг и сетка" диалогового окна "Режимы рисования" укажите число для опции "Главная линия - каждая".
  4. Нажмите "ОК".
Ввод команды: ТЕКВИЗСТИЛЬ
Контекстное меню:Щелкните правой кнопкой мыши на кнопке привязки [image] в строке состояния. Выберите "Настройки".


Настройка сетки и шаговой привязки (Краткий справочник)

Переопределение параметров объектной привязки
Настройка сетки и шаговой привязки
Ортогональное рисование
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Настройка сетки и шаговой привязки >
Настройка сетки и шаговой привязки
Понятие Процедура Краткий справочник

Команды

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

СЕТКА

Отображение точечной сетки на текущем видовом экране, которая не выводится на печать

ЛИМИТЫ

Установка и регулирование границ отображения сетки на текущей вкладке "Лист" или "Модель"

РЕЖИМРАСКР

Запускает команду ТЕКВИЗСТИЛЬ

ШАГ

Ограничение перемещения курсора определенными интервалами

Системные переменные

GRIDDISPLAY

Управление режимом работы дисплея и лимитами отображения сетки

GRIDMODE

Признак включения или отключения сетки

GRIDMAJOR

Управление частотой основных линий сетки по сравнению со вспомогательными линиями сетки

GRIDUNIT

Интервалы шага сетки по X и Y на текущем видовом экране

LIMCHECK

Управление созданием объектов за пределами лимитов чертежа

LIMMAX

Сохранение координат правой верхней точки лимитов сетки для текущего пространства, выраженных в мировой системе координат

LIMMIN

Сохранение координат левой нижней точки лимитов сетки для текущего пространства, выраженных в мировой системе координат

SNAPANG

Задание угла поворота сетки и шаговой привязки для текущего видового экрана относительно текущей ПСК

SNAPBASE

Задание исходной точки сетки и шаговой привязки для текущего видового экрана относительно текущей ПСК

SNAPMODE

Включение и отключение режима привязки

SNAPTYPE

Тип привязки для текущего видового экрана

SNAPUNIT

Интервал привязки для текущего видового экрана

TEMPOVERRIDES

Включение и отключение клавиш временной отмены

Утилиты

Нет

Ключевые слова для команд

Нет


Ортогональное рисование (Понятие)

Настройка сетки и шаговой привязки
Ограничение перемещения курсора
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора >
Ортогональное рисование
Понятие Процедура Краткий справочник

Для точного построения объектов можно ограничить перемещение курсора горизонтальным и вертикальным направлениями.

При создании объектов режим "Орто" ограничивает перемещение курсора горизонтальным или вертикальным направлением. По мере перемещения курсора, резиновая линия следует за горизонтальной или вертикальной осью, в зависимости от того, что ближе к курсору.

Ориентация текущей пользовательской системы координат (ПСК) определяет горизонтальное и вертикальное направления. На 3D видах режим "Орто" дополнительно ограничивает возможности перемещения курсора направлениями вверх и вниз. В этом случае в подсказке об угле отображается +Z или -Z.

СоветЕсли включен режим "Орто", для создания ортогональных линий заданной длины или для перемещения объектов на заданные расстояния необходимо использовать прямую запись расстояния.

В любой момент режим "Орто" может быть отключен и включен вновь. Когда пользователь вводит координаты или указывает объектную привязку, "Орто" игнорируется. Для временного включения или отключения режима "Орто" нажмите и удерживайте клавишу временной отмены, SHIFT. Пока задействована клавиша временной отмены, метод "направление-расстояние" будет недоступен.

Подробные сведения о работе с направлениями, ориентированными под углом к горизонтальной или вертикальной оси, см. в разделе Полярные отслеживание и привязка.

Если режим включен, то при определении горизонтального и вертикального направлений отдается предпочтение параметрам изометрической привязки над ПСК.

ПримечаниеРежим ортогонального рисования не может использоваться совместно с режимом полярного отслеживания, поэтому при включении режима "Орто" полярное отслеживание автоматически отключается.
См. также

    • Переопределение параметров объектной привязки


Для включения и отключения режима "Орто" (Процедура)

Настройка сетки и шаговой привязки
На уровень вверх ..
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Ортогональное рисование >
Ортогональное рисование
Понятие Процедура Краткий справочник

Для включения и отключения режима "Орто"

  • Нажмите кнопку "Орто" в строке состояния.

    Для временного включения или отключения режима "Орто" нажмите и удерживайте клавишу SHIFT во время работы. Пока задействована клавиша временной отмены, метод "направление-расстояние" будет недоступен.

    ПримечаниеПри включении режима "Орто" автоматически отключается полярное отслеживание.

Ввод команды: ОРТО


Ортогональное рисование (Краткий справочник)

Настройка сетки и шаговой привязки
Ортогональное рисование
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Ортогональное рисование >
Ортогональное рисование
Понятие Процедура Краткий справочник

Команды

ОРТО

Ограничение перемещение курсора в вертикальном или горизонтальном направлении

Системные переменные

ORTHOMODE

Управление перемещением курсора в перпендикулярном направлении

TEMPOVERRIDES

Включение и отключение клавиш временной отмены

Утилиты

Нет

Ключевые слова для команд

Нет


Полярные отслеживание и привязка (Понятие)

Ортогональное рисование
Ограничение перемещения курсора
Разовое задание угла отслеживания (Угол)
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Полярное отслеживание ограничивает перемещение курсора направлением под заданным углом. Полярная привязка задает шаг перемещения курсора в заданном направлении.

Полярное отслеживание облегчает выбор точек, лежащих на воображаемых линиях под одним из заданных полярных углов. На 3D видах полярное отслеживание дополнительно обеспечивает траекторию выравнивания в направлениях вверх и вниз. В этом случае в подсказке отображается для угла значение +Z или -Z.

Углы в полярных координатах соотносятся с ориентацией текущей пользовательской системы координат (ПСК) и с параметром для условного обозначения базового угла на чертеже. Базовое направление угла задается в диалоговом окне "Единицы чертежа".

Для привязки к заданным интервалам вдоль траектории выравнивания можно воспользоваться полярной привязкой (PolarSnap™). На следующей иллюстрации приводится пример последовательного построения двух отрезков длиной по 2 единицы каждый: сначала строится горизонтальный отрезок от точки 1 к точке 2, а затем под углом 45 градусов строится второй отрезок к точке 3. Если, например, шаг углов полярного отслеживания равен 45 градусам, линии отслеживания и всплывающие подсказки отображаются под углами, кратными 45 градусам. Текущая линия полярного отслеживания (а также всплывающая подсказка) исчезает, если она оказывается вне прицела курсора.

Линия полярного отслеживания и всплывающая подсказка появляются, если прямая, мысленно проведенная через предыдущую указанную точку и курсор, проходит под углом, близким к одному из полярных углов отслеживания. По умолчанию шаг полярных углов равен 90 градусам. Линию полярного отслеживания и информацию, содержащуюся во всплывающей подсказке, можно использовать при построении объектов. Для нахождения точки пересечения линии полярного отслеживания с другими объектами удобно пользоваться режимами объектной привязки "Пересечение" и "Кажущееся пересечение".

ПримечаниеРежим ортогонального рисования не может использоваться совместно с режимом полярного отслеживания, При включении режима "Орто" полярное отслеживание автоматически отключается. Аналогичным образом полярная привязка (PolarSnap) и привязка к сетке не могут быть включены одновременно. При включении режима полярной привязки отключается режим шаговой привязки к сетке.

Задание углов полярного отслеживания

Полярное отслеживание может осуществляться под углами, кратными следующим стандартным значениям: 90, 45, 30, 22.5, 18, 15, 10 или 5 градусов. Кроме того, пользователь может определить другие значения углов. На следующей иллюстрации показаны некоторые из возможных линий полярного отслеживания при значении углового интервала 30 градусов.

Ориентация угла в 0 градусов зависит от угла, заданного в диалоговом окне "Единицы чертежа" (ЕДИНИЦЫ). Направление отсчета угла привязки (по часовой стрелке или против) также задается при настройке единиц измерения чертежа.

Режим полярного отслеживания можно временно включить или отключить с помощью клавиши отмены. Метод "направление-расстояние" будет недоступен, пока для полярного отслеживания задействована клавиша временной отмены.

Задание интервала полярной привязки

Полярная привязка задает шаг перемещения курсора в заданном направлении. Например, при задании интервала длиной 4 единицы курсор будет позиционироваться в заданном направлении на расстояниях 0, 4, 8, 12, 16 единиц и т.д. При перемещении курсора появляются всплывающие подсказки для ближайшей точки полярной привязки. Для возможности точного указания точек в заданном направлении и на заданном расстоянии следует включить как режим полярного отслеживания, так и режим полярной привязки. Режим всех привязок и отслеживания можно временно отключить с помощью клавиши отмены.

См. также

    • Переопределение параметров объектной привязки


Полярные отслеживание и привязка (Процедура)

Ортогональное рисование
На уровень вверх ..
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Полярные отслеживание и привязка >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Для включения и отключения полярного отслеживания

Для задания шага полярной привязки

Для построения объектов с помощью полярного отслеживания

Для построения объектов с помощью полярной привязки

Для задания углов полярного отслеживания


Для включения и отключения полярного отслеживания (Процедура)

Полярные отслеживание и привязка
На уровень вверх ..
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Полярные отслеживание и привязка >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Для включения и отключения полярного отслеживания

  • Нажмите клавишу F10 или кнопку полярного отслеживания [image] в строке состояния.

    Для временного включения или отключения полярного отслеживания нажмите и удерживайте клавишу F10 во время работы.


Для задания шага полярной привязки (Процедура)

Полярные отслеживание и привязка
На уровень вверх ..
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Полярные отслеживание и привязка >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Для задания шага полярной привязки

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. На вкладке "Шаг и сетка" диалогового окна "Режимы рисования" выбрать "Шаг Вкл".
  3. В группе "Тип привязки" выберите "Полярная привязка".
  4. В группе "Полярная привязка" ввести шаг полярной привязки.
  5. На вкладке №Отслеживание" установите флажок "Полярное отслеживание Вкл".
  6. Из списка "Шаг углов" выбрать нужное значение угла.

    Можно задать и любое другое значение угла. Для этого служат опция "Дополнительные углы" и кнопка "Новый".

  7. Нажать "ОК".
Ввод команды: РЕЖИМРИС
Контекстное меню:Щелкните правой кнопкой мыши на [image] в строке состояния.


Для построения объектов с помощью полярного отслеживания (Процедура)

Полярные отслеживание и привязка
На уровень вверх ..
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Полярные отслеживание и привязка >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Для построения объектов с помощью полярного отслеживания

  1. Включите полярное отслеживание и вызовите команду рисования, например, ДУГА, КРУГ или ОТРЕЗОК.

    Полярное отслеживание можно также использовать при работе с командами редактирования, например, КОПИРОВАТЬ и ПЕРЕНЕСТИ.

  2. Переместить курсор, чтобы появилась пунктирная линия полярного отслеживания под одним из заданных углов. Указать точку на линии полярного отслеживания.
Ввод команды: РЕЖИМРИС


Для построения объектов с помощью полярной привязки (Процедура)

Полярные отслеживание и привязка
На уровень вверх ..
Полярные отслеживание и привязка
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Полярные отслеживание и привязка >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Для построения объектов с помощью полярной привязки

  1. Включить полярные отслеживание и привязку.

    Убедиться, что на вкладке "Шаг и сетка" диалогового окна "Режимы рисования" включена опция "Полярная привязка".

  2. Вызовите команду рисования, например, ОТРЕЗОК.
  3. Переместить курсор так, чтобы появилась пунктирная линия полярного отслеживания, определяющая заданный угол и расстояние от исходной точки.
  4. Указать точку.

    Длина нового отрезка кратна заданному шагу полярной привязки.

Ввод команды: РЕЖИМРИС


Для задания углов полярного отслеживания (Процедура)

Полярные отслеживание и привязка
На уровень вверх ..
Комбинирование и смещение точек и координат
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Полярные отслеживание и привязка >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Для задания углов полярного отслеживания

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. На вкладке "Отслеживание" диалогового окна "Режимы рисования" установить флажок "Полярное отслеживание Вкл".
  3. Из списка "Шаг углов" выбрать угол полярной привязки.
  4. Для указания любого другого угла отметить опцию "Дополнительные углы". Щелкнуть "Создать". Введите значение угла в текстовом поле.
  5. В группе "Отсчет полярных углов" указать метод определения исходного направления, от которого отсчитываются углы (от нулевого направления ПСК или от направления, определяемого последним созданным объектом).
  6. Нажать "ОК".
Ввод команды: РЕЖИМРИС

В строке состояния щелкните правой кнопкой мыши на [image]. Щелкните имеющийся угол или выберите "Режимы", чтобы установить дополнительные углы отслеживания.


Полярные отслеживание и привязка (Краткий справочник)

Ортогональное рисование
Полярные отслеживание и привязка
Разовое задание угла отслеживания (Угол)
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Полярные отслеживание и привязка >
Полярные отслеживание и привязка
Понятие Процедура Краткий справочник

Команды

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

ШАГ

Ограничение перемещения курсора определенными интервалами

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

ANGBASE

Задание для базового угла значения 0 в соответствии с текущей ПСК

ANGDIR

Направление отсчета положительных углов

AUTOSNAP

Управление отображением маркера, всплывающей подсказки и магнита автопривязки

POLARANG

Шаг для полярных углов

POLARDIST

Шаг привязки в случае, если для системной переменной SNAPTYPE установлено значение 1 (полярная привязка)

POLARMODE

Управление полярным и объектным отслеживанием

SNAPTYPE

Тип привязки для текущего видового экрана

TEMPOVERRIDES

Включение и отключение клавиш временной отмены

TRACKPATH

Управление отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки

Утилиты

Нет

Ключевые слова для команд

Нет


Разовое задание угла отслеживания (Угол) (Понятие)

Полярные отслеживание и привязка
Ограничение перемещения курсора
Комбинирование и смещение точек и координат
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора >
Разовое задание угла отслеживания (Угол)
Понятие Краткий справочник

Имеется возможность разового задания угла отслеживания, действующего до указания очередной точки.

Для разового задания угла отслеживания в ответ на запрос о выборе точки следует ввести в командной строке символ знака "меньше" (<) и нужное значение угла. Диалог в командной строке во время выполнения команды ОТРЕЗОК с использованием разового задания угла отслеживания выглядит следующим образом:

Команда: отрезок

Первая точка: Укажите точку начала отрезка

Следующая точка или [Отменить]: <30

Угол отслеживания: 30

Следующая точка или [Отменить]: Укажите точку

Заданный угол определяет направление перемещения курсора, игнорируя настройки шаговой привязки, ортогонального отслеживания и полярной привязки. Остаются действующими режим объектной привязки и метод задания координат.


Разовое задание угла отслеживания (Угол) (Краткий справочник)

Полярные отслеживание и привязка
Разовое задание угла отслеживания (Угол)
Комбинирование составляющих координат с помощью координатных фильтров
Создание и редактирование объектов > Средства обеспечения точности > Ограничение перемещения курсора > Разовое задание угла отслеживания (Угол) >
Разовое задание угла отслеживания (Угол)
Понятие Краткий справочник

Команды

Нет

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Комбинирование и смещение точек и координат

Разовое задание угла отслеживания (Угол)
Средства обеспечения точности
Комбинирование составляющих координат с помощью координатных фильтров
Создание и редактирование объектов > Средства обеспечения точности >
Комбинирование и смещение точек и координат
Понятие Процедура

Чтобы задать новое положение точки, можно объединить координатные значения из нескольких точек или указать смещения от существующих объектов.

Темы в этом разделе

  • Комбинирование составляющих координат с помощью координатных фильтров

    Координатные фильтры используются для единовременного извлечения одного координатного значения из местоположений в существующих объектах.

  • Объектное отслеживание

    Создаваемые объекты можно размещать в определенной зависимости относительно других объектов с помощью линий отслеживания.

  • Отслеживание со смещением от опорных точек

    С помощью отслеживания со смещением можно получать новые точки путем вертикального и горизонтального смещения временных опорных точек.


Комбинирование и смещение точек и координат (Процедура)

Полярные отслеживание и привязка
Комбинирование и смещение точек и координат
Комбинирование составляющих координат с помощью координатных фильтров
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат >
Комбинирование и смещение точек и координат
Понятие Процедура

Для задания 2D точки с использованием координатных фильтров

Для задания 3D точки с использованием координатных фильтров

Для включения и отключения объектного отслеживания

Для изменения параметров автоотслеживания

Для задания точки с помощью отслеживания


Комбинирование составляющих координат с помощью координатных фильтров (Понятие)

Комбинирование и смещение точек и координат
Комбинирование и смещение точек и координат
Объектное отслеживание
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат >
Комбинирование составляющих координат с помощью координатных фильтров
Понятие Процедура Краткий справочник

Координатные фильтры используются для единовременного извлечения одного координатного значения из местоположений в существующих объектах.

Координатными фильтрами указывается положение новой координаты с помощью значения X из одного положения, значения Y - из второго положения, а для 3D координат - значения Z из третьего положения. В сочетании с объектной привязкой координатные фильтры можно использовать для получения значений координат из существующего объекта.

Как правило, координатные фильтры используются для указания центра прямоугольника или проекции 3D точки на плоскость XY ПСК.

Для указания фильтра в командной строке нужно ввести знак десятичной точки, а затем одну или несколько букв: X, Y или Z. Следующий ввод ограничен только конкретным координатным значением.

Пример: Использование фильтров в 2D

Отверстие в крепежной пластине на следующем чертеже отцентрировано относительно прямоугольника путем извлечения координат X,Y середин горизонтального и вертикального ребер детали соответственно.

Последовательность набора в командной строке выглядит так:

Команда: круг

Центр круга или [3Т/2Т/ККР (кас кас радиус)]:x

сер

Выбрать горизонтальный отрезок нижнее ребро крепежной пластины

(требуется YZ): сер

Выбрать вертикальный отрезок левое ребро крепежной пластины

Диаметр/<Радиус> Задать радиус отверстия

Координатные фильтры действуют только в том случае, когда программа запрашивает точку. При попытке использования координатных фильтров в ответ на подсказку "команда" программа выводит сообщение об ошибке.

Пример: Использование координатных фильтров в 3D

В данном примере показано использование координатного фильтра для создания объекта точки в центре 3D объекта. Для простоты восприятия невидимые линии подавлены. Координата X новой точки извлекаются из первой заданной точки, координата Y - из второй точки, а Z - из третьей точки. В результате комбинирования этих трех значений получаются координаты новой точки.

Команда: точка

Точка: .x

сер

Выбрать объект (1)

(требуется YZ): .y

сер

Выбрать объект (2)

(требуется Z): сер

Выбрать объект (3)


Комбинирование составляющих координат с помощью координатных фильтров (Процедура)

Комбинирование и смещение точек и координат
На уровень вверх ..
Комбинирование составляющих координат с помощью координатных фильтров
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Комбинирование составляющих координат с помощью координатных фильтров >
Комбинирование составляющих координат с помощью координатных фильтров
Понятие Процедура Краткий справочник

Для задания 2D точки с использованием координатных фильтров

Для задания 3D точки с использованием координатных фильтров


Для задания 2D точки с использованием координатных фильтров (Процедура)

Комбинирование составляющих координат с помощью координатных фильтров
На уровень вверх ..
Комбинирование составляющих координат с помощью координатных фильтров
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Комбинирование составляющих координат с помощью координатных фильтров >
Комбинирование составляющих координат с помощью координатных фильтров
Понятие Процедура Краткий справочник

Для задания 2D точки с использованием координатных фильтров

  1. В ответ на запрос координат точки в командной строке указать координатный фильтр (.x или .y).

    Например, для задания значения координаты Xввести .x.

  2. Указать точку, из координат которой выделяется координатная составляющая.

    Например, в случае выбора фильтра .x в пункте 1, значение X выделяется из этой точки.

  3. Для получения остальных значений координат укажите другую точку.

    Положение новой точки объединяет координатные значения, извлеченные из точек, которые заданы в пункте 2 и 3.

ПримечаниеПри выполнении п.2 и п.3 вместо указания точек можно вводить числовые значения.


Для задания 3D точки с использованием координатных фильтров (Процедура)

Комбинирование составляющих координат с помощью координатных фильтров
На уровень вверх ..
Объектное отслеживание
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Комбинирование составляющих координат с помощью координатных фильтров >
Комбинирование составляющих координат с помощью координатных фильтров
Понятие Процедура Краткий справочник

Для задания 3D точки с использованием координатных фильтров

  1. В ответ на запрос координат точки в командной строке укажите координатный фильтр (.x, .y, .z, .xy, .xz или .yz).

    Например, для задания значения координаты Xввести .x.

  2. Указать точку, из координат которой выделяются значения.

    Например, в случае выбора фильтра .x в пункте 1, значение X выделяется из этой точки.

  3. В ответ на запрос остальных координат выполнить одно из действий:
    • Указать точку для получения остальных координатных значений.
    • Ввести другой координатный фильтр и вернуться к п.2.

    Например, в случае выбора фильтра .x в пункте 1, укажите вторую точку для одновременного выделения координат Y и Z либо введите .y или .z, чтобы отдельно указать значения Y и Z.

    Положение новой точки объединяет координатные значения, извлеченные из точек, которые заданы в пункте 2 и 3.

ПримечаниеПри выполнении п.2 и п.3 вместо указания точек можно вводить числовые значения.


Комбинирование составляющих координат с помощью координатных фильтров (Краткий справочник)

Разовое задание угла отслеживания (Угол)
Комбинирование составляющих координат с помощью координатных фильтров
Объектное отслеживание
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Комбинирование составляющих координат с помощью координатных фильтров >
Комбинирование составляющих координат с помощью координатных фильтров
Понятие Процедура Краткий справочник

Команды

Нет

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Координатные фильтры

Задание координат точки путем комбинирования значений X, Y и Z других точек


Объектное отслеживание (Понятие)

Комбинирование составляющих координат с помощью координатных фильтров
Комбинирование и смещение точек и координат
Отслеживание со смещением от опорных точек
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат >
Объектное отслеживание
Понятие Процедура Краткий справочник

Создаваемые объекты можно размещать в определенной зависимости относительно других объектов с помощью линий отслеживания.

Средства автоотслеживания (AutoTrack™) позволяют располагать объекты под определенными углами или в определенной зависимости относительно других объектов чертежа. При включенных режимах автоотслеживания специальные временные линии отслеживания помогают выполнять точные построения. Автоотслеживание включает в себя два варианта отслеживания: полярное отслеживание и отслеживание объектной привязки.

Режимы автоотслеживания можно быстро включать и отключать нажатием кнопок "ОТС-ПОЛЯР" и "ОТС-ОБЪЕКТ" в строке состояния. Использование клавиш временной отмены для включения и отключения отслеживания объектной привязки или отключения всех режимов привязки и отслеживания. См. чертеж с изображением клавиатуры в разделе Переопределение параметров объектной привязки.

Объектное отслеживание расширяет и дополняет возможности объектной привязки. Для использования объектного отслеживания необходимо наличие включенных режимов объектной привязки.

Объектное отслеживание

Объектное отслеживание облегчает выбор точек, которые лежат на линиях отслеживания, проходящих через характерные точки объектов. Захваченная точка помечается маркером в виде маленького знака "плюс" (+). Одновременно может быть захвачено до семи точек чертежа. После захвата точки по мере передвижения курсора появляются вертикальные, горизонтальные или полярные линии отслеживания, проходящие через данную точку. Таким образом, можно, например, выбрать точку, лежащую на пересечении линий, проходящих через конечные точки или середины объектов.

На следующей иллюстрации приводится пример построения отрезка с использованием режима объектной привязки "Конточка". Сначала задается первая точка отрезка (1), затем курсор перемещается к имеющемуся отрезку для захвата его конечной точки (2), после чего курсор перемещается вдоль горизонтальной линии отслеживания для выбора конечной точки (3) нового отрезка.

Изменение параметров объектного отслеживания

По умолчанию разрешено только ортогональное отслеживание. При этом линии отслеживания проводятся через захваченную точку только под углами 0, 90, 180 и 270 градусов. Однако, при необходимости объектное отслеживание можно осуществлять вдоль всех текущих полярных углов отслеживания.

Для отслеживания объектной привязки точки объекта запрашиваются автоматически. Однако можно установить такой режим, при котором захват точек происходит только по нажатию клавиши SHIFT.

Настройка отображения линий отслеживания

В функции автоотслеживания имеется возможность управления параметрами отображения линий отслеживания, а также способом захвата точек объектов для отслеживания объектных привязок. По умолчанию линии отслеживания являются бесконечными (продолжаются до границ области рисования). Однако можно установить такой режим, при котором длина линий отслеживания ограничивается текущим положением курсора.

Советы по использованию объектного отслеживания

Автоотслеживание (полярное и объектное) позволяет более простыми способами строить объекты, имеющие определенную геометрическую зависимость от других объектов. Ниже приводятся некоторые советы по использованию автоотслеживания при объектной привязке.

  • Для выбора точек, лежащих на перпендикулярах к концам или серединам объектов, объектное отслеживание следует использовать совместно с режимами привязки "Нормаль", "Конточка" и "Середина".
  • Для выбора точек, лежащих на касательной к конечной точке дуги, объектное отслеживание следует использовать совместно с режимами привязки "Касательная" и "Конточка".
  • Отслеживание можно осуществлять от так называемых временных точек отслеживания. Для задания такой точки в ответ на запрос команды выбрать точку, ввести то и указать нужную точку. Указанная точка помечается маленьким маркером в виде знака "плюс" (+). Далее, по мере перемещения курсора поочередно появляются линии отслеживания, проходящие через временную точку отслеживания. Для удаления временной точки нужно при перемещении задержать курсор на ее маркере (знаке "плюс").
  • Можно выбрать точку, находящуюся на заданном расстоянии от точки объектной привязки вдоль линии отслеживания. Для этого следует выбрать режим объектной привязки и после появления линии отслеживания ввести в командной строке требуемое значение расстояния.
    Примечание Метод "направление-расстояние" будет недоступен, пока для отслеживания объектной привязки задействована клавиша временной отмены.
  • Для изменения способа захвата точек используются параметры "Автоматически" и "Нажатием SHIFT" во вкладке "Построения" диалогового окна "Настройка". По умолчанию устанавливается автоматический способ. Для временного предотвращения захвата точки в областях чертежа с высокой плотностью объектов удерживайте нажатой клавишу SHIFT.


Объектное отслеживание (Процедура)

Комбинирование составляющих координат с помощью координатных фильтров
На уровень вверх ..
Объектное отслеживание
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Объектное отслеживание >
Объектное отслеживание
Понятие Процедура Краткий справочник

Для включения и отключения объектного отслеживания

Для изменения параметров автоотслеживания


Для включения и отключения объектного отслеживания (Процедура)

Объектное отслеживание
На уровень вверх ..
Объектное отслеживание
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Объектное отслеживание >
Объектное отслеживание
Понятие Процедура Краткий справочник

Для включения и отключения объектного отслеживания

  • Нажмите клавишу F11 или кнопку [image] в строке состояния.

    Для временного включения и отключения отслеживания объектной привязки удерживайте нажатой клавишу F11 во время работы.


Для изменения параметров автоотслеживания (Процедура)

Объектное отслеживание
На уровень вверх ..
Отслеживание со смещением от опорных точек
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Объектное отслеживание >
Объектное отслеживание
Понятие Процедура Краткий справочник

Для изменения параметров автоотслеживания

  1. В меню Сервис выберите [image] Настройка.В командной строке введите "настройка".
  2. В диалоговом окне "Параметры" на вкладке "Построения" в разделе "Параметры автоотслеживания" установите или снимите флажки, связанные с настройкой отображения линий отслеживания:
    • Бесконечные линии полярного отслеживания. Отображение линий объектного отслеживания в виде бесконечных прямых. Если флажок сброшен, линия полярного отслеживания проводится от предыдущей указанной точки до курсора.
    • Бесконечные линии объектного отслеживания. Отображение линий объектного отслеживания в виде бесконечных прямых. Если флажок сброшен, линия объектного отслеживания проводится от точки привязки до курсора.
    • Всплывающие подсказки автоотслеживания. Управление выводом подсказок для автоотслеживания. Всплывающие подсказки дают информацию о типе объектной привязки (при объектном отслеживании), текущем угле отслеживания и расстоянии до предыдущей точки.
  3. В группе "Захват точек отслеживания" выбрать способ захвата характерных точек объектов для отслеживания:
    • Автоматически. Автоматический захват точек объекта. Если выбран данный способ, для предотвращения захвата характерной точки объекта можно удерживать нажатой клавишу SHIFT.
    • Нажатием SHIFT. Захват точек происходит только при нажатии клавиши SHIFT в момент, когда курсор находится над точкой объектной привязки.
Ввод команды: НАСТРОЙКА


Объектное отслеживание (Краткий справочник)

Комбинирование составляющих координат с помощью координатных фильтров
Объектное отслеживание
Отслеживание со смещением от опорных точек
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Объектное отслеживание >
Объектное отслеживание
Понятие Процедура Краткий справочник

Команды

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

AUTOSNAP

Управление отображением маркера, всплывающей подсказки и магнита автопривязки

POLARMODE

Управление полярным и объектным отслеживанием

TRACKPATH

Управление отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки

Утилиты

Нет

Ключевые слова для команд

Нет


Отслеживание со смещением от опорных точек (Понятие)

Объектное отслеживание
Комбинирование и смещение точек и координат
Задание расстояний
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат >
Отслеживание со смещением от опорных точек
Понятие Процедура Краткий справочник

С помощью отслеживания со смещением можно получать новые точки путем вертикального и горизонтального смещения временных опорных точек.

Метод отслеживания можно применять во время запроса точки. При использовании отслеживания с помощью устройства указания можно задавать новые точки путем вертикального и горизонтального смещения временных опорных точек. После включения режима отслеживания и установки базовой опорной точки последующая опорная точка располагается на горизонтальных или вертикальных линиях отслеживания, проведенных от этой точки. Направление смещения определяется резиновой линией. Его можно изменить путем перемещения курсора через опорную точку. Допустимое число временных точек отслеживания не ограничено. Как правило, отслеживание используется в сочетании с режимами объектной привязки или методом задания точек "направление-расстояние".

Например, отслеживание можно использовать для определения центра прямоугольника без построения вспомогательных линий. Для этого необходимо включить отслеживание и указать середину горизонтального отрезка. Затем вертикально переместить курсор до середины вертикального отрезка (2). Нажмите ENTER для принятия точки (3) в центре прямоугольника.


Для задания точки с помощью отслеживания (Процедура)

Объектное отслеживание
На уровень вверх ..
Задание расстояний
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Отслеживание со смещением от опорных точек >
Отслеживание со смещением от опорных точек
Понятие Процедура Краткий справочник

Для задания точки с помощью отслеживания

  1. Вызовите команду (например, команду ОТРЕЗОК).
  2. Удерживая нажатой клавишу SHIFT, нажмите правую кнопку мыши в области чертежа. Выберите "Слежение".
  3. Указать точку.
  4. Переместить курсор вверх, вниз, влево или вправо до появления резиновой линии.

    Выбранным таким образом направлением задается направление отслеживания. Следует иметь в виду, что после перемещения курсора слева направо, если необходимо сменить направление перемещения вверх или вниз, нужно предварительно вернуть курсор на предыдущую заданную точку.

  5. Укажите вторую точку.
  6. Нажмите ENTER для завершения отслеживания.

    После этого начальная точка отрезка устанавливается в точке воображаемого пересечения вертикальной и горизонтальной линий отслеживания, проведенных через заданные точки. Расположение точки определяется направлением перемещения курсора после указания первой точки.

Ввод команды: СЛЕЖЕНИЕ (Ключевое слово)


Отслеживание со смещением от опорных точек (Краткий справочник)

Объектное отслеживание
Отслеживание со смещением от опорных точек
Метод задания координат "направление-расстояние"
Создание и редактирование объектов > Средства обеспечения точности > Комбинирование и смещение точек и координат > Отслеживание со смещением от опорных точек >
Отслеживание со смещением от опорных точек
Понятие Процедура Краткий справочник

Команды

Нет

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

ОТСЛЕЖИВАНИЕ

Указание положения точки с помощью вспомогательных точек


Задание расстояний

Отслеживание со смещением от опорных точек
Средства обеспечения точности
Метод задания координат "направление-расстояние"
Создание и редактирование объектов > Средства обеспечения точности >
Задание расстояний
Понятие Процедура

При указании точек можно вводить значения расстояний, смещений и интервалов.

Темы в этом разделе

  • Метод задания координат "направление-расстояние"

    Положение точки можно задавать путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния.

  • Смещение от временных опорных точек

    Пользователь может устанавливать временную опорную точку в качестве базовой для смещения последующих точек.

  • Разметка и деление объектов

    Имеется возможность выполнения разметки вдоль объектов с равным интервалом.


Задание расстояний (Процедура)

Отслеживание со смещением от опорных точек
Задание расстояний
Метод задания координат "направление-расстояние"
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний >
Задание расстояний
Понятие Процедура

Для построения отрезка методом "направление-расстояние"

Для смещения точки от временной опорной точки


Метод задания координат "направление-расстояние" (Понятие)

Задание расстояний
Задание расстояний
Смещение от временных опорных точек
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний >
Метод задания координат "направление-расстояние"
Понятие Процедура Краткий справочник

Положение точки можно задавать путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния.

Длину отрезка или положение точки можно быстро задавать путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния от первой заданной точки. Можно вводить вычисленные значения расстояния из калькулятора БыстрКальк. Дополнительные сведения см. в разделе Использование калькулятора БыстрКальк .

Методом "направление-расстояние" можно пользоваться при задании точек во всех командах, где требуется указание более одной точки. При включенном режиме "Орто" или полярном отслеживании этим способом очень удобно рисовать отрезки определенной длины в заданном направлении, а также перемещать или копировать объекты.

Примечание Метод "направление-расстояние" будет недоступен, пока для режима "Орто", отслеживания объектной привязки или полярного отслеживания задействованы клавиши временной отмены.
См. также

    • Полярные отслеживание и привязка

    • Разовое задание угла отслеживания (Угол)


Для построения отрезка методом "направление-расстояние" (Процедура)

Задание расстояний
На уровень вверх ..
Смещение от временных опорных точек
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Метод задания координат "направление-расстояние" >
Метод задания координат "направление-расстояние"
Понятие Процедура Краткий справочник

Для построения отрезка методом "направление-расстояние"

  1. Вызвать команду ОТРЕЗОК и указать первую точку.
  2. Перемещать устройство указания до тех пор, пока резиновая линия, соединяющая первую точку и перекрестье, не окажется повернутой под требуемым углом.
  3. Введите команду "расстояние" в командной строке.

    На экране появляется отрезок, имеющий заданную длину и располагающийся в указанном направлении.


Метод задания координат "направление-расстояние" (Краткий справочник)

Отслеживание со смещением от опорных точек
Метод задания координат "направление-расстояние"
Смещение от временных опорных точек
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Метод задания координат "направление-расстояние" >
Метод задания координат "направление-расстояние"
Понятие Процедура Краткий справочник

Команды

ОТРЕЗОК

Построение отрезков

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Метод "направление-расстояние

Размещение следующей точки на определенном расстоянии от предыдущей в направлении, заданном с помощью курсора


Смещение от временных опорных точек (Понятие)

Метод задания координат "направление-расстояние"
Задание расстояний
Разметка и деление объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний >
Смещение от временных опорных точек
Понятие Процедура Краткий справочник

Пользователь может устанавливать временную опорную точку в качестве базовой для смещения последующих точек.

Режим "Смещение" позволяет устанавливать временную опорную точку в качестве базовой для смещения последующих точек. Режим "Смещение" не ограничивает направление перемещения курсора. Как правило, режим "Смещение" используется совместно с режимами объектной привязки.


Для смещения точки от временной опорной точки (Процедура)

Метод задания координат "направление-расстояние"
На уровень вверх ..
Разметка и деление объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Смещение от временных опорных точек >
Смещение от временных опорных точек
Понятие Процедура Краткий справочник

Для смещения точки от временной опорной точки

  1. На запрос указания точки введите сме. Есть и другой способ: при нажатой клавише SHIFT нажмите правую кнопку мыши для вызова меню объектной привязки и выберите "Смещение".
  2. Если нужно выполнить смещение от точки, расположенной на имеющемся объекте, укажите режим объектной привязки. Затем выберите точку объектной привязки.
  3. Введите относительные координаты (например, @1,1).


Смещение от временных опорных точек (Краткий справочник)

Метод задания координат "направление-расстояние"
Смещение от временных опорных точек
Команды разметки объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Смещение от временных опорных точек >
Смещение от временных опорных точек
Понятие Процедура Краткий справочник

Команды

Нет

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

СМЕЩЕНИЕ

Привязка к точке, смещенной от указанной опорной точки на заданное расстояние


Разметка и деление объектов

Смещение от временных опорных точек
Задание расстояний
Команды разметки объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний >
Разметка и деление объектов
Понятие Процедура

Имеется возможность выполнения разметки вдоль объектов с равным интервалом.

Темы в этом разделе

  • Команды разметки объектов

    Обзор команд для выполнения разметки вдоль объектов с равным интервалом.

  • Разметка объектов

    Пользователь может делать разметку вдоль выбранного объекта с заданным шагом.

  • Деление объектов на равные сегменты

    Выбранный объект можно разделить на заданное число равных сегментов.


Разметка и деление объектов (Процедура)

Смещение от временных опорных точек
На уровень вверх ..
Разметка объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов >
Разметка и деление объектов
Понятие Процедура

Для разметки объекта с помощью точек

Для разметки объекта с помощью блоков

Для деления объекта точками на равные сегменты

Для деления объекта на равные сегменты с помощью блоков


Команды разметки объектов (Понятие)

Разметка и деление объектов
Разметка и деление объектов
Разметка объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов >
Команды разметки объектов
Понятие Краткий справочник

Обзор команд для выполнения разметки вдоль объектов с равным интервалом.

Иногда возникает необходимость расставить точки или блоки вдоль объекта на определенных расстояниях друг от друга.

Пользователь может:

  • РАЗМЕТИТЬ если известны длины сегментов.
  • ПОДЕЛИТЬ если известно число равных по длине сегментов.

Размечать и делить можно отрезки, дуги, сплайны, окружности, эллипсы и полилинии. Обе команды производят разметку путем простановки либо объектов-точек, либо блоков.

Если разметка производится с помощью точек, то впоследствии, используя режим объектной привязки "Узел", можно располагать в этих точках (находящихся на одинаковом расстоянии друг от друга) другие объекты. Разметка с помощью блоков позволяет расставлять последовательности геометрических объектов или пользовательские маркеры. Имеется возможность задавать поворот блоков в точках вставки.

Вставляемые блоки должны быть определены в чертеже. Переменные атрибуты блоков при вставке игнорируются.

Точки или блоки, созданные с помощью команд РАЗМЕТИТЬ и ПОДЕЛИТЬ, помещаются в текущий набор объектов. Таким образом, если сразу после расстановки необходимо редактирование этих объектов, выбрать их можно с помощью опции "Текущий" команды ВЫБРАТЬ.

См. также

    • Создание и использование блоков (обозначений)


Команды разметки объектов (Краткий справочник)

Смещение от временных опорных точек
Команды разметки объектов
Разметка объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Команды разметки объектов >
Команды разметки объектов
Понятие Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

ДИАЛТТОЧ

Задание стиля отображения и величины точечных объектов

ПОДЕЛИТЬ

Размещение точек или блоков на равном расстоянии по длине или периметру объекта

РАЗМЕТИТЬ

Размещение точек или блоков на объекте с равными интервалами

ПБЛОК

Запись объектов или блока в новый файл чертежа

Системные переменные

PDMODE

Управление отображением точечных объектов

PDSIZE

Размер отображения точечных объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Разметка объектов (Понятие)

Команды разметки объектов
Разметка и деление объектов
Деление объектов на равные сегменты
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов >
Разметка объектов
Понятие Процедура Краткий справочник

Пользователь может делать разметку вдоль выбранного объекта с заданным шагом.

Разметка объекта с заданным шагом производится командой РАЗМЕТИТЬ. В точках разметки могут проставляться либо объекты-точки, либо блоки. Последний сегмент размеченного объекта может оказаться короче заданного шага.

Выбор начальной точки для разметки и деления зависит от типа объекта. Для отрезков и разомкнутых полилиний начальная точка - конец объекта, ближайший к точке выбора. Для замкнутых полилиний начальная точка находится в начале полилинии. Для окружностей начальная точка располагается от центра под углом, равным текущему углу поворота шаговой привязки. Например, если угол поворота равен нулю, деление окружности идет в направлении против часовой стрелки начиная с точки окружности, радиус к которой ориентирован в восточном направлении.

Шаг разметки невозможно рассмотреть, если точки разметки отображаются как простые точки (по умолчанию). Стиль точек можно изменить несколькими способами. Для изменения стиля точек через диалоговое окно можно использовать команду ДИАЛТТОЧ. Как вариант, можно выбрать меню "Формат" [image] и нажать "Отображение точек". Вид точек разметки и деления можно также задать с помощью системной переменной PDMODE. Например, можно изменить значение таким образом, чтобы точки отображались в виде крестиков. Размером объектов-точек управляет системная переменная PDSIZE.


Разметка объектов (Процедура)

Разметка и деление объектов
На уровень вверх ..
Разметка объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Разметка объектов >
Разметка объектов
Понятие Процедура Краткий справочник

Для разметки объекта с помощью точек

Для разметки объекта с помощью блоков


Для разметки объекта с помощью точек (Процедура)

Разметка объектов
На уровень вверх ..
Разметка объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Разметка объектов >
Разметка объектов
Понятие Процедура Краткий справочник

Для разметки объекта с помощью точек

  1. Выберите меню Рисование [image] Точка [image] Разметить.В командной строке введите "разметить".
  2. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  3. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.

    Точки размещаются на объекте с указанным шагом.

Ввод команды: РАЗМЕТИТЬ


Для разметки объекта с помощью блоков (Процедура)

Разметка объектов
На уровень вверх ..
Деление объектов на равные сегменты
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Разметка объектов >
Разметка объектов
Понятие Процедура Краткий справочник

Для разметки объекта с помощью блоков

  1. Если необходимо, создать предварительно блок.
  2. Выберите меню Рисование [image] Точка [image] Разметить.В командной строке введите "разметить".
  3. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  4. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.
  5. Ввести имя вставляемого блока.
  6. Ввести д для поворота блоков при вставке так, чтобы каждый блок ориентировался по касательной к размечаемому объекту. Ввести н для вставки блоков без поворота.
  7. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.

    Блоки вставляются на объекте с указанным шагом.

Ввод команды: БЛОК, РАЗМЕТИТЬ


Разметка объектов (Краткий справочник)

Команды разметки объектов
Разметка объектов
Деление объектов на равные сегменты
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Разметка объектов >
Разметка объектов
Понятие Процедура Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

ДИАЛТТОЧ

Задание стиля отображения и величины точечных объектов

РАЗМЕТИТЬ

Размещение точек или блоков на объекте с равными интервалами

Системные переменные

PDMODE

Управление отображением точечных объектов

PDSIZE

Размер отображения точечных объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Деление объектов на равные сегменты (Понятие)

Разметка объектов
Разметка и деление объектов
Получение геометрической информации от объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов >
Деление объектов на равные сегменты
Понятие Процедура Краткий справочник

Выбранный объект можно разделить на заданное число равных сегментов.

Иногда возникает необходимость расставить точки или блоки вдоль объекта на определенных расстояниях друг от друга. Фактического деления объекта на отдельные части данной командой не производится. Определяется только местоположение делений, чтобы можно было использовать их как геометрические опорные точки.

Выбор начальной точки для разметки и деления зависит от типа объекта. Для отрезков и разомкнутых полилиний начальная точка - конец объекта, ближайший к точке выбора. Для замкнутых полилиний начальная точка находится в начале полилинии. Для окружностей начальная точка располагается от центра под углом, равным текущему углу поворота шаговой привязки. Например, если угол поворота равен нулю, деление окружности идет в направлении против часовой стрелки начиная с точки окружности, радиус к которой ориентирован в восточном направлении.

Сегменты невозможно рассмотреть, если точки деления отображаются как простые точки (по умолчанию). Стиль точек можно изменить несколькими способами. Для изменения стиля точек в диалоговом окне можно использовать команду ДИАЛТТОЧ. Как вариант, можно выбрать меню "Формат" [image] и нажать "Отображение точек". Вид точек разметки и деления можно также задать с помощью системной переменной PDMODE. Например, можно изменить значение таким образом, чтобы точки отображались в виде крестиков. Размером объектов-точек управляет системная переменная PDSIZE.


Деление объектов на равные сегменты (Процедура)

Разметка объектов
На уровень вверх ..
Деление объектов на равные сегменты
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Деление объектов на равные сегменты >
Деление объектов на равные сегменты
Понятие Процедура Краткий справочник

Для деления объекта точками на равные сегменты

Для деления объекта на равные сегменты с помощью блоков


Для деления объекта точками на равные сегменты (Процедура)

Деление объектов на равные сегменты
На уровень вверх ..
Деление объектов на равные сегменты
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Деление объектов на равные сегменты >
Деление объектов на равные сегменты
Понятие Процедура Краткий справочник

Для деления объекта точками на равные сегменты

  1. Выберите меню Рисование [image] Точка [image] Поделить.В командной строке введите "поделить".
  2. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  3. Ввести требуемое число сегментов.

    Точка помещается между каждым сегментом.

Ввод команды: ПОДЕЛИТЬ


Для деления объекта на равные сегменты с помощью блоков (Процедура)

Деление объектов на равные сегменты
На уровень вверх ..
Получение геометрической информации от объектов
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Деление объектов на равные сегменты >
Деление объектов на равные сегменты
Понятие Процедура Краткий справочник

Для деления объекта на равные сегменты с помощью блоков

  1. Если необходимо, создать предварительно блок.
  2. Выберите меню Рисование [image] Точка [image] Поделить.В командной строке введите "поделить".
  3. Выбрать отрезок, дугу, сплайн, окружность, эллипс или полилинию.
  4. Ввести значение шага разметки с клавиатуры или указанием двух точек чертежа.
  5. Ввести имя вставляемого блока.
  6. Ввести д для поворота блоков при вставке так, чтобы каждый блок ориентировался по касательной к размечаемому объекту. Ввести н для вставки блоков без поворота.
  7. Ввести требуемое число сегментов.
Ввод команды: БЛОК, ПОДЕЛИТЬ


Деление объектов на равные сегменты (Краткий справочник)

Разметка объектов
Деление объектов на равные сегменты
Вычисление расстояний, углов и определение координат
Создание и редактирование объектов > Средства обеспечения точности > Задание расстояний > Разметка и деление объектов > Деление объектов на равные сегменты >
Деление объектов на равные сегменты
Понятие Процедура Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

ДИАЛТТОЧ

Задание стиля отображения и величины точечных объектов

ПОДЕЛИТЬ

Размещение точек или блоков на равном расстоянии по длине или периметру объекта

ПБЛОК

Запись объектов или блока в новый файл чертежа

Системные переменные

PDMODE

Управление отображением точечных объектов

PDSIZE

Размер отображения точечных объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Получение геометрической информации от объектов

Деление объектов на равные сегменты
Средства обеспечения точности
Вычисление расстояний, углов и определение координат
Создание и редактирование объектов > Средства обеспечения точности >
Получение геометрической информации от объектов
Понятие Процедура

Пользователю предоставлен ряд команд для получения справочной информации об объектах чертежа и выполнения математических расчетов.

Темы в этом разделе

  • Вычисление расстояний, углов и определение координат

    Имеется возможность получения информации о взаимном расположении двух заданных точек: например, можно определить расстояние между ними или угол в плоскости XY.

  • Получение сведений о площади и свойствах массы

    Программа позволяет получать данные о площади, периметре и свойствах массы для области, ограниченной выбранными объектами или последовательностью точек.


Получение геометрической информации от объектов (Процедура)

Деление объектов на равные сегменты
Получение геометрической информации от объектов
Вычисление расстояний, углов и определение координат
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов >
Получение геометрической информации от объектов
Понятие Процедура

Для вычисления расстояния и угла

Для вычисления площади заданной области

Для вычисления площади объекта

Для суммирования площадей

Для вычитания площади из подсчитанной общей площади


Вычисление расстояний, углов и определение координат (Понятие)

Получение геометрической информации от объектов
Получение геометрической информации от объектов
Получение сведений о площади и свойствах массы
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов >
Вычисление расстояний, углов и определение координат
Понятие Процедура Краткий справочник

Имеется возможность получения информации о взаимном расположении двух заданных точек: например, можно определить расстояние между ними или угол в плоскости XY.

Пользователь имеет возможность получить следующую информацию о паре выбранных точек:

  • Расстояние между точками
  • Угол между точками в плоскости XY
  • Угол между воображаемым отрезком, проведенным через точки, и плоскостью XY
  • Разности координат точек по осям X, Y и Z

Получить координаты заданной точки можно с помощью команды КООРД.

См. также

    • Методы записи координат


Для вычисления расстояния и угла (Процедура)

Получение геометрической информации от объектов
На уровень вверх ..
Получение сведений о площади и свойствах массы
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Вычисление расстояний, углов и определение координат >
Вычисление расстояний, углов и определение координат
Понятие Процедура Краткий справочник

Для вычисления расстояния и угла

  1. Выберите вкладку "Инструменты" [image] панель "Сведения" [image] "Расстояние".В командной строке введите "дист".
  2. Указать первую и вторую точки, между которыми требуется определить расстояние.

    В командной строке отображается краткий отчет.

Панель:Сведения
Ввод команды: ДИСТ


Вычисление расстояний, углов и определение координат (Краткий справочник)

Деление объектов на равные сегменты
Вычисление расстояний, углов и определение координат
Получение сведений о площади и свойствах массы
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Вычисление расстояний, углов и определение координат >
Вычисление расстояний, углов и определение координат
Понятие Процедура Краткий справочник

Команды

ДИСТ

Измерение расстояний и углов между точками

КООРД

Определение координат точек

Системные переменные

DISTANCE

Сохранение значения расстояния, вычисленного с помощью команды ДИСТ

Утилиты

Нет

Ключевые слова для команд

Нет


Получение сведений о площади и свойствах массы (Понятие)

Вычисление расстояний, углов и определение координат
Получение геометрической информации от объектов
Использование калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов >
Получение сведений о площади и свойствах массы
Понятие Процедура Краткий справочник

Программа позволяет получать данные о площади, периметре и свойствах массы для области, ограниченной выбранными объектами или последовательностью точек.

Можно рассчитать и вывести на экран данные о площади и периметре для последовательности точек. Можно также получить данные о площади, периметре и свойствах массы для любого из нескольких типов объектов.

СоветСамый быстрый способ вычисления площади, ограничиваемой несколькими объектами в 2D, состоит в использовании команды КОНТУР. С помощью команды ГРАНИЦЫ можно выбрать точку в пределах площади с целью создания замкнутой полилинии или области. Далее можно использовать палитру "Свойства" или команду СПИСОК с целью получения площади и периметра полилинии или области.

Использование команды ПЛОЩАДЬ

С помощью команды ПЛОЩАДЬ можно задавать серии точек или выбирать объект. Если требуется найти общую площадь нескольких объектов, можно задать режим суммирования или вычитания последовательно вычисляемых площадей. Для выбора объектов в данном случае нельзя пользоваться рамкой выбора и секущей рамкой.

Вычисленные значения площади и периметра сохраняются в системных переменных AREA и PERIMETER.

Вычисление площади области, ограниченной точками

Можно вычислить площадь произвольной замкнутой области, определенной указанием набора двумерных или трехмерных точек. Все точки должны лежать в плоскости, параллельной плоскости XY текущей ПСК.

Вычисление площади, периметра или длины окружности объекта

Можно вычислить площадь, занимаемую кругом, эллипсом, полилинией, многоугольником или трехмерным телом, а также периметр объекта или длину его окружности. Набор выводимой информации зависит от типа выбранного объекта:

  • Круг. Площадь и длина окружности.
  • Эллипс, замкнутая полилиния, многоугольник, планарный замкнутый сплайн и область. Площадь и периметр. Для широкой полилинии вычисляется площадь, ограниченная ее осевой линией.
  • Разомкнутые объекты (разомкнутые сплайновые кривые, разомкнутые полилинии и т.п.). Площадь и длина. Площадь вычисляется в предположении, что начало и конец объекта соединены отрезком.
  • 3D тела AutoCAD. Общая площадь объекта.

Пример: Подсчет площадей в различных случаях

Сложение площадей

Можно производить измерение площади нескольких областей, как ограничиваемых точками, так и заключенных внутри объектов. Например, можно определить суммарную площадь комнат на плане этажа.

Вычитание площадей

Из подсчитанной суммарной площади можно производить вычитание площади одной или нескольких областей. В следующем примере вначале определяется полная площадь этажа, а затем из нее вычитается площадь, занимаемая комнатой.

Пример: Вычитание площади из суммарной площади

В следующем примере рассматривается определение площади металлической пластины, имеющей два больших отверстия; контур пластины образован замкнутой полилинией. Для определения площади пластины из площади, ограничиваемой полилинией, вычитается площадь, занимаемая отверстиями. После выполнения каждого шага вычислений отображаются значения площади и периметра или длины окружности каждого объекта и их суммарные значения.

Диалог в командной строке выглядит так:

Команда: площадь

Первая угловая точка или [Объект/Добавить/Вычесть]: д

Первая угловая точка или [Объект/Вычесть]: о

(Режим СЛОЖЕНИЕ) Выбрать объекты: Выберите полилинию (1)

Площадь = 0.34, Периметр = 2.71

Общая площадь = 0.34

(Режим СЛОЖЕНИЕ) Выбрать объекты: Нажмите ENTER

Первая угловая точка или [Объект/Вычесть]: о

Первая угловая точка или [Объект/Добавить]: о

(Режим ВЫЧИТАНИЕ) Выбрать объекты:Выберите нижнюю окружность (2)

Площадь = 0.02, Длина окружности = 0.46

Общая площадь = 0.32

(Режим ВЫЧИТАНИЕ) Выбрать объекты: Выберите верхнюю окружность (3)

Площадь = 0.02, Длина окружности = 0.46

Общая площадь = 0.30

(Режим ВЫЧИТАНИЕ) Выбрать окружность или полилинию: Нажмите ENTER

Первая угловая точка или [Объект/Добавить]: Нажмите ENTER

Площадь пластины можно также получить в палитре "Свойства" или (если предварительно преобразовать ее в область командой ОБЛАСТЬ и удалить из области отверстия) с помощью команды СПИСОК.

СоветКалькулятор БыстрКальк используется для преобразования единиц площади одной системы в единицы другой системы. Дополнительные сведения см. в разделе Использование калькулятора БыстрКальк .

Расчет массовых характеристик

С помощью команды МАСС-ХАР для 3D тел и 2D областей можно проанализировать их массовые характеристики, в том числе объем, площадь, момент инерции, центр тяжести и т. п. При этом результаты вычислений можно сохранить в текстовом файле.

См. также

    • Построение и объединение областей

    • Коротко о свойствах объектов


Получение сведений о площади и свойствах массы (Процедура)

Вычисление расстояний, углов и определение координат
На уровень вверх ..
Получение сведений о площади и свойствах массы
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Получение сведений о площади и свойствах массы >
Получение сведений о площади и свойствах массы
Понятие Процедура Краткий справочник

Для вычисления площади заданной области

Для вычисления площади объекта

Для суммирования площадей

Для вычитания площади из подсчитанной общей площади


Для вычисления площади заданной области (Процедура)

Получение сведений о площади и свойствах массы
На уровень вверх ..
Получение сведений о площади и свойствах массы
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Получение сведений о площади и свойствах массы >
Получение сведений о площади и свойствах массы
Понятие Процедура Краткий справочник

Для вычисления площади заданной области

  1. Выберите вкладку "Инструменты" [image] панель "Сведения" [image] "Площадь".В командной строке введите "площадь".
  2. Последовательно указать точки для задания области, площадь которой нужно измерить. Далее нажмите ENTER.

    Первая и последняя точка соединяются между собой для получения замкнутой области; отображаются значения площади и периметра, измеренные с учетом настроек, определяемых командой ЕДИНИЦЫ.

Панель:Сведения
Ввод команды: ПЛОЩАДЬ


Для вычисления площади объекта (Процедура)

Получение сведений о площади и свойствах массы
На уровень вверх ..
Получение сведений о площади и свойствах массы
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Получение сведений о площади и свойствах массы >
Получение сведений о площади и свойствах массы
Понятие Процедура Краткий справочник

Для вычисления площади объекта

  1. Выберите вкладку "Инструменты" [image] панель "Сведения" [image] "Площадь".В командной строке введите "площадь".
  2. В командной строке введите о (Объект).
  3. Выбрать объект.

    Выводятся значения площади и периметра указанного объекта.

Панель:Сведения
Ввод команды: ПЛОЩАДЬ


Для суммирования площадей (Процедура)

Получение сведений о площади и свойствах массы
На уровень вверх ..
Получение сведений о площади и свойствах массы
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Получение сведений о площади и свойствах массы >
Получение сведений о площади и свойствах массы
Понятие Процедура Краткий справочник

Для суммирования площадей

  1. Выберите вкладку "Инструменты" [image] панель "Сведения" [image] "Площадь".В командной строке введите "площадь".
  2. Последовательно указать точки для задания области, площадь которой нужно измерить.
  3. Воспользоваться одним из следующих способов:
    • Укажите точки для определения области, в которой выполняется сложение, и нажмите ENTER
    • Ввести о (Объект) и выбрать объекты, ограничивающие составные части области.

      Отображаются результаты измерений для каждой из заданных областей и текущее суммарное значение площади.

  4. Для завершения команды нажмите ENTER дважды.
Панель:Сведения
Ввод команды: ПЛОЩАДЬ


Для вычитания площади из подсчитанной общей площади (Процедура)

Получение сведений о площади и свойствах массы
На уровень вверх ..
Использование калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Получение сведений о площади и свойствах массы >
Получение сведений о площади и свойствах массы
Понятие Процедура Краткий справочник

Для вычитания площади из подсчитанной общей площади

  1. После вывода информации об общей площади введите в (Вычесть).
  2. Воспользуйтесь одним из следующих способов:
    • Укажите точки для определения области, в которой выполняется вычитание, и нажмите ENTER.
    • Введите о (Объект) и выберите объекты, ограничивающие составные части области.

    При определении новых областей обновляется текущее суммарное значение.

  3. Нажмите ENTER для завершения команды.
Панель:Сведения
Ввод команды: ПЛОЩАДЬ


Получение сведений о площади и свойствах массы (Краткий справочник)

Вычисление расстояний, углов и определение координат
Получение сведений о площади и свойствах массы
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Получение геометрической информации от объектов > Получение сведений о площади и свойствах массы >
Получение сведений о площади и свойствах массы
Понятие Процедура Краткий справочник

Команды

ПЛОЩАДЬ

Последнее значение площади, вычисленное с помощью команды ПЛОЩАДЬ

СПИСОК

Отображение свойств для выбранных объектов

МАСС-ХАР

Вычисление массовых характеристик областей и тел

ОКНОСВ

Управление свойствами объектов

БЫСТРКАЛЬК

Вызов калькулятора БыстрКальк

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

AREA

Последнее значение площади, вычисленное с помощью команды ПЛОЩАДЬ

PERIMETER

Последнее значение периметра, вычисленное с помощью команды ПЛОЩАДЬ или СПИСОК

Утилиты

Нет

Ключевые слова для команд

Нет


Использование калькулятора

Получение сведений о площади и свойствах массы
Средства обеспечения точности
Использование калькулятора БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности >
Использование калькулятора
Понятие Процедура

При работе с программой можно пользоваться функциями калькулятора. Предусмотрено два варианта калькулятора: калькулятор с графическим интерфейсом БыстрКальк и калькулятор командной строки.

Темы в этом разделе

  • Использование калькулятора БыстрКальк

    Используя калькулятор БыстрКальк, интерфейс которого напоминает карманный калькулятор, можно выполнять математические, научные и геометрические вычисления, преобразовывать единицы измерения, управлять свойствами объектов и осуществлять оценку выражений.

  • Использование калькулятора командной строки

    Калькулятор командной строки позволяет быстро решать математические задачи или рассчитывать координаты точек путем ввода выражений в командной строке.


Использование калькулятора (Процедура)

Получение сведений о площади и свойствах массы
Использование калькулятора
Использование калькулятора БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора >
Использование калькулятора
Понятие Процедура

Запуск калькулятора командной строки


Использование калькулятора БыстрКальк

Использование калькулятора
Использование калькулятора
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора >
Использование калькулятора БыстрКальк
Понятие Процедура

Используя калькулятор БыстрКальк, интерфейс которого напоминает карманный калькулятор, можно выполнять математические, научные и геометрические вычисления, преобразовывать единицы измерения, управлять свойствами объектов и осуществлять оценку выражений.

Темы в этом разделе

  • Коротко о калькуляторе БыстрКальк
  • Доступ к калькулятору БыстрКальк и сведения о его работе

    Калькулятора БыстрКальк можно использовать так же, как калькулятор рабочего стола, или в прозрачном режиме в рамках команды или палитры свойств.

  • Ввод, вычисление и получение выражений

    Введите выражения в БыстрКальк, используя стандартные математические правила предшествования; просмотрите и извлеките расчеты из области журнала; ознакомьтесь с правилами использования единиц британской системы, относящихся к длине, площади и объему.

  • Преобразование единиц измерения

    В области преобразования единиц калькулятора БыстрКальк можно получить эквивалентные значения для различных единиц измерения.

  • Создание и использование переменных калькулятора

    В области переменных БыстрКальк хранятся переменные калькулятора, к которым можно обращаться в случае необходимости. Переменные калькулятора могут быть константами или функциями.


Использование калькулятора БыстрКальк (Процедура)

Использование калькулятора
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк >
Использование калькулятора БыстрКальк
Понятие Процедура

Для очистки поля ввода

Для использования основных математических функций в калькуляторе БыстрКальк

Для использования научных функций в калькуляторе БыстрКальк

Для получения абсолютного значения числа с помощью калькулятора БыстрКальк

Для округления числа до ближайшего целого с помощью калькулятора БыстрКальк

Для отображения только целой части числа с помощью калькулятора БыстрКальк

Для сохранения значения в памяти калькулятора БыстрКальк

Для добавления текущего значения к значению, сохраненному в памяти калькулятора БыстрКальк

Для восстановления значения, сохраненного в памяти калькулятора БыстрКальк

Для очистки значения, сохраненного в памяти БыстрКальк

Для использования калькулятора БыстрКальк

Для использования калькулятора БыстрКальк в рамках команды

Для использования калькулятора БыстрКальк вместе с палитрой свойств

Для копирования/вставки значения в поле ввода БыстрКальк

Для вставки значения из поля ввода БыстрКальк в командную строку

Для очистки области журнала

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора БыстрКальк

Для изменения цвета шрифта значений или выражений в области журнала БыстрКальк

Для копирования/вставки выражения в область журнала БыстрКальк

Для добавления значения или выражения из области журнала калькулятора БыстрКальк в поле ввода

Для изменения свойства в палитре свойств с помощью калькулятора БыстрКальк

Для получения значений координат X, Y, Z для точки с помощью калькулятора БыстрКальк

Для измерения расстояния между двумя точками с помощью калькулятора БыстрКальк

Для получения угла наклона отрезка, заданного двумя точками, с помощью калькулятора БыстрКальк

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью калькулятора БыстрКальк

Для преобразования единиц измерения с помощью БыстрКальк

Для копирования результатов преобразования единиц в поле ввода калькулятора БыстрКальк

Для преобразования радианов в градусы с помощью БыстрКальк

Для преобразования градусов в радианы с помощью БыстрКальк

Для использования стандартной переменной в выражении БыстрКальк

Для создания новой переменной в БыстрКальк

Для редактирования переменной в калькуляторе БыстрКальк

Для удаления переменной в калькуляторе БыстрКальк

Для создания новой глобальной константы в поле ввода калькулятора БыстрКальк

Для обращения к глобальной константе из диалогового окна или обычного окна

Чтобы вычислять математические выражения в диалоговом окне


Коротко о калькуляторе БыстрКальк (Понятие)

Использование калькулятора БыстрКальк
Использование калькулятора БыстрКальк
Доступ к калькулятору БыстрКальк и сведения о его работе
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Калькулятор БыстрКальк содержит основные функции, аналогичные тем, что существуют в стандартных математических калькуляторах. Кроме того, БыстрКальк содержит функции, свойственные AutoCAD, например: геометрические функции, область преобразования единиц и область переменных.

В отличие от большинства калькуляторов, БыстрКальк является построителем выражений. Для большей гибкости калькулятор не сразу выдает ответ после выбора функции. Вместо этого составляется выражение, которое можно легко редактировать. По завершении нажмите знак равенства (=) или нажмите клавишу ENTER. Позднее это выражение можно извлечь из области журнала, изменить, а затем выполнить перерасчет результатов.

Используя калькулятор БыстрКальк, можно выполнять следующие действия.

  • Осуществление математических и тригонометрических расчетов
  • Обращение к ранее выполненным расчетам для переоценки, а также их просмотр
  • Использование калькулятора вместе с палитрой свойств для изменения свойств объектов
  • Преобразование единиц измерения
  • Осуществление геометрических расчетов, связанных с определенными объектами
  • Копирование и вставка значений и выражений в палитру свойств или командную строку, а также из палитры свойств или командной строки
  • Выполнение расчетов со смешанными числами (имеющими целые и дробные части), величинами в футах и дюймах
  • Определение, хранение и использование переменных калькулятора
  • Использование геометрических функций из команды КАЛЬК

Изменение размеров и внешнего вида калькулятора БыстрКальк

Нажмите кнопку "Больше/Меньше" на калькуляторе, и отобразятся только области ввода и журнала. Для открытия и закрытия областей можно пользоваться стрелками развертывания/свертывания. Кроме того, пользователь может изменять размеры, местоположение и внешний вид калькулятора БыстрКальк. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Задание параметров интерфейса.


Коротко о калькуляторе БыстрКальк (Процедура)

Использование калькулятора БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для очистки поля ввода

Для использования основных математических функций в калькуляторе БыстрКальк

Для использования научных функций в калькуляторе БыстрКальк

Для получения абсолютного значения числа с помощью калькулятора БыстрКальк

Для округления числа до ближайшего целого с помощью калькулятора БыстрКальк

Для отображения только целой части числа с помощью калькулятора БыстрКальк

Для сохранения значения в памяти калькулятора БыстрКальк

Для добавления текущего значения к значению, сохраненному в памяти калькулятора БыстрКальк

Для восстановления значения, сохраненного в памяти калькулятора БыстрКальк

Для очистки значения, сохраненного в памяти БыстрКальк


Для очистки поля ввода (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для очистки поля ввода

Выполнить одно из следующих действий:

  • На панели инструментов калькулятора БыстрКальк нажмите кнопку "Очистить".
  • На цифровой клавиатуре калькулятора БыстрКальк нажмите кнопку "Очистить".

    Любое текущее значение или выражение в поле ввода будет удалено, и будет восстановлено значение 0.


Для использования основных математических функций в калькуляторе БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для использования основных математических функций в калькуляторе БыстрКальк

  1. На цифровой клавиатуре введите число.
  2. Нажмите кнопку оператора (+, -, *, /). Затем введите следующее число и т.д.
  3. Нажмите знак равенства (=).

    В поле ввода отобразятся результаты. Выражение и результат также отобразятся в области журнала.


Для использования научных функций в калькуляторе БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для использования научных функций в калькуляторе БыстрКальк

  1. На цифровой клавиатуре введите число.
  2. В области научных расчетов выберите функцию.
  3. На цифровой клавиатуре нажмите знак равенства (=).

    В поле ввода отобразятся результаты.


Для получения абсолютного значения числа с помощью калькулятора БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для получения абсолютного значения числа с помощью калькулятора БыстрКальк

  1. В момент отображения текущего значения в области научных расчетов нажмите кнопку abs.
  2. На цифровой клавиатуре нажмите знак равенства (=).

    В поле ввода отобразится абсолютное значение.


Для округления числа до ближайшего целого с помощью калькулятора БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для округления числа до ближайшего целого с помощью калькулятора БыстрКальк

  1. В момент отображения текущего значения в области научных расчетов нажмите кнопку rnd.
  2. На цифровой клавиатуре нажмите знак равенства (=).

    В поле ввода отобразится число, округленное до ближайшего целого.


Для отображения только целой части числа с помощью калькулятора БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для отображения только целой части числа с помощью калькулятора БыстрКальк

  1. В момент отображения текущего значения в области научных расчетов нажмите кнопку trunc.
  2. На цифровой клавиатуре нажмите знак равенства (=).

    В поле ввода отобразится целая часть числа без десятичных знаков.


Для сохранения значения в памяти калькулятора БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для сохранения значения в памяти калькулятора БыстрКальк

  • В момент отображения текущего значения щелкните MS.

    Предыдущее значение перезаписывается, а новое значение сохраняется в памяти.


Для добавления текущего значения к значению, сохраненному в памяти калькулятора БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для добавления текущего значения к значению, сохраненному в памяти калькулятора БыстрКальк

  • В момент отображения текущего значения щелкните M+.

    Отобразится сумма нового значения и значения, занесенного в память.


Для восстановления значения, сохраненного в памяти калькулятора БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Коротко о калькуляторе БыстрКальк
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для восстановления значения, сохраненного в памяти калькулятора БыстрКальк

  • В момент отображения текущего значения щелкните MR.

    Отображаемое значение или выражение прибавляется, и выводится значение сохраненное в памяти.


Для очистки значения, сохраненного в памяти БыстрКальк (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Доступ к калькулятору БыстрКальк и сведения о его работе
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Для очистки значения, сохраненного в памяти БыстрКальк

  • Щелкните MC.

    Значение, сохраненное в памяти, будет очищено.


Коротко о калькуляторе БыстрКальк (Краткий справочник)

Получение сведений о площади и свойствах массы
Коротко о калькуляторе БыстрКальк
Доступ к калькулятору БыстрКальк и сведения о его работе
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Коротко о калькуляторе БыстрКальк >
Коротко о калькуляторе БыстрКальк
Понятие Процедура Краткий справочник

Команды

БЫСТРКАЛЬК

Вызов калькулятора БыстрКальк

БКЗАКРЫТЬ

Закрытие калькулятора БыстрКальк

Системные переменные

QCSTATE

Указание на открытое или закрытое состояние калькулятора БыстрКальк

Утилиты

Нет

Ключевые слова для команд

Нет


Доступ к калькулятору БыстрКальк и сведения о его работе (Понятие)

Коротко о калькуляторе БыстрКальк
Использование калькулятора БыстрКальк
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк >
Доступ к калькулятору БыстрКальк и сведения о его работе
Понятие Процедура Краткий справочник

Калькулятора БыстрКальк можно использовать так же, как калькулятор рабочего стола, или в прозрачном режиме в рамках команды или палитры свойств.

В программе существует три способа работы с калькулятором БыстрКальк:

  • Непосредственно из меню "Сервис", с панели инструментов "Стандартная", из контекстного меню или командной строки
  • В прозрачном режиме, во время выполнения команды из контекстного меню или командной строки
  • Просто из палитры свойств

Выбранный метод зависит от того, как используется калькулятор БыстрКальк.

Непосредственное использование калькулятора БыстрКальк

При непосредственной работе с калькулятором БыстрКальк можно выполнять расчеты и преобразования единиц, как при использовании настольного калькулятора. Для переноса результатов в другие части программы или во внешние программы можно использовать буфер обмена Windows (CTRL+C, CTRL+V). Расчеты, выполняемые непосредственно, не влияют на чертеж и ничего в нем не меняют.

Непосредственный доступ к калькулятору БыстрКальк можно получить следующими способами:

  • Выберите меню Сервис [image] Палитры [image] БыстрКальк.В командной строке введите "быстркальк".
  • На панели инструментов "Стандартная" нажмите кнопку "БыстрКальк".
  • В графическом редакторе (при отсутствии активных команд) нажмите правую кнопку мыши, а затем выберите "Быстркальк".
  • В командной строке введите быстркальк.
  • В командной строке введите бк.

Использование калькулятора БыстрКальк в прозрачном режиме в рамках команды

Во время выполнения команды доступ к калькулятору БыстрКальк выполняется следующими способами:

  • Щелкните правой кнопкой мыши для вызова контекстного меню. Выберите "БыстрКальк".
  • В командной строке введите быстркальк.
  • В командной строке введите бк.

Расчеты, переносимые в командную строку, влияют на чертеж. Например, если выполняется построение линии с помощью команды "отрезок" и выражение передается в командную строку из калькулятора, для следующей точки линии используются результаты, которые могут быть значением расстояния или координаты. В калькуляторе БыстрКальк нажмите кнопку "Применить", чтобы передать значение в чертеж исходя из данного выражения.

ПримечаниеВ случае прозрачного использования БыстрКальк для расчета значения, которое применяется при вводе методом "направление-расстояние", кнопка "Применить" служит для пересылки этого значение в командную строку. Для использования значения определите направление с помощью курсоров в форме перекрестия и нажмите клавишу ENTER.

Использование калькулятора БыстрКальк в прозрачном режиме из палитры свойств

Когда необходимо изменить свойства и применить вычисленные выражения к объектам в чертеже, можно открыто обратиться к калькулятору БыстрКальк из палитры свойств. Используйте следующий способ:

  • Щелкните любое поле в палитре свойств, содержащее числовое значение. Затем нажмите кнопку "БыстрКальк", которая появится в поле.
  • После расчета значения нажмите кнопку "Применить", чтобы перенести результат в палитру свойств.

Свойство объекта или чертежа изменяется, и в чертеже отображаются изменения.

Вычисление математических выражений в диалоговом окне

Можно также вводить и оценивать математические выражения в диалоговом окне с использованием следующего формата:=выражение<КОНЕЦ>

Примечание Чтобы вычислять выражения в диалоговом окне, необходимо убедиться, что для системной переменной CALCINPUT установлено значение 1.


Доступ к калькулятору БыстрКальк и сведения о его работе (Процедура)

Коротко о калькуляторе БыстрКальк
На уровень вверх ..
Доступ к калькулятору БыстрКальк и сведения о его работе
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Доступ к калькулятору БыстрКальк и сведения о его работе >
Доступ к калькулятору БыстрКальк и сведения о его работе
Понятие Процедура Краткий справочник

Для использования калькулятора БыстрКальк

Для использования калькулятора БыстрКальк в рамках команды

Для использования калькулятора БыстрКальк вместе с палитрой свойств


Для использования калькулятора БыстрКальк (Процедура)

Доступ к калькулятору БыстрКальк и сведения о его работе
На уровень вверх ..
Доступ к калькулятору БыстрКальк и сведения о его работе
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Доступ к калькулятору БыстрКальк и сведения о его работе >
Доступ к калькулятору БыстрКальк и сведения о его работе
Понятие Процедура Краткий справочник

Для использования калькулятора БыстрКальк

Выполнить одно из следующих действий:

  • В командной строке введите команду быстркальк или бк.
  • Нажмите правой кнопкой в области рисования, чтобы отобразить контекстное меню. Выберите "БыстрКальк".
  • Выберите меню Сервис [image] Палитры [image] БыстрКальк.В командной строке введите "быстркальк".
  • На панели инструментов "Стандартная" нажмите кнопку "БыстрКальк".


Для использования калькулятора БыстрКальк в рамках команды (Процедура)

Доступ к калькулятору БыстрКальк и сведения о его работе
На уровень вверх ..
Доступ к калькулятору БыстрКальк и сведения о его работе
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Доступ к калькулятору БыстрКальк и сведения о его работе >
Доступ к калькулятору БыстрКальк и сведения о его работе
Понятие Процедура Краткий справочник

Для использования калькулятора БыстрКальк в рамках команды

Выполните одно из следующих действий:

  • В командной строке введите 'быстркальк или 'бк.
  • Нажмите правую кнопку, чтобы отобразить контекстное меню. Выберите "БыстрКальк".


Для использования калькулятора БыстрКальк вместе с палитрой свойств (Процедура)

Доступ к калькулятору БыстрКальк и сведения о его работе
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Доступ к калькулятору БыстрКальк и сведения о его работе >
Доступ к калькулятору БыстрКальк и сведения о его работе
Понятие Процедура Краткий справочник

Для использования калькулятора БыстрКальк вместе с палитрой свойств

  1. Откройте палитру свойств.
  2. Выберите один или несколько объектов.
  3. Щелкните поле с числовым свойством.
  4. Нажмите в поле кнопку "БыстрКальк".


Доступ к калькулятору БыстрКальк и сведения о его работе (Краткий справочник)

Коротко о калькуляторе БыстрКальк
Доступ к калькулятору БыстрКальк и сведения о его работе
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Доступ к калькулятору БыстрКальк и сведения о его работе >
Доступ к калькулятору БыстрКальк и сведения о его работе
Понятие Процедура Краткий справочник

Команды

БЫСТРКАЛЬК

Вызов калькулятора БыстрКальк

БКЗАКРЫТЬ

Закрытие калькулятора БыстрКальк

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Ввод, вычисление и получение выражений (Понятие)

Доступ к калькулятору БыстрКальк и сведения о его работе
Использование калькулятора БыстрКальк
Преобразование единиц измерения
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Введите выражения в БыстрКальк, используя стандартные математические правила предшествования; просмотрите и извлеките расчеты из области журнала; ознакомьтесь с правилами использования единиц британской системы, относящихся к длине, площади и объему.

При вычислении выражений с помощью команды БыстрКальк используется следующий стандартный порядок выполнения арифметических операций.

  • Вычисляются выражения в скобках, начиная со скобок максимальной вложенности
  • Выполняются операции в стандартной последовательности: вначале возведение в степень, затем умножение и деление, затем сложение и вычитание
  • Операции с равными приоритетами выполняются слева направо

Поле ввода калькулятора находится там, где осуществляется ввод и извлечение выражений. При использовании БыстрКальк данные в поле ввода можно вводить двумя способами. Выражения можно вводить с помощью кнопок цифровой клавиатуры калькулятора БыстрКальк; кроме того, можно использовать клавиатуру компьютера или цифровую клавиатуру. Для использования цифровой клавиатуры на пользовательской клавиатуре включите функцию NUMLOCK (индикатор светится).

Чтобы вычислить выражение, щелкните знак равенства (=) на цифровой клавиатуре БыстрКальк или нажмите клавишу ENTER на клавиатуре компьютера.

Сведения о синтаксисе выражений

Синтаксис выражений калькулятора БыстрКальк и выражений калькулятора командной строки идентичен. Например, чтобы выполнить операцию над вектором или над координатами 5,2,0, введите [5,2,0] в поле ввода.

Можно использовать функцию GETVAR для чтения значений системных переменных. Синтаксис:

getvar (имя_переменной)

Дополнительные сведения см. в описании команды КАЛЬК.

Использование области журнала

В области журнала фиксируются текущие расчеты, наподобие бумажной ленты в физическом настольном калькуляторе. Область журнала можно использовать для просмотра предыдущих операций и передачи их обратно в поле ввода для повторных вычислений с различными параметрами.

Правила отображения и обработки единиц

В калькуляторе БыстрКальк действуют следующие правила:

  • Результаты расчетов всегда выражаются в десятичном формате, если только расстояние не вводится в футах и дюймах.
  • Предполагается, что угловые значения, введенные в поле ввода, выражаются градусами независимо от настроек в диалоговом окне "Единицы чертежа". Чтобы указать радианы, грады или градусы, добавьте после углового значения параметры r, g или d.
  • Результаты расчетов углов всегда выражаются в градусах с максимальной для AutoCAD точностью.

Когда в качестве единиц чертежа используются архитектурные единицы, калькулятор отображает результаты вычислений величин в британских единицах в архитектурном формате и округляет их до указанного знака (LUPREC) при отображении на чертеже. Результаты для всех других расчетов отображаются в десятичном формате со всей точностью.

Футы, дюймы и дробные значения дюймов можно отделять с помощью тире, пробела, либо можно вообще ничего не использовать. Для ввода допустимых значений в формате футов/дюймов можно пользоваться любыми из указанных вариантов синтаксиса:

  • 5' или 60"
  • 5'-9" или 5' 9" или 5'9"
  • 5'-1/2" или 5' 1/2" или 5'1/2"
  • 5'-9-1/2" или 5' 9-1/2" или 5'9-1/2"
  • 5'-9 1/2" или 5' 9 1/2" или 5'9 1/2"

Ввод двойных кавычек (") для обозначения дюймов в линейных расчетах носит факультативных характер. Например, вместо того, чтобы вводить 5'9-1/2", можно ввести 5'9-1/2.

Предупреждение При использовании британских единиц БыстрКальк интерпретирует минус или тире (-) не как операцию вычитания, а как разделитель единиц. Для обозначения вычитания вставляйте хотя бы один пробел до или после знака минуса. Например, чтобы вычесть 9" из 5', вводите 5' -9", а не 5'-9".

БыстрКальк можно использовать для вычисления квадратных и кубических футов. Для ввода квадратных или кубических футов необходимо ввести единицы, используя следующие сокращения:

  • sq. футов или sq ft
  • cu. футов или cu ft

Преобразование десятичных единиц измерения в британские

Для преобразования расстояний введите знак дюйма (") после числа на дисплее калькулятора. Например, если вычисленное расстояние составляет 15, введите знак " после числа 15 и нажмите клавишу Enter или кнопку "=". На дисплее появится значение расстояния в британских единицах: 1'-3".

Чтобы результаты вычислений выражались в футах и дюймах, исходные значения следует вводить в футах (') и дюймах ("). Например:

  • 5 * 6 = 30
  • 5" * 6 = 2'-6"
  • 5" * 6" = 30 кв. дюймов
  • 5" * 0'-6" = 0.208333333 кв. футов


Ввод, вычисление и получение выражений (Процедура)

Доступ к калькулятору БыстрКальк и сведения о его работе
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для копирования/вставки значения в поле ввода БыстрКальк

Для вставки значения из поля ввода БыстрКальк в командную строку

Для очистки области журнала

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора БыстрКальк

Для изменения цвета шрифта значений или выражений в области журнала БыстрКальк

Для копирования/вставки выражения в область журнала БыстрКальк

Для добавления значения или выражения из области журнала калькулятора БыстрКальк в поле ввода

Для изменения свойства в палитре свойств с помощью калькулятора БыстрКальк

Для получения значений координат X, Y, Z для точки с помощью калькулятора БыстрКальк

Для измерения расстояния между двумя точками с помощью калькулятора БыстрКальк

Для получения угла наклона отрезка, заданного двумя точками, с помощью калькулятора БыстрКальк

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью калькулятора БыстрКальк


Для копирования/вставки значения в поле ввода БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для копирования/вставки значения в поле ввода БыстрКальк

  1. Щелкните правой кнопкой мыши значение в поле ввода. Выберите "Копировать".

    Текущая запись копируется в буфер обмена.

  2. Щелкните в новом месте, затем щелкните правой кнопкой мыши. Выберите "Вставить".

    Значение скопируется в новое место.


Для вставки значения из поля ввода БыстрКальк в командную строку (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для вставки значения из поля ввода БыстрКальк в командную строку

  • На панели инструментов калькулятора БыстрКальк нажмите кнопку "Вставить значение в командную строку".

    Значение в поле ввода будет вставлено в командную строку.


Для очистки области журнала (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для очистки области журнала

  • На панели инструментов калькулятора БыстрКальк нажмите кнопку "Очистить журнал".
Контекстное меню: Щелкните правой кнопкой мыши в области журнала. Выберите "Очистить журнал".


Для повторного использования значения или выражения, сохраненного в области журнала калькулятора БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для повторного использования значения или выражения, сохраненного в области журнала калькулятора БыстрКальк

  1. Нажмите кнопку C (если необходимо) для очистки поля ввода.
  2. В области журнала дважды щелкните значение или выражение. Значение или выражение отобразится в поле ввода.
    Примечание Курсор должен находиться на выбираемом значении или выражении.


Для изменения цвета шрифта значений или выражений в области журнала БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для изменения цвета шрифта значений или выражений в области журнала БыстрКальк

  1. Щелкните правой кнопкой мыши в области журнала. Выберите "Цвет шрифта значения" или "Цвет шрифта выражения".
  2. В диалоговом окне "Цвет" щелкните "Основной цвет" или "Определить пользовательские цвета".

    При использовании параметра "Определить пользовательские цвета" можно выбрать пользовательский цвет и добавить его в "Пользовательские цвета".

  3. Нажать "ОК".

    Цвета, выбранные для значений и выражений, отобразятся в области журнала.

    Контекстное меню: Щелкните правой кнопкой мыши "Цвет шрифта выражения" или "Цвет шрифта значения". Выберите "Основной цвет" или "Определить пользовательские цвета".


Для копирования/вставки выражения в область журнала БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для копирования/вставки выражения в область журнала БыстрКальк

  1. Щелкните правой кнопкой мыши выражение в области журнала. Выберите "Копировать".

    Текущая запись копируется в буфер обмена.

  2. Щелкните правой кнопкой мыши в новом месте. Выберите "Вставить".

    Выражение скопируется в новое место.


Для добавления значения или выражения из области журнала калькулятора БыстрКальк в поле ввода (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для добавления значения или выражения из области журнала калькулятора БыстрКальк в поле ввода

  • Дважды щелкните значение или выражение в области журнала.

    Значение или выражение будет добавлено в поле ввода.

    Примечание Курсор должен находиться на выбираемом значении или выражении.
Контекстное меню: Щелкните правой кнопкой мыши "Добавить значение в область ввода" или "Добавить выражение в область ввода".


Для изменения свойства в палитре свойств с помощью калькулятора БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для изменения свойства в палитре свойств с помощью калькулятора БыстрКальк

  1. Выбрать объект.
    ПримечаниеЕсли БыстрКальк отображается на рабочем столе во время работы с палитрой свойств, он на время скрывается, когда из палитры свойств пользователь обращается к модальному калькулятору.
  2. В разделе геометрии палитры свойств щелкните значение свойства.

    Справа от значения отобразится небольшой значок калькулятора.

    Примечание Изменить можно только те свойства, которые отображаются на белом фоне.
  3. Щелкните значок калькулятора.

    Откроется калькулятор БыстрКальк, и в поле ввода отобразится текущее значение объекта.

  4. Выполните вычисления с отображаемым значением и щелкните кнопку знака равенства (=).

    В поле ввода отобразится новое значение.

  5. Нажмите кнопку "Применить".
    Примечание Кнопка "Применить" доступна только при определении свойств, которые можно редактировать, и к тому же, они должны относиться к числам.

    Калькулятор закроется, а новое значение отобразится в палитре свойств. Объект в чертеже изменится.


Для получения значений координат X, Y, Z для точки с помощью калькулятора БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для получения значений координат X, Y, Z для точки с помощью калькулятора БыстрКальк

  1. ПримечаниеКнопка "Получить координаты" на панели инструментов "БыстрКальк" использует функцию cur.
    На панели инструментов калькулятора БыстрКальк нажмите кнопку "Получить координаты".

    Окно калькулятора БыстрКальк временно закроется, и появится запрос на ввод точки.

  2. В чертеже выберите точку.

    Откроется калькулятор БыстрКальк, и в поле ввода отобразятся координатные значения точки.


Для измерения расстояния между двумя точками с помощью калькулятора БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для измерения расстояния между двумя точками с помощью калькулятора БыстрКальк

  1. Примечание Кнопка "Расстояние между двумя точками" на панели инструментов "БыстрКальк" использует функцию dist(p1,p2).
    На панели инструментов калькулятора БыстрКальк нажмите кнопку "Расстояние между двумя точками".

    Окно калькулятора БыстрКальк, и появится запрос на ввод двух точек.

  2. В чертеже выберите первую точку, затем - вторую.

    Откроется калькулятор БыстрКальк, и в поле ввода отобразится значение расстояния между двумя точками.


Для получения угла наклона отрезка, заданного двумя точками, с помощью калькулятора БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Ввод, вычисление и получение выражений
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для получения угла наклона отрезка, заданного двумя точками, с помощью калькулятора БыстрКальк

  1. Примечание Кнопка "Угол линии, определенной двумя точками" на панели инструментов "БыстрКальк" использует функцию ang(p1,p2).
    На панели инструментов калькулятора БыстрКальк нажмите кнопку "Угол линии, определенной двумя точками".

    Окно калькулятора БыстрКальк временно закроется, и появится запрос на ввод двух точек.

  2. Введите координатные значения первой точки, а затем - второй.

    Откроется калькулятор БыстрКальк, и значение угла между двумя точками будет добавлено в конец любого значения или выражения, уже присутствующего в поле ввода.


Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью калькулятора БыстрКальк (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Преобразование единиц измерения
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Для получения точки пересечения отрезков, заданной четырьмя точками, с помощью калькулятора БыстрКальк

  1. Примечание Кнопка "Пересечение двух линий, определенных четырьмя точками" калькулятора "БыстрКальк" использует функцию ill(p1,p2,p3,p4).
    На панели инструментов калькулятора БыстрКальк нажмите кнопку "Пересечение двух линий, определенных четырьмя точками".

    Окно калькулятора БыстрКальк временно закрывается, и отображается запрос на ввод четырех точек.

  2. Введите координатные значения первой точки первого отрезка, а затем - второй точки первого отрезка. Далее введите координатные значения первой точки второго отрезка, а затем - второй точки второго отрезка.

    Откроется калькулятор БыстрКальк, и значение вычисленного выражения будет добавлено в конец любого значения или выражения, уже присутствующего в поле ввода.


Ввод, вычисление и получение выражений (Краткий справочник)

Доступ к калькулятору БыстрКальк и сведения о его работе
Ввод, вычисление и получение выражений
Преобразование единиц измерения
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Ввод, вычисление и получение выражений >
Ввод, вычисление и получение выражений
Понятие Процедура Краткий справочник

Команды

БЫСТРКАЛЬК

Вызов калькулятора БыстрКальк

БКЗАКРЫТЬ

Закрытие калькулятора БыстрКальк

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Преобразование единиц измерения (Понятие)

Ввод, вычисление и получение выражений
Использование калькулятора БыстрКальк
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк >
Преобразование единиц измерения
Понятие Процедура Краткий справочник

В области преобразования единиц калькулятора БыстрКальк можно получить эквивалентные значения для различных единиц измерения.

Преобразование единиц возможно для величин, относящихся к длине, площади, объему и угловым значениям. В зависимости от выбранного типа можно выбрать список единиц, которые необходимо преобразовать, и список единиц, в которые они будут преобразованы.

В поле "Преобразуемое значение" автоматически отображается значение из поля ввода. Можно также ввести другое значение. Результаты преобразования единиц отображаются в поле "Преобразованное значение". Чтобы вставить этот результат в поле ввода, щелкните значок БыстрКальк в поле "Преобразованное значение".

Примечание В поле "Преобразуемое значение" введите десятичные значения без единиц.


Преобразование единиц измерения (Процедура)

Ввод, вычисление и получение выражений
На уровень вверх ..
Преобразование единиц измерения
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Преобразование единиц измерения >
Преобразование единиц измерения
Понятие Процедура Краткий справочник

Для преобразования единиц измерения с помощью БыстрКальк

Для копирования результатов преобразования единиц в поле ввода калькулятора БыстрКальк

Для преобразования радианов в градусы с помощью БыстрКальк

Для преобразования градусов в радианы с помощью БыстрКальк


Для преобразования единиц измерения с помощью БыстрКальк (Процедура)

Преобразование единиц измерения
На уровень вверх ..
Преобразование единиц измерения
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Преобразование единиц измерения >
Преобразование единиц измерения
Понятие Процедура Краткий справочник

Для преобразования единиц измерения с помощью БыстрКальк

  1. В области преобразования единиц выберите категорию единиц в списке "Тип единиц".
  2. В списке "Преобразовать из" выберите тип единиц, который следует преобразовать.
  3. В списке "Преобразовать в" выберите тип единиц, в который будет выполнено преобразование.
  4. В поле "Преобразуемое значение" введите значение, которое необходимо преобразовать. Нажать ENTER.

    Преобразованное значение отобразится в поле "Преобразованное значение".


Для копирования результатов преобразования единиц в поле ввода калькулятора БыстрКальк (Процедура)

Преобразование единиц измерения
На уровень вверх ..
Преобразование единиц измерения
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Преобразование единиц измерения >
Преобразование единиц измерения
Понятие Процедура Краткий справочник

Для копирования результатов преобразования единиц в поле ввода калькулятора БыстрКальк

  • В заголовке области преобразования единиц нажмите кнопку "Возвратить значение преобразования в область ввода".

    Преобразованное значение отобразится в поле ввода.


Для преобразования радианов в градусы с помощью БыстрКальк (Процедура)

Преобразование единиц измерения
На уровень вверх ..
Преобразование единиц измерения
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Преобразование единиц измерения >
Преобразование единиц измерения
Понятие Процедура Краткий справочник

Для преобразования радианов в градусы с помощью БыстрКальк

  1. На цифровой клавиатуре введите значение в радианах.
  2. В области научных расчетов нажмите кнопку r2d.
  3. На цифровой клавиатуре нажмите знак равенства (=).

    Преобразование отобразится в поле ввода.


Для преобразования градусов в радианы с помощью БыстрКальк (Процедура)

Преобразование единиц измерения
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Преобразование единиц измерения >
Преобразование единиц измерения
Понятие Процедура Краткий справочник

Для преобразования градусов в радианы с помощью БыстрКальк

  1. На цифровой клавиатуре введите значение в градусах.
  2. В области научных расчетов нажмите кнопку d2r.
  3. На цифровой клавиатуре нажмите знак равенства (=).

    Преобразование отобразится в поле ввода.


Преобразование единиц измерения (Краткий справочник)

Ввод, вычисление и получение выражений
Преобразование единиц измерения
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Преобразование единиц измерения >
Преобразование единиц измерения
Понятие Процедура Краткий справочник

Команды

БЫСТРКАЛЬК

Вызов калькулятора БыстрКальк

БКЗАКРЫТЬ

Закрытие калькулятора БыстрКальк

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание и использование переменных калькулятора (Понятие)

Преобразование единиц измерения
Использование калькулятора БыстрКальк
Использование калькулятора командной строки
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

В области переменных БыстрКальк хранятся переменные калькулятора, к которым можно обращаться в случае необходимости. Переменные калькулятора могут быть константами или функциями.

Область переменных можно использовать для определения, хранения и выбора переменных калькулятора. Переменные калькулятора могут быть константами (координаты/векторы, действительные числа и целые числа) или функциями. В области переменных можно выполнить следующее.

  • Щелкните переменную калькулятора для отображения в поле "Подробности" (в нижней части области переменных) такой информации, как значение, тип и описание.
  • Дважды щелкните переменную калькулятора, чтобы загрузить ее поле ввода БыстрКальк.

Дополнительные операции можно выполнять с помощью контекстных меню в области переменных.

Создание новых переменных калькулятора

Новые переменные калькулятора можно создавать с помощью контекстных меню в области переменных. При определении новых переменных калькулятора в диалоговом окне "Описание переменной" применяются следующие правила:

  • Константы. Любое выражение, введенное в поле текстового ввода "Значение" или "Выражение", вычисляется до сохранения переменной калькулятора. Переменные калькулятора, определенные как константы, доступны “глобально”. Обращаться к глобальным константам и использовать их можно в разных чертежах и сеансах работы.
  • Функции. Любое выражение, введенное в поле текстового ввода "Значение" или "Выражение", сохраняется как текст. Вычисление функций осуществляется при их использовании в поле ввода калькулятора БыстрКальк

Создание глобальных констант

Для создания глобальных констант воспользуйтесь одним из следующих способов.

  • Введите выражение в поле ввода в следующем формате: $имя_переменной=значение. Например, чтобы определить золотое отношение как 8 знаков после запятой и принять его в качестве глобальной константы Phi, введите в поле ввода $Phi=1.61803399.
  • Нажмите кнопку "Новая переменная" в заголовке области переменных. В диалоговом окне "Описание переменных" щелкните "Константа" и заполните остальные поля.
  • Щелкните правой кнопкой мыши в области переменных. Выберите "Новая переменная".

Доступ к глобальным константам

Пользователь может обратиться к глобальным константам и передать их в поле ввода калькулятора БыстрКальк следующим образом:

  • Дважды щелкните переменную в области переменных калькулятора БыстрКальк.
  • Щелкните переменную в списке переменных калькулятора и нажмите кнопку "Вернуть переменную в область ввода".
  • Введите знак доллара ($), за которым следует имя переменной, и нажмите клавишу ENTER.

Для использования глобальной константы в поле ввода текстовых или числовых данных, расположенном в окне или диалоговом окне, пользуйтесь следующим синтаксисом: =$имя_переменной с последующим нажатием клавиши END. Например, для использования ранее упомянутой глобальной переменной Phi введите =$Phi и нажмите клавишу END.

Примечание В калькуляторе БыстрКальк имена глобальных переменных, которые указываются в полях для ввода текстовых или числовых данных, можно использовать напрямую только для констант.

Использование функций в сокращенном виде

Некоторые типовые переменные калькулятора стали стандартными; они хранятся в категории функций сокращенного вида. Это геометрические выражения, объединяющие функции КАЛЬК с режимом привязки "Конточка". В приведенной ниже таблице описываются стандартные переменные, доступные в области переменных калькулятора.

Параметр | Сокращенная форма | Описание
dee | dist(end,end) | Расстояние между двумя конечными точками
ille | ill(end,end,end) | Пересечение двух линий, проведенных через четыре конечные точки
mee | (end+end)/2 | Середина отрезка, соединяющего две конечные точки
nee | nor(end,end) | Единичный вектор в плоскости XY, перпендикулярный двум конечным точкам
rad | rad | Радиус выбранной окружности, дуги или дуги полилинии
vee | vee(end,end) | Вектор от одной конечной точки к другой
vee1 | vec1(end,end) | Единичный вектор в направлении от одной конечной точки к другой

Можно легко создавать эти переменные калькулятора или создавать собственные. Дополнительную информацию см. в описании команды КАЛЬК.

Объединение переменных в категории

Систематизировать переменные калькулятора по нескольким категориям можно в области переменных. При этом формируется структура в виде одноярусного дерева. Категория функций сокращенного вида уже создана и содержит несколько функций.

Для создания, переименования или удаления категорий переменных пользуйтесь контекстным меню в области переменных.


Создание и использование переменных калькулятора (Процедура)

Преобразование единиц измерения
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Для использования стандартной переменной в выражении БыстрКальк

Для создания новой переменной в БыстрКальк

Для редактирования переменной в калькуляторе БыстрКальк

Для удаления переменной в калькуляторе БыстрКальк

Для создания новой глобальной константы в поле ввода калькулятора БыстрКальк

Для обращения к глобальной константе из диалогового окна или обычного окна

Чтобы вычислять математические выражения в диалоговом окне


Для использования стандартной переменной в выражении БыстрКальк (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Для использования стандартной переменной в выражении БыстрКальк

  1. В области переменных щелкните переменную, которую нужно применить.
  2. В заголовке области переменных калькулятора БыстрКальк нажмите кнопку "Вернуть переменную в область ввода".

    Переменная отобразится в поле ввода как часть выражения.


Для создания новой переменной в БыстрКальк (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Для создания новой переменной в БыстрКальк

  1. В заголовке области переменных калькулятора БыстрКальк нажмите кнопку "Новая переменная".
  2. В диалоговом окне "Описание переменной" в разделе "Тип переменной" выберите "Константа" или "Функция".
  3. В диалоговом окне "Описание переменной" в разделе имен свойств переменной введите имя переменной. Имена переменных не должны содержать пробелы и специальные символы.
    Примечание При обращении к этой переменной из поля ввода необходимо помнить, что имя переменной должно начинаться со знака доллара ($). Этим она отличается от локальных переменных LISP.
  4. В разделе "Свойства переменной - группа" выберите "Создать".
  5. В диалоговом окне "Описание категории" в разделе "Свойства категории - имя" введите имя для новой категории.
  6. В разделе "Описание" введите описание для новой категории. Нажать "ОК".
  7. В диалоговом окне "Описание переменной" в разделе "Значение" или "Выражение" введите значение или выражение для новой переменной.
  8. В разделе "Описание" введите описание новой переменной. Нажать "ОК".

    Новая переменная теперь отобразится в области переменных.


Для редактирования переменной в калькуляторе БыстрКальк (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Для редактирования переменной в калькуляторе БыстрКальк

  1. В области переменных щелкните переменную, которую нужно отредактировать.
  2. В заголовке области переменных калькулятора БыстрКальк нажмите кнопку "Изменить переменную".
  3. В диалоговом окне "Описание переменной" внесите изменения в переменную. Нажать "ОК".


Для удаления переменной в калькуляторе БыстрКальк (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Для удаления переменной в калькуляторе БыстрКальк

  1. В области переменных щелкните переменную, которую нужно удалить.
  2. В заголовке области переменных калькулятора БыстрКальк нажмите кнопку "Удалить".


Для создания новой глобальной константы в поле ввода калькулятора БыстрКальк (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Для создания новой глобальной константы в поле ввода калькулятора БыстрКальк

  • В поле ввода калькулятора БыстрКальк введите данные, используя следующий синтаксис: $имя_переменной=значение.

    Например, можно ввести $Phi=1.618

    Примечание Глобальные переменные не зависят от регистра.

    БыстрКальк добавляет глобальные константы в список переменных в области переменных.


Для обращения к глобальной константе из диалогового окна или обычного окна (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Создание и использование переменных калькулятора
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Для обращения к глобальной константе из диалогового окна или обычного окна

  • В любом поле ввода текстовых или числовых данных введите выражение, используя следующий синтаксис: =$имя_переменной с последующим нажатием клавиши END.


Чтобы вычислять математические выражения в диалоговом окне (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Использование калькулятора командной строки
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Чтобы вычислять математические выражения в диалоговом окне

  1. Если необходимо, установите для системной переменной CALCINPUT значение 1.
  2. В области ввода числовых значений диалогового окна введите математическое выражение в следующем формате: =выражение (например, =5+3).
  3. Нажмите клавишу END на клавиатуре.

    Выражение вычисляется, а его значение отображается.

    Ввод команды: CALCINPUT


Создание и использование переменных калькулятора (Краткий справочник)

Преобразование единиц измерения
Создание и использование переменных калькулятора
Использование калькулятора командной строки
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора БыстрКальк > Создание и использование переменных калькулятора >
Создание и использование переменных калькулятора
Понятие Процедура Краткий справочник

Команды

БКЗАКРЫТЬ

Закрытие калькулятора БыстрКальк

БЫСТРКАЛЬК

Вызов калькулятора БыстрКальк

Системные переменные

CALCINPUT

Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных

Утилиты

Нет

Ключевые слова для команд

Нет


Использование калькулятора командной строки (Понятие)

Создание и использование переменных калькулятора
Использование калькулятора
Построение геометрических объектов
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора >
Использование калькулятора командной строки
Понятие Процедура Краткий справочник

Калькулятор командной строки позволяет быстро решать математические задачи или рассчитывать координаты точек путем ввода выражений в командной строке.

Для вычисления векторных выражений (объединяющие точки, векторы и числа) и выражений из действительных и целых чисел можно пользоваться командой КАЛЬК, которой запускается утилита 3D калькулятора. Калькулятор поддерживает выполнение стандартных математических операций. Кроме того, калькулятор содержит набор специализированных функций, предназначенных для работы с трехмерными точками, векторами и геометрическими объектами AutoCAD. Команда КАЛЬК обеспечивает:

  • Вычисление вектора между двумя точками, длины вектора, вектора нормали (перпендикуляра к плоскости XY) и точки на прямой
  • Вычисление расстояния, радиуса или угла
  • Задание точки указывающим устройством
  • Задание точки или пересечения, построенных в последний раз
  • Использование объектных привязок в качестве переменных в выражении
  • Преобразование точек из ПСК в МСК и обратно.
  • Выделение компонентов вектора по осям X, Y и Z
  • Поворот точки вокруг оси

Вычисление выражений

При вычислении выражений с помощью команды КАЛЬК используется стандартный порядок выполнения арифметических операций.

Арифметические операции в порядке убывания приоритета
Оператор | Операция
( ) | группирование выражений
^ | возведение в степень
*, / | умножение и деление
+, - | сложение и вычитание

Вычисление координат точек

Команду КАЛЬК можно использовать при любой необходимости вычисления числа или координат точки в рамках команды.

Например, выражение (mid+cen)/2 определяет точку, расположенную точно посредине между серединой отрезка и центром круга.

В следующем примере команда КАЛЬК используется как вспомогательное средство построений. С ее помощью определяется положение центра для новой окружности и задается величина ее радиуса, которая должна равняться одной пятой радиуса имеющейся окружности.

Последовательность набора в командной строке выглядит так:

Команда: круг

Центр круга или [3Т/2Т/ККР (кас, кас, радиус)]: 'кальк

>> Выражение: (mid+cen)/2

>> Выберите объект для привязки MID: Выбрать отрезок в пазу (1)

>> Выберите объект для привязки CEN: Выбрать большую окружность (2)

Диаметр/<Радиус>: 'кальк

>> Выражение: 1/5*rad

>> Выберите круг, дугу или сегмент полилинии для функции RAD: Выберите большую окружность (3)

Вычисление математических выражений в диалоговом окне

Можно также вводить и оценивать математические выражения в диалоговом окне с использованием следующего формата:=выражение<КОНЕЦ>

Примечание Чтобы вычислять выражения в диалоговом окне, необходимо убедиться, что для системной переменной CALCINPUT установлено значение 1.


Запуск калькулятора командной строки (Процедура)

Создание и использование переменных калькулятора
На уровень вверх ..
Построение линий
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора командной строки >
Использование калькулятора командной строки
Понятие Процедура Краткий справочник

Запуск калькулятора командной строки

Выполните одно из следующих действий:

  • В командной строке введите КАЛЬК. Затем введите выражение для вычисления.
  • В ответ на запрос выполняемой команды введите 'КАЛЬК, чтобы запустить калькулятор командной строки в прозрачном режиме. После этого введите выражение для расчета запрашиваемого значения.


Использование калькулятора командной строки (Краткий справочник)

Создание и использование переменных калькулятора
Использование калькулятора командной строки
Построение отрезков
Создание и редактирование объектов > Средства обеспечения точности > Использование калькулятора > Использование калькулятора командной строки >
Использование калькулятора командной строки
Понятие Процедура Краткий справочник

Команды

КАЛЬК

Вычисление математических и геометрических выражений

Системные переменные

CALCINPUT

Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных

Утилиты

Нет

Ключевые слова для команд

Нет


Построение геометрических объектов

Использование калькулятора командной строки
Создание и редактирование объектов
Построение линий
Создание и редактирование объектов >
Построение геометрических объектов

Все чертежи состоят из объектов. Как правило, построение объектов выполняется путем задания точек либо с помощью устройства указания, либо вводом значений координат в командной строке.

Пользователь имеет возможность создавать различного рода графические объекты от простейших отрезков и кругов до сплайновых кривых и эллипсов. Как правило, построение объектов выполняется путем задания точек либо с помощью устройства указания, либо вводом значений координат в командной строке.

Темы в этом разделе

  • Построение линий

    Линия является базовым объектом AutoCAD и может представлять собой один сегмент или набор соединенных сегментов.

  • Построение криволинейных объектов

    К криволинейным объектам относятся дуги, круги, полилинии, кольца, эллипсы и сплайны.

  • Построение вспомогательных и опорных элементов

    Для выполнения точных построений используются такие временные объекты, как вспомогательные линии и опорные точки.

  • Построение и объединение областей

    Области представляют собой двумерные замкнутые области, обладающие такими физическими свойствами, как центры масс. Имеющиеся области можно объединить в одну сложную область с целью вычисления площади.

  • Создание пометочных облаков

    Пометочные облака представляют собой полилинии с дуговыми сегментами. Они используются для нанесения различных пояснительных надписей к элементам чертежа на стадии рассмотрения.


Построение линий

Построение геометрических объектов
Построение геометрических объектов
Построение отрезков
Создание и редактирование объектов > Построение геометрических объектов >
Построение линий
Понятие Процедура

Линия является базовым объектом AutoCAD и может представлять собой один сегмент или набор соединенных сегментов.

Темы в этом разделе

  • Построение отрезков
  • Построение полилиний

    Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.

  • Построение прямоугольников и многоугольников

    Можно быстро создавать прямоугольники и правильные многоугольники. Частным случаем равносторонних многоугольников являются равносторонние треугольники, квадраты, пятиугольники, шестиугольники и т.д.

  • Построение объектов мультилиний

    Мультилинии состоят из параллельных линий (от 1 до 16), называемых элементами.

  • Построение эскизов

    Эскизное рисование используется при построении линий неправильной формы и при оцифровке бумажных оригиналов с помощью дигитайзера.


Построение линий (Процедура)

Использование калькулятора командной строки
Построение линий
Построение отрезков
Создание и редактирование объектов > Построение геометрических объектов > Построение линий >
Построение линий
Понятие Процедура

Для построения отрезка

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура

Для построения описанного многоугольника

Для построения многоугольника с заданной стороной

Для построения вписанного многоугольника

Для построения прямоугольника

Для построения мультилинии

Для создания стиля мультилиний

Для построения эскиза

Стирание эскизных линий


Построение отрезков (Понятие)

Построение линий
Построение линий
Построение полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий >
Построение отрезков
Понятие Процедура Краткий справочник

Последовательность сегментов может быть замкнутой, т.е. конец последнего сегмента может совпадать с началом первого.

Отрезкам можно назначать такие свойства, как цвет, тип и вес линий. Дополнительную информацию о свойствах см. в разделе Работа со свойствами объектов.

Построение выполняется точным указанием конечных точек каждого отрезка. Пользователь может:

  • Вводить значения координат конечной точки с использованием либо абсолютных, либо относительных координат
  • Задать объектную привязку относительно имеющегося объекта. Например, в качестве одной конечной точки отрезка можно задать центр окружности
  • Использовать шаговую привязку

Также существуют и другие методы построения точных отрезков. Очень эффективным способом является создание подобного отрезка с его последующим удлинением или обрезкой до нужной длины.

Если необходимо, чтобы линейные сегменты были связаны между собой, как единый объект, следует использовать полилинии вместо отрезков.

См. также

    • Координаты и системы координат (ПСК)

    • Использование объектной привязки

    • Настройка сетки и шаговой привязки

    • Построение полилиний

    • Создание подобных объектов

    • Разрыв и соединение объектов


Для построения отрезка (Процедура)

Построение линий
На уровень вверх ..
Построение полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение отрезков >
Построение отрезков
Понятие Процедура Краткий справочник

Для построения отрезка

  1. Выберите меню Рисование [image] Отрезок.В командной строке введите "отрезок".
  2. Укажите начальную точку.

    Можно воспользоваться устройством указания или ввести координаты в командной строке.

  3. Укажите конечную точку первого сегмента.

    Чтобы стереть последний сегмент, построенный в ходе выполнения команды ОТРЕЗОК, следует ввести о или выбрать "Отменить" на панели инструментов.

  4. Укажите конечные точки последующих сегментов.
  5. Нажмите ENTER, чтобы завершить построение, или з, чтобы замкнуть последовательность линейных сегментов.

    Чтобы провести новый отрезок из конечной точки последнего построенного отрезка, вызовите команду ОТРЕЗОК и нажмите ENTER в ответ на запрос "Начальная точка".

Панель:Рисование
Ввод команды: ОТРЕЗОК


Построение отрезков (Краткий справочник)

Использование калькулятора командной строки
Построение отрезков
Построение полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение отрезков >
Построение отрезков
Понятие Процедура Краткий справочник

Команды

ОТРЕЗОК

Построение отрезков

ЛУЧ

Построение линии, начинающейся в точке и бесконечной в одном направлении

ПРЯМАЯ

Создание бесконечной линии

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Построение полилиний (Понятие)

Построение отрезков
Построение линий
Построение прямоугольников и многоугольников
Создание и редактирование объектов > Построение геометрических объектов > Построение линий >
Построение полилиний
Понятие Процедура Краткий справочник

Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.

Полилинии идеально подходят для следующих применений:

  • контурные линии на топографических картах, изобары и другие элементы научной графики,
  • электрические схемы и топологии печатных плат,
  • технологические схемы и схемы трубопроводов,
  • профили для выдавливания и траектории выдавливания в твердотельном 3D моделировании.

Для создания полилиний предусмотрен ряд команд, в том числе ПЛИНИЯ, ПРЯМОУГ, МН-УГОЛ, КОЛЬЦО, КОНТУР и ОБЛАКО. При использовании всех этих команд создается объект типа КПОЛИЛИНИЯ (компактная полилиния).

Команда 3DПЛИНИЯ позволяет создавать неплоские полилинии, т.е. объекты типа ПОЛИЛИНИЯ. Для 3D полилиний существует меньше возможностей редактирования.

Созданную полилинию можно редактировать с помощью ручек или команды ПОЛРЕД. С помощью команды РАСЧЛЕНИТЬ полилинию можно преобразовать в отдельные отрезки и дуги.

ПримечаниеСглаженную сплайном полилинию, созданную с помощью команды ПОЛРЕД, можно преобразовать в настоящий сплайновый объект командой СПЛАЙН.

Создание широких полилиний

Создаваемые полилинии могут иметь различную ширину, которая устанавливается опциями "Ширина" и "Полуширина". Для каждого сегмента можно задать свое значение ширины; кроме того, сегменты могут сужаться или расширяться, если значения ширины в начальной и конечной точках различны. Эти опции доступны после указания начальной точки при построении полилинии.

Опциями "Ширина" и "Полуширина" задается ширина следующего создаваемого сегмента полилинии. Любые ненулевые положительные значения ширины приводят к созданию широких линий, которые отображаются закрашенными или в виде контуров, в зависимости от состояния режима заливки.

Места пересечений смежных широких сегментов полилинии обычно подрезаются. Однако, этого не происходит в случае некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.

Создание полилиний из контуров перекрывающихся объектов

Команда КОНТУРпозволяет создать полилинию из границ объектов, образующих замкнутую область. Созданная таким образом полилиния представляет собой отдельный объект, отличающийся от объектов, использовавшихся для ее создания.

При работе с большими и сложными чертежами процесс задания контуров можно упростить, сгруппировав контуры в наборы. Набор создается путем выбора объектов, которые должны определять окончательный контур.

См. также

    • Построение прямоугольников и многоугольников

    • Редактирование сложных объектов

    • Разрыв и соединение объектов

    • Работа с весами линий


Построение полилиний (Процедура)

Построение отрезков
На уровень вверх ..
Построение полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение полилиний >
Построение полилиний
Понятие Процедура Краткий справочник

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии контура


Для построения полилинии из линейных сегментов (Процедура)

Построение полилиний
На уровень вверх ..
Построение полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение полилиний >
Построение полилиний
Понятие Процедура Краткий справочник

Для построения полилинии из линейных сегментов

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку полилинии.
  3. Укажите конечную точку первого сегмента полилинии.
  4. Продолжать указание конечных точек для последующих сегментов.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.

    Чтобы провести новую полилинию из конечной точки последней построенной полилинии, нужно снова вызвать команду ПЛИНИЯ и нажать ENTER в ответ на запрос "Начальная точка".

Панель:Рисование
Ввод команды: ПЛИНИЯ


Для построения полилинии из линейных и дуговых сегментов (Процедура)

Построение полилиний
На уровень вверх ..
Построение полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение полилиний >
Построение полилиний
Понятие Процедура Краткий справочник

Для построения полилинии из линейных и дуговых сегментов

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку сегмента полилинии.
  3. Укажите конечную точку сегмента.
    • Для включения режима построения дуг введите д (дуга).
    • Для возврата в режим построения линейных сегментов введите л (Линейный).
  4. При необходимости построить последующие сегменты полилинии.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.
Панель:Рисование
Ввод команды: ПЛИНИЯ


Для создания широкой полилинии (Процедура)

Построение полилиний
На уровень вверх ..
Построение полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение полилиний >
Построение полилиний
Понятие Процедура Краткий справочник

Для создания широкой полилинии

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку линейного сегмента.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Задайте ширину в конце сегмента одним из следующих методов:
    • Для создания линейного сегмента с постоянной шириной нажмите клавишу ENTER.
    • Для построения сужающегося или расширяющегося линейного сегмента введите другое значение ширины.
  6. Укажите конечную точку сегмента.
  7. Продолжайте указание конечных точек для последующих сегментов.
  8. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.
Панель:Рисование
Ввод команды: ПЛИНИЯ


Для создания полилинии контура (Процедура)

Построение полилиний
На уровень вверх ..
Построение прямоугольников и многоугольников
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение полилиний >
Построение полилиний
Понятие Процедура Краткий справочник

Для создания полилинии контура

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Контур". В командной строке введите "контур".
  2. В списке "Тип объекта" диалогового окна "Создание контура" выберите "Полилиния".
  3. В группе "Набор контуров" выполните одно из следующих действий:
    • Для создания набора контуров с учетом всех объектов, видимых на текущем видовом экране, выберите опцию "Текущий видовой экран". Эту опцию не следует использовать при работе с большими и сложными чертежами.
    • Для ручного выбора объектов, которые должны учитываться при создании набора контуров, нажмите "Новый". Выберите объекты, определяющие контур. При использовании этого параметра автоматически включается параметр "Имеющийся набор".
  4. Нажмите кнопку "Указание точек".
  5. Укажите точки внутри каждой области, которые должны определять контур для построения полилинии.

    Задаваемая область должна быть замкнутой, то есть между объектами, определяющими эту область, не должно быть промежутков. Имеется возможность выбора нескольких областей. Чтобы включить внутренние замкнутые области в набор контуров, нужно щелкнуть "Обнаружение островков".

  6. Для создания контур-полилинии и завершения команды нажмите ENTER.

    Создается полилиния, повторяющая форму заданного контура. Объекты, участвующие в построении полилинии, могут стать невидимыми в результате перекрытия новой полилинией. Построенную полилинию контура можно перемещать, копировать и редактировать точно так же, как и другие полилинии.

Ввод команды: КОНТУР


Построение полилиний (Краткий справочник)

Построение отрезков
Построение полилиний
Построение прямоугольников и многоугольников
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение полилиний >
Построение полилиний
Понятие Процедура Краткий справочник

Команды

3DПЛИНИЯ

Создание 3D полилинии

КОНТУР

Создание области или полилинии из замкнутого контура

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

ЗАКРАСИТЬ

Управление закрашиванием таких объектов, как штриховки, 2D фигуры и широкие полилинии

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ПЛИНИЯ

Создание 2D полилинии

МН-УГОЛ

Построение равносторонних многоугольников в виде замкнутых полилиний

ПРЯМОУГ

Построение полилинии в виде прямоугольника

Системные переменные

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

HPBOUND

Управление типом объекта, созданного с помощью команд КШТРИХ и КОНТУР

PLINEGEN

Управление созданием типа линии вокруг вершин двумерных полилиний

PLINETYPE

Признак использования оптимизированных двумерных полилиний

PLINEWID

Значение по умолчанию для ширины полилинии

Утилиты

Нет

Ключевые слова для команд

Нет


Построение прямоугольников и многоугольников (Понятие)

Построение полилиний
Построение линий
Построение объектов мультилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий >
Построение прямоугольников и многоугольников
Понятие Процедура Краткий справочник

Можно быстро создавать прямоугольники и правильные многоугольники. Частным случаем равносторонних многоугольников являются равносторонние треугольники, квадраты, пятиугольники, шестиугольники и т.д.

Если необходимо, с помощью команды РАСЧЛЕНИТЬ можно преобразовать получившийся полилинейный объект в отрезки.

Построение прямоугольников

Команда ПРЯМОУГ позволяет создавать замкнутые полилинии, имеющие форму прямоугольников.

Построение правильных многоугольников

Команда МН-УГОЛ позволяет создавать замкнутые полилинии в виде равносторонних многоугольников с числом сторон от 3 до 1024. На следующих иллюстрациях представлены три метода создания многоугольников. В каждом случае задаются две точки.

См. также

    • Построение полилиний


Построение прямоугольников и многоугольников (Процедура)

Построение полилиний
На уровень вверх ..
Построение прямоугольников и многоугольников
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение прямоугольников и многоугольников >
Построение прямоугольников и многоугольников
Понятие Процедура Краткий справочник

Для построения описанного многоугольника

Для построения многоугольника с заданной стороной

Для построения вписанного многоугольника

Для построения прямоугольника


Для построения описанного многоугольника (Процедура)

Построение прямоугольников и многоугольников
На уровень вверх ..
Построение прямоугольников и многоугольников
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение прямоугольников и многоугольников >
Построение прямоугольников и многоугольников
Понятие Процедура Краткий справочник

Для построения описанного многоугольника

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Многоугольник". В командной строке введите "мн-угол".
  2. В командной строке введите число сторон.
  3. Укажите центр многоугольника (1).
  4. Введите о (Описанный) для включения режима построения описанного многоугольника.
  5. Задайте радиус (2).

Панель:Рисование
Ввод команды: МН-УГОЛ


Для построения многоугольника с заданной стороной (Процедура)

Построение прямоугольников и многоугольников
На уровень вверх ..
Построение прямоугольников и многоугольников
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение прямоугольников и многоугольников >
Построение прямоугольников и многоугольников
Понятие Процедура Краткий справочник

Для построения многоугольника с заданной стороной

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Многоугольник". В командной строке введите "мн-угол".
  2. В командной строке введите число сторон.
  3. Введите к (Кромка).
  4. Укажите начальную точку одной стороны многоугольника.
  5. Укажите конечную точку этой же стороны.
Панель:Рисование
Ввод команды: МН-УГОЛ


Для построения вписанного многоугольника (Процедура)

Построение прямоугольников и многоугольников
На уровень вверх ..
Построение прямоугольников и многоугольников
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение прямоугольников и многоугольников >
Построение прямоугольников и многоугольников
Понятие Процедура Краткий справочник

Для построения вписанного многоугольника

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Многоугольник". В командной строке введите "мн-угол".
  2. В командной строке введите число сторон.
  3. Укажите центр многоугольника.
  4. Введите в (Вписанный) для входа в режим построения многоугольника, вписанного в круг с заданным центром.
  5. Задайте радиус.
Панель:Рисование
Ввод команды: МН-УГОЛ


Для построения прямоугольника (Процедура)

Построение прямоугольников и многоугольников
На уровень вверх ..
Построение объектов мультилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение прямоугольников и многоугольников >
Построение прямоугольников и многоугольников
Понятие Процедура Краткий справочник

Для построения прямоугольника

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Прямоугольник". В командной строке введите "прямоуг".
  2. Укажите первый угол прямоугольника.
  3. Укажите второй угол прямоугольника.
Панель:Рисование
Ввод команды: ПРЯМОУГ


Построение прямоугольников и многоугольников (Краткий справочник)

Построение полилиний
Построение прямоугольников и многоугольников
Построение объектов мультилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение прямоугольников и многоугольников >
Построение прямоугольников и многоугольников
Понятие Процедура Краткий справочник

Команды

КОНТУР

Создание области или полилинии из замкнутого контура

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

МН-УГОЛ

Построение равносторонних многоугольников в виде замкнутых полилиний

ПРЯМОУГ

Построение полилинии в виде прямоугольника

Системные переменные

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

HPBOUND

Управление типом объекта, созданного с помощью команд КШТРИХ и КОНТУР

PLINEWID

Значение по умолчанию для ширины полилинии

POLYSIDES

Число сторон по умолчанию для команды МН-УГОЛ

SNAPANG

Задание угла поворота сетки и шаговой привязки для текущего видового экрана относительно текущей ПСК

Утилиты

Нет

Ключевые слова для команд

Нет


Построение объектов мультилиний (Понятие)

Построение прямоугольников и многоугольников
Построение линий
Построение эскизов
Создание и редактирование объектов > Построение геометрических объектов > Построение линий >
Построение объектов мультилиний
Понятие Процедура Краткий справочник

Мультилинии состоят из параллельных линий (от 1 до 16), называемых элементами.

При построении мультилинии можно использовать стиль СТАНДАРТ, в котором есть два элемента, или присвоить стиль, созданный ранее. Перед началом рисования можно задать режим расположения и масштаб мультилинии.

Тип расположения мультилинии определяет, с какой стороны от курсора будет нарисована мультилиния, или она будет расположена по центру.

Значение масштаба мультилинии определяет общую ширину мультилинии в текущих единицах. Масштаб мультилинии не связан с масштабом типа линий. Чтобы не допустить непропорционального изменения размеров точек и штрихов при изменении масштаба мультилинии, необходимо внести соответствующие изменения в масштаб типа линий.

Создание стилей мультилиний

Имеется возможность создавать именованные стили мультилиний, определяющие количество элементов и свойства каждого из них. Свойства мультилиний.

  • Общее число элементов и положение каждого элемента
  • Расстояние смещения от оси мультилинии для каждого элемента
  • Цвет и тип линии каждого элемента
  • Символы видимости отрезков, именуемые стыками, на каждой вершине
  • Используемый тип торцевых ограничителей
  • Цвет заливки фона мультилинии

В стиле мультилиний может быть описано до 16 элементов. Элементы с положительным смещением располагаются по одну сторону от оси мультилинии, элементы с отрицательным смещением - по другую сторону.

См. также

    • Редактирование мультилиний


Построение объектов мультилиний (Процедура)

Построение прямоугольников и многоугольников
На уровень вверх ..
Построение объектов мультилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение объектов мультилиний >
Построение объектов мультилиний
Понятие Процедура Краткий справочник

Для построения мультилинии

Для создания стиля мультилиний


Для построения мультилинии (Процедура)

Построение объектов мультилиний
На уровень вверх ..
Построение объектов мультилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение объектов мультилиний >
Построение объектов мультилиний
Понятие Процедура Краткий справочник

Для построения мультилинии

  1. Выберите меню Рисование [image] Мультилиния.В командной строке введите "млиния".
  2. В командной строке введите c для выбора стиля.
  3. Введите ? для получения списка доступных стилей.
  4. Чтобы определить расположение мультилинии, нужно ввести р и выбрать один из следующих вариантов: верх, центр или низ.
  5. Для изменения масштаба мультилинии введите м и задать новый масштаб.

    Теперь можно переходить непосредственно к построению мультилинии.

  6. Укажите начальную точку.
  7. Укажите вторую точку.
  8. Задайте дополнительные точки или нажмите ENTER. Если указано три или более точек, то для замыкания мультилинии можно ввести з.
Ввод команды: МЛИНИЯ


Для создания стиля мультилиний (Процедура)

Построение объектов мультилиний
На уровень вверх ..
Построение эскизов
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение объектов мультилиний >
Построение объектов мультилиний
Понятие Процедура Краткий справочник

Для создания стиля мультилиний

  1. Выберите меню Формат [image] Стиль мультилиний.В командной строке введите "млстиль".

  2. В диалоговом окне "Стиль мультилиний" нажмите кнопку "Создать".
  3. В диалоговом окне "Создать новый стиль мультилинии" введите имя стиля мультилинии и выберите стиль для начала рисования. Нажмите кнопку "Продолжить".

  4. В диалоговом окне "Новый стиль мультилинии" выберите параметры стиля мультилинии. Можно также ввести описание.

    Описание не является обязательной характеристикой стиля мультилиний. Его длина не должна превышать 255 символов, включая пробелы.

  5. Нажмите "ОК".
  6. В диалоговом окне "Стиль мультилинии" нажмите кнопку "Сохранить", чтобы сохранить стиль мультилинии в файле (по умолчанию имя файла — acad.mln). В одном файле можно сохранять несколько стилей мультилиний.

    Перед созданием нового стиля мультилинии следует сохранить текущий стиль. В противном случае все изменения в текущем стиле будут потеряны.


Построение объектов мультилиний (Краткий справочник)

Построение прямоугольников и многоугольников
Построение объектов мультилиний
Построение эскизов
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение объектов мультилиний >
Построение объектов мультилиний
Понятие Процедура Краткий справочник

Команды

ПОДОБИЕ

Построение концентрических кругов, параллельных отрезков и кривых

МЛИНИЯ

Создание нескольких параллельных отрезков

МЛСТИЛЬ

Создание, изменение стилей мультилиний и управление ими

Системные переменные

CMLSTYLE

Задание стиля, который управляет отображением многострочного текста

Утилиты

Нет

Ключевые слова для команд

Нет


Построение эскизов (Понятие)

Построение объектов мультилиний
Построение линий
Построение криволинейных объектов
Создание и редактирование объектов > Построение геометрических объектов > Построение линий >
Построение эскизов
Понятие Процедура Краткий справочник

Эскизное рисование используется при построении линий неправильной формы и при оцифровке бумажных оригиналов с помощью дигитайзера.

Для рисования эскизов существует команда ЭСКИЗ. Эскизное рисование используется при построении линий неправильной формы и при оцифровке бумажных оригиналов с помощью дигитайзера.

Создание эскизов

При эскизном рисовании устройство указания используется как перо. После щелчка мыши перо опускается и рисует на экране; следующий щелчок мыши поднимает перо, и рисование прекращается. Эскизы состоят из множества прямолинейных сегментов. Каждый из сегментов может представлять собой либо отдельный объект, либо сегмент полилинии. Минимальная длина, или приращение, сегментов задается пользователем. При этом малая длина сегментов обеспечивает точность построений, но при этом значительно увеличивается размер файла чертежа. Поэтому данное средство следует применять только в случае крайней необходимости.

Перед построением эскиза следует убедиться, что системная переменная CELTYPE задает тип линии ПОСЛОЮ. Если используется тип линий, состоящий из точек или штрихов, а длина некоторых элементов образца (штрихов или промежутков) превышает величину приращения, то образец типа линий будет рисоваться не полностью.

Стирание эскизных линий

Стирание эскизных линий производится с помощью опции "Стереть" команды ЭСКИЗ. При этом стирается участок эскизной линии от выбранной точки до конца линии.

Сохраненные эскизные линии нельзя ни редактировать, ни стирать опцией "Стереть" команды ЭСКИЗ. По завершении эскизного рисования воспользуйтесь командой СТЕРЕТЬ.

Создание эскиза в режиме "Планшет"

Режим "Планшет" используется при работе с дигитайзером. Эскизное рисование в режиме "Планшет" используется, например, для копирования контуров карт с бумажного оригинала непосредственно на чертеж. Во время построения эскиза невозможно отключить режим "Планшет".

При включенном режиме "Планшет" можно настроить программу таким образом, что координаты чертежа на бумаге будут отображаться в программе в соответствии с Мировой системой координат. Таким образом устанавливается прямая связь между координатами перекрестья курсора на экране, координатами на планшете и координатами исходного чертежа. После того как соотнесение координат чертежа на бумаге настроено, может обнаружиться, что область, отображаемая на экране, не является требуемой областью. Во избежание этого перед входом в режим эскизного рисования нужно с помощью команды ПОКАЗАТЬ добиться показа на экране всей рабочей области.

Некоторые дигитайзеры не позволяют работать с меню при включенном режиме "Планшет". Дополнительные сведения см. в документации по используемому дигитайзеру.

Обеспечение точности эскизного рисования

Чтобы добиться достаточной точности рисования на медленном компьютере, следует устанавливать отрицательное значение приращения. Команда ЭСКИЗ использует это значение, как если бы оно было положительным, но при этом проверяет, чтобы расстояние между двумя последними полученными с устройства указания точками не превышало удвоенную величину приращения. Если расстояние превышает удвоенное приращение, выдается звуковой сигнал, означающий, что следует замедлить движение устройства указания; иначе точность рисования будет снижена. Например, если величина приращения составляет -1, шаг перемещения курсора не должен превышать 2. При использовании этого метода скорость трассировки не снижается.


Построение эскизов (Процедура)

Построение объектов мультилиний
На уровень вверх ..
Построение эскизов
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение эскизов >
Построение эскизов
Понятие Процедура Краткий справочник

Для построения эскиза

Стирание эскизных линий


Для построения эскиза (Процедура)

Построение эскизов
На уровень вверх ..
Построение эскизов
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение эскизов >
Построение эскизов
Понятие Процедура Краткий справочник

Для построения эскиза

  1. В командной строке введите эскиз.
  2. В ответ на запрос "Приращение:" введите значение минимальной длины линейного сегмента.
  3. Щелкните мышью, чтобы опустить перо.

    При перемещении устройства указания, программа рисует сегменты временных эскизных линий, указанной пользователем длины. Для команды ЭСКИЗ невозможно ввести координаты с клавиатуры. В ходе выполнения команды эскизные линии выделяются цветом.

  4. Для поднятия пера вновь щелкните мышью. После этого при перемещении курсора по экрану линия не строится. Нажмите кнопку мыши для задания новой начальной точки и продолжайте черчение.
  5. В любой момент можно ввести з, чтобы записать (сохранить) построенный эскиз в базу данных.

    Если перо опущено, то после записи можно продолжать черчение. Если перо поднято, для продолжения черчения требуется щелкнуть мышью. Новая линия строится из точки, в которой находится курсор.

  6. Для завершения эскиза и сохранения всех не сохраненных линий нажмите ENTER.


Стирание эскизных линий (Процедура)

Построение эскизов
На уровень вверх ..
Построение криволинейных объектов
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение эскизов >
Построение эскизов
Понятие Процедура Краткий справочник

Стирание эскизных линий

  1. Независимо от того, поднято перо или опущено, выполняя команду ЭСКИЗ, введите с (Стереть).

    Если перо было опущено, оно поднимается.

  2. Переместите курсор к конечной точке последней нарисованной линии; затем переместите его вдоль линии к точке, от которой необходимо стереть участок эскизной линии.
  3. Для возврата к обычной командной строке команды ЭСКИЗ введите п. Для отказа от стирания введите х.

    Для изменения текущего видового экрана в ходе эскизного рисования необходимо выполнение следующих условий: перо поднято, все эскизные линии сохранены, режим "Планшет" отключен.


Построение эскизов (Краткий справочник)

Построение объектов мультилиний
Построение эскизов
Построение дуг
Создание и редактирование объектов > Построение геометрических объектов > Построение линий > Построение эскизов >
Построение эскизов
Понятие Процедура Краткий справочник

Команды

ЭСКИЗ

Рисование коротких смежных сегментов от руки

Системные переменные

SKETCHINC

Значение приращения для команды ЭСКИЗ

SKPOLY

Определение типа объектов (линии или полилинии), генерируемых командой ЭСКИЗ

Утилиты

Нет

Ключевые слова для команд

Нет


Построение криволинейных объектов

Построение эскизов
Построение геометрических объектов
Построение дуг
Создание и редактирование объектов > Построение геометрических объектов >
Построение криволинейных объектов
Понятие Процедура

К криволинейным объектам относятся дуги, круги, полилинии, кольца, эллипсы и сплайны.

Темы в этом разделе

  • Построение дуг

    Дуги можно строить различными способами с использованием различных сочетаний таких параметров, как центральная, начальная и конечная точки, радиус, центральный угол, длина и направление хорды.

  • Построение кругов

    Для построения кругов используются различные сочетания таких параметров, как положение центра, радиус, диаметр, положение точек окружности и других объектов.

  • Построение дуг полилиний

    Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.

  • Построение колец

    Кольца представляют собой заполненные круги или замкнутые широкие полилинии круглой формы.

  • Построение эллипсов

    Построение эллипсов производится путем задания двух осей. Длинная ось эллипса называется его большой осью, короткая - малой осью.

  • Построение сплайнов

    Сплайн представляет собой гладкую кривую, проходящую через заданный набор точек или рядом с ними. Пользователь может задавать точность прохождения кривой через определяющие точки.

  • Построение спиралей

    Спираль представляет собой открытую 2D или 3D переходную кривую.


Построение криволинейных объектов (Процедура)

Построение эскизов
Построение криволинейных объектов
Построение дуг
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение криволинейных объектов
Понятие Процедура

Для построения дуги по трем точкам

Для построения дуги по началу, центру и концу

Для продолжения дуги касательным отрезком

Для продолжения дуги касательной дугой

Для построения круга по центру и радиусу (или диаметру)

Для построения круга, касающегося двух объектов

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии из контура

Для построения кольца

Для построения изометрического круга

Для построения эллипса по конечным точкам одной оси и половине длины другой оси

Для построения эллиптической дуги по начальному и конечному углам

Преобразование сглаженных сплайнами полилиний в сплайны

Для построения сплайна путем задания определяющих точек

Для создания спирали


Построение дуг (Понятие)

Построение криволинейных объектов
Построение криволинейных объектов
Построение кругов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение дуг
Понятие Процедура Краткий справочник

Дуги можно строить различными способами с использованием различных сочетаний таких параметров, как центральная, начальная и конечная точки, радиус, центральный угол, длина и направление хорды.

Дуги можно строить различными способами. Обычно дуги создаются в направлении против хода часовой стрелки (кроме первого рассматриваемого ниже метода).

Построение дуг по трем точкам

Имеется возможность построения дуги путем задания трех точек. В следующем примере начальная точка дуги совпадает с конечной точкой отрезка. Вторая точка дуги привязана к средней окружности.

Построение дуги по началу, центру и концу

Если известны начальная, центральная и конечная точки, то построение дуги можно начать с указания как начальной, так и центральной точки. Центральная точка совпадает с центром окружности, частью которой является создаваемая дуга.

Построение дуги по началу, центру и углу

Если известны начальная точка, центр дуги и центральный угол, то можно воспользоваться опцией "Начало, центр, угол" или "Центр, начало, угол".

Положение конечной точки определяется центральным углом. Если же известны начало и конец, но неизвестен центр дуги, следует воспользоваться методом "Начало, конец, угол".

Построение дуги по началу, центру и длине хорды

Если известны начальная точка, центр дуги и длина хорды, то можно воспользоваться методом "Начало, центр, длина" или "Центр, начало, длина".

Длина хорды определяет центральный угол дуги.

Построение дуги по началу, концу и направлению/радиусу

Если известны начальная и конечная точки, то можно воспользоваться методом "Начало, конец, направление" или "Начало, конец, радиус".

На чертеже слева показана дуга, построенная путем указания начальной точки, конечной точки и радиуса. Радиус задается с клавиатуры или путем перемещения курсора в требуемом направлении с последующим вводом точного значения расстояния.

На чертеже справа изображена дуга, построенная с помощью устройства указания путем задания начальной и конечной точек и направления касательной. Если курсор перемещается вверх от начальной и конечной точек, то строится вогнутая дуга, как показано в данном случае. При перемещении курсора вниз строится выпуклая дуга.

Построение смежных дуг и отрезков

Сразу после завершения построения дуги можно приступить к созданию касательной к дуге в ее конечной точке, вызвав команду ОТРЕЗОК и нажав ENTER в ответ на запрос "Начальная точка". От пользователя в данном случае требуется только задать его длину.

Аналогично, после построения отрезка можно приступить к построению дуги, касательной к отрезку в его конечной точке, для чего нужно вызвать команду ДУГА и нажать ENTER в ответ на запрос "Начальная точка". От пользователя в данном случае требуется только задать конечную точку дуги.

Подобным образом можно строить последовательности дуг, соединенных между собой. Для построения соединенных дуг с помощью меню выберите меню Рисование [image] Дуга [image] Продолжить.Для построения соединенных дуг с помощью меню введите в командной строке команду "дуга". В данном случае смежные дуги имеют общую касательную в точке соединения. Последующие касательные дуги можно строить с помощью пункта "Продолжить" контекстного меню.

См. также

    • Построение полилиний

    • Разрыв и соединение объектов


Построение дуг (Процедура)

Построение криволинейных объектов
На уровень вверх ..
Построение дуг
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг >
Построение дуг
Понятие Процедура Краткий справочник

Для построения дуги по трем точкам

Для построения дуги по началу, центру и концу

Для продолжения дуги касательным отрезком

Для продолжения дуги касательной дугой


Для построения дуги по трем точкам (Процедура)

Построение дуг
На уровень вверх ..
Построение дуг
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг >
Построение дуг
Понятие Процедура Краткий справочник

Для построения дуги по трем точкам

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "3 точки". В командной строке введите "дуга".
  2. Укажите начальную точку.
  3. Укажите промежуточную точку дуги.
  4. Укажите конечную точку.
Панель:Рисование
Ввод команды: ДУГА


Для построения дуги по началу, центру и концу (Процедура)

Построение дуг
На уровень вверх ..
Построение дуг
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг >
Построение дуг
Понятие Процедура Краткий справочник

Для построения дуги по началу, центру и концу

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Начало, центр, конец". В командной строке введите "дуга".
  2. Укажите начальную точку.
  3. Укажите точку центра.
  4. Укажите конечную точку.
Панель:Рисование
Ввод команды: ДУГА


Для продолжения дуги касательным отрезком (Процедура)

Построение дуг
На уровень вверх ..
Построение дуг
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг >
Построение дуг
Понятие Процедура Краткий справочник

Для продолжения дуги касательным отрезком

  1. Завершите построение дуги.
  2. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Отрезок". В командной строке введите "отрезок".
  3. Нажмите ENTER на запрос указания первой точки.
  4. Ввести длину отрезка и нажмите ENTER.
Панель:Рисование
Ввод команды: ОТРЕЗОК


Для продолжения дуги касательной дугой (Процедура)

Построение дуг
На уровень вверх ..
Построение кругов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг >
Построение дуг
Понятие Процедура Краткий справочник

Для продолжения дуги касательной дугой

  1. Завершить построение дуги.
  2. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Продолжить". В командной строке введите "дуга".
  3. Укажите конец касательной дуги.
Панель:Рисование
Ввод команды: ДУГА


Построение дуг (Краткий справочник)

Построение эскизов
Построение дуг
Построение кругов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг >
Построение дуг
Понятие Процедура Краткий справочник

Команды

ДУГА

Построение дуг

ОТРЕЗОК

Построение отрезков

ПОДОБИЕ

Построение концентрических кругов, параллельных отрезков и кривых

НАСТРВИД

Задание точности аппроксимации объектов на текущем видовом экране

Системные переменные

ANGDIR

Направление отсчета положительных углов

LASTANGLE

Конечный угол последней введенной дуги в плоскости XY текущей ПСК в текущем пространстве

WHIPARC

Управление сглаживанием кругов и дуг на экране

Утилиты

Нет

Ключевые слова для команд

Нет


Построение кругов (Понятие)

Построение дуг
Построение криволинейных объектов
Построение дуг полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение кругов
Понятие Процедура Краткий справочник

Для построения кругов используются различные сочетания таких параметров, как положение центра, радиус, диаметр, положение точек окружности и других объектов.

Круги можно строить различными способами. По умолчанию построение производится по заданным центру и радиусу. Существуют также три дополнительных метода, которые показаны на чертеже.

Построение окружности, касающейся других объектов

Точка касания - это точка, в которой объект касается другого объекта, не пересекаясь с ним. Для построения окружности, касающейся других объектов, нужно указать точки касания на каждом из объектов и радиус окружности. На следующих чертежах построенная окружность показана жирной линией; точки касания - (1) и (2).

Для построения окружности, касательной в трех точках, нужно установить режим привязки "Касательная" командой ПРИВЯЗКА и построить окружность по трем точкам.

См. также

    • Использование объектной привязки

    • Построение изометрических кругов


Построение кругов (Процедура)

Построение дуг
На уровень вверх ..
Построение кругов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение кругов >
Построение кругов
Понятие Процедура Краткий справочник

Для построения круга по центру и радиусу (или диаметру)

Для построения круга, касающегося двух объектов


Для построения круга по центру и радиусу (или диаметру) (Процедура)

Построение кругов
На уровень вверх ..
Построение кругов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение кругов >
Построение кругов
Понятие Процедура Краткий справочник

Для построения круга по центру и радиусу (или диаметру)

  1. Выполните одно из следующих действий:
    • Выберите вкладку "Главная" [image] панель "Рисование" [image] "Центр, радиус". В командной строке введите круг.
    • Выберите вкладку "Главная" [image] панель "Рисование" [image] "Центр, диаметр". В командной строке введите круг.
  2. Укажите точку центра.
  3. Задайте радиус или диаметр.
Панель:Рисование
Ввод команды: КРУГ


Для построения круга, касающегося двух объектов (Процедура)

Построение кругов
На уровень вверх ..
Построение дуг полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение кругов >
Построение кругов
Понятие Процедура Краткий справочник

Для построения круга, касающегося двух объектов

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "2 точки касания, радиус". В командной строке введите круг.

    Включается режим объектной привязки "Касательная".

  2. Выберите первый объект, которого касается окружность.
  3. Выберите второй объект, которого касается окружность.
  4. Задайте радиус круга.
Панель:Рисование
Ввод команды: КРУГ


Построение кругов (Краткий справочник)

Построение дуг
Построение кругов
Построение дуг полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение кругов >
Построение кругов
Понятие Процедура Краткий справочник

Команды

КРУГ

Построение окружностей

ПОДОБИЕ

Построение концентрических кругов, параллельных отрезков и кривых

Системные переменные

CIRCLERAD

Задание радиуса круга по умолчанию

WHIPARC

Управление сглаживанием кругов и дуг на экране

Утилиты

Нет

Ключевые слова для команд

Нет


Построение дуг полилиний (Понятие)

Построение кругов
Построение криволинейных объектов
Построение колец
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение дуг полилиний
Понятие Процедура Краткий справочник

Полилиния представляет собой связанную последовательность сегментов; все эти сегменты являются единым объектом. Полилинии могут состоять из линейных и дуговых сегментов, а также из любых их сочетаний.

Полилинии используются, если предполагается работа с набором сегментов как с целым. У полилиний можно изменять ширину и кривизну сегментов. Имеющиеся на чертеже полилинии можно отредактировать командой ПОЛРЕД, а также преобразовать в отдельные линейные и дуговые сегменты с помощью команды РАСЧЛЕНИТЬ. Пользователь может:

  • Преобразовывать сглаженные сплайнами полилинии в сплайны командой СПЛАЙН
  • Создавать многоугольники с помощью замкнутых полилиний
  • Создавать полилинии из контуров перекрывающихся объектов

Создание дуговых полилиний

Полилинии могут иметь дуговые сегменты. Каждый из таких сегментов строится из конечной точки предыдущего сегмента. Дуги описываются заданием угла, центра, направления или радиуса. Кроме того, дугу можно построить указанием второй и конечной точек.

Создание замкнутых полилиний

Имеется возможность построения замкнутой полилинии для создания многоугольника. Для замыкания полилинии нужно выбрать начальную точку последней стороны объекта, ввести з (Замкнуть) и нажать ENTER.

Создание широких полилиний

Создаваемые полилинии могут иметь различную ширину, которая устанавливается опциями "Ширина" и "Полуширина". Для каждого сегмента можно задать свое значение ширины; кроме того, сегменты могут сужаться или расширяться, если значения ширины в начальной и конечной точках различны. Эти опции доступны после указания начальной точки при построении полилинии.

Опциями "Ширина" и "Полуширина" задается ширина следующего создаваемого сегмента полилинии. При указании значения 0 строится тонкий сегмент с нулевой шириной. Любые ненулевые положительные значения ширины приводят к созданию широких линий, которые отображаются закрашенными или в виде контуров, в зависимости от состояния режима заливки. Опцией "Полуширина" можно задавать расстояние от осевой линии широкой полилинии до ее края.

Конус

При использовании опции "Ширина" предоставляется возможность задания ширины сегмента как в начальной точке, так и в конечной. В этом случае ввод разных значений позволяет строить сужающиеся полилинии. Начальные и конечные точки широких сегментов полилинии располагаются на центральных осевых линиях сегментов. Места пересечений смежных широких сегментов полилинии обычно подрезаются. Однако, этого не происходит в случае некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.

Создание полилиний из контуров перекрывающихся объектов

Из контура, полученного в результате взаимного перекрытия объектов и образующего замкнутую область, можно создать полилинию. Полилиния, построенная таким образом, является отдельным объектом и не связана с объектами, определяющими контур построения. С такой полилинией можно выполнять те же действия, что и с другими полилиниями.

При работе с большими и сложными чертежами процесс задания контуров можно упростить, сгруппировав контуры в наборы. Набор создается путем выбора объектов, которые должны определять окончательный контур.

См. также

    • Редактирование сплайнов

    • Редактирование и объединение полилиний

    • Разрыв и соединение объектов

    • Работа с весами линий


Построение дуг полилиний (Процедура)

Построение кругов
На уровень вверх ..
Построение дуг полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг полилиний >
Построение дуг полилиний
Понятие Процедура Краткий справочник

Для построения полилинии из линейных сегментов

Для построения полилинии из линейных и дуговых сегментов

Для создания широкой полилинии

Для создания полилинии из контура


Для построения полилинии из линейных сегментов (Процедура)

Построение дуг полилиний
На уровень вверх ..
Построение дуг полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг полилиний >
Построение дуг полилиний
Понятие Процедура Краткий справочник

Для построения полилинии из линейных сегментов

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку полилинии.
  3. Укажите конечную точку первого сегмента полилинии.
  4. Продолжите указание конечных точек для последующих сегментов.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.

    Чтобы провести новую полилинию из конечной точки последней построенной полилинии, нужно снова вызвать команду ПЛИНИЯ и нажать ENTER в ответ на запрос "Начальная точка".

Панель:Рисование
Ввод команды: ПЛИНИЯ


Для построения полилинии из линейных и дуговых сегментов (Процедура)

Построение дуг полилиний
На уровень вверх ..
Построение дуг полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг полилиний >
Построение дуг полилиний
Понятие Процедура Краткий справочник

Для построения полилинии из линейных и дуговых сегментов

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку сегмента полилинии.
  3. Укажите конечную точку сегмента.
    • Для включения режима построения дуг введите д (дуга) в командной строке.
    • Для возврата в режим построения линейных сегментов введите л (Линейный).
  4. При необходимости построить последующие сегменты полилинии.
  5. Для завершения построения нажмите ENTER или введите з, если нужно замкнуть полилинию.
Панель:Рисование
Ввод команды: ПЛИНИЯ


Для создания широкой полилинии (Процедура)

Построение дуг полилиний
На уровень вверх ..
Построение дуг полилиний
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг полилиний >
Построение дуг полилиний
Понятие Процедура Краткий справочник

Для создания широкой полилинии

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку линейного сегмента.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Задайте ширину в конце сегмента одним из следующих методов:
    • Для создания линейного сегмента с постоянной шириной нажмите клавишу ENTER.
    • Для построения сужающегося или расширяющегося линейного сегмента введите другое значение ширины.
  6. Укажите конечную точку сегмента.
  7. Продолжайте указание конечных точек для последующих сегментов.
  8. Нажмите ENTER для завершения команды или с для замыкания полилинии.
Панель:Рисование
Ввод команды: ПЛИНИЯ


Для создания полилинии из контура (Процедура)

Построение дуг полилиний
На уровень вверх ..
Построение колец
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг полилиний >
Построение дуг полилиний
Понятие Процедура Краткий справочник

Для создания полилинии из контура

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Контур". В командной строке введите "контур".
  2. В списке "Тип объекта" диалогового окна "Создание контура" выберите "Полилиния".
  3. В группе "Набор контуров" выполните одно из следующих действий:
    • Для создания набора контуров из всех объектов, видимых на текущем видовом экране, выберите из списка параметр "Текущий видовой экран". Эту опцию не следует использовать при работе с большими и сложными чертежами.
    • Для ручного выбора объектов, которые должны учитываться при создании набора контуров, нажмите "Новый". Выберите объекты, которые будут использоваться при создании контуров. При использовании этой опции автоматически включается опция "Имеющийся набор".
  4. Нажать кнопку "Указание точек".
  5. Укажите точки внутри каждой области, которые должны определять контур для построения полилинии.

    Задаваемая область должна быть замкнутой, то есть между объектами, определяющими эту область, не должно быть промежутков. Имеется возможность выбора нескольких областей.

  6. Для создания контур-полилинии и завершения команды нажмите ENTER.

    Создается полилиния, повторяющая форму заданного контура. Объекты, участвующие в построении полилинии, могут стать невидимыми в результате перекрытия новой полилинией. Построенную полилинию контура можно перемещать, копировать и редактировать точно так же, как и другие полилинии.

Ввод команды: КОНТУР


Построение дуг полилиний (Краткий справочник)

Построение кругов
Построение дуг полилиний
Построение колец
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение дуг полилиний >
Построение дуг полилиний
Понятие Процедура Краткий справочник

Команды

3DПЛИНИЯ

Создание 3D полилинии

КОНТУР

Создание области или полилинии из замкнутого контура

ПОДОБИЕ

Построение концентрических кругов, параллельных отрезков и кривых

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ПЛИНИЯ

Создание 2D полилинии

НАСТРВИД

Задание точности аппроксимации объектов на текущем видовом экране

Системные переменные

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

HPBOUND

Управление типом объекта, созданного с помощью команд КШТРИХ и КОНТУР

PLINEGEN

Управление созданием типа линии вокруг вершин двумерных полилиний

PLINETYPE

Признак использования оптимизированных двумерных полилиний

PLINEWID

Значение по умолчанию для ширины полилинии

Утилиты

Нет

Ключевые слова для команд

Нет


Построение колец (Понятие)

Построение дуг полилиний
Построение криволинейных объектов
Построение эллипсов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение колец
Понятие Процедура Краткий справочник

Кольца представляют собой заполненные круги или замкнутые широкие полилинии круглой формы.

Для построения кольца необходимо задать его внутренний и внешний диаметры, а также центр. Вызванная команда позволяет построить любое количество колец, имеющих одинаковые диаметры, но разные центры. Если требуется построить закрашенный круг, следует задать нулевой внутренний диаметр кольца.


Для построения кольца (Процедура)

Построение дуг полилиний
На уровень вверх ..
Построение эллипсов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение колец >
Построение колец
Понятие Процедура Краткий справочник

Для построения кольца

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Кольцо". В командной строке введите "кольцо".
  2. Задайте внутренний диаметр (1).
  3. Задайте наружный диаметр (2).
  4. Укажите центр кольца (3).
  5. Укажите центральную точку для другого кольца или нажмите клавишу ENTER для завершения команды.


Построение колец (Краткий справочник)

Построение дуг полилиний
Построение колец
Построение эллипсов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение колец >
Построение колец
Понятие Процедура Краткий справочник

Команды

КОЛЬЦО

Построение закрашенных кругов и колец

ЗАЛИВКА

Управление закрашиванием таких объектов, как штриховки, 2D фигуры и широкие полилинии

Системные переменные

DONUTID

Значение по умолчанию для внутреннего диаметра кольца

DONUTOD

Значение по умолчанию для внешнего диаметра кольца

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

Утилиты

Нет

Ключевые слова для команд

Нет


Построение эллипсов (Понятие)

Построение колец
Построение криволинейных объектов
Построение сплайнов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение эллипсов
Понятие Процедура Краткий справочник

Построение эллипсов производится путем задания двух осей. Длинная ось эллипса называется его большой осью, короткая - малой осью.

На следующем чертеже показаны два разных эллипса, построенные по конечным точкам одной оси и половине длины другой оси. Третья точка задает лишь половину длины второй оси, но не положение ее конечной точки.

При рисовании на плоскостях изометрии (имитация трехмерного рисования) окружности, рассматриваемые под углом к плоскости, представляются эллипсами. Перед рисованием нужно включить режим изометрии с помощью диалогового окна "Режимы рисования".

См. также

    • Построение изометрических кругов

    • Разрыв и соединение объектов


Построение эллипсов (Процедура)

Построение колец
На уровень вверх ..
Построение эллипсов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение эллипсов >
Построение эллипсов
Понятие Процедура Краткий справочник

Для построения изометрического круга

Для построения эллипса по конечным точкам одной оси и половине длины другой оси

Для построения эллиптической дуги по начальному и конечному углам


Для построения изометрического круга (Процедура)

Построение эллипсов
На уровень вверх ..
Построение эллипсов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение эллипсов >
Построение эллипсов
Понятие Процедура Краткий справочник

Для построения изометрического круга

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. В диалоговом окне "Режимы рисования" на вкладке "Шаг и сетка", для параметра "Тип и стиль привязки" выберите "Изометрическая". Нажмите "ОК".
  3. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Ось, конец". В командной строке введите эллипс.
  4. Введите и (изокруг).
  5. Укажите центр круга.
  6. Задайте радиус или диаметр круга.
Панель:Рисование
Ввод команды: ЭЛЛИПС


Для построения эллипса по конечным точкам одной оси и половине длины другой оси (Процедура)

Построение эллипсов
На уровень вверх ..
Построение эллипсов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение эллипсов >
Построение эллипсов
Понятие Процедура Краткий справочник

Для построения эллипса по конечным точкам одной оси и половине длины другой оси

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Ось, конец". В командной строке введите эллипс.
  2. Укажите начало первой оси (1).
  3. Укажите конец первой оси (2).
  4. Перетащив курсор на нужное расстояние, задать щелчком мыши половину длины второй оси (3).

Панель:Рисование
Ввод команды: ЭЛЛИПС


Для построения эллиптической дуги по начальному и конечному углам (Процедура)

Построение эллипсов
На уровень вверх ..
Построение сплайнов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение эллипсов >
Построение эллипсов
Понятие Процедура Краткий справочник

Для построения эллиптической дуги по начальному и конечному углам

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Дуга". В командной строке введите "эллипс".
  2. Укажите конечные точки первой оси (1 и 2).
  3. Задайте половину длины второй оси (3).
  4. Задайте начальный угол (4).
  5. Задайте конечный угол (5).

    Эллиптическая дуга будет построена между начальной и конечной точками против часовой стрелки.

Панель:Рисование
Ввод команды: ЭЛЛИПС


Построение эллипсов (Краткий справочник)

Построение колец
Построение эллипсов
Построение сплайнов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение эллипсов >
Построение эллипсов
Понятие Процедура Краткий справочник

Команды

ЭЛЛИПС

Построение эллипсов и эллиптических дуг

Системные переменные

ANGDIR

Направление отсчета положительных углов

PELLIPSE

Определение типа эллипса, созданного с помощью команды ЭЛЛИПС

Утилиты

Нет

Ключевые слова для команд

Нет


Построение сплайнов (Понятие)

Построение эллипсов
Построение криволинейных объектов
Построение спиралей
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение сплайнов
Понятие Процедура Краткий справочник

Сплайн представляет собой гладкую кривую, проходящую через заданный набор точек или рядом с ними. Пользователь может задавать точность прохождения кривой через определяющие точки.

Команда СПЛАЙН работает с частным случаем сплайнов неоднородными рациональными B-сплайновыми кривыми (NURBS). Применение NURBS обеспечивает достаточную гладкость кривых, проходящих через заданные управляющие точки.

Сплайны строятся путем задания координат определяющих точек. Сплайны могут быть замкнутыми; при этом совпадают как конечная и начальная точки, так и направления касательных в них.

Допуск задает максимально допустимое расстояние от реального сплайна до любой из определяющих точек. Чем меньше значение допуска, тем сплайн ближе к определяющим точкам. При нулевом допуске сплайн проходит через определяющие точки. При изменении допуска можно визуально контролировать результат для выбора оптимального значения.

Имеется два способа построения сплайнов:

  • Создание сплайнов с помощью опции "Сплайн" команды ПОЛРЕД, т.е. путем сглаживания имеющихся полилиний, созданных командой ПЛИНИЯ. Такие сглаженные сплайнами полилинии создаются с применением однородных узловых векторов и в дальнейшем могут использоваться в чертежах, созданных в более ранних версиях продукта.
  • Создание реальных сплайнов в виде NURBS-кривых с помощью команды СПЛАЙН. Чертеж, содержащий такие сплайны, занимает меньше места на диске и в оперативной памяти, чем Чертеж с полилиниями и фигурами подобных форм.

Сглаженные сплайнами полилинии можно легко преобразовать в реальные сплайны командой СПЛАЙН.

См. также

    • Редактирование сплайнов

    • Разрыв и соединение объектов


Построение сплайнов (Процедура)

Построение эллипсов
На уровень вверх ..
Построение сплайнов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение сплайнов >
Построение сплайнов
Понятие Процедура Краткий справочник

Преобразование сглаженных сплайнами полилиний в сплайны

Для построения сплайна путем задания определяющих точек


Преобразование сглаженных сплайнами полилиний в сплайны (Процедура)

Построение сплайнов
На уровень вверх ..
Построение сплайнов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение сплайнов >
Построение сплайнов
Понятие Процедура Краткий справочник

Преобразование сглаженных сплайнами полилиний в сплайны

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Сплайн". В командной строке введите "сплайн".
  2. Введите о (Объект).
  3. Выберите сглаженную сплайнами полилинию и нажмите ENTER.

    Выбранный объект преобразуется из полилинии в сплайн.


Для построения сплайна путем задания определяющих точек (Процедура)

Построение сплайнов
На уровень вверх ..
Построение спиралей
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение сплайнов >
Построение сплайнов
Понятие Процедура Краткий справочник

Для построения сплайна путем задания определяющих точек

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Сплайн". В командной строке введите "сплайн".
  2. Укажите начальную точку сплайна (1).
  3. Укажите определяющие точки сплайна (2-5); затем нажмите ENTER.
  4. Задайте направления касательных в начальной и конечной точках (6, 7).

На следующем чертеже показан сплайн с теми же определяющими точками, но с разными направлениями касательных в первой и последней точках.

Следующий сплайн построен по тем же определяющим точкам, но с большим допуском и другими направлениями касательных.

Панель:Рисование
Ввод команды: СПЛАЙН


Построение сплайнов (Краткий справочник)

Построение эллипсов
Построение сплайнов
Построение спиралей
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение сплайнов >
Построение сплайнов
Понятие Процедура Краткий справочник

Команды

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ПЛИНИЯ

Создание 2D полилинии

СПЛАЙН

Создание плавной кривой, проходящей через указанные точки или вблизи них

РЕДСПЛАЙН

Редактирование сплайнов или сглаженных сплайнами полилиний

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Построение спиралей (Понятие)

Построение сплайнов
Построение криволинейных объектов
Построение вспомогательных и опорных элементов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов >
Построение спиралей
Понятие Процедура Краткий справочник

Спираль представляет собой открытую 2D или 3D переходную кривую.

Показать: Создать и изменить спираль

Для запуска анимации нажмите на стрелку "Просмотр". Подробней об изменении спиралей см. в разделе Изменение спиралей.

Спираль можно использовать в качестве траектории для команды СДВИГ. Например, при сдвиге круга вдоль траектории спирали может быть создана твердотельная модель пружины.

При создании спирали можно указать следующие параметры:

  • Радиус в основании
  • Радиус верхнего основания
  • Высота
  • Число витков
  • Высота витка
  • Направление вращения

Если для радиуса в основании и радиуса верхнего основания задать равные значения, будет создана цилиндрическая спираль. По умолчанию радиус верхнего основания и радиус в основании задаются равными. Значение 0 не может быть задано ни для радиуса верхнего основания, ни для радиуса в основании.

Если для радиуса в основании и радиуса верхнего основания задать разные значения, будет создана коническая спираль.

Если задать высоту витка равной 0, создается плоская двумерная спираль.

ПримечаниеСпираль является сплайновой аппроксимацией реальной спирали. Значения длины могут быть не абсолютно точными. Однако при использовании спирали в качестве траектории развертки получаемые значения точны независимо от аппроксимации.
См. также

    • Изменение спиралей

    • Создание тела или поверхности посредством сдвига


Для создания спирали (Процедура)

Построение сплайнов
На уровень вверх ..
Построение вспомогательных и опорных элементов
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение спиралей >
Построение спиралей
Понятие Процедура Краткий справочник

Для создания спирали

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Спираль". В командной строке введите "спираль".
  2. Укажите координаты центра основания спирали.
  3. Задайте радиус в основании.
  4. Укажите радиус верхнего основания или нажмите ENTER для ввода значения, равного радиусу в основании.
  5. Укажите высоту спирали.
Панель:Моделирование
Ввод команды: СПИРАЛЬ


Построение спиралей (Краткий справочник)

Построение сплайнов
Построение спиралей
Построение опорных точек
Создание и редактирование объектов > Построение геометрических объектов > Построение криволинейных объектов > Построение спиралей >
Построение спиралей
Понятие Процедура Краткий справочник

Команды

СПИРАЛЬ

Создание 2D или 3D спирали

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Построение вспомогательных и опорных элементов

Построение спиралей
Построение геометрических объектов
Построение опорных точек
Создание и редактирование объектов > Построение геометрических объектов >
Построение вспомогательных и опорных элементов
Понятие Процедура

Для выполнения точных построений используются такие временные объекты, как вспомогательные линии и опорные точки.

Темы в этом разделе

  • Построение опорных точек

    Объекты-точки рекомендуется использовать в качестве геометрических опорных узлов для объектной привязки и относительных смещений.

  • Построение бесконечных линий (и лучей)

    Линии, бесконечные в обоих направлениях или только в одном направлении, называются соответственно прямыми и лучами. Бесконечные линии можно использовать в качестве вспомогательных при построении объектов.


Построение вспомогательных и опорных элементов (Процедура)

Построение спиралей
Построение вспомогательных и опорных элементов
Построение опорных точек
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов >
Построение вспомогательных и опорных элементов
Понятие Процедура

Для задания формы и размера точки

Для создания объекта-точки

Для построения прямой по двум точкам

Для построения луча


Построение опорных точек (Понятие)

Построение вспомогательных и опорных элементов
Построение вспомогательных и опорных элементов
Построение бесконечных линий (и лучей)
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов >
Построение опорных точек
Понятие Процедура Краткий справочник

Объекты-точки рекомендуется использовать в качестве геометрических опорных узлов для объектной привязки и относительных смещений.

Форму символа-точки и его размер можно задать относительно размера экрана, либо в абсолютных единицах. При изменении формы символов точек:

  • Достигается желаемый результат отображения точек и возможность их идентификации среди узловых точек сетки
  • Изменяется вид отображаемых объектов-точек чертежа
  • Для вывода чертежа с измененной формой точек следует запустить команду РЕГЕН


Построение опорных точек (Процедура)

Построение вспомогательных и опорных элементов
На уровень вверх ..
Построение опорных точек
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение опорных точек >
Построение опорных точек
Понятие Процедура Краткий справочник

Для задания формы и размера точки

Для создания объекта-точки


Для задания формы и размера точки (Процедура)

Построение опорных точек
На уровень вверх ..
Построение опорных точек
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение опорных точек >
Построение опорных точек
Понятие Процедура Краткий справочник

Для задания формы и размера точки

  1. Выберите меню Формат [image] Отображение точек.В командной строке введите "диалтточ".
  2. В диалоговом окне "Отображение точек" выберите форму точки.
  3. В поле "Размер точки" задайте необходимый размер относительно размера экрана или в абсолютных единицах.
  4. Нажмите "ОК".
Ввод команды: ДИАЛТТОЧ


Для создания объекта-точки (Процедура)

Построение опорных точек
На уровень вверх ..
Построение бесконечных линий (и лучей)
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение опорных точек >
Построение опорных точек
Понятие Процедура Краткий справочник

Для создания объекта-точки

  1. Выберите меню Рисование [image] Точка [image] Одиночная. В командной строке введите "точка".
  2. Укажите положение точки.

    В дальнейшем к этой точке можно будет привязываться в режиме "Узел".

Панель:Рисование
Ввод команды: ТОЧКА


Построение опорных точек (Краткий справочник)

Построение спиралей
Построение опорных точек
Построение бесконечных линий (и лучей)
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение опорных точек >
Построение опорных точек
Понятие Процедура Краткий справочник

Команды

ДИАЛТТОЧ

Задание стиля отображения и величины точечных объектов

ТОЧКА

Создание объектов-точек

Системные переменные

PDMODE

Управление отображением точечных объектов

PDSIZE

Размер отображения точечных объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Построение бесконечных линий (и лучей) (Понятие)

Построение опорных точек
Построение вспомогательных и опорных элементов
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов >
Построение бесконечных линий (и лучей)
Понятие Процедура Краткий справочник

Линии, бесконечные в обоих направлениях или только в одном направлении, называются соответственно прямыми и лучами. Бесконечные линии можно использовать в качестве вспомогательных при построении объектов.

Например, с помощью прямых можно найти центр треугольника, подготовить различные виды одного элемента или создать временные пересечения для объектной привязки.

Наличие бесконечных линий не изменяет границ чертежа. Следовательно, бесконечные линии не влияют на процесс зумирования и на видовые экраны, а также на результаты выполнения команд отображения в границах чертежа. Прямые и лучи можно перемещать, поворачивать и копировать таким же образом, как и любые другие объекты. Бесконечные линии часто строят на отдельном слое, который перед выводом на плоттер можно заморозить или отключить.

Построение прямых

Прямые () можно строить в любом месте трехмерного пространства. Их направление может задаваться различными способами. По умолчанию применяется метод создания отрезка по двум точкам: пользователь должен указать две точки для определения ориентации. Первая (или базовая) точка является серединой прямой и определяется как точка привязки в режиме объектной привязки "Середина".

Прямые линии можно также строить и другими способами:

  • Горизонтали и вертикали. Построение прямых, проходящих через заданную точку и параллельных оси X или Y текущей ПСК.
  • Угол Построение прямой по углу наклона одним из двух методов. Можно либо выбрать базовую линию и задать угол между базовой линией и создаваемой прямой, либо (для построения прямой, лежащей под заданным углом к горизонтальной оси) задать угол и указать точку, через которую должна проходить прямая.
  • Биссектриса Построение прямой, делящей пополам какой-либо угол. Нужно указать вершину угла и его стороны.
  • ДИАЛТТОЧ Создание прямой, параллельной какой-либо линии, выбранной в качестве базовой, методом смещения. Нужно задать величину смещения, выбрать базовую линию, а затем указать, с какой стороны от базовой линии должна проходить прямая.

Лучи

Луч представляет собой линию в трехмерном пространстве, начинающуюся в заданной точке и уходящую в бесконечность. Таким образом, в отличие от прямых, лучи бесконечны только в одном направлении. Использование лучей вместо прямых помогает уменьшить загроможденность чертежа. Как и прямые, лучи игнорируются командами, с помощью которых осуществляется показ чертежа в его границах.


Построение бесконечных линий (и лучей) (Процедура)

Построение опорных точек
На уровень вверх ..
Построение бесконечных линий (и лучей)
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение бесконечных линий (и лучей) >
Построение бесконечных линий (и лучей)
Понятие Процедура Краткий справочник

Для построения прямой по двум точкам

Для построения луча


Для построения прямой по двум точкам (Процедура)

Построение бесконечных линий (и лучей)
На уровень вверх ..
Построение бесконечных линий (и лучей)
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение бесконечных линий (и лучей) >
Построение бесконечных линий (и лучей)
Понятие Процедура Краткий справочник

Для построения прямой по двум точкам

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Прямая". В командной строке введите "прямая".
  2. Укажите базовую точку прямой.
  3. Укажите вторую точку, через которую должна проходить прямая.
  4. Если необходимо, можно сразу построить несколько прямых.

    Все последующие прямые начинаются в первой указанной точке.

  5. Нажмите ENTER для завершения команды.
Панель:Рисование
Ввод команды: ПРЯМАЯ


Для построения луча (Процедура)

Построение бесконечных линий (и лучей)
На уровень вверх ..
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение бесконечных линий (и лучей) >
Построение бесконечных линий (и лучей)
Понятие Процедура Краткий справочник

Для построения луча

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Луч". В командной строке введите "луч".
  2. Выберите точку начала луча.
  3. Укажите вторую точку, через которую должен проходить луч.
  4. Если необходимо, можно сразу построить несколько лучей.

    Все последующие лучи начинаются в первой указанной точке.

  5. Нажмите ENTER для завершения команды.
Ввод команды: ЛУЧ


Построение бесконечных линий (и лучей) (Краткий справочник)

Построение опорных точек
Построение бесконечных линий (и лучей)
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение вспомогательных и опорных элементов > Построение бесконечных линий (и лучей) >
Построение бесконечных линий (и лучей)
Понятие Процедура Краткий справочник

Команды

ЛУЧ

Построение линии, начинающейся в точке и бесконечной в одном направлении

ПРЯМАЯ

Создание бесконечной линии

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Построение и объединение областей (Понятие)

Построение бесконечных линий (и лучей)
Построение геометрических объектов
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов >
Построение и объединение областей
Понятие Процедура Краткий справочник

Области представляют собой двумерные замкнутые области, обладающие такими физическими свойствами, как центры масс. Имеющиеся области можно объединить в одну сложную область с целью вычисления площади.

Области представляют собой двумерные замкнутые области, созданные объектами, образующими замкнутые контуры. Контуры могут состоять из отрезков, полилиний, окружностей, дуг, эллипсов, эллиптических дуг и сплайнов. Объекты контура должны быть представлены либо одним замкнутым объектом, либо замкнутой последовательностью объектов, соединяющихся в конечных точках.

Для областей можно:

  • Выполнять штриховку и закрашивание
  • Рассчитывать свойства, например, площадь с помощью команды МАСС-ХАР
  • Получать информацию, например, о расположении центра масс

Области могут быть созданы из нескольких контуров, а также из нескольких разомкнутых кривых, соединенных между собой и образующих контур. Нельзя формировать области с помощью открытых объектов, которые, пересекаясь, образуют замкнутый контур: например, пересекающиеся дуги или самопересекающиеся кривые.

Создавать области можно также с помощью команды КОНТУР.

Составные области строятся путем вычитания, объединения и пересечения имеющихся областей. После этого к ним можно применять штрихование и подсчитывать общую площадь.

Объединение объектов с помощью команды ОБЪЕДИНЕНИЕ

Объединение объектов с помощью команды ВЫЧИТАНИЕ

Объединение объектов с помощью команды ПЕРЕСЕЧЕНИЕ


Построение и объединение областей (Процедура)

Построение бесконечных линий (и лучей)
Построение и объединение областей
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение и объединение областей >
Построение и объединение областей
Понятие Процедура Краткий справочник

Для определения областей

Для создания областей с использованием контуров

Для построения составной области путем объединения

Для построения составной области путем вычитания

Для построения составной области путем пересечения


Для определения областей (Процедура)

Построение и объединение областей
Построение и объединение областей
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение и объединение областей >
Построение и объединение областей
Понятие Процедура Краткий справочник

Для определения областей

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Область". В командной строке введите "область".
  2. Выбрать объекты для преобразования в область.

    Каждый из этих объектов должен образовывать замкнутый контур, например круг или замкнутую полилинию.

  3. Нажмите ENTER.

    В командной строке выводится сообщение о том, сколько обнаружено контуров и сколько создано областей.

Ввод команды: ОБЛАСТЬ


Для создания областей с использованием контуров (Процедура)

Построение и объединение областей
Построение и объединение областей
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение и объединение областей >
Построение и объединение областей
Понятие Процедура Краткий справочник

Для создания областей с использованием контуров

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Контур". В командной строке введите "контур".
  2. В списке "Тип объекта" диалогового окна "Создание контура" выберите "Область".
  3. Нажмите кнопку "Указание точек".
  4. Укажите точку на чертеже внутри каждого замкнутого контура, из которого необходимо создать область, а затем нажмите ENTER.

    Эта точка интерпретируется как внутренняя.

    ПримечаниеДля ограничения числа объектов, участвующих в определении контура, можно создать новый набор контуров.
Ввод команды: КОНТУР


Для построения составной области путем объединения (Процедура)

Построение и объединение областей
Построение и объединение областей
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение и объединение областей >
Построение и объединение областей
Понятие Процедура Краткий справочник

Для построения составной области путем объединения

  1. Выберите меню "Редактирование" [image] "Редактирование тела" [image] "Объединение".В командной строке введите "объединение".
  2. Выберите первую область для объединения.
  3. Выберите следующую область.

    Выбор объединяемых областей можно выполнять в любой последовательности.

  4. Продолжите выбор областей или нажмите ENTER для завершения команды.

    Выбранные области объединяются в одну составную область.

Ввод команды: ОБЪЕДИНЕНИЕ


Для построения составной области путем вычитания (Процедура)

Построение и объединение областей
Построение и объединение областей
Построение и объединение областей
Создание и редактирование объектов > Построение геометрических объектов > Построение и объединение областей >
Построение и объединение областей
Понятие Процедура Краткий справочник

Для построения составной области путем вычитания

  1. Выберите меню"Редактирование" [image] "Редактирование тела" [image] "Вычитание".В командной строке введите "вычитание".
  2. Выберите одну или несколько областей, из которых будет произведено вычитание и нажмите ENTER.
  3. Выберите вычитаемую область и нажмите ENTER.

    Будет выполнено вычитание площадей регионов.

Ввод команды: ВЫЧИТАНИЕ


Для построения составной области путем пересечения (Процедура)

Построение и объединение областей
Построение и объединение областей
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов > Построение и объединение областей >
Построение и объединение областей
Понятие Процедура Краткий справочник

Для построения составной области путем пересечения

  1. Выберите меню "Редактирование" [image] "Редактирование тела" [image] "Пересечение".В командной строке введите "пересечение".
  2. Выберите первую область для пересечения.
  3. Выберите следующую область для пересечения.

    Порядок выбора исходных областей при построении пересечения не имеет значения.

  4. Продолжите выбор областей или нажмите ENTER для завершения команды.

    Строится новая область, полученная в результате пересечения выбранных областей.

Ввод команды: ПЕРЕСЕЧЕНИЕ


Построение и объединение областей (Краткий справочник)

Построение бесконечных линий (и лучей)
Построение и объединение областей
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов > Построение и объединение областей >
Построение и объединение областей
Понятие Процедура Краткий справочник

Команды

КОНТУР

Создание области или полилинии из замкнутого контура

ПЕРЕСЕЧЕНИЕ

Создание 3D тела или 2D области из выбранных перекрывающихся тел или областей

МАСС-ХАР

Вычисление массовых характеристик областей и тел

ОБЛАСТЬ

Преобразование объектов, ограничивающих некоторую площадь, в области

ВЫЧИТАНИЕ

Создание области путем вычитания выбранных 3D тел или 2D областей

ОБЪЕДИНЕНИЕ

Создание области путем объединения выбранных 3D тел или 2D областей

Системные переменные

DELOBJ

Управление сохранением или удалением геометрических объектов, использованных для создания 3D объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Создание пометочных облаков (Понятие)

Построение и объединение областей
Построение геометрических объектов
Создание и использование блоков (обозначений)
Создание и редактирование объектов > Построение геометрических объектов >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Пометочные облака представляют собой полилинии с дуговыми сегментами. Они используются для нанесения различных пояснительных надписей к элементам чертежа на стадии рассмотрения.

Просмотр чертежей и процесс внесения электронных пометок можно сделать более удобным, если использовать возможность размещения на чертеже облаков, которые позволяют выделять пометки, вносимые в чертеж. С помощью команды ОБЛАКО можно создать полилинию из последовательно соединенных дуг для построения объекта в форме облака. Для пометочных облаков предусмотрено 2 стиля дуг: "Обычный" и "Каллиграфия". Облако со стилем "Каллиграфия" выглядит так, как если бы оно было нарисовано от руки.

Пометочные облака можно создавать с нуля или же строить их путем преобразования таких объектов, как круги, эллипсы, полилинии и сплайны. Если DELOBJ = 1, то в ходе преобразования объекта в облако исходный объект подлежит удалению.

Пользователь может задавать минимальные и максимальные значения длин дуг пометочных облаков. При создании пометочного облака можно изменять размер дуг, выбирая точки дуговых сегментов. При помощи выбранных точек можно изменять нужные длины дуг и хорд, образующих пометочное облако.

Для согласования чертежей с различными масштабными коэффициентами команда ОБЛАКО сохраняет последнее использованное значение длины дуги в виде числа, кратного значению системной переменной DIMSCALE.

Прежде чем вызвать команду ОБЛАКО, убедитесь, что область, которая будет очерчена облаком, целиком находится в зоне видимости. Команда ОБЛАКО не поддерживает прозрачное панорамирование и масштабирование в режиме реального времени.


Создание пометочных облаков (Процедура)

Построение и объединение областей
Создание пометочных облаков
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов > Создание пометочных облаков >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Создание пометочного облака с нуля

Для создания пометочного облака со стилем "Каллиграфия"

Для преобразования объекта в пометочное облако

Для изменения значений длин дуг по умолчанию для использования в облаках

Для изменения отдельных длин дуг или хорд, образующих облако


Создание пометочного облака с нуля (Процедура)

Создание пометочных облаков
Создание пометочных облаков
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов > Создание пометочных облаков >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Создание пометочного облака с нуля

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Пометочное облако". В командной строке введите "облако".
  2. В командной строке введите новые значения минимальной и максимальной длины дуги или укажите начальную точку пометочного облака.

    По умолчанию минимальная и максимальная длины дуги равны 0.5 единицам. Максимальная длина дуги не может превышать минимальную более чем в три раза.

  3. Обведите перекрестьем курсора форму создаваемого облака. Длину дуг можно изменять, перемещая точки дуговых сегментов.
  4. Прервать построение пометочного облака можно в любой момент нажатием ENTER.

    Для замыкания контура облака нужно вернуть курсор в начальную точку.

Панель:Рисование
Ввод команды: ОБЛАКО


Для создания пометочного облака со стилем "Каллиграфия" (Процедура)

Создание пометочных облаков
Создание пометочных облаков
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов > Создание пометочных облаков >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Для создания пометочного облака со стилем "Каллиграфия"

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Пометочное облако". В командной строке введите "облако".
  2. В командной строке введите стиль.
  3. В командной строке введите каллиграфия.
  4. Нажмите ENTER для сохранения параметра "Каллиграфия" и переходите к работе с командой, или нажмите ESC для завершения команды.
Панель:Рисование
Ввод команды: ОБЛАКО


Для преобразования объекта в пометочное облако (Процедура)

Создание пометочных облаков
Создание пометочных облаков
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов > Создание пометочных облаков >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Для преобразования объекта в пометочное облако

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Пометочное облако". В командной строке введите "облако".
  2. В командной строке введите новые значения минимальной и максимальной длины дуги или нажмите ENTER.

    По умолчанию минимальная и максимальная длины дуги равны 0.5 единицам. Максимальная длина дуги не может превышать минимальную более чем в три раза.

  3. Выбрать круг, эллипс, полилинию или сплайн, который требуется преобразовать в пометочное облако.

    Для изменения направления дуг введите в командной строке да и нажмите ENTER.

  4. Нажмите ENTER для преобразования выбранного объекта в облако.
Панель:Рисование
Ввод команды: ОБЛАКО


Для изменения значений длин дуг по умолчанию для использования в облаках (Процедура)

Создание пометочных облаков
Создание пометочных облаков
Создание пометочных облаков
Создание и редактирование объектов > Построение геометрических объектов > Создание пометочных облаков >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Для изменения значений длин дуг по умолчанию для использования в облаках

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Пометочное облако". В командной строке введите "облако".
  2. В командной строке введите новое минимальное значение длины дуги и нажмите ENTER.
  3. В командной строке введите новое максимальное значение длины дуги и нажмите ENTER.

    Максимальная длина дуги не может превышать минимальную более чем в три раза.

  4. Нажмите ENTER для продолжения работы с командой, или нажмите ESC для завершения команды.
Панель:Рисование
Ввод команды: ОБЛАКО


Для изменения отдельных длин дуг или хорд, образующих облако (Процедура)

Создание пометочных облаков
Создание пометочных облаков
Создание и сохранение блоков
Создание и редактирование объектов > Построение геометрических объектов > Создание пометочных облаков >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Для изменения отдельных длин дуг или хорд, образующих облако

  1. Выберите пометочное облако, размер которого требуется изменить.
  2. Изменение длины дуг и хорд, составляющих пометочные облака, выполняется перемещением выделенных точек.


Создание пометочных облаков (Краткий справочник)

Построение и объединение областей
Создание пометочных облаков
Базовые понятия для блоков
Создание и редактирование объектов > Построение геометрических объектов > Создание пометочных облаков >
Создание пометочных облаков
Понятие Процедура Краткий справочник

Команды

ОБЛАКО

Построение облака с помощью полилинии

Системные переменные

DIMSCALE

Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения

DELOBJ

Управление сохранением или удалением геометрических объектов, использованных для создания 3D объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Создание и использование блоков (обозначений)

Создание пометочных облаков
Создание и редактирование объектов
Базовые понятия для блоков
Создание и редактирование объектов >
Создание и использование блоков (обозначений)

Блоком называется совокупность связанных объектов чертежа, обрабатываемых как единый объект. Объединение объектов в блоки облегчает повторное использование их как внутри одного чертежа, так и в других чертежах.

Темы в этом разделе

  • Базовые понятия для блоков

    Блоки могут состоять из объектов, изначально находившихся на различных слоях и имевших различные свойства. Существует несколько способов создания блоков.

  • Создание и сохранение блоков

    Создание блока предполагает объединение объектов в группу под определенным именем. С блоком также можно связать дополнительные информационные записи (атрибуты).

  • Добавление функций динамического изменения в блоки

    При добавлении функций динамического изменения в определения блока добавляется гибкость и интеллектуальные возможности для геометрии. Блок уже не является фиксированной частью чертежа. Вхождение динамического блока можно изменять или манипулировать по мере работы с чертежом.

  • Вставка блоков

    При вставке блока создается вхождение блока. Пользователь указывает точку вставки, масштабные коэффициенты и угол поворота.

  • Работа с динамическими блоками в чертежах

    Динамический блок обладает гибкостью и интеллектуальными возможностями. Вхождение динамического блока можно легко изменить на чертеже во время работы. Для изменения геометрии можно использовать настраиваемые ручки или настраиваемые свойства. Это позволяет изменять вхождение блока на месте, вместо того чтобы искать другой блок для вставки или уточнять описание существующего блока.

  • Атрибуты блоков

    Пользователь может связывать с блоками различные текстовые данные и в дальнейшем извлекать их для составления спецификаций, отчетов и т.д..

  • Редактирование блоков

    Имеется возможность редактирования определений блоков и вхождений блоков уже после их вставки в чертеж.


Базовые понятия для блоков (Понятие)

Создание и использование блоков (обозначений)
Создание и использование блоков (обозначений)
Создание и сохранение блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) >
Базовые понятия для блоков
Понятие Краткий справочник

Блоки могут состоять из объектов, изначально находившихся на различных слоях и имевших различные свойства. Существует несколько способов создания блоков.

Существует несколько способов создания блоков:

  • Объединение объектов для создания определения блока в текущем чертеже.
  • Назначение определению блока в текущем чертеже функций динамического изменения с помощью контекстной вкладки ленты "Редактор блоков" (когда лента активна) или Редактор блоков (когда лента не активна).
  • Создание файла чертежа с последующей его вставкой в качестве блока в другой чертеж.
  • Создание файла чертежа с несколькими описаниями логически родственных блоков для использования в качестве библиотеки компонентов.

Блоки могут состоять из объектов, изначально находившихся на различных слоях и имевших различные цвета, типы линий и веса линий. Хотя вставляемый блок всегда размещается на текущем слое, для каждого объекта, входящего в блок сохраняется информация об исходных слоях, цветах и типах линий. Пользователь может сохранять исходные свойства объектов блока или использовать настройки текущего слоя и текущие значения цвета, типа и веса линий.

Определение блока может также содержать элементы, благодаря которым блок приобретает функции динамического изменения. Добавлять эти элементы в блок можно либо на контекстной вкладке "Редактор блоков" ленты, либо в редакторе блоков. При добавлении функций динамического изменения в блок добавляется гибкость и интеллектуальные возможности для геометрии. После вставки в чертеж вхождения блока с функциями динамического изменения можно манипулировать геометрией вхождения блока с помощью настраиваемых ручек или настраиваемых свойств в зависимости от того, как был определен блок.

Неиспользуемые в чертеже описания блоков можно удалить командой ОЧИСТИТЬ.

Кроме того, пользователь может создавать блоки, имеющие свойство аннотативный . Дополнительные сведения о создании аннотативных блоков и работе с ними см. в разделе Создание аннотативных блоков и атрибутов.

См. также

    • Масштабирование аннотаций


Базовые понятия для блоков (Краткий справочник)

Создание пометочных облаков
Базовые понятия для блоков
Хранение и использование блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Базовые понятия для блоков >
Базовые понятия для блоков
Понятие Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

ПБЛОК

Запись объектов или блока в новый файл чертежа

Системные переменные

MAXSORT

Максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков

Утилиты

Нет

Ключевые слова для команд

Нет


Создание и сохранение блоков

Базовые понятия для блоков
Создание и использование блоков (обозначений)
Хранение и использование блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) >
Создание и сохранение блоков
Понятие Процедура

Создание блока предполагает объединение объектов в группу под определенным именем. С блоком также можно связать дополнительные информационные записи (атрибуты).

Темы в этом разделе

  • Хранение и использование блоков

    В каждом файле чертежа имеется область данных, называемая таблицей определений блоков. В ней содержатся все описания блоков. Именно отсюда извлекается информация для формирования вхождений блоков в чертеж.

  • Создание блоков в чертеже

    После того как создано определение блока, его вхождение можно многократно размещать на чертеже. Этот метод можно использовать для быстрого создания множества идентичных графических структур.

  • Сохранение блока в отдельном файле

    Имеется возможность создания файлов чертежей для использования их в качестве блоков.

  • Цвета и типы линий объектов в блоках

    Объекты вставляемого блока могут сохранять свои исходные свойства, либо перенять свойства текущего слоя, на который они вставляются, или текущие значения свойств, установленные в чертеже.

  • Вложение блоков

    Блоки, которые содержатся внутри других вставленных в чертеж блоков, называются вложенными. Использование вложенных блоков позволяет упрощать описания сложных блоков.

  • Создание библиотек компонентов

    Библиотека компонентов представляет собой файл чертежа, в котором хранится набор определений блоков. Пользователь может использовать библиотеки компонентов, поставляемые Autodesk и другими разработчиками, а также создавать свои собственные библиотеки.

  • Использование палитр инструментов для организации блоков

    С помощью инструментальной палитры можно упорядочивать блоки, хранящиеся в одном файле или в отдельных файлах чертежей.

  • Удаление определений блоков

    Для сокращения размера чертежа неиспользуемые описания блоков можно удалить. Ссылку на блок можно удалить из чертежа путем ее стирания; однако при этом определение блока остается в таблице определений блоков чертежа.


Создание и сохранение блоков (Процедура)

Создание пометочных облаков
Создание и сохранение блоков
Создание блоков в чертеже
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Создание и сохранение блоков
Понятие Процедура

Для создания определения блока в текущем чертеже

Для сохранения выбранных объектов в новом файле

Для редактирования определения к блоку

Для задания цвета создаваемых объектов

Для задания типа линий вновь создаваемых объектов

Для создания библиотеки компонентов

Для удаления определения блока


Хранение и использование блоков (Понятие)

Создание и сохранение блоков
Создание и сохранение блоков
Создание блоков в чертеже
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Хранение и использование блоков
Понятие Краткий справочник

В каждом файле чертежа имеется область данных, называемая таблицей определений блоков. В ней содержатся все описания блоков. Именно отсюда извлекается информация для формирования вхождений блоков в чертеж.

На следующих иллюстрациях схематично показаны структуры трех файлов чертежей. Каждый прямоугольник, разделенный на две части, представляет файл чертежа. Малая часть прямоугольника обозначает таблицу определений блоков, большая часть - объекты чертежа.

При вставке блока в чертеже появляется так называемое вхождение блока. Данные не просто копируются из определения блока в область рисования, устанавливается связь между описанием и вхождением блока. Таким образом, при изменении определения блока все соответствующие вхождения автоматически обновляются.

Для сокращения размера чертежа неиспользуемые описания блоков можно удалить.


Хранение и использование блоков (Краткий справочник)

Базовые понятия для блоков
Хранение и использование блоков
Создание блоков в чертеже
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Хранение и использование блоков >
Хранение и использование блоков
Понятие Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание блоков в чертеже (Понятие)

Хранение и использование блоков
Создание и сохранение блоков
Сохранение блока в отдельном файле
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Создание блоков в чертеже
Понятие Процедура Краткий справочник

После того как создано определение блока, его вхождение можно многократно размещать на чертеже. Этот метод можно использовать для быстрого создания множества идентичных графических структур.

Каждое определение блока включает в себя имя блока, один или несколько объектов, координаты базовой точки, используемой для вставки блока, а также атрибуты, хранящие произвольную дополнительную информацию.

Базовая точка определяет положение вхождения блока на чертеже при его вставке. Как правило, базовая точка указывается в нижнем левом углу объекта, входящего в блок. При вставке блока выдается запрос указания точки вставки. Вхождение блока размещается таким образом, чтобы базовая точка совпадала с указанной в ответ на запрос.

Определение блока, приведенное на рисунке, содержит имя PLUG_VALVE, четыре отрезка и базовую точку на месте пересечения двух диагональных отрезков. Описание изображенной на чертеже схемы приводится в разделе Базовые понятия для блоков.

На следующем чертеже показана типичная последовательность действий при создании определения блока внутри чертежа.

Для создания блоков, сохраняемых в чертеже, можно пользоваться либо контекстной вкладкой "Редактор блоков" ленты, либо редактором блоков. Для получения более подробных сведений об использовании редактора блоков см. раздел Использование редактора блоков .


Для создания определения блока в текущем чертеже (Процедура)

Создание и сохранение блоков
На уровень вверх ..
Сохранение блока в отдельном файле
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Создание блоков в чертеже >
Создание блоков в чертеже
Понятие Процедура Краткий справочник

Для создания определения блока в текущем чертеже

  1. Создать объекты, предназначенные для формирования блока.
  2. Выберите вкладку "Главная" [image] панель "Блок" [image] "Создать". В командной строке введите "блок".
  3. В диалоговом окне "Определение блока" введите имя блока в поле "Имя".
  4. В группе "Объекты" отметить опцию "Сделать блоком".

    Если необходимо, чтобы выбранные объекты после создания определения блока не удалялись, следует убедиться, что отключена опция "Удалить". В противном случае, выбранные объекты будут удалены из чертежа. При необходимости можно восстанавливать объекты с помощью команды ОЙ.

  5. Нажмите кнопку "Выбор объектов".
  6. Выберите с помощью устройства указания объекты для создания определения блока. Для завершения выбора объектов нажмите ENTER.
  7. В группе "Базовая точка" диалогового окна "Определение блока" задать координаты базовой точки вставки одним из способов:
    • Нажать кнопку "Указать" для выбора базовой точки с помощью устройства указания.
    • Ввести координаты X,Y,Z точки.
  8. В поле "Описание" ввести описание определения блока. Данное описание отображается в окне Центра управления (ЦУВКЛ).
  9. Нажать "ОК".

    Определение блока сохраняется в текущем чертеже и может быть вставлено, как только это потребуется.

Панель:Рисование
Ввод команды: БЛОК


Создание блоков в чертеже (Краткий справочник)

Хранение и использование блоков
Создание блоков в чертеже
Сохранение блока в отдельном файле
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Создание блоков в чертеже >
Создание блоков в чертеже
Понятие Процедура Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Сохранение блока в отдельном файле (Понятие)

Создание блоков в чертеже
Создание и сохранение блоков
Цвета и типы линий объектов в блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Сохранение блока в отдельном файле
Понятие Процедура Краткий справочник

Имеется возможность создания файлов чертежей для использования их в качестве блоков.

Пользователь может создавать файлы чертежей для вставки их в другие чертежи в качестве блоков. Создавать отдельные файлы чертежей как источники определений блоков и манипулировать ими достаточно легко. Библиотеки компонентов можно также сохранить в виде отдельных файлов чертежей и сгруппировать их по папкам.

Создание нового файла чертежа

Новый файл чертежа можно создать двумя способами:

  • Создать и сохранить готовый чертеж в файле с помощью команд СОХРАНИТЬ или СОХРАНИТЬКАК.
  • Создать и сохранить только выбранные объекты из текущего чертежа в новый файл с помощью команд ЭКСПОРТ или ПБЛОК.

При любом способе создается обычный файл чертежа, который можно вставлять в качестве блока в любой другой чертеж. Если требуется создание нескольких версий символа в виде отдельных файлов чертежей либо требуется создание файла чертежа без выхода из текущего чертежа, рекомендуется использовать команду ПБЛОК.

Изменение базовой точки чертежа, используемого как блок

По умолчанию AutoCAD определяет базовую точку чертежа, используемого как блок, в начале координат (0,0,0) МСК (Мировой системы координат). Точку вставки можно изменить, открыв исходный чертеж и задав с помощью команды БАЗА другую базовую точку вставки. При очередной вставке блока используется уже новая базовая точка.

Обновление чертежа

Изменение исходного чертежа блока не оказывает действия на текущий чертеж. Если необходимо, чтобы все изменения были видны на текущем чертеже, то вместо вставки блока следует выполнить вставку исходного чертежа в качестве внешней ссылки. Дополнительные сведения о внешних ссылках см. в разделе Внешние ссылки .

Использование объектов пространства листа в блоках

При вставке чертежа в качестве блока все объекты пространства листа, содержащиеся в нем, игнорируются. Чтобы иметь возможность вставлять в другие чертежи в виде блоков объекты листа, следует преобразовать эти объекты в отдельный блок или сохранить их в отдельном файле чертежа.


Сохранение блока в отдельном файле (Процедура)

Создание блоков в чертеже
На уровень вверх ..
Сохранение блока в отдельном файле
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Сохранение блока в отдельном файле >
Сохранение блока в отдельном файле
Понятие Процедура Краткий справочник

Для сохранения выбранных объектов в новом файле

Для редактирования определения к блоку


Для сохранения выбранных объектов в новом файле (Процедура)

Сохранение блока в отдельном файле
На уровень вверх ..
Сохранение блока в отдельном файле
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Сохранение блока в отдельном файле >
Сохранение блока в отдельном файле
Понятие Процедура Краткий справочник

Для сохранения выбранных объектов в новом файле

  1. Открыть имеющийся чертеж или создать новый.
  2. В командной строке ввести пблок.
  3. В диалоговом окне "Запись блока на диск" установить переключатель "Источник данных" в положение "Объекты".

    Если необходимо, чтобы выбранные объекты после создания нового чертежа не удалялись, отключить опцию "Удалить из чертежа". В противном случае, выбранные объекты будут удалены из чертежа. При необходимости можно восстанавливать объекты с помощью команды ОЙ.

  4. Нажать кнопку "Выбор объектов".
  5. Выбрать с помощью устройства указания объекты для создания нового чертежа. Для завершения выбора объектов нажмите ENTER.
  6. В группе "Базовая точка" задать базовую точку вставки создаваемого чертежа одним из способов:
    • Нажать кнопку "Указать" для выбора базовой точки с помощью устройства указания.
    • Ввести координаты X,Y,Z точки.
  7. В группе "Размещение" ввести имя и путь для нового файла чертежа.
  8. Нажать "ОК".

    Выбранные объекты сохраняются в новом файле чертежа.

Ввод команды: ПБЛОК


Для редактирования определения к блоку (Процедура)

Сохранение блока в отдельном файле
На уровень вверх ..
Цвета и типы линий объектов в блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Сохранение блока в отдельном файле >
Сохранение блока в отдельном файле
Понятие Процедура Краткий справочник

Для редактирования определения к блоку

  1. Выберите меню Редактирование [image] Объект [image] Определение блока.В командной строке введите "блок".
  2. В диалоговом окне "Определение блока" выбрать нужный блок.
  3. Ввести новое имя.
  4. В поле "Описание" ввести новое или изменить имеющееся текстовое описание для блока.
  5. Нажать "ОК".
Ввод команды: БЛОК


Сохранение блока в отдельном файле (Краткий справочник)

Создание блоков в чертеже
Сохранение блока в отдельном файле
Цвета и типы линий объектов в блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Сохранение блока в отдельном файле >
Сохранение блока в отдельном файле
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

БАЗА

Задание базовой точки вставки для текущего чертежа

БЛОК

Создание определения блока из выбранных объектов

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

ОЙ

Восстановление стертых объектов

ПБЛОК

Запись объектов или блока в новый файл чертежа

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Цвета и типы линий объектов в блоках (Понятие)

Сохранение блока в отдельном файле
Создание и сохранение блоков
Вложение блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Цвета и типы линий объектов в блоках
Понятие Процедура Краткий справочник

Объекты вставляемого блока могут сохранять свои исходные свойства, либо перенять свойства текущего слоя, на который они вставляются, или текущие значения свойств, установленные в чертеже.

Как правило, цвет, тип и вес линий объектов блока сохраняют свои исходные значения, независимо от текущих свойств, заданных в чертеже. Однако имеется возможность присвоения текущих свойств чертежа объектам создаваемого блока. В этом случае происходит наследование значений свойств.

Пользователь может выбрать один из трех режимов поведения свойств объектов (цвета, типа линий и веса линий) при вставке блока.

  • Объекты блока сохраняют свои исходные свойства. Свойства объектов блока не меняются, независимо от заданных текущих значений свойств.

    В этом случае рекомендуется отдельно устанавливать свойства цвета, типа линии и веса линии для каждого объекта в описании блоков: при создании этих объектов нельзя использовать настройки цвета, типа линии и веса линии ПО БЛОКУ или ПОСЛОЮ .

  • Объекты блока наследуют цвет, тип линий и вес линий, установленные для текущего слоя.

    В данном случае перед созданием объектов, включаемых в определение блока, следует перейти на слой 0 и установить текущее значение ПОСЛОЮ для текущего цвета, типа линий и веса линий.

  • Объекты блока наследуют текущие значения цвета, типа линий и веса линий. Если текущие свойства в чертеже не заданы явным образом, то наследуются свойства текущего слоя.

    В данном случае перед созданием объектов, включаемых в определение блока, следует установить текущее значение ПОБЛОКУ для цвета или типа линия.

Если требуется, чтобы с помощью объектов в блоке | создавались объекты на этих слоях | создавались объекты с этими свойствами
сохраняли исходные свойства | на любых, но не 0 | с любыми, но не ПОБЛОКУ и ПОСЛОЮ
наследовали свойства текущего слоя | 0 | ПОСЛОЮ
наследовали в первую очередь текущие свойства, переопределяющие свойства слоя | на любых | ПОБЛОКУ

Наследуемые свойства могут также использоваться и во вложенных блоках.


Цвета и типы линий объектов в блоках (Процедура)

Сохранение блока в отдельном файле
На уровень вверх ..
Цвета и типы линий объектов в блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Цвета и типы линий объектов в блоках >
Цвета и типы линий объектов в блоках
Понятие Процедура Краткий справочник

Для задания цвета создаваемых объектов

Для задания типа линий вновь создаваемых объектов


Для задания цвета создаваемых объектов (Процедура)

Цвета и типы линий объектов в блоках
На уровень вверх ..
Цвета и типы линий объектов в блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Цвета и типы линий объектов в блоках >
Цвета и типы линий объектов в блоках
Понятие Процедура Краткий справочник

Для задания цвета создаваемых объектов

  1. На панели "Свойства" щелкнуть на управляющем списке "Цвета".
  2. Щелкнуть на нужном цвете для его использования при создании новых объектов или щелкнуть на пункте "Выбор цвета" для вызова одноименного диалогового окна, где выполнить одно из действий:
    • На вкладке "Номер цвета" выбрать цвет или ввести номер по ИЦА (1-255) либо имя в поле "Цвет". Нажать "ОК".
    • На вкладке "Вся палитра" выбрать цветовую модель "HSL" и задать значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Затем нажать "OK".
    • На вкладке "Альбомы цветов" выбрать необходимый альбом, выбрать требуемый цвет. Нажать "ОК".
    • Выберите ПОСЛОЮ для создания новых объектов чертежа в цвете, назначенном текущему слою.
    • Выберите ПОБЛОКУ для создания новых объектов чертежа в текущем цвете в течение всего времени, пока они объединены в блок. При вставке блока объектам присваивается текущий цвет, заданный в чертеже.
  3. Нажать "ОК".

    Установленный текущий цвет отображается в управляющем списке "Цвета".

Ввод команды: ЦВЕТ


Для задания типа линий вновь создаваемых объектов (Процедура)

Цвета и типы линий объектов в блоках
На уровень вверх ..
Создание библиотек компонентов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Цвета и типы линий объектов в блоках >
Цвета и типы линий объектов в блоках
Понятие Процедура Краткий справочник

Для задания типа линий вновь создаваемых объектов

  1. В меню Формат выберите [image] Тип линий.В командной строке ввести "типлин".
  2. При необходимости загрузки дополнительных типов линий нажать "Загрузить", выбрать один или несколько типов линий и нажать "OK".

    Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - клавиша SHIFT.

  3. В окне Диспетчера типов линий выполнить одно из следующих действий:
    • Выделить тип линий и нажать кнопку "Текущий" для назначения выбранного типа линий всем вновь создаваемым объектам.
    • Выберите значение ПОСЛОЮ для построения новых объектов с текущим типом линий слоя.
    • Выберите значение ПОБЛОКУ для построения новых объектов с типом линий текущего слоя, пока они не объединены в блок. При вставке блока в чертеж объектам в блоке присваивается текущая настройка типа линии.
  4. Нажать "ОК".

    Установленный текущий тип линий отображается в управляющем списке "Типы линий". Для установки текущим уже загруженного типа линий нужно раскрыть управляющий список "Типы линий" и выберите нужный тип линий.

Ввод команды: ТИПЛИН


Цвета и типы линий объектов в блоках (Краткий справочник)

Сохранение блока в отдельном файле
Цвета и типы линий объектов в блоках
Вложение блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Цвета и типы линий объектов в блоках >
Цвета и типы линий объектов в блоках
Понятие Процедура Краткий справочник

Команды

ЦВЕТ

Задание цвета для вновь создаваемых объектов

СЛОЙ

Управление слоями и их свойствами

ТИПЛИН

Загрузка, установка и изменение типов линий

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Вложение блоков (Понятие)

Цвета и типы линий объектов в блоках
Создание и сохранение блоков
Создание библиотек компонентов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Вложение блоков
Понятие Краткий справочник

Блоки, которые содержатся внутри других вставленных в чертеж блоков, называются вложенными. Использование вложенных блоков позволяет упрощать описания сложных блоков.

С помощью вложенных блоков можно построить один блок из нескольких компонентов. Например, можно вставить в чертеж изображение механического узла, в который входят кожух, кронштейн и крепежные элементы; где каждый крепежный элемент состоит из болта, шайбы и гайки. Единственное ограничение при использовании вложенных блоков - запрет ссылок из блока на сам этот блок.


Вложение блоков (Краткий справочник)

Цвета и типы линий объектов в блоках
Вложение блоков
Создание библиотек компонентов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Вложение блоков >
Вложение блоков
Понятие Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание библиотек компонентов (Понятие)

Вложение блоков
Создание и сохранение блоков
Использование палитр инструментов для организации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Создание библиотек компонентов
Понятие Процедура Краткий справочник

Библиотека компонентов представляет собой файл чертежа, в котором хранится набор определений блоков. Пользователь может использовать библиотеки компонентов, поставляемые Autodesk и другими разработчиками, а также создавать свои собственные библиотеки.

Набор родственных определений блоков можно объединить и сохранить в виде одного файла чертежа. Файлы чертежей, созданные таким образом, называются библиотеками компонентов. Во время работы с чертежом пользователь может вставлять из библиотеки компонентов отдельные описания блоков. Файлы библиотек компонентов, кроме своего функционального предназначения, ничем не отличаются по структуре от других файлов чертежей.

При создании каждого определения блока в библиотеке компонентов с помощью команды БЛОК можно задать короткое определение блока, которое выводится в Центре управления.

При необходимости, в графическую область чертежа библиотеки компонентов можно вставить тексты, поясняющие каждый блок. Здесь, например, указывается имя блока, дата создания, дата внесения последних изменений и т.п. Это позволяет наглядно представлять себе содержание библиотеки.

Для просмотра и копирования отдельных определений блоков из библиотеки компонентов и других имеющихся файлов чертежей в текущий чертеж можно использовать Центр управления. При копировании одноименного определения блока уже имеющийся в чертеже блок не удаляется.


Для создания библиотеки компонентов (Процедура)

Цвета и типы линий объектов в блоках
На уровень вверх ..
Удаление определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Создание библиотек компонентов >
Создание библиотек компонентов
Понятие Процедура Краткий справочник

Для создания библиотеки компонентов

  1. Создать новый чертеж.
  2. Создать определение блока.
  3. При необходимости, повторить пункт 2 для создания нескольких блоков.
  4. Сохранить чертеж с нужным именем.

    Эти блоки можно вставлять в любой чертеж с помощью Центра управления (команда ЦУВКЛ).

Панель:Рисование
Ввод команды: БЛОК


Создание библиотек компонентов (Краткий справочник)

Вложение блоков
Создание библиотек компонентов
Использование палитр инструментов для организации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Создание библиотек компонентов >
Создание библиотек компонентов
Понятие Процедура Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование палитр инструментов для организации блоков (Понятие)

Создание библиотек компонентов
Создание и сохранение блоков
Удаление определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Использование палитр инструментов для организации блоков
Понятие Краткий справочник

С помощью инструментальной палитры можно упорядочивать блоки, хранящиеся в одном файле или в отдельных файлах чертежей.

После добавления инструмента блока в инструментальную палитру можно легко вставить вхождение блока в чертеж, перетащив его из инструментальной палитры в чертеж или щелкнув и разместив его на чертеже. Для получения сведений об использовании инструментальных палитр для организации и вставки блоков см. раздел Создание инструментов из объектов и работа с ними.


Использование палитр инструментов для организации блоков (Краткий справочник)

Создание библиотек компонентов
Использование палитр инструментов для организации блоков
Удаление определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Использование палитр инструментов для организации блоков >
Использование палитр инструментов для организации блоков
Понятие Краткий справочник

Команды

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Удаление определений блоков (Понятие)

Использование палитр инструментов для организации блоков
Создание и сохранение блоков
Добавление функций динамического изменения в блоки
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков >
Удаление определений блоков
Понятие Процедура Краткий справочник

Для сокращения размера чертежа неиспользуемые описания блоков можно удалить. Ссылку на блок можно удалить из чертежа путем ее стирания; однако при этом определение блока остается в таблице определений блоков чертежа.

Пользователь может удалять из чертежа вхождения блоков, однако при этом определение блока сохраняется в таблице определений блоков чертежа.

Перед удалением определения блока необходимо предварительно удалить все связанные с ним вхождения блоков.

См. также

    • Базовые понятия для блоков


Для удаления определения блока (Процедура)

Создание библиотек компонентов
На уровень вверх ..
Добавление функций динамического изменения в блоки
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Удаление определений блоков >
Удаление определений блоков
Понятие Процедура Краткий справочник

Для удаления определения блока

  1. Выберите вкладку "Инструменты" [image] панель "Утилиты" [image] "Очистить". В командной строке введите "очистить".

    Появляется диалоговое окно "Очистка чертежа", отображающее дерево именованных объектов, которые можно удалить.

  2. Для удаления неиспользуемых блоков следует воспользоваться одним из следующих способов:
    • Для очистки чертежа от описаний всех неиспользуемых блоков выбрать "Блоки". Для включения вложенных блоков в список отметить опцию "Удаление вложенных элементов".
    • Для удаления описаний только некоторых неиспользуемых блоков дважды щелкнуть на элементе "Блоки" для раскрытия списка блоков. Выбрать блоки для удаления.

    Если нужные элементы отсутствуют в списке, включить опцию "Просмотреть элементы, которые нельзя удалить".

  3. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  4. Нажать "Удалить".

    В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.

  5. Выбрать другие элементы для удаления или нажать "Закрыть".
Ввод команды: ОЧИСТИТЬ


Удаление определений блоков (Краткий справочник)

Использование палитр инструментов для организации блоков
Удаление определений блоков
Быстрое начало работы по созданию динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Создание и сохранение блоков > Удаление определений блоков >
Удаление определений блоков
Понятие Процедура Краткий справочник

Команды

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление функций динамического изменения в блоки

Удаление определений блоков
Создание и использование блоков (обозначений)
Быстрое начало работы по созданию динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) >
Добавление функций динамического изменения в блоки
Понятие Процедура

При добавлении функций динамического изменения в определения блока добавляется гибкость и интеллектуальные возможности для геометрии. Блок уже не является фиксированной частью чертежа. Вхождение динамического блока можно изменять или манипулировать по мере работы с чертежом.

Темы в этом разделе

  • Быстрое начало работы по созданию динамических блоков
  • Обзор динамических блоков
  • Использование редактора блоков

    С помощью редактора блоков можно добавлять в блоки функции динамического изменения. Редактор блоков содержит все необходимые инструменты для добавления в блоки интеллектуальных возможностей и достижения большей гибкости в работе.

  • Добавление в блоки динамических элементов

    Чтобы создать динамический блок, необходимо добавить в определение блока определенные элементы.

  • Сохранение блока в редакторе блоков

    По завершении добавления элементов в описание динамических блоков в редакторе блоков сохраните описание блоков.


Добавление функций динамического изменения в блоки (Процедура)

Удаление определений блоков
Добавление функций динамического изменения в блоки
Использование редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки >
Добавление функций динамического изменения в блоки
Понятие Процедура

Сохранение описания блоков в редакторе блоков

Сохранение копии текущего описания блоков в редакторе блоков под другим именем


Быстрое начало работы по созданию динамических блоков (Понятие)

Добавление функций динамического изменения в блоки
Добавление функций динамического изменения в блоки
Обзор динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки >
Быстрое начало работы по созданию динамических блоков
Понятие Краткий справочник

Назначение новому или существующему определению блока функций динамического изменения заключается в добавлении в блок параметров и операций. Это делается на контекстной вкладке "Редактор блоков" ленты или в редакторе блоков. В следующем примере показан блок рабочего стола в редакторе блоков. Блок содержит линейный параметр, который отображается как размер и имеет метку “Расстояние”, и операцию растягивания, которая отображает вспышку молнии и метку “Растянуть”.

Чтобы сделать блок динамическим, необходимо добавить хотя бы один параметр. Затем добавляется операция, после чего она связывается с параметром. Типы добавляемых в описание блоков параметров и операций определяют, как будет работать вхождение блока в чертеже. Чтобы просмотреть, как параметры и операции добавляются в блок, см. Семинар по новым возможностям. Выберите меню Справка [image] Семинар по новым возможностям [image] Создать [image] Динамические блоки.

Дополнительные сведения о создании динамических блоков см.:

  • Обзор динамических блоков
  • Обзор элементов динамических блоков


Быстрое начало работы по созданию динамических блоков (Краткий справочник)

Удаление определений блоков
Быстрое начало работы по созданию динамических блоков
Обзор динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Быстрое начало работы по созданию динамических блоков >
Быстрое начало работы по созданию динамических блоков
Понятие Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОК

Создание определения блока из выбранных объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Обзор динамических блоков (Понятие)

Быстрое начало работы по созданию динамических блоков
Добавление функций динамического изменения в блоки
Использование редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки >
Обзор динамических блоков
Понятие Краткий справочник

Динамический блок обладает гибкостью и интеллектуальными возможностями. Вхождение динамического блока можно легко изменить на чертеже во время работы. Для изменения геометрии во вхождении динамического блока можно использовать настраиваемые ручки или настраиваемые свойства. Это позволяет изменять блок на месте, вместо того чтобы искать другой блок для вставки или уточнять описание существующего блока.

Например в случае вставки в чертеж вхождения блока может потребоваться изменить размер двери во время редактирования чертежа. Если блок является динамическим и в описании указано, что он имеет настраиваемый размер, то чтобы изменить размер двери, достаточно перетащить ручку настройки или указать другой размер в палитре "Свойства". Возможно, также потребуется изменить угол открытия двери. Дверной блок также может содержать ручку выравнивания, которая позволяет быстро выравнивать вхождение дверного блока с другой геометрией на чертеже.

Для создания динамических блоков можно пользоваться либо контекстной вкладкой "Редактор блоков" ленты, либо редактором блоков. Редактор блоков - это специальная область, в которой добавляются элементы, образующие динамический блок. Блоки можно создавать с самого начала или добавлять функции динамического изменения в описание существующего блока. Можно также создавать геометрию точно так же, как и в области рисования.

Затем в блок добавляются параметры и операции, чтобы сделать его динамическим. При добавлении этих элементов в блок добавляется гибкость и интеллектуальные возможности для его геометрии.

  • Параметры определяют настраиваемые свойства для динамического блока путем указания положений, расстояний и углов для геометрии в блоке.
  • Операции определяют, как будет двигаться или изменяться геометрия вхождения динамического блока при манипулировании в чертеже. При добавлении в блок операций их необходимо связать с параметрами и, как правило, с геометрией.

При добавлении параметра в определение блока в блок автоматически добавляются ручки и свойства настройки. Они используются для манипулирования вхождением блока в чертеже.

Процесс создания динамических блоков

Чтобы создать динамические блоки необходимым результатом, рекомендуется точно выполнить следующие действия. Этот процесс позволяет эффективно создавать динамические блоки.

Шаг 1. Содержимое динамических блоков необходимо спланировать перед созданием

Прежде чем создавать динамический блок, следует представить, как он должен выглядеть и как он будет использоваться на чертеже. Определите, какие объекты внутри блока будут изменяться или перемещаться при манипулировании вхождением динамического блока. Более того, следует определить, как эти объекты будут изменяться. Например, можно создать динамический блок с изменяемыми размерами. Кроме того, при изменении размера вхождения блока может отображаться дополнительная геометрия. Эти факторы определяют тип параметров и операций, добавляемых в определение блока, а также совместную работу параметров, операций и геометрии.

Шаг 2. Нарисуйте геометрию

Рисовать геометрию для динамического блока можно в области рисования, на контекстной вкладке "Редактор блоков" ленты или в редакторе блоков. Можно также воспользоваться существующей геометрией на чертеже или описанием существующего блока.

Примечание Если для изменения свойств отображения геометрии во вхождениях динамических блоков используются состояния видимости, то на этом этапе можно не включать всю геометрию. Дополнительные сведения о работе с состояниями видимости см. в разделе Создание "Состояния видимости" .

Шаг 3. Определите, как элементы блока будут взаимодействовать друг с другом

Прежде чем добавлять параметры и операции в определение блока, необходимо выяснить их взаимосвязи друг с другом, а также с геометрией внутри блока. При добавлении операции в определение блока необходимо связать операцию с параметром и набором объектов геометрии. При этом создается зависимость. При добавлении во вхождение динамического блока нескольких параметров для правильной работы вхождения блока в чертеже необходимо настроить правильные зависимости.

Например, можно создать динамический блок, содержащий несколько объектов. С некоторыми объектами связано действие растягивания. Требуется, чтобы все объекты вращались вокруг одной и той же базовой точки. В этом случае после добавления всех других параметров и операций необходимо добавить операцию поворота. Если операция поворота связана не со всеми другими объектами (геометрия, параметры и операции) в описании блока, части вхождения блока могут не вращаться или манипулирование блоками может приводить к неожиданных результатам.

Шаг 4. Добавление параметров

Добавьте соответствующие параметры в описание динамического блока, следуя подсказкам в командной строке. Для получения более подробных сведений об использовании параметров см. раздел Использование параметров в динамических блоках .

Примечание С помощью вкладки "Наборы параметров" палитр создания блоков можно добавлять одновременно параметр и связанную с ним операцию. Для получения более подробных сведений об использовании набора параметров см. раздел Использование наборов параметров .

Шаг 5. Добавьте операции

Добавьте соответствующие операции в описание динамического блока. Следуйте подсказкам в командной строке, не забывая указывать связи операций с соответствующими параметрами и геометрией. Для получения более подробных сведений об использовании операций см. раздел Обзор операций в динамических блоках .

Шаг 6. Определите, как будет выполняться манипулирование вхождением динамического блока

Можно указать, как будет выполняться манипулирование вхождением динамического блока на чертеже. Для манипулирования вхождением динамического блока можно использовать ручки или свойства настройки. При создании описания динамического блока можно определить, какие ручки отображаются и как они изменяют вхождение динамического блока. Можно также указать, должны ли свойства настройки отображаться в палитре "Свойства", а также можно ли эти свойства изменять с помощью палитры или с помощью ручек настройки.

Шаг 7. Сохраните блок, а затем попробуйте его вставить в чертеж

Сохраните определение динамического блока и выйдите из контекстной вкладки "Редактор блоков" ленты или из редактора блоков. Вставьте динамический блок в чертеж и проверьте его работу.

См. также

    • Сохранение блока в редакторе блоков


Обзор динамических блоков (Краткий справочник)

Быстрое начало работы по созданию динамических блоков
Обзор динамических блоков
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Обзор динамических блоков >
Обзор динамических блоков
Понятие Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОК

Создание определения блока из выбранных объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование редактора блоков

Обзор динамических блоков
Добавление функций динамического изменения в блоки
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки >
Использование редактора блоков
Понятие Процедура

С помощью редактора блоков можно добавлять в блоки функции динамического изменения. Редактор блоков содержит все необходимые инструменты для добавления в блоки интеллектуальных возможностей и достижения большей гибкости в работе.

Темы в этом разделе

  • Обзор редактора блоков
  • Использование палитр вариации блоков

    Редактор блока содержит три палитры вариации блоков: "Параметры", "Операции" и "Наборы параметров".

  • Как объекты отображаются в редакторе блоков

    Параметры, операции и их взаимосвязи (зависимости) отображаются по-разному в редакторе блоков. Можно указать настройки для некоторых из этих элементов.


Использование редактора блоков (Процедура)

Добавление функций динамического изменения в блоки
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков >
Использование редактора блоков
Понятие Процедура

Чтобы открыть существующее определение блока в редакторе блоков

Чтобы создать новое определение блока в редакторе блоков

Чтобы открыть блок на инструментальной палитре редакторе блоков

Чтобы открыть блок из окна Центра управления в редакторе блоков

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

Чтобы просмотреть свойства определения блока в редакторе блоков

Чтобы просмотреть свойства объектов в редакторе блоков

Чтобы закрыть редактор блоков

Чтобы запретить доступ к редактору блоков

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

Чтобы создать копию набора параметров

Чтобы добавить операцию в набор параметров

Чтобы удалить операцию из параметра или набора параметров

Чтобы указать цвет отображения для параметров в редакторе блоков

Чтобы указать размер текста для параметров и операций в редакторе блоков

Чтобы указать шрифт для параметров в редакторе блоков

Чтобы указать цвет текста для операций в редакторе блоков

Чтобы указать отображаемый размер ручек в редакторе блоков

Чтобы указать отображаемый цвет ручек в редакторе блоков

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

Чтобы включить или отключить выделение зависимостей в редакторе блоков

Чтобы определить, должны ли отображаться метки наборов значений (засечки)


Обзор редактора блоков (Понятие)

Использование редактора блоков
Использование редактора блоков
Использование палитр вариации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Контекстная вкладка "Редактор блоков" ленты и редактора блоков представляют собой специальные области для создания определений блоков и назначения им функций динамического изменения.

Редактор блоков содержит специальные палитры вариации. Эти палитры обеспечивают быстрый доступ к инструментам для разработки блоков.

Помимо палитр вариаций, на контекстной вкладке "Редактор блоков" ленты и в редакторе блоков предусмотрены области рисования, где можно строить и редактировать геометрию — так же, как и в главной области рисования программы. Для области рисования редактора блоков можно задать цвет фона.

ПримечаниеИз контекстной вкладки "Редактор блоков" ленты или в редакторе блоков можно вызывать большинство команд. При вводе команды, которая недопустима в редакторе блоков, в командной строке отображается сообщение.

Как контекстная вкладка "Редактор блоков" ленты, так и редактор блоков позволяют назначать имеющимся в текущем чертеже определениям блоков функции динамического изменения или редактировать их. С их помощью также можно создавать новые определения блоков.

Когда лента активна, над областью рисования отображается специальная контекстная вкладка ленты. Когда лента неактивна, отображается специальная панель инструментов. И на контекстной вкладке ленты, и на панели инструментов отображается имя редактируемого в данный момент определения блока, а также содержатся инструменты для выполнения следующих действий:

  • Сохранение определения блока
  • Добавление параметра
  • Добавление операции
  • Задание атрибутов
  • Закрытие редактора блоков
  • Управление состоянием видимости

На контекстной вкладке "Редактор блоков" ленты или в редакторе блоков можно выбирать любой параметр, ручку, действие или геометрический объект для просмотра их свойств в палитре "Свойства". При выборе объекта в редакторе блоков значения координат, отображаемые в палитре "Свойства", показывают пространство определения блока.

При работе на контекстной вкладке "Редактор блоков" ленты или в редакторе блоков командная строка должна присутствовать на экране. В командной строке отображаются подсказки практически по всем аспектам создания динамических блоков.

ПСК в редакторе блоков

В области рисования в редакторе блоков отображается ПСК. Начальная точка значка ПСК обозначает базовую точку блока. Чтобы изменить базовую точку для блока, можно переместить геометрию относительно исходной точки значка ПСК или добавить параметр базовой точки.

Команда ПСК не работает в редакторе блоков. В редакторе блоков можно открыть существующее описание 3D блока и назначить параметры для блока. Однако в параметрах будут игнорироваться все значения координат Z в пространстве блока. Поэтому вхождение бока нельзя изменять вдоль оси Z. Более того, при создании динамического блока, содержащего твердотельные объекты и добавлении в него таких операций, как перемещение, поворот и масштабирование, нельзя выполнять редактирование характеристик твердотельного объекта внутри вхождения динамического блока (например растяжение твердотельного объекта, перемещение отверстия в твердотельном объекте и т.д.).

См. также

    • Создание атрибутов


Обзор редактора блоков (Процедура)

Использование редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы открыть существующее определение блока в редакторе блоков

Чтобы создать новое определение блока в редакторе блоков

Чтобы открыть блок на инструментальной палитре редакторе блоков

Чтобы открыть блок из окна Центра управления в редакторе блоков

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

Чтобы просмотреть свойства определения блока в редакторе блоков

Чтобы просмотреть свойства объектов в редакторе блоков

Чтобы закрыть редактор блоков

Чтобы запретить доступ к редактору блоков


Чтобы открыть существующее определение блока в редакторе блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы открыть существующее определение блока в редакторе блоков

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Редактировать". В командной строке введите "блокред".
  2. В диалоговом окне "Редактирование определения блока" выполнить одно из следующих действий:
    • Выбрать определение блока из списка.
    • Выбрать <Текущий чертеж>, если чертеж является описанием блока, который требуется открыть.
  3. Нажать "ОК".
Панель:Стандартная
Ввод команды: БЛОКРЕД
Контекстное меню: Щелкнуть выбранный блок правой кнопкой мыши. Выбрать "Редактор блоков".


Чтобы создать новое определение блока в редакторе блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы создать новое определение блока в редакторе блоков

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Редактировать". В командной строке введите "блокред".
  2. В диалоговом окне "Редактирование определения блока" ввести имя для нового описания блоков.
  3. Нажать "ОК".
  4. В редакторе блоков щелкнуть "Сохранить определение блока".
    Примечание При этом определение блока будет сохранено, даже если в области рисования редактора блоков не было добавлено никаких объектов.
  5. Щелкнуть "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: БЛОКРЕД


Чтобы открыть блок на инструментальной палитре редакторе блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы открыть блок на инструментальной палитре редакторе блоков

  1. Если окно "Инструментальные палитры" еще не открыто, выберите меню Сервис [image] Палитры [image] Инструментальные палитры.Если окно "Инструментальные палитры" еще не открыто, введите в командной строке "инстрпалоткл".
  2. Щелкнуть правой кнопкой мыши значок блока.
  3. Выбрать "Редактор блоков".
Примечание В инструментальной палитре блок может находиться в другом чертеже. Чертеж, содержащий определение блока, откроется в редакторе блоков.
Панель:Стандартная
Ввод команды: ИНСТРПАЛВКЛ


Чтобы открыть блок из окна Центра управления в редакторе блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы открыть блок из окна Центра управления в редакторе блоков

  1. Если Центр управления еще не открыт, выберите меню "Сервис" [image] "Палитры" [image] "Центр управления".Если Центр управления еще не открыт, в командной строке введите "цуоткл".
  2. Щелкнуть правой кнопкой мыши значок блока.
  3. Выбрать "Редактор блоков".
Панель:Стандартная
Ввод команды: ЦУВКЛ


Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический) (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)

  1. Открыть файл чертежа, который был сохранен как блок.
  2. Выберите вкладку "Главная" [image] панель "Блок" [image] "Редактировать". В командной строке введите "блокред".
  3. В диалоговом окне "Редактирование определения блока" выбрать <Текущий чертеж>.
  4. Нажать "ОК".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок

  1. Открыть файл чертежа, который был сохранен как блок.

    Появится предупреждение, указывающее, что файл чертежа содержит элементы вариации.

  2. В диалоговом окне нажать "Да", чтобы открыть чертеж в редакторе блоков.
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Чтобы просмотреть свойства определения блока в редакторе блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы просмотреть свойства определения блока в редакторе блоков

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Редактировать". В командной строке введите "блокред".
  2. В диалоговом окне "Редактирование определения блока" выполнить одно из следующих действий:
    • Выбрать определение блока из списка.
    • Выбрать <Текущий чертеж>, если чертеж является описанием блока, который требуется открыть.
  3. Нажать "ОК".
  4. Если окно "Палитра свойств" не отображается, выберите меню Сервис [image] Палитра [image] Свойства.
  5. В окне "Палитра свойств" в разделе "Блок" просмотреть свойства определения блока.
Панель:Стандартная
Ввод команды: БЛОКРЕД


Чтобы просмотреть свойства объектов в редакторе блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы просмотреть свойства объектов в редакторе блоков

  1. Выберите объект в редакторе блоков.
  2. Если окно "Палитра свойств" не отображается, выберите меню Сервис [image] Палитра [image] Свойства.
  3. В окне "Палитра свойств" просмотреть свойства выбранного объекта.
Панель:Стандартная
Ввод команды: БЛОКРЕД
Контекстное меню: Щелкнуть правой кнопкой мыши на выбранном объекте. Нажать кнопку "Свойства".


Чтобы закрыть редактор блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Обзор редактора блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы закрыть редактор блоков

  • В редакторе блоков щелкнуть "Закрыть редактор блоков".
Ввод команды: БЛОКРЕДЗАКР


Чтобы запретить доступ к редактору блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Использование палитр вариации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Чтобы запретить доступ к редактору блоков

  1. В командной строке введите команду blockeditlock.
  2. Введите 1 и нажмите ENTER.


Обзор редактора блоков (Краткий справочник)

Обзор динамических блоков
Обзор редактора блоков
Использование палитр вариации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Обзор редактора блоков >
Обзор редактора блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕДЗАКР

Закрытие редактора блоков

БЛОКРЕД

Открытие определения блока в редакторе блоков

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ОКНОСВ

Управление свойствами объектов

Системные переменные

BLOCKEDITLOCK

Запрет открытия редактора блоков и редактирование определений динамических блоков

Утилиты

Нет

Ключевые слова для команд

Нет


Использование палитр вариации блоков (Понятие)

Обзор редактора блоков
Использование редактора блоков
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков >
Использование палитр вариации блоков
Понятие Процедура Краткий справочник

Редактор блока содержит три палитры вариации блоков: "Параметры", "Операции" и "Наборы параметров".

Окно "Палитры вариации блоков" отображается только в редакторе блоков. С помощью этих палитр можно добавлять параметры и операции в описание динамического блока.

Создание инструментов для разработки блоков

Можно создавать собственные инструменты для разработки блоков. Чтоб сохранить инструменты по умолчанию в палитрах вариации блоков, необходимо создать новую палитру для собственных инструментов разработки блоков. Затем можно скопировать инструмент набора параметров из одной из существующих палитр и вставить копию в новую палитру. В диалоговом окне "Свойства инструмента" можно затем изменить свойства нового инструмента, включая следующие:

  • Описание инструмента
  • Тип параметра
  • Связанные операции
  • Важное свойство параметра, с которым связана операция (если таковая имеется)
  • Изображение инструментальной палитры

Из редактора блока нельзя перетаскивать параметры и операции в другие палитры.

См. также

    • Использование параметров в динамических блоках

    • Использование операций с динамическими блоками

    • Использование наборов параметров

    • Изменение свойств инструментов

    • Организация инструментальных палитр


Использование палитр вариации блоков (Процедура)

Обзор редактора блоков
На уровень вверх ..
Использование палитр вариации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Использование палитр вариации блоков >
Использование палитр вариации блоков
Понятие Процедура Краткий справочник

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

Чтобы создать копию набора параметров

Чтобы добавить операцию в набор параметров

Чтобы удалить операцию из параметра или набора параметров


Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков (Процедура)

Использование палитр вариации блоков
На уровень вверх ..
Использование палитр вариации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Использование палитр вариации блоков >
Использование палитр вариации блоков
Понятие Процедура Краткий справочник

Чтобы отобразить или скрыть окно "Палитры вариации блоков" в редакторе блоков

  • В редакторе блоков на панели инструментов редактора блоков нажмите кнопку "Палитры вариации блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАЛВАР, БЛОКПАЛВАРЗАКР


Чтобы создать копию набора параметров (Процедура)

Использование палитр вариации блоков
На уровень вверх ..
Использование палитр вариации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Использование палитр вариации блоков >
Использование палитр вариации блоков
Понятие Процедура Краткий справочник

Чтобы создать копию набора параметров

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Наборы параметров" щелкните правой кнопкой мыши набор параметров. Выберите "Копировать".
  2. Щелкните правой кнопкой мыши в любом месте на палитре, которую необходимо добавить набор параметров (но не на наборе параметров). Выберите "Вставить".


Чтобы добавить операцию в набор параметров (Процедура)

Использование палитр вариации блоков
На уровень вверх ..
Использование палитр вариации блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Использование палитр вариации блоков >
Использование палитр вариации блоков
Понятие Процедура Краткий справочник

Чтобы добавить операцию в набор параметров

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Наборы параметров" щелкните правой кнопкой мыши набор параметров. Нажать кнопку "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе "Параметр" щелкните "Операции", а затем нажмите кнопку [...].
  3. В диалоговом окне "Добавление операций" в разделе "Добавляемый объект операции" выберите в списке операцию.
  4. Нажать "Добавить".
  5. (Необязательно) Повторить пункты 3 и 4, если нужно добавить дополнительные операции.
  6. Нажать "ОК".
  7. В диалоговом окне "Свойства инструмента" нажать "ОК".


Чтобы удалить операцию из параметра или набора параметров (Процедура)

Использование палитр вариации блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Использование палитр вариации блоков >
Использование палитр вариации блоков
Понятие Процедура Краткий справочник

Чтобы удалить операцию из параметра или набора параметров

  1. В редакторе блоков в окне "Палитры вариации блоков" щелкните правой кнопкой мыши параметр или набор параметров. Нажать кнопку "Свойства".
  2. В диалоговом окне "Свойства инструмента" в разделе "Параметр" щелкните "Операции", а затем нажмите кнопку [...].
  3. В диалоговом окне "Добавление операций" в разделе "Список объектов операций" выберите в списке операцию.
  4. Нажать кнопку "Удалить".
  5. (Необязательно) Повторить пункты 3 и 4, если нужно удалить дополнительные операции.
  6. Нажать "ОК".
  7. В диалоговом окне "Свойства инструмента" нажать "ОК".


Использование палитр вариации блоков (Краткий справочник)

Обзор редактора блоков
Использование палитр вариации блоков
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Использование палитр вариации блоков >
Использование палитр вариации блоков
Понятие Процедура Краткий справочник

Команды

БЛОКПАЛВАР

Открытие окна "Палитры вариации блоков" в редакторе блоков

БЛОКПАЛВАРЗАКР

Закрытие окна "Палитры вариации блоков" в редакторе блоков

БЛОКРЕД

Открытие определения блока в редакторе блоков

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

Системные переменные

BLOCKEDITOR

Признак открытого/закрытого редактора блока

Утилиты

Нет

Ключевые слова для команд

Нет


Как объекты отображаются в редакторе блоков (Понятие)

Использование палитр вариации блоков
Использование редактора блоков
Добавление в блоки динамических элементов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Параметры, операции и их взаимосвязи (зависимости) отображаются по-разному в редакторе блоков. Можно указать настройки для некоторых из этих элементов.

Параметры

В редакторе блоков большинство параметров выглядят как размеры. Если создать набор значений (диапазон или список значений) для параметра, в местоположениях этих значений отображаются засечки.

Можно указать следующие настройки для параметров в редакторе блоков:

  • Цвет параметра
  • Текст параметра и размер стрелки
  • Шрифт параметра
  • Цвет ручки
  • Отображение меток наборов значений (засечек) для параметров

При использовании параметра видимости в описании динамического блока указывается, какие геометрические объекты являются невидимыми в заданном состоянии видимости. Можно указать отображается ли геометрия, которая делается невидимой для состояний видимости, в редакторе блоков. В следующем примере состояние видимости отображается в редакторе блоков. Геометрия, которая отображается серым цветом, является невидимой в этом состоянии видимости.

Операции

Для операции в редакторе блоков отображается имя и значок (вспышка молнии). В редакторе блоков для операций можно задать размер и цвет текста.

Ручки

Можно также задать размер ручки и цвет при отображении в редакторе блоков. Этот параметр не влияет на размер и цвет ручек во вхождении блока на чертеже.

Зависимости

При выборе в редакторе блоков параметра, ручки или операции, будут выделены все связанные объекты или зависимости. Этот процесс называется выделением зависимостей. Выделение зависимостей можно включать или отключать.

В следующем примере показано, как при выделении зависимостей создается эффект ореола для связанного параметра (Расстояние) и операции (Растянуть) при выборе в редакторе блоков ручки настройки.

В следующей таблице показано, какая выделяется зависимость при выборе элемента в редакторе блоков.

Выбранный объект в редакторе блоков | Объекты с выделенными взаимосвязями
Параметр | Связанные ручки и операции
Ручка | Связанный параметр или операции
Операция | Связанные параметры, ручки и набор объектов (геометрии)


Как объекты отображаются в редакторе блоков (Процедура)

Использование палитр вариации блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать цвет отображения для параметров в редакторе блоков

Чтобы указать размер текста для параметров и операций в редакторе блоков

Чтобы указать шрифт для параметров в редакторе блоков

Чтобы указать цвет текста для операций в редакторе блоков

Чтобы указать отображаемый размер ручек в редакторе блоков

Чтобы указать отображаемый цвет ручек в редакторе блоков

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

Чтобы включить или отключить выделение зависимостей в редакторе блоков

Чтобы определить, должны ли отображаться метки наборов значений (засечки)


Чтобы указать цвет отображения для параметров в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать цвет отображения для параметров в редакторе блоков

  1. В командной строке введите команду bparametercolor.
  2. Установить одно из возможных значений переменной:
    • ПОСЛОЮ
    • ПОБЛОКУ
    • Целое число в диапазоне от 1 до 255
    • Точное значение цвета задается тремя целыми числами в диапазоне от 1 до 255 в следующем формате: RGB:000,000,000.
  3. Нажать ENTER.


Чтобы указать размер текста для параметров и операций в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать размер текста для параметров и операций в редакторе блоков

  1. В командной строке введите команду bparametersize.
  2. Введите целое число от 1 до 255 (точек).
  3. Нажать ENTER.


Чтобы указать шрифт для параметров в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать шрифт для параметров в редакторе блоков

  1. В командной строке введите команду bparameterfont.
  2. Введите любой шрифт TrueType или SHX в системе.
  3. Нажать ENTER.


Чтобы указать цвет текста для операций в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать цвет текста для операций в редакторе блоков

  1. В командной строке введите команду bactioncolor.
  2. Установить одно из возможных значений переменной:
    • ПОСЛОЮ
    • ПОБЛОКУ
    • Целое число в диапазоне от 1 до 255.
    • Точное значение цвета задается тремя целыми числами в диапазоне от 1 до 255 в следующем формате: RGB:000,000,000.
  3. Нажать ENTER.


Чтобы указать отображаемый размер ручек в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать отображаемый размер ручек в редакторе блоков

  1. В командной строке введите команду bgripobjsize.
  2. Введите целое число от 1 до 255 (точек).
  3. Нажать ENTER.


Чтобы указать отображаемый цвет ручек в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать отображаемый цвет ручек в редакторе блоков

  1. В командной строке введите команду bgripobjcolor.
  2. Установить одно из возможных значений переменной:
    • ПОСЛОЮ
    • ПОБЛОКУ
    • Целое число в диапазоне от 1 до 255.
    • Точное значение цвета задается тремя целыми числами в диапазоне от 1 до 255 в следующем формате: RGB:000,000,000.
  3. Нажать ENTER.


Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков

  • В редакторе блоков на панели инструментов редактора блоков щелкните "Обновление параметра и размер текста операции".
Примечание При увеличении или уменьшении в редакторе блоков размер текста и ручки изменится пропорционально коэффициенту масштабирования. Однако можно обновить текст или отображаемый размер ручки в указанных значениях в редакторе блоков.
Ввод команды: РЕГЕН


Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы указать, должны ли быть видны в редакторе блоков объекты, которые являются невидимыми для состояния видимости

  1. В командной строке введите команду bvmode.
  2. Установить одно из возможных значений переменной:
    • 0 Указывает, что невидимые объекты не видны в редакторе блоков.
    • 1 Указывает, что невидимые объекты отображаются серым цветом в редакторе блоков.
  3. Нажать ENTER.


Чтобы включить или отключить выделение зависимостей в редакторе блоков (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Как объекты отображаются в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы включить или отключить выделение зависимостей в редакторе блоков

  1. В командной строке введите команду bdependencyhighlight.
  2. Установить одно из возможных значений переменной:
    • 0 Выключает выделение зависимостей.
    • 1 Включает выделение зависимостей.
  3. Нажать ENTER.


Чтобы определить, должны ли отображаться метки наборов значений (засечки) (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Добавление в блоки динамических элементов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Чтобы определить, должны ли отображаться метки наборов значений (засечки)

  1. В командной строке введите команду btmarkdisplay.
  2. Установить одно из возможных значений переменной:
    • 0 Указывает, что метки наборов значений не отображаются.
    • 1 Указывает, что метки наборов значений отображаются.
  3. Нажать ENTER.


Как объекты отображаются в редакторе блоков (Краткий справочник)

Использование палитр вариации блоков
Как объекты отображаются в редакторе блоков
Обзор элементов динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Использование редактора блоков > Как объекты отображаются в редакторе блоков >
Как объекты отображаются в редакторе блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

РЕГЕН

Регенерация чертежа и перерисовка содержимого текущего видового экрана

Системные переменные

BACTIONCOLOR

Задание цвета текста для операций, выполняемых в редакторе блоков

BDEPENDENCYHIGHLIGHT

Управление наличием выделенных взаимосвязей в зависимых объектах, когда параметр, операция или ручка выбраны в редакторе блоков

BGRIPOBJCOLOR

Задание цвета ручек в редакторе блоков

BGRIPOBJSIZE

Задание отображаемого размера настраиваемых ручек в редакторе блоков относительно экранной системы

BPARAMETERCOLOR

Задание цвета параметров в редакторе блоков

BPARAMETERFONT

Задание шрифта, используемого для параметров и операций в редакторе блоков

BPARAMETERSIZE

Задание размера текста и функций параметра в редакторе блоков относительно экранной системы

BTMARKDISPLAY

Управление отображением меток наборов значений для вхождений динамического блока

BVMODE

Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление в блоки динамических элементов

Как объекты отображаются в редакторе блоков
Добавление функций динамического изменения в блоки
Обзор элементов динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки >
Добавление в блоки динамических элементов
Понятие Процедура

Чтобы создать динамический блок, необходимо добавить в определение блока определенные элементы.

Темы в этом разделе

  • Обзор элементов динамических блоков

    Динамические элементы добавляются в определение блока в редакторе блоков. Кроме геометрии, динамический блок обычно содержит один или несколько параметров, а также одну или несколько операций.

  • Использование параметров в динамических блоках

    С помощью добавляемых в описание динамических блоков параметров определяются свойства настройки для блока, а также указываются положения, расстояния и углы для геометрии в блоке.

  • Использование операций с динамическими блоками

    Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже.

  • Использование наборов параметров

    Для добавления чаще всего парных параметров и операций в описание динамических блоков пользуйтесь вкладкой "Наборы параметров" окна "Палитры вариации блоков".

  • Указание ручек для динамических блоков

    При добавлении параметра в описание динамического блока, автоматически добавляются ручки настройки, связанные с ключевыми точками параметра.

  • Создание "Состояния видимости"

    Можно использовать состояния видимости, чтобы сделать геометрию видимой или невидимой в динамическом блоке. Один блок может иметь несколько состояний видимости.

  • Использование таблицы выбора для назначения данных для динамических блоков

    Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока.

  • Указание настраиваемых свойств для динамических блоков

    При создании динамического блока можно указать настраиваемые свойства для блока. Можно также указать, должны ли эти свойства отображаться в палитре "Свойства" при выборе вхождения блока на чертеже.

  • Изменение определений динамических блоков

    Описания динамических блоков можно изменять в редакторе блоков.

  • Исправление ошибок в описаниях динамических блоков

    Желтый значок предупреждения отображается в редакторе блоков, если описание динамических блоков содержит ошибки или является неполным. Исправьте ошибки (или дополните блок), чтобы вхождение блока в чертеже работало правильно.


Добавление в блоки динамических элементов (Процедура)

Как объекты отображаются в редакторе блоков
На уровень вверх ..
Обзор элементов динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Добавление в блоки динамических элементов
Понятие Процедура

Чтобы создать динамический блок

Чтобы добавить в описание динамического блока параметр точки

Чтобы добавить в описание динамического блока линейный параметр

Чтобы добавить в описание динамического блока полярный параметр

Чтобы добавить в описание динамического блока параметр XY

Чтобы добавить в описание динамического блока параметр поворота

Чтобы добавить в описание динамического блока параметр выравнивания

Чтобы добавить в описание динамического блока параметр отражения

Чтобы добавить в описание динамического блока параметр видимости

Чтобы добавить в описание динамического блока параметр выбора

Чтобы добавить в описание динамического блока параметр базовой точки

Добавление набора параметров в описание динамического блока

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

Чтобы переместить ручку в описании динамического блока

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке

Для включения состояний видимости (добавить параметр видимости)

Для создания нового состояния видимости на основе текущего состояния

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

Для создания нового состояния видимости, в котором все объекты являются видимыми

Чтобы сделать состояние видимости текущим

Для удаления состояния видимости

Для задания нового имени состоянию видимости

Чтобы сделать объекты видимыми в текущем состоянии видимости

Чтобы сделать объекты видимыми во всех состояниях видимости

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

Чтобы сделать объекты невидимыми во всех состояниях видимости

Для отображения или скрытия невидимой геометрии для состояний видимости.

Для изменения порядка в списке состояний видимости для вхождения динамического блока

Для установки состояния видимости по умолчанию для вхождения динамического блока.

Чтобы открыть существующее описание динамического блока в редакторе блоков

Удаление элемента из описания динамических блоков

Изменение набора объектов для операции в описании динамических блоков

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

Просмотр зависимостей внутри описания динамических блоков


Обзор элементов динамических блоков (Понятие)

Добавление в блоки динамических элементов
Добавление в блоки динамических элементов
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Обзор элементов динамических блоков
Понятие Процедура Краткий справочник

Динамические элементы добавляются в определение блока в редакторе блоков. Кроме геометрии, динамический блок обычно содержит один или несколько параметров, а также одну или несколько операций.

  • Параметры. Определяют настраиваемые свойства для динамического блока путем указания положений, расстояний и углов для геометрии в блоке.
  • Операции. Определяют, как будет двигаться или изменяться геометрия вхождения динамического блока при манипулировании в чертеже. При добавлении в описание динамического блока операций их необходимо связать с параметрами. Кроме того, указывается набор объектов геометрии, которые участвуют в этой операции.
Примечание Параметры и операции отображаются только в редакторе блоков. При вставке в чертеж вхождения динамического блока параметры и операции, содержащиеся в описании динамического блока, не отображаются.

При добавлении параметра в описание динамического блока в ключевые точки параметра добавляются ручки. Ключевые точки - это части параметра, которые используются для манипулирования вхождением блока. Например, линейный параметр имеет ключевые точки в своей базовой и конечной точках. Расстоянием параметра можно манипулировать из любой ключевой точки.

Тип параметра, добавляемого в динамический блок, определяет тип добавляемых ручек. Каждый тип параметра поддерживает только определенные типы операций. В следующей таблице приведены взаимосвязи между параметрами, ручками и операциями.

Тип параметра | Тип ручки |  | Операции, которые можно связать с параметром
Точка |  | Стандартный | Переместить, Растянуть
Линейный |  | Линейный | Переместить, Масштаб, Растянуть, Массив
Полярная |  | Стандартный | Переместить, Масштаб, Растянуть, Полярное растяжение, Массив,
XY |  | Стандартный | Переместить, Масштаб, Растянуть, Массив
Поворот |  | Поворот | Поворот
Отразить |  | Отразить | Отразить
Выравнивание |  | Выравнивание | Нет (операция подразумевается и содержится внутри параметра).
Видимость |  | Поискать | Нет (операция подразумевается и определяется состояниями видимости).
Поискать |  | Поискать | Поискать
Базовая точка |  | Стандартный | Нет


Чтобы создать динамический блок (Процедура)

Добавление в блоки динамических элементов
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Обзор элементов динамических блоков >
Обзор элементов динамических блоков
Понятие Процедура Краткий справочник

Чтобы создать динамический блок

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Редактировать". В командной строке введите "блокред".
  2. В диалоговом окне "Редактирование определения блока" выполнить одно из следующих действий:
    • Выбрать определение блока из списка.
    • Выбрать <Текущий чертеж>, если необходимо сохранить чертеж как динамический блок.
    • В разделе "Блок для создания или изменения" ввести имя для описания нового блока.
  3. Нажать "ОК".
  4. В редакторе блоков добавить или изменить геометрию.
  5. Выполнить одно из следующих действий:
    • Добавьте один или несколько наборов параметров с вкладки "Наборы параметров" окна "Палитры вариации блоков", следуя подсказкам в командной строке. Дважды щелкните желтый значок предупреждения (или используйте команду БЛОКРЕАКТНАБОР) и следуйте подсказкам в командной строке, чтобы связать операцию с набором объектов геометрии.
    • Добавьте один или несколько параметров с вкладки "Параметры" окна "Палитры вариации блоков", следуя подсказкам в командной строке. Добавьте одну или несколько операций с вкладки "Операции", следуя подсказкам в командной строке.
  6. На панели инструментов редактора блоков щелкнуть "Сохранить определение блока".
  7. Щелкнуть "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: БЛОКРЕД
Контекстное меню: Щелкнуть правой кнопкой мыши блока. Выбрать "Редактор блоков".


Обзор элементов динамических блоков (Краткий справочник)

Как объекты отображаются в редакторе блоков
Обзор элементов динамических блоков
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Обзор элементов динамических блоков >
Обзор элементов динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование параметров в динамических блоках (Понятие)

Обзор элементов динамических блоков
Добавление в блоки динамических элементов
Использование операций с динамическими блоками
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

С помощью добавляемых в описание динамических блоков параметров определяются свойства настройки для блока, а также указываются положения, расстояния и углы для геометрии в блоке.

Параметры в описание динамического блока добавляются в редакторе блоков. В редакторе блоков параметры отображаются похожими на размеры. Параметры определяют свойства настройки блока. Параметры также определяют положения, расстояния и углы для геометрии во вхождения блока. При добавлении параметра в описание динамического блока параметры определяют одно или несколько настраиваемых свойств для блока.

Например, при добавлении в описание динамического блока параметра поворота этот параметр определяет свойство Угол для вхождения блока. Поэтому если на чертеже имеется блок стула и требуется возможность поворота положения блока во время редактирования, то этот параметр определяет ось, вокруг которой можно поворачивать блок.

В случае добавления параметра точки в описание динамического блока, этот параметр определяет два свойства настройки для вхождения блока: Положение X и Положение Y (относительно базовой точки вхождения блока).

Описание динамического блока должно содержать хотя бы один параметр. При добавлении параметра в описание динамического блока автоматически добавляются ручки, связанные с ключевыми точками параметра. Затем в определение блока необходимо добавить операцию и связать операцию с параметром.

На чертеже для манипулирования вхождением блока можно использовать ручку или свойство настройки в палитре свойств. При манипулировании вхождением блока на чертеже путем перемещения ручки или изменения значения настраиваемого свойства в палитре свойств изменяется значение параметра, определяющего это свойство настройки в блоке. При изменении значения параметра производится операция, связанная с этим параметром, которая изменяет геометрию (или свойство) вхождения динамического блока.

Параметры также определяют значения ограничений, влияющих на поведение вхождения динамического блока на чертеже. Некоторые параметры имеют фиксированный набор значений, минимальные и максимальные значения или значения приращения. Например, линейный параметр, используемый в блоке окна, может иметь следующий фиксированный набор значений: 10, 20, 30 и 40. При вставке в чертеж вхождения бока можно изменять окно, используя только одно из этих значений. Добавление набора значений для параметра позволяет ограничить манипулирование вхождением блока в чертеже. Для получения более подробных сведений о наборе значений параметров см. раздел Указание наборов значений для динамических блоков .

Параметры точки, поворота, XY, а также линейные и полярные параметры имеют свойство под названием "Цепочка операций". Для получения более подробных сведений о возможности использования цепочки операций для параметра см. раздел Разрешение цепочки операций для динамических блоков .

Значения параметров также можно извлекать с помощью Мастера извлечения атрибутов или с помощью файла шаблона извлечения атрибутов.

В следующей таблице приведен список и описания типов параметров, которые можно добавлять в описания динамических блоков, а также типы операций, которые можно связывать с каждым параметром.

Тип параметра | Описание | Поддерживаемые операции
Точка | Определяет координаты X и Y на чертеже. В редакторе блоков выглядят похоже на ординатный размер. | Переместить, Растянуть
Линейный | Показывает расстояние между двумя точками привязки. Ограничивает перемещение с помощью ручки по заданному углу. В редакторе блоков выглядят похоже на выровненный размер. | Переместить, Масштаб, Растянуть, Массив
Полярная | Отображает расстояние между двумя точками привязки и отображает значение угла. Для изменения значений расстояния и угла можно использовать как ручки, так и палитру свойств. В редакторе блоков выглядят похоже на выровненный размер. | Переместить, Масштаб, Растянуть, Полярное растяжение, Массив,
XY | Показывает расстояния X и Y от базовой точки параметра. В редакторе блоков отображается в виде пары размеров (горизонтального и вертикального). | Переместить, Масштаб, Растянуть, Массив
Поворот | Определяет угол. В редакторе блоков отображается в виде окружности. | Поворот
Отразить | Отражает объекты. В редакторе блоков отображается в виде линии отражения. Объекты могут отражаться относительно этой линии отражения. Отображает значение, которое показывает, отражено или еще нет вхождение блока. | Отразить
Выравнивание | Определяет координаты X и Y и угол. Параметр выравнивания всегда относится ко всему блоку и не требует наличия связанной с ним операции. Параметр выравнивания позволяет вхождению блока автоматически вращаться вокруг точки для выравнивания с другим объектом на чертеже. Параметр выравнивания влияет на свойство поворота вхождения блока. В редакторе блоков выглядит как линия выравнивания. | Нет (операция подразумевается и содержится внутри параметра).
Видимость | Управляет видимостью объектов в блоке. Параметр видимости всегда относится ко всему блоку и не требует наличия связанной с ним операции. На чертеже можно щелкнуть ручку, чтобы отобразить список имеющихся состояний видимости для вхождения блока. В редакторе блоков отображается в виде текста со связанной ручкой. | Нет (операция подразумевается и определяется состояниями видимости).
Поискать | Определяет свойство настройки, которое можно указать, или набор для вычисления значения из списка или таблицы, задаваемых пользователем. Его можно связать с одной ручкой выбора. Во вхождении блока можно щелкнуть ручку, чтобы отобразить список имеющихся значений. В редакторе блоков отображается в виде текста со связанной ручкой. | Поискать
Базовая точка | Определяет базовую точку для вхождения динамического блока относительно геометрии в блоке. Его невозможно связать с любыми операциями, но можно включить в набор объектов операции. В редакторе блоков отображается в виде окружности с перекрестиями. | Нет
См. также

    • Указание наборов значений для динамических блоков

    • Обзор настраиваемых свойств для динамических блоков

    • Извлечение данных из атрибутов

    • Извлечение данных из атрибутов (метод низкого уровня)


Использование параметров в динамических блоках (Процедура)

Обзор элементов динамических блоков
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр точки

Чтобы добавить в описание динамического блока линейный параметр

Чтобы добавить в описание динамического блока полярный параметр

Чтобы добавить в описание динамического блока параметр XY

Чтобы добавить в описание динамического блока параметр поворота

Чтобы добавить в описание динамического блока параметр выравнивания

Чтобы добавить в описание динамического блока параметр отражения

Чтобы добавить в описание динамического блока параметр видимости

Чтобы добавить в описание динамического блока параметр выбора

Чтобы добавить в описание динамического блока параметр базовой точки


Чтобы добавить в описание динамического блока параметр точки (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр точки

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр точки".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания расположения метки параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  5. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  6. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока линейный параметр (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока линейный параметр

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Линейный параметр".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания конечной точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий для указания расположения метки параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  6. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  7. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока полярный параметр (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока полярный параметр

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Полярный параметр".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания конечной точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий для указания расположения метки параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  6. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  7. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр XY (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр XY

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр XY".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания конечной точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  5. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  6. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр поворота (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр поворота

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр поворота".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Набор значений
    • Цепочка операций
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания базовой точки для параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  4. Выполните одно из следующих действий для указания радиуса для параметра:
    • Используйте указывающее устройство.
    • Введите значение.
  5. Укажите базовый угол для параметра.

    Угол, отображаемый в палитре свойств и при выборе вхождения блока на чертеже, измеряется относительно базового угла, заданного в описании блока.

  6. Выполните одно из следующих действий для указания угла поворота по умолчанию для параметра:
    • Используйте указывающее устройство.
    • Введите значение угла.
  7. Выполните одно из следующих действий для указания расположения метки параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  8. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  9. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  10. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр выравнивания (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр выравнивания

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр выравнивания".
  2. Следуйте подсказкам в командной строке, чтобы указать имя параметра.
  3. Выполните одно из следующих действий для указания базовой точки параметра выравнивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Эта базовая точка является местоположением по умолчанию для ручки параметра выравнивания.

  4. (Дополнительно) Введите в командной строке команду тип и следуйте подсказкам, чтобы указать, является ли тип параметра нормалью или касательной.
  5. Выполните одно из следующих действий для указания направления выравнивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  6. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр отражения (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр отражения

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр отражения".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания первой точки линии отражения для параметра отражения:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Эта первая точка линии отражения является местоположением по умолчанию для ручки параметра отражения.

  4. Выполните одно из следующих действий для указания второй точки линии отражения для параметра отражения:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий для указания расположения метки параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  6. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам для связи операции с параметром и набором объектов геометрии.
  7. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр видимости (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр видимости

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр видимости".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Это расположение для ручки параметра видимости во вхождении блока.

  4. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  5. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр выбора (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование параметров в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр выбора

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр выбора".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

      Желтый значок предупреждения показывает, что операцию необходимо связать с только что добавленным параметром.

  4. Чтобы добавить операцию сейчас, дважды щелкните значок предупреждения. Следуйте подсказкам, чтобы связать с параметром операцию поиска. При этом отобразится диалоговое окно "Таблица выбора свойств", значения в котором можно ввести либо сейчас, либо позднее.
  5. Нажать "ОК".
  6. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Чтобы добавить в описание динамического блока параметр базовой точки (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование операций с динамическими блоками
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Чтобы добавить в описание динамического блока параметр базовой точки

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр базовой точки".
  2. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  3. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  4. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Использование параметров в динамических блоках (Краткий справочник)

Обзор элементов динамических блоков
Использование параметров в динамических блоках
Обзор операций в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование параметров в динамических блоках >
Использование параметров в динамических блоках
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование операций с динамическими блоками

Использование параметров в динамических блоках
Добавление в блоки динамических элементов
Обзор операций в динамических блоках
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Использование операций с динамическими блоками
Понятие Процедура

Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже.

Темы в этом разделе

  • Обзор операций в динамических блоках
  • Использование операций перемещения в динамическом блоке

    Во вхождении динамического блока операция перемещения приводит к тем же результатам, что и команда ПЕРЕНЕСТИ.

  • Использование операций масштабирования в динамическом блоке

    Во вхождении динамического блока операция масштабирования приводит к тем же результатам, что и команда МАСШТАБ.

  • Используйте операцию растягивания в динамическом блоке

    Во вхождении динамического блока операция растягивания приводит к перемещению и растягиванию объектов на заданное расстояние в указанном месте.

  • Используйте операцию полярного растягивания в динамическом блоке

    Во вхождении динамического блока операция полярного растягивания вращает, перемещает и растягивает объекты на указанный угол и расстояние.

  • Используйте операцию поворота в динамическом блоке

    Во вхождении динамического блока действие операции поворота подобно действию команды ПОВЕРНУТЬ.

  • Используйте операцию отражения в динамическом блоке

    Операция отражения позволяет выполнять отражение вхождения динамического блока относительно указанной оси, которая называется линией отражения.

  • Используйте операцию с массивом в динамическом блоке

    Во вхождении динамического блока операция с массивом приводит к копированию и созданию массивов в прямоугольном массиве при редактировании связанного параметра с помощью ручки или палитры свойств.

  • Использование операции поиска в динамическом блоке

    При добавлении операции поиска в описание динамического блока и связывании ее с параметром выбора создается таблица выбора. Можно использовать таблицу выбора для назначения свойств настройки и значений динамического блока.

  • Использование переопределения для коэффициента расстояния и смещения угла

    В некоторых операциях используются свойства переопределения коэффициента расстояния и смещения угла. Эти свойства позволяют задать коэффициент, на который увеличивается или уменьшается значение параметра при его изменении во вхождении динамического блока.


Использование операций с динамическими блоками (Процедура)

Использование параметров в динамических блоках
На уровень вверх ..
Использование операций перемещения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Использование операций с динамическими блоками
Понятие Процедура

Для добавления операции перемещения в описание динамических блоков

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY

Для добавления операции масштабирования в описание динамических блоков

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY

Для добавления операции растягивания в определение блока

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY

Для добавления операции полярного растягивания в определение блока

Для добавления операции поворота в определение блока

Для добавления операции отражения в определение блока

Чтобы добавить в определение блока операцию с массивом

Для добавления операции поиска в описание динамических блоков

Задание переопределения коэффициента расстояния для операции

Задание переопределения смещения угла для операции


Обзор операций в динамических блоках (Понятие)

Использование операций с динамическими блоками
Использование операций с динамическими блоками
Использование операций перемещения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Обзор операций в динамических блоках
Понятие Краткий справочник

Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже. Динамический блок содержит по меньшей мере одну операцию.

Как правило, при добавление в описание динамического блока операции ее необходимо связать с параметром, ключевой точкой на параметре и геометрией. Ключевая точка - это точка на параметре, запускающая связанную с ней операцию при редактировании. Связанная с операцией геометрия называется набором объектов.

В следующем примере описание динамического блока содержит геометрию, представляющую стол, линейный параметр с одной ручкой, заданной для его конечной точки, и операцию растягивания, связанную с конечной точкой параметра и геометрией для правой стороны стола. Конечная точка параметра является ключевой точкой. Геометрия с правой стороны стола является набором объектов.

Если требуется изменить вхождение блока на чертеже, достаточно переместить ручку, и стол растянется.

В динамическом блоке можно использовать следующие типы операций:

  • Перенести
  • Масштаб
  • Растянуть
  • Полярное растяжение
  • Поворот
  • Отразить
  • Массив
  • Поискать

Для одного параметра и геометрии можно назначить несколько операций. Однако не следует назначать две или более операций одного типа для одной ключевой точки на параметре, если обе операции воздействуют на одну и ту же геометрию. Это может привести к неожиданному поведению вхождения блока.

Операции и типы параметров

Каждый тип операции можно связать с определенными параметрами. В следующей таблице показаны параметры, с которыми можно связать операции каждого типа.

Тип операции | Параметр
Перенести | Точка, линейный, полярный, XY
Масштаб | Линейный, полярный, XY
Растянуть | Точка, линейный, полярный, XY
Полярное растяжение | Полярная
Поворот | Поворот
Отразить | Отразить
Массив | Линейный, полярный, XY
Поискать | Поискать


Обзор операций в динамических блоках (Краткий справочник)

Использование параметров в динамических блоках
Обзор операций в динамических блоках
Использование операций перемещения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Обзор операций в динамических блоках >
Обзор операций в динамических блоках
Понятие Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование операций перемещения в динамическом блоке (Понятие)

Обзор операций в динамических блоках
Использование операций с динамическими блоками
Использование операций масштабирования в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Использование операций перемещения в динамическом блоке
Понятие Процедура Краткий справочник

Во вхождении динамического блока операция перемещения приводит к тем же результатам, что и команда ПЕРЕНЕСТИ.

Действие операции перемещения подобно действию команды ПЕРЕНЕСТИ. Во вхождении динамического блока операция перемещения приводит к перемещению объектов на заданные расстояние и угол.

В описании динамического блока операцию перемещения можно связать с любым из следующих параметров:

  • Точка
  • Линейный
  • Полярная
  • XY

После связи операции перемещения с параметром, операция связывается с набором объектов геометрии.

Во вхождении динамического блока, если с помощью ручки или палитры свойств изменяется значение параметра, связанного с операцией перемещения, это может повлиять на ключевую точку в параметре, связанную с операцией перемещения. При воздействии на ключевую точку геометрия в наборе операции перемещения будет перемещаться.

Например, пусть имеется динамический блок, представляющий стул. Блок содержит параметр точки и операцию перемещения, связанную с этим параметром. Набор объектов операции перемещения содержит всю геометрию в блоке (стуле). При манипулировании вхождением динамического объекта с помощью ручки, связанной с параметром точки (или свойств "Положение X" или "Положение Y" в палитре свойств), изменяется значение параметра точки. В результате этого изменения значения стул перемещается.

В следующем примере перемещение вхождения блока стула путем перетаскивания ручки параметра точки отображается новым положением этой ручки в палитре свойств.

Задание свойства "Тип расстояния" для операции перемещения

Если операция перемещения связана с параметром XY, то она имеет свойство переопределения Тип расстояния. Это свойство определяет, является ли примененное расстояние для перемещения значением X, значением Y или значениями координат X и Y от базовой точки параметра.

Например, в описании динамических блоков в качестве типа расстояния задается расстояние X для операции перемещения. Это означает, что блок может перемещаться только по оси X. Поэтому в случае перемещения блока по оси Y блок не перемещается.

См. также

    • Использование переопределения для коэффициента расстояния и смещения угла


Использование операций перемещения в динамическом блоке (Процедура)

Использование операций с динамическими блоками
На уровень вверх ..
Использование операций перемещения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций перемещения в динамическом блоке >
Использование операций перемещения в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции перемещения в описание динамических блоков

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY


Для добавления операции перемещения в описание динамических блоков (Процедура)

Использование операций перемещения в динамическом блоке
На уровень вверх ..
Использование операций перемещения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций перемещения в динамическом блоке >
Использование операций перемещения в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции перемещения в описание динамических блоков

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция перемещения".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией перемещения можно связать следующие типы параметров: точка, линейный, полярный и XY.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать коэффициент расстояния и угловое смещение.
  6. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
    Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  7. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY (Процедура)

Использование операций перемещения в динамическом блоке
На уровень вверх ..
Использование операций масштабирования в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций перемещения в динамическом блоке >
Использование операций перемещения в динамическом блоке
Понятие Процедура Краткий справочник

Для указания свойства "Тип расстояния" для операции перемещения, связанной с параметром XY

  1. В редакторе блоков выберите операцию перемещения.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип расстояния" в списке выберите параметр.


Использование операций перемещения в динамическом блоке (Краткий справочник)

Обзор операций в динамических блоках
Использование операций перемещения в динамическом блоке
Использование операций масштабирования в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций перемещения в динамическом блоке >
Использование операций перемещения в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование операций масштабирования в динамическом блоке (Понятие)

Использование операций перемещения в динамическом блоке
Использование операций с динамическими блоками
Используйте операцию растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Использование операций масштабирования в динамическом блоке
Понятие Процедура Краткий справочник

Во вхождении динамического блока операция масштабирования приводит к тем же результатам, что и команда МАСШТАБ.

Действие операции масштабирования подобно действию команды МАСШТАБ. Во вхождении динамического блока операция масштабирования приводит к масштабированию набора объектов блока при изменении параметра путем перемещения ручек или с использованием палитры свойств.

В описании динамического блока операция масштабирования связана со всем параметром, а не с ключевой точкой на параметре. Операцию масштабирования можно связать с любым из следующих параметров:

  • Линейный
  • Полярная
  • XY

После связи операции масштабирования с параметром, операция связывается с набором объектов геометрии.

Указание типа базовой точки для операции масштабирования

Операция масштабирования содержит свойство Тип базы. С помощью этого свойства можно указать тип базовой точки для масштабного коэффициента: зависимый или независимый.

Если тип базы зависимый, то объекты в наборе масштабируются относительно базовой точки параметра, с которой связана операция масштабирования. В следующем примере операция масштабирования связана с параметром XY. Операция масштабирования имеет зависимый тип базы. Базовая точка параметра XY расположена в левом нижнем углу прямоугольника. При использовании ручки настройки для масштабирования блока, его масштаб изменяется относительно левого нижнего угла прямоугольника.

Если тип базы независимый (показан в редакторе блоков как маркер X), то базовая точка задается независимо от параметра, с которым связана операция масштабирования. Объекты в наборе будут масштабироваться относительно базовой этой указанной независимой базовой точки. В следующем примере операция масштабирования связана с параметром XY. Операция масштабирования имеет независимый тип базы. Независимая базовая точка расположена в центре окружности. При использовании ручки настройки для масштабирования блока, его масштаб изменяется относительно центра окружности.

Укажите свойство "Тип масштаба" для операции масштабирования

Если операция масштабирования связана с параметром XY, то операция масштабирования имеет свойство переопределения Тип масштаба. Это свойство определяет, является ли использованный коэффициент масштаба расстоянием X, расстоянием Y или расстоянием значений координат X и Y от базовой точки параметра.

Например, в описании динамических блоков в качестве типа масштаба задается расстояние X для операции масштабирования. Если на чертеже выполняется редактирование вхождения блока путем перетаскивания ручки в параметре XY только вдоль оси Y, то масштаб связанной геометрии не изменяется.


Использование операций масштабирования в динамическом блоке (Процедура)

Использование операций перемещения в динамическом блоке
На уровень вверх ..
Использование операций масштабирования в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций масштабирования в динамическом блоке >
Использование операций масштабирования в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции масштабирования в описание динамических блоков

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY


Для добавления операции масштабирования в описание динамических блоков (Процедура)

Использование операций масштабирования в динамическом блоке
На уровень вверх ..
Использование операций масштабирования в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций масштабирования в динамическом блоке >
Использование операций масштабирования в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции масштабирования в описание динамических блоков

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция масштабирования".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией масштабирования можно связать следующие типы параметров: линейный, полярный и XY.)
  3. Выберите геометрию (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать тип базовой точки.
  6. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
    Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  7. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Для указания независимой базовой точки для операции масштабирования в описании динамических блоков (Процедура)

Использование операций масштабирования в динамическом блоке
На уровень вверх ..
Использование операций масштабирования в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций масштабирования в динамическом блоке >
Использование операций масштабирования в динамическом блоке
Понятие Процедура Краткий справочник

Для указания независимой базовой точки для операции масштабирования в описании динамических блоков

  1. Выберите операцию масштабирования в редакторе блоков.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип базы" в раскрывающемся списке выберите значение "Независимый".


Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY (Процедура)

Использование операций масштабирования в динамическом блоке
На уровень вверх ..
Используйте операцию растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций масштабирования в динамическом блоке >
Использование операций масштабирования в динамическом блоке
Понятие Процедура Краткий справочник

Для указания свойства "Тип масштаба" для операции масштабирования, связанной с параметром XY

  1. В редакторе блоков выберите операцию масштабирования, связанную с параметром XY.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип масштаба" в раскрывающемся списке выберите параметр.

    В зависимости от применяемого переопределения операции масштабирования для этого блока ограничена осью X, осью Y или обеими осями.


Использование операций масштабирования в динамическом блоке (Краткий справочник)

Использование операций перемещения в динамическом блоке
Использование операций масштабирования в динамическом блоке
Используйте операцию растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операций масштабирования в динамическом блоке >
Использование операций масштабирования в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Используйте операцию растягивания в динамическом блоке (Понятие)

Использование операций масштабирования в динамическом блоке
Использование операций с динамическими блоками
Используйте операцию полярного растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Используйте операцию растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Во вхождении динамического блока операция растягивания приводит к перемещению и растягиванию объектов на заданное расстояние в указанном месте.

В описании динамического блока операцию растягивания можно связать с любым из следующих параметров:

  • Точка
  • Линейный
  • Полярная
  • XY

После связывания операции растягивания с параметром можно указать рамку растягивания для этой операции. Затем выберите объекты для набора операции растяжения. Рамка растягивания определяет способ редактирования объектов внутри рамки или пересекаемых рамкой во вхождении блока. Это поведение напоминает выбор секущей рамкой с помощью команды РАСТЯНУТЬ.

  • Объекты, полностью входящие в рамку, перемещаются.
  • Объекты, пересекаемые рамкой, растягиваются.
  • Объекты, находящиеся внутри рамки или пересекаемые ей, но не входящие в набор объектов, не растягиваются и не перемещаются.
  • Объекты за пределами рамки, входящие в набор, перемещаются.

В следующем примере рамка растягивания указана пунктирной линией, а набор объектов выделен с помощью эффекта ореола. Несмотря на то, что верхняя окружность заключена в рамку растяжения, она не входит в набор объектов, поэтому не будет перемещаться. Нижняя окружность полностью входит в рамку растягивания и в набор объектов, поэтому она будет перемещаться. Прямоугольник пересекается рамкой растягивания и входит в набор объектов, поэтому он будет растягиваться.

Во вхождении динамического блока, если с помощью ручки или палитры свойств изменяется значение параметра, связанного с операцией растягивания, это может повлиять на ключевую точку в параметре, связанную с операцией растягивания. При воздействии на ключевую точку геометрия в наборе операции растяжения будет перемещаться.

Задание свойства "Тип расстояния" для операции растягивания

Если операция растягивания связана с параметром XY, то она имеет свойство переопределения Тип расстояния. Это свойство определяет, является ли примененное расстояние для перемещения значением X, значением Y или значениями координат X и Y от базовой точки параметра.

Например, в описании динамических блоков в качестве типа расстояния задается расстояние X для операции растягивания. На чертеже, если выполняется попытка изменить вхождение блока путем перетаскивания ключевой точки только вдоль оси Y, то связанная геометрия не перемещается, так как добавлено переопределение типа расстояния, которое позволяет только перемещение по оси X.

См. также

    • Использование переопределения для коэффициента расстояния и смещения угла


Используйте операцию растягивания в динамическом блоке (Процедура)

Использование операций масштабирования в динамическом блоке
На уровень вверх ..
Используйте операцию растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию растягивания в динамическом блоке >
Используйте операцию растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции растягивания в определение блока

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY


Для добавления операции растягивания в определение блока (Процедура)

Используйте операцию растягивания в динамическом блоке
На уровень вверх ..
Используйте операцию растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию растягивания в динамическом блоке >
Используйте операцию растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции растягивания в определение блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция растягивания".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией перемещения можно связать следующие типы параметров: точка, линейный, полярный и XY.)

    Если выполняется связка операции растягивания с параметром точки, перейдите к шагу 4.

  3. Выполните одно из следующих действий для выбора точки параметра для связывания с операцией:
    • Используйте указывающее устройство.
    • Отвечайте на запросы команды.
  4. Выполните одно из следующих действий, чтобы задать первый угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий, чтобы задать противоположный угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  6. Выберите объекты для набора операции.
  7. Нажать ENTER.
  8. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать коэффициент расстояния и угловое смещение.
  9. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
      Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  10. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  11. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY (Процедура)

Используйте операцию растягивания в динамическом блоке
На уровень вверх ..
Используйте операцию полярного растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию растягивания в динамическом блоке >
Используйте операцию растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Для указания свойства "Тип расстояния" для операции растягивания, связанной с параметром XY

  1. В редакторе блоков выберите операцию растягивания, связанную с параметром XY.
  2. На палитре "Свойства" в области "Переопределения" в поле "Тип расстояния" в раскрывающемся списке выберите параметр.

В зависимости от применяемого переопределения операция растягивания для этого блока ограничена осью X, осью Y или обеими осями.


Используйте операцию растягивания в динамическом блоке (Краткий справочник)

Использование операций масштабирования в динамическом блоке
Используйте операцию растягивания в динамическом блоке
Используйте операцию полярного растягивания в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию растягивания в динамическом блоке >
Используйте операцию растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Используйте операцию полярного растягивания в динамическом блоке (Понятие)

Используйте операцию растягивания в динамическом блоке
Использование операций с динамическими блоками
Используйте операцию поворота в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Используйте операцию полярного растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Во вхождении динамического блока операция полярного растягивания вращает, перемещает и растягивает объекты на указанный угол и расстояние.

Во вхождении блока операция полярного растягивания поворачивает, перемещает и растягивает объекты на указанный угол и расстояние, если ключевая точка в связанном полярном параметре изменяется с помощью ручки или палитры свойств.

В описании динамического блока операцию полярного растягивания можно связать только с полярным параметром: Базовая точка для части растяжения операции - это точка параметра, а не ключевая точка.

После связывания операции полярного растягивания с полярным параметром можно указать рамку растягивания для этой операции. Затем выбираются объекты для растяжения и объекты для вращения.

  • Объекты, полностью входящие в рамку, перемещаются.
  • Объекты, пересекаемые рамкой, растягиваются.
  • Объекты в наборе объектов операции, указанные только для вращения, не растягиваются.
  • Объекты, полностью входящие в рамку, перемещаются линейно после поворота.
  • Объекты, пересекаемые рамкой, растягиваются линейно после поворота.
  • Объекты, находящиеся внутри рамки или пересекаемые ей, но не входящие в набор объектов, не растягиваются и не поворачиваются.
  • Объекты за пределами рамки, входящие в набор, перемещаются.

В следующем примере рамка растягивания указана пунктирной линией, а набор объектов выделен с помощью эффекта ореола. Несмотря на то, что верхняя окружность заключена в рамку растяжения, она не входит в набор объектов, поэтому не будет перемещаться. Нижняя окружность полностью входит в рамку растягивания и в набор объектов растяжения, поэтому она будет перемещаться. Прямоугольник пересекается рамкой растягивания и входит в набор объектов, поэтому он будет растягиваться. Квадрат полностью входит в рамку растяжения и в набор объектов поворота, но не в набор объектов растягивания, он будет только вращаться.

Во вхождении динамического блока, если с помощью ручки или палитры свойств изменяется значение параметра, связанного с операцией полярного растягивания, это может повлиять на ключевую точку в параметре, связанную с операцией полярного растяжения. При воздействии на ключевую точку геометрия в наборе операции полярного растяжения будет перемещаться или вращаться в зависимости от способа определения блока.

Примечание Если требуется, чтобы вращались только объекты во вхождении блока, не включайте никакие объекты в рамку растяжения.
См. также

    • Использование переопределения для коэффициента расстояния и смещения угла


Для добавления операции полярного растягивания в определение блока (Процедура)

Используйте операцию растягивания в динамическом блоке
На уровень вверх ..
Используйте операцию поворота в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию полярного растягивания в динамическом блоке >
Используйте операцию полярного растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции полярного растягивания в определение блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция растягивания".
  2. В области рисования редактора блоков выберите полярный параметр для связывания с операцией. (Операцию полярного растягивания можно связать только с полярным параметром.)
  3. Выполните одно из следующих действий для выбора точки параметра для связывания с операцией:
    • Используйте указывающее устройство.
    • Отвечайте на запросы команды.
  4. Выполните одно из следующих действий, чтобы задать первый угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  5. Выполните одно из следующих действий, чтобы задать противоположный угол рамки растягивания:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
  6. Выберите объекты для растяжения или перемещения.
  7. Нажать ENTER.
  8. Выберите объекты для поворота.

    (Выбранные в шагах 6 и 8 объекты входят в набор операции полярного растяжения.)

  9. Нажать ENTER.
  10. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать расстояние и смещение.
  11. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
    Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  12. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  13. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Используйте операцию полярного растягивания в динамическом блоке (Краткий справочник)

Используйте операцию растягивания в динамическом блоке
Используйте операцию полярного растягивания в динамическом блоке
Используйте операцию поворота в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию полярного растягивания в динамическом блоке >
Используйте операцию полярного растягивания в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Используйте операцию поворота в динамическом блоке (Понятие)

Используйте операцию полярного растягивания в динамическом блоке
Использование операций с динамическими блоками
Используйте операцию отражения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Используйте операцию поворота в динамическом блоке
Понятие Процедура Краткий справочник

Во вхождении динамического блока действие операции поворота подобно действию команды ПОВЕРНУТЬ.

Действие операции поворота подобно действию команды ПОВЕРНУТЬ. Во вхождении динамического блока операция поворота приводит к повороту связанных объектов при редактировании связанного параметра с помощью ручки или палитры свойств.

В описании динамического блока операцию поворота можно связать только с параметром поворота: Операция поворота связана с целым параметром, а не с ключевой точкой параметра.

После связи операции поворота с параметром поворота, операция связывается с набором объектов геометрии.

Укажите тип базовой точки для операции поворота

Операция поворота содержит свойство Тип базы. С помощью этого свойства можно указать, является ли базовая точка поворота базовой точки параметра или независимой базовой точкой, которая указывается в описании блока.

По умолчанию тип базы зависимый. Это означает, что блок вращается вокруг связанной базовой точки параметра поворота. В следующем примере блок стула содержит параметр поворота и связанную операцию поворота. Операция поворота имеет зависимый типы базы. Базовая точка параметра - это центр стула. Поэтому стул вращается вокруг центральной точки.

При выборе независимого типа базы можно указать базовую точку для операции поворота, которая отличается от базовой точки связанного параметра поворота. Эта независимая базовая точка показана в редакторе блоков как маркер X. Местоположение независимой базовой точки можно изменять путем ее перетаскивания или изменения значений "База X" и "База Y" в разделе "Переопределения" палитры свойств.

В следующем примере блок стула содержит параметр поворота и связанную операцию поворота. Операция поворота имеет независимый типы базы. Независимая базовая точка расположена в левом нижнем углу стула. Поэтому стул вращается вокруг левого нижнего угла.

В следующем примере каждый из трех прямоугольников во вхождении динамического блока вращается вокруг независимой базовой точки, расположенной в левом нижнем углу каждого четырехугольника. Для этого задается один параметр поворота. Затем добавляются три операции поворота. Каждая операция поворота связана с параметром поворота. Каждая операция поворота затем связывается с отдельным объектом и для него назначается отдельная независимая базовая точка.

Такие результаты можно получить, используя для каждой операции поворота зависимые базовые точки, каждая из которых имеет отдельное смещение базы. Однако, если требуется переместить прямоугольники независимо друг от друга (например с помощью полярного параметра или параметра XY и операции перемещения) во вхождении блока, необходимо использовать независимые базовые точки для операций поворота, так как в противном случае объекты будут вращаться неправильно.


Для добавления операции поворота в определение блока (Процедура)

Используйте операцию полярного растягивания в динамическом блоке
На уровень вверх ..
Используйте операцию отражения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию поворота в динамическом блоке >
Используйте операцию поворота в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции поворота в определение блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операцию поворота".
  2. В области рисования редактора блоков выберите параметр поворота для связывания с операцией. (Операцию поворота можно связать только с параметром поворота.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать тип базовой точки.
  6. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
      Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  7. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  8. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Используйте операцию поворота в динамическом блоке (Краткий справочник)

Используйте операцию полярного растягивания в динамическом блоке
Используйте операцию поворота в динамическом блоке
Используйте операцию отражения в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию поворота в динамическом блоке >
Используйте операцию поворота в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Используйте операцию отражения в динамическом блоке (Понятие)

Используйте операцию поворота в динамическом блоке
Использование операций с динамическими блоками
Используйте операцию с массивом в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Используйте операцию отражения в динамическом блоке
Понятие Процедура Краткий справочник

Операция отражения позволяет выполнять отражение вхождения динамического блока относительно указанной оси, которая называется линией отражения.

Во вхождении динамического блока операция отражения приводит к отражению связанного набора объектов вокруг оси, которая называется линией отражения, при редактировании связанного параметра с помощью ручки или палитры свойств.

В описании динамического блока операцию отражения можно связать только с параметром отражения: Операция отражения связана с целым параметром, а не с ключевой точкой параметра. После связи операции отражения с параметром отражения, операция связывается с набором объектов геометрии. Только отдельные объекты будут отражаться относительно линии отражения.

Например, на следующем чертеже полилиния между двумя окружностями на включена в набора операции отражения При отражении вхождения блока полилиния не отражается с остальной геометрией.


Для добавления операции отражения в определение блока (Процедура)

Используйте операцию поворота в динамическом блоке
На уровень вверх ..
Используйте операцию с массивом в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию отражения в динамическом блоке >
Используйте операцию отражения в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции отражения в определение блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция отражения".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (Операцию отражения можно связать только с параметром отражения.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
      Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  6. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Используйте операцию отражения в динамическом блоке (Краткий справочник)

Используйте операцию поворота в динамическом блоке
Используйте операцию отражения в динамическом блоке
Используйте операцию с массивом в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию отражения в динамическом блоке >
Используйте операцию отражения в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Используйте операцию с массивом в динамическом блоке (Понятие)

Используйте операцию отражения в динамическом блоке
Использование операций с динамическими блоками
Использование операции поиска в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Используйте операцию с массивом в динамическом блоке
Понятие Процедура Краткий справочник

Во вхождении динамического блока операция с массивом приводит к копированию и созданию массивов в прямоугольном массиве при редактировании связанного параметра с помощью ручки или палитры свойств.

В описании динамического блока операцию с массивом можно связать с любым из следующих параметров:

  • Линейный
  • Полярная
  • XY

После связи операцию с массивом с параметром отражения, операция связывается с набором объектов геометрии.

Укажите ряды и столбцы для операции с массивом

При связывании операции с массивом с линейным или полярным параметром указывается расстояние между столбцами для элементов массива. Расстояние между столбцами определяет расстояние между элементами массива. При изменении параметра во вхождении блока расстояние параметра (от базовой до второй точки) делится на расстояние между столбцами для определения числа столбцов (числа объектов).

Например, можно связать операцию с массивом с линейным параметром. Задано значение 2 расстояния между столбцами, которое имеет операция с массивом. При изменении линейного параметра во вхождении динамического блока для расстояния 10, число столбцов для вхождения блока равно 5.

При связывании операции с массивом с параметром XY также указывается расстояние между строками.

Включение параметров в набор объектов операции с массивом

Если включить параметр в набор объектов операции с массивом, это не повлияет на работу вхождения блока. Параметр не копируется вместе с другими объектами в наборе объектов. Дополнительные ручки не отображаются во вхождении блока.

В следующем примере блок места парковки можно занести в массив, чтобы в нем могло быть любое количество мест. Вертикальную строку можно повернуть. Обратите внимание, что после занесения блока в массив он по-прежнему содержит только одну ручку поворота.

Однако при изменении ручки для параметра, включенного в набор объектов операции с массивом, выполняется связанная с параметром операция для всех вхождений объектов. То же самое происходит, если параметр не включен в набор объектов операции с массивом.

Использование операции поворота и операции с массивом в одном динамическом блоке

Динамический блок может содержать операцию с массивом и операцию поворота, воздействующие на один и тот же набор объектов. Порядок, в котором вхождение блока заносится в массив и поворачивается, влияет на отображение блока.

Если сначала повернуть блок, в затем занести его в массив, то все экземпляры элементов массива будут отдельно повернуты вокруг собственной базовой точки.

Если сначала занести блок в массив, а затем повернуть его, то все экземпляры элементов массива будут повернуты вокруг одной базовой точки.


Чтобы добавить в определение блока операцию с массивом (Процедура)

Используйте операцию отражения в динамическом блоке
На уровень вверх ..
Использование операции поиска в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию с массивом в динамическом блоке >
Используйте операцию с массивом в динамическом блоке
Понятие Процедура Краткий справочник

Чтобы добавить в определение блока операцию с массивом

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция с массивом".
  2. В области рисования редактора блоков выберите параметр, который необходимо связать с операцией. (С операцией с массивом можно связать линейные, полярные параметры и параметры XY.)
  3. Выберите объекты (набор), чтобы связать с этой операцией.
  4. Нажать ENTER.
  5. При связывании операции с массивом с параметром XY выполните одно из следующих действий:
    • Расстояние между строками.
    • Укажите ячейку единицы, введя через запятую два значения или выбрав две противоположные точки прямоугольника в обрасти чертежа, а затем перейдите к шагу 7.
  6. Введите значение расстояния между столбцами.
  7. В случае назначения операции с массивом для параметра XY введите расстояние между строками.
  8. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
      Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  9. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  10. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Используйте операцию с массивом в динамическом блоке (Краткий справочник)

Используйте операцию отражения в динамическом блоке
Используйте операцию с массивом в динамическом блоке
Использование операции поиска в динамическом блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Используйте операцию с массивом в динамическом блоке >
Используйте операцию с массивом в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование операции поиска в динамическом блоке (Понятие)

Используйте операцию с массивом в динамическом блоке
Использование операций с динамическими блоками
Использование переопределения для коэффициента расстояния и смещения угла
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Использование операции поиска в динамическом блоке
Понятие Процедура Краткий справочник

При добавлении операции поиска в описание динамического блока и связывании ее с параметром выбора создается таблица выбора. Можно использовать таблицу выбора для назначения свойств настройки и значений динамического блока.

Для получения сведений о добавлении таблиц выбора в динамические блоки, см. раздел Использование таблицы выбора для назначения данных для динамических блоков .


Для добавления операции поиска в описание динамических блоков (Процедура)

Используйте операцию с массивом в динамическом блоке
На уровень вверх ..
Использование переопределения для коэффициента расстояния и смещения угла
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операции поиска в динамическом блоке >
Использование операции поиска в динамическом блоке
Понятие Процедура Краткий справочник

Для добавления операции поиска в описание динамических блоков

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Операции" выберите инструмент "Операция поиска".
  2. В области рисования редактора блоков выберите один или несколько параметров выбора, которые необходимо связать с операцией. (Операцию поиска можно связать только с параметрами выбора.)
  3. Выполните одно из следующих действий, чтобы задать местоположение операции:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.
      Примечание Местоположение операции в описании блока не влияет на внешний вид или функциональные возможности вхождения блока.
  4. В диалоговом окне "Таблица выбора свойств", если необходимо, заполните таблицу.
  5. Нажать "ОК".
  6. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  7. Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКРЕАКТ


Использование операции поиска в динамическом блоке (Краткий справочник)

Используйте операцию с массивом в динамическом блоке
Использование операции поиска в динамическом блоке
Использование переопределения для коэффициента расстояния и смещения угла
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование операции поиска в динамическом блоке >
Использование операции поиска в динамическом блоке
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

БЛОКТАБЛВЫБ

Отображение или создание таблицы выбора для описания динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование переопределения для коэффициента расстояния и смещения угла (Понятие)

Использование операции поиска в динамическом блоке
Использование операций с динамическими блоками
Использование наборов параметров
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками >
Использование переопределения для коэффициента расстояния и смещения угла
Понятие Процедура Краткий справочник

В некоторых операциях используются свойства переопределения коэффициента расстояния и смещения угла. Эти свойства позволяют задать коэффициент, на который увеличивается или уменьшается значение параметра при его изменении во вхождении динамического блока.

В некоторых операциях используются свойства переопределения коэффициента расстояния и смещения угла. Эти свойства позволяют задать коэффициент, на который увеличивается или уменьшается значение параметра при его изменении во вхождении динамического блока.

Действие переопределяет свойства операций. Однако они не оказывают влияния на вхождение блока, пока оно не будет обработано в чертеже. Существует два типа переопределения операций: коэффициент расстояния и смещение угла.

  • Коэффициент расстояния. Свойство коэффициента расстояния используется для изменения значения параметра на заданный коэффициент. Например, если для свойства коэффициента расстояния установить значение 2, чтобы выполнить операцию растягивания, соответствующая геометрия во вхождении блока будет увеличена, а расстояние движения ручки будет удвоено.
  • Смещение угла. Свойство смещения угла используется для увеличения или уменьшения угла изменяемого значения параметра на заданную величину. Например, если для свойства смещения угла в операцию перемещения установить значение 90, вхождение блока переместится на 90 градусов от значения угла перемещения ручки.

Эти свойства переопределения операций можно задавать, следуя подсказкам в командной строке, в ходе добавления операции в описание динамического блока. Можно также указать эти свойства в палитре свойств при выборе операции в редакторе блоков.

В следующей таблице представлены возможные свойства переопределения для каждого типа операции.

Тип операции | Возможные свойства переопределения
Перенести | Коэффициент расстояния, смещение угла
Масштаб | Нет
Растянуть | Коэффициент расстояния, смещение угла
Полярное растяжение | Коэффициент расстояния, смещение угла
Поворот | Нет
Отразить | Нет
Массив | Нет
Поискать | Нет


Использование переопределения для коэффициента расстояния и смещения угла (Процедура)

Использование операции поиска в динамическом блоке
На уровень вверх ..
Использование переопределения для коэффициента расстояния и смещения угла
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование переопределения для коэффициента расстояния и смещения угла >
Использование переопределения для коэффициента расстояния и смещения угла
Понятие Процедура Краткий справочник

Задание переопределения коэффициента расстояния для операции

Задание переопределения смещения угла для операции


Задание переопределения коэффициента расстояния для операции (Процедура)

Использование переопределения для коэффициента расстояния и смещения угла
На уровень вверх ..
Использование переопределения для коэффициента расстояния и смещения угла
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование переопределения для коэффициента расстояния и смещения угла >
Использование переопределения для коэффициента расстояния и смещения угла
Понятие Процедура Краткий справочник

Задание переопределения коэффициента расстояния для операции

  1. В редакторе блоков выберите операцию перемещения, растягивания, полярного растягивания или операции с массивом.
  2. На палитре "Свойства" в области "Переопределения" в поле "Коэффициент расстояния" введите значение.
  3. Нажать ENTER.


Задание переопределения смещения угла для операции (Процедура)

Использование переопределения для коэффициента расстояния и смещения угла
На уровень вверх ..
Использование наборов параметров
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование переопределения для коэффициента расстояния и смещения угла >
Использование переопределения для коэффициента расстояния и смещения угла
Понятие Процедура Краткий справочник

Задание переопределения смещения угла для операции

  1. В редакторе блоков выберите операцию перемещения, растягивания, полярного растягивания.
  2. На палитре "Свойства" в области "Переопределения" в поле "Смещение угла" введите значение.
  3. Нажать ENTER.


Использование переопределения для коэффициента расстояния и смещения угла (Краткий справочник)

Использование операции поиска в динамическом блоке
Использование переопределения для коэффициента расстояния и смещения угла
Использование наборов параметров
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование операций с динамическими блоками > Использование переопределения для коэффициента расстояния и смещения угла >
Использование переопределения для коэффициента расстояния и смещения угла
Понятие Процедура Краткий справочник

Команды

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕД

Открытие определения блока в редакторе блоков

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование наборов параметров (Понятие)

Использование переопределения для коэффициента расстояния и смещения угла
Добавление в блоки динамических элементов
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Использование наборов параметров
Понятие Процедура Краткий справочник

Для добавления чаще всего парных параметров и операций в описание динамических блоков пользуйтесь вкладкой "Наборы параметров" окна "Палитры вариации блоков".

Для добавления чаще всего парных параметров и операций в описание динамических блоков пользуйтесь вкладкой "Наборы параметров" окна "Палитры вариации блоков".

Набор параметров добавляется в блок таким же образом, как и параметр. Операция, внесенная в набор параметров, автоматически добавляется в определение блока и связывается с добавленным параметром. Затем необходимо связать набор объектов (геометрию) с каждым действием.

При первом добавлении набора параметров в описание динамического блока, рядом с каждой операцией будет отображаться желтый значок предупреждения. Это указывает на то, что необходимо связать набор объектов с каждой операцией. Дважды щелкните желтый значок предупреждения (или используйте команду БЛОКРЕАКТНАБОР) и следуйте подсказкам в командной строке, чтобы связать операцию с набором объектов.

Примечание Когда пользователь вставляет набор параметров выбора и дважды щелкает желтый значок предупреждения, отображается диалоговое окно "Таблица выбора свойств". Операции поиска связываются с данными, добавляемыми в эту таблицу, а не с набором объектов.

В приведенной ниже таблице перечислены наборы параметров, предложенные на вкладке "Наборы параметров" окна "Палитры вариации блоков".

Набор параметров | Описание
Перемещение точки | Добавляет параметр точки с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Линейное перемещение | Добавляет линейный параметр с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Линейное растяжение | Добавляет линейный параметр с одной ручкой и связанную с ним операцию растягивания в описание динамического блока.
Линейный массив | Добавляет линейный параметр с одной ручкой и связанную с ним операцию с массивом в описание динамического блока.
Пара линейных перемещений | Добавляет линейный параметр с двумя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Пара линейных растяжений | Добавляет линейный параметр с двумя ручками и операцию растягивания, связанную с каждой ручкой, в описание динамического блока.
Полярное перемещение | Добавляет полярный параметр с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Полярное растяжение | Добавляет полярный параметр с одной ручкой и связанную с ним операцию растягивания в описание динамического блока.
Круговой массив | Добавляет полярный параметр с одной ручкой и связанную с ним операцию с массивом в описание динамического блока.
Пара полярных перемещений | Добавляет полярный параметр с двумя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Пара полярных растяжений | Добавляет полярный параметр с двумя ручками и операцию растягивания, связанную с каждой ручкой, в описание динамического блока.
Перемещение XY | Добавляет параметр XY с одной ручкой и связанную с ним операцию перемещения в описание динамического блока.
Пара перемещений XY | Добавляет параметр XY с двумя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Набор рамок перемещения XY | Добавляет параметр XY с четырьмя ручками и операцию перемещения, связанную с каждой ручкой, в описание динамического блока.
Набор рамок растяжения XY | Добавляет параметр XY с четырьмя ручками и операцию растягивания, связанную с каждой ручкой, в описание динамического блока.
Набор рамок массива XY | Добавляет параметр XY с четырьмя ручками и операцию с массивом, связанную с каждой ручкой, в описание динамического блока.
Поворот | Добавляет параметр поворота с одной ручкой и связанную с ним операцию поворота в описание динамического блока.
Отразить | Добавляет параметр отражения с одной ручкой и связанную с ним операцию отражения в описание динамического блока.
Видимость | Добавляет параметр видимости с одной ручкой. Параметр видимости не требует никаких операций.
Поискать | Добавляет параметр выбора с одной ручкой и операцию поиска в описание динамического блока.
См. также

    • Использование палитр вариации блоков


Добавление набора параметров в описание динамического блока (Процедура)

Использование переопределения для коэффициента расстояния и смещения угла
На уровень вверх ..
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование наборов параметров >
Использование наборов параметров
Понятие Процедура Краткий справочник

Добавление набора параметров в описание динамического блока

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Наборы параметров" щелкните набор параметров.
  2. Отвечайте на запросы команды.
  3. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Использование наборов параметров (Краткий справочник)

Использование переопределения для коэффициента расстояния и смещения угла
Использование наборов параметров
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование наборов параметров >
Использование наборов параметров
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Указание ручек для динамических блоков (Понятие)

Использование наборов параметров
Добавление в блоки динамических элементов
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

При добавлении параметра в описание динамического блока, автоматически добавляются ручки настройки, связанные с ключевыми точками параметра.

При добавлении параметра в описание динамического блока, автоматически добавляются ручки настройки, связанные с ключевыми точками параметра. В чертеже эти ручки настройки можно использовать для выполнения операций с геометрией вхождения динамического блока.

Все параметры (кроме параметра выравнивания, который всегда отображает одну ручку) содержат свойство Число ручек. При выборе параметра в редакторе блоков свойство "Число ручек" отображается в палитре свойств. Это свойство позволяет задавать (в стандартном списке) число ручек, которые требуется отобразить для параметра.

Если задать 0 ручек для параметра, вхождение динамического блока можно по-прежнему редактировать с помощью палитры свойств (если блок определен этим способом).

Если описание динамического блока содержит состояния видимости или таблицу выбора, можно описать блок таким образом, чтобы отображалась только ручка выбора. Если щелкнуть эту ручку во вхождении блока, отобразится раскрывающийся список. При выборе элемента из этого списка отображение вхождения блока может измениться.

Ручки добавляются автоматически в ключевых точках в параметре. Положение ручки можно изменить, то есть ее можно поместить в любом месте блока относительно связанной с ней ключевой точки в параметре. При изменении положения ручки она остается связанной с ключевой точкой, соотнесенной с ней. Независимо от того, где отображается ручка во вхождении блока, она по-прежнему будет манипулировать связанной с ней ключевой точкой. В случае перемещения или изменения ключевой точки параметра, положение ручки относительно ключевой точки будет сохранено. Поскольку ручки используются для манипулирования вхождением динамического блока в чертеже, необходимо убедиться, что каждая ручка размещена в логическом местоположении. Если ручка не размещена в логическом местоположении, существует вероятность непредвиденного поведения.

И линейные, и полярные параметры могут отображать две, одну или ни одной ручки. Если пользователь указывает, что линейный или полярный параметр отображается с одной ручкой, она отображается в конечной точке параметра. Если планируется, что будет отображаться только одна ручка, следует назначать операции только для конечной точки любого из этих параметров. Иначе невозможно будет манипулировать вхождением (запускать операции), потому что ручка не будет отображаться для ключевой точки, связанной с операцией.

Если пользователь изменяет положение ручки для динамического блока, он может использовать команду БЛОКНАБРУЧ, чтобы восстановить ручки в местоположениях по умолчанию.

Тип параметра, добавляемого в описание динамического блока, определяет тип ручек, добавляемых в блок. Эти ручки предоставляют визуальные ключи в отношении способа манипулирования вхождением блока в чертеже. В следующей таблице приведены типы ручек, используемых в динамических блоках, их внешний вид и параметры, с которыми они связаны.

Тип ручки | Манипулирование ручкой в чертеже | Связанные параметры
Стандартный | В пределах плоскости в любом направлении | База, Точка, Линейный, Полярный и XY
Линейный | Назад и вперед в определенном направлении или вдоль оси | Линейный
Поворот | Вокруг оси | Поворот
Отразить | Щелкните для отражения вхождения динамического блока | Отразить
Выравнивание | В пределах плоскости в любом направлении; при перемещении над объектом вхождение блока выравнивается по объекту | Выравнивание
Поискать | Щелкните для отображения списка элементов | Видимость, поиск

Задание параметров всплывающих подсказок на ручках

Все параметры динамического блока, кроме параметров базовой точки и выравнивания, имеет одно или несколько полей описания. Эти описания действуют в качестве всплывающих подсказок или запросов (для соответствующих параметрах) , а их отображением управляет системная переменная GRIPTIPS.

В следующей таблице показаны параметры динамических блоков и доступные для них описания.

Параметр | Описание
Точка | Описание положения
Линейный | Описание расстояния
Полярная | Описание расстояния, описание угла
XY | Описание расстояния по горизонтали, описание расстояния по вертикали
Поворот | Описание угла
Отразить | Описание отражения
Видимость | Описание видимости
Поискать | Описание поиска
Выравнивание | Включить "Выравнивание блока по объекту"
Базовая точка | Специальные подсказки не требуются

Указать циклическую вставку для ручек в динамических блоках

Ручки в динамических блоках имеют свойство Циклический перебор. Если для этого свойства задано значение "Да", то ручка становится доступной точкой вставки для вхождения динамического блока. Для включения или отключения циклического перебора ручек в динамических блоках, а также задания порядка их циклического перебора можно использовать команду БПОРЦИКЛ. При вставке вхождения динамического блока в чертеж можно использовать клавишу CTRL для циклического перемещения по имеющимся ручкам с целью выбора, какая ручка будет точкой вставки для блока.


Указание ручек для динамических блоков (Процедура)

Использование наборов параметров
На уровень вверх ..
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание ручек для динамических блоков >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

Чтобы переместить ручку в описании динамического блока

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке


Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке (Процедура)

Указание ручек для динамических блоков
На уровень вверх ..
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание ручек для динамических блоков >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

Для указания количества специальных ручек, отображаемых для параметра в динамическом блоке

  1. В редакторе блоков выберите параметр.
  2. На палитре свойств в разделе "Разное" щелкните "Число ручек", а затем выберите число ручек, которое должно отображаться для параметра.
  3. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Ввод команды: БЛОКНАБРУЧ
Контекстное меню: В редакторе блоков выберите параметр. Нажмите в области рисования правой кнопкой мыши. Выберите "Отображение ручки" [image] любое значение .


Чтобы переместить ручку в описании динамического блока (Процедура)

Указание ручек для динамических блоков
На уровень вверх ..
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание ручек для динамических блоков >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

Чтобы переместить ручку в описании динамического блока

  1. В редакторе блоков выберите ручку настройки (не стандартную ручку, связанную с ключевой точкой параметра).
  2. Выполните одно из следующих действий для перемещения ручки:
    • Перетащите ручку в другое место в пространстве блока.
    • В палитре свойств в разделе "Геометрия" введите значения для свойств "База X" и "База Y". (Эти значения указываются относительно базовой точки параметра.)
  3. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Чтобы восстановить для ручек в описании динамического блока положения по умолчанию (Процедура)

Указание ручек для динамических блоков
На уровень вверх ..
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание ручек для динамических блоков >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

Чтобы восстановить для ручек в описании динамического блока положения по умолчанию

  1. В командной строке редактора блоков введите блокнабруч.
  2. Выберите ручку, для которой требуется восстановить положения ручек по умолчанию.
  3. В командной строке введите перемещение и нажмите ENTER.
  4. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Контекстное меню: В редакторе блоков выберите параметр. Нажмите в области рисования правой кнопкой мыши. Выберите "Отображение ручки" [image] "Положение сброса".


Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока (Процедура)

Указание ручек для динамических блоков
На уровень вверх ..
Указание ручек для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание ручек для динамических блоков >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

Чтобы включить или отключить циклический перебор для ручки настройки во вхождении динамического блока

  1. В командной строке редактора блоков введите бпорцикл.
  2. В диалоговом окне "Порядок перебора при вставке" выберите из списка ручку и нажмите "Циклический перебор", чтобы включить или отключить циклический перебор для ручки. (Пометка в столбце "Циклический перебор" означает, что циклический перебор включен для ручки.)
  3. Нажать "ОК".
  4. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Контекстное меню: В редакторе блоков выберите динамическую ручку. Нажмите в области рисования правой кнопкой мыши. Выбрать "Циклическая вставка".


Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке (Процедура)

Указание ручек для динамических блоков
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание ручек для динамических блоков >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

Для изменения порядка перебора при вставке для специальных ручек в динамическом блоке

  1. В командной строке редактора блоков введите бпорцикл.
  2. В диалоговом окне "Порядок перебора при вставке" выберите из списка ручку и нажмите "Вверх" или "Вниз". (Пометка в столбце "Циклическая вставка" означает, что циклическая вставка включена для ручки.)
  3. Повторять шаг 2 пока не изменится порядок циклической вставки ручки.
  4. Нажать "ОК".
  5. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Указание ручек для динамических блоков (Краткий справочник)

Использование наборов параметров
Указание ручек для динамических блоков
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание ручек для динамических блоков >
Указание ручек для динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БПОРЦИКЛ

Изменение порядка циклического перебора ручек для вхождения динамического блока

БЛОКНАБРУЧ

Создание, удаление или сброс ручек, связанных с параметром

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

Системные переменные

GRIPTIPS

Управление отображением подсказок к ручкам при наведении курсора на ручки динамических блоков и пользовательских объектов, поддерживающих подсказки к ручкам

Утилиты

Нет

Ключевые слова для команд

Нет


Создание "Состояния видимости" (Понятие)

Указание ручек для динамических блоков
Добавление в блоки динамических элементов
Использование таблицы выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Можно использовать состояния видимости, чтобы сделать геометрию видимой или невидимой в динамическом блоке. Один блок может иметь несколько состояний видимости.

с помощью состояний видимости можно быстро создать блок, который будет иметь разные графические представления. Можно легко изменить вхождение блока, который имеет разные состояния видимости, для вставки в чертеж.

Например, имеется четыре следующих обозначения сварки.

С помощью состояний видимости можно объединить эти обозначения сварки в один динамический блок. В следующем примере отображена геометрия для четырех обозначений сварки, объединенных в одно описание динамического блока в редакторе блоков.

После объединения геометрии в редакторе блоков, можно добавить параметр видимости. Можно добавить только один параметр видимости к описанию динамического блока. Не связывайте какие-либо действия с параметром видимости.

Затем можно создать и назвать другое состояние видимости для каждого обозначения сварки (например, WLD1, WLD2, WLD3 и WLD4). Для каждого состояния можно сделать определенную геометрию видимой или невидимой. В следующем примере состояние видимости WLD1 отображается в редакторе блоков. Геометрия, которая отображается серым цветом, является невидимой в состоянии видимости WLD1.

Параметр видимости включает ручку выбора. Эта ручка всегда отображается во вхождении блока, который содержит состояния видимости. При нажатии этой ручки во вхождении блока отображается раскрывающийся список всех состояний видимости во вхождении блока. При выборе одного состояния из списка геометрия, которая является видимой для этого состояния, отобразится на чертеже.

На правой стороне панели инструментов редактора блоков отобразится имя текущего состояния видимости. Все блоки имеют хотя бы одно состояние видимости. Нельзя удалить текущее состояние. В этой области панели инструментов находится несколько инструментов для работы с состояниями видимости.

Во время работы с состояниями видимости можно увидеть геометрию, которая является невидимой для данного состояния. Можно использовать кнопку режима видимости (BVMODE) для отображения или скрытия геометрии (серым цветом), которая является невидимой. Если для системной переменной BVMODE установлено значение 1, то геометрия, являющаяся невидимой при заданном состоянии видимости, отображается тусклым цветом.


Создание "Состояния видимости" (Процедура)

Указание ручек для динамических блоков
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для включения состояний видимости (добавить параметр видимости)

Для создания нового состояния видимости на основе текущего состояния

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

Для создания нового состояния видимости, в котором все объекты являются видимыми

Чтобы сделать состояние видимости текущим

Для удаления состояния видимости

Для задания нового имени состоянию видимости

Чтобы сделать объекты видимыми в текущем состоянии видимости

Чтобы сделать объекты видимыми во всех состояниях видимости

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

Чтобы сделать объекты невидимыми во всех состояниях видимости

Для отображения или скрытия невидимой геометрии для состояний видимости.

Для изменения порядка в списке состояний видимости для вхождения динамического блока

Для установки состояния видимости по умолчанию для вхождения динамического блока.


Для включения состояний видимости (добавить параметр видимости) (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для включения состояний видимости (добавить параметр видимости)

  1. В редакторе блоков в окне "Палитры вариации блоков" на вкладке "Параметры" выберите инструмент "Параметр видимости".
  2. (Дополнительно) Следуйте подсказкам в командной строке, чтобы указать для параметра следующее:
    • Имя
    • Метка
    • Описание
    • Свойства, отображаемые для вхождения блока
    Примечание Можно также позднее указать и отредактировать эти свойства в палитре свойств, после добавления параметра в определение блока.
  3. Выполните одно из следующих действий для указания расположения параметра:
    • Используйте указывающее устройство.
    • Через запятую введите значения координат X и Y.

    Это расположение по умолчанию для ручки параметра видимости.

  4. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Для создания нового состояния видимости на основе текущего состояния (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для создания нового состояния видимости на основе текущего состояния

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" щелкните "Новый".
  3. В диалоговом окне "Новое состояние видимости" введите имя для нового состояния видимости.
  4. Выберите "Оставить видимость существующих объектов неизменной".
  5. Нажать "ОК".

Видимость существующих объектов неизменна в новом состоянии.

Ввод команды: БЛОКСОСТВИД


Для создания нового состояния видимости, в котором все объекты являются невидимыми. (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для создания нового состояния видимости, в котором все объекты являются невидимыми.

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" щелкните "Новый".
  3. В диалоговом окне "Новое состояние видимости" введите имя для нового состояния видимости.
  4. Выбрать "Скрыть все существующие объекты".
  5. Нажать "ОК".
Ввод команды: БЛОКСОСТВИД


Для создания нового состояния видимости, в котором все объекты являются видимыми (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для создания нового состояния видимости, в котором все объекты являются видимыми

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" щелкните "Новый".
  3. В диалоговом окне "Новое состояние видимости" введите имя для нового состояния видимости.
  4. Выбрать "Отобразить все существующие объекты".
  5. Нажать "ОК".
Ввод команды: БЛОКСОСТВИД


Чтобы сделать состояние видимости текущим (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Чтобы сделать состояние видимости текущим

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. Выберите состояние видимости, которое необходимо установить как текущее состояние.
Ввод команды: БЛОКСОСТВИД
Контекстное меню: В диалоговом окне "Состояния видимости" щелкните правой кнопкой мыши состояние видимости в списке. Нажать кнопку "Установить".


Для удаления состояния видимости (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для удаления состояния видимости

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Нажать кнопку "Удалить".
  4. Нажать "ОК".
Ввод команды: БЛОКСОСТВИД
Контекстное меню: В диалоговом окне "Состояния видимости" щелкните правой кнопкой мыши состояние видимости в списке. Выберите "Удалить состояние".


Для задания нового имени состоянию видимости (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для задания нового имени состоянию видимости

  1. В редакторе блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Выбрать "Переименовать".
  4. Введите новое имя для состояния видимости.
  5. Нажать "ОК".
Ввод команды: БЛОКСОСТВИД
Контекстное меню: Щелкните правой кнопкой мыши состояние видимости в списке. Щелкните "Переименовать состояние".


Чтобы сделать объекты видимыми в текущем состоянии видимости (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Чтобы сделать объекты видимыми в текущем состоянии видимости

  1. На панели инструментов редактора блоков щелкните "Сделать видимым".
  2. В области рисования выберите объекты, чтобы сделать их видимыми в текущем состоянии видимости.
  3. Нажать ENTER.
  4. В командной строке введите команду текущий.
  5. Нажать ENTER.
Ввод команды: БЛОКПОКАЗАТЬ
Контекстное меню: В области рисования редактора блоков выберите один или несколько объектов. Нажмите в области рисования правой кнопкой мыши. Выберите Видимость объекта [image] Показать для текущего состояния.


Чтобы сделать объекты видимыми во всех состояниях видимости (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Чтобы сделать объекты видимыми во всех состояниях видимости

  1. В области рисования редактора блоков выберите объекты, которые необходимо сделать видимыми во всех состояниях видимости.
  2. Нажмите в области рисования правой кнопкой мыши.
  3. Выберите Видимость объекта [image] Показать для всех состояний.
Ввод команды: БЛОКПОКАЗАТЬ


Чтобы сделать объекты невидимыми в текущем состоянии видимости. (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Чтобы сделать объекты невидимыми в текущем состоянии видимости.

  1. На панели инструментов редактора блоков щелкните "Сделать невидимым".
  2. В области рисования выберите объекты, которые необходимо сделать невидимыми в текущем состоянии видимости.
  3. Нажать ENTER.
  4. В командной строке введите команду текущий.
  5. Нажать ENTER.
Ввод команды: БЛОКСКРЫТЬ
Контекстное меню: В области рисования редактора блоков выберите один или несколько объектов. Нажмите в области рисования правой кнопкой мыши. Выберите Видимость объекта [image] Скрыть для текущего состояния.


Чтобы сделать объекты невидимыми во всех состояниях видимости (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Чтобы сделать объекты невидимыми во всех состояниях видимости

  1. В области рисования выберите объекты, которые необходимо сделать невидимыми во всех состояниях видимости.
  2. Нажмите в области рисования правой кнопкой мыши.
  3. Выберите Видимость объекта [image] Скрыть для всех состояний.
Ввод команды: БЛОКСКРЫТЬ


Для отображения или скрытия невидимой геометрии для состояний видимости. (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для отображения или скрытия невидимой геометрии для состояний видимости.

  • На панели инструментов редактора блоков щелкните "Режим видимости".
Ввод команды: BVMODE


Для изменения порядка в списке состояний видимости для вхождения динамического блока (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Создание "Состояния видимости"
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для изменения порядка в списке состояний видимости для вхождения динамического блока

  1. На панели инструментов редактора блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Щелкните "Вверх" или "Вниз", чтобы изменить порядок.
  4. Повторяйте шаги 2 и 3, пока не выберите правильный порядок в списке состояний видимости.
  5. Нажать "ОК".
Ввод команды: БЛОКСОСТВИД


Для установки состояния видимости по умолчанию для вхождения динамического блока. (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Использование таблицы выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Для установки состояния видимости по умолчанию для вхождения динамического блока.

  1. В редакторе блоков щелкните "Управление состояниями видимости".
  2. В диалоговом окне "Состояния видимости" выберите в списке состояние видимости.
  3. Нажимайте "Вверх" пока выбранное состояние видимости не появится в верхней части списка.
  4. Нажать "ОК".
Ввод команды: БЛОКСОСТВИД


Создание "Состояния видимости" (Краткий справочник)

Указание ручек для динамических блоков
Создание "Состояния видимости"
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Создание "Состояния видимости" >
Создание "Состояния видимости"
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

БЛОКСКРЫТЬ

Делает объекты невидимыми в текущем или во всех состояниях видимости в описании динамического блока

БЛОКПОКАЗАТЬ

Делает объекты видимыми в текущем или во всех состояниях видимости в описании динамического блока

БЛОКСОСТВИД

Создание, установка или удаление состояния видимости в динамическом блоке

Системные переменные

BVMODE

Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока

Утилиты

Нет

Ключевые слова для команд

Нет


Использование таблицы выбора для назначения данных для динамических блоков

Создание "Состояния видимости"
Добавление в блоки динамических элементов
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Использование таблицы выбора для назначения данных для динамических блоков
Понятие Процедура

Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока.

Темы в этом разделе

  • Обзор использования таблиц выбора для назначения данных для динамических блоков

    Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока. При работе с вхождением блока на чертеже значения свойств ассоциируются с изменениями вхождения блока.

  • Указание значений для таблиц выбора

    Когда указываются значения в таблицы выбора, применяются некоторые специальные правила.


Использование таблицы выбора для назначения данных для динамических блоков (Процедура)

Создание "Состояния видимости"
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков >
Использование таблицы выбора для назначения данных для динамических блоков
Понятие Процедура

Для создания таблицы выбора для динамического блока

Для добавления свойств входа в таблицу выбора.

Для добавления свойств поиска в таблицу выбора.

Для добавления значений в таблицу выбора

Для включения обратного поиска

Чтобы сделать свойство поиска только для чтения

Для проверки на наличие ошибок в таблице выбора

Для открытия существующей таблицы выбора


Обзор использования таблиц выбора для назначения данных для динамических блоков (Понятие)

Использование таблицы выбора для назначения данных для динамических блоков
Использование таблицы выбора для назначения данных для динамических блоков
Указание значений для таблиц выбора
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока. При работе с вхождением блока на чертеже значения свойств ассоциируются с изменениями вхождения блока.

Можно использовать таблицу выбора для определения и указания значений свойств для динамического блока. С помощью таблиц выбора можно быстро связать значения параметра для вхождения динамического блока с другими указанными данными (например, номером детали или модели). Данные из вхождений блока на чертеже можно вывести так же, как данные атрибутов блока.

После завершения таблица выбора назначает для вхождения динамического блока значения свойств на основе того, как блоком манипулируют на чертеже. И наоборот, можно изменить способ отображения вхождения блока на чертеже, изменив значение свойства таблицы поиска для вхождения блока с помощью ручки выбора или палитры свойств.

На следующем чертеже отображено вхождение динамического блока для крепления освещения. Для этого блока в области "Настройка" палитры "Свойства" отображается свойство размера. Это свойство определяется в таблице выбора для блока.

Если изменить размер крепления освещения на чертеже (с помощью специальных ручек), также изменится свойство размера в палитре "Свойства".

Можно также использовать ручку выбора для изменения отображения вхождения блока. Если выбрать размер из списка, который отображается при нажатии на ручку, изменится геометрия блока и новый размер отобразится в палитре "Свойства" в списке "Настройка".

Создание таблицы выбора

После того, как нарисована геометрия и добавлены необходимые для работы динамического блока параметры и действия, можно добавить таблицу поиска к определению блока.

Пустая таблица выбора создается, когда добавляется параметр выбора в описание динамического блока, а затем добавляется операция поиска и связывается с параметром выбора. Таблица выбора отображается в диалоговом окне таблицы выбора.

Добавление свойств и значений в таблицу выбора.

Таблица выбора свойств состоит из свойств входа и поиска. Каждое свойство входа и поиска представлено с помощью столбца в таблице.

  • Свойства входа. Параметры, отличные от параметров выбора (например, линейный параметр с ярлыком “Ширина”). В группе "Свойства входа" можно создать столбец для каждого параметра в описании блока, кроме параметров поиска, выравнивания и параметра базовой точки.
  • Свойства поиска. Параметры выбора. Один параметр выбора добавляется к описанию динамического блока для каждого столбца свойства поиска, который необходимо добавить к таблице выбора. Метка параметра выбора используется в качестве имени свойства.

После добавления свойств (столбцов) в таблицу, добавьте значения в ячейки каждого столбца. Щелкните ячейку и введите значение. Убедитесь, что выполняются следующие правила в разделе Указание значений для таблиц выбора.

Если определен набор значений для свойства (параметра) входа в таблице, отобразится раскрывающийся список доступных значений при нажатии ячейки в данном столбце.

Следующая таблица выбора используется для отображенного ранее блока крепления освещения. Линейные параметры с ярлыками “Высота” и “Ширина” были добавлены как свойства входа. “Размер” добавлен как свойство поиска. Значения параметров "Высота" и "Ширина" заимствованы из наборов значений, определенных для каждого из этих параметров. Значения параметра "Размер" вводятся вручную.

Когда значения параметров вхождения динамического блока соответствуют ряду значений свойств входа, значения соответствующего свойства поиска присваиваются этому вхождению блока. Эти параметры и значения поиска отображаются в палитре "Свойства" в списке "Настройка".

Например, при изменении значения высоты вхождения блока крепления освещения на 250 сантиметров и значения ширины на 500 сантиметров свойство "Размер" в области "Настройка" палитры "Свойства" будет иметь значение 0,25 м x 0,50 м.

В таблице выбора в нижней части свойств входа находится ряд с ярлыком <Несоответствующий>. Если значения параметра во вхождении блока не соответствуют ряду значений свойства входа, определенных в таблице поиска блока, значение свойства поиска, которое соответствует ряду <Несоответствующий> назначается вхождению блока. Значением по умолчанию является Настройка, но можно указать другое значение, изменив его в таблице.

Включение обратного поиска

Можно также указать свойство поиска для обратного поиска. Это добавит ручку выбора к вхождению динамического блока. При нажатии этой ручки отображается раскрывающийся список значений поиска для этого свойства поиска (столбец в таблице). При выборе значения из этого списка соответствующие значения свойства входа присваиваются этому вхождению блока. В зависимости от того, как был определен блок, это обычно приводит к изменению геометрии вхождения блока.

Для включения обратного поиска для свойства поиска каждый ряд в таблице выбора должен быть уникальным. После добавления свойств и значений в таблицу можно проверить ее на наличие ошибок и пустых ячеек, нажав кнопку проверки в диалоговом окне "Таблица выбора свойств". Можно также использовать параметры контекстного меню для вставки, удаления и изменения порядка рядов.

Примечание Если оставить ячейку в столбце свойств поиска пустой и если у нее будет связанное свойство входа в том же ряду, свойство поиска не позволит выполнить обратный поиск.
См. также

    • Извлечение данных из атрибутов

    • Извлечение данных из атрибутов (метод низкого уровня)


Обзор использования таблиц выбора для назначения данных для динамических блоков (Процедура)

Использование таблицы выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для создания таблицы выбора для динамического блока

Для добавления свойств входа в таблицу выбора.

Для добавления свойств поиска в таблицу выбора.

Для добавления значений в таблицу выбора

Для включения обратного поиска

Чтобы сделать свойство поиска только для чтения

Для проверки на наличие ошибок в таблице выбора

Для открытия существующей таблицы выбора


Для создания таблицы выбора для динамического блока (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для создания таблицы выбора для динамического блока

  1. В редакторе блоков добавьте один или несколько параметров выбора к описанию динамического блока, выполнив шаги в разделе Чтобы добавить в описание динамического блока параметр выбора.
  2. В редакторе блоков добавьте операцию поиска к описанию динамического блока, выполнив следующие шаги в разделе Для добавления операции поиска в описание динамических блоков .

    Отобразится диалоговое окно "Таблица выбора свойств".

  3. Используйте одну из следующих процедур для настройки таблицы выбора для динамического блока.
    • Для добавления свойств входа в таблицу выбора.
    • Для добавления свойств поиска в таблицу выбора.
    • Для включения обратного поиска
  4. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Редактор блоков
Ввод команды: БЛОКПАРАМ


Для добавления свойств входа в таблицу выбора. (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для добавления свойств входа в таблицу выбора.

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В диалоговом окне "Таблица выбора свойств" щелкните "Добавить свойства".
  3. В нижнем левом углу диалогового окна "Добавление свойств параметров" щелкните "Добавить свойства входа".
  4. В списке "Свойства параметров" выберите свойства параметров, которые необходимо добавить в таблицу выбора. Для выбора нескольких свойств следует удерживать нажатой клавишу CTRL.
  5. Нажать "ОК".
Ввод команды: БЛОКТАБЛВЫБ


Для добавления свойств поиска в таблицу выбора. (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для добавления свойств поиска в таблицу выбора.

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В диалоговом окне "Таблица выбора свойств" щелкните "Добавить свойства".
  3. В нижнем левом углу диалогового окна "Добавление свойств параметров" щелкните "Добавить свойства поиска".
  4. В списке "Свойства параметров" выберите свойства параметров выбора, которые необходимо добавить в таблицу выбора. Для выбора нескольких свойств следует удерживать нажатой клавишу CTRL.
  5. Нажать "ОК".
Ввод команды: БЛОКТАБЛВЫБ


Для добавления значений в таблицу выбора (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для добавления значений в таблицу выбора

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В диалоговом окне "Таблица выбора свойств" щелкните пустую ячейку и выполните одно из следующих действий:
    • Выбрать значение из раскрывающегося списка. (Раскрывающийся список отображается, только если для параметра определен набор значений.)
    • Ввести значение.
  3. Повторить шаг 2, как требуется для заполнения таблицы.
  4. Нажать "ОК".
Ввод команды: БЛОКТАБЛВЫБ


Для включения обратного поиска (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для включения обратного поиска

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В нижней части столбца "Свойство поиска" диалогового окна "Таблица выбора свойств" щелкните "Только чтение" и выберите "Разрешить обратный просмотр" из списка.
    Примечание Можно также выбрать "Разрешить обратный просмотр", если данные введены в столбец.
  3. Нажать "ОК".
Ввод команды: БЛОКТАБЛВЫБ


Чтобы сделать свойство поиска только для чтения (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Чтобы сделать свойство поиска только для чтения

  1. В редакторе блоков дважды щелкните операцию поиска в описании динамического блока.
  2. В нижней части столбца "Свойство поиска" диалогового окна "Таблица выбора свойств" щелкните "Разрешить обратный просмотр" и выберите "Только чтение" из списка.
  3. Нажать "ОК".
Ввод команды: БЛОКТАБЛВЫБ


Для проверки на наличие ошибок в таблице выбора (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор использования таблиц выбора для назначения данных для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для проверки на наличие ошибок в таблице выбора

  • В диалоговом окне "Таблица выбора свойств" нажмите кнопку "Проверить".


Для открытия существующей таблицы выбора (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Указание настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Для открытия существующей таблицы выбора

  • В редакторе блоков дважды щелкните операцию поиска.
Ввод команды: БЛОКТАБЛВЫБ


Обзор использования таблиц выбора для назначения данных для динамических блоков (Краткий справочник)

Создание "Состояния видимости"
Обзор использования таблиц выбора для назначения данных для динамических блоков
Указание значений для таблиц выбора
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Обзор использования таблиц выбора для назначения данных для динамических блоков >
Обзор использования таблиц выбора для назначения данных для динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКТАБЛВЫБ

Отображение или создание таблицы выбора для описания динамического блока

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Указание значений для таблиц выбора (Понятие)

Обзор использования таблиц выбора для назначения данных для динамических блоков
Использование таблицы выбора для назначения данных для динамических блоков
Указание настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков >
Указание значений для таблиц выбора
Понятие Краткий справочник

Когда указываются значения в таблицы выбора, применяются некоторые специальные правила.

Когда указываются значения в таблицы выбора, применяются следующие правила:

  • Использовать запятую при разделении значений.
  • Можно указать любое число уникальных значений, разделенное запятой. Например: 5,6,7 5.5,6.25
  • Для указания диапазона используйте квадратные скобки [ ], чтобы обозначить, что диапазон включает значения, разделенные запятой, или используйте круглые скобки ( ), чтобы обозначить, что в диапазон не входят значения, разделенные запятой.
  • Для непрерывного диапазона используйте пару значений, разделенных запятой и включенных в квадратные или круглые скобки. Например: [3,10] указывает любое значение между 3 и 10, включая 3 и 10; (3,10) указывает любое значение между 3 и 10, не включая 3 и 10.
  • Для неограниченного вторым значением диапазона используйте одно значение с запятой, включенное в квадратные или круглые скобки. Например: [,5] указывает значение меньше или равное 5; (5,) указывает значение больше 5.
  • Используйте не более, чем 256 символов в ячейке таблицы.
  • Можно использовать архитектурный и технический синтаксис для единицы (например, 15'1/4").
  • Если ввести значение в неверном формате, произойдет возврат последнего значения при переходе к другой ячейке в таблице.

Таблицы выбора поддерживают следующее:

  • Все свойства числовых параметров (например, параметры расстояния и углов для точки, линейные, полярные параметры, параметры XY и поворота)
  • Свойства параметра текстовой строки (например, значения параметров отражения и видимости)


Указание значений для таблиц выбора (Краткий справочник)

Обзор использования таблиц выбора для назначения данных для динамических блоков
Указание значений для таблиц выбора
Обзор настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Использование таблицы выбора для назначения данных для динамических блоков > Указание значений для таблиц выбора >
Указание значений для таблиц выбора
Понятие Краткий справочник

Команды

БЛОКТАБЛВЫБ

Отображение или создание таблицы выбора для описания динамического блока

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Указание настраиваемых свойств для динамических блоков

Указание значений для таблиц выбора
Добавление в блоки динамических элементов
Обзор настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Указание настраиваемых свойств для динамических блоков
Понятие Процедура

При создании динамического блока можно указать настраиваемые свойства для блока. Можно также указать, должны ли эти свойства отображаться в палитре "Свойства" при выборе вхождения блока на чертеже.

Темы в этом разделе

  • Обзор настраиваемых свойств для динамических блоков
  • Указание наборов значений для динамических блоков

    Можно указать определенный набор значений для линейных, полярных параметров, а также параметров XY и поворота.

  • Разрешение цепочки операций для динамических блоков

    Параметры точки, поворота, XY, а также линейные и полярные параметры имеют свойство под названием Цепочка операций. Это свойство влияет на параметра, если параметр является частью набора операций.


Указание настраиваемых свойств для динамических блоков (Процедура)

Обзор использования таблиц выбора для назначения данных для динамических блоков
На уровень вверх ..
Обзор настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков >
Указание настраиваемых свойств для динамических блоков
Понятие Процедура

Для указания метки параметра

Для указания отображения настраиваемых свойств во вхождении динамического блока.

Процедура задания режима, в котором возможно расчленение ссылки на динамический блок

Для запрета неоднородного масштабирования во вхождении динамического блока.

Для указания набора значений для линейного или полярного параметра

Для указания набора значений для параметра XY

Для указания набора значений для параметра поворота

Для удаления значений из набора значений параметра

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.

Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота


Обзор настраиваемых свойств для динамических блоков (Понятие)

Указание настраиваемых свойств для динамических блоков
Указание настраиваемых свойств для динамических блоков
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков >
Обзор настраиваемых свойств для динамических блоков
Понятие Процедура Краткий справочник

В редакторе блоков можно указать свойства для параметра в описании динамического блока. Некоторые из этих свойств можно отобразить как настраиваемые свойства для вхождения динамического блока, когда он находится на чертеже. Эти свойства отображаются в палитре "Свойства" в списке "Настройка".

В редакторе блоков можно указать метки параметров. При выборе на чертеже вхождения динамического блока эти свойства отображаются в списке "Настройка" в палитре "Свойства". Рекомендуется указать уникальные метки параметров в блоке.

В зависимости от параметров, используемых в описании динамического блока, другие свойства параметров могут быть перечислены в группе "Настройка" в палитре "Свойства" при выборе вхождения динамического блока на чертеже. Например, полярный параметр имеет свойство угла, которое отображается в палитре "Свойства". В зависимости от того, как динамический блок определен, эти свойства могут отображать такие значения, как размер, угол и положение для вхождения выбранного блока.

Можно указать, должны ли эти настраиваемые свойства отображаться для вхождения блока при выборе его на чертеже. Эти свойства можно извлечь с помощью Мастера извлечения атрибутов.

Можно также использовать палитру "Свойства" для указания свойств геометрии (таких, как цвет, тип линии и вес линии) параметра. Эти свойства перечисляются в палитре "Свойства" в списке "Геометрия" при выборе параметра в редакторе блоков.

Другие свойства параметра, например, свойства "Набор значений" и "Цепочка операций", определяют, как вхождение блока будет работать на чертеже.

В редакторе блоков также указывается, можно ли блок расчленить, и может ли он быть со сложным масштабом.

См. также

    • Указание наборов значений для динамических блоков

    • Разрешение цепочки операций для динамических блоков

    • Указание ручек для динамических блоков

    • Извлечение данных из атрибутов


Обзор настраиваемых свойств для динамических блоков (Процедура)

Указание настраиваемых свойств для динамических блоков
На уровень вверх ..
Обзор настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Обзор настраиваемых свойств для динамических блоков >
Обзор настраиваемых свойств для динамических блоков
Понятие Процедура Краткий справочник

Для указания метки параметра

Для указания отображения настраиваемых свойств во вхождении динамического блока.

Процедура задания режима, в котором возможно расчленение ссылки на динамический блок

Для запрета неоднородного масштабирования во вхождении динамического блока.


Для указания метки параметра (Процедура)

Обзор настраиваемых свойств для динамических блоков
На уровень вверх ..
Обзор настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Обзор настраиваемых свойств для динамических блоков >
Обзор настраиваемых свойств для динамических блоков
Понятие Процедура Краткий справочник

Для указания метки параметра

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите параметр.
  3. В палитре "Свойства" группы "Метки свойств" щелкните метку <имя параметра>.
  4. Введите метку для параметра.
  5. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ
Контекстное меню: Щелкнуть правой кнопкой мыши на выбранном объекте. Щелкнуть "Переименовать метку". Введите новое имя для параметра и нажмите ENTER.


Для указания отображения настраиваемых свойств во вхождении динамического блока. (Процедура)

Обзор настраиваемых свойств для динамических блоков
На уровень вверх ..
Обзор настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Обзор настраиваемых свойств для динамических блоков >
Обзор настраиваемых свойств для динамических блоков
Понятие Процедура Краткий справочник

Для указания отображения настраиваемых свойств во вхождении динамического блока.

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите параметр.
  3. В палитре "Свойства" в списке "Разное" щелкните "Показать свойства".
  4. В раскрывающемся списке выполните одно из следующих действий.
    • Выбрать "Да" для отображения настраиваемых свойств для вхождения блока.
    • Выбрать "Нет", чтобы настраиваемые свойства не отображались для вхождения блока.
  5. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Процедура задания режима, в котором возможно расчленение ссылки на динамический блок (Процедура)

Обзор настраиваемых свойств для динамических блоков
На уровень вверх ..
Обзор настраиваемых свойств для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Обзор настраиваемых свойств для динамических блоков >
Обзор настраиваемых свойств для динамических блоков
Понятие Процедура Краткий справочник

Процедура задания режима, в котором возможно расчленение ссылки на динамический блок

  1. Использовать одну из следующих процедур для открытия определения блока в редакторе блоков.
    • Чтобы открыть существующее определение блока в редакторе блоков
    • Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)
    • Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок
  2. Убедитесь, что в редакторе блоков ничего не выбрано.
  3. В палитре "Свойства" в списке "Блок" щелкните "Разрешить расчленение".
  4. В раскрывающемся списке выберите "Да" или "Нет".
  5. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: БЛОКРЕД


Для запрета неоднородного масштабирования во вхождении динамического блока. (Процедура)

Обзор настраиваемых свойств для динамических блоков
На уровень вверх ..
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Обзор настраиваемых свойств для динамических блоков >
Обзор настраиваемых свойств для динамических блоков
Понятие Процедура Краткий справочник

Для запрета неоднородного масштабирования во вхождении динамического блока.

  1. Использовать одну из следующих процедур для открытия определения блока в редакторе блоков.
    • Чтобы открыть существующее определение блока в редакторе блоков
    • Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок (но не динамический)
    • Чтобы открыть в редакторе блоков файл чертежа, сохраненный как блок
  2. Убедитесь, что в редакторе блоков ничего не выбрано.
  3. В палитре "Свойства" в списке "Блок" щелкните "Одинаковый масштаб".
  4. В раскрывающемся списке выберите "Да".
  5. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: БЛОКРЕД


Обзор настраиваемых свойств для динамических блоков (Краткий справочник)

Указание значений для таблиц выбора
Обзор настраиваемых свойств для динамических блоков
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Обзор настраиваемых свойств для динамических блоков >
Обзор настраиваемых свойств для динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Указание наборов значений для динамических блоков (Понятие)

Обзор настраиваемых свойств для динамических блоков
Указание настраиваемых свойств для динамических блоков
Разрешение цепочки операций для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Можно указать определенный набор значений для линейных, полярных параметров, а также параметров XY и поворота.

Набор значений - это диапазон или список значений, указанных для параметра. Эти значения могут быть отображены для вхождения блока как раскрывающийся список рядом с ярлыком параметра в списке "Настройка" в палитре "Свойства". Когда определяется набор значений для параметра, параметр ограничивается до этих значений при манипулировании вхождением блока на чертеже. Например, если определить линейный параметр в блоке, который задает рамку с набором значений 20, 40 и 60, рамку можно растянуть только до 20, 40 или 60 единиц.

При создании списка значений для параметра значение параметра, существующее в описании, автоматически добавляется в набор значений. Это значение является значением по умолчанию для вхождения блока при вставке его в чертеж.

Если изменить во вхождении блока значение параметра на значение, отличное от указанного в списке, будет выбрано ближайшее допустимое значение параметра. Например, определить набор значений линейного параметра, как 2, 4 и 6. Если изменить значение параметра во вхождении блока на 10, в результате будет выбрано 6, поскольку это ближайшее допустимое значение.

Если указать набор значений для параметра в динамическом блоке, отобразятся засечки при редактировании с помощью ручки вхождения блока на чертеже. Засечки означают расположения допустимых значений параметра.

Примечание Если переопределить значения в наборе значений после добавления свойств параметров в таблицу поиска, обязательно обновите таблицу поиска для соответствия новым значениям в наборе значений.


Указание наборов значений для динамических блоков (Процедура)

Обзор настраиваемых свойств для динамических блоков
На уровень вверх ..
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Для указания набора значений для линейного или полярного параметра

Для указания набора значений для параметра XY

Для указания набора значений для параметра поворота

Для удаления значений из набора значений параметра

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.


Для указания набора значений для линейного или полярного параметра (Процедура)

Указание наборов значений для динамических блоков
На уровень вверх ..
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Для указания набора значений для линейного или полярного параметра

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите линейный или полярный параметр.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Тип расстояния".
  4. В раскрывающемся списке выберите "Список".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Список значений расстояния".
  6. Нажмите кнопку [...].
  7. В диалоговом окне "Добавление значения расстояния" в списке "Расстояния для добавления" введите одно или несколько значений, разделенных запятой.
  8. Нажать "Добавить".
  9. Нажать "ОК".
  10. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  11. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Для указания набора значений для параметра XY (Процедура)

Указание наборов значений для динамических блоков
На уровень вверх ..
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Для указания набора значений для параметра XY

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите параметр XY.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Горизонтальный тип" или "Вертикальный тип".
  4. В раскрывающемся списке выберите "Список".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Список значений по горизонтали" или "Список значений по вертикали".
  6. Нажмите кнопку [...].
  7. В диалоговом окне "Добавление значения расстояния" в списке "Расстояния для добавления" введите одно или несколько значений, разделенных запятой.
  8. Нажать "Добавить".
  9. Нажать "ОК".
  10. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  11. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Для указания набора значений для параметра поворота (Процедура)

Указание наборов значений для динамических блоков
На уровень вверх ..
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Для указания набора значений для параметра поворота

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите параметр поворота.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Тип угла".
  4. В раскрывающемся списке выберите "Список".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Список значений угла".
  6. Нажмите кнопку [...].
  7. В диалоговом окне "Добавление значения угла" в списке "Угол для добавления" введите одно или несколько значений, разделенных запятой.
  8. Нажать "Добавить".
  9. Нажать "ОК".
  10. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  11. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Для удаления значений из набора значений параметра (Процедура)

Указание наборов значений для динамических блоков
На уровень вверх ..
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Для удаления значений из набора значений параметра

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите линейный, полярный параметр, параметр XY или поворота.
  3. В палитре "Свойства" в списке "Набор значений" щелкните один из следующих списков.
    • Список значений расстояния
    • Список значений угла
    • Список значений по горизонтали
    • Список значений по вертикали
  4. Нажмите кнопку [...].
  5. В диалоговом окне "Добавление значения расстояния" или "Добавление значения угла" выберите значение списка для удаления.
  6. Нажать кнопку "Удалить".
  7. Нажать "ОК".
  8. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  9. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота. (Процедура)

Указание наборов значений для динамических блоков
На уровень вверх ..
Указание наборов значений для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Для указания набора значений приращения для линейного, полярного параметра, параметра XY или поворота.

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите линейный, полярный параметр, параметр XY или поворота.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Тип расстояния", "Тип угла", "Горизонтальный тип" или "Вертикальный тип".
  4. В раскрывающемся списке выберите "Приращение".
  5. В палитре "Свойства" в списке " Набор значений" щелкните "Приращение расстояния", "Приращение угла", "Приращение по горизонтали" или "Приращение по вертикали", а затем введите значение приращения для параметра.
  6. Щелкните "Минимальное расстояние", "Минимальный угол", "Минимальное по горизонтали" или "Минимальное по вертикали", а затем введите минимальное значение для параметра.
  7. Щелкните "Максимальное расстояние", "Максимальный угол", "Максимальное по горизонтали" или "Максимальное по вертикали", а затем введите максимальное значение для параметра.
  8. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  9. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота. (Процедура)

Указание наборов значений для динамических блоков
На уровень вверх ..
Разрешение цепочки операций для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Для указания минимального и максимального значений для линейного, полярного параметра, параметра XY или поворота.

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите линейный, полярный параметр, параметр XY или поворота.
  3. В палитре "Свойства" в списке " Набор значений" щелкните "Минимальное расстояние", "Минимальный угол", "Минимальное по горизонтали" или "Минимальное по вертикали", а затем введите минимальное значение для параметра.
  4. Щелкните "Максимальное расстояние", "Максимальный угол", "Максимальное по горизонтали" или "Максимальное по вертикали", а затем введите максимальное значение для параметра.
  5. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Указание наборов значений для динамических блоков (Краткий справочник)

Обзор настраиваемых свойств для динамических блоков
Указание наборов значений для динамических блоков
Разрешение цепочки операций для динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Указание наборов значений для динамических блоков >
Указание наборов значений для динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Разрешение цепочки операций для динамических блоков (Понятие)

Указание наборов значений для динамических блоков
Указание настраиваемых свойств для динамических блоков
Изменение определений динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков >
Разрешение цепочки операций для динамических блоков
Понятие Процедура Краткий справочник

Параметры точки, поворота, XY, а также линейные и полярные параметры имеют свойство под названием Цепочка операций. Это свойство влияет на параметра, если параметр является частью набора операций.

Например, можно включить параметр точки в набор действия растягивания, который связан с линейным параметром. Если линейный параметр редактируется во вхождении блока, его связанная операция растягивания приводит к изменению в наборе. Так как параметр точки включен в набор, параметр точки редактируется с помощью изменения линейного параметра.

В следующем примере отображено определение блока в редакторе блоков. Параметр точки (с ярлыком "Положение") входит в набор операции растяжения.

Если у свойства "Цепочка операций" для параметра точки установлено значение "Да", изменение линейного параметра приведет к перемещению, связанному с параметром точки, как если бы параметр точки во вхождении блока был отредактирован с помощью ручки или настраиваемого свойства.

Если для свойства "Цепочка операций" установлено значение "Нет", перемещение, связанное с параметром точки, не будет выполнено при изменении линейного параметра. Поэтому круг не перемещается.


Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота (Процедура)

Указание наборов значений для динамических блоков
На уровень вверх ..
Изменение определений динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Разрешение цепочки операций для динамических блоков >
Разрешение цепочки операций для динамических блоков
Понятие Процедура Краткий справочник

Для указания свойства "Цепочка операций" для линейного, полярного параметра, параметра точки, XY и поворота

  1. В редакторе блоков выберите меню Сервис [image] Свойства. Отображается палитра свойств.
  2. В редакторе блоков выберите линейный, полярный параметр, параметр точки, XY или поворота.
  3. В палитре "Свойства" в списке "Разное" щелкните "Цепочка операций".
  4. В раскрывающемся списке выберите "Да" или "Нет".
  5. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  6. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: ОКНОСВ


Разрешение цепочки операций для динамических блоков (Краткий справочник)

Указание наборов значений для динамических блоков
Разрешение цепочки операций для динамических блоков
Изменение определений динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Указание настраиваемых свойств для динамических блоков > Разрешение цепочки операций для динамических блоков >
Разрешение цепочки операций для динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение определений динамических блоков (Понятие)

Разрешение цепочки операций для динамических блоков
Добавление в блоки динамических элементов
Исправление ошибок в описаниях динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Изменение определений динамических блоков
Понятие Процедура Краткий справочник

Описания динамических блоков можно изменять в редакторе блоков.

После описания динамического блока его можно изменить в редакторе блоков. В редакторе блоков можно удалять, добавлять, и изменять следующие элементы:

  • Параметры (см. раздел Использование параметров в динамических блоках )
  • Операции (см. раздел Использование операций с динамическими блоками )
  • Геометрия
  • Состояния видимости (см. раздел Создание "Состояния видимости" )
  • Таблицы выбора (см. раздел Использование таблицы выбора для назначения данных для динамических блоков )
  • Ручки (см. раздел Указание ручек для динамических блоков )
  • Свойства (см. раздел Обзор настраиваемых свойств для динамических блоков )

Можно также воспользоваться командой БЛОКРЕАКТНАБОР для изменения набора объектов операции. Если удален параметр, связанный с операцией, и требуется переназначить эту операцию для другого параметра, используйте команду БЛОКРЕАКТСВЯЗЬ.

После изменения описания динамического блока в редакторе блоков необходимо сохранить изменения (см. раздел Сохранение блока в редакторе блоков ).

Предупреждение Если переопределить динамический блок в AutoCAD 2005 или более ранних версиях, блок потеряет свои возможности динамического изменения.


Изменение определений динамических блоков (Процедура)

Разрешение цепочки операций для динамических блоков
На уровень вверх ..
Изменение определений динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Изменение определений динамических блоков >
Изменение определений динамических блоков
Понятие Процедура Краткий справочник

Чтобы открыть существующее описание динамического блока в редакторе блоков

Удаление элемента из описания динамических блоков

Изменение набора объектов для операции в описании динамических блоков

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков


Чтобы открыть существующее описание динамического блока в редакторе блоков (Процедура)

Изменение определений динамических блоков
На уровень вверх ..
Изменение определений динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Изменение определений динамических блоков >
Изменение определений динамических блоков
Понятие Процедура Краткий справочник

Чтобы открыть существующее описание динамического блока в редакторе блоков

  1. Откройте файл чертежа, содержащий описание динамического блока, или откройте файл чертежа, который был сохранен как блок.
  2. Выполните действия, приведенные в разделе Чтобы открыть существующее описание динамического блока в редакторе блоков .
Панель:Стандартная
Ввод команды: ОТКРЫТЬ
Контекстное меню: Щелкните выбранный блок правой кнопкой мыши. Выберите "Редактор блоков".


Удаление элемента из описания динамических блоков (Процедура)

Изменение определений динамических блоков
На уровень вверх ..
Изменение определений динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Изменение определений динамических блоков >
Изменение определений динамических блоков
Понятие Процедура Краткий справочник

Удаление элемента из описания динамических блоков

  1. Выберите в редакторе блоков элемент, который требуется удалить из описания динамических блоков.
  2. Нажмите клавишу DELETE.


Изменение набора объектов для операции в описании динамических блоков (Процедура)

Изменение определений динамических блоков
На уровень вверх ..
Изменение определений динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Изменение определений динамических блоков >
Изменение определений динамических блоков
Понятие Процедура Краткий справочник

Изменение набора объектов для операции в описании динамических блоков

  1. Выберите действие в редакторе блоков.
  2. В командной строке введите блокреактнабор и нажмите ENTER.
  3. Отвечайте на запросы команды.
  4. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков (Процедура)

Изменение определений динамических блоков
На уровень вверх ..
Исправление ошибок в описаниях динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Изменение определений динамических блоков >
Изменение определений динамических блоков
Понятие Процедура Краткий справочник

Переопределение растяжения или набора рамок растяжения для операции полярного растяжения в описании динамических блоков

  1. В редакторе блоков дважды щелкните операцию растягивания или полярного растягивания.
  2. Следуйте подсказкам в командной строке, чтобы определить новую рамку растягивания и добавить объекты в набор объектов для операции (или удалить их оттуда).
  3. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Ввод команды: БЛОКРЕАКТНАБОР


Изменение определений динамических блоков (Краткий справочник)

Разрешение цепочки операций для динамических блоков
Изменение определений динамических блоков
Исправление ошибок в описаниях динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Изменение определений динамических блоков >
Изменение определений динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕАКТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТИНСТ

Добавление операции в определение динамических блоков

БЛОКРЕАКТНАБОР

Задание набора объектов, связанных с операцией в описании динамического блока

БЛОКРЕАКТСВЯЗЬ

Создание связи операции с параметром в описании динамического блока

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКНАБРУЧ

Создание, удаление или сброс ручек, связанных с параметром

БЛОКПАРАМ

Добавление параметра с ручками в определение динамического блока

БЛОКТАБЛВЫБ

Отображение или создание таблицы выбора для описания динамического блока

БЛОКСОСТВИД

Создание, установка или удаление состояния видимости в динамическом блоке

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Исправление ошибок в описаниях динамических блоков (Понятие)

Изменение определений динамических блоков
Добавление в блоки динамических элементов
Сохранение блока в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов >
Исправление ошибок в описаниях динамических блоков
Понятие Процедура Краткий справочник

Желтый значок предупреждения отображается в редакторе блоков, если описание динамических блоков содержит ошибки или является неполным. Исправьте ошибки (или дополните блок), чтобы вхождение блока в чертеже работало правильно.

Желтый значок предупреждения указывает на то, что определение блока определено неправильно или является неполным. Например, желтый значок будет отображаться при наличии параметра, не связанного с операцией. При наличии параметра, не связанного с операцией или набором объектов, также отображается желтый значок.

Чтобы исправить эти ошибки, нажмите дважды на желтом значке предупреждения и следуйте подсказкам в командной строке.

После создания описания динамических блоков в редакторе блоков сохраните его, а затем проверьте правильность работы вхождения блока в чертеже. Если вхождение блока работает не так, как требуется, откройте описание в редакторе блоков и щелкните дважды типы использованных параметров и операций, а также их зависимости и свойства.


Исправление ошибок в описаниях динамических блоков (Процедура)

Изменение определений динамических блоков
На уровень вверх ..
Исправление ошибок в описаниях динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Исправление ошибок в описаниях динамических блоков >
Исправление ошибок в описаниях динамических блоков
Понятие Процедура Краткий справочник

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

Просмотр зависимостей внутри описания динамических блоков


Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков (Процедура)

Исправление ошибок в описаниях динамических блоков
На уровень вверх ..
Исправление ошибок в описаниях динамических блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Исправление ошибок в описаниях динамических блоков >
Исправление ошибок в описаниях динамических блоков
Понятие Процедура Краткий справочник

Исправление ошибки, обозначаемой желтым значком предупреждения в описании динамических блоков

  1. Дважды щелкните желтый значок предупреждения в редакторе блоков.
  2. Следуйте подсказкам в командной строке, чтобы исправить ошибки в описании динамических блоков.
  3. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  4. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Просмотр зависимостей внутри описания динамических блоков (Процедура)

Исправление ошибок в описаниях динамических блоков
На уровень вверх ..
Сохранение блока в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Исправление ошибок в описаниях динамических блоков >
Исправление ошибок в описаниях динамических блоков
Понятие Процедура Краткий справочник

Просмотр зависимостей внутри описания динамических блоков

  1. Выберите параметр или действие в редакторе блоков.

    При выборе параметра связанное с ним действие выделяется.

    При выборе действия параметр и набор объектов геометрии, связанные с ним, подсвечиваются.

  2. По окончании просмотра зависимостей нажмите ESC.
  3. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".


Исправление ошибок в описаниях динамических блоков (Краткий справочник)

Изменение определений динамических блоков
Исправление ошибок в описаниях динамических блоков
Сохранение блока в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Добавление в блоки динамических элементов > Исправление ошибок в описаниях динамических блоков >
Исправление ошибок в описаниях динамических блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕД

Открытие определения блока в редакторе блоков

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Сохранение блока в редакторе блоков (Понятие)

Исправление ошибок в описаниях динамических блоков
Добавление функций динамического изменения в блоки
Вставка блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки >
Сохранение блока в редакторе блоков
Понятие Процедура Краткий справочник

По завершении добавления элементов в описание динамических блоков в редакторе блоков сохраните описание блоков.

Чтобы сохранить описание блоков в редакторе блоков, нажмите кнопку "Сохранить определение блока" на панели инструментов редактора блоков или введите блоксохр в командной строке. Затем следует сохранить чертеж и убедиться, что описание блоков в чертеже сохранено.

При сохранении описания блоков в редакторе блоков текущие значения геометрии и параметров в блоке устанавливаются как значения по умолчанию для вхождения блока. При создании динамического блока, где используются состояния видимости, в верхней части списка диалогового окна "Управление состоянием видимости" отображается состояние видимости по умолчанию для вхождения блока.

После сохранения описания блоков можно закрыть редактор блоков и проверить блок в чертеже.

ПримечаниеЕсли во время работы в редакторе блоков выбрать в меню "Файл" [image] "Сохранить", то будет сохранен сам чертеж, а не описание блоков. Во время работы в редакторе блоков описание блоков нужно сохранять отдельно.


Сохранение блока в редакторе блоков (Процедура)

Исправление ошибок в описаниях динамических блоков
На уровень вверх ..
Сохранение блока в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Сохранение блока в редакторе блоков >
Сохранение блока в редакторе блоков
Понятие Процедура Краткий справочник

Сохранение описания блоков в редакторе блоков

Сохранение копии текущего описания блоков в редакторе блоков под другим именем


Сохранение описания блоков в редакторе блоков (Процедура)

Сохранение блока в редакторе блоков
На уровень вверх ..
Сохранение блока в редакторе блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Сохранение блока в редакторе блоков >
Сохранение блока в редакторе блоков
Понятие Процедура Краткий справочник

Сохранение описания блоков в редакторе блоков

  1. На панели инструментов редактора блоков щелкните "Сохранить определение блока".
  2. Для сохранения определения блока в чертеже выберите меню Файл [image] Сохранить.Для сохранения определения блока в чертеже введите в командной строке "бсохранить".
  3. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: БЛОКСОХР


Сохранение копии текущего описания блоков в редакторе блоков под другим именем (Процедура)

Сохранение блока в редакторе блоков
На уровень вверх ..
Вставка блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Сохранение блока в редакторе блоков >
Сохранение блока в редакторе блоков
Понятие Процедура Краткий справочник

Сохранение копии текущего описания блоков в редакторе блоков под другим именем

  1. На панели инструментов редактора блоков щелкните "Сохранить определение блока как".
  2. В диалоговом окне "Сохранение блока как" введите имя для нового описания блоков.
  3. Нажать "ОК".
  4. Для сохранения определения блока в чертеже выберите меню Файл [image] Сохранить.Для сохранения определения блока в чертеже введите в командной строке "бсохранить".
  5. (Дополнительно) Завершив работу с редактором блоков, щелкните "Закрыть редактор блоков".
Панель:Стандартная
Ввод команды: БЛОКСОХРКАК


Сохранение блока в редакторе блоков (Краткий справочник)

Исправление ошибок в описаниях динамических блоков
Сохранение блока в редакторе блоков
Вставка блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Добавление функций динамического изменения в блоки > Сохранение блока в редакторе блоков >
Сохранение блока в редакторе блоков
Понятие Процедура Краткий справочник

Команды

БЛОКРЕДЗАКР

Закрытие редактора блоков

БЛОКРЕД

Открытие определения блока в редакторе блоков

БЛОКСОХР

Сохранение текущего определения блока

БЛОКСОХРКАК

Сохранение копии текущего определения блока под новым именем

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Вставка блоков (Понятие)

Сохранение блока в редакторе блоков
Создание и использование блоков (обозначений)
Работа с динамическими блоками в чертежах
Создание и редактирование объектов > Создание и использование блоков (обозначений) >
Вставка блоков
Понятие Процедура Краткий справочник

При вставке блока создается вхождение блока. Пользователь указывает точку вставки, масштабные коэффициенты и угол поворота.

Для каждого направления X, Y и Z задаются свои значения масштабного коэффициента. Во время вставки блока создается так называемое вхождение блока - объект, который связан с описанием блока, хранящимся в текущем чертеже. Оранжевый значок вспышки молнии, отображаемый в правом нижнем углу окна предварительного просмотра блока, обозначает, что блок динамический.

Если вставить блок, где используются единицы чертежа, отличные от указанных для текущего чертежа, масштаб блока изменится автоматически в соответствии с коэффициентом отношения двух единиц.

При вставке вхождения блока, включающего в себя редактируемые пользовательские свойства или атрибуты, можно изменять значения этих пользовательских свойств и атрибутов в палитре "Свойства" во время вставки блока. Пользовательские свойства и атрибуты блока можно редактировать в палитре "Свойства" после указания блока одним из нижеперечисленных способов.

  • В диалоговом окне Вставка после нажатия OK.
  • Путем ввода команды -ВСТАВИТЬ после ввода имени блока.
  • Нажатием на инструмент работы с блоком в инструментальной палитре.

Вставка файла чертежа в качестве блока

При вставке в чертеж другого чертежа его данные копируются в таблицу блоков текущего чертежа в качестве определения блока. Последующие вхождения используют созданное описание, но для них задаются свои точки вставки, масштабные коэффициенты и углы поворота, как это показано на следующем чертеже.

В целевом чертеже (том, в который выполняется вставка) внешние ссылки и растровые изображения, содержащиеся во вставляемом чертеже, могут отображаться некорректно. Этого можно избежать, предварительно вставив такие внешние ссылки и изображения в целевой чертеж.

Вставка блоков из инструментальных палитр

Можно вставлять блоки из инструментальных палитр перетаскиванием инструмента работы с блоком в чертеж либо нажатием на инструмент работы с блоком и последующим обозначением точки вставки.

Можно выбрать режим, в котором при щелчке мышью для размещения блока отображается запрос на ввод угла поворота (начиная с 0). В этом режиме угол поворота, заданный в диалоговом окне "Свойства инструмента", игнорируется при создании объекта в чертеже. Запрос на ввод угла поворота не отображается при перетаскивании блока или внешней ссылки, а также в случае ввода "повернуть" в командной строке при выполнении первоначальной команды вставки.

Блоки, которые пользователь перетаскивает мышью из палитры в область рисования, можно масштабировать и поворачивать после того, как они станут объектами чертежа. При перетаскивании блоков можно использовать объектную привязку; шаговая привязка при этом подавляется.

При перетаскивании блока из инструментальной палитры в чертеж он автоматически масштабируется в соответствии с соотношением заданных единиц блока и единиц текущего чертежа. Например, если для измерения единиц данного чертежа используются метры, а для измерения единиц блока сантиметры, коэффициент пересчета составляет 1 к 100. Соответственно, при перетаскивании блока в чертеж его размеры меняются в пропорции 1:100.

ПримечаниеВ диалоговом окне "Настройка" на вкладке "Пользовательские" находятся раскрывающиеся списки "Единицы исходного чертежа" и "Единицы целевого чертежа". Выбранные в них единицы используются в том случае, когда единицы вставки не заданы в исходном блоке или целевом чертеже.

Вставка блоков из библиотек компонентов

В текущий чертеж можно вставлять один или несколько блоков из других файлов чертежей. Этот метод используется при вставке из библиотек компонентов. Библиотека компонентов содержит описания блоков для сходных компонентов. Такие описания блоков для удобства хранятся в одном файле чертежа.

Вставка блоков с помощью Центра управления AutoCAD

Вставка блоков из текущего и других чертежей выполняется с помощью Центра управления. Быстрое копирование блоков осуществляется простым перетаскиванием имен блоков. Двойным щелчком мыши на имени нужного блока можно задать положение, угол поворота и масштабные коэффициенты блока.

Вставка блоков в чертеж невозможна в процессе выполнения другой команды. Кроме того, за один раз можно вставить только один блок.

Вставка блоков с заданным интервалом

Имеется возможность вставки блоков с заданным интервалом вдоль выбранного геометрического объекта.

  • Для вставки блоков с заданным интервалом используется команда РАЗМЕТИТЬ.
  • Для вставки блоков с равными интервалами используется команда ПОДЕЛИТЬ.
См. также

    • Сохранение блока в отдельном файле

    • Базовые понятия для блоков

    • Создание библиотек компонентов

    • Работа с динамическими блоками в чертежах

    • Добавление содержимого с помощью Центра управления

    • Создание инструментов из объектов и работа с ними


Вставка блоков (Процедура)

Сохранение блока в редакторе блоков
Вставка блоков
Вставка блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Вставка блоков >
Вставка блоков
Понятие Процедура Краткий справочник

Для вставки блока, описанного в текущем чертеже

Для вставки файла чертежа в качестве блока путем его перетаскивания

Для вставки блока с помощью Центра управления


Для вставки блока, описанного в текущем чертеже (Процедура)

Вставка блоков
Вставка блоков
Вставка блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Вставка блоков >
Вставка блоков
Понятие Процедура Краткий справочник

Для вставки блока, описанного в текущем чертеже

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Вставить". В командной строке введите "вставить".
  2. В диалоговом окне "Вставка блока" выбрать имя блока из списка.
  3. Если необходимо задать точку вставки, масштабные коэффициенты и угол поворота непосредственно при вставке, установить опцию "Указать на экране" для каждого параметра. В противном случае, ввести значения в группах опций "Точка вставки", "Масштаб" и "Угол поворота".
  4. Если вместо целого блока необходимо вставить его отдельные объекты, то установить флажок "Расчленить".
  5. Нажать "ОК".
Панель:Вставка
Ввод команды: ВСТАВИТЬ


Для вставки файла чертежа в качестве блока путем его перетаскивания (Процедура)

Вставка блоков
Вставка блоков
Вставка блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Вставка блоков >
Вставка блоков
Понятие Процедура Краткий справочник

Для вставки файла чертежа в качестве блока путем его перетаскивания

  1. Перетащить значок файла чертежа в графическую область из Проводника Windows или любого другого окна с содержимым какой-либо папки.

    При отпускании кнопки мыши выдается запрос о точке вставки блока.

  2. Задать точку вставки, масштаб и угол поворота.


Для вставки блока с помощью Центра управления (Процедура)

Вставка блоков
Вставка блоков
Работа с динамическими блоками в чертежах
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Вставка блоков >
Вставка блоков
Понятие Процедура Краткий справочник

Для вставки блока с помощью Центра управления

  1. Если Центр управления еще не открыт, выберите меню "Сервис" [image] "Палитры" [image] "Центр управления".Если Центр управления еще не открыт, в командной строке введите "цуоткл".
  2. Выполнить одно из следующих действий для получения списка элементов, которые нужно вставить:
    • На панели окна Центра управления нажать кнопку "Область структуры". Нажать на обозначении папки, содержащей чертеж, который нужно вставить.
    • Нажать на значке нужного файла чертежа в области структуры.
  3. Выполнить одно из следующих действий для выполнения вставки:
    • Перетащить значок файла чертежа или блока в графическую область текущего чертежа. Этот метод удобен для быстрого выполнения вставки; точное положение и угол поворота блока определяется позже.
    • Дважды нажать на значке файла чертежа или блока, который нужно вставить в текущий чертеж. В этом случае значения координат точки вставки, масштаба и угла поворота задаются непосредственно перед вставкой блока. Этот метод можно использовать для обновления вхождений блоков в текущем чертеже из исходного файла.
Панель:Стандартная
Ввод команды: ЦУВКЛ


Вставка блоков (Краткий справочник)

Сохранение блока в редакторе блоков
Вставка блоков
Работа с динамическими блоками в чертежах
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Вставка блоков >
Вставка блоков
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

ПОДЕЛИТЬ

Размещение точек или блоков на равном расстоянии по длине или периметру объекта

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

РАЗМЕТИТЬ

Размещение точек или блоков на объекте с равными интервалами

Системные переменные

ATTDIA

Признак использования диалогового окна для указания значения атрибута при выполнении команды ВСТАВИТЬ

INSNAME

Имя блока по умолчанию для команды ВСТАВИТЬ

INSUNITS

Значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок

INSUNITSDEFSOURCE

Задание единиц измерения исходного содержимого, когда переменная INSUNITS имеет значение равное 0

INSUNITSDEFTARGET

Задание единиц измерения в целевом чертеже, когда переменная INSUNITS имеет значение равное 0

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с динамическими блоками в чертежах (Понятие)

Вставка блоков
Создание и использование блоков (обозначений)
Атрибуты блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) >
Работа с динамическими блоками в чертежах
Понятие Процедура Краткий справочник

Динамический блок обладает гибкостью и интеллектуальными возможностями. Вхождение динамического блока можно легко изменить на чертеже во время работы. Для изменения геометрии можно использовать настраиваемые ручки или настраиваемые свойства. Это позволяет изменять вхождение блока на месте, вместо того чтобы искать другой блок для вставки или уточнять описание существующего блока.

Например в случае вставки в чертеж вхождения блока может потребоваться изменить размер двери во время редактирования чертежа. Если блок является динамическим и в описании указано, что он имеет настраиваемый размер, то, чтобы изменить размер двери, достаточно перетащить ручку настройки или указать другой размер в палитре "Свойства". Возможно, также потребуется изменить угол открытия двери. Дверной блок также может содержать ручку выравнивания, которая позволяет быстро выравнивать вхождение дверного блока с другой геометрией на чертеже.

Кроме того, при наведении курсора на ручку отображается всплывающая подсказка или запрос, описывающие параметр для этой ручки. Отображением всплывающих подсказок управляет системная переменная GRIPTIPS.

В динамическом блоке могут присутствовать настраиваемые ручки или настраиваемые свойства. Возможно, в зависимости от того, как был определен блок, им можно будет управлять с помощью настраиваемых ручек или настраиваемых свойств. По умолчанию цвет настраиваемых ручек для динамического блока отличается от цвета стандартных. Цвет отображения настраиваемых ручек можно изменять с помощью системной переменной GRIPDYNCOLOR. В следующей таблице приведены различные типы настраиваемых ручек, которые можно включать в динамические блоки.

Тип ручки | Манипулирование ручкой в чертеже
Стандартный | В пределах плоскости в любом направлении
Линейный | Назад и вперед в определенном направлении или вдоль оси
Поворот | Вокруг оси
Отразить | При нажатии отражается вхождение динамического блока
Выравнивание | В пределах плоскости в любом направлении; при перемещении над объектом вхождение блока выравнивается по объекту
Поискать | При нажатии отображается список элементов

По завершении манипулирования динамическим блоком в чертеже его можно сбросить. При сбросе вхождения блока сам блок изменяется в соответствии со значением по умолчанию, указанным в описании блоков. Если масштаб вхождения динамического блока изменяется неравномерно или вхождение расчленяется, оно теряет свои динамические свойства. Блок можно сбросить, восстановив значения по умолчанию, что снова сделает его динамическим.

Некоторые динамические блоки определены таким образом, что геометрию внутри блока можно изменять только до определенных размеров, указанных в описаниях блоков. Если для редактирования вхождения блока используется ручка, в точках расположения допустимых значений для вхождения блока отображаются засечки. Если изменить значение свойства блока на значение, отличное от указанного в описании, будет выбрано ближайшее допустимое значение параметра. Например, согласно описанию длина блока имеет значение 2, 4 и 6. Если изменить это значение расстояния на 10, в результате будет выбрано 6, поскольку это ближайшее допустимое значение.


Работа с динамическими блоками в чертежах (Процедура)

Вставка блоков
Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Работа с динамическими блоками в чертежах >
Работа с динамическими блоками в чертежах
Понятие Процедура Краткий справочник

Манипулирование динамическим блоком с помощью настраиваемых ручек

Манипулирование динамическим блоком с помощью настраиваемых свойств

Сброс вхождений блока в чертеже

Изменение цвета отображения настраиваемых ручек


Манипулирование динамическим блоком с помощью настраиваемых ручек (Процедура)

Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Работа с динамическими блоками в чертежах >
Работа с динамическими блоками в чертежах
Понятие Процедура Краткий справочник

Манипулирование динамическим блоком с помощью настраиваемых ручек

  1. Выберите вхождение динамического блока в чертеже.
  2. Растяните или измените блок с помощью ручек.


Манипулирование динамическим блоком с помощью настраиваемых свойств (Процедура)

Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Работа с динамическими блоками в чертежах >
Работа с динамическими блоками в чертежах
Понятие Процедура Краткий справочник

Манипулирование динамическим блоком с помощью настраиваемых свойств

  1. Выберите вхождение динамического блока в чертеже.
  2. Измените соответствующие значения в палитре "Свойства" в разделе "Настройка".


Сброс вхождений блока в чертеже (Процедура)

Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Работа с динамическими блоками в чертежах >
Работа с динамическими блоками в чертежах
Понятие Процедура Краткий справочник

Сброс вхождений блока в чертеже

  1. Выберите вхождение динамического блока в чертеже.
  2. Нажмите в области рисования правой кнопкой мыши. Выберите "Сброс блока".
    Примечание Чтобы одновременно сбросить несколько вхождений блока, воспользуйтесь командой СБРОСБЛОКА.
Ввод команды: СБРОСБЛОКА


Изменение цвета отображения настраиваемых ручек (Процедура)

Работа с динамическими блоками в чертежах
Работа с динамическими блоками в чертежах
Атрибуты блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Работа с динамическими блоками в чертежах >
Работа с динамическими блоками в чертежах
Понятие Процедура Краткий справочник

Изменение цвета отображения настраиваемых ручек

  1. В командной строке введите gripdyncolor.
  2. Введите целое число от 1 до 255 (цвет ИЦА).
  3. Нажать ENTER.


Работа с динамическими блоками в чертежах (Краткий справочник)

Вставка блоков
Работа с динамическими блоками в чертежах
Коротко об атрибутах блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Работа с динамическими блоками в чертежах >
Работа с динамическими блоками в чертежах
Понятие Процедура Краткий справочник

Команды

АТРОБНОВИТЬ

Обновление вхождений блоков с учетом новых и измененных атрибутов из указанного определения блока

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

ОКНОСВ

Управление свойствами объектов

СБРОСБЛОКА

Сброс одного или нескольких вхождений динамических блоков на значения определений блоков по умолчанию

Системные переменные

BTMARKDISPLAY

Управление отображением меток наборов значений для вхождений динамического блока

GRIPDYNCOLOR

Управление цветом пользовательских ручек для динамических блоков

GRIPTIPS

Управление отображением подсказок к ручкам при наведении курсора на ручки динамических блоков и пользовательских объектов, поддерживающих подсказки к ручкам

Утилиты

Нет

Ключевые слова для команд

Нет


Атрибуты блоков

Работа с динамическими блоками в чертежах
Создание и использование блоков (обозначений)
Коротко об атрибутах блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) >
Атрибуты блоков
Понятие Процедура

Пользователь может связывать с блоками различные текстовые данные и в дальнейшем извлекать их для составления спецификаций, отчетов и т.д..

Темы в этом разделе

  • Коротко об атрибутах блоков
  • Создание атрибутов

    Для создания атрибута нужно вначале создать его описание, которое содержит конкретные характеристики атрибута.

  • Извлечение данных из атрибутов

    Если с блоком связаны атрибуты, позднее можно запросить один или несколько чертежей для этих данных атрибутов блока и сохранить их в таблице или внешнем файле.

  • Извлечение данных из атрибутов (метод низкого уровня)

    Файлы шаблонов вывода атрибутов предназначены для извлечения данных из атрибутов из чертежа в отдельный текстовый файл, который впоследствии может быть передан в какую-либо систему управления базами данных.


Атрибуты блоков (Процедура)

Работа с динамическими блоками в чертежах
Атрибуты блоков
Создание атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков >
Атрибуты блоков
Понятие Процедура

Для создания определения атрибута

Для создания определения атрибута мультилинии

Для редактирования описания атрибута до его связывания с блоком

Для изменение порядка запросов на ввод определений атрибутов

Извлечение атрибутов блоков в таблицу или файл

Обновление извлеченных значений атрибутов в таблице

Отключение уведомления об обновлении извлеченных значений атрибутов в таблице

Для создания файла шаблона вывода атрибутов

Для извлечения данных из атрибутов


Коротко об атрибутах блоков (Понятие)

Атрибуты блоков
Атрибуты блоков
Создание атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков >
Коротко об атрибутах блоков
Понятие Краткий справочник

Атрибут представляет собой метку или ярлык для связывания с блоком каких-либо данных. В атрибутах могут храниться номера деталей, стоимость, комментарии, фамилии владельцев и т.п. Имя атрибута можно сравнить с названием столбца в таблице базы данных. На иллюстрации показан блок с четырьмя атрибутами: "тип", "изготовитель", "модель" и "стоимость".

На этой иллюстрации атрибуты являются однострочными. Для сохранения таких данных, как адреса и описания, пользователь может создавать и многострочные атрибуты.

Информацию, хранящуюся в атрибутах чертежа, можно экспортировать из чертежа с последующим использованием в электронных таблицах или базах данных для генерации различных спецификаций. С каждым блоком может быть связано несколько атрибутов, имеющих различные имена.

Атрибуты могут быть скрытыми. Скрытый атрибут не отображается на экране и не выводится на печать. Тем не менее, информация атрибута хранится в файле чертежа и может быть записана в файл извлечения для использования в программе базы данных.

В процессе вставки блока с несколькими атрибутами последовательно предлагается ввести значение каждого из них. Кроме того, в блоках могут использоваться постоянные атрибуты, значения которых не изменяются. Запрос на их ввод при вставке блока не выдается.

Пользователь может создавать аннотативный атрибуты. Дополнительные сведения о создании аннотативных атрибутов и работе с ними см. в разделе Создание аннотативных блоков и атрибутов.

См. также

    • Редактирование определений атрибутов блоков

    • Масштабирование аннотаций


Коротко об атрибутах блоков (Краткий справочник)

Работа с динамическими блоками в чертежах
Коротко об атрибутах блоков
Создание атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Коротко об атрибутах блоков >
Коротко об атрибутах блоков
Понятие Краткий справочник

Команды

Создание определения атрибута для хранения данных в блоке

АТЭКР

Сохранение текущего значения параметра видимости для каждого атрибута

АТРЕД

Изменение данных атрибутов в блоке

АТРЕДМ

Изменение текстового содержимого атрибута в блоке

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

ОКНОСВ

Управление свойствами объектов

Системные переменные

AFLAGS

Задание параметров для атрибутов

ATTDIA

Признак использования диалогового окна для указания значения атрибута при выполнении команды ВСТАВИТЬ

ATTIPE

Управление отображением контекстного редактора при создании атрибутов мультилиний

ATTMODE

Управление отображением атрибутов

ATTMULTI

Управление возможностью создания атрибутов мультилиний

ATTREQ

Признак использования заданных по умолчанию настроек для атрибутов в процессе вставки блоков при выполнении команды ВСТАВИТЬ

Утилиты

Нет

Ключевые слова для команд

Нет


Создание атрибутов (Понятие)

Коротко об атрибутах блоков
Атрибуты блоков
Извлечение данных из атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков >
Создание атрибутов
Понятие Процедура Краткий справочник

Для создания атрибута нужно вначале создать его описание, которое содержит конкретные характеристики атрибута.

Эти характеристики содержат конкретную метку-имя для данного атрибута, текст подсказки, отображаемый при вставке блока, информацию о значениях, формат текста, расположение в блоке и его необязательные режимы (скрытый, постоянный, контролируемый, установленный, фиксированное положение, несколько строк).

Если данные из атрибутов планируется использовать для создания каких-либо спецификаций или отчетов, то следует запоминать имена атрибутов. Они понадобятся позже при создании файла шаблона атрибутов.

Выбор режимов атрибутов

Режимы атрибутов отвечают за поведение атрибутов в блоках. Например, пользователь может:

  • Сделать атрибут видимым или невидимым в чертеже
  • Указать, является ли значение атрибута постоянным (например, номер детали)
  • Указать, можно ли перемещать атрибут относительно блока
  • Указать, является ли атрибут однострочным или многострочным.

Если атрибут имеет постоянное значение, при вставке блока запрос этого значения не выводится. Если атрибут имеет переменное значение (например, инвентарный номер компьютера), при вставке блока выводится запрос этого значения.

Однострочные и многострочные атрибуты

Между однострочными или многострочными атрибутами имеется несколько отличий.

  • Однострочные атрибуты в интерфейсе пользователя ограничены 255 символами.
  • Многострочные атрибуты обеспечивают более сложное форматирование, чем однострочные.
  • Для редактирования однострочных и многострочных атрибутов используются разные редакторы.
  • Для многострочных атрибутов отображаются четыре ручки (как и для объектов МТЕКСТ), а для однострочных атрибутов отображается одна ручка.
  • При сохранении чертежа в AutoCAD 2007 или более ранней его версии многострочный атрибут преобразуется в несколько однострочных, по одному для каждой строки текста исходного многострочного атрибута. При открытии файла в текущей версии программы такие однострочные атрибуты автоматически объединяются обратно в многострочные.
ПримечаниеПри пересылке многострочного атрибута из текущей версии в более раннюю версию AutoCAD и обратно может произойти отсечение очень длинных строк текста с потерей форматирование (из-за различия между этими двумя типами атрибутов). Однако перед отсечением строки AutoCAD выводит диалоговое окно, позволяющее отменить эту операцию.

Устранение ошибок в описаниях атрибутов

При совершении ошибки в описании атрибута пользователь может сделать небольшие корректировки с использованием палитры "Свойства" или введением команды ДИАЛРЕД (перед связыванием этого атрибута с блоком). При необходимости внесения более обширных изменений будет лучше удалить определение атрибута и создать новое.

Связывание атрибутов с блоками

После создания одного или нескольких определений атрибутов они присоединяются к блоку (при его определении или переопределении). Вместе с другими объектами, включаемыми в блок, следует выбрать и нужные атрибуты.

В один блок можно включить несколько атрибутов. Например, можно определить атрибуты с метками "Тип", "Изготовитель", "Модель", "Стоимость" и далее включить их в блок с именем СТУЛ.

Обычно запросы выдаются в том же порядке, в каком выбирались атрибуты при формировании блока. Однако если атрибуты в ходе формирования блока были выбраны с помощью рамки или секущей рамки, запросы выдаются в порядке, обратном порядку создания атрибутов. Воспользуйтесь диспетчером атрибутов блоков, чтобы изменить порядок запросов данных атрибутов при вставке вхождения блока.

В процессе работы с редактором блоков можно также использовать диалоговое окно "Порядок атрибутов" для изменения порядка запросов данных об атрибутах (при вставке ссылки на блок).

Использование атрибутов без связывания с блоками

Имеется возможность создания отдельных атрибутов, не связанных с блоками. Если чертеж, где имеются такие атрибуты, сохранить, то при выполнении вставки этого чертежа в другой чертеж выдаются запросы на ввод значений атрибутов.


Создание атрибутов (Процедура)

Атрибуты блоков
На уровень вверх ..
Создание атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Создание атрибутов >
Создание атрибутов
Понятие Процедура Краткий справочник

Для создания определения атрибута

Для создания определения атрибута мультилинии

Для редактирования описания атрибута до его связывания с блоком

Для изменение порядка запросов на ввод определений атрибутов


Для создания определения атрибута (Процедура)

Создание атрибутов
На уровень вверх ..
Создание атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Создание атрибутов >
Создание атрибутов
Понятие Процедура Краткий справочник

Для создания определения атрибута

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Задание атрибутов". В командной строке введите "атопр".
  2. В диалоговом окне "Определение атрибута" указать точку вставки атрибута, задать его имя, подсказку, режимы и параметры текста.
  3. Нажать "ОК".

    Созданный атрибут включается в набор объектов при создании определения блока. При очередной вставке блока, имеющего атрибуты, выдается запрос с заданным в описании атрибута текстом. Значения атрибута для разных вхождений блока могут различаться.

Ввод команды: АТОПР


Для создания определения атрибута мультилинии (Процедура)

Создание атрибутов
На уровень вверх ..
Создание атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Создание атрибутов >
Создание атрибутов
Понятие Процедура Краткий справочник

Для создания определения атрибута мультилинии

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Задание атрибутов". В командной строке введите "атопр".
  2. В диалоговом окне "Определение атрибута", в группе "Режим" выберите "Несколько строк".
  3. Введите информацию метки, место расположения и параметры текста.
  4. (Если потребуется) укажите значение в поле "Ширина рамки" в группе "Параметры текста".
  5. (Если потребуется) нажмите кнопку "Многострочный контекстный редактор" для использования этого редактора при задании формата атрибута в чертеже.
  6. Нажать "ОК".

    Созданный атрибут включается в набор объектов при создании определения блока. При очередной вставке блока, имеющего атрибуты, выдается запрос с заданным в описании атрибута текстом. Значения атрибута для разных вхождений блока могут различаться.

Ввод команды: АТОПР


Для редактирования описания атрибута до его связывания с блоком (Процедура)

Создание атрибутов
На уровень вверх ..
Создание атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Создание атрибутов >
Создание атрибутов
Понятие Процедура Краткий справочник

Для редактирования описания атрибута до его связывания с блоком

  1. Выберите меню Редактирование [image] Объект [image] Текст.
  2. Выбрать атрибут для редактирования.
  3. В диалоговом окне "Редактирование описания атрибута" указать имя атрибута, подсказку и значение по умолчанию. Затем нажать "OK".
Ввод команды: ДИАЛРЕД


Для изменение порядка запросов на ввод определений атрибутов (Процедура)

Создание атрибутов
На уровень вверх ..
Извлечение данных из атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Создание атрибутов >
Создание атрибутов
Понятие Процедура Краткий справочник

Для изменение порядка запросов на ввод определений атрибутов

  1. Выберите атрибут блока в редакторе блоков.
  2. Щелкните в области рисования редактора блоков правой кнопкой мыши.
  3. Выберите "Порядок атрибутов".
  4. Выберите определение атрибута в диалоговом окне "Порядок атрибутов".
  5. Выберите "Вверх" или "Вниз", чтобы изменить порядок запросов на ввод определений атрибутов.
  6. Повторяйте шаги 2 и 3, пока не выберете правильный порядок в списке определений атрибутов.
  7. Нажать "ОК".
Ввод команды: БЛОКРЕД [image] БЛОКПОРАТР


Создание атрибутов (Краткий справочник)

Коротко об атрибутах блоков
Создание атрибутов
Извлечение данных из атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Создание атрибутов >
Создание атрибутов
Понятие Процедура Краткий справочник

Команды

АТОПР

Создание определения атрибута для хранения данных в блоке

АТЭКР

Сохранение текущего значения параметра видимости для каждого атрибута

БЛОКПОРАТР

Задание порядка атрибутов для блока

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

ОКНОСВ

Управление свойствами объектов

Системные переменные

AFLAGS

Задание параметров для атрибутов

ATTIPE

Управление отображением контекстного редактора при создании атрибутов мультилиний

ATTMULTI

Управление возможностью создания атрибутов мультилиний

Утилиты

Нет

Ключевые слова для команд

Нет


Извлечение данных из атрибутов (Понятие)

Создание атрибутов
Атрибуты блоков
Извлечение данных из атрибутов (метод низкого уровня)
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков >
Извлечение данных из атрибутов
Понятие Процедура Краткий справочник

Если с блоком связаны атрибуты, позднее можно запросить один или несколько чертежей для этих данных атрибутов блока и сохранить их в таблице или внешнем файле.

Извлечение данных атрибутов - это удобный способ создания спецификаций и отчетов о материалах непосредственно из данных чертежей. Например, можно создать чертеж, где каждый блок представляет определенное производственное оборудование. Если с каждым блоком связаны атрибуты, в которых указана модель и производитель оборудования, можно создать отчет о стоимости оборудования.

Процесс выбора чертежей, экземпляров блоков и атрибутов организован с помощью мастера извлечения данных. С помощью Мастера можно также создать файл срасширением .dxe, который будет содержать все настройки для дальнейшего использования.

Вывод в таблицу

Если извлечь данные атрибутов в таблицу, таблица будет вставлена в текущий чертеж и текущее пространство (пространство модели или пространство листа) на текущем слое.

При обновлении таблицы данные атрибутов извлекаются повторно, а строки данных в таблице заменяются. Если в эту таблицу была добавлена строка названия или от одной до нескольких строк заголовков, то во время обновления они не заменяются.

Примечание Чтобы контекстные меню в области чертежа, которые требуются для редактирования и обновления таблиц, стали доступны, установите флажок "Контекстные меню в области рисования" в диалоговом окне "Параметры" на вкладке "Пользовательские".

Вывод в файл

Для сохранения данных во внешний файл доступны следующие форматы файлов: с разделением запятыми (CSV), с разделением табуляциями (TXT), Microsoft Excel (XLS) и Microsoft Access (MDB).

Если точка (.), запятая (,) или решетка (#) записываются в файл Excel или Access, они заменяются знаками Unicode.

См. также
    • Извлечение данных из чертежей и электронных таблиц


Извлечение данных из атрибутов (Процедура)

Создание атрибутов
На уровень вверх ..
Извлечение данных из атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов >
Извлечение данных из атрибутов
Понятие Процедура Краткий справочник

Извлечение атрибутов блоков в таблицу или файл

Обновление извлеченных значений атрибутов в таблице

Отключение уведомления об обновлении извлеченных значений атрибутов в таблице


Извлечение атрибутов блоков в таблицу или файл (Процедура)

Извлечение данных из атрибутов
На уровень вверх ..
Извлечение данных из атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов >
Извлечение данных из атрибутов
Понятие Процедура Краткий справочник

Извлечение атрибутов блоков в таблицу или файл

  • Выберите меню Сервис [image] Извлечение данных.В командной строке введите "данныеизвл".

    Откроется диалоговое окно мастера извлечения данных. Мастер предоставляет пошаговые инструкции для извлечения информации из атрибутов блока в текущем чертеже или других чертежах. Информация используется для создания таблицы в текущем чертеже или сохраняется во внешний файл.

    В разделе Мастер извлечения данных описываются параметры, настраиваемые в мастере.

Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Обновление извлеченных значений атрибутов в таблице (Процедура)

Извлечение данных из атрибутов
На уровень вверх ..
Извлечение данных из атрибутов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов >
Извлечение данных из атрибутов
Понятие Процедура Краткий справочник

Обновление извлеченных значений атрибутов в таблице

  • При появлении диалогового окна "Устаревшая таблица" нажмите "Обновить"


Отключение уведомления об обновлении извлеченных значений атрибутов в таблице (Процедура)

Извлечение данных из атрибутов
На уровень вверх ..
Извлечение данных из атрибутов (метод низкого уровня)
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов >
Извлечение данных из атрибутов
Понятие Процедура Краткий справочник

Отключение уведомления об обновлении извлеченных значений атрибутов в таблице

  1. В командной строке введите DXEVAL.
  2. Введите 0.


Извлечение данных из атрибутов (Краткий справочник)

Создание атрибутов
Извлечение данных из атрибутов
Извлечение данных из атрибутов (метод низкого уровня)
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов >
Извлечение данных из атрибутов
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Извлечение данных из атрибутов (метод низкого уровня) (Понятие)

Извлечение данных из атрибутов
Атрибуты блоков
Редактирование блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков >
Извлечение данных из атрибутов (метод низкого уровня)
Понятие Процедура Краткий справочник

Файлы шаблонов вывода атрибутов предназначены для извлечения данных из атрибутов из чертежа в отдельный текстовый файл, который впоследствии может быть передан в какую-либо систему управления базами данных.

Имеется возможность извлечения данных из атрибутов из чертежа в отдельный текстовый файл, который впоследствии может быть передан в какую-либо систему управления базами данных. Это позволяет легко создавать различные спецификации и отчеты, опираясь на данные, содержащиеся в базах данных внутри чертежей. Извлечение информации, хранящейся в атрибутах, никак не влияет на чертеж.

Для создания спецификации или отчета

  • Создать и отредактировать определение атрибута.
  • Ввести значения атрибутов в процессе выполнения вставки блоков.
  • Создать файл шаблона и затем извлечь данные из атрибутов в текстовый файл.

Для извлечения данных из атрибутов вначале создается файл шаблона атрибутов с помощью любого текстового редактора, затем с помощью AutoCAD формируется файл вывода атрибутов, который, наконец, можно передать в систему управления базами данных. Если данные атрибутов необходимо выводить в DXF-файл графического обмена, то создание шаблона не требуется.

ПримечаниеНеобходимо убедиться в том, что имена файла вывода атрибутов и файла шаблона атрибутов не совпадают.

Создание файла шаблона вывода атрибутов

Перед тем как извлекать данные из атрибутов, вначале необходимо создать текстовый (ASCII) файл шаблона, описывающий структуру формируемого файла, куда должны выводится данные. В файле шаблона содержится информация об именах выводимых атрибутов, типах данных, длине полей и количестве знаков представления числовых значений.

Поля файла шаблона описывают информацию, извлекаемую из вхождений блоков чертежа. Каждая строка в шаблоне соответствует одному полю в файле вывода; она задает имя поля, его ширину (в символах) и точность представления. Каждая запись в файле вывода включает в себя заданные поля именно в том порядке, в каком они перечислены в шаблоне.

В следующем файле шаблона перечислено 15 возможных полей. N означает числовой тип, C символьный тип, www общая длина поля в виде трехзначного числа, ddd число выводимых знаков после десятичной точки в виде трехзначного числа.

BL:NAMECwww000 (Имя блока)

BL:LEVELNwww000 (Уровень вложенности блокаl)

BL:X Nwwwddd(Координата X точки вставки)

BL:Y Nwwwddd(Координата Y)

BL:Z Nwwwddd(Координата Z)

BL:NUMBERNwww000 (Счетчик блоков; один и тот же для блоков, вставленных по МВСТАВИТЬ)

BL:HANDLECwww000 (Метка блоков; одна и та же для блоков, вставленных по МВСТАВИТЬ)

BL:LAYERCwww000 (Имя слоя вставки блока)

BL:ORIENT Nwwwddd(Угол поворота блока)

BL:XSCALE Nwwwddd(Масштаб по X)

BL:YSCALE Nwwwddd(Масштаб по Y)

BL:ZSCALE Nwwwddd(Масштаб по Z)

BL:XEXTRUDE Nwwwddd(Составляющая X вектора выдавливания)

BL:YEXTRUDE Nwwwddd(Составляющая Y вектора выдавливания)

BL:ZEXTRUDE Nwwwddd(Составляющая Z вектора выдавливания)

numericNwwwddd (Числовой атрибут)

characterCwww000 (Символьный атрибут)

Шаблон может включать в себя все или некоторые из полей типа BL:xxxxxxx, перечисленных выше. Включенные в шаблон имена атрибутов задают, данные каких атрибутов (и, следовательно, каких блоков) включаются в файл вывода. Значения заданных в шаблоне, но не содержащихся в блоке атрибутов, заменяются пробелами (для символьных) или нулями (для числовых).

Пояснения о назначении стандартных полей приведены здесь исключительно в качестве комментария; включаться в шаблон они не должны.

В шаблоне вывода атрибутов задаются сведения об атрибутах; например, о наименовании детали, номере модели, стоимости и поставщике, как показано на чертеже блока с атрибутами и в таблице.

Поле | Символьные (C) или числовые (N) данные | Максимальная длина поля | Число десятичных знаков
Тип | C | 040 | 000
Изготовитель | C | 006 | 000
Модель | C | 015 | 000
Цена | N | 006 | 002

Число создаваемых файлов шаблонов не ограничивается. Каждая запись в файле шаблона описывает одно поле, сохраняемое в файле вывода атрибутов.

При создании файла шаблона вывода атрибутов рекомендуется придерживаться следующих правил:

  • Между именем атрибута и описанием формата выводимого значения должен стоять символ пробела. Для ввода пробела следует использовать не символ табуляции, а планку пробела.
  • Каждую строку файла, включая последнюю, необходимо заканчивать нажатием ENTER.
  • Файл шаблона должен содержать хотя бы одно поле с именем атрибута, и каждое из полей может упоминаться в шаблоне не более одного раза.

Ниже приведен пример простого файла шаблона для извлечения информации из атрибутов.

BL:NAME C008000 (Имя блока, 8 символов)

BL:X N007001 (Координата X, в формате nnnnnn.d)

BL:Y N007001 (Координата Y, в формате nnnnnn.d)

SUPPLIER C016000 (Фирма-изготовитель, 16 символов)

MODEL C009000 (Номер модели, 9 символов)

PRICE N009002 (Стоимость единицы, в формате nnnnnnnn.dd)

ПримечаниеВ общую длину числового поля входит и десятичная точка. Например, для вывода числа 249.95 требуется хотя бы 6 позиций; формат записи может выглядеть как N006002. Для описания символьных полей не нужно указывать три последние цифры, как для числовых полей.

Создание файла вывода атрибутов

После создания файла шаблона пользователь может извлечь данные из атрибутов, сохранив их в файле вывода в одном из форматов:

  • Формат файла с разделителями-запятыми (CDF)
  • Формат файла с разделителями-пробелами (SDF)
  • Формат файла обмена графическими данными (DXF)

Файл формата CDF содержит по одной записи для каждого вхождения блока в чертеж. Поля записи разделяются запятыми, а символьные поля заключаются в апострофы. Некоторые системы управления базами данных могут непосредственно воспринимать данный формат.

Файл формата SDF также содержит по одной записи для каждого вхождения блока в чертеж. Поля каждой записи имеют фиксированную длину и не требуют ни разделителей, ни ограничителей символьных полей. Операция dBASE III Copy . . . SDF также формирует файлы в формате SDI. Операция Append From... SDF позволяет читать файлы в формате dBASE IV, которые легко обрабатываются пользовательскими программами, написанными на языке FORTRAN.

При выводе в формате DXF образуется подмножество файла обмена чертежами, содержащее только вхождения блоков, атрибуты и символы конца последовательности. В данном случае файл шаблона вывода атрибутов не требуется. Выходные файлы отличаются от стандартных DXF-файлов своим расширением (.dxx ).

Использование файла вывода атрибутов

Файл вывода атрибутов содержит список значений и других сведений всех атрибутов, вывод которых описан в шаблоне.

Если при выводе с помощью шаблона применяется формат CDF, то файл вывода может иметь следующий вид:

'DESK', 120.0, 49.5, 'ACME INDUST.', '51-793W', 379.95

'CHAIR', 122.0, 47.0, 'ACME INDUST.', '34-902A', 199.95

'DESK', -77.2, 40.0, 'TOP DRAWER INC.', 'X-52-44',249.95

По умолчанию, символьные поля заключаются в апострофы. Разделителем по умолчанию является запятая. Для переопределения этих настроек можно использовать две следующие записи в шаблоне:

C:QUOTE c(Ограничитель символьной строки)

C:DELIM c(Разделитель полей)

Символ, следующий сразу (без пробела) за именем поля C:QUOTE или C:DELIM определяет соответственно ограничитель символьных строк или разделитель полей. Например, для того чтобы символьные строки заключались в кавычки, необходимо вписать в шаблон следующую строку:

C:QUOTE "

Ограничителем символьных строк не может быть символ, встречающийся в символьных значениях полей. Аналогично, разделителем полей не может быть символ, встречающийся в числовых значениях полей.

Если при выводе с помощью шаблона применяется формат SDF, то файл вывода может иметь следующий вид:

(NAME) | (X) | (Y) | (SUPPLIER) | (МОДЕЛЬ) | (PRICE)
DESK | 120.0 | 49.5 | ACME INDUST. | 51-793W | 379.95
CHAIR | 122.0 | 47.0 | ACME INDUST. | 34-902A | 199.95
DESK | -77.2 | 40.0 | TOP DRAWER INC. | X-52-44 | 249.95

Порядок вывода полей соответствует порядку описания полей в файле шаблона. Файлы, полученные после вывода атрибутов, могут использоваться в других приложениях, включая электронные таблицы. Данные из этих файлов могут в дальнейшем сортироваться и обрабатываться. О порядке работы с данными других приложений см. документацию по используемому приложению обработки электронных таблиц. Если полученный файл открыть в Блокноте или каком-либо другом текстовом редакторе Windows, то данные из файла можно вставить в чертеж в виде текста с помощью буфера обмена.

Вложенные блоки

Строка BL:LEVEL шаблона определяет уровень вложенности блока. Блок, вставленный в чертеж, имеет уровень вложенности, равный 1. Вхождение блока, являющееся частью другого блока (вложенное в другой блок), имеет уровень вложенности 2 и т.д.

Во вложенном вхождении блока координаты, масштабные коэффициенты, вектор выдавливания и угол поворота отражают реальные значения вложенного блока в Мировой системе координат.

В некоторых случаях, вложенные вхождения блоков невозможно корректно представить, оперируя только двумя масштабными коэффициентами и углом поворота. К таким случаям можно отнести вхождение блока, повернутое в трехмерном пространстве. В этой ситуации, масштабные коэффициенты и угол поворота в записях файла вывода отображаются значением 0.

Обработка ошибок

Если заданная длина поля недостаточна для представления значения атрибута, то конец значения отсекается, затем появляется следующее сообщение:

** Переполнение в поле записи <номер_записи>

Подобная ошибка может произойти, например, если в шаблоне для поля BL:NAME указана длина поля 8, а в чертеже содержится имя длиной 10 символов.


Извлечение данных из атрибутов (метод низкого уровня) (Процедура)

Извлечение данных из атрибутов
На уровень вверх ..
Извлечение данных из атрибутов (метод низкого уровня)
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов (метод низкого уровня) >
Извлечение данных из атрибутов (метод низкого уровня)
Понятие Процедура Краткий справочник

Для создания файла шаблона вывода атрибутов

Для извлечения данных из атрибутов


Для создания файла шаблона вывода атрибутов (Процедура)

Извлечение данных из атрибутов (метод низкого уровня)
На уровень вверх ..
Извлечение данных из атрибутов (метод низкого уровня)
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов (метод низкого уровня) >
Извлечение данных из атрибутов (метод низкого уровня)
Понятие Процедура Краткий справочник

Для создания файла шаблона вывода атрибутов

  1. Открыть программу "Блокнот".

    Можно также воспользоваться любым другим текстовым редактором, работающим с текстами в формате ASCII.

  2. Ввести данные шаблона. Дополнительные сведения о формате шаблона см. в разделе Извлечение данных из атрибутов (метод низкого уровня).
  3. Сохранить файл с расширением .txt.

    Для извлечения данных конкретного атрибута подставить его имя вместо элементов "числовой" или "символьный" приведенной выше таблицы.

ПредупреждениеПри создании файла шаблона не следует использовать символы табуляции. При использовании для выравнивания символов табуляции выходной файл не создается. Для выравнивания столбцов следует использовать обычные пробелы, нажимая планку пробела. При использовании символов табуляции текст может располагаться неравномерно.


Для извлечения данных из атрибутов (Процедура)

Извлечение данных из атрибутов (метод низкого уровня)
На уровень вверх ..
Редактирование блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов (метод низкого уровня) >
Извлечение данных из атрибутов (метод низкого уровня)
Понятие Процедура Краткий справочник

Для извлечения данных из атрибутов

  1. В командной строке введите атэксп.
  2. В диалоговом окне "Извлечение атрибутов" выберите нужный формат файла: CDF, SDF или DXF.
  3. Нажать кнопку "Выбрать объекты" и указать объекты, данные из атрибутов которых нужно извлечь.

    На чертеже можно выбрать один или несколько блоков.

  4. Ввести имя файла шаблона или нажать кнопку "Файл шаблона" и выбрать нужный файл.
  5. Ввести имя файла вывода или нажать кнопку "Файл вывода" и выбрать нужный файл.
  6. Нажать "ОК".
Ввод команды: АТЭКСП


Извлечение данных из атрибутов (метод низкого уровня) (Краткий справочник)

Извлечение данных из атрибутов
Извлечение данных из атрибутов (метод низкого уровня)
Редактирование определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Атрибуты блоков > Извлечение данных из атрибутов (метод низкого уровня) >
Извлечение данных из атрибутов (метод низкого уровня)
Понятие Процедура Краткий справочник

Команды

АТЭКСП

Извлечение в файл данных атрибута, т. е. связанного с блоком информационного текста

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование блоков

Извлечение данных из атрибутов (метод низкого уровня)
Создание и использование блоков (обозначений)
Редактирование определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) >
Редактирование блоков
Понятие Процедура

Имеется возможность редактирования определений блоков и вхождений блоков уже после их вставки в чертеж.

Темы в этом разделе

  • Редактирование определений блоков

    Изменения определений блоков в текущем чертеже оказывают действие как на уже созданные в чертеже вхождения блоков, так и на создаваемые в дальнейшем.

  • Изменение цвета и типа линий в блоке

    Изменение цвета и типа линий объектов блока доступно лишь в том случае, если свойства объектов являются наследуемыми.

  • Изменение данных в атрибутах блока

    Пользователь может редактировать значения атрибутов, которые присоединены к блоку и вставлены в чертеж.

  • Редактирование определений атрибутов блоков

    Имеется возможность редактирования значений и других свойств атрибутов, уже связанных с вставленными в чертеж блоками.

  • Расчленение блока


Редактирование блоков (Процедура)

Извлечение данных из атрибутов (метод низкого уровня)
Редактирование блоков
Редактирование определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков >
Редактирование блоков
Понятие Процедура

Для обновления блока при изменении исходного файла

Для редактирования описания блока

Для переноса объекта на другой слой

Для назначения цвета слою

Для назначения цвета объекту для использования вместо цвета слоя

Для назначения типа линий слою

Для назначения типа линий объекту для использования вместо типа линий слоя

Для изменения определения имеющегося блока

Для редактирования атрибутов

Для редактирования атрибутов в описаниях блоков

Для включения и отключения применения изменений к существующим вхождениям блоков

Для нахождения одинаковых имен атрибутов блока

Для изменение порядка запросов на ввод значений атрибутов

Для удаления атрибута из определения блока и из всех вхождений блоков

Для обновления измененных атрибутов в существующих вхождениях блоков

Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока

Для расчленения блока

Управление свойствами при расчленении объекта


Редактирование определений блоков (Понятие)

Редактирование блоков
Редактирование блоков
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков >
Редактирование определений блоков
Понятие Процедура Краткий справочник

Изменения определений блоков в текущем чертеже оказывают действие как на уже созданные в чертеже вхождения блоков, так и на создаваемые в дальнейшем.

Пользователь может переопределять описания блоков в текущем чертеже. Изменения определений блоков в текущем чертеже оказывают действие как на уже созданные в чертеже вхождения блоков, так и на создаваемые в дальнейшем, а также на любые связанные с блоками атрибуты.

Существует два способа редактирования определения блока:

  • Изменение определения блока в текущем чертеже.
  • Изменение определения блока в исходном файле и его повторная вставка в текущий чертеж.

Выбор метода зависит от того, необходимо ли внести изменения только в текущий чертеж или нужно изменить также исходный файл блока.

Изменение определения блока в текущем чертеже.

Для изменения определения блока следует выполнить все действия по созданию нового блока, но вводимое имя должно совпадать с именем редактируемого определения блока. При переопределении все имеющиеся вхождения блока в чертеже немедленно обновляются.

Чтобы облегчить задачу, можно выполнить вставку блока с его расчленением, а затем полученные таким образом объекты использовать для создания нового определения блока.

Обновление блока при изменении исходного файла

Изменение исходного чертежа блока не оказывает немедленного действия на текущий чертеж, куда вставлен этот блок. Для обновления блока в текущем чертеже, вставленного из исходного файла, следует воспользоваться командой ВСТАВИТЬ.

Обновление блока при изменении библиотеки компонентов

При выполнении вставки одноименного определения блока с помощью Центра управления уже имеющийся в чертеже блок не удаляется. Для обновления определения блока из библиотеки можно использовать команду ПБЛОК, которая создает отдельный файл блока из библиотеки компонентов. Затем используется команда ВСТАВИТЬ для перезаписи определения блока на чертеже, где используется блок.

ПримечаниеПри использовании команды ВСТАВИТЬ описания к блокам сбрасываются. Текстовые описания к блокам, выводимые в диалоговом окне "Определение блока", можно копировать между описаниями блоков через буфер обмена.

Редактирование описаний блоков

Для изменения описаний к блокам, отображаемых в Центре управления, следует использовать команду БЛОК. Кроме того, в диалоговом окне "Определение блока" можно также добавлять описания к имеющимся блокам.

Переопределение атрибутов блоков

Связывание атрибутов с блоком производится при его создании или переопределении. Необходимые атрибуты включаются в блок во время выбора объектов для блока. Переопределение атрибутов в описании блока оказывает следующие действия на уже созданные вхождения блоков:

  • Постоянные атрибуты, имеющие фиксированные значения (константы), теряются или заменяются новыми атрибутами.
  • Переменные атрибуты остаются без изменений, даже если в новом описании блока совсем нет атрибутов.
  • Новые атрибуты в имеющихся вхождениях блоков не появляются.
См. также

    • Атрибуты блоков

    • Изменение определений динамических блоков


Редактирование определений блоков (Процедура)

Редактирование блоков
На уровень вверх ..
Редактирование определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений блоков >
Редактирование определений блоков
Понятие Процедура Краткий справочник

Для обновления блока при изменении исходного файла

Для редактирования описания блока


Для обновления блока при изменении исходного файла (Процедура)

Редактирование определений блоков
На уровень вверх ..
Редактирование определений блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений блоков >
Редактирование определений блоков
Понятие Процедура Краткий справочник

Для обновления блока при изменении исходного файла

  1. Если Центр управления закрыт, выберите меню "Сервис" [image] "Палитры" [image] "Центр управления".Если Центр управления еще не открыт, в командной строке введите "цуоткл".
  2. Из списка папок выбрать папку, содержащую исходный файл чертежа.
  3. Нажать правой кнопкой мыши на файле чертежа.
  4. Выбрать "Вставить как блок" из контекстного меню.
  5. В диалоговом окне "Вставка блока" нажать "ОК".
  6. Нажать "Да" в диалоговом окне для перезаписи определения блока.
  7. Нажать ESC для выхода из команды.


Для редактирования описания блока (Процедура)

Редактирование определений блоков
На уровень вверх ..
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений блоков >
Редактирование определений блоков
Понятие Процедура Краткий справочник

Для редактирования описания блока

  1. Выберите меню Редактирование [image] Объект [image] Определение блока.В командной строке введите "блок".
  2. В диалоговом окне "Определение блока" выбрать блок, описание к которому необходимо отредактировать.
  3. В поле "Описание" ввести новое или изменить имеющееся описание для блока.
  4. Нажать "ОК".
  5. Появляется сообщение с запросом подтверждения на переопределение блока. Нажать "Да".
Ввод команды: БЛОК


Редактирование определений блоков (Краткий справочник)

Извлечение данных из атрибутов (метод низкого уровня)
Редактирование определений блоков
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений блоков >
Редактирование определений блоков
Понятие Процедура Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение цвета и типа линий в блоке (Понятие)

Редактирование определений блоков
Редактирование блоков
Изменение данных в атрибутах блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Изменение цвета и типа линий объектов блока доступно лишь в том случае, если свойства объектов являются наследуемыми.

Блок, содержащий объекты с наследуемыми свойствами, передает цвет и тип линий слоя, куда он вставляется, своим объектам. Если создание объектов блока выполняется с выполнением определенных условий, то пользователь может устанавливать в чертеже текущие цвет и тип линий, переопределяя тем самым свойства, наследуемые объектами блока.

Если объекты блока созданы с явно заданными свойствами, то единственный способ изменить их свойства это переопределение блока.

См. также

    • Цвета и типы линий объектов в блоках


Изменение цвета и типа линий в блоке (Процедура)

Редактирование определений блоков
На уровень вверх ..
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Для переноса объекта на другой слой

Для назначения цвета слою

Для назначения цвета объекту для использования вместо цвета слоя

Для назначения типа линий слою

Для назначения типа линий объекту для использования вместо типа линий слоя

Для изменения определения имеющегося блока


Для переноса объекта на другой слой (Процедура)

Изменение цвета и типа линий в блоке
На уровень вверх ..
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Для переноса объекта на другой слой

  1. Выбрать объекты, которые необходимо перенести на другой слой.
  2. На панели "Слои" щелкнуть на управляющем списке "Слой".
  3. Выбрать слой, на который требуется перенести объекты.
Ввод команды: СЛОЙ


Для назначения цвета слою (Процедура)

Изменение цвета и типа линий в блоке
На уровень вверх ..
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Для назначения цвета слою

  1. На панели "Слои" выбрать "Диспетчер свойств слоев".
  2. В окне Диспетчера свойств слоев щелкнуть на цвете, который нужно изменить.
  3. В диалоговом окне "Выбор цвета" выполнить одно из следующих действий:
    • На вкладке "Номер цвета" выбрать цвет и нажать "OK".
    • На вкладке "Номер цвета" ввести в поле "Цвет" порядковый номер (1-255). Затем нажать "OK".
    • На вкладке "Вся палитра" выбрать цветовую модель "HSL" и задать значения "H (оттенок)", "S (насыщенность)" и "L (яркость)". Затем нажать "OK".
    • На вкладке "Альбомы цветов" выбрать необходимый альбом, выбрать требуемый цвет. Нажать "ОК".
  4. Нажать "ОК".
Панель:Слои
Ввод команды: СЛОЙ


Для назначения цвета объекту для использования вместо цвета слоя (Процедура)

Изменение цвета и типа линий в блоке
На уровень вверх ..
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Для назначения цвета объекту для использования вместо цвета слоя

  1. На панели "Стандартная" нажать кнопку "Свойства".
  2. Выбрать объекты, цвета которых необходимо изменить.
  3. В панели "Свойства" выбрать свойство "Цвет".

    Справа от поля располагается кнопка со стрелкой.

  4. Щелкнуть на этой кнопке для раскрытия списка и выбрать необходимый цвет.
Панель:Стандартная
Ввод команды: ОКНОСВ


Для назначения типа линий слою (Процедура)

Изменение цвета и типа линий в блоке
На уровень вверх ..
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Для назначения типа линий слою

  1. На панели "Слои" выбрать "Диспетчер свойств слоев".
  2. В окне "Диспетчер свойств слоев" нажать "Загрузить" и выбрать один или несколько типов линий для их загрузки. Затем нажать "OK".

    Для выделения нескольких типов линий используется клавиша CTRL; для выделения диапазона типов линий - клавиша SHIFT.

  3. Выделить слой из списка и нажать "Вкл подробности" для получения доступа к дополнительным опциям диалогового окна.
  4. Выбрать тип линий из списка "Тип линий".
  5. Нажать кнопку "OK".

    Чтобы открыть Диспетчер свойств слоев, выберите меню Формат [image] Слой.Чтобы открыть Диспетчер свойств слоев, введите в командной строке "слой".

Панель:Слои
Ввод команды: СЛОЙ


Для назначения типа линий объекту для использования вместо типа линий слоя (Процедура)

Изменение цвета и типа линий в блоке
На уровень вверх ..
Изменение цвета и типа линий в блоке
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Для назначения типа линий объекту для использования вместо типа линий слоя

  1. Выбрать объекты, типы линий которых необходимо изменить.
  2. Щелкнуть на управляющем списке "Типы линий" панели "Свойства".
  3. Выбрать тип линий для назначения объектам.
Ввод команды: ТИПЛИН


Для изменения определения имеющегося блока (Процедура)

Изменение цвета и типа линий в блоке
На уровень вверх ..
Изменение данных в атрибутах блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Для изменения определения имеющегося блока

  1. Выбрать редактируемый блок.
  2. Щелкнуть правой кнопкой мыши на блоке и выбрать "Свойства" из контекстного меню.
  3. В окне "Свойства" выделить и изменить значения X и Y координат базовой точки, масштабных коэффициентов, угла поворота и других параметров.
Ввод команды: ОКНОСВ


Изменение цвета и типа линий в блоке (Краткий справочник)

Редактирование определений блоков
Изменение цвета и типа линий в блоке
Изменение данных в атрибутах блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение цвета и типа линий в блоке >
Изменение цвета и типа линий в блоке
Понятие Процедура Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

ТИПЛИН

Загрузка, установка и изменение типов линий

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение данных в атрибутах блока (Понятие)

Изменение цвета и типа линий в блоке
Редактирование блоков
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков >
Изменение данных в атрибутах блока
Понятие Процедура Краткий справочник

Пользователь может редактировать значения атрибутов, которые присоединены к блоку и вставлены в чертеж.

Для редактирования значений атрибутов, связанных с блоком, имеется несколько способов:

  • Дважды нажмите на блоке, чтобы открыть "Расширенный редактор атрибутов"
  • Удерживая клавишу CTRL, дважды нажмите на блоке, чтобы открыть контекстный редактор
  • Откройте палитру "Свойства" и выберите блок
  • Введите команду АТРЕД, чтобы открыть диалоговое окно "Редактирование атрибутов"
  • Введите команду "-АТРЕД" для доступа к различным значениям атрибутов и свойствам с помощью командной строки

Изменить положение атрибутов в блоке можно также с помощью ручек. Кроме того, с помощью ручек можно менять ширину текста при работе с многострочными атрибутами.

ПримечаниеЕсли, удерживая клавишу CTRL, дважды нажать на атрибуте, который содержит гиперссылку, откроется соответствующая веб-страница. Для редактирования атрибута, воспользуйтесь одним из перечисленных способов.
См. также

    • Редактирование определений блоков


Для редактирования атрибутов (Процедура)

Изменение цвета и типа линий в блоке
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение данных в атрибутах блока >
Изменение данных в атрибутах блока
Понятие Процедура Краткий справочник

Для редактирования атрибутов

  1. Выберите меню Редактирование [image] Объекты [image] Атрибут [image] Один.
  2. Выбрать редактируемый блок.
  3. В диалоговом окне "Редактор атрибутов блоков" изменить значения атрибутов и нажать "OK".


Изменение данных в атрибутах блока (Краткий справочник)

Изменение цвета и типа линий в блоке
Изменение данных в атрибутах блока
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Изменение данных в атрибутах блока >
Изменение данных в атрибутах блока
Понятие Процедура Краткий справочник

Команды

АТРЕД

Изменение данных атрибутов в блоке

АТРЕДМ

Изменение текстового содержимого атрибута в блоке

АТРОБНОВИТЬ

Обновление вхождений блоков с учетом новых и измененных атрибутов из указанного определения блока

ДИСПАТБЛК

Управление атрибутами выбранного определения блока

АТРЕДАКТ

Редактирование атрибутов во вхождениях блоков

Системные переменные

ATTIPE

Управление отображением контекстного редактора при создании атрибутов мультилиний

ATTMULTI

Управление возможностью создания атрибутов мультилиний

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование определений атрибутов блоков (Понятие)

Изменение данных в атрибутах блока
Редактирование блоков
Расчленение блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Имеется возможность редактирования значений и других свойств атрибутов, уже связанных с вставленными в чертеж блоками.

Изменение атрибутов определений блоков выполняется с помощью Диспетчера атрибутов блоков. Например, в нем можно редактировать:

  • Свойства, определяющие порядок присваивания значений атрибутам и отвечающие за вывод или подавление отображения значений в графической области
  • Свойства, управляющие отображением текста атрибутов на чертеже
  • Свойства, определяющие слой, цвет, вес и тип линий для вывода атрибутов

По умолчанию изменение атрибутов оказывает действие на все имеющиеся вхождения блоков в текущем чертеже.

Изменение свойств атрибутов существующих вхождений блоков не влияет на значения, связанные с этими блоками. Например, если атрибут блока имеет имя "Стоимость" со значением 19,99, то после изменения имени атрибута на "Стоимость единицы" значение останется прежним.

Обновление атрибутов с одинаковыми именами может привести к непредсказуемым результатам. Для выявления одинаковых имен и их изменения можно воспользоваться Диспетчером атрибутов блоков.

Для обновления вхождений блоков в графической области после изменения их постоянных атрибутов и атрибутов вложенных блоков используется команда РЕГЕН.

Изменение порядка запросов на ввод значений атрибутов

Во время создания определения блока порядок выбора атрибутов задает порядок следования запросов на ввод их значений при вставке блока. Изменить этот порядок можно с помощью Диспетчера атрибутов блоков.

Удаление атрибутов блока

В текущем чертеже пользователь может удалять атрибуты из определений блоков, а также из всех существующих вхождений блоков. Атрибуты, удаленные из вхождений блоков, не исчезают в области рисования до регенерации чертежа пользователем с помощью команды РЕГЕН.

Нельзя таким способом удалить все атрибуты из блока; хотя бы один атрибут в блоке должен остаться. Если необходимо удалить все атрибуты, следует переопределить блок.

Обновление вхождений блоков

После внесения изменений в описания блоков пользователь может обновлять вхождения блоков в текущем чертеже. При редактировании свойств атрибутов в описаниях блоков с помощью Диспетчера атрибутов блоков автоматического обновления в чертеже существующих вхождений блоков не происходит. После завершения внесения изменений пользователь может применить изменения ко всем блокам текущего чертежа.

Можно также использовать АТРОБНОВИТЬ для обновления свойств атрибутов во вхождениях блоков с целью согласования с определениями блоков либо для обновления экземпляра блока после переопределения атрибута блока с помощью команды БЛОК, -БЛОК или БЛОКРЕД.

Обновление свойств атрибутов во вхождениях блоков не оказывает никакого влияния на значения этих атрибутов.

Редактирование атрибутов во вхождениях блоков

Можно выбрать атрибут во вхождении блока и использовать палитру "Свойства" с целью изменения их свойств либо можно использовать Дополнительный редактор атрибутов с целью изменения всех атрибутов в выбранном вхождении блока.

См. также

    • Создание атрибутов

    • Редактирование определений блоков


Редактирование определений атрибутов блоков (Процедура)

Изменение данных в атрибутах блока
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для редактирования атрибутов в описаниях блоков

Для включения и отключения применения изменений к существующим вхождениям блоков

Для нахождения одинаковых имен атрибутов блока

Для изменение порядка запросов на ввод значений атрибутов

Для удаления атрибута из определения блока и из всех вхождений блоков

Для обновления измененных атрибутов в существующих вхождениях блоков

Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока


Для редактирования атрибутов в описаниях блоков (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для редактирования атрибутов в описаниях блоков

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Управление атрибутами". В командной строке введите "диспатблк".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.
  3. В списке атрибутов дважды щелкнуть мышью на имени редактируемого атрибута или, выделив его, нажать "Редактировать".
  4. В диалоговом окне "Редактирование атрибута" внести все необходимые изменения и нажать "OK".
Панель:Редактирование-2
Ввод команды: ДИСПАТБЛК


Для включения и отключения применения изменений к существующим вхождениям блоков (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для включения и отключения применения изменений к существующим вхождениям блоков

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Управление атрибутами". В командной строке введите "диспатблк".
  2. В Диспетчере атрибутов блоков нажать "Параметры".
  3. В диалоговом окне "Параметры" выполнить одно из действий:
    • Для применения внесенных изменений к существующим вхождениям блоков установите флажок "Применять к имеющимся вхождениям".
    • Для применения внесенных изменений только к новым вхождениям блоков снимите флажок "Применять к имеющимся вхождениям".
  4. Нажать "ОК".
Панель:Редактирование-2
Ввод команды: ДИСПАТБЛК


Для нахождения одинаковых имен атрибутов блока (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для нахождения одинаковых имен атрибутов блока

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Управление атрибутами". В командной строке введите "диспатблк".
  2. В Диспетчере атрибутов блоков нажать "Параметры".
  3. В диалоговом окне "Параметры" установить опцию "Выделять повторные имена".
  4. Нажать "ОК".
Панель:Редактирование-2
Ввод команды: ДИСПАТБЛК


Для изменение порядка запросов на ввод значений атрибутов (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для изменение порядка запросов на ввод значений атрибутов

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Управление атрибутами". В командной строке введите "диспатблк".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.

    Для выбранного блока выводится список атрибутов в порядке выполнения запросов на ввод их значений.

  3. Для изменения положения атрибута в списке выделить его и нажать кнопку "Вверх" для перемещения вверх по списку или кнопку "Вниз" для перемещения вниз.
    ПримечаниеДля постоянных атрибутов (Режим=C), определяющих константы, эти кнопки недоступны.
Панель:Редактирование-2
Ввод команды: ДИСПАТБЛК


Для удаления атрибута из определения блока и из всех вхождений блоков (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для удаления атрибута из определения блока и из всех вхождений блоков

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Управление атрибутами". В командной строке введите "диспатблк".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.
  3. (Не обязательно) Если атрибуты не нужно удалять из существующих экземпляров блока, щелкните "Настройки" и в диалоговом окне настроек снимите флажок "Применять к имеющимся вхождениям".
  4. В Диспетчере атрибутов блоков выделить атрибут в списке и нажать "Удалить".

    Атрибуты, удаленные из имеющихся экземпляров блоков, не исчезают в графической области до регенерации чертежа пользователем с помощью команды РЕГЕН.

Панель:Редактирование-2
Ввод команды: ДИСПАТБЛК


Для обновления измененных атрибутов в существующих вхождениях блоков (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Редактирование определений атрибутов блоков
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для обновления измененных атрибутов в существующих вхождениях блоков

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Управление атрибутами". В командной строке введите "диспатблк".
  2. В Диспетчере атрибутов блоков выбрать блок из списка или нажать "Выбрать блок" для указания блока в графической области.
  3. Нажать "Обновить" для обновления измененных атрибутов во всех вхождениях, связанных с выбранным блоком.
Панель:Редактирование-2
Ввод команды: ДИСПАТБЛК


Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Расчленение блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Для обновления атрибутов во вхождениях, связанных с выбранным описанием блока

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Обновить атрибуты". В командной строке введите атробновить.
  2. Выполнить одно из действий:
    • Ввести имя, затем ввести имя блока, вхождения которого следует обновить.
    • Ввести ? для получения списка блоков, затем введите имя и имя блока.
    • Нажмите ENTER и затем укажите блок в области чертежа с помощью указывающего устройства.

    При вводе имени несуществующего блока или при выборе блока, не имеющего атрибутов, появляется сообщение об ошибке.

Панель:Редактирование-2
Ввод команды: АТРОБНОВИТЬ

Другой способ

  1. Выберите вкладку "Главная" [image] панель "Блок" [image] "Редактирование отдельного атрибута". В командной строке введите "атредакт".
  2. В графической области выбрать блок для редактирования.
  3. В Редакторе атрибутов блоков выбрать атрибут для редактирования. Пользователь может изменить значение атрибута или перейти на другую вкладку для редактирования других свойств атрибута.
  4. Внести необходимые изменения и затем выполнить одно из следующих действий:
    • Нажать "Применить" для сохранения изменений. Редактор атрибутов блоков остается открытым.

      При нажатии кнопки "Отмена" для выхода из Редактора атрибутов блоков все изменения, сохраненные нажатием кнопки "Применить", остаются в силе.

    • Нажать "OK" для сохранения изменений и выхода из Редактора атрибутов блоков.
    • Нажать "Выбрать блок" для редактирования атрибутов другого блока. Если выполненные изменения для текущего блока не были сохранены, то перед началом выбора нового блока выдается запрос на сохранение.
Панель:Редактирование-2
Ввод команды: АТРЕДАКТ


Редактирование определений атрибутов блоков (Краткий справочник)

Изменение данных в атрибутах блока
Редактирование определений атрибутов блоков
Расчленение блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Редактирование определений атрибутов блоков >
Редактирование определений атрибутов блоков
Понятие Процедура Краткий справочник

Команды

АТРЕДМ

Изменение текстового содержимого атрибута в блоке

АТРОБНОВИТЬ

Обновление вхождений блоков с учетом новых и измененных атрибутов из указанного определения блока

ДИСПАТБЛК

Управление атрибутами выбранного определения блока

АТРЕДАКТ

Редактирование атрибутов во вхождениях блоков

Системные переменные

ATTIPE

Управление отображением контекстного редактора при создании атрибутов мультилиний

ATTMULTI

Управление возможностью создания атрибутов мультилиний

Утилиты

Нет

Ключевые слова для команд

Нет


Расчленение блока (Понятие)

Редактирование определений атрибутов блоков
Редактирование блоков
Методы редактирования
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков >
Расчленение блока
Понятие Процедура Краткий справочник

Для того чтобы получить возможность редактировать отдельные объекты, входящие в блок, необходимо выполнить его расчленение на отдельные компоненты. После этого пользователь может:

  • Создать определение нового блока
  • Переопределить определение имеющегося блока
  • Сохранить объекты в разрозненном виде для различных целей

Имеется возможность автоматического расчленения блоков на месте создаваемых вхождений блоков путем включения опции "Расчленить" диалогового окна "Вставка блока".


Расчленение блока (Процедура)

Редактирование определений атрибутов блоков
На уровень вверх ..
Расчленение блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Расчленение блока >
Расчленение блока
Понятие Процедура Краткий справочник

Для расчленения блока

Управление свойствами при расчленении объекта


Для расчленения блока (Процедура)

Расчленение блока
На уровень вверх ..
Расчленение блока
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Расчленение блока >
Расчленение блока
Понятие Процедура Краткий справочник

Для расчленения блока

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Расчленить". В командной строке введите "расчленить".
  2. Выберите блок для расчленения и нажмите ENTER.

    Блок на месте вхождения расчленяется на отдельные объекты; однако определение блока сохраняется для возможности выполнения вставки в дальнейшем.

Панель:Редактирование
Ввод команды: РАСЧЛЕНИТЬ


Управление свойствами при расчленении объекта (Процедура)

Расчленение блока
На уровень вверх ..
Выбор объектов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Расчленение блока >
Расчленение блока
Понятие Процедура Краткий справочник

Управление свойствами при расчленении объекта

  1. Введите расчленить
  2. Выбрать объекты для расчленения.
  3. Если выбрано более одного объекта, введите и с целью управления свойствами для индивидуальных объектов либо введите г с целью управления свойствами для всех выбранных объектов.
  4. Введите опцию для свойства, которое необходимо изменить.

    Свойство применяется к составному объекту, и заново выводится подсказка.

  5. Введите другую опцию или введите р для расчленения выбранных объектов.

    Выбранные объекты расчленяются, и указанные свойства применяются к компонентным объектам.


Расчленение блока (Краткий справочник)

Редактирование определений атрибутов блоков
Расчленение блока
Выбор отдельных объектов
Создание и редактирование объектов > Создание и использование блоков (обозначений) > Редактирование блоков > Расчленение блока >
Расчленение блока
Понятие Процедура Краткий справочник

Команды

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

РАСЧЛЕНИТЬ

Разбиение составного объекта на отдельные компоненты

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Методы редактирования

Расчленение блока
Создание и редактирование объектов
Выбор объектов
Создание и редактирование объектов >
Методы редактирования

В данной главе описывается, как выбирать объекты, просматривать и редактировать их свойства, а также выполнять различные действия по редактированию объектов.

Темы в этом разделе

  • Выбор объектов

    Для выбора редактируемых объектов предусмотрен широкий набор различных средств и опций.

  • Исправление ошибок

    Имеется возможность отмены действия последней или нескольких последних команд.

  • Стирание объектов

    Удаление объектов из чертежа можно выполнять различными способами.

  • Использование буфера обмена Windows

    При необходимости, объекты из чертежа можно скопировать или вырезать в буфер обмена, а затем вставить эти объекты в файл, открытый в другом приложении.

  • Редактирование объектов

    Объекты можно редактировать, изменяя их размеры, форму и расположение.

  • Редактирование сложных объектов

    Для таких сложных объектов, как блоки, размеры, штриховки и полилинии, предусмотрены дополнительные операции редактирования.


Выбор объектов

Методы редактирования
Методы редактирования
Выбор отдельных объектов
Создание и редактирование объектов > Методы редактирования >
Выбор объектов
Понятие Процедура

Для выбора редактируемых объектов предусмотрен широкий набор различных средств и опций.

См. также
    • Выбор объектов

Темы в этом разделе

  • Выбор отдельных объектов

    В ответ на запрос "Выберите объекты" можно произвести выбор одного или нескольких отдельных объектов.

  • Выбор нескольких объектов

    В ответ на запрос "Выберите объекты" можно одновременно выбрать сразу несколько объектов.

  • Блокирование выбора объектов

    Блокирование слоев позволяет защищать расположенные на них объекты от операций выбора и редактирования.

  • Фильтрация наборов объектов

    Имеется возможность отбора объектов, заносимых в набор, по каким-либо свойствам или по типам.

  • Адаптация параметров выбора объектов

    Можно управлять несколькими аспектами выбора объектов путем задания режима выбора сначала команды или объектов, размера курсора и отображения выбранных объектов.

  • Группы

    Группой называется именованный и сохраненный набор объектов. Пользователь может выбирать и редактировать как сразу всю группу, так и ее отдельные объекты. Группы удобны для согласованного управления несколькими графическими объектами.


Выбор объектов (Процедура)

Расчленение блока
Выбор объектов
Выбор отдельных объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов >
Выбор объектов
Понятие Процедура

Выбор одного объекта

Изменение размера прицела курсора

Для циклического перебора объектов

Исключение объектов из набора

Для получения списка опций при запросе выбора объектов

Для выбора объектов в области неправильной формы

Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы

Для выбора объектов линией выбора

Для исключения нескольких объектов из набора

Для блокирования и разблокирования слоя

Блокирование/разблокирование слоя путем выбора объекта на слое

Для формирования набора объектов с помощью функции быстрого выбора

Для исключения объектов из набора

Для добавления объектов в имеющийся набор

Для сохранения фильтра под заданным именем

Для использования именованного фильтра

Для изменения размера прицела

Для задания параметров выбора объектов

Для включения или отключения просмотра выбранных объектов

Для изменения вида просмотра выбранных объектов

Для исключения объектов из просмотра выбранных

Для изменения вида выбранной области


Выбор отдельных объектов (Понятие)

Выбор объектов
Выбор объектов
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов >
Выбор отдельных объектов
Понятие Процедура Краткий справочник

В ответ на запрос "Выберите объекты" можно произвести выбор одного или нескольких отдельных объектов.

Использование прицела

Если прицел находится в положении для выбора объекта, объект выделяется цветом. Для выбора объекта нажмите кнопку мыши.

Размер прицела можно регулировать на вкладке "Выбор" диалогового окна "Настройка".

Выбор одного из близкорасположенных объектов

Выбор одного из объектов, лежащих близко друг к другу или перекрывающих друг друга, представляет определенную трудность. На примере показаны два отрезка и окружность, которые находятся в прицеле.

Если включен предварительный просмотр набора объектов, можно просматривать объекты по очереди, удерживая нажатой клавишу SHIFT и нажимая клавишу ПРОБЕЛ. Когда нужный объект будет подсвечен, для его выбора нажмите на нем кнопку мыши.

Если предварительный просмотр набора объектов отключен, нажмите и удерживайте SHIFT + ПРОБЕЛ, а затем нажимайте кнопку мыши для переключения между объектами до тех пор пока не будет выбран нужный. Для выхода из режима циклического переключения нажмите ESC.

Исключение объектов из набора

Исключите объекты из текущего набора, удерживая нажатой клавишу SHIFT и повторно выбирая исключаемые объекты.

См. также

    • Выбор и редактирование 3D подобъектов

    • Манипулирование составными телами


Выбор отдельных объектов (Процедура)

Выбор объектов
На уровень вверх ..
Выбор отдельных объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор отдельных объектов >
Выбор отдельных объектов
Понятие Процедура Краткий справочник

Выбор одного объекта

Изменение размера прицела курсора

Для циклического перебора объектов

Исключение объектов из набора


Выбор одного объекта (Процедура)

Выбор отдельных объектов
На уровень вверх ..
Выбор отдельных объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор отдельных объектов >
Выбор отдельных объектов
Понятие Процедура Краткий справочник

Выбор одного объекта

  1. В ответ на запрос "Выберите объекты" какой-либо команды переместите прицел, чтобы объект, который необходимо выбрать, был выделен.
  2. Наведя курсор на объекте, нажмите кнопку мыши.

    Выбранный объект выделяется.

  3. По окончании выбора объектов нажмите ENTER.
    ПримечаниеЕсли значение системной переменной PICKFIRST равно 1 (предварительный выбор), объекты можно выбрать до ввода команды.


Изменение размера прицела курсора (Процедура)

Выбор отдельных объектов
На уровень вверх ..
Выбор отдельных объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор отдельных объектов >
Выбор отдельных объектов
Понятие Процедура Краткий справочник

Изменение размера прицела курсора

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В группе "Размер прицела" вкладки "Выбор" задайте необходимый размер прицела с помощью регулятора.
  3. Нажмите "ОК".
Ввод команды: РЕЖИМРИС


Для циклического перебора объектов (Процедура)

Выбор отдельных объектов
На уровень вверх ..
Выбор отдельных объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор отдельных объектов >
Выбор отдельных объектов
Понятие Процедура Краткий справочник

Для циклического перебора объектов

  1. При отображении запроса "Выберите объекты", нажмите и удерживайте клавиши SHIFT+ПРОБЕЛ. Нажмите кнопкой мыши как можно ближе к нужному объекту.
  2. Последовательно нажимайте кнопку мыши до тех пор, пока нужный объект не будет подсвечен.
  3. Для выбора объекта нажмите ENTER.
ПримечаниеЕсли включен предварительный просмотр набора объектов, можно просматривать объекты по очереди, удерживая нажатой клавишу SHIFT и нажимая клавишу ПРОБЕЛ. Когда нужный объект будет подсвечен, для его выбора нажмите на нем кнопку мыши.


Исключение объектов из набора (Процедура)

Выбор отдельных объектов
На уровень вверх ..
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор отдельных объектов >
Выбор отдельных объектов
Понятие Процедура Краткий справочник

Исключение объектов из набора

  • Нажмите и удерживайте нажатой клавишу SHIFT. Выберите объекты, которые необходимо исключить из набора.


Выбор отдельных объектов (Краткий справочник)

Расчленение блока
Выбор отдельных объектов
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор отдельных объектов >
Выбор отдельных объектов
Понятие Процедура Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

ВЫБРАТЬ

Занесение выбранных объектов в текущий набор

Системные переменные

3DSELECTIONMODE

Управление приоритетом выбора визуально перекрывающихся объектов при применении 3D визуальных стилей

HIGHLIGHT

Управление подсветкой объектов; не влияет на объекты, имеющие ручки

LEGACYCTRLPICK

Задание клавиш циклического повторения выбора и определение действий при нажатии клавиши CTRL и левой кнопки мыши

PICKADD

Управление дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)

PICKAUTO

Управление автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты"

PICKBOX

Размер прицела выбора объектов (в пикселах)

PICKDRAG

Управление способом создания рамки выбора

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

Утилиты

Нет

Ключевые слова для команд

Нет


Выбор нескольких объектов (Понятие)

Выбор отдельных объектов
Выбор объектов
Блокирование выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

В ответ на запрос "Выберите объекты" можно одновременно выбрать сразу несколько объектов.

Укажите прямоугольную область выбора

Укажите противоположные углы для определения прямоугольной области. Цвет фона в области изменится, и фон станет прозрачным. Направление, в котором перемещается курсор из начальной точки в противоположный угол, определяет выбор объектов.

  • Выбор рамкой. Перетащите курсор слева направо, чтобы выбрать только объекты, которые полностью заключены в прямоугольную область.
  • Пересечение секущей рамкой. Перетащите курсор слева направо, чтобы выбрать объекты, которые заключены или пересечены рамкой.

При выборе рамкой выбираемые объекты должны полностью находиться в прямоугольной области. Однако, если объект построен прерывистой линией (пунктиром) и виден в видовом экране лишь частично, а все видимые векторы типа линии включены в окно выбора, то будет выбран объект целиком.

Выбор области неправильной формы

Укажите точки для определения области неправильной формы. Многоугольная рамка используется для выбора объектов, полностью расположенные в пределах области выбора. Для выбора объектов, расположенных в области выбора полностью или пересекаемых ей, используется секущая рамка многоугольника.

Линии выбора

Используйте линии выбора на сложном чертеже. Линия выбора похожа на полилинию, и предназначена только для выбора объектов, через которые она проходит. На чертеже показана линия выбора, с помощью которой выбираются несколько элементов на печатной плате.

Использование других опций выбора

Для просмотра всех вариантов выбора достаточно ввести "?" в ответ на запрос "Выберите объекты". Дополнительные сведения о каждой из опций выбора см. в описании команды ВЫБРАТЬ.

Исключение нескольких объектов из набора

В ответ на запрос "Выберите объекты" можно ввести и (Исключить), а затем одним из доступных средств выделить объекты для исключения их из набора. Для возврата из режима исключения и продолжения пополнения набора выбираемых объектов следует ввести д (Добавить).

Объекты можно также исключать из текущего набора, удерживая нажатой клавишу SHIFT и повторно выбирая исключаемые объекты по отдельности, или удерживая нажатой клавишу SHIFT и перетаскивая рамку выбора или секущую рамку. В текущий набор можно добавлять и удалять объекты без ограничений.


Выбор нескольких объектов (Процедура)

Выбор отдельных объектов
На уровень вверх ..
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор нескольких объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

Для получения списка опций при запросе выбора объектов

Для выбора объектов в области неправильной формы

Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы

Для выбора объектов линией выбора

Для исключения нескольких объектов из набора


Для получения списка опций при запросе выбора объектов (Процедура)

Выбор нескольких объектов
На уровень вверх ..
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор нескольких объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

Для получения списка опций при запросе выбора объектов

  • Введите ? в ответ на запрос "Выберите объекты".


Для выбора объектов в области неправильной формы (Процедура)

Выбор нескольких объектов
На уровень вверх ..
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор нескольких объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

Для выбора объектов в области неправильной формы

  1. В ответ на запрос "Выберите объекты" введите рм (РМн-угол).
  2. Укажите точки, которые определяют область, полностью охватывающую объекты для выбора.
  3. Нажмите ENTER для замыкания многоугольной рамки выбора и завершения выбора.


Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы (Процедура)

Выбор нескольких объектов
На уровень вверх ..
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор нескольких объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

Для выбора объектов, входящих в область неправильной формы или пересекающих ее границы

  1. В ответ на запрос "Выберите объекты" введите см (СМн-угол).
  2. Укажите точки, которые определяют область, охватывающую или пересекающую объекты для выбора.
  3. Нажмите ENTER для замыкания многоугольной рамки выбора и завершения выбора.


Для выбора объектов линией выбора (Процедура)

Выбор нескольких объектов
На уровень вверх ..
Выбор нескольких объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор нескольких объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

Для выбора объектов линией выбора

  1. В ответ на запрос "Выберите объекты" введите л (Линия).
  2. Укажите точки, которые определяют линию выбора, проходящую через выбираемые объекты.
  3. Для завершения выбора нажмите ENTER.


Для исключения нескольких объектов из набора (Процедура)

Выбор нескольких объектов
На уровень вверх ..
Блокирование выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор нескольких объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

Для исключения нескольких объектов из набора

  1. В ответ на запрос "Выберите объекты" после выбора объектов введите и (Исключить).
  2. Введите любую опцию выбора, например, мн-секрамка (Секущая рамка многоугольника) или л (Линия) и выберите объекты, подлежащие удалению из набора объектов.

    Для возврата к операции добавления объектов введите д (Добавить).


Выбор нескольких объектов (Краткий справочник)

Выбор отдельных объектов
Выбор нескольких объектов
Блокирование выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Выбор нескольких объектов >
Выбор нескольких объектов
Понятие Процедура Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

БВЫБОР

Быстрое создание набора объектов на основе заданных критериев фильтрации

ВЫБРАТЬ

Занесение выбранных объектов в текущий набор

Системные переменные

HIGHLIGHT

Управление подсветкой объектов; не влияет на объекты, имеющие ручки

PICKADD

Управление дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)

PICKAUTO

Управление автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты"

PICKBOX

Размер прицела выбора объектов (в пикселах)

PICKDRAG

Управление способом создания рамки выбора

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

PREVIEWEFFECT

Определение визуального эффекта, используемого для предварительного просмотра набора объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Блокирование выбора объектов (Понятие)

Выбор нескольких объектов
Выбор объектов
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов >
Блокирование выбора объектов
Понятие Процедура Краткий справочник

Блокирование слоев позволяет защищать расположенные на них объекты от операций выбора и редактирования.

Как правило, на блокированных слоях невозможно выполнять редактирование объектов. Другие же операции остаются доступными и на блокированных слоях. Например, блокированный слой можно сделать текущим и разместить на нем новый объект. Кроме того, остаются доступными команды получения различных сведений (например, СПИСОК), режимы объектной привязки для указания характерных точек объектов на блокированных слоях и операция смены порядка прорисовки объектов.

Чтобы различать заблокированные и разблокированные слои, можно:

  • Навести курсор на объект и посмотреть, появится ли значок замка
  • Затенить объекты на заблокированных слоях
ПримечаниеДля объектов, расположенных на заблокированных слоях, ручки не отображаются.


Блокирование выбора объектов (Процедура)

Выбор нескольких объектов
На уровень вверх ..
Блокирование выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Блокирование выбора объектов >
Блокирование выбора объектов
Понятие Процедура Краткий справочник

Для блокирования и разблокирования слоя

Блокирование/разблокирование слоя путем выбора объекта на слое


Для блокирования и разблокирования слоя (Процедура)

Блокирование выбора объектов
На уровень вверх ..
Блокирование выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Блокирование выбора объектов >
Блокирование выбора объектов
Понятие Процедура Краткий справочник

Для блокирования и разблокирования слоя

  1. На панели "Слои" выберите "Диспетчер свойств слоев".
  2. В "Диспетчере свойств слоев" нажмите мышью на значке блокирования (с изображением замка) для тех слоев, которые нужно заблокировать или разблокировать.
  3. Нажмите "ОК".

    Закрытый замок, изображенный на значке, означает блокированный слой. На таком слое недоступны операции выбора объектов.

Панель:Слои
Ввод команды: СЛОЙ


Блокирование/разблокирование слоя путем выбора объекта на слое (Процедура)

Блокирование выбора объектов
На уровень вверх ..
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Блокирование выбора объектов >
Блокирование выбора объектов
Понятие Процедура Краткий справочник

Блокирование/разблокирование слоя путем выбора объекта на слое

  1. Перейдите на вкладку "Модель".
  2. Выполните одно из следующих действий:
    • Выберите меню Формат [image] Инструменты слоя [image] Блокировать слой.В командной строке введите "слойблк".
    • Выберите меню Формат [image] Инструменты слоя [image] Разблокировать слой.В командной строке введите "слойразбл".
  3. Выберите объект на слое, который требуется блокировать или разблокировать.
Панель:Слои-2
Ввод команды: СЛОЙБЛК, СЛОЙРАЗБЛ


Блокирование выбора объектов (Краткий справочник)

Выбор нескольких объектов
Блокирование выбора объектов
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Блокирование выбора объектов >
Блокирование выбора объектов
Понятие Процедура Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

СЛОЙОТД

Скрытие или блокировка всех слоев, отличных от слоев с выбранными объектами

СЛОЙБЛК

Блокировка слоя выбранного объекта

СЛОЙРАЗБЛ

Отмена блокирования слоя выбранного объекта

Системные переменные

LAYLOCKFADECTL

Управление затенением объектов на заблокированных слоях

Утилиты

Нет

Ключевые слова для команд

Нет


Фильтрация наборов объектов (Понятие)

Блокирование выбора объектов
Выбор объектов
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Имеется возможность отбора объектов, заносимых в набор, по каким-либо свойствам или по типам.

Имеется возможность отбора объектов, заносимых в набор выбора, по каким-либо характеристикам (цвет, тип объекта и т.п.) с помощью диалоговых окон "Быстрый выбор" (БВЫБОР) и "Фильтры выбора объектов" (ФИЛЬТР). Например, можно выбрать на чертеже только окружности красного цвета или, наоборот, выбрать все объекты, кроме окружностей красного цвета.

Функция "Быстрый выбор" позволяет быстро сформировать набор объектов по заданному критерию отбора. Если для добавления классификации функций в объект использовались Autodesk или программы других разработчиков, пользователь может выбирать объекты по свойству, упомянутому в классификации. В диалоговом окне "Фильтры выбора объектов" задаются и сохраняются для дальнейшего применения различные фильтры выбора.

При работе с функциями "Быстрый выбор" или "Фильтры выбора объектов" и фильтрации по цвету, типу линий или весу линий, сначала проверьте, задаются ли эти свойства ПОСЛОЮ для всех объектов чертежа. Например, объект может быть красным, потому что имеет цвет ПОСЛОЮ, а слою присвоен красный цвет.

См. также

    • Адаптация параметров выбора объектов

    • Работа со слоями


Фильтрация наборов объектов (Процедура)

Блокирование выбора объектов
На уровень вверх ..
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Фильтрация наборов объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Для формирования набора объектов с помощью функции быстрого выбора

Для исключения объектов из набора

Для добавления объектов в имеющийся набор

Для сохранения фильтра под заданным именем

Для использования именованного фильтра


Для формирования набора объектов с помощью функции быстрого выбора (Процедура)

Фильтрация наборов объектов
На уровень вверх ..
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Фильтрация наборов объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Для формирования набора объектов с помощью функции быстрого выбора

В следующем примере для выбора на чертеже всех объектов красного цвета используется функция "Быстрый выбор".

  1. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Быстрый выбор".В командной строке введите "бвыбор".
  2. В диалоговом окне "Быстрый выбор" из списка "Применить" выберите "Ко всему чертежу".
  3. В списке "Тип объектов" выберите "Несколько".
  4. В списке "Свойства" выберите "Цвет".
  5. В списке "Оператор" выберите "Равно".
  6. В списке "Значение" выберите "Красный".
  7. В группе "Отобранные объекты" выберите "Включить в новый набор".
  8. Нажмите "ОК".

    На чертеже выбираются все объекты красного цвета, и диалоговое окно "Быстрый выбор" закрывается. Если слой имеет красный цвет, то объекты красного цвета, унаследовавшие его ПОСЛОЮ, не включаются в набор объектов.

ПримечаниеЕсли для добавления классификации функций в объект использовались приложения, подобные Autodesk Map, и если имеется файл классификации (XML), пользователь может выбирать объекты по свойству, упомянутому в классификации. Так, можно выбрать классификацию в поле "Тип объекта" и его свойства в поле "Свойства".
Ввод команды: БВЫБОР


Для исключения объектов из набора (Процедура)

Фильтрация наборов объектов
На уровень вверх ..
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Фильтрация наборов объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Для исключения объектов из набора

Опция "Исключить из нового набора" позволяет исключать объекты из текущего набора. В следующем примере из имеющегося набора исключаются все круги с радиусом больше 1.

  1. Выберите несколько объектов.
  2. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Быстрый выбор".В командной строке введите "бвыбор".
  3. В диалоговом окне "Быстрый выбор" из списка "Применить" выберите "Текущий набор".
  4. В списке "Тип объектов" выберите "Круг".
  5. В списке "Свойства" выберите "Радиус".
  6. В списке "Оператор" выберите "Больше".
  7. В поле "Значение" введите 1.
  8. В группе "Отобранные объекты" выберите "Исключить из нового набора".
  9. Нажмите "ОК".

    Все окружности с радиусом превышающим 1 исключаются из набора.

Ввод команды: БВЫБОР


Для добавления объектов в имеющийся набор (Процедура)

Фильтрация наборов объектов
На уровень вверх ..
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Фильтрация наборов объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Для добавления объектов в имеющийся набор

Функцией "Быстрый выбор" можно воспользоваться для добавления объектов в имеющийся набор. В следующем примере к текущему набору объектов добавляются все объекты чертежа, содержащие гиперссылки, которые начинаются на bld1_.

  1. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Быстрый выбор".В командной строке введите "бвыбор".
  2. В диалоговом окне "Быстрый выбор" установить флажок "Добавить в текущий набор".
  3. В списке "Тип объектов" выберите "Несколько".
  4. В списке "Свойства" выберите "Гиперссылка".
  5. В списке "Оператор" выберите "* Поиск с глобальными символами".
  6. В поле "Значение" введите bld1_*.
  7. В группе "Отобранные объекты" выберите "Включить в новый набор".
  8. Нажмите "ОК".
Ввод команды: БВЫБОР


Для сохранения фильтра под заданным именем (Процедура)

Фильтрация наборов объектов
На уровень вверх ..
Фильтрация наборов объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Фильтрация наборов объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Для сохранения фильтра под заданным именем

  1. В командной строке введите фильтр.
  2. В диалоговом окне "Фильтры выбора объектов" из раскрывающегося списка "Выбор фильтра" выберите один из фильтров, например, Отрезок.
  3. Нажмите "Добавить в список".
  4. В поле справа от кнопки "Сохранить как" введите имя, например, "Фильтр отрезков".
  5. Нажмите "Сохранить как".
  6. Нажмите кнопку "Применить".

    Применяется фильтр, после чего можно выбрать на чертеже только отрезки. При выборе объектов с помощью рамки фильтр применяется ко всем попадающим в нее объектам.

Ввод команды: ФИЛЬТР


Для использования именованного фильтра (Процедура)

Фильтрация наборов объектов
На уровень вверх ..
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Фильтрация наборов объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Для использования именованного фильтра

  1. В ответ на запрос "Выберите объекты" введите 'фильтр. (Апостроф перед именем команды превращает ее в прозрачную.)
  2. В диалоговом окне "Фильтры выбора объектов" из раскрывающегося списка "Выбор фильтра" выберите нужный фильтр. Нажмите кнопку "Применить".
  3. Выберите объекты секущей рамкой.

    В набор включаются объекты, выбранные секущей рамкой и отвечающие условиям фильтра.


Фильтрация наборов объектов (Краткий справочник)

Блокирование выбора объектов
Фильтрация наборов объектов
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Фильтрация наборов объектов >
Фильтрация наборов объектов
Понятие Процедура Краткий справочник

Команды

ФИЛЬТР

Создает список свойств, которыми должен обладать объект, чтобы быть выбранным

ОКНОСВ

Управление свойствами объектов

БВЫБОР

Быстрое создание набора объектов на основе заданных критериев фильтрации

ВЫБРАТЬ

Занесение выбранных объектов в текущий набор

Системные переменные

PICKADD

Управление дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)

PICKAUTO

Управление автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты"

PICKBOX

Размер прицела выбора объектов (в пикселах)

PICKDRAG

Управление способом создания рамки выбора

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

Утилиты

Нет

Ключевые слова для команд

Нет


Адаптация параметров выбора объектов (Понятие)

Фильтрация наборов объектов
Выбор объектов
Группы
Создание и редактирование объектов > Методы редактирования > Выбор объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Можно управлять несколькими аспектами выбора объектов путем задания режима выбора сначала команды или объектов, размера курсора и отображения выбранных объектов.

Для команд, в которых используется запрос "Выберите объекты", можно выполнить следующее:

  • Вначале ввести команду, затем произвести выбор объектов
  • Вначале выбрать объекты, затем вызвать команду

Пользователь может также выбирать

  • Просматривать ли объекты, которые необходимо выбрать, во время выбора
  • Выделяются ли цветом ли выбранные объекты
  • Как определяются области выбора и создаются наборы объектов

Если начинать с выбора команды

После использования команды редактирования, отобразится запрос "Выберите объекты", и прицел заменит курсоры в форме перекрестия. На запрос "Выберите объекты" отреагируйте одним из следующих способов:

  • Выберите одновременно сразу все нужные объекты.
  • Щелкните в пустой области. Перетащите курсор, чтобы образовалась квадратная область выбора.
  • Введите опцию выбора. Введите ? для отображения всех параметров выбора.
  • Комбинируйте различные методы выбора. Например, для выбора большинства объектов в области рисования выберите все объекты, а затем исключите ненужные объекты.
  • Введите 'фильтр для использования именованного фильтра выбора. Символ апострофа указывает на прозрачное выполнение команды.

Если начинать с выбора объектов

Можно использовать один из двух методов для выбора объектов до вызова команды.

  • Введите команду ВЫБРАТЬ, затем введите "?" для отображения всех опций выбора. Все выбираемые объекты включаются в текущий набор. При выполнении последующей команды в ответ на запрос "Выберите объекты" введите т для использования набора предварительно выбранных объектов.
  • Если режим предварительного выбора включен, выбирайте объекты при отсутствии выполняемой команды перед вызовом таких команд, как ПЕРЕНЕСТИ, КОПИРОВАТЬ или СТЕРЕТЬ. В данном случае выбор может осуществляться только с помощью мыши (щелчками на каждом объекте), или путем автоматического выбора.
  • Введите бвыбор для использования фильтра выбора. Затем при выполнении последующей команды в ответ на запрос "Выберите объекты" введите т.

Выделение объектов для выбора

Объекты выделяются при перемещении прицела над ними, обеспечивая просмотр объектов, которые будут выбраны, если их нажать кнопкой мыши.

После того как указана область для выбора нескольких объектов, фон области становится прозрачным.

Эти эффекты просмотра выбранных объектов включены по умолчанию. Их можно выключить или изменить вид просмотра выбранных объектов (диалоговое окно "Настройка", вкладка "Выбор"). Если для системной переменной PICKBOX установлено значение 0, просмотр выбранных объектов недоступен.

Управление отображением выбранных объектов

По умолчанию выбранные объекты отображаются с прерывистыми линиями. Можно увеличить производительность программы, установив для системной переменной HIGHLIGHT значение 0. Однако эта возможность используется редко и только при работе с большими чертежами.

Задание параметров выбора объектов по умолчанию

С помощью параметров на вкладке "Выбор" диалогового окна "Настройка" можно контролировать методы выбора объектов, используемые по умолчанию.

  • Использовать эффекты просмотра выбранных объектов и эффекты выбранной области.
  • Выбирать объекты до ввода команды (предварительный выбор) или после ввода команды. (PICKFIRST)
  • Добавлять объекты в набор выбранных объектов при нажатой клавише SHIFT. (PICKADD)
  • Создавать рамку выбора нажатием кнопки мыши и перетаскиванием. Если соответствующий флажок снят, для создания рамки выбора нужно указать ее углы двумя щелчками мыши. PICKDRAG
  • Начинать операцию выбора рамкой или секущей рамкой автоматически при указании точки вне объектов. Если соответствующий флажок снят, для создания рамки или секущей рамки нужно ввести сили р. PICKAUTO
  • Изменять размер прицела. (PICKBOX)
  • Выбирать все объекты в группе при выборе одного объекта в этой группе.
  • При выборе штриховки включать контур в набор выбранных объектов.


Адаптация параметров выбора объектов (Процедура)

Фильтрация наборов объектов
На уровень вверх ..
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Для изменения размера прицела

Для задания параметров выбора объектов

Для включения или отключения просмотра выбранных объектов

Для изменения вида просмотра выбранных объектов

Для исключения объектов из просмотра выбранных

Для изменения вида выбранной области


Для изменения размера прицела (Процедура)

Адаптация параметров выбора объектов
На уровень вверх ..
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Для изменения размера прицела

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Параметры", в группе "Размер прицела" на вкладке "Выбор" задайте необходимый размер прицела с помощью скользящей шкалы.
  3. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Для задания параметров выбора объектов (Процедура)

Адаптация параметров выбора объектов
На уровень вверх ..
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Для задания параметров выбора объектов

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", измените области просмотра выбора и режимов выбора, а также размер прицела.
  3. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Для включения или отключения просмотра выбранных объектов (Процедура)

Адаптация параметров выбора объектов
На уровень вверх ..
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Для включения или отключения просмотра выбранных объектов

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", включите или отключите параметр следующим образом.
    • Выберите параметр "Когда активна команда" для отображения флажка.
    • Выберите параметр "Если нет активных команд" для отображения флажка.
    • Выберите оба параметра для включения режима просмотра выбранных объектов каждый раз, когда это возможно.
    • Отключите оба параметра для полного выключения режима просмотра выбранных объектов.
    Ввод команды: SELECTIONPREVIEW


Для изменения вида просмотра выбранных объектов (Процедура)

Адаптация параметров выбора объектов
На уровень вверх ..
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Для изменения вида просмотра выбранных объектов

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", выберите "Параметры визуальных эффектов".
  3. В диалоговом окне "Параметры визуальных эффектов" выберите один из следующих параметров.
    • Пунктир. Отображает прерывистые линии.
    • Придать толщину. Отображает утолщенные линии.
    • Оба. Отображает прерывистые и утолщенные линии.
  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".


Для исключения объектов из просмотра выбранных (Процедура)

Адаптация параметров выбора объектов
На уровень вверх ..
Адаптация параметров выбора объектов
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Для исключения объектов из просмотра выбранных

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", выберите "Параметры визуальных эффектов".
  3. В диалоговом окне "Параметры визуальных эффектов" выберите "Дополнительные опции".
  4. В диалоговом окне "Дополнительные опции просмотра" выберите любой из следующих параметров для исключения объектов из просмотра выбранных.
    • Исключить объекты на заблокированных слоях
    • Внешние ссылки
    • Таблицы
    • Группы
    • Многострочные тексты
    • штриховки
  5. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".


Для изменения вида выбранной области (Процедура)

Адаптация параметров выбора объектов
На уровень вверх ..
Группы
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Для изменения вида выбранной области

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка", на вкладке "Выбор", выберите "Параметры визуальных эффектов".
  3. В диалоговом окне "Параметры визуальных эффектов" измените один из следующих параметров.
    • Указать область. Выберите для отображения эффектов для областей.
    • Цвет рамки выбора. Выберите один из цветов, или воспользуйтесь элементом "Выбор цвета" для вызова диалогового окна "Выбор цвета". (системная переменная WINDOWAREACOLOR)
    • Цвет секущей рамки выбора. Выберите один из стандартных цветов, или воспользуйтесь элементом "Выбор цвета" для вызова диалогового окна выбора цвета. (системная переменная CROSSINGAREACOLOR)
    • Затенение выбранной области. Использовать указатель для установки прозрачности для областей выбора. Чем меньше значение настройки, тем прозрачнее область. При значении, равном 100 единицам, область становится непрозрачной. (системная переменная SELECTIONAREAOPACITY)
  4. Для выхода из каждого диалогового окна необходимо нажимать кнопку "ОК".


Адаптация параметров выбора объектов (Краткий справочник)

Фильтрация наборов объектов
Адаптация параметров выбора объектов
Коротко о группах
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Адаптация параметров выбора объектов >
Адаптация параметров выбора объектов
Понятие Процедура Краткий справочник

Команды

ФИЛЬТР

Создает список свойств, которыми должен обладать объект, чтобы быть выбранным

ОКНОСВ

Управление свойствами объектов

БВЫБОР

Быстрое создание набора объектов на основе заданных критериев фильтрации

Системные переменные

CROSSINGAREACOLOR

Управление цветом области выбора в процессе выбора с помощью секущей рамки

DRAGMODE

Управление отображением объектов при перетаскивании

HIGHLIGHT

Управление подсветкой объектов; не влияет на объекты, имеющие ручки

PICKADD

Управление дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)

PICKAUTO

Управление автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты"

PICKBOX

Размер прицела выбора объектов (в пикселах)

PICKDRAG

Управление способом создания рамки выбора

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

PREVIEWEFFECT

Определение визуального эффекта, используемого для предварительного просмотра набора объектов

PREVIEWFILTER

Исключение указанных типов объектов из области предварительного выбора

SELECTIONAREA

Управление отображением эффектов для областей выбора

SELECTIONAREAOPACITY

Управление прозрачностью области выбора в процессе выбора рамки и секущей рамки

SELECTIONPREVIEW

Управление отображением предварительного просмотра выбранных объектов

WINDOWAREACOLOR

Управление цветом прозрачной области выбора в процессе выбора с помощью рамки

Утилиты

Нет

Ключевые слова для команд

Нет


Группы

Адаптация параметров выбора объектов
Выбор объектов
Коротко о группах
Создание и редактирование объектов > Методы редактирования > Выбор объектов >
Группы
Понятие Процедура

Группой называется именованный и сохраненный набор объектов. Пользователь может выбирать и редактировать как сразу всю группу, так и ее отдельные объекты. Группы удобны для согласованного управления несколькими графическими объектами.

Темы в этом разделе

  • Коротко о группах
  • Создание групп

    При создании группы выбираются объекты, задается ее имя и описание.

  • Выбор объектов в группах

    Существует несколько способов выбора групп объектов, включая выбор группы по имени или выбор указанием одного из элементов группы.

  • Редактирование групп

    Можно изменять группы несколькими способами, включая изменение их состава, изменение их свойств, корректировку имен и описаний к группам и удаление их из чертежа.


Группы (Процедура)

Адаптация параметров выбора объектов
На уровень вверх ..
Создание групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы >
Группы
Понятие Процедура

Для создания группы

Определение возможности индивидуального выбора объектов, входящих в группу

Определение возможности выбора конкретной группы

Для удаления именованной группы

Для переупорядочения элементов группы


Коротко о группах (Понятие)

Группы
Группы
Создание групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы >
Коротко о группах
Понятие Краткий справочник

Группой называется именованный и сохраненный набор объектов. Пользователь может выбирать и редактировать как сразу всю группу, так и ее отдельные объекты. Группы удобны для согласованного управления несколькими графическими объектами. Можно создавать их быстро, назначая им имена по умолчанию.

СоветГруппы полезны при связывании 3D тел в случаях, когда не требуется их объединение с помощью булевой операции.

Имеется возможность в любой момент добавлять в группу или исключить из нее элементы.

В некоторой степени группы напоминают блоки, которые также объединяют объекты с присвоением имени, но несколько иным способом. Например, группы можно сохранять для использования в следующих сеансах работы. Различие - в том, что пользователь может редактировать отдельные объекты в группе, тогда как при работе с блоками для этого необходимо сначала расчленить блок на отдельные элементы. В отличие от блоков, группы нельзя использовать в других чертежах.


Коротко о группах (Краткий справочник)

Адаптация параметров выбора объектов
Коротко о группах
Создание групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Коротко о группах >
Коротко о группах
Понятие Краткий справочник

Команды

ГРУППА

Создание именованных наборов объектов (групп) и управление ими

Системные переменные

PICKSTYLE

Управление выбором групп и ассоциативной штриховки

Утилиты

Нет

Ключевые слова для команд

Нет


Создание групп (Понятие)

Коротко о группах
Группы
Выбор объектов в группах
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы >
Создание групп
Понятие Процедура Краткий справочник

При создании группы выбираются объекты, задается ее имя и описание.

При создании группы задается ее имя и описание. При копировании группы новой копии по умолчанию присваивается имя Ax; новая группа считается неименованной. Неименованные группы не выводятся в списке диалогового окна "Группы объектов", если не установлена опция "Включая неименованные".

При выборе хотя бы одного элемента выбираемой группы, все ее элементы включаются в новую группу.

Объект может входить одновременно в несколько групп, а группа может входить в другие группы. Для восстановления конфигураций исходных групп можно выполнить разгруппирование вложенных групп.

При использовании чертежа в качестве внешней ссылки или вставляемого блока именованные группы внутри этого чертежа становятся недоступны. Однако пользователь может внедрить и затем расчленить внешнюю ссылку или блок, после чего группы становятся доступными как неименованные.

ПримечаниеСледует избегать создания больших групп, содержащих сотни и тысячи объектов. Большие группы значительно снижают производительность этой программы.


Для создания группы (Процедура)

Группы
На уровень вверх ..
Выбор объектов в группах
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Создание групп >
Создание групп
Понятие Процедура Краткий справочник

Для создания группы

  1. В командной строке введите группа.
  2. В группе "Идентификация группы" диалогового окна "Группы объектов" введите имя группы и описание к ней.
  3. Нажмите кнопку "Новая".

    Диалоговое окно временно закрывается.

  4. Выберите объекты и нажмите ENTER.
  5. Нажмите "ОК".
Ввод команды: ГРУППА


Создание групп (Краткий справочник)

Коротко о группах
Создание групп
Выбор объектов в группах
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Создание групп >
Создание групп
Понятие Процедура Краткий справочник

Команды

ГРУППА

Создание именованных наборов объектов (групп) и управление ими

Системные переменные

PICKSTYLE

Управление выбором групп и ассоциативной штриховки

Утилиты

Нет

Ключевые слова для команд

Нет


Выбор объектов в группах (Понятие)

Создание групп
Группы
Редактирование групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы >
Выбор объектов в группах
Понятие Процедура Краткий справочник

Существует несколько способов выбора групп объектов, включая выбор группы по имени или выбор указанием одного из элементов группы.

Группу можно выбрать, введя ее имя в ответ на запрос "Выберите объекты". Если системная переменная PICKSTYLE имеет значение 1 или 3, при выборе любого элемента выбираемой группы выбираются также все входящие в нее элементы, отвечающие заданному критерию. Для включения и отключения режима выбора групп можно использовать комбинацию клавиш CTRL+H или SHIFT+CTRL+A.

Все элементы выбираемой группы выбираются также при циклическом переборе объектов; например, при выборе объекта, полностью покрытого другим. При выборе объекта, принадлежащего нескольким группам, выбираются все элементы всех групп, в которые он входит. Для редактирования с помощью ручек группу следует выбирать с помощью устройства указания в ответ на запрос "Команда:".


Выбор объектов в группах (Процедура)

Создание групп
На уровень вверх ..
Выбор объектов в группах
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Выбор объектов в группах >
Выбор объектов в группах
Понятие Процедура Краткий справочник

Определение возможности индивидуального выбора объектов, входящих в группу

Определение возможности выбора конкретной группы


Определение возможности индивидуального выбора объектов, входящих в группу (Процедура)

Выбор объектов в группах
На уровень вверх ..
Выбор объектов в группах
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Выбор объектов в группах >
Выбор объектов в группах
Понятие Процедура Краткий справочник

Определение возможности индивидуального выбора объектов, входящих в группу

Выполните одно из следующих действий:

  • В командной строке введите команду pickstyle. Введите 1 для включения режима выбора группы. Объекты, входящие в группу, можно выбирать не по отдельности, а только в виде группы.
  • В командной строке введите команду pickstyle. Введите 0 для отключения режима выбора группы. Объекты, входящие в группу, можно выбирать только по отдельности, но не в виде группы.
  • В любое время можно включать и отключать режим выбора групп с помощью комбинаций клавиш CTRL+H или SHIFT+CTRL+A.


Определение возможности выбора конкретной группы (Процедура)

Выбор объектов в группах
На уровень вверх ..
Редактирование групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Выбор объектов в группах >
Выбор объектов в группах
Понятие Процедура Краткий справочник

Определение возможности выбора конкретной группы

  1. В командной строке введите команду группа.
  2. Во вкладке "Имя группы" в диалоговом окне "Группа объектов" выберите группу, для которой необходимо изменить возможность выбора.
  3. Во вкладке "Изменить группу" выберите опцию "Выбираемая".

    При этом изменяется возможность выбора объектов, входящих в группу, в виде группы, что определяется системной переменной PICKSTYLE. Если возможность выбора выключена, входящие в группу объекты выбираются только в виде индивидуальных объектов. В списке "Выбираемые" вверху диалогового окна "Группа объектов" отображается текущее состояние для каждой группы.

  4. Нажмите "ОК".


Выбор объектов в группах (Краткий справочник)

Создание групп
Выбор объектов в группах
Редактирование групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Выбор объектов в группах >
Выбор объектов в группах
Понятие Процедура Краткий справочник

Команды

ГРУППА

Создание именованных наборов объектов (групп) и управление ими

Системные переменные

PICKSTYLE

Управление выбором групп и ассоциативной штриховки

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование групп (Понятие)

Выбор объектов в группах
Группы
Исправление ошибок
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы >
Редактирование групп
Понятие Процедура Краткий справочник

Можно изменять группы несколькими способами, включая изменение их состава, изменение их свойств, корректировку имен и описаний к группам и удаление их из чертежа.

Редактирование объекта в качестве группы

Если включен режим выбора групп, то группы можно перемещать, копировать, поворачивать и редактировать точно так же, как индивидуальные объекты. Для редактирования отдельного объекта в группе необходимо выключить режим выбора групп или воспользоваться ручками на объекте. Дополнительную информацию см. в разделе Выбор объектов в группах.

В некоторых случаях полезно управлять очередностью, в которой выбираются объекты, принадлежащие одной и той же группе. Например, пользовательская программа, определяющая траектории перемещения инструмента для числового управления, может зависеть от ряда смежных объектов в указанной очередности.

Переупорядочение элементов может быть выполнено двумя способами: либо изменить порядковые позиции отдельных элементов (как по одному, так и для нескольких), либо изменить порядок следования всех элементов. Нумерация объектов группы начинается с 0, а не с 1.

Изменение имени, описания и состава элементов группы

С помощью диалогового окна "Группа объектов" можно в любое время задавать объекты для добавления в группу или удаления из группы. Можно также изменять имя или описание группы. Если при удалении из чертежа или исключении объекта группа остается пустой, ее описание сохраняется без описания составных элементов.

ПримечаниеРасчленение такого объекта, как экземпляр блока или штриховка, принадлежащего группе, не вызывает автоматического добавления получаемых составных элементов в какую-либо группу.

Удаление групп

Для удаления описания группы можно использовать опцию "расчленить" в диалоговом окне "Группа объектов". Данная операция отличается от операции расчленения блока, штриховки или размера. Объекты, принадлежащие расчлененной группе, остаются в чертеже.

В результате группа распадается, но составные элементы группы более никак не изменяются.


Редактирование групп (Процедура)

Выбор объектов в группах
На уровень вверх ..
Редактирование групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Редактирование групп >
Редактирование групп
Понятие Процедура Краткий справочник

Для удаления именованной группы

Для переупорядочения элементов группы


Для удаления именованной группы (Процедура)

Редактирование групп
На уровень вверх ..
Редактирование групп
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Редактирование групп >
Редактирование групп
Понятие Процедура Краткий справочник

Для удаления именованной группы

  1. В командной строке введите команду группа.
  2. В диалоговом окне "Группы объектов" выберите имя группы из списка.
  3. В группе опций "Изменение группы" выберите "Расчленить".
  4. Нажмите "ОК".

    Группа удаляется.

Ввод команды: ГРУППА


Для переупорядочения элементов группы (Процедура)

Редактирование групп
На уровень вверх ..
Исправление ошибок
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Редактирование групп >
Редактирование групп
Понятие Процедура Краткий справочник

Для переупорядочения элементов группы

  1. В командной строке введите команду группа.
  2. В группе опций "Изменение группы" диалогового окна "Группы объектов" нажмите кнопку "Переупорядочить".
  3. В списке "Имя группы" диалогового окна "Порядок объектов в группе" выберите группу для переупорядочения.
  4. Для просмотра текущего порядка группы нажмите кнопку "Подсветить".
  5. С помощью кнопок "Предыдущий" и "Следующий" диалогового окна "Группа объектов" просмотреть порядок объектов в группе. Нажмите кнопку "ОК", если завершен просмотр порядка объектов.
  6. В поле "Взять из позиции" диалогового окна "Порядок объектов в группе" введите порядковый номер объекта.
  7. В поле "Переместить в позицию" введите номер новой позиции.
  8. В поле "Количество объектов" введите количество объектов, порядок которых меняется. Нажмите кнопку "Переупорядочить".
  9. Нажмите "OK" для закрытия каждого диалогового окна.
Ввод команды: ГРУППА


Редактирование групп (Краткий справочник)

Выбор объектов в группах
Редактирование групп
Исправление ошибок
Создание и редактирование объектов > Методы редактирования > Выбор объектов > Группы > Редактирование групп >
Редактирование групп
Понятие Процедура Краткий справочник

Команды

ГРУППА

Создание именованных наборов объектов (групп) и управление ими

Системные переменные

PICKSTYLE

Управление выбором групп и ассоциативной штриховки

Утилиты

Нет

Ключевые слова для команд

Нет


Исправление ошибок (Понятие)

Редактирование групп
Методы редактирования
Стирание объектов
Создание и редактирование объектов > Методы редактирования >
Исправление ошибок
Понятие Процедура Краткий справочник

Имеется возможность отмены действия последней или нескольких последних команд.

Отмена одного действия

Самой простой способ отмены одного последнего действия заключается в использовании кнопки "Отменить" на панели "Стандартная" или команды О. Многие команды имеют собственную опцию О (отменить), что позволяет исправлять ошибки без выхода из команды. Например, при создании отрезков или полилиний можно ввести о для отмены последнего построенного сегмента.

ПримечаниеПри отмене и повторе команда ОТМЕНИТЬ по умолчанию объединяет команды последовательного панорамирования и зумирования в одну операцию. Однако, команды панорамирования и зумирования, запущенные из меню, не объединяются и всегда остаются отдельными действиями.

Отмена группы действий

Опция "Метка" команды ОТМЕНИТЬ служит для запоминания состояния чертежа в ходе работы. С помощью опции "Обратно" команды ОТМЕНИТЬ можно отменить все действия, имевшие место после отмеченного действия. Используя опции "Начало" и "Конец" команды ОТМЕНИТЬ, можно отменять сразу целую группу действий.

Группу последних действий можно также отменить с помощью списка "Отмена" на панели "Стандартная".

Повторное выполнение отмененного действия

С помощью опции ПОВТОРИТЬ можно отменить отдельную операцию отмены или команду ОТМЕНИТЬ, имевшие место сразу после отмененного действия.

Группу последних действий можно также повторить с помощью списка "Повторить" на панели "Стандартная".

Стирание объектов

Любой построенный объект можно стереть. Если объект стерт случайно, его можно восстановить командой ОТМЕНИТЬ или ОЙ.

Дополнительную информацию см. в разделе Стирание объектов.

Прерывание команды

Выполнение команды можно прервать с помощью клавиши ESC.


Исправление ошибок (Процедура)

Редактирование групп
Исправление ошибок
Исправление ошибок
Создание и редактирование объектов > Методы редактирования > Исправление ошибок >
Исправление ошибок
Понятие Процедура Краткий справочник

Для отмены последнего действия

Для отмены нескольких действий

Для повторного выполнения отмененного действия

Для повторного выполнения нескольких отмененных действий


Для отмены последнего действия (Процедура)

Исправление ошибок
Исправление ошибок
Исправление ошибок
Создание и редактирование объектов > Методы редактирования > Исправление ошибок >
Исправление ошибок
Понятие Процедура Краткий справочник

Для отмены последнего действия

  • Выберите меню Правка [image] Отменить.
Панель:Стандартная
Ввод команды: О


Для отмены нескольких действий (Процедура)

Исправление ошибок
Исправление ошибок
Исправление ошибок
Создание и редактирование объектов > Методы редактирования > Исправление ошибок >
Исправление ошибок
Понятие Процедура Краткий справочник

Для отмены нескольких действий

  1. На панели "Стандартная" нажать на стрелку кнопки "Отменить" для раскрытия списка действий.

    Выводится список действий, которые можно отменить, начиная с последнего действия.

  2. Выделите отменяемые действия перетаскивая мышь.
  3. Нажмите кнопкой мыши для отмены выбранных действий.
Панель:Стандартная
Ввод команды: ОТМЕНИТЬ


Для повторного выполнения отмененного действия (Процедура)

Исправление ошибок
Исправление ошибок
Исправление ошибок
Создание и редактирование объектов > Методы редактирования > Исправление ошибок >
Исправление ошибок
Понятие Процедура Краткий справочник

Для повторного выполнения отмененного действия

  • Выберите меню Правка [image] Повторить.В командной строке введите "мповторить".

Команда ПОВТОРИТЬ используется для повтора последнего действия, отмененного командой ОТМЕНИТЬ. Команду ПОВТОРИТЬ нельзя использовать для повторного выполнения другой команды.

Панель:Стандартная
Ввод команды: ПОВТОРИТЬ


Для повторного выполнения нескольких отмененных действий (Процедура)

Исправление ошибок
Исправление ошибок
Стирание объектов
Создание и редактирование объектов > Методы редактирования > Исправление ошибок >
Исправление ошибок
Понятие Процедура Краткий справочник

Для повторного выполнения нескольких отмененных действий

  1. На панели "Стандартная" нажмите на стрелку кнопки "Повторить" для раскрытия списка действий.

    Выводится список отмененных действий, которые можно повторно выполнить, начиная с последнего действия.

  2. Выделите повторно выполняемые действия.
  3. Нажмите кнопкой мыши для повторного выполнения выбранных действий.
Панель:Стандартная
Ввод команды: МПОВТОРИТЬ


Исправление ошибок (Краткий справочник)

Редактирование групп
Исправление ошибок
Стирание объектов
Создание и редактирование объектов > Методы редактирования > Исправление ошибок >
Исправление ошибок
Понятие Процедура Краткий справочник

Команды

СТЕРЕТЬ

Удаление объектов из чертежа

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ОЙ

Восстановление стертых объектов

ПОВТОРИТЬ

Отмена действия последней команды ОТМЕНИТЬ или О

МПОВТОРИТЬ

Отмена действия нескольких команд ОТМЕНИТЬ или О

О

Отмена самой последней операции

ОТМЕНИТЬ

Отмена действия команд

Системные переменные

UNDOCTL

Указание состояния параметров "Авто", "Управление" и "Группа" команды ОТМЕНИТЬ

UNDOMARKS

Хранение количества меток, заданных в команде ОТМЕНИТЬ (параметр "Метка") для управления отменой

Утилиты

Нет

Ключевые слова для команд

Нет


Стирание объектов (Понятие)

Исправление ошибок
Методы редактирования
Использование буфера обмена Windows
Создание и редактирование объектов > Методы редактирования >
Стирание объектов
Понятие Процедура Краткий справочник

Удаление объектов из чертежа можно выполнять различными способами.

  • Удаление с помощью команды СТЕРЕТЬ.
  • Выберите объекты, а затем вырежьте их в буфер обмена с помощью комбинации клавиш CTRL+X.
  • Выберите объекты и нажмите клавишу DELETE.

Случайно стертые объекты можно восстановить командой ОТМЕНИТЬ. Команда ОЙ восстанавливает все объекты, удаленные последним выполнением одной из команд СТЕРЕТЬ, БЛОК или ПБЛОК

Очистка дисплея

Можно удалить маркеры и пикселы помех, которые могут остаться после некоторых операций редактирования, из области отображения.

  • Для удаления маркеров используйте команду ПЕРЕРИСОВЫВАТЬ.
  • Для удаления пиксел помех используйте команду РЕГЕН.

Удаление неиспользуемых определений и стилей

Для удаления неиспользуемых именованных объектов, определений блоков, размерных стилей, слоев, типов линий и текстовых стилей используется команда ОЧИСТИТЬ.

См. также

    • Исправление ошибок


Стирание объектов (Процедура)

Исправление ошибок
Стирание объектов
Стирание объектов
Создание и редактирование объектов > Методы редактирования > Стирание объектов >
Стирание объектов
Понятие Процедура Краткий справочник

Для стирания объекта

Для восстановления последнего стертого объекта

Для вырезания объектов в буфер обмена

Для удаления маркеров

Для очистки чертежа от неиспользуемых типов линий


Для стирания объекта (Процедура)

Стирание объектов
Стирание объектов
Стирание объектов
Создание и редактирование объектов > Методы редактирования > Стирание объектов >
Стирание объектов
Понятие Процедура Краткий справочник

Для стирания объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Стереть".В командной строке введите "стереть".
  2. В ответ на подсказку "Выберите объекты" укажите объекты любым способом или задать одну из следующих опций:
    • Введите п (Последний) для стирания последнего созданного объекта.
    • Введите т (Текущий) для стирания объектов из текущего набора.
    • Введите все для стирания всех объектов чертежа.
    • Введите ? для получения информации обо всех методах выбора.
  3. Нажмите ENTER для завершения команды.
Панель:Редактирование
Ввод команды: СТЕРЕТЬ


Для восстановления последнего стертого объекта (Процедура)

Стирание объектов
Стирание объектов
Стирание объектов
Создание и редактирование объектов > Методы редактирования > Стирание объектов >
Стирание объектов
Понятие Процедура Краткий справочник

Для восстановления последнего стертого объекта

  • В командной строке введите ой.

Восстанавливаются объекты, стертые последним выполнением одной из команд СТЕРЕТЬ, БЛОК или ПБЛОК.

Ввод команды: ОЙ


Для вырезания объектов в буфер обмена (Процедура)

Стирание объектов
Стирание объектов
Стирание объектов
Создание и редактирование объектов > Методы редактирования > Стирание объектов >
Стирание объектов
Понятие Процедура Краткий справочник

Для вырезания объектов в буфер обмена

  1. Выберите объекты для вырезания в буфер.
  2. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Вырезать".В командной строке введите "вбуфер". Можно также нажать комбинацию клавиш CTRL+X.

    После этого объекты становятся доступны для вставки в других приложениях Windows.

Ввод команды: ВБУФЕР


Для удаления маркеров (Процедура)

Стирание объектов
Стирание объектов
Стирание объектов
Создание и редактирование объектов > Методы редактирования > Стирание объектов >
Стирание объектов
Понятие Процедура Краткий справочник

Для удаления маркеров

  • Выберите меню Вид [image] Освежить.В командной строке введите "всеосвеж".
Ввод команды: ОСВЕЖИТЬ


Для очистки чертежа от неиспользуемых типов линий (Процедура)

Стирание объектов
Стирание объектов
Использование буфера обмена Windows
Создание и редактирование объектов > Методы редактирования > Стирание объектов >
Стирание объектов
Понятие Процедура Краткий справочник

Для очистки чертежа от неиспользуемых типов линий

  1. Выберите вкладку "Инструменты" [image] панель "Утилиты" [image] "Очистить".В командной строке введите "очистить".

    Появляется диалоговое окно "Очистка чертежа", отображающее дерево объектов, которые можно удалить.

  2. Для удаления неиспользуемых типов линий воспользоваться одним из способов:
    • Для очистки чертежа от всех неиспользуемых типов линий выберите "Типы линий".
    • Для очистки чертежа от определенных типов линий дважды нажмите на пункте "Типы линий" для раскрытия списка следующего уровня. Затем выделить типы линий для удаления.

    Если нужные элементы отсутствуют в списке, включить опцию "Просмотреть элементы, которые нельзя удалить".

  3. Удаление каждого элемента из списка требуется подтвердить. Для подавления запросов перед каждым удалением можно предварительно отключить опцию "Удаление элементов с подтверждением".
  4. Нажать "Удалить".

    В ответ на запрос перед каждым удалением следует нажимать "Да", "Нет" или "Да для всех" для удаления сразу всех выбранных элементов.

  5. Нажмите кнопку "Закрыть".
Ввод команды: ОЧИСТИТЬ


Стирание объектов (Краткий справочник)

Исправление ошибок
Стирание объектов
Использование буфера обмена Windows
Создание и редактирование объектов > Методы редактирования > Стирание объектов >
Стирание объектов
Понятие Процедура Краткий справочник

Команды

ВБУФЕР

Перемещение выбранных объектов в буфер обмена и удаление их из чертежа

СТЕРЕТЬ

Удаление объектов из чертежа

ОЙ

Восстановление стертых объектов

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

ОСВЕЖИТЬ

Перерисовка содержимого текущего видового экрана

ВСЕОСВЕЖ

Перерисовка содержимого всех видовых экранов

РЕГЕН

Регенерация чертежа и перерисовка содержимого текущего видового экрана

ОТМЕНИТЬ

Отмена действия команд

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование буфера обмена Windows (Понятие)

Стирание объектов
Методы редактирования
Редактирование объектов
Создание и редактирование объектов > Методы редактирования >
Использование буфера обмена Windows
Понятие Процедура Краткий справочник

При необходимости, объекты из чертежа можно скопировать или вырезать в буфер обмена, а затем вставить эти объекты в файл, открытый в другом приложении.

Вырезание объектов

В процессе вырезания выбранные объекты удаляются из чертежа и размещаются в буфере обмена. Объекты доступны для вставки в другие документы приложений Microsoft® Windows®.

Копирование объектов

Для копирования чертежа или его части в другое приложение можно использовать буфер обмена. Объекты копируются в векторном формате для сохранения высокого разрешения в других приложениях. Буфер обмена хранит эти объекты в формате метафайла Windows (WMF). Данные из буфера обмена могут внедряться в документы других приложений. При дальнейшем редактировании исходного объекта его вставленная копия в других приложениях не изменяется.

Вставка объектов

В различных приложениях для сохранения информации в буфере обмена используются различные внутренние форматы. При копировании объектов в буфер обмена информация сохраняется во всех доступных форматах. При вставке в чертеж содержимого буфера обмена используется формат, обеспечивающий наиболее полную информацию. Однако эту установку можно переопределить и задать явное преобразование информации о вставляемом объекте в формат AutoCAD.

Предпочтительно использовать при копировании объектов формат AutoCAD, так как он является самым удобным для редактирования созданных в AutoCAD объектов. Данный формат позволяет сохранить всю необходимую информацию об объекте, включая ссылки на блоки и трехмерные характеристики.

Формат метафайла Windows обеспечивает хранение графики в векторном представлении; таким образом, файлы могут масштабироваться и выводится на печать без потери качества. Данный формат рекомендуется использовать для вставки объектов в поддерживающие WMF-файлы приложения Windows. Вставляемые в AutoCAD метафайлы обладают большим разрешением, чем растровые изображения, но обрабатывать их сложнее, чем объекты AutoCAD. Растровые изображения, состоящие из описаний расположения пикселов, обычно используются в приложениях иллюстративной графики.

Цвет объекта не изменяется при копировании в буфер обмена. Если объект, имеющий белый цвет, вставляется в приложение с белым фоном рабочей области, то такой объект будет невидимым. Изменяя значения системных переменных WMFBKGND и WMFFOREGND, можно включать или отключать прозрачность фона и линий для формата метафайла объектов, помещенных в буфер обмена и вставленных в другие приложения.

Для вставки связанного или внедренного объекта из других приложений через буфер обмена в чертеж используется команда ВСТСПЕЦ. При этом, если данные буфера обмена можно преобразовать в формат AutoCAD, то объекты вставляются в виде вхождений блоков. Для редактирования вставленных таким образом блоков следует расчленить их в местах вхождений на отдельные объекты. Во время преобразования графики, хранимой в буфере обмена, из формата метафайла Windows в формат AutoCAD может произойти некоторая потеря точности масштабирования. Для избежания этого недостатка объекты из буфера обмена следует сохранять в виде блока в отдельном чертеже (ПБЛОК), а затем вставлять их в AutoCAD с помощью команды ВСТАВИТЬ.


Использование буфера обмена Windows (Процедура)

Стирание объектов
Использование буфера обмена Windows
Использование буфера обмена Windows
Создание и редактирование объектов > Методы редактирования > Использование буфера обмена Windows >
Использование буфера обмена Windows
Понятие Процедура Краткий справочник

Для вырезания объектов в буфер обмена

Для копирования объектов в буфер обмена

Для вставки объектов из буфера обмена

Для преобразования вставленной информации в формат файла чертежа


Для вырезания объектов в буфер обмена (Процедура)

Использование буфера обмена Windows
Использование буфера обмена Windows
Использование буфера обмена Windows
Создание и редактирование объектов > Методы редактирования > Использование буфера обмена Windows >
Использование буфера обмена Windows
Понятие Процедура Краткий справочник

Для вырезания объектов в буфер обмена

  1. Выберите объекты для вырезания в буфер.
  2. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Вырезать".В командной строке введите "вбуфер".

    Можно также нажать комбинацию клавиш CTRL+X.

    Вырезанные объекты можно вставлять также и в другие приложения Windows.

Ввод команды: ВБУФЕР


Для копирования объектов в буфер обмена (Процедура)

Использование буфера обмена Windows
Использование буфера обмена Windows
Использование буфера обмена Windows
Создание и редактирование объектов > Методы редактирования > Использование буфера обмена Windows >
Использование буфера обмена Windows
Понятие Процедура Краткий справочник

Для копирования объектов в буфер обмена

  1. Выберите объекты для копирования в буфер.
  2. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Копировать в буфер".В командной строке введите "кбуфер".

Можно также нажать комбинацию клавиш CTRL+C.

Ввод команды: КБУФЕР


Для вставки объектов из буфера обмена (Процедура)

Использование буфера обмена Windows
Использование буфера обмена Windows
Использование буфера обмена Windows
Создание и редактирование объектов > Методы редактирования > Использование буфера обмена Windows >
Использование буфера обмена Windows
Понятие Процедура Краткий справочник

Для вставки объектов из буфера обмена

  • Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Вставить".В командной строке введите "встбуфер".

    Можно также нажать комбинацию клавиш CTRL+V.

    Объекты, находящиеся в буфере обмена, вставляются в чертеж.

Ввод команды: ВСТБУФЕР


Для преобразования вставленной информации в формат файла чертежа (Процедура)

Использование буфера обмена Windows
Использование буфера обмена Windows
Перемещение или поворот объектов
Создание и редактирование объектов > Методы редактирования > Использование буфера обмена Windows >
Использование буфера обмена Windows
Понятие Процедура Краткий справочник

Для преобразования вставленной информации в формат файла чертежа

  1. Выберите вкладку "Главная" [image] панель "Утилиты" [image] "Специальная вставка".В командной строке введите "встспец".
  2. В диалоговом окне "Специальная вставка" выберите "Вставить".
  3. В списке форматов выберите "Растровое изображение".
  4. Нажмите "ОК".
Ввод команды: ВСТСПЕЦ


Использование буфера обмена Windows (Краткий справочник)

Стирание объектов
Использование буфера обмена Windows
Выберите метод для редактирования объектов
Создание и редактирование объектов > Методы редактирования > Использование буфера обмена Windows >
Использование буфера обмена Windows
Понятие Процедура Краткий справочник

Команды

БТКОПИРОВАТЬ

Копирование объектов в буфер обмена с указанием базовой точки

КБУФЕР

Копирование выбранных объектов в буфер обмена

ВБУФЕР

Перемещение выбранных объектов в буфер обмена и удаление их из чертежа

ВСТБЛОК

Вставка скопированных ранее объектов в виде блока

ВСТБУФЕР

Вставка содержимого буфера обмена

ВСТИСХОД

Вставка скопированного блока в новый чертеж с координатами, которые он имел в исходном чертеже

ВСТСПЕЦ

Вставка данных из буфера обмена Windows с возможностью управления их форматом

ИМПОРТМТФ

Импорт метафайла Windows

ОПЦИИМТФ

Задание опций для команды ИМПОРТМТФ

ЭКСПОРТМТФ

Сохранение объектов в метафайле Windows (WMF)

Системные переменные

OLEHIDE

Управление отображением и выводом на печать объектов OLE

WMFBKGND

Управление отображением фона при вставке объектов в формате метафайлов Windows (WMF)

WMFFOREGND

Управление назначением цвета переднего плана при вставке объектов в формате метафайла Windows (WMF)

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование объектов

Использование буфера обмена Windows
Методы редактирования
Выберите метод для редактирования объектов
Создание и редактирование объектов > Методы редактирования >
Редактирование объектов

Объекты можно редактировать, изменяя их размеры, форму и расположение.

Темы в этом разделе

  • Выберите метод для редактирования объектов
  • Перемещение или поворот объектов

    Можно переместить объекты в другое место или изменить ориентацию объектов, повернув их в заданном направлении или переместив к другим объектам.

  • Копирование, зеркальное отображение и создание подобных объектов

    Существует возможность создания копий объектов: либо точных, либо с закономерными изменениями.

  • Изменение размеров и формы объектов

    Имеется несколько способов регулировки размеров существующих объектов относительно других объектов, как с соблюдением симметрии, так и без соблюдения симметрии.

  • Сопряжение, Фаска, Разорвать или Объединить объекты

    Объекты чертежа можно соединять, сопрягая их в углах или строя фаски (скошенные линии). Кроме того, в объектах можно создавать или удалять разрывы.

  • Редактирование с помощью ручек

    Ручки имеют вид квадратных меток и находятся в характерных точках выбранных объектов. Перетаскивая эти ручки, можно быстро и наглядно редактировать объекты.


Выберите метод для редактирования объектов (Понятие)

Редактирование объектов
Редактирование объектов
Перемещение или поворот объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов >
Выберите метод для редактирования объектов
Понятие Краткий справочник

Объекты можно редактировать, изменяя их размеры, форму и расположение. Пользователь может:

  • Вначале вызвать команду, а затем выберите объекты для редактирования.
  • Сначала выбрать объекты, а затем вызвать команду для их редактирования.
  • Для выбора контекстного меню выбрать объект и нажать правую кнопку мыши.
  • Дважды нажать объект для открытия палитры "Свойства" или, в некоторых случаях, диалогового окна или окна редактора, соответствующего типу объекта. (Путем редактирования файла АПИ и загрузки его в программу пользователь может назначить выполнение действия по двойному нажатию кнопки мыши для каждого типа объекта)
См. также

    • Редактирование текста

    • Выбор объектов

    • Редактирование размеров

    • Отображение и редактирование свойств объектов

    • Работа со сторонними объектами и заместителями

    • См. раздел Создание операции при двукратном нажатии в документе Руководство по адаптации


Выберите метод для редактирования объектов (Краткий справочник)

Использование буфера обмена Windows
Выберите метод для редактирования объектов
Перемещение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Выберите метод для редактирования объектов >
Выберите метод для редактирования объектов
Понятие Краткий справочник

Команды

НПИ

Управление настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш

СЛЕДИТЬ

Управление отображением объектов при перетаскивании

ОКНОСВ

Управление свойствами объектов

ВЫБРАТЬ

Занесение выбранных объектов в текущий набор

Системные переменные

DBLCLKEDIT

Определение действия по редактированию, выполняемого при двойном нажатии левой кнопки мыши в области рисования

DRAGMODE

Управление отображением объектов при перетаскивании

PICKADD

Управление дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

Утилиты

Нет

Ключевые слова для команд

Нет


Перемещение или поворот объектов

Выберите метод для редактирования объектов
Редактирование объектов
Перемещение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов >
Перемещение или поворот объектов
Понятие Процедура

Можно переместить объекты в другое место или изменить ориентацию объектов, повернув их в заданном направлении или переместив к другим объектам.

Темы в этом разделе

  • Перемещение объектов

    Можно переместить объекты, расположив их на определенном расстоянии и в определенном направлении от исходных объектов.

  • Поворот объектов

    Объекты можно поворачивать на чертеже вокруг заданной базовой точки.

  • Выравнивание объектов

    Имеется возможность так переместить и повернуть объект, чтобы выровнять его с другим объектом.


Перемещение или поворот объектов (Процедура)

Использование буфера обмена Windows
Перемещение или поворот объектов
Перемещение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов >
Перемещение или поворот объектов
Понятие Процедура

Для перемещения объекта по двум точкам

Для перемещения объекта на заданную величину смещения

Перемещение объекта из пространства модели в пространство листа (и наоборот)

Перемещение объектов с помощью растягивания

Для поворота объекта

Поворот объекта на заданный абсолютный угол

Для поворота 3D объекта вокруг оси

Выравнивание двух объектов в 2D представлении

Выравнивание двух объектов в 3D представлении


Перемещение объектов (Понятие)

Перемещение или поворот объектов
Перемещение или поворот объектов
Поворот объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов >
Перемещение объектов
Понятие Процедура Краткий справочник

Можно переместить объекты, расположив их на определенном расстоянии и в определенном направлении от исходных объектов.

Используйте координаты, шаговую привязку, объектные привязки и другие инструменты для перемещения объектов с точностью.

Указание расстояния с помощью двух точек

Переместите объект, используя расстояние и направление, указанное базовой точкой, за которой следует вторая точка. В следующем примере производится перемещение блока, представляющего окно. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Перенести".В командной строке введите перенести. Затем выберите объект для перемещения. Укажите базовую точку для перемещения (2), за которой следует вторая точка (3). Объект перемещается на расстояние и в направлении от точки 2 к точке 3.

Указание расстояния с помощью относительных координат

Объект можно переместить путем указания относительного расстояния, для задания которого нужно ввести значения координат первой точки и нажать ENTER для второй. Значения координат определяют не положение базовой точки, а величину смещения объекта.

Примечание Не следует вводить знак @ для указания относительных координат, так как здесь уже предполагается ввод именно относительных координат.

В режимах полярного отслеживания и "Орто" объекты можно копировать путем ввода расстояния перемещения. Дополнительную информацию см. в разделе Метод задания координат "направление-расстояние"

Использование операции "Растянуть-Переместить"

Для перемещения объектов, расположенных полностью внутри рамки выбора, можно использовать команду РАСТЯНУТЬ. Включите режим "Орто" или полярного отслеживания для перемещения объектов в заданном направлении.

Например: движение двери по направлению к стене. Дверь на чертеже находится полностью в секущей рамке, а линии стены лишь частично размещены в области секущей рамки.

В результате необходимо захватить рамкой весь объект для перемещения.

Использование альтернативных методов

Для быстрого перемещения и копирования объектов можно использовать ручки. См. раздел Редактирование с помощью ручек.

Можно также выбирать объекты и перетаскивать их на новое место; для создания копии нажмите CTRL. Таким способом можно перетаскивать объекты между открытыми чертежами и приложениями. При попытке перетаскивания с помощью правой кнопки мыши открывается контекстное меню. Это меню содержит опции "Перенести сюда", "Копировать сюда", "Вставить как блок" и "Отмена". См. раздел Внедрение OLE-объектов в чертежи.


Перемещение объектов (Процедура)

Перемещение или поворот объектов
На уровень вверх ..
Перемещение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Перемещение объектов >
Перемещение объектов
Понятие Процедура Краткий справочник

Для перемещения объекта по двум точкам

Для перемещения объекта на заданную величину смещения

Перемещение объекта из пространства модели в пространство листа (и наоборот)

Перемещение объектов с помощью растягивания


Для перемещения объекта по двум точкам (Процедура)

Перемещение объектов
На уровень вверх ..
Перемещение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Перемещение объектов >
Перемещение объектов
Понятие Процедура Краткий справочник

Для перемещения объекта по двум точкам

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Перенести".В командной строке введите перенести.
  2. Выберите объекты для перемещения.
  3. Укажите базовую точку перемещения.
  4. Укажите вторую точку.

    Выбранные объекты перемещаются в направлении и на расстояние, определяемые двумя заданными точками.

Панель:Редактирование
Ввод команды: ПЕРЕНЕСТИ


Для перемещения объекта на заданную величину смещения (Процедура)

Перемещение объектов
На уровень вверх ..
Перемещение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Перемещение объектов >
Перемещение объектов
Понятие Процедура Краткий справочник

Для перемещения объекта на заданную величину смещения

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Перенести".В командной строке введите перенести.
  2. Выберите перемещаемый объект.
  3. Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. Не следует вводить знак @, так как уже предполагается ввод относительных координат.
  4. На запрос второй точки нажмите ENTER.

    Значения координат определяют не положение базовой точки, а величину смещения объекта. Выбранные объекты перемещаются на заданную величину смещения.

Панель:Редактирование
Ввод команды: ПЕРЕНЕСТИ


Перемещение объекта из пространства модели в пространство листа (и наоборот) (Процедура)

Перемещение объектов
На уровень вверх ..
Перемещение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Перемещение объектов >
Перемещение объектов
Понятие Процедура Краткий справочник

Перемещение объекта из пространства модели в пространство листа (и наоборот)

  1. Перейдите на вкладку "Лист".
  2. Выберите меню Редактирование [image] Смена пространства.В командной строке введите "сменапростр".
  3. Выберите один или несколько объектов для перемещения.
  4. Нажмите ENTER.

    Объект перемещается в выбранное пространство и в соответствии с этим пространством изменяет свой масштаб.

Ввод команды: СМЕНАПРОСТР


Перемещение объектов с помощью растягивания (Процедура)

Перемещение объектов
На уровень вверх ..
Поворот объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Перемещение объектов >
Перемещение объектов
Понятие Процедура Краткий справочник

Перемещение объектов с помощью растягивания

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Растянуть".В командной строке введите растянуть.
  2. Выберите объекты секущей рамкой.

    Секущая рамка должна захватывать по крайней мере одну вершину или определяющую точку объекта. Выбор секущей рамкой осуществляется путем щелчка и перетаскивания мыши справа налево, после чего необходимо снова нажать кнопку мыши.

  3. Выполните одно из следующих действий:
    • Укажите базовую точку и вторую точку для перемещения.
    • Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. Не следует вводить знак @, так как уже предполагается ввод относительных координат. На запрос второй точки смещения нажмите ENTER.

    Объекты, у которых хотя бы одна вершина или определяющая точка расположена внутри секущей рамки, растягиваются. Объекты, полностью охваченные секущей рамкой, перемещаются без растягивания.

Панель:Редактирование
Ввод команды: РАСТЯНУТЬ


Перемещение объектов (Краткий справочник)

Выберите метод для редактирования объектов
Перемещение объектов
Поворот объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Перемещение объектов >
Перемещение объектов
Понятие Процедура Краткий справочник

Команды

СМЕНАПРОСТР

Перемещение объектов между пространством модели и пространством листа

ПЕРЕНЕСТИ

Перемещение объектов на заданное расстояние в указанном направлении

ОКНОСВ

Управление свойствами объектов

РАСТЯНУТЬ

Растягивание объектов, пересекаемых рамкой выбора или многоугольником

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Метод "направление-расстояние

Размещение следующей точки на определенном расстоянии от предыдущей в направлении, заданном с помощью курсора


Поворот объектов (Понятие)

Перемещение объектов
Перемещение или поворот объектов
Выравнивание объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов >
Поворот объектов
Понятие Процедура Краткий справочник

Объекты можно поворачивать на чертеже вокруг заданной базовой точки.

Для определения угла поворота вводится значение угла, перетаскивается с помощью курсора или указывается опорный угол для выравнивания с абсолютным углом.

Поворот объекта на заданный угол

Введите значение угла поворота в диапазоне от 0 до 360 градусов. Значения также могут вводиться в радианах, градах и топографических единицах. Направление отсчета углов (по часовой стрелке или против нее) определяется установкой "Выбор направления" в диалоговом окне "Единицы измерения".

Поворот объекта с помощью перетаскивания

Протащите объект возле базовой точки и укажите вторую точку. Используйте режимы "Орто", полярного отслеживания или объектной привязки для большей точности.

Например, можно повернуть план дома путем выбора объектов (1), указания базовой точки (2) и угла поворота, перемещая к другой точке (3).

Поворот объекта на заданный абсолютный угол

С помощью параметра "Ссылка" можно поверните объект для выравнивания с абсолютным углом.

Например, поверните деталь на чертеже, чтобы диагональная кромка повернулась на 90 градусов, выберите объекты для поворота (1, 2), укажите базовую точку (3) и введите параметр "Ссылка". Для опорного угла укажите две конечные точки диагональной линии (4, 5). Для нового угла введите значение 90.

Поворот объектов в трехмерном пространстве

Для поворота 3D объектов может использоваться команда ПОВЕРНУТЬ или ПОВЕРНУТЬ3D.

  • С помощью команды ПОВЕРНУТЬ можно повернуть объекты вокруг указанной базовой точки. Ось вращения проходит через базовую точку и параллельна оси Z текущей ПСК.
  • С помощью ПОВЕРНУТЬ3D можно задавать ось вращения с использованием двух точек; либо объекта; оси X, Y или Z либо направления Z текущего вида.
См. также

    • Поворот видов на видовых экранах листа


Поворот объектов (Процедура)

Перемещение объектов
На уровень вверх ..
Поворот объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Поворот объектов >
Поворот объектов
Понятие Процедура Краткий справочник

Для поворота объекта

Поворот объекта на заданный абсолютный угол

Для поворота 3D объекта вокруг оси


Для поворота объекта (Процедура)

Поворот объектов
На уровень вверх ..
Поворот объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Поворот объектов >
Поворот объектов
Понятие Процедура Краткий справочник

Для поворота объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Повернуть".В командной строке введите "повернуть".
  2. Выберите поворачиваемый объект.
  3. Укажите базовую точку поворота.
  4. Выполните одно из следующих действий:
    • Введите значение угла поворота.
    • Перетащите объект возле базовой точки и укажите местоположение точки, к которой нужно повернуть объект.
    • Введите c для создания копии выбранных объектов.
    • Введите r для поворота выбранных объектов не на указанный опорный угол, а на абсолютный угол.
Панель:Редактирование
Ввод команды: ПОВЕРНУТЬ


Поворот объекта на заданный абсолютный угол (Процедура)

Поворот объектов
На уровень вверх ..
Поворот объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Поворот объектов >
Поворот объектов
Понятие Процедура Краткий справочник

Поворот объекта на заданный абсолютный угол

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Повернуть".В командной строке введите "повернуть".
  2. Выберите поворачиваемые объекты.
  3. Укажите базовую точку поворота.
  4. Выполните одно из следующих действий:
  5. Введите значение опорного угла или указать два местоположения точек.

    С помощью этого можно определить воображаемую линию, которую будет повернута на новый угол.

  6. Введите новый угол или указать точку.

    Значение, которое было введено для нового угла, является значением абсолютного угла. Если же указать точку, то опорный угол будет повернут к этой точке.

Панель:Редактирование
Ввод команды: ПОВЕРНУТЬ


Для поворота 3D объекта вокруг оси (Процедура)

Поворот объектов
На уровень вверх ..
Выравнивание объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Поворот объектов >
Поворот объектов
Понятие Процедура Краткий справочник

Для поворота 3D объекта вокруг оси

  1. Выберите меню Редактирование [image] 3D операции [image] 3D поворот.
  2. Выберите поворачиваемый объект (1).
  3. Укажите начальную и конечную точки оси вращения (2, 3).

    Положительным направлением оси считается направление от начальной точки к конечной; поворот подчиняется правилу правой руки (см. раздел Понятие о пользовательской системе координат в 3D).

  4. Задать угол поворота.

Ввод команды: ПОВЕРНУТЬ3D


Поворот объектов (Краткий справочник)

Перемещение объектов
Поворот объектов
Выравнивание объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Поворот объектов >
Поворот объектов
Понятие Процедура Краткий справочник

Команды

ПОВЕРНУТЬ

Поворот объекта вокруг базовой точки

ПОВЕРНУТЬ3D

Поворот объектов вокруг 3D оси

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Выравнивание объектов (Понятие)

Поворот объектов
Перемещение или поворот объектов
Копирование, зеркальное отображение и создание подобных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов >
Выравнивание объектов
Понятие Процедура Краткий справочник

Имеется возможность так переместить и повернуть объект, чтобы выровнять его с другим объектом.

В приведенном ниже примере две пары точек используются для выравнивания трубопровода в 2D представлении с использованием команды ВЫРОВНЯТЬ. Использование объектных привязок конечных точек позволяет выровнять трубы с высокой точностью.

В 3D представлении команда 3DВЫРОВНЯТЬ используется для обозначения до трех точек с целью определения исходной плоскости м далее до трех точек с целью определения конечной плоскости.

  • Первая исходная точка на объекте, именуемая базовой точкой, всегда переносится в первую конечную точку.
  • Указание второй исходной или конечной точки приводит к повороту выбранных объектов.
  • Третья точка, определяемая для исходной или конечной плоскости, приводит к дополнительному повороту выбранных объектов.
СоветПри работе с 3D моделями тел рекомендуется включать динамическую ПСК для ускорения выбора конечной плоскости.


Выравнивание объектов (Процедура)

Поворот объектов
На уровень вверх ..
Выравнивание объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Выравнивание объектов >
Выравнивание объектов
Понятие Процедура Краткий справочник

Выравнивание двух объектов в 2D представлении

Выравнивание двух объектов в 3D представлении


Выравнивание двух объектов в 2D представлении (Процедура)

Выравнивание объектов
На уровень вверх ..
Выравнивание объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Выравнивание объектов >
Выравнивание объектов
Понятие Процедура Краткий справочник

Выравнивание двух объектов в 2D представлении

  1. Выберите меню Редактирование [image] 3D операции [image] Выровнять.В командной строке введите "выровнять".
  2. Выберите объекты для выравнивания.
  3. Укажите исходную точку и далее соответствующую конечную точку. Для поворота объекта укажите вторую исходную точку и далее вторую конечную точку.
  4. Нажмите ENTER для завершения команды.

    Выбранные объекты перемещаются из исходной точки в конечную, а вторая и третья точки, если таковые заданы, определяют поворот и наклон выбранных объектов.

Ввод команды: ВЫРОВНЯТЬ


Выравнивание двух объектов в 3D представлении (Процедура)

Выравнивание объектов
На уровень вверх ..
Копирование, зеркальное отображение и создание подобных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Выравнивание объектов >
Выравнивание объектов
Понятие Процедура Краткий справочник

Выравнивание двух объектов в 3D представлении

  1. Выберите меню Редактирование [image] 3D операции [image] 3D выравнивание.В командной строке введите "3dвыровнять".
  2. Выберите объекты для выравнивания.
  3. Укажите одну, две или три исходных точки, а затем соответствующие им первую, вторую и третью конечные точки. Первая точка именуется базовой точкой.

    Объекты перемещаются из исходной точки в конечную, а вторая и третья точки, если таковые заданы, определяют поворот и наклон выбранных объектов.

Ввод команды: 3DВЫРОВНЯТЬ


Выравнивание объектов (Краткий справочник)

Поворот объектов
Выравнивание объектов
Копирование объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Перемещение или поворот объектов > Выравнивание объектов >
Выравнивание объектов
Понятие Процедура Краткий справочник

Команды

3DВЫРОВНЯТЬ

Выравнивание объектов относительно других объектов в 2D и 3D

ВЫРОВНЯТЬ

Выравнивание объектов относительно других объектов в 2D и 3D

Системные переменные

UCSDETECT

Управление активностью сбора данных динамической ПСК

Утилиты

Нет

Ключевые слова для команд

Нет


Копирование, зеркальное отображение и создание подобных объектов

Выравнивание объектов
Редактирование объектов
Копирование объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов >
Копирование, зеркальное отображение и создание подобных объектов
Понятие Процедура

Существует возможность создания копий объектов: либо точных, либо с закономерными изменениями.

Темы в этом разделе

  • Копирование объектов

    Можно создать копии объектов на указанном расстоянии и в указанном направлении от оригиналов.

  • Размножение объектов массивом

    Объекты можно копировать, упорядоченно располагая копии по окружности (круговой массив) или в узлах прямоугольного массива.

  • Создание подобных объектов

    Сместите объект для создания нового объекта, подобного имеющемуся и расположенному на заданном расстоянии от него.

  • Зеркальное отображение объектов

    Зеркальное отображение позволяет создавать зеркальные копии объектов относительно заданной оси.


Копирование, зеркальное отображение и создание подобных объектов (Процедура)

Выравнивание объектов
Копирование, зеркальное отображение и создание подобных объектов
Копирование объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов >
Копирование, зеркальное отображение и создание подобных объектов
Понятие Процедура

Для копирования объектов с помощью двух точек

Для создания прямоугольного массива

Для создания кругового массива

Для создания прямоугольного массива 3D объектов

Для создания кругового массива 3D объектов

Для построения подобного объекта путем задания смещения

Для построения подобного объекта, проходящего через точку

Для зеркального отображения объектов

Для зеркального отображения 3D объектов


Копирование объектов (Понятие)

Копирование, зеркальное отображение и создание подобных объектов
Копирование, зеркальное отображение и создание подобных объектов
Размножение объектов массивом
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов >
Копирование объектов
Понятие Процедура Краткий справочник

Можно создать копии объектов на указанном расстоянии и в указанном направлении от оригиналов.

Использовать координаты, шаговую привязку, объектные привязки и другие инструменты для копирования объектов с точностью.

Указание расстояния с помощью двух точек

Копировать объект, используя расстояние и направление, указанное базовой точкой, за которой следует вторая точка. В следующем примере производится копирование блока, представляющего электронный компонент.Выберите меню Правка [image] Копировать.В командной строке введите "кбуфер". Затем выберите исходный объект для копирования. Укажите базовую точку для перемещения (1), за которой следует вторая точка (2). Объект копируется на расстояние и в направлении от точки 1 к точке 2.

Указание расстояния с помощью относительных координат

Объект можно скопировать методом относительного расстояния, для чего нужно ввести значения координат для первой точки и нажать ENTER для ввода второй. Значения координат определяют не положение базовой точки, а величину смещения объекта.

Примечание Не следует вводить знак @ для указания относительных координат, так как здесь уже предполагается ввод именно относительных координат.

В режимах полярного отслеживания и "Орто" объекты можно копировать путем ввода расстояния перемещения. Дополнительную информацию см. в разделе Метод задания координат "направление-расстояние".

Создание нескольких копий

По умолчанию команда КОПИРОВАТЬ повторяется автоматически. Для завершения команды нажмите ENTER. Изменение поведения по умолчанию выполняется посредством системной переменной COPYMODE.

Использование альтернативных методов

Для быстрого перемещения и копирования объектов можно использовать ручки. См. раздел Редактирование с помощью ручек.

Можно также выбирать объекты и перетаскивать их на новое место; для создания копии нажмите CTRL. Таким способом можно перетаскивать объекты между открытыми чертежами и приложениями. При попытке перетаскивания с помощью правой кнопки мыши открывается контекстное меню. Это меню содержит опции "Перенести сюда", "Копировать сюда", "Вставить как блок" и "Отмена". См. раздел Внедрение OLE-объектов в чертежи.


Для копирования объектов с помощью двух точек (Процедура)

Копирование, зеркальное отображение и создание подобных объектов
На уровень вверх ..
Размножение объектов массивом
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Копирование объектов >
Копирование объектов
Понятие Процедура Краткий справочник

Для копирования объектов с помощью двух точек

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Копировать".В командной строке введите копировать.
  2. Выберите копируемые объекты.
  3. Укажите базовую точку.
  4. Укажите вторую точку. Нажмите ENTER.
Панель:Редактирование
Ввод команды: КОПИРОВАТЬ


Копирование объектов (Краткий справочник)

Выравнивание объектов
Копирование объектов
Размножение объектов массивом
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Копирование объектов >
Копирование объектов
Понятие Процедура Краткий справочник

Команды

КОПИРОВАТЬ

Копирование объектов на заданное расстояние в указанном направлении

Системные переменные

COPYMODE

Управление автоматическим повтором команды КОПИРОВАТЬ

Утилиты

Нет

Ключевые слова для команд

Нет


Размножение объектов массивом (Понятие)

Копирование объектов
Копирование, зеркальное отображение и создание подобных объектов
Создание подобных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов >
Размножение объектов массивом
Понятие Процедура Краткий справочник

Объекты можно копировать, упорядоченно располагая копии по окружности (круговой массив) или в узлах прямоугольного массива.

Для прямоугольных массивов задается количество рядов и столбцов, а также расстояние между ними. Для круговых массивов задается количество копий объекта и режим их поворота. Размножение массивом является более быстрым методом для создания нескольких копий объекта с заданным интервалом, чем выполнение обычного копирования.

Создание прямоугольных массивов

Прямоугольный массив создан вдоль базовой линии, определяемой текущим углом поворота шаговой привязки. Этот угол по умолчанию равен нулю, так что ряды и столбцы прямоугольного массива взаимно перпендикулярны и располагаются вдоль осей X и Y. Направление нулевого угла, принятое по умолчанию, можно изменить командой ЕДИНИЦЫ.

Создание круговых массивов

Направление создания кругового массива (по часовой стрелке или против нее) определяется знаком (положительный или отрицательный) угла заполнения массива.

При генерации массива радиус определяется расстоянием от центра массива до опорной или базовой точки на последнем выбранном объекте. Для создания массива может использоваться текущая опорная точка, обычной совпадающая с точкой привязки, или новая указанная базовая точка, которая в дальнейшем используется в качестве опорной точки.

Размножение 3D объектов массивом

С помощью команды 3DМАССИВ можно создать прямоугольный или полярный массив объектов в трехмерном пространстве. Дополнительно к заданию числа рядов (в направлении X) и числа столбцов (в направлении Y) здесь необходимо указать и число этажей массива (в направлении Z).

Ограничение размера массивов

Если для массива указать большое число рядов и столбцов, для создания копий может потребоваться много времени. По умолчанию число элементов массива, создаваемого по одной команде, ограничивается значением порядка 100000. Это предельное значение определяется в реестре при помощи переменной MaxArray.

Значение переменной MaxArray можно изменять вводом в командной строке выражения (setenv “MaxArray” “n”), где n означает число от 100 до 10000000 (десяти миллионов).

ПримечаниеПри изменении значения MaxArray необходимо соблюдать регистр символов в имени этой переменной.


Размножение объектов массивом (Процедура)

Копирование объектов
На уровень вверх ..
Размножение объектов массивом
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Размножение объектов массивом >
Размножение объектов массивом
Понятие Процедура Краткий справочник

Для создания прямоугольного массива

Для создания кругового массива

Для создания прямоугольного массива 3D объектов

Для создания кругового массива 3D объектов


Для создания прямоугольного массива (Процедура)

Размножение объектов массивом
На уровень вверх ..
Размножение объектов массивом
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Размножение объектов массивом >
Размножение объектов массивом
Понятие Процедура Краткий справочник

Для создания прямоугольного массива

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Массив".В командной строке введите "массив".
  2. В диалоговом окне "Массив" выберите "Прямоугольный массив".
  3. Нажмите кнопку "Выбор объектов".

    Закрытие диалогового окна "Массив". Запрос на выбор объектов.

  4. Выберите объекты для сведения в массив и нажмите ENTER.
  5. В полях "Рядов" и "Столбцов" введите число рядов и столбцов.
  6. Задать горизонтальное и вертикальное расстояния между объектами одним из следующих способов:
    • В полях "Между рядами" и "Между столбцами" введите значения расстояний между рядами и столбцами. Знак числа (плюс или минус) указывает на направление построения массива.
    • Нажмите кнопку "Указать оба расстояния" и указать с помощью устройства указания два противоположных угла ячейки массива. Ячейка определяет вертикальное и горизонтальное расстояния между рядами и столбцами.
    • Нажмите кнопку "Указать расстояние между рядами" для задания вертикального расстояния с помощью устройства указания и кнопку "Указать расстояние между столбцами" для задания горизонтального расстояния.

    В окне образца выводится результат действий.

  7. Для изменения угла поворота массива введите новое значение угла в поле "Угол поворота".
  8. Направление нулевого угла, принятого по умолчанию, можно изменить командой ЕДИНИЦЫ.
  9. Нажмите кнопку "ОК" для создания массива.
Панель:Редактирование
Ввод команды: МАССИВ


Для создания кругового массива (Процедура)

Размножение объектов массивом
На уровень вверх ..
Размножение объектов массивом
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Размножение объектов массивом >
Размножение объектов массивом
Понятие Процедура Краткий справочник

Для создания кругового массива

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Массив".В командной строке введите "массив".
  2. В диалоговом окне "Массив" выберите "Круговой массив".
  3. Для задания точки центра кругового массива выполнить одно из действий:
    • Введите значения координат X и Y, определяющие положение центра кругового массива.
    • Нажмите кнопку "Указать центр массива". Диалоговое окно "Массив" временно закрывается, и предлагается выбрать объекты. С помощью устройства указания задать точку центра кругового массива.
  4. Нажмите кнопку "Выбор объектов".

    Диалоговое окно "Массив" временно закрывается, и предлагается выбрать объекты.

  5. Выберите размножаемые объекты.
  6. В списке "Способ построения" выберите один из предлагаемых способов:
    • Число элементов и угол заполнения
    • Число элементов и угол между элементами
    • Угол заполнения и угол между элементами
  7. Введите число элементов, включая исходный объект, если установлена соответствующая опция.
  8. Воспользуйтесь одним из следующих способов:
    • Введите значения угла заполнения и угла между элементами, если таковые известны. В поле "Угол заполнения" указывается угол заполнения массива. В поле "Угол между элементами" задается угловое расстояние между парой соседних элементов.
    • Нажмите кнопку "Указать угол заполнения" и кнопку "Указать угол между элементами". Укажите угол заполнения и угол между элементами с помощью устройства указания.

    В окне образца выводится результат действий.

  9. При необходимости настройте дополнительные опции:
    • Для поворота элементов в массиве установите флажок "Поворачивать элементы массива". В окне образца выводится результат действий.
    • Чтобы указать базовую точку осей X,Y, выберите "Подробнее", отключите параметр "Как установлено в объекте" и введите значения в окна X и Y, или нажмите кнопку "Указать базовую точку" и используйте указывающее устройство для указания точки.
  10. Нажмите кнопку "ОК" для создания массива.
Панель:Редактирование
Ввод команды: МАССИВ


Для создания прямоугольного массива 3D объектов (Процедура)

Размножение объектов массивом
На уровень вверх ..
Размножение объектов массивом
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Размножение объектов массивом >
Размножение объектов массивом
Понятие Процедура Краткий справочник

Для создания прямоугольного массива 3D объектов

  1. Выберите меню Редактирование [image] 3D операции [image] 3D массив.В командной строке введите "3dмассив".
  2. Выберите размножаемый объект (1).
  3. Задать опцию "Прямоугольный".
  4. Введите число рядов.
  5. Введите число столбцов.
  6. Введите число этажей.
  7. Задать расстояние между рядами.
  8. Задать расстояние между столбцами.
  9. Задать расстояние между этажами.

Ввод команды: 3DМАССИВ


Для создания кругового массива 3D объектов (Процедура)

Размножение объектов массивом
На уровень вверх ..
Создание подобных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Размножение объектов массивом >
Размножение объектов массивом
Понятие Процедура Краткий справочник

Для создания кругового массива 3D объектов

  1. Выберите меню Редактирование [image] 3D операции [image] 3D массив.В командной строке введите "3dмассив".
  2. Выберите размножаемый объект (1).
  3. Задать опцию "Круговой".
  4. Задать число элементов массива.
  5. Задать угол заполнения.
  6. Нажмите ENTER для поворота объектов в ходе объединения в массив или введите n для сохранения их ориентации.
  7. Укажите начальную и конечную точки оси вращения (2, 3).

Ввод команды: 3DМАССИВ


Размножение объектов массивом (Краткий справочник)

Копирование объектов
Размножение объектов массивом
Создание подобных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Размножение объектов массивом >
Размножение объектов массивом
Понятие Процедура Краткий справочник

Команды

3DМАССИВ

Создание 3D массивов

МАССИВ

Создание массивов объектов

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

ПСК

Управление пользовательскими системами координат

ЕДИНИЦЫ

Задание форматов и точности представления линейных и угловых единиц

Системные переменные

ANGBASE

Задание для базового угла значения 0 в соответствии с текущей ПСК

ANGDIR

Направление отсчета положительных углов

SNAPANG

Задание угла поворота сетки и шаговой привязки для текущего видового экрана относительно текущей ПСК

Утилиты

Нет

Ключевые слова для команд

Нет


Создание подобных объектов (Понятие)

Размножение объектов массивом
Копирование, зеркальное отображение и создание подобных объектов
Зеркальное отображение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов >
Создание подобных объектов
Понятие Процедура Краткий справочник

Сместите объект для создания нового объекта, подобного имеющемуся и расположенному на заданном расстоянии от него.

С помощью команды СМЕЩЕНИЕ можно создать новый объект, подобный выбранному объекту. Подобные круги или дуги имеют диаметр, больший или меньший радиуса исходного, в зависимости от того, как задано смещение.

Создание подобных объектов с последующей обрезкой или удлинением концов является эффективным методом построений.

Можно строить следующие подобные объекты:

  • Отрезки
  • Дуги
  • Круги
  • Эллипсы и эллиптические дуги (в результате образуются сплайны овальных форм)
  • Двумерные полилинии
  • Прямые и лучи
  • Сплайны

Особые случаи перемещения полилиний и сплайнов

Обрезка двумерных полилиний и сплайнов происходит автоматически, если расстояние смещения превышает значение, допустимое для размещения создаваемого подобного объекта.

Закрытые 2D полилинии, которые смещаются для создания более крупных полилиний, приводят к зазорам между сегментами. Системная переменная OFFSETGAPTYPE контролирует закрытие зазоров.


Создание подобных объектов (Процедура)

Размножение объектов массивом
На уровень вверх ..
Создание подобных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Создание подобных объектов >
Создание подобных объектов
Понятие Процедура Краткий справочник

Для построения подобного объекта путем задания смещения

Для построения подобного объекта, проходящего через точку


Для построения подобного объекта путем задания смещения (Процедура)

Создание подобных объектов
На уровень вверх ..
Создание подобных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Создание подобных объектов >
Создание подобных объектов
Понятие Процедура Краткий справочник

Для построения подобного объекта путем задания смещения

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Подобие".В командной строке введите "подобие".
  2. Задать расстояние смещения.

    Смещение задается с помощью устройства указания или вводом с клавиатуры.

  3. Выберите исходный объект.
  4. Укажите сторону смещения.
  5. Выберите для смещения следующий объект или нажмите ENTER для завершения команды.
Панель:Редактирование
Ввод команды: ПОДОБИЕ


Для построения подобного объекта, проходящего через точку (Процедура)

Создание подобных объектов
На уровень вверх ..
Зеркальное отображение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Создание подобных объектов >
Создание подобных объектов
Понятие Процедура Краткий справочник

Для построения подобного объекта, проходящего через точку

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Подобие".В командной строке введите "подобие".
  2. Задайте расстояние смещения.
  3. Выберите исходный объект.
  4. Укажите точку, через которую должен проходить новый объект.
  5. Выберите для смещения следующий объект или нажмите ENTER для завершения команды.
Панель:Редактирование
Ввод команды: ПОДОБИЕ


Создание подобных объектов (Краткий справочник)

Размножение объектов массивом
Создание подобных объектов
Зеркальное отображение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Создание подобных объектов >
Создание подобных объектов
Понятие Процедура Краткий справочник

Команды

ПОДОБИЕ

Построение концентрических кругов, параллельных отрезков и кривых

Системные переменные

OFFSETDIST

Значение по умолчанию для расстояния смещения

OFFSETGAPTYPE

Управление зазорами между сегментами, возникающими при смещении замкнутых полилиний

Утилиты

Нет

Ключевые слова для команд

Нет


Зеркальное отображение объектов (Понятие)

Создание подобных объектов
Копирование, зеркальное отображение и создание подобных объектов
Изменение размеров и формы объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов >
Зеркальное отображение объектов
Понятие Процедура Краткий справочник

Зеркальное отображение позволяет создавать зеркальные копии объектов относительно заданной оси.

Функция зеркального отражения помогает быстро создавать симметричные объекты, так как достаточно построение лишь половины объекта с последующим зеркальным отражением вместо построения целого объекта.

Зеркальное отображение объектов производится относительно оси отражения. Ось отражения задается двумя точками. Можно выбрать удаление или сохранение исходных объектов.

Согласно настройкам по умолчанию при зеркальном отражении тексты, атрибуты и определения атрибутов в зеркальном изображении не обращаются справа налево и не переворачиваются вверх ногами. Выравнивание и отступ текста остаются такими же, как до операции зеркального отражения. Если обращение текста справа налево все-таки необходимо, задайте значение 1 для системной переменной MIRRTEXT.

Переменная MIRRTEXT влияет на текст, который создан с помощью команд ТЕКСТ, АТОПР или МТЕКСТ, а также на определения атрибутов и переменные атрибуты. При зеркальном отражении блока текст и постоянные атрибуты, являющиеся частью вставленного блока, обращаются независимо от состояния параметра MIRRTEXT.

Зеркальное отображение в трехмерном пространстве

С помощью команды 3DЗЕРКАЛО, можно зеркально отразить объекты относительно указанной плоскости отражения. Плоскость отражения может представлять собой:

  • Плоскость построения 2D объекта
  • Плоскость, параллельная одной из плоскостей координат (XY, YZ или XZ) текущей ПСК и проходящая через заданную точку
  • Плоскость определяется тремя указанными точками (2, 3 и 4)


Зеркальное отображение объектов (Процедура)

Создание подобных объектов
На уровень вверх ..
Зеркальное отображение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Зеркальное отображение объектов >
Зеркальное отображение объектов
Понятие Процедура Краткий справочник

Для зеркального отображения объектов

Для зеркального отображения 3D объектов


Для зеркального отображения объектов (Процедура)

Зеркальное отображение объектов
На уровень вверх ..
Зеркальное отображение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Зеркальное отображение объектов >
Зеркальное отображение объектов
Понятие Процедура Краткий справочник

Для зеркального отображения объектов

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Зеркало".В командной строке введите зеркало.
  2. Выберите отображаемые объекты.
  3. Укажите первую точку оси отражения.
  4. Укажите вторую точку.
  5. Нажмите ENTER для сохранения исходных объектов или введите y для их удаления.
Панель:Редактирование
Ввод команды: ЗЕРКАЛО


Для зеркального отображения 3D объектов (Процедура)

Зеркальное отображение объектов
На уровень вверх ..
Изменение размеров и формы объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Зеркальное отображение объектов >
Зеркальное отображение объектов
Понятие Процедура Краткий справочник

Для зеркального отображения 3D объектов

  1. Выберите меню Редактирование [image] 3D операции [image] 3D зеркало.
  2. Выберите отображаемый объект.
  3. Укажите три точки, определяющие плоскость отражения.
  4. Нажмите ENTER для сохранения исходных объектов или введите y для их удаления.
Ввод команды: 3DЗЕРКАЛО


Зеркальное отображение объектов (Краткий справочник)

Создание подобных объектов
Зеркальное отображение объектов
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Копирование, зеркальное отображение и создание подобных объектов > Зеркальное отображение объектов >
Зеркальное отображение объектов
Понятие Процедура Краткий справочник

Команды

ЗЕРКАЛО

Создание зеркальной копии выбранных объектов

3DЗЕРКАЛО

Создание зеркальной копии выбранных объектов относительно заданной плоскости

Системные переменные

MIRRTEXT

Управление отображением текста с помощью команды ЗЕРКАЛО

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение размеров и формы объектов

Зеркальное отображение объектов
Редактирование объектов
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов >
Изменение размеров и формы объектов
Понятие Процедура

Имеется несколько способов регулировки размеров существующих объектов относительно других объектов, как с соблюдением симметрии, так и без соблюдения симметрии.

Темы в этом разделе

  • Обрезка и удлинение объектов

    Объекты можно обрезать или удлинять так, чтобы они заканчивались точно на граничных кромках, определяемых другими объектами.

  • Изменение размеров и форм объектов

    Объекты можно изменять, увеличивая или уменьшая их размеры как в одном направлении, так и с сохранением пропорций.


Изменение размеров и формы объектов (Процедура)

Зеркальное отображение объектов
Изменение размеров и формы объектов
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов >
Изменение размеров и формы объектов
Понятие Процедура

Для удлинения объекта

Для обрезки объекта

Для удлинения объектов в 3D каркасных моделях

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

Для обрезки объектов в 3D каркасных моделях

Для растягивания объекта

Для масштабирования объекта с заданным масштабным коэффициентом

Для масштабирования объекта по длине опорного отрезка

Для изменения длины отрезка перетаскиванием


Обрезка и удлинение объектов (Понятие)

Изменение размеров и формы объектов
Изменение размеров и формы объектов
Изменение размеров и форм объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Объекты можно обрезать или удлинять так, чтобы они заканчивались точно на граничных кромках, определяемых другими объектами.

Таким образом, вначале можно создать такой объект, как отрезок, а затем изменить его длину, точно ограниченную с разных сторон другими объектами.

Объекты, выбираемые для определения граничных или режущих кромок, не обязательно должны пересекаться с обрезаемыми объектами. В операции могут участвовать и продолжения кромок, т.е. объекты удлиняются/обрезаются в точках воображаемых пересечений с кромками.

Если контур не задан, то нажатие клавиши ENTER на запрос "Выберите объект" превращает все отображаемые объекты в потенциальные контуры.

Примечание Для выбора режущих или граничных кромок, в которые входят блоки, можно использовать только параметры "Одиночный", "Секущая рамка", "Линия" и "Выбрать все".

Обрезка объектов

Имеется возможность обрезки объекта точно по режущей кромке, задаваемой одним или несколькими объектами.

Например, можно производить обрезку ненужных участков линий в месте пересечения двух стен.

Один и тот же объект может быть одновременно и режущей кромкой, и обрезаемым объектом. Например, на чертеже осветительного прибора окружность является режущей кромкой для прямых линий, и в то же время обрезается сама.

При обрезке составных объектов следует внимательно относиться к способам выбора режущих кромок и обрезаемых объектов. В следующем примере режущие кромки выбираются секущей рамкой.

В следующем примере обрезаемые объекты выбираются с помощью линии выбора.

Имеется возможность обрезать объекты до их ближайших пересечений с другими объектами. Вместо указания режущей кромки следует просто нажать ENTER. Далее, после выбора обрезаемых объектов, ближайшие отображаемые объекты выступают в качестве режущих кромок. В следующем примере производится обрезка ненужных участков линий в месте пересечения стен.

Имеется возможность обрезать объекты до их ближайших пересечений с другими объектами. Удерживая клавишу SHIFT нажатой, выберите объекты для удлинения.

Удлинение объектов

Удлинение и обрезка объектов схожи по технике выполнения. Имеется возможность удлинить объекты так, чтобы они заканчивались точно на граничных кромках, определенных другими объектами. В следующем примере отрезки удлиняются до пересечения с окружностью.

Пользователь может обрезать объекты не выходя из команды УДЛИНИТЬ. Удерживайте нажатой клавишу SHIFT и выберите объекты для обрезки.

Обрезка и удлинение широких полилиний

Обрезка 2D широких полилиний и удлинение центровых линий. Торцы широких полилиний всегда перпендикулярны осевым линиям. Если кромка направлена не под прямым углом, часть обрезанной полилинии выступает за кромку

При обрезке или удлинении сужающегося сегмента 2D полилинии ширина удлиненной конечной точки корректируется для сохранения степени сужения для новой конечной точки. Если в результате конечная ширина становится отрицательной, то она приравнивается к нулю.

Обрезка и удлинение сглаженных сплайнами полилиний

Обрезка сглаженных сплайнами полилиний стирает информацию о сглаженных сплайнами полилиниях и превращает сглаженные сплайнами сегменты в обычные сегменты полилиний.

При удлинении полилинии, сглаженной сплайном, добавляется новая вершина.

Обрезка и удлинение в трехмерном пространстве

Любой 3D объект можно обрезать или удлинить до другого объекта, независимо от того, лежат ли они в одной плоскости с режущими или граничными кромками. Для выбора одной из трех проекций для обрезки или удлинения в командах ОБРЕЗАТЬ и УДЛИНИТЬ используйте параметры "Проект" и "Кромка":

  • Плоскость XY текущей ПСК
  • Плоскость текущего вида
  • Реальное 3D пространство, которое не является проекцией
См. также

    • Разрыв и соединение объектов


Обрезка и удлинение объектов (Процедура)

Изменение размеров и формы объектов
На уровень вверх ..
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Обрезка и удлинение объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Для удлинения объекта

Для обрезки объекта

Для удлинения объектов в 3D каркасных моделях

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

Для обрезки объектов в 3D каркасных моделях


Для удлинения объекта (Процедура)

Обрезка и удлинение объектов
На уровень вверх ..
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Обрезка и удлинение объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Для удлинения объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Удлинить".В командной строке введите "удлинить".
  2. Выберите объекты, определяющие граничные кромки.

    Для выбора всех отображаемых объектов в качестве потенциальных граничных кромок нажмите ENTER, не выбирая объектов.

  3. Выберите удлиняемые объекты.
Панель:Редактирование
Ввод команды: УДЛИНИТЬ


Для обрезки объекта (Процедура)

Обрезка и удлинение объектов
На уровень вверх ..
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Обрезка и удлинение объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Для обрезки объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Обрезать".В командной строке введите "обрезать".
  2. Выберите объекты, определяющие режущие кромки.

    Для выбора всех отображаемых объектов в качестве потенциальных режущих кромок нажмите ENTER без указания объектов.

  3. Выберите обрезаемые объекты.
Панель:Редактирование
Ввод команды: ОБРЕЗКА


Для удлинения объектов в 3D каркасных моделях (Процедура)

Обрезка и удлинение объектов
На уровень вверх ..
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Обрезка и удлинение объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Для удлинения объектов в 3D каркасных моделях

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Удлинить" [image].В командной строке введите "удлинить".
  2. Выберите граничную кромку для удлинения (1).
  3. Введите к (Кромка).
  4. Введите с (С продолжением).
  5. Введите п (Проекция).
  6. Введите п (ПСК).
  7. Выберите удлиняемый объект (2).

Ввод команды: УДЛИНИТЬ


Для обрезки в 3D пространстве с проецированием на плоскость текущего вида (Процедура)

Обрезка и удлинение объектов
На уровень вверх ..
Обрезка и удлинение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Обрезка и удлинение объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Для обрезки в 3D пространстве с проецированием на плоскость текущего вида

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Обрезать" [image].В командной строке введите "обрезать".
  2. Выберите режущую кромку (1).
  3. Введите п (Проекция).
  4. Введите в (Вид).
  5. Выберите обрезаемый объект (2).

Ввод команды: ОБРЕЗКА


Для обрезки объектов в 3D каркасных моделях (Процедура)

Обрезка и удлинение объектов
На уровень вверх ..
Изменение размеров и форм объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Обрезка и удлинение объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Для обрезки объектов в 3D каркасных моделях

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Обрезать" [image].В командной строке введите "обрезать".
  2. Выберите режущие кромки (1, 2).
  3. Введите п (Проекция).
  4. Введите н (Нет).
  5. Выберите обрезаемый объект (3, 4).
Ввод команды: ОБРЕЗАТЬ


Обрезка и удлинение объектов (Краткий справочник)

Зеркальное отображение объектов
Обрезка и удлинение объектов
Изменение размеров и форм объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Обрезка и удлинение объектов >
Обрезка и удлинение объектов
Понятие Процедура Краткий справочник

Команды

РАЗОРВАТЬ

Разрыв выбранного объекта между двумя точками

УДЛИНИТЬ

Удлинение объектов в соответствии с кромками других объектов

СОЕДИНИТЬ

Соединение объектов для формирования одного целого объекта

УВЕЛИЧИТЬ

Изменение длин объектов и центральных углов дуг

ОКНОСВ

Управление свойствами объектов

ОБРЕЗАТЬ

Обрезка объектов в соответствии с кромками других объектов

Системные переменные

EDGEMODE

Управление режимом определения режущих и граничных кромок для команд ОБРЕЗАТЬ и УДЛИНИТЬ

PROJMODE

Установка текущего режима проецирования для операций обрезки и удлинения

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение размеров и форм объектов (Понятие)

Обрезка и удлинение объектов
Изменение размеров и формы объектов
Сопряжение, Фаска, Разорвать или Объединить объекты
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов >
Изменение размеров и форм объектов
Понятие Процедура Краткий справочник

Объекты можно изменять, увеличивая или уменьшая их размеры как в одном направлении, так и с сохранением пропорций.

Кроме того, некоторые объекты можно растягивать, перемещая их конечные точки, вершины или определяющие точки.

Изменение длин объектов

С помощью команды УВЕЛИЧИТЬ можно изменить внутренний угол дуг и длину следующих объектов.

  • Отрезки
  • Дуги
  • Разомкнутые полилинии
  • Эллиптические дуги
  • Разомкнутые сплайны.

В зависимости от ситуации операция изменения длины работает либо подобно удлинению, либо подобно обрезке. Пользователь может:

  • Динамическое перетаскивание конечной точки объекта
  • Укажите новую длину или угол в процентах к общей длине или углу
  • Укажите приращение длины или угла, откладываемого от конечной точки
  • Укажите полную абсолютную длину объекта или внутреннего угла

Растягивание объектов

С помощью команды РАСТЯНУТЬ переместите конечные точки объектов, которые пересекают рамку выбора или расположены внутри нее.

  • Объекты, которые частично находятся в секущей рамке, растягиваются.
  • Объекты, которые полностью включены в секущую рамку, или выделены отдельно, перемещаются, а не растягиваются.

Для растягивания объекта нужно указать базовую точку и точку перемещения.

Для точного растягивания использовать объектную привязку, привязку к ручкам и ввод относительных координат.

Масштабирование объектов с помощью масштабного коэффициента

С помощью команды МАСШТАБ можно увеличивать или уменьшать объект. Для масштабирования объекта нужно указать базовую точку и масштабный коэффициент. Можно также указать длину для использования в качестве масштабного коэффициента на основе текущих единиц чертежа.

Если масштабный коэффициент больше единицы, объект увеличивается, Значения в пределах от 0 до 1 уменьшают объект.

При масштабировании производится изменение размеров выбранного объекта во всех измерениях. Если масштабный коэффициент больше единицы, объект увеличивается, если меньше единицы уменьшается.

ПримечаниеПри применении команды МАСШТАБ к объектам, имеющим свойство аннотативный , положение объекта масштабируется относительно базовой точки операции масштабирования, но при этом размер объекта не изменяется.

Масштабирование объектов с помощью опорного отрезка

Масштабирование можно также выполнять по длине опорного отрезка. При масштабировании с помощью опорного отрезка используется имеющееся расстояние как основа для нового размера. При этом задается длина опорного отрезка в текущем масштабе и его новая длина. Пусть например, одна из сторон объекта имеет 4.8 единицы в длину. Необходимо таким образом масштабировать объект, чтобы она увеличилась до 7.5 единиц. Длина 4.8 является опорной.

Масштабирование по опорной длине можно применять ко всему чертежу. Это может понадобиться, например, если были неверно заданы единицы чертежа. Для этого нужно выбрать в чертеже все объекты. Затем, задав опцию "Опорный отрезок", выберите две точки и укажите новое расстояние между ними. Все объекты чертежа масштабируются соответственно.

См. также

    • Разрыв и соединение объектов


Изменение размеров и форм объектов (Процедура)

Обрезка и удлинение объектов
На уровень вверх ..
Изменение размеров и форм объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Изменение размеров и форм объектов >
Изменение размеров и форм объектов
Понятие Процедура Краткий справочник

Для растягивания объекта

Для масштабирования объекта с заданным масштабным коэффициентом

Для масштабирования объекта по длине опорного отрезка

Для изменения длины отрезка перетаскиванием


Для растягивания объекта (Процедура)

Изменение размеров и форм объектов
На уровень вверх ..
Изменение размеров и форм объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Изменение размеров и форм объектов >
Изменение размеров и форм объектов
Понятие Процедура Краткий справочник

Для растягивания объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Растянуть".В командной строке введите растянуть.
  2. Выберите объект секущей рамкой.

    Секущая рамка должна захватывать по крайней мере одну вершину или определяющую точку объекта.

  3. Выполнить одно из следующих действий:
    • Введите значения относительных координат смещения в декартовой, полярной, цилиндрической или сферической системе координат. Не следует вводить знак @, так как уже предполагается ввод относительных координат. Нажмите ENTER на запрос второй точки перемещения.
    • Укажите базовую точку для растягивания указать вторую точку для определения расстояния и направления.

    Объекты, у которых хотя бы одна вершина или конечная точка расположена внутри секущей рамки, растягиваются. Объекты, полностью охваченные секущей рамкой или выбранные отдельно, перемещаются без растягивания.

Панель:Редактирование
Ввод команды: РАСТЯНУТЬ


Для масштабирования объекта с заданным масштабным коэффициентом (Процедура)

Изменение размеров и форм объектов
На уровень вверх ..
Изменение размеров и форм объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Изменение размеров и форм объектов >
Изменение размеров и форм объектов
Понятие Процедура Краткий справочник

Для масштабирования объекта с заданным масштабным коэффициентом

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Масштаб".В командной строке введите масштаб.
  2. Выберите объект для масштабирования.
  3. Укажите базовую точку.
  4. Введите значение масштабного коэффициента или перетащить объект и нажать кнопку мыши для задания нового масштаба.
Панель:Редактирование
Ввод команды: МАСШТАБ


Для масштабирования объекта по длине опорного отрезка (Процедура)

Изменение размеров и форм объектов
На уровень вверх ..
Изменение размеров и форм объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Изменение размеров и форм объектов >
Изменение размеров и форм объектов
Понятие Процедура Краткий справочник

Для масштабирования объекта по длине опорного отрезка

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Масштаб".В командной строке введите масштаб.
  2. Выберите объект для масштабирования.
  3. Укажите базовую точку.
  4. Выполнить одно из следующих действий:
  5. Укажите первую и вторую опорные точки или введите значение длины опорного отрезка.
Панель:Редактирование
Ввод команды: МАСШТАБ


Для изменения длины отрезка перетаскиванием (Процедура)

Изменение размеров и форм объектов
На уровень вверх ..
Сопряжение, Фаска, Разорвать или Объединить объекты
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Изменение размеров и форм объектов >
Изменение размеров и форм объектов
Понятие Процедура Краткий справочник

Для изменения длины отрезка перетаскиванием

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Увеличить".В командной строке введите "увеличить".
  2. Введите ди для вызова режима динамического перетаскивания.
  3. Выберите объект, длина которого изменяется.
  4. Задать перетаскиванием новое положение ближайшей к точке указания конечной точки.

    Выбранный объект увеличивается или уменьшается, сохраняя положение и ориентацию.

Ввод команды: УВЕЛИЧИТЬ


Изменение размеров и форм объектов (Краткий справочник)

Обрезка и удлинение объектов
Изменение размеров и форм объектов
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Изменение размеров и формы объектов > Изменение размеров и форм объектов >
Изменение размеров и форм объектов
Понятие Процедура Краткий справочник

Команды

СОЕДИНИТЬ

Соединение объектов для формирования одного целого объекта

УВЕЛИЧИТЬ

Изменение длин объектов и центральных углов дуг

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ОКНОСВ

Управление свойствами объектов

МАСШТАБ

Увеличение или уменьшение выбранных объектов с сохранением пропорций

РЕДСПЛАЙН

Редактирование сплайнов или сглаженных сплайнами полилиний

РАСТЯНУТЬ

Растягивание объектов, пересекаемых рамкой выбора или многоугольником

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Сопряжение, Фаска, Разорвать или Объединить объекты

Изменение размеров и форм объектов
Редактирование объектов
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов >
Сопряжение, Фаска, Разорвать или Объединить объекты
Понятие Процедура

Объекты чертежа можно соединять, сопрягая их в углах или строя фаски (скошенные линии). Кроме того, в объектах можно создавать или удалять разрывы.

Темы в этом разделе

  • Построение сопряжений

    С помощью сопряжения можно соединить два объекта, используя дугу, касательную к объектам, и которая имеет определенный радиус.

  • Снятие фасок

    Фаска соединяет два объекта для их пересечения в плоском или скошенном углу.

  • Разрыв и соединение объектов

    Можно разорвать и объединить два объекта с зазором или нет. Можно также создать один объект, объединив несколько.


Сопряжение, Фаска, Разорвать или Объединить объекты (Процедура)

Изменение размеров и форм объектов
Сопряжение, Фаска, Разорвать или Объединить объекты
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты >
Сопряжение, Фаска, Разорвать или Объединить объекты
Понятие Процедура

Задание радиуса сопряжения

Для сопряжения двух отрезков

Построение сопряжения без обрезки

Для построения сопряжений вдоль всей полилинии

Для сопряжения нескольких объектов

Для построения фаски по двум линейным размерам

Для соединения фаской двух непараллельных отрезков

Для построения фаски по линейному и угловому размерам

Для построения фаски без обрезки объектов

Для снятия фасок вдоль всей полилинии

Для соединения фаской нескольких объектов

Для разрывания объекта

Для соединения объектов


Построение сопряжений (Понятие)

Сопряжение, Фаска, Разорвать или Объединить объекты
Сопряжение, Фаска, Разорвать или Объединить объекты
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты >
Построение сопряжений
Понятие Процедура Краткий справочник

С помощью сопряжения можно соединить два объекта, используя дугу, касательную к объектам, и которая имеет определенный радиус.

Внутренний угол называется сопряжением, а внешний угол - округлением; можно создать оба угла с помощью команды СОПРЯЖЕНИЕ.

Сопрягать можно следующие объекты:

  • Дуги
  • Круги
  • Эллипсы и эллиптические дуги
  • Отрезки
  • Полилинии
  • Лучи
  • Сплайны
  • Прямые
  • 3D тела

Cкруглить все углы полилинии можно с помощью команды СОПРЯЖЕНИЕ.

Примечание Сопряжение границ штриховки, которое состоит из отрезков, ведет к потере ассоциативности. Если же граница штриховки задана полилинией, ассоциативность сохраняется.

Если оба соединяемых объекта лежат на одном слое, дуга сопряжения также проводится на том же слое. В противном случае, она строится на текущем слое. Слой определяет другие свойства объекта, включая цвет и тип линий.

С помощью опции "Несколько" можно осуществить сопряжение нескольких объектов, не выходя из команды.

Задание радиуса сопряжения

Радиусом сопряжения называется радиус дуги, соединяющей сопрягаемые объекты. Изменение радиуса действует только на выполняемые после этого сопряжения, оставляя неизменными существующие. Если радиус задать равным 0, то сопрягаемые объекты просто обрезаются или удлиняются до точки пересечения без построения дуги сопряжения.

При выборе объектов для замены значения текущего радиуса сопряжения на 0 можно удерживать нажатой клавишу SHIFT.

Обрезка и удлинение сопрягаемых объектов

Опцией "С обрезкой" можно выбрать режим сопряжения, при котором объекты либо обрезаются/удлиняются до точки пересечения с сопрягающей дугой, либо остаются без изменений.

Задание точек сопряжения

Возможных сопряжений может существовать несколько, и программа делает их выбор на основании положения точек указания. Сравните на чертежах расположения наборов объектов и полученных сопряжений.

Сопряжение отрезков с полилиниями

Для сопряжения линий с полилиниями каждая линия или ее продолжение должно пересечь один из линейных сегментов полилинии. Если включен режим "С обрезкой", сопряженные объекты и дуга сопряжения объединяются, образуя новую полилинию.

Сопряжение вдоль всей полилинии

Можно построить или отменить построение сопряжений вдоль всей полилинии.

При ненулевом радиусе сопряжения команда СОПРЯЖЕНИЕ проводит сопрягающие дуги у каждой из вершин, образованных пересечением линейных сегментов, если эти сегменты имеют достаточную для радиуса сопряжения длину.

Если два сходящихся линейных сегмента полилинии разделены дугой, команда СОПРЯЖЕНИЕ заменяет эту дугу сопрягающей дугой.

Если радиус сопряжения равен 0, то сопрягающие дуги не проводятся. Если при этом два линейных сегмента полилинии разделены одним дуговым сегментом, команда СОПРЯЖЕНИЕ удаляет дугу и удлиняет линейные сегменты до их пересечения.

Сопряжение параллельных линий

Имеется возможность сопряжения параллельных отрезков, прямых и лучей. Текущий радиус сопряжения временно регулируется для создания дуги, касательной к обоим объектам, и размещенной в плоскости, общей для обоих объектов.

Первый из выбранных объектов должен быть отрезком или лучом, а второй - отрезком, прямой или лучом. Сопрягающая дуга проводится, как показано на чертеже.

Объекты сопряжения с ненулевой высотой в 3D пространстве

В AutoCAD можно сопрягать любые объекты, расположенные в одной плоскости и имеющие направления выдавливания, не параллельные оси Z текущей ПСК. Команда СОПРЯЖЕНИЕ определяет направление выдавливания для сопрягающей дуги в 3D пространстве близкое к направлению оси Z текущей ПСК.


Построение сопряжений (Процедура)

Сопряжение, Фаска, Разорвать или Объединить объекты
На уровень вверх ..
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Построение сопряжений >
Построение сопряжений
Понятие Процедура Краткий справочник

Задание радиуса сопряжения

Для сопряжения двух отрезков

Построение сопряжения без обрезки

Для построения сопряжений вдоль всей полилинии

Для сопряжения нескольких объектов


Задание радиуса сопряжения (Процедура)

Построение сопряжений
На уровень вверх ..
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Построение сопряжений >
Построение сопряжений
Понятие Процедура Краткий справочник

Задание радиуса сопряжения

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Сопряжение".В командной строке введите "сопряжение".
  2. Введите д (раДиус).
  3. Введите радиус сопряжения.
  4. Выберите объекты для сопряжения.
Панель:Редактирование
Ввод команды: СОПРЯЖЕНИЕ


Для сопряжения двух отрезков (Процедура)

Построение сопряжений
На уровень вверх ..
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Построение сопряжений >
Построение сопряжений
Понятие Процедура Краткий справочник

Для сопряжения двух отрезков

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Сопряжение".В командной строке введите "сопряжение".
  2. Выберите первый отрезок.
  3. Выберите второй отрезок.
Панель:Редактирование
Ввод команды: СОПРЯЖЕНИЕ


Построение сопряжения без обрезки (Процедура)

Построение сопряжений
На уровень вверх ..
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Построение сопряжений >
Построение сопряжений
Понятие Процедура Краткий справочник

Построение сопряжения без обрезки

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Сопряжение".В командной строке введите "сопряжение".
  2. Если нужно, введите с (С обрезкой). Введите б (Без обрезки).
  3. Выберите объекты для сопряжения.
Панель:Редактирование
Ввод команды: СОПРЯЖЕНИЕ


Для построения сопряжений вдоль всей полилинии (Процедура)

Построение сопряжений
На уровень вверх ..
Построение сопряжений
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Построение сопряжений >
Построение сопряжений
Понятие Процедура Краткий справочник

Для построения сопряжений вдоль всей полилинии

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Сопряжение".В командной строке введите "сопряжение".
  2. Введите п (полилиния).
  3. Выберите полилинию.
Панель:Редактирование
Ввод команды: СОПРЯЖЕНИЕ


Для сопряжения нескольких объектов (Процедура)

Построение сопряжений
На уровень вверх ..
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Построение сопряжений >
Построение сопряжений
Понятие Процедура Краткий справочник

Для сопряжения нескольких объектов

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Сопряжение".В командной строке введите "сопряжение".
  2. Укажите базовую точку.

    В командной строке отображается стандартное приглашение команды.

  3. Выберите первый отрезок или введите опцию и ответьте на запросы этой опции. Выберите первый отрезок.
  4. Выберите второй отрезок.

    В командной строке вновь отображается стандартное приглашение команды.

  5. Выберите первый отрезок для построения следующего сопряжения, либо нажмите ENTER или ESC для завершения команды.
Панель:Редактирование
Ввод команды: СОПРЯЖЕНИЕ


Построение сопряжений (Краткий справочник)

Изменение размеров и форм объектов
Построение сопряжений
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Построение сопряжений >
Построение сопряжений
Понятие Процедура Краткий справочник

Команды

СОПРЯЖЕНИЕ

Скругление углов и сопряжение объектов

Системные переменные

FILLETRAD

Значение текущего радиуса сопряжения

TRIMMODE

Управление обрезкой выбранных кромок для фасок и сопряжений

Утилиты

Нет

Ключевые слова для команд

Нет


Снятие фасок (Понятие)

Построение сопряжений
Сопряжение, Фаска, Разорвать или Объединить объекты
Разрыв и соединение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты >
Снятие фасок
Понятие Процедура Краткий справочник

Фаска соединяет два объекта для их пересечения в плоском или скошенном углу.

Фаска соединяет два объекта с помощью изогнутой линии. Обычно таким образом создаются скошенные углы.

Можно снять фаску

  • Отрезки
  • Полилинии
  • Лучи
  • Прямые
  • 3D тела

Команду ФАСКА можно использовать для скашивания углов полилинии с помощью одной команды.

Примечание Снятие фаски с границ штриховки, которая состоит из отрезков, ведет к потере ассоциативности. Если же граница штриховки задана полилинией, ассоциативность сохраняется.

Если оба соединяемых объекта лежат на одном слое, линия фаски также проводится на том же слое. В противном случае, она строится на текущем слое. Слой определяет другие свойства объекта, включая цвет и тип линий.

С помощью опции "Несколько" можно соединить фаской нескольких объектов, не выходя из команды.

Задание фасок двумя линейными размерами

Длиной фаски называется расстояние между точкой реального или воображаемого пересечения объектов и точкой, до которой удлиняется или обрезается объект при снятии фаски. Если обе длины фаски равны 0, то объекты обрезаются или удлиняются до точки их пересечения, а линия фаски не строится. Можно удерживать нажатой клавишу SHIFT при выборе объектов для замены значения текущих расстояний фаски на 0.

Приводится пример задания длины первой фаски 0,5, а второй фаски 0,25. После указания длин фасок выбираются два отрезка.

Обрезка и удлинение соединяемых фаской объектов

По умолчанию соединяемые фаской объекты обрезаются. Обрезку можно отменить с помощью опции "Обрезка".

Построение фаски по линейному и угловому размерам

Для построения фаски можно задать точку пересечения фаски с первым выбранным объектом и угла, образуемого линией фаски с этим объектом.

В следующем примере два отрезка соединяются фаской. Фаска начинается на первом отрезке на расстоянии 1.5 единицы от точки пересечения отрезков и образует с ним угол 30 градусов.

Построение фасок для полилиний и их сегментов

Для снятия фасок можно выбирать сегменты одной полилинии. Они должны быть либо смежными, либо разделенными одним дуговым сегментом. Если между заданными сегментами имеется дуговой сегмент, как это показано на чертеже, то этот дуговой сегмент удаляется и заменяется линией фаски.

Снятие фасок вдоль всей полилинии

Имеется возможность снять фаски вдоль всей полилинии, то есть построить их в каждом пересечении ее сегментов. При этом рекомендуется задавать одинаковые значения для обеих длин фаски.

В следующем примере оба линейных размера каждой фаски равны между собой.

При снятии фасок вдоль всей полилинии, обрабатываются только те сегменты, длины которых превосходят длину фаски. На следующем чертеже изображена полилиния, некоторые из сегментов которой оказались слишком малы для снятия фасок.


Снятие фасок (Процедура)

Построение сопряжений
На уровень вверх ..
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Для построения фаски по двум линейным размерам

Для соединения фаской двух непараллельных отрезков

Для построения фаски по линейному и угловому размерам

Для построения фаски без обрезки объектов

Для снятия фасок вдоль всей полилинии

Для соединения фаской нескольких объектов


Для построения фаски по двум линейным размерам (Процедура)

Снятие фасок
На уровень вверх ..
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Для построения фаски по двум линейным размерам

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Фаска".В командной строке введите "фаска".
  2. Введите д (Длина).
  3. Задать первую длину фаски.
  4. Задать вторую длину фаски.
  5. Выберите соединяемые фаской отрезки.
Панель:Редактирование
Ввод команды: ФАСКА


Для соединения фаской двух непараллельных отрезков (Процедура)

Снятие фасок
На уровень вверх ..
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Для соединения фаской двух непараллельных отрезков

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Фаска".В командной строке введите "фаска".
  2. Выберите первый отрезок.
  3. Выберите второй отрезок.
Панель:Редактирование
Ввод команды: ФАСКА


Для построения фаски по линейному и угловому размерам (Процедура)

Снятие фасок
На уровень вверх ..
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Для построения фаски по линейному и угловому размерам

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Фаска".В командной строке введите "фаска".
  2. Выберите первый отрезок.
  3. Введите длину фаски от угла соединения вдоль первого отрезка.
  4. Введите угол фаски.
  5. Выберите первый отрезок. Затем выберите второй отрезок.
Панель:Редактирование
Ввод команды: ФАСКА


Для построения фаски без обрезки объектов (Процедура)

Снятие фасок
На уровень вверх ..
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Для построения фаски без обрезки объектов

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Фаска".В командной строке введите "фаска".
  2. Введите t (Управление обрезкой).
  3. Введите n (Без обрезки)
  4. Выберите соединяемые объекты.
Панель:Редактирование
Ввод команды: ФАСКА


Для снятия фасок вдоль всей полилинии (Процедура)

Снятие фасок
На уровень вверх ..
Снятие фасок
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Для снятия фасок вдоль всей полилинии

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Фаска".В командной строке введите "фаска".
  2. Введите п (полилиния).
  3. Выберите полилинию.

    Вдоль всей полилинии происходит снятие фасок установленным текущим способом и с размерами, заданными по умолчанию.

Панель:Редактирование
Ввод команды: ФАСКА


Для соединения фаской нескольких объектов (Процедура)

Снятие фасок
На уровень вверх ..
Разрыв и соединение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Для соединения фаской нескольких объектов

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Фаска".В командной строке введите "фаска".
  2. Укажите базовую точку.

    В командной строке отображается стандартное приглашение команды.

  3. Выберите первый объект, или сначала задать необходимые опции, а затем выберите первый объект.
  4. Выберите второй отрезок.

    В командной строке вновь отображается стандартное приглашение команды.

  5. Выберите первый отрезок для построения следующей фаски, либо нажмите ENTER или ESC для завершения команды.
Панель:Редактирование
Ввод команды: ФАСКА


Снятие фасок (Краткий справочник)

Построение сопряжений
Снятие фасок
Разрыв и соединение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Снятие фасок >
Снятие фасок
Понятие Процедура Краткий справочник

Команды

ФАСКА

Построение фасок в местах пересечения объектов

Системные переменные

CHAMFERA

Задание первого расстояния фаски при нулевом значении CHAMMODE

CHAMFERB

Задание второго расстояния фаски при значении CHAMMODE равном 0

CHAMFERC

Задание длины фаски при значении CHAMMODE равном 1

CHAMFERD

Задание угла фаски при значении CHAMMODE равном 1

CHAMMODE

Задание способа ввода для команды ФАСКА

TRIMMODE

Управление обрезкой выбранных кромок для фасок и сопряжений

Утилиты

Нет

Ключевые слова для команд

Нет


Разрыв и соединение объектов (Понятие)

Снятие фасок
Сопряжение, Фаска, Разорвать или Объединить объекты
Редактирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты >
Разрыв и соединение объектов
Понятие Процедура Краткий справочник

Можно разорвать и объединить два объекта с зазором или нет. Можно также создать один объект, объединив несколько.

Разрыв объектов

Используйте команду РАЗОРВАТЬ, чтобы создать зазор в объекте для образования двух объектов с зазором. Команда РАЗОРВАТЬ часто используется для создания пространства для вставки блока или текста.

Для разрыва объекта без создания зазора указать обе точки разрыва в одном местоположении. Это можно сделать быстро, если ввести @0,0 на запрос второй точки.

Можно создать разрывы в большинстве геометрических тел кроме

  • Блоки
  • Размеры
  • Мультилинии
  • Области

Соединение объектов

Используйте команду СОЕДИНИТЬ для объединения похожих объектов в один. Можно также создать замкнутые круги и эллипсы из дуг и эллиптических дуг. Можно соединять объекты

  • Дуги
  • Эллиптические дуги
  • Отрезки
  • Полилинии
  • Сплайны

Объект, к которому необходимо присоединить подобные объекты, называется исходным объектом. Объекты, которые необходимо присоединить, должны находиться в одной плоскости. Дополнительные ограничения для каждого типа объектов описаны в команде СОЕДИНИТЬ.

ПримечаниеПри объединении двух или более дуг (или эллиптических дуг) их объединение начинается с исходной эллиптической дуги в направлении против часовой стрелки.
См. также

    • Редактирование и объединение полилиний

    • Редактирование сложных объектов


Разрыв и соединение объектов (Процедура)

Снятие фасок
На уровень вверх ..
Разрыв и соединение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Разрыв и соединение объектов >
Разрыв и соединение объектов
Понятие Процедура Краткий справочник

Для разрывания объекта

Для соединения объектов


Для разрывания объекта (Процедура)

Разрыв и соединение объектов
На уровень вверх ..
Разрыв и соединение объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Разрыв и соединение объектов >
Разрыв и соединение объектов
Понятие Процедура Краткий справочник

Для разрывания объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Разорвать".В командной строке введите "разорвать".
  2. Выберите разрываемый объект.

    По умолчанию точка указания объекта считается первой точкой разрыва. Чтобы выбрать в качестве первой точки разрыва другую точку, следует ввести п(Первая) и указать новую точку.

  3. Укажите вторую точку разрыва.

    Для разрыва объекта без создания зазора введите @0,0 для указания предыдущей точки.

Панель:Редактирование
Ввод команды: РАЗОРВАТЬ


Для соединения объектов (Процедура)

Разрыв и соединение объектов
На уровень вверх ..
Редактирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Разрыв и соединение объектов >
Разрыв и соединение объектов
Понятие Процедура Краткий справочник

Для соединения объектов

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Соединить".В командной строке введите "соединить".
  2. Выберите исходный объект, к которому необходимо присоединить объекты.
  3. Выберите один или несколько объектов для присоединения к исходному объекту.

    Доступные объекты включают арки, эллиптические арки, линии, полилинии и сплайны. Дополнительные ограничения для каждого типа объектов описаны в команде СОЕДИНИТЬ.

Панель:Редактирование
Ввод команды: СОЕДИНИТЬ


Разрыв и соединение объектов (Краткий справочник)

Снятие фасок
Разрыв и соединение объектов
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Сопряжение, Фаска, Разорвать или Объединить объекты > Разрыв и соединение объектов >
Разрыв и соединение объектов
Понятие Процедура Краткий справочник

Команды

РАЗОРВАТЬ

Разрыв выбранного объекта между двумя точками

СОЕДИНИТЬ

Соединение объектов для формирования одного целого объекта

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование с помощью ручек

Разрыв и соединение объектов
Редактирование объектов
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов >
Редактирование с помощью ручек
Понятие Процедура

Ручки имеют вид квадратных меток и находятся в характерных точках выбранных объектов. Перетаскивая эти ручки, можно быстро и наглядно редактировать объекты.

Темы в этом разделе

  • Использование режимов ручек

    Перетаскиванием ручек можно выполнять растягивание, перемещение, поворот, масштабирование и зеркальное отображение объектов. Выбранная операция редактирования называется режимом ручек.

  • Многократное копирование с помощью ручек

    С помощью ручек, кроме операций редактирования, можно также выполнять многократное копирование объектов.

  • Управление ручками в блоках

    По желанию пользователя вставленный блок может иметь как одну ручку, так и набор ручек.


Редактирование с помощью ручек (Процедура)

Разрыв и соединение объектов
Редактирование с помощью ручек
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек >
Редактирование с помощью ручек
Понятие Процедура

Для включения ручек

Для установки цвета ручек под курсором

Для задания предельного количества выбранных объектов для показа ручек

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

Для отмены выделения ручками

Для растягивания объекта с помощью ручек

Для растягивания с помощью нескольких ручек

Для перемещения объекта с помощью ручек

Для поворота объекта с помощью ручек

Для масштабирования объектов с помощью ручек

Для зеркального отображения объектов с помощью ручек

Для многократного копирования в любом режиме ручек

Для задания шага смещения при многократном копировании

Для задания шага поворота при многократном копировании

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов

Для включения и отключения ручек в блоках


Использование режимов ручек (Понятие)

Редактирование с помощью ручек
Редактирование с помощью ручек
Многократное копирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Перетаскиванием ручек можно выполнять растягивание, перемещение, поворот, масштабирование и зеркальное отображение объектов. Выбранная операция редактирования называется режимом ручек.

Ручки имеют вид квадратных меток и находятся в характерных точках выбранных объектов. Перетаскивая их, можно выполнять растягивание, перемещение, поворот, масштабирование и зеркальное отображение объектов.

В режиме включенных ручек выбор объектов производится до ввода команды, после чего пользователь может манипулировать объектом с помощью устройства указания.

ПримечаниеДля объектов, расположенных на заблокированных слоях, ручки не отображаются.

Для использования режима ручки выберите ручку (базовую ручку) с целью действий в базовой точке для операций. (Выбранная ручка называется также"горячей"). После этого выбирается один из режимов ручек. Циклическое переключение этих режимов производится последовательным нажатием клавиш ENTER или ПРОБЕЛ. Нужный режим можно включить с помощью комбинации быстрого вызова или из контекстного меню.

ПримечаниеРастягивание двумерного объекта, расположенного на плоскости, отличной от текущей ПСК, происходит именно в плоскости, где он был создан.

Работа с ручками квадранта

Для ручек, расположенных на кругах и эллипсах, расстояния отмеряются от точки центра, а не от выбранной ручки. Например, в режиме "Растянуть", можно выбрать ручку квадранта и растянуть круг, а затем ввести новое значение радиуса в командной строке. Новое значение радиуса отмеряется от центра круга, а не от выбранной ручки. Если выбрать ручку, расположенную в центре круга, то круг можно перемещать.

Выбор и изменение нескольких ручек

В качестве базовых ручек для операции можно использовать несколько ручек. Когда выбрано несколько ручек (что носит также название "выбор нескольких наиболее часто используемых ручек"), форма объекта между выбранными ручками остается неизменной. Чтобы выбрать несколько ручек, удерживайте SHIFT нажатой и выберите дополнительные ручки.

Ограничение отображения ручек

Отображение ручек на выбранных объектах является настраиваемым. Режим подавления ручек в случае, если исходный набор содержит больше объектов, чем задано, устанавливается системной переменной GRIPOBJLIMIT. При добавлении объектов в исходный набор ограничение не действует. Например, если значение переменной GRIPOBJLIMIT равно 20, то пользователь может выбрать 15 объектов, затем добавить в исходный набор 25 объектов, и на всех объектах будут отображаться ручки.

ПримечаниеДля объектов, расположенных на заблокированных слоях, ручки не отображаются.

Растягивание с помощью ручек

Объект можно растянуть перетаскиванием его ручек. Но если перетаскивать ручки, расположенные на текстовых объектах, в точках вхождений блоков, на серединах отрезков, в центрах кругов и на объектах-точках, то вместо растягивания происходит перемещение всего объекта. Таким образом, ручки позволяют легко перемещать вхождения блоков и изменять размеры объектов.

Перемещение с помощью ручек

С помощью ручек можно перемещать объекты. При задании направления и расстояния указанием точки выбранные объекты, выделенные подсветкой, перемещаются на новое место.

Поворот с помощью ручек

Выбранные объекты можно поворачивать вокруг базовой точки путем указания точки и перетаскивания ручки. Кроме того, можно ввести значение угла. Этим способом можно поворачивать и вхождения блоков.

Масштабирование с помощью ручек

Выбранные объекты можно масштабировать относительно базовой точки. Для увеличения объекта следует перетаскивать курсор от базовой ручки, а для уменьшения - к базовой ручке. Можно также ввести значение относительного масштабного коэффициента.

Зеркальное отображение с помощью ручек

Выбранные объекты можно зеркально отображать относительно временной оси отражения. Для задания вертикальной или горизонтальной оси отражения можно воспользоваться режимом "Орто".

См. также

    • Использование динамического ввода

    • Работа с динамическими блоками в чертежах


Использование режимов ручек (Процедура)

Редактирование с помощью ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для включения ручек

Для установки цвета ручек под курсором

Для задания предельного количества выбранных объектов для показа ручек

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

Для отмены выделения ручками

Для растягивания объекта с помощью ручек

Для растягивания с помощью нескольких ручек

Для перемещения объекта с помощью ручек

Для поворота объекта с помощью ручек

Для масштабирования объектов с помощью ручек

Для зеркального отображения объектов с помощью ручек


Для включения ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для включения ручек

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" установите флажок "Включить ручки".
  3. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Для установки цвета ручек под курсором (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для установки цвета ручек под курсором

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" нажать на стрелку рядом с полем "Цвет ручки под курсором".
  3. Выберите один из стандартных цветов, или воспользоваться элементом "Выбор цвета" для вызова диалогового окна выбора цвета.


Для задания предельного количества выбранных объектов для показа ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для задания предельного количества выбранных объектов для показа ручек

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" введите требуемое значение в поле "Предельное количество выбранных объектов для показа ручек". Максимальное возможное значение составляет 32767.

    При добавлении объектов к исходному набору ограничение не действует.


Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для отображения подсказок к ручкам в пользовательских объектах, поддерживающих подсказки к ручкам

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" выберите "Подсказки к ручкам".


Для отмены выделения ручками (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для отмены выделения ручками

  • Нажмите ESC.


Для растягивания объекта с помощью ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для растягивания объекта с помощью ручек

  1. Выберите объект для растягивания.
  2. Выберите базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Переместите устройство указания и нажмите кнопку мыши.

    Выбранный объект растягивается с учетом нового положения ручки.

ПримечаниеДля копирования выбранного объекта во время выполнения операции растяжения нажмите и удерживайте клавишу CTRL.


Для растягивания с помощью нескольких ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для растягивания с помощью нескольких ручек

  1. Выберите несколько объектов для растягивания.
  2. Удерживая нажатой клавишу SHIFT, выберите несколько ручек; выбранные ручки выделяются цветом.
  3. Отпустите клавишу SHIFT и нажатием кнопки мыши выберите ручку для использования в качестве базовой.

    Включается режим "Растягивание", выбранный по умолчанию.

  4. Переместить устройство указания и нажмите кнопку мыши.

    Выбранные ручки перемещаются одновременно. Заданные объекты растягиваются.


Для перемещения объекта с помощью ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для перемещения объекта с помощью ручек

  1. Выберите объекты для перемещения.
  2. Выберите базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Перемещение".

    Нужный режим можно также выбрать из контекстного меню.

  4. Переместить устройство указания и нажать кнопку мыши.

    Выбранные объекты перемещаются, следуя за ручкой.

ПримечаниеДля копирования выбранного объекта во время выполнения операции перемещения нажмите и удерживайте клавишу CTRL.


Для поворота объекта с помощью ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для поворота объекта с помощью ручек

  1. Выберите поворачиваемые объекты.
  2. Выберите базовую ручку на объекте с помощью нажатия кнопки мыши.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Поворот".

    Нужный режим можно также выбрать из контекстного меню.

  4. Переместить устройство указания и нажмите кнопку мыши.

    Выбранные объекты поворачиваются вокруг базовой ручки.

ПримечаниеДля копирования выбранного объекта во время выполнения операции поворота нажмите и удерживайте клавишу CTRL.


Для масштабирования объектов с помощью ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Использование режимов ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для масштабирования объектов с помощью ручек

  1. Выберите объекты для масштабирования.
  2. Выберите базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Масштаб".

    Нужный режим можно также выбрать из контекстного меню.

  4. Введите значение масштабного коэффициента или перетащите объект и нажмите кнопку мыши для задания нового масштаба.
ПримечаниеДля копирования выбранного объекта во время выполнения операции масштабирования нажмите и удерживайте клавишу CTRL.


Для зеркального отображения объектов с помощью ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Многократное копирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Для зеркального отображения объектов с помощью ручек

  1. Выберите отображаемые объекты.
  2. Выберите мышью базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Зеркало".

    Нужный режим можно также выбрать из контекстного меню.

  4. Укажите вторую точку для определения оси отражения.

    Для зеркального отображения объектов иногда удобно использовать режим "Орто".


Использование режимов ручек (Краткий справочник)

Разрыв и соединение объектов
Использование режимов ручек
Многократное копирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Использование режимов ручек >
Использование режимов ручек
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

GRIPBLOCK

Управление ручками внутри блоков

GRIPCOLOR

Управление цветом невыбранных ручек

GRIPHOT

Управление цветом выбранных ручек

GRIPHOVER

Управление цветом невыбранной ручки, когда курсор останавливается над ней

GRIPOBJLIMIT

Подавление отображения ручек, если количество объектов в наборе превышает заданное

GRIPS

Управление использованием ручек набора объектов при их растягивании, перемещении, повороте, масштабировании и зеркальном отображении

GRIPSIZE

Размер квадрата, изображающего ручку (в пикселах)

GRIPTIPS

Управление отображением подсказок к ручкам при наведении курсора на ручки динамических блоков и пользовательских объектов, поддерживающих подсказки к ручкам

Утилиты

Нет

Ключевые слова для команд

Нет


Многократное копирование с помощью ручек (Понятие)

Использование режимов ручек
Редактирование с помощью ручек
Управление ручками в блоках
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек >
Многократное копирование с помощью ручек
Понятие Процедура Краткий справочник

С помощью ручек, кроме операций редактирования, можно также выполнять многократное копирование объектов.

Так, например, используя опцию "Копировать", можно поворачивать выбранные объекты, создавая их копии в каждой указываемом положении.

Кроме того, режим многократного копирования активизируется нажатием клавиши CTRL в процессе указания первого нового положения для объекта. Так в режиме "Растянуть" функция многократного копирования растягивает объект, например, отрезок, и копирует его в любую точку графической области, указанную пользователем. Множественное копирование будет продолжаться, пока не выключить ручки.

ПримечаниеПри использовании ручек для многократного копирования объекта аннотативный , который содержит несколько масштабируемых представлений, выполняется копирование только текущего представления.

Задание шага смещения и шага поворота

Многократное копирование можно производить, размещая копии с заданным шагом смещения. Этот шаг определяется расстоянием между объектом и его следующей копией. В следующем примере размещаются источники освещения. Первая копия осветительного прибора создается со смещением в две единицы. Все последующие копии также размещаются на расстоянии в две единицы от предыдущих.

Если при выборе нескольких точек копирования с помощью указывающего устройства удерживать нажатой клавишу CTRL, графический курсор будет привязан к точке смещения, созданной на основе двух последних выбранных точек. В приведенной ниже иллюстрации координаты середины отрезка 1 - 8,5. На основе этой серединной точки отрезок 2 был скопирован с помощью клавиши CTRL и режима ручек "Растянуть"; координаты середины этого отрезка - 9,5. Третий отрезок будет привязан к точке смещения, созданной на основе значений координат 10,5.

При повороте объекта вокруг базовой ручки можно также размещать копии с заданным угловым интервалом. Шаг поворота определяется углом между объектом и его следующей копией, создаваемой в режиме ручек "Поворот". Для использования шага поворота нажмите и удерживайте клавишу CTRL.


Многократное копирование с помощью ручек (Процедура)

Использование режимов ручек
На уровень вверх ..
Многократное копирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Многократное копирование с помощью ручек >
Многократное копирование с помощью ручек
Понятие Процедура Краткий справочник

Для многократного копирования в любом режиме ручек

Для задания шага смещения при многократном копировании

Для задания шага поворота при многократном копировании

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов


Для многократного копирования в любом режиме ручек (Процедура)

Многократное копирование с помощью ручек
На уровень вверх ..
Многократное копирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Многократное копирование с помощью ручек >
Многократное копирование с помощью ручек
Понятие Процедура Краткий справочник

Для многократного копирования в любом режиме ручек

  1. Выберите копируемые объекты.
  2. Выберите базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите требуемый режим.

    Нужный режим можно также выбрать из контекстного меню.

  4. Введите к (Копировать) или нажмите и удерживайте клавишу CTRL при растягивании, перемещении, повороте или масштабировании.

    Копирование будет продолжаться, пока не выключены ручки.

  5. Введите или укажите дополнительные параметры для выполнения операции в текущем режиме ручек.
  6. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Для задания шага смещения при многократном копировании (Процедура)

Многократное копирование с помощью ручек
На уровень вверх ..
Многократное копирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Многократное копирование с помощью ручек >
Многократное копирование с помощью ручек
Понятие Процедура Краткий справочник

Для задания шага смещения при многократном копировании

  1. Выберите копируемые объекты.
  2. Выберите базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Перемещение".

    Нужный режим можно также выбрать из контекстного меню.

  4. Введите к (Копировать).
  5. Переместите курсор и нажмите кнопку мыши.

    Шаг смещения определяется расстоянием между выбранной ручкой и точкой, указанной для копирования.

  6. Удерживая в нажатой клавишу CTRL, разместите дополнительные копии, для чего укажите дополнительные положения.

    Копии объектов размещаются с равным интервалом, определяемым при последнем копировании.

  7. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Для задания шага поворота при многократном копировании (Процедура)

Многократное копирование с помощью ручек
На уровень вверх ..
Многократное копирование с помощью ручек
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Многократное копирование с помощью ручек >
Многократное копирование с помощью ручек
Понятие Процедура Краткий справочник

Для задания шага поворота при многократном копировании

  1. Выберите поворачиваемые объекты.
  2. Выберите базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Поворот".

    Нужный режим можно также выбрать из контекстного меню.

  4. Введите к (Копировать).
  5. Переместите устройство указания и нажмите кнопку мыши.

    Шаг поворота определяется углом между выбранной ручкой и точкой, указанной для копирования.

  6. Удерживая в нажатом состоянии клавишу CTRL, укажите следующие положения для копирования объектов.

    Копии объектов создаются путем поворота предыдущей копии на угол, определяемый при повороте первой копии.

  7. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов (Процедура)

Многократное копирование с помощью ручек
На уровень вверх ..
Управление ручками в блоках
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Многократное копирование с помощью ручек >
Многократное копирование с помощью ручек
Понятие Процедура Краткий справочник

Для зеркального отображения объектов с помощью ручек и с сохранением оригиналов

  1. Выберите отображаемые объекты.
  2. Выберите мышью базовую ручку на объекте.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Просмотрите режимы ручек с помощью клавиши ENTER и выберите режим "Зеркало".

    Нужный режим можно также выбрать из контекстного меню.

  4. Нажмите и удерживайте клавишу CTRL (или введите к (Копировать)), чтобы запомнить исходное изображение и указать вторую точку оси отражения.

    Для зеркального отображения объектов иногда удобно использовать режим "Орто".

  5. Выключите ручки нажатием клавиши ENTER, ПРОБЕЛ или ESC.


Многократное копирование с помощью ручек (Краткий справочник)

Использование режимов ручек
Многократное копирование с помощью ручек
Управление ручками в блоках
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Многократное копирование с помощью ручек >
Многократное копирование с помощью ручек
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

GRIPBLOCK

Управление ручками внутри блоков

GRIPCOLOR

Управление цветом невыбранных ручек

GRIPHOT

Управление цветом выбранных ручек

GRIPS

Управление использованием ручек набора объектов при их растягивании, перемещении, повороте, масштабировании и зеркальном отображении

GRIPSIZE

Размер квадрата, изображающего ручку (в пикселах)

Утилиты

Нет

Ключевые слова для команд

Нет


Управление ручками в блоках (Понятие)

Многократное копирование с помощью ручек
Редактирование с помощью ручек
Редактирование сложных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек >
Управление ручками в блоках
Понятие Процедура Краткий справочник

По желанию пользователя вставленный блок может иметь как одну ручку, так и набор ручек.

По желанию пользователя вставленный блок может иметь как одну ручку в точке вставки, так и набор ручек для каждого отдельного объекта внутри блока.

См. также

    • Указание ручек для динамических блоков


Для включения и отключения ручек в блоках (Процедура)

Многократное копирование с помощью ручек
На уровень вверх ..
Редактирование сложных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Управление ручками в блоках >
Управление ручками в блоках
Понятие Процедура Краткий справочник

Для включения и отключения ручек в блоках

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. На вкладке "Выбор" диалогового окна "Настройка" установите или сбросьте флажок "Ручки внутри блоков".
  3. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Управление ручками в блоках (Краткий справочник)

Многократное копирование с помощью ручек
Управление ручками в блоках
Расчленение составных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование объектов > Редактирование с помощью ручек > Управление ручками в блоках >
Управление ручками в блоках
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

GRIPBLOCK

Управление ручками внутри блоков

GRIPCOLOR

Управление цветом невыбранных ручек

GRIPHOT

Управление цветом выбранных ручек

GRIPS

Управление использованием ручек набора объектов при их растягивании, перемещении, повороте, масштабировании и зеркальном отображении

GRIPSIZE

Размер квадрата, изображающего ручку (в пикселах)

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование сложных объектов

Управление ручками в блоках
Методы редактирования
Расчленение составных объектов
Создание и редактирование объектов > Методы редактирования >
Редактирование сложных объектов
Понятие Процедура

Для таких сложных объектов, как блоки, размеры, штриховки и полилинии, предусмотрены дополнительные операции редактирования.

Темы в этом разделе

  • Расчленение составных объектов

    Составные объекты, такие как полилинии, размеры, штриховки и вхождения блоков, можно расчленять на отдельные составляющие элементы.

  • Редактирование и объединение полилиний

    Для изменения формы полилиний, кроме общих операций редактирования, предусмотрены также дополнительные операции. Кроме того, можно объединять отдельные полилинии в одну.

  • Редактирование сплайнов

    Для изменения форм сплайнов, кроме общих операций редактирования, предусмотрены также дополнительные опции.

  • Изменение спиралей

    Для изменения формы и размера спирали можно использовать как ручки, так и палитру "Свойства".

  • Редактирование мультилиний

    Многострочные объекты состоят из параллельных линий (от 1 до 16), называемых элементами. Для изменения мультилиний можно использовать обычные команды редактирования, команду редактирования мультилинии и стили мультилинии.


Редактирование сложных объектов (Процедура)

Управление ручками в блоках
Редактирование сложных объектов
Расчленение составных объектов
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов >
Редактирование сложных объектов
Понятие Процедура

Для расчленения объекта

Для редактирования полилинии

Объединение полилиний, линий и дуг в одну полилинию

Удаление вершины в полилинии

Для сужения ширины отдельных сегментов

Для редактирования сплайна

Для удаления вершины мультилинии

Для задания закрытого крестообразного типа пересечения

Редактирование стиля мультилинии


Расчленение составных объектов (Понятие)

Редактирование сложных объектов
Редактирование сложных объектов
Редактирование и объединение полилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов >
Расчленение составных объектов
Понятие Процедура Краткий справочник

Составные объекты, такие как полилинии, размеры, штриховки и вхождения блоков, можно расчленять на отдельные составляющие элементы.

Составные объекты, такие как полилинии, размеры, штриховки и вхождения блоков, можно расчленять на отдельные составляющие элементы. Например, расчленение полилинии приводит к ее разделению на простые отрезки и дуги. Вхождения блоков и ассоциативные размеры после расчленения преобразуются в наборы простых объектов.

Расчленение размеров и штриховок

При расчленении размеров и штриховок теряется ассоциативная связь между элементами, что приводит к образованию набора простых объектов, таких как отрезки, тексты, точки и 2D фигуры. Для автоматического расчленения размеров во время их создания задайте для системной переменной DIMASSOC значение 0.

Расчленение полилиний

При расчленении полилинии теряется информацию о ее ширине. Результирующие отрезки и дуги располагаются вдоль ее осевой линии. Для расчленения полилиний, содержавшихся в расчлененном блоке, требуется отдельная операция. Ширина кольца после его расчленения также становится нулевой.

Расчленение блоков

При расчленении из блоков удаляются атрибуты, однако при этом исходные определения атрибутов сохраняются. Цвета и типы линий отдельных объектов, образующихся на месте вхождений блоков, могут измениться.

Расчленение внешних ссылок

Внешними ссылками называются файлы чертежей, вставленные в другие чертежи и сохраняющие связь со своим исходным описанием. Внешние ссылки и унаследованные из них блоки расчленить нельзя.


Для расчленения объекта (Процедура)

Редактирование сложных объектов
На уровень вверх ..
Редактирование и объединение полилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Расчленение составных объектов >
Расчленение составных объектов
Понятие Процедура Краткий справочник

Для расчленения объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Расчленить". В командной строке введите "расчленить".
  2. Выберите объекты для расчленения.

    Для многих объектов результат расчленения визуально не заметен.

Панель:Редактирование
Ввод команды: РАСЧЛЕНИТЬ


Расчленение составных объектов (Краткий справочник)

Управление ручками в блоках
Расчленение составных объектов
Редактирование и объединение полилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Расчленение составных объектов >
Расчленение составных объектов
Понятие Процедура Краткий справочник

Команды

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

РАСЧЛЕНИТЬ

Разбиение составного объекта на отдельные компоненты

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

EXPLMODE

Управление обработкой блоков с разными масштабами вставки в команде РАСЧЛЕНИТЬ

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование и объединение полилиний (Понятие)

Расчленение составных объектов
Редактирование сложных объектов
Редактирование сплайнов
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов >
Редактирование и объединение полилиний
Понятие Процедура Краткий справочник

Для изменения формы полилиний, кроме общих операций редактирования, предусмотрены также дополнительные операции. Кроме того, можно объединять отдельные полилинии в одну.

Редактирование полилиний заключается в их замыкании и размыкании, а также в перемещении, добавлении и удалении отдельных вершин. Имеется возможность выпрямления полилинии между двумя вершинами, настройки типа линии так, что до и после каждой вершины рисуются штрихи. Можно задать единую ширину для всей полилинии или управлять шириной для каждого сегмента. Полилинии можно также линейно аппроксимировать в сплайновые кривые.

Сегменты объединяемых полилиний

К разомкнутой полилинии можно присоединить отрезок, дугу или другую полилинию, если их конечные точки совпадают. Если конечные точки не совпадают, но расстояние между ними не превышает некоторого критического значения, то объединение выполняется с помощью обрезки, удлинения или создания нового сегмента.

Свойства объединенных полилиний

Полилиния, полученная в результате объединения нескольких объектов с различными свойствами, наследует свойства первого выбранного объекта. Если две линии примыкают к полилинии в форме буквы Y, выбирается одна из линий и она присоединяется к полилинии. Данное объединение также приводит к тому, что программа неявно отменяет сглаживание как исходной полилинии, так и присоединяемой. После присоединения полученную полилинию можно сгладить снова.

Дополнительные опции редактирования полилиний

Для редактирования полилиний, кроме общих операций редактирования, применяемых ко многим объектам, предусмотрены также дополнительные опции редактирования и объединения, реализуемые командой ПОЛРЕД.

  • "Замкнуть". Создание замыкающего сегмента полилинии, соединяющего его последний сегмент с первым. Полилиния считается открытой, пока ее не замкнуть с помощью параметра "Замкнуть".
  • "Соединить". Добавление линий, дуг или полилиний к концу открытой полилинии и отмена сглаживания для полилиний, сглаженных дугой. Конец добавляемого объекта должен точно совпадать с одной из конечных точек полилинии.
  • "Ширина". Задание новой единой ширины для всей полилинии. Можно воспользоваться также подопцией "Ширина" опции "Вершина" для изменения начальной и конечной ширины отдельных сегментов.

  • "Вершина". Первая вершина полилинии на экране помечается крестиком (X) на экране. Если для этой вершины задана касательная, то ее направление указывается стрелкой.
  • "Сгладить". Вычисление гладкой кривой, сглаживающей вершины полилинии дугами. Кривая проходит через все вершины полилинии, удовлетворяя при этом значениям касательных, заданных для этих вершин.
  • "Сплайн". Использование вершин выбранной полилинии в качестве управляющих точек или контура сглаженной сплайном полилинии. Кривая проходит через первую и последнюю управляющие точки, если исходная полилиния не была замкнута.

  • "Убрать сглаживание". Удаление всех дополнительных вершин с помощью сглаженной дугой или сплайном полилинии и выпрямление всех сегментов полилинии.
  • "Типлин". Задание способа генерации типа линий в вершинах полилинии. При включенном параметре генерация заданного типа линий начинается со штриха и заканчивается штрихом в каждой вершине.
См. также

    • Обрезка и удлинение объектов

    • Разрыв и соединение объектов


Редактирование и объединение полилиний (Процедура)

Расчленение составных объектов
На уровень вверх ..
Редактирование и объединение полилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование и объединение полилиний >
Редактирование и объединение полилиний
Понятие Процедура Краткий справочник

Для редактирования полилинии

Объединение полилиний, линий и дуг в одну полилинию

Удаление вершины в полилинии

Для сужения ширины отдельных сегментов


Для редактирования полилинии (Процедура)

Редактирование и объединение полилиний
На уровень вверх ..
Редактирование и объединение полилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование и объединение полилиний >
Редактирование и объединение полилиний
Понятие Процедура Краткий справочник

Для редактирования полилинии

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Редактировать полилинию".В командной строке введите "полред".
  2. Выберите полилинию для редактирования.

    Если выбранный объект является линией или дугой, отобразится следующий запрос.

    Выбранный объект - не полилиния.

    Сделать его полилинией? <Y>: Введите y или n, или нажмите ENTER

    При ответе д такой объект преобразуется в двумерную полилинию, состоящую из одного сегмента. Полученную полилинию можно отредактировать. Этой операцией можно пользоваться для объединения отрезков и дуг в полилинию. Если значение системной переменной PEDITACCEPT равно 1, то такой запрос не выдается, и выбранный объект автоматически преобразуется в полилинию.

  3. Задать любые из приведенных опций редактирования:
    • Введите з (Замкнуть) для замыкания разомкнутой полилинии.
    • Введите д (Добавить) для объединения смежных отрезков, дуг или полилиний.
    • Введите ш (Ширина) для задания новой единой ширины для всей полилинии.
    • Введите в (Вершина) для редактирования вершин.
    • Введите сг (СГладить) для сглаживания полилинии дугами, проходящими через все вершины.
    • Введите сп (СПлайн) для сплайновой аппроксимации полилинии.
    • Введите у (Убрать сглаживание) для удаления всех дополнительных вершин, вставленных при выполнении операций "Сгладить" и "Сплайн", и выпрямление всех сегментов полилинии.
    • Введите т (Типлин) для включения или отключения непрерывной генерации образца типа линий.
    • Введите о (Отменить), чтобы вернуть действия к началу ПОЛРЕД.
  4. Введите x (Выход) для завершения опции команды. Для выхода из команды ПОЛРЕД нажмите ENTER.
Панель:Редактирование-2
Ввод команды: ПОЛРЕД


Объединение полилиний, линий и дуг в одну полилинию (Процедура)

Редактирование и объединение полилиний
На уровень вверх ..
Редактирование и объединение полилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование и объединение полилиний >
Редактирование и объединение полилиний
Понятие Процедура Краткий справочник

Объединение полилиний, линий и дуг в одну полилинию

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Редактировать полилинию".В командной строке введите "полред".
  2. Выберите полилинию, линию или дугу для редактирования. Если выбрана линия или дуга, нажмите ENTER для преобразования выбранной линии или дуги в полилинию.
  3. Введите с (Соединить).
  4. Выберите одну или несколько полилиний, линий или дуг, располагаемых из конца в конец.

    Все выбранные полилинии, линии или дуги теперь соединяются в единую полилинию.

  5. Нажмите ENTER для завершения команды.
Панель:Редактирование-2
Ввод команды: ПОЛРЕД


Удаление вершины в полилинии (Процедура)

Редактирование и объединение полилиний
На уровень вверх ..
Редактирование и объединение полилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование и объединение полилиний >
Редактирование и объединение полилиний
Понятие Процедура Краткий справочник

Удаление вершины в полилинии

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Редактировать полилинию".В командной строке введите "полред".
  2. Выберите полилинию.
  3. Введите р (редактировать вершину).

    Первая вершина помечается символом X. Используйте опцию "Далее" для перемещения X на вершину, предшествующую той, которую нужно удалить.

  4. Введите с (спрямить)
  5. Используйте опцию "Далее" для перемещения X на вершину, следующую непосредственно за той, которую нужно удалить
  6. Введите и (Идти дальше).

    Вершина на полилинии удаляется. Вершины с каждой из сторон от удаленной вершины соединяются между собой прямолинейным отрезком полилинии.

  7. Введите х (выХод) для завершения работы с вершинами.
  8. Нажмите ENTER для завершения команды.
Панель:Редактирование-2
Ввод команды: ПОЛРЕД


Для сужения ширины отдельных сегментов (Процедура)

Редактирование и объединение полилиний
На уровень вверх ..
Редактирование сплайнов
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование и объединение полилиний >
Редактирование и объединение полилиний
Понятие Процедура Краткий справочник

Для сужения ширины отдельных сегментов

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Редактировать полилинию".В командной строке введите "полред".
  2. Выберите полилинию для редактирования.
  3. Введите в (Вершина).

    Первая вершина помечается крестиком (X). Переместите соответствующую вершину с помощью опций "Следующая" или "Предыдущая".

  4. Введите ш (Ширина).
  5. Введите начальную и конечную ширину, затем нажмите ENTER для перехода к следующей вершине. Повторить пункты 4 и 5 для каждого сегмента.
  6. Введите о (Отменить), чтобы вернуть действия к началу ПОЛРЕД.
  7. Введите х (выХод) для завершения работы с вершинами.
  8. Нажмите ENTER для завершения команды.
Панель:Редактирование-2
Ввод команды: ПОЛРЕД


Редактирование и объединение полилиний (Краткий справочник)

Расчленение составных объектов
Редактирование и объединение полилиний
Редактирование сплайнов
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование и объединение полилиний >
Редактирование и объединение полилиний
Понятие Процедура Краткий справочник

Команды

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

СОЕДИНИТЬ

Соединение объектов для формирования одного целого объекта

Системные переменные

PEDITACCEPT

Подавление отображения подсказки "Выбранный объект не является полилинией" команды ПОЛРЕД

SPLFRAME

Управление отображением сплайнов и сглаженных сплайнами полилиний

SPLINESEGS

Количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД

SPLINETYPE

Тип кривой, создаваемой с помощью параметра "Сплайн" команды ПОЛРЕД

SURFTYPE

Управление типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн")

SURFU

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности

SURFV

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование сплайнов (Понятие)

Редактирование и объединение полилиний
Редактирование сложных объектов
Изменение спиралей
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов >
Редактирование сплайнов
Понятие Процедура Краткий справочник

Для изменения форм сплайнов, кроме общих операций редактирования, предусмотрены также дополнительные опции.

Для редактирования сплайнов, кроме общих операций редактирования, применяемых ко многим объектам, предусмотрены также дополнительные опции, реализуемые командой РЕДСПЛАЙН:

  • Определяющие. Редактирование определяющих сплайн данных, включая значения допусков.
  • "Замкнуть". Замыкание разомкнутого сплайна со сглаживанием в точке соединения.
  • Перенести. Изменение положения определяющей точки.
  • "Уточнить". Изменение формы сплайна добавлением управляющих точек и изменением их весовых коэффициентов, а также повышением порядка сплайна.
  • "Обратно". Изменение направление сплайна на противоположное.

Кроме того, разрешается изменение допуска сплайна. Допуск задает максимально допустимое расстояние от реального сплайна до любой из определяющих точек. Чем меньше значение допуска, тем сплайн ближе к определяющим точкам.

Редактирование сплайнов с помощью ручек

Если системная переменная GRIPS имеет значение 1, то ручки размещаются на определяющих точках выбранного сплайна. С их помощью можно изменять форму и положение сплайна.

Выполнение некоторых операций приводит к удалению определяющих точек. В этих случаях ручки располагаются в управляющих точках сплайна. К таким операциям относятся обрезка сплайна, перемещение контрольных точек и удаление определяющих данных. Если включена управляющая ломаная сплайна (системная переменная SPLFRAME равна 1), то ручки отображаются как на управляющих точках, так и на определяющих точках, если они имеются.

Имеется возможность удалять определяющие точки сплайна, добавлять их для повышения точности и изменять форму сплайна путем перемещения определяющих точек. Сплайны можно замыкать и размыкать, а также изменять направления касательных в начальной и конечной точках. Можно менять местами начало и конец сплайна. Кроме того, разрешается изменение допуска сплайна. Допуск задает максимально допустимое расстояние от реального сплайна до любой из определяющих точек. Чем меньше значение допуска, тем сплайн ближе к определяющим точкам.

Исправление формы сплайна

Повысить точность сплайна можно, увеличив количество управляющих точек в какой-либо из его частей, или изменив весовые коэффициенты некоторых из управляющих точек. Повышение весового коэффициента управляющей точки заставляет сплайн проходить ближе к ней. Еще один способ увеличения точности сплайна - повышение его порядка. Порядком сплайна называется число, на единицу большее степени полинома, описывающего сплайн. Например, кубический сплайн имеет порядок 4. Чем выше порядок сплайна, тем больше у него управляющих точек.

Рассмотрим следующий случай. Пусть построенный сплайн представляет на чертеже географическую горизонталь. Ручки включены, и для увеличения точности требуется переместить четвертую определяющую точку. При выборе сплайна в управляющих точках появляются ручки. Если сплайн создан путем задания совокупности определяющих точек и положения этих точек не удалены из определения опцией "Очистить" команды РЕДСПЛАЙН, при выборе опции "Определяющие" ручки появляются в определяющих, а не в управляющих, точках выбранного сплайна.

См. также

    • Разрыв и соединение объектов


Для редактирования сплайна (Процедура)

Редактирование и объединение полилиний
На уровень вверх ..
Редактирование мультилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование сплайнов >
Редактирование сплайнов
Понятие Процедура Краткий справочник

Для редактирования сплайна

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Редактировать сплайн".В командной строке введите "редсплайн".
  2. Выберите сплайн для редактирования.
  3. Выполните одно или несколько действий из перечисленных:
    • Введите о (Определяющие) для редактирования определяющих сплайн данных.
    • Введите з (Замкнуть) для замыкания разомкнутого сплайна и сглаживания кривой в точке соединения.
    • Введите п (Перенести) для переноса определяющей точки в новое положение.
    • Введите и (Исправить) для изменения формы сплайна путем добавления управляющих точек и изменения их весовых коэффициентов, а также повышением порядка сплайна.
    • Введите об (ОБратно) для изменения направления сплайна на противоположное.
    • Введите от (ОТменить) для отмены последней операции редактирования.
  4. Введите х (выХод) для завершения команды.
Панель:Редактирование-2
Ввод команды: РЕДСПЛАЙН


Редактирование сплайнов (Краткий справочник)

Редактирование и объединение полилиний
Редактирование сплайнов
Изменение спиралей
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование сплайнов >
Редактирование сплайнов
Понятие Процедура Краткий справочник

Команды

СОЕДИНИТЬ

Соединение объектов для формирования одного целого объекта

РЕДСПЛАЙН

Редактирование сплайнов или сглаженных сплайнами полилиний

Системные переменные

SPLFRAME

Управление отображением сплайнов и сглаженных сплайнами полилиний

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение спиралей (Понятие)

Редактирование сплайнов
Редактирование сложных объектов
Редактирование мультилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов >
Изменение спиралей
Понятие Краткий справочник

Для изменения формы и размера спирали можно использовать как ручки, так и палитру "Свойства".

Показать: Создать и изменить спираль

Для запуска анимации нажмите на стрелку "Показать". Более подробную информацию о создании спиралей см. в разделе Построение спиралей.

Ручки можно использовать для изменения следующих параметров спирали:

  • Начальная точка
  • Радиус в основании
  • Радиус верхнего основания
  • Высота
  • Расположения

Если для изменения радиуса спирали в основании используется ручка, то радиус верхнего основания автоматически изменяется с соблюдением заданной пропорции. Для изменения радиуса в основания независимо от радиуса верхнего основания используется палитра "Свойства".

С помощью палитры "Свойства" можно изменять и другие свойства спирали, например:

  • Число витков (Витки)
  • Высота витка
  • Направление кручения - по часовой стрелке (ПОЧС) или против часовой стрелки (ПРЧС).

С помощью свойства "Наложение зависимости" можно задать зависимости для таких свойств спирали как "Высота", "Число витков" и "Высота витка". "Наложение зависимости" влияет на изменение таких свойств спирали как "Высота", "Число витков" и "Высота витка" при изменении их в панели "Свойства" или с помощью ручек для редактирования. Приведенная ниже таблица показывает изменения спирали в зависимости от того, на какое свойство налагается зависимость.

Свойство, на которое наложена зависимость | Свойство, подлежащее изменению | Изменяемые свойства спирали
 |  | Высота | Витки | Высота витка
Высота | Высота | Изменяется | Не изменяется | Изменяется
 | Витки | Не изменяется | Изменяется | Изменяется
 | Высота витка | Не изменяется | Изменяется | Изменяется
Витки | Высота | Изменяется | Не изменяется | Изменяется
 | Витки | Не изменяется | Изменяется | Изменяется
 | Высота витка | Изменяется | Не изменяется | Изменяется
Высота витка | Высота | Изменяется | Изменяется | Не изменяется
 | Витки | Изменяется | Изменяется | Не изменяется
 | Высота витка | Не изменяется | Изменяется | Изменяется
См. также

    • Построение спиралей


Изменение спиралей (Краткий справочник)

Редактирование сплайнов
Изменение спиралей
Редактирование мультилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Изменение спиралей >
Изменение спиралей
Понятие Краткий справочник

Команды

СПИРАЛЬ

Создание 2D или 3D спирали

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование мультилиний (Понятие)

Изменение спиралей
Редактирование сложных объектов
Работа с 3D моделями
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов >
Редактирование мультилиний
Понятие Процедура Краткий справочник

Многострочные объекты состоят из параллельных линий (от 1 до 16), называемых элементами. Для изменения мультилиний можно использовать обычные команды редактирования, команду редактирования мультилинии и стили мультилинии.

Специальные функции редактирования мультилинии доступны с помощью команды МЛРЕД, включая следующие.

  • Добавление или удаление вершины
  • Контролирование видимости стыков угла
  • Контролирование стиля пересечения с другими мультилиниями
  • Создание или удаление разрывов в многострочном объекте

Добавление и удаление вершин мультилиний

Имеется возможность добавления к мультилинии новой вершины или удаления имеющейся.

Редактирование пересечений мультилиний

Имеется возможность отредактировать способ пересечения мультилиний. Пересечения могут быть крестообразными или T-образными; крестообразные или T-образные подразделяется на закрытые, открытые и сплошные пересечения.

Редактирование стилей мультилиний

Можно использовать команду МЛСТИЛЬ для редактирования стилей мультилиний, т.е. изменить свойства элементов, а также вид торцов и цвет закрашивания для последующих мультилиний.

Стили мультилиний определяют количество элементов в мультилинии, цвет, тип линий, толщину линии и смещение каждого элемента от исходного положения. Кроме того, допускается изменение вида соединяющих отрезков, торцевых ограничителей и фона заполнения.

Стили мультилиний имеют следующие ограничения.

  • Редактирование свойств элементов и мультилиний невозможно для стиля СТАНДАРТ и стилей, используемых в чертеже.
  • Редактировать стиль мультилинии необходимо до того, как он будет использован для создания мультилинии в текущем чертеже.
ПримечаниеЕсли не сохранить созданный с помощью команды МЛСТИЛЬ стиль мультилинии, то выбор другого стиля или переход к созданию нового приведет к потере всех свойств команды МЛСТИЛЬ Поэтому после определения свойств стиля мультилинии рекомендуется сразу сохранить его в MLN-файле.

Использование команд редактирования для мультилиний

Можно использовать большинство обычных команд редактирования для мультилиний кроме

  • РАЗОРВАТЬ
  • ФАСКА
  • СОПРЯЖЕНИЕ
  • УВЕЛИЧИТЬ
  • СМЕЩЕНИЕ

Для выполнения этих операций сначала использовать команду РАСЧЛЕНИТЬ для перемещения многострочного объекта с объектом отдельной линии.

Примечание При обрезке или удлинении многострочного объекта форму конца мультилинии определяет только первый объект контура. Сложный контур не может находиться на конечной точки мультилинии.
См. также

    • Построение объектов мультилиний


Редактирование мультилиний (Процедура)

Редактирование сплайнов
На уровень вверх ..
Редактирование мультилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование мультилиний >
Редактирование мультилиний
Понятие Процедура Краткий справочник

Для удаления вершины мультилинии

Для задания закрытого крестообразного типа пересечения

Редактирование стиля мультилинии


Для удаления вершины мультилинии (Процедура)

Редактирование мультилиний
На уровень вверх ..
Редактирование мультилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование мультилиний >
Редактирование мультилиний
Понятие Процедура Краткий справочник

Для удаления вершины мультилинии

  1. Выберите меню Редактирование [image] Объект [image] Мультилиния.В командной строке введите "млред".
  2. В диалоговом окне "Редактирование мультилинии" выберите пиктограмму "Удалить вершину".
  3. Укажите на чертеже вершину для удаления. Нажмите ENTER.
Ввод команды: МЛРЕД


Для задания закрытого крестообразного типа пересечения (Процедура)

Редактирование мультилиний
На уровень вверх ..
Редактирование мультилиний
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование мультилиний >
Редактирование мультилиний
Понятие Процедура Краткий справочник

Для задания закрытого крестообразного типа пересечения

  1. Выберите меню Редактирование [image] Объект [image] Мультилиния.В командной строке введите "млред".
  2. В диалоговом окне "Редактирование мультилинии" выберите пиктограмму "Закрытый крест".
  3. Выберите верхнюю мультилинию.
  4. Выберите нижнюю мультилинию.

    Тип пересечения изменяется. После этого можно либо продолжить выбор пересечений мультилиний, либо завершить команду нажатием ENTER . Для повторного вызова диалогового окна "Редактирование мультилинии" нужно вновь нажать ENTER.


Редактирование стиля мультилинии (Процедура)

Редактирование мультилиний
На уровень вверх ..
Создание 3D тел и поверхностей
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование мультилиний >
Редактирование мультилиний
Понятие Процедура Краткий справочник

Редактирование стиля мультилинии

  1. Выберите меню Формат [image] Стиль мультилиний.В командной строке введите "млстиль".
  2. В диалоговом окне "Стили мультилиний" выберите имя стиля из списка. Нажмите кнопку "Редактирование".
  3. Выберите "Свойства элементов".
  4. В диалоговом окне "Редактирование стилей мультилиний" изменить необходимые параметры.
  5. Нажмите "ОК".
  6. В диалоговом окне "Стили мультилиний" нажать кнопку "Сохранить" для сохранения сделанных изменений в MLN-файле.
  7. Нажмите "ОК".
Ввод команды: МЛСТИЛЬ


Редактирование мультилиний (Краткий справочник)

Изменение спиралей
Редактирование мультилиний
Обзор 3D моделирования
Создание и редактирование объектов > Методы редактирования > Редактирование сложных объектов > Редактирование мультилиний >
Редактирование мультилиний
Понятие Процедура Краткий справочник

Команды

МЛРЕД

Редактирование пересечения мультилиний, разрывов и вершин

МЛСТИЛЬ

Создание, изменение стилей мультилиний и управление ими

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с 3D моделями

Редактирование мультилиний
Создание 3D моделей
Работа с 3D моделями

Темы в этом разделе

  • Создание 3D моделей

    Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов. В дальнейшем эти тела и поверхность можно комбинировать для получения моделей тел. 3D объекты могут быть также представлены моделированными поверхностями (с 3D высотой), в виде каркасной модели или в виде сетчатой модели поверхности.

  • Изменение 3D тел и поверхностей

    После создания модели тела можно вручную изменять форму его отображения, вручную управляя телами и поверхностями множеством способов, включая нажатие и перетаскивание ручек, использование блоков захвата и изменение свойств объектов с помощью палитры свойств.

  • Построение сечений и 2D чертежей из 3D моделей

    Предусмотрена возможность построения поперечного сечения 3D тела с помощью пересечения плоскости и твердотельных объектов для создания области. Можно также использовать режущую плоскость, называемую объект-сечение, которая позволяет рассматривать в режиме реального времени виды поперечных сечений в 3D модели. Виды сечений можно зафиксировать в качестве плоскостных представлений.


Создание 3D моделей

Работа с 3D моделями
Работа с 3D моделями
Обзор 3D моделирования
Работа с 3D моделями >
Создание 3D моделей

Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов. В дальнейшем эти тела и поверхность можно комбинировать для получения моделей тел. 3D объекты могут быть также представлены моделированными поверхностями (с 3D высотой), в виде каркасной модели или в виде сетчатой модели поверхности.

Темы в этом разделе

  • Обзор 3D моделирования
  • Создание 3D тел и поверхностей

    Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов.

  • Проверка взаимодействий в твердотельной модели

    Команда ВЗАИМОД позволяет проверить взаимодействия (областей пересечения или перекрытия 3D тел) внутри твердотельной модели путем сравнения двух наборов объектов или попарного сравнения всех тел.

  • Создание сетей

    Имеется возможность создания многоугольных сетчатых форм. Так как грани сети являются плоскими, представление криволинейных поверхностей производится путем их аппроксимации.

  • Создание каркасных моделей

    Каркасная модель представляет собой скелетное описание 3D объекта, состоящее из отрезков и кривых.

  • Задание трехмерной высоты объектов

    Задание высоты объектов позволяет моделировать объем.


Обзор 3D моделирования (Понятие)

Создание 3D моделей
Создание 3D моделей
Создание 3D тел и поверхностей
Работа с 3D моделями > Создание 3D моделей >
Обзор 3D моделирования
Понятие Краткий справочник

Применяя 3D моделирование при работе над проектом, можно создавать модели тел, каркасные и сетчатые модели. Использование 3D моделирования дает несколько преимуществ. Имеется возможность:

  • Рассматривать модели из любой точки.
  • Использовать автоматическую генерацию основных и дополнительных 2D видов.
  • Создавать сечения и 2D чертежи.
  • Подавлять скрытые линии и добиваться реалистичного тонирования.
  • Проверять взаимодействия.
  • Добавлять источники света.
  • Создавать реалистичное тонирование.
  • Перемещаться по модели.
  • Использовать модель для создания анимации.
  • Выполнять инженерный анализ.
  • Извлекать характеристики, необходимые для производства.

Моделирование тела

При моделировании твердых тел в качестве строительных блоков для модели используются тела и поверхности.

Твердотельный объект, или тело, представляет собой изображение объекта, хранящее, помимо всего прочего, информацию о своих объемных свойствах. Следовательно, тела наиболее полно из всех типов 3D моделей отражают моделируемые объекты. Кроме того, тела, несмотря на их кажущуюся сложность, легче строить и редактировать, чем каркасные модели и сети.

ПримечаниеИногда при работе с 3D телами отображаются сообщения, в которых упоминается ShapeManager. ShapeManager® представляет собой технологию Autodesk, обеспечивающую возможности моделирования 3D тел в AutoCAD и других продуктах.
См. также

    • 3D координаты

    • Задание плоскостей видов чертежа в 3D (ПСК)

    • Использование динамической ПСК с моделями тел


Обзор 3D моделирования (Краткий справочник)

Редактирование мультилиний
Обзор 3D моделирования
Обзор создания 3D тел и поверхностей
Работа с 3D моделями > Создание 3D моделей > Обзор 3D моделирования >
Обзор 3D моделирования
Понятие Краткий справочник

Команды

ЯЩИК

Создание 3D твердотельного параллелепипеда

КОНУС

Создание 3D твердотельного конуса

ЦИЛИНДР

Создание 3D твердотельного цилиндра

ВЫДАВИТЬ

Создание 3D тела или поверхности с помощью выдавливания 2D объекта

ПОСЕЧЕНИЯМ

Создание 3D тела или поверхности в пространстве между несколькими поперечными сечениями

ПОЛИТЕЛО

Создание 3D политела

ПИРАМИДА

Создание 3D тела-пирамиды

ВРАЩАТЬ

Создание 3D тела путем вращения 2D объекта вокруг оси

ШАР

Создание 3D тела - шара

СДВИГ

Создание 3D тела или поверхности посредством сдвига 2D объекта вдоль траектории

ТОР

Создание кольцеобразного 3D тела

КЛИН

Создание 3D твердотельного клина

Системные переменные

DELOBJ
PSOLWIDTH

Управление значением ширины по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО

PSOLHEIGHT

Управление значением высоты по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО

Утилиты

Нет

Ключевые слова для команд

Нет


Создание 3D тел и поверхностей

Обзор 3D моделирования
Создание 3D моделей
Обзор создания 3D тел и поверхностей
Работа с 3D моделями > Создание 3D моделей >
Создание 3D тел и поверхностей
Понятие Процедура

Возможно создание 3D тел и поверхностей с самого начала или на основе имеющихся объектов.

Темы в этом разделе

  • Обзор создания 3D тел и поверхностей
  • Создание 3D твердотельных примитивов

    Предусмотрена возможность создания базовых твердотельных форм в виде ящика, конуса, цилиндра, шара, тора, клина и пирамиды. Эти формы называют твердотельными примитивами.

  • Создание политела

    Политело вычерчивается точно так же, как и полилиния. По умолчанию у политела всегда прямоугольные контуры. Предусмотрено задание высоты и ширины политела. Для построения в модели стен служит команда ПОЛИТЕЛО.

  • Создание тел и поверхностей на основе отрезков и кривых

    Тела и поверхности можно строить на основе существующих отрезков и кривых. Эти объекты можно использовать для определения как контура, так и траектории для тела или поверхности.

  • Создание тел и поверхностей на основе объектов

    Поверхности можно создавать на основе существующих в чертеже объектов.

  • Создание тел на основе поверхностей

    3D тело можно построить на основе поверхности любого типа путем ее утолщения.

  • Создание составных тел

    Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ, ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА).

  • Создание тел путем разрезания

    Новые тела могут быть получены разрезанием существующих тел. Существует ряд способов определения режущей плоскости, включая задание точек или выбор поверхности или плоского объекта.


Создание 3D тел и поверхностей (Процедура)

Редактирование мультилиний
Создание 3D тел и поверхностей
Создание 3D твердотельных примитивов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание 3D тел и поверхностей
Понятие Процедура

Вычерчивание политела

Создание политела на основе существующего объекта

Преобразование одного или нескольких объектов в поверхности

Создание плоской поверхности на основе существующего объекта

Создание плоской поверхности посредством задания углов поверхности

Преобразование объектов, имеющих высоту, в тела выдавливания

Преобразование одной или нескольких поверхностей в тела

Объединение тел

Вычитание тел друг из друга

Создание тела путем пересечения двух или нескольких тел

Разрезание тел

Разрезание тел с помощью плоского объекта

Разрезание тел с помощью поверхности


Обзор создания 3D тел и поверхностей (Понятие)

Создание 3D тел и поверхностей
Создание 3D тел и поверхностей
Создание 3D твердотельных примитивов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Обзор создания 3D тел и поверхностей
Понятие Краткий справочник

Предусмотрена возможность создания базовых 3D форм (твердотельных примитивов): ящиков, конусов, цилиндров, шаров, клиньев, пирамид и торов (колец). Из этих форм путем их объединения, вычитания и пересечения строятся более сложные пространственные тела.

Можно также создавать 3D тела и поверхности на основе существующих объектов с помощью любого из следующих методов:

  • Выдавливание объектов.
  • Сдвиг объектов вдоль траектории.
  • Вращение объектов вокруг оси.
  • Сечение с помощью набора кривых.
  • Разрезание тела.
  • Преобразование плоских объектов, имеющих толщину, в тела и поверхности

Тела и поверхности отображаются в таком визуальном стиле, который применим для соответствующего видового экрана.

Для тел предусмотрена возможность анализировать свойства, присущие массе (объем, момент инерции, центр масс и т.п.). Данные о теле могут экспортироваться в такие приложения, как системы числового программного управления (ЧПУ) или анализа методом конечных элементов (МКЭ). Посредством расчленения тела его можно разделить на области, элементарные тела, поверхности и каркасные объекты.

Плотность линий кривизны, используемых для визуализации криволинейных элементов модели, определяется системной переменной ISOLINES. Системная переменная FACETRES задает степень сглаживания тонированных объектов с подавленными скрытыми линиями.

По умолчанию в 3D телах журнале регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела. Дополнительные сведения о параметрах журнала для тел и поверхностей см. в разделе Отображение исходных форм составных тел.


Обзор создания 3D тел и поверхностей (Краткий справочник)

Обзор 3D моделирования
Обзор создания 3D тел и поверхностей
Создание ящиков
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Обзор создания 3D тел и поверхностей >
Обзор создания 3D тел и поверхностей
Понятие Краткий справочник

Команды

ЯЩИК

Создание 3D твердотельного параллелепипеда

КОНУС

Создание 3D твердотельного конуса

ПРЕОБРВТЕЛО

Преобразование полилиний и окружностей, для которых задана высота, в 3D тела

ПРЕОБРВПВРХ

Преобразование объектов в поверхности

ЦИЛИНДР

Создание 3D твердотельного цилиндра

ВЫДАВИТЬ

Создание 3D тела или поверхности с помощью выдавливания 2D объекта

ПЕРЕСЕЧЕНИЕ

Создание 3D тела или 2D области из выбранных перекрывающихся тел или областей

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

ПОСЕЧЕНИЯМ

Создание 3D тела или поверхности в пространстве между несколькими поперечными сечениями

ПИРАМИДА

Создание 3D тела-пирамиды

ВРАЩАТЬ

Создание 3D тела путем вращения 2D объекта вокруг оси

РАЗРЕЗ

Разрезание тел плоскостью или поверхностью

ВЫЧИТАНИЕ

Создание области путем вычитания выбранных 3D тел или 2D областей

СДВИГ

Создание 3D тела или поверхности посредством сдвига 2D объекта вдоль траектории

ТОР

Создание кольцеобразного 3D тела

ОБЪЕДИНЕНИЕ

Создание области путем объединения выбранных 3D тел или 2D областей

ВИЗСТИЛИ

Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану

КЛИН

Создание 3D твердотельного клина

Системные переменные

FACETRES

Регулировка гладкости раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями

ISOLINES

Количество линий контура для изображения поверхностей объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Создание 3D твердотельных примитивов

Обзор создания 3D тел и поверхностей
Создание 3D тел и поверхностей
Создание ящиков
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание 3D твердотельных примитивов
Понятие Процедура

Предусмотрена возможность создания базовых твердотельных форм в виде ящика, конуса, цилиндра, шара, тора, клина и пирамиды. Эти формы называют твердотельными примитивами.

Темы в этом разделе

  • Создание ящиков

    Имеется возможность построить ящик. Основание ящика всегда вычерчивается параллельно плоскости XY текущей ПСК (плоскость построений).

  • Создание клиньев

    Имеется возможность построить клин.

  • Создание конусов

    Можно построить конус с круговым или эллиптическим основанием, суживающимся в точку. Также можно построить усеченный конус, который суживается в круговую или эллиптическую грань, параллельную основанию конуса.

  • Создание цилиндров

    Можно построить цилиндр с круговым или эллиптическим основанием.

  • Создание шаров

    Имеется возможность построить шар.

  • Создание пирамиды

    Имеется возможность построить пирамиду. Для пирамиды можно определить от 3 до 32 сторон.

  • Создание торов

    Для построения тела в виде кольца, напоминающего по форме камеру автомобильной шины, служит команда ТОР.


Создание 3D твердотельных примитивов (Процедура)

Создание 3D тел и поверхностей
На уровень вверх ..
Создание ящиков
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание 3D твердотельных примитивов
Понятие Процедура

Для создания ящика по двум точкам и высоте

Для создания ящика по длине, ширине и высоте

Для создания ящика по центральной точке, углу основания и высоте

Для создания куба

Для создания клина по двум точкам и высоте

Для создания клина по длине, ширине и высоте

Для создания клина по центральной точке, углу основания и высоте

Для создания клина с одинаковыми длиной, шириной и высотой

Для построения конуса с круговым основанием

Для построения конуса с эллиптическим основанием

Создание усеченного конуса

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси

Создание цилиндра с круговым основанием

Создание цилиндра с эллиптическим основанием

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси

Создание шаров

Создание шара, определяемого тремя точками

Создание пирамиды

Создание усеченной пирамиды

Создание тора


Создание ящиков (Понятие)

Создание 3D твердотельных примитивов
Создание 3D твердотельных примитивов
Создание клиньев
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание ящиков
Понятие Процедура Краткий справочник

Имеется возможность построить ящик. Основание ящика всегда вычерчивается параллельно плоскости XY текущей ПСК (плоскость построений).

Для создания ящика с ребрами одинаковой длины можно воспользоваться параметром "Куб" команды ЯЩИК.

Если при построении ящика используется параметр "Куб" или "Длина", то при задании длины можно задать также угол поворота ящика в плоскости XY.

С помощью параметра "Центральная точка" можно построить ящик, задав конкретную центральную точку.


Создание ящиков (Процедура)

Создание 3D твердотельных примитивов
На уровень вверх ..
Создание ящиков
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание ящиков >
Создание ящиков
Понятие Процедура Краткий справочник

Для создания ящика по двум точкам и высоте

Для создания ящика по длине, ширине и высоте

Для создания ящика по центральной точке, углу основания и высоте

Для создания куба


Для создания ящика по двум точкам и высоте (Процедура)

Создание ящиков
На уровень вверх ..
Создание ящиков
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание ящиков >
Создание ящиков
Понятие Процедура Краткий справочник

Для создания ящика по двум точкам и высоте

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Ящик".В командной строке введите "ящик".
  2. Укажите первый угол основания.
  3. Укажите противоположный угол основания.
  4. Задайте высоту.
Панель:Моделирование
Ввод команды: ЯЩИК


Для создания ящика по длине, ширине и высоте (Процедура)

Создание ящиков
На уровень вверх ..
Создание ящиков
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание ящиков >
Создание ящиков
Понятие Процедура Краткий справочник

Для создания ящика по длине, ширине и высоте

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Ящик".В командной строке введите "ящик".
  2. Укажите первый угол основания.
  3. Выберите опцию "Длина" и укажите длину основания.
  4. Укажите ширину основания.
  5. Задайте высоту.
Панель:Моделирование
Ввод команды: ЯЩИК


Для создания ящика по центральной точке, углу основания и высоте (Процедура)

Создание ящиков
На уровень вверх ..
Создание ящиков
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание ящиков >
Создание ящиков
Понятие Процедура Краткий справочник

Для создания ящика по центральной точке, углу основания и высоте

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Ящик".В командной строке введите "ящик".
  2. Выберите опцию "Центр" и укажите центральную точку основания.
  3. Задайте от центральной точки один из углов основания с тем, чтобы вычислить длину и ширину или, если так будет удобнее, воспользуйтесь опцией "Длина" и укажите длину, а затем ширину, измеряемые от центральной точки основания.
  4. Задайте высоту.
Панель:Моделирование
Ввод команды: ЯЩИК


Для создания куба (Процедура)

Создание ящиков
На уровень вверх ..
Создание клиньев
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание ящиков >
Создание ящиков
Понятие Процедура Краткий справочник

Для создания куба

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Ящик".В командной строке введите "ящик".
  2. Задайте первый угол или выберите опцию "Центр" и укажите центральную точку основания.
  3. Выберите опцию "Куб" и укажите длину куба и угол поворота. При расчете размеров куба указанная длина будет использоваться в качестве ширины и высоты.
Панель:Моделирование
Ввод команды: ЯЩИК


Создание ящиков (Краткий справочник)

Обзор создания 3D тел и поверхностей
Создание ящиков
Создание клиньев
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание ящиков >
Создание ящиков
Понятие Процедура Краткий справочник

Команды

ЯЩИК

Создание 3D твердотельного параллелепипеда

Системные переменные

DRAGVS

Утилиты

Нет

Ключевые слова для команд

Нет


Создание клиньев (Понятие)

Создание ящиков
Создание 3D твердотельных примитивов
Создание конусов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание клиньев
Понятие Процедура Краткий справочник

Имеется возможность построить клин.

Основание клина вычерчивается параллельно плоскости XY текущей ПСК, а наклонная грань располагается напротив первого указанного угла основания. Высота клина параллельна оси Z.

Параметр "Куб" команды КЛИН служит для построения клина с ребрами одинаковой длины.

Если при построении клина используется параметр "Куб" или "Длина", то при задании длины можно задать также угол поворота клина в плоскости XY.

С помощью параметра "Центральная точка" можно построить клин, задав конкретную центральную точку.


Создание клиньев (Процедура)

Создание ящиков
На уровень вверх ..
Создание клиньев
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание клиньев >
Создание клиньев
Понятие Процедура Краткий справочник

Для создания клина по двум точкам и высоте

Для создания клина по длине, ширине и высоте

Для создания клина по центральной точке, углу основания и высоте

Для создания клина с одинаковыми длиной, шириной и высотой


Для создания клина по двум точкам и высоте (Процедура)

Создание клиньев
На уровень вверх ..
Создание клиньев
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание клиньев >
Создание клиньев
Понятие Процедура Краткий справочник

Для создания клина по двум точкам и высоте

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Клин".В командной строке введите "клин".
  2. Укажите первый угол основания.
  3. Укажите противоположный угол основания.
  4. Задайте высоту клина.
Панель:Моделирование
Ввод команды: КЛИН


Для создания клина по длине, ширине и высоте (Процедура)

Создание клиньев
На уровень вверх ..
Создание клиньев
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание клиньев >
Создание клиньев
Понятие Процедура Краткий справочник

Для создания клина по длине, ширине и высоте

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Клин".В командной строке введите "клин".
  2. Укажите первый угол основания.
  3. Выберите опцию "Длина" и укажите длину основания.
  4. Укажите ширину основания.
  5. Задайте высоту клина.
Панель:Моделирование
Ввод команды: КЛИН


Для создания клина по центральной точке, углу основания и высоте (Процедура)

Создание клиньев
На уровень вверх ..
Создание клиньев
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание клиньев >
Создание клиньев
Понятие Процедура Краткий справочник

Для создания клина по центральной точке, углу основания и высоте

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Клин".В командной строке введите "клин".
  2. Выберите опцию "Центр" и укажите центральную точку основания.
  3. Задайте от центральной точки один из углов основания с тем, чтобы вычислить длину и ширину или, если так будет удобнее, воспользуйтесь опцией "Длина" и укажите длину, а затем ширину, измеряемые от центральной точки основания.
  4. Задайте высоту клина.
Панель:Моделирование
Ввод команды: КЛИН


Для создания клина с одинаковыми длиной, шириной и высотой (Процедура)

Создание клиньев
На уровень вверх ..
Создание конусов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание клиньев >
Создание клиньев
Понятие Процедура Краткий справочник

Для создания клина с одинаковыми длиной, шириной и высотой

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Клин".В командной строке введите "клин".
  2. Задайте первый угол или выберите опцию "Центр" и укажите центральную точку основания.
  3. Выберите опцию "Куб" и укажите длину клина и угол поворота. При расчете размеров клина указанная длина будет использоваться в качестве ширины и высоты.
Панель:Моделирование
Ввод команды: КЛИН


Создание клиньев (Краткий справочник)

Создание ящиков
Создание клиньев
Создание конусов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание клиньев >
Создание клиньев
Понятие Процедура Краткий справочник

Команды

КЛИН

Создание 3D твердотельного клина

Системные переменные

DRAGVS

Утилиты

Нет

Ключевые слова для команд

Нет


Создание конусов (Понятие)

Создание клиньев
Создание 3D твердотельных примитивов
Создание цилиндров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание конусов
Понятие Процедура Краткий справочник

Можно построить конус с круговым или эллиптическим основанием, суживающимся в точку. Также можно построить усеченный конус, который суживается в круговую или эллиптическую грань, параллельную основанию конуса.

Показать: "Создание и изменение конуса"

Для запуска анимации нажмите стрелку "Просмотр". Дополнительные сведения об изменении конусов и других твердотельных примитивов см. в Манипулирование отдельными телами и поверхностями.

По умолчанию основание конуса располагается в плоскости XY текущей ПСК. Высота конуса параллельна оси Z.

Параметр "Конечная точка оси" команды КОНУС служит для определения высоты и ориентации конуса. Конечной точкой является вершина конуса или центр верхней грани, если используется параметр "Радиус верхнего основания". Конечная точка оси может быть расположена в любом месте 3D пространства

Параметр "3Т" (три точки) команды КОНУС позволяет определить основание конуса, задавая три точки, расположенные в любом месте 3D пространства.

Параметр "Радиус верхнего основания" команды КОНУС служит для построения усеченного конуса, суживающегося в эллиптическую или плоскую грань.

Для построения конического тела, определение сторон которого требует задания конкретного угла, начертите 2D круг, а затем с помощью команды ВЫДАВИТЬ и параметра "Угол конуса" задайте сужение к кругу, расположенному под углом к оси Z. Однако, этот метод обеспечивает построение выдавленного тела, а не подлинного примитива твердотельного конуса.


Создание конусов (Процедура)

Создание клиньев
На уровень вверх ..
Создание конусов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание конусов >
Создание конусов
Понятие Процедура Краткий справочник

Для построения конуса с круговым основанием

Для построения конуса с эллиптическим основанием

Создание усеченного конуса

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси


Для построения конуса с круговым основанием (Процедура)

Создание конусов
На уровень вверх ..
Создание конусов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание конусов >
Создание конусов
Понятие Процедура Краткий справочник

Для построения конуса с круговым основанием

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Конус".В командной строке введите "конус".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Задайте высоту конуса.
Панель:Моделирование
Ввод команды: КОНУС


Для построения конуса с эллиптическим основанием (Процедура)

Создание конусов
На уровень вверх ..
Создание конусов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание конусов >
Создание конусов
Понятие Процедура Краткий справочник

Для построения конуса с эллиптическим основанием

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Конус".В командной строке введите "конус".
  2. Введите э (эллиптический).
  3. Задайте конечную точку для первой оси. Это начальная точка первой оси.
  4. Задайте другую конечную точку первой оси. Это конечная точка первой оси.
  5. Задайте конечную точку (длину и угол поворота) второй оси.
  6. Задайте высоту конуса.
Панель:Моделирование
Ввод команды: КОНУС


Создание усеченного конуса (Процедура)

Создание конусов
На уровень вверх ..
Создание конусов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание конусов >
Создание конусов
Понятие Процедура Краткий справочник

Создание усеченного конуса

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Конус".В командной строке введите "конус".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Введите в (радиус верхнего основания).
  5. Задайте радиус верхнего основания.
  6. Задайте высоту конуса.
Панель:Моделирование
Ввод команды: КОНУС


Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси (Процедура)

Создание конусов
На уровень вверх ..
Создание цилиндров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание конусов >
Создание конусов
Понятие Процедура Краткий справочник

Создание конуса с высотой и ориентацией, задаваемыми конечной точкой оси

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Конус".В командной строке введите "конус".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. В командной строке введите a.
  5. Задайте конечную точку оси конуса.

    Эта конечная точка может располагаться в любом месте 3D пространства.

Панель:Моделирование
Ввод команды: КОНУС


Создание конусов (Краткий справочник)

Создание клиньев
Создание конусов
Создание цилиндров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание конусов >
Создание конусов
Понятие Процедура Краткий справочник

Команды

КОНУС

Создание 3D твердотельного конуса

Системные переменные

DRAGVS

Утилиты

Нет

Ключевые слова для команд

Нет


Создание цилиндров (Понятие)

Создание конусов
Создание 3D твердотельных примитивов
Создание шаров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание цилиндров
Понятие Процедура Краткий справочник

Можно построить цилиндр с круговым или эллиптическим основанием.

Для определения высоты и ориентации конуса служит параметр "Конечная точка оси" команды ЦИЛИНДР. Эта конечная точка является центральной точкой верхней грани цилиндра. Конечная точка оси может быть расположена в любом месте 3D пространства.

Параметр "3Т" (три точки) команды ЦИЛИНДР позволяет определить основание цилиндра, задавая три точки, расположенные в любом месте 3D пространства.

Если необходимо построить цилиндрическую форму со специальными деталями, например с пазами вдоль сторон, следует создать двумерные контуры ее основания с помощью команды ПЛИНИЯ и воспользоваться командой ВЫДАВИТЬ для задания ее высоты вдоль оси Z. Однако этот метод обеспечивает построение выдавленного тела, а не подлинного примитива твердотельного цилиндра.


Создание цилиндров (Процедура)

Создание конусов
На уровень вверх ..
Создание цилиндров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание цилиндров >
Создание цилиндров
Понятие Процедура Краткий справочник

Создание цилиндра с круговым основанием

Создание цилиндра с эллиптическим основанием

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси


Создание цилиндра с круговым основанием (Процедура)

Создание цилиндров
На уровень вверх ..
Создание цилиндров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание цилиндров >
Создание цилиндров
Понятие Процедура Краткий справочник

Создание цилиндра с круговым основанием

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Цилиндр".В командной строке введите "цилиндр".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Задайте высоту цилиндра.
Панель:Моделирование
Ввод команды: ЦИЛИНДР


Создание цилиндра с эллиптическим основанием (Процедура)

Создание цилиндров
На уровень вверх ..
Создание цилиндров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание цилиндров >
Создание цилиндров
Понятие Процедура Краткий справочник

Создание цилиндра с эллиптическим основанием

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Цилиндр".В командной строке введите "цилиндр".
  2. Введите э (эллиптический).
  3. Задайте конечную точку для первой оси. Это начальная точка первой оси.
  4. Задайте другую конечную точку первой оси. Это конечная точка первой оси.
  5. Задайте конечную точку (длину и угол поворота) второй оси.
  6. Задайте высоту цилиндра.
Панель:Моделирование
Ввод команды: ЦИЛИНДР


Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси (Процедура)

Создание цилиндров
На уровень вверх ..
Создание шаров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание цилиндров >
Создание цилиндров
Понятие Процедура Краткий справочник

Создание цилиндра с высотой и ориентацией, задаваемыми конечной точкой оси

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Цилиндр".В командной строке введите "цилиндр".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. В командной строке введите a.
  5. Задайте конечную точку оси цилиндра.

    Эта конечная точка может располагаться в любом месте 3D пространства.

Панель:Моделирование
Ввод команды: ЦИЛИНДР


Создание цилиндров (Краткий справочник)

Создание конусов
Создание цилиндров
Создание шаров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание цилиндров >
Создание цилиндров
Понятие Процедура Краткий справочник

Команды

ЦИЛИНДР

Создание 3D твердотельного цилиндра

Системные переменные

DRAGVS

Утилиты

Нет

Ключевые слова для команд

Нет


Создание шаров (Понятие)

Создание цилиндров
Создание 3D твердотельных примитивов
Создание пирамиды
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание шаров
Понятие Процедура Краткий справочник

Имеется возможность построить шар.

При задании центральной точки шар размещается так, чтобы его центральная ось была параллельна оси Z текущей пользовательской системы координат (ПСК).

Для определения шара можно также использовать любой из следующих параметров команды ШАР:

  • 3Т (три точки). Окружность шара определяется заданием трех точек, расположенных в произвольном месте 3D пространства. Три заданные точки определяют также плоскость окружности шара.
  • 2Т (две точки). Окружность шара определяется заданием двух точек, расположенных в произвольном месте 3D пространства. Плоскость окружности шара определяется координатой Z первой точки.
  • ККР (касательная, касательная, радиус). Шар определяется заданием радиуса, являющегося касательной для двух объектов. Указанные точки касания проецируются на текущую ПСК.


Создание шаров (Процедура)

Создание цилиндров
На уровень вверх ..
Создание шаров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание шаров >
Создание шаров
Понятие Процедура Краткий справочник

Создание шаров

Создание шара, определяемого тремя точками


Создание шаров (Процедура)

Создание шаров
На уровень вверх ..
Создание шаров
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание шаров >
Создание шаров
Понятие Процедура Краткий справочник

Создание шаров

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Шар".В командной строке введите "шар".
  2. Укажите центр шара.
  3. Задайте радиус или диаметр шара.
Панель:Моделирование
Ввод команды: ШАР


Создание шара, определяемого тремя точками (Процедура)

Создание шаров
На уровень вверх ..
Создание пирамиды
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание шаров >
Создание шаров
Понятие Процедура Краткий справочник

Создание шара, определяемого тремя точками

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Шар".В командной строке введите "шар".
  2. Введите 3т.
  3. Укажите первую точку.
  4. Укажите вторую точку.
  5. Укажите третью точку.
Панель:Моделирование
Ввод команды: ШАР


Создание шаров (Краткий справочник)

Создание цилиндров
Создание шаров
Создание пирамиды
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание шаров >
Создание шаров
Понятие Процедура Краткий справочник

Команды

ШАР

Создание 3D тела - шара

Системные переменные

DRAGVS

Утилиты

Нет

Ключевые слова для команд

Нет


Создание пирамиды (Понятие)

Создание шаров
Создание 3D твердотельных примитивов
Создание торов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание пирамиды
Понятие Процедура Краткий справочник

Имеется возможность построить пирамиду. Для пирамиды можно определить от 3 до 32 сторон.

Для задания расположения конечной точки оси пирамиды служит параметр "Конечная точка оси" команды ПИРАМИДА. Эта конечная точка является верхней точкой пирамиды или центром верхней грани, если используется параметр "Радиус верхнего основания". Возможно расположение конечной точки оси в любом месте 3D пространства. Конечная точка оси определяет длину пирамиды и ее положение в пространстве.

Параметр "Радиус верхнего основания" служит для построения усеченной пирамиды, суживающейся к плоской грани, имеющей такое же число сторон, как и основание.


Создание пирамиды (Процедура)

Создание шаров
На уровень вверх ..
Создание пирамиды
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание пирамиды >
Создание пирамиды
Понятие Процедура Краткий справочник

Создание пирамиды

Создание усеченной пирамиды


Создание пирамиды (Процедура)

Создание пирамиды
На уровень вверх ..
Создание пирамиды
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание пирамиды >
Создание пирамиды
Понятие Процедура Краткий справочник

Создание пирамиды

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Пирамида".В командной строке введите "пирамида".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Задайте высоту пирамиды.
Панель:Моделирование
Ввод команды: ПИРАМИДА


Создание усеченной пирамиды (Процедура)

Создание пирамиды
На уровень вверх ..
Создание торов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание пирамиды >
Создание пирамиды
Понятие Процедура Краткий справочник

Создание усеченной пирамиды

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Пирамида".В командной строке введите "пирамида".
  2. Задайте центральную точку основания.
  3. Задайте радиус или диаметр основания.
  4. Введите в (радиус верхнего основания).
  5. Задайте радиус верхнего основания.
  6. Задайте высоту пирамиды.
Панель:Моделирование
Ввод команды: ПИРАМИДА


Создание пирамиды (Краткий справочник)

Создание шаров
Создание пирамиды
Создание торов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание пирамиды >
Создание пирамиды
Понятие Процедура Краткий справочник

Команды

ПИРАМИДА

Создание 3D тела-пирамиды

Системные переменные

DRAGVS

Утилиты

Нет

Ключевые слова для команд

Нет


Создание торов (Понятие)

Создание пирамиды
Создание 3D твердотельных примитивов
Создание политела
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов >
Создание торов
Понятие Процедура Краткий справочник

Для построения тела в виде кольца, напоминающего по форме камеру автомобильной шины, служит команда ТОР.

Тор определяется двумя значениями радиусов. Одно значение задает радиус внутреннего прохода, а второе значение определяет расстояние от центра тора до центра внутреннего прохода.

Параметр "3Т" (три точки) команды ТОР служит для определения окружности тора посредством задания трех точек, расположенных в произвольном месте 3D пространства.

Тор вычерчивается параллельно плоскости XY текущей ПСК, рассекаемый ею пополам (это не обязательно выполняется при использовании параметра "3Т" [Три точки] команды ТОР).

Допускается построение самопересекающихся торов, т.е. торов, не имеющих центрального отверстия. Для этого нужно задавать радиус полости большим, чем радиус тора.


Создание тора (Процедура)

Создание пирамиды
На уровень вверх ..
Создание политела
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание торов >
Создание торов
Понятие Процедура Краткий справочник

Создание тора

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Тор".В командной строке введите "тор".
  2. Укажите центр тора.
  3. Задайте радиус или диаметр тора.
  4. Задайте радиус или диаметр полости тора.
Панель:Моделирование
Ввод команды: ТОР


Создание торов (Краткий справочник)

Создание пирамиды
Создание торов
Создание политела
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание 3D твердотельных примитивов > Создание торов >
Создание торов
Понятие Процедура Краткий справочник

Команды

ТОР

Создание кольцеобразного 3D тела

Системные переменные

DRAGVS

Утилиты

Нет

Ключевые слова для команд

Нет


Создание политела (Понятие)

Создание торов
Создание 3D тел и поверхностей
Создание тел и поверхностей на основе отрезков и кривых
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание политела
Понятие Процедура Краткий справочник

Политело вычерчивается точно так же, как и полилиния. По умолчанию у политела всегда прямоугольные контуры. Предусмотрено задание высоты и ширины политела. Для построения в модели стен служит команда ПОЛИТЕЛО.

С помощью команды ПОЛИТЕЛО можно построить политело на основе существующего отрезка, 2D полилинии, дуги или круга.

Показать: "Создание политела на основе полилинии"

Для запуска анимации нажмите стрелку "Просмотр".

Политело может содержать криволинейные сегменты, но контуры всегда являются прямоугольными по умолчанию.

При вычерчивании политела можно воспользоваться параметром "Дуга" для добавления в политело дуговых сегментов. Для замыкания тела между первой и последней указанными точками служит параметр "Замкнуть".

Системная переменная PSOLWIDTH задает ширину политела по умолчанию. Системная переменная PSOLHEIGHT задает высоту политела по умолчанию.

При построении политела на основе существующего объекта системная переменная DELOBJ определяет, должна ли траектория удаляться автоматически после построения политела, или должен выдаваться запрос на удаление объекта.

Политела представляют собой тела деформации (тела, вычерчиваемые посредством использования заданного контура вдоль указанной траектории) и на палитре "Свойства" отображаются как тела деформации.


Создание политела (Процедура)

Создание торов
На уровень вверх ..
Создание политела
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание политела >
Создание политела
Понятие Процедура Краткий справочник

Вычерчивание политела

Создание политела на основе существующего объекта


Вычерчивание политела (Процедура)

Создание политела
На уровень вверх ..
Создание политела
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание политела >
Создание политела
Понятие Процедура Краткий справочник

Вычерчивание политела

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Политело".В командной строке введите "политело".
  2. Укажите начальную точку.
  3. Укажите следующую точку.
  4. Повторите шаг 3 для завершения построения требуемого тела.
  5. Нажмите клавишу ENTER.
Панель:Моделирование
Ввод команды: ПОЛИТЕЛО


Создание политела на основе существующего объекта (Процедура)

Создание политела
На уровень вверх ..
Создание тел и поверхностей на основе отрезков и кривых
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание политела >
Создание политела
Понятие Процедура Краткий справочник

Создание политела на основе существующего объекта

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Политело".В командной строке введите "политело".
  2. Введите о, затем нажмите клавишу ENTER.
  3. Выберите отрезок, 2D полилинию, дугу или круг.

    После завершения построения тела исходный объект может быть удален или сохранен в зависимости от значения системной переменной DELOBJ.

Панель:Моделирование
Ввод команды: ПОЛИТЕЛО


Создание политела (Краткий справочник)

Создание торов
Создание политела
Выдавливание объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание политела >
Создание политела
Понятие Процедура Краткий справочник

Команды

ПОЛИТЕЛО

Создание 3D политела

Системные переменные

DELOBJ
PSOLHEIGHT

Управление значением высоты по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО

PSOLWIDTH

Управление значением ширины по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО

Утилиты

Нет

Ключевые слова для команд

Нет


Создание тел и поверхностей на основе отрезков и кривых

Создание политела
Создание 3D тел и поверхностей
Выдавливание объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание тел и поверхностей на основе отрезков и кривых
Понятие Процедура

Тела и поверхности можно строить на основе существующих отрезков и кривых. Эти объекты можно использовать для определения как контура, так и траектории для тела или поверхности.

Темы в этом разделе

  • Выдавливание объектов

    Тела и поверхности можно получать посредством выдавливания выбранных объектов. Для построения тела или поверхности на основе контура пересечения объекта служит команда ВЫДАВИТЬ.

  • Создание тела или поверхности посредством сдвига

    С помощью команды СДВИГ выполняется построение нового тела или поверхности посредством сдвига разомкнутой или замкнутой плоской кривой (контура) вдоль разомкнутой или замкнутой 2D или 3D траектории.

  • Создание тела или поверхности с помощью сечений

    С помощью команды ПОСЕЧЕНИЯМ выполняется построение 3D тела или поверхности посредством сечения (рисования тела или поверхности) с использованием двух или более кривых поперечного сечения.

  • Создание тела или поверхности с помощью вращения

    Команда ВРАЩАТЬ позволяет построить тело или поверхность с помощью вращения вокруг оси разомкнутых или замкнутых объектов. Вращаемые объекты определяют контур тела или поверхности.


Создание тел и поверхностей на основе отрезков и кривых (Процедура)

Создание политела
На уровень вверх ..
Выдавливание объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых >
Создание тел и поверхностей на основе отрезков и кривых
Понятие Процедура

Выдавливание объекта

Выдавливание объекта вдоль траектории

Создание тела или поверхности посредством сдвига объекта вдоль траектории

Создание тела или поверхности по сечениям с использованием набора поперечных сечений

Вращение объектов вокруг оси


Выдавливание объектов (Понятие)

Создание тел и поверхностей на основе отрезков и кривых
Создание тел и поверхностей на основе отрезков и кривых
Создание тела или поверхности посредством сдвига
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых >
Выдавливание объектов
Понятие Процедура Краткий справочник

Тела и поверхности можно получать посредством выдавливания выбранных объектов. Для построения тела или поверхности на основе контура пересечения объекта служит команда ВЫДАВИТЬ.

Если осуществляется выдавливание замкнутого объекта, получается тело. Если осуществляется выдавливание незамкнутого объекта, получается поверхность.

Операцию выдавливания можно применить к следующим объектам и подобъектам:

  • Отрезки
  • Дуги
  • Эллиптические дуги
  • Двумерные полилинии
  • 2D сплайны
  • Круги
  • эллипсы
  • 3D грани
  • 2D фигуры
  • Полосы
  • Области
  • Плоские поверхности
  • Плоские грани на телах
ПримечаниеДля выбора граней на телах или поверхностях нужно нажать и удерживать клавишу CTRL, а затем выбрать одну или несколько граней.

Невозможно получить операцией выдавливания следующие объекты.

  • Полилинии, имеющие пересекающиеся или самопересекающиеся сегменты
  • Объекты, заключенные в блок

Если заданная полилиния имеет ширину, эта ширина игнорируется, и полилиния выдавливается из центра своей траектории. Если выбранный объект имеет толщину, эта толщина игнорируется.

Для построения тела на основе контура с использованием отрезков или дуг служит параметр "Соединить" команды ПОЛРЕД, чтобы преобразовать их в единый объект полилинии. Перед использованием команды ВЫДАВИТЬ можно также преобразовать объекты в область.

При выдавливании объектов задаются любые из следующих параметров:

  • траектория
  • угол конуса
  • направление

задание траектории для тела выдавливания

Параметр "Траектор" служит для задания объекта в виде траектории для выдавливания. Для построения тела или поверхности контур выбранного объекта выдавливается вдоль выбранной траектории. Наилучшие результаты достигаются, если траектория лежит на или внутри границы выдавливаемого объекта.

Операция выдавливания отличается от операции сдвига. При выдавливании контура вдоль траектории, если она уже не пересекает контур, траектория перемещается к контуру. Затем контур сдвигается вдоль траектории.

ПримечаниеПрименение траектории в сочетании с командой СДВИГ обеспечивает большую степень контроля и достижение лучших результатов.

Тело выдавливания начинается в плоскости исходного контура и заканчивается в плоскости, перпендикулярной траектории в ее конечной точке.

Траекториями могут быть следующие объекты:

  • Отрезки
  • Круги
  • Дуги
  • Эллипсы
  • Эллиптические дуги
  • Двумерные полилинии
  • Трехмерные полилинии
  • Двумерные сплайны
  • Трехмерные сплайны
  • Грани тел
  • Грани поверхностей
  • Спирали
ПримечаниеДля выбора кромок на телах или поверхностях нужно нажать и удерживать клавишу CTRL, а затем выбрать одну или несколько кромок.

Задание угла конуса для тела выдавливания

Конусное выдавливание часто применяется при рисовании объектов с наклонными сторонами; например, литейных форм. Не рекомендуется задавать большие углы сужения. Если угол слишком большой, образующие конуса могут сойтись в одну точку до того, как будет достигнута требуемая глубина выдавливания.

Задание направления для тела выдавливания

Параметр "Направление" позволяет задать длину и направление выдавливания посредством указания двух точек.


Выдавливание объектов (Процедура)

Создание тел и поверхностей на основе отрезков и кривых
На уровень вверх ..
Выдавливание объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Выдавливание объектов >
Выдавливание объектов
Понятие Процедура Краткий справочник

Выдавливание объекта

Выдавливание объекта вдоль траектории


Выдавливание объекта (Процедура)

Выдавливание объектов
На уровень вверх ..
Выдавливание объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Выдавливание объектов >
Выдавливание объектов
Понятие Процедура Краткий справочник

Выдавливание объекта

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Выдавить".В командной строке введите "выдавить".
  2. Выберите объекты для выдавливания, затем нажмите клавишу ENTER.
  3. Задайте высоту.

    По завершении выдавливания исходные объекты удаляются или сохраняются, в зависимости от значения системной переменной DELOBJ.

Панель:Моделирование
Ввод команды: ВЫДАВИТЬ


Выдавливание объекта вдоль траектории (Процедура)

Выдавливание объектов
На уровень вверх ..
Создание тела или поверхности посредством сдвига
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Выдавливание объектов >
Выдавливание объектов
Понятие Процедура Краткий справочник

Выдавливание объекта вдоль траектории

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Выдавить".В командной строке введите "выдавить".
  2. Выберите объекты для выдавливания.
  3. Введите т (траектория), затем нажмите клавишу ENTER.
  4. Выберите объект для использования в качестве траектории.

    По завершении выдавливания исходные объекты удаляются или сохраняются, в зависимости от значения системной переменной DELOBJ.

Панель:Моделирование
Ввод команды: ВЫДАВИТЬ


Выдавливание объектов (Краткий справочник)

Создание политела
Выдавливание объектов
Создание тела или поверхности посредством сдвига
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Выдавливание объектов >
Выдавливание объектов
Понятие Процедура Краткий справочник

Команды

ВЫДАВИТЬ

Создание 3D тела или поверхности с помощью выдавливания 2D объекта

Системные переменные

DELOBJ
SURFU

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности

SURFV

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности

Утилиты

Нет

Ключевые слова для команд

Нет


Создание тела или поверхности посредством сдвига (Понятие)

Выдавливание объектов
Создание тел и поверхностей на основе отрезков и кривых
Создание тела или поверхности с помощью сечений
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых >
Создание тела или поверхности посредством сдвига
Понятие Процедура Краткий справочник

С помощью команды СДВИГ выполняется построение нового тела или поверхности посредством сдвига разомкнутой или замкнутой плоской кривой (контура) вдоль разомкнутой или замкнутой 2D или 3D траектории.

Командой СДВИГ вычерчивается тело или поверхность, имеющая форму с указанным контуром (объект сдвига) на протяжении указанной траектории. Команду СДВИГ можно использовать сразу для нескольких объектов при условии, что все они находятся в одной плоскости.

При сдвиге вдоль траектории замкнутой кривой получается тело.

Показать: "Сдвиг круга вдоль 3D траектории"

Для запуска анимации нажмите стрелку "Просмотр". Дополнительные сведения о построении и изменении спиралей см. в разделах Построение спиралей и Изменение спиралей.

При сдвиге вдоль траектории разомкнутой кривой получается поверхность.

Операция сдвига отличается от операции выдавливания. При выполнении сдвига контура вдоль траектории контур перемещается и устанавливается перпендикулярным к траектории. Затем контур сдвигается вдоль траектории.

СоветДля выполнения сдвига контура, например замкнутой полилинии, вдоль спирали переместите или поверните контур на месте и отключите режим "Выравнивание" в команде СДВИГ. Если при моделировании возникает ошибка, следите за тем, чтобы результирующий объект не пересекал сам себя.

Во время выполнения сдвига объектов их можно закручивать или масштабировать. Также можно использовать палитру "Свойства" для задания следующих свойств контура после его сдвига.

  • Вращение профиля
  • Масштабирование вдоль траектории
  • Закручивание вдоль траектории
  • Крен (естественное вращение)
ПримечаниеИзменение этих свойств на палитре "Свойства" невозможно, если режим "Выравнивание" был отключен при выполнении сдвига контура или если изменение приводит к ошибке моделирования, например самопересечению тела. Предупреждающее сообщение не отображается.

Можно сдвигать несколько объектов одновременно, но все они должны лежать в одной и той же плоскости.

При построении тела или поверхности сдвига можно использовать следующие объекты и траектории:

объекты для сдвига (контуры) | объекты, используемые в качестве траектории сдвига
отрезок | Отрезок
Дуга | Дуга
Эллиптическая дуга | Эллиптическая дуга
2D полилиния | 2D полилиния
2D сплайн | 2D сплайн
Круг | Круг
Эллипс | эллипс
3D грань | 3D сплайн
2D тело | 3D полилиния
Полоса | Спираль
Область | Кромки тел или поверхностей
Плоская поверхность |
Плоские грани тела |
ПримечаниеДля выбора граней и кромок на телах или поверхностях нужно нажать и удерживать клавишу CTRL, а затем выбрать эти подобъекты.

Системная переменная DELOBJ определяет, должны ли контур и траектория удаляться автоматически после построения тела или поверхности, или должен выдаваться запрос на удаление контура и траектории.

См. также

    • Построение спиралей


Создание тела или поверхности посредством сдвига объекта вдоль траектории (Процедура)

Выдавливание объектов
На уровень вверх ..
Создание тела или поверхности с помощью сечений
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Создание тела или поверхности посредством сдвига >
Создание тела или поверхности посредством сдвига
Понятие Процедура Краткий справочник

Создание тела или поверхности посредством сдвига объекта вдоль траектории

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Сдвиг".В командной строке введите "сдвиг".
  2. Выберите объекты для сдвига.
  3. Нажмите клавишу ENTER.
  4. Выберите траекторию сдвига.

    По завершении сдвига исходные объекты удаляются или сохраняются, в зависимости от значения системной переменной DELOBJ.

Панель:Моделирование
Ввод команды: СДВИГ


Создание тела или поверхности посредством сдвига (Краткий справочник)

Выдавливание объектов
Создание тела или поверхности посредством сдвига
Создание тела или поверхности с помощью сечений
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Создание тела или поверхности посредством сдвига >
Создание тела или поверхности посредством сдвига
Понятие Процедура Краткий справочник

Команды

СДВИГ

Создание 3D тела или поверхности посредством сдвига 2D объекта вдоль траектории

Системные переменные

DELOBJ
SURFU

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности

SURFV

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности

Утилиты

Нет

Ключевые слова для команд

Нет


Создание тела или поверхности с помощью сечений (Понятие)

Создание тела или поверхности посредством сдвига
Создание тел и поверхностей на основе отрезков и кривых
Создание тела или поверхности с помощью вращения
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых >
Создание тела или поверхности с помощью сечений
Понятие Процедура Краткий справочник

С помощью команды ПОСЕЧЕНИЯМ выполняется построение 3D тела или поверхности посредством сечения (рисования тела или поверхности) с использованием двух или более кривых поперечного сечения.

Поперечные сечения определяют контур (форму) результирующего тела или поверхности. Поперечные сечения (в общем случае, кривые и линии) могут быть разомкнутыми (например, дуга) или замкнутыми (например, окружность). Команда ПОСЕЧЕНИЯМ изображает тела или поверхности в пространстве между поперечными сечениями. При использовании команды ПОСЕЧЕНИЯМ необходимо задать не менее двух поперечных сечений.

Если при построении используется набор замкнутых кривых поперечных сечений, получается тело.

Показать: "Создание тела по набору поперечных сечений"

Для запуска анимации нажмите стрелку "Просмотр".

Если при построении используется набор разомкнутых кривых поперечных сечений, получается поверхность.

ПримечаниеВсе кривые, используемые при построении по сечениям, должны быть либо разомкнутыми, либо замкнутыми. Не допускается использование набора кривых, содержащего одновременно разомкнутые и замкнутые кривые.

Для операции построения по сечениям можно задать траекторию. Задание траектории обеспечивает более высокую степень контроля формы тела или поверхности, построение которых выполняется по сечениям. Рекомендуется выбирать криволинейную траекторию, начинающуюся на плоскости первого поперечного сечения и заканчивающуюся на плоскости последнего поперечного сечения.

Кроме этого, при построении по сечениям можно задать направляющие. Использование направляющих обеспечивает другой способ контроля формы тела или поверхности, построение которых выполняется по сечениям. Направляющие позволяют контролировать соответствие точек на соответствующих поперечных сечениях для предотвращения нежелательных эффектов, например складок на результирующем теле или поверхности.

Все направляющие должны удовлетворять следующим критериям:

  • Пересекать все поперечные сечения.
  • Начинаться на первом поперечном сечении
  • Завершаться на последнем поперечном сечении

Для построения поверхности или тела по сечениям можно выбрать любое число направляющих.

Если при построении поверхности или тела по сечениям используются только поперечные сечения, контролировать форму поверхности или тела можно также с помощью параметров диалогового окна "Настройка лофтинга".

В следующей таблице приведены объекты, которые можно использовать при построении тела или поверхности по сечениям.

Объекты, используемые в качестве поперечных сечений | Объекты, используемые в качестве траектории для построения по сечениям | Объекты, используемые в качестве направляющих
Отрезок | Отрезок | Отрезок
Дуга | Дуга | Дуга
Эллиптическая дуга | Эллиптическая дуга | Эллиптическая дуга
2D полилиния | Сплайн | 2D сплайн
2D сплайн | Спираль | 3D сплайн
Круг | Круг | 2D полилиния
Эллипс | Эллипс | 3D полилиния
Точки (только первого и последнего поперечного сечения) | 2D полилиния |
Область | 3D полилиния |
плоская грань тела |  |
Плоская поверхность |  |
Плоская 3D грань |  |
2D фигура |  |
полоса |  |

Системная переменная DELOBJ определяет, должны ли поперечные сечения, траектории и направляющие удаляться автоматически после построения тела или поверхности, или должен выдаваться запрос на удаление контуров и траектории.


Создание тела или поверхности по сечениям с использованием набора поперечных сечений (Процедура)

Создание тела или поверхности посредством сдвига
На уровень вверх ..
Создание тела или поверхности с помощью вращения
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Создание тела или поверхности с помощью сечений >
Создание тела или поверхности с помощью сечений
Понятие Процедура Краткий справочник

Создание тела или поверхности по сечениям с использованием набора поперечных сечений

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "По сечениям".В командной строке введите "посечениям".
  2. Выберите поперечные сечения в том порядке, в котором тело или поверхность должны через них проходить.
  3. Нажмите клавишу ENTER.
  4. Выполните одно из следующих действий:
    • Нажмите клавишу ENTER или введите с, чтобы использовать только поперечные сечения.

      Открывается диалоговое окно "Настройка лофтинга". Для контроля формы тела или поверхности воспользуйтесь параметрами этого диалогового окна. Задайте требуемые значения параметров и нажмите кнопку "Предварительный просмотр" для предварительного просмотра поверхности или тела.

      По завершении нажмите кнопку OK.

    • Введите н для выбора направляющих. Выберите направляющие, затем нажмите клавишу ENTER.
    • Введите т для выбора траектории. Выберите траекторию, затем нажмите клавишу ENTER.

    По завершении построения по сечениям исходные объекты могут быть удалены или сохранены, в зависимости от значения системной переменной DELOBJ.

Панель:Моделирование
Ввод команды: ПОСЕЧЕНИЯМ


Создание тела или поверхности с помощью сечений (Краткий справочник)

Создание тела или поверхности посредством сдвига
Создание тела или поверхности с помощью сечений
Создание тела или поверхности с помощью вращения
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Создание тела или поверхности с помощью сечений >
Создание тела или поверхности с помощью сечений
Понятие Процедура Краткий справочник

Команды

ПОСЕЧЕНИЯМ

Создание 3D тела или поверхности в пространстве между несколькими поперечными сечениями

Системные переменные

DELOBJ
LOFTANG1

Угол наклона первого поперечного сечения в операции ПОСЕЧЕНИЯМ

LOFTANG2

Угол наклона последнего поперечного сечения в операции ПОСЕЧЕНИЯМ

LOFTMAG1

Величина угла наклона первого поперечного сечения в операции ПОСЕЧЕНИЯМ

LOFTMAG2

Величина угла наклона последнего поперечного сечения в операции ПОСЕЧЕНИЯМ

LOFTNORMALS

Управление нормалями развернутого объекта в точках их прохода сквозь поперечные сечения

LOFTPARAM

Управление очертанием тел и поверхностей, созданных операцией ПОСЕЧЕНИЯМ

SURFU

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности

SURFV

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности

Утилиты

Нет

Ключевые слова для команд

Нет


Создание тела или поверхности с помощью вращения (Понятие)

Создание тела или поверхности с помощью сечений
Создание тел и поверхностей на основе отрезков и кривых
Создание тел и поверхностей на основе объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых >
Создание тела или поверхности с помощью вращения
Понятие Процедура Краткий справочник

Команда ВРАЩАТЬ позволяет построить тело или поверхность с помощью вращения вокруг оси разомкнутых или замкнутых объектов. Вращаемые объекты определяют контур тела или поверхности.

При вращении замкнутого объекта получается тело. При вращении разомкнутого объекта получается поверхность.

Допускается одновременное вращение нескольких объектов.

При вращении объектов любую из следующих осей можно задать в качестве оси, вокруг которой должны вращаться объекты.

  • Ось, определяемая двумя точками, указанными пользователем
  • X - ось
  • Y - ось
  • Z - ось
  • Ось, определяемая объектом (параметр "Объект")

Применяя команду ВРАЩАТЬ, можно использовать следующие объекты:

вращаемые объекты | объекты, используемые в качестве оси вращения
отрезок | Отрезок
дуга | линейный сегмент полилинии
эллиптическая дуга | линейная кромка поверхности
2D полилиния | линейная кромка тела
2D сплайн |
круг |
эллипс |
3D грани |
2D фигура |
полоса |
область |
плоская поверхность |
плоская грань тела |
ПримечаниеДля выбора граней на телах нужно нажать и удерживать клавишу CTRL, а затем выбрать одну или несколько граней.

Если выполняется построение тела с использованием контура, состоящего из отрезков и дуг, соответствующих полилинии, то перед вызовом команды ВРАЩАТЬ их нужно преобразовать в единый объект полилинии с помощью параметра "Соединить" команды ПОЛРЕД. Если эти объекты не преобразовать в единую полилинию, при их вращении получается поверхность.

Команду ВРАЩАТЬ нельзя применять к объектам, входящим в блок или полилиниям, имеющим пересекающиеся или самопересекающиеся сегменты.


Вращение объектов вокруг оси (Процедура)

Создание тела или поверхности с помощью сечений
На уровень вверх ..
Создание тел и поверхностей на основе объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Создание тела или поверхности с помощью вращения >
Создание тела или поверхности с помощью вращения
Понятие Процедура Краткий справочник

Вращение объектов вокруг оси

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Вращать".В командной строке введите "вращать".
  2. Выберите объекты для вращения.
  3. Укажите начальную и конечную точку оси вращения.

    Точки нужно указывать так, чтобы вращаемый объект находился по одну сторону оси. Положительным направлением оси считается направление от первой точки ко второй.

  4. Задайте угол поворота.
Панель:Моделирование
Ввод команды: ВРАЩАТЬ


Создание тела или поверхности с помощью вращения (Краткий справочник)

Создание тела или поверхности с помощью сечений
Создание тела или поверхности с помощью вращения
Создание тел и поверхностей на основе объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе отрезков и кривых > Создание тела или поверхности с помощью вращения >
Создание тела или поверхности с помощью вращения
Понятие Процедура Краткий справочник

Команды

ВРАЩАТЬ

Создание 3D тела путем вращения 2D объекта вокруг оси

Системные переменные

DELOBJ
SURFU

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности

SURFV

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности

Утилиты

Нет

Ключевые слова для команд

Нет


Создание тел и поверхностей на основе объектов (Понятие)

Создание тела или поверхности с помощью вращения
Создание 3D тел и поверхностей
Создание тел на основе поверхностей
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание тел и поверхностей на основе объектов
Понятие Процедура Краткий справочник

Поверхности можно создавать на основе существующих в чертеже объектов.

Команда ПРЕОБРВПВРХ позволяет преобразовывать в поверхности любой из следующих объектов:

  • 2D фигуры
  • области
  • фигуры
  • разомкнутые полилинии с нулевой шириной, имеющие высоту
  • Отрезки, имеющие высоту
  • Дуги, имеющие высоту
  • плоские 3D грани

С помощью команды РАСЧЛЕНИТЬ можно строить поверхности на основе 3D тел с искривленными гранями, например, на основе цилиндра.

Команда ПЛОСКПОВ используется для построения плоской поверхности. Воспользуйтесь одним из следующих методов:

  • Выберите один или несколько объектов, образующих одну или несколько замкнутых областей.
  • Укажите противоположные углы прямоугольника.

При задании углов поверхности она строится параллельно плоскости построений.

Команда ПРЕОБРВТЕЛО применяется для преобразования следующих объектов в 3D тела выдавливания:

  • широкие полилинии постоянной ширины, имеющие высоту
  • Замкнутые полилинии с нулевой шириной, имеющие высоту
  • Круги, имеющие высоту
ПримечаниеНельзя использовать команду ПРЕОБРВТЕЛО для полилиний, содержащих вертикальные линии с нулевой шириной, или содержащих сегменты разной ширины.

Системная переменная DELOBJ определяет, должны ли выбранные пользователем объекты удаляться автоматически после построения поверхности, или должен выдаваться запрос на удаление объектов.


Создание тел и поверхностей на основе объектов (Процедура)

Создание тела или поверхности с помощью вращения
На уровень вверх ..
Создание тел и поверхностей на основе объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе объектов >
Создание тел и поверхностей на основе объектов
Понятие Процедура Краткий справочник

Преобразование одного или нескольких объектов в поверхности

Создание плоской поверхности на основе существующего объекта

Создание плоской поверхности посредством задания углов поверхности

Преобразование объектов, имеющих высоту, в тела выдавливания


Преобразование одного или нескольких объектов в поверхности (Процедура)

Создание тел и поверхностей на основе объектов
На уровень вверх ..
Создание тел и поверхностей на основе объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе объектов >
Создание тел и поверхностей на основе объектов
Понятие Процедура Краткий справочник

Преобразование одного или нескольких объектов в поверхности

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Преобразовать в поверхность".В командной строке введите ПРЕОБРВПВРХ.
  2. Выберите объекты для преобразования.
  3. Нажмите клавишу ENTER.
Ввод команды: ПРЕОБРВПВРХ


Создание плоской поверхности на основе существующего объекта (Процедура)

Создание тел и поверхностей на основе объектов
На уровень вверх ..
Создание тел и поверхностей на основе объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе объектов >
Создание тел и поверхностей на основе объектов
Понятие Процедура Краткий справочник

Создание плоской поверхности на основе существующего объекта

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Плоская поверхность".В командной строке введите "плоскпов".
  2. Введите o.
  3. Выберите объект.
  4. Нажмите клавишу ENTER.
Панель:Моделирование
Ввод команды: ПЛОСКПОВ


Создание плоской поверхности посредством задания углов поверхности (Процедура)

Создание тел и поверхностей на основе объектов
На уровень вверх ..
Создание тел и поверхностей на основе объектов
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе объектов >
Создание тел и поверхностей на основе объектов
Понятие Процедура Краткий справочник

Создание плоской поверхности посредством задания углов поверхности

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Плоская поверхность".В командной строке введите "плоскпов".
  2. Укажите первый угол поверхности.
  3. Укажите второй угол поверхности.
Панель:Моделирование
Ввод команды: ПЛОСКПОВ


Преобразование объектов, имеющих высоту, в тела выдавливания (Процедура)

Создание тел и поверхностей на основе объектов
На уровень вверх ..
Создание тел на основе поверхностей
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе объектов >
Создание тел и поверхностей на основе объектов
Понятие Процедура Краткий справочник

Преобразование объектов, имеющих высоту, в тела выдавливания

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Преобразовать в тело".В командной строке введитепреобрвтело.
  2. Выберите один или несколько из следующих типов объектов, имеющих высоту.
    • полилинии постоянной ширины
    • замкнутые полилинии нулевой ширины
    • круги
  3. Нажмите клавишу ENTER.
Ввод команды: ПРЕОБРВТЕЛО


Создание тел и поверхностей на основе объектов (Краткий справочник)

Создание тела или поверхности с помощью вращения
Создание тел и поверхностей на основе объектов
Создание тел на основе поверхностей
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел и поверхностей на основе объектов >
Создание тел и поверхностей на основе объектов
Понятие Процедура Краткий справочник

Команды

ПРЕОБРВТЕЛО

Преобразование полилиний и окружностей, для которых задана высота, в 3D тела

ПРЕОБРВПВРХ

Преобразование объектов в поверхности

ПЛОСКПОВ

Создание плоской поверхности

Системные переменные

DELOBJ

Утилиты

Нет

Ключевые слова для команд

Нет


Создание тел на основе поверхностей (Понятие)

Создание тел и поверхностей на основе объектов
Создание 3D тел и поверхностей
Создание составных тел
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание тел на основе поверхностей
Понятие Процедура Краткий справочник

3D тело можно построить на основе поверхности любого типа путем ее утолщения.

Для преобразования поверхностей в тела служит команда ТОЛЩИНА.

Системная переменная DELOBJ определяет, удаляется ли выбранный пользователем объект автоматически после создания поверхности либо пользователю выводится запрос на удаление объекта.


Преобразование одной или нескольких поверхностей в тела (Процедура)

Создание тел и поверхностей на основе объектов
На уровень вверх ..
Создание составных тел
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел на основе поверхностей >
Создание тел на основе поверхностей
Понятие Процедура Краткий справочник

Преобразование одной или нескольких поверхностей в тела

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Придать толщину".В командной строке введите "толщина".
  2. Выберите поверхности для утолщения.
  3. Нажмите клавишу ENTER.
  4. Задайте толщину для тела.
  5. Нажмите клавишу ENTER.
Ввод команды: ТОЛЩИНА


Создание тел на основе поверхностей (Краткий справочник)

Создание тел и поверхностей на основе объектов
Создание тел на основе поверхностей
Создание составных тел
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел на основе поверхностей >
Создание тел на основе поверхностей
Понятие Процедура Краткий справочник

Команды

ТОЛЩИНА

Создание 3D тела посредством утолщения поверхности

Системные переменные

DELOBJ

Утилиты

Нет

Ключевые слова для команд

Нет


Создание составных тел (Понятие)

Создание тел на основе поверхностей
Создание 3D тел и поверхностей
Создание тел путем разрезания
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание составных тел
Понятие Процедура Краткий справочник

Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ, ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА).

По умолчанию для 3D тел в журнале регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела. Дополнительные сведения о параметрах журнала для тел и поверхностей см. в разделе Отображение исходных форм составных тел.

С помощью команды ОБЪЕДИНЕНИЕ можно получить сложный объект, занимающий суммарный объем всех его составляющих.

С помощью команды ВЫЧИТАНИЕ из набора тел удаляются те части объема, которые принадлежат другому набору тел. Например, команду ВЫЧИТАНИЕ можно использовать для получения отверстий в механических деталях путем вычитания цилиндров из объектов.

С помощью команды ПЕРЕСЕЧЕНИЕ можно построить сложное тело, занимающее объем, являющийся общим для нескольких пересекающихся тел. Выполнение команды ПЕРЕСЕЧЕНИЕ приводит к удалению непересекающихся частей и построению сложного тела, состоящего из общего объема.


Создание составных тел (Процедура)

Создание тел на основе поверхностей
На уровень вверх ..
Создание составных тел
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание составных тел >
Создание составных тел
Понятие Процедура Краткий справочник

Объединение тел

Вычитание тел друг из друга

Создание тела путем пересечения двух или нескольких тел


Объединение тел (Процедура)

Создание составных тел
На уровень вверх ..
Создание составных тел
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание составных тел >
Создание составных тел
Понятие Процедура Краткий справочник

Объединение тел

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Объединение".В командной строке введите "объединение".
  2. Выберите объединяемые объекты.
  3. Нажмите клавишу ENTER.
Панель:Редактирование тела
Ввод команды: ОБЪЕДИНЕНИЕ


Вычитание тел друг из друга (Процедура)

Создание составных тел
На уровень вверх ..
Создание составных тел
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание составных тел >
Создание составных тел
Понятие Процедура Краткий справочник

Вычитание тел друг из друга

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Вычесть".В командной строке введите "вычитание".
  2. Выберите объекты, из которых производится вычитание.
  3. Нажмите клавишу ENTER.
  4. Выберите объекты, которые вычитаются.
  5. Нажмите клавишу ENTER.
Панель:Редактирование тела
Ввод команды: ВЫЧИТАНИЕ


Создание тела путем пересечения двух или нескольких тел (Процедура)

Создание составных тел
На уровень вверх ..
Создание тел путем разрезания
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание составных тел >
Создание составных тел
Понятие Процедура Краткий справочник

Создание тела путем пересечения двух или нескольких тел

  1. Выберите меню Редактирование [image] Редактирование тел [image] Пересечение.В командной строке введите "пересечение".
  2. Выберите пересекаемые объекты.
  3. Нажмите клавишу ENTER.
Панель:Редактирование тела
Ввод команды: ПЕРЕСЕЧЕНИЕ


Создание составных тел (Краткий справочник)

Создание тел на основе поверхностей
Создание составных тел
Создание тел путем разрезания
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание составных тел >
Создание составных тел
Понятие Процедура Краткий справочник

Команды

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

ПЕРЕСЕЧЕНИЕ
ВЫЧИТАНИЕ

Создание области путем вычитания выбранных 3D тел или 2D областей

ОБЪЕДИНЕНИЕ

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание тел путем разрезания (Понятие)

Создание составных тел
Создание 3D тел и поверхностей
Проверка взаимодействий в твердотельной модели
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей >
Создание тел путем разрезания
Понятие Процедура Краткий справочник

Новые тела могут быть получены разрезанием существующих тел. Существует ряд способов определения режущей плоскости, включая задание точек или выбор поверхности или плоского объекта.

Применяя команду РАЗРЕЗ для разрезания тела, можно сохранить одну или обе половины разрезанного тела. Разрезанные тела не несут в себе информации об исходных формах, из которых они получены. Разрезанные тела наследуют свойства слоя и цвета исходных тел.

По умолчанию используется метод разрезания, при котором задаются две точки, определяющие режущую плоскость, перпендикулярную к текущей ПСК, после чего выбирается сохраняемая сторона. Режущую плоскость можно определить также, задав три точки, используя поверхность, другой объект, текущий вид, ось Z или плоскость XY, YZ или ZX.

В качестве режущей плоскости можно использовать следующие объекты:

  • поверхности
  • круги
  • эллипсы
  • круговые или эллиптические дуги
  • двумерные сплайны
  • сегменты 2D полилиний
См. также

    • Построение сечений и 2D чертежей из 3D моделей


Создание тел путем разрезания (Процедура)

Создание составных тел
На уровень вверх ..
Создание тел путем разрезания
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел путем разрезания >
Создание тел путем разрезания
Понятие Процедура Краткий справочник

Разрезание тел

Разрезание тел с помощью плоского объекта

Разрезание тел с помощью поверхности


Разрезание тел (Процедура)

Создание тел путем разрезания
На уровень вверх ..
Создание тел путем разрезания
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел путем разрезания >
Создание тел путем разрезания
Понятие Процедура Краткий справочник

Разрезание тел

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Разрез".В командной строке введите "разрез".
  2. Выберите объекты для разрезания.
  3. Нажмите клавишу ENTER.
  4. Укажите две точки для определения режущей плоскости.
  5. Укажите, какая сторона сохраняется, или введите б для сохранения обеих сторон.
Ввод команды: РАЗРЕЗ


Разрезание тел с помощью плоского объекта (Процедура)

Создание тел путем разрезания
На уровень вверх ..
Создание тел путем разрезания
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел путем разрезания >
Создание тел путем разрезания
Понятие Процедура Краткий справочник

Разрезание тел с помощью плоского объекта

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Разрез".В командной строке введите "разрез".
  2. Выберите объекты для разрезания.
  3. Нажмите клавишу ENTER.
  4. В командной строке введите о.
  5. Нажмите клавишу ENTER.
  6. Выберите круг, эллипс, дугу, 2D сплайн или 2D полилинию для использования в качестве режущей плоскости.
  7. Укажите, какая сторона сохраняется, или введите б для сохранения обеих сторон.
Ввод команды: РАЗРЕЗ


Разрезание тел с помощью поверхности (Процедура)

Создание тел путем разрезания
На уровень вверх ..
Проверка взаимодействий в твердотельной модели
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел путем разрезания >
Создание тел путем разрезания
Понятие Процедура Краткий справочник

Разрезание тел с помощью поверхности

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Разрез".В командной строке введите "разрез".
  2. Выберите объекты для разрезания.
  3. Нажмите клавишу ENTER.
  4. В командной строке введите команду р.
  5. Нажмите клавишу ENTER.
  6. Выберите поверхность для использования в качестве режущей плоскости.
  7. Укажите, какая сторона сохраняется, или введите б для сохранения обеих сторон.
Ввод команды: РАЗРЕЗ


Создание тел путем разрезания (Краткий справочник)

Создание составных тел
Создание тел путем разрезания
Проверка взаимодействий в твердотельной модели
Работа с 3D моделями > Создание 3D моделей > Создание 3D тел и поверхностей > Создание тел путем разрезания >
Создание тел путем разрезания
Понятие Процедура Краткий справочник

Команды

РАЗРЕЗ

Разрезание тел плоскостью или поверхностью

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Проверка взаимодействий в твердотельной модели (Понятие)

Создание тел путем разрезания
Создание 3D моделей
Создание сетей
Работа с 3D моделями > Создание 3D моделей >
Проверка взаимодействий в твердотельной модели
Понятие Процедура Краткий справочник

Команда ВЗАИМОД позволяет проверить взаимодействия (областей пересечения или перекрытия 3D тел) внутри твердотельной модели путем сравнения двух наборов объектов или попарного сравнения всех тел.

Команду ВЗАИМОД можно применять также к блокам, содержащим 3D тела, и к телам, вложенным в блоки.

При использовании команды ВЗАИМОД создаются временные тела и выделяются области пересечения тел.

Если задан один набор выбора (один набор объектов), команда ВЗАИМОД определяет области пересечения всех пар тел. Если задано два набора выбора (два набора объектов), команда ВЗАИМОД определяет области пересечения тел из первого набора с телами из второго.

Запустив проверку взаимодействий, можно в диалоговом окне "Проверка взаимодействий" циклически переключаться между объектами взаимодействий и выполнять их масштабирование. Предусмотрена возможность задания удаления при закрытии диалогового окна временных объектов взаимодействий, построенных во время проверки взаимодействий.

Отображение объектов взаимодействий настраивается с помощью параметров диалогового окна "Параметры взаимодействий".


Проверка взаимодействий в твердотельной модели (Процедура)

Создание тел путем разрезания
Проверка взаимодействий в твердотельной модели
Проверка взаимодействий в твердотельной модели
Работа с 3D моделями > Создание 3D моделей > Проверка взаимодействий в твердотельной модели >
Проверка взаимодействий в твердотельной модели
Понятие Процедура Краткий справочник

Проверка взаимодействий в твердотельной модели

Изменение отображения объектов взаимодействия


Проверка взаимодействий в твердотельной модели (Процедура)

Проверка взаимодействий в твердотельной модели
Проверка взаимодействий в твердотельной модели
Проверка взаимодействий в твердотельной модели
Работа с 3D моделями > Создание 3D моделей > Проверка взаимодействий в твердотельной модели >
Проверка взаимодействий в твердотельной модели
Понятие Процедура Краткий справочник

Проверка взаимодействий в твердотельной модели

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Проверка взаимодействий".В командной строке введите "взаимод".
  2. Выберите в модели первый набор объектов.
  3. Нажмите клавишу ENTER.
  4. Выберите в модели второй набор объектов.
  5. Нажмите клавишу ENTER.

    Отображается диалоговое окно "Проверка взаимодействий".

  6. (Дополнительно) В диалоговом окне "Проверка взаимодействий" для циклического переключения между объектами взаимодействия нажимайте кнопки "Следующий" и "Предыдущий".
  7. (Дополнительно) Чтобы объекты взаимодействия не удалялись при закрытии диалогового окна "Проверка взаимодействий", отмените выбор режима "При закрытии удалить созданные объекты взаимодействий".
  8. Нажмите кнопку "Закрыть".

    Объекты взаимодействия удаляются, если выбран режим "При закрытии удалить объекты взаимодействий".

Ввод команды: ВЗАИМОД


Изменение отображения объектов взаимодействия (Процедура)

Проверка взаимодействий в твердотельной модели
Проверка взаимодействий в твердотельной модели
Создание сетей
Работа с 3D моделями > Создание 3D моделей > Проверка взаимодействий в твердотельной модели >
Проверка взаимодействий в твердотельной модели
Понятие Процедура Краткий справочник

Изменение отображения объектов взаимодействия

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Проверка взаимодействий".В командной строке введите "взаимод".
  2. Введите р.
  3. Нажмите клавишу ENTER.
  4. В диалоговом окне "Параметры взаимодействий" измените значение любого параметра.
  5. Нажмите "ОК".
Ввод команды: ВЗАИМОД


Проверка взаимодействий в твердотельной модели (Краткий справочник)

Создание тел путем разрезания
Проверка взаимодействий в твердотельной модели
Создание сетей
Работа с 3D моделями > Создание 3D моделей > Проверка взаимодействий в твердотельной модели >
Проверка взаимодействий в твердотельной модели
Понятие Процедура Краткий справочник

Команды

ВЗАИМОД

Выделение подсветкой накладывающих друг на друга 3D тел

Системные переменные

INTERFERECOLOR

Задание цвета объектов взаимодействия

INTERFEREOBJVS

Задание стиля отображения объектов взаимодействия

INTERFEREVPVS

Задание стиля отображения видового экрана во время проверки пространственных взаимодействий

Утилиты

Нет

Ключевые слова для команд

Нет


Создание сетей (Понятие)

Проверка взаимодействий в твердотельной модели
Создание 3D моделей
Создание каркасных моделей
Работа с 3D моделями > Создание 3D моделей >
Создание сетей
Понятие Процедура Краткий справочник

Имеется возможность создания многоугольных сетчатых форм. Так как грани сети являются плоскими, представление криволинейных поверхностей производится путем их аппроксимации.

Моделирование объектов с помощью сетей применяется в случаях, когда можно игнорировать их физические свойства, такие как масса, объем, центр масс, момент инерции и т.п. (они сохраняются только в твердотельных моделях), но желательно иметь возможность подавления скрытых линий, раскрашивания и тонирования (эти средства неприменимы к каркасным моделям).

Сети применяются также для создания геометрии с необычными образцами сетей, например, 3D топологическая модель горной местности.

Способ отображения сети (каркасная или раскрашенная) определяется визуальным стилем (команда ВИЗСТИЛИ).

Предусмотрено создание нескольких типов сетей.

  • 3D грань. 3DГРАНЬ предназначена для построения плоской сети с тремя или четырьмя сторонами.
  • Сеть соединения. Команда П-СОЕД предназначена для построения полигональной сети в виде линейчатой поверхности между двумя отрезками или кривыми.
  • Сеть сдвига. С помощью команды П-СДВИГ создается полигональная сеть, представляющая собой поверхность сдвига, полученную при выдавливании отрезка или кривой (именуемой криволинейной траекторией) в определенном направлении и на определенное расстояние (именуемое направляющим вектором).
  • Сеть вращения. С помощью команды П-ВРАЩ создается полигональная сеть, аппроксимирующая поверхность вращения путем вращения криволинейной траектории вокруг выбранной оси. Определяющие кривые могут представлять собой отрезки, круги, дуги, эллипсы, эллиптические дуги, полилинии, сплайны, замкнутые полилинии, многоугольники, замкнутые сплайны или кольца.
  • Сеть, определенная кромкой Команда П-КРОМКА строит полигональную сеть, аппроксимирующую участок поверхности Кунса по четырем смыкающимся кромкам. Поверхность Кунса - это бикубическая поверхность, натянутая на четыре смыкающиеся кромки (пространственные кривые).
  • Стандартная 3D сеть. С помощью команды 3D создаются трехмерные сетевые объекты распространенных геометрических форм, включая параллелепипеды, конусы, сферы, торы, клинья и пирамиды.
  • Общие сети. 3DСЕТЬ и ПГРАНЬ позволяют создавать трехмерные сетевые объекты любой формы.

Построение сети

Плотность сети регулирует количество ячеек и задается матрицей с вершинами M и N, подобно сетке, состоящей из рядов и столбцов. Для сети значения M и N определяют соответственно ряд и столбец каждой вершины.

Сети могут быть разомкнутыми и замкнутыми. Сеть будет открыта в заданном направлении, если начальная и конечная кромки сети не соприкасаются, как показано на следующих иллюстрациях.

Существует несколько способов построения сетей.

Создание сети соединения

Сеть, соединяющую два отрезка или кривые, строится с помощью команды П-СОЕД. Для определения кромок сети соединения можно использовать два различных объекта: отрезки, точки, дуги, круги, эллипсы, эллиптические дуги, 2D или 3D полилинии, а также сплайны. Пары объектов, используемые в качестве "границ" сети соединения, должны быть либо разомкнуты, либо замкнуты. Если один из объектов - точка, то второй может быть как разомкнутым, так и замкнутым.

При выполнении команды П-СОЕД для замкнутых кривых можно задавать две произвольные точки. В случае разомкнутых кривых построение сети соединения определяется выбором местоположения заданных точек на кривых.

Создание сети сдвига

Сеть, представляющая общую поверхность сдвига, задаваемую криволинейной траекторией и направляющим вектором, строится командой П-СДВИГ. Криволинейная траектория может представлять собой отрезок, дугу, круг, эллипс, эллиптическую дугу, 2D или 3D полилинию, а также сплайн. Осью вращения может быть отрезок или разомкнутая полилиния (как 2D, так и 3D). Сеть, построенная командой П-СДВИГ, представляет собой набор параллельных многоугольников, идущих вдоль указанной траектории. Как показано на следующих иллюстрациях, исходный объект и направляющий вектор должны существовать на чертеже к моменту вызова команды.

Создание сети вращения

Для построения сети вращения путем вращения контура объекта вокруг оси используется команда П-ВРАЩ. Команда П-ВРАЩ полезна для построения сетей с осевой симметрией.

Контур называется криволинейной траекторией, которая может представлять собой любую комбинацию отрезков, кругов, дуг, эллипсов, эллиптических дуг, полилиний, сплайнов, замкнутых полилиний, многоугольников, замкнутых сплайнов или колец.

Создание сети, определенной кромкой

Сеть в виде участка поверхности Кунса, определяемая четырьмя кромками, строится командой П-КРОМКА. Кромки могут представлять собой дуги, отрезки, полилинии, сплайны или эллиптические дуги; они должны попарно смыкаться в конечных точках. Участок поверхности Кунса это бикубическая (т.е. обладающая кубической кривизной как в направлении M, так и в направлении N) поверхность, натянутая на четыре пространственные кривые.

Создание стандартной трехмерной сети

С помощью команды 3D можно создавать следующие 3D фигуры: ящики, конусы, чаши, купола, сети, пирамиды, сферы, торы (кольца) и клинья.

Для лучшего рассмотрения объектов, создаваемых с помощью команды 3D, следует задать направление просмотра, используя команды 3DОРБИТА, ДВИД и ТЗРЕНИЯ.

На приведенных ниже иллюстрациях цифрами обозначены последовательности точек, задаваемых для построения сети.

Создание сети из четырехугольных ячеек

Команда 3DСЕТЬ позволяет строить полигональные сети, разомкнутые как в направлении M, так и в направлении N (по аналогии с осями X и Y плоскости XY). Замкнуть сеть можно с помощью команды ПОЛРЕД. Для построения несимметричных сетей используется команда 3DСЕТЬ. В большинстве случаев команда 3DСЕТЬ применяется в комбинации с командными (пакетными) файлами AutoCAD или LISP-программами, передающими в нее координаты вершин сети.

Ниже приведен текст командной строки, иллюстрирующий пример создания сети путем ввода пользователем координат всех ее вершин.

Пример:

Команда: 3dсеть

Размер сети в направлении M: 4

Размер сети в направлении N: 3

Вершина (0, 0): 10,1, 3

Вершина (0, 1): 10, 5, 5

Вершина (0, 2): 10,10, 3

Вершина (1, 0): 15,1, 0

Вершина (1, 1): 15, 5, 0

Вершина (1, 2): 15,10, 0

Вершина (2, 0): 20,1, 0

Вершина (2, 1): 20, 5, -1

Вершина (2, 2): 20,10 ,0

Вершина (3, 0): 25,1, 0

Вершина (3, 1): 25, 5, 0

Вершина (3, 2): 25,10, 0

Создание многогранной сети

Полигональные сети строятся при помощи команды ПГРАНЬ. Команда ПГРАНЬ чаще всего используется приложениями, а не напрямую пользователем.

Создание многогранной сети производится аналогично сети из четырехугольных ячеек. Вначале вводятся все вершины сети. Затем производится описание граней путем ввода номеров вершин, образующих каждую грань. В ходе построения сети можно изменять видимость кромок граней, а также устанавливать слои и цвета для их рисования.

Для того чтобы сделать кромку невидимой, перед номером вершины при описании грани ставится знак минус. Например, если нужно сделать невидимой кромку между точками 5 и 7 сети, следует ввести:

грань 3, вершина 3: -7

На рисунке грань 1 определяется вершинами 1, 5, 6 и 2. Грань 2 определяется вершинами 1, 4, 3 и 2. Грань 3 определяется вершинами 1, 4, 7 и 5, а грань 5 определяется вершинами 3, 4, 7 и 8.

Изображение на чертеже невидимых кромок граней определяется системной переменной SPLFRAME. Если ее значение не равно нулю, невидимые кромки становится видимыми и доступны для редактирования. Если же переменная равна нулю, невидимые кромки не отображаются.


Создание сетей (Процедура)

Проверка взаимодействий в твердотельной модели
Создание сетей
Создание сетей
Работа с 3D моделями > Создание 3D моделей > Создание сетей >
Создание сетей
Понятие Процедура Краткий справочник

Для построения сети из четырехугольных ячеек

Создание сети соединения

Создание сети сдвига

Создание сети вращения

Для построения сети в виде участка поверхности Кунса, заданной кромками


Для построения сети из четырехугольных ячеек (Процедура)

Создание сетей
Создание сетей
Создание сетей
Работа с 3D моделями > Создание 3D моделей > Создание сетей >
Создание сетей
Понятие Процедура Краткий справочник

Для построения сети из четырехугольных ячеек

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "3D сеть".В командной строке введите "3dсеть".
  2. Задайте величину M с помощью целого числа от 2 до 256.
  3. Задайте величину N с помощью целого числа от 2 до 256.
  4. Введите в ответ на подсказки координаты вершин сети. После задания последней вершины построение сети завершается.

Ввод команды: 3DСЕТЬ


Создание сети соединения (Процедура)

Создание сетей
Создание сетей
Создание сетей
Работа с 3D моделями > Создание 3D моделей > Создание сетей >
Создание сетей
Понятие Процедура Краткий справочник

Создание сети соединения

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Сеть соединения".В командной строке введите "п-соед".
  2. Выберите первую определяющую кривую. Затем выберите вторую кривую.
  3. Если необходимо, сотрите исходную кривую.
Ввод команды: П-СОЕД


Создание сети сдвига (Процедура)

Создание сетей
Создание сетей
Создание сетей
Работа с 3D моделями > Создание 3D моделей > Создание сетей >
Создание сетей
Понятие Процедура Краткий справочник

Создание сети сдвига

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Сеть сдвига".В командной строке введите "п-сдвиг".
  2. Укажите криволинейную траекторию.
  3. Укажите направляющий вектор.
  4. Если необходимо, сотрите исходные объекты.
Ввод команды: П-СДВИГ


Создание сети вращения (Процедура)

Создание сетей
Создание сетей
Создание сетей
Работа с 3D моделями > Создание 3D моделей > Создание сетей >
Создание сетей
Понятие Процедура Краткий справочник

Создание сети вращения

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Сеть вращения".В командной строке введите "п-вращ".
  2. Укажите криволинейную траекторию.

    Криволинейная траектория, задающая направление N для сети, может быть отрезком, дугой, кругом, эллипсом, эллиптической дугой, 2D полилинией, 3D полилинией или сплайном. При выборе круга, замкнутого эллипса или замкнутой полилинии сеть будет замкнута в направленииN.

  3. Укажите ось вращения.

    Осью вращения может быть отрезок или разомкнутая полилиния (как 2D, так и 3D). Если указана полилиния, ось проводится между ее начальной и конечной точками; Все промежуточные вершины игнорируются. Ось вращения задает направление M сети.

  4. Задайте начальный угол. Затем задайте центральный угол.

    Если начальный угол не равен нулю, сеть будет построена со смещением от криволинейной траектории на величину этого угла. Центральный угол задает угол поворота кривой вокруг оси вращения.

  5. Если необходимо, сотрите исходные объекты.
Ввод команды: П-ВРАЩ


Для построения сети в виде участка поверхности Кунса, заданной кромками (Процедура)

Создание сетей
Создание сетей
Создание каркасных моделей
Работа с 3D моделями > Создание 3D моделей > Создание сетей >
Создание сетей
Понятие Процедура Краткий справочник

Для построения сети в виде участка поверхности Кунса, заданной кромками

  1. Выберите вкладку "Главная" [image] панель "Моделирование" [image] "Сеть по кромкам".В командной строке введите команду "п-кромка".
  2. Выберите в любом порядке четыре кромки.

    Первая из выбранных кромок определяет направление M сети.

Ввод команды: П-КРОМКА


Создание сетей (Краткий справочник)

Проверка взаимодействий в твердотельной модели
Создание сетей
Создание каркасных моделей
Работа с 3D моделями > Создание 3D моделей > Создание сетей >
Создание сетей
Понятие Процедура Краткий справочник

Команды

3D

Создание объектов - 3D полигональных сетей в виде распространенных геометрических форм, которые можно скрыть, раскрасить или тонировать

3DГРАНЬ

Создание трех- или четырехсторонней поверхности в любом месте 3D пространства

3DСЕТЬ

Построение полигональных сетей произвольной формы

П-КРОМКА

Построение 3D полигональной сети

ПОЛРЕД
ПГРАНЬ

Создание 3D многогранной сети по вершинам

П-ВРАЩ

Создание сети вращения вокруг выбранной оси

П-СОЕД

Создание сети соединений между двумя кривыми

П-СДВИГ

Создание сети сдвига на основе криволинейной траектории и вектора направления

Системные переменные

FACETRATIO

Управление плотностью сетевого представления цилиндрических и конических тел

PFACEVMAX

Максимальное число вершин на одной грани

SPLFRAME

Управление отображением сплайнов и сглаженных сплайнами полилиний

SURFTAB1

Число интервалов, генерируемых командами П-СОЕД и П-СДВИГ

SURFTAB2

Плотность сети в направлении N для команд П-ВРАЩ и П-КРОМКА

SURFTYPE

Управление типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн")

SURFU

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности

SURFV

Плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности

Утилиты

Нет

Ключевые слова для команд

Нет


Создание каркасных моделей (Понятие)

Создание сетей
Создание 3D моделей
Задание трехмерной высоты объектов
Работа с 3D моделями > Создание 3D моделей >
Создание каркасных моделей
Понятие Процедура Краткий справочник

Каркасная модель представляет собой скелетное описание 3D объекта, состоящее из отрезков и кривых.

Использование каркасных моделей позволяет:

  • Рассматривать модели из любой точки.
  • Автоматически генерировать ортогональные и дополнительные виды.
  • Легко генерировать расчлененные и перспективные виды.
  • Рассматривать взаимное расположение элементов в пространстве, оценивать кратчайшие расстояния между вершинами и ребрами и т.д.
  • Сократить число необходимых исходных элементов модели.

Каркасные модели состоят только из точек, отрезков и кривых, описывающих кромки объекта. Поскольку каждый из составляющих такую модель объектов должен рисоваться и размещаться независимо от других, затраты времени на моделирование часто бывают крайне велики.

Для создания каркасной геометрии на основе областей и 3D тел и поверхностей используется команда ИЗВЛРЕБРА. Команда ИЗВЛРЕБРА извлекает все ребра на выбранных объектах или подобъектах.

Советы по работе с каркасными моделями

Создание каркасных 3D моделей является более трудоемким процессом, чем построение их двумерных проекций. В связи с этим рекомендуется следовать следующим инструкциям, позволяющим повысить эффективность работы:

  • Спланировать послойную структуру создаваемой модели таким образом, чтобы можно было упрощать выводимую модель отключением тех или иных слоев. Использовать цвета для идентификации объектов на различных видах.
  • Использовать вспомогательные элементы для оценки формы модели.
  • Использовать несколько видов, особенно изометрические, для визуализации модели и упрощения выбора объектов.
  • Изучить управление ПСК в 3D пространстве. Плоскость XY текущей ПСК является плоскостью построений, которая задает ориентацию плоских объектов, таких как круги и дуги. ПСК также определяет плоскость для выполнения операций обрезки, удлинения, смещения и поворота объектов.
  • Использовать режимы объектной и шаговой привязки для обеспечения точности построения модели.
  • Использовать координатные фильтры для построения перпендикуляров и указания точек в трехмерном пространстве на основе координат точек имеющихся объектов.

Способы построения каркасных моделей

Имеется возможность создавать каркасные модели путем размещения плоских 2D объектов в любом месте 3D пространства. Для этого предлагаются следующие способы:

  • Ввод значений 3D точек. Ввод значений 3D точек (с координатами X, Y и Z) в ходе построения объекта.
  • Задание плоскости построений по умолчанию (т.е. плоскости XY ПСК) для рисования объекта.
  • Перемещение или копирование созданного 2D объекта для задания его пространственной ориентации.

Каркасное моделирование требует определенных навыков, приобретаемых в процессе практической работы. Для освоения каркасного моделирования лучше начинать с построения простых моделей с последующим переходом на более сложные.


Создание каркасных моделей (Процедура)

Создание сетей
Создание каркасных моделей
Создание каркасных моделей
Работа с 3D моделями > Создание 3D моделей > Создание каркасных моделей >
Создание каркасных моделей
Понятие Процедура Краткий справочник

Построение перпендикуляра из 3D точки к плоскости XY

Создание каркасной геометрии посредством извлечения ребер


Построение перпендикуляра из 3D точки к плоскостиXY (Процедура)

Создание каркасных моделей
Создание каркасных моделей
Создание каркасных моделей
Работа с 3D моделями > Создание 3D моделей > Создание каркасных моделей >
Создание каркасных моделей
Понятие Процедура Краткий справочник

Построение перпендикуляра из 3D точки к плоскости XY

  1. Выберите меню Рисование [image] Отрезок.В командной строке введите "отрезок".
  2. Используйте объектную привязку для указания точки на объекте, расположенном вне плоскости XY ПСК.

    Указанная точка определяет первую точку для построения отрезка.

  3. Введите .xy, затем введите @ на запрос командной строки.

    Этим действием извлекаются координатные значения X и Y первой точки.

  4. Введите 0 для указания оставшегося значения Z.

    С помощью координатного фильтра значения X и Y, извлеченные из координат первой точки, объединяются с указанным значением Z (0).

  5. Нажмите ENTER для завершения команды.


Создание каркасной геометрии посредством извлечения ребер (Процедура)

Создание каркасных моделей
Создание каркасных моделей
Задание трехмерной высоты объектов
Работа с 3D моделями > Создание 3D моделей > Создание каркасных моделей >
Создание каркасных моделей
Понятие Процедура Краткий справочник

Создание каркасной геометрии посредством извлечения ребер

  1. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Извлечь ребра".В командной строке введите команду "извлребра".
  2. Выберите любую комбинацию из следующих объектов:
    • тела
    • поверхности
    • области
    • ребра (на 3D телах или поверхностях)
    • грани (на 3D телах или поверхностях)
  3. Нажмите клавишу ENTER.
Ввод команды: ИЗВЛРЕБРА


Создание каркасных моделей (Краткий справочник)

Создание сетей
Создание каркасных моделей
Задание трехмерной высоты объектов
Работа с 3D моделями > Создание 3D моделей > Создание каркасных моделей >
Создание каркасных моделей
Понятие Процедура Краткий справочник

Команды

ПСК

Управление пользовательскими системами координат

ИЗВЛРЕБРА

Создание геометрии каркаса посредством извлечения ребер из 3D тела или поверхности

Системные переменные

ELEVATION

Текущий уровень новых объектов относительно текущей ПСК

Утилиты

Нет

Ключевые слова для команд

Нет


Задание трехмерной высоты объектов (Понятие)

Создание каркасных моделей
Создание 3D моделей
Изменение 3D тел и поверхностей
Работа с 3D моделями > Создание 3D моделей >
Задание трехмерной высоты объектов
Понятие Процедура Краткий справочник

Задание высоты объектов позволяет моделировать объем.

3D высотой объекта называется расстояние, на которое объект выдавлен выше или ниже своего уровня. Положительная высота означает выдавливание вверх (в положительном направлении оси Z), отрицательная выдавливание вниз (в отрицательном направлении оси Z), нулевая -рисование без выдавливания. Нулевая (0) высота означает отсутствие высоты объекта 3D. Направление Z определяет ориентацию создаваемого объекта относительно ПСК. Объекты, обладающие ненулевой высотой, можно раскрашивать. Они могут также скрывать другие объекты, расположенные позади.

Заданием высоты можно изменять внешний вид таких объектов, как:

  • 2D фигуры
  • дуги
  • круги
  • отрезки
  • полилинии (включая сглаженные сплайнами полилинии, прямоугольники, многоугольники, контуры и кольца)
  • текст (только однострочный текстовый объект, созданный с использованием шрифта SHX)
  • полосы
  • точки

Попытки изменения высоты других объектов не дают никакого эффекта.

Имеется возможность установить значение высоты для вновь создаваемых объектов с помощью системной переменной THICKNESS. Высоту уже имеющихся объектов можно изменять в палитре свойств. Задание трехмерной высоты относится к объекту как целому: различные его точки не могут иметь различные высоты.

Для наглядного просмотра объектов, обладающих ненулевой высотой, может понадобиться изменение положения точки зрения на 3D виде.

См. также

    • Создание тел и поверхностей на основе объектов


Задание трехмерной высоты объектов (Процедура)

Создание каркасных моделей
Задание трехмерной высоты объектов
Задание трехмерной высоты объектов
Работа с 3D моделями > Создание 3D моделей > Задание трехмерной высоты объектов >
Задание трехмерной высоты объектов
Понятие Процедура Краткий справочник

Для задания 3D высоты вновь создаваемых объектов

Для изменения 3D высоты существующих объектов


Для задания 3D высоты вновь создаваемых объектов (Процедура)

Задание трехмерной высоты объектов
Задание трехмерной высоты объектов
Задание трехмерной высоты объектов
Работа с 3D моделями > Создание 3D моделей > Задание трехмерной высоты объектов >
Задание трехмерной высоты объектов
Понятие Процедура Краткий справочник

Для задания 3D высоты вновь создаваемых объектов

  1. Выберите меню Формат [image] Высота.В командной строке введите "высота".
  2. В командной строке введите значение высоты.

    Новые объекты создаются с заданной 3D высотой.

Ввод команды: ВЫСОТА


Для изменения 3D высоты существующих объектов (Процедура)

Задание трехмерной высоты объектов
Задание трехмерной высоты объектов
Манипулирование 3D телами и поверхностями
Работа с 3D моделями > Создание 3D моделей > Задание трехмерной высоты объектов >
Задание трехмерной высоты объектов
Понятие Процедура Краткий справочник

Для изменения 3D высоты существующих объектов

  1. Выберите объекты, 3D высоту которых необходимо изменить.
  2. Щелкните правой кнопкой на одном из объектов. Выберите "Свойства".
  3. На палитре "Свойства" выберите "Высота" и задайте новое значение высоты.

    Выбранные объекты отображаются с заданной 3D высотой.

Панель:Стандартная
Ввод команды: ОКНОСВ


Задание трехмерной высоты объектов (Краткий справочник)

Создание каркасных моделей
Задание трехмерной высоты объектов
Манипулирование отдельными телами и поверхностями
Работа с 3D моделями > Создание 3D моделей > Задание трехмерной высоты объектов >
Задание трехмерной высоты объектов
Понятие Процедура Краткий справочник

Команды

УРОВЕНЬ

Задание уровня и трехмерной высоты для вновь создаваемых объектов

ОКНОСВ

Управление свойствами объектов

Системные переменные

BACKZ
FRONTZ
ВЫСОТА

Текущая трехмерная высота

VIEWMODE

Сохранение режима "Вид" для текущего видового экрана

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение 3D тел и поверхностей

Задание трехмерной высоты объектов
Работа с 3D моделями
Манипулирование 3D телами и поверхностями
Работа с 3D моделями >
Изменение 3D тел и поверхностей

После создания модели тела можно вручную изменять форму его отображения, вручную управляя телами и поверхностями множеством способов, включая нажатие и перетаскивание ручек, использование блоков захвата и изменение свойств объектов с помощью палитры свойств.

Темы в этом разделе

  • Манипулирование 3D телами и поверхностями

    Для изменения форм и размеров тел и поверхностей можно использовать ручки или палитру "Свойства". Возможности манипулирования телом или поверхностью определяются типом тела или поверхности и способом их создания.

  • Выбор и редактирование 3D подобъектов

    Имеется возможность выбора и редактирования подобъектов (граней, кромок и вершин) на телах. Можно выбирать и редактировать эти подобъекты по отдельности или создавать набор подобъектов одного или нескольких типов и редактировать набор.

  • Сжатие или вытягивание ограниченных областей

    Для сжатия или вытягивания ограниченных областей можно нажать CTRL + ALT и, удерживая их нажатыми, указать на область. Область должна быть ограничена копланарными линиями или кромками.

  • Использование инструментов ручек для редактирования объектов

    Инструменты ручки можно использовать для перемещения и вращения объектов и подобъектов в 3D виде. Инструменты ручки отображаются при выборе объектов и подобъектов в 3D виде с применением 3D визуального стиля или при использовании команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ.

  • Добавление ребер и граней к телам

    Внешний вид граней 3D тел можно изменять путем их клеймения различными объектами, пересекающими грани. При клеймении объект объединяется с гранью, создавая ребро.

  • Разделение 3D тел

    3D тела могут быть разделены на исходные компонентные 3D тела.

  • Создание оболочек из 3D тел

    Можно создать оболочку (тонкостенный полый объем заданной толщины) из 3D тела.

  • Упрощение и проверка корректности 3D тел

    С помощью команды РЕДТЕЛ имеется возможность автоматического удаления избыточных граней, ребер и вершин 3D тел, а также выполнения проверки на корректность тела.


Манипулирование 3D телами и поверхностями

Изменение 3D тел и поверхностей
Изменение 3D тел и поверхностей
Манипулирование отдельными телами и поверхностями
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Манипулирование 3D телами и поверхностями
Понятие Процедура

Для изменения форм и размеров тел и поверхностей можно использовать ручки или палитру "Свойства". Возможности манипулирования телом или поверхностью определяются типом тела или поверхности и способом их создания.

Темы в этом разделе

  • Манипулирование отдельными телами и поверхностями

    Для изменения размера и формы определенных отдельных тел и поверхностей можно использовать ручки или палитру "Свойства".

  • Работа с составными телами

    Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ , ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА.) Можно манипулировать исходными индивидуальными телами, образующими составное тело, или телом в полной компоновке.


Манипулирование 3D телами и поверхностями (Процедура)

Задание трехмерной высоты объектов
Манипулирование 3D телами и поверхностями
Манипулирование отдельными телами и поверхностями
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями >
Манипулирование 3D телами и поверхностями
Понятие Процедура

Перемещение оси вращения для тела (поверхности), построенного методом вращения

Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств


Манипулирование отдельными телами и поверхностями (Понятие)

Манипулирование 3D телами и поверхностями
Манипулирование 3D телами и поверхностями
Работа с составными телами
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями >
Манипулирование отдельными телами и поверхностями
Понятие Процедура Краткий справочник

Для изменения размера и формы определенных отдельных тел и поверхностей можно использовать ручки или палитру "Свойства".

Возможности манипулирования телом или поверхностью, предоставляемые ручками или палитрой свойств, зависят от типа тела или поверхности.

Элементарные тела (ящик, клин, пирамида, шар, цилиндр, конус и тор)

Использование ручек или палитры свойств позволяет изменять очертания и размер элементарных тел с сохранением их исходной базовой формы. Например, можно изменить радиус основания и высоту конуса, но сохранить форму конуса.

Показать: "Построение и изменение конуса"

Для запуска анимации нажмите стрелку "Просмотр". Дополнительную информацию о создании конусов см. в разделе Создание конусов.

Другой пример: можно изменить пирамиду, преобразуя четырехстороннюю пирамиду, сводимую в точку, в восьмистороннюю пирамиду, усекаемую до плоской поверхности, с сохранением пирамидальной формы.

Выдавливаемые тела и поверхности

Для создания выдавливаемых тел и поверхностей используется команда ВЫДАВИТЬ. При выборе выдавливаемых тел и поверхностей отображаются ручки на их профилях. Профиль является исходной формой, используемой для создания выдавливаемого тела или поверхности и определяющей внешний вид объекта. Можно использовать эти ручки для управления профилем тела или поверхности с целью изменения формы всего тела или поверхности.

Если выполнено выдавливание по траектории, отображается траектория, которой можно управлять с помощью ручек. Если траектория не использовалась, вверху выдавленного тела или поверхности отображается ручка высоты, позволяющая изменять высоту объекта.

Политела

Можно использовать ручки для изменения формы и размера полител, включая профиль политела. Ручки можно перемещать в плоскости XY тела. Политело всегда имеет угловой профиль (по умолчанию прямоугольный).

Развернутые тела и поверхности

Для развернутых тел и поверхностей ручки отображаются на развернутом профиле, а также на траектории развертывания. Эти ручки можно использовать для изменения тела или поверхности.

Перетаскивание по профилю ручки, выбранной нажатием левой кнопки мыши, позволяет вносить изменения только в плоскости кривой профиля.

Тела и поверхности, полученные по сечениям

В зависимости от того, каким способом получены тела и поверхности по сечениям, для тела или поверхности отображаются ручки на указанных ниже объектах, определяющих линиях или кривых.

  • Поперечное сечение
  • Траектория

Можно перетаскивать выбираемые мышью ручки по любой из определяющих линий или кривых с целью изменения тела или поверхности. Если полученное методом сечений тело или поверхность содержит траекторию, разрешается редактировать только часть траектории, находящуюся между первым и последним поперечными сечениями.

Можно также использовать область "Геометрия" палитры "Свойства" для изменения контура тела (поверхности), построенного методом сечений, на его поперечных сечениях. Когда выбирается тело (поверхность), полученное методом сечений, в области "Геометрия" палитры "Свойства" отображаются параметры, которые были заданы в диалоговом окне "Настройка лофтинга" при создании тела (поверхности).

Для изменения тел или поверхностей, построенных методом сечений с использованием направляющих, использование ручек не предусмотрено.

Тела и поверхности, созданные методом вращения

Для тел и поверхностей, созданных методом вращения, отображаются ручки на профиле вращения в начале тела (поверхности), построенного методом вращения. Можно использовать эти ручки для изменения профиля тела или поверхности.

Ручка отображается также в конечной точке оси вращения. Можно переместить ось вращения, выбирая ручку и указывая другое местоположение оси.

См. также

    • Создание 3D тел и поверхностей


Манипулирование отдельными телами и поверхностями (Процедура)

Манипулирование 3D телами и поверхностями
На уровень вверх ..
Манипулирование отдельными телами и поверхностями
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Манипулирование отдельными телами и поверхностями >
Манипулирование отдельными телами и поверхностями
Понятие Процедура Краткий справочник

Перемещение оси вращения для тела (поверхности), построенного методом вращения

Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств


Перемещение оси вращения для тела (поверхности), построенного методом вращения (Процедура)

Манипулирование отдельными телами и поверхностями
На уровень вверх ..
Манипулирование отдельными телами и поверхностями
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Манипулирование отдельными телами и поверхностями >
Манипулирование отдельными телами и поверхностями
Понятие Процедура Краткий справочник

Перемещение оси вращения для тела (поверхности), построенного методом вращения

  1. На чертеже выберите тело (поверхность), созданное методом вращения.
  2. Выберите ручку на оси вращения.
  3. Нажмите левую кнопку мыши и переместите ось вращения.


Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств (Процедура)

Манипулирование отдельными телами и поверхностями
На уровень вверх ..
Работа с составными телами
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Манипулирование отдельными телами и поверхностями >
Манипулирование отдельными телами и поверхностями
Понятие Процедура Краткий справочник

Изменение контура тела (поверхности), построенного методом сечений, с помощью палитры свойств

  1. На чертеже выбрать тело (поверхность), полученное методом сечений с использованием поперечных сечений.
  2. Если палитра "Свойства" не отображается, выберите меню Сервис [image] Палитры [image] Свойства.
  3. В области "Геометрия" палитры "Свойства" измените настройку "Нормали к поверхности", выбрав одно из указанных ниже значений.
    • Кусочно-линейчатая Указывается, что тело (поверхность) является линейчатым между поперечными сечениями и имеет острые кромки на поперечных сечениях.
    • СглаженнаяУказывается, что между поперечными сечениями расположено гладкое тело (поверхность), имеющее острые кромки на поперечных сечениях. Касательное направление на поперечных сечениях определяется примыкающими поперечными сечениями.
    • Первая нормальУказывается, что нормаль к поверхности является нормалью к первому поперечному сечению.
    • Последняя нормаль Указывается, что нормаль к поверхности является нормалью к последнему поперечному сечению.
    • Концы нормалиУказывается, что нормаль к поверхности является нормалью и к первому, и к последнему поперечному сечению.
    • Все нормали Указывается, что нормаль к поверхности является нормалью ко всем поперечным сечениям.
    • Использование конусных ограниченийОпределяется угол наклона первого и последнего поперечных сечений тела (поверхности), построенного по сечениям. Значения угла наклона определяются следующими системными переменными: LOFTANG1, LOFTANG2, LOFTMAG1 и LOFTMAG2.


Манипулирование отдельными телами и поверхностями (Краткий справочник)

Задание трехмерной высоты объектов
Манипулирование отдельными телами и поверхностями
Отображение исходных форм составных тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Манипулирование отдельными телами и поверхностями >
Манипулирование отдельными телами и поверхностями
Понятие Процедура Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

Системные переменные

GRIPS

Управление использованием ручек набора объектов при их растягивании, перемещении, повороте, масштабировании и зеркальном отображении

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с составными телами

Манипулирование отдельными телами и поверхностями
Манипулирование 3D телами и поверхностями
Отображение исходных форм составных тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями >
Работа с составными телами
Понятие Процедура

Составные тела создаются из двух и более индивидуальных тел с использованием любой из следующих команд: ОБЪЕДИНЕНИЕ , ВЫЧИТАНИЕ и ПЕРЕСЕЧЕНИЕ (Для создания составных тел используются также команды СОПРЯЖЕНИЕ и ФАСКА.) Можно манипулировать исходными индивидуальными телами, образующими составное тело, или телом в полной компоновке.

Темы в этом разделе

  • Отображение исходных форм составных тел

    По умолчанию в журнале 3D тел регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела.

  • Манипулирование составными телами

    Возможно манипулирование составным телом в полной компоновке или исходными формами, образующими составное тело.


Работа с составными телами (Процедура)

Манипулирование отдельными телами и поверхностями
На уровень вверх ..
Отображение исходных форм составных тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами >
Работа с составными телами
Понятие Процедура

Для отображения исходных тел, образующих составное тело

Для удаления журнала тела

Для выбора ведения журнала исходных форм в составном теле

Для выбора индивидуального тела, являющегося частью составного тела


Отображение исходных форм составных тел (Понятие)

Работа с составными телами
Работа с составными телами
Манипулирование составными телами
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами >
Отображение исходных форм составных тел
Понятие Процедура Краткий справочник

По умолчанию в журнале 3D тел регистрируются исходные профили 3D тел. Этот журнал позволяет видеть исходные формы, из которых получены составные тела.

При выборе значения "Да" для опции "Показать протокол" составного тела отображаются (бледными линиями) каркасы исходных форм индивидуальных тел, образующих составное тело.

Отображение журнала составного тела полезно при модификации составных тел. Ручки отображаются на исходных формах, из которых создается составное тело. Подробные сведения об использовании ручек для манипулирования составными телами см. в разделе Манипулирование составными телами.

Для переопределения настройки свойства "Показать протокол" в палитре "Свойства" можно использовать системную переменную SHOWHIST.

Ведение журнала регистрации исходных компонентов составного тела возможно при условии, что для свойства "Журнал" исходных индивидуальных тел установлено значение "Запись". "Запись" является значением данного свойства по умолчанию, но может быть изменено в секции "Журнал тел" палитры "Свойства" или с помощью системной переменной SOLIDHIST.

Для удаления журнала составного тела, можно выбрать тело и заменить значение его свойства "Журнал" на "Нет". Для удаления журнала из индивидуального или составного тела можно использовать также команду ГРПРЕД. При удалении журнала тела утрачивается возможность выбора и изменения исходных компонентов тела. После этого можно заново установить значение "Запись" для настройки журнала тела, перезапуская ведение журнала "с нуля".

Удаление журнала составного тела может быть полезным при создании очень сложных составных тел. Например, может понадобиться создание сложных составных тел, служащих основой для дополнительных составных тел. Журнал можно удалить сразу после создания базовой формы. Далее можно вернуть свойству "Журнал" значение "Запись" с тем, чтобы можно было в дальнейшем редактировать формы дополнительных объектов, добавляемых в составное тело.


Отображение исходных форм составных тел (Процедура)

Работа с составными телами
На уровень вверх ..
Отображение исходных форм составных тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами > Отображение исходных форм составных тел >
Отображение исходных форм составных тел
Понятие Процедура Краткий справочник

Для отображения исходных тел, образующих составное тело

Для удаления журнала тела

Для выбора ведения журнала исходных форм в составном теле


Для отображения исходных тел, образующих составное тело (Процедура)

Отображение исходных форм составных тел
На уровень вверх ..
Отображение исходных форм составных тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами > Отображение исходных форм составных тел >
Отображение исходных форм составных тел
Понятие Процедура Краткий справочник

Для отображения исходных тел, образующих составное тело

  1. Если палитра "Свойства" не отображается, выберите меню Сервис [image] Палитры [image] Свойства.
  2. На чертеже выберите 3D составное тело.
  3. Выберите "Да" для опции "Показать протокол" в секции "Журнал тел" палитры "Свойства".


Для удаления журнала тела (Процедура)

Отображение исходных форм составных тел
На уровень вверх ..
Отображение исходных форм составных тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами > Отображение исходных форм составных тел >
Отображение исходных форм составных тел
Понятие Процедура Краткий справочник

Для удаления журнала тела

  1. Если палитра "Свойства" не отображается, выберите меню Сервис [image] Палитры [image] Свойства.
  2. На чертеже выберите 3D тело.
  3. Выберите "Нет" для опции "Журнал" в секции "Журнал тел" палитры "Свойства".
Ввод команды: ГРПРЕД


Для выбора ведения журнала исходных форм в составном теле (Процедура)

Отображение исходных форм составных тел
На уровень вверх ..
Манипулирование составными телами
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами > Отображение исходных форм составных тел >
Отображение исходных форм составных тел
Понятие Процедура Краткий справочник

Для выбора ведения журнала исходных форм в составном теле

  1. Если палитра "Свойства" не отображается, выберите меню Сервис [image] Палитры [image] Свойства.
  2. Выберите тело на чертеже.
  3. Выберите "Запись" для опции "Журнал" в секции "Журнал тел" палитры "Свойства".


Отображение исходных форм составных тел (Краткий справочник)

Манипулирование отдельными телами и поверхностями
Отображение исходных форм составных тел
Манипулирование составными телами
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами > Отображение исходных форм составных тел >
Отображение исходных форм составных тел
Понятие Процедура Краткий справочник

Команды

ГРПРЕД

Удаление журнала из 3D элементарных тел и составных тел

Системные переменные

SHOWHIST

Управление свойством "Показать журнал" для тел на чертеже

SOLIDHIST

Управление установкой значения по умолчанию свойства "Журнал" для новых и существующих объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Манипулирование составными телами (Понятие)

Отображение исходных форм составных тел
Работа с составными телами
Выбор и редактирование 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами >
Манипулирование составными телами
Понятие Процедура Краткий справочник

Возможно манипулирование составным телом в полной компоновке или исходными формами, образующими составное тело.

Можно выбрать составное тело на чертеже и перемещать, масштабировать или вращать тело с использованием ручек или инструментов ручек.

Можно также выбирать исходные индивидуальные формы составного тела, удерживая в нажатом состоянии клавишу CTRL. Если исходная форма тела не является элементарным телом, отображаются ручки, позволяющие изменять профиль и размер элементарной формы внутри составного тела.

Если в выбранной индивидуальной форме отсутствует журнал, можно перемещать, поворачивать, масштабировать или удалять форму.

Составное тело может быть образовано другими составными телами. Можно выбирать исходные индивидуальные формы составных тел, образующих составное тело, удерживая в нажатом состоянии клавишу CTRL в процессе выбора форм левой кнопкой мыши.

Размер и форму составных тел можно изменять также, выбирая мышью и перетаскивая ручки на индивидуальных гранях, кромках и вершинах. Подробные сведения см. в разделе Выбор и редактирование 3D подобъектов.

См. также

    • Использование режимов ручек

    • Многократное копирование с помощью ручек

    • Использование инструментов ручек для редактирования объектов


Для выбора индивидуального тела, являющегося частью составного тела (Процедура)

Отображение исходных форм составных тел
На уровень вверх ..
Выбор и редактирование 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами > Манипулирование составными телами >
Манипулирование составными телами
Понятие Процедура Краткий справочник

Для выбора индивидуального тела, являющегося частью составного тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на индивидуальном теле, являющемся частью составного тела.
  3. Повторяйте этот шаг, пока не будут выбраны все требуемые формы.


Манипулирование составными телами (Краткий справочник)

Отображение исходных форм составных тел
Манипулирование составными телами
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Манипулирование 3D телами и поверхностями > Работа с составными телами > Манипулирование составными телами >
Манипулирование составными телами
Понятие Процедура Краткий справочник

Команды

Нет

Системные переменные

LEGACYCTRLPICK

Задание клавиш циклического повторения выбора и определение действий при нажатии клавиши CTRL и левой кнопки мыши

Утилиты

Нет

Ключевые слова для команд

Нет


Выбор и редактирование 3D подобъектов

Манипулирование составными телами
Изменение 3D тел и поверхностей
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Выбор и редактирование 3D подобъектов
Понятие Процедура

Имеется возможность выбора и редактирования подобъектов (граней, кромок и вершин) на телах. Можно выбирать и редактировать эти подобъекты по отдельности или создавать набор подобъектов одного или нескольких типов и редактировать набор.

Темы в этом разделе

  • Выбор 3D подобъектов

    Для выбора подобъектов (граней, кромок и вершин) на телах необходимо нажать и удерживать нажатой клавишу CTRL и далее выбирать эти подобъекты.

  • Перемещение, поворот и масштабирование подобъектов

    Перемещение, поворот и масштабирование отдельных подобъектов на 3D телах выполняется выбором и перетаскиванием ручки подобъекта, используя инструменты ручки (3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ) или посредством команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

  • Редактирование граней на 3D телах

    Возможен выбор граней на 3D теле для их перемещения, вращения или масштабирования. Можно также удалять, копировать, окрашивать грани и добавлять к ним материалы.

  • Редактирование ребер на 3D телах

    Имеется возможность выбора и редактирования ребер на 3D теле.

  • Редактирование вершин на 3D телах

    Имеется возможность выбора и редактирования вершин на 3D телах. Выбор левой кнопкой мыши и перетаскивание вершины приводит к "растягиванию" 3D объекта.


Выбор и редактирование 3D подобъектов (Процедура)

Манипулирование составными телами
Выбор и редактирование 3D подобъектов
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов >
Выбор и редактирование 3D подобъектов
Понятие Процедура

Для выбора одной или нескольких граней, кромок или вершин на теле

Для создания набора 3D объектов и подобъектов

Для удаления подобъекта из набора подобъектов

Для выбора кромки, грани или вершины на исходной форме составного тела

Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов

Для сопряжения граней тела

Снятие фаски на 3D теле

Для редактирования сопряжения или фаски на 3D теле

Для изменения цвета ребра тела

Для копирования ребра тела

Для редактирования вершины на 3D объекте

Для удаления вершины на 3D объекте


Выбор 3D подобъектов (Понятие)

Выбор и редактирование 3D подобъектов
Выбор и редактирование 3D подобъектов
Перемещение, поворот и масштабирование подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Для выбора подобъектов (граней, кромок и вершин) на телах необходимо нажать и удерживать нажатой клавишу CTRL и далее выбирать эти подобъекты.

Подобъектом является любая составная часть тела: грань, кромка или вершина. Возможен также вызов исходных индивидуальных форм, образующих составные подобъекты тел. Эти исходные формы являются составными частями тел и выбираются таким же образом (при нажатой клавише CTRL), как грани, кромки и вершины.

На всех выбранных гранях, кромках и вершинах по отдельности отображаются ручки различных типов.

Можно выбрать один подобъект либо создать набор из двух и более подобъектов в любом количестве тел. В этот набор разрешается включать подобъекты двух и более типов. Можно также использовать CTRL с целью выбора подобъектов по подсказкам выбора из команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ, МАСШТАБ и СТЕРЕТЬ.

Кроме того, можно нажимать и удерживать нажатой клавишу CTRL для выбора граней, кромок и вершин на составных телах. Однако, если для свойства "Журнал" составного тела задано значение "Запись", первое пользовательское "указание" может привести к выбору исходного тела, включенного в составное тело. Продолжая удерживать нажатой клавишу CTRL, можно новыми указаниями выбирать грань, кромку или вершину на данной исходной форме.

Возможно также создание набора, состоящего из любого числа тел, поверхностей и подобъектов.

Если подобъекты перекрываются между собой, и включена опция предварительного просмотра набора, можно циклически проходить по объектам; с этой целью выберите (прокруткой) подобъект на верхней позиции для его подсветки, нажмите и удерживайте нажатой клавишу CTRL и последовательно нажимайте клавишу ПРОБЕЛ. Когда подсвечивается нужный объект, выберите его нажатием левой кнопки мыши.

Если опция предварительного просмотра набора выключена и указатель выбора (миниатюрный прямоугольник, заменяющий перекрестье при выборе объектов) указывает на два и более подобъекта, можно циклически проходить по подобъектам, пока не будет выбран нужный подобъект; для этого следует нажимать клавишу ПРОБЕЛ при нажатой клавише CTRL и нажимать левую кнопку мыши на нужном подобъекте.

Например, когда выбираются грани в 3D телах, первой обнаруживается грань лицевой стороны на переднем плане. Грань задней стороны, расположенную позади грани лицевой стороны, можно выбрать нажатием клавиши ПРОБЕЛ (при нажатой клавише CTRL).


Выбор 3D подобъектов (Процедура)

Выбор и редактирование 3D подобъектов
На уровень вверх ..
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Выбор 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Для выбора одной или нескольких граней, кромок или вершин на теле

Для создания набора 3D объектов и подобъектов

Для удаления подобъекта из набора подобъектов

Для выбора кромки, грани или вершины на исходной форме составного тела

Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов


Для выбора одной или нескольких граней, кромок или вершин на теле (Процедура)

Выбор 3D подобъектов
На уровень вверх ..
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Выбор 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Для выбора одной или нескольких граней, кромок или вершин на теле

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Выберите грань, кромку или вершину.
  3. Повторяйте шаг 2, пока не будут выбраны требуемые подобъекты.
    Ввод команды: ВЫБРАТЬ (опция подобъекта)


Для создания набора 3D объектов и подобъектов (Процедура)

Выбор 3D подобъектов
На уровень вверх ..
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Выбор 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Для создания набора 3D объектов и подобъектов

  1. Выберите требуемые тела и поверхности.
  2. Нажмите и удерживайте нажатой клавишу CTRL.
  3. Выберите грань, кромку или вершину.
  4. Повторяйте шаги 1 - 3, пока не будут выбраны требуемые подобъекты.
Ввод команды: ВЫБРАТЬ


Для удаления подобъекта из набора подобъектов (Процедура)

Выбор 3D подобъектов
На уровень вверх ..
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Выбор 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Для удаления подобъекта из набора подобъектов

  1. Нажмите и удерживайте нажатыми клавиши CTRL + SHIFT.
  2. Нажатием левой кнопки мыши выберите грань, кромку или вершину.


Для выбора кромки, грани или вершины на исходной форме составного тела (Процедура)

Выбор 3D подобъектов
На уровень вверх ..
Выбор 3D подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Выбор 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Для выбора кромки, грани или вершины на исходной форме составного тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Выберите исходную форму, на которой необходимо выбрать грань, кромку или вершину.
  3. При нажатой клавише CTRL нажмите левую кнопку мыши на грани, кромке или вершине.

    Может потребоваться повтор данного шага для выбора требуемой грани, кромки или вершины.

Ввод команды: ВЫБРАТЬ (опция подобъекта)


Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов (Процедура)

Выбор 3D подобъектов
На уровень вверх ..
Редактирование граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Выбор 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Для циклического прохождения по подобъектам и выбора перекрывающихся подобъектов

  1. Нажмите и удерживайте нажатыми CTRL + ПРОБЕЛ.
  2. Нажмите левую кнопку мыши как можно ближе к требуемому подобъекту.
  3. Последовательно нажимайте кнопку, пока не произойдет подсветка нужного объекта.
  4. Нажмите ENTER для выбора подобъекта.


Выбор 3D подобъектов (Краткий справочник)

Манипулирование составными телами
Выбор 3D подобъектов
Перемещение, поворот и масштабирование подобъектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Выбор 3D подобъектов >
Выбор 3D подобъектов
Понятие Процедура Краткий справочник

Команды

ВЫБРАТЬ

Занесение выбранных объектов в текущий набор

РЕДТЕЛ

Редактирование граней и ребер 3D тел

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Перемещение, поворот и масштабирование подобъектов (Понятие)

Выбор 3D подобъектов
Выбор и редактирование 3D подобъектов
Редактирование граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов >
Перемещение, поворот и масштабирование подобъектов
Понятие Краткий справочник

Перемещение, поворот и масштабирование отдельных подобъектов на 3D телах выполняется выбором и перетаскиванием ручки подобъекта, используя инструменты ручки (3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ) или посредством команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Показать: "Перенос граней и ребер на 3D теле"

Для запуска анимации нажмите стрелку "Просмотр".

При переносе, повороте или масштабировании подобъекта претерпеваемые им изменения не нарушают целостности 3D тела. Например, при переносе ребра (красного цвета на иллюстрации), смежные с ребром грани остаются смежными с этим ребром.

В некоторых случаях при изменении тела возможно получение нескольких результатов. При переносе, повороте или масштабировании подобъектов можно во время перетаскивания нажать клавишу CTRL для циклического перебора режимов изменения. Ниже на иллюстрации показаны варианты изменений для переноса грани (красного цвета).

Дополнительные сведения о вариантах изменений см. в разделе:

  • Перемещение, вращение и масштабирование граней на 3D телах
  • Редактирование ребер на 3D телах
  • Редактирование вершин на 3D телах

"Перенос, поворот и масштабирование подобъектов на составных телах"

Если для свойства "Журнал" составного тела задано значение "Запись", можно выбирать и переносить, поворачивать и масштабировать грани, ребра и вершины только на отдельно взятых примитивных телах, образующих составные тела.

Если для свойства "Журнал" составного тела задано значение "Нет", можно выбирать и переносить, поворачивать и масштабировать грани, ребра и вершины только всего составного тела (но не отдельно взятых примитивов, образующих составные тела).

Правила и ограничения на выполнение переноса, поворота, масштабирования подобъектов

Допускаются только те операции переноса, поворота и масштабирования подобъектов, которые не нарушают целостности 3D тела. При выполнении переноса, поворота и масштабирования подобъектов действуют следующие правила:

  • Если для изменения подобъектов используются ручки, они не отображаются на подобъектах, которые нельзя переносить, поворачивать или масштабировать.
  • В большинстве случаев можно выполнять перенос, поворот и масштабирование как плоских, так и неплоских граней.
  • Можно изменять только ребро, являющееся прямым отрезком и имеющее не менее одной плоской смежной грани. Выполняется регулировка плоскостей смежных плоских граней, обеспечивающая сохранение в них изменяемого ребра.
  • Не допускается выполнение переноса, поворота или масштабирования ребре (или их вершин), запечатленных внутри грани.
  • Возможно изменение только вершины, имеющей не менее одной плоской смежной грани. Выполняется регулировка плоскостей смежных плоских граней, обеспечивающая сохранение в них изменяемой вершины.
  • При перетаскивании подобъекта конечный результат может отличаться от предварительного изображения, отображаемого во время изменения. Это определяется тем, что выполняется регулировка способа изменения тела для сохранения его топологии. В некоторых случаях изменение может оказаться невозможным из-за слишком серьезного изменения топологии тела.
  • Как правило, операция завершается неудачей, если изменения приводят к удлинению поверхностей сплайнов.
  • Не допускается выполнение переноса, поворота или масштабирования ребер или вершин, принадлежащих более чем двум граням. Аналогично, если некоторые ребра или вершины, принадлежащие более чем двум граням, находятся рядом с изменяемыми гранями, ребрами или вершинами, операция может оказаться невозможной.


Перемещение, поворот и масштабирование подобъектов (Краткий справочник)

Выбор 3D подобъектов
Перемещение, поворот и масштабирование подобъектов
Перемещение, вращение и масштабирование граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Перемещение, поворот и масштабирование подобъектов >
Перемещение, поворот и масштабирование подобъектов
Понятие Краткий справочник

Команды

ПЕРЕНЕСТИ

Перемещение объектов на заданное расстояние в указанном направлении

ПОВЕРНУТЬ

Поворот объекта вокруг базовой точки

МАСШТАБ

Увеличение или уменьшение выбранных объектов с сохранением пропорций

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование граней на 3D телах

Перемещение, поворот и масштабирование подобъектов
Выбор и редактирование 3D подобъектов
Перемещение, вращение и масштабирование граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов >
Редактирование граней на 3D телах
Понятие Процедура

Возможен выбор граней на 3D теле для их перемещения, вращения или масштабирования. Можно также удалять, копировать, окрашивать грани и добавлять к ним материалы.

Темы в этом разделе

  • Перемещение, вращение и масштабирование граней на 3D телах

    Разрешается выбирать и редактировать грани на 3D телах. Для изменения граней применяются ручки, захватные блоки или такие команды, как ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

  • Копирование, удаление и окрашивание граней на 3D телах

    Можно использовать РЕДТЕЛ для копирования или удаления граней объекта 3D тела. Палитра "Свойства" позволяет изменять цвет граней на объектах 3D тел.


Редактирование граней на 3D телах (Процедура)

Выбор 3D подобъектов
На уровень вверх ..
Копирование, удаление и окрашивание граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах >
Редактирование граней на 3D телах
Понятие Процедура

Для копирования грани тела

Для удаления грани тела

Для изменения цвета грани тела


Перемещение, вращение и масштабирование граней на 3D телах (Понятие)

Редактирование граней на 3D телах
Редактирование граней на 3D телах
Копирование, удаление и окрашивание граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах >
Перемещение, вращение и масштабирование граней на 3D телах
Понятие Краткий справочник

Разрешается выбирать и редактировать грани на 3D телах. Для изменения граней применяются ручки, захватные блоки или такие команды, как ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Команды ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ можно использовать для редактирования граней точно так же, как для любого другого объекта. Нажмите и удерживайте нажатой клавишу CTRL при выборе грани на теле.

Когда перемещается, поворачивается или масштабируется грань на 3D элементарном теле, удаляется журнал элементарного тела. Тело не является более истинно элементарным телом и не доступно для манипулирования в качестве такого тела (с помощью ручек и палитры "Свойства").

Режимы изменения граней

Для циклического перебора режимов изменения нажмите клавишу CTRL при перетаскивании грани.

При выполнении переноса, поворота или масштабирования грани без использования клавиши CTRL грань изменяется вместе со своими ребрами, сохраняя свою форму и ребра, но при этом возможно изменение плоскостей плоских граней, смежных с изменяемой.

При выполнении переноса, поворота или масштабирования грани, сопровождаемых однократным нажатием и отпусканием клавиши CTRL во время перетаскивания, грань изменяется отдельно от своих ребер. При этом сохраняются поверхности смежных граней, но возможно изменение формы (границы) изменяемой грани.

При выполнении переноса, поворота или масштабирования грани, сопровождаемых двукратным нажатием и отпусканием клавиши CTRL во время перетаскивания, грань изменяется вместе со своими ребрами (так же, как без нажатия клавиши CTRL). Однако, при необходимости, для плоских граней, смежных с изменяемой, выполняется триангуляция (разделение на две или более плоские треугольные грани).

Если клавиша CTRL нажимается и отпускается в третий раз, возвращается первый режим изменения, как если бы клавиша CTRL не нажималась.

См. также

    • Перемещение, поворот и масштабирование подобъектов

    • Использование инструментов ручек для редактирования объектов

    • Применение материалов к объектам и граням

    • Перемещение или поворот объектов

    • Изменение размеров и форм объектов


Перемещение, вращение и масштабирование граней на 3D телах (Краткий справочник)

Перемещение, поворот и масштабирование подобъектов
Перемещение, вращение и масштабирование граней на 3D телах
Копирование, удаление и окрашивание граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах > Перемещение, вращение и масштабирование граней на 3D телах >
Перемещение, вращение и масштабирование граней на 3D телах
Понятие Краткий справочник

Команды

ПЕРЕНЕСТИ

Перемещение объектов на заданное расстояние в указанном направлении

ПОВЕРНУТЬ

Поворот объекта вокруг базовой точки

МАСШТАБ

Увеличение или уменьшение выбранных объектов с сохранением пропорций

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Копирование, удаление и окрашивание граней на 3D телах (Понятие)

Перемещение, вращение и масштабирование граней на 3D телах
Редактирование граней на 3D телах
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах >
Копирование, удаление и окрашивание граней на 3D телах
Понятие Процедура Краткий справочник

Можно использовать РЕДТЕЛ для копирования или удаления граней объекта 3D тела. Палитра "Свойства" позволяет изменять цвет граней на объектах 3D тел.

Копирование и удаление граней

Если для копирования граней на объекте 3D тела используется команда РЕДТЕЛ, выбранные грани копируются в качестве областей или тел. Если указать две точки, то первая будет использоваться как базовая точка и одна копия будет размещена относительно базовой точки. Если указать одну точку и затем нажать клавишу ENTER, исходная точка выбора используется как базовая точка, а следующая точка используется как точка смещения.

Грань, окружаемую копланарными гранями, можно удалять либо путем выбора грани и ее удаления, либо с помощью команды СТЕРЕТЬ. Для удаления граней можно использовать также команду РЕДТЕЛ.

Изменение цвета граней

Цвет грани на 3D теле можно изменять, выбирая грань и далее изменяя свойство "Цвет" в палитре "Свойства".


Копирование, удаление и окрашивание граней на 3D телах (Процедура)

Редактирование граней на 3D телах
На уровень вверх ..
Копирование, удаление и окрашивание граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах > Копирование, удаление и окрашивание граней на 3D телах >
Копирование, удаление и окрашивание граней на 3D телах
Понятие Процедура Краткий справочник

Для копирования грани тела

Для удаления грани тела

Для изменения цвета грани тела


Для копирования грани тела (Процедура)

Копирование, удаление и окрашивание граней на 3D телах
На уровень вверх ..
Копирование, удаление и окрашивание граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах > Копирование, удаление и окрашивание граней на 3D телах >
Копирование, удаление и окрашивание граней на 3D телах
Понятие Процедура Краткий справочник

Для копирования грани тела

  1. Выберите меню Редактирование [image] Редактирование тела [image] Копировать грани.В командной строке введите "редтел".
  2. Выберите грань для копирования (1).
  3. Выберите дополнительные грани или нажмите ENTER для выполнения операции копирования.
  4. Укажите базовую точку для копирования (2).
  5. Укажите вторую точку перемещения (3).
  6. Нажмите ENTER для выполнения команды.

ПримечаниеДля выдавливания скопированной грани следует использовать команду ВЫДАВИТЬ.
Ввод команды: РЕДТЕЛ


Для удаления грани тела (Процедура)

Копирование, удаление и окрашивание граней на 3D телах
На уровень вверх ..
Копирование, удаление и окрашивание граней на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах > Копирование, удаление и окрашивание граней на 3D телах >
Копирование, удаление и окрашивание граней на 3D телах
Понятие Процедура Краткий справочник

Для удаления грани тела

  1. Выберите меню Редактирование [image] Редактирование тела [image] Удалить грани.В командной строке введите "редтел".
  2. Выберите грань для удаления (1).
  3. Выберите дополнительные грани или нажмите ENTER для удаления.
  4. Нажмите ENTER для выполнения команды.

Панель:Редактирование тела
Ввод команды: РЕДТЕЛ


Для изменения цвета грани тела (Процедура)

Копирование, удаление и окрашивание граней на 3D телах
На уровень вверх ..
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах > Копирование, удаление и окрашивание граней на 3D телах >
Копирование, удаление и окрашивание граней на 3D телах
Понятие Процедура Краткий справочник

Для изменения цвета грани тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на грани 3D тела.
  3. Если палитра "Свойства" не отображается, выберите меню Сервис [image] Палитры [image] Свойства.
  4. В палитре "Свойства" нажмите на "Цвет" на вкладке "Общие".

    Справа от поля располагается кнопка со стрелкой.

  5. Нажмите на кнопку и выберите цвет из списка или воспользуйтесь пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В этом случае выполните одно из следующих действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255).
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" и задайте цвет путем ввода значения цвета в поле "Цвет" или задания значений в полях "H" (Цвет), "S" (Насыщенность)" и "L" (Яркость). Нажмите "ОК".
    • На вкладке "Вся палитра" выберите цветовую модель "RGB" в списке "Цветовая модель". Задайте цвет путем введения его значения в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
    • На вкладке "Альбомы цветов" выберите из списка альбом цветов. Выберите цвет нажатием на цветовой полоске при перемещении по альбому цветов (с помощью стрелок вверх или вниз). Нажмите "ОК".
    Ввод команды: ОКНОСВ


Копирование, удаление и окрашивание граней на 3D телах (Краткий справочник)

Перемещение, вращение и масштабирование граней на 3D телах
Копирование, удаление и окрашивание граней на 3D телах
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование граней на 3D телах > Копирование, удаление и окрашивание граней на 3D телах >
Копирование, удаление и окрашивание граней на 3D телах
Понятие Процедура Краткий справочник

Команды

РЕДТЕЛ

Редактирование граней и ребер 3D тел

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование ребер на 3D телах (Понятие)

Копирование, удаление и окрашивание граней на 3D телах
Выбор и редактирование 3D подобъектов
Редактирование вершин на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Имеется возможность выбора и редактирования ребер на 3D теле.

Перемещение, поворот и масштабирование ребер

Ребра на 3D телах изменяются с помощью ручек, захватных блоков и с использованием таких команд, как ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Команды ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ можно использовать для редактирования ребер на 3D телах, точно так же как для любого другого объекта. Нажмите и удерживайте нажатой клавишу CTRL при выборе ребра на теле.

Ребра на областях можно выбирать, но при этом не отображаются ручки. Этими ребрами можно также управлять с помощью команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ.

Кроме того, можно удалять ребра, которые полностью разделяют две копланарные грани, либо путем выбора и удаления грани, либо с помощью команды СТЕРЕТЬ.

Когда перемещается, поворачивается или масштабируется ребро на 3D элементарном теле, удаляется журнал этого элементарного тела. Тело не является более элементарным и не доступно для манипулирования в качестве такого тела (с помощью ручек и палитры "Свойства").

Режимы изменения ребер

Для циклического перебора режимов изменения нажмите клавишу CTRL при перетаскивании ребра.

При выполнении переноса, поворота или масштабирования без нажатия клавиши CTRL ребро изменяется вместе со своим вершинами, сохраняя длину ребра, но при этом возможно изменение плоскостей плоских граней, смежных с вершинами ребер.

При выполнении переноса, поворота или масштабирования ребра, сопровождаемых однократным нажатием и отпусканием клавиши CTRL во время перетаскивания, ребро изменяется отдельно от своих вершин. При этом сохраняются поверхности смежных граней, но возможно изменение длины изменяемого ребра.

При выполнении переноса, поворота или масштабирования ребра, сопровождаемых двукратным нажатием и отпусканием клавиши CTRL во время перетаскивания, ребро изменяется вместе со своими вершинами (так же, как без нажатия клавиши CTRL). Однако, для плоских граней, смежных с вершинами изменяемого ребра, выполняется триангуляция (разделение на две или более плоские треугольные грани), если они становятся неплоскими.

Если клавиша CTRL нажимается и отпускается в третий раз, возвращается первый режим изменения, как если бы клавиша CTRL не нажималась.

Сопряжение граней и снятие фасок у 3D тел

С помощью команды СОПРЯЖЕНИЕ можно добавлять к выбранным 3D телам плавные переходы и сопряжения. Методом по умолчанию можно задать радиус сопряжения и далее выбрать ребра для сопряжения. Существуют и другие способы, в которых для каждой сопрягаемой грани задается свой радиус сопряжения или сопрягается последовательность ребер, переходящих одно в другое по касательной. Аналогично, снятие фасок на пересечениях смежных граней 3D тел осуществляется командой ФАСКА.

После выполнения команды СОПРЯЖЕНИЕ или ФАСКА для тела можно выбрать сопряжение или фаску и отредактировать свойства сопряжения или фаски в палитре "Свойства".

При применении сопряжения или фаски к ребру тела удаляется журнал тела.

Изменение цвета ребер

Для изменения цвета ребра на 3D объекте можно выбрать ребро и изменить свойство "Цвет" в палитре "Свойства".

Копирование ребер

Имеется возможность индивидуального копирования ребер 3D тел. В результате копирования образуются отрезки, дуги, круги, эллипсы и сплайны. Если указать две точки, первая будет использоваться как базовая точка и одна копия будет размещена относительно базовой точки. Если указать одну точку и затем нажать клавишу ENTER, исходная точка выбора используется как базовая точка, а следующая точка используется как точка смещения.

См. также

    • Перемещение, поворот и масштабирование подобъектов

    • Использование инструментов ручек для редактирования объектов

    • Редактирование объектов

    • Перемещение или поворот объектов

    • Изменение размеров и форм объектов


Редактирование ребер на 3D телах (Процедура)

Копирование, удаление и окрашивание граней на 3D телах
На уровень вверх ..
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование ребер на 3D телах >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Для сопряжения граней тела

Снятие фаски на 3D теле

Для редактирования сопряжения или фаски на 3D теле

Для изменения цвета ребра тела

Для копирования ребра тела


Для сопряжения граней тела (Процедура)

Редактирование ребер на 3D телах
На уровень вверх ..
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование ребер на 3D телах >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Для сопряжения граней тела

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Сопряжение". В командной строке введите "сопряжение".
  2. Выберите ребро тела для сопряжения.
  3. Задайте радиус сопряжения.
  4. Продолжите выбор ребер или нажмите ENTER для перехода к построению сопряжения.
Ввод команды: СОПРЯЖЕНИЕ


Снятие фаски на 3D теле (Процедура)

Редактирование ребер на 3D телах
На уровень вверх ..
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование ребер на 3D телах >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Снятие фаски на 3D теле

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "Фаска". В командной строке введите "фаска".
  2. Выберите ребро базовой грани для фаски (1).

    Выделяется одна из двух поверхностей, смежных с выбранным ребром.

  3. Для перехода к следующей грани введите с (сменить); для подтверждения работы с текущей выделенной гранью нажать ENTER.
  4. Задайте длину фаски для базовой грани.

    Длина фаски для базовой грани измеряется от выбранного ребра до точки на базовой грани. Длина фаски для смежной грани измеряется от выбранного ребра до точки на смежной грани.

  5. Задайте длину фаски для смежной грани.

    Опция "Периметр" выбирает для снятия фаски все ребра базовой грани; опция "Выберите ребро" позволяет выбрать ребра вручную.

  6. Указать ребра, на которых необходимо снять фаски (2).

Ввод команды: ФАСКА


Для редактирования сопряжения или фаски на 3D теле (Процедура)

Редактирование ребер на 3D телах
На уровень вверх ..
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование ребер на 3D телах >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Для редактирования сопряжения или фаски на 3D теле

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Выберите сопряжение или фаску на 3D теле.
  3. Если палитра "Свойства" не отображается, выберите меню Сервис [image] Палитры [image] Свойства.
  4. В палитре "Свойства" измените свойства сопряжения или фаски.
Ввод команды: ОКНОСВ


Для изменения цвета ребра тела (Процедура)

Редактирование ребер на 3D телах
На уровень вверх ..
Редактирование ребер на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование ребер на 3D телах >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Для изменения цвета ребра тела

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на ребре 3D тела.
  3. Если палитра "Свойства" не отображается, выберите меню Сервис [image] Палитры [image] Свойства.
  4. В палитре "Свойства" нажмите на "Цвет" на вкладке "Общие".

    Справа от поля располагается кнопка со стрелкой.

  5. Нажмите на кнопку и выберите цвет из списка или воспользуйтесь пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В этом случае выполните одно из следующих действий:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ИЦА (от 1 до 255).
    • На вкладке "Вся палитра" выберите цветовую модель "HSL" и задайте цвет путем ввода значения цвета в поле "Цвет" или задания значений в полях "H" (Цвет), "S" (Насыщенность) и "L" (Яркость). Нажмите "ОК".
    • На вкладке "Вся палитра" выберите цветовую модель "RGB" в списке "Цветовая модель". Задайте цвет путем введения его значения в поле "Цвет" или введением значений в полях "Красный", "Зеленый" и "Синий".
    • На вкладке "Альбомы цветов" выберите из списка альбом цветов и выберите цвет нажатием на цветовой полоске при перемещении по альбому цветов (с помощью стрелок вверх или вниз). Нажмите "ОК".
    Ввод команды: ОКНОСВ


Для копирования ребра тела (Процедура)

Редактирование ребер на 3D телах
На уровень вверх ..
Редактирование вершин на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование ребер на 3D телах >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Для копирования ребра тела

  1. Выберите меню Редактирование [image] Редактирование тела [image] Копировать грани.В командной строке введите "редтел".
  2. Выберите ребро для копирования (1).
  3. Выберите дополнительные ребра или нажмите ENTER.
  4. Укажите базовую точку перемещения (2).
  5. Укажите вторую точку перемещения (3).
  6. Нажмите ENTER для выполнения команды.

Панель:Редактирование тела
Ввод команды: РЕДТЕЛ


Редактирование ребер на 3D телах (Краткий справочник)

Копирование, удаление и окрашивание граней на 3D телах
Редактирование ребер на 3D телах
Редактирование вершин на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование ребер на 3D телах >
Редактирование ребер на 3D телах
Понятие Процедура Краткий справочник

Команды

КРОМКА

Изменение видимости кромок 3D грани

ФАСКА

Построение фасок в местах пересечения объектов

СОПРЯЖЕНИЕ

Скругление углов и сопряжение объектов

ПЕРЕНЕСТИ

Перемещение объектов на заданное расстояние в указанном направлении

ПОВЕРНУТЬ

Поворот объекта вокруг базовой точки

МАСШТАБ

Увеличение или уменьшение выбранных объектов с сохранением пропорций

РЕДТЕЛ

Редактирование граней и ребер 3D тел

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование вершин на 3D телах (Понятие)

Редактирование ребер на 3D телах
Выбор и редактирование 3D подобъектов
Сжатие или вытягивание ограниченных областей
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов >
Редактирование вершин на 3D телах
Понятие Процедура Краткий справочник

Имеется возможность выбора и редактирования вершин на 3D телах. Выбор левой кнопкой мыши и перетаскивание вершины приводит к "растягиванию" 3D объекта.

Можно также отредактировать всю форму 3D тела путем изменения одной или нескольких вершин с помощью ручек, инструментов ручек или с помощью команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ или МАСШТАБ. При масштабировании вершин следует масштабировать две или большее количество вершин и следить за изменениями в теле.

Когда выполняется перемещение, поворот или масштабирование одной или нескольких вершин в 3D элементарном теле, удаляется журнал этого элементарного тела. Тело не является более истинно элементарным и не доступно для манипулирования в качестве такого тела (с помощью ручек и палитры "Свойства").

Можно также удалять вершины, соединяющие два ребра, являющихся параллельными и коллинеарными и не совмещенными по расположению с какими-либо другими ребрами.

Режимы изменения вершины

Для циклического перебора вариантов изменения нажмите клавишу CTRL при перетаскивании вершины.

При выполнении переноса, поворота или масштабирования вершины без нажатия клавиши CTRL для некоторых плоских граней может быть проведена триангуляция (разделение на две или более плоские треугольные грани).

При выполнении переноса, поворота или масштабирования вершины, сопровождаемых однократным нажатием и отпусканием клавиши CTRL может производиться регулировка некоторых смежных плоских граней.

Если клавиша CTRL нажимается и отпускается во второй раз, возвращается первый режим изменения, как если бы клавиша CTRL не нажималась.

См. также

    • Перемещение, поворот и масштабирование подобъектов

    • Использование инструментов ручек для редактирования объектов

    • Редактирование объектов


Редактирование вершин на 3D телах (Процедура)

Редактирование ребер на 3D телах
На уровень вверх ..
Редактирование вершин на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование вершин на 3D телах >
Редактирование вершин на 3D телах
Понятие Процедура Краткий справочник

Для редактирования вершины на 3D объекте

Для удаления вершины на 3D объекте


Для редактирования вершины на 3D объекте (Процедура)

Редактирование вершин на 3D телах
На уровень вверх ..
Редактирование вершин на 3D телах
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование вершин на 3D телах >
Редактирование вершин на 3D телах
Понятие Процедура Краткий справочник

Для редактирования вершины на 3D объекте

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Щелкните на вершине 3D объекта.
  3. Отпустите CTRL.
  4. Нажмите левую кнопку мыши на вершине и перетащите вершину в требуемое место.


Для удаления вершины на 3D объекте (Процедура)

Редактирование вершин на 3D телах
На уровень вверх ..
Сжатие или вытягивание ограниченных областей
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование вершин на 3D телах >
Редактирование вершин на 3D телах
Понятие Процедура Краткий справочник

Для удаления вершины на 3D объекте

  1. Нажмите и удерживайте нажатой клавишу CTRL.
  2. Нажмите левую кнопку мыши на вершине 3D объекта, где соединяются два ребра, являющихся параллельными и коллинеарными и не совмещенными по расположению с какими-либо другими ребрами.
  3. Отпустите CTRL.
  4. Нажмите DELETE.


Редактирование вершин на 3D телах (Краткий справочник)

Редактирование ребер на 3D телах
Редактирование вершин на 3D телах
Сжатие или вытягивание ограниченных областей
Работа с 3D моделями > Изменение 3D тел и поверхностей > Выбор и редактирование 3D подобъектов > Редактирование вершин на 3D телах >
Редактирование вершин на 3D телах
Понятие Процедура Краткий справочник

Команды

ПЕРЕНЕСТИ

Перемещение объектов на заданное расстояние в указанном направлении

ПОВЕРНУТЬ

Поворот объекта вокруг базовой точки

МАСШТАБ

Увеличение или уменьшение выбранных объектов с сохранением пропорций

РЕДТЕЛ

Редактирование граней и ребер 3D тел

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Сжатие или вытягивание ограниченных областей (Понятие)

Редактирование вершин на 3D телах
Изменение 3D тел и поверхностей
Использование инструментов ручек для редактирования объектов
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Сжатие или вытягивание ограниченных областей
Понятие Процедура Краткий справочник

Для сжатия или вытягивания ограниченных областей можно нажать CTRL + ALT и, удерживая их нажатыми, указать на область. Область должна быть ограничена копланарными линиями или кромками.

Можно сжимать или вытягивать ограниченные области, определяемые объектами указанных ниже типов.

  • Любая область, которую можно штриховать путем выборки точек (с нулевым допуском замкнутости).
  • Области, замыкаемые пересечением копланарныхх линейных объектов, включая кромки и геометрические объекты в блоках
  • Замкнутые полилинии, области, 3D грани и 2D тела, состоящие из копланарных вершин
  • Области, создаваемые геометрией (включая ребра на гранях), вычерчиваемой копланарно любой грани 3D тела

Показать: "Сжатие ограниченной области"

Для запуска анимации щелкните на стрелке "Просмотр".

Сжимая или вытягивая ограниченную область, нельзя ее сужать. Однако можно выбирать ребра ограниченной области после ее сжатия или вытягивания и манипулировать ребрами для получения такого же эффекта.

Системная переменная IMPLIEDFACE позволяет указывать, допускается ли обнаружение ограниченной области и ее сжатие или вытягивание.

ПримечаниеЕсли выдавливается существующая грань на 3D теле, создается новый выдавливаемый объект.


Для сжатия или вытягивания ограниченной области (Процедура)

Редактирование вершин на 3D телах
Сжатие или вытягивание ограниченных областей
Использование инструментов ручек для редактирования объектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Сжатие или вытягивание ограниченных областей >
Сжатие или вытягивание ограниченных областей
Понятие Процедура Краткий справочник

Для сжатия или вытягивания ограниченной области

  1. Нажмите и удерживайте нажатыми CTRL + ALT.
  2. Нажмите левую кнопку мыши в любой области, ограничиваемой копланарными линиями или ребрами.
  3. Перетаскиванием указателя мыши сожмите или вытяните ограниченную область.
  4. Укажите высоту щелчком кнопкой мыши или введите численное значение высоты.
Панель:Моделирование
Ввод команды: ВЫДАВГРАНЬ


Сжатие или вытягивание ограниченных областей (Краткий справочник)

Редактирование вершин на 3D телах
Сжатие или вытягивание ограниченных областей
Понятие об инструментах ручки
Работа с 3D моделями > Изменение 3D тел и поверхностей > Сжатие или вытягивание ограниченных областей >
Сжатие или вытягивание ограниченных областей
Понятие Процедура Краткий справочник

Команды

ВЫДАВГРАНЬ

Сжатие или растяжение ограниченной области

Системные переменные

IMPLIEDFACE

Управление обнаружением предполагаемых граней

Утилиты

Нет

Ключевые слова для команд

Нет


Использование инструментов ручек для редактирования объектов

Сжатие или вытягивание ограниченных областей
Изменение 3D тел и поверхностей
Понятие об инструментах ручки
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Использование инструментов ручек для редактирования объектов
Понятие Процедура

Инструменты ручки можно использовать для перемещения и вращения объектов и подобъектов в 3D виде. Инструменты ручки отображаются при выборе объектов и подобъектов в 3D виде с применением 3D визуального стиля или при использовании команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ.

Темы в этом разделе

  • Понятие об инструментах ручки

    Инструменты ручек представляют собой значки, используемые в 3D виде для того, чтобы простым способом ограничивать перемещение или вращение выбранного набора объектов до оси или плоскости.

  • Использование инструмента ручки перемещения для редактирования объектов

    Инструмент ручки перемещения позволяет перемещать выбранный набор объектов без ограничений или с ограничением позицией оси или плоскости.

  • Использование инструмента ручки вращения для редактирования объекта

    Инструмент ручки вращения позволяет вращать объекты и подобъекты без ограничений или с ограничением позицией оси.


Использование инструментов ручек для редактирования объектов (Процедура)

Сжатие или вытягивание ограниченных областей
Использование инструментов ручек для редактирования объектов
Понятие об инструментах ручки
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов >
Использование инструментов ручек для редактирования объектов
Понятие Процедура

Определение начального местоположения по умолчанию для инструментов ручки

Для перемещения инструмента ручки

Изменение типа инструмента ручки при переносе или повороте объектов

Для перемещения объектов в 3D пространстве вдоль указанной оси

Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости.

Для вращения объектов в 3D пространстве вдоль указанной оси


Понятие об инструментах ручки (Понятие)

Использование инструментов ручек для редактирования объектов
Использование инструментов ручек для редактирования объектов
Использование инструмента ручки перемещения для редактирования объектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов >
Понятие об инструментах ручки
Понятие Процедура Краткий справочник

Инструменты ручек представляют собой значки, используемые в 3D виде для того, чтобы простым способом ограничивать перемещение или вращение выбранного набора объектов до оси или плоскости.

Имеются инструменты ручек двух типов: ручки перемещения и ручки вращения.

Инструменты ручек отображаются путем вызова команд 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ или нажатием на кнопки "3D Перенести" и "3D Повернуть" на ленте.

Инструменты ручек могут располагаться в любых местах 3D пространства. Данное местоположение (обозначаемое центральным прямоугольником [или базовой ручкой] инструмента ручки) определяет базовую точку для перемещения или вращения. Это равносильно временному изменению расположения в координатах ПСК во время перемещения или вращения выбранных объектов. Далее используются линии (ручки осей) инструмента ручки для ограничения перемещения или вращения позицией оси или плоскости.

Если сначала выбираются объекты, а затем нажимается кнопка мыши на рукоятке осей, и начинается перемещение выбранных объектов, для перехода к инструменту ручки поворота можно нажать клавишу ПРОБЕЛ. Повторное нажатие клавиши ПРОБЕЛ осуществляет возврат к инструменту ручки переноса. При таком способе изменения инструмента ручек перемещение ограничено выбранными осями.

Если запустить команду 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ перед выбором объектов, инструмент ручки присоединяется к курсору после создания набора объектов пользователем. Далее можно нажатием левой кнопки мыши поместить инструмент ручки в любое место 3D пространства. Для перемещения инструмента ручки можно нажать кнопку мыши на центральном прямоугольнике (базовой ручке) и далее нажатием кнопки указать новое расположение.

Инструменты ручки отображаются только в 3D виде, к которому применен 3D визуальный стиль. Если применен визуальный стиль 2D каркаса, то команды 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ автоматически заменяют этот стиль визуальным стилем 3D каркаса.

Если вначале выбираются объекты и далее вызывается команда 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ для отображения инструмента ручки, то по умолчанию отображается инструмент ручки перемещения, который помещается в то же место, что и в ПСК, и выравнивается по этому месту. Можно использовать системную переменную GTLOCATION с целью определения начального расположения по умолчанию для инструмента ручки.

Системная переменная GTAUTO используется для определения того, происходит ли автоматическое отображение инструментов ручки при выборе объектов перед запуском команды в 3D виде, к которому применен 3D визуальный стиль.

Системная переменная GTDEFAULT определяет, вызываются ли команды 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ автоматически при запуске команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде. По умолчанию, команды 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ не вызываются автоматически при запуске команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде


Понятие об инструментах ручки (Процедура)

Использование инструментов ручек для редактирования объектов
На уровень вверх ..
Понятие об инструментах ручки
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Понятие об инструментах ручки >
Понятие об инструментах ручки
Понятие Процедура Краткий справочник

Определение начального местоположения по умолчанию для инструментов ручки

Для перемещения инструмента ручки

Изменение типа инструмента ручки при переносе или повороте объектов


Определение начального местоположения по умолчанию для инструментов ручки (Процедура)

Понятие об инструментах ручки
На уровень вверх ..
Понятие об инструментах ручки
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Понятие об инструментах ручки >
Понятие об инструментах ручки
Понятие Процедура Краткий справочник

Определение начального местоположения по умолчанию для инструментов ручки

  1. В командной строке введите команду gtlocation.
  2. Выполните одно из следующих действий:
    • Введите 0 для определения местоположения, совпадающего с местоположением в ПСК.
    • Введите 1 для выбора в качестве места расположения позицию последнего выбранного объекта или подобъекта.
  3. Нажмите ENTER.


Для перемещения инструмента ручки (Процедура)

Понятие об инструментах ручки
На уровень вверх ..
Понятие об инструментах ручки
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Понятие об инструментах ручки >
Понятие об инструментах ручки
Понятие Процедура Краткий справочник

Для перемещения инструмента ручки

  1. Нажмите кнопку мыши на центральном прямоугольнике (базовой ручке) инструмента ручки.
  2. Нажатием левой кнопки мыши обозначьте новое местоположение.


Изменение типа инструмента ручки при переносе или повороте объектов (Процедура)

Понятие об инструментах ручки
На уровень вверх ..
Использование инструмента ручки перемещения для редактирования объектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Понятие об инструментах ручки >
Понятие об инструментах ручки
Понятие Процедура Краткий справочник

Изменение типа инструмента ручки при переносе или повороте объектов

  1. Выберите объекты и подобъекты для переноса или поворота.

    Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL для выбора объектов.

    Знак ПСК превращается в инструмент ручки перемещения.

  2. (Если необходимо) Нажмите на базовой ручке инструмента ручки, затем нажмите кнопку мыши, чтобы указать новое местоположение (базовую точку для операции)
  3. Удерживайте курсор на рукоятке оси на инструменте ручки, пока рукоятка оси не станет желтой и не появится вектор, затем нажмите левую кнопку мыши на рукоятке оси.
  4. Нажмите клавишу ПРОБЕЛ.

    Инструмент ручки перемещения превращается в инструмент ручки поворота. Повторное нажатие клавиши ПРОБЕЛ осуществляет возврат к инструменту ручки переноса. При таком способе изменения инструмента ручек перемещение ограничено выбранными осями.

ПримечаниеНельзя применять клавишу пробела для изменения типа инструмента ручки при использовании команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ.


Понятие об инструментах ручки (Краткий справочник)

Сжатие или вытягивание ограниченных областей
Понятие об инструментах ручки
Использование инструмента ручки перемещения для редактирования объектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Понятие об инструментах ручки >
Понятие об инструментах ручки
Понятие Процедура Краткий справочник

Команды

3DПЕРЕНЕСТИ

Отображение инструмента ручки перемещения в 3D виде и перемещение объектов на указанное расстояние в заданном направлении

3DПОВЕРНУТЬ

Отображение ручки поворота на 3D виде и вращение объектов вокруг базовой точки

Системные переменные

GTAUTO

Управление автоматическим отображением инструментов ручек при выборе объектов перед запуском команды в видовом экране, для которого задан 3D стиль отображения

GTDEFAULT

Управление автоматическим выполнением команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ при выполнении команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде

GTLOCATION

Управление первоначальным расположением инструментов ручек, если выбор объектов производится до выполнения команд 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ

Утилиты

Нет

Ключевые слова для команд

Нет


Использование инструмента ручки перемещения для редактирования объектов (Понятие)

Понятие об инструментах ручки
Использование инструментов ручек для редактирования объектов
Использование инструмента ручки вращения для редактирования объекта
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов >
Использование инструмента ручки перемещения для редактирования объектов
Понятие Процедура Краткий справочник

Инструмент ручки перемещения позволяет перемещать выбранный набор объектов без ограничений или с ограничением позицией оси или плоскости.

После выбора объектов и подобъектов, которые необходимо переместить, следует поместить инструмент ручки в любое место в 3D пространстве. Данное местоположение (обозначаемое центральным прямоугольником [или базовой ручкой] инструмента ручки) определяет базовую точку для перемещения и на время изменяет позицию в координатах ПСК в процессе перемещения выбранных объектов.

Далее следует свободно перемещать объекты путем перетаскивания инструмента ручки к наружной стороне или обозначить ось или плоскость, которой ограничивается перемещение.

ПримечаниеПо умолчанию, при создании набора объектов в 3D виде, к которому применен 3D визуальный стиль перед вызовом команды, автоматически отображается инструмент ручки перемещения. Можно отменить автоматическое отображение инструмента ручки перемещения, установив системную переменную GTAUTO равной 0.

Ограничение перемещения позицией оси

Можно использовать инструмент ручки перемещения для ограничения перемещения позицией оси. Следует удерживать курсор на ручке оси на инструменте ручки, пока отображаемый вектор не совпадет по расположению с осью, и далее нажать левую кнопку мыши на рукоятке оси.

При последующем перетаскивании курсора выбранные объекты и подобъекты перемещаются только вдоль указанной оси. Можно нажать левую кнопку мыши или ввести значение для обозначения расстояния смещения от базовой точки.

Ограничение перемещения позицией плоскости

Можно использовать инструмент ручки перемещения для ограничения перемещения позицией плоскости. Следует удерживать курсор на точке, в которой сходятся две линии, отходящие от рукояток оси (эти линии определяют плоскость), пока линии не станут желтыми, а затем нажать левую кнопку мыши на данной точке.

При последующем перетаскивании курсора выбранные объекты и подобъекты перемещаются только вдоль указанной плоскости. Можно нажать левую кнопку мыши или ввести значение для обозначения расстояния смещения от базовой точки.


Использование инструмента ручки перемещения для редактирования объектов (Процедура)

Понятие об инструментах ручки
На уровень вверх ..
Использование инструмента ручки перемещения для редактирования объектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Использование инструмента ручки перемещения для редактирования объектов >
Использование инструмента ручки перемещения для редактирования объектов
Понятие Процедура Краткий справочник

Для перемещения объектов в 3D пространстве вдоль указанной оси

Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости.


Для перемещения объектов в 3D пространстве вдоль указанной оси (Процедура)

Использование инструмента ручки перемещения для редактирования объектов
На уровень вверх ..
Использование инструмента ручки перемещения для редактирования объектов
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Использование инструмента ручки перемещения для редактирования объектов >
Использование инструмента ручки перемещения для редактирования объектов
Понятие Процедура Краткий справочник

Для перемещения объектов в 3D пространстве вдоль указанной оси

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "3D Перенести". В командной строке введите "3dперенести".
  2. Выберите объекты и подобъекты, которые необходимо переместить.

    Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL для выбора объектов.

  3. По окончании выбора объектов нажмите ENTER.

    Инструмент ручки перемещения отображается в соединении с курсором.

  4. Нажатием левой кнопки мыши выберите местоположение захватного блока, обозначая базовую точку для перемещения.
  5. Удерживать курсор на ручке оси на захватном блоке, пока рукоятка оси не станет желтой и не появится вектор, а затем нажмите левую кнопку мыши на рукоятке оси.

  6. Введите значение или нажмите левую кнопку мыши для обозначения расстояния перемещения.
Панель:Моделирование
Ввод команды: 3DПЕРЕНЕСТИ


Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости. (Процедура)

Использование инструмента ручки перемещения для редактирования объектов
На уровень вверх ..
Использование инструмента ручки вращения для редактирования объекта
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Использование инструмента ручки перемещения для редактирования объектов >
Использование инструмента ручки перемещения для редактирования объектов
Понятие Процедура Краткий справочник

Для перемещения объектов в 3D пространстве с ограничением по указанной плоскости.

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "3D Перенести". В командной строке введите "3dперенести".
  2. Выберите объекты и подобъекты, которые необходимо переместить.

    Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL для выбора объектов.

  3. По окончании выбора объектов нажмите ENTER.

    Инструмент ручки перемещения отображается в соединении с курсором.

  4. Щелчком выберите местоположение инструмента ручки, обозначая базовую точку для перемещения.
  5. Удерживать курсор на точке, в которой сходятся две линии, отходящие от рукояток оси (эти линии определяют плоскость), пока линии не станут желтыми, а затем нажмите левую кнопку мыши.

  6. Введите значение или нажмите левую кнопку мыши для обозначения расстояния перемещения.
Панель:Моделирование
Ввод команды: 3DПЕРЕНЕСТИ


Использование инструмента ручки перемещения для редактирования объектов (Краткий справочник)

Понятие об инструментах ручки
Использование инструмента ручки перемещения для редактирования объектов
Использование инструмента ручки вращения для редактирования объекта
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Использование инструмента ручки перемещения для редактирования объектов >
Использование инструмента ручки перемещения для редактирования объектов
Понятие Процедура Краткий справочник

Команды

3DПЕРЕНЕСТИ

Отображение инструмента ручки перемещения в 3D виде и перемещение объектов на указанное расстояние в заданном направлении

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование инструмента ручки вращения для редактирования объекта (Понятие)

Использование инструмента ручки перемещения для редактирования объектов
Использование инструментов ручек для редактирования объектов
Добавление ребер и граней к телам
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов >
Использование инструмента ручки вращения для редактирования объекта
Понятие Процедура Краткий справочник

Инструмент ручки вращения позволяет вращать объекты и подобъекты без ограничений или с ограничением позицией оси.

После выбора объектов и подобъектов, которые необходимо вращать, следует поместить инструмент ручки в любое место в 3D пространстве. Данное местоположение (обозначаемое центральным прямоугольником [или базовой ручкой] инструмента ручки) определяет базовую точку для перемещения и на время изменяет позицию в координатах ПСК в процессе поворота выбранных объектов.

Далее можно вращать объекты без ограничений, перетаскивая инструмент ручки к наружной стороне, либо указывать ось, которой ограничивается поворот.

Ограничение угла поворота позицией оси

Можно использовать инструмент ручки вращения для ограничения угла поворота позицией оси. Следует удерживать курсор на одной из рукояток осей инструмента ручки, пока линия не станет желтой и не появится желтый вектор, совпадающий по расположению с осью. Далее нажмите левую кнопку мыши на осевой линии.

При последующем перетаскивании курсора выбранные объекты и подобъекты поворачиваются относительно базовой точки вдоль указанной оси. Можно ввести значение или нажать левую кнопку мыши для обозначения угла поворота.


Для вращения объектов в 3D пространстве вдоль указанной оси (Процедура)

Использование инструмента ручки перемещения для редактирования объектов
На уровень вверх ..
Добавление ребер и граней к телам
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Использование инструмента ручки вращения для редактирования объекта >
Использование инструмента ручки вращения для редактирования объекта
Понятие Процедура Краткий справочник

Для вращения объектов в 3D пространстве вдоль указанной оси

  1. Выберите вкладку "Главная" [image] панель "Редактирование" [image] "3D поворот". В командной строке введите "3dповернуть".
  2. Выберите объекты и подобъекты, которые необходимо вращать.

    Нажмите и удерживайте нажатой кнопку CTRL для выбора подобъектов (граней, ребер и вершин). Отпустите CTRL для выбора объектов.

  3. По окончании выбора объектов нажмите ENTER.

    Инструмент ручки вращения отображается в соединении с курсором.

  4. Нажатием левой кнопки мыши выберите местоположение инструмента ручки вращения, обозначая базовую точку для перемещения.
  5. Удерживайте курсор на рукоятке оси на инструменте ручки, пока рукоятка оси не станет желтой и не появится вектор, а затем нажмите левую кнопку мыши.

  6. Введите значение или нажмите левую кнопку мыши для обозначения угла вращения.
Панель:Моделирование
Ввод команды: 3DПОВЕРНУТЬ


Использование инструмента ручки вращения для редактирования объекта (Краткий справочник)

Использование инструмента ручки перемещения для редактирования объектов
Использование инструмента ручки вращения для редактирования объекта
Добавление ребер и граней к телам
Работа с 3D моделями > Изменение 3D тел и поверхностей > Использование инструментов ручек для редактирования объектов > Использование инструмента ручки вращения для редактирования объекта >
Использование инструмента ручки вращения для редактирования объекта
Понятие Процедура Краткий справочник

Команды

3DПОВЕРНУТЬ

Отображение ручки поворота на 3D виде и вращение объектов вокруг базовой точки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление ребер и граней к телам (Понятие)

Использование инструмента ручки вращения для редактирования объекта
Изменение 3D тел и поверхностей
Разделение 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Добавление ребер и граней к телам
Понятие Процедура Краткий справочник

Внешний вид граней 3D тел можно изменять путем их клеймения различными объектами, пересекающими грани. При клеймении объект объединяется с гранью, создавая ребро.

Показать: "Добавление ребра, разделение грани на две"

Для запуска анимации щелкните на стрелке "Показать".

С помощью команды КЛЕЙМО AutoCAD позволяет создавать на 3D телах новые грани путем их клеймения дугами, кругами, отрезками, 2D и 3D полилиниями, эллипсами, сплайнами, областями и другими телами. Например, для пересекаемого кругом 3D тела можно выполнить клеймение кривой пересечения. Использованные для клеймения тел объекты можно удалить из чертежа или оставить в нем. Для того чтобы клеймение могло быть успешно выполнено, необходимо наличие пересечения клеймящего объекта и грани (граней) выбранного тела.

В некоторых случаях невозможно выполнение переноса, поворота или масштабирования следующих объектов, и клейменые ребра и грани могут быть утрачены, если выполняется перенос, поворот или масштабирование следующих подобъектов:

  • граней, содержащих клейменые ребра или грани
  • ребер или вершин со смежными гранями, содержащими клейменые ребра или грани
ПримечаниеПри клеймении ребра на грани тела возможен перенос ребер клейменой грани только вместе с плоскостью этой грани.


Для клеймения тела (Процедура)

Использование инструмента ручки вращения для редактирования объекта
Добавление ребер и граней к телам
Разделение 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Добавление ребер и граней к телам >
Добавление ребер и граней к телам
Понятие Процедура Краткий справочник

Для клеймения тела

  1. Выберите менюРедактирование [image] Редактирование тела [image] Клеймить.В командной строке введите "клеймо".
  2. Выберите 3D тело (1).
  3. Выберите клеймящий объект (2).
  4. Нажмите ENTER для сохранения исходных объектов или введите у для их удаления.
  5. Выберите дополнительные объекты для клеймения или нажмите ENTER.
  6. Нажмите ENTER для выполнения команды.

Панель:Редактирование тела
Ввод команды: КЛЕЙМО


Добавление ребер и граней к телам (Краткий справочник)

Использование инструмента ручки вращения для редактирования объекта
Добавление ребер и граней к телам
Разделение 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Добавление ребер и граней к телам >
Добавление ребер и граней к телам
Понятие Процедура Краткий справочник

Команды

Нет

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Разделение 3D тел (Понятие)

Добавление ребер и граней к телам
Изменение 3D тел и поверхностей
Создание оболочек из 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Разделение 3D тел
Понятие Процедура Краткий справочник

3D тела могут быть разделены на исходные компонентные 3D тела.

Составные тела могут быть разделены (расчленены) на составляющие. Данная операция применима только к составным 3D телам, части которых не обладают общим объемом. Тела, полученные в результате разделения 3D тела, наследуют слой и цвет исходного объекта. Все 3D тела с уровнями вложений разделяются на составляющие самого низкого уровня вложения.


Для разделения составного 3D тела на отдельные части (Процедура)

Добавление ребер и граней к телам
Разделение 3D тел
Создание оболочек из 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Разделение 3D тел >
Разделение 3D тел
Понятие Процедура Краткий справочник

Для разделения составного 3D тела на отдельные части

  1. Выберите меню Редактирование [image] Редактирование тела [image] Разделить.В командной строке введите "редтел".
  2. Выберите 3D тело.
  3. Нажмите ENTER для выполнения команды.
Панель:Редактирование тела
Ввод команды: РЕДТЕЛ


Разделение 3D тел (Краткий справочник)

Добавление ребер и граней к телам
Разделение 3D тел
Создание оболочек из 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Разделение 3D тел >
Разделение 3D тел
Понятие Процедура Краткий справочник

Команды

РЕДТЕЛ

Редактирование граней и ребер 3D тел

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание оболочек из 3D тел (Понятие)

Разделение 3D тел
Изменение 3D тел и поверхностей
Упрощение и проверка корректности 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Создание оболочек из 3D тел
Понятие Процедура Краткий справочник

Можно создать оболочку (тонкостенный полый объем заданной толщины) из 3D тела.

Новые грани создаются путем смещения существующих граней в ту или иную сторону от исходных позиций. Грани, переходящие друг в друга по касательной, считаются при создании оболочки единой гранью.


Для создания оболочки (Процедура)

Разделение 3D тел
Создание оболочек из 3D тел
Упрощение и проверка корректности 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Создание оболочек из 3D тел >
Создание оболочек из 3D тел
Понятие Процедура Краткий справочник

Для создания оболочки

  1. Выберите меню Редактирование [image] Редактирование тела [image] Оболочка.В командной строке введите "редтел".
  2. Выберите 3D тело.
  3. Выберите грань, исключаемую из оболочки (1).
  4. Выберите дополнительные исключаемые грани или нажмите ENTER.
  5. Задайте толщину стенок оболочки.

    При положительном значении толщины новые грани оболочки создаются с положительной стороны от исходных; при отрицательном значении - с отрицательной стороны.

  6. Нажмите ENTER для выполнения команды.

Панель:Редактирование тела
Ввод команды: РЕДТЕЛ


Создание оболочек из 3D тел (Краткий справочник)

Разделение 3D тел
Создание оболочек из 3D тел
Упрощение и проверка корректности 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Создание оболочек из 3D тел >
Создание оболочек из 3D тел
Понятие Процедура Краткий справочник

Команды

РЕДТЕЛ

Редактирование граней и ребер 3D тел

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Упрощение и проверка корректности 3D тел (Понятие)

Создание оболочек из 3D тел
Изменение 3D тел и поверхностей
Построение сечений и 2D чертежей из 3D моделей
Работа с 3D моделями > Изменение 3D тел и поверхностей >
Упрощение и проверка корректности 3D тел
Понятие Процедура Краткий справочник

С помощью команды РЕДТЕЛ имеется возможность автоматического удаления избыточных граней, ребер и вершин 3D тел, а также выполнения проверки на корректность тела.

Можно удалять ребра или вершины, если они находятся на одной и той же поверхности или имеют одно и то же определение вершины на любой стороне ребра или вершины. Тело, грани или ребра на теле отмечаются, а смежные грани, которые находятся на той же поверхности, объединяются. Удаляются все избыточные ребра в 3D теле, которые получены в результате клеймения или не используются.

Имеется возможность проверки, является ли используемое 3D тело корректным 3D телом. Если 3D тело корректно, можно редактировать объект, не вызывая сообщения об ошибках. Если 3D тело некорректно, редактирование объекта не допускается.


Упрощение и проверка корректности 3D тел (Процедура)

Создание оболочек из 3D тел
Упрощение и проверка корректности 3D тел
Упрощение и проверка корректности 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Упрощение и проверка корректности 3D тел >
Упрощение и проверка корректности 3D тел
Понятие Процедура Краткий справочник

Для упрощения тела

Для проверки целостности тела


Для упрощения тела (Процедура)

Упрощение и проверка корректности 3D тел
Упрощение и проверка корректности 3D тел
Упрощение и проверка корректности 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Упрощение и проверка корректности 3D тел >
Упрощение и проверка корректности 3D тел
Понятие Процедура Краткий справочник

Для упрощения тела

  1. Выберите меню Редактирование [image] Редактирование тела [image] Упростить.В командной строке введите "редтел".
  2. Выберите 3D тело (1).
  3. Нажмите ENTER для выполнения команды.

Панель:Редактирование тела
Ввод команды: РЕДТЕЛ


Для проверки целостности тела (Процедура)

Упрощение и проверка корректности 3D тел
Упрощение и проверка корректности 3D тел
Сечение 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Упрощение и проверка корректности 3D тел >
Упрощение и проверка корректности 3D тел
Понятие Процедура Краткий справочник

Для проверки целостности тела

  1. Выберите меню Редактирование [image] Редактирование тела [image] Проверить.В командной строке введите "редтел".
  2. Выберите 3D тело.
  3. Нажмите ENTER для выполнения команды.
Панель:Редактирование тела
Ввод команды: РЕДТЕЛ


Упрощение и проверка корректности 3D тел (Краткий справочник)

Создание оболочек из 3D тел
Упрощение и проверка корректности 3D тел
Сечение 3D тел
Работа с 3D моделями > Изменение 3D тел и поверхностей > Упрощение и проверка корректности 3D тел >
Упрощение и проверка корректности 3D тел
Понятие Процедура Краткий справочник

Команды

РЕДТЕЛ

Редактирование граней и ребер 3D тел

Системные переменные

SOLIDCHECK

Включение и отключение проверки тела для текущего сеанса

Утилиты

Нет

Ключевые слова для команд

Нет


Построение сечений и 2D чертежей из 3D моделей

Упрощение и проверка корректности 3D тел
Работа с 3D моделями
Сечение 3D тел
Работа с 3D моделями >
Построение сечений и 2D чертежей из 3D моделей

Предусмотрена возможность построения поперечного сечения 3D тела с помощью пересечения плоскости и твердотельных объектов для создания области. Можно также использовать режущую плоскость, называемую объект-сечение, которая позволяет рассматривать в режиме реального времени виды поперечных сечений в 3D модели. Виды сечений можно зафиксировать в качестве плоскостных представлений.

Темы в этом разделе

  • Сечение 3D тел

    Имеется возможность построения поперечного сечения 3D тела. Результатом является двумерный объект, имеющий форму соответствующего сечения. Предусмотрена также возможность использования режущей плоскости, называемой объект-сечение, которая позволяет увидеть в режиме реального времени профиль разреза пересечённых тел.

  • Работа с объектами-сечениями

    Можно строить виды сечений из 3D моделей, определяемые тем, в каком месте прозрачная режущая плоскость, называемая объект-сечение, пересекает модель. Если на объекте-сечении активна функция псевдоразреза, можно увидеть внутренние детали модели при неподвижной режущей плоскости или при её перемещении через 3D модель. Применение псевдоразреза позволяет динамически изменять профиль среза пересекаемого тела.

  • Применение псевдоразреза

    Если для объекта-сечения включена функция псевдоразреза, в пространстве модели можно динамически строить сечения 3D модели. При перемещении объекта-сечения через 3D модель его прозрачный указатель секущей плоскости разрезает тело, поверхность или область в режиме реального времени.

  • Создание 2D и 3D сечений

    Предусмотрена возможность создания представления области поперечного сечения в виде 2D или 3D блока в месте пересечения 3D модели объектом-сечением.

  • Создание плоского вида

    Командой ПЛОСКСНИМОК создаётся плоский вид всех 3D тел и областей текущего вида.


Сечение 3D тел (Понятие)

Построение сечений и 2D чертежей из 3D моделей
Построение сечений и 2D чертежей из 3D моделей
Работа с объектами-сечениями
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей >
Сечение 3D тел
Понятие Процедура Краткий справочник

Имеется возможность построения поперечного сечения 3D тела. Результатом является двумерный объект, имеющий форму соответствующего сечения. Предусмотрена также возможность использования режущей плоскости, называемой объект-сечение, которая позволяет увидеть в режиме реального времени профиль разреза пересечённых тел.

Команда СЕЧЕНИЕ позволяет построить поперечное сечение тела. Для определения плоскости поперечного сечения задаются три точки. Плоскость поперечного сечения можно определить также с помощью другого объекта, текущего вида, оси Z или плоскости XY, YZ или ZX. Плоскость поперечного сечения размещается на текущем слое.

Команда СЕКПЛОСКОСТЬ позволяет построить объект-сечение, который выступает в качестве режущей плоскости для тел, поверхностей или областей (двумерных областей, построенные на основе замкнутых контуров). Если включить функцию псевдоразреза, то при перемещении объекта-сечения через 3D модель в пространстве модели внутренние детали отображаются в режиме реального времени.

Для построения объекта-сечения нужно переместить курсор на любую грань 3D модели и нажать кнопку мыши для автоматического размещения объекта-сечения. Можно также указать точки для построения прямой режущей плоскости или указать несколько точек для построения плоскости, содержащей сегменты с изломами. Другой метод заключается в создании ортогонального вида, например, вида спереди, сверху или сзади.


Построение поперечного сечения тела (Процедура)

Упрощение и проверка корректности 3D тел
Сечение 3D тел
Работа с объектами-сечениями
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Сечение 3D тел >
Сечение 3D тел
Понятие Процедура Краткий справочник

Построение поперечного сечения тела

  1. Введитесечение в командной строке.
  2. Выберите объект для построения поперечного сечения.
  3. Задайте три точки для определения плоскости поперечного сечения.

Ввод команды: СЕЧЕНИЕ
ПримечаниеДля того чтобы заштриховать полученное сечение, необходимо вначале совместить ПСК с плоскостью поперечного сечения.


Сечение 3D тел (Краткий справочник)

Упрощение и проверка корректности 3D тел
Сечение 3D тел
Обзор объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Сечение 3D тел >
Сечение 3D тел
Понятие Процедура Краткий справочник

Команды

СЕЧЕНИЕ

Создание области на основе пересечения плоскости и тел

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с объектами-сечениями

Сечение 3D тел
Построение сечений и 2D чертежей из 3D моделей
Обзор объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей >
Работа с объектами-сечениями
Понятие Процедура

Можно строить виды сечений из 3D моделей, определяемые тем, в каком месте прозрачная режущая плоскость, называемая объект-сечение, пересекает модель. Если на объекте-сечении активна функция псевдоразреза, можно увидеть внутренние детали модели при неподвижной режущей плоскости или при её перемещении через 3D модель. Применение псевдоразреза позволяет динамически изменять профиль среза пересекаемого тела.

Темы в этом разделе

  • Обзор объектов-сечений
  • Построение объектов-сечений

    Объекты-сечения создаются с помощью команды СЕКПЛОСКОСТЬ .

  • Задание режимов объекта-сечения

    Объекты-сечения имеют три режима: "Секущая плоскость", "Контур сечения" и "Объем сечения". В зависимости от выбранного режима режущая плоскость представляется в виде 2D плоскости, 2D прямоугольника или 3D ящика. Ручки позволяют регулировать длину, ширину и высоту режущей области.

  • Применение ручек объекта-сечения

    При выборе объекта-сечения отображаются различные типы ручек, выполняющих разные функции. Существуют следующие ручки:

  • Открытие контекстного меню "Объект-сечение"

    Выбрав объект-сечение, можно получить доступ к следующим элементам управления в контекстном меню, нажав правой кнопкой мыши на секущей линии.

  • Изменить свойства объекта-сечения

    Объекты-сечения, точно так же, как и другие объекты AutoCAD, имеют свойства. Свойства хранятся в секущей линии и могут быть открыты в палитре свойств. Например, можно изменить имя объекта-сечения, слой и тип линий, а также цвет и прозрачность указателя секущей плоскости (прозрачная режущая плоскость объекта-сечения).

  • Связать объекты-сечения с видами и камерами

    Связывание объектов-сечений с именованными видами и камерами выполняется в диалоговом окне "Диспетчер видов".

  • Публикация объектов-сечений

    Предусмотрена возможность управления видимостью объектов-сечений во время их тонирования, вывода на печать или просмотра в программе просмотра DWF-файлов.

  • Сохранение объекта-сечения в качестве инструмента инструментальной палитры

    Аналогично другим объектам, из конкретных объектов-сечений можно создавать инструменты, доступные из инструментальной палитры.

  • Добавление изломов секущей плоскости

    Построение секущей линии с несколькими сегментами (изломами) осуществляется в режиме "Вычерчивание сечения" команды СЕКПЛОСКОСТЬ. Другой способ добавления излома к существующему объекту-сечению заключается в использовании пункта "Добавить излом секущей плоскости" контекстного меню.


Работа с объектами-сечениями (Процедура)

Сечение 3D тел
Работа с объектами-сечениями
Построение объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Работа с объектами-сечениями
Понятие Процедура

Создание объекта-сечения с помощью выбора грани

Создание объекта-сечения с использованием двух точек

Создание объекта-сечения с использованием сегментов с изломами

Создание объекта-сечения на предварительно заданной ортогональной плоскости

Изменение режима объекта-сечения с помощью ручки "Меню"

Переименование объекта-сечения

Изменение режима объекта-сечения с использованием палитры свойств

Изменение прозрачности и цвета указателя секущей плоскости

Изменение высоты указателя секущей плоскости

Связывание объекта-сечения с видом или камерой

Сохранение инструмента объекта-сечения в качестве инструмента инструментальной панели

Добавление изломов секущей плоскости


Обзор объектов-сечений (Понятие)

Работа с объектами-сечениями
Работа с объектами-сечениями
Построение объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Обзор объектов-сечений
Понятие Краткий справочник

С помощью команды СЕКПЛОСКОСТЬ можно построить один или несколько объектов-сечений и разместить их в объёме 3D модели. Активизирование функции псевдоразреза на объекте-сечении позволяет видеть динамические разрезы в 3D модели при перемещении через неё объекта-сечения, не изменяя при этом сами 3D объекты.

Объекты-сечения снабжены прозрачным указателем секущей плоскости, который действует как режущая плоскость. В силу прозрачности он является удобным визуальным инструментом, поскольку позволяет видеть геометрию с любой стороны режущей плоскости. Эту плоскость можно легко размещать и перемещать в любое место в пределах 3D модели, состоящей из 3D тел, поверхностей или областей (двумерных областей, построенных на основе замкнутых контуров).

Секущая плоскость включает секущую линию, в которой хранятся свойства объекта-сечения. Можно иметь несколько объектов-сечений, каждый из которых имеет индивидуальные свойства. Например, на одном объекте-сечении может отображаться штриховка в том месте, где пересекается 3D модель, в то время как на другом объекте-сечении может отображаться иной тип линий для обозначения границы пересечённой области.

Каждый объект-сечение может быть сохранён в качестве инструмента инструментальной палитры, что позволяет обеспечить к нему быстрый доступ без необходимости перенастройки свойств при очередном создании нового объекта-сечения.

Секущая плоскость может быть прямой линией или линией, имеющей несколько сегментов или имеющей сегменты с изломами. Например, секущая линия, содержащая излом, даёт возможность построить из цилиндра клин в форме куска пирога.

Объект-сечение с сегментом с изломом

После получения необходимого вида сечения можно выполнить генерацию точного 2D или 3D блока из 3D модели. Эти блоки можно анализировать или проверять на соблюдение зазоров и условий взаимодействия. Кроме этого, на них можно наносить размеры или использовать их в качестве каркасных или тонированных представлений в документации и презентационных чертежах.


Обзор объектов-сечений (Краткий справочник)

Сечение 3D тел
Обзор объектов-сечений
Построение объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Обзор объектов-сечений >
Обзор объектов-сечений
Понятие Краткий справочник

Команды

Нет

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Построение объектов-сечений (Понятие)

Обзор объектов-сечений
Работа с объектами-сечениями
Задание режимов объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Построение объектов-сечений
Понятие Процедура Краткий справочник

Объекты-сечения создаются с помощью команды СЕКПЛОСКОСТЬ .

Используемый по умолчанию способ заключается в перемещении курсора на грань 3D модели и размещении объекта-сечения последующим нажатием кнопки мыши. Объект-сечение автоматически выравнивается относительно плоскости выбранной грани.

Объект-сечение можно построить, выбрав две точки для создания прямой секущей линии.

На анимации показано построение объекта-сечения посредством задания двух точек. После построения и включения функции псевдоразреза объект-сечение перемещается в разные области модели; при этом построение сечений выполняется в режиме реального времени.

Показать: "Получение сечения 3D модели с помощью объекта-сечения (при включённой функции псевдоразреза)"

Для запуска анимации нажмите на стрелку "Показать".

Если требуется секущая линия, содержащая сегменты с изломами, в режиме "Вычерчивание сечения" можно указать несколько точек внутри 3D модели.

В режиме "Ортогональный" можно быстро построить объект-сечение, выровненный относительно предварительно выбранной ортогональной плоскости. Перед построением объекта-сечения оцениваются все 3D объекты чертежа и вычисляется воображаемая 3D граница, окружающая их. Затем объект-сечение располагается таким образом, чтобы он проходил через центр 3D контура и был ориентирован в сторону выбранной ортогональной плоскости.


Построение объектов-сечений (Процедура)

Работа с объектами-сечениями
На уровень вверх ..
Построение объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Построение объектов-сечений >
Построение объектов-сечений
Понятие Процедура Краткий справочник

Создание объекта-сечения с помощью выбора грани

Создание объекта-сечения с использованием двух точек

Создание объекта-сечения с использованием сегментов с изломами

Создание объекта-сечения на предварительно заданной ортогональной плоскости


Создание объекта-сечения с помощью выбора грани (Процедура)

Построение объектов-сечений
На уровень вверх ..
Построение объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Построение объектов-сечений >
Построение объектов-сечений
Понятие Процедура Краткий справочник

Создание объекта-сечения с помощью выбора грани

  1. Выберите меню Рисование [image] Моделирование [image] Секущая плоскость.В командной строке введите "секплоскость".
  2. Нажмите кнопку мыши для выбора грани на модели.

    На плоскости выбранной грани создаётся объект-сечение.

  3. Нажмите на секущей линии для отображения её ручек.
  4. Выберите ручку для перемещения секущей плоскости через 3D объект.

    Построенный объект-сечение имеет состояние "Секущая плоскость". Функция псевдоразреза включена.


Создание объекта-сечения с использованием двух точек (Процедура)

Построение объектов-сечений
На уровень вверх ..
Построение объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Построение объектов-сечений >
Построение объектов-сечений
Понятие Процедура Краткий справочник

Создание объекта-сечения с использованием двух точек

  1. Выберите меню Рисование [image] Моделирование [image] Секущая плоскость.В командной строке введите "секплоскость".
  2. Укажите первую точку объекта-сечения.
  3. Укажите конечную точку.

Объект-сечение строится между этими двумя точками. Функция псевдоразреза отключена.


Создание объекта-сечения с использованием сегментов с изломами (Процедура)

Построение объектов-сечений
На уровень вверх ..
Построение объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Построение объектов-сечений >
Построение объектов-сечений
Понятие Процедура Краткий справочник

Создание объекта-сечения с использованием сегментов с изломами

  1. Выберите меню Рисование [image] Моделирование [image] Секущая плоскость.В командной строке введите "секплоскость".
  2. Введите d ("Вычерчивание сечения").
  3. Укажите начальную точку объекта-сечения.
  4. Укажите вторую точку для построения первого сегмента с изломом.

    От этой точки невозможно построить пересекающиеся сегменты.

  5. Продолжайте задание конечных точек сегментов, затем нажмите клавишу ENTER.
  6. Задайте точку в направлении секущего разреза.

Создаётся объект-сечение с несколькими сегментами, имеющими состояние "Контур сечения". Функция псевдоразреза отключёна.


Создание объекта-сечения на предварительно заданной ортогональной плоскости (Процедура)

Построение объектов-сечений
На уровень вверх ..
Задание режимов объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Построение объектов-сечений >
Построение объектов-сечений
Понятие Процедура Краткий справочник

Создание объекта-сечения на предварительно заданной ортогональной плоскости

  1. Выберите меню Рисование [image] Моделирование [image] Секущая плоскость.В командной строке введите "секплоскость".
  2. Введите o (ортогонально).
  3. Выберите вариант выравнивания.

Создаётся объект-сечение, находящийся в центре воображаемого 3D контура, охватывающего все 3D объекты чертежа. Он размещается на выбранной ортогональной плоскости. Функция псевдоразреза включёна.


Построение объектов-сечений (Краткий справочник)

Обзор объектов-сечений
Построение объектов-сечений
Задание режимов объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Построение объектов-сечений >
Построение объектов-сечений
Понятие Процедура Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Задание режимов объекта-сечения (Понятие)

Построение объектов-сечений
Работа с объектами-сечениями
Применение ручек объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Задание режимов объекта-сечения
Понятие Процедура Краткий справочник

Объекты-сечения имеют три режима: "Секущая плоскость", "Контур сечения" и "Объем сечения". В зависимости от выбранного режима режущая плоскость представляется в виде 2D плоскости, 2D прямоугольника или 3D ящика. Ручки позволяют регулировать длину, ширину и высоту режущей области.

  • Секущая плоскость.Отображение секущей линии и прозрачного указателя секущей плоскости. Режущая плоскость расширяется неограниченно во всех направлениях.
  • Контур сечения. 2D прямоугольник представляет XY границы режущей плоскости. Режущая плоскость уходит в бесконечность вдоль оси Z.
  • Объем сечения. 3D параллелепипед (ящик) представляет границы режущей плоскости во всех направлениях.


Изменение режима объекта-сечения с помощью ручки "Меню" (Процедура)

Построение объектов-сечений
На уровень вверх ..
Изменить свойства объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Задание режимов объекта-сечения >
Задание режимов объекта-сечения
Понятие Процедура Краткий справочник

Изменение режима объекта-сечения с помощью ручки "Меню"

  1. Выберите объект-сечение для отображения его ручек.
  2. Выберите ручку "Меню".
  3. В меню режимов сечения выберите нужный режим.

Режим объекта-сечения на видовом экране меняется на выбранный.


Задание режимов объекта-сечения (Краткий справочник)

Построение объектов-сечений
Задание режимов объекта-сечения
Применение ручек объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Задание режимов объекта-сечения >
Задание режимов объекта-сечения
Понятие Процедура Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Применение ручек объекта-сечения (Понятие)

Задание режимов объекта-сечения
Работа с объектами-сечениями
Открытие контекстного меню "Объект-сечение"
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Применение ручек объекта-сечения
Понятие Краткий справочник

При выборе объекта-сечения отображаются различные типы ручек, выполняющих разные функции. Существуют следующие ручки:

  • Базовая ручка. Выполняет функцию ручки базовой точки объекта-сечения для перемещения, масштабирования и поворота объекта-сечения. Она всегда находится рядом с ручкой "Меню".
  • Ручка "Меню". Отображает меню режимов объекта-сечения.
  • Ручка "Направление". Показывает направление, относительно которого строятся 2D сечения и в котором просматриваются псевдоразрезы. Для изменения направления секущей плоскости на противоположное нажмите кнопку мыши на ручке "Направление".
  • Ручка "Стрелка". Перемещает сегменты секущей линии в перпендикулярном им направлении. Во время перемещения сегментов их длина изменяется, но угол между смежными сегментами сохраняется.
  • Ручка "Вторая". Вращает объект-сечение вокруг базовой ручки.
  • Ручки концов сегмента. Действуют аналогично ручкам полилинии, но не могут быть перемещены так, чтобы сегменты пересекались. Ручки концов сегментов отображаются в конечных точках сегментов с изломами.
    ПримечаниеНевозможно выбрать несколько ручек объекта-сечения одновременно.


Применение ручек объекта-сечения (Краткий справочник)

Задание режимов объекта-сечения
Применение ручек объекта-сечения
Открытие контекстного меню "Объект-сечение"
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Применение ручек объекта-сечения >
Применение ручек объекта-сечения
Понятие Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Открытие контекстного меню "Объект-сечение" (Понятие)

Применение ручек объекта-сечения
Работа с объектами-сечениями
Изменить свойства объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Открытие контекстного меню "Объект-сечение"
Понятие Краткий справочник

Выбрав объект-сечение, можно получить доступ к следующим элементам управления в контекстном меню, нажав правой кнопкой мыши на секущей линии.

  • Активизировать функцию псевдоразреза. Включает и отключает функцию псевдоразреза для выбранного объекта-сечения.
  • Показать геометрию срезов. Отображает геометрическую структуру, полученную вырезанием с использованием параметров отображения, установленными в диалоговом окне "Параметры сечения". Эта опция доступна при включенной функции псевдоразреза.
  • Параметры псевдоразрезов. Отображает диалоговое окно "Параметры сечения".
  • Создание 2D/3D сечения. Отображает диалоговое окно "Создание сечения/уровня".
  • Добавить излом секущей плоскости. Добавляет новый сегмент, излом, к секущей линии.


Открытие контекстного меню "Объект-сечение" (Краткий справочник)

Применение ручек объекта-сечения
Открытие контекстного меню "Объект-сечение"
Изменить свойства объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Открытие контекстного меню "Объект-сечение" >
Открытие контекстного меню "Объект-сечение"
Понятие Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Изменить свойства объекта-сечения (Понятие)

Открытие контекстного меню "Объект-сечение"
Работа с объектами-сечениями
Связать объекты-сечения с видами и камерами
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Изменить свойства объекта-сечения
Понятие Процедура Краткий справочник

Объекты-сечения, точно так же, как и другие объекты AutoCAD, имеют свойства. Свойства хранятся в секущей линии и могут быть открыты в палитре свойств. Например, можно изменить имя объекта-сечения, слой и тип линий, а также цвет и прозрачность указателя секущей плоскости (прозрачная режущая плоскость объекта-сечения).


Изменить свойства объекта-сечения (Процедура)

Задание режимов объекта-сечения
На уровень вверх ..
Изменить свойства объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Изменить свойства объекта-сечения >
Изменить свойства объекта-сечения
Понятие Процедура Краткий справочник

Переименование объекта-сечения

Изменение режима объекта-сечения с использованием палитры свойств

Изменение прозрачности и цвета указателя секущей плоскости

Изменение высоты указателя секущей плоскости


Переименование объекта-сечения (Процедура)

Изменить свойства объекта-сечения
На уровень вверх ..
Изменить свойства объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Изменить свойства объекта-сечения >
Изменить свойства объекта-сечения
Понятие Процедура Краткий справочник

Переименование объекта-сечения

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Объект-сечение" введите новое имя в поле "Имя".


Изменение режима объекта-сечения с использованием палитры свойств (Процедура)

Изменить свойства объекта-сечения
На уровень вверх ..
Изменить свойства объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Изменить свойства объекта-сечения >
Изменить свойства объекта-сечения
Понятие Процедура Краткий справочник

Изменение режима объекта-сечения с использованием палитры свойств

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Объект-сечение" измените значение в поле "Тип".

Режим объекта-сечения на видовом экране меняется на выбранный.


Изменение прозрачности и цвета указателя секущей плоскости (Процедура)

Изменить свойства объекта-сечения
На уровень вверх ..
Изменить свойства объекта-сечения
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Изменить свойства объекта-сечения >
Изменить свойства объекта-сечения
Понятие Процедура Краткий справочник

Изменение прозрачности и цвета указателя секущей плоскости

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Объект-сечение" введите для параметра "Прозрачность плоскости" значение из интервала 1 - 100. При значении "1" указатель секущей плоскости становится непрозрачным.
  3. Выберите цвет плоскости (параметр "Цвет плоскости").

    На видовом экране обновляется указатель секущей плоскости.


Изменение высоты указателя секущей плоскости (Процедура)

Изменить свойства объекта-сечения
На уровень вверх ..
Связать объекты-сечения с видами и камерами
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Изменить свойства объекта-сечения >
Изменить свойства объекта-сечения
Понятие Процедура Краткий справочник

Изменение высоты указателя секущей плоскости

  1. Нажмите правой кнопкой мыши на объекте-сечении. Нажмите кнопку "Свойства".
  2. В группе "Геометрия" измените значение параметра "Верхняя плоскость". Изменяется расстояние от секущей линии до верхней кромки секущей плоскости.
  3. Измените значение параметра "Нижняя плоскость". Это приводит к изменению расстояния от секущей линии до нижней кромки секущей плоскости.

    На видовом экране обновляется указатель секущей плоскости.


Изменить свойства объекта-сечения (Краткий справочник)

Открытие контекстного меню "Объект-сечение"
Изменить свойства объекта-сечения
Связать объекты-сечения с видами и камерами
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Изменить свойства объекта-сечения >
Изменить свойства объекта-сечения
Понятие Процедура Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Связать объекты-сечения с видами и камерами (Понятие)

Изменить свойства объекта-сечения
Работа с объектами-сечениями
Публикация объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Связать объекты-сечения с видами и камерами
Понятие Процедура Краткий справочник

Связывание объектов-сечений с именованными видами и камерами выполняется в диалоговом окне "Диспетчер видов".

Когда становятся активными именованный вид или камера, связанные с объектом-сечением, для этого объекта-сечения включается функция псевдоразреза. В случае 3D модели, имеющей несколько объектов-сечений, удобно связать конкретный объект-сечение с видом или камерой. Впоследствии можно быстро восстановить сохранённый вид сечения или камеру, что автоматически активизирует функцию псевдоразреза для связанного объекта-сечения.

Например, имеются два объекта-сечения, разрезающих 3D модель в разных направлениях. Объект-сечение A разрезает модель по ширине; объект-сечение B разрезает модель по длине. Требуется увидеть секущий разрез, перпендикулярный направлению взгляда. Связав каждый объект-сечение с видом или камерой, можно быстро переключиться между двумя видами и увидеть нужное поперечное сечение.


Связывание объекта-сечения с видом или камерой (Процедура)

Изменить свойства объекта-сечения
На уровень вверх ..
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Связать объекты-сечения с видами и камерами >
Связать объекты-сечения с видами и камерами
Понятие Процедура Краткий справочник

Связывание объекта-сечения с видом или камерой

  1. Выберите меню Вид [image] Именованные виды.В командной строке введите "вид".
  2. На левой панели диалогового окна "Диспетчер видов" в поле "Виды моделей" выберите именованный вид или камеру.
  3. В разделе "Общие" в раскрывающемся списке "Псевдоразрез" выберите объект-сечение по имени.
  4. Нажмите "ОК".

    Объект-сечение связан с именованным видом или камерой. Когда именованный вид или камера восстанавливается, включается функция псевдоразреза для связанного объекта-сечения.


Связать объекты-сечения с видами и камерами (Краткий справочник)

Изменить свойства объекта-сечения
Связать объекты-сечения с видами и камерами
Публикация объектов-сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Связать объекты-сечения с видами и камерами >
Связать объекты-сечения с видами и камерами
Понятие Процедура Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

ВИД

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Публикация объектов-сечений (Понятие)

Связать объекты-сечения с видами и камерами
Работа с объектами-сечениями
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Публикация объектов-сечений
Понятие Краткий справочник

Предусмотрена возможность управления видимостью объектов-сечений во время их тонирования, вывода на печать или просмотра в программе просмотра DWF-файлов.

Тонирование объектов-сечений

При включённой функции псевдоразреза все линии на объекте-сечении тонируются как 2D линии. Указатель секущей плоскости тонируется как прозрачный материал. Управление степенью его прозрачности осуществляется на палитре свойств объекта-сечения.

Печать объектов-сечений

Если для объекта-сечения установлен режим "Контур сечения" или "Объём сечения", отображаемые линии не печатаются. Указатель секущей плоскости изображается при печати так, как если бы он ему был назначен прозрачный материал, но не с той точностью воспроизведения, как при тонировании. Если при выводе на печать не требуется изображать секущую линию, поместите объект-сечение на отключённый слой.

Просмотр объектов-сечений в программе просмотра DWF-файлов

Если на объекте-сечении активна функция псевдоразреза, 3D модель отображается в DWF Viewer с максимально возможной точностью. Геометрическая структура, скрытая при создании псевдоразреза, скрывается также при ее отображении в программе DWF Viewer. Параметры отображения, связанные с псевдоразрезами, отображаются в этой программе так же, как на чертеже. Например, пунктирные линии и образцы штриховок, связанные с областью пересечения 3D модели, выглядят такими же в DWF Viewer.

Объект-сечение в DWF Viewer невидим.


Публикация объектов-сечений (Краткий справочник)

Связать объекты-сечения с видами и камерами
Публикация объектов-сечений
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Публикация объектов-сечений >
Публикация объектов-сечений
Понятие Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ПУБЛ
3DДВФ

Создание 3D DWF или 3D DWFx-файла 3D модели и его открытие в окне DWF Viewer

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Сохранение объекта-сечения в качестве инструмента инструментальной палитры (Понятие)

Публикация объектов-сечений
Работа с объектами-сечениями
Добавление изломов секущей плоскости
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Понятие Процедура Краткий справочник

Аналогично другим объектам, из конкретных объектов-сечений можно создавать инструменты, доступные из инструментальной палитры.

Можно иметь несколько объектов-сечений, имеющих свои собственные наборы свойств. Сохранив каждый объект-сечение в качестве инструмента, можно быстро создавать объекты-сечения без необходимости каждый раз менять их параметры.


Сохранение инструмента объекта-сечения в качестве инструмента инструментальной панели (Процедура)

Связать объекты-сечения с видами и камерами
На уровень вверх ..
Добавление изломов секущей плоскости
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Сохранение объекта-сечения в качестве инструмента инструментальной палитры >
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Понятие Процедура Краткий справочник

Сохранение инструмента объекта-сечения в качестве инструмента инструментальной панели

  1. На объекте-сечении выберите секущую линию.
  2. Перетащите объект-сечение на инструментальную панель и, не отпуская кнопку мыши, переведите курсор на то место инструментальной панели, в которое нужно поместить инструмент.

    Черная линия на палитре указывает возможное расположение инструмента.

  3. Отпустите кнопку мыши.

    Объект-сечение сохраняется в качестве инструмента инструментальной панели.


Сохранение объекта-сечения в качестве инструмента инструментальной палитры (Краткий справочник)

Публикация объектов-сечений
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Добавление изломов секущей плоскости
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Сохранение объекта-сечения в качестве инструмента инструментальной палитры >
Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Понятие Процедура Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

ИНСТРПАЛВКЛ

Открытие окна инструментальных палитр

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление изломов секущей плоскости (Понятие)

Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Работа с объектами-сечениями
Применение псевдоразреза
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями >
Добавление изломов секущей плоскости
Понятие Процедура Краткий справочник

Построение секущей линии с несколькими сегментами (изломами) осуществляется в режиме "Вычерчивание сечения" команды СЕКПЛОСКОСТЬ. Другой способ добавления излома к существующему объекту-сечению заключается в использовании пункта "Добавить излом секущей плоскости" контекстного меню.

Показать: "Добавление излома к объекту-сечению"

Для запуска анимации нажмите на стрелку "Показать".

Объект-сечение, построенный с помощью сегмента с изломом

При добавлении излома к существующему объекту-сечению создаётся сегмент, перпендикулярный выбранному сегменту, в направлении, определяемом ручкой "Направление". К боковым или задним линиям объекта-сечения добавить изломы невозможно. При добавлении изломов к сечению параметр "Ближайшая привязка" временно включается.

После добавления изломов можно улучшить сегменты с изломами, используя ручки объекта-сечения .


Добавление изломов секущей плоскости (Процедура)

Сохранение объекта-сечения в качестве инструмента инструментальной палитры
На уровень вверх ..
Применение псевдоразреза
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Добавление изломов секущей плоскости >
Добавление изломов секущей плоскости
Понятие Процедура Краткий справочник

Добавление изломов секущей плоскости

  1. На объекте-сечении выберите секущую линию.
  2. Нажмите на секущей линии правую кнопку мыши . Выберите "Добавить излом секущей плоскости".
  3. Переведите курсор на секущую линию.
  4. Выберите точку на секущей линии, в которую нужно поместить излом, перпендикулярный выбранному сегменту.

    Для построения других изломов повторите эти действия.

ПримечаниеВ программе не допускается введение изломов, которые приводят к самопересечению или замыканию линии. Если это происходит, точка ввода игнорируется, а в командной строке выводится сообщение об ошибке.
Ввод команды: ИЗЛОМРАЗРЕЗ


Добавление изломов секущей плоскости (Краткий справочник)

Сохранение объекта-сечения в качестве инструмента инструментальной палитры
Добавление изломов секущей плоскости
Принцип работы функции псевдоразреза
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Работа с объектами-сечениями > Добавление изломов секущей плоскости >
Добавление изломов секущей плоскости
Понятие Процедура Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

ИЗЛОМРАЗРЕЗ

Добавление сегмента с изломом к объекту-сечению

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Применение псевдоразреза

Добавление изломов секущей плоскости
Построение сечений и 2D чертежей из 3D моделей
Принцип работы функции псевдоразреза
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей >
Применение псевдоразреза
Понятие Процедура

Если для объекта-сечения включена функция псевдоразреза, в пространстве модели можно динамически строить сечения 3D модели. При перемещении объекта-сечения через 3D модель его прозрачный указатель секущей плоскости разрезает тело, поверхность или область в режиме реального времени.

Темы в этом разделе

  • Принцип работы функции псевдоразреза

    Функция псевдоразреза представляет собой аналитический инструмент, позволяющий видеть геометрию среза в 3D теле, поверхности или области в том месте, где объект-сечение пересекает 3D геометрическую структуру.


Применение псевдоразреза (Процедура)

Добавление изломов секущей плоскости
Применение псевдоразреза
Принцип работы функции псевдоразреза
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Применение псевдоразреза >
Применение псевдоразреза
Понятие Процедура

Включение и отключение функции псевдоразреза

Отображение геометрии срезов


Принцип работы функции псевдоразреза (Понятие)

Применение псевдоразреза
Применение псевдоразреза
Создание 2D и 3D сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Применение псевдоразреза >
Принцип работы функции псевдоразреза
Понятие Процедура Краткий справочник

Функция псевдоразреза представляет собой аналитический инструмент, позволяющий видеть геометрию среза в 3D теле, поверхности или области в том месте, где объект-сечение пересекает 3D геометрическую структуру.

Можно также применять функцию псевдоразреза для анализа модели, перемещая объект-сечение назад и вперёд. Например, плавно передвигая объект-сечение через двигатель в сборе, можно визуализировать его внутренние компоненты.

Перед началом работы с псевдоразрезом необходимо разобраться с некоторыми ключевыми свойствами этой функции.

  • Использование функции псевдоразреза возможно только для 3D объектов и областей в пространстве модели.
  • Функция псевдоразреза включается или отключается в зависимости от режима, используемого при создании объекта-сечения. Например, выбор грани создаёт объект-сечение с включённой функцией псевдоразреза; в режиме "Вычерчивание сечения" создаётся объект-сечение с отключённой функцией псевдоразреза. После того как объект-сечение создан, функцию псевдоразреза любого объекта-сечения можно включить или отключить вручную.
  • В чертеже можно иметь несколько объектов-сечений; однако функция псевдоразреза может быть активна только для одного из них. Например, в модели имеется два объекта-сечения: Сечение A и Сечение B. Если функция псевдоразреза Сечения A включена и выполняется активизирование функции псевдоразреза для Сечения B, функция псевдоразреза для Сечения A автоматически отключается.
  • Отключение слоя объекта-сечения не приводит к отключению функции псевдоразреза, но при замораживании слоя функция отключается.
  • При включенной функции псевдоразреза можно с помощью ручек плавно передвигать сегменты объекта-сечения и наблюдать результирующий эффект в 3D модели.


Принцип работы функции псевдоразреза (Процедура)

Применение псевдоразреза
На уровень вверх ..
Принцип работы функции псевдоразреза
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Применение псевдоразреза > Принцип работы функции псевдоразреза >
Принцип работы функции псевдоразреза
Понятие Процедура Краткий справочник

Включение и отключение функции псевдоразреза

Отображение геометрии срезов


Включение и отключение функции псевдоразреза (Процедура)

Принцип работы функции псевдоразреза
На уровень вверх ..
Принцип работы функции псевдоразреза
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Применение псевдоразреза > Принцип работы функции псевдоразреза >
Принцип работы функции псевдоразреза
Понятие Процедура Краткий справочник

Включение и отключение функции псевдоразреза

  1. Выберите объект-сечение.
  2. Нажмите на секущей линии правую кнопку мыши
  3. Для включения функции выберите пункт "Активизировать формирование псевдоразрезов". Если функция включена, нажмите, чтобы отключить ее.


Отображение геометрии срезов (Процедура)

Принцип работы функции псевдоразреза
На уровень вверх ..
Создание 2D и 3D сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Применение псевдоразреза > Принцип работы функции псевдоразреза >
Принцип работы функции псевдоразреза
Понятие Процедура Краткий справочник

Отображение геометрии срезов

  1. Выберите объект-сечение.
  2. Нажмите на секущей линии правую кнопку мыши Для включения функции выберите пункт "Показать геометрию срезов.

    Геометрия срезов отображается в соответствии с настройками "Линия переднего плана" в диалоговом окне "Параметры сечения".


Принцип работы функции псевдоразреза (Краткий справочник)

Добавление изломов секущей плоскости
Принцип работы функции псевдоразреза
Создание 2D и 3D сечений
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Применение псевдоразреза > Принцип работы функции псевдоразреза >
Принцип работы функции псевдоразреза
Понятие Процедура Краткий справочник

Команды

ПСЕВДОРАЗРЕЗ

Включение режима псевдоразреза для выбранного объекта-сечения

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание 2D и 3D сечений (Понятие)

Принцип работы функции псевдоразреза
Построение сечений и 2D чертежей из 3D моделей
Создание плоского вида
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей >
Создание 2D и 3D сечений
Понятие Процедура Краткий справочник

Предусмотрена возможность создания представления области поперечного сечения в виде 2D или 3D блока в месте пересечения 3D модели объектом-сечением.

Тип создаваемого блока задаётся в диалоговом окне "Создание сечения/уровня". Если в проекте требуется построение 2D чертежей уровней или 2D поперечных сечений, в режиме "2D сечение / уровень" создаётся точное представление блока, готовое для нанесения размеров. Если создаётся презентация и требуется опубликовать или тонировать срез 3D модели, используется режим "3D сечение".

При создании сечений нужно учитывать некоторые дополнительные обстоятельства.

  • Как 2D, так и 3D сечения могут быть вставлены в чертёж в виде неименованного блока или сохранены во внешнем файле в виде "пблока". Созданные сечения строятся в виде блоков, которые можно переименовывать и редактировать командой БЛОКРЕД.
  • Перед вставкой блоков в чертёж их можно поворачивать и изменять их масштаб. Предусмотрено также изменение базовой точки вставки.
  • Для создания сечений могут использоваться 3D объекты, вставленные в чертёж в виде внешних ссылок и блоков.
  • 2D сечения строятся с помощью 2D отрезков, дуг, окружностей, эллипсов, сплайнов и образцов штриховки.
  • 3D сечения строятся с помощью 3D тел и поверхностей, но для контуров профилей и образцов штриховки используются 2D отрезки.
  • Управление свойствами отображения блоков 2D сечений/уровней и блоков 3D сечений осуществляется в диалоговом окне "Параметры сечения".


Создание 2D или 3D сечения (Процедура)

Принцип работы функции псевдоразреза
Создание 2D и 3D сечений
Создание плоского вида
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Создание 2D и 3D сечений >
Создание 2D и 3D сечений
Понятие Процедура Краткий справочник

Создание 2D или 3D сечения

  1. Выберите объект-сечение. Нажмите на секущей линии правую кнопку мыши и выберите пункт "Создание 2D/3D сечения".
  2. В диалоговом окне "Создание сечения/уровня" выберите "2D сечение/уровень" или "3D сечение".
  3. Выберите "Включить все объекты".
  4. В группе "Назначение" выберите "Вставить в виде нового блока".
  5. Нажмите кнопку "Создать".
  6. Укажите на экране точку вставки.

    Вставляется неименованный блок, состоящий из 2D или 3D геометрической структуры.


Создание 2D и 3D сечений (Краткий справочник)

Принцип работы функции псевдоразреза
Создание 2D и 3D сечений
Создание плоского вида
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Создание 2D и 3D сечений >
Создание 2D и 3D сечений
Понятие Процедура Краткий справочник

Команды

СЕКПЛОСКОСТЬ

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание плоского вида (Понятие)

Создание 2D и 3D сечений
Построение сечений и 2D чертежей из 3D моделей
Аннотирование чертежей
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей >
Создание плоского вида
Понятие Процедура Краткий справочник

Командой ПЛОСКСНИМОК создаётся плоский вид всех 3D тел и областей текущего вида.

Полученный вид представляет собой блок, являющийся плоскостным представлением 3D модели, спроектированным на плоскость XY. Эта процедура аналогична получению "снимка" всей 3D модели с помощью камеры и последующего устранения эффекта объёмности на фотографии. После вставки блока его можно изменять, поскольку плоский вид состоит из 2D геометрических объектов. Эта функция особенно удобна для создания технических иллюстраций.

Перед применением команды ПЛОСКСНИМОК не обязательно задавать какой-то определённый вид. Можно настроить чертёж в ортогональном или параллельном виде.

Плоский вид создается со следующими параметрами:

  • Вид включает все 3D объекты на видовом экране пространства модели. Объекты, которые не следует помещать в вид, необходимо расположить на отключённых или замороженных слоях.
  • Плоские виды создаются в виде блоков, которые можно переименовывать и редактировать с помощью команды БЛОКРЕД.
  • Создаваемый блок определяется настройками отображения для линий переднего плана и скрытых линий, выполняемыми в диалоговом окне "Плоский снимок".
  • Скрытые линии фиксируются и отображаются в блоке с помощью настроек отображения для параметра "Линии заднего плана" в диалоговом окне "Плоский снимок".
  • 3D объекты, рассечённые объектом-сечением, помещаются в вид целиком. Командой ПЛОСКСНИМОК эти объекты помещаются в вид так, как если бы они не были рассечены.
ПримечаниеДля построения профилей изображений 3D тел в пространстве листа применяется команда Т-ПРОФИЛЬ.


Создание плоского 2D вида 3D модели (Процедура)

Создание 2D и 3D сечений
Создание плоского вида
Масштабирование аннотаций
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Создание плоского вида >
Создание плоского вида
Понятие Процедура Краткий справочник

Создание плоского 2D вида 3D модели

  1. Настройте вид 3D модели.
  2. Выберите вкладку "Главная" [image] панель "Редактирование тела" [image] "Плоский снимок".В командной строке введите плоскснимок.
  3. В диалоговом окне "Плоский снимок" в группе "Назначение" выберите один из параметров.
  4. Измените цвет и тип для фоновых и погашенных линий.
  5. Нажмите кнопку "Создать".
  6. Укажите на экране точку вставки для размещения блока. При необходимости отрегулируйте положение базовой точки, масштаб и угол поворота.

    Создаётся блок, состоящий из 2D геометрической структуры, который проецируется на плоскость XY текущей ПСК.


Создание плоского вида (Краткий справочник)

Создание 2D и 3D сечений
Создание плоского вида
Общие сведения об аннотациях
Работа с 3D моделями > Построение сечений и 2D чертежей из 3D моделей > Создание плоского вида >
Создание плоского вида
Понятие Процедура Краткий справочник

Команды

ПЛОСКСНИМОК

Создание 2D представления всех 3D объектов в текущем виде

Т-ПРОФИЛЬ

Создание профилей 3D тел в пространстве листа

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Аннотирование чертежей

Создание плоского вида
Работа с аннотациями
Аннотирование чертежей

Темы в этом разделе

  • Работа с аннотациями

    При аннотировании чертежей можно пользоваться инструментами и свойствами, упрощающими работу с аннотациями.

  • Штриховка, заливка и маскировка

    Штриховку можно использовать для закрашивания области выбранным образцом или цветом. Для того чтобы оставить свободное место на области, можно создать маскирующий объект.

  • Примечания и метки

    Имеется возможность выполнения и редактирования различных типов текстовых надписей, включая надписи на выносках. Большинство параметров текста управляется с помощью текстовых стилей.

  • Таблицы

    Таблица представляет собой прямоугольный массив ячеек с аннотациями; аннотации, как правило, являются текстовыми, но могут также состоять из нескольких блоков.

  • Размеры и допуски

    Имеется множество команд, предназначенных для нанесения и форматирования размеров на чертеже. Для быстрого форматирования размеров и обеспечения их соответствия государственным стандартам и стандартам предприятия используйте размерные стили.


Работа с аннотациями

Аннотирование чертежей
Аннотирование чертежей
Общие сведения об аннотациях
Аннотирование чертежей >
Работа с аннотациями

При аннотировании чертежей можно пользоваться инструментами и свойствами, упрощающими работу с аннотациями.

Темы в этом разделе

  • Общие сведения об аннотациях

    К аннотациям относятся примечания, поясняющие обозначения других типов, а также объекты, обычно используемые для добавления информации к чертежу.

  • Масштабирование аннотаций

    Можно автоматизировать процесс масштабирования аннотаций в различных видовых экранах листа и в пространстве модели.

  • Задание ориентации аннотаций

    Аннотативные блоки и текст можно настроить таким образом, что их ориентация будет соответствовать ориентации листа. Ориентация аннотативной штриховки всегда совпадает с ориентацией листа.


Общие сведения об аннотациях (Понятие)

Работа с аннотациями
Работа с аннотациями
Масштабирование аннотаций
Аннотирование чертежей > Работа с аннотациями >
Общие сведения об аннотациях
Понятие Краткий справочник

К аннотациям относятся примечания, поясняющие обозначения других типов, а также объекты, обычно используемые для добавления информации к чертежу.

Примеры аннотаций

  • Примечания и метки
  • Таблицы
  • Размеры и допуски
  • Штриховки
  • Метки-идентификаторы
  • Блоки

Типы объектов, которые можно использовать при создании аннотаций

  • Штриховки
  • Текст (однострочный и многострочный)
  • Таблицы
  • Размеры
  • Допуски
  • Выноски и мультивыноски
  • Блоки
  • Атрибуты


Общие сведения об аннотациях (Краткий справочник)

Создание плоского вида
Общие сведения об аннотациях
Общие сведения о масштабировании аннотаций
Аннотирование чертежей > Работа с аннотациями > Общие сведения об аннотациях >
Общие сведения об аннотациях
Понятие Краткий справочник

Команды

АТОПР

Создание определения атрибута для хранения данных в блоке

БЛОК

Создание определения блока из выбранных объектов

РЗМСТИЛЬ

Создание и модификация размерных стилей

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

МВЫНОСКАСТИЛЬ

Создание и модификация стилей мультивыносок

МТЕКСТ

Создание многострочного текстового объекта

ОБЪЕКТМАСШТ

Добавление или удаление поддерживаемых масштабов для объектов аннотативный

СТИЛЬ

Создание, изменение или определение стилей текста

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Масштабирование аннотаций

Общие сведения об аннотациях
Работа с аннотациями
Общие сведения о масштабировании аннотаций
Аннотирование чертежей > Работа с аннотациями >
Масштабирование аннотаций
Понятие Процедура

Можно автоматизировать процесс масштабирования аннотаций в различных видовых экранах листа и в пространстве модели.

Темы в этом разделе

  • Общие сведения о масштабировании аннотаций

    Для объектов, обычно используемых при аннотировании чертежей, предусмотрено свойство "Аннотативный". Это свойство позволяет автоматизировать процесс масштабирования аннотаций для вывода на печать или отображения в соответствии с требуемым форматом листа бумаги.

  • Задание масштаба аннотаций

    Значение масштаба аннотаций можно задать и сохранить для пространства модели, видовых экранов листа и видов модели. При добавлении объектов аннотативный к чертежу им назначается текущее значение масштаба аннотаций: объекты масштабируются на основе этого значения и автоматически отображаются в пространстве модели с соответствующим размером.

  • Создание аннотативных объектов

    Для объектов, обычно используемых при аннотировании чертежей, предусмотрено свойство "Аннотативный". Если для такого объекта активизировано свойство "Аннотативный" (задано значение "Да"), этот объект называется аннотативным объектом

  • Отображение аннотативных объектов

    Для видового экрана листа или пространства модели можно выбрать режим отображения всех объектов аннотативный или только тех объектов, которым назначено текущее значение масштаб аннотаций .

  • Добавление и изменение масштабируемых представлений

    Объекту аннотативный , созданному на чертеже, назначено одно значение масштаб аннотаций : масштаб аннотаций, который был текущим на момент создания объекта. Можно обновить аннотативные объекты, добавив к ним дополнительные значения масштаба аннотаций.


Масштабирование аннотаций (Процедура)

Создание плоского вида
Масштабирование аннотаций
Задание масштаба аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций >
Масштабирование аннотаций
Понятие Процедура

Процедура задания масштаба аннотаций при работе на вкладке "Модель"

Процедура задания масштаба аннотаций для видового экрана листа

Процедура задания масштаба аннотаций по умолчанию

Процедура отображения или скрытия аннотативных объектов на чертеже

Процедура добавления текущего масштаба аннотаций к аннотативному объекту

Процедура удаления текущего масштаба аннотаций из аннотативного объекта

Процедура включения режима, в котором текущее значение масштаба аннотаций автоматически применяется к аннотативным объектам

Процедура добавления масштаба аннотаций к аннотативному объекту

Процедура удаления масштаба аннотаций из аннотативного объекта


Общие сведения о масштабировании аннотаций (Понятие)

Масштабирование аннотаций
Масштабирование аннотаций
Задание масштаба аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций >
Общие сведения о масштабировании аннотаций
Понятие Краткий справочник

Для объектов, обычно используемых при аннотировании чертежей, предусмотрено свойство "Аннотативный". Это свойство позволяет автоматизировать процесс масштабирования аннотаций для вывода на печать или отображения в соответствии с требуемым форматом листа бумаги.

Вместо создания нескольких аннотаций разных размеров в отдельных слоях можно включить для объекта или стиля свойство "Аннотативный" и задать масштаб аннотаций для видовых экранов компоновки или модели. Масштаб аннотаций определяет размер аннотативных объектов относительно геометрии модели на чертеже.

Демонстрация: автоматическое масштабирование аннотаций

Для просмотра видеоролика с инструкциями щелкните на стрелке "Просмотр".

Указанные ниже объекты, обычно используемые при аннотировании чертежей, содержат свойство "Аннотативный".

  • Текст
  • Размеры
  • Штриховки
  • Допуски
  • Мультивыноски
  • Блоки
  • Атрибуты

Если для такого объекта активизировано свойство "Аннотативный" (задано значение "Да"), этот объект называется аннотативным объектом.

Для аннотативных объектов следует задать формат бумаги. масштаб аннотаций , заданный для видовых экранов листа и пространства модели, определяет размер аннотативных объектов в этих пространствах.

Последовательность действий для аннотирования чертежей

Ниже приведена типичная процедура аннотирования чертежа с автоматическим масштабированием аннотаций.

  1. Создайте аннотативные стили.
  2. В пространстве модели задайте значение масштаба аннотаций, при котором аннотации будут выводиться на печать или на экран.
  3. Создайте аннотативные объекты с применением аннотативных стилей.

Если требуется отобразить один или несколько аннотативных объектов в другом масштабе, выполните следующие действия.

  1. Добавьте к аннотативным объектам дополнительный масштаб.
  2. Задайте для масштаба аннотаций значение, соответствующее новому масштабу (размер объектов, поддерживающих новый масштаб, изменится в соответствии с масштабом аннотаций).
  3. При необходимости измените местоположение аннотативных объектов в соответствии с новым масштабом.

При создании листов выполните следующие действия.

  1. Создайте новый лист или назначьте лист текущим.
  2. Создайте видовые экраны.
  3. Задайте масштаб аннотаций для каждого видового экрана. (Для каждого видового экрана масштаб аннотаций должен совпадать с масштабом видового экрана.)

Более подробную информацию о настройке отображения/скрытия аннотативных объектов см. в разделе Отображение аннотативных объектов. Более подробную информацию о добавлении значений масштаба к аннотативным объектам см. в разделе Добавление и изменение масштабируемых представлений.


Общие сведения о масштабировании аннотаций (Краткий справочник)

Общие сведения об аннотациях
Общие сведения о масштабировании аннотаций
Задание масштаба аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Общие сведения о масштабировании аннотаций >
Общие сведения о масштабировании аннотаций
Понятие Краткий справочник

Команды

ОБЪЕКТМАСШТ

Добавление или удаление поддерживаемых масштабов для объектов аннотативный

Системные переменные

ANNOAUTOSCALE

Обновление аннотативный объектов для поддержки масштаб аннотаций при изменении масштаба аннотаций

CANNOSCALE

Задание имени текущего масштаб аннотаций для текущего пространства

CANNOSCALEVALUE

Отображение значения текущего масштаб аннотаций

MSLTSCALE

Масштабирование типов линий, отображаемых на вкладке модели масштаб аннотаций

Утилиты

Нет

Ключевые слова для команд

Нет


Задание масштаба аннотаций (Понятие)

Общие сведения о масштабировании аннотаций
Масштабирование аннотаций
Создание аннотативных объектов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций >
Задание масштаба аннотаций
Понятие Процедура Краткий справочник

Значение масштаба аннотаций можно задать и сохранить для пространства модели, видовых экранов листа и видов модели. При добавлении объектов аннотативный к чертежу им назначается текущее значение масштаба аннотаций: объекты масштабируются на основе этого значения и автоматически отображаются в пространстве модели с соответствующим размером.

Перед добавлением аннотативных объектов к модели следует задать масштаб аннотаций. Необходимо учитывать окончательные значения масштаба для видовых экранов, в которых будут отображаться аннотации. Масштаб аннотации должен совпадать с масштабом видового экрана листа, на котором будут отображаться аннотативные объекты (а при печати из пространства модели - с масштабом печати). Например, если аннотативные объекты будут отображаться на видовом экране, для которого задан масштаб 1:2, для масштаба аннотаций следует задать значение 1:2.

При работе на вкладке модели, а также при наличии выбранного видового экрана текущее значение масштаба аннотаций отображается в строке состояния приложения или чертежа. С помощью строк состояния можно изменить масштаб аннотаций.

Демонстрация: задание масштаба аннотаций

Для просмотра видеоролика с инструкциями щелкните на стрелке "Просмотр".

С помощью системной переменной ANNOAUTOSCALE можно задать автоматическое назначение текущего масштаба аннотаций для аннотативных объектов при изменении масштаба аннотаций. По умолчанию режим ANNOAUTOSCALE отключен для уменьшения размера файлов и повышения производительности. Если режим ANNOAUTOSCALE отключен, в правой части строки состояния чертежа или строки состояния приложения кнопка [image] отображается в таком виде.

С помощью системной переменной CANNOSCALE можно задать значение масштаба аннотаций по умолчанию.

См. также

    • Строка состояния чертежа


Задание масштаба аннотаций (Процедура)

Масштабирование аннотаций
На уровень вверх ..
Задание масштаба аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Задание масштаба аннотаций >
Задание масштаба аннотаций
Понятие Процедура Краткий справочник

Процедура задания масштаба аннотаций при работе на вкладке "Модель"

Процедура задания масштаба аннотаций для видового экрана листа

Процедура задания масштаба аннотаций по умолчанию


Процедура задания масштаба аннотаций при работе на вкладке "Модель" (Процедура)

Задание масштаба аннотаций
На уровень вверх ..
Задание масштаба аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Задание масштаба аннотаций >
Задание масштаба аннотаций
Понятие Процедура Краткий справочник

Процедура задания масштаба аннотаций при работе на вкладке "Модель"

  1. В правой части строки состояния чертежа или приложения щелкните на стрелке рядом с отображаемым значением масштаба аннотаций.
  2. Выберите масштаб из списка.


Процедура задания масштаба аннотаций для видового экрана листа (Процедура)

Задание масштаба аннотаций
На уровень вверх ..
Задание масштаба аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Задание масштаба аннотаций >
Задание масштаба аннотаций
Понятие Процедура Краткий справочник

Процедура задания масштаба аннотаций для видового экрана листа

  1. На листе выберите видовой экран.
  2. В правой части строки состояния чертежа или приложения щелкните на стрелке рядом с отображаемым значением масштаба аннотаций.
  3. Выберите масштаб из списка.


Процедура задания масштаба аннотаций по умолчанию (Процедура)

Задание масштаба аннотаций
На уровень вверх ..
Создание аннотативных объектов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Задание масштаба аннотаций >
Задание масштаба аннотаций
Понятие Процедура Краткий справочник

Процедура задания масштаба аннотаций по умолчанию

  1. В командной строке введите "cannoscale".
  2. Введите имя масштаба. Нажмите клавишу ENTER.
Ввод команды: CANNOSCALE


Задание масштаба аннотаций (Краткий справочник)

Общие сведения о масштабировании аннотаций
Задание масштаба аннотаций
Общие сведения о создании аннотативных объектов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Задание масштаба аннотаций >
Задание масштаба аннотаций
Понятие Процедура Краткий справочник

Команды

ОБЪЕКТМАСШТ

Добавление или удаление поддерживаемых масштабов для объектов аннотативный

Системные переменные

ANNOAUTOSCALE

Обновление аннотативный объектов для поддержки масштаб аннотаций при изменении масштаба аннотаций

CANNOSCALE

Задание имени текущего масштаб аннотаций для текущего пространства

CANNOSCALEVALUE

Отображение значения текущего масштаб аннотаций

MSLTSCALE

Масштабирование типов линий, отображаемых на вкладке модели масштаб аннотаций

Утилиты

Нет

Ключевые слова для команд

Нет


Создание аннотативных объектов

Задание масштаба аннотаций
Масштабирование аннотаций
Общие сведения о создании аннотативных объектов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций >
Создание аннотативных объектов
Понятие Процедура

Для объектов, обычно используемых при аннотировании чертежей, предусмотрено свойство "Аннотативный". Если для такого объекта активизировано свойство "Аннотативный" (задано значение "Да"), этот объект называется аннотативным объектом

Темы в этом разделе

  • Общие сведения о создании аннотативных объектов

    При добавлении к чертежу аннотаций можно включить для добавляемых объектов свойство "Аннотативный". Эти аннотативные объекты масштабируются на основе текущего значения масштаб аннотаций и автоматически отображаются с правильным размером.

  • Работа с аннотативными стилями

    Применение аннотативных стилей максимально упрощает процедуру аннотирования чертежа.

  • Создание аннотативного текста

    Текст, имеющий свойство аннотативный , служит для создания примечаний и меток на чертеже. Аннотативный текст создается на основе аннотативного стиля текста, который определяет высоту текста на листе бумаги.

  • Создание аннотативных размеров и допусков

    Для измерений на чертеже можно создавать аннотативный размеры на основе аннотативных размерных стилей.

  • Создание аннотативных выносок и мультивыносок

    Выноски и мультивыноска служат для добавления меток-идентификаторов к чертежам. Выноски со свойством "аннотативный " можно создавать на основе аннотативных стилей размеров, а мультивыноски - на основе аннотативных стилей мультивыносок.

  • Создание аннотативных блоков и атрибутов

    Если требуется аннотировать чертеж посредством геометрических объектов, можно объединить такие объекты, составив из них определение аннотативного блока.

  • Создание аннотативной штриховки

    Аннотативная штриховка применяется для обозначения таких материалов, как песок, бетон, сталь, грунт и др.


Создание аннотативных объектов (Процедура)

Задание масштаба аннотаций
На уровень вверх ..
Работа с аннотативными стилями
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Создание аннотативных объектов
Понятие Процедура

Процедуры создания аннотативного стиля

Процедуры создания аннотативных объектов на основе аннотативных стилей

Процедура создания нового аннотативного текстового стиля

Процедура преобразования обычного текстового стиля в аннотативный

Процедура создания однострочного аннотативного текста

Процедура создания многострочного аннотативного текста

Процедура преобразования обычного многострочного текста в аннотативный и наоборот

Процедура преобразования обычного текста (однострочного или многострочного) в аннотативный и наоборот

Процедура обновления текста с учетом текущих значений свойства "Аннотативный", заданных для текстового стиля

Процедура изменения высоты аннотативного текста, отображаемого на листе

Процедура создания нового стиля аннотативных размеров

Процедура преобразования существующего размерного стиля в аннотативный

Процедура создания аннотативного размера

Процедура преобразования обычного размера в аннотативный и наоборот

Процедура обновления размеров с учетом текущих значений свойств "Аннотативный", заданных для размерного стиля

Процедура создания аннотативного допуска

Процедура создания нового стиля аннотативных мультивыносок

Процедура преобразования существующего стиля мультивыносок в аннотативный

Процедура создания аннотативной мультивыноски

Процедура преобразования обычной выноски или мультивыноски в аннотативную и наоборот

Процедура создания определения аннотативного блока

Процедура преобразования существующих ссылок на блоки в ссылки на аннотативные блоки

Процедура создания определения аннотативного атрибута

Процедура создания аннотативного объекта-штриховки

Процедура преобразования существующего объекта-штриховки в аннотативный объект


Общие сведения о создании аннотативных объектов (Понятие)

Создание аннотативных объектов
Создание аннотативных объектов
Работа с аннотативными стилями
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Общие сведения о создании аннотативных объектов
Понятие Краткий справочник

При добавлении к чертежу аннотаций можно включить для добавляемых объектов свойство "Аннотативный". Эти аннотативные объекты масштабируются на основе текущего значения масштаб аннотаций и автоматически отображаются с правильным размером.

Для аннотативных объектов задается высота листа бумаги; размер отображаемых аннотативных объектов определяется масштабом аннотаций.

Ниже указаны возможные аннотативные объекты (объекты, для которых предусмотрено свойство "Аннотативный").

  • Штриховки
  • Текст (однострочный и многострочный)
  • Размеры
  • Допуски
  • Выноски и мультивыноски (созданные посредством МВЫНОСКА )
  • Блоки
  • Атрибуты

Во многих из диалоговых окон, с помощью которых создаются эти объекты, предусмотрен флажок "Аннотативный", предназначенный для преобразования объекта в аннотативный объект. Для преобразования существующих объектов в аннотативные можно также изменить значение свойства "Аннотативный" на палитре "Свойства".

При наведении курсора на аннотативный объект, которому назначено одно значение масштаба аннотаций, курсор отображается в виде значка [image]. Если объекту назначено несколько значений масштаба аннотаций, курсор отображается в виде значка [image].

Аннотативными могут быть также текстовые, размерные стили и стили мультивыносок. Объекты, созданные с применением аннотативных стилей, являются аннотативными.

Визуальная четкость аннотативных объектов

Этот параметр обеспечивает точность воспроизведения объектов аннотативный при их просмотре в AutoCAD 2007 и в более ранних версиях программы. Управление режимом визуальной четкости осуществляется с помощью системной переменной SAVEFIDELITY .

Если работа выполняется главным образом в пространстве модели, рекомендуется отключить режим визуальной четкости (задать для переменной SAVEFIDELITY значение 0). Однако если требуется обмениваться чертежами с другими пользователями и предъявляются высокие требования к точности воспроизведения компоновки, следует включить режим точного воспроизведения визуальной информации (задать для переменной SAVEFIDELITY значение 1).

Аннотативному объекту может соответствовать несколько масштабируемых представлений. Если режим визуальной четкости включен, аннотативные объекты разделяются таким образом, что масштабируемые представления сохраняются (в неименованный блок ) в отдельных слоях, имена которых образуются путем присоединения номера к имени исходного слоя. Если расчленить блок в AutoCAD 2007 или в более ранней версии программы, а затем открыть чертеж в AutoCAD 2008 или более поздней версии, каждое масштабируемое представление становится отдельным аннотативным объектом, для которого задан один масштаб аннотаций. Не рекомендуется редактировать и создавать объекты в этих слоях при работе в AutoCAD 2007 и более ранних версиях с чертежом, созданным в AutoCAD 2008 и более поздних версиях.

Если этот параметр не выбран, на вкладке "Модель" отображается пространство одной модели. Возможность отображения других объектов аннотаций на вкладке "Модель" зависит от значения ANNOALLVISIBLE. Кроме того, на видовых экранах пространства листа возможно отобразить больше объектов различного размера нежели в AutoCAD 2008 и более поздних версиях.

Информацию о процедуре задания этого параметра для аннотативных объектов см. в разделе Сохранение чертежей с визуальной четкостью аннотативных объектов.

См. также

    • Работа с аннотативными стилями


Общие сведения о создании аннотативных объектов (Краткий справочник)

Задание масштаба аннотаций
Общие сведения о создании аннотативных объектов
Работа с аннотативными стилями
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Общие сведения о создании аннотативных объектов >
Общие сведения о создании аннотативных объектов
Понятие Краткий справочник

Команды

АТОПР

Создание определения атрибута для хранения данных в блоке

БЛОК

Создание определения блока из выбранных объектов

РЗМСТИЛЬ

Создание и модификация размерных стилей

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

МВЫНОСКАСТИЛЬ

Создание и модификация стилей мультивыносок

МТЕКСТ

Создание многострочного текстового объекта

СТИЛЬ

Создание, изменение или определение стилей текста

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с аннотативными стилями (Понятие)

Общие сведения о создании аннотативных объектов
Создание аннотативных объектов
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Работа с аннотативными стилями
Понятие Процедура Краткий справочник

Применение аннотативных стилей максимально упрощает процедуру аннотирования чертежа.

На основе текстовых, размерных стилей и стилей мультивыносок можно создавать аннотативный объекты.

В диалоговых окнах, с помощью которых определяются эти объекты, предусмотрен флажок "Аннотативный", предназначенный для преобразования стиля в аннотативный стиль. В диалоговых окнах и на палитре "Свойства" перед именами аннотативных стилей отображается специальный значок [image].

Для создаваемых аннотативных текстовых стилей следует указать значение "Высота листа". Параметр "Высота листа" определяет высоту текста в пространстве листа.

ПримечаниеЕсли для стиля размеров или мультивыносок задано значение параметра "Высота листа", это значение применяется вместо значения параметра "Высота листа", заданного для текстового стиля.

При изменении определения стиля, предусматривающем преобразование аннотативного стиля в обычный или наоборот, существующие объекты, которые ссылаются на этот стиль, не обновляются автоматически в соответствии с новым значением свойства "Аннотативный" для стиля или определения. Для обновления существующих объектов в соответствии со значениями свойств "Аннотативный", заданными для стиля, следует выполнить команду АННООБНОВИТЬ .

При изменении значения свойства "Стиль" для существующего объекта (независимо от того, является ли он аннотативным или нет) значения свойств "Аннотативный" для этого объекта приводятся в соответствие с новым стилем. Если для стиля не задана фиксированная высота (значение параметра "Высота" равно 0), высота объекта на листе вычисляется на основе текущей высоты объекта и масштаба аннотаций.

См. также

    • Работа с текстовыми стилями

    • Создание аннотативного текста

    • Размерные стили

    • Создание аннотативных размеров и допусков

    • Работа со стилями выносок

    • Создание аннотативных выносок и мультивыносок


Работа с аннотативными стилями (Процедура)

Создание аннотативных объектов
На уровень вверх ..
Работа с аннотативными стилями
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Работа с аннотативными стилями >
Работа с аннотативными стилями
Понятие Процедура Краткий справочник

Процедуры создания аннотативного стиля

Процедуры создания аннотативных объектов на основе аннотативных стилей


Процедуры создания аннотативного стиля (Процедура)

Работа с аннотативными стилями
На уровень вверх ..
Работа с аннотативными стилями
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Работа с аннотативными стилями >
Работа с аннотативными стилями
Понятие Процедура Краткий справочник

Процедуры создания аннотативного стиля

  • Выполните одну из следующих процедур.
    • Процедура создания нового аннотативного текстового стиля
    • Процедура преобразования обычного текстового стиля в аннотативный
    • Процедура создания нового стиля аннотативных размеров
    • Процедура преобразования существующего размерного стиля в аннотативный
    • Процедура создания нового стиля аннотативных мультивыносок
    • Процедура преобразования существующего стиля мультивыносок в аннотативный


Процедуры создания аннотативных объектов на основе аннотативных стилей (Процедура)

Работа с аннотативными стилями
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Работа с аннотативными стилями >
Работа с аннотативными стилями
Понятие Процедура Краткий справочник

Процедуры создания аннотативных объектов на основе аннотативных стилей

  • Выполните одну из следующих процедур.
    • Процедура создания однострочного аннотативного текста
    • Процедура создания многострочного аннотативного текста
    • Процедура создания аннотативного размера
    • Процедура создания аннотативной мультивыноски


Работа с аннотативными стилями (Краткий справочник)

Общие сведения о создании аннотативных объектов
Работа с аннотативными стилями
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Работа с аннотативными стилями >
Работа с аннотативными стилями
Понятие Процедура Краткий справочник

Команды

АННООБНОВИТЬ

Обновление существующих аннотативный объектов в соответствии с текущими свойствами их стилей

РЗМСТИЛЬ

Создание и модификация размерных стилей

МВЫНОСКАСТИЛЬ

Создание и модификация стилей мультивыносок

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание аннотативного текста (Понятие)

Работа с аннотативными стилями
Создание аннотативных объектов
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Текст, имеющий свойство аннотативный , служит для создания примечаний и меток на чертеже. Аннотативный текст создается на основе аннотативного стиля текста, который определяет высоту текста на листе бумаги.

Текущий масштаб аннотаций автоматически определяет размер текста, отображаемого в пространстве модели и на видовых экранах пространства листа.

Например, если отображаемый на листе текст должен иметь высоту 3/16 дюйма, можно задать значение 3/16 дюйма для высоты на листе в текстовом стиле. Если для видового экрана задан масштаб "1/2 дюйма = 1 футу 10 дюймам", при добавлении текста на этом видовом экране текущий масштаб аннотаций, для которого задано то же значение, что и для масштаба видового экрана, обеспечивает автоматическое масштабирование текста до высоты приблизительно 4,5 дюйма.

Можно также преобразовать обычный текст в аннотативный, изменив значение свойства "Аннотативный" на "Да" применительно к данному тексту. Это относится к любому тексту, созданному на основе стилей текста или с помощью команд ТЕКСТ и МТЕКСТ.

Можно задать ориентацию аннотативных текстовых объектов, соответствующую ориентации листа бумаги. Боле подробную информацию о задании ориентации аннотативных объектов см. в разделе Задание ориентации аннотаций.

См. также

    • Нанесение текста

    • Работа с аннотативными стилями


Создание аннотативного текста (Процедура)

Работа с аннотативными стилями
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура создания нового аннотативного текстового стиля

Процедура преобразования обычного текстового стиля в аннотативный

Процедура создания однострочного аннотативного текста

Процедура создания многострочного аннотативного текста

Процедура преобразования обычного многострочного текста в аннотативный и наоборот

Процедура преобразования обычного текста (однострочного или многострочного) в аннотативный и наоборот

Процедура обновления текста с учетом текущих значений свойства "Аннотативный", заданных для текстового стиля

Процедура изменения высоты аннотативного текста, отображаемого на листе


Процедура создания нового аннотативного текстового стиля (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура создания нового аннотативного текстового стиля

  1. Выберите вкладку "Аннотирование" [image] панель "Текст" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" нажмите "Новый".
  3. В диалоговом окне "Новый текстовый стиль" введите имя нового стиля.
  4. Нажмите "ОК".
  5. В диалоговом окне "Текстовые стили" в разделе "Размер" выберите "Аннотативный".
  6. В поле "Высота текста в пространстве листа" введите высоту текста, отображаемого на листе.
  7. Нажмите кнопку "Применить".
  8. Для задания этого стиля в качестве текущего текстового стиля выберите "Установить как текущее" (не обязательно).
  9. Нажмите кнопку "Закрыть".
Ввод команды: СТИЛЬ


Процедура преобразования обычного текстового стиля в аннотативный (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура преобразования обычного текстового стиля в аннотативный

  1. Выберите вкладку "Аннотирование" [image] панель "Текст" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" выберите стиль из списка "Стили".
    ПримечаниеЗначок [image] рядом с именем текстового стиля указывает на то, что этот стиль уже является аннотативным.
  3. В разделе "Размер" выберите "Аннотативный".
  4. В поле "Высота текста в пространстве листа" введите высоту текста, отображаемого на листе.
  5. Нажмите кнопку "Применить".
  6. Для задания этого стиля в качестве текущего текстового стиля выберите "Установить как текущее" (не обязательно).
  7. Нажмите кнопку "Закрыть".
Ввод команды: СТИЛЬ


Процедура создания однострочного аннотативного текста (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура создания однострочного аннотативного текста

  1. Выберите вкладку "Аннотирование" [image] панель "Текст" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" выберите стиль аннотативного текста из списка "Стили".
    ПримечаниеЗначок [image] рядом с именем текстового стиля указывает на то, что этот стиль является аннотативным.
  3. Выберите "Установить как текущее" для задания этого стиля в качестве текущего стиля текста.
  4. Нажмите кнопку "Закрыть".
  5. Выберите вкладку "Аннотирование" [image] панель "Текст" [image] "Однострочный". В командной строке введите "текст".
  6. Укажите точку вставки первого символа.
  7. Задайте угол поворота текста.
  8. Введите текст.
Ввод команды: СТИЛЬ, ТЕКСТ


Процедура создания многострочного аннотативного текста (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура создания многострочного аннотативного текста

  1. Выберите вкладку "Аннотирование" [image] панель "Текст" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Укажите местоположение противоположных углов ограничивающей рамки для задания ширины многострочного текстового объекта. Отображается окно контекстного редактора.
  3. Выполните одно из следующих действий.
    • На панели инструментов "Формат текста" щелкните на стрелке рядом с управляющим элементом "Текстовые стили" и выберите в списке существующий стиль аннотативного текста.
    • Нажмите кнопку "Аннотативный" на панели инструментов для создания аннотативного многострочного текста.
  4. Введите текст.
  5. На панели инструментов "Формат текста" нажмите "ОК".
Ввод команды: МТЕКСТ


Процедура преобразования обычного многострочного текста в аннотативный и наоборот (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура преобразования обычного многострочного текста в аннотативный и наоборот

  1. Дважды щелкните на многострочном текстовом объекте. Отображается окно контекстного редактора.
  2. Нажмите кнопку "Аннотативный" [image] на панели инструментов для преобразования обычного многострочного текста в аннотативный или наоборот.

    Если кнопка "Аннотативный" выглядит утопленной, текст является аннотативным. В противном случае текст не является аннотативным.

  3. Нажмите "ОК" для сохранения изменений.
Контекстное меню:Выберите текст и щелкните на нем правой кнопкой мыши. Нажмите "Свойства" для изменения значения свойства "Аннотативный" применительно к данному тексту.


Процедура преобразования обычного текста (однострочного или многострочного) в аннотативный и наоборот (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура преобразования обычного текста (однострочного или многострочного) в аннотативный и наоборот

  1. Выберите на чертеже текстовый объект.
  2. Для отображения палитры "Свойства" выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре "Свойства" в разделе "Текст" выберите "Аннотативный".
  4. В раскрывающемся списке выберите "Да" или "Нет".
Ввод команды: СВОЙСТВА


Процедура обновления текста с учетом текущих значений свойства "Аннотативный", заданных для текстового стиля (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативного текста
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура обновления текста с учетом текущих значений свойства "Аннотативный", заданных для текстового стиля

  1. Выберите вкладку "Аннотирование" [image] панель "Текст" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" в списке "Стили" выберите стиль, связанный с текстом, который требуется обновить.
    ПримечаниеЗначок [image] рядом с именем текстового стиля указывает на то, что этот стиль уже является аннотативным.
  3. В разделе "Размер" выберите "Аннотативный".
  4. В диалоговом окне "Высота текста в пространстве листа" введите высоту текста, отображаемого на листе.
  5. Нажмите кнопку "Применить".
  6. Для задания этого стиля в качестве текущего текстового стиля выберите "Установить как текущее" (не обязательно).
  7. Нажмите кнопку "Закрыть".
  8. Выберите на чертеже все текстовые объекты (однострочный и многострочный текст), которые требуется обновить.
  9. В командной строке введите "аннообновить".
Ввод команды: СТИЛЬ


Процедура изменения высоты аннотативного текста, отображаемого на листе (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Процедура изменения высоты аннотативного текста, отображаемого на листе

  1. Выберите на чертеже текстовый объект.
  2. Для отображения палитры "Свойства" выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре "Свойства" в разделе "Высота текста в пространстве листа" выберите "Аннотативный".
Ввод команды: СВОЙСТВА


Создание аннотативного текста (Краткий справочник)

Работа с аннотативными стилями
Создание аннотативного текста
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативного текста >
Создание аннотативного текста
Понятие Процедура Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

СТИЛЬ

Создание, изменение или определение стилей текста

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание аннотативных размеров и допусков (Понятие)

Создание аннотативного текста
Создание аннотативных объектов
Создание аннотативных выносок и мультивыносок
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Для измерений на чертеже можно создавать аннотативный размеры на основе аннотативных размерных стилей.

Все элементы размеров, созданных на основе аннотативных размерных стилей, такие как текст, интервалы и стрелки, масштабируются равномерно посредством масштаб аннотаций .

После связывания размера с аннотативным объектом ассоциативность размера утрачивается.

Кроме того, можно преобразовать существующий обычный размер в аннотативный, изменив значение свойства "Аннотативный" для этого размера на "Да".

ПримечаниеКогда текущий размерный стиль является аннотативным, значение системной переменной DIMSCALE автоматически устанавливается равным 0 и не влияет на масштаб размеров.

Можно также создавать аннотативные допуски. Геометрические допуски указывают допустимые отклонения формы, профиля, ориентации, местоположения и протяженности компонента.

См. также

    • Размеры и допуски

    • Размерные стили

    • Работа с аннотативными стилями


Создание аннотативных размеров и допусков (Процедура)

Создание аннотативного текста
На уровень вверх ..
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Процедура создания нового стиля аннотативных размеров

Процедура преобразования существующего размерного стиля в аннотативный

Процедура создания аннотативного размера

Процедура преобразования обычного размера в аннотативный и наоборот

Процедура обновления размеров с учетом текущих значений свойств "Аннотативный", заданных для размерного стиля

Процедура создания аннотативного допуска


Процедура создания нового стиля аннотативных размеров (Процедура)

Создание аннотативных размеров и допусков
На уровень вверх ..
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Процедура создания нового стиля аннотативных размеров

  1. Выберите вкладку "Аннотирование" [image] панель "Размеры" [image] "Размерный стиль". В командной строке введите "рзмстиль".
  2. В диалоговом окне "Диспетчер размерных стилей" нажмите "Новый".
  3. В диалоговом окне "Создание нового размерного стиля" введите имя нового стиля.
  4. Выберите "Аннотативный".
  5. Нажмите кнопку "Продолжить".
  6. В диалоговом окне "Новый размерный стиль" выберите соответствующую вкладку и внесите изменения для задания размерного стиля.
  7. Нажмите "ОК".
  8. Для задания этого стиля в качестве текущего размерного стиля выберите "Установить как текущее" (не обязательно).
  9. Нажмите кнопку "Закрыть".
Ввод команды: РЗМСТИЛЬ


Процедура преобразования существующего размерного стиля в аннотативный (Процедура)

Создание аннотативных размеров и допусков
На уровень вверх ..
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Процедура преобразования существующего размерного стиля в аннотативный

  1. Выберите вкладку "Аннотирование" [image] панель "Размеры" [image] "Размерный стиль". В командной строке введите "рзмстиль".
  2. В диалоговом окне "Диспетчер размерных стилей" выберите стиль из списка "Стили".
    ПримечаниеЗначок [image] рядом с именем размерного стиля указывает на то, что этот стиль уже является аннотативным.
  3. Нажмите кнопку "Редактирование".
  4. В диалоговом окне "Изменение размерного стиля" на вкладке "Вписать" в разделе "Масштаб размерных элементов" выберите "Аннотативный".
  5. Нажмите "ОК".
  6. Для задания этого стиля в качестве текущего размерного стиля выберите "Установить как текущее" (не обязательно).
  7. Нажмите кнопку "Закрыть".
Ввод команды: РЗМСТИЛЬ


Процедура создания аннотативного размера (Процедура)

Создание аннотативных размеров и допусков
На уровень вверх ..
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Процедура создания аннотативного размера

  1. Выберите вкладку "Аннотирование" [image] панель "Размеры" [image] "Размерный стиль". В командной строке введите "рзмстиль".
  2. В диалоговом окне "Диспетчер размерных стилей" выберите аннотативный размерный стиль из списка "Стили".

    Значок [image] рядом с именем размерного стиля указывает на то, что этот стиль уже является аннотативным.

  3. Нажмите кнопку "Установить".
  4. Нажмите кнопку "Закрыть".
  5. Щелкните на меню "Размер" и выберите тип размера. В командной строке введите команду создания размера.
  6. Нажмите клавишу ENTER, чтобы выбрать объект для нанесения размеров, или укажите начальные точки первой и второй выносных линий.
  7. Укажите местоположение размерной линии.
Ввод команды: РЗМСТИЛЬ


Процедура преобразования обычного размера в аннотативный и наоборот (Процедура)

Создание аннотативных размеров и допусков
На уровень вверх ..
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Процедура преобразования обычного размера в аннотативный и наоборот

  1. Выберите на чертеже размер.
  2. Для отображения палитры "Свойства" выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре "Свойства" в разделе "Прочие" выберите "Аннотативный".
  4. В раскрывающемся списке выберите "Да" или "Нет".
Ввод команды: СВОЙСТВА


Процедура обновления размеров с учетом текущих значений свойств "Аннотативный", заданных для размерного стиля (Процедура)

Создание аннотативных размеров и допусков
На уровень вверх ..
Создание аннотативных размеров и допусков
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Процедура обновления размеров с учетом текущих значений свойств "Аннотативный", заданных для размерного стиля

  1. Выберите вкладку "Аннотирование" [image] панель "Размеры" [image] "Размерный стиль". В командной строке введите "рзмстиль".
  2. В диалоговом окне "Диспетчер размерных стилей" выберите стиль из списка "Стили".
    ПримечаниеЗначок [image] рядом с именем размерного стиля указывает на то, что этот стиль уже является аннотативным.
  3. Нажмите кнопку "Редактирование".
  4. В диалоговом окне "Изменение размерного стиля" на вкладке "Вписать" в разделе "Масштаб размерных элементов" выберите "Аннотативный".
  5. Нажмите "ОК".
  6. Для задания этого стиля в качестве текущего размерного стиля выберите "Установить как текущее" (не обязательно).
  7. Нажмите кнопку "Закрыть".
  8. Выберите на чертеже все размеры, которые требуется обновить.
  9. В командной строке введите "аннообновить".
Ввод команды: СТИЛЬ


Процедура создания аннотативного допуска (Процедура)

Создание аннотативных размеров и допусков
На уровень вверх ..
Создание аннотативных выносок и мультивыносок
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Процедура создания аннотативного допуска

  1. Выполните действия, приведенные в разделе Нанесение допуска формы и расположения .
  2. Для отображения палитры "Свойства" выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре "Свойства" в разделе "Прочие" выберите "Аннотативный".
  4. В раскрывающемся списке выберите "Да" или "Нет".
Ввод команды: СВОЙСТВА


Создание аннотативных размеров и допусков (Краткий справочник)

Создание аннотативного текста
Создание аннотативных размеров и допусков
Создание аннотативных выносок и мультивыносок
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных размеров и допусков >
Создание аннотативных размеров и допусков
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

DIMANNO

Создание однострочных текстовых объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Создание аннотативных выносок и мультивыносок (Понятие)

Создание аннотативных размеров и допусков
Создание аннотативных объектов
Создание аннотативных блоков и атрибутов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Создание аннотативных выносок и мультивыносок
Понятие Процедура Краткий справочник

Выноски и мультивыноска служат для добавления меток-идентификаторов к чертежам. Выноски со свойством "аннотативный " можно создавать на основе аннотативных стилей размеров, а мультивыноски - на основе аннотативных стилей мультивыносок.

В процессе создания выноски создаются два отдельных объекта: выноска и связанный с ней текст, блок или допуск. В процессе создания мультивыноски создается один объект.

Если стиль мультивыноски является аннотативным, связанный с ней текст или допуск также является аннотативным, независимо от значения свойства "Аннотативный", заданного для текстового стиля или допуска.

Блоки, связанные с аннотативными выносками, всегда являются аннотативными. Блоки, связанные с аннотативными мультивыносками, не обязательно являются аннотативными.

Значение свойства "Аннотативный" для выносок и мультивыносок можно также изменить на палитре "Свойства".

См. также

    • Создание выносок

    • Работа со стилями выносок


Создание аннотативных выносок и мультивыносок (Процедура)

Создание аннотативных размеров и допусков
На уровень вверх ..
Создание аннотативных выносок и мультивыносок
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных выносок и мультивыносок >
Создание аннотативных выносок и мультивыносок
Понятие Процедура Краткий справочник

Процедура создания нового стиля аннотативных мультивыносок

Процедура преобразования существующего стиля мультивыносок в аннотативный

Процедура создания аннотативной мультивыноски

Процедура преобразования обычной выноски или мультивыноски в аннотативную и наоборот


Процедура создания нового стиля аннотативных мультивыносок (Процедура)

Создание аннотативных выносок и мультивыносок
На уровень вверх ..
Создание аннотативных выносок и мультивыносок
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных выносок и мультивыносок >
Создание аннотативных выносок и мультивыносок
Понятие Процедура Краткий справочник

Процедура создания нового стиля аннотативных мультивыносок

  1. Выберите вкладку "Аннотирование" [image] панель "Мультивыноски" [image] "Стиль мультивыносок". В командной строке введите "мвыноскастиль".
  2. В диалоговом окне "Диспетчер стилей мультивыносок" нажмите "Новый".
  3. В диалоговом окне "Создание нового стиля мультивыносок" введите имя нового стиля, затем выберите "Аннотативный".
  4. Нажмите кнопку "Продолжить".
  5. В диалоговом окне "Изменение стиля мультивыносок" выберите соответствующую вкладку и внесите изменения для задания стиля мультивыносок.
  6. Нажмите "ОК".
  7. Для задания этого стиля в качестве стиля мультивыносок по умолчанию выберите "Установить как текущее" (не обязательно).
  8. Нажмите кнопку "Закрыть".
Ввод команды: МВЫНОСКАСТИЛЬ


Процедура преобразования существующего стиля мультивыносок в аннотативный (Процедура)

Создание аннотативных выносок и мультивыносок
На уровень вверх ..
Создание аннотативных выносок и мультивыносок
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных выносок и мультивыносок >
Создание аннотативных выносок и мультивыносок
Понятие Процедура Краткий справочник

Процедура преобразования существующего стиля мультивыносок в аннотативный

  1. Выберите вкладку "Аннотирование" [image] панель "Мультивыноски" [image] "Стиль мультивыносок". В командной строке введите "мвыноскастиль".
  2. В диалоговом окне "Диспетчер стилей мультивыносок" выберите стиль из списка "Стили".
    ПримечаниеЗначок [image] рядом с именем стиля мультивыносок указывает на то, что этот стиль уже является аннотативным.
  3. Нажмите кнопку "Редактирование".
  4. В диалоговом окне "Изменение стиля мультивыносок" на вкладке "Структура выноски" в разделе "Масштаб" выберите "Аннотативный".
  5. Нажмите "ОК".
  6. Для задания этого стиля в качестве стиля мультивыносок по умолчанию выберите "Установить как текущее" (не обязательно).
  7. Нажмите кнопку "Закрыть".
Ввод команды: МВЫНОСКАСТИЛЬ


Процедура создания аннотативной мультивыноски (Процедура)

Создание аннотативных выносок и мультивыносок
На уровень вверх ..
Создание аннотативных выносок и мультивыносок
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных выносок и мультивыносок >
Создание аннотативных выносок и мультивыносок
Понятие Процедура Краткий справочник

Процедура создания аннотативной мультивыноски

  1. Выберите вкладку "Аннотирование" [image] панель "Мультивыноски" [image] "Стиль мультивыносок". В командной строке введите "мвыноскастиль".
  2. В диалоговом окне "Диспетчер стилей мультивыносок" выберите стиль аннотативных мультивыносок в списке "Стили".
    ПримечаниеЗначок [image] рядом с именем стиля мультивыносок указывает на то, что этот стиль является аннотативным.
  3. Нажмите кнопку "Установить".
  4. Нажмите кнопку "Закрыть".
  5. Выберите вкладку "Аннотирование" [image] панель "Мультивыноски" [image] "Мультивыноска". В командной строке введите "мвыноска".
  6. Выберите точку для стрелки выноски.
  7. Выберите концевую точку выноски.
  8. Укажите ширину текста.
  9. Введите текст.
  10. На панели инструментов "Формат текста" нажмите "ОК".
Ввод команды: МВЫНОСКАСТИЛЬ, МВЫНОСКА


Процедура преобразования обычной выноски или мультивыноски в аннотативную и наоборот (Процедура)

Создание аннотативных выносок и мультивыносок
На уровень вверх ..
Создание аннотативных блоков и атрибутов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных выносок и мультивыносок >
Создание аннотативных выносок и мультивыносок
Понятие Процедура Краткий справочник

Процедура преобразования обычной выноски или мультивыноски в аннотативную и наоборот

  1. Выберите на чертеже выноску или мультивыноску.
  2. Для отображения палитры "Свойства" выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре "Свойства" в разделе "Прочие" выберите "Аннотативный".
  4. В раскрывающемся списке выберите "Да" или "Нет".
Ввод команды: СВОЙСТВА


Создание аннотативных выносок и мультивыносок (Краткий справочник)

Создание аннотативных размеров и допусков
Создание аннотативных выносок и мультивыносок
Создание аннотативных блоков и атрибутов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных выносок и мультивыносок >
Создание аннотативных выносок и мультивыносок
Понятие Процедура Краткий справочник

Команды

МВЫНОСКАСТИЛЬ

Создание и модификация стилей мультивыносок

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание аннотативных блоков и атрибутов (Понятие)

Создание аннотативных выносок и мультивыносок
Создание аннотативных объектов
Создание аннотативной штриховки
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Создание аннотативных блоков и атрибутов
Понятие Процедура Краткий справочник

Если требуется аннотировать чертеж посредством геометрических объектов, можно объединить такие объекты, составив из них определение аннотативного блока.

На основе определений аннотативных блоков создаются ссылки на аннотативные блоки. Ссылкам на аннотативные блоки и атрибутам аннотативных блоков первоначально назначено то значение масштаба аннотаций, которое было текущим на момент их вставки. Ссылки на аннотативные блоки следует вставлять с коэффициентом 1.

Невозможно изменить значение свойства "Аннотативный" для отдельных ссылок на блоки.

Если для аннотативного блока требуется задать формат листа бумаги, следует при определении блока в пространстве листа или на вкладке "Модель" задать для параметра масштаб аннотаций значение 1:1.

При создании аннотативных блоков и аннотативных объектов внутри блоков, а также при работе с ними необходимо учитывать следующую информацию.

  • Блоки, не являющиеся аннотативными, могут содержать аннотативные объекты; к таким объектам, помимо масштаба аннотаций, применяется коэффициент масштабирования, заданный для блока.
  • Аннотативный блок не может содержаться в другом аннотативном блоке.
  • Ссылки на аннотативные блоки масштабируются равномерно на основе текущего масштаба аннотаций или любого пользовательского масштаба, примененного к ссылке на блок.
  • Не следует вручную масштабировать блоки, содержащие аннотативные объекты.

Для блоков можно задавать аннотативные атрибуты независимо от того, являются ли эти блоки аннотативными. Аннотативные атрибуты блоков, не являющихся аннотативными, применяются в том случае, если геометрические объекты в блоке требуется отображать на листе бумаги в масштабе видового экрана, а текст атрибута - в соответствии со значением параметра "Высота листа", заданным для этого атрибута.

Можно задать ориентацию аннотативных блоков, соответствующую ориентации листа бумаги. Более подробную информацию о задании ориентации аннотативных объектов см. в разделе Задание ориентации аннотаций.

С помощью системной переменной ANNOTATIVEDWG можно включить или отключить режим, при котором чертеж в целом при его вставке в другой чертеж функционирует как аннотативный блок. Если чертеж содержит аннотативные объекты, системная переменная ANNOTATIVEDWG доступна только для чтения.

ПримечаниеЗначение INSUNITS игнорируется при вставке аннотативный блоков в чертеж.
См. также

    • Создание и использование блоков (обозначений)

    • Атрибуты блоков


Создание аннотативных блоков и атрибутов (Процедура)

Создание аннотативных выносок и мультивыносок
На уровень вверх ..
Создание аннотативных блоков и атрибутов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных блоков и атрибутов >
Создание аннотативных блоков и атрибутов
Понятие Процедура Краткий справочник

Процедура создания определения аннотативного блока

Процедура преобразования существующих ссылок на блоки в ссылки на аннотативные блоки

Процедура создания определения аннотативного атрибута


Процедура создания определения аннотативного блока (Процедура)

Создание аннотативных блоков и атрибутов
На уровень вверх ..
Создание аннотативных блоков и атрибутов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных блоков и атрибутов >
Создание аннотативных блоков и атрибутов
Понятие Процедура Краткий справочник

Процедура создания определения аннотативного блока

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Блок" [image] "Создать". В командной строке введите "блок".
  2. В диалоговом окне "Определение блока" введите имя блока в поле "Имя".
  3. В разделе "Объекты" выберите "Преобразовать в блок".
  4. Нажмите "Выбрать объекты".
  5. В разделе "Поведение" выберите "Аннотативный".
  6. С помощью устройства указания выберите объекты, которые требуется включить в определение блока. Для завершения выбора объектов нажмите клавишу ENTER.
  7. В диалоговом окне "Определение блока" укажите точку вставки блока в поле "Базовая точка".
  8. Нажмите "ОК".
Ввод команды: БЛОК


Процедура преобразования существующих ссылок на блоки в ссылки на аннотативные блоки (Процедура)

Создание аннотативных блоков и атрибутов
На уровень вверх ..
Создание аннотативных блоков и атрибутов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных блоков и атрибутов >
Создание аннотативных блоков и атрибутов
Понятие Процедура Краткий справочник

Процедура преобразования существующих ссылок на блоки в ссылки на аннотативные блоки

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Блок" [image] "Создать". В командной строке введите "блок".
  2. В диалоговом окне "Определение блока" щелкните на стрелке в поле "Имя" и выберите имя блока, который требуется преобразовать в аннотативный блок.
  3. В разделе "Поведение" выберите "Аннотативный".
  4. Нажмите "ОК".

    Теперь существующие на чертеже ссылки на блоки являются ссылками на аннотативные блоки.

Ввод команды: БЛОК


Процедура создания определения аннотативного атрибута (Процедура)

Создание аннотативных блоков и атрибутов
На уровень вверх ..
Создание аннотативной штриховки
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных блоков и атрибутов >
Создание аннотативных блоков и атрибутов
Понятие Процедура Краткий справочник

Процедура создания определения аннотативного атрибута

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Атрибуты" [image] "Задание атрибутов". В командной строке введите "атопр".
  2. В диалоговом окне "Определение атрибута" задайте режимы работы с атрибутом; введите информацию о ярлыке, точку вставки и параметры текста.
  3. В разделе "Параметры текста" выберите "Аннотативный".
  4. Нажмите "ОК".
  5. Укажите начальную точку.
  6. Нажмите клавишу ENTER.
Ввод команды: АТОПР


Создание аннотативных блоков и атрибутов (Краткий справочник)

Создание аннотативных выносок и мультивыносок
Создание аннотативных блоков и атрибутов
Создание аннотативной штриховки
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативных блоков и атрибутов >
Создание аннотативных блоков и атрибутов
Понятие Процедура Краткий справочник

Команды

АТОПР

Создание определения атрибута для хранения данных в блоке

БЛОК

Создание определения блока из выбранных объектов

Системные переменные

ANNOTATIVEDWG

Определение поведения чертежа как аннотативный блока при вставке в другой чертеж

Утилиты

Нет

Ключевые слова для команд

Нет


Создание аннотативной штриховки (Понятие)

Создание аннотативных блоков и атрибутов
Создание аннотативных объектов
Отображение аннотативных объектов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов >
Создание аннотативной штриховки
Понятие Процедура Краткий справочник

Аннотативная штриховка применяется для обозначения таких материалов, как песок, бетон, сталь, грунт и др.

Штриховка аннотативный определяется для конкретного формата листа бумаги. Можно создать аннотативную штриховку в виде отдельного объекта или образец аннотативной штриховки.

На основе аннотативных образцов штриховки (хранящихся в файле acad.pat) создаются аннотативные объекты-штриховки. При выборе аннотативного образца штриховки в диалоговом окне "Штриховка и градиент" флажок "Аннотативный" устанавливается автоматически.

Ориентация аннотативной штриховки всегда совпадает с ориентацией листа.


Создание аннотативной штриховки (Процедура)

Создание аннотативных блоков и атрибутов
На уровень вверх ..
Создание аннотативной штриховки
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативной штриховки >
Создание аннотативной штриховки
Понятие Процедура Краткий справочник

Процедура создания аннотативного объекта-штриховки

Процедура преобразования существующего объекта-штриховки в аннотативный объект


Процедура создания аннотативного объекта-штриховки (Процедура)

Создание аннотативной штриховки
На уровень вверх ..
Создание аннотативной штриховки
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативной штриховки >
Создание аннотативной штриховки
Понятие Процедура Краткий справочник

Процедура создания аннотативного объекта-штриховки

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка".В командной строке введите "штрих".
  2. В диалоговом окне "Штриховка и градиент" щелкните на элементе "Добавить: выбрать объекты".
  3. Укажите один или несколько объектов, которые необходимо заштриховать.
  4. В разделе "Настройка" выберите "Аннотативный".
  5. Нажмите "ОК".
Ввод команды: ШТРИХОВКА


Процедура преобразования существующего объекта-штриховки в аннотативный объект (Процедура)

Создание аннотативной штриховки
На уровень вверх ..
Отображение аннотативных объектов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативной штриховки >
Создание аннотативной штриховки
Понятие Процедура Краткий справочник

Процедура преобразования существующего объекта-штриховки в аннотативный объект

  1. В пространстве модели введите в командной строке команду "cannoscale".
  2. Введите значение масштаба, заданное для видового экрана, в котором отображается штриховка.
  3. Выберите на чертеже штриховку.
  4. На палитре "Свойства" в разделе "Образец" выберите "Аннотативный".
  5. В раскрывающемся списке выберите "Да".


Создание аннотативной штриховки (Краткий справочник)

Создание аннотативных блоков и атрибутов
Создание аннотативной штриховки
Отображение аннотативных объектов
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Создание аннотативных объектов > Создание аннотативной штриховки >
Создание аннотативной штриховки
Понятие Процедура Краткий справочник

Команды

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Отображение аннотативных объектов (Понятие)

Создание аннотативной штриховки
Масштабирование аннотаций
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций >
Отображение аннотативных объектов
Понятие Процедура Краткий справочник

Для видового экрана листа или пространства модели можно выбрать режим отображения всех объектов аннотативный или только тех объектов, которым назначено текущее значение масштаб аннотаций .

Это позволяет сократить количество слоев, необходимых для управления отображением аннотаций.

Выбор режима отображения аннотативных объектов осуществляется с помощью кнопки "Видимость аннотаций" в правой части строки состояния приложения или чертежа.

Демонстрация: задание режима отображения аннотаций

Для просмотра видеоролика с инструкциями щелкните на стрелке "Просмотр".

По умолчанию режим отображения аннотаций включен. Когда режим отображения аннотаций включен, отображаются все аннотативные объекты. Когда режим отображения аннотаций отключен [image], отображаются только те аннотативные объекты, которым назначено текущее значение масштаба.

В большинстве случаев режим отображения аннотаций следует отключить; включать его рекомендуется только при просмотре чертежей, созданных другими пользователями, и при добавлении значений масштаба к существующим аннотативным объектам.

Управлять отображением аннотаций можно также с помощью системной переменной ANNOALLVISIBLE.

Аннотативный объект может отображаться только в том случае, если включен слой, на котором расположен этот объект.

Если объекту назначено несколько значений масштаба аннотаций, объект отображается в масштабе, соответствующем текущему значению.

Если для системной переменной MSLTSCALE задано значение 1 (по умолчанию), линиям различных типов, отображаемым на вкладке модели, назначается масштаб в соответствии с масштабом аннотаций.

См. также

    • Строка состояния чертежа


Процедура отображения или скрытия аннотативных объектов на чертеже (Процедура)

Создание аннотативной штриховки
На уровень вверх ..
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Отображение аннотативных объектов >
Отображение аннотативных объектов
Понятие Процедура Краткий справочник

Процедура отображения или скрытия аннотативных объектов на чертеже

  1. Нажмите в строке состояния чертежа или приложения кнопку "Видимость аннотаций".

    Если кнопка имеет вид [image], отображаются все аннотативные объекты.

    Если кнопка имеет вид [image], отображаются только те аннотативные объекты, которым назначен текущий масштаб аннотаций.


Отображение аннотативных объектов (Краткий справочник)

Создание аннотативной штриховки
Отображение аннотативных объектов
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Отображение аннотативных объектов >
Отображение аннотативных объектов
Понятие Процедура Краткий справочник

Команды

Нет

Системные переменные

ANNOALLVISIBLE

Скрытие или отображение аннотативный объектов, не поддерживающих текущего масштаб аннотаций

MSLTSCALE

Масштабирование типов линий, отображаемых на вкладке модели масштаб аннотаций

SELECTIONANNODISPLAY

Управление временным отключением доступности масштабируемых представлений при выборе объекта аннотативный

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление и изменение масштабируемых представлений (Понятие)

Отображение аннотативных объектов
Масштабирование аннотаций
Задание ориентации аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Объекту аннотативный , созданному на чертеже, назначено одно значение масштаб аннотаций : масштаб аннотаций, который был текущим на момент создания объекта. Можно обновить аннотативные объекты, добавив к ним дополнительные значения масштаба аннотаций.

При обновлении аннотативного объекта, заключающемся в назначении ему дополнительных значений масштаба, к этому объекту добавляются дополнительные масштабируемые представления.

Например, если аннотативной мультивыноске назначено два дополнительных значения масштаба, ей соответствует два масштабируемых представления.

Демонстрация: добавление масштабируемых представлений к объектам

Для просмотра видеоролика с инструкциями щелкните на стрелке "Просмотр".

При выборе аннотативного объекта на масштабируемом представлении, которое соответствует текущему масштабу аннотаций, отображаются ручки. С помощью этих ручек можно настроить представление, соответствующее текущему масштабу. Если системной переменной SELECTIONANNODISPLAY присвоено значение 1, все остальные масштабируемые представления объекта недоступны и отображаются серым цветом.

Демонстрация: изменение масштабируемых представлений

Для просмотра видеоролика с инструкциями щелкните на стрелке "Просмотр".

При выполнении команды " АННОСБРОС " для всех представлений данного аннотативного объекта с учетом масштаба задается местоположение, соответствующее местоположению текущего представления с учетом масштаба.


Добавление и изменение масштабируемых представлений (Процедура)

Отображение аннотативных объектов
На уровень вверх ..
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Добавление и изменение масштабируемых представлений >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Процедура добавления текущего масштаба аннотаций к аннотативному объекту

Процедура удаления текущего масштаба аннотаций из аннотативного объекта

Процедура включения режима, в котором текущее значение масштаба аннотаций автоматически применяется к аннотативным объектам

Процедура добавления масштаба аннотаций к аннотативному объекту

Процедура удаления масштаба аннотаций из аннотативного объекта


Процедура добавления текущего масштаба аннотаций к аннотативному объекту (Процедура)

Добавление и изменение масштабируемых представлений
На уровень вверх ..
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Добавление и изменение масштабируемых представлений >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Процедура добавления текущего масштаба аннотаций к аннотативному объекту

  1. Выберите вкладку "Аннотирование" [image] панель "Масштабирование аннотаций" [image] "Добавить/Удалить масштабы". В командной строке введите "объектмасшт".
  2. Выберите на чертеже один или несколько аннотативных объектов.
  3. Нажмите клавишу ENTER.
Ввод команды: ОБЪЕКТМАСШТ
Контекстное меню:Выберите аннотативный объект и щелкните в области рисования правой кнопкой мыши. Выберите "Масштаб аннотативного объекта" [image] "Добавить текущий масштаб".


Процедура удаления текущего масштаба аннотаций из аннотативного объекта (Процедура)

Добавление и изменение масштабируемых представлений
На уровень вверх ..
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Добавление и изменение масштабируемых представлений >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Процедура удаления текущего масштаба аннотаций из аннотативного объекта

  1. Выберите вкладку "Аннотирование" [image] панель "Масштабирование аннотаций" [image] "Добавить/Удалить масштабы". В командной строке введите "объектмасшт".
  2. Выберите на чертеже один или несколько аннотативных объектов.
  3. Нажмите клавишу ENTER.
Ввод команды: ОБЪЕКТМАСШТ
Контекстное меню:Выберите аннотативный объект и щелкните в области рисования правой кнопкой мыши. Выберите "Масштаб аннотативного объекта" [image] "Добавить текущий масштаб".


Процедура включения режима, в котором текущее значение масштаба аннотаций автоматически применяется к аннотативным объектам (Процедура)

Добавление и изменение масштабируемых представлений
На уровень вверх ..
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Добавление и изменение масштабируемых представлений >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Процедура включения режима, в котором текущее значение масштаба аннотаций автоматически применяется к аннотативным объектам

  • В строке состояния чертежа или приложения нажмите кнопку [image]; вид кнопки изменяется на [image].


Процедура добавления масштаба аннотаций к аннотативному объекту (Процедура)

Добавление и изменение масштабируемых представлений
На уровень вверх ..
Добавление и изменение масштабируемых представлений
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Добавление и изменение масштабируемых представлений >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Процедура добавления масштаба аннотаций к аннотативному объекту

  1. Выберите вкладку "Аннотирование" [image] панель "Масштабирование аннотаций" [image] "Добавить/Удалить масштабы". В командной строке введите "объектмасшт".
  2. В области рисования выберите один или несколько аннотативных объектов.
  3. Нажмите клавишу ENTER.
  4. В диалоговом окне "Масштаб аннотативного объекта" нажмите "Добавить".
  5. В диалоговом окне "Добавление масштабов к объекту" выберите одно или несколько значений масштаба для добавления к объектам. (Выбор нескольких значений выполняется при нажатой клавише SHIFT.)
  6. Нажмите "ОК".
  7. В диалоговом окне "Масштаб аннотативного объекта" нажмите "ОК".
Ввод команды: ОБЪЕКТМАСШТ
Контекстное меню:Выберите аннотативный объект и щелкните в области рисования правой кнопкой мыши. Выберите "Масштаб аннотативного объекта" [image] "Добавить/Удалить масштабы".


Процедура удаления масштаба аннотаций из аннотативного объекта (Процедура)

Добавление и изменение масштабируемых представлений
На уровень вверх ..
Задание ориентации аннотаций
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Добавление и изменение масштабируемых представлений >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Процедура удаления масштаба аннотаций из аннотативного объекта

  1. Выберите вкладку "Аннотирование" [image] панель "Масштабирование аннотаций" [image] "Добавить/Удалить масштабы". В командной строке введите "объектмасшт".
  2. В области рисования выберите один или несколько аннотативных объектов.
  3. Нажмите клавишу ENTER.
  4. В диалоговом окне "Масштаб аннотативного объекта" выберите одной или несколько значений масштаба, которые требуется удалить из объектов. (Для выбора нескольких значений масштаба нажмите и удерживайте нажатой клавишу SHIFT).
    ПримечаниеУдалить масштаб 1:1 невозможно.
  5. Нажмите "ОК".
Ввод команды: ОБЪЕКТМАСШТ
Контекстное меню:Выберите аннотативный объект и щелкните в области рисования правой кнопкой мыши. Выберите "Масштаб аннотативного объекта" [image] "Добавить/Удалить масштабы".


Добавление и изменение масштабируемых представлений (Краткий справочник)

Отображение аннотативных объектов
Добавление и изменение масштабируемых представлений
Общие сведения об образцах штриховки и заливки
Аннотирование чертежей > Работа с аннотациями > Масштабирование аннотаций > Добавление и изменение масштабируемых представлений >
Добавление и изменение масштабируемых представлений
Понятие Процедура Краткий справочник

Команды

АННОСБРОС

Восстановление местоположения всех масштабируемых представлений для аннотативный объекта, к которому относится текущее масштабируемое представление

ОБЪЕКТМАСШТ

Добавление или удаление поддерживаемых масштабов для объектов аннотативный

Системные переменные

SELECTIONANNODISPLAY

Управление временным отключением доступности масштабируемых представлений при выборе объекта аннотативный

Утилиты

Нет

Ключевые слова для команд

Нет


Задание ориентации аннотаций (Понятие)

Добавление и изменение масштабируемых представлений
Работа с аннотациями
Штриховка, заливка и маскировка
Аннотирование чертежей > Работа с аннотациями >
Задание ориентации аннотаций
Понятие Процедура

Аннотативные блоки и текст можно настроить таким образом, что их ориентация будет соответствовать ориентации листа. Ориентация аннотативной штриховки всегда совпадает с ориентацией листа.

Даже в том случае, если вид в видовом экране листа искривлен или видовой экран не является плоским, ориентация этих объектов в видовых экранах листа соответствует ориентации листа.

Аннотативные атрибуты в блоках соответствуют ориентации листа бумаги для блока.

См. также

    • Работа с текстовыми стилями

    • Создание аннотативного текста

    • Создание аннотативных блоков и атрибутов

    • Создание аннотативной штриховки


Задание ориентации аннотаций (Процедура)

Добавление и изменение масштабируемых представлений
Задание ориентации аннотаций
Задание ориентации аннотаций
Аннотирование чертежей > Работа с аннотациями > Задание ориентации аннотаций >
Задание ориентации аннотаций
Понятие Процедура

Процедура согласования аннотативного текстового стиля с ориентацией листа

Процедура согласования определения аннотативного блока с ориентацией листа

Процедура согласования существующего аннотативного текстового объекта с ориентацией листа


Процедура согласования аннотативного текстового стиля с ориентацией листа (Процедура)

Задание ориентации аннотаций
Задание ориентации аннотаций
Задание ориентации аннотаций
Аннотирование чертежей > Работа с аннотациями > Задание ориентации аннотаций >
Задание ориентации аннотаций
Понятие Процедура

Процедура согласования аннотативного текстового стиля с ориентацией листа

  1. Выберите вкладку "Аннотирование" [image] панель "Текст" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" выберите стиль аннотативного текста из списка "Стили".
    ПримечаниеЗначок [image] рядом с именем текстового стиля указывает на то, что этот стиль является аннотативным.
  3. В разделе "Размер" выберите "Ориентация текста по листу".
  4. Нажмите кнопку "Применить".
  5. Нажмите кнопку "Закрыть".
Ввод команды: СТИЛЬ


Процедура согласования определения аннотативного блока с ориентацией листа (Процедура)

Задание ориентации аннотаций
Задание ориентации аннотаций
Задание ориентации аннотаций
Аннотирование чертежей > Работа с аннотациями > Задание ориентации аннотаций >
Задание ориентации аннотаций
Понятие Процедура

Процедура согласования определения аннотативного блока с ориентацией листа

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Блок" [image] "Создать". В командной строке введите "блок".
  2. В диалоговом окне "Определение блока" выберите блок в поле "Имя".
  3. В разделе "Поведение" выберите "Аннотативный".
  4. В разделе "Поведение" выберите "Ориентация блока по листу".
  5. Нажмите кнопку "Закрыть".
Ввод команды: БЛОК


Процедура согласования существующего аннотативного текстового объекта с ориентацией листа (Процедура)

Задание ориентации аннотаций
Задание ориентации аннотаций
Общие сведения об образцах штриховки и заливки
Аннотирование чертежей > Работа с аннотациями > Задание ориентации аннотаций >
Задание ориентации аннотаций
Понятие Процедура

Процедура согласования существующего аннотативного текстового объекта с ориентацией листа

  1. Выберите на чертеже аннотативный текстовый объект.
  2. Для отображения палитры "Свойства" выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".В командной строке введите "свойства".
  3. На палитре "Свойства" в разделе "Текст" выберите "Ориентация по листу".
Ввод команды: СВОЙСТВА


Штриховка, заливка и маскировка

Задание ориентации аннотаций
Аннотирование чертежей
Общие сведения об образцах штриховки и заливки
Аннотирование чертежей >
Штриховка, заливка и маскировка

Штриховку можно использовать для закрашивания области выбранным образцом или цветом. Для того чтобы оставить свободное место на области, можно создать маскирующий объект.

Темы в этом разделе

  • Общие сведения об образцах штриховки и заливки
  • Определение контуров штриховки

    Нанесение штриховки или заливки выполняется путем выбора объекта или определения контура с последующим указанием внутренней точки.

  • Выбор образцов штриховки и сплошной заливки

    Можно использовать стандартные образцы штриховки или сплошной заливки, а также определять собственные.

  • Редактирование штриховки и заливки

    Имеется возможность редактирования образцов и контуров штриховки (и сплошной заливки).

  • Создание пустых маскирующих областей

    Маскирующие объекты закрывают объекты чертежа с целью резервирования места для примечаний или скрытия каких-либо деталей.

См. также

    • Коротко об определении образцов штриховки в документе Руководство по адаптации

    • Редактирование сложных объектов


Общие сведения об образцах штриховки и заливки (Понятие)

Штриховка, заливка и маскировка
Штриховка, заливка и маскировка
Определение контуров штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка >
Общие сведения об образцах штриховки и заливки
Понятие Процедура Краткий справочник

Можно заштриховать область с помощью стандартных образцов, определить простой образец штриховки из текущего типа линии или создать более сложные образцы. Тип образца, заполняющий область чистым цветом, называется сплошным.

Градиентная заливка может состоять из оттенков одного цвета или представлять собой плавный переход из одного цвета в другой. Градиентные заливки можно использовать для украшения чертежей, создавая эффект отражающегося от объекта света.

Определение контуров штриховки

Можно выбрать один из способов определения контуров штриховки:

  • Указать точку на области, замкнутой объектами.
  • Выбрать объекты, окружающие область.
  • Из инструментальной палитры или Центра управления перетащите образец штриховки в замкнутую область.

Все объекты, полностью или частично попадающие в область штриховки и не являющиеся ее контуром, игнорируются и не влияют на процесс штрихования.

Если при выполнении команды ШТРИХОВКА линия штриховки пересекает такие объекты, как текст, атрибут, объект со сплошной заливкой или объект, выделенный как часть набора контуров, штриховка обтекает данные объекты.

ПримечаниеЕсли необходимо заштриховать область с незамкнутым контуром, можно так настроить системную переменную HPGAPTOL, что зазоры не будет учитываться и контур будет считаться замкнутым. Системная переменная HPGAPTOL используется только для разрывов между отрезками и дугами, которые пересеклись бы при их удлинении.

Для уменьшения размера файла область со штриховкой определяется в базе данных чертежа как единый графической объект.

Нанесение штриховки и сплошной заливки

Для нанесения штриховки можно использовать несколько методов.

  • Команда ШТРИХОВКА содержит большое число параметров.
  • Штриховки можно перетаскивать из инструментальной палитры. Наиболее простой и быстрый способ штрихования предоставляют инструментальные палитры.

    В открытом окне "Инструментальные палитры" можно нажать правой кнопкой мыши на выбранном образце штриховки и вызвать диалоговое окно "Свойства инструмента" из контекстного меню. В этом диалоговом окне содержится несколько параметров образца штриховки, которые также доступны при вызове команды ШТРИХОВКА. Например, можно задать масштаб и интервал между линиями штриховки.

  • Можно также использовать Центр управления.

Управление исходной точкой штриховки

По умолчанию образцы штриховки всегда выравниваются по отношению друг к другу. Тем не менее, иногда может потребоваться перенести начальную точку штриховки (исходная точка). Например, при создании образца кирпичной кладки, возможно, потребуется начать с целого кирпича в левом нижнем углу штрихуемой области. В этом случае используйте параметры "Исходная точка штриховки" диалогового окна "Штриховка и градиент".

Положение и вид образца штриховки зависит от системных переменных HPORIGIN, HPORIGINMODE и HPINHERIT, связанных с расположением и ориентацией пользовательской системы координат.

Выбор образца штриховки

В комплект поставки программы входит образец сплошной заливки и более чем 50 стандартных образцов штриховки, которые можно использовать для различения компонентов объектов или представления материалов объектов. В состав программы также входят 14 образцов штриховки, соответствующих стандартам ISO (Международная организация по стандартизации). Для штриховки по стандарту ISO можно задать толщину пера, которая определяет вес линий образца.

На вкладке "Штриховка" диалогового окна "Штриховка и градиент" в области "Тип и массив" отображаются имена всех образцов штриховки, определенных в текстовом файле acad.pat. Можно добавить в список в этом диалоговом окне новые образцы штриховки; для этого следует добавить их определения в файл acad.pat.

Нанесение ассоциативной штриховки

Обновление ассоциативной штриховки происходит при изменениях контура. Штриховка, нанесенная с помощью команды ШТРИХОВКА, является ассоциативной по умолчанию. Данная настройка хранится в системной переменной HPASSOC. К штриховкам, созданным путем перетаскивания образцов штриховки из палитры инструментов или Центра управления (DesignCenter™), применяется значение системной переменной HPASSOC. Можно в любой момент отменить ассоциативность штриховки или воспользоваться командой ШТРИХОВКА для создания неассоциативной штриховки. Если для системной переменной HPGAPTOL задано значение 0 (значение по умолчанию), ассоциативность устраняется автоматически, если при внесении правки создается разомкнутый контур.

Можно использовать команду ШТРИХОВКА для нанесения неассоциативной штриховки, не зависящей от контура.

Создание аннотативной штриховки

Штриховка аннотативный определяется для конкретного формата листа бумаги. Можно создать аннотативную штриховку в виде отдельного объекта или образец аннотативной штриховки.

Аннотативная штриховка применяется для обозначения таких материалов, как песок, бетон, сталь, грунт и др.

Более подробную информацию о создании аннотативной штриховки и о работе с ней см. в разделе Создание аннотативной штриховки.

Назначение штриховке порядка прорисовки

Штриховке можно назначить порядок прорисовки таким образом, чтобы она помещалась за или перед контуром на заднем или на переднем плане.

При нанесении штриховки она по умолчанию помещается за контуром. Это облегчает просмотр и выбор контура штриховки. Порядок прорисовки для штриховки можно изменить таким образом, чтобы она помещалась перед контуром на заднем или на переднем плане. Этот режим определяется значением системной переменной HPDRAWORDER. Штриховки, созданные путем перетаскивания образца штриховки из инструментальной палитры или из Центра управления, используют значение системной переменной HPDRAWORDER.

Ограничение плотности образца штриховки

При нанесении слишком плотной штриховки программа может отменить выполнение операции и вывести сообщение о том, что масштаб штриховки или длина пунктира слишком малы. Можно изменить максимальное количество линий штриховки путем задания системной переменной HPMAXLINES . Диапазон допустимых значений - от 100 до 10000000 (десять миллионов). По умолчанию для системной переменной HPMAXLINES задано значение 1000000.

Редактирование контуров штриховки

Поскольку комбинации штрихуемых областей крайне разнообразны, при редактировании объектов, определяющих штриховку, могут проявиться различные побочные эффекты. Если нанесение штриховки не дало ожидаемого результата, то можно отменить действие или удалить штриховку, а затем повторить попытку с другими параметрами.

Создание пользовательских образцов штриховки

Можно также создать собственный образец штриховки с помощью текущего типа линий и параметра "Пользовательская штриховка" диалогового окна "Штриховка и градиент". Можно также создать более сложные образцы.

См. также

    • Редактирование штриховки и заливки

    • См. раздел Коротко об определении образцов штриховки в документе Руководство по адаптации

    • Масштабирование аннотаций


Общие сведения об образцах штриховки и заливки (Процедура)

Задание ориентации аннотаций
Общие сведения об образцах штриховки и заливки
Общие сведения об образцах штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Общие сведения об образцах штриховки и заливки >
Общие сведения об образцах штриховки и заливки
Понятие Процедура Краткий справочник

Перетаскивание образцов штриховки в чертеж

Штрихование областей

Штрихование выбранных объектов


Перетаскивание образцов штриховки в чертеж (Процедура)

Общие сведения об образцах штриховки и заливки
Общие сведения об образцах штриховки и заливки
Общие сведения об образцах штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Общие сведения об образцах штриховки и заливки >
Общие сведения об образцах штриховки и заливки
Понятие Процедура Краткий справочник

Перетаскивание образцов штриховки в чертеж

  1. Выберите пункт меню "Сервис" [image] "Палитры" [image] "Центр управления".В командной строке введите "цуоткл".
    ПримечаниеДействия, описанные ниже, позволяют перетаскивать образцы штриховок из Центра управления непосредственно в чертеж. Образцы штриховок можно также перетаскивать с инструментальной палитры.
  2. Перейдите на вкладку "Папки" и нажмите кнопку "Поиск".
  3. В диалоговом окне "Поиск" необходимо выполнить следующие действия:
    • В списке "Что искать" выбрать "Файлы образцов штриховки".
    • В списке "Где искать" выбрать диск, на котором установлена программа.
    • Установить флажок "Просматривать вложенные папки".
    • На вкладке "Файлы образцов штриховки" в поле "Искать имя" введите * (звездочку).
  4. Нажать кнопку "Найти".

    Образец штриховки по умолчанию хранится в файле acad.pat или acadiso.pat. Результатом поиска может быть этот же файл, найденный по другому пути.

    ПримечаниеДля быстрого доступа к PAT-файлу можно занести его в папку "Избранное". Ярлык РАТ-файла отображается в папке "Избранное" на вкладке "Папки" в Центре управления.
  5. Дважды щелкните на имени найденного файла, чтобы добавить образцы штриховок в окно "Центр управления".
  6. (Не обязательно) Нажмите правую кнопку мыши на образце для вызова контекстного меню со следующими командами:
    • ШТРИХОВКА. Вызов диалогового окна "Штриховка и градиент".
    • Копировать. Копирование образца штриховки в буфер обмена.
    • Создать инструментальную палитру. Создание инструментальной палитры, содержащей выбранный образец штриховки.
  7. Перетащите с помощью устройства указания образец штриховки на замкнутый объект чертежа или на инструментальную палитру.
    ПримечаниеЕсли масштаб образца штриховки слишком велик или мал, то выдается сообщение об ошибке. Можно настроить масштаб любого образца штриховки в диалоговом окне "Штриховка и градиент", отображающемся при двойном нажатии кнопки мыши на образце.
Панель:Стандартная
Ввод команды: ЦУВКЛ


Штрихование областей (Процедура)

Общие сведения об образцах штриховки и заливки
Общие сведения об образцах штриховки и заливки
Общие сведения об образцах штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Общие сведения об образцах штриховки и заливки >
Общие сведения об образцах штриховки и заливки
Понятие Процедура Краткий справочник

Штрихование областей

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора".
  3. На чертеже укажите точку внутри каждой области, которую требуется заштриховать, и нажмите ENTER.

    Указанные точки интерпретируются как внутренние.

  4. Убедитесь, что в диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" выбран требуемый образец. Для выбора другого образца штриховки воспользуйтесь списком "Образец".
  5. При необходимости выполнить настройки в диалоговом окне "Штриховка и градиент".
  6. В списке "Порядок прорисовки" выберите одну из опций.

    Порядок прорисовки для штриховки можно изменить таким образом, чтобы она помещалась за или перед контуром на заднем или на переднем плане.

  7. Нажмите "ОК".
Панель:Рисование
Ввод команды: ШТРИХОВКА


Штрихование выбранных объектов (Процедура)

Общие сведения об образцах штриховки и заливки
Общие сведения об образцах штриховки и заливки
Определение контуров штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Общие сведения об образцах штриховки и заливки >
Общие сведения об образцах штриховки и заливки
Понятие Процедура Краткий справочник

Штрихование выбранных объектов

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора".
  3. Выберите объекты, которые необходимо заштриховать.

    При этом не обязательно, чтобы объекты образовывали замкнутый контур. Можно также указать любые островки, которые должны остаться незаштрихованными. Также можно задать для системной переменной HPGAPTOL такое значение, которое позволит считать набор объектов, составляющих не полностью замкнутую область, замкнутым контуром штриховки.

  4. В списке "Порядок прорисовки" выберите одну из опций.

    Порядок прорисовки для штриховки можно изменить таким образом, чтобы она помещалась за или перед контуром на заднем или на переднем плане.

  5. Нажмите "ОК".
Панель:Рисование
Ввод команды: ШТРИХОВКА


Общие сведения об образцах штриховки и заливки (Краткий справочник)

Добавление и изменение масштабируемых представлений
Общие сведения об образцах штриховки и заливки
Общие сведения о контурах штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Общие сведения об образцах штриховки и заливки >
Общие сведения об образцах штриховки и заливки
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

КОНТУР

Создание области или полилинии из замкнутого контура

КОЛЬЦО

Построение закрашенных кругов и колец

ЗАКРАСИТЬ

Управление закрашиванием таких объектов, как штриховки, 2D фигуры и широкие полилинии

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

РЕДШТРИХ

Изменение существующей штриховки или заливки

КОПИРОВАТЬСВ

Копирование свойств выбранного объекта в другие объекты

ПЛИНИЯ

Создание 2D полилинии

ОКНОСВ

Управление свойствами объектов

ФИГУРА

Создание закрашенных многоугольников

ПСК

Управление пользовательскими системами координат

Системные переменные

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

HPANG

Угол поворота образца штриховки

HPASSOC

Управление ассоциативностью образцов штриховки и градиентных заливок

HPBOUND

Управление типом объекта, созданного с помощью команд КШТРИХ и КОНТУР

HPDRAWORDER

Управление порядком прорисовки штриховки или заливки

HPDOUBLE

Указание режима штрихования крест-накрест для созданных пользователем штриховок

HPGAPTOL

Рассматривает набор объектов, окружающих почти замкнутую область, как замкнутый контур штриховки

HPINHERIT

Определение исходной точки полученной штриховки с помощью параметра "Копирование свойств" команд ШТРИХОВКА и РЕДШТРИХ

HPMAXLINES

Управление максимальным количеством создаваемых линий штриховки

HPNAME

Задание имени образца штриховки по умолчанию длиной до 34 символов (без пробелов)

HPOBJWARNING

Задание количества объектов контура штриховки, которые можно выбрать до отображения предупреждения

HPINHERIT

Определение исходной точки полученной штриховки с помощью параметра "Копирование свойств" команд ШТРИХОВКА и РЕДШТРИХ

HPORIGIN

Задание исходной точки штриховки для новых объектов штриховки относительно текущей системы координат пользователя

HPORIGINMODE

Определение исходной точки штриховки с помощью команды ШТРИХОВКА

HPSCALE

Масштабный коэффициент образца штриховки, который должен быть больше нуля

HPSEPARATE

Определение количества создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров

HPSPACE

Расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть больше нуля

PICKSTYLE

Управление выбором групп и ассоциативной штриховки

Утилиты

Нет

Ключевые слова для команд

Нет


Определение контуров штриховки

Общие сведения об образцах штриховки и заливки
Штриховка, заливка и маскировка
Общие сведения о контурах штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка >
Определение контуров штриховки
Понятие Процедура

Нанесение штриховки или заливки выполняется путем выбора объекта или определения контура с последующим указанием внутренней точки.

Темы в этом разделе

  • Общие сведения о контурах штриховки
  • Штрихование островков

    Имеется возможность задания способа штрихования замкнутых областей внутри контуров штриховки, называемых островками.

  • Определение контуров штриховки в сложных чертежах

    В целях сокращения времени на выполнение действий для штрихования небольшой области сложного чертежа можно задавать набор объектов чертежа, определяющих контуры штриховки.

  • Нанесение штриховки, не имеющей контура


Определение контуров штриховки (Процедура)

Общие сведения об образцах штриховки и заливки
Определение контуров штриховки
Штрихование островков
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки >
Определение контуров штриховки
Понятие Процедура

Исключение островков в области штриховки

Задание набора контуров в сложном чертеже

Задание контура штриховки по точкам


Общие сведения о контурах штриховки (Понятие)

Определение контуров штриховки
Определение контуров штриховки
Штрихование островков
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки >
Общие сведения о контурах штриховки
Понятие Краткий справочник

Штриховка замкнутой области или контура выполняется с помощью команды ШТРИХОВКА. По умолчанию с помощью команды ШТРИХОВКА создаются ассоциативные штриховки, обновляемые при каждом изменении контура.

Нанесение штриховки выполняется путем выбора объекта или определения контура с последующим указанием внутренней точки. Контур может представлять комбинацию объектов, таких как отрезки, дуги, круги и полилинии, которые образуют замкнутую область.

Замкнутые области внутри области штрихования рассматриваются как островки. Их можно заштриховать или оставить незаштрихованными в зависимости от значения параметра "Островки" в диалоговом окне "Штриховка и градиент".

Для штрихования небольшой области сложного чертежа можно задать произвольный набор контуров.

Штрихование объектов возможно только в том случае, если они расположены параллельно плоскости XY текущей ПСК.

ПримечаниеЕсли требуется заштриховать область, которая замкнута не полностью, можно задать допуск замкнутости (системная переменная HPGAPTOL). Зазоры между объектами, величина которых не превышает заданного максимального значения, игнорируются, а контур образованный такими объектами считается замкнутым.


Общие сведения о контурах штриховки (Краткий справочник)

Общие сведения об образцах штриховки и заливки
Общие сведения о контурах штриховки
Штрихование островков
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки > Общие сведения о контурах штриховки >
Общие сведения о контурах штриховки
Понятие Краткий справочник

Команды

КОНТУР

Создание области или полилинии из замкнутого контура

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

РЕДШТРИХ

Изменение существующей штриховки или заливки

Системные переменные

HPBOUND

Управление типом объекта, созданного с помощью команд КШТРИХ и КОНТУР

HPGAPTOL

Рассматривает набор объектов, окружающих почти замкнутую область, как замкнутый контур штриховки

HPOBJWARNING

Задание количества объектов контура штриховки, которые можно выбрать до отображения предупреждения

HPSEPARATE

Определение количества создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров

PICKSTYLE

Управление выбором групп и ассоциативной штриховки

Утилиты

Нет

Ключевые слова для команд

Нет


Штрихование островков (Понятие)

Общие сведения о контурах штриховки
Определение контуров штриховки
Определение контуров штриховки в сложных чертежах
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки >
Штрихование островков
Понятие Процедура Краткий справочник

Имеется возможность задания способа штрихования замкнутых областей внутри контуров штриховки, называемых островками.

Имеется возможность задания способа штрихования замкнутых областей внутри контура штриховки, называемых островками, путем выбора одного из трех стилей штриховки: "Обычное", "Внешнее", "Без островков". Предварительный просмотр этих стилей штриховки можно выполнить в области "Дополнительно" диалогового окна "Штриховка и градиент".

При использовании стиля "Обычное" (по умолчанию) штриховка наносится начиная от внешнего контура по направлению вовнутрь. Если обнаружено внутреннее пересечение, штрихование прекращается, а на следующем пересечении возобновляется.

Таким образом, штриховка наносится на области, отделенные от внешней области нечетным числом замкнутых контуров, как это показано ниже на чертеже. При этом области, отделенные четным числом контуров, не штрихуются.

При использовании стиля "Внешний" штриховка наносится только от внешнего контура до первого обнаруженного пересечения, за которым область остается незаштрихованной.

Стиль "Игнорирующий" служит для нанесения штриховки на всю область, ограниченную внешним контуром, вне зависимости от наличия внутренних контуров.

В области штриховки можно исключать из рассмотрения любые островки.

См. также

    • Редактирование штриховки и заливки


Исключение островков в области штриховки (Процедура)

Определение контуров штриховки
На уровень вверх ..
Определение контуров штриховки в сложных чертежах
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки > Штрихование островков >
Штрихование островков
Понятие Процедура Краткий справочник

Исключение островков в области штриховки

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  2. После добавления одного или нескольких контуров в диалоговом окне "Штриховка и градиент" нажмите кнопку "Удалить контуры".
  3. Выберите контуры, которые необходимо удалить, и нажмите ENTER.
  4. В диалоговом окне "Штриховка и градиент" нажмите "ОК" для нанесения штриховки.
Панель:Рисование
Ввод команды: ШТРИХОВКА


Штрихование островков (Краткий справочник)

Общие сведения о контурах штриховки
Штрихование островков
Определение контуров штриховки в сложных чертежах
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки > Штрихование островков >
Штрихование островков
Понятие Процедура Краткий справочник

Команды

КОНТУР

Создание области или полилинии из замкнутого контура

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

РЕДШТРИХ

Изменение существующей штриховки или заливки

Системные переменные

HPOBJWARNING

Задание количества объектов контура штриховки, которые можно выбрать до отображения предупреждения

HPSEPARATE

Определение количества создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров

Утилиты

Нет

Ключевые слова для команд

Нет


Определение контуров штриховки в сложных чертежах (Понятие)

Штрихование островков
Определение контуров штриховки
Нанесение штриховки, не имеющей контура
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки >
Определение контуров штриховки в сложных чертежах
Понятие Процедура Краткий справочник

В целях сокращения времени на выполнение действий для штрихования небольшой области сложного чертежа можно задавать набор объектов чертежа, определяющих контуры штриховки.

По умолчанию команда ШТРИХОВКА определяет контур, анализируя все замкнутые объекты чертежа. Для сложных чертежей подобный поиск контура среди всех объектов, полностью или частично отображаемых на экране, может отнимать достаточно много времени. В таких случаях для штрихования небольшой области сложного чертежа можно явно задать объекты, определяющие так называемый набор контуров. Команда ШТРИХОВКА не анализирует объекты, не входящие в набор контуров.

Для наглядности область, на которую необходимо нанести штриховку, можно предварительно увеличить.

Параметр "Просмотр набора" диалогового окна "Штриховка и градиент" используется для выделения объектов чертежа, определяющих контур.


Задание набора контуров в сложном чертеже (Процедура)

Штрихование островков
На уровень вверх ..
Нанесение штриховки, не имеющей контура
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки > Определение контуров штриховки в сложных чертежах >
Определение контуров штриховки в сложных чертежах
Понятие Процедура Краткий справочник

Задание набора контуров в сложном чертеже

  1. Выберите пункт меню "Рисование" [image] "Штриховка".В командной строке введите "кштрих".
  2. В диалоговом окне "Штриховка и градиент" в области "Дополнительно" в списке "Набор контуров" выберите "Создать".
  3. На запрос "Выберите объекты" укажите два противоположных угла для задания области, содержащей объекты, определяющие набор контуров, и нажмите ENTER.

    При выборе секущей рамкой путем перетаскивания курсора справа налево выбираются все объекты, полностью или частично входящие в заданную область.

  4. В диалоговом окне "Штриховка и градиент" выберите "Добавить контур". При необходимости введите у, чтобы выбрать опцию "Указать внутреннюю точку".
  5. Укажите внутреннюю точку.
  6. Нажмите "ОК" для нанесения штриховки.

Панель:Рисование
Ввод команды: ШТРИХОВКА


Определение контуров штриховки в сложных чертежах (Краткий справочник)

Штрихование островков
Определение контуров штриховки в сложных чертежах
Нанесение штриховки, не имеющей контура
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки > Определение контуров штриховки в сложных чертежах >
Определение контуров штриховки в сложных чертежах
Понятие Процедура Краткий справочник

Команды

КОНТУР

Создание области или полилинии из замкнутого контура

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

РЕДШТРИХ

Изменение существующей штриховки или заливки

Системные переменные

HPOBJWARNING

Задание количества объектов контура штриховки, которые можно выбрать до отображения предупреждения

Утилиты

Нет

Ключевые слова для команд

Нет


Нанесение штриховки, не имеющей контура (Понятие)

Определение контуров штриховки в сложных чертежах
Определение контуров штриховки
Выбор образцов штриховки и сплошной заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки >
Нанесение штриховки, не имеющей контура
Понятие Процедура Краткий справочник

Существует несколько способов нанесения штриховки, не имеющей контура.

  • Штриховку можно нанести с помощью команды ШТРИХ, а затем стереть все или некоторые объекты контура.
  • Штриховку можно нанести с помощью команды ШТРИХ, убедившись, что объекты контура не находятся на том же слое, что и штриховка. Затем нужно отключить или заморозить слой, на котором находятся объекты контура. Это единственный способ, поддерживающий ассоциативность штриховки.
  • Можно обрезать существующую штриховку объектами, созданными в качестве контура обрезки. После обрезки штриховки необходимо стереть эти объекты.
  • В командной строке можно задать контур штриховки, указав точки контура с помощью параметра построения -ШТРИХ.

Например, может понадобиться показать, что значительная область чертежа заполняется образцом путем заполнения всего лишь маленькой части этой области, как это показано на следующем рисунке.

Имеется возможность сохранения контура после нанесения штриховки; здесь контур не сохранен.


Задание контура штриховки по точкам (Процедура)

Определение контуров штриховки в сложных чертежах
На уровень вверх ..
Выбор образцов штриховки и сплошной заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки > Нанесение штриховки, не имеющей контура >
Нанесение штриховки, не имеющей контура
Понятие Процедура Краткий справочник

Задание контура штриховки по точкам

  1. В командной строке введите -штрих.
  2. Введите имя нужного образца штриховки. Например, введите earth для выбора образца EARTH.
  3. Задайте масштаб образца и угол его поворота.
  4. Введите ш, чтобы выбрать опцию "Рисование".
  5. Укажите точки, определяющие контур. Введите з, чтобы замкнуть контур полилинии, и нажмите ENTER.
  6. Введите н для удаления контура после нанесения штриховки или д для его сохранения.
Ввод команды: -ШТРИХОВКА


Нанесение штриховки, не имеющей контура (Краткий справочник)

Определение контуров штриховки в сложных чертежах
Нанесение штриховки, не имеющей контура
Построение областей со сплошной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Определение контуров штриховки > Нанесение штриховки, не имеющей контура >
Нанесение штриховки, не имеющей контура
Понятие Процедура Краткий справочник

Команды

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

РЕДШТРИХ

Изменение существующей штриховки или заливки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Выбор образцов штриховки и сплошной заливки

Нанесение штриховки, не имеющей контура
Штриховка, заливка и маскировка
Построение областей со сплошной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка >
Выбор образцов штриховки и сплошной заливки
Понятие Процедура

Можно использовать стандартные образцы штриховки или сплошной заливки, а также определять собственные.

Темы в этом разделе

  • Построение областей со сплошной заливкой

    Построение областей со сплошной заливкой может выполняться несколькими способами.

  • Создание областей с градиентной заливкой

    Градиентная заливка - это разновидность сплошной заливки с эффектом плавного перехода одного цвета в другой. Градиентная заливка позволяет создавать эффект объемности фигур в двумерных чертежах.

  • Стандартные образцы штриховки

    В продукт входит более 50 стандартных образцов штриховки, которые можно использовать в своей работе. Помимо образцов, поставляемых с продуктом, можно использовать также образцы из внешних библиотек.

  • Создание пользовательских образцов штриховки

    Можно сформировать простейший образец штриховки на основе текущего типа линий.


Выбор образцов штриховки и сплошной заливки (Процедура)

Нанесение штриховки, не имеющей контура
Выбор образцов штриховки и сплошной заливки
Построение областей со сплошной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки >
Выбор образцов штриховки и сплошной заливки
Понятие Процедура

Нанесение сплошной заливки

Построение 2D фигуры

Создание широкой полилинии

Построение кольца

Нанесение одноцветной градиентной заливки

Нанесение двухцветной градиентной заливки

Редактирование градиентной заливки

Использование стандартного образца штриховки

Формирование штриховки из линий


Построение областей со сплошной заливкой (Понятие)

Выбор образцов штриховки и сплошной заливки
Выбор образцов штриховки и сплошной заливки
Создание областей с градиентной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки >
Построение областей со сплошной заливкой
Понятие Процедура Краткий справочник

Построение областей со сплошной заливкой может выполняться несколькими способами.

Области со сплошной заливкой можно создать с помощью:

  • Штриховки с образцами сплошной штриховки (ШТРИХ)
  • двумерных фигур (ФИГУРА)
  • широких полилиний и колец (ПЛИНИЯ, КОЛЬЦО)

См. также

    • Общие сведения об образцах штриховки и заливки

    • Редактирование штриховки и заливки

    • Построение полилиний

    • Построение колец


Построение областей со сплошной заливкой (Процедура)

Выбор образцов штриховки и сплошной заливки
На уровень вверх ..
Построение областей со сплошной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Построение областей со сплошной заливкой >
Построение областей со сплошной заливкой
Понятие Процедура Краткий справочник

Нанесение сплошной заливки

Построение 2D фигуры

Создание широкой полилинии

Построение кольца


Нанесение сплошной заливки (Процедура)

Построение областей со сплошной заливкой
На уровень вверх ..
Построение областей со сплошной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Построение областей со сплошной заливкой >
Построение областей со сплошной заливкой
Понятие Процедура Краткий справочник

Нанесение сплошной заливки

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора".
  3. Укажите точки внутри областей, которые необходимо заштриховать.

    Указанные точки интерпретируются как внутренние.

  4. Нажмите ENTER.
  5. В диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" в списке "Тип" выберите "Стандартный".
  6. Нажмите кнопку [...] рядом со списком образцов.
  7. В диалоговом окне "Палитра образцов штриховки" на вкладке "Другие стандартные" выберите "Сплошная". Нажмите "ОК".
  8. Для просмотра образца штриховки нажмите "Просмотр".
  9. По завершении просмотра образца штриховки нажмите правую кнопку мыши или клавишу ENTER для нанесения штриховки или нажмите любую клавишу или кнопку для возврата к диалоговому окну "Штриховка и градиент".
  10. При необходимости выполните настройки в диалоговом окне "Штриховка и градиент". (Новые контуры штриховки можно определить, нажав кнопку "Добавить контуры" или "Удалить контуры".)
  11. Нажмите "ОК".
Панель:Рисование
Ввод команды: ШТРИХОВКА


Построение 2D фигуры (Процедура)

Построение областей со сплошной заливкой
На уровень вверх ..
Построение областей со сплошной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Построение областей со сплошной заливкой >
Построение областей со сплошной заливкой
Понятие Процедура Краткий справочник

Построение 2D фигуры

  1. Выберите меню "Рисование" [image] "Моделирование" [image] "Сети" [image] "2D фигура".В командной строке введите фигура.
  2. Укажите первую точку.
  3. Укажите вторую точку, переводя курсор слева направо.
  4. Продолжите указание следующих точек. Для окончания определения объекта нажмите ENTER.

    При создании четырехугольной фигуры порядок указания вершин влияет на форму фигуры. Это показано на следующих чертежах.

    Следует учитывать, что для создания четырехугольника верхняя и нижняя стороны должны определяться в одном направлении. При задании следующих пар вершин необходимо придерживаться установленного порядка указания для получения ожидаемого результата.

Ввод команды: ФИГУРА


Создание широкой полилинии (Процедура)

Построение областей со сплошной заливкой
На уровень вверх ..
Построение областей со сплошной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Построение областей со сплошной заливкой >
Построение областей со сплошной заливкой
Понятие Процедура Краткий справочник

Создание широкой полилинии

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Полилиния". В командной строке введите "плиния".
  2. Укажите начальную точку линейного сегмента.
  3. Введите ш (Ширина).
  4. Введите значение ширины в начале линейного сегмента.
  5. Задайте ширину в конце сегмента одним из следующих методов:
    • Для создания линейного сегмента с постоянной шириной нажмите клавишу ENTER.
    • Для построения сужающегося или расширяющегося линейного сегмента введите другое значение ширины.
  6. Укажите конечную точку сегмента.
  7. Продолжайте указание конечных точек для последующих сегментов.
  8. Нажмите ENTER для завершения команды или с для замыкания полилинии.
Панель:Рисование
Ввод команды: ПЛИНИЯ


Построение кольца (Процедура)

Построение областей со сплошной заливкой
На уровень вверх ..
Создание областей с градиентной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Построение областей со сплошной заливкой >
Построение областей со сплошной заливкой
Понятие Процедура Краткий справочник

Построение кольца

  1. Выберите пункт меню "Рисование" [image] "Кольцо".В командной строке введите "кольцо".
  2. Задайте внутренний диаметр (1).
  3. Задайте наружный диаметр (2).
  4. Укажите центр кольца (3).
  5. Укажите центральную точку для другого кольца или нажмите клавишу ENTER для завершения команды.

Ввод команды: КОЛЬЦО


Построение областей со сплошной заливкой (Краткий справочник)

Нанесение штриховки, не имеющей контура
Построение областей со сплошной заливкой
Создание областей с градиентной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Построение областей со сплошной заливкой >
Построение областей со сплошной заливкой
Понятие Процедура Краткий справочник

Команды

КОЛЬЦО

Построение закрашенных кругов и колец

ЗАКРАСИТЬ

Управление закрашиванием таких объектов, как штриховки, 2D фигуры и широкие полилинии

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

ПЛИНИЯ

Создание 2D полилинии

ФИГУРА

Создание закрашенных многоугольников

Системные переменные

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

Утилиты

Нет

Ключевые слова для команд

Нет


Создание областей с градиентной заливкой (Понятие)

Построение областей со сплошной заливкой
Выбор образцов штриховки и сплошной заливки
Стандартные образцы штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки >
Создание областей с градиентной заливкой
Понятие Процедура Краткий справочник

Градиентная заливка - это разновидность сплошной заливки с эффектом плавного перехода одного цвета в другой. Градиентная заливка позволяет создавать эффект объемности фигур в двумерных чертежах.

Одноцветная градиентная заливка может содержать плавный переход цвета от более светлого к более темному, от более темного к более светлому или сочетание таких переходов. Необходимо выбрать предлагаемый образец заливки и задать угол. Двухцветная градиентная заливка состоит из переходов от светлых к темным оттенкам, а также от одного цвета к другому.

Градиентная заливка наносится так же, как и сплошная. Она может иметь ассоциативную связь с контурами областей. Ассоциативная заливка автоматически обновляется при изменении контура.

Цвета градиентной заливки не зависят от стилей печати.

Для редактирования градиентной заливки необходимо нажать на ней дважды кнопку мыши.


Создание областей с градиентной заливкой (Процедура)

Построение областей со сплошной заливкой
На уровень вверх ..
Создание областей с градиентной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Создание областей с градиентной заливкой >
Создание областей с градиентной заливкой
Понятие Процедура Краткий справочник

Нанесение одноцветной градиентной заливки

Нанесение двухцветной градиентной заливки

Редактирование градиентной заливки


Нанесение одноцветной градиентной заливки (Процедура)

Создание областей с градиентной заливкой
На уровень вверх ..
Создание областей с градиентной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Создание областей с градиентной заливкой >
Создание областей с градиентной заливкой
Понятие Процедура Краткий справочник

Нанесение одноцветной градиентной заливки

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: выбрать объекты".
  3. Задайте внутреннюю точку или выберите объект, затем нажмите клавишу ENTER.
  4. В диалоговом окне "Штриховка и градиент" на вкладке "Градиент" выберите "Один цвет".
  5. Если необходимо изменить цвет, нажмите кнопку [...] рядом с цветом.
  6. В диалоговом окне "Выбор цвета" с помощью указателя "Темнее/светлее" настройте цвет.
    • Перемещение указателя вправо создает эффект перехода от более темного цвета к более светлому.
    • Перемещение указателя влево создает эффект перехода от более светлого цвета к более темному.
  7. Выбрать образец заливки и произвести следующие настройки:
    • Для создания симметричной заливки взвести флажок "По центру".
    • Ввести угол наклона.
  8. Кнопка "Просмотр" позволяет контролировать результат. Для возврата к диалоговому окну и выполнения настроек нажмите клавишу ENTER.
  9. После того, как требуемый эффект достигнут, в диалоговом окне "Штриховка и градиент" нажмите "ОК" для создания градиентной заливки.
Панель:Рисование
Ввод команды: ШТРИХОВКА


Нанесение двухцветной градиентной заливки (Процедура)

Создание областей с градиентной заливкой
На уровень вверх ..
Создание областей с градиентной заливкой
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Создание областей с градиентной заливкой >
Создание областей с градиентной заливкой
Понятие Процедура Краткий справочник

Нанесение двухцветной градиентной заливки

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: выбрать объекты".
  3. Задайте внутреннюю точку или выберите объект, затем нажмите клавишу ENTER.
  4. В диалоговом окне "Штриховка и градиент" на вкладке "Градиент" выберите "Два цвета".

    Двухцветная заливка создает эффект плавного перехода одного цвета в другой.

  5. Выбрать цвета можно в диалоговом окне "Выбор цвета", которое вызывается нажатием кнопки [...].
  6. Выбрать образец заливки и произвести следующие настройки:
    • Для создания симметричной заливки установить флажок "По центру".
    • Ввести угол наклона.
  7. Кнопка "Просмотр" позволяет контролировать результат. Для возврата к диалоговому окну и выполнения настроек нажмите клавишу ENTER.
  8. После того как требуемый эффект достигнут, в диалоговом окне "Штриховка и градиент" нажмите "ОК" для создания градиентной заливки.
Панель:Рисование
Ввод команды: ШТРИХОВКА


Редактирование градиентной заливки (Процедура)

Создание областей с градиентной заливкой
На уровень вверх ..
Стандартные образцы штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Создание областей с градиентной заливкой >
Создание областей с градиентной заливкой
Понятие Процедура Краткий справочник

Редактирование градиентной заливки

  • Для редактирования градиентной заливки необходимо дважды щелкнуть на ней.


Создание областей с градиентной заливкой (Краткий справочник)

Построение областей со сплошной заливкой
Создание областей с градиентной заливкой
Стандартные образцы штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Создание областей с градиентной заливкой >
Создание областей с градиентной заливкой
Понятие Процедура Краткий справочник

Команды

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Стандартные образцы штриховки (Понятие)

Создание областей с градиентной заливкой
Выбор образцов штриховки и сплошной заливки
Создание пользовательских образцов штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки >
Стандартные образцы штриховки
Понятие Процедура Краткий справочник

В продукт входит более 50 стандартных образцов штриховки, которые можно использовать в своей работе. Помимо образцов, поставляемых с продуктом, можно использовать также образцы из внешних библиотек.

Программа поставляется с образцом сплошной заливки и более чем 50 стандартными образцами штриховки, служащими для обозначения материалов объектов, например земля, кирпич или глина.

В AutoCAD имеется 14 образцов штриховки, удовлетворяющих стандартам ISO (Международной организации по стандартизации). Для штриховки по стандарту ISO можно задать толщину пера, которая определяет вес линий образца.

Помимо образцов, поставляемых с программой, можно использовать образцы из внешних библиотек. Список таких образцов и их изображения можно просматривать в диалоговом окне "Палитра образцов штриховки".


Использование стандартного образца штриховки (Процедура)

Создание областей с градиентной заливкой
На уровень вверх ..
Создание пользовательских образцов штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Стандартные образцы штриховки >
Стандартные образцы штриховки
Понятие Процедура Краткий справочник

Использование стандартного образца штриховки

  1. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  2. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: объекты выбора".
  3. Укажите внутреннюю точку или объект.
  4. В диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" в списке "Тип" выберите "Стандартный".
  5. Из списка "Образец" выберите нужный образец.
  6. Нажмите "ОК".
Панель:Рисование
Ввод команды: ШТРИХОВКА


Стандартные образцы штриховки (Краткий справочник)

Создание областей с градиентной заливкой
Стандартные образцы штриховки
Создание пользовательских образцов штриховки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Стандартные образцы штриховки >
Стандартные образцы штриховки
Понятие Процедура Краткий справочник

Команды

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

Системные переменные

HPANG

Угол поворота образца штриховки

HPBOUND

Управление типом объекта, созданного с помощью команд КШТРИХ и КОНТУР

HPDOUBLE

Указание режима штрихования крест-накрест для созданных пользователем штриховок

HPNAME

Задание имени образца штриховки по умолчанию длиной до 34 символов (без пробелов)

HPSCALE

Масштабный коэффициент образца штриховки, который должен быть больше нуля

Утилиты

Нет

Ключевые слова для команд

Нет


Создание пользовательских образцов штриховки (Понятие)

Стандартные образцы штриховки
Выбор образцов штриховки и сплошной заливки
Редактирование штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки >
Создание пользовательских образцов штриховки
Понятие Процедура Краткий справочник

Можно сформировать простейший образец штриховки на основе текущего типа линий.

Можно использовать стандартные образцы штриховки или сформировать простейший образец штриховки на основе текущего типа линий. Образец определяется углом поворота и интервалом между линиями штриховки.


Формирование штриховки из линий (Процедура)

Стандартные образцы штриховки
На уровень вверх ..
Редактирование штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Создание пользовательских образцов штриховки >
Создание пользовательских образцов штриховки
Понятие Процедура Краткий справочник

Формирование штриховки из линий

  1. Задайте текущий тип линий, используемый для образца штриховки пользователя.
  2. Выберите вкладку "Главная" [image] панель "Рисование" [image] "Штриховка". В командной строке введите "штрих".
  3. В диалоговом окне "Штриховка и градиент" выберите "Добавить: точки выбора" или "Добавить: выбрать объекты".
  4. Укажите внутреннюю точку или объект.
  5. В диалоговом окне "Штриховка и градиент" на вкладке "Штриховка" в списке "Тип" выберите "Пользовательская".
  6. Задайте угол поворота и интервал между линиями в образце штриховки.
  7. Для нанесения штриховки с линиями, расположенными крест-накрест, включите опцию "Двусторонняя".
  8. Нажмите "ОК".
Панель:Рисование
Ввод команды: ШТРИХОВКА


Создание пользовательских образцов штриховки (Краткий справочник)

Стандартные образцы штриховки
Создание пользовательских образцов штриховки
Редактирование штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Выбор образцов штриховки и сплошной заливки > Создание пользовательских образцов штриховки >
Создание пользовательских образцов штриховки
Понятие Процедура Краткий справочник

Команды

ШТРИХ

Заполнение замкнутой области или выбранных объектов штриховкой, сплошной заливкой или градиентной заливкой

Системные переменные

HPANG

Угол поворота образца штриховки

HPBOUND

Управление типом объекта, созданного с помощью команд КШТРИХ и КОНТУР

HPDOUBLE

Указание режима штрихования крест-накрест для созданных пользователем штриховок

HPNAME

Задание имени образца штриховки по умолчанию длиной до 34 символов (без пробелов)

HPSCALE

Масштабный коэффициент образца штриховки, который должен быть больше нуля

HPSPACE

Расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть больше нуля

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование штриховки и заливки (Понятие)

Создание пользовательских образцов штриховки
Штриховка, заливка и маскировка
Создание пустых маскирующих областей
Аннотирование чертежей > Штриховка, заливка и маскировка >
Редактирование штриховки и заливки
Понятие Процедура Краткий справочник

Имеется возможность редактирования образцов и контуров штриховки (и сплошной заливки).

Кроме того, можно редактировать закрашенные элементы чертежа; при этом способ редактирования зависит от их типа. Закрашенными могут выглядеть сплошные заливки, двумерные фигуры, широкие полилинии и кольца. Также можно изменить порядок следования для штриховки.

Управление плотностью образца штриховки

При нанесении штриховки может образовываться очень большое число отрезков и объектов-точек. Хотя штриховка хранится как единый объект, все же каждый его отрезок и точка занимает место на диске и требует определенного времени на обработку. При использовании относительно малого масштабного коэффициента во время штрихования области могут создаваться миллионы отрезков и объектов-точек, отнимающих длительное время на прорисовку и поглощающих практически все доступные ресурсы. Этой проблемы можно избежать, ограничив число объектов, создаваемых однократным выполнением команды ШТРИХОВКА. Если предполагаемое число объектов, необходимое для определенной штриховки (учитывая длину контура, образец и масштаб), превышает ограничение, команда ШТРИХОВКА выдает сообщение о том, что масштаб штриховки или длина пунктира слишком малы, и штрихование отменяется. В таком случае необходимо изменить параметры штрихования; например, поменять масштабный коэффициент.

Максимальное допустимое число объектов, создаваемых штрихованием, задается в записи MaxHatch системного реестра. По умолчанию количество объектов ограничивается числом 10000. Это предельное значение можно изменить, задав значение переменной MaxHatch системного реестра с помощью команды (setenv "MaxHatch" "n"), где n - число от 100 до 10000000 (десять миллионов).

ПримечаниеПри вводе команды MaxHatch необходимо вводить буквы M и H в верхнем регистре, а остальные буквы — в нижнем регистре.

Изменение свойств имеющейся штриховки

Можно изменять такие свойства имеющейся штриховки, как массив, масштаб и угол. Можно использовать:

  • диалоговое окно "Редактирование штриховки" (рекомендуется)
  • палитру свойств

Можно копировать свойства одной штриховки в другую штриховку. Используя кнопку "Копирование свойств" диалогового окна "Редактирование штриховки", можно копировать все свойства, включая исходную точку штриховки, из одной штриховки в другую. Для копирования общих свойств и свойств штриховки (кроме исходной точки штриховки) из одной штриховки в другую используется диалоговое окно "Копировать свойства".

Для разделения штриховки на исходные объекты можно использовать команду РАСЧЛЕНИТЬ.

Редактирование контура штриховки

Имеется возможность редактировать контуры штриховки, как и другие объекты. Для этого можно использовать ручки, позволяющие растягивать, перемещать, поворачивать, масштабировать и зеркально отображать заштрихованные области и их контуры. Ассоциативная штриховка при редактировании замкнутого контура автоматически обновляется. Если в результате редактирования контур стал разомкнутым, то штриховка перестает быть ассоциативной и, следовательно, больше не зависит от формы контура. Ассоциативность штриховки может быть потеряна также в том случае, если во время редактирования контура оказался недоступен файл образца штриховки. Также при обрезке штриховки, если файл образца штриховки (PAT-файл) недоступен, штриховка не отображается.

Ассоциативность штриховки зависит от состояния флажка "Ассоциативная" в диалоговых окнах "Штриховка и градиент" (ШТРИХОВКА) и "Редактирование штриховки" (РЕДШТРИХ). Неассоциативные штриховки при изменении контуров не обновляются.

Ассоциативность штриховки в любой момент можно отменить, но после этого ассоциативность существующей штриховки восстановить будет уже нельзя. Необходимо повторно создать штриховку для восстановления ассоциативности или создать новый контур и ассоциировать его со штриховкой.

Для создания контура вокруг неассоциативной штриховки или штриховки, созданной с помощью указания точек, используйте параметр "Восстановить контур" диалогового окна "Штриховка и градиент". С помощью этого параметра можно также задать ассоциативность нового контура со штриховкой.

Редактирование закрашенных элементов

Закрашенными элементами могут быть:

  • сплошные штриховки-заливки
  • двумерные фигуры
  • градиентные заливки
  • широкие полилинии и кольца

Эти закрашенные объекты редактируются так же, как и другие штриховки, 2D фигуры, широкие полилинии и кольца. Кроме команды ОКНОСВ, можно использовать команду РЕДШТРИХ для работы с закрашенными штриховками и градиентными заливками, ручки для редактирования 2D фигур, а также команду ПОЛРЕД для широких полилиний и колец.

Изменение порядка следования для штриховки

Во время редактирования штриховки можно изменить ее порядок прорисовки таким образом, чтобы она отображалась за контуром, перед контуром, на заднем или на переднем плане.


Редактирование штриховки и заливки (Процедура)

Создание пользовательских образцов штриховки
Редактирование штриховки и заливки
Редактирование штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Редактирование штриховки и заливки >
Редактирование штриховки и заливки
Понятие Процедура Краткий справочник

Изменение угла наклона штриховки

Для задания ограничения числа объектов, создаваемых штриховкой

Редактирование градиентной заливки


Изменение угла наклона штриховки (Процедура)

Редактирование штриховки и заливки
Редактирование штриховки и заливки
Редактирование штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Редактирование штриховки и заливки >
Редактирование штриховки и заливки
Понятие Процедура Краткий справочник

Изменение угла наклона штриховки

  1. Выберите образец штриховки.
  2. Щелкните правой кнопкой мыши на штриховке. Выберите "Свойства".
  3. На палитре свойств введите новое значение в поле "Угол".
Панель:Стандартная
Ввод команды: ОКНОСВ


Для задания ограничения числа объектов, создаваемых штриховкой (Процедура)

Редактирование штриховки и заливки
Редактирование штриховки и заливки
Редактирование штриховки и заливки
Аннотирование чертежей > Штриховка, заливка и маскировка > Редактирование штриховки и заливки >
Редактирование штриховки и заливки
Понятие Процедура Краткий справочник

Для задания ограничения числа объектов, создаваемых штриховкой

  1. В командной строке введите (setenv “MaxHatch” “n”)(.

    При вводе имени переменной MaxHatch необходимо соблюдать регистр символов. Чем больше значение, тем плотнее наносимая штриховка.

    ПримечаниеПри вводе имени переменной MaxHatch необходимо соблюдать регистр символов.


Редактирование градиентной заливки (Процедура)

Редактирование штриховки и заливки
Редактирование штриховки и заливки
Создание пустых маскирующих областей
Аннотирование чертежей > Штриховка, заливка и маскировка > Редактирование штриховки и заливки >
Редактирование штриховки и заливки
Понятие Процедура Краткий справочник

Редактирование градиентной заливки

  1. Дважды щелкните на градиентной заливке, которую требуется отредактировать.
  2. Внесите необходимые изменения на вкладке "Градиент" диалогового окна "Редактирование штриховки".
  3. Кнопка "Просмотр" позволяет контролировать результат. Для возврата к диалоговому окну и выполнения настроек нажмите клавишу ENTER.
  4. После того как требуемый эффект достигнут, в диалоговом окне "Штриховка и градиент" нажмите "ОК" для создания градиентной заливки.


Редактирование штриховки и заливки (Краткий справочник)

Создание пользовательских образцов штриховки
Редактирование штриховки и заливки
Создание пустых маскирующих областей
Аннотирование чертежей > Штриховка, заливка и маскировка > Редактирование штриховки и заливки >
Редактирование штриховки и заливки
Понятие Процедура Краткий справочник

Команды

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

ЗАКРАСИТЬ

Управление закрашиванием таких объектов, как штриховки, 2D фигуры и широкие полилинии

РЕДШТРИХ

Изменение существующей штриховки или заливки

КОПИРОВАТЬСВ

Копирование свойств выбранного объекта в другие объекты

ПОЛРЕД

Редактирование полилиний и 3D полигональных сетей

ОКНОСВ

Управление свойствами объектов

Системные переменные

FILLMODE

Управление закраской фигур, всех штриховок (в том числе сплошных), полилиний ненулевой ширины

HPANG

Угол поворота образца штриховки

HPASSOC

Управление ассоциативностью образцов штриховки и градиентных заливок

HPDOUBLE

Указание режима штрихования крест-накрест для созданных пользователем штриховок

HPINHERIT

Определение исходной точки полученной штриховки с помощью параметра "Копирование свойств" команд ШТРИХОВКА и РЕДШТРИХ

HPNAME

Задание имени образца штриховки по умолчанию длиной до 34 символов (без пробелов)

HPORIGIN

Задание исходной точки штриховки для новых объектов штриховки относительно текущей системы координат пользователя

HPORIGINMODE

Определение исходной точки штриховки с помощью команды ШТРИХОВКА

HPSCALE

Масштабный коэффициент образца штриховки, который должен быть больше нуля

HPSPACE

Расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть больше нуля

Утилиты

Нет

Ключевые слова для команд

Нет


Создание пустых маскирующих областей (Понятие)

Редактирование штриховки и заливки
Штриховка, заливка и маскировка
Примечания и метки
Аннотирование чертежей > Штриховка, заливка и маскировка >
Создание пустых маскирующих областей
Понятие Процедура Краткий справочник

Маскирующие объекты закрывают объекты чертежа с целью резервирования места для примечаний или скрытия каких-либо деталей.

Маскирующие объекты - это многоугольники фонового цвета, которыми можно закрывать объекты чертежа. Область ограничивается контурами, видимость которых можно включать при редактировании и отключать при печати.

Маскирующие объекты создаются указанием точек многоугольника; они также могут быть получены преобразованием замкнутых полилиний.

Необходимые условия и ограничения

Полилиния, преобразуемая в маскирующий объект, должна быть замкнутой, иметь нулевую ширину и состоять только из линейных сегментов.

Маскирующие объекты можно создавать в пространстве листа для скрытия объектов в пространстве модели, однако для гарантии правильного отображения маскирующего объекта при его выводе на печать на вкладке "Параметры печати" диалогового окна "Печать" должен быть снят флажок "Объекты листа последними".

Поскольку маскирующие объекты похожи на растровые изображения, они имеют аналогичные требования к печати. Необходимо устройство печати, поддерживающее растровую графику, управляемое драйвером ADI 4.3 или драйвером системного принтера.

См. также

    • Управление отображением перекрывающихся объектов


Создание пустых маскирующих областей (Процедура)

Редактирование штриховки и заливки
Создание пустых маскирующих областей
Создание пустых маскирующих областей
Аннотирование чертежей > Штриховка, заливка и маскировка > Создание пустых маскирующих областей >
Создание пустых маскирующих областей
Понятие Процедура Краткий справочник

Маскирование объектов чертежа пустыми областями

Включение/отключение видимости контуров маскирующих объектов


Маскирование объектов чертежа пустыми областями (Процедура)

Создание пустых маскирующих областей
Создание пустых маскирующих областей
Создание пустых маскирующих областей
Аннотирование чертежей > Штриховка, заливка и маскировка > Создание пустых маскирующих областей >
Создание пустых маскирующих областей
Понятие Процедура Краткий справочник

Маскирование объектов чертежа пустыми областями

  1. Выберите вкладку "Аннотирование" [image] панель "Пометка" [image] "Маскировка". В командной строке введите "маскировка".
  2. Укажите точки в последовательности, определяющей контур, в пределах которого необходимо скрыть объекты.
  3. Для завершения нажмите ENTER.
Ввод команды: МАСКИРОВКА


Включение/отключение видимости контуров маскирующих объектов (Процедура)

Создание пустых маскирующих областей
Создание пустых маскирующих областей
Коротко о примечаниях и метках
Аннотирование чертежей > Штриховка, заливка и маскировка > Создание пустых маскирующих областей >
Создание пустых маскирующих областей
Понятие Процедура Краткий справочник

Включение/отключение видимости контуров маскирующих объектов

  1. Выберите вкладку "Аннотирование" [image] панель "Пометка" [image] "Маскировка". В командной строке введите "маскировка".
  2. В командной строке введите "f" (контуры).
  3. Введите вкл или откл и нажмите ENTER.
Ввод команды: МАСКИРОВКА


Создание пустых маскирующих областей (Краткий справочник)

Редактирование штриховки и заливки
Создание пустых маскирующих областей
Коротко о примечаниях и метках
Аннотирование чертежей > Штриховка, заливка и маскировка > Создание пустых маскирующих областей >
Создание пустых маскирующих областей
Понятие Процедура Краткий справочник

Команды

МАСКИРОВКА

Создание маскирующих объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Примечания и метки

Создание пустых маскирующих областей
Аннотирование чертежей
Коротко о примечаниях и метках
Аннотирование чертежей >
Примечания и метки

Имеется возможность выполнения и редактирования различных типов текстовых надписей, включая надписи на выносках. Большинство параметров текста управляется с помощью текстовых стилей.

Темы в этом разделе

  • Коротко о примечаниях и метках
  • Нанесение текста

    Нанесение текста может выполняться различными способами, в зависимости от поставленных целей.

  • Создание выносок
  • Использование полей в тексте

    Поле представляет собой обновляемый текст, предназначенный для отображения данных, которые могут поменяться в ходе редактирования чертежа. При обновлении поля отображается его последнее значение.

  • Работа с текстовыми стилями

    При выполнении надписей на чертеже применяется текущий текстовый стиль, который определяет шрифт, высоту и угол наклона символов, ориентацию надписи, а также другие параметры текста.

  • Редактирование текста

    Имеется возможность редактирования и форматирования текста в надписях с изменением таких свойств, как масштаб и выравнивание.

  • Проверка орфографии

    Проверку орфографии всего текста можно выполнять по мере появления его на чертеже. Кроме того, можно указать используемый словарь для конкретного языка, а также настроить несколько пользовательских словарей проверки орфографии и работать с ними.

  • Работа с внешними текстовыми редакторами

    По умолчанию, в качестве текстового редактора используется вкладка ленты МТЕКСТ (если лента включена) или контекстный текстовый редактор (если вкладка не включена), но пользователь может выбрать любой другой редактор, позволяющий сохранять файлы в формате ASCII.


Коротко о примечаниях и метках (Понятие)

Примечания и метки
Примечания и метки
Нанесение текста
Аннотирование чертежей > Примечания и метки >
Коротко о примечаниях и метках
Понятие Процедура Краткий справочник

Текст можно создать различными способами. Более короткие фрагменты выполняются с помощью однострочного текста. Для длинных надписей с форматированием используется многострочный текст (также называемый мтекст). Многострочный текст может применяться и в выносках.

Несмотря на то, что при нанесении надписей применяется текущий текстовый стиль, который определяет шрифт и параметры текста, существует несколько способов настройки внешнего вида текста. Существуют инструменты для масштабирования и выравнивания текста, поиска и замены текста, а также для проверки на наличие орфографических ошибок.

Текстовые надписи, используемые в размерах и допусках, выполняются с помощью команд, предназначенных для нанесения размеров.

См. также

    • Отображение полилиний, штриховок, градиентных заливок, весов линий и текста

    • Управление отображением перекрывающихся объектов


Коротко о примечаниях и метках (Процедура)

Создание пустых маскирующих областей
Коротко о примечаниях и метках
Коротко о примечаниях и метках
Аннотирование чертежей > Примечания и метки > Коротко о примечаниях и метках >
Коротко о примечаниях и метках
Понятие Процедура Краткий справочник

Создание однострочного текста

Создание многострочного текста


Создание однострочного текста (Процедура)

Коротко о примечаниях и метках
Коротко о примечаниях и метках
Коротко о примечаниях и метках
Аннотирование чертежей > Примечания и метки > Коротко о примечаниях и метках >
Коротко о примечаниях и метках
Понятие Процедура Краткий справочник

Создание однострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Однострочный". В командной строке введите "дтекст".
  2. Укажите точку вставки первого символа. При нажатии клавиши ENTER программа поместит новый текст непосредственно под текстовым объектом, созданным последним (если таковой имеется).
  3. Задайте высоту текста. Запрос высоты появляется в том случае, если текущий текстовый стиль имеет нулевую высоту.

    Точка вставки текста и курсор соединяются резиновой линией. Чтобы задать высоту текста по резиновой линии, требуется нажать кнопку мыши.

  4. Задайте угол поворота текста.

    Угол можно задать путем ввода числового значения или с помощью устройства указания.

  5. Введите текст. В конце строки нажмите ENTER. Если необходимо, введите следующие строки.
    ПримечаниеТекст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.

    Если указать другую точку вставки, курсор перемещается к указанной позиции, после чего можно продолжать ввод текста. После каждого нажатия ENTER или указания точки создается новый текстовый объект.

  6. Для завершения команды нажмите ENTER на пустой строке.
Ввод команды: ТЕКСТ


Создание многострочного текста (Процедура)

Коротко о примечаниях и метках
Коротко о примечаниях и метках
Нанесение текста
Аннотирование чертежей > Примечания и метки > Коротко о примечаниях и метках >
Коротко о примечаниях и метках
Понятие Процедура Краткий справочник

Создание многострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.

    Если включена лента, то отображается контекстная вкладка ленты МТЕКСТ. Если лента не включена, отображается контекстный текстовый редактор.

  3. Для задания отступа первой строки абзаца на горизонтальной линейке переместите маркер "Первая строка" в положение, с которого должен начинаться текст. Для задания отступа остальных строк абзаца на горизонтальной линейке переместите маркер "Абзац".
  4. Для задания позиций табуляции нажмите кнопку мыши в нужных местах на горизонтальной линейке.
  5. Для задания текстового стиля, отличного от установленного по умолчанию, раскройте список "Стиль" на панели редактора и выберите требуемый стиль.
  6. Введите текст.
    ПримечаниеТекст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.
  7. Для переопределения настроек текущего текстового стиля выделите текст одним из следующих способов:
    • Для выделения фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, проведите курсор над нужными символами.
    • Для выделения слова дважды нажмите на нем кнопку мыши.
    • Для выделения абзаца трижды нажмите на нем кнопку мыши.
  8. С помощью панели инструментов измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
      ПримечаниеЕсли во время создания многострочного текста не изменить его высоту, установленную по умолчанию, значение высоты многострочного текста будет сброшено до 0.
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Если необходимый цвет отсутствует в списке, следует воспользоваться пунктом "Выбор цвета".
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Коротко о примечаниях и метках (Краткий справочник)

Создание пустых маскирующих областей
Коротко о примечаниях и метках
Общие сведения о создании текста
Аннотирование чертежей > Примечания и метки > Коротко о примечаниях и метках >
Коротко о примечаниях и метках
Понятие Процедура Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

МВЫНОСКА

Создание объекта-мультивыноски

МТЕКСТ

Создание многострочного текстового объекта

ОРФО

Орфографическая проверка надписей в чертеже

СТИЛЬ

Создание, изменение или определение стилей текста

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

DIMASZ

Управление величинами стрелок размерных линий и линий выноски

DIMLDRBLK

Задание типа стрелки для выносок

Утилиты

Нет

Ключевые слова для команд

Нет


Нанесение текста

Коротко о примечаниях и метках
Примечания и метки
Общие сведения о создании текста
Аннотирование чертежей > Примечания и метки >
Нанесение текста
Понятие Процедура

Нанесение текста может выполняться различными способами, в зависимости от поставленных целей.

Темы в этом разделе

  • Общие сведения о создании текста
  • Создание однострочного текста

    Можно создавать одну или несколько строк текста, каждая из которых является отдельным объектом. Строки можно по отдельности перемещать, форматировать или редактировать иным образом.

  • Создание многострочного текста

    Многострочный текст ("мтекст") состоит из одного или нескольких абзацев, которые при манипуляциях ведут себя как единый объект.

  • Создание и редактирование столбцов многострочного текста

    Предусмотрена возможность создания и редактирования текста, расположенного в нескольких столбцах, с помощью параметров столбцов в контекстном редакторе и ручек для работы со столбцами.

  • Импорт текстовых файлов

    В чертеж можно вставлять текст из файлов форматов TXT и RTF, импортируя сам текст или перетаскивая значок файла из Проводника Windows.


Нанесение текста (Процедура)

Коротко о примечаниях и метках
Нанесение текста
Общие сведения о создании текста
Аннотирование чертежей > Примечания и метки > Нанесение текста >
Нанесение текста
Понятие Процедура

Создание однострочного текста

Создание многострочного текста

Создание однострочного текста

Задание текстового стиля при создании однострочного текста

Задание режима выравнивания однострочного текста

Процедура создания нескольких столбцов в контекстном редакторе

Процедура настройки столбцов с помощью ручек

Импорт текстовых файлов

Вставка текстового файла перетаскиванием


Общие сведения о создании текста (Понятие)

Нанесение текста
Нанесение текста
Создание однострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста >
Общие сведения о создании текста
Понятие Процедура Краткий справочник

Наносимые на чертеж текстовые надписи несут различную информацию. Надписи могут представлять собой сложные спецификации, элементы основной надписи, метки; кроме того, надписи могут даже быть полноправными элементами самого чертежа.

Однострочный текст

Короткие надписи, не требующие применения различных шрифтов, выполняются в виде однострочного текста. Такие надписи наиболее удобны для нанесения меток.

Многострочный текст

Для создания длинных и сложных надписей используется многострочный текст или текст, содержащий абзацы. Многострочный текст состоит из текстовых строк или абзацев, вписанных в указанную пользователем ширину; его длина при этом не определена.

В отличие от однострочного текста, все строки многострочного текста представляют собой единый объект. Многострочный текст можно перемещать, поворачивать, стирать, копировать, зеркально отображать и масштабировать.

Возможности форматирования многострочного текста намного шире, чем однострочного. Например, в многострочных надписях можно задавать режим подчеркивания отдельных слов и фраз, назначать для них свой шрифт, цвет и высоту символов.

Аннотативный текст

Используйте аннотативный текст для создания примечаний и меток на чертеже. Аннотативный текст создается на основе аннотативного текстового стиля, который определяет высоту текста на листе бумаги.

Более подробную информацию о создании аннотативного текста и о работе с ним см. в разделе Создание аннотативного текста.

См. также

    • Масштабирование аннотаций


Общие сведения о создании текста (Процедура)

Нанесение текста
На уровень вверх ..
Общие сведения о создании текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Общие сведения о создании текста >
Общие сведения о создании текста
Понятие Процедура Краткий справочник

Создание однострочного текста

Создание многострочного текста


Создание однострочного текста (Процедура)

Общие сведения о создании текста
На уровень вверх ..
Общие сведения о создании текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Общие сведения о создании текста >
Общие сведения о создании текста
Понятие Процедура Краткий справочник

Создание однострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Однострочный". В командной строке введите "дтекст".
  2. Укажите точку вставки первого символа. При нажатии клавиши ENTER программа поместит новый текст непосредственно под текстовым объектом, созданным последним (если таковой имеется).
  3. Задайте высоту текста. Запрос высоты появляется в том случае, если текущий текстовый стиль имеет нулевую высоту.

    Точка вставки текста и курсор соединяются резиновой линией. Чтобы задать высоту текста по резиновой линии, требуется нажать кнопку мыши.

  4. Задайте угол поворота текста.

    Угол можно задать путем ввода числового значения или с помощью устройства указания.

  5. Введите текст. В конце строки нажмите ENTER. Если необходимо, введите следующие строки.
    ПримечаниеТекст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.

    Если указать другую точку вставки, курсор перемещается к указанной позиции, после чего можно продолжать ввод текста. После каждого нажатия ENTER или указания точки создается новый текстовый объект.

  6. Для завершения команды нажмите ENTER на пустой строке.
Ввод команды: ТЕКСТ


Создание многострочного текста (Процедура)

Общие сведения о создании текста
На уровень вверх ..
Создание однострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Общие сведения о создании текста >
Общие сведения о создании текста
Понятие Процедура Краткий справочник

Создание многострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.

    Если включена лента, то отображается контекстная вкладка ленты МТЕКСТ. Если лента не включена, отображается контекстный текстовый редактор.

  3. Для задания отступа первой строки абзаца на горизонтальной линейке переместите маркер "Первая строка" в положение, с которого должен начинаться текст. Для задания отступа остальных строк абзаца на горизонтальной линейке переместите маркер "Абзац".
  4. Для задания позиций табуляции нажмите кнопку мыши в нужных местах на горизонтальной линейке.
  5. Для задания текстового стиля, отличного от установленного по умолчанию, раскройте список "Стиль" на панели редактора и выберите требуемый стиль.
  6. Введите текст.
    ПримечаниеТекст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.
  7. Для переопределения настроек текущего текстового стиля выделите текст одним из следующих способов:
    • Для выделения фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, проведите курсор над нужными символами.
    • Для выделения слова дважды нажмите на нем кнопку мыши.
    • Для выделения абзаца трижды нажмите на нем кнопку мыши.
  8. С помощью панели инструментов измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
      ПримечаниеЕсли во время создания многострочного текста не изменить его высоту, установленную по умолчанию, значение высоты многострочного текста будет сброшено до 0.
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Если необходимый цвет отсутствует в списке, следует воспользоваться пунктом "Выбор цвета".
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Общие сведения о создании текста (Краткий справочник)

Коротко о примечаниях и метках
Общие сведения о создании текста
Создание однострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Общие сведения о создании текста >
Общие сведения о создании текста
Понятие Процедура Краткий справочник

Команды

МВЫНОСКА

Создание объекта-мультивыноски

МТЕКСТ

Создание многострочного текстового объекта

БВЫНОСКА

Построение простой выноски и аннотации для нее

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

DIMASZ

Управление величинами стрелок размерных линий и линий выноски

DIMLDRBLK

Задание типа стрелки для выносок

Утилиты

Нет

Ключевые слова для команд

Нет


Создание однострочного текста (Понятие)

Общие сведения о создании текста
Нанесение текста
Создание многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста >
Создание однострочного текста
Понятие Процедура Краткий справочник

Можно создавать одну или несколько строк текста, каждая из которых является отдельным объектом. Строки можно по отдельности перемещать, форматировать или редактировать иным образом.

Команда однострочного текста (ТЕКСТ) позволяет создать одну или несколько строк текста. Каждая строка заканчивается при нажатии клавиши ENTER. Каждая строка является отдельным объектом, который можно перемещать, форматировать или редактировать иным образом.

При создании однострочного текста устанавливаются стиль текста и выравнивание. Текущие настройки вида текстового объекта определяются текстовым стилем. Выравнивание задает расположение текстовой строки относительно точки вставки. Для ввода текста по месту используется команда ТЕКСТ, тогда как ввод слова -текст в командной строке позволяет ввести текст в командную строку.

В однострочный текст можно вставить поле. Полем называется текст, используемый для отображения данных, которые могут изменяться. При обновлении поля отображается его последнее значение.

Одни и те же текстовые стили могут применяться как для однострочных текстов, так и для многострочных. Назначение стиля при создании текста выполняется с помощью опции "Стиль" с последующим вводом имени нужного стиля. Для выполнения надписей с неоднородным форматированием вместо однострочного текста следует использовать многострочный.

Можно также задать режим вписывания текста между указанными точками. При этом текст растягивается или сжимается в зависимости от расстояния между ними.

Системная переменная DTEXTED определяет пользовательский интерфейс, отображаемый для редактирования однострочного текста.

Режимы выравнивания однострочного текста

При создании текста можно задать режимы его выравнивания. Варианты выравнивания текста иллюстрируются на следующем чертеже. По умолчанию используется режим выравнивания "Влево". Поэтому для нанесения надписи, выровненной влево от точки вставки, в командной строке дополнительно задавать ничего не требуется.

См. также

    • Использование полей в тексте


Создание однострочного текста (Процедура)

Общие сведения о создании текста
На уровень вверх ..
Создание однострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание однострочного текста >
Создание однострочного текста
Понятие Процедура Краткий справочник

Создание однострочного текста

Задание текстового стиля при создании однострочного текста

Задание режима выравнивания однострочного текста


Создание однострочного текста (Процедура)

Создание однострочного текста
На уровень вверх ..
Создание однострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание однострочного текста >
Создание однострочного текста
Понятие Процедура Краткий справочник

Создание однострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Однострочный". В командной строке введите "дтекст".
  2. Укажите точку вставки первого символа. При нажатии клавиши ENTER программа поместит новый текст непосредственно под текстовым объектом, созданным последним (если таковой имеется).
  3. Задайте высоту текста. Запрос высоты появляется в том случае, если текущий текстовый стиль имеет нулевую высоту.

    Точка вставки текста и курсор соединяются резиновой линией. Чтобы задать высоту текста по резиновой линии, требуется нажать кнопку мыши.

  4. Задайте угол поворота текста.

    Угол можно задать путем ввода числового значения или с помощью устройства указания.

  5. Введите текст. В конце строки нажмите ENTER. Если необходимо, введите следующие строки.
    ПримечаниеТекст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.

    Если указать другую точку вставки, курсор перемещается к указанной позиции, после чего можно продолжать ввод текста. После каждого нажатия ENTER или указания точки создается новый текстовый объект.

  6. Для завершения команды нажмите ENTER на пустой строке.
Ввод команды: ТЕКСТ


Задание текстового стиля при создании однострочного текста (Процедура)

Создание однострочного текста
На уровень вверх ..
Создание однострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание однострочного текста >
Создание однострочного текста
Понятие Процедура Краткий справочник

Задание текстового стиля при создании однострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Однострочный". В командной строке введите "дтекст".
  2. Введите с (стиль).
  3. В ответ на запрос "Имя стиля" введите имя имеющегося текстового стиля.

    Если для этого необходимо просмотреть список текстовых стилей, введите ? и дважды нажмите ENTER.

  4. Продолжите создание текста.
Ввод команды: ТЕКСТ


Задание режима выравнивания однострочного текста (Процедура)

Создание однострочного текста
На уровень вверх ..
Создание многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание однострочного текста >
Создание однострочного текста
Понятие Процедура Краткий справочник

Задание режима выравнивания однострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Однострочный". В командной строке введите "дтекст".
  2. Ввести с (Стиль).
  3. Задайте режим выравнивания. Например, введите вл для выравнивания текста вверх и влево.
  4. Продолжите создание текста.
Ввод команды: ТЕКСТ


Создание однострочного текста (Краткий справочник)

Общие сведения о создании текста
Создание однострочного текста
Коротко о многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание однострочного текста >
Создание однострочного текста
Понятие Процедура Краткий справочник

Команды

КТЕКСТ

Управление отображением и выводом на плоттер текста и атрибутов

СТИЛЬ

Создание, изменение или определение стилей текста

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

DTEXTED

Задание интерфейса пользователя, выводимого на экран для редактирования однострочного текста

FONTALT

Задание альтернативного шрифта, используемого в случае, если не найден указанный шрифт

FONTMAP

Задание файла, описывающего подстановку шрифтов

MIRRTEXT

Управление отображением текста с помощью команды ЗЕРКАЛО

QTEXTMODE

Управление отображением текста

TEXTEVAL
TEXTFILL
TEXTQLTY
TEXTSIZE

Значение высоты по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля

TEXTSTYLE

Имя текущего текстового стиля

Утилиты

Нет

Ключевые слова для команд

Нет


Создание многострочного текста

Создание однострочного текста
Нанесение текста
Коротко о многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста >
Создание многострочного текста
Понятие Процедура

Многострочный текст ("мтекст") состоит из одного или нескольких абзацев, которые при манипуляциях ведут себя как единый объект.

Темы в этом разделе

  • Коротко о многострочном тексте
  • Выравнивание многострочного текста

    Режим выравнивания управляет размещением многострочного текста относительно его точки вставки, а также направлением его распространения.

  • Форматирование символов многострочного текста
  • Создание списков в многострочном тексте

    Можно создавать маркированные списки, буквенные или нумерованные списки или простые планы в многострочном тексте.

  • Задание отступов и табуляции в многострочном тексте

    Можно устанавливать отступ абзацев в объектах многострочного текста (мтекст). Линейка в верхней части контекстного редактора отображает позиции табуляции и отступа текущего абзаца.

  • Задание межстрочного интервала многострочного текста

    Межстрочный интервал определяет расстояние между базовыми линиями двух соседних строк текста. Значение межстрочного интервала устанавливается сразу для всего многострочного текстового объекта, а не только для выделенных строк.

  • Создание дробей в многострочном тексте

    Символы, обозначающие дроби и допуски, можно отформатировать по различным стандартам.


Создание многострочного текста (Процедура)

Создание однострочного текста
На уровень вверх ..
Коротко о многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Создание многострочного текста
Понятие Процедура

Создание многострочного текста

Вставка обозначений или специальных символов в многострочный текст

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста

Изменение режима выравнивания многострочного текста

Форматирование символов многострочного текста

Форматирование многострочного текста как списка

Отмена форматирования в многострочном тексте

Создание буквенного или нумерованного списка в многострочном тексте при вводе

Создание маркированного списка в многострочном тексте при вводе

Перемещение элемента списка многострочного текста на один уровень вниз

Разделение существующего списка

Преобразование списков, расположенных в многострочном тексте, в обычный текст

Создание абзацев с отступом

Изменение межстрочного интервала многострочного текстового объекта

Создание дробного текста

Изменение свойств дробного текста

Отключение дробного текста


Коротко о многострочном тексте (Понятие)

Создание многострочного текста
Создание многострочного текста
Выравнивание многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Коротко о многострочном тексте
Понятие Процедура Краткий справочник

Состоящий из одного или нескольких абзацев многострочный текст (мтекст) можно создать на контекстной вкладке ленты МТЕКСТ , если лента включена, Контекстный текстовый редактор или (если лента не включена) использовать текстовый редактор. Кроме того, можно ввести текст в командную строку. Имеется возможность вставить текст из файла, сохраненного в формате ASCII или RTF.

Прежде чем набрать или импортировать текст, необходимо задать рамкой ширину абзацев многострочного текста. В отличие от ширины, длина текста не определяется рамкой, а зависит только от размера текстовых данных объекта. С помощью ручек многострочные текстовые объекты можно перемещать и поворачивать.

На вкладке ленты МТЕКСТ и в контекстном текстовом редакторе отображается рамка с линейкой в верхней ее части. Если лента не включена, то отображается и панель "Форматирование текста". Окно редактора является прозрачным, что позволяет контролировать расположение набираемого текста относительно других объектов. Для отключения прозрачности на время работы выберите "Непрозрачный фон" в меню "Настройка". Можно также включить для многострочного текста непрозрачную маску заднего плана и задать ее цвет.

В многострочном тексте можно использовать поля. Полем называется текст, используемый для отображения данных, которые могут изменяться. При обновлении поля отображается его последнее значение.

Текстовый стиль

Большинство параметров текста обуславливаются текстовым стилем. К числу таких параметров относятся шрифт, цвет, режим выравнивания и интервал. Имеется возможность использования текущего текстового стиля, а также выбора и загрузки нового. По умолчанию применяется текстовый стиль СТАНДАРТ.

Для отдельных фрагментов текста можно задавать различные текстовые стили, изменяя начертание и шрифт. Можно также включать фрагменты с использованием дробного текста, например значения допусков. Кроме того, при использовании шрифтов TrueType можно вставлять специальные символы, в том числе символы из набора Unicode.

ПримечаниеНе все текстовые шрифты TrueType и SHX поддерживают символы из набора Unicode.

Свойства текста

На палитре "Свойства" можно просматривать и изменять свойства объектов многострочного текста, в том числе свойства, присущие только тексту.

  • Режим выравнивания определяет положение текста относительно границ окна и задает направление текста при его вводе.
  • Опции межстрочного интервала определяют расстояние между базовыми линиями двух соседних строк многострочного текстового объекта.
  • Настройка ширины задает ширину рамки текста, т.е. определяет место переноса текста на новую строку.
  • Маска заднего плана делает невидимыми объекты, расположенные за текстом.


Коротко о многострочном тексте (Процедура)

Создание многострочного текста
На уровень вверх ..
Коротко о многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Коротко о многострочном тексте >
Коротко о многострочном тексте
Понятие Процедура Краткий справочник

Создание многострочного текста

Вставка обозначений или специальных символов в многострочный текст

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста


Создание многострочного текста (Процедура)

Коротко о многострочном тексте
На уровень вверх ..
Коротко о многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Коротко о многострочном тексте >
Коротко о многострочном тексте
Понятие Процедура Краткий справочник

Создание многострочного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.

    Если включена лента, то отображается контекстная вкладка ленты МТЕКСТ. Если лента не включена, отображается контекстный текстовый редактор.

  3. Для задания отступа первой строки абзаца на горизонтальной линейке переместите маркер "Первая строка" в положение, с которого должен начинаться текст. Для задания отступа остальных строк абзаца на горизонтальной линейке переместите маркер "Абзац".
  4. Для задания позиций табуляции нажмите кнопку мыши в нужных местах на горизонтальной линейке.
  5. Для задания текстового стиля, отличного от установленного по умолчанию, раскройте список "Стиль" на панели редактора и выберите требуемый стиль.
  6. Введите текст.
    ПримечаниеТекст, который может оказаться трудночитаемым (если он очень мелкий, очень крупный или повёрнут), отображается в удобном для чтения масштабе и в горизонтальном положении, чтобы его было удобно читать и редактировать.
  7. Для переопределения настроек текущего текстового стиля выделите текст одним из следующих способов:
    • Для выделения фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, проведите курсор над нужными символами.
    • Для выделения слова дважды нажмите на нем кнопку мыши.
    • Для выделения абзаца трижды нажмите на нем кнопку мыши.
  8. С помощью панели инструментов измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
      ПримечаниеЕсли во время создания многострочного текста не изменить его высоту, установленную по умолчанию, значение высоты многострочного текста будет сброшено до 0.
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Если необходимый цвет отсутствует в списке, следует воспользоваться пунктом "Выбор цвета".
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Вставка обозначений или специальных символов в многострочный текст (Процедура)

Коротко о многострочном тексте
На уровень вверх ..
Коротко о многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Коротко о многострочном тексте >
Коротко о многострочном тексте
Понятие Процедура Краткий справочник

Вставка обозначений или специальных символов в многострочный текст

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. На вкладке ленты или на развернутой панели выберите "Символ".
  3. Выберите нужный символ из подменю или выберите пункт "Прочие" для вызова диалогового окна "Таблица символов".

    Для вызова диалогового окна "Таблица символов" необходимо, чтобы была установлена программа charmap.exe. Информацию о добавлении программ к системе см. в справочной системе Microsoft® Windows®.

  4. В диалоговом окне "Таблица символов" выберите шрифт.
  5. Выделите символ и выполните одно из следующих действий:
    • Для вставки одиночного символа необходимо перетащить выбранный символ в редактор.
    • Для вставки нескольких символов необходимо для каждого символа нажать кнопку "Выбрать" для добавления его в поле "Копируемые символы". После выбора всех необходимых символов нажмите кнопку "Копировать". Нажмите правую кнопку мыши в редакторе. Выберите "Вставить".
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Задание объекту многострочного текста непрозрачной или цветной маски заднего плана (Процедура)

Коротко о многострочном тексте
На уровень вверх ..
Коротко о многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Коротко о многострочном тексте >
Коротко о многострочном тексте
Понятие Процедура Краткий справочник

Задание объекту многострочного текста непрозрачной или цветной маски заднего плана

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. На контекстной вкладке ленты выберите "Скрытие заднего плана". Нажмите правую кнопку мыши в редакторе. Выберите "Маска заднего плана".
  3. В диалоговом окне "Маска заднего плана" выберите "Использовать маску".
  4. Введите значение для коэффициента смещения границ.

    Значение привязывается к высоте текста. Коэффициент, равный 1,0, означает, что размер непрозрачного фона точно соответствует размеру объекта многострочного текста. Коэффициент 1,5 (по умолчанию) означает, что маска выступает за пределы текста на половину его высоты.

  5. В группе "Цвет заливки" выполните одно из следующих действий:
    • Выберите параметр "Использовать цвет фона чертежа".
    • Выберите цвет фона или нажмите "Выбор цвета" для открытия диалогового окна "Выбор цвета".
  6. Нажмите "OK" для возврата в редактор.
  7. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

    После выхода из редактора используется непрозрачный фон.

Панель:Рисование
Ввод команды: МТЕКСТ


Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста (Процедура)

Коротко о многострочном тексте
На уровень вверх ..
Выравнивание многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Коротко о многострочном тексте >
Коротко о многострочном тексте
Понятие Процедура Краткий справочник

Изменение в редакторе многострочного текста настройки сглаживания шрифтов Windows для улучшения видимости текста

  1. Нажмите правую кнопку мыши на рабочем столе Windows. Выберите "Свойства".
  2. В диалоговом окне "Свойства: Экран" выберите вкладку "Оформление".
  3. Выберите "Эффекты".
  4. В диалоговом окне "Эффекты" выберите "Применять следующий метод сглаживания экранных шрифтов" для отмены этого режима.
  5. Нажмите "ОК" для выхода из диалогового окна "Эффекты".
  6. Нажмите "ОК" для выхода из диалогового окна "Свойства: Экран".


Коротко о многострочном тексте (Краткий справочник)

Создание однострочного текста
Коротко о многострочном тексте
Выравнивание многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Коротко о многострочном тексте >
Коротко о многострочном тексте
Понятие Процедура Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

КТЕКСТ

Управление отображением и выводом на плоттер текста и атрибутов

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

MTEXTED

Задание приложения для редактирования многострочных текстовых объектов

MTEXTFIXED

Задание размера экрана и положения многострочного текста

MTEXTTOOLBAR

Управление отображением инструментальной панели "Форматирование текста"

MTJIGSTRING

Задание содержимого образца текста, отображаемого в месте курсора при запуске команды МТЕКСТ

QTEXTMODE

Управление отображением текста

TEXTFILL
TEXTQLTY
TEXTSIZE

Значение высоты по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля

TEXTSTYLE

Имя текущего текстового стиля

Утилиты

Нет

Ключевые слова для команд

Нет


Выравнивание многострочного текста (Понятие)

Коротко о многострочном тексте
Создание многострочного текста
Форматирование символов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Выравнивание многострочного текста
Понятие Процедура Краткий справочник

Режим выравнивания управляет размещением многострочного текста относительно его точки вставки, а также направлением его распространения.

Режим выравнивания управляет размещением многострочного текста относительно его точки вставки, а также направлением его распространения. Выравнивание текста производится относительно левой и правой границ текстовой рамки. Текст может распространяться от середины, верхней или нижней границы абзаца.

Существуют девять вариантов настроек выравнивания многострочного текста.

Если длина отдельного слова текста больше ширины абзаца, то слово не переносится, а выходит за границы абзаца.


Изменение режима выравнивания многострочного текста (Процедура)

Коротко о многострочном тексте
На уровень вверх ..
Форматирование символов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Выравнивание многострочного текста >
Выравнивание многострочного текста
Понятие Процедура Краткий справочник

Изменение режима выравнивания многострочного текста

  1. Выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".
  2. Выберите объект многострочного текста.
  3. На палитре свойств выберите один из режимов выравнивания.
  4. Нажмите кнопку мыши за пределами палитры свойств.
Ввод команды: ОКНОСВ


Выравнивание многострочного текста (Краткий справочник)

Коротко о многострочном тексте
Выравнивание многострочного текста
Форматирование символов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Выравнивание многострочного текста >
Выравнивание многострочного текста
Понятие Процедура Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Форматирование символов многострочного текста (Понятие)

Выравнивание многострочного текста
Создание многострочного текста
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Форматирование символов многострочного текста
Понятие Процедура Краткий справочник

Для многострочного текста можно применять неоднородное форматирование, переопределяя заданный текстовый стиль. Форматирование воздействует только на выбранный текст; текущий текстовый стиль не меняется.

Можно задавать шрифт и размер текста, а также изменять начертание (полужирное, курсивное, подчеркнутое, надчеркнутое) и цвет. Также можно задавать угол наклона, изменять межсимвольный интервал и расширять или сужать символы. Параметр "Отменить форматирование" в меню параметров меняет значения атрибутов символов выделенного фрагмента на значения текущего стиля текста, а также меняет цвет текста на цвет объекта многострочного текста.

Высота прописных букв в тексте определяется заданной высотой символов. Более подробную информацию о расчете высоты см. в описании команды МТЕКСТ.

См. также

    • Работа с внешними текстовыми редакторами


Форматирование символов многострочного текста (Процедура)

Выравнивание многострочного текста
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Форматирование символов многострочного текста >
Форматирование символов многострочного текста
Понятие Процедура Краткий справочник

Форматирование символов многострочного текста

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. Выделите текст одним из следующих способов:
    • Для выделения фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, провести курсор над нужными символами.
    • Для выделения слова дважды нажмите на нем кнопку мыши.
    • Для выделения абзаца трижды нажмите на нем кнопку мыши.
  3. На контекстной вкладке ленты или на панели измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Нажмите кнопку "Прочие" для отображения диалогового окна "Выбор цвета".
    • Для задания угла наклона текста введите значение от -85 до 85. Положительное значение угла соответствует наклону символов вправо, отрицательное - наклону влево.
    • Для изменения интервала между знаками в выделенном фрагменте введите новое значение.
    • Для изменения ширины символов в выделенном фрагменте введите новое значение.
  4. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Форматирование символов многострочного текста (Краткий справочник)

Выравнивание многострочного текста
Форматирование символов многострочного текста
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Форматирование символов многострочного текста >
Форматирование символов многострочного текста
Понятие Процедура Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

МТЕКСТ

Создание многострочного текстового объекта

ОКНОСВ

Управление свойствами объектов

СТИЛЬ

Системные переменные

TEXTFILL
TEXTSTYLE

Утилиты

Нет

Ключевые слова для команд

Нет


Создание списков в многострочном тексте (Понятие)

Форматирование символов многострочного текста
Создание многострочного текста
Задание отступов и табуляции в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Можно создавать маркированные списки, буквенные или нумерованные списки или простые планы в многострочном тексте.

Строки многострочного текста можно форматировать так же, как и список. При добавлении или удалении элемента или при перемещении элемента вверх или вниз на один уровень нумерация в списке изменяется автоматически. Имеется возможность удаления и возвращения форматирования списка тем же способом, что используется в большинстве текстовых редакторов.

Использование автоматического форматирования списков

По умолчанию формат списка применяется ко всем текстам, похожим на список. Списком считается текст, одновременно отвечающий следующим критериям:

  • строка начинается с одной или нескольких букв или цифр или обозначения;
  • за буквой или цифрой следует знак препинания;
  • пробел после знака препинания создается нажатием клавиши TAB;
  • текст, следующий за пробелом, заканчивается нажатием клавиш ЕNTER или SHIFT+ENTER.
ПримечаниеЕсли не требуется применять форматирование списка ко всем фрагментам текста, удовлетворяющим этим критериям, нужно снять флажок "Разрешить маркеры и списки". (Щелкните правой кнопкой мыши в контекстном редакторе, выберите "Маркеры и списки" и снимите флажок "Разрешить маркеры и списки".) Если не установлен флажок "Разрешить маркеры и списки", создавать новые форматированные списки в объекте многострочного текста нельзя.

Для создания списка можно воспользоваться одним из следующих способов:

  • Применить форматирование списка к новому тексту или выделенному фрагменту текста.
  • Воспользоваться автоматическим режимом списка (включен по умолчанию) и ввести элементы списка.
  • Если опция "Автоматический список" отключена, то для преобразования текста в список необходимо ввести элементы списка, затем закрыть редактор и вновь открыть его.

Применение форматирования списка

При использовании форматирования списка можно задавать маркеры, буквы верхнего или нижнего регистра или цифры. Для выбираемого типа списка используются параметры по умолчанию. После букв и цифр ставится точка. Во вложенных списках используются двойные маркеры, буквы или цифры. Смещение элементов вправо (отступ) производится по позициям табуляции, установленных на линейке контекстного редактора.

Использование автоматического списка для ввода списка

Когда включен режима автоматического списка, список можно создавать при вводе текста. Можно использовать буквы, цифры или символы.

Например, находясь в редакторе, введите \U+25CB, нажмите клавишу TAB и затем введите текст. В результате будет создан маркер в виде пустого кружка.

Таблица кодов символов может не содержать каких-либо символов для конкретного шрифта. Но если текст Unicode задать непосредственно (в данном случае введя \U+25CB), то всегда можно получить маркер нужного формата.

ПримечаниеПосле ввода текста Unicode или символа нажмите клавишу TAB, иначе он так и останется отдельным символом.

Кроме того, символ можно вставить из диалогового окна "Набор символов"

Ниже приведены символы, которые можно использовать в качестве знаков препинания после цифры или буквы при вводе элементов списка. Эти символы нельзя использовать в качестве маркеров.

Символ | Описание
. | Точка
: | Двоеточие
) | Закрывающая круглая скобка
> | Закрывающая угловая скобка
] | Закрывающая квадратная скобка
} | Закрывающая фигурная скобка

Вставка списка из другого документа

При копировании вложенных маркированных списков (список в списке) из программы Microsoft Word и вставке списка в многострочный текст маркеры, отображаемые пустыми кружками, не могут форматироваться, как другие маркеры в тексте. Это связано с тем, что в программе Word буква o используется вместо маркера для вложенных маркированных текстов. Можно отменить форматирование во вложенном списке и повторно применить его для замены маркеров двойными маркерами.


Создание списков в многострочном тексте (Процедура)

Форматирование символов многострочного текста
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Форматирование многострочного текста как списка

Отмена форматирования в многострочном тексте

Создание буквенного или нумерованного списка в многострочном тексте при вводе

Создание маркированного списка в многострочном тексте при вводе

Перемещение элемента списка многострочного текста на один уровень вниз

Разделение существующего списка

Преобразование списков, расположенных в многострочном тексте, в обычный текст


Форматирование многострочного текста как списка (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Форматирование многострочного текста как списка

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.
  3. Для развертывания панели инструментов "Формат текста" нажмите кнопку "Настройка" [image] "Показать параметры".
  4. При преобразовании многострочного текста в список выберите абзацы.
    ПримечаниеФорматирование списка возможно только тогда, когда флажок "Разрешить маркеры и списки" установлен (значение по умолчанию).
  5. На развернутой панели нажмите кнопку "Нумерация", "Маркеры" или "Буквы верхнего регистра".
    • Нумерация. Использует цифры с точками для элементов в списке.
    • Маркеры. Использует маркер или другой символ для элементов в списке.
    • Прописные буквы. Использует прописные буквы с точками для элементов в списке. Если в списке больше элементов, чем букв в алфавите, для продолжения последовательности используются две буквы. Для использования букв нижнего регистра нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки" [image] "Буквенный" [image] "Нижний регистр".
  6. Если создаются новые элементы списка, следует ввести текст.
  7. Чтобы завершить список, нажмите клавишу ENTER для перехода на новую строку. Нажмите кнопку, которая была нажата раньше для создания списка.
  8. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Отмена форматирования в многострочном тексте (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Отмена форматирования в многострочном тексте

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. Выберите элементы списка.
  3. Для развернутого отображения панели инструментов "Формат текста" нажмите кнопку "Настройка" [image] "Показать параметры".
  4. На развернутой панели нажмите активную кнопку списка: "Нумерация", "Маркеры" или "Буквы верхнего регистра" - для ее отключения.
    Примечание Если в списке используются буквы нижнего регистра, нажмите кнопку "Буквы нижнего регистра" для преобразования регистра букв списка в верхний. Затем нажмите кнопку "Буквы верхнего регистра" для ее отключения.
  5. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать ОК на контекстной вкладке ленты или на панели.
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Создание буквенного или нумерованного списка в многострочном тексте при вводе (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Создание буквенного или нумерованного списка в многострочном тексте при вводе

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.
  3. Для развертывания панели инструментов "Формат текста" нажмите кнопку "Настройка" [image] "Показать параметры".
  4. Выберите "Маркеры и списки". Удостоверьтесь, что установлены флажки "Разрешить автоматический список" и "Разрешить маркеры и списки".
  5. Введите букву или цифру и точку (или другой знак препинания).

    В качестве знаков препинания после букв или цифр можно использовать следующие символы: точку (.), двоеточие (:), закрывающую круглую скобку ()), закрывающую угловую скобку (>), закрывающую квадратную скобку (]) и закрывающую фигурную скобку (}).

  6. Нажмите TAB.
  7. Введите текст элемента списка. Нажмите клавишу ENTER для перехода к следующему элементу или использовать сочетание клавиш SHIFT+ENTER для добавления абзаца перед следующим элементом.

    Элементу автоматически присваивается следующая буква или цифра.

  8. Дважды нажмите клавишу ENTER для завершения списка.
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
    • Щелкнуть на значке "Закрыть текстовый редактор" в панели "Многострочный текст".
Панель:Рисование
Ввод команды: МТЕКСТ


Создание маркированного списка в многострочном тексте при вводе (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Создание маркированного списка в многострочном тексте при вводе

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.
  3. В панели "Настройка" щелкните на значке "Настройка" [image].
  4. Выберите "Маркеры и списки". Убедитесь в том, что флажки "Разрешить автоматический список" и "Разрешить маркеры и списки" установлены.
  5. В начале текстовой строки введите \U+2022 (строка Unicode для маркера) или выберите символ маркера или другой символ.
    Примечание В качестве маркеров не могут быть использованы следующие символы: точка (.), двоеточие (:), закрывающая круглая скобка ()), закрывающая угловая скобка (>), закрывающая квадратная скобка (]) и закрывающая фигурная скобка (}).
  6. Другой способ: выберите "Настройка" [image] "Символ" [image] "Другой".

    Отображается диалоговое окно "Набор символов".

  7. Дважды щелкните на нужном символе, чтобы скопировать его в буфер обмена.
  8. Закройте диалоговое окно "Набор символов".
  9. Вставьте скопированный символ в чертеж и нажмите клавишу "стрелка вверх" и End для возврата курсора в прежнюю строку.
  10. Нажмите TAB.
  11. Введите текст элемента списка. Нажмите клавишу ENTER для перехода к следующему элементу или используйте сочетание клавиш SHIFT+ENTER для добавления абзаца перед следующим элементом.

    Символ маркера автоматически добавляется к следующему элементу.

  12. Дважды нажмите клавишу ENTER для завершения списка.
  13. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Перемещение элемента списка многострочного текста на один уровень вниз (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Перемещение элемента списка многострочного текста на один уровень вниз

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. Поместите курсор в начале элемента списка и нажмите клавишу TAB.

    Элемент перемещается на один уровень вниз и начинает вложенный список.

  3. Нажмите клавишу ENTER для расположения следующего элемента на том же уровне или используйте сочетание клавиш SHIFT + TAB для перемещения элемента на один уровень вверх.
  4. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Разделение существующего списка (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Создание списков в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Разделение существующего списка

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. Выберите последовательность элементов или поместите курсор в начало элемента, где необходимо создать новый список.
  3. Нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки" [image] "Начать заново".

    Выбранные элементы перенумеровываются, создавая отдельную последовательность. Если выбрать элементы в середине списка, то невыбранные элементы, расположенные ниже выбранных, также станут частью нового списка.

  4. Для продолжения исходного списка после нового, выберите первый элемент, следующий за новым списком.
  5. Нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки" [image] "Продолжить".

    Выбранный и следующие за ним элементы перенумеровываются, продолжая исходный список.

  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Преобразование списков, расположенных в многострочном тексте, в обычный текст (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Задание отступов и табуляции в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Преобразование списков, расположенных в многострочном тексте, в обычный текст

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. Нажмите правую кнопку мыши в редакторе. Выберите "Маркеры и списки". Снимите флажок опции "Разрешить маркеры и списки".

    В неформатированных списках сохраняются маркеры, цифры и буквы нумерации. При добавлении элемента в такой список цифровая или буквенная последовательность не изменяется.


Создание списков в многострочном тексте (Краткий справочник)

Форматирование символов многострочного текста
Создание списков в многострочном тексте
Задание отступов и табуляции в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание списков в многострочном тексте >
Создание списков в многострочном тексте
Понятие Процедура Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

МТЕКСТ

Создание многострочного текстового объекта

ОКНОСВ

Управление свойствами объектов

Системные переменные

AUTOLIST
TEXTFILL
TEXTQLTY

Утилиты

Нет

Ключевые слова для команд

Нет


Задание отступов и табуляции в многострочном тексте (Понятие)

Создание списков в многострочном тексте
Создание многострочного текста
Задание межстрочного интервала многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Задание отступов и табуляции в многострочном тексте
Понятие Процедура Краткий справочник

Можно устанавливать отступ абзацев в объектах многострочного текста (мтекст). Линейка в верхней части контекстного редактора отображает позиции табуляции и отступа текущего абзаца.

Отступы и позиции табуляции, установленные до набора текста, относятся ко всему многострочному тексту. Чтобы задать различные отступы и позиции табуляции для разных абзацев, необходимо выбрать один или несколько абзацев, а затем установить необходимые отступы и табуляцию.

Маркеры на линейке показывают отступ от левой границы рамки текста. Верхний маркер служит для задания отступа первой строки, а нижний - остальных строк абзаца.

Длинные деления на линейке отмечают стандартные позиции табуляции. Если задать на линейке устройством указания пользовательские позиции табуляции, на ней появится небольшой L-образный маркер в каждой из таких позиций. Для удаления маркера табуляции следует перетащить его в нулевую позицию линейки.


Создание абзацев с отступом (Процедура)

Создание списков в многострочном тексте
На уровень вверх ..
Задание межстрочного интервала многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Задание отступов и табуляции в многострочном тексте >
Задание отступов и табуляции в многострочном тексте
Понятие Процедура Краткий справочник

Создание абзацев с отступом

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. Выделите абзацы, которые необходимо сместить.
  3. Переместить верхний маркер отступа на линейке туда, где должна начинаться первая строка абзаца.
    ПримечаниеНа линейке отображаются отступы и позиции табуляции для выделенного абзаца или для абзаца, где установлен курсор. Стандартные позиции табуляции отмечаются длинными делениями линейки. Для задания дополнительных маркеров табуляции нужно задать выбранную позицию горизонтальной линейки устройством указания.
  4. Переместить нижний маркер отступа туда, где должны начинаться остальные строки абзаца.

    Таким образом смещаются элементы абзацев длиной более одной строки.

  5. Для изменения величины отступа следует выделить необходимый абзац, установить на линейке позиции табуляции, если они требуются, и переместить маркеры отступов.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Задание отступов и табуляции в многострочном тексте (Краткий справочник)

Создание списков в многострочном тексте
Задание отступов и табуляции в многострочном тексте
Задание межстрочного интервала многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Задание отступов и табуляции в многострочном тексте >
Задание отступов и табуляции в многострочном тексте
Понятие Процедура Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

МТЕКСТ

Создание многострочного текстового объекта

ОКНОСВ

Управление свойствами объектов

Системные переменные

TEXTFILL
TEXTQLTY

Утилиты

Нет

Ключевые слова для команд

Нет


Задание межстрочного интервала многострочного текста (Понятие)

Задание отступов и табуляции в многострочном тексте
Создание многострочного текста
Создание дробей в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Задание межстрочного интервала многострочного текста
Понятие Процедура Краткий справочник

Межстрочный интервал определяет расстояние между базовыми линиями двух соседних строк текста. Значение межстрочного интервала устанавливается сразу для всего многострочного текстового объекта, а не только для выделенных строк.

Интервал между строками может иметь какое-либо фиксированное численное значение или устанавливаться кратным одинарному интервалу. Одинарный межстрочный интервал равен 1,66 высоты символов.

Используемая по умолчанию опция "Минимум" обеспечивает автоматический подбор межстрочного интервала для тех строк, которые содержат символы разной высоты. Способ задания межстрочного интервала "Точно" удобно использовать при создании таблиц.

Чтобы интервал между строками различных многострочных текстовых объектов имел одинаковое значение, для всех объектов следует использовать опцию "Точно" и одно и то же значение интервала.

ПримечаниеПри использовании опции "Точно" для текстов с неоднородной высотой символов наиболее высокие из них могут накладываться на символы соседних строк.


Изменение межстрочного интервала многострочного текстового объекта (Процедура)

Задание отступов и табуляции в многострочном тексте
На уровень вверх ..
Создание дробей в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Задание межстрочного интервала многострочного текста >
Задание межстрочного интервала многострочного текста
Понятие Процедура Краткий справочник

Изменение межстрочного интервала многострочного текстового объекта

  1. Выберите пункт меню "Сервис" [image] "Палитры" [image] "Свойства".

    Отображается палитра свойств.

  2. Выберите многострочный текстовый объект, который нужно изменить.
  3. В поле "Стиль межстр. интервала" выберите одну из опций:
    • Минимум. Автоматический подбор интервала на основе размера самого высокого символа строки. Чем выше символы строки, тем больше интервал до соседних строк. Данная опция используется по умолчанию.
    • Точно. Использование одинакового интервала между всеми строками многострочного текстового объекта, независимо от параметров форматирования отдельных фрагментов, например, шрифта и высоты символов.
  4. Измените межстрочный интервал, введя новое значение для любой из следующих опций. Две опции межстрочного интервала предоставляют различные способы задания параметров:
    • Межстрочный интервал. Установка межстрочного интервала, кратного одинарному интервалу. Одинарный межстрочный интервал равен 1,66 высоты символов.
    • Интервал между линиями. Установка межстрочного интервала по абсолютному значению в единицах чертежа. Абсолютные значения можно задавать в интервале от 0,0833 до 1,3333.
ПримечаниеПосле выхода из палитры свойств другие параметры межстрочных интервалов примут значения, соответствующие введенной пользователем величине.
Панель:Стандартная
Ввод команды: ОКНОСВ


Задание межстрочного интервала многострочного текста (Краткий справочник)

Задание отступов и табуляции в многострочном тексте
Задание межстрочного интервала многострочного текста
Создание дробей в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Задание межстрочного интервала многострочного текста >
Задание межстрочного интервала многострочного текста
Понятие Процедура Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

Системные переменные

TSPACEFAC

Управление отношением межстрочного интервала к высоте многострочного текста

TSPACETYPE

Утилиты

Нет

Ключевые слова для команд

Нет


Создание дробей в многострочном тексте (Понятие)

Задание межстрочного интервала многострочного текста
Создание многострочного текста
Создание и редактирование столбцов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста >
Создание дробей в многострочном тексте
Понятие Процедура Краткий справочник

Символы, обозначающие дроби и допуски, можно отформатировать по различным стандартам.

Текст в виде дроби применяется при форматировании символов внутри многострочных текстовых объектов и мультивыносок для отображения обыкновенных дробей и значений допуска.

Способ преобразования выбранного текста в обыкновенную дробь задается с помощью специальных символов.

  • Косая черта (/): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются друг над другом и разделяются горизонтальной чертой.
  • Решетка (#): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются по диагонали и разделяются косой чертой.
  • При вводе символа крышки (^) создается допуск в виде обыкновенной дроби, числитель и знаменатель которой располагаются по вертикали и не разделены чертой.

Для преобразования символов в обыкновенную дробь вручную в контекстном редакторе выберите текст, который требуется отформатировать, вместе со специальным символом обыкновенной дроби и нажмите кнопку "Дробный" на панели инструментов "Формат текста".

Автоматическое преобразование числовых символов и символов допуска в обыкновенную дробь

Можно задать автоматическое преобразование числовых символов, введенных перед специальным символом (косая черта, решетка, крышка) и после этого символа, в обыкновенную дробь. Например, при вводе текста 1#3, за которым следует нечисловой символ или пробел, по умолчанию отображается диалоговое окно "Автоформат дробного текста", в котором можно задать предпочтительные параметры форматирования.

Функция автоматического преобразования в обыкновенную дробь применяется только к числовым символам, непосредственно предшествующим символу косой черты, решетки или крышки и непосредственно следующим за этим символом. При создании допуска в виде обыкновенной дроби автоматическое преобразование в обыкновенную дробь применяется также к знакам "+", "-" и к десятичному разделителю.

См. также

    • Работа с внешними текстовыми редакторами


Создание дробей в многострочном тексте (Процедура)

Задание межстрочного интервала многострочного текста
На уровень вверх ..
Создание дробей в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание дробей в многострочном тексте >
Создание дробей в многострочном тексте
Понятие Процедура Краткий справочник

Создание дробного текста

Изменение свойств дробного текста

Отключение дробного текста


Создание дробного текста (Процедура)

Создание дробей в многострочном тексте
На уровень вверх ..
Создание дробей в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание дробей в многострочном тексте >
Создание дробей в многострочном тексте
Понятие Процедура Краткий справочник

Создание дробного текста

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.
  3. На вкладке ленты МТЕКСТ или в контекстном текстовом редакторе установите текстовый стиль и другие необходимые свойства многострочного текста.
  4. Введите текст, который необходимо преобразовать в дробный, отделив фрагменты друг от друга одним из следующих символов-разделителей:
    • Косая черта (/): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются друг над другом и разделяются горизонтальной чертой.
    • Решетка (#): создание текста в виде обыкновенной дроби, числитель и знаменатель которой располагаются по диагонали и разделяются косой чертой.
    • Крышка (^): создание дробного текста для пределов, элементы которого располагаются один над другим без разделительной черты.

    Если после цифр, разделенных упомянутыми выше символами, ввести какой-либо нецифровой символ или пробел, автоматически открывается диалоговое окно "Автоформат дробного текста".

  5. В этом окне можно разрешить автоматическое преобразование чисел в дроби, а также включить автоматическое удаление ведущих пробелов. Кроме того, для чисел, разделенных косой чертой, здесь можно выбрать формат дроби (с горизонтальной или косой разделяющей чертой). Если автоформатирование дробного текста не требуется, нажмите кнопку "Отмена".
  6. Выделите текст, который нужно преобразовать в дробный, и нажмите кнопку "Дробный" на панели инструментов.
  7. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Изменение свойств дробного текста (Процедура)

Создание дробей в многострочном тексте
На уровень вверх ..
Создание дробей в многострочном тексте
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание дробей в многострочном тексте >
Создание дробей в многострочном тексте
Понятие Процедура Краткий справочник

Изменение свойств дробного текста

  1. Дважды нажмите кнопку мыши для выделения многострочного текста, который нужно изменить.
  2. На вкладке ленты МТЕКСТ или в контекстном текстовом редакторе выберите дробный текст.
  3. Нажмите правую кнопку мыши в редакторе. Нажмите кнопку "Свойства".
  4. В диалоговом окне "Свойства дробного текста" измените параметры форматирования.
  5. Для задания параметров автоматического форматирования нажмите "Автоформат".
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Отключение дробного текста (Процедура)

Создание дробей в многострочном тексте
На уровень вверх ..
Создание и редактирование столбцов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание дробей в многострочном тексте >
Создание дробей в многострочном тексте
Понятие Процедура Краткий справочник

Отключение дробного текста

  1. Дважды нажмите кнопку мыши на многострочном, который нужно изменить.
  2. На вкладке ленты МТЕКСТ или в контекстном текстовом редакторе выберите дробный текст.
  3. Нажмите кнопку "Дробный" на панели форматирования текста.
  4. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Создание дробей в многострочном тексте (Краткий справочник)

Задание межстрочного интервала многострочного текста
Создание дробей в многострочном тексте
Создание и редактирование столбцов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание многострочного текста > Создание дробей в многострочном тексте >
Создание дробей в многострочном тексте
Понятие Процедура Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

Системные переменные

TSTACKALIGN

Управление выравниванием дробного текста по вертикали

TSTACKSIZE

Управление процентным соотношением дробной высоты многострочного текста и текущей высоты выбранного текста

Утилиты

Нет

Ключевые слова для команд

Нет


Создание и редактирование столбцов многострочного текста (Понятие)

Создание дробей в многострочном тексте
Нанесение текста
Импорт текстовых файлов
Аннотирование чертежей > Примечания и метки > Нанесение текста >
Создание и редактирование столбцов многострочного текста
Понятие Процедура Краткий справочник

Предусмотрена возможность создания и редактирования текста, расположенного в нескольких столбцах, с помощью параметров столбцов в контекстном редакторе и ручек для работы со столбцами.

Группу столбцов можно создавать и изменять либо на вкладке ленты МТЕКСТ, либо в контекстном текстовом редакторе, а также с помощью режима редактирования ручками. Редактирование столбцов с помощью ручек отличается повышенной гибкостью, поскольку изменения отображаются сразу после их внесения.

В отношении столбцов действует несколько правил. Все столбцы имеют одинаковую ширину; все межстолбцовые промежутки также имеют одинаковую ширину. Межстолбцовый промежуток - это незаполненная область между столбцами. Высота столбцов остается постоянной, изменяясь только в случае добавления в столбец большего объема текста, чем он может вместить, или если сам пользователь изменяет ее, перемещая ручку.

Редактирование столбцов в контекстном редакторе

Если работа со столбцами осуществляется на вкладке ленты МТЕКСТ или в контекстном редакторе, столбцы отображаются заключенными в рамку. Если включен режим "Непрозрачный фон", каждый столбец отображается с фоном, а межстолбцовые промежутки - без фона. Если применяется линейка, она пересекает все столбцы, но активна только для того столбца, который выбран в качестве текущего.

Добавление текста к столбцу произвольно заданной высоты не приводит к увеличению высоты столбца, даже в том случае, если текст уже заполняет весь столбец. Текст переносится в другой столбец.

Можно также вставить разрыв столбца, после которого текст принудительно переносится в следующий столбец. При каждой вставке разрыва столбца текущая высота столбца становится постоянной величиной. Для удаления разрыва выделите его и затем удалите; можно также поместить курсор в позицию, непосредственно следующую за разрывом, и нажать клавишу возврата.

Редактирование столбцов на палитре свойств

С помощью палитры свойств можно выбирать режим статических или динамических столбцов, отключать столбцы, а также изменять ширину столбцов и межстолбцовых промежутков. Результаты изменения ширины столбцов на палитре аналогичны результатам изменения с помощью ручек. Только на палитре можно также изменить значение межстолбцового промежутка.


Создание и редактирование столбцов многострочного текста (Процедура)

Создание дробей в многострочном тексте
На уровень вверх ..
Создание и редактирование столбцов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание и редактирование столбцов многострочного текста >
Создание и редактирование столбцов многострочного текста
Понятие Процедура Краткий справочник

Процедура создания нескольких столбцов в контекстном редакторе

Процедура настройки столбцов с помощью ручек


Процедура создания нескольких столбцов в контекстном редакторе (Процедура)

Создание и редактирование столбцов многострочного текста
На уровень вверх ..
Создание и редактирование столбцов многострочного текста
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание и редактирование столбцов многострочного текста >
Создание и редактирование столбцов многострочного текста
Понятие Процедура Краткий справочник

Процедура создания нескольких столбцов в контекстном редакторе

  1. Если лента включена, то для открытия контекстной вкладки ленты МТЕКСТ дважды щелкните на многострочном текстовом объекте. Если лента не включена, отображается контекстный текстовый редактор.
  2. В окне контекстного редактора выберите в списке столбцов вариант работы со столбцами. Предусмотрены следующие варианты: "Динамические столбцы" и "Статические столбцы".

    В случае динамических столбцов можно в свою очередь выбрать один из двух вариантов - "Автоматическое задание высоты" и "Задание высоты вручную". В режиме "Статические столбцы" можно выбрать количество столбцов.

  3. Для настройки высоты столбца переместите стрелки, расположенные в левом нижнем углу первого столбца.
    ПримечаниеСтрелки на верхней стороне линейки (в правой части) не влияют на ширину столбцов; они предназначены только для настройки ширины межстолбцовых промежутков.
Панель:Рисование
Ввод команды: МТЕКСТ


Процедура настройки столбцов с помощью ручек (Процедура)

Создание и редактирование столбцов многострочного текста
На уровень вверх ..
Импорт текстовых файлов
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание и редактирование столбцов многострочного текста >
Создание и редактирование столбцов многострочного текста
Понятие Процедура Краткий справочник

Процедура настройки столбцов с помощью ручек

  1. Выберите область за пределами многострочного текстового объекта. Панель инструментов контекстного редактора исчезает.
  2. Для отображения ручек щелкните один раз в области текста.

    С помощью ручек можно настраивать местоположение многострочного текстового объекта и ширину межстолбцовых промежутков, а также перемещать столбцы по вертикали и по горизонтали.

Панель:Рисование
Ввод команды: МТЕКСТ

На следующем рисунке показана работа с ручками в режиме "Динамические столбцы".

На следующем рисунке показана работа с ручками в режиме "Статические столбцы".

ПримечаниеКак правило, при работе с ручками обновление многострочного текстового объекта выполняется только после отпускания кнопки мыши.


Создание и редактирование столбцов многострочного текста (Краткий справочник)

Создание дробей в многострочном тексте
Создание и редактирование столбцов многострочного текста
Импорт текстовых файлов
Аннотирование чертежей > Примечания и метки > Нанесение текста > Создание и редактирование столбцов многострочного текста >
Создание и редактирование столбцов многострочного текста
Понятие Процедура Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Импорт текстовых файлов (Понятие)

Создание и редактирование столбцов многострочного текста
Нанесение текста
Создание выносок
Аннотирование чертежей > Примечания и метки > Нанесение текста >
Импорт текстовых файлов
Понятие Процедура Краткий справочник

В чертеж можно вставлять текст из файлов форматов TXT и RTF, импортируя сам текст или перетаскивая значок файла из Проводника Windows.

Имеется возможность вставки текста в чертеж из файлов формата TXT и RTF, созданных в текстовых редакторах, путем импорта или перетаскивания значка файла из окна Проводника Windows.

Импорт TXT- и RTF-файлов дает определенную гибкость. Например, в текстовом файле можно хранить стандартные примечания к чертежам. Импортированный текст становится многострочным текстовым объектом, который можно отредактировать и переформатировать. При импорте обычного TXT-файла применяется текущий текстовый стиль. При импорте RTF-файла применяются параметры текущего текстового стиля, однако исходные шрифты и элементы форматирования импортируемого текста сохраняются. Импортируемые файлы ограничены размером 32 Кб и должны иметь расширение .txt или .rtf.

При перетаскивании текстового файла в чертеж ширина текстовой рамки определяется символами конца строки или перехода на новую строку исходного документа. Текст перетаскиваемого RTF-файла вставляется в качестве OLE-объекта.

При вставке текста, созданного в другом приложении, из буфера обмена создается OLE-объект. Если текст импортируется из другого файла с помощью буфера обмена, текст вставляется как вхождение блока с сохранением исходного стиля.

См. также

    • Импорт OLE-объектов


Импорт текстовых файлов (Процедура)

Создание и редактирование столбцов многострочного текста
На уровень вверх ..
Импорт текстовых файлов
Аннотирование чертежей > Примечания и метки > Нанесение текста > Импорт текстовых файлов >
Импорт текстовых файлов
Понятие Процедура Краткий справочник

Импорт текстовых файлов

Вставка текстового файла перетаскиванием


Импорт текстовых файлов (Процедура)

Импорт текстовых файлов
На уровень вверх ..
Импорт текстовых файлов
Аннотирование чертежей > Примечания и метки > Нанесение текста > Импорт текстовых файлов >
Импорт текстовых файлов
Понятие Процедура Краткий справочник

Импорт текстовых файлов

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Задайте рамкой ширину области многострочного текста.
  3. Нажмите правую кнопку мыши в редакторе. Выберите "Импортировать текст".

    Размер импортируемых файлов ограничен 32 Кб.

  4. В диалоговом окне "Выбор файла" дважды щелкните на файле, подлежащем импортированию, или выберите файл. Нажмите "Открыть".

    Текст вставляется в текущей позиции курсора.

  5. Отредактируйте текст, если это необходимо.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.
Панель:Рисование
Ввод команды: МТЕКСТ


Вставка текстового файла перетаскиванием (Процедура)

Импорт текстовых файлов
На уровень вверх ..
Создание выносок
Аннотирование чертежей > Примечания и метки > Нанесение текста > Импорт текстовых файлов >
Импорт текстовых файлов
Понятие Процедура Краткий справочник

Вставка текстового файла перетаскиванием

  1. Откройте Проводник Windows в неполноэкранном режиме.
  2. Перейдите в папку, содержащую требуемый TXT- или RTF-файл.
  3. Перетащите значок текстового файла формата TXT или RTF в чертеж. TXT-файлы вставляются как многострочные текстовые объекты с применением текущего текстового стиля. RTF-файлы вставляются как OLE-объекты.


Импорт текстовых файлов (Краткий справочник)

Создание и редактирование столбцов многострочного текста
Импорт текстовых файлов
Общие сведения об объектах-выносках
Аннотирование чертежей > Примечания и метки > Нанесение текста > Импорт текстовых файлов >
Импорт текстовых файлов
Понятие Процедура Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание выносок

Импорт текстовых файлов
Примечания и метки
Общие сведения об объектах-выносках
Аннотирование чертежей > Примечания и метки >
Создание выносок
Понятие Процедура

Темы в этом разделе

  • Общие сведения об объектах-выносках
  • Создание и изменение выносок

    Как правило, в состав объекта-выноски входят стрелка, горизонтальная полка (не обязательно), линия выноски (прямая или кривая) и многострочный текстовый объект (или блок).

  • Работа со стилями выносок

    Внешний вид выноски определяется соответствующим стилем мультивыносок. Можно применить стиль мультивыносок по умолчанию ("СТАНДАРТ") или создать пользовательские стили мультивыносок.

  • Добавление содержимого к выноске

    Выноски могут содержать многострочный текст или блоки, которые служат метками частей чертежа.


Создание выносок (Процедура)

Импорт текстовых файлов
Создание выносок
Общие сведения об объектах-выносках
Аннотирование чертежей > Примечания и метки > Создание выносок >
Создание выносок
Понятие Процедура

Построение выноски с прямой линией

Построение выноски с прямой линией

Процедура создания сплайновой выноски с текстом или блоком

Редактирование аннотации

Построение нескольких выносок, ведущих к одной аннотации

Процедура удаления выносок из аннотации

Процедура выравнивания мультивыносок и задания интервалов между ними

Процедура группировки нескольких примечаний для прикрепления к одной полке

Процедура создания линии полки с несколькими сегментами

Процедура определения стиля выносок

Процедура применения стиля выносок к существующей выноске


Общие сведения об объектах-выносках (Понятие)

Создание выносок
Создание выносок
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок >
Общие сведения об объектах-выносках
Понятие Процедура Краткий справочник

Объект-выноска представляет собой прямую линию или сплайн со стрелкой на одном конце и многострочным текстовым объектом или блоком - на другом. В некоторых случаях текст или блоки, а также управляющие рамки компонентов соединяются с линией выноски короткой горизонтальной линией, которая называется полкой.

Полка и линия выноски связаны с многострочным текстовым объектом или блоком, поэтому при изменении местоположения полки содержимое и линия выноски перемещаются вместе с ней.

Выноска связывается с любым объектом, к которому прикреплена ее стрелка, если используются ассоциативные размеры и включена объектная привязка для позиционирования стрелок выносок. При перемещении объекта изменяется местоположение стрелки, а полка соответствующим образом растягивается.

ПримечаниеНе следует путать выноски с линиями-выносками, которые автоматически генерируются как части размерных линий.


Построение выноски с прямой линией (Процедура)

Создание выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Общие сведения об объектах-выносках >
Общие сведения об объектах-выносках
Понятие Процедура Краткий справочник

Построение выноски с прямой линией

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Мультивыноска". В командной строке введите мвыноска.
  2. В командной строке введите o для выбора параметров.
  3. Введите "в" для задания параметров выноски.
  4. Введите "т" для задания типа выноски.
  5. Введите "п" для задания прямолинейных выносок.
  6. Щелкните на чертеже в начальной точке стрелки выноски.
  7. Щелкните в конечной точке стрелки выноски.
  8. Введите многострочный текст.
  9. На панели инструментов "Форматирование текста" нажмите "OK".
Панель:Мультивыноска
Ввод команды: МВЫНОСКА


Общие сведения об объектах-выносках (Краткий справочник)

Импорт текстовых файлов
Общие сведения об объектах-выносках
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Общие сведения об объектах-выносках >
Общие сведения об объектах-выносках
Понятие Процедура Краткий справочник

Команды

ВЫНОСКА

Построение линий, соединяющих аннотации с поясняемыми элементами

МВЫНОСКА

Создание объекта-мультивыноски

БВЫНОСКА

Построение простой выноски и аннотации для нее

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

DIMGAP

Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом

DIMLDRBLK

Задание типа стрелки для выносок

MLEADERSCALE

Задание общего масштабного коэффициента для объектов-мультивыносок

Утилиты

Нет

Ключевые слова для команд

Нет


Создание и изменение выносок (Понятие)

Общие сведения об объектах-выносках
Создание выносок
Работа со стилями выносок
Аннотирование чертежей > Примечания и метки > Создание выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Как правило, в состав объекта-выноски входят стрелка, горизонтальная полка (не обязательно), линия выноски (прямая или кривая) и многострочный текстовый объект (или блок).

Пользователь может построить выноску из любой точки или объекта чертежа, управляя ее внешним видом. Выноски могут представлять собой отрезки прямых или гладкие кривые сплайнов.

Создание объекта-мультивыноски ("МВЫНОСКА") можно начать со стрелки, с концевой точки или с содержимого. При наличии стиля мультивыносок можно создать мультивыноску на основе этого стиля.

Объекты-мультивыноски могут содержать несколько линий выноски; таким образом, одно примечание может указывать на несколько объектов на чертеже. С помощью команды "МВЫНОСКАРЕД" можно добавлять выноски к ранее созданному объекту-мультивыноске и удалять из него выноски.

Для аннотативных мультивыносок, содержащих несколько сегментов-выносок, положение стрелок может зависеть от представления с учетом масштаба. Размеры горизонтальных полок и стрелок, а также расстояние от текста до полки зависят от масштабируемого представления. Внешний вид горизонтальной полки мультивыноски, тип линии выноски (прямая или сплайн) и количество сегментов выноски не зависят от масштабируемого представления. Дополнительную информацию см. в разделе Создание аннотативных выносок и мультивыносок

Для изменения внешнего вида мультивыноски можно воспользоваться ручками. С помощью ручек можно уменьшить или увеличить длину полки или линии выноски, а также переместить объект-выноску целиком.

Упорядочение выносок

В целях улучшения структуры и повышения согласованности чертежа предусмотрена возможность упорядочения мультивыносок.

Можно сгруппировать объекты-мультивыноски с блоками в качестве содержимого и прикрепить их к одной линии полки. Команда МВЫНОСКАСОБР позволяет выбрать вариант группировки мультивыносок в соответствии с конкретными задачами черчения: по горизонтали, по вертикали или в пределах указанной области.

Можно равномерно распределить объекты-мультивыноски вдоль указанной линии. Команда МВЫНОСКАВЫР позволяет выровнять выбранные выноски и расположить их с одинаковыми интервалами в соответствии с заданными параметрами.

Демонстрация: выравнивание мультивыносок

Для запуска анимации нажмите стрелку "Просмотр".

Ассоциирование выносок с объектами

При использовании ассоциированных размеров (переменная DIMASSOC) в режиме объектной привязки стрелка выноски связывается с объектом, на который она указывает. При изменении положения объекта стрелка также перемещается вместе с ним, а линия-выноска растягивается так, чтобы многострочный текст пояснительной надписи оставался на своем месте.

См. также
    • Создание аннотативных выносок и мультивыносок


Создание и изменение выносок (Процедура)

Общие сведения об объектах-выносках
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Построение выноски с прямой линией

Процедура создания сплайновой выноски с текстом или блоком

Редактирование аннотации

Построение нескольких выносок, ведущих к одной аннотации

Процедура удаления выносок из аннотации

Процедура выравнивания мультивыносок и задания интервалов между ними

Процедура группировки нескольких примечаний для прикрепления к одной полке

Процедура создания линии полки с несколькими сегментами


Построение выноски с прямой линией (Процедура)

Создание и изменение выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Построение выноски с прямой линией

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Мультивыноска". В командной строке введите мвыноска..
  2. В командной строке введите o для выбора параметров.
  3. Введите "в" для задания параметров выноски.
  4. Введите "т" для задания типа выноски.
  5. Введите "п" для задания прямолинейных выносок.
  6. Щелкните на чертеже в начальной точке стрелки выноски.
  7. Щелкните в конечной точке стрелки выноски.
  8. Введите многострочный текст.
  9. На панели инструментов "Форматирование текста" нажмите "OK".
Панель:Мультивыноска
Ввод команды: МВЫНОСКА


Процедура создания сплайновой выноски с текстом или блоком (Процедура)

Создание и изменение выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Процедура создания сплайновой выноски с текстом или блоком

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Мультивыноска". В командной строке введите мвыноска.
  2. В командной строке введите o для выбора параметров.
  3. Введите "в" для задания параметров выноски.
  4. Введите "т" для задания типа выноски.
  5. Введите "с" для задания выноски в виде сплайна.
  6. Щелкните на чертеже в начальной точке стрелки выноски.
  7. Щелкните в конечной точке выноски.
  8. Введите многострочный текст.
  9. На панели инструментов "Форматирование текста" нажмите "OK".

Панель:Мультивыноска
Ввод команды: МВЫНОСКА


Редактирование аннотации (Процедура)

Создание и изменение выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Редактирование аннотации

  1. Дважды нажмите кнопку мыши на тексте, который надо изменить.

    Если лента включена, отображается вкладка ленты МТЕКСТ. Если лента не включена, то как для однострочного, так и для многострочного текста отображается контекстный редактор. Панель "Форматирование текста" не доступна для однострочного текста.

  2. Отредактируйте текст.
Ввод команды: ДИАЛРЕД


Построение нескольких выносок, ведущих к одной аннотации (Процедура)

Создание и изменение выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Построение нескольких выносок, ведущих к одной аннотации

  1. Выберите мультивыноску.
  2. Перейдите на вкладку "Аннотирование" [image] панель "Мультивыноски" [image] "Добавить выноску". В командной строке введите мвыноскаред.
  3. Укажите конечную точку для новой выноски.
Панель:Мультивыноска
Ввод команды: МВЫНОСКАРЕД


Процедура удаления выносок из аннотации (Процедура)

Создание и изменение выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Процедура удаления выносок из аннотации

  1. Выберите мультивыноску.
  2. На панели инструментов "Мультивыноска" выберите "Удалить выноску".
  3. Выберите одну или несколько выносок, которые требуется удалить. Нажмите ENTER.
Панель:Мультивыноска
Ввод команды: МВЫНОСКАРЕД


Процедура выравнивания мультивыносок и задания интервалов между ними (Процедура)

Создание и изменение выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Процедура выравнивания мультивыносок и задания интервалов между ними

  1. Перейдите на вкладку "Аннотирование" [image] панель "Мультивыноски" [image] "Выравнивание". В командной строке введите мвыноскавыр.
  2. Выберите мультивыноски, которые требуется выровнять. Нажмите ENTER.
  3. Укажите на чертеже начальную точку зоны выравнивания. Выбранная точка определяет положение стрелки полки.
  4. Если требуется изменить интервал между объектами-мультивыносками, введите "и" и укажите один из указанных ниже вариантов задания интервалов.
    • Распределенный. Содержимое распределяется между двумя выбранными точками с равными интервалами.
    • Использовать текущий. Применяется текущее значение интервала между мультивыносками.
    • Сделать параллельными. Содержимое размещается таким образом, что последние сегменты линий в выбранных мультивыносках параллельны между собой.
  5. Щелкните на чертеже в точке, определяющей конец выравнивания.
Панель:Мультивыноска
Ввод команды: МВЫНОСКАВЫР


Процедура группировки нескольких примечаний для прикрепления к одной полке (Процедура)

Создание и изменение выносок
На уровень вверх ..
Создание и изменение выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Процедура группировки нескольких примечаний для прикрепления к одной полке

  1. Перейдите на вкладку "Аннотирование" [image] панель "Мультивыноски" [image] "Группировать". В командной строке введите мвыноскасобр.На панели инструментов "Мультивыноска" выберите "Группировать мультивыноски".
  2. Выберите мультивыноски в том порядке, в котором требуется их сгруппировать. Для последней выбранной мультивыноски сохраняется ее полка. Нажмите ENTER.
Панель:Мультивыноска
Ввод команды: МВЫНОСКАСОБР


Процедура создания линии полки с несколькими сегментами (Процедура)

Создание и изменение выносок
На уровень вверх ..
Работа со стилями выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок >
Создание и изменение выносок
Понятие Процедура Краткий справочник

Процедура создания линии полки с несколькими сегментами

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль мультивыносок". В командной строке введите мвыноскастиль.
  2. В Диспетчер стилей мультивыносок нажмите "Новый" для создания нового стиля мультивыносок.
  3. В диалоговом окне "Создание нового стиля мультивыносок" укажите имя для нового стиля мультивыносок.
  4. В диалоговом окне "Изменение стиля мультивыносок" выберите вкладку "Структура выноски".
  5. В групповом блоке Ограничения установите флажок "Максимум точек выноски". В поле справа укажите максимальное количество точек, на ввод которых будет отображаться запрос при создании новой мультивыноски. Нажмите ОК.
  6. В диспетчере стилей мультивыносок нажмите "Установить как текущее" для применения нового стиля мультивыносок к вновь создаваемым мультивыноскам.
Панель:Мультивыноска
Ввод команды: МВЫНОСКАСТИЛЬ


MLEADERSCALE (Краткий справочник)

Общие сведения об объектах-выносках
Создание и изменение выносок
MLEADERSCALE
Аннотирование чертежей > Примечания и метки > Создание выносок > Создание и изменение выносок > Создание и изменение выносок >
МВЫНОСКАСОБР

Организация выбранных мультивыносок в группу, прикрепленную к отдельной линии выноски

МВЫНОСКАРЕД

Добавление линий выноски к объекту мультивыноски или их удаление

МВЫНОСКАСТИЛЬ

Создание и модификация стилей мультивыносок

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

DIMASZ

Управление величинами стрелок размерных линий и линий выноски

DIMCLRD

Указание цветов размерных линий, стрелок и размерных линий выноски

DIMGAP

Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом

DIMLDRBLK

Задание типа стрелки для выносок

DIMSCALE

Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения

DIMTAD

Управление расположением текста по вертикали относительно размерной линии

MLEADERSCALE

MLEADERSCALE

Утилиты

Нет

Ключевые слова для команд

Нет


Работа со стилями выносок (Понятие)

Создание и изменение выносок
Создание выносок
Добавление содержимого к выноске
Аннотирование чертежей > Примечания и метки > Создание выносок >
Работа со стилями выносок
Понятие Процедура Краткий справочник

Внешний вид выноски определяется соответствующим стилем мультивыносок. Можно применить стиль мультивыносок по умолчанию ("СТАНДАРТ") или создать пользовательские стили мультивыносок.

В стиле мультивыносок может быть задан формат линий выносок, линий полок и стрелок, а также содержимого. Например, стиль мультивыносок "СТАНДАРТ" определяет использование прямой линии выноски с замкнутой заштрихованной стрелкой и многострочного текста в качестве содержимого.

ПримечаниеАннотативные блоки в объектах-мультивыносках могут использоваться в качестве содержимого или стрелок.

После определения стиля мультивыносок можно задать его в качестве текущего стиля мультивыносок; текущий стиль применяется при вызове команды "МВЫНОСКА".


Работа со стилями выносок (Процедура)

Создание и изменение выносок
На уровень вверх ..
Работа со стилями выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Работа со стилями выносок >
Работа со стилями выносок
Понятие Процедура Краткий справочник

Процедура определения стиля выносок

Процедура применения стиля выносок к существующей выноске


Процедура определения стиля выносок (Процедура)

Работа со стилями выносок
На уровень вверх ..
Работа со стилями выносок
Аннотирование чертежей > Примечания и метки > Создание выносок > Работа со стилями выносок >
Работа со стилями выносок
Понятие Процедура Краткий справочник

Процедура определения стиля выносок

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль мультивыносок". В командной строке введите мвыноскастиль.
  2. В Диспетчер стилей мультивыносок нажмите "Новый".
  3. В диалоговом окне "Создание нового стиля мультивыносок" укажите имя для нового стиля мультивыносок.
  4. В диалоговом окне "Редактирование стиля мультивыносок" на вкладке "Формат выноски" выберите значения следующих параметров (или отмените выбор значений).
    • Тип. Определяет тип полки. Можно выбрать прямую полку, полку-сплайн или отсутствие полки.
    • Цвет. Определяет цвет полки.
    • Тип линии. Определяет тип линии для полки.
    • Вес линии. Определяет вес линии для полки.
  5. Укажите обозначение и размер стрелки для мультивыноски.
  6. На вкладке "Структура выноски" выберите значения следующих параметров (или отмените выбор значений).
    • Максимум точек выноски. Определяет максимальное количество точек линии полки для мультивыноски.
    • Углы первого и второго сегментов. Определяет значения углов для первой или второй точек на полке.
    • Полка - Горизонтальное положение. Прикрепление горизонтальной полки к содержимому мультивыноски.
    • Задать величину полки. Определяет постоянную длину линии полки для мультивыноски.
  7. На вкладке "Содержимое" укажите тип содержимого мультивыноски: текст или блок. Если в качестве содержимого объекта-мультивыноски указан текст, выберите значения следующих параметров (или отмените выбор значений).
    • Текст по умолчанию. Определяет текст по умолчанию для содержимого мультивыноски. Здесь можно вставить поле.
    • Текстовый стиль. Заранее определенный текстовый стиль для текста атрибута. Отображаются загруженный на данный момент текстовые стили.
    • Угол строки текста. Определяет угол поворота текста мультивыноски.
    • Цвет текста. Определяет цвет текста мультивыноски.
    • Высота листа. Определяет высоту текста, отображаемого в пространстве листа.
    • Текст в рамке. Заключение текста мультивыноски в рамку.
    • Прикрепление. Определяет способ прикрепления полки к тексту мультивыноски.
    • Отступ от полки. Определяет расстояние между полкой и текстом мультивыноски.

    Если в качестве содержимого указан блок, выберите значения следующих параметров (или отмените выбор значений).

    • Блок-источник. Определяет блок, используемый в качестве содержимого мультивыноски.
    • Прикрепление. Определяет способ прикрепления блока к объекту-мультивыноске. Для прикрепления блока можно указать границы, точку вставки или центральную точку блока.
    • Цвет. Определяет цвет содержимого блока мультивыноски. По умолчанию выбрано значение "ПоБлоку".
  8. Нажмите ОК.
Меню: "Формат" [image] "Стиль мультивыносок"Пункт отсутствует в меню.
Панель:Мультивыноска
Ввод команды: МВЫНОСКАСТИЛЬ


Процедура применения стиля выносок к существующей выноске (Процедура)

Работа со стилями выносок
На уровень вверх ..
Использование полей в тексте
Аннотирование чертежей > Примечания и метки > Создание выносок > Работа со стилями выносок >
Работа со стилями выносок
Понятие Процедура Краткий справочник

Процедура применения стиля выносок к существующей выноске

  1. Выберите мультивыноску, к которой требуется применить новый стиль.
  2. На панели инструментов "Мультивыноска" выберите в ниспадающем списке требуемый стиль мультивыносок.
  3. Для создания нового стиля щелкните на значке "Стиль мультивыносок".
Панель:Мультивыноска
Ввод команды: МВЫНОСКАСТИЛЬ


Работа со стилями выносок (Краткий справочник)

MLEADERSCALE
Работа со стилями выносок
Добавление содержимого к выноске
Аннотирование чертежей > Примечания и метки > Создание выносок > Работа со стилями выносок >
Работа со стилями выносок
Понятие Процедура Краткий справочник

Команды

МВЫНОСКАСТИЛЬ

Системные переменные

CMLEADERSTYLE

Задание имени текущего стиля мультивыноски

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление содержимого к выноске (Понятие)

Работа со стилями выносок
Создание выносок
Использование полей в тексте
Аннотирование чертежей > Примечания и метки > Создание выносок >
Добавление содержимого к выноске
Понятие Краткий справочник

Выноски могут содержать многострочный текст или блоки, которые служат метками частей чертежа.

Выноски, содержащие многострочный текст

Содержимым выноски может служить многострочный текст. При создании стиля выносок можно вставить текст по умолчанию. В аннотациях выносок можно применить и изменить стиль, цвет, высоту и выравнивание текста. Можно также задать смещение многострочного текстового объекта, указав отступ от полки в текущем стиле выносок.

Предусмотрена возможность создания аннотативных мультивыносок с текстом в качестве содержимого. К текстовому содержимому может применяться масштабирование, соответствующее заданному масштабируемому представлению. Значения параметров ширины, выравнивания, прикрепления и поворота для текстового содержимого зависят от представления с учетом масштаба. Фактическое содержимое текста не зависит от масштабируемого представления.

Предусмотрено несколько вариантов размещения многострочного текста в качестве содержимого объекта-выноски.

Верх первой строки

Середина первой строки

Низ первой строки

Подчеркивание первой строки

Середина текста

Середина последней строки
Низ последней строки

Подчеркивание последней строки

Подчеркивание всего текста

Выноски, содержащие блоки

Для задания блока в качестве содержимого мультивыноски можно применить стиль мультивыносок, который содержит ссылку на блок, расположенный на чертеже.

ПримечаниеВ качестве содержимого и стрелок объектов-мультивыносок невозможно использовать аннотативные блоки.

Для соединения блока с мультивыноской можно прикрепить полку к выбранной точке вставки в блоке. Можно также соединить мультивыноску с центральной точкой выбранного блока.

Предусмотрена возможность создания аннотативных мультивыносок с блоками в качестве содержимого. Если содержимое состоит из блоков, к нему применяется масштабирование в соответствии с заданным масштабируемым представлением. При изменении масштабируемого представления все атрибуты блоков, используемых в качестве содержимого, остаются неизменными. Масштабирование неаннотативных мультивыносок может быть выполнено с помощью системной переменной MLEADERSCALE .

См. также
    • Использование полей в тексте


MLEADERSCALE (Краткий справочник)

Работа со стилями выносок
Добавление содержимого к выноске
MLEADERSCALE
Аннотирование чертежей > Примечания и метки > Создание выносок > Добавление содержимого к выноске > Добавление содержимого к выноске >
MLEADERSCALE
Понятие Краткий справочник

Задание общего масштабного коэффициента для объектов-мультивыносок

Отправьте ваши комментарии по поводу этой страницы

26455f5ffa23ce210c4a30acaf-64bd">ОКНОСВ

Управление свойствами объектов

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

КТЕКСТ

Управление отображением и выводом на плоттер текста и атрибутов

ОРФО

Орфографическая проверка надписей в чертеже

СТИЛЬ

Создание, изменение или определение стилей текста

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

DIMGAP

Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом

FONTALT

Задание альтернативного шрифта, используемого в случае, если не найден указанный шрифт

FONTMAP

Задание файла, описывающего подстановку шрифтов

MLEADERSCALE

MLEADERSCALE

MTEXTED

Задание приложения для редактирования многострочных текстовых объектов

QTEXTMODE

Управление отображением текста

TEXTFILL
TEXTQLTY

Утилиты

Нет

Ключевые слова для команд

Нет


Использование полей в тексте

Добавление содержимого к выноске
Примечания и метки
Вставка полей
Аннотирование чертежей > Примечания и метки >
Использование полей в тексте
Понятие Процедура

Поле представляет собой обновляемый текст, предназначенный для отображения данных, которые могут поменяться в ходе редактирования чертежа. При обновлении поля отображается его последнее значение.

Темы в этом разделе

  • Вставка полей

    Поле представляет собой текст, содержащий правила отображения данных, которые могут поменяться в ходе редактирования чертежа.

  • Обновление полей

    При обновлении поля отображается его последнее значение. Пользователь может обновить поля по одному или обновить все поля в одном или нескольких выбранных текстовых объектах.

  • Использование гиперссылок в полях

    В тексте можно использовать поля гиперссылок.


Использование полей в тексте (Процедура)

Работа со стилями выносок
Использование полей в тексте
Вставка полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте >
Использование полей в тексте
Понятие Процедура

Вставка поля в текст

Вставка поля в таблицу

Использование поля для отображения свойства объекта

Вставка поля заменителя подшивки

Форматирование значения поля

Редактирование поля

Ручное обновление поля

Обновление вручную нескольких полей

Автоматическое обновление полей

Добавление в текст поля гиперссылки


Вставка полей (Понятие)

Использование полей в тексте
Использование полей в тексте
Обновление полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте >
Вставка полей
Понятие Процедура Краткий справочник

Поле представляет собой текст, содержащий правила отображения данных, которые могут поменяться в ходе редактирования чертежа.

При обновлении поля отображаются самые новые данные. Например, значением поля "ИмяФайла" является имя файла. Если имя файла изменяется, то при обновлении данного поля отобразится новое имя файла.

Поля могут быть вставлены в текст любого типа (за исключением допусков), включая текст в ячейках таблицы, в атрибутах и описаниях атрибутов. В ходе выполнения любой текстовой команды в контекстном меню появляется опция "Вставить поле".

Некоторые поля подшивок могут быть вставлены как заменители. Например, пользователь может вставить поле "НомерИНазваниеЛиста" в качестве заменителя. Позднее, после добавления листа в подшивку, поле заменителя будет отображать правильный номер и название листа.

Поля местозаменителя блока можно использовать в описаниях атрибутов блока во время работы в Редактор блоков .

Поле, для которого нет значений, будет отображать черточки (---). Например, поле "Автор", устанавливаемое в диалоговом окне "Свойства чертежа", может быть оставлено пустым. Неверное поле будет отображать знаки решеток (####). Например, поле "НазваниеТекущегоЛиста", допустимое только для пространства листа, будет отображать знаки решетки, если его расположить в пространстве модели.

Изменение внешнего вида поля

Текст поля использует тот же текстовый стиль, что и текстовый объект, в который он вставлен. По умолчанию поля отображают информацию на светло-сером фоне, который не выводится на печать (системная переменная FIELDDISPLAY).

Настройки форматирования в диалоговом окне "Поле" позволяют контролировать вид отображаемого текста. Набор настроек зависит от типа поля. Например, формат полей дат включает опции по отображению дня недели и времени, а формат полей именованных объектов включает опции выделения заглавными буквами.

Редактирование поля

Поле является частью тестового объекта и не может редактироваться в текстовом редакторе. Самый простой способ редактирования поля состоит в следующем. Нужно дважды нажать кнопку мыши на текстовом объекте, содержащем поле, затем, для отображения диалогового окна "Поле", нужно дважды нажать кнопку мыши на поле. Эти операции можно выполнять также в контекстных меню.

Если необходимо, чтобы поле больше не обновлялось, то пользователь может сохранить значение, которое отображается в настоящий момент, преобразовав поле в текст.

Выражение поля, содержащее знаки переключения кода и код поля, показывается в диалоговом окне "Поле", но не может быть изменено.


Вставка полей (Процедура)

Использование полей в тексте
На уровень вверх ..
Вставка полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Вставка поля в текст

Вставка поля в таблицу

Использование поля для отображения свойства объекта

Вставка поля заменителя подшивки

Форматирование значения поля

Редактирование поля


Вставка поля в текст (Процедура)

Вставка полей
На уровень вверх ..
Вставка полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Вставка поля в текст

  1. Укажите текст, дважды нажав кнопку мыши для отображения соответствующего диалогового окна редактирования текста.
  2. Поместите курсор в то место, где должен располагаться текст поля, и нажмите правую кнопку мыши. Выберите "Вставить поле".

    Для вызова этой команды с клавиатуры используйте сочетание клавиш CTRL+ F.

  3. В диалоговом окне "Поле" в группе "Категории полей" выберите "Все" или категорию поля.

    Поля в выбранной категории будут отображены в списке "Имена полей".

  4. В списке "Имена полей" выберите поле.

    Текущее значение большинства полей будет отображено в затененной текстовой области справа от группы "Категории полей". Текущее значение поля даты отображается в списке "Варианты".

  5. Выберите формат и задать остальные настройки.

    Например, когда выбрано поле "ИменованныйОбъект", пользователь задает тип (например, слой или текстовые стили) и имя (например "0" для слоя или "STANDARD" для текстового стиля).

    В поле "Формула для поля" задается выражение, лежащее в основе поля. Формулу для поля нельзя изменить. Она только дает представление о том, как сформированы поля.

  6. Нажмите "ОК" для вставки поля.

    Поле отобразит свое текущее значение в тексте после выходе из диалогового окна "Поле".


Вставка поля в таблицу (Процедура)

Вставка полей
На уровень вверх ..
Вставка полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Вставка поля в таблицу

  1. Дважды нажмите кнопку мыши на выбранной ячейке таблицы для редактирования.
  2. Поместите курсор в то место, где должен располагаться текст поля, и нажмите правую кнопку мыши. Выберите "Вставить поле".
  3. В диалоговом окне "Поле" выберите опцию "Все" или выделить категорию.
  4. В списке "Имена полей" выберите поле.

    Текущее значение поля будет отображено в затененной текстовой области справа от группы "Категории полей".

  5. Выберите формат и любую другую опцию.
  6. Нажмите "ОК" для вставки поля.

    Поле отобразит свое текущее значение при переходе к следующей ячейке.


Использование поля для отображения свойства объекта (Процедура)

Вставка полей
На уровень вверх ..
Вставка полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Использование поля для отображения свойства объекта

  1. Дважды нажмите кнопку мыши на тексте для вызова соответствующего диалогового окна редактирования текста.
  2. Поместите курсор в то место, где должен располагаться текст поля, и нажмите правую кнопку мыши. Выберите "Вставить поле".
  3. В диалоговом окне "Поле" в группе "Категории полей" выберите "Все".
  4. В списке "Имена полей" выберите "Объект".
  5. В группе "Тип объекта" нажмите кнопку "Выберите объект" и выберите объект на чертеже.
  6. В диалоговом окне "Поле" в группе "Свойства" выберите свойство, значение которого необходимо отобразить в тексте.

    Например, поле может отображать радиус выбранного круга.

  7. Выберите формат текста.
  8. Нажмите "ОК".

    В тексте отобразится текущее значение свойства данного объекта.


Вставка поля заменителя подшивки (Процедура)

Вставка полей
На уровень вверх ..
Вставка полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Вставка поля заменителя подшивки

  1. Выберите пункт меню "Рисование" [image] "Блок" [image] "Задание атрибутов".В командной строке введите "атопр".
  2. В диалоговом окне "Определение атрибута", в группе "Режим" выберите "Стандартный". Задайте параметры текста.
  3. В поле "Имя" в группе "Атрибут" введите имя поля.
  4. Нажмите кнопку "Вставить поле", расположенную справа от поля "Значение".
  5. В диалоговом окне "Поле" в группе "Категории полей" выберите "Подшивка".
  6. В списке "Имена полей" выберите "ПодшЗаменитель".
  7. В группе "Тип заменителя" выберите необходимый тип поля.

    В блоке "Временное значение" будет показано поле заменителя.

  8. В группе "Формат" для поля-заменителя выберите стиль "Верхний регистр".

    При обновлении поля этот же стиль будет использоваться для значения поля.

  9. (Не обязательно) Установите флажок "С гиперссылками", если необходимо, чтобы поле служило гиперссылкой.
    ПримечаниеОпция "С гиперссылками" недоступна для поля "МасштабВЭкрана".
  10. Нажмите "OK", чтобы выйти из диалогового окна "Поле".

    Поле заменителя отображает свое имя после закрытия диалогового окна "Поле", например "НомерЛиста". Когда блок будет вставлен из контекстного меню вкладки "Список видов" в Диспетчере подшивок, поле отобразит значение, связанное с листом, в который оно было вставлено, например номер этого листа.

  11. Нажмите "OK" в диалоговом окне "Определение атрибута". Определите место около созданного объекта для вставки текста поля, которое будет использоваться Диспетчером подшивок как блок-идентификатор или блок метки.
  12. Создайте блок, в который наряду с геометрией для блока входит новый атрибут.


Форматирование значения поля (Процедура)

Вставка полей
На уровень вверх ..
Вставка полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Форматирование значения поля

  1. Дважды нажмите кнопку мыши на тексте для вызова соответствующего диалогового окна редактирования текста.
  2. Дважды нажмите на поле, которое необходимо отформатировать.

    Открывается диалоговое окно "Поле". Если форматирование этого поля возможно, отображается кнопка "Формат поля".

  3. Нажмите "Формат поля".

    В диалоговом окне "Дополнительные параметры формата" отображается текущее значение поля. Когда параметр выбран, результат отображается в области "Предварительный просмотр".

  4. Введите коэффициент преобразования, который необходимо использовать для текущего значения.

    Например, для преобразования дюймов в миллиметры введите 0.03937.

  5. Введите текст, который необходимо поместить до или после значения, указанного в поле.

    Например, введите мм для миллиметров.

  6. Выберите десятичный разделитель. Выберите "Ничего" или "Запятая" для тысяч.
  7. Выберите параметр для подавления нулей.
    • Ведущие: подавление ведущих нулей в десятичных значениях. Например, 0,5000 записывается как ,5000.
    • Замыкающие: подавление замыкающих нулей в десятичных значениях. Например, 12,5000 представляется как 12,5, а 30,0000 - как 30.
    • 0 футов: подавление вывода значения футов в поле формата футы-дюймы, если расстояние меньше одного фута. Например, 0'-6 1/2" представляется как 6 1/2".
    • 0 дюймов: подавление вывода значения дюймов в поле формата футы-дюймы, если расстояние равно целому числу футов. Например, 1'-0" представляется как 1'.
  8. Нажмите "ОК".

    В диалоговом окне "Поле" значение поля отображается в области "Предварительный просмотр" в формате, определенном пользователем.

  9. Нажмите "ОК".


Редактирование поля (Процедура)

Вставка полей
На уровень вверх ..
Обновление полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Редактирование поля

  1. Дважды нажмите кнопку мыши на тексте для вызова соответствующего диалогового окна редактирования текста.
  2. Дважды нажмите кнопку мыши на поле, которое нужно отредактировать.

    Открывается диалоговое окно "Поле".

  3. Внести необходимые изменения.
  4. Нажмите "OK", чтобы выйти из диалогового окна "Поле".
  5. Выйдите из текстового редактора.


Вставка полей (Краткий справочник)

MLEADERSCALE
Вставка полей
Обновление полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Вставка полей >
Вставка полей
Понятие Процедура Краткий справочник

Команды

ПОЛЕ

Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения

НАЙТИ

Поиск, замена , выбор и показ текста на чертеже

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

СПИСОК

Отображение свойств для выбранных объектов

МТЕКСТ

Создание многострочного текстового объекта

ОРФО

Орфографическая проверка надписей в чертеже

ТАБЛИЦА

Создание пустого объекта-таблицы

ЭКСПОРТТАБЛ

Экспорт данных таблицы в файл формата CSV

ТАБЛСТИЛЬ

Создание, изменение или определение стилей таблиц

ОБНПОЛЕ

Обновление полей в выбранных объектах чертежа вручную

Системные переменные

CTABLESTYLE

Задание имени текущего стиля таблицы

FIELDDISPLAY

Управление отображением полей на сером фоне

FIELDEVAL

Управление обновлением полей

Утилиты

Нет

Ключевые слова для команд

Нет


Обновление полей (Понятие)

Вставка полей
Использование полей в тексте
Использование гиперссылок в полях
Аннотирование чертежей > Примечания и метки > Использование полей в тексте >
Обновление полей
Понятие Процедура Краткий справочник

При обновлении поля отображается его последнее значение. Пользователь может обновить поля по одному или обновить все поля в одном или нескольких выбранных текстовых объектах.

Кроме того, можно установить автоматическое обновление полей при открытии, сохранении, печати, регенерации или отправке чертежа с помощью команды ФОРМКОМПЛЕКТ.

Настройки в Вкладка "Пользовательские" (диалоговое окно "Настройка") определяют режим обновления полей: автоматический или по запросу (системная переменная FIELDEVAL). Поле "Дата", вне зависимости от значения переменной FIELDEVAL, автоматически не обновляется.

ПримечаниеПри присвоении системной переменной DEMANDLOAD значения 2, невозможно будет обновить поля до тех пор, пока не будут использованы команды ПОЛЕ или ОБНПОЛЕ.

Контекстно-зависимые поля в блоках и внешних ссылках

Некоторые поля являются контекстно-зависимыми; т.е. их значение зависит от пространства или вкладки-листа, на котором они расположены. Например, поскольку каждая разметка листа может иметь различные параметры листа, то значение, отображаемое полем "ОриентацияЛиста", может различаться на различных разметках листа одного и того же чертежа.

Список контекстно-зависимых полей
ТекЛистПольз | НазваниеТекущегоЛиста
ОписаниеТекЛист | ИмяУстройства
НомерТекущегоЛиста | ФорматЛиста
НомерИНазваниеЛиста | ДатаВывода
ТекущаяПодшивка | ОриентацияЛиста
ТекПодшПольз | МасштабПечати
ОписаниеТекПодш | ИмяНабораПараметров
ТекущаяГруппаЛистов | ТаблицаСтилейПечати

Для совместимости с предыдущими версиями контекстно-зависимые поля в блоках и внешних ссылках не обновляются при вставке их в чертеж; вместо этого поля отображают последнее кэшированное значение. Поэтому, если необходимо использовать контекстно-зависимое поле внутри блока, например блока основной надписи, то надо вставить поле как атрибут. Например, блок основной надписи может использовать поле "НомерТекущегоЛиста" как атрибут. Тогда при вставке основной надписи в чертеж поле отобразит номер листа, на который была произведена вставка.

Большинство полей не являются контекстно-зависимыми и обновляются в блоках и внешних ссылках. Поля во внешних ссылках обновляются на основе файла, в который они вставлены, а не исходного файла. Эти поля не следует использовать в атрибутах. Например, поле, отображающее номер конкретного листа в подшивке и обновляющееся при изменении данного номера, является свойством подшивки. При создании поля пользователь выделяет имя поля "Подшивка", выбирает подшивку и лист в области структуры, а затем выбирает свойство "НомерЛиста" в качестве значения поля. Это поле будет отображать номер данного листа, даже если данное поле поместить в блок и вставить в другой чертеж. Если лист удалить из подшивки, то он уже не будет иметь номер, а поле станет недействительным и будет отображать знаки решетки.

Некоторые поля подшивок могут быть вставлены как заменители. Например, при создании собственных блоков-идентификаторов и блоков-меток, можно вставить поле "НомерЛиста" в качестве заменителя. Позже, когда блок будет вставлен из контекстного меню вкладки "Список видов" в Диспетчере подшивок, поле отобразит номер листа чертежа.

Совместимость с прежними версиями

При открытии чертежа с полями в AutoCAD 2004 или более ранней версии поля не обновляются; в них отображаются те значения, которые отображались последними до открытия чертежа. Если поля не были изменены, то они обновляются как обычно при открытии чертежа в системе, поддерживающей поля.

В предыдущих версиях AutoCAD LT поля отсутствуют. При открывании чертежа с полями в более ранних версиях приложения AutoCAD LT поля вычисляются на основе установленной для чертежа системной переменной FIELDEVAL, но эта системная переменная недоступна.

См. также

    • Работа с чертежами AutoCAD в AutoCAD LT


Обновление полей (Процедура)

Вставка полей
На уровень вверх ..
Обновление полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Обновление полей >
Обновление полей
Понятие Процедура Краткий справочник

Ручное обновление поля

Обновление вручную нескольких полей

Автоматическое обновление полей


Ручное обновление поля (Процедура)

Обновление полей
На уровень вверх ..
Обновление полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Обновление полей >
Обновление полей
Понятие Процедура Краткий справочник

Ручное обновление поля

  1. Дважды нажмите кнопку мыши на тексте.
  2. Выберите поле, которое необходимо обновить, и нажмите правую кнопку мыши. Выберите "Обновить поле".


Обновление вручную нескольких полей (Процедура)

Обновление полей
На уровень вверх ..
Обновление полей
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Обновление полей >
Обновление полей
Понятие Процедура Краткий справочник

Обновление вручную нескольких полей

  1. Перейдите на вкладку "Блоки и ссылки" [image] панель "Данные" [image] "Обновить поля". В командной строке введите обнполе.
  2. В ответ на подсказку "Выберите объекты" выберите объекты, содержащие поля, которые требуется обновить, и нажмите ENTER.

    Все поля в выделенных объектах обновятся.


Автоматическое обновление полей (Процедура)

Обновление полей
На уровень вверх ..
Использование гиперссылок в полях
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Обновление полей >
Обновление полей
Понятие Процедура Краткий справочник

Автоматическое обновление полей

  1. В командной строке введите fieldeval.
  2. Введите код, являющийся суммой любых из следующих значений:
    • 0: не обновляются
    • 1: обновляются при открытии
    • 2: обновляются при сохранении
    • 4: обновляются при печати
    • 8: обновляются при вызове команды ФОРМКОМПЛЕКТ
    • 16: обновляются при регенерации

    Например, для обновления полей только при открытии, сохранении или печати файла необходимо ввести 7.


Обновление полей (Краткий справочник)

Вставка полей
Обновление полей
Использование гиперссылок в полях
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Обновление полей >
Обновление полей
Понятие Процедура Краткий справочник

Команды

ПОЛЕ

Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения

ОБНПОЛЕ

Обновление полей в выбранных объектах чертежа вручную

Системные переменные

FIELDDISPLAY

Управление отображением полей на сером фоне

FIELDEVAL

Управление обновлением полей

Утилиты

Нет

Ключевые слова для команд

Нет


Использование гиперссылок в полях (Понятие)

Обновление полей
Использование полей в тексте
Работа с текстовыми стилями
Аннотирование чертежей > Примечания и метки > Использование полей в тексте >
Использование гиперссылок в полях
Понятие Процедура Краткий справочник

В тексте можно использовать поля гиперссылок.

Текстовые гиперссылки работают таким же образом, что и гиперссылки, связанные с объектами. При наведении курсора на текст отображается курсор гиперссылки, а также соответствующая подсказка. Для перехода по гиперссылке надо, нажав клавишу CTRL, указать гиперссылку.

ПримечаниеПоле гиперссылки использует абсолютный путь к файлу; команда ГИПЕРССЫЛКА может создать гиперссылку с относительным путем.

Полям, указывающим на названия и номера листов и видов, при создании могут быть назначены гиперссылки. При изменении этих элементов или перемещении в Диспетчере подшивок, гиперссылки, связанные с ними, также изменяются, указывая на новое положение.

При публикации в формат многолистового DWF-файла гиперссылки в полях преобразуются из связей с DWG-файлами в связи с DWF-файлами.


Добавление в текст поля гиперссылки (Процедура)

Обновление полей
На уровень вверх ..
Работа с текстовыми стилями
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Использование гиперссылок в полях >
Использование гиперссылок в полях
Понятие Процедура Краткий справочник

Добавление в текст поля гиперссылки

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  2. Расположите курсор в месте, где должен отображаться текст с гиперссылкой.
  3. Нажмите правую кнопку мыши в редакторе. Выберите "Вставить поле".
  4. В диалоговом окне "Поле" в группе "Категории полей" выберите "Связи".
  5. В группе "Имена полей" выберите "Гиперссылка" и укажите гиперссылку.
  6. В диалоговом окне "Вставка гиперссылки" для задания расположения можно использовать один из следующих способов:
    • В поле "Ввод имени файла или Web-страницы" ввести имя файла (вместе с путем), на который должен производиться переход.
    • В группе "Что искать:" нажать на кнопки "Файл", "Web-страница" или "Позиция". Перейдите к папке, которую необходимо связать. Нажмите "Открыть" или OK.
  7. (Не обязательно) В поле "Отображаемый текст" выделить текст, предлагаемый по умолчанию, и ввести текст ссылки, который должен отображаться в многострочном текстовом объекте.
  8. Нажать "OK" для закрытия каждого диалогового окна.
  9. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.

    Гиперссылка будет отображаться в многострочном текстовом объекте вместе с текстом, который был введен пользователем. Для перехода по гиперссылке указать ее, удерживая нажатой клавишу CTRL.

Панель:Рисование
Ввод команды: МТЕКСТ


Использование гиперссылок в полях (Краткий справочник)

Обновление полей
Использование гиперссылок в полях
Коротко о текстовых стилях
Аннотирование чертежей > Примечания и метки > Использование полей в тексте > Использование гиперссылок в полях >
Использование гиперссылок в полях
Понятие Процедура Краткий справочник

Команды

ПОЛЕ

Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения

НАЙТИ

Поиск, замена , выбор и показ текста на чертеже

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

СПИСОК

Отображение свойств для выбранных объектов

МТЕКСТ

Создание многострочного текстового объекта

ОРФО

Орфографическая проверка надписей в чертеже

ТАБЛИЦА

Создание пустого объекта-таблицы

ЭКСПОРТТАБЛ

Экспорт данных таблицы в файл формата CSV

ТАБЛСТИЛЬ

Создание, изменение или определение стилей таблиц

ОБНПОЛЕ

Обновление полей в выбранных объектах чертежа вручную

Системные переменные

CTABLESTYLE

Задание имени текущего стиля таблицы

FIELDDISPLAY

Управление отображением полей на сером фоне

FIELDEVAL

Управление обновлением полей

Утилиты

Нет записей

Ключевые слова для команд

Нет


Работа с текстовыми стилями

Использование гиперссылок в полях
Примечания и метки
Коротко о текстовых стилях
Аннотирование чертежей > Примечания и метки >
Работа с текстовыми стилями
Понятие Процедура

При выполнении надписей на чертеже применяется текущий текстовый стиль, который определяет шрифт, высоту и угол наклона символов, ориентацию надписи, а также другие параметры текста.

Темы в этом разделе

  • Коротко о текстовых стилях
  • Назначение шрифтов

    При создании описания текстового стиля пользователь задает для него шрифт. При этом выбор того или иного шрифта зависит от типа вводимого текста.

  • Задание высоты символов

    Высота символов задается в единицах чертежа.

  • Задание угла наклона символов
  • Задание горизонтальной или вертикальной ориентации текста

    Выполняемые надписи могут быть ориентированы как горизонтально, так и вертикально. Но вертикальную ориентацию можно использовать только для шрифтов, поддерживающих оба типа ориентации.


Работа с текстовыми стилями (Процедура)

Использование гиперссылок в полях
Работа с текстовыми стилями
Коротко о текстовых стилях
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями >
Работа с текстовыми стилями
Понятие Процедура

Установка текущего текстового стиля

Задание высоты в текстовом стиле

Задание угла наклона символов в текстовом стиле

Задание вертикальной ориентации текстового стиля


Коротко о текстовых стилях (Понятие)

Работа с текстовыми стилями
Работа с текстовыми стилями
Назначение шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями >
Коротко о текстовых стилях
Понятие Процедура Краткий справочник

У каждого фрагмента текста на чертеже свой текстовый стиль. При вводе текста применяется текущий текстовый стиль, который определяет шрифт, размер и угол наклона символов, ориентацию, а также другие параметры текста. При необходимости выполнить надпись определенным текстовым стилем его следует сделать текущим. Ниже приведен пример таблицы со значениями параметров текстового стиля СТАНДАРТ.

Параметры текстового стиля
Параметр | По умолчанию | Описание
Имя стиля | СТАНДАРТ | Имя может содержать до 255 символов
Имя шрифта | txt.shx | Имя файла шрифта, задающего начертание литер
Большой шрифт | Нет | Имя файла, используемого для задания наборов символов, не входящих в формат ASCII (японский алфавит и т.п.)
Высота | 0 | Высота символов
Коэффициент сжатия | 1 | Коэффициент растяжения или сжатия символов
Угол наклона | 0 | Величина наклона символов
Справа налево | Нет | Написание текста справа налево
Перевернутый | Нет | Написание текста в перевернутом виде
Вертикальный | Нет | Вертикальное или горизонтальное расположение текста

Настройки для текущего текстового стиля отображаются в командных строках. Имеется возможность использования и редактирования текущего текстового стиля, а также создания или загрузки нового. Созданный стиль может быть впоследствии модифицирован, переименован или удален.

Создание и редактирование текстовых стилей

Все текстовые стили, кроме заранее определенного стиля СТАНДАРТ, пользователю необходимо создавать самому.

Имя текстового стиля может иметь длину до 255 символов. В именах можно использовать буквы и цифры, а также некоторые специальные символы: знак доллара ($), подчеркивание (_) и дефис (-). Если пользователь не присваивает имена стилям, то им автоматически присваиваются имена "Стильn", где n - любое целое число, начиная с 1.

Имеется возможность изменять параметры существующих текстовых стилей с помощью диалогового окна "Текстовые стили". Можно также выполнять обновление существующего текста для измененного текстового стиля.

Влияние некоторых параметров стиля на многострочный и однострочный тексты различно. Например, параметры "Перевернутый" и "Справа налево" не оказывают никакого действия на многострочные текстовые объекты. А параметры "Коэффициент сжатия" и "Угол наклона", наоборот, бесполезны для однострочного текста.

После переименования существующего текстового стиля во всех текстовых объектах, использующих его, имя стиля обновляется.

Неиспользуемые текстовые стили можно удалять командой ОЧИСТИТЬ или удалением их имен из списка в диалоговом окне "Текстовые стили". Текстовый стиль СТАНДАРТ удалить нельзя.

Изменение текстового стиля

Изменение параметров текстового стиля для многострочного текстового объекта приводит к обновлению всего объекта. При этом некоторые ранее заданные элементы форматирования отдельных фрагментов текста могут быть потеряны. В следующей таблице приводятся элементы форматирования текстовых фрагментов и указана возможность их сохранения при обновлении объекта после изменения текстового стиля.

Элемент форматирования | Сохраняется?
Полужирный | Нет
Цвет | Да
Шрифт | Нет
Высота | Нет
Курсив | Нет
Дроби | Да
Подчеркивание | Да

Стили аннотативного текста

аннотативный текст служит для создания примечаний и меток на чертеже. Аннотативный текст создается на основе аннотативного стиля текста, который определяет высоту текста на листе бумаги.

Более подробную информацию о создании аннотативного текста и о работе с ним см. в разделе Создание аннотативного текста.

См. также

    • Масштабирование аннотаций


Установка текущего текстового стиля (Процедура)

Работа с текстовыми стилями
На уровень вверх ..
Назначение шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Коротко о текстовых стилях >
Коротко о текстовых стилях
Понятие Процедура Краткий справочник

Установка текущего текстового стиля

  • Выберите стиль из выпадающего списка на панели инструментов "Стили".
Ввод команды: СТИЛЬ


Коротко о текстовых стилях (Краткий справочник)

Использование гиперссылок в полях
Коротко о текстовых стилях
Коротко о назначении шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Коротко о текстовых стилях >
Коротко о текстовых стилях
Понятие Процедура Краткий справочник

Команды

ОЧИСТИТЬ

Очистка чертежа от неиспользуемых именованных элементов (определений блоков, слоев и т. п.)

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

FONTALT

Задание альтернативного шрифта, используемого в случае, если не найден указанный шрифт

FONTMAP

Задание файла, описывающего подстановку шрифтов

TEXTSIZE

Значение высоты по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля

TEXTSTYLE

Имя текущего текстового стиля

Утилиты

Нет

Ключевые слова для команд

Нет


Назначение шрифтов

Коротко о текстовых стилях
Работа с текстовыми стилями
Коротко о назначении шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями >
Назначение шрифтов
Понятие Процедура

При создании описания текстового стиля пользователь задает для него шрифт. При этом выбор того или иного шрифта зависит от типа вводимого текста.

Темы в этом разделе

  • Коротко о назначении шрифтов
  • Использование шрифтов TrueType

    Результат отображения шрифтов TrueType на чертеже зависит от различных факторов.

  • Использование шрифтов текста для работ в рамках международного сотрудничества

    Некоторые факторы влияют на выбор, ввод и представление на чертеже текста на разных языках.

  • Подстановка шрифтов

    Если используемый на чертеже шрифт недоступен, он автоматически подменяется другим шрифтом.


Назначение шрифтов (Процедура)

Коротко о текстовых стилях
На уровень вверх ..
Использование шрифтов TrueType
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов >
Назначение шрифтов
Понятие Процедура

Назначение шрифта текстовому стилю

Назначение SHX-шрифта азиатского языка текстовому стилю

Определение файла соответствия шрифтов

Задание альтернативного шрифта по умолчанию


Коротко о назначении шрифтов (Понятие)

Назначение шрифтов
Назначение шрифтов
Использование шрифтов TrueType
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов >
Коротко о назначении шрифтов
Понятие Краткий справочник

Шрифты определяют внешний вид всех символов, входящих в символьный набор. Возможно использование как собственных SHX-шрифтов, так и шрифтов TrueType.

Один и тот же шрифт может использоваться в нескольких текстовых стилях. Если стандарты (государственные, отраслевые и т.д.) требуют выполнения надписей только определенным шрифтом, можно создать набор стилей, базирующихся на нужном шрифте. На следующей иллюстрации показано использование одного шрифта в нескольких стилях, которые отличаются друг от друга углом наклона символов.

Назначение шрифта текстовому стилю выполняется путем выбора файла шрифта из списка диалогового окна "Текстовые стили".


Коротко о назначении шрифтов (Краткий справочник)

Коротко о текстовых стилях
Коротко о назначении шрифтов
Использование шрифтов TrueType
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Коротко о назначении шрифтов >
Коротко о назначении шрифтов
Понятие Краткий справочник

Команды

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

FONTALT

Задание альтернативного шрифта, используемого в случае, если не найден указанный шрифт

FONTMAP

Задание файла, описывающего подстановку шрифтов

Утилиты

Нет

Ключевые слова для команд

Нет


Использование шрифтов TrueType (Понятие)

Коротко о назначении шрифтов
Назначение шрифтов
Использование шрифтов текста для работ в рамках международного сотрудничества
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов >
Использование шрифтов TrueType
Понятие Процедура Краткий справочник

Результат отображения шрифтов TrueType на чертеже зависит от различных факторов.

Символы надписей, выполненные шрифтами TrueType, на чертеже всегда выглядят заполненными; однако при вычерчивании на плоттере их внешний вид определяется состоянием системной переменной TEXTFILL. По умолчанию TEXTFILL равна 1; это значит, что символы выводятся на печать заполненными.

Контекстный редактор способен отображать только шрифты, распознаваемые Microsoft Windows. Так как SHX-шрифты не распознаются системой Windows, в контекстном редакторе при выборе SHX-шрифта или любого другого шрифта, отличного от TrueType, применяется шрифт, эквивалентный TrueType.

См. также

    • Задание высоты символов


Назначение шрифта текстовому стилю (Процедура)

Назначение шрифтов
На уровень вверх ..
Использование шрифтов текста для работ в рамках международного сотрудничества
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Использование шрифтов TrueType >
Использование шрифтов TrueType
Понятие Процедура Краткий справочник

Назначение шрифта текстовому стилю

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль текста". В командной строке введите "стиль".
  2. В группе "Имя стиля" диалогового окна "Текстовые стили" нажмите кнопку "Создать".
  3. В диалоговом окне "Новый текстовый стиль" введите имя нового текстового стиля. Нажмите "ОК".
  4. В группе "Шрифт" выберите из списка один из TrueType-шрифтов. Слева от названий TrueType-шрифтов отображаются значки в виде буквы "Т".
  5. Чтобы увидеть результат применения эффектов к различным символам, можно ввести текст в текстовое поле группы "Образец", расположенное слева от кнопки "Просмотр". Нажмите кнопку "Просмотр".
  6. Чтобы обновить текст на чертеже, нажмите кнопку "Применить".
  7. Нажмите кнопку "Закрыть".
Панель:Стили
Ввод команды: СТИЛЬ


Использование шрифтов TrueType (Краткий справочник)

Коротко о назначении шрифтов
Использование шрифтов TrueType
Использование шрифтов текста для работ в рамках международного сотрудничества
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Использование шрифтов TrueType >
Использование шрифтов TrueType
Понятие Процедура Краткий справочник

Команды

КТЕКСТ

Управление отображением и выводом на плоттер текста и атрибутов

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

QTEXTMODE

Управление отображением текста

TEXTFILL
TEXTQLTY

Утилиты

Нет

Ключевые слова для команд

Нет записей


Использование шрифтов текста для работ в рамках международного сотрудничества (Понятие)

Использование шрифтов TrueType
Назначение шрифтов
Подстановка шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов >
Использование шрифтов текста для работ в рамках международного сотрудничества
Понятие Процедура Краткий справочник

Некоторые факторы влияют на выбор, ввод и представление на чертеже текста на разных языках.

Программа поддерживает стандарт кодирования символов Unicode. SHX-шрифт, закодированный с использованием шрифта стандарта Unicode, может содержать намного больше символов, чем описанный в системе пользователя; поэтому для использования символа, не доступного непосредственно с клавиатуры, можно ввести последовательность \U+nnnn, где nnnn представляет собой шестнадцатеричное значение Unicode для символа.

Начиная с версии AutoCAD 2007, все контурные SHX-шрифты кодируются с учетом стандарта Unicode, за исключением "Больших шрифтов". При выборе шрифта для международных работ можно воспользоваться или шрифтом TrueType, или "Большим шрифтом".

SHX-файлы азиатских "больших шрифтов"

Азиатские алфавиты содержат тысячи символов, не относящихся к стандарту ASCII. Для поддержки такого текста программа позволяет работать с особым типом файлов описания форм, называемых файлами большого шрифта. При этом текстовому стилю можно одновременно назначать обычный и большой шрифт.

Большие шрифты азиатских языков, входящие в продукт
Наименование файла шрифта | Описание
@extfont2.shx | Японский вертикальный шрифт (некоторые символы повернуты для корректного использования в вертикальном тексте)
bigfont.shx | Японский шрифт, подгруппа символов
chineset.shx | Традиционный китайский шрифт
extfont.shx | Расширенный японский шрифт, уровень 1
extfont2.shx | Расширенный японский шрифт, уровень 2
gbcbig.shx | Упрощенный китайский шрифт
whgdtxt.shx | Корейский шрифт
whgtxt.shx | Корейский шрифт
whtgtxt.shx | Корейский шрифт
whtmtxt.shx | Корейский шрифт

При вводе имен шрифтов в командной строке в ответ на запрос команды -СТИЛЬ предполагается, что первым вводится имя обычного шрифта, а вторым (через запятую) - имя большого шрифта. Если вводится только одно имя, предполагается, что это имя обычного шрифта, и любой связанный с ним большой шрифт удаляется из стиля. Вставляя запятые перед именами файлов шрифтов или после них, можно переназначить только один из шрифтов, не изменяя другой, как показано в следующей таблице.

Задание шрифтов и больших шрифтов в командной строке
Что вводится... | Что устанавливается...
[имя шрифта],[имя большого шрифта] | И обычный, и большой шрифты
[имя шрифта], | Только обычный шрифт (большой не изменяется)
,[имя большого шрифта] | Только большой шрифт (обычный не изменяется)
[имя шрифта] | Только обычный шрифт (большой отменяется, если был задан)
ENTER (пустой ввод) | Изменений нет
Примечание Длинные имена файлов, содержащие запятые, не принимаются в качестве имен файлов шрифтов. Запятая воспринимается как разделитель между именами файлов SHX-шрифта и большого шрифта.
См. также

    • Подстановка шрифтов


Назначение SHX-шрифта азиатского языка текстовому стилю (Процедура)

Использование шрифтов TrueType
На уровень вверх ..
Подстановка шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Использование шрифтов текста для работ в рамках международного сотрудничества >
Использование шрифтов текста для работ в рамках международного сотрудничества
Понятие Процедура Краткий справочник

Назначение SHX-шрифта азиатского языка текстовому стилю

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовый стиль" в группе "Имя стиля" нажмите кнопку "Создать".
  3. В диалоговом окне "Новый текстовый стиль" введите имя нового текстового стиля. Нажмите "ОК".
  4. Выберите имя файла шрифта SHX из списка "Имя шрифта", затем установите флажок "Использовать большой шрифт" для использования большого шрифта азиатского языка.

    После выбора опции "Использовать большой шрифт" список "Начертание" заменяется на "Большой шрифт". При этом в списках отображаются только SHX-шрифты.

  5. Чтобы увидеть результат применения эффектов к различным символам, можно ввести текст в текстовое поле группы "Образец", расположенное слева от кнопки "Просмотр". Нажмите кнопку "Просмотр".
  6. Чтобы обновить текст на чертеже, нажмите кнопку "Применить".
  7. Нажмите кнопку "Закрыть".
Панель:Стили
Ввод команды: СТИЛЬ


Использование шрифтов текста для работ в рамках международного сотрудничества (Краткий справочник)

Использование шрифтов TrueType
Использование шрифтов текста для работ в рамках международного сотрудничества
Подстановка шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Использование шрифтов текста для работ в рамках международного сотрудничества >
Использование шрифтов текста для работ в рамках международного сотрудничества
Понятие Процедура Краткий справочник

Команды

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Подстановка шрифтов (Понятие)

Использование шрифтов текста для работ в рамках международного сотрудничества
Назначение шрифтов
Задание высоты символов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов >
Подстановка шрифтов
Понятие Процедура Краткий справочник

Если используемый на чертеже шрифт недоступен, он автоматически подменяется другим шрифтом.

Программа заменяет отсутствующий в системе шрифт другим шрифтом.

Задание альтернативного шрифта

Если используемый на чертеже шрифт отсутствует в системе, то он автоматически заменяется альтернативным шрифтом, заданным пользователем. По умолчанию используется файл шрифта simplex.shx. Если необходимо задать другой шрифт, требуется ввести имя файла альтернативного шрифта в системную переменную FONTALT. Если используется текстовый стиль, содержащий большой шрифт, можно привести его в соответствие с другим шрифтом с помощью системной переменной FONTALT. По умолчанию эта системная переменная использует пару файлов шрифтов txt.shx и bigfont.shx. Дополнительную информацию см. в разделе Использование шрифтов текста для работ в рамках международного сотрудничества.

В предыдущих версиях программы поддерживалось отображение шрифтов PostScript® на чертеже. Так как в более поздних версиях шрифты PostScript не отображаются, в программе Autodesk используются шрифты, эквивалентные TrueType. Шрифты PostScript приводятся в соответствие шрифтам TrueType в файле соответствия шрифтов. Кроме того, при отсутствии какого-либо шрифта TrueType можно задать другой шрифт TrueType, но, чтобы избежать проблем, связанных с длиной текста или с переносами, следует убедиться в схожести этих шрифтов.

Если шрифт, применяемый по умолчанию, не поддерживает символы, вводимые пользователем в контекстном редакторе (с помощью команды МТЕКСТ), подставляется альтернативный шрифт.

Коды CIF или MIF, введенные с помощью контекстного текстового редактора или команды ДТЕКСТ, теперь автоматически преобразуются для отображения реальных символов.

Редактирование файла соответствия шрифтов

Файл соответствия шрифтов представляет собой список текстовых шрифтов и вариантов их замены. Если невозможно обнаружить шрифт, используемый в каком-либо чертеже, то на место отсутствующего подставляется другой шрифт с помощью файла соответствия шрифтов.

Каждая строка файла состоит из базового имени файла шрифта (без расширения и без пути к его папке), точки с запятой (;) и имени файла шрифта, используемого для замены. Имя файла, используемого для замены, может иметь расширение .ttf.

Файл соответствия шрифтов является обычным текстовым файлом ASCII с расширением .fmp. Стандартным файлом соответствия шрифтов для AutoCAD является файл acad.fmp и файл acadlt.fmp для AutoCAD LT. Назначения шрифтов в файле соответствия можно менять с помощью любого текстового редактора ASCII.

Например, чтобы задать возможность замены файла шрифта timesnr.pfb файлом шрифта times.ttf, в файле соответствия используется следующая строка:

timesnr;times.ttf

В следующей таблице приводятся правила замены шрифтов, применяемые, если файл шрифта не может быть обнаружен при открытии чертежа.

Подстановка шрифтов
Расширения файлов | В первую очередь | Во вторую очередь | В третью очередь | В четвертую очередь
.ttf | Шрифт, заданный в FONTMAP | Шрифт, заданный в текстовом стиле | Подобный шрифт из имеющихся в Windows |
.shx | Шрифт, заданный в FONTMAP | Шрифт, заданный в текстовом стиле | Шрифт, заданный в FONTALT | Запрос нового шрифта
.pfb | Шрифт, заданный в FONTMAP | Шрифт, заданный в FONTALT | Запрос нового шрифта |

Отображение шрифтов-заместителей

Шрифты сторонних разработчиков или пользовательские SHX-шрифты, не имеющие TrueType-эквивалентов, заменяются одним из нескольких шрифтов TrueType, называемых шрифтами-заместителями. В контекстном редакторе шрифты-заместители отличаются по внешнему виду от замещаемых шрифтов для отображения того, что они служат заместителями шрифтов чертежа.

Пользовательские SHX-шрифты не отображаются в списке шрифтов на панели "Форматирование текста". Чтобы иметь возможность использовать такие шрифты, необходимо вначале создать текстовый стиль с нужным шрифтом, а затем применить его к фрагменту текста.


Подстановка шрифтов (Процедура)

Использование шрифтов текста для работ в рамках международного сотрудничества
На уровень вверх ..
Подстановка шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Подстановка шрифтов >
Подстановка шрифтов
Понятие Процедура Краткий справочник

Определение файла соответствия шрифтов

Задание альтернативного шрифта по умолчанию


Определение файла соответствия шрифтов (Процедура)

Подстановка шрифтов
На уровень вверх ..
Подстановка шрифтов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Подстановка шрифтов >
Подстановка шрифтов
Понятие Процедура Краткий справочник

Определение файла соответствия шрифтов

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" в списке дважды нажмите кнопку мыши на элементе "Имена файлов текстового редактора, словаря и шрифтов".
  3. Дважды нажмите на "Файле соответствия шрифтов".

    По умолчанию задан файл acad.fmp.

  4. Для использования другой таблицы соответствия шрифтов нужно дважды нажать на линии со стрелкой и выбрать файл таблицы в диалоговом окне "Выбор файла". Выберите файл и нажмите кнопку "Открыть". Нажмите "ОК".
  5. Чтобы преобразовать имеющийся текст с использованием вновь назначенных соответствий шрифтов, в командной строке введите реген.
Ввод команды: НАСТРОЙКА


Задание альтернативного шрифта по умолчанию (Процедура)

Подстановка шрифтов
На уровень вверх ..
Задание высоты символов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Подстановка шрифтов >
Подстановка шрифтов
Понятие Процедура Краткий справочник

Задание альтернативного шрифта по умолчанию

  1. В командной строке введите fontalt.
  2. Введите имя файла шрифта, который должен использоваться как альтернативный.


Подстановка шрифтов (Краткий справочник)

Использование шрифтов текста для работ в рамках международного сотрудничества
Подстановка шрифтов
Задание высоты символов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Назначение шрифтов > Подстановка шрифтов >
Подстановка шрифтов
Понятие Процедура Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

FONTALT

Задание альтернативного шрифта, используемого в случае, если не найден указанный шрифт

FONTMAP

Задание файла, описывающего подстановку шрифтов

Утилиты

Нет

Ключевые слова для команд

Нет


Задание высоты символов (Понятие)

Подстановка шрифтов
Работа с текстовыми стилями
Задание угла наклона символов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями >
Задание высоты символов
Понятие Процедура Краткий справочник

Высота символов задается в единицах чертежа.

Исключение составляют шрифты TrueType: для них это значение, как правило, соответствует высоте буквенных символов верхнего регистра.

Если в описании стиля задана фиксированная высота текста, то при создании однострочных надписей запрос "Высота" не выводится. Когда в текстовом стиле задана высота, равная 0, каждый раз при создании однострочных надписей выводится запрос высоты. Задание высоты, равной 0, позволяет создавать новые тексты различной высоты.

Шрифты TrueType

Высота шрифтов TrueType определяется суммой высоты прописной буквы и высоты верхней добавочной зоны, предназначенной для диакритических знаков (штрихи, галочки и т.п.), которые располагаются над некоторыми буквами в ряде европейских языков. Конкретные значения этих двух составляющих высоты не стандартизованы: они определяются разработчиком шрифта при его создании и, как следствие, меняются от шрифта к шрифту.

Кроме высоты прописной буквы и высоты верхней добавочной зоны, определяющей высоту текста, заданную пользователем, для шрифтов TrueType существует нижняя добавочная зона для таких символов, как y, j, p, g и q.

При изменении высоты символов многострочного тексте в редакторе происходит изменение всех размеров текстового объекта, в том числе его ширины.


Задание высоты в текстовом стиле (Процедура)

Подстановка шрифтов
На уровень вверх ..
Задание угла наклона символов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Задание высоты символов >
Задание высоты символов
Понятие Процедура Краткий справочник

Задание высоты в текстовом стиле

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" выберите текстовый стиль из списка "Имя стиля".
  3. В поле "Высота" группы "Шрифт" введите значение высоты (в единицах чертежа).
  4. Для обновления надписей, использующих данный текстовый стиль, нажмите кнопку "Применить".
  5. Нажмите кнопку "Закрыть".
Панель:Стили
Ввод команды: СТИЛЬ


Задание высоты символов (Краткий справочник)

Подстановка шрифтов
Задание высоты символов
Задание угла наклона символов
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Задание высоты символов >
Задание высоты символов
Понятие Процедура Краткий справочник

Команды

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

TEXTSIZE

Значение высоты по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля

TEXTSTYLE

Имя текущего текстового стиля

Утилиты

Нет

Ключевые слова для команд

Нет


Задание угла наклона символов (Понятие)

Задание высоты символов
Работа с текстовыми стилями
Задание горизонтальной или вертикальной ориентации текста
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями >
Задание угла наклона символов
Понятие Процедура Краткий справочник

Угол наклона определяет наклон символов надписи вправо или влево. Значение угла наклона отсчитывается относительно перпендикуляра, проведенного к основанию строки.

Значение угла наклона может лежать в диапазоне от -85 до 85 градусов. Положительное значение угла соответствует наклону символов вправо. отрицательное - наклону влево.


Задание угла наклона символов в текстовом стиле (Процедура)

Задание высоты символов
На уровень вверх ..
Задание горизонтальной или вертикальной ориентации текста
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Задание угла наклона символов >
Задание угла наклона символов
Понятие Процедура Краткий справочник

Задание угла наклона символов в текстовом стиле

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" выберите текстовый стиль из списка "Имя стиля".
  3. В поле "Угол наклона" группы "Эффекты" введите значение угла между -85 и 85.

    Положительное значение угла соответствует наклону символов вправо, отрицательное - наклону влево.

  4. Для обновления надписей, использующих данный текстовый стиль, нажмите кнопку "Применить".
  5. Нажмите кнопку "Закрыть".
Панель:Стили
Ввод команды: СТИЛЬ


Задание угла наклона символов (Краткий справочник)

Задание высоты символов
Задание угла наклона символов
Задание горизонтальной или вертикальной ориентации текста
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Задание угла наклона символов >
Задание угла наклона символов
Понятие Процедура Краткий справочник

Команды

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

Нет записей

Утилиты

Нет

Ключевые слова для команд

Нет


Задание горизонтальной или вертикальной ориентации текста (Понятие)

Задание угла наклона символов
Работа с текстовыми стилями
Редактирование текста
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями >
Задание горизонтальной или вертикальной ориентации текста
Понятие Процедура Краткий справочник

Выполняемые надписи могут быть ориентированы как горизонтально, так и вертикально. Но вертикальную ориентацию можно использовать только для шрифтов, поддерживающих оба типа ориентации.

Надписи можно располагать вертикально или горизонтально. Но вертикальную ориентацию можно использовать только для шрифтов, поддерживающих оба типа ориентации. Строки текста вертикальной ориентации могут располагаться одна рядом с другой. При последовательном нанесении однострочных надписей с вертикальной ориентацией каждая следующая надпись располагается правее предыдущей. Стандартное значение угла поворота для вертикальных текстов равно 270 градусам.

ПримечаниеДля шрифтов и символов TrueType вертикальная ориентация не поддерживается.

Вертикальный текст для азиатских языков

  • Шрифты SHX. С помощью шрифтов SHX и больших шрифтов текст для вертикального отображения можно создавать так же, как и в предыдущих версиях. Для получения наилучших результатов используйте команду для однострочного текста ТЕКСТ, а не МТЕКСТ. Вертикальный стиль можно выбрать в диалоговом окне "Текстовые стили".
  • Шрифты TrueType. По-прежнему можно выбирать шрифты, имена которых начинаются со знака @, но в данном случае текст автоматически поворачивается на 270 градусов. (В AutoCAD 2005 и предыдущих версиях этот текст приходилось поворачивать вручную.) Для вертикально ориентированного текста теперь поддерживается перемещение курсора по вертикали.


Задание вертикальной ориентации текстового стиля (Процедура)

Задание угла наклона символов
На уровень вверх ..
Редактирование текста
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Задание горизонтальной или вертикальной ориентации текста >
Задание горизонтальной или вертикальной ориентации текста
Понятие Процедура Краткий справочник

Задание вертикальной ориентации текстового стиля

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль текста". В командной строке введите "стиль".
  2. В диалоговом окне "Текстовые стили" выберите текстовый стиль из списка "Имя стиля".
  3. В группе "Эффекты" выберите "Вертикальная ориентация".
  4. Для обновления надписей, использующих данный текстовый стиль, нажмите кнопку "Применить".
  5. Нажмите кнопку "Закрыть".
Панель:Стили
Ввод команды: СТИЛЬ


Задание горизонтальной или вертикальной ориентации текста (Краткий справочник)

Задание угла наклона символов
Задание горизонтальной или вертикальной ориентации текста
Коротко о редактировании текста
Аннотирование чертежей > Примечания и метки > Работа с текстовыми стилями > Задание горизонтальной или вертикальной ориентации текста >
Задание горизонтальной или вертикальной ориентации текста
Понятие Процедура Краткий справочник

Команды

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

Нет записей

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование текста

Задание горизонтальной или вертикальной ориентации текста
Примечания и метки
Коротко о редактировании текста
Аннотирование чертежей > Примечания и метки >
Редактирование текста
Понятие Процедура

Имеется возможность редактирования и форматирования текста в надписях с изменением таких свойств, как масштаб и выравнивание.

Темы в этом разделе

  • Коротко о редактировании текста
  • Изменение однострочного текста
  • Изменение многострочного текста

    Положение и содержимое многострочных текстовых объектов можно изменить с помощью палитры свойств, контекстного редактора и ручек.

  • Поиск и замена текста

    Поиск и замену текста легко выполнить с помощью команды НАЙТИ.

  • Изменение масштаба и режима выравнивания текста

    В распоряжении пользователя имеются команды, позволяющие изменять масштаб и точки вставки текстовых объектов и атрибутов, не меняя при этом положения объектов.


Редактирование текста (Процедура)

Задание горизонтальной или вертикальной ориентации текста
Редактирование текста
Изменение однострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста >
Редактирование текста
Понятие Процедура

Редактирование однострочного текста

Изменение свойств однострочного текста

Изменение многострочного текста

Изменение ширины многострочного текстового объекта

Поиск фрагмента текста на чертеже

Для замены текста с помощью диалогового окна "Поиск и замена"

Для масштабирования многострочных текстовых объектов без изменения их местоположения


Коротко о редактировании текста (Понятие)

Редактирование текста
Редактирование текста
Изменение однострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста >
Коротко о редактировании текста
Понятие Краткий справочник

Текст, созданный посредством ТЕКСТ, МТЕКСТ или МВЫНОСКА , можно изменить, как любой другой объект. Их можно перемещать, поворачивать, стирать и копировать. Свойства текстовых объектов можно изменять на палитре свойств.

Для текстового объекта возможно не только редактирование его содержимого, но и создание зеркального отображения текста. Системная переменная MIRRTEXT управляет тем, происходит ли зеркальное отображение текста при симметричном отображении объектов на чертеже. Процедура редактирования текстов при различных способах его создания может несколько отличаться.


Коротко о редактировании текста (Краткий справочник)

Задание горизонтальной или вертикальной ориентации текста
Коротко о редактировании текста
Изменение однострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Коротко о редактировании текста >
Коротко о редактировании текста
Понятие Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

НАЙТИ

Поиск, замена , выбор и показ текста на чертеже

ОКНОСВ

Управление свойствами объектов

Системные переменные

MIRRTEXT

Управление отображением текста с помощью команды ЗЕРКАЛО

TEXTFILL
TEXTQLTY

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение однострочного текста (Понятие)

Коротко о редактировании текста
Редактирование текста
Изменение многострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста >
Изменение однострочного текста
Понятие Процедура Краткий справочник

Однострочный текст редактируют с помощью команд ДИАЛРЕД и ОКОНСВ. Команда ДИАЛРЕД используется при необходимости изменить только сам текст, но не формат или свойства текстового объекта. Команда ОКОНСВ позволяет изменить содержимое, стиль текста, его расположение, ориентацию, размер, выравнивание и другие характеристики.

Перемещение, масштабирование и поворот текстовых объектов можно также осуществлять с помощью ручек. У текстового объекта ручки находятся в левом нижнем углу базовой линии и в точке вставки.

Действие команд редактирования зависит от того, какая из ручек выбрана.


Изменение однострочного текста (Процедура)

Редактирование текста
На уровень вверх ..
Изменение однострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение однострочного текста >
Изменение однострочного текста
Понятие Процедура Краткий справочник

Редактирование однострочного текста

Изменение свойств однострочного текста


Редактирование однострочного текста (Процедура)

Изменение однострочного текста
На уровень вверх ..
Изменение однострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение однострочного текста >
Изменение однострочного текста
Понятие Процедура Краткий справочник

Редактирование однострочного текста

  1. Выберите пункт меню "Редактирование" [image] "Объект" [image] "Текст" [image] "Правка".В командной строке введите "диалРед".
  2. Выберите однострочный текстовый объект.
  3. В контекстном редакторе введите новый текст.
  4. Нажмите ENTER.
  5. Выберите другой текстовый объект, требующий правки, или нажмите ENTER для завершения команды.
Ввод команды: ДИАЛРЕД


Изменение свойств однострочного текста (Процедура)

Изменение однострочного текста
На уровень вверх ..
Изменение многострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение однострочного текста >
Изменение однострочного текста
Понятие Процедура Краткий справочник

Изменение свойств однострочного текста

  1. Выберите однострочный текстовый объект.
  2. Нажмите правую кнопку мыши на выбранном объекте. Нажмите кнопку "Свойства".
  3. На палитре свойств измените (если необходимо) значение любого из свойств, включая и сам текст надписи.
Панель:Стандартная
Ввод команды: ОКНОСВ


Изменение однострочного текста (Краткий справочник)

Коротко о редактировании текста
Изменение однострочного текста
Изменение многострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение однострочного текста >
Изменение однострочного текста
Понятие Процедура Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

ОКНОСВ

Управление свойствами объектов

ТЕКСТ

Создание однострочных текстовых объектов

Системные переменные

DTEXTED

Задание интерфейса пользователя, выводимого на экран для редактирования однострочного текста

TEXTFILL
TEXTQLTY

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение многострочного текста (Понятие)

Изменение однострочного текста
Редактирование текста
Поиск и замена текста
Аннотирование чертежей > Примечания и метки > Редактирование текста >
Изменение многострочного текста
Понятие Процедура Краткий справочник

Положение и содержимое многострочных текстовых объектов можно изменить с помощью палитры свойств, контекстного редактора и ручек.

После создания многострочного текста пользователь может на палитре свойств изменять его следующие свойства:

  • текстовый стиль
  • выравнивание
  • ширина
  • поворот
  • межстрочный интервал

Кроме того, для изменения отдельных элементов форматирования, таких как полужирный шрифт, подчеркивание и изменение ширины многострочного текстового объекта, можно использовать вкладку ленты МТЕКСТ (если лента включена) или контекстный редактор (если лента не включена).

Изменение положения текста

Для изменения положения и ширины многострочного текста можно использовать ручки. Ручки располагаются в вершинах текстовой рамки и, в некоторых случаях, в точке вставки текста.

Для перемещения многострочного текста можно воспользоваться палитрой свойств, где можно также редактировать содержимое надписей и изменять их свойства.

При использовании для создания многострочного текста таких команд, как РЗМЛИНЕЙНЫЙ или ВЫНОСКА, не требуется указания рамки текста, и создаваемый объект имеет всего одну ручку в точке вставки.

При выравнивании или перемещении многострочных текстовых объектов для повышения точности можно воспользоваться функцией привязки объектов к узлам и точкам вставки. Если для системной переменной OSNAPNODELEGACY задано значение 0, функция привязки объектов к узлам не применяется к многострочному тексту.

См. также

    • Работа с текстовыми стилями

    • Отображение полилиний, штриховок, градиентных заливок, весов линий и текста


Изменение многострочного текста (Процедура)

Изменение однострочного текста
На уровень вверх ..
Изменение многострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение многострочного текста >
Изменение многострочного текста
Понятие Процедура Краткий справочник

Изменение многострочного текста

Изменение ширины многострочного текстового объекта


Изменение многострочного текста (Процедура)

Изменение многострочного текста
На уровень вверх ..
Изменение многострочного текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение многострочного текста >
Изменение многострочного текста
Понятие Процедура Краткий справочник

Изменение многострочного текста

  1. Выберите многострочный текстовый объект.
  2. Нажмите правую кнопку мыши на выбранном объекте. Нажмите кнопку "Свойства".
  3. На палитре свойств измените (если необходимо) значение любого из свойств, включая и сам текст надписи.
Панель:Стандартная
Ввод команды: ОКНОСВ


Изменение ширины многострочного текстового объекта (Процедура)

Изменение многострочного текста
На уровень вверх ..
Поиск и замена текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение многострочного текста >
Изменение многострочного текста
Понятие Процедура Краткий справочник

Изменение ширины многострочного текстового объекта

  1. Двойным нажатием выделите многострочный текстовый объект.
  2. В контекстном редакторе выполните одно из действий, описанных ниже:
    • Подвести курсор к правому краю линейки так, чтобы он принял вид двойной стрелки. Удерживая нажатой кнопку устройства указания, перетащить край линейки на необходимое расстояние. При перетаскивании значение ширины отображается в виде всплывающей подсказки. Отпустить кнопку, установив новую ширину.
    • Наведя указатель на нижнюю часть линейки, щелкнуть правой кнопкой мыши. Выбрать "Установить ширину МТекста". Ввести значение ширины в открывшемся диалоговом окне.
  3. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажать клавиши CTRL+ENTER.


Изменение многострочного текста (Краткий справочник)

Изменение однострочного текста
Изменение многострочного текста
Изменение масштаба и режима выравнивания текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение многострочного текста >
Изменение многострочного текста
Понятие Процедура Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

НАЙТИ

Поиск, замена , выбор и показ текста на чертеже

МТРЕД

Редактирование многострочный текст

ОКНОСВ

Управление свойствами объектов

СТИЛЬ

Создание, изменение или определение стилей текста

Системные переменные

CENTERMT

Управление растягиванием центрированного по горизонтали многострочного текста с помощью ручек

MIRRTEXT

Управление отображением текста с помощью команды ЗЕРКАЛО

MTEXTED

Задание приложения для редактирования многострочных текстовых объектов

OSNAPNODELEGACY

Управление возможностью использования узловой объектной привязки к многострочным текстовым объектам

TEXTFILL
TEXTQLTY

Утилиты

Нет

Ключевые слова для команд

Нет


Поиск и замена текста (Понятие)

Изменение многострочного текста
Редактирование текста
Изменение масштаба и режима выравнивания текста
Аннотирование чертежей > Примечания и метки > Редактирование текста >
Поиск и замена текста
Понятие Процедура

Поиск и замену текста легко выполнить с помощью команды НАЙТИ.

Для поиска и замены текста можно использовать команду НАЙТИ. Заменяется только содержание текста; форматирование символов и свойства текста не изменяются.

При поиске текста в 3D среде видовой экран временно перейдет в режим 2D, чтобы текст не перекрывался имеющимися в чертеже 3D объектами.

Команда НАЙТИ позволяет использовать при поиске символы-шаблоны.

Символ | Определение
# (Решетка) | Соответствует любой одиночной цифре
@ (Коммерческое "при") | Соответствует любой одиночной букве
. (Точка) | Соответствует любому символу, кроме букв и цифр
* (Звездочка) | Соответствует любой последовательности символов. Может использоваться в любой позиции строки
? (Знак вопроса) | Соответствует любому одиночному символу; например, ?BC соответствует ABC, 3BC и т.п.
~ (Тильда) | Соответствует всем строкам, кроме отвечающих следующему после тильды шаблону; например, ~*AB* соответствует всем строкам, не содержащим последовательности AB
[ ] | Соответствует любому из символов в скобках; например, [AB]C соответствует AC и BC
[~] | Соответствует любому из символов, кроме заключенных в скобки; например, [~AB]C соответствует XC, но не соответствует BC
[-] | Задает диапазон для одиночного символа; например, [A-G]C соответствует AC, BC и так далее до GC, но не соответствует HC
' (Апостроф) | Следующий за ним специальный символ трактуется как обычный; например, '~AB соответствует ~AB

Для поиска файлов чертежей, содержащих определенное слово или фразу, используйте средство поиска в системе Microsoft® Windows® . С помощью средства поиска можно искать любую текстовую информацию, кроме текста в таблицах и полях, а также внешних ссылок в файлах чертежей.


Поиск и замена текста (Процедура)

Изменение многострочного текста
На уровень вверх ..
Поиск и замена текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Поиск и замена текста >
Поиск и замена текста
Понятие Процедура

Поиск фрагмента текста на чертеже

Для замены текста с помощью диалогового окна "Поиск и замена"


Поиск фрагмента текста на чертеже (Процедура)

Поиск и замена текста
На уровень вверх ..
Поиск и замена текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Поиск и замена текста >
Поиск и замена текста
Понятие Процедура

Поиск фрагмента текста на чертеже

  1. Выберите пункт меню "Правка" [image] "Найти".В командной строке введите "найти".
  2. В поле "Найти" введите текст, который требуется найти.
  3. В поле "Область поиска" укажите части чертежа, где следует выполнить поиск, или нажмите кнопку "Выбрать объекты" для выбора одного или нескольких текстовых объектов.
  4. Нажмите кнопку "Параметры поиска", чтобы задать параметры и типы для указанного текста.
  5. Нажмите "Найти".
  6. Для просмотра результатов поиска используйте один из следующих вариантов:
    • Для вывода таблицы, содержащей список результатов, установите флажок "Результаты".
    • Чтобы выделить и увеличить каждый результат отдельно, не устанавливайте флажок "Результаты".
  7. Нажмите кнопку "Закрыть".
Панель:Форматирование текста
Ввод команды: НАЙТИ
Меню: Нажмите "Редактировать" [image] "Найти".В командной строке введите "найти".


Для замены текста с помощью диалогового окна "Поиск и замена" (Процедура)

Поиск и замена текста
На уровень вверх ..
Изменение масштаба и режима выравнивания текста
Аннотирование чертежей > Примечания и метки > Редактирование текста > Поиск и замена текста >
Поиск и замена текста
Понятие Процедура

Для замены текста с помощью диалогового окна "Поиск и замена"

  1. Выберите пункт меню "Правка" [image] "Найти".В командной строке введите "найти".
  2. В поле "Найти" введите текст, который требуется найти.
  3. В поле "Область поиска" укажите части чертежа, где следует выполнить поиск, или нажмите кнопку "Выбрать объекты" для выбора одного или нескольких текстовых объектов.
  4. Нажмите кнопку "Параметры поиска", чтобы задать параметры и типы для указанного текста.
  5. В поле "Заменить на" введите текст, которым необходимо заменить найденный при поиске фрагмент текста.
  6. Нажмите "Найти".
  7. Для просмотра результатов поиска используйте один из следующих вариантов:
    • Для вывода таблицы, содержащей список результатов, установите флажок "Результаты".
    • Чтобы выделить и увеличить каждый результат отдельно, не устанавливайте флажок "Результаты".
  8. Для замены текста используйте один из следующих способов:
    • Нажать кнопку "Заменить" для замены только текущего найденного фрагмента.
    • Нажать кнопку "Заменить все" для поиска и замены сразу всех искомых фрагментов текста.
    • Если результаты поиска были с помощью настройки "Результаты" выведены в виде таблицы, можно выделить в списке некоторые из них, щелкая на них мышью при нажатой клавише CTRL (щелчок + CTRL). Другой способ: выделить в списке группу результатов, с помощью сочетания клавиши Shift + щелчок.
  9. Нажмите кнопку "Закрыть".
Панель:Форматирование текста
Ввод команды: НАЙТИ
Меню: Нажмите "Правка" [image] "Найти".В командной строке введите "найти".


Изменение масштаба и режима выравнивания текста (Понятие)

Поиск и замена текста
Редактирование текста
Проверка орфографии
Аннотирование чертежей > Примечания и метки > Редактирование текста >
Изменение масштаба и режима выравнивания текста
Понятие Процедура Краткий справочник

В распоряжении пользователя имеются команды, позволяющие изменять масштаб и точки вставки текстовых объектов и атрибутов, не меняя при этом положения объектов.

Имеется возможность изменения масштаба и точек вставки текстовых объектов, атрибутов и их описаний, не меняя при этом положения объектов.

Изменение масштаба многострочного текстового объекта

В чертеже могут содержаться сотни текстовых объектов, и отдельное масштабирование каждого из них может оказаться утомительным. Для масштабирования одного или сразу нескольких объектов, таких как атрибуты, однострочный и многострочный тексты, можно использовать команду МАСШТЕКСТ. При этом имеется возможность задавать относительный масштабный коэффициент или абсолютную высоту символов. Можно также масштабировать выбранный текст по заданной высоте символов уже имеющегося текста. Все текстовые объекты масштабируются с общим коэффициентом и сохраняют свои текущие положения.

Преобразование высоты символов при переходе между пространствами листа и модели

Команда ЕДПРОСТ обеспечивает пересчет значений длины в пространстве модели и в пространстве листа. При прозрачном выполнении команды ЕДПРОСТ можно вводить в командах значения расстояния и длины относительно объектов в другом пространстве. Например, можно создать текстовый объект в пространстве модели с высотой символов другого текста, созданного в пространстве листа. В этом случае диалог в пространстве модели может выглядеть так:

Команда: текст

Начальная точка текста или [Выравнивание/Стиль]: 1,3

Высота <0,375>: 'едпрост

>>Расстояние в пространстве листа <1,000>: 3/8

Возобновляется команда ТЕКСТ.

Задайте высоту <0.375>: 1,173

После выполнения команды создается текстовый объект в пространстве модели с высотой символов 1,173; при переходе на лист высота равна 3/8.

ПримечаниеКоманда ЕДПРОСТ не доступна на вкладке "Модель", а также в виде перспективы.

Подробнее о прозрачных командах см. раздел Ввод команд в командной строке.

Изменение выравнивания текстовых объектов с сохранением их положения

Переопределение точки вставки текста без перемещения последнего выполняется с помощью команды ВЫРТЕКСТ. Например, в таблице или графике могут быть верно проставлены надписи, однако для дальнейшей работы необходимо их выровнять вправо.


Для масштабирования многострочных текстовых объектов без изменения их местоположения (Процедура)

Поиск и замена текста
На уровень вверх ..
Проверка орфографии
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение масштаба и режима выравнивания текста >
Изменение масштаба и режима выравнивания текста
Понятие Процедура Краткий справочник

Для масштабирования многострочных текстовых объектов без изменения их местоположения

  1. Перейдите на вкладку "Аннотирование" [image] панель "Текст" [image] "Масштаб". В командной строке введите "масштекст".
  2. Выберите один или несколько текстовых объектов и нажмите ENTER.
  3. Укажите один из вариантов выравнивания или нажмите ENTER, чтобы принять имеющиеся настройки выравнивания.
  4. Введите м и введите масштабный коэффициент, который будет применяться к каждому многострочному текстовому объекту.
Ввод команды: МАСШТЕКСТ


Изменение масштаба и режима выравнивания текста (Краткий справочник)

Изменение многострочного текста
Изменение масштаба и режима выравнивания текста
Проверка орфографии
Аннотирование чертежей > Примечания и метки > Редактирование текста > Изменение масштаба и режима выравнивания текста >
Изменение масштаба и режима выравнивания текста
Понятие Процедура Краткий справочник

Команды

ВЫРТЕКСТ

Изменение точки выравнивания для выбранных текстовых объектов без изменения их положения

ОКНОСВ

Управление свойствами объектов

МАСШТЕКСТ

Увеличение/уменьшение размеров текстовых объектов без изменения их расположения

ЕДПРОСТ

Расчет на листе эквивалентных значений длины в пространстве модели и пространстве листа

Системные переменные

Нет записей

Утилиты

Нет

Ключевые слова для команд

Нет


Проверка орфографии (Понятие)

Изменение масштаба и режима выравнивания текста
Примечания и метки
Работа с внешними текстовыми редакторами
Аннотирование чертежей > Примечания и метки >
Проверка орфографии
Понятие Процедура Краткий справочник

Проверку орфографии всего текста можно выполнять по мере появления его на чертеже. Кроме того, можно указать используемый словарь для конкретного языка, а также настроить несколько пользовательских словарей проверки орфографии и работать с ними.

Можно проверить орфографию всех текстовых объектов чертежа, включая:

  • Текст размера
  • Однострочный и многострочный текст
  • Текст атрибутов блоков
  • Внешние ссылки

В режиме проверки орфографии на всем чертеже или в указанных пользователем областях текста чертежа выполняется поиск слов с ошибками. При обнаружении слова с ошибкой это слово выделяется подсветкой, а масштаб области рисования увеличивается для удобства чтения этого слова.

Проверка орфографии при вводе

По умолчанию проверка орфографии выполняется при вводе текста в Контекстный текстовый редактор . Каждое введенное слово проверяется на наличие орфографических ошибок, как только оно полностью введено. Слово считается полностью введенным, когда выполняется одно из следующих действий:

  • Нажатие ПРОБЕЛ или ENTER
  • Перемещение курсора в другое положение внутри контекстного редактора.

Слова с грамматическими ошибками подчеркиваются красной пунктирной линией

Любое слово, не найденное в текущем словаре, подчеркивается как содержащее грамматическую ошибку. При щелчке на подчеркнутом слове правой кнопкой мыши отображаются варианты правильного написания.

Смена словарей

В целях проверки орфографии предусмотрено несколько главных словарей для различных языков. Можно также создать любое количество пользовательских словарей и по мере необходимости переходить в другому словарю.

В ходе орфографической проверки слова надписей на чертеже сравниваются со словами, хранящимися в текущем основном словаре. Все добавляемые пользователем слова сохраняются в том пользовательском словаре, который является текущим на момент проверки орфографии. Например, можно занести в словарь имена собственные, которые в дальнейшем не будут определяться как написанные с ошибкой.

ПримечаниеПо умолчанию в AutoCAD содержится один образец пользовательского словаря с такими словами, как "AutoCAD" и "Autodesk".

Для проверки орфографии на другом языке следует перейти к другому главному словарю.

Для перехода к другому словарю можно воспользоваться диалоговым окном "Словари", а также задать имя словаря с помощью системной переменной DCTMAIN или DCTCUST. Системная переменная DCTMAIN определяет список главных словарей.

Примечание В имени файла пользовательского словаря не допускается употребление символов, не соответствующих текущей кодовой странице. Если при работе с пользовательским словарем применяются различные наборы национальных параметров или языки, допускается употребление только символов ASCII.

Создание и редактирование вспомогательных словарей

Пользовательский словарь представляет собой список слов, не вошедших в главный словарь. Файлам, содержащим такие словари, присваивается имя с расширением .cus. С помощью любого текстового редактора ASCII можно добавлять и удалять слова, а также объединять различные словари. Если слову предшествует тильда (~), оно всегда отмечается как неправильное.


Проверка орфографии (Процедура)

Изменение масштаба и режима выравнивания текста
Проверка орфографии
Проверка орфографии
Аннотирование чертежей > Примечания и метки > Проверка орфографии >
Проверка орфографии
Понятие Процедура Краткий справочник

Проверка орфографии

Процедура проверки орфографии в атрибуте блока

Смена текущего словаря во время проверки орфографии

Процедура добавления пользовательского словаря или списка слов


Проверка орфографии (Процедура)

Проверка орфографии
Проверка орфографии
Проверка орфографии
Аннотирование чертежей > Примечания и метки > Проверка орфографии >
Проверка орфографии
Понятие Процедура Краткий справочник

Проверка орфографии

  1. Перейдите на вкладку "Аннотирование" [image] панель "Текст" [image] "Проверка орфографии". В командной строке введите "Орфо".
  2. Выберите параметр, определяющий область проверки. Выберите "Начало". При отсутствии слов с ошибками отображается соответствующее сообщение. При обнаружении орфографической ошибки в диалоговом окне "Проверка орфографии" отображается ошибочное слово. В области рисования это слово выделяется подсветкой и увеличивается.
  3. Выполните одно из следующих действий:
    • Для исправления слова выберите один из вариантов, предлагаемых в списке "Варианты", или введите слово в поле "Варианты". Нажмите кнопку "Изменить" или "Изменить все".
    • Для пропуска слова (без изменения) нажмите кнопку "Пропустить" или "Пропустить все".
    • Если требуется оставить слово без изменений и добавить его к словарю, выберите "Добавить к словарю".
  4. Повторите шаг 3 для каждого слова с ошибкой. Для завершения процедуры нажмите "Закрыть".
Панель:Текст
Ввод команды: ОРФО


Процедура проверки орфографии в атрибуте блока (Процедура)

Проверка орфографии
Проверка орфографии
Проверка орфографии
Аннотирование чертежей > Примечания и метки > Проверка орфографии >
Проверка орфографии
Понятие Процедура Краткий справочник

Процедура проверки орфографии в атрибуте блока

  1. Перейдите на вкладку "Аннотирование" [image] панель "Текст" [image] "Проверка орфографии". В командной строке введите "Орфо".
  2. В диалоговом окне "Проверка орфографии" выберите "Параметры".
  3. В диалоговом окне "Параметры проверки орфографии" выберите "Атрибуты блока". Нажмите ОК.
  4. В диалоговом окне "Проверка орфографии" выберите "Начало".
  5. Выполните одно из следующих действий:
    • Для исправления слова выберите один из вариантов, предлагаемых в списке "Варианты", или введите слово в поле "Варианты". Нажмите кнопку "Изменить" или "Изменить все".
    • Для пропуска слова (без изменения) нажмите кнопку "Пропустить" или "Пропустить все".
    • Если требуется оставить слово без изменений и добавить его к словарю, выберите "Добавить к словарю".
  6. Повторите шаг 5 для каждого слова с ошибкой. Для завершения процедуры нажмите "Закрыть".
Панель:Текст
Ввод команды: ОРФО


Смена текущего словаря во время проверки орфографии (Процедура)

Проверка орфографии
Проверка орфографии
Проверка орфографии
Аннотирование чертежей > Примечания и метки > Проверка орфографии >
Проверка орфографии
Понятие Процедура Краткий справочник

Смена текущего словаря во время проверки орфографии

  1. Перейдите на вкладку "Аннотирование" [image] панель "Текст" [image] "Проверка орфографии". В командной строке введите "Орфо".
  2. В диалоговом окне "Проверка орфографии" выберите "Словари".
  3. Выполните одно из следующих действий:
    • Для изменения основного словаря выберите словарь в списке "Текущий основной словарь".
    • Для изменения пользовательского словаря выберите словарь в списке "Текущий пользовательский словарь".
  4. Нажмите кнопку "Закрыть".
Ввод команды: ОРФО


Процедура добавления пользовательского словаря или списка слов (Процедура)

Проверка орфографии
Проверка орфографии
Работа с внешними текстовыми редакторами
Аннотирование чертежей > Примечания и метки > Проверка орфографии >
Проверка орфографии
Понятие Процедура Краткий справочник

Процедура добавления пользовательского словаря или списка слов

  1. Перейдите на вкладку "Аннотирование" [image] панель "Текст" [image] "Проверка орфографии". В командной строке введите "Орфо".
  2. В диалоговом окне "Проверка орфографии" выберите "Словари".
  3. В диалоговом окне "Словари" в списке текущих пользовательских словарей выберите "Управление пользовательскими словарями".
  4. В списке "Пользовательские словари" выберите "Добавить" и перейдите к папке словаря. Для создания нового пользовательского словаря выберите "Создать" и введите имя словаря. Имя должно содержать расширение .cus.
  5. Нажмите "ОК". Созданный словарь выделяется подсветкой как текущий пользовательский словарь.
  6. Если требуется импортировать список слов в пользовательский словарь, выберите "Импорт".
  7. Нажать "ОК".
Ввод команды: ОРФО


Проверка орфографии (Краткий справочник)

Изменение масштаба и режима выравнивания текста
Проверка орфографии
Коротко о работе с внешними текстовыми редакторами
Аннотирование чертежей > Примечания и метки > Проверка орфографии >
Проверка орфографии
Понятие Процедура Краткий справочник

Команды

ОРФО

Орфографическая проверка надписей в чертеже

Системные переменные

DCTCUST

Отображение пути и имени файла текущего пользовательского орфографического словаря

DCTMAIN

Отображение трехбуквенного ключевого слова для текущего основного орфографического словаря

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с внешними текстовыми редакторами

Проверка орфографии
Примечания и метки
Коротко о работе с внешними текстовыми редакторами
Аннотирование чертежей > Примечания и метки >
Работа с внешними текстовыми редакторами
Понятие Процедура

По умолчанию, в качестве текстового редактора используется вкладка ленты МТЕКСТ (если лента включена) или контекстный текстовый редактор (если вкладка не включена), но пользователь может выбрать любой другой редактор, позволяющий сохранять файлы в формате ASCII.

Темы в этом разделе

  • Коротко о работе с внешними текстовыми редакторами
  • Форматирование многострочного текста во внешнем редакторе


Работа с внешними текстовыми редакторами (Процедура)

Проверка орфографии
Работа с внешними текстовыми редакторами
Форматирование многострочного текста во внешнем редакторе
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами >
Работа с внешними текстовыми редакторами
Понятие Процедура

Указание внешнего текстового редактора

Создание многострочной надписи во внешнем редакторе


Коротко о работе с внешними текстовыми редакторами (Понятие)

Работа с внешними текстовыми редакторами
Работа с внешними текстовыми редакторами
Форматирование многострочного текста во внешнем редакторе
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами >
Коротко о работе с внешними текстовыми редакторами
Понятие Краткий справочник

Чтобы выбрать другой редактор, его следует указать с помощью системной переменной MTEXTED. Выбранный редактор должен работать с текстовыми файлами в формате ASCII. Это может быть, например, "Блокнот" Microsoft.

При использовании внешнего текстового редактора для работы с многострочным текстом перед вводом текста необходимо задать общие параметры текста из командной строки. Затем открывается текстовый редактор для ввода текста. После закрытия текстового редактора текст размещается в соответствии с заданной шириной абзаца.

Если используется внешний редактор, то пользователь должен ввести специальные коды для применения форматирования.

Набор этих кодов не зависит от выбора внешнего редактора. Во избежание потери информации о форматировании текста для его изменения рекомендуется использовать тот же редактор, который использовался при создании текста.


Коротко о работе с внешними текстовыми редакторами (Краткий справочник)

Проверка орфографии
Коротко о работе с внешними текстовыми редакторами
Форматирование многострочного текста во внешнем редакторе
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами > Коротко о работе с внешними текстовыми редакторами >
Коротко о работе с внешними текстовыми редакторами
Понятие Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

MTEXTED

Задание приложения для редактирования многострочных текстовых объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Форматирование многострочного текста во внешнем редакторе (Понятие)

Коротко о работе с внешними текстовыми редакторами
Работа с внешними текстовыми редакторами
Таблицы
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами >
Форматирование многострочного текста во внешнем редакторе
Понятие Процедура Краткий справочник

Для форматирования отдельных символов и слов надписи во внешнем редакторе в текст можно включать управляющие коды. С помощью управляющих кодов можно получать подчеркнутые, надчеркнутые и дробные надписи. Также имеется возможность задавать цвет, шрифт и размер символов. Кроме того, допускается изменение расстояния между символами текста и увеличение их ширины. Перечень управляющих кодов приводится в следующей таблице.

Управляющие коды для многострочных текстов
Код | Назначение | Что вводится | Результат
\0...\o | Включение и отключение надчеркивания | Autodesk \OAutoCAD\o |
\L...\l | Включение и отключение надчеркивания подчеркивания | Autodesk \OAutoCAD\o |
\~ | Вставка неразрывного пробела | Autodesk AutoCAD\~LT |
\\ | Вставка обратной косой черты | Autodesk \\AutoCAD |
\{...\} | Вставка открывающей и закрывающей фигурных скобок | Autodesk \{AutoCAD\} |
\Cзначение; | Переход к определенному цвету | Autodesk \C2;AutoCAD |
\ имя файла; | Переход к определенному файлу шрифта | Autodesk \Ftimes; AutoCAD |
\Hзначение; | Переход к высоте, определенной в единицах чертежа | Autodesk \H2;AutoCAD |
\HзначениеX; | Умножение текущей высоты символов на коэффициент (буква Х латинская) | Autodesk \H3x;AutoCAD |
\S...^...; | Построение дробного текста с разбиением по символу /, # или ^ | 1.000\S+0.010^-0.000; |
\Tзначение; | Настройка межсимвольного интервала. Диапазон допустимых значений - от 0,75 до 4 (кратность по отношению к первоначальному межсимвольному интервалу). | \T2;Autodesk |
\Qугол; | Изменение угла наклона символов | \Q20;Autodesk |
\Wзначение; | Изменение коэффициента растяжения символов | \W2;Autodesk |
\A | Установка режима выравнивания; допустимые значения: 0, 1, 2 (вниз, по центру, вверх) | \A1;1\S1/2 |
\P | Символ конца абзаца | Autodesk\PAutoCAD |

Допускается вложенность фигурных скобок до восьми уровней.

Управляющие коды могут также использоваться в размерных текстах (в частности для обозначения допусков). См. описание команды МТЕКСТ.

Пример: форматирование текста во внешнем текстовом редакторе

Данный пример описывает, как был создан текст со следующей иллюстрации.

Каждая приведенная ниже строка вводилась во внешнем текстовом редакторе:

{{\H1.5x; Большой текст} \A2; над текстом\A1;/\A0; за текстом}\P
{\A0;Базовый: 1 \S1/2;}\P
{\A1;По центру: 1 \S1/2;}\P
{\A2;Верхняя линия: 1 \S1/2;}\P
{Допуски: \A1;1.000\H.75x;\S+0.010^-0.000;}\P
{Архитектурный: 9-{\H.666x;\A2;11\A1;/\A0;16}\A2;"}\P


Форматирование многострочного текста во внешнем редакторе (Процедура)

Работа с внешними текстовыми редакторами
На уровень вверх ..
Форматирование многострочного текста во внешнем редакторе
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами > Форматирование многострочного текста во внешнем редакторе >
Форматирование многострочного текста во внешнем редакторе
Понятие Процедура Краткий справочник

Указание внешнего текстового редактора

Создание многострочной надписи во внешнем редакторе


Указание внешнего текстового редактора (Процедура)

Форматирование многострочного текста во внешнем редакторе
На уровень вверх ..
Форматирование многострочного текста во внешнем редакторе
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами > Форматирование многострочного текста во внешнем редакторе >
Форматирование многострочного текста во внешнем редакторе
Понятие Процедура Краткий справочник

Указание внешнего текстового редактора

  1. В командную строку введите mtexted.
  2. Выполните одно из следующих действий:
    • Ввести путь и имя исполняемого файла текстового редактора, поддерживающего текстовые файлы в формате ASCII, для его использования при создании и редактировании многострочного текста.
    • Ввести внутренний для назначения встроенного текстового редактора.


Создание многострочной надписи во внешнем редакторе (Процедура)

Форматирование многострочного текста во внешнем редакторе
На уровень вверх ..
Создание и редактирование таблиц
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами > Форматирование многострочного текста во внешнем редакторе >
Форматирование многострочного текста во внешнем редакторе
Понятие Процедура Краткий справочник

Создание многострочной надписи во внешнем редакторе

  1. Чтобы задать какой-либо текстовый редактор, в командную строку введите mtexted. Затем введите месторасположение используемого редактора.
  2. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Многострочный текст". В командной строке введите "мтекст".
  3. Укажите первый угол текстовой рамки.
  4. Укажите противоположный угол текстовой рамки.
  5. В текстовом редакторе введите текст. Для завершения абзаца введите \P и начните новый абзац со следующей строки. (Обратите внимание на то, что буква P должна быть прописной).
  6. По окончании ввода текста сохраните его в файле и выйдите из текстового редактора.
Панель:Рисование
Ввод команды: МТЕКСТ


Форматирование многострочного текста во внешнем редакторе (Краткий справочник)

Коротко о работе с внешними текстовыми редакторами
Форматирование многострочного текста во внешнем редакторе
Создание и редактирование таблиц
Аннотирование чертежей > Примечания и метки > Работа с внешними текстовыми редакторами > Форматирование многострочного текста во внешнем редакторе >
Форматирование многострочного текста во внешнем редакторе
Понятие Процедура Краткий справочник

Команды

МТЕКСТ

Создание многострочного текстового объекта

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

MTEXTED

Задание приложения для редактирования многострочных текстовых объектов

Утилиты

Нет

Ключевые слова для команд

Нет


Таблицы

Форматирование многострочного текста во внешнем редакторе
Аннотирование чертежей
Создание и редактирование таблиц
Аннотирование чертежей >
Таблицы

Таблица представляет собой прямоугольный массив ячеек с аннотациями; аннотации, как правило, являются текстовыми, но могут также состоять из нескольких блоков.

Темы в этом разделе

  • Создание и редактирование таблиц

    Данные в таблице организованы по строкам и столбцам. Объект-таблицу можно создать на основе пустой таблицы или стиля таблиц. Можно также связать таблицу с данными в электронной таблице Microsoft Excel.

  • Создание связи таблицы с внешними данными

    Таблицу можно связать с ячейками в файле Microsoft Excel (XLS, .XLSX или CSV). Можно создать связь с электронной таблицей в целом, отдельной строкой, столбцом, ячейкой или диапазоном ячеек в Excel.

  • Работа со стилями таблиц

    Вид таблицы определяется заданным для нее стилем. Можно использовать стиль таблиц СТАНДАРТ, предлагаемый по умолчанию, или создать свои собственные стили таблиц.

  • Добавление в таблицы текста и блоков

    Данные в ячейке таблицы могут содержать текст и несколько блоков.

  • Использование формул в ячейках таблицы

    В ячейках таблицы могут содержаться формулы, использующие для расчетов величины, содержащиеся в других ячейках таблицы.


Создание и редактирование таблиц (Понятие)

Таблицы
Таблицы
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Данные в таблице организованы по строкам и столбцам. Объект-таблицу можно создать на основе пустой таблицы или стиля таблиц. Можно также связать таблицу с данными в электронной таблице Microsoft Excel.

После создания таблицы пользователь может указать с помощью мыши любую линию сетки таблицы для ее выделения и изменения с помощью ручек или палитры свойств.

При изменении высоты или ширины таблицы фактически изменяется только строка или столбец рядом с выбранной ручкой. Общая высота или ширина таблицы остается неизменной. Чтобы изменить размер таблицы в соответствии с размером редактируемой строки или столбца, используйте ручку столбца при нажатой клавише CTRL.

Разбиение таблицы на части

Таблицу с большим объемом данных можно разбить на основной и дополнительных фрагменты. С помощью ручек разрыва таблицы, расположенных внизу таблицы, можно разместить таблицу в нескольких столбцах чертежа, а также выполнять различные операции с ранее созданными частями таблицы.

Демонстрация: разбиение таблиц на несколько частей

Для запуска анимации нажмите стрелку "Просмотр".

Изменение ячейки таблицы

Для выделения ячейки укажите точку внутри нее. На середине каждой границы ячейки появляется ручка. Для перемещения выбранных данных в другую ячейку щелкните внутри этой ячейки. С помощью ручек можно изменить ширину и высоту ячейки и, соответственно, ширину и высоту ее столбца и строки.

ПримечаниеДля редактирования текста в ячейке выберите ячейку и нажмите клавишу F2.

Для выделения нескольких ячеек следует выбрать первую из ячеек, а затем, удерживая кнопку мыши в нажатом состоянии, указать все остальные ячейки. Если, нажав клавишу SHIFT, последовательно указать точки внутри двух ячеек, то вместе с указанными ячейками будут выбраны также все ячейки, расположенные между ними.

Если щелкнуть внутри ячейки таблицы, когда включена лента, отображается контекстная вкладка ленты "Таблица". Если лента выключена, отображается панель "Таблица". С ее помощью можно выполнить следующие действия.

  • Редактирование строк и столбцов
  • Объединение и отмена объединения ячеек
  • Изменение внешнего вида границ ячеек
  • Изменение формата и выравнивания данных
  • Блокировка и разблокировка редактирования для ячеек
  • Вставка блоков, полей и формул
  • Создание и редактирование стилей ячеек
  • Связывание таблицы с внешними данными

Если выбрать ячейку и щелкнуть на ней правой кнопкой мыши, отображается контекстное меню, с помощью которого можно вставлять и удалять строки и столбцы, объединять смежные ячейки и вносить другие изменения. При наличии выбранных ячеек можно повторить последнюю операцию с помощью комбинации клавиш CTRL+Y.

ПримечаниеПри использовании комбинации CTRL+Y для повтора последней операции повторяются только операции, выполненные с помощью контекстных меню, вкладки ленты "Таблица" или панели "Таблица".

Добавление таблицы в инструментальную палитру

При добавлении таблицы в инструментальную палитру, свойства таблицы (например ее стиль и число строк и столбцов) и переопределения свойств ячеек (например для выравнивания и веса линий границ) сохраняются в описании инструмента. В определении инструмента содержится также текст, данные блоков и параметры формата символов.

Адаптация отображения букв столбцов и номеров строк

По умолчанию буквы столбца и номера строк отображаются в контекстном редакторе при выборе ячейки для редактирования. С помощью системной переменной TABLEINDICATOR можно включить или отключить этот режим отображения. Для установки нового цвета фона нужно выделить таблицу, нажать правую кнопку мыши и в контекстном меню выбрать "Цвет индикатора таблицы". Цвет, размер, стиль текста и цвет строки указаны в настройках заголовков столбцов в текущем стиле таблицы.

См. также

    • Добавление в таблицы текста и блоков


Создание и редактирование таблиц (Процедура)

Форматирование многострочного текста во внешнем редакторе
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Процедура создания пустой таблицы

Процедура создания таблицы на основе связанной электронной таблицы

Процедура создания таблицы по извлеченным данным.

Процедура создания инструмента на основе таблицы на текущем чертеже

Процедура блокировки или разблокировки ячеек

Изменение ячеек в таблице с помощью ручек

Изменение ячеек в таблице с помощью ручек

Изменение таблицы с помощью палитры свойств

Процедура разбиения таблицы на части с помощью ручек

Изменение ширины столбца или высоты строки в таблице

Добавление столбцов или строк в таблицу

Объединение ячеек в таблице

Удаление столбцов или строк из таблицы


Процедура создания пустой таблицы (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Процедура создания пустой таблицы

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Вставка таблицы". В командной строке введите "таблица".
  2. В диалоговом окне "Вставка таблицы" выберите в списке стиль таблиц или нажмите кнопку справа от ниспадающего меню для создания нового стиля таблиц.
  3. Выберите "Начать с незаполненной таблицы".
  4. Вставьте таблицу на чертеже одним из следующих способов.
    • Задайте точку вставки.
    • Задайте рамку для таблицы.
  5. Задайте число и ширину столбцов.

    При вставке с указанием области можно задайте либо число, либо ширину столбцов, но не оба эти параметра одновременно.

  6. Задайте число и высоту строк.

    При вставке с указанием области число строк определяется размером указанной области и высотой строк.

  7. Нажмите "ОК".
Ввод команды: ТАБЛИЦА


Процедура создания таблицы на основе связанной электронной таблицы (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Процедура создания таблицы на основе связанной электронной таблицы

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Вставка таблицы". В командной строке введите "таблица".
  2. Выберите "По связи с данными"
  3. Выберите в ниспадающем меню установленную связь с данными или нажмите кнопку [...] для создания новой связи с данными с помощью диспетчера связей с данными.
  4. Нажмите "OK" для задания точки вставки таблицы на чертеже.
Ввод команды: ТАБЛИЦА


Процедура создания таблицы по извлеченным данным. (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Процедура создания таблицы по извлеченным данным.

  1. Выберите "Сервис" [image] "Извлечение данных".В командной строке введите "данныеизвл".
  2. В мастере извлечения данных на странице "Начало" выберите "Новое извлечение данных". Если требуется применить файл шаблона (DXE или BLK), выберите "Использовать предыдущее извлечение в качестве шаблона". Нажмите "Далее".
  3. В диалоговом окне "Сохранение извлечения данных" укажите имя для файла извлеченных данных. Нажмите кнопку "Сохранить".
  4. На странице "Определение источника данных" укажите чертежи или папки, из которых требуется извлечь данные. Нажмите "Далее".
  5. На странице "Выбор объектов" выберите объекты, из которых требуется извлечь данные. Нажмите "Далее".
  6. На странице "Выбор свойств" выберите свойства, из которых требуется извлечь данные. Нажмите "Далее".
  7. При необходимости измените структуру столбцов на странице "Исправление данных". Нажмите "Далее".
  8. На странице "Выбор типа вывода" выберите "Вставить таблицу извлечения данных в чертеж" для создания таблицы извлечения данных. Нажмите "Далее".
  9. На странице "Стили таблиц" выберите стиль таблиц, если хотя бы один стиль таблиц определен для текущего чертежа, или таблицу, определенную в каком-либо стиле таблиц. При необходимости введите заголовок для таблицы. Нажмите "Далее".
  10. На последней странице нажмите "Готово".
  11. Щелкните в точке вставки на чертеже для создания таблицы.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Процедура создания инструмента на основе таблицы на текущем чертеже (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Процедура создания инструмента на основе таблицы на текущем чертеже

  1. Выберите таблицу на текущем чертеже.
  2. С помощью правой кнопки мыши перетащите таблицу на палитру инструментов и, не отпуская кнопки мыши, наведите курсор на то место на палитре инструментов, в которое требуется поместить инструмент.

    Для перехода на другую вкладку удерживайте курсор мыши на требуемой вкладке в течение нескольких секунд. Черная линия на палитре указывает возможное расположение инструмента.

  3. Отпустите кнопку мыши.
    ПримечаниеВсе параметры форматирования, свойства таблицы и свойства ячеек, а также содержимое в виде текста и блоков сохраняются в инструменте на палитре инструментов.
Панель:Стандартный
Ввод команды: ИНСТРПАЛВКЛ


Процедура блокировки или разблокировки ячеек (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Процедура блокировки или разблокировки ячеек

  1. Одним из указанных ниже способов выберите в таблице одну или несколько ячеек, которые требуется заблокировать или разблокировать.
    • Укажите точку внутри ячейки.
    • Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.
    • Укажите выбранную ячейку и, удерживая нажатой кнопку мыши, укажите остальные выбираемые ячейки, а затем отпустить кнопку.
  2. Выберите один из следующих вариантов.
    • Разблокировка одной или нескольких ячеек.На вкладке ленты "Таблица" или на панели "Таблица" выберите "Блокирование" [image] "Разблокировано"
    • Блокировка одной или нескольких ячеек. На вкладке ленты "Таблица" или на панели "Таблица" выберите "Блокирование" [image] "Содержимое формат заблокированы"
Ввод команды: ТАБЛРЕД
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Блокирование".


Изменение ячеек в таблице с помощью ручек (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Изменение ячеек в таблице с помощью ручек

  1. Выберите устройством указания линию сетки таблицы.
  2. Воспользуйтесь одной из следующих ручек:
    • Верхняя левая ручка. Перемещение таблицы.
    • Верхняя правая ручка. Изменение ширины таблицы с пропорциональным изменением ширины всех столбцов.
    • Нижняя левая ручка. Изменение высоты таблицы с пропорциональным изменением высоты всех строк.
    • Нижняя правая ручка. Изменение высоты и ширины таблицы с пропорциональным изменением высоты и ширины строк и столбцов соответственно.
    • Ручка столбца (над верхней строчкой столбца). Расширение или сужение соседних столбцов без изменения ширины таблицы.
    • Клавиша CTRL + ручка столбца Изменение ширины столбца, расположенного слева от ручки, и расширение или сужение таблицы в соответствии с этим изменением.

    Минимальное значение ширины столбца ограничено шириной одного символа. Минимальная высота строки пустой таблицы определяется суммарным значением высоты текста и вертикального отступа границ ячейки.

  3. Нажмите ESC для отмены выделения.


Изменение ячеек в таблице с помощью ручек (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Изменение ячеек в таблице с помощью ручек

  1. Выделите для изменения одну или несколько ячеек в таблице любым из следующих способов:
    • Укажите точку внутри ячейки.
    • Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.
    • Укажите выбранную ячейку и, удерживая нажатой кнопку мыши, укажите остальные выбираемые ячейки, а затем отпустить кнопку.
  2. Для изменения высоты строки выделенной ячейки необходимо перетащить верхнюю или нижнюю ручку.

    Если выделено несколько ячеек, то высота каждой строки изменится одинаково.

  3. Для изменения ширины столбца выделенной ячейки необходимо перетащить левую или правую ручку.

    Если выделено более одной ячейки, то ширина каждого столбца изменится одинаково.

  4. Чтобы объединить выбранные ячейки, на вкладке ленты "Таблица" или на панели "Таблица" нажмите "Объединить ячейки".

    Выделив несколько строк или столбцов, можно объединять ячейки по строкам или по столбцам.

  5. Нажмите ESC для отмены выделения.


Изменение таблицы с помощью палитры свойств (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Изменение таблицы с помощью палитры свойств

  1. Выберите устройством указания линию сетки таблицы.
  2. Выберите пункт меню "Редактирование" [image] "Свойства".В командной строке введите "окносв".
  3. В палитре свойств укажите значение, которое требуется изменить, и введите или выберите новое значение.

    Свойство изменится в выделенной таблице.

  4. Выведите курсор из палитры свойств и нажмите ESC для отмены выделения.
Панель:Свойства
Ввод команды: ОКНОСВ
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Нажмите кнопку "Свойства".


Процедура разбиения таблицы на части с помощью ручек (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Процедура разбиения таблицы на части с помощью ручек

  1. Выберите устройством указания линию сетки таблицы.
  2. Щелкните на треугольной ручке в центре нижней линии сетки таблицы.
    • Если треугольник расположен острием вниз, функция разбиения таблицы не активна. Новые строки добавляются снизу к текущей таблице.
    • Если треугольник расположен острием вверх, функция разбиения таблицы активна. Максимальная высота таблицы определяется текущим положением нижней строки таблицы. Новые строки добавляются ко второй части таблицы, расположенной справа от главной части таблицы.


Изменение ширины столбца или высоты строки в таблице (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Изменение ширины столбца или высоты строки в таблице

  1. Укажите точку внутри ячейки таблицы в столбце или строчке, которую требуется изменить.

    Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. Нажмите правую кнопку мыши. Нажмите кнопку "Свойства".
  3. В палитре свойств в группе "Ячейка" выберите значение ширины или высоты ячейки и введите новое значение.
  4. Нажмите ESC для отмены выделения.


Добавление столбцов или строк в таблицу (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Добавление столбцов или строк в таблицу

  1. Укажите точку внутри ячейки таблицы там, где необходимо добавить столбец или строчку.

    Можно выбрать одновременно несколько ячеек для добавления нескольких строк или столбцов.

  2. На вкладке ленты "Таблица" или на панели "Таблица" выберите одну из следующих опций:
    • Вставить строку выше. Вставка строки сверху от выделенной ячейки.
    • Вставить строку ниже. Вставка строки снизу от выделенной ячейки.
    • Вставить столбец слева. Вставка столбца слева от выделенной ячейки.
    • Вставить столбец справа. Вставка столбца справа от выделенной ячейки.
    ПримечаниеВ новой строке/столбце применяется тот же стиль ячеек, что и в первоначально выбранной строке/столбце. Для изменения стиля щелкните правой кнопкой мыши на ячейке (ячейках) и выберите "Стиль ячеек".
  3. Нажмите ESC для отмены выделения.
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Нажмите "Строки" или "Столбцы" и выберите способ вставки.


Объединение ячеек в таблице (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание и редактирование таблиц
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Объединение ячеек в таблице

  1. Выделите объединяемые ячейки в таблице любым из следующих способов:
    • Выделите ячейку и, нажав клавишу SHIFT, выберите другую ячейку для выделения этих двух ячеек и всех ячеек, находящихся между ними.
    • Укажите выбранную ячейку и, удерживая нажатой кнопку мыши, укажите остальные выбираемые ячейки, а затем отпустить кнопку.

    Полученная в результате объединенная ячейка должна иметь прямоугольную форму.

  2. На вкладке ленты "Таблица" или на панели "Таблица" нажмите "Объединить ячейки". Создать несколько объединенных ячеек можно каким-либо из следующих способов:
    • Все: объединение всех ячеек в выбранном прямоугольном диапазоне.
    • По строкам: объединение ячеек горизонтально, с удалением вертикальных линий сетки; горизонтальные линии сетки остаются нетронутыми.
    • По столбцам: объединение ячеек вертикально, с удалением горизонтальных линий сетки; вертикальные линии сетки остаются нетронутыми.
  3. Введите текст в новую объединенную ячейку или нажмите ESC для отмены выделения.
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Щелкните на пункте "Объединить" и выберите способ объединения.


Удаление столбцов или строк из таблицы (Процедура)

Создание и редактирование таблиц
Создание и редактирование таблиц
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Удаление столбцов или строк из таблицы

  1. Выберите ячейку, расположенную в столбце или строке, которую требуется удалить.

    Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. Чтобы удалить строки, на вкладке ленты "Таблица" или на панели "Таблица" нажмите "Удалить строки". Чтобы удалить столбцы, на вкладке ленты "Таблица" или на панели "Таблица" нажмите "Удалить столбцы".
    ПримечаниеНевозможно удалить строки и столбцы, в которых содержатся связанные данные.
  3. Нажмите ESC для отмены выделения.
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Столбцы" [image] "Удалить" или "Строки" [image] "Удалить".


Создание и редактирование таблиц (Краткий справочник)

Форматирование многострочного текста во внешнем редакторе
Создание и редактирование таблиц
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание и редактирование таблиц >
Создание и редактирование таблиц
Понятие Процедура Краткий справочник

Команды

ПОЛЕ

Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения

НАЙТИ

Поиск, замена , выбор и показ текста на чертеже

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

СПИСОК

Отображение свойств для выбранных объектов

МТЕКСТ

Создание многострочного текстового объекта

ОРФО

Орфографическая проверка надписей в чертеже

ТАБЛИЦА

Создание пустого объекта-таблицы

ТАБЛРЕД

Редактирование текста в ячейках таблиц

ЭКСПОРТТАБЛ

Экспорт данных таблицы в файл формата CSV

ТАБЛСТИЛЬ

Создание, изменение или определение стилей таблиц

ОБНПОЛЕ

Обновление полей в выбранных объектах чертежа вручную

Системные переменные

CTABLESTYLE

Задание имени текущего стиля таблицы

FIELDDISPLAY

Управление отображением полей на сером фоне

FIELDEVAL

Управление обновлением полей

TABLETOOLBAR

Управление отображением панели "Таблица"

Утилиты

Нет

Ключевые слова для команд

Нет


Создание связи таблицы с внешними данными (Понятие)

Создание и редактирование таблиц
Таблицы
Работа со стилями таблиц
Аннотирование чертежей > Таблицы >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Таблицу можно связать с ячейками в файле Microsoft Excel (XLS, .XLSX или CSV). Можно создать связь с электронной таблицей в целом, отдельной строкой, столбцом, ячейкой или диапазоном ячеек в Excel.

ПримечаниеДля создания связей с данными Microsoft Excel необходимо установить Microsoft Excel. Для создания связей с файлами типа XLSX необходимо установить Microsoft Excel 2007.

Предусмотрены три способа переноса данных из Microsoft Excel в таблицу.

  • В виде формул с присоединением поддерживаемых форматов данных.
  • В виде вычисляемых данных, полученных в результате вычисления формул в Excel (без присоединения поддерживаемых форматов данных).
  • В виде вычисляемых данных, полученных в результате вычисления формул в Excel (с присоединением форматов данных).

В таблице, содержащей связи с данными, вокруг связанных ячеек отображаются индикаторы. При наведении курсора на связь с данными отображается информация о связи с данными.

После изменения связанной электронной таблицы, например, после добавления строки или столбца, можно обновить таблицу на чертеже в соответствии с этим изменением с помощью команды СВЯЗЬОБНОВИТЬ . Аналогично, после изменения таблицы на чертеже можно с помощью той же команды обновить электронную таблицу, приведя ее в соответствие с этим изменением.

По умолчанию редактирование связи с данными заблокировано во избежание непреднамеренных изменений электронной таблицы. Для ячеек можно заблокировать изменение данных, изменение формата или обе операции. Чтобы разблокировать связь с данными, на вкладке ленты "Таблица" или на панели "Таблица" нажмите "Блокирование".

См. также
    • Извлечение данных из чертежей и электронных таблиц


Создание связи таблицы с внешними данными (Процедура)

Создание и редактирование таблиц
Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура создания связи таблицы с внешней электронной таблицей

Процедура удаления связи с внешней электронной таблицей

Процедура настройки именованного диапазона в Microsoft Excel

Процедура создания связи таблицы с именованным диапазоном в Microsoft Excel

Процедура создания связи таблицы с ячейками в Microsoft Excel

Процедура обновления данных чертежа в соответствии с изменениями данных в Microsoft Excel и наоборот

Процедура открытия внешней электронной таблицы по связи с данными


Процедура создания связи таблицы с внешней электронной таблицей (Процедура)

Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура создания связи таблицы с внешней электронной таблицей

  1. Перейдите на вкладку "Аннотирование" [image] панель "Таблицы" [image] "Связь с данными". В командной строке введите связь.
  2. В древовидном представлении диспетчера связей с данными выберите команду "Создать новую связь с данными Excel".
  3. В диалоговом окне "Ввод имени связи с данными" введите имя для связи с данными. Нажмите "ОК".
  4. Нажмите кнопку [...] для поиска файла XLS или CSV, с которым требуется установить связь.
    ПримечаниеДля создания связей с файлами типа XLSX необходимо установить Microsoft Excel 2007.
  5. В диалоговом окне "Новая связь с данными Excel" выберите вариант связи (с целым листом, с диапазоном или с именованным диапазоном Excel). Нажмите "ОК".
  6. Выберите новую связь с данными в древовидном представлении диспетчера связей с данными. Нажмите "ОК".
Ввод команды: СВЯЗЬ


Процедура удаления связи с внешней электронной таблицей (Процедура)

Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура удаления связи с внешней электронной таблицей

  1. Щелчком мыши выберите ячейку в таблице, содержащей связи с данными.
  2. Щелкните правой кнопкой мыши и выберите "Связи с данными" [image] "Разорвать связь с данными".
Ввод команды: СВЯЗЬ


Процедура настройки именованного диапазона в Microsoft Excel (Процедура)

Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура настройки именованного диапазона в Microsoft Excel

  1. В Microsoft Excel откройте требуемую книгу или электронную таблицу.
  2. Выберите диапазон ячеек для задания в качестве связанного диапазона.
  3. В поле "Имя" введите имя диапазона ячеек, затем нажмите клавишу ENTER.
  4. При необходимости повторите шаги 2 и 3 для задания других связанных диапазонов.
  5. В меню "Файл" (Microsoft Excel) выберите "Сохранить".


Процедура создания связи таблицы с именованным диапазоном в Microsoft Excel (Процедура)

Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура создания связи таблицы с именованным диапазоном в Microsoft Excel

  1. Выберите в таблице ячейки, с которыми требуется установить связь.
  2. На вкладке ленты "Таблица" или на панели "Таблица" нажмите "Установление связи ячейки".
  3. В древовидном представлении диспетчера связей с данными выберите команду "Создать новую связь с данными Excel".
  4. В диалоговом окне "Ввод имени связи с данными" введите имя для связи с данными. Нажмите "ОК".
  5. Нажмите кнопку [...] для поиска файла XLS или CSV, с которым требуется установить связь.
  6. В диалоговом окне "Новая связь с данными Excel" выберите "Связь с именованным диапазоном). Нажмите "ОК".
  7. Выберите новую связь с данными в древовидном представлении диспетчера связей с данными. Нажмите "ОК".
Ввод команды: СВЯЗЬ


Процедура создания связи таблицы с ячейками в Microsoft Excel (Процедура)

Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура создания связи таблицы с ячейками в Microsoft Excel

  1. Выберите в таблице ячейки, с которыми требуется установить связь.
  2. На панели инструментов "Таблица" выберите "Установление связи ячейки".
  3. В древовидном представлении диспетчера связей с данными выберите команду "Создать новую связь с данными Excel".
  4. В диалоговом окне "Ввод имени связи с данными" введите имя для связи с данными. Нажмите "ОК".
  5. Нажмите кнопку [...] для поиска файла .xls или .csv, с которым требуется установить связь.
  6. В диалоговом окне "Новая связь с данными Excel" выберите "Связь с диапазоном". Введите допустимый диапазон ячеек электронной таблицы Excel (например, A1:D17). Нажмите "ОК".
  7. Выберите новую связь с данными в древовидном представлении диспетчера связей с данными. Нажмите "ОК".
Ввод команды: СВЯЗЬ


Процедура обновления данных чертежа в соответствии с изменениями данных в Microsoft Excel и наоборот (Процедура)

Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура обновления данных чертежа в соответствии с изменениями данных в Microsoft Excel и наоборот

  1. Перейдите на вкладку "Аннотирование" [image] панель "Таблицы" [image] "Связь с данными". В командной строке введите связь.
  2. В подменю "Связь с данными" выберите "Обновить связи с данными".
Ввод команды: СВЯЗЬ


Процедура открытия внешней электронной таблицы по связи с данными (Процедура)

Создание связи таблицы с внешними данными
Создание связи таблицы с внешними данными
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Процедура открытия внешней электронной таблицы по связи с данными

  1. Выберите любую ячейку в связанной таблице или диапазон связанных ячеек.
  2. Щелкните правой кнопкой мыши и выберите "Связи с данными" [image] "Открытие файла связей с данными".


Создание связи таблицы с внешними данными (Краткий справочник)

Создание и редактирование таблиц
Создание связи таблицы с внешними данными
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Создание связи таблицы с внешними данными >
Создание связи таблицы с внешними данными
Понятие Процедура Краткий справочник

Команды

СВЯЗЬ

Вызов диалогового окна "Связь с данными"

СВЯЗЬОБНОВИТЬ

Обновление данных по организованной связи с внешними данными

Системные переменные

DATALINKNOTIFY

Управление уведомлением об обновленных или отсутствующих связях с данными

Утилиты

Нет

Ключевые слова для команд

Нет


Работа со стилями таблиц (Понятие)

Создание связи таблицы с внешними данными
Таблицы
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Вид таблицы определяется заданным для нее стилем. Можно использовать стиль таблиц СТАНДАРТ, предлагаемый по умолчанию, или создать свои собственные стили таблиц.

При создании нового стиля таблиц можно указать начальную таблицу. Начальная таблица - это таблица на чертеже, которая служит примером при задании формата нового стиля таблиц. После выбора таблицы можно указать компоненты структуры и содержимого, которые требуется скопировать из этой таблицы в стиль таблиц.

Можно создать стили ячеек и применить их к стилю таблиц при вставке новой таблицы. В стиле таблицы можно для каждого типа строк задать отдельный стиль ячеек; в этом случае строки разных типов будут различаться по способу выравнивания, а также по внешнему виду столбцов и линий сетки. Эти стили ячеек задаются при вставке таблицы. Например, стиль таблиц "СТАНДАРТ" содержит стиль ячеек, в котором ячейки объединены, а текст выровнен по центру. Для ячейки первой строки таблицы можно задать стиль ячеек с именем "Название". В этом случае вверху новой таблицы создается строка названия.

Данные в таблице могут располагаться сверху вниз или снизу вверх. Число столбцов и строк практически не ограничено.

Свойства границы, заданные в стиле ячеек таблицы, определяют отображение линий сетки, разделяющих таблицу на ячейки. Границы строки заголовка таблицы, строки заголовков столбцов и строк данных могут иметь различные вес линий и цвет и могут отображаться или не отображаться. При выборе вариантов отображения границ соответствующим образом обновляется образец стиля ячейки в правом нижнем углу таблицы.

Внешний вид текста в ячейках таблицы определяется стилем текста, заданным в текущем стиле ячеек. Можно применить любой текстовый стиль из имеющихся в чертеже или создать новый. С помощью Центра управления можно также копировать стили таблиц из других чертежей.

Для любого стиля ячеек в пределах стиля таблиц можно задать данные и формат. Также имеется возможность переназначить данные и форматирование для определенных ячеек. Например, можно при задании форматирования для всех строк, относящихся к заголовку столбца, выбрать отображение текста в верхнем регистре, а затем выбрать одну ячейку таблицу и задать для нее отображение текста в нижнем регистре. Тип отображаемых в строке данных и формат данных этого типа определяются значениями параметров форматирования, выбранными в диалоговом окне "Формат ячейки таблицы".

См. также

    • Работа с текстовыми стилями


Работа со стилями таблиц (Процедура)

Создание связи таблицы с внешними данными
Работа со стилями таблиц
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Определение или изменение стиля таблиц

Процедура задания или изменения стиля таблиц

Процедура создания стиля таблиц на основе существующей таблицы

Процедура создания стиля ячеек на основе существующей ячейки

Применение к таблице нового стиля

Изменение стиля таблиц, применяемого к новым таблицам


Определение или изменение стиля таблиц (Процедура)

Работа со стилями таблиц
Работа со стилями таблиц
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Определение или изменение стиля таблиц

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль таблиц". В командной строке введите "таблстиль".
  2. В диалоговом окне "Стиль таблиц" нажмите "Новый".
  3. В диалоговом окне "Создание нового стиля таблиц" введите имя для нового стиля таблиц.
  4. В раскрывающемся списке "На основе" выберите стиль таблиц, значения параметров которого будут использоваться по умолчанию для нового стиля таблиц. Нажмите "Продолжить".
  5. В диалоговом окне "Новый стиль таблиц" нажмите кнопку "Выбрать таблицу" для выбора таблицы на чертеже, к которой требуется применить новые параметры стиля таблиц.
  6. В раскрывающемся списке "Направление построения" выберите "Вниз" или "Вверх". При выборе опции "Вверх" таблица будет строиться снизу вверх, а заголовок таблицы и заголовки столбцов будут располагаться внизу таблицы.
  7. В ниспадающем списке "Стили ячеек" выберите стиль ячеек для применения к таблице или создайте новый стиль ячеек, нажав кнопку справа от ниспадающего списка.
  8. На вкладке "Общие" выберите значения указанных ниже параметров текущего стиля ячеек или отмените выбор значений.
    • Цвет заливки. Определяет цвет заливки. Выберите "Нет" или цвет фона или нажмите кнопку "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Выравнивание. Определяет выравнивание содержимого ячеек. Понятие "Центр" относится к выравниванию по горизонтали; понятие "Середина" относится к выравниванию по вертикали.
    • Формат Определяет тип и формат данных для строк в таблице. Нажмите кнопку [...] для вывода на экран диалогового окна "Формат ячеек таблицы", в котором можно определить дополнительные параметры форматирования.
    • Тип. Определяет стиль ячеек, который требуется применять при вставке текста по умолчанию в стиль таблицы, содержащий начальную таблицу; возможные варианты - метка или данные. Это значение применяется также при создании инструмента таблицы на инструментальной палитре.
    • Поля - горизонтальные. Задание расстояния между текстом/блоком и левой и правой границами ячеек.
    • Поля - вертикальные. Задание расстояния между текстом/блоком и верхней и нижней границами ячеек.
    • Объединять ячейки при создании строк/столбцов Объединение любой новой строки (столбца), созданной с применением текущего стиля ячеек, в одну ячейку.
  9. На панели инструментов "Таблица" выберите одну из следующих команд для текущего стиля ячейки.
    • Текстовый стиль. Определяет стиль текста. Выберите текстовый стиль или нажмите кнопку [...] для вызова диалогового окна "Текстовые стили" и создания нового текстового стиля.
    • Высота текста. Определяет высоту текста. Введите значение высоты текста. Эта опция доступна, только если выбранный текстовый стиль имеет значение 0 для высоты текста. (Используемый по умолчанию текстовый стиль СТАНДАРТ имеет значение 0 для высоты текста.) Если в выбранном текстовом стиле задана фиксированная высота текста, то данная опция недоступна.
    • Цвет текста. Определяет цвет текста. Выберите один из стандартных цветов или нажмите кнопку "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Угол строки текста. Определяет угол наклона текста. По умолчанию угол наклона текста составляет 0 градусов. Можно ввести угол в диапазоне от -359 до +359 градусов.
  10. Вкладка "Границы" служит для настройки внешнего вида линий сетки таблицы для текущего стиля ячеек. Задайте значения следующих параметров.
    • Вес линии. Определяет вес линии для отображаемых границ. При использовании больших значений весов линий может понадобиться изменить отступы в ячейках таким образом, чтобы внутри них был виден текст.
    • Тип линии. Определяет тип линии для применения к границам, указанным путем нажатия кнопки границ. Отображаются стандартные типы линий: "ПоБлоку", "ПоСлою" и "Цепь"; можно также выбрать вариант "Другое" для загрузки пользовательского типа линии.
    • Цвет. Определяет цвет для отображаемых границ. Щелкните на элементе "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Двойная линия. Указывает на то, что выбранные границы отображаются в виде двойной линии. Для изменения расстояния между линиями введите значение в поле "Шаг".
    • Кнопки обрамления. Применение выбранных параметров границ. Нажмите соответствующую кнопку для применения выбранных параметров границ ко всем границам ячейки, к наружным границам, к внутренним границам, к нижней границе, к левой границе, к верхней границе или к правой границе либо для отмены применения этих параметров к границам. Область предварительного просмотра в диалоговом окне будет обновляться и отображать результат.
  11. Нажмите "ОК".
Панель:Стили
Ввод команды: ТАБЛСТИЛЬ


Процедура задания или изменения стиля таблиц (Процедура)

Работа со стилями таблиц
Работа со стилями таблиц
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Процедура задания или изменения стиля таблиц

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль таблиц". В командной строке введите "таблстиль".
  2. Выберите стиль таблиц, содержащий стиль ячеек, который требуется изменить, или выберите "Создать" для создания нового стиля таблиц.
  3. В диалоговом окне "Стиль таблицы" в раскрывающемся списке "Стили ячеек" выберите стиль ячеек, который требуется изменить, или создайте новый стиль ячеек путем нажатия кнопки справа от ниспадающего списка.
  4. На вкладке "Общие" выберите значения указанных ниже параметров текущего стиля ячеек или отмените выбор значений.
    • Цвет заливки. Определяет цвет заливки. Выберите "Нет" или цвет фона или нажмите кнопку "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Выравнивание. Определяет выравнивание содержимого ячеек. Понятие "Центр" относится к выравниванию по горизонтали; понятие "Середина" относится к выравниванию по вертикали.
    • Формат Определяет тип и формат данных для строк в таблице. Нажмите кнопку [...] для вывода на экран диалогового окна "Формат ячеек таблицы", в котором можно определить дополнительные параметры форматирования.
    • Тип. Определяет стиль ячеек, который требуется применять при вставке текста по умолчанию в стиль таблицы, содержащий начальную таблицу; возможные варианты - метка или данные. Это значение применяется также при создании инструмента таблицы на инструментальной палитре.
    • Поля - горизонтальные. Задание расстояния между текстом/блоком и левой и правой границами ячеек.
    • Поля - вертикальные. Задание расстояния между текстом/блоком и верхней и нижней границами ячеек.
    • Объединять ячейки при создании строк/столбцов Объединение любой новой строки (столбца), созданной с применением текущего стиля ячеек, в одну ячейку.
  5. На панели инструментов "Таблица" выберите одну из следующих команд для текущего стиля ячейки.
    • Текстовый стиль. Определяет стиль текста. Выберите текстовый стиль или нажмите кнопку [...] для вызова диалогового окна "Текстовые стили" и создания нового текстового стиля.
    • Высота текста. Определяет высоту текста. Введите значение высоты текста. Эта опция доступна, только если выбранный текстовый стиль имеет значение 0 для высоты текста. (Используемый по умолчанию текстовый стиль СТАНДАРТ имеет значение 0 для высоты текста.) Если в выбранном текстовом стиле задана фиксированная высота текста, то данная опция недоступна.
    • Цвет текста. Определяет цвет текста. Выберите один из стандартных цветов или нажмите кнопку "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Угол строки текста. Определяет угол наклона текста. По умолчанию угол наклона текста составляет 0 градусов. Можно ввести угол в диапазоне от -359 до +359 градусов.
  6. Вкладка "Границы" служит для настройки внешнего вида линий сетки таблицы для текущего стиля ячеек. Задайте значения следующих параметров.
    • Вес линии. Определяет вес линии для отображаемых границ. При использовании больших значений весов линий может понадобиться изменить отступы в ячейках таким образом, чтобы внутри них был виден текст.
    • Тип линии. Определяет тип линии для применения к границам, указанным путем нажатия кнопки границ. Отображаются стандартные типы линий: "ПоБлоку", "ПоСлою" и "Непрерывная"; можно также выбрать вариант "Другое" для загрузки пользовательского типа линии.
    • Цвет. Определяет цвет для отображаемых границ. Щелкните на элементе "Выбор цвета" для отображения диалогового окна "Выбор цвета".
    • Двойная линия. Указывает на то, что выбранные границы отображаются в виде двойной линии. Для изменения расстояния между линиями введите значение в поле "Шаг".
    • Кнопки обрамления. Применение выбранных параметров границ. Нажмите соответствующую кнопку для применения выбранных параметров границ ко всем границам ячейки, к наружным границам, к внутренним границам, к нижней границе, к левой границе, к верхней границе или к правой границе либо для отмены применения этих параметров к границам. Область предварительного просмотра в диалоговом окне будет обновляться и показывать результат.
  7. Нажмите "ОК".
Панель:Стили
Ввод команды: ТАБЛСТИЛЬ


Процедура создания стиля таблиц на основе существующей таблицы (Процедура)

Работа со стилями таблиц
Работа со стилями таблиц
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Процедура создания стиля таблиц на основе существующей таблицы

  1. Выберите таблицу, указав линию ее сетки.
  2. Щелкните правой кнопкой мыши и выберите "Стиль таблицы" [image] "Сохранение в качестве нового стиля таблиц".
Панель:Стили
Ввод команды: ТАБЛСТИЛЬ


Процедура создания стиля ячеек на основе существующей ячейки (Процедура)

Работа со стилями таблиц
Работа со стилями таблиц
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Процедура создания стиля ячеек на основе существующей ячейки

  1. Щелкните в ячейке, на основе которой требуется создать стиль ячеек.
  2. Щелкните правой кнопкой мыши и выберите "Стиль ячеек" [image] "Сохранение нового стиля ячеек".
Панель:Стили
Ввод команды: ТАБЛСТИЛЬ


Применение к таблице нового стиля (Процедура)

Работа со стилями таблиц
Работа со стилями таблиц
Работа со стилями таблиц
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Применение к таблице нового стиля

  1. Выберите таблицу, указав линию ее сетки.
  2. Щелкните правой кнопкой мыши и выберите "Стиль таблиц".
  3. В подменю "Стиль таблицы" выберите стиль таблиц из списка.

    Новый стиль таблиц будет применен к таблице.

    ПримечаниеЕсли предыдущий стиль таблиц имел строку заголовка, а новый нет, то текст заголовка будет помещен в первую ячейку таблицы, а другие ячейки в первой строке останутся пустыми.
  4. Дважды нажмите ESC для отмены выделения.
Панель:Стили
Ввод команды: ТАБЛСТИЛЬ


Изменение стиля таблиц, применяемого к новым таблицам (Процедура)

Работа со стилями таблиц
Работа со стилями таблиц
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Изменение стиля таблиц, применяемого к новым таблицам

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Стиль таблиц". В командной строке введите "таблстиль".
  2. В диалоговом окне "Стили таблиц" выберите стиль. Нажмите кнопку "Установить".
  3. Нажмите кнопку "Закрыть".

    Текущий стиль таблиц будет применяться к вновь создаваемым таблицам.

Панель:Стили
Ввод команды: ТАБЛСТИЛЬ


Работа со стилями таблиц (Краткий справочник)

Создание связи таблицы с внешними данными
Работа со стилями таблиц
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Работа со стилями таблиц >
Работа со стилями таблиц
Понятие Процедура Краткий справочник

Команды

НАЙТИ

Поиск, замена , выбор и показ текста на чертеже

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

СПИСОК

Отображение свойств для выбранных объектов

МТЕКСТ

Создание многострочного текстового объекта

ОРФО

Орфографическая проверка надписей в чертеже

ТАБЛИЦА

Создание пустого объекта-таблицы

ТАБЛРЕД

Редактирование текста в ячейках таблиц

ЭКСПОРТТАБЛ

Экспорт данных таблицы в файл формата CSV

ТАБЛСТИЛЬ

Создание, изменение или определение стилей таблиц

ОБНПОЛЕ

Обновление полей в выбранных объектах чертежа вручную

Системные переменные

CTABLESTYLE

Задание имени текущего стиля таблицы

FIELDDISPLAY

Управление отображением полей на сером фоне

FIELDEVAL

Управление обновлением полей

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление в таблицы текста и блоков (Понятие)

Работа со стилями таблиц
Таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Данные в ячейке таблицы могут содержать текст и несколько блоков.

При создании таблицы выделяется первая ячейка и отображается панель инструментов "Формат текста"; после этого можно начать ввод текста. Высота строки ячейки увеличивается с увеличением количества строк текста. Для перехода к следующей ячейке нажмите клавишу табуляции; для перемещения влево, вправо, вверх или вниз воспользуйтесь соответствующими клавишами со стрелками. Для быстрого редактирования текста в ячейке можно выбрать ячейку и нажать клавишу F2.

При вставке блока в ячейку таблицы может выполняться либо автоматическая настройка размеров блока по размерам ячейки, либо настройка размеров ячейки по размерам блока. Блоки можно вставить с помощью панели инструментов "Таблица" или контекстного меню. В одну ячейку таблицы можно вставить несколько блоков. При наличии нескольких блоков в ячейке таблицы настройте формат отображения содержимого ячейки в диалоговом окне "Управление содержимым ячейки".

Внутри ячейки клавиши со стрелками перемещают курсор. Для форматирования текста, импорта текста и внесения других изменений в текст воспользуйтесь панелью инструментов "Таблица" или контекстным меню.

См. также

    • Использование полей в тексте

    • Создание многострочного текста


Добавление в таблицы текста и блоков (Процедура)

Работа со стилями таблиц
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Ввод текста в таблицу

Процедура задания или изменения форматов данных

Изменение свойств ячеек в таблице

Копирование свойств ячейки в другие ячейки

Процедура изменения веса линии, типа линии или цвета для границ ячеек таблицы

Редактирование текста в ячейке таблицы

Вставка блока в ячейку таблицы

Вставка поля в ячейку таблицы


Ввод текста в таблицу (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Ввод текста в таблицу

  1. Укажите точку внутри ячейки таблицы и введите текст.

    Открывается панель "Формат текста".

  2. Для перемещения курсора по тексту внутри ячейки используются клавиши со стрелками.
  3. Для перехода на новую строку в ячейке следует нажать комбинацию клавиш ALT+ ENTER.
  4. Для переопределения текстового стиля, описанного в стиле таблицы, необходимо нажать стрелку рядом со списком "Текстовые стили" на панели инструментов и выбрать новый текстовый стиль.

    Выбранный текстовый стиль применяется к тексту, уже имеющемуся в ячейке, и любому новому тексту, который будет введен в эту ячейку впоследствии.

  5. Для переопределения настроек форматирования текущего текстового стиля необходимо сначала выделить текст одним из следующих способов:
    • Для выделения произвольного фрагмента текста нажмите левую кнопку мыши и, не отпуская ее, выберите курсором требуемый сегмент текста.
    • Для выделения слова нажмите на нем дважды кнопку мыши.
    • Для выделения текста ячейки целиком нажмите кнопку мыши на ячейке трижды. (можно также нажать правую кнопку мыши и выбрать пункт "Выбрать все").
  6. С помощью панели инструментов измените формат следующим образом:
    • Для изменения шрифта выберите нужное значение из списка "Шрифт".
    • Для изменения высоты символов введите новое значение в поле "Высота текста".
    • Для изменения начертания символов на полужирное или курсивное (только для шрифтов TrueType) или создания подчеркнутого или надчеркнутого текста нажмите соответствующую кнопку на панели инструментов. Для SHX-шрифтов полужирное и курсивное начертания не поддерживаются.
    • Для изменения цвета символов выберите нужное значение из списка "Цвет". Нажмите кнопку "Прочие" для отображения диалогового окна "Выбор цвета".
  7. Для перемещения между ячейками можно использовать клавиатуру:
    • Нажмите TAB для перемещения в следующую ячейку. Для добавления новой строчки можно нажать TAB, находясь в последней ячейке.
    • Нажмите SHIFT+TAB для перехода к предыдущей ячейке.
    • Если курсор находится в начале или конце текста ячейки, то использование клавиш со стрелками приведет к переходу в соседние ячейки. Можно также использовать сочетание клавиши CTRL и клавиши со стрелкой.
    • Если текст в ячейке выделен цветом, то нажатие клавиши со стрелкой приведет к снятию выделения и переходу курсора в начало или конец текста ячейки.
    • Для перехода вниз на одну ячейку можно нажать ENTER.
  8. Для сохранения сделанных изменений и выхода нажмите "OK" на панели инструментов или сочетание клавиш CTRL+ ENTER.
Ввод команды: ДИАЛРЕД
Контекстное меню:Выберите ячейку и щелкните на ней правой кнопкой мыши. Выберите "Редактирование текста".


Процедура задания или изменения форматов данных (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Процедура задания или изменения форматов данных

  1. В таблице укажите ячейки, для которых требуется переопределить тип данных и форматирование.
  2. На панели инструментов "Таблица" выберите "Формат данных".
  3. Выберите тип данных, формат и другие параметры для выбранных ячеек таблицы.
  4. Введите данные в выбранные ячейки таблицы. Выбранные значения типа и формата данных определяют вариант отображения данных.
  5. Нажмите "ОК".
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Формат данных".


Изменение свойств ячеек в таблице (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Изменение свойств ячеек в таблице

  1. Укажите ячейку таблицы, которую следует изменить.

    Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. Воспользуйтесь одним из следующих способов:
    • Для изменения одного или большего количества свойств в палитре свойств укажите значение, которое требуется изменить, и введите или выберите новое значение.
    • Для восстановления свойств по умолчанию нажмите правую кнопку мыши. Выберите "Снять переопределения свойств".
Панель:Свойства
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Нажмите кнопку "Свойства".


Копирование свойств ячейки в другие ячейки (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Копирование свойств ячейки в другие ячейки

  1. Укажите ячейку таблицы, свойства которой надо скопировать.
  2. (Не обязательно) Для просмотра текущих свойств выбранной ячейки таблицы можно воспользоваться сочетанием клавиш CTRL+1, чтобы открыть палитру свойств.

    Будут скопированы все свойства ячейки за исключением типа ячейки: текстовая или блоковая.

  3. На панели инструментов "Таблица" выберите "Формат по образцу".

    Курсор примет форму кисти.

  4. Для копирования свойств в другую ячейку таблицы чертежа необходимо указать точку внутри этой ячейки.
  5. Нажмите правую кнопку мыши или нажмите клавишу ESC для прекращения копирования свойств.
Ввод команды: КОПИРОВАТЬЯЧСВ
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Формат по образцу".


Процедура изменения веса линии, типа линии или цвета для границ ячеек таблицы (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Процедура изменения веса линии, типа линии или цвета для границ ячеек таблицы

  1. Укажите ячейку таблицы, которую надо изменить.

    Нажав клавишу SHIFT, выберите другую ячейку для выделения вместе с указанными ячейками всех ячеек, находящихся между ними.

  2. На панели инструментов "Таблица" выберите "Границы ячеек".
  3. В диалоговом окне "Свойства границ ячеек" выберите вес линии, тип линии и цвет. Для задания границы в виде двойной линии выберите "Двойная линия".

    Для соответствия свойств границ параметрам стиля таблиц, который был применен к таблице, используйте значение "ПОБЛОКУ".

  4. Нажмите одну из кнопок типа границы для определения границ, которые надо изменить, или выделите границы в области предварительного просмотра.
  5. Нажмите "ОК".
  6. Выведите курсор из палитры свойств и нажмите ESC для отмены выделения или выберите другую ячейку.
Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Границы".


Редактирование текста в ячейке таблицы (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Редактирование текста в ячейке таблицы

  1. Дважды щелкните внутри ячейки, в которой требуется отредактировать текст, или выберите эту ячейку, щелкните правой кнопкой мыши и выберите "Редактировать ячейку".
    ПримечаниеДля редактирования текста в ячейке можно также выбрать ячейку и нажать клавишу F2.
  2. Для внесения изменений можно воспользоваться панелью "Формат текста" или контекстным меню.
  3. Для сохранения сделанных изменений и выхода нажмите "OK" на панели инструментов, воспользуйтесь сочетанием клавиш CTRL+ENTER или укажите точку вне ячейки.
  4. Для снятия выделения таблицы нажмите клавишу ESC.
Ввод команды: ДИАЛРЕД
Контекстное меню:Выберите ячейку и щелкните на ней правой кнопкой мыши. Выберите "Редактировать ячейку".


Вставка блока в ячейку таблицы (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Вставка блока в ячейку таблицы

  1. На панели инструментов "Таблица" выберите "Вставить блок".
  2. В диалоговом окне "Вставка блока в ячейку таблицы" выберите блок из списка блоков чертежа или нажмите кнопку "Обзор", чтобы найти блок в другом чертеже.
  3. Задайте следующие свойства для блока:
    • Способ выравнивания Задание параметров выравнивания для блока в ячейке таблицы. Относительно верхней и нижней границы ячейки блок можно выравнивать по середине, по верхнему краю или по нижнему краю. Горизонтальное выравнивание блока может осуществляться по центру, по правому и левому краям ячейки.
    • Масштаб Масштаб для вставки блока. Введите значение масштаба или выберите опцию "Вписать" для автоматического подбора масштаба по величине ячейки.
    • Угол поворота блока Угол поворота блока.
  4. Нажмите "ОК".

    Если блок имеет атрибуты, открывается диалоговое окно "Редактирование атрибутов".

Контекстное меню:Выберите ячейку и щелкните на ней правой кнопкой мыши. Выберите "Вставить" [image] "Блок".


Вставка поля в ячейку таблицы (Процедура)

Добавление в таблицы текста и блоков
Добавление в таблицы текста и блоков
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Вставка поля в ячейку таблицы

  1. Дважды нажмите кнопку мыши внутри ячейки таблицы.
  2. На панели инструментов "Таблица" выберите "Вставка поля"; можно также нажать комбинацию клавиш CTRL+F.
  3. В диалоговом окне "Поле" выберите категорию в списке "Категории полей" для отображения имен полей в данной категории.
  4. Выберите поле.
  5. Выберите формат или задайте другие настройки, доступные для данного поля.
  6. Нажмите "ОК".
Ввод команды: ПОЛЕ
Контекстное меню:Выберите ячейку и щелкните на ней правой кнопкой мыши. Выберите "Вставить" [image] "Поле".


Добавление в таблицы текста и блоков (Краткий справочник)

Работа со стилями таблиц
Добавление в таблицы текста и блоков
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Добавление в таблицы текста и блоков >
Добавление в таблицы текста и блоков
Понятие Процедура Краткий справочник

Команды

ПОЛЕ

Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения

НАЙТИ

Поиск, замена , выбор и показ текста на чертеже

ВСТАВИТЬ

Вставка блока или чертежа в текущий чертеж

СПИСОК

Отображение свойств для выбранных объектов

КОПИРОВАТЬЯЧСВ

Копирование свойства выбранной ячейки таблицы в другие ячейки

МТЕКСТ

Создание многострочного текстового объекта

ОРФО

Орфографическая проверка надписей в чертеже

ТАБЛИЦА

Создание пустого объекта-таблицы

ТАБЛРЕД

Редактирование текста в ячейках таблиц

ЭКСПОРТТАБЛ

Экспорт данных таблицы в файл формата CSV

ТАБЛСТИЛЬ

Создание, изменение или определение стилей таблиц

ОБНПОЛЕ

Обновление полей в выбранных объектах чертежа вручную

Системные переменные

CTABLESTYLE

Задание имени текущего стиля таблицы

FIELDDISPLAY

Управление отображением полей на сером фоне

FIELDEVAL

Управление обновлением полей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование формул в ячейках таблицы (Понятие)

Добавление в таблицы текста и блоков
Таблицы
Размеры и допуски
Аннотирование чертежей > Таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

В ячейках таблицы могут содержаться формулы, использующие для расчетов величины, содержащиеся в других ячейках таблицы.

При наличии в таблице выбранной ячейки можно вставлять формулы с помощью панели инструментов "Таблица" или контекстного меню. Можно также открыть контекстный редактор и ввести формулу в ячейку таблицы вручную.

Вставка формулы

В формулах ячейки обозначаются с помощью буквы столбца и номера строки. Например, ячейка в левом верхнем углу имеет обозначение A1. При объединении нескольких ячеек в одну ей присваивается обозначение левой верхней ячейки. Диапазон ячеек определяется с помощью первой и последней ячеек, разделенных двоеточием. Например, в диапазон A5:C10 включены ячейки строк 5-10 и столбцов A, B и C.

Формула должна начинаться со знака равенства (=). В формулах, использующихся для суммирования, определения средних значений и подсчета пустые ячейки и ячейки, не содержащие цифрового значения, игнорируются. Другие формулы выдают ошибку (#), если какая-либо ячейка арифметического выражения пуста или содержит нецифровые данные.

Для выбора ячейки из другой таблицы в том же чертеже используется параметр "Ячейка". После выбора ячейки открывается контекстный редактор, в котором можно ввести оставшуюся часть формулы. Можно также ввести формулу с помощью панели инструментов "Таблица".

Копирование формулы

При копировании формулы в другую ячейку таблицы диапазон изменяется для отображения нового местоположения. Например, при перемещении формулы из ячейки A10, используемой для суммирования значений в ячейках A1-A9, в ячейку B10 диапазон ячеек изменяется, и формула используется для суммирования значений в ячейках B1-B9.

Если при копировании и вставке формулы адрес ячейки изменять не требуется, добавьте значок доллара ($) в часть адреса, указывающую на строку или на столбец. Например, при вводе $A10 значение столбца останется прежним, а значение строки изменится. При вводе $A$10 значения столбца и строки останутся прежними.

Автоматическая вставка данных

С помощью ручки автоматического заполнения можно задать автоматическое пошаговое приращение данных в смежных ячейках. Например, в таблице со столбцом дат можно ввести даты автоматически; для этого следует ввести первую из требуемых дат и перетащить курсором мыши ручку автоматического заполнения.

Если выбрана одна ячейка с числовым значением, при ее перетаскивании автоматически вводятся числовые значения с шагом 1. Аналогичным образом выполняется ввод дат с шагом в один день, если выбрана только одна ячейка. Если в две ячейки вручную введены даты, отстоящие друг от друга на одну неделю, в остальные ячейки вводятся значения с шагом в одну неделю.

Демонстрация: автоматическая вставка данных

Для запуска анимации нажмите стрелку "Просмотр".

См. также

    • Использование полей в тексте


Использование формул в ячейках таблицы (Процедура)

Добавление в таблицы текста и блоков
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Суммирование значений в диапазоне ячеек таблицы

Получение среднего значения в диапазоне ячеек таблицы

Подсчет ячеек в столбце или строке таблицы

Использование в формуле ячейки из другой таблицы

Ввод формулы в ячейку таблицы вручную

Отключение отображения букв столбцов и номеров строк

Изменение цвета фона букв столбцов и номеров строк таблиц

Вставка поля формулы в ячейку таблицы

Процедура автоматического заполнения ячеек данными с шагом приращения


Суммирование значений в диапазоне ячеек таблицы (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Суммирование значений в диапазоне ячеек таблицы

  1. Щелчком мыши выберите в таблице ячейку, в которой требуется поместить формулу. Отображается панель инструментов "Таблица".
  2. На панели инструментов "Таблица" выберите "Вставка формулы" [image] "Сумма".

    В командной строке отображается следующий запрос:

    Выберите первый угол диапазона ячеек таблицы:

  3. Укажите точку внутри первой ячейки в диапазоне.

    В командной строке выдается следующий запрос:

    Выберите второй угол диапазона ячеек таблицы:

  4. Укажите точку внутри последней ячейки в диапазоне.

    Откроется контекстный редактор и отобразится формула в ячейке.

  5. При необходимости отредактируйте формулу.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится сумма значений всего диапазона ячеек. Пустые ячейки и ячейки, не содержащие цифрового значения, игнорируются.

Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Вставить" [image] "Формула" [image] "Сумма".


Получение среднего значения в диапазоне ячеек таблицы (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Получение среднего значения в диапазоне ячеек таблицы

  1. Щелчком мыши выберите в таблице ячейку, в которой требуется поместить формулу. Отображается панель инструментов "Таблица".
  2. На панели инструментов "Таблица" выберите "Вставка формулы" [image] "Среднее".

    В командной строке отображается следующий запрос:

    Выберите первый угол диапазона ячеек таблицы:

  3. Укажите точку внутри первой ячейки в диапазоне.

    В командной строке выдается следующий запрос:

    Выберите второй угол диапазона ячеек таблицы:

  4. Укажите точку внутри последней ячейки в диапазоне.

    Откроется контекстный редактор и отобразится формула в ячейке.

  5. При необходимости отредактируйте формулу.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится среднее значение для всего диапазона ячеек. Пустые ячейки и ячейки, не содержащие цифрового значения, игнорируются.

Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Вставить" [image] "Формула" [image] "Среднее".


Подсчет ячеек в столбце или строке таблицы (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Подсчет ячеек в столбце или строке таблицы

  1. Щелчком мыши выберите в таблице ячейку, в которой требуется поместить формулу. Отображается панель инструментов "Таблица".
  2. На панели инструментов "Таблица" выберите "Вставка формулы" [image] "Количество".

    В командной строке отображается следующий запрос:

    Выберите первый угол диапазона ячеек таблицы:

  3. Укажите точку внутри первой ячейки в диапазоне.

    В командной строке выдается следующий запрос:

    Выберите второй угол диапазона ячеек таблицы:

  4. Укажите точку внутри последней ячейки в диапазоне.

    Откроется контекстный редактор и отобразится формула в ячейке.

  5. При необходимости отредактируйте формулу.
  6. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится общее число ячеек в диапазоне.

Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Вставить" [image] "Формула" [image] "Количество".


Использование в формуле ячейки из другой таблицы (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Использование в формуле ячейки из другой таблицы

  1. Щелчком мыши выберите в таблице ячейку, в которой требуется поместить формулу. Отображается панель инструментов "Таблица".
  2. На панели инструментов "Таблица" выберите "Вставка формулы" [image] "Ячейка".

    В командной строке выдается следующий запрос:

    Выберите ячейку таблицы:

  3. Укажите точку внутри ячейки из другой таблицы.

    Откроется контекстный редактор и отобразится адрес ячейки.

  4. Введите оставшуюся часть формулы.
  5. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов.
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится результат вычисления.

Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Вставить" [image] "Формула" [image] "Ячейка".


Ввод формулы в ячейку таблицы вручную (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Ввод формулы в ячейку таблицы вручную

  1. Дважды нажмите кнопку мыши внутри ячейки таблицы.

    Откроется контекстный редактор.

  2. Введите формулу (функцию или арифметическое выражение), как показано в следующих примерах.
    • =sum(a1:a25,b1). Суммирует значения в 25 строках столбца A и в первой строке столбца B.
    • =average(a100:d100). Вычисляет среднее значение в первых 4 столбцах строки 100.
    • =count(a1:m500). Отображает общее число ячеек в столбцах A-M строк 1-100.
    • =(a6+d6)/e1. Суммирует значения в A6 и D6, а затем делит результат на значение в E1.

      Для задания диапазона ячеек используется двоеточие, а для отдельных ячеек - запятая. Формула должна начинаться со знака равенства (=) и может содержать любой из следующих знаков: знак плюс (+), знак минус (-), знак умножения (*), знак деления (/), знак возведения в степень (^) и скобки ().

  3. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится результат вычисления.

Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Вставить" [image] "Формула" [image] "Уравнение".


Отключение отображения букв столбцов и номеров строк (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Отключение отображения букв столбцов и номеров строк

  1. В командной строке введите tableindicator.
  2. В ответ на запрос "Введите новое значение" введите 0.

Если для параметра TABLEINDICATOR установлено значение 1, при выборе ячейки буквы столбца и номера строк отображаются в контекстном редакторе.

Ввод команды: TABLEINDICATOR


Изменение цвета фона букв столбцов и номеров строк таблиц (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Изменение цвета фона букв столбцов и номеров строк таблиц

  1. Укажите линию сетки, чтобы выберите таблицу.
  2. Нажмите правую кнопку мыши. Выберите "Цвет индикатора таблицы".
  3. В диалоговом окне "Выбор цвета" выберите цвет.
  4. Нажмите "ОК".

    Цвет, размер, стиль текста и цвет строки указаны в настройках заголовков столбцов в текущем стиле таблицы.


Вставка поля формулы в ячейку таблицы (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Вставка поля формулы в ячейку таблицы

  1. Щелкните внутри ячейки таблицы.
  2. На панели инструментов "Таблица" выберите "Вставка поля".
  3. В диалоговом окне "Поле" в списке "Категории полей" выберите "Объекты".
  4. В списке "Имена полей" выберите "Формула".
  5. Для ввода формулы можно использовать любой из следующих способов один или несколько раз:
    • Нажмите "Среднее", "Сумма" или "Кол-во". Диалоговое окно "Поле" временно закроется. Для указания диапазона укажите точку внутри первой и последней ячейки. Результат добавляется в формулу.
    • Нажмите "Ячейка". Диалоговое окно "Поле" временно закроется. Выберите ячейку в таблице на чертеже. Адрес ячейки добавится в формулу.
  6. (Не обязательно) Выберите формат и десятичный разделитель.
  7. Нажмите "ОК".
  8. Для сохранения текста и выхода из редактора воспользуйтесь одним из следующих приемов:
    • Нажать "ОК" на панели "Форматирование текста".
    • Указать точку на чертеже вне окна редактора.
    • Нажмите клавиши CTRL+ENTER.

    В ячейке отобразится результат вычисления.

Контекстное меню:Выберите ячейку или диапазон ячеек и щелкните на выбранных ячейках правой кнопкой мыши. Выберите "Вставить" [image] "Формула".


Процедура автоматического заполнения ячеек данными с шагом приращения (Процедура)

Использование формул в ячейках таблицы
Использование формул в ячейках таблицы
Основные понятия
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Процедура автоматического заполнения ячеек данными с шагом приращения

  1. Дважды нажмите кнопку мыши внутри ячейки таблицы.
  2. Введите числовое значение, например, 1 или 01/01/2000.
  3. Нажмите стрелку вниз и введите следующее числовое значение.
  4. На панели инструментов "Формат текста" нажмите "ОК".

    Для изменения формата данных в ячейке щелкните правой кнопкой мыши на этой ячейке. Выберите пункт "Формат данных".

  5. Выберите одну или несколько ячеек, с которых требуется начать приращение данных.
  6. Щелкните на ручке в правом нижнем углу ячейки или диапазона ячеек.

    Для изменения параметров автоматического заполнения щелкните на ручке автоматического заполнения в правом нижнем углу выбранного диапазона ячеек правой кнопкой мыши и выберите один из следующих вариантов.

    • Вставить последовательность. В диапазоне выбранных ячеек выполняется поиск закономерности, затем в ячейки вводятся последующие значения с учетом формата. Если в качестве значения, с которого требуется начать приращение данных, выбрана только одна ячейка, применяется приращение с шагом в одну единицу.
    • Вставить последовательность без форматирования. Выполняются указанные выше действия, но без форматирования ячеек.
    • Копировать ячейки. Выполняется копирование формата и значений в выбранных ячейках.
    • Копировать ячейки без форматирования. Выполняются указанные выше действия, но без форматирования ячеек.
    • Применить только форматирование. Копируется только формат выбранных ячеек. Значения в ячейках игнорируются.
  7. Перетащите ручку через ячейки, которые требуется автоматически заполнить данными с пошаговым приращением. Справа от выбранной ручки отображается поле предварительного просмотра значения текущей ячейки.


Использование формул в ячейках таблицы (Краткий справочник)

Добавление в таблицы текста и блоков
Использование формул в ячейках таблицы
Коротко о нанесении размеров
Аннотирование чертежей > Таблицы > Использование формул в ячейках таблицы >
Использование формул в ячейках таблицы
Понятие Процедура Краткий справочник

Команды

ПОЛЕ

Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения

МТЕКСТ

Создание многострочного текстового объекта

ТАБЛИЦА

Создание пустого объекта-таблицы

ЭКСПОРТТАБЛ

Экспорт данных таблицы в файл формата CSV

ТАБЛСТИЛЬ

Создание, изменение или определение стилей таблиц

ОБНПОЛЕ

Обновление полей в выбранных объектах чертежа вручную

Системные переменные

CTABLESTYLE

Задание имени текущего стиля таблицы

FIELDDISPLAY

Управление отображением полей на сером фоне

FIELDEVAL

Управление обновлением полей

TABLEINDICATOR

Управление отображением номеров строк и букв столбцов при открытии контекстного текстового редактора для изменения ячейки таблицы

Утилиты

Нет

Ключевые слова для команд

Нет


Размеры и допуски

Использование формул в ячейках таблицы
Аннотирование чертежей
Основные понятия
Аннотирование чертежей >
Размеры и допуски

Имеется множество команд, предназначенных для нанесения и форматирования размеров на чертеже. Для быстрого форматирования размеров и обеспечения их соответствия государственным стандартам и стандартам предприятия используйте размерные стили.

Темы в этом разделе

  • Основные понятия

    Имеется возможность проставления различных типов размеров, которые можно форматировать путем задания размерных стилей или редактирования отдельных размерных объектов.

  • Размерные стили

    Изменяя определенные параметры, можно управлять внешним видом размеров. При этом использование размерных стилей позволяет быстро форматировать размеры, обеспечивая их соответствие государственным стандартам и стандартам предприятия.

  • Задание масштаба размеров

    Имеется возможность задания масштаба для вывода размерных элементов. Устанавливаемый масштаб зависит от используемого способа компоновки и печати чертежа.

  • Нанесение размеров

    Имеется возможность нанесения всех стандартных типов размеров.

  • Редактирование размеров

    Редактирование нанесенных размеров может осуществляться либо отдельно для каждого размерного объекта, либо глобально путем изменения размерных стилей.

  • Нанесение допусков формы и расположения

    Имеется возможность нанесения допусков формы и расположения, выражающих отклонения формы, контура, ориентации и расположения элементов чертежа.


Основные понятия

Размеры и допуски
Размеры и допуски
Коротко о нанесении размеров
Аннотирование чертежей > Размеры и допуски >
Основные понятия
Понятие Процедура

Имеется возможность проставления различных типов размеров, которые можно форматировать путем задания размерных стилей или редактирования отдельных размерных объектов.

Темы в этом разделе

  • Коротко о нанесении размеров
  • Размерные элементы

    Здесь перечисляются элементы, составляющие размеры, и даются их краткие описания.

  • Ассоциативные размеры

    Размеры могут быть ассоциативными, неассоциативными и расчлененными. Ассоциативные размеры настраиваются в соответствии с изменениями объектов, к которым они относятся.


Основные понятия (Процедура)

Использование формул в ячейках таблицы
Основные понятия
Коротко о нанесении размеров
Аннотирование чертежей > Размеры и допуски > Основные понятия >
Основные понятия
Понятие Процедура

Создание размера

Включение-отключение ассоциативности размеров по умолчанию


Коротко о нанесении размеров (Понятие)

Основные понятия
Основные понятия
Размерные элементы
Аннотирование чертежей > Размеры и допуски > Основные понятия >
Коротко о нанесении размеров
Понятие Процедура Краткий справочник

Нанесение размеров является важным этапом в разработке конструкторской документации.

Размеры можно создавать для разных типов объектов, которые могут быть ориентированы разным образом. Существуют следующие основные типы нанесения размеров.

  • Линейный
  • Радиальный (радиус, диаметр, с изломом)
  • Угловой
  • Ординатный
  • Длина дуги

Линейные размеры могут быть горизонтальными, вертикальными, параллельными, повернутыми, базовыми или в виде цепей. Некоторые примеры приведены на чертеже.

ПримечаниеДля упрощения организации чертежа и изменения масштаба размера рекомендуется создавать размеры на листах, а не в пространстве модели.


Создание размера (Процедура)

Основные понятия
На уровень вверх ..
Ассоциативные размеры
Аннотирование чертежей > Размеры и допуски > Основные понятия > Коротко о нанесении размеров >
Коротко о нанесении размеров
Понятие Процедура Краткий справочник

Создание размера

  1. Создайте слой, предназначенный для размеров, и сделайте его текущим.
  2. В левом нижнем углу окна приложения выберите вкладку разметки листа.
  3. Выберите меню "Размер". Выберите вариант размера.
  4. Отвечайте на запросы команды.
Ввод команды: РЗМЛИНЕЙНЫЙ,РЗМРАДИУС, РЗМУГЛОВОЙ


Коротко о нанесении размеров (Краткий справочник)

Использование формул в ячейках таблицы
Коротко о нанесении размеров
Размерные элементы
Аннотирование чертежей > Размеры и допуски > Основные понятия > Коротко о нанесении размеров >
Коротко о нанесении размеров
Понятие Процедура Краткий справочник

Команды

РЗМУГЛОВОЙ

Нанесение угловых размеров

РЗМДУГА

Создает размер длины дуги

РЗМРАЗОРВАТЬ

Разрыв или восстановление размерных или выносных линий, пересекающих другие объекты

РЗМДИАМЕТР

Нанесение диаметра окружности или дуги

РЗМРЕД

Редактирование размерного текста и выносных линий

РЗМИНСПЕКТ

Добавление или удаление рамки с контрольными данными для выбранного размера

РЗМИЗЛОМ

Нанесение размеров с изломом для окружностей и дуг

РЗМИЗЛИНИЯ

Добавление или удаление линий с изломом к линейному или выровненному размеру

РЗМЛИНЕЙНЫЙ

Нанесение линейного размера

РЗМОРДИНАТА

Нанесение ординатных размеров

РЗМРАДИУС

Нанесение радиуса окружности или дуги

РЗМПРИКРЕПИТЬ

Ассоциирование выбранных размеров с геометрическими объектами

РЗМСМЕЩ

Корректировка расстояния между линейными или угловыми размерами

РЗМСТИЛЬ

Создание и модификация размерных стилей

РЗМРЕДТЕКСТ

Перенос и поворот размерного текста, изменение местоположения размерной линии

ОКНОСВ

Управление свойствами объектов

БРАЗМЕР

Быстрое создание серии размеров из выбранного объекта

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Размерные элементы (Понятие)

Коротко о нанесении размеров
Основные понятия
Ассоциативные размеры
Аннотирование чертежей > Размеры и допуски > Основные понятия >
Размерные элементы
Понятие Краткий справочник

Здесь перечисляются элементы, составляющие размеры, и даются их краткие описания.

Размеры содержат в себе следующие элементы: размерный текст, размерные линии, выносные линии и стрелки.

Размерный текст указывает величину размера. Размерный текст может включать в себя различные специальные обозначения в виде префиксов и суффиксов, а также допуски.

Размерные линии графически показывают величину размера и его ориентацию на чертеже. В случае углового размера размерная линия представляет собой дугу.

Стрелки ограничивают размерную линию и изображаются на ее концах. Можно задавать размеры и форму стрелок, а также использовать другие обозначения, такие как засечки и точки.

Выносные линии проводятся от объекта к размерной линии.

Маркер центра имеет вид крестика для обозначения центра круга или дуги.

Центровые линии исходят из маркера центра и имеют разрывы в точке центра.


Размерные элементы (Краткий справочник)

Коротко о нанесении размеров
Размерные элементы
Ассоциативные размеры
Аннотирование чертежей > Размеры и допуски > Основные понятия > Размерные элементы >
Размерные элементы
Понятие Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Ассоциативные размеры (Понятие)

Размерные элементы
Основные понятия
Размерные стили
Аннотирование чертежей > Размеры и допуски > Основные понятия >
Ассоциативные размеры
Понятие Процедура Краткий справочник

Размеры могут быть ассоциативными, неассоциативными и расчлененными. Ассоциативные размеры настраиваются в соответствии с изменениями объектов, к которым они относятся.

Ассоциативность размеров заключается в их связи с геометрическими объектами с нанесенными размерами. Существует три типа ассоциативности между объектами и размерами.

  • Ассоциативные размеры. Автоматически изменяют свое положение, ориентацию и значения величин при редактировании ассоциированных с ними геометрических объектов. Размеры в пространстве листа могут ассоциироваться с объектами в пространстве модели. Для системной переменной DIMASSOC установлено значение 2.
  • Неассоциативные размеры. Выделяются и редактируются вместе с измеряемыми геометрическими объектами. Изменение объектов не оказывает никакого действия на неассоциативные размеры. Системная переменная DIMASSOC равна 1.
  • Расчлененные размеры. Содержат не единые размерные объекты, а наборы отдельных объектов. Для системной переменной DIMASSOC установлено значение 0.

Определить наличие ассоциативной связи размера с объектом можно, выбрав размер и выполнив одно из следующих действий:

  • Посмотреть свойства размера на палитре свойств.
  • Воспользоваться командой СПИСОК для получения значений свойств размера.

Можно также с помощью диалогового окна "Быстрый выбор" выполнить выбор ассоциативных или неассоциативных размеров с применением соответствующего фильтра. Размер считается ассоциативным, даже если с объектом с нанесенными размерами ассоциирован только один его конец. Для отображения ассоциативных или неассоциативных элементов размера можно воспользоваться командой РЗМПРИКРЕПИТЬ.

Особые случаи и ограничения

После панорамирования или зумирования с помощью кнопки-колесика мыши, открытия чертежа, отредактированного и сохраненного в более ранних версиях программы, а также после открытия чертежа с отредактированными внешними ссылками следует использовать команду РЗМРЕГЕН для обновления ассоциативных размеров.

Ассоциативные размеры могут использоваться для многих объектов, однако они неприменимы для следующих типов объектов:

  • штриховки
  • мультилинии
  • двумерные фигуры
  • объекты с ненулевой трехмерной высотой
  • Изображения
  • Подложки DWF

При выборе объектов для нанесения ассоциативных размеров следует следить, чтобы в набор не входили перекрывающиеся объекты, которые не поддерживают ассоциативные размеры, например, 2D фигура.

Ассоциативность не сохраняется между размером и вхождением блока после того, как блок переопределен.

Ассоциативность не сохраняется между размером и 3D телом после того, как 3D тело изменяется.

Размеры, нанесенные с помощью команды БРАЗМЕР, не являются ассоциативными, но могут быть преобразованы в ассоциативные в индивидуальном порядке командой РЗМПРИКРЕПИТЬ.

ПримечаниеВ прежних редакциях (более ранних по сравнению с AutoCAD 2002) применялись другие определения ассоциативных и неассоциативных размеров; ассоциативность определялась значением системной переменной DIMASO. Теперь же ассоциативность устанавливается системной переменной DIMASSOC.

Подробнее о работе с ассоциативными размерами предыдущих версий см. раздел Сохранение чертежей в форматах прежних версий.

См. также

    • Изменение ассоциативности размеров


Включение-отключение ассоциативности размеров по умолчанию (Процедура)

Коротко о нанесении размеров
На уровень вверх ..
Размерные стили
Аннотирование чертежей > Размеры и допуски > Основные понятия > Ассоциативные размеры >
Ассоциативные размеры
Понятие Процедура Краткий справочник

Включение-отключение ассоциативности размеров по умолчанию

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Параметры" на вкладке "Пользовательские" в разделе "Ассоциативные размеры" установите или снимите флажок "Делать новые размеры ассоциативными".
  3. Выполните хотя бы одно из предлагаемых действий:
    • Нажмите кнопку "Применить" для сохранения текущих настроек в системном реестре.
    • Нажмите кнопку "OK" для сохранения текущих настроек в системном реестре и закрытия диалогового окна "Параметры".

Все новые размеры создаются с учетом заданных настроек. В отличие от большинства параметров, опция ассоциативности размеров сохраняется в самом чертеже.

Ввод команды: НАСТРОЙКА


Ассоциативные размеры (Краткий справочник)

Размерные элементы
Ассоциативные размеры
Коротко о размерных стилях
Аннотирование чертежей > Размеры и допуски > Основные понятия > Ассоциативные размеры >
Ассоциативные размеры
Понятие Процедура Краткий справочник

Команды

РЗМОТКРЕПИТЬ

Отмена ассоциативности выбранных размеров

РЗМПРИКРЕПИТЬ

Ассоциирование выбранных размеров с геометрическими объектами

РЗМРЕГЕН

Обновление расположения всех ассоциативных размеров

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

СПИСОК

Отображение свойств для выбранных объектов

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Размерные стили

Ассоциативные размеры
Размеры и допуски
Коротко о размерных стилях
Аннотирование чертежей > Размеры и допуски >
Размерные стили
Понятие Процедура

Изменяя определенные параметры, можно управлять внешним видом размеров. При этом использование размерных стилей позволяет быстро форматировать размеры, обеспечивая их соответствие государственным стандартам и стандартам предприятия.

Темы в этом разделе

  • Коротко о размерных стилях
  • Сравнение размерных стилей и переменных

    Имеется возможность просмотра всех свойств размерного стиля. Размерные стили, описанные в чертежах, вставленных как внешние ссылки, обрабатываются отдельно от размерных стилей текущего чертежа.

  • Редактирование размерных стилей

    Имеется возможность управления отображением размерных линий, выносных линий, стрелок и маркеров центра.

  • Управление размерным текстом

    Имеется возможность управления размещением размерного текста, стрелок и линий выносок относительно размерных и выносных линий.

  • Форматирование размерных значений

    Для отображения значений размерных чисел можно задавать различные параметры форматирования. Также имеется возможность управления представлением расстояния между числами.


Размерные стили (Процедура)

Ассоциативные размеры
Размерные стили
Коротко о размерных стилях
Аннотирование чертежей > Размеры и допуски > Размерные стили >
Размерные стили
Понятие Процедура

Выбор текущего размерного стиля

Процедура создания подчиненного стиля размеров

Получение списка всех параметров текущего размерного стиля

Получение списка параметров имеющегося размерного стиля

Получение списка размерных стилей в текущем чертеже

Сравнение размерных стилей


Коротко о размерных стилях (Понятие)

Размерные стили
Размерные стили
Сравнение размерных стилей и переменных
Аннотирование чертежей > Размеры и допуски > Размерные стили >
Коротко о размерных стилях
Понятие Процедура Краткий справочник

Размерный стиль - это именованный набор размерных параметров, управляющих внешним видом размеров, например стилем стрелок, расположением текста и двусторонними допусками. Использование размерных стилей позволяет быстро форматировать размеры, обеспечивая их соответствие государственным стандартам и стандартам предприятия.

  • При нанесении размера используются параметры текущего размерного стиля
  • При изменении параметров размерного стиля все размеры на чертеже, использующие этот стиль, обновляются автоматически
  • Можно создать размерные подстили для указанных типов размеров, которые отличаются от текущего размерного стиля
  • При необходимости размерный стиль можно на время переопределить.


Коротко о размерных стилях (Процедура)

Размерные стили
На уровень вверх ..
Коротко о размерных стилях
Аннотирование чертежей > Размеры и допуски > Размерные стили > Коротко о размерных стилях >
Коротко о размерных стилях
Понятие Процедура Краткий справочник

Выбор текущего размерного стиля

Процедура создания подчиненного стиля размеров


Выбор текущего размерного стиля (Процедура)

Коротко о размерных стилях
На уровень вверх ..
Коротко о размерных стилях
Аннотирование чертежей > Размеры и допуски > Размерные стили > Коротко о размерных стилях >
Коротко о размерных стилях
Понятие Процедура Краткий справочник

Выбор текущего размерного стиля

  • Выберите стиль из выпадающего списка "Управление размерными стилями" на панели "Стили".
Ввод команды: РЗМСТИЛЬ


Процедура создания подчиненного стиля размеров (Процедура)

Коротко о размерных стилях
На уровень вверх ..
Сравнение размерных стилей и переменных
Аннотирование чертежей > Размеры и допуски > Размерные стили > Коротко о размерных стилях >
Коротко о размерных стилях
Понятие Процедура Краткий справочник

Процедура создания подчиненного стиля размеров

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В диспетчере стилей размеров выберите стиль, на основе которого требуется создать подчиненный стиль. Нажмите кнопку "Новый".
  3. В диалоговом окне "Создание нового размерного стиля" выберите в списке "На основе" тип размера для подчиненного стиля. Нажмите кнопку "Далее".
  4. В диалоговом окне "Новый размерный стиль" выберите подходящую вкладку и внесите изменения, определяющие подчиненный стиль.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Ввод команды: РЗМСТИЛЬ


Коротко о размерных стилях (Краткий справочник)

Ассоциативные размеры
Коротко о размерных стилях
Сравнение размерных стилей и переменных
Аннотирование чертежей > Размеры и допуски > Размерные стили > Коротко о размерных стилях >
Коротко о размерных стилях
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сравнение размерных стилей и переменных (Понятие)

Коротко о размерных стилях
Размерные стили
Редактирование размерных стилей
Аннотирование чертежей > Размеры и допуски > Размерные стили >
Сравнение размерных стилей и переменных
Понятие Процедура Краткий справочник

Имеется возможность просмотра всех свойств размерного стиля. Размерные стили, описанные в чертежах, вставленных как внешние ссылки, обрабатываются отдельно от размерных стилей текущего чертежа.

Существует возможность получить список размерных стилей чертежа. Можно также просмотреть список значений всех размерных системных переменных или только тех переменных, которые определяются размерным стилем.

При просмотре текущего состояния всех размерных системных переменных отображается список значений с учетом переопределений, применяемых для текущего размерного стиля. Кроме того, имеется возможность получения списка различий параметров между указанным именованным и текущим размерными стилями.

Размерные стили из внешних ссылок

Программа одинаково отображает имена размерных стилей из внешних ссылок и имена других внешне зависимых именованных объектов. В списке стилей Диспетчера размерных стилей каждое имя файла чертежа, вставленного как внешняя ссылка, выводится в виде Xref:имя чертежа, под которым перечисляются имена описанных в нем размерных стилей. Например, если в файле чертежа baseplat.dwg содержится размерный стиль FRACTIONAL-1 и baseplat.dwg прикрепляется как внешняя ссылка к новому чертежу, то в списке стилей Диспетчера размерных стилей отображается размерный стиль внешней ссылки в виде Xref:baseplat.dwg и FRACTIONAL-1 (под именем чертежа).

Стили из внешних ссылок доступны для просмотра, но их нельзя редактировать и задавать текущими. Их можно использовать в качестве шаблонов для создания новых размерных стилей в текущем чертеже.


Сравнение размерных стилей и переменных (Процедура)

Коротко о размерных стилях
На уровень вверх ..
Сравнение размерных стилей и переменных
Аннотирование чертежей > Размеры и допуски > Размерные стили > Сравнение размерных стилей и переменных >
Сравнение размерных стилей и переменных
Понятие Процедура Краткий справочник

Получение списка всех параметров текущего размерного стиля

Получение списка параметров имеющегося размерного стиля

Получение списка размерных стилей в текущем чертеже

Сравнение размерных стилей


Получение списка всех параметров текущего размерного стиля (Процедура)

Сравнение размерных стилей и переменных
На уровень вверх ..
Сравнение размерных стилей и переменных
Аннотирование чертежей > Размеры и допуски > Размерные стили > Сравнение размерных стилей и переменных >
Сравнение размерных стилей и переменных
Понятие Процедура Краткий справочник

Получение списка всех параметров текущего размерного стиля

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В списке "Стили" Диспетчера размерных стилей выберите стиль.
  3. Нажмите кнопку "Сравнить".

    В списке перечислены размерные системные переменные с текущими параметрами и кратким описанием. Переопределения свойств текущего размерного стиля также отображаются в списке.

Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Получение списка параметров имеющегося размерного стиля (Процедура)

Сравнение размерных стилей и переменных
На уровень вверх ..
Сравнение размерных стилей и переменных
Аннотирование чертежей > Размеры и допуски > Размерные стили > Сравнение размерных стилей и переменных >
Сравнение размерных стилей и переменных
Понятие Процедура Краткий справочник

Получение списка параметров имеющегося размерного стиля

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей введите имя нужного стиля или выберите размер, стиль которого нужно просмотреть.
  3. Нажмите кнопку "Сравнить".

    В списке перечислены используемые переменные с заданными значениями и кратким описанием. Переопределения свойств выбранного размерного стиля не отображаются в списке.

Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Получение списка размерных стилей в текущем чертеже (Процедура)

Сравнение размерных стилей и переменных
На уровень вверх ..
Сравнение размерных стилей и переменных
Аннотирование чертежей > Размеры и допуски > Размерные стили > Сравнение размерных стилей и переменных >
Сравнение размерных стилей и переменных
Понятие Процедура Краткий справочник

Получение списка размерных стилей в текущем чертеже

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей в разделе "Вывести в список" выберите "Все стили" или "Задействованные стили".
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Сравнение размерных стилей (Процедура)

Сравнение размерных стилей и переменных
На уровень вверх ..
Редактирование размерных стилей
Аннотирование чертежей > Размеры и допуски > Размерные стили > Сравнение размерных стилей и переменных >
Сравнение размерных стилей и переменных
Понятие Процедура Краткий справочник

Сравнение размерных стилей

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В списке "Стили" Диспетчера размерных стилей выберите стиль, который необходимо сравнить.
  3. Нажмите кнопку "Сравнить".

    Размерный стиль сравнивается с текущим размерным стилем.

Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Сравнение размерных стилей и переменных (Краткий справочник)

Коротко о размерных стилях
Сравнение размерных стилей и переменных
Управление размерными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Сравнение размерных стилей и переменных >
Сравнение размерных стилей и переменных
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование размерных стилей

Сравнение размерных стилей и переменных
Размерные стили
Управление размерными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили >
Редактирование размерных стилей
Понятие Процедура

Имеется возможность управления отображением размерных линий, выносных линий, стрелок и маркеров центра.

Темы в этом разделе

  • Управление размерными линиями

    Можно изменять свойства размерных линий, включая цвет, толщину и интервал.

  • Управление выносными линиями

    Можно изменять свойства выносных линий, включая цвет, толщину, превышение и длину смещения.

  • Управление стрелками на концах размерных линий

    Символами стрелок у размеров и выносок можно управлять, в том числе их типом, размером и видимостью.

  • Пользовательские стрелки

    Пользователь имеет возможность создавать собственные стрелки.


Редактирование размерных стилей (Процедура)

Сравнение размерных стилей и переменных
На уровень вверх ..
Управление размерными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей >
Редактирование размерных стилей
Понятие Процедура

Форматирование размерных линий

Форматирование выносных линий

Выбор стрелок

Изменение направления стрелки

Использование стрелок собственной разработки


Управление размерными линиями (Понятие)

Редактирование размерных стилей
Редактирование размерных стилей
Управление выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей >
Управление размерными линиями
Понятие Процедура Краткий справочник

Можно изменять свойства размерных линий, включая цвет, толщину и интервал.

Имеется возможность изменения различных свойств размерных линий. Существует возможность:

  • Указывать цвет и толщину линии для визуального эффекта и печати.
  • Отключать отображение размерной линии или, если она разделена текстом, одну или обе ее половины.

  • Задавать интервал между соседними размерными линиями в базовых размерах.

  • Указывать расстояние, на которое размерная линия выходит за выносные линии, для окончаний размерных линий на строительных чертежах (с наклонными засечками).


Форматирование размерных линий (Процедура)

Редактирование размерных стилей
На уровень вверх ..
Управление выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление размерными линиями >
Управление размерными линиями
Понятие Процедура Краткий справочник

Форматирование размерных линий

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" измените параметры в разделе "Размерные линии".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Управление размерными линиями (Краткий справочник)

Сравнение размерных стилей и переменных
Управление размерными линиями
Управление выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление размерными линиями >
Управление размерными линиями
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMCLRD

Указание цветов размерных линий, стрелок и размерных линий выноски

DIMDLE

Задание значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок

DIMDLI

Управление расстоянием между размерными линиями в базовых размерах

DIMGAP

Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом

DIMLTYPE

Задание типа размерной линии

DIMLWD

Задание веса для размерных линий

DIMSD1

Управление подавлением первой размерной линии и стрелки

DIMSD2

Управление подавлением второй размерной линии и стрелки

DIMSOXD

Подавление отображения стрелок при отсутствии достаточного пространства между выносными линиями

DIMTOFL

Управление построением размерной линии между выносными линиями, даже если текст размещается вне линий

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление выносными линиями (Понятие)

Управление размерными линиями
Редактирование размерных стилей
Управление стрелками на концах размерных линий
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей >
Управление выносными линиями
Понятие Процедура Краткий справочник

Можно изменять свойства выносных линий, включая цвет, толщину, превышение и длину смещения.

Можно изменять различные свойства выносных линий. Существует возможность:

  • Указывать цвет и толщину линии для визуального эффекта и печати.
  • Отключать отображение одной или обеих выносных линий ("подавлять"), если они не используются или при недостатке места.

  • Указывать расстояние, на которое выносные линии выходят за размерную (удлинение).

  • Указывать отступ исходной точки удлинения, расстояние между исходной точкой выносной линии и ее началом.

  • Указывать фиксированную длину выносных линий - расстояние от размерной линии до исходной точки выносной линии.

  • Указывать тип прерывистой линии, обычно используемый для центровых линий.

  • Изменять угол выносных линий выбранного размера, делая их наклонными.

Выносные линии фиксированной длины

С помощью Диспетчера размерных стилей на вкладке "Линии" можно указать размерный стиль, устанавливающий полную длину выносных линий от размерной линии до исходной точки размера.

Расстояние отступа выносной линии от исходной точки никогда не будет меньше значения, указанного системной переменной DIMEXO.

См. также

    • Нанесение размеров с наклонными выносными линиями


Форматирование выносных линий (Процедура)

Управление размерными линиями
На уровень вверх ..
Управление стрелками на концах размерных линий
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление выносными линиями >
Управление выносными линиями
Понятие Процедура Краткий справочник

Форматирование выносных линий

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Выносные линии" измените необходимые параметры.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Управление выносными линиями (Краткий справочник)

Управление размерными линиями
Управление выносными линиями
Управление стрелками на концах размерных линий
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление выносными линиями >
Управление выносными линиями
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMCLRE

Указание цвета размерных выносных линий

DIMDLE

Задание значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок

DIMEXE

Задание величины, на которую выносная линия должна выступать за размерную линию

DIMEXO

Задание величины смещения выносных линий относительно исходных точек

DIMFXL

Задание общей длины выносных линий от размерной линии до исходной точки размера

DIMFXLON

Управление установкой фиксированной длины выносных линий

DIMLTEX1

Задание типа первой выносной линии

DIMLTEX2

Задание типа второй выносной линии

DIMLWE

Задание веса для выносных линий

DIMSE1

Подавление отображения первой выносной линии

DIMSE2

Подавление отображения второй выносной линии

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление стрелками на концах размерных линий (Понятие)

Управление выносными линиями
Редактирование размерных стилей
Пользовательские стрелки
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей >
Управление стрелками на концах размерных линий
Понятие Процедура Краткий справочник

Символами стрелок у размеров и выносок можно управлять, в том числе их типом, размером и видимостью.

Можно выбрать стандартные типы стрелок или создать собственные. Дополнительные возможности:

  • Подавление отображения стрелок или использование только одной стрелки.
  • Использование различного типа стрелок на каждом конце размерной линии.
  • Управление размером стрелок.
  • Изменение направления стрелки с помощью контекстного меню размера.
ПримечаниеВнешний вид стрелок с измененным направлением сохраняется в версиях, более поздних по сравнению с AutoCAD 2002. Тем не менее, при редактировании чертежа с отраженными стрелками в более ранних версиях, чем AutoCAD 2006, направления стрелок будут возвращены к исходным.
См. также

    • Пользовательские стрелки


Управление стрелками на концах размерных линий (Процедура)

Управление выносными линиями
На уровень вверх ..
Управление стрелками на концах размерных линий
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление стрелками на концах размерных линий >
Управление стрелками на концах размерных линий
Понятие Процедура Краткий справочник

Выбор стрелок

Изменение направления стрелки


Выбор стрелок (Процедура)

Управление стрелками на концах размерных линий
На уровень вверх ..
Управление стрелками на концах размерных линий
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление стрелками на концах размерных линий >
Управление стрелками на концах размерных линий
Понятие Процедура Краткий справочник

Выбор стрелок

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Символы и стрелки" в разделе "Стрелки" выберите тип стрелки на первом конце размерной линии.

    Тип второй стрелки автоматически устанавливается таким же.

  4. Для установки другого типа стрелки на втором конце размерной линии выберите необходимый тип во втором списке.
  5. Введите величину размерных стрелок в поле "Величина".
  6. Нажмите "ОК".
  7. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Изменение направления стрелки (Процедура)

Управление стрелками на концах размерных линий
На уровень вверх ..
Пользовательские стрелки
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление стрелками на концах размерных линий >
Управление стрелками на концах размерных линий
Понятие Процедура Краткий справочник

Изменение направления стрелки

  1. В ответ на подсказку выберите один объект размера рядом со стрелкой, направление которой необходимо изменить.
  2. Нажмите правую кнопку мыши. Выберите "Перевернуть стрелку".


Управление стрелками на концах размерных линий (Краткий справочник)

Управление выносными линиями
Управление стрелками на концах размерных линий
Пользовательские стрелки
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Управление стрелками на концах размерных линий >
Управление стрелками на концах размерных линий
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMCLRD

Указание цветов размерных линий, стрелок и размерных линий выноски

DIMDLE

Задание значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок

DIMSD1

Управление подавлением первой размерной линии и стрелки

DIMSD2

Управление подавлением второй размерной линии и стрелки

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Пользовательские стрелки (Понятие)

Управление стрелками на концах размерных линий
Редактирование размерных стилей
Управление размерным текстом
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей >
Пользовательские стрелки
Понятие Процедура Краткий справочник

Пользователь имеет возможность создавать собственные стрелки.

Стрелки сохраняются как описания блоков. Для создания своих стрелок необходимо описать блок и присвоить ему имя. Подробнее о создании блоков см. раздел Создание блоков в чертеже.

ПримечаниеВ качестве пользовательских стрелок для размеров или выносок невозможно использовать аннотативные блоки.

Окончательная величина стрелок зависит от глобального масштабного коэффициента размеров для чертежа. При нанесении размера происходит вставка блока в типовое место расположения стрелок. Для масштабных коэффициентов X и Y объекта задаётся значение глобальный масштабный коэффициентразмерной стрелки . Размерная линия обрезается с соблюдением зазоров размерного текста, определяемых умножением заданной величины зазора и глобального масштабного коэффициента. Чтобы обрезать размерную линию, крайний правый блок вставляется с нулевым углом поворота для горизонтального размера. Крайний левый блок поворачивается на 180 градусов вокруг точки вставки.

При использовании масштабирования пространства листа вычисление масштабного коэффициента происходит перед применением к значению размера стрелки.


Использование стрелок собственной разработки (Процедура)

Управление стрелками на концах размерных линий
На уровень вверх ..
Управление размерным текстом
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Пользовательские стрелки >
Пользовательские стрелки
Понятие Процедура Краткий справочник

Использование стрелок собственной разработки

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В Диспетчере размерных стилей на вкладке "Символы и стрелки" в разделе "Стрелки" в списке первой стрелки выберите "Пользовательская".
  4. В диалоговом окне "Выбор блока пользовательской стрелки" введите имя блока. Нажмите "ОК".
  5. Для установки второй пользовательской стрелки, отличающейся от первой, повторите действия пунктов 3 и 4, выбрав "Пользовательская" и в списке второй стрелки (не обязательно) .
  6. Нажмите "ОК".
  7. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Пользовательские стрелки (Краткий справочник)

Управление стрелками на концах размерных линий
Пользовательские стрелки
Размещение размерного текста между выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Редактирование размерных стилей > Пользовательские стрелки >
Пользовательские стрелки
Понятие Процедура Краткий справочник

Команды

БЛОК

Создание определения блока из выбранных объектов

РЗМСТИЛЬ

Создание и модификация размерных стилей

ПБЛОК

Запись объектов или блока в новый файл чертежа

Системные переменные

DIMASZ

Управление величинами стрелок размерных линий и линий выноски

DIMBLK

Задание блока стрелок, отображаемого на концах размерных линий или линий выноски

DIMBLK1

Задание стрелки на первом конце размерной линии (при включенной переменной DIMSAH)

DIMBLK2

Задание стрелки на втором конце размерной линии (при включенной переменной DIMSAH)

DIMCLRD

Указание цветов размерных линий, стрелок и размерных линий выноски

DIMDLE

Задание значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок

DIMSAH

Управление отображением блоков стрелок размерных линий

DIMTVP

Задание размера засечки, которая наносится вместо стрелки в линейных размерах, радиусах и диаметрах

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление размерным текстом

Пользовательские стрелки
Размерные стили
Размещение размерного текста между выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили >
Управление размерным текстом
Понятие Процедура

Имеется возможность управления размещением размерного текста, стрелок и линий выносок относительно размерных и выносных линий.

Темы в этом разделе

  • Размещение размерного текста между выносными линиями

    Как правило, размерный текст и стрелки располагаются между выносными линиями. Однако, в случае нехватки места, можно изменять расположение этих размерных элементов.

  • Размещение размерного текста

    Имеется возможность вручную указывать положение размерного текста, а также задавать его выравнивание и ориентацию.

  • Внешний вид размерного текста

    Размерный текст может содержать различные префиксы и суффиксы, а также другие определенные пользователем текстовые элементы. Можно также задать текстовый стиль и изменить параметры форматирования размерного текста.


Управление размерным текстом (Процедура)

Пользовательские стрелки
На уровень вверх ..
Размещение размерного текста между выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом >
Управление размерным текстом
Понятие Процедура

Размещение текста между выносными линиями

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения

Размещение текста вдоль размерной линии

Размещение текста у второй выносной линии

Размещение размерного текста вручную

Размещение текста над размерной линией

Управление текстовым стилем в размерах


Размещение размерного текста между выносными линиями (Понятие)

Управление размерным текстом
Управление размерным текстом
Размещение размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом >
Размещение размерного текста между выносными линиями
Понятие Процедура Краткий справочник

Как правило, размерный текст и стрелки располагаются между выносными линиями. Однако, в случае нехватки места, можно изменять расположение этих размерных элементов.

На результат размещения текста и стрелок между выносными линиями влияют различные факторы, в том числе расстояние между выносными линиями и величина стрелок. Обычно выбирается оптимальное расположение объектов, обеспечивающее наличие свободного места. Если есть возможность, текст и стрелки размещаются между выносными линиями, независимо от установленных опций размещения.

При создании новых размеров можно вручную задавать положение размерного текста путем ввода координат с клавиатуры или указанием точки с помощью устройства указания. В противном случае программа вычислит наилучшее расположение текста. Режимы автоматического размещения размерного текста и стрелок задаются на вкладке "Размещение" диалогового окна работы с размерными стилями. Например, можно установить такой режим, чтобы текст и стрелки размещались одинаковым способом. В этом случае, если между выносными линиями недостаточно места хотя бы для одного из элементов, то и размерный текст, и стрелки наносятся вне выносных линий. И наоборот, можно задать опции таким образом, чтобы между выносными линиями размещались либо стрелки, либо текст при наличии достаточного места для размещения хотя бы одного их этих элементов.

На следующих иллюстрациях показано определение программой оптимального расположения для стрелок и текста.

Если между выносными линиями недостаточно места для размещения текста, то имеется возможность автоматического создания выноски. Такой способ наиболее предпочтителен в тех случаях, когда при размещении вне выносных линий текст наезжает на другие элементы, например, при построении размерной цепи. Сторона, где должен располагаться текст относительно выноски, определяется режимом горизонтального выравнивания, заданного на вкладке "Текст" диалогового окна работы с размерными стилями. Положение размерного текста и стрелок можно сохранить между выносными линиями, изменяя их величину.

Даже если стрелки наносятся вне выносных линий, можно провести размерную линию между выносными. Пример такого принудительного размещения размерной линии показан на следующем чертеже.

Размещение текста на диаметре

Можно наносить несколько разных размеров диаметров в зависимости от размещения текста, режима горизонтального выравнивания, задаваемого на вкладке "Текст", и параметра "Размерная линия между выносными", устанавливаемого на вкладке "Размещение".


Размещение размерного текста между выносными линиями (Процедура)

Управление размерным текстом
На уровень вверх ..
Размещение размерного текста между выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста между выносными линиями >
Размещение размерного текста между выносными линиями
Понятие Процедура Краткий справочник

Размещение текста между выносными линиями

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения


Размещение текста между выносными линиями (Процедура)

Размещение размерного текста между выносными линиями
На уровень вверх ..
Размещение размерного текста между выносными линиями
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста между выносными линиями >
Размещение размерного текста между выносными линиями
Понятие Процедура Краткий справочник

Размещение текста между выносными линиями

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Опции размещения" задайте нужный режим.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

    Если имеется достаточно места, текст размещается между выносными линиями.

Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Принудительное размещение размерной линии между выносными линиями и выбора режима размещения (Процедура)

Размещение размерного текста между выносными линиями
На уровень вверх ..
Размещение размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста между выносными линиями >
Размещение размерного текста между выносными линиями
Понятие Процедура Краткий справочник

Принудительное размещение размерной линии между выносными линиями и выбора режима размещения

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Подгонка элементов" установите флажок "Размерная линия между выносными".
  4. В группе "Опции размещения" установите нужный режим.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Размещение размерного текста между выносными линиями (Краткий справочник)

Пользовательские стрелки
Размещение размерного текста между выносными линиями
Размещение размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста между выносными линиями >
Размещение размерного текста между выносными линиями
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMATFIT

Определение способа размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях

DIMJUST

Управление положением размерного текста по горизонтали

DIMLWD

Задание веса для размерных линий

DIMTAD

Управление расположением текста по вертикали относительно размерной линии

DIMTIH

Управление ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями

DIMTIX

Отображение текста между размерными линиями

DIMTOFL

Управление построением размерной линии между выносными линиями, даже если текст размещается вне линий

DIMTOH

Управление ориентацией размерного текста за выносными линиями

DIMTVP

Управление положением размерного текста по вертикали над или под размерной линией

DIMUPT

Управление действием курсора при пользовательском расположении текста

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Размещение размерного текста (Понятие)

Размещение размерного текста между выносными линиями
Управление размерным текстом
Внешний вид размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом >
Размещение размерного текста
Понятие Процедура Краткий справочник

Имеется возможность вручную указывать положение размерного текста, а также задавать его выравнивание и ориентацию.

В программе доступно несколько параметров для выравнивания, соответствующих международным стандартам. Также можно выбирать местоположение текста.

Многие параметры размещения взаимозависимы. В Диспетчере размерных стилей выводится пример изображения, обновляемый каждый раз при смене параметров для показа результата размещения размерного текста.

Параллельный размерный текст

Независимо от того, размещается ли размерный текст между выносными линиями или снаружи, имеется возможность задания ориентации текста как вдоль размерной линии, так и в горизонтальном направлении. На следующих чертежах показаны оба этих режима.

По умолчанию установлена горизонтальная ориентация размерного текста даже для вертикальных размеров.

Положение размерного текста по горизонтали

Положение текста вдоль размерной линии по отношению к выносным линиям называют размещением текста. Для произвольного размещения текста при нанесении размера следует включить опцию "Размещение текста вручную" на вкладке "Размещение" диалогового окна работы с размерными стилями. Для автоматического размещения текста в центре размерной линии или у одной из выносных линий используются опции размещения, устанавливающие нужный режим.

Первая и вторая выносные линии определяются последовательностью указания начальных точек выносных линий во время построения размера. Для угловых размеров вторая выносная линия повернута в направлении против часовой стрелки от первой. На следующем чертеже цифрой 1 обозначена первая начальная точка выносных линий, цифрой 2 - вторая.

При размещении текста создаваемого размера вручную имеется возможность указания положения текста в любом месте вдоль размерной линии, между выносными линиями или снаружи. Этот режим позволяет наиболее оптимально размещать текст при наличии очень ограниченного места. Однако при использовании горизонтальной ориентации размерного текста достигается большая аккуратность нанесения последовательности размеров.

Положение размерного текста по вертикали

Положение текста по отношению к размерной линии называют вертикальными размещением текста. Текст может размещаться над или под размерной линией, а также в центре размерной линии. В соответствии со стандартами ANSI, размерный текст обычно размещается в центре, разрывая размерную линию. Стандарты ISO предусматривают расположение размерного текста над размерной линией или за пределами объекта на который наносятся размеры. На следующих чертежах показаны примеры допустимого по стандартам ISO нанесения размерного текста.

На размерный текст влияют и другие параметры, например "Ориентация текста". Так, если установлена горизонтальная ориентация, то текст, размещаемый между выносными линиями в центре размерной линии, ориентируется горизонтально, как показано на левом чертеже выше. Здесь ориентация текста сохраняется горизонтальной даже в том случае, когда размерная линия не расположена горизонтально.


Размещение размерного текста (Процедура)

Размещение размерного текста между выносными линиями
На уровень вверх ..
Размещение размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста >
Размещение размерного текста
Понятие Процедура Краткий справочник

Размещение текста вдоль размерной линии

Размещение текста у второй выносной линии

Размещение размерного текста вручную

Размещение текста над размерной линией


Размещение текста вдоль размерной линии (Процедура)

Размещение размерного текста
На уровень вверх ..
Размещение размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста >
Размещение размерного текста
Понятие Процедура Краткий справочник

Размещение текста вдоль размерной линии

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Ориентация текста" установить опцию "Вдоль размерной линии".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Размещение текста у второй выносной линии (Процедура)

Размещение размерного текста
На уровень вверх ..
Размещение размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста >
Размещение размерного текста
Понятие Процедура Краткий справочник

Размещение текста у второй выносной линии

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Выравнивание текста" из списка "По горизонтали" выберите опцию "У 2-й выносной".

    Изменение параметров вызывает обновление образца изображения.

  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или стили
Ввод команды: РЗМСТИЛЬ


Размещение размерного текста вручную (Процедура)

Размещение размерного текста
На уровень вверх ..
Размещение размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста >
Размещение размерного текста
Понятие Процедура Краткий справочник

Размещение размерного текста вручную

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Подгонка элементов" включите опцию "Размещение текста вручную".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

    При создании размера можно перемещать текст вдоль размерной линии. Для задания положения размерной линии и текста можно воспользоваться устройством указания или ввести координаты с клавиатуры.

Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Размещение текста над размерной линией (Процедура)

Размещение размерного текста
На уровень вверх ..
Внешний вид размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста >
Размещение размерного текста
Понятие Процедура Краткий справочник

Размещение текста над размерной линией

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Выравнивание текста" из списка "По вертикали" выберите опцию "Над линией".

    Изменение параметров вызывает обновление образца изображения.

  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Размещение размерного текста (Краткий справочник)

Размещение размерного текста между выносными линиями
Размещение размерного текста
Внешний вид размерного текста
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Размещение размерного текста >
Размещение размерного текста
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

РЗМРЕДТЕКСТ

Перенос и поворот размерного текста, изменение местоположения размерной линии

Системные переменные

DIMJUST

Управление положением размерного текста по горизонтали

DIMTAD

Управление расположением текста по вертикали относительно размерной линии

DIMTIH

Управление ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями

DIMTOH

Управление ориентацией размерного текста за выносными линиями

DIMTVP

Управление положением размерного текста по вертикали над или под размерной линией

DIMUPT

Управление действием курсора при пользовательском расположении текста

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Внешний вид размерного текста (Понятие)

Размещение размерного текста
Управление размерным текстом
Форматирование размерных значений
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом >
Внешний вид размерного текста
Понятие Процедура Краткий справочник

Размерный текст может содержать различные префиксы и суффиксы, а также другие определенные пользователем текстовые элементы. Можно также задать текстовый стиль и изменить параметры форматирования размерного текста.

Программа позволяет работать с разнообразными текстовыми элементами, определяемыми пользователем, префиксами и суффиксами, поддерживаемыми размерным стилем, а также сгенерированными значениями размеров. Например, можно добавить символ диаметра в качестве префикса измерения или сокращение (например, мм) для единицы измерения в качестве суффикса. Описывать таким образом можно любой размерный текст, применяя любые доступные префиксы и суффиксы, основные и альтернативные единицы, а также обозначение двустороннего допуска. Допуски формы и расположения определяются независимо.

Размерный текст представляет из себя однострочный текст, который можно создайте и отформатировать с помощью текстового редактора.

Управление текстовым стилем в размерах

Внешний вид размерного текста зависит от текстового стиля, заданного с помощью Диспетчера размерных стилей на вкладке "Текст". В процессе создания размерного стиля можно выбрать текстовый стиль и задать цвет текста и высоту символов независимо от настроек текущего текстового стиля чертежа. Кроме того, можно указать величину зазора между базовой линией текста и окружающей рамкой.

Для размеров используются те же текстовые стили, что и для текстовых объектов чертежа.

Дополнительную информацию см. в разделе Работа с текстовыми стилями.

Пользовательский размерный текст

Кроме стандартных префиксов и суффиксов для основных и альтернативных единиц, пользователь может наносить свои тексты при создании размеров. С помощью префиксов, суффиксов и пользовательских текстов формируются однострочные тексты, к которым можно добавлять допуски, а также редактировать и форматировать с помощью текстового редактора.

Для размещения пользовательского текста над размерной линией и под ней используется символ разделителя \X. Текст, предшествующий этому символу, располагается над размерной линией и выравнивается вдоль нее. Текст, следующий за разделителем \X, располагается под размерной линией и ориентирован вдоль нее. Зазор между текстом и размерной линией определяется значением, вводимым в поле "Отступ от размерной линии" на вкладке "Текст".

Пример: пользовательский размерный текст

В данном примере величина размера в основных единицах измерения равна 5,08, а в альтернативных единицах - 2,00. У размера в основных единицах имеется суффикс H7/h6, а размер в альтернативных единицах содержит суффикс, обозначающий дюймы.

При создании размера в ответ на запрос вводится следующая строка, описывающая формат размерного текста:

<> H7/h6\XСм. примечание 26\P[ ]

Угловые скобки представляют значение величины в основных единицах, квадратные скобки значение в альтернативных единицах. Разделителем \X строка разбивается на две части; первая часть размещается над размерной линией, вторая под размерной линией. Обозначение \P указывает на конец абзаца.

В результате размерный текст имеет следующий вид:


Управление текстовым стилем в размерах (Процедура)

Размещение размерного текста
На уровень вверх ..
Форматирование размерных значений
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Внешний вид размерного текста >
Внешний вид размерного текста
Понятие Процедура Краткий справочник

Управление текстовым стилем в размерах

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Текст" диалогового окна "Изменение размерного стиля" в группе "Свойства текста" выберите текстовый стиль.
  4. Если в текстовом стиле не задана фиксированная высота, то укажите высоту символов размерного текста в поле "Высота текста".
  5. На вкладке "Допуски" в поле "Масштаб высоты" введите значение высоты текста для отклонений.
  6. В поле "Отступ от размерной линии" (на вкладке "Текст") введите величину зазора, окружающего текст при его расположении в разрыве размерной линии.
  7. В списке "Цвет текста" выберите цвет.
  8. Нажмите кнопку "ОК".
  9. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Внешний вид размерного текста (Краткий справочник)

Размещение размерного текста
Внешний вид размерного текста
Форматирование размерных единиц
Аннотирование чертежей > Размеры и допуски > Размерные стили > Управление размерным текстом > Внешний вид размерного текста >
Внешний вид размерного текста
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMCLRT

Указание цвета размерного текста Для цвета можно выбрать любой допустимый номер цвета

DIMFRAC

Задание формата дроби, если для переменной DIMLUNIT установлено значение 4 (архитектурные) или 5 (дробные)

DIMGAP

Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом

DIMTFAC

Задание масштабного коэффициента для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT

DIMTFILL

Управление фоном размерного текста

DIMTFILLCLR

Задание цвета фона текста в размерах

DIMTXSTY

Задание стиля текста для размера

DIMTXT

Задание высоты размерного текста, если в стиле текста не задана фиксированная высота

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Форматирование размерных значений

Внешний вид размерного текста
Размерные стили
Форматирование размерных единиц
Аннотирование чертежей > Размеры и допуски > Размерные стили >
Форматирование размерных значений
Понятие Процедура

Для отображения значений размерных чисел можно задавать различные параметры форматирования. Также имеется возможность управления представлением расстояния между числами.

Темы в этом разделе

  • Форматирование размерных единиц

    Числовые значения измеряемых величин могут наноситься на размерах как в одной системе измерений, так и в двух. В любом случае, существует возможность задавать формат отображаемых значений.

  • Округление размерных величин

    Все значения размерных чисел, включая двусторонние допуски, можно округлять.

  • Подавление нулей в размерных значениях

    Отображение ведущих и замыкающих нулей в числовых значениях размерного текста можно подавлять.

  • Нанесение двусторонних допусков

    Допуски показывают пределы, в которых может колебаться размер. Можно управлять отображением двусторонних допусков, стили которых можно выбирать.


Форматирование размерных значений (Процедура)

Внешний вид размерного текста
На уровень вверх ..
Форматирование размерных единиц
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений >
Форматирование размерных значений
Понятие Процедура

Добавление и форматирование основных единиц

Добавление и форматирование альтернативных единиц

Округление размерных значений

Подавление нулей в размерных значениях

Задание способа нанесения двусторонних допусков

Выравнивание допусков и подавление нулей в значениях допусков


Форматирование размерных единиц (Понятие)

Форматирование размерных значений
Форматирование размерных значений
Округление размерных величин
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений >
Форматирование размерных единиц
Понятие Процедура Краткий справочник

Числовые значения измеряемых величин могут наноситься на размерах как в одной системе измерений, так и в двух. В любом случае, существует возможность задавать формат отображаемых значений.

Параметры настройки основных единиц позволяют управлять выводом размерных значений. Можно форматировать размерные единицы, а также задавать такие свойства, как точность представления числовых значений и вид десятичного разделителя. Например, можно задать в качестве префикса обозначение диаметра, как показано на чертеже. Любой заданный префикс заменяет префиксы, обычно используемые для размеров диаметра и радиуса (символ Юникод 2205 и R, соответственно).

Все эти параметры задаются на вкладке "Основные единицы" Диспетчера размерных стилей.

Форматирование альтернативных единиц

Пользователь может наносить размеры с указанием величин сразу в двух системах единиц. Обычно такая возможность используется для проставления значений размеров в метрических единицах, если чертеж выполнен в британских единицах, и наоборот. Величина размера в альтернативных единицах наносится в квадратных скобках [ ] в размерном тексте. Альтернативные единицы не могут использоваться при нанесении угловых размеров.

Если включен режим альтернативных единиц, то выводимые значения в альтернативных единицах получаются путем умножения значений в основных единицах на заданный коэффициент пересчета. Этот коэффициент представляет число альтернативных единиц в одной текущей размерной единице. По умолчанию для основных британских единиц принимается коэффициент 25,4, используемый для пересчета дюймов в миллиметры. По умолчанию для основных метрических единиц коэффициент составляет примерно 0,0394, что равно количеству дюймов в миллиметре. Количество десятичных знаков устанавливается параметром точности альтернативных единиц.

Например, если основными являются британские единицы, для коэффициента пересчета задано значение 25,4, а для точности - 0,00, то размеры могут иметь такой вид:


Форматирование размерных единиц (Процедура)

Форматирование размерных значений
На уровень вверх ..
Форматирование размерных единиц
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Форматирование размерных единиц >
Форматирование размерных единиц
Понятие Процедура Краткий справочник

Добавление и форматирование основных единиц

Добавление и форматирование альтернативных единиц


Добавление и форматирование основных единиц (Процедура)

Форматирование размерных единиц
На уровень вверх ..
Форматирование размерных единиц
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Форматирование размерных единиц >
Форматирование размерных единиц
Понятие Процедура Краткий справочник

Добавление и форматирование основных единиц

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Основные единицы" диалогового окна "Изменение размерного стиля" в группах "Линейные размеры" и "Угловые размеры" задайте параметры форматирования и точность основных единиц.
  4. В группе "Линейные размеры" введите префикс и суффикс для размеров.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Добавление и форматирование альтернативных единиц (Процедура)

Форматирование размерных единиц
На уровень вверх ..
Округление размерных величин
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Форматирование размерных единиц >
Форматирование размерных единиц
Понятие Процедура Краткий справочник

Добавление и форматирование альтернативных единиц

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Альт. единицы" диалогового окна "Изменение размерного стиля" установить флажок "Разрешить альтернативные единицы".
  4. В группе "Альтернативные единицы":
    • Выберите формат единиц из списка.
    • Задайте точность значений для альтернативных единиц.
    • Введите любые префикс и суффикс для нанесения размеров. Здесь можно использовать символ пробела для задания интервала между префиксом или суффиксом и размерным значением.
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Форматирование размерных единиц (Краткий справочник)

Внешний вид размерного текста
Форматирование размерных единиц
Округление размерных величин
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Форматирование размерных единиц >
Форматирование размерных единиц
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMALT

Управление отображением альтернативных единиц в размерах

DIMALTD

Управление количеством десятичных знаков в альтернативных единицах

DIMALTF

Управление множителем для альтернативных единиц

DIMALTTD

Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц

DIMALTU

Задание формата альтернативных единиц измерения для всех размерных субстилей за исключением углового

DIMALTZ

Управление подавлением нулей в альтернативных размерных единицах

DIMAPOST

Указание префикса или суффикса текста (или и то, и другое) для альтернативных размерных единиц для всех типов размеров, кроме угловых

DIMAUNIT

Задание формата единиц измерения для угловых размеров

DIMDEC

Задание числа десятичных знаков, отображаемых для основных единиц размера

DIMDSEP

Задание символа десятичного разделителя, используемый при создании размеров с десятичным форматом единиц измерения

DIMLFAC

Установка масштабного коэффициента для значений линейных размеров

DIMLUNIT

Установка единиц для всех типов размеров, кроме угловых

DIMPOST

Указание префикса или суффикса текста (или и того, и другого) для размерных единиц

DIMTDEC

Задание количества десятичных знаков для значений допусков в основных единицах

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Округление размерных величин (Понятие)

Форматирование размерных единиц
Форматирование размерных значений
Подавление нулей в размерных значениях
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений >
Округление размерных величин
Понятие Процедура Краткий справочник

Все значения размерных чисел, включая двусторонние допуски, можно округлять.

Все значения размерных чисел, кроме угловых размеров, можно округлить. Например, если задать точность 0,25, все измеренные расстояния будут округлены до ближайшего кратного 0,25. Число десятичных знаков в дробной части зависит от точности, заданной для основных и альтернативных единиц, а также для двусторонних допусков.


Округление размерных значений (Процедура)

Форматирование размерных единиц
На уровень вверх ..
Подавление нулей в размерных значениях
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Округление размерных величин >
Округление размерных величин
Понятие Процедура Краткий справочник

Округление размерных значений

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Основные единицы" диалогового окна "Изменение размерного стиля" в группе "Линейные размеры" введите значения в поле "Округление".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Округление размерных величин (Краткий справочник)

Форматирование размерных единиц
Округление размерных величин
Подавление нулей в размерных значениях
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Округление размерных величин >
Округление размерных величин
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMRND

Округление всех размерных расстояний в соответствии с указанным значением

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подавление нулей в размерных значениях (Понятие)

Округление размерных величин
Форматирование размерных значений
Нанесение двусторонних допусков
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений >
Подавление нулей в размерных значениях
Понятие Процедура Краткий справочник

Отображение ведущих и замыкающих нулей в числовых значениях размерного текста можно подавлять.

Если включить подавление ведущих нулей, то значение 0,500 выводится как ,500. При подавлении замыкающих нулей 0,500 записывается как 0,5. При подавлении и тех и других нулей 0,5000 записывается как ,5, а 0,0000 как 0.

В следующей таблице представлены результаты подавления нулей в архитектурных единицах. Флажок подавления нулей не распространяется на значения в дюймах, выраженные с помощью дробей. Например, значение 4'-3/4" записывается как 4'-0 3/4".

Подавление нулей для футов и дюймов
Флажок | Воздействие | Примеры
Флажки не установлены | Нулевые значения отображаются как для футов, так и для дюймов | 0'-0 1/2" | 0'-6" | 1'-0" | 1'-0 3/4"
Установлен флажок "0 дюймов" | Нулевые значения подавляются для дюймов (записываются только для футов) | 0'-0 1/2" | 0'-6" | 1' | 1'-0 3/4"
Установлен флажок "0 футов" | Нулевые значения подавляются для футов (записываются только для дюймов) | 1/2" | 6" | 1'-0" | 1'-0 3/4"
Установлены флажки "0 футов" и "0 дюймов" | Нулевые значения не отображаются ни для футов, ни для дюймов | 1/2" | 6" | 1' | 1'-0 3/4"


Подавление нулей в размерных значениях (Процедура)

Округление размерных величин
На уровень вверх ..
Нанесение двусторонних допусков
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Подавление нулей в размерных значениях >
Подавление нулей в размерных значениях
Понятие Процедура Краткий справочник

Подавление нулей в размерных значениях

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Основные единицы" или "Альт. единицы" диалогового окна "Изменение размерного стиля" в группах "Подавление нулей" установить любые из следующих опций:
    • Ведущие. Подавление ведущих нулей в десятичных значениях.
    • Замыкающие. Подавление хвостовых нулей в десятичных значениях.
    • 0 футов. Подавление отображения значения "0 футов" в размере формата футы-дюймы.
    • 0 дюймов. Подавление отображения значения "0 дюймов" в размере формата футы-дюймы.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Подавление нулей в размерных значениях (Краткий справочник)

Округление размерных величин
Подавление нулей в размерных значениях
Нанесение двусторонних допусков
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Подавление нулей в размерных значениях >
Подавление нулей в размерных значениях
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMALTTZ

Управление подавлением нулей в значениях допуска

DIMALTZ

Управление подавлением нулей в альтернативных размерных единицах

DIMAZIN

Подавление нулевых значений для всех угловых размеров

DIMTZIN

Управление подавлением нулей в допусках

DIMZIN

Управление подавлением нулей в основных единицах измерения

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение двусторонних допусков (Понятие)

Подавление нулей в размерных значениях
Форматирование размерных значений
Задание масштаба размеров
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений >
Нанесение двусторонних допусков
Понятие Процедура Краткий справочник

Допуски показывают пределы, в которых может колебаться размер. Можно управлять отображением двусторонних допусков, стили которых можно выбирать.

Допуски показывают пределы, в которых может колебаться размер. Применение допусков в производстве позволяет задавать степень точности, которая должна соблюдаться при изготовлении для элементов детали, таких как точка, отрезок, ось или поверхность.

Допуски могут быть элементами размеров. Для этого их следует включить в размерный текст. Такие размерные допуски показывают максимальные и минимальные допустимые значения размерных величин. Кроме того, имеется возможность использования допусков формы и расположения, выражающих отклонения формы, контура, ориентации и взаимного расположения.

Для описания двусторонних допусков могут задаваться теоретически точные размеры. Такие размеры называются номинальными. Текст номинального размера заключается в рамку.

К размерным значениям можно добавить указание верхнего и нижнего отклонений. Если значения допусков отклонений одинаковы, они отображаются ос знаком ± и называются симметричными. В противном случае, значение верхнего отклонения (со знаком плюс) выводится над значением нижнего отклонения (со знаком минус).

Если допуски применяются в качестве ограничений, программа использует значения "плюс" и "минус", указанные пользователем, для вычисления максимального и минимального значения. Эти значения отображаются в качестве размерного текста. Наибольшее предельное значение выводится над наименьшим.

Форматирование двусторонних допусков

Имеется возможность задавать положение значений допусков по вертикали относительно основного размерного текста. При этом допуски могут выравниваться по верхней или нижней границе размерного текста, а также по середине.

Помимо расположения значений допусков по вертикали, предусмотрена возможность выравнивания верхнего и нижнего значений допуска по горизонтали. Для выравнивания верхнего и нижнего значений допуска можно воспользоваться операционным символом или десятичным разделителем.

Кроме того, можно включать подавление нулей в значениях допусков точно так же, как для размерных значений в основных и альтернативных единицах. Например, при подавлении ведущих нулей 0,5 записывается как ,5, а при подавлении замыкающих нулей 0,5000 - как 0,5.

См. также

    • Нанесение допусков формы и расположения


Нанесение двусторонних допусков (Процедура)

Подавление нулей в размерных значениях
На уровень вверх ..
Нанесение двусторонних допусков
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Нанесение двусторонних допусков >
Нанесение двусторонних допусков
Понятие Процедура Краткий справочник

Задание способа нанесения двусторонних допусков

Выравнивание допусков и подавление нулей в значениях допусков


Задание способа нанесения двусторонних допусков (Процедура)

Нанесение двусторонних допусков
На уровень вверх ..
Нанесение двусторонних допусков
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Нанесение двусторонних допусков >
Нанесение двусторонних допусков
Понятие Процедура Краткий справочник

Задание способа нанесения двусторонних допусков

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Допуски" диалогового окна "Изменение размерного стиля" в группе "Формат допусков" выберите нужный способ из списка "Способ" и выполнить одно из действий:
    • При выборе способа "Предельные размеры" введите значения верхнего и нижнего отклонений в полях "Максимальное значение" и "Минимальное значение" соответственно.
    • При выборе способа "Симметрично" введите только одно значение отклонения в поле "Максимальное значение". Указание минимального значения не требуется.
    • При выборе способа "Номинальный" введите значение в поле "Отступ от размерной линии" на вкладке "Текст" для задания зазора между размерным текстом и окружающей его рамкой.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Выравнивание допусков и подавление нулей в значениях допусков (Процедура)

Нанесение двусторонних допусков
На уровень вверх ..
Задание масштаба размеров
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Нанесение двусторонних допусков >
Нанесение двусторонних допусков
Понятие Процедура Краткий справочник

Выравнивание допусков и подавление нулей в значениях допусков

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Допуски" диалогового окна "Изменение размерного стиля" в группе "Формат допусков" выберите режим из списка "Выравнивание".
  4. Для подавления ведущих нулей размеров в основных и альтернативных единицах в группе "Подавление нулей" следует установить флажок "Ведущие". Для подавления замыкающих нулей следует установить флажок "Замыкающие".
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Нанесение двусторонних допусков (Краткий справочник)

Подавление нулей в размерных значениях
Нанесение двусторонних допусков
Задание масштаба размеров
Аннотирование чертежей > Размеры и допуски > Размерные стили > Форматирование размерных значений > Нанесение двусторонних допусков >
Нанесение двусторонних допусков
Понятие Процедура Краткий справочник

Команды

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMALTTD

Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц

DIMALTTZ

Управление подавлением нулей в значениях допуска

DIMGAP

Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом

DIMLIM

Создание ограничений размеров в качестве текста по умолчанию

DIMTDEC

Задание количества десятичных знаков для значений допусков в основных единицах

DIMTFAC

Задание масштабного коэффициента для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT

DIMTM

Задание минимального (или нижнего) предельного отклонения для размерного текста при включенной переменной DIMTOL или DIMLIM

DIMTOL

Добавление предельных отклонений в конец размерного текста

DIMTP

Задание максимального (или верхнего) предельного отклонения для размерного текста при включенной переменной DIMTOL или DIMLIM

DIMTZIN

Управление подавлением нулей в допусках

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание масштаба размеров (Понятие)

Нанесение двусторонних допусков
Размеры и допуски
Нанесение размеров
Аннотирование чертежей > Размеры и допуски >
Задание масштаба размеров
Понятие Процедура Краткий справочник

Имеется возможность задания масштаба для вывода размерных элементов. Устанавливаемый масштаб зависит от используемого способа компоновки и печати чертежа.

Масштаб размеров влияет на степень увеличения размерных элементов чертежа. При этом изменяются такие характеристики, как высота символов текста, величина стрелок и зазоров между выносными линиями и точками объектов с нанесенными размерами. При создании размерных стилей следует указывать реальные величины, используемые при выводе чертежа на печать. Глобальный масштаб размеров не применяется для значений длин, включая допуски, координат и углов.

ПримечаниеДля управления масштабом размеров, отображаемых в видовых экранах листа, можно использовать аннотативное масштабирование. При создании аннотативных размеров их масштабирование определяется текущей настройкой масштаба аннотаций, что автоматически приводит к корректному отображению размеров.

Задание масштаба размеров зависит от способа компоновки чертежа на листе. Существует три способа построения размеров:

  • Нанесение размеров в пространстве модели для печати в пространстве модели. Стандартный способ, используемый при работе с одним видом чертежа. Для корректного масштабирования размеров при выводе на печать системной переменной DIMSCALE следует присвоить значение, обратное установленному масштабу печати. Например, если масштаб печати равен 1/4, то переменная DIMSCALE должна иметь значение 4.
  • Нанесение размеров в пространстве модели для печати в пространстве листа. В прежних версиях (более ранних по сравнению с AutoCAD 2002) при работе со сложными чертежами, содержащими несколько видов, этот способ был предпочтительным. Используйте этот способ при необходимости ссылаться на размеры в чертеже с помощью других чертежей (внешние ссылки) или при нанесении изометрических размеров в трехмерных изометрических видах. Для того чтобы отключить вывод размеров одного видового экрана листа на других, необходимо создайте отдельный слой размеров для каждого видового экрана листа, замораживаемый на всех остальных видовых экранах. Для автоматического масштабирования размеров при отображении в пространстве листа нужно присвоить системной переменной DIMSCALE значение 0.
  • Нанесение размеров в пространстве листа. Самый простой способ. Для построения размеров в пространстве листа выбираются объекты пространства модели или включается объектная привязка для позиционирования в точках объектов модели. По умолчанию устанавливается ассоциативная связь между размерами пространства листа и объектами модели. Дополнительное масштабирование для размеров, нанесенных в пространстве листа, не требуется. Для переменных DIMLFAC и DIMSCALE не требуется изменять значения по умолчанию (1,0000).
Примечание При нанесении размера объектов пространства модели в пространстве листа с помощью ассоциативных размеров размерные величины для масштаба отображения каждого видового экрана настраиваются автоматически. Эта настройка объединяется с текущим параметром для DIMLFAC и отображается с помощью команды СПИСОК как переопределение размерного стиля. Для неассоциативных размеров необходимо установить DIMLFAC вручную.
См. также

    • Рисование, масштабирование и аннотирование в пространстве модели

    • Масштабирование видов на видовых экранах листа

    • Масштабирование аннотаций


Задание масштаба размеров (Процедура)

Нанесение двусторонних допусков
Задание масштаба размеров
Задание масштаба размеров
Аннотирование чертежей > Размеры и допуски > Задание масштаба размеров >
Задание масштаба размеров
Понятие Процедура Краткий справочник

Задание глобального масштаба размеров

Задание масштаба размеров пространства модели на листах

Задание масштаба размеров, создаваемых в пространстве листа


Задание глобального масштаба размеров (Процедура)

Задание масштаба размеров
Задание масштаба размеров
Задание масштаба размеров
Аннотирование чертежей > Размеры и допуски > Задание масштаба размеров >
Задание масштаба размеров
Понятие Процедура Краткий справочник

Задание глобального масштаба размеров

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. На вкладке "Размещение" диалогового окна "Изменение размерного стиля" в группе "Масштаб размерных элементов" введите значение глобального масштабного коэффициента.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Задание масштаба размеров пространства модели на листах (Процедура)

Задание масштаба размеров
Задание масштаба размеров
Задание масштаба размеров
Аннотирование чертежей > Размеры и допуски > Задание масштаба размеров >
Задание масштаба размеров
Понятие Процедура Краткий справочник

Задание масштаба размеров пространства модели на листах

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактировать".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Размещение" в разделе "Масштаб размерных элементов" выберите "Масштаб размеров по листу".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Задание масштаба размеров, создаваемых в пространстве листа (Процедура)

Задание масштаба размеров
Задание масштаба размеров
Нанесение размеров
Аннотирование чертежей > Размеры и допуски > Задание масштаба размеров >
Задание масштаба размеров
Понятие Процедура Краткий справочник

Задание масштаба размеров, создаваемых в пространстве листа

  1. Выберите вкладку разметки листа, чтобы переключиться на пространство листа.
  2. Для нанесения размеров в пространстве листа с корректными размерными значениями пространства модели включить объектную привязку для позиционирования в точках модели из пространства листа или непосредственно указывать объекты, на которые наносятся размеры.

    Значение системной переменной DIMLFAC можно изменить в случае необходимости преобразования линейных размерных величин между британской и метрической системой единиц.


Задание масштаба размеров (Краткий справочник)

Нанесение двусторонних допусков
Задание масштаба размеров
Коротко о нанесении линейных размеров
Аннотирование чертежей > Размеры и допуски > Задание масштаба размеров >
Задание масштаба размеров
Понятие Процедура Краткий справочник

Команды

РЗМРЕГЕН

Обновление расположения всех ассоциативных размеров

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

DIMLFAC

Установка масштабного коэффициента для значений линейных размеров

DIMSCALE

Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение размеров

Задание масштаба размеров
Размеры и допуски
Нанесение линейных размеров
Аннотирование чертежей > Размеры и допуски >
Нанесение размеров
Понятие Процедура

Имеется возможность нанесения всех стандартных типов размеров.

Темы в этом разделе

  • Нанесение линейных размеров

    Имеется возможность наносить линейные размеры с горизонтальным, вертикальным или параллельным направлением размерных линий. Линейные размеры могут располагаться в несколько уровней или составлять размерные цепи.

  • Нанесение радиальных размеров

    Радиальные размеры иллюстрируют значения радиусов и диаметров дуг или кругов; для этих объектов существует также возможность нанесения маркеров центра и центровых линий.

  • Нанесение угловых размеров
  • Нанесение ординатных размеров
  • Создание размеров длины дуги

    Размеры длины дуги указывают расстояние вдоль дуги или дугового сегмента полилинии.


Нанесение размеров (Процедура)

Задание масштаба размеров
Нанесение размеров
Нанесение линейных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров >
Нанесение размеров
Понятие Процедура

Нанесение диаметра

Нанесение радиуса

Создание размера радиуса с изломом

Автоматическое создание центровых линий с помощью радиальных размеров

Создание центровых линий или маркеров центра для дуги или круга

Чтобы изменить режим отображения выносной линии дуги для размеров радиуса или диаметра

Нанесение углового размера

Нанесение ординатного размера

Создание размера длины дуги


Нанесение линейных размеров

Нанесение размеров
Нанесение размеров
Коротко о нанесении линейных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров >
Нанесение линейных размеров
Понятие Процедура

Имеется возможность наносить линейные размеры с горизонтальным, вертикальным или параллельным направлением размерных линий. Линейные размеры могут располагаться в несколько уровней или составлять размерные цепи.

Темы в этом разделе

  • Коротко о нанесении линейных размеров
  • Нанесение горизонтальных и вертикальных размеров

    Имеется возможность нанесения размеров, описывающих горизонтальные или вертикальные величины координат и линейных характеристик объектов.

  • Нанесение параллельных размеров

    Имеется возможность нанесения размера с размерной линией, проходящей параллельно прямой, проходящей через заданные точки образмериваемого объекта.

  • Нанесение размеров от общей базы и размерных цепей

    Размеры от общей базы - это последовательность размеров, отложенных от одной базовой линии. У размерных цепей начало каждого размера совпадает с концом предыдущего, т.е. каждый последующий размер имеет общую выносную линию с предыдущим.

  • Нанесение повернутых размеров
  • Нанесение размеров с наклонными выносными линиями

    Имеется возможность нанесения размеров, выносные линии которых не располагаются перпендикулярно размерным.


Нанесение линейных размеров (Процедура)

Нанесение размеров
На уровень вверх ..
Нанесение горизонтальных и вертикальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров >
Нанесение линейных размеров
Понятие Процедура

Нанесение горизонтального или вертикального размера

Нанесение параллельного размера

Нанесение линейных размеров от общей базы

Нанесение линейной размерной цепи

Нанесение повернутого размера

Изменение наклона выносных линий


Коротко о нанесении линейных размеров (Понятие)

Нанесение линейных размеров
Нанесение линейных размеров
Нанесение горизонтальных и вертикальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров >
Коротко о нанесении линейных размеров
Понятие Краткий справочник

Линейные размеры могут иметь горизонтальное, вертикальное или параллельное направление. Размерная линия параллельного размера ориентирована так же, как и отрезок (воображаемый или реальный), соединяющий размерные точки. Последовательности линейных размеров могут представлять собой размеры от общей базы или размерные цепи.

На следующих чертежах задаются начальные точки выносных линий в позициях 1 и 2. Положение размерной линии определяется указанием точки 3.

При нанесении линейного размера можно редактировать размерный текст, а также задавать углы направлений текста и размерной линии.


Коротко о нанесении линейных размеров (Краткий справочник)

Задание масштаба размеров
Коротко о нанесении линейных размеров
Нанесение горизонтальных и вертикальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Коротко о нанесении линейных размеров >
Коротко о нанесении линейных размеров
Понятие Краткий справочник

Команды

РЗМПАРАЛ

Нанесение параллельных линейных размеров

РЗМБАЗОВЫЙ

Нанесение линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера

РЗМЦЕПЬ

Нанесение линейных, угловых или ординатных размеров от второй выносной линии предыдущего или выбранного размера

РЗМРЕД

Редактирование размерного текста и выносных линий

РЗМЛИНЕЙНЫЙ

Нанесение линейного размера

РЗМСТИЛЬ

Создание и модификация размерных стилей

БРАЗМЕР

Быстрое создание серии размеров из выбранного объекта

Системные переменные

DIMDLI

Управление расстоянием между размерными линиями в базовых размерах

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение горизонтальных и вертикальных размеров (Понятие)

Коротко о нанесении линейных размеров
Нанесение линейных размеров
Нанесение параллельных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров >
Нанесение горизонтальных и вертикальных размеров
Понятие Процедура Краткий справочник

Имеется возможность нанесения размеров, описывающих горизонтальные или вертикальные величины координат и линейных характеристик объектов.

Программа автоматически наносит горизонтальный или вертикальный размер в соответствии с исходными точками выносных линий, указанными пользователем, или местом выбора объекта. Тем не менее, можно заменить этот размер при нанесении, указав его положение (горизонтальное или вертикальное). На следующем примере чертежа по умолчанию создается горизонтальный размер, который меняется пользователем на вертикальный.


Нанесение горизонтального или вертикального размера (Процедура)

Нанесение линейных размеров
На уровень вверх ..
Нанесение параллельных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение горизонтальных и вертикальных размеров >
Нанесение горизонтальных и вертикальных размеров
Понятие Процедура Краткий справочник

Нанесение горизонтального или вертикального размера

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Линейный". В командной строке введите "рзмлинейный".
  2. Нажмите клавишу ENTER для выбора объекта для нанесения размеров или укажите начальные точки первой и второй выносных линий.
  3. Перед указанием расположения размерной линии можно переопределить направление размера, отредактировать размерный текст, а также задать углы направлений текста и выносной линии.
    • Для поворота выносных линий введите п (Повернутый). Затем введите угол поворота размерной линии.
    • Для редактирования размерного текста введите м (МТекст). В контекстном редакторе измените текст. Нажмите "ОК".

      Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины, вычисленной программой. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.

    • Для поворота текста введите у (Угол). Затем введите угол поворота размерного текста.
  4. Укажите положение размерной линии.
Панель:Размер
Ввод команды: РЗМЛИНЕЙНЫЙ


Нанесение горизонтальных и вертикальных размеров (Краткий справочник)

Коротко о нанесении линейных размеров
Нанесение горизонтальных и вертикальных размеров
Нанесение параллельных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение горизонтальных и вертикальных размеров >
Нанесение горизонтальных и вертикальных размеров
Понятие Процедура Краткий справочник

Команды

РЗМЛИНЕЙНЫЙ

Нанесение линейного размера

Системные переменные

DIMEXO

Задание величины смещения выносных линий относительно исходных точек

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение параллельных размеров (Понятие)

Нанесение горизонтальных и вертикальных размеров
Нанесение линейных размеров
Нанесение размеров от общей базы и размерных цепей
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров >
Нанесение параллельных размеров
Понятие Процедура Краткий справочник

Имеется возможность нанесения размера с размерной линией, проходящей параллельно прямой, проходящей через заданные точки образмериваемого объекта.

Размерная линия в параллельных размерах расположена параллельно прямой, проходящей через размерные точки. Примеры параллельных размеров приведены на следующих двух чертежах. Выбирается объект (1) и указывается положение параллельного размера (2). Выносные линии наносятся автоматически.


Нанесение параллельного размера (Процедура)

Нанесение горизонтальных и вертикальных размеров
На уровень вверх ..
Нанесение размеров от общей базы и размерных цепей
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение параллельных размеров >
Нанесение параллельных размеров
Понятие Процедура Краткий справочник

Нанесение параллельного размера

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Параллельный". В командной строке введите "рзмпарал".
  2. Нажмите клавишу ENTER для выбора объекта для нанесения размеров или укажите начальные точки первой и второй выносных линий.
  3. Перед указанием расположения размерной линии можно отредактировать размерный текст и изменить угол его наклона. Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины, вычисленной программой. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.
    • Для редактирования многострочного размерного текста введите м (МТекст). В контекстном редакторе измените текст. Нажмите "ОК".
    • Для редактирования однострочного размерного текста введите т (Текст). Измените текст в командной строке и нажмите клавишу ENTER.
    • Для поворота текста введите у (Угол). Затем введите угол поворота размерного текста.
  4. Укажите положение размерной линии.
Панель:Размер
Ввод команды: РЗМПАРАЛ


Нанесение параллельных размеров (Краткий справочник)

Нанесение горизонтальных и вертикальных размеров
Нанесение параллельных размеров
Нанесение размеров от общей базы и размерных цепей
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение параллельных размеров >
Нанесение параллельных размеров
Понятие Процедура Краткий справочник

Команды

РЗМПАРАЛ

Нанесение параллельных линейных размеров

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMEXO

Задание величины смещения выносных линий относительно исходных точек

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение размеров от общей базы и размерных цепей (Понятие)

Нанесение параллельных размеров
Нанесение линейных размеров
Нанесение повернутых размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров >
Нанесение размеров от общей базы и размерных цепей
Понятие Процедура Краткий справочник

Размеры от общей базы - это последовательность размеров, отложенных от одной базовой линии. У размерных цепей начало каждого размера совпадает с концом предыдущего, т.е. каждый последующий размер имеет общую выносную линию с предыдущим.

Для нанесения размеров от общей базы или размерной цепи для изделия должен быть проставлен хотя бы один линейный, ординатный или угловой размер. Величина каждого следующего размера из последовательности размеров от общей базы увеличивается по сравнению с величиной предыдущего размера.

Если не укажите начальную размерную точку, то базовая линия или первая выносная линия размерной цепи располагаются на месте второй выносной линии последнего нанесенного размера.


Нанесение размеров от общей базы и размерных цепей (Процедура)

Нанесение параллельных размеров
На уровень вверх ..
Нанесение размеров от общей базы и размерных цепей
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение размеров от общей базы и размерных цепей >
Нанесение размеров от общей базы и размерных цепей
Понятие Процедура Краткий справочник

Нанесение линейных размеров от общей базы

Нанесение линейной размерной цепи


Нанесение линейных размеров от общей базы (Процедура)

Нанесение размеров от общей базы и размерных цепей
На уровень вверх ..
Нанесение размеров от общей базы и размерных цепей
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение размеров от общей базы и размерных цепей >
Нанесение размеров от общей базы и размерных цепей
Понятие Процедура Краткий справочник

Нанесение линейных размеров от общей базы

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Базовый". В командной строке введите "рзмбазовый".

    По умолчанию первая выносная линия нового размера определяется начальной точкой последнего линейного размера. Появится запрос второй размерной линии.

  2. Воспользоваться объектной привязкой для указания начальной точки второй выносной линии или нажмите ENTER для выбора другого размера в качестве базового.

    Программа автоматически размещает вторую размерную линию на расстоянии, указанном с помощью параметра "Шаг в базовых размерах" на вкладке "Линии" Диспетчера размерных стилей.

  3. Воспользоваться объектной привязкой для указания начальной точки следующей выносной линии.
  4. При необходимости провести указание начальных точек последующих выносных линий.
  5. Для завершения команды нажмите ENTER дважды.
Панель:Размер
Ввод команды: РЗМБАЗОВЫЙ


Нанесение линейной размерной цепи (Процедура)

Нанесение размеров от общей базы и размерных цепей
На уровень вверх ..
Нанесение повернутых размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение размеров от общей базы и размерных цепей >
Нанесение размеров от общей базы и размерных цепей
Понятие Процедура Краткий справочник

Нанесение линейной размерной цепи

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Продолжить". В командной строке введите "рзмцепь".

    Программа использует исходную точку второй выносной линии существующего размера в качестве исходной точки первой выносной линии.

  2. Воспользоваться объектной привязкой для указания начальных точек последующих выносных линий.
  3. Для завершения команды нажмите ENTER дважды.
Панель:Размер
Ввод команды: РЗМЦЕПЬ


Нанесение размеров от общей базы и размерных цепей (Краткий справочник)

Нанесение параллельных размеров
Нанесение размеров от общей базы и размерных цепей
Нанесение повернутых размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение размеров от общей базы и размерных цепей >
Нанесение размеров от общей базы и размерных цепей
Понятие Процедура Краткий справочник

Команды

РЗМБАЗОВЫЙ

Нанесение линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера

РЗМЦЕПЬ

Нанесение линейных, угловых или ординатных размеров от второй выносной линии предыдущего или выбранного размера

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

DIMDLI

Управление расстоянием между размерными линиями в базовых размерах

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение повернутых размеров (Понятие)

Нанесение размеров от общей базы и размерных цепей
Нанесение линейных размеров
Нанесение размеров с наклонными выносными линиями
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров >
Нанесение повернутых размеров
Понятие Процедура Краткий справочник

В повернутом размере размерная линия проходит под заданным углом поворота относительно начальной точки выносной линии. На следующем чертеже показан пример повернутого размера. Здесь угол поворота размерной линии равен углу расположения щели, на которую наносятся размеры.


Нанесение повернутого размера (Процедура)

Нанесение размеров от общей базы и размерных цепей
На уровень вверх ..
Нанесение размеров с наклонными выносными линиями
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение повернутых размеров >
Нанесение повернутых размеров
Понятие Процедура Краткий справочник

Нанесение повернутого размера

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Линейный". В командной строке введите "рзмлинейный".
  2. Нажмите клавишу ENTER для выбора объекта для нанесения размеров или укажите начальные точки первой и второй выносных линий.
  3. Для поворота размерной линии введите п (Повернутый). Затем введите угол поворота размерной линии.
  4. Укажите положение размерной линии.
Панель:Размер
Ввод команды: РЗМЛИНЕЙНЫЙ


Нанесение повернутых размеров (Краткий справочник)

Нанесение размеров от общей базы и размерных цепей
Нанесение повернутых размеров
Нанесение размеров с наклонными выносными линиями
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение повернутых размеров >
Нанесение повернутых размеров
Понятие Процедура Краткий справочник

Команды

РЗМПАРАЛ

Нанесение параллельных линейных размеров

РЗМЛИНЕЙНЫЙ

Нанесение линейного размера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение размеров с наклонными выносными линиями (Понятие)

Нанесение повернутых размеров
Нанесение линейных размеров
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров >
Нанесение размеров с наклонными выносными линиями
Понятие Процедура Краткий справочник

Имеется возможность нанесения размеров, выносные линии которых не располагаются перпендикулярно размерным.

Выносные линии строятся перпендикулярно размерной линии. Однако в случае, если выносные линии ухудшают удобочитаемость других элементов чертежа, угол их наклона можно изменить уже после создания размера.

Применение наклона к существующему размеру не действует на размеры, строящиеся после этого.


Изменение наклона выносных линий (Процедура)

Нанесение повернутых размеров
На уровень вверх ..
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение размеров с наклонными выносными линиями >
Нанесение размеров с наклонными выносными линиями
Понятие Процедура Краткий справочник

Изменение наклона выносных линий

  1. Выберите пункт меню "Размер" [image] "Наклон".В командной строке введите "рзмред".
  2. Выберите размер.
  3. Введите значение угла наклона или укажите две точки.
Панель:Размер
Ввод команды: РЗМРЕД


Нанесение размеров с наклонными выносными линиями (Краткий справочник)

Нанесение повернутых размеров
Нанесение размеров с наклонными выносными линиями
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение линейных размеров > Нанесение размеров с наклонными выносными линиями >
Нанесение размеров с наклонными выносными линиями
Понятие Процедура Краткий справочник

Команды

РЗМРЕД

Редактирование размерного текста и выносных линий

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение радиальных размеров (Понятие)

Нанесение размеров с наклонными выносными линиями
Нанесение размеров
Нанесение угловых размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Радиальные размеры иллюстрируют значения радиусов и диаметров дуг или кругов; для этих объектов существует также возможность нанесения маркеров центра и центровых линий.

Существует два типа радиальных размеров.

  • РЗМРАДИУС - размер радиуса дуги или окружности; перед текстом размера отображается буква R.

  • РЗМДИАМЕТР - размер диаметра дуги или окружности; перед текстом размера отображается обозначение диаметра.

Если угол наклона радиальной размерной линии больше 15 градусов (от горизонтальной плоскости), для размерного текста, расположенного по горизонтали, создается полка выноски, также называемая ломаной линией или площадкой, рядом с размерным текстом.

Управление выносными линиями

При простановке размеров дуги радиальный или горизонтальный размер не обязательно располагается в пределах дуги. При постановке размера после конечной точки дуги может быть проведена выносная линия, повторяющая траекторию дуги. При подавлении (выключении) выносной линии размерная линия радиуса или диаметра проводится через центральную точку дуги, а не к выносной линии.

Системная переменная DIMSE1 управляет отображением выносной линии при размере радиуса или диаметра, когда размер располагается в стороне от конечной точки дуги. Если отображение выносной линии дуги не подавляется, то между дугой и ее выносной линией отображается зазор. Размер зазора определяется системной переменной DIMEXO.

Управление центровыми линиями и метками центра

В зависимости от настроек размерного стиля, маркер центра и центровые линии для размеров радиуса и диаметра создаются автоматически. Они создаются только в том случае, если размерная линия расположена за пределами круги или дуги. Центровые линии и маркеры центра можно создавать напрямую с помощью команды РЗМЦЕНТР.

Размером и видимостью центровых линий и маркеров центра можно управлять в диалоговом окне "Изменение размерного стиля" на вкладке "Символы и стрелки" в разделе "Маркеры центра". Доступ к этим настройкам можно также получить с помощью системной переменной DIMCEN.

Размер центровой линии равен длине сегмента центровой линии, выходящего за пределы круга или дуги. Это также и размер промежутка между маркером центра и началом центровой линии. Размер маркера центра равен расстоянию от центра круга или дуги до конца маркера центра.

Создание размеров радиуса с изломом

Если центр дуги или окружности находится вне пределов компоновки, и его отображение в истинном местоположении невозможно, с помощью команды РЗМИЗЛОМ можно создать размеры радиуса с изломом - так называемые "укороченные размеры радиуса". Исходную точку размера можно задайте в более удобном месте, называемом переопределением положения центра.

Углом ломаной линии по умолчанию можно управлять в диалоговом окне "Изменение размерного стиля" на вкладке "Символы и стрелки" в разделе "Ломаная размера радиуса".

После создания размера радиуса с изломом его, а также положение центра можно изменять следующим образом:

  • С помощью ручек для перемещения элементов.
  • Изменяя положение элементов с помощью палитры свойств.
  • С помощью команды РАСТЯНУТЬ.
ПримечаниеВ версиях, предшествующих AutoCAD 2006, размеры радиуса с изломом можно просматривать, но не редактировать. Кроме того, значительное редактирование связанных объектов может привести к непредсказуемым результатам для размера радиуса с изломом.
См. также

    • Размещение размерного текста между выносными линиями


Нанесение радиальных размеров (Процедура)

Нанесение размеров с наклонными выносными линиями
На уровень вверх ..
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Нанесение диаметра

Нанесение радиуса

Создание размера радиуса с изломом

Автоматическое создание центровых линий с помощью радиальных размеров

Создание центровых линий или маркеров центра для дуги или круга

Чтобы изменить режим отображения выносной линии дуги для размеров радиуса или диаметра


Нанесение диаметра (Процедура)

Нанесение радиальных размеров
На уровень вверх ..
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Нанесение диаметра

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Диаметр". В командной строке введите "рзмдиаметр".
  2. Выберите дугу или круг для нанесения размеров.
  3. Введите необходимые опции:
    • Для редактирования размерного текста введите т (Текст) или м (МТекст). Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.
    • Для задания угла нанесения размерного текста введите у (Угол).
  4. Укажите положение линии выноски.
Панель:Размер
Ввод команды: РЗМДИАМЕТР


Нанесение радиуса (Процедура)

Нанесение радиальных размеров
На уровень вверх ..
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Нанесение радиуса

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Радиус". В командной строке введите "рзмрадиус".
  2. Выберите дугу, круг или дуговой сегмент полилинии.
  3. Введите необходимые опции:
    • Для редактирования размерного текста введите т (Текст) или м (МTекст). Редактирование текста в скобках (<>) приводит к изменению или удалению размерной величины. Для добавления текстовых элементов до и после размерного числа следует введите текст до и после угловых скобок соответственно.
    • Для задания угла нанесения размерного текста введите у (Угол).
  4. Укажите положение линии выноски.
Панель:Размер
Ввод команды: РЗМРАДИУС


Создание размера радиуса с изломом (Процедура)

Нанесение радиальных размеров
На уровень вверх ..
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Создание размера радиуса с изломом

  1. Выберите меню "Размер" [image] "С изломом". В командной строке введите "рзмизлом".
  2. Выберите дугу, круг или дуговой сегмент полилинии.
  3. Укажите исходную точку размера (переопределение положения центра).
  4. Укажите точку угла размерной линии и положение размерного текста.
  5. Укажите другую точку для расположения излома размерной линии.
Панель:Размер
Ввод команды: РЗМИЗЛОМ


Автоматическое создание центровых линий с помощью радиальных размеров (Процедура)

Нанесение радиальных размеров
На уровень вверх ..
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Автоматическое создание центровых линий с помощью радиальных размеров

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Изменение размерного стиля", на вкладке "Символы и стрелки" в группе "Маркер центра" нажмите "Отрезок".
  4. В поле "Размер" введите длину выброса осевой линии. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.

В поле предварительного просмотра диалогового окна отобразятся результаты внесенных изменений.

Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Создание центровых линий или маркеров центра для дуги или круга (Процедура)

Нанесение радиальных размеров
На уровень вверх ..
Нанесение радиальных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Создание центровых линий или маркеров центра для дуги или круга

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Изменение размерного стиля", на вкладке "Символы и стрелки" в группе "Маркер центра" нажмите "Отрезок".
  4. В поле "Размер" введите длину выброса осевой линии. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
  6. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Маркер центра". В командной строке введите "рзмцентр".
  7. Выберите дугу или круг.
Панель:Размер
Ввод команды: РЗМЦЕНТР


Чтобы изменить режим отображения выносной линии дуги для размеров радиуса или диаметра (Процедура)

Нанесение радиальных размеров
На уровень вверх ..
Нанесение угловых размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Чтобы изменить режим отображения выносной линии дуги для размеров радиуса или диаметра

  1. Выберите размер радиуса или диаметра, выносную линию дуги которого необходимо подавить.
  2. Нажмите правой кнопкой мыши на чертеже. Нажмите кнопку "Свойства".
  3. В палитре свойств, в категории "Линии и стрелки" выберите "Вын линия".
  4. Щелкните на стрелке рядом с полем "Вын линия" и выберите пункт "Вкл" или "Выкл" из списка.
    • Для отображения выносной линии дуги выберите "Вкл".
    • Для подавления выносной линии дуги выберите "Выкл".
  5. Чтобы отменить выбор размера, нажмите клавишу ESC.
Панель:"Стандартная" и стандартные аннотации
Ввод команды: ОКНОСВ


Нанесение радиальных размеров (Краткий справочник)

Нанесение размеров с наклонными выносными линиями
Нанесение радиальных размеров
Нанесение угловых размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение радиальных размеров >
Нанесение радиальных размеров
Понятие Процедура Краткий справочник

Команды

РЗМЦЕНТР

Нанесение маркеров центра или центровых линий для кругов и дуг

РЗМДИАМЕТР

Нанесение диаметра окружности или дуги

РЗМИЗЛОМ

Нанесение размеров с изломом для окружностей и дуг

РЗМРАДИУС

Нанесение радиуса окружности или дуги

РЗМСТИЛЬ

Сохранение имени текущего размерного стиля

БРАЗМЕР

Быстрое создание серии размеров из выбранного объекта

Системные переменные

DIMATFIT

Определение способа размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях

DIMCEN

Управление рисованием маркеров центра и центровых линий кругов и дуг с помощью команд РЗМЦЕНТР, РЗМДИАМЕТР и РЗМРАДИУС

DIMEXO

Задание величины смещения выносных линий относительно исходных точек

DIMJOGANG

Определение угла поперечного сегмента размерной линии в линии радиуса с изломом

DIMJUST

Управление положением размерного текста по горизонтали

DIMSE1

Подавление отображения первой выносной линии

DIMTAD

Управление расположением текста по вертикали относительно размерной линии

DIMTIH

Управление ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями

DIMTMOVE

Установка правил перемещения размерного текста

DIMTOFL

Управление построением размерной линии между выносными линиями, даже если текст размещается вне линий

DIMTOH

Управление ориентацией размерного текста за выносными линиями

DIMUPT

Управление действием курсора при пользовательском расположении текста

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение угловых размеров (Понятие)

Нанесение радиальных размеров
Нанесение размеров
Нанесение ординатных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров >
Нанесение угловых размеров
Понятие Процедура Краткий справочник

Угловые размеры наносятся для обозначения углов между двумя отрезками или тремя точками. Для выбора измеряемого угла между двумя радиусами круга необходимо выбрать круг и указать конечные точки, определяющие угол с вершиной в центре круга. Для нанесения размеров на другие выбранные объекты следует указать положение размера. Кроме того, угловой размер можно нанести заданием вершины угла и образующих конечных точек. При создании размера перед указанием положения размерной линии можно отредактировать размерный текст и задать его ориентацию.

ПримечаниеИмеется возможность наносить размеры от общей базы и размерные цепи угловых размеров относительно уже существующих угловых размеров. Размеры от общей базы и цепи угловых размеров наносятся только в пределах 180 градусов. Это ограничение можно преодолеть, если с помощью ручек увеличить выносную линию размерной цепи или размера от общей базы.

Размерные линии

Если угол образован двумя непараллельными прямыми, размерная дуга стягивает угол между ними. Если дуга размерной линии не пересекается с одной или обеими измеряемыми линиями, программа проводит одну или две выносные линии для пересечения с дугой размерной линии. Стягиваемый угол всегда меньше 180 градусов.

Образмеривание кругов и дуг

Если для задания угла используется дуга, круг или три точки, программа проводит дугу размерной линии между выносными линиями. Выносные линии проходят из конечных точек, определяющих угол, до пересечений с размерной дугой.

Заданное положение размерной дуги определяет квадрант угла, на который наносятся размеры.

Простановка размеров с указанием квадранта

При простановке размеров для угла, определяемого конечными точками линии или дуги, центром окружности или двумя вершинами, угловые размеры могут относиться к конкретному квадранту. Создаваемый угловой размер может соответствовать одному из четырех квадрантов. Задание конкретного квадранта гарантирует правильность простановки углового размера. Если угловой размер проставляется после задания квадранта, текст размера можно поместить за пределами выносных линий размера. В этом случае автоматически вычерчивается продолжение размерной линии.


Нанесение углового размера (Процедура)

Нанесение радиальных размеров
На уровень вверх ..
Нанесение ординатных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение угловых размеров >
Нанесение угловых размеров
Понятие Процедура Краткий справочник

Нанесение углового размера

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Угловой". В командной строке введите "рзмугловой".
  2. Воспользуйтесь одним из следующих способов:
    • Для нанесения размеров на круг, выберите круг, указав первую конечную точку угла. Затем укажите вторую конечную точку.
    • Для нанесения размеров на любой другой объект укажите первый отрезок, определяющий сторону измеряемого угла. Затем укажите второй отрезок.
  3. Введите необходимые опции:
    • Для редактирования размерного текста введите т (Текст) или м (МТекст). Редактирование текста в скобках (<>) приводит к изменению или удалению вычисленной размерной величины. Для добавления текстовых элементов до и после размерного числа следует ввести текст до и после угловых скобок соответственно.
    • Для задания угла нанесения размерного текста введите у (Угол).
    • Если требуется связать размер с квадрантом, введите "q" (квадрант) и укажите требуемый квадрант.
  4. Укажите положение размерной дуги.
Панель:Размер
Ввод команды: РЗМУГЛОВОЙ


Нанесение угловых размеров (Краткий справочник)

Нанесение радиальных размеров
Нанесение угловых размеров
Нанесение ординатных размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение угловых размеров >
Нанесение угловых размеров
Понятие Процедура Краткий справочник

Команды

РЗМУГЛОВОЙ

Нанесение угловых размеров

РЗМБАЗОВЫЙ

Нанесение линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера

РЗМЦЕПЬ

Нанесение линейных, угловых или ординатных размеров от второй выносной линии предыдущего или выбранного размера

Системные переменные

DIMADEC

Управление отображением числа точных знаков в угловых размерах

DIMAUNIT

Задание формата единиц измерения для угловых размеров

DIMDEC

Задание числа десятичных знаков, отображаемых для основных единиц размера

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение ординатных размеров (Понятие)

Нанесение угловых размеров
Нанесение размеров
Создание размеров длины дуги
Аннотирование чертежей > Размеры и допуски > Нанесение размеров >
Нанесение ординатных размеров
Понятие Процедура Краткий справочник

Ординатные размеры указывают перпендикулярную проекцию расстояния от точки отсчета, которая называется базой, до элемента, например, отверстия в детали. Вычисление значений этих размеров относительно базы позволяет избежать возможных ошибок в размерах, связанных с накоплением погрешностей.

Ординатные размеры состоят из значения координаты X или Y и выноски. X - ординатные размеры - указывают расстояние элемента от базы по оси X. Ординатные размеры по оси Y указывают расстояние по оси Y.

Задание базы

Значения ординатных размеров зависит от положения начала координат и ориентации осей в текущей пользовательской системе координат. Как правило, перед созданием координатных размеров базу помещают в начало координат.

Задание положения выноски

После задания местоположения элемента отображается запрос на ввод концевой точки выноски. По умолчанию указанная пользователем концевая точка выноски определяет тип создаваемого ординатного размера - по оси X или по оси Y. Например, для создания ординатного размера по оси X следует расположить концевую точку выноски ближе к вертикали, чем к горизонтали.

После создания ординатного размера можно без затруднений переместить выноску и текст размера путем редактирования с помощью ручек. Текст размера всегда расположен параллельно ординатной линии выноски.


Нанесение ординатного размера (Процедура)

Нанесение угловых размеров
На уровень вверх ..
Создание размеров длины дуги
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение ординатных размеров >
Нанесение ординатных размеров
Понятие Процедура Краткий справочник

Нанесение ординатного размера

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Ординатный". В командной строке введите "рзмордината".
  2. Если необходимо построить прямые выноски, то включите режим "Орто".
  3. В ответ на запрос "Укажите положение элемента" укажите точку.
  4. Введите x (Xзначение) или y (Yзначение).

    Данный пункт можно пропустить, если необходимо соединить конец выноски с вертикалью для обозначения координаты X базы или с горизонталью для обозначения координаты Y.

  5. Укажите конечную точку выноски.
Панель:Размер
Ввод команды: РЗМОРДИНАТА


Нанесение ординатных размеров (Краткий справочник)

Нанесение угловых размеров
Нанесение ординатных размеров
Создание размеров длины дуги
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Нанесение ординатных размеров >
Нанесение ординатных размеров
Понятие Процедура Краткий справочник

Команды

РЗМОРДИНАТА

Нанесение ординатных размеров

БРАЗМЕР

Быстрое создание серии размеров из выбранного объекта

ПСК

Управление пользовательскими системами координат

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание размеров длины дуги (Понятие)

Нанесение ординатных размеров
Нанесение размеров
Редактирование размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров >
Создание размеров длины дуги
Понятие Процедура Краткий справочник

Размеры длины дуги указывают расстояние вдоль дуги или дугового сегмента полилинии.

Типичные применения размеров длины дуги включают измерение расстояния перемещения вокруг шаблона и указание длины кабеля. Чтобы отличать эти размеры от линейных и угловых, для размеров длины дуги по умолчанию отображается обозначение дуги.

Символ дуги, также называемый "шляпка" или "крышка", отображается над или перед размерным текстом. Стиль размещения можно задайте с помощью Диспетчера размерных стилей. Его можно изменить на вкладке "Символы и стрелки" диалогового окна "Новый размерный стиль" или "Изменение размерного стиля".

Выносные линии размера длины дуги могут быть ортогональными или радиальными.

ПримечаниеОртогональные выносные линии отображаются только в случае, если прилежащий угол дуги меньше 90 градусов.


Создание размера длины дуги (Процедура)

Нанесение ординатных размеров
На уровень вверх ..
Редактирование размеров
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Создание размеров длины дуги >
Создание размеров длины дуги
Понятие Процедура Краткий справочник

Создание размера длины дуги

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Длина дуги". В командной строке введите "рзмдуги".
  2. Выберите дугу или дуговой сегмент полилинии.
  3. Укажите положение размерной линии.
Панель:Размер
Ввод команды: РЗМДУГА


Создание размеров длины дуги (Краткий справочник)

Нанесение ординатных размеров
Создание размеров длины дуги
Назначение нового размерного стиля для уже нанесенного размера
Аннотирование чертежей > Размеры и допуски > Нанесение размеров > Создание размеров длины дуги >
Создание размеров длины дуги
Понятие Процедура Краткий справочник

Команды

РЗМДУГА

Создает размер длины дуги

РЗМСТИЛЬ

Создание и модификация размерных стилей

ОКНОСВ

Управление свойствами объектов

Системные переменные

DIMARCSYM

Управление отображением обозначения дуги в размере длины дуги

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование размеров

Создание размеров длины дуги
Размеры и допуски
Назначение нового размерного стиля для уже нанесенного размера
Аннотирование чертежей > Размеры и допуски >
Редактирование размеров
Понятие Процедура

Редактирование нанесенных размеров может осуществляться либо отдельно для каждого размерного объекта, либо глобально путем изменения размерных стилей.

Темы в этом разделе

  • Назначение нового размерного стиля для уже нанесенного размера

    Редактирование нанесенных размеров может выполняться путем назначения другого размерного стиля. Отредактировав размерный стиль, можно обновить или оставить без изменений уже нанесенные размеры, связанные с этим стилем.

  • Переопределение размерных стилей

    С помощью переопределений размерного стиля можно временно изменять значения размерных переменных без редактирования текущего размерного стиля.

  • Изменение размера

    Предусмотрена возможность включения в размер дополнительной информации (помимо значения размера). Можно также изменить внешний вид размера путем применения масок и настройки интервалов между ними.

  • Редактирование размерного текста

    Размерный текст в нанесенном размере можно отредактировать или заменить на новый, а также изменить его положение и угол поворота.

  • Редактирование геометрии размеров

    Редактирование с помощью ручек - наиболее быстрый и удобный способ изменения расположения размерных элементов. Способ редактирования размеров зависит от наличия ассоциативной связи между размерами и объектами.

  • Изменение ассоциативности размеров

    В некоторых случаях может понадобиться изменить ассоциативность размеров. Например, размеры, нанесенные на чертеже с помощью предыдущих версий программы, можно сделать ассоциативными.


Редактирование размеров (Процедура)

Создание размеров длины дуги
Редактирование размеров
Назначение нового размерного стиля для уже нанесенного размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров >
Редактирование размеров
Понятие Процедура

Назначение текущего размерного стиля уже нанесенным размерам

Восстановление размерного стиля

Переопределение размерного стиля

Назначение переопределений размерного стиля

Поворот размерного текста

Возврат размерного текста в исходное положение

Редактирование размерного текста

Перемещение текста вдоль размерной линии влево

Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях

Изменение отступа выносных линий от объекта

Ассоциативное прикрепление размеров к объектам

Разрыв ассоциативной связи размеров с объектами


Назначение нового размерного стиля для уже нанесенного размера (Понятие)

Редактирование размеров
Редактирование размеров
Переопределение размерных стилей
Аннотирование чертежей > Размеры и допуски > Редактирование размеров >
Назначение нового размерного стиля для уже нанесенного размера
Понятие Процедура Краткий справочник

Редактирование нанесенных размеров может выполняться путем назначения другого размерного стиля. Отредактировав размерный стиль, можно обновить или оставить без изменений уже нанесенные размеры, связанные с этим стилем.

Для создаваемого размера используется текущий размерный стиль. Размер сохраняет все настройки, заданные связанным с ним размерным стилем, до назначения нового размерного стиля или установки переопределений стиля.

Редактирование нанесенных размеров может выполняться путем назначения другого размерного стиля. Отредактировав размерный стиль, можно обновить или оставить без изменений уже нанесенные размеры, связанные с этим стилем.

Для выбранных размеров можно восстановить имеющийся размерный стиль или назначить текущий размерный стиль, включая все переопределения.


Назначение нового размерного стиля для уже нанесенного размера (Процедура)

Редактирование размеров
На уровень вверх ..
Назначение нового размерного стиля для уже нанесенного размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Назначение нового размерного стиля для уже нанесенного размера >
Назначение нового размерного стиля для уже нанесенного размера
Понятие Процедура Краткий справочник

Назначение текущего размерного стиля уже нанесенным размерам

Восстановление размерного стиля


Назначение текущего размерного стиля уже нанесенным размерам (Процедура)

Назначение нового размерного стиля для уже нанесенного размера
На уровень вверх ..
Назначение нового размерного стиля для уже нанесенного размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Назначение нового размерного стиля для уже нанесенного размера >
Назначение нового размерного стиля для уже нанесенного размера
Понятие Процедура Краткий справочник

Назначение текущего размерного стиля уже нанесенным размерам

  1. Выберите пункт меню "Размер" [image] "Обновить".В командной строке введите "рзмстиль".
  2. Выберите размеры для их обновления с параметрами текущего размерного стиля.
  3. Нажмите ENTER.
Панель:Размер
Ввод команды: РЗМСТИЛЬ


Восстановление размерного стиля (Процедура)

Назначение нового размерного стиля для уже нанесенного размера
На уровень вверх ..
Переопределение размерных стилей
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Назначение нового размерного стиля для уже нанесенного размера >
Назначение нового размерного стиля для уже нанесенного размера
Понятие Процедура Краткий справочник

Восстановление размерного стиля

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите размерный стиль, который необходимо восстановить. Нажмите кнопку "Установить".
  3. Нажмите кнопку "Закрыть".
Панель:Размер
Ввод команды: РЗМСТИЛЬ

Другой способ

  • Выберите стиль из выпадающего списка "Управление размерными стилями" на панели "Стили".


Назначение нового размерного стиля для уже нанесенного размера (Краткий справочник)

Создание размеров длины дуги
Назначение нового размерного стиля для уже нанесенного размера
Переопределение размерных стилей
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Назначение нового размерного стиля для уже нанесенного размера >
Назначение нового размерного стиля для уже нанесенного размера
Понятие Процедура Краткий справочник

Команды

РЗМПОДАВИТЬ

Переопределение установок размерных переменных

РЗМСТИЛЬ

Создание и модификация размерных стилей

ОКНОСВ

Управление свойствами объектов

Системные переменные

DIMCLRD

Указание цветов размерных линий, стрелок и размерных линий выноски

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Переопределение размерных стилей (Понятие)

Назначение нового размерного стиля для уже нанесенного размера
Редактирование размеров
Изменение размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров >
Переопределение размерных стилей
Понятие Процедура Краткий справочник

С помощью переопределений размерного стиля можно временно изменять значения размерных переменных без редактирования текущего размерного стиля.

Переопределения размерного стиля позволяют изменять отдельные параметры текущего размерного стиля. При этом происходит изменение значений размерных переменных без редактирования текущего размерного стиля.

Переопределения могут затрагивать параметры размерного стиля как для отдельных размеров, так и для всего текущего размерного стиля.

  • Переопределения в отдельных размерах используются для улучшения читаемости чертежа, когда, например, необходимо подавить нанесение выносных линий, отредактировать размерный текст или изменить положение стрелок, чтобы расположенные рядом размеры не перекрывали друг друга. При этом новые размерные стили не создаются.
  • Можно также переопределить параметры в текущем размерном стиле. Переопределения учитываются при создании новых размеров до тех пор, пока пользователь не сохранит их в новом стиле или не установит текущим другой стиль. Например, при выборе параметра "Переопределить" в Диспетчере размерных стилей и изменении цвета выносных линий на вкладке "Линии" текущий размерный стиль не изменится. Новое значение цвета сохраняется в системной переменной DIMCLRE. Таким образом, вновь создаваемые размеры строятся с выносными линиями нового цвета. Переопределения можно сохранить как новый размерный стиль.

Настройки некоторых свойств размеров общеприняты для всего чертежа и размерного стиля, поэтому они заданы в размерном стиле постоянно. Другие параметры, наоборот, используются индивидуально для каждого размера, поэтому их удобнее задавать с помощью переопределений. Например, в чертежах обычно применяется один простой вид стрелок, следовательно вид стрелки лучше задайте и сохранить в размерном стиле. Подавление выносных линий, наоборот, используется лишь в отдельных случаях и этот режим лучше задавать с помощью переопределения размерного стиля.

Существует несколько способов переопределения параметров размерных стилей. Можно изменить значения параметров в диалоговых окнах или значения системных переменных в командной строке. Можно отменить переопределения и восстановить исходные параметры. Установленные переопределения применяются при создании всех последующих размеров до момента отмены переопределений или смены текущего размерного стиля.

Пример: Переопределение размерного стиля в командной строке

Переопределение текущего размерного стиля во время построения размера выполняется путем ввода имени любой размерной переменной в ответ на любой запрос. В этом примере изменяется цвет размерной линии. Изменение цвета продолжает действовать при создании последующих размеров до момента отмены переопределения или смены текущего размерного стиля.

Команда: рзмподавить

Введите имя переменной размера для переопределения или "dimclrd" для отмены переопределений

Введите новой значение для переменной размера <BYBLOCK>: 5

Введите имя переменной размера для переопределения: введите другое имя переменной размера или нажмите клавишу ENTER

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов


Переопределение размерных стилей (Процедура)

Назначение нового размерного стиля для уже нанесенного размера
На уровень вверх ..
Переопределение размерных стилей
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Переопределение размерных стилей >
Переопределение размерных стилей
Понятие Процедура Краткий справочник

Переопределение размерного стиля

Назначение переопределений размерного стиля


Переопределение размерного стиля (Процедура)

Переопределение размерных стилей
На уровень вверх ..
Переопределение размерных стилей
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Переопределение размерных стилей >
Переопределение размерных стилей
Понятие Процедура Краткий справочник

Переопределение размерного стиля

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В окне "Диспетчер размерных стилей" выберите переопределяемый размерный стиль. Нажмите "Переопределить".
  3. В диалоговом окне "Переопределение текущего стиля" изменить размерный стиль, выбрав соответствующую вкладку.
  4. Нажмите "OK" для возврата в Диспетчер размерных стилей.

    Установленные переопределения включаются в список размерных стилей под именем переопределенного стиля.

  5. Нажмите кнопку "Закрыть".
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Назначение переопределений размерного стиля (Процедура)

Переопределение размерных стилей
На уровень вверх ..
Изменение размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Переопределение размерных стилей >
Переопределение размерных стилей
Понятие Процедура Краткий справочник

Назначение переопределений размерного стиля

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей нажмите кнопку "Переопределить".
  3. В диалоговом окне "Переопределение текущего стиля" введите переопределения стиля. Нажмите "ОК".

    В диалоговом окне "Диспетчер размерных стилей" под именем размерного стиля отображается <переопределения стиля>. Переопределения не препятствуют внесению изменений в стили, их можно также сравнивать с другими стилями, удалять или переименовывать.

Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Переопределение размерных стилей (Краткий справочник)

Назначение нового размерного стиля для уже нанесенного размера
Переопределение размерных стилей
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Переопределение размерных стилей >
Переопределение размерных стилей
Понятие Процедура Краткий справочник

Команды

РЗМПОДАВИТЬ

Переопределение установок размерных переменных

РЗМСТИЛЬ

Создание и модификация размерных стилей

ОКНОСВ

Управление свойствами объектов

Системные переменные

DIMCLRD

Указание цветов размерных линий, стрелок и размерных линий выноски

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение размера

Переопределение размерных стилей
Редактирование размеров
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров >
Изменение размера
Понятие Процедура

Предусмотрена возможность включения в размер дополнительной информации (помимо значения размера). Можно также изменить внешний вид размера путем применения масок и настройки интервалов между ними.

После создания размера может потребоваться изменить представленную в нем информацию. К линейному размеру можно добавить линию излома, указывающую на то, что значение размера не соответствует фактическому значению измеряемой величины; можно также добавить контрольный размер, определяющий частоту проверки значения размера для изготовленной детали.

В некоторых случаях изменение размера требуется для повышения удобочитаемости. Можно запретить расположение выносных и размерных линий поверх объектов, а также задать размещение линейных размеров с равными интервалами.

Темы в этом разделе

  • Излом размера

    К линейным размерам можно добавлять линии излома. Линии излома служат для отображения значения размера, не соответствующего фактическому значению измеряемой величины. Как правило, фактическое значение измеряемой величины меньше отображаемого значения.

  • Контрольный размер

    Контрольные размеры представляют собой удобный способ задания частоты, с которой следует проверять изготовленные детали на соответствие значения размера и допусков заданному диапазону.

  • Маски размеров

    Маски размеров позволяют избежать такого представления размерных и выносных линий, а также линий выноски, при котором они выглядят как часть конструкции.

  • Настройка интервалов между размерами

    Предусмотрена возможность автоматического размещения существующих на чертеже параллельных линейных и угловых размеров с равными интервалами, а также выравнивания набора таких размеров по размерной линии.


Изменение размера (Процедура)

Переопределение размерных стилей
На уровень вверх ..
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера >
Изменение размера
Понятие Процедура

Процедура добавления излома к линейному размеру

Процедура добавления излома к линейному размеру посередине выбранной размерной линии

Процедура изменения положения размера с помощью ручек

Процедура удаления излома

Процедура изменения высоты излома с помощью палитры свойств

Процедура создания контрольного размера

Процедура изменения контрольного размера в диалоговом окне "Контроль"

Процедура удаления контрольного размера

Процедура изменения контрольного размера с помощью палитры свойств

Процедура автоматического создания масок для каждого пересекающего объекта

Процедура создания одной маски размера на основе пересекающего объекта

Процедура создания маски размера вручную

Процедура одновременного создания масок для нескольких размеров или мультивыносок

Процедура удаления всех масок из размера или мультивыноски

Процедура удаления всех масок из нескольких размеров или мультивыносок

Процедура автоматического размещения параллельных линейных и угловых размеров с равными интервалами

Процедура размещения параллельных линейных и угловых размеров с равными интервалами по заданному значению интервала

Процедура выравнивания параллельных линейных и угловых размеров


Излом размера (Понятие)

Изменение размера
Изменение размера
Контрольный размер
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера >
Излом размера
Понятие Процедура Краткий справочник

К линейным размерам можно добавлять линии излома. Линии излома служат для отображения значения размера, не соответствующего фактическому значению измеряемой величины. Как правило, фактическое значение измеряемой величины меньше отображаемого значения.

Демонстрация: добавление излома к линейному размеру

Для запуска анимации нажмите на стрелку "Показать".

Излом состоит из двух параллельных прямых и одной прямой, пересекающей их под углом 40 градусов. Высота излома определяется значением высоты излома линейного размера, заданным в стиле размеров.

После добавления излома к линейному размеру можно задать его положение с помощью ручек. Для изменения положения излома выберите размер, а затем ручку. Переместите ручку в другую точку на размерной линии. В разделе "Линии и стрелки" на палитре свойств можно также настроить высоту обозначения излома на линейном размере.


Излом размера (Процедура)

Изменение размера
На уровень вверх ..
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Излом размера >
Излом размера
Понятие Процедура Краткий справочник

Процедура добавления излома к линейному размеру

Процедура добавления излома к линейному размеру посередине выбранной размерной линии

Процедура изменения положения размера с помощью ручек

Процедура удаления излома

Процедура изменения высоты излома с помощью палитры свойств


Процедура добавления излома к линейному размеру (Процедура)

Излом размера
На уровень вверх ..
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Излом размера >
Излом размера
Понятие Процедура Краткий справочник

Процедура добавления излома к линейному размеру

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Линия с изломом". Введите в командной строке.
  2. Выберите линейный размер.
  3. Укажите на размерной линии точку, в которой требуется поместить излом.
Панель:Размер
Ввод команды: РЗМИЗЛИНИЯ


Процедура добавления излома к линейному размеру посередине выбранной размерной линии (Процедура)

Излом размера
На уровень вверх ..
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Излом размера >
Излом размера
Понятие Процедура Краткий справочник

Процедура добавления излома к линейному размеру посередине выбранной размерной линии

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Линия с изломом". Введите в командной строке.
  2. Выберите линейный размер.
  3. Нажмите клавишу ENTER для задания положения размера посередине размерной линии.
Панель:Размер
Ввод команды: РЗМИЗЛИНИЯ


Процедура изменения положения размера с помощью ручек (Процедура)

Излом размера
На уровень вверх ..
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Излом размера >
Излом размера
Понятие Процедура Краткий справочник

Процедура изменения положения размера с помощью ручек

  1. Не запуская ни одной команды, выберите линейный размер, на котором требуется изменить положение излома.
  2. Выберите ручку в центре излома.

    Заданная ручка подсвечивается, и включается режим по умолчанию "Растягивание".

  3. Перетащите перекрестие в новое положение излома на размерной линии и нажмите кнопку мыши.
    СоветЕсли требуется поместить курсор на размерной линии без изменения положения размерной линии, включите режим "Орто".
Панель:Размер
Ввод команды: РЗМИЗЛИНИЯ


Процедура удаления излома (Процедура)

Излом размера
На уровень вверх ..
Излом размера
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Излом размера >
Излом размера
Понятие Процедура Краткий справочник

Процедура удаления излома

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Линия с изломом". Введите в командной строке.
  2. Введите "r" (удалить) и нажмите клавишу ENTER.
  3. Выберите линейный размер, с которого требуется удалить излом.
Панель:Размер
Ввод команды: РЗМИЗЛИНИЯ


Процедура изменения высоты излома с помощью палитры свойств (Процедура)

Излом размера
На уровень вверх ..
Контрольный размер
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Излом размера >
Излом размера
Понятие Процедура Краткий справочник

Процедура изменения высоты излома с помощью палитры свойств

  1. Не запуская ни одной команды, выберите линейный размер, на котором требуется изменить высоту излома.
  2. Щелкните в окне чертежа правой кнопкой мыши. Нажать кнопку "Свойства".
  3. На палитре свойств разверните раздел "Линии и стрелки".
  4. Выберите "Коэффициент высоты излома" и введите новое значение высоты излома.
  5. Щелкните мышью за пределами палитры "Свойства". Нажмите ESC.
Панель:Размер
Ввод команды: РЗМИЗЛИНИЯ


Излом размера (Краткий справочник)

Переопределение размерных стилей
Излом размера
Контрольный размер
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Излом размера >
Излом размера
Понятие Процедура Краткий справочник

Команды

РЗМПАРАЛ

Нанесение параллельных линейных размеров

РЗМБАЗОВЫЙ

Нанесение линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера

РЗМЦЕПЬ

Нанесение линейных, угловых или ординатных размеров от второй выносной линии предыдущего или выбранного размера

РЗМИЗЛИНИЯ

Добавление или удаление линий с изломом к линейному или выровненному размеру

РЗМЛИНЕЙНЫЙ

Нанесение линейного размера

РЗМСТИЛЬ

Создание и модификация размерных стилей

БРАЗМЕР

Быстрое создание серии размеров из выбранного объекта

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Контрольный размер (Понятие)

Излом размера
Изменение размера
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера >
Контрольный размер
Понятие Процедура Краткий справочник

Контрольные размеры представляют собой удобный способ задания частоты, с которой следует проверять изготовленные детали на соответствие значения размера и допусков заданному диапазону.

При работе с деталями, которые перед окончательной сборкой изделия должны соответствовать определенным требованиям к допуску или значению размера, можно указать частоту проверки детали с помощью контрольного размера.

Контрольный размер можно добавить к объекту-размеру любого типа; он состоит из рамки и текстовых значений. Рамка контрольного размера состоит из двух параллельных прямых; концы рамки могут быть прямыми или скругленными. Текстовые значения разделяются вертикальными линиями. Контрольный размер может содержать до трех различных информационных полей: "Метка контроля", "Значение размера" и "Процент контроля".

Поля контрольного размера

метка контроля

Текстовое значение, предназначенное для идентификации отдельных контрольных размеров. Эта метка расположена в левой части контрольного размера.

Значение размера

В этом поле отображается то значение размера, которое было задано до добавления контрольного размера. Значение размера может содержать допуски, текст (префиксы и суффиксы) и измеряемое значение. Значение размера расположено в средней части контрольного размера.

Процент контроля

Текстовое значение, определяющее частоту контроля значения размера в процентах. Это значение расположено в правой части контрольного размера.

Контрольные размеры можно добавлять к размерам любого типа. Текущие значения параметров контрольного размера отображаются на палитре свойств в разделе "Разное". К этим значениям относятся свойства, определяющие внешний вид рамки, а также текстовые значения полей "Метка контроля" и "Процент контроля".


Контрольный размер (Процедура)

Излом размера
На уровень вверх ..
Контрольный размер
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Контрольный размер >
Контрольный размер
Понятие Процедура Краткий справочник

Процедура создания контрольного размера

Процедура изменения контрольного размера в диалоговом окне "Контроль"

Процедура удаления контрольного размера

Процедура изменения контрольного размера с помощью палитры свойств


Процедура создания контрольного размера (Процедура)

Контрольный размер
На уровень вверх ..
Контрольный размер
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Контрольный размер >
Контрольный размер
Понятие Процедура Краткий справочник

Процедура создания контрольного размера

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Изучение". В командной строке введите "РЗМИНСПЕКТ".
  2. В диалоговом окне "Контрольный размер" нажмите "Выбор размеров".

    Диалоговое окно "Контрольный размер" закрывается. Отображается запрос на выбор размеров.

  3. Выберите размер, который требуется задать в качестве контрольного размера. Нажмите клавишу ENTER для возврата в диалоговое окно.
  4. В разделе "Форма" укажите тип рамки.
  5. В разделе "Метка/Процент контроля" задайте требуемые значения параметров.
    • Установите флажок "Метка" и введите требуемую метку в текстовом поле.
    • Установите флажок "Процент контроля" и введите требуемую частоту в текстовом поле.
  6. Нажмите ОК.
Панель:Размер
Ввод команды: РЗМИНСПЕКТ


Процедура изменения контрольного размера в диалоговом окне "Контроль" (Процедура)

Контрольный размер
На уровень вверх ..
Контрольный размер
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Контрольный размер >
Контрольный размер
Понятие Процедура Краткий справочник

Процедура изменения контрольного размера в диалоговом окне "Контроль"

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Изучение". В командной строке введите "РЗМИНСПЕКТ".
  2. В диалоговом окне "Контрольный размер" нажмите "Выбор размеров".

    Диалоговое окно "Контрольный размер" закрывается. Отображается запрос на выбор размеров.

  3. Выберите контрольный размер, который требуется изменить. Нажмите клавишу ENTER для возврата в диалоговое окно.
  4. В разделе "Форма" внесите требуемые изменения типа рамки.
  5. В разделе "Метка/Процент контроля" внесите требуемые изменения метки и частоты контроля.
  6. Нажмите ОК.
Панель:Размер
Ввод команды: РЗМИНСПЕКТ


Процедура удаления контрольного размера (Процедура)

Контрольный размер
На уровень вверх ..
Контрольный размер
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Контрольный размер >
Контрольный размер
Понятие Процедура Краткий справочник

Процедура удаления контрольного размера

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Изучение". В командной строке введите "РЗМИНСПЕКТ".
  2. В диалоговом окне "Контрольный размер" нажмите "Выбор размеров".

    Диалоговое окно "Контрольный размер" закрывается. Отображается запрос на выбор размеров.

  3. Выберите размер, из которого требуется удалить контрольный размер. Нажмите клавишу ENTER для возврата в диалоговое окно.
  4. Выберите "Удаление контроля".
  5. Нажмите ОК.
Панель:Размер
Ввод команды: РЗМИНСПЕКТ


Процедура изменения контрольного размера с помощью палитры свойств (Процедура)

Контрольный размер
На уровень вверх ..
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Контрольный размер >
Контрольный размер
Понятие Процедура Краткий справочник

Процедура изменения контрольного размера с помощью палитры свойств

  1. Не запуская ни одной команды, выберите контрольный размер, который требуется изменить.
  2. Щелкните в окне чертежа правой кнопкой мыши. Нажать кнопку "Свойства".
  3. На палитре свойств разверните панель "Разное", дважды щелкнув на ее заголовке.
  4. Задайте новые значения параметров контрольного размера, определяющие его форму и метку, а также частоту проверки.
  5. Щелкните мышью за пределами палитры "Свойства". Нажмите ESC.
Панель:Размер
Ввод команды: РЗМИНСПЕКТ


Контрольный размер (Краткий справочник)

Излом размера
Контрольный размер
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Контрольный размер >
Контрольный размер
Понятие Процедура Краткий справочник

Команды

РЗМИНСПЕКТ

Добавление или удаление рамки с контрольными данными для выбранного размера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Маски размеров (Понятие)

Контрольный размер
Изменение размера
Настройка интервалов между размерами
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера >
Маски размеров
Понятие Процедура Краткий справочник

Маски размеров позволяют избежать такого представления размерных и выносных линий, а также линий выноски, при котором они выглядят как часть конструкции.

Демонстрация: добавление маски к размеру

Для запуска анимации нажмите на стрелку "Показать".

Маски размеров могут добавляться к размерам и мультивыноскам автоматически или вручную. Рекомендуемый способ размещения масок размеров зависит от количества объектов, пересекающих размер или мультивыноску.

Ниже перечислены объекты - размеры и мультивыноски, к которым можно добавлять маски размеров.

  • Линейные размеры (параллельные и расположенные под углом)
  • Угловые размеры (двух- и трехточечные)
  • Радиальные размеры (радиус, диаметр, с изломом)
  • Размеры длины дуги
  • Ординатные размеры
  • Мультивыноски (только прямые)

Следующие объекты - размеры и мультивыноски не поддерживают маски размеров.

  • Мультивыноски (только сплайны)
  • "Вышедшие из употребления" выноски (прямые или сплайны)

В следующей таблице приведены сведения об условиях, в которых маски размеров не действуют или не поддерживаются.

Исключения для масок размеров
Условие | Описание
Маски во внешних ссылках и блоках не поддерживаются | Маски размеров не поддерживаются на размерах и мультивыносках, расположенных во внешних ссылках и блоках. Однако объекты во внешней ссылке или блоке могут служить режущими кромками для масок размеров на размерах и мультивыносках, не входящих в состав внешней ссылки или блока.
Маски на стрелках и тексте не поддерживаются | Маску размера невозможно расположить на стрелке или тексте размера. Если требуется отображение маски на тексте размера, рекомендуется применить режим скрытия заднего плана. Если точка пересечения объекта и размера находится на стрелке или тексте размера, маска будет отображаться только после перемещения размера, мультивыноски или пересекающего их объекта.
Маски на размерах, относящихся к другому пространству, не поддерживаются | Автоматическое размещение масок не поддерживается в том случае, если объект и размер (или мультивыноска) находятся в разных пространствах. Для создания маски размера или мультивыноски, расположенных в другом пространстве, необходимо при выполнении команды РЗМРАЗОРВАТЬ воспользоваться параметром "Вручную".

Маски размеров можно удалять из размеров или мультивыносок. При удалении масок размера из размера или мультивыноски одновременно удаляются все маски размера. Если требуется удалить только некоторые маски размера, остальные маски размера необходимо добавить заново.

Ниже приведен список объектов, которые могут служить режущей кромкой при добавлении маски размера.

  • Размеры
  • Выноска
  • Линия
  • Круг
  • Дуга
  • Сплайн
  • Эллипс
  • Полилиния
  • Текст
  • многострочный текст
  • Блоки, представляющие собой указанные выше объекты
  • Внешние ссылки на указанные выше объекты

Автоматическое размещение масок размеров

Для создания автоматически размещаемой маски размера следует выбрать размер или мультивыноску и затем выполнить команду РЗМРАЗОРВАТЬ с параметром "Авто". Автоматически размещаемые маски размеров обновляются при каждом внесении изменений в размер, мультивыноску или пересекающий их объект.

Протяженность автоматически размещаемых масок размеров задается на вкладке "Символы и стрелки" диалогового окна "Размерный стиль". Протяженность маски размера зависит от заданного значения протяженности маски размера, масштаба размеров и текущего масштаба аннотаций для текущего видового экрана. Подробнее о масштабировании аннотаций см. Масштабирование аннотаций.

Создание маски размера путем выбора объекта

Вместо размещения маски размера для каждого объекта, пересекающего размер или мультивыноску, можно указать пересекающие объекты, для которых требуется создать маски размеров. Маски размеров, добавленные путем выбора отдельных пересекающих объектов, обновляются при каждом внесении изменений в размер или мультивыноску либо в пересекающий их объект.

Создание маски размера путем выбора двух точек

Для размещения маски размера можно выбрать на размерной линии, выносной линии или линии выноски две точки, определяющие протяженность и местоположение маски. При внесении изменений в размер или мультивыноску либо в пересекающий их объект маски размера, добавленные вручную путем выбора двух точек, не обновляются автоматически.

Поэтому после перемещения размера или мультивыноски с маской размера, созданной вручную, а также после внесения изменений в пересекающий их объект может потребоваться восстановить размер или мультивыноску, а затем снова добавить маску размера. Протяженность маски размера, созданного путем выбора двух точек, не зависит от текущих значений масштаба размеров и масштаба аннотаций для текущего видового экрана.


Маски размеров (Процедура)

Контрольный размер
На уровень вверх ..
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Процедура автоматического создания масок для каждого пересекающего объекта

Процедура создания одной маски размера на основе пересекающего объекта

Процедура создания маски размера вручную

Процедура одновременного создания масок для нескольких размеров или мультивыносок

Процедура удаления всех масок из размера или мультивыноски

Процедура удаления всех масок из нескольких размеров или мультивыносок


Процедура автоматического создания масок для каждого пересекающего объекта (Процедура)

Маски размеров
На уровень вверх ..
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Процедура автоматического создания масок для каждого пересекающего объекта

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Разорвать". В командной строке введите "РЗМРАЗОРВАТЬ".
  2. Выберите размер или мультивыноску.
  3. Введите "a" (автоматически) и нажмите клавишу ENTER.
Панель:Размер
Ввод команды: РЗМРАЗОРВАТЬ


Процедура создания одной маски размера на основе пересекающего объекта (Процедура)

Маски размеров
На уровень вверх ..
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Процедура создания одной маски размера на основе пересекающего объекта

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Разорвать". В командной строке введите "РЗМРАЗОРВАТЬ".
  2. Выберите размер или мультивыноску.
  3. Выберите объект, пересекающий размер или мультивыноску. Нажать ENTER.
Панель:Размер
Ввод команды: РЗМРАЗОРВАТЬ


Процедура создания маски размера вручную (Процедура)

Маски размеров
На уровень вверх ..
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Процедура создания маски размера вручную

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Разорвать". В командной строке введите "РЗМРАЗОРВАТЬ".
  2. Выберите размер или мультивыноску.
  3. Введите "m" (вручную) и нажмите клавишу ENTER.
  4. Укажите на размерной линии, выносной линии или линии выноски первую точку для маски размера.
  5. Укажите на размерной линии, выносной линии или линии выноски вторую точку для маски размера.
Панель:Размер
Ввод команды: РЗМРАЗОРВАТЬ


Процедура одновременного создания масок для нескольких размеров или мультивыносок (Процедура)

Маски размеров
На уровень вверх ..
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Процедура одновременного создания масок для нескольких размеров или мультивыносок

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Разорвать". В командной строке введите "РЗМРАЗОРВАТЬ".
  2. Введите "m" (несколько) и нажмите клавишу ENTER.
  3. Выберите размеры или мультивыноски, к которым требуется добавить маски.
  4. Введите "a" (автоматически) и нажмите клавишу ENTER.
Панель:Размер
Ввод команды: РЗМРАЗОРВАТЬ


Процедура удаления всех масок из размера или мультивыноски (Процедура)

Маски размеров
На уровень вверх ..
Маски размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Процедура удаления всех масок из размера или мультивыноски

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Разорвать". В командной строке введите "РЗМРАЗОРВАТЬ".
  2. Выберите размер или мультивыноску.
  3. Введите "r" (удалить) и нажмите клавишу ENTER.
Панель:Размер
Ввод команды: РЗМРАЗОРВАТЬ


Процедура удаления всех масок из нескольких размеров или мультивыносок (Процедура)

Маски размеров
На уровень вверх ..
Настройка интервалов между размерами
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Процедура удаления всех масок из нескольких размеров или мультивыносок

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Разорвать". В командной строке введите "РЗМРАЗОРВАТЬ".
  2. Введите m (несколько) и нажмите клавишу ENTER.
  3. Выберите размеры или мультивыноски, из которых необходимо удалить разрывы размеров, и нажмите клавишу ENTER.
  4. Введите r (удалить) и нажмите клавишу ENTER.
Панель:Размер
Ввод команды: РЗМРАЗОРВАТЬ


Маски размеров (Краткий справочник)

Контрольный размер
Маски размеров
Настройка интервалов между размерами
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Маски размеров >
Маски размеров
Понятие Процедура Краткий справочник

Команды

РЗМРАЗОРВАТЬ

Разрыв или восстановление размерных или выносных линий, пересекающих другие объекты

РЗМСТИЛЬ

Создание и модификация размерных стилей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка интервалов между размерами (Понятие)

Маски размеров
Изменение размера
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера >
Настройка интервалов между размерами
Понятие Процедура Краткий справочник

Предусмотрена возможность автоматического размещения существующих на чертеже параллельных линейных и угловых размеров с равными интервалами, а также выравнивания набора таких размеров по размерной линии.

Демонстрация: настройка расстояния между размерами

Для запуска анимации нажмите на стрелку "Показать".

Предусмотрено несколько способов создания параллельных линейных и угловых размеров на чертеже. Команды РЗМЛИНЕЙНЫЙ и РЗМУГЛОВОЙ позволяют размещать размеры по одному; команды РЗМБАЗОВЫЙ и РЗМЦЕПЬ служат для размещения дополнительных линейных размеров на основе размещенного ранее линейного размера.

При выполнении команды РЗМБАЗОВЫЙ учитывается значение системной переменной DIMDLI, определяющей размещение размеров с равными интервалами; однако после размещения размеров изменение значения этой системной переменной не влияет на интервалы между размерами. При изменении высоты текста или настройке масштаба для размеров местоположение размеров не изменяется, что может привести к наложению размерных линий и текста.

К перекрывающимся размерам, а также к размерам с различными интервалами можно применить команду РЗМСМЕЩ для настройки интервалов между ними. Выбранные размеры должны быть линейными или угловыми, относиться к одному и тому же типу (расположены параллельно или под углом к объекту), быть параллельными или концентрическими относительно друг друга и иметь общие выносные линии. Можно также выполнить выравнивание линейных или угловых размеров, задав значение интервала, равное 0.

На следующем рисунке показаны параллельные линейные размеры с различными интервалами, а затем - те же размеры после их размещения с равными интервалами с помощью команды РЗМСМЕЩ.


Настройка интервалов между размерами (Процедура)

Маски размеров
На уровень вверх ..
Настройка интервалов между размерами
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Настройка интервалов между размерами >
Настройка интервалов между размерами
Понятие Процедура Краткий справочник

Процедура автоматического размещения параллельных линейных и угловых размеров с равными интервалами

Процедура размещения параллельных линейных и угловых размеров с равными интервалами по заданному значению интервала

Процедура выравнивания параллельных линейных и угловых размеров


Процедура автоматического размещения параллельных линейных и угловых размеров с равными интервалами (Процедура)

Настройка интервалов между размерами
На уровень вверх ..
Настройка интервалов между размерами
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Настройка интервалов между размерами >
Настройка интервалов между размерами
Понятие Процедура Краткий справочник

Процедура автоматического размещения параллельных линейных и угловых размеров с равными интервалами

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Корректировка расстояния". В командной строке введите "рзмсмещ".
  2. Выберите размер, который будет служить базовым размером в процессе размещения размеров с равными интервалами.
  3. Выберите следующий размер, к которому требуется применить операцию размещения с равными интервалами.
  4. Выберите остальные размеры, затем нажмите клавишу ENTER.
  5. Введите "a" (автоматически) и нажмите клавишу ENTER.
Панель:Размер
Ввод команды: РЗМСМЕЩ


Процедура размещения параллельных линейных и угловых размеров с равными интервалами по заданному значению интервала (Процедура)

Настройка интервалов между размерами
На уровень вверх ..
Настройка интервалов между размерами
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Настройка интервалов между размерами >
Настройка интервалов между размерами
Понятие Процедура Краткий справочник

Процедура размещения параллельных линейных и угловых размеров с равными интервалами по заданному значению интервала

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Корректировка расстояния". В командной строке введите "рзмсмещ".
  2. Выберите размер, который будет служить базовым размером в процессе размещения размеров с равными интервалами.
  3. Выберите следующий размер, к которому требуется применить операцию размещения с равными интервалами.
  4. Выберите остальные размеры, затем нажмите клавишу ENTER.
  5. Введите значение интервала и нажмите клавишу ENTER.
Панель:Размер
Ввод команды: РЗМСМЕЩ


Процедура выравнивания параллельных линейных и угловых размеров (Процедура)

Настройка интервалов между размерами
На уровень вверх ..
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Настройка интервалов между размерами >
Настройка интервалов между размерами
Понятие Процедура Краткий справочник

Процедура выравнивания параллельных линейных и угловых размеров

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Корректировка расстояния". В командной строке введите "рзмсмещ".
  2. Выберите размер, который будет служить базовым размером в процессе размещения размеров с равными интервалами.
  3. Выберите следующий размер, к которому требуется применить операцию выравнивания.
  4. Выберите остальные размеры, затем нажмите клавишу ENTER.
  5. Введите "0" и нажмите клавишу ENTER.
Панель:Размер
Ввод команды: РЗМСМЕЩ


Настройка интервалов между размерами (Краткий справочник)

Маски размеров
Настройка интервалов между размерами
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение размера > Настройка интервалов между размерами >
Настройка интервалов между размерами
Понятие Процедура Краткий справочник

Команды

РЗМПАРАЛ

Нанесение параллельных линейных размеров

РЗМУГЛОВОЙ

Нанесение угловых размеров

РЗМБАЗОВЫЙ

Нанесение линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера

РЗМЦЕПЬ

Нанесение линейных, угловых или ординатных размеров от второй выносной линии предыдущего или выбранного размера

РЗМЛИНЕЙНЫЙ

Нанесение линейного размера

РЗМСМЕЩ

Корректировка расстояния между линейными или угловыми размерами

РЗМСТИЛЬ

Создание и модификация размерных стилей

БРАЗМЕР

Быстрое создание серии размеров из выбранного объекта

Системные переменные

DIMDLI

Управление расстоянием между размерными линиями в базовых размерах

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование размерного текста (Понятие)

Настройка интервалов между размерами
Редактирование размеров
Редактирование геометрии размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Размерный текст в нанесенном размере можно отредактировать или заменить на новый, а также изменить его положение и угол поворота.

Размерный текст в нанесенном размере можно отредактировать или заменить на новый, а также изменить угол его поворота. Кроме того, текст можно передвинуть или, наоборот, вернуть в исходное положение, определяемое текущим размерным стилем. На следующей иллюстрации исходное положение текста задано над размерной линией в центре.

Поворот и редактирование размерного текста выполняется перед окончательным нанесением размера. Например, для поворота следует введите значения угла. Перемещение размерного текста осуществляется путем выбора уже нанесенного размера.

Размерный текст можно переместить вдоль размерной линии вправо, влево или к центру, а также разместить вне выносных линий или между ними. Наиболее быстрый и простой способ перемещения достигается использованием ручек. При перемещении текста вверх и вниз изменяются выносные линии и положение размерной линии; режим вертикального выравнивания текста относительно размерной линии сохраняется. На следующем чертеже показан результат перемещения текста вниз и вправо. Положение текста по вертикали относительно размерной линии сохраняется.

См. также

    • Управление размерным текстом


Редактирование размерного текста (Процедура)

Настройка интервалов между размерами
На уровень вверх ..
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Поворот размерного текста

Возврат размерного текста в исходное положение

Редактирование размерного текста

Перемещение текста вдоль размерной линии влево

Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях

Изменение отступа выносных линий от объекта


Поворот размерного текста (Процедура)

Редактирование размерного текста
На уровень вверх ..
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Поворот размерного текста

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Выравнивание текста". В командной строке введите "рзмредтекст".
  2. Выберите размер для редактирования.
  3. Введите новое значение угла поворота текста.
Панель:Размер
Ввод команды: РЗМРЕДТЕКСТ


Возврат размерного текста в исходное положение (Процедура)

Редактирование размерного текста
На уровень вверх ..
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Возврат размерного текста в исходное положение

  1. Выберите пункт меню "Размер" [image] "Выравнивание текста" [image] "Вернуть".В командной строке введите "рзмред".
  2. Выберите размерный текст для возврата в исходное положение.
Панель:Размер
Ввод команды: РЗМРЕДТЕКСТ


Редактирование размерного текста (Процедура)

Редактирование размерного текста
На уровень вверх ..
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Редактирование размерного текста

  1. Выберите пункт меню "Редактирование" [image] "Объект" [image] "Текст" [image] "Изменить".В командной строке введите "диалРед".
  2. Выберите размерный текст для редактирования.
  3. В контекстном редакторе, введите новый размерный текст. Нажмите "ОК".
Панель:Текст
Ввод команды: ДИАЛРЕД


Перемещение текста вдоль размерной линии влево (Процедура)

Редактирование размерного текста
На уровень вверх ..
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Перемещение текста вдоль размерной линии влево

  1. Выберите пункт меню "Размер" [image] "Выравнивание текста" [image] "Влево".В командной строке введите "рзмредтекст".
  2. Выберите размер.

    Размерный текст выравнивается влево вдоль размерной линии между выносными линиями. Для выравнивания текста по центру или вправо следует воспользоваться опциями "Центр" или "Вправо".

Панель:Размер
Ввод команды: РЗМРЕДТЕКСТ


Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях (Процедура)

Редактирование размерного текста
На уровень вверх ..
Редактирование размерного текста
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Задание расстояния между размерными линиями в размерах от общей базы и размерных цепях

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Размерные линии" в поле "Шаг в базовых размерах" введите значение расстояния смещения между размерными линиями для базовой линии и размерными цепями.
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Изменение отступа выносных линий от объекта (Процедура)

Редактирование размерного текста
На уровень вверх ..
Изменение ассоциативности размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Изменение отступа выносных линий от объекта

  1. Перейдите на вкладку "Главная" [image] панель "Аннотирование" [image] "Размерный стиль". В командной строке введите рзмстиль.
  2. В Диспетчере размерных стилей выберите стиль, который необходимо изменить. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Изменение размерного стиля" на вкладке "Линии" в разделе "Выносные линии" введите новое значение для параметра "Отступ от объекта".
  4. Нажмите "ОК".
  5. Нажмите кнопку "Закрыть" для выхода из Диспетчера размерных стилей.
Панель:Размер или Стили
Ввод команды: РЗМСТИЛЬ


Редактирование размерного текста (Краткий справочник)

Настройка интервалов между размерами
Редактирование размерного текста
Редактирование геометрии размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование размерного текста >
Редактирование размерного текста
Понятие Процедура Краткий справочник

Команды

ДИАЛРЕД

Редактирование текстов (в том числе размерных), определений атрибутов и допусков формы и расположения

РЗМРЕД

Редактирование размерного текста и выносных линий

РЗМРЕДТЕКСТ

Перенос и поворот размерного текста, изменение местоположения размерной линии

ОКНОСВ

Управление свойствами объектов

Системные переменные

DIMCLRT

Указание цвета размерного текста Для цвета можно выбрать любой допустимый номер цвета

DIMDSEP

Задание символа десятичного разделителя, используемый при создании размеров с десятичным форматом единиц измерения

DIMJUST

Управление положением размерного текста по горизонтали

DIMTAD

Управление расположением текста по вертикали относительно размерной линии

DIMTIH

Управление ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями

DIMTMOVE

Установка правил перемещения размерного текста

DIMTOH

Управление ориентацией размерного текста за выносными линиями

DIMTVP

Управление положением размерного текста по вертикали над или под размерной линией

DIMUPT

Управление действием курсора при пользовательском расположении текста

MTEXTED

Задание приложения для редактирования многострочных текстовых объектов

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование геометрии размеров (Понятие)

Редактирование размерного текста
Редактирование размеров
Изменение ассоциативности размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров >
Редактирование геометрии размеров
Понятие Краткий справочник

Редактирование с помощью ручек - наиболее быстрый и удобный способ изменения расположения размерных элементов. Способ редактирования размеров зависит от наличия ассоциативной связи между размерами и объектами.

Изменять размеры можно с помощью команд редактирования и ручек. Редактирование с помощью ручек - наиболее быстрый и удобный способ редактирования размеров. Способ редактирования размеров зависит от наличия ассоциативной связи между размерами и объектами.

Редактирование ассоциативных размеров

При использовании многих команд редактирования ассоциативный размер сохраняет связь с объектом с нанесенными размерами, если для выполнения одной команды выбирается сразу и размер, и связанный с ним объект. Так, например, после перемещения, копирования или размножения массивом объекта и связанного с ним размера одной командой ассоциативная связь между ними сохраняется.

Ассоциативная связь размеров теряется в следующих случаях:

  • Если удалить связанный с размером объект.
  • Если связанный с размером объект обработать логической операцией, такой как, например, UNION (ОБЪЕДИНЕНИЕ) или SUBTRACT (ВЫЧИТАНИЕ).
  • Если с помощью ручек растянуть размер вдоль размерной линии.
  • Если ассоциативная связь с объектом установлена в режиме объектной привязки "Кажущееся пересечение", и в результате перемещения объекта воображаемое пересечение исчезает.

В других случаях ассоциативная связь может частично сохраняться. Например, при создании ассоциативного размера для конечных точек двух объектов с последующим стиранием одного из этих объектов ассоциативная связь сохраняется с оставшимся объектом. Потерявший ассоциативную связь конец линейного размера в дальнейшем может быть ассоциирован с другим объектом с помощью команды РЗМПРИКРЕПИТЬ.

ПримечаниеЕсли ассоциативная связь с размером удалена, в командной строке отображается предупреждающее сообщение.

Редактирование неассоциативных размеров

В случае неассоциативных размеров для обновления размеров при редактировании объектов с нанесенными размерами необходимо включать в набор точки, определяющие размер. Эти точки задают расположение размера. Так, например, для растягивания размера необходимо включить в набор соответствующую определяющую точку при выборе редактируемого объекта. Это можно легко сделать, включив ручки и выбрав редактируемый объект таким образом, чтобы нужные ручки стали выделенными.

На следующих чертежах показаны определяющие точки разных типов размеров. Точка середины размерного текста является определяющей для любого типа размера.

Если вершина угла не отображается, определяющие точки располагаются на концах линий, образующих угол. В примере с двухлинейным углом определяющая точка расположена в центре измеряемой дуги.

ПримечаниеОпределяющие точки наносятся на специальном слое DEFPOINTS; объекты, расположенные на этом слое, никогда не выводятся на плоттер.

Редактирование расчлененных размеров

Расчлененные размеры можно редактировать как и любые другие объекты, поскольку они состоят из отдельных объектов: линий, двумерных фигур и текста. Иногда размер требуется расчленить, когда, например, нужно разорвать размерную или выносную линию. Расчлененный размер нельзя объединить обратно в единый размерный объект.

См. также

    • Редактирование размерных стилей


Редактирование геометрии размеров (Краткий справочник)

Редактирование размерного текста
Редактирование геометрии размеров
Изменение ассоциативности размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Редактирование геометрии размеров >
Редактирование геометрии размеров
Понятие Краткий справочник

Команды

РЗМРЕД

Редактирование размерного текста и выносных линий

РЗМОТКРЕПИТЬ

Отмена ассоциативности выбранных размеров

РЗМПРИКРЕПИТЬ

Ассоциирование выбранных размеров с геометрическими объектами

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

РАСТЯНУТЬ

Растягивание объектов, пересекаемых рамкой выбора или многоугольником

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение ассоциативности размеров (Понятие)

Редактирование геометрии размеров
Редактирование размеров
Нанесение допусков формы и расположения
Аннотирование чертежей > Размеры и допуски > Редактирование размеров >
Изменение ассоциативности размеров
Понятие Процедура Краткий справочник

В некоторых случаях может понадобиться изменить ассоциативность размеров. Например, размеры, нанесенные на чертеже с помощью предыдущих версий программы, можно сделать ассоциативными.

Изменение ассоциативности размеров может потребоваться в следующих случаях:

  • После внесения значительных изменений в чертежи.
  • При частичной утрате размерами ассоциативных связей.
  • После загрузки чертежей, созданных в прежних версиях программы.
  • На чертежах, с которыми предполагается работать в более ранних редакциях по сравнению с AutoCAD 2002 без использования представительских объектов, следует удалить ассоциативные связи из размеров.

Ассоциативное связывание размеров с различными объектами

С помощью команды РЗМПРИКРЕПИТЬ пользователь может выбрать один или несколько размеров и пройти через исходные точки выносной линии каждого размера. Для каждой исходной точки выносной линии можно задать новую точку прикрепления на геометрическом объекте. Точки прикрепления определяют места связи выносных линий с объектами.

ПримечаниеВ процессе создания или редактирования ассоциативных размеров важно тщательно указывать точки прикрепления, для того чтобы сохранялась возможность дальнейшего редактирования объектов совместно с прикрепленными к ним размерами.

При использовании команды РЗМПРИКРЕПИТЬ появляется маркер, показывающий наличие или отсутствие ассоциативной связи для исходной точки каждой последовательной выносной линии размера. Маркер в виде крестика в квадрате обозначает наличие ассоциативной связи начальной точки с точкой объекта, маркер в виде крестика без квадрата - отсутствие связи. Для указания новой связи для исходной точки выносной линии необходимо воспользоваться объектной привязкой или нажать ENTER для перехода к исходной точке следующей выносной линии.

ПримечаниеМаркер исчезает при панорамировании или зумировании с помощью мыши.

Преобразование неассоциативных размеров в ассоциативные

Все неассоциативные размеры чертежа можно быстро и просто преобразовать в ассоциативные. С помощью команды БВЫБОР выбираются все неассоциативные размеры, а затем командой РЗМПРИКРЕПИТЬ задаются ассоциативные связи с точками объектов путем перебора всех выбранных размеров.

Преобразование ассоциативных размеров в неассоциативные

Все ассоциативные размеры чертежа можно быстро и просто преобразовать в неассоциативные. С помощью команды БВЫБОР выбираются все ассоциативные размеры, затем командой РЗМОТКРЕПИТЬ выбранные размеры преобразовываются в неассоциативные.

См. также

    • Ассоциативные размеры

    • Сохранение чертежей в форматах прежних версий


Изменение ассоциативности размеров (Процедура)

Редактирование размерного текста
На уровень вверх ..
Изменение ассоциативности размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение ассоциативности размеров >
Изменение ассоциативности размеров
Понятие Процедура Краткий справочник

Ассоциативное прикрепление размеров к объектам

Разрыв ассоциативной связи размеров с объектами


Ассоциативное прикрепление размеров к объектам (Процедура)

Изменение ассоциативности размеров
На уровень вверх ..
Изменение ассоциативности размеров
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение ассоциативности размеров >
Изменение ассоциативности размеров
Понятие Процедура Краткий справочник

Ассоциативное прикрепление размеров к объектам

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Прикрепить". В командной строке введите "рзмприкрепить".
  2. Выберите один или несколько размеров для ассоциативного прикрепления.
  3. Выполнить одно из следующих действий:
    • Укажите новое положение начальной точки выносной линии.
    • Введите с и выберите геометрический объект для ассоциативного связывания с размером.
    • Нажмите ENTER для пропуска начальной точки текущей выносной линии и перехода к следующей.
    • Нажмите ESC для завершения команды с сохранением уже установленной ассоциативности размеров.
  4. Повторить предыдущий пункт нужное число раз.
Ввод команды: РЗМПРИКРЕПИТЬ


Разрыв ассоциативной связи размеров с объектами (Процедура)

Изменение ассоциативности размеров
На уровень вверх ..
Нанесение допусков формы и расположения
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение ассоциативности размеров >
Изменение ассоциативности размеров
Понятие Процедура Краткий справочник

Разрыв ассоциативной связи размеров с объектами

  1. В командной строке введите "РЗМОТКРЕПИТЬ".
  2. Выделите размеры, для которых требуется удалить ассоциативную связь, и нажмите ENTER.


Изменение ассоциативности размеров (Краткий справочник)

Редактирование геометрии размеров
Изменение ассоциативности размеров
Коротко о допусках формы и расположения
Аннотирование чертежей > Размеры и допуски > Редактирование размеров > Изменение ассоциативности размеров >
Изменение ассоциативности размеров
Понятие Процедура Краткий справочник

Команды

РЗМОТКРЕПИТЬ

Отмена ассоциативности выбранных размеров

РЗМПРИКРЕПИТЬ

Ассоциирование выбранных размеров с геометрическими объектами

РЗМРЕГЕН

Обновление расположения всех ассоциативных размеров

РАСЧЛЕНИТЬ

Разбиение составного объекта на составляющие его объекты

Системные переменные

DIMASSOC

Управление ассоциативностью размерных объектов и расчленением размеров

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Нанесение допусков формы и расположения

Изменение ассоциативности размеров
Размеры и допуски
Коротко о допусках формы и расположения
Аннотирование чертежей > Размеры и допуски >
Нанесение допусков формы и расположения
Понятие Процедура

Имеется возможность нанесения допусков формы и расположения, выражающих отклонения формы, контура, ориентации и расположения элементов чертежа.

Темы в этом разделе

  • Коротко о допусках формы и расположения
  • Зависимые допуски

    Зависимые допуски связаны с элементами, размеры которых могут варьироваться.

  • Комплект базовых плоскостей
  • Выступающие поля допуска расположения

    Дополнительно к позиционным допускам для их уточнения можно задавать выступающие поля допуска.

  • Составные допуски


Нанесение допусков формы и расположения (Процедура)

Изменение ассоциативности размеров
Нанесение допусков формы и расположения
Коротко о допусках формы и расположения
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения >
Нанесение допусков формы и расположения
Понятие Процедура

Нанесение допуска формы и расположения

Нанесение допуска формы и расположения с выноской


Коротко о допусках формы и расположения (Понятие)

Нанесение допусков формы и расположения
Нанесение допусков формы и расположения
Зависимые допуски
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения >
Коротко о допусках формы и расположения
Понятие Процедура Краткий справочник

Допуски формы и расположения иллюстрируют отклонения формы, контура, ориентации и расположения элементов чертежа. Такие допуски проставляются в прямоугольных рамках. В каждой рамке содержится исчерпывающая информация по допускам для соответствующего размера. Допуски формы и расположения могут строиться как с выносками, так и без них, в зависимости от используемой команды для нанесения допусков (ДОПУСК или ВЫНОСКА).

Рамка допуска формы и расположения состоит, по меньшей мере, из двух частей. В первой находится графический обозначение, обозначающий вид допуска (формы, расположения, сечения, биения и т.п.). Допуски формы подразделяются на допуски прямолинейности, плоскостности, округлости, цилиндричности и профиля продольного сечения. На чертеже обозначен позиционный допуск.

Редактирование рамок допусков формы и расположения осуществляется многими командами редактирования, а также с помощью ручек. Кроме того, для их указания можно использовать режимы объектной привязки. Также их можно редактировать с помощью ручек.

ПримечаниеВ отличие от размеров и выносок, допуски формы и расположения не могут ассоциативно прикрепляться к геометрическим объектам.

Можно также создать аннотативный допуск. Подробнее о создании аннотативных допусков и о работе с ними см. Создание аннотативных размеров и допусков.

См. также

    • Масштабирование аннотаций


Коротко о допусках формы и расположения (Процедура)

Нанесение допусков формы и расположения
На уровень вверх ..
Коротко о допусках формы и расположения
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Коротко о допусках формы и расположения >
Коротко о допусках формы и расположения
Понятие Процедура Краткий справочник

Нанесение допуска формы и расположения

Нанесение допуска формы и расположения с выноской


Нанесение допуска формы и расположения (Процедура)

Коротко о допусках формы и расположения
На уровень вверх ..
Коротко о допусках формы и расположения
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Коротко о допусках формы и расположения >
Коротко о допусках формы и расположения
Понятие Процедура Краткий справочник

Нанесение допуска формы и расположения

  1. Перейдите на вкладку "Аннотирование" [image] панель "Размеры" [image] "Допуск". В командной строке введите "допуск".
  2. В диалоговом окне "Допуски формы и расположения" нажмите на первой ячейке группы "Симв" и выберите обозначение вида допуска.
  3. В группе "Допуск 1" нажмите на крайней слева ячейке для нанесения диаметра.
  4. В текстовом поле введите значение для первого допуска.
  5. Если необходимо добавить обозначение зависимого допуска, нажмите на крайней справа ячейке, затем в диалоговом окне "Зависимый допуск" нажмите на нужном символе зависимого допуска.
  6. Если необходимо, таким же образом проставьте второй допуск.
  7. Нанесите буквенные обозначения баз в полях соответствующих групп.
  8. Для каждой базы нажмите на соответствующей ячейке справа для вставки символа-модификатора.
  9. В поле "Высота" введите значение высоты.
  10. Нажмите на ячейке "Выступающее поле допуска" для вставки обозначения.
  11. В поле "Идентификатор базы" добавьте значение базы.
  12. Нажмите "ОК".
  13. Укажите на чертеже положение рамки допуска.
Панель:Размер
Ввод команды: ДОПУСК


Нанесение допуска формы и расположения с выноской (Процедура)

Коротко о допусках формы и расположения
На уровень вверх ..
Задание настроек параметров листа
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Коротко о допусках формы и расположения >
Коротко о допусках формы и расположения
Понятие Процедура Краткий справочник

Нанесение допуска формы и расположения с выноской

  1. В командной строке введите "выноска".
  2. Укажите начальную точку выноски.
  3. Укажите вторую точку выноски.
  4. Дважды нажмите ENTER для вывода запросов на ввод обозначений.
  5. Введите д (Допуск) для нанесения рамки допуска формы и расположения.

    Рамка допуска формы и расположения наносится у конечной точки выноски.

Ввод команды: ВЫНОСКА


Коротко о допусках формы и расположения (Краткий справочник)

Изменение ассоциативности размеров
Коротко о допусках формы и расположения
Зависимые допуски
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Коротко о допусках формы и расположения >
Коротко о допусках формы и расположения
Понятие Процедура Краткий справочник

Команды

ВЫНОСКА

Построение линий, соединяющих аннотации с поясняемыми элементами

ДОПУСК

Нанесение допусков, формы и расположения в табличной форме

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Зависимые допуски (Понятие)

Коротко о допусках формы и расположения
Нанесение допусков формы и расположения
Комплект базовых плоскостей
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения >
Зависимые допуски
Понятие Краткий справочник

Зависимые допуски связаны с элементами, размеры которых могут варьироваться.

Во второй части допуска формы и расположения помещается числовое значение допуска. Перед значением может быть проставлено обозначение диаметра, а после значения - один из символов зависимого допуска.

Зависимые допуски связаны с элементами, размеры которых могут варьироваться.

  • При максимально допустимом припуске (обозначение "М", также известный как "МДП") элемент содержит максимальное количество материала, указанное значением допуска.
  • При МДП отверстие имеет минимальный диаметр, тогда как вал - максимальный.
  • При минимально допустимом припуске (обозначение "L") элемент содержит минимальное количество материала, указанное значением допуска.
  • В этом случае отверстие имеет максимальный диаметр, а вал - минимальный.
  • Произвольным зависимым допуском (обозначение "S") считается тот, при котором в детали может содержаться любое в допустимых пределах количество материала.


Зависимые допуски (Краткий справочник)

Коротко о допусках формы и расположения
Зависимые допуски
Комплект базовых плоскостей
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Зависимые допуски >
Зависимые допуски
Понятие Краткий справочник

Команды

ВЫНОСКА

Построение линий, соединяющих аннотации с поясняемыми элементами

ДОПУСК

Нанесение допусков, формы и расположения в табличной форме

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Комплект базовых плоскостей (Понятие)

Зависимые допуски
Нанесение допусков формы и расположения
Выступающие поля допуска расположения
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения >
Комплект базовых плоскостей
Понятие Краткий справочник

За величиной допуска в рамке допуска формы и расположения можно проставить до трех необязательных обозначений баз с символами-модификаторами. Базой называется теоретически точный элемент детали (точка, ось или плоскость), относительно которой производятся измерения и контроль размеров. Обычно в роли баз выступают две или три взаимно перпендикулярные плоскости. В совокупности они называются комплектом базовых плоскостей.

На следующем чертеже изображен комплект базовых плоскостей, используемый для контроля размеров детали.


Комплект базовых плоскостей (Краткий справочник)

Зависимые допуски
Комплект базовых плоскостей
Выступающие поля допуска расположения
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Комплект базовых плоскостей >
Комплект базовых плоскостей
Понятие Краткий справочник

Команды

ВЫНОСКА

Построение линий, соединяющих аннотации с поясняемыми элементами

ДОПУСК

Нанесение допусков, формы и расположения в табличной форме

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выступающие поля допуска расположения (Понятие)

Комплект базовых плоскостей
Нанесение допусков формы и расположения
Составные допуски
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения >
Выступающие поля допуска расположения
Понятие Краткий справочник

Дополнительно к позиционным допускам для их уточнения можно задавать выступающие поля допуска.

Дополнительно к позиционным допускам для их уточнения можно задавать выступающие поля допуска. Они могут, например, определять допуск перпендикулярности для детали, вставляемой или вворачиваемой в отверстие другой.

Перед символом выступающего поля допуска ( [image]) ставится значение высоты, обозначающее минимальное выступающее поле допуска. Высота и сам символ проставляются в рамке, расположенной под рамкой допуска формы и расположения, как показано на следующем чертеже.


Выступающие поля допуска расположения (Краткий справочник)

Комплект базовых плоскостей
Выступающие поля допуска расположения
Составные допуски
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Выступающие поля допуска расположения >
Выступающие поля допуска расположения
Понятие Краткий справочник

Команды

ВЫНОСКА

Построение линий, соединяющих аннотации с поясняемыми элементами

ДОПУСК

Нанесение допусков, формы и расположения в табличной форме

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Составные допуски (Понятие)

Выступающие поля допуска расположения
Нанесение допусков формы и расположения
Печать и публикация чертежей
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения >
Составные допуски
Понятие Краткий справочник

В составных допусках указываются два допуска для одной геометрической характеристики элемента, либо для элементов с различными требованиями к базам. Первый допуск относится к системе элементов, второй - к каждому элементу в отдельности. При этом второй допуск является более строгим, чем первый.

На чертеже пересечение базовых плоскостей A и B образует базовую ось, от которой определяется положение системы.

На следующем чертеже составной допуск относится и к диаметру системы отверстий, и диаметру каждого отверстия в отдельности.

При нанесении составного допуска вначале создается первая строка рамки допусков формы и расположения, а затем указывается тот же самый символ вида допуска для второй строки. Часть геометрического обозначения расширяется по обеим линиям. После этого вычерчивается вторая строка рамки.


Составные допуски (Краткий справочник)

Выступающие поля допуска расположения
Составные допуски
Коротко о сохранении параметров печати и публикаций
Аннотирование чертежей > Размеры и допуски > Нанесение допусков формы и расположения > Составные допуски >
Составные допуски
Понятие Краткий справочник

Команды

ВЫНОСКА

Построение линий, соединяющих аннотации с поясняемыми элементами

ДОПУСК

Нанесение допусков, формы и расположения в табличной форме

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Печать и публикация чертежей

Составные допуски
Подготовка чертежей к печати и публикации
Печать и публикация чертежей

Темы в этом разделе

  • Подготовка чертежей к печати и публикации

    При подготовке чертежа к печати или публикации ему назначается ряд параметров, сохраняемых в файле чертежа в виде набора для каждого листа. Настройка может осуществляться либо путем редактирования отдельных параметров, либо применением к листу какого-либо из ранее сохраненных наборов.

  • Вывод чертежей на печать

    Понятие "печать чертежа" для подготовленных в AutoCAD чертежей объединяет в себе процессы получения вычерченных бумажных копий или электронных чертежей, которые могут использоваться в других приложениях. В обоих случаях необходимо настроить параметры печати.

  • Публикация чертежей

    Публикацию целой подшивки легко выполнить в Диспетчере подшивок либо в виде набора чертежей на бумаге, либо в электронном виде как единого многолистового файла DWF или DWFx.


Подготовка чертежей к печати и публикации

Печать и публикация чертежей
Печать и публикация чертежей
Коротко о сохранении параметров печати и публикаций
Печать и публикация чертежей >
Подготовка чертежей к печати и публикации

При подготовке чертежа к печати или публикации ему назначается ряд параметров, сохраняемых в файле чертежа в виде набора для каждого листа. Настройка может осуществляться либо путем редактирования отдельных параметров, либо применением к листу какого-либо из ранее сохраненных наборов.

Темы в этом разделе

  • Коротко о сохранении параметров печати и публикаций

    Подготовка чертежа к печати или публикации требует задания многих параметров и опций, определяющих внешний вид чертежа. Чтобы сэкономить время, можно сохранить эти параметры в качестве именованного набора параметров листа.

  • Задание настроек параметров листа

    Параметры листа связаны с листами и хранятся в файле чертежа. Настройки, заданные в параметрах листа, определяют вид и формат листа, как он будет напечатан или опубликован.

  • Задание параметров листа с помощью Мастера компоновки листа

    Новую разметку листа можно создать с помощью Мастера компоновки листа.

  • Импорт настроек PCP или PC2 в компоновку листа

    Можно импортировать в текущую разметку листа параметры листа и печати, содержащиеся в файлах PCP или PC2.

  • Создание и использование наборов параметров листов

    Настройки устройства печати и другие параметры листа можно сохранить в наборе параметров листов. Созданный таким образом набор параметров листа можно впоследствии изменить или импортировать в другие чертежи.

  • Использование наборов параметров листов в подшивках

    Наборы параметров листов можно использовать для задания одних и тех же опций вывода для всех листов подшивки.


Коротко о сохранении параметров печати и публикаций (Понятие)

Подготовка чертежей к печати и публикации
Подготовка чертежей к печати и публикации
Задание настроек параметров листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации >
Коротко о сохранении параметров печати и публикаций
Понятие Краткий справочник

Подготовка чертежа к печати или публикации требует задания многих параметров и опций, определяющих внешний вид чертежа. Чтобы сэкономить время, можно сохранить эти параметры в качестве именованного набора параметров листа.

Применить набор параметров листа к пространству бумажного листа можно с помощью Диспетчера параметров листов. Можно также импортировать набор параметров листов из другого чертежа и применить его к листам в текущем чертеже.


Коротко о сохранении параметров печати и публикаций (Краткий справочник)

Составные допуски
Коротко о сохранении параметров печати и публикаций
Обзор настроек параметров листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Коротко о сохранении параметров печати и публикаций >
Коротко о сохранении параметров печати и публикаций
Понятие Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ИМПОРТПЛ

Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание настроек параметров листа

Коротко о сохранении параметров печати и публикаций
Подготовка чертежей к печати и публикации
Обзор настроек параметров листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации >
Задание настроек параметров листа
Понятие Процедура

Параметры листа связаны с листами и хранятся в файле чертежа. Настройки, заданные в параметрах листа, определяют вид и формат листа, как он будет напечатан или опубликован.

Темы в этом разделе

  • Обзор настроек параметров листа

    Параметры листа - это набор устройств печати и других настроек, определяющих вид и формат листа, как он будет напечатан или опубликован. Эти параметры можно изменять и применять к другим листам.

  • Выбор принтера или плоттера для листа
  • Задание формата бумаги для разметки листа

    Формат бумаги можно выбрать из стандартного списка. Также можно задать пользовательский нестандартный формат с помощью редактора параметров плоттера.

  • Установка печатаемой области в разметке листа

    Можно указать печатаемую область, т.е. пространственную часть чертежа, которая должна быть выведена на печать.

  • Регулировка смещения от начала для разметки листа

    Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на листе штриховой линией. При смене устройства вывода на печать область печати может измениться.

  • Задание масштаба печати

    При выводе чертежа на печать можно либо задать точный масштаб, либо воспользоваться режимом вписывания чертежа в заданный формат листа бумаги.

  • Задание масштаба весов линий

    Веса линий на выводимых листах можно пропорционально масштабировать в соответствии с масштабом печати.

  • Выбор таблицы стилей печати для разметки листа
  • Задание параметров печати для видовых экранов с раскрашиванием

    Ряд настроек, сохраняющихся в параметрах листа, позволяет задавать параметры вывода на печать видовых экранов, содержащих раскрашенные тела.

  • Задание ориентации чертежа


Задание настроек параметров листа (Процедура)

Коротко о допусках формы и расположения
Задание настроек параметров листа
Обзор настроек параметров листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Задание настроек параметров листа
Понятие Процедура

Изменение настроек разметки в параметрах листа

Применение именованного набора параметров разметки одного листа к другой разметке листа

Выбор принтера или плоттера для разметки листа

Изменение конфигурации принтера или плоттера, определенного в параметрах листа

Задание формата бумаги для разметки листа

Запуск редактора параметров плоттера

Создание пользовательского формата листа бумаги с нуля

Чтобы создать новый пользовательский формат листа на основе имеющегося формата

Чтобы отредактировать нестандартный формат листа

Чтобы удалить нестандартный формат листа

Для изменения стандартного формата листа

Задание области печати

Задание смещения печати для разметки листа

Задание масштаба печати

Подбор масштаба в зависимости от формата листа при печати

Масштабирование весов линий

Выбор таблицы стилей печати для разметки листа

Создание новой таблицы стилей печати для разметки листа

Изменение таблицы стилей печати для разметки листа

Просмотр содержимого листа с учетом таблицы стилей печати

Задание параметров печати видовых экранов с раскрашиванием

Установка опций печати для листа

Задание ориентации вывода чертежа


Обзор настроек параметров листа (Понятие)

Задание настроек параметров листа
Задание настроек параметров листа
Выбор принтера или плоттера для листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Обзор настроек параметров листа
Понятие Процедура Краткий справочник

Параметры листа - это набор устройств печати и других настроек, определяющих вид и формат листа, как он будет напечатан или опубликован. Эти параметры можно изменять и применять к другим листам.

После того как чертеж полностью построен на вкладке "Модель", пользователь может cформировать компоновку листа для вывода чертежа на печать. При первом открытии вкладки разметки на листе отображается один видовой экран. Пунктирная линия обозначает печатаемую область листа для текущих настроек формата и печатающего устройства.

Подготавливая разметку листа, пользователь задает настройки параметров листа и настройки устройства печати для вывода. Пользовательские настройки параметров листа сохраняются в файле чертежа вместе с листом. Пользователь может изменить настройки параметров листа в любое время.

По умолчанию каждая инициализированная разметка листа имеет свои параметры. Инициализировать разметку листа можно, щелкнув на вкладке этой разметки и тем самым активизировав ранее не использовавшуюся разметку. До инициализации лист не содержит никаких параметров печати. Перед публикацией разметку листа следует инициализировать (формат бумаги в наборе параметров листа задается установкой размеров, отличных от 0 x 0). После инициализации на листах можно выполнять черчение, их можно публиковать и добавлять в подшивки (после сохранения чертежа). Именованный набор параметров листа, сохраненный с одним листом, может быть применен к другому листу. При этом создается новый набор параметров листа, имеющий те же настройки, что и исходный набор.

Для того чтобы каждый раз при начале работы с новой разметкой листа открывался Диспетчер наборов параметров листа, следует установить флажок "Диспетчер параметров для новых разметок листов" на вкладке "Экран" диалогового окна "Настройка". Если не нужно, чтобы при каждой новой разметке листа автоматически создавался видовой экран, следует опустить там же флажок "Создавать видовые экраны при новой разметке листа".


Обзор настроек параметров листа (Процедура)

Задание настроек параметров листа
На уровень вверх ..
Обзор настроек параметров листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Обзор настроек параметров листа >
Обзор настроек параметров листа
Понятие Процедура Краткий справочник

Изменение настроек разметки в параметрах листа

Применение именованного набора параметров разметки одного листа к другой разметке листа


Изменение настроек разметки в параметрах листа (Процедура)

Обзор настроек параметров листа
На уровень вверх ..
Обзор настроек параметров листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Обзор настроек параметров листа >
Обзор настроек параметров листа
Понятие Процедура Краткий справочник

Изменение настроек разметки в параметрах листа

  1. Выберите вкладку разметки листа, параметры которого необходимо изменить.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" внесите необходимые изменения. Нажмите "ОК".
  6. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Применение именованного набора параметров разметки одного листа к другой разметке листа (Процедура)

Обзор настроек параметров листа
На уровень вверх ..
Выбор принтера или плоттера для листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Обзор настроек параметров листа >
Обзор настроек параметров листа
Понятие Процедура Краткий справочник

Применение именованного набора параметров разметки одного листа к другой разметке листа

  1. Выберите вкладку разметки листа, к которой необходимо применить настройки параметров другой разметки.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите именованный набор параметров разметки листа, который надо применить к данной разметке.
  4. Нажмите кнопку "Установить как текущее".
  5. Нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Обзор настроек параметров листа (Краткий справочник)

Коротко о сохранении параметров печати и публикаций
Обзор настроек параметров листа
Выбор принтера или плоттера для листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Обзор настроек параметров листа >
Обзор настроек параметров листа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор принтера или плоттера для листа (Понятие)

Обзор настроек параметров листа
Задание настроек параметров листа
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Выбор принтера или плоттера для листа
Понятие Процедура Краткий справочник

При создании разметки листа необходимо в диалоговом окне "Параметры листа" выбрать принтер или плоттер для его вывода на печать. После выбора устройства можно просматривать сведения об имени и местоположении устройства, а также изменять параметры его настройки.

От того, какой принтер или плоттер был выбран пользователем в диалоговом окне "Параметры листа", зависит печатаемая область листа. Она обозначается на разметке листа штриховой линией. При изменении размера бумаги или устройства печати может измениться область печати чертежа.

См. также

    • Выбор принтера или плоттера

    • Настройка параметров устройства и документа в PC3-файле в документе Руководство по периферийным устройствам


Выбор принтера или плоттера для листа (Процедура)

Обзор настроек параметров листа
На уровень вверх ..
Выбор принтера или плоттера для листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор принтера или плоттера для листа >
Выбор принтера или плоттера для листа
Понятие Процедура Краткий справочник

Выбор принтера или плоттера для разметки листа

Изменение конфигурации принтера или плоттера, определенного в параметрах листа


Выбор принтера или плоттера для разметки листа (Процедура)

Выбор принтера или плоттера для листа
На уровень вверх ..
Выбор принтера или плоттера для листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор принтера или плоттера для листа >
Выбор принтера или плоттера для листа
Понятие Процедура Краткий справочник

Выбор принтера или плоттера для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо определить принтер или плоттер.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Принтер/плоттер" выберите принтер или плоттер из списка. Нажмите "ОК".
  6. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на ярлыке вкладки разметки листа и выберите из контекстного меню "Диспетчер наборов параметров листов".


Изменение конфигурации принтера или плоттера, определенного в параметрах листа (Процедура)

Выбор принтера или плоттера для листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор принтера или плоттера для листа >
Выбор принтера или плоттера для листа
Понятие Процедура Краткий справочник

Изменение конфигурации принтера или плоттера, определенного в параметрах листа

  1. Выберите вкладку разметки листа, для которой необходимо определить принтер или плоттер.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Принтер/Плоттер" нажмите "Свойства".
  6. В Редактора параметров плоттера внесите необходимые изменения. Нажмите "ОК".
  7. В диалоговом окне "Параметры листа" нажмите "ОК".
  8. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Выбор принтера или плоттера для листа (Краткий справочник)

Обзор настроек параметров листа
Выбор принтера или плоттера для листа
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор принтера или плоттера для листа >
Выбор принтера или плоттера для листа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание формата бумаги для разметки листа (Понятие)

Выбор принтера или плоттера для листа
Задание настроек параметров листа
Установка печатаемой области в разметке листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Формат бумаги можно выбрать из стандартного списка. Также можно задать пользовательский нестандартный формат с помощью редактора параметров плоттера.

Формат бумаги можно выбрать из стандартного списка. Перечень присутствующих в списке форматов определяется установкой текущего для данной разметки листа плоттера. Если плоттер сконфигурирован на вывод в растровом формате, размеры изображения задаются в пикселах. Используя редактор настроек плоттера, можно добавить свои форматы бумаги и сохранить их в файле конфигурации плоттера (PC3).

При выводе на системный принтер формат по умолчанию берется из Панели управления Windows. Именно этот формат первоначально предлагается в диалоговом окне "Параметры листа" при создании новой разметки листа. Если изменяется формат, новое значение запоминается вместе с разметкой листа; оно имеет приоритет перед форматом, хранящимся в файле конфигурации плоттера (PC3).

См. также

    • Настройка параметров устройства и документа в PC3-файле в документе Руководство по периферийным устройствам


Задание формата бумаги для разметки листа (Процедура)

Выбор принтера или плоттера для листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Задание формата бумаги для разметки листа

Запуск редактора параметров плоттера

Создание пользовательского формата листа бумаги с нуля

Чтобы создать новый пользовательский формат листа на основе имеющегося формата

Чтобы отредактировать нестандартный формат листа

Чтобы удалить нестандартный формат листа

Для изменения стандартного формата листа


Задание формата бумаги для разметки листа (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Задание формата бумаги для разметки листа

  1. Выберите вкладку разметки листа, размер бумаги для которого необходимо задать.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Формат листа" выберите из списка формат бумажного листа. Нажмите "ОК".
  6. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Запуск редактора параметров плоттера (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Запуск редактора параметров плоттера

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.

    Открывается редактор параметров плоттера.

Ввод команды: ДИСППЕЧ


Создание пользовательского формата листа бумаги с нуля (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Создание пользовательского формата листа бумаги с нуля

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. В Диспетчере плоттеров дважды нажмите на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения параметров калибровки и формата листа бумаги для печати.
  4. Выберите "Нестандартные форматы бумаги".
  5. В группе "Нестандартные форматы бумаги" нажмите "Добавить".
  6. В Мастере пользовательских форматов бумаги на странице "Начало" выберите "Начать заново". Нажмите "Далее".
  7. На страничке "Медиа-границы" в списке "Единицы" выберите "Миллиметры" или "Дюймы".

    Если печатается растровое изображение (например BMP- или TIFF-файл), не имеющее определенных размеров, формат задается только в пикселах.

  8. В списках "Ширина" и "Длина" укажите размеры листа. Нажмите "Далее".
    ПримечаниеДля каждого плоттера существует ограничение на область вывода, в пределах которой может перемещаться контейнер с перьями. При задании формата, размеры которого больше предлагаемых Мастером, следует убедиться, что имеющийся плоттер может выводить чертежи в указанных размерах.
  9. На страничке "Область печати" в полях "Верх", "Низ", "Слева" и "Справа" задайте размеры полей области печати. Нажмите "Далее".
  10. На страничке "Имя формата" введите имя для идентификации данного нестандартного формата. Нажмите "Далее".
  11. На страничке "Имя файла" введите имя для PMP-файла.
  12. На конечной странице выберите источник подави бумаги - листовая или рулонная.
  13. Нажмите кнопку "Тестовая печать" для проверки созданного нестандартного формата.

    Напечатаются перекрестье, определяющее формат листа, и прямоугольник, определяющий область печати. Если какие-либо стороны рамки отсутствуют, следует увеличить область печати.

  14. Нажмите "Готово" для выхода из Мастера.
Ввод команды: ДИСППЕЧ


Чтобы создать новый пользовательский формат листа на основе имеющегося формата (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Чтобы создать новый пользовательский формат листа на основе имеющегося формата

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения настроек калибровки и формата бумаги.
  4. Выберите "Нестандартные форматы бумаги".
  5. В группе "Нестандартные форматы бумаги" нажмите "Добавить".
  6. В Мастере пользовательских форматов листа бумаги на странице "Начало" выберите "По существующему формату".
  7. В списке имеющихся стандартных форматов выберите формат, на основе которого будет создан новый.
  8. Дальнейшие действия, выполняемые в Мастере пользовательских форматов листа, описаны в разделе Создание пользовательского формата листа бумаги с нуля .

    Созданный таким образом формат считается нестандартным.

  9. Нажмите "Готово" для выхода из Мастера.
Ввод команды: ДИСППЕЧ


Чтобы отредактировать нестандартный формат листа (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Чтобы отредактировать нестандартный формат листа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения настроек калибровки и формата бумаги.
  4. Выберите "Нестандартные форматы бумаги".
  5. В списке группы опций "Нестандартные форматы бумаги" выберите требуемый формат. Нажмите кнопку "Правка".
  6. В окне Мастера пользовательских форматов листа изменить размер листа или области печати, имя формата или источник носителя.
  7. Нажмите "Готово" для выхода из Мастера.
Ввод команды: ДИСППЕЧ


Чтобы удалить нестандартный формат листа (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Задание формата бумаги для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Чтобы удалить нестандартный формат листа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите элемент "Нестандартные форматы и калибровка" для отображения настроек калибровки и формата листа.
  4. Нажмите "Нестандартные форматы бумаги".
  5. В списке группы опций "Нестандартные форматы бумаги" выберите требуемый формат.
  6. Нажмите кнопку "Удалить".
Ввод команды: ДИСППЕЧ


Для изменения стандартного формата листа (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Установка печатаемой области в разметке листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Для изменения стандартного формата листа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. В Диспетчере плоттеров дважды нажмите на значке PC3-файла, в котором нужно изменить конфигурацию плоттера.
  3. В редакторе параметров плоттеров на вкладке "Параметры устройства и документа" дважды нажмите на "Нестандартных форматах и калибровке" для отображения настроек калибровки и формата листов бумаги.
  4. Выберите "Изменение стандартных форматов бумаги".
  5. В списке группы "Изменение стандартных форматов бумаги" выберите формат для его изменения. Нажмите кнопку "Редактирование".
  6. В Мастере пользовательских форматов листа измените область печати. Нажмите "Готово" для выхода из Мастера.
Ввод команды: ДИСППЕЧ


Задание формата бумаги для разметки листа (Краткий справочник)

Выбор принтера или плоттера для листа
Задание формата бумаги для разметки листа
Установка печатаемой области в разметке листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание формата бумаги для разметки листа >
Задание формата бумаги для разметки листа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Установка печатаемой области в разметке листа (Понятие)

Задание формата бумаги для разметки листа
Задание настроек параметров листа
Регулировка смещения от начала для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Установка печатаемой области в разметке листа
Понятие Процедура Краткий справочник

Можно указать печатаемую область, т.е. пространственную часть чертежа, которая должна быть выведена на печать.

Готовя модель или лист к печати, можно указать печатаемую область, т.е. пространственную часть чертежа, которая должна быть выведена на печать. При создании новой разметки листа в качестве печатаемой области используется настройка по умолчанию "Разметка листа". Это значит, что печатаются все объекты, попадающие в область печати выбранного формата листа.

Для печати всех объектов, отображаемых в графической области окна, используется настройка печатаемой области "Экран". Для печати всех видимых объектов чертежа применяется настройка печатаемой области "Границы". Настройка печатаемой области "Вид" позволяет печатать сохраненный ранее вид. Для печати объектов в пределах указанной области используется настройка печатаемой области "Рамка".

См. также

    • Задание области печати


Задание области печати (Процедура)

Задание формата бумаги для разметки листа
На уровень вверх ..
Регулировка смещения от начала для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Установка печатаемой области в разметке листа >
Установка печатаемой области в разметке листа
Понятие Процедура Краткий справочник

Задание области печати

  1. Выберите вкладку разметки листа, для которой необходимо задать область печати и параметры отображения.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Область печати" выберите одну из следующих опций:
    • Разметка листа. Печать всех объектов, находящихся в печатаемой области листа. Опция доступна только для вкладок разметок листа.
    • Лимиты. Печать в пределах границ сетки. Опция доступна только для вкладок модели.
    • Границы. Печать всех объектов на чертеже.
    • Экран. Печать всех объектов, отображаемых в пределах области рисования.
    • Вид. Печать сохраненного вида. Вид выбирается из предлагаемого списка именованных видов.
    • Рамка. Печать объектов в пределах задаваемой пользователем области. Выберите опцию "Рамка" и в ответ на запрос укажите нужную область. Кнопкой "Рамка" можно воспользоваться также для того, чтобы изменить заданную область.
  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Установка печатаемой области в разметке листа (Краткий справочник)

Задание формата бумаги для разметки листа
Установка печатаемой области в разметке листа
Регулировка смещения от начала для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Установка печатаемой области в разметке листа >
Установка печатаемой области в разметке листа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Регулировка смещения от начала для разметки листа (Понятие)

Установка печатаемой области в разметке листа
Задание настроек параметров листа
Задание масштаба печати
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Регулировка смещения от начала для разметки листа
Понятие Процедура Краткий справочник

Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на листе штриховой линией. При смене устройства вывода на печать область печати может измениться.

Смещение печати задается от нижнего левого угла печатаемой области или края листа бумаги в зависимости от настройки параметра "Отсчет смещения чертежа" в диалоговом окне "Настройка" на вкладке "Печать/Публикация". Выбранный вариант смещения приводится в круглых скобках после названия группы опций "Смещение от начала" в диалоговом окне "Печать".

Смещение можно задать, введя положительные или отрицательные значения в поля "X" и "Y". Однако это может привести к усечению чертежа при печати.

Если на печать выводится не все содержимое разметки листа, то можно воспользоваться опцией центрирования чертежа на листе бумаги.


Задание смещения печати для разметки листа (Процедура)

Установка печатаемой области в разметке листа
На уровень вверх ..
Задание масштаба печати
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Регулировка смещения от начала для разметки листа >
Регулировка смещения от начала для разметки листа
Понятие Процедура Краткий справочник

Задание смещения печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо настроить смещение чертежа.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Смещение от начала" введите значение по оси X,Y или по обеим осям. Нажмите "ОК".
  6. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Регулировка смещения от начала для разметки листа (Краткий справочник)

Установка печатаемой области в разметке листа
Регулировка смещения от начала для разметки листа
Задание масштаба печати
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Регулировка смещения от начала для разметки листа >
Регулировка смещения от начала для разметки листа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

PLOTOFFSET

Управление способом отсчета смещения чертежа относительно печатаемой области или кромок листа бумаги

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание масштаба печати (Понятие)

Регулировка смещения от начала для разметки листа
Задание настроек параметров листа
Задание масштаба весов линий
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Задание масштаба печати
Понятие Процедура Краткий справочник

При выводе чертежа на печать можно либо задать точный масштаб, либо воспользоваться режимом вписывания чертежа в заданный формат листа бумаги.

Обычно чертежи печатают в масштабе 1:1. Чтобы задать другой масштаб печати чертежа, установите его в диалоговом окне "Параметры листа" или "Печать" В указанных диалоговых окнах масштаб можно ввести или выбрать из списка.

ПримечаниеМожно изменить список масштабов с помощью команды СПИСМАСШТРЕД.

Для черновых вариантов чертежей точность задания масштаба не столь важна. Здесь лучше воспользоваться опцией "Вписать" для вывода чертежа в наибольшем из возможных для данного формата масштабе.

См. также

    • Масштабирование видов на видовых экранах листа

    • Рисование, масштабирование и аннотирование в пространстве модели


Задание масштаба печати (Процедура)

Регулировка смещения от начала для разметки листа
На уровень вверх ..
Задание масштаба печати
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Задание масштаба печати

Подбор масштаба в зависимости от формата листа при печати


Задание масштаба печати (Процедура)

Задание масштаба печати
На уровень вверх ..
Задание масштаба печати
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Задание масштаба печати

  1. Выберите вкладку разметки листа, для которой необходимо установить масштаб.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Масштаб печати" выберите масштаб из списка масштабов.

    Для листа масштаб по умолчанию равен 1:1. Для установки пользовательского (нестандартного) масштаба печати следует ввести значения, задающие отношение реальных единиц готового чертежа к условным единицам чертежа. Тип единиц измерения определяется размером листа, но его можно изменить, выбрав из списка.

  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Параметры листа".


Подбор масштаба в зависимости от формата листа при печати (Процедура)

Задание масштаба печати
На уровень вверх ..
Задание масштаба весов линий
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Подбор масштаба в зависимости от формата листа при печати

  1. Выберите вкладку разметки листа, которую необходимо вписать в лист данного формата.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Масштаб печати" выберите опцию "Вписать".
    ПримечаниеЕсли выбрана опция области печати "Разметка листа", то опция "Вписать" становится недоступной.
  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание масштаба печати (Краткий справочник)

Регулировка смещения от начала для разметки листа
Задание масштаба печати
Задание масштаба весов линий
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Команды

СПИСМАСШТРЕД

Управление списком доступных значений масштаба для видовых экранов, листа и печати

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание масштаба весов линий (Понятие)

Задание масштаба печати
Задание настроек параметров листа
Выбор таблицы стилей печати для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Задание масштаба весов линий
Понятие Процедура Краткий справочник

Веса линий на выводимых листах можно пропорционально масштабировать в соответствии с масштабом печати.

Веса линий, как правило, обозначают ширину линий печатаемых объектов и печатаются независимо от масштаба печати. Наиболее часто масштаб печати бывает равен 1:1, при этом никаких дополнительных действий с весом линий производить не требуется. Однако один и тот же лист можно напечатать в масштабе 1:1 на бумаге формата A3, а также в масштабе 1:2 на бумаге формата A4. При этом на каждом из полученных чертежей может понадобиться сохранить пропорции толщины линий.

См. также

    • Работа с весами линий


Масштабирование весов линий (Процедура)

Задание масштаба печати
На уровень вверх ..
Выбор таблицы стилей печати для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание масштаба весов линий >
Задание масштаба весов линий
Понятие Процедура Краткий справочник

Масштабирование весов линий

  1. Выберите вкладку разметки листа, для которой необходимо изменить веса линий.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Масштаб печати" установите флажок "Масштабировать веса линий".

    Веса линий в текущем листе будут отмасштабированы в соответствии с указанным масштабом печати. При работе на вкладке "Модель" данная опция недоступна.

  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание масштаба весов линий (Краткий справочник)

Задание масштаба печати
Задание масштаба весов линий
Выбор таблицы стилей печати для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание масштаба весов линий >
Задание масштаба весов линий
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор таблицы стилей печати для разметки листа (Понятие)

Задание масштаба весов линий
Задание настроек параметров листа
Задание параметров печати для видовых экранов с раскрашиванием
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Выбор таблицы стилей печати для разметки листа
Понятие Процедура Краткий справочник

Таблица стилей печати содержит набор стилей печати, назначенных разметке листа или модели. Стиль печати, наряду с типом линии или цветом, является свойством объекта. Стили печати могут назначаться отдельным объектам и слоям. Стиль печати задает свойства объекта при выводе на печать.

Можно создать новую таблицу стилей печати для сохранения параметров листа или отредактировать уже существующую таблицу стилей печати.

Если установить флажок "Показать стили печати" в группе опций "Таблица стилей печати", объекты на выбранном листе будут отображаться с учетом назначенных им свойств стилей печати.

См. также

    • Управление стилем печати объектов


Выбор таблицы стилей печати для разметки листа (Процедура)

Задание масштаба весов линий
На уровень вверх ..
Выбор таблицы стилей печати для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор таблицы стилей печати для разметки листа >
Выбор таблицы стилей печати для разметки листа
Понятие Процедура Краткий справочник

Выбор таблицы стилей печати для разметки листа

Создание новой таблицы стилей печати для разметки листа

Изменение таблицы стилей печати для разметки листа

Просмотр содержимого листа с учетом таблицы стилей печати


Выбор таблицы стилей печати для разметки листа (Процедура)

Выбор таблицы стилей печати для разметки листа
На уровень вверх ..
Выбор таблицы стилей печати для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор таблицы стилей печати для разметки листа >
Выбор таблицы стилей печати для разметки листа
Понятие Процедура Краткий справочник

Выбор таблицы стилей печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо выбрать таблицу стилей печати.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе опций "Таблица стилей печати" выберите необходимую таблицу.
  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Создание новой таблицы стилей печати для разметки листа (Процедура)

Выбор таблицы стилей печати для разметки листа
На уровень вверх ..
Выбор таблицы стилей печати для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор таблицы стилей печати для разметки листа >
Выбор таблицы стилей печати для разметки листа
Понятие Процедура Краткий справочник

Создание новой таблицы стилей печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо создать новую таблицу стилей печати.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Таблица стилей печати" выберите из списка "Новая".
  6. Следуйте инструкциям появившегося мастера (Мастера создания таблиц цветозависимых стилей печати или Мастера создания таблиц именованных стилей печати).
  7. В диалоговом окне "Параметры листа" нажмите "ОК".
  8. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Изменение таблицы стилей печати для разметки листа (Процедура)

Выбор таблицы стилей печати для разметки листа
На уровень вверх ..
Выбор таблицы стилей печати для разметки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор таблицы стилей печати для разметки листа >
Выбор таблицы стилей печати для разметки листа
Понятие Процедура Краткий справочник

Изменение таблицы стилей печати для разметки листа

  1. Выберите вкладку разметки листа, для которой необходимо изменить таблицу стилей печати.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Таблица стилей печати" выберите из списка таблицу стилей печати, которую надо отредактировать.
  6. Нажмите кнопку "Правка".
  7. В Редакторе таблиц стилей печати внесите необходимые изменения. Нажать кнопку "Принять".
  8. В диалоговом окне "Параметры листа" нажмите "ОК".
  9. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Просмотр содержимого листа с учетом таблицы стилей печати (Процедура)

Выбор таблицы стилей печати для разметки листа
На уровень вверх ..
Задание параметров печати для видовых экранов с раскрашиванием
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор таблицы стилей печати для разметки листа >
Выбор таблицы стилей печати для разметки листа
Понятие Процедура Краткий справочник

Просмотр содержимого листа с учетом таблицы стилей печати

  1. Выберите вкладку разметки листа, для которой необходимо отобразить стили печати.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Таблицы стилей печати" выберите опцию "Отобразить таблицу стилей печати".
  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Выбор таблицы стилей печати для разметки листа (Краткий справочник)

Задание масштаба весов линий
Выбор таблицы стилей печати для разметки листа
Задание параметров печати для видовых экранов с раскрашиванием
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Выбор таблицы стилей печати для разметки листа >
Выбор таблицы стилей печати для разметки листа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание параметров печати для видовых экранов с раскрашиванием (Понятие)

Выбор таблицы стилей печати для разметки листа
Задание настроек параметров листа
Задание ориентации чертежа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Задание параметров печати для видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Ряд настроек, сохраняющихся в параметрах листа, позволяет задавать параметры вывода на печать видовых экранов, содержащих раскрашенные тела.

Ряд настроек позволяет задавать параметры вывода на печать видовых экранов, содержащих раскрашенные тела. Настройки печати видовых экранов, содержащих раскрашенные объекты, обеспечивают большую гибкость представления трехмерных объектов. Печать чертежа производится на основании выбранного режима обращения с раскрашенными видовыми экранами и установленного разрешения печатающего устройства.

Настройки печати ВЭкранов с раскрашиванием

Возможные варианты печати раскрашенных видовых экранов таковы: "Обычный", "Каркас", "Скрытие линий" и "Тонирование".

Опции печати раскрашенных видовых экранов применимы ко всем объектам на видовых экранах и в пространстве модели. При использовании средства печати раскрашенных и тонированных видовых экранов таблицы стилей печати в параметрах листов не активизируются. Если используется опция "Тонирование", то двумерные каркасные объекты, такие как линии, дуги и текст, не печатаются.

ПримечаниеРаспечатывать раскрашенные видовые экраны можно только на устройствах с растровой графикой. Большинство современных плоттеров и принтеров поддерживают растровую графику.

Опции печати

Для листов можно задать также следующие опции, определяющие то, как объекты будут печататься.

  • Учитывать веса линий. Задает печать с учетом весов линий, назначенных объектам и слоям.
  • Учитывать стили печати. Задает печать чертежа с применением стилей печати. При выборе этой опции печать выполняется с учетом весов линий. Если эта опция отключена, то печать выполняется с учетом свойств объектов без переопределения этих свойств с помощью стилей печати.
  • Объекты листа последними. Задает последовательность печати таким образом, чтобы в первую очередь выполнялась печать объектов пространства модели и только затем - пространства листа.
  • Скрывать объекты листа Определяет, применима ли операция скрытия к объектам видового экрана пространства листа. Доступно только для вкладки разметки листа. Опция воздействует на линии только в момент печати и просмотра перед печатью.
См. также

    • Настройка печати видовых экранов с раскрашиванием

    • Задание параметров печати объектов


Задание параметров печати для видовых экранов с раскрашиванием (Процедура)

Выбор таблицы стилей печати для разметки листа
На уровень вверх ..
Задание параметров печати для видовых экранов с раскрашиванием
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание параметров печати для видовых экранов с раскрашиванием >
Задание параметров печати для видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Задание параметров печати видовых экранов с раскрашиванием

Установка опций печати для листа


Задание параметров печати видовых экранов с раскрашиванием (Процедура)

Задание параметров печати для видовых экранов с раскрашиванием
На уровень вверх ..
Задание параметров печати для видовых экранов с раскрашиванием
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание параметров печати для видовых экранов с раскрашиванием >
Задание параметров печати для видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Задание параметров печати видовых экранов с раскрашиванием

  1. Выберите вкладку разметки листа, для которой необходимо установить параметры печати раскрашенных видовых экранов.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "ВЭкраны с раскрашиванием" выберите требуемые настройки.
  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Установка опций печати для листа (Процедура)

Задание параметров печати для видовых экранов с раскрашиванием
На уровень вверх ..
Задание ориентации чертежа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание параметров печати для видовых экранов с раскрашиванием >
Задание параметров печати для видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Установка опций печати для листа

  1. Выберите вкладку разметки листа, для которого необходимо установить параметры печати.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Опции печати" выберите требуемые настройки.
  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание параметров печати для видовых экранов с раскрашиванием (Краткий справочник)

Выбор таблицы стилей печати для разметки листа
Задание параметров печати для видовых экранов с раскрашиванием
Задание ориентации чертежа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание параметров печати для видовых экранов с раскрашиванием >
Задание параметров печати для видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание ориентации чертежа (Понятие)

Задание параметров печати для видовых экранов с раскрашиванием
Задание настроек параметров листа
Задание параметров листа с помощью Мастера компоновки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа >
Задание ориентации чертежа
Понятие Процедура Краткий справочник

Переключатель ориентации чертежа имеет два положения: "Альбомная" и "Книжная". При альбомной ориентации горизонтально располагается длинная сторона листа, а при книжной - короткая. Смена ориентации создает эффект поворота листа бумаги, подложенного под чертеж, на 90 градусов.

При любой ориентации, переключив флажок "Перевернуть", можно выполнить разворот выводимого чертежа на 180 градусов.

Хотя ориентацию чертежа можно задать в обоих диалоговых окнах, управляющих выводом на печать ("Параметры листа" и "Печать"), с листом сохраняются только установки, сделанные в диалоговом окне "Параметры листа". В диалоговом окне "Печать" можно переопределить параметры отдельного листа, но новые значения параметров при этом не сохраняются. Для сохранения настроек, которые были применены в диалоговом окне "Печать", необходимо в этом диалоговом окне нажать на кнопку "Применить к листу".

При смене ориентации чертежа точка его начала остается в левом нижнем углу области чертежа.


Задание ориентации вывода чертежа (Процедура)

Задание параметров печати для видовых экранов с раскрашиванием
На уровень вверх ..
Задание параметров листа с помощью Мастера компоновки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание ориентации чертежа >
Задание ориентации чертежа
Понятие Процедура Краткий справочник

Задание ориентации вывода чертежа

  1. Выберите вкладку разметки листа, для которой необходимо задать ориентацию чертежа.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе опций "Параметры листа" выберите набор параметров, который требуется изменить.
  4. Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Параметры листа" в группе "Ориентация чертежа" необходимо осуществить одно из следующих действий:
    • Если чертеж должен располагаться горизонтально, выберите "Альбомная".
    • Если чертеж должен располагаться вертикально, выберите "Книжная".
    • Для разворота чертежа на 180 градусов оставьте значение ориентации прежним ("Книжная" или "Альбомная") и переключите состояние флажка "Перевернуть".
  6. Нажмите "ОК".
  7. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Задание ориентации чертежа (Краткий справочник)

Задание параметров печати для видовых экранов с раскрашиванием
Задание ориентации чертежа
Задание параметров листа с помощью Мастера компоновки листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание настроек параметров листа > Задание ориентации чертежа >
Задание ориентации чертежа
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание параметров листа с помощью Мастера компоновки листа (Понятие)

Задание ориентации чертежа
Подготовка чертежей к печати и публикации
Импорт настроек PCP или PC2 в компоновку листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации >
Задание параметров листа с помощью Мастера компоновки листа
Понятие Процедура Краткий справочник

Новую разметку листа можно создать с помощью Мастера компоновки листа.

При использовании Мастера процесс создания разметки листа разбивается на несколько этапов, при прохождении которых пользователь задает следующие параметры:

  • Имя нового листа
  • Принтер, назначаемый листу
  • Формат бумаги, используемый для листа
  • ориентация чертежа на листе бумаги
  • основная надпись
  • параметры видового экрана
  • Расположение видового экрана на листе

Информацию, введенную с помощью мастера, можно отредактировать позднее. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". Выбрав разметку листа, в командной строке введите "парамлист". В диспетчере наборов параметров листов нажмите "Редактирование".


Создание разметки листа с помощью Мастера (Процедура)

Задание ориентации чертежа
Задание параметров листа с помощью Мастера компоновки листа
Импорт настроек PCP или PC2 в компоновку листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание параметров листа с помощью Мастера компоновки листа >
Задание параметров листа с помощью Мастера компоновки листа
Понятие Процедура Краткий справочник

Создание разметки листа с помощью Мастера

  1. Выберите пункт меню "Вставить" [image] "Лист" [image] "Мастер компоновки листа".
  2. На каждой странице Мастера создания листа необходимо задать соответствующие настройки для нового листа.

    После завершения работы Мастера вновь созданный лист станет текущим.

Ввод команды: МАСТЕРЛИСТ


Задание параметров листа с помощью Мастера компоновки листа (Краткий справочник)

Задание ориентации чертежа
Задание параметров листа с помощью Мастера компоновки листа
Импорт настроек PCP или PC2 в компоновку листа
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Задание параметров листа с помощью Мастера компоновки листа >
Задание параметров листа с помощью Мастера компоновки листа
Понятие Процедура Краткий справочник

Команды

МАСТЕРЛИСТ

Создание нового листа, задание параметров листа и печати

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Импорт настроек PCP или PC2 в компоновку листа (Понятие)

Задание параметров листа с помощью Мастера компоновки листа
Подготовка чертежей к печати и публикации
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации >
Импорт настроек PCP или PC2 в компоновку листа
Понятие Процедура Краткий справочник

Можно импортировать в текущую разметку листа параметры листа и печати, содержащиеся в файлах PCP или PC2.

При работе с чертежами, созданными в редакции 14 или в более ранних редакциях AutoCAD, можно импортировать параметры компоновки и печати, содержащиеся в файле PCP или PC2, и применить их к текущей компоновке. В файлах PCP или PC2 хранятся следующие настройки

  • печатаемая область
  • угол поворота
  • формат листа
  • масштаб печати
  • точка начала чертежа
  • смещение от начала

Кроме того, файл PC2 содержит сведения о разрешении, модифицированные при калибровке плоттера. Из PCP- и PC2-файлов с помощью Мастера создания таблиц стилей печати можно импортировать информацию о присвоениях перьев и сохранить ее в таблице стилей печати.

Для импорта информации об устройстве печати и назначениях перьев можно воспользоваться Мастером импорта параметров печати из PCP или PC2. Любые из импортированных настроек можно изменить в диалоговом окне "Параметры листа".


Импорт параметров из PCP или PC2 в текущую разметку листа (Процедура)

Задание параметров листа с помощью Мастера компоновки листа
Импорт настроек PCP или PC2 в компоновку листа
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Импорт настроек PCP или PC2 в компоновку листа >
Импорт настроек PCP или PC2 в компоновку листа
Понятие Процедура Краткий справочник

Импорт параметров из PCP или PC2 в текущую разметку листа

  1. В командной строке введите мастерпеч.
  2. В Мастере импорта параметров печати из PCP или PC2 выберите файл PCP или PC2 для импорта настроек в текущий лист.


Импорт настроек PCP или PC2 в компоновку листа (Краткий справочник)

Задание параметров листа с помощью Мастера компоновки листа
Импорт настроек PCP или PC2 в компоновку листа
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Импорт настроек PCP или PC2 в компоновку листа >
Импорт настроек PCP или PC2 в компоновку листа
Понятие Процедура Краткий справочник

Команды

МАСТЕРПЕЧ

Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и использование наборов параметров листов (Понятие)

Импорт настроек PCP или PC2 в компоновку листа
Подготовка чертежей к печати и публикации
Использование наборов параметров листов в подшивках
Печать и публикация чертежей > Подготовка чертежей к печати и публикации >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Настройки устройства печати и другие параметры листа можно сохранить в наборе параметров листов. Созданный таким образом набор параметров листа можно впоследствии изменить или импортировать в другие чертежи.

Пользователь может создать набор параметров листов и применить его к другим разметкам листов в данном чертеже. Набор параметров листов сохраняется в файле чертежа. Он может быть импортирован в другие файлы чертежей и применен к другим разметкам листов. Можно также изменить настройки набора параметров листов. Измененные параметры могут быть применены только к текущей разметке листа или ко всем листам в текущем чертеже, использующим данный набор параметров листов.

Наборы параметров листа используются в тех случаях, когда необходимо распечатать один и тот же лист различными способами или задать одни и те же настройки вывода на печать для нескольких разметок листов.

Пользователь может применить другой набор параметров листов к этой же разметке листа, чтобы получить несколько иной результат при печати. Например, можно создать наборы параметров листа, описанные в следующей таблице.

Набор параметров листа | Описание
В натур. вел. | Печать в масштабе 1:1, на формате A3
Масштаб 1:2 | Печать в масштабе 1:2, на формате A4
Черновое | Вывод с черновым качеством
Окончат. вариант | Высококачественная печать
Вписать в размеры листа | Вписать в размеры листа, лист формата А5

Печать или публикация листа всегда осуществляется с применением настроек, заданных в назначенном данной разметке листа наборе параметров.


Создание и использование наборов параметров листов (Процедура)

Импорт настроек PCP или PC2 в компоновку листа
Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Создание новых наборов параметров листов

Процедура применения именованного набора параметров листа к компоновке

Процедура изменения именованного набора параметров листа

Импорт набора параметров листов из другого чертежа

Удаление набора параметров листов

Переименование набора параметров листов


Создание новых наборов параметров листов (Процедура)

Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Создание новых наборов параметров листов

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  2. В Диспетчере наборов параметров листов в группе опций "Параметры листа" нажмите кнопку "Создать".
  3. В диалоговом окне "Создание набора параметров листа" ввести имя для нового набора параметров листа.
  4. В группе "На основе" выберите из списка параметры листа. Настройки выбранного в качестве основы набора параметров листа, будут отображены в диалоговом окне "Параметры листа" после нажатия кнопки "ОК".
  5. Нажмите "ОК".
  6. В диалоговом окне "Параметры листа" измените необходимые настройки. Нажмите "ОК".

    Новые настройки листа будут отображены в списке "Параметры листа" в Диспетчере наборов параметров листов.

  7. Для применения новых настроек листа к текущей разметке листа необходимо в Диспетчере наборов параметров листов нажать "Установить текущим".
  8. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Процедура применения именованного набора параметров листа к компоновке (Процедура)

Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Процедура применения именованного набора параметров листа к компоновке

  1. Выберите вкладку разметки листа, к которой надо применить набор параметров листа.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов в группе "Параметры листа" выберите набор параметров листов из списка.
    ПримечаниеНеименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующего листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какому-либо иному листу. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к листу, которому данный неименованный набор параметров был назначен.
  4. Нажмите кнопку "Установить".
  5. Нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Процедура изменения именованного набора параметров листа (Процедура)

Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Процедура изменения именованного набора параметров листа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  2. В Диспетчере наборов параметров листов в группе "Параметры листа" выберите набор параметров листов из списка.
    ПримечаниеНеименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующего листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какому-либо иному листу. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к разметке листа, которой данный неименованный набор параметров был назначен.
  3. Нажмите кнопку "Редактирование".
  4. В диалоговом окне "Параметры листа" внесите необходимые изменения. Нажмите "ОК".
  5. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Импорт набора параметров листов из другого чертежа (Процедура)

Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Импорт набора параметров листов из другого чертежа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  2. В Диспетчере наборов параметров листов нажмите кнопку "Импорт".
  3. В диалоговом окне "Выбор набора параметров листа из файла" выберите файл чертежа, из которого будет импортирован один или несколько именованных наборов параметров листов. Нажмите кнопку "Импорт".
  4. В диалоговом окне "Импорт наборов параметров листов" выберите один или несколько наборов параметров листов для импорта. Нажмите "ОК".

    Если набор параметров листов с таким же именем уже существует в данном чертеже, то можно принять настройки из импортируемого набора параметров листа или отменить операцию.

    Импортированные наборы параметров листа появляются в списке Диспетчера наборов параметров листов.

    ПримечаниеМожно импортировать параметры одновременно и для вкладок разметок листов и для пространства модели. Однако импортированный набор параметров листа для пространства модели включается в список Диспетчера наборов параметров листов только в том случае, если вкладка модели являлась текущей при открытии Диспетчера. Аналогично, импортированный набор параметров вкладки разметки листа включается в список Диспетчера наборов параметров листов только в том случае, если вкладка листа являлась текущей при открытии Диспетчера.
  5. В Диспетчере наборов параметров листов нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Удаление набора параметров листов (Процедура)

Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Удаление набора параметров листов

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  2. В Диспетчере наборов параметров листов в группе "Параметры листов" нажмите правую кнопку мыши на наборе параметров листов, который требуется удалить. Выберите "Удалить".
    ПримечаниеНеименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующей разметки листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какому-либо иному листу. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к разметке листа, которой данный неименованный набор параметров был назначен.
  3. Нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Переименование набора параметров листов (Процедура)

Создание и использование наборов параметров листов
Создание и использование наборов параметров листов
Использование наборов параметров листов в подшивках
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Переименование набора параметров листов

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  2. В Диспетчере наборов параметров листов в группе опций "Параметры листов" нажмите правую кнопку мыши на наборе параметров листов, который требуется переименовать. Выберите "Переименовать".
    ПримечаниеНеименованные наборы параметров листа обозначаются в Диспетчере наборов параметров листов звездочками вокруг имени соответствующей разметки листа. Неименованный набор параметров листа менее функционален по сравнению с именованным набором параметров. Например, неименованный набор параметров можно присвоить какому-либо иному листу. Однако если затем изменить настройки этого неименованного набора параметров листов, то эти изменения не будут применены к листу, которому данный неименованный набор параметров был назначен.
  3. Введите новое имя для набора параметров листов.
  4. Нажмите кнопку "Закрыть".
Панель:Листы
Ввод команды: ПАРАМЛИСТ
Контекстное меню:Нажмите правую кнопку мыши на вкладке разметки листа. Выберите "Диспетчер наборов параметров листов".


Создание и использование наборов параметров листов (Краткий справочник)

Импорт настроек PCP или PC2 в компоновку листа
Создание и использование наборов параметров листов
Использование наборов параметров листов в подшивках
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Создание и использование наборов параметров листов >
Создание и использование наборов параметров листов
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование наборов параметров листов в подшивках (Понятие)

Создание и использование наборов параметров листов
Подготовка чертежей к печати и публикации
Вывод чертежей на печать
Печать и публикация чертежей > Подготовка чертежей к печати и публикации >
Использование наборов параметров листов в подшивках
Понятие Процедура Краткий справочник

Наборы параметров листов можно использовать для задания одних и тех же опций вывода для всех листов подшивки.

Пользователь может с помощью Диспетчера подшивок создать разметку листа с нуля, а затем применить к ней набор параметров листа.

В ходе публикации можно также разово применить наборы параметров листов, которые хранятся в файле переопределения параметров листа подшивки (DWT), к одному листу или ко всей подшивке.

См. также

    • Создание и использование наборов параметров листов


Использование наборов параметров листов в подшивках (Процедура)

Создание и использование наборов параметров листов
Использование наборов параметров листов в подшивках
Использование наборов параметров листов в подшивках
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Использование наборов параметров листов в подшивках >
Использование наборов параметров листов в подшивках
Понятие Процедура Краткий справочник

Применение набора параметров к листу подшивки, созданному с нуля

Применение набора параметров листов в качестве переопределения при публикации листов


Применение набора параметров к листу подшивки, созданному с нуля (Процедура)

Использование наборов параметров листов в подшивках
Использование наборов параметров листов в подшивках
Использование наборов параметров листов в подшивках
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Использование наборов параметров листов в подшивках >
Использование наборов параметров листов в подшивках
Понятие Процедура Краткий справочник

Применение набора параметров к листу подшивки, созданному с нуля

  1. Выберите пункт меню "Файл" [image] "Открыть подшивку".В командной строке введите "пшоткрыть".
  2. В диалоговом окне "Открыть подшивку" выберите подшивку. Нажмите "Открыть".
  3. В Диспетчере подшивок щелкните правой кнопкой мыши в области "Листы". Выберите "Новый лист".
  4. В диалоговом окне "Новый лист" введите номер и заголовок листа. Нажмите "ОК".
  5. В Диспетчере подшивок в области "Листы" дважды нажмите кнопку мыши на новом листе.
  6. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер параметров листов". В командной строке введите "парамлист".
  7. В Диспетчере параметров листов, в группе "Параметры листа" выберите набор параметров листа. Нажмите кнопку "Установить".

    Именованные наборы параметров листов не обрамляются звездочками.

  8. Нажмите кнопку "Закрыть".
Панель:Стандартная
Ввод команды: ПОДШИВКА


Применение набора параметров листов в качестве переопределения при публикации листов (Процедура)

Использование наборов параметров листов в подшивках
Использование наборов параметров листов в подшивках
Основные сведения о процессе печати
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Использование наборов параметров листов в подшивках >
Использование наборов параметров листов в подшивках
Понятие Процедура Краткий справочник

Применение набора параметров листов в качестве переопределения при публикации листов

  1. Выберите пункт меню "Файл" [image] "Открыть подшивку".В командной строке введите "пшоткрыть".
  2. В диалоговом окне "Открыть подшивку" выберите подшивку. Нажмите "Открыть".
  3. В Диспетчере подшивок в области "Листы" выберите подшивку, подгруппу или лист для публикации.
  4. В верхней части Диспетчера подшивок нажмите кнопку "Опубликовать".
  5. В контекстном меню наведите курсор на пункт "Опубликовать без учета параметров листа"
  6. В подменю выберите тот набор параметров листа, который будет использоваться.
Панель:Стандартная
Ввод команды: ПОДШИВКА


Использование наборов параметров листов в подшивках (Краткий справочник)

Создание и использование наборов параметров листов
Использование наборов параметров листов в подшивках
Коротко о процессе печати
Печать и публикация чертежей > Подготовка чертежей к печати и публикации > Использование наборов параметров листов в подшивках >
Использование наборов параметров листов в подшивках
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПУБЛ
ПОДШИВКА

Вызов Диспетчера подшивок

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вывод чертежей на печать

Использование наборов параметров листов в подшивках
Печать и публикация чертежей
Коротко о процессе печати
Печать и публикация чертежей >
Вывод чертежей на печать

Понятие "печать чертежа" для подготовленных в AutoCAD чертежей объединяет в себе процессы получения вычерченных бумажных копий или электронных чертежей, которые могут использоваться в других приложениях. В обоих случаях необходимо настроить параметры печати.

Темы в этом разделе

  • Коротко о процессе печати

    Для вывода на печать одного листа или части чертежа используется диалоговое окно "Печать".

  • Основные сведения о процессе печати

    Знание терминов и понятий, касающихся процесса печати, поможет сделать первый шаг в работе с программой.

  • Использование набора параметров листа для задания режимов печати
  • Выбор принтера или плоттера

    Перед печатью чертежа необходимо выбрать принтер или плоттер. Выбранное устройство определяет, какая часть чертежа входит в печатаемую область.

  • Задание области печати

    Для печати чертежа необходимо задать печатаемую область. В диалоговом окне "Печать" можно выбрать любой из следующих вариантов:

  • Задание формата бумаги

    Формат листа при выводе чертежа на печать задается в диалоговом окне "Печать".

  • Расположение чертежа на бумаге

    Для задания расположения чертежа на бумаге существует несколько методов. Можно задать область печати, смещение чертежа на бумаге и ориентацию чертежа.

  • Управление стилем печати объектов

    Имеется возможность управления печатью объектов с помощью параметров масштаба печати, стилей печати, таблиц стилей печати и путем изменения свойств слоев объектов.

  • Предварительный просмотр

    Прежде чем выводить чертеж на печать, рекомендуется выполнять предварительный просмотр чертежа. Это позволит сократить затраты времени и расходных материалов, необходимых для выполнения печати.

  • Печать в файлы различных форматов

    Экспорт и печать чертежей можно осуществлять в целом ряде форматов, включая DWF, DWFx, DXF, PDF и метафайл Windows (WMF). Вывод чертежей в файлы можно выполнять с помощью специальных драйверов печати.


Коротко о процессе печати (Понятие)

Вывод чертежей на печать
Вывод чертежей на печать
Основные сведения о процессе печати
Печать и публикация чертежей > Вывод чертежей на печать >
Коротко о процессе печати
Понятие Краткий справочник

Для вывода на печать одного листа или части чертежа используется диалоговое окно "Печать".

В диалоговом окне "Печать" можно задать именованный набор параметров печати, а также определить устройство вывода на печать.

Для печати более одного чертежа следует использовать окно "Публикация".

См. также

    • Коротко о публикации


Коротко о процессе печати (Краткий справочник)

Использование наборов параметров листов в подшивках
Коротко о процессе печати
Основные сведения о процессе печати
Печать и публикация чертежей > Вывод чертежей на печать > Коротко о процессе печати >
Коротко о процессе печати
Понятие Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Основные сведения о процессе печати (Понятие)

Коротко о процессе печати
Вывод чертежей на печать
Использование набора параметров листа для задания режимов печати
Печать и публикация чертежей > Вывод чертежей на печать >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Знание терминов и понятий, касающихся процесса печати, поможет сделать первый шаг в работе с программой.

Диспетчер плоттеров

Диспетчер плоттеров представляет собой окно, содержащее список файлов параметров плоттера (PC3) для каждого установленного несистемного принтера. Файлы параметров плоттера также можно создавать для системных принтеров Windows®, чтобы использовать по умолчанию свойства, отличные от тех, что используются операционной системой Windows. К параметрам плоттера относятся сведения о порте подключения, качестве растровой и векторной графики, допустимых форматах листа, а также дополнительные свойства (свои для каждого типа устройства).

Диспетчер плоттеров предоставляет базовое средство для создания новых файлов параметров плоттеров - Мастер установки плоттеров. Этот Мастер запрашивает у пользователя необходимую информацию о плоттере в процессе установки.

Разметки листов

Разметка листа является изображением распечатанной страницы. Имеется возможность создавать столько вариантов разметок, сколько потребуется. Каждый вариант разметки листа хранится на своей вкладке разметки листа, и ему может быть назначен свой набор параметров листа.

В процессе создания разметки листа выполняется размещение таких выводящихся только при печати листа элементов, как основная надпись и примечания. Объекты чертежа, создаваемые в пространстве модели, размещаются на вкладке "Модель". Для их просмотра в пространстве листа необходимо создавать видовые экраны разметки листа.

Инициализация разметки листа

Инициализация разметки листа - это процесс, в ходе которого щелчком на соответствующей вкладке активизируется разметка, которая прежде не использовалась.

До инициализации лист не содержит никаких параметров печати. После инициализации на листах можно выполнять черчение, их можно публиковать и добавлять в подшивки (после сохранения чертежа).

Наборы параметров листа

При создании листа необходимо указывать устройство печати и такие параметры, как формат и ориентация печати. Эти настройки сохраняются в наборе параметров листа. Эти параметры можно задавать для пространства листа и модели с помощью Диспетчера наборов параметров листов. Наборы параметров листа можно именовать и сохранять в целях дальнейшего их использования для других разметок листов.

Если в диалоговом окне "Параметры листа" заданы не все параметры, то их можно указать непосредственно перед началом печати. Кроме того, можно переназначить параметры листа во время печати. Новые параметры листа могут быть либо использованы только во время текущего процесса печати, либо сохранены для последующих сеансов.

Стили печати

Использование стилей печати позволяет изменять внешний вид объектов и слоев при их выводе на печатающее устройство, регулируя такие свойства, как вес линий, цвет и стиль закрашивания. Стили печати группируются в таблицы стилей печати. Диспетчер стилей печати - это окно, в котором отображаются все доступные стили печати.

Существует два типа стилей печати: цветозависимые и именованные. В таблице, которая назначена чертежу, должны присутствовать только стили какого-либо одного вида. Стили печати в таблице могут быть преобразованы из одного типа в другой. Можно также менять используемый в чертеже тип стилей печати.

При использовании цветозависимых стилей печати на печать объектов влияет их цвет. Файлы таблиц таких стилей имеют расширение .ctb. Назначение цветозависимых стилей печати непосредственно объектам не разрешено. Это означает, что для изменения внешнего вида выводимого на печать объекта нужно присвоить ему другой цвет на чертеже. Например, для печати группы объектов чертежа одним методом им всем присваивается красный цвет.

Именованные стили печати могут быть назначены непосредственно объектам и слоям. Файлы таблиц таких стилей печати имеют расширение .stb. Использование именованных стилей позволяет печатать каждый объект с различными характеристиками, независимо от цвета самих объектов.

Штемпель для чертежа

Штемпель - это фрагмент текста, размещаемый на чертеже при печати. Расположение штемпеля задается в диалоговом окне "Штемпель". Этот параметр включают, чтобы добавлять информацию для штемпеля—включая имя чертежа, имя листа, дату и время и прочее—для добавления в чертеж, который будет распечатан на каком-либо устройстве. Информацию со штемпеля можно запомнить в файле журнала (одновременно выводя или не выводя ее на печать).

ПримечаниеФайл чертежа или файл шаблона чертежа, созданный в учебной версии, всегда выводится на печать со следующим штемпелем: "СОЗДАНО УЧЕБНОЙ ВЕРСИЕЙ ПРОДУКТА AUTODESK" Если в чертеже используются блоки или внешние ссылки, созданные в учебной версии продукта, то при выводе на печать появляется аналогичный штемпель.
См. также

    • Создание многовидовых чертежей (в пространстве листа)

    • Для получения справки по дополнительным свойствам в документе Руководство по периферийным устройствам


Основные сведения о процессе печати (Процедура)

Использование наборов параметров листов в подшивках
Основные сведения о процессе печати
Основные сведения о процессе печати
Печать и публикация чертежей > Вывод чертежей на печать > Основные сведения о процессе печати >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Печать чертежа

Включение/отключение фоновой печати

Проверка состояния текущего вывода на печать, выполняемого в фоновом режиме

Частичная или полная отмена печати, выполняемой в фоновом режиме

Просмотр подробных сведений о выполненных процедурах печати


Печать чертежа (Процедура)

Основные сведения о процессе печати
Основные сведения о процессе печати
Основные сведения о процессе печати
Печать и публикация чертежей > Вывод чертежей на печать > Основные сведения о процессе печати >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Печать чертежа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя печатающего устройства.
  3. В группе "Формат" выберите из списка формат бумаги для печати.
  4. (Не обязательно) Задайте число печатаемых экземпляров в поле "Число экземпляров".
  5. В группе "Печатаемая область" укажите фрагмент чертежа, выводимый на печать.
  6. В группе "Масштаб печати" из раскрывающегося списка "Масштаб" выберите необходимый масштаб.
  7. Для отображения других параметров нажмите кнопку "Дополнительные параметры".

  8. (Не обязательно) В группе "Таблица стилей печати" выберите таблицу стилей печати из списка.
  9. (Не обязательно) Настройте параметры в группах "ВЭкраны с раскрашиванием" и "Опции печати".
    ПримечаниеШтемпель в чертеже не сохраняется и используется только во время распечатки чертежа.
  10. В группе "Ориентация чертежа" задайте ориентацию.
  11. Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ
Контекстное меню:Нажмите правую кнопку мыши на ярлыке вкладки "Модель" или разметки листа и выберите "Печать".

Если печать выполняется не из диалогового окна, а из командной строки, введите "-ПЕЧАТЬ".


Включение/отключение фоновой печати (Процедура)

Основные сведения о процессе печати
Основные сведения о процессе печати
Основные сведения о процессе печати
Печать и публикация чертежей > Вывод чертежей на печать > Основные сведения о процессе печати >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Включение/отключение фоновой печати

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Печать/Публикация" установите или снимите флажок "Поддержка фонового вывода: печать" в группе "Параметры фоновой обработки".
  3. Нажмите "ОК".
    ПримечаниеПри фоновой печати можно сразу же возобновить работу с чертежом. При фоновой печати документа в строке состояния появляется значок печатающего устройства, с помощью которого можно узнать о состоянии процесса печати. Подробности о завершенных заданиях можно просмотреть непосредственно из текущего сеанса программы.
Ввод команды: НАСТРОЙКА


Проверка состояния текущего вывода на печать, выполняемого в фоновом режиме (Процедура)

Основные сведения о процессе печати
Основные сведения о процессе печати
Основные сведения о процессе печати
Печать и публикация чертежей > Вывод чертежей на печать > Основные сведения о процессе печати >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Проверка состояния текущего вывода на печать, выполняемого в фоновом режиме

  • Подведите курсор к значку плоттера в строке состояния. Во всплывающей подсказке отображается состояние процесса печати.


Частичная или полная отмена печати, выполняемой в фоновом режиме (Процедура)

Основные сведения о процессе печати
Основные сведения о процессе печати
Основные сведения о процессе печати
Печать и публикация чертежей > Вывод чертежей на печать > Основные сведения о процессе печати >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Частичная или полная отмена печати, выполняемой в фоновом режиме

  • Нажмите правую кнопку мыши на значке печатающего устройства. Выберите "Отмена задания для листа" <имя листа> или "Прервать все задание".


Просмотр подробных сведений о выполненных процедурах печати (Процедура)

Основные сведения о процессе печати
Основные сведения о процессе печати
Использование набора параметров листа для задания режимов печати
Печать и публикация чертежей > Вывод чертежей на печать > Основные сведения о процессе печати >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Просмотр подробных сведений о выполненных процедурах печати

  1. Выполните одно из следующих действий:
    • Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Подробности о виде". В командной строке введите "подробностипп".
    • Нажмите кнопку мыши на значке печатающего устройства в строке состояния.
  2. В диалоговом окне "Подробности о печати/публикации" выводятся подробные сведения о процессе печати.
Ввод команды: ПОДРОБНОСТИПП
Контекстное меню:Нажмите правую кнопку мыши на значке плоттера. Выберите "Подробности о печати/публикации".


Основные сведения о процессе печати (Краткий справочник)

Коротко о процессе печати
Основные сведения о процессе печати
Использование набора параметров листа для задания режимов печати
Печать и публикация чертежей > Вывод чертежей на печать > Основные сведения о процессе печати >
Основные сведения о процессе печати
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

МАСТЕРПЕЧ

Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ШТЕМПЕЛЬ

Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

ПОДРОБНОСТИПП

Отображение информации о выполненных заданиях печати и публикации

Системные переменные

BACKGROUNDPLOT

Управление включением/отключением режима фонового вывода для операций печати и публикации

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование набора параметров листа для задания режимов печати (Понятие)

Основные сведения о процессе печати
Вывод чертежей на печать
Выбор принтера или плоттера
Печать и публикация чертежей > Вывод чертежей на печать >
Использование набора параметров листа для задания режимов печати
Понятие Процедура Краткий справочник

Существует возможность настроить процесс печати на основании установок из набора параметров листа. При выборе какого-либо из именованных наборов параметров листа в диалоговом окне "Печать" поля окна заполняются параметрами из этого набора. С этими настройками можно либо сразу производить печать, либо изменить некоторые параметры перед отправкой чертежа на печать.

Любые настройки, установленные в диалоговом окне "Печать", могут быть сохранены как новый именованный набор параметров, если нажать кнопку "Добавить" рядом со списком имеющихся наборов.

Настройки параметров, заданные любым способом (как вручную, так с помощью набора параметров), могут быть применены и для последующей печати.


Использование набора параметров листа для задания режимов печати (Процедура)

Основные сведения о процессе печати
Использование набора параметров листа для задания режимов печати
Использование набора параметров листа для задания режимов печати
Печать и публикация чертежей > Вывод чертежей на печать > Использование набора параметров листа для задания режимов печати >
Использование набора параметров листа для задания режимов печати
Понятие Процедура Краткий справочник

Печать чертежа с настройками, заданными в наборе параметров листа

Сохранение настроек печати в новом именованном наборе параметров

Сохранение параметров печати вместе с листом


Печать чертежа с настройками, заданными в наборе параметров листа (Процедура)

Использование набора параметров листа для задания режимов печати
Использование набора параметров листа для задания режимов печати
Использование набора параметров листа для задания режимов печати
Печать и публикация чертежей > Вывод чертежей на печать > Использование набора параметров листа для задания режимов печати >
Использование набора параметров листа для задания режимов печати
Понятие Процедура Краткий справочник

Печать чертежа с настройками, заданными в наборе параметров листа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в списке "Набор параметров листа" выберите набор параметров.
  3. (Не обязательно) Измените отдельные настройки в диалоговом окне "Печать".
  4. Сохраните настройки, нажав кнопку "Применить к листу".
  5. Нажмите "OK".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Сохранение настроек печати в новом именованном наборе параметров (Процедура)

Использование набора параметров листа для задания режимов печати
Использование набора параметров листа для задания режимов печати
Использование набора параметров листа для задания режимов печати
Печать и публикация чертежей > Вывод чертежей на печать > Использование набора параметров листа для задания режимов печати >
Использование набора параметров листа для задания режимов печати
Понятие Процедура Краткий справочник

Сохранение настроек печати в новом именованном наборе параметров

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" измените параметры.
  3. Рядом со списком наборов параметров листов нажмите кнопку "Добавить".
  4. В диалоговом окне "Параметры листа" введите имя нового набора параметров листа. Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Сохранение параметров печати вместе с листом (Процедура)

Использование набора параметров листа для задания режимов печати
Использование набора параметров листа для задания режимов печати
Выбор принтера или плоттера
Печать и публикация чертежей > Вывод чертежей на печать > Использование набора параметров листа для задания режимов печати >
Использование набора параметров листа для задания режимов печати
Понятие Процедура Краткий справочник

Сохранение параметров печати вместе с листом

  1. Выберите вкладку компоновки.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  3. В диалоговом окне "Печать" выберите имеющийся набор параметров листа или настройте параметры вручную.
  4. Нажмите "Применить к разметке листа".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Использование набора параметров листа для задания режимов печати (Краткий справочник)

Основные сведения о процессе печати
Использование набора параметров листа для задания режимов печати
Выбор принтера или плоттера
Печать и публикация чертежей > Вывод чертежей на печать > Использование набора параметров листа для задания режимов печати >
Использование набора параметров листа для задания режимов печати
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор принтера или плоттера (Понятие)

Использование набора параметров листа для задания режимов печати
Вывод чертежей на печать
Задание области печати
Печать и публикация чертежей > Вывод чертежей на печать >
Выбор принтера или плоттера
Понятие Процедура Краткий справочник

Перед печатью чертежа необходимо выбрать принтер или плоттер. Выбранное устройство определяет, какая часть чертежа входит в печатаемую область.

После выбора устройства печати на нем можно напечатать чертеж, используя настройки печати по умолчанию.


Выбор принтера или плоттера (Процедура)

Использование набора параметров листа для задания режимов печати
Выбор принтера или плоттера
Задание области печати
Печать и публикация чертежей > Вывод чертежей на печать > Выбор принтера или плоттера >
Выбор принтера или плоттера
Понятие Процедура Краткий справочник

Выбор принтера или плоттера

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя плоттера.

    Если текущий формат листа не поддерживается выбранным устройством печати, выдается сообщение о том, что будет использован формат листа по умолчанию. Нажмите "ОК" в этом окне сообщения.

  3. После выбора плоттера задайте формат листа или сразу нажмите "OK".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Выбор принтера или плоттера (Краткий справочник)

Использование набора параметров листа для задания режимов печати
Выбор принтера или плоттера
Задание области печати
Печать и публикация чертежей > Вывод чертежей на печать > Выбор принтера или плоттера >
Выбор принтера или плоттера
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание области печати (Понятие)

Выбор принтера или плоттера
Вывод чертежей на печать
Задание формата бумаги
Печать и публикация чертежей > Вывод чертежей на печать >
Задание области печати
Понятие Процедура Краткий справочник

Для печати чертежа необходимо задать печатаемую область. В диалоговом окне "Печать" можно выбрать любой из следующих вариантов:

  • Разметка листа или Лимиты. Печатаются все объекты в пределах области печати. Началом чертежа служит точка листа с координатами 0,0. При печати со вкладки "Модель" печатается вся область рисования, определенная границами сетки. Если вид на текущем видовом экране отличен от вида в плане, опция работает аналогично опции "Границы".
  • Границы. Печать той части чертежа, которая в данный момент содержит объекты. Печатаются все объекты текущего пространства. Чертеж может быть регенерирован для пересчета границ перед печатью.
  • Экран. Печатается текущий видовой экран (для вкладки "Модель") или текущий вид пространства листа на вкладке разметки листа.
  • Вид. Вывод вида, предварительно описанного и сохраненного командой ВИД. Имя вида выбирается из списка. Если в чертеже нет именованных видов, опция недоступна.
  • Рамка. Печатается выделенный фрагмент чертежа. Нажав кнопку "Рамка", можно либо указать два противоположных угла, определяющих область печати, либо ввести их координаты.


Выбор печатаемой области (Процедура)

Выбор принтера или плоттера
Задание области печати
Задание формата бумаги
Печать и публикация чертежей > Вывод чертежей на печать > Задание области печати >
Задание области печати
Понятие Процедура Краткий справочник

Выбор печатаемой области

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать", в группе "Печатаемая область", укажите, какой фрагмент чертежа должен выводиться на печать.
  3. Внесите необходимые изменения в параметры. Нажмите "ОК" для печати чертежа.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание области печати (Краткий справочник)

Выбор принтера или плоттера
Задание области печати
Задание формата бумаги
Печать и публикация чертежей > Вывод чертежей на печать > Задание области печати >
Задание области печати
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание формата бумаги (Понятие)

Задание области печати
Вывод чертежей на печать
Расположение чертежа на бумаге
Печать и публикация чертежей > Вывод чертежей на печать >
Задание формата бумаги
Понятие Процедура Краткий справочник

Формат листа при выводе чертежа на печать задается в диалоговом окне "Печать".

При печати по разметке листа используются параметры, установленные в диалоговом окне "Параметры листа". Если печать производится со вкладки "Модель", формат должен указать пользователь. Формат листа бумаги при выводе чертежа на печать задается в диалоговом окне "Печать". Набор доступных форматов зависит от принтера или плоттера, выбранного в этом же диалоговом окне или в окне "Параметры листа". Список доступных плоттеров содержит все плоттеры, имеющие текущие настройки для использования с ОС Windows, и плоттеры, для которых пользователем были установлены несистемные драйверы.

Для вновь создаваемых разметок листов можно установить принятый по умолчанию формат бумаги с помощью PC3-файла, назначенного выбранному устройству печати. При выводе на системный принтер Windows данным методом можно пользоваться для указания другого формата страницы по умолчанию в Windows и в этой программе.

ПримечаниеЕсли системная переменная PAPERUPDATE равна 0, выполняется проверка, поддерживает ли печатающее устройство заданный формат листа бумаги, и выводится предупреждение в случае несоответствия. Если переменная равна 1, при печати автоматически используется формат бумаги по умолчанию.

Нестандартный формат бумаги

Если необходимо задать формат бумаги, отсутствующий в списке в диалоговых окнах "Печать" или "Параметры листа", можно с помощью Редактора параметров плоттера добавить пользовательский формат листа для несистемного плоттера. Как правило, для системных принтеров Windows добавление нестандартных форматов невозможно, и наборы допустимых форматов и печатаемых областей определяются производителями. Однако существует возможность изменения печатаемых областей для форматов бумаги, назначенных системному принтеру Windows.


Задание формата бумаги (Процедура)

Задание области печати
Задание формата бумаги
Задание формата бумаги
Печать и публикация чертежей > Вывод чертежей на печать > Задание формата бумаги >
Задание формата бумаги
Понятие Процедура Краткий справочник

Выбор формата для текущей процедуры печати

Задание формата, принятого для листа по умолчанию

Задание формата бумаги, принятого по умолчанию для плоттера

Чтобы создать или редактировать пользовательский формат листа для несистемного принтера


Выбор формата для текущей процедуры печати (Процедура)

Задание формата бумаги
Задание формата бумаги
Задание формата бумаги
Печать и публикация чертежей > Вывод чертежей на печать > Задание формата бумаги >
Задание формата бумаги
Понятие Процедура Краткий справочник

Выбор формата для текущей процедуры печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя плоттера.
  3. В группе "Формат" выберите формат бумаги из раскрывающегося списка.

    Набор доступных форматов зависит от выбранного устройства печати.

Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание формата, принятого для листа по умолчанию (Процедура)

Задание формата бумаги
Задание формата бумаги
Задание формата бумаги
Печать и публикация чертежей > Вывод чертежей на печать > Задание формата бумаги >
Задание формата бумаги
Понятие Процедура Краткий справочник

Задание формата, принятого для листа по умолчанию

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Параметры листа". В командной строке введите "парамлист".
  2. В Диспетчере наборов параметров листов в группе "Параметры листа" должна быть выбрана та разметка листа, для которой назначается формат. Если она не выбрана, выберите ее. Нажмите кнопку "Редактирование".
  3. В диалоговом окне "Параметры листа" в группе "Формат листа" выберите из списка формат бумажного листа. Нажмите "ОК".

    Доступные форматы бумаги в списке зависят от типа плоттера.

  4. Нажмите кнопку "Закрыть" в Диспетчере наборов параметров листов.

    Новые параметры вступают в силу, изменяя вид разметки листа.

Панель:Листы
Ввод команды: ПАРАМЛИСТ


Задание формата бумаги, принятого по умолчанию для плоттера (Процедура)

Задание формата бумаги
Задание формата бумаги
Задание формата бумаги
Печать и публикация чертежей > Вывод чертежей на печать > Задание формата бумаги >
Задание формата бумаги
Понятие Процедура Краткий справочник

Задание формата бумаги, принятого по умолчанию для плоттера

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" выберите из списка имя плоттера.
  3. Нажмите кнопку "Свойства".

    Открывается редактор параметров плоттера.

  4. Установить формат бумаги по умолчанию одним из следующих способов:
    • Для несистемного плоттера в группе "Носитель" выберите "Подача и размеры".
    • Для системного принтера в области структуры выберите "Дополнительные свойства". Затем в группе параметров "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. Укажите необходимый формат бумаги.
  6. Нажмите "OK" для закрытия каждого диалогового окна.
    ПримечаниеНабор доступных форматов бумаги зависит от выбранного устройства печати. Различные производители устройств предлагают свои диалоговые окна, вызываемые из редактора параметров устройства печати, для управления форматом бумаги.
Панель:Листы
Ввод команды: ПАРАМЛИСТ


Чтобы создать или редактировать пользовательский формат листа для несистемного принтера (Процедура)

Задание формата бумаги
Задание формата бумаги
Управление стилем печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Задание формата бумаги >
Задание формата бумаги
Понятие Процедура Краткий справочник

Чтобы создать или редактировать пользовательский формат листа для несистемного принтера

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. В Диспетчере плоттеров дважды нажмите кнопку мыши на ярлыке PC3-файла, в котором нужно изменить конфигурацию.
  3. В Редакторе параметров плоттеров на вкладке "Параметры устройства и документа" в группе "Нестандартные форматы и калибровка" области структуры выберите "Нестандартные форматы листа бумаги".
  4. Установите формат бумаги одним из следующих способов:
    • Для добавления нестандартного формата листа бумаги нажмите "Добавить" и следуйте указаниям Мастера пользовательских форматов бумаги. С помощью Мастера определяются формат бумаги, печатаемая область и имя для нового формата.
    • Для редактирования существующего формата бумаги в группе "Нестандартные форматы листа" укажите формат листа бумаги и нажмите "Правка". Появляется окно Мастера пользовательских форматов бумаги. Введите необходимые изменения в параметры формата листа бумаги.
  5. Нажмите "ОК".

    После выбора соответствующего PC3-файла новый или измененный формат бумаги становится доступным в диалоговых окнах "Печать" и "Параметры листа".

    ПримечаниеПри создании пользовательского формата листа для несистемного драйвера файл параметров модели плоттера (PMP) добавляется в файл параметров плоттера (PC3). PMP-файл содержит пользовательские параметры калибровки плоттера и формата бумаги. По умолчанию PMP-файлы размещаются в папке Drv.
Ввод команды: ДИСППЕЧ


Задание формата бумаги (Краткий справочник)

Задание области печати
Задание формата бумаги
Задание печатаемой области
Печать и публикация чертежей > Вывод чертежей на печать > Задание формата бумаги >
Задание формата бумаги
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

PAPERUPDATE

Управление выводом диалогового окна предупреждения при попытке вывести на печать лист, формат которого не совпадает с форматом, заданным по умолчанию в файле параметров плоттера

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Расположение чертежа на бумаге

Задание формата бумаги
Вывод чертежей на печать
Задание печатаемой области
Печать и публикация чертежей > Вывод чертежей на печать >
Расположение чертежа на бумаге

Для задания расположения чертежа на бумаге существует несколько методов. Можно задать область печати, смещение чертежа на бумаге и ориентацию чертежа.

Темы в этом разделе

  • Задание печатаемой области

    Область чертежа, предназначенная для вывода на печать, выделяется пунктирной рамкой на вкладке разметки листа. Печатаемая область определяется установленным плоттером и выбранным форматом бумаги.

  • Задание расположения при печати

    Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на разметке листа пунктирной линией. Расположение при печати может изменяться в зависимости от области печати и размера бумаги.

  • Ориентация листа и ориентация изображения


Задание печатаемой области (Понятие)

Расположение чертежа на бумаге
Расположение чертежа на бумаге
Задание расположения при печати
Печать и публикация чертежей > Вывод чертежей на печать > Расположение чертежа на бумаге >
Задание печатаемой области
Понятие Краткий справочник

Область чертежа, предназначенная для вывода на печать, выделяется пунктирной рамкой на вкладке разметки листа. Печатаемая область определяется установленным плоттером и выбранным форматом бумаги.

ПредупреждениеЕсли плоттер работает в одном из режимов экономии бумаги (вложение или печать области, содержащей чернила), возможно несоблюдение плоттером установленной печатаемой области и параметров смещения чертежа.

Если результат печати не соответствует установленной печатаемой области для выбранного формата бумага, то настройку печатаемой области можно выполнить в редакторе параметров плоттера на вкладке "Параметры устройства и документа" в разделе структуры "Изменение стандартных форматов листа".

ПримечаниеЭти опции не служат для задания отступов при выводе на печать. Для указания расположения чертежа на листе бумаги следует пользоваться опциями группы "Смещение от начала" диалогового окна "Печать".


Задание печатаемой области (Краткий справочник)

Задание формата бумаги
Задание печатаемой области
Задание расположения при печати
Печать и публикация чертежей > Вывод чертежей на печать > Расположение чертежа на бумаге > Задание печатаемой области >
Задание печатаемой области
Понятие Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание расположения при печати (Понятие)

Задание печатаемой области
Расположение чертежа на бумаге
Ориентация листа и ориентация изображения
Печать и публикация чертежей > Вывод чертежей на печать > Расположение чертежа на бумаге >
Задание расположения при печати
Понятие Краткий справочник

Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на разметке листа пунктирной линией. Расположение при печати может изменяться в зависимости от области печати и размера бумаги.

Печатаемая область листа чертежа определяется выбранным устройством вывода на печать и обозначается на разметке листа пунктирной линией. При выборе другого печатающего устройства область печати может измениться.

Настройка параметра "Смещение от начала" диалогового окна "Печать" определяет смещение области печати относительно левого нижнего угла печатаемой области или границы бумаги, в зависимости от положения переключателя "Отсчет смещения чертежа" на вкладке "Печать/Публикация" диалогового окна "Настройка". Выбранный вариант смещения приводится в круглых скобках после названия группы опций "Смещение от начала" в диалоговом окне "Печать".

Чертеж может быть смещен на положительную или отрицательную величину по осям X и Y. Однако это может привести к усечению чертежа при печати. Если выводимый фрагмент (границы, экран, вид или рамка) не укладывается полностью в печатаемую область, существует возможность центрировать изображение, выбрав опцию "Центрировать".


Задание расположения при печати (Краткий справочник)

Задание печатаемой области
Задание расположения при печати
Ориентация листа и ориентация изображения
Печать и публикация чертежей > Вывод чертежей на печать > Расположение чертежа на бумаге > Задание расположения при печати >
Задание расположения при печати
Понятие Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Ориентация листа и ориентация изображения (Понятие)

Задание расположения при печати
Расположение чертежа на бумаге
Управление стилем печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Расположение чертежа на бумаге >
Ориентация листа и ориентация изображения
Понятие Краткий справочник

Имеется возможность выбора из двух типов ориентации чертежа: альбомная (длинный край располагается горизонтально) или книжная (длинный край располагается вертикально). Тип ориентации выбирается с учетом заданного формата бумаги. Кроме того, при выводе на печать чертеж можно переворачивать.


Ориентация листа и ориентация изображения (Краткий справочник)

Задание расположения при печати
Ориентация листа и ориентация изображения
Задание масштаба печати
Печать и публикация чертежей > Вывод чертежей на печать > Расположение чертежа на бумаге > Ориентация листа и ориентация изображения >
Ориентация листа и ориентация изображения
Понятие Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

PLOTROTMODE

Управление ориентацией чертежа при выводе на печать

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление стилем печати объектов

Ориентация листа и ориентация изображения
Вывод чертежей на печать
Задание масштаба печати
Печать и публикация чертежей > Вывод чертежей на печать >
Управление стилем печати объектов
Понятие Процедура

Имеется возможность управления печатью объектов с помощью параметров масштаба печати, стилей печати, таблиц стилей печати и путем изменения свойств слоев объектов.

Темы в этом разделе

  • Задание масштаба печати

    Для вывода чертежа на печать можно выбрать из списка один из предлагаемых масштабов печати в реальных координатах или указать свой масштаб. Кроме этого, можно установить масштаб "Вписать"; в этом случае масштаб будет подобран таким образом, что выводимый на печать чертеж окажется вписанным в выбранный формат листа.

  • Настройка печати видовых экранов с раскрашиванием

    Существует возможность выбора опций для печати раскрашенных и тонированных видовых экранов. Видовой экран можно вывести на печать в обычном состоянии, в каркасном представлении, без невидимых линий или тонированным.

  • Задание параметров печати объектов

    Диалоговые окна "Печать" и "Параметры листа" позволяют настраивать параметры, влияющие на печать объектов.

  • Использование стилей печати

    Имеется возможность управления печатью объектов с помощью стилей печати.

  • Таблицы цветозависимых стилей печати

    Использование цветозависимых стилей печати обеспечивает вывод объектов с учетом заданных для этих объектов цветов.

  • Таблицы именованных стилей печати

    В таблице именованных стилей печати можно создавать, удалять и редактировать стили. В такой таблице может быть создано любое число стилей.

  • Редактирование стилей печати

    В стили печати можно вносить изменения с помощью редактора таблиц стилей печати. Все модификации стиля отражаются на объектах, использующих этот стиль.


Управление стилем печати объектов (Процедура)

Задание формата бумаги
Управление стилем печати объектов
Задание масштаба печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Управление стилем печати объектов
Понятие Процедура

Печать с использованием масштаба в реальных координатах

Печать с использованием нестандартного масштаба

Вписывание чертежа в лист бумаги

Настройка параметров печати раскрашенных объектов со вкладки "Модель"

Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов

Подавление скрытых линий при печати со вкладки "Модель"

Подавление скрытых линий при печати вкладки разметки листа

Печать с учетом весов линий

Отключение использования стилей печати

Изменение последовательности печати объектов

Скрытие объектов пространства листа при печати со вкладки разметки листа


Задание масштаба печати (Понятие)

Управление стилем печати объектов
Управление стилем печати объектов
Настройка печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Задание масштаба печати
Понятие Процедура Краткий справочник

Для вывода чертежа на печать можно выбрать из списка один из предлагаемых масштабов печати в реальных координатах или указать свой масштаб. Кроме этого, можно установить масштаб "Вписать"; в этом случае масштаб будет подобран таким образом, что выводимый на печать чертеж окажется вписанным в выбранный формат листа.

При рисовании объекты обычно изображаются в натуральную величину. Пользователь сам решает, с какой единицей реального мира (дюйм, миллиметр, метр и т.д.) сопоставить единицу чертежа. Например, если размеры реальных объектов удобно выражать в миллиметрах, то одна единица чертежа соответствует одному миллиметру. В дальнейшем при печати чертежа можно либо задать точный масштаб, либо воспользоваться режимом вписывания чертежа в заданный формат листа бумаги.

В большинстве случаев печать чертежей выполняется с точным масштабом. Метод задания масштаба печати зависит от выбора между вкладками разметки и модели при печати:

  • При выборе вкладки "Модель" задание масштаба печати выполняется в диалоговом окне "Печать". Этот масштаб определяет отношение единицы длины на напечатанном чертеже к единице реального мира, использованной при построении чертежа.
  • При выборе одной из вкладок разметки листа используются два масштаба. Первый из них задается для всего листа чертежа установленного формата и обычно определяется отношением 1:1. Второй масштаб применяется к самой модели, изображаемой на видовых экранах листа. Он определяет для каждого видового экрана как отношение размеров формата листа к размерам модели на видовом экране.
ПримечаниеМожно изменить список масштабов, отображающихся во всех списках видов и масштабов печати, с помощью команды СПИСМАСШТРЕД.

Задание нестандартных масштабов

Во время печати можно выбирать единицы измерения (дюймы или миллиметры). Так, например, выбрав опцию "мм" (миллиметры) и указав в числовом поле значение 1, а в поле "Единицы чертежа" значение 10, можно тем самым установить масштаб, при котором каждые 10 миллиметров чертежа при выводе на печать будут преобразовываться в 1 миллиметр.

На рисунке показан результат печати лампы в трех различных масштабах.

Вписывание чертежа в лист бумаги

Для черновых вариантов чертежей точность задания масштаба не столь важна. Здесь лучше воспользоваться опцией "Вписать" для печати чертежа в наибольшем из возможных для данного формата масштабе. Ширина или высота чертежа соответствует ширине или высоте листа.

Опция масштабирования "Вписать" используется автоматически при печати вида в перспективе из пространства модели, даже если был выбран другой масштаб.

При выборе параметра "Вписать" происходит также изменение размеров текстовых объектов для отражения отношения форматов печатаемых объектов к формату объектов чертежа. Этот масштаб обновляется при каждом изменении формата бумаги, устройства печати, начала чертежа, ориентации или размеров печатаемой области в диалоговом окне "Печать".

ПримечаниеОпция не доступна, если для области печати задан параметр "Разметка листа".


Задание масштаба печати (Процедура)

Управление стилем печати объектов
На уровень вверх ..
Задание масштаба печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Печать с использованием масштаба в реальных координатах

Печать с использованием нестандартного масштаба

Вписывание чертежа в лист бумаги


Печать с использованием масштаба в реальных координатах (Процедура)

Задание масштаба печати
На уровень вверх ..
Задание масштаба печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Печать с использованием масштаба в реальных координатах

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Масштаб печати" выберите масштаб из раскрывающегося списка.
  3. Нажмите "ОК" для вывода чертежа на печать.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать с использованием нестандартного масштаба (Процедура)

Задание масштаба печати
На уровень вверх ..
Задание масштаба печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Печать с использованием нестандартного масштаба

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Масштаб печати" введите пользовательский масштаб. Масштаб задается двумя значениями, определяющими отношение единиц измерения. Первое значение задает число единиц измерения на чертеже, а второе - соответствующее число единиц чертежа. Тип единиц измерения определяется размером листа, но его можно изменить, выбрав из списка.

    При вводе значений пользовательского масштаба автоматически происходит выбор опции "Пользовательский" из раскрывающего списка "Масштаб"; при этом параметры пользовательского масштаба могут совпадать с установками уже выбранного из списка масштаба. Пользовательский масштаб определяется отношением между единицами печати и чертежа; например, соотношения 1:12 и 2:24 приводят к выводу на печать в одном и том же масштабе.

  3. Нажмите "ОК" для вывода чертежа на печать.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Вписывание чертежа в лист бумаги (Процедура)

Задание масштаба печати
На уровень вверх ..
Настройка печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Вписывание чертежа в лист бумаги

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Масштаб печати" выберите опцию "Вписать".

    Полученный масштаб будет вычислен автоматически. В соответствующем поле отображается отношение размеров печатаемых объектов к размерам объектов чертежа.

  3. Нажмите "ОК" для вывода чертежа на печать.
ПримечаниеОпция не доступна, если для области печати задан параметр "Разметка листа".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание масштаба печати (Краткий справочник)

Ориентация листа и ориентация изображения
Задание масштаба печати
Коротко о процессе печати тонированных видовых экранов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание масштаба печати >
Задание масштаба печати
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

СПИСМАСШТРЕД

Управление списком доступных значений масштаба для видовых экранов, листа и печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка печати видовых экранов с раскрашиванием

Задание масштаба печати
Управление стилем печати объектов
Коротко о процессе печати тонированных видовых экранов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Настройка печати видовых экранов с раскрашиванием
Понятие Процедура

Существует возможность выбора опций для печати раскрашенных и тонированных видовых экранов. Видовой экран можно вывести на печать в обычном состоянии, в каркасном представлении, без невидимых линий или тонированным.

Для этого необходимо определить, как должны печататься раскрашенные области, и сохранить настройку опций в чертеже. Разрешение при печати выбирается в зависимости от плоттера и сохраняется для чертежа.

ПримечаниеЕсли аппаратное ускорение отключено, а также в том случае, если оно включено, но поддерживает не все доступные аппаратные эффекты, для печати чертежа с затененными видовыми экранами, к которым применяются не поддерживаемые графической платой аппаратные эффекты, можно воспользоваться программной эмуляцией. Для включения программной эмуляции аппаратных эффектов, не поддерживаемых графической платой. введите "графнастр" и выберите "Ручная настройка". В диалоговом окне "Ручная оптимизация параметров" выберите "Эмулировать при печати неподдерживаемые аппаратные эффекты в программе". Эффекты отсутствуют на видовом экране в реальном времени, но отображаются на печатной копии, а также при просмотре файла, созданного в процессе печати.

Темы в этом разделе

  • Коротко о процессе печати тонированных видовых экранов

    Настройки печати видовых экранов, содержащих раскрашенные объекты, обеспечивают большую гибкость представления трехмерных объектов. Печать чертежа производится на основании выбранного режима обращения с раскрашенными видовыми экранами и установленного разрешения печатающего устройства.

  • Настройка режима печати видовых экранов с раскрашиванием

    При печати чертежей, содержащих раскрашенные 3D тела, возможен контроль качества печати.

  • Настройка уровня разрешения при печати видовых экранов с раскрашиванием

    Этот параметр управляет скоростью и качеством печати раскрашенных видовых экранов.


Настройка печати видовых экранов с раскрашиванием (Процедура)

Задание масштаба печати
На уровень вверх ..
Настройка режима печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием >
Настройка печати видовых экранов с раскрашиванием
Понятие Процедура

Изменение способа печати раскрашенных видовых экранов

Изменение способа печати раскрашенных объектов пространства модели

Настройка уровня разрешения при печати видовых экранов с раскрашиванием


Коротко о процессе печати тонированных видовых экранов (Понятие)

Настройка печати видовых экранов с раскрашиванием
Настройка печати видовых экранов с раскрашиванием
Настройка режима печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием >
Коротко о процессе печати тонированных видовых экранов
Понятие Краткий справочник

Настройки печати видовых экранов, содержащих раскрашенные объекты, обеспечивают большую гибкость представления трехмерных объектов. Печать чертежа производится на основании выбранного режима обращения с раскрашенными видовыми экранами и установленного разрешения печатающего устройства.

С помощью режимов печати с раскрашиванием можно задать печать набора раскрашенных объектов в том виде, как они отображаются, либо в каркасном виде, в режиме с использованием подавления линий, визуальном стиле, или с тонированием. Раскрашенные и тонированные видовые экраны можно предварительно просматривать, печатать, печатать в файл и публиковать.

Презентационные изображения часто формируются путем печати содержимого раскрашенных видовых экранов либо в обычном виде, либо с изменением параметров.

Опции печати раскрашенных видовых экранов применимы ко всем объектам на видовых экранах и в пространстве модели. При использовании средства печати раскрашенных и тонированных видовых экранов таблицы стилей печати в параметрах листов не активизируются. Если используется опция "Тонирование", то двумерные каркасные объекты, такие как линии, дуги и текст, не печатаются.

ПримечаниеРаспечатывать раскрашенные видовые экраны можно только на устройствах с растровой графикой. Большинство современных плоттеров и принтеров поддерживают растровую графику.


Коротко о процессе печати тонированных видовых экранов (Краткий справочник)

Задание масштаба печати
Коротко о процессе печати тонированных видовых экранов
Настройка режима печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием > Коротко о процессе печати тонированных видовых экранов >
Коротко о процессе печати тонированных видовых экранов
Понятие Краткий справочник

Команды

ГРАФНАСТР

Настройка параметров трехмерной графики

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

РЕЖИМРАСКР

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка режима печати видовых экранов с раскрашиванием (Понятие)

Коротко о процессе печати тонированных видовых экранов
Настройка печати видовых экранов с раскрашиванием
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием >
Настройка режима печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

При печати чертежей, содержащих раскрашенные 3D тела, возможен контроль качества печати.

Существует возможность выбора одного из следующих параметров:

  • Обычный. Печатает чертеж в том виде, в каком он отображен на экране, т. е. с сохранением всего имеющегося раскрашивания.
  • Каркас. Отображает линии и кривые для показа контуров объектов.
  • Скрытие линий. Запрещает печать объектов, находящихся за другими объектами.
  • Визуальные стили.Проект печатается так, как он отображается в выбранном визуальном стиле.
  • Тонирование. Выполнение тонирования объектов перед их печатью на основе параметров тонирования, заданных перед запуском печати или на основе выбранного набора параметров тонирования.

Параметры для чертежа могут быть выбраны в пространстве модели или на листе. В пространстве модели параметры печати доступны на палитре свойств и в диалоговом окне "Печать". Для разметки листа (после выбора видового экрана) доступ к параметрам печати возможет через контекстное меню или палитру свойств.

Также существует возможность сохранить настройки в самом чертеже.

ПримечаниеПри использовании параметра "Тонирование" перед печатью необходимо указать настройки тонирования. Если опция "Тонирование" выбрана для очень сложного чертежа, то, возможно, выведенной на печать окажется только рамка видового экрана.


Настройка режима печати видовых экранов с раскрашиванием (Процедура)

Настройка печати видовых экранов с раскрашиванием
На уровень вверх ..
Настройка режима печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием > Настройка режима печати видовых экранов с раскрашиванием >
Настройка режима печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Изменение способа печати раскрашенных видовых экранов

Изменение способа печати раскрашенных объектов пространства модели


Изменение способа печати раскрашенных видовых экранов (Процедура)

Настройка режима печати видовых экранов с раскрашиванием
На уровень вверх ..
Настройка режима печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием > Настройка режима печати видовых экранов с раскрашиванием >
Настройка режима печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Изменение способа печати раскрашенных видовых экранов

  1. Перейдите на вкладку разметки листа.
  2. Дважды нажмите кнопку мыши на контуре видового экрана, который нужно отредактировать.
  3. На палитре свойств в группе "Разное" выберите "Визуализация при печати" и назначьте нужный режим.
Контекстное меню:Выберите видовой экран и нажмите правую кнопку мыши в области построения чертежа. Выберите один из параметров подменю "Способ вывода".


Изменение способа печати раскрашенных объектов пространства модели (Процедура)

Настройка режима печати видовых экранов с раскрашиванием
На уровень вверх ..
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием > Настройка режима печати видовых экранов с раскрашиванием >
Настройка режима печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Изменение способа печати раскрашенных объектов пространства модели

  1. На вкладке "Модель" отмените выбор всех объектов.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  3. В диалоговом окне "Печать" выберите нужный способ вывода в группе "ВЭкраны с раскрашиванием".
Ввод команды: ПЕЧАТЬ


Настройка режима печати видовых экранов с раскрашиванием (Краткий справочник)

Коротко о процессе печати тонированных видовых экранов
Настройка режима печати видовых экранов с раскрашиванием
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием > Настройка режима печати видовых экранов с раскрашиванием >
Настройка режима печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ГРАФНАСТР

Настройка параметров трехмерной графики

РЕЖИМРАСКР

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка уровня разрешения при печати видовых экранов с раскрашиванием (Понятие)

Настройка режима печати видовых экранов с раскрашиванием
Настройка печати видовых экранов с раскрашиванием
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием >
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Этот параметр управляет скоростью и качеством печати раскрашенных видовых экранов.

После выбора устройства печати можно установить уровень качества вывода на печать. Уровень качества определяет количество точек на дюйм (dpi). Количество точек на дюйм, соответствующее уровню качества, зависит от выбранного плоттера.

Максимально возможное количество точек на дюйм также зависит от выбранного плоттера. Если качеству печати присвоено значение "Пользовательское", можно установить значение в диапазоне от 100 т/дюйм до максимально допустимого значения.

Чем выше уровень качества печати, тем больше оперативной памяти компьютера требуется для вывода на печать. Следовательно время, затрачиваемое на печать чертежа, возрастает. Для оптимальной работы большинства устройств печати достаточно назначить уровень качества в диапазоне от 300 до 600 т/дюйм.


Настройка уровня разрешения при печати видовых экранов с раскрашиванием (Процедура)

Настройка режима печати видовых экранов с раскрашиванием
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием > Настройка уровня разрешения при печати видовых экранов с раскрашиванием >
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Настройка уровня разрешения при печати видовых экранов с раскрашиванием

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать", в группе "ВЭкраны с раскрашиванием", выберите в раскрывающемся списке "Качество" соответствующее значение.

    Для явного задания уровня качества печати выберите из списка "Качество" значение "Пользовательское" и введите число в поле "Т/дюйм".

  3. Нажмите "ОК".
Ввод команды: ПЕЧАТЬ


Настройка уровня разрешения при печати видовых экранов с раскрашиванием (Краткий справочник)

Настройка режима печати видовых экранов с раскрашиванием
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Настройка печати видовых экранов с раскрашиванием > Настройка уровня разрешения при печати видовых экранов с раскрашиванием >
Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание параметров печати объектов (Понятие)

Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Управление стилем печати объектов
Использование стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Диалоговые окна "Печать" и "Параметры листа" позволяют настраивать параметры, влияющие на печать объектов.

  • ВЭкраны с раскрашиванием. Задает параметры печати раскрашенных видовых экранов: "Обычный", "Каркас" или "Скрытие линий". Опция воздействует на линии только в момент печати и просмотра перед печатью.
  • Учитывать веса линий. Задает печать с учетом весов линий, назначенных объектам и слоям.
  • Учитывать стили печати. Задает печать чертежа с применением стилей печати. При выборе этой опции печать выполняется с учетом весов линий. Если эта опция отключена, то печать выполняется с учетом свойств объектов без переопределения этих свойств с помощью стилей печати.
    ПримечаниеСтили печати недоступны для объектов, к которым применён модификатор дрожания ребра (ВИЗСТИЛИ).
  • Печатать пространство листа последним. Задает последовательность печати таким образом, чтобы в первую очередь выполнялась печать объектов пространства модели и только затем - пространства листа.
  • Скрывать объекты листа Определяет, применима ли операция скрытия к объектам видового экрана пространства листа. Доступно только для вкладки разметки листа. Опция обеспечивает изображение только для просмотра перед печатью, но не в разметке листа.
  • Печатать штемпель. Распечатывает штемпель в определенном углу каждого чертежа и записывает соответствующую информацию в файл журнала. Настройки штемпеля задаются в диалоговом окне "Штемпель чертежа", предназначенном для задания информации, включаемой в штемпель, например имени чертежа, даты/времени, масштаба и т.п. Для вызова этого окна следует в диалоговом окне "Печать" выбрать опцию "Печатать штемпель", а затем нажать кнопку "Параметры штемпеля".
  • Сохранить изменения в разметке листа. После нажатия кнопки "OK" сохраняет в разметке листа все изменения параметров, произведенные в диалоговом окне "Печать".


Задание параметров печати объектов (Процедура)

Настройка уровня разрешения при печати видовых экранов с раскрашиванием
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Настройка параметров печати раскрашенных объектов со вкладки "Модель"

Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов

Подавление скрытых линий при печати со вкладки "Модель"

Подавление скрытых линий при печати вкладки разметки листа

Печать с учетом весов линий

Отключение использования стилей печати

Изменение последовательности печати объектов

Скрытие объектов пространства листа при печати со вкладки разметки листа


Настройка параметров печати раскрашенных объектов со вкладки "Модель" (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Настройка параметров печати раскрашенных объектов со вкладки "Модель"

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "ВЭкраны с раскрашиванием" в раскрывающемся списке "Способ вывода" выберите соответствующий параметр.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Настройка параметров печати видовых экранов с раскрашиванием со вкладок разметок листов

  1. Выберите видовой экран разметки листа.
  2. Дважды нажав кнопку мыши на границе видового экрана, откройте палитру свойств.
  3. В палитре свойств выберите "Визуализация при печати".
  4. В раскрывающемся списке "Визуализация при печати" выберите соответствующий параметр.
Панель:Стандартный
Ввод команды: ОКОНСВ
Контекстное меню:Выберите видовой экран, нажмите правую кнопку мыши в области чертежа и выберите "Визуализация при печати".


Подавление скрытых линий при печати со вкладки "Модель" (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Подавление скрытых линий при печати со вкладки "Модель"

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "ВЭкраны с раскрашиванием" в раскрывающемся списке "Способ вывода" выберите "Скрытие линий".
  3. Нажмите "ОК" для вывода чертежа на печать.

Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Подавление скрытых линий при печати вкладки разметки листа (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Подавление скрытых линий при печати вкладки разметки листа

  1. Выберите видовой экран разметки листа.
  2. Дважды нажав кнопку мыши на границе видового экрана, откройте палитру свойств.
  3. В палитре свойств выберите "Визуализация при печати".
  4. В раскрывающемся списке "Визуализация при печати" выберите "Скрытие линий".
  5. Нажмите "ОК" для вывода чертежа на печать.

Панель:Стандартный
Ввод команды: СВОЙСТВА
Контекстное меню:Выберите видовой экран и нажмите правую кнопку мыши в области построения чертежа. Выберите "Визуализация при печати".


Печать с учетом весов линий (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Печать с учетом весов линий

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" установить флажок "Учитывать веса линий".

    Эта опция доступна для изменения только в том случае, если сброшен флажок "Учитывать стили печати".

  3. Нажмите "ОК" для вывода чертежа на печать.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Отключение использования стилей печати (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Отключение использования стилей печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" снимите флажок "Учитывать стили печати".
  3. Нажмите "ОК" для вывода чертежа на печать.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Изменение последовательности печати объектов (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Задание параметров печати объектов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Изменение последовательности печати объектов

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" установите флажок "Объекты листа последними". Снимите флажок для вывода на печать объектов листа первыми.
  3. Нажмите "ОК" для вывода чертежа на печать.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Скрытие объектов пространства листа при печати со вкладки разметки листа (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Использование стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Скрытие объектов пространства листа при печати со вкладки разметки листа

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Опции печати" установить флажок "Скрывать объекты листа".
  3. Нажмите "ОК" для вывода чертежа на печать.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание параметров печати объектов (Краткий справочник)

Настройка уровня разрешения при печати видовых экранов с раскрашиванием
Задание параметров печати объектов
Коротко о стилях печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Задание параметров печати объектов >
Задание параметров печати объектов
Понятие Процедура Краткий справочник

Команды

ВЕСЛИН

Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ШТЕМПЕЛЬ

Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование стилей печати

Задание параметров печати объектов
Управление стилем печати объектов
Коротко о стилях печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Использование стилей печати
Понятие Процедура

Имеется возможность управления печатью объектов с помощью стилей печати.

Темы в этом разделе

  • Коротко о стилях печати

    Стиль печати задает свойства объекта при выводе на печать.

  • Выбор типа таблиц стилей печати

    Таблица стилей печати содержит набор стилей печати, назначенных листу или модели. Существует два типа таблиц стилей печати: таблицы цветозависимых стилей печати и таблицы именованных стилей печати.

  • Смена типов таблиц стилей печати

    При работе с чертежом имеется возможность выбора, использовать таблицу цветозависимых стилей печати или именованных стилей печати.

  • Подключение таблиц стилей печати к листам
  • Управление таблицами стилей печати

    С помощью Диспетчера стилей печати можно добавлять, удалять, переименовывать, копировать и редактировать таблицы стилей печати.


Использование стилей печати (Процедура)

Задание параметров печати объектов
На уровень вверх ..
Выбор типа таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати >
Использование стилей печати
Понятие Процедура

Задание типа таблицы стилей печати для новых чертежей

Переход к использованию именованных стилей печати

Переход к использованию цветозависимых стилей печати

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати

Подключения таблицы стилей печати к разметке листа

Просмотр разметки листа с учетом таблицы стилей печати

Создание таблицы стилей печати

Переименование таблицы стилей печати

Изменение описания таблицы стилей печати

Редактирование стилей в таблице стилей печати


Коротко о стилях печати (Понятие)

Использование стилей печати
Использование стилей печати
Выбор типа таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати >
Коротко о стилях печати
Понятие Краткий справочник

Стиль печати задает свойства объекта при выводе на печать.

Стиль печати наряду с типом линии или цветом является свойством объекта. Стили печати могут назначаться отдельным объектам и слоям. Стиль печати управляет следующими свойствами объекта при выводе его на печать:

  • цвет
  • размывание
  • оттенки серого
  • номер пера
  • виртуальное перо
  • интенсивность
  • тип линий
  • вес линий
  • стиль окончаний линий
  • стиль соединений линий
  • стиль заливки

Использование стилей печати позволяет при необходимости переопределять установленные свойства объектов, что придает работе с объектами большую гибкость.

Стили печати могут быть сохранены группами в виде таблиц. Таблицы стилей печати бывают двух видов: цветозависимые (CTB) или именованные (STB). Цветозависимые стили печати базируются на цветах объектов. Именованные стили печати могут назначаться объектам независимо от их цветов.

ПримечаниеСтили печати недоступны для объектов, к которым применён модификатор дрожания ребра (ВИЗСТИЛИ).


Коротко о стилях печати (Краткий справочник)

Задание параметров печати объектов
Коротко о стилях печати
Выбор типа таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Коротко о стилях печати >
Коротко о стилях печати
Понятие Краткий справочник

Команды

ПРЕОБРТСП

Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)

ПРЕОБРСПЕЧ

Настройка чертежа на использование именованных или цветозависимых стилей печати

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

CPLOTSTYLE

Управление текущим стилем печати для новых объектов

DEFLPLSTYLE

Определение стиля печати по умолчанию для всех слоев в чертеже при открытии чертежа, созданного в версиях, предшествующих AutoCAD 2000, или для слоя 0 при создании нового чертежа без использования шаблонов

DEFPLSTYLE

Определение стиля печати по умолчанию для новых объектов в чертеже при открытии чертежа, созданного в версиях, предшествующих AutoCAD 2000, или при создании нового чертежа без использования шаблонов

PSTYLEMODE

Указание режима стиля печати текущего чертежа - цветозависимый или именованный

PSTYLEPOLICY

Управление режимом стилей печати (цветозависимый или именованный), используемым при открытии чертежа, созданного в версиях, предшествующих AutoCAD 2000, или при создании нового чертежа без использования шаблонов

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выбор типа таблиц стилей печати (Понятие)

Коротко о стилях печати
Использование стилей печати
Смена типов таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати >
Выбор типа таблиц стилей печати
Понятие Процедура Краткий справочник

Таблица стилей печати содержит набор стилей печати, назначенных листу или модели. Существует два типа таблиц стилей печати: таблицы цветозависимых стилей печати и таблицы именованных стилей печати.

Таблицы цветозависимых стилей печати (CTB) позволяют использовать цвет для определения таких характеристик, как вес линий. Каждый объект, вычерченный, например, красным цветом, будет напечатан с одними и теми же параметрами. Стили печати в такой таблице можно редактировать, но их добавление в таблицу и удаление из таблицы цветозависимых стилей печати невозможны. В таблице цветозависимых стилей печати имеется 256 стилей, по одному на каждый цвет.

Таблицы именованных стилей печати (STB) содержат пользовательские стили печати. При использовании такой таблицы печать объектов, имеющих один и тот же цвет, может выполняться с различными характеристиками, на основании назначенных каждому объекту стилей печати. Таблица именованных стилей печати может содержать любое количество стилей. Именованные стили печати могут назначаться объектам или слоям, как любые другие свойства.


Задание типа таблицы стилей печати для новых чертежей (Процедура)

Использование стилей печати
На уровень вверх ..
Смена типов таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Выбор типа таблиц стилей печати >
Выбор типа таблиц стилей печати
Понятие Процедура Краткий справочник

Задание типа таблицы стилей печати для новых чертежей

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Печать/Публикация" нажмите кнопку "Таблицы стилей печати".
  3. В диалоговом окне "Параметры таблиц стилей печати" установите переключатель в положение "Цветозависимые стили печати" или "Именованные стили печати".
  4. (Не обязательно) Выберите таблицу из списка "Таблица стилей печати по умолчанию".
  5. (Не обязательно) Если установить переключатель в положение "Именованные стили печати", то выбранные стили будут применяться к слою 0 и к новым объектам.
  6. Нажмите "ОК".
    ПримечаниеУстановка типов таблиц стилей печати для новых чертежей никак не влияет на уже существующие чертежи.
Ввод команды: НАСТРОЙКА


Выбор типа таблиц стилей печати (Краткий справочник)

Коротко о стилях печати
Выбор типа таблиц стилей печати
Смена типов таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Выбор типа таблиц стилей печати >
Выбор типа таблиц стилей печати
Понятие Процедура Краткий справочник

Команды

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Смена типов таблиц стилей печати (Понятие)

Выбор типа таблиц стилей печати
Использование стилей печати
Подключение таблиц стилей печати к листам
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати >
Смена типов таблиц стилей печати
Понятие Процедура Краткий справочник

При работе с чертежом имеется возможность выбора, использовать таблицу цветозависимых стилей печати или именованных стилей печати.

Для определения того, какую таблицу стилей печати, цветозависимых или именованных, следует использовать на чертеже, можно вызвать команду ПРЕОБРСПЕЧ.

При переходе с использования таблицы цветозависимых стилей печати к использованию таблицы именованных стилей печати все цветозависимые стили печати, назначенные листам, удаляются, и вместо них назначаются именованные стили печати. Если необходимо использовать стили, определяемые в таблицах цветозависимых стилей печати, после применения к чертежу таблицы именованных стилей, требуется предварительное преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати.

При переходе с таблиц именованных стилей печати к таблицам цветозависимых стилей печати теряются имена стилей печати, назначенных объектам чертежа.

Кроме смены типа таблицы стилей печати, можно воспользоваться командой ПРЕОБРТСП для преобразования таблиц цветозависимых стилей печати в таблицы именованных стилей. Преобразовать таблицу именованных стилей печати в таблицу цветозависимых стилей невозможно.


Смена типов таблиц стилей печати (Процедура)

Выбор типа таблиц стилей печати
На уровень вверх ..
Смена типов таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Смена типов таблиц стилей печати >
Смена типов таблиц стилей печати
Понятие Процедура Краткий справочник

Переход к использованию именованных стилей печати

Переход к использованию цветозависимых стилей печати

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати


Переход к использованию именованных стилей печати (Процедура)

Смена типов таблиц стилей печати
На уровень вверх ..
Смена типов таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Смена типов таблиц стилей печати >
Смена типов таблиц стилей печати
Понятие Процедура Краткий справочник

Переход к использованию именованных стилей печати

  1. В командной строке введите преобрспеч.
  2. Нажмите "ОК" в окне сообщения для подтверждения.
  3. В диалоговом окне "Выбор файла" выберите файл таблицы именованных стилей печати для его подключения к модели и листам, использующих общую таблицу.
  4. Нажмите "Открыть".

    Появится окно подтверждения преобразования чертежа.

    ПримечаниеЕсли в диалоговом окне уже установлен флажок "Показать стили печати", для отображения параметров стиля печати необходимо ввести "реген" в командной строке.


Переход к использованию цветозависимых стилей печати (Процедура)

Смена типов таблиц стилей печати
На уровень вверх ..
Смена типов таблиц стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Смена типов таблиц стилей печати >
Смена типов таблиц стилей печати
Понятие Процедура Краткий справочник

Переход к использованию цветозависимых стилей печати

  1. В командной строке введите преобрспеч.
  2. Нажмите "ОК".

    Появится окно подтверждения преобразования чертежа.


Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати (Процедура)

Смена типов таблиц стилей печати
На уровень вверх ..
Подключение таблиц стилей печати к листам
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Смена типов таблиц стилей печати >
Смена типов таблиц стилей печати
Понятие Процедура Краткий справочник

Преобразование таблицы цветозависимых стилей печати в таблицу именованных стилей печати

  1. В командной строке введите преобртсп.
  2. В диалоговом окне "Выбор файла" выберите файл таблицы стилей печати для преобразования и нажмите "Открыть". По умолчанию, таблицы стилей печати сохраняются в папке Plot Styles.
  3. Введите имя новой таблицы стилей печати. Нажмите кнопку "Сохранить".
  4. Нажмите "ОК" в окне сообщения для подтверждения.
ПримечаниеПереименование стилей печати таблицы с помощью редактора таблиц стилей печати следует выполнять перед тем, как подключать эту таблицу к чертежу.
Ввод команды: ПРЕОБРТСП


Смена типов таблиц стилей печати (Краткий справочник)

Выбор типа таблиц стилей печати
Смена типов таблиц стилей печати
Подключение таблиц стилей печати к листам
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Смена типов таблиц стилей печати >
Смена типов таблиц стилей печати
Понятие Процедура Краткий справочник

Команды

ПРЕОБРТСП

Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)

ПРЕОБРСПЕЧ

Настройка чертежа на использование именованных или цветозависимых стилей печати

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подключение таблиц стилей печати к листам (Понятие)

Смена типов таблиц стилей печати
Использование стилей печати
Управление таблицами стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати >
Подключение таблиц стилей печати к листам
Понятие Процедура Краткий справочник

Возможность подключения различных таблиц стилей печати к каждому листу чертежа позволяет управлять печатью объектов пространств модели и листа. Для печати чертежа без учета свойств стилей печати следует из списка таблиц стилей печати выбрать "Нет".

Если используются таблицы именованных стилей печати, то стиль печати присваивается каждому объекту чертежа напрямую или через назначение слою с этим объектом.

Для просмотра результата применения таблицы стилей печати к листу необходимо в диалоговом окне "Параметры листа" в группе "Таблица стилей печати" установить флажок "Показать стили печати".

ПримечаниеЕсли вставить в текущий чертеж внешнюю ссылку, то таблица стилей печати этой внешней ссылки также добавляется в чертеж. Для внесения изменений в процесс обработки объектов с помощью стилей печати служит редактор таблиц стилей печати.


Подключение таблиц стилей печати к листам (Процедура)

Смена типов таблиц стилей печати
На уровень вверх ..
Подключение таблиц стилей печати к листам
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Подключение таблиц стилей печати к листам >
Подключение таблиц стилей печати к листам
Понятие Процедура Краткий справочник

Подключения таблицы стилей печати к разметке листа

Просмотр разметки листа с учетом таблицы стилей печати


Подключения таблицы стилей печати к разметке листа (Процедура)

Подключение таблиц стилей печати к листам
На уровень вверх ..
Подключение таблиц стилей печати к листам
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Подключение таблиц стилей печати к листам >
Подключение таблиц стилей печати к листам
Понятие Процедура Краткий справочник

Подключения таблицы стилей печати к разметке листа

  1. Перейдите на вкладку модели или разметки листа, которой должна быть назначена таблица.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Параметры листа". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов нажмите "Редактировать".
  4. В группе "Таблица стилей печати" выберите таблицу стилей печати из списка.
  5. В диалоговом окне "Вопрос" нажмите "Да" или "Нет", чтобы указать, применять ли сделанный выбор к текущей вкладке или ко всем разметкам листов.

    Эта опция доступна только на вкладке "Модель".

  6. Для просмотра результата применения таблицы стилей печати к разметке листа установите флажок "Показать стили печати".

    Эта опция доступна только на вкладках разметок листов.

  7. Нажмите "ОК".
  8. Нажмите кнопку "Закрыть" в Диспетчере наборов параметров листов.
ПримечаниеЕсли в диалоговом окне уже установлен флажок "Показать стили печати", для отображения параметров стиля печати необходимо ввести "реген" в командной строке.
Панель:Листы
Ввод команды: ПАРАМЛИСТ


Просмотр разметки листа с учетом таблицы стилей печати (Процедура)

Подключение таблиц стилей печати к листам
На уровень вверх ..
Управление таблицами стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Подключение таблиц стилей печати к листам >
Подключение таблиц стилей печати к листам
Понятие Процедура Краткий справочник

Просмотр разметки листа с учетом таблицы стилей печати

  1. Перейдите на вкладку разметки листа, на которой нужно оценить результат применения таблицы стилей печати.
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Параметры листа". В командной строке введите "парамлист".
  3. В Диспетчере наборов параметров листов нажмите "Редактирование".
  4. В группе "Таблица стилей печати" установить флажок "Показать стили печати".
  5. Нажмите "ОК".
  6. Нажмите кнопку "Закрыть" в Диспетчере наборов параметров листов.

    Результат применения таблицы стилей печати отображается на разметке листа.

Панель:Листы
Ввод команды: ПАРАМЛИСТ


Подключение таблиц стилей печати к листам (Краткий справочник)

Смена типов таблиц стилей печати
Подключение таблиц стилей печати к листам
Управление таблицами стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Подключение таблиц стилей печати к листам >
Подключение таблиц стилей печати к листам
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление таблицами стилей печати (Понятие)

Подключение таблиц стилей печати к листам
Использование стилей печати
Таблицы цветозависимых стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати >
Управление таблицами стилей печати
Понятие Процедура Краткий справочник

С помощью Диспетчера стилей печати можно добавлять, удалять, переименовывать, копировать и редактировать таблицы стилей печати.

По умолчанию таблицы цветозависимых (CTB-файлы) и именованных (STB-файлы) стилей печати хранятся в папке Plot Styles. С файлами из этой папки Диспетчер стилей печати работает по умолчанию.

С помощью Диспетчера стилей печати можно добавлять, удалять, переименовывать, копировать и редактировать таблицы стилей печати. В Диспетчере стилей печати отобразятся все доступные таблицы стилей печати.


Управление таблицами стилей печати (Процедура)

Подключение таблиц стилей печати к листам
На уровень вверх ..
Управление таблицами стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Управление таблицами стилей печати >
Управление таблицами стилей печати
Понятие Процедура Краткий справочник

Создание таблицы стилей печати

Переименование таблицы стилей печати

Изменение описания таблицы стилей печати

Редактирование стилей в таблице стилей печати


Создание таблицы стилей печати (Процедура)

Управление таблицами стилей печати
На уровень вверх ..
Управление таблицами стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Управление таблицами стилей печати >
Управление таблицами стилей печати
Понятие Процедура Краткий справочник

Создание таблицы стилей печати

  1. Выберите пункт меню "Сервис" [image] "Мастеры" [image] "Создание таблицы стилей печати".
  2. Прочтите первую страницу. Нажмите "Далее".
  3. На странице "Начало" можно использовать файл конфигурации (CFG) или файл конфигурации плоттера (PCP или PC2) для импорта параметров перьев и создания таблицы стилей на основе уже существующей таблицы стилей или с самого начала. Если для создания выберите уже существующую таблицу стилей печати, то для новой таблицы устанавливается тот же тип. Нажмите "Далее".
  4. На странице "Выбор типа таблицы" установите переключатель в положение "Таблица цветозависимых стилей печати" или "Таблица именованных стилей печати".
  5. Если создание выполняется с импортированием параметров перьев из PCP- или PC2-файла, а также на основе CFG-файла или существующей таблицы стилей печати, то на странице "Поиск файла" выберите файл. Если для создания используется CFG-файл, то может потребоваться выбор конфигурации плоттера для импорта. Нажмите "Далее".
  6. На странице "Имя файла" введите имя новой таблицы стилей печати. Нажмите "Далее".
  7. На странице "Окончание" можно нажать кнопку "Редактор таблиц стилей печати" для редактирования новой таблицы. Можно указать, что новая таблица стилей печати будет использоваться всеми чертежами.
  8. Нажмите "Готово".

    Новая таблица стилей печати становится доступна в диалоговых окнах "Печать" и "Параметры листа" для применения ко всем чертежам, использующим таблицы цветозависимых стилей печати.


Переименование таблицы стилей печати (Процедура)

Управление таблицами стилей печати
На уровень вверх ..
Управление таблицами стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Управление таблицами стилей печати >
Управление таблицами стилей печати
Понятие Процедура Краткий справочник

Переименование таблицы стилей печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Правой кнопкой мыши щелкните на стиле печати, имя которого необходимо изменить. Выберите "Переименовать".
  3. Введите новое имя файла. Расширение нового имени файла следует оставить без изменений (.ctb или .stb). По завершении процедуры нажмите ENTER.

    Переименованная таблица стилей печати становится доступна в диалоговых окнах "Печать" и "Параметры листа" для применения ко всем чертежам, использующим данный тип таблиц стилей печати.

Ввод команды: ДИСПСТИЛЬ


Изменение описания таблицы стилей печати (Процедура)

Управление таблицами стилей печати
На уровень вверх ..
Управление таблицами стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Управление таблицами стилей печати >
Управление таблицами стилей печати
Понятие Процедура Краткий справочник

Изменение описания таблицы стилей печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке файла таблицы стилей печати, описание к которой требуется изменить.
  3. На вкладке "Общие" редактора таблиц стилей печати введите новое описание к таблице.
  4. Нажмите кнопку "Принять".
Ввод команды: ДИСПСТИЛЬ


Редактирование стилей в таблице стилей печати (Процедура)

Управление таблицами стилей печати
На уровень вверх ..
Таблицы именованных стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Управление таблицами стилей печати >
Управление таблицами стилей печати
Понятие Процедура Краткий справочник

Редактирование стилей в таблице стилей печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати в списке "Стили" выберите стиль печати и внесите изменения в его параметры.
  4. Нажмите кнопку "Принять".
Ввод команды: ДИСПСТИЛЬ


Управление таблицами стилей печати (Краткий справочник)

Подключение таблиц стилей печати к листам
Управление таблицами стилей печати
Таблицы цветозависимых стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Использование стилей печати > Управление таблицами стилей печати >
Управление таблицами стилей печати
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Таблицы цветозависимых стилей печати (Понятие)

Управление таблицами стилей печати
Управление стилем печати объектов
Таблицы именованных стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Таблицы цветозависимых стилей печати
Понятие Краткий справочник

Использование цветозависимых стилей печати обеспечивает вывод объектов с учетом заданных для этих объектов цветов.

Если в чертеже используется таблица цветозависимых стилей печати, назначение стиля печати отдельно каждому объекту или слою невозможно. Для настройки цветов следует использовать цветовые свойства объектов или слоев.

Таблицы цветозависимых стилей печати можно назначать листам. При этом допустимо использование нескольких стандартных таблиц цветозависимых стилей, а также редактирование и создание своих таблиц.

По умолчанию файлы таблиц цветозависимых стилей печати имеют расширение .ctb и хранятся в папке Plot Styles.

Стандартные таблицы цветозависимых стилей печати

В папке Plot Styles, которая называется также Диспетчером стилей печати, установлено несколько таблиц цветонезависимых стилей печати.

Таблица | Описание
acad.ctb | Таблица стилей печати, используемая по умолчанию
fillPatterns.ctb | Устанавливает первые 9 цветов для использования в первых 9 образцах закрашивания, а остальные цвета - для закрашиваний, задаваемых в объектах
grayscale.ctb | Преобразовывает все цвета в оттенки серого при печати
monochrome.ctb | Печатает все цвета черным
Нет | Обозначает отсутствие назначения какой-либо таблицы стилей печати
screening 100%.ctb | Использует 100% краски для вывода всех цветов
screening 75%.ctb | Использует 75% краски для вывода всех цветов
screening 50%.ctb | Использует 50% краски для вывода всех цветов
screening 25%.ctb | Использует 25% краски для вывода всех цветов
ПримечаниеНазначение листу таблицы цветозависимых стилей печати возможно лишь в том случае, если в параметрах чертежа установлена возможность использования таблиц цветозависимых стилей.
См. также

    • Подключение таблиц стилей печати к листам


Таблицы цветозависимых стилей печати (Краткий справочник)

Управление таблицами стилей печати
Таблицы цветозависимых стилей печати
Именованные стили печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы цветозависимых стилей печати >
Таблицы цветозависимых стилей печати
Понятие Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Таблицы именованных стилей печати

Таблицы цветозависимых стилей печати
Управление стилем печати объектов
Именованные стили печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Таблицы именованных стилей печати
Понятие Процедура

В таблице именованных стилей печати можно создавать, удалять и редактировать стили. В такой таблице может быть создано любое число стилей.

Темы в этом разделе

  • Именованные стили печати

    Именованные стили печати, так же как тип линий и цвет, можно назначать объектам и слоям.

  • Управление именованными стилями печати

    Для добавления, удаления, переименования и копирования именованных стилей печати в таблице стилей предназначен редактор таблиц стилей печати.

  • Стандартные таблицы именованных стилей печати

    Помимо таблицы стилей по умолчанию имеется дополнительная таблица именованных стилей, которую можно использовать. Все файлы таблиц именованных стилей печати имеют расширение .stb.

  • Удаление таблиц соответствия цветов

    Таблицы стилей печати, из которых удалена информация о соответствии цветов, не годятся для назначения стилей печати объектам старых чертежей.


Таблицы именованных стилей печати (Процедура)

Управление таблицами стилей печати
На уровень вверх ..
Именованные стили печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати >
Таблицы именованных стилей печати
Понятие Процедура

Изменение стиля печати объекта

Изменение стиля печати для слоя

Задание текущего стиля печати

Создание именованного стиля печати

Копирование именованного стиля печати

Изменение описания стиля печати

Переименование именованного стиля печати

Удаление именованного стиля печати

Удаление таблицы соответствия цветов


Именованные стили печати (Понятие)

Таблицы именованных стилей печати
Таблицы именованных стилей печати
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати >
Именованные стили печати
Понятие Процедура Краткий справочник

Именованные стили печати, так же как тип линий и цвет, можно назначать объектам и слоям.

Если для свойства "Стиль печати" объекта установлено значение ПОСЛОЮ, то данный объект использует характеристики стиля печати, назначенные для его слоя.

Изменение стиля печати для объекта можно выполнять с помощью палитры свойств, для слоя - с помощью Диспетчера свойств слоев.

Так как каждому листу может быть назначена своя таблица именованных стилей печати, в которой может содержаться произвольное число стилей, то возможны такие ситуации, когда для объекта или слоя назначается стиль печати, который не определен в таблицах, подключенных к другим листам чертежа. В этом случае, если стиль печати отсутствует в диалоговом окне "Выбор стиля печати", используются свойства печати объекта по умолчанию. Например, пусть имеются таблицы Style1 со стилями печати A и B и Style2 со стилями печати B и C. Тогда на листе с подключенной таблицей Style1 все объекты, которым назначен стиль печати C, будут выведены в список объектов с необнаруженными стилями печати. Эти объекты вычерчиваются с учетом параметров, установленных по умолчанию.


Именованные стили печати (Процедура)

Таблицы именованных стилей печати
На уровень вверх ..
Именованные стили печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Именованные стили печати >
Именованные стили печати
Понятие Процедура Краткий справочник

Изменение стиля печати объекта

Изменение стиля печати для слоя

Задание текущего стиля печати


Изменение стиля печати объекта (Процедура)

Именованные стили печати
На уровень вверх ..
Именованные стили печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Именованные стили печати >
Именованные стили печати
Понятие Процедура Краткий справочник

Изменение стиля печати объекта

Устанавливать стиль печати для каждого объекта можно лишь в том случае, если в чертеже используются таблицы именованных стилей печати. Если же в чертеже используются таблицы цветозависимых стилей, то управление отображением объектов возможно лишь через их свойства, определяющие цвет.

  1. Выберите объекты, для которых необходимо изменить стиль печати.
  2. Нажмите правую кнопку мыши в области чертежа. Выберите "Свойства".
  3. В палитре свойств выберите стиль печати из списка доступных стилей. Нажмите для этого кнопку мыши на второй ячейке строки "Стиль печати".

    Раскрывается список стилей, используемых объектами и входящих в таблицу стилей, подключенную к текущему листу.

  4. Если требуется задать иной стиль печати, не входящий в этот список, выберите "Прочие". В диалоговом окне "Выбор стиля печати" можно подключить другую таблицу стилей печати и выбрать необходимый стиль из этой таблицы.
  5. Для редактирования текущей таблицы стилей нажмите "Редактор".
  6. По завершении нажмите кнопку "OK".

    Все изменения, выполненные на палитре свойств, сразу же вступают в силу. Смена таблицы стилей печати для текущего листа сказывается на объектах модели и пространства листа.

Панель:Стандартный
Ввод команды: ОКОНСВ


Изменение стиля печати для слоя (Процедура)

Именованные стили печати
На уровень вверх ..
Именованные стили печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Именованные стили печати >
Именованные стили печати
Понятие Процедура Краткий справочник

Изменение стиля печати для слоя

  1. Выберите меню "Формат" [image] "Слой".В командной строке введите "слой".
  2. В Диспетчере свойств слоев выберите слой, для которого требуется изменить стиль печати.
  3. Нажмите кнопку мыши на имени текущего стиля в столбце "Стиль печати". Выберите назначаемый стиль печати.
  4. Для выбора стиля печати из другой таблицы стилей выберите нужную таблицу для активизации из списка "Активная таблица стилей печати".

    Состав списка доступных стилей печати меняется в соответствии с выбранной таблицей.

  5. Для редактирования таблицы стилей нажмите "Редактор". Внесите необходимые изменения. Нажмите кнопку "Принять & Закрыть".
  6. Нажмите "ОК".

    Устанавливать стиль печати для каждого слоя можно лишь в том случае, если в чертеже используются таблицы именованных стилей печати. Если же в чертеже используются таблицы цветозависимых стилей, то управление отображением слоя возможно лишь через свойства его объектов, определяющие цвет.

    ПримечаниеДля того, чтобы объект наследовал стиль печати от слоя, следует установить для стиля печати объекта значение ПОСЛОЮ.
Панель:Слои
Ввод команды: СЛОЙ


Задание текущего стиля печати (Процедура)

Именованные стили печати
На уровень вверх ..
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Именованные стили печати >
Именованные стили печати
Понятие Процедура Краткий справочник

Задание текущего стиля печати

  1. Выберите пункт меню "Формат" [image] "Стиль печати".
  2. В диалоговом окне "Текущий стиль печати" выберите стиль из списка.

    В списке выводятся стили печати, доступные в текущей таблице стилей.

  3. Для выбора стиля печати из другой таблицы стилей выберите нужную таблицу для активизации из списка "Активная таблица стилей печати".

    Состав списка доступных стилей печати меняется в соответствии с выбранной таблицей.

  4. Для редактирования таблицы стилей нажмите "Редактор". Измените необходимые настройки. Нажмите кнопку "Принять & Закрыть".
  5. Нажмите "ОК".

    Текущий стиль печати автоматически назначается новым создаваемым объектам чертежа.

    Задание текущего стиля возможно лишь в том случае, если в чертеже используются таблицы именованных стилей печати. Если же в чертеже используются таблицы цветозависимых стилей, то управление отображением объектов и слоев возможно лишь через свойства объектов, определяющие цвет.

    ПримечаниеДля того, чтобы объект унаследовал текущий стиль печати от текущего слоя, следует установить для текущего стиля печати объекта значение ПОСЛОЮ.
Ввод команды: ПСТИЛЬ


Именованные стили печати (Краткий справочник)

Таблицы цветозависимых стилей печати
Именованные стили печати
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Именованные стили печати >
Именованные стили печати
Понятие Процедура Краткий справочник

Команды

СЛОЙ

Управление слоями и их свойствами

ПСТИЛЬ

Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление именованными стилями печати (Понятие)

Именованные стили печати
Таблицы именованных стилей печати
Стандартные таблицы именованных стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Для добавления, удаления, переименования и копирования именованных стилей печати в таблице стилей предназначен редактор таблиц стилей печати.

Редактор используется также для настройки параметров как именованных стилей, так и цветозависимых стилей печати.

ПримечаниеСтиль печати NORMAL нельзя ни модифицировать, ни удалить. Кроме того, если для таблицы именованных стилей печати уже присвоены цвета, то добавление, удаление, копирование или переименование стилей в такой таблице невозможно. Таблица соответствия цветов связывает каждый стиль печати с цветом ACI.
См. также

    • Редактирование стилей печати


Управление именованными стилями печати (Процедура)

Именованные стили печати
На уровень вверх ..
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Управление именованными стилями печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Создание именованного стиля печати

Копирование именованного стиля печати

Изменение описания стиля печати

Переименование именованного стиля печати

Удаление именованного стиля печати


Создание именованного стиля печати (Процедура)

Управление именованными стилями печати
На уровень вверх ..
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Управление именованными стилями печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Создание именованного стиля печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла таблицы стилей, в которую нужно добавить стиль печати.
  3. (Не обязательно) Если нужно задать расположение нового стиля в списке, то на вкладке "Карточка" указать стиль печати, который должен предшествовать новому стилю в списке.
  4. На вкладке "Карточка" или "Таблица" нажмите "Добавить стиль".
  5. В диалоговом окне "Добавление стиля печати" введите имя стиля печати.
  6. Нажмите кнопку "Принять & Закрыть".
    ПримечаниеСтиль печати NORMAL нельзя ни модифицировать, ни удалить.
Ввод команды: ДИСПСТИЛЬ


Копирование именованного стиля печати (Процедура)

Управление именованными стилями печати
На уровень вверх ..
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Управление именованными стилями печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Копирование именованного стиля печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла, который нужно отредактировать.
  3. На вкладке "Карточка" редактора таблиц стилей печати нажмите правую кнопку мыши на стиле печати, который необходимо скопировать. Выберите "Копировать".
  4. Нажмите правую кнопку мыши на стиле печати. Выберите "Вставить". Если нужно задать расположение нового стиля в списке, то нажмите правую кнопку мыши на имени стиля, который должен предшествовать новому стилю в списке.
  5. В диалоговом окне "Добавление стиля печати" введите имя стиля печати.
  6. Нажмите кнопку "Принять & Закрыть".
ПримечаниеЕсли таблице стилей печати назначена таблица соответствия цветов, то копирование стилей этой таблицы невозможно. Нельзя также выполнять копирование и в таблицах цветозависимых стилей.
Ввод команды: ДИСПСТИЛЬ


Изменение описания стиля печати (Процедура)

Управление именованными стилями печати
На уровень вверх ..
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Управление именованными стилями печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Изменение описания стиля печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке файла таблицы, описания к стилям которой требуется изменить.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль печати, описание к которому необходимо изменить.
  4. В поле "Описание" введите необходимый текст.

    Можно выбрать несколько стилей печати и ввести для них описания или настроить их параметры.

  5. Нажмите кнопку "Принять & Закрыть".
ПримечаниеСтиль печати NORMAL нельзя ни модифицировать, ни удалить.
Ввод команды: ДИСПСТИЛЬ


Переименование именованного стиля печати (Процедура)

Управление именованными стилями печати
На уровень вверх ..
Управление именованными стилями печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Управление именованными стилями печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Переименование именованного стиля печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла, в котором необходимо переименовать стиль печати.
  3. На вкладке "Карточка" редактора таблиц стилей печати нажмите правую кнопку мыши на стиле печати, который необходимо переименовать. Выберите "Переименовать".
  4. Введите новое имя для выбранного стиля печати.
  5. Нажмите кнопку "Принять & Закрыть".
ПримечаниеСтиль печати NORMAL переименовать нельзя. Нельзя также переименовывать цветозависимые стили печати.
Ввод команды: ДИСПСТИЛЬ


Удаление именованного стиля печати (Процедура)

Управление именованными стилями печати
На уровень вверх ..
Удаление таблиц соответствия цветов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Управление именованными стилями печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Удаление именованного стиля печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке STB-файла, который нужно отредактировать.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль для его удаления из списка.
  4. Выберите "Удалить стиль".
  5. Нажмите кнопку "Принять & Закрыть".
ПримечаниеСтиль печати NORMAL нельзя ни модифицировать, ни удалить. Если таблице стилей печати назначена таблица соответствия цветов, то удаление стилей из этой таблицы невозможно. Нельзя также удалять цветозависимые стили печати.
Ввод команды: ДИСПСТИЛЬ


Управление именованными стилями печати (Краткий справочник)

Именованные стили печати
Управление именованными стилями печати
Стандартные таблицы именованных стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Управление именованными стилями печати >
Управление именованными стилями печати
Понятие Процедура Краткий справочник

Команды

ПСТИЛЬ

Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Стандартные таблицы именованных стилей печати (Понятие)

Управление именованными стилями печати
Таблицы именованных стилей печати
Удаление таблиц соответствия цветов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати >
Стандартные таблицы именованных стилей печати
Понятие Краткий справочник

Помимо таблицы стилей по умолчанию имеется дополнительная таблица именованных стилей, которую можно использовать. Все файлы таблиц именованных стилей печати имеют расширение .stb.

  • acad.stb: таблица стилей печати по умолчанию
  • Monochrome.stb: печатает все цвета черным
  • "Нет": ни одна таблица стилей печати не назначена
ПримечаниеТаблицы именованных стилей доступны лишь в том случае, когда для чертежа установлено использование таблиц именованных стилей.
См. также

    • Подключение таблиц стилей печати к листам


Стандартные таблицы именованных стилей печати (Краткий справочник)

Управление именованными стилями печати
Стандартные таблицы именованных стилей печати
Удаление таблиц соответствия цветов
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Стандартные таблицы именованных стилей печати >
Стандартные таблицы именованных стилей печати
Понятие Краткий справочник

Команды

ПСТИЛЬ

Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Удаление таблиц соответствия цветов (Понятие)

Стандартные таблицы именованных стилей печати
Таблицы именованных стилей печати
Редактирование стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати >
Удаление таблиц соответствия цветов
Понятие Процедура Краткий справочник

Таблицы стилей печати, из которых удалена информация о соответствии цветов, не годятся для назначения стилей печати объектам старых чертежей.

У таблиц именованных стилей печати, созданных на основе файлов, CFG, PCP или PC2, имеются таблицы соответствия цветов, созданные с присвоением перьев из прежних версий. Для таких таблиц, помимо этого, имеются таблицы соответствия цветов. При открытии чертежей, созданных в более ранних версиях AutoCAD по сравнению AutoCAD 2000, с помощью таблиц соответствия цветов каждому стилю печати сопоставляется определенный цвет и, следовательно, объекты данного цвета. Это позволяет выводить чертежи, построенные и предназначенные для вывода в прежних версиях.

Пока существует таблица соответствия цветов, добавление, удаление и переименование стилей печати в таблице невозможно.

Таблицы стилей печати, из которых удалена информация о соответствии цветов, не годятся для назначения стилей печати объектам старых чертежей. Тем не менее, остается возможность их использования во вновь создаваемых чертежах.

ПредупреждениеПосле удаления таблицы соответствия цветов автоматическое назначение стилей печати для объектов при первом открытии чертежей, созданных в более ранних версиях программы, невозможно.


Удаление таблицы соответствия цветов (Процедура)

Управление именованными стилями печати
На уровень вверх ..
Редактирование стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Удаление таблиц соответствия цветов >
Удаление таблиц соответствия цветов
Понятие Процедура Краткий справочник

Удаление таблицы соответствия цветов

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. В редакторе таблиц стилей печати на вкладке "Общие" выберите удаление таблицы соответствия цветов AutoCAD Release 14.
  4. Прочтите предупреждающее сообщение. Нажмите "Да" для удаления таблицы соответствия цветов или "Нет" для отмены удаления.
  5. Нажмите кнопку "Принять & Закрыть".
Ввод команды: ДИСПСТИЛЬ


Удаление таблиц соответствия цветов (Краткий справочник)

Стандартные таблицы именованных стилей печати
Удаление таблиц соответствия цветов
Коротко о параметрах стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Таблицы именованных стилей печати > Удаление таблиц соответствия цветов >
Удаление таблиц соответствия цветов
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование стилей печати

Удаление таблиц соответствия цветов
Управление стилем печати объектов
Коротко о параметрах стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов >
Редактирование стилей печати
Понятие Процедура

В стили печати можно вносить изменения с помощью редактора таблиц стилей печати. Все модификации стиля отражаются на объектах, использующих этот стиль.

Темы в этом разделе

  • Коротко о параметрах стилей печати

    Редактор таблиц стилей печати можно вызвать двойным нажатием кнопки мыши на ярлыке CTB- или STB-файла в Диспетчере стилей печати. В окне редактора таблиц стилей печати отображаются параметры всех стилей, входящих в выбранную таблицу.

  • Цвет, интенсивность, оттенки серого и размывание

    С помощью стиля печати можно задавать свойства, определяющие цвет, интенсивность, режимы размывания и преобразования в оттенки серого.

  • Назначение номеров перьев и виртуальных перьев в таблицах стилей печати

    Присвоения перьев, используемые плоттером, могут изменяться в зависимости от того, является ли устройство печати перьевым плоттером или каким-то другим типом устройства, например, лазерным принтером.

  • Задание веса и типа линий

    Вес и тип линий могут определяться в свойствах объекта или в стиле печати при выводе на печать. Во время печати параметры веса и типа линий, заданные в стиле печати, переопределяют аналогичные свойства объекта.

  • Задание стилей окончаний и соединений линий

    Стили окончаний и соединений линий можно задавать в свойствах объекта или переопределять с помощью стиля печати.

  • Задание стиля заливки

    Для печати широких полилиний, колец, раскрашенных объектов и тел предлагаются различные стили закрашивания.


Редактирование стилей печати (Процедура)

Удаление таблиц соответствия цветов
На уровень вверх ..
Коротко о параметрах стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати >
Редактирование стилей печати
Понятие Процедура

Изменение параметров стиля печати

Задание цвета в стиле печати

Назначение интенсивности

Включение/отключение размывания

Включение/отключение преобразования цветов в оттенки серого

Задание номера виртуального пера

Задание веса линий в стиле печати

Задание типа линий в стиле печати

Масштабирование типов линий и образцов заливки, не относящихся к стандарту ISO

Задание стиля окончаний или соединений линий

Задание стиля заливки


Коротко о параметрах стилей печати (Понятие)

Редактирование стилей печати
Редактирование стилей печати
Цвет, интенсивность, оттенки серого и размывание
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати >
Коротко о параметрах стилей печати
Понятие Процедура Краткий справочник

Редактор таблиц стилей печати можно вызвать двойным нажатием кнопки мыши на ярлыке CTB- или STB-файла в Диспетчере стилей печати. В окне редактора таблиц стилей печати отображаются параметры всех стилей, входящих в выбранную таблицу.

Вкладка "Общие" предоставляет базовые сведения о таблице стилей. Вкладки "Таблица" и "Карточка" обеспечивают два способа доступа к свойствам стилей печати. Как правило, если количество стилей печати невелико, удобнее пользоваться вкладкой "Таблица". Если же в таблице определено много стилей печати, более предпочтительной становится вкладка "Карточка".

В таблице именованных стилей стиль NORMAL содержит свойства объекта, принятые по умолчанию (без применения стиля печати). Стиль NORMAL изменить или удалить невозможно.


Изменение параметров стиля печати (Процедура)

Редактирование стилей печати
На уровень вверх ..
Цвет, интенсивность, оттенки серого и размывание
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Коротко о параметрах стилей печати >
Коротко о параметрах стилей печати
Понятие Процедура Краткий справочник

Изменение параметров стиля печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати из списка "Стили" выберите стиль печати для редактирования.
  4. В группе "Свойства" щелкните на стрелке рядом со свойством, которое необходимо изменить. Выберите опцию из списка.
  5. Если необходимо, повторите операцию редактирования для других свойств.
  6. Нажмите кнопку "Принять & Закрыть".
Ввод команды: ДИСПСТИЛЬ


Коротко о параметрах стилей печати (Краткий справочник)

Удаление таблиц соответствия цветов
Коротко о параметрах стилей печати
Цвет, интенсивность, оттенки серого и размывание
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Коротко о параметрах стилей печати >
Коротко о параметрах стилей печати
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Цвет, интенсивность, оттенки серого и размывание (Понятие)

Коротко о параметрах стилей печати
Редактирование стилей печати
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати >
Цвет, интенсивность, оттенки серого и размывание
Понятие Процедура Краткий справочник

С помощью стиля печати можно задавать свойства, определяющие цвет, интенсивность, режимы размывания и преобразования в оттенки серого.

Задание цвета в стиле печати

По умолчанию в стиле печати установлено значение цвета "Взять из объекта". Это значение позволяет сохранять цвет объекта, установленный в свойствах слоя или самого объекта. Если задать цвет явно, при печати объекты будут перекрашены в этот цвет. Можно выбрать один из 255 цветов ACI, из всей палитры цветов или воспользоваться альбомами цветов. Для использования всей палитры цветов плоттер должен быть настроен для работы в режиме True Color.

ПримечаниеПри работе с таблицей стилей печати, сохраненной в AutoCAD 2000 или в более поздней версии, значения, заданные в режиме "Вся палитра", заменяются ближайшими значениями из палитры текущей версии.

Задание интенсивности вывода

Можно выбрать значение интенсивности цвета, которое определяет количество краски, попадающее на бумагу при печати. Допустимый диапазон значений - от 0 до 100. Значение 0 соответствует выводу белым цветом, а значение 100 - полной интенсивности. Параметр интенсивности работает только на плоттерах, работающих с цветом или оттенками серого. Для использования этого параметра необходимо также включить режим размывания.

Включение размывания

Размывание используется в плоттерах для имитации составных цветов путем пространственного комбинирования точек, имеющих стандартные цвета (т.е. цвета чернил картриджей). Если плоттер не поддерживает размывание, параметр игнорируется.

Иногда отключение размывания позволяет избежать преобразования тонких векторов в псевдоштриховые линии, а также делает более наглядными цвета тусклых оттенков. Если размывание отключено, устанавливается соответствие цвета с ближайшим стандартным; это ограничивает цветовую гамму чертежа. Размывание при печати возможно независимо от того, как задан цвет в стиле печати (цвет объекта или явное присвоение).

ПримечаниеВключение размывания может приводить к визуальному слиянию близко расположенных элементов.

Печатать с оттенками серого

Если выбран параметр "Печатать с оттенками серого", цвета объекта преобразуются в оттенки серого, если плоттер поддерживает печать с оттенками серого. Светлые цвета, такие как желтый, печатаются светлыми оттенками серого, а темные цвета - темными оттенками серого. Если параметр "Печатать с оттенками серого" отключен, для печати цветов объекта используются значения RGB. Преобразование в оттенки серого при печати возможно независимо от того, как задан цвет в стиле печати (цвет объекта или явное присвоение).


Цвет, интенсивность, оттенки серого и размывание (Процедура)

Коротко о параметрах стилей печати
На уровень вверх ..
Цвет, интенсивность, оттенки серого и размывание
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Цвет, интенсивность, оттенки серого и размывание >
Цвет, интенсивность, оттенки серого и размывание
Понятие Процедура Краткий справочник

Задание цвета в стиле печати

Назначение интенсивности

Включение/отключение размывания

Включение/отключение преобразования цветов в оттенки серого


Задание цвета в стиле печати (Процедура)

Цвет, интенсивность, оттенки серого и размывание
На уровень вверх ..
Цвет, интенсивность, оттенки серого и размывание
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Цвет, интенсивность, оттенки серого и размывание >
Цвет, интенсивность, оттенки серого и размывание
Понятие Процедура Краткий справочник

Задание цвета в стиле печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Щелкните правой кнопкой мыши на файле CTB или STB. Нажмите "Открыть".
  3. На вкладке "Таблица" редактора таблиц стилей печати выберите поле "Цвет" стиля печати, в который требуется внести изменения.
  4. Из раскрывающегося списка цветов выберите нужный цвет или опцию "Выбор цвета", открывающую одноименное диалоговое окно, и выполните одну из следующих операций:
    • На вкладке "Номер цвета" выберите цвет или введите в поле "Цвет" его имя или числовое значение в системе ACI (от 1 до 255). Нажмите "ОК".
    • На вкладке "Вся палитра" в поле "Цветовая модель" задайте цвет. (Введите значение цвета в поле "Цвет" или задайте значения "H (оттенок)", "S (насыщенность)" и "L (яркость)"). Нажмите "ОК".
    • На вкладке "Альбомы цветов" выберите цвет в поле "Альбом цветов" (воспользуйтесь стрелками перемещения вверх и вниз и выберите цветовую метку). Нажмите "ОК".
Ввод команды: ДИСПСТИЛЬ


Назначение интенсивности (Процедура)

Цвет, интенсивность, оттенки серого и размывание
На уровень вверх ..
Цвет, интенсивность, оттенки серого и размывание
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Цвет, интенсивность, оттенки серого и размывание >
Цвет, интенсивность, оттенки серого и размывание
Понятие Процедура Краткий справочник

Назначение интенсивности

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" Редактора таблиц стилей печати выберите стиль для редактирования.
  4. В поле параметра "Интенсивность" укажите значение от 1 до 100.
  5. По завершении нажмите кнопку "Принять & Закрыть".

    Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

    ПримечаниеКак правило, при использовании параметра интенсивности цвет каждого стиля устанавливают в черный. Таким образом, значение интенсивности задает насыщенность черного цвета.
Ввод команды: ДИСПСТИЛЬ


Включение/отключение размывания (Процедура)

Цвет, интенсивность, оттенки серого и размывание
На уровень вверх ..
Цвет, интенсивность, оттенки серого и размывание
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Цвет, интенсивность, оттенки серого и размывание >
Цвет, интенсивность, оттенки серого и размывание
Понятие Процедура Краткий справочник

Включение/отключение размывания

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль и нажмите кнопку мыши на поле параметра "Разрешить размывание".
  4. Выберите значение "Вкл" или "Откл".
  5. По завершении нажмите кнопку "Принять & Закрыть".

    Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Включение/отключение преобразования цветов в оттенки серого (Процедура)

Цвет, интенсивность, оттенки серого и размывание
На уровень вверх ..
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Цвет, интенсивность, оттенки серого и размывание >
Цвет, интенсивность, оттенки серого и размывание
Понятие Процедура Краткий справочник

Включение/отключение преобразования цветов в оттенки серого

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль и нажмите кнопку мыши на поле параметра "Печатать с оттенками серого".
  4. Выберите значение "Вкл" или "Откл".
  5. По завершении нажмите кнопку "Принять & Закрыть".

    Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Цвет, интенсивность, оттенки серого и размывание (Краткий справочник)

Коротко о параметрах стилей печати
Цвет, интенсивность, оттенки серого и размывание
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Цвет, интенсивность, оттенки серого и размывание >
Цвет, интенсивность, оттенки серого и размывание
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Назначение номеров перьев и виртуальных перьев в таблицах стилей печати (Понятие)

Цвет, интенсивность, оттенки серого и размывание
Редактирование стилей печати
Задание веса и типа линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати >
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Понятие Процедура Краткий справочник

Присвоения перьев, используемые плоттером, могут изменяться в зависимости от того, является ли устройство печати перьевым плоттером или каким-то другим типом устройства, например, лазерным принтером.

Задание перьев для стилей печати

Для задания перьев, используемых каждым стилем печати, служит параметр "Номер назначенного пера" в стиле печати. Физические перья плоттера задаются в PC3-файле конфигурации плоттера. При использовании перьевого плоттера необходимо указать значения цветов, скоростей и толщин всех перьев в разделе "Параметры физических перьев" редактора параметров плоттера.

Рассмотрим пример. Пусть в редакторе параметров плоттера задано, что перо номер 1 чертит черным цветом и обладает толщиной 0,25 мм, а перо номер 2 имеет красный цвет и толщину 0,5 мм. В Редакторе таблиц стилей печати можно назначить перу №1 стиль печати под названием "Водопроводные трубы", а перу №2 - стиль печати "Канализационные трубы".

Номер назначаемого пера в поле "Номер назначенного пера" может указываться в диапазоне от 1 до 32. По умолчанию используется значение 1. Изменение номера пера невозможно в том случае, если для цвета в стиле печати установлено значение "Взять из объекта", а также при редактировании стиля печати в таблице цветозависимых стилей печати.

Если занести в поле значение 0, программа изменяет его на "Авто". Сведения, указанные в поле "Параметры физических перьев" редактора параметров плоттера, используются для выбора пера, ближайшего по цвету к печатаемому объекту.

Эмуляция перьев для неперьевых плоттеров

Многие неперьевые плоттеры способны работать в режиме эмуляции перьевых, оперируя понятием виртуального пера. Эмуляция перьев для таких устройств выполняется программно или при помощи панели управления плоттера.

Если установлен режим программного управления перьями устройства, то параметры веса и типа линий, интенсивности, стилей окончаний и соединений линий, а также стиля закрашивания, задаваемые в таблице стилей печати, отражаются на работе плоттера, переопределяя установки панели устройства печати.

Если программное управление отключено (как правило, используется аппаратное управление), то программно можно задавать только номера виртуальных перьев без установки цвета, весов и типов линий, стилей окончаний, соединений и закрашивания. В программе аппаратное управления (виртуальное перо) включается вместо программного (нормального) управления после выбора параметра "255 виртуальных перьев" в области "Глубина цветности" параметра "Векторная графика" на вкладке "Устройство и документ" редактора параметров плоттера. Выбор любой другой глубины цветности включает программное управление.

В редакторе таблиц стилей печати значение параметра "Номер виртуального пера" может устанавливаться в диапазоне от 1 до 255. Введите 0 или Авто для указания на то, что назначение виртуальных перьев необходимо производить с использованием ACI.

При создании таблицы стилей печати необходимо иметь в виду, что таблица может использоваться различными плоттерами, и для разных плоттеров и режимов печати могут выбираться разные части одной таблицы стилей.

  • Если используется перьевой плоттер с пользовательскими установками перьев, то номера виртуальных перьев и назначения цветов игнорируются.
  • Если используется перьевой плоттер с автоматическим назначением перьев, то выбор перьев осуществляется с учетом цвета и веса линий. В этом случае номера виртуальных перьев также игнорируются.
  • Если используется растровый плоттер в растровом режиме, то игнорируются номера как физических, так и виртуальных перьев.
  • Если используется растровый плоттер в режиме работы с виртуальными перьями, то игнорируются все параметры перьев, кроме назначенных номеров виртуальных перьев.
ПримечаниеЕсли для работы с созданными файлами печати используется другое приложение и пользователь изменяет атрибуты перьев, печать без применения виртуальных перьев приводит к отсутствию прямой связи номеров перьев в файле печати с цветами объекта в программе. Это затрудняет использование дополнительных атрибутов перьев.


Задание номера виртуального пера (Процедура)

Цвет, интенсивность, оттенки серого и размывание
На уровень вверх ..
Задание веса и типа линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Назначение номеров перьев и виртуальных перьев в таблицах стилей печати >
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Понятие Процедура Краткий справочник

Задание номера виртуального пера

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль печати, который необходимо изменить, и нажмите поле "Номер виртуального пера".
  4. В поле "Номер виртуального пера" ввести число от 1 до 255, или же 0 или Авто для автоматического назначения цвета ACI печатаемого объекта для виртуального пера.
  5. По завершении нажмите кнопку "Принять & Закрыть".

    Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Назначение номеров перьев и виртуальных перьев в таблицах стилей печати (Краткий справочник)

Цвет, интенсивность, оттенки серого и размывание
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Задание веса и типа линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Назначение номеров перьев и виртуальных перьев в таблицах стилей печати >
Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание веса и типа линий (Понятие)

Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Редактирование стилей печати
Задание стилей окончаний и соединений линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати >
Задание веса и типа линий
Понятие Процедура Краткий справочник

Вес и тип линий могут определяться в свойствах объекта или в стиле печати при выводе на печать. Во время печати параметры веса и типа линий, заданные в стиле печати, переопределяют аналогичные свойства объекта.

Задание и отображение весов линий

При выборе свойства "Вес линий" в редакторе таблиц стилей печати отображается образец толщины линии и его цифровое значение. По умолчанию в стиле печати установлено значение веса линии "Взять из объекта". Если нужного веса линий нет в списке, его можно получить модификацией одного из существующих.

Для просмотра листа с результатами применения весов линий необходимо в диалоговом окне "Параметры листа" в группе "Таблица стилей печати" установите флажок "Показать стили печати".

Задание типов линий

При выборе свойства "Тип линий" в редакторе таблиц стилей печати отображается список с описаниями и образцами всех доступных типов линий. По умолчанию в стиле печати установлено значение типа линии "Взять из объекта".

Независимо от того, как задан тип линии в стиле печати (тип линии объекта или явное присвоение), пользователь может включать параметр "Подстройка масштаба". Этот параметр регулирует масштаб типа линий так, чтобы в каждом объекте укладывалось целое число элементарных образцов. Если он отключен, элементарные образцы могут обрываться в линиях на середине. Параметр необходимо отключать, если приоритет имеет соблюдение точного масштаба. Включение параметра означает, что масштабы типов линий будут разными, но за счет этого будет достигнута корректность отображения объектов, выполненных штриховыми и пунктирными линиями.

Пользователь может применить глобальный масштабный коэффициент к типам линий и образцам закрашивания, не относящимся к стандарту ISO.

См. также

    • Работа с типами линий

    • Работа с весами линий


Задание веса и типа линий (Процедура)

Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
На уровень вверх ..
Задание веса и типа линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание веса и типа линий >
Задание веса и типа линий
Понятие Процедура Краткий справочник

Задание веса линий в стиле печати

Задание типа линий в стиле печати

Масштабирование типов линий и образцов заливки, не относящихся к стандарту ISO


Задание веса линий в стиле печати (Процедура)

Задание веса и типа линий
На уровень вверх ..
Задание веса и типа линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание веса и типа линий >
Задание веса и типа линий
Понятие Процедура Краткий справочник

Задание веса линий в стиле печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль для редактирования.
  4. Раскройте список параметра "Вес линий" и выберите необходимое значение. Чтобы указать необходимость использования веса линий объекта, следует выбрать параметр "Взять из объекта".
  5. Нажмите кнопку "Принять & Закрыть".

    Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Задание типа линий в стиле печати (Процедура)

Задание веса и типа линий
На уровень вверх ..
Задание веса и типа линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание веса и типа линий >
Задание веса и типа линий
Понятие Процедура Краткий справочник

Задание типа линий в стиле печати

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Карточка" редактора таблиц стилей печати выберите стиль для редактирования.
  4. Раскройте список параметра "Тип линий" и выберите необходимое значение. Чтобы указать необходимость использования типа линий объекта, следует выбрать параметр "Взять из объекта".
  5. Для регулирования масштаба типа линий таким образом, чтобы в каждом объекте укладывалось целое число элементарных образцов, на вкладке "Карточка" для параметра "Подстройка масштаба" установите значение "Вкл".
  6. Нажмите кнопку "Принять & Закрыть".

    Редактор таблиц стилей печати позволяет одновременно изменять параметры для нескольких стилей.

Ввод команды: ДИСПСТИЛЬ


Масштабирование типов линий и образцов заливки, не относящихся к стандарту ISO (Процедура)

Задание веса и типа линий
На уровень вверх ..
Задание стилей окончаний и соединений линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание веса и типа линий >
Задание веса и типа линий
Понятие Процедура Краткий справочник

Масштабирование типов линий и образцов заливки, не относящихся к стандарту ISO

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Дважды нажмите кнопку мыши на ярлыке таблицы стилей, требующей редактирования.
  3. На вкладке "Общие" Редактора таблиц стилей печати установите флажок "Применить глобальный масштаб к типам линий, не относящимся к ISO".

    Эта опция позволяет выполнять масштабирование типов линий и образцов закрашивания с учетом заданного значения масштаба.

  4. Введите значение масштаба в поле "Масштаб".
  5. Нажмите кнопку "Принять & Закрыть".
Ввод команды: ДИСПСТИЛЬ


Задание веса и типа линий (Краткий справочник)

Назначение номеров перьев и виртуальных перьев в таблицах стилей печати
Задание веса и типа линий
Задание стилей окончаний и соединений линий
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание веса и типа линий >
Задание веса и типа линий
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание стилей окончаний и соединений линий (Понятие)

Задание веса и типа линий
Редактирование стилей печати
Задание стиля заливки
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати >
Задание стилей окончаний и соединений линий
Понятие Процедура Краткий справочник

Стили окончаний и соединений линий можно задавать в свойствах объекта или переопределять с помощью стиля печати.

Задание стиля окончаний линий

ППрограмма содержит следующие опции стиля окончания линий:

  • срез
  • квадрат
  • полукруг
  • треугольник

По умолчанию устанавливается значение "Взять из объекта", при котором используется полукруглый стиль окончания. При печати стиль окончания, установленный в стиле печати, переопределяет стиль, заданный в свойствах объекта.

ПримечаниеТексты, набранные SHX-шрифтом, лучше печатать, используя полукруглые окончания и дуговые соединения линий.

Задание стиля соединений линий

Программа поддерживает следующие стили соединений линий:

  • угол
  • скос
  • дуга
  • треугольник

По умолчанию устанавливается значение "Взять из объекта", при котором используется стиль соединения "Дуга". При печати стиль соединений, установленный в стиле печати, переопределяет стиль, заданный в свойствах объекта.


Задание стиля окончаний или соединений линий (Процедура)

Задание веса и типа линий
На уровень вверх ..
Задание стиля заливки
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание стилей окончаний и соединений линий >
Задание стилей окончаний и соединений линий
Понятие Процедура Краткий справочник

Задание стиля окончаний или соединений линий

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Щелкните правой кнопкой мыши на файле CTB или STB. Нажмите "Открыть".
  3. На вкладке "Таблица" редактора таблиц стилей печати выберите поле "Стиль окончаний линий" или "Стиль соединений линий" для стиля печати, в который требуется внести изменения.
  4. Выберите нужную опцию из выпадающего списка.
Ввод команды: ДИСПСТИЛЬ


Задание стилей окончаний и соединений линий (Краткий справочник)

Задание веса и типа линий
Задание стилей окончаний и соединений линий
Задание стиля заливки
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание стилей окончаний и соединений линий >
Задание стилей окончаний и соединений линий
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание стиля заливки (Понятие)

Задание стилей окончаний и соединений линий
Редактирование стилей печати
Предварительный просмотр
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати >
Задание стиля заливки
Понятие Процедура Краткий справочник

Для печати широких полилиний, колец, раскрашенных объектов и тел предлагаются различные стили закрашивания.

Программа поддерживает следующие стили закрашивания для печати широких полилиний, колец, объектов со сплошной заливкой и тел:

  • сплошное
  • решетка
  • штриховка
  • шахматы
  • горизонтальные полосы
  • наклонные влево
  • наклонные вправо
  • квадраты
  • точки
  • вертикальные полосы

По умолчанию в стиле печати установлено значение стиля заливки "Взять из объекта". При печати стиль закрашивания, установленный в стиле печати, переопределяет стиль, заданный в свойствах объекта.

Пользователь может применить в стилях печати глобальный масштабный коэффициент к типам линий и образцам закрашивания, не относящимся к стандарту ISO.

См. также

    • Выбор образцов штриховки и сплошной заливки


Задание стиля заливки (Процедура)

Задание стилей окончаний и соединений линий
На уровень вверх ..
Предварительный просмотр
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание стиля заливки >
Задание стиля заливки
Понятие Процедура Краткий справочник

Задание стиля заливки

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер стилей печати". В командной строке введите "диспстиль".
  2. Щелкните правой кнопкой мыши на файле CTB или STB. Нажмите "Открыть".
  3. На вкладке "Таблица" редактора таблиц стилей печати выберите поле "Стиль закрашивания" стиля печати, в который требуется внести изменения.
  4. Выберите стиль заливки из выпадающего списка.
Ввод команды: ДИСПСТИЛЬ


Задание стиля заливки (Краткий справочник)

Задание стилей окончаний и соединений линий
Задание стиля заливки
Предварительный просмотр
Печать и публикация чертежей > Вывод чертежей на печать > Управление стилем печати объектов > Редактирование стилей печати > Задание стиля заливки >
Задание стиля заливки
Понятие Процедура Краткий справочник

Команды

ДИСПСТИЛЬ

Вызов Диспетчера стилей печати

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Предварительный просмотр (Понятие)

Задание стиля заливки
Вывод чертежей на печать
Печать в файлы различных форматов
Печать и публикация чертежей > Вывод чертежей на печать >
Предварительный просмотр
Понятие Процедура Краткий справочник

Прежде чем выводить чертеж на печать, рекомендуется выполнять предварительный просмотр чертежа. Это позволит сократить затраты времени и расходных материалов, необходимых для выполнения печати.

Для предварительного просмотра можно создать изображение всего чертежа с помощью диалогового окна "Печать". На таком изображении виден результат печати чертежа с учетом весов линий, образцов штриховок и других параметров стилей печати.

При предварительном просмотре активные панели и инструментальные палитры исчезают с экрана, а вместо них отображается панель "Предварительный просмотр", обеспечивающая доступ к функциям печати, панорамирования и увеличения чертежа.

В диалоговых окнах "Печать" и "Параметры листа" также содержится простой образец для просмотра, отображающий печатаемую область и положение чертежа при печати.


Предварительный просмотр (Процедура)

Задание стиля заливки
Предварительный просмотр
Печать в файлы различных форматов
Печать и публикация чертежей > Вывод чертежей на печать > Предварительный просмотр >
Предварительный просмотр
Понятие Процедура Краткий справочник

Предварительный просмотр

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" нажмите кнопку "Просмотр".

    Открывается окно просмотра, курсор в котором приобретает форму, аналогичную курсору зумирования.

  3. Нажмите правую кнопку мыши для вызова контекстного меню со следующими параметрами: "Печать", "Панорамирование", "Зумирование", "Показать рамкой" или "Показать исходный" (для возврата к исходному коэффициенту экранного увеличения).
  4. Нажмите ESC для закрытия окна просмотра и возврата в диалоговое окно "Печать".
  5. Если необходимо, перенастройте параметры печати и снова просмотрите чертеж.
  6. После завершения корректировки параметров нажмите "ОК" для печати чертежа.
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Предварительный просмотр (Краткий справочник)

Задание стиля заливки
Предварительный просмотр
Печать в DWF-файлы
Печать и публикация чертежей > Вывод чертежей на печать > Предварительный просмотр >
Предварительный просмотр
Понятие Процедура Краткий справочник

Команды

ПАН

Перемещение изображения на текущем видовом экране

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ПРЕДВАР

Предварительный просмотр на экране выводимого на печать листа

ПОКАЗАТЬ

Увеличение или уменьшение видимого размера объектов на текущем видовом экране

Системные переменные

RASTERPREVIEW

Управление сохранением образцов для просмотра в формате BMP вместе с чертежом

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Печать в файлы различных форматов

Предварительный просмотр
Вывод чертежей на печать
Печать в DWF-файлы
Печать и публикация чертежей > Вывод чертежей на печать >
Печать в файлы различных форматов
Понятие Процедура

Экспорт и печать чертежей можно осуществлять в целом ряде форматов, включая DWF, DWFx, DXF, PDF и метафайл Windows (WMF). Вывод чертежей в файлы можно выполнять с помощью специальных драйверов печати.

Все перечисленные варианты предусматривают настройку драйвера несистемного плоттера для вывода чертежей в файлы. Пользовательские параметры несистемных драйверов можно настраивать с помощью редактора параметров плоттера. Справочные сведения по каждому драйверу можно получить, нажав кнопку "Справка" в окне настройки его дополнительных свойств (доступно из редактора параметров плоттера).

Темы в этом разделе

  • Печать в DWF-файлы

    Для публикации чертежей в Интернете или в локальной сети можно создавать файлы DWF (файлы 2D векторной графики).

  • Печать файлов DWFx

    Файлы DWFx (DWF и XPS) можно создавать для публикации чертежей в Интернете или в локальной сети.

  • Печать в DXB-файлы

    Поддержка форматов файла DXB (двоичный файл обмена чертежами) осуществляется с помощью несистемного драйвера файлов DXB. Как правило, эти файлы используются для “уплощения” 3D чертежей и превращения их в 2D.

  • Печать в файлы растровых форматов

    Несистемным драйвером растровой печати поддерживается несколько форматов, включая Windows BMP, CALS, TIFF, PNG, TGA, PCX и JPEG. Растровые форматы часто используются для создания файлов публикаций рабочего стола.

  • Печать в файлы Adobe PDF

    С помощью драйвера для преобразования формата DWG в PDF можно создавать файлы формата Adobe® Portable Document Format (PDF) на основе чертежей.

  • Печать в файлы Adobe PostScript

    Использование драйвера Adobe PostScript позволяет в файлах чертежей формата DWG использовать элементы постраничной верстки и средства для просмотра. Примером может служить формат Adobe Acrobat Portable Document Format (PDF).

  • Создание файлов вывода на печать

    Используя любую конфигурацию плоттера, можно создавать файлы вывода на печать, которые в дальнейшем могут обрабатываться приложениями для вывода данных.


Печать в файлы различных форматов (Процедура)

Предварительный просмотр
Печать в файлы различных форматов
Печать в DWF-файлы
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Печать в файлы различных форматов
Понятие Процедура

Печать в файлы DWF

Для печати файла DWFx

Создание файла DXB

Создание файла растрового формата

Печать файла PDF

Печать файла PDF в альбомной ориентации

Печать в файл PostScript

Процедура создания файла печати (PLT)

Процедура создания командного файла для буферизации данных перед выводом на печать

Процедура печати из файла печати (PLT) посредством командного файла


Печать в DWF-файлы (Понятие)

Печать в файлы различных форматов
Печать в файлы различных форматов
Печать файлов DWFx
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Печать в DWF-файлы
Понятие Процедура Краткий справочник

Для публикации чертежей в Интернете или в локальной сети можно создавать файлы DWF (файлы 2D векторной графики).

Программу можно использовать для создания файлов DWF. Файл DWF - это файл двумерных векторов, который можно использовать для публикации чертежа в Интернете или во внутренней сети. Каждый DWF файл может содержать один или несколько листов чертежа.

Файлы DWF можно открывать, просматривать и печатать с помощью программы Autodesk® Design Review. С помощью программы просмотра файлов DWF можно просматривать файлы DWF в браузере Microsoft® Internet Explorer 5.01 или более поздних его версий. DWF-файлы поддерживают функции зумирования и панорамирования в реальном времени, а также функции управления отображением слоев и именованных видов.

См. также

    • Публикация чертежей


Печать в файлы DWF (Процедура)

Печать в файлы различных форматов
На уровень вверх ..
Печать файлов DWFx
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в DWF-файлы >
Печать в DWF-файлы
Понятие Процедура Краткий справочник

Печать в файлы DWF

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер DWF6 ePlot.pc3.
  3. Если необходимо, настройте параметры печати в DWF-файл.
  4. Нажмите "ОК".
  5. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя DWF-файла.
  6. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать в DWF-файлы (Краткий справочник)

Предварительный просмотр
Печать в DWF-файлы
Печать файлов DWFx
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в DWF-файлы >
Печать в DWF-файлы
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Печать файлов DWFx (Понятие)

Печать в DWF-файлы
Печать в файлы различных форматов
Печать в DXB-файлы
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Печать файлов DWFx
Понятие Процедура Краткий справочник

Файлы DWFx (DWF и XPS) можно создавать для публикации чертежей в Интернете или в локальной сети.

Для печати файла DWFx можно использовать файл настройки печати DWFx ePlot (совместимый с XPS). Каждый файл DWFx может содержать один или несколько листов с чертежами.

Файлы DWFx доступны для открытия, просмотра и распечатки всеми пользователями следующих приложений:

  • С помощью Internet Explorer можно просматривать и печатать 2D геометрию из файлов DWFx.
  • С помощью Autodesk Design Review можно просматривать файлы DWFx целиком, осуществлять в этом файле зумирование и панорамирование, включать и выключать слои, а также помечать чертежи.


Для печати файла DWFx (Процедура)

Печать в DWF-файлы
На уровень вверх ..
Печать в DXB-файлы
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать файлов DWFx >
Печать файлов DWFx
Понятие Процедура Краткий справочник

Для печати файла DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В группе "Принтер/плоттер" выберите раскрывающийся список "Имя" и выберите в этом списке конфигурацию DWFx ePlot (XPS Compatible).pc3.
  3. Выберите параметры печати, необходимые для печати файла DWFx.
  4. Нажмите "ОК".
  5. В диалоговом окне "Поиск файла печати" выберите папку и введите имя файла DWFx.
  6. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать файлов DWFx (Краткий справочник)

Печать в DWF-файлы
Печать файлов DWFx
Печать в DXB-файлы
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать файлов DWFx >
Печать файлов DWFx
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл


Печать в DXB-файлы (Понятие)

Печать файлов DWFx
Печать в файлы различных форматов
Печать в файлы растровых форматов
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Печать в DXB-файлы
Понятие Процедура Краткий справочник

Поддержка форматов файла DXB (двоичный файл обмена чертежами) осуществляется с помощью несистемного драйвера файлов DXB. Как правило, эти файлы используются для “уплощения” 3D чертежей и превращения их в 2D.

Формат вывода совместим с командой ИМПОРТД и драйвером ADI DXB, поставлявшимся с более ранними версиями. Данный DXB-драйвер имеет те же ограничения, что и драйвер ADI:

  • Все графические данные в DXB-файле представляются только в виде векторов, задаваемых 16-битовыми целыми числами.
  • Графика в файле формата DXB является монохромной, всем векторным данным присваивается цвет номер 7.
  • Растровые изображения и внедренные OLE-объекты не поддерживаются.
  • Не учитываются веса линий, заданные в свойствах объектов и в стилях печати.
См. также

    • Настройка вывода в файл в документе Руководство по периферийным устройствам


Создание файла DXB (Процедура)

Печать файлов DWFx
На уровень вверх ..
Печать в файлы растровых форматов
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в DXB-файлы >
Печать в DXB-файлы
Понятие Процедура Краткий справочник

Создание файла DXB

  1. Убедитесь в том, что для вывода файла DXB указан драйвер плоттера. (См. пункт Настройка вывода в файл в "Руководстве по драйверам и устройствам").
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  3. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода в формат DXB.
  4. Если необходимо, настройте параметры печати для вывода в DXB-файл.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и ввести имя DXB-файла.
  7. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать в DXB-файлы (Краткий справочник)

Печать файлов DWFx
Печать в DXB-файлы
Печать в файлы растровых форматов
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в DXB-файлы >
Печать в DXB-файлы
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Печать в файлы растровых форматов (Понятие)

Печать в DXB-файлы
Печать в файлы различных форматов
Печать в файлы Adobe PDF
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Печать в файлы растровых форматов
Понятие Процедура Краткий справочник

Несистемным драйвером растровой печати поддерживается несколько форматов, включая Windows BMP, CALS, TIFF, PNG, TGA, PCX и JPEG. Растровые форматы часто используются для создания файлов публикаций рабочего стола.

Все поддерживаемые драйвером растровые форматы, кроме одного, не сохраняют сведения о размерах чертежа в миллиметрах или дюймах. Для растровых изображений известны лишь размеры в точках. Единственным форматом, сохраняющим размеры, является формат Dimensional СALS, который поддерживается некоторыми плоттерами. Если используемый плоттер принимает файлы в формате CALS, то необходимо задать реальные размеры листа и разрешение. Разрешение указывается в точках на дюйм в разделе структуры "Векторная графика" редактора параметров плоттера.

По умолчанию вывод для драйвера растровой печати направлен только в файл. Однако можно выбрать параметр "Показать все порты" на странице "Порты" Мастера установки плоттеров или на вкладке "Порты" окна Редактора параметров плоттера, после чего все имеющиеся на компьютере порты будут доступны для настройки. Если указать вывод на печать через один из портов, то драйвер будет выводить чертеж сначала в файл, а затем файл будет передаваться в назначенный порт. Для вывода чертежа на устройство необходимо убедиться в том, что оно подсоединено к указанному порту и способно принимать и обрабатывать посылаемые данные. Дополнительную информацию по данному вопросу можно найти в документации, прилагаемой к используемому устройству печати.

Тип, размер и глубина цветности растрового изображения определяют размер создаваемого растрового файла. В результате, файлы растровых изображений могут иметь очень большие размеры. В связи с этим, при выводе чертежа следует ограничиваться только теми размерами в точках и глубиной цветности, которые необходимы.

Для растровых чертежей можно задавать цвет фона с помощью диалогового окна дополнительных свойств, вызываемого из редактора параметров плоттера. Все объекты чертежа, цвет которых совпадает с цветом фона, на печати становятся невидимыми.

См. также

    • Настройка вывода в файл в документе Руководство по периферийным устройствам


Создание файла растрового формата (Процедура)

Печать в DXB-файлы
На уровень вверх ..
Печать в файлы Adobe PDF
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы растровых форматов >
Печать в файлы растровых форматов
Понятие Процедура Краткий справочник

Создание файла растрового формата

  1. Убедитесь в том, что для вывода растрового файла указан драйвер плоттера. (См. пункт Настройка вывода в файл в "Руководстве по драйверам и устройствам").
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  3. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода в растровый формат.
  4. Если необходимо, настройте параметры печати для вывода в файл растрового формата.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя растрового файла.
  7. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать в файлы растровых форматов (Краткий справочник)

Печать в DXB-файлы
Печать в файлы растровых форматов
Печать в файлы Adobe PDF
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы растровых форматов >
Печать в файлы растровых форматов
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТБМП

Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)

ЭКСПОРТДЖ

Сохранение выбранных объектов в файле в формате JPEG

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ЭКСПОРТПНГ

Сохранение выбранных объектов в файле в формате Portable Network Graphics

ЭКСПОРТТИФ

Сохранение выбранных объектов в файле формата TIFF

Системные переменные

RASTERDPI

Управление размером листа и масштабом печати при переключении с устройств вывода размерных файловых форматов на устройства вывода безразмерных файловых форматов и наоборот

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Печать в файлы Adobe PDF (Понятие)

Печать в файлы растровых форматов
Печать в файлы различных форматов
Печать в файлы Adobe PostScript
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Печать в файлы Adobe PDF
Понятие Процедура Краткий справочник

С помощью драйвера для преобразования формата DWG в PDF можно создавать файлы формата Adobe® Portable Document Format (PDF) на основе чертежей.

Формат Adobe® Portable Document Format (PDF) является стандартом для обмена информацией в электронном виде. Файлы PDF легко распространяются для просмотра и печати в программе Adobe Reader, которую можно получить бесплатно на веб-сайте компании Adobe. Применяя файлы PDF, можно совместно использовать чертежи практически с любым пользователем.

Как и файлы DWF6, файлы PDF формируются, для сохранения точности, в формате с векторной основой. Чертежи, преобразованные в формат PDF, можно без труда распространять для просмотра и печати из приложения Adobe Reader 6-й версии или более поздней.

Для настройки параметров вывода следует воспользоваться диалоговым окном дополнительных свойств, который можно вызвать из редактора параметров плоттера. Для этого необходимо перейти на вкладку "Параметры устройства и документа" и в области структуры выбрать "Дополнительные свойства". Затем в группе "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".

Результирующий файл PDF можно адаптировать, задавая разрешение. В диалоговом окне дополнительных свойств редактора параметров печатающего устройства можно задать разрешение для векторных и растровых изображений в диапазоне от 150 до 4800 точек на дюйм максимум. Можно также указать пользовательские разрешения для векторного, градиентного, цветного и черно-белого результирующего файла.

ПримечаниеХотя прозрачные объекты и маскировки правильно отображаются в средстве просмотра файлов PDF, они не распечатываются с той же точностью воспроизведения при использовании параметров печати по умолчанию. Если в чертеже имеются прозрачные объекты, может потребоваться регулировка некоторых параметров в программе Adobe Acrobat. В программе Adobe Acrobat задайте для параметра "Выравнивание прозрачности" значение "Печатать как изображение" или уменьшите значение параметра "Баланс растровый/векторный". Дополнительные сведения см. в документации Adobe.
См. также

    • Настройка вывода в файл в документе Руководство по периферийным устройствам


Печать в файлы Adobe PDF (Процедура)

Печать в файлы растровых форматов
На уровень вверх ..
Печать в файлы Adobe PDF
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы Adobe PDF >
Печать в файлы Adobe PDF
Понятие Процедура Краткий справочник

Печать файла PDF

Печать файла PDF в альбомной ориентации


Печать файла PDF (Процедура)

Печать в файлы Adobe PDF
На уровень вверх ..
Печать в файлы Adobe PDF
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы Adobe PDF >
Печать в файлы Adobe PDF
Понятие Процедура Краткий справочник

Печать файла PDF

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать", в группе "Принтер/плоттер" в поле "Имя" выберите из списка имен драйвер DWG to PDF.pc3.
  3. Если необходимо, настройте параметры печати для вывода в файл PDF.
  4. Нажмите "ОК".
  5. В диалоговом окне "Поиск файла чертежа" выберите местоположение или введите имя PDF-файла.
  6. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать файла PDF в альбомной ориентации (Процедура)

Печать в файлы Adobe PDF
На уровень вверх ..
Печать в файлы Adobe PostScript
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы Adobe PDF >
Печать в файлы Adobe PDF
Понятие Процедура Краткий справочник

Печать файла PDF в альбомной ориентации

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать", в группе "Принтер/плоттер" в поле "Имя" выберите из списка имен драйвер DWG to PDF.pc3.
  3. Из списка "Формат" выберите формат листа, больший размер которого указан первым. Например, ANSI A (11,00 x 8,50 дюймов)
  4. Нажмите "ОК".
  5. В диалоговом окне "Поиск файла чертежа" выберите местоположение или введите имя PDF-файла.
  6. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать в файлы Adobe PDF (Краткий справочник)

Печать в файлы растровых форматов
Печать в файлы Adobe PDF
Печать в файлы Adobe PostScript
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы Adobe PDF >
Печать в файлы Adobe PDF
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Печать в файлы Adobe PostScript (Понятие)

Печать в файлы Adobe PDF
Печать в файлы различных форматов
Создание файлов вывода на печать
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Печать в файлы Adobe PostScript
Понятие Процедура Краткий справочник

Использование драйвера Adobe PostScript позволяет в файлах чертежей формата DWG использовать элементы постраничной верстки и средства для просмотра. Примером может служить формат Adobe Acrobat Portable Document Format (PDF).

Для вывода чертежей на принтеры, поддерживающие формат PostScript, или в PostScript-файлы можно использовать несистемный драйвер PostScript. Для вывода на принтеры следует указывать формат PS, а для вывода в файлы - EPS. При печати непосредственно на PostScript-устройство автоматически выбирается формат PS. Если же для вывода выбран файл, который затем планируется распечатывать на принтере, то пользователь должен сам установить формат PS.

Для настройки параметров вывода следует воспользоваться диалоговым окном дополнительных свойств, который можно вызвать из редактора параметров плоттера. Для этого необходимо перейти на вкладку "Параметры устройства и документа" и в области структуры выбрать "Дополнительные свойства". Затем в группе "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".

Драйвер поддерживает три разновидности формата PostScript.

  • Level 1: используется большинством плоттеров.
  • Level 1.5: используется для плоттеров с поддержкой цветной печати.
  • Level 2: если используемый плоттер поддерживает PostScript Level 2, то имеется возможность существенно уменьшить размер выходных файлов и увеличить скорость вывода на печать.

Опции "Использовать двоичный код (2-го уровня)" и "Сжатие растровых изображений" в диалоговом окне "Дополнительные свойства" позволяют уменьшить размер выходного файла и ускорить процесс печати на устройствах, поддерживающих эти функции. При возникновении проблем с печатью можно попытаться отключить все опции. В случае успеха выполненных действий можно повторно выполнять печать, каждый раз включая по одной опции, с тем, чтобы определить те опции, которые поддерживаются принтером.

Некоторые издательские системы поддерживают только PostScript Level 1. Поэтому, если возникают проблемы при работе с EPS-файлами, следует попытаться выбрать более простой тип PostScript и отключить параметры оптимизации формата, как это было описано выше.

Имеется возможность включения в EPS-файлы графических образцов изображений. Это значительно увеличивает размеры файлов, однако позволяет быстро просматривать эти файлы с помощью многих приложений. В Windows для предварительного просмотра используется формат WMF; для Macintosh и других платформ используется формат EPSF.

ПримечаниеВключение образцов для предварительного просмотра в обоих форматах может привести к увеличению размера результирующего файла в три раза.
См. также

    • Экспорт файлов формата PostScript

    • Настройка вывода в файл в документе Руководство по периферийным устройствам


Печать в файл PostScript (Процедура)

Печать в файлы Adobe PDF
На уровень вверх ..
Создание файлов вывода на печать
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы Adobe PostScript >
Печать в файлы Adobe PostScript
Понятие Процедура Краткий справочник

Печать в файл PostScript

  1. Убедитесь в том, что для вывода файла PostScript указан драйвер плоттера. (См. пункт Настройка вывода в файл в "Руководстве по драйверам и устройствам").
  2. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  3. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода в формат PostScript.
  4. Если необходимо, настройте параметры печати для вывода в PostScript-файл.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя PostScript-файла.
  7. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Печать в файлы Adobe PostScript (Краткий справочник)

Печать в файлы Adobe PDF
Печать в файлы Adobe PostScript
Создание файлов вывода на печать
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Печать в файлы Adobe PostScript >
Печать в файлы Adobe PostScript
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание файлов вывода на печать (Понятие)

Печать в файлы Adobe PostScript
Печать в файлы различных форматов
Публикация чертежей
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов >
Создание файлов вывода на печать
Понятие Процедура Краткий справочник

Используя любую конфигурацию плоттера, можно создавать файлы вывода на печать, которые в дальнейшем могут обрабатываться приложениями для вывода данных.

Например, файлы форматов HP-GL и HP-GL/2 используются в качестве промежуточных файлов различными программными средствами разработки, а также для хранения данных и использования многими устройствами вывода.

Драйвер несистемного устройства HP-GL поддерживает формат HP-GL (Hewlett-Packard Graphics Language), широко используемый перьевыми плоттерами и сохраняющий только векторную графику. Растровые объекты драйвером устройства HP-GL не поддерживаются.

Драйвер несистемного устройства HP-GL/2 объединяет возможности перьевых плоттеров формата HP-GL/2 и струйных плоттеров. Этот драйвер является базовым и не оптимизирован для работы со специфическими устройствами. Например, он не посылает команд PJL устройству, как это делает драйвер фирмы Hewlett-Packard. Драйвер HP-GL/2 поддерживает устаревшие графопостроители и более новые устройства других производителей, не только фирмы Hewlett-Packard.

См. также

    • Информация о настройке конкретных моделей устройств в документе Руководство по периферийным устройствам


Создание файлов вывода на печать (Процедура)

Печать в файлы Adobe PostScript
На уровень вверх ..
Создание файлов вывода на печать
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Создание файлов вывода на печать >
Создание файлов вывода на печать
Понятие Процедура Краткий справочник

Процедура создания файла печати (PLT)

Процедура создания командного файла для буферизации данных перед выводом на печать

Процедура печати из файла печати (PLT) посредством командного файла


Процедура создания файла печати (PLT) (Процедура)

Создание файлов вывода на печать
На уровень вверх ..
Создание файлов вывода на печать
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Создание файлов вывода на печать >
Создание файлов вывода на печать
Понятие Процедура Краткий справочник

Процедура создания файла печати (PLT)

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В диалоговом окне "Печать" в группе "Принтер/Плоттер" в поле "Имя" выберите из списка драйвер вывода на плоттер.
    ПримечаниеНеобходимым условием создания допустимого файла PLT является правильная настройка плоттера в качестве устройства вывода.
  3. Если имеется такая возможность, установите флажок "Печать в файл".
  4. Если необходимо, настройте параметры печати для вывода в файл.
  5. Нажмите "ОК".
  6. В диалоговом окне "Поиск файла чертежа" задайте путь к файлу и введите имя файла чертежа.
  7. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Процедура создания командного файла для буферизации данных перед выводом на печать (Процедура)

Создание файлов вывода на печать
На уровень вверх ..
Создание файлов вывода на печать
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Создание файлов вывода на печать >
Создание файлов вывода на печать
Понятие Процедура Краткий справочник

Процедура создания командного файла для буферизации данных перед выводом на печать

Файлы печати предназначены для работы с программным обеспечением буферизации данных; их можно также передать в центр обслуживания для вывода на печать. Вывод файлов PLT можно запустить с помощью простого командного файла.

  1. Откройте текстовый редактор и сохраните командный файл в той папке, где хранятся файлы PLT.
  2. Присвойте командному файлу имя, например, MySpooler.bat.
  3. Добавьте к командному файлу одну строку следующего вида:

    copy %1 \\сервер\принтер

    Параметр %1 автоматически заменяется именем файла .plt, который передается устройству вывода.

    СоветЕсли устройство вывода подключено непосредственно к компьютеру, вместо пути к серверу печати можно указать порт принтера, например, LPT1.
  4. Сохраните командный файл и закройте текстовый редактор.


Процедура печати из файла печати (PLT) посредством командного файла (Процедура)

Создание файлов вывода на печать
На уровень вверх ..
Общие сведения о публикации
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Создание файлов вывода на печать >
Создание файлов вывода на печать
Понятие Процедура Краткий справочник

Процедура печати из файла печати (PLT) посредством командного файла

При выполнении этой процедуры используется командный файл, созданный в ходе выполнения процедуры Процедура создания командного файла для буферизации данных перед выводом на печать.

  1. Откройте окно командной строки и введите команду перехода к папке, содержащей файл PLT и командный файл буферизации данных.
  2. В командной строке введите следующую команду:

    MySpooler.bat MyDrawing.plt

    Здесь MySpooler.bat - имя созданного ранее командного файла, а MyDrawing.plt - имя файла печати.

Выполняется копирование файла PLT на устройство вывода и создание чертежа.


Создание файлов вывода на печать (Краткий справочник)

Печать в файлы Adobe PostScript
Создание файлов вывода на печать
Коротко о публикации
Печать и публикация чертежей > Вывод чертежей на печать > Печать в файлы различных форматов > Создание файлов вывода на печать >
Создание файлов вывода на печать
Понятие Процедура Краткий справочник

Команды

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация чертежей

Создание файлов вывода на печать
Печать и публикация чертежей
Коротко о публикации
Печать и публикация чертежей >
Публикация чертежей

Публикацию целой подшивки легко выполнить в Диспетчере подшивок либо в виде набора чертежей на бумаге, либо в электронном виде как единого многолистового файла DWF или DWFx.

Темы в этом разделе

  • Коротко о публикации

    С помощью диалогового окна "Публикация" можно на основе целого набора чертежей одним нажатием кнопки мыши получить в бумажном или электронном виде набор готовых чертежей.

  • Общие сведения о публикации

    Публикация предлагает удобный способ получения набора бумажных чертежей или их электронного аналога.

  • Создание и изменение набора чертежей для публикации

    Предусмотрена возможность группировки листов чертежа для публикации с выводом на плоттер, в файлы печати или в файл DWF или DWFx. Полученный набор чертежей можно сохранять и редактировать.

  • Вывод набора для публикации на плоттер или в файл печати

    Набор чертежей можно при публикации вывести на печатающее устройство или в файл печати.

  • Публикация электронного набора чертежей

    Имеется возможность публиковать электронный набор чертежей в виде файла DWF или DWFx.

  • Публикация подшивки

    С помощью Диспетчера подшивок можно опубликовать целую подшивку листов, группу листов из подшивки или отдельный лист. В Диспетчере подшивок публикация подшивки выполняется быстрее, чем с помощью диалогового окна "Публикация".

  • Повторная публикация набора чертежей

    Существует возможность повторной публикации листов чертежей, списки которых были ранее сохранены в формате описаний наборов чертежей (DSD).

  • Просмотр опубликованного электронного набора чертежей

    Просматривать и печатать опубликованный электронный набор чертежей можно с помощью Autodesk Design Review.

  • Настройка параметров публикации

    Можно настраивать такие параметры процесса публикации, как папка файла вывода, тип DWF-файла, именование листов в многолистовом DWF, защита DWF-файла паролем и включение в него информации о слоях. Кроме того, пользователь может задать, какие типы информации будут открыты в публикуемых файлах DWF и DWFx и следует ли публиковать чертежи в автоматическом режиме.

  • Публикация 3D DWF

    Предусмотрена возможность создания и публикации файлов трехмерных моделей в формате DWF или DWFx, а также их просмотра в Autodesk Design Review.

  • Настройка драйвера DWF6

    Изменение настроек драйвера публикаций DWF6 ePlot требуется довольно редко. Но если это действительно нужно, то можно воспользоваться окном свойств этого драйвера для оптимизации вывода. Здесь можно настроить глубину цветности, экранное разрешение, сжатие файла, параметры обработки шрифтов, параметры перьев и другие опции. При создании DWF6-файлов используется файл параметров плоттера, определяющий некоторые особенности формата DWF6. Для печати в файлы формата DWF6 необходимо использовать DWF6 ePlot.pc3.

  • Настройка драйвера DWFx (дополнительная)

    Изменения в файл параметров плоттера DWFx ePlot вносятся в диалоговом окне "Свойства DWFx ePlot (совместимо с XPS)". Например, можно задать такие параметры, как глубина цвета, экранное разрешение и пр.


Коротко о публикации (Понятие)

Публикация чертежей
Публикация чертежей
Общие сведения о публикации
Печать и публикация чертежей > Публикация чертежей >
Коротко о публикации
Понятие Краткий справочник

С помощью диалогового окна "Публикация" можно на основе целого набора чертежей одним нажатием кнопки мыши получить в бумажном или электронном виде набор готовых чертежей.

Наборы чертежей являются основным итогом работы большинства проектных коллективов. Создание набора чертежей с дальнейшим рассмотрением его в различных инстанциях может оказаться довольно долгим и сложным процессом.

С помощью диалогового окна "Публикация" можно на основе целого набора чертежей одним нажатием кнопки мыши получить в бумажном или электронном виде набор готовых чертежей.

Электронные наборы чертежей сохраняются в виде файлов DWF или DWFx. Просмотр и печать файлов DWF или DWFx можно выполнить с помощью приложения Autodesk Design Review.

Для печати отдельного чертежа используется диалоговое окно "Печать".

См. также

    • Коротко о процессе печати


Коротко о публикации (Краткий справочник)

Создание файлов вывода на печать
Коротко о публикации
Общие сведения о публикации
Печать и публикация чертежей > Публикация чертежей > Коротко о публикации >
Коротко о публикации
Понятие Краткий справочник

Команды

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Общие сведения о публикации (Понятие)

Коротко о публикации
Публикация чертежей
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Публикация предлагает удобный способ получения набора бумажных чертежей или их электронного аналога.

Электронный набор чертежей - это аналог набора чертежей, распечатанных на бумаге. Создание электронного набора чертежей выполняется путем публикации чертежей в файл DWF или DWFx.

С помощью Диспетчера подшивок можно опубликовать целую подшивку листов. Публикация в едином многолистовом файле формата DWF или DWFx позволяет одним нажатием кнопки мыши создать готовый электронный набор чертежей.

Набор бумажных чертежей создается публикацией каждого листа подшивки на заданном в его параметрах плоттере.

С помощью диалогового окна "Публикация" можно не только собрать в одно целое набор различных чертежей для публикации, но и сохранить их перечень в файле описаний наборов чертежей формата DSD (Drawing Set Descriptions). Этот набор для публикации можно адаптировать под нужды конкретного пользователя, добавляя и удаляя листы по мере развития проекта. Созданный в диалоговом окне "Публикация" перечень листов можно опубликовать любым из следующих способов:

  • На плоттер, заданный в параметрах каждого листа подшивки (включая чертежи, которые необходимо вывести в файл).
  • Единый многолистовой файл DWF или DWFx, содержащий как 2D, так и 3D объекты
  • Несколько одностраничных файлов DWF или DWFx, содержащих как 2D, так и 3D объекты.

Используя процедуру "3D публикация DWF", имеется возможность создания и публикации в файлы формата DWF трехмерных моделей и просмотра их в Autodesk Design Review.

Подробнее о публикации файлов 3D DWF см. описание процедуры 3D публикация DWF.

Публикация электронного набора чертежей в виде файла DWF или DWFx экономит время и увеличивает производительность, поскольку позволяет создавать точное и сжатое представление чертежей в удобном для просмотра и распространения файле. Она также позволяет обеспечивать целостность и взаимосвязь исходных чертежей.

Файлы DWF, когда в них осуществляется публикация, создаются в формате на основе векторной графики (кроме вставок растровых изображений), поддерживающей точность отображения.

Файлы DWFx создаются на основе формата XPS Microsoft. Файлы DWFx представляют собой zip-файлы и содержат метаданные. Просмотреть метаданные можно только средствами приложения Autodesk Design Review.

Обычную графику можно просматривать и печатать как в Autodesk Design Review, так и в Internet Explorer 7. Просмотреть метаданные DWFx можно только в приложении Autodesk Design Review.

Просмотр и печать файлов DWF или DWFx можно выполнить с помощью приложения Autodesk Design Review. Файлы DWF и DWFx могут распространяться по электронной почте или на CD, размещаться на FTP-сайтах и web-сайтах проектов.

Можно задавать свойства блоков и атрибуты, которые будут доступны для пользователей приложения Autodesk Design Review. Например, можно опубликовать для водопроводного подрядчика файл DWF или DWFx, содержащий информацию об атрибутах блоков указанной в чертеже водопроводной арматуры. В такой же подшивке для подрядчика по электротехнике можно указать только данные атрибута блока об осветительной арматуре.

По умолчанию задания публикации выполняются в фоновом режиме, что позволяет пользователю сразу же вернуться к работе над своими чертежами. Задания публикации выполняются по очереди (не могут выполняться одновременно). Для проверки статуса задания, выполняющегося в фоновом режиме, достаточно навести курсор на значок плоттера в правом углу строки состояния. Можно также просмотреть подробные сведения обо всех заданиях, которые были опубликованы или напечатаны в ходе текущего сеанса.

См. также

    • Публикация, комплектование и архивация подшивок

    • Задание настроек параметров листа

    • Публикация 3D DWF


Общие сведения о публикации (Процедура)

Создание файлов вывода на печать
Общие сведения о публикации
Общие сведения о публикации
Печать и публикация чертежей > Публикация чертежей > Общие сведения о публикации >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Проверка статуса задания на публикацию, выполнявшегося в фоновом режиме

Отмена всех или части заданий на публикацию, выполняющихся в фоновом режиме

Просмотр подробных сведений о задании на публикацию

Включение и выключение фонового режима публикации выполняется в диалоговом окне "Настройка"

Для включения и выключения фонового режима публикации используется диалоговое окно "Публикация".


Проверка статуса задания на публикацию, выполнявшегося в фоновом режиме (Процедура)

Общие сведения о публикации
Общие сведения о публикации
Общие сведения о публикации
Печать и публикация чертежей > Публикация чертежей > Общие сведения о публикации >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Проверка статуса задания на публикацию, выполнявшегося в фоновом режиме

  • Поместите курсор на значок плоттера в строке состояния. Всплывающая подсказка отображает статус задания.


Отмена всех или части заданий на публикацию, выполняющихся в фоновом режиме (Процедура)

Общие сведения о публикации
Общие сведения о публикации
Общие сведения о публикации
Печать и публикация чертежей > Публикация чертежей > Общие сведения о публикации >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Отмена всех или части заданий на публикацию, выполняющихся в фоновом режиме

  • Нажмите правую кнопку мыши на значке в строке состояния. Выберите "Отмена задания для листа" <имя листа> или "Прервать все задание".


Просмотр подробных сведений о задании на публикацию (Процедура)

Общие сведения о публикации
Общие сведения о публикации
Общие сведения о публикации
Печать и публикация чертежей > Публикация чертежей > Общие сведения о публикации >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Просмотр подробных сведений о задании на публикацию

  1. Выполните одно из следующих действий:
    • Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Подробности о виде". В командной строке введите "подробностипп".
    • Нажмите кнопку мыши на значке печатающего устройства в строке состояния.
  2. В диалоговом окне "Подробности о печати/публикации" просмотрите сведения о заданиях на публикацию.
Ввод команды: ПОДРОБНОСТИПП
Контекстное меню:Нажмите правую кнопку мыши на значке плоттера. Выберите "Подробности о печати/публикации".


Включение и выключение фонового режима публикации выполняется в диалоговом окне "Настройка" (Процедура)

Общие сведения о публикации
Общие сведения о публикации
Общие сведения о публикации
Печать и публикация чертежей > Публикация чертежей > Общие сведения о публикации >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Включение и выключение фонового режима публикации выполняется в диалоговом окне "Настройка"

  1. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Печать/Публикация" в группе опций "Параметры фоновой обработки" установите или сбросьте для настройки "Поддержка фонового вывода" флажки "Печать" и "Публикация".
  3. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Для включения и выключения фонового режима публикации используется диалоговое окно "Публикация". (Процедура)

Общие сведения о публикации
Общие сведения о публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Общие сведения о публикации >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Для включения и выключения фонового режима публикации используется диалоговое окно "Публикация".

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В группе "Управление публикацией" установите или снимите флажок "Публикация в фоновом режиме".
Ввод команды: ПУБЛ


Общие сведения о публикации (Краткий справочник)

Коротко о публикации
Общие сведения о публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Общие сведения о публикации >
Общие сведения о публикации
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

BACKGROUNDPLOT

Управление включением/отключением режима фонового вывода для операций печати и публикации

PUBLISHCOLLATE

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание и изменение набора чертежей для публикации (Понятие)

Общие сведения о публикации
Публикация чертежей
Вывод набора для публикации на плоттер или в файл печати
Печать и публикация чертежей > Публикация чертежей >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Предусмотрена возможность группировки листов чертежа для публикации с выводом на плоттер, в файлы печати или в файл DWF или DWFx. Полученный набор чертежей можно сохранять и редактировать.

Предусмотрена возможность группировки листов чертежа для публикации с выводом на плоттер, в файлы печати или в файл DWF или DWFx. Набор для публикации можно адаптировать под нужды конкретного пользователя, добавляя, удаляя, меняя местами, копируя и переименовывая листы по мере развития проекта.

Набор чертежей можно распечатать непосредственно на бумаге, в одном или в нескольких файлах DWF, а также в одном или в нескольких файлах DWFx. Файлы DWF и DWFx могут распространяться по электронной почте, на CD, размещаться на FTP-сайтах и web-сайтах проектов. Описание набора чертежей, собранных для публикации, можно сохранить в файле формата DSD (Drawing Set Descriptions).


Создание и изменение набора чертежей для публикации (Процедура)

Общие сведения о публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Создание набора чертежей для публикации

Добавление листов из чертежа в набор для публикации

Добавление листов из DSD-файла в набор для публикации

Исключение листа из набора для публикации

Исключение всех листов из набора для публикации

Изменение порядка следования листов в наборе для публикации

Копирование листов в наборе для публикации

Переименование листов в наборе для публикации

Изменение набора настроек листа в наборе для публикации

Изменение набора настроек одного или нескольких листов в наборе для публикации

Импорт набора параметров листов из другого чертежа для применения к публикуемому листу

Публикация нескольких листов чертежа


Создание набора чертежей для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Создание набора чертежей для публикации

  1. Откройте чертеж. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране появляется диалоговое окно "Публикация". Если выбрана опция "Включать вкладки листов" (в контекстном меню или в диалоговом окне "Публикация"), то все разметки листа текущего чертежаперечисляются в списке листов.

  2. Для редактирования списка листов в диалоговом окне "Публикация" требуется выполнить одно из следующих действий:
    • Добавление листов. Для того чтобы добавить листы из других чертежей, нажмите кнопку "Добавить листы" (или перетащить чертежи с рабочего стола). В диалоговом окне "Выбор чертежей" выберите чертежи. Для добавления их в список листов диалогового окна "Публикация" нажмите "Выбрать". Каждая разметка листа чертежа становится отдельным листом в списке диалогового окна. Отдельные листы, которые не требуется включать в набор чертежей, можно удалить. Публикация возможна только для инициализированных разметок листов (т.е. тех листов, в параметрах которых задан любой формат листа, отличный от 0 x 0).
    ПримечаниеДля включения всех разметок листа при добавлении листов в набор чертежей следует задать опцию "Включать вкладки листов" в контекстном меню или в диалоговом окне "Публикация".
    • Добавление разметок листов модели. Если включить неинициализированную вкладку модели (формат листа для которой не задан или имеет размеры 0 x 0 ), она будет иметь статус "Разметка листа не инициализирована" в поле "Статус" списка листов. Для вывода на печать такой вкладки следует выбрать в качестве переопределения набор параметров листа из раскрывающегося списка в столбце "Параметры листа" в списке листов диалогового окна "Публикация".
    ПримечаниеДля включения модели при добавлении листов в набор чертежей следует убедиться, что в контекстном меню или в диалоговом окне "Публикация" включена опция "Включать вкладку модели".
    • Исключение листов. Чтобы удалить листы из списка, выберите в этом списке один или несколько листов. Нажмите кнопку "Исключение листов". Для исключения всех листов, нажмите правую кнопку мыши на выбранных листах. Выберите "Исключить все".
    • Изменение порядка листов. Чтобы изменить порядок листов, сдвинув их выше или ниже на одну позицию списка, выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз". Просмотр и печать листов набора чертежей выполняется в том порядке, в котором они расположены в списке.
    • Переименование листов. Чтобы переименовать лист, выберите его в списке и нажмите правую кнопку мыши. Выберите "Переименовать лист". Введите новое имя листа.
    • Изменение набора параметров листа. Для изменения набора параметров разметки листа выберите лист, в столбце "Параметры листа" из раскрывающегося списка выберите именованный набор параметров или же выберите один или несколько листов и нажмите правую кнопку мыши. Выберите "Изменение набора параметров листа". В списке "Параметры листа" выберите набор параметров или "Импорт" для импорта набора параметров из другого чертежа или шаблона. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, обладающий одним или несколькими наборами параметров. Нажмите кнопку "Импорт". В списке "Параметры листа" выберите требуемый набор параметров.
    ПримечаниеИзмените набор параметров листа, соответствующий каждой разметке, в зависимости желаемого результата. Наборы параметров листов пространства модели могут применяться только к листам пространства модели; наборы параметров пространства листов могут применяться только к листам пространства листов.
    • Копирование листов. Чтобы скопировать один или несколько листов чертежей, выберите листы из списка и нажмите правую кнопку мыши. Выберите "Копировать выбранные листы". Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа. Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1). При каждом новом копировании одного и того же листа число n будет увеличиваться на 1. Создавая копии листа, можно для одного и того же листа получить различные наборы параметров листа и разные настройки.
  3. Когда список листов чертежа будет скомпонован и настроен требуемым образом, нажмите кнопку "Сохранить список листов".
  4. В диалоговом окне "Сохранение списка" в поле "Имя файла" введите имя для данного списка. Нажмите кнопку "Сохранить".

    Список сохраняется в DSD-файле (файле описания наборов чертежей).

Панель:Стандартный
Ввод команды: ПУБЛ


Добавление листов из чертежа в набор для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Добавление листов из чертежа в набор для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" нажмите кнопку "Добавить листы".
  3. В диалоговом окне "Выбор чертежей" выберите чертежи. Для добавления их в список листов диалогового окна "Публикация" нажмите "Выбрать".
    ПримечаниеМожно также для добавления листов в список перетащить чертежи с рабочего стола в окно "Публикация".

    Все разметки листов чертежа становятся отдельными листами в списке диалогового окна.

    Листы, которые не требуется включать в набор, следует исключить из списка. Перед публикацией разметки листа должны быть инициализированы. (Разметка листа инициализирована, если в наборе параметров листа для формата бумаги заданы размеры, отличные от 0 x 0).

Панель:Стандартный
Ввод команды: ПУБЛ


Добавление листов из DSD-файла в набор для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Добавление листов из DSD-файла в набор для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" нажмите кнопку "Загрузить список листов".
  3. В диалоговом окне "Загрузка списка листов" выберите файл DSD. Нажмите "Загрузить".
  4. В диалоговом окне "Замена или добавление" нажмите кнопку "Заменить" для замены текущих листов в DSD-файле или нажмите "Добавить" для добавления листов из DSD-файла в список листов в диалоговом окне "Публикация".
Панель:Стандартный
Ввод команды: ПУБЛ


Исключение листа из набора для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Исключение листа из набора для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что все листы, которые необходимо исключить, содержатся в списке.
  3. В группе "Лист" выберите один или несколько листов, подлежащих исключению. Нажмите кнопку "Исключение листов".
Панель:Стандартный
Ввод команды: ПУБЛ


Исключение всех листов из набора для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Исключение всех листов из набора для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что все листы, которые необходимо исключить, содержатся в списке.
  3. Нажмите правую кнопку мыши на выбранном наборе. Выберите "Исключить все".
    ПримечаниеОтменить операцию исключения всех листов нельзя.
Панель:Стандартный
Ввод команды: ПУБЛ


Изменение порядка следования листов в наборе для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Изменение порядка следования листов в наборе для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что все листы, порядок которых необходимо изменить, содержатся в списке.
  3. Выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз".
    ПримечаниеПросмотр и вывод на печать листов, входящих в набор для публикации, осуществляется в порядке следования листов в списке диалогового окна "Публикация".
Панель:Стандартный
Ввод команды: ПУБЛ


Копирование листов в наборе для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Копирование листов в наборе для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что листы, подлежащие копированию, содержатся в списке.
  3. Нажмите правую кнопку мыши на выбранном наборе. Выберите "Копировать выбранные листы".

    Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа.

    Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1).

    При каждом новом копировании одного и того же листа число n будет увеличиваться на 1. Создавая копии листа, можно для одного и того же листа получить различные наборы параметров листа и разные настройки.

Панель:Стандартный
Ввод команды: ПУБЛ


Переименование листов в наборе для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Переименование листов в наборе для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что листы, подлежащие переименованию, содержатся в списке.
  3. Выберите лист из списка а затем выполнить одно из следующих действий:
    • Нажмите правую кнопку мыши на выбранном наборе. Выберите "Переименовать лист".
    • Нажмите F2.
  4. Введите новое имя листа.
Панель:Стандартный
Ввод команды: ПУБЛ


Изменение набора настроек листа в наборе для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Изменение набора настроек листа в наборе для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что лист, для которого необходимо изменить набор параметров листа, содержится в списке.
  3. Выберите лист из списка.
  4. В столбце "Параметры листа" выберите набор параметров для применения к листу.
Панель:Стандартный
Ввод команды: ПУБЛ


Изменение набора настроек одного или нескольких листов в наборе для публикации (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Изменение набора настроек одного или нескольких листов в наборе для публикации

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что листы, для которых необходимо изменить наборы параметров листов, содержатся в списке.
  3. Выберите один или несколько листов из списка.
  4. Нажмите правую кнопку мыши на выбранном наборе. Выберите "Изменение набора параметров листа".
  5. В столбце "Параметры листа" выберите набор параметров для применения к листам.
    ПримечаниеИзмените набор параметров листа, соответствующий каждой разметке, в зависимости желаемого результата. Наборы параметров листов пространства модели могут применяться только к листам пространства модели; наборы параметров пространства листов могут применяться только к листам пространства листов.
Панель:Стандартный
Ввод команды: ПУБЛ


Импорт набора параметров листов из другого чертежа для применения к публикуемому листу (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Импорт набора параметров листов из другого чертежа для применения к публикуемому листу

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" убедитесь в том, что лист, для которого необходимо изменить набор параметров листа, содержится в списке.
  3. Выберите лист из списка.
  4. В столбце "Параметры листа" выберите из раскрывающегося списка "Импорт".
  5. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, из которого будут импортированы наборы параметров листов. Нажмите кнопку "Импорт".
Панель:Стандартный
Ввод команды: ПУБЛ


Публикация нескольких листов чертежа (Процедура)

Создание и изменение набора чертежей для публикации
Создание и изменение набора чертежей для публикации
Вывод набора для публикации на плоттер или в файл печати
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Публикация нескольких листов чертежа

  1. В области чертежа выберите вкладку разметки листа для публикации.
  2. Удерживая нажатой клавишу CTRL, указать мышью другие вкладки разметок листов, которые требуется опубликовать.
  3. Щелкните правой кнопкой мыши на одной из вкладок разметок листов. Выбрать в контекстном меню "Опубликовать выбранные листы".
  4. В диалоговом окне "Публикация" задайте, как требуется, настройки выбранных разметок листов.
  5. Нажмите кнопку "Опубликовать".
Ввод команды: ПУБЛ


Создание и изменение набора чертежей для публикации (Краткий справочник)

Общие сведения о публикации
Создание и изменение набора чертежей для публикации
Вывод набора для публикации на плоттер или в файл печати
Печать и публикация чертежей > Публикация чертежей > Создание и изменение набора чертежей для публикации >
Создание и изменение набора чертежей для публикации
Понятие Процедура Краткий справочник

Команды

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вывод набора для публикации на плоттер или в файл печати (Понятие)

Создание и изменение набора чертежей для публикации
Публикация чертежей
Публикация электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей >
Вывод набора для публикации на плоттер или в файл печати
Понятие Процедура Краткий справочник

Набор чертежей можно при публикации вывести на печатающее устройство или в файл печати.

Существует возможность компоновки листов чертежей в адаптируемый набор чертежей и его публикации с выводом каждого листа на заданное для него устройство печати или в файл печати. Если в качестве устройства печати указан плоттер, то результатом вывода на печать будет набор бумажных чертежей.

Если задана печать в файл, то листы сохраняются в файлах, расположение которых зависит от настроек в диалоговом окне "Параметры публикации". Файл печати для каждого из листов сохраняется под тем же именем, что и лист, с соответствующим расширением (например, .plt, .jpg или .bmp). По умолчанию расположение можно изменить в диалоговом окне "Настройка" на вкладке "Печать/Публикация" в группе опций "Печать в файл".

См. также

    • Настройка параметров публикации


Вывод набора для публикации на плоттер или в файл печати (Процедура)

Создание и изменение набора чертежей для публикации
Вывод набора для публикации на плоттер или в файл печати
Публикация электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Вывод набора для публикации на плоттер или в файл печати >
Вывод набора для публикации на плоттер или в файл печати
Понятие Процедура Краткий справочник

Вывод набора для публикации на плоттер или в файл печати

  1. Откройте чертеж. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" в списке листов чертежа отображаются его вкладки. Создание набора для публикации путем выполнения одного из следующих действий:
    • Добавление листов. Для того чтобы добавить листы из других чертежей, нажмите кнопку "Добавить листы" (или перетащить чертежи с рабочего стола). В диалоговом окне "Выбор чертежей" выберите чертежи. Для добавления их в список листов диалогового окна "Публикация" нажмите "Выбрать". Каждая разметка листа чертежа становится отдельным листом в списке диалогового окна. Отдельные листы, которые не требуется включать в набор чертежей, можно удалить. Публикация возможна только для инициализированных разметок листов (т.е. тех листов, в параметрах которых задан любой формат листа, отличный от 0 x 0).
    ПримечаниеДля включения всех разметок листа при добавлении листов в набор чертежей следует убедиться в том, что задана опция "Включать вкладки листов" в контекстном меню или в диалоговом окне "Публикация".
    • Добавление разметок листов модели. Если включена неинициализированная вкладка разметки листа модели (формат листа для которой не задан или имеет размеры 0 x 0 ), она будет иметь в статус "Лист не инициализирован" в поле "Статус" списка листов. Эта разметка может быть напечатана, если заменить для нее набор параметров листа.
    ПримечаниеДля включения вкладки разметки листа модели при добавлении листов в набор чертежей следует убедиться, что в контекстном меню включена опция "Включать вкладку модели".
    • Исключение листов. Чтобы удалить листы из списка, выберите в этом списке один или несколько листов. Нажмите кнопку "Исключение листов". Чтобы исключить все листы, нажмите правую кнопку мыши. Выберите "Исключить все".
    • Изменение порядка листов. Чтобы изменить порядок листов, сдвинув их выше или ниже на одну позицию списка, выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз". Просмотр и печать листов набора чертежей выполняется в том порядке, в котором они расположены в списке.
    • Переименование листов. Для изменения имени листа выберите его в списке и нажмите правую кнопку мыши. Выберите "Переименовать лист". Введите новое имя листа.
    • Изменение набора параметров листа. Для изменения набора параметров листа выберите лист. В столбце "Параметры листа" из раскрывающегося списка выберите требуемый набор параметров или же выберите один или несколько листов из списка и нажмите правую кнопку мыши. Выберите "Изменение набора параметров листа". В списке "Параметры листа" выберите набор параметров или "Импорт" для импорта набора параметров из другого чертежа или шаблона. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, обладающий одним или несколькими наборами параметров. Нажмите кнопку "Импорт". В списке "Параметры листа" выберите требуемый набор параметров.
    ПримечаниеИзмените набор параметров листа, соответствующий каждой разметке, в зависимости желаемого результата. Наборы параметров листов пространства модели могут применяться только к листам пространства модели; наборы параметров пространства листов могут применяться только к листам пространства листов.
    • Копирование листов. Чтобы скопировать один или несколько листов чертежей, выберите листы из списка и нажмите правую кнопку мыши. Выберите "Копировать выбранные листы". Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа. Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1). При каждом новом копировании одного и того же листа число n будет увеличиваться на 1. Создавая копии листа, можно для одного и того же листа получить различные наборы параметров листа и разные настройки.
  3. Когда список листов чертежа будет скомпонован и настроен требуемым образом, нажмите кнопку "Сохранить список листов".
  4. В диалоговом окне "Сохранение списка" в поле "Имя файла" введите имя списка набора чертежей. Нажмите кнопку "Сохранить".

    Список сохраняется в DSD-файле (файле описания наборов чертежей).

  5. В диалоговом окне "Публикация" в группе опций "Вывод при публикации" установите переключатель в положение "На плоттер, заданный в параметрах".
  6. Нажмите кнопку "Публикация" для запуска процесса.

    Если был включен режим фоновой публикации, в правой части строки состояния отображается значок плоттера, обозначающий ход процесса: печать бумажных чертежей или создание файлов печати.

  7. Для просмотра информации о ходе выполнения задания на публикацию нажмите правую кнопку мыши на значке плоттера, расположенном на правой стороне строки состояния. Выберите "Подробности о печати/публикации".
Панель:Стандартный
Ввод команды: ПУБЛ


Вывод набора для публикации на плоттер или в файл печати (Краткий справочник)

Создание и изменение набора чертежей для публикации
Вывод набора для публикации на плоттер или в файл печати
Публикация электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Вывод набора для публикации на плоттер или в файл печати >
Вывод набора для публикации на плоттер или в файл печати
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

PUBLISHCOLLATE

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация электронного набора чертежей (Понятие)

Вывод набора для публикации на плоттер или в файл печати
Публикация чертежей
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей >
Публикация электронного набора чертежей
Понятие Процедура Краткий справочник

Имеется возможность публиковать электронный набор чертежей в виде файла DWF или DWFx.

Существует возможность компоновки листов чертежей в адаптируемый набор чертежей с последующей публикацией в электронном виде. Электронный набор чертежей - это аналог набора чертежей, распечатанных на бумаге.

Электронный набор чертежей можно сохранить в виде одного многолистового файла DWF или DWFx и использовать для демонстрации хода проектов заказчикам, поставщикам и сотрудникам собственной компании - то есть всем, кому чертежи необходимы для изучения и протоколирования.

Опубликованный электронный набор чертежей можно послать как вложение к электронному письму, использовать его для совместной работы с помощью специализированного Интернет-ресурса, такого как Autodesk Buzzsaw, или разместить на сайте в Интернете. С помощью программы просмотра Autodesk Design Review можно просматривать и печатать только нужные вкладки.

Набор чертежей можно также опубликовать в виде набора одностраничных файлов DWF или DWFx, где каждый файл соответствует листу чертежа.

  • При публикации в файл формата DWF используется файл конфигурации плоттера DWF6 ePlot.pc3.
  • При публикации в файл DWFx используется файл DWFx ePlot (XPS Compatible).pc3.

Можно использовать драйвер плоттера, установленный по умолчанию, а можно изменить такие параметры конфигурации, как глубина цвета, экранное разрешение, сжатие файла, обработка шрифтов и другие. Изменения, внесенные в первоначальный файл конфигурации плоттера, распространяются на все будущие действия по печати и публикации файлов DWF и DWFx.

ВниманиеПеред внесением изменений создайте копию первоначального файла конфигурации плоттера.
См. также

    • Настройка параметров публикации


Публикация электронного набора чертежей (Процедура)

Вывод набора для публикации на плоттер или в файл печати
Публикация электронного набора чертежей
Публикация электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Публикация электронного набора чертежей >
Публикация электронного набора чертежей
Понятие Процедура Краткий справочник

Чтобы создать файл dwf или dwfx с помощью публикации

Чтобы создать файл dwf или dwfx с помощью Windows Explorer

Чтобы с помощью Windows Explorer создать файл DWF или DWFX и отправить его по электронной почте


Чтобы создать файл dwf или dwfx с помощью публикации (Процедура)

Публикация электронного набора чертежей
Публикация электронного набора чертежей
Публикация электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Публикация электронного набора чертежей >
Публикация электронного набора чертежей
Понятие Процедура Краткий справочник

Чтобы создать файл dwf или dwfx с помощью публикации

  1. Откройте чертеж. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране появляется диалоговое окно "Публикация". Если задана настройка добавления вкладок разметок листов в контекстном меню диалогового окна "Публикация", в списке листов перечисляются все вкладки разметок листов из текущего чертежа.

  2. Для редактирования списка листов в диалоговом окне "Публикация" следует выполнить одно из следующих действий:
    • Добавление листов. Для того чтобы добавить листы из других чертежей, нажмите кнопку "Добавить листы" (или перетащить чертежи с рабочего стола). В диалоговом окне "Выбор чертежей" выберите чертежи. Для добавления их в список листов диалогового окна "Публикация" нажмите "Выбрать". Каждая разметка листа чертежа становится отдельным листом в списке диалогового окна. Листы, которые не требуется включать в набор, следует исключить из списка.
    ПримечаниеДля включения всех вкладок листа при добавлении листов в набор чертежей выберите — опцию "Включать вкладки листов" в контекстном меню или на вкладке "Листы" в диалоговом окне "Добавление вкладок" во время добавления группы листов.
    • Добавление разметок листов модели. Если включить неинициализированную вкладку модели (формат листа для которой не задан или имеет размеры 0 x 0 ), она будет иметь статус "Лист не инициализирован" в поле "Статус" списка листов. Для вывода на печать такой вкладки следует выбрать в качестве переопределения набор параметров листа из раскрывающегося списка в столбце "Параметры листа" в списке листов диалогового окна "Публикация".
    ПримечаниеДля включения всех вкладок листов модели при добавлении листов в набор чертежей выберите — опцию "Включать вкладку модели" в контекстном меню или на вкладке "Модель" в диалоговом окне "Добавление вкладок" во время добавления группы листов.
    • Исключение листов. Для исключения листов из списка выберите один или несколько листов. Нажмите кнопку "Исключить листы". Чтобы исключить все листы, нажмите правую кнопку мыши. Выберите "Исключить все".
    • Изменение порядка листов. Чтобы изменить порядок листов, сдвинув их выше или ниже на одну позицию списка, выберите лист. Нажмите кнопку "Сдвинуть лист вверх" или "Сдвинуть лист вниз". Просмотр и печать листов набора чертежей выполняется в том порядке, в котором они расположены в списке.
    • Переименование листов. Чтобы переименовать лист, выберите его в списке и нажмите правую кнопку мыши. Выберите "Переименовать лист". Введите новое имя листа.
    • Изменение набора параметров листа. Для изменения набора параметров разметки листа выберите лист, в столбце "Параметры листа" из раскрывающегося списка выберите именованный набор параметров или же выберите один или несколько листов и нажмите правую кнопку мыши. Выберите "Изменение набора параметров листа". В списке "Параметры листа" выберите набор параметров или "Импорт" для импорта набора параметров из другого чертежа или шаблона. В диалоговом окне "Импорт наборов параметров листов" выберите чертеж, обладающий одним или несколькими наборами параметров. Нажмите кнопку "Импорт". В списке "Параметры листа" выберите требуемый набор параметров.
    ПримечаниеИзмените набор параметров листа, соответствующий каждой разметке, в зависимости желаемого результата. Наборы параметров листов пространства модели могут применяться только к листам пространства модели; наборы параметров пространства листов могут применяться только к листам пространства листов.
    • Копирование листов. Чтобы скопировать один или несколько листов чертежей, выберите листы из списка и нажмите правую кнопку мыши. Выберите "Копировать выбранные листы". Копии добавляются в конец списка и выделяются подсвечиванием. Имя копии создается путем добавления слова -Копия(n) к имени исходного листа. Например, при копировании листа под названием Водопровод его копия будет называться Водопровод-Копия(1). При каждом новом копировании одного и того же листа число n будет увеличиваться на 1. Создавая копии листа, можно для одного и того же листа получить различные наборы параметров листа и разные настройки.
  3. Когда список листов чертежа будет скомпонован и настроен требуемым образом, нажмите кнопку "Сохранить список листов".
    ПримечаниеПеред нажатием кнопки "Сохранить список листов" убедитесь, что чертеж сохранен.
  4. В диалоговом окне "Сохранение списка" в поле "Имя файла" введите имя для данного списка. Нажмите кнопку "Сохранить".

    Список набора чертежей сохраняется как файл описания набора чертежей (DSD).

  5. В диалоговом окне "Публикация" в группе "Вывод при публикации" выберите "Формат DWF" и выберите "DWF-файл " или "DWFx-файл ". Нажмите кнопку "Опубликовать".
  6. В диалоговом окне "Указать DWF-файл" введите имя файла.

    В поле "Тип файла" будет стоять DWF или DWFx в зависимости от выбранного формата DWF.

  7. Нажмите "Выбрать" для выбора имени и папки назначения для файла DWF или DWFx.
    ПримечаниеМожно также ввести URL-адрес, чтобы загрузить файл DWF или DWFx на FTP-сервер или сайт в Интернете.
  8. Нажмите кнопку "Сохранить" для запуска процедуры создания электронного набора чертежей.

    Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса.

  9. Для просмотра информации о ходе выполнения задания на публикацию нажмите правую кнопку мыши на значке плоттера, расположенном на правой стороне строки состояния. Выберите "Подробности о печати/публикации".

    Информация, выводимая в диалоговое окно "Подробности о печати/публикации", также сохраняется в файле журнала печати/публикации.

  10. При наличии подходящей программы просмотра пользователь может просмотреть файл DWF или DWFx. Щелкните правой кнопкой мыши на значке плоттера в правой части строки состояния. Выберите "Просмотр файла DWF".
Панель:Стандартный
Ввод команды: ПУБЛ


Чтобы создать файл dwf или dwfx с помощью Windows Explorer (Процедура)

Публикация электронного набора чертежей
Публикация электронного набора чертежей
Публикация электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Публикация электронного набора чертежей >
Публикация электронного набора чертежей
Понятие Процедура Краткий справочник

Чтобы создать файл dwf или dwfx с помощью Windows Explorer

  1. Запустите Windows Explorer.
  2. Выберите чертежи для публикации в файл DWF или DWFx.

    С помощью комбинации Shift или Ctrl + щелчок мышью выберите файлы, расположенные в одном или в разных местах списка.

    ПримечаниеС помощью контекстного меню приложения Windows Explorer можно публиковать только файлы 2D DWF или 2D DWFx.
  3. Нажмите правую кнопку мыши на выбранном наборе. Выберите "Публиковать в DWF".

    Диалоговое окно "Указать DWF-файл" отображается в рамках временного сеанса AutoCAD.

  4. Для поля "Тип файлов" укажите значение *.dwfx или *.dwf.
  5. Введите имя файла или выберите файл.

    Публикация файла чертежа в AutoCAD осуществляется по следующим параметрам:

    Тип DWF-файлов = многолистовой

    Пароль = Отключен

    Информация о слоях = Не включать

    Сведения о блоке = Не включать

    По умолчанию, файл DWFx / DWF сохраняется в той же папке, что и файл(ы) выбранного чертежа.


Чтобы с помощью Windows Explorer создать файл DWF или DWFX и отправить его по электронной почте (Процедура)

Публикация электронного набора чертежей
Публикация электронного набора чертежей
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация электронного набора чертежей >
Публикация электронного набора чертежей
Понятие Процедура Краткий справочник

Чтобы с помощью Windows Explorer создать файл DWF или DWFX и отправить его по электронной почте

  1. Запустите Windows Explorer.
  2. Выберите чертежи для публикации в файл DWF / DWFx.

    С помощью комбинации Shift или Ctrl + щелчок мышью выберите файлы, расположенные в одном или в разных местах списка.

    ПримечаниеС помощью контекстного меню приложения Windows Explorer можно публиковать только файлы 2D DWF или 2D DWFx.
  3. Нажмите правую кнопку мыши на выбранном наборе. Выберите "Публикация в DWF и отправка по электронной почте".

    Диалоговое окно "Указать DWF-файл" отображается в рамках временного сеанса AutoCAD.

  4. Для поля "Тип файлов" укажите значение *.dwfx или *.dwf.
  5. Введите имя файла или выберите файл.

    Файл DWF или DWFx имеет следующие настройки:

    Тип DWF-файлов = многолистовой

    Пароль = Отключен

    Информация о слоях = Не включать

    Сведения о блоке = Не включать

  6. Приложение AutoCAD запускает настроенное по умолчанию почтовое приложение для отправки сообщения, вложением в котором будет вновь созданный файл DWF или DWFx.


Публикация электронного набора чертежей (Краткий справочник)

Вывод набора для публикации на плоттер или в файл печати
Публикация электронного набора чертежей
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация электронного набора чертежей >
Публикация электронного набора чертежей
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

PUBLISHCOLLATE

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

PUBLISHHATCH

Управление обработкой образцов штриховки, опубликованных в формате DWF или DWFx, как отдельным объектом при открытии в Autodesk Impression

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация подшивки (Понятие)

Публикация электронного набора чертежей
Публикация чертежей
Повторная публикация набора чертежей
Печать и публикация чертежей > Публикация чертежей >
Публикация подшивки
Понятие Процедура Краткий справочник

С помощью Диспетчера подшивок можно опубликовать целую подшивку листов, группу листов из подшивки или отдельный лист. В Диспетчере подшивок публикация подшивки выполняется быстрее, чем с помощью диалогового окна "Публикация".

При работе с Диспетчером подшивок публикацию электронного листа можно осуществить, опубликовав его в файл DWF или DWFx. Кроме того, публикацию можно выполнить на бумажных листах с помощью плоттера, указанного в наборе параметров листа, связанном с каждым листом чертежа. Публикация может также выполняться с использованием переопределений параметров, заданных в связанном с подшивкой DWF-файле. Переопределение имеет силу только для текущего задания на публикацию.

Если диалоговое окно "Публикация" открывается из Диспетчера подшивок, в список в нем автоматически заносятся все листы, которые были выбраны в подшивке. В дальнейшем имеется возможность редактировать список.

ПримечаниеПредусмотрена возможность передачи листов на плоттер в обратном порядке. Этот режим можно выбрать в диалоговом окне "Публикация" и в диспетчере подшивок.
См. также

    • Использование наборов параметров листов в подшивках

    • Работа с листами в подшивке

    • Настройка параметров публикации


Публикация подшивки (Процедура)

Публикация электронного набора чертежей
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Публикация подшивки в файл DWF

Чтобы опубликовать подшивку в файл DWFx

Печать подшивки в файл PDF

Публикация группы листов подшивки или отдельного листа в DWF-файл

Для публикации группы листов из подшивки или отдельного листа в файл DWFx

Публикация листов подшивки на заданном в параметрах листов плоттере

Публикация листов подшивки с переопределением параметров листов

Добавление штемпеля на публикуемые листы подшивки

Процедура публикации листов подшивки в обратном порядке

Задание параметров публикации подшивок

Для изменения подшивки, предназначенной для публикации, с помощью диалогового окна "Публикация"


Публикация подшивки в файл DWF (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Публикация подшивки в файл DWF

  1. В Диспетчере подшивок, в группе "Листы" выберите подшивку, группу листов или лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать".

    ПримечаниеВ подшивках не могут содержаться файлы 3D DWF (или 3D DWFx).
  3. В подменю выберите пункт "Публикация в DWF".

    Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.

    СоветПроизводительность публикации можно повысить отключением публикации в фоновом режиме. Убедитесь в том, что на вкладке "Печать/Публикация" ("Сервис" [image] "Настройка") и в группе "Управление публикацией" не выбран фоновый режим публикации.
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Правой кнопкой мыши щелкните на подшивке, группе листов или на отдельном листе. Выберите меню "Публикация" [image] "Публикация в DWF".


Чтобы опубликовать подшивку в файл DWFx (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Чтобы опубликовать подшивку в файл DWFx

  1. В Диспетчере подшивок, в группе "Листы" выберите подшивку, группу листов или лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать".

    ПримечаниеВ подшивках не могут содержаться файлы 3D DWF (или 3D DWFx).
  3. В подменю выберите "Опубликовать в DWFx".

    Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.

    СоветПроизводительность публикации можно повысить отключением публикации в фоновом режиме. Убедитесь в том, что на вкладке "Печать/Публикация" ("Сервис" [image] "Настройка") и в группе "Управление публикацией" не выбран фоновый режим публикации.
Ввод команды: ПОДШИВКА
Контекстное меню:Правой кнопкой мыши щелкните на подшивке, группе листов или на отдельном листе. Выберите меню "Публикация" [image] "Опубликовать в DWFx".


Печать подшивки в файл PDF (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Печать подшивки в файл PDF

  1. В Диспетчере подшивок щелкните правой кнопкой мыши на подшивке, группе листов или на отдельном листе. Выберите меню "Публикация" [image] "Наборы параметров листа".
  2. В диалоговом окне "Диспетчер параметров листов" выберите "Создать".
  3. В диалоговом окне "Создание набора параметров листа", в разделе "Имя набора параметров листа" введите имя для PDF набора параметров листа. Нажмите "ОК".
  4. В диалоговом окне "Параметры листа", в разделе "Принтер/плоттер", выберите файл настройки DWG to PDF.pc3.

    Если отображается диалоговое окно "Не найден формат листа", выберите формата листа для подшивки.

  5. В диалоговом окне "Параметры листа", задайте требуемые параметры листа. Нажмите "ОК".
  6. В "Диспетчере параметров листов" нажмите кнопку "Закрыть".
  7. В диспетчере подшивок щелкните на подшивке правой кнопкой мыши для публикации. Выберите "Публикация" [image] "Опубликовать без учета параметров листа". Щелкните на созданном наборе параметров листа.

    Печать файла PDF осуществляется в папку, содержащуюся в списке в диалоговом окне "Подробности о печати/публикации" ПОДРОБНОСТИПП.

    СоветПроизводительность публикации можно повысить отключением публикации в фоновом режиме. Публикацию в фоновом режиме можно отключить, сняв флажок "Публикация в фоновом режиме" (в группе "Управление публикацией") в диалоговом окне "Публикация".
Панель:Окно Диспетчера подшивок
Ввод команды: ПОДШИВКА


Публикация группы листов подшивки или отдельного листа в DWF-файл (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Публикация группы листов подшивки или отдельного листа в DWF-файл

  1. В Диспетчере подшивок, в группе "Листы" выберите подшивку, группу листов или лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать".

  3. В подменю выберите пункт "Публикация в DWF".
    ПримечаниеЕсли был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните правой кнопкой мыши на подшивке, группе листов или на отдельном листе. Выберите "Публикация" [image] "Публикация в DWF".


Для публикации группы листов из подшивки или отдельного листа в файл DWFx (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Для публикации группы листов из подшивки или отдельного листа в файл DWFx

  1. В Диспетчере подшивок, в группе "Листы" выберите подшивку, группу листов или лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Публикация".

  3. В подменю выберите "Опубликовать в DWFx".
    ПримечаниеЕсли был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Для вывода вариантов просмотра файла DWFx или для получения сведений о ходе выполнения задания на публикацию щелкните на этом значке правой кнопкой мыши .
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните правой кнопкой мыши на подшивке, группе листов или на отдельном листе. Выберите "Опубликовать" [image] "Опубликовать в DWFx".


Публикация листов подшивки на заданном в параметрах листов плоттере (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Публикация листов подшивки на заданном в параметрах листов плоттере

  1. В Диспетчере подшивок, в группе "Список листов" выберите подшивку, группу листов или лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать". Выберите "Опубликовать на плоттер".

    ПримечаниеЕсли был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните правой кнопкой мыши на подшивке, группе листов или на отдельном листе.Выберите "Опубликовать" [image] "Опубликовать на плоттер".


Публикация листов подшивки с переопределением параметров листов (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Публикация листов подшивки с переопределением параметров листов

  1. В группе "Список листов" Диспетчера подшивок выберите подшивку, группу листов или отдельный лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать". Выберите "Опубликовать без учета параметров листа" [image] <имя_файла.dwt>. (Отображается список всех именованных наборов параметров листа, сохраненных в файле DWT переопределения параметров листа.)

    Параметры листа, заданные в файле переопределений, имеют приоритет перед параметрами, которые заданы в самих публикуемых листах. Переопределения имеют силу только для текущего задания на публикацию.

    ПримечаниеЕсли был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Нажатие правой кнопкой на этом значке вызывает контекстное меню, с помощью которого можно просматривать DWF-файлы и получать информацию о процессе публикации.
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните правой кнопкой мыши на подшивке, группе листов или на отдельном листе. Выберите "Опубликовать" [image] "Опубликовать без учета параметров листа" [image] <имя_файла.dwt>.


Добавление штемпеля на публикуемые листы подшивки (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Добавление штемпеля на публикуемые листы подшивки

  • В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать". Выберите "Добавить штемпель".

    На все публикуемые листы добавляется штемпель.

ПримечаниеЧтобы изменить параметры штемпеля, нажмите кнопку "Опубликовать". Выберите "Параметры штемпеля".
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните на узле или имени подшивки, группы листов или отдельного листа правой кнопкой мыши.Выберите "Опубликовать" [image] "Добавить штемпель".


Процедура публикации листов подшивки в обратном порядке (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Процедура публикации листов подшивки в обратном порядке

  1. В диспетчере подшивок выберите имя подшивки или группы листов в разделе "Список листов".
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать". Выберите "Опубликовать в обратном порядке".

    Флажок, поставленный напротив этого пункта меню, указывает, что при нажатии кнопки "Опубликовать" листы будут публиковаться в обратном порядке.

    ПримечаниеДля файлов DWF этот параметр не доступен.
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните на узле или имени подшивки или группы листов правой кнопкой мыши. Выберите "Опубликовать" [image] "Опубликовать в обратном порядке".


Задание параметров публикации подшивок (Процедура)

Публикация подшивки
Публикация подшивки
Публикация подшивки
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Задание параметров публикации подшивок

  1. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать". Нажмите "Параметры публикации подшивки".

  2. В диалоговом окне "Параметры публикации подшивки" настройте параметры.
  3. Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните на узле или имени подшивки, группы листов или отдельного листа правой кнопкой мыши.Выберите "Опубликовать" [image] "Листы".


Для изменения подшивки, предназначенной для публикации, с помощью диалогового окна "Публикация" (Процедура)

Публикация подшивки
Публикация подшивки
Повторная публикация набора чертежей
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Для изменения подшивки, предназначенной для публикации, с помощью диалогового окна "Публикация"

  1. В Диспетчере подшивок выберите в группе "Листы" имя подшивки, группы листов или отдельный лист.
  2. В правом верхнем углу Диспетчера подшивок нажмите кнопку "Опубликовать". Выберите диалоговое окно "Публикация".

    Открывается диалоговое окно "Публикация". В список публикуемых листов заносятся все листы, которые были выбраны в Диспетчере подшивок.

  3. В диалоговом окне "Публикация" отредактируйте список и настройте параметры, как это требуется.
  4. Нажмите кнопку "Опубликовать" для публикации подшивки с текущими настройками.
    ПримечаниеЕсли был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса. Для вывода вариантов просмотра файла DWF или DWFx или для просмотра информации о ходе выполнения задания на публикацию щелкните этот значок правой кнопкой мыши.
Панель:Стандартный
Ввод команды: ПОДШИВКА
Контекстное меню:Щелкните на узле или имени подшивки, группы листов или отдельного листа правой кнопкой мыши.Выберите "Публикация" [image] "Диалоговое окно публикации".


Публикация подшивки (Краткий справочник)

Публикация электронного набора чертежей
Публикация подшивки
Повторная публикация набора чертежей
Печать и публикация чертежей > Публикация чертежей > Публикация подшивки >
Публикация подшивки
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

ПОДШИВКА

Вызов Диспетчера подшивок

Системные переменные

PUBLISHCOLLATE

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Повторная публикация набора чертежей (Понятие)

Публикация подшивки
Публикация чертежей
Просмотр опубликованного электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей >
Повторная публикация набора чертежей
Понятие Процедура Краткий справочник

Существует возможность повторной публикации листов чертежей, списки которых были ранее сохранены в формате описаний наборов чертежей (DSD).

После внесения изменений в чертежи может понадобиться заново опубликовать набор чертежей для его просмотра или печати. Подшивку (DST-файл) или набор листов чертежей можно с легкостью опубликовать повторно, если сведения о них ранее были сохранены как DSD-файл (файл описания наборов чертежей). Также можно загружать и выполнять повторную публикацию BP3-файлов (списков пакетной печати).


Повторная публикация набора чертежей (Процедура)

Публикация подшивки
Повторная публикация набора чертежей
Просмотр опубликованного электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Повторная публикация набора чертежей >
Повторная публикация набора чертежей
Понятие Процедура Краткий справочник

Повторная публикация набора чертежей

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    Если имеется открытый чертеж, все его разметки заносятся в список диалогового окна "Публикация". Нажмите правую кнопку мыши в списке листов. Выберите "Исключить все", чтобы удалить разметки листов из списка.

  2. В диалоговом окне "Публикация" нажмите кнопку "Загрузить список листов".
  3. В диалоговом окне "Загрузка списка листов" выберите папку для файла DSD или файла BP3. Нажмите "Загрузить".

    Теперь в списке диалогового окна "Публикация" отображаются листы, входящие в загруженный файл списка.

  4. В группе "Вывод при публикации" выполните одно из следующих действий:
    • Для публикации в файл DWF —щелкните "Формат DWF" и выберите "Файл DWF".
    • Для публикации в файл DWFx — щелкните "Формат DWF" и выберите "Файл DWFx".
    • Для публикации с выводом на плоттер или принтер — выберите "На плоттер, заданный в параметрах".
  5. Нажмите кнопку "Опубликовать".

    Если был включен фоновый режим публикации, в правом углу строки состояния появляется значок плоттера, обозначающий ход процесса.

  6. Если режим фоновой печати включен, можно сразу просмотреть сведения о выполненном задании на публикацию. Щелкните правой кнопкой мыши на значке плоттера в правой части строки состояния. Выберите "Подробности о печати/публикации". Информация, выводимая в диалоговое окно "Подробности о печати/публикации", также сохраняется в файле журнала печати/публикации.
Панель:Стандартный
Ввод команды: ПУБЛ


Повторная публикация набора чертежей (Краткий справочник)

Публикация подшивки
Повторная публикация набора чертежей
Просмотр опубликованного электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Повторная публикация набора чертежей >
Повторная публикация набора чертежей
Понятие Процедура Краткий справочник

Команды

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Просмотр опубликованного электронного набора чертежей (Понятие)

Повторная публикация набора чертежей
Публикация чертежей
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей >
Просмотр опубликованного электронного набора чертежей
Понятие Процедура Краткий справочник

Просматривать и печатать опубликованный электронный набор чертежей можно с помощью Autodesk Design Review.

Опубликованный набор чертежей является электронным эквивалентом набора печатных чертежей, созданным на основе чертежей. Просмотр и печать набора чертежей, который может быть сохранен в виде файла DWF или DWFx, могут осуществлять любые пользователи Autodesk Design Review.

ПримечаниеС помощью Internet Explorer 7 можно просматривать 2D геометрию файлов DWFx.

С помощью Autodesk Design Review можно открывать, просматривать и печатать файлы DWF и DWFx любых форматов и растровые изображения других форматов. Можно производить панорамирование, зумирование и просматривать изображения отдельных листов и видовых экранов. Также можно просматривать информацию о слоях, свойства листов и подшивок, информацию о блоках, атрибутах и настраиваемых свойствах, если эти сведения включены в файл DWF или DWFx. При наведении курсора в программе просмотра на геометрию DWF или DWFx объекты, имеющие связи с данными, подсвечиваются красным цветом.

Получателям наборов чертежей в формате DWF или DWFx не обязательно иметь программу или уметь с ней работать. Находясь в любой точке мира, они могут просматривать и печатать листы с высоким качеством с помощью программы Autodesk Design Review.

Программа Autodesk Design Review может работать как автономное приложение или в составе любого приложения, поддерживающего элементы управления ActiveX, например, Microsoft® Internet Explorer.

Для получения сведений о программном продукте и ссылки для загрузки программы Autodesk Design Review обратитесь к странице "Продукты" на веб-сайте Autodesk.


Просмотр опубликованного электронного набора чертежей (Процедура)

Повторная публикация набора чертежей
Просмотр опубликованного электронного набора чертежей
Просмотр опубликованного электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Просмотр опубликованного электронного набора чертежей >
Просмотр опубликованного электронного набора чертежей
Понятие Процедура Краткий справочник

Для просмотра файла 2D DWFx в приложении Internet Explorer 7

Для просмотра недавно опубликованного файла DWF

Для просмотра недавно опубликованного файла DWFx


Для просмотра файла 2D DWFx в приложении Internet Explorer 7 (Процедура)

Просмотр опубликованного электронного набора чертежей
Просмотр опубликованного электронного набора чертежей
Просмотр опубликованного электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Просмотр опубликованного электронного набора чертежей >
Просмотр опубликованного электронного набора чертежей
Понятие Процедура Краткий справочник

Для просмотра файла 2D DWFx в приложении Internet Explorer 7

  • Выделите и перетащите файл DWFx в окно Internet Explorer 7.
  • В диалоговом окне "Internet Explorer" нажмите OK.

    Содержимое файла DWFx отображается в новом окне.

    ПримечаниеЕсли в данной системе заблокированы всплывающие окна, выберите “Разрешить заблокированное содержимое” и при появлении подсказки нажмите "Да".


Для просмотра недавно опубликованного файла DWF (Процедура)

Просмотр опубликованного электронного набора чертежей
Просмотр опубликованного электронного набора чертежей
Просмотр опубликованного электронного набора чертежей
Печать и публикация чертежей > Публикация чертежей > Просмотр опубликованного электронного набора чертежей >
Просмотр опубликованного электронного набора чертежей
Понятие Процедура Краткий справочник

Для просмотра недавно опубликованного файла DWF

  • Нажмите правую кнопку мыши на значке плоттера в правой части строки состояния программы. Выберите "Просмотр файла DWF".
ПримечаниеЭта опция доступна, если на данном компьютере установлена соответствующая программа просмотра.

Файл DWF отображается в приложении Autodesk Design Review (если оно установлено) или в DWF Viewer (если приложение Autodesk Design Review отсутствует).


Для просмотра недавно опубликованного файла DWFx (Процедура)

Просмотр опубликованного электронного набора чертежей
Просмотр опубликованного электронного набора чертежей
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Просмотр опубликованного электронного набора чертежей >
Просмотр опубликованного электронного набора чертежей
Понятие Процедура Краткий справочник

Для просмотра недавно опубликованного файла DWFx

  • Нажмите правую кнопку мыши на значке плоттера в правой части строки состояния программы. Выберите "Просмотр файла DWF".

    Эта опция доступна, если на данном компьютере установлена соответствующая программа просмотра.

    Файл DWFx отображается в одном из следующих приложений (если они установлены): Autodesk Design Review (по умолчанию) или Internet Explorer 7 (только файлы 2D DWFx).


Просмотр опубликованного электронного набора чертежей (Краткий справочник)

Повторная публикация набора чертежей
Просмотр опубликованного электронного набора чертежей
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Просмотр опубликованного электронного набора чертежей >
Просмотр опубликованного электронного набора чертежей
Понятие Процедура Краткий справочник

Команды

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка параметров публикации (Понятие)

Просмотр опубликованного электронного набора чертежей
Публикация чертежей
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Можно настраивать такие параметры процесса публикации, как папка файла вывода, тип DWF-файла, именование листов в многолистовом DWF, защита DWF-файла паролем и включение в него информации о слоях. Кроме того, пользователь может задать, какие типы информации будут открыты в публикуемых файлах DWF и DWFx и следует ли публиковать чертежи в автоматическом режиме.

Можно включить следующие типы метаданных.

  • Свойства подшивки (необходима публикация с помощью Диспетчера подшивок)
  • Свойства листов для публикации (необходима публикация с помощью Диспетчера подшивок)
  • Стандартные свойства, а также настраиваемые свойства и атрибуты блока
  • Свойства настраиваемых объектов

Используйте файл шаблона блока (BLK), чтобы указать, какие блоки и свойства требуется включить в публикуемые файлы DWF и DWFx. Можно использовать диалоговое окно "Шаблон блока" для создания или изменения настроек файла шаблона блока (BLK). Можно также использовать файлы BLK, созданные с помощью Мастера извлечения атрибутов.

При изменении настроек в диалоговом окне "Параметры публикации" можно сохранить их в файл описания наборов чертежей (DSD), чтобы воспользоваться ими в следующий раз при публикации чертежей. Их также можно сохранить в файле DSD.

Кроме того, можно задать, чтобы файл DWF или DWFx автоматически создавался при сохранении или закрытии чертежа в Диалоговое окно "Параметры автопубликации".


Настройка параметров публикации (Процедура)

Просмотр опубликованного электронного набора чертежей
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Для изменения назначенной по умолчанию папки для публикуемых файлов DWF, DWFx и файлов печати

Чтобы указать тип выходного файла DWF (одностраничный или многолистовой файл DWF или файл DWFx)

Чтобы задать имя для многолистового файла DWF или DWFx

Для установки режима запроса имени для многолистовых файлов DWF или DWFx

Установка режима защиты публикуемых файлов DWF и DWFx паролями

Добавление информации о слоях в публикуемый файл DWF или DWFx

Включение сведений о блоках в публикуемый файл DWF или DWFx

Включение сведений о шаблонах блоков в публикуемый файл DWF или DWFx

Создание файла шаблона блока (BLK)

Редактирование файла шаблона блока (BLK)


Для изменения назначенной по умолчанию папки для публикуемых файлов DWF, DWFx и файлов печати (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Для изменения назначенной по умолчанию папки для публикуемых файлов DWF, DWFx и файлов печати

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. В группе "Вывод при публикации" выполните одно из следующих действий:

    - Щелкните "Формат DWF" и выберите "Файл DWF" или "Файл DWFx".

    - Выберите опцию "На плоттер, заданный в параметрах".

  3. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  4. В окне "Папка для вывода по умолчанию (для DWF, DWFx и печати в файл)" выполните одно из следующих действий:
    • Нажмите кнопку "Размещение" и произвести выбор из раскрывающегося списка.
    • Нажмите кнопку [...] и в диалоговом окне "Выбор папки для сформированных чертежей" выберите папку. Нажмите "Выбрать".
  5. В диалоговом окне "Параметры публикации" нажмите "OK".
Панель:Стандартный
Ввод команды: ПУБЛ


Чтобы указать тип выходного файла DWF (одностраничный или многолистовой файл DWF или файл DWFx) (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Чтобы указать тип выходного файла DWF (одностраничный или многолистовой файл DWF или файл DWFx)

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В панели "Общие параметры DWF" в группе "Тип DWF-файлов" выберите один из следующих параметров:
    • Одностраничный файл DWF. Указывает на то, что для каждого листа создается отдельный одностраничный файл DWF или DWFx.
    • Многолистовой файл DWF. Указывает на то, что создается один многолистовой файл DWF или DWFx.
  4. Нажмите "ОК".
  5. В диалоговом окне "Публикация" продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Чтобы задать имя для многолистового файла DWF или DWFx (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Чтобы задать имя для многолистового файла DWF или DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В панели "Общие параметры DWF" в группе "Тип DWF-файлов" выберите в раскрывающемся списке "Многолистовые DWF-файлы".
  4. В панели "Параметры многолистовых файлов DWF" в группе "Имена DWF" выберите в раскрывающемся списке позицию "Заданное здесь имя".
  5. Нажмите "ОК".
  6. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Для установки режима запроса имени для многолистовых файлов DWF или DWFx (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Для установки режима запроса имени для многолистовых файлов DWF или DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экран выводится диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В панели "Общие параметры DWF" в группе "Тип DWF-файлов" выберите в раскрывающемся списке "Многолистовые DWF-файлы".
  4. В панели "Параметры многолистовых файлов DWF" выберите "Запрос имени", чтобы при каждой публикации файла DWF выдавался запрос имени файла.
  5. Нажмите "ОК".
  6. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Установка режима защиты публикуемых файлов DWF и DWFx паролями (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Установка режима защиты публикуемых файлов DWF и DWFx паролями

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В панели "Общие параметры DWF" в группе "Защита паролем" выберите один из следующих вариантов из раскрывающегося списка:
    • Выберите "Заданный здесь пароль" и в поле "Пароль" введите пароль для файлов DWF и DWFx.
    • Выберите параметр "Запрос пароля". При открытии опубликованного файла DWF или DWFx будет выдаваться запрос на ввод пароля или фразы.

    Пароли для файлов DWF и DWFx вводятся с учетом регистра. Пароль или фраза могут содержать буквы, цифры, знаки препинания и символы, которые не входят в стандартный набор ASCII.

    ВниманиеСписок паролей и имен соответствующих файлов DWF и DWFx рекомендуется хранить в надежном месте. Забытый или утерянный пароль не может быть восстановлен.
  4. Нажмите "ОК".
  5. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Добавление информации о слоях в публикуемый файл DWF или DWFx (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Добавление информации о слоях в публикуемый файл DWF или DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В диалоговом окне "Параметры данных DWF", в группе "Информация о слоях" щелкните на раскрывающемся списке и выберите "Включать".
    ПримечаниеПо умолчанию параметру "Информация о слоях" присвоено значение "Не включать", чтобы сократить затрачиваемое на публикацию время. Если изменить значение параметра, при просмотре и печати сформированных после этого DWF-файлов можно будет делать отдельные слои невидимыми.
  4. Нажмите "ОК".
  5. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Включение сведений о блоках в публикуемый файл DWF или DWFx (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Включение сведений о блоках в публикуемый файл DWF или DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В диалоговом окне "Параметры данных DWF", в группе "Сведения о блоке" щелкните на раскрывающемся списке и выберите "Включать".
    ПримечаниеПо умолчанию для параметра "Сведения о блоке" установлено значение "Не включать". При изменении настройки включения сведений о блоках можно использовать программу просмотра для просмотра или печати информации о свойствах и атрибутах блоков в файле DWF или DWFx.
  4. Нажмите "ОК".
  5. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Включение сведений о шаблонах блоков в публикуемый файл DWF или DWFx (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Включение сведений о шаблонах блоков в публикуемый файл DWF или DWFx

ПримечаниеМожно использовать файлы шаблонов блоков (BLK), созданные в диалоговом окне "Параметры публикации", или файлы BLK, созданные с помощью Мастера извлечения атрибутов.
  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В диалоговом окне "Параметры данных DWF", в группе "Сведения о блоке" щелкните на раскрывающемся списке. Выберите "Включать".
  4. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Файл шаблона блока" для отображения раскрывающегося списка. Выберите файл шаблона блока (BLK), содержащий определения свойств и атрибутов, которые должны быть доступны в опубликованном файле DWF или DWFx. Нажмите "ОК".
    ПримечаниеВ списке также представлены параметры создания и редактирования. При использовании параметра создания открывается диалоговое окно "Публикация шаблона блока", в котором можно создать новый файл шаблона блока. При использовании параметра редактирования открывается диалоговое окно "Редактирование опубликованного шаблона", в котором можно выберите существующий файл шаблона блока для изменения.
  5. Нажмите "ОК".
  6. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Создание файла шаблона блока (BLK) (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Настройка параметров публикации
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Создание файла шаблона блока (BLK)

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В диалоговом окне "Параметры данных DWF", в группе "Сведения о блоке" щелкните на раскрывающемся списке и выберите "Включать".
  4. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Файл шаблона блока" для отображения раскрывающегося списка и выберите "Создать".

    В диалоговом окне "Публикация шаблона блока" имеется область "Исходный чертеж блока", в котором отображается текущий чертеж.

    ПримечаниеРабочий набор чертежей для этого списка не зависит от того, какие чертежи будут включаться в операцию публикации.
  5. Выполните одно из следующих действий:
    • Если этот чертеж содержит свойства блоков, которые планируется включить в публикуемый файл DWF или DWFx, нажмите кнопку "Поиск блоков".

      Программа выполняет поиск в файле DWG всех уникальных определений блоков и связанных с ними свойств и атрибутов.

    • Если этот чертеж не содержит свойства блоков, которые планируется включить в публикуемый файл DWF или DWFx, нажмите кнопку "Добавить".

      Открывается диалоговое окно "Выбор чертежей". Выберите чертежи для добавления в список исходных чертежей для блоков. Можно также добавлять и исключать чертежи, содержащие целевые блоки, свойства которых планируется включить в публикуемый файл DWF или DWFx. Нажмите кнопку "Поиск блоков".

      Поиск в файле DWG выполняется для всех уникальных определений блоков и связанных с ними свойств и атрибутов.

      ПримечаниеПо умолчанию включаются параметры для вложенных блоков и блоков во внешних ссылках. Если не требуется включать эти параметры блоков, нажмите "Параметры" в диалоговом окне "Публикация шаблона блока" и опустите соответствующие флажки.
  6. В диалоговом окне "Публикация шаблона блока" в разделах "Данные блока для публикации", "Уникальные блоки в исходных чертежах" и "Проверить блоки для публикации" выберите имена блоков, которые необходимо включить в публикуемые файлы DWF и DWFx. Для установки или снятия всех флажков нажмите правую кнопку мыши.
  7. В разделах "Данные блока для публикации", "Свойства выбранных блоков" и "Проверить свойства для публикации" выберите свойства, которые необходимо включить в публикуемые файлы DWF и DWFx. Для установки или снятия всех флажков нажмите правую кнопку мыши.

    В списке отображается набор свойств всех выбранных блоков.

    ПримечаниеПри выборе блока в списке блоков и снятии для него флажков всех свойств в формируемый файл DWF или DWFx будет опубликовано только имя блока; сведения о свойствах добавлены не будут.
  8. Нажмите "Сохранить" для ввода имени и сохранения файла шаблона блока. Нажмите "ОК".

    Новый файл шаблона блока теперь будет доступен в разделе "Параметры данных DWF" диалогового окна "Публикация шаблона блока".

  9. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Редактирование файла шаблона блока (BLK) (Процедура)

Настройка параметров публикации
Настройка параметров публикации
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Редактирование файла шаблона блока (BLK)

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".

    На экране отображается диалоговое окно "Публикация".

  2. Нажмите кнопку "Параметры публикации".

    На экране отображается диалоговое окно "Параметры публикации".

  3. В диалоговом окне "Параметры данных DWF", в группе "Сведения о блоке" щелкните на раскрывающемся списке и выберите "Включать".
  4. В группе "Параметры данных DWF" диалогового окна "Параметры публикации" нажмите "Файл шаблона блока" для отображения раскрывающегося списка и выберите "Редактировать".
  5. В диалоговом окне "Выбор шаблона блока" выберите файл шаблона блока (BLK) для редактирования, а затем нажмите "Выберите".
    ПримечаниеРабочий набор чертежей для этого списка не зависит от того, какие чертежи будут включаться в операцию публикации.
  6. В диалоговом окне "Публикация шаблона блока" нажмите "Поиск блоков".

    Программа выполняет поиск в файлах DWG всех уникальных определений блоков и связанных с ними свойств и атрибутов.

    ПримечаниеПо умолчанию включаются параметры для вложенных блоков и блоков во внешних ссылках. Если не требуется включать эти параметры блоков, нажмите "Параметры" в диалоговом окне "Публикация шаблона блока" и опустите соответствующие флажки.
  7. В разделах "Данные блока для публикации", "Уникальные блоки в исходных чертежах" и "Проверить блоки для публикации" установите или опустите флажки имен блоков, которые необходимо включить в публикуемые файлы DWF.
  8. В разделах "Данные блока для публикации", "Свойства выбранных блоков" и "Проверить свойства для публикации" установите или снимите флажки свойств, которые необходимо включить в публикуемые файлы DWF или DWFx.

    В этом списке отображается набор свойств всех выбранных блоков.

    ПримечаниеЕсли выбрать блок из списка блоков и снять флажки всех его свойств, в формируемом файле DWF или DWFx будет опубликовано только имя блока; сведения о свойствах добавлены не будут.
  9. Нажмите кнопку "Сохранить". Нажмите "ОК".

    Измененный файл шаблона блока теперь будет доступен в разделе "Параметры данных DWF" диалогового окна "Публикация шаблона блока".

  10. В диалоговом окне "Публикация" выполните продолжите работу с заданиями на публикацию, затем закройте окно.
Панель:Стандартный
Ввод команды: ПУБЛ


Настройка параметров публикации (Краткий справочник)

Просмотр опубликованного электронного набора чертежей
Настройка параметров публикации
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Настройка параметров публикации >
Настройка параметров публикации
Понятие Процедура Краткий справочник

Команды

АВТОПУБЛ

Автоматическая публикация чертежей в DWF или DWFx-файлы в указанную папку

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

AUTODWFPUBLISH

Управление автоматическим созданием файлов DWF (Design Web Format) при сохранении и закрытии файлов чертежей (DWG)

PUBLISHCOLLATE

Управление возможностью прерывания другими заданиями печати подшивки, многостраничных файлов печати или файлов печати в фоновом режиме

PUBLISHHATCH

Управление обработкой образцов штриховки, опубликованных в формате DWF или DWFx, как отдельным объектом при открытии в Autodesk Impression

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация 3D DWF (Понятие)

Настройка параметров публикации
Публикация чертежей
Настройка драйвера DWF6
Печать и публикация чертежей > Публикация чертежей >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Предусмотрена возможность создания и публикации файлов трехмерных моделей в формате DWF или DWFx, а также их просмотра в Autodesk Design Review.

Можно сформировать файлы DWF или DWFx трехмерных моделей почти с тем же визуальным разрешением, что и у исходных файлов в формате DWG. Предусмотрена возможность создания однолистового или многолистового файла DWF или DWFx, содержащего 2D и 3D объекты пространства модели. Для доступа к функции публикации однолистового файла 3D DWF используйте команды 3DDWF, ЭКСПОРТ. Для доступа к функции публикации многолистового файла, содержащего 2D и 3D объекты пространства модели, используйте команду ПУБЛ.

Получатели файлов 3D DWF и 3D DWFx могут осуществлять их просмотр и печать с помощью приложения Autodesk Design Review.

Для получения сведений о программном продукте и ссылки для загрузки программы Autodesk Design Review обратитесь к странице "Продукты" на веб-сайте Autodesk.

Подробные сведения о возможностях приложения Autodesk Design Review см. в справочной системе Autodesk Design Review.

Публикация одного или нескольких файлов 3D DWF или 3D DWFx

Публикация одного файла 3D DWF или 3D DWFx выполняется с помощью команд ЭКСПОРТ и 3DДВФ. При исполнении любой из этих команд модель, с которой в настоящее время работает пользователь, сохраняется в видеD DWF-файла.

Одновременная публикация нескольких файлов 3D DWF или 3D DWFx выполняется с помощью команды ПУБЛ В диалоговом окне "Публикация" отображается список всех имен листов файлов чертежей, открытых в текущий момент. Пользователь имеет возможность определить, какие листы будут опубликованы в файле 3D DWF или 3D DWFx, добавляя листы в список "Имя листа" или исключая их из списка.

ПримечаниеУправление списком листов, отображаемых в списке "Имя листа" диалогового окна "Публикация", осуществляется посредством системной переменной PUBLISHALLSHEETS. По умолчанию отображаются все листы всех открытых чертежей.

Публикация материалов

Если для моделей назначены материалы с соответствующей текстурой, эти материалы могут быть опубликованы в файл 3D DWF или 3D DWFx. Ориентация и масштаб текстуры, заданные в графическом редакторе, сохраняются в опубликованном файле 3D DWF или 3D DWFx.

Имеются некоторые ограничения публикации материалов.

  • Единственным наложением, подлежащим публикации, является канал "Текстура рассеяния". Если материал содержит текстуры непрозрачности, отражения или выдавливания, они не будут опубликованы.
  • Такие производственные материалы, как дерево или мрамор, публикации не подлежат.
ПримечаниеТак как приложение для просмотра DWF и средство тонирования отличаются друг от друга, могут возникнуть некоторые отклонения внешнего вида текстур в приложении DWF Viewer.

Усиление сглаживания в моделях 3D DWF и 3D DWFx

Качество сглаживания моделей 3D DWF or 3D DWFx повышается путем изменения значения системной переменной 3DDWFPREC. Переменная 3DDWFPREC может принимать значение от 1 до 6. Чем выше значение, тем лучше выглядят объекты в приложении для просмотра DWF.

ПримечаниеЗначение переменной 3DDWFPREC имеет глобальное действие, влияющее на все объекты 3D модели. Поэтому чем выше значение, тем больше размер файла.

Повышение производительности при работе с большими моделями

При публикации файла DWF или DWFx обрабатываются все объекты модели. При работе с большими моделями производительность значительно повышается, если используются блоки. Например, модель офиса содержит базовую конфигурацию секции из восьми перегородок, письменного стола и стула. Обработка только этих десяти объектов не требует много времени. Однако, если эта базовая конфигурация секции используется 100 раз, это приводит к обработке 1000 объектов, и соответственно возрастает время публикации. Если базовая конфигурация секции вставлена в модель в качестве отдельного блока, эти десять объектов обрабатываются один раз для каждой вставки.

Повысить производительность выполнения публикации можно еще больше, группируя разнообразные объекты во временные блоки. По завершении публикации эти блоки можно расчленить и продолжать работу над этими объектами.

По мере приближения проекта к завершению можно создавать блоки, состоящие из частей модели, которые, скорее всего, не требуют дальнейших изменений. Если первый этаж офиса не будет подвергаться большим изменениям, рекомендуется создать блок, содержащий все его компоненты. Во время публикации вместо обработки каждого отдельного объекта этого этажа такой блок обрабатывается как один объект.

Элементы, не поддерживаемые в файлах 3D DWF и 3D DWFx

При публикации файла 3D DWF или 3D DWFx некоторые элементы чертежа могут не отобразиться в программе просмотра DWF Viewer. В следующей таблице представлено содержимое, которое не поддерживается при выводе файла 3D DWF или 3D DWFx.

Неподдерживаемое содержимое

Подробности

Анимации и сквозной контроль

Атрибуты блоков

Типы шрифтов (разные)

См. таблицу “Поддерживаемые текстовые шрифты”

Градиентные заливки (штриховки)

Невидимые ребра

Гиперссылки

Изображения

Информация о слоях

Источники света и тени

Компоненты материалов

  • Текстуры "Выдавливание", "Непрозрачность" и "Цвет блика"
  • Процедурные материалы (дерево и мрамор)
  • Отражение и преломление
  • Самосвечение
  • Блеск
  • Степень прозрачности

МТекст (частичный)

Курсивный и полужирный текст не поддерживается

Именованные виды и камеры

Объекты OLE

Лучи и X-линии

Создание сечений и XClipping

Высота текста

Визуальные стили

Поддерживаемые текстовые шрифты

При публикации файла 3D DWF или 3D DWFx многие текстовые шрифты не поддерживаются. Шрифты, которые можно публиковать, приведены в следующей таблице.

Поддерживаемые текстовые шрифты

Arial

Arial Black

Comic Sans MS

Courier New

Impact

Lucinda Console

Lucinda Sans Unicode

Martlett

Tahoma

Times New Roman

Verdana

Verdana Italic

Webdings

Wingdings


Публикация 3D DWF (Процедура)

Настройка параметров публикации
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Публикация одного 3D файла DWF

Для публикации одного файла 3D DWFx

Экспорт в 3D файл DWF

Для экспорта файла 3D DWFx

Публикация нескольких файлов 3D DWF или сочетания файлов 2D и 3D DWF

Публикация группы файлов 3D DWFx или комбинированных файлов 2D и 3D DWFx

Публикация выбранных объектов модели в файл 3D DWF или 3D DWFx

Просмотр и печать опубликованного файла 3D DWF file или 3D DWFx


Публикация одного 3D файла DWF (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Публикация одного 3D файла DWF

  1. Введите3dдвф в командной строке.
  2. В диалоговом окне "Экспорт данных" задайте имя и местоположение файла DWF. Нажмите кнопку "Сохранить".

    По умолчанию все объекты пространства модели публикуются в 3D файл DWF и, если в чертеже содержатся внешние ссылки, опция "Группировать по иерархии внешних ссылок" активизирована.

  3. (Необязательно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk Design Review и просмотреть публикуемый файл 3D DWF.
Панель:Стандартный
Ввод команды: 3DДВФ


Для публикации одного файла 3D DWFx (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Для публикации одного файла 3D DWFx

  1. Введите3dдвф в командной строке.
  2. В диалоговом окне "Экспорт данных" задайте имя и местоположение файла DWFx.
  3. В раскрывающемся списке "Тип файла" выберите "3D DWFx".
  4. Нажмите кнопку "Сохранить".

    По умолчанию все объекты пространства модели публикуются в файл 3D DWFx и, если в чертеже содержатся внешние ссылки, опция "Группировать по иерархии внешних ссылок" активизирована.

  5. (Необязательно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk Design Review и просмотреть публикуемый файл 3D DWFx.


Экспорт в 3D файл DWF (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Экспорт в 3D файл DWF

  1. Перейдите на вкладку "Вывод" [image] панель "Переслать" [image] "Экспорт". В командной строке введите "экспорт".
  2. В диалоговом окне "Экспорт данных" задайте имя и местоположение файла DWF.
  3. При необходимости из списка "Типы файлов" выберите "3D DWF (*.dwf)". Нажмите кнопку "Сохранить".

    По умолчанию все объекты пространства модели экспортируются в 3D файл DWF и, если в чертеже содержатся внешние ссылки, опция "Группировать по иерархии внешних ссылок" активизирована.

  4. (Необязательно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk Design Review и просмотреть публикуемый файл 3D DWF.
Ввод команды: ЭКСПОРТ


Для экспорта файла 3D DWFx (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Для экспорта файла 3D DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Переслать" [image] "Экспорт". В командной строке введите "экспорт".
  2. В диалоговом окне "Экспорт данных" задайте имя и местоположение файла DWFx.
  3. В раскрывающемся списке "Тип файлов" выберите 3D DWFx (*.dwfx). Нажмите кнопку "Сохранить".

    По умолчанию все объекты пространства модели экспортируются в файл 3D DWFx и, если в чертеже содержатся внешние ссылки, опция "Группировать по иерархии внешних ссылок" активизирована.

  4. (Необязательно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk Design Review и просмотреть публикуемый файл 3D DWFx.
Ввод команды: ЭКСПОРТ


Публикация нескольких файлов 3D DWF или сочетания файлов 2D и 3D DWF (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Публикация нескольких файлов 3D DWF или сочетания файлов 2D и 3D DWF

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" в группе "Публикуемые листы" выберите листы, которые требуется опубликовать, и измените значение их параметра "Параметры листа / 3D DWF" на "3D DWF".

    Управление листами, отображаемыми в группе "Публикуемые листы", осуществляется посредством системной переменной PUBLISHALLSHEETS.

  3. В группе "Вывод при публикации" щелкните "Формат DWF".
  4. В раскрывающемся списке выберите "В DWF-файл".
    ПримечаниеВ поле "Состояние" выбранного листа будет отображаться сообщение “Невозможно опубликовать 3D DWF на “плоттер, указанный в параметрах листа”, пока опция "Вывод при публикации" не будет изменена на "Формат DWF".
  5. Нажмите "Параметры публикации". В разделе "Общие параметры DWF" для параметра "Тип DWF-файлов" задайте значение "Многолистовые DWF-файлы".
  6. В группе опций "3D DWF" нажмите "Да" для публикации материалов. Нажмите "ОК".
  7. Нажмите кнопку "Опубликовать".
Панель:Стандартный
Ввод команды: ПУБЛ


Публикация группы файлов 3D DWFx или комбинированных файлов 2D и 3D DWFx (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Публикация группы файлов 3D DWFx или комбинированных файлов 2D и 3D DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Публикация" [image] "Публикация". В командной строке введите "публ".
  2. В диалоговом окне "Публикация" в группе "Публикуемые листы" выберите листы, которые требуется опубликовать, и измените значение их параметра "Параметры листа / 3D DWF" на "3D DWF".

    Управление листами, отображаемыми в группе "Публикуемые листы", осуществляется посредством системной переменной PUBLISHALLSHEETS.

    ПримечаниеВ поле "Состояние" выбранного листа будет отображаться сообщение “Невозможно опубликовать 3D DWF на “плоттер, указанный в параметрах листа”, пока опция "Вывод при публикации" не будет изменена на "Формат DWF".
  3. В группе "Вывод при публикации" щелкните "Формат DWF".
  4. В раскрывающемся списке выберите "Файл DWFx".
  5. Нажмите "Параметры публикации". В разделе "Общие параметры DWF" для параметра "Тип DWF-файлов" задайте значение "Многолистовые DWF-файлы".
  6. В группе опций "3D DWF" нажмите "Да" для публикации материалов. Нажмите "ОК".
  7. Нажмите кнопку "Опубликовать".
Панель:Стандартный
Ввод команды: ПУБЛ


Публикация выбранных объектов модели в файл 3D DWF или 3D DWFx (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Публикация 3D DWF
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Публикация выбранных объектов модели в файл 3D DWF или 3D DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Переслать" [image] "Экспорт". В командной строке введите "экспорт".
  2. В диалоговом окне "Экспорт данных" задайте имя и местоположение файла DWF или DWFx.
  3. Нажмите кнопку "Сервис" в верхнем правом углу окна.
  4. Выберите меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  5. В диалоговом окне "Публикация 3D DWF" в группе "Объекты для публикации" нажмите "Выбранные объекты пространства модели", а затем кнопку "Выбор объектов".
  6. В пространстве модели выберите объекты, которые требуется опубликовать.
  7. Нажмите клавишу ENTER или ПРОБЕЛ по завершению выбора объектов.
  8. Нажмите "ОК".
  9. В диалоговом окне "Экспорт данных" нажмите кнопку "Сохранить".
  10. (Необязательно) Нажмите "Да", чтобы открыть окно программы просмотра Autodesk Design Review и просмотреть публикуемый файл 3D DWF или 3D DWFx.
Ввод команды: ЭКСПОРТ


Просмотр и печать опубликованного файла 3D DWF file или 3D DWFx (Процедура)

Публикация 3D DWF
Публикация 3D DWF
Настройка драйвера DWF6
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Просмотр и печать опубликованного файла 3D DWF file или 3D DWFx

  1. Если необходимо просмотреть файл 3D DWF или 3D DWFx, выполните одно из следующих действий:
    • Непосредственно после публикации файла 3D DWF или 3D DWFx и отображения запроса "Просмотреть его?" выберите "Да".

      Этот файл 3D DWF или 3D DWFx открывается в приложении Autodesk Design Review.

    • В приложении Windows Explorer дважды щелкните мышью на файле 3D DWF или 3D DWFx, чтобы просмотреть его в открывшемся приложении Autodesk Design Review.
    • Откройте приложение Autodesk Design Review. Выберите меню "Файл" [image] "Открыть".В командной строке введите "открыть". Выберите файл 3D DWF или 3D DWFx для просмотра.
  2. Для печати файла 3D DWF или 3D DWFx в приложении Autodesk Design Review выберите меню "Файл" [image] "Печать".

    Дополнительные сведения см. в справочной системе Autodesk Design Review.


Публикация 3D DWF (Краткий справочник)

Настройка параметров публикации
Публикация 3D DWF
Коротко о создании и редактировании файла параметров DWF6
Печать и публикация чертежей > Публикация чертежей > Публикация 3D DWF >
Публикация 3D DWF
Понятие Процедура Краткий справочник

Команды

3DДВФ

Создание 3D DWF или 3D DWFx-файла 3D модели и его открытие в окне DWF Viewer

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

Системные переменные

3DDWFPREC

Управление точностью при публикации файлов 3D DWF или 3D DWFx

PUBLISHALLSHEETS

Управление заполнением списка диалогового окна "Публикация" при выполнении команды ПУБЛ

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка драйвера DWF6

Публикация 3D DWF
Публикация чертежей
Коротко о создании и редактировании файла параметров DWF6
Печать и публикация чертежей > Публикация чертежей >
Настройка драйвера DWF6
Понятие Процедура

Изменение настроек драйвера публикаций DWF6 ePlot требуется довольно редко. Но если это действительно нужно, то можно воспользоваться окном свойств этого драйвера для оптимизации вывода. Здесь можно настроить глубину цветности, экранное разрешение, сжатие файла, параметры обработки шрифтов, параметры перьев и другие опции. При создании DWF6-файлов используется файл параметров плоттера, определяющий некоторые особенности формата DWF6. Для печати в файлы формата DWF6 необходимо использовать DWF6 ePlot.pc3.

Темы в этом разделе

  • Коротко о создании и редактировании файла параметров DWF6
  • Задание экранного разрешения DWF-файлов
  • Задание сжатия DWF-файлов

    По умолчанию DWF-файлы создаются в упакованном двоичном формате. Данный формат рекомендуется для большинства файлов DWF.

  • Задание способа обработки шрифтов в файлах DWF
  • Редактирование наборов перьев для вывода в DWF-файлы


Настройка драйвера DWF6 (Процедура)

Публикация 3D DWF
Настройка драйвера DWF6
Коротко о создании и редактировании файла параметров DWF6
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 >
Настройка драйвера DWF6
Понятие Процедура

Создание файла параметров плоттера для вывода в файл DWF

Задание или модификация параметров печати в файлы DWF

Задание глубины цветности при печати в файлы DWF

Задание экранного разрешения DWF-файлов

Задание сжатия DWF-файлов

Задание способа обработки шрифтов в файлах DWF

Редактирование списка шрифтов, доступных для включения в DWF-файл

Редактирование наборов перьев для вывода в DWF-файлы


Коротко о создании и редактировании файла параметров DWF6 (Понятие)

Настройка драйвера DWF6
Настройка драйвера DWF6
Задание экранного разрешения DWF-файлов
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 >
Коротко о создании и редактировании файла параметров DWF6
Понятие Процедура Краткий справочник

Модуль публикаций использует только файл параметров плоттера DWF6 ePlot.pc3. Можно либо воспользоваться настройками по умолчанию входящего в стандартную поставку файла параметров плоттера DWF6 ePlot.pc3, либо внести в него изменения, нажав на кнопку "Свойства" в диалоговом окне "Печать". В результате этого открывается редактор рс3-файлов, который позволяет внести непосредственные изменения в файл DWF6 ePlot.pc3. Хотя для использования в команде вывода на печать можно сохранять файлы DWF6 ePlot.pc3 под другими именами, другое имя для команды "Публикация" не подойдет. Все изменения, внесенные в файл DWF6 ePlot.pc3, действуют при выводе на печать или публикаций файлов DWF6, пока параметры DWF6 ePlot.pc3 не будут снова изменены.

ПримечаниеЕсли планируется внести изменения в файл DWF6 ePlot.pc3, следует вначале создать резервную копию данного файла на тот случай, если впоследствии потребуется вернуться к параметрам по умолчанию. При необходимости исходный файл DWF6 ePlot.pc3 можно восстановить с помощью Мастера установки плоттеров.

Значения этих параметров могут повлиять на размер файла и качество печати в зависимости от содержимого исходного чертежа для файла Design Web Format™ (DWF™). При редактировании файла параметров DWF6 ePlot.pc3 могут устанавливаться следующие параметры:

  • глубина цветности
  • экранное разрешение
  • режимы сжатия
  • режимы включения в файл и обработки шрифтов
  • цвет фона
  • параметры виртуальных перьев и узоров
  • режим включения в файл информации о слоях
  • режим включения в файл контура границ листа
  • режим включения образца для просмотра
ПримечаниеЕсли планируется вывод DWF-файлов на печать, необходимо устанавливать в них белый цвет фона. Если задан черный цвет фона, то объекты, имеющие цвет с номером 7, печатаются белыми. При других цветах фона эти же объекты печатаются черным цветом.


Коротко о создании и редактировании файла параметров DWF6 (Процедура)

Настройка драйвера DWF6
На уровень вверх ..
Коротко о создании и редактировании файла параметров DWF6
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Коротко о создании и редактировании файла параметров DWF6 >
Коротко о создании и редактировании файла параметров DWF6
Понятие Процедура Краткий справочник

Создание файла параметров плоттера для вывода в файл DWF

Задание или модификация параметров печати в файлы DWF

Задание глубины цветности при печати в файлы DWF


Создание файла параметров плоттера для вывода в файл DWF (Процедура)

Коротко о создании и редактировании файла параметров DWF6
На уровень вверх ..
Коротко о создании и редактировании файла параметров DWF6
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Коротко о создании и редактировании файла параметров DWF6 >
Коротко о создании и редактировании файла параметров DWF6
Понятие Процедура Краткий справочник

Создание файла параметров плоттера для вывода в файл DWF

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Диспетчер плоттеров". В командной строке введите "дисппеч".
  2. Дважды нажмите кнопку мыши на ярлыке "Мастер установки плоттеров".
  3. На страничке "Установка плоттера - Введение" нажмите "Далее".
  4. На страничке "Установка плоттера - Начало" выберите "Мой компьютер". Нажмите "Далее".
  5. На страничке "Модель плоттера" в списке "Производители" выберите "Autodesk ePlot (DWF)". В списке "Модели" выберите нужный тип создаваемого DWF6 ePlot-файла. Нажмите "Далее".
  6. (Не обязательно) Если необходимо импортировать прежние настройки параметров плоттера, на странице "Импорт параметров печати из PCP или PC2" нажмите "Импорт файла". Выберите файл PCP или PC2 для импорта. Нажмите кнопку "Импорт".
  7. Нажмите "Далее".
  8. На страничке "Порты" установить переключатель в положение "Вывод в файл". Нажмите "Далее".
  9. На странице "Имя плоттера" введите имя файла параметров плоттера. Нажмите "Далее".
  10. На страничке "Окончание" нажмите кнопку "Готово".

    Создается новый PC3-файл параметров плоттера.

Ввод команды: ДИСППЕЧ


Задание или модификация параметров печати в файлы DWF (Процедура)

Коротко о создании и редактировании файла параметров DWF6
На уровень вверх ..
Коротко о создании и редактировании файла параметров DWF6
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Коротко о создании и редактировании файла параметров DWF6 >
Коротко о создании и редактировании файла параметров DWF6
Понятие Процедура Краткий справочник

Задание или модификация параметров печати в файлы DWF

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В группе "Принтер/плоттер" в списке "Имя" диалогового окна "Печать" выберите устройство печати DWF. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. Нажмите кнопку "Дополнительные свойства".
  5. В диалоговом окне "Свойства DWF6 ePlot" выберите необходимые опции. Нажмите "ОК".
  6. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  7. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий. Затем нажать "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  8. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание глубины цветности при печати в файлы DWF (Процедура)

Коротко о создании и редактировании файла параметров DWF6
На уровень вверх ..
Задание экранного разрешения DWF-файлов
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Коротко о создании и редактировании файла параметров DWF6 >
Коротко о создании и редактировании файла параметров DWF6
Понятие Процедура Краткий справочник

Задание глубины цветности при печати в файлы DWF

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" перейти на вкладку "Устройство и документ" и развернуть вложенный список пункта "Графика" в окне дерева.
  4. Нажмите элемент "Векторная графика".
  5. В области "Глубина цветности" укажите глубину цветности. Нажмите "ОК".
  6. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий. Затем нажать "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  7. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Коротко о создании и редактировании файла параметров DWF6 (Краткий справочник)

Публикация 3D DWF
Коротко о создании и редактировании файла параметров DWF6
Задание экранного разрешения DWF-файлов
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Коротко о создании и редактировании файла параметров DWF6 >
Коротко о создании и редактировании файла параметров DWF6
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание экранного разрешения DWF-файлов (Понятие)

Коротко о создании и редактировании файла параметров DWF6
Настройка драйвера DWF6
Задание сжатия DWF-файлов
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 >
Задание экранного разрешения DWF-файлов
Понятие Процедура Краткий справочник

Можно установить значение разрешения для векторных и растровых изображений при создании DWF6-файлов. Чем больше значение разрешения, тем выше точность отображения объектов, но в то же время тем больше размер файла.

ПредупреждениеЗначение разрешения растрового изображения и градиентного разрешения не может превышать значение векторного разрешения.

В следующем списке отображаются значения векторного разрешения и разрешения растрового изображения по умолчанию.

  • Векторное разрешение: 1200 т/д
  • Настраиваемое векторное разрешение: 40000 т/д
  • Градиентное разрешение: 200 т/д
  • Настраиваемое градиентное разрешение: 200 т/д
  • Разрешение цветного и полутонового изображения: 200 т/д
  • Настраиваемое разрешение цветного и полутонового изображения: 200 т/д
  • Разрешение черно-белого изображения: 400 т/д
  • Настраиваемое разрешение черно-белого изображения: 400 т/д

При создании файла DWF, предназначенного для вывода на печать, установленное значение разрешения для этого файла должно совпадать с разрешением устройства печати. Высокие разрешения (более 2400 т/дюйм) предназначены для просмотра чертежей. Например, при создании DWF-файлов чертежей с большим числом элементов, таких как топографическая карта большого региона, рекомендуется задавать более высокое разрешение для качественной детализации. Очень большие значения разрешения (более 40000 т/д) приводят к созданию файлов очень большого размера. Не следует устанавливать такие значения без крайней необходимости. При увеличении значения разрешения увеличивается качество изображения, но уменьшается скорость печати и возрастают требования к объему оперативной памяти.

Чтобы проиллюстрировать различия между возможными значениями экранного разрешения, предположим, что в DWF-файл выводится карта мира. При среднем экранном разрешении максимальное зумирование дает на экране участок, эквивалентный по площади области, провинции или штату; при высоком разрешении - городу. Наилучшее разрешение позволяет рассматривать даже отдельные дома.


Задание экранного разрешения DWF-файлов (Процедура)

Коротко о создании и редактировании файла параметров DWF6
На уровень вверх ..
Задание сжатия DWF-файлов
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание экранного разрешения DWF-файлов >
Задание экранного разрешения DWF-файлов
Понятие Процедура Краткий справочник

Задание экранного разрешения DWF-файлов

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
    ПримечаниеМожно ввести целое число между 150 и 100000000 для значения разрешения цветного и полутонового изображения. Это значение не должно превышать текущее значение векторного разрешения.
  5. В области "Векторное и градиентное разрешение (точек на дюйм)" диалогового окна "Свойства DWF6 ePlot" выберите значение из списка "Векторное и градиентное разрешение" или выберите "Настройка" и введите значения параметров вручную. Нажмите "ОК".
  6. В области "Разрешение растрового изображения (точек на дюйм)" диалогового окна "Свойства DWF6 ePlot" выберите значение из списка "Разрешение цветного и полутонового изображения" или выберите "Настройка" и введите значения параметров вручную. Нажмите "ОК".
  7. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  8. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий. Затем нажать "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  9. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание экранного разрешения DWF-файлов (Краткий справочник)

Коротко о создании и редактировании файла параметров DWF6
Задание экранного разрешения DWF-файлов
Задание сжатия DWF-файлов
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание экранного разрешения DWF-файлов >
Задание экранного разрешения DWF-файлов
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание сжатия DWF-файлов (Понятие)

Задание экранного разрешения DWF-файлов
Настройка драйвера DWF6
Задание способа обработки шрифтов в файлах DWF
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 >
Задание сжатия DWF-файлов
Понятие Процедура Краткий справочник

По умолчанию DWF-файлы создаются в упакованном двоичном формате. Данный формат рекомендуется для большинства файлов DWF.

Упаковка (сжатие) не вызывает потери данных и рекомендуется к использованию в большинстве случаев. Другой возможный вариант формата - упакованный 2D ASCII-поток (текстовый файл). Уровень сжатия может устанавливаться при создании или редактировании файла параметров DWF-драйвера.


Задание сжатия DWF-файлов (Процедура)

Задание экранного разрешения DWF-файлов
На уровень вверх ..
Задание способа обработки шрифтов в файлах DWF
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание сжатия DWF-файлов >
Задание сжатия DWF-файлов
Понятие Процедура Краткий справочник

Задание сжатия DWF-файлов

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В поле "Формат DWF" области "Дополнительные настройки вывода" диалогового окна "Свойства DWF6 ePlot" выберите параметр сжатия файла. Нажмите "ОК".
  6. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  7. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий. Затем нажать "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  8. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание сжатия DWF-файлов (Краткий справочник)

Задание экранного разрешения DWF-файлов
Задание сжатия DWF-файлов
Задание способа обработки шрифтов в файлах DWF
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание сжатия DWF-файлов >
Задание сжатия DWF-файлов
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание способа обработки шрифтов в файлах DWF (Понятие)

Задание сжатия DWF-файлов
Настройка драйвера DWF6
Редактирование наборов перьев для вывода в DWF-файлы
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 >
Задание способа обработки шрифтов в файлах DWF
Понятие Процедура Краткий справочник

При создании DWF-файлов имеется возможность задания параметров обработки и включения шрифтов в DWF6-файл. По умолчанию в диалоговом окне "Свойства DWF6 ePlot" установлен параметр "Включить по выбору"; с его помощью можно выбирать шрифты, включаемые в DWF-файл. Рекомендуется использовать именно эту опцию.

ПримечаниеРазмер файла DWF зависит от параметров обработки шрифтов, а также от количества текста, числа и типа используемых шрифтов. Если размер файла слишком велик, рекомендуется изменить параметры обработки шрифтов.


Задание способа обработки шрифтов в файлах DWF (Процедура)

Задание сжатия DWF-файлов
На уровень вверх ..
Задание способа обработки шрифтов в файлах DWF
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание способа обработки шрифтов в файлах DWF >
Задание способа обработки шрифтов в файлах DWF
Понятие Процедура Краткий справочник

Задание способа обработки шрифтов в файлах DWF

Редактирование списка шрифтов, доступных для включения в DWF-файл


Задание способа обработки шрифтов в файлах DWF (Процедура)

Задание способа обработки шрифтов в файлах DWF
На уровень вверх ..
Задание способа обработки шрифтов в файлах DWF
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание способа обработки шрифтов в файлах DWF >
Задание способа обработки шрифтов в файлах DWF
Понятие Процедура Краткий справочник

Задание способа обработки шрифтов в файлах DWF

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В области "Шрифты" диалогового окна "Свойства DWF6 ePlot" выберите параметр включения шрифта. Нажмите "ОК".
  6. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  7. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий. Затем нажать "OK".
    • "Применить изменения только к текущему чертежу" - если изменение параметров является разовым и не должно сохраняться для последующего использования.
    • "Сохранить изменения в следующем файле" - если необходимо пользоваться измененными параметрами и в дальнейшем.
  8. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Редактирование списка шрифтов, доступных для включения в DWF-файл (Процедура)

Задание способа обработки шрифтов в файлах DWF
На уровень вверх ..
Редактирование наборов перьев для вывода в DWF-файлы
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание способа обработки шрифтов в файлах DWF >
Задание способа обработки шрифтов в файлах DWF
Понятие Процедура Краткий справочник

Редактирование списка шрифтов, доступных для включения в DWF-файл

  1. Выберите меню "Файл" [image] "Печать".В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В области "Шрифты" диалогового окна "Свойства DWF6 ePlot" выберите "Включить по выбору".
  6. Нажмите кнопку "Список шрифтов".
    Примечание Включение шрифтов в файл DWF приводит к увеличению его размера. Для уменьшения размера файла шрифты TrueType, использующиеся всеми платформами Microsoft® Windows®, по умолчанию не отмечаются в списке. Несмотря на то, что рядом с этими шрифтами нет пометки, они правильно отображаются в DWF6-файле, просматриваемом в операционной системе Windows. Необходимо отметить все остальные установленные шрифты True Type, чтобы удостовериться, что они будут включены в DWF6. В файл включаются только необходимые шрифты.
  7. В диалоговом окне "Шрифты TrueType" выберите шрифты, которые необходимо включить в файл DWF. Нажмите "ОК".
  8. В диалоговом окне "Свойства DWF6 ePlot" нажмите "ОК".
  9. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  10. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание способа обработки шрифтов в файлах DWF (Краткий справочник)

Задание сжатия DWF-файлов
Задание способа обработки шрифтов в файлах DWF
Редактирование наборов перьев для вывода в DWF-файлы
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Задание способа обработки шрифтов в файлах DWF >
Задание способа обработки шрифтов в файлах DWF
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование наборов перьев для вывода в DWF-файлы (Понятие)

Задание способа обработки шрифтов в файлах DWF
Настройка драйвера DWF6
Настройка драйвера DWFx (дополнительная)
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 >
Редактирование наборов перьев для вывода в DWF-файлы
Понятие Процедура Краткий справочник

В диалоговом окне "Редактирование набора перьев" можно задать узор пера, его толщину, форму, эффекты, а также другие параметры, например, масштабирование и глобальные параметры толщины. Изменения, произведенные в диалоговом окне "Редактирование набора перьев", сохраняются в файле параметров плоттера.

ПримечаниеДля редактирования узоров перьев и других параметров в файле параметров DWF6 ePlot выберите глубину цветности "255 виртуальных перьев".


Редактирование наборов перьев для вывода в DWF-файлы (Процедура)

Задание способа обработки шрифтов в файлах DWF
На уровень вверх ..
Настройка драйвера DWFx (дополнительная)
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Редактирование наборов перьев для вывода в DWF-файлы >
Редактирование наборов перьев для вывода в DWF-файлы
Понятие Процедура Краткий справочник

Редактирование наборов перьев для вывода в DWF-файлы

  1. Выберите меню "Файл" [image] "Печать".В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите устройство печати DWF. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" перейдите на вкладку "Устройство и документ" и разверните вложенный список пункта "Графика" в окне структуры. Выберите "Векторная графика". В группе параметров "Глубина цветности" выберите в раскрывающемся списке "255 виртуальных перьев". Затем в зоне структуры свойств выберите элемент "Дополнительные свойства".
  4. В группе опций "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В диалоговом окне "Свойства DWF6 ePlot" выберите "Изменить виртуальные перья".
  6. В диалоговом окне "Редактирование набора перьев" нажмите правую кнопку мыши на нужном поле.
  7. Из контекстного меню выберите одну из стандартных настроек или пункт "Свойства" для вывода диалогового окна свойств пера, в котором можно изменять свойства каждого пера индивидуально.
  8. В диалоговом окне свойств пера нажмите "ОК".
  9. В диалоговом окне "Редактирование набора перьев" нажмите "ОК".
  10. В диалоговом окне "Свойства DWF6 ePlot" нажмите "ОК".
  11. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  12. В диалоговом окне "Изменения в файле параметров плоттера" установите переключатель в одно из перечисленных ниже положений:
    • "Применить изменения только к текущему чертежу".
    • "Сохранить изменения в следующем файле". (Ввести имя файла.)
  13. В списке "Папка" диалогового окна "Поиск файла печати" выберите папку для сохранения файла DWF и нажмите "Сохранить". Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Редактирование наборов перьев для вывода в DWF-файлы (Краткий справочник)

Задание способа обработки шрифтов в файлах DWF
Редактирование наборов перьев для вывода в DWF-файлы
Коротко о создании и редактировании файла параметров DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWF6 > Редактирование наборов перьев для вывода в DWF-файлы >
Редактирование наборов перьев для вывода в DWF-файлы
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка драйвера DWFx (дополнительная)

Редактирование наборов перьев для вывода в DWF-файлы
Публикация чертежей
Коротко о создании и редактировании файла параметров DWFx
Печать и публикация чертежей > Публикация чертежей >
Настройка драйвера DWFx (дополнительная)
Понятие Процедура

Изменения в файл параметров плоттера DWFx ePlot вносятся в диалоговом окне "Свойства DWFx ePlot (совместимо с XPS)". Например, можно задать такие параметры, как глубина цвета, экранное разрешение и пр.

При создании файлов DWFx следует использовать файл DWFx ePlot (XPS Compatible).pc3, поскольку он использует модель с драйвером DWFx.

Темы в этом разделе

  • Коротко о создании и редактировании файла параметров DWFx
  • Задание экранного разрешения файлов DWFx


Настройка драйвера DWFx (дополнительная) (Процедура)

Редактирование наборов перьев для вывода в DWF-файлы
Настройка драйвера DWFx (дополнительная)
Коротко о создании и редактировании файла параметров DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) >
Настройка драйвера DWFx (дополнительная)
Понятие Процедура

Создание файла параметров плоттера для вывода в файл DWFx

Задание или модификация параметров выводимых на печать файлов DWFx

Задание глубины цвета для предназначенных к печати файлов DWFx

Задание экранного разрешения файлов DWFx


Коротко о создании и редактировании файла параметров DWFx (Понятие)

Настройка драйвера DWFx (дополнительная)
Настройка драйвера DWFx (дополнительная)
Задание экранного разрешения файлов DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) >
Коротко о создании и редактировании файла параметров DWFx
Понятие Процедура Краткий справочник

Для создания файлов DWFx в ходе публикации используется файл параметров DWFx ePlot (XPS Compatible).pc3.

Хотя для использования в команде "Печать" можно сохранять файлы DWFx ePlot (XPS Compatible).pc3 под другими именами, команда "Публикация" с другими именами работать не будет.

Для внесения изменений непосредственно в файл DWFx ePlot (XPS Compatible).pc3 используется кнопка "Свойства" в диалоговом окне "Печать". При нажатии этой кнопки запускается редактор pc3.

Любые изменения, внесенные пользователем в файл DWFx ePlot (XPS Compatible).pc3, используются во всех операциях печати или публикации файлов DWFx до тех пор, пока вновь не будут изменены настройки в файле DWFx ePlot (XPS Compatible).pc3.

ПримечаниеПрежде, чем вносить в файл DWFx ePlot (XPS Compatible).pc3какие-либо изменения, следует создать его резервную копию. Другой способ: стандартный файл DWFx ePlot (XPS Compatible).pc3 можно создать повторно с помощью мастера установки плоттеров.

При редактировании файла параметров DWFx ePlot (XPS Compatible).pc3 пользователь может задать следующие настройки:

  • глубина цветности
  • экранное разрешение
  • цвет фона
  • режим включения в файл информации о слоях
ПримечаниеЕсли планируется вывод файлов DWFx на печать, необходимо устанавливать в них белый цвет фона. Если задан черный цвет фона, то объекты, имеющие цвет с номером 7, печатаются белыми. При других цветах фона эти же объекты печатаются черным цветом.


Коротко о создании и редактировании файла параметров DWFx (Процедура)

Настройка драйвера DWFx (дополнительная)
На уровень вверх ..
Коротко о создании и редактировании файла параметров DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) > Коротко о создании и редактировании файла параметров DWFx >
Коротко о создании и редактировании файла параметров DWFx
Понятие Процедура Краткий справочник

Создание файла параметров плоттера для вывода в файл DWFx

Задание или модификация параметров выводимых на печать файлов DWFx

Задание глубины цвета для предназначенных к печати файлов DWFx


Создание файла параметров плоттера для вывода в файл DWFx (Процедура)

Коротко о создании и редактировании файла параметров DWFx
На уровень вверх ..
Коротко о создании и редактировании файла параметров DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) > Коротко о создании и редактировании файла параметров DWFx >
Коротко о создании и редактировании файла параметров DWFx
Понятие Процедура Краткий справочник

Создание файла параметров плоттера для вывода в файл DWFx

  1. Выберите меню "Файл" [image] "Диспетчер плоттеров".В командной строке введите "дисппеч".
  2. В окне Диспетчера плоттеров Autodesk дважды нажмите левую кнопку мыши на ярлыке Мастера установки плоттеров.
  3. В окне Мастера установки плоттеров нажмите "Далее".
  4. На странице " Установка плоттера - Начало" выберите "Мой компьютер". Нажмите "Далее".
  5. На странице "Установка плоттера - Модель плоттера" выберите приведенные ниже значения и нажмите "Далее".

    Производители: Autodesk ePlot (DWFx)

    Модели: DWFx ePlot (XPS Compatible)

    В списке содержатся все плоттеры, установленные в системе.

  6. На экране "Импорт PCP или PC2" нажмите "Далее".
  7. На страничке "Установка плоттера — Порты" выберите порт, к которому подключен плоттер. Нажмите "Далее".

    По умолчанию выбрана опция "Вывод в файл".

  8. На страничке "Установка плоттера — Имя плоттера" введите имя для идентификации текущей настройки плоттера. Нажмите "Далее".
  9. На странице "Установка плоттера - Конец" нажмите кнопку "Изменить конфигурацию", чтобы изменить стандартные настройки плоттера.

    Дополнительные сведения о графических свойствах и пользовательских настройках драйвера DWFx (вкладка "Устройство и документ"), см. в разделе "Свойства драйвера DWFx".

  10. По завершении настройки плоттера нажмите "Готово".
  11. На страничке "Окончание" нажмите кнопку "Готово".

    Создается новый PC3-файл параметров плоттера.

Ввод команды: ДИСППЕЧ


Задание или модификация параметров выводимых на печать файлов DWFx (Процедура)

Коротко о создании и редактировании файла параметров DWFx
На уровень вверх ..
Коротко о создании и редактировании файла параметров DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) > Коротко о создании и редактировании файла параметров DWFx >
Коротко о создании и редактировании файла параметров DWFx
Понятие Процедура Краткий справочник

Задание или модификация параметров выводимых на печать файлов DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В группе "Принтер/плоттер" в списке "Имя" диалогового окна "Печать" выберите подлежащий редактированию файл параметров плоттера DWFx. Выберите "Свойства".
  3. В диалоговом окне "Редактор параметров плоттера" на вкладке "Устройство и документ" выделите элемент "Дополнительные свойства" в зоне структуры свойств.
  4. В группе "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
  5. В диалоговом окне "Свойства DWFx ePlot" выберите необходимые опции. Нажмите "ОК".
  6. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  7. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий:
    • Выберите "Применить изменения только к текущему чертежу" — чтобы задать однократное переопределение настроек, которое не будет сохранено в файле параметров ePlot.
    • Выберите "Сохранить изменения в следующем файле" — чтобы сохранить изменения параметров в текущем файле параметров DWFx.
  8. Нажмите ОК дважды.
  9. В диалоговом окне "Поиск файла печати" перейдите к папке, которую необходимо сохранить. Нажмите кнопку "Сохранить".
  10. Нажмите "ОК".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание глубины цвета для предназначенных к печати файлов DWFx (Процедура)

Коротко о создании и редактировании файла параметров DWFx
На уровень вверх ..
Задание экранного разрешения файлов DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) > Коротко о создании и редактировании файла параметров DWFx >
Коротко о создании и редактировании файла параметров DWFx
Понятие Процедура Краткий справочник

Задание глубины цвета для предназначенных к печати файлов DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите файл параметров плоттера DWFx. Выберите "Свойства".
  3. В Редакторе параметров плоттера перейдите на вкладку "Устройство и документ".
  4. Щелкните на значке (+), чтобы развернуть узел "Графика" древовидной структуры.
  5. Нажмите элемент "Векторная графика".
  6. В области "Глубина цветности" укажите глубину цветности. Нажмите "ОК".
  7. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий:
    • Выберите "Применить изменения только к текущему чертежу" — чтобы задать однократное переопределение настроек, которое не будет сохранено в файле параметров DWF.
    • Выберите "Сохранить изменения в следующем файле" — чтобы сохранить изменения параметров в файле параметров DWF.
  8. Нажмите "ОК".
  9. В диалоговом окне "Поиск файла печати" перейдите к папке, которую необходимо сохранить. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Коротко о создании и редактировании файла параметров DWFx (Краткий справочник)

Редактирование наборов перьев для вывода в DWF-файлы
Коротко о создании и редактировании файла параметров DWFx
Задание экранного разрешения файлов DWFx
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) > Коротко о создании и редактировании файла параметров DWFx >
Коротко о создании и редактировании файла параметров DWFx
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание экранного разрешения файлов DWFx (Понятие)

Коротко о создании и редактировании файла параметров DWFx
Настройка драйвера DWFx (дополнительная)
Совместное использование данных в чертежах и приложениях
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) >
Задание экранного разрешения файлов DWFx
Понятие Процедура Краткий справочник

Можно установить значение разрешения для векторных и растровых изображений при создании файлов DWFx. Чем больше значение разрешения, тем выше точность отображения объектов, но в то же время тем больше размер файла.

ВниманиеЗначение разрешения растрового изображения и градиентного разрешения не может превышать значение векторного разрешения.

В следующем списке отображаются значения векторного разрешения и разрешения растрового изображения по умолчанию.

  • Векторное разрешение: 1200 т/д
  • Настраиваемое векторное разрешение: 40000 т/д
  • Градиентное разрешение: 200 т/д
  • Настраиваемое градиентное разрешение: 200 т/д
  • Разрешение цветного и полутонового изображения: 200 т/д
  • Настраиваемое разрешение цветного и полутонового изображения: 200 т/д
  • Разрешение черно-белого изображения: 400 т/д
  • Настраиваемое разрешение черно-белого изображения: 400 т/д

При создании файлов DWFx, предназначенных для вывода на печать, следует выбирать значение разрешения, соответствующее параметрам плоттера или принтера. Высокие разрешения (более 2400 т/дюйм) предназначены для просмотра чертежей. Например, при создании файлов DWFx чертежей с большим числом элементов, таких как топографическая карта большого района, рекомендуется задавать более высокое разрешение для качественной детализации в файле DWFx.

Очень большие значения разрешения (более 40000 т/д) приводят к созданию файлов очень большого размера. Не следует устанавливать такие значения без крайней необходимости. При увеличении значения разрешения увеличивается качество изображения, но уменьшается скорость печати и возрастают требования к объему оперативной памяти.

Чтобы проиллюстрировать различия между возможными значениями разрешения, предположим, что в файл DWFx выводится карта мира. При среднем экранном разрешении максимальное зумирование дает на экране участок, эквивалентный по площади области, провинции или штату; при высоком разрешении - городу. Наилучшее разрешение позволяет рассматривать даже отдельные дома.


Задание экранного разрешения файлов DWFx (Процедура)

Коротко о создании и редактировании файла параметров DWFx
На уровень вверх ..
Вставка и удаление вхождений чертежей
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) > Задание экранного разрешения файлов DWFx >
Задание экранного разрешения файлов DWFx
Понятие Процедура Краткий справочник

Задание экранного разрешения файлов DWFx

  1. Перейдите на вкладку "Вывод" [image] панель "Печать" [image] "Печать". В командной строке введите "печать".
  2. В области "Принтер/плоттер" в списке "Имя" выберите файл параметров плоттера DWFx. Выберите "Свойства".
  3. В Редакторе параметров плоттера перейдите на вкладку "Устройство и документ".
  4. Щелкните на пункте "Дополнительные свойства" древовидной структуры.
  5. В группе "Доступ к дополнительным свойствам" нажмите кнопку "Дополнительные свойства".
    ПримечаниеМожно ввести целое число между 150 и 100000000 для значения разрешения цветного и полутонового изображения. Это значение не должно превышать текущее значение векторного разрешения.

    На экран выводится диалоговое окно "Свойства DWFx ePlot".

  6. В группе "Векторное и градиентное разрешение (точек на дюйм)" выполните одно из следующих действий:

    - Из списка выберите настройки для пункта "Векторное и градиентное разрешение".

    - Выберите в списке пункт "Настройка" и введите пользовательские значения.

  7. Нажмите "ОК".
  8. В области "Разрешение растрового изображения (точек на дюйм)" выполните одно из следующих действий:

    - Выберите настройки для пункта "Цветное и полутоновое изображение".

    - Выберите из списка настройки для пункта "Черно-белое изображение".

    - Выберите в списке пункт "Настройка" и введите пользовательские значения.

  9. Нажмите "ОК".
  10. В диалоговом окне "Редактор параметров плоттера" нажмите "OK".
  11. В диалоговом окне "Изменение параметров плоттера" выполните одно из следующих действий.
    • Выберите "Применить изменения только к текущему чертежу" — чтобы задать однократное переопределение настроек, которое не будет сохранено в файле параметров DWF.
    • Выберите "Сохранить изменения в следующем файле" — чтобы сохранить изменения параметров в файле параметров DWF.
  12. Нажмите "ОК".
  13. В диалоговом окне "Поиск файла печати" перейдите к папке, которую необходимо сохранить. Нажмите кнопку "Сохранить".
Панель:Стандартный
Ввод команды: ПЕЧАТЬ


Задание экранного разрешения файлов DWFx (Краткий справочник)

Коротко о создании и редактировании файла параметров DWFx
Задание экранного разрешения файлов DWFx
Коротко о внешних ссылках
Печать и публикация чертежей > Публикация чертежей > Настройка драйвера DWFx (дополнительная) > Задание экранного разрешения файлов DWFx >
Задание экранного разрешения файлов DWFx
Понятие Процедура Краткий справочник

Команды

ПАРАМЛИСТ

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

ДИСППЕЧ

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Совместное использование данных в чертежах и приложениях

Задание экранного разрешения файлов DWFx
Внешние ссылки
Совместное использование данных в чертежах и приложениях

Темы в этом разделе

  • Внешние ссылки

    Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже.

  • Составные документы и технология OLE

    С помощью технологии связывания и внедрения объектов (OLE), реализованной в Microsoft Windows, можно копировать и размещать информацию из одного приложения в другое, сохраняя возможность редактирования ее в исходном приложении.

  • Работа с данными других форматов

    Можно работать с различными графическими файлами, которые могут быть созданы в других приложениях или в более ранних версиях программы. Кроме того, можно задать пути к папкам, в которых происходит поиск чертежей или вспомогательных файлов.

  • Извлечение данных из чертежей и электронных таблиц

    Предусмотрена возможность извлечения данных о свойствах из объектов чертежей с последующим экспортом в таблицу или внешний файл.

  • Внешние базы данных

    С графическими объектами чертежа можно связывать данные из внешних баз данных.


Внешние ссылки

Совместное использование данных в чертежах и приложениях
Совместное использование данных в чертежах и приложениях
Коротко о внешних ссылках
Совместное использование данных в чертежах и приложениях >
Внешние ссылки

Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже.

Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже. Внешние ссылки устанавливают лишь связь с другими чертежами без вставки содержимого самих чертежей. Таким образом, можно добавлять элементы в чертеж, не увеличивая значительно его размера.

Темы в этом разделе

  • Коротко о внешних ссылках
  • Вставка и удаление вхождений чертежей

    Можно выполнять некоторые операции с файлами чертежей, на которые была произведена ссылка. Среди них - вставка, задание пути и удаление.

  • Обновление и внедрение внешних чертежей

    Кроме вставки и удаления вхождений чертежей (внешних ссылок), их можно обновлять и внедрять.

  • Подрезка внешних чертежей и блоков

    Предусмотрена возможность задания подрезающего контура для отображения ограниченного фрагмента вставленного блока или внешней ссылки.

  • Редактирование внешних чертежей

    Вставленные в качестве внешних ссылок чертежи можно редактировать, открыв их непосредственно или редактируя внешнюю ссылку по месту, из текущего чертежа. Можно также редактировать определение блока непосредственно через любое его вхождение.

  • Ошибки обработки чертежей-ссылок

    Если при открытии чертежа не удается загрузить чертеж-внешнюю ссылку, то появляется сообщение об ошибке.

  • Увеличение производительности при работе с большими внешними чертежами

    Имеется несколько функций, которые могут повысить производительность при работе с большими чертежами, вставленными в качестве внешних ссылок.


Коротко о внешних ссылках (Понятие)

Внешние ссылки
Внешние ссылки
Вставка и удаление вхождений чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки >
Коротко о внешних ссылках
Понятие Краткий справочник

Имеется возможность вставки в текущий чертеж целого чертежа в качестве внешней ссылки. Внешняя ссылка обеспечивает внесение в текущий чертёж изменений, сделанных в исходном чертеже. Внешние ссылки устанавливают лишь связь с другими чертежами без вставки содержимого самих чертежей. Таким образом, можно добавлять элементы в чертеж, не увеличивая значительно его размера.

За счет вставки чертежей в виде внешних ссылок можно осуществлять следующие действия:

  • Координировать свои действия с действиями других разработчиков, ссылаясь на другие чертежи и учитывая изменения, произведенные в них другими участниками проекта. Имеется также возможность собирать главный чертеж из фрагментов, которые могут изменяться в ходе разработки проекта.
  • Гарантировать наличие на экране последних версий фрагментов чертежей. При открытии чертежа производится автоматическая повторная загрузка всех чертежей, вставленных в качестве внешних ссылок, таким образом, чертеж всегда отражает самые последние изменения, внесенные в связанный файл чертежа.
  • Логически разделять имена слоев, размерных стилей, текстовых стилей и других именованных элементов главного чертежа и связанных с ним чертежей.
  • Осуществлять постоянное объединение (внедрение) связанных чертежей с текущим чертежом по завершению проекта и его готовности к архивации.
ПримечаниеКак и блок, внешняя ссылка представляет собой в текущем чертеже единый объект. Однако внешнюю ссылку нельзя расчленить, предварительно ее не внедрив.
См. также

    • Центр управления


Коротко о внешних ссылках (Краткий справочник)

Задание экранного разрешения файлов DWFx
Коротко о внешних ссылках
Вставка вхождений чертежей (внешних ссылок)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Коротко о внешних ссылках >
Коротко о внешних ссылках
Понятие Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

БАЗА

Задание базовой точки вставки для текущего чертежа

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ВНССЫЛКИЗАКР

Закрытие палитры "Внешние ссылки"

ССЫЛЗАКР

Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок

ССЫЛРЕД

Выбор внешней ссылки или вхождения блока для редактирования

ССЫЛНАБ

Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок

НОВОЕИМЯ

Изменение имен именованных объектов

ССВСТАВИТЬ

Вставка внешних ссылок в текущий чертеж

ВНЕДРИТЬ

Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж

ССПОДРЕЗАТЬ

Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока

ССЫЛКА

Запуск команды ВНССЫЛКИ

Системные переменные

BINDTYPE

Управление обработкой имен внешних ссылок при внедрении или контекстном редактировании внешних ссылок

ERSTATE

Указание на открытое или закрытое состояние палитры "Внешние ссылки"

INDEXCTL

Управление созданием слоевых и пространственных индексов и сохранением их в файле чертежа

INSBASE

Координаты базовой точки вставки, установленной с помощью команды БАЗА, в текущей ПСК текущего пространства

PROJECTNAME

Присвоение имени проекта текущему чертежу

VISRETAIN

Управление свойствами слоев, зависящих от внешних ссылок

XCLIPFRAME

Управление видимостью контуров подрезки внешних ссылок

XEDIT

Управление возможностью контекстного редактирования текущего чертежа при использовании его в качестве внешней ссылки

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

XLOADPATH

Создание пути для хранения временных копий файлов подгруженных внешних ссылок

XREFNOTIFY

Управление уведомлением для обновленных или отсутствующих внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка и удаление вхождений чертежей

Коротко о внешних ссылках
Внешние ссылки
Вставка вхождений чертежей (внешних ссылок)
Совместное использование данных в чертежах и приложениях > Внешние ссылки >
Вставка и удаление вхождений чертежей
Понятие Процедура

Можно выполнять некоторые операции с файлами чертежей, на которые была произведена ссылка. Среди них - вставка, задание пути и удаление.

Темы в этом разделе

  • Вставка вхождений чертежей (внешних ссылок)

    Если чертеж вставляется в качествевнешней ссылки, осуществляется его привязка к текущему чертежу; любые изменения в чертеже, на который есть ссылка, отображаются в текущем чертеже при его открытии или повторной загрузке.

  • Задание путей к внешним чертежам

    При поиске конкретной внешней ссылки чертежа можно просматривать и изменять имя файла и путь к нему. Эта возможность полезна, если файл ссылки был перемещён в другую папку или переименован после того, как он был вставлен впервые.

  • Удаление вхождений чертежей

    Для окончательного удаления вхождения DWG (внешней ссылки) из чертежа простого ее стирания недостаточно.


Вставка и удаление вхождений чертежей (Процедура)

Задание экранного разрешения файлов DWFx
Вставка и удаление вхождений чертежей
Вставка вхождений чертежей (внешних ссылок)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей >
Вставка и удаление вхождений чертежей
Понятие Процедура

Для вставки внешней ссылки

Вставка или наложение внешней ссылки с помощью Центра управления

Просмотр файлов ссылок по типу на палитре "Внешние ссылки"

Изменение пути к вхождению DWG

Просмотр имен имеющихся проектов

Добавление имени проекта

Удаление имени проекта

Изменение имени проекта

Добавление пути доступа

Удаление пути доступа

Изменение пути доступа

Установка проекта текущим

Отмена установки проекта текущим

Удаление внешней ссылки


Вставка вхождений чертежей (внешних ссылок) (Понятие)

Вставка и удаление вхождений чертежей
Вставка и удаление вхождений чертежей
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей >
Вставка вхождений чертежей (внешних ссылок)
Понятие Процедура Краткий справочник

Если чертеж вставляется в качествевнешней ссылки, осуществляется его привязка к текущему чертежу; любые изменения в чертеже, на который есть ссылка, отображаются в текущем чертеже при его открытии или повторной загрузке.

Чертеж может быть вставлен в качестве ссылки сразу в несколько чертежей. И наоборот, в один чертеж можно вставить несколько внешних ссылок.

Средства вставки внешних ссылок

Предусмотрено несколько способов вставки внешней ссылки.

  • Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  • Воспользуйтесь командой ВНССЫЛКИ.
  • Перейдите на вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] "DWG". В командной строке введите "ссвставить".
  • Воспользуйтесь командой ССВСТАВИТЬ.

Можно также вставить в чертеж внешние ссылки из Центра управления™. С его помощью процедура вставки упрощается, так как он позволяет не только просматривать вхождения чертежей и описания к ним, но и быстро вставлять внешние ссылки в чертеж путем простого перетаскивания.

Можно вставить внешнюю ссылку, перетащив ее из Центра управления или выбрав "Вставить как внешнюю ссылку" из контекстного меню.

Для задания местоположения внешней ссылки можно сохранить полный путь, сохранить относительный (частичный) путь или не сохранять никакого пути.

Если внешняя ссылка содержит какие-либо переменные атрибуты блоков, они игнорируются.

ПримечаниеПри работе с палитрой "Внешние ссылки" рекомендуется активизировать функцию автоматического скрытия или прикрепить палитру якорем. При указании точки вставки внешней ссылки палитра будет автоматически убираться с экрана.

Уведомление о внешних ссылках

В правом нижнем углу окна приложения (в строке состояния) размещается значок, свидетельствующий о наличии в чертеже внешних ссылок.

Если по адресу, указанному во внешней ссылке, не обнаружен чертеж или если ссылка должна быть обновлена, на значке ссылки появляется восклицательный знак. При нажатии на значке внешних ссылок открывается палитра "Внешние ссылки".

Видимость, цвет и тип линий

Можно включать и отключать слои внешних ссылок, а также задавать для них цвет, тип линий и другие свойства. Вносимые изменения могут быть временными или постоянными. Если значение системной переменной VISRETAIN приравнено к 0, эти изменения относятся только к текущему сеансу работы с чертежом. Значения свойств восстанавливаются по завершению сеанса работы или при повторной загрузке или удалении внешней ссылки.

Подрезка внешних ссылок контурами

Чертежи могут содержать подрезанные внешние ссылки. Для вывода контура подрезки следует включить системную переменную XCLIPFRAME.

Вставка из учебных версий приложений

Если открыть, вставить или добавить внешнюю ссылку, созданную в учебной версии приложения Autodesk, то при выводе чертежей на печать на чертеже появится надпись: “СОЗДАНО УЧЕБНОЙ ВЕРСИЕЙ ПРОДУКТА AUTODESK”.

См. также

    • Вложенные и наложенные внешние чертежи

    • Подрезка внешних чертежей и блоков

    • Задание путей к внешним чертежам

    • Центр управления

    • Задание параметров интерфейса


Вставка вхождений чертежей (внешних ссылок) (Процедура)

Вставка и удаление вхождений чертежей
На уровень вверх ..
Вставка вхождений чертежей (внешних ссылок)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Вставка вхождений чертежей (внешних ссылок) >
Вставка вхождений чертежей (внешних ссылок)
Понятие Процедура Краткий справочник

Для вставки внешней ссылки

Вставка или наложение внешней ссылки с помощью Центра управления

Просмотр файлов ссылок по типу на палитре "Внешние ссылки"


Для вставки внешней ссылки (Процедура)

Вставка вхождений чертежей (внешних ссылок)
На уровень вверх ..
Вставка вхождений чертежей (внешних ссылок)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Вставка вхождений чертежей (внешних ссылок) >
Вставка вхождений чертежей (внешних ссылок)
Понятие Процедура Краткий справочник

Для вставки внешней ссылки

  1. Перейдите на вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] "DWG". В командной строке введите "ссвставить".
  2. В диалоговом окне "Выбор файла внешней ссылки" выберите файл для вставки. Нажмите кнопку "Открыть".
  3. В поле "Тип ссылки" диалогового окна "Внешняя ссылка" выберите тип ссылки "Вставленная".
  4. Задайте точку вставки, масштаб и угол поворота. Для того чтобы задать какой-либо параметр с помощью устройства указания, нужно установить флажок "Указать на экране" в соответствующей группе опций.

    Чертеж вставляется вместе со всеми вложенными в него внешними ссылками.

  5. Нажмите "ОК".
Панель:Ссылка
Ввод команды: ССВСТАВИТЬ


Вставка или наложение внешней ссылки с помощью Центра управления (Процедура)

Вставка вхождений чертежей (внешних ссылок)
На уровень вверх ..
Вставка вхождений чертежей (внешних ссылок)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Вставка вхождений чертежей (внешних ссылок) >
Вставка вхождений чертежей (внешних ссылок)
Понятие Процедура Краткий справочник

Вставка или наложение внешней ссылки с помощью Центра управления

  1. Выберите пункт меню "Сервис" [image] "Палитры" [image] "Центр управления".В командной строке введите "цуоткл".
  2. В диалоговом окне "Поиск" в области содержимого выделите ссылку на DWG, которую требуется вставить или наложить.
  3. Нажмите правую кнопку мыши. Перетащите ссылку на DWG в открытый чертеж.
  4. Отпустите правую кнопку мыши. Выберите "Вставить как ссылку".
  5. В поле "Тип ссылки" диалогового окна "Внешняя ссылка" выберите "Вставленная" или "Наложенная".
  6. Задайте точку вставки, масштаб и угол поворота. Для любого из этих параметров можно поднять флажок "Указать на экране"; это сигнализирует о том, что параметр будет задан с помощью устройства указания.
  7. Нажмите "ОК".

    Можно также вставить внешнюю ссылку, перетащив ее или выбрав в контекстном меню "Вставить как внешнюю ссылку".

  8. Нажмите "ОК".
Панель:Стандартная
Ввод команды: ЦУВКЛ


Просмотр файлов ссылок по типу на палитре "Внешние ссылки" (Процедура)

Вставка вхождений чертежей (внешних ссылок)
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Вставка вхождений чертежей (внешних ссылок) >
Вставка вхождений чертежей (внешних ссылок)
Понятие Процедура Краткий справочник

Просмотр файлов ссылок по типу на палитре "Внешние ссылки"

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки", на панели "Файл ссылок", нажмите кнопку "Просмотр списка".
  3. Нажмите кнопку мыши на столбце "Значок".

    Соответствующие ссылочные файлы сортируются в списке по типу.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Вставка вхождений чертежей (внешних ссылок) (Краткий справочник)

Коротко о внешних ссылках
Вставка вхождений чертежей (внешних ссылок)
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Вставка вхождений чертежей (внешних ссылок) >
Вставка вхождений чертежей (внешних ссылок)
Понятие Процедура Краткий справочник

Команды

ЦУВКЛ

Управление содержимым: блоками, внешними ссылками и образцами штриховки

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ВНССЫЛКИЗАКР

Закрытие палитры "Внешние ссылки"

ЛОТОКНАСТР

Управление отображением значков и уведомлений в области уведомлений строки состояния

ССВСТАВИТЬ

Вставка внешних ссылок в текущий чертеж

ССЫЛКА

Запуск команды ВНССЫЛКИ

Системные переменные

ERSTATE

Указание на открытое или закрытое состояние палитры "Внешние ссылки"

INDEXCTL

Управление созданием слоевых и пространственных индексов и сохранением их в файле чертежа

TRAYICONS

Управление отображением области уведомлений в строке состояния

TRAYICONS

Управление отображением уведомлений служб в области уведомлений строки состояния

TRAYTIMEOUT

Управление временем (в секундах), в течение которого отображаются уведомления служб

VISRETAIN

Управление свойствами слоев, зависящих от внешних ссылок

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

XLOADPATH

Создание пути для хранения временных копий файлов подгруженных внешних ссылок

XREFNOTIFY

Управление уведомлением для обновленных или отсутствующих внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание путей к внешним чертежам (Понятие)

Вставка вхождений чертежей (внешних ссылок)
Вставка и удаление вхождений чертежей
Удаление вхождений чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

При поиске конкретной внешней ссылки чертежа можно просматривать и изменять имя файла и путь к нему. Эта возможность полезна, если файл ссылки был перемещён в другую папку или переименован после того, как он был вставлен впервые.

Имя файла и путь к нему, используемые программой при поиске ссылки чертежа, можно просматривать и изменять. Эта возможность полезна, если файл ссылки был перемещён в другую папку или переименован после того, как он был вставлен впервые.

Предусмотрено три варианта ввода информации о пути к папке для сохранения в составе вставленной ссылки: можно задать полный путь, задать относительный путь или не задавать никакого пути.

Задание полного (абсолютного) пути

Полный путь содержит исчерпывающую информацию об иерархии папок, содержащих файл, на который указывает ссылка. Полный путь включает в себя буквенное обозначение локального жесткого диска, адрес URL веб-узла или буквенное обозначение диска на сетевом сервере. Это наиболее точный, но негибкий способ задания пути.

Задание относительного пути

Относительные пути - это лишь частично определенные иерархии папок, задаваемые относительно текущего чертежа (папки, в которой он хранится). Это наиболее гибкий способ описания пути, позволяющий перенести всю структуру папок с чертежами на другой жесткий диск.

Если файл, на который есть ссылка, находится на другом жёстком диске или сетевом сервере, возможность использования относительного пути недоступна.

Правила формирования относительных путей таковы:

\

Корневая папка жесткого диска, на котором находится текущий чертеж

путь

Путь, начиная от папки, в которой находится текущий чертеж

\путь

Путь, начиная от корневой папки

.\путь

Путь, начиная от папки, в которой находится текущий чертеж

..\путь

Путь, начиная от папки, лежащей уровнем выше папки текущего чертежа

..\..\путь

Путь, начиная от папки, лежащей двумя уровнями выше папки текущего чертежа

ПримечаниеЕсли чертёж, содержащий файлы ссылок, перемещён или сохранён по другому пути, на другой локальный жёсткий диск или на другой сетевой сервер, необходимо отредактировать все относительные пути, чтобы привести их в соответствие с новым расположением чертежа, или изменить местонахождение файлов ссылок.

Задание пустого пути

В случае, если вместе со внешней ссылкой не сохранена информация о пути, программа предпринимает поиск. Он происходит в следующем порядке.

  • Текущая папка главного чертежа
  • Пути поиска файлов проекта, заданные в диалоговом окне "Настройка" (вкладка "Файлы") или с помощью системной переменной PROJECTNAME
  • Пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке приложения Microsoft® Windows®

Задание пустого пути удобно при перемещении набора чертежей в другую структуру папок, а также в тех случаях, когда структура папок неизвестна.

Информация о переносе внешнего чертежа

Если редактируемый чертеж содержит внешнюю ссылку на файл, который был перемещен в другую папку, при загрузке чертежа появится сообщение об изменении пути внешней ссылки. Сообщение говорит о том, что внешняя ссылка не может быть загружена по старому пути. После указания нового пути будет произведена повторная загрузка внешней ссылки в чертеж.

Задание пути к внешнему чертежу по имени проекта

Задание имен проектов в настройках продукта упрощает работу с внешними ссылками в случаях, когда разработчики активно обмениваются чертежами, а также если используемый совместно ресурс сервера сети отображается на различные локальные диски рабочих станций. Имя проекта указывает на отдельный раздел системного реестра, в который записываются один или несколько путей поиска относящихся к проекту файлов.

Если программа не находит внешнюю ссылку в папке по указанному пути, от имени ссылки отделяются все префиксы (если они имеются). Если для чертежа установлено значение системной переменной PROJECTNAME (т.е. чертеж является частью какого-либо проекта) и в реестре имеется соответствующая запись, программа выполняет поиск файла во всех папках данного проекта. Если после этого внешняя ссылка все еще не найдена, программа будет искать ее в своих стандартных папках.

Имеется возможность создавать, удалять и изменять занесенные в реестр имена проектов. Те же операции можно производить и с именами путей к файлам проектов.

Пути доступа к файлам проектов можно добавлять, удалять и изменять точно так же, как и имена проектов. Порядок просмотра папок можно изменить. Редактирование путей доступа к проектам можно выполнить только на вкладке "Файлы" диалогового окна "Настройка". В командной строке невозможно редактировать имена проектов.

Проект, для которого заданы имя и пути доступа к файлам, в любой момент может быть установлен текущим. В программе выполняется поиск путей, связанных с активным в данный момент проектом (для ссылок, не обнаруженных в текущей папке чертежа, в который они вставлены), полного пути поиска, папки текущего чертежа или служебных путей программы.

Расширенные возможности изменения путей поиска для нескольких чертежей

При переносе файлов чертежей или внешних файлов, на которые они ссылаются, включая другие файлы чертежей, шрифты текстов, изображения и параметры плоттеров, пути поиска, сохраняемые в чертеже, требуют обновления. "Диспетчер ссылок" Autodesk приводит перечень файлов, на которые произведена ссылка из выбранных чертежей, и обеспечивает инструментами изменения сохраненных путей поиска без необходимости в открытии каждого файла чертежа. Также "Диспетчер ссылок" можно использовать для выявления и устранения необработанных ссылок.

"Диспетчер ссылок" представляет собой автономное приложение с собственной справочной системой. Для доступа к этому приложению нажмите кнопку меню "Пуск" (Windows) [image] (Все) Программы [image] Autodesk [image] AutoCAD [image] Диспетчер ссылок. При работе в сети он может быть не установлен на локальном компьютере.

Предупреждение"Диспетчер ссылок", прежде всего, предназначен для специалистов по САПР, которые точно осведомлены о местоположениях файлов проекта. Он позволяет одновременно изменить несколько путей, отмена результатов его действий невозможна. Необходимо быть предельно осторожным, в особенности при работе в сети.


Задание путей к внешним чертежам (Процедура)

Вставка вхождений чертежей (внешних ссылок)
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Изменение пути к вхождению DWG

Просмотр имен имеющихся проектов

Добавление имени проекта

Удаление имени проекта

Изменение имени проекта

Добавление пути доступа

Удаление пути доступа

Изменение пути доступа

Установка проекта текущим

Отмена установки проекта текущим


Изменение пути к вхождению DWG (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Изменение пути к вхождению DWG

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите имя внешнего чертежа.
  3. В группе "Найдено в" выполните одно из следующих действий:
    • Введите новый путь непосредственно к внешней ссылке.
    • Нажмите кнопку "Обзор". Выберите внешнюю ссылку по новому пути.
  4. Нажмите "ОК".

    Программа загрузит внешнюю ссылку и регенерирует чертеж с обновленной внешней ссылкой.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Просмотр имен имеющихся проектов (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Просмотр имен имеющихся проектов

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды щелкните кнопкой мыши на элементе "Путь доступа к файлам проектов".
  3. Нажмите имя нужного проекта, чтобы просмотреть заданные для него пути доступа.
  4. Нажмите кнопку "OK" (или "Применить").


Добавление имени проекта (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Добавление имени проекта

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды щелкните кнопкой мыши на элементе "Путь доступа к файлам проектов". Нажмите "Добавить".

    AutoCAD создает новую папку проекта с именем projectx (где x - следующий доступный номер).

  3. Введите новое имя или нажмите ENTER для подтверждения имени projectx.

    Длина имени проекта должна быть не более 31 символа; оно не может начинаться с пробелов или заканчиваться ими.

  4. Нажмите кнопку "OK" (или "Применить").


Удаление имени проекта (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Удаление имени проекта

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды щелкните кнопкой мыши на элементе "Путь доступа к файлам проектов".
  3. Выберите имя проекта. Нажмите кнопку "Исключить".
  4. Нажмите кнопку "OK" (или "Применить").


Изменение имени проекта (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Изменение имени проекта

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Введите новое имя.
  3. Нажмите кнопку "OK" (или "Применить").

    Также можно изменить имя проекта, выбрав имя в папке проекта и нажав клавишу F2.


Добавление пути доступа (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Добавление пути доступа

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Нажмите "Добавить".
  3. Под именем проекта введите новый путь или выберите его, нажав кнопку "Обзор".
  4. Нажмите кнопку "OK" (или "Применить").

    Новый путь записывается с отступом под выбранным именем проекта.


Удаление пути доступа (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Удаление пути доступа

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Выберите "Исключить".
  3. Нажмите "ОК".


Изменение пути доступа (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Изменение пути доступа

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите имя проекта. Нажмите кнопку "Обзор".
  3. В окне обзора выберите нужную папку.
  4. Нажмите "OK" для закрытия каждого диалогового окна.

    Путь доступа к проекту можно также изменить, если выделить его и нажать F2.


Установка проекта текущим (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Задание путей к внешним чертежам
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Установка проекта текущим

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" дважды щелкните кнопкой мыши на элементе "Путь доступа к файлам проектов".
  3. Выберите имя проекта. Нажмите кнопку "Установить".
  4. Нажмите кнопку "OK" (или "Применить").

    Для задания проекта в качестве текущего можно также ввести в командной строке "projectname", а затем имя проекта.


Отмена установки проекта текущим (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Удаление вхождений чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Отмена установки проекта текущим

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" укажите элемент "Путь доступа к файлам проектов".
  3. Выберите "Отменить путь".

    Установка текущего проекта отменяется.

  4. Нажмите кнопку "OK" (или "Применить").

    Также отменить установку проекта как текущего можно путем ввода в командной строке projectname, а затем ввода точки (.).


Задание путей к внешним чертежам (Краткий справочник)

Вставка вхождений чертежей (внешних ссылок)
Задание путей к внешним чертежам
Удаление вхождений чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Задание путей к внешним чертежам >
Задание путей к внешним чертежам
Понятие Процедура Краткий справочник

Команды

ССЫЛКА

Запуск команды ВНССЫЛКИ

Системные переменные

PROJECTNAME

Присвоение имени проекта текущему чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Удаление вхождений чертежей (Понятие)

Задание путей к внешним чертежам
Вставка и удаление вхождений чертежей
Обновление и внедрение внешних чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей >
Удаление вхождений чертежей
Понятие Процедура Краткий справочник

Для окончательного удаления вхождения DWG (внешней ссылки) из чертежа простого ее стирания недостаточно.

Для окончательного удаления внешней ссылки из чертежа ее необходимо удалить (открепить). Так, например, обычное стирание внешней ссылки не приводит к удалению описаний слоев, связанных с внешней ссылкой. Для окончательного удаления внешних ссылок со всеми связанными данными необходимо использовать опцию "Удалить".


Удаление внешней ссылки (Процедура)

Задание путей к внешним чертежам
На уровень вверх ..
Обновление и внедрение внешних чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Удаление вхождений чертежей >
Удаление вхождений чертежей
Понятие Процедура Краткий справочник

Удаление внешней ссылки

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите имя внешнего чертежа.
  3. Нажмите правую кнопку мыши на вхождении DWG и выберите из контекстного меню "Удалить".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Удаление вхождений чертежей (Краткий справочник)

Задание путей к внешним чертежам
Удаление вхождений чертежей
Вложенные и наложенные внешние чертежи
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Вставка и удаление вхождений чертежей > Удаление вхождений чертежей >
Удаление вхождений чертежей
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Обновление и внедрение внешних чертежей

Удаление вхождений чертежей
Внешние ссылки
Вложенные и наложенные внешние чертежи
Совместное использование данных в чертежах и приложениях > Внешние ссылки >
Обновление и внедрение внешних чертежей
Понятие Процедура

Кроме вставки и удаления вхождений чертежей (внешних ссылок), их можно обновлять и внедрять.

Темы в этом разделе

  • Вложенные и наложенные внешние чертежи

    Вставленные вхождения DWG (внешние ссылки) могут быть вложенными: это означает, что можно вставить внешнюю ссылку, которая в свою очередь содержит другую внешнюю ссылку.

  • Обновление вставленных внешних чертежей

    При открытии чертежа все вхождения DWG (внешние ссылки) автоматически обновляются. Можно также обновить внешние ссылки, чтобы убедиться, что на главном чертеже отображаются самые последние версии чертежей внешних ссылок.

  • Архивные чертежи, содержащие внешние чертежи (внедрение)

    При архивации окончательных версий чертежей можно выбрать способ сохранения внешних ссылок.


Обновление и внедрение внешних чертежей (Процедура)

Удаление вхождений чертежей
Обновление и внедрение внешних чертежей
Вложенные и наложенные внешние чертежи
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей >
Обновление и внедрение внешних чертежей
Понятие Процедура

Наложение внешней ссылки

Обновление вставленной внешней ссылки

Внедрение внешней ссылки в текущий чертеж


Вложенные и наложенные внешние чертежи (Понятие)

Обновление и внедрение внешних чертежей
Обновление и внедрение внешних чертежей
Обновление вставленных внешних чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей >
Вложенные и наложенные внешние чертежи
Понятие Процедура Краткий справочник

Вставленные вхождения DWG (внешние ссылки) могут быть вложенными: это означает, что можно вставить внешнюю ссылку, которая в свою очередь содержит другую внешнюю ссылку.

Одни внешние ссылки могут быть вложенными в другие: это означает, что можно вставить внешнюю ссылку, которая в свою очередь также содержит внешнюю ссылку. Одна и та же ссылка может быть вставлена в чертеж неограниченное число раз, причем с различными масштабными коэффициентами и углами поворота.

В следующем примере чертеж master.dwg ссылается на чертежи a.dwg и b.dwg. Чертеж a.dwg ссылается на чертеж c.dwg. В чертеже master.dwg чертеж c.dwg является вложенной внешней ссылкой.

Кроме того, можно выполнять наложение внешних ссылок на чертеж. Отличие наложения от вставки заключается в том, что, когда чертеж со ссылками сам вставляется в другой чертеж или накладывается на него, его вставленные ссылки загружаются и отображаются на экране, а наложенные - нет. Наложенные ссылки применяются при совместной работе нескольких пользователей над данными. Они позволяют проследить, как чертеж согласуется с чертежами, выполняемыми другими разработчиками, без выполнения вставки внешних ссылок, изменяющих чертеж.

Пусть, например, несколько человек работают над чертежами, на которые ссылается чертеж master.dwg. Пользователь, который работает над чертежом a.dwg должен видеть результат работы того, кто редактировал b.dwg, при этом файл b.dwg не должен быть внешней ссылкой, поскольку в этом случае в главном чертеже master.dwg он будет представлен дважды. Вместо этого, пользователь должен наложить файл b.dwg, тогда при использовании файла a.dwg в главном чертеже master.dwg наложенный файл открываться не будет.

Относительные сохраненные пути и вложенные внешние ссылки

Для внешней ссылки можно сохранить полный путь, сохранить относительный (частичный) путь или не сохранять никакого пути. Для вложенной ссылки относительный путь, как правило, указывает на непосредственное расположение ссылки, частным случаем которого может быть текущий открытый чертеж.


Наложение внешней ссылки (Процедура)

Обновление и внедрение внешних чертежей
На уровень вверх ..
Обновление вставленных внешних чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей > Вложенные и наложенные внешние чертежи >
Вложенные и наложенные внешние чертежи
Понятие Процедура Краткий справочник

Наложение внешней ссылки

  1. Перейдите на вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] "DWG". В командной строке введите "ссвставить".
  2. В диалоговом окне "Выбор файла внешней ссылки" выберите файл для вставки. Нажмите кнопку "Открыть".
  3. В поле "Тип ссылки" диалогового окна "Внешняя ссылка" выберите "Наложенная".
  4. Задайте точку вставки, масштаб и угол поворота. Для того чтобы задать какой-либо параметр с помощью устройства указания, нужно установить флажок "Указать на экране" в соответствующей группе опций.

    Использование опции "Наложенная" исключает вложенность внешних ссылок.

  5. Нажмите "ОК".
Панель:Ссылка
Ввод команды: ССВСТАВИТЬ


Вложенные и наложенные внешние чертежи (Краткий справочник)

Удаление вхождений чертежей
Вложенные и наложенные внешние чертежи
Обновление вставленных внешних чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей > Вложенные и наложенные внешние чертежи >
Вложенные и наложенные внешние чертежи
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

XREFTYPE

Управление типом ссылки по умолчанию при вставке или наложении внешней ссылки

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Обновление вставленных внешних чертежей (Понятие)

Вложенные и наложенные внешние чертежи
Обновление и внедрение внешних чертежей
Архивные чертежи, содержащие внешние чертежи (внедрение)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей >
Обновление вставленных внешних чертежей
Понятие Процедура Краткий справочник

При открытии чертежа все вхождения DWG (внешние ссылки) автоматически обновляются. Можно также обновить внешние ссылки, чтобы убедиться, что на главном чертеже отображаются самые последние версии чертежей внешних ссылок.

При открытии чертежа все внешние ссылки автоматически обновляются. Для обновления внешних ссылок используется команда обновления палитры "Внешние ссылки", если требуется гарантировать отображение на чертеже самых последних версий внешних ссылок.

После сохранения отредактированного чертежа внешней ссылки в локальной сети любой другой можно отобразить изменения на своем чертеже, обновив внешнюю ссылку.

Уведомление об изменении внешних ссылок

При вставке в чертеж внешних ссылок программа периодически проверяет, не изменились ли файлы, на которые они ссылаются с момента последней загрузки или обновления чертежей. Уведомлениями о состоянии внешних ссылок управляет системная переменная XREFNOTIFY.

По умолчанию при изменении файла, на который есть ссылка, рядом со значком внешней ссылки в правом нижнем углу окна приложения (в строке состояния) появляется всплывающее уведомление. Необходимо нажать ссылку в уведомлении, чтобы обновить все изменившиеся внешние ссылки.

Если закрыть всплывающее уведомление, не обновив ссылку, на значке внешней ссылки появится восклицательный знак. При нажатии на значке внешних ссылок открывается палитра "Внешние ссылки".

По умолчанию программа проверяет изменение файлов внешних ссылок каждые пять минут. Интервал времени между проверками можно изменить, установив значение переменной реестра XNOTIFYTIME(setenv "XNOTIFYTIME" "n"), где n - количество минут от 1 до 10080 (семь дней).

ПримечаниеПри изменении значения переменной XNOTIFYTIME необходимо ввестиXNOTIFYTIME заглавными буквами, как показано.

Обновление внешних ссылок в режиме подгрузки

Режим подгрузки при загрузке или обновлении внешней ссылки

  • Если для системной переменной XLOADCTL установлено значение 1, чертеж внешней ссылки будет оставаться открытым в заблокированном состоянии. Никто, кроме открывшего его пользователя, не сможет изменить чертеж внешней ссылки.
  • Если для системной переменной XLOADCTL установлено значение 2, то будет открыта и заблокирована временная копия последней сохраненной версии файла внешней ссылки. Другие пользователи могут открывать и изменять чертеж внешней ссылки.

Дополнительную информацию о подгрузке см. в разделе Увеличение производительности при работе с большими внешними чертежами.


Обновление вставленной внешней ссылки (Процедура)

Вложенные и наложенные внешние чертежи
На уровень вверх ..
Архивные чертежи, содержащие внешние чертежи (внедрение)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей > Обновление вставленных внешних чертежей >
Обновление вставленных внешних чертежей
Понятие Процедура Краткий справочник

Обновление вставленной внешней ссылки

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите имя вхождения, которое требуется обновить.
  3. Нажмите правую кнопку мыши и выберите "Обновить".
ПримечаниеЕсли чертеж выбранной ссылки был изменен уже после открытия основного чертежа, то внешняя ссылка обновляется.
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Обновление вставленных внешних чертежей (Краткий справочник)

Вложенные и наложенные внешние чертежи
Обновление вставленных внешних чертежей
Архивные чертежи, содержащие внешние чертежи (внедрение)
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей > Обновление вставленных внешних чертежей >
Обновление вставленных внешних чертежей
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ВНССЫЛКИЗАКР

Закрытие палитры "Внешние ссылки"

ЛОТОКНАСТР

Управление отображением значков и уведомлений в области уведомлений строки состояния

Системные переменные

INDEXCTL

Управление созданием слоевых и пространственных индексов и сохранением их в файле чертежа

TRAYICONS

Управление отображением области уведомлений в строке состояния

TRAYICONS

Управление отображением уведомлений служб в области уведомлений строки состояния

TRAYTIMEOUT

Управление временем (в секундах), в течение которого отображаются уведомления служб

XEDIT

Управление возможностью контекстного редактирования текущего чертежа при использовании его в качестве внешней ссылки

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

XLOADPATH

Создание пути для хранения временных копий файлов подгруженных внешних ссылок

XREFNOTIFY

Управление уведомлением для обновленных или отсутствующих внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Архивные чертежи, содержащие внешние чертежи (внедрение) (Понятие)

Обновление вставленных внешних чертежей
Обновление и внедрение внешних чертежей
Подрезка внешних чертежей и блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей >
Архивные чертежи, содержащие внешние чертежи (внедрение)
Понятие Процедура Краткий справочник

При архивации окончательных версий чертежей можно выбрать способ сохранения внешних ссылок.

Существует два способа сохранения внешних ссылок в окончательной версии чертежа:

  • сохранение файлов-ссылок вместе с основным чертежом;
  • внедрение файлов-ссылок в основной чертеж.

Файлы внешних ссылок, сохраняемые вместе с основным чертежом, должны всегда размещаться вместе с основным файлом. При любом изменении файлов-ссылок происходит обновление внешних ссылок в основном чертеже.

Чтобы избежать случайного обновления внешних ссылок в окончательном чертеже, следует выполнить их внедрение.

При внедрении в чертеж ссылка перестает быть простым указателем на внешний файл и становится постоянной частью текущего чертежа. С помощью опции "Внедрить" команды ССЫЛКА можно внедрить всю базу данных файла-ссылки, включая именованные объекты (блоки, размерные стили, слои, типы линий и текстовые стили). Дополнительную информацию см. в разделе Управление именованными объектами внешних ссылок.

Внедрение внешних ссылок в чертеж можно также использовать в целях подготовки чертежа для просмотра другими пользователями. После внедрения внешних ссылок исчезает необходимость отсылать вместе с файлом чертежа все его внешние ссылки.

ПримечаниеНельзя внедрять внешние ссылки, содержащие объекты-заместители. Дополнительную информацию см. в разделе Работа со сторонними объектами и заместителями.


Внедрение внешней ссылки в текущий чертеж (Процедура)

Обновление вставленных внешних чертежей
На уровень вверх ..
Подрезка внешних чертежей и блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей > Архивные чертежи, содержащие внешние чертежи (внедрение) >
Архивные чертежи, содержащие внешние чертежи (внедрение)
Понятие Процедура Краткий справочник

Внедрение внешней ссылки в текущий чертеж

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите имя вхождения, которое требуется внедрить.
  3. Нажмите правую кнопку мыши и выберите "Внедрить".
  4. В диалоговом окне "Внедрение ссылок" выберите одну из нижеприведенных опций.
    • Внедрение: преобразовывает объекты, содержащиеся во внешней ссылке, во вхождения блоков. Описания именованных объектов добавляются в текущий чертеж с префиксом "имя_блока$n$".
    • Вставка: также преобразовывает объекты, содержащиеся во внешней ссылке, во вхождения блоков. Однако описания именованных объектов вносятся в текущий чертеж без использования префиксов.
  5. Нажмите "OK" для закрытия каждого диалогового окна.
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Архивные чертежи, содержащие внешние чертежи (внедрение) (Краткий справочник)

Обновление вставленных внешних чертежей
Архивные чертежи, содержащие внешние чертежи (внедрение)
Подрезка внешних чертежей и блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Обновление и внедрение внешних чертежей > Архивные чертежи, содержащие внешние чертежи (внедрение) >
Архивные чертежи, содержащие внешние чертежи (внедрение)
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ВНЕДРИТЬ

Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж

Системные переменные

BINDTYPE

Управление обработкой имен внешних ссылок при внедрении или контекстном редактировании внешних ссылок

XEDIT

Управление возможностью контекстного редактирования текущего чертежа при использовании его в качестве внешней ссылки

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подрезка внешних чертежей и блоков (Понятие)

Архивные чертежи, содержащие внешние чертежи (внедрение)
Внешние ссылки
Редактирование внешних чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки >
Подрезка внешних чертежей и блоков
Понятие Процедура Краткий справочник

Предусмотрена возможность задания подрезающего контура для отображения ограниченного фрагмента вставленного блока или внешней ссылки.

Задать подрезающий контур можно с помощью команды ССПОДРЕЗАТЬ. Подрезающий контур определяет фрагмент блока или внешней ссылки (вне или внутри контура), который не отображается.

Подрезка применяется не к определению внешней ссылки или блока, а к отдельному экземпляру. Объекты внешней ссылки или блока не изменяются; подрезка влияет только на их отображение.

Ниже указаны параметры просмотра, которыми можно управлять с помощью команды ССПОДРЕЗАТЬ.

  • Отображение или скрытие подрезающего контура
  • Отображение или скрытие отрезанной области внешней ссылки или блока

Управление отображением подрезающего контура

Для отображения подрезающего контура (называемого также подрезающей рамкой) можно включить системную переменную XCLIPFRAME. Если подрезающий контур включен (задано значение 1), его можно выбрать и распечатать.

Управление отображением отрезанной области

С помощью команды ССПОДРЕЗАТЬ можно включить или отключить подрезку. Эта команда определяет скрытие или отображение отрезанной области.

Если подрезка отключена, контур не отображается, а внешняя ссылка отображается полностью, при условии, что слои, в которых расположены объекты, включены и не зафиксированы.

Редактирование параметров

После подрезки внешней ссылки или блока ее можно перемещать, копировать и поворачивать точно так же, как неподрезанную внешнюю ссылку или блок. Подрезающий контур перемещается вместе со ссылкой. Операция подрезки действует одинаково как на ссылки первого уровня, так и на вложенные ссылки. Если подрезана главная ссылка, все вложенные ссылки также выводятся подрезанными.

Выбор параметров подрезающего контура

С помощью команды ССПОДРЕЗАТЬ можно выполнять операции следующих типов.

  • Создание нового подрезающего контура
  • Удаление существующего подрезающего контура
  • Формирование полилинии, совпадающей с подрезающим контуром
  • Переключение между вариантами скрытия области (вне или внутри подрезающего контура)

Изменение размера контура подрезки

Если необходимо изменить форму или размер непрямоугольных контуров подрезки внешних ссылок и блоков, редактирование вершин, как и любых других объектов, можно выполнять с помощью ручек.

ПримечаниеКоманда ССПОДРЕЗАТЬ не поддерживает самопересекающиеся многоугольные контуры. На экран будет выведено сообщение об ошибке, после чего будет осуществлен возврат к последнему "правильному" контуру.

При редактировании прямоугольных объектов с помощью ручек всегда поддерживается перпендикулярность взаиморасположения двух перетаскиваемых отрезков.

Ограничения подрезки внешних ссылок

При подрезке внешней ссылки или блока необходимо учитывать следующие правила.

  • Подрезающий контур можно задать в любом месте трехмерного пространства, но применяется он всегда параллельно текущей пользовательской системе координат.
  • Во втором случае плоскость контура совпадает с плоскостью исходной полилинии.
  • Подрезка изображений во внешних ссылках или блоках всегда выполняется по прямоугольным контурам. Если во внешней ссылке имеются растровые изображения, они подрезаются не по многоугольному контуру, а по описанному вокруг него прямоугольному.


Подрезка внешних чертежей и блоков (Процедура)

Архивные чертежи, содержащие внешние чертежи (внедрение)
Подрезка внешних чертежей и блоков
Подрезка внешних чертежей и блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Подрезка внешних чертежей и блоков >
Подрезка внешних чертежей и блоков
Понятие Процедура Краткий справочник

Процедура подрезки внешней ссылки

Инвертирование области подрезки


Процедура подрезки внешней ссылки (Процедура)

Подрезка внешних чертежей и блоков
Подрезка внешних чертежей и блоков
Подрезка внешних чертежей и блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Подрезка внешних чертежей и блоков >
Подрезка внешних чертежей и блоков
Понятие Процедура Краткий справочник

Процедура подрезки внешней ссылки

  1. Перейдите на вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] "Подрезка внешней ссылки". В командной строке введите "ссподрезать".
  2. Выберите внешнюю ссылку.
  3. При отображении приглашения выберите задание нового контура, нажав клавишу ENTER.
  4. Задайте прямоугольный или многоугольный подрезающий контур. Задайте углы или вершины контура.
  5. При необходимости с помощью параметра "Обратная подрезка" задайте скрытие области не вне, а внутри подрезающего контура.

    На основе заданной области выполняется подрезка внешней ссылки: фрагмент внешней ссылки, расположенный вне или внутри подрезающего контура, становится скрытым.

Панель:Ссылка
Ввод команды: ССПОДРЕЗАТЬ


Инвертирование области подрезки (Процедура)

Подрезка внешних чертежей и блоков
Подрезка внешних чертежей и блоков
Редактирование внешних чертежей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Подрезка внешних чертежей и блоков >
Подрезка внешних чертежей и блоков
Понятие Процедура Краткий справочник

Инвертирование области подрезки

  1. Для системной переменной XCLIPFRAME установите значение 1. Отобразится контур подрезки для ссылки.
  2. Перейдите на вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] "Подрезка внешней ссылки". В командной строке введите "ссподрезать".
  3. Выберите внешнюю ссылку.
  4. При отображении приглашения выберите задание нового контура, нажав клавишу ENTER.
  5. Задайте прямоугольный или многоугольный подрезающий контур. Задайте углы или вершины контура.
  6. Выберите контур подрезки. Посередине первой кромки контура подрезки должна быть видна ручка [image].
  7. Чтобы инвертировать текущую область x-clip, щелкните на этой ручке. Теперь ручка указывает в противоположную сторону.
Панель:Ссылка
Ввод команды: ССПОДРЕЗАТЬ


Подрезка внешних чертежей и блоков (Краткий справочник)

Архивные чертежи, содержащие внешние чертежи (внедрение)
Подрезка внешних чертежей и блоков
Редактирование внешних чертежей в отдельном окне
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Подрезка внешних чертежей и блоков >
Подрезка внешних чертежей и блоков
Понятие Процедура Краткий справочник

Команды

ССПОДРЕЗАТЬ

Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока

Системные переменные

XCLIPFRAME

Управление видимостью контуров подрезки внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование внешних чертежей

Подрезка внешних чертежей и блоков
Внешние ссылки
Редактирование внешних чертежей в отдельном окне
Совместное использование данных в чертежах и приложениях > Внешние ссылки >
Редактирование внешних чертежей
Понятие Процедура

Вставленные в качестве внешних ссылок чертежи можно редактировать, открыв их непосредственно или редактируя внешнюю ссылку по месту, из текущего чертежа. Можно также редактировать определение блока непосредственно через любое его вхождение.

Темы в этом разделе

  • Редактирование внешних чертежей в отдельном окне

    Наиболее простой способ редактирования внешней ссылки - открыть чертеж-ссылку в новом окне. Этот способ открывает доступ ко всем объектам чертежа-ссылки.

  • Редактирование выбранных объектов во внешних чертежах и вставленных блоках

    Редактировать внешние ссылки и описания можно не выходя из текущего чертежа, т.е. посредством редактирования их вхождений. Как блоки, так и внешние ссылки вставляются в чертеж в виде вхождений.

  • Использование рабочего набора для редактирования внешних чертежей и вставленных блоков

    Для редактирования вставленного в качестве внешней ссылки чертежа из текущего чертежа создается рабочий набор, позволяющий определить объекты, принадлежащие внешней ссылке или определению блока, а не текущему чертежу.

  • Сохранение отредактированных внешних чертежей и вставленных блоков

    Изменения, произведенные при редактировании вставленного в качестве внешней ссылки чертежа или определения блока в текущем чертеже, можно сохранить в исходном чертеже или отменить.

  • Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами

    Существуют ограничения при редактировании из текущего чертежа внешних чертежей и вставленных блоков с вложенными объектами.


Редактирование внешних чертежей (Процедура)

Подрезка внешних чертежей и блоков
Редактирование внешних чертежей
Редактирование внешних чертежей в отдельном окне
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей >
Редактирование внешних чертежей
Понятие Процедура

Редактирование внешней ссылки в отдельном окне

Редактирование внешней ссылки или блока в контексте чертежа

Добавление объектов в рабочий набор

Исключение объектов из рабочего набора

Сохранение изменений в результате редактирования внешних ссылок и блоков

Отказа от изменений внешних ссылок и блоков


Редактирование внешних чертежей в отдельном окне (Понятие)

Редактирование внешних чертежей
Редактирование внешних чертежей
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей >
Редактирование внешних чертежей в отдельном окне
Понятие Процедура Краткий справочник

Наиболее простой способ редактирования внешней ссылки - открыть чертеж-ссылку в новом окне. Этот способ открывает доступ ко всем объектам чертежа-ссылки.

Вместо того, чтобы искать внешнюю ссылку с помощью диалогового окна "Выбор файла", можно выбрать ее вхождение в текущем чертеже и открыть чертеж-ссылку в новом окне. Для такого способа редактирования внешних ссылок используется палитра "Внешние ссылки" или команда ССОТКРЫТЬ.


Редактирование внешней ссылки в отдельном окне (Процедура)

Редактирование внешних чертежей
На уровень вверх ..
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Редактирование внешних чертежей в отдельном окне >
Редактирование внешних чертежей в отдельном окне
Понятие Процедура Краткий справочник

Редактирование внешней ссылки в отдельном окне

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите имя вхождения, которое требуется отредактировать.
  3. Нажмите правую кнопку мыши и выберите "Открыть".
  4. Выбранный внешний чертеж открывается в новом окне, в котором его редактируют, сохраняют, а затем закрывают чертеж.
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Редактирование внешних чертежей в отдельном окне (Краткий справочник)

Подрезка внешних чертежей и блоков
Редактирование внешних чертежей в отдельном окне
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Редактирование внешних чертежей в отдельном окне >
Редактирование внешних чертежей в отдельном окне
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование выбранных объектов во внешних чертежах и вставленных блоках (Понятие)

Редактирование внешних чертежей в отдельном окне
Редактирование внешних чертежей
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей >
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Понятие Процедура Краткий справочник

Редактировать внешние ссылки и описания можно не выходя из текущего чертежа, т.е. посредством редактирования их вхождений. Как блоки, так и внешние ссылки вставляются в чертеж в виде вхождений.

Редактируя вхождение внешней ссылки в контексте текущего чертежа, проектировщик может вносить изменения в ссылку и видеть, как это отразится на всем чертеже.

Часто чертежи содержат в себе несколько различных вхождений внешних ссылок и блоков. При работе с ссылками на блоки можно выбрать блок, изменить его, просмотреть и отредактировать его свойства, обновить определение блока.

Также с помощью вхождений можно выбрать и отредактировать внешнюю ссылку, а затем записать изменения в исходный файл внешней ссылки. Таким образом, отпадает необходимость постоянно переключаться из одного чертежа в другой при необходимости внести незначительные изменения.

Примечание Значительные изменения внешних ссылок и блоков рекомендуется выполнять непосредственно в исходном внешнем чертеже. Редактирование вхождения внешней ссылки в контексте текущего чертежа может сильно увеличить размер файла (если производятся существенные изменения).

Понятие рабочего набора

Выбирать можно только объекты, принадлежащие предназначенному для редактирования вхождению. Программа извлекает требуемые объекты из выбранного вхождения и делает их доступными для редактирования в текущем чертеже. Набор извлеченных объектов, или рабочий набор, можно изменить, а затем сохранить в исходный файл внешней ссылки или определение блока. Объекты, входящие в рабочий набор, визуально выделяются среди других объектов чертежа. По сравнению с объектами, входящими в рабочий набор, все остальные объекты выглядят более бледно.

Затенение объектов

Интенсивностью отображения объектов в ходе редактирования вхождений управляет системная переменная XFADECTL. Все объекты, извлеченные из вхождения, отображаются обычным образом. Все остальные объекты текущего чертежа, не входящие в рабочий набор, выглядят более бледно. Переменная управляет интенсивностью отображения объектов, не входящих в рабочий набор. Чем больше значение переменной XFADECTL, тем менее ярко выглядят объекты.

ПримечаниеЕсли в команде РЕЖИМРАСКР установлен режим, отличный от "2D каркас", объекты, не входящие в рабочий набор, не затеняются.

Использование вкладки ленты "Редактирование вхождений"

Если для редактирования выбираются вложенные объекты при включенной ленте, отображается вкладка ленты "Редактирование вхождений". С помощью кнопок этой вкладки можно добавить или исключить объекты из рабочего набора, а также сохранить или отказаться от сохранения изменений вхождения. Вкладка "Редактирование вхождений" автоматически сворачивается после сохранения (или отказа от сохранения) внесенных в рабочий набор изменений.

Панель "Редактирование вхождений"

Если лента выключена, панель "Редактирование вхождений" отображается и активизируется после выбора пользователем вложенных объектов для редактирования. С помощью кнопок этой панели можно добавить или исключить объекты из рабочего набора, а также сохранить или отказаться от сохранения изменений вхождения. Панель "Редактирование вхождений" автоматически сворачивается после завершения редактирования вхождения, если только она не фиксирована у границ окна.


Редактирование внешней ссылки или блока в контексте чертежа (Процедура)

Редактирование внешних чертежей в отдельном окне
На уровень вверх ..
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Редактирование выбранных объектов во внешних чертежах и вставленных блоках >
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Понятие Процедура Краткий справочник

Редактирование внешней ссылки или блока в контексте чертежа

  1. Выберите меню "Сервис" [image] "Внешняя ссылка или блок для контекстного редактирования" [image] "Редактирование вхождений"В командной строке введите ссылред.
  2. В текущем чертеже выберите вхождение, которое необходимо отредактировать.

    Если выбранный объект принадлежит одному из вложенных вхождений, все доступные для редактирования вхождения выводятся в диалоговом окне "Редактирование вхождений".

  3. В диалоговом окне "Редактирование вхождений" выберите ссылку для редактирования.

    Файл вхождения будет заблокирован для предотвращения одновременного открытия файла несколькими пользователями. Если исходный файл ссылки используется каким-либо другим пользователем, ее вхождение становится недоступным для редактирования в текущем чертеже.

  4. Нажмите "ОК".
  5. Выберите принадлежащие вхождению объекты, которые нужно отредактировать, и нажмите ENTER.

    Выбранные объекты образуют рабочий набор. По умолчанию все остальные объекты будут заблокированы и затенены.

  6. Выполните редактирование объектов рабочего набора. Нажмите "Сохранить изменения".

    Объекты рабочего набора сохраняются; вхождение ссылки или блока в текущий чертеж обновляется.

Ввод команды: ССЫЛРЕД


Редактирование выбранных объектов во внешних чертежах и вставленных блоках (Краткий справочник)

Редактирование внешних чертежей в отдельном окне
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Редактирование выбранных объектов во внешних чертежах и вставленных блоках >
Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Понятие Процедура Краткий справочник

Команды

ССЫЛЗАКР

Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок

ССЫЛРЕД

Выбор внешней ссылки или вхождения блока для редактирования

ССЫЛНАБ

Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок

РЕЖИМРАСКР

Системные переменные

BINDTYPE

Управление обработкой имен внешних ссылок при внедрении или контекстном редактировании внешних ссылок

REFEDITNAME

Имя редактируемого вхождения

XEDIT

Управление возможностью контекстного редактирования текущего чертежа при использовании его в качестве внешней ссылки

XFADECTL

Управление процентом интенсивности затенения для редактируемых ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование рабочего набора для редактирования внешних чертежей и вставленных блоков (Понятие)

Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Редактирование внешних чертежей
Сохранение отредактированных внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей >
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Для редактирования вставленного в качестве внешней ссылки чертежа из текущего чертежа создается рабочий набор, позволяющий определить объекты, принадлежащие внешней ссылке или определению блока, а не текущему чертежу.

В ходе редактирования вхождений в рабочий набор можно добавлять новые объекты, а также исключать из него уже имеющиеся. Новые объекты, создаваемые в процессе редактирования вхождения, практически всегда добавляются в рабочий набор автоматически. Объекты, не включенные в рабочий набор, отображаются в чертеже более бледно.

Новые объекты, созданные в результате изменения объектов, не входящих в рабочий набор, не добавляются в рабочий набор. Например, пусть в чертеже имеются два отрезка, не входящие в рабочий набор. При выполнении команды СОПРЯЖЕНИЕ между отрезками создается дуга. При этом вновь созданная дуга не добавляется в рабочий набор.

Объект, входящий в рабочий набор, можно выбирать для редактирования, даже если слой, на котором он расположен в исходном файле, блокирован. Слой можно разблокировать и после этого отредактировать объект. Хотя изменения в объекте могут быть сохранены, это не влияет на состояние слоя (блокированный или нет) в исходном файле.

Объект, исключенный из рабочего набора, добавляется в основной чертеж и удаляется из вхождения при сохранении изменений. Объект, добавленный в рабочий набор, удаляется из основного чертежа и заносится во вхождение при сохранении изменений. Вновь созданные или удаленные объекты автоматически добавляются или удаляются из рабочего набора. Например, после применения команды СТЕРЕТЬ в ходе редактирования вхождения, стертые объекты удаляются из рабочего набора. Можно определить, принадлежит ли объект рабочему набору, по способу его отображения - если объект затенен, он не принадлежит рабочему набору.

Использование вкладки ленты "Редактирование вхождений"

Если выбрано вхождение для контекстного редактирования при включенной ленте, отображается вкладка "Редактирование вхождений". Имя выбранного вхождения отображается на вкладке. Расположенные на вкладке кнопки редактирования ("Добавить объекты в рабочий набор", "Исключить объекты из рабочего набора", "Отказаться от изменений" и "Сохранить изменения") активны только во время контекстного редактирования вхождений. Вкладка ленты "Редактирование вхождений" автоматически сворачивается после сохранения или отклонения внесенных изменений.

Панель "Редактирование вхождений"

Если лента выключена, панель "Редактирование вхождений" отображается при выполнении контекстного редактирования вхождения. В ней указывается имя выбранного вхождения. Кнопки редактирования, расположенные на этой панели ("Добавить объекты в рабочий набор", "Исключить объекты из рабочего набора", "Отказаться от изменений" и "Сохранить изменения"), активны только в процессе редактирования вхождения. Кнопка "Редактирование блока или внешней ссылки" доступна всегда, даже если режим редактирования вхождения в текущем чертеже не включен. Панель "Редактирование вхождений" автоматически сворачивается после завершения редактирования вхождения.


Использование рабочего набора для редактирования внешних чертежей и вставленных блоков (Процедура)

Редактирование выбранных объектов во внешних чертежах и вставленных блоках
На уровень вверх ..
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Использование рабочего набора для редактирования внешних чертежей и вставленных блоков >
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Добавление объектов в рабочий набор

Исключение объектов из рабочего набора


Добавление объектов в рабочий набор (Процедура)

Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
На уровень вверх ..
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Использование рабочего набора для редактирования внешних чертежей и вставленных блоков >
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Добавление объектов в рабочий набор

  1. Выберите пункт меню "Сервис" [image] "Внешняя ссылка или блок для контекстного редактирования" [image] "Добавить в рабочий набор".

    Другой способ: в командной строке введите ссылнаб.

  2. Введя ссылнаб в командную строку, на вкладке ленты или на панели "Редактирование вхождений" нажмите кнопку "Добавить объекты в рабочий набор".

  3. Выберите объекты для добавления. Можно также присвоить переменной PICKFIRST значение 1, чтобы создать набор объектов перед добавлением.

    Команда ССЫЛНАБ применяется только для объектов, находящихся в том пространстве (листа или модели), из которого была вызвана команда ССЫЛРЕД.


Исключение объектов из рабочего набора (Процедура)

Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
На уровень вверх ..
Сохранение отредактированных внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Использование рабочего набора для редактирования внешних чертежей и вставленных блоков >
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Исключение объектов из рабочего набора

  1. Выберите пункт меню "Сервис" [image] "Внешняя ссылка или блок для контекстного редактирования" [image] "Исключить из рабочего набора".

    Другой способ: в командной строке введите ссылнаб.

  2. Введя ссылнаб в командную строку, на вкладке или на панели "Редактирование вхождений" нажмите кнопку "Исключить объекты из рабочего набора".

  3. Выберите объекты для исключения. Можно также присвоить переменной PICKFIRST значение 1, чтобы создать набор объектов перед исключением.

    Команда ССЫЛНАБ применяется только для объектов, находящихся в том пространстве (листа или модели), из которого была вызвана команда ССЫЛРЕД.


Использование рабочего набора для редактирования внешних чертежей и вставленных блоков (Краткий справочник)

Редактирование выбранных объектов во внешних чертежах и вставленных блоках
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Сохранение отредактированных внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Использование рабочего набора для редактирования внешних чертежей и вставленных блоков >
Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Команды

ССЫЛЗАКР

Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок

ССЫЛРЕД

Выбор внешней ссылки или вхождения блока для редактирования

ССЫЛНАБ

Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок

Системные переменные

XEDIT

Управление возможностью контекстного редактирования текущего чертежа при использовании его в качестве внешней ссылки

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение отредактированных внешних чертежей и вставленных блоков (Понятие)

Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Редактирование внешних чертежей
Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей >
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Изменения, произведенные при редактировании вставленного в качестве внешней ссылки чертежа или определения блока в текущем чертеже, можно сохранить в исходном чертеже или отменить.

Изменения, произведенные при редактировании определения блока в текущем чертеже, можно сохранить в текущем чертеже или отменить. При сохранении изменений вхождения будет выполнена регенерация чертежа.

После сохранения изменений определение блока будет обновлено, а все экземпляры блока будут регенерированы с учетом произведенных изменений. Если пользователь отказывается от изменений, то рабочий набор удаляется, и вхождение блока возвращается в исходное состояние.

Аналогично, при редактировании внешней ссылки в текущем чертеже сделанные изменения можно сохранить или отменить. Новые свойства, ранее не присутствовавшие во внешнем файле, заданные для объектов рабочего набора, сохраняются в исходном чертеже. Например, пусть внешняя ссылка содержит слои A, B и C, а в текущем чертеже имеется также слой D. Если в ходе редактирования вхождения по месту новые объекты создавались на слое D и изменения сохранялись в исходном чертеже, то этот слой при сохранении изменений копируется в чертеж внешней ссылки.

Объекты, исключенные из рабочего набора, при сохранении изменений удаляются из вхождения и добавляются в основной чертеж. Изменения, произведенные с объектами текущего чертежа (не входящими во внешнюю ссылку или блок), остаются в чертеже. Удаленные объекты, не входящие в рабочий набор, не восстанавливаются даже после отказа от изменений. Вернуть чертеж в его начальное состояние можно с помощью команды ОТМЕНИТЬ. Отменить нежелательные изменения, записанные в исходный файл внешней ссылки при выполнении команды ССЫЛЗАКР также можно с помощью команды ОТМЕНИТЬ. Отменив все нежелательные изменения, нужно снова воспользоваться командой ССЫЛЗАКР, чтобы записать восстановленные объекты в исходный файл внешней ссылки.

ПредупреждениеУдаленные в ходе редактирования вхождения в текущем чертеже объекты, не входящие в рабочий набор, не восстанавливаются даже после отказа от изменений вхождения.

Объекты текущего чертежа, наследующие свойства из внешнего файла, сохраняют свои новые свойства, полученные после изменения. Свойства, изначально взятые из внешнего файла, внедряются в текущий чертеж. Так, например, слой с именем SITE, если он был присвоен объекту, не входившему в рабочий набор, появляется в текущем чертеже с именем $#$SITE. Если переменной BINDTYPE присвоено значение 0, то ко всем внедряемым именам символов добавляется префикс $#$. Если переменной BINDTYPE присвоено значение 1, то имена символов при внедрении в текущий чертеж остаются без изменений.

ПримечаниеПосле редактирования вхождения внешней ссылки в текущем чертеже, изображение, использовавшееся для предварительного просмотра внешнего файла, становится недоступным и возобновляется только после открытия и сохранения файла внешней ссылки.


Сохранение отредактированных внешних чертежей и вставленных блоков (Процедура)

Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
На уровень вверх ..
Сохранение отредактированных внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Сохранение отредактированных внешних чертежей и вставленных блоков >
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Сохранение изменений в результате редактирования внешних ссылок и блоков

Отказа от изменений внешних ссылок и блоков


Сохранение изменений в результате редактирования внешних ссылок и блоков (Процедура)

Сохранение отредактированных внешних чертежей и вставленных блоков
На уровень вверх ..
Сохранение отредактированных внешних чертежей и вставленных блоков
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Сохранение отредактированных внешних чертежей и вставленных блоков >
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Сохранение изменений в результате редактирования внешних ссылок и блоков

  • Выберите пункт меню "Сервис" [image] "Внешняя ссылка или блок для контекстного редактирования" [image] "Сохранить изменения вхождения".

    Другой способ: на вкладке или на панели "Редактирование вхождений" нажмите кнопку "Сохранить изменения".

Панель:Редактирование вхождений
Ввод команды: ССЫЛЗАКР


Отказа от изменений внешних ссылок и блоков (Процедура)

Сохранение отредактированных внешних чертежей и вставленных блоков
На уровень вверх ..
Ошибки обработки чертежей-ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Сохранение отредактированных внешних чертежей и вставленных блоков >
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Отказа от изменений внешних ссылок и блоков

  • На вкладке или на панели "Редактирование вхождений" нажмите кнопку "Отказаться от изменений".
Панель:Редактирование вхождений
Ввод команды: ССЫЛЗАКР
Контекстное меню:Если при контекстном редактировании вхождений нет выбранных объектов, нажмите правую кнопку мыши в области чертежа. Выберите "Завершение сеанса ССЫЛРЕД".


Сохранение отредактированных внешних чертежей и вставленных блоков (Краткий справочник)

Использование рабочего набора для редактирования внешних чертежей и вставленных блоков
Сохранение отредактированных внешних чертежей и вставленных блоков
Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Сохранение отредактированных внешних чертежей и вставленных блоков >
Сохранение отредактированных внешних чертежей и вставленных блоков
Понятие Процедура Краткий справочник

Команды

ССЫЛЗАКР

Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок

ССОТКРЫТЬ

Открытие выбранной внешней ссылки на чертеж (xref) в новом окне

Системные переменные

BINDTYPE

Управление обработкой имен внешних ссылок при внедрении или контекстном редактировании внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами (Понятие)

Сохранение отредактированных внешних чертежей и вставленных блоков
Редактирование внешних чертежей
Ошибки обработки чертежей-ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей >
Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Понятие Краткий справочник

Существуют ограничения при редактировании из текущего чертежа внешних чертежей и вставленных блоков с вложенными объектами.

Если в выбранном для редактирования вхождении есть вставленные внешние ссылки или описания блоков, то ссылки и вложенные в них ссылки будут отображены и могут быть выбраны в диалоговом окне "Редактирование вхождений". Однако при этом здесь появляются только те вхождения, которым принадлежат выбранные объекты. Пользователь не может редактировать одновременно несколько вхождений. OLE-объекты, содержащиеся в редактируемых вхождениях, хотя и отображаются, но не могут быть отредактированы.

Если для редактирования выбран блок с атрибутами, их описания можно отображать в исходном файле и сделать доступными для редактирования. При этом атрибуты становятся невидимыми, а определения атрибутов становятся доступными для редактирования вместе с графическими объектами выбранного вхождения. При сохранении изменений в исходный чертеж определения блока атрибуты в имеющихся вхождениях остаются без изменений. Новые определения атрибутов вступают в силу только для последующих вхождений блока.


Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами (Краткий справочник)

Сохранение отредактированных внешних чертежей и вставленных блоков
Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Обработка отсутствующих внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Редактирование внешних чертежей > Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами >
Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Понятие Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ССЫЛРЕД

Выбор внешней ссылки или вхождения блока для редактирования

ССЫЛНАБ

Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Ошибки обработки чертежей-ссылок

Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Внешние ссылки
Обработка отсутствующих внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки >
Ошибки обработки чертежей-ссылок
Понятие Процедура

Если при открытии чертежа не удается загрузить чертеж-внешнюю ссылку, то появляется сообщение об ошибке.

Темы в этом разделе

  • Обработка отсутствующих внешних ссылок

    Если при открытии чертежа не удается обнаружить файл внешней ссылки, то появляется сообщение об ошибке. Пользователю предлагается несколько способов решения этой проблемы.

  • Обработка циклических внешних ссылок

    Если внешний чертеж содержит цепь вложенных ссылок, один из элементов которой ссылается на элемент цепи из числа предыдущих, выдается сообщение об ошибке.

  • Управление именованными объектами внешних ссылок

    При вставке внешней ссылки имена содержащихся в ней блоков, размерных стилей, слоев, типов линий и текстовых стилей должны отличаться от имен элементов текущего чертежа.

  • Работа с файлом журнала внешних ссылок

    Программа может вести журнал действий при выполнении операций вставки, удаления и обновления ссылок, а также при загрузке чертежей, содержащих внешние ссылки.


Ошибки обработки чертежей-ссылок (Процедура)

Сохранение отредактированных внешних чертежей и вставленных блоков
Ошибки обработки чертежей-ссылок
Обработка отсутствующих внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок >
Ошибки обработки чертежей-ссылок
Понятие Процедура

Изменение пути ко внешней ссылке

Внедрение зависимых от ссылок именованных объектов в текущий чертеж

Переименование слоев, размерных стилей и других именованных объектов

Использование файла журнала внешних ссылок


Обработка отсутствующих внешних ссылок (Понятие)

Ошибки обработки чертежей-ссылок
Ошибки обработки чертежей-ссылок
Обработка циклических внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок >
Обработка отсутствующих внешних ссылок
Понятие Процедура Краткий справочник

Если при открытии чертежа не удается обнаружить файл внешней ссылки, то появляется сообщение об ошибке. Пользователю предлагается несколько способов решения этой проблемы.

Программа запоминает полное имя файла чертежа, используемого для создания вхождения. Программа проверяет путь внешней ссылки каждый раз при загрузке или выводе на печать чертежа или при обновлении внешней ссылки с помощью параметра "Обновить" палитры "Внешние ссылки", чтобы определить имя и местоположение файла внешнего чертежа. Если имя или местоположение файла чертежа было изменено, программа не сможет загрузить внешнюю ссылку.

Если программа не может загрузить внешнюю ссылку при открытии главного чертежа, выводится сообщение об ошибке. Например, программа не может найти внешнюю ссылку HOUSE:

"\acad\dwg\house.dwg": Не удалось открыть файл

** Ошибка при обработке внешней ссылки HOUSE.

В точках вставки внешнего чертежа программа выводит текст (в том же месте и с использованием масштаба и угла поворота исходной ссылки), который содержит путь ненайденной ссылки. Откорректировать и сохранить путь к ссылке можно с помощью опции "Путь" команды ССЫЛКА.

Для избежания таких ошибок при передаче чертежа другим пользователям следует предоставлять все связанные файлы.

Изменение путей вложенных внешних ссылок

При последующем открытии чертежа и загрузке вложенной внешней ссылки программа сначала попытается найти внешнюю ссылку по ее исходному пути. Если это не удается, производится следующий поиск:

  • Текущая папка главного чертежа
  • Пути поиска файлов проекта, заданные в диалоговом окне "Настройка" (вкладка "Файлы") или с помощью системной переменной PROJECTNAME
  • Пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке приложения Microsoft® Windows®

Это гарантирует отражение в чертеже всех изменений ссылок и делает возможным автоматический поиск перемещенных ссылок.

Например, пусть в текущий чертеж A вставлены ссылки, образующие структуру A>B>C, и владелец чертежа B изменил путь к ссылке C так, что теперь он указывает на файл C1.dwg. При последующем открытии чертежа A загружается ссылка B, из которой извлекается информация о текущем положении ссылки C1.dwg. Однако если файл C1.dwg не найден, программа вновь обращается к чертежу A в поисках последнего сохраненного в нем пути к отсутствующей ссылке С.

См. также

    • Обновление вставленных внешних чертежей


Изменение пути ко внешней ссылке (Процедура)

Ошибки обработки чертежей-ссылок
На уровень вверх ..
Управление именованными объектами внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Обработка отсутствующих внешних ссылок >
Обработка отсутствующих внешних ссылок
Понятие Процедура Краткий справочник

Изменение пути ко внешней ссылке

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите внешнюю ссылку.
  3. В группе "Найдено в" выполните одно из следующих действий:
    • Непосредственно введите новый путь ко внешней ссылке.
    • Нажмите кнопку [...] и найдите файл внешней ссылки по его новому пути.
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Обработка отсутствующих внешних ссылок (Краткий справочник)

Редактирование внешних чертежей и блоков с вложенными вхождениями, OLE-объектами и атрибутами
Обработка отсутствующих внешних ссылок
Обработка циклических внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Обработка отсутствующих внешних ссылок >
Обработка отсутствующих внешних ссылок
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Обработка циклических внешних ссылок (Понятие)

Обработка отсутствующих внешних ссылок
Ошибки обработки чертежей-ссылок
Управление именованными объектами внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок >
Обработка циклических внешних ссылок
Понятие Краткий справочник

Если внешний чертеж содержит цепь вложенных ссылок, один из элементов которой ссылается на элемент цепи из числа предыдущих, выдается сообщение об ошибке.

Циклической называется цепь вложенных ссылок, один из элементов которой ссылается на элемент цепи из числа предыдущих. Например, если чертеж A ссылается на чертеж B, чертеж B на чертеж C, а последний вновь на чертеж A, цепь ссылок A>B>C>A является циклической.

Если при вставке внешней ссылки программа обнаруживает появление цикличности, отображается предупреждение с вопросом, желает ли пользователь продолжить обработку ссылок. В случае положительного ответа программа считывает внешнюю ссылку и все вложенные в нее ссылки пока не обнаружит некорректный элемент. В случае отрицательного ответа процесс будет остановлен, а внешняя ссылка не будет вставлена в чертеж.

Если при загрузке чертежа встречается циклическая ссылка, отображается сообщение об ошибке и циклическая ссылка разрывается на время текущего сеанса работы. Например, если имеется цепь внешних ссылок A>B>C>A, и пользователь открывает файл a.dwg, программа находит и разрывает циклическую связь между чертежами c.dwg и a.dwg. При этом выводится сообщение:

Разрывается циклическая ссылка из С на текущий чертеж.


Обработка циклических внешних ссылок (Краткий справочник)

Обработка отсутствующих внешних ссылок
Обработка циклических внешних ссылок
Управление именованными объектами внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Обработка циклических внешних ссылок >
Обработка циклических внешних ссылок
Понятие Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление именованными объектами внешних ссылок (Понятие)

Обработка циклических внешних ссылок
Ошибки обработки чертежей-ссылок
Работа с файлом журнала внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок >
Управление именованными объектами внешних ссылок
Понятие Процедура Краткий справочник

При вставке внешней ссылки имена содержащихся в ней блоков, размерных стилей, слоев, типов линий и текстовых стилей должны отличаться от имен элементов текущего чертежа.

Как правило, описание внешней ссылки содержит такие графические объекты, как отрезки, дуги и др. Во внешнюю ссылку могут также входить описания блоков, размерные стили, слои, типы линий, а также текстовые стили. При вставке внешней ссылки программа различает имена зависящих от ссылки именованных объектов и объектов текущего чертежа: имени зависящего от ссылки объекта предшествует имя внешнего чертежа и вертикальная черта ( | ). Например, в Диспетчере свойств слоев относящийся к внешней ссылке именованный объект, который находится во внешнем чертеже, названном stair.dwg, на слое с именем STEEL, упоминается в списке как STAIR|STEEL.

Описания зависимых объектов из внешней ссылки не становятся частью текущего чертежа. При каждом обновлении внешней ссылки они заново загружаются из исходного файла.

Внедрение зависящих от внешних ссылок определений

Описание объекта, зависящего от внешней ссылки, может измениться при изменении исходного файла. Например, имя слоя из внешнего чертежа может измениться в процессе редактирования этого чертежа. Если слой будет удален из чертежа-ссылки, то исчезнет и его имя. Поэтому программа не позволяет использовать зависимые от ссылок слои или другие именованные объекты непосредственно. Нельзя, например, вставить в чертеж описанный в ссылке блок или сделать один из ее слоев текущим и начать создавать на нем новые объекты.

Такие операции становятся возможны только после внедрения зависимых от внешних ссылок объектов в чертеж. В результате внедрения внешне-зависимые именованные объекты становятся элементами текущего чертежа.

Внедренные зависимые объекты можно редактировать так же, как и именованные объекты самого чертежа. При внедрении зависимого от внешней ссылки именованного объекта программа преобразует его имя, заменяя символ вертикальной черты (|) на два знака доллара ($$), между которыми ставится число (обычно это ноль); например, имя связанного слоя STAIR|STEEL изменяется на STAIR$0$STEEL. Для изменения STAIR$0$STEEL на STEEL можно впоследствии воспользоваться командой НОВОЕИМЯ.

При внедрении слоя, которому присвоен тип линий, отличный от CONTINUOUS, этот тип линий также будет внедрен в чертеж. Если команда ВНЕДРИТЬ применяется к блоку, то все именованные объекты, на которые ссылаются объекты этого блока, также внедряются в чертеж. Если блок содержит в себе ссылку на внешнюю ссылку, эта внешняя ссылка и все зависимые от нее описания также будут внедрены.


Управление именованными объектами внешних ссылок (Процедура)

Обработка отсутствующих внешних ссылок
На уровень вверх ..
Управление именованными объектами внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Управление именованными объектами внешних ссылок >
Управление именованными объектами внешних ссылок
Понятие Процедура Краткий справочник

Внедрение зависимых от ссылок именованных объектов в текущий чертеж

Переименование слоев, размерных стилей и других именованных объектов


Внедрение зависимых от ссылок именованных объектов в текущий чертеж (Процедура)

Управление именованными объектами внешних ссылок
На уровень вверх ..
Управление именованными объектами внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Управление именованными объектами внешних ссылок >
Управление именованными объектами внешних ссылок
Понятие Процедура Краткий справочник

Внедрение зависимых от ссылок именованных объектов в текущий чертеж

  1. Выберите пункт меню "Редактировать" [image] "Объект" [image] "Внешние ссылки" [image] "Внедрить".В командной строке введите "внедрить".
  2. В диалоговом окне "Внедрение" нажмите значок "+" рядом с именем ссылки.

    Разворачивается ветвь, соответствующая выбранной ссылке, со списком имен пяти типов описаний именованных объектов (блоки, размерные стили, слои, типы линий и текстовые стили).

  3. Нажмите значок "+" рядом с именем типа описания.

    Появляется список имен элементов таблицы описаний.

  4. Выберите определение именованного объекта. Нажмите "Добавить".

    В группе "Внедряемые описания" появляется список описаний именованных объектов.

  5. При необходимости повторить пункты 3 и 4.
  6. Нажмите "ОК".
Ввод команды: ВНЕДРИТЬ


Переименование слоев, размерных стилей и других именованных объектов (Процедура)

Управление именованными объектами внешних ссылок
На уровень вверх ..
Работа с файлом журнала внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Управление именованными объектами внешних ссылок >
Управление именованными объектами внешних ссылок
Понятие Процедура Краткий справочник

Переименование слоев, размерных стилей и других именованных объектов

  1. Перейдите на вкладку "Сервис" [image] панель "Утилиты" [image] "Переименовать". В командной строке введите "новоеимя".
  2. В диалоговом окне "Задание нового имени" выберите тип объекта и объект для переименования.
  3. Введите новое имя в поле "Новое имя", расположенное под старым именем.
  4. Нажмите "Переименовать в". Нажмите "ОК".
Ввод команды: НОВОЕИМЯ


Управление именованными объектами внешних ссылок (Краткий справочник)

Обработка циклических внешних ссылок
Управление именованными объектами внешних ссылок
Работа с файлом журнала внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Управление именованными объектами внешних ссылок >
Управление именованными объектами внешних ссылок
Понятие Процедура Краткий справочник

Команды

НОВОЕИМЯ

Изменение имен именованных объектов

ВНЕДРИТЬ

Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж

Системные переменные

BINDTYPE

Управление обработкой имен внешних ссылок при внедрении или контекстном редактировании внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с файлом журнала внешних ссылок (Понятие)

Управление именованными объектами внешних ссылок
Ошибки обработки чертежей-ссылок
Увеличение производительности при работе с большими внешними чертежами
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок >
Работа с файлом журнала внешних ссылок
Понятие Процедура Краткий справочник

Программа может вести журнал действий при выполнении операций вставки, удаления и обновления ссылок, а также при загрузке чертежей, содержащих внешние ссылки.

Программа может вести журнал действий при выполнении операций вставки, удаления и обновления ссылок, а также при загрузке чертежей, содержащих внешние ссылки. Запись в журнал производится, если системной переменной XREFCTL присвоено значение 1. По умолчанию значение переменной равно 0.

Журнал представляет собой обычный текстовый ASCII-файл с тем же именем, что и у текущего чертежа, и с расширением .xlg. При загрузке чертежа с именем файла, например, sample.dwg, программа ищет в текущей папке файл журнала sample.xlg. Если файл не существует, будет создан новый файл с таким именем.

Если для чертежа создан файл журнала, программа будет добавлять в него информацию о чертеже. Каждый раз при открытии файла программа записывает в файл журнала основную надпись. Файл журнала, имеющий слишком большой размер, можно удалить.

Пример: образец блока заголовка в файле журнала внешних ссылок

Данный блока заголовка содержит имя текущего чертежа, дату, время и произведенные в файле операции.

=============================
Чертеж: деталь
Дата/Время: 09/28/99 10:45:20
Операция: вставка внешней ссылки
=============================

При удалении или обновлении ссылок сразу после блока заголовка программа указывает уровни вложенности всех обрабатываемых внешних ссылок. Таким образом, в файле журнала можно просмотреть дерево набора внешних ссылок текущего чертежа как результат использования опции "Удалить" или "Обновить".

Пример: образец записи в файле журнала с указанием вложенных внешних ссылок

В следующем примере ссылка ENTRY_DR содержит в себе две вложенных внешних ссылки: HARDWARE и PANELS. Каждая из последних двух ссылок, в свою очередь, также содержит по две внешних ссылки.

==============================
 Чертеж: деталь
 Дата/Время: 10/05/99 15:47:39
 Операция: обновление внешней ссылки
=============================
Дерево ссылок для ENTRY_DR:
Вн-ссыл. ENTRY_DR Xref
-Вн-ссыл.HARDWARE
--Вн-ссыл. LOCKSET
--Вн-ссыл. HINGES
-Вн-ссыл.PANELS
--Вн-ссыл. UPPER
--Вн-ссыл. LOWER
 Программа заносит в журнал сведения о каждом зависимом именованном объекте, временно добавленном в текущий чертеж, и о каждой обнаруженной ошибке. Большинство сообщений об ошибках выводится и на экран, и в файл журнала.
Пример: образец файла журнала с результатом вставки внешней ссылки
В следующем примере показана часть файла журнала, содержащая записи о процессе вставки в рабочий чертеж test.dwg внешней ссылки STAIR. Записи свидетельствуют об изменениях в таблице определений (обозначений) и включают в себя имена добавленных определений и статусные сообщения.
==============================
 Чертеж: тест
 Дата/Время: 12/18/99 14:06:34
 Операция: вставка внешней ссылки
=============================
Вставка внешней ссылки STAIR: \ACAD\DWGS\STAIR.dwg
 Поиск в стандартных папках ACAD
 Обновление таблицы обозначений блоков:
 Добавление обозначения: STAIR|BOLT
 Добавление обозначения: STAIR|BOLT-HALF
 ...
 Обновление блоков завершено.
 Обновление таблицы обозначений типов линий:
 Добавление обозначения: STAIR|DASHED
 Добавление обозначения: STAIR|CENTER
 Добавление обозначения: STAIR|PHANTOM
 Обновление типов линий завершено.
 Обновление таблицы обозначений слоев:
 Добавление обозначения: STAIR|STEEL-HIDDEN
 Добавление обозначения: STAIR|OAK
 ...
 Обновление слоев завершено.
Чертеж STAIR загружен.


Использование файла журнала внешних ссылок (Процедура)

Управление именованными объектами внешних ссылок
На уровень вверх ..
Увеличение производительности при работе с большими внешними чертежами
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Работа с файлом журнала внешних ссылок >
Работа с файлом журнала внешних ссылок
Понятие Процедура Краткий справочник

Использование файла журнала внешних ссылок

  1. В командной строке введите xrefctl.
  2. Введите 1 для включения режима ведения журнала или 0 для отключения.
  3. Нажмите ENTER.

    По умолчанию журнал не ведется.


Работа с файлом журнала внешних ссылок (Краткий справочник)

Управление именованными объектами внешних ссылок
Работа с файлом журнала внешних ссылок
Коротко о подгрузке
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Ошибки обработки чертежей-ссылок > Работа с файлом журнала внешних ссылок >
Работа с файлом журнала внешних ссылок
Понятие Процедура Краткий справочник

Команды

ССЫЛКА

Запуск команды ВНССЫЛКИ

Системные переменные

XREFCTL

Управление созданием файлов журналов внешних ссылок (XLG)

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Увеличение производительности при работе с большими внешними чертежами

Работа с файлом журнала внешних ссылок
Внешние ссылки
Коротко о подгрузке
Совместное использование данных в чертежах и приложениях > Внешние ссылки >
Увеличение производительности при работе с большими внешними чертежами
Понятие Процедура

Имеется несколько функций, которые могут повысить производительность при работе с большими чертежами, вставленными в качестве внешних ссылок.

Темы в этом разделе

  • Коротко о подгрузке

    Краткое обзорное описание использования режима подгрузки для повышения скорости обработки чертежей с внешними ссылками больших размеров.

  • Выгрузка внешних ссылок

    Временная выгрузка вхождений DWG (внешних ссылок) из чертежа позволяет сократить время, требующееся на его чтение с диска, и уменьшить объем используемой памяти.

  • Использование подгрузки

    Использование подгрузки позволяет загружать в память только необходимую для регенерации текущего чертежа информации.

  • Использование слоевых и пространственных указателей
  • Задание пути к временным копиям внешних ссылок

    При включении режима подгрузки ссылок с копированием, можно задать путь к создаваемым копиям файлов внешних чертежей.


Увеличение производительности при работе с большими внешними чертежами (Процедура)

Работа с файлом журнала внешних ссылок
Увеличение производительности при работе с большими внешними чертежами
Выгрузка внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами >
Увеличение производительности при работе с большими внешними чертежами
Понятие Процедура

Выгрузка внешней ссылки

Включение режима подгрузки ссылок

Сохранение чертежа с пространственным и слоевым указателями

Задание пути к копиям файлов внешних ссылок


Коротко о подгрузке (Понятие)

Увеличение производительности при работе с большими внешними чертежами
Увеличение производительности при работе с большими внешними чертежами
Выгрузка внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами >
Коротко о подгрузке
Понятие Краткий справочник

Краткое обзорное описание использования режима подгрузки для повышения скорости обработки чертежей с внешними ссылками больших размеров.

Программа использует режим подгрузки и сохранения чертежей с указателями, позволяющий повысить производительность обработки больших внешних чертежей, которые были подрезаны в программе или содержащие много объектов на замороженных слоях. При подгрузке внешних ссылок программа загружает в память только те фрагменты ссылок, которые необходимы для регенерации текущего чертежа. Другими словами, чтение ссылочного материала выполняется "по запросу". Подгрузка по запросу работает в сочетании с системными переменными INDEXCTL, XLOADCTL и XLOADPATH.


Коротко о подгрузке (Краткий справочник)

Работа с файлом журнала внешних ссылок
Коротко о подгрузке
Выгрузка внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Коротко о подгрузке >
Коротко о подгрузке
Понятие Краткий справочник

Команды

ССЫЛКА

Запуск команды ВНССЫЛКИ

Системные переменные

INDEXCTL

Управление созданием слоевых и пространственных индексов и сохранением их в файле чертежа

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

XLOADPATH

Создание пути для хранения временных копий файлов подгруженных внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Выгрузка внешних ссылок (Понятие)

Коротко о подгрузке
Увеличение производительности при работе с большими внешними чертежами
Использование подгрузки
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами >
Выгрузка внешних ссылок
Понятие Процедура Краткий справочник

Временная выгрузка вхождений DWG (внешних ссылок) из чертежа позволяет сократить время, требующееся на его чтение с диска, и уменьшить объем используемой памяти.

Временная выгрузка ссылок из чертежа позволяет сократить время, требующееся на его чтение с диска, и уменьшить объем используемой памяти. Описание ссылки удаляется из чертежа; в нем остается лишь указатель на используемый внешний чертеж. Графические объекты выгруженной ссылки на экран не выводятся; зависимые от ссылки символы также не читаются и не заносятся в символьную таблицу. Для восстановления ссылки необходимо обновить ее. Если системная переменная XLOADCTL (режим подгрузки ссылок) равна 1, при выгрузке ссылки происходит разблокирование ее файла.

Ссылки рекомендуется выгружать в случае, если они более не используются в текущем сеансе, но могут понадобиться при дальнейшем выводе чертежа на печать. Для удобства можно составить список выгруженных ссылок, которые потребуется обновить впоследствии.


Выгрузка внешней ссылки (Процедура)

Увеличение производительности при работе с большими внешними чертежами
На уровень вверх ..
Использование подгрузки
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Выгрузка внешних ссылок >
Выгрузка внешних ссылок
Понятие Процедура Краткий справочник

Выгрузка внешней ссылки

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите имя ссылки, которое требуется выгрузить.
  3. Нажмите правую кнопку мыши и выберите "Выгрузить".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Выгрузка внешних ссылок (Краткий справочник)

Коротко о подгрузке
Выгрузка внешних ссылок
Использование подгрузки
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Выгрузка внешних ссылок >
Выгрузка внешних ссылок
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование подгрузки (Понятие)

Выгрузка внешних ссылок
Увеличение производительности при работе с большими внешними чертежами
Использование слоевых и пространственных указателей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами >
Использование подгрузки
Понятие Процедура Краткий справочник

Использование подгрузки позволяет загружать в память только необходимую для регенерации текущего чертежа информации.

Сохранение чертежей-ссылок со слоевыми и пространственными указателями дает возможность почувствовать преимущества использования подгрузки. Повышение производительности особенно заметно в следующих случаях:

  • Подрезка ссылки с помощью данной программы для отображения небольшого фрагмента ссылки. Сохранение пространственного индекса в чертеже, являющемся внешней ссылкой.
  • Замораживание нескольких слоев внешней ссылки. Сохранение чертежа, являющегося внешней ссылкой, вместе с индексом слоя.

При включенном режиме подгрузки после подрезки внешних ссылок, имеющих пространственные указатели, из ссылок читаются только те объекты, которые расположены в пределах контура подрезки. При изменении контура подрезки, выполняется дополнительная загрузка объектов, оказавшихся в его границах. Аналогичным образом, после замораживания слоев в ссылках, имеющих указатели слоев, из ссылок читаются только объекты, находящиеся на размороженных слоях. При размораживании слоев, зависимых от внешних ссылок, программа считывает данные об их геометрии с внешнего чертежа.

Если подгрузка ссылок включена, программа блокирует все связанные чертежи, чтобы обеспечить возможность считывания любых требуемых для подгрузки объектов. В результате пользователь, работающий с главным файлом, всегда может беспрепятственно получить доступ к файлам ссылок и подгрузить требуемые объекты. Другим пользователям в это время разрешен лишь просмотр блокированных чертежей; внесение изменений в них не допускается. Если такая стратегия не устраивает коллектив разработчиков, следует применять подгрузку с копированием.

При включении подгрузки с копированием программа создает временную копию файла внешнего чертежа и осуществляет подгрузку временного файла. Никакой блокировки исходных файлов не производится, и они остаются доступными для любых изменений. При отключении режима подгрузки программа считывает ссылку полностью, независимо от состояния слоев и наличия контуров подрезки.

В редакции 14 AutoCAD и в AutoCAD LT 97 добавлены функции индексации слоев и пространственной индексации. При вставке в качестве внешней ссылки чертежа, сохраненного в формате более ранних версий программы, преимущества использования указателей не так ощутимы. Для оптимизации производительности в редакции 14 AutoCAD, в AutoCAD LT 97 и в более поздних версиях следует применять загрузку по требованию и сохранять чертежи, на которые существуют ссылки, с включенной индексацией слоев и пространственной индексацией.


Включение режима подгрузки ссылок (Процедура)

Выгрузка внешних ссылок
На уровень вверх ..
Использование слоевых и пространственных указателей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Использование подгрузки >
Использование подгрузки
Понятие Процедура Краткий справочник

Включение режима подгрузки ссылок

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Открытие/Сохранение" диалогового окна "Параметры" выберите "Запрещена", "Разрешена" или "Разрешена с копированием".
  3. Нажмите "ОК".


Использование подгрузки (Краткий справочник)

Выгрузка внешних ссылок
Использование подгрузки
Использование слоевых и пространственных указателей
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Использование подгрузки >
Использование подгрузки
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

INDEXCTL

Управление созданием слоевых и пространственных индексов и сохранением их в файле чертежа

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование слоевых и пространственных указателей (Понятие)

Использование подгрузки
Увеличение производительности при работе с большими внешними чертежами
Задание пути к временным копиям внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами >
Использование слоевых и пространственных указателей
Понятие Процедура Краткий справочник

Для обеспечения максимальной производительности при использовании подгрузки рекомендуется сохранять все файлы внешних ссылок с пространственным и слоевым указателями.

Указатель слоя представляет собой список слоев с перечнем объектов, расположенных на каждом из них. Этот список используется программой при обращении к чертежу в ходе подгрузки, чтобы определить, какие объекты необходимо считать и отобразить. При наличии у внешнего чертежа указателя слоя и включенном режиме подгрузки объекты с замороженных слоев внешнего чертежа не считываются.

Пространственный указатель организует объекты по их положению в 3D пространстве. Это позволяет эффективно определять, какие объекты подлежат считыванию в ходе подгрузки подрезанной внешней ссылки. Если подгрузка включена, а чертеж вставлен как внешняя ссылка и выполнена его подрезка, при обращении к файлу внешней ссылки в ходе подгрузки программа использует пространственный указатель, чтобы определить, какие объекты лежат в пределах контура подрезки. Затем программа считывает только эти объекты в текущий рабочий сеанс.

Наиболее эффективно пространственный и слоевой указатели используются в процессе подгрузки файла внешней ссылки, вставленной в другой чертеж. Если чертеж не используется в качестве внешней ссылки или открыт частично, индексация слоев, пространственная индексация и загрузка по требованию не влияют на эффективность работы с этим чертежом.


Сохранение чертежа с пространственным и слоевым указателями (Процедура)

Использование подгрузки
На уровень вверх ..
Задание пути к временным копиям внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Использование слоевых и пространственных указателей >
Использование слоевых и пространственных указателей
Понятие Процедура Краткий справочник

Сохранение чертежа с пространственным и слоевым указателями

  1. Выберите пункт меню "Файл" [image] "Сохранить как.В командной строке введите "сохранитькак".
  2. В диалоговом окне "Сохранение чертежа" выберите пункт меню "Сервис" [image] "Настройка".В диалоговом окне "Сохранение чертежа" в командной строке введите "настройка".

  3. В диалоговом окне "Параметры сохранения" из списка "Тип указателя" выберите "Слоевой", "Пространственный" или "Оба". Нажмите "ОК".
    ПримечаниеПри сохранении частично открытого чертежа, не имеющего пространственного и слоевого указателей, эта опция недоступна.
  4. Нажмите кнопку "Сохранить".


Использование слоевых и пространственных указателей (Краткий справочник)

Использование подгрузки
Использование слоевых и пространственных указателей
Задание пути к временным копиям внешних ссылок
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Использование слоевых и пространственных указателей >
Использование слоевых и пространственных указателей
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

INDEXCTL

Управление созданием слоевых и пространственных индексов и сохранением их в файле чертежа

TREEDEPTH

Максимальное количество ветвлений древовидного пространственного индекса

TREEMAX

Снижение использования памяти при регенерации чертежа путем ограничения числа узлов в пространственном индексе (дерево октантов)

XLOADCTL

Включение и отключение режима подгрузки внешних ссылок, а также управление открытием чертежа внешней ссылки или его копии

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание пути к временным копиям внешних ссылок (Понятие)

Использование слоевых и пространственных указателей
Увеличение производительности при работе с большими внешними чертежами
Составные документы и технология OLE
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами >
Задание пути к временным копиям внешних ссылок
Понятие Процедура Краткий справочник

При включении режима подгрузки ссылок с копированием, можно задать путь к создаваемым копиям файлов внешних чертежей.

При включении режима подгрузки ссылок с копированием можно использовать системную переменную XLOADPATH для указания пути к копиям внешних чертежей. Заданный путь действует для всех сеансов работы с чертежом вплоть до указания иного пути. Если значение для переменной XLOADPATH не задано, временные копии файлов записываются в стандартную папку для временных файлов.

Если скорость работы с внешними ссылками в сети недостаточно высока, следует присвоить переменной XLOADCTL значение 2 (подгрузка с копированием) и задать в переменной XLOADPATH одну из локальных папок для сохранения копий файлов внешних ссылок. И наоборот, чтобы сократить число создаваемых различными пользователями временных файлов, относящихся к одному и тому же файлу, необходимо задать для копий в переменной XLOADPATH одну из совместно используемых папок сети. Тогда несколько пользователей могут обращаться к одной и той же временной копии чертежа внешней ссылки.

Установка переменной XLOADPATH может быть выполнена в диалоговом окне "Настройка"; она задает путь размещения копий внешних файлов, на которых производились ссылки.


Задание пути к копиям файлов внешних ссылок (Процедура)

Использование слоевых и пространственных указателей
На уровень вверх ..
Коротко о связывании и внедрении объектов
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Задание пути к временным копиям внешних ссылок >
Задание пути к временным копиям внешних ссылок
Понятие Процедура Краткий справочник

Задание пути к копиям файлов внешних ссылок

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. На вкладке "Файлы" диалогового окна "Параметры" выберите папку Папка для временных файлов внешних ссылок.

    Здесь выводится путь, по которому производится размещение копий файлов внешних ссылок. Если путь не задан, временные копии сохраняются в папку, заданную элементом "Папка для временных файлов".

  3. Выберите нужный путь и отредактировать его.
  4. Нажмите кнопку "OK" (или "Применить") для задания пути.


Задание пути к временным копиям внешних ссылок (Краткий справочник)

Использование слоевых и пространственных указателей
Задание пути к временным копиям внешних ссылок
Коротко о связывании и внедрении объектов
Совместное использование данных в чертежах и приложениях > Внешние ссылки > Увеличение производительности при работе с большими внешними чертежами > Задание пути к временным копиям внешних ссылок >
Задание пути к временным копиям внешних ссылок
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

XLOADPATH

Создание пути для хранения временных копий файлов подгруженных внешних ссылок

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Составные документы и технология OLE

Задание пути к временным копиям внешних ссылок
Совместное использование данных в чертежах и приложениях
Коротко о связывании и внедрении объектов
Совместное использование данных в чертежах и приложениях >
Составные документы и технология OLE

С помощью технологии связывания и внедрения объектов (OLE), реализованной в Microsoft Windows, можно копировать и размещать информацию из одного приложения в другое, сохраняя возможность редактирования ее в исходном приложении.

С помощью технологии связывания и внедрения объектов (OLE), реализованной в Windows, можно копировать и размещать информацию из разных приложений в одном документе. Это может быть, например, страница Adobe PageMaker, включающая в себя чертеж AutoCAD, или чертеж AutoCAD, содержащий таблицу Microsoft Excel или ее часть.

Темы в этом разделе

  • Коротко о связывании и внедрении объектов
  • Импорт OLE-объектов

    Имеется возможность импорта данных из приложений, поддерживающих OLE, в чертеж.

  • Экспорт OLE-объектов из чертежей
  • Редактирование OLE-объектов в чертежах

    Пользователь может отредактировать связанные или внедренные в чертеж OLE-объекты. Для этого нужно дважды нажать на объекте, чтобы открыть приложение-сервер, с помощью которого выполняется редактирование.


Коротко о связывании и внедрении объектов (Понятие)

Составные документы и технология OLE
Составные документы и технология OLE
Импорт OLE-объектов
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE >
Коротко о связывании и внедрении объектов
Понятие Процедура Краткий справочник

Связывание и внедрение объектов позволяет использовать информацию из одного приложения в другом. Для использования технологии OLE необходимо, чтобы и исходное приложение, и целевое приложение поддерживали OLE.

И при связывании, и при внедрении производится вставка информации из одного документа в другой. Далее, в обоих случаях редактирование объекта производится в документе приложения-приемника. Однако результаты связывания и внедрения объектов отличаются друг от друга методом хранения информации.

По своей сути внедрение объектов и их связывание подобны вставке блоков и созданию внешних ссылок.

Внедрение объектов

При внедрении методом OLE в составном документе размещается копия внедренных данных. Эта копия теряет связь с исходным документом. Внедренные данные в составном документе могут редактироваться с помощью приложения, в котором они были созданы; но исходный документ при этом не изменяется. При внедрении объектов связь с исходным файлом не поддерживается. Внедрение следует применять, если модификация исходного документа при редактировании составного нежелательна.

Связывание объектов

При связывании методом OLE создается ссылка между документом сервера и составным документом. Связь является удобным способом использования одних и тех же данных в различных документах: если исходные данные модифицируются, для изменения составных документов требуется лишь обновление связей. Большинство приложений-приемников могут также быть настроены на автоматическое их обновление.

При установлении связи чертежа необходимо поддерживать доступ и к исходному приложению, и к документу. Если что-либо из них переименовано или перемещено, может потребоваться повторное задание связи.

Управление качеством представления OLE-объектов при печати

При использовании растрового устройства печати OLE-объекты рассматриваются как растровые. Так как крупные, полноцветные растровые изображения с высоким разрешением весьма неэкономичны при печати, можно управлять выводом каждого объекта на печать с помощью системной переменной OLEQUALITY. По умолчанию она настроена на автоматический выбор, при этом значении качество печати задается в соответствии с типом объекта. Объем затраченных на печать времени и памяти напрямую зависит от заданного качества печати.

Качество печати объектов OLE может также настраиваться в редакторе параметров плоттера. При разворачивании опции "Графика" появляется элемент "Растровая графика", в котором можно настроить качество печати OLE-объектов.

ПримечаниеВложенные OLE-объекты могут служить причиной возникновения проблем. Например, если в чертеж вставляется документ Word, в который внедрена таблица Excel, это может привести к сбою в ходе печати. Кроме того, OLE-объекты, которые не лежат в плоскости текущего вида, не выводится на печать, однако у них (в зависимости от значения системной переменной OLEFRAME) могут оказаться напечатаны ограничивающие рамки.
См. также

    • Использование буфера обмена Windows


Установка качества печати OLE-объектов (Процедура)

Задание пути к временным копиям внешних ссылок
Коротко о связывании и внедрении объектов
Импорт OLE-объектов
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Коротко о связывании и внедрении объектов >
Коротко о связывании и внедрении объектов
Понятие Процедура Краткий справочник

Установка качества печати OLE-объектов

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" перейдите на вкладку "Печать/публикация" и из списка "Качество печати OLE" выберите один из следующих параметров:
    • Монохромное. Например таблицы
    • Простая графика. Например цветной текст и круговые диаграммы
    • Сложная графика. Например фотографии
    • Автоматический выбор. Параметры качества печати задаются в соответствии с типом файла
  3. Чтобы продолжить выбор параметров, нажмите "Применить"; для закрытия диалогового окна нажать "ОК".


Коротко о связывании и внедрении объектов (Краткий справочник)

Задание пути к временным копиям внешних ссылок
Коротко о связывании и внедрении объектов
Коротко об импорте OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Коротко о связывании и внедрении объектов >
Коротко о связывании и внедрении объектов
Понятие Процедура Краткий справочник

Команды

КСВЯЗЬ

Копирование текущего вида в буфер обмена для связывания с другими OLE-приложениями

ВСТ ОБКТ

Вставка связанного или внедренного объекта

ВНЕДРСВЯЗИ

Обновление, изменение и разрыв имеющихся связей

Системные переменные

OLEHIDE

Управление отображением и выводом на печать объектов OLE

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Импорт OLE-объектов

Коротко о связывании и внедрении объектов
Составные документы и технология OLE
Коротко об импорте OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE >
Импорт OLE-объектов
Понятие Процедура

Имеется возможность импорта данных из приложений, поддерживающих OLE, в чертеж.

Темы в этом разделе

  • Коротко об импорте OLE-объектов в чертежи
  • Связывание OLE-объектов с чертежами

    Связывание данных документа с чертежом позволяет при модифицировании исходного документа обновлять данные в чертеже.

  • Внедрение OLE-объектов в чертежи

    Внедренные в чертежи данные при модифицировании исходного документа не обновляются.


Импорт OLE-объектов (Процедура)

Коротко о связывании и внедрении объектов
Импорт OLE-объектов
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов >
Импорт OLE-объектов
Понятие Процедура

Связывание объектов с чертежом

Связывание с чертежом целого файла как OLE-объекта

Обновление связей вручную

Редактирование связи с OLE-объектом

Разрыв связи с OLE-объектом

Внедрение OLE-объекта в чертеж

Создание объекта в другом приложении и его внедрение в чертеж

Изменение размеров OLE-объекта

Масштабирования текста в OLE-объекте согласно его шрифту


Коротко об импорте OLE-объектов в чертежи (Понятие)

Импорт OLE-объектов
Импорт OLE-объектов
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов >
Коротко об импорте OLE-объектов в чертежи
Понятие Краткий справочник

Для вставки информации из другого приложения в качестве OLE-объекта может использоваться один из следующих способов:

  • Копирование или вырезание данных из существующего файла и вставка их в чертеж.
  • Импорт существующего файла, созданного в другом приложении.
  • Открытие другого приложения из чертежа и создание в нем данных для дальнейшего использования.

При вставке информации необходимо указать точку вставки.

По умолчанию OLE-объекты отображаются в рамке, которая не выводится на печать. OLE-объекты являются непрозрачными; при печати они скрывают объекты, расположенные за ними. Для OLE-объектов поддерживается настройка порядка прорисовки. Пользователь может управлять отображением OLE-объектов двумя способами:

  • изменить значение системной переменной OLEHIDE для отображения или подавления OLE-объектов в пространстве листа и/или модели;
  • отключить или заморозить слой, на котором размещаются OLE-объекты, для подавления их вывода.

При печати OLE-объектов, которые содержат текст, размер текста масштабируется так, чтобы приближенно соответствовать размеру текста в исходном приложении.

ПримечаниеOLE-объекты не отображаются и не печатаются во внешних ссылках и вхождениях блоков.


Коротко об импорте OLE-объектов в чертежи (Краткий справочник)

Коротко о связывании и внедрении объектов
Коротко об импорте OLE-объектов в чертежи
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Коротко об импорте OLE-объектов в чертежи >
Коротко об импорте OLE-объектов в чертежи
Понятие Краткий справочник

Команды

ВСТ ОБКТ

Вставка связанного или внедренного объекта

ВНЕДРСВЯЗИ

Обновление, изменение и разрыв имеющихся связей

ОЛЕСВОЙСТВА

Настройка размера, масштаба и других свойств выбранного OLE-объекта

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ВСТСПЕЦ

Вставка данных из буфера обмена Windows с возможностью управления их форматом

Системные переменные

MSOLESCALE

Управление размером объектов OLE, в которых текст вставлен в пространство модели

OLEHIDE

Управление отображением и выводом на печать объектов OLE

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Связывание OLE-объектов с чертежами (Понятие)

Коротко об импорте OLE-объектов в чертежи
Импорт OLE-объектов
Внедрение OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Связывание данных документа с чертежом позволяет при модифицировании исходного документа обновлять данные в чертеже.

Имеется возможность связывания данных документов, созданных в других приложениях, с чертежами. Например, в чертеж можно вставить автоматически обновляемую электронную таблицу. Можно также устанавливать в чертеже значки средств мультимедиа, активизируемые двойным щелчком.

Обновление связей

Можно настроить либо автоматическое, либо ручное обновление связей при изменении данных в документе-сервере. По умолчанию связи автоматически обновляются. Переключение режима обновления связей производится системной переменной OLELINKS.

Повторное задание связей

Так как установленная связь является ссылкой на источник данных сервера, при перемещении или переименовании файла-сервера необходимо задать ее вновь.

Разрыв связей

При разрыве связи данные, вставленные ранее в чертеж, не уничтожаются, удаляется только связь. Связь следует разорвать, как только отпадает необходимость обновления данных.


Связывание OLE-объектов с чертежами (Процедура)

Импорт OLE-объектов
На уровень вверх ..
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Связывание OLE-объектов с чертежами >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Связывание объектов с чертежом

Связывание с чертежом целого файла как OLE-объекта

Обновление связей вручную

Редактирование связи с OLE-объектом

Разрыв связи с OLE-объектом


Связывание объектов с чертежом (Процедура)

Связывание OLE-объектов с чертежами
На уровень вверх ..
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Связывание OLE-объектов с чертежами >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Связывание объектов с чертежом

  1. Запустите исходное приложение и открыть в нем документ.
  2. Выделите и скопируйте в буфер обмена связываемые данные документа.
  3. Откройте чертеж.
  4. Введите встспец в командной строке.
  5. В диалоговом окне "Специальная вставка" выбрать опцию "Вставить связь".

    В этом случае при вставке содержимого буфера обмена устанавливается связь с исходным файлом. В противном случае (при активной опции "Вставить") происходит внедрение объекта.

  6. Из списка "Как" выберите требуемый формат данных.
  7. Нажмите "ОК".
Ввод команды: ВСТАВПРБ


Связывание с чертежом целого файла как OLE-объекта (Процедура)

Связывание OLE-объектов с чертежами
На уровень вверх ..
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Связывание OLE-объектов с чертежами >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Связывание с чертежом целого файла как OLE-объекта

  1. Откройте чертеж.
  2. Перейдите на вкладку "Блоки и ссылки" [image] панель "Данные" [image] "OLE-объект". В командной строке введите "встобъект".
  3. В диалоговом окне "Вставка объекта" установите текущей опцию "Создать из файла".
  4. Поднимите флажок "Связь". Нажмите кнопку "Обзор".
  5. В диалоговом окне "Обзор" выберите файл для установки связи. Нажмите "Открыть".
  6. В диалоговом окне "Вставка объекта" нажмите "ОК".

    Файл связывается с чертежом.

Ввод команды: ВСТ ОБКТ


Обновление связей вручную (Процедура)

Связывание OLE-объектов с чертежами
На уровень вверх ..
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Связывание OLE-объектов с чертежами >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Обновление связей вручную

  1. Выберите пункт меню "Правка" [image] "Связи".В командной строке введите "внедрсвязи".
  2. В диалоговом окне "Связи" выберите обновляемые связи.
  3. Нажмите "Обновить".
  4. Нажмите кнопку "Закрыть".
ПримечаниеЕсли обновляемые связи необходимо выбрать непосредственно в области чертежа без использования списка диалогового окна "Связи", то нужно выбрать объекты перед тем, как выполнить действие пункта 1.
Ввод команды: ВНЕДРСВЯЗИ


Редактирование связи с OLE-объектом (Процедура)

Связывание OLE-объектов с чертежами
На уровень вверх ..
Связывание OLE-объектов с чертежами
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Связывание OLE-объектов с чертежами >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Редактирование связи с OLE-объектом

  1. В чертеже выберите OLE-объект, связь которого должна быть отредактирована.
  2. Выберите пункт меню "Правка" [image] "Связи"В командной строке введите "внедрсвязи".
  3. В диалоговом окне "Связи" нажмите кнопку "Сменить источник".
  4. В диалоговом окне "Смена источника" найдите новый файл-источник.
  5. Выберите файл-источник. Нажмите "Открыть".
  6. Нажмите "ОК".
Ввод команды: ВНЕДРСВЯЗИ


Разрыв связи с OLE-объектом (Процедура)

Связывание OLE-объектов с чертежами
На уровень вверх ..
Внедрение OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Связывание OLE-объектов с чертежами >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Разрыв связи с OLE-объектом

  1. Выберите объект, связь которого разрывается.
  2. Выберите пункт меню "Правка" [image] "Связи"В командной строке введите "внедрсвязи".
  3. В диалоговом окне "Связи" нажмите кнопку "Разорвать связь".
  4. Нажмите "Да".
  5. Нажмите кнопку "Закрыть".
Ввод команды: ВНЕДРСВЯЗИ


Связывание OLE-объектов с чертежами (Краткий справочник)

Коротко об импорте OLE-объектов в чертежи
Связывание OLE-объектов с чертежами
Внедрение OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Связывание OLE-объектов с чертежами >
Связывание OLE-объектов с чертежами
Понятие Процедура Краткий справочник

Команды

ВСТ ОБКТ

Вставка связанного или внедренного объекта

ВНЕДРСВЯЗИ

Обновление, изменение и разрыв имеющихся связей

ОЛЕСВОЙСТВА

Настройка размера, масштаба и других свойств выбранного OLE-объекта

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ВСТСПЕЦ

Вставка данных из буфера обмена Windows с возможностью управления их форматом

Системные переменные

OLEHIDE

Управление отображением и выводом на печать объектов OLE

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Внедрение OLE-объектов в чертежи (Понятие)

Связывание OLE-объектов с чертежами
Импорт OLE-объектов
Экспорт OLE-объектов из чертежей
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов >
Внедрение OLE-объектов в чертежи
Понятие Процедура Краткий справочник

Внедренные в чертежи данные при модифицировании исходного документа не обновляются.

Объекты можно внедрять в чертежи путем их копирования в буфер обмена с последующей вставкой в файл чертежа. Таким образом, например, производится добавление логотипа фирмы, созданного в другом приложении, в чертеж.

Перетаскивание объектов в чертеж

Данные и графику, выбранные в окне другого приложения, можно добавить в чертеж, перетаскивая их мышью по экрану. Как окно AutoCAD, так и окно другого приложения при этом должно быть открыто и не свернуто. Перетаскивание между приложениями возможно, только если второе приложение поддерживает технологию ActiveX. Объекты, перенесенные таким образом, становятся внедренными (а не связанными).

Обычное перетаскивание данных аналогично их последовательному вырезанию и вставке. Данные полностью удаляются из документа-сервера и вставляются в составной документ. Если же перетаскивание производится при нажатой клавише CTRL, вместо вырезания осуществляется копирование; в составном документе создается копия данных, а исходный их вариант остается неизменным.


Внедрение OLE-объектов в чертежи (Процедура)

Связывание OLE-объектов с чертежами
На уровень вверх ..
Внедрение OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Внедрение OLE-объектов в чертежи >
Внедрение OLE-объектов в чертежи
Понятие Процедура Краткий справочник

Внедрение OLE-объекта в чертеж

Создание объекта в другом приложении и его внедрение в чертеж

Изменение размеров OLE-объекта

Масштабирования текста в OLE-объекте согласно его шрифту


Внедрение OLE-объекта в чертеж (Процедура)

Внедрение OLE-объектов в чертежи
На уровень вверх ..
Внедрение OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Внедрение OLE-объектов в чертежи >
Внедрение OLE-объектов в чертежи
Понятие Процедура Краткий справочник

Внедрение OLE-объекта в чертеж

  1. Откройте документ в исходном приложении.
  2. Скопируйте внедряемые данные в буфер обмена.
  3. Откройте чертеж.
  4. Перейдите на вкладку "Главная" [image] панель "Утилиты" [image] "Вставить". В командной строке введите "встбуфер".
  5. Нажмите "ОК".
Ввод команды: ВСТБУФЕР


Создание объекта в другом приложении и его внедрение в чертеж (Процедура)

Внедрение OLE-объектов в чертежи
На уровень вверх ..
Внедрение OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Внедрение OLE-объектов в чертежи >
Внедрение OLE-объектов в чертежи
Понятие Процедура Краткий справочник

Создание объекта в другом приложении и его внедрение в чертеж

  1. Откройте чертеж.
  2. Перейдите на вкладку "Блоки и ссылки" [image] панель "Данные" [image] "OLE-объект". В командной строке введите "встобъект".
  3. В диалоговом окне "Вставка объекта" в разделе "Тип объекта" выберите параметр "Создать новый".
  4. В группе "Тип объекта" выберите приложение. Нажмите "ОК".

    Открывается исходное приложение.

  5. Используя серверное приложение, создайте данные для вставки. Сохраните документ.
  6. Из меню "Файл" исходного приложения выберите "Обновить".
  7. Закройте исходное приложение.

    OLE-объект внедряется в чертеж.

Ввод команды: ВСТ ОБКТ


Изменение размеров OLE-объекта (Процедура)

Внедрение OLE-объектов в чертежи
На уровень вверх ..
Внедрение OLE-объектов в чертежи
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Внедрение OLE-объектов в чертежи >
Внедрение OLE-объектов в чертежи
Понятие Процедура Краткий справочник

Изменение размеров OLE-объекта

  1. Щелкните правой кнопкой мыши на OLE-объекте. Выберите "Свойства".
  2. На палитре свойств введите новые значения ширины и высоты, или введите процент масштаба для высоты и ширины.
    ПримечаниеЕсли при поднятом флажке "Не изменять пропорции" изменить одно из значений ("Ширина" или "Высота"), то другое изменится автоматически. Например, если задать значение высоты в пятьдесят процентов, значение ширины также изменится и станет равным пятидесяти процентам. Если необходимо изменить только высоту или ширину, следует сбросить флажок "Не изменять пропорции".
  3. Нажмите "OK" для принятия изменений.
Ввод команды: ОКОНСВ


Масштабирования текста в OLE-объекте согласно его шрифту (Процедура)

Внедрение OLE-объектов в чертежи
На уровень вверх ..
Экспорт OLE-объектов из чертежей
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Внедрение OLE-объектов в чертежи >
Внедрение OLE-объектов в чертежи
Понятие Процедура Краткий справочник

Масштабирования текста в OLE-объекте согласно его шрифту

  1. Выберите OLE-объект.
  2. Нажмите правую кнопку мыши. Выберите пункт "OLE" [image] "Размер текста".
  3. В группе "Размер текста" выберите шрифт из раскрывающегося списка.

    В списке перечисляются все шрифты, появляющиеся в выбранном OLE-объекте.

  4. Выберите размер шрифта.

    В этом списке перечисляются все размеры, доступные для выбранного шрифта.

  5. В поле "Высота" введите значение в единицах чертежа.

    Это будет высота текста в чертеже, набранного указанным шрифтом указанного размера. Например, если выбрать шрифт Arial и размер 10 пунктов, а затем введите 0,5 в поле "Высота текста", то все тексты в выбранном OLE-объекте, набранные изначально шрифтом Arial размером 10 пунктов, в чертеже примут высоту 0,5 единиц чертежа. Все остальные тексты в объекте изменяют свой размер пропорционально выбранному базовому шрифту. Рамка объекта также перенастраивается в соответствии с новыми размерами текстов.

Ввод команды: ОЛЕСВОЙСТВА


Внедрение OLE-объектов в чертежи (Краткий справочник)

Связывание OLE-объектов с чертежами
Внедрение OLE-объектов в чертежи
Экспорт OLE-объектов из чертежей
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Импорт OLE-объектов > Внедрение OLE-объектов в чертежи >
Внедрение OLE-объектов в чертежи
Понятие Процедура Краткий справочник

Команды

ВСТ ОБКТ

Вставка связанного или внедренного объекта

ОЛЕСВОЙСТВА

Настройка размера, масштаба и других свойств выбранного OLE-объекта

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ВСТБУФЕР

Вставка содержимого буфера обмена

ВСТСПЕЦ

Вставка данных из буфера обмена Windows с возможностью управления их форматом

Системные переменные

OLEHIDE

Управление отображением и выводом на печать объектов OLE

OLEQUALITY

Значение по умолчанию для качества печати объектов OLE

OLESTARTUP

Управление загрузкой исходного приложения, в котором был создан внедренный OLE объект, для его печати

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт OLE-объектов из чертежей (Понятие)

Внедрение OLE-объектов в чертежи
Составные документы и технология OLE
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE >
Экспорт OLE-объектов из чертежей
Понятие Процедура Краткий справочник

Виды чертежа можно связывать или внедрять в документы других приложений, поддерживающих технологию OLE.

Связывание видов с другими документами

Чертеж может играть роль документа-сервера и иметь связи с одним или несколькими составными документами. Копирование вида в буфер обмена из текущего видового экрана или пространства листа выполняется командой КСВЯЗЬ. Можно затем вставить вид в документ-приемник.

При вставке в документ неименованного вида ему назначается имя, подобное OLE1. При выходе из чертежа предлагается сохранить изменения в новом именованном виде. Для того чтобы сформировать связь и сохранить вид под именем OLE1, необходимо выполнить сохранение чертежа.

Внедрение объектов чертежей в другие документы

Имеется возможность выбирать и внедрять объекты чертежей в документы других приложений. При этом происходит размещение копии выбранного объекта в составном документе. При вызове AutoCAD из другого приложения для редактирования OLE-объекта изменения никак не отображаются в исходном чертеже.


Экспорт OLE-объектов из чертежей (Процедура)

Внедрение OLE-объектов в чертежи
Экспорт OLE-объектов из чертежей
Экспорт OLE-объектов из чертежей
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Экспорт OLE-объектов из чертежей >
Экспорт OLE-объектов из чертежей
Понятие Процедура Краткий справочник

Внедрение OLE-объекта в другой документ

Связывание вида с другим документом


Внедрение OLE-объекта в другой документ (Процедура)

Экспорт OLE-объектов из чертежей
Экспорт OLE-объектов из чертежей
Экспорт OLE-объектов из чертежей
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Экспорт OLE-объектов из чертежей >
Экспорт OLE-объектов из чертежей
Понятие Процедура Краткий справочник

Внедрение OLE-объекта в другой документ

  1. Выберите меню "Правка" [image] "Копировать". В командной строке введите "кбуфер".
  2. В области чертежа выберите объекты, которые требуется внедрить, и нажмите ENTER.

    Выбранные объекты копируются в буфер обмена Windows.

  3. Откройте приложение-приемник. Создайте в нем новый или откройте существующий документ.
  4. Вставьте содержимое буфера обмена в документ, следуя подсказкам приложения по внедрению содержимого буфера обмена.
Ввод команды: КБУФЕР


Связывание вида с другим документом (Процедура)

Экспорт OLE-объектов из чертежей
Экспорт OLE-объектов из чертежей
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Экспорт OLE-объектов из чертежей >
Экспорт OLE-объектов из чертежей
Понятие Процедура Краткий справочник

Связывание вида с другим документом

  1. Сохраните чертеж, который требуется связать, так как он обязательно должен иметь имя.
  2. Если открыто несколько видовых экранов, выберите один из них.
  3. Введите ксвязь в командной строке.
  4. Создайте новый или откройте существующий документ в приложении-приемнике.
  5. Вставьте содержимое буфера обмена в документ, следуя подсказкам приложения по вставке связанных данных.

    Вставленный OLE-объект отображается в документе и может редактироваться в AutoCAD через приложение-приемник.

Ввод команды: КСВЯЗЬ


Экспорт OLE-объектов из чертежей (Краткий справочник)

Внедрение OLE-объектов в чертежи
Экспорт OLE-объектов из чертежей
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Экспорт OLE-объектов из чертежей >
Экспорт OLE-объектов из чертежей
Понятие Процедура Краткий справочник

Команды

КБУФЕР

Копирование выбранных объектов в буфер обмена

КСВЯЗЬ

Копирование текущего вида в буфер обмена для связывания с другими OLE-приложениями

ВБУФЕР

Перемещение выбранных объектов в буфер обмена и удаление их из чертежа

ВСТ ОБКТ

Вставка связанного или внедренного объекта

ВНЕДРСВЯЗИ

Обновление, изменение и разрыв имеющихся связей

Системные переменные

WMFBKGND

Управление отображением фона при вставке объектов в формате метафайлов Windows (WMF)

WMFFOREGND

Управление назначением цвета переднего плана при вставке объектов в формате метафайла Windows (WMF)

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование OLE-объектов в чертежах (Понятие)

Экспорт OLE-объектов из чертежей
Составные документы и технология OLE
Работа с данными других форматов
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Пользователь может отредактировать связанные или внедренные в чертеж OLE-объекты. Для этого нужно дважды нажать на объекте, чтобы открыть приложение-сервер, с помощью которого выполняется редактирование.

Выбранные любым способом OLE-объекты могут редактироваться с помощью большинства команд редактирования, палитры свойства, а также с помощью ручек. Если для размеров объекта задан режим сохранения пропорций и для изменения OLE-объекта используются ручки, форма объекта не меняется. Для OLE-объектов недоступны следующие команды редактирования: РАЗОРВАТЬ, ФАСКА, СОПРЯЖЕНИЕ и УВЕЛИЧИТЬ.

Если OLE-объект повернут или находится не на виде в плане, его содержимое становится временно скрытым; отображается только рамка объекта.

Заданные на палитре свойств общие свойства OLE-объекта применяются к его рамке.

Ручки отображаются на рамке, поэтому редактирование с помощью ручек невозможно, если рамка не отображается. Для отображения рамки требуется изменить значение системной переменной OLEFRAME.

Редактирование информации в OLE-объектах

Пользователь может отредактировать связанные или внедренные в чертеж OLE-объекты. Для этого нужно дважды нажать на объекте, чтобы открыть приложение-сервер, с помощью которого выполняется редактирование.

Редактирование OLE-объекта в случае, если исходным приложением является AutoCAD

Если чертеж связан с документом, то в этом документе хранится информация о расположении связанного файла чертежа. Это позволяет редактировать связанный чертеж непосредственно в конечном приложении либо в исходной программе. Программа должна быть загружена или доступна для запуска во время редактирования документа.

Чертеж AutoCAD, внедренный в документ, можно редактировать только в конечном приложении. Для запуска программы следует дважды нажать кнопку мыши на OLE-объекте. Редактирование исходного чертежа в программе не оказывает никакого действия на внедренный чертеж.

См. также

    • Копирование объектов


Редактирование OLE-объектов в чертежах (Процедура)

Экспорт OLE-объектов из чертежей
Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Редактирование связанного чертежа из приложения-приемника

Изменение связанного чертежа в исходном приложении

Редактирование внедренных объектов AutoCAD

Восстановление исходных размеров и формы OLE-объекта

Управление отображением OLE-объектов

Включение-отключение отображения рамок OLE-объекта


Редактирование связанного чертежа из приложения-приемника (Процедура)

Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Редактирование связанного чертежа из приложения-приемника

  1. Откройте документ, содержащий связанный чертеж AutoCAD (например документ Microsoft Word).
  2. Дважды нажмите кнопку мыши на связанном чертеже.

    Откроется чертеж.

  3. Отредактируйте чертеж.
  4. Для сохранения изменений на чертеже выберите пункт меню "Файл" [image] "Сохранить".Чтобы сохранить внесенные в чертеж изменения, в командной строке введите "бсохранить".
  5. Для возврата к приложению файла назначения выберите пункт меню "Файл" [image] "Выход".Для возврата к приложению файла назначения в командной строке введите "покинуть".

    Чертеж обновляется во всех документах, с которыми он связан.

    Способ обновления связи зависит от самого приложения-приемника. Некоторые приложения обновляют связи автоматически; в других это делается вручную.


Изменение связанного чертежа в исходном приложении (Процедура)

Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Изменение связанного чертежа в исходном приложении

  1. Запустите программу и откройте связанный чертеж.
  2. Отредактируйте чертеж и связанный вид.
  3. Для сохранения изменений на чертеже выберите пункт меню "Файл" [image] Сохранить".Чтобы сохранить внесенные в чертеж изменения, в командной строке введите "бсохранить".
  4. Если необходимо, обновите связь в составном документе.

    Чертеж обновляется во всех документах, с которыми он связан.

    Способ обновления связи зависит от самого приложения-приемника. Некоторые приложения обновляют связи автоматически; в других это делается вручную.


Редактирование внедренных объектов AutoCAD (Процедура)

Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Редактирование внедренных объектов AutoCAD

  1. Откройте документ, содержащий внедренные объекты AutoCAD (например файл Microsoft Word).
  2. Дважды нажмите на внедренных объектах для запуска программы и отображения объектов.
  3. Отредактируйте объекты.
  4. Для сохранения изменений внедренных объектов выберите пункт меню "Файл" [image] "Обновить".
  5. Для возврата в приложение-приемник выберите пункт меню "Файл" [image] "Выход".Для возврата к приложению файла назначения в командной строке введите "покинуть".


Восстановление исходных размеров и формы OLE-объекта (Процедура)

Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Восстановление исходных размеров и формы OLE-объекта

  1. Выберите OLE-объект.
  2. Щелкните правой кнопкой мыши. Выберите "OLE" [image] "Сброс".

    Опция "Сброс" также доступна из диалогового окна "Размер текста".


Управление отображением OLE-объектов (Процедура)

Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Управление отображением OLE-объектов

  1. В командной строке введите olehide.
  2. Установите одно из возможных значений переменной:
    • 0Объекты OLE отображаются как в пространстве листа, так и в пространстве модели.
    • 1 Объекты OLE отображаются только в пространстве листа.
    • 2 Объекты OLE отображаются только в пространстве модели.
    • 3 Объекты OLE не отображаются.


Включение-отключение отображения рамок OLE-объекта (Процедура)

Редактирование OLE-объектов в чертежах
Редактирование OLE-объектов в чертежах
Импорт, вставка и открытие файлов других форматов
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Включение-отключение отображения рамок OLE-объекта

  1. В командной строке введите oleframe.
  2. Установите одно из возможных значений переменной:
    • 0 - рамка не отображается и не выводится на печать.
    • 1 - рамка отображается и выводится на печать.
    • 2 - рамка отображается, но на печать не выводится.

    Для того, чтобы были доступны ручки, рамка должна отображаться.


Редактирование OLE-объектов в чертежах (Краткий справочник)

Экспорт OLE-объектов из чертежей
Редактирование OLE-объектов в чертежах
Импорт файлов 3DS
Совместное использование данных в чертежах и приложениях > Составные документы и технология OLE > Редактирование OLE-объектов в чертежах >
Редактирование OLE-объектов в чертежах
Понятие Процедура Краткий справочник

Команды

КБУФЕР

Копирование выбранных объектов в буфер обмена

ВБУФЕР

Перемещение выбранных объектов в буфер обмена и удаление их из чертежа

СТЕРЕТЬ

Удаление объектов из чертежа

ВСТБУФЕР

Вставка содержимого буфера обмена

О

Отмена самой последней операции

Системные переменные

OLEFRAME

Управление отображением и выводом на печать рамок для всех объектов OLE чертежа

OLEHIDE

Управление отображением и выводом на печать объектов OLE

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с данными других форматов

Редактирование OLE-объектов в чертежах
Совместное использование данных в чертежах и приложениях
Импорт, вставка и открытие файлов других форматов
Совместное использование данных в чертежах и приложениях >
Работа с данными других форматов

Можно работать с различными графическими файлами, которые могут быть созданы в других приложениях или в более ранних версиях программы. Кроме того, можно задать пути к папкам, в которых происходит поиск чертежей или вспомогательных файлов.

Темы в этом разделе

  • Импорт, вставка и открытие файлов других форматов

    Предусмотрена возможность импорта, вставки и открытия в чертежах файлов, созданных в других приложениях и имеющих формат, отличный от DWG.

  • Создание файлов в других форматах

    При необходимости использовать информацию из файла чертежа в другом приложении его преобразуют в требуемый формат процедурами экспорта. При этом можно использовать буфер обмена.

  • Использование чертежей из разных приложений и версий

    Допустим обмен чертежами между разными версиями AutoCAD и AutoCAD LT, а также экспорт и импорт файлов, содержащих сторонние объекты. Однако в некоторых случаях существуют ограничения.


Импорт, вставка и открытие файлов других форматов

Работа с данными других форматов
Работа с данными других форматов
Импорт файлов 3DS
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов >
Импорт, вставка и открытие файлов других форматов
Понятие Процедура

Предусмотрена возможность импорта, вставки и открытия в чертежах файлов, созданных в других приложениях и имеющих формат, отличный от DWG.

Темы в этом разделе

  • Импорт файлов 3DS

    Можно импортировать файл 3DS, созданный в 3D Studio®. Выполняется считывание геометрии 3D Studio и данных тонирования, к которым относятся сети, материалы, наложения, источники света и камеры. Процедурные материалы 3D Studio, группы сглаживания и данные ключевых кадров не могут быть импортированы.

  • Импорт SAT-файлов ACIS

    Для импорта геометрических объектов, хранящихся в файлах SAT (ASCII), можно воспользоваться командой ИМПОРТТЕЛ.

  • Использование файлов DWF в качестве подложек на чертеже

    Файл формата DWF (Design Web Format) - это файл с очень сжатым форматом, созданный на основе файла DWG. Файл DWF можно вставить в файл чертежа в качестве подложки. При вставке файла DWF можно сослаться на него, не увеличивая размера файла чертежа.

  • Использование файлов DWFx в качестве подложек на чертеже

    Формат DWFx, разработанный на основе предложенного корпорацией Microsoft формата XML Paper Specification (XPS), в будущем заменит формат DWF.

  • Преобразование файлов DXF и DXB в формат DWG

    DXF и DXB - это два типа файлов обмена данными чертежей, с помощью которых можно переносить данные между различными приложениями.

  • Вставка файлов DGN в качестве подложек

    В качестве подложки можно вставить двумерные геометрические объекты, хранящиеся в файле MicroStation DGN.

  • Импорт файлов MicroStation DGN

    Предусмотрена возможность импорта файлов чертежей MicroStation® DGN в файлы DWG.

  • Управление параметрами соответствия при преобразовании

    Для операций импорта и экспорта файлов DGN предусмотрена возможность управления параметрами соответствия при преобразовании.

  • Вставка файлов растровых изображений

    В чертежах можно просматривать и манипулировать растровыми изображениями и соответствующими путями файлов.

  • Вставка файлов WMF

    Метафайлы Windows (файлы формата WMF) часто используются для хранения графических изображений. WMF-файлы можно вставлять в чертежи в виде блоков. В отличие от растровых картинок, в метафайлах информация хранится в векторном формате, поэтому их можно масштабировать без потери разрешающей способности. Если WMF-файл содержит изображения 2D фигур или широких линий, для повышения скорости рисования можно отключить их вывод на экран.


Импорт, вставка и открытие файлов других форматов (Процедура)

Редактирование OLE-объектов в чертежах
Импорт, вставка и открытие файлов других форматов
Импорт файлов 3DS
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Импорт, вставка и открытие файлов других форматов
Понятие Процедура

Для импорта файлов 3D Studio

Для импорта ACIS-файлов

Открытие файла DXF

Для открытия DXB-файла

Импорт чертежа MicroStation DGN

Создание нового набора параметров соответствия DGN

Переименование набора параметров соответствия DGN

Изменение набора параметров соответствия DGN

Удаление набора параметров соответствия DGN

Выбор типа линии из файла .lin

Добавление свойств из файла DGN

Процедура добавления свойств из файла чертежа

Процедура вставки файла WMF

Управление видимостью сплошных закрасок и широких линий в WMF-файлах


Импорт файлов 3DS (Понятие)

Импорт, вставка и открытие файлов других форматов
Импорт, вставка и открытие файлов других форматов
Импорт SAT-файлов ACIS
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Импорт файлов 3DS
Понятие Процедура Краткий справочник

Можно импортировать файл 3DS, созданный в 3D Studio®. Выполняется считывание геометрии 3D Studio и данных тонирования, к которым относятся сети, материалы, наложения, источники света и камеры. Процедурные материалы 3D Studio, группы сглаживания и данные ключевых кадров не могут быть импортированы.

Импортированным объектам назначается цвет, максимально приближенный к цвету объекта в 3D Studio.

Для источников света и материалов применяются команды ПРЕОБРУСТАРСВЕТ и ПРЕОБРУСТАРМАТЕРИАЛ. Источники света в 3D Studio преобразуются в наиболее близкий эквивалент. Источники рассеянного света теряют цветовую окраску. Источники ненаправленного света становятся точечными источниками. Прожекторы остаются прожекторами. Камеры 3D Studio становятся именованными видами.

Возможен конфликт между именами объектов 3D Studio и AutoCAD. В этом случае имени объекта 3D Studio присваивается следующий по порядку номер. При этом имя объекта может оказаться усеченным.


Для импорта файлов 3D Studio (Процедура)

Импорт, вставка и открытие файлов других форматов
На уровень вверх ..
Импорт SAT-файлов ACIS
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Импорт файлов 3DS >
Импорт файлов 3DS
Понятие Процедура Краткий справочник

Для импорта файлов 3D Studio

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Импорт" [image] 3DS-файл. В командной строке введите "импорт3дс".
  2. В диалоговом окне "Импорт файла 3D Studio" найдите и выберите импортируемый файл.
  3. Нажмите "Открыть".
Ввод команды: ИМПОРТ3DC


Импорт файлов 3DS (Краткий справочник)

Редактирование OLE-объектов в чертежах
Импорт файлов 3DS
Импорт SAT-файлов ACIS
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Импорт файлов 3DS >
Импорт файлов 3DS
Понятие Процедура Краткий справочник

Команды

ИМПОРТ3DC

Импорт файлов 3D Studio (3DS)

ИМПОРТ

Импорт файлов в различных форматах

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Импорт SAT-файлов ACIS (Понятие)

Импорт файлов 3DS
Импорт, вставка и открытие файлов других форматов
Использование файлов DWF в качестве подложек на чертеже
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Импорт SAT-файлов ACIS
Понятие Процедура Краткий справочник

Для импорта геометрических объектов, хранящихся в файлах SAT (ASCII), можно воспользоваться командой ИМПОРТТЕЛ.

Команда "ИМПОРТТЕЛ" преобразует модель в объект тела или в 3D тела и области, если объект в действительности является телом или областью.


Для импорта ACIS-файлов (Процедура)

Импорт файлов 3DS
На уровень вверх ..
Использование файлов DWF в качестве подложек на чертеже
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Импорт SAT-файлов ACIS >
Импорт SAT-файлов ACIS
Понятие Процедура Краткий справочник

Для импорта ACIS-файлов

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Импорт" [image] ACIS-файл. В командной строке введите "импорттел".
  2. В диалоговом окне "Выбор ACIS-файла" найдите и выберите импортируемый файл.
  3. Нажмите "Открыть".
Ввод команды: ИМПОРТТЕЛ


Импорт SAT-файлов ACIS (Краткий справочник)

Импорт файлов 3DS
Импорт SAT-файлов ACIS
Вставка файлов DWF как подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Импорт SAT-файлов ACIS >
Импорт SAT-файлов ACIS
Понятие Процедура Краткий справочник

Команды

ИМПОРТТЕЛ

Импорт файлов формата ACIS и создание в чертеже соответствующих объектов: тел ACIS, 3D тел и областей

ИМПОРТ

Импорт файлов в различных форматах

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование файлов DWF в качестве подложек на чертеже

Импорт SAT-файлов ACIS
Импорт, вставка и открытие файлов других форматов
Вставка и удаление DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Использование файлов DWF в качестве подложек на чертеже
Понятие Процедура

Файл формата DWF (Design Web Format) - это файл с очень сжатым форматом, созданный на основе файла DWG. Файл DWF можно вставить в файл чертежа в качестве подложки. При вставке файла DWF можно сослаться на него, не увеличивая размера файла чертежа.

Темы в этом разделе

  • Вставка и удаление DWF-подложек

    Имеется возможность вставки или удаления подложки DWF (вхождения файлов DWF) в файлы чертежей. Также можно изменять положение, масштаб и ориентацию подложек DWF.

  • Работа со вставленными файлами DWF-подложек

    После вставки подложки DWF можно изменить ее расположение, масштаб или угол поворота, а также с помощью функции объектной привязки для DWF задать расположение различных объектов относительно объектов подложки DWF.

  • Изменение свойств отображения и подрезки DWF-подложки

    В подложке DWF предусмотрена возможность управления слоями, настройки внешнего вида и задания подрезающих контуров.

  • Управление и публикация чертежей, содержащих DWF-подложки

    Имеется возможность просмотра и работы с подложками DWF и изменения путей к подложкам с палитры "Внешние ссылки".


Использование файлов DWF в качестве подложек на чертеже (Процедура)

Импорт SAT-файлов ACIS
На уровень вверх ..
Вставка и удаление DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже >
Использование файлов DWF в качестве подложек на чертеже
Понятие Процедура

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

Редактирование положения подложки DWF с помощью базовой ручки


Вставка и удаление DWF-подложек

Использование файлов DWF в качестве подложек на чертеже
Использование файлов DWF в качестве подложек на чертеже
Вставка файлов DWF как подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже >
Вставка и удаление DWF-подложек
Понятие Процедура

Имеется возможность вставки или удаления подложки DWF (вхождения файлов DWF) в файлы чертежей. Также можно изменять положение, масштаб и ориентацию подложек DWF.

Темы в этом разделе

  • Вставка файлов DWF как подложек

    Файл DWF можно вставить в файл чертежа в качестве подложки.

  • Удаление файлов DWF-подложек

    Подложки DWF могут быть удалены из файла чертежа.


Вставка и удаление DWF-подложек (Процедура)

Использование файлов DWF в качестве подложек на чертеже
На уровень вверх ..
Вставка файлов DWF как подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Вставка и удаление DWF-подложек >
Вставка и удаление DWF-подложек
Понятие Процедура

Вставка подложки DWF

Удаление подложки DWF


Вставка файлов DWF как подложек (Понятие)

Вставка и удаление DWF-подложек
Вставка и удаление DWF-подложек
Удаление файлов DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Вставка и удаление DWF-подложек >
Вставка файлов DWF как подложек
Понятие Процедура Краткий справочник

Файл DWF можно вставить в файл чертежа в качестве подложки.

Показать: "Вставка файла DWF в качестве подложки"

Для запуска анимации нажмите на стрелку "Показать".

На файлы DWF ссылаются и размещают их в файлах чертежей таким же способом как файлы растровых изображений, но на самом деле они не являются частью файла чертежа. Как и при работе с растровыми изображениями, связь файла чертежа и подложки DWF устанавливается заданием пути. Можно в любой момент редактировать пути связей с файлами DWF или удалять их. За счет вставки подложек DWF с помощью связанных путей к файлам DWF имеется возможность использовать файлы DWF без существенного увеличения размера файла чертежа.

ПримечаниеХотя файлы подложки DWF являются воспроизведением своих исходных чертежей, они не так точны, как файлы чертежей. В подложках DWF могут наблюдаться расхождения по точности.

Перетаскивание и вставка файлов DWF-подложек

Также имеется возможность непосредственного перетаскивания подложек DWF в чертеж. При перетаскивании файла DWF в чертеж отображается запрос на ввод имени листа из файла DWF в командной строке. После этого требуется указать точку вставки, масштабный коэффициент и угол поворота.

Допускается многократная вставка в чертеж одной и той же подложки DWF; общая стратегия здесь полностью совпадает с используемой для блоков. Каждая подложка имеет собственную границу подрезки и отличающиеся от других вхождений значения контрастности, степени слияния с фоном и наличия цвета. Тем не менее, невозможно внедрить подложку в чертёж, и невозможно внести изменения в содержимое чертежа подложки.

Слои в файлах DWF-подложки

Отображение диалогового окна "Слои DWF" зависит от информации о слоях, опубликованных в файле DWF. При отсутствии информации о слоях диалоговое окно "Слои DWF" не отображается. Кроме того, в командной строке отображается следующее сообщение.

Выбранная DWF-подложка не содержит сведений о слоях.

Файлы DWF-подложек во внешних ссылках

При работе с чертежами, содержащими ссылки на файлы DWG (внешние ссылки), существует вероятность наличия в одной из них вставленной подложки DWF. В этом случае объекты в файле DWF будут видны в исходном файле DWG.

Например, "Чертеж А" содержит подложку DWF, на которой показаны некоторые особенности конструкции. Требуется содержимое "Чертежа А" вставить в текущий чертеж, "Чертеж Б". Если вставить "Чертеж А" в "Чертеж Б" в качестве внешней ссылки, подложка DWF, уже вставленная в "Чертеж А", также будет присутствовать.

Все настройки свойств объектов, сделанные для подложки в ссылке в файле DWG, например границы подрезки, отображаются также, как в исходном чертеже.

Файлы DWF-подложек с защитой паролем

Если файл DWF, который требуется вставить как подложку, защищен паролем, после выбора файла будет выдан запрос на ввод пароля. Нельзя завершить процедуру вставки, пока пароль не будет введен правильно.

После вставки подложки DWF в файл DWG запрос на ввод пароля файла DWF будет выдаваться при последующем открытии файла чертежа. Если файл DWG также защищен паролем или в него вставлено несколько ссылок на разные защищенные чертежи, может запрашиваться несколько паролей.

Если возникла необходимость перенаправить путь к подложке DWF на файл DWF, требующий ввода пароля, будет выдан соответствующий запрос.

СоветПароль файла DWF вводится с учетом регистра, а пароль файла DWG -без. Для упрощения согласования между паролями файлов DWG и DWF рекомендуется вводить пароль файла DWF, совпадающий с паролем файла DWG и полностью набираемый в верхнем регистре.


Вставка подложки DWF (Процедура)

Вставка и удаление DWF-подложек
На уровень вверх ..
Удаление файлов DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Вставка и удаление DWF-подложек > Вставка файлов DWF как подложек >
Вставка файлов DWF как подложек
Понятие Процедура Краткий справочник

Вставка подложки DWF

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Ссылка" [image] DWF. В командной строке введите "двфвставить".
  2. В диалоговом окне "Выбор DWF-файла" выберите файл, который требуется вставить.
  3. Нажмите "Открыть".
  4. Если файл DWF содержит несколько листов, в диалоговом окне "Вставка DWF-подложки" выберите лист для вставки.
  5. Воспользуйтесь одним из следующих способов для указания точки вставки, масштаба или угла поворота файла подложки:
    • Установите флажок "Указать на экране", чтобы использовать устройство указания для вставки подложки DWF в определенную точку с необходимым масштабом и под нужным углом.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".
  6. Нажмите "ОК".
Панель:Вставка
Ввод команды: ДВФВСТАВИТЬ


Вставка файлов DWF как подложек (Краткий справочник)

Импорт SAT-файлов ACIS
Вставка файлов DWF как подложек
Удаление файлов DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Вставка и удаление DWF-подложек > Вставка файлов DWF как подложек >
Вставка файлов DWF как подложек
Понятие Процедура Краткий справочник

Команды

ДВФРЕГУЛ

Позволяет выполнять настройку подложки DWF или DWFx из командной строки

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ОКНОСВ

Управление свойствами объектов

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

Системные переменные

DWFFRAME

Определение видимости контура подложки DWF или DWFx

DWFOSNAP

Определение активности привязки объекта для геометрии в подложках DWF или DWFx, прикрепленных к чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Удаление файлов DWF-подложек (Понятие)

Вставка файлов DWF как подложек
Вставка и удаление DWF-подложек
Работа со вставленными файлами DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Вставка и удаление DWF-подложек >
Удаление файлов DWF-подложек
Понятие Процедура Краткий справочник

Подложки DWF могут быть удалены из файла чертежа.

Имеется возможность удалять подложки DWF, которые больше не нужны на чертеже. При удалении подложки DWF из чертежа убираются все ее экземпляры, очищается описание подложки и удаляется путь связи с файлом DWF.

ПримечаниеСтирание отдельного экземпляра подложки DWF не эквивалентно ее удалению. Подложку DWF необходимо удалять для разрыва связи чертежа с файлом DWF.


Удаление подложки DWF (Процедура)

Вставка файлов DWF как подложек
На уровень вверх ..
Работа со вставленными файлами DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Вставка и удаление DWF-подложек > Удаление файлов DWF-подложек >
Удаление файлов DWF-подложек
Понятие Процедура Краткий справочник

Удаление подложки DWF

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" в окне "Вхождения файлов" выберите подложку DWF, которую требуется удалить.
  3. Укажите подложку DWF правой кнопкой мыши и нажмите "Удалить".

    Подложка DWF больше не связана с файлом чертежа. Все экземпляры подложки удаляются из чертежа.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку DWF и щелкните правой кнопкой мыши в области чертежа. Выберите палитру "Внешние ссылки".


Удаление файлов DWF-подложек (Краткий справочник)

Вставка файлов DWF как подложек
Удаление файлов DWF-подложек
Работа со вставленными файлами DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Вставка и удаление DWF-подложек > Удаление файлов DWF-подложек >
Удаление файлов DWF-подложек
Понятие Процедура Краткий справочник

Команды

ДВФРЕГУЛ

Позволяет выполнять настройку подложки DWF или DWFx из командной строки

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ОКНОСВ

Управление свойствами объектов

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

Системные переменные

DWFFRAME

Определение видимости контура подложки DWF или DWFx

DWFOSNAP

Определение активности привязки объекта для геометрии в подложках DWF или DWFx, прикрепленных к чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа со вставленными файлами DWF-подложек (Понятие)

Удаление файлов DWF-подложек
Использование файлов DWF в качестве подложек на чертеже
Изменение свойств отображения и подрезки DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже >
Работа со вставленными файлами DWF-подложек
Понятие Процедура Краткий справочник

После вставки подложки DWF можно изменить ее расположение, масштаб или угол поворота, а также с помощью функции объектной привязки для DWF задать расположение различных объектов относительно объектов подложки DWF.

Хотя точка вставки, масштабный коэффициент и угол поворота могут быть указаны в момент вставки файла DWF, может возникнуть необходимость изменения этих параметров по мере работы над чертежом. По умолчанию, точка вставки файла DWF имеет координаты (0,0,0), масштабный коэффициент равен 1, а угол поворота - 0.

Так как вставленная подложка DWF ведет себя так же, как вставленное растровое изображение, общие команды редактирования используются в том же режиме, позволяя перемещать ее, масштабировать, поворачивать, симметрично отражать, создавать массив и т.д. Для внесения изменений можно также выбрать подложку DWF, а затем требуемую команду в контекстном меню или на палитре свойств.

СоветДвойное нажатие кнопки мыши на подложке DWF откроет палитру свойств для данной подложки.

Работа с функцией привязки объектов к DWF-подложкам

Привязка к объектам DWF функционирует аналогично обычной объектной привязке, с тем отличием, что ее можно включить или отключить отдельно от обычной объектной привязки и что она применяется только к объектам во вставленном файле DWF.

Привязка к объектам DWF применяется в том случае, если требуется вычерчивание или редактирование различных объектов относительно тех объектов, которые отображаются на одной или нескольких вставленных подложках DWF. Привязка объекта к геометрическим объектам подложки DWF не отличается от привязки объекта к геометрическим объектам файлов DWG. Объектная привязка для подложек DWF включается и отключается с помощью системной переменной DWFOSNAP.

Объектную привязку к DWF также можно включить и отключить из контекстного меню. Выберите файл подложки DWF, затем нажмите правую кнопку мыши. В контекстном меню выберите "Объектная привязка к DWF".

Ручки DWF-подложки

Хотя режимы работы с подложкой DWF в основном соответствуют принятым для растровых изображений, имеется одно отличие в способе действия ручек. В данном случае режим ближе к принятому для блоков.

Подложки DWF обычно отображают только базовую ручку. Базовая ручка используется для изменения положения подложки на чертеже. Если настроен контур подрезки, у каждого угла контура появляются дополнительные ручки. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Изменение свойств отображения и подрезки DWF-подложки .

Ручка базовой точки выглядит аналогично базовой точке стандартного блока. Базовую точку нельзя перенастроить изнутри основного файла DWG. Она определяется при публикации файла DWF на основании начала координат исходного файла DWG. Если существующий (унаследованный) файл DWF не имеет определенной базовой точки, в качестве базовой точки (0,0,0) используется левый нижний угол.


Работа со вставленными файлами DWF-подложек (Процедура)

Удаление файлов DWF-подложек
На уровень вверх ..
Работа со вставленными файлами DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Работа со вставленными файлами DWF-подложек >
Работа со вставленными файлами DWF-подложек
Понятие Процедура Краткий справочник

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

Редактирование положения подложки DWF с помощью базовой ручки


Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств (Процедура)

Работа со вставленными файлами DWF-подложек
На уровень вверх ..
Работа со вставленными файлами DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Работа со вставленными файлами DWF-подложек >
Работа со вставленными файлами DWF-подложек
Понятие Процедура Краткий справочник

Редактирование положения, масштаба или угла поворота подложки DWF с палитры свойств

  1. На видовом экране чертежа дважды нажмите кнопку мыши на подложке DWF, которую требуется отредактировать.
  2. На палитре свойств выведите на экран группу "Геометрия" и выполните одну из следующих операций:
    • Для изменения положения подложки DWF измените значения параметров "Положение X", "Положение Y" или "Положение Z".
    • Для изменения масштаба, ширины или высоты подложки DWF внесите изменения значений параметров "Масштаб", "Ширина" и "Высота".
    • Для изменения угла поворота подложки DWF измените значение параметра "Угол поворота".


Редактирование положения подложки DWF с помощью базовой ручки (Процедура)

Работа со вставленными файлами DWF-подложек
На уровень вверх ..
Изменение свойств отображения и подрезки DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Работа со вставленными файлами DWF-подложек >
Работа со вставленными файлами DWF-подложек
Понятие Процедура Краткий справочник

Редактирование положения подложки DWF с помощью базовой ручки

  1. Укажите контур вставленной подложки DWF.
  2. Для изменения положения подложки DWF нажмите базовую ручку.
  3. Перетащить курсор в новое положение, а затем нажмите кнопку мыши снова, чтобы разместить подложку DWF.


Работа со вставленными файлами DWF-подложек (Краткий справочник)

Удаление файлов DWF-подложек
Работа со вставленными файлами DWF-подложек
Управление отображением слоев в DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Работа со вставленными файлами DWF-подложек >
Работа со вставленными файлами DWF-подложек
Понятие Процедура Краткий справочник

Команды

ДВФВСТАВИТЬ

Вставка подложки DWF или DWFx в текущий чертеж

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

ДВФСЛОЙ

Управление отображением слоев в DWF или DWFx подложке

Системные переменные

DWFOSNAP

Определение активности привязки объекта для геометрии в подложках DWF или DWFx, прикрепленных к чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение свойств отображения и подрезки DWF-подложки

Работа со вставленными файлами DWF-подложек
Использование файлов DWF в качестве подложек на чертеже
Управление отображением слоев в DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже >
Изменение свойств отображения и подрезки DWF-подложки
Понятие Процедура

В подложке DWF предусмотрена возможность управления слоями, настройки внешнего вида и задания подрезающих контуров.

Темы в этом разделе

  • Управление отображением слоев в DWF-подложке

    В подложке DWF можно включать и отключать слои.

  • Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки

    Помимо палитры "Свойства" для редактирования положения, масштаба и угла поворота подложки DGN предусмотрена возможность изменения параметров слияния с фоном, контрастности, "Монохромный" и цвета фона подложки DGN.

  • Подрезка DWF-подложек

    Для подрезки изображения подложки DWF на чертеже можно использовать прямоугольный или многоугольный контур подрезки.

  • Показ и скрытие контуров DWF-подложки

    Имеется возможность управления видимостью контура, который описывает границы подложки DWF или видимостью контура, который определяется контуром подрезки.


Изменение свойств отображения и подрезки DWF-подложки (Процедура)

Работа со вставленными файлами DWF-подложек
На уровень вверх ..
Управление отображением слоев в DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки >
Изменение свойств отображения и подрезки DWF-подложки
Понятие Процедура

Процедура включения и отключения слоев подложки DWF

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью палитры свойств

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью команды "ДВФРЕГУЛ"

Подрезка подложки DWF

Указание нового контура для подрезанной подложки DWF

Редактирование существующего контура у подрезанной подложки DWF

Показ или скрытие подрезанной части подложки DWF

Удаление контура подрезанной подложки DWF

Показ и скрытие контуров подложки DWF


Управление отображением слоев в DWF-подложке (Понятие)

Изменение свойств отображения и подрезки DWF-подложки
Изменение свойств отображения и подрезки DWF-подложки
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки >
Управление отображением слоев в DWF-подложке
Понятие Процедура Краткий справочник

В подложке DWF можно включать и отключать слои.

По умолчанию во вставленной подложке DWF включены все слои. Как правило, при работе с подложками DWF во избежание чрезмерной сложности изображения требуется отключить неиспользуемые слои.

Воспользуйтесь командой ДВФСЛОЙ или выберите "Слои DWF" в контекстном меню, отображаемом при щелчке на выбранной подложке DWF правой кнопкой мыши.

ПримечаниеФайл DWF можно опубликовать без информации о слоях. Если подложка DWF не содержит слоев, диалоговое окно "Слои DWF" отображается без данных.

С помощью палитры свойств можно определить, отключены ли какие-либо слои подложки DWF.

  • При отсутствии отключенных слоев для свойства "Переопределение отображения слоев" задано значение "Нет".
  • Если хотя бы один слой отключен, для свойства "Переопределение отображения слоев" задано значение "Применяется".


Процедура включения и отключения слоев подложки DWF (Процедура)

Изменение свойств отображения и подрезки DWF-подложки
На уровень вверх ..
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Управление отображением слоев в DWF-подложке >
Управление отображением слоев в DWF-подложке
Понятие Процедура Краткий справочник

Процедура включения и отключения слоев подложки DWF

  1. Выберите подложку DWF, щелкнув на ограничивающей ее рамке.
  2. Щелкните правой кнопкой мыши, затем выберите "Слои DWF".

    Если подложка DWF не содержит ни одного слоя, этот пункт меню не доступен и отображается серым цветом.

  3. В диалоговом окне "Слои DWF" щелкните на значке лампочки рядом с именем слоя, который требуется включить или отключить.

    Для выбора нескольких слоев следует во время щелчка удерживать нажатой клавишу CTRL или SHIFT.

  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Ввод команды: ДВФСЛОЙ


Управление отображением слоев в DWF-подложке (Краткий справочник)

Работа со вставленными файлами DWF-подложек
Управление отображением слоев в DWF-подложке
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Управление отображением слоев в DWF-подложке >
Управление отображением слоев в DWF-подложке
Понятие Процедура Краткий справочник

Команды

ДВФСЛОЙ

Управление отображением слоев в DWF или DWFx подложке

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки (Понятие)

Управление отображением слоев в DWF-подложке
Изменение свойств отображения и подрезки DWF-подложки
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки >
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Понятие Процедура Краткий справочник

Помимо палитры "Свойства" для редактирования положения, масштаба и угла поворота подложки DGN предусмотрена возможность изменения параметров слияния с фоном, контрастности, "Монохромный" и цвета фона подложки DGN.

Также можно установить значения параметров контрастности, слияния с фоном, "Монохромный" и цвета для вывода на печать без влияния на исходный файл DWF и без влияния на другие экземпляры DWF на чертеже.

Изменения контрастности, степени слияния с фоном, цветов и параметра "Монохромный" выполняются в группе "Регулировка DWF" на палитре "Свойства" при выбранной подложке DWF.

ПримечаниеНастройка цветопередачи возможна только при работе с визуальным стилем "2D каркас".

Контрастность

Управляет внешним видом самой тусклой рабочей линии, присутствующей в подложке DWF. Действует совместно с параметром "Слияние с фоном". Если для параметра "Контрастность" задано значение 100, все контурные изображения соответствуют интенсивности значения параметра "Слияние с фоном". Если значение контрастности равно 20, интенсивность самых тусклых линий уменьшается на 20 процентов от значения параметра "Слияние с фоном".

Слияние с фоном

Параметр "Слияние с фоном" определяет насколько светлыми или темными отображаются линии. Высокие значения обеспечивают светлые линии; и наоборот, низкие значения параметра слияния с фоном приводят к отображению темных линий.

Монохромный

Параметр "Монохромный" используется для управления насыщенностью цвета всех контурных изображений, одновременно обеспечивая яркость. При его включении контурные изображения отображаются разными оттенками серого цвета, начиная от черного, если яркость цвета фона составляет 50% или выше. Если яркость цвета фона ниже 50%, происходит инверсия цветов, так что самая темная линия контура отображается белым цветом, а самая светлая - черным. Такая инверсия используется для отображения подложки на экране, но для печати осуществляется возврат в исходное состояние.

Регулировка цвета заднего плана

Параметр "Регулировка цвета заднего плана" регулирует, будут ли видны фоновые цвета подложки DWF через цвет фона чертежа. Значение по умолчанию "Да" позволяет проводить анализ цветов фона подложки DWF и среды построений чертежа для проверки, не являются ли они оба светлыми или темными, или же один - темный, а другой - светлый. Если один фон - светлый, а другой - темный, цвета подложки DWF инвертируются так, чтобы подложка была видна. При изменении значения параметра на "Нет", используется исходные цвета подложки. В зависимости от цветов фона, подложку DWF может не быть видно.


Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки (Процедура)

Управление отображением слоев в DWF-подложке
На уровень вверх ..
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки >
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Понятие Процедура Краткий справочник

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью палитры свойств

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью команды "ДВФРЕГУЛ"


Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью палитры свойств (Процедура)

Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
На уровень вверх ..
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки >
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Понятие Процедура Краткий справочник

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью палитры свойств

  1. Выберите подложку DWF, параметры которой требуется отредактировать.
  2. Выберите пункт меню "Редактирование" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре свойств DWF-подложки выполните одно из следующих действий:
    • Отрегулируйте контрастность, вводя новое значение.

      Значение по умолчанию для контрастности - 25 на шкале от 0 (низкая) до 100 (высокая).

    • Отрегулируйте степень слияния с фоном, вводя новое значение.

      Значение по умолчанию для слияния с фоном - 25 на шкале от 0 (темное) до 80 (светлое).

    • Включите или отключите параметр "Монохромный".

      Значением по умолчанию для параметра "Монохромный" является "Откл".

    • Задайте для параметра "Регулировка цвета заднего плана" значение "Да" или "Нет".

      По умолчанию значение параметра "Регулировка цвета заднего плана" - "Да".

Обновление внешнего вида подложки DWF происходит в реальном времени, одновременно с регулировкой значений параметров на палитре свойств.

Контекстное меню:Дважды нажмите кнопку мыши на подложке DWF.


Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью команды "ДВФРЕГУЛ" (Процедура)

Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
На уровень вверх ..
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки >
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Понятие Процедура Краткий справочник

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWF с помощью команды "ДВФРЕГУЛ"

  1. В командной строке введите "ДВФРЕГУЛ".
  2. Выберите подложку DWF, параметры которой требуется отредактировать.
  3. С помощью меню "Ввод параметров DWF-подложки" выберите значение одного из указанных ниже параметров.
    • Выберите "Слияние с фоном" и введите значение слияния с фоном.

      Значение по умолчанию для слияния с фоном - 25 на шкале от 0 (темное) до 80 (светлое).

    • Выберите "Контрастность" и введите значение контрастности.

      Значение по умолчанию для контрастности равно 75 по шкале от 0 (низкая) до 100 (высокая).

    • Выберите "Монохромный" и задайте для этого параметра значение "Да" или "Нет".

      По умолчанию для параметра "Монохромный" задано значение "Нет".

После ввода нового значения и завершения выполнения команды внешний вид подложки DWF обновляется.


Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки (Краткий справочник)

Управление отображением слоев в DWF-подложке
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки >
Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Понятие Процедура Краткий справочник

Команды

ДВФРЕГУЛ

Позволяет выполнять настройку подложки DWF или DWFx из командной строки

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подрезка DWF-подложек (Понятие)

Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Изменение свойств отображения и подрезки DWF-подложки
Показ и скрытие контуров DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Для подрезки изображения подложки DWF на чертеже можно использовать прямоугольный или многоугольный контур подрезки.

Можно определить часть подложки DWF, которую требуется отображать и выводить на печать, путем задания контура подрезки. Дополнительным преимуществом от задания контура подрезки является увеличение скорости перерисовки за счет выделения только частей подложки, которые должны быть видимыми. Контуром подрезки может служить прямоугольник или двумерный (2D) многоугольник, вершины которого лежат внутри границ подложки. Контур подрезки для каждого экземпляра подложки DWF может быть только один. Разные экземпляры одной и той же подложки могут иметь разные контуры. Контур подрезанной подложки можно изменить в любой момент.

Подрезанную подложку можно отображать с использованием контура подрезки или можно его скрыть, чтобы отображать подложку в её исходных границах.

Если контур подрезки более не нужен, его можно удалить из подложки. После удаления контура подрезки подложка отображается в своих исходных границах.

Далее приводится пример подложки DWF с вкладками, демонстрирующий многоугольный (м) и прямоугольный (п) контур подрезки:


Подрезка DWF-подложек (Процедура)

Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
На уровень вверх ..
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Подрезка DWF-подложек >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Подрезка подложки DWF

Указание нового контура для подрезанной подложки DWF

Редактирование существующего контура у подрезанной подложки DWF

Показ или скрытие подрезанной части подложки DWF

Удаление контура подрезанной подложки DWF


Подрезка подложки DWF (Процедура)

Подрезка DWF-подложек
На уровень вверх ..
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Подрезка DWF-подложек >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Подрезка подложки DWF

  1. Выберите подложку DWFx, щелкнув на ограничивающей ее рамке.
  2. Щелкните на подложке DWF правой кнопкой мыши. Выберите "Подрезка DWF...".
  3. В командной строке введите н (Новый контур).
  4. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

Контекстное меню:Нажмите правую кнопку мыши на объекте подложки DWF. Выберите "Подрезка DWF...".
Ввод команды: ДВФРЕЗ


Указание нового контура для подрезанной подложки DWF (Процедура)

Подрезка DWF-подложек
На уровень вверх ..
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Подрезка DWF-подложек >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Указание нового контура для подрезанной подложки DWF

  1. Нажмите правую кнопку мыши на объекте, являющемся частью подложки DWF. Выберите "Подрезка DWF...".
  2. В командной строке введите н (Новый контур).
  3. Введите н (Нет) или д (Да) в ответ на запрос об удалении старого контура.
  4. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

    Контуры подрезки могут редактироваться с помощью ручек. См. раздел Редактирование с помощью ручек.

Контекстное меню:Нажмите правую кнопку мыши на подрезанной подложке DWF. Выберите "Подрезка DWF...".
Ввод команды: ДВФРЕЗ


Редактирование существующего контура у подрезанной подложки DWF (Процедура)

Подрезка DWF-подложек
На уровень вверх ..
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Подрезка DWF-подложек >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Редактирование существующего контура у подрезанной подложки DWF

  1. Выберите подрезанную подложку DWF.
  2. Нажмите одну из угловых ручек и перетащить ее в новое положение.
  3. Нажмите кнопку мыши повторно для установки угловой ручки.
Контекстное меню:Нажмите правую кнопку мыши на подрезанной подложке DWF. Выберите "Подрезка DWF...".
Ввод команды: ДВФРЕЗ


Показ или скрытие подрезанной части подложки DWF (Процедура)

Подрезка DWF-подложек
На уровень вверх ..
Подрезка DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Подрезка DWF-подложек >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Показ или скрытие подрезанной части подложки DWF

  1. Выберите подрезанную подложку DWF, часть которой требуется показать или скрыть.
  2. Нажмите правую кнопку мыши и выберите "Свойства".
  3. Осуществите прокрутку до группы "Прочие" и выберите "Да" или "Нет" для параметра "Показ подрезанного".
    Контекстное меню:После выбора подрезанной подложки DWF нажмите правую кнопку мыши. Нажмите кнопку "Свойства".
    Ввод команды: ОКНОСВ


Удаление контура подрезанной подложки DWF (Процедура)

Подрезка DWF-подложек
На уровень вверх ..
Показ и скрытие контуров DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Подрезка DWF-подложек >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Удаление контура подрезанной подложки DWF

  1. Выберите подрезанную подложку DWF.
  2. Нажмите правую кнопку мыши и выберите "Подрезка DWF...".
  3. Нажмите кнопку "Удалить".

    Контур подрезанной подложки удаляется, и восстанавливается исходный контур подложки.

Контекстное меню:Нажмите правую кнопку мыши на подрезанной подложке DWF. Выберите "Подрезка DWF...".
Ввод команды: ДВФРЕЗ


Подрезка DWF-подложек (Краткий справочник)

Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона DWF-подложки
Подрезка DWF-подложек
Показ и скрытие контуров DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Подрезка DWF-подложек >
Подрезка DWF-подложек
Понятие Процедура Краткий справочник

Команды

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Показ и скрытие контуров DWF-подложки (Понятие)

Подрезка DWF-подложек
Изменение свойств отображения и подрезки DWF-подложки
Управление и публикация чертежей, содержащих DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки >
Показ и скрытие контуров DWF-подложки
Понятие Процедура Краткий справочник

Имеется возможность управления видимостью контура, который описывает границы подложки DWF или видимостью контура, который определяется контуром подрезки.

Можно скрывать контуры подложки DWF. Контур - это визуальная граница, которая показывает предельные размеры подложки DWF или контур ее подрезки. Скрытие контура подложки предотвращает печать границы или ее представление на экране. Тем не менее, при невидимом контуре можно выбрать подложку с помощью устройства указания. Однако подложки DWF все же можно выбирать, если они не находятся на заблокированном слое, например, если подложка является частью именованного набора объектов, выбранных с использованием параметра "Все". Если контуры подложки скрыты, подрезанные подложки все же отображаются в заданных для них пределах; операция относится только к контуру. Включение и отключение отображения контуров подложки относится ко всем подложкам, вставленным в чертеж.

Приведенный на переднем плане пример показывает подложку DWF с видимым контуром DWF.

Приведенный на переднем плане пример показывает подложку DWF с видимым контуром DWF.


Показ и скрытие контуров подложки DWF (Процедура)

Подрезка DWF-подложек
На уровень вверх ..
Управление и публикация чертежей, содержащих DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Показ и скрытие контуров DWF-подложки >
Показ и скрытие контуров DWF-подложки
Понятие Процедура Краткий справочник

Показ и скрытие контуров подложки DWF

  1. В командной строке введите dwfframe.
  2. На запрос в командной строке произведите одну из следующих операций:
    • Для скрытия контуров подложки DWF введите 0.
    • Для отображения и вывода на печать контуров подложки DWF введите 1.
    • Для показа контуров подложки DWF на экране без вывода на печать введите 2.
Ввод команды: DWFFRAME


Показ и скрытие контуров DWF-подложки (Краткий справочник)

Подрезка DWF-подложек
Показ и скрытие контуров DWF-подложки
Просмотр сведений о DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Изменение свойств отображения и подрезки DWF-подложки > Показ и скрытие контуров DWF-подложки >
Показ и скрытие контуров DWF-подложки
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

DWFFRAME

Определение видимости контура подложки DWF или DWFx

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление и публикация чертежей, содержащих DWF-подложки

Показ и скрытие контуров DWF-подложки
Использование файлов DWF в качестве подложек на чертеже
Просмотр сведений о DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже >
Управление и публикация чертежей, содержащих DWF-подложки
Понятие Процедура

Имеется возможность просмотра и работы с подложками DWF и изменения путей к подложкам с палитры "Внешние ссылки".

Темы в этом разделе

  • Просмотр сведений о DWF-подложке

    Можно просматривать относящуюся к файлам информацию о подложках DWF, вставленных в чертеж, на палитре "Внешние ссылки". Также имеется возможность загружать и выгружать подложки и производить иные операции.

  • Изменение путей к файлам DWF-подложек

    Имеется возможность изменения пути к файлу DWF, на который имеется ссылка, или поиска необнаруженной подложки DWF.

  • Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки

    Файлы чертежей, содержащие вставки подложек DWF, можно выводить на печать или публиковать как файлы DWF. При формировании комплекта для электронной пересылки происходит отслеживание и управление файлами DWF. Более того, подложки DWF не будут потеряны при сохранении в формате чертежа прежних версий.

  • Диспетчер ссылок и DWF-подложек

    С помощью Диспетчера ссылок можно просматривать вхождения файлов, вставленных в файл DWF, и редактировать пути вставляемых файлов.


Управление и публикация чертежей, содержащих DWF-подложки (Процедура)

Показ и скрытие контуров DWF-подложки
На уровень вверх ..
Просмотр сведений о DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки >
Управление и публикация чертежей, содержащих DWF-подложки
Понятие Процедура

Просмотр списка подложек DWF, вставленных в чертеж

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

Процедура просмотра состояния переопределения слоев подложки DWF

Изменение пути к подложке DWF

Проверка подложек DWF с помощью Диспетчера ссылок


Просмотр сведений о DWF-подложке (Понятие)

Управление и публикация чертежей, содержащих DWF-подложки
Управление и публикация чертежей, содержащих DWF-подложки
Изменение путей к файлам DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки >
Просмотр сведений о DWF-подложке
Понятие Процедура Краткий справочник

Можно просматривать относящуюся к файлам информацию о подложках DWF, вставленных в чертеж, на палитре "Внешние ссылки". Также имеется возможность загружать и выгружать подложки и производить иные операции.

На палитре "Внешние ссылки" можно просматривать сведения о подложке или в виде списка, или в режиме древовидного представления. Способ отображения информации на палитре "Внешние ссылки" выбирается кнопками "Список" или "Дерево" в верхнем правом углу. В режиме списка для каждой подложки на чертеже отображаются имя, статус ее загрузки, размер файла, дата последнего изменения и путь поиска файла. В режиме просмотра дерева подложки представлены в рамках иерархической структуры, отображающей уровень их вложенности во внешние ссылки и блоки. Сведения о статусе, размере и т.д. не выводятся.

Для любого вида можно отобразить информацию о подложке; вставить или удалить подложку; выгрузить или обновить подложку; а также выбрать и сохранить новый путь поиска.

Работа с режимом списка

В режиме просмотра списка отображаются все подложки, вставленные в текущий чертеж, но нет никакой информации о количестве экземпляров. Этот режим установлен по умолчанию. Сортировка подложек по категориям осуществляется нажатием кнопки мыши на заголовке соответствующего столбца. Для изменения ширины столбца необходимо установить курсор на вертикальную границу, разделяющую заголовки столбцов, и перетащить ее влево или вправо.

В список включаются следующие сведения:

  • имя файла DWF
  • положение (загружена, выгружена или не найдена)
  • размер файла
  • тип файла
  • дата и время последнего сохранения
  • сохраненный путь

Если программе не удается обнаружить подложку, ее положение становится "Не найдена". Подложка со статусом "Не найдена" отображается на чертеже своими контурами, даже их показ в команде DWFFRAME отключен. Если на подложку нет ссылок, то ее экземпляры в чертеж не вставляются. Если подложка не загружена, ее положение становится "Выгружена". Подложки в положении "Выгружена" или "Не найдена" на чертеже не отображаются.

Работа с режимом древовидного представления

На верхнем уровне в режиме дерева файлы DWF перечисляются в алфавитном порядке. В большинстве случаев файл подложки связывается непосредственно с чертежом и упоминается на верхнем уровне. Однако, если внешняя ссылка или блок содержит вставленную подложку, отображаются дополнительные уровни.

Просмотр подробных сведений о файле DWF-подложки

Имеется возможность предварительного просмотра выбранной подложки и файла DWF и получения подробных данных о нем, среди которых:

  • имя
  • положение
  • размер файла
  • тип файла
  • дата создания файла
  • сохраненный путь
  • обнаружен в... (путь, по которому изображение найдено)
    ПримечаниеПараметр "Обнаружен в..." отключен, если выбрана вложенная ссылка.
  • Монохромное состояние


Просмотр сведений о DWF-подложке (Процедура)

Управление и публикация чертежей, содержащих DWF-подложки
На уровень вверх ..
Просмотр сведений о DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Просмотр сведений о DWF-подложке >
Просмотр сведений о DWF-подложке
Понятие Процедура Краткий справочник

Просмотр списка подложек DWF, вставленных в чертеж

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

Процедура просмотра состояния переопределения слоев подложки DWF


Просмотр списка подложек DWF, вставленных в чертеж (Процедура)

Просмотр сведений о DWF-подложке
На уровень вверх ..
Просмотр сведений о DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Просмотр сведений о DWF-подложке >
Просмотр сведений о DWF-подложке
Понятие Процедура Краткий справочник

Просмотр списка подложек DWF, вставленных в чертеж

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Вид".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку и нажмите правую кнопку мыши в области рисования. Выберите "Внешние ссылки".


Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки (Процедура)

Просмотр сведений о DWF-подложке
На уровень вверх ..
Просмотр сведений о DWF-подложке
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Просмотр сведений о DWF-подложке >
Просмотр сведений о DWF-подложке
Понятие Процедура Краткий справочник

Отображение имен подложек DWF и уровней их вложения во внешние ссылки и блоки

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Дерево".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Процедура просмотра состояния переопределения слоев подложки DWF (Процедура)

Просмотр сведений о DWF-подложке
На уровень вверх ..
Изменение путей к файлам DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Просмотр сведений о DWF-подложке >
Просмотр сведений о DWF-подложке
Понятие Процедура Краткий справочник

Процедура просмотра состояния переопределения слоев подложки DWF

  1. Выберите подложку DWF, для которой требуется просмотреть состояние переопределения слоев.
  2. Выберите пункт меню "Вставить" [image] "Свойства".
  3. На палитре свойств путем прокрутки перейдите к разделу "Разное" и просмотрите значение параметра "Переопределение отображения слоев", указывающее состояние отображения слоев.
Контекстное меню:Выберите подложку и нажмите правую кнопку мыши в области рисования. Нажмите "Свойства".
Ввод команды: ОКНОСВ


Просмотр сведений о DWF-подложке (Краткий справочник)

Показ и скрытие контуров DWF-подложки
Просмотр сведений о DWF-подложке
Изменение путей к файлам DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Просмотр сведений о DWF-подложке >
Просмотр сведений о DWF-подложке
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ДВФСЛОЙ

Управление отображением слоев в DWF или DWFx подложке

ОКНОСВ

Управление свойствами объектов

ДВФСЛОЙ

Управление отображением слоев в DWF или DWFx подложке

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение путей к файлам DWF-подложек (Понятие)

Просмотр сведений о DWF-подложке
Управление и публикация чертежей, содержащих DWF-подложки
Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки >
Изменение путей к файлам DWF-подложек
Понятие Процедура Краткий справочник

Имеется возможность изменения пути к файлу DWF, на который имеется ссылка, или поиска необнаруженной подложки DWF.

При открытии чертежа с вставленным файлом DWF путь к выбранной подложке DWF отображается в палитре "Внешние ссылки", в поле "Обнаружен в..." в списке "Подробности". Отображаемый путь - это фактическое местоположение файла DWF. В поле "Сохраненный путь" отображается путь, по которому находился файл DWF на момент вставки.

Для обнаружения файла DWF программа выполняет поиск путей и папок в следующей последовательности.

  • Путь, указанный при вставке подложки DWF
  • Папка, в которой хранится текущий чертеж
  • Стандартные пути поиска файлов проектов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Стандартные пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке программы

Если открыть чертеж, содержащий файл DWF, который не обнаружить ни по сохраненному пути, ни по одному из путей поиска, в столбце "Положение" списка "Вхождения файлов" палитры "Внешние ссылки" отображается "Не найдена", а поле "Обнаружен в..." списка "Подробности" остается незаполненным.

Можно удалить путь из имени файла или указать относительный путь путем ручного редактирования пути в поле "Обнаружен в..." или после нажатия кнопки [...] в правой части поля "Обнаружен в...". Последняя операция открывает диалоговое окно "Выбор DWF-файла".

Подробнее о работе с полными путями, относительными путями и именами проектов см. Задание путей к внешним чертежам .

Листы в DWF-подложках

Если файлы DWF используются в качестве подложек, появляется дополнительный ссылочный уровень, который отображается за именем файла DWF. Также указывается лист, который вставлен как подложка. При смене путей возможна ситуация, при которой подложка DWF будет считаться ненайденной, если новый путь, заданный для файла DWF, содержит не такое же имя листа, что и файл, на который происходила ссылка первоначально.


Изменение пути к подложке DWF (Процедура)

Просмотр сведений о DWF-подложке
На уровень вверх ..
Диспетчер ссылок и DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Изменение путей к файлам DWF-подложек >
Изменение путей к файлам DWF-подложек
Понятие Процедура Краткий справочник

Изменение пути к подложке DWF

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите подложку DWF, путь к которой требуется изменить. Нажмите кнопку [...] в правой части поля "Обнаружен в...".
  3. В диалоговом окне "Выбор DWF-файла" задайте новый путь. Нажмите "Открыть".

    Новый путь отображается в столбце "Сохраненный путь".

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку DWF и нажмите правую кнопку мыши в области рисования. Выберите "Внешние ссылки".


Изменение путей к файлам DWF-подложек (Краткий справочник)

Просмотр сведений о DWF-подложке
Изменение путей к файлам DWF-подложек
Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Изменение путей к файлам DWF-подложек >
Изменение путей к файлам DWF-подложек
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки (Понятие)

Изменение путей к файлам DWF-подложек
Управление и публикация чертежей, содержащих DWF-подложки
Диспетчер ссылок и DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки >
Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки
Понятие Краткий справочник

Файлы чертежей, содержащие вставки подложек DWF, можно выводить на печать или публиковать как файлы DWF. При формировании комплекта для электронной пересылки происходит отслеживание и управление файлами DWF. Более того, подложки DWF не будут потеряны при сохранении в формате чертежа прежних версий.

Печать и публикация

Если файл чертежа, содержащий вставленную подложку DWF, выводить на печать или публиковать в новый файл DWF, вся видимая геометрия DWF включается в новый отпечатанный или опубликованный файл DWF. Однако в новый файл DWF не будут опубликованы сведения о слоях, относящиеся к исходному файлу DWF, вставленному в чертеж.

Сохранение в формате DWG прежних версий

Если чертеж сохранен в формате DWG предыдущей версии, подложка DWF не будет отображаться при открытии чертежа в устаревшей версии программы, она не будет отображена и как объект-заместитель или прокси-контур. Если же открыть чертеж в текущей версии программы, подложка DWF появится на изображении снова.

Формирование комплекта

Отслеживание и управление вставками DWF при формировании комплекта для электронной пересылки происходит тем же образом, что и при работе с растровыми изображениями.


Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки (Краткий справочник)

Изменение путей к файлам DWF-подложек
Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки
Диспетчер ссылок и DWF-подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки >
Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки
Понятие Краткий справочник

Команды

3DДВФ

Создание 3D DWF или 3D DWFx-файла 3D модели и его открытие в окне DWF Viewer

ПУБЛ3DДВФ

Устар.

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Диспетчер ссылок и DWF-подложек (Понятие)

Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки
Управление и публикация чертежей, содержащих DWF-подложки
Использование файлов DWFx в качестве подложек на чертеже
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки >
Диспетчер ссылок и DWF-подложек
Понятие Процедура Краткий справочник

С помощью Диспетчера ссылок можно просматривать вхождения файлов, вставленных в файл DWF, и редактировать пути вставляемых файлов.

Диспетчер ссылок - это внешнее приложение, позволяющее проверять связи файла чертежа с другими файлами. Диспетчер ссылок отображает следующие свойства:

  • тип файла
  • положение
  • имя файла
  • имя
  • сохраненный путь
  • путь обнаружения
  • основной чертёж
  • основная версия

Имеется возможность просмотра списка ссылок, относящихся к чертежу, или списка ссылок одного типа.


Проверка подложек DWF с помощью Диспетчера ссылок (Процедура)

Изменение путей к файлам DWF-подложек
На уровень вверх ..
Использование файлов DWFx в качестве подложек на чертеже
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Диспетчер ссылок и DWF-подложек >
Диспетчер ссылок и DWF-подложек
Понятие Процедура Краткий справочник

Проверка подложек DWF с помощью Диспетчера ссылок

  1. Выберите в ОС Windows "Пуск" [image] "Все программы" ("Программы") [image] Autodesk [image] "AutoCAD 2009" [image] "Диспетчер ссылок".
  2. В окне "Диспетчер ссылок" нажмите кнопку "Добавить чертежи".
  3. В диалоговом окне "Добавление чертежей" выберите чертеж и нажмите кнопку "Открыть".


Диспетчер ссылок и DWF-подложек (Краткий справочник)

Публикация, сохранение и формирование комплекта чертежей, содержащих DWF-подложки
Диспетчер ссылок и DWF-подложек
Вставка файлов DWFx в качестве подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWF в качестве подложек на чертеже > Управление и публикация чертежей, содержащих DWF-подложки > Диспетчер ссылок и DWF-подложек >
Диспетчер ссылок и DWF-подложек
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование файлов DWFx в качестве подложек на чертеже

Диспетчер ссылок и DWF-подложек
Импорт, вставка и открытие файлов других форматов
Вставка и удаление подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Использование файлов DWFx в качестве подложек на чертеже
Понятие Процедура

Формат DWFx, разработанный на основе предложенного корпорацией Microsoft формата XML Paper Specification (XPS), в будущем заменит формат DWF.

Файл DWFx можно вставить в файл чертежа в качестве подложки. При вставке файла DWF создается ссылка на этот файл без увеличения размеров чертежа.

Темы в этом разделе

  • Вставка и удаление подложек DWFx

    Подложку DWFx (ссылку на файл DWFx) можно вставить в файл чертежа или удалить из него. Можно также изменять положение, масштаб и ориентацию подложек DWFx.

  • Работа со вставленными файлами подложек DWFx

    После вставки подложки DWFx можно изменить ее положение, масштаб или угол поворота, а также с помощью функции объектной привязки для DWFx задать расположение различных объектов относительно объектов подложки DWFx.

  • Изменение свойств отображения и подрезка подложки DWF

    В подложке DWFx предусмотрена возможность управления слоями, настройки внешнего вида и задания контуров подрезки.

  • Управление чертежами, содержащими подложки DWFx, и их публикация

    На палитре "Внешние ссылки" можно просматривать подложки DWFx, выполнять операции с ними и изменять пути к подложкам.


Использование файлов DWFx в качестве подложек на чертеже (Процедура)

Диспетчер ссылок и DWF-подложек
На уровень вверх ..
Вставка и удаление подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже >
Использование файлов DWFx в качестве подложек на чертеже
Понятие Процедура

Редактирование положения, масштаба или угла поворота подложки DWFx с палитры свойств

Изменение положения подложки DWFx с помощью базовой ручки


Вставка и удаление подложек DWFx

Использование файлов DWFx в качестве подложек на чертеже
Использование файлов DWFx в качестве подложек на чертеже
Вставка файлов DWFx в качестве подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже >
Вставка и удаление подложек DWFx
Понятие Процедура

Подложку DWFx (ссылку на файл DWFx) можно вставить в файл чертежа или удалить из него. Можно также изменять положение, масштаб и ориентацию подложек DWFx.

Темы в этом разделе

  • Вставка файлов DWFx в качестве подложек

    Файл DWFx можно вставить в файл чертежа в качестве подложки.

  • Удаление файлов подложек DWFx

    Подложки DWFx можно удалить из файла чертежа.


Вставка и удаление подложек DWFx (Процедура)

Использование файлов DWFx в качестве подложек на чертеже
На уровень вверх ..
Вставка файлов DWFx в качестве подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Вставка и удаление подложек DWFx >
Вставка и удаление подложек DWFx
Понятие Процедура

Процедура вставки подложки DWFx

Процедура удаления подложки DWFx


Вставка файлов DWFx в качестве подложек (Понятие)

Вставка и удаление подложек DWFx
Вставка и удаление подложек DWFx
Удаление файлов подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Вставка и удаление подложек DWFx >
Вставка файлов DWFx в качестве подложек
Понятие Процедура Краткий справочник

Файл DWFx можно вставить в файл чертежа в качестве подложки.

Создание ссылок на файлы подложек DWFx и их размещение в файлах чертежей выполняется так же, как и в случае файлов растровых изображений; однако фактически файлы DWFx не являются частью чертежа. Как и при работе с файлами растровых изображений, связь между подложкой DWFx и файлом чертежа устанавливается посредством задания пути. Связанные пути DWFx можно в любой момент изменить или удалить. Вставка подложек DWFx с помощью связанных путей к файлам DWFx позволяет использовать файлы DWFx в чертеже без существенного увеличения размера файла чертежа.

ПримечаниеХотя файлы подложек DWFx представляют собой результат воспроизведения соответствующих исходных чертежей, их точность ниже по сравнению с файлами чертежей. В подложках DWFx допускаются незначительные отклонения от точного воспроизведения.

Перетаскивание и вставка файлов подложек DWFx

Предусмотрена также возможность непосредственного перетаскивания подложек DWF в чертеж. При перетаскивании файла DWFx в чертеж отображается запрос на ввод имени листа из файла DWFx в командной строке. После этого требуется указать точку вставки, масштабный коэффициент и угол поворота.

После прикрепления подложки DWFx ее можно многократно вставлять повторно в качестве блока. Каждая подложка имеет собственную границу подрезки и отличающиеся от других вхождений значения контрастности, степени слияния с фоном и наличия цвета. Однако внедрить подложку в чертёж, а также внести изменения в содержимое чертежа подложки невозможно.

Слои в файлах подложек DWFx

Отображение диалогового окна "Слои DWFx" зависит от информации о слоях, опубликованных в файле DWF. При отсутствии информации о слоях диалоговое окно "Слои DWFx" не отображается. Кроме того, в командной строке отображается следующее сообщение.

Выбранная подложка DWFx не содержит сведений о слоях

Файлы подложек DWFx во внешних ссылках

При работе с чертежами, содержащими ссылки на файлы DWG (внешние ссылки), возможна ситуация, когда в одну из ссылок на файл DWG вставлена подложка DWFx. В этом случае геометрия DWFx отображается в исходном чертеже.

Пусть, например, чертеж А содержит подложку DWFx, на которой показаны некоторые особенности конструкции. Содержимое чертежа А требуется вставить в текущий чертеж Б. При вставке чертежа А в чертеж Б в качестве внешней ссылки отображается также подложка DWFx, ранее вставленная в чертеж А.

Все настройки свойств объектов, сделанные для подложки в ссылке в файле DWG, например границы подрезки, отображаются также, как в исходном чертеже.

Файлы подложек DWFx с защитой паролем

Если файл DWFx, который требуется вставить в качестве подложки, защищен паролем, после выбора этого файла отображается запрос на ввод пароля. Нельзя завершить процедуру вставки, пока пароль не будет введен правильно.

Если в файл DWG вставлена подложка DWFx, при открытии этого файла DWG отображается запрос на ввод пароля доступа к файлу DWFx. Если файл DWG также защищен паролем или в него вставлено несколько ссылок на разные защищенные чертежи, может запрашиваться несколько паролей.

При перенаправлении пути к подложке DWF на файл DWF, требующий ввода пароля, отображается запрос на ввод пароля.

СоветРегистр учитывается при вводе паролей DWFx, но не учитывается при вводе паролей DWG. Для упрощения согласования между паролями DWG и DWFx рекомендуется ввести пароль DWF, совпадающий с паролем DWG, но состоящий только из символов верхнего регистра.


Процедура вставки подложки DWFx (Процедура)

Вставка и удаление подложек DWFx
На уровень вверх ..
Удаление файлов подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Вставка и удаление подложек DWFx > Вставка файлов DWFx в качестве подложек >
Вставка файлов DWFx в качестве подложек
Понятие Процедура Краткий справочник

Процедура вставки подложки DWFx

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Ссылка" [image] DWF. В командной строке введите "двфвставить".
  2. В диалоговом окне "Выбор DWF-файла" перейдите к файлу DWFx, затем нажмите "Открыть".
  3. Если файл DWFx содержит несколько листов, в диалоговом окне "Вставка DWF-подложки" выберите лист для вставки.
  4. Воспользуйтесь одним из следующих способов для указания точки вставки, масштаба или угла поворота файла подложки:
    • Установите флажок "Указать на экране" и вставьте подложку DWF, задав местоположение, масштаб и угол поворота с помощью указательного устройства.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".
  5. Нажмите "ОК".
Панель:Вставка
Ввод команды: ДВФВСТАВИТЬ


Вставка файлов DWFx в качестве подложек (Краткий справочник)

Диспетчер ссылок и DWF-подложек
Вставка файлов DWFx в качестве подложек
Удаление файлов подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Вставка и удаление подложек DWFx > Вставка файлов DWFx в качестве подложек >
Вставка файлов DWFx в качестве подложек
Понятие Процедура Краткий справочник

Команды

ДВФРЕГУЛ

Позволяет выполнять настройку подложки DWF или DWFx из командной строки

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ОКНОСВ

Управление свойствами объектов

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

Системные переменные

DWFFRAME

Определение видимости контура подложки DWF или DWFx

DWFOSNAP

Определение активности привязки объекта для геометрии в подложках DWF или DWFx, прикрепленных к чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Удаление файлов подложек DWFx (Понятие)

Вставка файлов DWFx в качестве подложек
Вставка и удаление подложек DWFx
Работа со вставленными файлами подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Вставка и удаление подложек DWFx >
Удаление файлов подложек DWFx
Понятие Процедура Краткий справочник

Подложки DWFx можно удалить из файла чертежа.

Предусмотрена возможность удаления подложек DWFx, которые больше не используются на чертеже. При удалении подложки DWFx из чертежа удаляются все экземпляры подложки, выполняется очистка описания подложки и удаляется путь связи с файлом DWFx.

ПримечаниеСтирание отдельного экземпляра подложки DWFx не эквивалентно ее удалению. Подложку DWFx необходимо удалять для разрыва связи чертежа с файлом DWFx.


Процедура удаления подложки DWFx (Процедура)

Вставка файлов DWFx в качестве подложек
На уровень вверх ..
Работа со вставленными файлами подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Вставка и удаление подложек DWFx > Удаление файлов подложек DWFx >
Удаление файлов подложек DWFx
Понятие Процедура Краткий справочник

Процедура удаления подложки DWFx

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите на панели "Вхождения файлов" подложку DWFx, которую требуется удалить.
  3. Щелкните на подложке DWFx правой кнопкой мыши и выберите "Удалить".

    Теперь подложка DWFx не связана с файлом чертежа. Все экземпляры подложки удаляются из чертежа.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку DWFx и щелкните в области рисования правой кнопкой мыши. Выберите палитру "Внешние ссылки".


Удаление файлов подложек DWFx (Краткий справочник)

Вставка файлов DWFx в качестве подложек
Удаление файлов подложек DWFx
Работа со вставленными файлами подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Вставка и удаление подложек DWFx > Удаление файлов подложек DWFx >
Удаление файлов подложек DWFx
Понятие Процедура Краткий справочник

Команды

ДВФРЕГУЛ

Позволяет выполнять настройку подложки DWF или DWFx из командной строки

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ОКНОСВ

Управление свойствами объектов

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

Системные переменные

DWFFRAME

Определение видимости контура подложки DWF или DWFx

DWFOSNAP

Определение активности привязки объекта для геометрии в подложках DWF или DWFx, прикрепленных к чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа со вставленными файлами подложек DWFx (Понятие)

Удаление файлов подложек DWFx
Использование файлов DWFx в качестве подложек на чертеже
Изменение свойств отображения и подрезка подложки DWF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже >
Работа со вставленными файлами подложек DWFx
Понятие Процедура Краткий справочник

После вставки подложки DWFx можно изменить ее положение, масштаб или угол поворота, а также с помощью функции объектной привязки для DWFx задать расположение различных объектов относительно объектов подложки DWFx.

Хотя точку вставки, масштабный коэффициент и угол поворота можно указать в момент вставки файла DWFx, в процессе работы над чертежом может потребоваться изменить значения этих параметров. По умолчанию точка вставки файла DWFx имеет координаты (0,0,0), масштабный коэффициент равен 1, а угол поворота - 0.

Поскольку вставленная подложка DWF функционирует аналогично вставленному растровому изображению, к ней можно применять обычные команды редактирования - перемещение, масштабирование, поворот, симметричное отражение, создание массива и т.п. Для внесения изменений можно также выбрать подложку DWFx, а затем требуемую команду в контекстном меню или на палитре свойств.

СоветПри двойном щелчке на подложке DWFx открывается палитра свойств для данной подложки.

Функция объектной привязки применительно к подложкам DWFx

Привязка к объектам DWFx функционирует аналогично обычной объектной привязке, с тем отличием, что ее можно включить или отключить отдельно от обычной объектной привязки и что она применяется только к объектам во вставленном файле DWF.

Привязка к объектам DWFx применяется в том случае, если требуется вычерчивание или редактирование различных объектов относительно тех объектов, которые отображаются на одной или нескольких вставленных подложках DWFx. Привязка объекта к геометрическим объектам подложки DWFx не отличается от привязки объекта к геометрическим объектам файлов DWG. Объектная привязка для подложек DWFx включается и отключается с помощью системной переменной DWFOSNAPDWFOSNAP.

Функцию объектной привязки для DWFx можно также включить или отключить с помощью контекстного меню. Выберите файл подложки DWF, затем щелкните правой кнопкой мыши. В контекстном меню выберите "Объектная привязка для DWFx".

Ручки подложек DWFx

Подложки DWFx по своим функциям аналогичны растровым изображениям, однако существует различие, касающееся работы ручек. В данном случае режим ближе к принятому для блоков.

Как правило, для подложек DWFx отображается только базовая ручка. Базовая ручка используется для изменения положения подложки на чертеже. Если настроен контур подрезки, для каждого угла контура отображаются дополнительные ручки. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Изменение свойств отображения и подрезки DWF-подложки .

Ручка базовой точки выглядит аналогично базовой точке стандартного блока. Положение базовой точки невозможно изменить из основного файла DWG; она определяется при публикации файла DWFx по началу координат исходного файла DWG. Если для существующего (унаследованного) файла DWFx базовая точка не определена, в качестве базовой точки (0,0,0) используется левый нижний угол.


Работа со вставленными файлами подложек DWFx (Процедура)

Удаление файлов подложек DWFx
На уровень вверх ..
Работа со вставленными файлами подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Работа со вставленными файлами подложек DWFx >
Работа со вставленными файлами подложек DWFx
Понятие Процедура Краткий справочник

Редактирование положения, масштаба или угла поворота подложки DWFx с палитры свойств

Изменение положения подложки DWFx с помощью базовой ручки


Редактирование положения, масштаба или угла поворота подложки DWFx с палитры свойств (Процедура)

Работа со вставленными файлами подложек DWFx
На уровень вверх ..
Работа со вставленными файлами подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Работа со вставленными файлами подложек DWFx >
Работа со вставленными файлами подложек DWFx
Понятие Процедура Краткий справочник

Редактирование положения, масштаба или угла поворота подложки DWFx с палитры свойств

  1. На видовом экране чертежа дважды щелкните на подложке DWFx, которую требуется отредактировать.
  2. На палитре свойств выведите на экран группу "Геометрия" и выполните одну из следующих операций:
    • Для изменения положения подложки DWFx измените значения параметров "Положение по X", "Положение по Y" или "Положение по Z".
    • Для изменения масштаба, ширины или высоты подложки DWF измените значения параметров "Масштаб", "Ширина" и "Высота".
    • Для изменения угла поворота подложки DWFx измените значение параметра "Поворот".


Изменение положения подложки DWFx с помощью базовой ручки (Процедура)

Работа со вставленными файлами подложек DWFx
На уровень вверх ..
Изменение свойств отображения и подрезка подложки DWF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Работа со вставленными файлами подложек DWFx >
Работа со вставленными файлами подложек DWFx
Понятие Процедура Краткий справочник

Изменение положения подложки DWFx с помощью базовой ручки

  1. Щелкните на контуре вставленной подложки DWFx.
  2. Для изменения положения подложки DWFx щелкните на базовой ручке.
  3. Перетащите курсор в новое местоположение и щелкните еще раз для размещения подложки DWFx.


Работа со вставленными файлами подложек DWFx (Краткий справочник)

Удаление файлов подложек DWFx
Работа со вставленными файлами подложек DWFx
Управление отображением слоев в подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Работа со вставленными файлами подложек DWFx >
Работа со вставленными файлами подложек DWFx
Понятие Процедура Краткий справочник

Команды

ДВФВСТАВИТЬ

Вставка подложки DWF или DWFx в текущий чертеж

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

ДВФСЛОЙ

Управление отображением слоев в DWF или DWFx подложке

Системные переменные

DWFOSNAP

Определение активности привязки объекта для геометрии в подложках DWF или DWFx, прикрепленных к чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение свойств отображения и подрезка подложки DWF

Работа со вставленными файлами подложек DWFx
Использование файлов DWFx в качестве подложек на чертеже
Управление отображением слоев в подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже >
Изменение свойств отображения и подрезка подложки DWF
Понятие Процедура

В подложке DWFx предусмотрена возможность управления слоями, настройки внешнего вида и задания контуров подрезки.

Темы в этом разделе

  • Управление отображением слоев в подложке DWFx

    В подложке DWFx можно включать и отключать слои.

  • Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx

    С помощью палитры свойств можно не только отредактировать положение, масштаб и угла поворота подложки DWFx, но и изменить для нее контрастность, степень слияния с фоном, монохромный режим и цвета фона.

  • Подрезка подложек DWFx

    Для подрезки изображения подложки DWFx на чертеже можно использовать прямоугольный или многоугольный контур подрезки.

  • Отображение и скрытие контуров подложки DWFx

    Предусмотрена возможность управления видимостью контура, представляющего границы подложки DWF, а также видимостью контура подрезки.


Изменение свойств отображения и подрезка подложки DWF (Процедура)

Работа со вставленными файлами подложек DWFx
На уровень вверх ..
Управление отображением слоев в подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF >
Изменение свойств отображения и подрезка подложки DWF
Понятие Процедура

Процедура включения и отключения слоев подложки DWFx

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWFx с помощью палитры свойств

Настройка параметров слияния с фоном, контрастности и монохромного режима для подложки DWFx с помощью команды "ДВФРЕГУЛ"

Подрезка подложки DWFx

Задание нового контура для подрезанной подложки DWFx

Редактирование существующего контура подрезанной подложки DWFx

Отображение или скрытие подрезанной части подложки DWFx

Удаление контура подрезанной подложки DWFx

Отображение и скрытие контуров подложек DWFx


Управление отображением слоев в подложке DWFx (Понятие)

Изменение свойств отображения и подрезка подложки DWF
Изменение свойств отображения и подрезка подложки DWF
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF >
Управление отображением слоев в подложке DWFx
Понятие Процедура Краткий справочник

В подложке DWFx можно включать и отключать слои.

По умолчанию во вставленной подложке DWFx включены все слои. Как правило, при работе с подложками DWFx во избежание чрезмерной сложности изображения требуется отключить неиспользуемые слои.

Воспользуйтесь командой ДВФСЛОЙ или выберите "Слои DWF" в контекстном меню, отображаемом при щелчке на выбранной подложке DWFx правой кнопкой мыши.

ПримечаниеФайл DWFx можно опубликовать без информации о слоях. Если подложка DWFx не содержит слоев, диалоговое окно "Слои DWF" отображается без данных.

С помощью палитры свойств можно определить, отключены ли какие-либо слои подложки DWFx.

  • При отсутствии отключенных слоев для свойства "Переопределение отображения слоев" задано значение "Нет".
  • Если хотя бы один слой отключен, для свойства "Переопределение отображения слоев" задано значение "Применяется".


Процедура включения и отключения слоев подложки DWFx (Процедура)

Изменение свойств отображения и подрезка подложки DWF
На уровень вверх ..
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Управление отображением слоев в подложке DWFx >
Управление отображением слоев в подложке DWFx
Понятие Процедура Краткий справочник

Процедура включения и отключения слоев подложки DWFx

  1. Выберите подложку DWFx, щелкнув на ограничивающей ее рамке.
  2. Щелкните на подложке DWF правой кнопкой мыши. В контекстном меню выберите "Слои DWF".

    Отображается диалоговое окно "Слои DWF".

  3. Щелкните на значке лампочки рядом с именем слоя, который требуется включить или отключить.

    Для выбора нескольких слоев следует во время щелчка удерживать нажатой клавишу CTRL или SHIFT.

  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Ввод команды: ДВФСЛОЙ


Управление отображением слоев в подложке DWFx (Краткий справочник)

Работа со вставленными файлами подложек DWFx
Управление отображением слоев в подложке DWFx
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Управление отображением слоев в подложке DWFx >
Управление отображением слоев в подложке DWFx
Понятие Процедура Краткий справочник

Команды

ДВФСЛОЙ

Управление отображением слоев в DWF или DWFx подложке

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx (Понятие)

Управление отображением слоев в подложке DWFx
Изменение свойств отображения и подрезка подложки DWF
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF >
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Понятие Процедура Краткий справочник

С помощью палитры свойств можно не только отредактировать положение, масштаб и угла поворота подложки DWFx, но и изменить для нее контрастность, степень слияния с фоном, монохромный режим и цвета фона.

Можно также настроить параметры контрастности, слияния с фоном, монохромного режима и цвета для вывода на печать, не изменяя исходный файл DWFx и другие экземпляры подложки DWFx на чертеже.

Изменения контрастности, степени слияния с фоном, монохромного режима и цветов вносятся в области "Регулировка DWFx" на палитре свойств при выбранной подложке DWFx.

ПримечаниеНастройка цветопередачи возможна только при работе с визуальным стилем "2D каркас".

Контрастность

Параметр "Контрастность" определяет внешний вид самой тусклой рабочей линии, присутствующей в подложке DWFx; действует совместно с параметром "Слияние с фоном". Если для параметра "Контрастность" задано значение 100, все контурные изображения соответствуют интенсивности значения параметра "Слияние с фоном". Если значение контрастности равно 20, интенсивность самых тусклых линий уменьшается на 20 процентов от значения параметра "Слияние с фоном".

Слияние с фоном

Параметр "Слияние с фоном" определяет насколько светлыми или темными отображаются линии. Высокие значения обеспечивают светлые линии; и наоборот, низкие значения параметра слияния с фоном приводят к отображению темных линий.

Монохромный

Параметр "Монохромный" используется для управления насыщенностью цвета всех контурных изображений, одновременно обеспечивая яркость. При его включении контурные изображения отображаются разными оттенками серого цвета, начиная от черного, если яркость цвета фона составляет 50% или выше. Если яркость цвета фона ниже 50%, происходит инверсия цветов, так что самая темная линия контура отображается белым цветом, а самая светлая - черным. Такая инверсия используется для отображения подложки на экране, но для печати осуществляется возврат в исходное состояние.

Регулировка цвета заднего плана

Параметр "Регулировка цвета заднего плана" определяет видимость цветов подложки DWF через цвет фона чертежа. Значение по умолчанию "Да" указывает на то, что выполняется анализ цветов фона подложки DWFx, позволяющий определить, являются ли оба фона светлыми, оба фона темными или один темным, а другой светлым. Если один фон является светлым, а другой темным, выполняется обращение цветов подложки DWFx, обеспечивающее видимость подложки. При изменении значения параметра на "Нет", используется исходные цвета подложки. В зависимости от цветов фона подложка DWFx может быть невидимой.


Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx (Процедура)

Управление отображением слоев в подложке DWFx
На уровень вверх ..
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx >
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Понятие Процедура Краткий справочник

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWFx с помощью палитры свойств

Настройка параметров слияния с фоном, контрастности и монохромного режима для подложки DWFx с помощью команды "ДВФРЕГУЛ"


Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWFx с помощью палитры свойств (Процедура)

Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
На уровень вверх ..
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx >
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Понятие Процедура Краткий справочник

Процедура настройки параметров контрастности, слияния с фоном, монохромного режима и цвета фона для подложки DWFx с помощью палитры свойств

  1. Выберите подложку DWFx, параметры которой требуется настроить.
  2. Выберите пункт меню "Редактирование" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре свойств подложки DWF выполните одно из следующих действий.
    • Отрегулируйте контрастность, вводя новое значение.

      Значение по умолчанию для контрастности - 25 на шкале от 0 (низкая) до 100 (высокая).

    • Отрегулируйте степень слияния с фоном, вводя новое значение.

      Значение по умолчанию для слияния с фоном - 25 на шкале от 0 (темное) до 80 (светлое).

    • Включите или отключите параметр "Монохромный".

      Значением по умолчанию для параметра "Монохромный" является "Откл".

    • Задайте для параметра "Регулировка цвета заднего плана" значение "Да" или "Нет".

      По умолчанию значение параметра "Регулировка цвета заднего плана" - "Да".

Обновление внешнего вида подложки DWF выполняется в реальном времени, одновременно с корректировкой значений параметров на палитре свойств.

Контекстное меню:Щелкните на каком-либо объекте подложки DWFx правой кнопкой мыши. Нажмите кнопку "Свойства".


Настройка параметров слияния с фоном, контрастности и монохромного режима для подложки DWFx с помощью команды "ДВФРЕГУЛ" (Процедура)

Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
На уровень вверх ..
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx >
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Понятие Процедура Краткий справочник

Настройка параметров слияния с фоном, контрастности и монохромного режима для подложки DWFx с помощью команды "ДВФРЕГУЛ"

  1. В командной строке введите "ДВФРЕГУЛ".
  2. Выберите рамку, ограничивающую подложку DWFx, и нажмите клавишу ENTER.
  3. С помощью меню "Ввод параметров подложки DWFx" выберите значение одного из указанных ниже параметров.
    • Выберите "Слияние с фоном" и введите значение слияния с фоном.

      Значение по умолчанию для слияния с фоном - 25 на шкале от 0 (темное) до 80 (светлое).

    • Выберите "Контрастность" и введите значение контрастности.

      Значение по умолчанию для контрастности равно 75 по шкале от 0 (низкая) до 100 (высокая).

    • Выберите "Монохромный" и задайте для этого параметра значение "Да" или "Нет".

      По умолчанию для параметра "Монохромный" задано значение "Нет".

После ввода нового значения и завершения выполнения команды внешний вид подложки DWFx обновляется.


Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx (Краткий справочник)

Управление отображением слоев в подложке DWFx
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx >
Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Понятие Процедура Краткий справочник

Команды

ДВФРЕГУЛ

Позволяет выполнять настройку подложки DWF или DWFx из командной строки

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подрезка подложек DWFx (Понятие)

Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Изменение свойств отображения и подрезка подложки DWF
Отображение и скрытие контуров подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Для подрезки изображения подложки DWFx на чертеже можно использовать прямоугольный или многоугольный контур подрезки.

Можно определить часть подложки DWFx, которую требуется отображать и выводить на печать, путем задания контура подрезки. Дополнительным преимуществом от задания контура подрезки является увеличение скорости перерисовки за счет выделения только частей подложки, которые должны быть видимыми.

Контуром подрезки может служить прямоугольник или двумерный (2D) многоугольник, вершины которого лежат внутри границ подложки.

Для каждого экземпляра подложки DWFx допускается только один контур подрезки. Разные экземпляры одной и той же подложки могут иметь разные контуры. Контур подрезанной подложки можно изменить в любой момент.

Подрезанную подложку можно отображать с использованием контура подрезки или можно его скрыть, чтобы отображать подложку в её исходных границах.

Если контур подрезки более не нужен, его можно удалить из подложки. После удаления контура подрезки подложка отображается в своих исходных границах.

На следующем рисунке показан пример подложки DWFx; на вкладках изображены контуры подрезки - многоугольный (м) и прямоугольный (п).


Подрезка подложек DWFx (Процедура)

Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
На уровень вверх ..
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Подрезка подложек DWFx >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Подрезка подложки DWFx

Задание нового контура для подрезанной подложки DWFx

Редактирование существующего контура подрезанной подложки DWFx

Отображение или скрытие подрезанной части подложки DWFx

Удаление контура подрезанной подложки DWFx


Подрезка подложки DWFx (Процедура)

Подрезка подложек DWFx
На уровень вверх ..
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Подрезка подложек DWFx >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Подрезка подложки DWFx

  1. Выберите подложку DWFx, щелкнув на ограничивающей ее рамке.
  2. Щелкните на подложке DWF правой кнопкой мыши. Выберите "Подрезка DWF...".
  3. В командной строке введите н (Новый контур).
  4. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    Задание многоугольного контура производится последовательным указанием его вершин.

    Для завершения построения многоугольника нажмите клавишу ENTER или щелкните в любой точке области рисования правой кнопкой мыши.

Контекстное меню:Щелкните на каком-либо объекте подложки DWFx правой кнопкой мыши. Выберите "Подрезка DWF...".
Ввод команды: ДВФРЕЗ


Задание нового контура для подрезанной подложки DWFx (Процедура)

Подрезка подложек DWFx
На уровень вверх ..
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Подрезка подложек DWFx >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Задание нового контура для подрезанной подложки DWFx

  1. Выберите подложку DWFx, щелкнув на ограничивающей ее рамке.
  2. Щелкните на подложке DWF правой кнопкой мыши. Выберите "Подрезка DWF...".
  3. В командной строке введите н (Новый контур).
  4. Введите н (Нет) или д (Да) в ответ на запрос об удалении старого контура.
  5. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

    Контуры подрезки могут редактироваться с помощью ручек. См. раздел Редактирование с помощью ручек.

Контекстное меню:Щелкните на подрезанной подложке DWFx правой кнопкой мыши. Выберите "Подрезка DWFx".
Ввод команды: ДВФРЕЗ


Редактирование существующего контура подрезанной подложки DWFx (Процедура)

Подрезка подложек DWFx
На уровень вверх ..
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Подрезка подложек DWFx >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Редактирование существующего контура подрезанной подложки DWFx

  1. Выберите подрезанную подложку DWFx.
  2. Нажмите одну из угловых ручек и перетащите ее в новое положение.
  3. Нажмите кнопку мыши повторно для установки угловой ручки.
Контекстное меню:После выбора подрезанной подложки DWF щелкните правой кнопкой мыши. Выберите "Подрезка DWF...".
Ввод команды: ДВФРЕЗ


Отображение или скрытие подрезанной части подложки DWFx (Процедура)

Подрезка подложек DWFx
На уровень вверх ..
Подрезка подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Подрезка подложек DWFx >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Отображение или скрытие подрезанной части подложки DWFx

  1. Выберите подрезанную подложку DWFx, часть которой требуется показать или скрыть.
  2. Нажмите правую кнопку мыши и выберите "Свойства".
  3. Осуществите прокрутку до группы "Прочие" и выберите "Да" или "Нет" для параметра "Показ подрезанного".
Контекстное меню:После выбора подрезанной подложки DWF щелкните правой кнопкой мыши. Нажмите кнопку "Свойства".
Ввод команды: ОКНОСВ


Удаление контура подрезанной подложки DWFx (Процедура)

Подрезка подложек DWFx
На уровень вверх ..
Отображение и скрытие контуров подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Подрезка подложек DWFx >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Удаление контура подрезанной подложки DWFx

  1. Выберите подрезанную подложку DWFx.
  2. Нажмите правую кнопку мыши и выберите "Подрезка DWF...".
  3. Нажмите кнопку "Удалить".

    Контур подрезанной подложки удаляется, и восстанавливается исходный контур подложки.

Контекстное меню:Щелкните на подрезанной подложке DWFx правой кнопкой мыши. Выберите "Подрезка DWF...".
Ввод команды: ДВФРЕЗ


Подрезка подложек DWFx (Краткий справочник)

Регулировка контрастности, степени слияния с фоном, монохромного режима и цветов фона для подложки DWFx
Подрезка подложек DWFx
Отображение и скрытие контуров подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Подрезка подложек DWFx >
Подрезка подложек DWFx
Понятие Процедура Краткий справочник

Команды

ДВФРЕЗ

Определение подобласти подложки DWF или DWFx с помощью секущих контуров

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Отображение и скрытие контуров подложки DWFx (Понятие)

Подрезка подложек DWFx
Изменение свойств отображения и подрезка подложки DWF
Управление чертежами, содержащими подложки DWFx, и их публикация
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF >
Отображение и скрытие контуров подложки DWFx
Понятие Процедура Краткий справочник

Предусмотрена возможность управления видимостью контура, представляющего границы подложки DWF, а также видимостью контура подрезки.

Можно скрыть контуры подложки DWFx. Контур представляет собой визуальную границу подложки DWFx или контур подрезки подложки DWFx. Скрытие контура подложки предотвращает печать границы или ее представление на экране. Тем не менее, при невидимом контуре можно выбрать подложку с помощью устройства указания. Подложки DWFx можно выбрать в том случае, если они не находятся в заблокированном слое, например, если подложка является частью именованного набора объектов, выбранных с использованием параметра "Все". Если контуры подложки скрыты, подрезанные подложки все же отображаются в заданных для них пределах; операция относится только к контуру. Включение и отключение отображения контуров подложки относится ко всем подложкам, вставленным в чертеж.

Ниже приведен пример переднего плана, на котором показана подложка DWFx с видимым контуром DWFx.

На примере переднего плана показана подложка DWFx с видимым контуром DWFx.


Отображение и скрытие контуров подложек DWFx (Процедура)

Подрезка подложек DWFx
На уровень вверх ..
Управление чертежами, содержащими подложки DWFx, и их публикация
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Отображение и скрытие контуров подложки DWFx >
Отображение и скрытие контуров подложки DWFx
Понятие Процедура Краткий справочник

Отображение и скрытие контуров подложек DWFx

  1. В командной строке введите двфконтур.
  2. На запрос в командной строке произведите одну из следующих операций:
    • Для скрытия контуров подложек DWFx введите 0.
    • Для отображения контуров подложек DWFx и вывода их на печать введите1.
    • Для отображения контуров подложек DWFx без вывода на печать введите2.
Ввод команды: DWFFRAME


Отображение и скрытие контуров подложки DWFx (Краткий справочник)

Подрезка подложек DWFx
Отображение и скрытие контуров подложки DWFx
Просмотр сведений о подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Изменение свойств отображения и подрезка подложки DWF > Отображение и скрытие контуров подложки DWFx >
Отображение и скрытие контуров подложки DWFx
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

DWFFRAME

Определение видимости контура подложки DWF или DWFx

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление чертежами, содержащими подложки DWFx, и их публикация

Отображение и скрытие контуров подложки DWFx
Использование файлов DWFx в качестве подложек на чертеже
Просмотр сведений о подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже >
Управление чертежами, содержащими подложки DWFx, и их публикация
Понятие Процедура

На палитре "Внешние ссылки" можно просматривать подложки DWFx, выполнять операции с ними и изменять пути к подложкам.

Темы в этом разделе

  • Просмотр сведений о подложке DWFx

    На палитре "Внешние ссылки" можно просматривать относящуюся к файлам информацию о подложках DWFx, вставленных в чертеж. Также имеется возможность загружать и выгружать подложки и производить иные операции.

  • Изменение путей к файлам подложек DWFx

    Предусмотрена возможность изменения пути к файлу DWFx, на который существует ссылка, а также поиска подложки DWFx, для которой отображается состояние "Не найдена".

  • Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx

    Файлы чертежей, содержащие вставленные подложки DWFx, можно выводить на печать или публиковать как файлы DWFx. При работе с функцией формирования комплектов выполняются операции отслеживания подложек DWFx и управления ими. Кроме того, при сохранении в форматах чертежей предыдущих версий подложки DWFx не утрачиваются.

  • Диспетчер ссылок и подложки DWFx

    С помощью Диспетчера ссылок можно просматривать вхождения файлов, вставленных в файл DWF, и редактировать пути вставляемых файлов.


Управление чертежами, содержащими подложки DWFx, и их публикация (Процедура)

Отображение и скрытие контуров подложки DWFx
На уровень вверх ..
Просмотр сведений о подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация >
Управление чертежами, содержащими подложки DWFx, и их публикация
Понятие Процедура

Отображение списка подложек DWFx, вставленных в чертеж

Отображение имен подложек DWFx и уровней их вложения во внешние ссылки и блоки

Отображение состояния переопределения слоев подложки DWFx

Изменение пути к подложке DWFx

Проверка подложек DWFx с помощью диспетчера ссылок


Просмотр сведений о подложке DWFx (Понятие)

Управление чертежами, содержащими подложки DWFx, и их публикация
Управление чертежами, содержащими подложки DWFx, и их публикация
Изменение путей к файлам подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация >
Просмотр сведений о подложке DWFx
Понятие Процедура Краткий справочник

На палитре "Внешние ссылки" можно просматривать относящуюся к файлам информацию о подложках DWFx, вставленных в чертеж. Также имеется возможность загружать и выгружать подложки и производить иные операции.

На палитре "Внешние ссылки" можно просматривать сведения о подложке или в виде списка, или в режиме древовидного представления. Способ отображения информации на палитре "Внешние ссылки" выбирается кнопками "Список" или "Дерево" в верхнем правом углу. В режиме списка для каждой подложки на чертеже отображаются имя, статус ее загрузки, размер файла, дата последнего изменения и путь поиска файла. В режиме просмотра дерева подложки представлены в рамках иерархической структуры, отображающей уровень их вложенности во внешние ссылки и блоки. Сведения о статусе, размере и т.д. не выводятся.

В обоих режимах можно отобразить информацию о подложке; вставить или удалить подложку; выгрузить или обновить подложку; выбрать и сохранить новый путь поиска.

Работа с режимом списка

В режиме просмотра списка отображаются все подложки, вставленные в текущий чертеж, но нет никакой информации о количестве экземпляров. Этот режим установлен по умолчанию. Сортировка подложек по категориям осуществляется нажатием кнопки мыши на заголовке соответствующего столбца. Для изменения ширины столбца необходимо установить курсор на вертикальную границу, разделяющую заголовки столбцов, и перетащить ее влево или вправо.

В список включаются следующие сведения:

  • имя файла DWFx
  • положение (загружено, выгружено или не найдено)
  • размер файла
  • тип файла
  • дата и время последнего сохранения
  • сохраненный путь

Если программе не удается обнаружить подложку, ее положение становится "Не найдена". Подложка со статусом "Не найдена" отображается на чертеже своими контурами, даже их показ в команде DWFFRAME отключен. Если на подложку нет ссылок, то ее экземпляры в чертеж не вставляются. Если подложка не загружена, ее положение становится "Выгружена". Подложки в положении "Выгружена" или "Не найдена" на чертеже не отображаются.

Работа с древовидной структурой представления

На верхнем уровне древовидного представления файлы DWFx представлены в алфавитном порядке. В большинстве случаев файл подложки связывается непосредственно с чертежом и упоминается на верхнем уровне. Однако, если внешняя ссылка или блок содержит вставленную подложку, отображаются дополнительные уровни.

Просмотр подробных сведений о файле подложки DWFx

При предварительном просмотре выбранной подложки отображаются следующие сведения о файле DWFx:

  • имя
  • положение
  • размер файла
  • тип файла
  • дата создания файла
  • сохраненный путь
  • обнаружен в... (путь, по которому изображение найдено)
    ПримечаниеПараметр "Обнаружен в..." отключен, если выбрана вложенная ссылка.
  • Монохромное состояние


Просмотр сведений о подложке DWFx (Процедура)

Управление чертежами, содержащими подложки DWFx, и их публикация
На уровень вверх ..
Просмотр сведений о подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Просмотр сведений о подложке DWFx >
Просмотр сведений о подложке DWFx
Понятие Процедура Краткий справочник

Отображение списка подложек DWFx, вставленных в чертеж

Отображение имен подложек DWFx и уровней их вложения во внешние ссылки и блоки

Отображение состояния переопределения слоев подложки DWFx


Отображение списка подложек DWFx, вставленных в чертеж (Процедура)

Просмотр сведений о подложке DWFx
На уровень вверх ..
Просмотр сведений о подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Просмотр сведений о подложке DWFx >
Просмотр сведений о подложке DWFx
Понятие Процедура Краткий справочник

Отображение списка подложек DWFx, вставленных в чертеж

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Вид".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку и нажмите правую кнопку мыши в области чертежа. Выберите "Внешние ссылки".


Отображение имен подложек DWFx и уровней их вложения во внешние ссылки и блоки (Процедура)

Просмотр сведений о подложке DWFx
На уровень вверх ..
Просмотр сведений о подложке DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Просмотр сведений о подложке DWFx >
Просмотр сведений о подложке DWFx
Понятие Процедура Краткий справочник

Отображение имен подложек DWFx и уровней их вложения во внешние ссылки и блоки

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Дерево".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Отображение состояния переопределения слоев подложки DWFx (Процедура)

Просмотр сведений о подложке DWFx
На уровень вверх ..
Изменение путей к файлам подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Просмотр сведений о подложке DWFx >
Просмотр сведений о подложке DWFx
Понятие Процедура Краткий справочник

Отображение состояния переопределения слоев подложки DWFx

  1. Выберите подложку DWFx, щелкнув на границе ее области.
  2. Щелкните на подложке DWF правой кнопкой мыши. Нажмите кнопку "Свойства".
  3. На палитре свойств путем прокрутки перейдите к разделу "Разное" и просмотрите значение параметра "Переопределение отображения слоев", указывающее состояние отображения слоев.
Контекстное меню:Выберите подложку и нажмите правую кнопку мыши в области рисования. Нажмите "Свойства".
Ввод команды: ОКНОСВ


Просмотр сведений о подложке DWFx (Краткий справочник)

Отображение и скрытие контуров подложки DWFx
Просмотр сведений о подложке DWFx
Изменение путей к файлам подложек DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Просмотр сведений о подложке DWFx >
Просмотр сведений о подложке DWFx
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ДВФВСТАВИТЬ

Вставка подложки DWF или DWFx в текущий чертеж

ОКНОСВ

Управление свойствами объектов

ДВФСЛОЙ

Управление отображением слоев в DWF или DWFx подложке

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение путей к файлам подложек DWFx (Понятие)

Просмотр сведений о подложке DWFx
Управление чертежами, содержащими подложки DWFx, и их публикация
Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация >
Изменение путей к файлам подложек DWFx
Понятие Процедура Краткий справочник

Предусмотрена возможность изменения пути к файлу DWFx, на который существует ссылка, а также поиска подложки DWFx, для которой отображается состояние "Не найдена".

При открытии чертежа с вставленным файлом DWFx путь к выбранной подложке DWFx отображается на палитре "Внешние ссылки" в поле "Найден в" (в списке "Сведения"). Отображаемый путь соответствуют фактическому местоположению файла DWFx. В поле "Сохраненный путь" отображается путь, соответствующий местоположению файла DWFx на момент вставки.

Для обнаружения файла DWFx в AutoCAD выполняется поиск по путям и папкам в следующем порядке.

  • Путь, указанный при вставке подложки DWFx
  • Папка, в которой хранится текущий чертеж
  • Стандартные пути поиска файлов проектов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Стандартные пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке программы

Если открыть чертеж, содержащий файл DWFx, местоположение которого не соответствует ни сохраненному пути, ни какому-либо из заданных путей поиска, на палитре "Внешние ссылки" в столбце "Статус" списка "Вхождение файлов" отображается значение "Не найдена", а в списке "Подробности" поле "Найден в" не заполнено.

Можно удалить путь из имени файла или указать относительный путь путем ручного редактирования пути в поле "Обнаружен в..." или после нажатия кнопки [...] в правой части поля "Обнаружен в...". В последнем случае отображается диалоговое окно "Выбор файла DWFx".

Подробнее о работе с полными путями, относительными путями и именами проектов см. Задание путей к внешним чертежам .

Листы в подложках DWFx

Для файлов DWFx, используемых в качестве подложек, предусмотрен дополнительный уровень ссылок, который отображается за именем файла DWFx. Также указывается лист, который вставлен как подложка. При изменении путей для подложки DWFx может отображаться состояние "Не найдена"; эта ситуация возникает в том случае, если файл DWFx, соответствующий новому пути, не содержит лист с тем же именем, что и файл, соответствующий прежнему пути.


Изменение пути к подложке DWFx (Процедура)

Просмотр сведений о подложке DWFx
На уровень вверх ..
Диспетчер ссылок и подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Изменение путей к файлам подложек DWFx >
Изменение путей к файлам подложек DWFx
Понятие Процедура Краткий справочник

Изменение пути к подложке DWFx

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите подложку DWFx, путь к которой требуется изменить. Нажмите кнопку "Обзор" [...] справа от поля "Найдено в".
  3. Выберите новый путь. Нажмите "Открыть".

    Новый путь отображается в столбце "Сохраненный путь".

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку DWFx и щелкните в области рисования правой кнопкой мыши. Выберите "Внешние ссылки".


Изменение путей к файлам подложек DWFx (Краткий справочник)

Просмотр сведений о подложке DWFx
Изменение путей к файлам подложек DWFx
Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Изменение путей к файлам подложек DWFx >
Изменение путей к файлам подложек DWFx
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx (Понятие)

Изменение путей к файлам подложек DWFx
Управление чертежами, содержащими подложки DWFx, и их публикация
Диспетчер ссылок и подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация >
Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx
Понятие Краткий справочник

Файлы чертежей, содержащие вставленные подложки DWFx, можно выводить на печать или публиковать как файлы DWFx. При работе с функцией формирования комплектов выполняются операции отслеживания подложек DWFx и управления ими. Кроме того, при сохранении в форматах чертежей предыдущих версий подложки DWFx не утрачиваются.

Печать и публикация

При печати или публикации файла чертежа, содержащего вставленную подложку DWFx, в новый файл DWFx вся видимая геометрия DWFx включается в файл DWFx, в который выполнена печать или публикация. Однако в новый файл DWFx не публикуются данные о слоях из исходного файла DWF, вставленного в чертеж.

Сохранение в формате DWG прежних версий

Если чертеж сохранен в формате DWG предыдущей версии, при открытии чертежа в более ранней версии программы подложка DWFx не отображается; она также не представлена объектом-заместителем или контуром-заместителем. При последующем открытии чертежа в текущей версии программы подложка DWFx снова отображается.

Формирование комплекта

При работе с функцией формировании комплектов отслеживание вставленных файлов DWFx и управление ими выполняется так же, как в случае растровых изображений.


Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx (Краткий справочник)

Изменение путей к файлам подложек DWFx
Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx
Диспетчер ссылок и подложки DWFx
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx >
Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx
Понятие Краткий справочник

Команды

3DДВФ

Создание 3D DWF или 3D DWFx-файла 3D модели и его открытие в окне DWF Viewer

ПУБЛ3DДВФ

Устар.

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Диспетчер ссылок и подложки DWFx (Понятие)

Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx
Управление чертежами, содержащими подложки DWFx, и их публикация
Преобразование файлов DXF и DXB в формат DWG
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация >
Диспетчер ссылок и подложки DWFx
Понятие Процедура Краткий справочник

С помощью Диспетчера ссылок можно просматривать вхождения файлов, вставленных в файл DWF, и редактировать пути вставляемых файлов.

Диспетчер ссылок - это внешнее приложение, позволяющее проверять связи файла чертежа с другими файлами. Диспетчер ссылок отображает следующие свойства:

  • Тип
  • положение
  • имя файла
  • имя
  • сохраненный путь
  • путь обнаружения
  • основной чертёж
  • основная версия

Имеется возможность просмотра списка ссылок, относящихся к чертежу, или списка ссылок одного типа.


Проверка подложек DWFx с помощью диспетчера ссылок (Процедура)

Изменение путей к файлам подложек DWFx
На уровень вверх ..
Преобразование файлов DXF и DXB в формат DWG
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Диспетчер ссылок и подложки DWFx >
Диспетчер ссылок и подложки DWFx
Понятие Процедура Краткий справочник

Проверка подложек DWFx с помощью диспетчера ссылок

  1. Выберите в ОС Windows "Пуск" [image] "Все программы" ("Программы") [image] "Autodesk" [image] "AutoCAD 2009" [image] "Диспетчер ссылок".
  2. В окне "Диспетчер ссылок" нажмите кнопку "Добавить чертежи".
  3. В диалоговом окне "Добавление чертежей" выберите чертеж и нажмите кнопку "Открыть".

    Если чертеж содержит вложенные ссылки, следует просмотреть информацию в диалоговом окне задачи "Добавление внешних ссылок". Можно добавить все внешние ссылки независимо от уровня вложения или только внешние ссылки первого уровня. Выберите требуемые параметры и нажмите "ОК".

  4. Щелкните на чертеже правой кнопкой мыши. Для просмотра по типам ссылок выберите "Просмотр ссылок".

    По умолчанию применяется режим просмотра по чертежам.

  5. Щелкните на чертеже правой кнопкой мыши. Для просмотра по чертежам выберите "Просмотр по чертежам".


Диспетчер ссылок и подложки DWFx (Краткий справочник)

Публикация, сохранение и формирование комплектов чертежей, содержащих подложки DWFx
Диспетчер ссылок и подложки DWFx
Преобразование файлов DXF и DXB в формат DWG
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Использование файлов DWFx в качестве подложек на чертеже > Управление чертежами, содержащими подложки DWFx, и их публикация > Диспетчер ссылок и подложки DWFx >
Диспетчер ссылок и подложки DWFx
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Преобразование файлов DXF и DXB в формат DWG (Понятие)

Диспетчер ссылок и подложки DWFx
Импорт, вставка и открытие файлов других форматов
Вставка файлов DGN в качестве подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Преобразование файлов DXF и DXB в формат DWG
Понятие Процедура Краткий справочник

DXF и DXB - это два типа файлов обмена данными чертежей, с помощью которых можно переносить данные между различными приложениями.

Файл DXF (формат обмена данными чертежей) является представлением файла чертежа в двоичном формате или в формате ASCII. Эти файлы часто используются для организации совместного доступа других программ автоматизированного проектирования к данным чертежей.

Файл DXB (двоичный файл обмена данными чертежей) - это особым образом закодированная двоичная версия файла DXF, предназначенная для печати; с помощью этого файла можно преобразовывать чертежи трехмерного каркаса в двумерные объекты векторной графики.

Преобразование DXF- или DXB-файла в DWG-формат осуществляется путем его открытия с последующим сохранением в формате DWG. Результатом такого преобразования является файл чертежа, с которым можно работать точно так же, как с любым другим файлом чертежа.


Преобразование файлов DXF и DXB в формат DWG (Процедура)

Диспетчер ссылок и подложки DWFx
На уровень вверх ..
Преобразование файлов DXF и DXB в формат DWG
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Преобразование файлов DXF и DXB в формат DWG >
Преобразование файлов DXF и DXB в формат DWG
Понятие Процедура Краткий справочник

Открытие файла DXF

Для открытия DXB-файла


Открытие файла DXF (Процедура)

Преобразование файлов DXF и DXB в формат DWG
На уровень вверх ..
Преобразование файлов DXF и DXB в формат DWG
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Преобразование файлов DXF и DXB в формат DWG >
Преобразование файлов DXF и DXB в формат DWG
Понятие Процедура Краткий справочник

Открытие файла DXF

  1. Выберите пункт меню "Файл" [image] "Открыть".В командной строке введите "открыть".
  2. В списке "Тип файла" диалогового окна "Выбор файла" выберите "DXF (*.dxf)".
  3. Найдите и выберите импортируемый DXF-файл или введите имя файла в соответствующем поле.
  4. Нажмите "Открыть".
    Ввод команды: ОТКРЫТЬ


Для открытия DXB-файла (Процедура)

Преобразование файлов DXF и DXB в формат DWG
На уровень вверх ..
Вставка и удаление подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Преобразование файлов DXF и DXB в формат DWG >
Преобразование файлов DXF и DXB в формат DWG
Понятие Процедура Краткий справочник

Для открытия DXB-файла

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Импорт" [image] DXB-файл. В командной строке введите "импортд".
  2. В диалоговом окне "Выбор DXB-файла" найдите и выберите импортируемый DXB-файл.
  3. Нажмите "Открыть".
Ввод команды: ИМПОРТД


Преобразование файлов DXF и DXB в формат DWG (Краткий справочник)

Диспетчер ссылок и подложки DWFx
Преобразование файлов DXF и DXB в формат DWG
Общие сведения о вставке файлов DGN в качестве подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Преобразование файлов DXF и DXB в формат DWG >
Преобразование файлов DXF и DXB в формат DWG
Понятие Процедура Краткий справочник

Команды

ИМПОРТД

Импорт двоичных файлов в специальной кодировке

ОТКРЫТЬ

Открытие существующего файла чертежа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка файлов DGN в качестве подложек

Преобразование файлов DXF и DXB в формат DWG
Импорт, вставка и открытие файлов других форматов
Общие сведения о вставке файлов DGN в качестве подложек
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Вставка файлов DGN в качестве подложек

В качестве подложки можно вставить двумерные геометрические объекты, хранящиеся в файле MicroStation DGN.

Темы в этом разделе

  • Общие сведения о вставке файлов DGN в качестве подложек
  • Перекрестные ссылки понятий MicroStation на термины AutoCAD

    Несмотря на некоторое сходство двух приложений САПР - MicroStation и AutoCAD - в них употребляется различная терминология.

  • Вставка и удаление подложки DGN

    Имеется возможность добавлять подложки DGN в файлы чертежей или удалять их или же менять их положение, масштаб и ориентацию.

  • Корректировка внешнего вида подложки DGN и контуров подрезки

    После вставки подложки DGN можно настраивать внешний вид подложки или задавать контуры подрезки для выделения конкретного фрагмента подложки.

  • Управление и публикация чертежей, содержащих подложки DGN

    Имеется возможность просмотра и работы с подложками DGN и изменения путей к подложкам с палитры "Внешние ссылки".


Общие сведения о вставке файлов DGN в качестве подложек (Понятие)

Вставка файлов DGN в качестве подложек
Вставка файлов DGN в качестве подложек
Перекрестные ссылки понятий MicroStation на термины AutoCAD
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек >
Общие сведения о вставке файлов DGN в качестве подложек
Понятие Краткий справочник

Предусмотрена возможность создания подложек на основе двумерных геометрических объектов, которые хранятся в файлах DGN, созданных в программе MicroStation. Подобно растровым изображениям, подложки обеспечивают визуализацию данных; кроме того, они поддерживают некоторые функции привязки объектов. В отличие от внешних ссылок подложки нельзя внедрить в чертеж.

Поддержка DGN ограничена файлами DGN версий V7/V8 и двумерными объектами. Двумерные объекты импортируются или вставляются с полной информацией о координатах (x, y, z), которая присутствовала в исходном файле. В случае обнаружения трехмерных тел, поверхностей и других трехмерных объектов отображается предупреждающее сообщение о том, что в файле обнаружено неподдерживаемое содержимое.


Общие сведения о вставке файлов DGN в качестве подложек (Краткий справочник)

Преобразование файлов DXF и DXB в формат DWG
Общие сведения о вставке файлов DGN в качестве подложек
Перекрестные ссылки понятий MicroStation на термины AutoCAD
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Общие сведения о вставке файлов DGN в качестве подложек >
Общие сведения о вставке файлов DGN в качестве подложек
Понятие Краткий справочник

Команды

ДГНВСТАВИТЬ

Вставка подложки DGN в текущий чертеж

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Перекрестные ссылки понятий MicroStation на термины AutoCAD (Понятие)

Общие сведения о вставке файлов DGN в качестве подложек
Вставка файлов DGN в качестве подложек
Вставка и удаление подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек >
Перекрестные ссылки понятий MicroStation на термины AutoCAD
Понятие Краткий справочник

Несмотря на некоторое сходство двух приложений САПР - MicroStation и AutoCAD - в них употребляется различная терминология.

В приведенной ниже таблице поясняются многие особые термины, использующиеся в MicroStation, и приводятся ссылки на термины AutoCAD, если это возможно.

Термины MicroStation и AutoCAD

Термин MicroStation

Термин AutoCAD

Замечания

AccuSnap

Привязка

Инструмент автоматической привязки при построении чертежей.

ВСК

ПСК

Сокращение, используемое для описания системы координат.

ВСК - вспомогательная система координат

ПСК - пользовательская система координат

Параметр "ПоУровню"

Параметр "ПОСЛОЮ"

Параметр, определяющий, устанавливаются ли цвет, вес линий и стиль линий для каждого уровня (слоя).

Библиотеки сегментов

Н/П

В терминологии AutoCAD аналога не имеется.

Сегменты: общие и обычные

Блоки

В AutoCAD все блоки ведут себя как общие сегменты. В терминологии AutoCAD не имеется аналога понятию "обычная ячейка".

Модель конструкции

Пространство модели

Принципы работы в AutoCAD и с файлами DWG предусматривают всего одну модель. Режим работы в файле DGN MicroStation допускает несколько моделей.

Файл DGN

Файл DWG

Собственный формат файлов в каждой программе.

Упрощение элемента

Расчленить

Команда, используемая для перевода типов элементов/объектов на более низкий уровень. Например, сегменты/блоки могут быть сведены до геометрии.

Атрибуты элемента

Свойства

Наименование характеристик элементов/объектов.

Вписать вид

Показать до границ

Команда, используемая для показа всех элементов, присутствующих в данный момент на чертеже.

  • При работе с инструментом "вписывания вида" в MicroStation операция вписывания применяется только к видимым геометрическим объектам.
  • Область, отображаемая в результате исполнения команды "Показать до границ", будет учитывать слои, отображение которых отключено.

Рукоятки

Ручки

Вершины геометрических элементов, которые можно выберите и использовать для редактирования.

Команда

Командная строка

Место для ввода команд/переменных вручную.

Уровни

Слои

Организационная структура, используемая для управления видом объектов на чертеже.

Стили линий

Типы линий

Параметр, используемый для управления видом рабочей линии на чертеже.

Внедрение в главный файл

Внедрение внешней ссылки

Вставка внешней ссылки в текущий чертеж.

Центр сообщений

Текстовое окно

Место просмотра текстовых сообщений, выдающихся при работе программы.

Parasolid

ACIS

Собственное ядро 3D моделирования в каждой из программ.

Штрихование

Штриховка

Заливка определенной площади определенным образцом.

Таблицы перьев

Стили печати

Используются для управления тем, как выглядит рабочая линия при выводе на печать.

Ссылки

Ссылки: вставки, наложения и подложки

Ссылки на текущий чертеж хранятся вне чертежа, что снижает размер файла, но сохраняет возможность доступа к геометрическим объектам для построений и печати. В программе Microstation предусмотрены ссылки с активными вложениями и без вложений. При переносе в программы на основе AutoCAD ссылки без вложений преобразуются в подложки.

В MicroStation V7 не поддерживаются вложенные ссылки.

Файл прототипа

Файл шаблона чертежа

Такие файлы используются как исходная точка для создания файлов и сохраняют распространенные пользовательские параметры.

Для команды ДГНЭКСПОРТ основные и вспомогательные единицы, применяемые при преобразовании в файл .dgn, а также значения разрешения и точности определяются выбранным файлом прототипа.

Модель листа

Разметка листа чертежа

(пространство листа)

Основное назначение -- управление выводом чертежа на печать.

Интеллектуальная линия

Полилиния

Линия, состоящая из нескольких участков.

Маркеры

Атрибуты

Элемент, используемый для хранения в сегменте (блоке) текстовой информации.

Вид

Видовой экран

Используется для управления видимостью различных участков чертежа.

Атрибуты вида

Режимы рисования

Прямой аналог в терминологии AutoCAD отсутствует. Аналогичные режимы имеются в области панели задач/настройки параметров AutoCAD.

Рабочие единицы

Единицы чертежа

Используются для управления вводом для команд значений, зависящих от единиц измерения.


Перекрестные ссылки понятий MicroStation на термины AutoCAD (Краткий справочник)

Общие сведения о вставке файлов DGN в качестве подложек
Перекрестные ссылки понятий MicroStation на термины AutoCAD
Вставка файлов DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Перекрестные ссылки понятий MicroStation на термины AutoCAD >
Перекрестные ссылки понятий MicroStation на термины AutoCAD
Понятие Краткий справочник

Команды

ДГНРЕГУЛ

Управление параметрами отображения выбранных DGN подложек

ДГНВСТАВИТЬ

Вставка подложки DGN в текущий чертеж

ДГНРЕЗ

Определение контура подрезки для выбранной DGN подложки

ДГНЭКСПОРТ

Создание одного или нескольких DGN-файлов из текущего чертежа

ДГНИМПОРТ

Импорт данных в новый DWG-файл из файла DGN

ДГНСЛОЙ

Управление отображением слоев в DGN-подложке

ДГНСООТВ

Позволяет пользователям создавать и редактировать пользовательские параметры соответствия DGN

Системные переменные

DGNFRAME

Включение/отключение отображения или печати контуров подложки DGN в текущем чертеже

DGNIMPORTMAX

Контроль максимального количества элементов, преобразуемых при выполнении команды ДГНИМПОРТ

DGNMAPPINGPATH

Задание папки для файла dgnsetups.ini, в котором хранятся параметры соответствия DGN

DGNOSNAP

Управление объектной привязкой для геометрии в подложках DGN

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка и удаление подложки DGN

Перекрестные ссылки понятий MicroStation на термины AutoCAD
Вставка файлов DGN в качестве подложек
Вставка файлов DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек >
Вставка и удаление подложки DGN
Понятие Процедура

Имеется возможность добавлять подложки DGN в файлы чертежей или удалять их или же менять их положение, масштаб и ориентацию.

Темы в этом разделе

  • Вставка файлов DGN

    Файлы DGN можно вставлять в файлы чертежей в виде подложек.

  • Удаление подложек DGN

    Подложки DGN могут быть удалены из файла чертежа.

  • Редактирование подложек DGN

    После вставки подложки DGN в чертеж еще имеется возможность в любой момент изменить ее положение, масштаб или угол поворота.


Вставка и удаление подложки DGN (Процедура)

Преобразование файлов DXF и DXB в формат DWG
Вставка и удаление подложки DGN
Вставка файлов DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN >
Вставка и удаление подложки DGN
Понятие Процедура

Процедура вставки файла DGN в виде подложки

Удаление подложки DGN

Процедура выгрузки или загрузки подложки DGN

Процедура включения или отключения объектной привязки на подложках DGN

Редактирование положения, масштаба или угла поворота подложки DGN с палитры "Свойства"


Вставка файлов DGN (Понятие)

Вставка и удаление подложки DGN
Вставка и удаление подложки DGN
Удаление подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN >
Вставка файлов DGN
Понятие Процедура Краткий справочник

Файлы DGN можно вставлять в файлы чертежей в виде подложек.

Файлы DGN связывают и размещают в файлах чертежей сходным образом с файлами растровых изображений, но на самом деле они не являются частью файла чертежа. Связь файла чертежа и подложки DGN устанавливается заданием пути. Можно в любой момент редактировать пути связей с файлами DGN или удалять их. За счет вставки подложек DGN с помощью связанных путей к файлам DGN имеется возможность помещать в чертеж подложки DGN без существенного увеличения размера файла.

ПримечаниеКоманда ДГНВСТАВИТЬ применима не только к файлам с расширением *.dgn. Она поддерживает все файлы DGN независимо от наличия расширения .dgn.

Перетаскивание файлов DGN

Также можно перетаскивать подложки DGN прямо в чертеж. Сразу по завершению перетаскивания файла DGN выдается запрос точки вставки, масштаба и угла поворота.

Допускается многократная вставка в чертеж одной и той же подложки DGN; общая стратегия здесь полностью совпадает с используемой для блоков. Каждая подложка имеет собственную границу подрезки и отличающиеся от других вхождений значения контрастности, степени слияния с фоном и наличия цвета. Тем не менее, невозможно внедрить подложку в чертёж, и невозможно внести изменения в содержимое чертежа подложки.

Уровни в файлах DGN

При вставке файла DGN в качестве подложки структура любого количества уровней сводится на один слой. Подложка помещается на текущий слой листа.

В подложке DGN можно включать и отключать слои. Подробнее см. раздел ДГНСЛОЙ.

Подложки DGN во внешних ссылках

При работе с чертежами, содержащими ссылки на файлы DWG (внешние ссылки), возможна ситуация, когда в одну из ссылок на файл DWG вставлена подложка DGN. В такой ситуации геометрия DGN будет видна в исходном чертеже.

Например, "Чертеж А" содержит подложку DGN, на которой показаны некоторые особенности конструкции. Требуется содержимое "Чертежа А" вставить в текущий чертеж, "Чертеж Б". Если вставить "Чертеж А" в "Чертеж Б" в качестве внешней ссылки, подложка DGN, уже вставленная в "Чертеж А", также будет присутствовать.

Все настройки свойств объектов, сделанные для подложки в ссылке в файле DWG, например границы подрезки, отображаются также, как в исходном чертеже.

3D файлы в формате DGN

При попытке вставки файла DGN, содержащего трехмерные объекты, отображается предупреждающее сообщение.


Процедура вставки файла DGN в виде подложки (Процедура)

Вставка и удаление подложки DGN
На уровень вверх ..
Удаление подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Вставка файлов DGN >
Вставка файлов DGN
Понятие Процедура Краткий справочник

Процедура вставки файла DGN в виде подложки

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] DGN. В командной строке введите "дгнвставить".
  2. В диалоговом окне "Выбор DGN-файла" выберите файл, который требуется вставить.
  3. Нажмите "Открыть".
  4. Если файл DGN содержит несколько моделей конструкций, в диалоговом окне "Вставка подложки DGN" выберите модель, которую требуется вставить.
  5. В разделе "Единицы преобразования" укажите единицы, которые требуется применять в AutoCAD: "Основные единицы" или "Вспомогательные единицы".
  6. Воспользуйтесь одним из следующих способов для указания точки вставки, масштаба или угла поворота:
    • Установите флажок "Указать на экране", чтобы использовать устройство указания для вставки подложки DGN в определенную точку с необходимым масштабом и под нужным углом.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".
  7. Нажмите "ОК".
Панель:Вставка
Ввод команды: ДГНВСТАВИТЬ


Вставка файлов DGN (Краткий справочник)

Перекрестные ссылки понятий MicroStation на термины AutoCAD
Вставка файлов DGN
Удаление подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Вставка файлов DGN >
Вставка файлов DGN
Понятие Процедура Краткий справочник

Команды

ДГНВСТАВИТЬ

Вставка подложки DGN в текущий чертеж

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Удаление подложек DGN (Понятие)

Вставка файлов DGN
Вставка и удаление подложки DGN
Редактирование подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN >
Удаление подложек DGN
Понятие Процедура Краткий справочник

Подложки DGN могут быть удалены из файла чертежа.

Имеется возможность удалять подложки DGN, которые больше не нужны на чертеже. При удалении подложки DGN из чертежа убираются все ее экземпляры, очищается описание подложки и удаляется путь связи с файлом DGN.

Если требуется временно скрыть подложку DGN, можно вместо отсоединения подложки выгрузить ее. В этом случае подложка DGN и ее местоположение резервируются для последующей загрузки.

ПримечаниеСтирание отдельного экземпляра подложки DGN не эквивалентно ее удалению. Подложку DGN необходимо удалять для разрыва связи чертежа с файлом DGN.


Удаление подложек DGN (Процедура)

Вставка файлов DGN
На уровень вверх ..
Удаление подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Удаление подложек DGN >
Удаление подложек DGN
Понятие Процедура Краткий справочник

Удаление подложки DGN

Процедура выгрузки или загрузки подложки DGN


Удаление подложки DGN (Процедура)

Удаление подложек DGN
На уровень вверх ..
Удаление подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Удаление подложек DGN >
Удаление подложек DGN
Понятие Процедура Краткий справочник

Удаление подложки DGN

  1. Откройте палитру "Внешние ссылки".
  2. В области "Вхождения файлов" выберите подложку DGN, которую требуется удалить.
  3. Нажмите правую кнопку мыши и выберите "Удалить".

    Связь между файлом чертежа и подложкой DGN разрывается, и все экземпляры подложки удаляются из чертежа.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Выберите "Внешние ссылки".


Процедура выгрузки или загрузки подложки DGN (Процедура)

Удаление подложек DGN
На уровень вверх ..
Редактирование подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Удаление подложек DGN >
Удаление подложек DGN
Понятие Процедура Краткий справочник

Процедура выгрузки или загрузки подложки DGN

  1. Откройте палитру "Внешние ссылки".
  2. В области "Вхождения файлов" выберите подложку DGN.
  3. Щелкните правой кнопкой мыши и выберите "Выгрузить" или "Загрузить повторно".

    После выгрузки подложка DGN по-прежнему связана с файлом чертежа, но не отображается на чертеже.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Выберите "Внешние ссылки".


Удаление подложек DGN (Краткий справочник)

Вставка файлов DGN
Удаление подложек DGN
Редактирование подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Удаление подложек DGN >
Удаление подложек DGN
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование подложек DGN (Понятие)

Удаление подложек DGN
Вставка и удаление подложки DGN
Корректировка внешнего вида подложки DGN и контуров подрезки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN >
Редактирование подложек DGN
Понятие Процедура Краткий справочник

После вставки подложки DGN в чертеж еще имеется возможность в любой момент изменить ее положение, масштаб или угол поворота.

Хотя точка вставки, масштабный коэффициент и угол поворота могут быть указаны в момент вставки файла DGN, может возникнуть необходимость изменения этих параметров по мере работы над чертежом. По умолчанию выводится запрос на точку вставки. Масштаб зависит от рабочих единиц, используемых в файле DGN, единиц преобразования, применяемых при вставке подложки DGN, и единиц масштаба вставки, заданных в файле DWG.

После вставки подложки DGN можно с помощью палитры свойств изменить для нее значения следующих параметров слияние с фоном, контрастность и монохромный режим.

Так как вставленная подложка DGN ведет себя так же, как вставленное растровое изображение, общие команды редактирования используются в том же режиме, позволяя перемещать ее, масштабировать, поворачивать, симметрично отражать, создавать массив и т.д. Также имеется возможность производить изменения путем выбора команд из контекстного меню после выбора подложки DGN или из палитры свойств выбранной подложки DGN.

СоветДвойное нажатие кнопки мыши на подложке DGN откроет палитру свойств для данной подложки.

Объектная привязка к подложкам DGN

Для создания ссылок на определенные местоположения на подложке DGN можно включить функцию объектной привязки для объектов на всех подложках DGN.

Включение и отключение объектной привязки для подложек DGN осуществляется посредством системной переменной DGOSNAP или с помощью команды "Объектная привязка к DGN" в меню быстрого вызова команд, открытом при выбранной подложке DGN.

Ручки для редактирования подложек DGN

Подложки DGN по своим функциям аналогичны растровым изображениям, однако существует различие, касающееся работы ручек. В данном случае режим ближе к принятому для блоков.

Подложки DGN обычно отображают только базовую ручку. Базовая ручка используется для изменения положения подложки на чертеже. Если указан подрезающий контур, а системная переменная DGNFRAME включена, для каждого угла контура отображаются дополнительные ручки. См. "Корректировка внешнего вида подложки DGN и контуров подрезки".

Ручка для базовой точки отображается как базовая точка для ссылки на блок. Из текущего файла чертежа невозможно выполнить сброс базовой точки. Она определяется в файле DGN.


Редактирование подложек DGN (Процедура)

Удаление подложек DGN
На уровень вверх ..
Редактирование подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Редактирование подложек DGN >
Редактирование подложек DGN
Понятие Процедура Краткий справочник

Процедура включения или отключения объектной привязки на подложках DGN

Редактирование положения, масштаба или угла поворота подложки DGN с палитры "Свойства"


Процедура включения или отключения объектной привязки на подложках DGN (Процедура)

Редактирование подложек DGN
На уровень вверх ..
Редактирование подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Редактирование подложек DGN >
Редактирование подложек DGN
Понятие Процедура Краткий справочник

Процедура включения или отключения объектной привязки на подложках DGN

  1. Щелкните на подложке DGN, затем щелкните правой кнопкой мыши.
  2. В меню быстрого вызова команд выберите "Объектная привязка к DGN" для включения или отключения этой функции.
Ввод команды: DGNOSNAP


Редактирование положения, масштаба или угла поворота подложки DGN с палитры "Свойства" (Процедура)

Редактирование подложек DGN
На уровень вверх ..
Корректировка внешнего вида подложки DGN и контуров подрезки
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Редактирование подложек DGN >
Редактирование подложек DGN
Понятие Процедура Краткий справочник

Редактирование положения, масштаба или угла поворота подложки DGN с палитры "Свойства"

  1. На видовом экране чертежа дважды нажмите кнопку мыши на подложке DGN, которую требуется отредактировать.
  2. На палитре свойств откройте группу "Геометрия", если она не отображается.
  3. Выполните одно или несколько следующих действий.
    • Измените параметры положения X, Y или Z.
    • измените значение угла поворота;
    • откорректируйте размер подложки за счет изменения величины масштаба или заново задайте ширину и высоту.
Панель:Стандартная
Ввод команды: ОКНОСВ


Редактирование подложек DGN (Краткий справочник)

Удаление подложек DGN
Редактирование подложек DGN
Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Вставка и удаление подложки DGN > Редактирование подложек DGN >
Редактирование подложек DGN
Понятие Процедура Краткий справочник

Команды

ДГНВСТАВИТЬ

Вставка подложки DGN в текущий чертеж

Системные переменные

DGNFRAME

Включение/отключение отображения или печати контуров подложки DGN в текущем чертеже

DGNOSNAP

Управление объектной привязкой для геометрии в подложках DGN

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Корректировка внешнего вида подложки DGN и контуров подрезки

Редактирование подложек DGN
Вставка файлов DGN в качестве подложек
Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек >
Корректировка внешнего вида подложки DGN и контуров подрезки
Понятие Процедура

После вставки подложки DGN можно настраивать внешний вид подложки или задавать контуры подрезки для выделения конкретного фрагмента подложки.

Темы в этом разделе

  • Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN

    Помимо палитры свойств для редактирования положения, масштаба и угла поворота подложки DGN, предусмотрена возможность изменения параметров слияния с фоном, контрастности и "Монохромный" подложки DGN.

  • Подрезка подложек DGN

    Имеется возможность подрезки изображения подложки DGN на чертеже с помощью прямоугольного или многоугольного контура подрезки.

  • Показ и скрытие контуров подложки DGN

    Имеется возможность управления видимостью контура, который описывает границы подложки DGN или видимостью контура, который определяется контуром подрезки.

  • Управление отображением слоев в подложке DGN

    В подложке DGN можно включать и отключать слои.


Корректировка внешнего вида подложки DGN и контуров подрезки (Процедура)

Редактирование подложек DGN
Корректировка внешнего вида подложки DGN и контуров подрезки
Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки >
Корректировка внешнего вида подложки DGN и контуров подрезки
Понятие Процедура

Процедура настройки слияния с фоном, контрастности и монохромного режима для подложки DGN

Подрезка подложки DGN

Указание нового контура для подрезанной подложки DGN

Редактирование существующего контура у подрезанной подложки DGN

Показ или скрытие подрезанной части подложки DGN

Удаление контура подрезанной подложки DGN

Показ и скрытие контуров подложки DGN

Процедура включения и отключения слоев подложки DGN


Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN (Понятие)

Корректировка внешнего вида подложки DGN и контуров подрезки
Корректировка внешнего вида подложки DGN и контуров подрезки
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки >
Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Понятие Процедура Краткий справочник

Помимо палитры свойств для редактирования положения, масштаба и угла поворота подложки DGN, предусмотрена возможность изменения параметров слияния с фоном, контрастности и "Монохромный" подложки DGN.

Можно отрегулировать параметры слияния с фоном, контрастности и "Монохромный" для отображения подложки DGN, а также для вывода на печать, не внося изменений в исходный файл DGN и другие экземпляры подложки DGN на чертеже.

В разделе "Настройка подложки" палитры свойств можно изменить значения параметров "Слияние с фоном", "Контрастность" и "Монохромный" для выбранной подложки DGN.

Слияние с фоном

Служит для регулирования эффекта слияния с цветом фона. Более высокие значения соответствуют большей прозрачности подложки DGN. При выводе чертежа на печать слияние с фоном пересчитывается по отношению к белому фону.

Контрастность

Служит для настройки контрастности подложки DGN; косвенно влияет на степень ее слияния с фоном. Если для параметра "Контрастность" задано значение 100, все контурные изображения соответствуют интенсивности значения параметра "Слияние с фоном". При более высоких значениях к основному и дополнительному цветам добавляются дополнительные пикселы.

Монохромный

Служит для регулирования цветонасыщенности при сохранении яркости. Если этот параметр включен, а яркость цвета фона составляет не менее 50%, объекты отображаются оттенками серого, начиная с черного цвета. Если яркость цвета фона меньше 50%, выполняется обращение цветов объекта: самые темные объекты отображаются белым цветом, а самые светлые - черным. Обращение цветов служит для обеспечивает отчетливое изображение подложки на экране; при печати цвета восстанавливаются.

ПримечаниеЕсли DGN-файл вставляется в качестве подложки, то структура его уровней (слоев) преобразовывается в один слой. Подложка DGN вставляется в текущий слой. Если требуется скрыть подложку DGN, зафиксируйте слой, в который она вставлена. Для включения или отключения слоя DGN щелкните на соответствующем значке электрической лампочки (см. ДГНСЛОЙ).


Процедура настройки слияния с фоном, контрастности и монохромного режима для подложки DGN (Процедура)

Корректировка внешнего вида подложки DGN и контуров подрезки
На уровень вверх ..
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN >
Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Понятие Процедура Краткий справочник

Процедура настройки слияния с фоном, контрастности и монохромного режима для подложки DGN

  1. Выберите подложку DGN, параметры которой требуется отредактировать.
  2. Выберите пункт меню "Редактировать" [image] "Свойства".В командной строке введите "окносв".
  3. На палитре свойств подложки DGN выполните одно из следующих действий.
    • Отрегулируйте контрастность, увеличивая или снижая значение.
    • Отрегулируйте степень слияния с фоном, увеличивая или снижая значение.
    • Включите или отключите параметр "Монохромный".
Ввод команды: ДГНРЕГУЛ
Контекстное меню:Щелкните на подложке DGN, затем щелкните правой кнопкой мыши. В меню быстрого вызова команд выберите "Свойства".


Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN (Краткий справочник)

Редактирование подложек DGN
Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN >
Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Понятие Процедура Краткий справочник

Команды

ДГНРЕГУЛ

Управление параметрами отображения выбранных DGN подложек

ДГНСЛОЙ

Управление отображением слоев в DGN-подложке

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подрезка подложек DGN (Понятие)

Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Корректировка внешнего вида подложки DGN и контуров подрезки
Показ и скрытие контуров подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Имеется возможность подрезки изображения подложки DGN на чертеже с помощью прямоугольного или многоугольного контура подрезки.

Можно определить часть подложки DGN, которую требуется отображать и выводить на печать, путем задания контура подрезки. Дополнительным преимуществом от задания контура подрезки является увеличение скорости перерисовки за счет выделения только тех частей подложки, которые должны быть видимыми. Контуром подрезки может служить прямоугольник или двумерный (2D) многоугольник, вершины которого лежат внутри границ подложки. Контур подрезки для каждого экземпляра подложки DGN может быть только один. Разные экземпляры одной и той же подложки могут иметь разные контуры. Контур подрезанной подложки можно изменить в любой момент.

Подрезанную подложку можно отображать с использованием контура подрезки или можно его скрыть, чтобы отображать подложку в её исходных границах.

Если контур подрезки более не нужен, его можно удалить из подложки. После удаления контура подрезки подложка отображается в своих исходных границах.


Подрезка подложек DGN (Процедура)

Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
На уровень вверх ..
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Подрезка подложек DGN >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Подрезка подложки DGN

Указание нового контура для подрезанной подложки DGN

Редактирование существующего контура у подрезанной подложки DGN

Показ или скрытие подрезанной части подложки DGN

Удаление контура подрезанной подложки DGN


Подрезка подложки DGN (Процедура)

Подрезка подложек DGN
На уровень вверх ..
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Подрезка подложек DGN >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Подрезка подложки DGN

  1. Щелкните на подложке DGN, затем щелкните правой кнопкой мыши в области чертежа. В меню быстрого вызова команд выберите "Подрезка DGN".
  2. В командной строке введите "n" (новый контур).
  3. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

Ввод команды: ДГНРЕЗ
Контекстное меню:Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Нажмите "Подрезка DGN".


Указание нового контура для подрезанной подложки DGN (Процедура)

Подрезка подложек DGN
На уровень вверх ..
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Подрезка подложек DGN >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Указание нового контура для подрезанной подложки DGN

  1. Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Нажмите "Подрезка DGN".
  2. В командной строке введите "n" (новый контур).
  3. Введите н (Нет) или д (Да) в ответ на запрос об удалении старого контура. Если выбирается н (нет), выполнение команды завершается.
  4. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

    Контуры подрезки могут редактироваться с помощью ручек. См. раздел Редактирование с помощью ручек.

Ввод команды: ДГНРЕЗ
Контекстное меню:Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Нажмите "Подрезка DGN".


Редактирование существующего контура у подрезанной подложки DGN (Процедура)

Подрезка подложек DGN
На уровень вверх ..
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Подрезка подложек DGN >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Редактирование существующего контура у подрезанной подложки DGN

  1. Выберите подрезанную подложку DGN.
  2. Нажмите одну из угловых ручек и перетащите ее в новое положение.
  3. Нажмите кнопку мыши повторно для установки угловой ручки.


Показ или скрытие подрезанной части подложки DGN (Процедура)

Подрезка подложек DGN
На уровень вверх ..
Подрезка подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Подрезка подложек DGN >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Показ или скрытие подрезанной части подложки DGN

  1. Выберите подрезанную подложку DGN, часть которой требуется показать или скрыть.
  2. Нажмите правую кнопку мыши в области чертежа. Нажмите кнопку "Свойства".
  3. На палитре свойств выберите "Да" или "Нет" в списке "Показать отрезанную часть".
Панель:Стандартная
Ввод команды: ОКНОСВ


Удаление контура подрезанной подложки DGN (Процедура)

Подрезка подложек DGN
На уровень вверх ..
Показ и скрытие контуров подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Подрезка подложек DGN >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Удаление контура подрезанной подложки DGN

  1. Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Нажмите "Подрезка DGN".
  2. В командной строке введите "d" (удалить).

    Контур подрезанной подложки удаляется, и восстанавливается исходный контур подложки.

Ввод команды: ДГНРЕЗ
Контекстное меню:Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Нажмите "Подрезка DGN".


Подрезка подложек DGN (Краткий справочник)

Регулировка слияния с фоном, контрастности и параметра "Монохромный" для подложки DGN
Подрезка подложек DGN
Показ и скрытие контуров подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Подрезка подложек DGN >
Подрезка подложек DGN
Понятие Процедура Краткий справочник

Команды

ДГНРЕЗ

Определение контура подрезки для выбранной DGN подложки

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Показ и скрытие контуров подложки DGN (Понятие)

Подрезка подложек DGN
Корректировка внешнего вида подложки DGN и контуров подрезки
Управление отображением слоев в подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки >
Показ и скрытие контуров подложки DGN
Понятие Процедура Краткий справочник

Имеется возможность управления видимостью контура, который описывает границы подложки DGN или видимостью контура, который определяется контуром подрезки.

Можно скрывать контуры подложки DGN. Контур - это визуальная граница, которая показывает предельные размеры подложки DGN или контур ее подрезки. Скрытие контура подложки предотвращает печать границы или ее представление на экране. Если контуры подложки скрыты, подрезанные подложки все же отображаются в заданных для них пределах; операция относится только к контуру. Включение и отключение отображения контуров подложки относится ко всем подложкам, вставленным в чертеж.


Показ и скрытие контуров подложки DGN (Процедура)

Подрезка подложек DGN
На уровень вверх ..
Управление отображением слоев в подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Показ и скрытие контуров подложки DGN >
Показ и скрытие контуров подложки DGN
Понятие Процедура Краткий справочник

Показ и скрытие контуров подложки DGN

  1. В командной строке введите "дгнконтур".
  2. Выполнить одно из действий:
    • Для скрытия контуров подложки DGN введите 0.
    • Для отображения и вывода на печать контуров подложки DGN введите 1.
    • Для показа контуров подложки DGN на экране без вывода на печать введите 2.
Ввод команды: DGNFRAME


Показ и скрытие контуров подложки DGN (Краткий справочник)

Подрезка подложек DGN
Показ и скрытие контуров подложки DGN
Управление отображением слоев в подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Показ и скрытие контуров подложки DGN >
Показ и скрытие контуров подложки DGN
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

DGNFRAME

Включение/отключение отображения или печати контуров подложки DGN в текущем чертеже

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление отображением слоев в подложке DGN (Понятие)

Показ и скрытие контуров подложки DGN
Корректировка внешнего вида подложки DGN и контуров подрезки
Управление и публикация чертежей, содержащих подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки >
Управление отображением слоев в подложке DGN
Понятие Процедура Краткий справочник

В подложке DGN можно включать и отключать слои.

Как правило, при работе с подложками DGN во избежание чрезмерной сложности изображения требуется отключить неиспользуемые слои.

Операции управления слоями подложек DGN следует выполнять не в диспетчере свойств слоев, а в диалоговом окне "Слои DGN" ( ДГНСЛОЙ).

С помощью палитры свойств можно определить, отключены ли какие-либо слои подложки DGN.

  • Если в выбранной подложке DGN нет отключенных слоев, для свойства "Переопределение отображения слоев" задано значение "Нет".
  • Если в выбранной подложке DGN отключен хотя бы один слой, для свойства "Переопределение отображения слоев" задано значение "Применяется".
СоветДля включения и отключения слоев DGN можно щелкнуть в списке правой кнопкой мыши и выбрать "Вкл" или "Откл".


Процедура включения и отключения слоев подложки DGN (Процедура)

Показ и скрытие контуров подложки DGN
На уровень вверх ..
Управление и публикация чертежей, содержащих подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Управление отображением слоев в подложке DGN >
Управление отображением слоев в подложке DGN
Понятие Процедура Краткий справочник

Процедура включения и отключения слоев подложки DGN

  1. Выберите подложку DGN, щелкнув на ограничивающей ее рамке.
  2. Щелкните правой кнопкой мыши, затем выберите "Слои DGN" в контекстном меню.
  3. В диалоговом окне "Слои DGN" щелкните на значке лампочки рядом с именем слоя, который требуется включить или отключить.

    Для выбора нескольких слоев следует во время щелчка удерживать нажатой клавишу CTRL или SHIFT.

  4. Нажмите "Применить" для сохранения изменений, или "OK" для сохранения изменений и выхода из диалогового окна.
Ввод команды: ДГНСЛОЙ


Управление отображением слоев в подложке DGN (Краткий справочник)

Показ и скрытие контуров подложки DGN
Управление отображением слоев в подложке DGN
Просмотр сведений о подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Корректировка внешнего вида подложки DGN и контуров подрезки > Управление отображением слоев в подложке DGN >
Управление отображением слоев в подложке DGN
Понятие Процедура Краткий справочник

Команды

ДГНСЛОЙ

Управление отображением слоев в DGN-подложке

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление и публикация чертежей, содержащих подложки DGN

Управление отображением слоев в подложке DGN
Вставка файлов DGN в качестве подложек
Просмотр сведений о подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек >
Управление и публикация чертежей, содержащих подложки DGN
Понятие Процедура

Имеется возможность просмотра и работы с подложками DGN и изменения путей к подложкам с палитры "Внешние ссылки".

Темы в этом разделе

  • Просмотр сведений о подложке DGN

    Имеется возможность просматривать относящуюся к файлам информацию о подложках DGN, вставленных в чертеж. Также можно загружать и выгружать подложки и проводить другие операции с палитры "Внешние ссылки".

  • Изменение путей к файлам подложек DGN

    Имеется возможность изменения пути к файлу DGN, на который имеется ссылка, или поиска необнаруженной подложки DGN.

  • Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN

    Файлы чертежей, содержащих вставки подложек DGN, можно вывести на печать или опубликовать как файлы DGN. Подложки DGN отслеживаются и подлежат управлению при формировании комплекта электронной пересылки.

  • Диспетчер ссылок и подложки DGN

    Приложение "Диспетчер ссылок" позволяет просматривать вхождения файлов, вставленных в файл DWG, и редактировать пути к вставленным файлам.


Управление и публикация чертежей, содержащих подложки DGN (Процедура)

Управление отображением слоев в подложке DGN
Управление и публикация чертежей, содержащих подложки DGN
Просмотр сведений о подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN >
Управление и публикация чертежей, содержащих подложки DGN
Понятие Процедура

Просмотр списка подложек DGN, вставленных в чертеж

Отображение имен подложек DGN и уровней их вложения во внешние ссылки и блоки

Изменение пути к подложке DGN

Проверка подложек DGN с помощью Диспетчера ссылок


Просмотр сведений о подложке DGN (Понятие)

Управление и публикация чертежей, содержащих подложки DGN
Управление и публикация чертежей, содержащих подложки DGN
Изменение путей к файлам подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN >
Просмотр сведений о подложке DGN
Понятие Процедура Краткий справочник

Имеется возможность просматривать относящуюся к файлам информацию о подложках DGN, вставленных в чертеж. Также можно загружать и выгружать подложки и проводить другие операции с палитры "Внешние ссылки".

На палитре "Внешние ссылки" можно просматривать сведения о подложке или в виде списка, или в виде древовидной структуры. Способ отображения информации на палитре "Внешние ссылки" выбирается кнопками "Список" или "Дерево" в верхнем правом углу. В режиме списка для каждой подложки на чертеже отображаются имя, статус ее загрузки, размер файла, дата последнего изменения и путь поиска файла. В режиме просмотра дерева подложки представлены в рамках иерархической структуры, отображающей уровень их вложенности во внешние ссылки и блоки. Сведения о статусе, размере и т.д. не выводятся.

Для любого вида можно отобразить информацию о подложке; вставить или удалить подложку; выгрузить или обновить подложку; а также выбрать и сохранить новый путь поиска.

Работа с режимом списка

В режиме просмотра списка отображаются все подложки, вставленные в текущий чертеж, но нет никакой информации о количестве экземпляров. Этот режим установлен по умолчанию. Сортировка подложек по категориям осуществляется нажатием кнопки мыши на заголовке соответствующего столбца. Для изменения ширины столбца необходимо установить курсор на вертикальную границу, разделяющую заголовки столбцов, и перетащить ее влево или вправо.

В список включаются следующие сведения:

  • имя (по умолчанию, это - "имя файла - имя модели")
  • положение (загружено, выгружено или не найдено)
  • размер файла
  • тип файла
  • дата и время последнего сохранения
  • путь и имя файла на момент вставки в чертеж

Если в AutoCAD невозможно обнаружить подложку, для нее указано состояние "Не найдена". Если для подложки указано состояние "Не найдена", для нее отображается также текст "Ссылка отсутствует или недопустима" вместе с исходным путем и именем файла. Если на подложку нет ссылок, то ее экземпляры в чертеж не вставляются. Если подложка не загружена, ее положение становится "Выгружена". Подложки в положении "Выгружена" или "Не найдена" на чертеже не отображаются.

Работа с древовидной структурой представления

На верхнем уровне в режиме дерева файлы DGN перечисляются в алфавитном порядке. В большинстве случаев файл подложки связывается непосредственно с чертежом и упоминается на верхнем уровне. Однако, если внешняя ссылка или блок содержит вставленную подложку, отображаются дополнительные уровни.

Просмотр сведений о файле или предварительный просмотр подложки DGN

Ниже перечислены сведения о файле DGN, которые можно просмотреть.

  • имя
  • положение
  • размер файла
  • тип файла
  • дата создания файла
  • путь и имя файла на момент вставки в чертеж
  • путь, по которому файл был обнаружен
    ПримечаниеПараметр "Обнаружен в..." отключен, если выбрана вложенная ссылка.

Вместо просмотра сведений о файле DGN можно щелкнуть на значке увеличительного стекла в правом верхнем углу области для предварительного просмотра подложки DGN. Рядом с этим значком расположен значок возврата к просмотру сведений.


Просмотр сведений о подложке DGN (Процедура)

Управление и публикация чертежей, содержащих подложки DGN
На уровень вверх ..
Просмотр сведений о подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Просмотр сведений о подложке DGN >
Просмотр сведений о подложке DGN
Понятие Процедура Краткий справочник

Просмотр списка подложек DGN, вставленных в чертеж

Отображение имен подложек DGN и уровней их вложения во внешние ссылки и блоки


Просмотр списка подложек DGN, вставленных в чертеж (Процедура)

Просмотр сведений о подложке DGN
На уровень вверх ..
Просмотр сведений о подложке DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Просмотр сведений о подложке DGN >
Просмотр сведений о подложке DGN
Понятие Процедура Краткий справочник

Просмотр списка подложек DGN, вставленных в чертеж

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Вид".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку и нажмите правую кнопку мыши в области чертежа. Выберите "Внешние ссылки".


Отображение имен подложек DGN и уровней их вложения во внешние ссылки и блоки (Процедура)

Просмотр сведений о подложке DGN
На уровень вверх ..
Изменение путей к файлам подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Просмотр сведений о подложке DGN >
Просмотр сведений о подложке DGN
Понятие Процедура Краткий справочник

Отображение имен подложек DGN и уровней их вложения во внешние ссылки и блоки

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Дерево".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку и нажмите правую кнопку мыши в области чертежа. Выберите "Внешние ссылки".


Просмотр сведений о подложке DGN (Краткий справочник)

Управление отображением слоев в подложке DGN
Просмотр сведений о подложке DGN
Изменение путей к файлам подложек DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Просмотр сведений о подложке DGN >
Просмотр сведений о подложке DGN
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ДГНВСТАВИТЬ

Вставка подложки DGN в текущий чертеж

ДГНСЛОЙ

Управление отображением слоев в DGN-подложке

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение путей к файлам подложек DGN (Понятие)

Просмотр сведений о подложке DGN
Управление и публикация чертежей, содержащих подложки DGN
Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN >
Изменение путей к файлам подложек DGN
Понятие Процедура Краткий справочник

Имеется возможность изменения пути к файлу DGN, на который имеется ссылка, или поиска необнаруженной подложки DGN.

При открытии чертежа с вставленным файлом DGN путь к выбранной подложке DGN отображается в палитре "Внешние ссылки", в поле "Обнаружен в..." в списке "Подробности". Отображаемый путь - это фактическое местоположение файла DGN. В поле "Сохраненный путь" отображается путь, по которому находился файл DGN на момент вставки.

Для обнаружения файла DGN программа выполняет поиск путей и папок в следующей последовательности.

  • Путь, указанный при вставке подложки DGN
  • Папка, в которой хранится текущий чертеж
  • Стандартные пути поиска файлов проектов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Стандартные пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке программы

Если открыть чертеж, содержащий файл DGN, который не обнаружить ни по сохраненному пути, ни по одному из путей поиска, в столбце "Положение" списка "Вхождения файлов" палитры "Внешние ссылки" отображается "Не найдена", а поле "Обнаружен в..." списка "Подробности" остается незаполненным.

Можно удалить путь из имени файла или указать относительный путь путем ручного редактирования пути в поле "Обнаружен в..." или после нажатия эллипса в правой части поля "Обнаружен в...". Последняя операция открывает диалоговое окно "Выбор DGN-файла".

Подробнее о работе с полными путями, относительными путями и именами проектов см. Задание путей к внешним чертежам .


Изменение пути к подложке DGN (Процедура)

Просмотр сведений о подложке DGN
На уровень вверх ..
Диспетчер ссылок и подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Изменение путей к файлам подложек DGN >
Изменение путей к файлам подложек DGN
Понятие Процедура Краткий справочник

Изменение пути к подложке DGN

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите подложку DGN, путь к которой требуется изменить. Нажмите кнопку [...] в правой части поля "Обнаружен в ...".
  3. В диалоговом окне "Выбор DGN-файла" задайте новый путь. Нажмите "Открыть".

    Новый путь отображается в столбце "Сохраненный путь".

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите подложку DGN и щелкните правой кнопкой мыши в области чертежа. Выберите "Внешние ссылки".


Изменение путей к файлам подложек DGN (Краткий справочник)

Просмотр сведений о подложке DGN
Изменение путей к файлам подложек DGN
Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Изменение путей к файлам подложек DGN >
Изменение путей к файлам подложек DGN
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN (Понятие)

Изменение путей к файлам подложек DGN
Управление и публикация чертежей, содержащих подложки DGN
Диспетчер ссылок и подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN >
Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN
Понятие Краткий справочник

Файлы чертежей, содержащих вставки подложек DGN, можно вывести на печать или опубликовать как файлы DGN. Подложки DGN отслеживаются и подлежат управлению при формировании комплекта электронной пересылки.

ПримечаниеПодложки DGN, сохраненные в AutoCAD 2008, не распознаются в версиях, более ранних по сравнению с AutoCAD 2008. Однако если сохранить такой файл в прежней версии AutoCAD, а затем снова открыть его в AutoCAD 2008 или более поздней версии, подложка обнаруживается. Кроме того, при сохранении чертежа в AutoCAD 2009 подложка распознается в AutoCAD 2008 только в том случае, если она является файлом V8 MicroStation.

Печать и публикация

Если файл чертежа, содержащий вставленную подложку DGN, выводят на печать или публикуют, вся видимая геометрия DGN включается в печатаемый или публикуемый файл чертежа.

Сохранение и сохранение в формате DWG прежних версий

Подложка DGN, вставленная в чертеж, сохраняется вместе со всем содержимым, составляющим чертеж. При повторном открытии чертежа подложка DGN присутствует, если путь к файлу DGN не был каким-либо образом изменен. В противном случае на экран выводится ограничивающая рамка, содержащая путь к отсутствующему файлу DGN и модель, выбранную при вставке файла DGN. После восстановления пути или указания нового пути подложка DGN появится на чертеже.

Если чертеж сохранен в формате DWG более ранней версии, при открытии чертежа в более ранней версии AutoCAD подложка DWG не отображается. Если снова открыть чертеж в текущей версии, подложка DWG отображается.

Формирование комплекта

Отслеживание и управление вставками DGN при формировании комплекта для электронной пересылки происходит тем же образом, что и при работе с растровыми изображениями.


Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN (Краткий справочник)

Изменение путей к файлам подложек DGN
Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN
Диспетчер ссылок и подложки DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN >
Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN
Понятие Краткий справочник

Команды

ФОРМКОМПЛЕКТ

Формирование комплекта файлов для передачи другим пользователям через Интернет

ПУБЛ

Публикация чертежей в DWF, DWFx-файлы или на плоттеры

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Диспетчер ссылок и подложки DGN (Понятие)

Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN
Управление и публикация чертежей, содержащих подложки DGN
Импорт файлов MicroStation DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN >
Диспетчер ссылок и подложки DGN
Понятие Процедура Краткий справочник

Приложение "Диспетчер ссылок" позволяет просматривать вхождения файлов, вставленных в файл DWG, и редактировать пути к вставленным файлам.

Диспетчер ссылок - это внешнее приложение, позволяющее проверять связи файла чертежа с другими файлами. Диспетчер ссылок отображает следующие свойства:

  • тип файла
  • положение
  • имя файла
  • имя
  • сохраненный путь
  • путь обнаружения
  • основной чертёж
  • основная версия

Имеется возможность просмотра списка ссылок, относящихся к чертежу, или списка ссылок одного типа.


Проверка подложек DGN с помощью Диспетчера ссылок (Процедура)

Изменение путей к файлам подложек DGN
На уровень вверх ..
Импорт файлов MicroStation DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Диспетчер ссылок и подложки DGN >
Диспетчер ссылок и подложки DGN
Понятие Процедура Краткий справочник

Проверка подложек DGN с помощью Диспетчера ссылок

  1. Выберите в ОС Windows "Пуск" [image] "Все программы" ("Программы") [image] "Autodesk" [image] "AutoCAD 2009" [image] "Диспетчер ссылок".
  2. В окне "Диспетчер ссылок" нажмите кнопку "Добавить чертежи".
  3. Выберите чертеж из диалогового окна "Добавление чертежей", а затем нажмите кнопку "Открыть".


Диспетчер ссылок и подложки DGN (Краткий справочник)

Публикация, сохранение и формирование комплекта чертежей, содержащих подложки DGN
Диспетчер ссылок и подложки DGN
Импорт файлов MicroStation DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов DGN в качестве подложек > Управление и публикация чертежей, содержащих подложки DGN > Диспетчер ссылок и подложки DGN >
Диспетчер ссылок и подложки DGN
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Импорт файлов MicroStation DGN (Понятие)

Диспетчер ссылок и подложки DGN
Импорт, вставка и открытие файлов других форматов
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Импорт файлов MicroStation DGN
Понятие Процедура Краткий справочник

Предусмотрена возможность импорта файлов чертежей MicroStation® DGN в файлы DWG.

В процессе импорта базовые данные DGN преобразуются в соответствующие данные файла DWG. Предусмотрено несколько параметров преобразования, определяющих способ обработки конкретных данных, например, текстовых элементов и внешних ссылок. Пользователи могут не только выполнять операции с текстовыми элементами и ссылками, но и выбирать единицы преобразования на основе параметров единиц DGN, а также, что особенно важно, предварительно просматривать результаты преобразования при соответствии по умолчанию или создавать собственные наборы параметров соответствия ДГНСООТВ

Обмен базовыми данными чертежей играет важную роль в совместной разработке проектов. Например, обслуживающим организациям, таким как компании по архитектурному и техническому проектированию или проектно-строительным компаниям, может потребоваться импорт картографических данных, созданных в MicroStation, в план строительной площадки, созданный в одной из программ на основе AutoCAD. При создании плана строительной площадки данные DGN могут служить точными опорными данными.

Команда ДГНИМПОРТ применима не только к файлам с расширением *.dgn. Она поддерживает все файлы DGN независимо от наличия расширения .dgn.

Сведения об ограничениях

Функции импорта и экспорта DGN предназначены для обеспечения обмена информацией между файлами MicroStation V7/V8 DGN и файлами AutoCAD DWG в полном объеме. Однако преобразование данных между двумя принципиально различными форматами неизбежно требует компромиссных решений и замены части данных.

  • Между форматами данных DWG и DGN поддерживается прямое соответствие простых геометрических объектов, например, прямых, дуг и окружностей, а также простых свойств, таких как назначение слоев.
  • К данным со встроенными элементами и к вариативным данным применяется визуальная аппроксимация. К таким данным относятся, например, текст и размеры со специальным форматированием и определения цветов, настроенные под пользователя.
  • Некоторые данные невозможно преобразовать полностью. Например, элементы, специфичные для конкретной программы, такие как поля данных или динамические блоки, могут быть представлены визуально, но не функционально.

Дополнительные сведения об области действия функции импорта применительно к объектам и другим данным MicroStation см. Таблица преобразования ДГНИМПОРТ.

Дополнительные сведения о преобразовании единиц измерения при импорте объектов MicroStation см. в Таблица соответствия единиц ДГНИМПОРТ.

Рекомендации

Приведенные ниже рекомендации, предназначенные для разработчиков чертежей MicroStation, позволяют оптимизировать перенос данных из файла формата MicroStation® DGN.

  • Для каждой модели конструкции создавайте отдельный файл
  • Не создавайте в моделях конструкций ссылки на модели листов
  • По возможности не создавайте пользовательские объекты и другие данные, не являющиеся стандартными в программе MicroStation.
  • Для свойств, определяющих цвет, стиль линии и вес линии, задавайте значение "ПоУровню"
  • По возможности применяйте простые стили линий
  • Применяйте простые узоры и стили узоров
  • Пользуйтесь шрифтами TrueType, а не шрифтами для текстов SHX
  • Применяйте к размерам и тексту определенные стили; не задавайте для стиля значение "нет".
  • По возможности применяйте простые стили размеров
  • Работайте с совместно используемыми ячейками, а не с обычными ячейками (ячейками библиотек)
  • Работайте преимущественно в одном формате - DWG или DGN; не переключайтесь между этими форматами без необходимости

При экспорте файла DGN укажите единицы преобразования (основные или вспомогательные) на основе единиц, заданных для чертежа в файле DWG. Например, если в импортируемом файле DGN в качестве основных и вспомогательных единиц заданы соответственно метры и миллиметры, а на чертеже в файле DWG требуется применять метры, в диалоговом окне "Параметры импорта DGN" необходимо выбрать основные единицы. В этом случае метры в файле DGN будут соответствовать метрам в файле DWG.


Импорт чертежа MicroStation DGN (Процедура)

Диспетчер ссылок и подложки DGN
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Импорт файлов MicroStation DGN >
Импорт файлов MicroStation DGN
Понятие Процедура Краткий справочник

Импорт чертежа MicroStation DGN

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Импорт" [image] Импорт. В командной строке введите "импорт".
  2. В диалоговом окне "Импорт файла" выберите в списке "Тип файла" значение "MicroStation DGN (*.dgn)".
  3. Найдите и выберите файл DGN для импорта или введите имя файла DGN в поле "Имя файла".
  4. Нажмите "Открыть".
  5. В диалоговом окне "Параметры импорта DGN" выберите из списка модель конструкции и укажите требуемые параметры импорта.
  6. Нажмите ОК.
Ввод команды: ДГНИМПОРТ


Импорт файлов MicroStation DGN (Краткий справочник)

Диспетчер ссылок и подложки DGN
Импорт файлов MicroStation DGN
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Импорт файлов MicroStation DGN >
Импорт файлов MicroStation DGN
Понятие Процедура Краткий справочник

Команды

ДГНИМПОРТ

Импорт данных в новый DWG-файл из файла DGN

Системные переменные

DGNIMPORTMAX

Контроль максимального количества элементов, преобразуемых при выполнении команды ДГНИМПОРТ

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление параметрами соответствия при преобразовании (Понятие)

Импорт файлов MicroStation DGN
Импорт, вставка и открытие файлов других форматов
Вставка файлов растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Для операций импорта и экспорта файлов DGN предусмотрена возможность управления параметрами соответствия при преобразовании.

Наборы параметров соответствия при преобразовании можно создавать, изменять, переименовывать и удалять с учетом стандартов оформления, принятых в конкретной компании, например, для сопоставления именам уровней в файлах DGN подходящих имен слоев файлов DWG или неподдерживаемым типам линий DGN - типа линий DWG из файла acad.lin, что позволяет упростить процедуру импорта/экспорта и одновременно минимизировать объем изменений, которые требуется вносить в импортированные или экспортированные файлы.

Диалоговое окно "Параметры соответствия DGN" отображается при нажатии кнопки "Параметры соответствия" в диалоговых окнах Параметры импорта DGNи Параметры экспорта в DGN. Можно также ввести ДГНСООТВ в командной строке.


Управление параметрами соответствия при преобразовании (Процедура)

Импорт файлов MicroStation DGN
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Создание нового набора параметров соответствия DGN

Переименование набора параметров соответствия DGN

Изменение набора параметров соответствия DGN

Удаление набора параметров соответствия DGN

Выбор типа линии из файла .lin

Добавление свойств из файла DGN

Процедура добавления свойств из файла чертежа


Создание нового набора параметров соответствия DGN (Процедура)

Управление параметрами соответствия при преобразовании
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Создание нового набора параметров соответствия DGN

  1. В диалоговом окне "Параметры импорта DGN" ("Параметры экспорта в DGN") нажмите "Параметры соответствия". Отображается диалоговое окно "Параметры соответствия DGN".
  2. Нажмите "Создать". Отображается диалоговое окно "Новые параметры соответствия".
  3. В поле "Имя параметров соответствия DGN" введите имя набора параметров соответствия.
  4. В поле "На основе" выберите набор параметров соответствия. Если не существует ни одного набора параметров соответствия, по умолчанию применяется стандартный набор.
  5. Выберите тип соответствия.
  6. Нажмите кнопку "Продолжить". Отображается диалоговое окно "Изменить параметры соответствия DGN".
  7. Укажите соответствие свойств для импорта (или экспорта) DGN.
  8. Нажмите "ОК".
Ввод команды: ДГНСООТВ


Переименование набора параметров соответствия DGN (Процедура)

Управление параметрами соответствия при преобразовании
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Переименование набора параметров соответствия DGN

  1. В диалоговом окне "Параметры соответствия DGN" выберите набор параметров соответствия, которые требуется переименовать.
    ПримечаниеЕсли выбран стандартный набор параметров соответствия, кнопка "Переименовать" не доступна.
  2. Выберите "Переименовать".
  3. Введите новое имя набора параметров соответствия.
  4. Щелкните за пределами текстового поля.

Можно также щелкнуть на имени набора параметров соответствия в списке наборов параметров соответствия правой кнопкой мыши, выбрать "Переименовать" и затем перейти к шагу 3.

Ввод команды: ДГНСООТВ


Изменение набора параметров соответствия DGN (Процедура)

Управление параметрами соответствия при преобразовании
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Изменение набора параметров соответствия DGN

  1. В диалоговом окне "Параметры соответствия DGN" выберите набор параметров соответствия, которые требуется изменить.
    ПримечаниеЕсли выбран стандартный набор параметров соответствия, кнопка "Редактирование" не доступна.
  2. Нажмите кнопку "Редактирование". Отображается диалоговое окно "Изменить параметры соответствия DGN: <набор_параметров_соответствия>".
  3. Укажите соответствие свойств для импорта (или экспорта) DGN.
  4. Нажмите "ОК".

Можно также щелкнуть на имени набора параметров соответствия в списке наборов параметров соответствия правой кнопкой мыши, выбрать "Редактирование" и затем перейти к шагу 3.

Ввод команды: ДГНСООТВ


Удаление набора параметров соответствия DGN (Процедура)

Управление параметрами соответствия при преобразовании
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Удаление набора параметров соответствия DGN

  1. В диалоговом окне "Параметры соответствия DGN" выберите набор параметров соответствия, которые требуется удалить.
    ПримечаниеЕсли выбран стандартный набор параметров соответствия, кнопка "Удалить" не доступна.
  2. Нажмите кнопку "Удалить".
  3. При отображении запроса на подтверждение удаления параметров соответствия нажмите "Да".

Можно также щелкнуть на имени набора параметров соответствия в списке наборов параметров соответствия правой кнопкой мыши и выбрать "Удалить".

Ввод команды: ДГНСООТВ


Выбор типа линии из файла .lin (Процедура)

Управление параметрами соответствия при преобразовании
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Выбор типа линии из файла .lin

  1. В диалоговом окне "Изменить параметры соответствия DGN" перейдите на вкладку "Тип линий".
  2. Щелкните на ниспадающем списке в ячейке правого столбца.
  3. Нажмите кнопку "Другой..."
  4. Для выбора типа линии из файла acad.lin (acadiso.lin) нажмите кнопку "Загрузить".

Если в диалоговом окне "Загрузка или перезагрузка типов линий" загружено несколько типов линий, укажите в диалоговом окне "Выбрать тип линии" один тип линий для заполнения ячейки. После загрузки нескольких типов линий дополнительные типы линий добавляются к раскрывающихся спискам, что позволяет выбрать их дл других ячеек непосредственно из раскрывающихся списков.


Добавление свойств из файла DGN (Процедура)

Управление параметрами соответствия при преобразовании
На уровень вверх ..
Управление параметрами соответствия при преобразовании
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Добавление свойств из файла DGN

  1. В диалоговом окне "Параметры соответствия DGN" нажмите "Редактирование".
    ПримечаниеЕсли выбран стандартный набор параметров соответствия, кнопка "Редактирование" не доступна.
  2. В диалоговом окне "Изменить параметры соответствия DGN" нажмите кнопку "Добавить свойства из файла DGN".
  3. Отображается диалоговое окно "Добавить свойства из файла DGN". Выберите файл DGN и нажмите "Открыть".

Свойства файла (без повторений) добавляются внизу столбца DGN на каждой вкладке ("Уровень", "Стиль линий", "Вес линий" и "Цвет").

ПримечаниеПовторяющиеся свойства игнорируются.
Ввод команды: ДГНСООТВ


Процедура добавления свойств из файла чертежа (Процедура)

Управление параметрами соответствия при преобразовании
На уровень вверх ..
Вставка, масштабирование и удаление растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Процедура добавления свойств из файла чертежа

  1. В диалоговом окне "Параметры соответствия DGN" нажмите "Редактирование".
    ПримечаниеЕсли выбран стандартный набор параметров соответствия, кнопка "Редактирование" не доступна.
  2. В диалоговом окне "Изменить параметры соответствия DGN" нажмите кнопку "Добавить свойства из файла чертежа".
  3. Отображается диалоговое окно "Добавить свойства из файла чертежа". Выберите файл чертежа и нажмите "Открыть".

Свойства файла (без повторений) добавляются внизу столбца DGN на каждой вкладке ("Уровень", "Стиль линий", "Вес линий" и "Цвет").

ПримечаниеПовторяющиеся свойства игнорируются.
Ввод команды: ДГНСООТВ


Управление параметрами соответствия при преобразовании (Краткий справочник)

Импорт файлов MicroStation DGN
Управление параметрами соответствия при преобразовании
Коротко о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Управление параметрами соответствия при преобразовании >
Управление параметрами соответствия при преобразовании
Понятие Процедура Краткий справочник

Команды

ДГНСООТВ

Задание папки для файла dgnsetups.ini, в котором хранятся параметры соответствия DGN

Системные переменные

DGNMAPPINGPATH

Задание папки для файла dgnsetups.ini, в котором хранятся параметры соответствия DGN

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка файлов растровых изображений

Управление параметрами соответствия при преобразовании
Импорт, вставка и открытие файлов других форматов
Коротко о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Вставка файлов растровых изображений

В чертежах можно просматривать и манипулировать растровыми изображениями и соответствующими путями файлов.

Можно добавлять растровые изображения в векторные чертежи, а затем выполнять просмотр и печать полученного файла. Благодаря использованию растровых изображений в векторных файлах, можно работать с отсканированными и полученными по факсу документами, микрофильмами, результатами аэро- и спутниковой фотосъемки, цифровыми фотографиями, создавать и вставлять в чертеж водяные знаки и логотипы, а также включать в выпускаемую документацию тонированные изображения.

Темы в этом разделе

  • Коротко о растровых изображениях
  • Вставка, масштабирование и удаление растровых изображений

    Можно добавлять к файлам чертежей ссылки на растровые изображения или удалять их или же изменять их относительные размеры.

  • Редактирование растровых изображений и их контуров

    Имеется возможность управлять контурами подрезки и видимыми свойствами растровых изображений.

  • Управление растровыми изображениями

    Имеется возможность управления и манипуляции растровыми изображениями и изменения путей к файлам изображений с помощью палитры "Внешние ссылки".

  • Настройка скорости обработки изображений

    Пути повышения производительности системы при обработке больших или множества маленьких растровых изображений.


Коротко о растровых изображениях (Понятие)

Вставка файлов растровых изображений
Вставка файлов растровых изображений
Вставка, масштабирование и удаление растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений >
Коротко о растровых изображениях
Понятие Краткий справочник

Растровые изображения представляют собой прямоугольную сетку мелких квадратиков или точек, называемых пикселами. Рассмотрим, например, фотографию дома: она составлена из множества разноцветных пикселов, которые, будучи взятыми вместе, передают его внешний вид. Пикселы растрового изображения образуют сетку.

Растровые изображения, как и многие другие объекты чертежа, можно копировать, перемещать или подрезать. Изображение можно редактировать с помощью ручек, изменять его контрастность, подрезать прямоугольными и многоугольными контурами; кроме того, изображение само может быть использовано в качестве кромок для обрезки.

Форматы файлов изображений, поддерживаемые программой, включают большинство распространенных форматов, используемых в основных областях применения приложений для работы с изображениями: компьютерная графика, обработка документов, проектирование, картография и географические информационные системы (GIS). По глубине палитры картинки могут быть монохромными, 8-битовыми в уровнях серого, а также 8- и 24-битовыми цветными. Изображения с глубиной цветности 16-бит не поддерживаются, начиная с AutoCAD 2009.

В некоторых растровых форматах существует понятие прозрачных пикселов. При включении режима прозрачности изображения программа распознает прозрачные пикселы и позволяет просматривать сквозь них графические объекты в области рисования. (В монохромных изображениях фоновые пикселы считаются прозрачными.) Прозрачные изображения могут быть черно-белыми или цветными.

ПримечаниеНесмотря на то, что расширения имен файлов перечислены в следующей таблице, формат файла определяется по его содержимому, а не по расширению.
Поддерживаемые форматы файлов изображений
Тип | Описание и версии | Расширения файлов
BMP | Растровые форматы Windows и OS/2 | ..bmp,.dib, rle
CALS-I | Mil-R-Raster I | .gp4,mil,rst,cg4, cal
FLIC | Анимация FLIC Autodesk Animator | .flc,fli
GeoSPOT | GeoSPOT (для каждого BIL-файла в той же папке должны иметься HDR-файл и PAL-файл с параметрами совмещения) | .bil
IG4 | Image Systems Group 4 | .ig4
IGS | Image Systems Grayscale | .igs
JFIF или JPEG | Joint Photographics Expert Group | .jpg или .jpeg
PCX | Рисунок PC Paintbrush Picture | .pcx
PICT | Рисунок Macintosh Picture | .pct
PNG | Portable Network Graphic (переносимая сетевая графика) | .png
RLC | Run-Length Compressed | .rlc
TARGA | Формат растровой графики фирмы True Vision | .tga
TIFF | формат TIFF (теговый формат файлов изображений) | .tif или .tiff


Коротко о растровых изображениях (Краткий справочник)

Управление параметрами соответствия при преобразовании
Коротко о растровых изображениях
Вставка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Коротко о растровых изображениях >
Коротко о растровых изображениях
Понятие Краткий справочник

Команды

ИЗОБ

Открытие палитры "Внешние ссылки"

ИЗОБВСТАВИТЬ

Вставка нового изображения в текущий чертеж

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка, масштабирование и удаление растровых изображений

Коротко о растровых изображениях
Вставка файлов растровых изображений
Вставка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений >
Вставка, масштабирование и удаление растровых изображений
Понятие Процедура

Можно добавлять к файлам чертежей ссылки на растровые изображения или удалять их или же изменять их относительные размеры.

Темы в этом разделе

  • Вставка растровых изображений

    Можно вставить в файл чертежа растровое изображение, указав путь к соответствующему файлу. Доступ к изображениям может осуществляться через Интернет.

  • Масштабирование растровых изображений

    Имеется возможность управлять размерами растрового изображения на чертеже, так чтобы оно соответствовало его масштабу.

  • Удаление растровых изображений

    Ссылку на файл изображения можно удалить из чертежа.


Вставка, масштабирование и удаление растровых изображений (Процедура)

Управление параметрами соответствия при преобразовании
Вставка, масштабирование и удаление растровых изображений
Вставка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений >
Вставка, масштабирование и удаление растровых изображений
Понятие Процедура

Вставка изображения

Для вставки и масштабирования изображения из Интернета

Вставка и масштабирование изображения

Удаление изображения


Вставка растровых изображений (Понятие)

Вставка, масштабирование и удаление растровых изображений
Вставка, масштабирование и удаление растровых изображений
Масштабирование растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений >
Вставка растровых изображений
Понятие Процедура Краткий справочник

Можно вставить в файл чертежа растровое изображение, указав путь к соответствующему файлу. Доступ к изображениям может осуществляться через Интернет.

Вставленные в файл чертежа изображения, как и внешние ссылки, в действительности не являются его составной частью. Связь чертежа и картинки устанавливается заданием пути. Можно в любой момент редактировать пути связей с изображениями и удалять их. При вставке изображений в чертеж с применением связанных путей к изображениям, а также при перетаскивании изображений на чертеж с помощью Центра управления™ размер файла чертежа увеличивается незначительно. См. раздел Добавление содержимого с помощью Центра управления.

Допускается многократная вставка в чертеж одного и того же изображения; общая стратегия здесь полностью совпадает с используемой для блоков. Каждое вхождение изображения может иметь собственный контур подрезки и отличающиеся от других вхождений значения яркости, контрастности, прозрачности и степени слияния с фоном.

ПримечаниеAutoCAD 2000, AutoCAD LT 2000, и более поздние версии не поддерживают TIFF файлы, сжатые с помощью LZW. Исключением являются англоязычные версии программ, территории США и Канады. Если необходимо вставить в чертеж TIFF файлы, которые были созданы с использованием сжатия LZW, пересохраните файлы, отключив сжатие LZW.

Доступ к растровым изображениям через Интернет

В наши дни дизайнеры и производители все чаще размещают образцы предлагаемой ими продукции в сети Интернет. Доступ к файлам изображений можно легко получить из Интернета. URL-адреса и имена файлов изображений сохраняются в чертеже.

Использование хранящихся в Интернете изображений ускоряет работу над проектами и облегчает движение чертежей по цепи "исполнитель-руководитель-заказчик". Например, архитектор, которому требуется показать заказчику, как будут выглядеть разработанные кабинеты, просит создать тонированное изображение кабинетов, разместить его на Интернет-сайте, а затем вставить изображение в файл чертежа с помощью URL-адреса; все изменения в проекте можно будет немедленно обновлять. Дополнительную информацию см. в разделе Внешние ссылки .


Вставка растровых изображений (Процедура)

Вставка, масштабирование и удаление растровых изображений
На уровень вверх ..
Вставка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Вставка растровых изображений >
Вставка растровых изображений
Понятие Процедура Краткий справочник

Вставка изображения

Для вставки и масштабирования изображения из Интернета


Вставка изображения (Процедура)

Вставка растровых изображений
На уровень вверх ..
Вставка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Вставка растровых изображений >
Вставка растровых изображений
Понятие Процедура Краткий справочник

Вставка изображения

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] Изображение. В командной строке введите "изобрегул".
  2. В диалоговом окне "Выбор файла изображения" выберите имя файла из списка или введите имя файла изображения в поле "Имя файла". Нажмите "Открыть".
  3. В диалоговом окне "Растровое изображение" задайте точку вставки, масштаб и угол поворота одним из следующих способов:
    • Установите флажок "Указать на экране", чтобы использовать устройство указания для вставки изображения в определенную точку с необходимым масштабом и под нужным углом.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".

    Для просмотра единиц измерения для изображения нажмите кнопку "Подробнее".

  4. Нажмите "ОК".
Панель:Ссылка
Ввод команды: ИЗОБВСТАВИТЬ


Для вставки и масштабирования изображения из Интернета (Процедура)

Вставка растровых изображений
На уровень вверх ..
Масштабирование растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Вставка растровых изображений >
Вставка растровых изображений
Понятие Процедура Краткий справочник

Для вставки и масштабирования изображения из Интернета

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] Изображение. В командной строке введите "изобрегул".
  2. В диалоговом окне "Выбор файла изображения" нажать кнопку "Поиск в Интернете".
  3. В окне "Просмотр Web - Открытие" ввести адрес (URL) файла изображения в поле "Поиск в".
  4. Ввести имя файла изображения в поле "Имя или URL". Нажмите "Открыть".

    Можно также выбрать изображение, нажав на нем правую кнопку мыши. Нажмите кнопку "Свойства". Можно выделить, скопировать и вставить полный URL-адрес изображения в поле "Имя файла".

  5. В диалоговом окне "Изображение" нажмите "ОК".
  6. При запросе указать точку вставки и масштаб.
Панель:Ссылка
Ввод команды: ИЗОБВСТАВИТЬ


Вставка растровых изображений (Краткий справочник)

Коротко о растровых изображениях
Вставка растровых изображений
Масштабирование растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Вставка растровых изображений >
Вставка растровых изображений
Понятие Процедура Краткий справочник

Команды

ИЗОБ

Открытие палитры "Внешние ссылки"

ИЗОБВСТАВИТЬ

Вставка нового изображения в текущий чертеж

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Масштабирование растровых изображений (Понятие)

Вставка растровых изображений
Вставка, масштабирование и удаление растровых изображений
Удаление растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений >
Масштабирование растровых изображений
Понятие Процедура Краткий справочник

Имеется возможность управлять размерами растрового изображения на чертеже, так чтобы оно соответствовало его масштабу.

Можно задать масштабный коэффициент растрового изображения при его вставке таким образом, что масштаб объектов в изображении будет соответствовать масштабу объектов в чертеже. По умолчанию в момент вставки масштаб равен 1, а единица измерения картинки не определена. В файле изображения могут храниться сведения о его экранном разрешении (в точках на дюйм, DPI), заданные, например, в ходе сканирования.

Если в изображении содержатся сведения о его разрешении, программа объединяет эти сведения с масштабным коэффициентом и единицами измерения чертежа для масштабирования изображения в чертеже. Например, если растровое изображение является отсканированной копией, масштаб которой составляет 1 дюйм на 50 футов, или 1:600, а на чертеже 1 единица представляет 1 дюйм, то в диалоговом окне "Изображение" в разделе "Масштаб" выберите "Указать на экране". Для масштабирования изображения удалите флажок параметра "Указать на экране", а затем введите 600 в поле "Масштаб". Изображение вставляется с таким масштабом, что объекты на изображении выравниваются в соответствии с объектами на чертеже.

Если сведения о разрешении вставляемого файла изображения отсутствуют, для ширины растрового изображения устанавливается значение в одну единицу. Таким образом, при вставке файла изображения его ширина равна масштабному коэффициенту растрового изображения.


Вставка и масштабирование изображения (Процедура)

Вставка растровых изображений
На уровень вверх ..
Удаление растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Масштабирование растровых изображений >
Масштабирование растровых изображений
Понятие Процедура Краткий справочник

Вставка и масштабирование изображения

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] Изображение. В командной строке введите "изобрегул".
  2. В диалоговом окне "Выбор файла изображения" выберите имя файла из списка или введите имя файла изображения в поле "Имя файла". Нажмите "Открыть".
  3. В диалоговом окне "Растровое изображение" задайте точку вставки, масштаб и угол поворота одним из следующих способов:
    • Установите флажок "Указать на экране", чтобы использовать устройство указания для вставки изображения в определенную точку с необходимым масштабом и под нужным углом.
    • Уберите флажок "Указать на экране" и введите значения в поля групп "Точка вставки", "Масштаб" или "Угол поворота".

      Для просмотра единиц измерения для изображения нажмите кнопку "Подробнее".

  4. Нажмите "ОК".
Панель:Ссылка
Ввод команды: ИЗОБВСТАВИТЬ


Масштабирование растровых изображений (Краткий справочник)

Вставка растровых изображений
Масштабирование растровых изображений
Удаление растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Масштабирование растровых изображений >
Масштабирование растровых изображений
Понятие Процедура Краткий справочник

Команды

ИЗОБ

Открытие палитры "Внешние ссылки"

ИЗОБВСТАВИТЬ

Вставка нового изображения в текущий чертеж

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Удаление растровых изображений (Понятие)

Масштабирование растровых изображений
Вставка, масштабирование и удаление растровых изображений
Редактирование растровых изображений и их контуров
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений >
Удаление растровых изображений
Понятие Процедура Краткий справочник

Ссылку на файл изображения можно удалить из чертежа.

Растровые изображения, которые больше не нужны в чертеже, следует удалять. При удалении изображения происходит стирание всех его экземпляров, описания и относящихся к нему связей (но не файла, в котором изображение хранится на диске!).

ПримечаниеСтирание отдельного экземпляра изображения и его удаление - не одно и то же. Изображение необходимо удалить из чертежа для разрыва связи между чертежом и файлом изображения.


Удаление изображения (Процедура)

Масштабирование растровых изображений
На уровень вверх ..
Редактирование растровых изображений и их контуров
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Удаление растровых изображений >
Удаление растровых изображений
Понятие Процедура Краткий справочник

Удаление изображения

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" укажите имя изображения, используя правую кнопку мыши.
  3. Выберите "Удалить".

    Связь между чертежом и растровым изображением разрывается, и все экземпляры изображения удаляются из чертежа.

Ввод команды: ВНССЫЛКИ
Панель:Ссылка


Удаление растровых изображений (Краткий справочник)

Масштабирование растровых изображений
Удаление растровых изображений
Включение и отключение контуров растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Вставка, масштабирование и удаление растровых изображений > Удаление растровых изображений >
Удаление растровых изображений
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Редактирование растровых изображений и их контуров

Удаление растровых изображений
Вставка файлов растровых изображений
Включение и отключение контуров растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений >
Редактирование растровых изображений и их контуров
Понятие Процедура

Имеется возможность управлять контурами подрезки и видимыми свойствами растровых изображений.

Темы в этом разделе

  • Включение и отключение контуров растровых изображений

    Имеется возможность управления видимостью контуров подрезки растрового изображения на чертеже.

  • Подрезка растровых изображений

    Изображения на чертеже можно подрезать с помощью многоугольного контура.

  • Изменение яркости, контрастности и степени слияния с фоном растрового изображения

    Для улучшения восприятия или достижения специальных эффектов некоторые видимые свойства растровых изображений на чертеже можно изменять.

  • Изменение цвета и прозрачности монохромных изображений

    В монохромных изображениях различают цвета переднего плана и фона. Имеется возможность изменять цвет переднего плана, а также включать и отключать прозрачность фона.


Редактирование растровых изображений и их контуров (Процедура)

Удаление растровых изображений
Редактирование растровых изображений и их контуров
Включение и отключение контуров растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров >
Редактирование растровых изображений и их контуров
Понятие Процедура

Включение и отключение видимости контуров изображений

Подрезка изображения

Изменение контура подрезки изображения

Показа или скрытие подрезанной части изображения

Удаление контура подрезки изображения

Регулировка яркости, контрастности и слияния с фоном

Изменение цвета и прозрачности монохромного изображения

Изменение только прозрачности монохромного изображения


Включение и отключение контуров растровых изображений (Понятие)

Редактирование растровых изображений и их контуров
Редактирование растровых изображений и их контуров
Подрезка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров >
Включение и отключение контуров растровых изображений
Понятие Процедура Краткий справочник

Имеется возможность управления видимостью контуров подрезки растрового изображения на чертеже.

Видимость границы растровой картинки может быть отключена. Скрытие контура изображения предотвращает печать контура или ее отображение на экране. Кроме того, скрытие контура изображения не позволяет выбирать его устройством указания, а это гарантирует, что изображение не будет непреднамеренно сдвинуто или изменено. Однако изображения все же можно выбирать, если они не находятся на заблокированном слое, например, если изображение является частью именованного набора объектов, выбранных с использованием параметра "Все". Если контуры изображения скрыты, подрезанные изображения все же отображаются в заданных для них пределах; операция относится только к контурам. Включение и отключение контуров изображения относится ко всем изображениям, вставленным в чертеж.

ПримечаниеПри отключенных контурах выбор изображений указанием или с помощью опции "Рамка" команды ВЫБОР невозможен.


Включение и отключение видимости контуров изображений (Процедура)

Редактирование растровых изображений и их контуров
На уровень вверх ..
Подрезка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Включение и отключение контуров растровых изображений >
Включение и отключение контуров растровых изображений
Понятие Процедура Краткий справочник

Включение и отключение видимости контуров изображений

  1. Выберите пункт меню "Редактирование" [image] "Объект" [image] "Изображение" [image] "Контур".В командной строке введите "изобконтур".
  2. Для скрытия контуров изображения введите 0; для показа контуров изображения на экране и вывода их на печать введите 1; для отображения контуров изображения без вывода на печать введите 2.
Панель:Ссылка
Ввод команды: ИЗОБКОНТУР


Включение и отключение контуров растровых изображений (Краткий справочник)

Удаление растровых изображений
Включение и отключение контуров растровых изображений
Подрезка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Включение и отключение контуров растровых изображений >
Включение и отключение контуров растровых изображений
Понятие Процедура Краткий справочник

Команды

ИЗОБКОНТУР

Управление видимостью рамок изображения и выводом их на печать

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подрезка растровых изображений (Понятие)

Включение и отключение контуров растровых изображений
Редактирование растровых изображений и их контуров
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров >
Подрезка растровых изображений
Понятие Процедура Краткий справочник

Изображения на чертеже можно подрезать с помощью многоугольного контура.

Скорость перерисовки чертежа можно повысить, ограничив имеющиеся в нем растровые изображения так, чтобы на экране остались видны только нужные их части. Определить часть изображения, которую требуется отображать и выводить на печать, можно путем подрезки изображения. Контуром может служить прямоугольник или двумерный (2D) многоугольник, вершины которого лежат внутри границы изображения. Контур подрезки для каждого вхождения картинки может быть только один; но для разных вхождений разрешается задание отдельных контуров. AutoCAD позволяет изменять контуры подрезки изображений.

Имеется возможность отображать подрезанное изображение с использованием контура подрезки или же можно отключить контур подрезки, чтобы отображать изображение в его исходных границах.

Контур подрезки изображения можно удалить. После его удаления изображение восстанавливается на экране в своих исходных границах.

ПримечаниеДля выполнения подрезки контур изображения должен быть видимым. См. раздел Включение и отключение контуров растровых изображений.


Подрезка растровых изображений (Процедура)

Включение и отключение контуров растровых изображений
На уровень вверх ..
Подрезка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Подрезка растровых изображений >
Подрезка растровых изображений
Понятие Процедура Краткий справочник

Подрезка изображения

Изменение контура подрезки изображения

Показа или скрытие подрезанной части изображения

Удаление контура подрезки изображения


Подрезка изображения (Процедура)

Подрезка растровых изображений
На уровень вверх ..
Подрезка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Подрезка растровых изображений >
Подрезка растровых изображений
Понятие Процедура Краткий справочник

Подрезка изображения

  1. Выберите пункт меню "Редактирование" [image] "Подрезка" [image] "Изображение".В командной строке введите "изобрез".
  2. Выберите подрезаемое изображение, указав его границу.
  3. Введите н (Новый контур).
  4. Введите м (Многоугольный) или п (Прямоугольный); затем очертите контур подрезки.

    Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

Панель:Ссылка
Ввод команды: ИЗОБРЕЗ
Контекстное меню:Выберите изображение и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Подрезка".


Изменение контура подрезки изображения (Процедура)

Подрезка растровых изображений
На уровень вверх ..
Подрезка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Подрезка растровых изображений >
Подрезка растровых изображений
Понятие Процедура Краткий справочник

Изменение контура подрезки изображения

  1. Выберите пункт меню "Редактирование" [image] "Подрезка" [image] "Изображение".В командной строке введите "изобрез".
  2. Выберите подрезаемое изображение, указав его границу.
  3. Введите н (Новый контур).
  4. Введите н (Нет) или д (Да) в ответ на запрос об удалении старого контура.
  5. Введите м (Многоугольный) или п (Прямоугольный); затем очертите новый контур в пределах изображения.

    Задание многоугольного контура производится последовательным указанием его вершин. Для завершения построения многоугольника нажмите клавишу ENTER или правую кнопку мыши в любой точке области чертежа.

    Контуры подрезки могут редактироваться с помощью ручек. См. раздел Редактирование с помощью ручек.

Панель:Ссылка
Ввод команды: ИЗОБРЕЗ
Контекстное меню:Выберите изображение и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Подрезка".


Показа или скрытие подрезанной части изображения (Процедура)

Подрезка растровых изображений
На уровень вверх ..
Подрезка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Подрезка растровых изображений >
Подрезка растровых изображений
Понятие Процедура Краткий справочник

Показа или скрытие подрезанной части изображения

  1. Выберите подрезанное изображение, часть которого требуется показать или скрыть.
  2. Нажмите правую кнопку мыши в области чертежа. Нажмите кнопку "Свойства".
  3. На "Палитре свойств" выберите "Да" или "Нет" в списке "Показ изображения".
Панель:Стандартная
Ввод команды: ОКОНСВ


Удаление контура подрезки изображения (Процедура)

Подрезка растровых изображений
На уровень вверх ..
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Подрезка растровых изображений >
Подрезка растровых изображений
Понятие Процедура Краткий справочник

Удаление контура подрезки изображения

  1. Выберите пункт меню "Редактирование" [image] "Подрезка" [image] "Изображение".В командной строке введите "изобрез".
  2. Выберите подрезанное изображение, содержащее контур, который требуется удалить.
  3. Введите у (Удалить).

    Контур подрезки удаляется; изображение восстанавливается в исходных границах.

Панель:Ссылка
Ввод команды: ИЗОБРЕЗ
Контекстное меню:Выберите изображение и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Подрезка".


Подрезка растровых изображений (Краткий справочник)

Включение и отключение контуров растровых изображений
Подрезка растровых изображений
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Подрезка растровых изображений >
Подрезка растровых изображений
Понятие Процедура Краткий справочник

Команды

ИЗОБРЕЗ

Использование контуров подрезки для определения подобласти объекта изображения

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение яркости, контрастности и степени слияния с фоном растрового изображения (Понятие)

Подрезка растровых изображений
Редактирование растровых изображений и их контуров
Изменение цвета и прозрачности монохромных изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров >
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Понятие Процедура Краткий справочник

Для улучшения восприятия или достижения специальных эффектов некоторые видимые свойства растровых изображений на чертеже можно изменять.

Имеется возможность регулировать яркость, контрастность и степень слияния с фоном отдельного изображения как на экране, так и при выводе на печать. Эти изменения не влияют на параметры исходного файла растрового изображения и другие экземпляры изображения на чертеже. При регулировке яркости картинка становится ярче или темнее. Регулировка контрастности в некоторых случаях повышает читаемость низкокачественных изображений. Регулировка слияния с фоном полезна, если векторные объекты чертежа должны выделяться на фоне изображений; она, в частности, используется при создании водяных знаков во время печати.

Для монохромных изображений регулировка яркости, контрастности и слияния с фоном не разрешена. Находящееся на экране изображение сливается с цветом фона экрана, а при выводе на печать - с белым цветом бумаги.


Регулировка яркости, контрастности и слияния с фоном (Процедура)

Подрезка растровых изображений
На уровень вверх ..
Изменение цвета и прозрачности монохромных изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Изменение яркости, контрастности и степени слияния с фоном растрового изображения >
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Понятие Процедура Краткий справочник

Регулировка яркости, контрастности и слияния с фоном

  1. Выберите пункт меню "Редактировать" [image] "Объект" [image] "Изображение" [image] "Регулировка".В командной строке введите "изобрегул".
  2. Выберите изображение для редактирования.
  3. В диалоговом окне "Регулировка изображения" настройте яркость, контрастность и слияние с фоном, используя соответствующие шкалы с движками или непосредственно вводя значения в поля.

    По умолчанию и яркость, и контрастность имеют значение 50. Его можно изменять в диапазоне от 0 до 100. Степень слияния с фоном по умолчанию установлена в 0. Ее максимальное значение равно 100.

  4. Нажмите "ОК".
Панель:Ссылка
Ввод команды: ИЗОБРЕГУЛ
Контекстное меню:Выберите изображение и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Регулировка".


Изменение яркости, контрастности и степени слияния с фоном растрового изображения (Краткий справочник)

Подрезка растровых изображений
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Изменение цвета и прозрачности монохромных изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Изменение яркости, контрастности и степени слияния с фоном растрового изображения >
Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Понятие Процедура Краткий справочник

Команды

ИЗОБРЕГУЛ

Регулировка яркости, контрастности и степени слияния с фоном изображений

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение цвета и прозрачности монохромных изображений (Понятие)

Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Редактирование растровых изображений и их контуров
Управление растровыми изображениями
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров >
Изменение цвета и прозрачности монохромных изображений
Понятие Процедура Краткий справочник

В монохромных изображениях различают цвета переднего плана и фона. Имеется возможность изменять цвет переднего плана, а также включать и отключать прозрачность фона.

В монохромных изображениях присутствуют всего два цвета: цвет переднего плана и цвет фона. При вставке такого изображения пикселы, окрашенные в файле в цвет переднего плана, изменяют цвет на установленный текущим в AutoCAD. В дополнение к общим для всех типов картинок операциям редактирования, описанным выше, у монохромных изображений допускается изменение цвета переднего плана и включение/отключение прозрачности фона.

ПримечаниеМонохромные изображения и их границы всегда имеют один и тот же цвет.


Изменение цвета и прозрачности монохромных изображений (Процедура)

Изменение яркости, контрастности и степени слияния с фоном растрового изображения
На уровень вверх ..
Изменение цвета и прозрачности монохромных изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Изменение цвета и прозрачности монохромных изображений >
Изменение цвета и прозрачности монохромных изображений
Понятие Процедура Краткий справочник

Изменение цвета и прозрачности монохромного изображения

Изменение только прозрачности монохромного изображения


Изменение цвета и прозрачности монохромного изображения (Процедура)

Изменение цвета и прозрачности монохромных изображений
На уровень вверх ..
Изменение цвета и прозрачности монохромных изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Изменение цвета и прозрачности монохромных изображений >
Изменение цвета и прозрачности монохромных изображений
Понятие Процедура Краткий справочник

Изменение цвета и прозрачности монохромного изображения

  1. Выберите изображение для редактирования.
  2. Нажмите правую кнопку мыши в области чертежа. Выберите "Свойства".
  3. Для изменения цвета изображения на палитре свойств выберите "Цвет".
  4. В списке цветов выберите цвет или воспользоваться пунктом "Выбор цвета" для вызова диалогового окна "Выбор цвета". В диалоговом окне "Выбор цвета" укажите цвет. Нажмите "ОК".
  5. Для переключения состояния прозрачности фона выбранного изображения выберите "Да" или "Нет" в списке "Прозрачность".
Панель:Стандартная
Ввод команды: ОКОНСВ


Изменение только прозрачности монохромного изображения (Процедура)

Изменение цвета и прозрачности монохромных изображений
На уровень вверх ..
Управление растровыми изображениями
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Изменение цвета и прозрачности монохромных изображений >
Изменение цвета и прозрачности монохромных изображений
Понятие Процедура Краткий справочник

Изменение только прозрачности монохромного изображения

  1. Выберите пункт меню "Редактирование" [image] "Объект" [image] "Изображение" [image] "Прозрачность".В командной строке введите "прозрачность".
  2. Выберите изображение для редактирования.

    Чтобы изменить фон выбранного изображения на прозрачный, введите вкл. Введите откл, чтобы изменить фон на непрозрачный.

Панель:Ссылка
Ввод команды: ПРОЗРАЧНОСТЬ
Контекстное меню:Выберите изображение и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Прозрачность".


Изменение цвета и прозрачности монохромных изображений (Краткий справочник)

Изменение яркости, контрастности и степени слияния с фоном растрового изображения
Изменение цвета и прозрачности монохромных изображений
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Редактирование растровых изображений и их контуров > Изменение цвета и прозрачности монохромных изображений >
Изменение цвета и прозрачности монохромных изображений
Понятие Процедура Краткий справочник

Команды

ОКНОСВ

Управление свойствами объектов

ПРОЗРАЧНОСТЬ

Управление прозрачностью фоновых пикселов растровых изображений

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление растровыми изображениями

Изменение цвета и прозрачности монохромных изображений
Вставка файлов растровых изображений
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений >
Управление растровыми изображениями
Понятие Процедура

Имеется возможность управления и манипуляции растровыми изображениями и изменения путей к файлам изображений с помощью палитры "Внешние ссылки".

Темы в этом разделе

  • Просмотр сведений о растровых изображениях

    Можно просматривать относящуюся к файлам информацию о растровых изображениях, вставляемых в чертеж. Также можно загружать и выгружать изображения и проводить другие операции с палитры "Внешние ссылки".

  • Присвоение имен-описаний растровым изображениям

    Если для идентификации изображения недостаточно только имени файла, на палитре "Внешние ссылки" можно добавить к нему имя-описание.

  • Изменение путей к файлам растровых изображений

    С помощью палитры "Внешние ссылки" можно изменить путь к файлу вставленного растрового изображения или отыскать файл для изображения в положении "Не найдено".


Управление растровыми изображениями (Процедура)

Изменение цвета и прозрачности монохромных изображений
Управление растровыми изображениями
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями >
Управление растровыми изображениями
Понятие Процедура

Просмотр списка изображений, вставленных в чертеж

Отображение имен изображений и уровней их вложения в ссылки на файлы DWG и блоки

Просмотр изображения и подробных сведений о файле

Предварительный просмотр еще не вставленного изображения

Просмотра сведений об изображении в текстовом окне

Изменение имени изображения

Изменение пути к изображению


Просмотр сведений о растровых изображениях (Понятие)

Управление растровыми изображениями
Управление растровыми изображениями
Присвоение имен-описаний растровым изображениям
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Можно просматривать относящуюся к файлам информацию о растровых изображениях, вставляемых в чертеж. Также можно загружать и выгружать изображения и проводить другие операции с палитры "Внешние ссылки".

На палитре "Внешние ссылки" можно просматривать сведения об изображениях в области "Вхождения файлов" или в виде списка, или в режиме древовидной структуры. Способ отображения информации на палитре "Внешние ссылки" выбирается кнопками "Список" или "Дерево" в верхнем правом углу. В режиме списка отображаются имя каждого изображения на чертеже, статус его загрузки, размер, дата последнего изменения и путь поиска файла. В режиме просмотра дерева изображения представлены в рамках иерархической структуры, отображающей уровень их вложенности в чертежи, на которые сделаны ссылки, и блоки. Положение, размер и иная информация отображаются ниже, в области "Подробности".

Оба режима просмотра позволяют просматривать сведения об изображении, вставлять изображения и удалять их, производить выгрузку и повторную загрузку, осуществлять поиск изображения и сохранять его по новому пути.

Работа с режимом списка

В режиме просмотра списка перечисляются изображения и другие внешние ссылки, вставленные в текущий чертеж, но нет никакой информации о количестве экземпляров. Этот режим установлен по умолчанию. Внешние ссылки можно отсортировать по категориям нажатием по заголовкам столбцов. Для изменения ширины столбца необходимо установить курсор на вертикальную границу, разделяющую заголовки столбцов, и перетащить ее влево или вправо.

В список включаются следующие сведения:

  • имя изображения или выбранной внешней ссылки
  • положение (загружено, выгружено или не найдено)
  • размер файла
  • тип файла
  • дата и время последнего сохранения
  • сохраненный путь

Если изображение не обнаружено, для него указывается статус "Не найдено". Изображение со статусом "Не найдено" представляется в чертеже только своим контуром, даже если в команде ИЗОБКОНТУР установлен параметр "Откл". Если на изображение нет ссылок, то его экземпляры в чертеж не вставляются. Если изображение не загружено, его положение - "Выгружено". Изображения в положении "Не найдено" или "Выгружено" на чертеже не отображаются.

Работа с режимом дерева

В режиме просмотра дерева файлы, на которые имеются ссылки, перечисляются в той последовательности, в которой они вставлялись в чертеж. В большинстве случаев файл изображения связывается непосредственно с чертежом и упоминается на верхнем уровне. Однако если ссылка на файл DWG или блок содержит связанное изображение, отображаются дополнительные уровни.

Просмотр подробных сведений о файле изображения

В нижних окнах палитры "Внешние ссылки" можно производить предварительный просмотр выбранного изображения или просматривать сведения о файлах изображений, среди которых:

  • имя изображения
  • сохраненный путь
  • активный путь (по которому изображение найдено)
  • дата создания файла
  • размер файла
  • тип файла
  • цвет
  • глубина цветности
  • размеры изображения (ширина и высота в пикселах, разрешение и размеры при вставке по умолчанию)

Просмотр сведений об изображениях в текстовом окне

Сведения об изображении можно просмотреть в командной строке. С помощью командной строки можно просмотреть следующую информацию об изображениях: имя изображения, путь к изображению, количество определений и количество экземпляров изображений, вставленных в чертеж.


Просмотр сведений о растровых изображениях (Процедура)

Управление растровыми изображениями
На уровень вверх ..
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Просмотр сведений о растровых изображениях >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Просмотр списка изображений, вставленных в чертеж

Отображение имен изображений и уровней их вложения в ссылки на файлы DWG и блоки

Просмотр изображения и подробных сведений о файле

Предварительный просмотр еще не вставленного изображения

Просмотра сведений об изображении в текстовом окне


Просмотр списка изображений, вставленных в чертеж (Процедура)

Просмотр сведений о растровых изображениях
На уровень вверх ..
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Просмотр сведений о растровых изображениях >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Просмотр списка изображений, вставленных в чертеж

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Вид".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите изображение и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Внешние ссылки".


Отображение имен изображений и уровней их вложения в ссылки на файлы DWG и блоки (Процедура)

Просмотр сведений о растровых изображениях
На уровень вверх ..
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Просмотр сведений о растровых изображениях >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Отображение имен изображений и уровней их вложения в ссылки на файлы DWG и блоки

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" нажмите кнопку "Дерево".
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Просмотр изображения и подробных сведений о файле (Процедура)

Просмотр сведений о растровых изображениях
На уровень вверх ..
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Просмотр сведений о растровых изображениях >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Просмотр изображения и подробных сведений о файле

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите файл изображения.
  3. Если панель видов не открыта, нажмите кнопку "Просмотр".

    На экран выводится образец изображения.

  4. Для просмотра сведений о файле нажмите кнопку "Подробнее".

    Отображаются сведения о файле (размер изображения).

Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Предварительный просмотр еще не вставленного изображения (Процедура)

Просмотр сведений о растровых изображениях
На уровень вверх ..
Просмотр сведений о растровых изображениях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Просмотр сведений о растровых изображениях >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Предварительный просмотр еще не вставленного изображения

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Ссылки" [image] Изображение. В командной строке введите "изобрегул".
  2. В диалоговом окне "Выбор файла изображения" выделить файл, который нужно просмотреть.

    Если изображение не отображается в окне предварительного просмотра, нажмите кнопку "Показать образец".

  3. Нажмите "Открыть".
  4. В диалоговом окне "Изображение" нажмите "Подробнее".

    На экране появляются сведения о файле изображения.

Панель:Ссылка
Ввод команды: ИЗОБВСТАВИТЬ


Просмотра сведений об изображении в текстовом окне (Процедура)

Просмотр сведений о растровых изображениях
На уровень вверх ..
Присвоение имен-описаний растровым изображениям
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Просмотр сведений о растровых изображениях >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Просмотра сведений об изображении в текстовом окне

  1. В командной строке введите -изоб.
  2. Введите ? (список).
  3. Нажмите ENTER для перечисления всех изображений.

    В текстовом окне сведения об изображении отображаются в виде списка.


Просмотр сведений о растровых изображениях (Краткий справочник)

Изменение цвета и прозрачности монохромных изображений
Просмотр сведений о растровых изображениях
Присвоение имен-описаний растровым изображениям
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Просмотр сведений о растровых изображениях >
Просмотр сведений о растровых изображениях
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ИЗОБВСТАВИТЬ

Вставка нового изображения в текущий чертеж

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Присвоение имен-описаний растровым изображениям (Понятие)

Просмотр сведений о растровых изображениях
Управление растровыми изображениями
Изменение путей к файлам растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями >
Присвоение имен-описаний растровым изображениям
Понятие Процедура Краткий справочник

Если для идентификации изображения недостаточно только имени файла, на палитре "Внешние ссылки" можно добавить к нему имя-описание.

Имена изображений не обязательно такие же, как и имена файлов изображений. При вставке изображения в чертеж в качестве его имени программа использует имя файла без расширения. Имена изображений хранятся в символьных таблицах чертежа; поэтому операция изменения имени изображения никак не отражается на имени файла. Имена фалов изображений могут содержать до 255 символов. Кроме букв и цифр имена могут содержать пробелы и любые специальные символы, не используемые Microsoft® Windows® или AutoCAD в других целях.

При вставке изображений с одинаковыми именами из разных папок к их именам добавляются номера.


Изменение имени изображения (Процедура)

Просмотр сведений о растровых изображениях
На уровень вверх ..
Изменение путей к файлам растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Присвоение имен-описаний растровым изображениям >
Присвоение имен-описаний растровым изображениям
Понятие Процедура Краткий справочник

Изменение имени изображения

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки", в области сведений, выберите имя изображения и отредактируйте его.
Панель:Ссылка
Ввод команды: ВНССЫЛКИ


Присвоение имен-описаний растровым изображениям (Краткий справочник)

Просмотр сведений о растровых изображениях
Присвоение имен-описаний растровым изображениям
Изменение путей к файлам растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Присвоение имен-описаний растровым изображениям >
Присвоение имен-описаний растровым изображениям
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение путей к файлам растровых изображений (Понятие)

Присвоение имен-описаний растровым изображениям
Управление растровыми изображениями
Настройка скорости обработки изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями >
Изменение путей к файлам растровых изображений
Понятие Процедура Краткий справочник

С помощью палитры "Внешние ссылки" можно изменить путь к файлу вставленного растрового изображения или отыскать файл для изображения в положении "Не найдено".

Если открыть чертеж со вставленным изображением, путь выбранного изображения появляется на палитре "Внешние ссылки" в области сведений в поле "Обнаружен в...". Отображаемый путь - это фактическое местоположение файла изображения. В поле "Сохраненный путь" отображается путь, по которому находился файл изображения на момент вставки.

Для обнаружения файла изображения программа выполняет поиск путей и папок в следующей последовательности.

  • Путь, указанный при вставке изображения
  • Папка, в которой хранится текущий чертеж
  • Стандартные пути поиска файлов проектов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Стандартные пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, указанная в ярлыке программы

Если в ходе открытия чертежа какое-либо изображение не найдено ни по сохраненному пути, ни по любому из заданных путей поиска, оно получает положение "Не найдено" в списке изображений палитры "Внешние ссылки", а поле свойства "Обнаружено в" для него остается незаполненным.

Можно удалить путь из имени файла или задать относительный путь редактированием свойств "Обнаружено в" и последующего нажатия "ОК" в диалоговом окне "Выбор файла изображения".

Подробнее о работе с полными путями, относительными путями и именами проектов см. Задание путей к внешним чертежам .


Изменение пути к изображению (Процедура)

Присвоение имен-описаний растровым изображениям
На уровень вверх ..
Настройка скорости обработки изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Изменение путей к файлам растровых изображений >
Изменение путей к файлам растровых изображений
Понятие Процедура Краткий справочник

Изменение пути к изображению

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" выберите изображение, путь к которому требуется изменить.
  3. В области сведений нажмите кнопку "Обзор" в группе "Обнаружено в".
  4. В диалоговом окне "Выбор файла изображения" перейдите к новому пути. Нажмите ОК.

    В свойствах "Обнаружено в" отображается новый путь.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите изображение и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Внешняя ссылка".


Изменение путей к файлам растровых изображений (Краткий справочник)

Присвоение имен-описаний растровым изображениям
Изменение путей к файлам растровых изображений
Загрузка и выгрузка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Управление растровыми изображениями > Изменение путей к файлам растровых изображений >
Изменение путей к файлам растровых изображений
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

PROJECTNAME

Присвоение имени проекта текущему чертежу

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка скорости обработки изображений

Изменение путей к файлам растровых изображений
Вставка файлов растровых изображений
Загрузка и выгрузка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений >
Настройка скорости обработки изображений
Понятие Процедура

Пути повышения производительности системы при обработке больших или множества маленьких растровых изображений.

Темы в этом разделе

  • Загрузка и выгрузка растровых изображений
  • Увеличение скорости вывода растровых изображений на экран

    Для увеличения скорости вывода изображений на экран можно изменить качество вывода изображений, скрыть не используемые в настоящее время изображения, использовать мозаичные изображения или отключить подсветку изображений.


Настройка скорости обработки изображений (Процедура)

Изменение путей к файлам растровых изображений
Настройка скорости обработки изображений
Загрузка и выгрузка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений >
Настройка скорости обработки изображений
Понятие Процедура

Выгрузка и повторная загрузка изображения

Изменения видимости отдельных экземпляров изображения

Изменение качества представления изображений

Скрытие и повторный вывод изображения


Загрузка и выгрузка растровых изображений (Понятие)

Настройка скорости обработки изображений
Настройка скорости обработки изображений
Увеличение скорости вывода растровых изображений на экран
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений >
Загрузка и выгрузка растровых изображений
Понятие Процедура Краткий справочник

Производительность работы можно повысить путем выгрузки из чертежа изображений, если они не требуются в данном сеансе работы с чертежом. Выгруженные изображения не выводятся ни на экран, ни на печать; отображается только контур изображения. С хранящейся в чертеже связью, однако, никаких изменений не происходит. Если для открытия нескольких вставленных на чертеж изображений недостаточно памяти, изображения выгружаются автоматически.

Для загрузки ранее выгруженных изображений, а также для обновления загруженных изображений путем повторной загрузки изображения из файла по заданному пути, служит кнопка "Обновить" палитры "Внешние ссылки". Если чертеж был закрыт после выгрузки изображения, файл изображения не будет загружаться при следующем открытии чертежа. Его необходимо загрузить повторно.


Загрузка и выгрузка растровых изображений (Процедура)

Настройка скорости обработки изображений
На уровень вверх ..
Загрузка и выгрузка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Загрузка и выгрузка растровых изображений >
Загрузка и выгрузка растровых изображений
Понятие Процедура Краткий справочник

Выгрузка и повторная загрузка изображения

Изменения видимости отдельных экземпляров изображения


Выгрузка и повторная загрузка изображения (Процедура)

Загрузка и выгрузка растровых изображений
На уровень вверх ..
Загрузка и выгрузка растровых изображений
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Загрузка и выгрузка растровых изображений >
Загрузка и выгрузка растровых изображений
Понятие Процедура Краткий справочник

Выгрузка и повторная загрузка изображения

  1. Выберите пункт меню "Вставить" [image] "Внешние ссылки".В командной строке введите "внссылки".
  2. На палитре "Внешние ссылки" в области "Вхождения файлов" с помощью правой кнопки мыши выберите имя изображения, а затем нажмите "Выгрузить" или "Обновить".

    Статус изображения изменяется в зависимости от выполненной операции.

    Операции выгрузки и повторной загрузки действуют на все экземпляры выбранных вставленных изображений.

Панель:Ссылка
Ввод команды: ВНССЫЛКИ
Контекстное меню:Выберите изображение для загрузки или выгрузки и щелкните в области чертежа правой кнопкой мыши. Выберите "Изображение" [image] "Внешние ссылки".


Изменения видимости отдельных экземпляров изображения (Процедура)

Загрузка и выгрузка растровых изображений
На уровень вверх ..
Увеличение скорости вывода растровых изображений на экран
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Загрузка и выгрузка растровых изображений >
Загрузка и выгрузка растровых изображений
Понятие Процедура Краткий справочник

Изменения видимости отдельных экземпляров изображения

  1. Выберите изображения, отображение которых требуется переключить.
  2. Нажмите правую кнопку мыши в области чертежа. Нажмите кнопку "Свойства".
  3. На "Палитре свойств" выберите "Да" или "Нет" в списке "Показ изображения".
Панель:Стандартная
Ввод команды: ОКНОСВ


Загрузка и выгрузка растровых изображений (Краткий справочник)

Изменение путей к файлам растровых изображений
Загрузка и выгрузка растровых изображений
Увеличение скорости вывода растровых изображений на экран
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Загрузка и выгрузка растровых изображений >
Загрузка и выгрузка растровых изображений
Понятие Процедура Краткий справочник

Команды

ВНССЫЛКИ

Открытие палитры "Внешние ссылки"

ОКНОСВ

Управление свойствами объектов

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Увеличение скорости вывода растровых изображений на экран (Понятие)

Загрузка и выгрузка растровых изображений
Настройка скорости обработки изображений
Вставка файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений >
Увеличение скорости вывода растровых изображений на экран
Понятие Процедура Краткий справочник

Для увеличения скорости вывода изображений на экран можно изменить качество вывода изображений, скрыть не используемые в настоящее время изображения, использовать мозаичные изображения или отключить подсветку изображений.

Для повышения скорости вывода изображений на экран можно изменить уровень качества их представления с высокого (оно принято по умолчанию) на черновое. Изображения, имеющие черновое качество, выглядят более зернистыми (в зависимости от типа файла изображения), однако загружаются они быстрее, чем высококачественные изображения.

На вкладке "Экран" диалогового окна "Настройка" имеется ряд параметров, управляющих качеством показа изображений при использовании точной цветопередачи (24 или 32 бита на пиксел). При отображении изображений с оптимальным качеством время, необходимое для регенерации, значительно увеличивается. Для того чтобы повысить производительность при работе с чертежом, следует установить меньшую глубину цветности в системных настройках экрана.

Для повышения скорости перерисовки объектов можно также воспользоваться функцией скрытия растровых картинок, которые больше не потребуются в данном сеансе работы. Скрытые изображения не выводятся ни на экран, ни на печать; видны только их контуры. Положение пользовательской системы координат (ПСК) на текущем видовом экране никак не влияет на скрытие изображений.

Работа с мозаичными изображениями

Мозаичные изображения представляют собой маленькие части (набор плиток) больших изображений, загрузка которых выполняется быстрее, чем немозаичных изображений. При редактировании или изменении свойств изображения осуществляется регенерация только измененной части, что способствует экономии времени. Единственным мозаичным форматом, который поддерживается программой, является TIFF (Tagged Image File Format - теговый формат файлов изображений). Процедура чтения TIFF-файлов обрабатывает все стандартные глубины цветности:

  • монохромные (1 бит на пиксел)
  • в оттенках серого и с индексацией цветов (8 бит на пиксел)
  • с полной палитрой (24 или 32 бита на пиксел)

Мозаичные TIFF-изображения могут быть порождены большинством программ сканирования. Размер фрагментов мозаики должен составлять не меньше 64 x 64 пиксела и не больше 512 x 512 пикселов. Сторонние разработчики предлагают драйверы и для других мозаичных графических форматов, таких как CALS Type II.

Отключение подсветки изображения при выборе

Управление стилем подсветки растровых изображений при выборе (все изображение или только его контуры) осуществляется с помощью опции "Подсвечивать только контуры растра" на вкладке "Экран" диалогового окна "Настройка". Это значение можно задайте с помощью системной переменной IMAGEHLT. По умолчанию IMAGEHLT равна 0; это означает, что подсвечиваются только контуры растрового изображения. Отключение подсветки всего изображения ускоряет его обработку.


Увеличение скорости вывода растровых изображений на экран (Процедура)

Загрузка и выгрузка растровых изображений
На уровень вверх ..
Увеличение скорости вывода растровых изображений на экран
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Увеличение скорости вывода растровых изображений на экран >
Увеличение скорости вывода растровых изображений на экран
Понятие Процедура Краткий справочник

Изменение качества представления изображений

Скрытие и повторный вывод изображения


Изменение качества представления изображений (Процедура)

Увеличение скорости вывода растровых изображений на экран
На уровень вверх ..
Увеличение скорости вывода растровых изображений на экран
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Увеличение скорости вывода растровых изображений на экран >
Увеличение скорости вывода растровых изображений на экран
Понятие Процедура Краткий справочник

Изменение качества представления изображений

  1. Выберите пункт меню "Редактирование" [image] "Объект" [image] "Изображение" [image] "Качество".В командной строке введите "изобкачество".
  2. Введите ч (Черновое) или в (Высокое).

    Изображение перерисовывается с заданным качеством.

Панель:Ссылка
Ввод команды: ИЗОБКАЧЕСТВО


Скрытие и повторный вывод изображения (Процедура)

Увеличение скорости вывода растровых изображений на экран
На уровень вверх ..
Вставка файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Увеличение скорости вывода растровых изображений на экран >
Увеличение скорости вывода растровых изображений на экран
Понятие Процедура Краткий справочник

Скрытие и повторный вывод изображения

  1. Выберите изображение для редактирования.
  2. Нажмите правую кнопку мыши в области чертежа. Выберите "Свойства".
  3. На "Палитре свойств" выберите "Да" или "Нет" в списке "Показ изображения", чтобы показать или скрыть изображение.
  4. Для переключения состояния прозрачности фона выбранного изображения выберите "Да" или "Нет" в списке "Прозрачность".
Панель:Стандартная
Ввод команды: ОКНОСВ


Увеличение скорости вывода растровых изображений на экран (Краткий справочник)

Загрузка и выгрузка растровых изображений
Увеличение скорости вывода растровых изображений на экран
Вставка файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов растровых изображений > Настройка скорости обработки изображений > Увеличение скорости вывода растровых изображений на экран >
Увеличение скорости вывода растровых изображений на экран
Понятие Процедура Краткий справочник

Команды

ИЗОБКАЧЕСТВО

Управление качеством вывода изображений на экран

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ОКНОСВ

Управление свойствами объектов

Системные переменные

IMAGEHLT

Управление режимом подсветки растровых изображений при выборе

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка файлов WMF (Понятие)

Увеличение скорости вывода растровых изображений на экран
Импорт, вставка и открытие файлов других форматов
Создание файлов в других форматах
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов >
Вставка файлов WMF
Понятие Процедура Краткий справочник

Метафайлы Windows (файлы формата WMF) часто используются для хранения графических изображений. WMF-файлы можно вставлять в чертежи в виде блоков. В отличие от растровых картинок, в метафайлах информация хранится в векторном формате, поэтому их можно масштабировать без потери разрешающей способности. Если WMF-файл содержит изображения 2D фигур или широких линий, для повышения скорости рисования можно отключить их вывод на экран.

Формат WMF позволяет хранить и векторную, и растровую графику. Однако программой используется только векторная информация из файла WMF. При импортировании файлов WMF в программу растровая графика игнорируется.

См. также

    • Импорт текстовых файлов


Вставка файлов WMF (Процедура)

Увеличение скорости вывода растровых изображений на экран
На уровень вверх ..
Вставка файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов WMF >
Вставка файлов WMF
Понятие Процедура Краткий справочник

Процедура вставки файла WMF

Управление видимостью сплошных закрасок и широких линий в WMF-файлах


Процедура вставки файла WMF (Процедура)

Вставка файлов WMF
На уровень вверх ..
Вставка файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов WMF >
Вставка файлов WMF
Понятие Процедура Краткий справочник

Процедура вставки файла WMF

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Импорт" [image] WMF-файл. В командной строке введите "импортмтф".
  2. В диалоговом окне "Импорт WMF-файла" выберите файл, который требуется открыть. Нажмите "Открыть".
  3. Указать точку вставки для WMF-файла.
  4. Установить масштаб одним из следующих способов:
    • Для задания воображаемого прямоугольника, размеры которого соответствуют коэффициенту масштабирования, введите в командной строке c (угол). Второй угол рамки должен лежать выше и правее точки вставки, иначе будет вставлено зеркальное отражение изображения.
    • Введите xyz для задания масштабных коэффициентов для трехмерного пространства.
    • Для задания масштаба по осям Xи Y введите масштаб в командной строке. Масштабы по горизонтали и вертикали могут быть различными. Для сохранения текущего масштаба введите 1. Введите более высокое значение, чтобы увеличить размер изображения метафайла. (Для увеличения размера изображения в два раза нужно введите 2). Введите положительное число, меньшее 1, чтобы уменьшить размеры изображения. (Для сокращения размера изображения в два раза нужно введите 0,5). Следует учесть, что использование этого параметра затрудняет импорт файла WMF определенных масштабов и размеров.
  5. Задайте угол поворота.
Ввод команды: ИМПОРТМТФ


Управление видимостью сплошных закрасок и широких линий в WMF-файлах (Процедура)

Вставка файлов WMF
На уровень вверх ..
Создание файлов в других форматах
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов WMF >
Вставка файлов WMF
Понятие Процедура Краткий справочник

Управление видимостью сплошных закрасок и широких линий в WMF-файлах

  1. Выберите вкладку "Блоки и ссылки" [image] панель "Импорт" [image] WMF-файл. В командной строке введите "импортмтф".
  2. В диалоговом окне "Импорт WMF" выберите "Сервис" [image] "Настройка".В диалоговом окне "Импорт WMF" введите в командной строке "настройка".
  3. В диалоговом окне "Параметры импорта из WMF" поднять или сбросить флажки "В каркасном виде" и "С широкими линиями". По умолчанию эти флажки подняты.
  4. Нажмите "ОК".
  5. Выполнить импорт WMF-файла обычным образом.
Ввод команды: ИМПОРТМТФ


Вставка файлов WMF (Краткий справочник)

Увеличение скорости вывода растровых изображений на экран
Вставка файлов WMF
Экспорт DXF-файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Импорт, вставка и открытие файлов других форматов > Вставка файлов WMF >
Вставка файлов WMF
Понятие Процедура Краткий справочник

Команды

ИМПОРТ

Импорт файлов в различных форматах

ИМПОРТМТФ

Импорт метафайла Windows

ОПЦИИМТФ

Задание опций для команды ИМПОРТМТФ

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание файлов в других форматах

Вставка файлов WMF
Работа с данными других форматов
Экспорт DXF-файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов >
Создание файлов в других форматах
Понятие Процедура

При необходимости использовать информацию из файла чертежа в другом приложении его преобразуют в требуемый формат процедурами экспорта. При этом можно использовать буфер обмена.

Темы в этом разделе

  • Экспорт DXF-файлов

    Чертеж можно экспортировать в файл формата DXF для передачи в другие системы автоматизированного проектирования.

  • Экспорт файлов MicroStation DGN

    Предусмотрена возможность экспорта файлов DWG, созданных в программах на основе AutoCAD, в формат файлов чертежей MicroStation® DGN.

  • Экспорт файлов WMF
  • Экспорт растровых файлов

    Из объектов чертежа можно создавать растровые изображения, независимые от устройства вывода.

  • Экспорт файлов формата PostScript

    Чертеж можно преобразовать в формат PostScript, который поддерживается многими издательскими системами.

  • Экспорт файлов ACIS SAT

    Можно экспортировать некоторые типы объектов в ACIS-файлы формата ASCII (SAT).

  • Экспорт файлов стереолитографических данных STL

    Твердотельные объекты можно записать в файл формата STL, совместимый со стереолитографической аппаратурой (SLA).


Создание файлов в других форматах (Процедура)

Вставка файлов WMF
Создание файлов в других форматах
Экспорт DXF-файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Создание файлов в других форматах
Понятие Процедура

Создание файла DXF

Экспорт чертежа MicroStation DGN

Создание WMF-файла (метафайла Windows)

Создание файла BMP

Создание JPEG-файла (JPG)

Создание TIFF-файла (TIF)

Создание файла формата PNG (переносимая сетевая графика)

Экспорт чертежа в файл формата Encapsulated PostScript (EPS)

Создание файла ACIS

Процедура экспорта трехмерных твердотельных элементов в файл STL


Экспорт DXF-файлов (Понятие)

Создание файлов в других форматах
Создание файлов в других форматах
Экспорт файлов MicroStation DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Экспорт DXF-файлов
Понятие Процедура Краткий справочник

Чертеж можно экспортировать в файл формата DXF для передачи в другие системы автоматизированного проектирования.

Чертеж можно экспортировать в файл формата DXF (формат графического обмена). DXF-файл представляет собой текстовый или двоичный файл с информацией о чертеже, которая может быть прочитана другими программами, в том числе другими программами автоматизированного проектирования. Сохранение чертежа в DXF-формате может пригодиться, например, если у консультантов проекта имеется другая программа автоматизированного проектирования, воспринимающая DXF-файлы.

Для величин с плавающей точкой может задаваться точность (до 16 десятичных знаков); чертеж можно сохранять либо в формате ASCII, либо в двоичном виде. Результатом сохранения в формате ASCII является текстовый файл, доступный для чтения и редактирования, а результатом сохранения в двоичном формате является файл меньшего размера, скорость работы с которым значительно выше.

Если требуется сохранение только части чертежа, указываются сохраняемые объекты. Эту опцию можно использовать для удаления из файлов чертежей посторонних объектов.


Создание файла DXF (Процедура)

Создание файлов в других форматах
На уровень вверх ..
Экспорт файлов MicroStation DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт DXF-файлов >
Экспорт DXF-файлов
Понятие Процедура Краткий справочник

Создание файла DXF

  1. Выберите пункт меню "Файл" [image] "Сохранить как".В командной строке введите "сохранитькак".
  2. В списке "Тип файла" диалогового окна "Сохранение чертежа" выберите формат DXF.
    • Для сохранения всего чертежа перейдите к выполнению этапа 4.
    • Для сохранения конкретных объектов в формате DXF выберите "Сервис" [image] "Настройка".Для сохранения конкретных объектов в формате DXF введите в командной строке "настройка". В диалоговом окне "Параметры сохранения" выберите формат DXF и поднять флажок "С выбором объектов". Введите значение, соответствующее количеству знаков после запятой. Нажмите "ОК".
  3. В диалоговом окне "Сохранение чертежа" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    К имени файла будет добавлено расширение .dxf.

  4. Если задан режим сохранения с выбором объектов, то укажите объекты и нажмите ENTER.
Ввод команды: СОХРАН В


Экспорт DXF-файлов (Краткий справочник)

Вставка файлов WMF
Экспорт DXF-файлов
Экспорт файлов MicroStation DGN
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт DXF-файлов >
Экспорт DXF-файлов
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

СОХРАН В

Сохранение копии текущего чертежа под новым именем

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт файлов MicroStation DGN (Понятие)

Экспорт DXF-файлов
Создание файлов в других форматах
Экспорт файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Экспорт файлов MicroStation DGN
Понятие Процедура Краткий справочник

Предусмотрена возможность экспорта файлов DWG, созданных в программах на основе AutoCAD, в формат файлов чертежей MicroStation® DGN.

В процессе экспорта базовые данные файла DWG преобразуются в соответствующие данные файла DGN. Предусмотрено несколько параметров преобразования, определяющих способ обработки конкретных данных (например, внешних ссылок), динамический диапазон файла DGN в зависимости от заданных основных и вспомогательных единиц измерения, а также возможность передачи в файл DGN данных с ненулевым значением координаты Z.

Обмен базовыми данными чертежей играет важную роль в совместной разработке проектов. Например, обслуживающим организациям, таким как компании по архитектурному и техническому проектированию или проектно-строительным компаниям, может потребоваться экспорт плана строительной площадки в формат DGN для передачи в компанию по ландшафтному проектированию или в отдел градостроительства.

При преобразовании слоев, типов линий, весов линий и цветов в формате DWG в уровни, типы линий, веса линий и цвета в формате DGN применяются стандартные (используемые по умолчанию) параметры соответствия. Можно изменить параметры соответствия для этих элементов с учетом принятых в конкретной компании стандартов оформления, что позволяет упростить процедуру экспорта и вместе с тем минимизировать объем изменений, которые потребуется внести в полученный файл DGN (см. ДГНСООТВ).

Сведения об ограничениях

Функции импорта и экспорта DGN предназначены для обеспечения обмена информацией между файлами MicroStation DGN и файлами AutoCAD DWG в полном объеме. Однако преобразование данных между двумя принципиально различными форматами неизбежно требует компромиссных решений и замены части данных.

  • Между форматами данных DWG и DGN поддерживается прямое соответствие простых геометрических объектов, например, прямых, дуг и окружностей, а также простых свойств, таких как назначение слоев.
  • К данным со встроенными элементами и к вариативным данным применяется визуальная аппроксимация. К таким данным относятся, например, текст и размеры со специальным форматированием и определения цветов, настроенные под пользователя.
  • Некоторые данные невозможно преобразовать полностью. Например, компоненты, специфичные для конкретной программы, такие как динамические блоки, могут быть представлены визуально, но не функционально.
  • При экспорте файла DWG со вложенными ссылками в формате V7 DGN вложенные ссылки не объединяются с основным файлом DGN. Вложенные ссылки не отображаются в основном файле DGN, но цепочка ссылок сохраняется.
  • AD-объекты не поддерживаются; перед экспортом объектов в DGN необходимо преобразовать их в базовые объекты ACAD с помощью команды EXPORTTOAUTOCAD.

Подробные сведения об экспорте объектов DWG и других данных в файлы DGN см. в таблице преобразования ДГНЭКСПОРТ.

ПримечаниеНе экспортируйте чертежи, содержащие подложки V8 DGN, файл формата V7 DGN. Отображение ссылок V8 DGN в файле V7 DGN невозможно, так как файлы формата V8 DGN не являются допустимыми файлами проектирования для результирующего файла V7 DGN.

Рекомендации

Ниже приведены рекомендации по повышению эффективности переноса данных в файлы формата MicroStation DGN.

  • Сведите к минимуму применение пользовательских объектов и других данных, которые не являются стандартными для программ на основе AutoCAD
  • По возможности применяйте простые стили линий
  • Применяйте простые штриховки и стили штриховок
  • Применяйте простые градиенты и стили градиентов
  • По возможности применяйте простые стили размеров
  • Пользуйтесь шрифтами TrueType, а не шрифтами для текстов SHX
  • Работайте преимущественно в одном формате - DWG или DGN; не переключайтесь между этими форматами без необходимости

При экспорте данных DWG в файлы DGN необходимо правильно указать единицы преобразования (основные или вспомогательные) для файла прототипа DGN на основе единиц, заданных для чертежа в файле DWG. Например, если на чертеже в файле DWG, экспортируемом в DGN, применяются дюймы, а в файле DGN, в который выполняется экспорт, в качестве основных и вспомогательных единиц заданы соответственно футы и дюймы, в диалоговом окне "Экспорт в DGN" необходимо выбрать вспомогательные единицы. Если вместо вспомогательных единиц выбраны основные, импортированный файл DWG отображается в неверном масштабе. Например, 36-дюймовая дверь отображается как 36-футовая.

ПредупреждениеНекоторые программы, работающие с файлами DGN, не поддерживают дополнительные символы, которые в операционной системе Windows могут употребляться в именах файлов. Поэтому при работе с командой ДГНЭКСПОРТ не рекомендуется употреблять в именах файлов символы с диакритическими знаками и азиатские символы.


Экспорт чертежа MicroStation DGN (Процедура)

Экспорт DXF-файлов
На уровень вверх ..
Экспорт файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов MicroStation DGN >
Экспорт файлов MicroStation DGN
Понятие Процедура Краткий справочник

Экспорт чертежа MicroStation DGN

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Экспорт. В командной строке введите "экспорт".
  2. В диалоговом окне "Экспорт данных" выберите в списке "Тип файла" значение "V8 DGN (*.dgn)" или "V7 DGN (*.dgn)".
  3. В поле "Имя файла" укажите имя файла DGN. Не вводите символы с диакритическими знаками и азиатские символы.
  4. Нажмите кнопку "Сохранить".
  5. В диалоговом окне "Параметры экспорта в DGN" задайте требуемые параметры экспорта.
  6. Нажмите ОК.
Ввод команды: ДГНЭКСПОРТ


Экспорт файлов MicroStation DGN (Краткий справочник)

Экспорт DXF-файлов
Экспорт файлов MicroStation DGN
Экспорт файлов WMF
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов MicroStation DGN >
Экспорт файлов MicroStation DGN
Понятие Процедура Краткий справочник

Команды

ДГНЭКСПОРТ

Создание одного или нескольких DGN-файлов из текущего чертежа

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт файлов WMF (Понятие)

Экспорт файлов MicroStation DGN
Создание файлов в других форматах
Экспорт растровых файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Экспорт файлов WMF
Понятие Процедура Краткий справочник

Формат WMF поддерживается многими приложениями Windows. WMF-файлы (метафайлы Windows) используется для представления векторной графики и растровой графики. Файлы WMF создаются только в векторной графике. Векторный формат позволяет значительно ускорить выполнение панорамирования и зумирования.


Создание WMF-файла (метафайла Windows) (Процедура)

Экспорт файлов MicroStation DGN
На уровень вверх ..
Экспорт растровых файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов WMF >
Экспорт файлов WMF
Понятие Процедура Краткий справочник

Создание WMF-файла (метафайла Windows)

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Экспорт. В командной строке введите "экспорт".
  2. В списке "Тип файла" диалогового окна "Экспорт данных" выберите "Метафайл (*.wmf)".
  3. Выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    К имени файла будет добавлено расширение .wmf.

Ввод команды: ЭКСПОРТ


Экспорт файлов WMF (Краткий справочник)

Экспорт файлов MicroStation DGN
Экспорт файлов WMF
Экспорт растровых файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов WMF >
Экспорт файлов WMF
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ЭКСПОРТМТФ

Сохранение объектов в метафайле Windows (WMF)

Системные переменные

WMFBKGND

Управление отображением фона при вставке объектов в формате метафайлов Windows (WMF)

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт растровых файлов (Понятие)

Экспорт файлов WMF
Создание файлов в других форматах
Экспорт файлов формата PostScript
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Экспорт растровых файлов
Понятие Процедура Краткий справочник

Из объектов чертежа можно создавать растровые изображения, независимые от устройства вывода.

Для экспорта объектов в растровые изображения форматов BMP, JPEG, TIFF и PNG существует несколько команд.

Объекты появляются в растровом изображении по мере возникновения их на экране. Это относится также к объектам на раскрашенных и тонированных видовых экранах.

Файлы таких форматов, как JPEG, при создании сжимаются. Сжатие файлов сокращает их размеры, однако такие файлы могут не поддерживаться некоторыми приложениями.


Экспорт растровых файлов (Процедура)

Экспорт файлов WMF
На уровень вверх ..
Экспорт растровых файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт растровых файлов >
Экспорт растровых файлов
Понятие Процедура Краткий справочник

Создание файла BMP

Создание JPEG-файла (JPG)

Создание TIFF-файла (TIF)

Создание файла формата PNG (переносимая сетевая графика)


Создание файла BMP (Процедура)

Экспорт растровых файлов
На уровень вверх ..
Экспорт растровых файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт растровых файлов >
Экспорт растровых файлов
Понятие Процедура Краткий справочник

Создание файла BMP

  1. В командной строке введите экспортбмп.
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    К имени файла будет добавлено расширение .bmp.

  3. Выберите объекты для сохранения.
Ввод команды: ЭКСПОРТБМП


Создание JPEG-файла (JPG) (Процедура)

Экспорт растровых файлов
На уровень вверх ..
Экспорт растровых файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт растровых файлов >
Экспорт растровых файлов
Понятие Процедура Краткий справочник

Создание JPEG-файла (JPG)

  1. В командной строке введите "экспортдж".
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    К имени файла будет добавлено расширение.jpg.

  3. Выберите объекты для сохранения.
Ввод команды: ЭКСПОРТДЖ


Создание TIFF-файла (TIF) (Процедура)

Экспорт растровых файлов
На уровень вверх ..
Экспорт растровых файлов
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт растровых файлов >
Экспорт растровых файлов
Понятие Процедура Краткий справочник

Создание TIFF-файла (TIF)

  1. В командной строке введите "экспорттиф".
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите кнопку "Сохранить".

    К имени файла будет добавлено расширение .tif.

  3. Выберите объекты для сохранения.
Ввод команды: ЭКСПОРТТИФ


Создание файла формата PNG (переносимая сетевая графика) (Процедура)

Экспорт растровых файлов
На уровень вверх ..
Экспорт файлов формата PostScript
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт растровых файлов >
Экспорт растровых файлов
Понятие Процедура Краткий справочник

Создание файла формата PNG (переносимая сетевая графика)

  1. В командной строке введите "экспортпнг".
  2. В диалоговом окне "Создание растрового файла" выберите папку и введите имя файла. Нажмите "ОК".

    К имени файла будет добавлено расширение .png.

  3. Выберите объекты для сохранения.
Ввод команды: ЭКСПОРТПНГ


Экспорт растровых файлов (Краткий справочник)

Экспорт файлов WMF
Экспорт растровых файлов
Экспорт файлов формата PostScript
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт растровых файлов >
Экспорт растровых файлов
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТБМП

Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ЭКСПОРТДЖ

Сохранение выбранных объектов в файле в формате JPEG

ЭКСПОРТПНГ

Сохранение выбранных объектов в файле в формате Portable Network Graphics

ЭКСПОРТТИФ

Сохранение выбранных объектов в файле формата TIFF

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт файлов формата PostScript (Понятие)

Экспорт растровых файлов
Создание файлов в других форматах
Экспорт файлов ACIS SAT
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Экспорт файлов формата PostScript
Понятие Процедура Краткий справочник

Чертеж можно преобразовать в формат PostScript, который поддерживается многими издательскими системами.

Формат PostScript используется во многих издательских системах. Возможность вывода файлов PostScript на печать с высоким разрешением делает этот формат более предпочтительным по сравнению с растровыми форматами, такими как GIF, PCX и TIFF. Для чертежа, преобразованного в формат PostScript, можно использовать PostScript-шрифты.

Экспорт в формат PostScript

При экспорте файла в формате PostScript как файла EPS обработка некоторых объектов происходит по-особому.

  • Уплотненный текст, кодs управления текстом. Если плотность текста больше 0 или текст содержит управляющие коды (например, %%O или %%D), он не выводится на печать как текст PostScript, несмотря на то, что текст отображается правильно. При записи в PostScript-файл можно выводить тексты, содержащие международные и специальные символы (например %%213).
  • Набор символов ISO 8859 Latin/1. Если в тексте используются коды символов в диапазоне от 127 до 255, текст интерпретируется на основе набора символов ISO 8859 Latin/1. Если в тексте появляется символ, связанный с PostScript, генерируется версия шрифта, вектор кодирования которого переназначен для отображения набора символов ISO. Полученный текст, совместимый с заданным шрифтом, выводится в PostScript-файл.
  • Круги, дуги, эллипсы, эллиптические дуги. Дуги и круги преобразуются в эквивалентные объекты PostScript за исключением случаев, когда они обладают толщиной.
  • Закрашенные фигуры. Сплошная заливка выводится в PostScript как закрашенные контуры.
  • Двумерные полилинии. 2D (плоские) полилинии с постоянной шириной выводятся в PostScript в виде контуров. Для переменных торцевого ограничителя и ограничителя угла PostScript установлены значения, аппроксимирующие объединение сегментов.
См. также

    • Печать в файлы Adobe PostScript


Экспорт чертежа в файл формата Encapsulated PostScript (EPS) (Процедура)

Экспорт растровых файлов
На уровень вверх ..
Экспорт файлов ACIS SAT
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов формата PostScript >
Экспорт файлов формата PostScript
Понятие Процедура Краткий справочник

Экспорт чертежа в файл формата Encapsulated PostScript (EPS)

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Экспорт. В командной строке введите "экспорт".
  2. В диалоговом окне "Экспорт данных" задайте имя и путь для EPS-файла.
  3. Из списка "Тип файла" выберите значение "Encapsulated PS (*.eps)".
  4. Нажмите кнопку "Сохранить".
Ввод команды: ПЕЧАТЬ


Экспорт файлов формата PostScript (Краткий справочник)

Экспорт растровых файлов
Экспорт файлов формата PostScript
Экспорт файлов ACIS SAT
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов формата PostScript >
Экспорт файлов формата PostScript
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ПЕЧАТЬ

Вывод чертежа на плоттер, принтер или в файл

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт файлов ACIS SAT (Понятие)

Экспорт файлов формата PostScript
Создание файлов в других форматах
Экспорт файлов стереолитографических данных STL
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Экспорт файлов ACIS SAT
Понятие Процедура Краткий справочник

Можно экспортировать некоторые типы объектов в ACIS-файлы формата ASCII (SAT).

В файл ACIS формата ASCII (SAT) можно экспортировать обрезанные поверхности неравномерных рациональных би-сплайнов, области и трехмерные твердотельные элементы. Все другие объекты (отрезки, дуги и т.п.) при этом игнорируются.

Cистемная переменная ACISOUTVER задает версию ACIS для вывода команды ЭКСПОРТТЕЛ.


Создание файла ACIS (Процедура)

Экспорт файлов формата PostScript
На уровень вверх ..
Экспорт файлов стереолитографических данных STL
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов ACIS SAT >
Экспорт файлов ACIS SAT
Понятие Процедура Краткий справочник

Создание файла ACIS

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Экспорт. В командной строке введите "экспорт".
  2. В диалоговом окне "Экспорт данных" введите имя файла.
  3. В списке "Тип файла" выберите "ACIS" (*.sat). Нажмите кнопку "Сохранить".
  4. Выберите экспортируемые в ACIS-файл объекты.

    Автоматически добавляется расширение файла .sat.

Ввод команды: ЭКСПОРТ, ЭКСПОРТТЕЛ


Экспорт файлов ACIS SAT (Краткий справочник)

Экспорт файлов формата PostScript
Экспорт файлов ACIS SAT
Экспорт файлов стереолитографических данных STL
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов ACIS SAT >
Экспорт файлов ACIS SAT
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТТЕЛ

Экспорт в файл ACIS тел ACIS, 3D тел и областей

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

Системные переменные

ACISOUTVER

Управление версией ACIS файлов SAT, созданных с помощью команды ACISOUT

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Экспорт файлов стереолитографических данных STL (Понятие)

Экспорт файлов ACIS SAT
Создание файлов в других форматах
Использование чертежей из разных приложений и версий
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах >
Экспорт файлов стереолитографических данных STL
Понятие Процедура Краткий справочник

Твердотельные объекты можно записать в файл формата STL, совместимый со стереолитографической аппаратурой (SLA).

Твердотельные объекты можно экспортировать в файл формата STL, совместимый со стереолитографической аппаратурой (SLA). Объекты передаются в SLA в виде многогранной сети с гранями в форме треугольников. Рабочая станция SLA извлекает из информации о гранях наборы контуров, определяющих слои генерируемой детали.


Процедура экспорта трехмерных твердотельных элементов в файл STL (Процедура)

Экспорт файлов ACIS SAT
На уровень вверх ..
Использование чертежей из разных приложений и версий
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов стереолитографических данных STL >
Экспорт файлов стереолитографических данных STL
Понятие Процедура Краткий справочник

Процедура экспорта трехмерных твердотельных элементов в файл STL

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Экспорт. В командной строке введите "экспорт".
  2. В диалоговом окне "Экспорт данных" введите имя файла.
  3. В списке "Тип файла" выберите "Литография (*.stl)". Нажмите кнопку "Сохранить".
  4. Выберите один или несколько твердотельных объектов. Все объекты должны располагаться внутри октанта МСК с положительными значениями координат X, Y и Z. Это значит, что значения координат X, Y и Z должны быть больше нуля.

    К имени файла будет автоматически добавлено расширение.stl.

Ввод команды: ЭКСПОРТСТЛ


Экспорт файлов стереолитографических данных STL (Краткий справочник)

Экспорт файлов ACIS SAT
Экспорт файлов стереолитографических данных STL
Сохранение чертежей в форматах прежних версий
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Создание файлов в других форматах > Экспорт файлов стереолитографических данных STL >
Экспорт файлов стереолитографических данных STL
Понятие Процедура Краткий справочник

Команды

ЭКСПОРТСТЛ

Сохранение тел в двоичном или ASCII-файле

Системные переменные

FACETRES

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование чертежей из разных приложений и версий

Экспорт файлов стереолитографических данных STL
Работа с данными других форматов
Работа с чертежами в более ранних версиях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов >
Использование чертежей из разных приложений и версий
Понятие Процедура

Допустим обмен чертежами между разными версиями AutoCAD и AutoCAD LT, а также экспорт и импорт файлов, содержащих сторонние объекты. Однако в некоторых случаях существуют ограничения.

Темы в этом разделе

  • Работа с чертежами в более ранних версиях

    При работе в AutoCAD 2007 (и более ранних версиях) с чертежами, созданными в AutoCAD 2008 (и более поздних версиях), необходимо учитывать указанные ниже несоответствия, связанные с точностью воспроизведения визуальной информации.

  • Сохранение чертежей в форматах прежних версий

    Имеется возможность сохранения чертежей в форматах, поддерживаемых прежними версиями продукта.

  • Работа с чертежами AutoCAD в AutoCAD LT

    AutoCAD LT полностью поддерживает чертежи AutoCAD. Однако следует учитывать то, как AutoCAD LT обрабатывает специфичные для AutoCAD элементы.

  • Работа со сторонними объектами и заместителями

    Использование сторонних объектов открывает дополнительные возможности применения программы и родственных продуктов. Если приложение, в котором был создан сторонний объект, не загружено, то используется объект-заместитель.


Использование чертежей из разных приложений и версий (Процедура)

Экспорт файлов стереолитографических данных STL
Использование чертежей из разных приложений и версий
Работа с чертежами в более ранних версиях
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий >
Использование чертежей из разных приложений и версий
Понятие Процедура

Процедура сохранения чертежей с точным воспроизведением аннотативных объектов

Сохранение чертежа AutoCAD в формате предыдущей версии


Работа с чертежами в более ранних версиях (Понятие)

Использование чертежей из разных приложений и версий
Использование чертежей из разных приложений и версий
Сохранение чертежей в форматах прежних версий
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий >
Работа с чертежами в более ранних версиях
Понятие Процедура

При работе в AutoCAD 2007 (и более ранних версиях) с чертежами, созданными в AutoCAD 2008 (и более поздних версиях), необходимо учитывать указанные ниже несоответствия, связанные с точностью воспроизведения визуальной информации.

Точность воспроизведения визуальной информации для аннотативных объектов в предыдущих версиях

При просмотре объектов типа "аннотативный " в AutoCAD 2007 (и более ранних версиях) можно задать режим точного воспроизведения визуальной информации с помощью системной переменной SAVEFIDELITY .

Если работа выполняется главным образом в пространстве модели, рекомендуется отключить режим точного воспроизведения (задать для переменной SAVEFIDELITY значение 0). Однако при необходимости в обмене чертежами с другими пользователями, если точная передачи изображения в компоновке имеет первостепенное значение, следует включить режим точного воспроизведения (задать для переменной SAVEFIDELITY значение 1).

Аннотативному объекту может соответствовать несколько представлений с учетом масштаба. Если режим точного воспроизведения визуальных объектов включен, аннотативные объекты разбиваются на составные части, а представления с учетом масштаба сохраняются (в неименованный блок ) в отдельных слоях. Этим слоям присваиваются имена, образуемые путем добавления числового значения к имени исходного слоя. Если расчленить блок в AutoCAD 2007 (или более ранней версии) и затем открыть чертеж в AutoCAD 2008 (или более поздней версии), каждое представление с учетом масштаба становится отдельным аннотативным объектом; каждому из таких объектов соответствует определенный масштаб аннотаций. При работе в AutoCAD 2007 (или более ранней версии) с чертежом, созданным в AutoCAD 2008 (или более поздней версии), не рекомендуется создавать и редактировать объекты на этих слоях.

Если для аннотативных объектов не выбран режим точного воспроизведения, на вкладке "Модель" отображается одно представление пространства модели. В зависимости от значения системной переменной ANNOALLVISIBLE на вкладке "Модель" могут отображаться дополнительные объекты-аннотации, а на видовых экранах пространства листа - дополнительные объекты, размеры которых отличаются от размеров в AutoCAD 2008 и более поздних версиях.

Описание процедуры задания режима точного воспроизведения визуальной информации для аннотативных объектов см. в разделе Сохранение чертежей с визуальной четкостью аннотативных объектов.

Свойства аннотативных объектов в более ранних редакциях

Если на чертеже AutoCAD 2008 для аннотативного блока не задана ориентация листа, соответствующая компоновке, и этот блок содержит многострочные атрибуты, созданные на основе стиля текста, для которого не задано соответствие ориентации компоновки, при открытии этого чертежа в AutoCAD 2007 (и более ранних версиях) возможно смещение положения этих атрибутов.

Переопределения свойств слоев в более ранних редакциях

При открытии чертежа AutoCAD 2008, содержащего переопределения свойств слоев, переопределения не отображаются. Значения переопределений свойств не утрачиваются при сохранении чертежа в более ранней версии и вновь отображаются при открытии чертежа в AutoCAD 2008.

Если на чертеже, открытом в более ранней версии, удалить видовой экран, содержащий переопределения свойств слоев, значения переопределений утрачиваются; в этом случае после открытии чертежа в AutoCAD 2008 значения переопределений не доступны.

Если открыть чертеж в более ранней версии и затем задать для системной переменной VISRETAIN значение 0, слои внешних ссылок, содержащие переопределения свойств видового экрана, утрачиваются.

Если открыть чертеж AutoCAD 2008 в более ранней редакции, переопределения свойств могут отображаться в виде образца изображения. Если сохранить чертеж на вкладке компоновки, а затем открыть его в более ранней версии, эти переопределения свойств не отображаются.

Подложки DGN в более ранних редакциях

В версиях, более ранних по сравнению с AutoCAD 2008, не отображаются подложки.

Усовершенствования размеров в предыдущих редакциях

Новые функции размеров, добавленные в AutoCAD 2008, утрачиваются при редактировании в более ранних версиях. Если в размеры не внесены изменения, они восстанавливаются при открытии чертежа в AutoCAD 2008.

Ниже перечислены новые функции размеров, для которых сохраняется точность воспроизведения визуальной информации в предыдущих версиях, если размеры не редактируются.

  • Маски размеров
  • Линейные размеры с изломом
  • Контрольные размеры
  • Угловые размеры, проставленные в режиме квадрантов
  • Дугообразные выносные линии для размеров радиуса и диаметра

Объекты-мультивыноски в более ранних версиях

В версиях, более ранних по сравнению с AutoCAD 2008, мультивыноски отображаются как объекты-заместители. Отображение объектов-заместителей на чертеже зависит от значения системной переменной PROXYSHOW.

Интервалы между абзацами и строками абзацев многострочного текста в более ранних редакциях

При открытии многострочного текстового объекта AutoCAD 2008 в AutoCAD 2007 (и более ранних редакциях) поддерживаются не все новые параметры интервалов между абзацами и между строками абзацев.

Ниже перечислены функции форматирования многострочного текста, для которых в более ранних версиях не поддерживается точность воспроизведения визуальной информации.

  • Выравнивание абзацев по ширине
  • Распределенное выравнивание абзацев
  • Поля с переносом текста между столбцами
  • Поля с переносом текста между строками и новыми параметрами выравнивания абзацев
  • Абзацы с нестандартным выравниванием многострочного текста без выравнивания по левому краю на уровне объектов

Ниже перечислены функции форматирования многострочного текста, для которых в более ранних версиях точность воспроизведения визуальной информации поддерживается частично (при условии, что возможно добавление пробелов или замена текста пробелами).

  • Абзацы с нестандартным выравниванием многострочного текста (т.е. отличным от выравнивания по ширине и распределенного выравнивания) без выравнивания по левому краю на уровне объектов
  • Новые параметры выравнивания символов табуляции в абзацах (по центру, по левому краю, выравнивание десятичных чисел)
  • Новые параметры выравнивания строк в абзацах (возможна "аппроксимация" посредством "высоких" символов пробела)

Если многострочный текст с новыми параметрами форматирования отредактирован и сохранен в более ранней версии, при последующем открытии этого текста в AutoCAD 2008 новые параметры форматирования утрачиваются.

Таблицы в более ранних редакциях

При редактировании таблиц AutoCAD 2008 в предыдущих версиях отменяется форматирование таблиц, выполненное в AutoCAD 2008. Кроме того, при открытии таблиц AutoCAD 2008 в более ранних редакциях ячейки, содержащие длинные блоки или строки текста, могут выходить за свои границы.

Таблицы извлечения данных в более ранних версиях

В более ранних версиях невозможно редактирование и обновление извлеченных данных в таблицах извлечения данных, созданных в AutoCAD 2008 с помощью мастера извлечения данных.

Материалы в более ранних версиях

В AutoCAD 2008 введены новые процедурные карты для материалов и яркости. Для чертежей, созданных в более ранних версиях по сравнению с AutoCAD 2007 и содержащих материалы, необходимо преобразование. В AutoCAD 2008 предусмотрена системная переменная 3DCONVERSIONMODE, обеспечивающая автоматическое преобразование чертежей из более ранних версий в формат AutoCAD 2008. Однако при обратном сохранении в более ранних версиях AutoCAD возможны нарушения точности воспроизведения.

  • В AutoCAD 2007 (и более ранних версиях) не доступны процедурные карты "Клетки", "Помехи", "Пятна", "Мозаика" и "Волны". При открытии в AutoCAD 2007 чертежа AutoCAD 2008 эти процедурные карты не отображаются. Процедурные карты "Мрамор" и "Дерево" доступны, но внешний вид материала может отличаться от исходного.
  • В AutoCAD 2008 внесены исправления в функционирование канала текстуры "Непрозрачность" применительно к материалам типа "Реалистичный". В AutoCAD 2008 канал текстуры "Непрозрачность" функционирует аналогично текстуре прозрачности белый цвет соответствует прозрачным участкам, а черный - непрозрачным (как и в более ранних версиях по сравнению с AutoCAD 2007). В AutoCAD 2007 белый цвет соответствовал непрозрачным участкам, а черный - прозрачным.
  • В AutoCAD 2008 применяется другой вариант поворота сферических карт. При открытии чертежа в более ранних версиях по сравнению с AutoCAD 2008 шов карты направлен к оси +Y. В AutoCAD 2008 он направлен к оси +X.

Освещение в более ранних версиях

В AutoCAD 2008 предусмотрено два режима освещения: стандартное (общее) освещение и фотометрическое освещение. В долее ранних версиях поддерживалось только стандартное (общее) освещение. При переносе из AutoCAD 2007 в AutoCAD 2008 не требуется явно заданного преобразования источников света. По умолчанию чертежи из AutoCAD 2007 открываются в AutoCAD 2008 в режиме стандартного (общего) освещения. Дополнительные фотометрические свойства, предусмотренные в AutoCAD 2008, доступны в том случае, если для чертежа включен режим фотометрического освещения.

Для чертежей с освещением, созданных в более ранних версиях по сравнению с AutoCAD 2007, требуется процесс преобразования. С помощью системной переменной 3DVCONVERSTIONMODE можно задать автоматическое преобразование чертежей с освещением из предыдущих версий в формат освещения AutoCAD 2007 и AutoCAD 2008. Системная переменная 3DVCONVERSTIONMODE может принимать три значения. Если задано значение 0, преобразование не выполняется. Если задано значение 1 (по умолчанию), преобразование выполняется автоматически. Если задано значение 2, для источников света, требующих преобразования, отображается запрос на выполнение или отмену преобразования.

Ниже перечислены другие несоответствия, связанные с точностью воспроизведения освещения.

  • Источники света в блоках. Источники света в блоках, созданные в AutoCAD 2008, могут не отображаться в AutoCAD 2007.
  • Освещение текстур. В AutoCAD 2007 (и более ранних версиях) невозможно добавить освещение текстур. Эта функция поддерживается в AutoCAD 2008.
  • Тени на земле.Контрастность теней на земле в AutoCAD 2008 зависит от яркости источника света и угла падения.

Поддержка различных языков в более ранних версиях

В AutoCAD 2008 свойства чертежа сохраняются в кодировке Unicode. Например, если сохранить чертеж из последней версии, содержащий свойства чертежа на нескольких языках, в чертеж формата 2004, свойства чертежа будут преобразованы в собственные символы текущего языка Windows. При невозможности преобразования в символы нужного языка текст сохраняется в кодировке CIF (\U+nnnn) или MIF (\M+nxxxx).

При сохранении чертежа последней версии в формате 2004 любое новое имя обозначения или имя словаря (например, имя листа, имя текстового стиля, имя размерного стиля), созданные в AutoCAD 2008, будут сохранены на том языке, который использовался при создании имен обозначений.

Для просмотра и редактирования чертежей, содержащих символы, которые не существуют в языках, указанных для используемой операционной системы, убедитесь, что в системе установлена поддержка дополнительных языков. Язык можно указать в диалоговом окне "Язык и региональные стандарты" в панели управления Windows. (Текст, в котором используются шрифты SHX, можно просмотреть, не включая поддержку дополнительных языков.)

Текстовые стили для азиатских языков, использующие SHX и файлы большого шрифта, могут поддерживать только символы из той же кодовой страницы. Например, текстовые стили, в которых используется японский крупный шрифт, не поддерживают немецкие или корейские символы. (Английские символы, входящие во все кодовые страницы, поддерживаются.) Поддержка нескольких языков обеспечивается только для тех текстовых стилей неазиатских языков, в которых используются шрифты SHX, а крупные шрифты отключены. (В шрифте SHX должны быть определены требуемые символы.)

Функция поддержки нескольких языков отсутствует в некоторых ранних версиях AutoCAD. Например, при сохранении файла в формате AutoCAD 2000 содержимое многострочного текста на нескольких языках может быть повреждено. Возникновение неполадок более вероятно при открытии и сохранении чертежа в операционной системе, в которой настройки языка отличаются от настроек системы, в которой чертеж был сохранен в последний раз.

ПримечаниеУказанные выше ограничения действуют также в отношении внешних ссылок на файлы чертежей, сохраненные в более ранних версиях.
См. также

    • Преобразование материалов

    • Преобразование источников света


Процедура сохранения чертежей с точным воспроизведением аннотативных объектов (Процедура)

Использование чертежей из разных приложений и версий
На уровень вверх ..
Сохранение чертежей в форматах прежних версий
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий > Работа с чертежами в более ранних версиях >
Работа с чертежами в более ранних версиях
Понятие Процедура

Процедура сохранения чертежей с точным воспроизведением аннотативных объектов

  1. Выберите пункт меню "Сервис" [image] "Настройка".В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" в разделе "Сохранение файлов" выберите "Сохранять визуальную четкость аннотативных объектов".
  3. Нажмите ОК.
Ввод команды: SAVEFIDELITY


Сохранение чертежей в форматах прежних версий (Понятие)

Работа с чертежами в более ранних версиях
Использование чертежей из разных приложений и версий
Работа с чертежами AutoCAD в AutoCAD LT
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий >
Сохранение чертежей в форматах прежних версий
Понятие Процедура Краткий справочник

Имеется возможность сохранения чертежей в форматах, поддерживаемых прежними версиями продукта.

Имеется возможность сохранения чертежей, созданных с помощью текущей версии продукта, в форматах, поддерживаемых ее прежними версиями. С помощью этой процедуры создается чертеж, содержащий информацию, относящуюся к текущей версии программы. Эта информация выделяется или преобразуется в объект другого типа. После преобразования чертежа в другой формат создается журнал со списком внесенных или удаленных данных.

Если текущая версия используется для открытия чертежа, созданного с помощью прежней версии, а информация, относящаяся к текущей версии, добавлена не будет, можно сохранить чертеж в формате прежней версии без потери данных.

ПримечаниеЧтобы чертежи были доступны в AutoCAD Release 12 или AutoCAD LT Release 2, их следует сохранять в формате AutoCAD R12/LT2 DXF.

Если требуется сохранить чертеж, созданный с помощью прежней версии в исходном формате, можно пометить файл атрибутом "только для чтения" или открыть его с помощью текущей версии программы и использовать параметры списка "Тип файла" диалогового окна "Сохранение файла", чтобы сохранить его в исходном формате.

Так как сохранение чертежа в формате ранних версий может привести к потере некоторых данных, следует сохранять чертеж с новым именем, чтобы избежать удаления файла текущего чертежа. Если происходит перезапись текущего чертежа, имеется возможность восстановить переписанную версию на основании резервного файла (имя_файла.bak), созданного в процессе сохранения.

Поддержка ассоциативных размеров

Как правило, ассоциативные размеры, созданные в AutoCAD 2002 или в более поздних редакциях, остаются ассоциативными в случае их сохранения в более ранней редакции и последующего открытия в текущей редакции. Однако, если в одной из прежних версий изменить формы объектов с нанесенными размерами, то при загрузке чертежа в текущую версию происходит изменение ассоциативных связей размеров с объектами. Так, например, если отрезок с нанесенными размерами разорвать на две части, получив при этом два отрезка, то ассоциативный размер сохранит связь только с одним из них.

Ассоциативность размеров не поддерживается, если чертеж сохранить как файл формата AutoCAD R12/LT 2 DXF, а затем вновь открыть его в текущей версии.

ПримечаниеПри сохранении чертежей в формате более ранних редакций по сравнению с AutoCAD 2002 сохраняется значение системной переменной DIMASSOC. В случае открытия чертежа в программе AutoCAD 2002 или более поздней версии настройка ассоциативности размеров восстанавливается. При открытии чертежа, созданного в более ранней редакции, в AutoCAD 2002 или в более поздней редакции, системной переменной DIMASSOC присваивается значение системной переменной DIMASO, заданное для этого чертежа.

Ограничения сохранения в прежние версии

При сохранении чертежа в формате версий 2000/LT 2000 действуют следующие ограничения:

  • Размер файла может увеличиться.
  • Шифрование и цифровые подписи не сохраняются.

При сохранении чертежа в формате версий 14/LT 98/LT 97 действуют следующие ограничения:

  • Гиперссылки преобразуются в прикрепленные поля URL версий 14/LT 98/LT 97.
  • Связи с базами данных и автономные метки преобразуются в связи и отображаемые атрибуты версий 14/LT 98/LT 97.
  • Прикрепленные к базам данных метки преобразуются в объекты многострочного текста и выносок, причем информация о связях становится недоступной. Прикрепленные метки восстанавливаются, если открыть чертеж в AutoCAD 2000 или более поздней версии.
  • Геометрия динамических блоков может переопределена независимо от динамических элементов блоков, а геометрия во вхождении блока не обновляется, если чертеж открыть в AutoCAD 2009 или более поздней версии программы.
  • Размеры, созданные с помощью команд РЗМДУГА и РЗМИЗЛОМ, могут в версиях 14/LT 98/LT 97 потерять свой исходный цвет.

При сохранении чертежа в формате Release 12/LT 2 DXF действуют следующие ограничения:

  • Компактные полилинии и образцы штриховки преобразуются в полилинии и образцы штриховки формата R12.
  • Все тела, ACIS-тела, области, эллипсы, выноски, мультилинии, лучи, рамки допусков и прямые преобразуются в отрезки, дуги и круги.
  • Группы, сложные типы линий, OLE-объекты и изображения для предварительного просмотра не выводятся.
  • После сохранения чертежа в формате R12 и последующего его открытия в версиях AutoCAD 2000/AutoCAD LT 2000 или более поздних версиях многие объекты могут оказаться потерянными.
  • Информация о нескольких листах и именах листов чертежа теряется. Сохраняются только вкладка "Модель" и вкладка разметки текущего листа.
  • Пробелы в именах слоев и других объектов преобразуются в символы подчеркивания. Максимальная длина имени не может превышать тридцати двух символов.
  • Файлы подложек DWF или DWFx, вставленные в чертежи, невозможно сохранить в формате DXF версии 12/LT 2.
  • Положение внешних ссылок "Выгружена" теряется.


Сохранение чертежа AutoCAD в формате предыдущей версии (Процедура)

Работа с чертежами в более ранних версиях
На уровень вверх ..
Извлечение данных с помощью мастера извлечения данных
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий > Сохранение чертежей в форматах прежних версий >
Сохранение чертежей в форматах прежних версий
Понятие Процедура Краткий справочник

Сохранение чертежа AutoCAD в формате предыдущей версии

  1. Выберите пункт меню "Файл" [image] "Сохранить как".В командной строке введите "сохранитькак".
  2. В диалоговом окне "Сохранение чертежа" в поле "Имя файла" введите имя чертежа.
  3. В группе "Тип файла" выберите формат требуемой версии AutoCAD или AutoCAD LT.
  4. Нажмите "ОК".
Ввод команды: СОХРАН В


Сохранение чертежей в форматах прежних версий (Краткий справочник)

Экспорт файлов стереолитографических данных STL
Сохранение чертежей в форматах прежних версий
Работа с чертежами AutoCAD в AutoCAD LT
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий > Сохранение чертежей в форматах прежних версий >
Сохранение чертежей в форматах прежних версий
Понятие Процедура Краткий справочник

Команды

ПРЕОБРАЗОВАТЬ

Преобразование 2D полилиний и ассоциативных штриховок, созданных в AutoCAD Release 13 или более ранних версиях

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

СОХРАНИТЬ

Сохранение чертежа под текущим или заданным именем

СОХРАН В

Сохранение копии текущего чертежа под новым именем

Системные переменные

PLINETYPE

Признак использования оптимизированных двумерных полилиний

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с чертежами AutoCAD в AutoCAD LT (Понятие)

Сохранение чертежей в форматах прежних версий
Использование чертежей из разных приложений и версий
Работа со сторонними объектами и заместителями
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий >
Работа с чертежами AutoCAD в AutoCAD LT
Понятие Краткий справочник

AutoCAD LT полностью поддерживает чертежи AutoCAD. Однако следует учитывать то, как AutoCAD LT обрабатывает специфичные для AutoCAD элементы.

Работа с полями

В AutoCAD можно создать подшивку и вставить поля "LispVariable" и "Диспетчер подшивки". В AutoCAD LT поля "LispVariable" и "Диспетчер подшивки" не предусмотрены. Созданные в AutoCAD чертежи, содержащие поля "LispVariable" и "Диспетчер подшивки", можно открыть в AutoCAD LT без ошибок; в этом случае отображается значение из кэш-памяти.

Работа с несколькими пользовательскими системами координат

В AutoCAD можно задавать для каждого видового экрана свою пользовательскую систему координат (ПСК). В AutoCAD LT можно использовать в одном чертеже только одну ПСК. В этом отношении AutoCAD LT ничем не отличается от AutoCAD прежних версий.

При открытии в AutoCAD LT чертежа AutoCAD используется только одна ПСК, взятая из текущего видового экрана. Если такой чертеж отредактировать в AutoCAD LT и сохранить, а затем повторно открыть в AutoCAD, то может появиться сообщение о несоответствии используемых ПСК. Это связано с тем, что при активизации в AutoCAD LT видовых экранов, для которых с помощью AutoCAD были заданы свои ПСК, эти системы координат могут измениться.

Работа с раскрашенными объектами 2D фигур и 3D тел AutoCAD

В AutoCAD визуальные стили позволяют работать с параметрами тонирования и каркасной модели объектов на текущем видовом экране. В AutoCAD LT визуальные стили не поддерживаются. Команда РЕЖИМРАСКР в AutoCAD LT предлагает только опции "2D каркас" и "Скрытие". Имеется возможность использовать РЕЖИМРАСКР в AutoCAD LT для отключения визуальных стилей на видовых экранах, ранее созданных в AutoCAD. Это позволяет отобразить элементы заднего плана, что упрощает редактирование и дает возможность применения таких средств обеспечения точности, как объектная привязка.


Работа с чертежами AutoCAD в AutoCAD LT (Краткий справочник)

Сохранение чертежей в форматах прежних версий
Работа с чертежами AutoCAD в AutoCAD LT
Работа со сторонними объектами и заместителями
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий > Работа с чертежами AutoCAD в AutoCAD LT >
Работа с чертежами AutoCAD в AutoCAD LT
Понятие Краткий справочник

Команды

Нет записей

Системные переменные

FIELDDISPLAY

Управление отображением полей на сером фоне

PERSPECTIVE

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа со сторонними объектами и заместителями (Понятие)

Работа с чертежами AutoCAD в AutoCAD LT
Использование чертежей из разных приложений и версий
Извлечение данных из чертежей и электронных таблиц
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий >
Работа со сторонними объектами и заместителями
Понятие Краткий справочник

Использование сторонних объектов открывает дополнительные возможности применения программы и родственных продуктов. Если приложение, в котором был создан сторонний объект, не загружено, то используется объект-заместитель.

Сторонний объект - это тип объектов, созданных в приложении ObjectARX® (AutoCAD Run-Time Extension), обладающий обычно более специализированными функциями по сравнению со стандартными объектами AutoCAD. К пользовательским объектам относятся параметрические тела (Autodesk® Mechanical), интерактивные (с интеллектуальными функциями) обозначения дверей (AutoCAD®Architecture), объекты-многоугольники (Autodesk Map™) и объекты - ассоциативные размеры (AutoCAD и AutoCAD LT).

Кроме Autodesk, существуют производители программного обеспечения, использующие ObjectARX для создания приложений, с помощью которых можно строить графические и неграфические сторонние объекты. Эти объекты можно использовать в приложениях AutoCAD.

Объекты-заместители

Объекты-заместители используются в AutoCAD и других приложениях вместо сторонних объектов, созданных с помощью приложения ObjectARX, если последнее недоступно. В дальнейшем, когда приложение становится доступным, объект-заместитель заменяется сторонним объектом.

Объекты-заместители сильно упрощены по сравнению с исходными сторонними объектами. Возможности редактирования сторонних объектов определяются приложениями ObjectARX, в котором объекты были созданы. Например, такие операции, как стирание или перемещение объекта, а также изменение его свойств могут быть допустимы или нет в зависимости от создавшего их приложения.

Открывая чертеж, следует обратить внимание на диалоговое окно "Информация о заместителях". В этом окне выводится общее количество объектов-заместителей (как графических, так и неграфических), имя приложения, необходимого для нормального вывода замещенных объектов, а также дополнительная информация о типе и способе отображения объектов-заместителей. С помощью опций данного диалогового окна можно управлять выводом объектов-заместителей на чертеже.

Адаптеры объектов

Адаптер объектов - это средство доступа для специального просмотра и стандартного редактирования сторонних объектов в других приложениях, использующееся, если приложение, в котором был создан сторонний объект, в системе не установлено.

Использование адаптеров объектов обеспечивает большую гибкость работы со сторонними объектами, чем непосредственное использование объектов-заместителей. Адаптеры объектов также обеспечивают возможность коллективной работы с другими продуктами Autodesk.

Если приложение ObjectARX не установлено в системе, можно выполнить поиск доступных адаптеров объектов в Интернете. Например, при получении чертежа с объектами, созданными с помощью программы Autodesk Architectural Desktop, которая не установлена в системе, выполняется загрузка адаптера объектов AEC для просмотра чертежа в исходном виде. Поиск адаптеров объектов можно включить и отключить с помощью параметров в списке "Адаптер объектов" вкладки "Система" диалогового окна "Параметры".

Полный список доступных в настоящее время адаптеров объектов представлен на веб-узле корпорации Autodesk по адресам http://www.autodesk.com/enablers.

Классификация объектов

Если в приложении (например Autodesk Map) объекту была присвоена классификация, ее можно просмотреть на палитре "Свойства" в группе "Имя класса". Если классификация объекта удалена из XML-файла, или удален сам файл классификаций, в группе имен классов выводится восклицательный знак. Подробнее о классификациях см. документацию по Autodesk Map.

Можно также использовать опцию "Быстрый выбор" для выбора объектов по именам или свойствам классов.


Работа со сторонними объектами и заместителями (Краткий справочник)

Работа с чертежами AutoCAD в AutoCAD LT
Работа со сторонними объектами и заместителями
Извлечение данных с помощью мастера извлечения данных
Совместное использование данных в чертежах и приложениях > Работа с данными других форматов > Использование чертежей из разных приложений и версий > Работа со сторонними объектами и заместителями >
Работа со сторонними объектами и заместителями
Понятие Краткий справочник

Команды

EXPORTTOAUTOCAD

Создание нового DWG-файла со всеми расчлененными AD-объектами

Системные переменные

PROXYGRAPHICS

Управление сохранением объектов-заместителей в чертеже

PROXYNOTICE

Отображение сообщения при создании объекта-заместителя

PROXYSHOW

Управление отображением объектов-заместителей на чертеже

PROXYWEBSEARCH

Установка в программе режима поиска адаптеров объектов

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Извлечение данных из чертежей и электронных таблиц

Работа со сторонними объектами и заместителями
Совместное использование данных в чертежах и приложениях
Коротко об извлечении данных
Совместное использование данных в чертежах и приложениях >
Извлечение данных из чертежей и электронных таблиц

Предусмотрена возможность извлечения данных о свойствах из объектов чертежей с последующим экспортом в таблицу или внешний файл.

С помощью мастера извлечения данных можно выбрать объекты и их свойства, из которых требуется извлечь данные с сохранением параметров в файле. Можно также объединить извлеченные данные с информацией в электронной таблице Microsoft Excel. С помощью стилей таблиц можно быстро создать таблицу заданного формата, имеющую название и заголовки столбцов.

Если в результате изменения чертежа извлеченные данные отличаются от текущих данных на чертеже, отображается уведомление о необходимости обновить таблицу.

Темы в этом разделе

  • Коротко об извлечении данных

    С помощью мастера извлечения данных можно извлечь информацию о свойствах объектов на чертеже, включая блоки и их атрибуты, а также информацию о свойствах чертежа, в том числе имя чертежа и сводную информацию. Извлеченные данные можно связать с информацией в электронной таблице Microsoft Excel, а также вывести в таблицу или внешний файл.

  • Извлечение данных с помощью мастера извлечения данных

    Мастер извлечения данных позволяет выбрать источник данных (чертежи), в котором требуется извлечь данные свойств из выбранных объектов. Данные можно вывести в таблицу или во внешний файл.

  • Создание связи с электронной таблицей Excel для доступа к данным

    Информацию в электронной таблице Microsoft Excel можно объединить с извлеченными из чертежа данными.

  • Вывод извлеченных данных

    Предусмотрена возможность экспорта данных в таблицу или во внешний файл.

  • Обновление извлеченных данных

    Извлеченные данные в таблице можно обновить как вручную, так и автоматически.

  • Изменение таблицы извлечения данных

    Предусмотрены следующие возможности изменения таблицы извлечения данных: изменение форматирования, добавление строк и столбцов, редактирование данных в ячейках.


Коротко об извлечении данных

Извлечение данных из чертежей и электронных таблиц
Извлечение данных из чертежей и электронных таблиц
Извлечение данных с помощью мастера извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц >
Коротко об извлечении данных

С помощью мастера извлечения данных можно извлечь информацию о свойствах объектов на чертеже, включая блоки и их атрибуты, а также информацию о свойствах чертежа, в том числе имя чертежа и сводную информацию. Извлеченные данные можно связать с информацией в электронной таблице Microsoft Excel, а также вывести в таблицу или внешний файл.

Необходимые данные, включая блоки и атрибуты, а также информацию о чертеже, можно беспрепятственно извлекать из объектов для создания различных спецификаций или списка деталей. Пусть, например, при работе с проектом строительства жилого здания требуется создать расписание установки дверей и поместить его на чертеже. Мастер извлечения данных позволяет выбрать только объекты, которые являются дверями (в данном случае - блоками), и извлечь данные атрибутов. Повышенная гибкость достигается за счет того, что с помощью мастера извлечения данных можно также извлечь информацию о свойствах объектов.

После выбора свойств дверей извлеченные данные отображаются в окне мастера в виде столбцов. В этих столбцах можно структурировать и уточнить информацию. После структурирования данных их можно отформатировать, указав стиль таблиц или применив существующую таблицу в качестве шаблона.

После настройки внешнего вида таблицы ее можно вставить в чертеж; на этом процедура извлечения завершается. Для обмена извлеченными данными с другими членами рабочей группы можно вывести эти данные во внешний файл.

Информацию, сохраненную в электронной таблице Excel, можно связать и объединить с извлеченными данными чертежа (данными о свойствах объектов). Допустим, что в предыдущем примере дополнительная информация о дверях на чертеже (поставщик и стоимость) содержится в электронной таблице Excel. Можно выбрать в электронной таблице столбцы с информацией о поставщике и стоимости, а затем объединить эту информацию с другими данными из набора извлеченных данных.

Столбцы электронной таблицы Excel добавляются к столбцам на странице "Исправление данных" мастера извлечения данных.

Все столбцы, кроме столбца "Стоимость", добавлены к столбцам извлеченных данных. Столбцы Excel обозначены специальным значком на метке столбца.

Таблица, вставленная в чертеж, содержит как столбцы извлеченных данных, так и столбцы из электронной таблицы Excel.

При изменении чертежа, из которого извлечены данные свойств, может отображаться уведомление о том, что таблица извлечения данных уже не соответствует текущим данным. Например, можно выбрать режим, в котором при изменении размеров или удалении дверей отображается уведомление о необходимости обновления таблицы извлечения данных. Уведомления особенно удобно использовать в ответственные моменты выполнения операций, когда важно знать, обновлены ли данные таблицы, например, при печати или публикации.


Извлечение данных с помощью мастера извлечения данных (Понятие)

Коротко об извлечении данных
Извлечение данных из чертежей и электронных таблиц
Запуск извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц >
Извлечение данных с помощью мастера извлечения данных
Понятие Процедура Краткий справочник

Мастер извлечения данных позволяет выбрать источник данных (чертежи), в котором требуется извлечь данные свойств из выбранных объектов. Данные можно вывести в таблицу или во внешний файл.

Мастер извлечения данных поможет выполнить следующие действия:

  • Выбор источника данных: чертежа, набора чертежей или папок.
  • Фильтрация объектов для извлечения данных (блоки или другие объекты) и выбор свойств, из которых требуется извлечь данные.
  • Структурирование и уточнение извлеченных данных.
  • Объединение информации из электронной таблицы Excel с извлеченными данными.
  • Выбор формата вывода данных (таблица и/или внешний файл).
  • Форматирование извлеченных данных в таблице путем задания стиля таблицы или выбора существующей таблицы, отформатированной заранее.

При первом извлечении данных отображается запрос на сохранение параметров извлечения данных в файле извлечения данных (DXE). Последующее редактирование набора извлеченных данных осуществляется путем выбора файла DXE, содержащего все параметры (источник данных, выбранные объекты и их свойства, формат вывода и стиль таблицы), которые использовались при создании набора извлеченных данных. Например, если требуется удалить из набора извлеченных данных некоторые данные свойств, следует выбрать файл DXE, который использовался при создании набора извлеченных данных, и внести требуемые изменения.

Можно также применить файл извлечения данных в качестве шаблона для выполнения извлечения того же типа на другом чертеже. В файле DXE указаны чертежи и папки, объекты и свойства, а также варианты форматирования. Файл DXE удобно использовать при необходимости многократного извлечения аналогичной информации; он позволяет сэкономить время.

Предусмотрена также возможность редактирования файла DXE. Можно добавлять и удалять чертежи, добавлять и удалять объекты, а также выбирать различные свойства, из которых требуется извлекать данные. Изменения внесенные в файл DXE, отображаются в таблицах, которые ссылаются на этот файл, даже в том случае, если эти таблицы расположены на других чертежах.

ПримечаниеПри извлечении данных из блоков и атрибутов можно применить файл извлечения атрибутов (BLK) в качестве шаблона. При использовании файла BLK для извлечения данных или редактирования набора извлечения данных отображается запрос на сохранение набора извлечения данных в файл DXE для перехода к процессу извлечения.

Темы в этом разделе

  • Запуск извлечения данных
  • Выбор источника для извлечения данных

    Данные можно извлечь из отдельных объектов на чертеже, из всех объектов на одном чертеже, из нескольких чертежей или из папок.

  • Выбор объектов для извлечения данных

    Предусмотрена возможность выбора объектов, в том числе блоков и их атрибутов, а также информации о свойствах чертежа для извлечения данных.

  • Структурирование и уточнение извлеченных данных

    Перед выводом в таблицу или внешний файл извлеченные данные можно организовать, исправить и отформатировать.

  • Использование стилей таблиц для таблиц извлечения данных

    Для форматирования таблицы извлечения данных можно применить стиль таблиц или существующую таблицу.


Извлечение данных с помощью мастера извлечения данных (Процедура)

Сохранение чертежей в форматах прежних версий
Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Извлечение данных с помощью мастера извлечения данных
Понятие Процедура Краткий справочник

Создание новой таблицы извлечения данных

Редактирование набора извлечения данных для таблицы

Открепление файла извлечения данных (DXE) от таблицы


Создание новой таблицы извлечения данных (Процедура)

Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Извлечение данных с помощью мастера извлечения данных
Понятие Процедура Краткий справочник

Создание новой таблицы извлечения данных

Перед началом работы с мастером извлечения данных рекомендуется сохранить текущий чертеж. Если текущий чертеж не сохранен, отображается запрос на сохранение чертежа перед переходом к извлечению данных.

  1. Выберите следующие элементы: вкладка "Аннотирование" [image] панель "Таблицы" [image] Извлечение данных. В командной строке введите "данныеизвл".
  2. В мастере извлечения данных на странице "Начало" выберите "Новое извлечение данных". Если необходимо использовать файл-шаблон (DXE или BLK), выберите "Использовать предыдущее извлечение в качестве шаблона". Нажмите "Далее".
  3. В диалоговом окне "Сохранение извлечения данных" укажите имя файла извлечения данных. Нажмите кнопку "Сохранить".
  4. На странице "Определение источника данных" укажите чертежи или папки, из которых требуется извлечь данные. Нажмите "Далее".
  5. На странице "Выбор объектов" выберите объекты, из которых требуется извлечь данные. Нажмите "Далее".
  6. На странице "Выбор свойств" выберите свойства, из которых требуется извлечь данные. Нажмите "Далее".
  7. При необходимости измените структуру столбцов на странице "Исправление данных". Нажмите "Далее".
  8. На странице "Выбор типа вывода" выберите "Вставить таблицу извлечения данных в чертеж" для создания таблицы извлечения данных. Нажмите "Далее".
  9. На странице "Стили таблиц" выберите стиль таблицы. При необходимости введите название таблицы. Нажмите "Далее".
  10. На страничке "Окончание" нажмите кнопку "Готово".
  11. При отображении запроса на создание таблицы выберите на чертеже точку вставки.

Информацию о связывании с электронной таблицей Microsoft Excel см. в разделе Создание связи с электронной таблицей Excel для доступа к данным.

Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Редактирование набора извлечения данных для таблицы (Процедура)

Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Извлечение данных с помощью мастера извлечения данных
Понятие Процедура Краткий справочник

Редактирование набора извлечения данных для таблицы

  1. Щелкните правой кнопкой мыши на таблице извлечения данных. Выберите Извлечение данных [image] Редактировать параметры извлечения данных.

    В мастере извлечения данных отображается таблица Определение источника данных. Файл извлечения данных (DXE), который использовался для данной таблицы, загружается автоматически.

  2. Нажмите "Далее".
  3. Выполните необходимые изменения набора извлечения данных на страницах мастера.
  4. На страничке "Окончание" нажмите кнопку "Готово".
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Открепление файла извлечения данных (DXE) от таблицы (Процедура)

Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Выбор источника для извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Извлечение данных с помощью мастера извлечения данных
Понятие Процедура Краткий справочник

Открепление файла извлечения данных (DXE) от таблицы

  • Щелкните на таблице извлечения данных правой кнопкой мыши и выберите "Извлечение данных" [image] "Разорвать связь с данными".

    Данные в таблице больше не связаны с файлом извлечения данных (DXE) и не могут быть обновлены.


Извлечение данных с помощью мастера извлечения данных (Краткий справочник)

Работа со сторонними объектами и заместителями
Извлечение данных с помощью мастера извлечения данных
Запуск извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Извлечение данных с помощью мастера извлечения данных
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Запуск извлечения данных (Понятие)

Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Выбор источника для извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Запуск извлечения данных
Понятие Краткий справочник

При создании нового набора извлеченных данных отображается запрос на сохранение подробных сведений об извлечении в файле извлечения данных (DXE). В файле DXE хранится информация о выбранных чертежах и папках, о выбранных объектах и свойствах, а также о параметрах форматирования.

В любой момент можно выполнить извлечение такого де типа, применив файл извлечения данных в качестве шаблона. Файл DXE удобно использовать при необходимости многократного извлечения аналогичной информации; он позволяет сэкономить время.

Также можно редактировать существующий набор извлечения данных для добавления или удаления чертежей и объектов, а также выбора различных свойств, из которых необходимо извлечь данные. Таблицы, ссылающиеся на один и тот же файл DXE, отображают изменения при обновлении даже в том случае, если эти таблицы находятся в других чертежах.


Запуск извлечения данных (Краткий справочник)

Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Выбор источника для извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Запуск извлечения данных >
Запуск извлечения данных
Понятие Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Выбор источника для извлечения данных (Понятие)

Запуск извлечения данных
Извлечение данных с помощью мастера извлечения данных
Выбор объектов для извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Выбор источника для извлечения данных
Понятие Процедура Краткий справочник

Данные можно извлечь из отдельных объектов на чертеже, из всех объектов на одном чертеже, из нескольких чертежей или из папок.

При выборе чертежа извлекаются все объекты на чертеже, в том числе скрытые. Если требуется извлечь данные из конкретных объектов на чертеже, можно создать набор выбранных объектов.

После выбора чертежа или объектов для извлечения данных можно отфильтровать выходные данные с помощью функций в Мастер извлечения данных. Например, можно выбрать извлечение данных только из внешних ссылок или только из объектов пространства модели. Эти функции удобно использовать для фильтрации данных перед их извлечением. При последующей сортировке потребуется обработка меньшего объема информации.

Можно включить отображение уведомления о необходимости обновления данных, если изменение чертежей влияет на извлеченные данные. Более подробную информацию см. в разделе Автоматическое обновление таблицы извлечения данных.

ПримечаниеВремя отображения уведомления о необходимости обновления задается системной переменной DXEVAL .

Выбор папок для извлечения данных

В диалоговом окне Параметры добавления папок можно выбрать папки для извлечения данных, включая вложенные папки. Если в диалоговом окне не установлен флажок "Автоматически включать добавляемые к этой папке чертежи в набор извлеченных данных", выбранная папка становится "активной", т.е. ее содержимое отслеживается. При добавлении чертежей к такой папке отображается уведомление о том, что набор извлеченных данных уже не соответствует текущим данным.

Если к папке добавлены новые чертежи, при редактировании набора извлеченных данных в диалоговом окне "Поиск новых чертежей" отображается список чертежей. В этот момент можно выбрать новые чертежи для добавления к набору извлеченных данных.

Имя чертежа, добавленного к папке после извлечения данных, отображается в списке в диалоговом окне "Поиск новых чертежей".

Можно настроить фильтрацию поиска с применением символов шаблона (* и ?); при этом данные извлекаются только из тех чертежей, которые соответствуют критерию поиска. Например, символы-шаблоны следует использовать, если папка содержит весь набор чертежей проекта, но требуется извлечь только те чертежи, которые содержат данные трубопроводной системы. Например, *Pipe*.dwg.

Добавление в папку нового чертежа, соответствующего критериям поиска, заданным с помощью символов-шаблонов, не приводит к отображению уведомления о необходимости обновления, поскольку этот чертеж не был включен в исходный набор извлечения данных. Для включения нового чертежа необходимо отредактировать набор извлечения данных.

Если после извлечения данных удалить критерий поиска с символами шаблона, отслеживание чертежей, соответствующих этому критерию поиска, прекращается. Если изменить критерий поиска с символами шаблона, отслеживаются только те чертежи, которые соответствуют новому критерию поиска.


Процедура отслеживания выбранных папок для новых чертежей (Процедура)

Извлечение данных с помощью мастера извлечения данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Выбор источника для извлечения данных >
Выбор источника для извлечения данных
Понятие Процедура Краткий справочник

Процедура отслеживания выбранных папок для новых чертежей

  1. В мастере извлечения данных на странице "Определение источника данных" выберите "Добавить папку".
  2. В диалоговом окне "Параметры добавления папок" снимите флажок "Автоматически включать добавляемые к этой папке чертежи в набор извлеченных данных".
  3. Для контроля вложенных папок выберите "Включая вложенные папки".
  4. Нажмите ОК.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Выбор источника для извлечения данных (Краткий справочник)

Запуск извлечения данных
Извлечение данных с помощью мастера извлечения данных
Выбор объектов для извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Выбор источника для извлечения данных >
Выбор источника для извлечения данных
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Выбор объектов для извлечения данных (Понятие)

Выбор источника для извлечения данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Выбор объектов для извлечения данных
Понятие Краткий справочник

Предусмотрена возможность выбора объектов, в том числе блоков и их атрибутов, а также информации о свойствах чертежа для извлечения данных.

Задание объектов и их свойств для извлечения данных выполняется на следующем этапе после выбора чертежей, из которых требуется извлечь данные. Эти данные будут выведены в таблицу или внешний файл. По умолчанию объекты извлекаются как из пространства модели, так и из пространства листа, включая объекты в блоках и внешних ссылках. В диалоговом окне Извлечение данных - Дополнительные параметры можно изменить значения параметров по умолчанию.

На странице Выбрать объекты мастера отображается список объектов. На этой странице можно использовать фильтры для сортировки объектов по типу (является или не является блоком). Можно наложить на список объектов дополнительные ограничения. Например, можно задать отображение только тех блоков, с которыми связаны атрибуты.

Объекты и их свойства всегда извлекаются с использованием мировой системы координат (МСК) даже в том случае, если во время извлечения данных текущей является пользовательская система координат (ПСК).

Выбор свойств объектов для извлечения

Следующим шагом после выбора объектов является задание свойств, которые требуется извлечь.

На странице Выбор свойств мастера извлечения данных отображается список свойств объектов, выбранных на странице "Выбор объектов". В этом списке выполняется окончательный выбора свойств, из которых требуется извлечь данные для вывода в формате столбцов. Для сокращения списка свойств можно применить фильтрацию по встроенным категориям, таким как "общие", "геометрия" и "атрибут".

Категории свойств для фильтрации извлечения данных

Для удобства фильтрации извлеченные свойства группируются по категориям. Например, если требуется просмотреть только свойства, относящиеся к геометрическим объектам, выберите на странице "Выбор свойств" фильтр "Геометрия".

На странице "Выбор свойств" отображается список категорий для фильтрации при извлечении свойств. Эти категории перечислены ниже.

  • 3D визуализация. Материалы.
  • Атрибут. Ярлыки атрибутов.
  • Чертеж. Имя файла, местоположение, размер, дата создания и изменения.
  • Динамический блок. Свойства динамического блока.
  • Общие. Цвет, гиперссылка, слой, тип линии и т.п.
  • Геометрия. Площадь, начальная точка, конечная точка, радиус и т.п.
  • Разное. Стиль размеров и имя блока.
  • Узор. Имя узора штриховки, угол, масштаб, интервал и т.п.
  • Таблица. Стиль таблицы.
  • Текст. Однострочный текст, многострочный текст, текст размера и т.п.
ПримечаниеКатегории на странице "Выбор свойств" совпадают с категориями, отображаемыми на палитре "Свойства".

Имена свойств

После того, как данные свойств извлечены, в качестве меток столбцов таблицы данных применяются имена свойств по умолчанию (например, "Ширина", "Длина", "Площадь"). Эти имена свойств можно изменить; в этом случае метки столбцов заменяются новыми именами. Например, если из линий извлечено свойство "длина", но метка столбца должна указывать на то, что данные относятся к расстоянию, в столбце "Выводимое имя" на странице "Выбор свойств" можно изменить значение "Длина" на значение "Расстояние".

Отображаемое имя свойства полилиний "длина" изменяется на "Расстояние".

Параметры данных свойств и единиц измерения

Если в качестве источника данных выбрано несколько чертежей, для которых заданы разные единицы измерения, отображается сообщение о несоответствии единиц измерения на чертежах. В этом случае для преобразования числовых значений свойств используется параметр единиц текущего чертежа.

Например, если для параметра единиц текущего чертежа установлено значение дюймы, а для параметра единиц другого чертежа - миллиметры, извлеченные числовые данные автоматически преобразуются в дюймы. Преобразование выполняется даже в том случае, если текущий чертеж не включен в источник данных.

Типы свойств

Каждое значение свойства рассматривается как текстовое или числовое. Например, такие свойства, как радиус или длина, рассматриваются как числовые данные. Числовые значения атрибутов рассматриваются как текстовые данные. Это следует учитывать при использовании столбцов с формулами для выполнения арифметических действий над извлеченными данными.

Блоки с разными масштабами

Объекты, расположенные в блоках с разными масштабами, извлечь нельзя, поскольку числовые значения могут быть некорректными или неприменимыми. Например, если круг находится в блоке, который был вставлен с неравномерным масштабным коэффициентом, то он уже не является правильным кругом.

При обнаружении блоков с разными масштабами во время извлечения отображается диалоговое окно с соответствующим сообщением, и объекты в этих блоках не извлекаются.

Аннотативные объекты

Данные свойств аннотативных объектов извлекаются с помощью текущего параметра масштаба аннотаций.


Выбор объектов для извлечения данных (Краткий справочник)

Выбор источника для извлечения данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Выбор объектов для извлечения данных >
Выбор объектов для извлечения данных
Понятие Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

Нет.

Утилиты

Нет

Ключевые слова для команд

Нет


Структурирование и уточнение извлеченных данных (Понятие)

Выбор объектов для извлечения данных
Извлечение данных с помощью мастера извлечения данных
Использование стилей таблиц для таблиц извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Перед выводом в таблицу или внешний файл извлеченные данные можно организовать, исправить и отформатировать.

На следующем этапе процесса извлечения данных выполняется настройка внешнего вида данных в таблице извлечения данных. Извлеченные данные чертежа отображаются в столбцах страницы Исправление данных , на которой эти столбцы можно отсортировать и переупорядочить, а также добавить к ним столбец формул и т. д. Можно также создать связь с электронной таблицей Excel для добавления к извлеченным данным информации из электронной таблицы.

На этой странице мастера можно выполнять следующие действия по организации и исправлению:

  • Переупорядочение, переименование, скрытие и сортировка данных в столбцах
  • Форматирование данных в ячейках (например, задание формата данных или преобразование текста в нижний регистр)
  • Вставка столбца формул или вставка итоговой нижней строки для отдельных столбцов
  • Фильтрация данных в столбцах
  • Отображение или скрытие столбцов "Количество" или "Имя"
  • Группирование одинаковых строк или отображение их по отдельности
  • Предварительный просмотр таблицы в отдельном окне
  • Создание связи с электронной таблицей Excel

Щелкнув правой кнопкой мыши на метке столбца в табличном представлении на странице "Исправление данных", можно выбрать параметры структурирования информации, отображаемой в таблице, или порядок расположения данных во внешнем файле.

Данные можно отображать в развернутом или свернутом формате. При развернутом формате каждое свойство отображается в отдельной строке сетки данных. В свернутом формате повторяющиеся имена свойств объединены в группы. Автоматически создается столбец "Кол-во", в котором отображается общее количество свойств для каждой строки свойств.

Все столбцы, отображаемые в сетке данных, выводятся в таблицу или внешний файл. Все скрытые столбцы не учитываются.

ПримечаниеСкрытыми могут быть также столбцы, извлеченные из электронной таблицы Excel. Эти скрытые столбцы не включаются в таблицу извлечения данных.

Диалоговое окно Сортировка столбцов позволяет отсортировать один или сразу несколько столбцов.

В таблицу данных можно вставить столбцы формул. Предусмотрено использование основных арифметических операций (+, -, *, /), а также функций команд БЫСТРКАЛЬК и КАЛЬК, например, SIN, COS и LOG. В заголовках столбцов формул отображается соответствующий значок.

При объединении одинаковых строк, содержащих числовые данные, в одну строку отображается сумма данных.

На следующем этапе после структурирования данных на странице " Выбор типа вывода " выполняется выбор формата вывода.

Столбцы из электронной таблицы Excel

Для включения столбцов электронной таблицы Excel в набор извлеченных данных необходимо вызвать диалоговое окно Связь с внешними данными и создать в нем связь с файлом XLS.

Со столбцами, извлеченными из электронной таблицы Excel, можно выполнять различные операции, включая структурирование и скрытие, как со столбцами извлечения данных. В каждом заголовке столбца Excel отображается соответствующий значок, позволяющий отличать столбцы электронной таблицы от столбцов извлеченных данных. Этот значок не отображается в таблице извлечения данных.

Если имена столбцов в электронной таблице содержат указанные ниже символы, перед отображение таблицы данных на странице "Исправление данных" эти символы удаляются.

< > / “ : ; ? * | = ‘

Если метка столбца электронной таблицы Excel совпадает с меткой столбца данных, извлеченных из чертежей, отображаются оба столбца, но к имени метки столбца Excel добавляется суффикс -(Внешний).

См. также
    • Создание связи с электронной таблицей Excel для доступа к данным
    • Использование формул в ячейках таблицы


Структурирование и уточнение извлеченных данных (Процедура)

Выбор источника для извлечения данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура просмотра имени файла извлечения данных, связанного с таблицей, и пути к этому файлу

Переименование заголовка столбца

Процедура сортировки извлеченных данных в столбце

Процедура фильтрации извлеченных данных в столбцах

Процедура задания форматирования извлеченных данных в столбце

Процедура вставки столбца с формулой в набор извлеченных данных

Процедура редактирования формулы в столбце с формулой, добавленном к набору извлеченных данных

Процедура вставки нижней строки с итоговым значением для столбца в таблице извлечения данных

Отображение суммы числовых данных в одинаковых строках свойств


Процедура просмотра имени файла извлечения данных, связанного с таблицей, и пути к этому файлу (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура просмотра имени файла извлечения данных, связанного с таблицей, и пути к этому файлу

  1. Щелкните правой кнопкой мыши на таблице извлечения данных. Выберите "Свойства".
  2. На палитре "Свойства" нажмите кнопку рядом с полем "Связь с данными ячейки".

Отображается путь и имя файла извлечения данных (DXE).


Переименование заголовка столбца (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Переименование заголовка столбца

  1. В мастере извлечения данных на странице "Исправление данных" щелкните на метке столбца правой кнопкой мыши. Выберите "Переименовать столбец".
  2. Выберите "Переименовать столбец".
  3. В поле метки столбца введите новое имя. Нажмите ENTER.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Процедура сортировки извлеченных данных в столбце (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура сортировки извлеченных данных в столбце

  1. В мастере извлечения данных на странице "Исправление данных" выберите "Параметры сортировки столбцов".
  2. В диалоговом окне "Сортировка столбцов" выберите имя столбца из ниспадающего списка.
  3. В столбце "Порядок" выберите "В порядке возрастания" или "В порядке убывания". Нажмите ОК.

    Порядок сортировки данных в столбце изменяется.

  4. (Не обязательно) Для сортировки дополнительных столбцов нажмите "Добавить".
  5. Повторите шаги 2 и 3.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Процедура фильтрации извлеченных данных в столбцах (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура фильтрации извлеченных данных в столбцах

  1. В мастере извлечения данных на странице "Исправление данных" щелкните на метке столбца правой кнопкой мыши. Выберите "Параметры фильтра".
  2. В диалоговом окне "Фильтр" выберите встроенный фильтр в ниспадающем списке.
  3. Из ниспадающего списка слева выберите значение.
  4. В поле "Фильтровать по этим значениям" отмените выбор всех значений для их исключения.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Процедура задания форматирования извлеченных данных в столбце (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура задания форматирования извлеченных данных в столбце

  1. В мастере извлечения данных на странице "Исправление данных" щелкните правой кнопкой мыши на метке столбца, в котором требуется изменить тип данных. В контекстном меню выберите "Задать формат данных столбцов".
  2. В диалоговом окне "Задание формата ячеек" выберите тип данных в списке "Тип данных" ("Угол", "Денежное значение", "Данные", "Десятичное число", "Общие", "Процент", "Точка", "Текст" или "Целое число").
  3. В зависимости от выбранного типа данных задайте дополнительные параметры в правой части диалогового окна.
  4. Нажмите ОК.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Процедура вставки столбца с формулой в набор извлеченных данных (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура вставки столбца с формулой в набор извлеченных данных

  1. В мастере извлечения данных на странице "Исправление данных" щелкните на метке столбца правой кнопкой мыши. Выберите "Вставка столбца с формулой".
  2. В поле "Имя столбца" диалогового окна "Вставка столбца с формулой" введите имя столбца формул.
  3. В списке "Столбцы" дважды щелкните по имени столбца, содержащего числовые данные. Имя столбца отображается в поле "Формула".
  4. Выберите кнопку оператора [ + - * / ]. Оператор отображается в поле "Формула".
  5. Добавьте другой столбец из списка "Имя столбца" или введите числовое значение.
  6. Нажмите "Подтвердить".
  7. Нажмите ОК.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Процедура редактирования формулы в столбце с формулой, добавленном к набору извлеченных данных (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура редактирования формулы в столбце с формулой, добавленном к набору извлеченных данных

  1. В мастере извлечения данных на странице "Исправление данных" щелкните на метке столбца с формулой правой кнопкой мыши. Выберите "Редактировать столбец с формулой".
  2. В диалоговом окне "Редактировать столбец с формулой" измените формулу.
  3. Нажмите "Подтвердить".
  4. Нажмите ОК.
Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Процедура вставки нижней строки с итоговым значением для столбца в таблице извлечения данных (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Структурирование и уточнение извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Процедура вставки нижней строки с итоговым значением для столбца в таблице извлечения данных

  1. В мастере извлечения данных на странице "Исправление данных" щелкните правой кнопкой мыши на метке столбца, к которому требуется добавить нижнюю строку с итоговым значением. Выберите "Вставить итоговую нижнюю строку".
  2. В отображенном подменю выберите "Сумма", "Макс", "Мин" или "Среднее".

Итоговая нижняя строка устанавливается в качестве последней строки выбранного столбца.

Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Отображение суммы числовых данных в одинаковых строках свойств (Процедура)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Создание связи с электронной таблицей Excel для доступа к данным
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Отображение суммы числовых данных в одинаковых строках свойств

  1. В мастере извлечения данных на странице "Исправление данных" выберите "Объединить совпадающие строки.
  2. Щелкните на метке столбца правой кнопкой мыши. Выберите "Объединить режим записи" [image] "Суммировать значения".

    Отображается сумма значений числовых данных.

Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Структурирование и уточнение извлеченных данных (Краткий справочник)

Выбор объектов для извлечения данных
Извлечение данных с помощью мастера извлечения данных
Использование стилей таблиц для таблиц извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Структурирование и уточнение извлеченных данных >
Структурирование и уточнение извлеченных данных
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Использование стилей таблиц для таблиц извлечения данных (Понятие)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
Создание связи с электронной таблицей Excel для доступа к данным
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных >
Использование стилей таблиц для таблиц извлечения данных
Понятие Краткий справочник

Для форматирования таблицы извлечения данных можно применить стиль таблиц или существующую таблицу.

Если на странице " Выбор типа вывода " выбрано создание таблицы извлечения данных, в мастере отображается страница "Стиль таблицы".

На странице " Стиль таблиц" мастера можно выбрать один из трех вариантов форматирования таблицы. Пользователь может:

  • Создать новый стиль таблиц.
  • Выбрать существующий стиль таблиц.
  • Выбрать существующую таблицу, хранящуюся в стиле таблиц.

При создании нового стиля таблиц отображается диалоговое окно Стили таблиц, в котором можно выбрать параметры форматирования.

Если в чертеже определены стили таблиц, можно выбрать существующий стиль таблиц по имени. В любом случае можно добавить название.

Если таблица уже определена в стиле таблиц, ячейки ее названия и заголовка уже содержат текст и таблица отформатирована. Использование существующей таблицы исключает необходимость повторного форматирования и позволяет стандартизировать создание таблиц.

Независимо ли от того, применяется ли стиль таблиц или таблица в рамках стиля таблиц, извлеченные данные вставляются между названием, заголовком и нижними строками (при их наличии в таблице).

Границы ячеек, в которых содержатся извлеченные данные, отображаются жирными линиями.

Перед завершением извлечения можно просмотреть результаты форматирования в отдельном окне предварительного просмотра.

См. также
    • Работа со стилями таблиц


Использование стилей таблиц для таблиц извлечения данных (Краткий справочник)

Структурирование и уточнение извлеченных данных
Извлечение данных с помощью мастера извлечения данных
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Извлечение данных с помощью мастера извлечения данных > Использование стилей таблиц для таблиц извлечения данных >
Использование стилей таблиц для таблиц извлечения данных
Понятие Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание связи с электронной таблицей Excel для доступа к данным

Использование стилей таблиц для таблиц извлечения данных
Извлечение данных из чертежей и электронных таблиц
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц >
Создание связи с электронной таблицей Excel для доступа к данным
Понятие Процедура

Информацию в электронной таблице Microsoft Excel можно объединить с извлеченными из чертежа данными.

С помощью создания связи с электронной таблицей Excel можно включить информацию из всего листа или только его части, т. е. именованного диапазона. В диалоговом окне Связь с внешними данными можно выполнить следующие действия:

  • Задать связь с данными путем выбора файла XLS, с которым требуется связать данные, извлеченные из чертежа.
  • Задать соответствие между извлеченными данными чертежа и данными электронной таблицы. (Более подробную информацию см. в разделе О связывании и установлении соответствия данных.)
  • Выбрать в файле XLS столбцы, которые требуется объединить с извлеченными данными чертежа.

На странице "Исправление данных" предусмотрен доступ к диалоговому окну "Связь с внешними данными", в котором можно настроить связь извлеченных данных со всей электронной таблицей Excel или с диапазоном строк и столбцов.

Для создания связи с электронной таблицей необходимо, чтобы на компьютере, выполняющем извлечение данных, было установлено приложение Microsoft Excel. Если не установлена программа Microsoft Excel или файл XLS не сохранен локально на компьютере, на котором выполняется извлечение данных, установить связь с данными невозможно.

После изменения связанной электронной таблицы, например, после добавления строки или столбца, можно обновить таблицу на чертеже в соответствии с этим изменением с помощью команды СВЯЗЬОБНОВИТЬ . Аналогичным образом, при изменении таблицы в чертеже связанную электронную таблицу можно обновить с помощью этой же команды.

См. также
    • Коротко об извлечении данных

Темы в этом разделе

  • О связывании и установлении соответствия данных
  • Проверка соответствия данных


Создание связи с электронной таблицей Excel для доступа к данным (Процедура)

Структурирование и уточнение извлеченных данных
Создание связи с электронной таблицей Excel для доступа к данным
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным >
Создание связи с электронной таблицей Excel для доступа к данным
Понятие Процедура

Процедура создания связи таблицы извлечения данных с данными в электронной таблице Excel

Процедура настройки именованного диапазона в Microsoft Excel для использования при извлечении данных

Процедура просмотра связи таблицы извлечения данных с данными электронной таблицы Excel

Процедура удаления связи таблицы извлечения данных с электронной таблицей Excel.


О связывании и установлении соответствия данных (Понятие)

Создание связи с электронной таблицей Excel для доступа к данным
Создание связи с электронной таблицей Excel для доступа к данным
Проверка соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник

Связывание данных заключается в выборе электронной таблицы Microsoft Excel с целью объединения всей таблицы или ее части с извлеченными данными чертежа. Более подробную информацию о связывании данных см. в разделе Создание связи таблицы с внешними данными.

В процессе задания соответствия данных создается связь между двумя наборами данных: данные в столбце таблицы извлеченных данных чертежа и данные в столбце электронной таблицы Excel.

В следующем примере рассматривается простая спецификация. Из чертежа извлекаются три столбца данных. В этих столбцах содержатся следующие данные: № детали, Редакция и Количество. В спецификацию можно включить два дополнительных столбца данных из электронной таблицы. В этих столбцах содержатся следующие данные Стоимость и Поставщик.

В данном примере электронная таблица содержит столбец номеров деталей, который имеет заголовок Номер по каталогу и соответствует столбцу Номер детали в таблице извлеченных данных. В диалоговом окне "Связь с внешними данными" выберите "Номер детали" в качестве столбца для данных чертежа и "Номер по каталогу" в качестве столбца для внешних данных. Поскольку в столбце данных чертежа и в столбце внешних данных существует по крайней мере одна ячейка соответствующих данных, функция извлечения данных "знает", как связаны между собой оба источника.

Соответствие данных можно проверить путем нажатия кнопки "Проверить соответствие" в диалоговом окне "Связь с внешними данными". При ошибочном соответствии отображается предупреждающее сообщение, указывающее причину. В некоторых случаях правильное создание связи между данными чертежа и данными электронной таблицы невозможно. Более подробную информацию см. в разделе Проверка соответствия данных.

См. также
    • Создание связи таблицы с внешними данными


О связывании и установлении соответствия данных (Процедура)

Создание связи с электронной таблицей Excel для доступа к данным
На уровень вверх ..
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > О связывании и установлении соответствия данных >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник

Процедура создания связи таблицы извлечения данных с данными в электронной таблице Excel

Процедура настройки именованного диапазона в Microsoft Excel для использования при извлечении данных

Процедура просмотра связи таблицы извлечения данных с данными электронной таблицы Excel

Процедура удаления связи таблицы извлечения данных с электронной таблицей Excel.


Процедура создания связи таблицы извлечения данных с данными в электронной таблице Excel (Процедура)

О связывании и установлении соответствия данных
На уровень вверх ..
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > О связывании и установлении соответствия данных >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник

Процедура создания связи таблицы извлечения данных с данными в электронной таблице Excel

  1. В мастере извлечения данных на странице "Исправление данных" выберите "Связь с внешними данными".
  2. В диалоговом окне "Связь с внешними данными" выберите "Запустить диспетчер связей с данными.
  3. В дереве диспетчера связей с данными выберите параметр "Создайте новую связь с данными Excel".
  4. В диалоговом окне "Ввод имени связи с данными" введите имя связи с данными. Нажмите ОК.
  5. Нажмите кнопку [...] для поиска файла .xls или .csv, с которым требуется создать связь.
  6. В диалоговом окне "Новая связь с данными Excel" выберите вариант связи (вся электронная таблица, диапазон или именованный диапазон Excel). Нажмите ОК.
  7. Выберите новую связь с данными в дереве диспетчера связей с данными. Нажмите ОК.
  8. В диалоговом окне "Связь с внешними данными" в списке "Столбец данных чертежа" укажите столбец, с которым требуется создать связь.
  9. В списке "Столбец внешних данных" укажите столбец Excel, с которым требуется создать связь.
  10. Нажмите "Проверить соответствие". В случае возникновения ошибки см. Проверка соответствия данных.
  11. В списке "Выберите столбцы внешних данных для включения" укажите столбцы Excel, которые требуется добавить к извлеченным данным.
  12. Нажмите ОК.
Панель:Редактирование II
Ввод команды: ДАННЫЕИЗВЛ


Процедура настройки именованного диапазона в Microsoft Excel для использования при извлечении данных (Процедура)

О связывании и установлении соответствия данных
На уровень вверх ..
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > О связывании и установлении соответствия данных >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник

Процедура настройки именованного диапазона в Microsoft Excel для использования при извлечении данных

  1. Откройте требуемую книгу или электронную таблицу в Microsoft Excel.
  2. Выберите диапазон ячеек для задания связанного диапазона.
  3. Введите имя диапазона ячеек в поле "Имя", затем нажмите ENTER.
  4. При необходимости повторите шаги 2 и 3 для задания дополнительных связанных диапазонов.
  5. В меню "Файл" (Microsoft Excel) выберите "Сохранить".


Процедура просмотра связи таблицы извлечения данных с данными электронной таблицы Excel (Процедура)

О связывании и установлении соответствия данных
На уровень вверх ..
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > О связывании и установлении соответствия данных >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник

Процедура просмотра связи таблицы извлечения данных с данными электронной таблицы Excel

  • Щелкните правой кнопкой мыши на таблице извлечения данных. Выберите "Свойства".

В поле "Связь с данными ячейки" на палитре "Свойства" отображается имя связи с данными таблицы.


О связывании и установлении соответствия данных (Процедура)

О связывании и установлении соответствия данных
На уровень вверх ..
О связывании и установлении соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > О связывании и установлении соответствия данных >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник
Меню: Сервис
Ввод команды: СВЯЗЬОБНОВИТЬ


Процедура удаления связи таблицы извлечения данных с электронной таблицей Excel. (Процедура)

О связывании и установлении соответствия данных
На уровень вверх ..
Вывод извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > О связывании и установлении соответствия данных >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник

Процедура удаления связи таблицы извлечения данных с электронной таблицей Excel.

  • Выберите таблицу извлечения данных и щелкните правой кнопкой мыши. Выберите "Связи с данными" [image] "Разорвать связь с данными".

Связь с данными электронной таблицы Excel удаляется из таблицы извлечения данных.


О связывании и установлении соответствия данных (Краткий справочник)

Использование стилей таблиц для таблиц извлечения данных
О связывании и установлении соответствия данных
Проверка соответствия данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > О связывании и установлении соответствия данных >
О связывании и установлении соответствия данных
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Проверка соответствия данных (Понятие)

О связывании и установлении соответствия данных
Создание связи с электронной таблицей Excel для доступа к данным
Вывод извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным >
Проверка соответствия данных
Понятие Краткий справочник

Сбой при проверке соответствия данных означает, что невозможно найти допустимое соответствие между данными чертежа и внешними данными (в электронной таблице). Отображаются следующие сообщения об ошибках.

Соответствия между значениями в данных чертежа и внешними данными не обнаружены.

  • Если неполадку устранить не удается, объединение внешних данных не происходит. Сравните данные столбца электронной таблицы с данными чертежа и попробуйте найти соответствующие значения. Например, для данных чертежа и внешних данных может быть установлены разные значения точности.

Столбец данных во внешних данных не содержит уникальных значений.

  • Столбец внешних данных содержит одну или несколько ячеек с одинаковыми данными. В этой ситуации невозможно однозначно задать соответствие между данными чертежа и внешними данными.


Проверка соответствия данных (Краткий справочник)

О связывании и установлении соответствия данных
Проверка соответствия данных
Вывод извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Создание связи с электронной таблицей Excel для доступа к данным > Проверка соответствия данных >
Проверка соответствия данных
Понятие Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Вывод извлеченных данных (Понятие)

Проверка соответствия данных
Извлечение данных из чертежей и электронных таблиц
Обновление извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц >
Вывод извлеченных данных
Понятие Процедура Краткий справочник

Предусмотрена возможность экспорта данных в таблицу или во внешний файл.

На странице " Выбор типа вывода " мастера извлечения данных можно задать вывод извлеченных данных в таблицу извлечения данных и/или во внешний файл.

Вывод извлеченных данных в таблицу

Если на странице "Выбор типа вывода" установлен флажок "Вставка в чертеж таблицы извлеченных данных", по завершении процесса извлечения отображается запрос на вставку таблицы в текущий чертеж. Таблица создается на основе выбранного стиля и заполняется информацией, извлеченной из источника данных. При наличии связи с электронной таблицей Excel столбцы, выбранные в электронной таблице, включаются в таблицу.

Хотя таблица извлечения данных по внешнему виду сходна с таблицей, созданной с помощью команды ТАБЛИЦА, между ними имеются существенные различия.

  • Если таблица выбрана, в отображаемой всплывающей подсказке содержится информация об извлечении данных.

    При открытии чертежа, содержащего таблицу извлечения данных, в AutoCAD LT текст всплывающей подсказки указывает на наличие в таблице извлеченных данных. Обновление извлеченных данных, а также изменение связи с данными (если она существует) невозможно.

  • Ячейки заблокированы; их содержимое можно изменить только после разблокирования. (По умолчанию форматирование для ячеек разблокировано.)

Ячейки таблицы извлечения данных заблокированы по умолчанию для предотвращения редактирования. Отдельные ячейки или таблицу можно разблокировать, если требуется изменить данные. Более подробную информацию см. в разделе Изменение таблицы извлечения данных.

См. также
    • Изменение таблицы извлечения данных

Вывод извлеченных данных в файл

Данные, извлекаемые в таблицу, можно экспортировать во внешний файл. На странице Выбор типа вывода выберите вариант вывода данных во внешний файл. При наличии связи с электронной таблицей Excel данные этой таблицы также экспортируются.

Предусмотрена возможность экспорта данных в файлы следующих форматов.

  • Microsoft Excel (XLS)
  • Microsoft Access (MDB)
  • C разделителями - запятыми (CSV). Файл .csv представляет собой файл данных, в котором для разделения полей используется символ запятой, а для разделения записей (строк) - символ новой строки. Этот формат подходит для ввода данных в большинство приложений, работающих с электронными таблицами.
  • C разделителями - символами табуляции (TXT). Файл txt представляет собой файл данных, в котором для разделения полей используется символ табуляции. Этот формат подходит для ввода данных в приложение, работающее с электронными таблицами. Информация о форматировании не включается.
Примечание Если точка (.), запятая (,) или решетка (#) записываются в файл Excel или Access, они заменяются кодами Unicode.

Щелчок правой кнопкой мыши на таблице извлечения данных позволяет получить доступ к функции "Экспорт" для вывода содержимого всей таблицы в файл CSV. Также можно применить команду -ДАННЫЕИЗВЛ для экспорта данных чертежа с использованием файла-шаблона BLK или DXE.

При экспорте в файл Microsoft Excel (XLS) или Microsoft Access (MDB) можно вывести не более 255 столбцов. Если число столбцов извлеченных данных превышает 255, после нажатия кнопки "Далее" на странице "Выбор типа вывода" отображается диалоговое окно. Это диалоговое окно содержит сообщение о том, что будут экспортированы только первые 255 столбцов. В файлы, разделенные запятыми (CSV), а также символами табуляции (TXT), можно экспортировать неограниченное число столбцов.


Вывод извлеченных данных (Процедура)

О связывании и установлении соответствия данных
Вывод извлеченных данных
Вывод извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Вывод извлеченных данных >
Вывод извлеченных данных
Понятие Процедура Краткий справочник

Процедура экспорта извлеченных данных во внешний файл с помощью мастера извлечения данных

Экспорт извлеченных данных таблицы в файл, разделенный запятыми (CSV)


Процедура экспорта извлеченных данных во внешний файл с помощью мастера извлечения данных (Процедура)

Вывод извлеченных данных
Вывод извлеченных данных
Вывод извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Вывод извлеченных данных >
Вывод извлеченных данных
Понятие Процедура Краткий справочник

Процедура экспорта извлеченных данных во внешний файл с помощью мастера извлечения данных

  1. Выберите следующие элементы: вкладка "Аннотирование" [image] панель "Таблицы" [image] Извлечение данных. В командной строке введите "данныеизвл".
  2. На каждой странице мастера извлечения данных выбирайте "Следующ" до отображения страницы "Выбор типа вывода".
  3. Выберите "Вывести данные во внешний файл".
  4. Нажмите кнопку "Обзор". Выберите формат файла из ниспадающего списка.
  5. Нажмите "Далее". Следуйте подсказкам мастера до отображения страницы "Конец".
  6. Нажмите "Готово".

Внешний файл создан.

Панель:Редактирование-2
Ввод команды: ДАННЫЕИЗВЛ


Экспорт извлеченных данных таблицы в файл, разделенный запятыми (CSV) (Процедура)

Вывод извлеченных данных
Вывод извлеченных данных
Обновление извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Вывод извлеченных данных >
Вывод извлеченных данных
Понятие Процедура Краткий справочник

Экспорт извлеченных данных таблицы в файл, разделенный запятыми (CSV)

  1. Выберите таблицу и щелкните правой кнопкой мыши. Нажмите кнопку "Экспорт".
  2. В диалоговом окне "Экспорт данных" введите имя файла или воспользуйтесь именем по умолчанию. Нажмите кнопку "Сохранить".

В качестве внешнего файла создан файл CSV.


Вывод извлеченных данных (Краткий справочник)

Проверка соответствия данных
Вывод извлеченных данных
Обновление извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Вывод извлеченных данных >
Вывод извлеченных данных
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Обновление извлеченных данных (Понятие)

Вывод извлеченных данных
Извлечение данных из чертежей и электронных таблиц
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц >
Обновление извлеченных данных
Понятие Процедура Краткий справочник

Извлеченные данные в таблице можно обновить как вручную, так и автоматически.

Предусмотрена возможность обновления извлеченных данных для обеспечения их соответствия источнику данных. Извлеченные данные можно обновить вручную независимо от способа их вывода (в таблицу или внешний файл) или при отображении соответствующего уведомления во время использования определенных команд, например, СОХРАНИТЬ или ПЕЧАТЬ. Затем можно выбрать обновление таблицы в диалоговом окне "Извлечение данных - Устаревшая таблица".

ПримечаниеДля извлеченных данных во внешних файлах проверка соответствия текущему состоянию источника данных не выполняются, и уведомления не отображаются.

Обновление таблицы извлечения атрибутов

Предусмотрена возможность обновления содержимого таблицы, созданной с помощью мастера извлечения атрибутов. Перед обновлением таблицу необходимо преобразовать в таблицу извлечения данных.

ПримечаниеПри преобразовании таблицы извлечения атрибутов в таблицу извлечения данных ширина и высота столбцов не сохраняется.
См. также
    • Выбор источника для извлечения данных

Темы в этом разделе

  • Обновление извлеченных данных вручную

    Извлеченные данные в таблице или внешнем файле можно обновить вручную.

  • Автоматическое обновление таблицы извлечения данных

    Можно задать отображение уведомлений при изменении извлеченных данных.


Обновление извлеченных данных (Процедура)

Вывод извлеченных данных
Обновление извлеченных данных
Обновление извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных >
Обновление извлеченных данных
Понятие Процедура Краткий справочник

Редактирование параметров извлечения данных для таблицы извлечения данных

Преобразование таблицы извлечения атрибутов в таблицу извлечения данных


Редактирование параметров извлечения данных для таблицы извлечения данных (Процедура)

Обновление извлеченных данных
Обновление извлеченных данных
Обновление извлеченных данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных >
Обновление извлеченных данных
Понятие Процедура Краткий справочник

Редактирование параметров извлечения данных для таблицы извлечения данных

  1. В чертеже щелкните правой кнопкой мыши на таблице извлечения данных. Выберите Извлечение данных [image] Редактировать параметры извлечения данных.
  2. На странице "Определение источника данных" мастера извлечения данных выполните любые изменения.
  3. Нажмите "Далее". Продолжая работу с мастером, вносите необходимые изменения до отображения страницы "Готово".
  4. Нажмите "Готово".


Преобразование таблицы извлечения атрибутов в таблицу извлечения данных (Процедура)

Обновление извлеченных данных
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных >
Обновление извлеченных данных
Понятие Процедура Краткий справочник

Преобразование таблицы извлечения атрибутов в таблицу извлечения данных

  1. Щелкните на таблице извлечения атрибутов правой кнопкой мыши. Выберите "Преобразование в таблицу извлечения данных".
  2. В отображенном диалоговом окне введите имя файла извлечения данных (DXE) и нажмите "Сохранить".


Обновление извлеченных данных (Краткий справочник)

Вывод извлеченных данных
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных >
Обновление извлеченных данных
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Обновление извлеченных данных вручную (Понятие)

Обновление извлеченных данных
Обновление извлеченных данных
Автоматическое обновление таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Извлеченные данные в таблице или внешнем файле можно обновить вручную.

В случае изменения чертежей, из которых извлечены данные, можно обновить данные вручную. Предусмотрено два способа обновления таблицы извлечения данных.

  • Откройте чертеж, на котором расположена таблица, и с помощью мастера извлечения данных отредактируйте файл DXE, содержащий параметры извлечения.
  • Щелкните на таблице извлечения данных правой кнопкой мыши для доступа к контекстному меню. Выберите "Извлечение данных" [image] "Обновить извлечение данных".

Для обновления извлеченных данных, которые сохранены во внешнем файле, необходимо запустить мастер извлечения данных и выбрать файл DXE, который использовался для извлечения.

ПримечаниеФайл .dxe сохраняется под именем и в папке, которые были указаны при создании нового файла извлечения данных.

Файл извлечения данных (DXE) также позволяет редактировать существующий набор извлечения данных для добавления или удаления чертежей и объектов, а также выбора различных свойств, из которых необходимо извлечь данные. Таблицы, ссылающиеся на один и тот же файл DXE, отображают изменения при обновлении даже в том случае, если эти таблицы находятся в других чертежах.

ПримечаниеДля доступа к необходимым для редактирования и обновления таблиц контекстным меню в области рисования необходимо установить флажок "Контекстные меню в области рисования" в диалоговом окне "Настройка" (вкладка "Пользовательские").


Обновление извлеченных данных вручную (Процедура)

Обновление извлеченных данных
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Изменение существующих извлеченных данных во внешнем файле

Изменение связи с данными для таблицы извлечения данных

Просмотр файла извлечения данных (DXE), связанного с таблицей извлечения данных

Просмотр файла извлечения данных (DXE) и связанного с ним файла Excel (XLS), соответствующего чертежу

Удаление связи с данными для таблицы извлечения данных

Обновление таблицы извлечения данных вручную


Изменение существующих извлеченных данных во внешнем файле (Процедура)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Изменение существующих извлеченных данных во внешнем файле

  1. В чертеже щелкните правой кнопкой мыши на таблице извлечения данных. Выберите Извлечение данных [image] Редактировать параметры извлечения данных.
  2. На странице "Определение источника данных" мастера извлечения данных выполните любые изменения.
  3. Нажмите "Далее". Следуйте подсказкам мастера и выполняйте необходимые изменения до отображения страницы "Конец".
  4. Нажмите "Готово".


Изменение связи с данными для таблицы извлечения данных (Процедура)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Изменение связи с данными для таблицы извлечения данных

  1. В чертеже щелкните правой кнопкой мыши на таблице извлечения данных. Выберите Извлечение данных [image] Редактировать параметры извлечения данных.
  2. На странице "Определение источника данных" мастера извлечения данных нажимайте "Далее" до отображения страницы "Исправление данных".
  3. Нажмите кнопку "Связь с внешними данными".
  4. Выберите "Запуск диспетчера связей с данными".
  5. Нажмите кнопку "Создайте новую связь с данными Excel".
  6. В диалоговом окне "Ввод имени связи с данными" введите имя связи с данными. Нажмите ОК.
  7. Нажмите кнопку [...] для поиска файла .xls.
  8. В диалоговом окне "Новая связь с данными Excel" выберите вариант связи (вся электронная таблица, диапазон или именованный диапазон Excel). Нажмите ОК.
  9. Выберите новую связь с данными в дереве диспетчера связей с данными. Нажмите ОК.


Просмотр файла извлечения данных (DXE), связанного с таблицей извлечения данных (Процедура)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Просмотр файла извлечения данных (DXE), связанного с таблицей извлечения данных

  • Щелкните правой кнопкой мыши в ячейке таблицы извлечения данных на чертеже. Нажмите "Связь с данными ячейки".

    Отображается путь и имя файла DXE.


Просмотр файла извлечения данных (DXE) и связанного с ним файла Excel (XLS), соответствующего чертежу (Процедура)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Просмотр файла извлечения данных (DXE) и связанного с ним файла Excel (XLS), соответствующего чертежу

  • Выберите Вставить [image] Внешние ссылки.В командной строке введите "внссылки".

Отображается имя и путь к файлу. При наличии связи с данными файла Microsoft Excel (XLS) информация об этой связи отображается на панели "Подробности".


Удаление связи с данными для таблицы извлечения данных (Процедура)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Обновление извлеченных данных вручную
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Удаление связи с данными для таблицы извлечения данных

  • В чертеже щелкните правой кнопкой мыши таблицу извлечения данных. Выберите "Извлечение данных" [image] "Разорвать связь с данными".

    Файл .DXE открепляется от таблицы извлечения данных.


Обновление таблицы извлечения данных вручную (Процедура)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Обновление таблицы извлечения данных вручную

  • Щелкните правой кнопкой мыши на таблице извлечения данных. Выберите "Извлечение данных" [image] "Обновить извлечение данных".


Обновление извлеченных данных вручную (Краткий справочник)

Обновление извлеченных данных
Обновление извлеченных данных
Автоматическое обновление таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Обновление извлеченных данных вручную >
Обновление извлеченных данных вручную
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Автоматическое обновление таблицы извлечения данных (Понятие)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных >
Автоматическое обновление таблицы извлечения данных
Понятие Краткий справочник

Можно задать отображение уведомлений при изменении извлеченных данных.

Если изменение источника данных влияет на извлеченные данные в таблице, отображается уведомление о необходимости обновления. (В случае таблиц извлечения атрибутов уведомление не отображается.) В зависимости от значения системной переменной DXEVAL при использовании определенных команд отображается диалоговое окно Извлечение данных - Устаревшая таблица (например команда ОТКРЫТЬ или СОХРАНИТЬ). По умолчанию DXEVAL принимает значение, согласно которому при использовании команды ПЕЧАТЬ или ФОРМКОМПЛЕКТ проверка соответствия извлеченной информации данным источника выполняется без автоматического обновления.

ВниманиеЕсли DXEVAL = 8 (обновление при публикации), а для BACKGROUNDPLOT задано значение 2 или 3, при публикации файлов отображается запрос на обновление. Однако таблицы в файле DWF не обновляются. Если требуется отражать обновления таблиц в опубликованных файлах, задайте для BACKGROUNDPLOT значение 0 или 1.

Автоматическое обновление можно настроить для следующих команд: СОХРАНИТЬ, ПЕЧАТЬ, ПУБЛ и ФОРМКОМПЛЕКТ. Если автоматическое обновление включено, проверка соответствия извлеченной информации данным источника выполняется автоматически. При обнаружении несоответствия процедура обновления выполняется без вмешательства пользователя. При использовании команды ПЕЧАТЬ или ФОРМКОМПЛЕКТ извлеченные данные обновляются перед печатью или передачей чертежей, которые не сохраняются.

Если открыто несколько чертежей и системная переменная DXEVAL в каждом из них принимает значение, согласно которому при использовании команды ОТКРЫТЬ выполняется проверка необходимости обновления, для каждого чертежа, содержащего устаревшую таблицу извлечения данных, отображается диалоговое окно "Устаревшая таблица". Для каждого чертежа, содержащего таблицу, которую требуется обновить, можно выполнить обновление сразу или пропустить все операции обновления.

В последнем случае обновление можно выполнить позднее из контекстного меню таблицы извлечения данных.

Ячейки таблицы извлечения данных, отредактированные в предыдущей версии программы, становятся разблокированными при открытии в текущей версии программы. При обновлении таблицы в текущей версии программы отображается диалоговое окно, содержащее сообщение о том, что некоторые ячейки были перезаписаны. Во время обновления перезапись ячеек можно выполнить немедленно или пропустить.

ПримечаниеПеред выполнением завершающей операции сохранения, печати, публикации, формирования комплекта или архивирования рекомендуется включить функцию уведомления.


Автоматическое обновление таблицы извлечения данных (Краткий справочник)

Обновление извлеченных данных вручную
Обновление извлеченных данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Обновление извлеченных данных > Автоматическое обновление таблицы извлечения данных >
Автоматическое обновление таблицы извлечения данных
Понятие Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Изменение таблицы извлечения данных (Понятие)

Автоматическое обновление таблицы извлечения данных
Извлечение данных из чертежей и электронных таблиц
Внешние базы данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Предусмотрены следующие возможности изменения таблицы извлечения данных: изменение форматирования, добавление строк и столбцов, редактирование данных в ячейках.

После вставки таблицы извлечения данных в чертеж можно изменять ее формат, добавлять столбцы и строки и редактировать ячейки, содержащие извлеченные данные.

Все изменения формата, структуры и данных фиксируются после обновления таблицы. В частности, при обновлении таблицы сохраняются такие изменения, как добавление тонирования в строке заголовка или изменение параметров форматирования текста в отдельных столбцах.

По умолчанию все ячейки таблицы извлечения данных заблокированы для редактирования и разблокированы для изменения формата. Разблокирование и блокирование ячеек для изменения данных и формата осуществляется из контекстного меню таблицы.

Добавление столбцов и строк

Столбцы и строки можно добавлять в таблицу извлечения данных без воздействия на извлеченные данные. Если таблица выбрана, границы ячеек, содержащих извлеченные данные, отображаются жирными линиями. Столбцы и строки можно добавлять только вне этого контура. Следует иметь в виду, что во время обновления возможно образование пустых ячеек в результате извлечения дополнительных данных, и, наоборот, сокращение числа столбцов или строк, содержащих извлеченные данные.

Например, если после вставки таблицы в чертеж к ней добавлены строка и столбец, при обновлении этой таблицы область, заполненная извлеченными данными, распространяется на добавленный столбец. В таблице сохраняются добавленные вручную столбец и строка, но образуется незаполненная ячейка, соответствующая пустому значению.

Используя этот же пример, если при обновлении таблицы произошло сокращение числа столбцов и строк, содержащих извлеченные данные, столбцы и строки, вставленные пользователем, будут расположены на том же месте. Область, в которой изначально находились столбцы и строки извлеченных данных, теперь содержит пустые ячейки.

Редактирование содержимого ячеек

Ячейки данных заблокированы по умолчанию для предотвращения непроизвольных изменений. Для редактирования содержимого ячейки ее необходимо разблокировать вручную. При обновлении таблицы предоставляется возможность выбора: перезаписать отредактированные ячейки или не обновлять их.

См. также
    • Создание и редактирование таблиц


Изменение таблицы извлечения данных (Процедура)

Обновление извлеченных данных вручную
Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Процедура редактирования/разблокирования ячеек в таблице извлечения данных

Редактирование/разблокирование всех ячеек в таблице извлечения данных

Редактирование текста в разблокированной ячейке таблицы

Определение состояния блокировки ячеек таблицы

Добавление столбца в таблицу извлечения данных

Добавления строки в таблицу извлечения данных

Выравнивание размеров всех столбцов и строк таблицы


Процедура редактирования/разблокирования ячеек в таблице извлечения данных (Процедура)

Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Процедура редактирования/разблокирования ячеек в таблице извлечения данных

  • В чертеже щелкните правой кнопкой мыши на ячейке таблицы извлечения данных. Выберите Блокирование ячейки [image] Данные.

Ячейка разблокируется для редактирования.


Редактирование/разблокирование всех ячеек в таблице извлечения данных (Процедура)

Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Редактирование/разблокирование всех ячеек в таблице извлечения данных

  • В чертеже щелкните правой кнопкой мыши на ячейке таблицы извлечения данных. Выберите Блокирование ячейки [image] Все [image] Разблокировать.

Все ячейки таблицы разблокируются для редактирования.


Редактирование текста в разблокированной ячейке таблицы (Процедура)

Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Редактирование текста в разблокированной ячейке таблицы

  • Щелкните правой кнопкой мыши в ячейке таблицы извлечения данных на чертеже. Выберите "Редактировать текст ячейки".

Все ячейки таблицы разблокируются для редактирования.


Определение состояния блокировки ячеек таблицы (Процедура)

Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Определение состояния блокировки ячеек таблицы

  1. Щелкните правой кнопкой мыши в ячейке таблицы извлечения данных на чертеже. Выберите "Свойства".
  2. На палитре "Свойства" посмотрите на поле "Блокирование ячеек".

В этом поле отображается одно из следующих состояний.

  • Разблокировано: ячейка разблокирована для изменения данных и формата.
  • Данные заблокированы: ячейка заблокирована для изменения данных.
  • Формат заблокирован: ячейка заблокирована для изменения формата.
  • Данные и формат заблокированы: ячейка заблокирована для изменения данных и формата.


Добавление столбца в таблицу извлечения данных (Процедура)

Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Добавление столбца в таблицу извлечения данных

  1. Щелкните правой кнопкой мыши на ячейке в первом или последнем столбце.
  2. Для вставки столбца перед первым столбцом выберите "Столбцы" [image] "Вставить слева". Для вставки столбца после последнего столбца выберите "Столбцы" [image] "Вставить справа".


Добавления строки в таблицу извлечения данных (Процедура)

Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Добавления строки в таблицу извлечения данных

  1. Щелкните правой кнопкой мыши на ячейке в первой или последней строке.
  2. Для вставки строки над первой строкой выберите "Строки" [image] "Вставить выше". Для вставки строки под последней строкой выберите "Строки" [image] "Вставить ниже".


Выравнивание размеров всех столбцов и строк таблицы (Процедура)

Изменение таблицы извлечения данных
Изменение таблицы извлечения данных
Доступ к базе данных из AutoCAD
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Выравнивание размеров всех столбцов и строк таблицы

  • Выберите таблицу и щелкните правой кнопкой мыши. Выберите "Столбцы одного размера" или "Строки одного размера".


Изменение таблицы извлечения данных (Краткий справочник)

Автоматическое обновление таблицы извлечения данных
Изменение таблицы извлечения данных
Обзор использования внешних баз данных
Совместное использование данных в чертежах и приложениях > Извлечение данных из чертежей и электронных таблиц > Изменение таблицы извлечения данных >
Изменение таблицы извлечения данных
Понятие Процедура Краткий справочник

Команды

ДАННЫЕИЗВЛ

Извлечение из чертежей и экспорт данных свойств объектов и слияние данных из внешнего источника с таблицей извлечения данных или с внешним файлом

Системные переменные

DXEVAL

Управление отображением уведомления об обновлении для таблиц извлечения данных

Утилиты

Нет

Ключевые слова для команд

Нет


Внешние базы данных

Изменение таблицы извлечения данных
Совместное использование данных в чертежах и приложениях
Обзор использования внешних баз данных
Совместное использование данных в чертежах и приложениях >
Внешние базы данных

С графическими объектами чертежа можно связывать данные из внешних баз данных.

С помощью программы можно подключать к графическим объектам чертежа данные, хранящиеся во внешних базах данных, таких как dBASE, Oracle и Microsoft Access. Данные средства можно с успехом применять, не имея специальных знаний по базам данных и языкам запросов. Однако, для получения максимального эффекта желательно наличие некоторого опыта работы с языком SQL.

Темы в этом разделе

  • Обзор использования внешних баз данных

    При подключении к графическим объектам чертежа записей базы данных применяются запросы - это мощное средство отбора и сортировки информации. Результаты выполнения запросов могут быть представлены графически.

  • Доступ к базе данных из AutoCAD

    После настройки источника данных можно просматривать и редактировать записи базы данных непосредственно из программы.

  • Подключение записей базы данных к графическим объектам

    Процесс подключения записей базы данных к графическим объектам заключается в создании связей между объектами чертежа и таблицами внешней базы данных.

  • Использование меток

    Метки представляют собой многострочные текстовые объекты, содержимое которых определяется содержимым выбранных полей тех или иных записей таблицы внешней базы данных.

  • Использование запросов для выбора информации из базы данных

    Запросы позволяют извлекать из базы данных требуемые записи.

  • Совместное использование запросов, шаблонов связей и меток

    Запросы, шаблоны связей и меток можно экспортировать и импортировать.

  • Работа со связями в файлах предыдущих версий

    Связи ASE чертежей форматов R12, R13 и R14 можно преобразовывать в связи формата AutoCAD 2000 и более поздних версий. Связи формата AutoCAD 2000 можно сохранять в форматах R13 и R14.


Обзор использования внешних баз данных (Понятие)

Внешние базы данных
Внешние базы данных
Доступ к базе данных из AutoCAD
Совместное использование данных в чертежах и приложениях > Внешние базы данных >
Обзор использования внешних баз данных
Понятие Краткий справочник

При подключении к графическим объектам чертежа записей базы данных применяются запросы - это мощное средство отбора и сортировки информации. Результаты выполнения запросов могут быть представлены графически.

База данных представляет собой совокупность логически связанной информации, которая обычно представляется в табличном виде как, например, в электронных таблицах. Следующая таблица представляет собой пример содержимого простейшей базы данных, которая может использоваться техническим отделом для проведения плановых работ по техническому обслуживанию оборудования. Таблица состоит из четырех столбцов, имеющих названия "Вид работ", "Время на выполнение", "Периодичность" и "Исполнитель". Значения переменных хранятся в отдельных полях (ячейках). Каждая строка таблицы называется записью.

Техническое обслуживание
Вид работ | Время на выполнение | Периодичность | Исполнитель
ОБСЛУЖ. ЛИФТА | 3,5 | РАЗ В КВАРТАЛ | ПЕТРОВ Д.
ЧИСТКА ПОКРЫТИЙ | 5,25 | РАЗ В НЕДЕЛЮ | МАРИНИНА А.
ПРОВЕРКА ЭЛ. ОБОРУДОВАНИЯ | 2,00 | РАЗ В ДВЕ НЕДЕЛИ | СИДОРОВ Д.
ПРОВЕРКА ВОЗДУХООЧИСТИТЕЛЯ | 3,00 | РАЗ В МЕСЯЦ | ИВАНЦОВ Р.

Современные системы управления базами данных обладают большой гибкостью и легко адаптируются. Имеется возможность добавлять в таблицы новые столбцы или удалять ненужные. Аналогично, можно добавлять, удалять или изменять записи таблицы. При наличии нескольких баз данных можно также определить взаимосвязи между несколькими таблицами баз данных. Предположим, например, что имеются две таблицы, каждая из которых содержит в отдельном столбце информацию о номерах комнат. С использованием реляционной базы данных эти две таблицы можно объединить на основе общего столбца. При этом отпадает необходимость в повторном вводе одних и тех же данных в разные таблицы.

Программа предоставляет возможность связывать с графическими объектами чертежа информацию из таблиц внешних баз данных. Связь - это указатель на определенную запись таблицы базы данных. Программа также позволяет создавать метки, представляющие собой текстовые объекты, содержимое которых определяется содержимым выбранных полей таблицы.

Модуль взаимодействия с внешними базами данными включает в себя следующие элементы:

  • Средство настройки источников данных, которое позволяет программе работать с информацией, хранящейся в той или иной внешней базе данных.
  • Диспетчер подключения к БД, который позволяет создавать в чертежах AutoCAD связи, метки и формировать запросы.
  • Окно просмотра данных, которое позволяет просматривать записи таблицы внешней базы данных непосредственно из программы
  • Редактор запросов, который позволяет формировать, выполнять и сохранять SQL-запросы.
  • Средство преобразования связей и отображаемых атрибутов прежних версий в формат AutoCAD 2000 и более поздних версий
  • Средство выбора по связи, которое позволяет итеративно создавать наборы объектов с помощью запросов и прямого выбора графических объектов на чертеже.


Обзор использования внешних баз данных (Краткий справочник)

Изменение таблицы извлечения данных
Обзор использования внешних баз данных
Настройка базы данных для использования в чертежах AutoCAD
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Обзор использования внешних баз данных >
Обзор использования внешних баз данных
Понятие Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

DBCSTATE

Признак открытого/закрытого состояния окна Диспетчера подключения к БД

Утилиты

Нет

Ключевые слова для команд

Нет


Доступ к базе данных из AutoCAD

Обзор использования внешних баз данных
Внешние базы данных
Настройка базы данных для использования в чертежах AutoCAD
Совместное использование данных в чертежах и приложениях > Внешние базы данных >
Доступ к базе данных из AutoCAD
Понятие Процедура

После настройки источника данных можно просматривать и редактировать записи базы данных непосредственно из программы.

Темы в этом разделе

  • Настройка базы данных для использования в чертежах AutoCAD
  • Просмотр таблицы базы данных

    После настройки источника данных, используя окно просмотра данных, можно просматривать и редактировать записи базы данных непосредственно из программы.

  • Редактирование таблиц баз данных

    В окне просмотра данных можно находить требуемые записи таблицы базы данных и редактировать их. Кроме того, можно удалять имеющиеся записи и добавлять новые.


Доступ к базе данных из AutoCAD (Процедура)

Изменение таблицы извлечения данных
Доступ к базе данных из AutoCAD
Настройка базы данных для использования в чертежах AutoCAD
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD >
Доступ к базе данных из AutoCAD
Понятие Процедура

Для открытия или закрытия Диспетчера подключения к БД

Для изменения конфигурационного файлаjet_dbsamples.udl

Для открытия таблицы БД в режиме просмотра или редактирования

Для открытия таблицы БД непосредственно из Диспетчера подключения к БД

Для настройки режима открытия таблиц БД по двойному нажатию

Для перемещения столбца в таблице

Для изменения ширины столбца в таблице

Для скрытия столбца в таблице

Для показа всех скрытых столбцов в таблице

Для задания порядка расположения записей в окне просмотра данных

Для фиксации положения одного или нескольких столбцов

Для освобождения зафиксированных столбцов

Для задания режима выравнивания текста в ячейках одного или нескольких столбцов

Для выбора шрифта и размера символов, используемых в окне просмотра данных

Для экспорта записей из окна просмотра данных

Для редактирования записи базы данных

Для добавления новой записи в базу данных

Для удаления записи базы данных

Для поиска определенного значения в окне просмотра данных

Для поиска и замены определенного значения в окне просмотра данных

Для закрытия окна просмотра данных с сохранением изменений в базу данных

Для закрытия окна просмотра данных с восстановлением исходных значений


Настройка базы данных для использования в чертежах AutoCAD (Понятие)

Доступ к базе данных из AutoCAD
Доступ к базе данных из AutoCAD
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD >
Настройка базы данных для использования в чертежах AutoCAD
Понятие Процедура Краткий справочник

Для получения доступа к внешней базе данных (БД) из программы ее необходимо настроить с помощью приложений Microsoft ODBC (интерфейс открытого взаимодействия с базами данных) и OLE DB. Драйверы ODBC и OLE DB позволяют использовать в программе информацию из различных баз данных независимо от формата и платформы, использовавшихся для создания БД. Процедура настройки базы данных предполагает создание нового источника данных, в котором хранится информация о наборе данных и драйверах, необходимых для доступа к данным.

Источником данных может служить либо отдельная таблица, либо набор таблиц, место хранения которых описывается понятиями среды, каталога и схемы. Среда, каталог и схема являются теми элементами, которые поддерживаются большинством систем управления БД и упрощают структурирование и манипуляцию данными. Их можно сравнить с файловой системой Windows: среда как бы соответствует папке, в которую вложены другие папки каталогов. Каталоги, в свою очередь, также содержат вложенные папки схемы. Каждая схема представляет собой набор таблиц.

В зависимости от типа используемой базы данных процесс ее настройки несколько различается. Например, базы данных серверного типа, такие как Oracle и Microsoft SQL Server, требуют ввода имени пользователя и пароля, а также задания сетевого расположения базы данных. Файловые базы данных, такие как Microsoft Access и dBASE III, не требуют задания подобной информации. По этой причине невозможно использовать единую процедуру настройки, подходящую для баз данных различного типа. Процедура настройки каждого типа БД, поддерживаемого в программе, приводится в разделе Настройка внешних баз данных. Для получения дополнительной информации следует обратиться к соответствующей документации используемой системы управления базами данных (СУБД), а также к справочной системе по ODBC и OLE DB.

Средство взаимодействия с БД поддерживает следующие внешние приложения:

  • Microsoft Access
  • dBASE
  • Microsoft Excel
  • Oracle
  • Базы данных Paradox
  • Microsoft Visual FoxPro
  • SQL Server
Примечание64-разрядная версия AutoCAD не поддерживает работу с Поставщиком OLE DB Microsoft Jet 4.0 (для взаимодействия с файлами .MDB) и Поставщиком OLE DB Microsoft для драйверов ODBC(для взаимодействия с файлами .XLS). Дополнительную информацию см. в разделе Замена SQL Server на OLE DB.

Программа содержит файл примера базы данных Microsoft Access и настроенный драйвер (jet_dbsamples.udl), который можно использовать для работы с базой данных. Для использования этих файлов не требуется наличие приложения Access, установленного в системе. Данный файл находится в папке Sample, которая находится в папке установки. Если же папка Sample перемещена в другое место, то для возможности работы с данными таблицами следует обновить путь к ней в файле настройки jet_dbsamples.udl.

Диспетчер подключения к БД

Диспетчер подключения к базам данных представляет собой специальное окно, содержащее область структуры и набор кнопок. Положение и размер данного окна можно изменять. Из Диспетчера подключения к БД можно быстро вызывать окно просмотра данных, предназначенное для просмотра и редактирования таблиц базы данных. С помощью Диспетчера можно быстро создавать объекты базы данных (шаблоны связей, шаблоны меток и запросы), которые хранятся в файле чертежа.

Область структуры Диспетчера подключения к БД содержит разделы (узловые элементы) двух основных типов:

  • Узлы чертежа. Каждый такой элемент соответствует одному открытому чертежу и объединяет все объекты базы данных, связанные с данным чертежом.
  • Источники данных. Объединяет все настроенные источники данных.

С каждым элементом области структуры Диспетчера подключения к БД связано контекстное меню. С помощью контекстного меню можно, например, настроить источник данных или изменить сохраненный запрос.


Настройка базы данных для использования в чертежах AutoCAD (Процедура)

Доступ к базе данных из AutoCAD
На уровень вверх ..
Настройка базы данных для использования в чертежах AutoCAD
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Настройка базы данных для использования в чертежах AutoCAD >
Настройка базы данных для использования в чертежах AutoCAD
Понятие Процедура Краткий справочник

Для открытия или закрытия Диспетчера подключения к БД

Для изменения конфигурационного файла jet_dbsamples.udl


Для открытия или закрытия Диспетчера подключения к БД (Процедура)

Настройка базы данных для использования в чертежах AutoCAD
На уровень вверх ..
Настройка базы данных для использования в чертежах AutoCAD
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Настройка базы данных для использования в чертежах AutoCAD >
Настройка базы данных для использования в чертежах AutoCAD
Понятие Процедура Краткий справочник

Для открытия или закрытия Диспетчера подключения к БД

  • Выберите меню Сервис [image] Палитры [image] Базы данных.
Ввод команды: БДСВЯЗЬ


Для изменения конфигурационного файлаjet_dbsamples.udl (Процедура)

Настройка базы данных для использования в чертежах AutoCAD
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Настройка базы данных для использования в чертежах AutoCAD >
Настройка базы данных для использования в чертежах AutoCAD
Понятие Процедура Краткий справочник

Для изменения конфигурационного файла jet_dbsamples.udl

  1. Выберите меню Сервис [image] Палитры [image] Связь с БД.
  2. В диспетчере подключения к БД щелкните правой кнопкой мыши в древовидном представлении на элементе "Источники данных". Выберите "Настройка источника данных".
  3. В списке "Источники данных" диалогового окна "Настройка источника данных" выделите "Jet_dbsamples". Нажмите "ОК".
  4. На вкладке "Connection" диалогового окна "Data Link Properties" нажмите кнопку [...].
  5. В диалоговом окне "Select Access Database" выберите файл db_samples.mdb. Нажмите "Open".

    Данный файл находится в папке Sample.

  6. Нажмите кнопку "Test Connection" для проверки работоспособности подключения.
  7. Если тест подключения к базе данных завершился неудачно, необходимо убедиться в правильности выбора файла БД.
  8. Нажмите "OK" для закрытия каждого диалогового окна.


Настройка базы данных для использования в чертежах AutoCAD (Краткий справочник)

Обзор использования внешних баз данных
Настройка базы данных для использования в чертежах AutoCAD
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Настройка базы данных для использования в чертежах AutoCAD >
Настройка базы данных для использования в чертежах AutoCAD
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

DBCSTATE

Признак открытого/закрытого состояния окна Диспетчера подключения к БД

Утилиты

Нет

Ключевые слова для команд

Нет


Просмотр таблицы базы данных (Понятие)

Настройка базы данных для использования в чертежах AutoCAD
Доступ к базе данных из AutoCAD
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

После настройки источника данных, используя окно просмотра данных, можно просматривать и редактировать записи базы данных непосредственно из программы.

После настройки источника данных с его таблицами можно работать непосредственно из программы. Делается это с помощью окна просмотра данных, которое позволяет просматривать и редактировать записи таблиц. Таблицы БД можно открывать в режиме "Только чтение" или в режиме "Редактирование". В режиме "Только чтение" не допускается добавление, удаление или изменение записей таблицы. При открытии таблицы выполняется подключение к той базе данных, к которой принадлежит данная таблица. Подключение к базам данных некоторых типов требует ввода имени пользователя и пароля.

В окне просмотра данных выводятся записи из таблицы базы данных. Для перехода между записями можно использовать полосы прокрутки и кнопки управления перемещением, которые располагаются около правой и нижней границ окна.

Основным компонентом окна просмотра данных является таблица, которая состоит из следующих элементов:

  • Заголовок столбца. При нажатии на нем выделяются все ячейки, расположенные в данном столбце.
  • Заголовок записи. При нажатии на нем выделяются все поля (ячейки) данной записи.
  • Ячейки таблицы. При нажатии на ней выделяется содержимое данного поля записи.
  • Заголовок таблицы. При нажатии на нем выделяется вся таблица базы данных.

Окно просмотра данных предоставляет широкие возможности по управлению параметрами отображения записей таблицы. Имеется возможность:

  • Перемещать столбцы или изменять их ширину
  • Скрывать столбцы (отключать их видимость в окне просмотра данных)
  • Сортировать записи по возрастанию или убыванию содержимого столбцов
  • Фиксировать один или несколько столбцов для того, чтобы их положение не изменялось при горизонтальной прокрутке
  • Задавать режим выравнивания содержимого ячеек для каждого столбца
  • Изменять параметры шрифта (тип, размер, начертание), используемого в окне просмотра данных.

Форматирование столбцов и порядок сортировки записей действуют только во время просмотра текущей таблицы. При открытии другой таблицы или закрытии окна просмотра данных эта информация теряется. Если необходимо сохранить отчет, отформатированный определенным образом, содержимое окна просмотра данных следует сначала скопировать в буфер обмена, а затем вставить во внешнее приложение типа Microsoft Excel. Дальнейшее форматирование таблицы можно выполнить уже во внешнем приложении. Для получения информации о создании шаблонов следует обратиться к документации внешнего приложения, которое планируется использовать для форматирования таблиц.

Окно просмотра данных и внешние запросы

Некоторые системы управления базами данных поддерживают использование так называемых видов. Виды позволяют отображать данные из таблицы различными способами. Например, с помощью видов можно отображать только определенную часть информации, имеющейся в таблице. Виды также можно использовать для определения связей между таблицами, а также создания новой таблицы, являющейся производной от нескольких других таблиц.

В системах управления базами данных, не поддерживающих использование видов, аналогичные результаты можно получить с помощью запросов. Более подробную информацию о создании и использовании видов и запросов можно найти в документации по применяемой СУБД.

Виды и внешние запросы отображаются в Диспетчере подключения к БД в разделе "Источники данных". Внешними запросами называются запросы, которые созданы и хранятся во внешней базе данных, а не в программе. С внешними запросами и видами можно работать точно так же, как с обычными запросами и таблицами. Их можно просматривать и редактировать в окне просмотра данных, использовать при формировании запросов, создании связей и меток.


Просмотр таблицы базы данных (Процедура)

Настройка базы данных для использования в чертежах AutoCAD
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для открытия таблицы БД в режиме просмотра или редактирования

Для открытия таблицы БД непосредственно из Диспетчера подключения к БД

Для настройки режима открытия таблиц БД по двойному нажатию

Для перемещения столбца в таблице

Для изменения ширины столбца в таблице

Для скрытия столбца в таблице

Для показа всех скрытых столбцов в таблице

Для задания порядка расположения записей в окне просмотра данных

Для фиксации положения одного или нескольких столбцов

Для освобождения зафиксированных столбцов

Для задания режима выравнивания текста в ячейках одного или нескольких столбцов

Для выбора шрифта и размера символов, используемых в окне просмотра данных

Для экспорта записей из окна просмотра данных


Для открытия таблицы БД в режиме просмотра или редактирования (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для открытия таблицы БД в режиме просмотра или редактирования

  1. Выполнить одно из следующих действий:
    • Для открытия базы данных в режиме "только чтение" выберите меню Базы данных [image] Просмотр данных [image] Просмотр внешней таблицы.
    • Для открытия базы данных в режиме редактирования выберите меню Базы данных [image] Просмотр данных [image] Редактировать внешнюю таблицу.

    Если требуется, при подключении в БД выдается запрос имени пользователя и пароля.

  2. В диалоговом окне "Выбор объекта данных" выберите таблицу, которую необходимо открыть. Нажмите "ОК".
ПримечаниеНекоторые типы баз данных требуют наличия у пользователя прав доступа на просмотр или изменение таблиц БД. Для получения более подробной информации следует обратиться к документации по системе управления БД или к администратору БД.


Для открытия таблицы БД непосредственно из Диспетчера подключения к БД (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для открытия таблицы БД непосредственно из Диспетчера подключения к БД

  • Дважды нажмите левую кнопку мыши на имени таблицы в Диспетчере подключения к БД.

    По умолчанию при двойном нажатии таблица базы данных открывается в режиме "Редактирование". При необходимости двойное нажатие можно настроить для открытия таблицы в режиме "Только чтение".


Для настройки режима открытия таблиц БД по двойному нажатию (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для настройки режима открытия таблиц БД по двойному нажатию

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. На вкладке "Система" установите или снимите флажок "Открывать таблицы только для чтения".
  3. Нажмите "ОК".


Для перемещения столбца в таблице (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для перемещения столбца в таблице

  1. Нажмите кнопку мыши в области заголовка того столбца, который нужно переместить.
  2. Нажмите кнопку мыши еще раз и, не отпуская ее, перетащите столбец в требуемую позицию.


Для изменения ширины столбца в таблице (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для изменения ширины столбца в таблице

  1. В окне просмотра данных захватите линию рамки, расположенную справа от заголовка того столбца, ширину которого нужно изменить.
  2. Для увеличения ширины столбца перетащите линию вправо, для уменьшения - влево.


Для скрытия столбца в таблице (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для скрытия столбца в таблице

  1. В окне просмотра данных выделите заголовок того столбца, видимость которого нужно отключить.
  2. Нажмите правую кнопку мыши на заголовке столбца. Выберите "Скрыть".


Для показа всех скрытых столбцов в таблице (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для показа всех скрытых столбцов в таблице

  • Нажмите правую кнопку мыши в области заголовка любого из столбцов в окне "Просмотр данных". Выберите "Показать все".


Для задания порядка расположения записей в окне просмотра данных (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для задания порядка расположения записей в окне просмотра данных

  1. Нажмите правую кнопку мыши в области заголовка любого из столбцов в окне "Просмотр данных". Выберите "Сортировка".
  2. Выберите столбец для сортировки в списке "Сортировать по". Выберите сортировку "По возрастанию" или "По убыванию".

    При сортировке по возрастанию запись с наименьшим значением в сортируемом столбце размещается первой, с наибольшим - последней. При сортировке по убыванию запись с наибольшим значением в сортируемом столбце размещается первой, с наименьшим - последней.

  3. При необходимости дополнительной сортировки записей выбрать имя столбца из списка "Затем по". Выберите сортировку "По возрастанию" или "По убыванию".

    При использовании дополнительной сортировки все записи сначала сортируются по столбцу, заданному в списке "Сортировать по"; после этого записи, имеющие совпадающее значение в уже упорядоченном столбце, сортируются по столбцу, выбранному из списка "Затем по".

  4. Повторить действия пункта 2 для задания дополнительных условий сортировки записей.

    Сортировка записей таблицы может осуществляться не более чем по пяти столбцам одновременно.


Для фиксации положения одного или нескольких столбцов (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для фиксации положения одного или нескольких столбцов

  1. В окне просмотра данных выделите один или несколько заголовков тех столбцов, положение которых нужно зафиксировать.
  2. Нажмите правую кнопку мыши на одном из выбранных заголовков столбцов. Выберите "Фиксировать".
ПримечаниеФункция "Фиксировать" доступна только в том случае, если выделен один либо несколько смежных столбцов. Если нужно зафиксировать несколько несмежных столбцов, их следует переставить так, чтобы они располагались друг за другом (см. раздел Для перемещения столбца в таблице).


Для освобождения зафиксированных столбцов (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для освобождения зафиксированных столбцов

  • Нажмите правую кнопку мыши в области заголовка любого из столбцов в окне "Просмотр данных". Выберите "Освободить все".


Для задания режима выравнивания текста в ячейках одного или нескольких столбцов (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для задания режима выравнивания текста в ячейках одного или нескольких столбцов

  1. В окне просмотра данных выделите один или несколько заголовков тех столбцов, для которых нужно изменить режим выравнивания текста в ячейках.
  2. Нажмите правую кнопку мыши на заголовке столбца. Выберите "Выравнивание".
  3. Выберите один из следующих режимов выравнивания текста:
    • Стандартное. Для полей числового типа задает выравнивание по правому краю столбца, а для полей любого другого типа - по левому краю столбца.
    • Левое. Задает выравнивание содержимого ячеек по левому краю столбца.
    • По центру. Задает центрирование содержимого ячеек столбца.
    • Правое. Задает выравнивание содержимого ячеек по правому краю столбца.


Для выбора шрифта и размера символов, используемых в окне просмотра данных (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Просмотр таблицы базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для выбора шрифта и размера символов, используемых в окне просмотра данных

  1. Нажмите правую кнопку мыши на левой верхней ячейке в окне просмотра таблицы базы данных. Выберите меню "Формат".
  2. Выберите требуемые параметры шрифта. Нажмите "ОК".


Для экспорта записей из окна просмотра данных (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Для экспорта записей из окна просмотра данных

  1. Откройте таблицу базы данных, дважды нажав на ее имени в Диспетчере подключения к БД.
  2. В окне просмотра данных выделите записи, которые необходимо экспортировать.
  3. Нажмите правую кнопку мыши в любой ячейке. Выберите "Копировать".
  4. Откройте внешнее приложение, в которое необходимо экспортировать данные. Выберите следующие элементы: вкладка "Главная" [image] панель "Утилиты" [image] "Вставить". В командной строке введите "встбуфер".

    Содержимое буфера обмена вставляется во внешнее приложение в виде текста, причем ячейки каждой записи отделяются друг от друга символами табуляции.


Просмотр таблицы базы данных (Краткий справочник)

Настройка базы данных для использования в чертежах AutoCAD
Просмотр таблицы базы данных
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Просмотр таблицы базы данных >
Просмотр таблицы базы данных
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование таблиц баз данных (Понятие)

Просмотр таблицы базы данных
Доступ к базе данных из AutoCAD
Подключение записей базы данных к графическим объектам
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

В окне просмотра данных можно находить требуемые записи таблицы базы данных и редактировать их. Кроме того, можно удалять имеющиеся записи и добавлять новые.

Для получения возможности изменять таблицу базы данных ее следует открыть в окне просмотра данных в режиме "Правка". В этом случае можно добавлять, удалять записи, а также редактировать содержимое полей записи. Кроме того, имеется возможность выполнять поиск нужного значения среди всех ячеек определенного столбца.

ПримечаниеОбласть поиска при работе функции "Найти" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка. С помощью функции "Найти" нельзя выполнять глобальный поиск по всем ячейкам таблицы. Для поиска значения по всей таблице необходимо поочередно выбирать столбцы и выполнять поиск для каждого столбца.

Любые изменения содержимого таблицы в окне просмотра данных сохраняются в базе данных только после выполнения операции принятия. Функция "Принять" обновляет таблицу базы данных в соответствии со значениями, заданными в окне просмотра данных во время сеанса редактирования таблицы, после чего закрывает окно просмотра данных. Функция "Восстановить" отменяет любые изменения, внесенные в окне просмотра данных во время сеанса редактирования таблицы, после чего закрывает окно просмотра данных.

ПримечаниеПри выходе из программы, открытии новой таблицы или закрытии окна просмотра данных любые изменения, внесенные в текущую открытую таблицу, автоматически принимаются и сохраняются в базе данных.

Для облегчения отслеживания изменений заголовки отредактированных записей помечаются специальным значком в виде треугольника. Ориентируясь по этим значкам, можно быстро найти и просмотреть модифицированные записи перед сохранением изменений в базу данных.


Редактирование таблиц баз данных (Процедура)

Просмотр таблицы базы данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для редактирования записи базы данных

Для добавления новой записи в базу данных

Для удаления записи базы данных

Для поиска определенного значения в окне просмотра данных

Для поиска и замены определенного значения в окне просмотра данных

Для закрытия окна просмотра данных с сохранением изменений в базу данных

Для закрытия окна просмотра данных с восстановлением исходных значений


Для редактирования записи базы данных (Процедура)

Редактирование таблиц баз данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для редактирования записи базы данных

  1. В окне просмотра данных выделите ячейку, содержимое которой нужно изменить.
  2. Введите в ячейке новое значение.
  3. Повторите процедуру для всех ячеек, значения которых требуется изменить.

    Для перемещения между ячейками можно использовать клавиши-стрелки.


Для добавления новой записи в базу данных (Процедура)

Редактирование таблиц баз данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для добавления новой записи в базу данных

  1. Нажмите правую кнопку мыши в области заголовка записи (пустой прямоугольник слева от записи). Выберите "Добавить запись".

    Все поля новой записи получают пустые значения, а сама запись добавляется в конец таблицы.

  2. Выделите ячейку новой записи и введите нужное значение.
  3. Повторите пункт 2 для всех дополнительных полей.


Для удаления записи базы данных (Процедура)

Редактирование таблиц баз данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для удаления записи базы данных

  • Нажмите правую кнопку мыши в области заголовка записи, которую требуется удалить (пустой прямоугольник слева от записи). Выберите "Удалить запись".


Для поиска определенного значения в окне просмотра данных (Процедура)

Редактирование таблиц баз данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для поиска определенного значения в окне просмотра данных

  1. Нажмите правую кнопку мыши на одной из ячеек того столбца, в котором нужно выполнить поиск. Нажмите "Найти".
  2. В поле "Что" введите искомое значение.
  3. Задайте направление поиска:
    • Вверх. Поиск осуществляется, начиная от выделенной ячейки по направлению к самой первой записи таблицы.
    • Вниз. Поиск осуществляется, начиная от выделенной ячейки по направлению к самой последней записи таблицы.
  4. Нажмите кнопку "Найти далее".
  5. Повторите пункт 4 для поиска других ячеек, имеющих заданное значение.
ПримечаниеОбласть поиска при работе функции "Найти" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка. С помощью функции "Найти" нельзя выполнять глобальный поиск по всем ячейкам таблицы. Для поиска значения по всей таблице необходимо поочередно выбирать столбцы и выполнять поиск для каждого столбца.


Для поиска и замены определенного значения в окне просмотра данных (Процедура)

Редактирование таблиц баз данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для поиска и замены определенного значения в окне просмотра данных

  1. Нажмите правую кнопку мыши на одной из ячеек того столбца, в котором нужно выполнить поиск. Выберите "Заменить".
  2. В поле "Что" введите искомое значение.
  3. В поле "Заменить на" введите значение, на которое следует заменить найденное значение.
  4. Нажмите кнопку "Найти далее".
  5. Выполните одно из следующих действий:
    • Нажмите кнопку "Заменить" для замены только текущего найденного фрагмента.
    • Нажмите кнопку "Заменить все" для поиска и замены сразу всех искомых фрагментов.
  6. Повторите пункты 4 и 5 для поиска и замены остальных фрагментов, совпадающих с образцом.
ПримечаниеОбласть поиска при работе функции "Заменить" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка. С помощью функции "Заменить" нельзя выполнять глобальный поиск по всем ячейкам таблицы. Для поиска и замены значений во всей таблице необходимо поочередно выбирать столбцы и выполнять поиск и замену для каждого столбца.


Для закрытия окна просмотра данных с сохранением изменений в базу данных (Процедура)

Редактирование таблиц баз данных
На уровень вверх ..
Редактирование таблиц баз данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для закрытия окна просмотра данных с сохранением изменений в базу данных

  • Нажмите правую кнопку мыши на левой верхней ячейке в окне просмотра таблицы базы данных. Нажмите "Принять".


Для закрытия окна просмотра данных с восстановлением исходных значений (Процедура)

Редактирование таблиц баз данных
На уровень вверх ..
Подключение записей базы данных к графическим объектам
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Для закрытия окна просмотра данных с восстановлением исходных значений

  • Нажмите правую кнопку мыши на левой верхней ячейке в окне просмотра таблицы базы данных. Нажмите "Восстановить".
Примечание При выходе из программы, открытии новой таблицы или закрытии окна просмотра данных любые изменения, внесенные в текущую открытую таблицу, автоматически принимаются и сохраняются в базе данных.


Редактирование таблиц баз данных (Краткий справочник)

Просмотр таблицы базы данных
Редактирование таблиц баз данных
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Доступ к базе данных из AutoCAD > Редактирование таблиц баз данных >
Редактирование таблиц баз данных
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Подключение записей базы данных к графическим объектам

Редактирование таблиц баз данных
Внешние базы данных
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных >
Подключение записей базы данных к графическим объектам
Понятие Процедура

Процесс подключения записей базы данных к графическим объектам заключается в создании связей между объектами чертежа и таблицами внешней базы данных.

Темы в этом разделе

  • Создание и редактирование связей и шаблонов связей

    Для создания связи требуется шаблон связи, который определяет, значения каких столбцов таблицы подключаются к объектам при создании связи.

  • Просмотр и выбор существующих связей

    Можно выбирать записи таблицы, выбирая объекты чертежа, к которым эти записи подключены, и наоборот, можно выбирать объекты чертежа, выбирая записи таблицы.

  • Поиск и исправление поврежденных связей

    Функция синхронизации позволяет обнаруживать поврежденные связи.

  • Экспорт связей

    Информацию об имеющихся связях можно экспортировать в текстовый файл.


Подключение записей базы данных к графическим объектам (Процедура)

Редактирование таблиц баз данных
Подключение записей базы данных к графическим объектам
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам >
Подключение записей базы данных к графическим объектам
Понятие Процедура

Для создания шаблона связи в текущем чертеже

Для создания связи между объектом и записью во внешней базе данных

Для редактирования шаблона связи

Для обновления свойств шаблона связи

Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи

Для изменения ключевого значения связи с помощью Диспетчера связей

Для просмотра графических объектов, связанных с записями таблицы

Для просмотра записей базы данных, связанных с выбранными графическими объектами

Для автоматического просмотра графических объектов, связанных с записями таблицы

Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами

Для задания дополнительных режимов просмотра связей

Для синхронизации связей в чертеже

Для экспорта связей из чертежа


Создание и редактирование связей и шаблонов связей (Понятие)

Подключение записей базы данных к графическим объектам
Подключение записей базы данных к графическим объектам
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для создания связи требуется шаблон связи, который определяет, значения каких столбцов таблицы подключаются к объектам при создании связи.

Основным назначением модуля взаимодействия с базами данных является подключение внешних данных к графическим объектам программы. Это позволяет, например, подключать к полилинии чертежа, представляющей стены комнаты, информацию об этом помещении, хранящуюся во внешней базе данных. Подключение внешних данных к графическому объекту осуществляется путем создания связи между объектом и одной или несколькими записями таблицы базы данных. С неграфическими объектами, например, слоями или типами линий, связи устанавливать нельзя.

Связи с графическими объектами обладают ассоциативностью. При переносе или копировании объекта все имеющиеся у него связи также переносятся или копируются. При удалении объекта все его связи удаляются.

При подключении записи базы данных к графическому объекту между ними устанавливается динамическая связь. Это значит, что можно, например, изменить тип помещения со склада на офис в базе данных, и программа обновит данные, хранящиеся в чертеже в соответствии с данными в базе данных.

Для установления связей между записями таблицы и графическими объектами требуется наличие шаблона связи. Шаблон связи определяет, значения каких столбцов таблицы подключаются к объектам при создании связи. Например, можно создать шаблон связи, использующий столбец "Номер комнаты" базы данных о помещениях здания. Далее этот шаблон связи можно применять для создания связей с различными записями данной таблицы базы данных.

Шаблон связи также служит своеобразным ярлыком таблицы базы данных, на основании которой он создан. С помощью имеющихся в чертеже шаблонов связи можно открывать таблицы, указанные в этих шаблонах, для просмотра и редактирования. Данная возможность может оказаться весьма полезной при наличии в системе большого числа настроенных источников данных. При этом вместо того, чтобы искать таблицу в списке всех источников данных, нужную таблицу можно быстро открыть из раздела того чертежа, который ее использует. Для открытия таблицы, заданной в шаблоне связи, следует нажать правую кнопку мыши на имени шаблона в Диспетчере подключения к БД. Выберите команду "Просмотреть таблицу" или "Редактировать таблицу".

К любому графическому объекту чертежа можно подключать данные с использованием разных шаблонов связи. Это позволяет подключать к одному объекту информацию сразу из нескольких таблиц базы данных.

Связи во внешних ссылках и блоках

Из текущего чертежа нельзя просматривать или изменять связи, имеющиеся во внешних ссылках (чертежах, вставленных в текущий чертеж в виде внешних ссылок). Такие связи доступны только при открытии самого исходного чертежа.

Связи, имеющиеся в блоках, доступны, однако не могут редактироваться командой ССЫЛРЕД.

Редактирование шаблонов связей

Иногда возникает необходимость внесения изменений в шаблоны связи. Например, может понадобиться добавить в шаблон еще один ключевой столбец или удалить ранее заданный. Кроме того, обновление шаблона связи может потребоваться в результате изменения источника данных, на который ссылается шаблон, например, после переименования таблицы базы данных или изменения места ее расположения.

ПримечаниеДопускается изменение только тех полей шаблонов связи, для которых не определены связи в чертеже. В противном случае происходит нарушение связей с таблицей базы данных. Для редактирования шаблона связи в чертеже необходимо предварительно удалить все связи, использующие данный шаблон.

Редактирование связей

После создания связей может потребоваться изменить используемые этими связями ключевые значения. Например, можно изменить порядок нумерации некоторых офисов или передать часть комнат бухгалтерии отделу продаж. Для изменения ключевого значения у выбранной связи можно использовать Диспетчер связей. Ключевые значения должны соответствовать тем значениям, которые имеются в таблице базы данных.


Создание и редактирование связей и шаблонов связей (Процедура)

Подключение записей базы данных к графическим объектам
На уровень вверх ..
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для создания шаблона связи в текущем чертеже

Для создания связи между объектом и записью во внешней базе данных

Для редактирования шаблона связи

Для обновления свойств шаблона связи

Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи

Для изменения ключевого значения связи с помощью Диспетчера связей


Для создания шаблона связи в текущем чертеже (Процедура)

Создание и редактирование связей и шаблонов связей
На уровень вверх ..
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для создания шаблона связи в текущем чертеже

  1. Нажмите правую кнопку мыши на файле-источнике данных в окне Диспетчера подключения к БД. Выберите "Новый шаблон связи".
  2. В диалоговом окне "Новый шаблон связи" введите имя шаблона связи в поле "Имя нового шаблона связи". Нажмите кнопку "Далее".
  3. Выберите один или несколько ключевых столбцов, установив соответствующие флажки.

    Число ключевых столбцов должно быть минимальным. Большое количество ключевых столбцов может ухудшить скорость выполнения функций работы с базами данных.

  4. Нажмите "ОК" для создания шаблона.


Для создания связи между объектом и записью во внешней базе данных (Процедура)

Создание и редактирование связей и шаблонов связей
На уровень вверх ..
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для создания связи между объектом и записью во внешней базе данных

  1. Из Диспетчера подключения к БД откройте таблицу, для которой создан хотя бы один шаблон связи.
  2. В окне просмотра данных из списка "Шаблон связи" выберите нужный шаблон связи.
  3. В окне просмотра данных выделите одну или несколько записей, которые необходимо подключить.
  4. Нажмите на стрелку рядом с кнопкой "Связь!" для раскрытия выпадающего списка.
  5. Из раскрытого списка выберите "Создавать связи".
  6. Выберите один или несколько объектов чертежа, к которым необходимо подключить данные.
  7. Нажмите ENTER.


Для редактирования шаблона связи (Процедура)

Создание и редактирование связей и шаблонов связей
На уровень вверх ..
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для редактирования шаблона связи

  1. Выберите меню Базы данных [image] Шаблоны [image] Редактировать шаблон связи.
  2. В диалоговом окне "Выбор объекта базы данных" выберите шаблон связи, который нужно изменить. Нажмите кнопку "Далее".
  3. Выберите один или несколько ключевых столбцов, установив соответствующие флажки.
  4. Нажмите "OK" для сохранения изменений, внесенных в шаблон связи.


Для обновления свойств шаблона связи (Процедура)

Создание и редактирование связей и шаблонов связей
На уровень вверх ..
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для обновления свойств шаблона связи

  1. Выберите меню Базы данных [image] Шаблоны [image] Свойства шаблона связи.
  2. В диалоговом окне "Выбор объекта базы данных" выберите шаблон связи. Нажмите кнопку "Далее".
  3. В диалоговом окне "Свойства шаблона связи" обновите информацию об источнике данных. Нажмите "ОК".


Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи (Процедура)

Создание и редактирование связей и шаблонов связей
На уровень вверх ..
Создание и редактирование связей и шаблонов связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для удаления из текущего чертежа всех связей, использующих определенный шаблон связи

  1. Выберите меню Базы данных [image] Связи [image] Удалить связи.
  2. В диалоговом окне "Выбор объекта базы данных" выберите шаблон связи, связи которого нужно удалить. Нажмите "ОК".


Для изменения ключевого значения связи с помощью Диспетчера связей (Процедура)

Создание и редактирование связей и шаблонов связей
На уровень вверх ..
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Для изменения ключевого значения связи с помощью Диспетчера связей

  1. Выберите меню Базы данных [image] Связи [image] Диспетчер связей.
  2. Выберите на чертеже графический объект, к которому подключены внешние данные.
  3. Следует особо отметить, что Диспетчер связей одновременно может работать только с одним графическим объектом.
  4. В Диспетчере связей выберите одну из связей объекта, которая создана с помощью шаблона связи, указанного в списке "Шаблоны связи".
  5. Введите новое значение в ячейку "Значение" той связи, которую нужно изменить, или нажмите кнопку [...]. Повторите процедуру для других ключевых полей, если необходимо.

    Нажатие кнопки [...] позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

    ПримечаниеКнопка [...] доступна только в том случае, если используемый связью источник данных подключен к чертежу.
  6. Нажмите "OK" для обновления связи и закрытия диалогового окна.


Создание и редактирование связей и шаблонов связей (Краткий справочник)

Редактирование таблиц баз данных
Создание и редактирование связей и шаблонов связей
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Создание и редактирование связей и шаблонов связей >
Создание и редактирование связей и шаблонов связей
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Просмотр и выбор существующих связей (Понятие)

Создание и редактирование связей и шаблонов связей
Подключение записей базы данных к графическим объектам
Поиск и исправление поврежденных связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Можно выбирать записи таблицы, выбирая объекты чертежа, к которым эти записи подключены, и наоборот, можно выбирать объекты чертежа, выбирая записи таблицы.

Внешние данные, подключенные к графическим объектам с помощью связей, можно просматривать. Пусть, например, имеется план офисов, к которому подключены записи базы данных с информацией обо всех сотрудниках фирмы. В этом случае не составит большого труда найти офис любого из сотрудников. Выбрав сотрудника фирмы в окне просмотра данных, можно выделить связанные с ним графические объекты. И наоборот, выбрав объекты чертежа, в окне просмотра данных можно выделить связанные с ними записи и определить, какие сотрудники работают в данном офисе.

Автоматический выбор связанных объектов

Имеется возможность автоматически выбирать на чертеже графические объекты по мере выделения связанных с ними записей в окне просмотра данных. И наоборот, можно автоматически выделять записи базы данных по мере выбора связанных с ними графических объектов чертежа. Однако текущим может быть только один из этих режимов автопросмотра.

Дополнительные режимы просмотра

Для задания различных режимов просмотра связанных графических объектов и записей используется диалоговое окно "Параметры окна просмотра данных и запросов".

Режим "Автоматическое панорамирование" позволяет автоматически панорамировать чертеж так, чтобы объекты, связанные с выделенным в окне просмотра данных набором записей, располагались в области рисования. Однако при фиксированном (текущем) коэффициенте экранного увеличения не всегда возможно разместить в области рисования все объекты, связанные с выделенными записями. Чтобы исключить подобные ситуации, можно активизировать режим автоматического зумирования.

Режим "Автоматическое зумирование" позволяет автоматически подбирать экранное увеличение таким образом, чтобы все объекты, связанные с текущим набором записей, умещались в области рисования. При этом требуется задать коэффициент, определяющий какую часть (в процентах) от области рисования должен занимать выбранный набор объектов. Возможный диапазон значений лежит в переделах от 20 до 90 процентов, по умолчанию используется значение 50 процентов. Если коэффициент равен 50 процентам, то экранное увеличение подбирается таким образом, чтобы высота или ширина набора объектов (большее из этих значений) составляла 50 процентов от области рисования.

Кроме того, имеются следующие группы режимов просмотра связей:

  • Режимы пометки записей. Здесь можно выбрать, какие записи следует отображать в окне просмотра данных - все или только связанные с текущими выбранными графическими объектами. При использовании режима "Все записи, с выделением выбранных" имеется возможность выбрать цвет пометки.
  • Режимы накопления. Здесь можно установить, следует ли по мере выбора графических объектов или записей окна просмотра данных добавлять их в набор объектов или всегда создавать новый набор.

Подробнее о режимах просмотра см. раздел Диалоговое окно "Параметры окна просмотра данных и запросов" описания команды БДСВЯЗЬ в Справочнике команд.


Просмотр и выбор существующих связей (Процедура)

Создание и редактирование связей и шаблонов связей
На уровень вверх ..
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Просмотр и выбор существующих связей >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Для просмотра графических объектов, связанных с записями таблицы

Для просмотра записей базы данных, связанных с выбранными графическими объектами

Для автоматического просмотра графических объектов, связанных с записями таблицы

Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами

Для задания дополнительных режимов просмотра связей


Для просмотра графических объектов, связанных с записями таблицы (Процедура)

Просмотр и выбор существующих связей
На уровень вверх ..
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Просмотр и выбор существующих связей >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Для просмотра графических объектов, связанных с записями таблицы

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В окне просмотра данных выделите одну или несколько записей.
  4. Нажмите правую кнопку мыши на выбранной записи. Выберите "Просмотреть связанные объекты".

    Все объекты чертежа, связанные с выделенными записями, подсвечиваются.


Для просмотра записей базы данных, связанных с выбранными графическими объектами (Процедура)

Просмотр и выбор существующих связей
На уровень вверх ..
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Просмотр и выбор существующих связей >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Для просмотра записей базы данных, связанных с выбранными графическими объектами

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В области рисования выберите один или несколько объектов.
  4. Нажмите кнопку "Просмотр связанных записей в окне просмотра данных" на панели инструментов окна просмотра данных.

    По умолчанию в окно просмотра данных выводятся только те записи, которые связаны с выбранными объектами. При необходимости в диалоговом окне "Параметры запросов и окна просмотра данных" можно задать вывод всех записей.


Для автоматического просмотра графических объектов, связанных с записями таблицы (Процедура)

Просмотр и выбор существующих связей
На уровень вверх ..
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Просмотр и выбор существующих связей >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Для автоматического просмотра графических объектов, связанных с записями таблицы

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. Нажмите кнопку "Автопросмотр связанных объектов в чертеже" на панели инструментов окна просмотра данных.
  4. В окне просмотра данных выделите одну или несколько записей.

    Все графические объекты, связанные с выделенными записями, подсвечиваются в области рисования.

  5. Повторите пункт 4 для выделения дополнительных связанных графических объектов.
  6. Повторите пункт 3 для отключения режима автопросмотра связанных объектов.


Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами (Процедура)

Просмотр и выбор существующих связей
На уровень вверх ..
Просмотр и выбор существующих связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Просмотр и выбор существующих связей >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Для автоматического просмотра записей таблицы, связанных с выбранными графическими объектами

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. Нажмите кнопку "Автопросмотр связанных записей в окне просмотра данных" на панели инструментов окна просмотра данных.
  4. В области рисования выберите один или несколько объектов.

    По умолчанию в окно просмотра данных выводятся только те записи, которые связаны с выбранными объектами. При необходимости в диалоговом окне "Параметры запросов и окна просмотра данных" можно задать вывод всех записей.

  5. Повторите пункт 4 для выделения дополнительных связанных записей.
  6. Повторите пункт 3 для отключения режима автопросмотра связанных записей.


Для задания дополнительных режимов просмотра связей (Процедура)

Просмотр и выбор существующих связей
На уровень вверх ..
Поиск и исправление поврежденных связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Просмотр и выбор существующих связей >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Для задания дополнительных режимов просмотра связей

  1. Нажмите кнопку "Параметры окна просмотра данных и запросов" на панели инструментов окна просмотра данных.
  2. В диалоговом окне "Параметры окна просмотра данных и запросов" задайте требуемые значения параметров.
  3. Нажмите "OK" для сохранения изменений и закрытия диалогового окна.


Просмотр и выбор существующих связей (Краткий справочник)

Создание и редактирование связей и шаблонов связей
Просмотр и выбор существующих связей
Поиск и исправление поврежденных связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Просмотр и выбор существующих связей >
Просмотр и выбор существующих связей
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Поиск и исправление поврежденных связей (Понятие)

Просмотр и выбор существующих связей
Подключение записей базы данных к графическим объектам
Экспорт связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам >
Поиск и исправление поврежденных связей
Понятие Процедура Краткий справочник

Функция синхронизации позволяет обнаруживать поврежденные связи.

Рекомендуется периодически проверять связи чертежей, чтобы обновить или удалить поврежденные связи. Для обнаружения поврежденных связей можно использовать функцию синхронизации, которая выполняет анализ связей выбранного шаблона связи. После запуска функции синхронизации в диалоговом окне выдается список обнаруженных ошибок. Определенные типы ошибок (например изменение формата столбца в таблице базы данных) можно исправить непосредственно с помощью диалогового окна "Синхронизация". Другие типы ошибок (например, подключение к несуществующей записи) следует исправлять в самой таблице базы данных.


Для синхронизации связей в чертеже (Процедура)

Просмотр и выбор существующих связей
На уровень вверх ..
Экспорт связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Поиск и исправление поврежденных связей >
Поиск и исправление поврежденных связей
Понятие Процедура Краткий справочник

Для синхронизации связей в чертеже

  1. Нажмите правую кнопку мыши на шаблоне связи в окне Диспетчера подключения к БД. Нажмите "Синхронизация".

    Если ошибки не обнаружены, отображается соответствующее сообщение. В случае выявления ошибок их список выводится в диалоговом окне "Синхронизация".

  2. В диалоговом окне "Синхронизация" выберите ошибку из списка и выполните одно или несколько из следующих действий:
    • Нажмите кнопку "Выделить объекты чертежа" для выбора объектов, имеющих поврежденные связи.
    • Нажмите кнопку "Исправить" для корректировки поврежденной связи.
    • Нажмите кнопку "Удалить" для удаления поврежденной связи.
  3. Повторите пункт 3 для оставшихся ошибок.
  4. Нажмите кнопку "Закрыть".


Поиск и исправление поврежденных связей (Краткий справочник)

Просмотр и выбор существующих связей
Поиск и исправление поврежденных связей
Экспорт связей
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Поиск и исправление поврежденных связей >
Поиск и исправление поврежденных связей
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Экспорт связей (Понятие)

Поиск и исправление поврежденных связей
Подключение записей базы данных к графическим объектам
Использование меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам >
Экспорт связей
Понятие Процедура Краткий справочник

Информацию об имеющихся связях можно экспортировать в текстовый файл.

Имеющиеся у графических объектов чертежа связи можно экспортировать. Эту возможность удобно использовать в тех случаях, когда к различным записям одной таблицы подключено по несколько графических объектов. Пусть, например, требуется составить перечень используемых на схеме источников освещения с указанием числа источников каждого типа. Очевидно, что необходимая для этого информация отсутствует во внешней базе данных. Записи базы данных предоставляют информацию о самих источниках света (например, типе, технических характеристиках и т.д.). Однако в таблице не хранятся данные о количестве подключений той или иной записи к объектам чертежа. Для получения подобной информации нужно выполнить экспорт имеющихся в чертеже связей.


Для экспорта связей из чертежа (Процедура)

Поиск и исправление поврежденных связей
На уровень вверх ..
Использование меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Экспорт связей >
Экспорт связей
Понятие Процедура Краткий справочник

Для экспорта связей из чертежа

  1. Выберите меню Базы данных [image] Связи [image] Экспорт связей.
  2. Выберите графические объекты чертежа, связи которых нужно экспортировать.

    Если к выбранным графическим объектам внешние данные подключены с помощью нескольких шаблонов связи, в диалоговом окне "Выбор объекта базы данных" выберите нужный шаблон. Если все выбранные объекты используют только один шаблон связи, сразу же вызывается диалоговое окно "Экспорт связей".

  3. В диалоговом окне "Экспорт связей" в списке "Включая поля" выберите поля записей, которые нужно экспортировать.

    Ключевые столбцы шаблона связи выбираются автоматически. Кроме полей записей, для каждой связи также экспортируется идентификатор того объекта, который использует данную связь.

  4. В поле "Имя файла" введите имя выходного файла.
  5. Выберите формат из списка "Тип файла".

    Файл можно сохранить либо в формате исходной базы данных, либо в текстовом файле с отделением полей записи друг от друга запятыми или пробелами.

  6. Нажмите "Сохранить" для экспорта связей и закрытия диалогового окна.
  7. Повторите, если необходимо, пункты с 1 по 6 для экспорта связей других шаблонов связи.


Экспорт связей (Краткий справочник)

Поиск и исправление поврежденных связей
Экспорт связей
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Подключение записей базы данных к графическим объектам > Экспорт связей >
Экспорт связей
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование меток

Экспорт связей
Внешние базы данных
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных >
Использование меток
Понятие Процедура

Метки представляют собой многострочные текстовые объекты, содержимое которых определяется содержимым выбранных полей тех или иных записей таблицы внешней базы данных.

Темы в этом разделе

  • Создание и редактирование меток и шаблонов меток

    Метки могут быть свободными и прикрепленными. Шаблон метки задает, информация из каких полей таблицы базы данных отображается в метках, созданных по этому шаблону.

  • Обновление меток в соответствии с новыми значениями полей базы данных

    Для того чтобы отобразить в чертеже измененные значения полей базы данных, метки требуется обновить.


Использование меток (Процедура)

Экспорт связей
Использование меток
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток >
Использование меток
Понятие Процедура

Для создания шаблона метки

Для создания связи со свободной меткой

Для создания прикрепленной метки

Для редактирования шаблона метки

Для задания параметров форматирования метки

Для обновления меток текущего чертежа


Создание и редактирование меток и шаблонов меток (Понятие)

Использование меток
Использование меток
Обновление меток в соответствии с новыми значениями полей базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Метки могут быть свободными и прикрепленными. Шаблон метки задает, информация из каких полей таблицы базы данных отображается в метках, созданных по этому шаблону.

Связи являются мощным средством, которое используется для подключения внешних данных к графическим объектам. Выбирая объекты, имеющие связи, можно быстро просматривать подключенные к ним записи внешней базы данных. Однако поскольку связи являются невидимыми элементами чертежа, они имеют некоторые ограничения. Например, пусть требуется распечатать чертеж и вместе с чертежом вывести внешние данные, связанные с отдельными связями. Но внешние данные не распечатаются. Связано это с тем, что связи являются всего лишь указателями на записи внешней базы данных. Поэтому при необходимости вывести на чертеж содержимое записей внешних таблиц следует использовать так называемые метки.

Метки представляют собой многострочные текстовые объекты, содержимое которых определяется содержимым выбранных полей тех или иных записей внешней таблицы базы данных.

Метки могут быть свободными или прикрепленными к графическим объектам. Свободная метка не зависит ни от каких графических объектов чертежа. Метка, прикрепленная к графическому объекту, обладает ассоциативностью. При переносе графического объекта прикрепленная к нему метка перемещается вместе с ним. При копировании объекта в буфер обмена метка также копируется. При удалении объекта все прикрепленные к нему метки также удаляются. Метка графического объекта располагается на выноске.

Для создания меток требуется наличие шаблона метки, который задает параметры форматирования метки, а также столбцы таблицы, значения которых определяют текст надписи метки.

Редактирование шаблонов меток

После создания шаблона метки может возникнуть необходимость изменить его. Например, может потребоваться добавить в шаблон другие столбцы таблицы или изменить шрифт или размер символов текста метки. Кроме того, можно задать ряд параметров, которые влияют на выбор точки вставки метки и конфигурацию выноски (только для прикрепленных ярлыков).

Значения смещений по координатам X и Y начала выноски и надписи задаются на вкладке "Смещение метки" диалогового окна "Шаблон метки". В следующей таблице приводятся сведения о назначении данных параметров применительно к свободным и прикрепленным меткам.

Параметры вкладки "Смещение метки"
Флажок | Свободные метки | Прикрепленные метки
Начало | Отсутствует | Задает начальную точку объекта-выноски. Положение точки определяется относительно границ графического объекта, к которому прикрепляется метка. Предположим, например, что для метки, прикрепленной к объекту типа прямоугольник, выбрано значение "Вверх влево". В этом случае начало выноски размещается в левом верхнем углу прямоугольника.
Выноска Отступ | Отсутствует | Задает смещение полки и надписи ярлыка по координатам X и Y относительно начала выноски. По умолчанию смещение полки по X и Y устанавливается равным 1, что задает смещение метки относительно начала выноски (стрелки) на одну единицу чертежа по каждой из координат X и Y.
Совет Отступ | Задает смещение метки по координатам X и Y относительно указанной точки вставки метки. Например, если смещение по X и Y равно -1, то метка смещается от точки вставки метки на одну единицу чертежа в отрицательном направлении каждой из координат. | Задает смещение выноски по координатам X и Y относительно начальной точки. Предположим, например, что для метки, прикрепленной к объекту типа прямоугольник, выбрано значение "Вверх влево". Пусть смещение выноски по координатам X и Y равно 1. В этом случае начало выноски смещается на одну единицу чертежа по осям X и Y относительно левого верхнего угла прямоугольника.

Редактирование меток

Имеется возможность осуществлять различные манипуляции над имеющимися на чертеже метками. Метки и их выноски можно переносить и масштабировать с помощью стандартных команд КОПИРОВАТЬ, ПЕРЕНЕСТИ и МАСШТАБ. Важно отметить, что внесение изменений в отдельные экземпляры меток не влияет на шаблон меток и не приводит к изменению его определения.

ПримечаниеТекст метки не рекомендуется изменять с помощью контекстного редактора. Связано это с тем, что подобные изменения не заносятся в базу данных, а потому после выполнения обновления ярлыков восстанавливаются исходные значения. Поэтому для изменения содержимого метки следует изменить подключенные данные, как описано в разделе Создание и редактирование связей и шаблонов связей, и выбрать "Обновить".


Создание и редактирование меток и шаблонов меток (Процедура)

Использование меток
На уровень вверх ..
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Создание и редактирование меток и шаблонов меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Для создания шаблона метки

Для создания связи со свободной меткой

Для создания прикрепленной метки

Для редактирования шаблона метки

Для задания параметров форматирования метки


Для создания шаблона метки (Процедура)

Создание и редактирование меток и шаблонов меток
На уровень вверх ..
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Создание и редактирование меток и шаблонов меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Для создания шаблона метки

  1. В окне Диспетчера подключения к БД нажмите кнопку "Новый шаблон метки".
  2. В диалоговом окне "Новый шаблон метки" в списке "Имя нового шаблона метки" введите имя шаблона метки.
  3. Для открытия диалогового окна "Шаблон метки" нажмите кнопку "Далее".
  4. В диалоговом окне "Шаблон метки" на вкладке "Поля метки" в списке "Столбец" выберите столбец таблицы, значения из которого должны содержать метки. Нажмите кнопку "Добавить", чтобы добавить его в метку.

    Кроме того, шаблон метки может содержать статический текст, общий для всех меток. Например, можно создать шаблон метки, использующий столбец "Номер комнаты" базы данных о помещениях здания. Для того чтобы каждая метка кроме значения из базы данных содержала еще и имя столбца, в диалоговом окне "Шаблон метки" перед добавлением в шаблон столбца следует ввести Номер комнаты:.

  5. Повторите действия пункта 5 для добавления других столбцов, значения которых должны отображаться в метке.
  6. Нажмите "ОК".


Для создания связи со свободной меткой (Процедура)

Создание и редактирование меток и шаблонов меток
На уровень вверх ..
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Создание и редактирование меток и шаблонов меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Для создания связи со свободной меткой

  1. Из Диспетчера подключения к БД откройте таблицу, для которой создан хотя бы один шаблон связи и один шаблон метки.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В окне просмотра данных из списка "Выбор шаблона метки" выберите требуемый шаблон метки.
  4. В окне просмотра данных выделить запись, которую необходимо подключить.
  5. Нажмите правую кнопку мыши в области заголовка выделенной записи (пустой прямоугольник слева от записи). Выберите Параметры связей и меток [image] Создавать свободные метки.
  6. Выберите меню Просмотр данных [image] Связь.
  7. Задайте положение метки на чертеже.


Для создания прикрепленной метки (Процедура)

Создание и редактирование меток и шаблонов меток
На уровень вверх ..
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Создание и редактирование меток и шаблонов меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Для создания прикрепленной метки

  1. Из Диспетчера подключения к БД откройте таблицу, для которой создан хотя бы один шаблон связи и один шаблон метки.
  2. В окне просмотра данных из списка "Выбор шаблона связи" выберите требуемый шаблон связи.
  3. В окне просмотра данных из списка "Выбор шаблона метки" выберите требуемый шаблон метки.
  4. В окне просмотра данных выделите запись, которую необходимо подключить.
  5. Выберите меню Просмотр данных [image] Параметры связей и меток [image] Создавать прикрепленные метки.
  6. Выберите меню Просмотр данных [image] Связь.
  7. Выберите один или несколько объектов чертежа, для которых нужно создать прикрепленные метки.
  8. Нажмите ENTER.


Для редактирования шаблона метки (Процедура)

Создание и редактирование меток и шаблонов меток
На уровень вверх ..
Создание и редактирование меток и шаблонов меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Создание и редактирование меток и шаблонов меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Для редактирования шаблона метки

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на шаблоне метки, который требуется отредактировать. Нажмите кнопку "Изменить".
  2. Внесите необходимые изменения в диалоговом окне "Шаблон метки", как описано в разделе Для создания шаблона метки.
  3. Нажмите "ОК".


Для задания параметров форматирования метки (Процедура)

Создание и редактирование меток и шаблонов меток
На уровень вверх ..
Обновление меток в соответствии с новыми значениями полей базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Создание и редактирование меток и шаблонов меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Для задания параметров форматирования метки

  1. Создайте новый шаблон метки, как описано в разделе Для создания шаблона метки.
  2. В диалоговом окне "Шаблон метки" выберите параметры форматирования текста с помощью вкладок "Символ" и "Свойства", как описано в разделе МТЕКСТ в Справочнике команд.
  3. На вкладке "Смещение метки" выберите из списка "Начало" способ задания точки вставки начала выноски.

    Значение параметра "Начало" игнорируется при создании свободных меток.

  4. В поля "Смещ. полки" введите значение X и Y, определяющие величину смещения полки и метки относительно начала выноски.

    По умолчанию смещение полки выноски по X и Y устанавливается равным 1, что задает смещение метки относительно начала выноски на одну единицу чертежа по каждой из координат.

  5. В поля "Смещение выноски" введите значения X и Y, которые для свободных меток задают величину смещения надписи от точки вставки, а для прикрепленных меток величину смещения начала выноски.


Создание и редактирование меток и шаблонов меток (Краткий справочник)

Экспорт связей
Создание и редактирование меток и шаблонов меток
Обновление меток в соответствии с новыми значениями полей базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Создание и редактирование меток и шаблонов меток >
Создание и редактирование меток и шаблонов меток
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Обновление меток в соответствии с новыми значениями полей базы данных (Понятие)

Создание и редактирование меток и шаблонов меток
Использование меток
Использование запросов для выбора информации из базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток >
Обновление меток в соответствии с новыми значениями полей базы данных
Понятие Процедура Краткий справочник

Для того чтобы отобразить в чертеже измененные значения полей базы данных, метки требуется обновить.

Использованные при создании меток записи базы данных впоследствии можно изменять. В случае частого изменения базы данных рекомендуется периодически выполнять обновление меток, для того чтобы содержимое ярлыков соответствовало текущим значениям полей базы данных.


Для обновления меток текущего чертежа (Процедура)

Создание и редактирование меток и шаблонов меток
На уровень вверх ..
Использование запросов для выбора информации из базы данных
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Обновление меток в соответствии с новыми значениями полей базы данных >
Обновление меток в соответствии с новыми значениями полей базы данных
Понятие Процедура Краткий справочник

Для обновления меток текущего чертежа

  • В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Выберите "Обновить метки".


Обновление меток в соответствии с новыми значениями полей базы данных (Краткий справочник)

Создание и редактирование меток и шаблонов меток
Обновление меток в соответствии с новыми значениями полей базы данных
Основные понятия
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование меток > Обновление меток в соответствии с новыми значениями полей базы данных >
Обновление меток в соответствии с новыми значениями полей базы данных
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование запросов для выбора информации из базы данных

Обновление меток в соответствии с новыми значениями полей базы данных
Внешние базы данных
Основные понятия
Совместное использование данных в чертежах и приложениях > Внешние базы данных >
Использование запросов для выбора информации из базы данных
Понятие Процедура

Запросы позволяют извлекать из базы данных требуемые записи.

Темы в этом разделе

  • Основные понятия
  • Формирование простых запросов

    Самые простые запросы позволяют отбирать записи по одному столбцу, одному значению и с использованием одного оператора. Запросы по интервалу позволяют отбирать записи, у которых значение определенного поля лежит в заданном интервале.

  • Использование вкладки "Формирователь"

    Для формирования запросов по двум и более критериям используются логические операторы и группировка условий.

  • Использование вкладки "SQL-запрос"

    Если используемая база данных совместима со стандартом SQL 92, для формирования запросов одновременно к нескольким таблицам базы данных можно использовать SQL-выражения.

  • Комбинирование запросов

    Специальное средство выбора по связи (модификация редактора запросов) позволяет создавать сложные наборы графических объектов и записей базы данных путем комбинирования имеющихся наборов.

  • Сохранение и повторное использование запросов

    Часто используемые запросы можно сохранять в чертеже. Сохраненные запросы можно редактировать, переименовывать и копировать в другие чертежи.


Использование запросов для выбора информации из базы данных (Процедура)

Обновление меток в соответствии с новыми значениями полей базы данных
Использование запросов для выбора информации из базы данных
Основные понятия
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных >
Использование запросов для выбора информации из базы данных
Понятие Процедура

Для вызова Редактора запросов

Для создания простого запроса

Для создания запроса по интервалу

Для создания запроса с одним условием отбора на вкладке "Формирователь"

Для создания запроса с несколькими условиями отбора на вкладке "Формирователь"

Для задания столбцов таблицы, которые следует выводить по запросу

Для задания порядка сортировки записей, выводимых по запросу

Для создания SQL-запроса

Для создания набора объектов на основе связей

Для выполнения сохраненного запроса

Для редактирования сохраненного запроса

Для переименования сохраненного запроса

Для удаления сохраненного запроса

Для копирования сохраненного запроса в другой чертеж

Для автоматического сохранения всех создаваемых запросов в текущем чертеже


Основные понятия (Понятие)

Использование запросов для выбора информации из базы данных
Использование запросов для выбора информации из базы данных
Формирование простых запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных >
Основные понятия
Понятие Процедура Краткий справочник

Основным преимуществом хранения информации в базах данных является возможность построения запросов для поиска записей, удовлетворяющих определенным условиям. Например, пусть имеется таблица базы данных, содержащая записи всех комнат в здании штаб-квартиры компании. Допустим, требуется составить список всех залов для совещаний, способных вместить более 20 человек. С помощью Редактора запросов AutoCAD можно без труда сформировать запрос для нахождения нужного набора записей или графических объектов (к объектам должны быть подключены внешние данные).

Окно Редактора запросов состоит из четырех вкладок, предназначенных для составления запросов. Каждая вкладка позволяет формировать запросы определенной степени сложности, причем в простейших случаях от пользователя даже не требуется знание языка SQL (Structured Query Language). Вкладки "Простой запрос" и "Запрос по интервалу" предназначены для тех пользователей, которые не знакомы с языком запросов. Вкладки "Формирователь" и "SQL-запрос" могут использоваться более подготовленными пользователями.

Формирование запроса можно начать на одной вкладке, а затем продолжить на другой. Например, на вкладке "Простой запрос" можно составить простейший запрос, а затем задать дополнительные условия поиска на вкладке "Формирователь". При этом после перехода на вкладку "Формирователь" в таблице данной вкладки выводятся условия запроса, заданные на вкладке "Простой запрос". Можно добавить в запрос и другие условия. Переключение на одну из последующих вкладок позволяет формировать более сложные условия поиска, которые нельзя задать на предыдущих вкладках. После модификации запроса при попытке перейти на одну из предыдущих вкладок выдается сообщение о том, что будут восстановлены параметры запроса по умолчанию.

Наличие в Редакторе запросов отдельных вкладок для формирования запросов различной степени сложности облегчает и ускоряет освоение языка SQL. Например, запрос можно сформировать на вкладке "Простой запрос", а затем переключиться на вкладку "SQL-запрос" и посмотреть, как данный запрос выглядит на языке SQL.

Для построения запросов можно использовать следующие вкладки Редактора запросов:

  • Простой запрос. Позволяет формировать простейшие запросы, осуществляющие отбор записей по одному столбцу, одному значению и с использованием одного оператора. Например, в текущей базе данных можно найти все записи, поле "тип комнаты" которых имеет значение "офис."
  • Запрос по интервалу. Позволяет формировать запросы для нахождения тех записей, у которых значение определенного поля лежит в заданном интервале. Например, в текущей базе данных можно найти все записи, поле "площадь комнаты" которых имеет значение большее или равное 9 кв. м., но меньшее или равное 12 кв. м.
  • Формирователь. Позволяет формировать более сложные запросы, осуществляющие отбор записей по нескольким критериям. Например, в текущей базе данных можно найти все записи, поле "тип комнаты" которых имеет значение "кабинет", а площадь комнаты превышает 8 кв. м.
  • SQL-запрос. Позволяет формировать сложные запросы на языке стандарта SQL 92. Например, можно выбрать * из таблицы казань.гармония.комната, где

    казань.гармония.комната.тип = "кабинет"

    и

    казань.гармония.комната.площадь < 8.

Подробнее о составлении простых запросов и использовании операторов см. раздел Формирование простых запросов. Подробнее о формировании более сложных запросов см. раздел Использование вкладки "Формирователь".


Для вызова Редактора запросов (Процедура)

Использование запросов для выбора информации из базы данных
На уровень вверх ..
Формирование простых запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Основные понятия >
Основные понятия
Понятие Процедура Краткий справочник

Для вызова Редактора запросов

  1. Выберите таблицу в окне Диспетчера подключения к БД.
  2. Нажмите кнопку "Новый запрос".
  3. В диалоговом окне "Новый запрос" в список "Имя нового запроса" введите имя запроса.
  4. Нажмите кнопку "Далее" для открытия окна Редактора запросов.


Основные понятия (Краткий справочник)

Обновление меток в соответствии с новыми значениями полей базы данных
Основные понятия
Формирование простых запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Основные понятия >
Основные понятия
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Формирование простых запросов (Понятие)

Основные понятия
Использование запросов для выбора информации из базы данных
Использование вкладки "Формирователь"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных >
Формирование простых запросов
Понятие Процедура Краткий справочник

Самые простые запросы позволяют отбирать записи по одному столбцу, одному значению и с использованием одного оператора. Запросы по интервалу позволяют отбирать записи, у которых значение определенного поля лежит в заданном интервале.

Использование вкладки "Простой запрос"

Вкладка "Простой запрос" предназначена для облегчения освоения языка запросов и может использоваться пользователями, не имеющими опыта работы с базами данных. Формирование простого запроса заключается в указании столбца текущей таблицы базы данных, выборе условного оператора и задании значения поля.

Условные операторы (например, равно, больше или меньше) определяют условия, по которым производится отбор записей. В следующей таблице приводятся сведения о назначении операторов, используемых при формировании запросов.

Операторы запросов

Операторы запросов
Оператор | Описание
Равно (=) | Возвращает все записи, значение которых в указанном столбце полностью совпадает с заданным значением.
Не равно (<>) | Возвращает все записи, значения которых в указанном столбце не равны заданному значению.
Больше (>) | Возвращает все записи, значения которых в указанном столбце больше заданного значения.
Меньше (<) | Возвращает все записи, значения которых в указанном столбце меньше заданного значения.
Больше чем или равно (>=) | Возвращает все записи, значения которых в указанном столбце больше или равны заданному значению.
Меньше или равно (<=) | Возвращает все записи, значения которых в указанном столбце меньше или равны заданному значению.
Like | Возвращает все записи, значения которых в указанном столбце содержат заданное значение. При использовании оператора like (подобие) допускается применение необязательного символа-шаблона %. Например, если необходимо найти все записи, заканчивающиеся на "вол", нужно задать значение %вол. Если необходимо найти все записи, начинающиеся с "вол", нужно задать значение вол% Если символ-шаблон % отсутствует, выполняется поиск записей, значение которых полностью совпадает с заданным значением.
In | Возвращает все записи, значения которых в указанном столбце совпадают с одним из заданных значений. Например, если необходимо найти запись сотрудника, но точно не известно, какое имя хранится в базе (Лена или Елена), тогда можно применить оператор In, задать оба варианта имени и произвести поиск всех записей, содержащих либо значение Лена, либо Елена. Варианты значений должны отделяться друг от друга запятой.
Is null | Возвращает все записи, которые имеют пустое значение в указанном столбце. Данный оператор удобно использовать для поиска записей в таблице базы данных, в которых отсутствуют данные.
Is not null | Возвращает все записи, которые имеют какое-либо не пустое значение в указанном столбце. Данный оператор удобно использовать для исключения записей, полям которых не присвоены значения.
ПримечаниеВсе операторы могут применяться к столбцам как числового, так и строкового типа. Например, в результате применения оператора "больше" и значения "в" к столбцу строкового типа будут возвращены все записи, начинающиеся с сочетаний "ва..." - "я...". Кроме того, необходимо помнить о том, что при выполнении запросов учитывается регистр символов, то есть "КОМНАТА" и "комната" считаются разными значениями.

Использование вкладки "Запрос по интервалу"

Вкладка "Запрос по интервалу", так же как и вкладка "Простой запрос", предназначена для тех пользователей, которые не знакомы с языком запросов. С помощью вкладки "Запрос по интервалу" можно отбирать записи, определенное поле которых имеет значения, лежащие в заданном интервале. Например, можно определить все комнаты, площадь которых больше или равна 8 кв. м., но меньше или равна 12 кв. м. По внешнему виду и назначению элементов управления данная вкладка подобна вкладке "Простой запрос", за тем исключением, что список "Оператор" отсутствует, а поле "Значение" заменено двумя другими полями: "От" и "До". Все остальные элементы вкладок "Простой запрос" и "Запрос по интервалу" одинаковы.


Формирование простых запросов (Процедура)

Основные понятия
На уровень вверх ..
Формирование простых запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Формирование простых запросов >
Формирование простых запросов
Понятие Процедура Краткий справочник

Для создания простого запроса

Для создания запроса по интервалу


Для создания простого запроса (Процедура)

Формирование простых запросов
На уровень вверх ..
Формирование простых запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Формирование простых запросов >
Формирование простых запросов
Понятие Процедура Краткий справочник

Для создания простого запроса

  1. Откройте Редактор запросов, как описано в разделе Для вызова Редактора запросов.
  2. На вкладке "Простой запрос" выберите требуемый столбец в списке "Столбец".
  3. Выберите оператор из списка "Оператор".
  4. Введите значение в текстовое поле "Значение" или нажмите кнопку "Просмотр значений".

    Нажатие кнопки "Просмотр значений" позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

  5. Установите или снимите флажки:
    • Пометить записи в окне просмотра. Задает выделение цветом в окне просмотра данных тех записей, которые удовлетворяют условиям запроса.
    • Пометить объекты в чертеже. Задает подсвечивание тех объектов чертежа, с которыми связаны записи, удовлетворяющие условиям запроса.
  6. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  7. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.

    В окно просмотра данных выводится набор записей, удовлетворяющих условиям запроса. Для повторного вызова Редактора запросов и уточнения запроса нажмите кнопку "Возврат к запросу".


Для создания запроса по интервалу (Процедура)

Формирование простых запросов
На уровень вверх ..
Использование вкладки "Формирователь"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Формирование простых запросов >
Формирование простых запросов
Понятие Процедура Краткий справочник

Для создания запроса по интервалу

  1. Откройте редактор запросов в соответствии с инструкциями в разделе To open the Query Editor.
  2. На вкладке "Запрос по интервалу" выберите требуемое поле в списке "Поле".
  3. Введите значение в текстовое поле "От" или нажмите кнопку "Просмотр значений" (От).

    Нажатие кнопки "Просмотр значений" позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

    При выполнении запроса отбираются только те записи, значения которых в указанном столбце больше или равны заданному значению.

  4. Введите значение в текстовое поле "До" или нажмите кнопку "Просмотр значений" (До).

    При выполнении запроса отбираются только те записи, значения которых в указанном столбце меньше или равны заданному значению.

  5. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  6. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Формирование простых запросов (Краткий справочник)

Основные понятия
Формирование простых запросов
Использование вкладки "Формирователь"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Формирование простых запросов >
Формирование простых запросов
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование вкладки "Формирователь" (Понятие)

Формирование простых запросов
Использование запросов для выбора информации из базы данных
Использование вкладки "SQL-запрос"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных >
Использование вкладки "Формирователь"
Понятие Процедура Краткий справочник

Для формирования запросов по двум и более критериям используются логические операторы и группировка условий.

Вкладка "Формирователь" является основным средством для формирования запросов. В отличие от вкладок "Простой запрос" и "Запрос по интервалу", данная вкладка позволяет составлять запросы, содержащие сразу несколько критериев отбора. При этом имеется возможность группировать отдельные выражения с помощью скобок, а также задавать, какие столбцы следует выводить в окно просмотра данных, и порядок сортировки отобранных записей.

При создании сложных запросов на вкладке "Формирователь" отдельные условия можно объединять с помощью скобок и логических операторов. Например, используя логические операторы, можно сформировать запрос, позволяющий найти все источники уличного освещения определенного типа, которые были установлены после определенной даты.

  • Оператор And (И). Задает отбор только тех записей, которые удовлетворяют всем заданным критериям. Пусть, например, необходимо найти все помещения, которые предназначены для использования под офис и в настоящее время никем не заняты. Для этого условия запроса следует объединить логическим оператором And.
  • Оператор Or (ИЛИ). Задает отбор только тех записей, которые удовлетворяют хотя бы одному из заданных критериев. Пусть, например, необходимо найти все помещения, которые предназначены для использования под офис или в настоящее время ни кем не заняты. Для этого условия запроса следует объединить логическим оператором Or.
  • Скобки. Используются для группировки отдельных условий запроса. Например, может потребоваться найти

    (Все помещения, которые являются офисами и в настоящее время свободны)

    или

    (Все помещения, которые являются кабинетами и в настоящее время свободны)

    В результате выполнения запроса с подобными условиями будут отобраны все свободные офисы и кабинеты.

    Уровень вложенности скобок в выражении не может превышать четырех.


Использование вкладки "Формирователь" (Процедура)

Формирование простых запросов
На уровень вверх ..
Использование вкладки "Формирователь"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "Формирователь" >
Использование вкладки "Формирователь"
Понятие Процедура Краткий справочник

Для создания запроса с одним условием отбора на вкладке "Формирователь"

Для создания запроса с несколькими условиями отбора на вкладке "Формирователь"

Для задания столбцов таблицы, которые следует выводить по запросу

Для задания порядка сортировки записей, выводимых по запросу


Для создания запроса с одним условием отбора на вкладке "Формирователь" (Процедура)

Использование вкладки "Формирователь"
На уровень вверх ..
Использование вкладки "Формирователь"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "Формирователь" >
Использование вкладки "Формирователь"
Понятие Процедура Краткий справочник

Для создания запроса с одним условием отбора на вкладке "Формирователь"

  1. Откройте Редактор запросов, как описано в разделе Для вызова Редактора запросов.
  2. На вкладке "Формирователь" выберите поле в раскрывающемся списке в ячейке "Поле".
  3. Выберите оператор из раскрывающегося списка ячейки "Оператор".
  4. Введите значение в ячейку "Значение" или нажмите кнопку [...].

    Нажатие кнопки [...] позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. После выбора значения нажмите "ОК".

  5. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  6. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Для создания запроса с несколькими условиями отбора на вкладке "Формирователь" (Процедура)

Использование вкладки "Формирователь"
На уровень вверх ..
Использование вкладки "Формирователь"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "Формирователь" >
Использование вкладки "Формирователь"
Понятие Процедура Краткий справочник

Для создания запроса с несколькими условиями отбора на вкладке "Формирователь"

  1. Задайте первое условие запроса, как описано в процедуре Для создания запроса с одним условием отбора на вкладке "Формирователь".
  2. Выберите логический оператор And (И) или Or (Или) в ячейке "Логический".

    Для вставки оператора And (И) следует нажать на ячейке "Логический". Для вставки оператора Or следует повторно нажать на этой же ячейке.

  3. Задайте дополнительные условия запроса в ячейках последующих строк.
  4. Повторите действия пункта 2 для всех дополнительных условий запроса, кроме самого последнего.
  5. Расставьте скобки, если необходимо. Нажмите ячейку, расположенную левее той ячейки "Поле", которая должна служить началом группы условий. При этом вставляется одна открывающая скобка. Нажмите ячейку, расположенную правее той ячейки "Значение", которая должна служить концом группы условий. При этом вставляется одна закрывающая скобка.
  6. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  7. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Для задания столбцов таблицы, которые следует выводить по запросу (Процедура)

Использование вкладки "Формирователь"
На уровень вверх ..
Использование вкладки "Формирователь"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "Формирователь" >
Использование вкладки "Формирователь"
Понятие Процедура Краткий справочник

Для задания столбцов таблицы, которые следует выводить по запросу

  1. Задайте условие запроса, как описано в процедурах Для создания запроса с одним условием отбора на вкладке "Формирователь" и Для создания запроса с несколькими условиями отбора на вкладке "Формирователь".
  2. Выделите в списке "Столбцы таблицы" тот столбец, поля которого должны выводиться после выполнения запроса.
  3. Нажмите кнопку "Добавить", расположенную над списком "Показать столбцы".
  4. Повторите пункты 2 и 3 для других столбцов, которые также должны отображаться в окне просмотра данных после выполнения запроса.


Для задания порядка сортировки записей, выводимых по запросу (Процедура)

Использование вкладки "Формирователь"
На уровень вверх ..
Использование вкладки "SQL-запрос"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "Формирователь" >
Использование вкладки "Формирователь"
Понятие Процедура Краткий справочник

Для задания порядка сортировки записей, выводимых по запросу

  1. Постройте запрос в соответствии с инструкциями в разделах Для создания запроса с одним условием отбора на вкладке "Формирователь"и Для создания запроса с несколькими условиями отбора на вкладке "Формирователь".
  2. Выделите в списке "Показать столбцы" тот столбец, по которому нужно отсортировать записи в первую очередь.
  3. Нажмите кнопку "Добавить", расположенную над списком "Сортировка".

    По умолчанию выполняется сортировка по возрастанию. Нажмите кнопку "Сортировка" для упорядочивания записей по убыванию.

  4. Повторите пункты 2 и 3 для других столбцов, по которым следует отсортировать записи, отобранные при выполнении запроса.


Использование вкладки "Формирователь" (Краткий справочник)

Формирование простых запросов
Использование вкладки "Формирователь"
Использование вкладки "SQL-запрос"
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "Формирователь" >
Использование вкладки "Формирователь"
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование вкладки "SQL-запрос" (Понятие)

Использование вкладки "Формирователь"
Использование запросов для выбора информации из базы данных
Комбинирование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных >
Использование вкладки "SQL-запрос"
Понятие Процедура Краткий справочник

Если используемая база данных совместима со стандартом SQL 92, для формирования запросов одновременно к нескольким таблицам базы данных можно использовать SQL-выражения.

Вкладка "SQL-запрос" содержит специальную область для ввода и редактирования произвольных запросов на языке SQL, а также вспомогательные средства, облегчающие формирование запросов. AutoCAD поддерживает выполнение SQL-запросов, соответствующих стандарту SQL 92 фирмы Microsoft. Поскольку не все системы управления базами данных полностью совместимы со стандартом SQL 92, необходимо обратиться к документации по СУБД и выяснить, какие команды SQL она поддерживает.

В отличие от остальных вкладок Редактора запросов, вкладка "SQL-запрос" позволяет с помощью SQL-оператора объединения формировать запросы, обеспечивающие поиск записей сразу в нескольких таблицах базы данных. Более подробную информацию об использовании оператора объединения можно найти в документации по применяемой СУБД или описании языка SQL 92.

На вкладке "SQL-запрос" имеется ряд дополнительных элементов управления:

  • Список таблиц. Список всех таблиц баз данных, имеющихся в текущем источнике данных. Для добавления имени таблицы в область редактирования SQL-запросов можно либо дважды нажать на ее имени, либо выделить таблицу в списке и нажать кнопку "Добавить", либо ввести ее имя непосредственно в редакторе.
  • Проверить. Позволяет проверить запрос на соответствие правилам языка SQL без выполнения запроса. Данная функция предназначена для выявления синтаксических ошибок.


Для создания SQL-запроса (Процедура)

Использование вкладки "Формирователь"
На уровень вверх ..
Комбинирование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "SQL-запрос" >
Использование вкладки "SQL-запрос"
Понятие Процедура Краткий справочник

Для создания SQL-запроса

  1. Откройте Редактор запросов, как описано в разделе Для вызова Редактора запросов.
  2. Перейдите на вкладку "SQL-запрос".
  3. Введите запрос в области редактирования запроса или задайте его условия с помощью элементов управления, как описано в разделе Использование вкладки "Формирователь".
  4. Чтобы сохранить запрос в текущем чертеже для последующего использования, нажмите кнопку "Сохранить".
  5. Нажмите кнопку "Выполнить" для выполнения запроса и закрытия диалогового окна.


Использование вкладки "SQL-запрос" (Краткий справочник)

Использование вкладки "Формирователь"
Использование вкладки "SQL-запрос"
Комбинирование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Использование вкладки "SQL-запрос" >
Использование вкладки "SQL-запрос"
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Комбинирование запросов (Понятие)

Использование вкладки "SQL-запрос"
Использование запросов для выбора информации из базы данных
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных >
Комбинирование запросов
Понятие Процедура Краткий справочник

Специальное средство выбора по связи (модификация редактора запросов) позволяет создавать сложные наборы графических объектов и записей базы данных путем комбинирования имеющихся наборов.

Специальное средство выбора по связи является модификацией редактора запросов и позволяет итеративно создавать наборы графических объектов и записей базы данных.

Средство выбора по связи используется для облегчения формирования набора объектов, удовлетворяющего определенным требованиям. Прежде всего, с помощью запроса или путем непосредственного выбора графических объектов создается исходный набор. Данный набор считается набором А. Далее можно задать второй набор, выбрав дополнительные графические объекты или выполнив другой запрос. Этот вторичный набор объектов считается набором В. Для получения результирующего набора требуется задать операцию, устанавливающую отношения между наборами А и В. Доступны следующие операции:

  • Выбор. Создает исходный запрос или набор объектов. Полученный таким образом набор можно уточнять с помощью повторного выполнения операций выбора по связи.
  • Объединение. Добавляет в исходный набор объектов результат выполнения дополнительного запроса или повторного выбора объектов. Данная операция возвращает все записи или объекты, находящиеся в наборах А или В.
  • Пересечение. Возвращает пересечение исходного набора с результатом выполнения дополнительного запроса или повторного выбора объектов. Данная операция возвращает только те записи или объекты, которые имеются одновременно в наборах А и В.
  • Вычитание A - B. Вычитает из текущего набора результат выполнения дополнительного запроса или повторного выбора объектов.
  • Вычитание B - A. Вычитает из результата выполнения дополнительного запроса или повторного выбора объектов текущий набор.

После выполнения любой из описанных выше операций результирующий набор становится новым текущим набором и считается набором А. Далее можно продолжить процедуру формирования набора объектов, создав очередной набор В.


Для создания набора объектов на основе связей (Процедура)

Использование вкладки "SQL-запрос"
На уровень вверх ..
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Комбинирование запросов >
Комбинирование запросов
Понятие Процедура Краткий справочник

Для создания набора объектов на основе связей

  1. Нажмите правую кнопку мыши на шаблоне связи в окне Диспетчера подключения к БД. Нажмите "Выбор по связи".
  2. Выберите способ получения результирующего набора из списка "Операция".
  3. Выберите шаблон связи из списка "Шаблон".
  4. Выбрать одно из следующих значений:
    • По запросу. Позволяет сформировать запрос с помощью одной из вкладок Редактора запросов.
    • Выбрать в чертеже. Позволяет временно выйти из диалогового окна для выбора объектов на чертеже. Если переключатель установлен в положение "Выбрать в чертеже", название кнопки "Выполнить" заменяется на "Выбрать".
  5. Нажмите кнопку "Выполнить" или "Выбрать" для создания исходного набора объектов.
  6. Выберите тип операции из списка "Операция": "Объединение", "Пересечение", "Вычитание A-B" или "Вычитание B-A".
  7. Повторите пункты 3-5 для создания дополнительного набора В.
  8. Установите или снимите следующие флажки, после чего нажмите кнопку "Закрыть":
    • Пометить записи в окне просмотра. После нажатия кнопки "Готово" результаты выполнения текущей операции выбора по связи выводятся в окно просмотра данных. Для уточнения набора можно нажать кнопку "Возврат к выбору по связи" в окне "Просмотр данных".
    • Пометить объекты в чертеже. После нажатия кнопки "Готово" на чертеже создается соответствующий набор объектов. Для последующих повторений операции выбора по связи можно нажимать клавишу ENTER в командной строке.
ПримечаниеПри выполнении операций выбора сразу по нескольким таблицам баз данных флажок "Пометить записи в окне просмотра" рекомендуется снимать. Связано это с тем, что средство выбора по связи может отображать записи только той таблицы, которая задана в текущем шаблоне связи. Поэтому в окно просмотра данных могут выводиться не все записи.


Комбинирование запросов (Краткий справочник)

Использование вкладки "SQL-запрос"
Комбинирование запросов
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Комбинирование запросов >
Комбинирование запросов
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Сохранение и повторное использование запросов (Понятие)

Комбинирование запросов
Использование запросов для выбора информации из базы данных
Совместное использование запросов, шаблонов связей и меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Часто используемые запросы можно сохранять в чертеже. Сохраненные запросы можно редактировать, переименовывать и копировать в другие чертежи.

Часто используемые запросы можно сохранять в чертеже. Все сохраненные запросы отображаются в Диспетчере подключения к БД в разделе того чертежа, в котором они созданы. Имеющиеся запросы можно редактировать, переименовывать, а также копировать в другие чертежи.


Сохранение и повторное использование запросов (Процедура)

Комбинирование запросов
На уровень вверх ..
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Для выполнения сохраненного запроса

Для редактирования сохраненного запроса

Для переименования сохраненного запроса

Для удаления сохраненного запроса

Для копирования сохраненного запроса в другой чертеж

Для автоматического сохранения всех создаваемых запросов в текущем чертеже


Для выполнения сохраненного запроса (Процедура)

Сохранение и повторное использование запросов
На уровень вверх ..
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Для выполнения сохраненного запроса

  • В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени сохраненного запроса. Нажмите "Выполнить".


Для редактирования сохраненного запроса (Процедура)

Сохранение и повторное использование запросов
На уровень вверх ..
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Для редактирования сохраненного запроса

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени сохраненного запроса. Нажмите "Изменить".
  2. Внесите необходимые изменения в диалоговом окне "Редактор запросов". Нажмите "Сохранить" для сохранения отредактированного запроса в текущем чертеже.


Для переименования сохраненного запроса (Процедура)

Сохранение и повторное использование запросов
На уровень вверх ..
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Для переименования сохраненного запроса

  1. В Диспетчере подключения к БД нажмите правую кнопку мыши на запросе, который следует переименовать. Нажмите "Переименовать".
  2. Введите новое имя запроса. Нажмите ENTER.


Для удаления сохраненного запроса (Процедура)

Сохранение и повторное использование запросов
На уровень вверх ..
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Для удаления сохраненного запроса

  • В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени сохраненного запроса. Нажмите "Удалить".


Для копирования сохраненного запроса в другой чертеж (Процедура)

Сохранение и повторное использование запросов
На уровень вверх ..
Сохранение и повторное использование запросов
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Для копирования сохраненного запроса в другой чертеж

  1. В Диспетчере подключения к БД выделите копируемый запрос.
  2. Перетащите запрос в раздел того чертежа, в который нужно скопировать запрос.


Для автоматического сохранения всех создаваемых запросов в текущем чертеже (Процедура)

Сохранение и повторное использование запросов
На уровень вверх ..
Совместное использование запросов, шаблонов связей и меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Для автоматического сохранения всех создаваемых запросов в текущем чертеже

  1. Из Диспетчера подключения к БД откройте таблицу, дважды нажав на ее имени.
  2. Нажмите кнопку "Запрос" на панели инструментов окна просмотра данных.
  3. В диалоговом окне "Новый запрос" нажмите кнопку "Далее".
  4. В Редакторе запросов нажмите кнопку "Настройка".
  5. В диалоговом окне "Параметры окна просмотра данных и запросов" в области "Параметры запросов" выберите "Автоматическое сохранение". Нажмите ОК.


Сохранение и повторное использование запросов (Краткий справочник)

Комбинирование запросов
Сохранение и повторное использование запросов
Совместное использование запросов, шаблонов связей и меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Использование запросов для выбора информации из базы данных > Сохранение и повторное использование запросов >
Сохранение и повторное использование запросов
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Совместное использование запросов, шаблонов связей и меток (Понятие)

Сохранение и повторное использование запросов
Внешние базы данных
Работа со связями в файлах предыдущих версий
Совместное использование данных в чертежах и приложениях > Внешние базы данных >
Совместное использование запросов, шаблонов связей и меток
Понятие Процедура Краткий справочник

Запросы, шаблоны связей и меток можно экспортировать и импортировать.

В некоторых случаях желательно иметь возможность обмениваться запросами, шаблонами связей и ярлыков между пользователями. Это позволяет различным членам команды, работающим над одним проектом, использовать одни и те же запросы и шаблоны и не тратить время на повторное воспроизведение уже разработанных запросов и шаблонов. Программа предоставляет возможность импортировать и экспортировать запросы и шаблоны. При экспорте в набор шаблонов (запросов) включаются все шаблоны (запросы), имеющиеся в текущем чертеже.


Совместное использование запросов, шаблонов связей и меток (Процедура)

Сохранение и повторное использование запросов
Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Совместное использование запросов, шаблонов связей и меток >
Совместное использование запросов, шаблонов связей и меток
Понятие Процедура Краткий справочник

Для импорта набора шаблонов в текущий чертеж

Для экспорта набора шаблонов из текущего чертежа

Для импорта набора запросов в текущий чертеж

Для экспорта набора запросов из текущего чертежа


Для импорта набора шаблонов в текущий чертеж (Процедура)

Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Совместное использование запросов, шаблонов связей и меток >
Совместное использование запросов, шаблонов связей и меток
Понятие Процедура Краткий справочник

Для импорта набора шаблонов в текущий чертеж

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Выберите "Импорт набора шаблонов".
  2. В диалоговом окне "Импорт набора шаблонов" выберите файл набора шаблонов.
  3. Нажмите кнопку "Открыть" для импорта набора шаблонов в текущий чертеж.

    Если имя импортируемого шаблона совпадает с именем одного из уже имеющихся в текущем чертеже шаблонов, отображается окно предупреждения, в котором можно указать уникальное имя для шаблона.


Для экспорта набора шаблонов из текущего чертежа (Процедура)

Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Совместное использование запросов, шаблонов связей и меток >
Совместное использование запросов, шаблонов связей и меток
Понятие Процедура Краткий справочник

Для экспорта набора шаблонов из текущего чертежа

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Нажмите "Экспорт набора шаблонов".
  2. В диалоговом окне "Экспорт набора шаблонов" выберите папку, в которую следует сохранить файл набора шаблонов.
  3. В поле "Имя файла" задайте имя файла набора шаблонов. Нажмите кнопку "Сохранить".


Для импорта набора запросов в текущий чертеж (Процедура)

Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Совместное использование запросов, шаблонов связей и меток >
Совместное использование запросов, шаблонов связей и меток
Понятие Процедура Краткий справочник

Для импорта набора запросов в текущий чертеж

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Нажмите "Импорт набора запросов".
  2. В диалоговом окне "Импорт набора запросов" выберите файл набора запросов.
  3. Нажмите кнопку "Открыть" для импорта набора запросов в текущий чертеж.

    Если имя импортируемого запроса совпадает с именем одного из уже имеющихся в текущем чертеже запросов, открывается окно, в котором можно задать уникальное имя для запроса.


Для экспорта набора запросов из текущего чертежа (Процедура)

Совместное использование запросов, шаблонов связей и меток
Совместное использование запросов, шаблонов связей и меток
Работа со связями в файлах предыдущих версий
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Совместное использование запросов, шаблонов связей и меток >
Совместное использование запросов, шаблонов связей и меток
Понятие Процедура Краткий справочник

Для экспорта набора запросов из текущего чертежа

  1. В окне Диспетчера подключения к БД нажмите правую кнопку мыши на имени файла чертежа. Выберите "Экспорт набора запросов".
  2. В диалоговом окне "Экспорт набора запросов" выберите папку, в которую следует сохранить файл набора запросов.
  3. В поле "Имя файла" задайте имя файла набора запросов. Нажмите кнопку "Сохранить".


Совместное использование запросов, шаблонов связей и меток (Краткий справочник)

Сохранение и повторное использование запросов
Совместное использование запросов, шаблонов связей и меток
Работа со связями в файлах предыдущих версий
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Совместное использование запросов, шаблонов связей и меток >
Совместное использование запросов, шаблонов связей и меток
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Работа со связями в файлах предыдущих версий (Понятие)

Совместное использование запросов, шаблонов связей и меток
Внешние базы данных
Совместная работа над проектами
Совместное использование данных в чертежах и приложениях > Внешние базы данных >
Работа со связями в файлах предыдущих версий
Понятие Процедура Краткий справочник

Связи ASE чертежей форматов R12, R13 и R14 можно преобразовывать в связи формата AutoCAD 2000 и более поздних версий. Связи формата AutoCAD 2000 можно сохранять в форматах R13 и R14.

В AutoCAD 2000 и более поздних версиях связи хранятся в формате, отличном от формата предыдущих версий. Поэтому для работы со связями прежних версий такие связи следует преобразовать. В терминологию (по сравнению с Release 14) внесены следующие изменения: понятие ключевой столбец заменено на ключевое значение, имя маршрута связи на шаблон связи, а отображаемый атрибут на метка. При этом может потребоваться создание файла настройки, содержащего перечень использовавшихся ранее источников данных.

При открытии чертежа, содержащего связи в формате предыдущих версий, программа пытается автоматически преобразовать все имеющиеся связи. Например, при открытии чертежа версии 14, который содержит связи с источником данных, имеющим структуру db3.ase.db3sample.computer(com), в программе выполняется попытка установления точного взаимно-однозначного соответствия для компонентов источника данных.

В некоторых случаях использовавшиеся в прежней версии настройки источника данных могут несколько отличаться от настроек того же источника данных в этой версии программы. Например, в прежней версии мог использоваться каталог, не описанный в настройках источника данных новой версии. Для тех связей, которые не удается автоматически преобразовать при открытии чертежа, можно воспользоваться диалоговым окном "Преобразование связей" для задания соответствия между источниками данных в прежних версиях и в новой версии. Кроме того, с помощью диалогового окна "Свойства шаблона связи" можно изменить параметры источника данных для выбранного шаблона связи.

Во время преобразования связей создается файл asi.ini, содержащий сведения о сопоставлении источников данных. Если необходимо, хранящуюся в данном файле информацию о параметрах преобразования связей можно отредактировать вручную.

ПримечаниеПрограмма пытается произвести автоматическое преобразование только тех связей, источники данных которых не описаны в файле asi.ini. Если же какой-либо источник данных уже описан в таблице преобразования связей, то при открытии любого чертежа прежней версии, содержащего связи с этим источником, используются параметры, заданные в файле asi.ini.

Сохранение связей в форматах предыдущих версий

Связи, созданные в AutoCAD 2000 и более поздних версиях, можно преобразовать в связи формата R13 или R14. Преобразовать связи AutoCAD 2000 и более поздних версий в формат R12 невозможно. При сохранении чертежа в формат R13 или R14 с помощью команды СОХРАНИТЬКАК, связи автоматически преобразуются в соответствующий формат. При этом необходимо задать параметры преобразования связей (соответствие источников данных), как описано выше.


Работа со связями в файлах предыдущих версий (Процедура)

Совместное использование запросов, шаблонов связей и меток
Работа со связями в файлах предыдущих версий
Работа со связями в файлах предыдущих версий
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Работа со связями в файлах предыдущих версий >
Работа со связями в файлах предыдущих версий
Понятие Процедура Краткий справочник

Для преобразования связей из форматов AutoCAD версии 13 и 14\\

Для преобразования связей из формата Release 12


Для преобразования связей из форматов AutoCAD версии 13 и 14\\ (Процедура)

Работа со связями в файлах предыдущих версий
Работа со связями в файлах предыдущих версий
Работа со связями в файлах предыдущих версий
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Работа со связями в файлах предыдущих версий >
Работа со связями в файлах предыдущих версий
Понятие Процедура Краткий справочник

Для преобразования связей из форматов AutoCAD версии 13 и 14\\

  1. Выберите меню Базы данных [image] Преобразование связей.
  2. В группе "Прежний формат связи" выполните все перечисленные ниже операции:
    • Установите переключатель "Формат связи" в положение "R13/R14".
    • В поле "Среда" введите имя среды, использовавшейся в R13 или R14, связи с которой нужно преобразовать.
    • В поле "Каталог" введите имя каталога, использовавшегося в R13 или R14, связи с которым нужно преобразовать.
    • В поле "Схема" введите имя схемы, использовавшейся в R13 или R14, связи с которой нужно преобразовать.
    • В поле "Таблица" введите имя таблицы, использовавшейся в R13 или R14, связи с которой нужно преобразовать.
    • В поле "Имя маршрута связи" введите имя маршрута связи, использовавшегося в R13 или R14, связи с которым нужно преобразовать.
  3. В группе "Новый формат связи" выполните все перечисленные ниже операции:
    • Выберите из списка "Источник данных" подходящий источник данных.
    • Выберите из списка "Каталог" подходящий каталог.
    • Выберите из списка "Схема" подходящую схему.
    • Выберите из списка "Таблица" подходящую таблицу.
    • Выберите из списка "Шаблон связи" подходящий шаблон связи.
  4. Нажмите "ОК".
  5. Откройте чертеж, связи которого необходимо преобразовать, и сохраните его.
    ПримечаниеСреду, таблицу и имя маршрута связи требуется задавать при преобразовании связей с любыми базами данных. Каталог и схему нужно задавать только для тех баз данных, которые поддерживают их использование.


Для преобразования связей из формата Release 12 (Процедура)

Работа со связями в файлах предыдущих версий
Работа со связями в файлах предыдущих версий
Защита чертежей шифрованием
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Работа со связями в файлах предыдущих версий >
Работа со связями в файлах предыдущих версий
Понятие Процедура Краткий справочник

Для преобразования связей из формата Release 12

  1. Выберите меню Базы данных [image] Преобразование связей.
  2. В группе "Прежний формат связи" выполните все перечисленные ниже операции:
    • Установите переключатель "Формат связи" в положение "R12".
    • В поле "СУБД" введите имя системы управления базами данных, использовавшейся в R12, связи с которой нужно преобразовать.
    • В поле "База данных" введите имя базы данных, использовавшейся в R12, связи с которой нужно преобразовать.
    • В поле "Таблица" введите имя таблицы базы данных, использовавшейся в R12, связи с которой нужно преобразовать.
  3. В группе "Новый формат связи" выполните все перечисленные ниже операции:
    • Выберите из списка "Источник данных" подходящий источник данных.
    • Выберите из списка "Каталог" подходящий каталог.
    • Выберите из списка "Схема" подходящую схему.
    • Выберите из списка "Таблица" подходящую таблицу.
    • Выберите из списка "Шаблон связи" подходящий шаблон связи.
  4. Нажмите "ОК".
  5. Откройте чертеж, связи которого необходимо преобразовать, и сохраните его.

    После задания таблицы преобразования связей при открытии и сохранении чертежа в формате AutoCAD 2000 или более поздних версий все содержащиеся в этом чертеже связи, указанные в данной таблице, преобразуются в связи нового формата.


Работа со связями в файлах предыдущих версий (Краткий справочник)

Совместное использование запросов, шаблонов связей и меток
Работа со связями в файлах предыдущих версий
Коротко о шифровании
Совместное использование данных в чертежах и приложениях > Внешние базы данных > Работа со связями в файлах предыдущих версий >
Работа со связями в файлах предыдущих версий
Понятие Процедура Краткий справочник

Команды

БДСВЯЗЬ

Интерфейс между программой и таблицами внешних баз данных

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Совместная работа над проектами

Работа со связями в файлах предыдущих версий
Защита чертежей и добавление цифровой подписи
Совместная работа над проектами

Темы в этом разделе

  • Защита чертежей и добавление цифровой подписи

    Пароли и цифровые подписи можно использовать при совместной работе над проектом. Для открытия защищенного чертежа необходимо ввести пароль. При наличии подписи чертежа она однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата).

  • Совместная работа с чертежами в Интернете

    Пользователь может хранить чертежи AutoCAD и связанные с ними файлы в глобальной сети Интернет. Необходимо, чтобы на пользовательском компьютере был установлен Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздняя версия) и существовал доступ в Интернет или корпоративную сеть.

  • Использование пометок для рецензирования проектов

    На последних этапах работы над проектом чертежи обычно публикуются для итогового просмотра и последних исправлений. Замечания и комментарии могут быть размещены в электронной версии чертежа. На основании полученных комментариев проект дорабатывают, а публикацию исправленных чертежей повторяют. Такая работа с электронными пометками упрощает этап согласования, сокращает цикл разработки и в результате повышает эффективность процесса проектирования.


Защита чертежей и добавление цифровой подписи

Совместная работа над проектами
Совместная работа над проектами
Шифрование чертежей
Совместная работа над проектами >
Защита чертежей и добавление цифровой подписи

Пароли и цифровые подписи можно использовать при совместной работе над проектом. Для открытия защищенного чертежа необходимо ввести пароль. При наличии подписи чертежа она однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата).

Особое внимание в продукте уделяется безопасной отправке и получению данных, а также защите от несанкционированного изменения чертежей. Используя пароль, можно зашифровать содержимое чертежа. Цифровая подпись однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата).

Темы в этом разделе

  • Шифрование чертежей

    Если чертеж снабжен паролем, последний шифрует чертеж и защищает его от просмотра посторонними лицами.

  • Добавление цифровой подписи к чертежам

    Цифровые подписи обеспечивают подлинность сообщений и безопасность их передачи. Пользователь может принимать участие в работе над коллективными проектами, обмениваясь файлами через Интернет, и быть уверенным в том, что содержимое отправленного файла абсолютно идентично содержимому файла, полученного адресатом.


Шифрование чертежей

Защита чертежей и добавление цифровой подписи
Защита чертежей и добавление цифровой подписи
Коротко о шифровании
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи >
Шифрование чертежей

Если чертеж снабжен паролем, последний шифрует чертеж и защищает его от просмотра посторонними лицами.

Темы в этом разделе

  • Коротко о шифровании

    Шифрование на основе пароля позволяет предотвратить доступ посторонних лиц к данным чертежа при работе над совместными проектами. Шифрование особенно актуально при пересылке данных по линиям связи.

  • Защита чертежей шифрованием

    Если чертеж снабжают паролем и сохраняют, он шифруется и не может быть открыт без ввода пароля.

  • Открытие файлов чертежей, защищенных паролями

    Для просмотра информации чертежа, защищенного паролем, необходимо вначале получить и ввести пароль. При редактировании и сохранении чертежа пароль остается неизменным до его удаления или изменения.


Коротко о шифровании (Понятие)

Шифрование чертежей
Шифрование чертежей
Защита чертежей шифрованием
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей >
Коротко о шифровании
Понятие Краткий справочник

Шифрование на основе пароля позволяет предотвратить доступ посторонних лиц к данным чертежа при работе над совместными проектами. Шифрование особенно актуально при пересылке данных по линиям связи.

Если чертеж снабжен паролем, последний шифрует чертеж и защищает его от просмотра посторонними лицами. Пользователь может выбирать способы шифрования. При совместной работе над проектом шифрование предотвращает доступ посторонних лиц к данным.

Пароли шифрования чертежей отличаются от других видов паролей, например, от паролей функции формирования комплектов (eTransmit) тем, что здесь пользователь может выбирать способы шифрования.

Основная функция пароля – предотвращение хищения данных чертежа. Шифрование также позволяет обеспечить сохранность сведений, носящих конфиденциальный характер.

Например, проектная фирма, выполняющая дорогостоящий заказ для машиностроительного предприятия, может защитить паролем (или фразой) электронные чертежи, отсылаемые заказчику для просмотра. Парольная защита электронных документов может являться одной из многих мер защиты информации и правилом внутренней безопасности разработок.

Пароли работают только в файлах чертежей AutoCAD 2004® и более поздних версий (файлы DWG, DWS и DWT).

ПримечаниеЕсли файл чертежа требуется и зашифровать, и добавить к нему цифровую подпись, то сначала нужно выполнить шифрование. Изменение файла, в том числе добавление пароля, делает цифровую подпись недействительной.


Коротко о шифровании (Краткий справочник)

Работа со связями в файлах предыдущих версий
Коротко о шифровании
Защита чертежа паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Коротко о шифровании >
Коротко о шифровании
Понятие Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Защита чертежей шифрованием

Коротко о шифровании
Шифрование чертежей
Защита чертежа паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей >
Защита чертежей шифрованием
Понятие Процедура

Если чертеж снабжают паролем и сохраняют, он шифруется и не может быть открыт без ввода пароля.

Пароль может быть задан при редактировании чертежа или при его сохранении. Пароль задается для каждого файла, который требуется зашифровать, по отдельности.

ПредупреждениеВосстановление чертежа при утере пароля невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.

Темы в этом разделе

  • Защита чертежа паролем

    Паролем может служить слово или фраза. В качестве пароля рекомендуется использовать несвязанный набор символов. Чем больше длина пароля, тем труднее его извлечь с помощью программ-«взломщиков».

  • Выбор способа шифрования

    Можно выбирать способы шифрования для своих чертежей.


Защита чертежей шифрованием (Процедура)

Работа со связями в файлах предыдущих версий
Защита чертежей шифрованием
Защита чертежа паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием >
Защита чертежей шифрованием
Понятие Процедура

Для задания пароля в процессе работы над чертежом

Для задания пароля при сохранении чертежа

Для удаления пароля

Для выбора поставщика услуг шифрования чертежа и задания длины ключа


Защита чертежа паролем (Понятие)

Защита чертежей шифрованием
Защита чертежей шифрованием
Выбор способа шифрования
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием >
Защита чертежа паролем
Понятие Процедура Краткий справочник

Паролем может служить слово или фраза. В качестве пароля рекомендуется использовать несвязанный набор символов. Чем больше длина пароля, тем труднее его извлечь с помощью программ-«взломщиков».

Пользователь может выбирать способ шифрования и длину ключа. Свойства чертежа также могут быть зашифрованы.

После ввода пароля и сохранения чертежа требуется ввод пароля, прежде чем какая-либо программа или ее часть сможет считать данные из чертежа, даже если чертеж является внешней ссылкой. Как правило, в сеансе работы с чертежом пароль требуется вводить только один раз.

Если свойства чертежа (поля "Автор", "Название", "Тема" и "Ключевые слова") зашифрованы, то для их просмотра также потребуется ввести пароль. Пароль запрашивается еще и при открытии зашифрованного чертежа с опцией просмотра образца. Число систем шифрования и длина ключа зависят от операционной системы, установленной на компьютере пользователя.

ПримечаниеНастройки при задании пароля распространяются только на текущий чертеж.


Защита чертежа паролем (Процедура)

Защита чертежей шифрованием
На уровень вверх ..
Защита чертежа паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием > Защита чертежа паролем >
Защита чертежа паролем
Понятие Процедура Краткий справочник

Для задания пароля в процессе работы над чертежом

Для задания пароля при сохранении чертежа

Для удаления пароля


Для задания пароля в процессе работы над чертежом (Процедура)

Защита чертежа паролем
На уровень вверх ..
Защита чертежа паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием > Защита чертежа паролем >
Защита чертежа паролем
Понятие Процедура Краткий справочник

Для задания пароля в процессе работы над чертежом

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" введите пароль.
  4. Для защиты паролем таких свойств чертежа, как название, имя автора, тема и ключевые слова, нажмите "Шифровать свойства чертежа".
  5. Нажмите "ОК".
  6. В диалоговом окне "Подтверждение пароля" введите пароль еще раз. Нажмите "ОК".
    ПредупреждениеВ случае утери пароля его восстановление невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.
Ввод команды: БЕЗОПНАСТР


Для задания пароля при сохранении чертежа (Процедура)

Защита чертежа паролем
На уровень вверх ..
Защита чертежа паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием > Защита чертежа паролем >
Защита чертежа паролем
Понятие Процедура Краткий справочник

Для задания пароля при сохранении чертежа

  1. Выберите меню Файл [image] Сохранить как.В командной строке введите "сохранитькак".
  2. Перед сохранением файла в диалоговом окне "Сохранение чертежа" выберите меню "Сервис" [image] "Параметры безопасности".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" введите пароль.
  4. Для защиты паролем таких свойств чертежа, как название, имя автора, тема и ключевые слова, нажмите "Шифровать свойства чертежа".
  5. Нажмите "ОК".
  6. В диалоговом окне "Подтверждение пароля" введите пароль еще раз. Нажмите "ОК".
    ПредупреждениеВ случае утери пароля его восстановление невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.
Ввод команды: БЕЗОПНАСТР


Для удаления пароля (Процедура)

Защита чертежа паролем
На уровень вверх ..
Выбор способа шифрования
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием > Защита чертежа паролем >
Защита чертежа паролем
Понятие Процедура Краткий справочник

Для удаления пароля

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" снимите флажок "Для открытия этого чертежа необходимо ввести пароль (слово или фразу)".
  4. Нажмите "ОК".
Ввод команды: БЕЗОПНАСТР


Защита чертежа паролем (Краткий справочник)

Коротко о шифровании
Защита чертежа паролем
Выбор способа шифрования
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием > Защита чертежа паролем >
Защита чертежа паролем
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Выбор способа шифрования (Понятие)

Защита чертежа паролем
Защита чертежей шифрованием
Открытие файлов чертежей, защищенных паролями
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием >
Выбор способа шифрования
Понятие Процедура Краткий справочник

Можно выбирать способы шифрования для своих чертежей.

По умолчанию используется стандартный способ шифрования, обеспечиваемый операционной системой пользователя. Усовершенствованные алгоритмы шифрования RC4 можно выбрать из списка поставщиков услуг шифрования операционной системы. Можно также задать длину ключа (чем больше длина, тем выше степень защиты). Поставщики услуг шифрования используют стандартный алгоритм шифрования RC4 и различаются только предлагаемыми способами защиты.

Перед тем как использовать усовершенствованную систему шифрования (поставщик, способ и длина ключа), необходимо удостовериться в том, что на компьютере заказчика установлена такая же система. Подробную информацию о поставщиках услуг шифрования, системах и алгоритмах шифрования можно найти в Интернете.


Для выбора поставщика услуг шифрования чертежа и задания длины ключа (Процедура)

Защита чертежа паролем
На уровень вверх ..
Открытие файлов чертежей, защищенных паролями
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием > Выбор способа шифрования >
Выбор способа шифрования
Понятие Процедура Краткий справочник

Для выбора поставщика услуг шифрования чертежа и задания длины ключа

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
  3. В диалоговом окне "Параметры безопасности" на вкладке "Пароль" введите пароль или фразу, чтобы открыть чертеж. Нажмите "Дополнительные параметры".
  4. В диалоговом окне "Дополнительные параметры" выберите поставщика услуг шифрования, длину ключа или оба параметра. Нажмите "ОК".
  5. Нажмите "ОК" в диалоговом окне "Параметры безопасности".
Ввод команды: БЕЗОПНАСТР


Выбор способа шифрования (Краткий справочник)

Защита чертежа паролем
Выбор способа шифрования
Ввод пароля при открытии чертежа
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Защита чертежей шифрованием > Выбор способа шифрования >
Выбор способа шифрования
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Открытие файлов чертежей, защищенных паролями

Выбор способа шифрования
Шифрование чертежей
Ввод пароля при открытии чертежа
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей >
Открытие файлов чертежей, защищенных паролями
Понятие Процедура

Для просмотра информации чертежа, защищенного паролем, необходимо вначале получить и ввести пароль. При редактировании и сохранении чертежа пароль остается неизменным до его удаления или изменения.

Защищенный паролем чертеж может содержать внешние ссылки на чертежи, которые также могут быть защищены паролями. При открытии чертежа, содержащего внешние ссылки, сначала запрашивается пароль для текущего чертежа. Затем запрашивается ввод паролей для всех внешних ссылок, пароли которых отличаются от пароля, введенного в ходе данного сеанса работы. Определенный пароль, относящийся к чертежу или внешней ссылке, требуется вводить один раз за сеанс.

Если данные в чертеже, защищенном паролем, считываются программой по какой-либо причине, необходимо ввести пароль как минимум один раз за сеанс использования программы.

Пароли файлов чертежей и внешних ссылок действуют до тех пор, пока не будут удалены. Удаление паролей может потребоваться, например, при пакетной обработке файлов (но не при добавлении цифровых подписей).

Темы в этом разделе

  • Ввод пароля при открытии чертежа

    Процедура открытия защищенного паролем файла ничем не отличается от стандартной, кроме дополнительного диалогового окна для ввода пароля. Для паролей использование регистров учитывается.

  • Открытие внешних ссылок, защищенных паролями

    Пользователь может открывать чертежи, которые содержат в себе внешние ссылки на чертежи, защищенные паролями.

  • Просмотр свойств чертежа, защищенного паролем

    Если при шифровании файла чертежа не была выбрана опция шифрования его свойств (поля "Автор", "Название", "Тема" и "Ключевые слова"), то они доступны для просмотра.


Открытие файлов чертежей, защищенных паролями (Процедура)

Выбор способа шифрования
Открытие файлов чертежей, защищенных паролями
Ввод пароля при открытии чертежа
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями >
Открытие файлов чертежей, защищенных паролями
Понятие Процедура

Для открытия файла чертежа, защищенного паролем

Для открытия чертежа, содержащего внешние ссылки с паролями

Для просмотра свойств чертежа, защищенного паролем


Ввод пароля при открытии чертежа (Понятие)

Открытие файлов чертежей, защищенных паролями
Открытие файлов чертежей, защищенных паролями
Открытие внешних ссылок, защищенных паролями
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями >
Ввод пароля при открытии чертежа
Понятие Процедура Краткий справочник

Процедура открытия защищенного паролем файла ничем не отличается от стандартной, кроме дополнительного диалогового окна для ввода пароля. Для паролей использование регистров учитывается.

Если при добавлении пароля к файлу чертежа не была выбрана опция шифрования его свойств (поля "Название", "Автор", "Тема" и "Ключевые слова"), то они доступны для просмотра в диалоговом окне "Свойства" Проводника Microsoft® Windows.


Для открытия файла чертежа, защищенного паролем (Процедура)

Открытие файлов чертежей, защищенных паролями
На уровень вверх ..
Открытие внешних ссылок, защищенных паролями
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями > Ввод пароля при открытии чертежа >
Ввод пароля при открытии чертежа
Понятие Процедура Краткий справочник

Для открытия файла чертежа, защищенного паролем

  1. Выберите меню Файл [image] Открыть.В командной строке введите "открыть".
  2. В диалоговом окне "Выбор файла" выберите файл. Нажмите "Открыть".
  3. В диалоговом окне "Пароль" введите пароль.
  4. Нажмите "ОК".
Ввод команды: БЕЗОПНАСТР


Ввод пароля при открытии чертежа (Краткий справочник)

Выбор способа шифрования
Ввод пароля при открытии чертежа
Открытие внешних ссылок, защищенных паролями
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями > Ввод пароля при открытии чертежа >
Ввод пароля при открытии чертежа
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Открытие внешних ссылок, защищенных паролями (Понятие)

Ввод пароля при открытии чертежа
Открытие файлов чертежей, защищенных паролями
Просмотр свойств чертежа, защищенного паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями >
Открытие внешних ссылок, защищенных паролями
Понятие Процедура Краткий справочник

Пользователь может открывать чертежи, которые содержат в себе внешние ссылки на чертежи, защищенные паролями.

В этом случае сначала запрашивается пароль на открытие чертежа, затем последовательно на все внешние ссылки, пароли которых отличаются от введенного в первую очередь.

Запрашиваются только те пароли, которые не были введены ни разу. Например, если во внешней ссылке и чертеже, доступ к которому осуществлялся в текущем сеансе программы (открытие чертежа или внешней ссылки), используется один и тот же пароль, повторный ввод этого пароля не требуется.


Для открытия чертежа, содержащего внешние ссылки с паролями (Процедура)

Ввод пароля при открытии чертежа
На уровень вверх ..
Просмотр свойств чертежа, защищенного паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями > Открытие внешних ссылок, защищенных паролями >
Открытие внешних ссылок, защищенных паролями
Понятие Процедура Краткий справочник

Для открытия чертежа, содержащего внешние ссылки с паролями

  1. Выберите меню Файл [image] Открыть.В командной строке введите "открыть".
  2. В диалоговом окне "Выбор файла" выберите файл. Нажмите "Открыть".
  3. Если в диалоговом окне "Пароль" отображается запрос на ввод паролей, введите все необходимые пароли. Нажмите "ОК".
Ввод команды: БЕЗОПНАСТР


Открытие внешних ссылок, защищенных паролями (Краткий справочник)

Ввод пароля при открытии чертежа
Открытие внешних ссылок, защищенных паролями
Просмотр свойств чертежа, защищенного паролем
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями > Открытие внешних ссылок, защищенных паролями >
Открытие внешних ссылок, защищенных паролями
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Просмотр свойств чертежа, защищенного паролем (Понятие)

Открытие внешних ссылок, защищенных паролями
Открытие файлов чертежей, защищенных паролями
Добавление цифровой подписи к чертежам
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями >
Просмотр свойств чертежа, защищенного паролем
Понятие Процедура Краткий справочник

Если при шифровании файла чертежа не была выбрана опция шифрования его свойств (поля "Автор", "Название", "Тема" и "Ключевые слова"), то они доступны для просмотра.

Если при шифровании файла чертежа не была выбрана опция шифрования его свойств, то их можно просмотреть с помощью диалогового окна "Свойства" операционной системы.


Для просмотра свойств чертежа, защищенного паролем (Процедура)

Открытие внешних ссылок, защищенных паролями
На уровень вверх ..
Чертежи с цифровой подписью
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями > Просмотр свойств чертежа, защищенного паролем >
Просмотр свойств чертежа, защищенного паролем
Понятие Процедура Краткий справочник

Для просмотра свойств чертежа, защищенного паролем

  1. В Проводнике найдите файл, свойства которого требуется просмотреть.
  2. Нажмите правую кнопку мыши на имени файла. Нажать кнопку "Свойства".
Ввод команды: БЕЗОПНАСТР


Просмотр свойств чертежа, защищенного паролем (Краткий справочник)

Открытие внешних ссылок, защищенных паролями
Просмотр свойств чертежа, защищенного паролем
Коротко о цифровых подписях
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Шифрование чертежей > Открытие файлов чертежей, защищенных паролями > Просмотр свойств чертежа, защищенного паролем >
Просмотр свойств чертежа, защищенного паролем
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление цифровой подписи к чертежам

Просмотр свойств чертежа, защищенного паролем
Защита чертежей и добавление цифровой подписи
Коротко о цифровых подписях
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи >
Добавление цифровой подписи к чертежам

Цифровые подписи обеспечивают подлинность сообщений и безопасность их передачи. Пользователь может принимать участие в работе над коллективными проектами, обмениваясь файлами через Интернет, и быть уверенным в том, что содержимое отправленного файла абсолютно идентично содержимому файла, полученного адресатом.

Темы в этом разделе

  • Коротко о цифровых подписях

    Цифровые подписи делают работу над коллективными проектами более безопасной. Вместе с чертежами адресат получает достоверную информацию об их авторе, а также о внесении изменений в чертежи после добавления цифровой подписи.

  • Чертежи с цифровой подписью

    Получатели файлов с цифровой подписью могут быть уверены в неизменности файлов с момента их подписания. Любые вносимые изменения делают цифровую подпись недействительной.

  • Открытие файлов чертежей с цифровой подписью

    Вместе с файлами чертежей, имеющих цифровую подпись, отправляются электронные средства оценки (проверки подлинности) подписей.


Коротко о цифровых подписях (Понятие)

Добавление цифровой подписи к чертежам
Добавление цифровой подписи к чертежам
Чертежи с цифровой подписью
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам >
Коротко о цифровых подписях
Понятие Краткий справочник

Цифровые подписи делают работу над коллективными проектами более безопасной. Вместе с чертежами адресат получает достоверную информацию об их авторе, а также о внесении изменений в чертежи после добавления цифровой подписи.

Цифровые подписи обладают следующими преимуществами:

  • Получатель файлов с цифровой подписью может быть уверен в том, что они пришли именно от заявленного отправителя (организации или лиц).
  • Цифровая подпись гарантирует неизменность файлов с момента их подписания.
  • Файл с цифровой подписью не может быть признан недействительным. Отправитель файла с цифровой подписью не может позднее отказаться от него под предлогом того, что подпись была подделана.

Цифровая подпись - это не оцифрованное изображение подписи. Цифровая подпись гарантирует подлинность и достоверность передаваемых данных, в то время как цифровое изображение подписи - это всего лишь отсканированная личная подпись. Она может быть подделана, размножена и не имеет ценности с точки зрения безопасности.

В цифровых удостоверениях используются два ключа — открытый ключ, с помощью которого любой пользователь может проверить цифровую подпись, и закрытый ключ, известный только владельцу цифрового удостоверения. Закрытый ключ используется для создания цифровой подписи. Подробную информацию о цифровых удостоверениях, цифровых подписях, открытых и закрытых ключах можно найти в Интернете.

Цифровую подпись можно добавить к файлам форматов AutoCAD 2000 и более поздних версий, включая файлы, созданные с помощью функции формирования комплекта. Для добавления цифровой подписи одновременно к нескольким файлам или к файлу чертежа, совместимому с форматом AutoCAD 2000 или более поздней версии, см. раздел Диалоговое окно "Добавление цифровых подписей" в Справочнике команд.

ПримечаниеДобавленная к чертежу цифровая подпись может быть либо действительной, либо недействительной. Удалить цифровую подпись из файла чертежа невозможно. Если цифровая подпись была добавлена ошибочно, необходимо сохранить чертеж в формате DXF, затем открыть DXF-файл и сохранить его в DWG-формате.


Коротко о цифровых подписях (Краткий справочник)

Просмотр свойств чертежа, защищенного паролем
Коротко о цифровых подписях
Получение цифрового удостоверения
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Коротко о цифровых подписях >
Коротко о цифровых подписях
Понятие Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Чертежи с цифровой подписью

Коротко о цифровых подписях
Добавление цифровой подписи к чертежам
Получение цифрового удостоверения
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам >
Чертежи с цифровой подписью
Понятие Процедура

Получатели файлов с цифровой подписью могут быть уверены в неизменности файлов с момента их подписания. Любые вносимые изменения делают цифровую подпись недействительной.

Для того чтобы отправлять файлы с цифровой подписью, необходимо получить цифровое удостоверение (сертификат). Цифровое удостоверение однозначно определяет лицо или организацию, подписавшую файл. Для получения дополнительной информации о цифровых удостоверениях выполните поиск в Интернете по ключевым словам "цифровое удостоверение".

Пользователь может включить опцию автоматического добавления цифровой подписи к чертежу при его сохранении. Существует возможность одновременного подписывания нескольких файлов, а также подписывания комплекта файлов, сформированного функцией eTransmit.

ПримечаниеДля предотвращения изменения чертежа присоединение цифровой подписи к файлу чертежа автоматически устанавливает системную переменную FIELDEVAL в 0 (ручное обновление).

Темы в этом разделе

  • Получение цифрового удостоверения

    Для того чтобы отправлять файлы с цифровой подписью, необходимо получить цифровое удостоверение (сертификат). Цифровые удостоверения выдаются независимыми центрами сертификации. Существуют удостоверения для отдельных лиц и для организаций.

  • Добавление цифровой подписи к одному файлу

    Добавление цифровой подписи к файлу гарантирует, что получатели будут извещены о внесенных в файл изменениях.

  • Добавление цифровых подписей к нескольким файлам

    Добавление цифровой подписи к набору файлов гарантирует, что любой просматривающий файлы будет знать обо всех изменениях, внесенных в файлы, после того как они были подписаны.

  • Добавление комментария и штемпеля даты/времени

    К цифровой подписи можно добавить комментарий, а также штемпель даты и времени.

  • Добавление цифровой подписи к зашифрованным чертежам

    Файл чертежа может быть одновременно и зашифрован с помощью пароля, и защищен цифровой подписью. Пароль добавляется в первую очередь


Чертежи с цифровой подписью (Процедура)

Просмотр свойств чертежа, защищенного паролем
Чертежи с цифровой подписью
Получение цифрового удостоверения
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью >
Чертежи с цифровой подписью
Понятие Процедура

Для получения цифрового удостоверения через Интернет

Для включения опции автоматического добавления цифровой подписи после сохранения файла

Для добавления цифровых подписей к нескольким файлам

Выбор сервера времени и добавление комментария

Добавление сервера времени к списку серверов времени


Получение цифрового удостоверения (Понятие)

Чертежи с цифровой подписью
Чертежи с цифровой подписью
Добавление цифровой подписи к одному файлу
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью >
Получение цифрового удостоверения
Понятие Процедура Краткий справочник

Для того чтобы отправлять файлы с цифровой подписью, необходимо получить цифровое удостоверение (сертификат). Цифровые удостоверения выдаются независимыми центрами сертификации. Существуют удостоверения для отдельных лиц и для организаций.

Цифровое удостоверение содержит имя, серийный номер, срок действия и другую информацию, подтверждающую цифровую подпись. От центра сертификации можно получить цифровые удостоверения, различающиеся по уровню безопасности: "Низкого", "Среднего" или "Высокого".

  • Низкий. Используется при необходимости быстрого добавления цифровой подписи к нескольким файлам. Цифровая подпись автоматически добавляется ко всем выбранным типам файлов.
  • Средний. Используется при необходимости уведомления о попытке создать приложением подпись с цифровым удостоверением пользователя. Таким образом, пользователь получает уведомления обо всех файлах с цифровыми подписями, использующих его цифровое удостоверение.
  • Высокий. Применяется при необходимости исключить возможность несанкционированного использования цифровой подписи пользователя. При подписывании каждого файла запрашивается ввод пароля.


Для получения цифрового удостоверения через Интернет (Процедура)

Чертежи с цифровой подписью
На уровень вверх ..
Добавление цифровой подписи к одному файлу
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Получение цифрового удостоверения >
Получение цифрового удостоверения
Понятие Процедура Краткий справочник

Для получения цифрового удостоверения через Интернет

  1. Запустить Интернет-браузер, перейти на страницу поисковой системы и набрать в строке поиска «цифровой сертификат» («digital certificate»).
  2. В результатах поиска можно найти подробную информацию о центрах сертификации и порядке получения цифрового удостоверения.
Ввод команды: БЕЗОПНАСТР


Получение цифрового удостоверения (Краткий справочник)

Коротко о цифровых подписях
Получение цифрового удостоверения
Добавление цифровой подписи к одному файлу
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Получение цифрового удостоверения >
Получение цифрового удостоверения
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Добавление цифровой подписи к одному файлу (Понятие)

Получение цифрового удостоверения
Чертежи с цифровой подписью
Добавление цифровых подписей к нескольким файлам
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью >
Добавление цифровой подписи к одному файлу
Понятие Процедура Краткий справочник

Добавление цифровой подписи к файлу гарантирует, что получатели будут извещены о внесенных в файл изменениях.

Пользователь может включить опцию автоматического добавления цифровой подписи после сохранения файла. К одному файлу можно добавить только одну цифровую подпись.

Если несколько файлов чертежей требуется и зашифровать, и добавить к ним цифровую подпись, то сначала нужно выполнить шифрование, а затем пакетное добавление цифровой подписи. Любое изменение файла, в том числе при шифровании, делает цифровую подпись недействительной.

ПримечаниеУтилита добавления цифровых подписей освобождает от необходимости проведения этой операции с каждым файлом по отдельности.


Для включения опции автоматического добавления цифровой подписи после сохранения файла (Процедура)

Получение цифрового удостоверения
На уровень вверх ..
Добавление цифровых подписей к нескольким файлам
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление цифровой подписи к одному файлу >
Добавление цифровой подписи к одному файлу
Понятие Процедура Краткий справочник

Для включения опции автоматического добавления цифровой подписи после сохранения файла

  1. Выполните одно из следующих действий:
    • Выберите меню Сервис [image] Параметры.В командной строке введите "настройка". В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" нажмите "Безопасность".
    • Выберите меню Файл [image] Сохранить как.В командной строке введите "сохранитькак". В диалоговом окне "Сохранение чертежа" выберите "Сервис" [image] "Параметры безопасности".
  2. В диалоговом окне "Параметры безопасности" на вкладке "Цифровая подпись" установите флажок "Присоединить цифровую подпись после сохранения чертежа".
  3. Нажмите "ОК".
    ПримечаниеВ диалоговом окне "Параметры безопасности" можно добавлять цифровые подписи только к файлам, совместимым с форматами файлов чертежей AutoCAD 2000 и более поздних версий.
Ввод команды: БЕЗОПНАСТР


Добавление цифровой подписи к одному файлу (Краткий справочник)

Получение цифрового удостоверения
Добавление цифровой подписи к одному файлу
Добавление цифровых подписей к нескольким файлам
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление цифровой подписи к одному файлу >
Добавление цифровой подписи к одному файлу
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Добавление цифровых подписей к нескольким файлам (Понятие)

Добавление цифровой подписи к одному файлу
Чертежи с цифровой подписью
Добавление комментария и штемпеля даты/времени
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью >
Добавление цифровых подписей к нескольким файлам
Понятие Процедура Краткий справочник

Добавление цифровой подписи к набору файлов гарантирует, что любой просматривающий файлы будет знать обо всех изменениях, внесенных в файлы, после того как они были подписаны.

Цифровую подпись можно добавлять к файлам следующих типов:

  • EXE- и ZIP-файлы, полученные с помощью функции формирования комплектов (eTransmit)
  • DWS-файлы
  • Файлы DWG и DWT, совместимые с форматом чертежей AutoCAD 2000 и более поздних версий

При добавлении цифровой подписи к набору файлов можно выбирать файлы по одному в утилите добавления цифровой подписи или перетаскивать их в утилиту из окна Проводника.


Для добавления цифровых подписей к нескольким файлам (Процедура)

Добавление цифровой подписи к одному файлу
На уровень вверх ..
Добавление комментария и штемпеля даты/времени
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление цифровых подписей к нескольким файлам >
Добавление цифровых подписей к нескольким файлам
Понятие Процедура Краткий справочник

Для добавления цифровых подписей к нескольким файлам

  1. В ОС Windows выберите "Пуск" [image] "Все программы" [image] "Autodesk" [image] "AutoCAD 2009" [image] "Добавление цифровых подписей".
  2. В диалоговом окне "Добавление цифровых подписей" нажмите кнопку "Добавить".
  3. В диалоговом окне "Выбор файлов" выберите файлы, к которым требуется добавить цифровую подпись. Нажмите "Открыть".
    ПримечаниеВ диалоговом окне "Добавление цифровых подписей" можно добавлять цифровые подписи к файлам, совместимым с форматом чертежей AutoCAD 2000 и более поздних версий.
  4. В диалоговом окне "Добавление цифровых подписей" в поле "Имеющиеся сертификаты" выберите цифровое удостоверение, которое необходимо добавить к файлам, выбранным в списке "Список файлов".
  5. В списке "Источник для отметки времени" выберите службу времени, если необходимо добавить штемпель времени к подписываемым файлам. Если отметка времени не требуется, используйте значение по умолчанию - "Без отметки времени".
  6. В поле "Пояснение" можно добавить текстовые комментарии для файлов, к которым добавляется цифровая подпись.
  7. Нажмите кнопку "Добавить подпись".
  8. Если выбранный файл имеет атрибут "только чтение", появляется диалоговое окно с соответствующим запросом. Выполните одно из следующих действий:
    • Для добавления цифровой подписи в диалоговом окне нажмите "Да".
    • Для добавления цифровой подписи ко всем файлам, доступным только для чтения, выберите "Применить для всех таких файлов в списке". Нажмите "Да".
    • Для отказа от добавления цифровой подписи к файлу с атрибутом "только чтение" нажмите "Нет".
    • Для отказа от добавления цифровой подписи ко всем файлам с атрибутом "только чтение" нажмите "Отмена".
    ПримечаниеЕсли при получении цифрового сертификата установлен средний или высокий уровень безопасности, то при добавлении цифровой подписи к каждому файлу выдается информационное сообщение.
  9. После добавления цифровой подписи ко всем файлам выдается сообщение с числом подписанных файлов. Нажать "ОК".

    В группе «Список файлов» подписанные файлы приобретают статус «Подписано».

  10. Нажать кнопку "Закрыть".
ПримечаниеПодписанные файлы приобретают атрибут "только чтение" для защиты от случайного изменения.


Добавление цифровых подписей к нескольким файлам (Краткий справочник)

Добавление цифровой подписи к одному файлу
Добавление цифровых подписей к нескольким файлам
Добавление комментария и штемпеля даты/времени
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление цифровых подписей к нескольким файлам >
Добавление цифровых подписей к нескольким файлам
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Добавление комментария и штемпеля даты/времени (Понятие)

Добавление цифровых подписей к нескольким файлам
Чертежи с цифровой подписью
Добавление цифровой подписи к зашифрованным чертежам
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью >
Добавление комментария и штемпеля даты/времени
Понятие Процедура Краткий справочник

К цифровой подписи можно добавить комментарий, а также штемпель даты и времени.

При добавлении штемпеля даты и времени к цифровой подписи к цифровой подписи можно получить текущее время с какого-либо сервера. При передаче файлов чертежей через сеть Интернет или в процессе разработки совместного проекта можно выбрать конкретный сервер для создания точного согласованного штемпеля даты и времени.

Существуют правительственные (например, National Institute of Standards and Technology или the US Naval Observatory) и общедоступные (California Institute of Technology) службы точного времени. Пользователь может также добавить собственный сервер для создания штемпеля даты и времени путем изменения файла timesrvr.txt или создания пользовательского файла, содержащего сведения о серверах, которые требуется использовать при добавлении штемпеля даты и времени к цифровой подписи.

Файл timesrvr.txt находится в каталоге установки программы. По умолчанию программа устанавливается в каталог \Program Files\AutoCAD 2009. Для добавления нового сервера откройте файл timesrvr.txt в текстовом редакторе (например, "Блокнот") и введите необходимую информацию о сервере. При добавлении пользовательского сервера необходимо ввести в файле timesrvr.txt описание и имя сервера. В качестве описания следует ввести значение, представленное в раскрывающемся списке, а в качестве имени сервера - его адрес URL (Uniform Resource Locator - унифицированный указатель ресурсов). Информация о каждом сервере, указанном в файле timesrvr.txt, должна быть представлена в следующем формате.

Описание (имя_сервера)

Например:

National Institute of Standards and Technology (time.nist.gov)

ПримечаниеСведения о каждом добавляемом сервере следует вводить в отдельной строке текстового файла.

Если вместо файла timesrvr.txt требуется использовать другой текстовый файл, содержащий сведения о серверах времени, с которых можно получать текущее время при создании штемпеля даты и времени для цифровой подписи, следует изменить значение переменной среды ADSKSIGTIMESRVR. Например, можно изменить значение этой переменной на c:\temp\mytimelist.txt


Добавление комментария и штемпеля даты/времени (Процедура)

Добавление цифровых подписей к нескольким файлам
На уровень вверх ..
Добавление комментария и штемпеля даты/времени
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление комментария и штемпеля даты/времени >
Добавление комментария и штемпеля даты/времени
Понятие Процедура Краткий справочник

Выбор сервера времени и добавление комментария

Добавление сервера времени к списку серверов времени


Выбор сервера времени и добавление комментария (Процедура)

Добавление комментария и штемпеля даты/времени
На уровень вверх ..
Добавление комментария и штемпеля даты/времени
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление комментария и штемпеля даты/времени >
Добавление комментария и штемпеля даты/времени
Понятие Процедура Краткий справочник

Выбор сервера времени и добавление комментария

  1. Выполните одно из следующих действий:
    • Выберите меню Сервис [image] Параметры.В командной строке введите "настройка". В диалоговом окне "Настройка" на вкладке "Открытие/Сохранение" выберите "Параметры безопасности".
    • Выберите пункт меню "Файл" [image] "Сохранить как".В командной строке введите "сохранитькак". В диалоговом окне "Сохранение чертежа" выберите "Сервис" [image] "Параметры безопасности".
  2. В диалоговом окне "Параметры безопасности" на вкладке "Цифровая подпись" установите флажок "Присоединить цифровую подпись после сохранения чертежа".
  3. В списке "Источник для отметки времени" выберите сервер времени.
  4. В поле "Пояснение" введите необходимые пояснения.
  5. Нажмите "ОК".
Ввод команды: БЕЗОПНАСТР


Добавление сервера времени к списку серверов времени (Процедура)

Добавление комментария и штемпеля даты/времени
На уровень вверх ..
Открытие файлов чертежей с цифровой подписью
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление комментария и штемпеля даты/времени >
Добавление комментария и штемпеля даты/времени
Понятие Процедура Краткий справочник

Добавление сервера времени к списку серверов времени

  1. Найдите и откройте файл timesrvr.txt.

    В файле timesrvr.txt содержатся данные о службах времени.

  2. Добавьте требующуюся службу времени в файл timesrvr.txt. Используйте следующий формат:

    Описание (имя_сервера)

    Например:

    National Institute of Standards and Technology (time.nist.gov)

  3. Сохраните файл.
ПримечаниеЕсли вместо файла timesrvr.txt требуется использовать другой текстовый файл, содержащий сведения о серверах времени, с которых можно получать текущее время при создании штемпеля даты и времени для цифровой подписи, следует изменить значение переменной среды ADSKSIGTIMESRVR. Например, измените значение переменной на c:\temp\mytimelist.txt.
Ввод команды: БЕЗОПНАСТР


Добавление комментария и штемпеля даты/времени (Краткий справочник)

Добавление цифровых подписей к нескольким файлам
Добавление комментария и штемпеля даты/времени
Добавление цифровой подписи к зашифрованным чертежам
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление комментария и штемпеля даты/времени >
Добавление комментария и штемпеля даты/времени
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Добавление цифровой подписи к зашифрованным чертежам (Понятие)

Добавление комментария и штемпеля даты/времени
Чертежи с цифровой подписью
Открытие файлов чертежей с цифровой подписью
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью >
Добавление цифровой подписи к зашифрованным чертежам
Понятие Краткий справочник

Файл чертежа может быть одновременно и зашифрован с помощью пароля, и защищен цифровой подписью. Пароль добавляется в первую очередь

Изменение файла, в том числе добавление пароля, делает цифровую подпись недействительной.


Добавление цифровой подписи к зашифрованным чертежам (Краткий справочник)

Добавление комментария и штемпеля даты/времени
Добавление цифровой подписи к зашифрованным чертежам
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Чертежи с цифровой подписью > Добавление цифровой подписи к зашифрованным чертежам >
Добавление цифровой подписи к зашифрованным чертежам
Понятие Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Открытие файлов чертежей с цифровой подписью

Добавление цифровой подписи к зашифрованным чертежам
Добавление цифровой подписи к чертежам
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам >
Открытие файлов чертежей с цифровой подписью
Понятие Процедура

Вместе с файлами чертежей, имеющих цифровую подпись, отправляются электронные средства оценки (проверки подлинности) подписей.

Цифровая подпись однозначно определяет лицо или организацию с помощью цифрового удостоверения (сертификата) и позволяет подтвердить неизменность файла. Подписывание файлов особенно актуально при пересылке данных по линиям связи. Цифровая подпись позволяет предотвратить доступ посторонних лиц к данным при работе над совместными проектами. Цифровую подпись можно проверить или в программе, или в Проводнике.

Цифровая подпись содержит следующие сведения о подписанном файле:

  • Изменялся ли чертеж после добавления подписи.
  • Сведения о подлинности подписи.
  • Сведения о пользователе, подписавшем файл.

Цифровую подпись считают недействительной в следующих случаях:

  • При добавлении цифровой подписи файл был поврежден.
  • Файл был поврежден при пересылке.
  • Срок действия цифрового удостоверения истек.
ПримечаниеДля сохранения действительности цифровой подписи не следует изменять или шифровать файлы, имеющие цифровую подпись. Вносить изменения, а также шифровать файлы необходимо до добавления цифровой подписи. Свойства цифровой подписи изменяются при редактировании, сохранении или экспорте данных чертежа.

Темы в этом разделе

  • Просмотр свойств цифровой подписи

    Получив файл с цифровой подписью, пользователь может проверить, вносились ли в файл изменения с момента его подписания, и просмотреть другую информацию.

  • Установка корневого сертификата

    При получении из центра сертификации файла с цифровой подписью, которая не распознается операционной системой, может потребоваться установка корневого сертификата (наивысший сертификат в иерархии сертификации).


Открытие файлов чертежей с цифровой подписью (Процедура)

Добавление комментария и штемпеля даты/времени
Открытие файлов чертежей с цифровой подписью
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью >
Открытие файлов чертежей с цифровой подписью
Понятие Процедура

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

Для подтверждения допустимости цифровой подписи в Проводнике

Для отыскания файлов с цифровой подписью в Проводнике

Для включения-отключения отображения значка цифровой подписи в Проводнике

Для отключения отображения свойств действительных цифровых подписей

Для получения корневого сертификата


Просмотр свойств цифровой подписи (Понятие)

Открытие файлов чертежей с цифровой подписью
Открытие файлов чертежей с цифровой подписью
Установка корневого сертификата
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Получив файл с цифровой подписью, пользователь может проверить, вносились ли в файл изменения с момента его подписания, и просмотреть другую информацию.

Если файл содержит данные о цифровой подписи, в строке состояния программы отображается соответствующий значок. Нажав на значке, можно извлечь следующую информацию:

  • Действительность цифровой подписи
  • Были ли изменения в чертеже после добавления подписи.
  • Сведения об организации или разработчике, подписавшем файл
  • Дату и время подписи, а также комментарии к файлу.
  • Сведения о центре сертификации.
  • Срок действия цифрового удостоверения.

Цифровые подписи можно создавать для файлов, совместимых с форматом чертежей AutoCAD 2000 и более поздних версий. Если пользователь сохраняет файл, полученный с цифровой подписью, то считается, что файл изменен, и цифровая подпись становится недействительной. Информация о цифровой подписи при этом не теряется и может быть просмотрена. При получении и сохранении подписанного файла чертежа сведения о подписи могут быть утеряны.

ПримечаниеЕсли значение системной переменной SIGWARN равно 1, то при открытии файла с цифровой подписью отображаются свойства цифровой подписи. Если системная переменная SIGWARN приравнена к нулю и выполняется открытие файла, состояние цифровой подписи отображается только если она недействительна.

Также для проверки и подтверждения допустимости цифровой подписи можно просматривать свойства файла чертежа в Проводнике. Некоторые операционные системы модифицируют значки файлов, имеющих действительную цифровую подпись. Отображение такого значка может привести к некоторому снижению производительности системы (в зависимости от тактовой частоты процессора и размера файла), поэтому данную функцию можно отключить.


Просмотр свойств цифровой подписи (Процедура)

Открытие файлов чертежей с цифровой подписью
На уровень вверх ..
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

Для подтверждения допустимости цифровой подписи в Проводнике

Для отыскания файлов с цифровой подписью в Проводнике

Для включения-отключения отображения значка цифровой подписи в Проводнике

Для отключения отображения свойств действительных цифровых подписей


Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD (Процедура)

Просмотр свойств цифровой подписи
На уровень вверх ..
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Для подтверждения допустимости цифровой подписи при открытии файла чертежа AutoCAD

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/сохранение" установите флажок "Отображать информацию о цифровой подписи".
  3. Нажмите "ОК".
  4. Откройте подписанный файл.

    В раскрывающемся списке "Другие поля" диалогового окна "Свойства цифровой подписи" пользователь может выбирать и просматривать интересующие его сведения о цифровой подписи, например даты начала и прекращения действия цифрового удостоверения и серийный номер.

  5. Нажмите кнопку "Закрыть".
Ввод команды: ПДПРОВЕРИТЬ


Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей" (Процедура)

Просмотр свойств цифровой подписи
На уровень вверх ..
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Для подтверждения допустимости цифровой подписи файла чертежа с помощью значка "Проверка цифровых подписей"

  1. Откройте подписанный файл.
  2. В строке состояния программы нажмите значок "Проверка цифровых подписей".
  3. Если цифровая подпись файла действительна, в диалоговом окне "Проверка цифровых подписей" нажмите кнопку "Основная подпись".

    Диалоговое окно "Свойства цифровой подписи" содержит подробные сведения о цифровой подписи, такие как подписавшийся, дату окончания действия цифрового удостоверения, серийный номер, комментарии к цифровой подписи, временной штемпель и службу времени.

  4. Нажмите кнопку "Закрыть".
  5. Если файл содержит внешние ссылки с цифровой подписью, в диалоговом окне "Проверка цифровых подписей" выберите параметр "Просмотр чертежей внешних ссылок". Для просмотра внешних ссылок, связанных с файлом, нажмите кнопку "Подписи в ссылках".
  6. Нажмите кнопку "Закрыть".
Ввод команды: ПДПРОВЕРИТЬ


Для подтверждения допустимости цифровой подписи в Проводнике (Процедура)

Просмотр свойств цифровой подписи
На уровень вверх ..
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Для подтверждения допустимости цифровой подписи в Проводнике

  1. В Проводнике найдите файл, цифровую подпись которого требуется проверить.

    Некоторые операционные системы модифицируют значки файлов, имеющих действительную цифровую подпись.

  2. Нажмите правую кнопку мыши на имени файла. Нажмите кнопку "Свойства".
  3. При наличии у файла цифровой подписи в диалоговом окне "Свойства" отображается вкладка "Цифровая подпись". На вкладке "Цифровая подпись" содержатся сведения о цифровой подписи.

    Если цифровая подпись действительна, отображается значок действительной цифровой подписи. Для недействительной цифровой подписи отображается значок недействительной цифровой подписи.

  4. В раскрывающемся списке "Другие поля" свойств цифровой подписи пользователь может выбирать и просматривать интересующие его сведения о цифровой подписи, например сведения о центре сертификации, описание и дату прекращения действия цифрового удостоверения. Также можно просматривать временной штемпель и сведения о службе времени.
  5. Для закрытия окна с информацией о цифровой подписи нажмите "ОК".


Для отыскания файлов с цифровой подписью в Проводнике (Процедура)

Просмотр свойств цифровой подписи
На уровень вверх ..
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Для отыскания файлов с цифровой подписью в Проводнике

  • В Проводнике найдите файл, цифровую подпись которого требуется проверить. Для файлов с цифровой подписью отображается соответствующий значок.


Для включения-отключения отображения значка цифровой подписи в Проводнике (Процедура)

Просмотр свойств цифровой подписи
На уровень вверх ..
Просмотр свойств цифровой подписи
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Для включения-отключения отображения значка цифровой подписи в Проводнике

  1. В Проводнике найдите файл, у которого имеется значок цифровой подписи.
  2. Нажмите правую кнопку мыши на имени файла. Выберите "Включение и отключение значков цифровых подписей".
  3. Установите или снимите флажок параметра "Проверять цифровые подписи и отображать специальные значки" для, соответственно, включения или отключения отображения значка в Проводнике.
  4. Нажмите "ОК". Выйдите, а затем снова войдите в Windows.


Для отключения отображения свойств действительных цифровых подписей (Процедура)

Просмотр свойств цифровой подписи
На уровень вверх ..
Установка корневого сертификата
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Для отключения отображения свойств действительных цифровых подписей

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Открытие/сохранение" снимите флажок "Отображать информацию о цифровой подписи".
  3. Нажмите "ОК".
Ввод команды: SIGWARN


Просмотр свойств цифровой подписи (Краткий справочник)

Добавление цифровой подписи к зашифрованным чертежам
Просмотр свойств цифровой подписи
Установка корневого сертификата
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Просмотр свойств цифровой подписи >
Просмотр свойств цифровой подписи
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Установка корневого сертификата (Понятие)

Просмотр свойств цифровой подписи
Открытие файлов чертежей с цифровой подписью
Совместная работа с чертежами в Интернете
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью >
Установка корневого сертификата
Понятие Процедура Краткий справочник

При получении из центра сертификации файла с цифровой подписью, которая не распознается операционной системой, может потребоваться установка корневого сертификата (наивысший сертификат в иерархии сертификации).

Работа цифровых удостоверений основана на принципе доверительной иерархии. Корневой сертификат - это сертификат, выданный и подписанный одним и тем же центром сертификации. Распространенные браузеры, например Microsoft Internet Explorer, содержат корневые сертификаты основных их распространителей, что автоматически удостоверяет соответствующие цифровые удостоверения.

При получении файла, подписанного цифровым удостоверением, выданным, например службой информационных технологий вашей организации, становится невозможно проверить цифровое удостоверение и может потребоваться установка корневого сертификата.


Для получения корневого сертификата (Процедура)

Просмотр свойств цифровой подписи
На уровень вверх ..
Основные принципы
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Установка корневого сертификата >
Установка корневого сертификата
Понятие Процедура Краткий справочник

Для получения корневого сертификата

  1. Для получения корневого сертификата обратитесь в организацию или к пользователю, добавившему цифровую подпись к данному файлу.
  2. При получении корневого сертификата выберите меню "Пуск" (Windows) [image] "Настройка" [image] "Панель управления" [image] "Свойства обозревателя".
  3. В диалоговом окне "Свойства Интернета" на вкладке "Содержимое" выберите "Сертификаты".
  4. В окне "Сертификаты" нажмите кнопку "Импорт" для вызова Мастера импорта сертификатов.
  5. Для получения корневого сертификата следуйте экранным подсказкам Мастера импорта сертификатов.


Установка корневого сертификата (Краткий справочник)

Просмотр свойств цифровой подписи
Установка корневого сертификата
Основные принципы
Совместная работа над проектами > Защита чертежей и добавление цифровой подписи > Добавление цифровой подписи к чертежам > Открытие файлов чертежей с цифровой подписью > Установка корневого сертификата >
Установка корневого сертификата
Понятие Процедура Краткий справочник

Команды

БЕЗОПНАСТР

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

ПДПРОВЕРИТЬ

Вывод информации о цифровой подписи файла

Системные переменные

SIGWARN

Управление отображением предупреждения при открытии файла с присоединенной цифровой подписью

Утилиты

Добавление цифровых подписей

Добавление цифровой подписи к файлам

Ключевые слова для команд

Нет


Совместная работа с чертежами в Интернете

Установка корневого сертификата
Совместная работа над проектами
Основные принципы
Совместная работа над проектами >
Совместная работа с чертежами в Интернете

Пользователь может хранить чертежи AutoCAD и связанные с ними файлы в глобальной сети Интернет. Необходимо, чтобы на пользовательском компьютере был установлен Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздняя версия) и существовал доступ в Интернет или корпоративную сеть.

Темы в этом разделе

  • Основные принципы
  • Добавление гиперссылок в чертеж

    Можно добавлять гиперссылки в чертежи - это указатели переходов на логически связанные файлы или веб-сайты.

  • Работа с чертежами в Интернете

    Имеется возможность открывать чертежи с сетевых серверов, сохранять их там, вставлять блоки путем перетаскивания чертежей с сайтов, вставлять в чертежи гиперссылки, а также создавать комплекты, объединяющие в себе чертежи и все связанные с ними файлы.

  • Создание веб-страниц с помощью Мастера публикации в Интернете

    Мастер "Публикация в Интернете" позволяет упростить процесс создания файлов DWF или DWFx, а также их форматирования для отображения на страницах HTML.


Основные принципы (Понятие)

Совместная работа с чертежами в Интернете
Совместная работа с чертежами в Интернете
Добавление гиперссылок в чертеж
Совместная работа над проектами > Совместная работа с чертежами в Интернете >
Основные принципы
Понятие Процедура Краткий справочник

Чтобы воспользоваться Интернет-средствами с помощью этой программы, необходимо иметь доступ к Интернету или интрасети и установить в системе Microsoft Internet Explorer 6.1 с пакетом обновления SP1 (или более поздней версии). Здесь и далее термин Интернет будет использоваться для обозначения как глобальной, так и корпоративной сети. Для того, чтобы сохранять файлы в Интернете, нужны соответствующие права доступа к сетевой папке. Их можно получить у администратора сети или у поставщика Интернет-услуг (провайдера).

Если подключение к Интернету осуществляется через локальную сеть организации, возможно, потребуется конфигурация прокси-сервера. Прокси-серверы выступают в роли барьеров, ограждающих рабочие станции сети от опасности несанкционированного вторжения извне и порчи данных. О том, как настроить систему на работу через прокси-сервер, можно узнать в справочной системе по Windows® (Панель управления, элемент "Интернет") или у администратора сети.


Процедура изменения адреса URL, используемого при выполнении команды "БРАУЗЕР" и при работе с диалоговым окном "Навигация в Интернете" (Процедура)

Установка корневого сертификата
Основные принципы
Добавление гиперссылок в чертеж
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Основные принципы >
Основные принципы
Понятие Процедура Краткий справочник

Процедура изменения адреса URL, используемого при выполнении команды "БРАУЗЕР" и при работе с диалоговым окном "Навигация в Интернете"

  1. В командной строке введите inetlocation.
  2. Введите новый адрес в сети Интернет.
Ввод команды: INETLOCATION


Основные принципы (Краткий справочник)

Установка корневого сертификата
Основные принципы
Основные понятия использования гиперссылок в чертежах
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Основные принципы >
Основные принципы
Понятие Процедура Краткий справочник

Команды

БРАУЗЕР

Вызов заданного по умолчанию обозревателя Интернета, указанного в системном реестре

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

Системные переменные

HYPERLINKBASE

Указание пути, используемого для всех относительных гиперссылок в чертеже

INETLOCATION

Адрес в сети Интернет, используемый в команде БРАУЗЕР и в диалоговом окне "Просмотр Web"

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление гиперссылок в чертеж

Основные принципы
Совместная работа с чертежами в Интернете
Основные понятия использования гиперссылок в чертежах
Совместная работа над проектами > Совместная работа с чертежами в Интернете >
Добавление гиперссылок в чертеж
Понятие Процедура

Можно добавлять гиперссылки в чертежи - это указатели переходов на логически связанные файлы или веб-сайты.

Темы в этом разделе

  • Основные понятия использования гиперссылок в чертежах

    Использование гиперссылок - это удобный способ связывания с чертежом дополнительных документов: других чертежей, спецификаций, организационных планов.

  • Использование гиперссылок для доступа к файлам и веб-страницам

    Гиперссылки могут указывать на файлы, хранящиеся на диске компьютера, в локальной сети и в Интернете или на именованные места в чертежах, такие как виды.

  • Гиперссылки для создания сообщений электронной почты

    Обычно гиперссылки используются для подключения к графическим объектам логически связанных документов. Но в некоторых случаях бывает необходимо, чтобы при выборе гиперссылки создавалось сообщение электронной почты.

  • Гиперссылки в блоках

    Гиперссылки можно подключать к блокам и даже к объектам, заключенным в блоки. Все относительные гиперссылки, заданные для объектов блока, после вставки начинают опираться на базовый путь текущего чертежа.

  • Использование гиперссылок для создания новых чертежей


Добавление гиперссылок в чертеж (Процедура)

Основные принципы
Добавление гиперссылок в чертеж
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж >
Добавление гиперссылок в чертеж
Понятие Процедура

Создание абсолютной гиперссылки на другой файл

Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD)

Для редактирования гиперссылки, подключенной к графическому объекту

Для удаления гиперссылки из графического объекта

Для открытия файла, на который указывает гиперссылка

Для включения и отключения курсора на гиперссылках

Для задания пути, используемого для всех относительных гиперссылок в чертеже

Для создания относительной гиперссылки

Для создания гиперссылки на сообщение электронной почты

Для открытия файла, на который указывает гиперссылка внутри блока

Для создания нового чертежа на основе DWT-файла гиперссылки


Основные понятия использования гиперссылок в чертежах (Понятие)

Добавление гиперссылок в чертеж
Добавление гиперссылок в чертеж
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж >
Основные понятия использования гиперссылок в чертежах
Понятие Краткий справочник

Использование гиперссылок - это удобный способ связывания с чертежом дополнительных документов: других чертежей, спецификаций, организационных планов.

Гиперссылки в чертежах - это указатели переходов на логически связанные файлы. При выборе гиперссылки, например, может выполняться вызов текстового процессора с загрузкой в него указанного файла, или же активизация веб-браузера и переход в нем на заданный сайт в Интернете. Открываемый файл может быть сразу установлен на именованную позицию (вид в файле чертежа или закладка в программе текстового редактора). Гиперссылки разрешается подключать к любым графическим объектам чертежей AutoCAD. Использование гиперссылок - это удобный способ связывания с чертежом AutoCAD дополнительных документов: других чертежей, спецификаций, организационных планов.

В чертежах можно создавать как абсолютные, так и относительные гиперссылки. Абсолютные гиперссылки содержат полный путь к файлу. Относительные гиперссылки содержат только часть пути к файлу, которая отсчитывается от некоторого адреса URL или от папки, указанной в системной переменной HYPERLINKBASE.


Основные понятия использования гиперссылок в чертежах (Краткий справочник)

Основные принципы
Основные понятия использования гиперссылок в чертежах
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Основные понятия использования гиперссылок в чертежах >
Основные понятия использования гиперссылок в чертежах
Понятие Краткий справочник

Команды

УРЛСВЯЗАТЬ

Создание гиперссылок для объектов или областей чертежа

УРЛРАЗОРВАТЬ

Удаление гиперссылок в чертеже

УРЛПЕРЕЙТИ

Открытие файла или веб-страницы, ассоциированной с гиперссылкой, прикрепленной к объекту

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

Системные переменные

HYPERLINKBASE

Указание пути, используемого для всех относительных гиперссылок в чертеже

Утилиты

Нет

Ключевые слова для команд

Нет


Использование гиперссылок для доступа к файлам и веб-страницам (Понятие)

Основные понятия использования гиперссылок в чертежах
Добавление гиперссылок в чертеж
Гиперссылки для создания сообщений электронной почты
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Гиперссылки могут указывать на файлы, хранящиеся на диске компьютера, в локальной сети и в Интернете или на именованные места в чертежах, такие как виды.

По умолчанию, когда перекрестье курсора располагается над объектом, к которому прикреплена гиперссылка, возникает курсор гиперссылки и всплывающая подсказка. Для перехода по ссылке следует нажать клавишу CTRL и затем нажать на данной ссылке (CTRL + щелчок).

ПримечаниеДля открытия файлов, связанных с гиперссылками, системная переменная PICKFIRST должна иметь значение 1. Отключить курсор гиперссылки, всплывающие подсказки и контекстное меню можно в диалоговом окне "Настройка" на вкладке "Пользовательские".

Если была создана гиперссылка в чертеже и определен именованный вид, куда должен осуществляться переход, то открытие гиперссылки приводит к восстановлению данного вида. Можно также создать гиперссылку, которая открывает чертеж в определенном расположении.

Использование относительных и абсолютных путей в гиперссылках

Относительные гиперссылки предоставляют большую гибкость по сравнению с абсолютными гиперссылками; кроме того, их проще редактировать. В случае, если вся структура файлов перемещена в другую папку, для обновления относительных гиперссылок достаточно всего одной операции.

Абсолютную гиперссылку необходимо использовать при создании в файле ссылки на документ, который не содержится в этом файле, или в том случае, если относительный путь к документу не известен. Например, абсолютную гиперссылку следует использовать для создания связи с чертежом на другом сетевом диске. При перемещении файлов, на которые указывают абсолютные гиперссылки, в другой каталог редактирование соответствующих относительных путей может занять много времени.


Использование гиперссылок для доступа к файлам и веб-страницам (Процедура)

Добавление гиперссылок в чертеж
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Создание абсолютной гиперссылки на другой файл

Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD)

Для редактирования гиперссылки, подключенной к графическому объекту

Для удаления гиперссылки из графического объекта

Для открытия файла, на который указывает гиперссылка

Для включения и отключения курсора на гиперссылках

Для задания пути, используемого для всех относительных гиперссылок в чертеже

Для создания относительной гиперссылки


Создание абсолютной гиперссылки на другой файл (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Создание абсолютной гиперссылки на другой файл

  1. В области рисования выберите один или несколько объектов.
  2. Выберите следующие элементы: вкладка "Блоки и ссылки" [image] панель "Данные" [image] Гиперссылка. В командной строке введите "гиперссылка".
  3. Выполнить одно из следующих действий:
    • В поле "Введите имя файла или веб-страницы" введите имя файла (вместе с путем), на который должен производиться переход.
    • Нажмите кнопку "Файл". Перейдите к файлу, который необходимо связать с гиперссылкой. Нажмите кнопку "Открыть".
  4. (Дополнительно) При создании гиперссылки на чертеж выберите "Цель" для задания именованной позиции в чертеже, к которой необходимо перейти, и выполните следующие действия:
    • Выберите именованную позицию.
    • Нажмите "ОК".
  5. (Дополнительно) В поле "Описание к гиперссылке" введите текст отображаемого на экране описания.
  6. Нажмите "ОК".
Ввод команды: ГИПЕРССЫЛКА


Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD) (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Для создания гиперссылки на именованную позицию в файле другого приложения (не AutoCAD)

  1. Создайте гиперссылку (см. процедуру Создание абсолютной гиперссылки на другой файл).
  2. Выберите следующие элементы: вкладка "Блоки и ссылки" [image] панель "Данные" [image] Гиперссылка. В командной строке введите "гиперссылка".
  3. Выберите графические объекты для связывания с гиперссылкой.
  4. В поле "Введите имя файла или веб-страницы" после введенного имени файла, на который должен выполняться переход, введите символ решетки (#) и имя позиции. Между именем файла, символом решетки (#) и именем позиции не должно быть пробелов.
  5. Нажмите "ОК".
Ввод команды: ГИПЕРССЫЛКА


Для редактирования гиперссылки, подключенной к графическому объекту (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Для редактирования гиперссылки, подключенной к графическому объекту

  1. Выберите следующие элементы: вкладка "Блоки и ссылки" [image] панель "Данные" [image] Гиперссылка. В командной строке введите "гиперссылка".
  2. В области рисования выберите один или несколько объектов, имеющих одну и ту же гиперссылку.
  3. Введите новые значения в диалоговом окне "Редактирование гиперссылки". Нажмите "ОК".
Ввод команды: ГИПЕРССЫЛКА


Для удаления гиперссылки из графического объекта (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Для удаления гиперссылки из графического объекта

  1. В области рисования выберите один или несколько объектов, имеющих одну и ту же гиперссылку.
  2. Выберите следующие элементы: вкладка "Блоки и ссылки" [image] панель "Данные" [image] Гиперссылка. В командной строке введите "гиперссылка".
  3. В области рисования выберите один или несколько объектов, имеющих одну и ту же гиперссылку.
  4. Нажмите "Удалить гиперссылку". Нажмите "ОК".
Ввод команды: ГИПЕРССЫЛКА


Для открытия файла, на который указывает гиперссылка (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Для открытия файла, на который указывает гиперссылка

  1. В области рисования выберите объект, имеющий гиперссылку.
  2. Используйте один из следующих методов для перехода по ссылке:
    • Удерживайте в нажатом состоянии клавишу CTRL и нажмите кнопку мыши.
    • Нажмите правую кнопку мыши. Выберите "Гиперссылка". Выберите имя нужной гиперссылки. Каждая гиперссылка имеет либо описание, либо полный URL до файла, на который она указывает.
    ПримечаниеЕсли пользователь отключил отображение курсора гиперссылки, то параметры "Гиперссылка" становятся недоступными в контекстном меню. В диалоговом окне "Настройка" на вкладке "Пользовательские" можно включить курсор гиперссылки, всплывающие подсказки и контекстное меню. Для открытия файлов, связанных с гиперссылками, системная переменная PICKFIRST должна иметь значение 1.


Для включения и отключения курсора на гиперссылках (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Для включения и отключения курсора на гиперссылках

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Пользовательские" выберите или отключите параметр "Курсор, подсказки и контекстное меню".
  3. Нажмите "Применить" или "ОК".
Ввод команды: НАСТРОЙКА


Для задания пути, используемого для всех относительных гиперссылок в чертеже (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Использование гиперссылок для доступа к файлам и веб-страницам
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Для задания пути, используемого для всех относительных гиперссылок в чертеже

  1. Выберите следующие элементы: вкладка "Инструменты" [image] панель "Утилиты" [image] Свойства чертежа. В командной строке введите "свойстварис".
  2. На вкладке "Документ" введите относительный путь в поле "База гиперссылки".
  3. Нажмите "ОК".
Ввод команды: СВОЙСТВАРИС


Для создания относительной гиперссылки (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Гиперссылки для создания сообщений электронной почты
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Для создания относительной гиперссылки

  1. Выберите следующие элементы: вкладка "Блоки и ссылки" [image] панель "Данные" [image] Гиперссылка.В командной строке введите "гиперссылка".
  2. В области рисования выберите один или несколько объектов.
  3. Введите имя файла, подключаемого к гиперссылке, в поле "Введите имя файла или веб-страницы".

    Не следует вводить информацию о пути, а только имя файла, иначе будет создана абсолютная гиперссылка.

  4. Нажмите "ОК".
Ввод команды: ГИПЕРССЫЛКА


Использование гиперссылок для доступа к файлам и веб-страницам (Краткий справочник)

Основные понятия использования гиперссылок в чертежах
Использование гиперссылок для доступа к файлам и веб-страницам
Гиперссылки для создания сообщений электронной почты
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для доступа к файлам и веб-страницам >
Использование гиперссылок для доступа к файлам и веб-страницам
Понятие Процедура Краткий справочник

Команды

УРЛСВЯЗАТЬ

Создание гиперссылок для объектов или областей чертежа

УРЛРАЗОРВАТЬ

Удаление гиперссылок в чертеже

СВОЙСТВАРИС

Задание и просмотр свойств текущего чертежа

УРЛПЕРЕЙТИ

Открытие файла или веб-страницы, ассоциированной с гиперссылкой, прикрепленной к объекту

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

ГИПЕРСВОЙСТВА

Управление отображением курсора, подсказок и контекстного меню для гиперссылок

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

Системные переменные

HYPERLINKBASE

Указание пути, используемого для всех относительных гиперссылок в чертеже

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

Утилиты

Нет

Ключевые слова для команд

Нет


Гиперссылки для создания сообщений электронной почты (Понятие)

Использование гиперссылок для доступа к файлам и веб-страницам
Добавление гиперссылок в чертеж
Гиперссылки в блоках
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж >
Гиперссылки для создания сообщений электронной почты
Понятие Процедура Краткий справочник

Обычно гиперссылки используются для подключения к графическим объектам логически связанных документов. Но в некоторых случаях бывает необходимо, чтобы при выборе гиперссылки создавалось сообщение электронной почты.

В качестве примера можно рассмотреть проект, над которым работают несколько разработчиков, каждый из которых имеет возможность обновлять различные компоненты чертежа. В этом случае разработчики могут связывать новые помещаемые в чертеж компоненты с гиперссылками, в которых указываются их адреса электронной почты. Это позволяет легко идентифицировать автора какого-то компонента чертежа и послать ему по электронной почте сообщение с вопросами по поводу этого компонента.


Для создания гиперссылки на сообщение электронной почты (Процедура)

Использование гиперссылок для доступа к файлам и веб-страницам
На уровень вверх ..
Гиперссылки в блоках
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Гиперссылки для создания сообщений электронной почты >
Гиперссылки для создания сообщений электронной почты
Понятие Процедура Краткий справочник

Для создания гиперссылки на сообщение электронной почты

  1. В области рисования выберите один или несколько объектов.
  2. Выберите следующие элементы: вкладка "Блоки и ссылки" [image] панель "Данные" [image] Гиперссылка.В командной строке введите "гиперссылка".
  3. В диалоговом окне "Вставка гиперссылки" нажмите "Адрес электронной почты".
  4. Введите адрес получателя в поле "Адрес электронной почты".
  5. (Дополнительно) Введите тему сообщения в поле "Тема".
  6. Нажмите "ОК".

    После нажатия на гиперссылке происходит создание нового сообщения в установленном по умолчанию клиенте электронной почты. При формировании сообщения используются заданный адрес электронной почты и тема, если последняя была определена при создании гиперссылки. Затем можно ввести текст сообщения и отправить его получателю.

Ввод команды: ГИПЕРССЫЛКА


Гиперссылки для создания сообщений электронной почты (Краткий справочник)

Использование гиперссылок для доступа к файлам и веб-страницам
Гиперссылки для создания сообщений электронной почты
Гиперссылки в блоках
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Гиперссылки для создания сообщений электронной почты >
Гиперссылки для создания сообщений электронной почты
Понятие Процедура Краткий справочник

Команды

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

Системные переменные

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

Утилиты

Нет

Ключевые слова для команд

Нет


Гиперссылки в блоках (Понятие)

Гиперссылки для создания сообщений электронной почты
Добавление гиперссылок в чертеж
Использование гиперссылок для создания новых чертежей
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж >
Гиперссылки в блоках
Понятие Процедура Краткий справочник

Гиперссылки можно подключать к блокам и даже к объектам, заключенным в блоки. Все относительные гиперссылки, заданные для объектов блока, после вставки начинают опираться на базовый путь текущего чертежа.

Если элемент блока, выбранный для перехода, и сам блок содержат различные гиперссылки, обе они перечисляются в контекстном меню. Выбрав соответствующий пункт меню, можно перейти по нужной ссылке; однако, редактирование и удаление может производиться только для гиперссылок верхнего уровня.

Пусть, например, в чертеже имеется блок, содержащий отрезок и круг. К отрезку подключена гиперссылка по имени отрезок, а к кругу - гиперссылка по имени круг. Вхождение блока также имеет гиперссылку (назначенную уже после его вставки в чертеж); ее имя блок. Тогда пользователь, указывая курсором элемент блока, получает возможность выбора ссылки для перехода: либо связанной с вложенным элементом, либо со всем блоком. Например, при выборе элемента блока линии можно перейти по гиперссылке линия или блок. При выборе элемента блока окружности можно перейти по гиперссылке окружность или блок. В обоих случаях операции редактирования и удаления разрешены только для гиперссылки блок.

Чтобы выполнить редактирование или удаление гиперссылок вложенных элементов, следует предварительно расчленить блок или использовать команду ССЫЛРЕД.


Для открытия файла, на который указывает гиперссылка внутри блока (Процедура)

Гиперссылки для создания сообщений электронной почты
На уровень вверх ..
Использование гиперссылок для создания новых чертежей
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Гиперссылки в блоках >
Гиперссылки в блоках
Понятие Процедура Краткий справочник

Для открытия файла, на который указывает гиперссылка внутри блока

  1. В области рисования выберите блок, имеющий гиперссылки.
  2. Используйте один из следующих методов для перехода по ссылке:
    • Удерживайте в нажатом состоянии клавишу CTRL и нажмите кнопку мыши.
    • Нажмите правую кнопку мыши. Выберите "Гиперссылка". Выберите имя нужной гиперссылки. Каждая гиперссылка имеет либо описание, либо полный URL до файла, на который она указывает.


Гиперссылки в блоках (Краткий справочник)

Гиперссылки для создания сообщений электронной почты
Гиперссылки в блоках
Использование гиперссылок для создания новых чертежей
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Гиперссылки в блоках >
Гиперссылки в блоках
Понятие Процедура Краткий справочник

Команды

УРЛСВЯЗАТЬ

Создание гиперссылок для объектов или областей чертежа

УРЛРАЗОРВАТЬ

Удаление гиперссылок в чертеже

УРЛПЕРЕЙТИ

Открытие файла или веб-страницы, ассоциированной с гиперссылкой, прикрепленной к объекту

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование гиперссылок для создания новых чертежей (Понятие)

Гиперссылки в блоках
Добавление гиперссылок в чертеж
Работа с чертежами в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж >
Использование гиперссылок для создания новых чертежей
Понятие Процедура Краткий справочник

При активизации гиперссылки, указывающей на DWT-файл шаблона чертежа, программа не открывает файл шаблона, а создает вместо этого новый чертеж, использующий указанный шаблон как основу.

Это позволяет держать в Интернете набор стандартных шаблонов, не беспокоясь об их несанкционированной модификации пользователями. Файлы шаблонов, на которые имеются гиперссылки, открывают новый чертеж, поэтому нет опасности случайной перезаписи исходного шаблона.


Для создания нового чертежа на основе DWT-файла гиперссылки (Процедура)

Гиперссылки в блоках
На уровень вверх ..
Работа с чертежами в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для создания новых чертежей >
Использование гиперссылок для создания новых чертежей
Понятие Процедура Краткий справочник

Для создания нового чертежа на основе DWT-файла гиперссылки

  1. В области рисования выберите объект, имеющий гиперссылку на DWT-файл.
  2. Используйте один из следующих методов для перехода по ссылке:
    • Удерживайте в нажатом состоянии клавишу CTRL и нажмите кнопку мыши.
    • Нажмите правую кнопку мыши. Выберите "Гиперссылка". Выберите имя нужной гиперссылки. Каждая гиперссылка имеет либо описание, либо полный URL до файла, на который она указывает.

    Открывается новый чертеж, созданный на основе DWT-файла гиперссылки.

    ПримечаниеЕсли пользователь отключил отображение курсора гиперссылки, то параметры гиперссылки становятся недоступными в контекстном меню. В диалоговом окне "Параметры" на вкладке "Пользовательские" можно включить курсор гиперссылки, всплывающие подсказки и контекстное меню.


Использование гиперссылок для создания новых чертежей (Краткий справочник)

Гиперссылки в блоках
Использование гиперссылок для создания новых чертежей
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Добавление гиперссылок в чертеж > Использование гиперссылок для создания новых чертежей >
Использование гиперссылок для создания новых чертежей
Понятие Процедура Краткий справочник

Команды

УРЛПЕРЕЙТИ

Открытие файла или веб-страницы, ассоциированной с гиперссылкой, прикрепленной к объекту

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

Системные переменные

PICKFIRST

Определение момента выбора объектов: до вызова команды (предварительный выбор) или после

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с чертежами в Интернете

Использование гиперссылок для создания новых чертежей
Совместная работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете >
Работа с чертежами в Интернете
Понятие Процедура

Имеется возможность открывать чертежи с сетевых серверов, сохранять их там, вставлять блоки путем перетаскивания чертежей с сайтов, вставлять в чертежи гиперссылки, а также создавать комплекты, объединяющие в себе чертежи и все связанные с ними файлы.

Темы в этом разделе

  • Открытие и сохранение файлов в Интернете

    Команды, осуществляющие файловый ввод-вывод, распознают в заданных путях к файлам элементы Интернет-адресов (Uniform Resource Locator, URL).

  • Совместное использование файлов пользователями из разных стран

    Программные продукты на базе AutoCAD 2007 и более поздних версий используют для чертежей и связанных с ними файлов стандарт Unicode. Благодаря этому при сохранении и открытии файлов чертежей обеспечивается точность отображения международных символов и целостность данных.

  • Доступ Buzzsaw для совместной работы

    Приложение Autodesk® Buzzsaw® позволяет выполнять сохранение, управление и совместное использование документов, расположенных на веб-узле Buzzsaw.

  • Работа с внешними ссылками в Интернете

    В чертежи, хранящиеся на локальном диске компьютера, можно вставлять внешние ссылки из Интернета.

  • Вставка содержимого с веб-страниц
  • Формирование комплектов файлов


Работа с чертежами в Интернете (Процедура)

Использование гиперссылок для создания новых чертежей
Работа с чертежами в Интернете
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете >
Работа с чертежами в Интернете
Понятие Процедура

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с выбором в веб-папке

Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL)

Для сохранения чертежа AutoCAD в Интернете на FTP-сервере

Для сохранения файла AutoCAD в Интернете с выбором в веб-папке

Для задания начальной страницы диалогового окна "Поиск в Web"

Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web"

Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web"

Для доступа к веб-сайту Buzzsaw в первый раз

Для доступа к веб-сайту Buzzsaw

Для добавления ярлыка папки Buzzsaw

Для переименования ярлыка папки Buzzsaw

Для изменения ярлыка папки Buzzsaw

Для удаления ярлыка папки Buzzsaw

Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw

Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw

Для отправки набора комплектов на веб-узел Buzzsaw

Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок"

Для публикации файла на веб-сайте Buzzsaw

Для публикации подшивки на веб-сайте Buzzsaw

Для вставки в чертеж внешней ссылки из Интернета

Для формирования комплекта файлов в заданной папке

Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле

Для создания комплекта файлов на основе подшивки

Для распаковки самораспаковывающегося комплекта файлов


Открытие и сохранение файлов в Интернете (Понятие)

Работа с чертежами в Интернете
Работа с чертежами в Интернете
Совместное использование файлов пользователями из разных стран
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Команды, осуществляющие файловый ввод-вывод, распознают в заданных путях к файлам элементы Интернет-адресов (Uniform Resource Locator, URL).

Работая в AutoCAD, можно открывать и сохранять файлы в сети Интернет. Команды AutoCAD, осуществляющие файловый ввод-вывод (ОТКРЫТЬ, ЭКСПОРТ и так далее) распознают любой правильно сформулированный URL-путь к файлу AutoCAD. Чертеж, загружаемый из Интернета, копируется на компьютер и открывается в окне AutoCAD. Выполнив редактирование, пользователь может либо сохранить файл на своем локальном диске, либо вернуть его в Интернет (в последнем случае необходимо наличие прав доступа на запись в сетевую папку).

Если известен полный адрес открываемого файла, его вводят в диалоговом окне "Выбор файла". Кроме того, файл можно выбрать на FTP-сервере, заданном в качестве хранилищ в диалоговом окне «Выбор файла», разыскать в Интернете с помощью диалогового окна «Поиск в Web» или найти в ресурсах службы размещения проектов Autodesk® Buzzsaw®, используя значок Buzzsaw в диалоговом окне «Выбор файла» или «Сохранение чертежа».

Диалоговое окно "Поиск в Web"

Диалоговое окно "Поиск в Web" предназначено для перемещения по Интернету в поисках папки, где открывается или сохраняется файл. Пользователь может указать, какая веб-страница должна загружаться по умолчанию (т.е. быть начальной) при открытии этого окна. Применение окна "Поиск в Web" оправдано в случаях, когда неизвестен точный адрес файла или длина адреса слишком велика.


Открытие и сохранение файлов в Интернете (Процедура)

Работа с чертежами в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

Для открытия файла AutoCAD из Интернета с выбором в веб-папке

Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL)

Для сохранения чертежа AutoCAD в Интернете на FTP-сервере

Для сохранения файла AutoCAD в Интернете с выбором в веб-папке

Для задания начальной страницы диалогового окна "Поиск в Web"

Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web"

Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web"


Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL) (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

  1. Выберите меню Файл [image] Открыть.В командной строке введите "открыть".
  2. В диалоговом окне "Выбор файла" введите URL-адрес в поле "Имя файла". Нажмите "Открыть".

    Адрес должен включать в себя признак протокола передачи гипертекстов или файлов (например, http:// или ftp://), а также расширение (например, .dwg или .dwt) файла, который надо открыть.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL) (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для открытия файла AutoCAD из Интернета с заданием сетевого адреса (URL)

  1. Выберите меню Файл [image] Открыть.В командной строке введите "открыть".
  2. В диалоговом окне "Выбор файла" выберите "Сервис" [image] "Добавление/изменение FTP-адресов".
  3. В диалоговом окне "Добавление/редактирование FTP-адресов" в разделе "Адрес FTP-сервера" введите адрес для FTP-сервера (например, ftp.autodesk.com).
  4. В разделе "Способ входа" выберите один из следующих вариантов.
    • Анонимно. Вход на FTP-сервер без указания имени пользователя. Если FTP-сервер не допускает такого способа входа, необходимо перевести переключатель в положение "С именем" и ввести имя.
    • С именем. Вход на FTP-сервер с указанием имени пользователя.
  5. Введите пароль, если это требуется FTP-сервером.
  6. Нажмите "Добавить". Нажмите "ОК".
  7. В списке хранилищ информации диалогового окна "Выбор файла" нажмите "FTP".
  8. Дважды нажмите на обозначении нужного FTP-сервера, а затем выберите файл.
  9. Нажмите "Открыть".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для открытия файла AutoCAD из Интернета с выбором в веб-папке (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для открытия файла AutoCAD из Интернета с выбором в веб-папке

  1. Выберите меню Файл [image] Открыть.В командной строке введите "открыть".
  2. В диалоговом окне "Выбор файла" в разделе "Поиск" выберите "Веб-папки" (или "Сетевое окружение" в зависимости от версии системы Microsoft® Windows® ).
  3. Дважды щелкнуть на обозначении нужной Web-папки, а затем выбрать файл.

    С помощью Проводника Windows можно создать новые веб-папки. Дополнительную информацию о веб-папках можно получить у администратора или в справочной системе по Проводнику Windows.

  4. Нажмите "Открыть".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL) (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для сохранения файла AutoCAD в Интернете с заданием сетевого адреса (URL)

  1. Выберите меню Файл [image] Сохранить как.В командной строке введите "сохранитькак".
  2. Введите сетевой адрес (URL) в поле "Имя файла".

    Адрес должен включать в себя признак протокола передачи гипертекстов или файлов (например, ftp:// или http://), а также расширение (например, .dwg или .dwt) файла, который надо сохранить. Сохранение файлов в Интернете возможно только при наличии соответствующих прав доступа к заданному адресу.

  3. Выберите формат в списке "Тип файла". Нажмите кнопку "Сохранить".
Ввод команды: СОХРАНИТЬ


Для сохранения чертежа AutoCAD в Интернете на FTP-сервере (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для сохранения чертежа AutoCAD в Интернете на FTP-сервере

  1. Выберите меню Файл [image] Сохранить как.В командной строке введите "сохранитькак".
  2. В списке хранилищ информации диалогового окна "Сохранение чертежа" нажмите "FTP".
  3. Если FTP-сервер еще не добавлен к доступным FTP-адресам, выберите "Инструменты" [image] "Добавление/изменение FTP-адресов" в соответствии с инструкциями в разделе Открытие файла AutoCAD из сети Интернет путем обзора FTP-сервера.
  4. Дважды нажмите на обозначении нужного FTP-сервера, а затем выберите файл.
  5. Выберите формат в списке "Тип файла". Нажмите кнопку "Сохранить".
Ввод команды: СОХРАНИТЬ


Для сохранения файла AutoCAD в Интернете с выбором в веб-папке (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для сохранения файла AutoCAD в Интернете с выбором в веб-папке

  1. Выберите меню Файл [image] Сохранить как.В командной строке введите "сохранитькак".
  2. В диалоговом окне "Выбор файла" в разделе "Поиск" выберите "Веб-папки" (или "Сетевое окружение", в зависимости от версии системы Windows).
  3. Дважды нажмите на обозначении нужной веб-папки.

    С помощью Проводника Windows можно создать новые веб-папки. Дополнительную информацию о веб-папках можно получить у администратора или в справочной системе по Проводнику Windows.

  4. Введите имя файла и выберите формат из списка "Тип файла".
  5. Нажмите кнопку "Сохранить".

    Сохранение файлов в Интернете возможно только при наличии соответствующих прав доступа к заданному адресу.

Ввод команды: СОХРАНИТЬ


Для задания начальной страницы диалогового окна "Поиск в Web" (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для задания начальной страницы диалогового окна "Поиск в Web"

  1. Выберите меню Сервис [image] Параметры.В командной строке введите "настройка".
  2. На вкладке "Файлы" нажмите кнопку мыши на значке "плюс" рядом с элементом "Имена файлов справок и других файлов".
  3. Выберите параметр "Начальный узел Интернета". Нажмите кнопку "Обзор".
  4. В диалоговом окне "Выбор файла" выполните одну из следующих операций:
    • Введите URL-адрес для веб-сайта. Нажмите "Открыть".
    • Нажмите кнопку поиска в Интернете и введите Интернет-адрес в поле "Искать в".
  5. Нажмите "ОК".
Ввод команды: НАСТРОЙКА


Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web" (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Открытие и сохранение файлов в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для открытия файла AutoCAD из Интернета с помощью диалогового окна "Поиск в Web"

  1. Выберите меню Файл [image] Открыть.В командной строке введите "открыть".
  2. Нажмите кнопку поиска в Интернете.

    В большинстве случаев для получения доступа к файлам в Интернете требуется указание имени пользователя и пароля. AutoCAD предлагает ввести эту информацию.

  3. В диалоговом окне "Поиск в Web" выполните одну из следующих операций:
    • Нажмите гиперссылку в отображаемой странице.
    • В поле "Искать в" введите полный адрес или его начальную часть; затем нажмите клавишу ENTER.
  4. Повторяйте действия пункта 3 до тех пор, пока не будет найден нужный файл.
  5. Нажмите "Открыть".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web" (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Для сохранения чертежа AutoCAD в Интернете с помощью диалогового окна "Поиск в Web"

  1. Выберите меню Файл [image] Сохранить как.В командной строке введите "сохранитькак".
  2. Нажмите кнопку поиска в Интернете.

    В большинстве случаев для получения доступа к файлам в Интернете требуется указание имени пользователя и пароля. AutoCAD предлагает ввести эту информацию.

  3. В диалоговом окне "Поиск в Web" выполните одну из следующих операций:
    • Нажмите гиперссылку в отображаемой странице.
    • В поле "Искать в" введите полный адрес или его начальную часть; затем нажмите клавишу ENTER.
  4. Повторяйте действия пункта 3 до тех пор, пока не будет найдена нужная папка для сохранения файла.
  5. Нажмите кнопку "Сохранить".
Ввод команды: СОХРАНИТЬКАК


Открытие и сохранение файлов в Интернете (Краткий справочник)

Использование гиперссылок для создания новых чертежей
Открытие и сохранение файлов в Интернете
Совместное использование файлов пользователями из разных стран
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Открытие и сохранение файлов в Интернете >
Открытие и сохранение файлов в Интернете
Понятие Процедура Краткий справочник

Команды

ЗАГПРИЛ

Загрузка и выгрузка приложений; задание набора приложений для автозагрузки

ЭКСПОРТ

Сохранение объектов в файлах различных форматов

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

ОТКРЫТЬ

Открытие существующего файла чертежа

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Совместное использование файлов пользователями из разных стран (Понятие)

Открытие и сохранение файлов в Интернете
Работа с чертежами в Интернете
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете >
Совместное использование файлов пользователями из разных стран
Понятие Краткий справочник

Программные продукты на базе AutoCAD 2007 и более поздних версий используют для чертежей и связанных с ними файлов стандарт Unicode. Благодаря этому при сохранении и открытии файлов чертежей обеспечивается точность отображения международных символов и целостность данных.

ПримечаниеAutoCAD 2006, AutoCAD LT 2006 и предыдущие версии не поддерживали систему Unicode. В случае использования чертежей в предыдущих версиях, не поддерживающих систему Unicode, для обеспечения совместимости используйте символы ASCII при сохранении файлов, вставке внешних ссылок и указании путей к папкам.

Основные сведения о стандарте Unicode

Операционная система компьютера обрабатывает все символы в числовом виде, присвоив каждому символу некоторое число. В прошлом использовались различные системы числового кодирования, однако, эти системы зачастую вступали в конфликт. В результате операционные системы и приложения использовали кодовые страницы с собственным набором символов и нумерацией, которые менялись в зависимости от страны или региона.

Для упрощения международной совместимости программ большинством производителей был принят стандарт Unicode, разработанный и поддерживаемый консорциумом Unicode.

Применение в чертежах

Допускается использование характерных для данного языка символов в именах файлов и текстах внутри чертежей и связанных с ними файлах. Основные примеры применения:

  • Имена файлов чертежей
  • Имена путей к папке
  • Файлы данных подшивки
  • Именованные объекты, например, слои и блоки в чертеже
  • Типы линий и имена файлов образцов штриховки, а также их содержимое
  • Тексты, используемые в примечаниях и размерах чертежа
  • Файлы пометок DWF или DWFx

Это означает, что чертежи можно открывать, изменять и сохранять, не беспокоясь о правильности отображения характерных символов данного языка. Единственное требование - до начала работы с файлом должен быть установлен пакет соответствующего языка.

При сохранении текстовых файлов, например, файлов типа линии (LIN), образцов штриховки (PAT) и пакетных файлов (SCR) в приложениях типа редактора Блокнот рекомендуется указать кодировку Unicode внизу диалогового окна "Сохранить как" для обеспечения совместимости файлов.

Ограничения

Большинство международных проектов могут быть выполнены в данной программной среде. Однако некоторые типы файлов и функций не поддерживаются применительно к странам и регионам, использующим разные кодовые страницы Windows. К этим функциям относятся:

  • Формирование комплекта
  • Совместимость по файлам и данным, требующим передачи лицензии "туда и обратно" для продуктов, не поддерживающих стандарт Unicode
  • Блокирование атрибутов
  • Файлы Visual LISP
ПримечаниеПри этом допускается формирование наборов комплектов для передачи в страны и регионы, использующие одну и ту же кодовую страницу.


Совместное использование файлов пользователями из разных стран (Краткий справочник)

Открытие и сохранение файлов в Интернете
Совместное использование файлов пользователями из разных стран
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Совместное использование файлов пользователями из разных стран >
Совместное использование файлов пользователями из разных стран
Понятие Краткий справочник

Команды

ОТКРЫТЬ

Открытие существующего файла чертежа

СОХРАНИТЬ

Сохранение чертежа под текущим или заданным именем

СОХРАН В

Сохранение копии текущего чертежа под новым именем

Системные переменные

TEXTOUTPUTFILEFORMAT

Служит для хранения параметров Unicode для печати и текстовых файлов журналов

Утилиты

Нет

Ключевые слова для команд

Нет


Доступ Buzzsaw для совместной работы (Понятие)

Совместное использование файлов пользователями из разных стран
Работа с чертежами в Интернете
Работа с внешними ссылками в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Приложение Autodesk® Buzzsaw® позволяет выполнять сохранение, управление и совместное использование документов, расположенных на веб-узле Buzzsaw.

Buzzsaw является безопасной интерактивной службой совместной работы над проектом, с помощью которой различные пользователи могут размещать файлы на основном веб-сайте, а также загружать с него файлы. Можно сохранять файлы, отправлять наборы комплектов и публиковать листы в Buzzsaw.

Бесплатную 30-дневную ознакомительную версию можно получить при доступе к Buzzsaw или на веб-узле Autodesk. Подписка Buzzsaw включает лицензии пользователя для доступа к Buzzsaw. Программное обеспечение Buzzsaw загружается автоматически, когда вы приглашаете на веб-узел консультантов и подрядчиков.

Подготовка к использованию Buzzsaw

Для использования программного обеспечения Buzzsaw необходимо иметь учетную запись для управления проектами или получить доступ к веб-сайту Buzzsaw подписчика. Подписчик предоставит URL-адрес для программы Buzzsaw, имя пользователя и пароль для входа в систему, доступа к файлам и их отправке.

Использование Buzzsaw

Доступ к программе Buzzsaw можно получить из разных стандартных диалоговых окон выбора файлов (например, "Создать" или "Открыть"). Значок Buzzsaw отображается в списке хранилищ информации для обеспечения быстрого доступа.

Поддержка сервисов Autodesk Buzzsaw обеспечивает следующие функции:

  • Поддержка "Диспетчером подшивок". Хранит информацию, необходимую для публикации подшивок и наборов комплектов. Подробнее о "Диспетчере подшивок" см. раздел Работа с листами в подшивке.
  • Поддержка модулем публикаций. Публикация файлов DWF или DWFx непосредственно в папки Autodesk Buzzsaw. Подробнее о публикации на Autodesk Buzzsaw см. раздел Настройка параметров публикации.
  • Поддержка формирования комплектов. Можно отправить набор комплектов файлов DWG на веб-узел Buzzsaw, а также создать и отправить набор комплектов с помощью Диспетчера подшивок.

Если для совместной работы над проектом планируется использовать Buzzsaw, установите несколько ярлыков, чтобы можно было быстро перемещаться по часто используемым веб-сайтам. Используя значок Buzzsaw в списке хранилищ информации, можно выбрать ярлык для существующего веб-сайта совместной работы над проектом или создать новый ярлык с помощью параметра "Добавить ярлык папки Buzzsaw".

Для отображения контекстного меню, содержащего пункты добавления, управления и удаления папок Autodesk Buzzsaw, необходимо в диалоговом окне, поддерживающем Buzzsaw, щелкнуть правой кнопкой мыши на области "Размещение". Изменения папок сохраняются в реестре.


Доступ Buzzsaw для совместной работы (Процедура)

Открытие и сохранение файлов в Интернете
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для доступа к веб-сайту Buzzsaw в первый раз

Для доступа к веб-сайту Buzzsaw

Для добавления ярлыка папки Buzzsaw

Для переименования ярлыка папки Buzzsaw

Для изменения ярлыка папки Buzzsaw

Для удаления ярлыка папки Buzzsaw

Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw

Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw

Для отправки набора комплектов на веб-узел Buzzsaw

Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок"

Для публикации файла на веб-сайте Buzzsaw

Для публикации подшивки на веб-сайте Buzzsaw


Для доступа к веб-сайту Buzzsaw в первый раз (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для доступа к веб-сайту Buzzsaw в первый раз

  1. В диалоговом окне поиска файла, например в диалоговом окне "Выбор файла", в списке хранилищ информации нажмите значок Buzzsaw.
    ПримечаниеЕсли Buzzsaw выбирается впервые, запустится Internet Explorer, и отобразится веб-страница Autodesk Buzzsaw.

    Параметр "Ярлыки папки Buzzsaw" отобразится в окне "Искать в".

  2. Дважды нажмите левую кнопку мыши на параметре "Добавить ярлык папки Buzzsaw".
  3. В диалоговом окне "Вход на веб-узел Buzzsaw" в разделе "Сайт Buzzsaw" введите имя папки для веб-сайта Buzzsaw, к которому требуется получить доступ.
  4. В разделе "ИмяДляВхода", "Имя пользователя Buzzsaw" введите имя для входа.

    Это имя предоставляется лицом, обеспечивающим доступ к веб-сайту Buzzsaw.

  5. В окне "Пароль" введите пароль. Нажмите "ОК".

    AutoCAD проверяет, имеет ли пользователь доступ к указанному веб-сайту. В случае предоставления доступа отобразится окно "Создание ярлыка папки Buzzsaw". Если доступ не предоставлен, появится сообщение об ошибке.

    ПримечаниеУстановите флажок "Сохранить имя пользователя и пароль", если требуется сохранить их для использования в будущем.
  6. В диалоговом окне "Создание ярлыка папки Buzzsaw" в разделе "Выберите папку Buzzsaw, проект или набор документов" нажмите кнопку "Обзор".
  7. В диалоговом окне "Выбор папки Buzzsaw" перейдите к проекту или папке, к которым необходимо получить доступ. Нажмите "ОК".

    Путь будет отображаться в окне "Выберите папку Buzzsaw, проект или набор документов".

  8. В разделе "Введите имя для этого ярлыка папки Buzzsaw" введите имя для ярлыка. Нажмите "ОК".

    Отобразится диалоговое окно выбора файла, и будет создан ярлык. Для доступа к папке Buzzsaw, обозначенной ярлыком, можно дважды нажать на ярлыке. Пользователь может создать необходимое количество ярлыков Buzzsaw.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для доступа к веб-сайту Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для доступа к веб-сайту Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Дважды нажмите левую кнопку мыши на ярлыке Buzzsaw.

    Если пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для добавления ярлыка папки Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для добавления ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Выберите "Добавить ярлык папки Buzzsaw".
  3. В диалоговом окне "Вход на веб-узел Buzzsaw" в разделе "Веб-узел Buzzsaw" выберите веб-узел Buzzsaw, к которому требуется получить доступ.
  4. При необходимости в разделе "ИмяДляВхода" в поле "Имя пользователя Buzzsaw" введите имя для входа.

    (Имя пользователя предоставляется лицом, обеспечивающим доступ к веб-сайту Buzzsaw.)

  5. В разделе "Вход" в поле "Пароль" введите пароль. Нажмите "ОК".
    ПримечаниеУстановите флажок "Сохранить имя пользователя и пароль", если требуется сохранить их на этом компьютере для использования в будущем.
  6. В диалоговом окне "Создание ярлыка папки Buzzsaw" в разделе "Выберите папку Buzzsaw, проект или набор документов" нажмите кнопку "Обзор" для перехода к проекту или папке.
  7. В дереве диалогового окна "Выбор папки Buzzsaw" нажмите имя веб-сайта для просмотра содержимого папки и перехода к проекту или папке. Нажмите "ОК".

    Путь отобразится в диалоговом окне "Создание ярлыка папки Buzzsaw" в разделе "Выберите папку Buzzsaw, проект или набор документов".

  8. В разделе "Введите имя для этого ярлыка папки Buzzsaw" введите имя. Нажмите "ОК".

    Это имя папки будет добавлено в список веб-сайта в диалоговом окне выбора файла.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для переименования ярлыка папки Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для переименования ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите "Управление ярлыками папок Buzzsaw".
  3. В диалоговом окне "Ярлыки папки Buzzsaw" выберите ярлык. Выберите "Переименовать".
  4. Введите новое имя для ярлыка папки Buzzsaw. Нажмите кнопку "Закрыть".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для изменения ярлыка папки Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для изменения ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите "Управление ярлыками папок Buzzsaw".
  3. В диалоговом окне "Ярлыки папки Buzzsaw" выберите ярлык. Нажмите кнопку "Редактирование".
  4. В диалоговом окне "Вход на веб-узел Buzzsaw" выполните вход на веб-узел Buzzsaw.
  5. В диалоговом окне "Изменение ярлыка местоположения Buzzsaw" измените папку или имя ярлыка.
  6. Нажмите "ОК". Нажмите кнопку "Закрыть".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для удаления ярлыка папки Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для удаления ярлыка папки Buzzsaw

  1. В диалоговом окне выбора файла, поддерживающем Buzzsaw, в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  2. Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите "Управление ярлыками папок Buzzsaw".
  3. В диалоговом окне "Ярлыки папки Buzzsaw" выберите ярлык. Нажмите кнопку "Удалить".

    Выбранный ярлык будет удален.

  4. Нажмите кнопку "Закрыть".
    Контекстное меню:Нажмите правую кнопку мыши на ярлыке Buzzsaw. Нажмите кнопку "Удалить".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для сохранения файла, открытого на веб-сайте Buzzsaw, на другом веб-сайте Buzzsaw

  1. Выберите меню Файл [image] Сохранить.В командной строке введите "бсохранить".
  2. В диалоговом окне "Сохранение чертежа" в разделе "Имя файла" отобразится полный путь к файлу чертежа. Нажмите кнопку "Сохранить".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для сохранения файла, открытого в другой папке, на веб-сайте Buzzsaw

  1. Выберите меню Файл [image] Сохранить как.В командной строке введите "сохранитькак".
  2. В диалоговом окне "Сохранение чертежа" в списке хранилищ информации нажмите значок Buzzsaw.
  3. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.
    ПримечаниеЕсли пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.
  4. Введите имя файла и нажмите "Сохранить".
Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для отправки набора комплектов на веб-узел Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для отправки набора комплектов на веб-узел Buzzsaw

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Сформировать комплект. В командной строке введите "формкомплект".
  2. В диалоговом окне "Формирование комплекта файлов" нажмите "OK".
  3. В диалоговом окне "Выбор ZIP-файла" в списке хранилищ информации нажмите значок Buzzsaw.

    Параметр "Ярлыки папки Buzzsaw" отобразится в окне "Сохранить в". Существующие ярлыки Buzzsaw отобразятся в столбце "Сайт".

  4. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.
    ПримечаниеЕсли пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.
  5. Нажмите кнопку "Сохранить".

    Создан комплект файлов.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок" (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для отправки набора комплектов Buzzsaw из "Диспетчера подшивок"

  1. Нажмите правую кнопку мыши в "Диспетчере подшивок" на вкладке "Список листов". Нажмите "Сформировать комплект".

    Программа собирает информацию для создания комплекта файлов.

  2. В диалоговом окне "Формирование комплекта файлов" нажмите "OK".
  3. В диалоговом окне "Выбор ZIP-файла" в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  4. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.
    ПримечаниеЕсли пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.
  5. Нажмите кнопку "Сохранить".

    Создан комплект файлов.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для публикации файла на веб-сайте Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Доступ Buzzsaw для совместной работы
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для публикации файла на веб-сайте Buzzsaw

  1. В окне чертежа выберите меню Файл [image] Опубликовать.В командной строке окна чертежа введите "публ".
  2. В диалоговом окне "Публикация" в разделе "Вывод при публикации" выберите один из следующих параметров и нажмите "Параметры публикации".
    • На плоттер, заданный в параметрах
    • Формат DWF (файл DWF или файл DWFx)
  3. В диалоговом окне "Параметры публикации" в разделе "Папка для вывода по умолчанию" нажмите "Размещение". Нажмите кнопку [...].
  4. В диалоговом окне "Выбор папки для сформированных чертежей" в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  5. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.
    ПримечаниеЕсли пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.
  6. Нажмите "Выбрать".
  7. В диалоговом окне "Параметры публикации" нажмите "OK".
  8. В диалоговом окне "Публикация" нажмите "Опубликовать"
  9. В диалоговом окне "Указать DWF-файл" нажмите "Выбрать".

    Запустится операция публикации. В окне состояния отобразится сообщение о завершении публикации.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Для публикации подшивки на веб-сайте Buzzsaw (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Работа с внешними ссылками в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Для публикации подшивки на веб-сайте Buzzsaw

  1. В диспетчере подшивок на вкладке "Список листов" щелкните на стрелке рядом с элементом "Публикация". Выберите диалоговое окно "Публикация".
  2. В диалоговом окне "Публикация" выберите "Параметры публикации подшивки".
  3. В диалоговом окне "Параметры публикации подшивки" в разделе "Папка для вывода по умолчанию" нажмите "Размещение". Нажмите кнопку [...].
  4. В диалоговом окне "Выбор папки для сформированных чертежей" в списке хранилищ информации нажмите значок Buzzsaw.

    В окне "Искать в" отобразится параметр "Ярлыки папки Buzzsaw" и все настроенные ярлыки Buzzsaw.

  5. Дважды нажмите левую кнопку мыши на существующем ярлыке или создайте новый ярлык.
    ПримечаниеЕсли пользователь не выполнил вход на веб-узел, отобразится диалоговое окно "Вход на веб-узел Buzzsaw". После регистрации на веб-сайте будет выполнен переход к папке, обозначенной этим ярлыком.
  6. Нажмите "Выбрать".
  7. В диалоговом окне "Параметры публикации подшивки" нажмите "OK".
  8. В диалоговом окне "Публикация" нажмите "Опубликовать"
  9. В диалоговом окне "Указать DWF-файл" нажмите "Выбрать".

    Запустится операция публикации. В окне состояния отобразится сообщение о завершении публикации.

Панель:Стандартная
Ввод команды: ОТКРЫТЬ


Доступ Buzzsaw для совместной работы (Краткий справочник)

Совместное использование файлов пользователями из разных стран
Доступ Buzzsaw для совместной работы
Работа с внешними ссылками в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Доступ Buzzsaw для совместной работы >
Доступ Buzzsaw для совместной работы
Понятие Процедура Краткий справочник

Команды

ОТКРЫТЬ

Открытие существующего файла чертежа

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Работа с внешними ссылками в Интернете (Понятие)

Доступ Buzzsaw для совместной работы
Работа с чертежами в Интернете
Вставка содержимого с веб-страниц
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете >
Работа с внешними ссылками в Интернете
Понятие Процедура Краткий справочник

В чертежи, хранящиеся на локальном диске компьютера, можно вставлять внешние ссылки из Интернета.

Пусть, например, над отдельными элементами проекта трудится несколько инженеров из разных организаций. Они сохраняют свои чертежи в общей сетевой папке в Интернете. Руководитель проекта держит на своем компьютере главный чертеж, а результаты работы своих подчиненных он подключает к нему как внешние ссылки. Если кто-то из инженеров вносит коррективы в свой фрагмент, они отражаются в главном чертеже при его следующем открытии. Приведенный в качестве примера механизм почти идеален для разработки сложных распределенных проектов.

ПримечаниеЕсли скорость соединения с Интернетом низка, а также, если в главном чертеже имеется множество внешних ссылок, загрузка ссылок может занять достаточно долгое время.


Для вставки в чертеж внешней ссылки из Интернета (Процедура)

Доступ Buzzsaw для совместной работы
На уровень вверх ..
Вставка содержимого с веб-страниц
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Работа с внешними ссылками в Интернете >
Работа с внешними ссылками в Интернете
Понятие Процедура Краткий справочник

Для вставки в чертеж внешней ссылки из Интернета

  1. Выберите пункт меню "Вставка" [image] "Внешние ссылки".
  2. В диалоговом окне "Выбор файла внешней ссылки" выполните одну из следующих операций:
    • Введите сетевой адрес (URL) в поле "Имя файла".

      Адрес должен включать в себя признак протокола передачи (например, http:// или ftp://).

    • Нажмите кнопку поиска в Интернете, а затем в диалоговом окне "Поиск в Web" перейдите к файлу, который требуется прикрепить.

    Если для входа в локальную сеть или в Интернет требуется имя пользователя и пароль, появится запрос на ввод этой информации.

  3. Нажмите кнопку "Открыть".
  4. В диалоговом окне "Внешние ссылки" нажмите "OK".
  5. Укажите точку вставки ссылки.
Ввод команды: ССЫЛКА


Работа с внешними ссылками в Интернете (Краткий справочник)

Доступ Buzzsaw для совместной работы
Работа с внешними ссылками в Интернете
Коротко об i-drop (точках загрузки)
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Работа с внешними ссылками в Интернете >
Работа с внешними ссылками в Интернете
Понятие Процедура Краткий справочник

Команды

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Вставка содержимого с веб-страниц

Работа с внешними ссылками в Интернете
Работа с чертежами в Интернете
Коротко об i-drop (точках загрузки)
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете >
Вставка содержимого с веб-страниц
Понятие Процедура

Функция Autodesk® i-drop® позволяет перетаскивать содержимое веб-страницы на чертеж.

Темы в этом разделе

  • Коротко об i-drop (точках загрузки)
  • Использование i-drop

    Работа с i-drop заключается в простом перетаскивании образцов компонентов с веб-страницы в область рисования. Можно также задавать тип i-drop для своего проекта.


Вставка содержимого с веб-страниц (Процедура)

Работа с внешними ссылками в Интернете
На уровень вверх ..
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц >
Вставка содержимого с веб-страниц
Понятие Процедура

Для вставки компонента из i-drop в чертеж

Для настройки параметров вставки из i-drop

Для задания типа i-drop по умолчанию

Для просмотра файла журнала

Для просмотра адреса гиперссылки содержимого i-drop


Коротко об i-drop (точках загрузки) (Понятие)

Вставка содержимого с веб-страниц
Вставка содержимого с веб-страниц
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц >
Коротко об i-drop (точках загрузки)
Понятие Краткий справочник

При помощи технологии, использующей так называемые точки загрузки (i-drop), можно перетаскивать необходимые компоненты из Интернета в текущий чертеж. Данная технология позволяет легко вставлять чертежи и другие объекты из Web-страниц в открытый чертеж. Примером содержимого i-drop, которое можно перетащить, является блок стула, окна или растровое изображение образца линолеума.

С помощью Мастера публикации в Интернете можно создать веб-страницу с содержимым i-drop для файла чертежа. О других способах создания веб-страниц с i-drop можно прочитать на веб-сайте компании Autodesk по адресу:

http://www. autodesk.com/idrop


Коротко об i-drop (точках загрузки) (Краткий справочник)

Работа с внешними ссылками в Интернете
Коротко об i-drop (точках загрузки)
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Коротко об i-drop (точках загрузки) >
Коротко об i-drop (точках загрузки)
Понятие Краткий справочник

Команды

ТЗАГРТИП

Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование i-drop (Понятие)

Коротко об i-drop (точках загрузки)
Вставка содержимого с веб-страниц
Формирование комплектов файлов
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц >
Использование i-drop
Понятие Процедура Краткий справочник

Работа с i-drop заключается в простом перетаскивании образцов компонентов с веб-страницы в область рисования. Можно также задавать тип i-drop для своего проекта.

Образец компонента - это обычно уменьшенное и упрощенное изображение объекта, который появится в чертеже после перетаскивания.

Для i-drop существуют следующие настройки:

  • Задание типа i-drop по умолчанию. Можно задать тип содержимого i-drop по умолчанию, которое будет приниматься программой. С помощью данной настройки задается тип содержимого, перетаскиваемого в чертеж с веб-страницы. Например, при выборе параметра "Блок" добавленным содержимым будет являться блок.
  • Задание типа i-drop правой кнопкой мыши в процессе перетаскивания. Путем перетаскивания образца содержимого i-drop при нажатии правой кнопкой мыши можно выбрать тип содержимого i-drop для добавления в чертеж.
  • Задание связанных файлов данных правой кнопкой мыши в процессе перетаскивания. Можно указать связанные файлы данных, которые необходимо загрузить, путем перетаскивания содержимого i-drop в чертеж при нажатии правой кнопки мыши.
  • Задание расположения загружаемых связанных файлов данных. Можно указать место для загрузки файлов данных, связанных с содержимым i-drop.
  • Просмотр файла журнала. Можно просмотреть файл журнала с информацией о содержимом i-drop, который создается для каждого чертежа. Файл журнала располагается в папке, где хранится чертеж.


Использование i-drop (Процедура)

Вставка содержимого с веб-страниц
На уровень вверх ..
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Использование i-drop >
Использование i-drop
Понятие Процедура Краткий справочник

Для вставки компонента из i-drop в чертеж

Для настройки параметров вставки из i-drop

Для задания типа i-drop по умолчанию

Для просмотра файла журнала

Для просмотра адреса гиперссылки содержимого i-drop


Для вставки компонента из i-drop в чертеж (Процедура)

Использование i-drop
На уровень вверх ..
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Использование i-drop >
Использование i-drop
Понятие Процедура Краткий справочник

Для вставки компонента из i-drop в чертеж

  1. Откройте чертеж, в который нужно вставить компонент.
  2. Перетащите образец компонента с веб-страницы в открытый чертеж.

    Курсор, перемещаемый над образцом компонента, приобретает вид пипетки. Компонент переходит в режим вставки.

  3. Переместите курсор в нужную позицию чертежа и установите компонент нажатием левой кнопки мыши.

    Компонент из i-drop помещается в чертеж.


Для настройки параметров вставки из i-drop (Процедура)

Использование i-drop
На уровень вверх ..
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Использование i-drop >
Использование i-drop
Понятие Процедура Краткий справочник

Для настройки параметров вставки из i-drop

При добавлении содержимого i-drop в чертеж можно указать путь и место размещения связанных файлов данных.

  1. Перетащите образец компонента с веб-страницы в открытый чертеж с помощью правой кнопки мыши.

    Курсор, перемещаемый над образцом компонента, приобретает вид пипетки.

  2. В контекстном меню выберите "Вставить как" [image] "Блок".
  3. В диалоговом окне "Параметры вставки из i-drop" в области "Выбор связанного файла" выберите связанные файлы данных, которые требуется загрузить с помощью содержимого i-drop.
  4. В поле "Путь к папке назначения" указывается путь, куда по умолчанию помещаются связанные файлы. Нажав на кнопку [...], можно задать другой путь.
  5. Нажмите "ОК".
  6. Переместите курсор в нужную позицию чертежа и установите компонент нажатием левой кнопки мыши.


Для задания типа i-drop по умолчанию (Процедура)

Использование i-drop
На уровень вверх ..
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Использование i-drop >
Использование i-drop
Понятие Процедура Краткий справочник

Для задания типа i-drop по умолчанию

  1. В командной строке введите тзагртип.
  2. В открывшемся диалоговом окне выберите тип i-drop по умолчанию.

    В раскрывающемся списке содержатся только поддерживаемые технологией i-drop типы содержимого i-drop.

    Перетаскиваемый в чертеж объект может быть нескольких типов содержимого. Данная настройка определяет, какой тип содержимого вставляется в чертеж. Выбор "Блок" указывает на то, что добавляется блок. В чертеж можно поместить любой блок, созданный в программе семейства AutoCAD.


Для просмотра файла журнала (Процедура)

Использование i-drop
На уровень вверх ..
Использование i-drop
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Использование i-drop >
Использование i-drop
Понятие Процедура Краткий справочник

Для просмотра файла журнала

  • Откройте файл <имя файла чертежа>_idrop.txt в папке, где хранится чертеж.

    Файл журнала содержит информацию о дате и времени загрузки, имени целевого файла, имени i-drop и загруженного компонента (в конце URL-адреса), а также подробную информацию о каждом связанном файле.


Для просмотра адреса гиперссылки содержимого i-drop (Процедура)

Использование i-drop
На уровень вверх ..
Формирование комплектов файлов
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Использование i-drop >
Использование i-drop
Понятие Процедура Краткий справочник

Для просмотра адреса гиперссылки содержимого i-drop

  1. Выберите загруженный компонент на чертеже.
  2. Разместите над ним курсор.

    Адрес гиперссылки отображается в виде контекстной подсказки указателя.


Использование i-drop (Краткий справочник)

Коротко об i-drop (точках загрузки)
Использование i-drop
Формирование комплектов файлов
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Вставка содержимого с веб-страниц > Использование i-drop >
Использование i-drop
Понятие Процедура Краткий справочник

Команды

ТЗАГРТИП

Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Формирование комплектов файлов (Понятие)

Использование i-drop
Работа с чертежами в Интернете
Создание веб-страниц с помощью Мастера публикации в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете >
Формирование комплектов файлов
Понятие Процедура Краткий справочник

С помощью функции формирования комплектов пользователь может группировать файлы для пересылки через Интернет. В комплекты автоматически включаются все связанные с чертежом файлы, такие как файлы внешних ссылок и шрифтов.

Как правило, при отправке чертежа получателю возникает проблема добавления к нему связанных файлов (шрифтов, внешних ссылок и др.). В некоторых случаях отсутствие связанных файлов делает невозможным использование файлов чертежей получателем. Функция формирования комплектов включает зависимые файлы в комплект автоматически, уменьшая тем самым возможность ошибки.

Выбор файлов для комплекта

В диалоговом окне "Формирование комплекта файлов" присутствует две вкладки, если функция вызывается для отдельных файлов чертежей, или три вкладки, если функция вызывается для подшивок и файлов чертежей, на которые есть ссылки в подшивках. Используя эти вкладки, пользователь может просмотреть и изменить файлы, которые должны быть включены в комплект.

  • Листы. Эта вкладка доступна, только когда открыта подшивка. На ней отображается иерархический список листов в текущей подшивке. При выборе листа все его зависимые файлы автоматически включаются в комплект.
  • Дерево файлов. На этой вкладке отображается список файлов. Пользователь может развернуть любое имя файла чертежа, чтобы увидеть его зависимые файлы. По умолчанию все зависимые файлы автоматически включаются в комплект; если какой-либо файл не нужен в комплекте, необходимо убрать флажок около его имени.
  • Таблица файлов. На этой вкладке отображается таблица файлов, местоположение их папки и дополнительные сведения о файле. Можно установить или убрать флажок около каждого файла, тем самым соответственно включив файл в комплект или исключив его оттуда. Для каждого файла это делается индивидуально.

В следующей таблице представлены общие типы файлов, которые добавляются в комплект автоматически. Можно удалить любые из автоматически добавленных файлов, а также вручную добавить дополнительные файлы, которые требуется включить в комплект.

Типы файлов, которые добавляются в комплект автоматически
Типы файлов | Описание
*.dwg | Файл корневого чертежа и любые вложенные внешние ссылки.
Всевозможные типы файлов изображений | Файлы растровых изображений, прикрепленные с помощью внешних ссылок к корневому чертежу или к его внешним чертежам либо как часть материала
*.dng | Файлы DGN, прикрепленные с помощью внешних ссылок к корневому чертежу или к его внешним чертежам
*.dwf | Файлы DWF, прикрепленые с помощью внешних ссылок к корневому чертежу или к его внешним чертежам
*.dwfx | Файл DWF с информацией XPS, вставленный посредством внешней ссылки в корневой чертеж или в другой чертеж, на который существует внешняя ссылка
*.dxe | Файлы извлечения данных, содержащие параметры извлечения и информацию о связях с данными
*.xls | Файлы электронных таблиц Microsoft Excel, связанные с таблицами извлечения данных
*.fmp | Файлы соответствия шрифтов для контекстного редактора при работе с многострочными текстовыми объектами
*.ctb | Файлы CTB, используемые для управления внешним видом объектов в чертежах комплекта при передаче на плоттер
*.stb | Файлы STB, используемые для управления внешним видом объектов в чертежах комплекта при передаче на плоттер
*.pc3 | Файлы, используемые для управления плоттером и его параметрами при выводе листов чертежей комплекта на устройство
*.dwt | Файл шаблонов чертежей, связанных с подшивкой
*.dst | Файлы подшивок
*.dws | Файл стандартов чертежей, связанный с чертежом для проверки соответствия стандартам

В следующей табице представлены общие типы файлов, которые не добавляются в комплект автоматически. Большинство этих файлов содержит информацию, касающуюся приложений, выполняющихся совместно с данным программным продуктом, или информацию, которая изначально использовались для форматирования объектов чертежа, но больше не требуется для его правильного просмотра при передаче другому пользователю.

Типы файлов, которые не добавляются в комплект автоматически
Типы файлов | Описание
*.arx, *.dbx, *.lsp, *.vlx, *.dvb, *.dll | Файлы пользовательских приложений (ObjectARX, ObjectDBX, AutoLISP, Visual LISP, VBA и .NET)
*.shx | Файлы составных объектов, используемые для текстовых стилей и сложных типов линий
*.ttf | Файлы шрифтов True Type, используемые для текстовых стилей
*.pfa, *.pfb | Файлы шрифтов PostScript Type 1
*.pat | Файлы образцов штриховки
*.lin | Файлы определений типов линий
*.mln | Файлы определений многострочных объектов
*.pmp | Файлы параметров моделей плоттеров, используемые для хранения конфигурационной информации, относящейся к определенному плоттеру, например, пользовательские форматы бумаги
*.unt | Файлы преобразования единиц чертежа, используемые функциями БыстрКальк и CVUNIT AutoLISP
*.pss | Файлы параметров штемпеля
объекты OLE (связанные файлы) | Объекты OLE, связанные с файлами в чертеже, не включаются в комплект
объекты Rtext (связанные файлы) | Текстовые файлы, на которые ссылается объект RTEXT, не включаются в комплект
*.xls (файлы Microsoft Excel) | Файлы электронных таблиц Microsoft Excel, связанные с таблицами извлечения данных, не включаются в комплект

Добавление инструкций для получателя

При формировании комплекта генерируется файл отчета, который включает в себя список файлов комплекта. Этот отчет также содержит инструкции по обработке зависимых файлов чертежа, таких как внешние ссылки и файлы шрифтов, чтобы зависимые файлы можно было использовать с включенными в комплект файлами. Пользователь может также добавить свои примечания к файлу отчета.

Сохранение наборов параметров комплектов

В ходе выполнения проекта может понадобиться посылать комплекты файлов несколько раз. Функция формирования комплектов предоставляет возможность сохранить настройки параметров комплекта как именованный набор параметров комплекта. В диалоговом окне "Наборы параметров комплектов" отображается список имеющихся наборов параметров, которыми можно воспользоваться всякий раз при формировании нового комплекта. Набор параметров комплекта по умолчанию называется "Standard".

Настройка параметров комплекта

Порядок формирования комплекта файлов регулируется рядом параметров. Используя эти параметры, можно:

  • Заархивировать комплект в ZIP-файл, в самораспаковывающийся EXE-файл или скопировать его в определенную папку.
  • Задать вид структуры папок передаваемых файлов: логическая иерархия, одна папка или "как есть". Если комплект сохраняется в Интернете (по протоколу FTP или HTTP), то все файлы принудительно записываются в одну папку.
  • Добавить защиту паролем к комплекту, автоматически внедрить внешние ссылки, установить пустое устройство в качестве плоттера по умолчанию и др.

После того как комплект создан, его можно разместить его на каком-либо сервере в Интернете или послать другим разработчикам в качестве прикрепленного к электронному письму файла. Если необходимо послать комплект по электронной почте, то пользователь может использовать опцию в диалоговом окне "Изменение набора параметров комплекта", которая автоматически вызывает зарегистрированное в системе почтовое приложение. При этом сам комплект и файл отчета автоматически прикрепляются к новому электронному письму.

ПримечаниеНезависимо от выбранной структуры папок комплекта все полные (абсолютные) пути к зависимым файлам преобразуются в относительные пути или к типу "путь не задан"; это позволяет сохранить связи чертежа с зависимыми файлами.

Формирование комплектов из подшивок

В Диспетчере подшивок можно создать комплект на основе всей подшивки, группы листов или отдельного листа. В Диспетчере подшивок укажите, какой комплект требуется создать.

ПримечаниеВ Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на узле подшивки, узле группы или узле отдельного листа в дереве листов. В контекстном меню есть пункт "Сформировать комплект", который осуществляет формирование комплекта, основываясь на том, какой элемент выделен. Для включения в комплект больших или сложных наборов листов удобно пользоваться именованными наборами листов.

С помощью вкладок диалогового окна "Формирование комплекта файлов" можно определить, какие файлы должны быть включены в данный комплект.

  • На вкладке "Листы" можно легко выбирать листы для формирования комплекта, ставя или убирая флажки около их имен.
  • На вкладках "Дерево файлов" и "Таблица файлов" можно добавлять и убирать файлы чертежей и зависимые файлы. В комплект можно также добавить любые другие файлы, не связанные с основными чертежами.
ПримечаниеЕсли из одного файла чертежа в комплект взяты несколько листов, то с помощью флажка на вкладке "Листы" можно управлять только первым из них; другие листы будут недоступны. Поэтому рекомендуется в каждом файле чертежа создавать только одну вкладку-лист.

Взаимодействие комплектов с AutoCAD LT и более ранними версиями AutoCAD

Комплекты файлов пересылаются между различными людьми и организациями, и вполне возможно, что некоторые из получателей подобных комплектов имеют у себя AutoCAD LT или более ранние версии AutoCAD.

Пересылка комплектов файлов может производиться между пользователями различных продуктов на основе AutoCAD; кроме того, функция формирования комплектов обладает способностью преобразования файлов в DWG-форматы предыдущих версий. Кроме того, комплекты файлов, созданные в AutoCAD 2005 и более поздних версиях программы, могут содержать подшивки, недоступные в AutoCAD LT и в более ранних версиях AutoCAD. Файлы этих подшивок могут пересылаться и приниматься в AutoCAD LT и более ранних версиях AutoCAD. Однако если для передачи файлов требуется более действенный и удобный способ, используйте подшивки в комплектах файлов.

Пересылка файлов пользователям других стран

Начиная с AutoCAD 2007 и AutoCAD LT 2007, в именах файлов, созданных в программах на базе продуктов AutoCAD, используются стандарты Unicode, что обеспечивает совместную работу над проектом людям из разных стран. Однако функция "Сформировать комплект" использует технологию WinZip для формирования комплектов. Так как WinZip не поддерживает стандарт Unicode, рекомендуется использовать одну из следующих операций:

  • Пересылка файлов по отдельности.
  • Использование функции "Сформировать комплект" для создания папки, содержащей пересылаемые файлы, и копирование этой папки на общий сервер.
  • Формирование пакетов файлов с помощью коммерческого приложения, поддерживающего стандарт Unicode.
  • Перед использованием функции формирования комплектов убедитесь, что все имена файлов используют символы, шестнадцатеричные значения которых не превосходят 80.


Формирование комплектов файлов (Процедура)

Использование i-drop
На уровень вверх ..
Формирование комплектов файлов
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Формирование комплектов файлов >
Формирование комплектов файлов
Понятие Процедура Краткий справочник

Для формирования комплекта файлов в заданной папке

Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле

Для создания комплекта файлов на основе подшивки

Для распаковки самораспаковывающегося комплекта файлов


Для формирования комплекта файлов в заданной папке (Процедура)

Формирование комплектов файлов
На уровень вверх ..
Формирование комплектов файлов
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Формирование комплектов файлов >
Формирование комплектов файлов
Понятие Процедура Краткий справочник

Для формирования комплекта файлов в заданной папке

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Сформировать комплект. В командной строке введите "формкомплект".
  2. В диалоговом окне "Формирование комплекта файлов" на вкладке "Дерево файлов" или "Таблица файлов" нажмите кнопку "Добавить файл".
  3. (Не обязательно) В диалоговом окне "Добавление файла в комплект" найдите и выберите файлы, которе требуется включить в комплект. Нажмите кнопку "Открыть". Повторите этот шаг для дополнительных файлов, если необходимо.
  4. В диалоговом окне "Формирование комплекта файлов" на вкладке с деревом или таблицей файлов снимите флажки около тех файлов, которые не должны входить в комплект. Пользователь может развернуть любой файл чертежа, чтобы увидеть зависимые от него файлы.
  5. Выберите "Наборы параметров комплектов". Нажмите кнопку "Редактирование".
  6. В диалоговом окне "Изменение набора параметров комплекта" нажмите стрелку рядом со списком "Тип комплекта" и затем выберите "Папка с файлами". Задайте необходимые дополнительные параметры комплекта.
  7. Нажмите кнопку "Обзор" под списком "Папка с файлом комплекта" для определения папки, в которую должен быть помещен комплект. Появляется стандартное диалоговое окно выбора файлов.
  8. Перейдите к папке, в которой требуется создать комплект файлов. Нажмите кнопку "Открыть".
  9. Нажмите кнопку "OK" для закрытия диалогового окна "Изменение набора параметров комплекта".
  10. Нажмите кнопку "Закрыть" для закрытия диалогового окна "Наборы параметров комплектов".
  11. (Дополнительно) В диалоговом окне "Формирование комплекта файлов" в области для примечаний можно записать любые дополнительные комментарии, которые будут включены в файл отчета.
  12. Нажмите "OK" для создания комплекта файлов в заданной папке.
Ввод команды: ФОРМКОМПЛЕКТ


Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле (Процедура)

Формирование комплектов файлов
На уровень вверх ..
Формирование комплектов файлов
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Формирование комплектов файлов >
Формирование комплектов файлов
Понятие Процедура Краткий справочник

Для формирования комплекта файлов в самораспаковывающемся EXE-файле или ZIP-файле

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Переслать" [image] Сформировать комплект. В командной строке введите "формкомплект".
  2. В диалоговом окне "Формирование комплекта файлов" на вкладке "Дерево файлов" или "Таблица файлов" нажмите кнопку "Добавить файл".
  3. (Не обязательно) В диалоговом окне "Добавление файла в комплект" найдите и выберите файлы, которе требуется включить в комплект. Нажмите кнопку "Открыть". Повторите этот шаг для файлов, находящихся в дополнительных папках, если необходимо.
  4. В диалоговом окне "Формирование комплекта файлов" на вкладке с деревом или таблицей файлов снимите флажки около тех файлов, которые не должны входить в комплект. На вкладке "Дерево файлов" пользователь может развернуть любой файл чертежа, чтобы увидеть зависимые от него файлы.
  5. Выберите "Наборы параметров комплектов". Нажмите кнопку "Редактирование".
    ПримечаниеРекомендуется создать и сохранить несколько именованных наборов параметров комплектов. Теперь для создания комплекта файлов не нужно выполнять шаги с 5 по 11, можно лишь выбрать набор параметров.
  6. В диалоговом окне "Изменение набора параметров комплекта" щелкните на стрелке для отображения списка "Тип комплекта". Выберите "Zip (*.zip)" или "Самораспаковывающийся EXE-файл". Задайте необходимые дополнительные параметры комплекта.
  7. Нажмите кнопку "Обзор" под списком "Папка с файлом комплекта" для определения папки, в которую должен быть помещен комплект. Появляется стандартное диалоговое окно выбора файлов.
  8. Перейдите к папке, в которой требуется создать комплект файлов. Нажмите кнопку "Открыть".
  9. Нажмите кнопку "OK" для закрытия диалогового окна "Изменение набора параметров комплекта".
  10. Нажмите кнопку "Закрыть" для закрытия диалогового окна "Наборы параметров комплектов".
  11. (Дополнительно) В диалоговом окне "Формирование комплекта файлов" в области для примечаний можно записать любые дополнительные комментарии, которые будут включены в файл отчета.
  12. Нажмите "OK" для создания комплекта файлов в заданной папке.
Ввод команды: ФОРМКОМПЛЕКТ


Для создания комплекта файлов на основе подшивки (Процедура)

Формирование комплектов файлов
На уровень вверх ..
Формирование комплектов файлов
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Формирование комплектов файлов >
Формирование комплектов файлов
Понятие Процедура Краткий справочник

Для создания комплекта файлов на основе подшивки

  1. Откройте подшивку, на основе которой формируется комплект.
  2. В Диспетчере подшивок на вкладке "Список листов" нажмите правую кнопку мыши на одном из следующих типов узлов в списке дерева листов:
    • Подшивка (узел верхнего уровня). Комплект формируется из всей подшивки.
    • Группа листов (узел среднего уровня). Комплект формируется из группы листов или набора листов подшивки.
    • Лист (узел нижнего уровня). Комплект формируется из выбранного листа или набора листов подшивки.
  3. В контекстном меню выберите "Сформировать комплект".

    Если листы принадлежат одному и тому же файлу чертежа, то в диалоговом окне "Формирование комплекта файлов" на вкладке "Листы" они отображаются с отступом относительно других листов. Выбор или отказ от включения листа в комплект приводит автоматически к такому же выбору или отказу для остальных листов того же чертежа.

    ПримечаниеРекомендуется создать и сохранить несколько именованных наборов параметров комплектов. Теперь для создания комплекта файлов не нужно выполнять шаги с 4 по 11, можно лишь выбрать набор параметров.
  4. В диалоговом окне "Формирование комплекта файлов" выберите "Наборы параметров комплектов". Нажмите кнопку "Редактирование".
  5. В диалоговом окне "Изменение набора параметров комплекта" нажмите стрелку возле списка "Тип комплекта" и выберите тип комплекта, который должен быть создан. Задайте необходимые дополнительные параметры комплекта. В группе "Опции для комплекта" рекомендуется использовать первый параметр - "Организованная структура папок". Корневой в данном случае считается папка, где хранится файл данных подшивки (.dst). Выберите параметр "Текущая структура файлов и папок" для режима формирования комплекта AutoCAD 2007.
  6. Нажмите кнопку "Обзор" под списком "Папка с файлом комплекта" для определения папки, в которую должен быть помещен комплект. Появляется стандартное диалоговое окно выбора файлов.
  7. Перейдите к папке, в которой требуется создать комплект файлов. Нажмите кнопку "Открыть".
  8. Нажмите кнопку "OK" для закрытия диалогового окна "Изменение набора параметров комплекта".
  9. Нажмите кнопку "Закрыть" для закрытия диалогового окна "Наборы параметров комплектов".
  10. (Дополнительно) В диалоговом окне "Формирование комплекта файлов" в области для примечаний можно записать любые дополнительные комментарии, которые будут включены в файл отчета.
  11. Нажмите "OK" для создания комплекта файлов в заданной папке.
Ввод команды: ФОРМКОМПЛЕКТ


Для распаковки самораспаковывающегося комплекта файлов (Процедура)

Формирование комплектов файлов
На уровень вверх ..
Создание веб-страниц с помощью Мастера публикации в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Формирование комплектов файлов >
Формирование комплектов файлов
Понятие Процедура Краткий справочник

Для распаковки самораспаковывающегося комплекта файлов

  1. В Проводнике Windows дважды нажмите левую кнопку мыши на значке файла комплекта.
  2. В диалоговом окне "Формирование комплекта" нажмите кнопку "Обзор" для задания папки, в которую требуется распаковать файлы комплекта.
  3. Нажмите "ОК".
  4. Если для защиты комплекта был задан пароль, появляется запрос на ввод пароля.
  5. Нажмите "OK" для закрытия каждого диалогового окна.


Формирование комплектов файлов (Краткий справочник)

Использование i-drop
Формирование комплектов файлов
Создание веб-страниц с помощью Мастера публикации в Интернете
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Работа с чертежами в Интернете > Формирование комплектов файлов >
Формирование комплектов файлов
Понятие Процедура Краткий справочник

Команды

АРХИВАЦИЯ

Упаковка файлов текущей подшивки для архивирования

ФОРМКОМПЛЕКТ

Формирование комплекта файлов для передачи другим пользователям через Интернет

ГИПЕРССЫЛКА

Создание гиперссылки для объекта или изменение существующей гиперссылки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Создание веб-страниц с помощью Мастера публикации в Интернете (Понятие)

Формирование комплектов файлов
Совместная работа с чертежами в Интернете
Использование пометок для рецензирования проектов
Совместная работа над проектами > Совместная работа с чертежами в Интернете >
Создание веб-страниц с помощью Мастера публикации в Интернете
Понятие Процедура Краткий справочник

Мастер "Публикация в Интернете" позволяет упростить процесс создания файлов DWF или DWFx, а также их форматирования для отображения на страницах HTML.

Мастер "Публикация в Интернете" представляет собой упрощеннй интерфейс для создания отформатированных веб-страниц, содержащих изображения чертежей в формате DWF, DWFx, JPEG или PNG.

  • Форматы DWF и DWFx не предусматривают сжатия файлов чертежей.
  • Формат JPEG использует сжатие информации с потерями; т.е. происходит сознательный отказ от некоторых данных для более компактного сжатия файла.
  • PNG-формат (Portable Network Graphics) использует сжатие информации без потерь; т.е. не происходит потери данных ради уменьшения размера файла.

С помощью Мастера публикации можно легко и быстро создавать наглядные веб-страницы, не имея никаких навыков в выполнении HTML-верстки. Созданные таким образом веб-страницы могут размещаться в Интернете или корпоративной сети.

Ниже перечислены элементы оформления, с помощью которых в Мастере создаются веб-страницы:

  • Шаблоны. Можно выбрать один из четырех шаблонов для листа веб-страницы или создать собственный шаблон.
  • Темы. Для выбранного шаблона можно задать одну из тем. Темы определяют цветовое и шрифтовое оформление веб-страницы.
  • i-drop. На веб-странице можно включить поддержку технологии i-drop. Посетители страницы могут перетаскивать файлы чертежей в сеанс программы. i-drop идеально подходят для публикации библиотек компонентов в Интернете.

Информацию по использованию функции i-drop для создания идентификатора i-drop на веб-страницах см. в документации по i-drop на веб-узле Autodesk по адресу: http://www.autodesk.com/idrop.

ПримечаниеШаблон, используемый для создания веб-страницы, можно настраивать. Подробнее об использовании шаблонов см. раздел Адаптация шаблонов Интернет-публикаций в Руководстве по адаптации.


Для использования Мастера публикации (Процедура)

Формирование комплектов файлов
Создание веб-страниц с помощью Мастера публикации в Интернете
Просмотр пометок
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Создание веб-страниц с помощью Мастера публикации в Интернете >
Создание веб-страниц с помощью Мастера публикации в Интернете
Понятие Процедура Краткий справочник

Для использования Мастера публикации

  1. Выберите следующие элементы: вкладка "Вывод" [image] панель "Публикация" [image] Публикация в Интернете. В командной строке введите "опубликовать".
  2. Следуйте инструкциям по созданию веб-страницы.
Ввод команды: ОПУБЛИКОВАТЬ


Создание веб-страниц с помощью Мастера публикации в Интернете (Краткий справочник)

Формирование комплектов файлов
Создание веб-страниц с помощью Мастера публикации в Интернете
Коротко об использовании электронных пометок
Совместная работа над проектами > Совместная работа с чертежами в Интернете > Создание веб-страниц с помощью Мастера публикации в Интернете >
Создание веб-страниц с помощью Мастера публикации в Интернете
Понятие Процедура Краткий справочник

Команды

ОПУБЛИКОВАТЬ

Создание HTML-страниц с изображениями выбранных чертежей

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Использование пометок для рецензирования проектов

Создание веб-страниц с помощью Мастера публикации в Интернете
Совместная работа над проектами
Коротко об использовании электронных пометок
Совместная работа над проектами >
Использование пометок для рецензирования проектов

На последних этапах работы над проектом чертежи обычно публикуются для итогового просмотра и последних исправлений. Замечания и комментарии могут быть размещены в электронной версии чертежа. На основании полученных комментариев проект дорабатывают, а публикацию исправленных чертежей повторяют. Такая работа с электронными пометками упрощает этап согласования, сокращает цикл разработки и в результате повышает эффективность процесса проектирования.

Темы в этом разделе

  • Коротко об использовании электронных пометок

    Вносить в файлы DWF или DWFx пометки в процессе рецензирования можно только с помощью Autodesk Design Review. Затем можно просмотреть эти пометки в программе AutoCAD, внести изменения в чертежи и изменить статус пометок.

  • Публикация чертежей для рецензирования

    Публикация чертежей для рецензирования выполняется в конце работы над проектом.

  • Вставка пометок

    С помощью Autodesk Design Review можно вставлять пометки в файл DWF или DWFx. Пометка представляет собой единичный комментарий либо исправление геометрии, отображаемое красным цветом и вставленное в файл DWF или DWFx.

  • Просмотр пометок

    Просмотр пометок и управление ими осуществляется в диспетчере наборов пометок. Для просмотра пометок в проекте следует загрузить набор пометок в диспетчер наборов пометок.

  • Реакция на пометки

    После изучения полученных пометок можно менять их статус и добавлять комментарии, которые сохраняются вместе с пометкой.

  • Повторная публикация набора пометок

    После того как набор пометок изучен и в чертежи внесены изменения, набор пометок можно повторно опубликовать для дополнительного рецензирования.


Коротко об использовании электронных пометок (Понятие)

Использование пометок для рецензирования проектов
Использование пометок для рецензирования проектов
Публикация чертежей для рецензирования
Совместная работа над проектами > Использование пометок для рецензирования проектов >
Коротко об использовании электронных пометок
Понятие Краткий справочник

Вносить в файлы DWF или DWFx пометки в процессе рецензирования можно только с помощью Autodesk Design Review. Затем можно просмотреть эти пометки в программе AutoCAD, внести изменения в чертежи и изменить статус пометок.

Для рецензирования проектов можно опубликовать файл DWF или DWFx и затем передать его клиенту или рецензенту. Рецензент может открыть файл DWF или DWFx в программе Autodesk Design Review, внести в файл пометки в электронном виде и затем вернуть его отправителю.

Открыв файл DWF или DWFx с пометками в AutoCAD®, можно просмотреть исправления геометрии в области рисования AutoCAD, отключить их, внести изменения, изменить состояние пометок и снова опубликовать файл DWF для передачи на повторное рецензирование.


Коротко об использовании электронных пометок (Краткий справочник)

Создание веб-страниц с помощью Мастера публикации в Интернете
Коротко об использовании электронных пометок
Публикация чертежей для рецензирования
Совместная работа над проектами > Использование пометок для рецензирования проектов > Коротко об использовании электронных пометок >
Коротко об использовании электронных пометок
Понятие Краткий справочник

Команды

ПМТНАБОР

Отображение сведения о пометках с возможностью изменения их статуса

ПМТЗАКРЫТЬ

Закрытие Диспетчера наборов пометок

НПОТКРЫТЬ

Открытие DWF или DWFx-файла, который содержит пометки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Публикация чертежей для рецензирования (Понятие)

Коротко об использовании электронных пометок
Использование пометок для рецензирования проектов
Вставка пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов >
Публикация чертежей для рецензирования
Понятие Краткий справочник

Публикация чертежей для рецензирования выполняется в конце работы над проектом.

Чертежи для рецензирования публикуются на последнем этапе работы над проектом. Для совмещения электронных пометок, созданных в программе Autodesk Design Review, с исходной геометрией чертежа важно не изменять в файле чертежа элементы, которые могут оказать влияние на это совмещение после публикации файла DWF или DWFx для рецензирования.

К этим элементам относятся:

  • слои и состояния слоев
  • слои, на которых расположены объекты
  • количество и размещение видовых экранов на листах
  • расположение и масштаб объектов на видовых экранах
  • углы поворота видов
  • большинство объектов чертежа


Публикация чертежей для рецензирования (Краткий справочник)

Коротко об использовании электронных пометок
Публикация чертежей для рецензирования
Вставка пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Публикация чертежей для рецензирования >
Публикация чертежей для рецензирования
Понятие Краткий справочник

Команды

ПУБЛ

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Вставка пометок (Понятие)

Публикация чертежей для рецензирования
Использование пометок для рецензирования проектов
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов >
Вставка пометок
Понятие Краткий справочник

С помощью Autodesk Design Review можно вставлять пометки в файл DWF или DWFx. Пометка представляет собой единичный комментарий либо исправление геометрии, отображаемое красным цветом и вставленное в файл DWF или DWFx.

С помощью программы Autodesk DWF Composer можно вносить в чертеж электронные пометки, аналогичные пометкам на листе бумаги. Можно также назначить пометке состояние и добавить комментарии.

Пометки и их состояние сохраняются в файле DWF или DWFx

Дополнительные сведения о создании пометок с помощью программы Autodesk Design Review см. в документации "Справочная система Autodesk Design Review".


Вставка пометок (Краткий справочник)

Публикация чертежей для рецензирования
Вставка пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Вставка пометок >
Вставка пометок
Понятие Краткий справочник

Команды

Нет

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Просмотр пометок (Понятие)

Вставка пометок
Использование пометок для рецензирования проектов
Реакция на пометки
Совместная работа над проектами > Использование пометок для рецензирования проектов >
Просмотр пометок
Понятие Процедура Краткий справочник

Просмотр пометок и управление ими осуществляется в диспетчере наборов пометок. Для просмотра пометок в проекте следует загрузить набор пометок в диспетчер наборов пометок.

Набор пометок - это группа пометок, содержащихся в одном файле DWF или DWFx. При загрузке набора пометок в Диспетчер наборов пометок в области структуры отображаются все листы чертежа и связанные с ними пометки.

В Диспетчере наборов пометок можно выбирать отдельные пометки, просматривать их статус и другие подробности, такие как сведения об авторе пометки, дате и времени ее создания и любые комментарии, связанные с пометкой.

Можно создать пометки других типов, которые также будут отображаться в файле DWF или DWFx: текстовые блоки, исправления геометрии, размеры и штемпели. Но из всех этих пометок только комментарии имеют статус и отображаются в Диспетчере наборов пометок.

В программе Autodesk Design Review предусмотрены следующие способы внесения изменений в файлы DWF и DWFx.

  • Изменение порядка листов в файле DWF или DWFx.
  • Добавление листов к файлу DWF или DWFx.
    ПримечаниеДля листов, добавленных с помощью Autodesk Design Review, в диспетчере наборов пометок (в режиме "Просмотр таблицы") отображается состояние листа "Отсутствует файл". Причина заключается в том, что добавляемые листы не вносятся в файл DSD.
  • Удаление листов из файла DWF или DWFx.

Для каждого набора пометок, листы которого удалены, переставлены или добавлены с помощью Autodesk Design Review, в диспетчере наборов пометок листы отображаются в новом порядке.

Все листы, добавленные к файлу DWF или DWFx с помощью Autodesk Design Review, выделены курсивом. При двойном щелчке на листе, добавленном к файлу DWF или DWFx с помощью Autodesk Design Review, или на пометке для этого листа он отображается в программе просмотра файлов DWF.

Если при загрузке набора пометок выполняется попытка открытия файла DWF или DWFx, не содержащего пометок, открыть такой файл в AutoCAD невозможно. Однако можно открыть файл DWF или DWFx в программе просмотра файлов DWF.

При двойном нажатии в Диспетчере наборов пометок на пометке, нанесенной в пространстве модели, исходный файл чертежа открывается в пространстве модели и принимает тот угол поворота вида, который был текущим при сохранении чертежа. Если в дальнейшем изменить угол поворота вида, пометки не будут отображаться в чертеже до тех пор, пока пользователь не вернется к исходному виду, повторно произведя двойное нажатие на пометке.

С помощью Диспетчера наборов пометок можно указать объекты для отображения в области рисования. Можно показать и скрыть исходный файл чертежа, измененную геометрию файла DWF и исправления геометрии. Благодаря этому пользователь может просмотреть электронные пометки, отключить их для внесения изменений в файл чертежа, а затем снова просмотреть пометки в программе AutoCAD для проверки исправлений.

При просмотре пометок полезны следующие рекомендации:

  • В качестве цвета фона пространства модели для чертежа задайте светлый оттенок любого цвета, кроме черного. Это позволяет просмотреть геометрию DWF или DWFx в AutoCAD после возврата файла DWF или DWFx с пометками.
  • Поместите файлы чертежа, использованные при публикации файла DWF или DWFx, в папку, которую указывает путь поиска. Это обеспечивает возможность загрузки соответствующих наборов чертежей для файла DWF или DWFx с пометками.

    Путь поиска следует задать на вкладке "Файлы" диалогового окна "Параметры".

ПримечаниеПросматривать пометки в AutoCAD можно только в том случае, если файл DWF или DWFx с пометками первоначально создан в AutoCAD 2005 или более поздней версии. Чтобы просмотреть пометки с помощью программы AutoCAD, требуется исходный файл чертежа. Файлы DWF или DWFx с пометками, первоначально созданные в более ранней версии AutoCAD, можно открыть в Autodesk Design Review.


Просмотр пометок (Процедура)

Создание веб-страниц с помощью Мастера публикации в Интернете
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для открытия Диспетчера наборов пометок

Для открытия набора пометок

Для просмотра подробностей об отдельной пометке в Диспетчере наборов пометок

Для открытия листа чертежа с пометками из Диспетчера наборов пометок

Для отображения или скрытия DWG-геометрии для листов чертежа с пометками

Отображение или скрытие геометрии файла DWF в области рисования

Отображение или скрытие геометрии пометок в области рисования

Для вывода чертежа с пометками на печать

Для закрытия Диспетчера наборов пометок


Для открытия Диспетчера наборов пометок (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для открытия Диспетчера наборов пометок

  • Выберите меню Сервис [image] Палитры [image] Диспетчер наборов пометок.
Панель:Стандартный
Ввод команды: ПМТНАБОР


Для открытия набора пометок (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для открытия набора пометок

  1. Для открытия набора пометок следует воспользоваться одним из следующих способов:
    • Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
    • В диспетчере наборов пометок щелкните на списке "Набор пометок". Нажмите "Открыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

    Файл DWF или DWFx, не содержащий пометок, следует открыть в Autodesk Design Review, так как файлы без пометок невозможно загрузить в PRODNAME.

Ввод команды: НПОТКРЫТЬ


Для просмотра подробностей об отдельной пометке в Диспетчере наборов пометок (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для просмотра подробностей об отдельной пометке в Диспетчере наборов пометок

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок выделите нужную пометку.

    В группе "Подробности" в нижней части Диспетчера наборов пометок отображаются сведения о выбранной пометке.

Ввод команды: НПОТКРЫТЬ


Для открытия листа чертежа с пометками из Диспетчера наборов пометок (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для открытия листа чертежа с пометками из Диспетчера наборов пометок

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок дважды нажмите лист чертежа или узел пометки.

    При двойном нажатии узла пометки в области рисования откроется лист чертежа, соответствующий пометке. Для просмотра связанного листа чертежа необходим исходный файл DWG, из которого был создан файл DWF или DWFx с пометками.

    ПримечаниеЕсли пометки требуется просматривать в области рисования, необходимо задать для визуального стиля и параметра РЕЖИМРАСКР значение "2D каркас".
Ввод команды: НПОТКРЫТЬ


Для отображения или скрытия DWG-геометрии для листов чертежа с пометками (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для отображения или скрытия DWG-геометрии для листов чертежа с пометками

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок дважды нажмите лист чертежа, чтобы открыть исходный DWG-файл.
  4. Нажмите кнопку "Просмотр геометрии DWG" для скрытия DWG-геометрии. Для отображения DWG-геометрии нажмите эту кнопку еще раз.
    ПримечаниеПри открытии файла DWG, с которым не связаны пометки, а также в том случае, если набор пометок не загружен в диспетчер наборов пометок, в диспетчере наборов пометок не доступны следующие кнопки: "Повторить публикацию всех наборов пометок", "Просмотр геометрии DWG", "Просмотр геометрии DWF или DWFx", "Просмотр геометрии пометок".

Ввод команды: НПОТКРЫТЬ


Отображение или скрытие геометрии файла DWF в области рисования (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Отображение или скрытие геометрии файла DWF в области рисования

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок дважды нажмите лист чертежа, чтобы открыть исходный DWG-файл.
  4. В диспетчере наборов пометок нажмите кнопку "Просмотр геометрии DWF" для отображения геометрии DWF или DWFx. Для скрытия геометрии DWF или DWFx можно нажать эту же кнопку еще раз.

Ввод команды: НПОТКРЫТЬ


Отображение или скрытие геометрии пометок в области рисования (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Отображение или скрытие геометрии пометок в области рисования

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. Для отображения геометрии пометки в области рисования выделите ее в Диспетчере пометок.
  4. Нажмите кнопку "Просмотр геометрии пометок" для скрытия электронной пометки. Для отображения электронной пометки нажмите эту кнопку еще раз.

Ввод команды: НПОТКРЫТЬ


Для вывода чертежа с пометками на печать (Процедура)

Просмотр пометок
Просмотр пометок
Просмотр пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для вывода чертежа с пометками на печать

  • В проводнике Windows дважды щелкните на файле DWF или DWFx, содержащем пометки. Файл DWF или DWFx открывается в Autodesk Design Review. Теперь можно распечатать файл DWF или DWFx с пометками.


Для закрытия Диспетчера наборов пометок (Процедура)

Просмотр пометок
Просмотр пометок
Реакция на пометки
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Для закрытия Диспетчера наборов пометок

  • При открытом Диспетчере наборов пометок выберите меню Сервис [image] Палитры [image] Диспетчер наборов пометок.
Ввод команды: ПМТЗАКРЫТЬ


Просмотр пометок (Краткий справочник)

Вставка пометок
Просмотр пометок
Реакция на пометки
Совместная работа над проектами > Использование пометок для рецензирования проектов > Просмотр пометок >
Просмотр пометок
Понятие Процедура Краткий справочник

Команды

ПМТНАБОР

Отображение сведения о пометках с возможностью изменения их статуса

ПМТЗАКРЫТЬ

Закрытие Диспетчера наборов пометок

НПОТКРЫТЬ

Открытие DWF или DWFx-файла, который содержит пометки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Реакция на пометки (Понятие)

Просмотр пометок
Использование пометок для рецензирования проектов
Повторная публикация набора пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов >
Реакция на пометки
Понятие Процедура Краткий справочник

После изучения полученных пометок можно менять их статус и добавлять комментарии, которые сохраняются вместе с пометкой.

При выборе пометки в структуре Диспетчера наборов пометок информация о ней отображается в группе "Подробности". В этой области можно изменить состояние пометки; можно также щелкнуть правой кнопкой мыши и выбрать требуемое состояние в контекстном меню "Статус пометки".

Статус по умолчанию для новых пометок - <нет>. Можно изменить состояние пометки на "Вопрос", "Рассмотрение" или "Выполнено".

Для выбранной пометки можно добавлять комментарии или примечания в области "Примечания", расположенной под группой "Подробности".

Изменения состояния пометок и добавленные комментарии автоматически сохраняются в файле DWF или DWFx и включаются в файл при его повторной публикации. Изменения можно также сохранить, нажав правую кнопку мыши на имени набора пометок и выбрав из контекстного меню пункт "Сохранить журнал пометок".


Реакция на пометки (Процедура)

Просмотр пометок
Реакция на пометки
Реакция на пометки
Совместная работа над проектами > Использование пометок для рецензирования проектов > Реакция на пометки >
Реакция на пометки
Понятие Процедура Краткий справочник

Для изменения статуса пометки

Для добавления комментариев к пометке

Для сохранения изменений в пометках


Для изменения статуса пометки (Процедура)

Реакция на пометки
Реакция на пометки
Реакция на пометки
Совместная работа над проектами > Использование пометок для рецензирования проектов > Реакция на пометки >
Реакция на пометки
Понятие Процедура Краткий справочник

Для изменения статуса пометки

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. Щелкните на узле пометки правой кнопкой мыши. Выберите "Статус пометки", затем выберите состояние щелчком мыши.

    Добавленные комментарии автоматически сохраняются в файле DWF или DWFx и включаются в файл DWF или DWFx при повторной публикации. Изменения также можно сохранить, нажав правую кнопку мыши на узле набора пометок. Выберите "Сохранить журнал пометок".

Ввод команды: НПОТКРЫТЬ


Для добавления комментариев к пометке (Процедура)

Реакция на пометки
Реакция на пометки
Реакция на пометки
Совместная работа над проектами > Использование пометок для рецензирования проектов > Реакция на пометки >
Реакция на пометки
Понятие Процедура Краткий справочник

Для добавления комментариев к пометке

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере пометок выделите нужную пометку.
  4. На панели "Сведения" щелкните в текстовом поле "Замечания". Добавьте комментарии.

    Комментарии сохраняются в файле DWF или DWFx и включаются в файл при его повторной публикации.

    Изменения также можно сохранить, нажав правую кнопку мыши на узле набора пометок. Выберите "Сохранить журнал пометок".

Ввод команды: НПОТКРЫТЬ


Для сохранения изменений в пометках (Процедура)

Реакция на пометки
Реакция на пометки
Повторная публикация набора пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Реакция на пометки >
Реакция на пометки
Понятие Процедура Краткий справочник

Для сохранения изменений в пометках

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок выделите пометку, измените ее статус или добавьте комментарии.
  4. Щелкните на узле набора пометок правой кнопкой мыши. Выберите "Сохранить журнал пометок".

    Изменения состояния пометки и все дополнительные комментарии также сохраняются в файле DWF или DWFx при закрытии или повторной публикации чертежа.

Ввод команды: НПОТКРЫТЬ


Реакция на пометки (Краткий справочник)

Просмотр пометок
Реакция на пометки
Повторная публикация набора пометок
Совместная работа над проектами > Использование пометок для рецензирования проектов > Реакция на пометки >
Реакция на пометки
Понятие Процедура Краткий справочник

Команды

ПМТНАБОР

Отображение сведения о пометках с возможностью изменения их статуса

ПМТЗАКРЫТЬ

Закрытие Диспетчера наборов пометок

НПОТКРЫТЬ

Открытие DWF или DWFx-файла, который содержит пометки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Повторная публикация набора пометок (Понятие)

Реакция на пометки
Использование пометок для рецензирования проектов
Тонирование чертежа для презентации
Совместная работа над проектами > Использование пометок для рецензирования проектов >
Повторная публикация набора пометок
Понятие Процедура Краткий справочник

После того как набор пометок изучен и в чертежи внесены изменения, набор пометок можно повторно опубликовать для дополнительного рецензирования.

При повторной публикации набора пометок в файле DWF или DWFx сохраняются пометки со всеми внесенными в них изменениями. При просмотре повторно опубликованного файла DWF или DWFx в Autodesk Design Review он отображается со всеми изменениями, внесенными в чертеж, а также со всеми изменениями состояния и сведений о пометках.

После повторной публикации файла DWF или DWFx, листы которого удалены или переставлены с помощью Autodesk Design Review, в повторно опубликованном файле DWF или DWFx листы отображаются в новом порядке; однако листы, добавленные к файлу DWF или DWFx с помощью Autodesk Design Review, не включаются в повторно опубликованный файл DWF или DWFx.


Для повторной публикации чертежа с набором пометок (Процедура)

Реакция на пометки
Повторная публикация набора пометок
Задание изометрического стиля шаговой привязки и сетки
Совместная работа над проектами > Использование пометок для рецензирования проектов > Повторная публикация набора пометок >
Повторная публикация набора пометок
Понятие Процедура Краткий справочник

Для повторной публикации чертежа с набором пометок

  1. Выберите меню Файл [image] Загрузить набор пометок.В командной строке введите "нпоткрыть".
  2. В диалоговом окне "Открытие DWF-файла пометок" выберите файл DWF или DWFx, содержащий пометки. Нажмите "Открыть".

    Пометки отображаются в Диспетчере наборов пометок в виде иерархической структуры.

  3. В Диспетчере наборов пометок дважды нажмите пометку или лист чертежа, чтобы открыть исходный файл DWG.
  4. В области рисования внесите необходимые изменения в файл DWG.
  5. В Диспетчере наборов пометок выделите нужные пометки, измените их статус или добавьте комментарии.
  6. Нажмите кнопку "Повторить публикацию DWF-файла" в верхней части диспетчера наборов пометок.

  7. Выберите один из следующих параметров.
    • Повторить публикацию всех листов. При выборе этого параметра повторно публикуются все листы в файле DWF или DWFx с пометками.
    • Повторить публикацию листов с пометками.При выборе этого параметра повторно публикуются только те листы в файле DWF или DWFx с пометками, которые содержат связанные пометки.
  8. В диалоговом окне "Указать DWF-файл" выберите файл DWF или DWFx либо введите имя файла. Нажмите "Выбрать".

    По умолчанию отображается имя ранее созданного файла с пометками; этот файл заменяется файлом с тем же именем, содержащим изменения чертежа и пометок.

Ввод команды: НПОТКРЫТЬ


Повторная публикация набора пометок (Краткий справочник)

Реакция на пометки
Повторная публикация набора пометок
Задание изометрического стиля шаговой привязки и сетки
Совместная работа над проектами > Использование пометок для рецензирования проектов > Повторная публикация набора пометок >
Повторная публикация набора пометок
Понятие Процедура Краткий справочник

Команды

ПМТНАБОР

Отображение сведения о пометках с возможностью изменения их статуса

ПМТЗАКРЫТЬ

Закрытие Диспетчера наборов пометок

НПОТКРЫТЬ

Открытие DWF или DWFx-файла, который содержит пометки

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Тонирование чертежа для презентации

Повторная публикация набора пометок
Построение 2D изометрических видов
Тонирование чертежа для презентации

Темы в этом разделе

  • Построение 2D изометрических видов

    Изометрический режим шаговой привязки и сетки помогает строить двумерные чертежи, представляющие трехмерные объекты.

  • Добавление освещения в модель

    Для создания более реалистичного тонирования в сцене создается освещение.

  • Материалы и текстуры

    В сочетании с освещением, материалы повышают уровень реалистичности моделей.

  • Реалистичное тонирование 3D объектов

    Благодаря реалистичному тонированию модели проект становится более наглядным по сравнению с напечатанным чертежом.

  • Имитация рисования от руки на чертежах САПР

    Для презентаций может потребоваться придать чертежу вид, имитирующий рисование от руки.


Построение 2D изометрических видов

Тонирование чертежа для презентации
Тонирование чертежа для презентации
Задание изометрического стиля шаговой привязки и сетки
Тонирование чертежа для презентации >
Построение 2D изометрических видов

Изометрический режим шаговой привязки и сетки помогает строить двумерные чертежи, представляющие трехмерные объекты.

Изометрический стиль шаговой привязки и сетки помогает строить двумерные чертежи, представляющие трехмерные объекты. Изометрическая шаговая привязка (сетка) позволяет расположить объекты в трех изометрических плоскостях. Однако несмотря на имитацию трехмерности в изометрических чертежах, в действительности они являются двумерными. Поэтому для таких видов вычисление 3D расстояний и площадей, просмотр объектов в различных ракурсах, а также автоматическое подавление скрытых линий невозможно.

Темы в этом разделе

  • Задание изометрического стиля шаговой привязки и сетки

    Имитация трехмерности за счет расположения объектов по трем изометрическим осям.

  • Построение изометрических кругов

    Изображение кругов в изометрических плоскостях с помощью эллипсов.


Задание изометрического стиля шаговой привязки и сетки (Понятие)

Построение 2D изометрических видов
Построение 2D изометрических видов
Построение изометрических кругов
Тонирование чертежа для презентации > Построение 2D изометрических видов >
Задание изометрического стиля шаговой привязки и сетки
Понятие Процедура Краткий справочник

Имитация трехмерности за счет расположения объектов по трем изометрическим осям.

Имитация трехмерности в изометрических чертежах достигается расположением объектов по трем изометрическим осям.

Изометрическая шаговая привязка (сетка) позволяет расположить объекты в трех изометрических плоскостях. Однако несмотря на имитацию трехмерности в изометрических чертежах, в действительности они являются двумерными. Поэтому для таких видов вычисление 3D расстояний и площадей, просмотр объектов в различных ракурсах, а также автоматическое подавление скрытых линий невозможно.

При нулевом угле поворота шаговой привязки направления изометрических осей следующие: 30, 90 и 150 градусов. Изометрический стиль шаговой привязки позволяет работать в трех плоскостях, каждая из которых определяется своей парой осей:

  • Левая.Сетка и шаговая привязка ориентируются вдоль осей, направленных под углами 90 и 150 градусов.
  • Верхняя.Сетка и шаговая привязка ориентируются вдоль осей, направленных под углами 30 и 150 градусов.
  • Правая.Сетка и шаговая привязка ориентируются вдоль осей, направленных под углами 30 и 90 градусов.

При выборе одной из трех изометрических плоскостей шаговая привязка, сетка и перекрестье курсора поворачиваются соответственно выбранным изометрическим осям. Например, при включенном режиме "Орто" указываемые при рисовании точки располагаются в текущей изометрической плоскости. Таким образом, можно вначале выполнить построения на верхней плоскости модели, затем переключиться в левую плоскость и построить эту сторону модели, и наконец завершить рисование, выбрав правую плоскость.


Задание изометрического стиля шаговой привязки и сетки (Процедура)

Повторная публикация набора пометок
Задание изометрического стиля шаговой привязки и сетки
Задание изометрического стиля шаговой привязки и сетки
Тонирование чертежа для презентации > Построение 2D изометрических видов > Задание изометрического стиля шаговой привязки и сетки >
Задание изометрического стиля шаговой привязки и сетки
Понятие Процедура Краткий справочник

Для включения изометрии

Для быстрой смены изометрической плоскости


Для включения изометрии (Процедура)

Задание изометрического стиля шаговой привязки и сетки
Задание изометрического стиля шаговой привязки и сетки
Задание изометрического стиля шаговой привязки и сетки
Тонирование чертежа для презентации > Построение 2D изометрических видов > Задание изометрического стиля шаговой привязки и сетки >
Задание изометрического стиля шаговой привязки и сетки
Понятие Процедура Краткий справочник

Для включения изометрии

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. В диалоговом окне "Режимы черчения" на вкладке "Шаг и сетка" в поле "Тип привязки" выберите "Изометрическая".
  3. Нажмите "ОК".

Альтернатива

Для циклического переключения между тремя плоскостями можно воспользоваться клавишей F5.

Ввод команды: РЕЖИМРИС


Для быстрой смены изометрической плоскости (Процедура)

Задание изометрического стиля шаговой привязки и сетки
Задание изометрического стиля шаговой привязки и сетки
Построение изометрических кругов
Тонирование чертежа для презентации > Построение 2D изометрических видов > Задание изометрического стиля шаговой привязки и сетки >
Задание изометрического стиля шаговой привязки и сетки
Понятие Процедура Краткий справочник

Для быстрой смены изометрической плоскости

  • Нажмите F5 или CTRL+E для смены изометрической плоскости.

Программа циклически переключается между верхней, правой и левой изометрическими плоскостями.


Задание изометрического стиля шаговой привязки и сетки (Краткий справочник)

Повторная публикация набора пометок
Задание изометрического стиля шаговой привязки и сетки
Построение изометрических кругов
Тонирование чертежа для презентации > Построение 2D изометрических видов > Задание изометрического стиля шаговой привязки и сетки >
Задание изометрического стиля шаговой привязки и сетки
Понятие Процедура Краткий справочник

Команды

РЕЖИМРИС

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

СЕТКА

Отображение точечной сетки на текущем видовом экране, которая не выводится на печать

ИЗОМЕТР

Выбор текущей изометрической плоскости

ОРТО

Ограничение перемещение курсора в вертикальном или горизонтальном направлении

ШАГ

Ограничение перемещения курсора определенными интервалами

Системные переменные

ISOLINES

Количество линий контура для изображения поверхностей объектов

SNAPISOPAIR

Управление плоскостью изометрии для текущего видового экрана

SNAPSTYL

Стиль шаговой привязки для текущего видового экрана

Утилиты

Нет

Ключевые слова для команд

Нет


Построение изометрических кругов (Понятие)

Задание изометрического стиля шаговой привязки и сетки
Построение 2D изометрических видов
Добавление освещения в модель
Тонирование чертежа для презентации > Построение 2D изометрических видов >
Построение изометрических кругов
Понятие Процедура Краткий справочник

Изображение кругов в изометрических плоскостях с помощью эллипсов.

При рисовании на изометрических плоскостях круги, рассматриваемые под углом к плоскости, представляются эллипсами. Наиболее удобный способ построения таких эллипсов обеспечивает параметр "Изокруг" команды ЭЛЛИПС. Функция изоцикличности доступна, только если для параметра "Тип привязки" режима шаговой привязки установить значение "Изометрическая" (см. команду РЕЖИМРИС).

ПримечаниеДля создания концентрических кругов следует построить другие эллипсы с таким же центром. Функция построения подобных объектов дает здесь неверный результат, а именно сплайн овальной формы.


Для построения изометрического круга (Процедура)

Задание изометрического стиля шаговой привязки и сетки
Построение изометрических кругов
Режимы стандартного и фотометрического освещения
Тонирование чертежа для презентации > Построение 2D изометрических видов > Построение изометрических кругов >
Построение изометрических кругов
Понятие Процедура Краткий справочник

Для построения изометрического круга

  1. Выберите меню Сервис [image] Режимы рисования.В командной строке введите "режимрис".
  2. В диалоговом окне "Режимы рисования" на вкладке "Шаг и сетка" выберите "Изометрическая".
  3. Нажмите "ОК".
  4. Выберите Рисование [image] Эллипс [image] Ось, конец.В командной строке введите "эллипс".
  5. Введите и (изокруг).
  6. Укажите центр круга.
  7. Задайте радиус или диаметр круга.
Панель:Рисование
Ввод команды: ЭЛЛИПС


Построение изометрических кругов (Краткий справочник)

Задание изометрического стиля шаговой привязки и сетки
Построение изометрических кругов
Обзор функций освещения
Тонирование чертежа для презентации > Построение 2D изометрических видов > Построение изометрических кругов >
Построение изометрических кругов
Понятие Процедура Краткий справочник

Команды

ЭЛЛИПС

Построение эллипсов и эллиптических дуг

ИЗОМЕТР

Выбор текущей изометрической плоскости

Системные переменные

Нет

Утилиты

Нет

Ключевые слова для команд

Нет


Добавление освещения в модель

Построение изометрических кругов
Тонирование чертежа для презентации
Обзор функций освещения
Тонирование чертежа для презентации >
Добавление освещения в модель

Для создания более реалистичного тонирования в сцене создается освещение.

Темы в этом разделе

  • Обзор функций освещения

    Освещение придает сцене завершенность.

  • Режимы стандартного и фотометрического освещения

    Типы освещения, выбираемые глобально и влияющие на чертеж.

  • Освещение сцены

    В процессе работы можно добавлять различные виды освещения (точечное, прожектор, удалённое), менять их расположение и фотометрические свойства.

  • Регулировка источников света и манипулирование ими

    В процессе работы можно добавлять различные виды освещения (точечное, прожектор, удалённое), менять их расположение и свойства.

  • Имитация солнечного и небесного света

    Солнечный свет - это вид освещения, который создает эффект естественного освещения и используется для демонстрации влияния теней от объекта на окружающий вид.

  • Вставка объектов-светильников

    Объект-светильник представляет собой вспомогательный объект, позволяющий скомбинировать набор объектов в световой блок.

  • Преобразование источников света

    Свойства источников света совместимы с предыдущими выпусками AutoCAD и другими программными продуктами.


Обзор функций освещения (Понятие)

Добавление освещения в модель
Добавление освещения в модель
Режимы стандартного и фотометрического освещения
Тонирование чертежа для презентации > Добавление освещения в модель >
Обзор функций освещения
Понятие Краткий справочник

Освещение придает сцене завершенность.

Освещение по умолчанию

Для затенения сцены, в которой нет источников света, используется освещение по умолчанию. Освещение по умолчанию создается двумя удаленными источниками, следующими за точкой зрения при ее перемещении вокруг модели. Все поверхности модели освещаются таким образом, чтобы визуально отличаться друг от друга. Пользователь может контролировать яркость и контраст, но не связан необходимостью создавать или располагать источники света самостоятельно.

При установке пользовательских источников света или добавлении солнечного света можно отключить освещение по умолчанию. Освещение по умолчанию можно применить только к видовому экрану; в то же время пользовательское освещение можно применить к тонированию.

Режим стандартного освещения

Источники света добавляются для того, чтобы придать сцене более реалистичный вид. Освещение улучшает четкость и трехмерность сцены. Для получения необходимых эффектов освещение можно изменить на точечное, прожекторное или удалённое. С помощью инструментов ручек источники света можно перемещать и вращать, включать и выключать, а также можно менять их свойства, например цвет или затухание. Результаты изменений отображаются на видовом экране в реальном времени.

Прожекторы и точечные источники света представлены разными обозначениями источников света (обозначениями на чертеже, указывающими местоположение источников света). Удаленные источники света и солнце не обозначаются в чертеже, поскольку не занимают определенного положения и освещают всю сцену. Во время работы можно включить или отключить отображение обозначений источников света. По умолчанию обозначения источников света не выводятся на печать.

Режим фотометрического освещения

Для более точного управления освещением модели можно использовать фотометрическое освещение. При фотометрическом освещении используются фотометрические значения, позволяющие с точностью определить источники света и сделать освещение максимально приближенным к реальному. Для создания источников света можно использовать различные характеристики распространения и цвета или импортировать специальные фотометрические файлы, предоставляемые производителями осветительных приборов.

Для описания фотометрических источников света производители могут использовать файлы в формате стандарта IES. С помощью данных об освещении, предоставляемых производителями, в модели можно визуализировать освещение, создаваемое имеющимися в продаже осветительными приборами. Пользователь имеет возможность экспериментировать с различными световыми блоками и, меняя интенсивность света и цветовую температуру, может создать нужную ему систему освещения.

Солнце и небо

Солнечный свет - это особый вариант удалённого освещения. Угол солнечного освещения определяется географическим местоположением, а также датой и временем, которые задаются для конкретной модели. В зависимости от желания пользователя, интенсивность и цвет солнечного света также могут меняться. Солнце и небо являются основными источниками естественного освещения. Функция имитации солнца и неба позволяет настроить их свойства.

В фотометрическом режиме воспроизведение солнечного света как на видовом экране, так и при визуализации окончательного результата более точно соответствует физическим характеристикам. В фотометрическом режиме поддерживается также имитация неба как источника освещения (с помощью функции фона неба); это позволяет создать эффект мягкого рассеянного света, формируемого в результате взаимодействия солнечных лучей с атмосферой.

Для запуска анимации нажмите стрелку "Просмотр".

Объекты-светильники

Осветительные приборы могут быть представлены в виде блоков, в которые включены как источники света, так и геометрические объекты (световых блоков). Cветильник - это набор источников света, скомбинированный в световой блок.

См. также

    • Получение новостей и обновлений программы


Обзор функций освещения (Краткий справочник)

Построение изометрических кругов
Обзор функций освещения
Режимы стандартного и фотометрического освещения
Тонирование чертежа для презентации > Добавление освещения в модель > Обзор функций освещения >
Обзор функций освещения
Понятие Краткий справочник

Команды

ПРЕОБРУСТАРСВЕТ

Преобразование источников света, созданных в чертежах формата предыдущих версий, в формат текущей версии

УДАЛСВЕТ

Создание удаленного источника света

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБПРОЖЕКТОР

Создание свободного прожектора, подобного прожектору без заданной цели

СВОБСЕТСВЕТ

Создание свободной световой сетки, подобной световой сетке без заданной цели

ТОЧСВЕТ

Создание точечного источника света

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

ПРОЖЕКТОР

Создание прожектора

СВОЙСТВАСОЛНЦА

Вызов окна "Свойства солнца" для определения свойств солнечного освещения

ТОЧКАЦЕЛИ

Создание целевого точечного источника света

СЕТСВЕТ

Создание световой сетки

Системные переменные

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

SUNSTATUS

Управление излучением солнечного света на текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Режимы стандартного и фотометрического освещения (Понятие)

Обзор функций освещения
Добавление освещения в модель
Освещение сцены
Тонирование чертежа для презентации > Добавление освещения в модель >
Режимы стандартного и фотометрического освещения
Понятие Процедура Краткий справочник

Типы освещения, выбираемые глобально и влияющие на чертеж.

Задание типа освещения

В AutoCAD можно использовать три варианта единиц измерения освещения: стандартные (общие), международные (СИ) и американские. Режим стандартного (общего) освещения не отличается от режима освещения, реализованного в версиях AutoCAD, предшествующих AutoCAD 2008. В AutoCAD 2008 в качестве освещения по умолчанию используется фотометрическое освещение на основе единиц измерения освещения из международной системы (СИ). Этот вариант дает физически правильные результаты. Единицы освещения, применяемые в США, предоставляют другие опции. В отличие от международной системы единиц, в американской системе единиц освещенность выражается не в люксах, а в фут-канделах.

В предыдущих версиях AutoCAD стандартное освещение принималось по умолчанию. С помощью системной переменной LIGHTINGUNITS можно изменить тип освещения. Значение 0 системной переменной LIGHTINGUNITS соответствует стандартному (общему) освещению); значение 1 соответствует фотометрическому освещению с применением международной системы единиц (СИ); значение 2 соответствует фотометрическому освещению с применением американской системы единиц.

Фотометрические источники света

Фотометрические источники света являются физически правильными. При физически правильном освещении затухание происходит пропорционально квадрату расстояния от источника. Фотометрические свойства можно добавить как в искусственные, так и в естественные источники света. Естественными источниками света являются солнечный и небесный свет. Естественное освещение задается интерактивно путем указания типа фона в видовом экране.

Для создания источников света можно использовать различные характеристики распространения и цвета или импортировать специальные фотометрические файлы, предоставляемые производителями осветительных приборов. Свет фотометрических источников всегда затухает в соответствии с обратной квадратической зависимостью и зависит от единиц, используемых в сцене.

Наложение тонов

При работе с фотометрическими источниками света, особенно с солнечным светом, как правило, требуется задать соответствие тонов. Настроить соответствие тонов можно с помощью команды ТОНИРЭКСПОЗ . В диалоговом окне "Регулировка экспозиции тонирования" предусмотрена область предварительного просмотра, а также управляющие элементы для настройки соответствия тонов.


Режимы стандартного и фотометрического освещения (Процедура)

Построение изометрических кругов
Режимы стандартного и фотометрического освещения
Режимы стандартного и фотометрического освещения
Тонирование чертежа для презентации > Добавление освещения в модель > Режимы стандартного и фотометрического освещения >
Режимы стандартного и фотометрического освещения
Понятие Процедура Краткий справочник

Процедура задания режима стандартного освещения для чертежа

Процедура задания режима фотометрического освещения для чертежа


Процедура задания режима стандартного освещения для чертежа (Процедура)

Режимы стандартного и фотометрического освещения
Режимы стандартного и фотометрического освещения
Режимы стандартного и фотометрического освещения
Тонирование чертежа для презентации > Добавление освещения в модель > Режимы стандартного и фотометрического освещения >
Режимы стандартного и фотометрического освещения
Понятие Процедура Краткий справочник

Процедура задания режима стандартного освещения для чертежа

  • В командной строке введите " LIGHTINGUNITS " и задайте значение 0, соответствующее стандартному освещению.

    При добавлении каждого источника света ему назначаются стандартные свойства освещения.


Процедура задания режима фотометрического освещения для чертежа (Процедура)

Режимы стандартного и фотометрического освещения
Режимы стандартного и фотометрического освещения
Освещение сцены
Тонирование чертежа для презентации > Добавление освещения в модель > Режимы стандартного и фотометрического освещения >
Режимы стандартного и фотометрического освещения
Понятие Процедура Краткий справочник

Процедура задания режима фотометрического освещения для чертежа

  • В командной строке введите " LIGHTINGUNITS " и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.

    При добавлении каждого источника света ему назначаются фотометрические свойства освещения.


Режимы стандартного и фотометрического освещения (Краткий справочник)

Обзор функций освещения
Режимы стандартного и фотометрического освещения
Принципы освещения
Тонирование чертежа для презентации > Добавление освещения в модель > Режимы стандартного и фотометрического освещения >
Режимы стандартного и фотометрического освещения
Понятие Процедура Краткий справочник

Команды

Нет записей

Системные переменные

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

LOGEXPPHYSICALSCALE

Управление относительной яркостью самосветящихся материалов в фотометрической среде

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Освещение сцены

Режимы стандартного и фотометрического освещения
Добавление освещения в модель
Принципы освещения
Тонирование чертежа для презентации > Добавление освещения в модель >
Освещение сцены
Понятие Процедура

В процессе работы можно добавлять различные виды освещения (точечное, прожектор, удалённое), менять их расположение и фотометрические свойства.

Создать источник света можно путем ввода команды либо с помощью кнопки на панели инструментов "Источники света" или на панели "Источники света" ленты. Цвет и другие особенности выбранного освещения можно изменить с помощью палитры свойств. Источник света и его свойства можно сохранить в инструментальной палитре и использовать в дальнейшем как в текущем чертеже, так и в других чертежах.

Темы в этом разделе

  • Принципы освещения

    Принципы работы с освещением, используемые фотографами, кино- и театральными режиссерами, могут быть полезны при настройке освещения сцены.

  • Использование точечных источников света

    Точечный источник света испускает лучи во всех направлениях.

  • Использование прожекторов

    Свет прожектора может быть направлен на объект.

  • Использование световых сеток

    Фотометрическая световая сетка обеспечивает освещение, приближенное к реальному.

  • Использование удалённых источников света

    Удаленные источники света удобны для освещения и объектов, и фона.

  • Назначение формы источнику света

    Назначение формы источнику света изменяет освещенность сцены.


Освещение сцены (Процедура)

Режимы стандартного и фотометрического освещения
Освещение сцены
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены >
Освещение сцены
Понятие Процедура

Для создания точечного источника света в режиме стандартного освещения

Для создания точечного источника света в фотометрическом режиме и изменения его фотометрических свойств

Для создания направленного точечного источника света в режиме стандартного освещения

Процедура создания направленного точечного источника света из обычного точечного источника света

Для создания инструмента точечного источника света

Создание прожектора

Процедура создания фотометрического прожектора и изменения фотометрических свойств

Для создания свободного прожектора в режиме фотометрического освещения

Для создания инструмента прожектора

Для создания сетки распределения с помощью файла IES от изготовителя

Создание удалённого источника света

Для создания точечного источника в фотометрическом режиме и назначения ему прямоугольной формы


Принципы освещения (Понятие)

Освещение сцены
Освещение сцены
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены >
Принципы освещения
Понятие Краткий справочник

Принципы работы с освещением, используемые фотографами, кино- и театральными режиссерами, могут быть полезны при настройке освещения сцены.

Освещение выбирается в зависимости от того, требует ли сцена естественного освещения или искусственного. В сценах с естественным освещением, например с дневным или лунным светом, большая часть света поступает от одного источника света. Сцены с искуственным освещением часто освещаются несколькими источниками света одинаковой интенсивности.

Естественное освещение

Из практических соображений принято считать, что на уровне поверхности земли солнечный свет распространяется параллельными лучами, в одном направлении. Напрвление и угол падения лучей могут меняться в зависимости от времени суток, географической широты и времени года.

В ясную погоду солнечный свет имеет бледно-желтый цвет: например, со значениями RGB 250, 255, 175 (HSV 45, 80, 255). Облачная погода может добавить к солнечному свету голубой оттенок, а дождливая погода может затенить его до темно-серого цвета. Частицы, взвешенные в воздухе, могут придать солнечному свету оранжевый или коричневатый оттенок. При восходе и заходе солнца цвет может быть не желтым, а скорее оранжевым или красным.

В ясный день тени становятся более насыщенными; они являются важнейшим элементом сцены с естественным освещением, внося в нее ощущение трехмерности.

В качестве направленного света может использоваться и лунный свет - белый, но более темный, чем солнечный.

Искусственное освещение

Сцена, освещенная точечными источниками света, прожекторами или удаленными источниками света, считается сценой с искусственным освещением. Поэтому полезно знать закономерности распространения света.

Когда лучи света падают на поверхность, поверхность отражает их, или по крайней мере некоторые из них, позволяя нам видеть поверхность. То, как поверхность выглядит, зависит от света, который на нее падает, а также от свойств материала поверхности, таких как цвет, гладкость, прозрачность.

Свойства источника освещения, например цвет, интенсивность, затухание и угол падения, также играют свою роль в том, как объекты выглядят в сцене.


Принципы освещения (Краткий справочник)

Режимы стандартного и фотометрического освещения
Принципы освещения
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Принципы освещения >
Принципы освещения
Понятие Краткий справочник

Команды

УДАЛСВЕТ

Создание удаленного источника света

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБПРОЖЕКТОР

Создание свободного прожектора, подобного прожектору без заданной цели

ТОЧСВЕТ

Создание точечного источника света

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

ПРОЖЕКТОР

Создание прожектора

ТОЧКАЦЕЛИ

Создание целевого точечного источника света

Системные переменные

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование точечных источников света (Понятие)

Принципы освещения
Освещение сцены
Использование прожекторов
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены >
Использование точечных источников света
Понятие Процедура Краткий справочник

Точечный источник света испускает лучи во всех направлениях.

Точечные источники света

Точечный источник света испускает лучи во всех направлениях. Точечный свет не направлен на объект. Их широко используют для создания общих эффектов освещения, Точечный источник света можно создать, введя команду ТОЧСВЕТ или выбрав его на панели "Источники света" на ленте.

Для создания направленного точечного источника света используется команда " ТОЧКАЦЕЛИ ". Направленный точечный свет отличается от точеченого света дополнительными свойствами направленности. Направленный точечный источник света может быть направлен на объект. Можно также создать направленный точечный источник света из обычного точечного источника света; для этого следует изменить значение свойства "Нацеленный" для точечного источника света с "Нет" на "Да".

В режиме стандартного освещения можно задать уменьшение интенсивности точечного света с увеличением расстояния вручную: в соответствии с линейной зависимостью, в соответствии с обратной квадратичной зависимостью или без уменьшения. По умолчанию затухание отсутствует.

Точечные источники света в фотометрическом режиме

Для свободного точечного источника света могут быть заданы свойства фотометрического распределения. В режиме фотометрического освещения затухание точечного света всегда выполняется в соответствии с обратной квадратичной зависимостью.

При установке переменной системы LIGHTINGUNITS на 1 (Международная система единиц СИ) или 2 (Единицы, применяемые в США) доступны дополнительные свойства точечного источника света. На палитре "Свойства" доступны следующие фотометрические свойства.

  • Интенсивность лампы. Определяет собственную яркость источника света. Задает для лампы интенсивность, световой поток и освещенность.
  • Итоговая интенсивность. Указывает фактическую яркость источника света. (Произведение интенсивности лампы на коэффициент интенсивности. Доступно только для чтения.)
  • Цвет лампы. Задает собственный цвет источника света в температуре по Кельвину или по стандарту.
  • Итоговый цвет.Указывает фактический цвет источника света. Это значение определяется комбинацией цвета лампы и цвета фильтра. (Определяется цветом лампы и цветом фильтра. Доступно только для чтения.)
ПримечаниеПри использовании в чертеже фотометрических единиц свойство "Тип затухания" отключается. Фотометрические источники света имеют фиксированное затухание в соответствии с обратной квадратической зависимостью.

Дополнительные сведения об этих свойствах приведены в Свойства освещения. На следующем рисунке показан пример фотометрического точечного источника света, а также палитра свойств освещения, на которой фотометрические свойства выделены рамкой.


Использование точечных источников света (Процедура)

Освещение сцены
На уровень вверх ..
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование точечных источников света >
Использование точечных источников света
Понятие Процедура Краткий справочник

Для создания точечного источника света в режиме стандартного освещения

Для создания точечного источника света в фотометрическом режиме и изменения его фотометрических свойств

Для создания направленного точечного источника света в режиме стандартного освещения

Процедура создания направленного точечного источника света из обычного точечного источника света

Для создания инструмента точечного источника света


Для создания точечного источника света в режиме стандартного освещения (Процедура)

Использование точечных источников света
На уровень вверх ..
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование точечных источников света >
Использование точечных источников света
Понятие Процедура Краткий справочник

Для создания точечного источника света в режиме стандартного освещения

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. Введите точка в командной строке.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  5. Два раза нажмите клавишу ENTER для завершения команды.

    Выберите источник света и измените его с помощью инструментов ручек. Можно также щелкнуть на источнике света правой кнопкой мыши и затем выбрать "Свойства". Для изменения свойств источника света используется окно Свойства освещения.

    Панель:Источники света
    Ввод команды: ТОЧСВЕТ


Для создания точечного источника света в фотометрическом режиме и изменения его фотометрических свойств (Процедура)

Использование точечных источников света
На уровень вверх ..
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование точечных источников света >
Использование точечных источников света
Понятие Процедура Краткий справочник

Для создания точечного источника света в фотометрическом режиме и изменения его фотометрических свойств

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. Введите точка в командной строке.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  5. Два раза нажмите клавишу ENTER для завершения команды.

    Выберите источник света и измените его с помощью инструментов ручек.

  6. Щелкните на источнике света правой кнопкой мыши. Нажмите кнопку "Свойства". Изменить фотометрические свойства можно в окне " Свойства освещения".
    Панель:Источники света
    Ввод команды: ТОЧСВЕТ


Для создания направленного точечного источника света в режиме стандартного освещения (Процедура)

Использование точечных источников света
На уровень вверх ..
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование точечных источников света >
Использование точечных источников света
Понятие Процедура Краткий справочник

Для создания направленного точечного источника света в режиме стандартного освещения

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. В командной строке введите точкацели.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. Щелкните для задания точки цели.
  5. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  6. Два раза нажмите клавишу ENTER для завершения команды.

    Щелкните на источнике света правой кнопкой мыши. Нажмите кнопку "Свойства". Для изменения источника света можно воспользоваться палитрой " Свойства освещения". Обратите внимание на дополнительные свойства, определяющее местоположение цели; для обычных точечных источников света эти свойства отсутствуют.

    Ввод команды: ТОЧКАЦЕЛИ


Процедура создания направленного точечного источника света из обычного точечного источника света (Процедура)

Использование точечных источников света
На уровень вверх ..
Использование точечных источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование точечных источников света >
Использование точечных источников света
Понятие Процедура Краткий справочник

Процедура создания направленного точечного источника света из обычного точечного источника света

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. Введите точка в командной строке.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  5. Два раза нажмите клавишу ENTER для завершения команды.
  6. Нажмите правую кнопку мыши на источнике света и нажмите Свойства на палитре Свойства освещения. Измените значение свойства "Нацеленный" на "Да".

    Становятся доступны дополнительные свойства цели: целевая координата X, целевая координата Y и целевая координата Z.

    ПримечаниеПри превращении точечного источника света в направленный название источника остается тем же. Если в названии по-прежнему упоминается точечный источник, можно сменить название.
    Панель:Источники света
    Ввод команды: ТОЧСВЕТ


Для создания инструмента точечного источника света (Процедура)

Использование точечных источников света
На уровень вверх ..
Использование прожекторов
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование точечных источников света >
Использование точечных источников света
Понятие Процедура Краткий справочник

Для создания инструмента точечного источника света

  1. Выберите меню Сервис [image] Палитры [image] Инструментальные палитры. В командной строке введите "ИнстрПалвкл".
  2. Выберите на чертеже точечный источник света, свойства которого будут использованы для инструмента.
  3. Перетащите источник света в действующую палитру инструментов.

    При этом у нового инструмента источника света сохранятся все исходные свойства, исключая местоположение.


Использование точечных источников света (Краткий справочник)

Принципы освещения
Использование точечных источников света
Использование прожекторов
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование точечных источников света >
Использование точечных источников света
Понятие Процедура Краткий справочник

Команды

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

ТОЧСВЕТ

Создание точечного источника света

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

ТОЧКАЦЕЛИ

Создание целевого точечного источника света

Системные переменные

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование прожекторов (Понятие)

Использование точечных источников света
Освещение сцены
Использование световых сеток
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены >
Использование прожекторов
Понятие Процедура Краткий справочник

Свет прожектора может быть направлен на объект.

Прожекторы

Распределение прожектора имитирует падение сфокусированного луча света, подобного свету от ручного электрического фонаря, следящего прожектора в театре или фары. Прожектор испускает направленный конус света. Имеется возможность управлять направлением света и размером конуса. Как и точечный источник света, прожектор можно вручную настроить на затухание интенсивности с увеличением расстояния. Кроме того, интенсивность света прожектора всегда затухает в соответствии с углом, связанным с оптической осью прожектора. Затухание зависит от положения светового пятна и углов спада освещенности для данного прожектора. Прожекторы служат для выделения конкретных компонентов и участков модели. Свободный прожектор ( СВОБПРОЖЕКТОР ) аналогичен прожектору. Для прожектора предусмотрены свойства направленного источника света.

Прожекторы в фотометрическом режиме

В режиме фотометрического освещения интенсивность в области максимальной интенсивности снижается до 50 процентов. В режиме стандартного освещения интенсивность в области максимальной интенсивности (пятна) равна 100 процентам. На границе светового конуса интенсивность освещения падает до нуля. Задание значения 1 (международная система единиц СИ) или 2 (американская система единиц) для системной переменной LIGHTINGUNITS обеспечивает доступ к указанным ниже дополнительным свойствам точечных источников света.

  • Интенсивность лампы. Определяет собственную яркость источника света. Задается интенсивность, световой поток или освещенность для лампы.
  • Итоговая интенсивность. Указывает фактическую яркость источника света. (Произведение интенсивности лампы на коэффициент интенсивности. Доступно только для чтения.)
  • Цвет лампы. Задает собственный цвет источника света в температуре по Кельвину или по стандарту.
  • Итоговый цвет.Указывает фактический цвет источника света. Это значение определяется комбинацией цвета лампы и цвета фильтра. (Определяется цветом лампы и цветом фильтра. Доступно только для чтения.)
ПримечаниеПри использовании в чертеже фотометрических единиц свойство "Тип затухания" отключается. Фотометрические источники света имеют фиксированное затухание в соответствии с обратной квадратической зависимостью. Спад освещенности светового пятна в тонированном изображении отличается от стандартного освещения, так как для его вычисления применяются другие математические формулы.

Дополнительные сведения об этих свойствах имеются в Свойства освещения. Ниже показан пример фотометрического прожектора и палитры свойств освещения; фотометрические свойства выделены рамкой.


Использование прожекторов (Процедура)

Использование точечных источников света
На уровень вверх ..
Использование прожекторов
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование прожекторов >
Использование прожекторов
Понятие Процедура Краткий справочник

Создание прожектора

Процедура создания фотометрического прожектора и изменения фотометрических свойств

Для создания свободного прожектора в режиме фотометрического освещения

Для создания инструмента прожектора


Создание прожектора (Процедура)

Использование прожекторов
На уровень вверх ..
Использование прожекторов
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование прожекторов >
Использование прожекторов
Понятие Процедура Краткий справочник

Создание прожектора

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. Введите прожектор в командной строке.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. Нажатием кнопки мыши устанавливается направление прожектора.
  5. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  6. Два раза нажмите клавишу ENTER для завершения команды.

    Выберите источник света и измените его с помощью инструментов ручек. Можно также щелкнуть на источнике света правой кнопкой мыши и выбрать "Свойства". Измените свойства с помощью палитры " Свойства освещения".

    Панель:Источники света
    Ввод команды: ПРОЖЕКТОР


Процедура создания фотометрического прожектора и изменения фотометрических свойств (Процедура)

Использование прожекторов
На уровень вверх ..
Использование прожекторов
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование прожекторов >
Использование прожекторов
Понятие Процедура Краткий справочник

Процедура создания фотометрического прожектора и изменения фотометрических свойств

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. Введите прожектор в командной строке.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. Нажатием кнопки мыши устанавливается направление прожектора.
  5. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  6. Два раза нажмите клавишу ENTER для завершения команды.

    Выберите источник света и измените его с помощью инструментов ручек.

  7. Для изменения свойств щелкните правой кнопкой мыши на источнике света. Нажмите кнопку "Свойства". Измените фотометрические свойства с помощью палитры " Свойства освещения".
    Панель:Источники света
    Ввод команды: ПРОЖЕКТОР


Для создания свободного прожектора в режиме фотометрического освещения (Процедура)

Использование прожекторов
На уровень вверх ..
Использование прожекторов
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование прожекторов >
Использование прожекторов
Понятие Процедура Краткий справочник

Для создания свободного прожектора в режиме фотометрического освещения

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. В командной строке введите свобпрожектор.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  5. Два раза нажмите клавишу ENTER для завершения команды.

    Выберите источник света и измените его с помощью инструментов ручек.

  6. Для изменения свойств щелкните правой кнопкой мыши на источнике света. Нажмите кнопку "Свойства". Изменить фотометрические свойства можно в окне " Свойства освещения".
    Панель:Источники света
    Ввод команды: ПРОЖЕКТОР


Для создания инструмента прожектора (Процедура)

Использование прожекторов
На уровень вверх ..
Использование световых сеток
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование прожекторов >
Использование прожекторов
Понятие Процедура Краткий справочник

Для создания инструмента прожектора

  1. Выберите меню Сервис [image] Палитры [image] Инструментальные палитры. В командной строке введите "ИнстрПалвкл".
  2. Выберите на чертеже прожектор, свойства которого будут использованы для инструмента.
  3. Перетащите источник света в действующую палитру инструментов.

    При этом у нового инструмента источника света сохранятся все исходные свойства, исключая местоположение.


Использование прожекторов (Краткий справочник)

Использование точечных источников света
Использование прожекторов
Использование световых сеток
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование прожекторов >
Использование прожекторов
Понятие Процедура Краткий справочник

Команды

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБПРОЖЕКТОР

Создание свободного прожектора, подобного прожектору без заданной цели

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

ПРОЖЕКТОР

Создание прожектора

Системные переменные

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование световых сеток (Понятие)

Использование прожекторов
Освещение сцены
Формат файла стандарта IES
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены >
Использование световых сеток
Понятие Процедура Краткий справочник

Фотометрическая световая сетка обеспечивает освещение, приближенное к реальному.

Фотометрическая световая сетка - это 3D представление распределения интенсивности света, излучаемого источником. С помощью фотометрических сеточных источников света можно получить анизотропное (неравномерное) распределение освещенности, вычисленное на основе данных, которые предоставляются изготовителями реальных источников света. Использование световых сеток позволяет создать гораздо более точное, по сравнению с точечными источниками или прожекторами, представление об освещении, получаемом в итоге.

Информация о распространении света по направлениям хранится в файле фотометрических данных в формате для фотометрических данных согласно стандарту IES LM-63-1991. С помощью панели "Фотометрическая сетка" на палитре "Свойства" для источников света можно загрузить файлы фотометрических данных, предоставляемые различными изготовителями. Значок с изображением источника света представляет выбранную фотометрическую сетку.

Для добавления к чертежу источников света, в которых используется фотометрическая сетка, можно ввести в командной строке команды СЕТСВЕТ и СВОБСЕТСВЕТ . В отличие от свободных сеточных источников света, обычные сеточные источники света направлены на объекты.

Для описания распределения по направлениям для света, излучаемого источником, AutoCAD аппроксимирует этот источник точечным источником света, помещенным в фотометрический центр. В соответствии с этой аппроксимацией распределение характеризуется как функция только исходящего направления. Для предварительно заданного набора горизонтальных и вертикальных углов предоставляются данные об интенсивности света источника, а интенсивность света вдоль произвольного направления система может рассчитать методом интерполяции.

ПримечаниеСеточное распределение применяется только в тонированных изображениях. На видовых экранах отображается приближенное изображение сеточных источников света.
ПримечаниеРазмер обозначения света задается в меню Сервис > Настройка > Построения > Настройки обозначения источников света. Некоторые обозначения сеток могут выглядеть на экране очень маленькими, поэтому для них требуется настройка размеров.

Гониометрические диаграммы

Фотометрические данные часто изображаются в виде гониометрических диаграмм.

Гониометрическая диаграмма сеточного распределения

На диаграмме этого типа видно, как интенсивность света от источника меняется в зависимости от вертикального угла. Горизонтальный угол остается фиксированным и, если распределение не имеет осевой симметрии, для полного описания распределения может понадобиться несколько гониометрических диаграмм.

Фотометрические сетки

Фотометрическая сетка является трехмерным представлением распределения света. Использование фотометрической сетки позволяет расширить гониометрическую диаграмму до трех измерений, так, чтобы одновременно были видны зависимости интенсивности света по вертикальному и горизонтальному углам. В центре фотометрической сетки помещается центр источника света.

Интенсивность света в любом направлении пропорциональна расстоянию между этой сеткой и фотометрическим центром, измеренным по прямой линии, исходящей из центра в заданном направлении.

Пример изотропного распределения

Примером изотропного распределения может служить сфера, центр которой находится в начале координат. Все точки на диаграмме равноудалены от центра, поэтому свет излучается во всех направлениях одинаково.

Пример эллипсоидального распределения

В этом примере точки отрицательного направления оси Z находятся на таком же расстоянии от начала координат, как и точки положительного направления оси Z, и таким образом вверх и вниз излучается одинаковое количество света. Ни одна из точек не имеет слишком больших компонент X или Y, ни положительных, ни отрицательных, поэтому в стороны от источника света излучается меньше света.

Темы в этом разделе

  • Формат файла стандарта IES

    Пользователь может создавать и изменять форматы файлов стандарта IES.

  • Распространенные значения ламп для фотометрических источников света

    В инструментальной палитре "Освещение" имеется список распространенных ламп, используемых для описания фотометрических источников света.


Для создания сетки распределения с помощью файла IES от изготовителя (Процедура)

Использование прожекторов
На уровень вверх ..
Использование удалённых источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование световых сеток >
Использование световых сеток
Понятие Процедура Краткий справочник

Для создания сетки распределения с помощью файла IES от изготовителя

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. В командной строке введите окносв для активизации палитры свойств.
  3. Введите прожектор в командной строке.
  4. Выберите на чертеже источник света. Свойства прожектора отображаются на палитре "Свойства".
  5. На панели "Общие" измените тип освещения с прожектора на сетку.
  6. На панели "Фотометрическая сетка" выберите незаполненное текстовое поле.
  7. Нажмите кнопку "Обзор" и выберите файл IES.

    Источник света изменяется в соответствии с сеткой распределения, построенной на основе параметров сетки из файла IES.

    Ввод команды: СЕТСВЕТ
    Ввод команды: СВОБСЕТСВЕТ


Использование световых сеток (Краткий справочник)

Использование прожекторов
Использование световых сеток
Формат файла стандарта IES
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование световых сеток >
Использование световых сеток
Понятие Процедура Краткий справочник

Команды

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБСЕТСВЕТ

Создание свободной световой сетки, подобной световой сетке без заданной цели

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

СЕТСВЕТ

Создание световой сетки

Системные переменные

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

SUNSTATUS

Управление излучением солнечного света на текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Формат файла стандарта IES (Понятие)

Использование световых сеток
Использование световых сеток
Распространенные значения ламп для фотометрических источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование световых сеток >
Формат файла стандарта IES
Понятие Краткий справочник

Пользователь может создавать и изменять форматы файлов стандарта IES.

Создать файл фотометрических данных в формате IES можно с помощью формата файла стандарта IES LM-63-1991 для фотометрических данных. IES расшифровывается как Illuminating Engineering Society, Светотехническое инженерное общество (США). В данном разделе приводится только информация, относящаяся к AutoCAD. Полное описание формата файлов по стандарту IES приведено в документе "Формат файлов по стандарту IES для электронного переноса фотометрических данных и сопутствующая информация", подготовленном комитетом по компьютерам (http://www.iesna.org).

Распределение интенсивности света (LID) измеряется в узлах фотометрической сетки для фиксированного набора горизонтальных и вертикальных углов. Полюса сетки лежат на вертикальной оси, где направление "вертикально вниз" соответствует вертикальному углу в 0 градусов. Горизонтальная ось соответствует горизонтальному углу 0 градусов и ориентирована параллельно длине светильника. Этот тип фотометрической сетки создается с помощью гониометра типа "С"; он распространен в Северной Америке. Формат файла стандарта IES поддерживает и другие типы гониометрии, которые, однако, здесь не рассматриваются.

Фотометрические данные хранятся в файле формата ASCII. Строка файла должна иметь длину не более 132 символов и должна заканчиваться последовательностью символов "возврат каретки/перевод строки". Для продолжения длинных строк необходимо использовать последовательность символов "возврата каретк/перевод строки".

Каждое поле файла должно начинаться с новой строки, а данные должны размещаться в следующей последовательности:

  1. IESNA91
  2. [ТЕСТ] Номер отчета о данных тестирования
  3. [MANUFAC] Изготовитель светильника
  4. TILT=NONE
  5. 1
  6. Номинальный начальный световой поток для лампы, используемой в тесте, или -1, если используются абослютные значения фотометрии, а интенсивность не зависит от номиналов лампы.
  7. Коэффициент умножения для всех значений силы света в файле. Коэффициент умножения позволяет масштабировать все значения силы света в файле, когда измерительное устройство оперирует нестандартными единицами измерения, например если фотометрические значения получены из каталога путем измерения линейкой гониометрической диаграммы. Обычно коэффициент умножения равен 1.
  8. Число вертикальных углов в фотометрической сетке.
  9. Число горизонтальных углов в фотометрической сетке.
  10. 1
  11. Тип единицы измерения размеров светового отверстия. Для измерения в футах используется значение 1, для измерения в метрах используется значение 2.
  12. Ширина, длина и высота светового отверстия. Обычно эти значения указываются как 0 0 0.
  13. 1.0 1.0 0.0
  14. Набор значений вертикальных углов в порядке уменьшения. Если распределение лежит полностью в нижнем полушарии, первый и последний углы должны быть равны, соответственно, 0° и 90°. Если распределение лежит полностью в верхнем полушарии, первый и последний углы должны быть равны, соответственно, 90° и 180°. Во всех других случаях они равны, соответственно, 0° и 180°.
  15. Набор значений горизонтальных углов в порядке увеличения. Первый угол должен быть равен 0°. Последний угол определяет степень боковой симметрии, показанной распределением интенсивности. Если он равен 0°, распределение имеет осевую симметрию. Если он равен 90°, распределение симметрично по четвертям. Если он равен 180°, распределение симметрично относительно вертикальной плоскости. Если этот угол больше 180°, но меньше или равен 360°, распределение не обладает боковой симметрией. Любые другие значения недопустимы.
  16. Набор значений силы света. Список начинается со значений в канделах, соответствующих первому горизонтальному углу; первое значение в списке соответствует наименьшему вертикальному углу, а порядок последующих значений соответствует движению вверх в вертикальной плоскости. Затем представлены значения в канделах, соответствующие вертикальной плоскости, которая определяется вторым горизонтальных углом, и так далее до последнего горизонтального угла. Набор значений для каждого вертикального разреза должен начинаться на новой строке. Если необходимо, создавайте разрывы между значениями в длинных строках, следуя инструкциям, изложенным выше.

Пример файла фотометрических данных

Ниже дан пример файла фотометрических данных.


Формат файла стандарта IES (Краткий справочник)

Использование световых сеток
Использование световых сеток
Распространенные значения ламп для фотометрических источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование световых сеток > Формат файла стандарта IES >
Формат файла стандарта IES
Понятие Краткий справочник

Команды

ПРЕОБРУСТАРСВЕТ

Преобразование источников света, созданных в чертежах формата предыдущих версий, в формат текущей версии

УДАЛСВЕТ

Создание удаленного источника света

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБПРОЖЕКТОР

Создание свободного прожектора, подобного прожектору без заданной цели

СВОБСЕТСВЕТ

Создание свободной световой сетки, подобной световой сетке без заданной цели

ТОЧСВЕТ

Создание точечного источника света

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

ПРОЖЕКТОР

Создание прожектора

СВОЙСТВАСОЛНЦА

Вызов окна "Свойства солнца" для определения свойств солнечного освещения

ТОЧКАЦЕЛИ

Создание целевого точечного источника света

СЕТСВЕТ

Создание световой сетки

Системные переменные

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

SUNSTATUS

Управление излучением солнечного света на текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Распространенные значения ламп для фотометрических источников света (Понятие)

Формат файла стандарта IES
Использование световых сеток
Использование удалённых источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование световых сеток >
Распространенные значения ламп для фотометрических источников света
Понятие Краткий справочник

В инструментальной палитре "Освещение" имеется список распространенных ламп, используемых для описания фотометрических источников света.

В инструментальной палитре "Освещение" доступны значения для часто используемых ламп (флуоресцентных, натриевых низкого давления, ламп накаливания, газоразрядных).


Распространенные значения ламп для фотометрических источников света (Краткий справочник)

Формат файла стандарта IES
Использование световых сеток
Управление отображением источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование световых сеток > Распространенные значения ламп для фотометрических источников света >
Распространенные значения ламп для фотометрических источников света
Понятие Краткий справочник

Команды

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБСЕТСВЕТ

Создание свободной световой сетки, подобной световой сетке без заданной цели

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

СЕТСВЕТ

Создание световой сетки

Системные переменные

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Использование удалённых источников света (Понятие)

Распространенные значения ламп для фотометрических источников света
Освещение сцены
Назначение формы источнику света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены >
Использование удалённых источников света
Понятие Процедура

Удаленные источники света удобны для освещения и объектов, и фона.

Удаленные источники света в режиме стандартного освещения

Удаленный источник света испускает параллельные лучи только в одном направлении. Для задания направления распространения света в любом месте видового экрана задаются точки ОТКУДА и КУДА. Точечные источники света и прожектора показываются различными обозначениями источников света. Удаленные источники света не имеют обозначений в чертеже, поскольку не занимают определенного положения и освещают всю сцену.

Интенсивность освещения в этом случае не зависит от расстояния, оставаясь постоянной в любой точке. Удаленные источники света удобны для равномерного освещения и объектов, и фона.

ПримечаниеНе рекомендуется включать удаленные источники света в состав блоков.

Удаленные источники света в фотометрическом режиме

Удаленные источники света не являются физически точными. Использовать их в фотометрическом режиме не рекомендуется.


Создание удалённого источника света (Процедура)

Использование световых сеток
На уровень вверх ..
Назначение формы источнику света
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Использование удалённых источников света >
Использование удалённых источников света
Понятие Процедура

Создание удалённого источника света

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. Введите удалсвет в командной строке.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. Затем определяется направление светового луча.
  5. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  6. Два раза нажмите клавишу ENTER для завершения команды. Удаленные источники света не отображаются в виде обозначений источников света.

    Процедура изменения свойств удаленного источника света В командной строке введите "списоксвет". В окне "Источники света в модели" дважды щелкните на имени удаленного источника света в списке источников света и измените его цвет и другие свойства с помощью палитры " Свойства освещения".

    Панель:Источники света
    Ввод команды: УДАЛСВЕТ


Назначение формы источнику света (Понятие)

Использование удалённых источников света
Освещение сцены
Регулировка источников света и манипулирование ими
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены >
Назначение формы источнику света
Понятие Процедура

Назначение формы источнику света изменяет освещенность сцены.

Поверхностные и линейные источники света

Параметр "Площадь" является свойством источника света. Помимо цвета, источнику света можно назначить форму. Например, источнику света можно придать форму прямоугольника, и он станет действовать наподобие панельного потолочного освещения. Можно также придать источнику света форму линии, например, для имитации узкой люминесцентной лампы. Площадной свет является способом задания формы источника света. Тонирование и тени для различных форм источников света различаются подобно тому, как в реальном мире свет панельного источника отличается от света трубки.

Свойство, определяющее форму, задается с помощью палитры инструментов " Свойства освещения". Это свойство выводится на палитре на основе типа выбранного свойства. Свойство "Тип" настраивается в панели "Сведения о тонировании теней". Оно определяет тип тени, создаваемой светом. Имеются следующие типы: мягкая (карта), резкая (по умолчанию) и мягкая (выборочная) Если выбрано значение "Мягкое (выборочное)", доступно свойство "Форма".

Набор доступных форм зависит от типа источника света. Свойство "Тип" для распределения освещенности можно выбрать на панели "Общие" палитры "Свойства освещения". Если выбраны значения "Прожектор" и "Мягкое (выборочное)", доступны формы следующих типов: "Прямоугольный" и "Дисковая". Если выбраны значения "Точечный" и "Мягкое (выборочное)", доступны следующие формы: "Линейная", "Прямоугольный", "Дисковая", "Цилиндрическая" и "Сферическая". Если выбраны значения "Сетка" и "Мягкое (выборочное)", доступны следующие формы: "Линейная", "Прямоугольный", "Дисковая", "Цилиндрическая" и "Сферическая". Свойство образцов может использоваться для источника света для задания баланса между временем тонирования и точностью затенения.

Свойство "Видимость при тонировании" в панели "Сведения о тонированном изображении с тенями" управляет видимостью формы при тонировании сцены.


Для создания точечного источника в фотометрическом режиме и назначения ему прямоугольной формы (Процедура)

Использование удалённых источников света
На уровень вверх ..
Регулировка источников света и манипулирование ими
Тонирование чертежа для презентации > Добавление освещения в модель > Освещение сцены > Назначение формы источнику света >
Назначение формы источнику света
Понятие Процедура

Для создания точечного источника в фотометрическом режиме и назначения ему прямоугольной формы

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. Введите точсвет в командной строке.
  3. Нажатием кнопки мыши в области чертежа устанавливается расположение источника света.
  4. В командной строке введите n, затем введите имя. Это имя будет отображаться в разделе свойств и в окне "Источники света в модели" ( СПИСОКСВЕТ ).

    Можно продолжить задание свойств, вводя значения параметров, или выйти из окна и задать свойства в интерактивном режиме. При использовании интерактивного способа результаты вносимых изменений отображаются в процессе работы.

  5. Два раза нажмите клавишу ENTER для завершения команды.

    Выберите источник света и измените его с помощью инструментов ручек.

  6. На чертеже щелкните правой кнопкой мыши и выберите "Свойства". Измените свойства с помощью палитры Свойства освещения.
  7. На палитре "Свойства освещения" под панелью "Общие" убедитесь, что для распределения света задан тип "Точечный".
  8. Прокрутите палитру "Свойства освещения" вниз до отображения раздела "Сведения о тонированном изображении с тенями".
  9. Измените значение свойства "Тип" на "Мягкая (выборочная)".
  10. Измените значение свойства "Форма" на "Прямоугольный". Укажите размеры для свойств "Длина" и "Ширина".
  11. Измените значение свойства "Видимость при тонировании" на "Да".
  12. Выполните тонирование изображения. На чертеже источник света представляется в виде прямоугольника.
    Панель:Источники света
    Ввод команды: ТОЧСВЕТ


Регулировка источников света и манипулирование ими

Назначение формы источнику света
Добавление освещения в модель
Управление отображением источников света
Тонирование чертежа для презентации > Добавление освещения в модель >
Регулировка источников света и манипулирование ими
Понятие Процедура

В процессе работы можно добавлять различные виды освещения (точечное, прожектор, удалённое), менять их расположение и свойства.

Темы в этом разделе

  • Управление отображением источников света

    Отображение источников света в чертеже можно включать и отключать.

  • Регулировка размещения источников света

    Положение и направление размещенного в сцене источника света могут быть изменены.

  • Управление свойствами источника света

    На палитре "Источники света в модели" указано имя и тип каждого источника света, добавленного на чертеже (СПИСОКСВЕТ). Источники освещения в группах и ссылках, солнечный свет и освещение по умолчанию не отображаются.


Регулировка источников света и манипулирование ими (Процедура)

Назначение формы источнику света
Регулировка источников света и манипулирование ими
Управление отображением источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими >
Регулировка источников света и манипулирование ими
Понятие Процедура

Управление внешним видом обозначений источников света

Отображение/отключение обозначений источников света

Печать обозначений источников света

Для выбора источника света из списка источников света

Удаление источника света

Для перемещения точечного источника света и прожектора

Установка параметров затухания точечного света и прожектора

Определение исходного вектора источника удаленного освещения.

Изменение цвета освещения


Управление отображением источников света (Понятие)

Регулировка источников света и манипулирование ими
Регулировка источников света и манипулирование ими
Регулировка размещения источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими >
Управление отображением источников света
Понятие Процедура Краткий справочник

Отображение источников света в чертеже можно включать и отключать.

Для управления отображением источников света имеется несколько способов. В диалоговом окне "Настройка" на вкладке "Построения" настройки обозначений источников света определяют их вид на чертеже.

Обозначение источника света является графическим представлением источника. Точечные источники света и прожекторы могут быть размещены на чертеже при помощи обозначений источников света. Удаленные источники света, в частности, солнечный свет, отображаются без обозначений.

Показ обозначений источников света при печати чертежа необязателен; он зависит от настроек печати обозначений. В свойствах печати обозначений задается вывод источников света по одному за один раз. Значение параметра печати для обозначений источников света оказывает глобальное воздействие на все источники света.


Управление отображением источников света (Процедура)

Регулировка источников света и манипулирование ими
На уровень вверх ..
Управление отображением источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление отображением источников света >
Управление отображением источников света
Понятие Процедура Краткий справочник

Управление внешним видом обозначений источников света

Отображение/отключение обозначений источников света

Печать обозначений источников света


Управление внешним видом обозначений источников света (Процедура)

Управление отображением источников света
На уровень вверх ..
Управление отображением источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление отображением источников света >
Управление отображением источников света
Понятие Процедура Краткий справочник

Управление внешним видом обозначений источников света

  1. Выберите меню Сервис [image] Параметры. В командной строке введите "настройка".
  2. В диалоговом окне "Настройка" на вкладке "Построения" выберите "Настройки обозначения источников света"
  3. В диалоговом окне "Вид обозначений источников света" выберите "Точка" или "Пятно", чтобы отобразить обозначение текущего точечного источника света или прожектора в качестве "Образца обозначения".
  4. Изменить цвет можно в диалоговом окне "Цвета окна построения", активировав "Редактор цветов обозначений".

    Дополнительную информацию см. в разделе Задание параметров интерфейса

  5. Для изменения размера обозначения используется бегунок "Размер обозначения".
  6. Для выхода из любого диалогового окна нажмите на "ОК".
    Ввод команды: НАСТРОЙКА


Отображение/отключение обозначений источников света (Процедура)

Управление отображением источников света
На уровень вверх ..
Управление отображением источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление отображением источников света >
Управление отображением источников света
Понятие Процедура Краткий справочник

Отображение/отключение обозначений источников света

  1. На ленте выберите следующие элементы: вкладка "Визуализация" [image] панель "Источники света".
  2. На расширенной панели "Источники света" выберите "Отображение обозначений источников света".

    Экранные установки не позволяют обеспечить отображение обозначений источников света при печати.

Ввод команды: LIGHTGLYPHDISPLAY


Печать обозначений источников света (Процедура)

Управление отображением источников света
На уровень вверх ..
Регулировка размещения источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление отображением источников света >
Управление отображением источников света
Понятие Процедура Краткий справочник

Печать обозначений источников света

  1. Выберите меню Сервис [image] Палитры [image] Свойства.
  2. Выберите точечный источник света или прожектор.
  3. На палитре "Свойства" измените значение свойства "Обозначение на печати" на "Да".
Панель:Стандартная
Ввод команды: ОКНОСВ


Управление отображением источников света (Краткий справочник)

Распространенные значения ламп для фотометрических источников света
Управление отображением источников света
Регулировка размещения источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление отображением источников света >
Управление отображением источников света
Понятие Процедура Краткий справочник

Команды

УДАЛСВЕТ

Создание удаленного источника света

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СПИСОКСВЕТЗАКР

Закрытие окна "Источники света в модели"

НАСТРОЙКА

Параметры данной вкладки служат для пользовательской настройки программы

ТОЧСВЕТ

Создание точечного источника света

ПРОЖЕКТОР

Создание прожектора

Системные переменные

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTLISTSTATE

Указание на открытое или закрытое состояние окна "Источники света в модели"

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Регулировка размещения источников света (Понятие)

Управление отображением источников света
Регулировка источников света и манипулирование ими
Управление свойствами источника света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими >
Регулировка размещения источников света
Понятие Процедура Краткий справочник

Положение и направление размещенного в сцене источника света могут быть изменены.

После размещения на чертеже источника света, представленного обозначением, его положение можно изменить. Предусмотрена возможность перемещения и поворота источника света, а также изменения объекта, на который он направлен. При выборе обозначения источника света отображаются ручки.

Если щелкнуть на источнике света правой кнопкой мыши, отображается контекстное меню со следующими командами настройки положения источника света.

  • Переместить. Активизация команды "ПЕРЕНЕСТИ". Используется для изменения положения источника света.
  • Повернуть. Активизация команды "ПОВЕРНУТЬ". Используется для изменения ориентации источников света. Помимо команд контекстного меню, можно воспользоваться командами "ПОВЕРНУТЬ", "3DПОВЕРНУТЬ" и "ПОВЕРНУТЬ3D".
  • Отразить. Меняет направление света от источника на противоположное.
ПримечаниеПоворот направленного света полезно применять при выравнивании области площадной тени. При изменении объекта, на который направлен поверхностный источник света с затенением, выполняется сброс ориентации источника света.

Расположение (для точечного источника света и прожектора)

Можно использовать позиционные ручки для перемещения точечного источника света или установить его местоположение в палитре "Свойства". Позиционные ручки перемещают источник света, но не меняют целевую область освещения. Для перемещения и того, и другого необходимо перетащить само изображение обозначения источника света.


Регулировка размещения источников света (Процедура)

Управление отображением источников света
На уровень вверх ..
Регулировка размещения источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Регулировка размещения источников света >
Регулировка размещения источников света
Понятие Процедура Краткий справочник

Для выбора источника света из списка источников света

Удаление источника света

Для перемещения точечного источника света и прожектора


Для выбора источника света из списка источников света (Процедура)

Регулировка размещения источников света
На уровень вверх ..
Регулировка размещения источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Регулировка размещения источников света >
Регулировка размещения источников света
Понятие Процедура Краткий справочник

Для выбора источника света из списка источников света

  1. Выберите меню Вид [image] Тонирование [image] Источник света [image] Список источников света.
  2. В окне "Источники света в модели" выберите имя источника света.

    Если для этого источника света существует обозначение, он отображается как выбранный. При двойном щелчке на имени источника света отображается палитра " Свойства освещения".

    ПримечаниеУдалённые источники не обозначаются на чертеже. Панель "Источники света" используется в окне "Модель" для выбора удалённого освещения.
Панель:Источники света
Ввод команды: СПИСОКСВЕТ


Удаление источника света (Процедура)

Регулировка размещения источников света
На уровень вверх ..
Регулировка размещения источников света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Регулировка размещения источников света >
Регулировка размещения источников света
Понятие Процедура Краткий справочник

Удаление источника света

  1. В командной строке введите "списоксвет".
  2. Выберите один или несколько источников света для удаления
  3. Нажмите правую кнопку мыши на выбранном наборе. Выберите "Удалить источник света" или "Удалить источники света".
Панель:Источники света
Ввод команды: СПИСОКСВЕТ


Для перемещения точечного источника света и прожектора (Процедура)

Регулировка размещения источников света
На уровень вверх ..
Управление свойствами источника света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Регулировка размещения источников света >
Регулировка размещения источников света
Понятие Процедура Краткий справочник

Для перемещения точечного источника света и прожектора

  1. Выберите обозначения источников света или позицию списка в "Источниках света" окна "Модель".
  2. Выберите позиционную ручку,

    которая находится у нижней границы прожектора или в центре точечного источника света.

  3. Перетащите источник света на новое место и нажатием кнопки мыши разместите его там.
    ПримечаниеПрожектор для нацеливания на объект вращается также, как и двигается. При необходимости передвинуть и объект освещения, и источник света, перетаскивается обозначение источника света, а не позиционная ручка.


Регулировка размещения источников света (Краткий справочник)

Управление отображением источников света
Регулировка размещения источников света
Управление свойствами источника света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Регулировка размещения источников света >
Регулировка размещения источников света
Понятие Процедура Краткий справочник

Команды

ПРЕОБРУСТАРСВЕТ

Преобразование источников света, созданных в чертежах формата предыдущих версий, в формат текущей версии

УДАЛСВЕТ

Создание удаленного источника света

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБПРОЖЕКТОР

Создание свободного прожектора, подобного прожектору без заданной цели

СВОБСЕТСВЕТ

Создание свободной световой сетки, подобной световой сетке без заданной цели

ТОЧСВЕТ

Создание точечного источника света

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

ПРОЖЕКТОР

Создание прожектора

СВОЙСТВАСОЛНЦА

Вызов окна "Свойства солнца" для определения свойств солнечного освещения

ТОЧКАЦЕЛИ

Создание целевого точечного источника света

СЕТСВЕТ

Создание световой сетки

Системные переменные

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

SUNSTATUS

Управление излучением солнечного света на текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление свойствами источника света (Понятие)

Регулировка размещения источников света
Регулировка источников света и манипулирование ими
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими >
Управление свойствами источника света
Понятие Процедура Краткий справочник

На палитре "Источники света в модели" указано имя и тип каждого источника света, добавленного на чертеже (СПИСОКСВЕТ). Источники освещения в группах и ссылках, солнечный свет и освещение по умолчанию не отображаются.

Если выбрать источник света в списке, он окажется выбранным и в чертеже, и наоборот. Характеристики источников света в списке сохраняются в соответствии с чертежом. Всех характеристики могут изменяться в палитре "Свойства". Когда источник света для чертежа выбран, можно использовать ручки для его перемещения или вращения, а также менять отдельные свойства, такие как бликование или угол конуса у прожектора. Эффекты освещения меняются одновременно с изменением свойств источника.

Общие свойства

Перечисленные ниже свойства используются во всех источниках света и находятся в панели палитры "Общие" Свойства освещения. Полные описания элементов управления помещены в описании команды "Окносв" в Свойства освещения.

  • Имя Имя, назначаемое источнику света.
  • Тип. Определяет тип источника света: точечный источник света, прожектор, удаленный источник света или сетка.
  • Вкл./Откл.. Служит для включения и отключения источника света.
  • Тени. Определяет, отбрасываются ли тени. Для отображения тени должны быть включены в параметры стиля изображения текущего видового экрана. Отключение теней увеличивает производительность.
  • Коэффициент интенсивности. Устанавливает коэффициент, контролирующий яркость. Интенсивность не связана с затуханием освещения.
  • Цвет фильтра. Устанавливает цвет испускаемого света.
  • Печать обозначений источников света. Позволяет при печати чертежа выводить на печать обозначения источников света.

Яркое пятно прожектора и Спад освещенности в свойствах "Общие"

Попадая на освещаемую поверхность, свет от прожектора дает в центре пятно максимальной освещенности, окруженное переходной областью меньшей интенсивности.

  • Угол конуса максимальной освещенности. Определяет наиболее яркую часть светового пучка. Также может называться угол светового пучка.
  • Полный световой конус. Задаёт параметры светового конуса. Также может называться угол поля.
  • Зона быстрого рассеивания. Представляет собой пространство между зоной максимальной освещённости и углом ограничения светового конуса.

Чем больше разница между ярким пятном и полным световым конусом, тем мягче граничная кромка освещаемого пятна. Если угол наибольшей освещённости равен углу ограничения светового конуса, или близки по величине, освещаемое пятно имеет чёткие очертания. Оба этих угла могут принимать значения в пределах от 0 до 160 градусов. Эти значения можно задать напрямую соответствующими ручками спада освещенности.

Фотометрические свойства

Фотометрическое освещение обладает дополнительными свойствами, которые позволяют сделать его отличным от стандартного. Указанные ниже свойства доступны на панели "Фотометрические свойства".

  • Интенсивность лампы. Определяет собственную яркость источника света. Задается интенсивность, световой поток или освещенность для лампы.
  • Итоговая интенсивность. Указывает фактическую яркость источника света. (Произведение интенсивности лампы на коэффициент интенсивности. Доступно только для чтения.)
  • Цвет лампы. Задает собственный цвет источника света в температуре по Кельвину или по стандарту.
  • Итоговый цвет. Указывает фактический цвет источника света. Это значение определяется комбинацией цвета лампы и цвета фильтра. (Определяется цветом лампы и цветом фильтра. Доступно только для чтения.)

Если для свойства "Тип" фотометрического источника света выбрано значение "Сетка", на панелях "Фотометрическая сетка" и "Смещения сетки" (на палитре "Свойства освещения") становятся доступными дополнительные свойства.

  • Файл сетки. Указывает файл данных, в котором описывается распределение интенсивности света.
  • Предварительный просмотр сетки. Отображает 2D разрез с учетом гониометрических данных.
  • "Поворот вокруг оси X". Определяет угловое смещение сетки относительно оптической оси X.
  • "Поворот вокруг оси Y". Определяет угловое смещение сетки относительно оптической оси Y.
  • "Поворот вокруг оси Z". Определяет угловое смещение сетки относительно оптической оси Z.

Геометрия, включающая свойства направления

Панель "Геометрия" содержит элементы управления для работы с местом расположения источника света. Для точечных источников света, прожекторов и сеточных источников света доступны дополнительные свойства, определяющие направление источника света. Выбрав значение "Да" или "Нет" для свойства "Нацеленный", можно преобразовать обычный источник света в источник света со свойствами направления или наоборот.

Затухание (для точечного источника света и прожектора)

Эта функция определяет ослабление света в зависимости от дистанции. Чем дальше расположен объект от источника света, тем темнее он выглядит. Пользователь может задать отсутствие затухания, линейную инверсию или квадратичную инверсию (ТОЧСВЕТ, ПРОЖЕКТОР). Функция затухания не активна для фотометрических источников света.

Другим способом контроля точек источника и объекта освещения является использование пределов. Пределы используются в виде секущих плоскостей, определяющих, откуда свет испускается и где прекращается. Задание пределов может способствовать повышению производительности, так как в этом случае уровни освещенности не вычисляются в тех областях, где свет является практически невидимым.

ПримечаниеДрайвер OpenGL (wopengl9.hdi) не поддерживает в видовых экранах начальные и конечные пределы затухания. В отличие от драйвера OpenGL, драйвер Direct 3D (direct3d9.hdi) поддерживает в видовых экранах конечные пределы затухания, хотя и не поддерживает начальные пределы. Независимо от того, какой драйвер является текущим, начальные и конечные пределы затухания для источников света отображаются во время тонирования. Для идентификации драйвера надо ввести команду графнастр, выбрать ручную настройку и посмотреть имя выбранного драйвера в диалоговом окне "Ручная оптимизация параметров".


Управление свойствами источника света (Процедура)

Регулировка размещения источников света
На уровень вверх ..
Управление свойствами источника света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление свойствами источника света >
Управление свойствами источника света
Понятие Процедура Краткий справочник

Установка параметров затухания точечного света и прожектора

Определение исходного вектора источника удаленного освещения.

Изменение цвета освещения


Установка параметров затухания точечного света и прожектора (Процедура)

Управление свойствами источника света
На уровень вверх ..
Управление свойствами источника света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление свойствами источника света >
Управление свойствами источника света
Понятие Процедура Краткий справочник

Установка параметров затухания точечного света и прожектора

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. Выберите меню Сервис [image] Палитры [image] Свойства.
  3. Выберите на чертеже обозначение источника света.
  4. В панели "Свойства затухания" установите "Да" напротив "Использования пределов" или выберите тип затухания.
    • Отсутствие. Затухание отсутствует. И далекие, и близкие к источнику света объекты освещаются одинаково.
    • Линейная инверсия. Затухание в зависимости от дистанции можно сделать инверсивным. Например, на расстоянии 2 единицы от источника освещенность равна 1/2 от освещенности на источнике, на расстоянии 4 единицы — 1/4. По умолчанию, интенсивность при линейной инверсии равна половине максимальной интенсивности.
    • Квадратичная инверсия. Затухание в зависимости от дистанции можно сделать квадратично инверсным. Например, на расстоянии 2 единиц от источника освещенность равна 1/4 от освещенности на источнике, на расстоянии 4 единиц — 1/16.
  5. Если для позиции "Использование пределов" установлено "Да", введите эти значения в палитру свойств или используйте инструмент ручек на чертеже для установки этих пределов:
    • Смещение начального предела. Определяет точку испускания света как смещение от центра освещения. По умолчанию определена как 0.
    • Смещение конечного предела. Определяет точку окончания светового луча как смещение от центра освещения. За эту точку свет не проникает.
      ПримечаниеНачальные и конечные пределы затухания не поддерживаются драйвером OpenGL (wopengl9.hdi), но поддерживаются драйвером Direct 3D (direct3d9.hdi). Для идентификации драйвера надо ввести команду графнастр, выбрать ручную настройку и посмотреть имя выбранного драйвера в диалоговом окне "Ручная оптимизация параметров".


Определение исходного вектора источника удаленного освещения. (Процедура)

Управление свойствами источника света
На уровень вверх ..
Управление свойствами источника света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление свойствами источника света >
Управление свойствами источника света
Понятие Процедура Краткий справочник

Определение исходного вектора источника удаленного освещения.

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. Выберите меню Вид [image] Тонирование [image] Источник света [image] Список источников света.
  3. На палитре "Источники света в модели" выберите удаленный источник света.
  4. Выберите меню Сервис [image] Палитры [image] Свойства.
  5. На палитре "Свойства" в разделе "Геометрия" измените значение одним из предложенных ниже способов.
    • Введите значение в ячейку.
    • Нажмите кнопку "Калькулятор" для использования функции "БыстрКальк"
    • Нажмите кнопку "Выбрать в чертеже" и укажите точку "Откуда" и точку "Куда" с помощью устройства указания. На чертеже отображается отрезок, представляющий собой вектор.

    При изменении значений "Вектора от точки" и "Вектор к точке" значения "Исходного вектора" обновляются. При непосредственном изменении значений "Исходного вектора" обновляются значения "Вектора от точки" и "Вектора к точке".

Панель:Источники света
Ввод команды: СПИСОКСВЕТ


Изменение цвета освещения (Процедура)

Управление свойствами источника света
На уровень вверх ..
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление свойствами источника света >
Управление свойствами источника света
Понятие Процедура Краткий справочник

Изменение цвета освещения

  1. Выберите меню Сервис [image] Палитры [image] Свойства.
  2. Выберите на чертеже обозначение источника света.
  3. В палитре "Свойства" активизируйте ячейку "Цвет" и выберите соответствующий. Активизация "Выбора цвета" открывает диалоговое окно "Выбор цвета".
    Ввод команды: ОКОНСВ


Управление свойствами источника света (Краткий справочник)

Регулировка размещения источников света
Управление свойствами источника света
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Регулировка источников света и манипулирование ими > Управление свойствами источника света >
Управление свойствами источника света
Понятие Процедура Краткий справочник

Команды

ПРЕОБРУСТАРСВЕТ

Преобразование источников света, созданных в чертежах формата предыдущих версий, в формат текущей версии

УДАЛСВЕТ

Создание удаленного источника света

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

СВЕТ

Создание источника света

СПИСОКСВЕТ

Активизация палитры "Источники света в модели"

СВОБПРОЖЕКТОР

Создание свободного прожектора, подобного прожектору без заданной цели

СВОБСЕТСВЕТ

Создание свободной световой сетки, подобной световой сетке без заданной цели

ТОЧСВЕТ

Создание точечного источника света

ТОНИРЭКСПОЗ

Интерактивная настройка освещения для самого последнего выходного тонированного изображения

ПРОЖЕКТОР

Создание прожектора

СВОЙСТВАСОЛНЦА

Вызов окна "Свойства солнца" для определения свойств солнечного освещения

ТОЧКАЦЕЛИ

Создание целевого точечного источника света

СЕТСВЕТ

Создание световой сетки

Системные переменные

DEFAULTLIGHTING

Управление освещением по умолчанию в текущем видовом экране

DEFAULTLIGHTINGTYPE

Задание типа освещения по умолчанию

LIGHTGLYPHDISPLAY

Управление отображением обозначений источников света

LIGHTINGUNITS

Управление использованием обычных или фотометрических источников света и указание текущих единиц измерения освещенности

LIGHTSINBLOCKS

Управление использованием источников света, содержащихся в блоках, при тонировании

LINEARBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании обычных источников света или источников света по умолчанию

LINEARCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании обычных источников света или источников света по умолчанию

LOGEXPBRIGHTNESS

Управление глобальным уровнем яркости чертежа при использовании фотометрического освещения

LOGEXPCONTRAST

Управление глобальным уровнем контрастности чертежа при использовании фотометрического освещения

LOGEXPDAYLIGHT

Управление внешним дневным светом при использовании фотометрического освещения

LOGEXPMIDTONES

Управление глобальным уровнем полутонов чертежа при использовании фотометрического освещения

RENDERUSERLIGHTS

Управление преобразованием пользовательских источников света при тонировании

SUNSTATUS

Управление излучением солнечного света на текущем видовом экране

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Имитация солнечного и небесного света (Понятие)

Управление свойствами источника света
Добавление освещения в модель
Вставка объектов-светильников
Тонирование чертежа для презентации > Добавление освещения в модель >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Солнечный свет - это вид освещения, который создает эффект естественного освещения и используется для демонстрации влияния теней от объекта на окружающий вид.

Солнце и небо являются основными источниками естественного освещения в AutoCAD. Солнечные лучи параллельны и имеют желтоватый оттенок, а свет атмосферы исходит во всех направлениях и имеет явный синий отенок. При включении фотометрического режима с помощью системной переменной LIGHTINGUNITS набор доступных свойств солнца расширяется.

Если применяется фотометрический режим (для системной переменной LIGHTINGUNITS задано значение 1 или 2), доступны дополнительные свойства солнца, а визуализация осуществляется с применением модели солнечного света, обладающей более точными физическими характеристиками. В фотометрическом режиме отключен параметр цвета солнца; цвет вычисляется автоматически на основе значений времени, даты и географического местоположения, заданных для чертежа. Цвет определяется по положению на небе. Если применяется стандартный (общий) режим (для системной переменной LIGHTINGUNITS задано значение 0) дополнительные свойства света и неба не доступны.

Свойства солнца можно изменить с помощью команды СВОЙСТВАСОЛНЦА. Отображается окно "Свойства солнца". Подробные сведения о параметрах приведены в разделе " СВОЙСТВАСОЛНЦА" документа "Справочник команд".

Лучи при этом параллельны и имеют одинаковую интенсивность на всём протяжении. Тени могут быть как включены, так и выключены. Если в тенях нет необходимости, их можно отключить - это увеличит производительность. Все настройки для солнечного света, за исключением географического местоположения, сохраняются на видовом экране, а не в чертеже. Географическое местоположение сохраняется в чертеже.

Угол освещения при использовании солнечного света определяется географическим положением, задающимся для модели, а также датой и временем. Эти свойства могут быть изменены в "Свойствах солнечного света"и диалоговом окне "Географическое положение". Часовой пояс определяется местоположением, но его можно также настроить независимо от местоположения (с помощью системной переменной TIMEZONE).

Небесный фон

Фон неба можно выбрать только в том случае, если освещение представлено в фотометрических единицах (для системной переменной LIGHTINGUNITS задано значение 1 или 2). Если после выбора фона неба перейти в режим стандартного (общего) освещения (задать для системной переменной LIGHTINGUNITS значение 0), фон неба отключается.

В окне "Свойства солнца" можно активизировать область просмотра для настройки фона "солнце и небо" в интерактивном режиме; для этого следует нажать первую кнопку на панели названия окна "Свойства солнца". При нажатии этой кнопки активизируется диалоговое окно "Регулировка фона "Солнце и небо". В нем можно изменить свойства и просмотреть изменения фона в области предварительного просмотра.

Демонстрация: настройка свойств неба

Для запуска анимации нажмите стрелку "Просмотр".

Небесное освещение

Виду можно назначить фон неба без небесного освещения или с небесным освещением. Этот параметр можно выбрать в ниспадающем списке "Состояние свойств солнца" в диалоговом окне "Свойства солнца". Дополнительное небесное освещение сцены имитирует эффект солнечных лучей, рассеиваемых в атмосфере и освещающих всю сцену. Такой дополнительный свет виден только в результате тонирования, когда включена функция окончательной компоновки. Эта функция доступна на палитре "Дополнительные параметры тонирования".

Примечание Если для параметра "Чистовые пробы" задано значение по умолчанию "Авто", при тонировании с включенным небесным освещением включена функция чистовых проб.

Вид

Команда ВИД обеспечивает механизм создания именованных видов и их организации. Фон "солнце и небо" можно назначить новому фону с именем в разделе "Фон". Небесный фон создается с учетом данных солнечного освещения в именованном виде.

В диалоговом окне "Регулировка фона "Солнце и небо" предусмотрена возможность интерактивной настройки фона "солнце и небо" в области просмотра. Нажмите первую кнопку в строке названия окна "Свойства неба". При нажатии этой кнопки открывается диалоговое окно "Регулировка фона "Солнце и небо". В нем можно изменить свойства и просмотреть изменения фона в области предварительного просмотра.


Имитация солнечного и небесного света (Процедура)

Управление свойствами источника света
Имитация солнечного и небесного света
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Включение и выключение освещения солнечным светом на чертеже

Для изменения яркости солнца

Для изменения географического положения модели

Изменение угла солнечного света

Изменение цвета солнечного света

Процедура создания нового вида с фоном "солнце и небо"


Включение и выключение освещения солнечным светом на чертеже (Процедура)

Имитация солнечного и небесного света
Имитация солнечного и небесного света
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Включение и выключение освещения солнечным светом на чертеже

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. Введите свойствасолнца в командной строке.
  3. В "Общих параметрах" выберите "Установка положения" и задайте "Вкл" или "Откл".
Панель:Источники света
Ввод команды: СВОЙСТВАСОЛНЦА


Для изменения яркости солнца (Процедура)

Имитация солнечного и небесного света
Имитация солнечного и небесного света
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Для изменения яркости солнца

  1. В командной строке введите lightingunits и задайте значение 0, соответствующее стандартному освещению.
  2. Введите свойствасолнца в командной строке.
  3. В "Общих параметрах" выберите "Коэффициент интенсивности" и задайте новое значение.
Ввод команды: ВИД


Для изменения географического положения модели (Процедура)

Имитация солнечного и небесного света
Имитация солнечного и небесного света
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Для изменения географического положения модели

  1. Введитегеоположение в командной строке.
  2. В диалоговом окне задач "Положение уже существует" выберите "Редактирование текущего географического положения".
  3. В диалоговом окне "Географическое положение" введите необходимые величины.
  4. Нажмите "ОК".
Меню: Сервис [image] Географическое положение
Ввод команды: ГЕОПОЛОЖЕНИЕ


Изменение угла солнечного света (Процедура)

Имитация солнечного и небесного света
Имитация солнечного и небесного света
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Изменение угла солнечного света

  1. Введите свойствасолнца в командной строке.
  2. В параметрах "Положения солнца" нажмите на "Установку даты" и выберите новую дату.
  3. Выберите "Установку времени" и задайте новое время.

    Если необходимо, используйте параметр "Летнее время".

Панель:Источники света
Ввод команды: СВОЙСТВАСОЛНЦА


Изменение цвета солнечного света (Процедура)

Имитация солнечного и небесного света
Имитация солнечного и небесного света
Имитация солнечного и небесного света
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Изменение цвета солнечного света

  1. Введите свойствасолнца в командной строке.
  2. В "Общих параметрах" выберите "Установки цвета" и задайте соответствующий цвет.

    Активизация "Выбора цвета" открывает диалоговое окно "Выбор цвета".

Панель:Источники света
Ввод команды: СВОЙСТВАСОЛНЦА


Процедура создания нового вида с фоном "солнце и небо" (Процедура)

Имитация солнечного и небесного света
Имитация солнечного и небесного света
Вставка объектов-светильников
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Процедура создания нового вида с фоном "солнце и небо"

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. Выберите меню "Вид" > "Именованные виды".
  3. Щелкнуть "Создать".
  4. В диалоговом окне "Новый вид" введите имя нового вида.
  5. В ниспадающем списке "Фон" выберите значение "Солнце и небо" для применения по умолчанию.
  6. В диалоговом окне "Регулировка фона "Солнце и небо" отрегулируйте фон.
  7. Нажмите "ОК".
Панель:Источники света
Ввод команды: СВОЙСТВАСОЛНЦА


Имитация солнечного и небесного света (Краткий справочник)

Управление свойствами источника света
Имитация солнечного и небесного света
Вставка объектов-светильников
Тонирование чертежа для презентации > Добавление освещения в модель > Имитация солнечного и небесного света >
Имитация солнечного и небесного света
Понятие Процедура Краткий справочник

Команды

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

СВОЙСТВАСОЛНЦА

Вызов окна "Свойства солнца" для определения свойств солнечного освещения

СВОЙСТВАСОЛНЦАЗАКР

Закрытие окна "Свойства Солнца"

Системные переменные

LATITUDE

Значение широты модели чертежа в десятичном формате

LONGITUDE

Значение долготы модели чертежа в десятичном формате

NORTHDIRECTION

Угол между направлением на солнце и на север

SUNPROPERTIESSTATE

Указание на открытое или закрытое состояние диалогового окна "Свойства солнца"

SUNSTATUS

Управление излучением солнечного света на текущем видовом экране

TIMEZONE

Устанавливает часовой пояс для положения солнца в чертеже

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Вставка объектов-светильников (Понятие)

Имитация солнечного и небесного света
Добавление освещения в модель
Преобразование источников света
Тонирование чертежа для презентации > Добавление освещения в модель >
Вставка объектов-светильников
Понятие Процедура Краткий справочник

Объект-светильник представляет собой вспомогательный объект, позволяющий скомбинировать набор объектов в световой блок.

Объект-светильник - это группа компонентов источника света, с которой можно выполнять операции как с одним объектом. Осветительные приборы могут быть представлены в виде блоков, в которые включены как источники света, так и геометрические объекты (световых блоков). Объект-светильник формируется в результате объединения набора объектов - источников света в световой блок.

Для упрощения процедуры создания объекта-светильника можно воспользоваться палитрами инструментов работы с фотометрическими источникам света. Поддержка объектов-светильников обеспечивается дополнительными модулями.

Пример объекта-светильника


Процедура добавления фотометрического источника света для использования в светильнике (Процедура)

Имитация солнечного и небесного света
Вставка объектов-светильников
Инструментальные палитры "Материалы"
Тонирование чертежа для презентации > Добавление освещения в модель > Вставка объектов-светильников >
Вставка объектов-светильников
Понятие Процедура Краткий справочник

Процедура добавления фотометрического источника света для использования в светильнике

  1. В командной строке введите lightingunits и задайте значение 1 (международная система единиц) или 2 (американская система единиц); оба значения соответствуют фотометрическому освещению.
  2. Выберите следующие элементы: вкладка "Вид" [image] панель "Палитры" [image] Инструментальные палитры. В командной строке введите "инстрпалвкл".
  3. Щелкните на строке названия палитры инструментов правой кнопкой мыши. Выберите "Фотометрические источники света".
  4. Перетащите источник света из палитры в чертеж.
  5. Перетащите другой источник света с палитры на чертеж.
  6. В командной строке введите "блок" для создания светового блока с источниками света, размещенными на чертеже.
Ввод команды: ИНСТРПАЛВКЛ


Вставка объектов-светильников (Краткий справочник)

Имитация солнечного и небесного света
Вставка объектов-светильников
Работа с источниками света в чертежах из более ранних версий AutoCAD
Тонирование чертежа для презентации > Добавление освещения в модель > Вставка объектов-светильников >
Вставка объектов-светильников
Понятие Процедура Краткий справочник

Команды

ГЕОПОЛОЖЕНИЕ

Задание информации о географическом положении для файла чертежа

СВОЙСТВАСОЛНЦА

Вызов окна "Свойства солнца" для определения свойств солнечного освещения

СВОЙСТВАСОЛНЦАЗАКР

Закрытие окна "Свойства Солнца"

Системные переменные

LATITUDE

Значение широты модели чертежа в десятичном формате

LONGITUDE

Значение долготы модели чертежа в десятичном формате

NORTHDIRECTION

Угол между направлением на солнце и на север

SUNPROPERTIESSTATE

Указание на открытое или закрытое состояние диалогового окна "Свойства солнца"

SUNSTATUS

Управление излучением солнечного света на текущем видовом экране

TIMEZONE

Устанавливает часовой пояс для положения солнца в чертеже

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Преобразование источников света

Вставка объектов-светильников
Добавление освещения в модель
Работа с источниками света в чертежах из более ранних версий AutoCAD
Тонирование чертежа для презентации > Добавление освещения в модель >
Преобразование источников света

Свойства источников света совместимы с предыдущими выпусками AutoCAD и другими программными продуктами.

Темы в этом разделе

  • Работа с источниками света в чертежах из более ранних версий AutoCAD

    Преобразование источников света из предыдущих версий программы.

  • Импорт чертежей в 3ds Max или Viz

    Чертеж можно открыть в программах 3ds Max и Viz.


Работа с источниками света в чертежах из более ранних версий AutoCAD (Понятие)

Преобразование источников света
Преобразование источников света
Импорт чертежей в 3ds Max или Viz
Тонирование чертежа для презентации > Добавление освещения в модель > Преобразование источников света >
Работа с источниками света в чертежах из более ранних версий AutoCAD
Понятие Краткий справочник

Преобразование источников света из предыдущих версий программы.

В AutoCAD 2008, предусмотрена возможность выбора между стандартным (общим) и фотометрическим освещением. В более ранних версиях по сравнению с AutoCAD 2008 поддерживалось только стандартное (общее) освещение. Для использования в AutoCAD 2008 источники света из AutoCAD 2007 не требуют специального преобразования. Чертежи из AutoCAD 2007 по умолчанию открываются в AutoCAD 2008 в режиме стандартного (общего) освещения. При включении на чертеже режима фотометрического освещения становятся доступными дополнительные фотометрические свойства, предусмотренные в AutoCAD 2008.

При открытии чертежей с источниками света, созданных в более ранних версиях по сравнению с AutoCAD 2007, требуется процесс преобразования. По умолчанию с помощью системной переменной 3DCONVERSIONMODE задан режим, в котором чертежи с освещением из более ранних версий преобразуются в формат освещения AutoCAD 2007 и AutoCAD 2008. Эта системная переменная может принимать три значения. Если для переменной задано значение 0, автоматическое преобразование не выполняется. Если задать значение 1 (используется по умолчанию), преобразование будет выполняться автоматически. Если задано значение 2, для источников света, требующих преобразования, отображается запрос на выполнение или отмену преобразования.

С помощью команды "ПРЕОБРУСТАРСВЕТ" можно вручную преобразовать источники света из более ранних версий.


Работа с источниками света в чертежах из более ранних версий AutoCAD (Краткий справочник)

Вставка объектов-светильников
Работа с источниками света в чертежах из более ранних версий AutoCAD
Импорт чертежей в 3ds Max или Viz
Тонирование чертежа для презентации > Добавление освещения в модель > Преобразование источников света > Работа с источниками света в чертежах из более ранних версий AutoCAD >
Работа с источниками света в чертежах из более ранних версий AutoCAD
Понятие Краткий справочник

Команды

ПРЕОБРУСТАРСВЕТ

Преобразование источников света, созданных в чертежах формата предыдущих версий, в формат текущей версии

Системные переменные

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Импорт чертежей в 3ds Max или Viz (Понятие)

Работа с источниками света в чертежах из более ранних версий AutoCAD
Преобразование источников света
Материалы и текстуры
Тонирование чертежа для презентации > Добавление освещения в модель > Преобразование источников света >
Импорт чертежей в 3ds Max или Viz
Понятие Краткий справочник

Чертеж можно открыть в программах 3ds Max и Viz.

Подробную информацию об импорте формата DWG можно найти в документации по импорту DWG для программ 3ds Max и Viz.


Импорт чертежей в 3ds Max или Viz (Краткий справочник)

Работа с источниками света в чертежах из более ранних версий AutoCAD
Импорт чертежей в 3ds Max или Viz
Коротко о материалах
Тонирование чертежа для презентации > Добавление освещения в модель > Преобразование источников света > Импорт чертежей в 3ds Max или Viz >
Импорт чертежей в 3ds Max или Viz
Понятие Краткий справочник

Команды

ПРЕОБРУСТАРСВЕТ

Преобразование источников света, созданных в чертежах формата предыдущих версий, в формат текущей версии

Системные переменные

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Материалы и текстуры

Импорт чертежей в 3ds Max или Viz
Тонирование чертежа для презентации
Коротко о материалах
Тонирование чертежа для презентации >
Материалы и текстуры

В сочетании с освещением, материалы повышают уровень реалистичности моделей.

Темы в этом разделе

  • Коротко о материалах

    Применяя функцию назначения материалов объектам в чертежах можно создать эффект реалистичности.

  • Инструментальные палитры "Материалы"

    Инструментальные палитры "Материалы" служат для доступа к материалам.

  • Создание материалов

    Материал характеризуется рядом своих свойств. Доступные свойства материала зависят от выбранного типа материала.

  • Применение материалов к объектам и граням

    Материалы можно применять к отдельным объектам и граням или ко всем объектам в слое.

  • Редактирование материалов

    Свойства материала можно изменять после создания материала или после применения материала.

  • Дополнительное переопределение освещения

    Функция дополнительного переопределения освещения позволяет задать параметры, влияющие на тонирование объекта при освещении отраженным светом общего освещения и/или освещения методом чистовых проб.

  • Повышение реалистичности изображения с помощью текстур

    Наложение карт позволяет сделать материал более сложным.

  • Преобразование материалов

    При использовании некоторых версий AutoCAD или других программных продуктов может потребоваться преобразование материалов.


Коротко о материалах (Понятие)

Материалы и текстуры
Материалы и текстуры
Инструментальные палитры "Материалы"
Тонирование чертежа для презентации > Материалы и текстуры >
Коротко о материалах
Понятие Краткий справочник

Применяя функцию назначения материалов объектам в чертежах можно создать эффект реалистичности.

Параметры материала определяют его физические свойства. На инструментальной палитре "Материалы" в окне "Инструментальные палитры" представлено большое количество заранее созданных материалов. Эти инструменты материалов используются для назначения материалов объектам в сцене. Можно самостоятельно создавать и изменять материалы с помощью окна "Материалы". В окне "Материалы" содержатся многочисленные параметры, предназначенные для изменения свойств материала.

Наложение структур позволяет создать материал с детально проработанной и реалистичной текстурой. Например, можно создать копию дороги с асфальтовым покрытием с помощью текстуры "Помехи" и применить ее к объекту, представляющему дорогу на сцене. Для получения рисунка кирпича и раствора можно воспользоваться картой с образцом плитки.

В разделе "Дополнительные параметры переопределения освещения" можно добавить к материалу свойства, которые влияют на тонирование сцены, освещенной отраженным светом в режиме общего освещения и/или чистовых проб.

После того, как текстуры применены к материалу и настроены под пользователя, можно скорректировать текстуру на объекте с помощью разнообразных инструментов, доступных с панели "Материалы" на ленте.

См. также

    • Получение новостей и обновлений программы


Коротко о материалах (Краткий справочник)

Импорт чертежей в 3ds Max или Viz
Коротко о материалах
Инструментальные палитры "Материалы"
Тонирование чертежа для презентации > Материалы и текстуры > Коротко о материалах >
Коротко о материалах
Понятие Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

CMATERIAL

Задание материала для новых объектов

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Инструментальные палитры "Материалы"

Коротко о материалах
Материалы и текстуры
Инструментальные палитры "Материалы"
Тонирование чертежа для презентации > Материалы и текстуры >
Инструментальные палитры "Материалы"
Понятие Процедура

Инструментальные палитры "Материалы" служат для доступа к материалам.

Темы в этом разделе

  • Инструментальные палитры "Материалы"

    Инструментальные палитры "Материалы" обеспечивают быстрый доступ к предварительно выбранным материалам.


Инструментальные палитры "Материалы" (Процедура)

Вставка объектов-светильников
Инструментальные палитры "Материалы"
Инструментальные палитры "Материалы"
Тонирование чертежа для презентации > Материалы и текстуры > Инструментальные палитры "Материалы" >
Инструментальные палитры "Материалы"
Понятие Процедура

Открытие окна "Материалы"

Для добавления материала в инструментальную палитру


Инструментальные палитры "Материалы" (Понятие)

Инструментальные палитры "Материалы"
Инструментальные палитры "Материалы"
Создание материалов
Тонирование чертежа для презентации > Материалы и текстуры > Инструментальные палитры "Материалы" >
Инструментальные палитры "Материалы"
Понятие Процедура Краткий справочник

Инструментальные палитры "Материалы" обеспечивают быстрый доступ к предварительно выбранным материалам.

Библиотека материалов

В комплект поставки программы входит библиотека, содержащая более 400 материалов и текстур. После установки материалы доступны на инструментальных палитрах и отображаются на них с клетчатой подложкой.

При обычной установке в инструментальные палитры "Материалы" устанавливается менее 100 материалов. Дополнительно можно установить библиотеку материалов, содержащую не менее 300 материалов. В программе установки для добавления библиотеки используется кнопка "Конфигурация" функции добавления/удаления компонентов программы. По умолчанию все инструментальные палитры "Материалы" устанавливаются в папке, путь к которой указан в поле "Папки для файлов инструментальных палитр" на вкладке "Файлы" диалогового окна "Параметры". (Для определения местонахождения текстур см. "Папка для поиска текстур" на вкладке "Файлы".)

ПримечаниеКомпоненты библиотеки материалов всегда устанавливаются в папке по умолчанию. Если изменить пути перед установкой библиотеки материалов, новые материалы не отображаются на инструментальных палитрах и не содержат ссылок на текстуры. Следует либо скопировать вновь установленные файлы в нужное место, либо заменить путь на путь по умолчанию.

Окно палитры инструментов

Окно "Инструментальные палитры" содержит отдельные палитры материалов, которые можно применить к объектам в сцене.

Окно "Инструментальные палитры" может быть свернуто.

В свернутом состоянии отображается только вертикальная строка заголовка окна. С помощью контекстного меню можно задать отображение окна "Инструментальные палитры" в виде открытого окна или в виде вертикальной панели. Щелкните на строке заголовка правой кнопкой мыши и в контекстном меню выберите "Автоматически убирать с экрана". Если параметр "Автоматически убирать с экрана" включен, скрытое окно "Инструментальные палитры" отображается при наведении курсора мыши на строку заголовка. Если параметр "Автоматически убирать с экрана" отключен, окно "Инструментальные палитры" всегда отображается в виде развернутого окна.

Материалы можно применять к объектам с помощью отдельных инструментальных палитр в окне "Инструментальные палитры". Материалы из отдельных инструментальных палитр можно перетаскивать в область отображения образцов окна "Материалы". В окне "Материалы" можно вносить изменения в материалы.

Контекстные меню инструментальных палитр

Наведите курсор мыши на область инструментальной палитры, не содержащую каких-либо элементов, и щелкните правой кнопкой мыши. Отображается меню, содержащее стандартные команды работы с инструментальной палитрой.

Пользовательские инструментальные палитры

Предусмотрена возможность создания пользовательской палитры для отображения материалов в рабочем пространстве. Использование такой палитры помогает сэкономить время, если пользователь регулярно работает с материалами.

Для создания новой палитры и присвоения ей имени нажмите на строке заголовка окна "Инструментальные палитры" и выберите "Новая палитра". Пользователь может настроить эту палитру в соответствии со своими предпочтениями. С помощью копирования и вставки в палитру можно добавлять инструменты материалов из других инструментальных палитр. Соответствующие команды предусмотрены в контекстном меню окна "Инструментальные палитры".

Редактирование и сохранение материалов

Создайте копию материала и вставьте его в новую палитру. Свойства материала можно отредактировать. Щелкните на новом материале правой кнопкой мыши и выберите "Свойства". Отображаются свойства материала. Свойства можно редактировать, а затем сохранить нажатием кнопки "ОК".


Инструментальные палитры "Материалы" (Процедура)

Инструментальные палитры "Материалы"
На уровень вверх ..
Инструментальные палитры "Материалы"
Тонирование чертежа для презентации > Материалы и текстуры > Инструментальные палитры "Материалы" > Инструментальные палитры "Материалы" >
Инструментальные палитры "Материалы"
Понятие Процедура Краткий справочник

Открытие окна "Материалы"

Для добавления материала в инструментальную палитру


Открытие окна "Материалы" (Процедура)

Инструментальные палитры "Материалы"
На уровень вверх ..
Инструментальные палитры "Материалы"
Тонирование чертежа для презентации > Материалы и текстуры > Инструментальные палитры "Материалы" > Инструментальные палитры "Материалы" >
Инструментальные палитры "Материалы"
Понятие Процедура Краткий справочник

Открытие окна "Материалы"

  • Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.

    Отображается окно "Материалы".

Панель:Тонирование
Контекстное меню:Нажмите правую кнопку мыши и выберите "Экспортировать в активную инструментальную палитру".
Ввод команды: МАТЕРИАЛЫ


Для добавления материала в инструментальную палитру (Процедура)

Инструментальные палитры "Материалы"
На уровень вверх ..
Создание материалов
Тонирование чертежа для презентации > Материалы и текстуры > Инструментальные палитры "Материалы" > Инструментальные палитры "Материалы" >
Инструментальные палитры "Материалы"
Понятие Процедура Краткий справочник

Для добавления материала в инструментальную палитру

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. Выберите меню Инструменты [image] Палитры [image] Инструментальные палитрыВ командной строке введите инстрпалвкл.
  3. Нажатием кнопки мыши активируйте вкладку инструментальной палитры, к которой нужно добавить инструмент материала.
  4. В окне "Материалы" выберите образец.
  5. Перетащите образец материала из окна "Материалы" на инструментальную палитру.

    Инструмент материала добавляется в активную инструментальную палитру, откуда им удобно пользоваться при работе с чертежом.

ПримечаниеЕсли впоследствии свойства материала изменяются в окне "Материалы", автоматическое обновление инструмента не выполняется. Удаление старого инструмента материала Перетащите обновленный образец; старый образец будет заменен новым.
Панель:Тонирование
Контекстное меню:Нажмите правую кнопку мыши и выберите "Экспортировать в активную инструментальную палитру".
Ввод команды: МАТЕРИАЛЫ


Инструментальные палитры "Материалы" (Краткий справочник)

Коротко о материалах
Инструментальные палитры "Материалы"
Создание материалов
Тонирование чертежа для презентации > Материалы и текстуры > Инструментальные палитры "Материалы" > Инструментальные палитры "Материалы" >
Инструментальные палитры "Материалы"
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Создание материалов (Понятие)

Инструментальные палитры "Материалы"
Материалы и текстуры
Применение материалов к объектам и граням
Тонирование чертежа для презентации > Материалы и текстуры >
Создание материалов
Понятие Процедура Краткий справочник

Материал характеризуется рядом своих свойств. Доступные свойства материала зависят от выбранного типа материала.

Создать новый материал можно в окне "Материалы". Для открытия окна "Материалы" выполните одно из указанных ниже действий. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы. Для создания нового материала нажмите кнопку "Создать новый материал" под панелью "Материалы, имеющиеся в чертеже". В разделе "Редактор материалов" окна "Материалы" можно выбрать тип материала и шаблон для создания нового материала. После задания этих свойств можно внести в материалы дополнительные изменения с помощью текстур или процедурных карт, а также параметров "Дополнительные параметры переопределения освещения", "Масштаб и мозаичное расположение материала", "Смещение текстуры материала и просмотр".

В панели "Редактор материалов" можно задать следующие свойства:

  • Типы "Реалистичный" и "Реалистичное тонирование металла". Материалы характеризуются физическими свойствами. Шаблон материала можно выбрать в списке материалов с предварительно заданными свойствами, например: "Керамическая плитка, глянцевая"; "Ткань"; "Стекло" и т. д.
  • Типы "Дополнительный" и "Улучшенное тонирование металла". Эти материалы имеют расширенный набор параметров, в том числе свойства, которые можно использовать для создания специальных эффектов, например имитации отражений. Для типов "Дополнительный" и "Улучшенное тонирование металла" шаблоны материалов не предоставляются.

В новом чертеже всегда доступен один материал, который имеет название ГЛОБАЛЬНЫЙ; по умолчанию он создается с использованием шаблона "Реалистичный". До тех пор, пока материал объекта не будет изменен, все объекты по умолчанию используют этот материал. Этот материал, как и любой другой, можно использовать как основу для создания нового материала.

В зависимости от используемого типа материала, для дальнейшей проработки материала будут доступны одно или несколько свойств.

Цвет

Цвет материала на разных участках объекта различается. Например, если смотреть на красный шар, он не покажется монотонно красным. Поверхности, не освещённые напрямую, покажутся темнее, чем те, на которые непосредственно падает свет. Бликовое отражение покажется самым ярким, и если сфера очень блестящая, то блики могут показаться даже белыми.

Для материала типа "Дополнительные" можно задавать цвета трех типов, а для материала типа "Улучшенное тонир. металла" - цвета двух типов.

  • Диффузный. Главный цвет материала.
  • Рассеянный. Это цвет, который виден на поверхности, освещённой только рассеянным светом. При этом рассеянный цвет может полностью совпадать с диффузным.
  • Зеркальный. Это цвет блика на освещенном материале. Зеркальный цвет может быть таким же, как диффузный.

В шаблонах "Реалистичный" и "Реалистичное тонирование металла" используется только цвет "Диффузный".

Блеск

Отражающая способность поверхности материала определяет уровень блеска или шероховатости. Для симуляции блестящей поверхности материал должен иметь точечные блики, цвет которых намного ярче, в некоторых случаях даже белый. Шероховатая поверхность даёт блики большей площади, которые по цвету близки к основному цвету материала.

Другие свойства

Для создания специальных эффектов можно использовать следующие свойства:

  • Непрозрачность. Полностью непрозрачная поверхность объекта не пропускает свет. Объект, в котором свойство непрозрачности отсутствует, называется прозрачным (не применимо к металлическим типам материалов).
  • Отражение. С помощью регулятора отражения можно управлять тем, насколько отражающим является материал. При значении 100 материал отражает весь свет, падающий на него, а в любом объекте, к которому применен такой материал, отражается окружающая среда (не применимо к металлическим типам материалов).
  • Преломление. При прохождении через полупрозрачные материалы лучи изменяют свое направление, в результате сквозь этот материал другие объекты видны в искаженном виде. Например, при значении 1,0 объект за прозрачным объектом не искажается. При коэффициенте, равном 1,5, происходит сильное искажение объекта, как при взгляде сквозь стеклянный шарик. (не применимо к металлическим типам материалов).

    Материал

    Коэффициент преломления

    Вакуум

    1,0 (точно)

    Воздух

    1,0003

    Вода

    1,3333

    Стекло

    1,5 - 1,7

    Алмаз

    2,419

  • Прозрачность. Полупрозрачный объект не только пропускает свет, но и рассеивает часть его внутри себя, как, например, покрытое инеем стекло. Степень прозрачности выражается в процентах: при значении 0 материал не является просвечивающим; при 100 материал является просвечивающим в максимально возможной степени. (не применимо к металлическим типам материалов).
  • Самосвечение. Если объект обладает свойством самосвечения, кажется, что он сам излучает свет. Например, для того чтобы изобразить неоновый свет без использования внешнего источника света, надо установить значение самосвечения больше нуля. На другие объекты такой свет не отбрасывается.
  • Яркость. Яркость позволяет имитировать освещение материала фотометрическим источником света. Выбранное значение в фотометрических единицах соответствует интенсивности светового излучения. На другие объекты такой свет не отбрасывается.
  • Двусторонний материал. Это свойство указывает на то, что материал является двусторонним. Его следует задать в том случае, если в сцене требуется тонировать обе стороны материала.
См. также

    • Использование наложения текстур для улучшения реалистичности

    • Типы карт


Создание материалов (Процедура)

Инструментальные палитры "Материалы"
Создание материалов
Создание материалов
Тонирование чертежа для презентации > Материалы и текстуры > Создание материалов >
Создание материалов
Понятие Процедура Краткий справочник

Отображения или скрытие панели материалов на ленте

Создание нового материала типа "Реалистичный"

Создание нового материала типа "Дополнительный"


Отображения или скрытие панели материалов на ленте (Процедура)

Создание материалов
Создание материалов
Создание материалов
Тонирование чертежа для презентации > Материалы и текстуры > Создание материалов >
Создание материалов
Понятие Процедура Краткий справочник

Отображения или скрытие панели материалов на ленте

  1. Щелкните правой кнопкой мыши в любой области вкладки "Визуализация" на ленте.
  2. В контекстном меню вкладки "Визуализация" снимите или установите флажок "Панели" [image] "Материалы".
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Создание нового материала типа "Реалистичный" (Процедура)

Создание материалов
Создание материалов
Создание материалов
Тонирование чертежа для презентации > Материалы и текстуры > Создание материалов >
Создание материалов
Понятие Процедура Краткий справочник

Создание нового материала типа "Реалистичный"

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы..
  2. В окне "Материалы", под образцами, нажмите "Создать новый материал".
  3. В диалоговом окне "Создать новый материал" ввести название, а при необходимости - и описание материала. Нажмите "ОК".
  4. В разделе "Редактор материалов" установите тип материала как "Реалистичный".
  5. В разделе "Редактор материалов" выберите шаблон материала.
  6. Щелкните на элементе "Цвет" для назначения материалу диффузного цвета или выберите "По объекту" для применения цвета того объекта, которому назначен материал.
  7. С помощью шкал задайте такие свойства как блеск, непрозрачность, преломление, полупрозрачность и т. д.
  8. (Дополнительно) Выберите тип наложения текстур и тип процедурной карты, см. Использование наложения текстур для улучшения реалистичности и Типы карт.
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Создание нового материала типа "Дополнительный" (Процедура)

Создание материалов
Создание материалов
Применение материалов к объектам и граням
Тонирование чертежа для презентации > Материалы и текстуры > Создание материалов >
Создание материалов
Понятие Процедура Краткий справочник

Создание нового материала типа "Дополнительный"

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы..
  2. В окне "Материалы", под образцами, нажмите "Создать новый материал".
  3. В диалоговом окне "Создать новый материал" ввести название, а при необходимости - и описание материала. Нажмите "ОК".
  4. В разделе "Редактор материалов" выберите "Дополнительно" в раскрывающемся списке "Тип".
  5. Задайте параметры цвета материала. Можно выбрать один или несколько параметров цвета из числа указанных ниже.
    • Выберите "Рассеянный" для задания цвета на гранях, освещенных только рассеянным светом или выберите "По объекту" для использования цвета объекта, к которому применен материал.
    • Выберите "Диффузный" для присвоения цвета материалу или выберите "По объекту" для использования цвета объекта, к которому применен материал.
    • Выберите "Цвет блика" для задания цвета блика на блестящем материале или выберите "По объекту" для использования цвета объекта, к которому применен материал.
  6. (Не обязательно) Щелкните на первом значке блокировки (между элементами "Рассеянный" и "Диффузный") для задания диффузного цвета в качестве рассеянного цвета. Щелкните на втором значке блокировки (между элементами "Цвет блика" и "Диффузный") для задания цвета блика в качестве диффузного цвета.

    Если цвет связан с другим цветом, то изменение одного приводит к изменению другого.

  7. С помощью шкал задайте такие свойства как блеск, непрозрачность, преломление, полупрозрачность и т. д.
  8. (Дополнительно) Выберите стиль карты и тип процедурной карты, см. Использование наложения текстур для улучшения реалистичности и Типы карт.
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Создание материалов (Краткий справочник)

Инструментальные палитры "Материалы"
Создание материалов
Применение материалов к объектам и граням
Тонирование чертежа для презентации > Материалы и текстуры > Создание материалов >
Создание материалов
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

LOGEXPPHYSICALSCALE
MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

Утилиты

Нет

Ключевые слова для команд

Нет


Применение материалов к объектам и граням (Понятие)

Создание материалов
Материалы и текстуры
Редактирование материалов
Тонирование чертежа для презентации > Материалы и текстуры >
Применение материалов к объектам и граням
Понятие Процедура Краткий справочник

Материалы можно применять к отдельным объектам и граням или ко всем объектам в слое.

Для применения материала к объекту или грани (треугольному или четырехугольному участку поверхности объекта) можно перетащить материал с палитры инструментов на объект. Материал добавляется на чертеже, а его образец отображается в окне "Материалы".

При создании или изменении материала в окне "Материалы" можно выполнять следующие действия.

  • Перетаскивать образец материала прямо на объекты в чертеже.
  • Перетаскивать образец материала на активную инструментальную палитру для создания инструмента материала.
  • Применять материал к объектам по слоям ( МАТЕРИАЛПРИСВ ). Материал применяется ко всем объектам слоя, у которых для свойства "Материал" задано значение ПОСЛОЮ (значение по умолчанию).
  • Назначать материал объекту с помощью кнопки "Применить материалы к объекту" на палитре "Материалы".


Применение материалов к объектам и граням (Процедура)

Создание материалов
Применение материалов к объектам и граням
Применение материалов к объектам и граням
Тонирование чертежа для презентации > Материалы и текстуры > Применение материалов к объектам и граням >
Применение материалов к объектам и граням
Понятие Процедура Краткий справочник

Для применения материала к объекту с помощью инструментальной палитры

Для применения материала к объекту с помощью окна "Материалы"

Открепление материала от объекта

Для применения материала по слою


Для применения материала к объекту с помощью инструментальной палитры (Процедура)

Применение материалов к объектам и граням
Применение материалов к объектам и граням
Применение материалов к объектам и граням
Тонирование чертежа для презентации > Материалы и текстуры > Применение материалов к объектам и граням >
Применение материалов к объектам и граням
Понятие Процедура Краткий справочник

Для применения материала к объекту с помощью инструментальной палитры

  1. Выберите меню Инструменты [image] Палитры [image] Инструментальные палитры.

    Если в окне "Инструментальные палитры" не отображаются материалы, выполните одно из указанных ниже действий. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы..

  2. Нажмите кнопку мыши на инструментальной палитре для её активизации.
  3. Перетащите материал из инструментальной палитры на объект.
Ввод команды: ИНСТРПАЛВКЛ


Для применения материала к объекту с помощью окна "Материалы" (Процедура)

Применение материалов к объектам и граням
Применение материалов к объектам и граням
Применение материалов к объектам и граням
Тонирование чертежа для презентации > Материалы и текстуры > Применение материалов к объектам и граням >
Применение материалов к объектам и граням
Понятие Процедура Краткий справочник

Для применения материала к объекту с помощью окна "Материалы"

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" выберите материал, который требуется применить.
  3. Нажмите кнопку "Применить материал к объектам".
  4. Выберите объект с помощью специального указателя.

    Материал отображается на каждом выбираемом объекте.

Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Открепление материала от объекта (Процедура)

Применение материалов к объектам и граням
Применение материалов к объектам и граням
Применение материалов к объектам и граням
Тонирование чертежа для презентации > Материалы и текстуры > Применение материалов к объектам и граням >
Применение материалов к объектам и граням
Понятие Процедура Краткий справочник

Открепление материала от объекта

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" нажмите кнопку "Убрать материалы с выбранных объектов".
  3. Выберите объект с помощью специального указателя.

Материал удаляется.

Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Для применения материала по слою (Процедура)

Применение материалов к объектам и граням
Применение материалов к объектам и граням
Редактирование материалов
Тонирование чертежа для презентации > Материалы и текстуры > Применение материалов к объектам и граням >
Применение материалов к объектам и граням
Понятие Процедура Краткий справочник

Для применения материала по слою

  1. В командной строке введите материалприсв.
  2. В диалоговом окне "Параметры назначения материала" перетащите материал на слой.

    Материал применяется ко всем объектам слоя, у которых для свойства "Материал" задано значение ПОСЛОЮ. При создании объекта по умолчанию для свойства "Материал" используется значение ПОСЛОЮ.


Применение материалов к объектам и граням (Краткий справочник)

Создание материалов
Применение материалов к объектам и граням
Редактирование материалов
Тонирование чертежа для презентации > Материалы и текстуры > Применение материалов к объектам и граням >
Применение материалов к объектам и граням
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

CMATERIAL

Задание материала для новых объектов

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Редактирование материалов (Понятие)

Применение материалов к объектам и граням
Материалы и текстуры
Дополнительное переопределение освещения
Тонирование чертежа для презентации > Материалы и текстуры >
Редактирование материалов
Понятие Процедура Краткий справочник

Свойства материала можно изменять после создания материала или после применения материала.

После создания и применения материала его можно изменить в окне "Материалы", а также на палитре инструментов "Материалы" (если этот материал назначен палитре инструментов).

Окно "Материалы"

Образцы материалов, существующие на чертеже, отображаются в верхней части окна "Материалы". При выборе образца материала свойства этого материала в разделах окна "Материалы" становятся активными.

В разделах окна "Материалы" отображаются различные параметры свойств.

  • Материалы, имеющиеся в чертеже. Образцы материалов и кнопок инструментов.
  • Перемещение по вложенным текстурам. Активный материал и материалы в дереве карт.
  • Редактор материалов. Отображение типов, шаблонов и свойств материалов.
  • Текстуры. Отображение каналов текстур, выбранного типа текстуры и кнопок инструментов, а также доступ к элементам управления для процедурных карт.
  • Дополнительные параметры освещения.(Только для типов "Реалистичный" и "Реалистичное тонирование металла"). Задание параметров, влияющих на тонирование материала при освещении фотометрическими источниками света.
  • Масштабирование и наложение материала. Задание канала текстур или синхронизация коэффициента масштабирования и мозаичного расположения для совместного использования на всех уровнях текстур. Этот раздел предназначен для работы с двумерными текстурами ("Текстура", "Клетки", "Формула градиента", "Мозаика") и каналами текстур (рассеяние, выдавливание, непрозрачность, отражение).
  • Смещение текстуры материала и просмотр. Свойства смещения и предварительного просмотра карт, наложенных на материалы.

Отображается окно "Материалы". С левой стороны панели закрываются. С правой стороны некоторые панели разворачиваются.

Изменения параметров сохраняются в образце материала по мере их внесения. Изменения отображаются в области предварительного просмотра образца материала. При повторном тонировании чертежа изменения отображаются на всех объектах, которые содержат измененный материал.

Можно изменить имя материала и форму области предварительного просмотра материала. Щелкните правой кнопкой мыши на образце в области предварительного просмотра и выберите "Редактировать имя и описание". При нажатии первой кнопки, расположенной под окном предварительного просмотра, выдвигается набор кнопок, представляющих различные геометрические формы для окна предварительного просмотра.

ПримечаниеЕсли измененный материал присутствует на инструментальной палитре, необходимо обновить инструментальную палитру, задав новые параметры материала.
См. также

    • Инструментальные палитры "Материалы"


Редактирование материалов (Процедура)

Применение материалов к объектам и граням
Редактирование материалов
Редактирование материалов
Тонирование чертежа для презентации > Материалы и текстуры > Редактирование материалов >
Редактирование материалов
Понятие Процедура Краткий справочник

Изменение параметров материала на инструментальной палитре

Для изменения имени материала

Для изменения формы образца для предварительного просмотра материала


Изменение параметров материала на инструментальной палитре (Процедура)

Редактирование материалов
Редактирование материалов
Редактирование материалов
Тонирование чертежа для презентации > Материалы и текстуры > Редактирование материалов >
Редактирование материалов
Понятие Процедура Краткий справочник

Изменение параметров материала на инструментальной палитре

  1. Выберите инструментальную палитру.
  2. Щелкните правой кнопкой мыши на материале и выберите "Свойства".

    Отображается диалоговое окно "Свойства инструмента".

  3. На инструментальной палитре щелкните правой кнопкой мыши на измененном материале.
  4. В контекстном меню материала выберите "Обновить изображение инструмента".
Ввод команды: ИНСТРПАЛВКЛ


Для изменения имени материала (Процедура)

Редактирование материалов
Редактирование материалов
Редактирование материалов
Тонирование чертежа для презентации > Материалы и текстуры > Редактирование материалов >
Редактирование материалов
Понятие Процедура Краткий справочник

Для изменения имени материала

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы выберите материал и щелкните правой кнопкой мыши. Выберите "Редактировать имя и описание".
  3. В диалоговом окне "Редактировать имя и описание" измените имя и описание материала.
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Для изменения формы образца для предварительного просмотра материала (Процедура)

Редактирование материалов
Редактирование материалов
Текстура рассеяния
Тонирование чертежа для презентации > Материалы и текстуры > Редактирование материалов >
Редактирование материалов
Понятие Процедура Краткий справочник

Для изменения формы образца для предварительного просмотра материала

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" нажмите и удерживайте первый значок в полоске кнопок под образцами.
  3. Выберите для окна предварительного просмотра материала другую форму.
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Редактирование материалов (Краткий справочник)

Применение материалов к объектам и граням
Редактирование материалов
Дополнительное переопределение освещения
Тонирование чертежа для презентации > Материалы и текстуры > Редактирование материалов >
Редактирование материалов
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Дополнительное переопределение освещения (Понятие)

Редактирование материалов
Материалы и текстуры
Повышение реалистичности изображения с помощью текстур
Тонирование чертежа для презентации > Материалы и текстуры >
Дополнительное переопределение освещения
Понятие Краткий справочник

Функция дополнительного переопределения освещения позволяет задать параметры, влияющие на тонирование объекта при освещении отраженным светом общего освещения и/или освещения методом чистовых проб.

Дополнительные параметры переопределения освещения позволяют изменять свойства материала, влияющие на отображение тонированной сцены. Эта возможность доступна только для типов материала "Реалистичный" и "Реалистичное тонирование металла". Общее освещение - это способ непрямого освещения, который допускает такие эффекты, как цветовое рассеивание. Свет, падая на цветной объект модели, отражается от него на смежные объекты, добавляя к ним оттенок цвета исходного объекта. Отражённое освещение усиливает реализм изображения путём имитации отсвечивания или взаимного отражения объектов. Дополнительные сведения об отраженном освещении, общем освещении и чистовых пробах см. в разделе "Дополнительные функции тонирования".

Пользователь может задать следующие параметры:

  • Коэффициент цветового заполнения. Усиление или уменьшение насыщенности отраженного цвета.
  • Непрямой рельефный коэффициент. Коэффициент, с помощью которого регулируется текстура выдавливания на участках, освещенных отраженным светом.
  • Коэффициент отражения. Увеличивает или уменьшает количество световой энергии, отражаемой материалом. Коэффициент отражения - это процент диффузного света, отраженного от материала.
  • Коэффициент пропускания. Служит для увеличения или уменьшения количества энергии, проходящего через материал. Коэффициент пропускания определяет количество световой энергии, проходящее через материал. Полностью непрозрачный материал имеет коэффициент пропускания, равный 0%.

Материалы с ярким диффузным цветом или сильным блеском имеют высокий коэффициент отражения. Из-за этого отраженное освещение может стать передержанным или блеклым. В некоторых случаях дополнительное переопределение освещения позволяет улучшить качество отраженного освещения. Ниже приведены примеры ситуаций, в которых настройка параметров материала позволяет включить в изображение большие темные участки и размытые цветовые контуры.

  • Когда большой цветовой участок (например, красный ковер в комнате с белыми стенами) создает излишнее цветовое рассеяние, можно попробовать уменьшить коэффициент отражения или коэффициент цветового заполнения. С точки зрения физики это может быть правильно, однако зрение непривычно к таким эффектам, и зрительно результат отраженного освещения может выглядеть лучше, если уменьшить отражение или коэффициент цветового заполнения.
  • Когда в сцене присутствует большой темный участок (например, черный пол), можно попробовать увеличить коэффициент отражения. В такой ситуации сцена кажется очень темной. Можно попробовать оставить цвет пола прежним, но увеличить его отражение и тем самым увеличить его яркость.

Если материал прозрачен (как например, прозрачное стекло), световая энергия не рассеивается и свет проходит прямо через материал (при этом преломляясь). Значение направленного пропускания зависит от параметра "Прозрачность", установленного для материала. Материал с высоким коэффициентом пропускания обычно имеет низкий коэффициент отражения и наоборот.


Дополнительное переопределение освещения (Краткий справочник)

Редактирование материалов
Дополнительное переопределение освещения
Повышение реалистичности изображения с помощью текстур
Тонирование чертежа для презентации > Материалы и текстуры > Дополнительное переопределение освещения >
Дополнительное переопределение освещения
Понятие Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Повышение реалистичности изображения с помощью текстур (Понятие)

Дополнительное переопределение освещения
Материалы и текстуры
Использование наложения текстур для улучшения реалистичности
Тонирование чертежа для презентации > Материалы и текстуры >
Повышение реалистичности изображения с помощью текстур
Понятие Краткий справочник

Наложение карт позволяет сделать материал более сложным.

При наложении используются различные уровни параметров и свойств карты. В отношении карт действует следующая иерархия:

  • Тип материала определяет набор доступных каналов текстур, таких как "Рассеяние", "Отражение" (только для дополнительных типов материалов), "Непрозрачность" и "Выдавливание".
  • Выбор канала текстур переопределяет назначение диффузного цвета в редакторе материалов.
  • В рамках наложения текстур выбирается тип текстуры - "Текстура" или одна из процедурных карт ("Клетки", "Мрамор" и т. д.). Карта текстуры имеет параметры свойств только для верхнего уровня материала, но позволяет выбрать изображение для наложения на объект или грань. Процедурные карты имеют параметры свойств и на следующем уровне.
  • Функция вложенных процедурных карт позволяет вложить текстуру или процедурную карту в другую процедурную карту. Эта функция доступна только в то случае, если на верхнем уровне выбрана процедурная карта.

Темы в этом разделе

  • Использование наложения текстур для улучшения реалистичности

    Использование наложения текстур повышает уровень реалистичности текстуры материала.

  • Типы карт

    Для получения сложной структуры материала можно выбирать текстуры или процедурные карты а пределах каждого канала текстур ("Рассеяние", "Отражение", "Непрозрачность" и "Выдавливание").

  • Изменение свойств текстуры

    При создании сложных узоров можно изменить свойства текстуры путем изменения значений параметров текстуры.

  • Настройка наложений на объектах и гранях

    После присоединения материала с текстурой можно настроить ориентацию текстуры на объектах или гранях.


Повышение реалистичности изображения с помощью текстур (Краткий справочник)

Дополнительное переопределение освещения
Повышение реалистичности изображения с помощью текстур
Использование наложения текстур для улучшения реалистичности
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур >
Повышение реалистичности изображения с помощью текстур
Понятие Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Использование наложения текстур для улучшения реалистичности (Понятие)

Повышение реалистичности изображения с помощью текстур
Повышение реалистичности изображения с помощью текстур
Текстура рассеяния
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур >
Использование наложения текстур для улучшения реалистичности
Понятие Краткий справочник

Использование наложения текстур повышает уровень реалистичности текстуры материала.

Каналы текстур служат для добавления узора или текстуры к цвету материала. При включении наложения текстур диффузный цвет материала заменяется цветами карты.

После выбора типа наложения можно использовать любую Текстура, или один из Процедурные карты, например, дерево или мрамор. Например, если нужно представить стену из кирпича, можно выбрать текстуру, изображающую кирпичную кладку. Это наиболее общий вариант наложения карты. Можно также применить процедурную карту, например, "Мозаика" или "Дерево". Процедурные карты имеют свойства, которые можно настраивать для получения нужного эффекта. Это могут быть, например, размер плиток или толщина растворного шва в материале с кирпичным рисунком или расстояние между волокнами в деревянном материале.

Схему, добавляемую к материалу, можно масштабировать или вписывать в объект. Образец можно делать мозаичным или поворачивать его.

Текстуры также подходят и для других целей. Для одного и того же материала можно использовать разные карты и создавать вложенные карты.

После применения карты ее можно вписать в грань или объект с помощью функции наложения материала.

ПримечаниеПри включенной функции "Сжатие текстур" уменьшается объем видеопамяти, необходимой для открытия чертежа, содержащего материалы с изображениями. При использовании сжатия текстур объем видеопамяти, необходимой для отображения чертежа, уменьшается, однако увеличивается время загрузки изображений при первом доступе к ним. Кроме того, имеет место ухудшение качества изображений при отображении в видовом экране или при выводе на печать. При выполнении тонирования потери качества изображений нет.

Темы в этом разделе

  • Текстура рассеяния

    Текстура рассеяния позволяет назначить материалу цветной узор.

  • Текстура отражения

    Текстура отражения имитирует сцену, отраженную от поверхности блестящего объекта.

  • Карта непрозрачности

    Карты непрозрачности используются для создания иллюзии непрозрачности или прозрачности.

  • Текстура выдавливания

    Текстура выдавливания имитирует бугристую или неровную поверхность.


Использование наложения текстур для улучшения реалистичности (Краткий справочник)

Повышение реалистичности изображения с помощью текстур
Повышение реалистичности изображения с помощью текстур
Текстура рассеяния
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности >
Использование наложения текстур для улучшения реалистичности
Понятие Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Текстура рассеяния (Понятие)

Использование наложения текстур для улучшения реалистичности
Использование наложения текстур для улучшения реалистичности
Текстура отражения
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности >
Текстура рассеяния
Понятие Процедура Краткий справочник

Текстура рассеяния позволяет назначить материалу цветной узор.

В качестве карты текстуры или процедурной карты для назначения узора или текстуры диффузному цвету материала пользователь может выбрать файл изображения. Цвета текстуры полностью или частично заменяют в Редактор материалов компонент материала с диффузным цветом. Это наиболее общий вариант наложения текстуры.

Наложение диффузного цвета подобно нанесению краски на поверхность объекта. Например, если нужно представить стену из кирпича, можно выбрать файл с фотографией кирпичной кладки или имитировать узор кладки с помощью процедурной карты с плитками.


Текстура рассеяния (Процедура)

Редактирование материалов
Текстура рассеяния
Текстура рассеяния
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура рассеяния >
Текстура рассеяния
Понятие Процедура Краткий справочник

Наложение цвета текстуры рассеяния

Для удаления текстуры рассеяния из материала


Наложение цвета текстуры рассеяния (Процедура)

Текстура рассеяния
Текстура рассеяния
Текстура рассеяния
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура рассеяния >
Текстура рассеяния
Понятие Процедура Краткий справочник

Наложение цвета текстуры рассеяния

  1. В окне "Материалы" выберите материал.
  2. В разделе "Карты" выберите "Текстура рассеяния".
  3. Выберите тип текстуры, например, "Текстура", или процедурные карты, например, "Клетки", "Мрамор", "Помехи" и т.п.
  4. В разделе "Карта текстуры" выберите "Изображение". Для задания дополнительных свойств текстуры нажмите кнопку "Нажмите для обращения к параметрам <тип текстуры>" (или "Параметры <тип текстуры>") для доступа к значениям свойств процедурной карты.
  5. Для предварительного просмотра структуры нажмите кнопку "Просмотр результатов процедуры настройки наложения текстуры".
Панель:Тонирование
Ввод команды: МАТЕРИАЛСООТВ


Для удаления текстуры рассеяния из материала (Процедура)

Текстура рассеяния
Текстура рассеяния
Текстура отражения
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура рассеяния >
Текстура рассеяния
Понятие Процедура Краткий справочник

Для удаления текстуры рассеяния из материала

  1. В окне "Материалы" выберите материал.
  2. В окне "Материалы" отмените выбор элемента "Текстура рассеяния" в разделе "Карты".
  3. Для удаления текстуры рассеяния из материала нажмите на значке "Удаление из материала информации о наложении".

    Программа предложит удалить все вложенные карты.

  4. Нажмите "Да".

    Из материала удаляется назначенная ему текстура рассеяния вместе с вложенными в нее текстурами.

Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Текстура рассеяния (Краткий справочник)

Использование наложения текстур для улучшения реалистичности
Использование наложения текстур для улучшения реалистичности
Текстура отражения
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура рассеяния >
Текстура рассеяния
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Текстура отражения (Понятие)

Текстура рассеяния
Использование наложения текстур для улучшения реалистичности
Карта непрозрачности
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности >
Текстура отражения
Понятие Процедура Краткий справочник

Текстура отражения имитирует сцену, отраженную от поверхности блестящего объекта.

Для моделирования сцены, отражающейся на поверхности блестящего объекта, используется текстура отражения. Для хорошего отображения текстур отражения при тонировании материал должен быть блестящим, а картинка текстуры отражения должна иметь высокое разрешение (по меньшей мере, 512х480 пикселов). Текстуры отражения недоступны для типов материала "Реалистичный" и "Реалистичное тонирование металла".


Текстура отражения (Процедура)

Текстура рассеяния
Текстура отражения
Текстура отражения
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура отражения >
Текстура отражения
Понятие Процедура Краткий справочник

Для назначения текстуры отражения

Для удаления текстуры отражения из материала


Для назначения текстуры отражения (Процедура)

Текстура отражения
Текстура отражения
Текстура отражения
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура отражения >
Текстура отражения
Понятие Процедура Краткий справочник

Для назначения текстуры отражения

  1. В окне "Материалы" выберите материал.
  2. В окне "Редактор материалов" выберите тип материала "Дополнительно".
  3. В разделе "Карты" выберите "Текстура отражения".
  4. Выберите тип текстуры, например, "Текстура", или процедурные карты, например, "Клетки", "Мрамор", "Помехи" и т.п.
  5. В разделе "Карта текстуры" выберите "Изображение". В случае процедурных карт нажмите кнопку "Нажмите для обращения к параметрам <тип текстуры>" (или "Параметры <тип текстуры>").
  6. Для предварительного просмотра структуры нажмите кнопку "Просмотр результатов процедуры настройки наложения текстуры".
  7. Для изменения настроек воспользуйтесь шкалой текстуры отражения.
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Для удаления текстуры отражения из материала (Процедура)

Текстура отражения
Текстура отражения
Карта непрозрачности
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура отражения >
Текстура отражения
Понятие Процедура Краткий справочник

Для удаления текстуры отражения из материала

  1. В окне "Материалы" выберите материал.
  2. В разделе "Карты" отмените выбор элемента "Текстура отражения".
  3. Для удаления текстуры отражения из материала щелкните на значке "Удалите из материала информацию о наложении".

    Программа предложит удалить все вложенные карты.

  4. Нажмите "Да".

    Текстура отражения и вложенные карты будут удалены с материала.

Панель:Тонирование
Ввод команды: МАТЕРИАЛСООТВ


Текстура отражения (Краткий справочник)

Текстура рассеяния
Использование наложения текстур для улучшения реалистичности
Карта непрозрачности
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура отражения >
Текстура отражения
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Карта непрозрачности (Понятие)

Текстура отражения
Использование наложения текстур для улучшения реалистичности
Текстура выдавливания
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности >
Карта непрозрачности
Понятие Процедура Краткий справочник

Карты непрозрачности используются для создания иллюзии непрозрачности или прозрачности.

С помощью канала текстуры непрозрачности можно задать прозрачные и непрозрачные участки. Например, если при работе с материалом типа "Реалистичный" применить текстуру непрозрачности к изображению, представляющему собой белый круг в центре черного прямоугольника, наложение круга на объект создает впечатление отверстия на поверхности. При работе с материалом типа "Реалистичный" или "Дополнительные" черный круг в центре белого прямоугольника создает впечатление отверстия, если круг наложен на объект. Если изображение цветное, то для каждого цвета можно использовать полутонирование.


Карта непрозрачности (Процедура)

Текстура отражения
Карта непрозрачности
Карта непрозрачности
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Карта непрозрачности >
Карта непрозрачности
Понятие Процедура Краткий справочник

Для назначения материалу карты непрозрачности

Для удаления карты непрозрачности из материала


Для назначения материалу карты непрозрачности (Процедура)

Карта непрозрачности
Карта непрозрачности
Карта непрозрачности
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Карта непрозрачности >
Карта непрозрачности
Понятие Процедура Краткий справочник

Для назначения материалу карты непрозрачности

  1. В окне "Материалы" выберите материал.
  2. В разделе "Карты" выберите "Текстура непрозрачности".
  3. Выберите тип текстуры, например, "Текстура", или процедурные карты, например, "Клетки", "Мрамор", "Помехи" и т.п.
  4. В случае значения "Текстура" выберите "Изображение". В случае процедурных карт нажмите кнопку "Нажмите для обращения к параметрам <тип текстуры>" (или "Параметры <тип текстуры>").
  5. Для предварительного просмотра структуры нажмите кнопку "Просмотр результатов процедуры настройки наложения текстуры".
  6. Для изменения настроек воспользуйтесь шкалой карты непрозрачности.
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Для удаления карты непрозрачности из материала (Процедура)

Карта непрозрачности
Карта непрозрачности
Текстура выдавливания
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Карта непрозрачности >
Карта непрозрачности
Понятие Процедура Краткий справочник

Для удаления карты непрозрачности из материала

  1. В окне "Материалы" выберите материал.
  2. В разделе "Карты" отмените выбор элемента "Текстура непрозрачности".
  3. Для удаления текстуры непрозрачности из материала щелкните на значке "Удалите из материала информацию о наложении".

    Программа предложит удалить все вложенные карты.

  4. Нажмите "Да".

    Карта непрозрачности и вложенные карты будут удалены из материала.

Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Карта непрозрачности (Краткий справочник)

Текстура отражения
Использование наложения текстур для улучшения реалистичности
Текстура выдавливания
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Карта непрозрачности >
Карта непрозрачности
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Текстура выдавливания (Понятие)

Карта непрозрачности
Использование наложения текстур для улучшения реалистичности
Типы карт
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности >
Текстура выдавливания
Понятие Процедура Краткий справочник

Текстура выдавливания имитирует бугристую или неровную поверхность.

В качестве текстуры выдавливания можно выбрать файл изображения или процедурные карты. Наложение текстуры выдавливания делает поверхность объекта бугристой или неровной. При тонировании объекта, на который наложен материал с картой выдавливания, более светлые (белые) области текстуры выглядят приподнятыми, а более темные (черные) области - более низкими. Если изображение цветное, можно использовать полутонирование. Наложение текстуры выдавливания значительно увеличивает время тонирования, но повышает реалистичность сцены.

При наложении текстуры выдавливания для воздействия на поверхность материала используется интенсивность карты. В этом случае интенсивность влияет на кажущуюся неровность поверхности: белые участки выглядят выступающими, черные - утопленными.

Текстуры выдавливания рекомендуется применять в том случае, если поверхность не должна выглядеть гладкой, в частности, для создания тисненой поверхности. Однако следует учитывать, что с помощью текстуры выдавливания можно создать только ограниченный эффект глубины. Если на поверхности требуется создать более глубокий рельеф, следует использовать не текстуры выдавливания, а методы моделирования.

Степень выдавливания можно настроить с помощью регулятора текстуры выдавливания. Большие значения дают более глубокий рельеф, а низкие значения - менее глубокий.

Выпуклости представляют собой имитацию, создаваемую отклонениями перпендикуляров грани перед тонированием объекта. По этой причине выпуклости не отображаются на силуэтах объектов.


Текстура выдавливания (Процедура)

Карта непрозрачности
Текстура выдавливания
Текстура выдавливания
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура выдавливания >
Текстура выдавливания
Понятие Процедура Краткий справочник

Назначение материалу текстуры выдавливания

Удаление текстуры выдавливания из материала


Назначение материалу текстуры выдавливания (Процедура)

Текстура выдавливания
Текстура выдавливания
Текстура выдавливания
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура выдавливания >
Текстура выдавливания
Понятие Процедура Краткий справочник

Назначение материалу текстуры выдавливания

  1. В окне "Материалы" выберите материал.
  2. В разделе "Карты" выберите "Текстура выдавливания".
  3. Выберите тип текстуры: Текстура или одну из процедурных карт, например, "Клетки", "Мрамор", "Помехи" и т.п.
  4. В случае значения "Текстура" выберите "Изображение". В случае процедурных карт нажмите кнопку "Нажмите для обращения к параметрам <тип текстуры>" (или "Параметры <тип текстуры>").
  5. Для предварительного просмотра структуры нажмите кнопку "Просмотр результатов процедуры настройки наложения текстуры".
  6. Для изменения настроек воспользуйтесь шкалой текстуры выдавливания.
Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Удаление текстуры выдавливания из материала (Процедура)

Текстура выдавливания
Текстура выдавливания
Текстура
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура выдавливания >
Текстура выдавливания
Понятие Процедура Краткий справочник

Удаление текстуры выдавливания из материала

  1. В окне "Материалы" выберите материал.
  2. В разделе "Карты" выберите "Текстура выдавливания".
  3. Для удаления текстуры выдавливания из материала щелкните на значке "Удалите из материала информацию о наложении".

    Программа предложит удалить все вложенные карты.

  4. Нажмите "Да".

    Текстура выдавливания и вложенные карты будут удалены из материала.

Панель:Тонирование
Ввод команды: МАТЕРИАЛЫ


Текстура выдавливания (Краткий справочник)

Карта непрозрачности
Использование наложения текстур для улучшения реалистичности
Типы карт
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Использование наложения текстур для улучшения реалистичности > Текстура выдавливания >
Текстура выдавливания
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Типы карт (Понятие)

Текстура выдавливания
Повышение реалистичности изображения с помощью текстур
Текстура
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур >
Типы карт
Понятие Краткий справочник

Для получения сложной структуры материала можно выбирать текстуры или процедурные карты а пределах каждого канала текстур ("Рассеяние", "Отражение", "Непрозрачность" и "Выдавливание").

Имеются следующие типы карт:

  • Текстура. В качестве карты используется файл изображения.
  • Шашечки. Используется двухцветный шахматный рисунок.
  • Формула градиента. Создаются различные варианты градиента с применением цветов, текстур и сглаживания.
  • Мрамор. Карта "Мрамор" позволяет нанести на материал цвет камня и цвет прожилок.
  • Шум. Искажение поверхности рассчитывается на основе случайного взаимодействия двух цветов.
  • Пятна. Создается пятнистый узор поверхности.
  • Плитка. Цвета размещаются в виде кирпичной кладки или уложенных плиток или используются текстуры материала.
  • Волны. Создает водянистый или волнистый эффект.
  • Дерево. Карта типа "Дерево" используется для создания цвета и узора волокон деревянной поверхности.

Каждый тип карты имеет специальный набор элементов управления. Предусмотрена возможность настройки параметров, включая отключение, удаление или синхронизацию текстуры, в пределах каждого канала текстур. Для синхронизации всех каналов текстур можно включать и отключать изменения параметров и значений для канала текстур с помощью переключателя "Синхронизация текстур". По умолчанию режим синхронизации текстур включен (отображается значок, состоящий из соединенных частей). В положении "включен" отображается значок объединения. Если данный режим отключен, отображается значок, состоящий из разделенных частей.

На экране " Перемещение по вложенным текстурам" отображается краткая справочная информация о вложенных текстурах, назначенных данному материалу. Для отображения вложенных текстур щелкните на стрелке раскрывающегося списка рядом с именем материала.

После применения типа текстуры ее можно вписать в грань или объект с помощью функции наложения материалов.

ПримечаниеПри включенной функции "Сжатие текстур" уменьшается объем видеопамяти, необходимой для открытия чертежа, содержащего материалы с изображениями. При сжатии текстур уменьшается объем видеопамяти, необходимой для отображения чертежа, но увеличивается время, затрачиваемое на загрузку изображений при первом обращении к ним. Кроме того, при выводе изображений на видовой экран или на печать ухудшается качество изображения. При создании тонирования качество изображения остается без изменений.

Темы в этом разделе

  • Текстура

    С помощью текстур удобно создавать разнообразные материалы, например волокнистую поверхность дерева или поверхности стен.

  • Процедурные карты

    Процедурные карты придают материалу дополнительную реалистичность.


Типы карт (Краткий справочник)

Текстура выдавливания
Повышение реалистичности изображения с помощью текстур
Текстура
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт >
Типы карт
Понятие Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Текстура (Понятие)

Типы карт
Типы карт
Процедурные карты
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт >
Текстура
Понятие Процедура Краткий справочник

С помощью текстур удобно создавать разнообразные материалы, например волокнистую поверхность дерева или поверхности стен.

Ниже указаны типы файлов, на основе которых можно создавать текстуры.

  • BMP, RLE или DIB
  • GIF
  • JFIF, JPG или JPEG
  • PCX
  • PNG
  • TGA
  • TIFF

. Для отображения раздела " Значения свойств текстуры", относящегося к текстуре, нажмите кнопку "Настройка наложения текстур".

Для возврата к текстуре вышележащего уровня после изменения значений свойств нажмите рядом с именем " Перемещение по вложенным текстурам" в верхней части окна значений свойств кнопку [image] ("На один уровень вверх к базовой текстуре").

Примеры текстур


Текстура (Процедура)

Текстура выдавливания
Текстура
Текстура
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Текстура >
Текстура
Понятие Процедура Краткий справочник

Добавление текстуры к материалу

Отключение текстуры или удаление ее из материала


Добавление текстуры к материалу (Процедура)

Текстура
Текстура
Текстура
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Текстура >
Текстура
Понятие Процедура Краткий справочник

Добавление текстуры к материалу

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" на панели Материалы, имеющиеся в чертеже нажмите кнопку "Создать новый материал".
  3. Выберите для материала тип "Реалистичный".
  4. Выберите "Текстура рассеяния"; для параметра "Тип текстуры" выберите значение "Текстура".
  5. Нажмите кнопку "Выбрать изображение" и выберите изображение из имеющихся в наличии.
  6. Для доступа к дополнительным элементам управления картой нажмите кнопку со стрелкой вниз, затем "Параметры свойств карт текстуры".
  7. Внесите изменения в Значения свойств текстуры.
  8. После внесения изменений нажмите кнопку "На один уровень вверх к базовой текстуре" для возврата к текстуре вышележащего уровня (эта кнопка расположена в верхней части окна значений свойств рядом с именем " Перемещение по вложенным текстурам" и кнопкой со стрелкой вниз).
  9. Для отображения образца в окне большего размера выберите "Просмотр результатов процедуры наложения текстуры".
  10. На панели навигации по вложенным текстурам щелкните на стрелке вниз.

    Отображается текстура.

После внесения изменений в материал можно применять материалы к объектам и граням.

Панель:Тонирование


Отключение текстуры или удаление ее из материала (Процедура)

Текстура
Текстура
Процедурные карты
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Текстура >
Текстура
Понятие Процедура Краткий справочник

Отключение текстуры или удаление ее из материала

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" на панели "Материалы, имеющиеся в чертеже" выберите образец материала или создайте образец с помощью кнопки "Создать новый материал".
  3. Выберите для материала тип "Реалистичный".
  4. Выберите "Текстура рассеяния"; для параметра "Тип текстуры" выберите значение "Текстура".
  5. Нажмите кнопку "Выбрать изображение" и выберите изображение из имеющихся в наличии.
  6. В разделе " Перемещение по вложенным текстурам" щелкните на стрелке раскрывающегося списка.

    Отображается имя изображения карты рассеяния и текстуры.

  7. Снимите флажок "Текстура рассеяния".
  8. На панели навигации по вложенным текстурам щелкните на стрелке вниз.

    Имя изображения карты рассеяния и текстуры отображается серым цветом и неактивно.

  9. Установите флажок "Текстура рассеяния".
  10. На панели навигации по вложенным текстурам щелкните на стрелке вниз.

    Имя изображения карты рассеяния и текстуры становится активным.

  11. На панели канала текстуры рассеяния нажмите кнопку "Удалите из материала информацию о наложении" для удаления текстуры, назначенной материалу.
  12. На панели навигации по вложенным текстурам щелкните на стрелке вниз.

    Имя изображения текстуры больше не отображается в списке навигации.

Панель:Тонирование


Текстура (Краткий справочник)

Типы карт
Типы карт
Процедурные карты
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Текстура >
Текстура
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Процедурные карты (Понятие)

Текстура
Типы карт
Шашечки
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт >
Процедурные карты
Понятие Процедура Краткий справочник

Процедурные карты придают материалу дополнительную реалистичность.

В отличие от растровых изображений, в которых используется похожая на мозаику фиксированная матрица цветных пикселов, процедурные карты формируются с помощью математического алгоритма. Поэтому типы элементов управления для процедурных карт зависят от особенностей процедуры. Процедурную карту можно сформировать в двух или трех измерениях. Для увеличения глубины и повышения сложности материала можно также вложить в процедурную карту текстуры или другие процедурные карты.

Примеры процедурных карт с вариациями. Верхний ряд: "Мрамор", "Шашечки", "Пятна" и "Волны". Нижний ряд: "Мозаика", "Помехи" и "Дерево".

Темы в этом разделе

  • Шашечки

    Применение двухцветного шахматного узора к материалу.

  • Формула градиента

    Создание градиентов с применением цветов, текстур и сглаживания.

  • Мрамор

    Карта "Мрамор" позволяет нанести на материал цвет камня и цвет прожилок.

  • Шум

    Создание случайных искажений поверхности за счет взаимодействия двух цветов и/или текстур.

  • Пятна

    Создается пятнистый узор поверхности.

  • Плитка

    В карте типа "Плитка" цвета размещаются в виде кирпичной кладки или уложенных плиток или используются текстуры материала.

  • Волны

    Имитация эффектов водной поверхности или волн.

  • Дерево

    Карта типа "Дерево" используется для создания цвета и узора волокон деревянной поверхности.


Процедурные карты (Процедура)

Текстура
Процедурные карты
Процедурные карты
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Процедурные карты
Понятие Процедура Краткий справочник

Добавление процедурной карты в материал

Для отключения процедурной карты или удаления ее из материала

Для вложения процедурной карты в другую процедурную карту


Добавление процедурной карты в материал (Процедура)

Процедурные карты
Процедурные карты
Процедурные карты
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Процедурные карты
Понятие Процедура Краткий справочник

Добавление процедурной карты в материал

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" на панели " Материалы, имеющиеся в чертеже" нажмите кнопку "Создать новый материал".
  3. Выберите для материала тип "Реалистичный".
  4. Выберите "Текстура рассеяния"; для параметра "Тип текстуры" выберите одну из процедурных карт ("Клетки", "Формула градиента", "Мрамор", "Помехи", "Пятна", "Мозаика", "Волны" или "Дерево").
  5. Для задания дополнительных свойств текстуры нажмите кнопку "Нажмите для обращения к параметрам <тип текстуры>" (или "Параметры <тип текстуры>").
  6. Внесите изменения в Значения свойств текстуры значения свойств текстуры.
  7. Для возврата к текстуре вышележащего уровня нажмите кнопку "На один уровень вверх к базовой текстуре" в верхней части окна значений свойств.
  8. Для отображения образца материала в окне большего размера выберите "Просмотр результатов процедуры наложения текстуры".
  9. На панели навигации по вложенным текстурам щелкните на стрелке вниз.

    Отображается процедурная карта. Пример. "Рассеяние" : "Клетки".

ПримечаниеДля каждого типа процедурных карт доступны разные параметры свойств. Дополнительные сведения см. в разделе " Значения свойств текстуры" документа "Справочник команд".

После внесения изменений в материал можно применять материалы к объектам и граням.

Панель:Тонирование


Для отключения процедурной карты или удаления ее из материала (Процедура)

Процедурные карты
Процедурные карты
Процедурные карты
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Процедурные карты
Понятие Процедура Краткий справочник

Для отключения процедурной карты или удаления ее из материала

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" на панели "Материалы, имеющиеся в чертеже" выберите образец материала или создайте образец с помощью кнопки "Создать новый материал".
  3. Выберите для материала тип "Реалистичный".
  4. Выберите "Текстура рассеяния"; для параметра "Тип текстуры" выберите одну из процедурных карт ("Клетки", "Формула градиента", "Мрамор", "Помехи", "Пятна", "Мозаика", "Волны" или "Дерево").
  5. Нажмите "стрелку вниз" в Перемещение по вложенным текстурам. Отображается текстура рассеяния, а также имя процедурной карты. Пример. "Рассеяние" : "Клетки".
  6. Снимите флажок "Текстура рассеяния".
  7. На панели навигации по вложенным текстурам щелкните на стрелке вниз.

    Параметр "Рассеяние" и имя процедурной карты отображаются серым цветом и не доступны.

  8. Установите флажок "Текстура рассеяния".
  9. Нажмите "стрелку вниз" в панели "Обзор вложенных карт". Имя карты рассеяния и процедурной карты становится активным.
  10. На панели канала текстуры рассеяния нажмите кнопку "Удалите из материала информацию о наложении" для удаления текстуры, назначенной материалу. На кнопке изображен знак "х" красного цвета.
  11. Нажмите "стрелку вниз" в панели "Обзор вложенных карт". Имя процедурной карты больше не отображается в списке навигации.
Панель:Тонирование


Для вложения процедурной карты в другую процедурную карту (Процедура)

Процедурные карты
Процедурные карты
Настройка наложений на объектах и гранях
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Процедурные карты
Понятие Процедура Краткий справочник

Для вложения процедурной карты в другую процедурную карту

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Материалы" [image] Материалы.В командной строке введите материалы.
  2. В окне "Материалы" на панели " Материалы, имеющиеся в чертеже" нажмите кнопку "Создать новый материал".
  3. Выберите для материала тип "Реалистичный".
  4. Выберите опцию "Текстура рассеяния", а в качестве типа карты выберите "Шашечки".
  5. Для доступа к параметрам клеток нажмите кнопку со стрелкой вниз.
  6. В качестве типа карты для цвета 1 выберите "Пятна". В качестве типа карты для цвета 2 выберите "Дерево".
  7. Для возврата к текстуре вышележащего уровня нажмите кнопку "На один уровень вверх к базовой текстуре".
  8. Для отображения образца в окне большего размера выберите "Просмотр результатов процедуры наложения текстуры".
  9. Для просмотра вложенного списка материалов щелкните на стрелке вниз на панели навигации по вложенным структурам.
ПримечаниеДля каждого типа процедурных карт доступны разные параметры свойств. Для получения дополнительных сведений см. раздел Значения свойств текстуры.

После внесения изменений в материал можно применять материалы к объектам и граням.

Панель:Тонирование


Процедурные карты (Краткий справочник)

Текстура
Типы карт
Изменение свойств текстуры
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Процедурные карты
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Шашечки

Процедурные карты
Процедурные карты
Формула градиента
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Шашечки

Применение двухцветного шахматного узора к материалу.

По умолчанию в карте "Шашечки" используется рисунок, состоящий из черных и белых квадратов. В качестве клеток могут быть заданы цвета или текстуры. Эту текстуру можно просмотреть в области предварительного просмотра образца.

Пример текстуры "Клетки"

Для отображения параметров свойств, специфичных для текстуры "Клетки", воспользуйтесь кнопкой "Нажмите для обращения к параметрам клеток". Для получения дополнительных сведений см. раздел Значения свойств текстуры клеток.


Формула градиента

Шашечки
Процедурные карты
Мрамор
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Формула градиента

Создание градиентов с применением цветов, текстур и сглаживания.

Процедурная карта "Формула градиента" обеспечивает широкие возможности настройки градиентов. В процедурной карте "Формула градиента" предусмотрено несколько цветов и вложенных процедурных карт, сочетание которых позволяет создавать разнообразные оттенки и плавные переходы между ними.

Пример текстуры "Формула градиента"

Для отображения параметров свойств, специфичных для текстуры "Формула градиента", воспользуйтесь кнопкой "Нажмите для обращения к параметрам формулы градиента". Для получения дополнительных сведений см. раздел Значения свойств текстуры формулы градиента.


Мрамор

Формула градиента
Процедурные карты
Шум
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Мрамор

Карта "Мрамор" позволяет нанести на материал цвет камня и цвет прожилок.

С помощью текстуры "Мрамор" можно задать цвет камня и прожилок. Можно также изменить расстояние между прожилками и их ширину.

Пример текстуры "Мрамор"

Для отображения параметров свойств, специфичных для текстуры "Мрамор", нажмите кнопку "Параметры мрамора". Для получения дополнительных сведений см. раздел Значения свойств текстуры мрамора.


Шум

Мрамор
Процедурные карты
Пятна
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Шум

Создание случайных искажений поверхности за счет взаимодействия двух цветов и/или текстур.

Текстура "Помехи" позволяет смягчить впечатление монотонности для растровых и мозаичных изображений. Случайный узор в процедурной карте "Помехи" создается путем применения двух цветов, вложенных процедурных карт или комбинации цветов и процедурных карт.

Пример текстуры "Помехи"

Для отображения параметров свойств, специфичных для текстуры "Помехи", воспользуйтесь кнопкой "Нажмите для обращения к параметрам помех". Для получения дополнительных сведений см. раздел Значения свойств текстуры шума.


Пятна

Шум
Процедурные карты
Плитка
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Пятна

Создается пятнистый узор поверхности.

Карту "Пятна" удобно использовать для наложения диффузных и бугристых поверхностей и создания узоров типа "гранит", а также рисунков других типов.

Пример текстуры "Пятна"

Для отображения параметров свойств, специфичных для текстуры "Пятна", воспользуйтесь кнопкой "Нажмите для обращения к параметрам пятен". Для получения дополнительных сведений см. раздел Значения свойств текстуры пятен.


Плитка

Пятна
Процедурные карты
Волны
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Плитка

В карте типа "Плитка" цвета размещаются в виде кирпичной кладки или уложенных плиток или используются текстуры материала.

С помощью текстуры "Мозаика" можно создавать пользовательские образцы кирпичной кладки. На инструментальной палитре "Материалы" представлены применяемые в архитектуре стандартные образцы кирпичной кладки, которые можно выбрать и изменить в окне "Материалы".

Пример текстуры "Мозаика"

Для отображения параметров свойств, специфичных для текстуры "Мозаика", воспользуйтесь кнопкой "Нажмите для обращения к параметрам мозаики". Для получения дополнительных сведений см. раздел Значения свойств текстуры мозаики.


Волны

Плитка
Процедурные карты
Дерево
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Волны

Имитация эффектов водной поверхности или волн.

Текстура выдавливания позволяет имитировать поверхность воды. Карта "Волны" создается путем формирования множества эпицентров сферических волн и случайного их распространения в сфере. Можно менять число наборов волн, амплитуду и скорость распространения волн. Эта текстура эффективно применяется в качестве текстуры рассеяния и текстуры выдавливания одновременно, а также в сочетании с картой непрозрачности.

Пример текстуры "Волны"

Для отображения параметров свойств, специфичных для текстуры "Волны", воспользуйтесь кнопкой "Нажмите для обращения к параметрам волн". Для получения дополнительных сведений см. раздел Значения свойств текстуры волн.


Дерево

Волны
Процедурные карты
Изменение свойств текстуры
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Типы карт > Процедурные карты >
Дерево

Карта типа "Дерево" используется для создания цвета и узора волокон деревянной поверхности.

Текстура "Дерево" позволяет создавать изображения древесины с реалистичной передачей цветов и волокон.

Пример текстуры "Дерево"

Для отображения параметров свойств, специфичных для текстуры "Дерево", нажмите кнопку "Параметры дерева". Для получения дополнительных сведений см. раздел Значения свойств текстуры дерева.


Изменение свойств текстуры (Понятие)

Дерево
Повышение реалистичности изображения с помощью текстур
Настройка наложений на объектах и гранях
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур >
Изменение свойств текстуры
Понятие Краткий справочник

При создании сложных узоров можно изменить свойства текстуры путем изменения значений параметров текстуры.

После добавления к материалу канала текстуры и типа текстуры можно выполнить отделку материала, изменив постоянные свойства текстуры. Настроить свойства текстуры можно с помощью управляющих элементов текстуры. Нажмите кнопку "Нажмите для обращения к параметрам <тип текстуры>" (или "Параметры <тип текстуры>") для отображения набора элементов управления. Набор отображаемых свойств текстуры зависит от выбранного типа текстуры.

Масштабирование и наложение материала

С помощью параметра "Масштаб и мозаичное расположение материала", доступного на верхнем уровне материала, можно задавать масштаб и мозаичное расположение для текстур, примененных к материалам. Для уровня процедурных карт функции масштабирования и мозаичного расположения доступны только для двумерных типов вложенных процедурных карт ("Текстура", "Клетки", "Формула градиента" и "Мозаика"). Дополнительные сведения см. в разделах " Масштабирование и наложение материала" и " Масштаб и мозаичное расположение материала для подчиненных процедурных карт".

Каждая карта имеет собственные масштабный коэффициент и коэффициент наложения. Для синхронизации масштаба и мозаичного расположения всех текстур щелкните на значке синхронизации.

Ниже приведены доступные параметры настройки масштаба и мозаичной структуры материала.

  • "Плитка", "Зеркало", "Нет". Можно создать узор посредством мозаичного расположения или зеркального отражения либо выбрать "Нет" для сохранения узора текстуры без изменений.
  • Единицы масштаба.Можно указать единицы для масштабирования в натуральную величину. Выберите "Нет" для применения фиксированного масштаба или "Вписать в ручку" для вписывания изображения в грань объекта.
  • Параметры осей UV Координаты материала можно настроить на его образце. При изменении этих параметров материал отображается на панели "Смещение текстуры материала и просмотр" в режиме предварительного просмотра.
  • Настройки синхронизации. Можно синхронизировать масштаб и мозаичную структуру между всеми картами путем нажатия кнопки синхронизации.
ПримечаниеДля материалов применяется система координат UVW, поскольку обозначения XYZ, как правило, зарезервированы для мировой системы координат (МСК). Как правило, текстуры лежат в двумерной плоскости и назначены трехмерному пространству. Координатные оси U, V и W параллельны относительным направлениям координатных осей X,Y и Z. На двумерном изображении текстуры ось Uсоответствует оси X и представляет горизонтальное направление текстуры. Ось V соответствует оси Y и представляет вертикальное направление текстуры. Ось W соответствует оси Z и представляет направление, перпендикулярное плоскости текстуры UV.

Можно применить изображение и создать на его основе узор с помощью функции мозаичного расположения. Этот эффект используется для создания пола или фонтана, выложенного плиткой.

Пример мозаичного расположения текстуры

При мозаичном расположении выбранный объект заполняется изображениями текстуры. По умолчанию при наложении текстур функция мозаичного расположения активна. Поскольку изображение текстуры масштабируется по размерам объекта, для просмотра эффекта мозаики необходимо сместить систему координат UV или повернуть текстуру. При смещении изображения освободившиеся участки поверхности заполняются другими фрагментами текстуры.

Пример зеркального отражения текстуры

При зеркальном отражении создается еще одна (перевернутая) копия текстуры. Как и в случае мозаичной структуры, зеркальное отражение можно выполнить в направлении оси U, в направлении оси Y или в направлении обеих осей.

Смещение и просмотр материала

На всех уровнях текстур можно задать смещение материала и параметры предварительного просмотра текстур. Дополнительные сведения см. в разделах " Смещение текстуры материала и просмотр" и " Масштаб и мозаичное расположение материала для подчиненных процедурных карт".

Каждая карта имеет собственные коэффициенты смещения и предварительного просмотра. Для синхронизации смещения и параметров предварительного просмотра всех текстур нажмите кнопку синхронизации.

Ниже приведены доступные параметры настройки масштаба и мозаичной структуры материала.

  • Параметры осей UV Координаты материала можно настроить на его образце. При изменении этих параметров внесенные изменения отображаются в режиме предварительного просмотра.
  • Поворот. Можно повернуть изображение вокруг оси W в системе координат UVW. Для отображения метаручки наложения текстуры, позволяющей поворачивать прямоугольные, плоские, сферические и цилиндрические структуры, воспользуйтесь командой " МАТЕРИАЛСООТВ ".
  • Синхронизация параметров. С помощью кнопки синхронизации можно синхронизировать масштаб и мозаичное расположение всех текстур. Изменения , внесенные в параметры и значения для данного канала текстур, применяются ко всем каналам текстур.

Пример поворота текстуры


Изменение свойств текстуры (Краткий справочник)

Процедурные карты
Повышение реалистичности изображения с помощью текстур
Настройка наложений на объектах и гранях
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Изменение свойств текстуры >
Изменение свойств текстуры
Понятие Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Настройка наложений на объектах и гранях (Понятие)

Изменение свойств текстуры
Повышение реалистичности изображения с помощью текстур
Преобразование материалов
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур >
Настройка наложений на объектах и гранях
Понятие Процедура Краткий справочник

После присоединения материала с текстурой можно настроить ориентацию текстуры на объектах или гранях.

Форму материала с наложенной текстурой можно скорректировать в соответствии с формой объекта. Точность соответствия форм зависит от выбора подходящего типа текстуры для наложения на материал.

  • Плоское наложение. Изображение накладывается на объект, как если бы оно проектировалось со слайда на двумерную поверхность. Изображение не искажается, а только масштабируется для вписывания в объект. Обычно это наложение используется для граней.
  • Соответствие прямоугольников. Изображение накладывается на коробчатые тела. Изображение повторяется на всех сторонах объекта.
  • Сферическое наложение. Изображение накладывается на сферический объект. Верх наложения стягивается в точку, располагающуюся в "северном полюсе" сферы, в то время как низ стягивается в "южный полюс".
  • Цилиндрическое наложение. Изображение накладывается на цилиндрический объект; горизонтальные края загибаются и соединяются, верх и низ не затрагиваются. Высота изображения масштабируется вдоль оси цилиндра.

Метаручки наложения текстуры

При необходимости в дополнительной корректировке можно переместить или повернуть текстуру на объекте с помощью метаручек наложения текстуры, отображаемых на объекте.

Метаручки наложения текстуры представляют собой значки на видовом экране, позволяющие быстро выбрать одну из двух осей при преобразовании выбранных элементов с помощью мыши. Для выбора оси нужно навести курсор на любую ось значка, а затем, перетаскивая мышь, трансформировать выбранные элементы вдоль этой оси. При перемещении или масштабировании объекта можно с помощью других областей захватного блока выполнить преобразование по двум осям одновременно. Гизмо позволяет быстро переключаться между различными осями и плоскостями трансформации.


Регулировка положения текстуры на объекте или грани (Процедура)

Процедурные карты
Настройка наложений на объектах и гранях
Подготовка моделей для тонирования
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Настройка наложений на объектах и гранях >
Настройка наложений на объектах и гранях
Понятие Процедура Краткий справочник

Регулировка положения текстуры на объекте или грани

  1. Выбрать объект.
  2. Выберите на ленте следующие элементы: вкладка "Визуализация" [image] панель "Материалы".
  3. Щелкните на всплывающем меню "Плоское наложение" и выберите тип текстуры.

  4. Инструмент ручки для наложения материала отображается на объекте.

  5. Инструменты ручки и представление объекта служат для настройки отображения изображения на объекте или грани.
Панель:Тонирование
Ввод команды: МАТЕРИАЛСООТВ


Настройка наложений на объектах и гранях (Краткий справочник)

Изменение свойств текстуры
Повышение реалистичности изображения с помощью текстур
Преобразование материалов
Тонирование чертежа для презентации > Материалы и текстуры > Повышение реалистичности изображения с помощью текстур > Настройка наложений на объектах и гранях >
Настройка наложений на объектах и гранях
Понятие Процедура Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Преобразование материалов (Понятие)

Настройка наложений на объектах и гранях
Материалы и текстуры
Реалистичное тонирование 3D объектов
Тонирование чертежа для презентации > Материалы и текстуры >
Преобразование материалов
Понятие Краткий справочник

При использовании некоторых версий AutoCAD или других программных продуктов может потребоваться преобразование материалов.

Новые материалы с процедурными параметрами, созданные в AutoCAD 2008, невозможно преобразовать в более ранние версии PRODNAME;; исключение составляют материалы с процедурными картами "Мрамор" и "Дерево". Процедурные карты "Мрамор" и "Дерево" существуют в AutoCAD 2007 и могут быть преобразованы надлежащим образом. Процедурные карты, существующие в AutoCAD 2007 ("Мрамор" и "Дерево") можно преобразовать из AutoCAD 2008 в AutoCAD 2007. При открытии в AutoCAD 2007 чертежа с новыми процедурными картами, добавленными в AutoCAD 2008, объекты отображаются с материалами, примененными в AutoCAD 2008, но со значениями свойств по умолчанию, заданными в окне "Материал" AutoCAD 2007. Если в AutoCAD 2007 в материал не внесены изменения, информация о материале сохраняется и при последующем открытии чертежа в AutoCAD 2008 материал отображается с исходными значениями свойств, заданными в AutoCAD 2008.

Преобразование материалов из чертежей, выполненных в версиях, более ранних, чем AutoCAD 2007

Чертежи, выполненные в версиях, предшествующих AutoCAD 2007, требуют преобразования. С помощью системной переменной можно задать автоматическое преобразование чертежей с материалами из более ранних версий в формат материалов AutoCAD 2007 и AutoCAD 2008. Для этого применяется системная переменная 3DCONVERSIONMODE. Для нее можно задать одно из трех значений. Если для переменной задать значение 0, преобразование выполняться не будет. Если задать значение 1 (используется по умолчанию), преобразование будет выполняться автоматически. Если задано значение 2, при необходимости в преобразовании материалов отображается запрос, в ответ на который пользователь может подтвердить или отменить преобразование.

При значении 0 переменной 3DCONVERSIONMODE автоматическое преобразование не выполняется. Для преобразования материалов из более ранних версий вручную можно воспользоваться командой " ПРЕОБРУСТАРМАТЕРИАЛ".


Преобразование материалов (Краткий справочник)

Настройка наложений на объектах и гранях
Преобразование материалов
Коротко о тонировании
Тонирование чертежа для презентации > Материалы и текстуры > Преобразование материалов >
Преобразование материалов
Понятие Краткий справочник

Команды

ПРЕОБРУСТАРМАТЕРИАЛ

Преобразование материалов, созданных в чертежах формата предыдущих версий, в формат текущей версии

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

МАТЕРИАЛЫЗАКР

Закрытие окна "Материалы"

Системные переменные

MATSTATE

Признак открытого или закрытого состояния окна "Материалы"

3DCONVERSIONMODE

Преобразование определений материалов и источников света в соответствии с текущей версией программы

Утилиты

Нет

Ключевые слова для команд

Нет


Реалистичное тонирование 3D объектов

Преобразование материалов
Тонирование чертежа для презентации
Коротко о тонировании
Тонирование чертежа для презентации >
Реалистичное тонирование 3D объектов

Благодаря реалистичному тонированию модели проект становится более наглядным по сравнению с напечатанным чертежом.

В процессе проектирования большая часть графических работ приходится на создание каркасных представлений модели. Однако иногда возникает необходимость получить более реалистичное изображение (раскрашенное или в перспективе) — например, для проверки правильности спроектированной модели или при предъявлении законченного проекта заказчику.

Темы в этом разделе

  • Коротко о тонировании

    При тонировании создается 2D изображение на основе 3D сцены. Геометрия сцены тонируется с помощью настроенного пользователем освещения, применяемых материалов и особенностей окружающей среды, например, фона или тумана.

  • Подготовка моделей для тонирования

    Важную роль для оптимизации производительности системы тонирования и качества изображения играет способ построения модели.

  • Настройка системы тонирования

    Можно менять параметры, управляющие процессом тонирования, например при тонировании изображений высокого разрешения.

  • Основные сведения о тонировании

    Основной целью работы является создание высококачественного изображения фотографического качества, поэтому для достижения этой цели потребуется создать множество различных вариантов тонирования.

  • Дополнительные функции тонирования

    С помощью дополнительных функций тонирования можно выполнять тонирование изображений высокого уровня детальности и фотографического качества.

  • Журнал тонированных изображений

    Журнал тонирования включает список последних тонированных изображений текущей загруженной модели.

  • Сохранение и повторное воспроизведение изображений

    Тонированное изображение можно сохранить на диске, а затем в любой момент воспроизвести его на экране. Повторное воспроизведение тонированного изображения выполняется намного быстрее повторного тонирования.


Коротко о тонировании (Понятие)

Реалистичное тонирование 3D объектов
Реалистичное тонирование 3D объектов
Подготовка моделей для тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов >
Коротко о тонировании
Понятие Краткий справочник

При тонировании создается 2D изображение на основе 3D сцены. Геометрия сцены тонируется с помощью настроенного пользователем освещения, применяемых материалов и особенностей окружающей среды, например, фона или тумана.

Система тонирования - это универсальная система, создающая физически правильную модель освещения, включающую отражения и преломления лучей, а также общее освещение.

В программе предусмотрены разнообразные стандартные наборы параметров тонирования, параметры тонирования для многократного использования. Некоторые наборы параметров предназначены для быстрого создания тонирования, другие наборы - для получения высококачественного тонирования.

См. также

    • Получение новостей и обновлений программы


Коротко о тонировании (Краткий справочник)

Преобразование материалов
Коротко о тонировании
Нормали к граням и скрытые поверхности
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Коротко о тонировании >
Коротко о тонировании
Понятие Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

ТОНИРПОДРЕЗ

Задание конкретного участка (окно кадрирования) в изображении для тонирования

СРЕДАТОН

Управление туманом и затемнением объектов для визуального представления удаленных расстояний

НАБПАРАМТОНИР

Задание предварительной настройки и повторно используемых параметров тонирования изображения

ТОНИРОКНО

Отображение окна тонирования без вызова задачи тонирования

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

РЕЖИМТОНОТКЛ

Закрытие палитры "Параметры тонирования" (если открыта)

СОХРИЗОБ

Сохранение тонированных изображений в файлах

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Подготовка моделей для тонирования

Коротко о тонировании
Реалистичное тонирование 3D объектов
Нормали к граням и скрытые поверхности
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов >
Подготовка моделей для тонирования
Понятие Процедура

Важную роль для оптимизации производительности системы тонирования и качества изображения играет способ построения модели.

Темы в этом разделе

  • Нормали к граням и скрытые поверхности

    Чтобы минимизировать время, необходимое для тонирования модели, обычно удаляют скрытые поверхности или скрывают объекты, расположенные вне зоны действия камеры. Кроме того, тонирование выполняется быстрее, если все нормали к граням обращены в одну сторону.

  • Уменьшение числа пересечений и копланарных граней

    Некоторые типы геометрических объектов могут вызывать определенные трудности при тонировании.

  • Изменение плотности сети для сглаживания геометрии

    При тонировании модели на гладкость поверхностей влияет плотность сети.


Подготовка моделей для тонирования (Процедура)

Настройка наложений на объектах и гранях
Подготовка моделей для тонирования
Нормали к граням и скрытые поверхности
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования >
Подготовка моделей для тонирования
Понятие Процедура

Для тонирования обеих нормалей грани

Для изменения разрешающей способности при тонировании пространственных объектов

Для изменения разрешения отображения дуг и кругов


Нормали к граням и скрытые поверхности (Понятие)

Подготовка моделей для тонирования
Подготовка моделей для тонирования
Уменьшение числа пересечений и копланарных граней
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования >
Нормали к граням и скрытые поверхности
Понятие Процедура Краткий справочник

Чтобы минимизировать время, необходимое для тонирования модели, обычно удаляют скрытые поверхности или скрывают объекты, расположенные вне зоны действия камеры. Кроме того, тонирование выполняется быстрее, если все нормали к граням обращены в одну сторону.

Каждая поверхность модели состоит из граней. Грани могут быть треугольными или четырехугольными; для каждой грани определена внутренняя и внешняя сторона. Направление грани определяется вектором, который называется нормалью. Направление нормали указывает переднюю, или внешнюю, сторону грани.

Если все нормали направлены во внешнюю сторону, процесс тонирования применяется к каждой грани модели. Если же какие-то нормали направлены во внутреннюю сторону, то система тонирования их игнорирует и не тонирует соответствующие треугольники или четырехугольники.

Неокрашенные области, как правило, появляются по одной из двух причин: либо в палитре "Параметры тонирования" снят флажок "Вынужденное 2-стороннее", либо грань физически отсутствует в модели.

В случае отсутствия грани необходимо ее восстановить вручную. Направление нормали определяется тем, как нарисована грань в правоориентированной системе координат: если грань нарисована против часовой стрелки, нормаль ориентирована наружу, если по часовой стрелке - внутрь. Все грани следует строить одним и тем же методом.

ПримечаниеТвердотельные объекты имеют заведомо правильно ориентированные сети и нормали, что очень удобно для задач тонирования.

В процессе тонирования система вычисляет все нормали, направленные от точки зрения, и удаляет из сцены связанные с ними грани. Этот этап подавления называется выбраковкой задней грани и контролируется параметром "Вынужденное 2-стороннее" палитры "Параметры тонирования".

После того, как задние грани подавлены, система тонирования сравнивает относительные расстояния по оси Z при помощи Z-буфера. Если Z-буфер указывает, что одна из граней перекрывает другую, система тонирования подавляет скрытую грань.

Выигранное таким образом время пропорционально отношению числа скрытых граней к общему их количеству.

В некоторых случаях нужно пропустить этап выбраковки задних граней и оставить задние грани видимыми (например, если объект прозрачен, если в связи с формой и ориентацией объекта можно видеть обе его стороны, если при тонировании разомкнутого объекта видны его внутренние участки). Прозрачность также учитывается при определении видимости граней, скрытых за другими. В таком случае убедитесь, что параметр "Вынужденное 2-стороннее" включен и что производится тонирование всех граней, вне зависимости от направления нормалей.

При выполнении тонирования чертежа, первоначально не предназначенного для тонирования или выполненного в другом приложении, необходимо установить флажок "Вынужденное 2-стороннее". Это обеспечивает правильность тонирования всех поверхностей.

ПримечаниеПрименение параметра "Вынужденное 2-сторонее" лишь незначительно влияет на производительность процесса тонирования.

Система тонирования обрабатывает каждый объект сцены, включая объекты, которые "не попадают" в камеру и которые не будут видны на тонированном виде. Модель, построенная с учетом системы тонирования, отличается рациональным расположением слоев. Можно значительно увеличить скорость тонирования, отключив слои, объекты которых не попадают в поле зрения.

См. также

    • Работа с моделями в других приложениях

    • Использование стиля отображения для модели


Для тонирования обеих нормалей грани (Процедура)

Подготовка моделей для тонирования
На уровень вверх ..
Изменение плотности сети для сглаживания геометрии
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования > Нормали к граням и скрытые поверхности >
Нормали к граням и скрытые поверхности
Понятие Процедура Краткий справочник

Для тонирования обеих нормалей грани

  1. Выберите меню Вид [image] Тонирование [image] Дополнительные параметры тонирования.
  2. В разделе "Материалы" палитры "Дополнительные параметры тонирования" убедитесь, что для параметра "Вынужденное 2-стороннее" выбрано значение "Вкл".
  3. Выполните тонирование сцены.
Панель:Тонирование
Ввод команды: РЕЖТОН


Нормали к граням и скрытые поверхности (Краткий справочник)

Коротко о тонировании
Нормали к граням и скрытые поверхности
Уменьшение числа пересечений и копланарных граней
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования > Нормали к граням и скрытые поверхности >
Нормали к граням и скрытые поверхности
Понятие Процедура Краткий справочник

Команды

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Уменьшение числа пересечений и копланарных граней (Понятие)

Нормали к граням и скрытые поверхности
Подготовка моделей для тонирования
Изменение плотности сети для сглаживания геометрии
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования >
Уменьшение числа пересечений и копланарных граней
Понятие Краткий справочник

Некоторые типы геометрических объектов могут вызывать определенные трудности при тонировании.

Сложность объекта зависит от числа его вершин и граней. Чем больше у модели граней, тем больше времени занимает процесс тонирования. Простота геометрии чертежа позволит сократить время, необходимое на выполнение тонирования. При создании поверхностей нужно стремиться к минимизации числа граней.

Пересечение граней

Иногда случается так, что одна грань в модели проходит через другую. При создании эскизных проектов для наглядности бывает удобно расположить объекты так, чтобы один проходил сквозь другой. Однако кромка, возникающая при пересечении двух объектов, может быть волнистой.

В следующем примере волнистая кромка изображения слева значительно улучшается после применения логического объединения.

Если кромки выглядят недостаточно аккуратными, используйте логические операции, например объединение, пересечение и вычитание. Более точные и аккуратные кромки лучше отражают вид объекта.

Копланарные грани

Тонирование граней, лежащих в одной плоскости (копланарные грани)и перекрывающих друг друга, может приводить к неоднозначным результатам, особенно если этим граням присвоены разные материалы.

В следующем примере дефекты появляются, если грани занимают одно и то же местоположение.

Для устранения дефектов изображения следует переместить объект так, чтобы его грани не лежали в плоскости другого объекта.

Скрученные грани

Тонирование граней, скрученных на 180 градусов и поэтому самоперекрывающихся, также может приводить к неоднозначным результатам из-за неопределенности направления нормалей.

В следующем примере показаны дефекты изображения, выражающиеся в скручивании грани вследствие пересечения второй и третьей угловых точек.

Эта ситуация часто возникает при попытке исправить модель с отверстием на поверхности. Например, пусть выбираются угловые точки для новой грани. Возможно они будут пересекаться вместо того, чтобы разместиться вокруг отверстия в направлении против часовой стрелки. Во избежание этого дефекта выбирайте угловые точки в правильном порядке.


Уменьшение числа пересечений и копланарных граней (Краткий справочник)

Нормали к граням и скрытые поверхности
Уменьшение числа пересечений и копланарных граней
Изменение плотности сети для сглаживания геометрии
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования > Уменьшение числа пересечений и копланарных граней >
Уменьшение числа пересечений и копланарных граней
Понятие Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменение плотности сети для сглаживания геометрии (Понятие)

Уменьшение числа пересечений и копланарных граней
Подготовка моделей для тонирования
Настройка системы тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования >
Изменение плотности сети для сглаживания геометрии
Понятие Процедура Краткий справочник

При тонировании модели на гладкость поверхностей влияет плотность сети.

Компоненты сети включают в себя вершины, грани, многоугольники и кромки.

  • Вершина - это точка, образующая угол грани или многоугольника.
  • Грань - это треугольный участок поверхности.
  • Многоугольник - это четырехугольный участок объекта поверхности.
  • Кромка - это линия периметра грани или многоугольника.

В чертежах все грани имеют три вершины, за исключением многогранных сетей, состоящих из смежных треугольников. С точки зрения алгоритмов тонирования каждая четырехугольная грань состоит из двух треугольных граней с одной общей кромкой.

Сглаживание объекта выполняется системой тонирования автоматически. При тонировании существует два типа сглаживания. Первый тип сглаживания выполняет интерполяцию нормалей к граням поверхности. В другой операции учитывается число граней, счётчик граней, определяющих геометрию; чем больше число граней, тем более гладкие получаются поверхности, но увеличивается время обработки.

Интерполяцией нормалей к граням управлять нельзя, однако можно изменять аккуратность отображения криволинейных объектов с помощью команды НАСТРВИД и системной переменной FACETRES.

Управление отображением кругов и дуг

Аккуратность отображения криволинейных 2D объектов, например, кругов и дуг, в текущем виде можно изменять с помощью команды НАСТРВИД.

В следующем примере отрезки становятся более заметными при уменьшении значений команды НАСТРВИД - до значений "Левый верхний" = 1000, "Середина" = 100, "Правый нижний = 10.

Эти объекты отображаются на экране как множество коротких прямолинейных сегментов. При увеличении значений параметров НАСТРВИД дуги и круги становятся более гладкими, но при этом требуется больше времени для их создания. Для повышения производительности рекомендуется в ходе рисования устанавливать для параметра НАСТРВИД как можно меньшее значение.

Управление отображением тел с криволинейными поверхностями

Системная переменная FACETRES регулирует плотность сети и гладкость раскрашенных и тонированных тел с криволинейными поверхностями.

В следующем примере отображаются ячейки на криволинейной геометрической структуре с низким значением переменной FACETRES. FACETRES = 0,25.

Если значение FACETRES равно 1, то устанавливается взаимнооднозначное соответствие между разрешением кругов и дуг при просмотре и аппроксимацией линий кривизны (посредством подразделения граней) твердотельных объектов. Например, если значение FACETRES равно 2, аппроксимация будет в два раза больше аппроксимации, установленной командой НАСТРВИД. Для параметра FACETRES по умолчанию установлено значение 0,5. Диапазон допустимых значений: от 0,01 до 10.

Изменение значения точности аппроксимации в команде НАСТРВИД оказывает соответствующее воздействие как на объекты, управляемые командой НАСТРВИД, так и на объекты, управляемые системной переменной FACETRES. Изменение значения переменной FACETRES отражается только на твердотельных объектах.

В следующем примере отображается гладкая геометрическая структура с высокими значениями переменной FACETRES. FACETRES = 5.

См. также

    • Создание сетей


Изменение плотности сети для сглаживания геометрии (Процедура)

Нормали к граням и скрытые поверхности
На уровень вверх ..
Изменение плотности сети для сглаживания геометрии
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования > Изменение плотности сети для сглаживания геометрии >
Изменение плотности сети для сглаживания геометрии
Понятие Процедура Краткий справочник

Для изменения разрешающей способности при тонировании пространственных объектов

Для изменения разрешения отображения дуг и кругов


Для изменения разрешающей способности при тонировании пространственных объектов (Процедура)

Изменение плотности сети для сглаживания геометрии
На уровень вверх ..
Изменение плотности сети для сглаживания геометрии
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования > Изменение плотности сети для сглаживания геометрии >
Изменение плотности сети для сглаживания геометрии
Понятие Процедура Краткий справочник

Для изменения разрешающей способности при тонировании пространственных объектов

  1. В командной строке введите facetres.
  2. Выполните одно из следующих действий:
    • Для увеличения гладкости криволинейных поверхностей введите значение, большее чем 0,5.
    • Для уменьшения гладкости криволинейных поверхностей введите значение, меньшее чем 0,5.


Для изменения разрешения отображения дуг и кругов (Процедура)

Изменение плотности сети для сглаживания геометрии
На уровень вверх ..
Настройка системы тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования > Изменение плотности сети для сглаживания геометрии >
Изменение плотности сети для сглаживания геометрии
Понятие Процедура Краткий справочник

Для изменения разрешения отображения дуг и кругов

  1. В командной строке введите настрвид.
  2. Подсказку, касающуюся быстрого зумирования, можно игнорировать, если единственной целью вызова команды является улучшение вида кругов и дуг.
  3. В ответ на запрос "Точность аппроксимации" выполните одно из следующих действий:
    • Для увеличения гладкости дуг и кругов введите значение, большее чем 1000.
    • Для уменьшения гладкости дуг и кругов введите значение, меньшее чем 1000.


Изменение плотности сети для сглаживания геометрии (Краткий справочник)

Уменьшение числа пересечений и копланарных граней
Изменение плотности сети для сглаживания геометрии
Использование палитры "Параметры тонирования"
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Подготовка моделей для тонирования > Изменение плотности сети для сглаживания геометрии >
Изменение плотности сети для сглаживания геометрии
Понятие Процедура Краткий справочник

Команды

НАСТРВИД

Задание точности аппроксимации объектов на текущем видовом экране

Системные переменные

FACETRES

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Настройка системы тонирования

Изменение плотности сети для сглаживания геометрии
Реалистичное тонирование 3D объектов
Использование палитры "Параметры тонирования"
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов >
Настройка системы тонирования
Понятие Процедура

Можно менять параметры, управляющие процессом тонирования, например при тонировании изображений высокого разрешения.

Темы в этом разделе

  • Использование палитры "Параметры тонирования"

    Палитра "Параметры тонирования" содержит основные элементы управления системой тонирования. В ней можно выбрать стандартные параметры тонирования или установить собственные значения.

  • Создание пользовательских наборов параметров тонирования

    При задании совокупности параметров тонирования, обеспечивающих требуемые результаты, рекомендуется сохранить их в виде пользовательского набора параметров для последующего применения.

  • Управление средой при тонировании

    Функции среды можно использовать для создания атмосферных эффектов или фона изображений.


Настройка системы тонирования (Процедура)

Изменение плотности сети для сглаживания геометрии
Настройка системы тонирования
Использование палитры "Параметры тонирования"
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования >
Настройка системы тонирования
Понятие Процедура

Для создания пользовательского набора параметров тонирования из палитры "Дополнительные параметры тонирования"

Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования"

Для изменения пользовательского набора параметров тонирования

Для работы с туманом / затемнением

Задание фона для именованного вида

Изменение фона для именованного вида


Использование палитры "Параметры тонирования" (Понятие)

Настройка системы тонирования
Настройка системы тонирования
Создание пользовательских наборов параметров тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования >
Использование палитры "Параметры тонирования"
Понятие Процедура Краткий справочник

Палитра "Параметры тонирования" содержит основные элементы управления системой тонирования. В ней можно выбрать стандартные параметры тонирования или установить собственные значения.

Палитру "Параметры тонирования", в которой задаются параметры системы тонирования, можно открыть с помощью команды РЕЖТОН

Палитра разделена на несколько групп параметров, от основных до дополнительных. В разделах "Общие" содержатся параметры, влияющие на способ тонирования модели, способ управления материалами и тенями и способ выполнения сглаживания. (Процедура сглаживания уменьшает эффект зубчатости криволинейных линий и кромок.) Параметры раздела "Трассировка лучей" определяют способ раскрашивания. Параметры раздела "Отраженное освещение" определяют свойства освещения сцены, а также указывают, применяются ли общее освещение и метод чистовых проб. Имеются также элементы управления "Диагностические", которые могут помочь выяснить причины, почему изображение тонируется непредусмотренным образом.

Наборы стандартных параметров тонирования

Раскрывающийся список содержит стандартные параметры тонирования, называемые наборы параметров тонирования. В "Наборе параметров тонирования" хранятся группы параметров, позволяющие системе тонирования создавать изображения разного качества. Стандартные параметры обеспечивают изображения разного качества: от качества "Черновое", предназначенного для быстрого получения проверочных изображений, до качества "Презентационное", обеспечивающего изображения фотографического качества. Кроме того, можно открыть "Диспетчер наборов стандартных параметров тонирования", предназначенный для создания пользовательских наборов тонирования.

См. также

    • Создание пользовательских наборов параметров тонирования


Для создания пользовательского набора параметров тонирования из палитры "Дополнительные параметры тонирования" (Процедура)

Настройка системы тонирования
На уровень вверх ..
Создание пользовательских наборов параметров тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Использование палитры "Параметры тонирования" >
Использование палитры "Параметры тонирования"
Понятие Процедура Краткий справочник

Для создания пользовательского набора параметров тонирования из палитры "Дополнительные параметры тонирования"

  1. В командной строке введите режтон
  2. В палитре "Дополнительные параметры тонирования" выберите существующий стандартный или пользовательский набор.
  3. Внесите изменения в значения параметров, необходимых для тонирования.

    Обратите внимание, что перед исходным набором параметров тонирования расположен знак звездочки (*), указывающий, что набор был изменен.

  4. Выполните тонирование модели.
  5. Для сохранения внесенных изменений в качестве пользовательского набора параметров тонирования выполните одно из следующих действий:
    • Выберите поле имени набора наверху палитры "Дополнительные параметры тонирования" и введите новое имя.
    • Щелкните в поле "Набор параметров тонирования" на панели "Тонирование" ленты и введите новое имя.


Использование палитры "Параметры тонирования" (Краткий справочник)

Изменение плотности сети для сглаживания геометрии
Использование палитры "Параметры тонирования"
Создание пользовательских наборов параметров тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Использование палитры "Параметры тонирования" >
Использование палитры "Параметры тонирования"
Понятие Процедура Краткий справочник

Команды

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

РЕЖИМТОНОТКЛ

Закрытие палитры "Параметры тонирования" (если открыта)

НАБПАРАМТОНИР

Задание предварительной настройки и повторно используемых параметров тонирования изображения

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Создание пользовательских наборов параметров тонирования (Понятие)

Использование палитры "Параметры тонирования"
Настройка системы тонирования
Управление средой при тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования >
Создание пользовательских наборов параметров тонирования
Понятие Процедура Краткий справочник

При задании совокупности параметров тонирования, обеспечивающих требуемые результаты, рекомендуется сохранить их в виде пользовательского набора параметров для последующего применения.

Используя стандартный набор параметров в качестве основы, можно менять настройки параметров и отслеживать изменения в отображении тонированных изображений. По достижении требуемых результатов можно создать новый пользовательский набор параметров.

Пользователь может просмотреть параметры тонирования чертежа для любого набора и изменить их следующими методами:

  • Изменить настройки существующего набора параметров тонирования.
  • Изменить параметры в стандартном или созданном пользовательском наборе.
  • Создать, обновить или удалить пользовательские наборы параметров тонирования.
  • Задать набор параметров для использования системой тонирования.

В панели просмотра дерева отображаются все наборы параметров, сохраненные для текущего чертежа. Дерево разделено на две части: стандартные наборы параметров тонирования и созданные пользовательские наборы. Можно изменить порядок расположения стандартных и пользовательских наборов, перетаскивая их в режиме дерева. Новый созданный набор параметров всегда добавляется в раздел "Пользовательские наборы параметров тонирования". Кроме того, он отображается в списках "Наборы параметров тонирования" на панели "Тонирование" ленты и на палитре параметров тонирования.

Большинство параметров тонирования палитры "Параметры тонирования" можно найти и в "Диспетчере наборов стандартных параметров тонирования". Используя стандартный набор параметров в качестве основы, можно изменить настройки параметров и увидеть, как выглядят тонированные изображения. По достижении требуемых результатов рекомендуется создать новый пользовательский набор параметров.

Предусмотрено удаление только пользовательских наборов параметров тонирования. При выборе стандартного набора кнопка "Удалить" недоступна.

Для того чтобы набор параметров тонирования использовался системой тонирования, необходимо выбрать его в качестве текущего. Работая с "Диспетчером наборов стандартных параметров тонирования" можно выбирать наборы для редактирования. Однако, если требуется, чтобы набор использовала система тонирования, необходимо нажать кнопку "Установить как текущее". В противном случае применяется набор параметров, выбранный на панели "Тонирование" ленты или на палитре "Дополнительные параметры тонирования".

При внесении изменений в стандартный набор параметров тонирования рядом с его именем отображается звездочка. В случае удовлетворительных результатов тонирования можно сохранить набор параметров путем ввода нового имени в списке наборов параметров на панели "Тонирование" ленты или на палитре параметров тонирования.

Изменив значения параметров из пользовательского набора параметров тонирования, можно ввести новое имя для создания нового пользовательского набора или обновить текущий набор в списке наборов параметров на панели "Тонирование" ленты или на палитре параметров тонирования.


Создание пользовательских наборов параметров тонирования (Процедура)

Использование палитры "Параметры тонирования"
На уровень вверх ..
Создание пользовательских наборов параметров тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Создание пользовательских наборов параметров тонирования >
Создание пользовательских наборов параметров тонирования
Понятие Процедура Краткий справочник

Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования"

Для изменения пользовательского набора параметров тонирования


Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования" (Процедура)

Создание пользовательских наборов параметров тонирования
На уровень вверх ..
Создание пользовательских наборов параметров тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Создание пользовательских наборов параметров тонирования >
Создание пользовательских наборов параметров тонирования
Понятие Процедура Краткий справочник

Для создания пользовательского набора параметров тонирования из "Диспетчера наборов стандартных параметров тонирования"

  1. В командной строке введите набпарамтонир.
  2. В "Диспетчере наборов стандартных параметров тонирования" выберите существующий стандартный или пользовательский набор.
  3. Нажмите кнопку "Создать копию" и укажите имя нового набора. Нажмите "ОК".

    Новый набор отображается в дереве в разделе "Пользовательские наборы параметров тонирования".


Для изменения пользовательского набора параметров тонирования (Процедура)

Создание пользовательских наборов параметров тонирования
На уровень вверх ..
Управление средой при тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Создание пользовательских наборов параметров тонирования >
Создание пользовательских наборов параметров тонирования
Понятие Процедура Краткий справочник

Для изменения пользовательского набора параметров тонирования

  1. В командной строке введите набпарамтонир.
  2. В "Диспетчере наборов стандартных параметров тонирования" выберите существующий пользовательский набор.
  3. Внесите изменения в разделе параметров тонирования.

    Рядом с именем набора отображается звездочка, указывающая, что набор был изменен.

  4. Нажмите кнопку "Установить как текущее" и выполните тонирование сцены.

    По достижении требуемых результатов можно обновить текущий набор или вновь открыть "Диспетчер наборов параметров тонирования" и создать новый пользовательский набор параметров.


Создание пользовательских наборов параметров тонирования (Краткий справочник)

Использование палитры "Параметры тонирования"
Создание пользовательских наборов параметров тонирования
Управление средой при тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Создание пользовательских наборов параметров тонирования >
Создание пользовательских наборов параметров тонирования
Понятие Процедура Краткий справочник

Команды

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

НАБПАРАМТОНИР

Задание предварительной настройки и повторно используемых параметров тонирования изображения

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Управление средой при тонировании (Понятие)

Создание пользовательских наборов параметров тонирования
Настройка системы тонирования
Основные сведения о тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования >
Управление средой при тонировании
Понятие Процедура Краткий справочник

Функции среды можно использовать для создания атмосферных эффектов или фона изображений.

Тонированное изображение можно улучшить с помощью атмосферных эффектов, например, тумана или затемнения, или добавить изображение растрового формата в качестве фона.

Эффекты "Туман / Затемнение"

Туман и затемнение - похожие атмосферные явления, размывающее объекты по мере его удаления от камеры. Однако для создания эффекта тумана используется белый цвет, а для создания затемнения - черный.

Для настройки параметров тумана и затемнения используется команда СРЕДАТОН. Основные настраиваемые параметры тумана и затемнения - цвет, близкое и далекое расстояние и размытость тумана в процентах.

Эффекты тумана и затемнения основаны на применении секущих плоскостей с учетом расстояний, указанных в диалоговом окне "Тонировать среду". Пусть, например, активная задняя секущая плоскость камеры расположена на расстоянии 30 метров от камеры. Если требуется, чтобы эффект тумана начинался на расстоянии 15 метров и распространялся неограниченно, установите для параметра "Близкое расстояние" значение 50, а для параметра "Далекое расстояние" - 100.

Параметры "Процент близкого тумана" и "Процент далекого тумана" регулируют плотность тумана и затемнения. Эти параметры могут принимать значения в диапазоне от 0,0001 до 100. Чем выше значение параметра, тем сильнее эффект тумана или затемнения.

СоветДля небольших масштабных моделей может потребоваться установить значения параметров "Процент близкого тумана" и "Процент далекого тумана" ниже 1,0 для достижения требуемого эффекта.

Фон

Фон располагается позади модели. Фон может быть одноцветным или многоцветным градиентным, либо являться изображением растрового формата.

Фон лучше всего применять при тонировании неподвижных изображений либо анимации с неизменяемым видом или неподвижной камерой. Фон задается в окне Диспетчер видов. После настройки фон сопоставляется с именованным видом или камерой и сохраняется вместе с чертежом.


Управление средой при тонировании (Процедура)

Создание пользовательских наборов параметров тонирования
На уровень вверх ..
Управление средой при тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Управление средой при тонировании >
Управление средой при тонировании
Понятие Процедура Краткий справочник

Для работы с туманом / затемнением

Задание фона для именованного вида

Изменение фона для именованного вида


Для работы с туманом / затемнением (Процедура)

Управление средой при тонировании
На уровень вверх ..
Управление средой при тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Управление средой при тонировании >
Управление средой при тонировании
Понятие Процедура Краткий справочник

Для работы с туманом / затемнением

  1. Выберите камеру и откройте палитру "Свойства".
  2. Включите переднюю или заднюю секущую плоскость.
  3. Установите значение смещения для секущей плоскости.
  4. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Тонирование" [image] Среда.В командной строке введите средатон.
  5. Установите флажок "Включить туман" и задайте цвет тумана или затемнения.

    Светлые цвета обычно используются для тумана, а темные - для затемнения.

  6. Установите значения близкого и далекого расстояния, чтобы указать начало и конец тумана.
  7. Установите непрозрачность тумана или затемнения в параметрах процента близкого и далекого тумана. Нажмите "ОК".
  8. Выполните тонирование модели.


Задание фона для именованного вида (Процедура)

Управление средой при тонировании
На уровень вверх ..
Управление средой при тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Управление средой при тонировании >
Управление средой при тонировании
Понятие Процедура Краткий справочник

Задание фона для именованного вида

  1. В командной строке введите вид.
  2. В Диспетчере видов выберите существующий именованный вид в списке "Виды моделей".
  3. На панели "Общие" откройте список "Переопределение фона" и выберите пункт "Заливка", "Градиент" или "Изображение".
  4. В диалоговом окне "Фон" выберите для фона цвет или изображение в растровом формате. Нажмите "ОК".
  5. Нажмите "ОК", чтобы закрыть Диспетчер видов.
  6. Выберите на ленте именованный вид из раскрывающегося списка на вкладке "Вид" [image] панели "Видовые экраны".
  7. Выполните тонирование сцены.


Изменение фона для именованного вида (Процедура)

Управление средой при тонировании
На уровень вверх ..
Основные сведения о тонировании
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Управление средой при тонировании >
Управление средой при тонировании
Понятие Процедура Краткий справочник

Изменение фона для именованного вида

  1. В командной строке введите вид.
  2. В "Диспетчере видов" выберите существующий именованный вид в списке "Виды моделей".
  3. На панели "Общие" откройте список "Переопределение фона" и выберите "Правка".
  4. В диалоговом окне "Фон" задайте новые цвета или выберите новое растровое изображение для фона. Нажмите "ОК".
  5. Нажмите "ОК", чтобы закрыть Диспетчер видов.
  6. Выберите на ленте именованный вид из раскрывающегося списка на вкладке "Вид" [image] панели "Видовые экраны"
  7. Выполните тонирование сцены.


Управление средой при тонировании (Краткий справочник)

Создание пользовательских наборов параметров тонирования
Управление средой при тонировании
Задание места назначения тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Настройка системы тонирования > Управление средой при тонировании >
Управление средой при тонировании
Понятие Процедура Краткий справочник

Команды

СРЕДАТОН

Управление туманом и затемнением объектов для визуального представления удаленных расстояний

ВИД

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Основные сведения о тонировании

Управление средой при тонировании
Реалистичное тонирование 3D объектов
Задание места назначения тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов >
Основные сведения о тонировании
Понятие Процедура

Основной целью работы является создание высококачественного изображения фотографического качества, поэтому для достижения этой цели потребуется создать множество различных вариантов тонирования.

На начальном этапе можно использовать команду ТОНИРОВАТЬ для тонирования модели без применения дополнительных материалов, источников освещения или настройки сцены. При тонировании новой модели по умолчанию используется виртуальный удаленный источник света, расположенный за спиной наблюдателя. Этот источник нельзя ни переместить, ни изменить.

Темы в этом разделе

  • Задание места назначения тонирования

    Изображения с тонированием отображаются на видовом экране или в окне тонирования.

  • Тонирование видов, выбранных объектов или части содержимого

    Предусмотрено тонирование всего вида, набора выбранных объектов или части видимого на экране изображения.

  • Задание выходного разрешения

    Установите разрешение тонированного изображения, указав его ширину и высоту в пикселах.

  • Изменения материалов

    Добавление материалов к объектам делает модель более реалистичной.

  • Регулировка выборки для улучшения качества изображения

    Для устранения зазубрин в наклонных или кривых линиях можно использовать несколько стандартных наборов параметров тонирования.

  • Тонирование с тенями

    С помощью теней можно придать тонированным изображениям больше глубины и сделать их более реалистичными.


Основные сведения о тонировании (Процедура)

Управление средой при тонировании
Основные сведения о тонировании
Задание места назначения тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании >
Основные сведения о тонировании
Понятие Процедура

Для указания места назначения тонирования

Для тонирования вида

Для тонирования набора объектов

Для тонирования выделенной области

Просмотр теней на видовом экране

Создание теней, полученных применением текстур теней, в тонированном изображении

Создание теней трассировки луча в тонированном изображении


Задание места назначения тонирования (Понятие)

Основные сведения о тонировании
Основные сведения о тонировании
Тонирование видов, выбранных объектов или части содержимого
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании >
Задание места назначения тонирования
Понятие Процедура Краткий справочник

Изображения с тонированием отображаются на видовом экране или в окне тонирования.

После выполнения тонирования сцены изображение отображается на видовом экране или в окне тонирования. Это и называется местом назначения тонирования.

Место назначения тонирования указывается в разделе "Контекстное меню тонирования" палитры "Дополнительные параметры тонирования". По умолчанию устанавливается значение "Окно".

Если местом назначения тонирования является "Окно", система тонирования автоматически открывает "Окно тонирования" и обрабатывает изображение. По окончанию обработки изображение появляется в окне и создается запись журнала. При выполнении других заданий тонирования записи добавляются в журнал, что позволяет быстро открывать и сравнивать предыдущие изображения для достижения наилучших результатов. Изображения можно сохранять из окна тонирования.

Если место назначения тонирования задать как "Видовой экран", полученное изображение тонируется и отображается непосредственно на активном видовом экране. По существу это является однократным тонированием, так как записи журнала тонирования не создаются и нет возможности сравнить результаты разных задач тонирования. Для сохранения тонированного изображения из видового экрана используйте команду СОХРИЗОБ.

При тонировании с выводом на видовой экран изображение объектов всегда создается на фоне, заданном для области рисования. Цвет фона окна тонирования может совпадать с цветом основного фона. Используйте команду РЕГЕН для обновления экрана.

См. также

    • Окно тонирования


Для указания места назначения тонирования (Процедура)

Основные сведения о тонировании
На уровень вверх ..
Тонирование видов, выбранных объектов или части содержимого
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Задание места назначения тонирования >
Задание места назначения тонирования
Понятие Процедура Краткий справочник

Для указания места назначения тонирования

  1. В командной строке введите режтон
  2. С помощью прокрутки перейдите в верхнюю часть палитры "Дополнительные параметры тонирования". В области "Общие" откройте панель "Контекстное меню тонирования".
  3. Откройте список "Назначение" и выберите значение "Окно" или "Видовой экран".
  4. Выполните тонирование сцены.
    Панель:Тонирование
    Ввод команды: РЕЖТОН


Задание места назначения тонирования (Краткий справочник)

Управление средой при тонировании
Задание места назначения тонирования
Тонирование видов, выбранных объектов или части содержимого
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Задание места назначения тонирования >
Задание места назначения тонирования
Понятие Процедура Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

СОХРИЗОБ

Сохранение тонированных изображений в файлах

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Тонирование видов, выбранных объектов или части содержимого (Понятие)

Задание места назначения тонирования
Основные сведения о тонировании
Задание выходного разрешения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании >
Тонирование видов, выбранных объектов или части содержимого
Понятие Процедура Краткий справочник

Предусмотрено тонирование всего вида, набора выбранных объектов или части видимого на экране изображения.

Тонирование вида

По умолчанию в процесс тонирования вовлекаются все объекты, принадлежащие текущей сцене чертежа. Если именованный вид или вид камеры не был открыт, тонируется текущий вид. Процесс тонирования только основных объектов или небольших участков вида проходит быстрее, однако тонирование вида целиком позволяет определить ориентацию всех объектов по отношению друг к другу.

При наличии именованных видов в текущем чертеже или добавленных к модели камер их можно быстро отобразить с помощью команды ВИД.

В следующем примере демонстрируется процесс тонирования именованного вида.

В зависимости от выбранного места назначения тонированный вид отображается в окне тонирования или непосредственно на видовом экране. Полное описание окна тонирования см. в разделе " ТОНИРОВАТЬ" документа "Справочник команд".

Тонирование выбранных объектов

При добавлении элемента к определенным объектам нет необходимости терять время на тонирование всего видового экрана. Можно изменить процедуру тонирования на "Выбранные", которая позволяет выбирать объекты для тонирования.

В следующем примере демонстрируется результат тонирования первой бутылки, ее пробки и фужера.

Тонирование набора объектов эффективно при тестировании различных материалов, особенно материалов, включающих текстуры. Благодаря тонированию выбранного объекта можно посмотреть материал и при необходимости изменить координаты текстуры.

Тонирование выделенной области

Иногда необходимо выполнить тонирование части изображенного на экране чертежа, сохранив при этом окружающую среду.

В следующем примере тонируется только область, окружающая третью бутылку и фужер.

Выбрав для процедуры тонирования значение "Обрезать", следует указать небольшую область видового экрана для тонирования. Можно не только выбирать объекты в окне, но и указать прямоугольную область на видовом экране. При этом тонируются все объекты в указанной области, а объекты вне ее игнорируются.

ПримечаниеТонированная область отображается только на видовом экране. Используйте команду РЕГЕН для обновления экрана.


Тонирование видов, выбранных объектов или части содержимого (Процедура)

Задание места назначения тонирования
На уровень вверх ..
Тонирование видов, выбранных объектов или части содержимого
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование видов, выбранных объектов или части содержимого >
Тонирование видов, выбранных объектов или части содержимого
Понятие Процедура Краткий справочник

Для тонирования вида

Для тонирования набора объектов

Для тонирования выделенной области


Для тонирования вида (Процедура)

Тонирование видов, выбранных объектов или части содержимого
На уровень вверх ..
Тонирование видов, выбранных объектов или части содержимого
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование видов, выбранных объектов или части содержимого >
Тонирование видов, выбранных объектов или части содержимого
Понятие Процедура Краткий справочник

Для тонирования вида

  1. Воспроизведите на экране трехмерный вид модели.
  2. В командной строке введите режтон
  3. В наборе параметров тонирования измените качество и скорость тонирования.

    Набор "Черновое" предлагает очень быстрый способ тонирования, но низкого качества. Набор "Презентационное" создает изображение высокого качества, но при этом процесс тонирования занимает существенно больше времени.

  4. Укажите место размещения тонированного изображения, выбрав для параметра "Назначение" значение "Окно" или "Видовой экран".

    Если указать место расположения изображения, оно не только отобразится на экране, но и сохранится в файле.

  5. Выполните тонирование сцены.
Панель:Тонирование
Ввод команды: РЕЖТОН


Для тонирования набора объектов (Процедура)

Тонирование видов, выбранных объектов или части содержимого
На уровень вверх ..
Тонирование видов, выбранных объектов или части содержимого
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование видов, выбранных объектов или части содержимого >
Тонирование видов, выбранных объектов или части содержимого
Понятие Процедура Краткий справочник

Для тонирования набора объектов

  1. В командной строке введите режтон
  2. В наборе параметров тонирования измените качество и скорость тонирования.

    Набор "Черновое" предлагает очень быстрый способ тонирования, но низкого качества. Набор "Презентационное" создает изображение высокого качества, но при этом процесс тонирования занимает существенно больше времени.

  3. Установите для процедуры тонирования значение "Выбранные".
  4. Выберите объекты модели для тонирования.
  5. Выполните тонирование сцены.
Панель:Тонирование
Ввод команды: РЕЖТОН


Для тонирования выделенной области (Процедура)

Тонирование видов, выбранных объектов или части содержимого
На уровень вверх ..
Тонирование с тенями
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование видов, выбранных объектов или части содержимого >
Тонирование видов, выбранных объектов или части содержимого
Понятие Процедура Краткий справочник

Для тонирования выделенной области

  1. В командной строке введите тонирподрез.
  2. Выделите рамкой область на экране для тонирования.
  3. Выполните тонирование сцены.
Ввод команды: ТОНИРПОДРЕЗ


Тонирование видов, выбранных объектов или части содержимого (Краткий справочник)

Задание места назначения тонирования
Тонирование видов, выбранных объектов или части содержимого
Задание выходного разрешения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование видов, выбранных объектов или части содержимого >
Тонирование видов, выбранных объектов или части содержимого
Понятие Процедура Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

ТОНИРПОДРЕЗ

Задание конкретного участка (окно кадрирования) в изображении для тонирования

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Задание выходного разрешения (Понятие)

Тонирование видов, выбранных объектов или части содержимого
Основные сведения о тонировании
Изменения материалов
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании >
Задание выходного разрешения
Понятие Краткий справочник

Установите разрешение тонированного изображения, указав его ширину и высоту в пикселах.

Отображением тонированного изображения управляют три параметра разрешения: ширина, высота и пропорции изображения.

Ширина и высота указывают размер тонированного изображения в пикселах. Пиксел (от Picture Element, элемент изображения) - это одна точка графического изображения.

По умолчанию установлено выходное разрешение 640 x 480, максимально возможное расширение - 4096 x 4096. Чем больше установлено значение разрешения, тем меньше размер пикселов и точнее отображаются элементы. Для тонирования изображений с высоким разрешением требуется больше времени.

Значения выходного разрешения устанавливаются в Диалоговое окно "Формат вывода" . Значения параметров можно ввести непосредственно в полях ширины и высоты либо изменить разрешение с помощью элементов управления.

При задании выходного разрешения оно сохраняется вместе с текущим чертежом и добавляется к списку значений выходного разрешения на панели "Тонирование" ленты. В большинстве случаев при тестировании внешнего вида объектов модели используются низкие значения разрешения - 320 x 200 и ниже. По мере добавления элементов и материалов рекомендуется переходить к разрешениям среднего диапазона, например, 640 x 480. Для тонирования на последних этапах работы следует применять наибольшее разрешение, необходимое для проекта (1024 x 768 и выше), так как именно это изображение будет представлено заказчику или напечатано.

Пропорция указывает размеры неподвижного изображения или рамки анимации. Она вычисляется как отношение ширины к высоте без учета разрешения изображения. Значение пропорции задается параметром "Пропорции изображения". Значение пропорции обычно указывается в виде отношения ширины к высоте (например, 4:3) или коэффициента (1,333). При изменении этого значения меняется параметр "Высота", чтобы сохранить правильные размеры выходного разрешения.

В следующем примере демонстрируются различные пропорции.

При фиксации пропорции изображения параметры ширины и высоты становятся зависимыми друг от друга: при изменении одного автоматически меняется другой в соответствии со значением пропорци.


Задание выходного разрешения (Краткий справочник)

Тонирование видов, выбранных объектов или части содержимого
Задание выходного разрешения
Изменения материалов
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Задание выходного разрешения >
Задание выходного разрешения
Понятие Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Изменения материалов (Понятие)

Задание выходного разрешения
Основные сведения о тонировании
Регулировка выборки для улучшения качества изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании >
Изменения материалов
Понятие Краткий справочник

Добавление материалов к объектам делает модель более реалистичной.

При тонировании в зависимости от используемого материала меняется способность объекта отражать и пропускать свет. Программа имитирует текстуру материала, эффекты выдавливания, а также отражения и преломления света.

В палитре "Дополнительные параметры тонирования" можно задать, требуется ли использовать материалы и их фильтрацию, а также способ тонирования поверхностей объекта.

Как правило, созданные и прикрепленные к объектам модели материалы включаются при процессе тонирования. Если же их отключить, всем объектам модели присваиваются характеристики глобального материала.

Фильтр текстур

В программе предусмотрено управление фильтрацией текстур атмосферных явлений, а также усреднением пикселов, применяемым процедурой сглаживания во время тонирования модели.

Если фильтрация текстур включена, система тонирования использует пирамидальные методы фильтрации - фильтрации как функции от расстояния.

ПримечаниеДля сужающихся в перспективе поверхностей при наложении подробных текстур могут возникать зазубрины.

Фильтрация текстур вызывает небольшие погрешности тонирования. Для пирамидальной фильтрации требуются значительные ресурсы памяти - около 133% размера текстуры. По сравнению с текстурными материалами тонирование предлагает меньший уровень детальности и реалистичности.

Если фильтрация текстур отключена, при тонировании модели текстуры не сглаживаются.

2-стороннее тонирование

Так как направление нормалей к граням изменить нельзя, иногда возникает необходимость работы с моделью с отраженными нормалями. Задняя сторона граней невидима для системы тонирования. Это означает, что грань, видимая с задней стороны, не тонируется и создается впечатление, что эта грань отсутствует. Обычно объекты создаются с направленными наружу нормалями к поверхностям. Однако можно создать объекты с отраженными гранями или импортировать сложную геометрию, в которой нормали к граням не унифицированы.

Если установлен флажок "Вынужденное 2-стороннее", в отношении обеих сторон граней применяется отслеживание лучей с тенями. Хотя это увеличивает время тонирования, обычно применение процедуры занимает меньше времени, чем поиск и обработка отраженных граней вручную.


Изменения материалов (Краткий справочник)

Задание выходного разрешения
Изменения материалов
Регулировка выборки для улучшения качества изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Изменения материалов >
Изменения материалов
Понятие Краткий справочник

Команды

МАТЕРИАЛПРИСВ

Назначение материалов объектам по слоям

МАТЕРИАЛСООТВ

Отображение ручки блока наложения материалов для корректировки наложений на грань или на объект

МАТЕРИАЛЫ

Администрирование, применение и редактирование материалов

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

LOGEXPPHYSICALSCALE

Управление относительной яркостью самосветящихся материалов в фотометрической среде

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Регулировка выборки для улучшения качества изображения (Понятие)

Изменения материалов
Основные сведения о тонировании
Тонирование с тенями
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании >
Регулировка выборки для улучшения качества изображения
Понятие Краткий справочник

Для устранения зазубрин в наклонных или кривых линиях можно использовать несколько стандартных наборов параметров тонирования.

На мониторе изображение строится из отдельных пикселов фиксированной сетки. Поэтому сцены, тонированные с помощью наборов параметров "Черновое" или "Низкое", получаются неаккуратными и с зубчатыми краями.

В следующем примере качество изображения очень низкое - "Мин". Выборка = 1/64; "Макс". Выборка = 1/4.

Чем выше разрешение (и, соответственно, мельче пикселы), тем менее заметен эффект зазубрин. Однако, лучше всего уменьшить эффект зазубрин с помощью процедуры сглаживания. Процедура сглаживания, используемая системой тонирования, называется выборкой. Выборкой можно управлять с помощью параметров образца и фильтра палитры "Дополнительные параметры тонирования".

Процедура выборки определяет наилучший цвет для каждого тонируемого пиксела. Система тонирования сначала выбирает произвольные пикселы вокруг рассматриваемого пиксела, затем использует фильтр для определения оптимального цвета обрабатываемого пиксела. Увеличение минимума и максимума диапазона выборки значительно улучшает качество тонирования.

В следующем примере увеличено сглаживание кромок - "Мин". Выборка = 1; "Макс". Выборка = 16.

Предусмотрено пять методов фильтрации: "Прямоугольник", "По Гауссу", "Треугольник", "По Митчеллу" или "По Ланчосу". По умолчанию установлен самый быстрый метод - "Прямоугольник". Фильтр "По Митчеллу" обычно самый точный. Фильтр "Прямоугольник" равномерно обрабатывает выборку, весовые коэффиценты не используются. Каждый фильтр применяет собственную систему весов для обработки пикселов.

У процедуры сглаживания зазубрин есть по крайней мере два недостатка.

  • Дополнительные вычисления. Чтобы добавить промежуточные оттенки, программе необходимо анализировать как пикселы, образующие линию, так и соседние пикселы фона.
  • Утолщение линий. Хотя линии с устраненными зазубринами выглядят более плавными, они получаются толще, чем исходные.

Использовать или нет устранение зазубрин - решает пользователь, основываясь на требованиях, предъявляемых к продолжительности тонирования и качеству полученного изображения. Следует искать разумный компромисс между возможностями аппаратных средств и запросами аудитории, которой будет демонстрироваться результат.

Стандартные наборы параметров тонирования предлагают пять уровней сглаживания. Набор "Черновое" использует низший уровень устранения зазубрин, при этом процесс тонирования занимает наименьшее количество времени. Чем выше установленный уровень устранения зазубрин, тем больше времени требуется на вычисления при тонировании. При использовании алгоритма устранения зазубрин повышается эффективность процесса, поскольку программа может снижать количество требуемых проб для отдельных пикселов изображения.


Регулировка выборки для улучшения качества изображения (Краткий справочник)

Изменения материалов
Регулировка выборки для улучшения качества изображения
Тонирование с тенями
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Регулировка выборки для улучшения качества изображения >
Регулировка выборки для улучшения качества изображения
Понятие Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Тонирование с тенями (Понятие)

Регулировка выборки для улучшения качества изображения
Основные сведения о тонировании
Дополнительные функции тонирования
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании >
Тонирование с тенями
Понятие Процедура Краткий справочник

С помощью теней можно придать тонированным изображениям больше глубины и сделать их более реалистичными.

Система тонирования генерирует тени посредством наложения теней или посредством трассировки лучей. Тени, полученные применением текстур теней, основаны на растровом формате, генерируемым системой тонирования во время предварительного тонирования сцены. При использовании наложения теней получаются более мягкие края и требуется меньшее расчетное время, чем при создании теней трассировки луча, но тени получаются менее точными. Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Тени появляются в тех местах, где распространению лучей препятствуют объекты. У теней трассировки луча более точные и четкие границы, и для их получения требуется большее расчётное время.

Тени, полученные наложением

Только с помощью карт теней можно получать тени с мягкими границами, не отображают цвет, отбрасываемый прозрачными или полупрозрачными объектами. Тени, полученные наложением, рассчитываются быстрее, чем тени трассировки луча.

В следующем примере демонстрируется, как карты теней обеспечивают мягкие, менее точные тени, обработка которых выполняется быстрее, чем обработка теней трассировки луча.

Во время предварительного тонирования создаётся растровый формат карты теней. Качество теней регулируется увеличением или уменьшением размера карты теней. По умолчанию размер карты теней равен 256 x 256 пикселов. Если отображается слишком зернистая тень, можно улучшить её качество, увеличивая размер карты. Не следует использовать тени, полученные применением текстур теней, если свет проходит через прозрачную поверхность (например, если требуется получить тени от рамы и средников окна с большим числом панелей). Чтобы средники отбрасывали тени, потребовалось бы удалить стёкла.

Тени трассировки луча

Тени трассировки лучей (так же, как эффекты отражения и преломления) генерируются алгоритмом трассировки лучей, исходящих от источника света. Этот вид теней более точный, чем тени на основе карт.

Как показано на следующем примере, в режиме трассировки лучей увеличивается время обработки, но обеспечивается получение более точных и реалистичных теней.

Тени трассировки лучей имеют четко очерченные границы, они передают изменение цвета при прохождении луча сквозь прозрачные и полупрозрачные объекты. Поэтому тени от рамы и средников окна с большим числом панелей будут тонироваться. Так как этот вид теней вычисляется без использования карты, они не требует настройки разрешения, в отличие от теней на основе карт.

Режимы теней

Можно выбрать один из трех режимов теней: Для режима теней можно задать значение "Простой", "Сортировка" или "Сегмент".

  • Простой Система тонирования выбирает модули тонирования в произвольном порядке. Этот режим теней установлен по умолчанию.
  • Отсортировано Система тонирования последовательно выбирает модули тонирования от объекта до источника освещения.
  • Сегмент Система тонирования последовательно выбирает модули тонирования вдоль светового луча между объектом и источником света.

Отображение теней

Для того, чтобы в модели присутствовали тени, необходимо установить источник света. Необходимо ввести в сцену источник света и указать, создаёт ли этот источник света тени. Чтобы на видовом экране отображались тени, при настройке сцены необходимо включить использование теней для визуального стиля. Если требуется, чтобы в тонированном изображении отображались тени, необходимо на палитре "Дополнительные параметры тонирования" включить режим теней и выбрать тип теней для тонирования.


Тонирование с тенями (Процедура)

Тонирование видов, выбранных объектов или части содержимого
На уровень вверх ..
Тонирование с тенями
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование с тенями >
Тонирование с тенями
Понятие Процедура Краткий справочник

Просмотр теней на видовом экране

Создание теней, полученных применением текстур теней, в тонированном изображении

Создание теней трассировки луча в тонированном изображении


Просмотр теней на видовом экране (Процедура)

Тонирование с тенями
На уровень вверх ..
Тонирование с тенями
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование с тенями >
Тонирование с тенями
Понятие Процедура Краткий справочник

Просмотр теней на видовом экране

  1. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Визуальные стили" [image] Диспетчер визуальных стилей.В командной строке введите визстили.
  2. В окне "Диспетчер визуальных стилей" выберите стиль "Концептуальный" или "Реалистический".

    Параметр "Отображение тени" не оказывает влияния на стили "3D скрытый" или "3D каркас".

  3. Задайте для параметра "Отображение тени" значение "Тени на земле" или "Полные тени".
  4. Закройте окно "Диспетчер визуальных стилей".
Ввод команды: ВИЗСТИЛИ


Создание теней, полученных применением текстур теней, в тонированном изображении (Процедура)

Тонирование с тенями
На уровень вверх ..
Тонирование с тенями
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование с тенями >
Тонирование с тенями
Понятие Процедура Краткий справочник

Создание теней, полученных применением текстур теней, в тонированном изображении

  1. В командной строке введите режтон
  2. Убедитесь, что в палитре "Дополнительные параметры тонирования" установлен флажок "С тенями".
  3. Выберите требуемый режим создания теней.
  4. Включите параметр "Текстура теней".
  5. Выполните тонирование модели.
Панель:Тонирование
Ввод команды: РЕЖТОН


Создание теней трассировки луча в тонированном изображении (Процедура)

Тонирование с тенями
На уровень вверх ..
Сохранение и повторное воспроизведение изображений
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование с тенями >
Тонирование с тенями
Понятие Процедура Краткий справочник

Создание теней трассировки луча в тонированном изображении

  1. В командной строке введите режтон
  2. Убедитесь, что в палитре "Дополнительные параметры тонирования" установлен флажок "С тенями".
  3. Выберите требуемый режим создания теней.
  4. Отключите параметр "Текстура теней".
  5. Выполните тонирование модели.
Панель:Тонирование
Ввод команды: РЕЖТОН


Тонирование с тенями (Краткий справочник)

Регулировка выборки для улучшения качества изображения
Тонирование с тенями
Отражения и преломления в режиме трассировки лучей
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Основные сведения о тонировании > Тонирование с тенями >
Тонирование с тенями
Понятие Процедура Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

ВИЗСТИЛИ

Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Дополнительные функции тонирования

Тонирование с тенями
Реалистичное тонирование 3D объектов
Отражения и преломления в режиме трассировки лучей
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов >
Дополнительные функции тонирования

С помощью дополнительных функций тонирования можно выполнять тонирование изображений высокого уровня детальности и фотографического качества.

Темы в этом разделе

  • Отражения и преломления в режиме трассировки лучей

    Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Возникающие при этом отражения и преломления лучей точны с физической точки зрения.

  • Преимущества отраженного освещения

    Функции отраженного освещения, например общее освещение и метод чистовых проб, повышает реалистичность сцены благодаря имитации диффузионного отражения или взаимного отражения света.

  • Чистовая проба

    Метод чистовых проб - дополнительный алгоритм, используемый для улучшения общего освещения. Он увеличивает число лучей, используемых при сглаживании общего освещения, и подавляет дефекты освещения.


Отражения и преломления в режиме трассировки лучей (Понятие)

Дополнительные функции тонирования
Дополнительные функции тонирования
Преимущества отраженного освещения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Дополнительные функции тонирования >
Отражения и преломления в режиме трассировки лучей
Понятие Краткий справочник

Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Возникающие при этом отражения и преломления лучей точны с физической точки зрения.

Для уменьшения времени, необходимого для генерации отражений и преломлений, на лучи накладывается ограничение глубина трассировки Глубина трассировки ограничивает число отражений или преломлений луча, либо оба эти значения. В палитре "Дополнительные параметры тонирования" можно установить максимальную глубину трассировки, максимальное число отражений или максимальное число преломлений

Ниже показан пример значительного повышения реалистичности сцены за счет отражений и преломлений в режиме трассировки лучей. Макс. глубина = 8; макс. отражений и преломлений = 4.

Если режим трассировки лучей отключен, отражения и преломления отсутствуют.

В следующем примере показана та же модель при отключенном режиме трассировки лучей.

Глубина трассировки задает количество возможных отражений или преломлений светового луча. Увеличение этих значений приводит к повышению сложности и реалистичности тонируемого изображения за счет увеличения затрачиваемого времени.

В следующем примере демонстрируется, как увеличение глубины трассировки улучшает тонирование. Макс. глубина = 4; макс. отражений и преломлений = 2.

Элементы управления режимом трассировки лучей

Параметр "Макс. глубина" ограничивает суммарно возможное число преломлений и отражений. Трассировка луча прекращается при достижении суммой чисел отражения и преломления значения максимальной глубины. Например, если для параметра "Макс. глубина" установлено значение 3, а для параметров "Макс отражений" и "Макс преломлений" - 2, луч может дважды отразиться и один раз преломиться, или наоборот, но он не может отразиться и преломиться четыре раза.

Параметр "Макс отражений" задает число возможных отражений луча. При значении, равном 0, отражения отсутствуют. При значении, равном 1, допускается однократное отражение луча. При значении, равном 2, допускается двукратное отражение луча и т.д.

Параметр "Макс преломлений" задает число возможных преломлений луча. При значении, равном 0, преломления отсутствуют. При значении, равном 1, допускается однократное преломление луча. При значении, равном 2, допускается двукратное преломление луча и т.д.

ПримечаниеПри увеличении числа отражений и преломлений также увеличивается продолжительность процесса тонирования.


Отражения и преломления в режиме трассировки лучей (Краткий справочник)

Тонирование с тенями
Отражения и преломления в режиме трассировки лучей
Преимущества отраженного освещения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Дополнительные функции тонирования > Отражения и преломления в режиме трассировки лучей >
Отражения и преломления в режиме трассировки лучей
Понятие Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Преимущества отраженного освещения (Понятие)

Отражения и преломления в режиме трассировки лучей
Дополнительные функции тонирования
Чистовая проба
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Дополнительные функции тонирования >
Преимущества отраженного освещения
Понятие Краткий справочник

Функции отраженного освещения, например общее освещение и метод чистовых проб, повышает реалистичность сцены благодаря имитации диффузионного отражения или взаимного отражения света.

Функция общего освещения (GI) обеспечивает такие эффекты, как цветовое заполнение. Например, если рядом с белой стеной расположена красная столешница, стена приобретает светло-розовый оттенок. Может показаться, что это незначительная деталь, но если розовый оттенок будет отсутствовать на изображении, оно будет выглядеть ненастоящим. Данный эффект невозможен при обычных вычислениях трассировки луча.

При расчете общего освещения система тонирования использует фотонные схемы - метод создания эффектов отраженного освещения и общего освещения. Побочным эффектом использования фотонных схем является появление дефектов тонирования, как например, темных углов и низкочастотных колебаний освещения. Подобные дефекты можно частично или полностью подавить, включив метод чистовых проб, который увеличивает число лучей, используемых при обсчитывании эффекта общего освещения.

При подготовке окончательной процедуры тонирования, перед заданием каких-либо параметров общего освещения, следует убедиться в том, что указаны единицы чертежа, которые должны использоваться. Изменение единиц чертежа после того, как получено удовлетворительное общее освещение, отрицательно сказывается на результатах тонирования.

Точность и мощность общего освещения зависит от числа порождаемых фотонов, радиуса выборки и глубины трассировки. Этот пример демонстрирует эффекты, определяемые низким числом фотонов и слишком малым радиусом выборки.

Фотоны и радиус выборки

Мощность общего освещения зависит от указанного числа фотонов. При уменьшении числа фотонов уровень шума общего освещения увеличивается, но при этом оно становится более рассеянным. При уменьшении числа фотонов уровень шума в общем освещении увеличивается, но освещение становится менее рассеянным. Чем больше используется фотонов, тем дольше выполняется процесс тонирования.

СоветЗначения таких параметров, как "Фотоны/образцы" или "Фотоны/Источник света", рекомендуется уменьшить при предварительном просмотре общего освещения, а затем увеличить для окончательного тонирования.

Радиус выборки определяет размер фотонов. Во многих случаях значение размера фотона по умолчанию, равное 1/10 от размера сцены ("Использовать радиус"="Откл"), обеспечивает удовлетворительный результат. Но иногда размер фотона по умолчанию оказывается слишком большим или слишком маленьким.

Значение радиуса выборки ("Радиус") определяет, перекрываются ли фотоны. При наложении фотонов друг на друга система тонирования сглаживает их. Увеличение радиуса улучшает качество сглаживания и создает более естественное освещение. Если фотоны маленького радиуса и не перекрываются друг другом, процедура сглаживания не выполняется. Рекомендуется устанавливать такие значения, чтобы фотоны накладывались друг на друга. Для достижения хороших результатов рекомендуется включить параметр "Использовать радиус" и увеличить значение радиуса.

Глубина трассировки общего освещения

Алгоритмы вычисления параметра "Глубина трассировки" аналогичны алгоритмам вычисления отражения и преломления. Однако параметр глубины трассировки применяется к фотонам, использующимся при общем освещении, а не к отражениям и преломлениям лучей.

Параметр максимальной глубины ограничивает суммарно возможное число преломлений и отражений. Отражения и преломления фотона прекращаются по достижении их суммы значения максимальной глубины. Например, если для параметра "Макс глубина" установлено значение 3, а для параметров "Макс отражений" и "Макс преломлений" - 2, фотон может дважды отразиться и один раз преломиться, или наоборот, но он не может отразиться и преломиться четыре раза.

Параметр "Макс отражений" задает число возможных отражений фотона. При значении, равном 0, отражения отсутствуют. При значение, равном 1, возможно только однократное отражение фотона. При значении, равном 2, возможно двукратное отражение фотона и т.д.

Параметр "Макс преломлений" задает число возможных преломлений фотона. При значении, равном 0, преломления отсутствуют. При значении, равном 1, возможно только однократное преломление фотона. При значении, равном 2, возможно двукратное преломление фотона и т.д.


Преимущества отраженного освещения (Краткий справочник)

Отражения и преломления в режиме трассировки лучей
Преимущества отраженного освещения
Чистовая проба
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Дополнительные функции тонирования > Преимущества отраженного освещения >
Преимущества отраженного освещения
Понятие Краткий справочник

Команды

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Чистовая проба (Понятие)

Преимущества отраженного освещения
Дополнительные функции тонирования
Журнал тонированных изображений
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Дополнительные функции тонирования >
Чистовая проба
Понятие Краткий справочник

Метод чистовых проб - дополнительный алгоритм, используемый для улучшения общего освещения. Он увеличивает число лучей, используемых при сглаживании общего освещения, и подавляет дефекты освещения.

Для создания общего освещения используется алгоритм, основанный на фотонных схемах. Следствием этого является возникновение дефектов тонирования, например, темных углов и низкочастотных колебаний освещения.

Метод чистовых проб увеличивает число лучей, используемых при создании общего освещения, тем самым полностью или частично подавляя эти дефекты освещения.

Пользователь сам решает, следует ли применять метод чистовых проб. Метод чистовых проб значительно увеличивает продолжительность процесса тонирования. Однако он очень удобен для сцен с общим диффузным освещением.

СоветОтключите метод чистовых проб во время предварительного просмотра, затем включите его при окончательной процедуре тонирования. (Увеличение числа фотонов, используемых для создания общего освещения, также улучшает качество освещения.)

Для включения и регулировки метода чистовых проб используйте палитру "Дополнительные параметры тонирования".


Чистовая проба (Краткий справочник)

Преимущества отраженного освещения
Чистовая проба
Журнал тонированных изображений
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Дополнительные функции тонирования > Чистовая проба >
Чистовая проба
Понятие Краткий справочник

Команды

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Журнал тонированных изображений (Понятие)

Чистовая проба
Реалистичное тонирование 3D объектов
Сохранение и повторное воспроизведение изображений
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов >
Журнал тонированных изображений
Понятие Краткий справочник

Журнал тонирования включает список последних тонированных изображений текущей загруженной модели.

Каждое изображение, местом расположения тонирования которого является файл или "Окно тонирования", сохраняется вместе с чертежом в качестве записи журнала.

Понятие о записях журнала

Записи журнала хранят информацию о тонированиях текущего чертежа.

Каждая запись журнала содержит информацию о последних тонированных изображениях. Записи журнала предоставляют следующую информацию:

  • Дата и время выполнения тонирования
  • Статистика задачи тонирования
  • Текущий вид или имя сохраненного вида
  • Имя активного набора параметров тонирования
  • Активные параметры тонирования, например, выходное разрешение
  • Размеры выделенной области, если задачей тонирования использовалось выделение
ПримечаниеВ записях журнала хранится не тонированное изображение, а ссылка на его местоположение.

Информация записи журнала

Помимо статистики записи журнала содержат пять элементов:

Имя выходного файла

Содержит два элемента: имя задачи тонирования и ее состояние. При выборе выходного файла в поле отображается имя этого файла. Если выходной файл не указан, отображается имя чертежа с временным суффиксом.

Формат вывода

Сообщает выходное разрешение тонированного изображения.

Вид

Всегда отображается текущий вид, за исключением задач тонирования сохраненного вида. В таком случае отображается имя вида.

Время тонирования

Указывается дата и продолжительность процесса тонирования изображения.

Набор параметров тонирования

Указывается, использовался ли системой набор параметров тонирования при создании изображения.

Время создания записи журнала

Если запись журнала сохраняется с текущим чертежом, она создается с учетом некоторых правил. Параметр назначения - основной фактор, определяющий, будет ли создана запись журнала. Подробнее о том, когда создается запись журнала и где она хранится, см. в следующей таблице.

Назначение | Запись журнала создана? | Запись сохранена с чертежом?
Файл | Да | Да
Окно тонирования | Да | Только при сохранении вида окна тонирования
"Видовой экран" | Нет записей | Неприменимо

Все созданные записи журнала, но не сохраненные вместе с чертежом, доступны только во время текущего сеанса работы. После закрытия файла или выхода из программы несохраненные записи теряются.

Состояния записи журнала

Существует четыре состояния отображения записи журнала в окне тонирования.

Нормальное

При задании папки для вывода и имени файла для тонирования создается запись журнала, она сохраняется вместе с чертежом. Запись журнала имеет обычный вид, и заданное пользователем имя файла отображается в столбце "Имя файла" в разделе журнала тонирования в окне тонирования.

Временное

Временные записи журнала создаются, если местом расположения тонирования является окно тонирования и пользователем не задано имя выходного файла. Запись журнала хранится в памяти до завершения текущего сеанса работы. Имена временных записей в списке "Имя выходного файла" имеют суффикс - -TempXXX.

Пустой

При задании папки для вывода и имени файла для тонирования создается запись журнала; она сохраняется вместе с чертежом. Запись журнала имеет обычный вид, а заданное пользователем имя файла отображается в столбце "Имя выходного файла" в разделе журнала тонирования в окне тонирования.


Журнал тонированных изображений (Краткий справочник)

Чистовая проба
Журнал тонированных изображений
Запись тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Журнал тонированных изображений >
Журнал тонированных изображений
Понятие Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

ТОНИРОКНО

Отображение окна тонирования без вызова задачи тонирования

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение и повторное воспроизведение изображений

Журнал тонированных изображений
Реалистичное тонирование 3D объектов
Запись тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов >
Сохранение и повторное воспроизведение изображений
Понятие Процедура

Тонированное изображение можно сохранить на диске, а затем в любой момент воспроизвести его на экране. Повторное воспроизведение тонированного изображения выполняется намного быстрее повторного тонирования.

Темы в этом разделе

  • Запись тонированного изображения

    Можно выполнить тонирование с записью в файл или сохранить запись журнала в одном из доступных форматов файлов.

  • Повторное воспроизведение тонированного изображения

    Сохраненное в файле тонированное изображение можно в любой момент воспроизвести на экране монитора.

  • Сохранение копий тонированных изображений

    Можно сохранить копии изображений из журнала тонирования чертежа.

  • Работа с моделями в других приложениях

    Для улучшения качества модели рекомендуется использовать и другие продукты Autodesk.

  • Обновление чертежей более ранней версии продукта

    При открытии чертежей прежних версий AutoCAD содержимое преобразуется для обеспечения совместимости с системой тонирования.


Сохранение и повторное воспроизведение изображений (Процедура)

Тонирование с тенями
Сохранение и повторное воспроизведение изображений
Запись тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений >
Сохранение и повторное воспроизведение изображений
Понятие Процедура

Для тонирования с записью в файл

Для сохранения тонированного изображения, отображаемого на видовом экране

Для сохранения тонированного изображения из "Окна тонирования"

Для сохранения тонированного изображения из окна тонирования


Запись тонированного изображения (Понятие)

Сохранение и повторное воспроизведение изображений
Сохранение и повторное воспроизведение изображений
Повторное воспроизведение тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений >
Запись тонированного изображения
Понятие Процедура Краткий справочник

Можно выполнить тонирование с записью в файл или сохранить запись журнала в одном из доступных форматов файлов.

Созданное тонированное изображение можно сохранить на диске, а затем в любой момент воспроизвести его. Длительность выполнения процесса тонирования зависит от выбранных параметров и наборов параметров тонирования. В то же время, повторное воспроизведение изображения, которое было тонировано ранее, происходит мгновенно.

Предусмотрены следующие способы сохранения тонированного изображения: тонирование с одновременной записью в файл; тонирование с выводом на экран и последующим сохранением изображения; тонирование с выводом в окно тонирования и дальнейшим сохранением изображения или его копии. Сохраненное изображение можно воспроизвести в любое время. Кроме того, сохраненные изображения можно использовать в качестве текстур создаваемых материалов.

Тонирование с записью в файл

Независимо от типа установленного в конфигурации монитора, можно вывести тонированное изображение сразу в файл, минуя экран. Преимущество такого способа заключается в том, что тонирование может быть произведено с разрешением, превышающим разрешение имеющегося монитора. Впоследствии изображение можно рассматривать на других системах, обладающих мониторами с более высокой разрешающей способностью. Местоположение и имя файла задаются с помощью параметра "Цель для изображения" на палитре "Дополнительные параметры тонирования" или на панели "Тонирование" ленты. Тонированное изображение хранится в файле одного из следующих форматов: BMP, TGA, TIF, PCX, JPG или PNG.

Сохранение тонированного изображения, отображаемого на экране

Программой предусмотрено тонирование с выводом изображения на видовой экран. После того как на видовом экране получено тонированное изображение, с помощью команды СОХРИЗОБ его можно сохранить в файле одного из следующих форматов: BMP, TGA, TIF, PCX, JPG или PNG. Доступные для сохранения форматы файлов предлагают большой выбор оттенков серого и значений глубины цвета.

Сохранение тонированного изображения, отображаемого в окне тонирования

Если местом расположения тонирования является окно тонирования, изображение или его копию можно сохранить в файле одного из следующих форматов: BMP, TGA, TIF, PCX, JPG или PNG. В зависимости от выбранного формата файла доступны оттенки серого и значения глубины цвета в диапазоне от 8 до 32 бит на пиксел.


Запись тонированного изображения (Процедура)

Сохранение и повторное воспроизведение изображений
На уровень вверх ..
Запись тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Запись тонированного изображения >
Запись тонированного изображения
Понятие Процедура Краткий справочник

Для тонирования с записью в файл

Для сохранения тонированного изображения, отображаемого на видовом экране

Для сохранения тонированного изображения из "Окна тонирования"


Для тонирования с записью в файл (Процедура)

Запись тонированного изображения
На уровень вверх ..
Запись тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Запись тонированного изображения >
Запись тонированного изображения
Понятие Процедура Краткий справочник

Для тонирования с записью в файл

  1. В командной строке введите режтон
  2. На палитре "Дополнительные параметры тонирования" установите флажок "Сохранить тонирование в файл".
  3. Нажмите кнопку [...] рядом с полем "Имя выходного файла".
  4. В диалоговом окне "Сохранить как" выберите тип файла и папку для хранения изображения. Нажмите кнопку "Сохранить".
  5. Нажмите кнопку "Тонирование".
    Панель:Тонирование
    Ввод команды: РЕЖТОН

    По завершению процесса тонирования изображение выводится в окне тонирования. Кроме того, оно сохраняется в папке с указанным именем.


Для сохранения тонированного изображения, отображаемого на видовом экране (Процедура)

Запись тонированного изображения
На уровень вверх ..
Запись тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Запись тонированного изображения >
Запись тонированного изображения
Понятие Процедура Краткий справочник

Для сохранения тонированного изображения, отображаемого на видовом экране

  1. После тонирования изображения на видовом экране выполните одно из указанных ниже действий. Выберите следующие элементы: вкладка "Визуализация" [image] панель "Тонирование" [image] Сохранить.В командной строке введите сохризоб.
  2. В диалоговом окне "Выходной файл тонирования" укажите папку для сохранения изображения.
  3. Введите имя изображения и формат выходного файла.
  4. Нажмите кнопку "Сохранить".
    Ввод команды: СОХРИЗОБ


Для сохранения тонированного изображения из "Окна тонирования" (Процедура)

Запись тонированного изображения
На уровень вверх ..
Сохранение копий тонированных изображений
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Запись тонированного изображения >
Запись тонированного изображения
Понятие Процедура Краткий справочник

Для сохранения тонированного изображения из "Окна тонирования"

  1. В "Окне тонирования" выберите запись журнала.
  2. Выберите пункт меню "Файл" [image] "Сохранить".
  3. В диалоговом окне "Выходной файл тонирования" выберите формат файла, введите папку для его хранения и имя файла. Нажмите кнопку "Сохранить".

    Изображение сохраняется в выбранном формате файла.


Запись тонированного изображения (Краткий справочник)

Журнал тонированных изображений
Запись тонированного изображения
Повторное воспроизведение тонированного изображения
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Запись тонированного изображения >
Запись тонированного изображения
Понятие Процедура Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

ТОНИРОКНО

Отображение окна тонирования без вызова задачи тонирования

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

СОХРИЗОБ

Сохранение тонированных изображений в файлах

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Повторное воспроизведение тонированного изображения (Понятие)

Запись тонированного изображения
Сохранение и повторное воспроизведение изображений
Сохранение копий тонированных изображений
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений >
Повторное воспроизведение тонированного изображения
Понятие Краткий справочник

Сохраненное в файле тонированное изображение можно в любой момент воспроизвести на экране монитора.

Сохраненное тонированное изображение можно просмотреть в любое время, открыв его в приложении просмотра изображений Windows.

Кроме того, изображение можно просмотреть, вставив его в чертеж с помощью команды ИЗОБВСТАВИТЬ.


Повторное воспроизведение тонированного изображения (Краткий справочник)

Запись тонированного изображения
Повторное воспроизведение тонированного изображения
Сохранение копий тонированных изображений
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Повторное воспроизведение тонированного изображения >
Повторное воспроизведение тонированного изображения
Понятие Краткий справочник

Команды

ИЗОБВСТАВИТЬ

Вставка нового изображения в текущий чертеж

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Сохранение копий тонированных изображений (Понятие)

Повторное воспроизведение тонированного изображения
Сохранение и повторное воспроизведение изображений
Работа с моделями в других приложениях
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений >
Сохранение копий тонированных изображений
Понятие Процедура Краткий справочник

Можно сохранить копии изображений из журнала тонирования чертежа.

Используйте элемент "Сохранить копию", который имеется в "Окне тонирования" для сохранения тонированного изображения в другой папке, даже если уже установлен путь для выходного файла. Благодаря этому можно выполнить повторное тонирование записи журнала и сравнить новое изображение с предыдущим.


Для сохранения тонированного изображения из окна тонирования (Процедура)

Запись тонированного изображения
На уровень вверх ..
Работа с функцией экспорта в Impression
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Сохранение копий тонированных изображений >
Сохранение копий тонированных изображений
Понятие Процедура Краткий справочник

Для сохранения тонированного изображения из окна тонирования

  1. В "Окне тонирования" выберите запись журнала.
  2. Выберите пункт меню "Файл" [image] "Сохранить копию".
  3. В диалоговом окне "Выходной файл тонирования" выберите формат файла, введите папку для его хранения и имя файла. Нажмите кнопку "Сохранить".

    Изображение сохраняется в выбранном формате файла.


Сохранение копий тонированных изображений (Краткий справочник)

Повторное воспроизведение тонированного изображения
Сохранение копий тонированных изображений
Работа с моделями в других приложениях
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Сохранение копий тонированных изображений >
Сохранение копий тонированных изображений
Понятие Процедура Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

ТОНИРОКНО

Отображение окна тонирования без вызова задачи тонирования

РЕЖТОН

Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с моделями в других приложениях (Понятие)

Сохранение копий тонированных изображений
Сохранение и повторное воспроизведение изображений
Обновление чертежей более ранней версии продукта
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений >
Работа с моделями в других приложениях
Понятие Краткий справочник

Для улучшения качества модели рекомендуется использовать и другие продукты Autodesk.

В программы Autodesk®, включая 3ds max®, Autodesk® VIZ, AutoCAD® Architecture и AutoCAD® Mechanical, постоянно вносятся усовершенствования, расширяющие возможности совместного использования чертежей и моделей.

3ds max или Autodesk VIZ

С помощью этих программ можно существенно улучшить модели. Программы предоставляют возможность открыть файлы DWG или DXF без преобразования, кроме того можно использовать Диспетчер связей файлов для создания связи с файлом чертежа. 3ds max или Autodesk VIZ предлагает расширенные возможности анимации, широкий выбор источников освещения, материалов и возможностей тонирования, которые повышают реалистичность графических объектов.

AutoCAD Architecture

Геометрию чертежа AutoCAD можно открыть в AutoCAD Architecture в формате DWG. Преобразование файла не требуется. Открыв модель, использовуйте программу VIZ Render - упрощенный вариант приложения Autodesk VIZ. Также доступны "Связь файла", функции создания материалов и дополнительные функции тонирования.

AutoCAD Mechanical

Если в AutoCAD Mechanical требуется использовать геометрические данные и данные тонирования AutoCAD, для экспорта и импорта файлов можно воспользоваться следующими способами.

  • Для экпорта чертежа выберите меню Файл [image] Экспорт.Для экпорта чертежа введите в командной строке "экспорт".
  • Для импорта файла выберите меню Вставка [image] Двоичные файлы графического обмена.Для импорта файла введите в командной строке "импортд".


Работа с моделями в других приложениях (Краткий справочник)

Сохранение копий тонированных изображений
Работа с моделями в других приложениях
Обновление чертежей более ранней версии продукта
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Работа с моделями в других приложениях >
Работа с моделями в других приложениях
Понятие Краткий справочник

Команды

ИМПОРТ3DC

Импорт файлов 3D Studio (3DS)

AMECONVERT

Преобразование моделей AME в твердотельные объекты AutoCAD

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Обновление чертежей более ранней версии продукта (Понятие)

Работа с моделями в других приложениях
Сохранение и повторное воспроизведение изображений
Имитация рисования от руки на чертежах САПР
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений >
Обновление чертежей более ранней версии продукта
Понятие Краткий справочник

При открытии чертежей прежних версий AutoCAD содержимое преобразуется для обеспечения совместимости с системой тонирования.

Источники света, материалы и камеры

Источники света, материалы и камеры улучшены, однако некоторые старые чертежи могут содержать информацию системы AutoShade, например источники света, блоки сцен и камер.

Источники света и материалы старых чертежей также могут быть преобразованы. В AutoCAD 2008 введена новая системная переменная 3DCONVERSIONMODE . Если для этой системной переменной задано значение по умолчанию 1, для чертежей более ранних версий автоматически выполняется преобразование освещения и материалов. Дополнительные сведения о преобразовании чертежей приведены в разделах Преобразование источников света и Преобразование материалов.


Обновление чертежей более ранней версии продукта (Краткий справочник)

Работа с моделями в других приложениях
Обновление чертежей более ранней версии продукта
О программе Autodesk Impression
Тонирование чертежа для презентации > Реалистичное тонирование 3D объектов > Сохранение и повторное воспроизведение изображений > Обновление чертежей более ранней версии продукта >
Обновление чертежей более ранней версии продукта
Понятие Краткий справочник

Команды

ТОНИРОВАТЬ

Создание фотореалистичного или реалистичного тонированного изображения 3D каркасной или твердотельной модели

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Имитация рисования от руки на чертежах САПР

Обновление чертежей более ранней версии продукта
Тонирование чертежа для презентации
О программе Autodesk Impression
Тонирование чертежа для презентации >
Имитация рисования от руки на чертежах САПР

Для презентаций может потребоваться придать чертежу вид, имитирующий рисование от руки.

Темы в этом разделе

  • О программе Autodesk Impression

    Программное обеспечение Autodesk Impression позволяет преобразовать точные чертежи в привлекающие взгляд иллюстрации, которые могут имитировать, например, карандашные рисунки или раскраску от руки.

  • Работа с функцией экспорта в Impression

    Экспорт чертежа в Impression позволяет просмотреть, как будет выглядеть чертеж после применения штрихов, имитирующих рисование от руки.

  • Получение информации о программе Impression

    В этом разделе приведены источники информации о работе с программой Impression и о ее приобретении.


О программе Autodesk Impression (Понятие)

Имитация рисования от руки на чертежах САПР
Имитация рисования от руки на чертежах САПР
Работа с функцией экспорта в Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР >
О программе Autodesk Impression
Понятие Краткий справочник

Программное обеспечение Autodesk Impression позволяет преобразовать точные чертежи в привлекающие взгляд иллюстрации, которые могут имитировать, например, карандашные рисунки или раскраску от руки.

Открытие или импорт файлов DWG или DWF

Функция экспорта в Impression позволяет экспортировать вид в Autodesk® Impression. для тонирования. Если на компьютере установлена программа Impression, файл DWG (например, чертеж AutoCAD) или двумерный файл DWF открывается в ней с имитацией штрихов, нанесенных карандашом или маркером.

В Impression выполняется преобразование трехмерных (3D) видов в двумерные иллюстрации, в которых скрытые линии по умолчанию удалены.

В Impression предусмотрены инструменты, позволяющие назначать стили слоям и объектам, а также закрашивать замкнутые области с применением разнообразных стилей заливки.

Применение стилей к чертежу

В комплект поставки Impression входит большое количество встроенных стилей. Предусмотрена также возможность разработки наборов стилей пользователями. Настройка внешнего вида осуществляется путем изменения таких свойств, как ширина штриха, цвет и допустимое отклонение. Можно задать контурные штрихи или создать стили заливки, включающие в себя штрихи, текстуры и градиенты.

Поддерживаются различные эффекты, например, шероховатые кромки.

Во избежание перегруженности иллюстрации рекомендуется пользоваться едиными стилями слоев, что позволяет применить ко всем объектам в данном слое один и тот же стиль штрихов.

Для применения заливки к замкнутым областям, ограниченным различными объектами, можно воспользоваться следующими способами.

  • С помощью инструмента "Закраска областей" вставить стиль заливки одним щелчком мыши, прочертив линию через контур области или перетащив рамку. В этом случае области, к которым можно применить заливку, отображаются в режиме предварительного просмотра оттенками серого цвета.

  • С помощью инструмента "Эффективная закраска" одновременно применить заливку к нескольким сформированным областям.

  • Перетащить образец стиля с палитры стилей в замкнутую область (этот способ позволяет быстро применить заливку к обширным областям).

Создание геометрических объектов и текста

Предусмотрена возможность вставки текста, рисования пользовательских фигур и добавления падающих теней.

Работа с блоками в целях экономии времени

Поддерживается создание и вставка блоков, а также быстрая замена вставленных блоков путем перетаскивания в них объектов, к которым применены стили.

Для изменения внешнего вида блоков можно обновить стили блоков, хранящиеся на палитре стилей.

Исходные стили блоков и блок дерева

Обновленные стили блоков и обновленный блок дерева

Совместное использование результатов

По завершении работы над иллюстрацией можно сохранить ее в одном из разнообразных стандартных форматов для совместного использования.

ПримечаниеПрограмма Autodesk Impression распространяется с ограничениями. Информация о доступности Impression в конкретной стране представлена на веб-узле Autodesk для этой страны.


О программе Autodesk Impression (Краткий справочник)

Обновление чертежей более ранней версии продукта
О программе Autodesk Impression
Работа с функцией экспорта в Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР > О программе Autodesk Impression >
О программе Autodesk Impression
Понятие Краткий справочник

Команды

ВПЕЧАТЛЕНИЕ

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Работа с функцией экспорта в Impression (Понятие)

О программе Autodesk Impression
Имитация рисования от руки на чертежах САПР
Получение информации о программе Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР >
Работа с функцией экспорта в Impression
Понятие Процедура Краткий справочник

Экспорт чертежа в Impression позволяет просмотреть, как будет выглядеть чертеж после применения штрихов, имитирующих рисование от руки.

Процесс экспорта

В процессе экспорта чертежа в Impression можно указать тип штриха по умолчанию, который будет применяться при открытии этого чертежа в Impression. Все чертежи, в том числе трехмерные, в Impression рассматриваются как двумерные чертежи.

ПримечаниеДля работы с этой функцией экспорта необходимо сначала установить на компьютер Autodesk® Impression. Данная программа распространяется с ограничениями. Информация о доступности Impression в конкретной стране представлена на веб-узле Autodesk для этой страны.

Инструменты Impression позволяют усовершенствовать иллюстрацию путем применения стилей заливки к объектам и слоям. Можно перетащить образец заливки области в любую точку внутри замкнутого контура или воспользоваться инструментом закраски областей, обеспечивающим более высокую точность. Если для выполнения конкретной задачи не подходит ни один из многочисленных стилей заливки, входящих в комплект программы, можно создать пользовательские стили.

В Impression иллюстрации сохраняются в формате IRF (Impression Render Format - формат тонирования Impression). Внесенные изменения не влияют на исходный файл DWG или DWF. Однако при изменении исходного чертежа можно с помощью функции обновления геометрии САПР обновить рабочие линии и сохранить значительную часть стилей, примененных с помощью Impression. Если контуры заливки существенно различаются, можно обновить раскраску путем повторного применения заливки к областям или перетаскивания якорей заливки в новое местоположение.

Преобразование трехмерных чертежей

При экспорте трехмерных чертежей в Impression они преобразуются в двумерные с автоматическим применением следующих параметров: скрытые линии удалены, пересекающиеся кромки отображаются, а линии контура отключены.

Эти параметры по умолчанию невозможно изменить при экспорте чертежа непосредственно из AutoCAD или другой программы на основе AutoCAD. Если требуется изменить эти параметры дл отображения геометрии каркаса, следует импортировать или открыть чертеж в Impression.

Экспортировать в Impression трехмерный файл DWF невозможно.


Работа с функцией экспорта в Impression (Процедура)

Сохранение копий тонированных изображений
Работа с функцией экспорта в Impression
Работа с функцией экспорта в Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР > Работа с функцией экспорта в Impression >
Работа с функцией экспорта в Impression
Понятие Процедура Краткий справочник

Экспорт чертежа в Impression (диалоговое окно)

Экспорт чертежа в Impression (лента)


Экспорт чертежа в Impression (диалоговое окно) (Процедура)

Работа с функцией экспорта в Impression
Работа с функцией экспорта в Impression
Работа с функцией экспорта в Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР > Работа с функцией экспорта в Impression >
Работа с функцией экспорта в Impression
Понятие Процедура Краткий справочник

Экспорт чертежа в Impression (диалоговое окно)

  1. Выберите пункт меню "Файл" [image] "Экспорт в Impression".
    ПримечаниеДля работы с этой функцией экспорта необходимо сначала установить на компьютер программу Impression.
  2. В диалоговом окне "Экспорт в Impression" выберите в разделе "Экспортировать" один из следующих вариантов.
    • Экран. Экспорт текущего вида.
    • Границы. Экспорт всех геометрических объектов в текущем виде независимо от того, отображаются ли они в данный момент в области рисования.
    • Рамка. Экспорт фрагмента области рисования, который определяется двумя точками, указанными пользователем.
    • Листы. Экспорт всех видовых экранов и геометрических объектов, отображаемых на выбранном листе.
  3. В списке "Таблица стилей печати" выполните одно из следующих действий.
    • Если за основу стилей штрихов Impression требуется брать свойства (цвет, вес линий и тип линий), заданные в таблице стилей печати, выберите файл STB или CTB.
    • Если за основу стилей штрихов Impression требуется брать вес линий и тип линий, заданные для каждого входящего слоя, выберите "Нет".
  4. В списке "Штрих" выберите штрих, который требуется применять ко всем экспортируемым геометрическим объектам.

    Если заданные в стиле печати значения веса линий и типа линий требуется применять в сочетании со свойствами выбранного штриха, выберите одновременно стиль печати и штрих. В случае конфликта значений параметров более высоким приоритетом обладает параметр, заданный в стиле печати.

  5. Нажмите "ОК".

    Чертеж открывается в Impression. Можно сохранить или распечатать чертеж либо продолжить процедуру применения стилей к иллюстрации.

Ввод команды: ВПЕЧАТЛЕНИЕ
Панель:Стандартный


Экспорт чертежа в Impression (лента) (Процедура)

Работа с функцией экспорта в Impression
Работа с функцией экспорта в Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР > Работа с функцией экспорта в Impression >
Работа с функцией экспорта в Impression
Понятие Процедура Краткий справочник

Экспорт чертежа в Impression (лента)

  1. На ленте выберите следующие элементы: вкладка "Печать/Публикация" [image] панель "Экспорт в Impression" [image] список "Экспорт", затем вид, который требуется экспортировать.
    • Экран. Экспорт текущего вида.
    • Границы. Экспорт всех геометрических объектов в текущем виде независимо от того, отображаются ли они в данный момент в области рисования.
    • Рамка. Экспорт фрагмента области рисования, который определяется двумя точками, указанными пользователем.
    • Листы. Экспорт всех видовых экранов и геометрических объектов, отображаемых на выбранном листе.
    ПримечаниеДля работы с этой функцией экспорта необходимо сначала установить на компьютер программу Impression.
  2. Щелкните на списке "Таблица стилей печати" и выполните одно из следующих действий.
    • Если за основу стилей штрихов Impression требуется брать свойства (цвет, вес линий и тип линий), заданные в таблице стилей печати, выберите файл STB или CTB.
    • Если за основу стилей штрихов Impression требуется брать вес линий и тип линий, заданные для каждого входящего слоя, выберите "Нет".
  3. В списке "Штрих" выберите штрих, который требуется применять ко всем экспортируемым геометрическим объектам.

    Если заданные в стиле печати значения веса линий и типа линий требуется применять в сочетании со свойствами выбранного штриха, выберите одновременно стиль печати и штрих. В случае конфликта значений параметров более высоким приоритетом обладает параметр, заданный в стиле печати.

  4. Нажмите кнопку "Экспорт".

    Чертеж открывается в Impression. Можно сохранить или распечатать чертеж либо продолжить процедуру применения стилей к иллюстрации.


Работа с функцией экспорта в Impression (Краткий справочник)

О программе Autodesk Impression
Работа с функцией экспорта в Impression
Получение информации о программе Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР > Работа с функцией экспорта в Impression >
Работа с функцией экспорта в Impression
Понятие Процедура Краткий справочник

Команды

ВПЕЧАТЛЕНИЕ

Создание рисованного от руки эскиза для CAD-чертежа при его экспорте для тонирования в Autodesk Impression

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Получение информации о программе Impression (Понятие)

Работа с функцией экспорта в Impression
Имитация рисования от руки на чертежах САПР
Словарь терминов
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР >
Получение информации о программе Impression
Понятие Краткий справочник

В этом разделе приведены источники информации о работе с программой Impression и о ее приобретении.

Получение информации о работе с программой Impression

Информацию можно найти в различных источниках.

  • Краткий обзор Это краткое руководство, доступное из меню "Справка" программы Impression, отображается в нижней части полотна Impression, или области рисования. В него включены иллюстрированные примеры, представляющие собой практические инструкции по работе с важнейшими функциями Impression. Предусмотрены также короткие мультиплицированные демонстрации отдельных этапов работы.
  • Руководство по началу работы Руководство по началу работы, доступное из меню "Справка" программы Impression, представляет собой иллюстрированный и мультиплицированный обзор функциональных возможностей Impression.
  • Справочная система Impression После первоначального ознакомления с программой Impression можно получить более подробные сведения в справочной системе Impression. Для быстрого поиска общих описаний, процедур, сведений о диалоговых окнах и палитрах, определений рекомендуется ознакомиться со структурой справочной системы.
  • Веб-узел сообщества Autodesk Impression Для просмотра новостей и обмена информацией с другими пользователями Impression перейдите по адресу http://impression.autodesk.com/impression-community.

Получение программы Impression

В комплект поставки некоторых программ Autodesk входит полностью лицензированная версия Impression. Дополнительные сведения см. на веб-узле по адресу http://www.autodesk.com/impression.

ПримечаниеПрограмма Autodesk Impression распространяется с ограничениями. Информация о доступности Impression в конкретной стране представлена на веб-узле Autodesk для этой страны.

Доступ к версиям Impression

Если на компьютере установлено несколько версий Impression, при обращении к функции экспорта в Impression автоматически выполняется экспорт чертежа в наиболее позднюю версию. Если последняя версия Impression не установлена, можно обновить одну из более ранних версий или задать ее для использования по умолчанию. По истечении срока действия ознакомительной версии можно приобрести лицензию или вернуться к любой из установленных на компьютере более ранних версий.

При экспорте в более ранние версии Impression не все функции работают так же, как в последней версии.

  • Экспорт в Impression версии 1 в режимах "Рамка" и "Экран" не поддерживается. Экспорт выполняется только в пределах границ чертежа.
  • Информация о стиле печати утрачивается. В тонированных чертежах применяется только тип штриха.


Получение информации о программе Impression (Краткий справочник)

Работа с функцией экспорта в Impression
Получение информации о программе Impression
Тонирование чертежа для презентации > Имитация рисования от руки на чертежах САПР > Получение информации о программе Impression >
Получение информации о программе Impression
Понятие Краткий справочник

Команды

ВПЕЧАТЛЕНИЕ

Системные переменные

Нет записей

Утилиты

Нет записей

Ключевые слова для команд

Нет записей


Словарь терминов

Получение информации о программе Impression
Словарь терминов
B-сплайновая кривая

Кусочно-гладкая полиномиальная кривая, проходящая вблизи набора управляющих точек. См. также кривая Безье. (СПЛАЙН)

CMYK

От cyan, magenta, yellow, and key color (голубой, фиолетовый, желтый и цвет фонового экрана). Цвет определяется системой исходя из процентного содержания голубого, фиолетового, желтого и фонового экранного (обычно это черный) цветов.

CTB-файл

SТаблица цветозависимых стилей печати.

DIESEL

Direct Interpretively Evaluated String Expression Language (прямая интерпретация содержания текстовой строки). Макроязык, предназначенный для модификации статусной строки AutoCAD с помощью системной переменной MODEMACRO, а также для адаптации пунктов меню.

DSD

От drawing set descriptions (описания наборов чертежей). Формат файлов для хранения описаний наборов чертежей, использующихся в диалоговом окне "Публикация".

DST

От sheet set data (данные подшивки). Формат файлов типа XML, использующийся для хранения сведений о подшивке.

DWF

От Design Web Format (формат для использования в сети Интернет). Формат плотно упакованного файла, создаваемого из чертежа AutoCAD. Файлы формата DWF используются для публикации и просмотра чертежей в сети Интернет. См. также DWG и DXF.

DWFx

Формат DWFx, разработанный на основе предложенного корпорацией Microsoft формата XML Paper Specification (XPS), в будущем заменит формат DWF.

Файлы DWFx без затруднений распространяются на платформе Windows Vista, так как этот формат поддерживается средством просмотра XPS. Можно также просматривать файлы DWFx с помощью программы Autodesk Design Review.

DWG

Стандартный формат файлов для хранения векторной графики. См. также DWF и DXF.

DXF

От drawing interchange format (формат для обмена чертежами). Текстовый (ASCII) или двоичный формат файлов для экспорта чертежей в другие приложения или для импорта чертежей из других приложений. См. также DWF и DWG.

HDI

От Heidi Device Interface (интерфейс устройств Heidi). Интерфейс с драйверами устройств, необходимыми для взаимодействия периферийного оборудования с программой и другими продуктами Autodesk.

HLS

От hue, lightness, saturation (оттенок, яркость, насыщенность). Задание цвета на основе его оттенка, яркости и насыщенности.

i-drop

Элементы, с помощью которых можно перетаскивать файлы чертежей с веб-страниц.

IGES

От Initial graphics exchange specification (исходный стандарт обмена графическими данными). Стандартный формат для двоичного представления данных и обмена ими между различными системами САПР. В приложениях на основе AutoCAD команды импорта и экспорта файлов IGES имеются только в AutoCAD Mechanical.

ISO

От International Standards Organization (Международная организация стандартов). Организация, занимающаяся разработкой международных стандартов во всех отраслях, кроме электротехники и электроники. Штаб-квартира ISO находится в Женеве (Швейцария).

NURBS

От Nonuniform rational B-spline curve (неоднородный рациональный В-Сплайн). B-сплайновая кривая или поверхность, задаваемая набором управляющих точек с определенными весами и одним или более узловыми векторами. См. также B-сплайновая кривая.

ObjectARX (AutoCAD Runtime Extension)

Среда программирования, позволяющая разрабатывать компилируемые приложения AutoCAD.

OLE

От Object linking and embedding (присоединенный или встроенный в другие файлы объект). Механизм, с помощью которого данные из исходного документа, созданного с помощью одного приложения, могут быть внедрены в целевой документ, созданный в другом приложении, или связаны с ним. Выбор таких данных в целевом документе инициирует подгрузку исходного приложения, что обеспечивает возможность их редактирования. См. также внедрение и связь.

PC2-файл

Общий файл конфигурации печати. Файлы PC2 содержат все настройки печати и специализированные параметры устройств, сохраненные в прежних версиях программы. См. также файл PCP и файл PC3.

PC3-файл

Частный файл конфигурации плоттера. Содержит параметры печати, включая выбор драйвера и модели устройства, выбор порта для вывода на печать и различные сведения для конкретного устройства печати. Однако в этот набор параметров не входят пользовательские настройки плоттера и сведения о нестандартном формате листа. См. также файл PMP, файл STB и файл CTB.

PCP-файл

Частный файл конфигурации плоттера. Файлы PCP содержат основные параметры печати и перьев, сохраненные в предыдущих версиях программы. К этим параметрам относятся присвоения перьев, единицы измерения для печати, формат листа, поворот чертежа, коэффициент масштабирования и выбор режима оптимизации перемещений перьев. См. также файл PC2 и файл PC3.

PMP-файл

Plot Model Parameter. Файл, содержащий пользовательские сведения о калибровке плоттера и форматах листа. Связан с файлом конфигурации плоттера.

RGB

От Red, green, blue (красный, зеленый, синий). Задание цвета на основе процентного содержания красной, зеленой и синей составляющих.

RSS-канал

Информация, публикуемая веб-узлом, на который подписан пользовать. Обычно уведомляет пользователей о публикации новых материалов (статей). RSS расшифровывается как Rich Site Summary (Полная сводка по сайту) или Really Simple Syndication (Действительно простое распространение)

ShapeManager

ShapeManager® представляет собой технологию Autodesk, обеспечивающую возможности моделирования 3D тел в AutoCAD и других продуктах.

ShowMotion ("Аниматор движения")

Элемент интерфейса, обеспечивающий доступ к именованным видам (снимкам), которые хранятся в текущем чертеже. Именованные виды (снимки) расположены в определенной последовательности и могут содержать данные о движении.

STB-файл

Файл таблицы стилей печати. Содержит стили печати и их параметры.

TILEMODE

Системная переменная, управляющая режимом создания видовых экранов (либо в виде перемещаемых, масштабируемых объектов, либо как неперекрывающихся элементов экрана со смежными кромками). См. также видовой экран.

UVW

Координатное пространство материала. Используется вместо систему координат XYZ, которая обычно зарезервирована мировой системой координат. Как правило, текстуры лежат в двумерной плоскости и назначены трехмерному пространству. Координатные оси U, V и W параллельны координатным осям X, Y и Z. В изображении наложенной текстуры ось U эквивалентна оси X и представляет горизонтальное направление текстуры. Ось V эквивалентна оси Y и представляет вертикальное направление текстуры. Ось W эквивалентна оси Z и представляет направление, перпендикулярное плоскости UV текстуры.

X,Y,Z фильтры точек

См. фильтры координат.

абсолютные координаты

Значения координат, измеренные относительно начальной точки системы координат. См. также начало координат, относительные координаты, пользовательская система координат, мировые координаты и Мировая система координат (МСК).

адаптер объектов

Средство просмотра и редактирования сторонних объектов, использующееся, если приложение ObjectARX, в котором был создан сторонний объект, в системе не установлено. См. также пользовательский объект и объект-заместитель.

адаптивная выборка

Метод, ускоряющий процесс устранения зазубрин в пределах границ пробной матрицы. См. также сглаживание.

адаптивное ухудшение

Метод управления производительностью, заключающийся в отключении функций в определенном порядке, когда производительность падает ниже заданного уровня.

активация

Часть процесса регистрации программного обеспечения. Позволяет запускать продукт в соответствии с лицензионным соглашением конечного пользователя продукта.

альфа-канал

"Альфа" представляет собой тип данных, содержащихся в 32-битовых растровых файлах, с помощью которых присваивается прозрачность пикселам изображения.

В файле с 24-битовой точной цветопередачей содержится три канала информации о цвете: красный, зеленый и синий, или RGB. Каждый канал файла с точной цветопередачей задается 8-ю битами, обеспечивая 256 уровней интенсивности. Интенсивность каждого канала определяет цвет пиксела в изображении. Таким образом, файл RGB является 24-битовым с 256 уровнями для каждого цвета: красного, зеленого и синего.

За счет добавления четвертого, альфа-канала, файл может задавать прозрачность или непрозрачность каждого из пикселов. Значение альфа 0 означает прозрачность, значение 255 - непрозрачность, а промежуточные значения означают полупрозрачность. Файл RGBA (красный, зеленый, синий, альфа) является 32 битовым, с дополнительными 8 битами альфа, обеспечивающими 256 уровней прозрачности.

Для вывода изображения, тонированного с использованием альфа, его нужно сохранить в формате, совместимом с альфа, например, PNG, TIFF или Targa.

аннотативный

Свойство объекта, который обычно используется в аннотативных чертежах. Это свойство позволяет автоматизировать процесс масштабирования аннотаций. Аннотативные объекты определяются по высоте листа, а их размер, отображаемый в видовых экранах листа и пространстве модели, соответствует масштабу аннотаций, установленному для этих пространств.

ассоциативная штриховка

Штриховка замкнутой области, автоматически изменяющаяся при любых модификациях ограничивающего контура. (КШТРИХ)

ассоциативный размер

Размер, автоматически обновляющийся при изменении объекта с нанесенными размерами. Управляется системной переменной DIMASSOC. См. также неассоциативный размер и расчленённый размер.

аффинная калибровка

Метод калибровки планшета, основанный на линейном преобразовании координат в двумерном пространстве. Аффинная калибровка требует ввода трех контрольных точек для вычисления преобразования координат планшета, включая перемещение, независимое масштабирование осей X и Y, а также поворот и искажения. Аффинную калибровку следует использовать, если наблюдается неравномерность в вертикальном и горизонтальном масштабном отображении чертежа при его оцифровке с помощью дигитайзера. (ПЛАНШЕТ)

базовая линия

Воображаемая линия, на которой устанавливаются символы текста. Нижние элементы некоторых символов могут опускаться ниже базовой линии. См. также базовый размер.

базовая подсказка

Краткое описание, отображаемое в качестве подсказки.

базовая точка

1. В контексте ручек редактирования это ручка, которая, когда она выбрана для указания центральной точки последующей операции редактирования, изменяется, приобретая чистый цвет. 2. Точка, предназначенная для определения относительного расстояния и угла при копировании, переносе и повороте объектов. 3. Базовая точка вставки для текущего чертежа. (БАЗА) 4. Базовая точка вставки для определения блока. (БЛОК)

базовый размер

Совокупность размеров, проведенных от одной базовой линии. Также называются параллельные размеры. См. также базовый.

библиотека обозначений

Набор определений блоков, хранящийся в одном файле чертежа.

библиотека слайдов

Набор файлов слайдов, скомпилированных для хранения и последующего просмотра. Файлы библиотеки слайдов имеют расширение .slb и создаются с помощью утилиты slidelib.exe.

блок

Один или несколько объектов, сгруппированные в единый объект. Иногда, для краткости, используется вместо терминов "определение блока" и "вхождение блока". См. также определение блока и вхождение блока. (БЛОК)

блок-идентификатор

Блок, используемый в качестве обозначения для ссылки на другой лист. Блоки-идентификаторы могут называться по-разному (в зависимости от отрасли промышленности): ссылочные метки, коды выносных элементов, метки выносных элементов, коды разрезов зданий и т.д. См. также блок метки.

блок-метка

Блок, используемый для маркировки видов и подробностей. Метки содержат связанные с видом сведения, такие как имя, номер вида и масштаб. См. также блок-идентификатор.

большие штурвалы

Увеличенный вариант SteeringWheels. В каждом сегменте штурвала отображаются метки, а размер сегментов больше размера курсора.

булавка

Кнопка в форме канцелярской кнопки, используемая на ленте и в обозревателе меню. На ленте булавки служат для фиксации панелей в развернутом виде. В обозревателе меню с помощью булавки можно запретить удаление элемента из списка последних просмотренных элементов.

ведомость листов

Таблица с перечнем всех листов в подшивке. Ведомость листов можно сгенерировать автоматически с помощью Диспетчера подшивок.

вектор

Математический объект, обладающий направлением и длиной, но не имеющий фиксированного положения в пространстве.

вертикальная лента

Лента, расположенная вертикально, как правило, вдоль левого или правого края окна чертежа.

верхняя панель (ВП)

Процесс прозрачного отображения элементов пользовательского интерфейса в верхней части области рисования или поверх нее, не препятствующий просмотру нарисованных объектов в области рисования.

вершина

Место пересечения кромок объекта или сегментов полилинии.

вес линий

Значение ширины, которое может быть присвоено всем графическим объектам, кроме шрифтов TrueType® и растровых изображений.

вид

Графическое представление двумерного чертежа или трехмерной модели из заданного места (точки зрения) в пространстве. См. также точка зрения и видовой экран. (3DОРБИТА, ТЗРЕНИЯ, ДВИД, ВИД)

вид в перспективе

Вид, на котором 3D объекты рассматриваются из некоторой точки пространства. Чем дальше объект находится от точки наблюдения, тем меньше его видимые размеры. Хотя вид в перспективе достаточно реалистичен, на нем возможно искажение формы объектов. Параллельные линии как будто сходятся. Настройки видов в перспективе задаются в программе для элементов таблиц видовых экранов, а также для объектов видовых экранов, с помощью параметра ВЭКРАН.

вид в плане

Ориентация вида от точки на положительной оси Zк начальной точке (0,0,0). (ПЛАН)

Видовой куб

Элемент пользовательского интерфейса, предназначенный для отображения модели в текущей ориентации. С его помощью можно восстановить или создать ПСК, повернуть вид в интерактивном режиме, а также восстановить стандартный вид.

видовой экран

Ограниченная область экрана, на которой отображается некоторая часть пространства модели чертежа. Тип создаваемого видового экрана определяется системной переменной TILEMODE. 1. Если TILEMODE выключена (0), видовые экраны являются объектами, которые можно перемещать на листе и изменять их размер. (СВИД) 2. Если TILEMODE включена (1), то вся область рисования делится на неперекрывающиеся видовые экраны. См. также TILEMODE, вид и точка зрения. (ВЭКРАН)

видовые экраны пространства модели

Состояние экрана монитора, при котором графическая область разбивается на две или более смежных неперекрывающихся прямоугольных области с видами чертежа. См. также видовые экраны листа, TILEMODE и видовой экран. (ВЭКРАН)

визуальный стиль

Совокупность параметров, определяющих отображение

виртуальное экранное пространство

Область, в пределах которой программа может выполнять панорамирование и зумирование чертежа без необходимости его регенерации.

вкладка ленты

Элемент управления наивысшего уровня на ленте. Вкладки содержат панели, которые в свою очередь содержат кнопки или другие элементы управления.

внедрение

Один из методов использования данных исходного документа в целевом документе. Позволяет вставлять копию объекта из одного документа в другой без ссылки на исходный документ. См. также связывание.

внешние именованные объекты

См. зависимые именованные объекты во внешних ссылках.

внешняя ссылка

Файл чертежа, связанный с другим чертежом или вставленный в него. (ССЫЛКА)

внешняя ссылка

См. внешняя ссылка (ссылка).

воспроизведение

Процесс выполнения операций, сохраненных в ранее записанном макросе операции.

временные файлы

Файлы данных, создаваемые в ходе сеанса работы программы. Файлы удаляются по окончании сеанса. При аварийном завершении (например, из-за отключения электропитания), временные файлы могут остаться на диске.

вспомогательная подсказка

Командная строка с инструкцией по вводу данных для выполнения команды или изменения свойства.

вторичный фрагмент таблицы

Любой фрагмент разорванной таблицы, не содержащий начального набора строк.

вхождение блока

Составной объект, вставленный в чертеж и отображающий данные из определения блока. Также называется экземпляром. См. также блок и определение блока. (ВСТАВИТЬ)

выбор рамкой

Прямоугольник, позволяющий выбирать группы объектов. Очерчивается в области рисования. См. также секущая рамка, многоугольник выбора.

выбор секущей рамкой

Прямоугольная рамка выбора, захватывающая все объекты, которые попадают в нее целиком или пересекают ее границы.

выборка

Выборка представляет собой методику сглаживания цветов. Эта процедура определяет наилучший цвет для каждого тонируемого пиксела. Система тонирования сначала выбирает произвольные пикселы вокруг рассматриваемого пиксела, затем использует фильтр для определения оптимального цвета обрабатываемого пиксела.

выдавливание

Процесс получения трехмерного тела путем смещения объекта вдоль линейной траектории.

выделение зависимости

В описании динамического блока это способ отображения связанных объектов при выборе параметра, ручки или операции.

выплывающая панель

Область ленты, связанная с панелью ленты. выплывающая панель содержит дополнительные инструменты и элементы управления. См. также панель ленты и лента.

высота

Расстояние, на которое двумерный объект AutoCAD выдавлен выше или ниже уровня, на котором он создан. (ОКОНСВ, СВОЙСТВА, УРОВЕНЬ, ВЫСОТА)

географический маркер

Визуальное представление информации о географическом местоположении.

географический уровень

Относительная высота вдоль заданного направления вверх, определенная для географического маркера.

геометрия чертежа

Все графические объекты - отрезки, круги, дуги, полилинии, размеры и т.д. Неграфическая информация (типы линий, веса линий, текстовые стили, слои и т.д.) не считается геометрией. См. также именованный объект.

горизонтальная лента

Лента, расположенная вдоль верхнего края окна чертежа.

горизонтальная полка

Необязательный отрезок прямой, соединяющий хвостовую точку линии выноски с содержимым выноски.

граница ячейки

Четыре линии сетки, ограничивающие ячейку таблицы. Граница ячейки может ограничивать также набор смежных ячеек.

границы

См. границы чертежа.

границы чертежа

Наименьший прямоугольник, который может вместить в себя все объекты в чертеже, расположенные на экране таким образом, чтобы выглядеть максимально крупными. (ПОКАЗАТЬ)

грань

Треугольный или четырехугольный участок поверхности.

графическая область

См. область рисования.

графическое окно

См. окно AutoCAD и область рисования.

группа листов

Именованный набор листов в подшивке, часто составляемый на основе этапа моделирования. См. также категория видов.

двустронность материала

Положительный и отрицательный лучи перпендикуляра, проходящего через объект; используются в процессе тонирования.

дерево операций

Элемент управления, предназначенный для отображения операций, которые записаны в макросе операции.

дескриптор поиска

Заданное пользователем ключевое слово для поиска команд в обозревателе меню.

десятичные градусы

Обозначение широты и долготы. Например, 35,1234°; 100,5678°.

Долгота всегда указывается после широты.

допуск сплайна

Значение максимально допустимого отклонения B-сплайна от его определяющих точек.

журнал тела

Свойство тела, позволяющее, просматривать и изменять исходные формы тела.

зависимые именованные объекты во внешних ссылках

Именованные объекты (например слои, блоки или типы линий), появившиеся в результате вставки или наложения внешней ссылки. См. также именованный объект и таблица обозначений.

зависимые обозначения

См. зависимые именованные объекты во внешних ссылках.

задняя грань

Противоположная (относительно передней грани) сторона объекта. Задние грани не видны на тонированном изображении модели. См. также передние грани.

зазубрины

Эффект ступенчатости границ объектов на растровом мониторе, не способном гладко отображать диагональные отрезки, дуги и круги. См. также устранение зазубрин.

закрепляемое окно

Элемент интерфейса пользователя, который в области рисования может быть закрепленным, прикрепленным якорем или плавающим. В закрепляемых окнах находятся окна команд, инструментальные палитры, палитра свойств и т.д.

Заливка

Сплошное заполнение цветом области, ограниченной отрезками или кривыми. (ЗАКРАСИТЬ)

замораживание

Подавление отображения объектов, расположенных на указанных слоях. Объекты на замороженных слоях не выводятся на экран, не регенерируются и не вычерчиваются. Замораживание слоев ускоряет регенерацию чертежа. См. также размораживание. (СЛОЙ)

записанное значение

Значение, введенное в процессе записи макроса операции для вспомогательной подсказки к команде.

запрос

Сообщение в командной строке или подсказка, в которой содержится запрос на ввод данных или на действие, например, указание точки.

запрос значения

Элемент, назначенный узлу операции приостановки воспроизведения макроса операции, позволяющей пользователю ввести данные перед возобновлением воспроизведения.

затухание

Ослабление интенсивности света с расстоянием.

захватный блок

Некоторые модификаторы отображаются в видовых экранах в виде коробкообразного приспособления, называемого захватным блоком, которое изначально окружает выбранный объект. Захватный блок представляет собой своеобразный контейнер, передающий изменение объекту, к которому захватный блок прикреплен.

захватываемая точка

При использовании таких способов указания положения точки, как отслеживание или отслеживание привязки объектов, в качестве опорной точки используется промежуточное положение.

зеркальное отражение

Создание объектов, симметричных выбранным относительно заданной оси или плоскости. (ЗЕРКАЛО)

зеркальное отражение

Узкий световой конус, для которого угол падения луча равен углу его отражения.

значение атрибута

Текстовая информация, связанная с именем атрибута. См. также определение атрибута, подсказка атрибута и имя атрибута.

значение по умолчанию

Значение, которое вводится при нажатии клавиши ENTER в строке вспомогательной подсказки. Значение по умолчанию отображается в угловых скобках <>. См. также по умолчанию.

значок ПСК

Значок, указывающий ориентацию осей ПСК. (ЗНАКПСК)

зумирование

Процесс уменьшения или увеличения видимых размеров области рисования на экране. (ЗУМИРОВАТЬ)

изометрический стиль шаговой привязки

Режим рисования, позволяющий выровнять курсор и изображение двух или трех из изометрических осей и отобразить сетку, облегчающую создание 2D изометрических чертежей.

именованная траектория

Сохраненная траектория перемещения объекта, связанная с камерой или целью.

именованный вид

Вид, сохраненный с возможностью последующего восстановления. (ВИД)

именованный диапазон

Инструмент Microsoft Excel, предоставляющий алгоритм присвоения информативного имени отдельной ячейке или диапазону ячеек.

именованный объект

Описывает различные виды неграфической информации (например, стили или описания), хранящейся в чертежах. Именованными объектами являются типы линий, слои, размерные стили, текстовые стили, описания блоков, листы, виды и конфигурации видовых экранов. Именованные объекты записываются в таблицы обозначений.

имя атрибута

Связанная с атрибутом текстовая строка, позволяющая различать атрибуты при их извлечении из базы данных. См. также определение атрибута, подсказка атрибута и значение атрибута.

индекс слоя

Список объектов и слоев, на которых они находятся. Слоевой индекс используется для определения области чертежа, загружаемой при его частичном открытии. Сохранение чертежа со слоевым индексом также улучшает производительность обработки внешних ссылок. Для управления сохранением слоевых и пространственных индексов в чертеже служит системная переменная INDEXCTL.

инструмент быстрого просмотра

Инструмент предварительного просмотра, обеспечивающий переключение между открытыми чертежами и листами чертежа.

инструмент ручки

Значок, используемый в 3D виде для того, чтобы простым способом ограничивать перемещение или вращение выбранного набора объектов до оси или плоскости. (3DПЕРЕНЕСТИ, 3DПОВЕРНУТЬ)

инструменты вариаций блоков

Операции, параметры и наборы параметров на вкладках окна "Палитры вариации блоков". Используется в редакторе блоков для создания динамических блоков.

информация об инструменте

Краткая инструкция, отображаемая поверх окна чертежа и относящаяся к активному инструменту навигации из SteeringWheel.

исходное состояние среды чертежа

состояние чертежа перед воспроизведением макроса операции

исходный вид

Особый вид, сохраненный вместе с чертежом и управляемый с помощью ViewCube. Исходный вид принципиально сходен с начальным видом по умолчанию, отображаемым при открытии чертежа.

кадр

Отдельное статическое изображение в анимационной цепочке. См. также траектория перемещения

камера

Задается текущее положение уровня глаз в 3D модели. Камера хранит координаты XYZ расположения, координаты XYZ цели и поле зрения или фокусное расстояние, определяющее коэффициент увеличения или зумирования.

кандела

Единица измерения интенсивности света в Международной системе единиц (воспринимаемая мощность, излученная источником света в определенном направлении). Обозначение: русское кд, международное cd. Cd/Sr

каркасная модель

Представление объемного объекта с использованием линий и кривых.

карта цветов

Таблица, задающая интенсивность красной, зеленой и синей составляющих (в системе RGB) для каждого из цветов палитры.

карты теней

Карта теней - изображение растрового формата, создаваемое системой тонирования во время предварительного просмотра сцены. Карты теней не отображают цвет, отбрасываемый прозрачными или полупрозрачными объектами. С другой стороны, карты теней могут отображать тени с мягкими краями, что невозможно для теней трассировки луча.

Тени, полученные посредством карты теней, обеспечивают более мягкие края и требуют меньше расчетного времени, чем тени трассировки луча, но являются менее точными. На палитре "Дополнительные параметры тонирования" тени, полученные посредством карты теней, активны при включенном режиме "Карта теней".

категория

См. категория вида.

категория вида

Именованный набор видов в подшивке, часто составляемый на основе общности их функционального назначения. См. также группа.

клавиши быстрого вызова

Это клавиши и их комбинации, которые используются для запуска команд, например, комбинация CTRL+S запускает сохранение файла. Сюда же относятся и функциональные клавиши (F1, F2 и др.). Также известны под названием клавиш ускоренного вызова.

ключевая точка

В описание динамического блока - точка на параметре, запускающая связанную с ней операцию при редактировании во вхождении блока.

кнопка выбора

Кнопка устройства указания, используемая для выбора объектов или точек на экране. Например, на двухкнопочной мыши кнопкой выбора по умолчанию является левая кнопка.

кнопочное меню

Меню для устройств указания, имеющих несколько кнопок. Каждая кнопка на устройстве указания (кроме кнопки выбора) может быть определена в файле адаптации (acad.cui).

командная строка

Текстовая область, предназначенная для ввода с клавиатуры, отображения запросов и сообщений.

компас

Визуальное средство, указывающее направления на север, юг, восток и запад в текущей модели. Компас отображается под инструментом ViewCube.

контекстная вкладка

Вкладка ленты, отображаемая только при наличии объектов конкретного типа, например, штриховки или таблицы, в наборе выбранных объектов. Посредством АПИ можно заменить панели инструментов контекстными вкладками.

контекстное меню

Меню, которое появляется в месте расположения графического курсора при нажатии правой кнопки устройства указания. Набор предлагаемых функций зависит от того, в какой области экрана находится курсор, а также от других факторов (наличие выбранного объекта, выполняемая команда и т.п.).

конфигурация видовых экранов

Именованная совокупность видовых экранов модели, которую можно сохранять и восстанавливать. (ВЭКРАН)

координатные фильтры

Средство, позволяющее извлекать значения координат точек отдельно по каждой из осей X, Y и Z с целью последующего их использования для задания положения новой точки. Также называются точечными фильтрами X,Y,Z.

корпоративный файл адаптации

Файл АПИ, управление которым обычно осуществляет менеджер по САПР. Обычно файл хранится в сетевой папке, и к нему имеют доступ многие пользователи. Пользователи имеют доступ только для чтения для предотвращения изменения данных в файле. Менеджер по САПР создает файл АПИ предприятия путем изменения основного файла АПИ и сохранения его в папку файлов поддержки, задаваемой на вкладке "Файлы" диалогового окна "Настройки".

коэффициент отражения

Увеличивает или уменьшает величину энергии, отражаемой материалом.

коэффициент пропускания

Увеличивает или уменьшает энергию, пропускаемую прозрачным материалом в сцену.

Коэффициент цветового заполнения

Увеличивает или уменьшает насыщенность цвета, отраженного от материала.

кривая Безье

Полиномиальная кривая, задаваемая набором определяющих точек. Представляет уравнение, порядок которого на одну ступень меньше количества учитываемых точек. Кривая Безье - частный случай B-сплайновой кривой. См. также B-сплайновая кривая.

кривая профиля

Объект, который сдвигается, выдавливается или вращается, задавая форму результирующего тела или поверхности. (СДВИГ, ВЫДАВИТЬ, ВРАЩАТЬ)

криволинейная траектория

Определяет направление и длину для поднятия, сдвига или выдавливания кривой профиля при построении тела или поверхности. (СДВИГ, ПОСЕЧЕНИЯМ, ВЫДАВИТЬ)

кромка

Ограничивающая линия грани.

круговой массив

Расположение заданного количества копий объекта вокруг указанной центральной точки. (МАССИВ)

курсор

См. указатель и курсор в форме перекрестия.

лента

Палитра, на которой отображаются кнопки и элементы управления как для рисования и аннотирования в двумерной плоскости, так и для моделирования, просмотра и тонирования в трехмерном пространстве. См. также вкладка ленты, панель ленты и выплывающая панель. (ЛЕНТА)

лимиты

См. лимиты чертежа.

лимиты чертежа

См. лимиты сетки.

лимиты чертежа

Заданные пользователем размеры области чертежа, покрытой сеткой Также носит название лимиты чертежа. (ЛИМИТЫ)

линии кривизны

Линии, предназначенные для повышения наглядности при визуализации поверхностей.

линия выбора

Ломаная линия, захватывающая все объекты, пересеченные ей.

линия отражения

Во вхождении динамического блока это ось, относительно которой выполняется отражение набора операции отражения при редактировании связанного параметра с помощью ручки или палитры свойств.

лист

Вкладка, выбранная из файла чертежа и включенная в подшивку. См. также подшивка.

Логическое группирование данных, подобное наложению друг на друга прозрачных пленок с элементами чертежа.

Логическое группирование данных, подобное наложению друг на друга прозрачных пленок с элементами чертежа. Слои могут отображаться по отдельности или в комбинации. (СЛОЙ)

люкс

Единица измерения освещенности в Международной системе единиц (обозначение: русское лк, международное lx). Lm/m^2

люмен

Единица измерения светового потока в Международной системе единиц. Сокращённое обозначение: русское лм, международное lm. Cd * Sr

макрос операции

Последовательность записанных операций, которую можно воспроизвести на активном чертеже.

маркеры

Временные метки на экране, отображаемые в области рисования при указании точек и выборе объектов. (МАРКЕР)

маскирующий объект

Полигональная область, использующаяся для скрытия находящихся под ней объектов. Скрытие производится текущим цветом фона. Область ограничивается контурами, видимость которых можно включать при редактировании и отключать при печати.

массив

1. Множественное копирование выбранных объектов прямоугольного или полярного (кругового) массива. (МАССИВ) 2. Набор элементов данных, в котором идентификация элементов выполняется по нижнему индексу (ключу) и который организован так, что можно выполнить проверку набора и извлечь данные с определенным ключом.

масштаб аннотаций

Параметр, сохраняемый с пространством модели, видовыми экранами листа и видами модели. При создании аннотативные объекты принимают настройки масштаба текущей аннотации и автоматически отображаются в правильном размере.

меню курсора

См. контекстное меню.

метка

Уникальный буквенно-цифровой идентификатор объекта в базе данных программы.

метод "направление-расстояние"

Метод указания второй точки путем перемещения курсора в нужном направлении и ввода значения расстояния с клавиатуры.

мини-штурвалы

Уменьшенный вариант SteeringWheels. Ни в одном из сегментов штурвала не отображаются метки, а размер сегментов во многих случаях не превышает размера курсора.

Мировая система координат, МСК

Система координат, используемая как основа для построения всех объектов и определения других систем координат. См. также пользовательская система координат (ПСК).

мировые координаты

Координаты, заданные в Мировой системе координат (МСК).

многолистовой DWF-файл

DWF-файл, состоящий из нескольких листов.

многоугольник выбора

Опция выбора объектов с помощью произвольного многоугольника (в набор попадают все объекты, полностью расположенные внутри него). См. также секущая рамка и рамка выбора.

модель

Двух- или трехмерное представление объекта.

модификаторы ребер

Определяют выступание и дрожание ребер при их отображении на раскрашенной модели.

МСК

См. Мировая система координат (МСК).

мультивыноска

Объект-выноска с несколькими линиями выносок, предназначенный для создания аннотаций.

набор значений

В описании динамического блока - диапазон или список значений, указанный для параметров линии, круга, координат XY и вращения.

набор листов

Именованный набор листов в подшивке, который можно с удобством использовать для операций архивирования, формирования комплекта и публикации.

набор объектов

Один или несколько объектов, выбранных для последующей обработки.

В описание динамического блока - геометрия, связанная с операцией.

набор объектов макроса

Набор всех объектов, созданных в процессе воспроизведения макроса операции до обращения к команде, содержащей запрос на набор объектов.

набор параметров

Средство на вкладке "Наборы параметров" окна "Палитры вариации блоков", используемое для добавления одного или нескольких параметров и одной или нескольких операций к описанию динамического блока.

набор параметров листа

Набор параметров устройства печати и других настроек, которые влияют на внешний вид и форматирование печатаемого листа. Эти параметры можно изменять и применять к другим листам.

набор пометок

Группа пометок, содержащаяся в одном DWF-файле.

набор предварительного выбора

Набор объектов, выбранных перед выполнением макроса операции или команды. См. также предварительная выборка.

набор смежных ячеек

Набор выбранных ячеек таблицы, каждая из которых имеет хотя бы одну общую границу с другой ячейкой из этого набора.

набор чертежей

Набор чертежей, использующийся в диалоговом окне "Публикация".

надстройки

Надстройками называются библиотеки многократно используемого содержимого, позволяющие расширить функциональность AutoCAD. Надстройки создаются сторонними разработчиками и доступны на канале "Функциональные технологии и содержимое" (Featured Technologies and Content) Центра коммуникаций.

направление вверх

Вектор, определяющий направление вверх. По умолчанию он ориентирован в положительном направлении оси Z (0,0,+1).

На направление вверх и направление на север всегда наложено ограничение, состоящее в том, что они взаимно перпендикулярны.

направляющие кривые

Отрезки или кривые, пересекающие каждое поперечное сечение полученных методом сечений тела или поверхности, задающие форму посредством добавления к объекту дополнительной каркасной информации. (ПОСЕЧЕНИЯМ)

начало координат

Точка пересечения осей системы координат. Например, точкой начала прямоугольной системы координат является точка пересечения осей X, Y и Z; ее координаты равны (0,0,0).

начальная среда

Значения переменных и параметров для новых чертежей, определенные в шаблоне чертежа по умолчанию, например, в acad.dwg или acadiso.dwg. См. также чертеж шаблона.

начертание линий

См. тип линий.

неассоциативный размер

Размер, не обновляющийся автоматически при изменении объекта с нанесенными размерами. Управляется системной переменной DIMASSOC. См. также ассоциативный размер и расчлененный размер.

неименованный блок

Блок без имени, используемый при нанесении штриховки, размеров и других подобных объектов.

неперекрывающиеся видовые экраны

См. видовые экраны модели.

непрямой рельефный коэффициент

Коэффициент, с помощью которого регулируется текстура выдавливания на участках, освещенных непрямым светом.

нестандартные ручки

Используется для манипулирования геометрией и настраиваемыми свойствами вхождения динамического блока.

нормаль

Нормаль представляет собой вектор, определяющий, в какую сторону направлена грань. Направление нормали указывает переднюю, или внешнюю, сторону грани.

нормаль поверхности

Ориентированный в положительном направлении перпендикуляр к поверхности объекта.

нулевая плоскость

Это плоскость XY в пользовательской системе координат при включённом перспективном проецировании. Нулевая плоскость отображается с помощью изменения цвета между опущенным дальним планом (ближайшим к горизонту) и опущенным ближним планом (ближайшим к зрителю). См. также цвет неба и поднятая нулевая плоскость.

области рисования

Область экрана, в которой отображается и редактируется чертеж. Размер области зависит от размера окна AutoCAD и количества видимых в нем панелей и других элементов интерфейса. См. также окно AutoCAD.

обозначение

Повсеместно используемый в чертежах графический элемент. Обозначения вставляются в чертежи в виде блоков.

обозначения источников света

Графическое представление точечного источника света или прожектора.

обозреватель меню

Элемент пользовательского интерфейса, обеспечивающий доступ ко всем меню. (Нажмите кнопку в левом верхнем углу окна приложения.) В обозревателе меню выполняется поиск команд меню и отображается средство обзора для последних использованных файлов.

оборот (курсора)

Режим автоматического переноса курсора на противоположную сторону области рисования, позволяющий продолжить операцию перетаскивания по достижении края области рисования.

обратный выбор

Добавление ручки выбора во вхождение динамического блока. При нажатии этой ручки отображается раскрывающийся список значений поиска для этого свойства поиска (столбец в таблице выбора). При выборе значения из этого списка соответствующие значения свойства входа присваиваются этому вхождению блока. В зависимости от того, как был определен блок, это обычно приводит к изменению геометрии вхождения блока. (БЛОКТАБЛВЫБ)

общее освещение

Отраженное освещение - это способ, позволяющий создавать такие эффекты, как цветовое рассеивание. Свет, падая на цветной объект модели, отражается от него на смежные объекты, добавляя к ним оттенок цвета исходного объекта.

общее свойство

Свойство, общее для набора объектов. К таким свойствам относятся цвет, слой, тип линий, масштаб типа линий, вес линий, гиперссылка и толщина.

объект

Один или более элементов чертежа (текст, размеры, отрезки, круги, полилинии и т.п.), рассматриваемые как единое целое при создании, обработке и модификации. В прежних версиях программы назывался существующим объектом.

объект-заместитель

Используется вместо сторонних объектов, созданных с помощью приложения ObjectARX, если последнее недоступно. См. также пользовательский объект и адаптер объектов.

объектная привязка

Механизм выбора определенных точек в процессе редактирования чертежа. См. также текущий режим объектной привязки и подавление объектной привязки.

объемные тени

Фотореалистически тонированные области пространства; представляют собой тени, отбрасываемые объектами.

окно AutoCAD

Собирательное название области, занимаемой чертежом, меню, панелями и командной строкой.

операция

Минимальный этап работы (задача или действие пользователя), который может быть записан в рекордере операций.

операция

Определяет способ перемещения или изменения геометрии вхождения динамического блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже. Описание динамического блока обычно содержит по меньшей мере одну операцию, связанную с параметром. (БЛОКРЕАКТ)

определение атрибута

Объект, включаемый в определение блока и предназначенный для хранения буквенно-цифровой информации. Значения атрибутов задаются либо при их описании, либо в момент вставки блока в чертеж. Существует возможность извлечения значений атрибутов из чертежа с выводом в текстовые файлы. (АТОПР)

определение блока

Информация об имени, базовой точке и геометрических объектах, входящих в блок. Хранится в символьной таблице чертежа. См. также блок и вхождение блока.

определяющие точки

Точки, используемые для создания размеров. Программа использует эти точки для изменения вида и значения неассоциативного размера при изменении измеряемого объекта. Эти точки также называются точками описания и хранятся в специальном слое DEFPOINTS.

определяющие точки

Точки, через которые B-сплайн должен проходить либо точно, либо в пределах заданного допуска. См. также точки интерполяции и точки аппроксимации.

оптимизация параметров

Способ оптимизации производительности 3D графики Мастер оптимизации параметров производительности проверяет графическую плату и драйвер 3D дисплея и принимает решение об использовании программной либо аппаратной реализации тех функций, которые поддерживают оба варианта.

ортогональность

Свойство объектов, когда касательные к ним в точке пересечения перпендикулярны друг другу.

освежить

Быстрое обновление или очистка изображения на текущем видовом экране от лишних элементов без внесения изменений в базу данных чертежа. См. также регенерировать. (ОСВЕЖИТЬ)

освещение по умолчанию

Освещение на раскрашенном видовом экране при отключенном солнце и отключенных пользовательских источниках света. Грани освещаются двумя удаленными источниками, которые перемещаются при изменении направления взгляда на модель.

Освещенность

В фотометрии освещенностью называется суммарный световой поток, падающий на единицу поверхности.

основной файл адаптации

Файл АПИ с возможностью записи в него, определяющий большую часть элементов интерфейса пользователя (включая стандартные меню, панели инструментов, клавиши быстрого запуска и т.д.). Файл acad.cui (основной файл АПИ по умолчанию) загружается автоматически при запуске AutoCAD.

основные штурвалы

Обозначение штурвалов SteeringWheels для объектов и для построений

островок

Замкнутый контур, расположенный внутри другого замкнутого контура. Понятие островков связано с процессами штрихования, построения полилиний и областей. (КШТРИХ, КОНТУР)

относительные координаты

Координаты, заданные относительно предыдущих.

отражённое освещение

Функции освещения, например общее освещение и метод чистовых проб, повышающие реалистичность сцены благодаря имитации диффузионного отражения или взаимного отражения света присутствующими объектами.

отступ от полки

Иногда используемый зазор между хвостовой точкой и содержимым выноски.

пакетный файл

Набор команд программы, выполняемых последовательно с помощью команды "ПАКЕТ". Пакетные файлы создаются вне программы с помощью текстового редактора, сохраняются в текстовом формате и записываются во внешний файл с расширением .scr.

палитры вариации блоков

Инструментальные палитры, используемые в редакторе блоков для добавления операций и параметров к описаниям динамических блоков.

панель

Элемент интерфейса, содержащий значки, которые обозначают команды.

панель ленты

Элемент управления второго уровня на ленте. Панели содержат кнопки или другие элементы управления. Несколько панелей образуют вкладку.

панорамирование

Перемещение вида чертежа без изменения экранного увеличения. См. также зумирование. (ПАН)

параллельный размер

Указывает расстояние между двумя точками под любым углом. Размерная линия параллельна линии, которая соединяет определяющие точки на объекте. (РЗМПАРАЛ)

параметр

В описании динамического блока определяет настраиваемые свойства для динамического блока путем указания положений, расстояний и углов для геометрии в блоке.

первый фрагмент таблицы

Фрагмент разорванной таблицы, содержащий набор строк от начала таблицы до первого разрыва таблицы.

передние грани

Грани объекта, нормали к которым направлены от экрана.

перекрестье

Тип графического курсора, состоящий из двух пересекающихся линий.

переменная среды

Переменная, управляющая работой программы.

перемотка

Восстановление предыдущего вида (или траектории движения), созданного с помощью ViewCube, SteeringWheels или другого инструмента навигации.

персонализация

Настройка выполняемого файла во время установки с указанием имени пользователя, компании и другой информации.

плавающая панель

Панель ленты, не прикрепленная к остальной части ленты или рамке приложения.

плавающие видовые экраны

См. видовые экраны.

планарная проекция

Проецирование объектов или изображений на плоскость.

плиния

См. полилиния.

плоская грань

Плоская грань, расположенная в любом месте 3D пространства.

плоская поверхность

Плоская поверхность, расположенная в любом месте 3D пространства. (ПЛОСКПОВ)

плоскость построений

См. рабочая плоскость.

ПОБЛОКУ

Специальное свойство объекта. Объекты, обладающие данным свойством, наследуют цвета и типы линий блоков, в которые они входят. См. также ПОСЛОЮ.

поверхность Кунса

В 3D поверхностном моделировании - бикубическая (в направлениях M и N) поверхность, натянутая на четыре кромки.

поверхность штурвала

Область штурвала, в которой размещены сегменты и другие кнопки.

поворотные стрелки

Искривленные стрелки, расположенные над инструментом ViewCube и позволяющие поворачивать текущий вид по часовой стрелке или против часовой стрелки.

подавление объектной привязки

Механизм временного отключения или изменения текущих режимов объектной привязки для ввода одной точки. См. также объектная привязка и текущий режим объектной привязки.

подложка

Файл DWF или DGN, который используется для обеспечения визуального контекста в файле чертежа. Подложки не могут быть отредактированы и не обеспечивают полного диапазона обозначений внешних ссылок. Подложки не могут быть привязаны к чертежу. См. также внешняя ссылка.

подложка DGN

См. подложка.

подложка DWF

См. подложка.

поднятая нулевая плоскость

Это плоскость XY в пользовательской системе координат при включённом перспективном проецировании и просмотре снизу. Поднятая нулевая плоскость отображается с помощью изменения цвета между поднятым дальним планом (ближайшим к горизонту) и поднятым ближним планом (ближайшим к зрителю). См. также нулевая плоскостьи цвет неба.

подобъект

Любая часть тела: грань, ребро или вершина. А также исходная индивидуальная форма, являющаяся частью составного тела.

подсказка

Небольшое текстовое поле, отображаемое при наведении курсора на объект или элемент интерфейса и содержащее его название или необходимые пояснения.

подсказка атрибута

Текстовая строка, которая выводится при вставке блока, имеющего атрибуты с не определенными заранее значениями. См. также определение атрибута, имя атрибута и значение атрибута.

подшивка

Именованный и структурированный набор листов из различных чертежей. См. также лист. (ПОДШИВКА)

поле

Специальный текстовый объект, предназначенный для отображения данных, которые могут поменяться в ходе редактирования чертежа. При обновлении поля отображается его последнее значение. (ПОЛЕ)

полилиния

Объект, состоящий из одного или нескольких связанных между собой прямолинейных и дуговых сегментов, Также называется плиния. (ПЛИНИЯ, ПОЛРЕД)

политело

Тело сдвига, вычерчиваемое таким же способом, как и полилиния, или на основе существующей линии. По умолчанию у политела всегда прямоугольные контуры. Предусмотрено задание высоты и ширины политела. (ПОЛИТЕЛО)

полка

Часть объекта выноски, служащая указателем на выносимый объект. Полкой может служить отрезок прямой или кривая сплайна.

полупрозрачность

Свойство рассеяния света, проходящего через объект.

пользовательская система координат, ПСК

Определяемая пользователем система координат, устанавливающая ориентацию осей X, Y и Z в трехмерном пространстве. Текущая ПСК задает расположение геометрии чертежа по умолчанию. См. также Мировая система координат (МСК).

полярная привязка

Средство обеспечения точности построений. Позволяет привязываться к точкам, расположенным с определенными интервалами вдоль полярных лучей, которые расходятся из исходной точки. См. также полярное отслеживание.

полярное отслеживание

Средство обеспечения точности построений. Выдает пользователю набор временных линий, проходящих под заданными углами. См. также полярная привязка.

пометка

Отдельные комментарий или исправление, вставленное в DWF-файл с помощью средства просмотра проектов Autodesk.

пометки

Текст, размеры, допуски, символы, примечания и другие типы поясняющих обозначений или объектов, используемые для добавления информации в модель.

поперечные сечения

Как правило, это кривые или отрезки, определяющие контур (форму) тела или поверхности, получаемых с помощью сечений. Поперечные сечения могут быть разомкнутыми или замкнутыми. Тело или поверхность, получаемые с помощью сечений, рисуются в пространстве между поперечными сечениями. (ПОСЕЧЕНИЯМ)

ПОСЛОЮ

Специальное свойство объекта. Объекты, обладающие данным свойством, наследуют цвета и типы линий слоев, на которых они расположены. См. также ПОБЛОКУ.

предварительная выборка

Набор объектов, определенный перед выполнением макроса операции.

предварительный выбор

Режим, позволяющий выбрать объект еще до ввода команды его обработки.

предварительный выбор

Выбор объектов перед обращением к макросу операции или к команде.

представление с учетом масштаба (масштабируемое представление)

Отображение аннотативного объекта в соответствии с масштабами аннотации, поддерживаемыми объектом. Например, если аннотативный объект поддерживает два масштаба аннотаций, он имеет два масштабируемых представления

преломление

Искажение света при прохождении через объект.

прозрачная команда

Команда, которую можно вызывать в ходе выполнения другой команды. Для использования команды в прозрачном режиме перед ее именем следует ввести апостроф.

прозрачность

Величина, определяющая количество света, пропускаемого через объект.

производственные материалы

Материалы, получаемые путем генерации трехмерного образца с использованием двух или более цветов, с последующим наложением на поверхность объекта. Они обеспечивают имитацию мрамора и дерева. Также называются шаблонами материалов.

промежуточный маркер

Это используемый в отслеживании и объектном отслеживании значок "плюс", временно устанавливаемый в захватываемых точках.

пропорция

Отношение ширины экрана монитора к его высоте.

пространственный индекс

Список объектов и их положений в пространстве. Пространственный индекс используется для определения области чертежа, загружаемой при его частичном открытии. Сохранение чертежа с пространственным индексом также улучшает производительность обработки внешних ссылок. Для управления сохранением слоевых и пространственных индексов в чертеже служит системная переменная INDEXCTL.

пространство листа

Одно из двух основных пространств для размещения объектов. В нем производится окончательная компоновка видов для вычерчивания (в отличие от построения моделей, которое выполняется в пространстве модели). Ее построение выполняется на вкладке "Модель". См. также пространство модели и видовой экран. (ЛИСТ)

пространство модели

Одно из двух основных пространств для размещения объектов. Обычно геометрическая модель располагается в трехмерном пространстве модели, а отдельные виды модели и аннотации в пространстве листа. См. также пространство листа. (МОДЕЛЬ)

прямоугольный разрыв

Разрыв таблицы с помощью ручек разрыва таблицы на несколько равных частей заданной пользователем высоты.

псевдоним

Сочетание клавиш для команды. Например, КПявляется псевдонимом для команды КОПИРОВАТЬ, а ПО - псевдонимом для команды ПОКАЗАТЬ. Псевдонимы определяются в файле acad.pgp.

ПСК

См. пользовательская система координат (ПСК).

пустой набор

Набор объектов, не содержащий объектов.

путь поиска библиотек AutoCAD

Программа выполняет поиск файла поддержки в следующем порядке: текущая папка, папка чертежа, папка, указанная в пути поддержки и папка, содержащая исполняемый файл acad.exe.

рабочая плоскость

Альтернативное название для плоскости XY в пользовательской системе координат. См. также подъем и пользовательская система координат (ПСК).

рабочее пространство

Наборы меню, панелей инструментов и закрепляемых окон (таких, как "Палитра свойств", "Центр управления", "Инструментальные палитры"), объединенных и организованных таким образом, что можно работать в настроенной и удобной для рисования среде.

рабочий набор

Группа объектов, выбранных в ходе редактирования вхождений ссылок.

рабочий чертеж

Чертеж, предназначенный для непосредственного применения в производстве или строительстве.

размер шага

Интервал между точками сетки шаговой привязки.

размерная дуга

Дуга (обычно со стрелками или засечками на концах), проходящая между двумя выносными линиями размера, которые образуют измеряемый угол. Размерный текст пишется рядом с размерной дугой, иногда деля ее на две части. См. также угловой размер.

размерная стрелка

Символ (стрелка, засечка, точка и т.п.), наносимый на концах размерной линии для отметки начала и конца размера.

размерная цепочка

Вид линейного размера, использующий начало второй выносной линии выбранного размера в качестве начала своей первой выносной линии. При сложении сегментов размерной цепи получается полный размер. (РЗМПРОДОЛЖ)

размерные переменные

Набор числовых величин, текстовых строк и переключателей, управляющих способом нанесения размеров. (РЗМСТИЛЬ)

размерный стиль

Именованная группа размерных параметров, определяющая вид размера и облегчающая установку размерных переменных. (РЗМСТИЛЬ)

размерный текст

Текстовая строка с результатом измерения объекта.

разметка листа

Среда, в которой создаются и компонуются видовые экраны пространства листа, предназначенные для печати. Один чертеж может иметь несколько вариантов разметок.

разметочные видовые экраны

Объекты, создаваемые в пространстве листа для отображения различных видов чертежа. См. также пространство листа. (ВЭКРАН)

размораживание

Включение отображения ранее замороженных слоев. См. также заморозить. (СЛОЙ)

размывание

Способ получения дополнительных оттенков путем составления пространственных комбинаций из точек, окрашенных в разные цвета.

разрыв таблицы

Точка в нижней части строки таблицы, в которой от таблицы будет отделен вспомогательный фрагмент.

рамка допуска формы и расположения

Задает отклонения геометрических свойств и характеристик. Рамка допуска формы и расположения состоит по меньшей мере из двух частей. В первой находится графическое обозначение вида допуска (формы, расположения и т. п.), а во второй численное значение допуска.

рамка растягивания

В описании динамического блока, содержащем операцию растягивания или операцию полярного растягивания, определяет способ редактирования объектов внутри рамки или пересекаемых рамкой во вхождении блока.

рассеянный свет

Свет, который освещает все поверхности модели с равной интенсивностью. Не имеет ни источника, ни направления; интенсивность рассеянного света не изменяется при любых перемещениях.

растровый формат

Цифровое представление изображения, в котором каждому пикселу соответствует определенное количество бит. Цвет пиксела обычно передается как сумма уровней цветовых составляющих (красного, зеленого и синего).

расчленение

Операция, разбивающая сложный объект (блок, размер, тело или полилинию) на более простые. Определение блока при этом не изменяется. Вхождение блока заменяется на составляющие его объекты. См. также блок, определение блока и вхождение блока. (РАСЧЛЕНИТЬ)

расчлененный размер

Размер, сформированный из отдельных объектов, которые не имеют связи ни друг с другом, ни с объектом с нанесенными размерами. Управляется системной переменной DIMASSOC. См. также ассоциативный размер, неассоциативный размер и расчленить. (РАСЧЛЕНИТЬ)

расширенные подсказки

Дополнительная информация, отображаемая при наведении курсора мыши на подсказку в течение определенного периода времени.

регенерация

Процесс обновления изображения на экране монитора путем пересчета координат в базе данных чертежа. См. также обновление. (РЕГЕН)

режим

Действующие установки программы или ее текущее состояние.

режим "Орто"

Режим работы, допускающий ввод с помощью устройства указания только горизонтальных и вертикальных (по отношению к ПСК и к повороту сетки шаговой привязки) смещений. См. также угол привязки и пользовательская система координат (ПСК).

режим видимости

Отображает или не отображает геометрию (выделена серым цветом), невидимую в состоянии видимости. (BVMODE)

режим цвета грани

Настройка визуального стиля, определяющая способ отображения цвета на грани.

режимы редактирования с помощью ручек

Средства редактирования, активизируемые при включенных ручках: растягивание, перемещение, поворот, масштабирование и зеркальное отображение.

резиновая линия

Временная линия, динамически растягивающаяся и сжимающаяся при перемещении курсора. Один конец линии прикреплен к фиксированной точке на чертеже, а другой к перекрестью курсора.

ручки

Небольшие квадратики и треугольники, отображаемые на выбранных объектах. После выбора ручки объект можно редактировать путем перетаскивания, не прибегая к вводу команд редактирования.

светильник

Совокупность лампы или ламп и осветительной арматуры. В качестве арматуры может использоваться простой цилиндр или сложные конструкции с фиксированными соединениями.

световой поток

Воспринимаемая мощность излучения на единицу телесного угла. Суммарный световой поток лампы равен воспринимаемой мощности излучения во всех направлениях.

свойство входа

В описании динамического блока - свойство параметров, кроме таких, как поиск, выравнивание и параметр базовой точки, которые можно добавить в таблицу выбора в виде столбца. Когда значения параметров вхождения динамического блока соответствуют ряду значений свойств входа, значения соответствующего свойства поиска присваиваются этому вхождению блока. (БЛОКТАБЛВЫБ)

свойство выбора

В описании динамического блока - параметр выбора, добавляемый в таблицу выбора. Метка параметра выбора используется в качестве имени свойства. Когда значения параметров вхождения динамического блока соответствуют ряду значений свойств входа, значения соответствующего свойства поиска присваиваются этому вхождению блока. (БЛОКТАБЛВЫБ)

связь

Один из методов использования данных исходного документа в целевом документе. При этом любые изменения объекта в исходном документе влекут за собой изменения этого объекта во всех других документах, использующих данный объект посредством связи. См. также внедрение.

связь с данными

Связь между таблицей и внешним источником данных.

сглаженное тонирование

Сглаживание зазубрин и плавные переходы цветов на многогранных тонированных поверхностях.

сглаживание

Процесс уменьшения неровности границ объектов путем подбора оттенка пикселов, смежных с пикселами, определяющими линию границы объекта. См. также зазубрины

сегмент штурвала

Участок поверхности штурвала, выделенный для конкретного инструмента двумерной или трехмерной навигации.

секущие плоскости

Границы, определяющие или подрезающие поле вида.

сетка

Область, покрытая точками или отрезками с равными интервалами между ними, облегчающая построение чертежа. Шаг сетки можно регулировать. Точки сетки никогда не распечатываются. См. также лимиты сетки. (СЕТКА)

сетка шаговой привязки

Невидимая сетка, к точкам которой привязывается перемещение курсора при включенном режиме "Шаг". Шаг привязки может быть не равен интервалу видимой на экране сетки, контролируемому независимо командой СЕТКА. (ШАГ)

система координат LL84

Обычная система координат на основе широты и долготы, в которой широта и долгота принимают значения от -90 до 90 градусов.

Долгота равна 0 градусов на начальном меридиане (Гринвич, Англия) и принимает значения от -180 до 180.

Широта равна 0 градусов на экваторе и принимает значения от -90 до 90.

системная переменная

Имя, с которым связан какой-либо режим, размер или ограничение. Системные переменные, доступные только для чтения (например, DWGNAME), не могут непосредственно изменяться пользователем.

следящее меню

Набор кнопок, перемещаемый вместе с курсором в области рисования.

слежение

Способ задания положения некоторой точки относительно других точек чертежа.

слияние

В таблицах - группа смежных ячеек, объединенных в одну ячейку.

снимок

Сохраненный вид, который можно восстановить по имени или с помощью пользовательского интерфейса ShowMotion. Снимок может содержать статический эскиз сохраненного вида или данные о движении камеры, которое можно воспроизвести в форме мультипликации. См. также именованный вид.

сопоставление слоев

Отображение имеющихся слоев в слои, заданные в стандарте оформления. Стандарты регулируют именование слоев и их свойства. Также называется соответствием слоев.

составное тело

Тело, созданное на основе двух или более отдельных тел. (ОБЪЕДИНЕНИЕ, ВЫЧЕСТЬ, ПЕРЕСЕЧЕНИЕ)

состояние видимости

В динамическом блоке - настраиваемое свойство, позволяющее отображать во вхождении блока только выбранную геометрию. (БЛОКСОСТВИД)

состояние чертежа

Набор заданных значений, определяющий функциональные свойства чертежа и/или среды чертежа в заданный период времени, например, во время записи макроса операции или перед воспроизведением макроса операции.

сохранение в исходный чертеж

Обновление объектов исходного чертежа внешней ссылки или определения блока после того, как были отредактированы их вхождения.

спираль

Открытая 2D или 3D спираль. (СПИРАЛЬ)

ссылка

Определение, известное как внешняя ссылка или вхождение блока. Применяется и хранится в самом чертеже. См. также блок (БЛОК) и внешняя ссылка (ССЫЛКА). (ССЫЛКА)

стиль грани

Настройка визуального стиля, определяющая раскрашивание грани.

стиль печати

Свойство объекта, задающее его вид при вычерчивании (цвет, размывание, оттенки серого, присвоения перьев, прозрачность, тип и вес линии, торцы и соединения, способ заливки). Прикладывается только в процессе печати.

стиль таблицы

Стиль форматирования и структуры таблицы. В стиль таблицы входит как минимум три стиля ячеек.

стиль ячеек

Стиль форматирования ячеек таблицы.

столбец

Набор ячеек таблицы, прилегающих друг по высоте таблицы. Ширина одного столбца соответствует одной ячейке.

сторонний объект

Тип объектов, созданных в приложениях ObjectARX и обладающих обычно более специализированными функциями по сравнению со стандартными объектами. К сторонним объектам относятся параметрические тела (Autodesk Mechanical Desktop), интерактивные (с интеллектуальными функциями) обозначения дверей (AutoCAD Architecture), объекты-многоугольники (AutoCAD Map 3D) и объекты - ассоциативные размеры (AutoCAD и AutoCAD LT). См. также объект-заместитель и адаптер объектов.

строка

Набор ячеек таблицы, прилегающих друг по ширине таблицы. Высота одной строки соответствует одной ячейке.

таблица

Прямоугольный массив ячеек, содержащих текстовые объекты или блоки. В архитектуре и строительстве таблицы часто относятся к спецификациям и содержат информацию о материалах, необходимых для возведения проектируемого здания. В обрабатывающей промышленности, таблицы часто используются как перечни материалов. (ТАБЛИЦА)

таблица выбора

Определяет и указывает значения свойств для динамического блока. Указывает значения свойств для вхождения динамического блока в зависимости от манипулирования блоком в чертеже. (БЛОКТАБЛВЫБ)

таблица обозначений

См. таблица описаний и таблица блоков.

таблица определений

Неграфическая часть файла чертежа, в которой хранятся описания блоков.

таблица определений блоков

Неграфическая часть файла чертежа, в которой хранятся описания блоков. См. также именованный объект.

таблица стилей печати

Набор стилей печати. Стили печати заносятся в таблицу; к объектам они применяются только после назначения таблицы листу или видовому экрану.

текстовый стиль

Именованный, сохраненный набор установок, определяющий вид текстовых символов, например, растянутых, сжатых, наклоненных, зеркально отображаемых или расположенных вертикально в столбце.

текстура

Проецирование изображения образца поверхности определенного материала на поверхность заданного объекта.

текстура выдавливания

Текстура, значения яркости в точках которой преобразуются в кажущуюся высоту поверхности объекта.

текстура отражения

Используется для создания эффекта отражения сцены от поверхности освещенного материала.

текстура прозрачности

Наложение прозрачных и непрозрачных областей на объекты.

текстура среды

Растровое изображение, используемое для имитации отражений в материалах, обладающих отражательными свойствами. Текстура среды, "обернутая" вокруг сцены и отражающего объекта, проявится в отражающих частях материала в виде соответствующей текстуры.

текущий режим объектной привязки

Постоянно действующий режим, который можно использовать для указания нескольких точек. См. также объектная привязка и подавление объектной привязки. (ПРИВЯЗКА)

текущий чертеж

Файл чертежа, открытый в программе, на который направлены все команды и операции, задаваемые пользователем.

тело

Объект, представляющий общий объём объекта, например, параллепипед.

тело/поверхность сдвига

Тело или поверхность, очертания которых получены в результате сдвига заданного контура (объект сдвига) вдоль заданной траектории. (СДВИГ)

тело/поверхность, построенные методом сечений

Тело или поверхность, вычерченные с помощью набора из двух или нескольких кривых поперечных сечений. Поперечные сечения определяют контур (форму) результирующего тела или поверхности. Поперечные сечения (как правило, кривые или отрезки) могут быть разомкнутыми или замкнутыми. (ПОСЕЧЕНИЯМ)

тени трассировки луча

Способ, используемый системой тонирования для получения теней. Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Тени появляются в тех местах, где распространению лучей препятствуют объекты. Тени трассировки лучей имеют резкие границы.

Тени трассировки луча активны, если на палитре "Дополнительные параметры тонирования" отключена "Карта теней".

тип линий

Определяет внешний вид отрезка или кривой. Именно благодаря этому свойству, например, непрерывная линия отличается от прерывистой. Также называется начертание линий . (ТИПЛИН)

тонирование по Гучу

Тип раскрашивания, при котором в большей степени используется переход от холодных к теплым тонам, чем переход от темного к светлому.

точка

Точка в трехмерной системе координат, заданная с помощью значений X, Y и Z. 2. Объект, состоящий из одной точки в системе координат. (ТОЧКА)

точка зрения

Точка в трехмерном пространстве, из которой рассматривается модель. См. также вид и точка зрения. (3DОРБИТА, ДВИД, ТЗРЕНИЯ)

точки аппроксимации

Точки, задающие вид B-сплайна, который может отклоняться от них на величину, заданную допуском аппроксимации. См. также определяющие точки и точки интерполяции.

точки интерполяции

Точки, задающие вид B-сплайна и принадлежащие ему. См. также точки аппроксимации и определяющие точки.

траектория перемещения

Определяет траекторию или цель камеры. Траектория может представлять собой отрезок, дугу, эллиптическую дугу, окружность, полилинию, трехмерную полилинию или сплайн.

трассировка лучей

Система тонирования генерирует отражения и преломления. Функция "Отслеживание лучей" отслеживает путь лучей, исходящих из источника света. Возникающие при этом отражения и преломления лучей точны с физической точки зрения.

Трассировка лучей включается на палитре "Дополнительные параметры тонирования".

трехмерный (3D) вид

Любой вид, в котором значок ПСК отображается в тонированном цветном представлении: текущий визуальный стиль отличается от "2D каркас".

тройка осей

Значок с изображением осей X, Y и Z, используемый для задания точки зрения (направления взгляда) в трехмерном чертеже. (ТЗРЕНИЯ)

уведомление о неактивном штурвале

Интерактивная графическая подсказка, отображаемая при запуске инструмента SteeringWheel, если он закреплен.

угловой размер

Размер для углов и дуговых сегментов, включающий размерную дугу, текст, выносные линии и выноски. (РЗМУГЛОВОЙ)

угловые единицы

Единицы измерения углов. Углы могут измеряться в десятичных градусах, градусах-минутах-секундах, градах и радианах.

угол поворота сетки привязки

Угол, на который повернута сетка привязки.

узел

Режим привязки к объектам-точкам, определяющим точкам размеров и точкам вставки размерного текста.

узел выбора

Особый тип узла в дереве операций, предназначенный для выбора объектов.

узел значений

Узел операций особого типа, предназначенный для обработки запросов на ввод данных пользователем и хранения значения, которое введено в процессе записи макроса операции.

указатель

Курсор на экране монитора. Его текущая позиция определяет положение наносимой текстовой и графической информации. См. также курсоры в форме перекрестия.

управляющая точка

См. управляющая рамка.

управляющий контур

Набор управляющих точек, соединенных линейными сегментами. Используется как механизм управления формой B-сплайна. Вывод управляющего контура обеспечивает более наглядное представление для визуального контроля за отклонением сплайна от его определяющих точек. Для вывода управляющего контура на экран должна быть включена переменная SPLFRAME.

уровень

Координата Z (над или под плоскостью XY текущей ПСК), назначаемая по умолчанию при вводе координат и оцифровке точек. (УРОВЕНЬ)

файл адаптации (АПИ)

Файл XML, в котором хранятся данные об адаптации. Файл адаптации можно изменить в диалоговом окне "Адаптация интерфейса пользователя". Файлы АПИ заменяют файлы MNU, MNS и MNC, которые использовались для определения параметров меню в более ранних версиях.

файл вывода атрибутов

Текстовый файл, в который выводятся значения атрибутов. Содержание и формат данного файла определяются с помощью файла шаблона вывода атрибутов. См. также файл шаблона вывода атрибутов.

файл макроса операции

Файл, в котором хранятся все операции, содержащиеся в макросе операции. Имена файлов макросов операции имеют расширение .actm

файл слайда

Файл, содержащий растровое изображение или снимок объектов, отображаемых в области рисования. Файлы слайдов имеют расширение .sld. (ДСЛАЙД, СЛАЙД)

файл частичной адаптации

Любой файл АПИ, который не определен как основной файл АПИ. Частичные файлы АПИ можно загружать и выгружать по мере необходимости во время сеанса работы с чертежом.

файл шаблона вывода атрибутов

Текстовый файл, в котором определяется, какие атрибуты заносятся в файл вывода и в каком формате. См. также файл вывода атрибутов.

фильтры

См. фильтры координат.

фильтры точек

См. фильтры координат.

фокусное расстояние

Определяет увеличительные свойства объектива камеры. Чем больше фокусное расстояние объектива, тем ближе поле зрения.

Формат файлов шаблонов для Интернет-публикаций чертежей.

Формат файлов шаблонов для Интернет-публикаций чертежей.

фотометрическое освещение

Фотометрическим называется физически правильное освещение. При физически правильном освещении затухание происходит пропорционально квадрату расстояния от источника. Фотометрия - это наука об измерении видимого света по воспринимаемой яркости.

фотонная схема

Способ создания эффектов отражённого освещения для общего освещения, используемый системой тонирования. При расчёте отражённого освещения устройство тонирования отслеживает фотоны, испускаемые источником света. Фотон проходит через модель, отражаясь или передаваясь от объекта, пока не достигнет диффузной поверхности. После этого параметры фотона сохраняются в фотонной схеме.

фотореалистичное тонирование

Тонирование с получением изображений фотографического качества.

фут-кандела

Американская единица измерения освещенности (обозначение: fc). Лм/фут^2.

фут-кандела

Американская единица измерения освещенности (обозначение: fc). Lm/ft^2

хвостовая точка выноски

Часть линии выноски, соединенная с аннотацией.

цвет диффузного отражения

Основной цвет объекта.

цвет неба

Это цвет фона в области чертежа при включённом перспективном проецировании. Он отображается изменением цвета между дальним (ближайшим к горизонту) и ближним (ближайшим к зрителю) планами неба. См. также нулевая плоскость

цвет отражения

Цвет блика на освещенном материале. Также называется цвет блика

цвет рассеянного света

Цвет, полученный действием только рассеянного света. Рассеиваемый цвет - это цвет тех частей объекта, которые находятся в тени. Это цвет, отражаемый объектом при освещении рассеяным, а не прямым светом.

цель камеры

Определяет рассматриваемую точку: координаты центра вида.

Центр подписки

Средство, доступное с помощью меню "Справка", обеспечивает подписчикам доступ к последним версиям программных продуктов Autodesk, программам-расширениям, технической поддержке через Интернет и электронному обучению (e-Learning).

Цепочка операций

В описании динамического блока свойство параметров точки, линии, круга, координат XY и вращения. Если для параметра установлено значение "Да", изменение операции, содержащей параметр из набора объектов для операции, запускает все операции, связанные с этим параметром. Это аналогично редактированию параметра во вхождении блока с помощью ручек или настраиваемых свойств.

циклическая внешняя ссылка

Внешняя ссылка, которая явно или неявно ссылается сама на себя. Ссылки, создающие цикличность, игнорируются.

чертеж по умолчанию

См. начальная среда.

чистовые пробы

"Чистовые пробы" являются необязательным дополнительным шагом при вычислении общего освещения. Применение фотонной схемы для вычисления общего освещения может приводить к возникновению дефектов тонирования, таких как темные углы и низкочастотные колебания освещения. Подобные дефекты можно частично или полностью подавить, включив метод чистовых проб, который увеличивает число лучей, используемых при обсчитывании эффекта общего освещения.

Метод чистовых проб значительно увеличивает продолжительность процесса тонирования. Он наиболее удобен для сцен с общим диффузным освещением и меньше подходит для сцен с яркими точкам отражённого освещения.

Режим чистовых проб включается на палитре "Дополнительные параметры тонирования". См. также общее освещение

чувствительность выбора

Возможность определения опорной точки вида на основе центра ограничивающей рамки, определяемой текущим набором выбранных объектов. Эта функция поддерживается инструментом SteeringWheels.

шаблон чертежа

Файл чертежа с заранее заданными значениями для новых чертежей, например, acad.dwt и acadiso.dwt; однако шаблоном может служить любой чертеж. См. также исходная среда.

Шаговая привязка

Привязка перемещения графического курсора к точкам воображаемой прямоугольной сетки. При включенном режиме "Шаг" курсор и все введенные координаты привязываются к ближайшей точке такой сетки. Размер шага перемещения курсора определяется заданным интервалом сетки шаговой привязки. См. также объектная привязка. (ШАГ)

шероховатость

Значение, используемое при имитации отражения света от грани. При большом значении шероховатости объект выглядит неблестящим или шероховатым (наждачная бумага/ковер) При малом значении шероховатости объект получается очень блестящим (металлы, некоторые пластмассы)

шрифт

Набор символов - букв, цифр, знаков препинания и специальных символов, характеризующийся пропорцией и внешним видом.

штурвал

Обозначение одного из отдельных элементов пользовательского интерфейса, составляющих инструмент SteeringWheels. См. также Штурвалы.

Штурвалы

Набор инструментов, содержащий инструменты двумерной и трехмерной навигации.

штурвалы

Обозначение одного или нескольких отдельных элементов пользовательского интерфейса, составляющих инструмент SteeringWheels. См. также Штурвалы.

экземпляр блока

См. вхождение блока.

электронный набор чертежей

Электронный аналог набора чертежей, распечатанных на бумаге. Электронный набор чертежей можно получить, опубликовав чертежи в файле формата DWF.

элемент интерфейса

Объекты интерфейса пользователя, такие как панель инструментов, контекстное меню, сочетание клавиш, закрепляемое окно, могут быть настраиваемыми.

элементарное тело

Базовая форма тела. К элементарным телам относятся: параллепипед, клин, конус, цилиндр, сфера, тор и пирамида.

эскиз быстрого просмотра

Эскиз чертежа, листа или пространства модели, отображаемый с помощью инструментов быстрого просмотра.

яркость

Яркостью называется величина интенсивности света, отраженного от поверхности. Это мера воспринимаемой яркости или затемности поверхности.

ячейка

Наименьшая доступная область таблицы.


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!