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Chapter 5
Working with Text

Text regions function as commentary in a Mathcad worksheet, 
explaining and annotating your computations and plots. 

Mathcad supports many of the text editing and formatting features 
word processors. Mathcad text can include any combination of fon
sizes, and text styles. Text automatically wraps, breaking lines accor
to margins you specify. You can specify the alignment, indentation, 
other properties of paragraphs in your text regions. You can define
apply text styles to maintain consistency in the appearance of your

This chapter includes the following sections:

Inserting text
Creating and resizing text regions. Selecting and moving text and text reg

Text and paragraph properties
Manipulating text that is already in a region: changing text properties suc
font and font size, and changing paragraph properties such as alignment and 
indentation.

Text styles
Working with text styles to streamline text formatting. Creating and apply
new text styles.

Equations in text
Embedding equations into text regions.

Text tools
Finding and replacing characters in text and math regions. Finding and 
correcting spelling errors in text.
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Inserting text 

This section describes how to create text regions in Mathcad. Text regions are u
for inserting any kind of text into your worksheets and templates: comments arou
the equations and plots in your worksheet, blocks of explanatory text, backgroun
information, instructions for the use of the worksheet, and so on. Mathcad ignores
when it performs calculations, but you can insert working math equations into tex
regions as described in “Equations in text” on page 81. 

Creating a text region 

To create a text region, follow these steps. First, click in a blank space in your work
to position the crosshair where you want the text region to begin. Then:

■ Choose Text Region from the Insert 
menu, or press the double-quote (" ) key. 
Mathcad begins a text region. The 
crosshair changes into an insertion point 
and a text box appears.

■ Now begin typing some text. Mathcad 
displays the text and surrounds it with a 
text box. As you type, the insertion point 
moves and the text box grows.

■ When you finish typing the text, click 
outside the text region. The text box dis-
appears.

Note You cannot leave a text region simply by pressing [↵]. You must leave the text region by 
clicking outside the region, by pressing [Ctrl ][Shift ][↵], or by repeatedly pressing one of 
the arrow keys until the cursor leaves the region.

To insert text into an existing text region:

■ Click anywhere in a text region. A text box now surrounds your text. Anything y
type gets inserted at the insertion point. 

To delete text from an existing text region, click in the text region and:

■ Press [BkSp] to delete the character to the left of the insertion point, or

■ Press [Delete ] to delete the character to the right of the insertion point.

To overtype text:

■ Place the insertion point to the left of the first character you want to overtype.
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■ Press [Insert ] to begin typing in overtype mode. To return to the default insert 
mode, press [Insert ] again. 

You can also overtype text by first selecting it (see below). Whatever you type n
replaces your selection.

Tip To break a line or start a new line in a text region, press [↵]. Mathcad inserts a hard page break
and moves the insertion point down to the next line. When you rewrap the text by changin
width of the text region, Mathcad maintains a line break at this spot in the text. To delete a
return, click at the beginning of the next line in the text region and press [BkSp]. 

Moving the insertion point

In general, you move the insertion point around text regions by clicking with the mo
wherever you want to put the insertion point. However, you can also use the arrow
to move the insertion point. 

The arrow keys move the insertion point character by character or line by line wi
text. Pressing [Ctrl ] and an arrow key moves the insertion point word by word or li
by line. These and other ways of moving the insertion point are summarized belo

   Key Action

[→] Move right one character.

[←] Move left one character.

[↑] Move up to the previous line.

[↓] Move down to the next line.

[Ctrl ][→] Move to the end of the current word. If the insertion point is already the
move to the end of the next word.

[Ctrl ][←] Move to the beginning of the current word. If the insertion point is alrea
there, move to the beginning of the previous word.

[Ctrl ][↑] Move to the beginning of the current line. If the insertion point is alrea
there, move to the beginning of the previous line.

[Ctrl ][↓] Move to the end of the current line. If the insertion point is already the
move to the end of the next line.

[Home] Move to the beginning of the current line.

[End] Move to the end of the current line.

Selecting text 

There are several ways to select text within a text region:
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■ Click in the text region so that the text box appears. Drag across the text hold
the mouse button down. Mathcad highlights the selected text, including any f
lines between the first and last characters you selected.

■ Click in the text and press [Shift ] and an arrow key. Mathcad highlights the tex
in the direction of the arrow key used.

■ Click in the text and press [Ctrl ][Shift ] and an arrow key. If a left or right arrow
is used, Mathcad highlights from the insertion point to the beginning of the cur
or next word. If an up or down arrow is used, Mathcad highlights text from the
insertion point to the beginning or end of a line.

■ Select just one word of text by double-clicking it.

■ Select an entire paragraph of text within a text region by triple-clicking it.

■ Select an entire text region by clicking with the right mouse button on the reg
and choosing Select All from the pop-up menu.

Once text is selected, you can delete it, copy it, check the spelling, or change its
size, style, or color.

Tip Once you’ve cut or copied text to the Clipboard, you can paste it back into any text region o
an empty space to create a new text region.

Greek letters in text

To type a Greek letter in a text region, use one of these two methods:

■ Click on the appropriate letter on the Greek toolbar. To see this toolbar, click 
on the Math toolbar, or choose Toolbars⇒Greek from the View menu.

■ Type the Roman equivalent of the Greek symbol and then press [Ctrl ]G. For 
example, to enter φ, press f [Ctrl ]G. See “Greek letters” on page 349 in the 
Appendices for a table of Greek letters and their Roman equivalents.

Tip As discussed in the section “Inserting math” in Chapter 4, typing [Ctrl ]G after a letter in a math 
region also converts it to its Greek equivalent. In addition, [Ctrl ]G converts a nonalphabetic 
character to its Greek symbol equivalent. For example, typing [Shift ]2[Ctrl ]G in a text 
region produces the “≅” character.

To change a text selection into its Greek equivalent, select the text and then:

■ Choose Text from the Format  menu.

■ From the Font list select the Symbol font.

You can also change the font of a text selection by using the Formatting toolbar.
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Changing the width of a text region

When you start typing in a text region, the region grows as you type, wrapping o
when you reach the right margin or page boundary. (The location of the right ma
is determined by the settings in the Page Setup dialog box, which you can modif
choosing Page Setup from the File menu.) Press [↵] whenever you want to start a new
line. Often you would like to set a width for your whole text region and have lines w
to stay within that width as you type. To do this:

■ Type normally until the first line reaches the width you want.

■ Type a space and press [Ctrl ][↵]. 

All other lines break to stay within this width. When you add to or edit the text, Math
rewraps the text according to the width set by the line at the end of which you pre
[Ctrl ][ ↵]. 

To change the width of an existing text region, do the following:

■ Drag-select the text region by clicking in the worksheet outside it and dragging
mouse pointer across the region and releasing it, or click anywhere in the text re
A selection box encloses the text region.

■ Move the pointer to the middle of the right edge of the text region until it hove
over the “handle” on the selection rectangle. The pointer changes to a double-he
arrow. You can now change the size of the text region the same way you cha
the size of any window—by dragging the mouse.

Tip You can specify that a text region occupies the full page width by clicking on the region a
choosing Properties from the Format menu. Click the “Text” tab and check “Occupy Page 
Width.” As you enter more lines of text into a full-width text region, any regions that are be
are automatically pushed down in the worksheet.
 

Selecting and moving text regions

To select and move a single text region or group of regions, follow the same step
you would use with math regions:

■ Click on an empty spot in the worksheet, hold the mouse button down, and dra
selection rectangle across the region or regions you want to select. When you re
the mouse button, dashed outlines show which regions are selected. If you h
selected a single region, a selection box appears around that region.

■ Now move the mouse pointer to the edge of a selected region so that its appea
changes to a hand.

■ Hold down the mouse button and drag the region to the desired spot. If you’v
selected more than one region, the selected regions move as a group.

■ Release the mouse button.
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You can also cut, delete, paste, and copy text regions as you would any other re
Select the regions, and then choose Cut, Delete, Paste, or Copy from the Edit  menu, 
or click the corresponding buttons on the Standard toolbar.

Text and paragraph properties 

This section describes changing various font properties and changing the alignm
and indenting of paragraphs within a text region.

Changing text properties 

To change the font, size, style, po-
sition, or color of a portion of the 
text within a text region, first se-
lect the text. (See “Selecting text” 
on page 73 for techniques of se-
lecting text within a text region.) 
Then choose Text from the For-
mat menu to access the Text For-
mat dialog box. The Text Format 
dialog box also appears when you 
click with the right mouse button 
on selected text and choose Font 
from the pop-up menu.

Many of the options of the Text Format dialog box are also available via the butto
and drop-down lists on the Formatting toolbar:

When you first insert text, its properties are determined by the worksheet or tem
defaults for the style called “Normal.” See “Text styles” on page 78 to find out ab
applying and modifying existing text styles and creating new ones for governing 
default appearance of entire text paragraphs or regions. Any properties that you c
for selected text as described here override the properties associated with the style fo
that text region.

Tip If you simply place the insertion point in text and then change the text properties through 
Text Format dialog box or the Formatting toolbar, any text you now type at that insertion p
will have the new properties you selected.

You can change the following properties of selected text:
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Font

To change the font of the selected text, scroll through the Font list in the Text Fo
dialog box or Formatting toolbar and choose an available font. 

Font Style

To change the style of the selected text, scroll through the Font Style list in the T
Format dialog box or click on the style buttons on the Formatting toolbar. 

Font Size

To change the size of the selected text, scroll through the Size list in the Text Fo
dialog box or Formatting toolbar. Font sizes are in points. Note that some fonts a
available in many sizes and others aren’t. Remember that if you choose a bigger
the text region you’re in may grow and overlap nearby regions. Choose Separate 
Regions from the Format menu if necessary.

Tip You can specify that a text region automatically pushes regions down as it grows by clickin
the region and choosing Properties from the Format menu. Click the “Text” tab and select 
“Push Regions Down As You Type.” 

Effects

To make selected text take on effects such as superscripts and subscripts, click 
appropriate Effects options in the Text Format dialog box.

Tip As a shortcut for creating subscripts and superscripts in text, use the Subscript and Superscript 
commands on the pop-up menu that appears when you click with the right mouse button 
selected text.

Color

To change the color of the selected text, scroll through the color list in the Text Fo
dialog box. 

Changing paragraph properties

A paragraph in a text region is any stream of characters followed by a hard return, w
is created when you type [ ↵] . You can assign distinct properties to each paragraph
a text region, including alignment, indenting for either the first or all lines in the 
paragraph, and bullets or sequential numbering to begin the paragraph.

When you first create a text region, its paragraph properties are determined by th
worksheet or template defaults for the style called “Normal.” See “Text styles” on p
78 to find out about applying and modifying existing text styles and creating new o
for governing the default appearance of entire text regions or paragraphs. Any p
Text and paragraph properties 77



 

” and 
e 

n 
ive 

r the 
one 

ns. 
heets. 
gion, 
erties 

Mathcad Users Guide.book  Page 78  Sunday, August 9, 1998  2:59 PM
graph properties that you change as described here override the paragraph properties
associated with the style for that text region.

You can change the properties for a paragraph within a text region by doing the 
following: 

■ Select the paragraph by clicking in it 
to place the insertion point, by drag-
selecting it, or by triple-clicking it.

■ Choose Paragraph from the Format 
menu, or click with the right mouse 
button and choose Paragraph from 
the pop-up menu. Mathcad displays 
the Paragraph Format dialog box.

■ Change the appropriate properties in the dialog box and click “OK.” 

You can change the following paragraph properties:

Indent

To indent every line in the paragraph the same amount, enter numbers in the “Left
“Right” text boxes. To indent the first line of the paragraph a different amount than th
rest of the lines, as for a conventional or hanging indent, select “First Line” or 
“Hanging” from the “Special” drop-down list and enter a value below.

Bullets

To begin the paragraph with a bullet, select “Bullets” from the “Bullets” drop-dow
list. Select “Numbers” from the drop-down list to have Mathcad number success

paragraphs in the region automatically. Alternatively, click  or  on the 
Formatting toolbar.

Alignment

To align the paragraph at either the left or right edge of the text region, or to cente
text within the text region, use these three alignment buttons. Alternatively, click 
of the three alignment buttons on the Formatting toolbar. 

Text styles

Mathcad uses text styles to assign default text and paragraph properties to text regio
Text styles give you an easy way to create a consistent appearance in your works
Rather than choose particular text and paragraph properties for each individual re
you can apply an available text style, setting a range of text and paragraph prop
at once.
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Every worksheet has a default “normal” text style with a particular choice of text 
paragraph properties. Depending on your worksheet and the template from whic
worksheet is derived, you may have other predefined text styles to choose from, w
you can apply to existing or new text regions. You can also modify existing text sty
create new ones of your own, and delete ones you no longer need. 

This section describes the procedures for applying, modifying, creating, and dele
text styles. See the previous section, “Text and paragraph properties,” for details o
available text and paragraph properties and for instructions on formatting selected
within a text region. 

Applying a text style to a paragraph in a text region

When you create a text region in your worksheet, the region is tagged by default
the “Normal” style. You can, however, apply a different style to each paragraph—e
stream of characters followed by a hard return—within the text region:

■ Click in the text region on the paragraph where you want to change the style.

■ Choose Style from the Format menu, or click 
with the right mouse button and choose Style 
from the pop-up menu, to see a list of the avail-
able text styles. Available text styles depend on 
the worksheet template used.

■ Select one of the available text styles and click 
“Apply.” The default text in your paragraph ac-
quires the text and paragraph properties associat-
ed with that style.

Tip As an alternative to choosing Style from the Format menu, you can apply a text style to a tex
paragraph simply by clicking in the paragraph and choosing a style from the left-most dro
down list in the Formatting toolbar. To apply a text style to an entire text region, first selec
the text in the region using one of the methods described in “Selecting text” on page 73. 

Modifying an existing text style

You can change the definition of a text style—its text and paragraph properties—a
time.

To modify a text style:

■ Choose Style from the Format menu. Mathcad brings up the Text Styles dialog
box showing the currently available text styles.

■ Select the name of the text style you want to modify and click “Modify.”
Text styles 79
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■ The Define Style dialog 
box displays the defini-
tions of that text style.

■ Click “Font” to modify 
text formats such as the 
font, font size, font styl-
ing, special effects, and 
color. Click “Paragraph” 
to modify the indenting and alignment for paragraphs. See “Text and paragra
properties” on page 76 for details about the available text and paragraph forma
options. 

■ Click “OK” to save your changes. 

Any new text regions to which you apply the modified text style will reflect the ne
definition for that text style. In addition, any text regions previously created with t
text style will be modified accordingly.

Creating and deleting text styles

You can modify the list of available text styles in your worksheet by creating new o
and deleting ones you no longer use; any text style changes are saved with your
worksheet. You can base a new text style on an existing text style, such that it inh
some text or paragraph properties but not others, or you can create the style ent
anew. For example, you may want to base a new “Subheading” style on an exis
“Heading” style, but choose a smaller font size, keeping other text and paragrap
properties the same. 

Creating a text style

To create a new text style:

■ Choose Style from the Format menu. Mathcad brings up the Text Styles dialog
box showing the currently available text styles.

■ Click “New” to bring up the Define Style dialog box.

■ Enter a name for the new style in the “Name” text box. If you want to base the 
style on one of the existing styles in the current worksheet or template, select a
from the “Based on” drop-down list.

■ Click the “Font” button to make your choices for text formats for the new style
Click the “Paragraph” button to choose alignment and indentation options for
new style.

■ Click “OK” when you have finished defining the new style.

Your new style now appears in the Text Styles dialog box and can be applied to
text region as described in “Applying a text style to a paragraph in a text region” 
page 79. When you save the worksheet, the new text style is saved with it. If you 
to use the new text style in your future worksheets, save your worksheet as a tem
as described in Chapter 7, “Worksheet Management.” You may also copy the text
80  Chapter 5  Working with Text
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into another worksheet simply by copying and pasting a styled region into the ne
worksheet.

Note If you base a new text style on an existing text style, any changes you make later make to
original text style will be reflected in the new text style as well.

Deleting a text style

You may delete a text style at any time. To do so:

■ Choose Style from the Format menu. Mathcad brings up the Text Styles dialog
box showing the currently available text styles.

■ Select one of the available text styles from the list.

■ Click “Delete.”

The text style is removed from the list of available text styles. However, any text reg
in your worksheet whose text and paragraph properties were defined in terms of
text style will continue to display the properties of that style.

Equations in text

This section describes how to insert equations into your text regions. Equations ins
into text have the same properties as those in the rest of your worksheet. You ca
them using the methods described in Chapter 4, “Working with Math.” 

Inserting an equation into text 

Place an equation into text either by creating a new equation inside a text region 
pasting an existing equation into a text region.

To add a new equation into a text region or a paragraph, follow these steps:

■ Click in the text region or paragraph to 
place the insertion point where you 
want the equation to start.

■ Choose Math Region from the Insert 
menu.
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■ Type in the equation just as you would 
in a math region.

■ When you’ve finished typing in the 
equation, click on any text to return to 
the text region. Mathcad adjusts the 
line spacing in the text region to accommodate the embedded math region.

To paste an existing equation into a text region, follow these steps:

■ Select the equation you want to paste into the text.

■ Choose Copy from the Edit  menu, or click  on the Standard toolbar.

■ Click in the text region to place the insertion point where you want the equatio
start.

■ Choose Paste from the Edit  menu, or click  on the Standard toolbar.

Disabling embedded equations

When you first insert an equation into text, it behaves just like an equation in a m
region; it affects calculations throughout the worksheet. If you want the equation t
purely cosmetic, you can disable it so that it no longer calculates. To do so:

■ Click on the equation you want to disable.

■ Choose Properties from the Format menu. Click on the Calculation tab.

■ Click the “Disable Evaluation” check box.

■ Click “OK.”

Once you have done so, the equation can neither affect nor be affected by other
equations in the worksheet. To turn it back on, remove the check next to “Disabl
Evaluation” in the Properties dialog box.

For a more general discussion of disabling and locking equations, see “Disabling
equations” on page 144.

Text tools 

Mathcad has tools for finding and replacing text as well as checking the spelling of

Find and Replace

Mathcad’s Find  and Replace commands on the Edit menu are capable of working
both text and math regions. By default, however, Mathcad finds and replaces tex
text regions only.
82  Chapter 5  Working with Text



 the 
ords 
ether 

d in 
ation 

n text 

gest 

Mathcad Users Guide.book  Page 83  Sunday, August 9, 1998  2:59 PM
Searching for text

To find a sequence of characters:

■ Choose Find  from the Edit  menu. 
Mathcad brings up the Find dialog 
box.

■ Enter the sequence of characters you 
want to find. 

■ Click “Find Next” to find the occur-
rence of the character sequence im-
mediately after the current insertion point location. Use the available options in
dialog box to search upward or downward in the worksheet, to match whole w
only, to match the case exactly of the characters you entered, and to specify wh
Mathcad should search in text or math regions or both.

On-line Help The Help topic “Characters You Can Find and Replace” details the characters you can fin
math and text regions, including Greek symbols. Many special characters, including punctu
and spaces, can be located only in text or in math strings.

Replacing characters

To search and replace text:

■ Choose Replace from the Edit  menu 
to bring up the Replace dialog box.

■ Enter the string you want to find (the 
target string) in the “Find what” box. 

■ Enter the string you want to replace it 
with in the “Replace with” box. Check 
the appropriate boxes to match whole 
words only, to match the case exactly 
of the characters you entered, and to specify whether Mathcad should search i
or math regions or both.

You now have the following options:

■ Click “Find Next” to find and select the next instance of your target string.

■ Click “Replace” to replace the currently selected instance of the string.

■ Click “Replace All” to replace all instances of the string.

Spell-checking 

After creating text, you can have Mathcad search it for misspelled words and sug
replacements. You can also add words that you commonly use to your personal 
dictionary. 
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Note Mathcad spell-checks text regions only, not math or graphics regions.

To begin spell-checking, specify the portion of the worksheet to spell-check. There
two ways to do this:

■ Click at the beginning of wherever you want to spell-check. Mathcad spell-che
starting from this point and continues to the end of the worksheet. You can th
either continue the spell-check from the beginning of the worksheet or quit sp
checking.

■ Alternatively, select the text you want to spell-check.

Once you’ve defined a range over which to check spelling:

■ Choose Check Spelling from the Edit  

menu, or click  on the Standard 
toolbar. 

■ When Mathcad finds a misspelled 
word, it opens the Check Spelling di-
alog box. The misspelled word is 
shown along with a suggested replace-
ment, or a list of possible replace-
ments. If Mathcad has no immediate 
suggestions, it shows only the misspelled word. 

Tip To determine whether a word is misspelled, Mathcad compares it with the words in two 
dictionaries: a general dictionary of common English words supplemented by mathematic
terms and a personal dictionary. If there are certain correctly spelled words throughout yo
worksheet which Mathcad nevertheless shows as being misspelled, you may want to add
to your personal dictionary. 

After the Check Spelling dialog box appears, you have several options:

■ To change the word to the suggested replacement, or to another word you se
from the list of possible replacements, click “Change.”

■ Click “Suggest” to see additional but less likely replacements. If Mathcad can o
no additional suggestions, “Suggest” is grayed.

■ To change the word to one not listed, type the replacement into the “Change
box and click “Change.”

■ To leave the word as is, click “Ignore” or “Add.” If you click “Ignore,” Mathcad
leaves the word alone, continues spell-checking, and ignores all future occurre
of the word. If you click “Add,” the word is added to your personal dictionary. 
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