
 a 

ls, 
 on 

 you 

sktop 
 use 

d.

Mathcad Users Guide.book  Page 31  Sunday, August 9, 1998  2:59 PM
Chapter 3
On-line Resources

With Mathcad you can access mathematical and technical content 
located on your computer or on the World Wide Web. In addition to
full on-line Help system, Mathcad comes with the Resource Center, a 
Mathcad Electronic Book containing an extensive collection of tutoria
examples, and reference information, with links to further resources
the World Wide Web. Mathcad also gives you a direct link to the 
Collaboratory, a unique Web-based messaging system that connects
to the community of Mathcad users. 

The following sections make up this chapter:

Resource Center and Electronic Books 
How to use the Resource Center, a library of reference content on your de
and a gateway to resources on the World Wide Web. How to locate and
information in Mathcad Electronic Books. 

Help
On-line Help on product features.

Internet access in Mathcad
What you need to connect to Web-based resources from within Mathca

The Collaboratory
How to retrieve and post files to the Collaboratory, a Web service for 
communicating with other Mathcad users.
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Resource Center and Electronic Books

If you learn best from examples, want information you can put to work immediatel
your Mathcad worksheets, or wish to access any page on the World Wide Web f

within Mathcad, choose Resource Center from the Help menu or click  on the 
Standard toolbar. The Resource Center is a Mathcad Electronic Book that appears in a 
custom window with its own menus and toolbar, as shown in Figure 3-1. 

Figure 3-1: Resource Center for Mathcad Professional. Topics available in 
Mathcad Standard and other editions differ slightly.

Note Each edition of Mathcad comes with one or more additional Electronic Books on the install
media. In addition, a variety of Mathcad Electronic Books are available from MathSoft or y
local distributor or software reseller. To open an Electronic Book you have installed, choo
Open Book from the Help menu and browse to find the location of the appropriate Electron
Book (HBK) file. 

The Resource Center offers:

■ A comprehensive Mathcad Electronic Book containing a collection of tutorials
QuickSheet templates, examples, and reference information. Simply drag and
information from the Resource Center into your own Mathcad worksheets.
32  Chapter 3  On-line Resources
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■ Immediate access to Mathcad worksheets on MathSoft’s World Wide Web sit
other Internet sites.

■ Access to the full Web-browsing functionality of Microsoft Internet Explorer fro
within the Mathcad environment.

Tip To open the Resource Center automatically every time you start Mathcad, choose Preferences 
from the View menu, click the General tab, and check “Open Resource Center at startup.”
 

Content in the Resource Center

Here are brief descriptions of the topics available in the Resource Center. Exact t
vary in Mathcad Professional, Mathcad Professional Academic, and Mathcad Stan
Edition.

■ Mathcad Overview. A tour of Mathcad’s features.

■ Getting Started. A hands-on introduction to Mathcad’s unique “live” workshee
interface.

■ Advanced Topics. Getting more out of Mathcad’s mathematical, graphing, and
document creation features. 

■ QuickSheets. Over 300 “recipes” take you through a wide variety of common 
mathematical tasks.

■ Mathcad in Action. Dozens of discipline- and industry-specific examples show
how you can apply Mathcad to your work.

■ Reference Tables. Look up physical constants, chemical and physical data, an
mathematical formulas you can use in your Mathcad worksheets.

■ Mathcad Web Library . A built-in connection to regularly updated technical 
content and resources for Mathcad users only.

■ Collaboratory . A connection to MathSoft’s free Internet forum lets you consul
with the world-wide community of Mathcad users.

Finding information in an Electronic Book

The Resource Center is a Mathcad Electronic Book—a hyperlinked collection of 
Mathcad worksheets. As in other hypertext systems, you move around a Mathca
Electronic Book simply by clicking on icons or underlined text. The mouse pointe
automatically changes into the shape of a hand when it hovers over a hypertext 
and a message in the status bar tells you what will happen when you click the lin
Depending on how the book is organized, the activated link automatically opens
appropriate section or displays information in a pop-up window.

You can also use the buttons on the toolbar at the top of the Electronic Book win
to navigate and use content within the Electronic Book:
Resource Center and Electronic Books 33
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    Button Function

Links to the Table of Contents, the page that appears when you first o
the Electronic Book.

Opens a toolbar for entering a World Wide Web address.

Backtracks to whatever document was last viewed.

Reverses the last backtrack.

Goes backward one section in the Electronic Book.

Goes forward one section in the Electronic Book.

Displays a list of documents most recently viewed.

Searches the Electronic Book for a particular term.

Copies selected regions to the clipboard.

Saves current section of the Electronic Book.

Prints current section of the Electronic Book.

Mathcad keeps a record of where you’ve been in the Electronic Book. When you 

, Mathcad goes back to the last section you opened and the page you were on
you left it. Backtracking is especially useful when you have clicked to look at a cro
reference and then want to return to the section you just came from.

If you don’t want to go back one section at a time, click . This opens a Histor
window from which you can jump to any section you viewed since you first open
the Electronic Book. 

Full-text search

In addition to using hypertext links to find topics in the Electronic Book, you can sea
for topics or phrases. To do so:
34  Chapter 3  On-line Resources
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■ Click  to open the Search dialog 
box.

■ Type a word or phrase in the “Search 
for” text box. Select a word or phrase 
and click “Search” to see a list of 
topics containing that entry and the 
number of times it occurs in each 
topic. 

■ Choose a topic and click “Go To.” 
Mathcad opens the Electronic Book 
section containing the entry you want 
to search for. Click “Next” or 
“Previous” to bring the next or previous
occurrence of the entry into the window. 

Annotating an Electronic Book

A Mathcad Electronic Book is made up of fully interactive Mathcad worksheets. Y
can freely edit any math region in an Electronic Book to see the effects of chang
parameter, modifying an equation, etc. You can also enter text, math, or graphic
annotations in any section of your Electronic Book, using the menu commands on
Electronic Book window and the Mathcad toolbars. 

Tip By default any changes or annotations you make to the Electronic Book are displayed in 
annotation highlight color. To change this color, choose Color⇒⇒⇒⇒Annotation from the Format 
menu. To suppress the highlighting of Electronic Book annotations, remove the check fro
Highlight Changes on the Electronic Book’s Book menu.

Changes you make to an Electronic Book are temporary by default: your edits disa
when you close the Electronic Book, and the Electronic Book is restored to its orig
appearance the next time you open it. You can choose to save annotations in an
Electronic Book by checking Annotate Book on the Book menu or on the pop-up menu
that appears when you click with the right mouse button. Once you do so, you hav
following annotation options:

■ Choose Save Section from the Book menu to save annotations you made in the
current section of the Electronic Book, or choose Save All Changes to save all 
changes made since you last opened the Electronic Book. 

■ Choose View Original Section to see the Electronic Book section in its original
form. Choose View Edited Section to see your annotations again.

■ Choose Restore Section to revert to the original section, or choose Restore All to 
delete all annotations and edits you have made to the Electronic Book.
Resource Center and Electronic Books 35
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Copying information from an Electronic Book

There are two ways to copy information from an Electronic Book into your Mathc
worksheet:

■ You can use the Clipboard. Select text or equations in the Electronic Book us

one of the methods described in “Selecting regions” on page 19, click  on
Electronic Book toolbar or choose Copy from the Edit  menu, click on the appro-
priate spot in your worksheet, and choose Paste from the Edit menu.

■ You can drag regions from the Book window and drop them into your worksh
Select the regions as above, then click and hold down the mouse button over
of the regions while you drag the selected regions into your worksheet. The reg
are copied into the worksheet when you release the mouse button.

Web browsing 

If you have Internet access, the Web Library button in the Resource Center conn
you to a collection of Mathcad worksheets and Electronic Books on the World W
Web. You can also use the Resource Center window to browse to any location o
World Wide Web and open standard Hypertext Mark-up Language (HTML ) and other 
Web pages, in addition to Mathcad worksheets. You have the convenience of acce
all of the Internet’s rich information resources right in the Mathcad environment.

Note When the Resource Center window is in Web-browsing mode, Mathcad is using a Web-
browsing OLE control provided by Microsoft Internet Explorer. Web browsing in Mathcad
requires Microsoft Internet Explorer version 4.0 or later to be installed on your system. Altho
Microsoft Internet Explorer is available for installation when you install Mathcad, refer to 
Microsoft Corporation’s Web site at http://www.microsoft.com/  for licensing and 
support information about Microsoft Internet Explorer and to download the latest version.

To browse to any World Wide Web page from within the Resource Center windo

■ Click  on the Resource Center toolbar. As shown below, an additional too
with an “Address” box appears below the Resource Center toolbar to indicate
you are now in a Web-browsing mode:

■ In the “Address” box type a Uniform Resource Locator (URL) for a document on 
the World Wide Web. To visit the MathSoft home page, for example, type
http://www.mathsoft.com/  and press [Enter ]. If you have Internet access
and the server is available, you load the requested page in your Resource Ce
36  Chapter 3  On-line Resources
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window. Under Windows NT 3.51 or if you do not have a supported version o
Microsoft Internet Explorer installed, you launch your default Web browser inste

The remaining buttons on the Web Toolbar have the following functions:

Button Function

Bookmarks current page for a later visit.

Reloads the current page.

Interrupts the current file transfer.

Note When you are in Web-browsing mode and click with the right mouse button on the Resou
Center window, Mathcad displays a pop-up menu with commands appropriate for viewing 
pages. Many of the buttons on the Resource Center toolbar remain active when you are in
browsing mode, so that you can copy, save, or print material you locate on the Web, or bac

to pages you previously viewed. When you click , you return to the Table of Contents
the Resource Center and disconnect from the Web.

Tip You can use the Resource Center in Web-browsing mode to open Mathcad worksheets any
on the World Wide Web. Simply type the URL of a Mathcad worksheet in the “Address” bo
the Web toolbar.

Help

Mathcad provides several ways to get help on product features through an exten
on-line Help system. To see Mathcad’s on-line Help at any time, choose Mathcad Help 

from the Help menu, click  on the Standard toolbar, or press [F1]. Mathcad’s Help 
system is delivered in Microsoft’s HTML Help environment, as shown in Figure 3-2
You can browse the Explorer view in the Contents tab, look up terms or phrases o
Index tab, or search the entire Help system for a keyword or phrase on the Sear
Help 37
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Figure 3-2: Mathcad on-line Help is delivered in HTML Help.

You can get context-sensitive help while using Mathcad. For Mathcad menu com
mands, click on the command and read the status bar at the bottom of your wind
For toolbar buttons, hold the pointer over the button momentarily to see a tool tip

Note The status bar in Mathcad is displayed by default. You can hide the status bar by removin
check from Status Bar on the View menu.

You can also get more detailed help on menu commands or on many operators 
error messages. To do so:

■ Click an error message, a built-in function or variable, or an operator.

■ Press [F1] to bring up the relevant Help screen.

To get help on menu commands or on any of the toolbar buttons:

■ Press [Shift ][F1]. Mathcad changes the pointer into a question mark.

■ Choose a command from the menu. Mathcad shows the relevant Help screen

■ Click any toolbar button. Mathcad displays the operator’s name and a keyboa
shortcut in the status bar.

To resume editing, press [Esc ] or [Shift ][F1]. The pointer turns back into an arrow
38  Chapter 3  On-line Resources
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Tip Choose Tip of the Day from the Help menu for a series of helpful hints on using Mathcad. 
Mathcad automatically displays one of these tips whenever you start it if “Show Tips at Sta
is checked.

Internet access in Mathcad

Many of the on-line Mathcad resources described in this chapter are located not on
own computer or on a local network but on the Internet, the global network that incl
the World Wide Web. 

To access these resources on the Internet you need:

■ Networking software to support a 32-bit Internet (TCP/IP) application. Such soft-
ware is usually part of the networking services of your operating system; see 
operating system documentation for details. 

■ A direct or dial-up connection to the Internet, with appropriate hardware and 
communications software. Consult your system administrator or Internet acce
provider for more information about your Internet connection. 

Before accessing the Internet through Mathcad, you also need to know whether 
use a proxy server to access the Internet. If you use a proxy, ask your system 
administrator for the proxy machine’s name or Internet Protocol (IP) address, as well 
as the port number (socket) you use to connect to it. You may specify separate p
servers for each of the three Internet protocols understood by Mathcad: HTTP, for the 
World Wide Web; FTP, a file transfer protocol; and GOPHER, an older protocol for access
to information archives. 

Once you have this information, 
choose Preferences from the View 
menu, and click the Internet tab. 
Then enter the information in the 
dialog box.

The remaining information in the In-
ternet tab of the Preferences dialog 
was entered at the time you installed 
Mathcad, but you may modify it here 
at any time: 

■ Your name, which appears on 
any messages you send to the 
Collaboratory (see page 39).
Internet access in Mathcad 39
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■ Your Internet electronic mail address, which is sent with any Collaboratory m
sages.

■ The URL for the Collaboratory server you contact when you click the Collaborat
button on the Resource Center home page:

http://webserve.mathsoft.com/mathcad/

The Collaboratory

If you have a dial-up or direct Internet connection, you can access the MathSoft 
Collaboratory server from the Resource Center home page. The Collaboratory is
interactive World Wide Web service that puts you in contact with a community o
Mathcad users. The Collaboratory consists of a group of forums that allow you to
contribute Mathcad or other files, post messages, and download files and read me
contributed by other Mathcad users. You’ll find that the Collaboratory combines so
of the best features of a computer bulletin board or an on-line news group with th
convenience of sharing worksheets and other files created using Mathcad.

When you open the Collaboratory, Mathcad displays a window as shown in Figu
3. A list of forums appears in an Explorer pane on the left, and available subjects in 
each forum are listed in the pane to the right. Scroll in the right-hand pane to see
date, size, and file name of each subject. If a subject is indented, it’s a reply to th
previous subject.

Figure 3-3: Opening the Collaboratory from the Resource Center. Available 
forums and subjects change over time.
40  Chapter 3  On-line Resources
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Note MathSoft maintains the Collaboratory server as a free service, open to all in the Mathcad
community. Be sure to read the Agreement posted in the top level of the Collaboratory fo
important information and disclaimers. 

Opening a worksheet or other file stored in the Collaboratory

To open a worksheet or other file stored in the Collaboratory:

■ Click the Collaboratory button on the Resource Center home page.

■ Select a forum from the list of forums in the Explorer tree in the left pane.

■ Click a subject in the pane to the right. 

Details about the author, title, and date of the subject appear in a pane below the
of buttons in the Collaboratory. Depending on the subject, one of three things hap
If the file is text, the text appears directly in the pane below the Collaboratory butt
Click “Post Reply” to reply to the message if you wish. If the file is a Mathcad 
worksheet, it opens in its own Mathcad window. If the file is of another type, you 
prompted either to open or to save the file. 

Click the “Next” button to view the next subject in the forum. Click “Previous” to vie
the subject before the current subject. Click “Refresh” to reload the current forum

Sending a worksheet to the Collaboratory

If you want to send a worksheet you’ve created, or any other file, to the Collabora

■ Click the Collaboratory button on the Resource Center home page.

■ Select a forum from the list of forums in the Explorer tree in the left pane. If y
want to send the file as a response to an earlier subject, click the subject.

■ Click “Post” or “Post Reply,” as appropriate, to open the Send dialog box.

■ Click “Send my Current File” if the worksheet you’d like to post is currently op
in your Mathcad window. If it isn’t, click “Send Another File.”

■ If you click “Send Another File,” enter the path to the file in the File text box. 
Alternatively, click “Browse” to locate the file.

■ Enter a title in the Title text box. This is the text that will appear in the list of subje
in the forum.

■ Click “Send.” Your file is then uploaded to the Collaboratory server, and the t
appears in the Subjects pane. 

Tip The Collaboratory is accessible to users of Mathcad 7 and higher. If you want Mathcad 7 
to be able to access a worksheet you post, you can first save it in a compatible format as
described in “Saving your worksheet in Mathcad 7 or Mathcad 6 format” on page 102.
The Collaboratory 41
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Sending a text message to the Collaboratory

To write a text message and send it to the Collaboratory:

■ Click the Collaboratory button on the Resource Center home page.

■ Select a forum from the list of forums in the Explorer tree in the left pane. If y
want to send the message as a response to an earlier subject, click the subje

■ Click “Post” or “Post Reply,” as appropriate, to open the Send dialog box.

■ Click “Send a Message.”

■ Enter a title in the Title 
text box. This is the text 
that will appear in the list 
of subjects in the forum.

■ Type your message into 
the Message text box.

■ Click “Send.” Your mes-
sage is then uploaded to 
the Collaboratory server, 
and the title appears in the 
Subjects pane.

Tip Your name automatically appears in the details of any subject that you post to the Collabor
You can edit the user name as described in “Internet access in Mathcad” on page 39.

Deleting a subject from the Collaboratory 

If you posted a file or a message to the Collaboratory but would like to remove it

■ Click the Collaboratory button on the Resource Center home page.

■ Select a forum containing the subject you wish to delete from the list of forum
the Explorer tree in the left pane. 

■ Click with the right mouse button on the topic you want to delete and choose Delete 
from the pop-up menu. 

Note You may only delete subjects that you previously posted. In addition, if your file or messag
received any responses, you won’t be able to delete it. 
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