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Chapter 13
3D Plots 

To visualize a function of two variables or three-dimensional data in
Mathcad worksheet, you can create a surface plot, a contour plot, a
bar plot, a 3D scatter plot, or a vector field plot. This chapter explai
how to create and format these plots using Mathcad’s OpenGL grap
engine. 

This chapter contains the following sections:

Overview of 3D plotting
Introduction to creating three-dimensional plots, including multiple plots 
a single graph.

Examples of 3D plots
Instructions for creating surface plots, contour plots, 3D bar plots, 3D sca
plots, and vector field plots.

Formatting a 3D plot
Basic procedures for formatting a three-dimensional plot. Description of w
to modify the surface, lines, and points of a plot. Introduction to lighting an
annotations.

Modifying your 3D plot’s perspective
Rotating, spinning, and zooming a three-dimensional plot.
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Overview of 3D plotting

To visually represent a function of two variables in Mathcad or to plot data in the f
of x-, y-, and z-coordinates, you can create a surface plot, a contour plot, a 3D bar 
a 3D scatter plot, or a vector field plot. You insert these different plot types using
commands from the Insert menu or the 3D Plot Wizard. You can also create more th
one of these plots on the same graph. Mathcad renders 3D plots with a sophistic
high performance OpenGL graphics engine.

Inserting a 3D plot

In general, to create a three-dimensional plot:

Q Store the values to be plotted in a Mathcad variable. Most 3D plots require yo
store the values in a matrix. The row and column numbers typically represenx- 
and y-axis values. The matrix elements themselves typically are z-values.

Q Click in the worksheet where you want the plot 
to appear. Then choose Graph from the Insert  
menu and choose a 3D plot. Alternatively, 
click one of the 3D graph buttons on the Graph 
toolbar. Mathcad inserts a blank 3D plot with 
axes and an empty placeholder.

Q Enter the name of the matrix (or other required 
arguments) into the placeholder. If the plot 
requires more than one argument, enclose the 
arguments in parentheses and separate them 
by commas. For a list of the arguments 
required by each type of plot, see page 253.

Q Click outside the plot or press [Enter ]. Math-
cad creates the plot according to the points 
represented in the matrix or other arguments 
you specified. For example, a surface plot is 
created, as shown at right.

The plot is created using default format settings. 
For information on modifying plot characteristics 
such as the axes, lighting, and lines, see “Format-
ting a 3D plot” on page 264.

To resize a plot, click in the plot to select it. Then 
move the cursor to a handle along the edge of the 
plot until the cursor changes to a double-headed 
arrow. Hold the mouse button down and drag the 
mouse in the direction that you want the plot’s 
dimension to change.
252  Chapter 13  3D Plots
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3D Plot Wizard

To help you have more control over the format settings of a plot as it is inserted,
the 3D Plot Wizard which specifies a plot’s appearance step by step.

To use the Wizard:

Q Click in your worksheet 
wherever you want the 
graph to appear. Make sure 
you see the crosshair.

Q Choose Graph⇒3D Plot 
Wizard from the Insert 
menu. The first page of the 
3D Plot Wizard appears.

Q Select the type of three-
dimensional graph you 
want to see and click “Next.”

Q Make your selections for the appearance and coloring of the plot on subsequ
pages of the Wizard. Click “Finish” to insert a plot with appropriate axes and 
blank placeholder into your worksheet.

Q Enter appropriate arguments for the 3D plot into the placeholder. A list of the
arguments required by each type of 3D plot is provided below.

Q Click outside the plot or press [Enter ].

The plot is created using the settings you specified in the Wizard. For informatio
modifying the appearance of your plot, see “Formatting a 3D plot” on page 264.

Plot arguments

The following table indicates the arguments required for each kind of three-dimens
plot. When a plot requires multiple arguments, enter the arguments into the placeh
separated by commas and surround the group of arguments with parentheses.

    3D plot Arguments

Surface plot A matrix whose row and column numbers represent the x- 
and y-axis values. The matrix elements themselves are thez-
values.

Parametric surface Three matrices containing, respectively, the x-, y-, and z-
coordinates of points on the surface. The three matrix arg
ments must be enclosed in parentheses. See “Creating a
parametric surface plot” on page 257.

Contour plot A matrix whose row and column numbers represent the x- 
and y-axis values. The matrix elements themselves are thez-
values.
Overview of 3D plotting 253
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3D scatter plot Three vectors containing, respectively, the x-, y-, and z-
coordinates of points in space. The three vector argumen
must be enclosed in parentheses.

3D bar plot A matrix whose row and column numbers represent the x- 
and y-axis values. The matrix elements themselves are thez-
values, or the heights of the bars.

Vector field plot A single matrix of complex values whose row and column
numbers represent the vector x- and y-coordinates. The real 
part of each matrix element is the x-component of a vector. 
The imaginary part of each element is the y-component of a 
vector. 

Alternatively, two matrices: one whose elements contain t
x-components of the vectors and one whose elements are
y-components. The two matrix arguments must be enclos
in parentheses.

Pro Although you can enclose multiple arguments in parentheses, as indicated in the a
table, in Mathcad Professional you can also create a nested array (see page 233) as a
convenient shortcut to assemble multiple arguments. One element of the nested
must contain all of the arguments for the plot. For example, to pass the matrix argum
for one of the parametric surface plots in Figure 13-1 using a nested array:

Q Create a vector each of whose first element contains the three matrix 
argument for the parametric surface plot. 

Q Enter the name of the vector, in this case v , into the placeholder on the 
3D plot. 

Graphing multiple 3D plots

Pro Just as you can plot more than one trace on a two-dimensional graph, you can c
more than one three-dimensional plot on a graph. To do so, insert a 3D plot and 
the necessary arguments, separated by commas, for each of the plots you want
graph. For example, to create a contour plot and a surface plot on the same gra

Q Define two matrices, one containing the data for the contour plot, the other 
containing the surface plot data.

Q Choose Graph⇒Contour Plot from the Insert menu or click  on the Graph 
toolbar. Mathcad inserts a blank 3D plot as shown on page 252.

Q Enter the name of the matrix containing the data for the contour plot into the 
placeholder. Then type ,  (a comma).

Q Enter the name of the matrix containing the data for the surface plot.

Q Press [Enter ] or click outside the plot. You see two contour plots. 
254  Chapter 13  3D Plots
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Q Double-click the graph to bring up the 3D Plot Format dialog box. In the Disp
As section of the General tab, click the tab labeled Plot 2 and click Surface. C
“OK.” 

Both the contour plot and the surface plot, with default format settings, appear in
single graph. 

Figure 13-1 shows an example of two parametric surfaces on a single 3D graph.
that the three arguments for each surface are enclosed in parentheses.

Figure 13-1:  Two parametric surface plots shown on the same graph.

Tip As a general rule, you will not want to graph more than two or three plots together since t
may obscure each other and make the graph difficult to interpret.

Examples of 3D plots

This section describes in more detail how to create various 3D plots in Mathcad 
provides examples. Although the instructions focus on using commands on the Insert 
menu, you can also use the 3D Plot Wizard, as described on page 253.

Tip To see a variety of two- and three-dimensional functions and data sets visualized in plots,
the Advanced Topics in the Mathcad Resource Center (choose Resource Center from the Help 
menu) and click “Practical Curves and Surfaces.” 
Examples of 3D plots 255
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Creating a surface plot

A surface plot is useful for visualizing two-dimensional data contained in an array
points in space that are connected to form a surface.

To create a surface plot:

Q Define a matrix of values to plot. The row and column numbers represent the x- and 
y-axis values. The matrix elements themselves are the z-values, the heights above
the x-y plane.

Q Choose Graph⇒Surface Plot from the Insert  menu or click  on the Graph 
toolbar. Mathcad inserts a blank 3D plot as shown on page 252.

Q Enter the name of the matrix in the placeholder. 

Q Press [Enter ] or click outside the plot.

What you see is a visual representation of the matrix. Mathcad draws a perspec
view of the matrix as a two-dimensional grid lying flat in three-dimensional space. E
matrix element is represented as a point at a specified height above or below this
The height is proportional to the value of the matrix element. In the default perspec
the first row of the matrix extends from the back left corner of the grid to the righ
while the first column extends from the back left corner out toward the viewer. 

By default, Mathcad draws lines, called a wireframe, to connect the points in the plot.
These lines define the surface. You can change the way a surface plot looks onc
inserted. For example, you can color the surface, change lines, or draw points. 

For general information on formatting a three-dimensional plot, refer to “Formattin
3D plot” on page 264. For specific information on formatting a surface plot, refer
the topic “Surface Plots” in the on-line Help.

Example: Plotting a function of two variables as a surface plot 

A typical surface plot shows the values of a function of two variables. First create
matrix that holds the values of the function, then create a surface plot of that ma
Here are the steps in plotting a function of two variables such as that shown in F
13-2:

Q Define a function of two variables f( ).

Q Decide how many points you want to plot in the x and y directions. Set up range 
variables (named i and j in this example, but you can choose any names) to ind
these points. For example, if you want to plot 10 points in each direction, ente

Q Define  and  as evenly spaced points on the x- and y-axes.

Q Fill the matrix M  with the values of f( ).

Q Choose Graph⇒Surface Plot from the Insert  menu or click  on the Graph 
toolbar.

x y,

i 0 9..:= j 0 9..:=

xi yj

xi yj,
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Q Type M in the placeholder and click outside the plot.

Figure 13-2: Surface plot of a function of two variables.

Creating a parametric surface plot

Parametric equations allow you to describe points in space that vary according to 
other variables such as time and speed. Parametric surface plots are created in M
by passing to the surface plot three matrices representing the x-, y-, and z-coordinates 
of your points in space. 

To create a parametric surface plot: 

Q Define three matrices having the same number of rows and columns. 

Q Choose Graph⇒Surface Plot from the Insert  menu or click  on the Graph 
toolbar. Mathcad shows an empty plot with a single placeholder.

Q Type the names of the three matrices separated by commas into the placeho
and surround the three names with parentheses. 

Q Press [Enter ] or click outside the plot.

Mathcad interprets the three matrices as the x-, y-, and z-coordinates of points on a 
surface and draws this surface from the viewing angle prescribed by the Rotation
and Twist settings in the 3D Plot Format dialog box. 

Note The underlying parameter space is a rectangular sheet covered by a uniform mesh. In effe
three matrices map this sheet into three-dimensional space. For example, the matrices X, Y, and 
Z defined in Figure 13-3 carry out a mapping that rolls the sheet into a tube and then join
ends of the tube to form a torus.
Examples of 3D plots 257
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Figure 13-3: A parametric surface plot.

Creating a contour plot

To view three-dimensional data from above or from another direction, you can cr
a contour plot:

Q Define a matrix of values to plot. 

Q Choose Graph⇒Contour Plot from the Insert menu or click  on the Graph 
toolbar. Mathcad shows a blank plot with a single placeholder.

Q Type the name of the matrix in the placeholder. 

Q Press [Enter ] or click outside the plot.

What you see is a visual representation of the matrix’s level curves. Mathcad ass
that the rows and columns represent equally spaced intervals on the axes, and t
linearly interpolates the values of this matrix to form level curves or contours. Each 
level curve is formed in such a way that no two cross. By default, the z-contours are 
shown on the x-y plane. Mathcad plots the matrix by rotating it so that the elemen
row 0, column 0 is in the lower-left corner. Thus the rows of the matrix correspon
values on the x-axis, increasing to the right, and the columns correspond to values a
the y-axis, increasing toward the top. 

You can format a contour plot once it is inserted. For example, you can specify wh
or not the contours are to be numbered, how many contours there are, and wheth
lines appear on the plot. You can also choose to show the x or y contours on the x-z or 
y-z backplane, respectively. 

For general information on formatting a three-dimensional plot, refer to “Formattin
3D plot” on page 264. For specific information on formatting a contour plot, refer
the topic “Contour Plots” in the on-line Help.
258  Chapter 13  3D Plots
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Example: A contour plot of a function of two variables 

A typical contour plot shows the level curves of a function of two variables. To se
such a plot, first create a matrix that holds the values of the function, then create
contour plot of that matrix. Here are the typical steps in plotting a function of two
variables such as that shown in Figure 13-4:

Q Define a function of two variables, f( ).

Q Decide how many points you want to plot in the x and y directions. Set up range 
variables (named i and j in this example, but you can choose any names) to ind
these points. For example, if you want to plot 10 points in each direction, ente

Q Define  and  as evenly spaced points on the x- and y-axes.

Q Fill the matrix M  with the values of f( ).

Q Choose Graph⇒Contour Plot from the Insert menu or click  on the Graph 
toolbar.

Q Type M in the placeholder and click outside the plot.

Figure 13-4: Contour plot of a function of two variables.

Note If you plot a function as described above, the positive x-axis of the plot extends to the right and
the positive y-axis extends toward the top of the plot.

x y,

i 0 9..:= j 0 9..:=

xi yj

xi yj,
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Creating a 3D bar plot 

To create a bar plot of three-dimensional data:

Q Define a matrix of values to display.

Q Choose Graph⇒3D Bar Plot from the Insert menu or click  on the Graph 
toolbar. Mathcad shows an empty plot with a placeholder.

Q Type the name of the matrix in the placeholder. 

Q Press [Enter ] or click outside the plot.

What you see is a visual representation of the matrix. Mathcad draws a perspec
view of the matrix as a two-dimensional grid lying flat in three-dimensional space. E
matrix element is represented as a column extending above or below this grid by
amount proportional to the value of the matrix element. In the default perspective
first row of the matrix extends from the back left corner of the grid to the right, wh
the first column extends from the back left corner out toward the viewer. 

The perspective on the bar plot depends on the location of the viewer with respe
the surface. You can change this view and other format options as described in 
“Formatting a 3D plot” on page 264. For example, you can specify whether you w
the bars stacked or laid out side-by-side.

Example: A bar plot of a function of two variables 

A typical 3D bar plot shows the values of a function of two variables. To see suc
chart, first create a matrix that holds the values of the function, then create a bar
of that matrix. Here are the typical steps in plotting a function of two variables suc
that shown in Figure 13-5:

Q Define a function of two variables, f( ).

Q Decide how many points you want to plot in the x and y directions. Set up range 
variables (named i and j in this example, but you can choose any names) to ind
these points. For example, if you want to display 10 points in each direction, e

Q Define  and  as evenly spaced points on the x- and y-axes. 

Q Fill the matrix M  with the values of f ( ).

Q Choose Graph⇒3D Bar Plot from the Insert menu or click  on the Graph 
toolbar.

Q Type M in the placeholder. 

Q Press [Enter ] or click outside the plot.

x y,

i 0 9..:= j 0 9..:=

xi yj

xi yj,
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Figure 13-5: 3D bar plot of a function of two variables.

You can change the way a 3D bar chart looks once it is inserted. For example, yo
color the bars according to their height or their x or y values. You can also control the
way the bars are laid out.

For general information on formatting a three-dimensional plot, refer to “Formattin
3D plot” on page 264. For specific information on formatting a 3D bar plot, refer to
topic “3D bar plots” in the on-line Help.

Creating a 3D scatter plot 

To create a scatter plot of three-dimensional data:

Q Define three vectors, each having as many elements as you have points to plo
three vectors contain the x-, y-, and z-coordinates of the points, respectively.

Q Choose Graph⇒3D Scatter Plot from the Insert menu or click  on the Graph
toolbar. Mathcad shows a blank plot with a single placeholder.

Q Type the names of the vectors, separated by commas, in the placeholder, an 
surround the three names with parentheses. 

Q Click outside the plot or press [Enter] . 

Tip If you have a matrix of data that you want to show as a set of points, create a surface plot as 
described on page 256, double-click it to bring up the 3D Plot Format dialog box, and select
Points in the Display As group on the General page.
Examples of 3D plots 261
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Example: Plotting parametric curves in three-dimensional space

You can easily create parametric curves in space using a 3D scatter plot. For exa
to create the plot shown in Figure 13-6:

Q Decide how many points you want to plot. Set up a range variable (named i in this 
example, but choose any name) to index these points. 

Q Define two vectors x and y in terms of the cos and sin functions. Define a third 
vector z as the parametric function. 

Q Choose Graph⇒3D Scatter Plot from the Insert menu or click  on the Graph
toolbar.

Q Type (x,y,z)  in the placeholder. Then click outside the plot.

Figure 13-6: A 3D scatter plot.

You can change the way a scatter plot looks once it is inserted. For example, yo
change the symbol and its color used at each point. You can also connect the po
space with a line. 

For general information on formatting a three-dimensional plot, refer to “Formattin
3D plot” on page 264. For specific information on formatting a 3D scatter plot, re
to the topic “3D scatter plots” in the on-line Help.

Creating a vector field plot   

In a vector field plot, each point in the x-y plane is assigned a two-dimensional vecto
To create a vector field plot, you define a rectangular array of points and assign a v
to each point. One way to do this is by creating a matrix of complex numbers in w

Q The row and column numbers represent x- and y-coordinates.

Q The real part of each matrix element is the x-component of the vector associated
with that row and column.
262  Chapter 13  3D Plots
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Q The imaginary part of each element is the y-component of the vector associated 
with that row and column.

To create a vector field plot:

Q Create a matrix as described above.

Q Choose Graph⇒Vector Field Plot from the Insert menu or click  on the 
Graph toolbar. 

Q Type the name of the matrix in the placeholder.

Q Press [Enter ] or click outside the plot.

Mathcad plots the matrix by rotating it so that the element in row 0, column 0 is a
lower-left corner. Thus the rows of the matrix correspond to values on the x-axis, 
increasing to the right, and the columns correspond to values along the y-axis, increas-
ing toward the top.

You see a collection of  vectors as shown in Figure 13-7. The base of each v
sits on the x- and y-values corresponding to its row and column. The magnitude an
direction of each vector are derived from the real and imaginary parts of the mat
element.

Figure 13-7: A sample vector plot from a complex matrix.

You can also create a vector field plot by using two matrices of real numbers rat
than a single matrix of complex members. 

Q Create two matrices having the same number of rows and columns. The first m
should have the x-components of the vectors, the second the y- components.

Q Choose Graph⇒Vector Field Plot from the Insert menu or click  on the 
Graph toolbar. 

m n⋅
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Q Type the names of the matrices separated by commas in the placeholder, an
surround the names with parentheses.

Q Press [Enter ] or click outside the plot.

Figure 13-8 shows a vector field plotted using two real matrices rather than a sin
complex matrix. 

Figure 13-8: A sample vector plot from two matrices of real numbers.

You can change the way a vector field plot looks once it is inserted. For example
can change the color of the arrow heads and the lines. 

For general information on formatting a three-dimensional plot, refer to “Formattin
3D plot.” For specific information on formatting a vector field plot, refer to the top
“Vector field plots” in the on-line Help.

Formatting a 3D plot

A three-dimensional plot’s default appearance depends on how you insert it. When
choose Graph⇒3D Plot Wizard from the Insert menu, you make selections in the 
pages of the Wizard that determine a plot’s appearance. When you insert a plot 
choosing a plot type from the Insert menu, however, the plot automatically acquire
default characteristics. 

You can change the appearance of any 3D plot after it is inserted. To do so, you
the many options available in the 3D Plot Format dialog box. For example, you can
264  Chapter 13  3D Plots
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the options to change a plot’s color, format the axes, add backplanes, and forma
lines or points.

To bring up the 3D Plot Format dialog box:

Q Click once on the plot to select 
it and choose Graph⇒3D Plot 
from the Format menu. Alter-
natively, double-click the plot 
itself. Mathcad brings up the 3D 
Plot Format dialog box. The 
General page is shown at right. 
The remaining tabs take you to 
additional pages.

Q Click the tab for the page you 
want to work with. For an over-
view of the options available on 
each page, see below.

Q Make the appropriate changes in the dialog box.

Q Click “Apply” to see the effect of your changes without closing the dialog box. 

Q Close the dialog by clicking “OK.” 

The 3D Plot Format dialog box

The tabs in the 3D Plot Format dialog box bring you to pages containing options
formatting various aspects of a three-dimensional plot. Some options available o
certain pages in the dialog box depend on the kind of plot you are formatting. Opt
on other pages are available for any three-dimensional graph. 

Q The General page gives you access to basic options that control the overall 
appearance of the graph. Use these options to control the position of a plot, s
axis style, draw a border or a box, or convert one 3D plot to another type.

Q The options on the Axes page allow you to control exactly how each axis looks.
You can specify the weight of each axis and whether it has numbers or tick ma
You can also specify the axis limits. Use the tabs at the top of the page to for
the x-, y-, or z-axis. 

Q The Backplanes page has options for specifying whether a backplane is filled w
a color, has a border, or has grid lines or tick marks. Use the tabs at the top o
page to format the x-y, y-z, or x-z backplane.

Note Both the Backplanes page and the Axes page have options for setting and formatting grid
When you set the grid lines for an axis on the Axes tab, you set them for the two backpla
shared by the axis. When you set the grid lines on the Backplanes tab, you set them for o
backplane only.
Formatting a 3D plot 265
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Q Use the options on the Appearance page to format the surfaces, lines, and poin
that make up a plot. For example, the options here let you apply color directly
plot’s surface, its contours, or its lines and points. To learn more about contro
the surfaces, lines, and points of a plot, see the sections that follow.

Q The Lighting page options control both the overall lighting of the plot as well a
individual lights directed onto it. See “Lighting” on page 271 for more informati
on lighting and how it affects a plot.

Q The Title  page gives you a text box for entering a title for the graph and options
specifying the location of the title on the graph.

Q The options on the Special page are for controlling plot options related to specif
kinds of plots. For example, the Bar Plot Layout options let you specify the w
the bars are arranged in a 3D bar plot.

Q The Advanced page has options which you are likely to use only when you ne
very fine control over the appearance of a plot, such as the vertical scale.

On-line Help For details on the options available on a particular page in the 3D Plot Format dialog box,
the Help button at the bottom of the dialog box.

Some options in the 3D Plot Format dialog box work together to control the appear
of a plot. For example, the options on the Appearance page, the Lighting page, an
Special and Advanced pages work together to control the color of a plot. Refer to
sections that follow for more information on controlling the color of a plot’s surfac
and its lines and points.

Note When you format a graph containing more than one plot, as described on “Graphing multip
plots” on page 254, some options in the 3D Plot Format dialog box apply to an entire graph 
others apply to individual plots. For example, all the options on the Axes, Backplanes, an
Lighting pages are for the graph as a whole: each plot on the graph uses common axes, 
backplanes, and lighting. However, options on the Appearance tab are specific to each p
the graph. That is, each plot can be filled with its own color, have its own lines drawn, etc.
the tabs labeled Plot 1, Plot 2, etc. to control the settings for individual plots.

Fill color

The color of a plot is primarily determined by its fill color. This section describes 
ways to apply color to a plot by filling its surfaces or contours. A plot’s color and 
shading are also affected by lighting, as described in more detail in page 271.

Mathcad allows you to apply either a solid color or a colormap to the surface or con
of a plot. A solid color is useful when you don’t want to overcomplicate a plot wit
many colors or when you want to use primarily lighting to shade a plot. A colorm
applies an array of color to a plot according to its coordinates. 
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Note Mathcad comes with a variety of colormaps for applying rainbow colors and shades of gray
green, and blue. You can also create and load custom colormaps by using the SaveColormap and 
LoadColormap functions, described on page 216. By default, a colormap is applied in the 
direction of the z-values, or according to the height of the plot. You can apply the colormap
the direction of the x-values or y-values by clicking the Advanced tab and choosing a directio
in the Colormap section. For more information on colormaps, see on-line Help.

Filling the surface

To apply color to a plot’s surface, use the options on the Appearance page of th
Plot Format dialog box. Fill the surface with a solid color or a colormap. For exam
to color the bars in a 3D bar plot according to a colormap:

Q Double-click the graph to bring 
up the 3D Plot Format dialog 
box.

Q Click the Appearance tab. 

Q Click both Fill Surface and 
Colormap in the Fill Options 
section.

Q Click “Apply” to preview the 
plot. Click “OK” to close the 
dialog box.

Figure 13-9 shows an example. 

Figure 13-9: Filling the surface or contours of a plot.
Formatting a 3D plot 267



ad 

face 
face 
can 
, 
ot. 

ecial 
 you 

aw 
plot.

ance 
n a 
The plot is shaded using the default colormap “Rainbow.” To choose a different 
colormap, click the Advanced tab of the 3D Plot Format dialog box and select a 
colormap from the Choose Colormap drop-down menu.

If you wanted to fill the bars of the plot with a solid color, choose Solid Color inste
of Colormap and double-click the color box next to Solid Color to select a color.

Filling contours

When you format a surface plot, you can choose Fill Contours instead of Fill Sur
in the Fill Options section of the Appearance page. If you fill the contours of a sur
plot, the plot is filled according to its contours rather than directly by its data. You 
fill according to the x-, y-, or z-contours or two at the same time. For a contour plot
you must choose Fill Contours instead of Fill Surface to fill the contours of the pl

For example, to fill a contour plot with color:

Q Double-click the graph to bring up the tabbed dialog box.

Q Click the Appearance tab. 

Q In the Fill Options section, click Fill Contours.

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

The plot is shaded using the default colormap “Rainbow.” To choose a different 
colormap, click the Advanced tab of the 3D Plot Format dialog box and select a 
colormap from the Choose Colormap drop-down menu.

Note If you have a contour plot projected on a plane other than the x-y plane, you can fill the contour 
using options on the Special page of the 3D Plot Format dialog box. To do so, click the Sp
tab, then choose a contour direction from the drop-down menu. Click Fill for each contour
want to color. For example, if you have Fill checked for the z-contours and x-contours, you will 
see contour color on both the x-y backplane and the y-z backplane. 

Lines

Mathcad provides many ways to control the appearance of the lines on a three-
dimensional plot. You can draw the lines so they form a wireframe, or you can dr
only the contour lines. You can also control the weight and color of the lines on a 

Drawing a wireframe

To control whether lines form a wireframe on a plot, use the options on the Appear
page of the 3D Plot Format dialog box. For example, to remove the wireframe o
surface plot as shown in Figure 13-10:

Q Double-click the graph to bring up the tabbed dialog box.

Q Click the Appearance tab. 

Q In the Line Options section, click No Lines.
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Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

To turn lines on again later, choose Wireframe on the Appearance page.

Figure 13-10: A wireframe vs. contour lines on a surface plot.

Drawing contour lines

When you format a surface plot, you can choose Contour instead of Wireframe in
Line Options section of the Appearance page. Contour lines are those drawn acco
to the contours of a surface. You can draw either the x-, y-, or z- contour lines, two of 
these contours lines, or all three.

Note For contour plots, Mathcad always chooses Contour instead of Wireframe to draw contour 

For example, to draw lines showing the x-contours of a surface plot:

Q Double-click the graph to bring up the tabbed dialog box.

Q Click the Appearance tab. 

Q Click Contour in the Line Options section. 

Q Click the Special tab.

Q Verify that Z-Contours is selected in the drop-down menu at the bottom of the
Contour Options section. Click Draw Lines to remove the check mark. This tu
lines off for the z-contours. 

Q Choose X-Contours from the drop-down menu on the Special page.

Q Check Draw Lines.
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Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

The surface plot is drawn with contour lines perpendicular to the z-axis, as shown in 
Figure 13-10.

Note When you format a contour plot on a multi-plot graph (see page 254), the options in the d
down menu on the Special tab determine on which backplane the contour lines are drawn
example, if you have Draw Lines checked for the z-contours and x-contours, you will see contour 
lines on both the x-y backplane and the y-z backplane. 

Line color

You can control the color of the lines in a plot using the color options in the Line Opt
section of the Appearance page. Just as you can fill a plot’s surface with a colorm
a solid color, described on page 267, you can also apply a colormap or solid colo
the lines in a plot.

For example, to make the lines of a contour plot orange:

Q Double-click the graph to bring up the tabbed dialog box.

Q Click the Appearance tab. 

Q In the Line Options section, click Contour to draw contour lines and Solid Col

Q Double-click the color box next to Solid Color, click the orange box, and click
“OK.”

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

Points

You can draw and format points on any three-dimensional plot, since all 3D plots
constructed from discrete data points. Points are most useful, however, on a 3D s
plot in which points are the main focus of the plot. Mathcad allows you to control 
symbol used for the points in a plot as well as the color and size of the symbol. 

To draw, remove, or format the points on a plot, use the options on the Appearanc
of the 3D Plot Format dialog box. For example, to draw points on a surface plot:

Q Double-click the graph to bring up the 3D Plot Format dialog box.

Q Click the Appearance tab.

Q In the Points Options section, check Draw Points.

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

Point symbols

To specify a symbol for the points on a three-dimensional plot such as a 3D scatte

Q Double-click the graph to bring up the 3D Plot Format dialog box.
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Q Click the Appearance tab.

Q In the Points Options section, choose a Symbol from the drop-down list. Incre
or decrease the size of the points using the Size spin box.

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

Point color

You can control the color of the points in a plot using the color options in the Poi
Options section of the Appearance page. Just as you can fill a plot’s surface with
colormap or a solid color, described on page 267, you can also apply a colormap
solid color to the points in a plot.

For example, to make all the points in a 3D scatter plot red:

Q Double-click the graph to bring up the 3D Plot Format dialog box.

Q Click the Appearance tab.

Q In the Points Options section, check Draw Points. Then click Solid Color.

Q Double-click the box next to Solid Color, click the red box, and click “OK.”

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

Lighting

The color of a three-dimensional plot is a result of color you use to fill its surface, lin
and points as well as the color of any ambient light or directed lights shining on it. T
is just as it is in the real world where an object has color, but its color is affected b
surrounding light. This is due to the fact that as light shines, an object reflects an
absorbs light, depending on its color. For example, a yellow ball reflects mostly ye
light and absorbs others, and it can look grayish under dim lighting, green under
lighting, and bright yellow in bright lighting.

As described in previous sections, you can fill a plot’s surfaces, contours, lines, a
points with either a solid color or a colormap using the options on the Appearance
Advanced pages of the 3D Plot Format dialog box. 

Light is controlled using the options on the Lighting page of the 3D Plot Format dia
box. If you are content to fill a plot with a colormap, you may not need to use light
at all. However, if you want to shade the plot differently, or if you fill the plot with 
solid color and want to shade it, you can enable lighting.

Note If your 3D graph contains multiple plots, lighting affects all the plots in a graph, but you can
individual plots with color independently.
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Figure 13-11: A white surface plot with lighting enabled.

Note If you want lighting to be the sole determinant of the color of a plot, use the Appearance p
options in the 3D Plot Format dialog box to fill the plot with solid white.

To enable lighting:

Q Double-click the plot to open the tabbed dialog box.

Q Click the Lighting tab.

Q Check Enable Lighting in the Lighting section.

Q Click the options on tabs labeled Light 1, Light 2, etc. to enable a directed light
set its color and location. Mathcad lets you set up to eight directed lights.

Q Double-click the Ambient Light Color box to set the ambient light color. Note th
black corresponds to no ambient light.

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

On-line Help For details on the options available on the Lighting page, click the Help button at the botto
the dialog box. For additional information on lighting, see the Help topic “Lighting a 3D plo

Changing one 3D plot to another

You can change almost any three-dimensional plot into another kind of three-
dimensional plot by using the Display As options on the General tab in the 3D Pl
Format dialog box. Simply select another available 3D plot type and click “Apply”
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“OK” to change the plot instantaneously to another type. Figure 13-12 shows the s
matrix displayed as three different plot types.

Figure 13-12:  The same data displayed in several different 3D plots.

Note Some three-dimensional plots cannot be converted to other forms. For example, you can
convert a vector field plot into any other kind of plot. If a plot cannot be converted to anoth
kind of plot, that plot type is grayed in the 3D Plot Format dialog box.

Annotations

In addition to adding a title to your three-dimensional plot by using options on the T
page of the 3D Plot Format dialog box, you can annotate a three-dimensional pl
placing text or bitmaps anywhere on it. This allows you to label or highlight any p
of the plot that you wish.

To add a text annotation to a three-dimensional plot:

Q Create a text region in your worksheet using the methods described in Chapt
“Working with Text.” 

Q Drag the text region from its location in your worksheet and drop it directly on
the plot. See “Selecting and moving text regions” on page 75 for more on drag
and dropping text regions.

You can select the text annotation on your plot to reposition it. To edit a text annota
on a plot, select the text and drag it off the plot to your worksheet. You can then 
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the text region as you would any text in Mathcad. Then drag the text region back
the plot.

Tip You can drag a bitmap image from your Mathcad worksheet onto a three-dimensional plo
as you drag and drop text annotations. To place a bitmap you create in another applicatio
a three-dimensional plot, copy the bitmap from the other application to the Clipboard, clic
the plot with the right mouse button, and choose Paste Special from the pop-up menu.

Modifying your 3D plot’s perspective

You can resize a three-dimensional plot using the same methods you use to resiz
graphics regions in Mathcad (see page 88). Mathcad provides several additional op
for manipulating the presentation of your 3D plot:

Q You can rotate the plot to see it from a different perspective.

Q You can set the plot in motion about an axis of rotation so that it spins continuo

Q You can zoom in or out on a portion of the plot.

Note When you rotate, spin, or zoom a three-dimensional plot, any visible axes move or resize
themselves with the plot. Text or graphic annotations you add to the plot (see page 273) r
anchored at their original sizes and positions.

Rotating a plot

You can rotate a plot interactively with the mouse or by specifying parameters in
3D Plot Format dialog box.

To rotate a three-dimensional plot interactively by using the mouse:

Q Click in the plot, and hold the mouse button down.

Q Drag the mouse in the direction you want the plot to turn.

Q Release the mouse button when the plot is in the desired position.

To rotate a three-dimensional plot by using the 3D Plot Format dialog box:

Q Click once on the plot to select it and choose Graph⇒3D Plot from the Format 
menu. Alternatively, double-click the plot.

Q Click the General tab.
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Q Edit the settings for Rotation, Tilt, and Twist in the View options.

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.

Spinning a plot

You can set a plot in motion so that it spins continuously about an axis of rotation

Q Click in the plot, and hold the [Shift ] key and the mouse button down.

Q Drag the mouse in the direction you want the plot to spin.

Q Release the mouse button to set the plot in motion.

 The plot spins continuously until you click again inside the plot.

Note If you make changes to equations that affect a plot, the plot recomputes even when it is spi

Tip To create an AVI file of a spinning plot, see the techniques in “Animation” on page 145.

Zooming a plot

You can zoom in or out of a plot interactively or by specifying a zoom factor in the
Plot Format dialog box.

To zoom in on a three-dimensional plot by using the mouse:

Q Click in the plot, and hold the [Ctrl ] key and the mouse button down.

Q Drag the mouse toward the top of the plot to zoom out, or drag the mouse tow
the bottom to zoom in.

Q Release the mouse button when the plot is at the desired zoom factor.

Tip If you use an IntelliMouse-compatible mouse with a center wheel, you can rotate the whe
zoom in or out of a three-dimensional plot.

To zoom in or out of a three-dimensional plot by using the 3D Plot Format dialog 

Q Click once on the plot to select it and choose Graph⇒3D Plot from the Format 
menu. Alternatively, double-click the plot.

Q Click the General tab.

Q Edit the Zoom setting in the View options.

Q Click “Apply” to preview the plot. Click “OK” to close the dialog box.
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