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Chapter 6
Working with Graphics 
and Other Objects

This chapter describes how to insert a variety of graphics and othe
objects into Mathcad worksheets. You can create a variety of 
sophisticated two- and three-dimensional graphs to visualize your 
calculations. You can create pictures in your worksheet by referenc
bitmap files, and import graphic images by copying them from anot
application and pasting them into Mathcad. This chapter also introdu
Object Linking and Embedding (OLE) as a way of inserting objects 
created by other applications into a Mathcad worksheet.

This chapter contains the following sections:

Inserting graphs
Introduction to placing two- and three-dimensional graphs in a worksheet,
along with basics of graph resizing and formatting.

Inserting pictures
Using the Picture command from the Insert menu to create a picture base
on a matrix or bitmap file. Pasting in a graphic image from the clipboard
Formatting options for pictures.

Inserting objects
How to insert objects from other applications into a Mathcad worksheet.
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Inserting graphs

Mathcad provides two-dimensional graphs, including X-Y and polar 
plots, that enable you to visualize a function or expression of one variable, 
X-Y or angle-dependent data, or a vector.You can also create a variety 
of three-dimensional graphs, including surface plots for visualizing a 
matrix of data, contour plots for visualizing level curves, three-dimen-
sional scatter plots for visualizing coordinate data, parametric surface plots, and o
The Graph toolbar provides convenient shortcuts for inserting and manipulating m
graphs.

This section provides only a brief introduction to inserting and formatting Mathca
two- and three-dimensional graphs. See Chapter 12, “2D Plots,” and Chapter 13
Plots,” for details.

Inserting a two-dimensional graph

To create an X-Y plot based on an expression of a single variable:

Q Click in your worksheet wherever you want the graph to appear. Make sure you
the crosshair.

Q Choose Graph⇒X-Y Plot from the Insert menu 

or click  on the Graph toolbar. Mathcad inserts 
a blank X-Y plot, a box with one placeholder on the 
bottom (x-axis) and one on the left (y-axis).

Q Fill in the middle placeholder on the left (y-axis) 
with a function or expression of one variable. For 
example, type sin(x)  to see a graph of the sin 
function.

Q Press [Enter ] or click outside the plot. 

Mathcad automatically produces a plot using default format settings over a defau
range of the variable on the x-axis: –10 to 10. A plot such as this, where Mathcad choo
the range for the dependent variable, is called a QuickPlot.
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Note As described in Chapter 12, “2D Plots,” you can explicitly enter expressions on both the x- and 
y-axes that specify the range of values to plot. Usually these expressions depend on rang
variables you previously defined in your worksheet. But if you have not previously defined
range variables, Mathcad generates the range for the plot implicitly.

You can plot multiple traces on a single two-dimensional graph. For example, an X-
plot can show several y-axis expressions against the same x-axis expression, or it can 
match up several y-axis expressions with corresponding x-axis expressions. See Chap
ter 12, “2D Plots,” for details on how to do this.

Inserting a three-dimensional graph

As described in detail in &KDSWHU ��� ¦�' 3ORWV�§ \RX FDQ FUHDWH VRSKLVWLFDWHG�ORRNLQJ

VXUIDFH SORWV� FRQWRXU SORWV� DQG RWKHU NLQGV RI WKUHH�GLPHQVLRQDO SORWV XVLQJ D ZLGH

UDQJH RI GLVSOD\ RSWLRQV WKDW FRQWURO WKH OLJKWLQJ DQG FRORU DQG GHWDLO WKDW DSSHDUV� To 
simplify the creation of a three-dimensional graph into your worksheet, Mathcad
includes a 3D Plot Wizard. 

Tip You can also insert specific three-dimensional graphs directly into your worksheet using de
format settings by selecting commands from the Graph pull-right menu on the Insert menu or 
by clicking appropriate buttons on the Graph toolbar.

To use the Wizard:

Q Click in your worksheet 
wherever you want the 
graph to appear. Make sure 
you see the crosshair.

Q Choose Graph⇒Plot 
Wizard from the Insert 
menu. The first page of the 
3D Plot Wizard appears.

Q Select the type of three-di-
mensional graph you want 
to see and click “Next.”
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Q Make your selections for the appearance and coloring 
of the plot on subsequent pages of the Wizard. Click 
“Finish” to insert a plot with appropriate axes and a 
blank placeholder into your worksheet.

Q Enter an expression in the placeholder. For example, 
to see a surface plot of a matrix M  you have previously 
created in your worksheet, enter M. Mathcad interprets 
the number of rows and columns of the matrix as 
values on the x- and y- axes. The matrix elements are 
plotted as heights above or below the x-y plane using 
the display and formatting options you selected.

Q Press [Enter ] or click outside the plot. 

Note See “Plot arguments” on page 253 for a description of the expressions you can enter in th
placeholder of a three-dimensional plot to produce different plot types such as 3D scatter 
vector field plots, and parametric surface plots.

You can place multiple plots on a single three-dimensional graph. For example, yo
can simultaneously plot a surface and a contour plot of the same data. See “Gra
multiple 3D plots” on page 254 for details.

Resizing a graph

Resizing a two- or three-dimensional graph is very much like resizing a text regio

Q Click in the plot to select it.

Q Move the mouse pointer to one of the handles 
along the edges or the corners of the plot. The 
pointer changes to a double-headed arrow.

Q Press and hold down the mouse button and move 
the mouse in the direction that you want the 
plot’s dimension to change.

Q Once the plot is the right size, let go of the mouse 
button. 
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Q Click outside the plot to deselect it.

Note See Chapter 12, “2D Plots,” and Chapter 13, “3D Plots,” for information on zooming in or 
of a two- or three-dimensional graph.

Formatting a graph

When you insert a two- or three-dimensional graph into a worksheet, the graph ap
with Mathcad’s default choices for the appearance of various elements in the gra
data points, traces, surfaces, axes, labels, and so on. You can easily modify the 
appearance of a graph by accessing the formatting dialog box associated with it,
introduced below. See Chapter 12, “2D Plots,” and Chapter 13, “3D Plots,” for det
on formatting options for graphs in Mathcad.

Tip Double-clicking a two- or three-dimensional graph is a convenient shortcut for opening th
appropriate formatting dialog box. 
 

Two-dimensional graphs

To modify the appearance of an X-Y or polar plot:

Q Click on the plot and choose 
Graph⇒X-Y Plot  or Graph⇒Polar 
Plot from the Format menu. Select the 
appropriate two-dimensional graph 
from the pull-right menu. The format-
ting dialog box appears, as in the exam-
ple at right.

Q Click the tab for the page you want to 
work with. 

Q Make the appropriate changes in the 
dialog box. 

Q To see the effect of your changes on the 
graph without closing the dialog box, 
click “Apply.” 

Q When you’re finished, close the dialog by clicking “OK.” The plot’s appearanc
updates to reflect the changes you made.

You can access the following options from the plot formatting dialog box:

Q Axes settings, such as whether the axes are logarithmic, whether grid lines app
and the style of the axes.
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Q Trace settings, such as the weight and color of a trace and whether points on t
trace are marked with individual symbols.

Q Labels on the graph, including the placement of a graph title, axes labels, and
legends to identify individual traces.

Q The ability to create or apply default settings for two-dimensional plots in your 
worksheet.

Three-dimensional graphs

To modify the appearance of a surface, contour, 3D bar, 3D scatter, or vector field

Q Click on the graph and choose 
Graph⇒3D Plot from the 
Format menu. The formatting 
dialog box appears, as in the 
example at right.

Q Click the tab for the page you 
want to work with. 

Q Make the appropriate changes 
in the dialog box. To see the 
effect of your changes on the 
graph without closing the dialog 
box, click “Apply.” 

Q Close the dialog box by clicking “OK.” The plot’s appearance updates to reflect
changes you made.

You can access the following options from the Properties dialog box:

Q General settings, such as the type of surface to create and the angle of view.

Q Axes settings, such as the appearance of tick marks, grid lines, and axes label

Q Appearance options, governing whether a surface is filled and lines or points a
shown.

Q Lighting settings, governing the location and color of lights for the plot.

Q Backplane formatting for the planes defined by the intersecting axes.

Q Special surface options, such as the density of contours in a contour plot.

Q Advanced color options, such as colormaps for different surfaces.
90  Chapter 6  Working with Graphics and Other Objects
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Inserting pictures

This section describes techniques for creating and formatting pictures—static graphic 
images—in your Mathcad worksheet.

Creating a picture

You can create a picture in a Mathcad worksheet in the following ways:

Q By using the picture operator and supplying either the name of a Mathcad matr
or the name of an external bitmap file, or 

Q By importing an image from another application via the Clipboard. 

Creating a picture from a matrix

You can view any matrix in Mathcad as a picture by using the picture operator:

Q Click in a blank space in your Mathcad worksheet.

Q Choose Picture from the Insert menu or click  on the Matrix toolbar.

Q Type the name of a matrix in the placeholder at the bottom of the operator.

Mathcad creates a 256-shade grayscale representation of the data in the matrix,
each matrix element corresponding to a pixel in the picture. 

Note Mathcad’s picture operator assumes a 256-color model with the value 0 represented as bla
255 as white. Numbers outside the range 0–255 are reduced modulo 256, and any nonin
value is treated as if its decimal part has been removed.

Since the matrices used in picture rendering are usually quite large, this techniqu
creating a picture is most useful when you import graphics files into Mathcad as 
matrices as described in “File access functions” on page 214. For example, you ca
the READBMP function to read an external graphics file into a matrix, and then use
picture operator to see the picture in Mathcad. 

Tip To display an image in color, you must provide the picture operator with the names of thr
matrices of the same size containing the red, green, and blue color values of the image. Ty
three names, separated by commas, in the placeholder of the picture operator. Otherwise
image appears in grayscale.
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Creating a picture by reference to a bitmap file

Mathcad can create a picture directly from an external file in Windows bitmap (BMP)
format. To do so, click in a blank space in your worksheet and then:

Q Choose Picture from the Insert menu, 

or click  on the Matrix toolbar, to 
insert the picture operator. 

Q In the placeholder, type a string contain-
ing the name of a bitmap file in the 
current directory, or type a full path to a 
bitmap file. You create a string in the 
placeholder by first typing the double-
quote (" ) key.

Q Click outside the picture operator. The 
bitmap appears in your worksheet.

Each time you open the worksheet or calculate the worksheet, the bitmap file is 
into the picture operator. 

Note If you modify the source bitmap file, you must recalculate your worksheet to see the mod
image. If you move the source bitmap file, Mathcad can no longer display the picture.

Creating a picture by importing from the Clipboard

You can copy an image from another application to the Clipboard and paste it in
Mathcad in one of the formats put on the Clipboard at the time of copying. This sec
describes using the Paste Special command on the Edit  menu to paste a graphic image
into a Mathcad worksheet from the Clipboard in a noneditable format: as a metafi
bitmap. A metafile, which is strictly a Windows graphic format, can be resized in
Mathcad without undue loss of resolution, whereas a bitmap is usually viewed best
at its original size. A device-independent bitmap, or DIB, is stored in a bitmap format 
that is portable to other operating systems.
92  Chapter 6  Working with Graphics and Other Objects
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Note If you use the Paste command on Mathcad’s Edit  menu to paste in an image from the Clipboar
(or use drag-and-drop from another application), you typically paste a linked OLE object into 
your Mathcad worksheet, as discussed in “Inserting objects” on page 95. When you double
a linked OLE object, you activate the application that created the object and are able to ed
object in your Mathcad worksheet.

To paste a graphics image from another application into Mathcad, do the followi

Q Open the application and place the graphics image on the Clipboard, usually 
Copy command on the Edit  menu. Many Windows applications have this featur

Q Click the mouse wherever you want the image in your Mathcad worksheet.

Q Choose Paste Special from the Edit  menu, and choose “Picture (metafile)” or 
“Device Independent Bitmap.” 

Q Click “OK.” Mathcad creates a picture region and puts into it the image stored
the clipboard.

Note The format choices in the Paste Special dialog box will vary, depending on the application
which you originally copied a selection. 

Mathcad stores the color depth—the number of colors in the image—at the time
paste it into a worksheet. This means that you can safely resave any worksheets
contain color images on systems that have different color displays, either fewer or 
colors. The images continue to display at the proper color depth on the systems 
created the worksheets.

Note When you import directly from the Clipboard, the picture information is stored as part of th
Mathcad worksheet. This makes the file size larger. It also means that when you copy the
worksheet, the picture information travels along with it. 

Formatting a picture

This section describes your options for formatting a picture once you’ve created 

Resizing a picture

To resize a picture region, do the following:

Q Click the mouse inside the picture region to select it.

Q Move the mouse pointer to one of the handles along the edge of region. The po
changes to a double-headed arrow.
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Q Press and hold down the left mouse button. With the button still held, drag the m
in the direction you want the picture region to be stretched.

Tip When you change the size of the picture region, the picture inside may be distorted. If you 
the picture by dragging diagonally on the handle in the lower right corner, you preserve th
aspect ratio—the ratio of height to width—of the original picture. To restore a picture to its
original size, click on the picture and choose Properties from the Format menu. On the display 
tab of the Properties dialog box, check “Display at Original Size.”

Framing a picture

Mathcad allows you to place a border all the way around a picture region. To do

Q Double-click the picture itself, or choose Properties from the Format menu. This 
brings up the Properties dialog box.

Q Click “Show Border.”

Q Click “OK.” Mathcad draws a border around the picture region.

Controlling color palettes

If you are using a 256-color display and have color bitmaps in your Mathcad wor
sheets, Mathcad by default uses a single 256-color palette to display all the bitma
your worksheets. This is the same default color palette Mathcad uses for displayin
rest of the Mathcad screen, and is suitable for most pictures. 

This default color palette, however, may not be the exact one that any color bitma
a worksheet were designed to use. To improve the appearance of bitmaps in yo
worksheet, you can tell Mathcad to optimize its default color palette so that it cho
the best possible 256 colors to display bitmaps in the worksheet. To do so:

Q Choose Color⇒Optimize Palette from the Format menu. Mathcad surveys the 
pictures in the worksheet and generates an optimal 256-color palette to use f
of them. 

Q Make sure that Color⇒Use Default Palette in the Format menu is checked. Then
Mathcad uses the new default palette it generates. 

Note If your display driver supports more than 256 colors, the palette-setting options on the Format 
menu are grayed.
94  Chapter 6  Working with Graphics and Other Objects
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Inserting objects

This section describes techniques for inserting and editing objects created by other 
applications in your Mathcad worksheets. OLE (Object Linking and Embedding) 
technology in Microsoft Windows makes it possible not only to insert static pictur
of such objects into your applications (or of Mathcad objects into other applicatio
but to insert the objects in such a way that they can be fully edited in their origina
applications. 

An object can be either embedded in or linked to a Mathcad worksheet. An object tha
is linked must exist in an external saved file. An object that you embed may be cre
at the time of insertion. When you edit a linked object, any changes you make to
object also update the original file containing the object. When you edit an embe
object, any changes you make to the object affect it only in the context of the Mat
worksheet. The original object in the source application, if there is one, is unchan

Tip For information about using specialized objects called components to import and export data, as
well as establish dynamic connections between Mathcad and other applications, see Chap
“Vectors, Matrices, and Data Arrays,” and Chapter 16, “Advanced Computational Feature

Inserting an object into a worksheet

You insert an object into Mathcad, which is an OLE 2–compatible application, by using
the Object command from the Insert menu, by copying and pasting, or by drag and
drop. The method you choose depends on whether you want to create the object 
fly, whether the object has already been created, or whether you want the object
an entire file. You can edit objects in a Mathcad worksheet simply by double-click
them, causing in-place activation of the originating application in most cases.

Tip In general, you use the same methods to insert a Mathcad object into another application and edit
it inside that application as you do to insert objects into a Mathcad worksheet. However, t
details depend on the extent to which the application receiving a Mathcad object supports
2. Once you’ve inserted a Mathcad object into a compatible application, you can edit it by
double-clicking it. If the application supports in-place activation, as current releases of 
Microsoft Office applications do, the menus and toolbars will change to Mathcad’s.

Insert Object command

When you use the Object command from the Insert menu, you can insert an object 
that you create at the time you are inserting it, or you can insert an entire file you
already created.
Inserting objects 95
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To insert an object or a saved file:

Q First click in your worksheet where you want to insert the object. Make sure y
see the crosshair.

Q Choose Object from the 
Insert menu to bring up 
the Insert Object dialog 
box. By default “Create 
New” is selected:

Q Check “Display As Icon” 
if you want an icon, rather 
than the actual object, to 
appear in your worksheet. 
The icon is typically the 
icon of the application that 
created the object.

To create a new object:

Q Select an application from the “Object Type” list. The available object types dep
on the applications you have installed on your system.

Q Click “OK.” 

The source application opens so that you can create the object. When you are fin
working to create the object, exit the source application. The object you created is
embedded in your Mathcad worksheet.

If you want to insert a previously created file:

Q Click “Create from File” 
in the Insert Object dialog 
box. The dialog box then 
changes appearance.

Q Type the path to the ob-
ject file or click “Browse” 
to locate it.

Q Check “Link” to insert a 
linked object. Otherwise, 
the object is embedded.

Q Click “OK.”

Pasting an object into a worksheet

You can copy an object from a source application to the Clipboard and paste it dir
into Mathcad. This method is particularly useful when you’ve already created the ob
in another application and you don’t want to insert an entire file. 

To insert an embedded or linked object into a worksheet via the Clipboard:
96  Chapter 6  Working with Graphics and Other Objects
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Q Open the source application containing the object.

Q Copy the object from the source application to the Clipboard. You typically do 
by choosing Copy from the Edit  menu or by pressing [Ctrl ]C.

Q Click in the Mathcad worksheet where you’d like to place the object. 

Q Choose Paste or Paste Special from Mathcad’s Edit  menu. 

If you choose Paste, the object is pasted in your Mathcad worksheet in a format th
depends on what the source application has placed on the Clipboard. The behav
differs depending on whether you have selected a math placeholder or are pastin
a blank space in the worksheet. Mathcad creates one of the following:

Q A matrix, if you are pasting numeric data from the clipboard into an empty ma
placeholder. 

Q A text region, if you are pasting text that does not contain numeric data exclusiv

Q A bitmap or picture (metafile), if the originating application generates graphics.

Q An embedded object, if the originating application supports OLE. 

If you choose Paste Special, you have the option of pasting the object in one of the
available formats placed on the Clipboard. Typically you can choose to paste the o
as an embedded or linked OLE object (if the object was stored in a saved file in an OLE-
compatible source application), a picture (metafile), or a bitmap. See “Creating a pi
by importing from the Clipboard” on page 92 for more information on pasting metaf
and bitmaps. 

Dragging and dropping an object into a worksheet

A third way to insert an OLE object into a Mathcad worksheet is to drag it from the
source application and drop it into the worksheet. This is very similar to copying 
pasting, but does not allow you to create a link to an object. To do so, open both Ma
and the source application and arrange the two windows side by side on the scr
Then select the object in the source application and drag it with the mouse into y
Mathcad worksheet. The object appears when you release the mouse button.

Editing an object

To edit an embedded object in a Mathcad worksheet, double-click the object. Math
menus and toolbars change to those of the source application, and a hatched bo
surrounds the object so that you can edit it. This OLE editing mechanism is called in-
place activation. For example, you can use in-place activation to edit objects crea
by Microsoft Office applications such as Excel and Word inside Mathcad.

If the source application does not support in-place activation inside Mathcad or t
object is linked, the behavior is different. In the case of an embedded object, a co
the object is placed into a window from the other application. If the object is linke
the source application opens the file containing the object. 
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Editing a link

If you’ve inserted a 
linked object into a 
Mathcad worksheet, you 
can update the link, 
eliminate it, or change 
the source file to which 
the object is linked. To 
do so, choose Links  
from the Edit  menu. 

Choose the link you 
want to edit from the list 
of links. Then make changes using the available options:

Automatic:  Updates links whenever you open the worksheet and any time the so
information changes while the worksheet is open. 

Manual:  Updates links only when you press “Update Now.”

Update Now: Updates a manual link.

Open Source: Opens the application in which the linked object was created.

Change Source: Links the object with a different source file. The new source file mu
have been created in the same application as the original source file.

Break Link:  Breaks the link between an object’s original source and the copy of 
object in the worksheet.
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