Оглавление

    Содержание

    Предисловие
    Глава 1. Основные понятия
    Глава 2. Цвет в программе Photoshop
    Глава 3. Начало работы
    Глава 4. Основные сведения о растровых
    Глава 5. Выделение
    Глава 6. Компоновка
    Глава 7. Слои
    Глава 8. События
    Глава 9. Команды корректировки
    Глава 10. Выбор цвета
    Глава 11. Раскрашивание
    Глава 12. Рисование
    Глава 13. Градиенты
    Глава 14. Дополнительные сведения о слоях
    Глава 15. Маски
    Глава 16. Контуры и фигуры
    Глава 17. Работа с текстом
    Глава 18. Фильтры
    Глава 19. Команда Liquify
    Глава 20. Автоматизация
    Глава 21. Общие установки программы Photoshop
    Глава 22. Печать
    Глава 23. Работа с Web и программой ImageReady
    Приложение. «Горячие» клавиши


  • Глава 1. Основные понятия
    • Панель инструментов
      • Примечания
    • Панель опций
      • Всплывающие подсказки
    • Вид экрана при работе с программой Photoshop 7
    • Меню
      • Меню File
      • Меню Edit
      • Меню Image
      • Меню Layer
      • Меню Select
      • Меню Filter
      • Меню View
      • Меню Window
      • Меню Help
    • Палитры
      • Как пользоваться палитрами
      • Палитра Color
      • Палитра Swatches
      • Палитра Styles
      • Палитра Navigator
      • Палитра Info
      • Палитра Layers
      • Палитра Channels
      • Палитра Paths
      • Палитра History
      • Палитра Actions
      • Палитра Character
      • Палитра Paragraph
      • Выбор кисти
      • Небольшой глоссарий
    • Методы создания изображения

Глава №1.

Основные понятия

Рис. 1.1. Всплывающая подсказка на панели инструментов

Рис. 1.2. Всплывающая подсказка на панели опций

Панель инструментов

Для того чтобы активизировать инструмент, пиктограмма которого в данный момент видна на экране, щелкните по ней. Рядом с некоторыми пиктограммами расположена маленькая стрелочка. Если по ней щелкнуть, раскроется всплывающая палитра, где можно выбрать инструмент, входящий в ту же группу.

Еще удобнее вызывать инструменты при помощи клавиатуры (запомните буквы, указанные на следующих страницах для каждого инструмента). Если вы забыли клавишную комбинацию, наведите курсор на пиктограмму инструмента, задержите на несколько секунд, и всплывающая подсказка напомнит ее вам (рис. 1.1). Чтобы попеременно вызывать входящие в какую-либо группу инструменты, пиктограммы которых спрятаны, нажимайте клавишу Shift и соответствующую «горячую» клавишу. Также можно, нажав клавишу Alt, щелкнуть по пиктограмме видимого инструмента.

Для каждого инструмента задаются свои собственные параметры (например, режим смешивания, значение непрозрачности) на панели опций, расположенной вверху экрана (подробнее о панели опций рассказано в разделе «Панель опций» этой главы) - см. рис. 1.2. Состав параметров на панели опций изменяется в зависимости от того, какой инструмент выбран.

На панели опций с правой стороны расположена пиктограмма активного инструмента. Если щелкнуть по стрелочке рядом с пиктограммой, раскроется выпадающее меню, где вы можете выбрать другой инструмент. Этот список можно редактировать, удалять редко используемые и добавлять часто применяемые инструменты. Установки на панели опций сохраняются для каждого инструмента, если их не изменить или не восстановить принимаемые по умолчанию. Загрузить, добавить и сохранить различные комбинации кнопок, а также восстановить принимаемые по умолчанию характеристики инструмента можно с помощью команд меню выпадающей панели (рис. 1.3). Для того чтобы восстановить принимаемые по умолчанию значения опций для всех инструментов, там же выберите команду Reset All Tools (Восстановить все инструменты) либо щелкните по кнопке Reset All Tools в окне Edit > Preferences > General (Правка > Установки > Общие).

В окне Edit > Preferences > Display&Cursors (Правка > Установки > Отображение&курсоры) выберите, как будет выглядеть курсор: так же, как и пиктограмма инструмента на панели инструментов, или в виде перекрестия.

Если попытаться неправильно использовать инструмент, появится пиктограмма запрета 0. Щелкните мышью в окне, содержащем изображение, над которым вы работаете, чтобы узнать, почему нельзя использовать инструмент в данной ситуации.

Рис. 1.3. Панель выбора инструмента

На рис. 1.4 показана панель инструментов программы Photoshop 7. Рядом с названием групп инструментов указана «горячая клавиша» для вызова инструментов, входящих в эту группу.

Нажимайте клавишу Shift и соответствующую «горячую» клавишу, чтобы по очереди вызывать инструменты, расположенные на одной всплывающей палитре (см. рис. 1.5—1.21) и связанные между собой.

Рис. 1.4. Панель инструментов

Рис. 1.5. Палитра инструментов для выделения области геометрической формы

Рис. 1.6. Палитра инструментов для выделения области произвольной формы

Рис. 1.7. Палитра инструментов для устранения дефектов изображений

Рис. 1.8. Палитра инструментов клонирования

Рис. 1.9. Палитра инструментов стирания

Рис. 1.10. Палитра инструментов, контролирующих четкость границ изображения

Рис. 1.11. Палитра инструментов прямого выделения

Рис. 1.12. Палитра инструментов для работы с контурами

Рис. 1.13. Палитра инструментов для создания примечаний

Рис. 1.14. Палитра инструментов для работы с ломтиками

Рис. 1.15. Палитра инструментов рисования

Рис.1.16. Палитра инструментов для работы с историей создания изображения

Рис. 1.17. Палитра инструментов заливки

Рис. 1.18. Панель инструментов для осветления и затемнения изображений

Рис. 1.19. Панель инструментов для работы с текстом

Рис. 1.20. Панель векторных инструментов рисования

Рис. 1.21. Панель инструментов для работы с цветом, углами и расстояниями

Рис. 1.22. Примечание, созданное с помощью инструмента Notes

Рис. 1.23. Область на панели опций, предназначенная для хранения палитр

Рис. 1.24. Панель опций для инструмента Brush

Рис. 1.25. Панель опций для инструмента Rectangular Marquee

Примечания

С помощью инструмента Notes (Примечания), панель которого показана на рис. 1.13, можно создать текстовые примечания в формате, совместимом с форматом программы Acrobat. Эти примечания не выводятся на печать. Их можно использовать для передачи какой-либо информации клиенту, типографии и т. д. Щелкнув по значку примечания, вы сможете увидеть сообщение в появившемся окне (рис. 1.22). Аудиопримечания создаются с помощью инструмента Audio Annotation (Звуковое примечание) - см. рис. 1.13.

Панель опций

Панель опций используется для выбора значений параметров каждого инструмента (например, уровня непрозрачности, точки начала затухания, режима смешивания) - см. рис. 1.24. Справа на панели опций имеется особая область, предназначенная для хранения палитр (рис. 1.23). Набор параметров, выводимых на панель, меняется в зависимости от того, какой именно инструмент выбран (рис. 1.24-1.29). Введенные или выбранные вами значения будут сохранены до тех пор, пока вы снова не измените их. Так же, как и палитру, панель опций можно переместить в любую часть экрана.

Рис. 1.26. Панель опций для инструмента Gradient

Рис. 1.27. Панель опций для инструмента Реп

Рис. 1.28. Панель опций для инструмента Rectangle

Рис. 1.29. Панель опций для инструмента Туре

Всплывающие подсказки

Наведите курсор на пиктограмму инструмента, не щелкая и не нажимая кнопки мыши, и вы узнаете название инструмента, а также «горячие» клавиши для его активизации (см. рис. 1.1). Аналогично можно получить сведения о функции палитры или о значениях опций, доступ к которым обеспечивает панель опций инструмента (см. рис. 1.2). Для того, чтобы включить режим подсказок, установите флажок Show Tool Tips (Показывать всплывающие подсказки) в окне Edit > Preferences > General (Правка > Установки > Общие).

«Горячие» клавиши для инструментов

В табл. 1.1 приведены наиболее часто выполняемые операции и соответствующие им «горячие» клавиши.

Таблица 1.1

Операция | «Горячие» клавиши
Показать/спрятать панель инструментов и все открытые палитры | Tab
По очереди вызывать связанные между собой инструменты из одного всплывающего меню | Shift + клавиша активизации инструмента или щелчок по видимой пиктограмме инструмента при нажатой клавише Alt
Переключать режимы смешивания для текущего инструмента или слоя | Shift+«плюс» или Shift+«минyc»

Вид экрана при работе с программой Photoshop 7

На рис. 1.30 показан вид экрана при работе с программой Photoshop 7.

Щелчком по кнопке (1) вызывается меню управления приложением. Оно содержит следующие команды: Restore (Восстановить), Move (Переместить), Size (Размер), Minimize (Свернуть), Maximize (Развернуть) и Close (Закрыть). С помощью кнопки (7) вызывается меню управления документом. В основном меню документа содержатся такие команды, как Restore (Восстановить), Move (Переместить), Size (Размер), Minimize (Свернуть), Maximize (Развернуть), Close (Закрыть) и Next (Следующий).

Щелкните мышью по любому элементу панели меню (2), чтобы получить доступ к различным диалоговым окнам, подменю и командам.

Для определения параметров выбранного инструмента предназначена панель опций (3).

Щелкните по кнопке Minimize (4), чтобы свернуть окно приложения; в результате его пиктограмма будет расположена на панели задач. Для того чтобы восстановить прежний размер окна, просто щелкните по этому значку.

Кнопка Maximize (Развернуть) приложения (5) или документа (10) позволяет увеличить размер окна, насколько это возможно. Если же хотите восстановить прежний размер окна, щелкните по кнопке Restore. После того как размер окна восстановится, кнопка Restore превратится в кнопку Maximize.

Рис. 1.30. Вид экрана программы Photoshop 7

Кнопка закрытия приложения (6) закрывает окно приложения.

Заголовок (8) содержит наименование и масштаб изображения, имя текущего слоя или идентификатор Background (Фон) и информацию о режиме изображения.

Свернуть документ можно, щелкнув по кнопке Minimize (9) документа, при этом пиктограмма документа будет расположена в левом нижнем углу окна приложения. Щелкните по кнопке Restore (Восстановить) (16), и будет восстановлен прежний размер окна документа.

Если хотите закрыть изображение или палитру, щелкните по пиктограмме (11).

Чтобы отобразить на экране линейки (12), воспользуйтесь командой View > Show Rulers (Вид > Показать линейки). Положение курсора указывается соответствующим маркером на каждой из линеек. Выберите единицы измерения для линейки в диалоговом окне Edit > Preferences > Units&Rulers (Правка > Установки > Единицы измерения&линейки).

В программе имеется 13 палитр (13), которые можно перемещать по экрану и менять их группировку, принимаемую по умолчанию. Щелкните по вкладке (имени палитры) в группе палитр, и она станет самой верхней в данном стеке.

Для того чтобы показать/спрятать панель инструментов (14) и все открытые палитры, нажмите клавишу Tab.

В строке состояния (15) отображаются значения следующих параметров: Document Size (Размер документа), Document Profile (Профиль документа), Scratch Sizes (Объем памяти) - объем оперативной памяти, в данный момент доступный

для программы Photoshop, Efficiency (Эффективность) - доля используемой оперативной памяти, Timing (Время) и Current Tool (Текущий инструмент) -имя инструмента. Указав курсором на строку состояния, нажмите и удерживайте кнопку мыши, чтобы увидеть, как будет расположено изображение на странице. Если, указав курсором на строку состояния, нажать кнопку мыши при нажатой клавише Alt, то на экран будет выведена информация о размерах изображения, числе каналов, режиме и разрешении. Чтобы начать отсчет времени с нуля, выберите элемент меню Timing (Время).

Рис. 1.31. Меню File

Рис. 1.32. Меню Edit

Меню

Меню File

Команды из меню File (Файл) применяются в тех случаях, когда необходимо создать, открыть, разместить, закрыть, сохранить, отсканировать, импортировать или экспортировать, напечатать изображение, передать файл по сети, автоматизировать некоторые операции и, наконец, выйти из программы Photoshop (рис. 1.31). Воспользуйтесь подменю File > Jump to (Файл > Перейти в), чтобы перейти во вспомогательные приложения, такие как ImageReady или GoLive.

Меню Edit

В меню Edit (Правка), показанном на рис. 1.32, содержатся команды редактирования изображения: копирования, трансформации, вставки и переопределения цветов изображения, а также команды создания кисти определенного размера и формы, различных узоров и фигур. Команды подменю Fade (Ослабить) позволяют ослабить эффект от многих операций (например, последнего примененного фильтра, команд корректировки или рисования каким-либо инструментом). Команды подменю Purge (Очистить) освобождают память. Также с помощью меню Edit можно открыть диалоговые окна Color Settings (Характеристики цвета), Preset Manager (Менеджер настроек) и Preferences (Установки).

Меню Image

С помощью подменю Mode (Режим) меню Image (Изображение), которое приводится на рис. 1.33, изображение может быть преобразовано в любое из восьми представлений. Команды подменю Adjustments (Корректировки) изменяют тон, насыщенность, яркость цвета или контрастность изображения. С помощью команды Image Size (Размер изображения) можно изменить размер файла, размеры изображения или разрешение. Диалоговое окно Canvas Size (Размер холста) используется в том случае, когда нужно изменить размер рабочего пространства, в котором расположено изображение.

Меню Layer

Команды, расположенные в меню Layer (Слой) и показанные на рис. 1.34, позволяют добавлять, копировать, удалять, изменять, группировать, менять порядок следования слоев в стеке, управлять взаимным расположением связанных слоев, объединять слои, добавлять к ним маски и превращать изображение в один единственный слой. Доступ к некоторым командам можно получить быстрее, воспользовавшись меню палитры Layers (Слои). .

Рис. 1.33. Меню Image

Рис. 1.34. Меню Layer

Рис. 1.35. Меню Select

Рис. 1.36. Меню Filter

Меню Select

Команда All (Все) из меню Select (Выделить) - рис. 1.35 - выделяет весь слой целиком. Команда же Deselect (Снять выделение), наоборот, снимает выделение со всех ранее выделенных областей. Команда Reselect (Восстановить выделение) опять выделяет ту область, к которой была применена последняя команда Deselect. Команда Color Range (Диапазон цветов) создает выделение с учетом цвета. Другие команды этого меню расширяют, сжимают, сглаживают или растушевывают границы выделенной области, а также сохраняют выделенные области в каналах или загружают области из каналов.

Меню Filter

Меню Filter (Фильтр) содержит фильтры, выполняющие широкий диапазон операций по редактированию изображения и сгруппированные при помощи подменю (рис. 1.36). Фильтр Digimarc (Диджимак) вставляет в изображение невидимый для человеческого глаза знак авторского права.

По сравнению с предыдущей версией программы в это меню из меню Image перемещены две команды. Команда Extract (Извлечь) позволяет создавать выделенные области сложной формы. Команда Liquify (Исказить) сдвигает точки изображения в каком-либо направлении.

Меню View

Команды меню View (Вид), показанного на рис. 1.37, контролируют, что отображается и что не отображается на экране. Команда Gamut Warning (Предупреждение о гамме) выделяет те цвета, которые не будут выведены при четырехцветной печати. Команды подменю Proof Setup (Установки пробного отпечатка) позволяют увидеть, как будет выглядеть изображение при печати в различных режимах. Другие команды из меню View управляют масштабом изображения, а также выводят на экран линейки, координатную сетку, вспомогательные линии и области, на которые поделено изображение.

Меню Window

Команды из меню Window (Окно), которое представлено на рис. 1.38, управляют показом или скрытием различных палитр. В этом меню также расположен список открытых изображений, и любое из них можно сделать активным.

При работе в среде операционной системы Windows данное меню позволяет управлять взаимным расположением окон изображений и показать/спрятать строку состояния.

Меню Help

Команды из меню Help (Помощь) помогут вам получить доступ к руководству по программе Photoshop в интерактивном режиме, узнать последние новости от компании Adobe, подключиться к сайту Adobe Online или выполнить какие-либо другие действия с помощью подсказок, появляющихся на экране (рис. 1.39).

Рис. 1.37. Меню View

Рис. 1.38. Меню Рис. 1.39. Меню Help Window

Рис. 1.40 Отделение палитры от группы

Рис. 1.41. Новая самостоятельная палитра

При установке Photoshop 7 поверх прежних версий расположение палитр будет соответствовать внесенным ранее изменениям.

Палитры

Как пользоваться палитрами

Многие операции, производимые в программе Photoshop, выполняются с помощью палитр, которые можно перемещать. Для того чтобы не занимать большое пространство на экране, палитры по умолчанию соединены в группы: Navigator/Info (Навигация/Информация), Color/Swatches/ Styles (Цвет/Образцы/Стили), History/Actions/Tool Presets (История/Действия/Набор инструментов), Layers/Channels/Paths (Слои/Каналы/Контуры) и Character/Paragraph (Шрифт/Абзац).

Для того чтобы открыть какую-либо палитру, воспользуйтесь командой Window (Окно). Указанная палитра будет расположена поверх остальных, входящих в ту же группу.

Некоторые палитры открываются щелчком по кнопке Туре на панели опций, например Character/Paragraph при выбранном инструменте Туре (Текст). Нажмите клавишу Tab, чтобы показать/ скрыть все открытые палитры, включая и панель инструментов. Комбинация клавиш Shift+Tab позволяет показать/скрыть все открытые палитры за исключением панели инструментов.

Для того чтобы какая-либо палитра «всплыла» поверх остальных, расположенных в той же группе, щелкните по соответствующей вкладке (имени палитры). Палитру можно отделить от группы, перетащив ее вкладку (рис. 1.40,1.41), а также добавить в любую другую группу, перетащив вкладку и расположив ее поверх группы. С помощью манипулятора изменения размеров (нижний правый угол) можно увеличить размер палитры, если вы хотите, чтобы были видны дополниразмер любой палитры, кроме палитр Color (Цвет) и Info (Информация).

Для того чтобы свернуть/развернуть палитру, дважды щелкните по ее имени или один раз по соответствующей кнопке, расположенной в верхнем правом углу окна. Если размер палитры отличается от установленного по умолчанию, сначала щелкните по кнопке Minimize, чтобы восстановить размер палитры по умолчанию, затем щелкните еще раз, чтобы свернуть палитру.

Если в диалоговом окне Edit > Preferences > General (Правка > Установки > Общие) установлен флажок Save Palette Locations (Сохранять расположение палитр), палитры, открытые в момент выхода из программы Photoshop, появятся на том же месте при очередном запуске программы.

В любой момент можно восстановить группировку палитр по умолчанию, для этого необходимо воспользоваться командой Window > Workspace > Reset Palette Locations (Окно > Рабочее поле > Восстановить расположение палитр).

Чтобы быстро изменить значение какого-либо поля палитры или диалогового окна, щелкните по нему, а затем, нажимая клавишу со стрелкой, направленной вверх/вниз, увеличьте/уменьшите значение параметра.

Всплывающий ползунок

Всплывающий ползунок можно использовать двумя способами (рис. 1.42): утопите кнопку со стрелкой и перетащите ползунок, не отпуская кнопку мыши, либо просто щелкните по шкале, и ползунок переместится в указанную позицию. Чтобы закрыть панель ползунка, щелкните мышью где-либо вне ее либо нажмите клавишу Enter. Если вы щелкнули по кнопке со стрелкой, чтобы открыть панель ползунка, можно нажать клавишу Esc, и ползунок примет положение, заданное последним.

Рис. 1.42. Всплывающая панель ползунка

Палитра Color

Палитра Color (Цвет), изображенная на рис. 1.43, предназначена для смешивания и выбора цветов. Цвета применяются к изображению с помощью какого-либо инструмента рисования или правки либо команд, например, Fill (Залить) или Canvas Size (Размер холста). Из меню палитры выберите цветовую модель/Смешать цвета можно, передвигая ползунки. Чтобы быстро выбрать цвет, просто щелкните по панели с образцами, расположенной внизу палитры Color.

Для того чтобы открыть панель Color Picker (Выбор цвета), где также можно выбрать цвет, щелкните один раз по квадратику фонового или основного цвета, если он в данный момент является активным, либо дважды, если он не активен.

Рис. 1.43. Палитра Color и ее меню

Палитра Swatches

Палитра Swatches (Образцы) - она изображена на рис. 1.44 - используется в том случае, если вы хотите выбрать готовые цвета. Отдельные образцы можно добавлять или удалять из палитры. Команды меню этой палитры также позволяют загрузить, присоединить и сохранить палитры цветов, определенные пользователем.

Рис. 1.44. Палитра Swatches и ее меню

Палитра Styles

Палитра Styles (Стили), показанная на рис. 1.45, используется в случае, когда нужно применить сохраненные прежде определенные эффекты или их сочетание. Ранее такая возможность уже была в программе ImageReady, теперь она есть и в программе Photoshop.

Палитра Navigator

С помощью палитры Navigator (Навигация), приведенной на рис. 1.46, можно выбрать видимый в окне фрагмент изображения или изменить масштаб такого фрагмента.

Рис. 1.45. Палитра Styles и ее меню

Рис. 1.46. Палитра Navigator и ее меню

Палитра Info

На палитре Info (Информация) отображаются цветовые компоненты пиксела, на который в данный момент указывает курсор (рис. 1.47а). Также здесь располагаются данные о цветовых образцах (максимум четырех), выбранных на изображении (рис. 1.48). Если открыто диалоговое окно корректировки цвета, то на палитре будут отображаться сведения о цветовых образцах до и после модификации. Кроме того, здесь показываются координаты х и у курсора на изображении (рис. 1.49в).

На палитре может отображаться и другая информация в зависимости от того, какой инструмент активизирован: например, расстояние между точками при перемещении выделенной области, при построении фигуры или при использовании инструмента Measure (Измеритель); размеры выделенной области или рамки, по которой будет обрезано изображение (рис. 1.47в); или ширина (W), высота (Н), угол (А), вертикальный (V) и горизонтальный (Н) наклон при трансформации выделенной области (рис. 1.49б). Чтобы выбрать единицы измерения для линеек, щелкните по стрелке, показанной на рис. 1.476.

Щелкните по стрелке (рис. 1.49а) и, не отпуская кнопки мыши, выберите режим для представления выводимых данных: Actual Color (текущий режим изображения), Proof Color, Grayscale, RGB, Web, HSB, CMYK, Lab Color, Total Ink или задайте значение параметра Opacity (Непрозрачность) текущего слоя. Режим представления данных о цвете, установленный для палитры, может отличаться от режима текущего изображения.

Рис. 1.47. Палитра Info

Рис. 1.48. Данные о цвете образцов #1, #2

Если рядом с информацией о цвете стоит восклицательный знак, это значит, что цвет выходит за пределы палитры CMYK, то есть при печати поменяет свой оттенок.

Рис. 1.49. Палитра Info

Режим вывода данных о цвете или единицы измерения также можно выбрать в окне Info Options (Опции палитры Info). Доступ-к этому окну обеспечивает команда Palette Options (Опции палитры) в меню палитры.

Палитра Layers

Обычно при создании нового изображения его фон является непрозрачным. Палитра Layers (Слои) позволяет добавлять, удалять, показывать/скрывать, копировать, группировать, связывать и менять порядок следования слоев, расположенных поверх фона (рис. 1.50). Каждому слою может соответствовать свой собственный режим смешивания и уровень прозрачности, и каждый слой допускается редактировать, не изменяя при этом другие. Также со слоем можно связать маску (mask). Кроме стандартных слоев в программе Photoshop можно создать и два других вида слоев: корректирующий слой (adjustment layer), используемый для временного применения цвета или корректировки цвета слоев, расположенных под ним; и редактируемый текстовый слой (editable type layer), который автоматически создается при использовании инструмента Туре (Текст) или Vertical Type (Вертикальный текст). Если к слою применить эффект (например, Inner Glow (Внутреннее свечение), Drop Shadow (Отбросить тень)), рядом с именем слоя появится пиктограмма эффекта и кнопка вызова всплывающего меню.

Редактировать можно только текущий слой (также называемый выбранным или активным). Выбрать слой просто - достаточно щелкнуть по его имени на палитре Layers.

Для того чтобы самым нижним слоем нового изображения вместо непрозрачного фона стал прозрачный слой, установите флажок Transparent (Прозрачный) в группе Contents (Содержание) в диалоговом окне, вызываемом командой File > New (Файл > Новый).

Рис. 1.50. Палитра Layers

Палитра Channels

В палитре Channels (Каналы) отображается один или более каналов, которые и составляют изображение (рис. 1.51). Также с помощью этой палитры можно создать альфа-каналы, используемые для сохранения выделенных областей, и каналы заказных, или плашечных, цветов (spot color channel), необходимые при цветоделении.

Палитра Paths

Контур (path) представляет собой фигуру, состоящую из сегментов кривых и отрезков прямых линий, соединенных между собой узловыми точками. Есть два способа нарисовать контур: непосредственно с помощью любого из инструментов построения фигур или инструмента Реn (Перо) либо создав выделенную область, а затем преобразовав ее в контур. Контур можно залить или очертить. Для того чтобы с высокой точностью создать выделенную область заданной формы, лучше сначала нарисовать контур, а потом преобразовать его в выделенную область.

Рис. 1.51. Палитра Channels

Рис. 1.52. Палитра Paths

Рис. 1.53. Палитра History в линейном режиме

Инструмент Реп и родственные ему инструменты Add anchor point (Добавить узловую точку), Delete anchor point (Удалить узловую точку) и Convert point (Преобразовать точку) позволяют изменять форму контура. Сохранить контур и получить доступ к нему можно, используя палитру Paths (Контуры) - см. рис. 1.52.

Если выделен слой типа shape или слой изображения, с которым связан контур отсечения, то последний также будет отображен на палитре Paths.

Палитра History

С помощью палитры History (История) можно выборочно отменить одно или несколько действий по редактированию изображения (рис. 1.53). Каждый мазок кисти, применение фильтра и любая другая операция представлена в виде отдельного элемента в списке событий на данной палитре, при этом самое нижнее событие является и самым последним. Если щелкнуть по предыдущему событию, документ будет восстановлен до этого этапа редактирования. Что произойдет при выделении какого-то события, зависит от того, находится ли палитра в линейном режиме или нет.

В линейном режиме, если вы выделили, а затем удалили одно из предыдущих событий или возобновили редактирование изображения с более раннего события, все последующие события (на палитре их элементы станут тусклыми) также будут удалены. В нелинейном режиме можно выделить или удалить ранее происшедшее событие и при этом не потерять последующие. Эта опция включается/выключается с помощью флажка Allow Non-Linear History (Разрешить нелинейность событий) в окне History Options (Опции палитры History), вызываемом командой меню History Options. Линейный и нелинейный режимы палитры можно переключать в любой момент редактирования.

Инструмент History Brush (Восстанавливающая кисть) восстанавливает изображение до указанного события в той области изображения, где провели кистью. Инструмент Art History Brush (Художественная восстанавливающая кисть) производит такое же действие, но только штрихами определенного стиля.

Палитра Actions

Основным назначением палитры Actions (Действия) является автоматизация обработки изображений (рис. 1.54). Можно записать последовательность команд, а затем применить их к одному изображению или к целой группе изображений. Также палитра Actions позволяет задать и получить доступ к «горячим» клавишам для какого-либо действия.

Рис. 1.54. Палитра Actions

Палитра Character

В Photoshop 7 для того, чтобы создать текст, не нужно вызывать специальное диалоговое окно. Все операции по введению и редактированию текста можно выполнить с помощью палитры Character (Шрифт) - см. рис. 1.55. Характеристики шрифта также можно выбрать на панели опций инструмента Туре (Текст).

Палитра Paragraph

Палитра Paragraph (Абзац) позволяет применить к абзацам текста определенные характеристики, включая отступ первой строки и расстояние между абзацами (рис. 1.56).

Рис. 1.55. Палитра Character

Рив. 1.56. Палитра Paragraph

Выбор кисти

Форму кисти для инструментов рисования и редактирования нельзя выбрать в отдельной палитре. В Photoshop 7, чтобы открыть панель с образцами кистей, надо щелкнуть по стрелке поля Brush (Кисть) на панели опций соответствующего инструмента (рис. 1.57). Загрузить, добавить и сохранить различные кисти и библиотеки кистей и редактировать уже существующие можно также посредством окна Brushes (Кисти), которое находится справа на панели опций в области для хранения палитр (рис. 1.58). Когда окно будет уже не нужно, достаточно щелкнуть мышью вне его либо снова щелкнуть по стрелке поля Brush, и оно закроется.

Число под образцом кисти определяет ее диаметр в пикселах.

Небольшой глоссарий

Текущий слой и прозрачность слоя

Слой, в данный момент выделенный на палитре Layers (Слои), - единственный, который можно редактировать. У изображения может быть либо только фон (никаких слоев), либо несколько слоев (рис. 1.59).

В слои могут быть включены эффекты (рис. 1.60), порядок следования слоев можно менять, слои можно перемещать; они прозрачны там, где нет изображения, что позволяет видеть сквозь целую стопку слоев. Одно из преимуществ использования слоев - возможность распределять компоненты изображения по отдельным слоям и редактировать их, не затрагивая другие слои.

Рис. 1.57. Панель выбора кисти

Рис. 1.58. Окно Brushes

Рис. 1.59. Слои изображения

Корректирующий слой

В отличие от стандартного слоя изменение корректирующего слоя никак не отразится на изображении до тех пор, пока он не будет слит с расположенными ниже слоями (рис. 1.60). Корректирующие слои идеальны для экспериментов с цветом. Любой из корректирующих слоев влияет только на слои, расположенные ниже него.

Рис. 1.60. Корректировка цвета с помощью команды Levels

Пикселы

Точки, составляющие растровое изображение на экране компьютера, называются пикселами (рис. 1.61).

Векторные объекты

В программе Photoshop 7 редактируемый текст и фигуры, как и растровые изображения, автоматически располагаются в своих собственных слоях, но эти слои векторные (рис. 1.62). Общее разрешение файла может быть сохранено на том уровне, который подходит для растрового изображения; векторные элементы будут выводиться на печать в соответствии с разрешением печатающего устройства.

Выделенная область

Выделенная область представляет собой фрагмент изображения, изолированный специальной рамкой, поэтому его можно изменять, не затрагивая оставшуюся часть изображения (рис. 1.63).

Рис. 1.61. Изображение, увеличенное в пять раз

Рис. 1.62. Векторные слои

Рис. 1.63. Выделение области изображения

Рис. 1.64. Окно Image Size

Перемещаемая рамка определяет границы выделенной области. Если передвинуть выделенный фрагмент изображения, то область, соответствующая вырезу, будет залита фоновым цветом, если выделенная область была расположена непосредственно над фоном, либо будет прозрачной, если ниже находится очередной слой. Выделенную область можно создать с помощью инструментов выделения (например, Lasso (Лассо) или Magic Wand (Волшебная палочка)) или с помощью команды выделения (например, Color Range (Диапазон цветов)). Также можно преобразовать контур в границу выделения или загрузить маску, содержащуюся в альфа-канале, в виде выделенной области.

Разрешение

Разрешение изображения - это число пикселов, содержащихся в изображении; разрешение измеряется в пикселах на дюйм. Опции окна Image Size (Размер изображения) позволяют изменить размеры изображения, а также его разрешение (рис. 1.64).

Разрешение монитора также измеряется в пикселах на дюйм. Свое собственное разрешение, измеряемое в точках на дюйм, есть и у устройств вывода.

Размер файла

Размер файла любого изображения измеряется в байтах, килобайтах, мегабайтах или гигабайтах.

Размеры

Изображение имеет размеры - ширину и высоту.

Характеристики цвета

Цвет имеет тон, яркость и насыщенность, которые можно задать в окне выбора цвета (рис. 1.65). Тон определяется длиной световой волны, дающей название цвету, например красный или синий, вне зависимости от яркости и насыщенности. Насыщенность характеризует чистоту цвета. Чем больше серого содержит цвет, тем ниже его насыщенность.

Построение изображения с помощью слоев

Можно работать с одним слоем, не влияя при этом на остальные, а также скрыть или удалить те слои, которые не нужны. Для того чтобы сэкономить память при работе с большим изображением, периодически объединяйте два или более слоев (рис. 1.66).

При использовании маски слоя или контура отсечения можно временно спрятать точки отдельного слоя, что позволяет экспериментировать с различными композициями. Если вы закончили работу с маской слоя, можно ее удалить или применить данный эффект к слою.

Быстрота перерисовки

Для того чтобы ускорить процесс обработки изображения, выберите команду Palette Options (Опций панели) из меню палитр Layers/Channels/Paths (Слои/Каналы/Контуры), затем в группе Thumbnail Size (Размер миниатюры) установите переключатель в положение None (Нет) либо выберите наименьший размер миниатюры (рис. 1.67).

Рис. 1.65. Окно выбора цвета в программе Photoshop

Рис. 1.66. Создание изображения при помощи слоев

Рис. 1.67. Выбор размера миниатюры

Методы создания изображения

  • Чтобы отменить последнюю операцию, воспользуйтесь командой Edit > Undo (Правка > Отменить) или сочетанием клавиш Ctrl+Z. Имейте в виду, что некоторые команды отменить нельзя. Для того чтобы отменить несколько шагов, щелкните по предшествующему событию на палитре History либо с помощью инструмента History Brush восстановите определенные области изображения.
  • Периодически щелкайте по кнопке Create new snapshot (Создать новый снимок), расположенной на палитре History, чтобы сохранять версии изображения. Если вы хотите вернуться к соответствующей версии изображения, щелкните по миниатюре снимка.
  • Воспользуйтесь корректирующим слоем, чтобы поэкспериментировать с раз личными цветами, а затем объедините корректирующий слой с нижним, тем самым зафиксировав полученный эффект, либо удалите корректирующий слой. С помощью ползунка Opacity (Непрозрачность), расположенного на палитре Layers, можно ослабить эффект применения корректирующего слоя. Чтобы ограничить действие корректирующего слоя тем, который расположен непосредственно под ним, создайте отсекающую группу (clipping group), включающую слой, расположенный непосредственно под корректирующим.
  • С помощью команды Edit > Fade (Правка > Ослабить) или сочетания клавиш Ctrl+Shift+F можно ослабить эффект от последнего примененного фильтра, команды корректировки или инструмента редактирования без использования команды повторного действия или отмены; при выполнении команды Fade выберите нужный вам режим смешивания и уровень непрозрачности.
  • Для того чтобы прервать перерисовку экрана после применения команды или фильтра, выберите другой инструмент или команду (если хотите отменить команду, пока отображается индикатор выполнения, просто нажмите клавишу Esc).
  • Выберите наименьшее возможное разрешение и размеры изображения с учетом требований к качеству печати. Можно создать образец изображения с меньшим разрешением, сохраняя используемые команды в виде действия, а затем воспроизвести действие для этого же изображения с более высоким разрешением. Помните, что векторные слои (слои редактируемого текста и фигур) при печати имеют разрешение печатающего устройства, а не разрешение документа.
  • Одновременно отображайте изображение в двух окнах, большом и маленьком, чтобы вам не приходилось постоянно
  • изменять его масштаб.
  • Сохраняйте сложные выделенные области в специальных полутоновых каналах, называемых альфа-каналами (alpha channel), которые можно в любой момент загрузить и использовать в каком-либо изображении. Или создайте контур или отсекающий контур - они занимают гораздо меньше дискового пространства, чем альфа-канал. Впоследствии их можно будет преобразовать в границы выделенной области.
  • Воспользуйтесь режимом Quick Mask (Быстрая маска), чтобы преобразовать выделенную область в маску, которая оставляет защищенные области изображения видимыми, а незащищенные области закрывает, затем с помощью инструмента рисования можно будет изменять форму маски. Выключите режим Quick Mask, если хотите преобразовать закрытую область обратно в выделенную.

Рис. 1.68. Подменю Purge

  • Так как CMYK-файлы обрабатываются медленнее, чем RGB-файлы, воспользуйтесь командой Proof Setup > Working CMYK (Установки пробного отпечатка > Рабочий CMYK), чтобы иметь возможность предварительно просматривать изображение в режиме CMYK, а при окончании работы с изображением преобразуйте его в полноценное представление типа CMYK.
  • Запомните как можно больше «горячих» клавиш. Начните изучение с «горячих» клавиш для выбора инструментов (см. раздел «Панель инструментов» выше в этой главе). Для справки используйте всплывающие подсказки либо обращайтесь к списку «горячих» клавиш, расположенному в конце книге. «Горячие» клавиши указаны и в большинстве приведенных в книге инструкций.
  • Постарайтесь выделить не менее 60 Мб оперативной памяти для программы Photoshop или в 4 раза больше, чем размер документа.
  • Периодически используйте команды подменю Edit > Purge (Правка > Очистить), чтобы освободить оперативную память, занятую для работы с Clipboard (Буфер обмена), команды Undo (Отмена), палитры History (История) или для всего вышеперечисленного All (Все) - рис. 1.68. Команды подменю Purge отменить нельзя.

Экономия времени при помощи контекстных меню

Для того чтобы выбрать команду из контекстного меню, щелкните правой кнопкой мыши по миниатюре, имени или какой-либо характеристике, расположенной на палитре Layers/Channels/Paths (рис. 1.69).

Либо выберите инструмент, затем, наведя курсор на изображение, щелкните правой кнопкой мыши, чтобы выбрать команды или опции данного инструмента (рис. 1.70, 1.71).

Рис. 1.69. Контекстное меню

Рис. 1.70. Выбор кисти

Рис. 1.71. Выбор команды для инструмента выделения


  • Глава 10. Выбор цвета
    • Основной и фоновый цвет
      • Выбор цветов с помощью панели Color Picker
      • Цвет, определяемый пользователем
      • Выбор цвета с помощью палитры Color
      • Выбор цвета на палитре Swatches
      • Добавление образцов в палитру Swatches
      • Удаление цвета с палитры Swatches
      • Сохранение библиотеки образцов
      • Замена, расширение и загрузка библиотеки образцов
      • Выбор цветов на изображении с помощью инструмента Eyedropper
      • Копирование цвета в виде шестнадцатеричной величины

Глава №10.

Выбор цвета

Рис. 10.1. Основной и фоновый цвета на панели инструментов

Рис. 10.2. Палитра Color

В этой главе вы узнаете, как выбирать цвета. Цвета используются при работе различных инструментов рисования и редактирования, а также при выполнении некоторых команд.

Основной и фоновый цвет

При использовании какого-либо инструмента рисования, создании текста или выполнении команды Stroke (Обводка) применяется текущий основной цвет (fore-groundcolor).

При использовании инструмента Eraser (Ластик), увеличении размера холста или перемещении выделенной области, расположенной на фоне, с помощью инструмента Move (Перемещение) открывшийся участок автоматически заливается текущим фоновым цветом (background color). Инструмент Gradient (Градиент) смешивает различные цвета, в том числе основной и/или фоновый.

Основной и фоновый цвета представлены на панели инструментов в виде квадратиков соответствующего цвета (рис. 10.1), а также на палитре Color (Цвет) - см. рис. 10.2.

Есть несколько способов выбора основного и фонового цветов, и они описываются в следующих разделах:

  • введите значения в определенные поля или щелкните по большому цветному квадрату на панели выбора цветов;
  • в диалоговом окне Custom Colors (Цвета по выбору пользователя) выберите ранее определенную систему цветов;
  • введите значения в числовые поля или передвиньте ползунки на палитре Color (Цвет);
  • щелкните по образцу цвета на палитре Swatches (Образцы);
  • с помощью инструмента Eyedropper (Пипетка) выберите цвет на изображении.

Выбор цветов с помощью панели Color Picker

  1. Чтобы выбрать цвет, на панели инструментов щелкните по квадратику основного или фонового цвета.

    Можно также щелкнуть по квадратику основного или фонового цвета на палитре Color (Цвет), если квадратик уже активен (обведен двойной рамкой), в противном случае потребуется двойной щелчок.

Если квадратик, по которому вы щелкнули, содержит цвет, определенный пользователем, то появится диалоговое окно Custom Colors (Цвет по выбору пользователя). Щелкните по кнопке Picker (Выбор), чтобы открыть диалоговое окно Color Picker (Выбор цвета).

  2. По желанию. В окне выбора цветов поставьте флажок Only Web Colors (Только Web-цвета), чтобы были доступны только цвета, пригодные для вывода в сеть.
  3. Щелкните по какому-либо цвету на вертикальной полосе со скользящим указателем, чтобы выбрать основной тон, затем щелкните по оттенку тона в большом квадрате (рис. 10.3).

    Чтобы указать определенный цвет при выводе на печать, введите точные значения в поля С, М, Y и К в процентах.

    Если требуется вывод на экран, введите значения (от 0 до 255) для компонентов R, G и В. Если везде ввести 0, получится черный цвет; если же везде ввести 255 -белый. Также можно ввести числа в поля Н, S, В или L, а, Ь.

  4. Щелкните по кнопке ОК.

Для вызова панели выбора цветов выполните команду Edit > Preferences > General (Правка > Установки > Общие) или нажмите комбинацию клавиш Ctrl+K. В открывшемся диалоговом окне в поле Color Picker (Выбор цветов) выберите вариант Adobe. В этом же всплывающем меню содержится вариант Windows. Одновременно можно получить доступ только к одной панели.

Цвет, не входящий в гамму

Восклицательный знак на панели выбора цвета (рис. 10.4) или на палитре Color (Цвет) указывает, что для данного оттенка нет сочетания основных цветов, то есть цвет не входит в печатаемую гамму цветов. Если вы собираетесь распечатать изображение, выберите цвет, входящий в гамму, или щелкните по восклицательному знаку, и программа Photoshop заменит данный цвет ближайшим (его демонстрирует образец, расположенный под восклицательным знаком). Если перевести изображение в режим CMYK, все цвета будут преобразованы так, чтобы они входали в печатаемую гамму. Диапазон не входящих в гамму цветов определен профилем вывода CMYK, который установлен в данный момент в диалоговом окне Color Settings (Характеристики цвета).

Рис. 10.3. Диалоговое окно Color Picker

Рис. 10.4. Восклицательный знак на палитре Color Picker

Рис. 10.5. Диалоговое окно Custom Colors

Цвет, определяемый пользователем

Обычно программа Photoshop разделяет все цвета в изображении на четыре основных цвета независимо от того, составлен ли цвет из основных или является заказным (spot color). Для того чтобы отделить заказной цвет, необходимо создать специальный цветовой канал (см. главу 11, раздел «Создание канала заказного цвета»).

Не полагайтесь на то, что монитор точно воспроизведет заданную систему цветов, необходимо выбирать образцы из официально изданных справочников PANTONE, TRUMATCH, TOYO, DIG, FOCOLTONE или ANPA. Но прежде, чем сделать это, выясните, какой марки чернила в вашем принтере.

Для вывода в сеть можно выбрать шест-надцатеричные цвета (HKS E, HKS К, KHS N и KHS Z).

  1. На панели инструментов щелкните по квадратику основного или фонового цвета. Или щелкните по квадратику основного или фонового цвета на палитре Color (Цвет), если этот цвет активен. В противном случае Щелкните по нему дважды.

Если цвет, по квадратику которого вы щелкнули, не относится к числу определенных пользователем, откроется диалоговое окно Color Picker (Выбор цветов). Щелкните по кнопке Custom (Пользовательский), чтобы открыть диалоговое окно Custom Colors (Цвета по выбору пользователя).

  2. Из всплывающего меню Book (Книга), . показанного на рис. 10.5, выберите подходящую систему цветов.
  3. Введите какое-либо число или щелкните по какому-либо цвету на вертикальной панели, затем щелкните по образцу (см. рис. 10.5).
  4. По желанию. Щелкните по кнопке Picker, чтобы вернуться к диалоговому окну Color Picker (Выбор цветов).
  5. Щелкните по кнопке ОК.

О том, как загрузить систему цветов на палитру Swatches (Образцы), рассказано ниже, в раздел «Загрузка библиотеки образцов».

Выбор цвета с помощью палитры Color

  1. Щелкните по квадратику основного или фонового цвета, если он еще не активен (рис. 10.6).
  2. Из меню палитры Color (Цвет) выберите цветовую модель, определяющую вид ползунков.

    Передвиньте любой из ползунков (см. рис. 10.6) или введите какие-либо значения в цифровые поля. Можно также щелкнуть по цветной полосе, расположенной внизу палитры, или протащить по ней курсор.

В модели RGB белый цвет получается тогда, когда все ползунки находятся в самом правом положении, черный - в самом левом положении, а серый цвет создается, когда все ползунки выровнены по вертикали в любом другом положении.

Щелкните правой кнопкой мыши по цветной полосе внизу палитры Color (Цвет), чтобы из контекстного меню выбрать другой спектр цветов.

Рис. 10.6. Палитра Color

Цветоделение

Чтобы выполнить цветоделение для изображения, созданного в программе Photoshop и содержащего канал заказного цвета, с помощью программ QuarkXPress, InDesign, Illustrator или FreeHand, сначала преобразуйте файл в режим CMYK и сохраните его в формате Photoshop DCS 2.0 (см. главу 22, раздел «Сохранение изображений в формате DCS 2.0»). Если вы используете в канале заказного цвета образец из каталога Pantone, выполните команду Edit > Preferences > General (Правка > Установки > Общие) или нажмите комбинацию клавиш Ctrl+K.

Рис. 10.7. Создание нового образца цвета

Рис. 10.8. Удаление образца

Для того чтобы восстановить вид палитры Swatches (Образцы), установленный по умолчанию, из меню палитры выберите пункт Reset Swatches (Восстановить образцы), затем щелкните по кнопке ОК.

Если вы изменили палитру Swatches (Образцы), затем вышли из программы Photoshop и запустили ее заново, будет открыта отредактированная палитра.

Нажмите клавишу Alt и щелкните по цветной полосе, чтобы выбрать цвет для невыделенного квадратика цвета.

Цвета на панелях, вдоль которых движутся скользящие указатели, будут меняться при перетаскивании курсора. Для того чтобы выключить эту опцию, в диалоговом окне Edit > Preferences > General (Правка > Установки > Общие) снимите флажок Dynamic Color Sliders (Динамические цветовые ползунки).

Выбор цвета на палитре Swatches

Для того чтобы выбрать цвет для активного квадратика цвета, просто щелкните по образцу.

При выборе цвета неактивного квадратика нажмите клавишу Ctrl и щелкните по образцу.

Добавление образцов в палитру Swatches

  1. Смешайте какой-либо цвет, используя палитру Color (Цвет).
  2. Откройте вкладку Swatches (Образцы).
  3. Поместите курсор над пустой областью после всех образцов, расположенных на палитре, и щелкните мышью (курсор примет тот же вид, что и при активизации инструмента заливки) — см. рис. 10.7. Новый цвет появится рядом с последним образцом.
  4. Введите какое-либо имя и щелкните по кнопке ОК.

Для замены существующего образца новым нажмите клавишу Shift и щелкните по образцу, который необходимо заменить.

Удаление цвета с палитры Swatches

Нажмите клавишу Alt и щелкните по какому-либо образцу (курсор примет вид ножниц)-см. рис. 10.8.

Сохранение библиотеки образцов

  1. Из меню палитры Swatches (Образцы) выберите команду Save Swatches (Сохранить образцы).
  2. В поле Name (Имя) введите имя библиотеки (рис. 10.9).
  3. Выберите папку, в которой будет сохранена библиотека (обратите внимание на папку, принимаемую по умолчанию, название которой указано слева) и щелкните по кнопке Save(Сохранить).

Замена, расширение и загрузка библиотеки образцов

Можно загрузить любую из стандартных библиотек цветовых образцов, которые поставляются вместе с программой Photoshop, или любую палитру, которую вы сами создали с помощью палитры Swatches (Образцы). Можно или заменить существующую библиотеку новой или добавить новую библиотеку к уже существующей.

Если вы хотите увеличить размеры палитры так, чтобы были видны вновь загруженные образцы, перетащите границу палитры или щелкните по кнопке масштабирования.

Чтобы найти и открыть библиотеку образцов, которая не расположена в стандартной папке Adobe Photoshop 7.0/Presets/Color Swatches или в папке Color Swatches/Adobe Photoshop Only (рис. 10.10,10.11), воспользуйтесь командой Load Swatches (Загрузить образцы).

Рис. 10.9. Сохранение библиотеки образцов

Рис. 10.10. Загрузка стандартных систем цветов

Рис. 10.11. Выбор цвета с помощью инструмента Eyedropper

Рис. 10.12. Размер области, на которой выбирает цвет инструмент Eyedropper

Для изменения области, с которой инструмент Eyedropper (Пипетка) выбирает цвета, на панели опций (рис. 10.12) укажите значение параметра Sample Size (Размер пробы): Point Sample (Точка) - тот пиксел, по которому вы щелкаете, 3 by 3 Average или 5 by 5 Average - среднее значение цвета в пределах области 3x3 или 5x5 пикселов. Если активизировать инструмент Eyedropper (Пипетка) и щелкнуть правой кнопкой мыши в окне изображения, эти опции можно выбрать из контекстного меню.

Нажмите клавишу Alt и щелкните или перетащите курсор в окне изображения при активизированном инструменте Eyedropper (Пипетка), чтобы выбрать фоновый цвет, когда активен квадратик основного цвета, или основной цвет, если активен квадратик фонового цвета.

  1. Для загрузки библиотеки образцов из меню палитры Swatches (Образцы) выберите команду Load Swatches (Загрузить образцы).
  2. Найдите и выделите библиотеку образцов, которую хотите открыть.
  3. Щелкните по кнопке Load (Загрузить). Загруженные образцы появятся ниже существующих на палитре Swatches (Образцы). .

Для возврата палитры, установленной по умолчанию, из меню палитры выберите команду Reset Swatches (Восстановить образцы). Щелкните по кнопке Append (Присоединить), чтобы добавить новую библиотеку к текущей, или по кнопке ОК, чтобы заменить текущее содержимое палитры новой библиотекой образцов.

Выбор цветов на изображении с помощью инструмента Eyedropper

  1. На палитре Color (Цвет) щелкните по квадратику основного или фонового цвета, если он неактивен.
  2. В любом открытом окне изображения щелкните по какому-либо цвету (см. рис. 10.11). Также можно перетащить курсор над цветовой областью, чтобы предварительно просмотреть ее цвета (следите за изменением цвета на панели инструментов или палитре Color (Цвет)), затем отпустить кнопку мыши, когда курсор будет расположен над желаемым цветом. Составляющие выбранного цвета будут отображаться на палитре Info (Информация).

Копирование цвета в виде шестнадцатеричной величины

Цвета могут быть скопированы в виде шес-тнадцатеричных величин из файла в программе Photoshop или ImageReady, а затем вставлены в HTML-файл. Далее рассказано о двух способах копирования.

Первый способ:

  1. Активизируйте инструмент Eyedropper (Пипетка), нажав клавишу I.
  2. Photoshop: щелкните правой кнопкой мыши по цвету в окне изображения, затем выберите элемент меню Сору Color as HTML (Копировать цвет как HTML).

    ImageReady, щелкните по цвету изображения, который вы хотите копировать (он станет основным цветом). Не перемещая курсор инструмента Eye-dropper (Пипетка), щелкните правой кнопкой мыши по изображению и из контекстного меню выберите элемент Copy Foreground Color as HTML (Копировать основной цвет как HTML).

    Выделенный цвет будет занесен в буфер обмена в виде шестпадцатеричпой величины.

  3. Для того чтобы вставить цвет в HTML-файл, в программе редактирования HTML-файлов отобразите этот файл, затем выберите команду Edit О Paste (Правка > Вставить). Допускается вставить код в любой элемент HTML, если у элемента может быть собственный цвет.

Второй способ:

  1. С помощью палитры Color (Цвет), панели выбора цветов или палитры Swatches (Образцы) выберите основной цвет.
  2. Photoshop: из меню палитры Color (Цвет) выберите команду Copy Color as HTML (Копировать цвет как HTML).

    ImageReady, выберите команду Edit Copy Foreground Color as HTML (Правка > Копировать основной цвет как HTML). Основной цвет будет помещен в буфер обмена в виде шестнадцатеричной величины.

  3. Для того чтобы вставить цвет в HTML-файл, откройте целевое приложение, отобразите этот файл и выберите команду Edit > Paste (Правка > Вставить).


  • Глава 11. Раскрашивание
    • Основные сведения о командах корректировки
      • Заливка выделенной области или слоя каким-либо цветом, узором или изображением
      • Очерчивание выделенной области или слоя
      • Корректировка цвета изображения с помощью команды Hue/Saturation
      • Размещение цветовых меток на изображении
      • Вид палитры Info при работе с инструментом Color Sampler
      • Удаление цветовой метки
      • Замена цвета
      • Тонирование или коррекция цвета с помощью команды Color Balance
      • Корректировка цвета с помощью миниатюры в диалоговом окне Variations
      • Изменение насыщенности цвета с помощью инструмента Sponge
      • Использование команды Channel Mixer
    • Команды Curves и Levels
      • Коррекция цвета с помощью команды Curves
      • Корректировка отдельных цветовых каналов с помощью команды Levels
      • Усиление цвета или подчеркивание силуэта изображения на черном слое
      • Преобразование цветового слоя в полутоновый и частичное восстановление цвета
      • Создание канала заказного цвета
      • Рисование в канале заказного цвета
      • Основные сведения о каналах заказного цвета
      • Печать изображения с каналами заказного цвета
      • Преобразование альфа-канала в канал заказного цвета

Глава №11.

Раскрашивание

В этой главе вы узнаете, как заполнить выделенную область каким-либо цветом, узором или рисунком; как очертить выделенную область или слой; настроить цвет изображения с помощью команд Hue/ Saturation (Тон/Насыщенность), Color Balance (Баланс цвета), Variations (Вариации), Curves (Кривые) и Levels (Уровни); как воспользоваться инструментом Color Sampler (Цветовая проба), чтобы получить данные о нескольких цветах; изменить цвет с помощью команды Replace Color (Заменить цвет); сделать цветное изображение черно-белым; увеличить или уменьшить насыщенность цвета с помощью инструмента Sponge (Губка); смешать каналы, используя команду Channel Mixer (Смеситель каналов); применить слой нейтрального цвета, чтобы подчеркнуть цвета изображения; раскрасить полутоновое изображение; создать и распечатать каналы заказных цветов.

Прежде чем .корректировать цвет, убедитесь, что произведена калибровка монитора (см. главу 2, раздел «Калибровка монитора»).

Основные сведения о командах корректировки

В каждом диалоговом окне, открываемом с помощью подменю Image > Adjustments (Изображение > Корректировки), можно включить режим предварительного просмотра. Вносимые изменения сразу же становятся видны на изображении или выделенной области, если стоит флажок Preview (Предварительный просмотр) - см. рис. 11.1.

Пока открыто диалоговое окно, можно нажать клавиши Ctrl+«пробел» и щелкнуть по изображению, чтобы увеличить его масштаб. Если нажать клавиши Аlt+«пробел» и щелкнуть по изображению, то его масштаб будет уменьшен, если же просто нажать клавишу пробела, то изображение можно будет перемещать в окне.

Многие из команд подменю Adjustments (Корректировки) можно применить посредством корректирующего слоя (adjustment layer) - см. рис. 11.2. В отличие от обычного метода, где затрагивается только активный слой, корректирующий слой влияет на все расположенные ниже слои. Однако корректирующий слой на самом деле не изменяет пикселов изображения до тех пор, пока не будет слит с нижележащим слоем.

В этой главе говорится только об использовании корректирующих слоев, а о том, как их создать, рассказано в главе 9, раздел «Корректирующие слои». Также можно использовать слой заливки (fill layer), чтобы применить однотонную окраску, градиент или узор (см. главу 7, раздел «Создание слоя заливки»). «Горячие» клавиши некоторых операций заливки перечислены в табл. 11.1.

Рис. 11.1. Корректировка цвета в режиме Preview

Рис. 11.2. Палитра Layers с расположенным на ней корректирующим слоем

В диалоговых окнах Levels (Уровни), Curves (Кривые), Replace Color (Заменить цвет), Selective color (Выборочный цвет), Hue/ Saturation (Тон/Насыщенность), Channel Mixer (Смеситель каналов) и Variations (Вариации) можно воспользоваться кнопкой Save (Сохранить), чтобы сохранить настройки, касающиеся корректировки цвета, а затем применить их к другому слою или изображению, щелкнув по кнопке Load (Загрузить) в том же диалоговом окне. Также любую команду подменю Adjustments (Корректировки) можно записать и применять в виде действия.

Некоторые команды корректировки, такие как Variations (Вариации), Color Balance (Баланс цвета) и Brightness/Contrast (Яркость/Контраст), изменяют все изображение. Другие команды, например Levels (Уровни), Curves (Кривые), Hue/Saturation (Тон/Насыщенность), Replace Color (Заменить цвет), Selective color (Выборочный цвет) и Channel Mixer (Смеситель каналов), позволяют более строго контролировать вносимые изменения, но их несколько сложнее использовать. Какую команду применить, зависит от характера изображения, с которым вы работаете, а также от. того, предполагается ли выполнять для него цветоделение или оно будет передаваться по сети. Слитком яркий цвет (например, синий или фиолетовый) будет бросаться в глаза на насыщенной предметами фотографии и может потребовать более тщательной корректировки цвета.

Для восстановления исходных значений параметров в диалоговом окне корректировки, если оно еще открыто, нажмите клавишу Alt и щелкните по кнопке Reset (Восстановить).

Заливка выделенной области или слоя каким-либо цветом, узором или изображением

  1. Для однотонной заливки основным или фоновым цветом выберите цвет на палитре Color (Цвет) или Swatches (Образцы) или щелкните по соответствующему квадратику состояния на палитре History (История), чтобы создать, источник информации для инструмента History Brush (Восстанавливающая кисть).

    Для создания повторяющегося узора не надо делать что-либо особенное -просто выберите готовый подходящий образец. Если же вы хотите создать собственный образец «черепицы», с помощью инструмента Rectangular Marquee (Прямоугольная область) выделите какую-либо область слоя (никакого растушевывания!), выберите команду Edit > Define Pattern (Правка > Определить узор), как показано на рис. 11.3, введите имя и воспользуйтесь командой Deselect (Снять выделение) или нажмите комбинацию клавиш Ctrl+D.

Таблица 11.1. «Горячие» клавиши для операций заливки изображения

Операции | «Горячие» клавиши
Залить основным цветом, 100% непрозрачность | Alt+Backspace
Залить фоновым цветом, 100% непрозрачность | Ctrl+Backspace
Залить видимые пикселы (непрозрачные области) основным цветом | Alt+Shift+Backspace
Залить видимые пикселы (непрозрачные области) фоновым цветом | Ctrl+Shift+Backspace
  2. Выберите слой. Чтобы залить его полностью, на палитре Layers (Спои) снимите флажок Lock transparent pixels (Блокировать прозрачные точки); если же хотите залить только непрозрачные области слоя, поставьте этот флажок. Для ограничения действия операции заливки создайте выделенную область с использованием любого метода выделения.
  3. Выполните команду Edit > Fill (Правка > Залить) или нажмите комбинацию клавиш Shift+Backspace.
  4. Из всплывающего меню Use (Используя) выберите, чем вы хотите залить выделенную область или слой (рис. 11.4): Foreground Color (Основной цвет), Background Color (Фоновый цвет), Black (Черный), 50% Gray (50% серый) или White (Белый). Если выберете вариант Pattern (Узор), щелкните по стрелке поля Custom Pattern (Узор по выбору пользователя) и на всплывающей панели укажите образец.

    Выберите вариант History (История), чтобы залить выделенную область или слой изображением с активного слоя того состояния, которое вы выбрали в качестве исходного.

  5. Укажите значения параметров Mode (Режим) и Opacity (Непрозрачность) в разделе Blending (Смешивание).
  6. По желанию. Если на палитре Layers (Слои) вы забыли поставить флажок Lock transparent pixels (Блокировать прозрачные точки), то вместо этого можно здесь поставить флажок Preserve Transparency (Сохранять прозрачность).
  7. Щелкните по кнопке ОК (рис. 11.5).

Рис. 11.3. Выделение области для использования в качестве повторяющегося узора

Рис. 11.4. Диалоговое окно Fill

Рис. 11.5. Результат заливки слоя узором

Рис. 11.6. Изображение, полученное путем дублирования узора с уменьшением непрозрачности копии до 43% и применения режима смешивания Multiply

Если вам не понравился выбранный вами цвет заливки, выполните команду Edit > Undo (Правка > Отменить), так чтобы этот цвет не смешивался со следующим выбранным и не влиял на режим, который вы установите.

Для заливки слоя с использованием какого-либо эффекта дважды щелкните по имени слоя, затем в диалоговом окне Layer Style (Стиль слоя) отметьте вариант Color Overlay (Наложение цвета), Gradient Overlay (Наложение градиента) или Pattern Overlay (Наложение узора). Подкорректируйте остальные характеристики. К одному и тому же слою можно применить один, два или все три эффекта типа Overlay.

Узоры

С помощью средств запоминания установок в программе Photoshop 7 очень просто сохранить узор, например, показанный на рис. 11.6, для последующего применения. Подробнее об установках рассказано в главе 21, раздел «Использование диалогового окна Preset Manager». Тем не менее, для большей безопасности постарайтесь сохранить файлы, которые вы использовали при создании узоров, на случай, если сведения об установках будут случайно удалены.

Для создания узора предназначена не только команда Fill (Залить). Также можно воспользоваться инструментами Pattern Stamp (Штамп узора), о чем рассказано в главе 6, раздел «Использование инструмента Pattern Stamp», или Paint Bucket (Ведро с краской).

Очерчивание выделенной области или слоя

  1. По желанию. Если вы хотите выбрать цвет для команды Stroke (Очертить) с помощью палитры Color (Цвет) или Swatches (Образцы), сделайте это сейчас. Если же вы предпочитаете выбрать цвет на панели Color Picker (Выбор цвета), то доступ к ней можно будет получить из диалогового окна Stroke (Очертить).
  2. Выберите слой. Если не хотите, чтобы граница проходила и по прозрачным областям, на палитре Layers (Слои) установите флажок Lock transparent pixels (Блокировать прозрачные точки) и на шаге 6 не ставьте переключатель Location (Положение) в положение Outside (Вне).

    По желанию. Выделите какую-либо область слоя.

  3. Выберите команду Edit > Stroke (Правка > Очертить).
  4. Введите какое-либо значение от 1 до 16 в поле Width (Ширина) - см. рис. 11.7.
  5. Если на шаге 1 вы не выбрали цвет очерчивания, щелкните по образцу в поле Color (Цвет) и выберите цвет на панели Color Picker.
  6. Поставьте переключатель Location (Положение) в положение Inside (Внутри), Center (По центру) или Outside (Вне), тем самым определив расположение очерчивающей линии относительно границы выделенной области или изображения слоя.
  7. Выберите значение параметра Mode (Режим смешивания) и величину Opacity (Непрозрачность) в процентах.
  8. Щелкните по кнопке ОК (рис. 11.8).

Рис. 11.7. Выбор опций в диалоговом окне Stroke

Рис. 11.8. Результат очерчивания кнопки белым цветом

Рис. 11.9. Окно параметров команды Hue/ Saturation в режиме Master

О том, как очертить контур, рассказано в главе 16, раздел «Обводка контура».

Также можно очертить контур с помощью эффекта слоя. Дважды щелкните по имени слоя, в диалоговом окне Layer Style (Стиль слоя) отметьте опцию Stroke (Очертить), подкорректируйте характеристики и щелкните по кнопке ОК.

Корректировка цвета изображения с помощью команды Hue/Saturation

  1. Выберите слой. По желанию. Выделите какую-либо область слоя, чтобы изменить цвет только этой области.
  2. Выполните команду Image > Hue/Saturation (Изображение > Тон/Насыщенность) (комбинация клавиш Ctrl+U (Windows) или Cmd+U (Mac OS)) или создайте корректирующий слой, выбрав пункт Hue/Saturation (Тон/Насыщенность) из всплывающего меню, которое вызывается с помощью кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).
  3. Из всплывающего меню Edit (Правка) выберите вариант Master (Мастер), чтобы настроить все цвета изображения сразу, либо выберите предварительно заданный диапазон, чтобы настроить только цвета, входящие в этот диапазон (рис. 11.9).
  4. Убедитесь, что стоит флажок Preview (Предварительный просмотр).
  5. Выполните любое из нижеследующих действий.

    Передвиньте ползунок Hue (Тон) влево или вправо, чтобы сдвинуть цвет в другую область панели цветов.

    Передвиньте ползунок Saturation (Насыщенность) влево, чтобы уменьшить насыщенность цветов, или вправо, чтобы увеличить.

    Для осветления изображения или слоя передвиньте ползунок Lightness (Яркость) вправо, а для затемнения - влево.

Чтобы разместить на изображении цветовые метки, выбранные с помощью инструмента Color Sampler (Цветовая проба), при открытом диалоговом окне Hue/Saturation (Тон/Насыщенность) выберите опцию Master (Мастер) в поле Edit (Правка), а затем нажмите клавишу Shift и щелкните по изображению (см. следующий раздел данной главы).

  6. Если из всплывающего меню Edit (Правка) был выбран заданный ранее диапазон цветов, становятся доступными ползунок корректировки и пипетки для выделения цвета (рис. 11.10). Можно воспользоваться ползунком корректировки, чтобы сузить или расширить диапазон цветов, на которые будут влиять опции Hue (Тон), Saturation (Насыщенность) и Lightness (Яркость).

    По умолчанию ползунок корректировки закрывает 90° цветового колеса: се: рые области справа и слева (области размытости) - по 30° каждая и темно-серая область (диапазон цветов) тоже занимает 30°.

    Выполните с ползунком корректировки любое из нижеследующих действий.

    Перетащите самую темную серую (центральную) область, чтобы переместить весь ползунок в другое место панели цветов; таким образом, будет изменен диапазон цветов (рис. 11.11). Соответственно поменяется всплывающее меню Edit (Правка), чтобы отразить изменение цветового диапазона.

Рис. 11.10. Окно параметров команды Hue/ Saturation в режиме, отличном от режима Master

Рис. 11.11. Перемещение ползунка корректировки в другой диапазон цветов

Рис. 11.12. Сужение диапазона цветов за счет перемещения вертикальной белой полоски

Рис. 11.13. Расширение диапазона цветов путем сдвига области размытости без изменения последней

Рис. 11.14. Расширение области размытости без изменения диапазона цвета путем перетаскивания треугольника

Рис. 11.15. Перемещение панели цветов

Перетащите любую из двух вертикальных белых полосок, чтобы сузить или расширить диапазон цветов. Сужение диапазона вызывает увеличение областей размытости и наоборот (рис. 11.12).

Перетащите любую из двух серых областей, чтобы сузить или расширить диапазон цветов, не затрагивая область размытости (рис. 11.13). Перетащите внешние треугольники, чтобы изменить долю текущего диапазона цветов, которая будет размываться с переходом в соседние цвета (рис. 11.14). Перетащите треугольник наружу, чтобы увеличить область размытости, или внутрь, чтобы уменьшить ее.

Очень узкая область размытости может вызвать эффект Dither (Интерполяция растра с использованием близких цветов).

Нажмите клавишу Ctrl и перетащите панель цветов, чтобы подкорректировать расположение на ней различных оттенков (рис. 11.15). Цвета будут переходить с одного конца панели на другой (они «закольцованы»). Это не повлияет на само изображение.

Если выбрать один из шести предустановленных диапазонов цветов и изменить положение ползунка, текущая корректировка цвета будет отражена во всплывающем меню Edit (Правка). Если, например, вы переместите ползунок Red (Красный) так, что он захватит немного желтых оттенков, в меню будут присутствовать Yellow (Желтый) и Yellow 2 (Желтый 2), но не будет пункта Red (Красный), так как теперь в диапазон Yellow включен и цвет Red.

Щелкните по какому-либо цвету в окне изображения - будут подкорректированы связанные с ним цвета. Либо воспользуйтесь пипеткой со знаком «+» или «—» и щелкните по изображению, чтобы добавить или удалить цвет из текущего диапазона цветов. Нажмите и удерживайте клавишу Shift, чтобы выбранная обычная пипетка временно выполняла функции пипетки добавления, или Alt - для превращения в пипетку удаления.

  7. Щелкните по кнопке ОК.

Для восстановления исходного состояния диалогового окна нажмите клавишу Alt и щелкните по кнопке Reset (Восстановить).

Размещение цветовых меток на изображении

Вместо инструмента Eyedropper (Пипетка), дающего информацию только об од--ной точке, можно воспользоваться инструментом Color Sampler (Цветовая проба), чтобы получить сведения о четырех точках изображения, называемых цветовыми метками. При корректировке цвета и тени до и после операции данные о цвете указанных точек будут отображаться на палитре Info (Информация). Также можно расставить цветовые метки в то время, как открыто какое-либо диалоговое окно корректировки цвета (для этого нажмите клавишу Shift и щелкните по изображению). Они сохраняются вместе с файлом, в котором были размещены.

  1. Активизируйте инструмент Color Sampler (Цветовая проба), нажав клавишу I или Shift+I

Тонирование цветного или полутонового изображения

В диалоговом окне Hue/Saturation (Тон/ Насыщенность) установите флажок Colorize (Тонировать), если хотите особым образом раскрасить текущий слой. Передвиньте ползунок Hue (Тон), чтобы выбрать цвет; ползунок Saturation (Насыщенность) - чтобы увеличить/уменьшить насыщенность цвета, и ползунок Lightness (Яркость) - чтобы осветлить или затемнить цвет изображения или слоя. По умолчанию во всплывающем меню Edit (Правка) выбран пункт Master (Мастер), когда включена опция Colorize (Тонировать). О создании двутоно-вого изображения рассказано в главе 22, раздел «Создание двутоновых изображений». Для раскраски полутонового изображения таким методом сначала преобразуйте его в режим RGB или CMYK.

Рис. 11.16. Размещение цветовых меток на изображении с помощью инструмента Color Sampler

  2. Щелкните по изображению для того, чтобы создать до четырех цветовых меток (рис. 11.16).

Если активизировать инструмент, отличный от инструмента Color Sampler (Цветовая проба), Eyedropper (Пипетка) или какого-либо инструмента рисования или редактирования, то цветовые метки исчезнут с экрана. Для того чтобы снова их увидеть, выберите один из вышеупомянутых инструментов или откройте какое-либо диалоговое окно с помощью подменю Adjustments (Корректировки). Если же вы хотите специально скрыть их, из меню палитры Info (Информация) выберите пункт Hide Color Samplers (Скрыть цветовые пробы).

Цветовые пробы дают информацию о самом верхнем видимом слое, содержащем непрозрачную точку в позиции, куда указывает курсор. Если спрятать слой, с которого берется проба, то информация будет взята со следующего слоя, расположенного ниже и содержащего непрозрачный пиксел в этой точке. Данные на панели Info (Информация) изменятся, если спрятать слой, с которого была взята проба.

Цветовые метки располагаются на холсте. Они не будут перемещены при трансформации или переворачивании слоя, но переместятся, если будет повернут холст целиком.

Перемещение цветовых меток

Активизируйте инструмент Color Sampler (Цветовая проба) с помощью клавиши I или Shift+I и перетащите метку или активизируйте инструмент Eyedropper (Пипетка), воспользовавшись той же «горячей» клавишей, и, нажав клавишу Ctrl, перетащите метку.

Вид палитры Info при работе с инструментом Color Sampler

На палитре Info (Информация) отображаются данные о пикселе или совокупности пикселов, расположенных под каждой цветовой меткой, до и после операции корректировки (рис. 11.17).

Размер области, из которой берется проба, зависит от значения параметра Sample Size (Размер пробы), установленного на панели опций инструмента Color Sampler (Цветовая проба) - см. рис. 11.18.

Выберите вариант Point Sample (Точка), чтобы брать в качестве пробы только цвет точки, расположенной непосредственно под курсором; выберите 3 by 3 Average или 5 by 5 Average, чтобы выбирать среднее значение цвета в области размером 3x3 или 5x5 пикселов. Если изменить значение этого параметра для инструмента Color Sampler (Цветовая проба), то оно также изменится и для инструмента Eyedrop-рег (Пипетка), и наоборот.

Чтобы выбрать модель цвета (например, Grayscale, RGB -и т.д.) для раздела палитры Info (Информация), щелкните по маленькой стрелочке рядом со значком пипетки и в появившемся всплывающем меню укажите желаемую модель (рис. 11.19). Actual Color (Действительный цвет) - это текущий цветовой режим изображения; Total Ink (Все краски) - процент CMYK-составляющих точки, расположенной под курсором, с учетом текущих установок цветовой модели CMYK. Модель, выбираемая для палитры Info (Информация), не обязательно должна совпадать с текущим режимом изображения. Также модель цвета можно указать в диалоговом окне Info Options (Опции палитры Info), которое открывается, если из меню палитры выбрать пункт Palette Options (Опции палитры).

Рис. 11.17. Данные о цветовых метках на палитре Info

Рис. 11.18. Выбор размера пробы на панели опций инструмента Color Sampler

Рис. 11.19. Выбор цветовой модели каждой цветовой пробы

Удаление цветовой метки

Активизируйте инструмент Color Sampler (Цветовая проба), затем, нажав клавишу Alt, щелкните по метке (курсор примет вид ножниц) или перетащите ее за пределы окна изображения. Раздел, содержащий информацию об этой метке, будет удален с палитры Info (Информация), а оставшиеся метки будут снова автоматически пронумерованы.

Можно также активизировать инструмент Eyedropper (Пипетка), а затем, нажав клавиши Alt+Shift (Windows) или Option+ Shift (Mac OS), щелкнуть, по цветовой метке.

Чтобы удалить все метки, щелкните по кнопке Clear (Очистить) на панели опций инструмента.

Замена цвета

Воспользуйтесь командой Replace Color (Заменить цвет), если хотите изменить цвета изображения, предварительно не выбирая их.

  1. По желанию. Для RGB-изображения выполните команду View > Proof Setup> Working CMYK (Вид > Установки пробного отпечатка > Рабочий CMYK), чтобы увидеть неконтрастный образец изображения и изменения, которые произойдут в режиме CMYK. (Образец цветовой пробы в диалоговом окне Replace Color (Заменить цвет) все еще будет отображаться в режиме RGB.) Эту команду можно выполнить, даже если диалоговое окно уже открыто.
  2. Выберите слой.
  3. По желанию. Создайте выделенную область, чтобы ограничить замену цветов только этим участком.
  4. Выполните команду Image > Adjustments > Replace Color (Изображение > Корректировки > Заменить цвет).
  5. Щелкните по цвету, который вы хотите заменить, либо в окне предварительного просмотра диалогового окна Replace Color (Заменить цвет), либо в самом окне изображения (рис. 11.20).

Изначально окно предварительного просмотра имеет сплошной черный цвет. Поставьте переключатель в положение Selection (Выделенная область), чтобы увидеть выделенную область в окне предварительного просмотра, или в положение Image (Изображение), чтобы отобразить все изображение целиком. Если изображение выходит за рамки монитора, поставьте переключатель в положение Image (Изображение), чтобы иметь возможность брать пробы цвета со всего изображения.

  6. По желанию. Передвиньте ползунок Fuz-ziness (Размытость) вправо, чтобы добавить в выделенную область фрагменты, цвет которых связан с выбранным цветом (рис. 11.20), или нажмите клавишу Shift и щелкните мышью в окне предварительного просмотра или окне изображения, чтобы добавить другие цветные области к выделению. Можно также активизировать инструмент Eyed-ropper+ (Пипетка+) и щелкать мышью, не нажимая клавишу Shift.

    Нажмите клавишу Alt и щелкните в окне предварительного просмотра или окне изображения, чтобы удалить цветные области из выделения. Либо активизируйте инструмент jfj Eyedropper-(Пипетка-) и щелкните мышью, не нажимая клавишу Alt.

Рис. 11.20. Окно команды Replace Color

Рис. 11.21. Исходное изображение

Рис. 11.22. Результат корректировки параметра Lightness фона изображения

  7. Передвиньте ползунки Hue (Тон), Saturation (Насыщенность) и Lightness (Яркость), чтобы изменить выбранные цвета (для полутонового изображения будет доступен только ползунок Lightness (Яркость)). Образец в окне Sample (Проба) будет изменяться при перемещении ползунков (рис. 11.20).

    Эти ползунки останутся в своих текущих положениях, даже если щелкнуть по другой области изображения.

  8. Щелкните по кнопке ОК (рис. 11.21 и 11.22).

Образец цвета Sample (Проба) из диалогового окна Replace Color (Заменить цвет) также будет отображен в активном квадратике палитры Color (Цвет), и ползунки на этой палитре будут отражать составляющие данного цвета. Если появилось предупреждение о гамме, значит, с помощью ползунков Transform (Изменение) был создан непечатаемый цвет. Перемещение этих ползунков не влияет на компонент К цветовой модели CMYK. Значение данного компонента устанавливается в программе Photoshop функцией Black Generation (Создание черного).

Для восстановления исходного состояния диалогового окна нажмите клавишу Alt и щелкните по кнопке Reset (Восстановить).

Преобразование слоя или фона в полутоновой вид

Воспользуйтесь командой Desaturate (Обесцветить), чтобы убрать цвет со слоя (преобразовать его в полутоновой), не изменяя при этом действительного режима изображения.

  1. Выберите какой-либо слой или фон.
  2. Выполните команду Image z> Adjustments > Desaturate (Изображение > Корректировки > Обесцветить) или нажмите комбинацию клавиш Ctrl+ Shift+U.

Тонирование или коррекция цвета с помощью команды Color Balance

Воспользуйтесь диалоговым окном Color Balance (Баланс цвета), чтобы скорректировать или внести какой-либо теплый или холодный оттенок в светлые, средние или темные тона слоя. Коррекцию цвета будет проще заметить на изображении с широким диапазоном цветов.

  1. Убедитесь, что в окне показано изображение со смешанными цветами (первый канал на палитре Channels (Каналы)). Для тонирования полутонового изображения сначала преобразуйте его в цветовой режим.
  2. Выберите какой-либо слой.
  3. Воспользуйтесь командой Image > Adjustments > Color Balance (Изображение > Корректировки > Баланс цвета) (комбинация клавиш Ctrl+B) или создайте корректирующий слой, выбрав пункт Color Balance (Баланс цвета) во всплывающем меню, которое вызывается нажатием кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).
  4. Внизу диалогового окна отметьте диапазон, который-вы хотите подкорректировать: Shadows (Темные тона), Midtones (Средние тона) или Highlights (Светлые тона) - см. рис. 11.23.
  5. По желанию. Установите флажок Preserve Luminosity (Сохранять яркость), чтобы сохранить значения яркости.
  6. Передвиньте любой ползунок в сторону того цвета, который вы хотите добавить. Теплые и холодные тона расположены парами напротив друг друга. Например, перемещение ползунков в сторону Cyan и Blue создаст холодный оттенок. Сделайте паузу, чтобы просмотреть предварительно результаты.

Рис. 11.23. Диалоговое окно команды Color Balance

Рис. 11.24. Диалоговое окно Variations

  7. По желанию. Повторите шаг 6, установив другие опции в разделе Tone Balance (Баланс тона).
  8. Щелкните по кнопке ОК.

Чтобы подкрасить маленькие области вручную, воспользуйтесь инструментом Brush (Кисть) или Airbrush (Аэрограф) с небольшим значением непрозрачности (устанавливается на панели опций).

Корректировка цвета с помощью миниатюры в диалоговом окне Variations

Миниатюры в диалоговом окне Variations (Вариации) позволяют увидеть, как будет выглядеть изображение с различными настройками цвета. Для проведения более точной корректировки и изменений в окне изображения воспользуйтесь диалоговыми окнами Color Balance (Баланс цвета) или Levels (Уровни).

Команду Variations (Вариации) нельзя использовать для изображения в режиме Indexed Color.

  1. Выберите какой-либо слой.
  2. Выполните команду Image > Adjustments > Variations (Изображение > Корректировки > Вариации).
  3. Вверху диалогового окна поставьте переключатель в положение Shadows (Темные тона), Midtones (Средние тона) или Highlights (Светлые тона), чтобы изменять только указанные области (см. рис. 11.24), или отметьте пункт Saturation (Насыщенность), чтобы настроить только это свойство цвета.
  4. Расположите ползунок Fine/Coarse (Тонкий/Грубый) вправо от центра, чтобы провести серьезную коррекцию, или влево от центра для незначительных изменений (рис. 11.24). Перемещение на одно деление вправо удваивает эффект корректировки, вносимый за один щелчок мышью.
  5. Щелкните по любой миниатюре с подписью More... (Больше...), чтобы добавить больше этого цвета в слой (рис. 11.24). Сделайте паузу, чтобы предварительно просмотреть изменения. Если хотите уменьшить количество какого-либо цвета, щелкните по цвету, находящемуся на противоположном конце диагонали.

Сравните миниатюру Current Pick (Текущий выбор), представляющую собой измененный слой, с миниатюрой Original (Исходное изображение). Щелкните по миниатюре исходного изображения, чтобы отменить корректировку.

  6. По желанию. Щелкните по миниатюре Lighter (Светлее) или Darker (Темнее), чтобы изменить яркость, не затрагивая при этом тон (рис. 11.24).
  7. По желанию. Если вы выбрали коррекцию темных, светлых тонов или насыщенности, можно установить флажок Show Clipping (Показать отсечение), чтобы в областях, которые будут окрашены в черный или белый цвет, отображался яркий неоновый цвет.
  8. По желанцю. Повторите шаги 3-8 для другого диапазона цветов.
  9. Щелкните по кнопке ОК.

Изменение насыщенности цвета с помощью инструмента Sponge

Воспользуйтесь инструментом Sponge (Губка), чтобы изменить насыщенность цветных областей. (Также об этом инструменте рассказывается в главе 22, раздел «Корректировка цветов, не входящих в гамму»). Помните, что нельзя использовать этот инструмент для изображений в режиме Bitmap или Indexed Color.

  1. Дважды щелкните по пиктограмме (^ инструмента Sponge (Губка) или нажмите клавишу О или Shift+O.
  2. На панели опций (рис. 11.25) щелкните по стрелке в поле Brush (Кисть) и выберите вид кисти (кисть с мягкими границами создаст более гладкий результат). Выберите значение в поле Mode (Режим): Desaturate (Обесцветить) или Saturate (Окрасить).

    Выберите величину параметра Pressure (Нажим) в диапазоне от 1% до 100%. Попробуйте значение 20-30%, чтобы инструмент не слишком быстро изменял насыщенность цвета.

  3. Выберите какой-либо слой.
  4. Нанесите штрих на любую область слоя (рис. 11.26). Если необходимо, сделайте паузу, чтобы программа успела отобразить внесенные изменения на экране. Повторите операцию, чтобы усилить эффект.

Если вы слишком сильно изменили окраску какой-либо области, выполните команду Edit > Undo (Правка > Отменить) или щелкните по более раннему состоянию или снимку на палитре History (История). Не пытайтесь использовать этот же инструмент с противоположной опцией, чтобы исправить изображение, вы получите весьма неожиданные результаты.

Рис. 11.25. Панель опций инструмента Sponge

Рис. 11.26. Обесцвечивание изображения при помощи инструмента Sponge

Также насыщенность цвета в изображении можно настроить с помощью команды Image > Adjustments > Hue/Saturation (Изображение > Корректировки > Тон/Насыщенность) или Replace Color (Заменить цвет).

Рис. 11.27. Окно команды Channel Mixer

Использование команды Channel Mixer

Команда Channel Mixer (Смеситель каналов) дает уникальную смесь каналов RGB иЛи CMYK, которую очень трудно получить при помощи других команд. О том, как использовать эту команду для преобразования изображения из цветового режима в полутоновой или для тонирования полутонового изображения, рассказано в главе 9, раздел «Превращение слоя в полутоновой с помощью команды Channel Mixer».

  1. Выберите какой-либо слой и убедитесь, что отображен канал смешанного цвета (верхний канал на палитре Channels (Каналы)).
  2. Выполните команду Image > Adjustments > Channel Mixer (Изображение > Корректировки > Смеситель каналов) или создайте корректирующий слой, выбрав команду Channel Mixer (Смеситель каналов) из всплывающего меню, которое вызывается нажатием кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).
  3. Из всплывающего меню Output Channel (Выходной канал) выберите какой-либо канал (рис. 11.27).
  4. Выполните любой из перечисленных ниже шагов.

    Передвиньте ползунок, указывающий на значение 100% (выбранный выходной канал), на отметку ниже 100, чтобы уменьшить количество этого цвета в канале, или на значение, большее 100 -чтобы увеличить.

    Переместите остальные ползунки влево для того, чтобы увеличить количество соответствующего цвета в канале вывода (отрицательное значение), или вправо, чтобы уменьшить его (положительное значение).

При перемещении влево ползунка исходного канала Black (Черный) количество черного цвета в канале уменьшается, а вправо - увеличивается.

Помните о соотношении 6 основных цветных компонентов: от Cyan (Голубой) к Red (Красный), от Magenta (Пурпурный) к Green (Зеленый) и от Yellow (Желтый) к Blue (Синий). Уменьшение количества голубого, например, вызовет увеличение красного оттенка в канале и наоборот. Если вы забыли эти соотношения, откройте диалоговое окно Color Balance (Баланс цвета).

Передвиньте ползунок Constant (Константа) вправо, чтобы добавить цвет текущего выходного канала в виде тонкого слоя ко всему изображению. Переместите его влево, чтобы удалить этот цвет и добавить связанные с ним цвета ко всему слою.

  5. Щелкните по кнопке ОК.

Команды. Curves и Levels

При использовании команды Curves (Кривые) или Levels (Уровни) для корректировки цвета или тонирования сначала необходимо провести корректировку для всего изображения целиком (в канале смешанного цвета), а затем, если необходимо, подкорректировать отдельные каналы (немного больше голубого, немного меньше фуксина и т.д.).

С помощью команды Curves (Кривые) можно корректировать тона от светлых до темных. Для создания такого эффекта можно даже применить несколько корректирующих слоев. Сначала для смешанного канала воспользуйтесь одним корректирующим слоем, а затем создайте еще один слой для каждого отдельного канала, чтобы еще точнее настроить цвет. Можно поэкспериментировать с непрозрачностью слоя или использовать маску слоя для удаления или ослабления эффекта корректировки в определенных областях.

Коррекция цвета с помощью команды Curves

  1. По желанию. Для одновременной корректировки двух и более каналов нажмите клавишу Shift и щелкните по их именам.

Это нельзя сделать для корректирующего слоя, содержащего команду Curves (Кривые)!

  2. Выберите команду Image > Adjustments > Curves (Изображение > Корректировки > Кривые) (комбинация клавиш Ctrl+M) или создайте корректирующий слой, выбрав пункт Curves (Кривые) из всплывающего меню, которое вызывается нажатием кнопки New fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).
  3. Поместите курсор над сеткой. Информация, содержащаяся в полях Input (Входной уровень) и Output (Выходной уровень), расположенных в левом нижнем углу диалогового окна, представляет собой значения яркости для режима RGB или значения в процентах для режима CMYK. Щелкните по панели градиента, чтобы переключиться с одного поля на другое.

Рис. 11.28. Диалоговое окно команды Curves

  4. По желанию. Выберите какой-либо вариант в выпадающем меню поля Channel (Канал), чтобы настроить соответствующий канал отдельно (это нельзя сделать при работе с корректирующим слоем). Если на шаге 1 вы выбрали более одного канала, то в этом меню можно будет выбрать их комбинацию (например, RB для красного (red) и синего (blue) каналов).

При корректировке отдельных цветовых каналов помните о связи между противоположными цветами (голубой и красный, фуксин и зеленый, желтый и синий). Например, уменьшение количества голубого добавит красного; уменьшение красного добавит голубого. На самом деле, возможно, вам понадобится корректировать несколько каналов, чтобы удалить нежелательные оттенки цвета. Если вы слишком сильно измените только один канал, то баланс цвета изображения в целом будет нарушен.

  5. Если на панели градиента белый цвет расположен с левой стороны (режим CMYK), перетащите часть кривой, которую вы хотите подкорректировать, вверх, чтобы затемнить, или вниз, чтобы осветлить изображение (рис. 11.28). Щелкните по двухсторонней стрелке в середине панели градиента, чтобы кривая приняла противоположное положение. Для режима RGB все делается с точностью до наоборот.

    Для более точной корректировки щелкните по кривой, чтобы создать до 14 дополнительных точек, положение которых фиксировано, затем перетаскивайте участки кривой между точками, чтобы внести едва заметные изменения. (Для того чтобы удалить точку, щелкните по ней и нажмите клавишу Backspace либо щелкните по ней при нажатой клавише Ctrl).

    Переместите самую крайнюю точку кривой, чтобы значение абсолютно черного цвета стало ниже 100% или значение абсолютно белого стало больше 0%.

Как только вы добавили какую-либо точку, для нее можно ввести число (числа) в поле Input (Входной уровень) и/или Output (Выходной уровень).

  6. По желанию. Вы можете воспользоваться опциями автоматической коррекции цвета, имеющимися в диалоговом окне Auto Colors Correction Options (рис. 11.29). Чтобы вызвать это окно, щелкните по кнопке Options в окне Curves.
  7. Щелкните по кнопке ОК (рис. 11.30 и 11.31).

Инструмент Pencil (Карандаш) в окне Curves (Кривые) создает неровную кривую, что в результате приведет к резким перепадам цвета.

Для изображения в режиме RGB щелкните по изображению, чтобы увидеть расположение указанного пиксела на кривой. Нажав клавишу Ctrl, щелкните по изображению, чтобы разместить точку на кривой. Значение пиксела будет отображено в отдельных каналах С, М, Y и К, но не в смешанном канале CMYK.

Нажав клавишу Alt, щелкните по сетке в диалоговом окне Curves, чтобы уменьшить шаг сетки; снова при нажатой клавише Alt щелкните мышью, чтобы увеличить шаг.

Рис. 11.29. Диалоговое окно Auto Colors Correction Options

Рис. 11.30. Исходное изображение

Нажмите клавишу Shift и щелкните по изображению, чтобы разместить цветовую метку в то время, как открыто диалоговое окно Curves (Кривые).

Щелкните по кнопке Auto (Авто), и программа Photoshop зафиксирует самые светлые и темные тона и распределит между ними промежуточные значения средних тонов. Кривые отдельных каналов будут изменены.

Рис. 11.31. Вид изображения после применения команды Curves

Рис. 11.32. Диалоговое окно Levels

Корректировка отдельных цветовых каналов с помощью команды Levels

  1. Активизируйте палитру Info (Информация).
  2. Выберите команду Image > Adjustments > Levels (Изображение > Корректировки > Уровни) (комбинация клавиш Ctrl+L) или создайте корректирующий слой, выбрав пункт Levels (Уровни) во всплывающем меню, которое вызывается нажатием кнопки Create new fill or adjust level (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).
  3. Поставьте флажок Preview (Предварительный просмотр).
  4. Если в изображении наблюдается явное преобладание одного цвета (например, слишком много красного или зеленого), из всплывающего меню Channel (Канал) выберите соответствующий канал (рис. 11.32).

    Выполните любой из следующих шагов для CMYK-изображения (ползунки будут оказывать противоположное действие для RGB-изображения).

    Чтобы увеличить количество определенного цвета, переместите черный или серый ползунок Input Levels (Входные уровни) вправо. Черный треугольник влияет на темные тона изображения, серый - на средние тона.

    Для уменьшения количества заданного цвета переместите серый или белый ползунок Input Levels (Входные уровни) влево. Белый треугольник влияет на светлые тона изображения.

    Для тонирования изображения цветом выбранного канала переместите белый ползунок Output Levels (Выходные уровни) влево, а для уменьшения количества этого цвета - вправо. Ползунки Output Levels особенно эффективны для корректировки телесных цветов на фотографиях.

    Повторите эти шаги для любого другого канала, требующего корректировки, не забывая, что изменение одного канала может повлечь изменение другого.

  5. Щелкните по кнопке ОК.

Нажмите клавишу Alt и щелкните по кнопке Reset (Восстановить), чтобы восстановить исходные значения параметров диалогового окна.

Нажав клавишу Shift, щелкните по изображению, чтобы разместить цветовые метки в то время, как открыто диалоговое окно Levels (Уровни).

Усиление цвета или подчеркивание силуэта изображения на черном слое

В этом упражнении вы будете раскрашивать оттенками серого цвета специальный нейтральный черный или белый слой в режиме Color Dodge (Комбинирование цветов) или Color Burn (Форсирование цвета), чтобы усилить или ослабить цвет нижележащего слоя. Предлагаем попробовать и другие режимы слоя.

  1. Преобразуйте изображение в режим RGB и активизируйте слой, который хотите изменить.
  2. Нажмите клавишу Alt и щелкните по кнопке Create new layer (Создать новый слой) на палитре Layers (Слои).
  3. Введите имя нового слоя.

Рис. 11.33. Создание нейтрального слоя

Рис. 11.34. Исходное изображение

Рис. 11.35. Результат рисования на слое в режимах Color Dodge и Color Burn

Рис. 11.36. Исходное изображение

Рис. 11.37. Результат усиления бликов и теней в режимах Color Dodge и Color Burn

  4. Выберите значение поля Mode (Режим). Для нашей иллюстрации был выбран режим Color Dodge (Комбинирование цветов) - см. рис. 11.33. Но можно выбрать и другой режим, отличный от режимов Normal (Нормальный), Dissolve (Растворение), Hue (Тон), Saturation (Насыщенность), Color (Цвет) или Luminosity (Яркость света).
  5. Поставьте флажок Fill with имя ре-жима > - neutral color (Залить нейтральным цветом имя режима>) и щелкните по кнопке ОК. Слой будет залит черным цветом.
  6. Активизируйте инструмент Brush (Кисть), или нажав клавишу В или Shift+B, и на панели опций выберите вид кисти.
  7. Из меню палитры Color (Цвет) выберите пункт Grayscale Slider (Ползунок полутонов).
  8. Рисуйте серым на 60-88% цветом. Фактически вы будете изменять нейтральный черный цвет слоя. Области, на которые будут наноситься штрихи, станут светлее. Если вы остались недовольны результатом, закрасьте или снова залейте слой черным цветом и начните сначала. Если еще раз закрасить или залить слой черным цветом, будут удалены все результаты редактирования, но при этом пикселы нижележащих слоев сохранят свое состояние.
  9. Для усиления цветового эффекта можно выбрать другой режим на панели Layers (Слои). Мы выбрали режим Color Burn (Форсирование цвета). Наносимые мазки будут вырисовываться на черном фоне (рис. 11.34-11.37). Если хотите восстановить больше исходных цветов, рисуйте средним оттенком серого.

Преобразование цветового слоя в полутоновый и частичное восстановление цвета

  1. Выберите какой-либо слой в цветном изображении. Слои, расположенные под выбранным, будут изменены под воздействием корректирующего слоя, который вы создадите.
  2. Создайте корректирующий слой, выбрав пункт Hue/Saturation (Тон/Насыщенность) из всплывающего меню, которое вызывается нажатием кнопки Create new fill or adjust layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).
  3. Передвиньте ползунок Saturation (Насыщенность) в крайнее левое положение (до -100) - см. рис. 11.38.
  4. Щелкните по кнопке ОК.
  5. Установите черный в качестве основного цвета.
  6. При активизированном корректирующем слое рисуйте по изображению там, где хотите восстановить исходные цвета нижележащих слоев (рис. 11.39). Рисуйте белым цветом, чтобы восстановить полутоновые области. Также можно изменить положение какого-либо слоя, расположенного выше корректирующего, чтобы полностью восстановить цвет того слоя.

Выберите любое из следующих сочетаний режима и значения непрозрачности для корректирующего слоя: Dissolve (Растворение) плюс непрозрачность на уровне 40-50%, чтобы восстановить цвет и создать известковую текстуру; Multiply (Умножение) плюс 100% непрозрачности, чтобы восстановить едва заметные цвета в темных областях изображения, Color Dodge (Комбинирование цвета) - для осветления и усиления цвета или Color Burn (Форсирование цвета) - для затемнения и усиления цвета.

Рис. 11.38. Удаление цвета со слоя при помощи перемещения ползунка Saturation

Рис. 11.39. Нанесение штрихов на корректирующий слой

Если вы хотите ограничить область действия корректирующего слоя только слоем, расположенным ниже, нажмите клавишу Alt и на палитре Layers (Слои) щелкните по линии, разделяющей эти слои, чтобы создать группу отсечения.

Рис. 11.40. Диалоговое окно New Spot Channel

Как спрятать за маской цветной слой

Создайте дубликат какого-либо цветного слоя и его маску. Чтобы получить маску, выберите команду Image > Adjustments > Desaturate (Изображение > Корректировки > Обесцветить) или - второй вариант - нажмите комбинацию клавиш Ctrl+Shift+U), а затем выполните команду Layer > Add Layer Mask > Hide All (Слой > Добавить маску слоя > Спрятать все). Рисуйте белым цветом, чтобы изменить области черно-белого слоя, расположенного поверх цветного. Таким образом, можно постепенно скорректировать форму маски, рисуя черным, чтобы добавить область в маску, или белым, чтобы удалить маску изображения.

Создание канала заказного цвета

Специальный (заказной) цвет может быть помещен в собственный отдельный канал. Затем после цветоделения этот канал появится в виде отдельной печатной формы.

  1. Активизируйте палитру Channels (Каналы) и перетащите ее в сторону от палитры Layers (Слои), чтобы можно было видеть сразу две палитры.
  2. Из меню палитры Channels (Каналы) выберите пункт New Spot Channel (Новый канал заказного цвета).
  3. Щелкните по образцу цвета (рис. 11.40) и, если необходимо, по кнопке Custom (По выбору пользователя), чтобы открыть диалоговое окно Custom Colors (Цвет по выбору пользователя).
  4. Из всплывающего меню Book (Книга) выберите вариант Pantone или другую систему цветов, затем изберите какой-либо цвет и щелкните по кнопке ОК.
  5. По желанию. Для того чтобы изменить способ отображения заказного цвета в канале, введите новое значение параметра Solidity (Плотность) в группе Ink Characteristics (Характеристики краски). При значении равном 100% цвет будет казаться сплошным, при меньшем значении окажется более прозрачным (скажем, словно лак данного цвета).
  6. Щелкните по кнопке ОК. Новый канал заказного цвета автоматически получит имя выбранного цвета (рис. 11.41). Любой штрих или элемент изображения, созданный при активном канале заказного цвета, будет иметь этот цвет (см. следующий раздел).

Для изменения цвета в канале заказного цвета дважды щелкните по имени канала, затем выполните шаги 3-6 (см. выше). Канал будет автоматически переименован в соответствии с новым цветом, и все пикселы, относящиеся к этому каналу, поменяют свой цвет на новый.

Рисование в канале заказного цвета

  1. Создайте канал заказного цвета (как это сделать, рассказано выше, в разделе «Создание канала заказного цвета»).
  2. Дважды щелкните по имени канала, в поле Solidity (Плотность) введите 100% и щелкните по кнопке ОК.
  3. Активизируйте инструмент Brush (Кисть). Помните, что палитра Color (Цвет) будет находиться в полутоновом режиме, пока активен канал заказного цвета. Выберите черный цвет в качестве основного цвета рисования.
  4. На панели опций инструмента выберите значение Normal (Нормальный) параметра Mode (Режим) и уровень непрозрачности для краски той печатной формы, которая соответствует каналу заказного цвета.

Рис. 11.41. Новый канал заказного цвета на палитре Channels

Копирование в канал заказного цвета

Для того чтобы скопировать изображение в канал заказного цвета, сначала выделите какую-либо область слоя. Не снимая выделения, создайте новый канал заказного цвета. Или выберите существующий канал заказного цвета и залейте выделение черным цветом.

Для копирования светлых и темных цветов изображения в канал заказного цвета сначала выделите некоторую область и скопируйте ее в буфер обмена. Затем создайте или выберите какой-либо канал заказного цвета и вставьте выделенную область в этот канал.

  5. Убедитесь, что канал заказного цвета активен, и рисуйте на изображении.

Осветление или затемнение краски в канале заказного цвета

На палитре Channels (Каналы) выберите канал заказного цвета, затем воспользуйтесь командой Image > Adjustments > Levels (Изображение > Корректировки > Уровни). Для затемнения краски передвиньте вправо черный ползунок Input Levels (Входные уровни), для осветления -черный ползунок Output Levels (Выходные уровни). Поместите курсор над изображением так, чтобы на палитре Info (Информация) появились данные о непрозрачности точки (выберите режим Actual Color (Действительный цвет) для цветовой пробы). Если хотите, перенастройте любой из ползунков.

Основные сведения о каналах заказного цвета

Если на палитре Channels (Каналы) присутствует пиктограмма в виде глаза напротив канала заказного цвета и самого верхнего канала смешанного цвета, то канал заказного цвета будет отображаться наряду с остальными слоями изображения. Для отображения только канала заказного цвета спрячьте смешанный канал, щелкнув по его значку в виде глаза.

Если вы хотите узнать уровень непрозрачности области заказного цвета, активизируйте канал заказного цвета, для цветовых проб на палитре Info (Информация) выберите режим Actual Color (Действительный цвет), перемещайте курсор над изображением и следите за величиной параметра К на палитре.

Когда активен канал заказного цвета, миниатюра слоя, который был активизирован последним, будет окружена черной рамкой, а редактирование затронет только канал заказного цвета. Если щелкнуть по самому верхнему (смешанному) каналу на палитре Channels (Каналы), редактироваться будет последний активный слой, а не канал заказного цвета.

О том, как добавить текст в канал заказного цвета, рассказано в главе 17, раздел «Создание текста в канале заказного цвета».

Если цветное изображение с каналом заказного цвета (или изображение в режиме Duotone) преобразовать в режим Multichannel, все заказные цвета будут распределены по отдельным каналам. Ранее существовавшие каналы заказного цвета, если такие имелись, будут сохранены. Для печати всего изображения с помощью одной краски заказного цвета преобразуйте изображение в режим Duotone и укажите единственный желаемый цвет (см. главу 22, раздел «Создание двутоно-вых изображений»).

Для экспорта файла с каналами заказного цвета сохраните его в формате DCS 2.O. Каждый канал заказного цвета будет сохранен в виде отдельного файла наряду с композитным файлом DCS. Позвольте программе Photoshop самой выбрать имя для этих файлов. Тогда другие приложения распознают файл как канал заказного цвета. Формат Photoshop PDF также поддерживает заказные цвета.

Печать изображения с каналами заказного цвета

Заказные цвета печатаются поверх всех других цветов изображения. Порядок расположения каналов заказных цветов на палитре Channels (Каналы) определяет порядок, в котором эти каналы печатаются. Чтобы предотвратить распечатку канала заказного цвета поверх остальных каналов, необходимо вручную удалить те области из других каналов, которые располагаются под фигурами канала заказного цвета (подробнее об этом читайте в руководстве пользователя по программе Adobe Photoshop). И обсудите с работниками типографии, следует ли вообще так делать.

Команда Merge Spot Channels (Слить каналы заказных цветов) из меню палитры Channels (Каналы) позволяет слить заказные цвета с имеющимися цветовыми каналами, а затем получить пробный композитный отпечаток на цветном принтере. В противном случае каналы заказного цвета будут распечатаны в виде отдельных страниц.

Слияние канала заказного цвета с другими каналами изменит плашечный цвет, так как краски CMYK не могут с точностью воспроизвести его. При слиянии канала заказного цвета с другими каналами значение его параметра Solidity (Плотность) будет определять процент окраски изображения данным цветом. При слиянии каналов заказного цвета все слои изображения объединяются.

В диалоговом окне Spot Channel Options (Опции канала заказного цвета) воспользуйтесь параметром Solidity (Плотность), чтобы создать на экране имитацию непрозрачности реальной краски печатной формы. Для непрозрачных красок типа металлических используйте значение 100% параметра Solidity (Плотность). Для прозрачного, чистого «лака» выберите значение параметра Solidity (Плотность) равное 0%.

Преобразование альфа-канала в канал заказного цвета

  1. На палитре Channels (Каналы) дважды щелкните по элементу альфа-канала.
  2. В группе параметров Color Indicates (Цвет означает) установите переключатель в положение Spot Color (Заказной цвет) - см. рис. 11.42.
  3. Щелкните по образцу цвета, затем по кнопке Custom (По выбору пользователя), если необходимо открыть диалоговое окно Custom Colors (Цвет по выбору пользователя), выберите какой-либо плашечный цвет и щелкните по кнопке ОК.
  4. Щелкните еще раз по кнопке ОК. Бывшие не белыми (черными или серыми) области канала теперь будут окрашены заказным цветом.

Чтобы поменять местами области заказного и белого цвета, выберите канал, а затем выполните команду Image > Adjustments > Invert (Изображение о Корректировки > Инвертировать) или нажмите комбинацию клавиш Ctrl+l.

Рис. 11.42. Диалоговое окно Channel Options


  • Глава 12. Рисование
    • Инструмент Brush
      • Новые возможности работы с кистями
      • Изменение существующей кисти
      • Создание новой кисти
      • Удаление кисти
      • Загрузка библиотеки кистей
      • Подкрашивание полутонового изображения
      • Создание кисти на основе изображения
      • Сохранение кистей в новой библиотеке
      • Заливка области с помощью инструмента Paint Bucket
      • Стирание части слоя
      • Использование инструмента Background Eraser
      • Использование инструмента Magic Eraser
      • Режим автоматического стирания
      • Размазывание цветов

Глава №12.

Рисование

Таблица 12.1. «Горячие» клавиши инструментов рисования

Попеременное изменение | Shift+«плюс»
режимов смешивания | или
Shift+«минус» на панели опций |
Попеременное изменение видов кисти из числа имеющихся на панели выбора кисти | [ или ]
Выбор уровня | От 0 до 9
непрозрачности | (например 2 = 20%) либо быстрый набор величины (например, 38)

В этой главе вы узнаете, как в программе Photoshop воспользоваться инструментами Brush (Кисть), Pencil (Карандаш), Paint Bucket (Ведро с краской), Eraser (Ластик), Magic Eraser (Волшебный ластик), Background Eraser (Ластик для фона), Smudge (Палец) и Gradient (Градиент), чтобы раскрасить отсканированное изображение или создать изображения с нуля. Также вы узнаете, как создать кисть желаемой формы для инструмента рисования; как сохранить или загрузить библиотеки кистей и как выбрать опции отдельных инструментов, например режим смешивания или уровень непрозрачности.

При рисовании удобно пользоваться «горячими» клавишами. Их функции описаны в табл. 12.1.

Инструмент Brush

  1. Выберите какой-либо слой. Создайте выделенную область, если хотите ограничить действие инструмента этой областью.
  2. Щелкните по пиктограмме инструмента Brush (Кисть) (клавиша В).
  3. Выберите основной цвет (см. начало главы 10).
  4. На панели опций щелкните по стрелке в поле Brush (Кисть), чтобы выбрать тип кисти (рис. 12.1). Число под каждой пиктограммой определяет ширину кончика кисти в пикселах. Если вы остановите курсор над каким-либо видом кисти, во всплывающей подсказке будет показано ее имя и ширина кончика. (Как загрузить другие библиотеки кистей на панель опций, рассказано в главе 12, раздел «Загрузка библиотеки кистей»). Щелкните мышью где-либо вне панели выбора кистей, чтобы закрыть ее. Выберите значение параметра Mode (Режим смешивания), как описано в главе 2, раздел «Режимы смешивания»), а также величину параметра Opacity (Непрозрачность) в процентах для инструмента Brush (Кисть) см. рис. 12.2. Если значение указанных параметров равно 100%, штрих кисти будет полностью закрывать расположенные ниже пикселы (рис. 12.3,12.4).

На палитре Layers (Слои) поставьте флажок Lock transparent pixels (Зафиксировать прозрачные точки), чтобы изменять цвет только непрозрачных областей.

Для создания прямого штриха щелкните мышью один раз, чтобы начать штрих, затем, нажав клавишу Shift, щелкните в другом месте, чтобы завершить штрих.

Нажмите клавишу Alt и щелкните в любом открытом изображении, чтобы взять образец цвета в то время, как активизирован инструмент рисования (временное переключение на инструмент Eyedropper (Пипетка)).

Для каждого инструмента сохраняются его собственные значения параметров на панели опций.

Рис. 12.1. Панель выбора формы кисти

Рис. 12.2. Выбор значения параметра Opacity

Рис. 12.3. Штрих инструмента Brush при значении параметра Opacity 100%

Рис. 12.4. Штрих инструмента Brush при значении параметра Opacity 20%

Рис. 12.5. Штрихи, созданные с помощью инструмента Brush при использовании различных кистей

Рис. 12.6. Окно выбора кисти

Наряду с другими возможностями палитра кистей позволяет выполнить предварительный просмотр кисти по миниатюре ее следа.

Рисование с помощью инструмента Line

В программе Photoshop 7 можно нарисовать прямые линии с помощью инструментов построения фигур (инструмент Line (Линия)). Подробно об этом рассказано в главе 16, раздел «Фигуры».

Новые возможности работы с кистями

При помощи Photoshop 7.0 вы сможете создавать удивительные художественные полотна, используя множество имеющихся кистей или создав свою собственную кисть для живописи (рис. 12.5).

Новый процессор для живописи позволит вам создавать удивительные образы. В Photoshop 7.0 можно имитировать традиционные приемы живописи, включая пастель и уголь, при помощи эффектов сухой и влажной кисти. В состав пакета включены кисти для добавления специальных эффектов, иаких как трава и листья. Чтобы создать оригинальное изображение, можно воспользоваться отсканированным и обработанным изображением какой-либо поверхности (например, бумаги или ткани) или применить текстуру, поставляемую вместе с программой. Процессор для живописи Photoshop 7 не только предоставляет совершенно новые возможности для творчества, но и обеспечивает более точные средства управления. Используя палитру кистей (рис. 12.6), можно подобрать различные варианты формы, наклона, интервала, разброса, диаметра и других атрибутов и сохранить эти значения в виде параметров своих личных кистей. Кроме того, вы можете комбиниро-ватьдве различные кисти для получения нужного эффекта.

Изменение существующей кисти

Вместе с программой Photoshop поставляются библиотеки кистей, и вы можете по своему усмотрению модифицировать любую входящую в них кисть.

  1. На панели опций щелкните по кнопке Brushes (Кисть) и перейдите в меню Brush Tip Shape - см. рис. 12.7.
  2. Переместите ползунок Diameter (Диаметр) или введите диаметр (ширину) штриха (от 1 до 999 пикселов).
  3. Передвиньте ползунок Hardness (Жесткость) или введите цифру - значение в процентах от диаметра штриха (0-100%), определяющее непрозрачный след кисти.
  4. Переместите ползунок Spacing (Интервал) или введите величину этого параметра (0-999%). Чем оно выше, тем дальше друг от друга расположены отпечатки кисти. Можно также снять флажок Spacing (Интервал), чтобы след кисти соответствовал скорости перемещения мыши или пера. Чем быстрее передвигается мышь или перо, тем больше точек пропускается при рисовании (см. также главу 12, раздел «Выбор опций пера»).

Для многих видов кисти, установленных по умолчанию, единственные опции, которую можно-изменить, - это Spacing и Diameter.

  5. Введите какое-либо значение (от -180° до +180°) в поле Angle (Угол) или перетащите серую стрелку по кругу в окне, расположенном слева.
  6. Введите значение параметра Roundness (Округлость) (0-100%) или измените форму кисти, перетащив одну из черных точек внутрь или наружу в окне, расположенном слева. Чем выше значение, тем ближе к окружности форма кисти.

Рис. 12.7. Окно правки кисти

а)

б)

в)

г)

Рис. 12.8. Штрихи с различными параметрами

а)

б)

г)

д)

Рис. 12.9. Влияние параметра Spacing

  7. Измененные характеристики кисти будут временными до тех пор, пока вы не сохраните их в качестве нового экземпляра кисти.
  8. Снова щелкните по кнопке Brushes (Кисти), чтобы закрыть окно.

Измененные параметры кисти сохраняются до тех пор, пока вы не выберите для работы другую кисть. Открыв панель выбора кисти, вы увидите, что пиктограмма кисти не поменялась.

При изменении существующей кисти на самом деле будет модифицирована временная копия, а не исходная кисть, находящаяся в текущей библиотеке.

На рис. 12.8 показаны штрихи, нанесенные кистью с различными значениями параметров: Hardness 100% (рис. 12.8а), Hardness 3% (рис. 12.8б), Roundness 100% .(рис. 12.8в), Roundness 20% (рис. 12.8г).

На рис. 12.9 показано, как распределяются пропуски в штрихе при различных значениях параметра Spacing (Интервал): значение параметра Spacing равно 25% (рис. 12.9а), 150% (рис. 12.9в), пропуски распределены равномерно; медленное (рис. 12.9в) и быстрое (рис. 12.9г) рисование при снятом флажке Spacing, пропуски распределены неравномерно.

Создание новой кисти

  1. Щелкните по стрелке в поле Brush (Кисть) и выберите команду New Brush (Создать кисть) из меню панели выбора.
  2. Выполните шаги 2-8 из раздела «Изменение существующей кисти», чтобы создать кисть. Щелкните по кнопке Create New Brush (Создать новую кисть), если хотите сохранить измененный вариант кисти, созданный на панели выбора. (Однако новый образец кисти не попадет в какую-либо библиотеку.) Введите имя новой кисти и щелкните по кнопке ОК. Пиктограмма новой кисти станет последней на панели выбора. О том, как сохранить кисть в библиотеке, рассказано в главе 21, раздел «Сохранение нового элемента панели выбора в новой библиотеке».

Удаление кисти

  1. Откройте панель выбора кисти.
  2. Первый способ: нажмите клавишу Alt и щелкните по кисти, которую вы хотите удалить. Это действие нельзя отменить.

Второй способ: укажите кисть, которую хотите удалить, и из выпадающего меню выберите команду Delete Brush (Удалить кисть) - см. рис. 12.10

Рис. 12.10. Удаление кисти

Восстановление кистей, установленных по умолчанию

Кисти, расположенные на панели выбора кисти в момент выхода из программы Photoshop, будут там же, когда вы снова запустите программу. Для восстановления библиотеки кистей, установленной по умолчанию, из меню панели выбора выберите команду Reset Brushes (Восстановить кисти) и щелкните по кнопке ОК.

Рис. 12.11. Библиотека Dry Media Brushes

Рис. 12.13. Библиотека Thick Heavy Brushes

Рис. 12.14. Библиотека Wet Media Brushes

Загрузка библиотеки кистей

В дополнение к кистям, присутствующим в программе по умолчанию, вместе с программой Photoshop поставляется еще одинадцать библиотек кистей. Библиотеки Assorted Brushes (Кисти в виде фигурок), Calligraphic Brushes (Каллиграфические кисти), Drop Shadow Brushes (Отбрасывающие тень кисти), Faux Finish Brushes (Кисти с изрезанными кончиками), Natural Brushes (Естественные кисти), Natural Brushes 2 (Естественные кисти 2) и Square Brushes (Квадратные кисти) были еще и в программе Photoshop 6. Dry Media Brushes, Special Effect Brushes (Кисти со специальным эффектом), Thick Heavy Brushes, Wet Media Brushes -новые библиотеки, появившиеся в программе Photoshop 7 (рис. 12.11-12.14).

  1. Откройте панель выбора кисти.
  2. Щелкните по стрелке, расположенной на панели справа, затем в нижней части меню выберите имя какой-либо библиотеки кистей.
  3. Щелкните по кнопке Append (Добавить), чтобы добавить дополнительные кисти к текущей панели выбора, или по кнопке ОК, чтобы заменить текущую библиотеку кистей новой.

Для того чтобы найти и открыть библиотеку кистей, которая находится не в папке Adobe Photoshop 7/Presets/Brushes, просматриваемой по умолчанию, выберите команду Load (Загрузить) из меню панели выбора.

Подкрашивание полутонового изображения

Далее написано об удобном методе подкрашивания полутонового изображения. Нанося красочные штрихи на отдельные слои, вы сможете гибко управлять режимом смешивания и уровнем непрозрачности инструмента рисования или цветового слоя, а также стиранием и осветлением областей изображения - все это без какого-либо изменения лежащего ниже серого изображения.

  1. Откройте изображение в режиме Grayscale и преобразуйте его в режим RGB (команда Image > Mode > RGB Color (Изображение > Режим > Цвет RGB)).
  2. Нажмите клавишу Alt и щелкните по кнопке Create new layer (Создать новый слой), расположенной внизу палитры Layers (Слои), чтобы добавить новый слой поверх полутонового изображения, и выберите в поле Mode (Режим) вариант Color (Цвет) для нового слоя, а затем щелкните по кнопке ОК.
  3. Активизируйте инструмент Brush (Кисть) с помощью клавиши В.
  4. Выберите основной цвет рисования.
  5. На панели опций выберите кисть и установите значение параметра Opacity (Непрозрачность) менее 100%. Для едва заметной подкраски выберите маленькое значение. Между нанесением штрихов можно изменять уровень непрозрачности. Также с помощью палитры Layers (Слои) можно уменьшить непрозрачность целого слоя.
  6. Нанесите штрихи на новый слой (см. рис. 12.15).
  7. По желанию. Воспользуйтесь инструментом Eraser (Ластик), чтобы удалить области неподходящего цвета (для этого снимите флажок Lock transparent pixels

    (Зафиксировать прозрачные точки)), затем, если хотите, снова рисуйте. Либо воспользуйтесь инструментом Dodge (Осветление) с небольшим значением параметра Exposure (Воздействие), чтобы слегка осветлить цвет.

  8. По желанию. Выберите другой режим смешивания для цветного слоя. Попробуйте Multiply (Умножение), Soft Light (Мягкий свет), Color Burn (Форсирование цвета) или Color (Цвет). Также для тонирования изображения можно воспользоваться командой Channel Mixer (Смеситель каналов).

Рис. 12.15. Подкрашивание фонового полутонового изображения с помощью слоя Layer 1

Рис. 12.16. Выделение произвольной области изображения

Рис. 12.17. Ввод имени новой кисти

Рис. 12.18. Результат использования кисти, определенной пользователем, при рисовании инструментом Brush с различными значениями параметра непрозрачности

Создание кисти на основе изображения

  1. Активизируйте инструмент Rectangular Marquee (Прямоугольная область), нажав клавишу М или сочетание Shift+M.
  2. Обведите рамкой какую-либо область картинки (максимум 1000x1000 пикселов). Попробуйте воспользоваться фигурами, выделяющимися на белом фоне (рис. 12.16).
  3. Выберите команду Edit > Define Brush (Правка > Определить кисть).
  4. Введите имя новой кисти и щелкните по кнопке ОК (рис. 12.17). Пиктограмма новой кисти станет последней на панели выбора. Этой кистью можно воспользоваться при работе с инструментами Brush (Кисть) - см. рис. 12.18. На всплывающей палитре редактирования кисти подкорректируйте значение параметра Spacing (Интервал), задающего расстояние между отпечатками кисти (1-999%).
  5. Снимите выделение с области (комбинация клавиш Ctrl+D).

Сохранение кистей в новой библиотеке

Любые новые кисти будут удалены с панели выбора, если текущая библиотека будет замещена другой, в том числе принимаемой по умолчанию. Для того чтобы сохранить новые виды кисти в новой библиотеке для будущего использования, следуйте приведенным ниже инструкциям.

  1. Выберите команду Save Brushes (Сохранить кисти) в меню панели выбора кисти.
  2. Введите имя библиотеки. Оставьте расширение библиотеки кистей без изменений (.abr).
  3. Выберите папку, где будет храниться библиотека, и щелкните по кнопке Save (Сохранить) либо нажмите клавишу Enter.

Заливка области с помощью инструмента Paint Bucket

Инструмент Paint Bucket (Ведро с краской) заменяет пикселы основным цветом или узором, заливая таким образом области близкого цвета с учетом заданного значения параметра Tolerance (Допуск). Этим инструментом можно воспользоваться, не создавая выделенную область.

  1. Выберите какой-либо слой. Если не хотите заливать прозрачные области слоя, установите флажок Lock transparent pixels (Зафиксировать прозрачные точки).

Нельзя применить инструмент Paint Bucket (Ведро с краской) к изображению в режиме Bitmap.

  2. Выберите инструмент Paint Bucket (Ведро с краской), нажав клавишу G. Соответствующая команда располагается во всплывающей палитре инструмента Gradient (Градиент).

Рис. 12.19. Левая часть панели опций инструмента Paint Bucket

Рис. 12.20. Правая часть панели опций инструмента Paint Bucket

Рис. 12.21. Исходное изображение

Рис. 12.22. Изображение после щелчка мышью при активизированном инструменте Paint Bucket

  3. На панели (рис. 12.19,12.20) установите значение Foreground (Основной цвет) в поле Fill (Залить) и значение поля Mode (Режим смешивания). Воспользуйтесь «горячими» клавишами Shift-Ншлюс» или Shift+«минус», чтобы попеременно переключать режимы. Нужен совет? Попробуйте режим Multiply (Умножение), Soft Light (Мягкий свет) или Color Burn (Форсирование цвета).

    Введите значение параметра Opacity (Непрозрачность) в процентах и величину допуска Tolerance (0-255). Чем выше это значение, тем шире диапазон цветов, которые будет заменять инструмент Paint Bucket (Ведро с краской). Сначала задайте небольшой допуск и установите флажок Anti-aliased (Сглаживание), чтобы немного сгладить границы области заливки, а также флажок Contiguous (Смежные), чтобы залить только те области, которые соединены с областью, по которой вы щелкаете. Снимите этот флажок, чтобы заливать не только соседние области.

    Установите флажок All Layers (Все слои), если хотите, чтобы инструмент Paint Bucket (Ведро с краской) заливал области активного слоя с учетом цветов, которые инструмент обнаруживает на всех видимых в данный момент слоях, а не только на активном.

  4. Выберите основной цвет.
  5. Щелкните по изображению (рис. 12.21 и 12.22). Во время щелчка мышью необходимо обратить внимание на позицию той части курсора, которая изображает проливаемую жидкость.

Использование узоров при работе с инструментом Paint Bucket

На панели опций установите значение Pattern (Узор) в поле Fill (Залить) и выберите подходящий рисунок на панели выбора. Для создания собственного узора выделите прямоугольную область, выберите команду Edit > Define Pattern (Правка > Определить рисунок), введите какое-либо имя и щелкните по кнопке ОК. Затем снимите выделение с области. Определенный вами образец будет располагаться в самом конце панели выбора узоров.

Стирание части слоя

  1. Выберите какой-либо слой. Если использовать инструмент Eraser (Ластик) на слое в то время, когда стоит флажок Lock transparent pixels (Зафиксировать прозрачные точки), или на фоне изображения, стираемая область будет залита текущим фоновым цветом. Если для слоя снят флажок Lock transparent pixels (Зафиксировать прозрачные точки), удаляемая область станет прозрачной.
  2. Активизируйте инструмент Eraser (Ластик), нажав клавишу Е или Shift+E.
  3. На панели опций инструмента щелкните по стрелке в поле Brush (Кисть) и выберите кисть на всплывающей панели.

    Задайте режим в поле Mode (Режим): возможны варианты Brush (Кисть), Pencil (Карандаш) или Block (Блок) -см. рис. 12.23,12.24. Для имитации эффекта мокрых границ выберите Brush (Кисть).

    Задайте значение параметра Opacity (Непрозрачность).

Рис. 12.23. Левая часть панели опций инструмента Eraser

Рис. 12.24. Правая часть панели опций инструмента Eraser

Рис. 12.25. Исходное изображение

Рис. 12.26. Появление слоя , частично заполненного белым цветом, после стирания части слоя

Рис. 12.27. Слой карты, частично заполненный белым цветом

  4. Если вы хотите стереть часть фона изображения или на палитре Layers (Слои) установлен флажок Lock transparent pixels (Зафиксировать прозрачные точки), выберите какой-либо фоновый цвет.
  5. Щелкните мышью или перетащите курсор, удерживая нажатой кнопку мыши, поперек слоя (рис. 12.25-12.27).

Для восстановления областей текущего слоя, соответствующих определенному состоянию, переместите пиктограмму источника на необходимый элемент палитры History (История). Затем активизируйте инструмент Eraser (Ластик), при этом на панели опций должен стоять флажок Erase to History (Восстановить до состояния). Второй способ: нажмите клавишу Alt и тащите курсор, чтобы временно включить опцию Erase to History (Восстановить до состояния). Опция Erase to History (Восстановить до состояния) станет недоступной, если добавить новый слой или изменить общее число пикселов в файле.

Использование инструмента Background Eraser

Инструмент Background Eraser (Ластик для фона) делает области, через которые протаскивается курсор, прозрачными или заливает их фоновым цветом. Достоинство этого инструмента заключается том, что можно осуществлять контроль за определенными критериями, например, стирать соседние (смежные) или несмежные области. Аккуратно выбрав кисть, можно контролировать размер стираемой области и регулировать мягкость ее границ.

  1. Из всплывающей палитры инструмента Eraser (Ластик) выберите инструмент Background Eraser (Ластик для фона), щелкнув по пиктограмме, на которой нарисованы ножницы, или нажав клавишу Е или Shift+E.
  2. На панели опций из всплывающего меню Limits (Границы) выберите, где будет стираться изображение (рис. 12.28, 12.29):
    • Discontiguous (Несмежные), чтобы стирать все точки в диапазоне, определяемом допуском, независимо от того, являются ли точки смежными или нет. Если вы выбрали эту опцию, то на шаге 5 из всплывающего меню Sampling (Взятие образца) выберите Once (Один раз);
    • Contiguous (Непрерывно), чтобы стирать только смежные точки в диапазоне, определяемом значением параметра Tolerance (Допуск), цвет которых соответствует цвету первого пиксела, по которому вы щелкнули мышью;
    • Find Edges (Найти края), чтобы стирать соседние точки, но сохранять границы объекта (высококонтрастные границы) - см. рис. 12.30.
  3. На всплывающей панели выберите кисть с жесткими или мягкими границами.
  4. Выберите значение параметра Tolerance (Допуск). Чем оно выше, тем шире удаляемый диапазон цветов, похожих на цвет первого пиксела, по которому вы щелкнули.
    1. Из всплывающего меню Sampling (Взятие образца) выберите:
    • Continuous (Непрерывно), чтобы сделать прозрачными все пикселы в диапазоне, определяемом текущим значением допуска, над которыми вы перетаскиваете курсор;

Рис. 12.28. Левая часть панели опций инструмента Background Eraser

Рис. 12.29. Правая часть панели опций инструмента Background Eraser

Рис. 12.30. Стирание фона изображения с помощью опции Find Edges

Рис. 12.31. Исходное изображение

Рис. 12.32. Результат применения инструмента Background Eraser с различными значениями параметров

    • Once (Один раз), чтобы сделать прозрачными только пикселы, точно соответствующие первому пикселу, через который вы протащили курсор. Для стирания только одного цвета выберите эту опцию и задайте допуск равным 1%;
    • Background Swatch (Фоновый цвет), чтобы стирать только те пикселы, цвет которых совпадает с фоновым. Выберите сейчас какой-либо фоновый цвет. И при использовании этой опции возьмите маленькое значение допуска.
  6. По желанию. Для защиты какого-либо определенного цвета от стирания поставьте флажок Protect Foreground Color (Защитить основной цвет) и убедитесь, что во всплывающем меню Sampling (Взятие образца) выбрана опция Once (Один раз). На палитре Color (Цвет) активизируйте квадратик основного цвета, нажмите и не отпускайте клавишу Alt, затем в окне изображения щелкните по пикселу того цвета, который вы хотите защитить. Это может быть любой пиксел, расположенный на фоне или слое.
  7. Если вы используете чувствительный к нажиму планшет, на панели опций задайте дополнительные характеристики инструмента в окне Brushes (Кисти).
  8. Выберите слой, точки которого вы хотите стереть.
  9. Перетащите курсор поперек области изображения, которую вы хотите стереть. Активная часть курсора - это перекрестие.

Если вы недовольны результатами, отмените действие или щелкните по более раннему состоянию, измените любые параметры инструмента и попытайтесь снова. Для расширения или сужения диапазона стираемых цветов измените значение допуска на панели опций инструмента Background Eraser (Ластик для фона).

Использование инструмента Magic Eraser

Инструмент Magic Eraser (Волшебный ластик) позволяет стирать пикселы простым щелчком мыши, а не перетаскиванием курсора. Он стирает точки, цвет которых с учетом заданного допуска похож на цвет пиксела, по которому вы щелкнули. Этот инструмент работает так же, как и инструмент Paint Bucket (Ведро с краской), за исключением того, что он удаляет, а не добавляет пикселы. Если установить непрозрачность ниже 100%, то с помощью инструмента Magic Eraser можно сделать целевые области слоя частично прозрачными.

  1. Из всплывающей палитры инструмента Eraser (Ластик) выберите инструмент Magic Eraser (Волшебный ластик). Активизировать этот инструмент можно также, щелкнув по пиктограмме ;iPJ или нажав комбинацию клавиш Shift+E.
  2. На панели (рис. 12.33,12.34) введите значение параметра Tolerance (Допуск). Чем оно выше, тем шире диапазон цветов, которые будут стерты. Введите маленькое значение допуска, если хотите стирать только цвета, практически идентичные цвету, по которому вы щелкнете. Введите 0, чтобы стереть пикселы только одного цвета.

Рис. 12.33. Левая часть панели опций инструмента Magic Eraser

Рис. 12.34. Правая часть панели опций инструмента Magic Eraser

Рис. 12.35. Исходное изображение

Рис. 12.36. Результат стирания правого листапри помощи инструмента Magic Eraser с включенной опцией Contiguous

Рис. 12.37. Результат стирания правого листа при помощи инструмента Magic Eraser с включенной опцией Contiguous

Установите флажок Anti-aliased (Сглаживание), чтобы слегка смягчить границы стираемой области.

Установите флажок Contiguous (Смежные), чтобы стирать только пикселы, расположенные рядом друг с другом. Снимите этот флажок, чтобы стирать похожие по цвету пикселы, расположенные на всем слое (см. 12.35-12.37).

Установите флажок Use All Layers (Использовать все слои), чтобы инструмент Magic Eraser (Волшебный ластик) стирал области активного слоя, учитывая цвет пикселов на всех видимых слоях. Если эта опция выключена, инструмент анализирует только цвета активного слоя. В любом случае стерты будут только точки активного слоя.

Выберите величину параметра Opacity (Непрозрачность). Введите значение 100%, чтобы точки стали прозрачными, либо выберите меньшее значение, чтобы стереть пикселы частично.

  3. Выберите слой, пикселы которого вы хотите стереть.
  4. В окне изображения аккуратно поместите перекрестие инструмента над областью, которую хотите стереть, затем щелкните мышью.

Если стертая область слишком маленькая или большая, отмените действие, на панели опций инструмента измените значение допуска, затем попробуйте щелкнуть по изображению еще раз.

Режим автоматического стирания

В режиме автостирания (на самом деле при работе с инструментом Pencil (Карандаш) с включенной опцией Auto Erase (Автоластик)) происходит рисование фоновым цветом, если вы начинаете перетаскивать курсор по пикселам основного цвета. Если перетаскивать курсор над пикселами любого другого цвета, то инструмент будет рисовать основным цветом.

  1. Выберите какие-либо основной и фоновый цвета. Можно воспользоваться инструментом Eyedropper (Пипетка), чтобы выбрать цвет на изображении.
  2. Выберите какой-либо слой.
  3. Активизируйте инструмент Pencil (Карандаш), для чего нажмите клавишу В или Shift+B.
  4. На панели опций поставьте флажок Auto Erase (Автоластик).
  5. Нанесите штрихи на изображение (рис. 12.38). Начните тащить курсор с пиксела основного цвета (если таковой есть), чтобы рисовать фоновым цветом. Начните тащить курсор с пиксела любого другого цвета, чтобы рисовать основным цветом.

Рис. 12.38. Результат использования инструмента Pencil в режиме Auto Erase

Рис. 12.39. Левая часть панели опций инструмента Smudge

Рис. 12.40. Правая часть панели опций инструмента Smudge

Инструмент Smudge (Палец) нельзя применить к изображению в режиме Bitmap или Indexed Color.

Размазывание цветов

  1. Выберите какой-либо слой.
  2. Активизируйте инструмент Smudge (Палец), нажав клавишу R или Shift+R

    На панели опций (рис. 12.39,12.40) ще/ж-ните по стрелке в поле Brush (Кисть) и выберите тип кисти на всплывающей панели.

  3. Выберите значение в поле Mode (Режим смешивания) (см. главу 2, раздел «Режимы смешивания»). Задайте режим Normal (Нормальный), чтобы размазывать все оттенки цвета, Darken (Затемнить), чтобы добавить темные цвета в более светлые, или Lighten (Осветлить), чтобы подпустить светлых цветов в более темные. Переместите ползунок Pressure (Давление) на значение ниже 100%.
  4. По желанию. На панели опций поставьте флажок Use All Lauers (Использовать все слои), чтобы размазывать цвета со всех видимых слоев изображения (при выборе этой опции снимите флажок Finger Painting (Рисование пальцем)). Снимите флажок Use All Layers (Использовать все слои), чтобы размазывать цвет только с активного слоя. В любом случае, конечно, изменены будут пикселы только активного слоя.
  5. По желанию. Для того чтобы начать процесс размазывания с основного цвета, на панели опций поставьте флажок Finger Painting (Рисование пальцем). Если эта опция отключена, размазывание начнется с цвета той точки, в которой начинается штрих. Чем выше значение параметра Strength (Давление), тем больше основного цвета будет применено.

    Нажмите клавишу Alt, чтобы временно включить опцию Finger painting (Рисование пальцем), если этот флажок снят.

  6. Перетащите курсор через какую-либо область изображения (рис. 12.41-12.44). Если необходимо, сделайте паузу, чтобы программа успела отразить внесенные изменения на экране (стрелкой обозначено направление движения курсора).

Рис. 12.41. Исходное изображение

Рис. 12.42. Результат применения инструмента Smudge в режиме Normal

Рис. 12.43. Результат применения инструмента Smudge в режиме Darken

Рис. 12.44. Результат применения инструмента Smudge в режиме Lighten


  • Глава 13. Градиенты
    • Применение градиента в качестве слоя заливки
    • Использование инструмента Gradient
      • Создание и редактирование образца градиента
      • Сохранение текущих образцов градиента в отдельном файле
      • Использование дополнительных библиотек градиентов
      • Изменение степени непрозрачности цветов градиента
      • Создание многоцветной волны
      • Применение градиентной карты к слою

Глава №13.

Градиенты

Градиентная окраска представляет собой постепенный переход между двумя и более цветами. Программа Photoshop 7 предлагает два способа применения градиента. Первый - использовать инструмент Gradient (Градиент), позволяющий применить градиент непосредственно к содержимому слоя (обратите внимание на новое положение пиктограммы инструмента на палитре инструментов). Этот инструмент пригодится, если вы хотите вручную подогнать градиент к определенной области или залить маску слоя (любого корректирующего слоя или слоя заливки) градиентом, чтобы эффект маскирования проявлялся постепенно.

Второй вариант - использовать новый слой заливки градиентом (gradient fill layer), чтобы градиент находился на своем собственном слое и обладал маской слоя, с помощью которой можно частично маскировать пикселы слоя. Этот последний вид градиента проще редактировать.

Применение градиента в качестве слоя заливки

  1. Выберите какой-либо слой. Инструмент Gradient (Градиент) нельзя применять к изображению в режиме Bitmap или Indexed Color.
  2. По желанию. Выделите область слоя, чтобы ограничить распространение градиента (как это сделать, рассказано ниже, в разделе «Маскирование слоя градиентной заливки»). В противном случае градиентом будет заполнен весь слой.
  3. Выберите пункт Gradient (Градиент) из всплывающего меню, вызываемого нажатием кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои)-см. рис. 13.1.
  4. Вверху диалогового окна щелкните по стрелке в поле Gradient (Градиент) и выберите образец окраски (рис. 13.2).
  5. Теперь выберите значение в поле Style (Стиль): Linear (Линейный), Radial (Радиальный), Reflected (Отраженный), Angular (Угловой) или Diamond (Ромбовидный) - см. рис. 13.3 и 13.4.

    Задайте значение параметра Angle (Угол), переместив указатель или введя какое-либо число.

    Воспользуйтесь ползунком Scale (Масштаб), чтобы настроить масштаб градиента по отношению к слою. Чем выше это значение, тем более плавным будет переход между цветами градиента.

  6. По желанию. Перетащите курсор в окне изображения, чтобы изменить положение градиента. Получится отлично!
  7. Выполните любое из описанных ниже действий.

Рис. 13.1. Создание слоя градиентной заливки

Рис. 13.2. Диалоговое окно Gradient Fill

Рис. 13.3. Выбор стиля градиента

Рис. 13.4. Основные сгили градиентов

Рис. 13.5. Слой градиента и его маска на палитре Layers

Рис. 13.6. Градиент, ограниченный прямоугольной маской, в режиме смешивания Hard Light

Маскирование слоя градиентной заливки

Если перед созданием слоя градиентной заливки вы выделили некоторую область, градиент окажется ограничен ею. Эта предварительно выделенная область на маске слоя градиента будет иметь белый цвет (рис. 13.5, 13.6).

Для ограничения слоя градиентной заливки после его создания щелкните по миниатюре маски слоя и раскрасьте ее.

Поставьте/снимите флажок Reverse (Обратить), чтобы заменить на обратный порядок следования цветов в градиенте.

Поставьте флажок Dither (Размыть), чтобы свести к минимуму возможное появление полосок на градиенте.

Поставьте флажок Align with layer (Выровнять со слоем), чтобы длина градиентной заливки была рассчитана с учетом размеров рамки слоя.

  8. Щелкните по кнопке ОК (рис..13.3).
  9. По желанию. С помощью палитры Layers (Слои) можно изменить непрозрачность и режим смешивания слоя градиентной заливки. Таким образом можно получить очень красивые эффекты. Если у изображения на слое прозрачные границы, дважды щелкните по миниатюрному изображению слоя, чтобы открыть диалоговое окно Layer Style (Стиль слоя), и примените к нему какой-либо эффект.

Для корректировки любой из характеристик градиента дважды щелкните по миниатюре слоя градиентной заливки, снова откроется диалоговое окно Gradient Fill (Залить градиентом). Вот что мы имели в виду, говоря о большей гибкости этого метода.

Параметры градиентной заливки можно настроить, если в окне Gradient Fill (Залить градиентом) щелкнуть по изображению градиента в поле Gradient. Откроется окно Gradient Editor (Правка градиента).

Для того чтобы скрыть слой градиентной заливки, щелкните по его значку в виде глаза. Чтобы удалить этот слой, перетащите его на кнопку (Корзина).

Использование инструмента Gradient

С помощью инструмента Gradient (Градиент) можно окрашивать изображение, просто перетаскивая курсор. Каждый раз при перетаскивании курсора к слою будет применяться новый градиент. Любые дополнительные градиенты, непрозрачность которых меньше 100%, не будут полностью закрывать существующий градиент. В отличие от слоя градиентной заливки, градиент, примененный подобным образом, редактировать довольно сложно.

  1. Выберите или создайте слой.
  2. По желанию. Выделите область на слое. В противном случае градиент заполнит весь слой целиком.
  3. Активизируйте инструмент Gradient Tool (Градиент). «Горячие» клавиши инструмента Gradient - G или Shift+G.
  4. На панели опций инструмента (рис. 13.7 и 13.8) щелкните по стрелке первого поля и выберите образец окраски.

    Щелкните по кнопке стиля градиента: Linear (Линейный), Radial (Радиальный), Angular (Угловой), Reflected (Отраженный) или Diamond (Ромбовидный).

    Выберите в поле Mode (Режим) режим смешивания, а также значение параметра Opacity (Непрозрачность).

  5. Выполните любой из нижеследующих необязательных шагов.

    Поставьте флажок Reverse (Обратить), чтобы изменить порядок следования цветов в градиенте на обратный.

Рис. 13.7. Левая часть панели опций инструмента Gradient

Рис. 13.8. Правая часть панели опций инструмента Gradient

Рис. 13.9. Результат перемещения курсора на большое и малое расстояние при создании линейного градиента

Рис. 13.10. Результат заливки растрового слоя, содержащего текст, градиентом в различных направлениях при установленном флажке Lock transparent pixels

Отметьте опцию Dither (Размыть), чтобы свести к минимуму появление полосок на градиенте.

Поставьте флажок Transparency (Прозрачность), чтобы прозрачные области также можно было залить градиентом (см. ниже раздел «Изменение степени непрозрачности цветов градиента»).

  6. Если вам нужен линейный градиент, перетащите курсор с одной стороны или одного угла изображения или выделенной области в другую(ой). Для создания градиента любого другого стиля тащите курсор из центра в сторону. Перемещайте курсор при нажатой клавише Shift, чтобы угол градиента был кратен 45°. Для удаления градиента удалите соответствующий элемент с палитры History (История).

    Перетащите курсор на большое расстояние, чтобы создать едва уловимый переход цветов, или на небольшое расстояние для создания резкого перехода (рис. 13.9-13.10). Это похоже на действие ползунка Scale (Масштаб) в диалоговом окне Gradient Fill (Заливка градиентом).

Создание и редактирование образца градиента

Если изменить или удалить образец градиента, действительный градиент в текущей библиотеке градиентов не будет затронут; вы автоматически будете работать с копией образца, в том числе при удалении.

  1. По желанию. Откройте палитру Swatches (Образцы), если собираетесь выбирать цвета для градиента, и переместите ее в угол экрана, Это очень удобно, так как при открытом окне Gradient Editor (Правка градиента) вы не сможете ее перемещать.
  2. Активизируйте инструмент Gradient (Градиент), нажав клавишу G или Shift+G, затем на панели опций щелкните по образцу градиента, чтобы открыть окно Gradient Editor (Правка градиента).

    Второй способ: на палитре Layers (Слои) дважды щелкните по миниатюре существующего слоя градиентной заливки, затем вверху диалогового окна Gradient Fill (Заливка градиентом) щелкните по миниатюре градиента.

  3. В диалоговом окне Gradient Editor (Правка градиента) щелкните по образцу, который вы хотите изменить.
  4. Для выбора начального цвета щелкните по начальному маркеру оттенка, расположенному под панелью градиента (рис.13.11).
  5. Щелкните по какому-либо цвету в палитре Swatches (Образцы), которую вы так удобно разместили в углу экрана, либо по панели спектра, расположенной в нижней части палитры Color (Цвет), либо в любом открытом окне изображения.

    Для создания градиента, использующего текущий основной или фоновый цвет, выберите эти цвета из всплывающего меню Color (Цвет), расположенного внизу диалогового окна.

    Кроме того, в окне Gradient Editor (Правка градиента) можно щелкнуть по образцу цвета в поле Color (Цвет) и выбрать цвет на панели Color Picker (Выбор цвета), а затем щелкнуть по кнопке ОК.

  6. Для выбора конечного цвета щелкните по маркеру конечного оттенка, расположенному справа под панелью градиента, затем повторите шаг 5.
  7. Выполните любое из перечисленных ниже действий.

Рис. 13.11. Диалоговое окно Gradient Editor

Рис. 13.12. Изменение градиента в зависимости от значения параметра Location

Для того чтобы добавить промежуточный цвет в градиент, щелкните под панелью градиента, чтобы создать для него маркер, затем, выполнив шаг 5, выберите цвет.

Перетащите маркер промежуточного цвета.

Для контроля над резкостью перехода цветов переместите в любое место маркер в форме ромба, указывающий такую точку, в которой цвета справа и слева находятся в равных пропорциях (по 50% каждый). Либо щелкните по ромбу и в поле Location (Положение) введите какое-либо значение в процентах (рис. 13.12). 0% означает самое левое положение, 100% - самое правое.

Переместите маркер начального или конечного цвета либо введите новое значение в поле Location (Положение) для любого из них.

Для того чтобы удалить цвет, перетащите его маркер вниз от панели.

Воспользуйтесь «горячими» клавишами Ctrl+Z, если хотите отменить последнюю операцию.

  8. Введите какое-либо имя в поле Name (Имя) и щелкните по кнопке New (Создать). Каждый раз при редактировании градиента его имя автоматически меняется на Custom (По выбору пользователя), чтобы гарантировать, что вы работаете с копией градиента, а не с оригиналом.
  9. Щелкните по кнопке ОК. Теперь новый образец градиента доступен на панели выбора градиентов для дальнейшего использования.

О том, как сохранить образцы, находящиеся в данный момент на панели выбора градиента, в виде файла, рассказано,ниже, в разделе «Сохранение текущих образцов градиента в отдельном файле».

Для переименования образца дважды щелкните по нему, введите новое имя и щелкните по кнопке ОК.

Для того чтобы удалить образец, нажмите клавишу Alt и щелкните по нему.

На рис. 13.13 показан еще один способ создания градиента. Из всплывающего меню в поле Gradient Type (Тип градиента) выберите вариант Noise (Шум), чтобы получить градиент из случайно выбранных цветов, входящих в заданный диапазон, и с указанным значением параметра Roughness (Резкость). Чем меньше значение параметра Roughness (Резкость), тем более гладким будет переход цветов. Диапазон цветов зависит от модели, выбранной из всплывающего меню Color Model (Модель цвета).

Сохранение текущих образцов градиента в отдельном файле

  1. Для того чтобы открыть диалоговое окно Gradient Editor (Правка градиента), активизируйте инструмент Gradient (Градиент) и на панели опций щелкните по образцу градиента. Либо дважды щелкните по миниатюре существующего слоя градиентной заливки на палитре Layers (Слои), а затем вверху диалогового окна Gradient Fill (Заливка градиентом) щелкните по образцу градиента.
  2. Щелкните по кнопке Save (Сохранить), введите какое-либо имя (сохраните расширение .grd), оставьте файл в папке Adobe Photoshop 7.0/Presets/Gradients и щелкните по кнопке Save (Сохранить).

Рис. 13.13. Создание градиента на основе цветовой модели

Рис. 13.14. Выбор библиотеки градиентов

Восстановление стандартных библиотек

Из меню окна Gradient Editor (Правка градиента) выберите пункт Reset Gradients (Восстановить градиенты) и щелкните по кнопке ОК. Все недавно созданные или недавно измененные образцы будут удалены!

Рис. 13.15. Маркер непрозрачности на панели градиента

Все градиенты, которые в данный момент отображаются на панели образцов, будут сохранены в этом отдельном файле. Его имя появится в меню панели выбора градиентов при перезагрузке программы Photoshop.

  3. Щелкните по кнопке ОК.

Использование дополнительных библиотек градиентов

  1. Откройте диалоговое окно Gradient Editor (Правка градиента), как сказано в п. 1 предыдущего раздела, либо щелкните по стрелке в поле с образцом градиента, чтобы открыть панель выбора.
  2. Вверху палитры щелкните по стрелке в кружочке, затем из нижней части меню выберите библиотеку градиентов (рис. 13.14). Библиотеки, определенные пользователем в результате выполнения инструкций предыдущего раздела, появятся под списком стандартных библиотек Adobe Photoshop.
  3. Щелкните по кнопке Append (Добавить), чтобы добавить выбранную библиотеку к текущим образцам, или щелкните по кнопке ОК, чтобы заменить текущие образцы элементами выбранной библиотеки.

Изменение степени непрозрачности цветов градиента

  1. Откройте диалоговое окно Gradient Editor (Правка градиента) и щелкните по образцу, который вы хотите изменить.
  2. Щелкните по маркеру непрозрачности, расположенному сверху панели градиента (рис. 13.15).
  3. Выберите уровень непрозрачности (можно ввести число или переместить ползунок). Взгляните на панель градиента, чтобы предварительно оценить достигнутый эффект.
  4. Выполните любое из перечисленных ниже действий.

    Для того чтобы добавить дополнительные маркеры непрозрачности, щелкните сверху панели градиента и введите процент непрозрачности для каждого маркера.

    Для удаления маркера перетащите его вверх от панели градиента.

    Чтобы переместить маркер, перетащите его или измените значение его параметра Location (Положение).

    Для изменения положения срединной точки перетащите один из ромбов, расположенных сверху панели, управляющей прозрачностью, или щелкните по ромбу и измените значение параметра Location (Положение).

  5. Введите какое-либо имя и щелкните по кнопке New (Создать).
  6. Щелкните по кнопке ОК (рис. 13.16). В упражнении следующего раздела используются полупрозрачные градиенты на нескольких слоях.

Создание многоцветной волны

  1. Выберите какой-либо слой.
  2. По желанию. Выделите некоторую область слоя.
  3. Выберите пункт Gradient (Градиент) из всплывающего меню, которое вызывается нажатием кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).
  4. В диалоговом окне Gradient Fill (Заливка градиентом) щелкните по образцу градиента, чтобы открыть окно Gradient Editor (Правка градиента).

Рис. 13.16. Изображение, полученное при помощи двух градиентов, расположенных на отдельных слоях и имеющих в середине непрозрачность равную 20%, что позволяет увидеть шары

  5. В этом окне либо выберите существующий образец градиента, край которого постепенно становится прозрачным, либо создайте новый, постепенно исчезающий градиент и щелкните по кнопке ОК.
  6. Выберите значения параметров Style (Стиль), Angle (Угол) и Scale (Масштаб) для слоя градиента и щелкните по кнопке ОК.
  7. Создайте другой слой градиента и повторите шаги 4 и 5. Попробуйте различные значения параметров Style (Стиль), Angle (Угол) и Scale (Масштаб) или перетащите градиент в окне изображения (рис. 13.17, 13.18).
  8. По желанию. С помощью палитры Layers (Слои) измените уровень непрозрачности или режим смешивания слоев градиента или перекомпонуйте их.

Рис. 13.17. Создание слоев градиентной заливки

Рис. 13.18. Ромбовидный и линейный градиенты

Применение градиентной карты к слою

Мы оставили одну из четырех наших любимых возможностей программы напоследок. Команда Gradient Map (Градиентная карта) применяет градиент с учетом уровней освещенности (ярких И темных тонов) нижележащего слоя. Эту команду можно использовать для тонирования полутонового изображения или для повторного рендеринга цветного изображения в новых тонах, причем результат может быть как едва уловимым, так и очень ярким. Если применить команду Gradient Map (Градиентная карта) с помощью корректирующего слоя, результат можно будет редактировать в полном объеме.

Начальный (левый) цвет выбранного градиента применяется к темным областям слоя, конечный (правый) цвет - к светлым областям. Все дополнительные маркеры цвета, добавленные к градиенту, будут учтены при обработке средних тонов слоя. Число переходов цвета в результате зависит от числа маркеров цвета в выбранном градиенте.

  1. Выберите какой-либо слой.
  2. Выберите команду Gradient Map (Градиентная карта) из всплывающего меню, которое вызывается нажатием кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).

    Можно применить градиентную карту непосредственно к слою, выбрав команду Image > Adjustmens > Gradient Map (Изображение > Корректировки > Градиентная карта), но мы предпочитаем корректирующий слой, так как он предоставляет большую гибкость действий. Градиентную карту, примененную непосредственно к слою, нельзя заново редактировать или удалять.

  3. Щелкните по стрелке градиента, чтобы открыть панель выбора, щелкните по образцу градиента, затем снова по стрелке, чтобы закрыть панель выбора, а затем нажмите кнопку ОК.

    Можно также щелкнуть и по градиенту в окне Gradient Map (Градиентная карта), чтобы открыть окно Gradient Editor (Правка градиента) - см. рис. 13.19.

  4. Измените начальный и/или конечный цвета и добавьте больше маркеров цвета в середине градиента, чтобы повлиять на цвет средних тонов изображения.

    Если градиент содержит четыре цветовых маркера, в слое будет четыре основных цветовых области. Переместите цветовые маркеры, чтобы изменить распределение цветов в слое, и щелкните по кнопке ОК.

  5. По желанию. Поставьте флажок Dither (Размыть), чтобы добавить элемент случайности в переходные области цвета в слое и избежать появления полос.
  6. По желанию. Поставьте флажок Reverse (Обратить), чтобы изменить направление цветов градиента на противоположное. Аналогичным образом будет изменено и распределение цветов.
  7. Щелкните по кнопке ОК (рис. 13.20-13.22). Для того чтобы отредактировать карту градиента, на палитре Layers (Слои) в любой момент дважды щелкните по миниатюре слоя с картой градиента.

Для усиления контраста цветов, созданных с помощью корректирующего слоя градиентной карты, создайте корректирующий слой при помощи команды Posterize (Превратить в плакат), установив 4-6 уровня, затем поместите этот слой между слоем изображения и слоем градиентной карты.

Рис. 13.19. Окно Gradient Map

Рис. 13.20. Эффект применения градиентной карты

Рис. 13.21. Эффект применения градиентной карты

Рис. 13.22. Эффект применения градиентной карты


  • Глава 14. Дополнительные сведения о слоях
    • Непрозрачность слоя
      • Изменение непрозрачности слоя
    • Эффекты слоя
      • Применение эффектов слоя
      • Применение эффектов Drop Shadow и Inner Shadow
      • Применение эффекта Outer Glow и Inner Glow
      • Применение эффекта Bevel and Emboss
      • Изменение профиля контура
      • Применение эффекта Satin
      • Применение эффекта Color Overlay
      • Применение эффекта Gradient Overlay
      • Применение эффекта Pattern Overlay
      • Применение эффекта Stroke
      • Другие команды, связанные с эффектами
    • Смешивание слоев
      • Режимы смешивания слоев
      • Настройка параметров смешивания двух слоев
      • Дополнительные режимы смешивания
      • Выбор опции Knockout для слоя
      • Смешивание модифицированного слоя с исходным
    • Маски слоя
      • Создание маски слоя
      • Изменение формы маски слоя
      • Раздельное перемещение маски и слоя
      • Создание дубликата маски слоя
      • Выбор опций отображения маски слоя
      • Заливка текста изображением с помощью маски слоя
      • Временное удаление эффектов маски слоя
      • Применение и удаление эффектов маски слоя
    • Группы отсечений
      • Создание группы отсечения
      • Удаление слоя из группы отсечения
    • Связывание слоев
      • Связывание слоев и их перемещение как единого целого
      • Выравнивание двух или более связанных слоев
      • Выравнивание границы слоя по выделенной области
      • Распределение трех и более связанных слоев

Глава №14.

Дополнительные сведения о слоях

Рис. 14.1. Выбор уровня непрозрачности слоя на палитре Layers

В этой главе вы узнаете о более сложных и используемых настоящими профессионалами возможностях, слоев в программе Photoshop. Но сначала прочитайте главу 7, чтобы узнать об основных операциях со слоями. (О корректирующих слоях рассказывается в главе 9, раздел «Корректирующие слои»).

Непрозрачность слоя

Изменение непрозрачности слоя

На палитре Layers (Слои) можно задать уровень непрозрачности слоя. В Photoshop 7 по сравнению с предыдущими версиями существует возможность задать как основной уровень непрозрачности (поле Opacity), так и внутренний (поле Fill) (рис. 14.1). Чем ниже эти значения, тем больше пикселов лежащего ниже слоя будет видно сквозь активный слой (рис. 14.2, 14.3). Непрозрачность фона нельзя изменить.

Активизируйте какой-либо инструмент, отличный от инструмента рисования, затем нажмите клавишу 1, чтобы сделать непрозрачность активного слоя равной 10%, клавишу 2 - 20% и т.д. Либо быстро наберите две цифры на клавиатуре (например, 15 для 15%).

Также непрозрачность слоя можно изменить, используя параметры раздела Blending Options (Опции смешивания) диалогового окна Layer Style (Стиль слоя), о чем подробнее написано в главе 14, раздел «Настройка параметров смешивания двух слоев»).

Рис. 14.2. Слой карты с непрозрачностью 100%, расположенный поверх слоя авокадо

Рис. 14.3. Результат уменьшения непрозрачности слоя карты до 58%

Эффекты слоя

Применение эффектов слоя

К слою можно применить следующие специальные эффекты: Drop Shadow (Отбросить тень), Inner Shadow (Внутренняя тень), Outer Glow (Внешнее свечение), Inner Glow (Внутреннее свечение), Bevel and Emboss (Скос и рельеф), Satin (Атлас), Color Overlay (Наложение цвета), Gradient Overlay (Наложение градиента), Pattern Overlay (Наложение узора) и Stroke (Кайма). Эффект(ы) слоя могут быть применены к любому слою, даже к редактируемому текстовому слою, и в любой момент их можно включить/выключить. Эффект слоя автоматически влияет на все непрозрачные точки слоя и обновляется при добавлении, изменении или удалении пикселов со слоя.

Не путайте стили и эффекты. Стиль - это просто сочетание одного или нескольких эффектов слоя.

Эффекты применяются и редактируются с помощью диалогового окна Layer Style (Стиль слоя) (рис. 14.4) или всплывающего меню Add layer style (Добавить стиль слоя), содержащего названия эффектов (рис. 14.5). Галочка рядом с элементом меню означает, что данный эффект уже применен к текущему слою. На палитре Layers (Слои) эффекты отображаются в виде списка под элементом слоя, к которому они применены (рис. 14.6). Эффекты связываются с главным слоем, к которому они были применены, и перемещаются вместе с ним. Эффекты слоя нельзя применить к фону изображения.

Рис. 14.4. Диалоговое окно Layer Style

Прежде чем пойдет речь об отдельных эффектах, сообщим основную информацию, которую необходимо знать пользователю:

  • для того чтобы применить эффект слоя, дважды щелкните по имени слоя. В диалоговом окне Layer Style (Стиль слоя) щелкните по имени какого-либо эффекта (не ограничивайтесь только флажком!) и выберите параметры эффекта.

    К одному слою можно применить несколько эффектов. Поставьте флажок Preview (Предварительный просмотр), чтобы предварительно просмотреть результат . в окне изображения. Также к слою можно применить эффект, выбрав слой, а затем элемент из всплывающего меню Add layer style (Добавить стиль слоя), которое вызывается нажатием кнопки, расположенной внизу палитры Layers (Слои);

  • на палитре Layers (Слои) каждый слой, к которому был применен эффект, снабжен особой пиктограммой цу. Щелкните по стрелке рядом с этим значком, чтобы увидеть список эффектов, примененных к данному слою (рис. 14.6). У каждого эффекта есть собственная пиктограмма в виде глаза, используемая для отображения/скрытия эффекта;
  • для редактирования существующего эффекта слоя (или для добавления еще одного) или по имени эффекта в списке, расположенном под именем слоя; можно также выбрать эффект из всплывающего меню Add layer style (Добавить стиль слоя), расположенной внизу палитры Layers (Слои);

Рис. 14.5. Меню эффектов слоя

Рис. 14.6. Список эффектов слоя на палитре Layers

Копирование эффекта из одного слоя в другой

Выберите какой-либо слой, содержащий эффект(ы), воспользуйтесь командой Layer > Layer Style > Copy Layer Style (Слой > Стиль слоя > Копировать стиль слоя), выберите другой слой, а затем выполните команду Layer > Layer Style > Paste Layer Style (Слой > Стиль слоя > Вставить стиль слоя).

Можно также открыть список эффектов слоя и перетащить имя отдельного эффекта на имя другого слоя или на панель Effects (Эффекты) другого слоя.

Для копирования нескольких эффектов из одного слоя в другой откройте список эффектов слоя и перетащите панель Effects на другое имя слоя или панель Effects другого слоя. Дубликат эффекта заменит существующий эффект в целевом слое.

  • для того чтобы скрыть эффект слоя, разверните список примененных к данному слою эффектов, затем щелкните по значку в виде глаза. (Щелкните по нему еще раз, чтобы снова отобразить эффект.)

    Для того чтобы временно скрыть все эффекты для всех слоев и увеличить быстродействие программы, выберите команду Layer > Layer Style > Hide All Effects (Слой > Стиль слоя > Спрятать все эффекты). Выберите из того же меню команду Show All Effects (Показать все эффекты), чтобы снова отобразить их;

  • для удаления отдельного эффекта слоя дважды щелкните по имени слоя или имени отдельного эффекта на палитре Layers (Слои), затем снимите флажок рядом с именем эффекта. Или перетащите имя отдельного эффекта на кнопку Delete Layer (Удалить слой) в виде корзины, расположенную внизу палитры Layers (Слои).

Если снова поставить флажок рядом с названием эффекта, с которого флажок был снят или который был удален, он будет отображен с учетом значений параметров, установленных последними.

Для очистки всех эффектов текущего активного слоя выберите команду Layer Style > Clear Layer Style (Стиль слоя > Очистить стиль слоя).

Нажав клавишу Alt, щелкните по кнопке Reset (Восстановить), чтобы восстановить те значения параметров диалогового окна Layer Style (Стиль слоя), которые действовали до его открытия.

Применение эффектов Drop Shadow и Inner Shadow

  1. Дважды щелкните по имени какого-либо слоя.
  2. Щелкните по названию эффекта Drop Shadow (Отбросить тень).
  3. Измените любой из перечисленных ниже параметров (рис. 14.7).

    Из всплывающего меню Blend Mode (Режим смешивания) выберите режим смешивания.

    Щелкните по образцу цвета, чтобы выбрать другой цвет для тени на панели выбора цветов (он сразу же будет виден), и щелкните по кнопке ОК.

    Выберите уровень непрозрачности тени.

    Выберите значение параметра Angle (Угол), определяющего угол тени относительно фигур исходного слоя. Установите флажок Use Global Light (Использовать глобальное освещение), чтобы использовать то значение угла, которое было введено в диалоговом окне Layer > Layer Style > Global Light (Слой > Стиль слоя > Глобальный свет). Снимите этот флажок, если хотите использовать необычный угол для данного эффекта.

Если изменить угол для отдельного эффекта при установленном флажке Use Global Light (Использовать глобальное освещение), то угол для всех эффектов, использующих эту опцию, также будет изменен. Такая возможность помогает сделать однородным освещение нескольких слоев.

Выберите значение параметра Distance (Расстояние), определяющего расстояние (в пикселах) от тени до фигуры исходного слоя или ширину внутренней тени (рис. 14.8, 14.9).

Рис. 14.7. Раздел Drop Shadow диалогового окна Layer Style

Рис. 14.8. Эффект Drop Shadow

Рис. 14.9. Сочетание эффектов Inner Shadow и Drop Shadow

Рис. 14.10. Исходный слой с эффектом Drop Shadow

Пока открыто диалоговое окно, можно перетащить тень в окне изображения. К сожалению, это приведет к перемещению всех эффектов, использующих опцию Use Global Light (Использовать глобальное освещение).

Выберите значение параметра Spread (Распространение), определяющего степень размытости тени. Для эффекта Inner Shadow (Внутренняя тень) выберите значение параметра Choke (Уменьшение), позволяющего сузить тень.

Задайте размер тени при помощи ползунка Size (Размер).

В группе параметров Quality (Качество) щелкните по стрелке Contour (Контур), чтобы выбрать контур для границы тени на специальной панели (также см. раздел «Изменение профиля контура» этой главы).

Поставьте флажок Anti-aliased (Сглаживание), чтобы смягчить зубчатые границы между тенью и другими частями изображения.

Установите уровень шума с помощью параметра Noise (Шум), чтобы отрегулировать степень хаотичности на границе тени.

Поставьте флажок Layer Knocks Out Drop Shadow (Запретить просвечивание тени), чтобы сквозь прозрачные области слоя не было видно тень.

  4. Щелкните по кнопке ОК.

Трансформация эффекта Drop Shadow

  1. Примените к изображению эффект Drop Shadow (Отбросить тень), как описано выше (рис. 14.10), и не снимайте выделения со слоя.
  2. Выберите команду Layer > Layer Style > Create Layer (Слой > Стиль слоя > Создать слой), чтобы преобразовать эффект слоя в отдельный слой.
  3. Активизируйте новый слой (рис. 14.11).
  4. Выберите команду Edit > Transform > Distort (Правка > Трансформация > Искажение), затем перетащите манипуляторы рамки, чтобы придать ей желаемую форму (рис. 14.12, 14.13).
  5. По желанию. Измените яркость тени с помощью корректирующего слоя или выбрав другой режим смешивания и уровень непрозрачности слоя тени. На палитре Layers (Слои) поставьте флажок Lock transparent pixels (Блокировать прозрачные точки), чтобы действие операций заливки и рисования не выходило за границы тени.

Свяжите слой тени и слой исходного объекта, чтобы перемещать их синхронно.

Создание эффекта Drop Shadow без использования эффекта слоя

Для выполнения данного упражнения выделите текст и сохраните выделенную область в канале, а затем загрузите канал в качестве выделенной области.

  1. Выделите какую-либо область, которая в дальнейшем будет определять форму тени. Для этого нажмите клавишу Ctrl и щелкните по объекту слоя.
  2. Растушуйте немного границы выделенной области (комбинация клавиш Ctrl+Alt+D.
  3. Выберите команду Select > Transform Selection (Выделить > Трансформировать выделенную область) или щелкните правой кнопкой мыши и из контекстного меню выберите команду Transform Selection (Трансформировать выделенную область), а затем измените и/или переместите рамку выделения.

Рис. 14.11. Активизация нового слоя Drop Shadow

Рис. 14.12. Искажение слоя Drop Shadow

Рис. 14.13. Результирующее изображение

Рис. 14.14. Раздел Inner Glow диалогового окна Layer Style

  4. Внизу палитры Layers (Слои) щелкните по кнопке Create new layer (Создать новый слой), затем поместите новый слой непосредственно под слоем, содержащим исходный объект.
  5. Выберите команду Edit > Fill (Правка > Залить) и установите следующие значения параметров: Fill (Заливка) - Black (Черный), Mode (Режим) - Normal (Нормальный), Opacity (Непрозрачность) - 75%, щелкните по кнопке ОК, затем снимите выделение с области.
  6. С помощью инструмента Move (Перемещение) переместите слой тени. Также можно изменить его режим смешивания и уровень непрозрачности.

Применение эффекта Outer Glow и Inner Glow

  1. Откройте палитру Swatches (Образцы).
  2. Дважды щелкните по имени какого-либо слоя.
  3. Щелкните по названию эффекта Outer Glow (Внешнее свечение) или Inner Glow (Внутреннее свечение).
  4. Задайте значения параметров в разделе Structure (Структура) - см. рис. 14.14.

    Выберите подходящий вариант в выпадающем меню Blend Mode (Режим смешивания). О том, как это сделать, написано в главе 2, раздел «Режимы смешивания».

    Для изменения цвета свечения щелкните по образцу цвета, выберите оттенок на всплывающей панели (или из палитры Swatches (Образцы), пока открыта панель Color Picker). Выберите цвет, контрастирующий с фоновым, потому что сложно увидеть светлый цвет внешнего свечения на светлом фоне. Цвет будет предварительно показан в окне изображения. Щелкните по кнопке ОК.

    Для создания свечения из градиента щелкните по стрелке, чтобы выбрать градиент на всплывающей панели, или по миниатюре градиента, чтобы изменить один из имеющихся образцов или создать новый (подробнее об этом рас сказано в главе 13, раздел «Создание и редактирование образца градиента»).

  5. Выберите значение параметра Opacity (Непрозрачность) для свечения.

    Также установите значение параметра Noise (Шум), определяющего степень хаотичности свечения.

    Выберите значения параметров в разделе Elements (Элементы).

    Из всплывающего меню Technique (Техника) выберите вариант Softer (Мягче) или Precise (Точно) для контроля над тем, насколько точно маска соответствует контуру области.

    Для эффекта Inner Glow (Внутреннее свечение) поставьте переключатель в положение Center (Центр), чтобы создать свечение, исходящее из центра пикселов слоя (рис. 14.15). Если переключатель установлен в положение Edge (Граница), создается свечение, исходящее внутрь от границ объекта.

    В случае эффекта Outer Glow (Внешнее свечение) установите величину параметра Spread (Распространение), чтобы определить ширину свечения (на самом деле, маски) до начала размытия (рис. 14.16).

    Для эффекта Inner Glow (Внутреннее свечение) подкорректируйте величину параметра Choke (Уменьшение), чтобы определить ширину свечения до момента, когда оно начнет размываться.

    Укажите размер свечения при помощи параметра Size (Размер).

Рис. 14.15. Эффект Inner Glow в сочетании с эффектом Drop Shadow в режиме Center

Рис. 14.16. Эффект Outer Glow

Рис. 14.17. Раздел Bevel and Emboss диалогового окна Layer Style

Рис. 14.18. Эффект Outer Bevel

Рис. 14.19. Эффект Inner Bevel в сочетании с эффектом Drop Shadow

Рис. 14.20. Эффект Emboss в сочетании с эффектом Drop Shadow

Рис. 14.21. Эффект Pillow Emboss

  6. Выберите значения параметров в разделе Quality (Качество).

    Щелкните по стрелке в поле Contour (Контур), чтобы выбрать образец контура для профиля границы свечения (см. раздел «Изменение профиля контура» этой главы).

    Установите значение параметра Range (Диапазон) для контроля над расположением эффекта контура внутри свечения.

    Если свечение содержит градиент, установите значение параметра Jitting (Дрожание), чтобы случайным образом распределить цвета в градиенте.

  7. Щелкните по кнопке ОК.

Перед применением эффекта слоя к тексту сделайте буквы крупными и расположите их не слишком близко друг к другу.

Применение эффекта Bevel and Emboss

Эффект Bevel and Emboss (Скос и рельеф) создает иллюзию объема путем добавления света и тени к фигурам слоя.

  1. Откройте палитру Swatches (Образцы).
  2. На палитре Layers (Слои) дважды щелкните по имени какого-либо слоя. Это может быть и текстовый слой.
  3. Щелкните по названию эффекта Bevel and Emboss (Скос и рельеф).
  4. Выберите значения параметров в разделе Structure (Структура) - см. рис. 14.17.

    В меню Style (Стиль) выберите один из вариантов: Outer Bevel (Внешний скос) (рис. 14.18), Inner Bevel (Внутренний скос) (рис. 14.19), Emboss (Рельеф), Pillow Emboss (Выпуклый рельеф) или Stroke Emboss (Рельефная кайма) (рис. 14.20, 14.21).

    Из всплывающего меню Technique (Техника) выберите вариант Smooth (Гладко), Chisel Hard (Твердый резец) или Chisel Soft (Мягкий резец).

    Выберите значение параметра Depth (Глубина), чтобы указать степень смещения светлых участков и тени от фигур слоя.

    Переключатели Up (Вверх) и Down (Вниз) позволяют поменять местами положение света и тени.

    Выберите значение параметра Size (Размер) для эффекта.

    Увеличьте значение параметра Soften (Смягчить), если хотите размыть четкие границы фигуры и, таким образом, смягчить эффект.

  5. Выберите значения параметров в разделе Shading (Затенение).

    Параметры Angle (Угол) и Altitude (Высота) определяют положение источника света, что в свою очередь влияет на блики и тени. Поставьте флажок Use Global Light (Использовать глобальное освещение), чтобы воспользоваться текущими значениями параметров Angle (Угол) и Altitude (Высота) из диалогового окна Layer > Layer Style > Global Light (Слой > Стиль слоя > Глобальное освещение). Или снимите этот флажок, чтобы использовать другие значения названных параметров для конкретного стиля. Осторожно: если изменять значения Angle (Угол) и Altitude (Высота) для отдельного стиля в то время, как стоит флажок Use Global Light (Использовать глобальное освещение), другие стили, также использующие эту опцию, будут изменены.

    Щелкните по стрелке Gloss Contour (Контур блеска) и выберите образец на всплывающей панели (см. раздел «Изменение профиля контура» данной главы).

Рис. 14.22. Опции текстуры для эффекта Bevel and Emboss

Рис. 14.23. Текстура Adobe Tie Dye в сочетании с эффектом Bevel and Emboss

Выберите значения параметров Highlight Mode (Режим света) и Opacity (Непрозрачность) или Shadow Mode (Режим - тени) и Opacity (Непрозрачность) для светлых и темных областей изображения соответственно (подробнее об этом рассказано в главе 2, раздел «Режимы смешивания»).

Для изменения цвета светлых или темных тонов щелкните по любому образцу цвета и выберите новый тон на панели Color Picker (или пока открыта панель Color Picker, из палитры Swatches (Образцы)). Цвет будет предварительно показан в окне изображения. Затем щелкните по кнопке ОК.

  6. Для того чтобы добавить определенный контур к эффекту Bevel and Emboss (Скос и рельеф), влияющий на границы свечения, щелкните по надписи Contour (Контур), расположенной слева в диалоговом окне Layer Style (Стиль слоя) под заголовком Bevel and Emboss (Скос и рельеф). Щелкните по стрелке в поле Contour (Контур) и выберите образец на всплывающей панели (см. раздел «Изменение профиля контура» данной главы). Эта опция может кардинально изменить результат.

    Установите значение параметра Range (Диапазон), чтобы определить расположение эффекта контура в пределах свечения. Эта опция никак не влияет на эффект Emboss (Рельеф).

    Поставьте флажок Anti-aliased (Сглаживание), если хотите смягчить четкие границы примыкающих областей.

  7. Для того чтобы добавить текстуру к эффекту, щелкните по надписи Texture (Текстура), расположенной слева в диалоговом окне Layer Style (Стиль слоя) под заголовком Bevel and Emboss (Скос и рельеф), затем по стрелке поля Texture (Текстура) и выберите рисунок на всплывающей панели (рис. 14.22,14.23). Выполните любое из перечисленных ниже действий.

    Отрегулируйте масштаб рисунка при помощи ползунка Scale (Масштаб).

    Измените значение параметра Depth (Глубина), чтобы подкорректировать контраст светлых и темных цветов рисунка.

    Поставьте флажок Invert (Инвертировать), чтобы поменять местами светлые и темные области. Это даст такой же эффект, что и при изменении значения параметра Depth (Глубина) с отрицательного на положительное и наоборот.

    Поставьте флажок Link with Layer (Связать со слоем), чтобы текстура и слой перемещались синхронно.

    Перетащите курсор в окне изображения, если хотите изменить положение текстуры внутри эффекта. Щелкните по кнопке Snap to Origin (Привязать к началу координат), чтобы выровнять узор относительно верхнего левого угла изображения.

    Если вы загрузили узор, определенный пользователем, щелкните по кнопке Create new preset (Создать новый образец), чтобы добавить его к остальным образцам.

  8. Щелкните по кнопке ОК.

Изменение профиля контура

Для всех эффектов слоя, кроме эффектов Overlay (Наложение) и Stroke (Кайма), можно выбрать стиль границы, называемый контуром. Контур управляет такими элементами, как постепенное исчезновение тени или уменьшение освещенности на скосах. Выполните следующие шаги, если хотите изменить контур эффекта.

  1. Дважды щелкните по имени слоя или эффекта, чтобы открыть диалоговое окно Layer Style (Стиль слоя). Только в случае эффекта Bevel and Emboss (Скос и рельеф) щелкните по надписи Contour (Контур) в левой части диалогового окна.
  2. Щелкните по миниатюре контура (не по стрелке).
  3. По желанию. В диалоговом окне Contour Editor (Правка контура) выберите контур во всплывающем меню Preset (Образец), который будет использоваться в качестве исходного образца (рис. 14.25).
  4. Щелкните по графику, чтобы добавить несколько новых точек. Перетащив точку, измените график. Во всплывающем меню Preset (Образец) автоматически появится имя Custom (Определен пользователем).

    Поставьте флажок Corner (Угол), чтобы преобразовать выделенную в данный момент точку в угловую.

  5. Для того чтобы сохранить полученный график в файле для последующего использования, щелкните по кнопке Save (Сохранить), введите какое-либо имя, а затем снова щелкните по кнопке Save.
  6. Щелкните по кнопке ОК, чтобы закрыть диалоговое окно Contour Editor (Правка контура).

Рис. 14.24. Миниатюры профилей

Рис. 14.25. Построение контура с помощью диалогового окна Contour Editor

Для удаления контура откройте панель выбора контуров, затем, нажав клавишу Alt, щелкните по контуру, который хотите удалить, и закройте панель выбора. Примечание: контур будет удален только с текущей панели выбора, а не из настоящей библиотеки образцов.

Для восстановления стандартной библиотеки контуров откройте панель выбора контуров и в меню панели выполните команду Reset Contours (Восстановить контуры), затем щелкните по кнопке ОК. Если вы хотите загрузить другую библиотеку, выберите ее имя в нижней части меню панели, затем щелкните по кнопке Append (Добавить) или ОК, чтобы заменить текущую библиотеку.

Выбор контура

Миниатюры профилей на панели выбора контуров иллюстрируют различные стили границ (рис. 14.24). Серые области представляют собой непрозрачные пикселы, белые - прозрачные. Для того чтобы закрыть панель выбора, щелкните по стрелке в поле Contour (Контур) или где-либо вне панели в диалоговом окне Layer Style (Стиль слоя).

Применение эффекта Satin

  1. На палитре Layers (Слои) дважды щелкните по имени какого-либо слоя.
  2. Щелкните по названию эффекта Satin (Атлас).
  3. Выполните любой из перечисленных ниже шагов (рис. 14.26).

    Измените значение поля Blend Mode (Режим смешивания), руководствуясь рекомендациями, приведенными в главе 2, раздел «Режимы смешивания».

    Для изменения цвета щелкните по образцу и выберите цвет на всплывающей панели.

    Теперь отрегулируйте значение параметра Opacity (Непрозрачность).

    Измените значение параметра Angle (Угол). Этот угол не зависит от значения параметра Global Light (Глобальное освещение).

    Установите значения параметров Distanсе (Расстояние) и Size (Размер). Также можно перетащить эффект в окне изображения, чтобы изменить значение параметра Distance (Расстояние).

    Щелкните по стрелке в поле Contour (Контур), затем выберите профиль границы эффекта на всплывающей панели.

    Поставьте флажок Anti-aliased (Сглаживание), чтобы смягчить резкую границу между эффектом и нижележащей фигурой.

    Поставьте флажок Invert (Инвертировать), чтобы поменять местами светлые и темные области.

  4. Щелкните по кнопке ОК (рис. 14.27 и 14.28).

Рис. 14.26. Опции эффекта Satin

Рис. 14.27. Эффект Satin, примененный к редактируемому тексту

Рис. 14.28. Эффект Satin с установленным флажком Invert

Рис. 14.29. Опции эффекта Color Overlay

Рис. 14.30. Опции эффекта Gradient Overlay

Рис. 14.31. Эффект Gradient Overlay, стиль Reflected, с установленным флажком Reverse

Применение эффекта Color Overlay

  1. На палитре Layers (Слои) щелкните по имени какого-либо слоя.
  2. Щелкните по названию эффекта Color Overlay (Наложение цвета).
  3. Выполните любое из перечисленных ниже действий (рис. 14.29).

    Выберите значение параметра Blend Mode (Режим смешивания).

    Щелкните по образцу цвета и выберите другой цвет для наложения.

    Подкорректируйте значение параметра Opacity (Непрозрачность).

  4. Щелкните по кнопке ОК.

Применение эффекта Gradient Overlay

  1. На палитре Layers (Слои) дважды щелкните по имени слоя.
  2. Щелкните по названию эффекта Gradient Overlay (Наложение градиента).
  3. Выполните любое из перечисленных ниже действий (рис. 14.30).

    Выберите значение параметра Blend Mode (Режим смешивания).

    Теперь отрегулируйте значение параметра Opacity (Непрозрачность).

    Щелкните по стрелке в поле Gradient (Градиент), затем выберите образец окраски на всплывающей панели.

    Поставьте флажок Reverse (Обратить), чтобы изменить направление градиента.

    Выберите значение в поле Style (Стиль): Linear (Линейный), Radial (Радиальный), Angle (Угловой), Reflected (Отраженный) или Diamond (Ромбовидный).

    Поставьте флажок Align with Layer (Выровнять со слоем), чтобы выровнять градиент относительно фигур слоя.

    Установите значение параметра Angle (Угол) для градиента.

    Выберите значение параметра Scale (Масштаб) для определения положения срединной точки градиента.

    Также можно перетащить градиент в окне изображения, чтобы изменить его положение.

  4. Щелкните по кнопке ОК (рис. 14.31). Подробнее о градиентах читайте в главе 13.

Применение эффекта Pattern Overlay

  1. На палитре Layers (Слои) дважды щелкните по имени какого-либо слоя.
  2. Щелкните по названию эффекта Pattern Overlay (Наложение узора).
  3. Выполните любое из перечисленных ниже действий (рис. 14.32).

    Выберите значение параметра Blend Mode (Режим смешивания).

    Теперь отрегулируйте значение параметра Opacity (Непрозрачность).

    Щелкните по стрелке в поле Pattern (Узор) и выберите желаемый образец на всплывающей панели.

    Щелкните по кнопке Snap to Origin (Привязать к началу координат), чтобы выровнять узор относительно верхнего левого угла изображения. Изменить положение узора можно также, перетащив его в окне изображения.

Рис. 14.32. Опции эффекта Pattern Overlay

Рис. 14.33. Результат применения эффекта Pattern Overlay к объекту слоя типа shape

Рис. 14.34. Опции эффекта Stroke

Рис. 14.35. Результат применения эффекта Stroke к объекту слоя фигуры

Выберите значение параметра Scale (Масштаб) для узора.

Поставьте флажок Link with Layer (Связать со слоем), чтобы связать узор со слоем.

Если был загружен узор, определенный пользователем, щелкните по кнопке Create new preset (Создать новый образец), чтобы добавить узор к остальным образцам.

  4. Щелкните по кнопке ОК (рис. 14.33).

Применение эффекта Stroke

  1. На палитре Layers (Слои) щелкните по имени какого-либо слоя.
  2. Щелкните по названию эффекта Stroke (Кайма).
  3. Выполните любое из перечисленных ниже действий (рис. 14.34).

    Выберите значение параметра Size (Размер).

    Из всплывающего меню Position (Положение) выберите, как будет располагаться кайма по отношению к границам фигуры: Outside (Снаружи), Inside (Внутри) или Centered (По центру).

    Выберите значение параметра Blend Mode (Режим смешивания).

    Установите значение параметра Opacity (Непрозрачность).

    Выберите подходящий вариант в выпадающем меню Fill Type (Тип заливки): Color (Цвет), Gradient (Градиент) или Pattern (Узор) и определите характеристики заливки с помощью соответствующих элементов интерфейса (см. выше описание эффектов Overlay).

  4. Щелкните по кнопке ОК (рис. 14.35).

Другие команды, связанные с эффектами

Доступ к командам, о которых говорится далее, можно получить, щелкнув правой кнопкой мыши по значку эффектов слоя на палитре Layers (Слои), либо с помощью меню Layer > Layer Style (Слой > Стиль слоя).

Команда Copy Layer Style (Копировать стиль слоя) копирует все эффекты выделенного слоя так, что их можно вставить в любой другой слой.

Команда Paste Layer Style (Вставить стиль слоя) вставляет эффекты на текущий слой в том же самом или другом документе; команда Paste Layer Style to Linked (Вставить стиль слоя в связанный слой) вставляет эффекты во все слои, связанные в данный момент с выделенным. Но вставленный эффект заменит уже примененный только в том случае, если они принадлежат одной категории (например, вставляемый эффект Drop Shadow (Отбросить тень) заменит существующий эффект Drop Shadow (Отбросить тень)).

Команда Clear Layer Style (Очистить стиль слоя) удаляет все стили из выделенного слоя. Она также восстанавливает значение параметра Blending Options (Опции смешивания), принимаемое по умолчанию.

Команда Global Light (Глобальное освещение) устанавливает значения параметров Angle (Угол) и Altitude (Высота), общие для всех текущих и будущих эффектов, в которых включена опция Use Global Light (Использовать глобальное освещение). И наоборот, если изменить значение параметров Angle (Угол) и Altitude (Высота) для отдельного эффекта при включенной опции Use Global Light (Использовать глобальное освещение), значения данных параметров для других эффектов, использующих эту опцию, также изменятся, так как изменятся их значения в диалоговом окне Global Light (Глобальное освещение). Команда Global Light (Глобальное освещение) обеспечивает одинаковое освещение на нескольких слоях. Если к слою было применено более одного эффекта и выбрана команда Create Layers (Создать слои), то каждый эффект разместится на своем собственном слое. После этого изображение существенно не изменится, но теперь больше нельзя будет редактировать эффекты с помощью диалогового окна Layer Style (Стиль слоя), и эффекты не будут связаны со слоем, к которому изначально были применены. Вы можете получить предупреждение, что эффекты могут не полностью перейти в слои. Но у вас нет выбора, если вы хотите сохранить слои.

Рис. 14.36. Команды для управления эффектами

После применения команды Create Layers (Создать слои) каждый эффект, находящийся внутри какой-либо фигуры (внутреннее свечение, светлые или темные тона при скосе или внутренний рельеф), будет расположен на новом, отдельном слое, но войдет вместе с исходным слоем фигуры в группу отсечения; исходный слой станет базовым слоем группы. Любой эффект, расположенный вне фигуры (отбрасываемая тень, внешнее свечение, тень при скосе или внешний рельеф), будет преобразован в отдельный слой, расположенный под исходным слоем фигуры. Воспользуйтесь командой Create Layers (Создать слои), чтобы экспортировать файл в мультимедийную программу, такую как Adobe After Effects или Adobe LiveMotion. Команду Create Layers (Создать слои) нельзя применить к фону изображения.

Команда Hide All Effects (Спрятать все эффекты) временно скрывает эффекты всех слоев документа. Для того чтобы снова отобразить их, выберите команду Layer > Layer Style & Show All Effects (Слой > Стиль слоя > Показать все эффекты). Команда Scale Effects (Масштаб эффектов) открывает диалоговое окно, которое позволяет уменьшить или увеличить размер всех текущих эффектов выделенного слоя. Затронуты будут только параметры, задаваемые в пикселах (а не в процентах). Эффекты слоя можно сохранить в виде стиля с помощью палитры Styles (Стили) в программах ImageReady и Photoshop. О том, как сохранить эффекты слоя в виде стиля и применить стиль к слою, рассказано в главе 23, разделы «Применение стиля к слою» и «Сохранение эффекта слоя в виде стиля».

Смешивание слоев

Режимы смешивания слоев

Выбираемый для слоя режим смешивания влияет на то, как пикселы этого слоя смешиваются с пикселами слоя, расположенного непосредственно под ним. Некоторые режимы не сильно влияют на изображение (например, Soft Light (Мягкий свет)), другие же значительно изменяют цвета (например, Difference (Различие)). Режим Normal (Нормальный) принимается по умолчанию. Подробно режимы смешивания описаны в главе 2, раздел «Режимы смешивания».

Есть три способа выбрать режим смешивания для слоя:

  • из всплывающего меню режимов, расположенного в верхнем левом углу палитры Layers (Слои) - см. рис. 14.37;
  • воспользовавшись «горячими» клавишами Shift-"шлюс» или Shift+«минус», можно попеременно переключать режимы активного слоя (убедитесь, что в это время не активизирован какой-либо инструмент рисования);
  • дважды щелкнув по слою и щелкнув затем по надписи Blending Options (Опции смешивания) в диалоговом окне Layer Style (Стиль слоя).

Рис. 14.37. Выбор режима смешивания из всплывающего меню на палитре Layers

На панели опций можно выбрать режим Behind (Позади) для инструментов Brush (Кисть), Paint Bucket (Ведро с краской), Pencil (Карандаш), History Brush (Восстанавливающая кисть), Clone Stamp (Клонирующий штамп), Pattern Stamp (Штамп узора) или Gradient (Градиент), но не для слоя. В режиме Behind (Позади) будет казаться, что вы рисуете с обратной стороны текущего слоя. При использовании инструмента Paint Bucket (Ведро с краской) или инструмента, предназначенного для работы с фигурами, если щелкнуть по кнопке Create filled region (Создать область заливки), можно выбрать еще один режим - Clear (Очистить), действующий подобно ластику. Для того чтобы получить доступ к режимам Behind (Позади) и Clear (Очистить), необходимо на палитре Layers (Слои) снять флажки Lock transparent pixels (Зафиксировать прозрачные точки) и Lock image pixels (Зафиксировать точки изображения).

Рис. 14.38. Раздел Blending Options диалогового окна Layer Style (Стиль слоя)

Настройка параметров смешивания двух слоев

Контролировать, какие пикселы текущего слоя останутся видимыми, а какие пикселы нижележащего слоя будут видны сквозь верхний слой, можно при помощи ползунков Blend If (Смешивать если) в разделе Blending Options (Опции смешивания) диалогового окна Layer Style (Стиль слоя).

  1. На палитре Layers (Слои) дважды щелкните по имени какого-либо слоя, затем в верхней левой части диалогового окна Layer Style (Стиль слоя) щелкните по надписи Blending Options (Опции смешивания) или выберите слой, а затем из меню палитры Layers (Слои) выберите элемент Blending Options (Опции смешивания).
  2. По желанию. В разделе General Blending (Общие параметры смешивания) измените текущее значение параметра Blend Mode (Режим смешивания) и значение параметра Opacity (Непрозрачность) -см. рис. 14.38.
  3. Поставьте флажок Preview (Предварительный просмотр).
  4. В разделе Advanced Blending (Дополнительные параметры смешивания) выполните любое из указанных ниже действий.

    Чтобы отрегулировать непрозрачность пикселов слоя (внутреннюю непрозрачность), не изменив при этом вид каких-либо эффектов слоя, выходящих за его границы (например, Bevel, Drop Shadow, Outer Glow), подкорректируйте значение параметра Fill Opacity (Непрозрачность заливки).

    Снимите в поле Channels (Каналы) флажки со всех каналов, которые вы хотите исключить из операции смешивания с нижележащим слоем. Чтобы установить диапазон смешивания для каждого канала, выбирайте их по очереди во всплывающем меню Blend If (Смешивать если); для одновременной работы со всеми каналами оставьте без изменений опцию Gray (Серый). Текущий режим изображения (например, RGB или CMYK) определяет, какие каналы доступны.

    Передвиньте левый ползунок панели This Layer (Этот слой) вправо, чтобы удалить темные области с активного слоя.

    Переместите правый ползунок панели This Layer (Этот слой) влево, чтобы удалить светлые области с активного слоя.

    Передвиньте левый ползунок панели Underlying Layer (Нижележащий слой) вправо, чтобы восстановить темные области слоя, расположенного непосредственно под активным.

    Переместите правый ползунок панели Underlying Layer (Нижележащий слой) влево, чтобы восстановить светлые области слоя, расположенного непосредственно под активным.

  5. Щелкните по кнопке ОК (рис. 14.39 и 14.40).

Для независимой корректировки средних то-ноа перемещайте ползунок при нажатой клавише Alt. Ползунок будет разделен на два.

Дополнительные режимы смешивания

В разделе Advanced Blending (Дополнительные параметры смешивания) диалогового окна Layer Style (Стиль слоя) есть два флажка, управляющих тем, как слои группы отсечения или отдельные слои смешиваются с нижележащими слоями изображения (подробнее о группах отсечений см. раздел «Группы отсечений» этой главы). В примерах, приведенных ниже, используется группа отсечения, показанная на рис. 14.41.

Рис. 14.39. Слой изображения, расположенный поверх слоя с изображением авокадо

Рис. 14.40. То же самое изображение после перемещения белого ползунка панели This Layer и черного ползунка Underlying Layer в диалоговом окне Layer Style

Рис. 14.41. Группа отсечения, используемая для получения изображений на рис. 14.42-14.44

Рис. 14.42. Смешивание при установленном флажке Blend Clipped Layers as Group

Рис. 14.43. Смешивание при снятом флажке Blend Clipped Layers as Group

Смешивание слоев отсечения как группы

Дважды щелкните по базовому слою, параметр которого Knockout (Исключение) имеет значение Shallow (Мелкое) или Deep (Глубокое) (см. в данной главе раздел «Выбор опции Knockout для слоя»). Если стоит (устанавливаемый по умолчанию) флажок Blend Clipped Layers as Group (Смешивать слои отсечения как группу), режим смешивания базового слоя определяет, как все слои группы вместе смешиваются с любыми нижележащими слоями изображения (рис. 14.42).

Если же флажок Blend Clipped Layers as Group (Смешивать слои отсечения как группу) не установлен, отдельные слои группы отсечения будут смешиваться с нижележащими слоями в соответствии с их собственным режимом смешивания, а не с режимом смешивания базового слоя (рис. 14.43).

Смешивание внутренних эффектов как группы

Дважды щелкните по какому-либо слою. Если флажок Blend Interior Effect as Group (Смешивать внутренние эффекты как группу) снят (по умолчанию), внутренние эффекты слоя (например, Inner Glow (Внутреннее свечение), Satin (Атлас), Color Overlay (Наложение цвета), Pattern Overlay (Наложение узора) или Gradient Overlay (Наложение градиента)) будут использоваться для смешивания слоя с нижележащими слоями. Режим смешивания самого слоя (палитра Layers (Слои)) воздействует на вид изображения в меньшей степени.

Если же флажок Blend Interior Effect as Group (Смешивать внутренние эффекты как группу) установлен, внутренние эффекты слоя сначала смешаются в соответствии с режимом смешивания слоя, а затем вся композиция будет смешана с нижележащими слоями. Теперь эффекты слоя будут меньше воздействовать на вид изображения (рис. 14.44). Эффекты Inner Glow (Внутреннее свечение) и Gradient Overlay (Наложение градиента), хорошо заметные на рис. 14.42, видны в меньшей степени на рис. 14.44.

Выбор опции Knockout для слоя

В программе Photoshop можно определять, содержимое скольких слоев, лежащих ниже выбранного, будет проигнорировано (будут исключены нижележащие пикселы) - до самого фона или до заданной точки остановки, расположенной среди слоев.

  1. На палитре Layers (Слои) дважды щелкните по имени какого-либо слоя, затем в левой части диалогового окна Layer Style (Стиль слоя) щелкните по надписи Blending Options (Опции смешивания). Расположение слоев, используемых в данном примере, показано на рис. 14.45.
  2. Убедитесь, что стоит флажок Preview (Предварительный просмотр).
  3. В разделе Advanced Blending (Дополнительные параметры смешивания) выберите из всплывающего меню Knockout (Исключение) одно из перечисленных ниже значений:
    • None (Нет) — исключение пикселов не выполняется (рис. 14.46);

Рис. 14.44. Смешивание при установленном флажке Blend Interior Effect as Group

Рис. 14.45. Расположение слоев, используемых в примере

Рис. 14.46. Результирующее изображение при установке значения None

Рис. 14.47. Результирующее изображение при установке значения Shallow

Рис. 14.48. Результирующее изображение при установке значения Deep

    • Shallow (Мелкое) - исключение пикселов всех слоев до точки остановки (рис. 14.47). По умолчанию эта точка может быть: слоем, расположенным непосредственно под набором слоев, в который входит слой с данной опцией, или, если стоит флажок Blend Clipped Layers as Group (Смешивать слои отсечения как группу), самым нижним слоем группы;
    • Deep (Глубокое) - исключение всех слоев вплоть до фона (рис. 14.48).

В этом примере слой Sand входит в набор слоев. Поэтому опция Shallow (Мелкое) не принимает во внимание слои набора, в то время как опция Deep (Глубокое) убирает все слои вплоть до фона.

  4. Щелкните по кнопке ОК. Советы:
  • если у набора слоев, содержащего слой с опцией Knockout (Исключение), режим смешивания отличен от Pass Through (Пройти сквозь), тогда точкой остановки будет слой, расположенный непосредственно под набором слоев, независимо от того, какое значение выбрано: Shallow (Мелкое) или Deep (Глубокое). Режим смешивания других наборов слоев не влияет на поведение слоя с опцией Knockout и его набора;
  • если слой с опцией Knockout находится в группе отсечения, входящей в набор слоев, тогда при выборе варианта Shallow точкой остановки будет самый нижний слой группы отсечения, а для опции Deep - слой, расположенный под набором слоев;
  • если в изображении не содержится ни групп отсечений, ни наборов слоев, то обе опции Shallow и Deep будут устранять все слои вплоть до фона.

Смешивание модифицированного слоя с исходным

В рассматриваемом ниже примере к дубликату слоя применяется фильтр, а затем исходный слой и дубликат смешиваются при заданных на палитре Layers (Слои) значениях непрозрачности и режиме. Воспользуйтесь этим приемом, чтобы смягчить эффект команды редактирования изображения, например фильтрации, или для экспериментов с различными режимами смешивания и командами корректировки. Также ограничить область применения эффекта можно с помощью маски слоя. Если вам не понравился результат, можете просто удалить дубликат слоя и начать заново.

  1. Выберите какой-либо слой (рис. 14.49).
  2. Создайте дубликат слоя, перетащив исходный слой на кнопку Create new layer (Создать новый слой), расположенную внизу палитры Layers (Слои), или выбрав из меню палитры Layers (Слои) команду Duplicate Layer (Дублировать слой). Щелкните по кнопке ОК.
  3. Измените дубликат слоя (например, примените фильтр или другую команду редактирования).
  4. На палитре Layers (Слои) подкорректируйте, значение параметра Opacity (Непрозрачность), чтобы получить желаемый уровень прозрачности одного слоя относительного другого (рис. 14.50), и/или выберите другой режим смешивания.
  5. По желанию. Создайте маску слоя, чтобы частично спрятать пикселы верхнего слоя. Попробуйте добавить градиент к маске слоя, благодаря чему эффект смешивания будет постепенно исчезать.

Рис. 14.49. Исходное изображение

Рис. 14.50. Результат применения эффекта Mezzotint к дубликату слоя и уменьшения его непрозрачности

Рис. 14.51. Эффект смешивания слоев с использованием фильтра Pointillize

Для создания качественного текстурного эффекта создайте дубликат фона в цветном изображении (желательно, чтобы фон не был чисто белым), выделите новый слой и выберите команду Image >Adjustments > Desaturate (Изображение > Корректировки > Обесцветить) либо нажмите комбинацию клавиш Ctrl+Shift+U, чтобы слой стал полутоновым. Затем примените фильтр Add Noise (Добавить шум) или Pointillize (Пуантилизм) - см. рис. 14.51. I/I наконец, с помощью палитры Layers (Слои) уменьшите непрозрачность или попробуйте другие режимы смешивания для нового слоя.

В диалоговом окне Layej Style (Стиль слоя) можно также указать те каналы дубликата слоя, которые будут смешиваться с нижележащим слоем.

Маски слоя

Маска слоя представляет собой 8-битный полутоновой канал с черным или белым фоном. По умолчанию белые области маски слоя позволяют видеть пикселы, черные - скрывают точки, а серые - частично их маскируют. С помощью маски можно временно скрыть пикселы слоя так, чтобы была видна остальная часть изображения без них. Позднее можно изменить маску, применить эффект маски, чтобы она стала постоянной, или вообще удалить ее.

Преимущество использования маски заключается в том, что получить доступ к ней можно как с палитры Layers (Слои), так и с палитры Channels (Каналы). На обеих палитрах показывается миниатюра маски слоя, когда выделен содержащий ее слой. В отличие от альфа-канала выделенной области, который допускается загрузить в любой слой, маску слоя можно включить/выключить только для слоя или группы отсечения, с которым(ой) она связана.

Создание маски слоя

  1. Выберите слой, к которому хотите прикрепить маску.
  2. По желанию. Выделите некую область, если хотите создать маску определенной формы.
  3. Для создания белой маски, в которой видны все пикселы, выберите команду Layer > Add Layer Mask > Reveal All (Слой > Добавить маску слоя > Показать все) или щелкните по кнопке а Add a mask (Добавить маску) на палитре Layers (Слои) - см. рис. 14.52.

Чтобы создать черную маску, где все пикселы спрятаны, выберите команду Layer > Add Layer Mask > Hide All (Слой > Добавить маску слоя > Скрыть все) или, нажав клавишу Alt, щелкните по кнопке Add a mask (Добавить маску) на палитре Layers (Слои).

Для отображения только пикселов, входящих в выделенную область, выберите команду Layer > Add Layer Mask > Reveal Selection (Слой > Добавить маску слоя > Показать выделение) или щелкните по кнопке Add a mask (Добавить маску), расположенной внизу палитры Layers (Слои).

Чтобы спрятать все пикселы, находящиеся в выделенной области, выберите команду Layer > Add Layer Mask > Hide Selection (Слой > Добавить маску слоя > Скрыть выделение) или, нажав клавишу Alt, щелкните по кнопке Add a mask (Добавить маску) внизу палитры Layers (Слои).

На рис. 14.53 показано изображение с отключенными масками слоев. На рис. 14.54 после включения масок всех слоев самая верхняя труба постепенно исчезает, поскольку маска соответствующего слоя имеет градиентную окраску, а части средней и нижней труб спрятаны посредством черно-белых масок.

Рис. 14.52. Палитра Layers, содержащая три слоя, каждый со своей маской

Рис. 14.53. Маски слоев не использованы

Рис. 14.54. Маски слоев включены

Рис. 14.55. Слой с маской на панели Layers

Рис. 14.56. Исходное изображение

Рис. 14.57. Скрытие с помощью маски слоя центра правого авокадо

Изменение формы маски слоя

  1. Выберите инструмент Brush (Кисть), нажав клавишу В или Shift+B.
  2. На панели опций задайте 100% непрозрачности (либо меньшее значение, если хотите частично скрыть пикселы слоя), в поле Mode (Режим) укажите значение Normal (Нормальный) и выберите тип кисти на всплывающей панели.
  3. Чтобы изменить форму маски в то время, как видны пикселы слоя, на палитре Layers (Слои) щелкните по миниатюре маски (не по имени слоя) - см. рис. 14.55. Она будет обведена темной линией, и напротив этого слоя в левой колонке появится значок маски.

    Для показа самой маски в окне изображения, нажав клавишу Alt, щелкните по ее миниатюре. (Нажмите клавишу Alt и щелкните по миниатюре маски слоя, чтобы снова увидеть маску на изображении). Нажав клавиши Alt+Shift, щелкните по миниатюре маски слоя, чтобы отобразить маску поверх изображения. (Снова нажмите клавиши Alt+Shift и щелкните по миниатюре, чтобы восстановить нормальный режим изображения.)

  4. Рисуйте на картинке черным цветом в качестве основного, чтобы увеличить маску и спрятать пикселы слоя.

    Рисуйте белым цветом в качестве основного, чтобы уменьшить маску и восстановить пикселы слоя.

    Рисуйте, выбрав серый цвет в качестве основного, чтобы частично спрятать точки слоя.

  5. Когда закончите модификацию маски слоя, щелкните по миниатюре слоя (рис. 14.56, 14.57).

Для инвертирования эффекта маски слоя щелкните по ее миниатюре и выберите команду Image > Adjustments > Invert (Изображение > Корректировки > Инвертировать) или нажмите комбинацию клавиш Ctrt+l. Спрятанные области будут отображены, а ранее видимые области - скрыты.

Другие инструменты изменения маски

Попробуйте воспользоваться для модификации маски инструментом Eraser (Ластик). Также можно применить инструменты Burn (Затемнить), Dodge (Осветление), Sponge (Губка), Sharpen (Резкость), Blur (Размытие), Smudge (Палец), Paint Bucket (Ведро с краской) и Gradient (Градиент). Если хотите воспользоваться каким-либо инструментом построения фигур, сначала необходимо вывести в окно изображения саму маску (см. шаг 3 в предыдущем разделе).

Раздельное перемещение маски и слоя

По умолчанию слой и его маска перемещаются вместе. Следуйте нижеприведенным инструкциям, чтобы перемещать пикселы слоя или маску независимо друг от друга.

  1. На палитре Layers (Слои), который расположен между миниатюрами слоя и маски слоя (рис. 14.58). Значок связи исчезнет.
  2. Щелкните по миниатюре маски слоя.
  3. Активизируйте инструмент Move (Перемещение), нажав клавишу V.
  4. Перетащите маску слоя в окне изображения.
  5. Снова щелкните между миниатюрами слоя и маски, чтобы опять связать их.

Рис. 14.58. Слой с маской на палитре Layers

Рис. 14.59. Опции отображения маски слоя

Создание дубликата маски слоя

  1. Выберите слой, на котором вы хотите, чтобы появился дубликат маски.
  2. Из другого слоя перетащите миниатюру маски слоя, которую вы хотите скопировать, на кнопку Add a mask (Добавить маску), расположенную внизу палитры Layers (Слои).

Если вы хотите, чтобы видимые и спрятанные области поменялись местами в дубликате маски, нажмите клавишу Alt и перетащите миниатюру маски на кнопку Add a mask (Добавить маску).

Выбор опций отображения маски слоя

Если маска слоя выведена поверх изображения (см. шаг 3 в разделе «Изменение формы маски слоя»), можно отрегулировать цвет и непрозрачность в окне Layer Mask Display Options (Опции отображения маски слоя).

  1. Дважды щелкните по миниатюре маски слоя.
  2. Измените в разделе Overlay (Наложение) цвет и/или значение непрозрачности (рис. 14.59), затем щелкните по кнопке ОК.

Заливка текста изображением с помощью маски слоя

  1. Активизируйте слой, содержащий непрозрачные пикселы (не фон).
  2. Активизируйте инструмент Horizontal Type Mask (Горизонтальная маска текста) нажав клавишу Т.
  3. Выберите шрифт и другие характеристики текста, затем щелкните мышью по изображению. Временно будет включен режим Quick Mask (Быстрая маска) для изображения. Введите текст, который вы хотите увидеть. Для преобразования текста в выделенную область на панели опций нажмите клавишу Enter либо активизируйте любой другой инструмент.
  4. С помощью инструмента группы Marquee измените положение выделенного текста. (Внимание! Если для перемещения выделенной области использовать инструмент Move (Перемещение), будут удалены пикселы изображения из выделенной области текущего слоя.)
  5. Выберите команду Layer > Add Layer Mask > Reveal Selection (Слой > Добавить маску слоя > Показать выделение), чтобы ограничить видимые пикселы слоя выделенной областью, или выберите команду Layer > Add Layer Mask > Hide Selection (Слой > Добавить маску слоя > Спрятать выделение), чтобы спрятать пикселы слоя в пределах выделенной области.
  6. Теперь текст будет отображаться в виде белых или черных пикселов на миниатюре маски слоя (рис. 14.60, 14.61).

Чтобы изменить положение текста в маске слоя, сначала удалите связь маски со слоем (щелкните по пиктограмме связи, чтобы она исчезла), затем с помощью инструмента Move (Перемещение), который активизируется нажатием клавиши V, перетащите маску в окне изображения.

О том, как залить текст изображением с помощью контура отсечения (вместо маски слоя), рассказано в главе 16, раздел «Создание контура отсечения из текста».

Рис. 14.60. Слой с текстовой маской

Рис. 14.61. Изображение, проглядывающее сквозь буквы маски слоя

Рис. 14.62. Временное удаление маски слоя

Рис. 14.63. Слой с маской на палитре Layers

Рис. 14.64. Кнопки Apply и Discard

Временное удаление эффектов маски слоя

Нажав клавишу Shift, щелкните по миниатюре маски слоя на палитре Layers (Слои) (миниатюра маски выделена не будет). Поверх нее появится красный крест, и весь слой станет виден целиком (рис. 14.62). Снова нажмите клавишу Shift и щелкните по миниатюре маски, чтобы удалить крест и восстановить эффект маски.

Применение и удаление эффектов маски слоя

Маску слоя, которая больше не нужна, следует удалить, так как она занимает дисковое пространство.

  1. На палитре Layers (Слои) щелкните по миниатюре маски слоя, которую вы хотите применить или удалить (рис. 14.63).
  2. Щелкните по кнопке Delete Layer (Удалить слой) в виде корзины. Для того чтобы сделать эффект маски постоянным, щелкните по кнопке Apply (Применить), показанной на рис. 14.64, а чтобы просто удалить маску, щелкните по кнопке Discard (Удалить).

Для выполнения этих действий можно также воспользоваться командой Layer > Remove Layer Mask > Discard (Слой > Удалить маску слоя > Удалить) или Apply (Применить).

Пикселы слоя также можно замаскировать с помощью контура отсечения, созданного с использованием инструмента Реп (Перо) или какого-либо инструмента построения фигур (см. главу 16, раздел «Создание контура отсечения»).

Группы отсечений

Самый нижний слой группы отсечения (базовый слой) ограничивает отображение пикселов и по умолчанию управляет режимом смешивания и непрозрачностью слоев, расположенных над ним.

Создание группы отсечения

  1. Щелкните по имени какого-либо слоя.
  2. Нажав клавишу Alt, щелкните по линии, разделяющей имя этого слоя и имя слоя, расположенного непосредственно над ним (курсор примет вид двух перекрывающих друг друга кружочков) - см, рис. 14.65, 14.66. (Слои, отобранные для группы отсечения, должны быть последовательно расположены на палитре. Слои могут быть сгруппированы с набором слоев, но не со слоями, расположенными за его пределами).
  3. По желанию. Повторите предыдущий шаг, чтобы добавить большее количество слоев в группу отсечения.

Имя базового слоя будет подчеркнуто, а миниатюры других слоев в группе отсечения расположатся с некоторым отступом.

Для создания группы отсечения из связанных слоев просто выберите команду Layer > Group Linked (Слой > Сгруппировать связанные) либо нажмите комбинацию клавиш Ctrl+G.

О том, как залить текст изображением с помощью группы отсечения, рассказано в главе 17, раздел «Заполнение текста изображением с помощью группы отсечения».

Рис. 14.65. Создание группы отсечения

Рис. 14.66. Карта Индии, ограничивающая (отсекающая) изображение с куклами

Для того чтобы узнать, как слои группы отсечения смешиваются с нижележащими слоями, прочтите раздел «Смешивание слоев отсечения как группы» этой главы.

Рис. 14.67. Удаление слоя из группы отсечения

Рис. 14.68. Результат выполнения команды Ungroup над группой отсечения

Удаление слоя из группы отсечения

При удалении (разгруппировании) слоя из группы отсечения все сгруппированные слои, расположенные сверху этого слоя, также будут разгруппированы.

Нажав клавишу Alt, щелкните по линии под слоем, который вы хотите удалить из группы отсечения (рис. 14.67). Теперь слой больше не будет иметь отступа.

Можно также щелкнуть по имени слоя, который вы хотите удалить из группы отсечения, затем выбрать команду Layer > Ungroup (Слой > Разгруппировать) либо нажать комбинацию клавиш Ctrl+Shift+G.

Чтобы разгруппировать всю группу отсечений, выполните действия, указанные ниже.

  1. Щелкните по базовому слою группы.
  2. Выберите команду Layer > Ungroup (Слой > Разгруппировать) либо на-жмте комбинацию клавиш Ctrl+Shift+G -см. рис. 14.68.

Связывание слоев

Связывание используется тогда, когда необходимо зафиксировать относительное расположение нескольких слоев. Как только слои связаны, их можно перемещать как единое целое в окне изображения или перетаскивать/копировать в другое изображение, также их можно распределять яи выравнивать.

Связанные слои можно трансформировать. На самом деле искажение изображения в таких случаях бывает минимальным, так как повторная выборка будет проводиться всего один раз, а не для каждого слоя.

Связывание слоев и их перемещение как единого целого

  1. На палитре Layers (Слои) щелкните по одному из слоев, которые вы хотите связать.
  2. Щелкните по квадратику во второй колонке рядом со слоем, который вы хотите связать со слоем, выбранным на шаге 1. Связываемые слои не обязательно должны быть расположены последовательно. Значок связи появляется рядом с каждым неактивным связанным слоем (рис. 14.69).
  3. По желанию. Выберите инструмент Move (Перемещение), нажав клавишу V, затем нажмите кнопку мыши и перетащите связанные слои в окне изображения.

Для снятия связи со слоя щелкните по значку связи.

Выравнивание двух или более связанных слоев

Команда Align Layers (Выровнять слои) используется для выравнивания границ связанных слоев.

  1. Выберите слой, с которым связаны два или бодее слоев, например button 2 (рис. 14.70). Выбранный слой станет опорным, относительно него будут выровнены остальные связанные слои.
  2. Выберите команду Layer > Align Linked > Top Edges (Слой > Выровнять связанные > Верхние границы), Vertical Center (Положение центра по вертикали), Bottom Edges (Нижние границы), Horizontal Center (Положение центра по горизонтали), Left (Левый край) или Right (Правый край) - см. рис. 14.71-14.73.

Рис. 14.69. Связывание слоев

Рис. 14.70. Выравнивание слоев

Рис. 14.71. Команды выравнивания

Можно также на панели опций щелкнуть по соответствующей кнопке выравнивания.

Выравнивание границы слоя по выделенной области

  1. Создайте выделенную область.
  2. Выберите слой, который будет выровнен по этой области.
  3. Выберите команду выравнивания из подменю Layer > Align to Selection (Слой > Выровнять по выделенной области).

Можно также на панели опций щелкнуть по кнопке выравнивания.

Любые слои, связанные с выбранным слоем, также будут выровнены.

Распределение трех и более связанных слоев

Можно распределить заданным образом изображения в связанных слоях с помощью команды Distribute Linked (Распределить связанные).

  1. Выберите слой, с которым связаны два или более слоя.
  2. По желанию. Выделите некоторую область этого слоя, по которой будут выровнены другие слои.
  3. Выберите команду Layer > Distribute Linked > Top Edges (Слой > Распределить связанные > Верхние границы), Vertical Center (Положение центра по вертикали), Bottom Edges (Нижние границы), Horizontal Center (Положение центра по горизонтали), Left (Левый край) или Right (Правый край).

Можно также на панели опций щелкнуть по соответствующей кнопке выравнивания.

Изображения слоев будут равномерно распределены между двумя слоями, расположенными дальше всего друг от друга (рис. 14.72, 14.74).

Если вы недовольны результатом выравнивания или распределения и хотите попробовать другую опцию, отмените последнее действие прежде, чем воспользоваться другим способом выравнивания.

Рис. 14.72. Исходное изображение

Рис. 14.73. Выровненные по нижней границе слои

Рис. 14.74. Результат распределения слоев в режиме Horizontal Center


  • Глава 15. Маски
    • Сохранение выделенной области в канале
      • Отображение канала выделения
    • Загрузка канала выделения на изображение
      • Значения параметра Operation при сохранении выделения
      • Значения параметра Operation при загрузке выделения
      • Выбор опций канала
      • Удаление канала
      • Копирование канала
      • Изменение формы маски в альфа-канале
    • Изменение формы выделенной области с помощью режима Quick Mask
      • Создание быстрой маски без использования выделенной области
      • Выбор параметров быстрой маски

Глава №15.

Маски

Рис. 15.1. Чистая активная (выделенная) область и полупрозрачная область Quick Mask

В этой главе рассказывается о двух специальных методах сохранения и изменения формы выделенной области: альфа-каналах и режиме Quick Mask (Быстрая маска) - см. рис. 15.1.

Если сохранить выделенную область в специально созданном полутоновом канале, называемом альфа-каналом, ее в любой момент можно будет загрузить на изображение. Особенно удобно это для выделенной области неправильной формы, которую очень сложно воспроизвести. В файле может содержаться до 24 каналов, но поскольку каждый канал увеличивает размер файла (в зависимости от размера выделенной области), при их добавлении следует вести себя благоразумно.

Доступ к альфа-каналам можно получить с помощью палитры Channels (Каналы), показанной на рис. 15.2, а сохранить или загрузить их можно, воспользовавшись командами из меню Select (Выделить) или палитры Channels (Каналы). О том, как создать отсекающий контур слоя вместо альфа-канала, чтобы сохранить дисковое пространство, рассказано в главе 16, раздел «Создание контура отсечения слоя».

С помощью режима Quick Mask (Быстрая маска) в программе Photoshop выделенные и невыделенные области изображения могут быть покрыты полупрозрачной цветной маской, форму которой впоследствии можно изменить с помощью какого-либо инструмента рисования или редактирования. Замаскированные области защищены от изменений. В отличие от альфа-канала сохранить быструю маску нельзя, но при возврате к режиму Standard (Стандартный) маска будет преобразована в выделенную область, которую можно сохранить.

Если вы не знакомы с основными инструментами выделения программы Photoshop, то прежде чем прочитать эту главу, обратитесь к главе 5.

О масках слоя рассказывается в главе 14.

Сохранение выделенной области в канале

Выделенная область, сохраненная в альфа-канале, может быть загружена на изображение в любой момент, когда это понадобится.

О том, как преобразовать альфа-канал в канал заказного (плашечного) цвета, рассказано в главе 11, раздел «Преобразование альфа-канала в канал заказного цвета»;.

Рис. 15.2. Палитра Channels

Рис. 15.3. Выделение области слоя

Рис. 15.4. Кнопка Save selection as channel на палитре Channels

Рис. 15.5. Выбор опций в диалоговом окне Save Selection

Чтобы сохранить выделенную область с использованием текущих опций, выполните следующие действия.

  1. Выделите какую-либо область (рис. 15.3).
  2. Внизу палитры Channels (Каналы) щелкните по кнопке Save selection as channel (Сохранить выделенную область как канал) - см. рис. 15.4.

Чтобы сохранить выделенную область и выбрать при этом желаемые значения параметров, выполните следующие действия.

  1. Выделите какую-либо область (рис. 15.3). По желанию. Также выберите слой, если хотите создать маску для него.
  2. Выполните команду Select > Save Selection (Выделить > Сохранить выделение).
  3. Выполните любое из действий, перечисленных ниже.

    Оставьте текущий файл в качестве значения параметра Document (Документ) без изменений или выберите вариант New (Новый) в поле Document (Документ), чтобы сохранить выделенную область как альфа-канал в новом, отдельном документе (рис. 15.5).

    Выберите в поле Channel (Канал) вариант <...> Mask (<...> Маска), чтобы преобразовать выделенную область в маску для текущего слоя. Пикселы слоя будут видны только там, где располагалась выделенная область.

    Введите какое-либо имя для выделенной области в поле Name (Имя).

    Выберите положение переключателя Operation (Операция), тем самым определив способ комбинирования текущей выделенной области с существующим альфа-каналом, выбранным во всплывающем меню Channel (Канал). Значения переключателя Operation (Операция) рассмотрены далее.

Можно сохранить альфа-канал вместе с изображением в формате Photoshop, TIFF, Photoshop PDF, PICT, Pixar или Targa. Для того чтобы сохранить копию файла без альфа-каналов, в диалоговом окне Save As (Сохранить как) снимите флажок Alpha Channels (Альфа-каналы), если такая опция доступна.

  4. Щелкните по кнопке ОК. Область останется выделенной.

Загрузка канала выделения в другое изображение

Убедитесь, что у целевого и исходного изображений одно и то же разрешение и размеры, активизируйте целевое изображение, затем выполните шаги 2-6 из раздела «Загрузка канала выделения на изображение» этой главы, выбрав в диалоговом окне Load Selection (Загрузить выделение) исходный документ. Для загрузки выделения из маски слоя сначала активизируйте слой исходного изображения.

Отображение канала выделения

Альфа-канал можно отобразить, не загружая его на изображение в качестве выделенной области.

  1. На палитре Channels (Каналы) щелкните по имени альфа-канала (рис. 15.6). Выделенная область будет белой, защищенная - черной (рис. 15.7).
  2. Для восстановления нормального режима изображения щелкните по верхнему (смешанному) каналу на палитре (комбинация клавиш Ctrl+~).

Если для выделенной области задан радиус растушевывания, область постепенного исчезновения окажется серой и будет лишь частично редактируема.

Измените форму маски с помощью любого инструмента рисования, используя черный, белый или серый цвет.

Рис. 15.6. Активизация альфа-канала

Рис. 15.7. Альфа-канал в окне изображения

Рис. 15.8. Выбор альфа-канала во всплывающем меню

Загрузка канала выделения на изображение

Если при загрузке канала выделения не требуется изменить какие-либо характеристики, на палитре Channels (Каналы), нажав клавишу Ctrl, просто щелкните по имени альфа-канала, который вы хотите загрузить. Если же необходимо выбрать определенные значения параметров, выполните действия, перечисленные ниже.

  1. Если смешанное изображение не отображено, щелкните по имени верхнего канала на палитре Channels (Каналы). Можно скомбинировать канал выделения с существующей выделенной областью изображения (см. далее).
  2. Выберите команду Select > Load Selection (Выделить > Загрузить выделение).
  3. Далее из всплывающего меню Channel (Канал) выберите имя альфа-канала (рис. 15.8).
  4. Для того чтобы скомбинировать канал с существующей выделенной областью изображения, выберите положение переключателя Operation (Операция), как написано далее.
  5. По желанию. Поставьте флажок Invert (Инвертировать), чтобы поменять местами выделенные и невыделенные области.
  6. Щелкните по кнопке ОК.

Для выделения только непрозрачных точек активного слоя в диалоговом окне Load Selection (Загрузить выделение) выберите в поле Channel (Канал) вариант < > Transparency (< > Прозрачность) или, нажав клавишу Ctrl, щелкните по имени слоя на палитре Layers (Слои).

Значения параметра Operation при сохранении выделения

При сохранении выделенной области в диалоговом окне Save Selection (Сохранить выделение) можно выбрать следующие значения параметра Operation (Операция):

  • New Channel (Новый канал), чтобы сохранить текущую выделенную область в новом канале. Это можно сделать, щелкнув на палитре Channels (Каналы) по кнопке Save selection as channel (Сохранить выделенную область как канал);
  • Subtract from Channel (Вычесть из канала), чтобы удалить белые или серые области, перекрывающие новую выделенную область (рис. 15.9);
  • Add to Channel (Добавить в канал), чтобы добавить новую выделенную область в канал (рис. 15.10);
  • Intersect with Channel (Пересечь с каналом), чтобы сохранить только белые или серые области, которые пересекаются с новой выделенной областью.

Значения параметра Operation при загрузке выделения

Если какой-либо канал- загружается в то время, как выделена какая-то область слоя, в диалоговом окне Load Selection (Загрузить выделение) можно выбрать следующие опции с помощью переключателя Operation (Операция):

  • New Selection (Новое выделение) - канал превращается в текущую выделенную область. Быстрый способ: нажав клавишу Ctrl, щелкните по имени канала или перетащите имя канала на кнопку Load channel as selection (Загрузить канал как выделенную область);

Рис. 15.9. Результат применения опции Subtract from Channel (справа) к каналу и выделенной области (слева)

Рис. 15.10. Результат применения опции Add to Channel (справа) к каналу и выделенной области (слева)

Рис. 15.11. Результат применения опции Intersect with Channel (справа) к каналу и выделенной области (слева)

Рис. 15.12. Результат применения опции Subtract from Selection (справа) к загружаемому каналу и выделенной области (слева)

Рис. 15.13. Результат применения опции Add to Selection (справа) к загружаемому каналу и выделенной области (слева)

Рис. 15.14. Результат применения опции Intersect with Selection (справа) к загружаемому каналу и выделенной области (слева)

Рис. 15.15. Ввод имени канала

Рис. 15.16. Выделенная область, окрашенная белым (слева) и черным (справа) цветом

  • Subtract from Selection (Вычесть из выделения) - удаляет те фрагменты текущей выделенной области, которые перекрывают область канала (рис. 15.12). «Горячие» клавиши: нажмите Ctrl+Alt и щелкните по имени канала;
  • Add to Selection (Добавить в выделение) - добавляет область канала к текущей выделенной области (рис. 15.13). «Горячие» клавиши: нажмите Ctrl+Shift и щелкните по имени канала;
  • Intersect with Selection (Пересечь с выделением) - сохраняет только те фрагменты текущей выделенной области, которые пересекаются с областью канала (рис. 15.14). «Горячие» клавиши: нажмите Ctrl+Alt+Shift и щелкните по имени канала.

Выбор опций канала

  1. Дважды щелкните по имени канала на палитре Channels (Каналы) или щелкните по имени канала и выберите пункт Channel Options (Опции канала) в меню палитры.
  2. В поле Name (Имя) введите какое-либо имя (рис. 15.15).

    Обычно выделенные области альфа-канала - белые, а защищенные - черные или другого цвета. Чтобы поменять местами цвета, не изменяя при этом область, которая действительно выделена, поставьте переключатель Color Indicates (Цвет обозначает) в положение Selected Areas (Выделенные области) - см. рис. 15.16.

  3. Щелкните по кнопке ОК.

Для того чтобы изменить размер миниатюры канала, из меню палитры Channels (Каналы) выберите пункт Palette Options (Опции палитры), а затем отметьте другой размер миниатюры.

Удаление канала

Перетащите канал на кнопку Delete current channel (Удалить текущий канал), пиктограмма которой имеет вид корзины, или на палитре Channels (Каналы) щелкните по имени канала, который хотите удалить, затем по кнопке Delete current channel (Удалить текущий канал), расположенной внизу палитры (рис. 15.17), и выберите ответ Yes (Да). Либо нажмите клавишу Alt и щелкните по кнопке корзины, чтобы пропустить появление окна с предупреждением.

Можно также щелкнуть правой кнопкой мыши по имени канала и из контекстного меню выбрать команду Delete Channel (Удалить канал).

Копирование канала

Перетащите имя канала, дубликат которого вы хотите создать, на кнопку Create new channel (Создать новый канал) или в окно другого изображения (рис. 15.17).

Можно также щелкнуть правой кнопкой мыши по имени канала и выбрать команду Duplicate Channel (Дублировать канал) из контекстного меню, изменить имя в случае необходимости и щелкнуть по кнопке ОК (рис. 15.18).

Изменение формы маски в альфа-канале

Можно наложить выделенную область альфа-канала на изображение в качестве цветной маски, а затем изменить форму маски.

Рис. 15.17. Кнопки палитры Channel

Рис. 15.18. Дублирование канала с помощью контекстного меню

Рис. 15.19. Активизация альфа-канала

Рис. 15.20. Переключение верхнего канала в режим видимости

Рис. 15.21. Увеличение замаскированной области

  1. Убедитесь, что на изображении не выделена какая-либо область.
  2. На палитре Channels (Каналы) щелкните по имени альфа-канала. Рядом появится значок в виде глаза (рис. 15.19).
  3. Щелкните мышью по верхнему квадратику в левой колонке палитры. Появится значок в виде глаза. Альфа-канал должен быть единственным выделенным каналом (рис. 15.20).
  4. Активизируйте инструмент Pencil (Карандаш) или Brush (Кисть). «Горячие» клавиши для этих инструментов: В или Shift+B.
  5. На панели опций щелкните по стрелке в поле Brush (Кисть) и выберите кисть на всплывающей панели.

    В поле Mode (Режим) укажите значение Normal (Нормальный) и установите значение непрозрачности равное 100% для создания полной маски или уменьшите это значение, чтобы создать частичную маску.

  6. Для увеличения замаскированной (защищенной) области наносите штрихи на вырезанную область, выбрав черный цвет в качестве основного (рис. 15.21). На панели инструментов можно щелкнуть по кнопке Switch Colors (Переключить цвета) или нажать клавишу X, чтобы поменять местами основной и фоновый цвета (рис. 15.22).

    Для увеличения незамаскированной области наносите мазки белым цветом (рис. 15.23).

  7. Для того чтобы спрятать маску, щелкните по значку в виде глаза в строке альфа-канала или выберите какой-либо слой на палитре Layers (Слои).

Изменение формы выделенной области с помощью режима Quick Mask

Если выбрать режим Quick Mask (Быстрая маска), выделив некоторую область слоя, полупрозрачная тонированная маска накроет невыделенные области, а выделенная область будет видна. Изображение, накрытое маской, все еще будет видно сквозь нее. Изменить форму маски можно с помощью инструментов Pencil (Карандаш) или Brush (Кисть).

  1. Выделите какую-либо область слоя (рис. 15.24).
  2. На палитре инструментов щелкните по кнопке режима Quick Mask (Быстрая маска), показанной на рис. 15.25, или нажмите клавишу Q. Маска закроет часть картинки (рис. 15.26).
  3. Активизируйте инструмент Pencil (Карандаш) или Brush (Кисть).
  4. На панели опций инструмента щелкните по стрелке в поле Brush (Кисть) и выберите кисть на всплывающей панели.

    В поле Mode (Режим) выберите вариант Normal (Нормальный).

    Переместите ползунок Opacity (Непрозрачность) на отметку 100% и убедитесь, что не стоит флажок Auto Erase (Автоластик) или Wet Edges (Мокрые края).

  5. Рисуйте по вырезанной области основным черным цветом, чтобы увеличить замаскированную (защищенную) область, или рисуйте на маске белым цветом, чтобы увеличить вырезанную (незамаскированную) область. На панели инструментов можно щелкнуть по кнопке Switch Colors (Переключить цвета), чтобы поменять местами основной и фоновый цвета (рис. 15.22).

Рис. 15.22. Часть панели инструментов с кнопками управления цветом

Рис. 15.23. Увеличение незамаскированной области

Рис. 15.24. Выделение области слоя

Рис. 15.25. Кнопки переключения режимов на панели инструментов

Рис. 15.26. Невыделенная область, закрытая маской

Рис. 15.27. Кнопки переключения режимов на панели инструментов

Можно также рисовать серым цветом либо с непрозрачностью ниже 100% (устанавливается на панели опций), чтобы создать неполную маску. При редактировании слоя эта область будет затрагиваться лишь частично.

  6. Элемент Quick Mask появится на палитре Channels (Каналы) и такая же надпись будет присутствовать в строке заголовка изображения, пока оно находится в этом режиме. На панели инструментов щелкните по кнопке Standard mode (Стандартный режим) или нажмите клавишу Q, когда захотите выключить режим Quick Mask (Быстрая маска) - см. рис. 15.27. Незамаскированные области преобразуются в выделенную область.
  7. Измените слои. Затронуты буду! юл» кр незамаскированные (выделенные) области.

Создание быстрой маски без использования выделенной области

Следуя перечисленным ниже инструкциям, вы создадите маску без выделения области.

  1. Активизируйте инструмент Pencil (Карандаш) или Brush (Кисть) и выберите опции инструмента, как описано в предыдущем разделе.
  2. Дважды щелкните по кнопке Quick Mask (Быстрая маска) на панели инструментов.
  3. Поставьте переключатель Color Indicates (Цвет означает) в положение Selected Areas (Выделенные области) и щелкните по кнопке ОК.
  4. Нанесите черные штрихи на слой (см. рис. 15.28). Выделенные области будут покрыты маской, а вы будете создавать то, что станет выделенной областью. Нажмите клавишу Q, чтобы вернуться к стандартному режиму.

Выбор параметров быстрой маски

Опции быстрой маски влияют только на то, как эта маска выглядит на экране, а не на то, как она работает.

  1. Дважды щелкните по надписи Quick Mask на палитре Channels (Каналы) или дважды щелкните по кнопке Quick Mask (Быстрая маска) на панели инструментов.
  2. Выполните любое из действий, перечисленных ниже (рис. 15.29).

    Поставьте переключатель Color Indicates (Цвет означает) в положение Selected Areas или Masked Areas (Замаскированные области).

    Щелкните по образцу цвета и выберите новый цвет быстрой маски.

    Измените значение, параметра Opacity (Непрозрачность) для цвета.

  3. Щелкните по кнопке ОК.

Быстрое переключение

Для переключения цвета маски выделенных и замаскированных областей без использования диалогового окна Quick Mask Options (Опции быстрой маски) нажмите клавишу Alt и щелкните по кнопке Quick Mask (Быстрая маска) на панели инструментов.

Рис. 15.28. Рисование маски на изображении в режиме Quick Mask

Рис. 15.29. Окно Сhannel Options


  • Глава 16. Контуры и фигуры
    • Контуры
      • Преобразование выделенной области в контур
      • Построение контура с помощью инструмента Реп
      • Построение контура объекта с помощью инструмента Freeform Pen
      • Окно Magnetic Options
      • Создание произвольного контура с помощью инструмента Freeform Pen
    • Операции над контурами
      • Дорисовка существующего незамкнутого контура
      • Трансформация контура или контура отсечения целиком
      • Изменение расположения точек контура
      • Копирование контура в том же окне изображения
      • Перетаскивание контура в окно с другим изображением
      • Сохранение рабочего контура
      • Отображение и скрытие контура
      • Выделение узловых точек контура
      • Изменение формы контура
      • Удаление контура
      • Преобразование контура в границу выделения
      • «Горячие» клавиши для преобразования контура в выделенную область
      • Обводка контура
      • Заливка контура
      • Экспорт контура в программы Illustrator или Freehand
    • Контуры отсечения слоев
      • Создание контура отсечения слоя
      • Операции над контурами отсечения
      • Временное отключение эффектов контура отсечения слоев
      • Создание контура отсечения из текста
    • Фигуры
      • Создание слоя фигуры
      • Создание рабочего контура
      • Создание растровой геометрической фигуры
      • Выбор параметров для инструментов построения фигур
      • Перемещение контура отсечения в слое типа shape
      • Трансформация слоя типа shape
      • Изменение контура в слое типа shape
      • Временное скрытие контура отсечения в слое типа shape
      • Вставка векторного объекта из программы Illustrator в Photoshop в виде слоя типа shape
      • Использование режимов взаимодействия контуров друг с другом
      • Добавление нового элемента на панель выбора произвольных фигур
      • Изменение заливки фигуры
      • Преобразование слоя типа shape в растровый формат

Глава №16.

Контуры и фигуры

Рис. 16.1 Инструменты группы Реп

Рис. 16.2 Инструменты построения фигур

Рис. 16.3. Контур

Контуры

С помощью инструментов группы Реп (Перо), показанных на рис. 16.1, и инструментов построения фигур (рис. 16.2) можно создать векторные объекты, называемые контурами (path).

Контуры состоят из узловых точек (anchor point), которые соединены между собой сегментами кривых или прямых линий (рис. 16.3). Чтобы изменить форму контура или фигуры, надо переместить, добавить или удалить узловую точку или передвинуть сегмент. Форму криволинейных участков контура также можно скорректировать, меняя направление касательных.

Кроме того, инструменты группы Реп используются для создания слоев типа shape (фигура), видимые области которых контролируют контуры отсечения (clipping path). Слои данного типа содержат области заливки, которые можно редактировать, и контур отсечения, определяющий границу фигуры. Контуры отсечения слоев - это векторные маски, практически идентичные маскам слоев, но имеющие одно преимущество: они задают точные границы, занимающие гораздо меньше оперативной памяти, чем каналы.

Контуры, созданные с помощью инструментов Реп (Перо) или Freeform Pen (Свободное перо), отображают, открывают, закрывают, переставляют в стеке, сохраняют и удаляют с использованием палитры Paths (Контуры) - см. рис. 16.4. После активизации инструмента Реп (и до начала создания рабочего контура).

Чтобы создать слой фигуры (типа shape), щелкните по левой кнопке, если же хотите получить рабочий контур (work path) -по правой.

Преобразование выделенной области в контур

Прежде чем подробно рассмотреть инструменты группы Реп, покажем, как создать контур с помощью операции выделения области. Превратив границы области в контур, можно с большой точностью изменять ее форму, а затем использовать полученную замкнутую линию в качестве контура отсечения слоя. При необходимости контур можно обратно преобразовать в выделенную область.

Преобразование области в контур можно выполнить двумя способами.

Первый способ:

  1. Выберите часть изображения (рис. 16.5).

Как только-вы преобразуете выделенную область в контур, программа будет выполнять действия только с контуром.

  2. Нажмите клавишу Alt и, не отпуская ее, щелкните по кнопке Make work path from selection (Создать рабочий контур из выделенной области) в нижней части палитры Paths (рис. 16.6) или выберите команду Make work path в меню палитры Paths.
  3. Введите значение параметра Tolerance (Допуск) от 0,5 до 10 (рис. 16.7).

Рис. 16.4. Палитра Paths

Рис. 16.5. Исходная выделенная область

Рис. 16.6. Кнопка создания рабочего контура

Рис. 16.7. Ввод значения параметра Tolerance

Рис. 16.8. Вид рабочего контура при значении параметра Tolerance равном 2

Рис. 16.9. Вид рабочего контура при значении параметра Tolerance равном 6

При невысоком значении параметра Tolerance программа создаст много узловых точек, и контур будет точно соответствовать выделенной области (рис. 16.8). При большом же значении данного параметра получится меньше узловых точек, и контур окажется более сглаженным, но будет менее точно соответствовать исходной выделенной области (рис. 16.9). Попробуйте ввести значение указанного параметра равным 4 или 5.

  4. Щелкните по кнопке ОК.

Имя нового рабочего контура появится на палитре Paths. Это имя, предложенное программой, надо обязательно изменить! Дважды щелкните по нему, а затем в появившемся окне Save Path (Сохранить контур) введите новое имя контура и щелкните по кнопке ОК.

Для наименования контуров нельзя использовать кириллицу.

Во втором способе преобразования границы выбранной области в контур используется текущее значение параметра Tolerance. Щелкните по кнопке Make work path from selection в нижней части палитры Paths. Сохраните контур: дважды щелкните по его имени, введите новое имя, затем нажмите кнопку ОК.

Построение контура с помощью инструмента Реn

  1. Выберите инструмент Pen Tool (клавиша Р или Shift+P).
  2. Убедитесь, что на палитре Paths не активизирован ни один контур, и затем щелкните по кнопке Paths (Контуры) на панели опций.
  3. Установите флажок Rubber Band (Резиновая нить) во всплывающем окне Реп Options (Опции пера) на панели опций, чтобы видеть форму создаваемого сегмента.
  4. Щелкните по какой-либо точке окна с и-зображением, передвиньте мышь и щелкните еще раз в другом месте, чтобы получить прямолинейный сегмент (рис. 16.10). Чтобы нарисовать следующий отрезок под углом кратным 45° к предыдущему, щелкайте кнопкой мыши при нажатой клавише Shift.

    Если надо построить криволинейный сегмент, перемещайте мышь с нажатой левой кнопкой. Появятся направляющие линии (рис. 16.11, 16.12). Чем меньше узловых точек, тем изящнее выглядит кривая.

    Для создания излома в последней узловой точке нажмите клавишу Alt, переместите мышь в нужном направлении (оба манипулятора направляющей линии будут расположены по одну сторону кривой), после чего отпустите клавишу и кнопку мыши. Затем продолжите построение очередного сегмента кривой, как описано выше (рис. 16.13).

    Чтобы удалить последнюю из созданных узловых точек, нажмите клавишу Delete, а для удаления всего контура нажмите эту же клавишу дважды.

Рис. 16.10. Построение отрезка прямой

Рис. 16.11. Построение криволинейного сегмента

Рис. 16.12. Зависимость между направлением перемещения мыши и формой кривой

Рис. 16.13. Построение кривых с изломами

  5. Для построения желаемой фигуры повторите действия, описанные в шаге 4, необходимое число раз.
  6. Чтобы закончить работу с контуром, но оставить его незамкнутым, нажмите клавишу Ctrl и щелкните мышью вне контура или по пиктограмме какого-либо инструмента. Если перед построением очередного контура вы не перевели предыдущий контур в неактивное состояние, то все дополнительные контуры, которые вы создадите, будут сохранены под тем же самым именем.

    Чтобы замкнуть контур, щелкните по первой узловой точке (при этом рядом с курсором появится маленький кружочек).

  7. Сохранить новый рабочий контур можно следующим образом: дважды щелкните по его имени, введите новое имя и щелкните по кнопке ОК. Как изменять форму контура, рассказано в данной главе ниже.

Чтобы добавить с помощью инструмента Реn новый контур к сохраненной ранее фигуре, активизируйте соответствующий ей элемент в палитре Paths. Если вы хотите начать работу с новым контуром, прервав на время построение рабочего, щелкните по кнопке Create new path (Создать новый контур) на палитре Paths.

Построение контура объекта с помощью инструмента Freeform Pen

Так же как и инструмент Magnetic Lasso (Магнитное лассо), инструмент Freeform Pen (Свободное перо) при включении опции Magnetic (Магнитный) автоматически создает контур, когда вы ведете мышь вдоль области с контрастным изображением. Контур будет выровнен по ближайшей границе тени или цвета изображения.

  1. Спрячьте слои, которые не должны участвовать в данной операции.
  2. Выберите инструмент Freeform Pen Tool (клавиша Р или комбинация клавиш Shift+P).
  3. Отмените выделение всех контуров на палитре Paths. На панели опций инструмента Freeform Pen щелкните по кнопке Paths (Контуры) и установите флажок Magnetic (Магнитный).
  4. Далее щелкните по кнопке Geometry options (Геометрические опции) на той же панели и задайте во всплывающем окне Freeform Pen Options необходимые параметры (рис. 16.14).
  5. Щелкните мышью в том месте, где необходимо начать построение контура. Затем медленно двигайте курсор - при этом не обязательно удерживать нажатой кнопку мыши - вдоль края фигуры, где должен быть контур (рис. 16.15).

    Когда вы будете вести мышь, контур будет выравниваться по краю фигуры. Если вы станете перемещать мышь слишком быстро, то, возможно, инструмент не будет успевать фиксировать ее перемещения.

Рис. 16.14. Окно Freeform Pen Options

Рис. 16.15. Начало построения контура вдоль заданного объекта

Рис. 16.16. Готовый контур, созданный в режиме Magnetic

  6. Если программа выровняла контур по каким-либо соседним фигурам, которые вы не хотите выделять, щелкните кнопкой мыши по краю нужного объекта, чтобы вручную создать узловую точку. Затем продолжайте перемещать мышь и завершите построение контура (рис. 16.16).
  7. Замкнуть контур можно тремя способами.Во-первых, дважды щелкнуть вне изображения, чтобы замкнуть контур с помощью «магнитных» сегментов, или сделать то же самое при нажатой клавише Alt, чтобы сегменты были прямолинейными. Во-вторых, щелкнуть по первой узловой точке (при этом рядом с указателем появится маленький кружочек). Наконец, можно нажать клавишу Ctrl и щелкнуть мышью где-либо вне изображения.

    Чтобы закончить работу с контуром, но оставить его незамкнутым, нажмите клавишу Enter. Затем можно начать построение другого контура в этом же рабочем поле с помощью инструмента Реn.

Чтобы при работе с Freeform Pen Tool на время активизировать инструмент Реn Tool и создать прямолинейные сегменты, нажмите клавишу Alt и можете рисовать. Для возврата к инструменту Freeform Pen Tool отпустите нажатую ранее клавишу Alt.

Нажмите клавишу Esc, если хотите удалить незаконченный контур.

Окно Magnetic Options

Если на панели опций инструмента Free-form Pen установлен флажок Magnetic (Магнитный), то становится доступным всплывающее окно Freeform Pen Options Параметры свободного пера) см. рис. 16.14.

Параметр Width (Ширина), значение которого меняется от 1 до 40, определяет ширину в пикселах (относительно расположения курсора) участка, анализируемого программой при выборе места для узловой точки. Для высококонтрастного изображения с четко определенными границами объектов выбирайте большое значение ширины. Для низкоконтрастных изображений с едва различимыми или близко расположенными границами выбирайте малое значение, чтобы более точно расположить сегменты контура.

Чтобы курсор инструмента Freeform Pen в режиме Magnetic имел вид круга с диаметром заданной ширины, включите опцию Precise (Точный) в группе Other cursors (Другие курсоры), выбрав элемент меню Edit > Preferences о Display&Cursors (Правка о Установки > Отображение&курсоры). Либо нажмите клавишу Caps Lock для временного включения этой опции.

Для того чтобы плавно уменьшить значение параметра Width при создании контура, нажимайте клавишу [. Соответственно, для увеличения его значения нажимайте клавишу ].

Значение параметра Contrast (Контраст), изменяющееся от 0 до 100, определяет уровень контраста, который учитывается при разграничении изображений. При малой величине контраста программа будет различать границы даже между слабоконтрастными областями.

Рис. 16.17. Замыкание контура в первой точке

Рис. 16.18. Готовый замкнутый контур, созданный при помощи инструмента Freeform Pen

Значение параметра Frequency (Частота) лежит в диапазоне от 5 до 40 и определяет скорость установки узловых точек при создании контура. Чем меньше значение частоты, тем быстрее будут рисоваться промежуточные точки и тем больше узловых точек будет создано.

Создание произвольного контура с помощью инструмента Freeform Pen

Инструмент Freeform Pen (Свободное перо) позволяет рисовать контур путем перемещения мыши с нажатой кнопкой. Узловые точки расставляются вдоль траектории автоматически, как только вы отпускаете кнопку мыши.

  1. Выберите инструмент Freeform Pen Tool (клавиша Р или комбинация клавиш Shift+P).
  2. На панели опций инструмента щелкните по кнопке Paths и снимите флажок Magnetic.
  3. Нарисуйте произвольный контур. Чтобы построить прямолинейный сегмент, щелкните кнопкой мыши при нажатой клавише Alt, а затем отпустите клавишу, чтобы отключить данный режим.
  4. Чтобы получить замкнутый контур, доведите кривую до первой созданной точки (рис. 16.17 и 16.18).

При этом рядом с указателем появится маленький кружочек. Второй способ замкнуть контур - нажать клавишу Ctrl и отпустить кнопку мыши.

Чтобы завершить работу с контуром, но оставить его незамкнутым, просто отпустите кнопку мыши.

Введите значение параметра Curve Fit (Подгонка кривой) во всплывающем окне Freeform Pen Options (Опции свободного пера) в пределах от 0.5 до 10 пикселов, чтобы задать точность соответствия контура движению курсора. Чем больше это значение, тем реже будут стоять узловые точки, и тем более плавные очертания будет иметь контур.

Операции над контурами

В программе Photoshop есть несколько операций, облегчающих корректировку контуров.

Дорисовка существующего незамкнутого контура

  1. Активизируйте инструмент |J Free-form Pen или |• j Pen (клавиша Р или комбинация клавиш Shift+P).
  2. Щелкните по имени сохраненного незамкнутого или рабочего контура на палитре Paths.
  3. Достройте контур от любой конечной точки (рис. 16.20 и 16.21). Чтобы замкнуть контур, выполните шаг 4 раздела «Создание произвольного контура с помощью инструмента Freeform Pen».

Рис. 16.19. Перемещение контура с помощью инструмента Path Component Selection

Перемещение контура

1. На палитре Paths щелкните по имени контура.

2. Активизируйте инструмент Path Selection Tool (Инструмент выбора контура), например, при помощи клавиши А или комбинации клавиш Shift+A. Затем, чтобы выбрать контур, щелкните по нему в окне изображения.

3. Переместите контур (рис. 16.19).

Рис. 16.20. Достраивание контура от конечной точки с помощью инструмента Реn или Freeform Pen

Рис. 16.21. Замыкание контура

Рис. 16.22. Масштабирование контура

Трансформация контура или контура отсечения целиком

  1. Выберите инструмент Path Selection Tool (клавиша А или Shift+A).
  2. Далее активизируйте контур на палитре Paths и затем щелкните мышью внутри него.
  3. В подменю Edit > Transform Path (Правка > Трансформировать контур) воспользуйтесь командами Scale (Масштабирование), Rotate (Вращение), Skew (Наклон), Distort (Деформация) или Perspective (Перспектива). Либо выполните команду меню Edit > Free Transform Path (Правка> Произвольная трансформация контура). Для ее вызова предназначена комбинация клавиш Ctrl+T.
  4. При изменении контура с помощью этих команд, следуйте указаниям по их применению, которые были даны в главе 7.

Для повторной произвольной трансформации контура используйте команду меню Edit > Transform Path > Again (Правка > Трансформировать контур> Повторно). Этой команде соответствуют комбинации клавиш Ctrl+Shift+T.

Работая с инструментом Path Selection Tool, лучше установить на панели опций режим Show Bounding Box (Показать габаритную рамку). С помощью манипуляторов этой рамки (рис. 16.22) вы можете изменять контур, как и при выполнении команды Free Transform Path.

Изменение расположения точек контура

  1. Активизируйте инструмент Direct Selection Tool (Инструмент прямого выделения), нажав клавишу А, и затем выберите одну или несколько точек контура (см. рис. 16.27).
  2. В подменю Edit > Transform Path выполните команду Scale, Rotate или Skew (команды Distort и Perspective будут недоступны), либо выполните команду Edit> Free Trasform Path (комбинация клавиш Ctrl+T).
  3. При изменении расположения точек с помощью этих команд следуйте указаниям, которые содержатся в главе 7.

Копирование контура в том же окне изображения

Чтобы создать копию контура с другим именем, на палитре Paths перетащите имя контура при нажатой клавише Alt на кнопку Create new path, расположенную в нижней части палитры (рис. 16.23), потом введите новое имя (рис. 16.24) и щелкните по кнопке ОК.

Чтобы скопировать контур, не присваивая ему нового имени, проделайте то же самое, не нажимая на клавишу Alt.

Рис. 16.23. Кнопка Create new path

Рис. 16.24. Ввод нового имени для копии контура

Есть еще один способ копирования контуров. Активизируйте инструмент Path Selection Tool, а затем в окне изображения, нажав клавишу Alt, переместите контур. Оба контура будут иметь одно и то же имя.

Перетаскивание контура в окно с другим изображением

Первый способ:

  1. Сначала откройте два окна: окнотис-точник и окно-получатель, куда будет копироваться контур. Щелкните мышью в окне-источнике.
  2. Перетащите элемент контура с палитры Paths в окно-получатель.

Второй способ: активизируйте инструмент Path Selection Tool (клавиша А), щелкните мышью по копируемому контуру и перетащите его из одного окна в другое.

Третий способ: выделите имя контура на палитре Paths, в меню Edit выполните команду Сору (Копировать), которой соответствует комбинация клавиш Ctrl+C. Затем щелкните мышью по окну-получателю и выполните команду Paste (Вставить) - комбинации клавиш Ctrl+V - из того же меню.

Аналогичным образом при помощи команд Сору и Paste можно также копировать и вставлять контур отсечения слоя, созданный для слоя изображения или слоя типа shape.

Сохранение рабочего контура

Новый контур, построенный с помощью инструмента Реn, автоматически получит название Work Path и будет сохранен вместе с файлом. Однако следующий созданный вами контур заменит существующий. Чтобы не допустить этого, дважды щелкните по имени контура, введите новое имя (рис. 16.25), а потом нажмите кнопку ОК. В результате программа будет автоматически сохранять данный контур после каждого его изменения.

Чтобы быстро сохранить рабочий контур, перетащите его имя на кнопку Create New Path, расположенную в нижней части палитры Paths. Программа Photoshop присвоит ему имя по умолчанию. Чтобы переименовать контур, дважды щелкните по его имени и введите новое.

Отображение и скрытие контура

Щелкните по имени контура или по его миниатюре на палитре Paths (рис. 16.26).

Чтобы изменить размер миниатюры контура на палитре или не отображать ее вовсе, в меню палитры Paths выполните команду Palette Options (Опции палитры) и потом выберите желаемый вариант отображения в группе Thumbnail Size (Размер миниатюры).

Чтобы скрыть контур, нажмите клавишу Shift и щелкните мышью по имени контура на палитре Paths или щелкните мышью под списком имен контуров на палитре.

Рис. 16.25. Ввод имени сохраняемого контура

Рис. 16.26. Элемент контура на палитре Paths

Рис. 16.27. Выделение отдельных точек контура

Рис. 16.28. Выделение всех узловых точек контура

Выделение узловых точек контура

Первый способ:

  1. Щелкните мышью по имени контура на палитре Paths.
  2. Выберите инструмент Path Selection Tool (клавиша А или комбинация клавиш Shift+А).
  3. Щелкните по контуру в окне изображения или нарисуйте с помощью мыши вокруг него пунктирную рамку выделения. Будут выделены все узловые точки контура.

Второй способ:

  1. Выделите имя контура на палитре Paths.
  2. Выберите инструмент Direct Selection Tool (клавиша А или комбинация клавиш Shift+A).
  3. Щелкните по контуру или его части, затем выберите узловую точку (рис. 16.27).

Нажав клавишу Shift и щелкая мышью, можно выделить и другие узловые точки.

Чтобы выделить все узловые точки на контуре, нажмите клавишу Alt и щелкните по контуру или его части либо нарисуйте вокруг контура рамку выделения (рис. 16.28).

Имейте в виду, что переместить контур можно только в том случае, если выделены все узловые точки.

Чтобы изменить положение контура в стеке, на палитре Paths перетащите его имя вверх или вниз.

Если выбран один из инструментов группы Реn, то для временной активизации инструмента Direct Selection Tool нажмите на клавишу Ctrl.

Изменение формы контура

Чтобы изменить форму контура, надо переместить, добавить или удалить узловую точку либо переместить сегмент. Изменить форму криволинейного сегмента можно, переместив или повернув вокруг соответствующей узловой точки направляющую линию.

  1. На палитре Paths щелкните мышью по контуру, форму которого вы хотите изменить.
  2. Выберите инструмент Direct Selection (клавиша А или комбинация клавиш Shift+A). Для переключения на этот инструмент во время работы с другим инструментом группы Реп нажмите клавишу Ctrl.
  3. Щелкните по контуру в окне изображения.
  4. Выполните любое из перечисленных ниже действий.

    Переместите узловую точку или сегмент (рис. 16.29).

    Чтобы выделить сегмент, нарисуйте рамку выделения, охватывающую обе конечные точки сегмента. Нажав клавишу Shift, можно выделить и другие сегменты и части контура. Перемещайте или вращайте направляющую линию (рис. 16.30).

    Если вы будете перемещать манипулятор направляющей линии в точке гладкой стыковки двух сегментов, то оба сегмента также переместятся. Если вы будете перемещать направляющую линию в точке излома контура, то будет перемещаться только один сегмент.

    Чтобы добавить новую узловую точку, выберите инструмент Add Anchor Point Tool (Добавить узловую точку), потом щелкните по сегменту. В тот момент, когда вы наведете указатель на сегмент, появится курсор в виде пера со знаком «плюс» (рис. 16.31 и 16.32).

Рис. 16.29. Перемещение узловой точки

Рис. 16.30. Перемещение манипулятора направляющей линии

Рис. 16.31. Добавление узловой точки

Рис. 16.32. Новая узловая точка

Рис. 16.33. Удаление узловой точки

Рис. 16.34. Поворот направляющей линии

Если на панели опций установлен флажок AutoAdd/Delete (Автоматическое добавление/удаление), инструмент Реп превращается в Add Anchor Point Tool, как только указатель наводят на сегмент, или в инструмент Delete Anchor Point Tool (Удалить узловую точку), если указатель оказывается на узловой точке. Чтобы временно выключить этот режим, нажмите и удерживайте клавишу Shift.

Чтобы удалить узловую точку, активизируйте инструмент Delete Anchor Point Tool (Удалить узловую точку) и щелкните по ней. Когда курсор указывает на точку, рядом с изображением пера появляется знак «минус» (рис. 16.33).

Чтобы превратить точку гладкой стыковки сегментов в излом, активизируйте инструмент Convert Point Tool (Преобразовать узел). Если перед этим вы пользовались инструментом Direct Selection Tool, то достаточно нажать сочетание клавиш Ctrl+Alt, если же вы работали с инструментом Реп, то клавишу Alt. Затем щелкните по узловой точке и выберите другой инструмент.

Если же вы хотите превратить точку излома в точку гладкой стыковки сегментов, снова выберите инструмент Convert Point Tool и перетащите манипулятор направляющей линии в нужном направлении.

Воспользуйтесь инструментом Convert Point Tool, чтобы повернуть одну половину направляющей линии независимо от второй (рис. 16.34).

Если инструмент Convert Point Tool был применен по отношению к одной половине направляющей линии, то также можно воспользоваться им или инструментом Direct Selection Tool пo отношению к другой.

  5. Щелкните мышью вне контура, чтобы снять с него выделение.

Удаление контура

Первый способ: на палитре Paths выберите тот контур, который следует удалить, затем щелкните правой кнопкой мыши по имени контура и выполните команду Delete Path (Удалить контур) из контекстного меню (рис. 16.35).

Второй способ: нажав клавишу Alt, щелкните мышью по кнопке Delete current path (Удалить текущий контур) на палитре Paths. Можно также щелкнуть по кнопке Delete current path, затем - по кнопке Yes (Да) или просто перетащить имя контура на кнопку Delete current path.

Если контур, который вы хотите удалить, рабочий, то достаточно просто с помощью инструмента Реп создать новый рабочий контур, тогда предыдущий контур будет автоматически удален.

Преобразование контура в границу выделения

  1. По желанию. Выделите некоторую область, чтобы в дальнейшем над ней и вновь созданной областью выделения можно было произвести такие операции, как сложение, вычитание и пересечение.

Рис. 16.35. Выбор команды Delete Path в контекстном меню

Отмена выделения контура

1. Выберите инструмент Direct Selection Tool или Path Selection Tool (клавиша А или сочетание клавиш Shift+A).

2. Щелкните мышью вне контура в окне изображения. Контур останется видимым, но его узловые точки и направляющие линии будут скрыты.

Рис. 16.36. Превращение контура в выделение

Рис. 16.37. Окно параметров операции Make Selection

  2. Нажав клавишу Ctrl, щелкните мышью по имени того контура, который вы хотите преобразовать в выделенную область, или выберите имя контура в палитре Paths и щелкните по кнопке Load path as selection (Загрузить контур в виде выделенной области) в нижней части палитры Paths (рис. 16.36). При выполнении данной команды будут применены текущие параметры операции Make Selection (Создать выделение).

    Для установки других параметров щелкните правой кнопкой мыши по имени контура и выполните команду Make Selection из контекстного меню. Для выделенной области можно задать значение параметра Feather Radius (Радиус растушевки). Введите небольшую величину этого радиуса (рис. 16.37), чтобы немного смягчить границы. Над рассматриваемым контуром и выделенной ранее областью изображения также можно выполнить операции сложения, вычитания или пересечения (выберите нужный элемент в группе Operation (Операция). Клавишные эквиваленты для каждой из этих операций приведены ниже. Щелкните по кнопке ОК.

Если установлен флажок Anti-aliased (Сглаживание), то значение параметра Feather Radius задайте равным 0.

  3. В палитре Layers (Слои) выберите тот слой, для которого была создана выделенная область.

«Горячие» клавиши для преобразования контура в выделенную область

В табл. 16.1 перечислены операции, применяемые для преобразования контура в выделенную область, и соответствующие им «горячие» клавиши.

Обводка контура

При обводке (stroke) контура определенным цветом опции текущего инструмента (например, Opacity (Непрозрачность) и Mode (Режим)) используются в качестве параметров выполняемой операции.

  1. В палитре Paths выберите замкнутый или незамкнутый контур.
  2. В палитре Layers (Слои) выделите тот слой, в котором необходимо произвести обводку контура (но не слой типа shape).
  3. Выберите инструмент из списка, показанного на рис. 16.38.

Рис. 16.38. Список инструментов для обводки контура

Таблица 16.1. «Горячие» клавиши для операций преобразования контура

Операции | «Горячие» клавиши
Выделить контур | Щелчок мышью по имени контура при нажатой клавише Ctrl
Добавить контур к выделению | Щелчок мышью по имени контура при нажатых клавишах Ctrl+Shift
Удалить контур из выделения | Щелчок мышью по имени контура при нажатых клавишах Ctrt+Alt
Пересечь контур с выделением | Щелчок мышью по имени контура при нажатых клавишах Ctrl+Alt+Shift

Рис. 16.39. Кнопка операции обводки

Рис. 16.40. Исходное изображение (его миниатюра показана на рис. 16.39)

Рис. 16.41. Результат обводки контура с помощью инструмента Pencil

  4. На панели опций выберите значение параметров Mode (Режим), Opacity (Непрозрачность) или Pressure (Нажим) и, щелкнув по стрелке рядом со значением опции Brush (Кисть), выберите из списка инструмент подходящего размера. Толщина обводки будет равна диаметру кисти.
  5. Выберите значение параметра Foreground Color (Основной цвет).
  6. В нижней части палитры Paths щелкните по кнопке Stroke path with brush (Обводка контура кистью) - рис. 16.39,16.40 и 16.41.

Если необходимо поменять инструмент для обводки, то, нажав клавишу Alt, щелкните мышью по кнопке Stroke path with brush, выберите инструмент из всплывающего меню Tool (Инструмент) и щелкните по кнопке ОК (см. рис. 16.38).

С помощью окна Layer Style (Стиль слоя) можно применить эффект Stroke к контуру отсечения слоя, предварительно указав параметры обводки (см. главу 14, раздел «Применение эффекта Stroke»).

Заливка контура

Команда Fill Path (Заливка контура) позволяет заполнить контур определенным цветом, повторяющимся узором или каким-либо другим изображением.

  1. В палитре Paths активизируйте замкнутый или незамкнутый контур.
  2. В палитре Layers выберите слой, в котором будет находиться закрашенный контур.
  3. Чтобы залить контур каким-либо цветом, отличным от белого и черного, задайте значение параметра Foreground color.

    Если вы хотите заполнить контур каким-либо изображением, с которым вы работали ранее, переместите пиктограмму инструмента History Brush (Восстанавливающая кисть) на состояние, соответствующее этому изображению.

    Чтобы залить контур повторяющимся узором, воспользуйтесь имеющимися образцами.

  4. Нажав клавишу Alt, щелкните мышью по кнопке Fill path with foreground color (Заливка контура основным цветом) в нижней части палитры Paths (рис. 16.42).
  5. Выберите в группе Contents (Содержимое заливки) из раскрывающегося списка Use (Использовать) соответствующий режим заливки (рис. 16.43).

    Для заполнения контура узором выберите какой-либо элемент на панели Custom Pattern (Палитра узоров). Затем установите значение параметра Mode (Режим). Чтобы заполнение казалось прозрачным, используйте режим Clear (Очистка).

    Задайте значение параметра Opacity (Непрозрачность) в процентах.

  6. По желанию. Если слой изображения (кроме фонового) активен, то установите флажок Preserve Transparency (Сохранить прозрачность), чтобы изменить цвет только видимых областей слоя.
  7. По желанию. Задайте значения параметров группы Rendering (Рендеринг) - радиус растушевки и режим сглаживания.
  8. Щелкните по кнопке ОК (рис. 16.44 и 16.45).

Рис. 16.42. Кнопка операции заливки контура

Рис. 16.43. Окно опций операции заливки

Чтобы залить контур с использованием текущих значений параметров данной операции, выберите имя контура и щелкните по кнопке Fill path with foreground color, находящейся внизу палитры Paths.

С помощью окна Layer Style (Стиль слоя) к контуру отсечения можно применить эффект Color Overlay (Наложение цвета), предварительно указав параметры операции (см. главу 14, раздел «Применение эффекта Color Overlay»).

Рис. 16.44. Исходный контур

Рис. 16.45. Контур, заполненный узором при 50% непрозрачности

Экспорт контура в программы Illustrator или Freehand

Созданный в Photoshop контур можно экспортировать в программы Adobe Illustrator или Macromedia Freehand и в дальнейшем редактировать его там. Затем допускается импортировать этот же контур обратно в Photoshop (операции экспорта-импорта были описаны в главе 3, раздел «Размещение изображения формата EPS, PDF или Adobe Illustrator в Photoshop»).

С помощью инструмента Path Selection Tool и буфера обмена можно копировать, вставлять или перетаскивать активный контур в другое приложение (или в другое окно в том же приложении).

  1. Создайте новый контур, а затем сохраните его. Также можно использовать контур отсечения слоя (см. следующий раздел).
  2. Выполните команду File > Export > Paths to Ilustrator (Файл > Экспорт > Контуры в Illustrator).
  3. По желанию, если необходимо, то укажите имя файла в соответствующем поле - File Name.
  4. В меню Paths (Контуры) (рис. 16.46) выберите имя контура или режим All Paths (Все контуры), чтобы экспортировать все контуры изображения в одном файле. Информация о границах документа (crop mark) будет включена в экспортируемый файл.

    Чтобы экспортировать данные о границах только для текущего файла, выберите вариант Document Bounds (Границы документа).

  5. Укажите каталог, в котором следует сохранить файл.
  6. Щелкните по кнопке Save (Сохранить). Теперь контур может быть открыт как документ в программе Adobe Illustrator.

Чтобы быть уверенным в том, что контур будет полностью соответствовать изображению при его импорте обратно в Photoshop, не меняйте в программе Illustrator границы документа.

Возможно, вам придется включить опцию Outline View (Показ контура) в программе Illustrator, чтобы увидеть экспортированный контур. Это потребуется в том случае, если для него не была выполнена операция обводки.

Рис. 16.46. Выбор контура в меню Paths

Рис. 16.47. Слой с мазками, которые впоследствии будут отсечены

Контуры отсечения слоев

Контур отсечения слоя (layer clipping path) практически идентичен маске слоя с той только разницей, что для разграничения видимых и невидимых областей слоя используется векторный объект. Такой контур можно создать с помощью инструментов Pen, Freeform Pen или инструментов построения фигур, либо используя выделенную область, границы которой были преобразованы в контур. Контур отсечения слоев позволяет с высокой точностью задать границы видимого изображения. В любой момент можно изменить форму контура или удалить его.

Миниатюра контура отсечения слоев будет отображаться серым цветом на палитре Layers, а также на палитре Paths, если активизирован слой с контуром отсечения. Как и маска слоя, контур отсечения связан только с одним слоем.

Создание контура отсечения слоя

Первый способ:

  1. В палитре Layers выберите тот слой, к которому необходимо добавить контур отсечения (рис. 16.47).
  2. Для созданий «белой» маски, обеспечивающей видимость всех пикселов слоя, выберите команду меню Layer > Add Vector Mask > Reveal All (Слой > Добавить контур отсечения > Показать все), либо, нажав клавишу Ctrl, щелкните мышью по кнопке Add layer mask (Добавить маску) на палитре Layers.

    Для создания «серой» маски, скрывающей все точки слоя, выберите команду меню Layer > Add Vector Mask > Hide All (Слой > Добавить контур отсечения > Спрятать все), либо, нажав сочетание клавиш Ctrl+Alt, щелкните мышью по кнопке Add layer mask на палитре Layers.

  3. Выберите любой из инструментов: Реп, Freeform pen или инструмент построения фигуры - и создайте контур отсечения желаемой формы (рис. 16.48,16.49).

Более подробно методы использования перечисленных инструментов описаны в данной главе выше.

Второй способ:

  1. В палитре Layers выберите тот слой, к которому хотите добавить контур отсечения.
  2. Для отображения только тех точек слоя, которые расположены внутри контура, выделите контур на палитре Paths. Выполните команду меню Layer > Add Vector Mask> Current Path (Слой > Добавить контур отсечения <> Текущий контур).

Контуры отсечения в формате EPS - новые возможности

Если сохранить файл, содержащий контур отсечения, в формате EPS для последующего импорта в другую программу (например, InDesign или QuarkXPress), то маскирующий эффект контура будет сохранен. Преимущества этого способа по сравнению с использованием палитры Paths в том, что работа ведется непосредственно со слоем изображения, и можно увидеть, как выглядит изображение, прежде чем оно будет экспортировано. Только обязательно убедитесь, что в окне EPS

Рис. 16.48. Построение контура отсечения

Рис. 16.49. Результат применения контура отсечения к изображению слоя

Рис. 16.50. Добавление нового контура отсечения к слою, уже содержащему один контур отсечения

Рис. 16.51. Миниатюра слоя, содержащего два контура отсечения

Options (Опции формата EPS) установлен флажок Include Vector Data (Включить векторные данные).

Чтобы импортировать файл, содержащий контур отсечения слоев, из программы Photoshop в программу Illustrator 9, выполните в последней команду Place (Разместить), предварительно сбросив флажок Link (Связь), или Open (Открыть), а затем выполните преобразование слоев в объекты.

Операции над контурами отсечения

Операции над контурами отсечения в целом похожи на действия, выполняемые с обычными контурами.

Комбинирование контуров

Кнопки операций над контурами используются в том случае, если необходимо дополнить контур или вырезать его часть, либо создать отдельный контур.

  1. Щелкните по имени слоя, имеющего контур отсечения. Его миниатюра будет выделена.
  2. Выберите инструмент Реn или инструмент построения фигуры.
  3. На панели опций щелкните по одной из четырех кнопок, определяющих режимы взаимодействия контуров (добавить к области, удалить из области, пересечь области фигур, исключить общие области), и нарисуйте еще один контур в окне изображения (рис. 16.50 и 16.51).

Изменение формы контура отсечения слоев

При изменении формы контура отсечения соответственно будет изменяться и маскирующий эффект.

  1. Выберите инструмент Direct Selection Tool (Прямое выделение), нажав клавишу А или комбинацию клавиш Shift+A.
  2. Щелкните мышью в окне изображения по контуру отсечения, чтобы его выделить, или выберите имя слоя, содержащего контур отсечения. В результате будет выделена миниатюра контура отсечения, а сам контур отсечения появится в окне изображения.
  3. Щелкните по границе контура отсечения слоев, чтобы можно было выбрать узловые точки.
  4. Для изменения формы контура выполните шаги, описанные в разделе «Изменение формы контура».

Перемещение контура отсечения слоев

В любой момент контур отсечения слоев может быть перемещен независимо от точек слоя, при этом он остается прикрепленным к слою.

  1. Выберите инструмент Path Selection Tool (клавиша А или комбинация клавиш Shift+A).
  2. На палитре Layers щелкните по имени слоя, содержащего контур отсечения, или выделите контур отсечения в окне изображения.
  3. Переместите контур отсечения на новое место. Теперь будет видна другая область слоя (рис. 16.52).

Рис. 16.52. Перемещение контура отсечения

Рис. 16.53. Перемещение миниатюры контура отсечения

Рис. 16.54. Копия контура отсечения в активном слое

Рис. 16.55. Временное отключение эффекта контура отсечения слоев

Рис. 16.56. Выделение узловых точек контура отсечения

Создание копии контура отсечения

  1. Выберите слой, в котором вы хотите создать копию.
  2. Из другого слоя перетащите миниатюру контура отсечения слоев, который надо скопировать, на кнопку Add layer mask (Добавить маску) - рис. 16.53, 16.54. В активном слое появится копия контура отсечения.

Временное отключение эффектов контура отсечения слоев

Нажав клавишу Shift, в палитре Layers щелкните мышью по миниатюре контура отсечения слоев. Миниатюра будет перечеркнута красным крестом, и на экране отобразятся все точки слоя (рис. 16.55). При этом миниатюра контура отсечения слоев не будет выделена.

Снова нажав клавишу Shift и щелкнув по миниатюре, удалите красный крест и восстановите указанный эффект.

Переключение видимых и невидимых областей

  1. Выберите инструмент Path Selection Tool (клавиша А или сочетание клавиш Shift+A).
  2. На палитре Layers щелкните по имени слоя, содержащего контур отсечения, а затем по контуру отсечения в окне изображения.

    Можно также дважды щелкнуть по контуру отсечения в окне изображения.

    Каким бы методом вы не воспользовались, сначала будет выделен сам контур отсечения, а потом его узловые точки и сегменты (рис. 16.56).

  3. Щелкните по второй из кнопок на панели параметров - Subtract from shape area (Вычесть из области) - рис. 16.57 и 16.58 (или нажмите клавишу со знаком «минус»).

Чтобы снова поменять местами видимые и невидимые участки, щелкните по первой кнопке Add to shape area (Добавить к области) или нажмите клавишу со знаком «плюс».

Удаление контура отсечения слоев

Если вам уже не нужны какие-либо контуры отсечения слоев, их можно удалить, хотя это действие и не увеличит объем свободного дискового пространства.

  1. На палитре Layers выберите миниатюру контура отсечения, который следует удалить.
  2. Щелкните по кнопке Delete Layer (Удалить слой) или перетащите миниатюру контура отсечения слоев на эту кнопку (рис. 16.59).

    Можно также воспользоваться командой меню Layer > Delete Vector Mask (Слой > Удалить контур отсечения).

  3. Щелкните по кнопке ОК.

Рис. 16.57. Кнопка Subtract from shape area

Рис. 16.58. Результат операции вычитания

Рис. 16.59. Перетаскивание миниатюры контура отсечения слоев на кнопку Delete Layer

Рис. 16.60. Преобразование выделенной области маски слоя в контур отсечения

Преобразование маски слоя в контур отсечения

  1. Нажав клавишу Ctrl, щелкните по миниатюре маски слоя в палитре Layers.
  2. На палитре Paths щелкните по кнопке Make work path (Создать рабочий контур) и оставьте контур выделенным.
  3. Выполните команду меню Layer > Add Vector Mask > Current Path (Слой > Добавить контур отсечения > Текущий контур) - см. рис. 16.60.
  4. По желанию. Чтобы удалить маску слоя, перетащите ее миниатюру на кнопку Delete layer (Удалить слой) в палитре Layers, а потом щелкните по кнопке Discard (Удалить), либо выполните команду меню Layer > Remove Layer Mask > Discard (Слой > Удалить маску слоя > Удалить). При этом контур отсечения слоев будет сохранен.

Создание корректирующего слоя, использующего контур отсечения

  1. Создайте новый слой типа shape (как это сделать, описано ниже в разделе «Создание слоя фигуры»).
  2. Выполните команду меню Layer > Change Layer Content (Слой > Изменить содержимое слоя) и выберите команду коррекции слоя.
  3. В диалоговом окне проведите необходимые изменения и щелкните по кнопке ОК.

Создание контура отсечения из текста

С помощью контуров отсечения можно заполнить внутреннюю область букв каким-либо изображением. Первый способ:

  1. Создайте слой текста (рис. 16.61).
  2. Выполните команду меню Layer & Туре > Convert to Shape (Слой > Текст > Преобразовать в фигуру) - см. рис. 16.62.
  3. В меню палитры Paths выполните команду Save Path (Сохранить контур) и щелкните по кнопке ОК.
  4. Пусть контур останется выделенным. Активизируйте палитру Layers и выберите слой, к которому следует прикрепить новый контур отсечения слоев (но не тот слой, который содержит контур!).
  5. Выполните команду меню Layer >. Add Vector Mask > Current Path (Слой > Добавить контур отсечения > Текущий контур).
  6. Удалите или спрячьте слой с фигурами, изображающими текст.

Рис. 16.61. Выбор слоя текста

Рис. 16.62. Преобразование слоя текста в слой типа shape

Рис. 16.63. Копирование миниатюры слоя отсечения в выбранный слой

Второй способ:

  1. Создайте слой текста (см. рис. 16.61).
  2. Выполните команду меню Layer > Type > Convert to Shape (см. рис. 16.62).
  3. Выделите слой, к которому следует прикрепить новый контур отсечения слоев (но не тот слой, который его содержит!).
  4. Перетащите миниатюру контура отсечения, созданного на шаге 2, на кнопку Add layer mask (Добавить маску) в палитре Layers. К активному слою будет прикреплен новый контур отсечения слоев (рис. 16..63).
  5. Удалите или спрячьте слой текста.

При использовании любого из описанных выше способов вы можете сделать следующее:

  • создать дубликат исходного слоя текста до его преобразования так, что в дальнейшем можно будет редактировать слой и создавать другие контуры отсечения, а затем спрятать этот дубликат;
  • с помощью инструмента Path Selection Tool в любой момент переместить контур отсечения внутри слоя, его содержащего;
  • поменять местами видимые и невидимые участки слоя с помощью инструмента Path Selection Tool. Для этого необходимо нажать клавишу Shift и щелкнуть по контурам отсечения в изображении, а затем - по кнопке Subtract from shape area на панели опций.

Фигуры

Фигура (shape) представляет собой геометрический объект или область определенной формы. Фигура может иметь однотонную или градиентную окраску, либо заполняться повторяющимся узором в пределах своих границ, причем каждой фигуре при этом соответствует собственный слой (рис. 16.64).

В любой момент фигура может быть перемещена, трансформирована, или могут быть изменены ее границы, тип и содержимое заливки. Для фигуры допускается задать (или применить к ней) обычные стили слоя, эффекты, режимы наложения и уровень прозрачности.

В отличие от основного растрового изображения, с которым .работает Photoshop, слои фигур (или слои типа shape) представляют собой совокупность векторных данных, как в программах Adobe Illustrator или Macromedia Freehand. Это значит, что фигура всегда имеет точные границы вне зависимости от того, напечатана ли она на принтере PostScript, сохранена в формате PDF или импортирована в другую программу векторной графики, то есть фигура не зависит от разрешения.

Создание слоя фигуры

Создание слоя типа shape подразумевает построение векторного контура.

  1. В палитре Layers выберите слой, поверх которого будет создан новый слой фигуры.

Если выбранный слой содержит контур отсечения, то фигура станет его частью. Чтобы предотвратить это, убедитесь, что с миниатюры контура отсечения снято выделение.

Рис. 16.64. Фигура в виде звезды с однотонной окраской

Рис. 16.65. Инструменты для построения фигур

Рис. 16.66. Панель опций инструмента Custom Shape

  2. С помощью палитр Color (Цвет) или Swatches (Образцы) выберите цвет для заливки фигуры. Потом вы узнаете, как задать градиентную окраску фигуры или заполнить ее узором.
  3. Выберите какой-либо инструмент для построения фигур (клавиша U или комбинация клавиш Shift+U) на панели инструментов (рис. 16.65).

    Как только вы выберете один из инструментов для построения фигур, появится панель опций, с помощью которой можно переключиться на другой инструмент, щелкнув мышью по соответствующей кнопке (рис. 16.66).

  4. Панель опций группы инструментов, предназначенных для построения фигур, дает пользователю следующие возможности.

    Если активизирован инструмент Rounded Rectangle Tool (Прямоугольник с округленными углами), то выберите величину параметра Radius (Радиус); если активизирован инструмент Polygon Tool (Многоугольник) - то Sides (Число сторон), а если инструмент Line (Прямая) - то Weight (Толщина линии). Если вы работаете с инструментом Custom Shape Tool (Произвольная фигура), выберите соответствующую фигуру из раскрывающегося списка.

    Щелкните по кнопке Shape layers (Создать новые слои типа shape). Если эта кнопка недоступна, значит, выбран существующий контур отсечения, и в этом случае сначала отмените выделение его миниатюры.

    Выберите значения параметров Layer Style (Стиль слоя), Mode (Режим) и Opacity (Непрозрачность).

  5. В окне изображения нарисуйте фигуру. При нажатии клавиши Shift будет построен квадрат (вместо прямоугольника), круг (вместо эллипса) и линия, расположенная под углом кратным 45° к предыдущей.
  6. Если отпустить кнопку мыши, то на экране отобразится созданная фигура (рис. 16.67).

Новый слой Shape 1 появится в списке слоев на палитре Layers. Одновременно появится миниатюра корректирующего слоя, который управляет содержимым заливки, и миниатюра контура отсечения, где показана форма контура и место его расположения (рис. 16.68).

Эффекты, применяемые к контуру отсечения

К слою фигуры или слою, имеющему контур отсечения, применимы такие эффекты слоя, как, например, Inner Glow (Внутреннее свечение), Bevel (Скос) и другие, что позволяет подчеркнуть края, добавить тень и т.д. Если для обводки или заливки контура отсечения применить эффект Stroke (Обводка) или любой из эффектов Overlay (Наложение), то тогда появится возможность в любой момент изменить параметры заливки или обводки.

Рис. 16.67. Фигура, построенная с помощью инструмента Custom Shape Tool

Рис. 16.68. Элемент палитры Layers, соответствующий новому слою типа shape

Рис. 16.69. Кнопка Create new work path

Рис. 16.70. Пятиугольный рабочий контур

Рис. 16.71. Рабочий контур на палитре Paths

При создании следующего рабочего контура с использованием инструмента для построения фигур в режиме Paths существующий контур будет удален. Чтобы избежать этого и сохранить рабочий контур, дважды щелкните по рабочему контуру на палитре Paths и нажмите кнопку ОК.

Сравнение программ Photoshop ImageReady

Инструменты группы Pen, Polygon (Многоугольник), а также Custom Shape (Произвольная фигура) доступны только в программе Photoshop, но не в ImageReady.

В программе Photoshop в одном и том же слое типа shape могут находиться сразу несколько фигур, и можно объединять их, удалять общие области, либо, наоборот, оставлять только их пересечение, нажимая соответствующие кнопки на панели опций. В программе же ImageReady для одного слоя может быть создана только одна фигура.

В программе Photoshop в любой момент можно редактировать фигуры. А в программе ImageReady только трансформировать их и перемещать, но не редактировать.

Создание рабочего контура

Инструменты для построения фигур можно использовать и для создания временного рабочего контура.

  1. Выполните шаги 1-4 раздела «Создание слоя фигуры».
  2. На панели опций щелкните по кнопке Paths (Контуры) - рис. 16.69.
  3. С помощью мыши нарисуйте контур в окне изображения (рис. 16.70).

Нажав клавишу Shift, можно нарисовать квадрат вместо прямоугольника, круг -вместо эллипса, а также линию под углом кратным 45° к предыдущей. Новый рабочий контур появится в списке на палитре Paths (рис. 16.71).

Подробнее о рабочих контурах см. выше в данной главе.

Создание растровой геометрической фигуры

Также с помощью инструмента для построения фигур можно создать растровую геометрическую область в слое. Это довольно быстрый способ получить точную фигуру без использования контура отсечения слоев.

  1. Выделите или постройте новый слой. Растровая фигура (pixel shape) не может быть создана в векторном слое (слое фигуры или текстовом слое).
  2. Выберите цвет.
  3. Активизируйте инструмент для построения фигуры (клавиша U или комбинация клавиш Shift+U). На панели опций поменяйте в случае необходимости тип инструмента, щелкнув по соответствующей кнопке.
  4. На панели опций щелкните по кнопке Fill pixels (Создать заполненную область) - см. рис. 16.72.

    Если вы используете инструмент Rounded Rectangle Tool (Прямоугольник с закругленными углами), укажите величину радиуса; для инструмента Polygon Tool (Многоугольник) задайте число сторон; для инструмента Line (Линия) - толщину линии; а для инструмента Custom Shape Tool (Произвольная фигура) выберите какую-либо фигуру из выпадающего меню.

    Выберите значения параметров Layer Style (Стиль слоя), Mode (Режим) и Opacity (Непрозрачность).

  5. С помощью мыши постройте фигуру в окне изображения. В результате будет создана растровая область (рис. 16.73).

Для изменения растровой области воспользуйтесь кистью, инструментами редактирования, фильтрами и т.д.

Рис. 16.72. Кнопка создания заполненной-области

Рис. 16.73. Новая растровая область на палитре Layers

Рис. 16.74. Рисование растровой области в маске слоя

Чтобы создать растровую геометрическую область в маске слоя, на палитре Layers выделите миниатюру существующей маски слоя и щелкните по кнопке Fill pixels на панели опций р;, а затем с помощью мыши нарисуйте желаемую область (рис. 16.74).

Рис. 16.75. Панель опций инструмента Ellipse и кнопка ее вызова

Рис. 16.76. Панель с пиктограммами -эоизвольных фигур

Выбор параметров для инструментов построения фигур

В данном разделе рассказывается, как настроить параметры инструментов построения фигур.

  1. Выберите один из инструментов построения фигур (клавиша U или комбинация клавиш Shift+U). Если один из них уже активен, то для перехода к другому инструменту достаточно щелкнуть по соответствующей кнопке на панели опций.
  2. На панели опций инструмента нажмите кнопку со стрелкой (рис. 16.75).
  3. На выпадающей панели выберите одно из значений переключателя: Unconstrained (Произвольный размер), Square/Circle (Квадрат/Круг), Fixed Size (Фиксированный размер) или Proportional (Пропорционально). В случае Fixed Size и Proportional введите числовые значения в поля W (Ширина) и Н (Высота). Установите флажок From Center (Из центра), чтобы строить фигуру относительно центра.
  4. Если вы воспользовались инструментом Custom Shape, то щелкните мышью по кнопке с треугольной стрелкой (рис. 16.76) и на выпадающей панели выберите соответствующую фигуру. С помощью меню этой панели можно загрузить фигуры из других библиотек.
  5. Еще раз щелкните по кнопке с треугольной стрелкой, чтобы закрыть выпадающую панель опций или панель выбора фигур.

Перемещение контура отсечения в слое типа shape

Так как слой фигуры содержит векторные данные, то его контур отсечения можно передвинуть в любой момент; при этом форма контура не изменится.

  1. Выберите инструмент Path Selection Tool (клавиша А или сочетание клавиш Shift+A).
  2. Щелкните мышью по фигуре в окне изображения или по имени слоя типа shape на палитре Layers.
  3. Передвиньте контур отсечения на новое место (рис. 16.77). Тогда миниатюра, на которой показан контур отсечения, тоже изменится (рис. 16.78).

Если вы щелкнете по миниатюре контура отсечения на палитре Layers или просто наведете на нее указатель, то в окне изображения станет видимым контур отсечения. Однако при этом сам контур выделен не будет.

Рис. 16.77. Перемещение контура отсечения в слое типа shape

Рис. 16.78. Изменение миниатюры маски слоя. Сравните с рис. 16.69

Рис. 16.79. Габаритная рамка контура отсечения слоя типа shape

Рис. 16.80. Перемещение узловых точек контура отсечения в слое типа shape

Трансформация слоя типа shape

  1. Воспользуйтесь инструментом Path Selection Tool (клавиша А или комбинация клавиш Shift+A).
  2. Выберите какую-либо фигуру в окне изображения или имя слоя типа shape на палитре Layers.
  3. Щелкните по выделенной фигуре, что6ы стали видны узловые точки (а также габаритная рамка, если на панели опций установлен флажок Show Bounding Box (Показать-габаритную рамку) - см. рис. 16.79). Перемещая манипуляторы габаритной рамки, трансформируйте фигуру.
  4. Операции трансформации подробно описаны в главе 7.

Изменение контура в слое типа shape

  1. Выберите инструмент Direct Selection Tool (клавиша А или сочетание клавиш Shift+A).
  2. Выделите фигуру в окне изображения или имя слоя типа shape на палитре Layers.
  3. Щелкните по краю выделенной фигуры, чтобы стали видимыми узловые точки (рис. 16.80).
  4. Методы изменения формы контура подробно описаны выше в данной главе.

Временное скрытие контура отсечения в слое типа shape

Нажав клавишу Shift, щелкните по миниатюре контура отсечения в строке слоя типа shape на палитре Layers, тогда миниатюра будет перечеркнута красным крестом (рис. 16.81), и на экране отобразятся все точки слоя. Чтобы убрать красный крест и восстановить действие контура отсечения, снова щелкните по миниатюре контура отсечения, нажав на клавишу Shift.

Вставка векторного объекта из программы Illustrator в Photoshop в виде слоя типа shape

  1. Скопируйте векторный объект в программе Illustrator.
  2. В программе Photoshop 7 в меню Edit (Правка) воспользуйтесь командой Paste (Вставить). В появившемся диалоговом окне выберите вариант Shape Layer и щелкните по кнопке ОК (рис. 16.82).

Слой типа shape будет залит текущим основным цветом, но у него не окажется обводки. Вставленный вами объект будет представлять собой контур отсечения слоя типа shape.

Рис. 16.81. Миниатюра временно скрытого контура отсечения

Рис. 16.82. Окно команды Paste

Рис. 16.83. Кнопки для включения режимов взаимодействия контуров

Рис. 16.84. Отсечение части фигуры при помощи вновь построенного контура

Рис. 16.85. Исходное изображение слоя

Чтобы поменять местами видимые и невидимые области, воспользуйтесь инструментом Path Selection Tool, выделите контур и на панели опций щелкните по (второй) кнопке Subtract from shape area (рис. 16.85,16.86). Чтобы восстановить исходный вид, щелкните по (первой) кнопке Add to shape area.

Использование режимов взаимодействия контуров друг с другом

  1. Создайте слой типа shape.
  2. Выделите контур отсечения нового слоя.
  3. Выберите один из инструментов для построения фигур.
  4. На панели опций щелкните по одной из кнопок, определяющих режим взаимодействия контуров: Add to shape area (Добавить к области фигуры), Subtract from shape area (Вычесть из области фигуры), Intersect shape areas (Пересечь области фигур), Exclude overlapping areas (Исключить общие области фигур) - см. рис. 16.83.
  5. С помощью мыши постройте новую фигуру поверх существующей, которая либо расширит ее границы, либо вызовет удаление части первой фигуры (рис. 16.84).

Рис. 16.86. Тот же слой после того, как видимая и невидимая области поменялись местами

Добавление нового элемента на панель выбора произвольных фигур

Если вы изменили вид стандартной фигуры или перенесли фигуру из программы Illustrator, то можно добавить ее на панель инструмента Custom Shape Tool для использования в будущем.

  1. Создайте новую фигуру (рис. 16.87) или новый слой типа shape, используя объект из программы Illustrator.
  2. Выделите имя слоя на палитре Layers.
  3. Выполните команду меню Edit > Define Custom Shape (Правка > Определить произвольную фигуру), введите имя определяемой фигуры и щелкните по кнопке ОК. На панели инструмента Custom Shape появится новый элемент (рис. 16.88) и останется там, даже если вы выйдете из программы или перезагрузите ее. Этот элемент будет удален только в том случае, если вы загрузите новую библиотеку фигур или восстановите библиотеку, заданную по умолчанию.

Изменение заливки фигуры

Чтобы изменить заливку фигуры (на градиентную или с повторяющимся узором) или повлиять на способ применения корректирующего слоя, который по контуру отсечения определяет те области, где необходимо произвести коррекцию, выполните команду меню Layer > Change Layer Contents (Слой > Изменить содержимое слоя).

Рис. 16.87. Новая нестандартная фигура

Рис. 16.88. Новый элемент на панели инструмента Custom Shape Tool

Рис. 16.89. Миниатюра слоя типа shape

Рис. 16.90. Исходный слой на палитре Layers

Рис. 16.91. Результат выполнения команды Rasterize о Shape

Рис. 16.92. Результат выполнения команды Rasterize > Fill Content

Заливка фигуры может быть изменена в любой момент.

  1. Дважды щелкните по миниатюре слоя типа shape в палитре Layers (рис. 16.89) или выделите слой типа shape и выполните команду меню Layer > Layer Contents Options (Слой > Параметры содержимого слоя).
  2. Из цветовой палитры выберите новый цвет и щелкните по кнопке ОК.

Преобразование слоя типа shape в растровый формат

Для выполнения различных операций над пикселами в слое типа shape, например рисования или фильтрации, либо для преобразования контура отсечения фигуры в (пиксельную) маску слоя, сначала надо преобразовать слой в растровый формат.

  1. Выделите слой типа shape (рис. 16.90).
  2. Выполните команду меню Layer > Rasterize (Слой > Преобразовать в растровый формат) и выберите подходящий вариант в появившемся подменю:
    • Shape (Фигура) - преобразует слой типа shape в растровую фигуру с заливкой, расположенную в прозрачном слое, без использования контура отсечения. Теперь в слое можно рисовать и выполнять правку (рис. 16.91);
    • Fill Content (Содержимое заливки) - преобразует содержимое заливки слоя в растровую область, ограниченную контуром отсечения. Теперь в слое можно рисовать и выполнять правку (рис. 16.92);
    • Vector Mask (Векторная маска) -преобразует контур отсечения слоев в растровую маску слоя, имеющую ту же самую форму и положение. Можно менять цвет заливки и перемещать маску в пределах слоя (рис. 16.93);
    • Layer (Слой) - дает такой же эффект, что и команда Shape (см. выше и рис. 16.94);
    • All Layers (Все слои) - преобразует все слои типа shape в растровые фигуры с заливкой, расположенной в прозрачном слое, без использования контура отсечения.

Рис. 16.93. Результат выполнения команды Rasterize > Vector Mask

Рис. 16.94. Результат выполнения команды Rasterize > Layer


  • Глава 17. Работа с текстом
    • Создание текста
      • Различные виды текста
      • Создание редактируемого текстового слоя
    • Редактирование текста
      • Выделение блока текста
      • Выделение всех или нескольких символов в текстовом слое
      • Масштабирование текста
      • Установка межсимвольного расстояния для пары символов
      • Установка межсимвольного расстояния для всей строки текста
      • Установка межстрочного расстояния для горизонтального текста
      • Смещение выделенных символов относительно базовой линии
      • Меню палитры Character
      • Шрифт-заменитель
      • Изменение расположения текста
    • Использование атрибутов абзаца
      • Выключка
      • Настройка отступов и отбивок между абзацами
      • Настройка параметров абзаца
    • Специальные эффекты для текста
      • Трансформация габаритной рамки и текста внутри нее
      • Трансформация габаритной рамки без изменения текста внутри нее
      • Деформация текста на редактируемом слое
      • Перемещение текстового слоя
      • Преобразование текста в растровый формат
      • Отображение рисунка за слоем текста
      • Отображение текста позади слоя с рисунком
      • Заполнение текста изображением с помощью команды Paste Into
      • Заполнение текста изображением с помощью группы отсечения
      • Создание исчезающего текста
      • Применение эффектов слоя к полупрозрачному тексту
      • Обводка текстового слоя
      • Создание выделения в форме символов
      • Перемещение выделения в форме символов
      • Создание текста в канале заказного цвета
      • Редактирование текста в канале заказного цвета
      • Создание текстовой маски для корректирующего слоя

Глава №17.

Работа с текстом

В программе Photoshop текст является векторным.

Текст в программе Photoshop имеет жесткие, четко определенные границы, потому что программа при создании и изменении текста использует векторный контур. В то же время текст является растровым и имеет то же разрешение, что и обыкновенное изображение. Независимо от того, печатают ли текст на принтере, поддерживающем PostScript, либо сохраняют в формате PDF или EPS, он не меняет разрешение и выглядит таким же четким.

Но это еще не все, в программе Photoshop текст можно изменять непосредственно на изображении, присваивать каждой букве свои атрибуты (например, шрифт, кегль) не только во время набора текста, но и после него.

В этой главе вы узнаете, как создавать, изменять, перемещать и изгибать текст; изменять атрибуты литер и абзацев; преобразовывать текст в растровое представление; изменять фон текста; заполнять текст изображением с помощью команды Paste Into (Вставить в) или групп отсечений; создавать исчезающий текст; работать с выделенными областями в виде символов текста; добавлять текст в канал заказного цвета, а также создавать текстовую маску для корректирующего слоя.

Создание текста

Различные виды текста

Как только с помощью инструмента Туре (Текст) был создан текст в программе Photoshop, о(н автоматически появляется на своем собственном слое. В любой момент можно изменить его атрибуты: шрифт, стиль, кегль, цвет, кернинг1, трекинг2, межстрочный интервал, выравнивание, положение относительно базовой линии. Кроме того, различные атрибуты могут быть установлены для разных букв в одном и том же текстовом слое (рис. 17.1).

Также допускается изменять содержание текста, применять к нему разные эффекты слоя, изменять режим смешивания и уровень непрозрачности. Что же можно сделать с редактируемым текстовым слоем? Можно применить фильтры, очертить текст или заполнить его градиентом или рисунком. Чтобы осуществить эти операции, необходимо преобразовать текстовый слой в растровый формат с помощью команды меню Layer > Rasterize > Туре (Слой > Преобразовать в растровый формат > Текст). Текст, показанный на рис. 17.2, сначала был преобразован в растровый формат, а затем к нему применили фильтры и эффекты слоя.

Рис. 17.1. Редактируемый векторный текст

Рис. 17.2. Текст, подвергнутый преобразованию

Русский шрифт

Ввод текста на русском языке в Photoshop 7 возможен, но для этого необходимо иметь шрифты TrueType или Туре 1, которые не содержат кодовых страниц, кроме ISO 8859-1 (стандартная латиница) и СР 1251 (кириллица Windows). Для работы со шрифтами Туре 1 в Windows 9x/ME/NT 4 необходимо, чтобы на компьютере пользователя был установлен пакет Adobe Type Manager (ATM), желательно версии 4 или выше. Комплекты шрифтов TrueType можно приобрести в компании «Арсеналъ» (www.ars.ru) или «ПараГраф» (www.paragraph.ru). Имеются и бесплатные наборы, например размещенный по адресу http://www.bebits.com/ bob/8878/BSFontsCyrl3.zip. Довольно большой выбор кириллических TrueType-шрифтов имеется на FTP сервере фирмы Netscape Communications ftp:/ /ftp.netscape.com. Применять шрифты в тандарте UNICODE из штатной поставки Windows нельзя, вместо русских букв будут отображаться греческие или латиница с диакритическими знаками.

Рис. 17.3. Палитры Character и Paragraph

Текст, созданный в режиме Bitmap, Indexed Color и Multichannel, появится на фоне, а не на слое изображения; такой текст нельзя будет редактировать.

Но все не так просто. Как только текст будет преобразован в растровый формат, его типографские атрибуты (например, шрифт или стиль) уже изменить нельзя. Заметьте, что текст, импортированный из программы Adobe Illustrator, автоматически преобразуется в растровый формат.

Любые типы текста (редактируемый и др.) создаются с помощью инструмента Туре (Текст), меню „Layer (Слои), палитры Character (Шрифт), показанной на рис. 17.3, палитры Paragraph (Абзац) и панели опций (рис. 17.4).

Также с помощью инструмента Туре в активном слое выделяют фрагмент текста, который можно преобразовать в маску слоя (см. главу 14, раздел «Маски слоя»), сохранить в альфа-канале или сохранить в виде слоя фигуры (типа shape) для дальнейшего использования (как это сделать, рассказано в главе 16, раздел «Фигуры»).

Редактируемый текст (в противоположность тексту, созданному как выделение в активном слое) автоматически появляется в своем собственном слое, и в дальнейшем его можно редактировать, перемещать, трансформировать, менять его положение относительно других слоев, словом, выполнять над ним различные операции, не влияя на другие слои. Работая с программой Photoshop 7, не нужно беспокоиться о том, куда изначально поместить текст и какие его атрибуты выбрать, так как впоследствии все это легко изменить.

Рис. 17.4. Панель опций инструмента Туре

Создание редактируемого текстового слоя

  1. Сначала активизируйте инструмент Туре (Текст), который вызывается нажатием клавиши Т.
  2. Чтобы определить начальную точку для текста в режиме построчного ввода, щелкните в окне (обратите внимание на изменения в правой части панели опций инструмента). Для ввода текстового блока нарисуйте пунктирный контур, тем самым определив границы текста, в которых будут применяться атрибуты абзаца. Лучше располагать отдельные слова или даже символы в отдельных слоях, что позволит перемещать их независимо друг от друга (рис. 17.5).
  3. На панели опций (рис. 17.6,17.7 и 17.8) выполните следующие действия:
    • щелкните по кнопоке Туре на панели опций инструмента Туре (рис. 17.6), чтобы поменять ориентацию теста (по горизонтали/по вертикали);
    • выберите семейство шрифтов (рис. 17.7), стиль и кегль шрифта (последний можно ввести вручную);
    • также укажите в поле Anti-aliased (Сглаживание) один из методов сглаживания границ литер: Sharp (Резкое) Crisp (Жесткое),-Strong (Сильное), или Smooth (Гладкое). Это позволит сгладить границы текста как с маленьким, так и со средним кеглем, добавляя полупрозрачные точки вдоль границ.

    При выборе варианта None (He применять сглаживание) у символов будут неровные края (рис. 17.9-17.12).

Рис. 17.5. Размещение элементов текста в отдельных слоях

Рис. 17.6. Фрагмент панели опций инструмента Туре

Рис. 17.7. Левая сторона панели опций нструмента Туре

Рис. 17.8. Правая часть панели опций инструмента Туре

Рис. 17.9. Без сглаживания

Рис. 17.10. Сглаживание в режиме Crisp

Рис. 17.11. Сглаживание в режиме Strong

Рис. 17.12. Сглаживание в режиме Smooth

Рис. 17.13. Способы выравнивания текстового блока

Щелкните по одной из кнопок группы Alignment (Выключка), чтобы выровнять текст относительно первой точки (построчный режим ввода) или относительно левой, правой границы или по центру окна (при вводе текстового блока)-рис. 17.13.

Выберите цвет текста, щелкнув по полю образца на панели опций и выбрав цвет на всплывающей панели. Цвет текста можно указать также с помощью палитр Swatches (Образцы) или Colors (Цвета).

Щелкните по кнопке Palettes (Палитры), чтобы открыть палитры Character (Шрифт) и Paragraph (Абзац) - и выбрать необходимые атрибуты (об этих палитрах более подробно рассказано ниже в этой главе).

  4. Наберите текст в окне изображения.

Когда курсор находится внутри габаритной рамки, то команда Save (Сохранить) не доступна.

  5. Для того чтобы создать новый текстовый слой, нажмите клавишу Enter. Если же в этом нет необходимости, то нажмите клавишу Esc.

При загрузке программа Photoshop инициализирует все открытые шрифты. Если вам кажется, что загрузка программы идет слишком медленно, и у вас слишком много открытых шрифтов, то попробуйте закрыть некоторыe из них - это должно ускорить процесс.

Каждый раз при использовании инструмента Туре (Текст) программа создает новый слой. Помните об этом, если создаете текст методом проб и ошибок, и удаляйте текстовые слои, которые уже не нужны.

Построчный ввод и текстовые блоки

Если активизировать инструмент Туре (Текст) и щелкнуть мышью в окне изображения, то включается режим построчного ввода. По достижении края изображения такой текст будет исчезать, пока вы не нажмете клавишу Enter. Этот режим удобен при вводе нескольких строк текста и расстановке переносов вручную.

Когда вы рисуете пунктирный контур, определяющий границы вводимого текста, создается текстовый блок. Такой способ ввода используется для больших фрагментов текста. Можно выбрать два алгоритма обработки текстового блока - Adobe Single-line Composer (Построчное размещение) или Adobe Every-line Composer (Размещение всех строк). Они определяют действия программы Photoshop при переносе текста на другую строчку, когда уже достигнута граница блока. Различия между этими двумя алгоритмами незначительные, но иногда бывают полезны.

Редактирование текста

Прежде чем редактировать текст, его следует выделить. Можно выделить одну букву, слово или все слова одного и того же текстового слоя или же габаритную рамку для редактирования текстового блока.

Выделение блока текста

  1. Выберите инструмент Move (Перемещение).
  2. Установите флажок Show Bounding Box (Показать габаритную рамку) на панели опций.
  3. Щелкните мышью по имени текстового слоя на палитре Layers (Слои). Вы увидите границы текстового блока.

Проверка правописания

В Photoshop 7 предусмотрена также проверка правописания. Чтобы вызвать данный модуль, щелкните правой кнопкой мыши по текстовому блоку и в появившемся контекстном меню выберите команду Check Spelling. При обнаружении слова, которое отсутствует в словаре, программа контроля правописания предложит заменить его, внести в словарь или проигнорировать (рис. 17.14).

Рис. 17.14. Программа проверки правописания Photoshop 7

О том, как трансформировать текст с помощью габаритной рамки, см. главу 7, раздел «Трансформация слоя простым перетаскиванием курсора».

В международной версии Photoshop 7 поддерживается проверка правописания на английском (как американском, так и британском), французском, испанском, итальянском, немецком, голландском, шведском и чешском языках.

Для того чтобы после редактирования зафиксировать изменения и перейти к выполнению других операций, нажмите клавишу Enter на дополнительной цифровой клавиатуре, либо активизируйте другой инструмент или выделите другой слой. (Чтобы не сохранять внесенные изменения, нажмите клавишу Esc.)

Если вы хотите применить эффекты слоя или изменить их в текстовом слое, дважды щелкните по имени этого слоя.

Таблица 17.1. Выделение элементов текста

Действие | Способ выполнения
Выделение части строки | Нажмите кнопку мыши и перетащите курсор. Или щелкните по началу фрагмента строки, затем, нажав клавишу Shift, щелкните по его концу
Выделение слова | Дважды щелкните по нему
Выделение строки | Трижды щелкните
Выделение абзаца | Щелкните четыре раза
Выделение всего текста | Нажав клавиши Ctrl+A, щелкните четыре раза в тексте либо дважды по его миниатюре на палитре Layers (Слои)

Выделение всех или нескольких символов в текстовом слое

Выберите инструмент Туре (Текст), например, нажав клавишу Т, щелкните мышью в тексте и перетащите курсор таким образом, чтобы выделить один или несколько символов. Или дважды щелкните по слову, которое надо выделить; тройным щелчком мыши выделяется целая строка. Если был активным другой инструмент, то дважды щелкните по значку в виде буквы Т текстового слоя на палитре Layers (Слои). В результате будет выделен весь текст и активизирован инструмент Туре (Текст).

Выделение текста с помощью инструмента Туре

В табл. 17.1 перечислены действия, необходимые для выделения всего текста или какого-то его элемента.

Масштабирование текста

Пользуйтесь командами Horizontal Scale (Масштаб по горизонтали) и Vertical Scale (Масштаб по вертикали) только в том случае, если желаете исказить буквы (удлинить или укоротить их). Для равномерного масштабирования литер воспользуйтесь инструкциями, приведенными ниже, либо выделите необходимые символы и поменяйте кегль в палитре Character (Шрифт).

Масштабирование выбранных символов

  1. В палитре Layers (Слои) выберите слой, содержащий текст.
  2. Откройте палитру Character (Шрифт). Это можно сделать, выбрав соответствующую команду в меню Window (Окно), либо активизировав инструмент Туре (Текст) (клавиша Т) и щелкнув по кнопке Palettes (Палитры) на панели опций.
  3. По желанию. С помощью инструмента Туре выделите те символы, которые следует масштабировать. Иначе будут искажены все символы в слое.
  4. Измените значения масштаба в полях Horizontal Scale (Масштаб по горизонтали) и/или Vertical Scale (Масштаб по вертикали) в палитре Character (Шрифт) -рис. 17.15, 17.16. Если текст не выделен и, кроме того, желаемое значение в одном из полей было введено вручную, а не выбрано из всплывающего меню, то для выполнения масштабирования следует нажать клавишу Enter.

Рис. 17.15. Поля для ввода масштаба

Рис. 17.16. Изменение вида текста в результате изменения масштаба

Масштабирование всего текста на слое

  1. Активизируйте инструмент Move (Перемещение).
  2. Установите флажок Show Bounding Box (Показать габаритную рамку) на панели опций инструмента.
  3. Выделите имя слоя в палитре Layers (Слои).
  4. Перетащите габаритную рамку за ее угол, чтобы одновременно поменять масштаб по вертикали и по горизонтали, а если надо изменить только одну из величин, перетаскивайте боковой манипулятор рамки. Подождите, пока программа закончит перерисовку текста. Для сохранения пропорций текста проделайте то же самое при нажатой клавише Shift.
  5. Для фиксации проведенных изменений следует на панели опций щелкнуть по кнопке Щ либо дважды - по текстовому блоку. Габаритная рамка все еще будет видна. Чтобы не сохранять изменений, щелкните по кнопке Щ на панели опций либо нажмите клавишу Esc.

Рис. 17.17. Палитра Character

Установка межсимвольного расстояния для пары символов

  1. На палитре Layers (Слои) выберите текстовый слой.
  2. Щелкните по пиктограмме Character на панели опций, чтобы открыть палитру Character (Шрифт), если она еще не открыта (рис. 17.17).
  3. Выберите пункт Metrics (Метрика) во всплывающем меню Kerning (Kepнинг) для изменения межсимвольного расстояния, установленного по умолчанию (в других приложениях это называется Auto Kern (Автокернинг)). Это необходимо сделать перед тем, как вручную подгонять расстояние между парой символов.
  4. Активизируйте инструмент Туре (клавиша Т) и щелкните между двух букв в тексте.
  5. Выберите подходящую величину из всплывающего меню Kerning (Кернинг) либо введите свое собственное значение. Ведите отрицательное число, чтобы сблизить символы (-100 на рис. 17.18), и положительное - чтобы увеличить зазор между ними. Изменить расстояние между символами можно также, нажав клавишу Alt и клавишу со стрелкой, направленной вправо или влево.

Рис. 17.18. Результат ввода отрицательного значения керна

Установка межсимвольного расстояния для всей строки текста

  1. В палитре Layers (Слои) выберите текстовый слой.
  2. По желанию. С помощью инструмента Туре выделите тот фрагмент текста, который следует изменить. Иначе тре-кинг будет применен ко всему тексту.
  3. Щелкните по кнопке Palettes (Палитры), чтобы открыть палитру Character (Шрифт), если она еще не открыта.
  4. Выберите .одно из значений трекинга во всплывающем меню Tracking (Tpe-кинг) либо введите любое свое значение (рис. 17.19). Воспользуйтесь отрицательным значением, чтобы сблизить символы, и положительным - чтобы увеличить зазор между ними.

Нажав клавишу Alt при активном инструменте Move (Перемещение) и нажимая клавиши со стрелками «вправо»/«влево», можно скопировать весь текстовый блок.

Для того чтобы текст в сети был читабельным, не следует размещать символы слишком близко друг к другу.

Установка межстрочного расстояния для горизонтального текста

Межстрочное расстояние (интерлиньяж) -это расстояние между текущей строчкой текста и строчкой, расположенной над ней. У каждого символа может быть свое собственное межстрочное расстояние; наибольшее значение будет определять межстрочное расстояние для данной строки.

Рис. 17.19. Увеличенное межзнаковое расстояние в заголовке

Рис. 17.20. Выбор межстрочного интервала

Рис. 17.21. Абзацы с одинаковым кеглем, но разными межстрочными интервалами

Межстрочный интервал по умолчанию рассчитывается пропорционально кеглю. Их отношение указывается в диалоговом окне Justification (Выравнивание), которое открывается с помощью меню палитры Paragraph (Абзац). По умолчанию величина интервала составляет 120% от кегля. Например, межстрочное расстояние для кегля в 30 точек по умолчанию равно 36.

Для установки межсимвольного расстояния в тексте, который расположен по вертикали, выделите нужные символы и измените значение трекинга в палитре Character (Шрифт). Вы увидите, что текст после этого преобразится.

Поэтому, если установить разные значения межстрочного расстояния для строк абзаца и потом редактировать текст, изменяя его распределение по строкам, межстрочное расстояние может поменяться.

Нельзя с уверенностью сказать, что создаваемый вами текст будет примечательным во всех отношениях, но использование оптимальных расстояний между строчками существенно облегчит его чтение, даже если он займет много места на странице. Не утомляйте читателя прежде, чем он прочитает все ваши умные мысли.

Сказанное выше о форматировании текста относится только к программе Photoshop. Если вы используете другие приложения, возможно, порядок действий при выборе шрифта будет иным. При создании текстов для сети Internet лучше обратиться к программе, предназначенной для Web-дизайна.

  1. В палитре Layers (Слои) выберите нужный слой.
  2. По желанию. Выделите одну или несколько строк, в которых будете менять межстрочный интервал. Если текст был введен в построчном режиме, то необходимо выделить всю строку. Если не выделять строки, то изменения произойдут во всем тексте.
  3. Выберите или введите значение межстрочного интервала в палитре Character (Шрифт) - см. рис. 17.20, 17.21.

Смещение выделенных символов относительно базовой линии

  1. На палитре Layers (Слои) выберите нужный слой.
  2. По желанию. С помощью инструмента Туре (Текст) выделите те символы, которые следует сместить. Иначе изменят положение все символы слоя.
  3. Откройте палитру Character (Шрифт).
  4. Введите значение в поле смещения относительно базовой линии (рис. 17.22) -положительное, если хотите, чтобы буквы были расположены выше базовой линии; и отрицательное - в противном случае (рис. 17.23). Если вы не выполняли шаг 2, нажмите клавишу Enter.

Меню палитры Character

  1. Выберите текст, который необходимо изменить, или слой текста, чтобы изменить его целиком.
  2. В меню палитры Character (Шрифт) включите одну из следующих опций (рис. 17.24):
    • Faux Bold (Псевдожирный) преобразует обычный шрифт в полужирный;
    • Faux Italic (Псевдокурсив) преобразует обычный шрифт в курсив. Эти операции недоступны для изогнутого текста;
    • All Caps (Все прописные) и Small Caps (Строчные) изменяют текст соответственно своим названиям. Опция Small Caps не работает, если текст изначально был набран в верхнем регистре;

Рис. 17.22. Поле смещения относительно базовой линии

Рис. 17.23. Положение текста при вводе положительного, нулевого и отрицательного значения смещения относительно базовой линии

Рис. 17.24. Меню палитры Character

    • Superscript (Верхний индекс) и Subscript (Нижний индекс) уменьшают кегль и соответственно поднимают или опускают текст относительно базовой линии;
    • Underline (Подчеркнуть) и/или Strikethrough (Перечеркнуть);
    • Fractional Width (Дробная ширина) - используются доли точек для установки оптимального интервала между словами, причем эта функция применяется ко всему слою. Если отключить данную опцию, будет проще читать текст в приложениях, работающих в режиме реального времени и использующих небольшой кегль.
    • No Break (He разбивать) предписывает программе располагать выбранные литеры на одной строке, если это возможно;

Шрифт-заменитель

Если текст набран таким шрифтом, для которого не установлен соответствующий полужирный вариант или курсив, и включена опция Faux Bold (Псевдожирный) или Faux Italic (Псевдокурсив), то программа Photoshop применяет так называемый полужирный или курсивный шрифт-заменитель. Любители точности и четкости (мы в том числе) заметят, что форма или наклон подобного полужирного стиля не совсем точно соответствуют настоящему шрифту.

Изменение расположения текста

С помощью команды меню Layer > Туре > Vertical (Слой > Текст > Вертикально) или Horizontal (Горизонтально) можно изменить расположение текста на вертикальное или горизонтальное.

  1. В палитре Layers (Слои) выберите нужный слой (рис. 17.25).
  2. Выполните команду меню Layer > Туре > Horizontal (Слой > Текст > Горизонтально). Возможно, вам придется переместить текст после применения данной команды. Результат показан на рис. 17.26.

Для вращения вертикального текста дважды щелкните по миниатюре слоя, выделите нужные символы, а затем установите или снимите флажок опции Rotate (Вращение) в меню палитры Character (Шрифт) -см. рис. 17.27. Однако эта команда не до ступна для горизонтального текста.

Рис. 17.25. Исходный вертикальный текст

Рис. 17.26. Вертикальный текст после выполнения команды Horizontal

Рис 17.27. Исходный вертикальный текст (рис. 17.25) после применения команды Rotate

Рис. 17.28. Кнопки выключки в верхней части палитры Paragraph

a)

б)

в)

Рис. 17.29. Способы выравнивания абзаца при помощи кнопок первой группы

Использование атрибутов абзаца

При создании текстового блока (в противоположность построчному вводу текста) nporpaммa Photoshop предлагает вам множество средств для его форматирования. Когда вы отказываетесь от непосредственного управления форматированием, как при построчном вводе, то в обмен получаете довольно сложный автоматический инструмент.

В палитру Paragraph (Абзац) включены разнообразные параметры, такие как выключка, отступ и отбивка, которые можно настраивать по своему усмотрению.

Выключка

  1. В палитре Layers (Слои) щелкните по тому текстовому слою, который хотите изменить.
  2. Если же необходимо изменить весь текст в слое, то не выделяйте его. Чтобы модифицировать один или несколько абзацев, активизируйте инструмент Туре (Текст).
  3. Если палитра Paragraph (Абзац) еще не открыта, то щелкните по кнопке jQj на панели опций и выберите вкладку Paragraph (Абзац).
  4. Щелкните по одной из кнопок выключки в верхней части палитры (рис. 17.28):
    • кнопки первой группы: Left align text (По левому краю), Center text (По центру) и Right align text (По правому краю) отвечают за выравнивание текста относительно одной из границ габаритной рамки (рис. 17.29).
    • вторая группа кнопок: Justify last left (Последняя строчка по левому краю), Justify last centered (Последняя строчка по центру) и Justify last right (Последняя строчка по правому краю) отвечает за выравнивание только последней строки абзаца; при этом остальные строки заполняют пространство от одной до другой границы габаритной рамки целиком (рис. 17.30).

    Щелчок по последней кнопке Justify all (По ширине) выравнивает весь абзац, включая последнюю строчку, относительно габаритной рамки.

  5. Установите флажок Hyphenate (Расстановка переносов) в нижней части палитры, чтобы включить функцию автоматического переноса слов. В тех случаях, когда применяются кнопки второй группы или весь текст выровнен по ширине, это помогает устранить большие пробелы между словами.

Настройка отступов и отбивок между абзацами

Изменение величины отступа и отбивки позволяет сделать текст более удобным для чтения.

  1. На палитре Layers (Слои) выберите нужный слой.
  2. Если хотите изменить весь текст в слое, не выделяйте его. Для модификации одного или нескольких абзацев активизируйте инструмент Туре (Текст), которому соответствует пиктограмма *f*j,и щелкните мышью внутри абзаца или выделите несколько последовательных абзацев.

Рис. 17.30. Способы выравнивания абзаца при помощи кнопок второй группы

Рис. 17.31. Поля для ввода значений отступа и отбивки

Рис. 17.32. Абзац без отступов

Рис. 17.33. Отступ слева и справа в два цицеро

Рис. 17.34. Отступ в виде красной строки

Рис. 17.35. Добавление отбивки перед абзацем

  3. Если палитра Paragraph (Абзац) еще не открыта, щелкните по кнопке Qi на панели опций и выберите вкладку Paragraph (Абзац)-рис. 17.31.
  4. Измените значения в полях Indent left margin (Отступ слева), Indent right margin (Отступ справа), как показано на рис. 17.32-17.33, или Indent first line (Отступ красной строки) - см. рис. 17.34. Для того чтобы текст было удобнее читать, вводите значение в поле Indent first line (Отступ красной строки) в том случае, если нет возможности добавить так называемую отбивку между абзацами. Но не применяйте одновременно опцию Indent first line и отбивку между абзацами, это выглядит непрофессионально. Сочетание отступа справа и слева поможет выделить некоторый фрагмент текста, например цитату или маркированный список. Для визуального разделения абзацев введите значения в поля Add space before paragraph (Добавить интервал перед абзацем) и/или Add space after paragraph (Добавить интервал после абзаца) - см. рис. 17.35.

При активизированном инструменте Туре (Текст) на экране показывается габаритная рамка абзаца, форму которой можно изменять. Нажав клавишу Ctrl, перетащите один из манипуляторов габаритной рамки, чтобы изменить ее форму и расположение строк текста внутри нее.

Единицы измерения

Если вы вводите значения параметров, отличные от установленных по умолчанию, указывайте для них единицы измерения. Дюйм обозначается сокращением in, сантиметр - cm, пиксел - рх и цицеро - pica. Введенная вами величина автоматически будет преобразована с учетом установленных по умолчанию единиц измерения. Кстати, вы можете сами установить удобные вам единицы, для этого в меню Edit (Правка) воспользуйтесь командой Preferences (Установки). Затем выберите окно Units&Rulers (Единицы измерения и линейки) и в поле Туре (Текст) раздела Units (Единицы измерения) укажите соответствующие единицы измерения.

Настройка параметров абзаца

Ниже описаны некоторые параметры, которые отличают любительски оформленный текст от текста, обработанного профессионально.

В меню палитры Paragraph (Абзац), кнопка вызова которого расположена в верхнем правом углу палитры, можно выбрать следующие команды:

  • Roman_Hanging Punctuation (Подве-щивание знаков пунктуации) - программа Photoshop перемещает (подвешивает) знаки пунктуации, не помещающиеся в конце строки, за пределы габаритной рамки;
  • Justification (Выравнивание) и Hyphenation (Расстановка переносов) - определяет границы, в пределах которых действует выравнивание текста, чтобы он лучше выглядел (рис. 17.36, 17.37). В диалоговом окне Justification (Выравнивание) выберите соответствующие значения параметров в группах:

Рис. 17.36. Диалоговое окно Justification

Рис. 17.37. Диалоговое окно Hyphenation

Рис. 17.38. Результат применения команды Adobe Single-line Composer

Рис. 17.39. Результат применения команды Adobe Every-line Composer

Maximum (Максимальный), Desired (Желательный) и Minimum (Минимальный) для выравнивания ширины строки. В этом окне можно также указать межстрочное расстояние в процентах от кегля;

В диалоговом окне Justification введите в поле Glyph Scaling (Масштаб символа) величину, превышающую 100% (установлено по умолчанию), тогда программа будет подбирать ширину символов в строке так, чтобы текст оптимально распределялся внутри габаритной рамки.

  • Adobe Single-line Composer (Построчное размещение) и Adobe Every-line Composer (Размещение всех строк) определяют возможную расстановку переносов в абзаце и расстояния между словами и символами для минимизации числа переносов (рис. 17.38,17.39). Команда Adobe Single-line Composer осуществляет эти действия для каждой строки отдельно, рассматривая строчку за строчкой, расставляя переносы и устанавливая пробелы между словами, а команда Adobe Every-line Composer - для всего абзаца в целом, причем может изменить число переносив в начале абзаца так, что в конце они станут выглядеть более привлекательно.
  • команда Reset Paragraph (Восстановить параметры абзаца) восстанавливает значения параметров абзаца, установленные по умолчанию.

Специальные эффекты для текста

Во-первых, запомните несколько ограничений. Вы можете перемещать, изменять масштаб, вращать и наклонять габаритную рамку в редактируемом текстовом слое, но чтобы исказить текст или применить команду для изменения перспективы, необходимо преобразовать текстовый слой в растровый формат. Во-вторых, нельзя трансформировать выделенный фрагмент текста. Команды трансформации, о которых сначала пойдет речь, изменяют форму текста и габаритной рамки.

С помощью инструмента Move (Перемещение), который активизируется клавишей V, можно трансформировать и текст, введенный построчно, и текстовые блоки. Установите флажок Show Bounding Box (Показать габаритную рамку) на панели опций и выделите текстовый слой на палитре Layers (Слои). На экране будет отображена габаритная рамка для текста. Перетащите один из манипуляторов, чтобы изменить расположение текста, при этом используйте те же приемы, что и в случае команды Free Transform (Произвольная трансформация), как написано в главе 7, раздел «Производная трансформация слоя».

И наконец, текст, введенный построчно, и текстовый блок могут быть изменены следующим образом:

  • выделите текстовой слой в палитре Layers (Слои), а в меню Edit (Правка) выполните команду Free Transform (Произвольная трансформация);

Рис. 17.40. Исходный текст

Рис. 17.41. Изменение формы литер в результате масштабирования

Рис. 17.42. Изменение формы литер в результате перекоса габаритной рамки

Рис. 17.43. Вращение текста без изменения формы символов

  • перетаскивайте манипуляторы .габаритной рамки, чтобы изменить форму текста. Это можно сделать при любом активном инструменте, за исключением Реn (Перо), а также инструментов для построения фигур и выделения контура.

Трансформация габаритной рамки и текста внутри нее

Воспользуйтесь сведениями, изложенными в главе 7, раздел «Произвольная трансформация слоя» или выполните следующие действия:

  1. В палитре Layers (Слои) выделите нужный слой, содержащий текстовый блок.
  2. Выберите инструмент Туре (Текст), нажав клавишу Т.
  3. Щелкните по тексту в окне изображения.
  4. Нажмите клавишу Ctrl и используйте «горячие» клавиши команды Free Transform (Произвольная трансформация). Результаты показаны на рис. 17.40-17.43.

Трансформация габаритной рамки без изменения текста внутри нее

Для изменения формы габаритной рамки без изменения формы литер воспользуйтесь инструкциями, приведенными ниже.

  1. В палитре Layers (Слои) выделите тот слой, который необходимо модифицировать.
  2. Выберите инструмент Туре (Текст).
  3. Щелкните по тексту в окне изображения.
  4. Наведите указатель на манипулятор габаритной рамки и перетащите его, чтобы изменить масштаб этой рамки и переформатировать текст (рис. 17.44). При этом не изменится ни формагнигразмер букв.

    Но, можно сделать и по-другому. Поместите указатель снаружи рядом с одним из углов рамки (указатель примет вид изогнутой двусторонней стрелки), а потом, нажав кнопку мыши, можете вращать эту рамку. Наконец, нажав клавишу Ctrl, перетащите габаритную рамку (указатель должен быть внутри нее), чтобы переместить весь текстовый блок.

  5. Чтобы зафиксировать изменения, нажмите клавишу Enter на цифровой клавиатуре или щелкните по кнопке на панели опций (чтобы отменить изменения, нажмите клавишу Esc или щелкните по кнопке, на панели опций).

Деформация текста на редактируемом слое

В программе Photoshop 7 есть определенный набор функций вида Warp Text (Деформировать текст), которые позволяют изгибать габаритную рамку и текст внутри нее. Деформированный текст остается при этом редактируемым.

  1. В палитре Layers (Слои) выделите текст, который следует деформировать.
  2. Для того чтобы открыть диалоговое окно Warp Text (Деформировать текст) (рис. 17.45), выполните команду Layer > Type > Warp Text (Слои > Текст > Деформировать текст) или активизируйте инструмент Туре (Текст) нажав клавишу Т и щелкните по кнопке Warp Text на панели опций.

Рис. 17.44. Изменение формы габаритной рамки без изменения формы и размера литер

Рис. 17.45. Диалоговое окно Warp Text

Рис. 17.46. Стили команды Warp Text

Риc.17.47. Миниатюра текстового слоя после вменения команды Warp Text

  3. Во всплывающем меню Style (Стиль) выберите стиль текста.
  4. Поставьте переключатель в положение Vertical (По вертикали) или Horizontal (По горизонтали), чтобы задать основное направление для операции деформирования текста.
  5. Передвиньте ползунки Bend (Изгиб), Horizontal Distortion (Горизонтальное искажение) и/или Vertical Distortion (Вертикальное искажение).
  6. Щелкните по кнопке ОК. Миниатюра слоя изменится, обозначая таким образом, что к тексту была применена операция деформации (рис. 17.46 и 17.47).

Если вы хотите изменить масштаб или форму деформированного текста так, чтобы он уместился в определенную область, выберите слой деформированного текста и с помощью инструмента Move (Перемещение) - проверьте, чтобы был установлен флажок Show Bounding Box (Показать габаритную рамку) - измените форму габаритной рамки.

Перемещение текстового слоя

Первый способ:

  1. Выберите инструмент Move (Перемещение), нажав клавишу V.
  2. Щелкните правой кнопкой мыши по тексту в окне изображения и выберите из контекстного меню имя слоя. Можно также выбрать имя того слоя, который необходимо переместить, в палитре Layers (Слои).
  3. Перетащите текст в окне изображения или нажмите клавишу со стрелкой.

Второй способ:

  1. Дважды щелкните по миниатюре текстового слоя (в виде буквы Т),
  2. Нажав клавишу Ctrl, перетащите текст в окне изображения.

Отсутствующие шрифты

Если при открытии файла, содержащего редактируемый текст, необходимо изменить его, а нужный шрифт отсутствует (недоступен или не установлен), то появится предупреждающее диалоговое окно (рис. 17.48).

Если щелкнуть по кнопке ОК, то программа автоматически создаст шрифт-заменитель. При этом на миниатюре слоя в палитре Layers (Слои) появится треугольный значок с восклицательным знаком внутри (рис. 17.49).

Преобразование текста в растровый формат

Чтобы обрабатывать текст при помощи фильтров или инструментов, таких как Brush (Кисть), Blur (Размытие), Eraser (Ластик), Smudge (Палец), либо команды Distort (Исказить) или команды Perspective (Перспектива) из подменю Transform, сначала необходимо преобразовать текст в растровый формат. Но надо помнить о том, что как только вы преобразовали текст в растровый формат, его типографские атрибуты уже изменить нельзя, хотя он и остается в своем слое.

  1. В палитре Layers (Слои) выберите нужный слой. Если необходимо сохранить исходный редактируемый слой для дальнейшего использования, то создайте его дубликат и работайте с ним.
  2. Выполните команду меню Layer > Rasterize > Туре (Слой > Преобразовать в растровый формат > Текст). При этом можно изменять текст, преобразованный в растр, неограниченным числом способов - дайте волю своей фантазии (рис. 17.50-17.51). Мы вам предлагаем один из вариантов. В палитре Layers (Слои) установите флажок Lock transparent pixels (Зафиксировать прозрачные пикселы), заполните растеризованный текст каким-либо узором, примените к нему фильтр, снимите флажок Lock transparent pixels, а затем с помощью инструмента Smudge (Палец) размажьте края текста.

Рис. 17.48. Диалоговое окно, предупреждающее об отсутствующем шрифте

Рис. 17.49. Предупреждение об отсутствии шрифта на палитре Layers

Рис. 17.50. Текст, заполненный узором в режиме Difference (слева), после применения фильтра Fresco (справа)

Рис. 17.51. Текст, заполненный узором c использованием градиента (слева), после применения фильтра Palette Knife (справа)

Для того чтобы раскрасить растеризованный текст, выберите инструмент Brush (Кисть) и цвет. Установите флажок Lock transparent pixels (Зафиксировать прозрачные пикселы) и сделайте несколько мазков кистью на рисунке. Чтобы нарисовать что-нибудь за текстом, сделайте это на слое, лежащем ниже текстового (рис._17.52-17.53).

Если был применен эффект Color Overlay (Наложение цвета), Gradient Overlay (Наложение градиента) или Pattern Overlay (Наложение узора), то выбирайте режим смешивания, который позволит цветовым мазкам просвечивать сквозь текст.

Рис. 17.52. Расположение слоев изображения

Рис. 17.53. Результат раскрашивания растеризованного текста и слоя под ним

Рис. 17.54. Результат применения команды Levels к корректирующему слою над фоновым рисунком (значения параметра Input Levels равны 0; 0,95 и 255, а значения параметра Output Levels - 92 и 255)

Рис. 17.55. Результат заполнения корректирующего слоя градиентом от-черного-к-белому (с верхнего правого угла к нижнему левому) для того, чтобы замаскировать действие эффекта Levels в верхнем правом углу

Отображение рисунка за слоем текста

  1. Выберите изображение для фона в палитре Layers (Слои). Следуя приведенным ниже инструкциям, можно осветлить фоновое изображение под слоем эффекта Drop Shadow (Отбросить тень).
  2. Выполните команду Layer > New Adjustment Layer > Levels (Слой > Coздать корректирующий сдой > Уровни), а затем щелкните по кнопке ОК.

    Можно выбрать пункт Levels (Уровни) из всплывающего меню, вызываемого нажатием кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной в нижней части палитры Layers (Слои):

  3. Установите флажок Preview (Предварительный просмотр).
  4. Передвиньте серый ползунок Input (Ввод) немного влево, а черный ползунок Output (Вывод) - немного вправо.
  5. Щелкните по кнопке ОК (рис. 17.54 и 17.55).

Для дальнейшей корректировки уровней попробуйте различные режимы смешивания, например Screen (Экран) или Overlay (Перекрытие), либо различные уровни непрозрачности для корректирующего слоя Levels.

Для того чтобы корректирующий слой затрагивал только слой, лежащий непосредственно под ним, нажав клавишу Alt, щелкните по линии между двумя слоями на палитре Layers (Слои).

«Растеризация» без преобразования в растровый формат

Для того чтобы текстовый слой выглядел раскрашенным без растеризации, сделайте его базовым в группе отсечения (см. главу 14, раздел «Группы отсечений»), а затем нанесите мазки на слой, расположенный непосредственно над текстовым. Преимущество данного метода заключается в том, что можно перерисовывать мазки или перемещать их, не оказывая при этом влияния на текстовый слой.

Отображение текста позади слоя с рисунком

  1. Создайте текстовый слой.
  2. Создайте дубликат текстового слоя, перетащив его на кнопку Create new layer (Создать новый слой), расположенную в нижней части палитры Layers (Слои). Скройте исходный текстовый слой (сохраните для будущего редактирования).
  3. Выделите дубликат слоя, а затем выполните команду Layer > Type > Convert to Shape (Слой > Текст > Преобразовать в фигуру). Текстовый слой будет преобразован в слой типа shape с контуром отсечения. Исходный текст будет сохранен, но изменить его типографские атрибуты будет уже нельзя.
  4. Воспользуйтесь командой меню Layer > Change Layer Content > Levels (Слои > Изменить содержимое слоя > Уровни) -см. рис. 17.56. Эффект отсечения не будет виден до тех пор, пока вы не измените слой-дубликат.

Рис. 17.56. Контур отсечения и корректирующий слой

Рис. 17.57. Текст, отображенный позади рисунка

Рис. 17.58. Рисунок, расположенный за текстом

  5. Передвиньте серый ползунок средних тонов Input (Ввод) влево к светлым полутонам, затем дождитесь изменений на экране. Можно переместить и ползунок Input светлых тонов. Кроме того, передвиньте ползунок Output (Вывод) темных тонов вправо, чтобы уменьшить контрастность текста.
  6. Нажмите кнопку ОК (рис. 17.57). Щелкните по слою, содержащему фоновое изображение.

Измените режим смешивания для корректирующего или базового слоя, чтобы восстановить в определенной степени фоновый цвет (попробуйте режимы Overlay (Перекрытие), Color burn (Форсирование цвета), Hard light (Жесткий свет)). Уменьшите уровень непрозрачности слоя для ослабления эффекта Levels.

Если хотите отобразить рисунок позади текста, повторяйте шаги 1-4. При выполнении шага 5 измените положение ползунков, чтобы затемнить текст. Отмените все изменения непрозрачности или режима смешивания, а затем используйте корректирующий слой для осветления рисунка под текстовым слоем (рис. 17.58).

Заполнение текста изображением с помощью команды Paste Into

  1. Создайте текстовый слой. Впоследствии его можно будет редактировать, преобразовывать в слой фигур или в растровый формат.
  2. Активизируйте слой в том же файле или в другом, содержащем нужное изображение.
  3. Воспользуйтесь командой меню Selection > All (Выделить > Все) или создайте выделение с помощью мыши.
  4. В меню Edit (Правка) выполните команду Сору (Копировать), которой соответствуют сочетания клавиш Ctrl+C.
  5. Выделите изображение, содержащее текстовый слой, а затем, нажав клавишу Ctrl, щелкните по имени этого слоя.
  6. В меню Edit (Правка) выполните команду Paste Into (Вставить в) или нажмите комбинацию клавиш Ctrl+Shift+V (рис. 17.59-17.60). Автоматически будет создан слой, содержащий маску слоя, и изображение станет видимым сквозь маску, форму которой задает текст.

Рис. 17.59. Текст, заполненный изображением с помощью команды Paste Into

Рис. 17.60. Второй слой - исходный. Самый верхний слой был создан после вставки изображения в выделенный текст

  7. По желанию. Выделив миниатюру нового слоя на палитре Layers (Слои), воспользуйтесь инструментом Move (Перемещение), который активизируется при помощи клавиши V, а затем переместите вставленное изображение в пределах текста. Теперь щелкните между миниатюрой слоя и миниатюрой маски слоя, чтобы связать маску с изображением. Пока существует эта связь, нельзя переместить изображение внутри маски. (С помощью инструмента Move можно будет перетащить маску и находящееся внутри нее изображение одновременно, и, таким образом, станет виден слой, находящийся под текстовым.)

Чтобы перемещать текстовый слой и слой с изображением одновременно, свяжите маску слоя с самим слоем, а затем свяжите слой со вставленным в текст изображением со слоем текста.

О том, как заполнить текст изображением при помощи маски слоя, сказано в главе 14, раздел «Заливка текста изображением с помощью маски слоя»; а об использовании контура отсечения слоев - в главе 16, раздел «Преобразование маски слоя в контур отсечения».

Заполнение текста изображением с помощью группы отсечения

  1. Создайте текст с помощью инструментов Туре (Текст) или Vertical Type (Вертикальный текст). В дальнейшем его можно редактировать, преобразовывать в фигуру или растровый формат.
  2. Переместите текстовый слой в палитре Layers (Слои) непосредственно под слой/слои, содержимое которых будет заполнять этот слой (рис. 17.61, 17.62).
  3. Нажав клавишу Alt, щелкните по линии между именем текстового слоя и слоем, расположенным непосредственно над ним. Левый край миниатюры слоя, лежащего над текстовым, будет сдвинут и помечен стрелкой, направленной вниз, а имя базового (нижнего) слоя группы отсечения будет подчеркнуто (рис. 17.63). При этом окажутся видны только те точки, которые закрывают текст (рис. 17.64).
  4. По желанию. Выделив текстовый слой, с помощью инструмента Move (Перемещение) можно переместить символы в окне изображения.
  5. По желанию. Нажав клавишу Alt, щелкните по линиям между другими слоями, расположенным выше данной группы отсечения, чтобы добавить их к группе.
  6. По желанию. Можно изменить режим или значение непрозрачности для любого слоя в группе отсечения. По умолчанию режим смешивания для базового слоя (его имя подчеркнуто) определяет то, как группа отсечения комбинируется со слоями, лежащими ниже и не входящими в эту группу. Дважды щелкните по имени базового слоя. Затем в окне Layer Style (Стиль слоя) вызовите раздел Blending Options (Опции наложения) и в области Advanced Blending (Дополнительные параметры смешивания) снимите флажок Blend Clipped Layers as Group (Смешивать слои отсечения как группу) для того, чтобы на базовый слой не влияло смешивание слоев, входящих и не входящих в группу.

Рис. 17.61.Отдельные слои до их присоединения к группе отсечения

Рис. 17.62. Взаимное расположение отдельных слоев

Рис. 17.63. Палитра Layers после создания группы отсечения

Рис. 17.64. Текст, заполненный изображением с использованием группы отсечения

Чтобы убрать слой из группы отсечения, снова нажмите клавишу Alt и щелкните по линии, разделяющей этот и базовый слои.

Создание исчезающего текста

  1. Создайте текст и оставьте его слой активным. Текст можно редактировать и преобразовывать в растровый формат.
  2. В нижней части палитры Layers (Слои) щелкните по кнопке Add a mask (Добавить маску). Рядом с именем слоя появится миниатюра маски (рис. 17.65).
  3. Выберите инструмент Gradient (Градиент), нажав клавишу G или комбинацию клавиш Shift+G.
  4. На панели опций щелкните по кнопке с треугольной стрелочкой в поле Gradient и выберите граничные цвета. Щелкните по кнопке Linear gradient (Линейный градиент), выберите режим Normal (Нормальный) и введите значение непрозрачности равное 100%.
  5. Удерживая кнопку мыши, перетащите курсор сверху вниз или справа налево в окне изображения, по крайне мере, через половину текста. Маска текстового слоя заполнится градиентом от-белого-к-черному. Текст будет спрятан в тех местах, где на маске присутствует черный цвет (рис. 17.66).

Щелкните по миниатюре или имени текстового слоя на палитре Layers (Слои) для того, чтобы модифицировать слой; затем выделите миниатюру маски слоя для того, чтобы изменить эту маску (подробнее о масках слоя рассказано в главе 14).

Рис. 17.65. Текстовый слой с маской

Рис. 17.66. Исчезающий текст

Рис. 17.67. Эффекты текстового слоя

Рис. 17.68. Результат применения эффектов к слою

Для того чтобы переместить текст вместе с эффектом, выделите текстовый слой, активизируйте инструмент Move (Перемещение) и перетащите текст в окне изображения.

Если хотите изменить эффект слоя, щелкните по имени слоя - появится диалоговое окно Layer Style

Применение эффектов слоя к полупрозрачному тексту

Эффекты слоя могут быть применены только к слоям, допускающим редактирование (подробнее об эффектах слоя рассказано в главе 14, раздел «Эффекты слоя»).

  1. Создайте текст на редактируемом текстовом слое.
  2. Дважды щелкните по имени текстового слоя.
  3. В окне Layer Style (Стиль слоя) выберите один или несколько эффектов с левой стороны диалогового окна (например, Drop Shadow (Отбросить тень), Inner Shadow (Внутренняя тень), Inner Glow (Внутреннее свечение), Bevel&Emboss (Скос и рельеф)) и выберите параметры для каждого эффекта (рис. 17.67, 17.68).

    Примените эффект Satin (Атлас) для того, чтобы затемнить содержимое текстового слоя. Эффекты Color Overlay (Наложение цвета) или Gradient Overlay (Наложение градиента) позволяют получить эффект тонирования; a Pattern Overlay (Наложение узора) имитирует заполнение текста узором.

  4. Щелкните по полю Blending Options (Опции смешивания) в диалоговом окне Layer Style (Стиль слоя). В разделе Advanced Blending (Дополнительные параметры смешивания) перетащите ползунок Fill Opacity (Непрозрачность заливки) на отметку 0%. Если необходимо, измените параметры эффектов слоя.
  5. Нажмите кнопку ОК.

Обводка текстового слоя

  1. В выпадающем меню выберите Blending Options (Опции смешивания) палитры Layers (Слои).
  2. Щелкните по надписи Stroke (Обводка), расположенной с левой стороны диалогового окна Layer Style (Стиль слоя), и проверьте, установлен ли флажок Preview (Предварительный просмотр).
  3. Выберите в разделе Structure (Структура) значения параметров Size (Размер), Position (Положение) (это может быть Outside (Снаружи), Inside (Внутри) или Center (По центру)), Blend Mode (Режим смешивания), Opacity (Непрозрачность), Fill Type (Тип заливки) и Color (Цвет)-см. рис. 17.69 и 17.70.
  4. Щелкните по кнопке ОК (либо нажмите клавишу Enter).

Рис. 17.69. Применение эффекта Stroke к редактируемому или растеризованному тексту при помощи диалогового окна Layer Style

Рис. 17.70. Результат применения к редактируемому тексту эффекта Stroke с типом заливки Gradient

Рис. 17.71. Выделение в форме текста

Рис. 17.72. Палитра Channels

Создание выделения в форме символов

Программа Photoshop позволяет создавать выделение в форме символов текста. Это может понадобиться в нескольких случаях: чтобы скопировать рисунок в форме символов; замаскировать (ограничить) эффект корректирующего слоя, примененный к тексту; или чтобы добавить к изображению маску слоя, имеющую форму литер (команды Reveal Selection (Отобразить выделение) и Hide Selection (Спрятать выделение)).

  1. Выделите слой, на котором необходимо создать выделение в форме символов (необязательно текстовый слой).
  2. Активизируйте инструмент Type Mask Tool (Текстовая маска), нажав клавишу Т или Shift+T.
  3. Щелкните в том месте окна изображения, где должно быть выделение. Через некоторое время появится Quick Mask (Быстрая маска).
  4. Создайте и отредактируйте текст, чтобы зафиксировать изменения (рис. 17.71).

Сохраните выделенный текст в новом канале. Для этого щелкните по кнопке jgy Save selection as channel (Сохранить выделенную область как канал) в нижней части палитры Channels (Каналы) - см. рис. 17.72. Теперь текст можно увидеть на палитре Channels и в любой момент поместить на любой слой или маску слоя.

Перемещение выделения в форме символов

  1. Выберите инструмент Rectangular Marquee (Прямоугольная область), нажав клавишу М (не инструмент Move).
  2. На панели опций щелкните по кнопке New Selection (Создать новое выделение).
  3. Нажав кнопку мыши внутри выделенной области, перетаскивайте курсор в окне изображения. Второй способ: нажмите клавишу со стрелкой. Удерживая нажатой клавишу Shift, нажимайте клавишу со стрелкой. При этом текстовое выделение каждый раз будет смещаться на 10 пикселов.

Если вы будете перемещать выделение в форме символов с помощью инструмента Move (Перемещение), то одновременно вырежете и переместите точки активного слоя, расположенные внутри символов (рис. 17.73).

Для того чтобы отменить выделение области, выполните команду Select > Deselect (Выделить > Отменить выделение), которой соответствует комбинация клавиш Ctrl+D.

Для того чтобы скопировать точки, расположенные в выделенной области, выполните команду Edit > Сору (Правка > Копировать), при этом скопируются точки только активного слоя. Или выполните команду Edit о Copy Merged (Правка > Копировать объединение), в результате чего будут скопированы точки всех видимых слоев, расположенных под выделением. Расположите выделение в форме символов над заданными точками, прежде чем применить

Рис. 17.73. Перемещение выделенной области в форме символов с помощью инструмента Move

Рис. 17.74. Результат вставки изображения в выделение в форме символов

Выравнивание текстовых слоев

Для того чтобы выровнять или распределить многочисленные текстовые слои, необходимо связать их (щелкните во второй колонке палитры Layers (Слои)), а затем выполнить команду из подменю Layer > Align Linked (Слой > Выровнять связанные) или Distribute Linked (Распределить связанные).

Не теряйте точки!

Чтобы отменить выделение уже выделенной области, воспользуйтесь командой Deselect (Отменить выделение) из меню Select (Выделить), которой соответствует комбинация клавиш Ctrl+D. Не нажимайте клавишу Delete и не выбирайте команду Clear (Очистить) в меню Edit (Правка). Эти команды удалят точки из выделенной области.

Для того чтобы вставить изображение в выделение в форме символов (рис. 17.74), сначала выделите и скопируйте область с другого слоя или другого изображения, создайте выделение в форме символов в целевом окне изображения, а затем выполните команду Edit > Paste Into (Правка о Вставить в). При этом будет создан новый слой и снято выделение с области в форме символов.

Создание текста в канале заказного цвета

  1. Создайте редактируемый текстовый слой (с помощью инструмента Туре (Текст)), чтобы в дальнейшем можно было его изменять.
  2. Повторите шаги 1-6 раздела «Создание канала заказного цвета» главы 11 для создания нового канала заказного (пла-шечного) цвета (spot channel).
  3. Выделите текстовый слой, а затем, нажав клавишу Ctrl, щелкните по имени слоя, чтобы выделить только его видимые области (символы).
  4. В палитре Channels (Каналы) выберите имя канала заказного цвета и убедитесь, что рядом стоит значок в виде глаза.
  5. Выполните команду Edit > Fill (Правка > Залить) и в появившемся диалоговом окне в поле Use (Использовать) выберите вариант Black (Черный), режим Normal (Нормальный) и установите значение параметра Opacity (Непрозрачность), соответствующее плотности краски канала заказного цвета. Нажмите кнопку ОК. Выделенная область будет полностью залита плашечным цветом.
  6. Выполните команду Select > Deselect (Выделить > Снять выделение) - см. рис. 17.75-17.77. Можно изменить значение параметра Solidity (Плотность), чтобы имитировать другую степень прозрачности краски на экране. При этом значение плотности не повлияет на результаты распечатки.
  7. По желанию. Спрячьте текстовый слой (щелкните по значку в виде глаза на палитре Layers (Слои)).

Для того чтобы переместить текст в канале заказного цвета, выделите этот канал и с помощью инструмента Move (Перемещение) переместите текст в окне изображения.

О том, как скорректировать тон плашечного канала, говорится в главе 11, раздел «Осветление или затемнение краски в канале заказного цвета».

Редактирование текста в канале заказного цвета

На самом деле невозможно редактировать текст в канале заказного цвета. В этом случае придется удалять из канала существующие там фигуры, а затем добавлять уже измененный текст.

  1. В палитре Channels (Каналы) выберите шишечный канал, содержащий текст.
  2. Нажав кнопку мыши, нарисуйте пунктирный контур вокруг текста и нажмите клавишу Delete, чтобы удалить текст из канала.
  3. В меню Select (Выделить) выполните команду Deselect (Снять выделение).
  4. Дважды щелкните по миниатюре исходного текстового слоя в палитре Layers (Слои), отредактируйте слой и щелкните по кнопке yf\ на панели опций.

Рис. 17.75. Текст в канале плашечного цвета

Рис. 17.76. Маска выделенного текста в канале заказного цвета

Рис. 17.77. Параметры канала заказного цвета

Рис. 17.78. Использование выделения в форме символов в качестве маски корректирующего слоя

Рис. 17.79. Влияние корректирующего слоя ча изображение

  5. Повторите шаги 3-7 предыдущего раздела. Теперь канал заказного цвета будет содержать измененный текст.

Создание текстовой маски для корректирующего слоя

  1. Сначала активизируйте инструмент Туре (Текст), щелкните по кнопке дц Create a mask or selection (Создать маску или выделение) на панели опций, а затем щелкните в том месте окна изображения, где должен появиться текст.
  2. Выберите атрибуты текста, введите текст и щелкните по кнопке на панели опций. Не снимайте выделение с текста.
  3. Активизируйте слой, над которым надо разместить новый корректирующий слой.
  4. Из всплывающего меню, вызываемого нажатием кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой) в нижней части палитры Layers, выполните соответствующую команду корректировки (рис. 17.78), введите необходимые значения параметров и нажмите кнопку ОК. Очертания символов станут маской корректирующего слоя. Причем корректировка будет влиять только на те точки, которые расположены непосредственно под символами (рис. 17.79).

Для создания выделения можно также использовать существующий текстовый слой. Для этого сначала спрячьте текстовый слой, а затем выделите текст, нажав клавишу Ctrl и щелкнув по миниатюре текстового слоя в палитре Layers (Слои). Затем выполните шаг 4 (см. выше).

Для того чтобы отобразить одну только маску, нажмите клавишу Alt и щелкните по миниатюре маски слоя (она расположена с правой стороны). Снова нажав Alt, щелкните еще раз по миниатюре, чтобы восстановить полное изображение.

Выделите корректирующий слой, а в меню Image (Изображение) выполните команды Adjustments > Invert (Корректировки > Инвертировать), нажав комбинацию клавиш Ctrl+l для того, чтобы поменять местами черные и белые области маски корректирующего слоя.

С помощью инструмента Move (Перемещение) - помните, что должен быть установлен флажок Auto Select Layer (Автовыделение слоя) - можно перемещать текстовую маску в выбранном корректирующем слое.


  • Глава 18. Фильтры
    • Основные сведения о фильтрах
      • Применение фильтров
      • Диалоговое окно фильтра
      • Ослабление эффекта от фильтра
      • Ограничение области, к которой применяется фильтр
      • Усиление эффекта фильтрации
      • Нанесение текстуры с помощью фильтров
    • Все фильтры программы Photoshop
      • Фильтры подменю Artistic
      • Фильтры подменю Artistic
      • Фильтры подменю Blur
      • Фильтры подменю Brush Strokes
      • Фильтры подменю Distort
      • Фильтры подменю Distort
      • Фильтры подменю Noise
      • Фильтры подменю Pixelate
      • Фильтры подменю Render
      • Фильтры подменю Sharpen
      • Фильтры подменю Sketch
      • Фильтры подменю Sketch
      • Фильтры подменю Stylize
      • Фильтры подменю Texture
      • Фильтры подменю Texture
    • Несколько упражнений с фильтрами
      • Создание изображения со «смятыми» краями
      • Применение текстуры с помощью маски слоя
      • Превращение фотографии в картину или рисунок
      • Акварельный фильтр
      • Применение фильтра Mosaic
      • Создание иллюзии движения
      • Добавление света в изображение

Глава №18.

Фильтры

В программе Photoshop с помощью фильтра можно получить бессчетное количество эффектов, начиная от небольшого увеличения резкости и заканчивая нелепыми искажениями, (рис. 18.1). Например, фильтры Blur (Размытие) или Sharpen (Резкость) можно использовать для едва заметного ретуширования изображения; фильтры Color Halftone (Цветной растр), Find Edges (Выделение краев), Emboss (Рельеф) или Wind (Ветер) -для более ярких эффектов; Artistic (Художественный), Brush Strokes (Мазки кисти), Sketch (Эскиз) или Texture (Текстура) - для создания изображения, «нарисованного» вручную; Lighting Effects (Эффекты освещения) - для того, чтобы осветить изображение.

В этой главе рассматриваются способы применения фильтров и приводится несколько развернутых примеров на эту тему, а также содержатся иллюстрации, демонстрирующие возможности различных фильтров в программе Photoshop.

Все фильтры сгруппированы по 13 категориям, перечисленным в меню Filter (Фильтр) - см. рис. 18.2. Импортированные фильтры появляются в своих собственных подменю (рекомендации по

Рис. 18.1. Фильтр Groucho

установке подобных фильтров можно отыскать в файлах интерактивной справочной системы (Help) программы Adobe Photoshop).

Основные сведения о фильтрах

Применение фильтров

Фильтр можно применить как к слою в целом, так и к его выделенной части. Прежде чем применить фильтр к выделенной области, необходимо растушевать ее, чтобы она не слишком выделялась на изображении после фильтрации.

Некоторые фильтры можно применить непосредственно (выбрав соответствующую команду из подменю). Другие же фильтры можно использовать, только установив определенные значения переменных в диалоговом окне. Выбрав команду меню Filter > Last Filter (Фильтр > Последний фильтр) (комбинация клавиш Ctrl+F), можно повторно применить последний использовавшийся фильтр с теми же характеристиками. Для установки других характеристик выберите фильтр из соответствующего подменю. Для того чтобы открыть диалоговое окно последнего использовавшегося фильтра, в котором будут отображены последние установленные характеристики, нажмите сочетание клавиш Ctrl+Alt+F.

В режиме RGB и Multichannel доступны все фильтры; а в режиме CMYK, Grayscale и Lab Color - только некоторые из них. Фильтры неприменимы к изображениям в режиме Bitmap и Indexed Color и к изображениям, в которых приходится 16 бит на каждый канал.

Рис. 18.2. Меню Filter

Рис. 18.3. Окно предварительного просмотра для фильтров

Диалоговое окно фильтра

Диалоговые окна большинства фильтров имеют окно предварительного просмотра (рис. 18.3).

Щелкните в окне предварительного просмотра и перетащите курсор, чтобы переместить изображение внутри него. При открытых диалоговых окнах некоторых фильтров указатель принимает вид квадрата, когда вы перемещаете его по изображению. Щелкните мышью по изображению, чтобы увидеть соответствующую область в окне предварительного просмотра. (Установите флажок Preview (Предварительный просмотр), если он существует, чтобы иметь возможность предварительно оценить действие эффекта.)

Щелкните по кнопке «плюс», чтобы увеличить изображение в окне предварительного просмотра, и по кнопке «минус», чтобы уменьшить его (рис. 18.3).

Нажмите клавишу со стрелкой, направленной вверх, чтобы увеличить значение подсвеченного поля на единицу (или на 0.1, если возможно), соответственно, нажмите клавишу со стрелкой, направленной вниз, чтобы уменьшить его.

Ослабление эффекта от фильтра

С помощью команды Fade (Ослабить) можно ослабить эффект от применения фильтра, команд подменю Adjustments (Коррекция), находящихся в меню Image (Изображение), и команд подменю Extract (Извлечь) или Liquify (Исказить), находящихся в меню Filter (Фильтры), а также изменить результат рисования, стирания или редактирования. После применения фильтра выберите команду меню Edit > Fade (Правка > Ослабить) (комбинация клавиш Ctrl+Shift+F) и уменьшите значение непрозрачности, выберите режим смешивания и нажмите кнопку ОК (рис. 18.4-18.6). На рис. 18.4 приведено изображение, к которому был применен фильтр Mosaic Tiles (Мозаичные плитки). После выполнения команды Fade (Ослабить) ко всему изображению (рис. 18.5) в режиме смешивания Overlay (Перекрытие) действие фильтра заметно уменьшилось (рис. 18.6).

Для того чтобы ослабить эффект от применения фильтра и выбрать подходящий режим смешивания, выполните следующие шаги:

  1. Создайте дубликат слоя, к которому следует применить фильтр.
  2. Примените к этому дубликату фильтр.
  3. В палитре Layers (Слои) переместите ползунок Opacity (Непрозрачность) влево, чтобы ослабить эффект от действия фильтра, и выберите другой режим смешивания. На рис. 18.7 и 18.8 соответственно показано исходное изображение и результат применения фильтра Find Edges (Выделение краев) к дубликату исходного изображения с уменьшением непрозрачности и в режиме смешивания Hard Light (Жесткий свет). Также попробуйте режимы Overlay (Перекрытие), Color Dodge (Комбинирование цветов) и Difference (Различие).

Рис. 18.4. Результат применения фильтра Mosaic Tiles

Рис. 18.5. Окно команды Fade

Рис. 18.6. Результат применения команды Fade

Рис. 18.7. Исходное изображение

Рис. 18.8. Результат применения фильтра Find Edges

Так как фильтр был применен к копии слоя, то впоследствии можно изменить режим смешивания или значение непрозрачности слоя фильтра, чтобы можно было разными способами смешать его с исходным слоем, либо создать маску копии слоя, чтобы спрятать или изменить эффект фильтрации, либо полностью удалить слой фильтра. Когда изменение изображения закончено, выполните операцию слияния копии слоя с исходным слоем.

Другой способ сглаживания эффекта фильтрации - изменение пикселов только в одном из компонентов цвета. Для этого выделите слой, щелкните по имени цветового канала на палитре Channels (Каналы), примените фильтр (Add Noise (Добавить шум) - один из тех, с которыми лучше всего экспериментировать). Щелкните по верхнему каналу на палитре (комбинация клавиш Ctrl+~), чтобы снова отобразить смешанное изображение.

Ограничение области, к которой применяется фильтр

Выделите некоторую область слоя, к которой будет применен фильтр. Для того чтобы смягчить переход между отфильтрованными и неотфильтрованными областями, примените команду растушевки к выделенной области перед фильтрацией.

Также можно использовать маску слоя, чтобы ограничить область действия фильтра. Граница между белыми и черными областями маски слоя может быть резкой или мягкой (в зависимости от типа мазков кисти, с помощью которой вы закрашиваете черные области маски). Выбрав команду меню Layer > Add Layer Mask > Reveal Selection (Слои > Добавить маску слоя > Показать выделенную область) при активной выделенной области и применив фильтр к маске, можно будет увидеть эффект фильтрации в том месте, где проходит граница между черными и белыми областями маски (попробуйте использовать фильтры Brush Strokes > Spatter (Мазки кисти > Разбрызгивание), Pixelate > Pointillize (Объединение пикселов > Пуантилизм), Stylize > Wind (Стилизация > Ветер) Distort > Zigzag (Деформация > Зигзаг) или Distort > Ripple (Деформация > Рябь)).

Рис. 18.9. Результат восстановления лица и животика ангела поле применения фильтра Poster Edges

Рис. 18.10. Радиальный градиент в маске слоя

Рис. 18.11. Ослабление эффекта применения фильтра Stamp в центре гнезда

Или создайте градиент от-белого-к-черно-му в маске слоя, а затем примените фильтр к слою изображения (не к слою маски). При этом фильтр будет применен полностью к изображению там, где находятся белые области маски, а для черных областей маски не произойдет никаких изменений (рис. 18.10-18.12).

Примените несколько фильтров, и тогда изображение будет выглядеть более естественным. Если с создаваемым изображением можно экспериментировать, то придумайте свои сочетания фильтров и попробуйте установить различные значения переменных в соответствующих диалоговых окнах. Если необходимо повторно использовать определенную комбинацию фильтров, то сохраните ее во время выполнения.

Рис. 18.12. Ослабление эффекта применения фильтра Rough Pastel в правой части изображения при помощи линейного градиента

Усиление эффекта фильтрации

Увеличение значений яркости и контраста могут способствовать усилению эффекта фильтрации. Выберите команду меню Image > Adjustments > Levels (Изображение > Корректировки > Уровни) и в поя: вившемся диалоговом окне Levels (Уровни) переместите черный ползунок Input (Ввод) вправо, а белый ползунок Output (Вывод) - немного влево и щелкните по кнопке ОК.

Для того чтобы изменить цвет слоя после применения к нему фильтра, который удалил некоторые цвета (например, при использовании фильтра Charcoal (Уголь)), воспользуйтесь командой меню Image > Adjustments > Hue/Saturation (Изображение > Корректировки > Тон/Насыщенность) и установите флажок Colorize (Тонировать).

Фильтры подменю Sketch (Эскиз), за исключением фильтра Water Paper (Мокрая бумага), сводят цвета слоя к белому и основному цвету рисования, так что выберите значение параметра Foreground color (Основной цвет) прежде, чем применять один из этих фильтров.

Нанесение текстуры с помощью фильтров

И наконец, для некоторых фильтров (например, Conte Crayon (Волшебный карандаш), Displace (Смещение), Glass (Стекло), Lighting Effects (Эффекты освещения), Rough Pastels (Пастель), Texture Fill (Текстурная заливка) или Texturizer (Тексту-ризатор)) вместо использования стандартного узора для создания текстуры, можно загрузить другое изображение и применить его в качестве узора. Светлые и темные области изображения будут порождать пики и впадины на текстуре. Изображение, используемое для текстурирования, должно быть сохранено в формате Photoshop. В диалоговом окне фильтра, содержащем всплывающее меню Texture (Текстура), включите опцию Load Texture (Загрузить текстуру), преобразуйте цветное или черно-белое изображение в формат Photoshop и щелкните по кнопке ОК.

Все фильтры программы Photoshop

Фильтры подменю Artistic

Рис. 18.13. Исходное изображение

Рис. 18.14. Colored Pencil (Цветной карандаш)

Рис. 18.15. Cutout (Аппликация)

Рис. 18.16. Dry Brush (Сухая кисть)

Рис. 18.17. Film Grain (Зернистость фотопленки)

Рис. 18.18. Fresco (Фреска)

Рис. 18.19. Neon Glow (Неоновый свет)

Рис. 18.20. Paint Daubs (Масляная живопись)

Рис. 18.21. Palette Knife (Шпатель)

Фильтры подменю Artistic

Рис. 18.22. Исходное изображение

Рис. 18.23. Plastic Wrap (Целлофановая упаковка)

Рис. 18.24. Poster Edges(Плакатные края)

Рис. 18.25. Rough Pastels (Пастель)

Рис. 18.26. Smudge Stick (Растушевка)

Рис. 18.27. Sponge (Губка)

Рис. 18.28. Watercolor (Акварель)

Рис. 18.29. Underpaying (Грунтовка)

Фильтры подменю Blur

Рис. 18.30. Исходное изображение

Рис. 18.31. Blur More (Размытие плюс)

Рис. 18.32. Gaussian Blur (Размытие по Гауссу)

Рис. 18.33. Motion Blur (Размытие в движении)

Рис. 18.34. Radial Blur (Радиальное размытие)

Рис. 18.35. Smart Blur (Умное размытие), режим Normal (Нормальный)

Рис. 18.36. Smart Blur (Умное размытие), режим Edges Only (Только контуры)

Рис. 18.37. Smart Blur (Умное размытие), режим Overlay Edge (Режим наложения)

Фильтры подменю Brush Strokes

Рис. 18.38. Исходное изображение

Рис. 18.39. Accented Edges (Подчеркнутые края)

Рис. 18.40. Angled Strokes (Наклонные штрихи)

Рис. 18.41. Crosshatch (Перекрестные штрихи)

Рис. 18.42. Dark Strokes (Темные штрихи)

Рис. 18.43. Ink Outlines (Обводка тушью)

Рис. 18.44. Spatter (Разбрызгивание)

Рис. 18.45. Sprayed Strokes (Аэрограф)

Рис. 18.46. Sumi-e (Японская роспись)

Фильтры подменю Distort

Рис. 18.47. Исходное изображение

Рис. 18.48. Diffuse Glow (Рассеянный свет)

Рис. 18.49. Displace (Смещение)

Рис. 18.50. Glass (Стекло)

Рис. 18.51. Ocean Ripple (Океанские волны)

Рис. 18.52. Pinch (Дисторсия)

Рис. 18.53. Polar Coordinates (Полярные координаты)

Рис. 18.54. Ripple (Рябь)

Рис. 18.55. Shear (Искривление)

Фильтры подменю Distort

Рис. 18.56. Spherize (Сферизация)

Рис. 18.57. Twirl (Скручивание)

Рис. 18.58. Wave (Волна), тип Square (Квадрат)

Рис. 18.59. Wave (Волна), тип Sine (Синусоида)

Рис.18.60. ZigZag (Зигзаг)

Фильтры подменю Noise

Рис. 18.61. Исходное изображение

Рис. 18.62. Add noise (Добавить шум)

Рис. 18.63. Median (Медиана)

Фильтры подменю Pixelate

Рис. 18.64. Исходное изображение

Рис. 18.65. Color Halftone (Цветной растр)

Рис. 18.66. Crystallize (Кристаллизация)

Рис. 18.67. Facet (Грань)

Рис. 18.68. Fragment (Фрагмент)

Рис. 18.69. Mezzotint (Меццо-тинто), режим Short Strokes (Короткие штрихи)

Рис. 18.70. Mezzotint (Меццо-тинто), режим Medium Dots (Средние точки)

Рис. 18.71. Mosaic (Мозаика)

Рис. 18.72. Pointillize (Пуантилизм)

Фильтры подменю Render

О фильтре Lighting Effects (эффекты освещения) рассказано далее в разделе «Добавление света в изображение».

Рис. 18.73. Исходное изображение

Рис. 18.74. Clouds (Облака)

Рис. 18.75. Difference Clouds (Облака с разностью)

Рис. 18.76. Lens Flare(Блик)

Фильтры подменю Sharpen

Рис. 18.77. Sharpen Edges (Резкость на краях)

Рис. 18.78. Sharpen More (Резкость плюс)

Рис. 18.79. Unsharp Mask (Нерезкое маскирование)

Фильтры подменю Sketch

Рис. 18.80. Исходное изображение

Рис.18.81. Bas Relief (Барельеф)

Рис. 18.82.Chalk&Charcoal (Мел и уголь)

Рис. 18.83. Charcoal (Уголь)

Рис. 18.84. Chrome (Хром)

Рис. 18.85. Conte Crayon (Волшебный карандаш)

Рис. 18.86. Graphic Pen (Тушь)

Рис. 18.87. Halftone Pattern (Полутоновый узор), стиль узора Circle (Круг)

Рис. 18.88. Halftone Pattern (Полутоновый узор), стиль узора Dot (Точка)

Фильтры подменю Sketch

Рис. 18.89. Исходное изображение

Рис. 18.90. Note Paper (Почтовая бумага)

Рис. 18.91. Photocopy (Ксерокопия)

Рис. 18.92. Plaster (Гипс)

Рис. 18.93. Reticulation (Ретикуляция)

Рис. 18.94. Stamp (Штамп)

Рис. 18.95. Torn Edges (Рваные края)

Рис. 18.96. Water Paper (Мокрая бумага)

Фильтры подменю Stylize

Рис. 18.97. Исходное изображение

Рис. 18.98. Diffuse (Диффузия)

Рис. 18.99. Emboss (Рельеф)

Рис. 18.100. Extrude (Экструзия)

Рис. 18.101. Find Edges (Выделение краев)

Рис. 18.102. Glowing Edges(Свечение краев)

Рис. 18.103. Solarize (Соляризация)

Рис. 18.104. Tiles (Плитки)

Рис. 18.105. Результат применения фильтра Tiles (Плитки), затем команды Fade (Ослабить) в режиме Overlay (Перекрытие)

Фильтры подменю Stylize

Рис. 18.106. Исходное изображение

Рис. 18.107. Trace Contour (Трассировка контуров)

Рис. 18.108. Wind (Ветер)

Фильтры подменю Texture

Рис. 18.109. Craquelure (Кракелюры)

Рис. 18.110. Grain (Зерно), режим Horizontal (Горизонтально)

Рис. 18.111. Mosaic Tiles (Мозаичные плитки)

Рис. 18.112. Patchwork (Цветная плитка)

Рис. 18.113. Stained Glass (Витраж)

Рис.18.114. Texturizer (Текстуризатор)

Рис. 18.115. Вид выделенной области

Несколько упражнений с фильтрами

Примените фильтр Ripple (Рябь), Twirl (Скручивание) или Zigzag (Зигзаг) к целевому слою, имеющему края белого цвета, чтобы создать текстуру, имеющую вид смятой бумаги.

Создание изображения со «смятыми» краями

  1. В качестве фонового цвета выберите белый.
  2. Выполните команду Canvas Size (Размер холста) в меню Image (Изображение), чтобы добавить окантовку (воспользуйтесь однослойным изображением).
  3. Выберите инструмент Rectangular Marquee (Прямоугольная область) (клавиша М или комбинация клавиш Shift+M).
  4. На панели опций этого инструмента введите значение 8 в поле Feather (Растушевка).
  5. Нарисуйте пунктирный контур вокруг примерно трех четвертей изображения (не включая его окантовки).
  6. Из меню Select (Выделение) выберите команду Inverse (Инвертировать) (комбинация клавиш Ctrl+Shift+I). Теперь выделенная область будет состоять из добавленной окантовки и части изображения (рис. 18.115).
  7. Выполните команду меню Filter > Distort > Ripple (Фильтр > Деформация > Рябь) (рис. 18.116), команду Filter > Brush Strokes > Spatter (Фильтр > Мазки кисти > Разбрызгивание) или воспользуйтесь их комбинацией. Переместите изображение в окне предварительного просмотра так, чтобы была видна граница изображения.

Более легкий способ

Воспользуйтесь одним из так называемых эффектов кадра, например, из набора PhotoFrame компании Extensis (рис. 18.117 и 18.118). Можно применить несколько эффектов кадра к одному и тому же изображению.

Рис. 18.116. Искаженные рябью края изображения

Рис. 18.117. Результат использования фильтра Camera (Камера) из набора PhotoFrame

Рис 18.118. Применение фильтра Water-color (Акварель) из набора PhotoFrame

Рис. 18.119. Результат применения фильтра к маске слоя

Рис. 18.120. Применение фильтра с использованием маски слоя

Применение текстуры с помощью маски слоя

В следующем упражнении показано, как можно добавить черную или серую текстуру к маске слоя с помощью фильтра. Черные области маски слоя скроют точки в слое, и станет видимым изображение, расположенное на нижележащем слое.

  1. Откройте изображение, создайте новый слой и залейте его белым цветом.
  2. Создайте для нового слоя маску, щелкнув по кнопке Add layer mask (Добавить маску слоя) на палитре Layers (Слои), и оставьте миниатюру маски слоя активной.
  3. Примените к маске фильтр с помощью команды меню Filter > Noise > Add Noise (Фильтр > Шум > Добавить шум).
  4. Примените другие фильтры к маске слоя (рис. 18.119 и 18.120). Попробуйте фильтры подменю Texture (Текстура): Craquelure (Кракелюры), Grain (Зерно), Mosaic Tiles (Мозаичные плитки), Patchwork (Цветная плитка), Texturize (Текстуризатор). Или воспользуйтесь фильтрами подменю Artistic (Художественный): Dry Brush (Сухая кисть) с небольшим размером кисти, Palette Knife (Шпатель) с небольшой толщиной штриха, Sponge (Губка), Watercolor (Акварель) или Plastic Wrap (Целлофановая упаковка). В последнем случае для увеличения контраста используйте палитру Levels (Уровни).
  5. Можно дополнительно выполнить любой из следующих шагов:
  • чтобы усилить эффект от применения фильтра, примените потом фильтр Twirl (Скручивание) из подменю Distort (Деформация) или фильтр Wind (Ветер) из подменю Stylize (Стилизация);
  • чтобы, наоборот, ослабить эффект от применения фильтра, выберите команду Fade (Ослабить) в меню Edit (Правка);
  • установите более подходящее значение непрозрачности слоя, содержащего маску; поменяйте режим смешивания (попробуйте варианты Overlay (Перекрытие), Soft Light (Мягкий свет) или Hue (Тон));
  • чтобы ограничить действие эффекта наложения текстуры в некоторых каналах изображения, дважды щелкните по имени нового слоя. В диалоговом окне Layer Style (Стиль слоя) выберите вкладку Blending Options (Опции смешивания) и в разделе Advanced Blending (Дополнительные опции смешивания) снимите флажок с тех каналов, которые не участвуют в операции смешивания с нижележащими слоями. Также в этом диалоговом окне можно изменить режим смешивания и уровень непрозрачности.

Рис. 18.121. Исходное изображение

Рис. 18.122. Полученное изображение

Превращение фотографии в картину или рисунок

  1. Откройте изображение, затем в меню палитры Layers (Слои) выберите команду Duplicate Layer (Дублировать слой) и нажмите кнопку ОК.
  2. Выполните команду Filter > Stylize > Find Edges (Фильтр > Стилизация > Выделение краев).
  3. При активном дубликате слоя щелкните по кнопке Add a mask (Добавить маску).
  4. Раскрасьте маску слоя черным цветом со значением непрозрачности менее 100%, чтобы показать некоторые области лежащего ниже слоя (рис. 18.121 и 18.122).
  5. По желанию. Уменьшите значение непрозрачности дубликата слоя.
  6. По желанию. Для получения более впечатляющего цветового эффекта на темном фоне щелкните по миниатюре слоя и воспользуйтесь командой меню Image & Adjustments > Invert (Изображение > Корректировки => Обратить) (комбинация клавиш Ctrl+I).

Для того чтобы получить карандашный рисунок, вместо выполнения шага 2 сначала примените фильтр Trace Contour (Трассировка контуров) и затем фильтр Minimum (Минимум) из подменю Other (Другие), задав значение радиуса равным 1 или 2.

Акварельный фильтр

Преобразовать фотографию в акварельный рисунок можно с помощью фильтров Minimum (Минимум) из подменю Other (Другие) и Median (Медиана) из подменю Noise (Шум). Сравните их с фильтром Watercolor (Акварель) программы Photoshop. Ниже представлен пример применения нескольких фильтров к одному изображению.

  1. Создайте дубликат слоя, который необходимо превратить в акварельный рисунок.
  2. Активизируйте дубликат слоя и выполните команду Filter > Noise > Median (Фильтр > Шум > Медиана).
  3. Передвиньте ползунок параметра Radius (Радиус) в промежуток между цифрами 2 и 8.
  4. Нажмите кнопку ОК.
  5. Выполните команду Filter > Others > Minimum (Фильтр > Другие > Минимум).
  6. Установите ползунок параметра Radius (Радиус) на отметках 1, 2 или 3.
  7. Щелкните по кнопке ОК (рис. 18.123-18.125).
  8. По желанию: Выполните команду меню Filter > Sharpen > Sharpen More (Фильтр > Резкость > Резкость плюс).

Рис. 18.123. Исходное изображение

Рис. 18.124. Получившееся изображение

Рис. 18.125. Изображение с применением фильтра Watercolor

Рис. 18.126. Применение фильтра Mosaic с использованием градиентной заливки маски слоя

Рис. 18.127. Окно фильтра Mosaic

Рис. 18.128. Перетаскивание пунктирного контура

Применение фильтра Mosaic

В следующем упражнении фильтр Mosaic (Мозаика) применяется к ряду прямоугольных выделенных областей с одновременным увеличением размеров фрагментов мозаики. Использование градиента в маске слоя ослабит эффект от действия фильтра Mosaic, не изменяя при этом размер ее элементов (рис. 18.126).

  1. Выделите слой.
  2. 2. Выберите инструмент Rectangular Marquee (Прямоугольная область), нажав клавишу М или сочетание клавиш Shift+M.
  3. Обведите одну четвертую или одну пятую часть изображения там, где вы хотите, чтобы начиналась мозаика.
  4. Выберите фильтр Mosaic (Мозаика) в подменю Pixelate (Объединение пикселов).
  5. Введите значение 6 в поле Cell Size (Размер ячейки) в диалоговом окне Mosaic (Мозаика) - рис. 18.127. Выполните это действие еще несколько раз, постепенно увеличивая вводимое значение.
  6. Нажмите кнопку ОК.
  7. Сохраняя активными выделенную область и инструмент Rectangular Marquee (Прямоугольная область), нажмите клавишу Shift и перетащите пунктирный контур в прилегающую область (рис. 18.128), снова примените фильтр и т.д. и т.п.
  8. Повторяйте шаги 4-7 до тех пор, пока не обработаете все изображение, вводя в поле Cell Size (Размер ячейки) значения 12, 24 и 30 соответственно. Для создания больших по размеру элементов введите большие значения в это поле, например, 8,16,28 и 34.
  9. Отмените выделение (сочетание клавиш Ctrl+D) -см. рис. 18.129.

Создание иллюзии движения

Для того чтобы создать иллюзию движения, необходимо выделить объект, который должен оставаться неподвижным, скопировать его в новый слой, а затем применить фильтр Motion Blur (Размытие в движении) к фоновому изображению.

  1. Выделите фрагмент изображения, который следует оставить неизменным (рис. 18.130).
  2. Выполните команду Feather (Растушевка) из меню Select (Выделение), нажав комбинацию клавиш Ctrl+Alt+D.
  3. Введите значение 5 в поле Feather Radius (Радиус растушевки) и нажмите кнопку ОК.

Рис. 18.129. Эффект от применения фильтра Mosaic с постепенно увеличивающимся размером ячеек

Рис. 18.130. Выделение объекта

Рис. 18.131. Копирование выделенной области

Рис. 18.132. Диалоговое окно фильтра Motion Blur

  4. Воспользуйтесь сочетанием клавиш Ctrl+J, чтобы скопировать выделенную область в новый слой (рис. 18.131).
  5. Выделите исходное изображение, содержащее фон.
  6. Выполните команду меню Filter > Blur> Motion Blur (Фильтр> Размытие > Размытие в движении).
  7. Введите значение угла наклона Angle (Угол) в диапазоне от -360° до 360° (рис. 18.132). Мы ввели значение -17°.

    Выберите значение степени размытия Distance (Расстояние) в пределах от 1 до 999. (Мы ввели, значение степени размытия, равное 50.)

  8. Нажмите кнопку ОК (рис. 18.133).

Рис. 18.133. Итоговое изображение

Добавление света в изображение

Фильтр Lighting Effects (Эффекты освещения) позволяет создать бессчетное количество эффектов освещения. В изображении можно расположить до 16 источников света, и для каждого источника установить свой цвет, интенсивность и направление лучей света.

Для оптимального использования данного фильтра программе Photoshop необходимо как минимум 50 Мб оперативной памяти.

  1. Убедитесьв том, что изображение представлено в цветовом режиме RGB (рис. 18.134).
  2. Выделите слой. По желанию. Выделите область слоя, чтобы ограничить действие фильтра.
  3. Выполните команду Filter > Render > Lighting Effects (Фильтр > Освещение> Эффекты освещения).
  4. Из раскрывающегося списка в поле Style (Стиль) выберите вариант Default (По умолчанию) или готовый эффект освещения (рис. 18.135).
  5. В разделе Light Type (Тип освещения) выполните следующие действия (см. рис. 18.136):
    • установите флажок On (Включить), чтобы увидеть эффект в окне предварительного просмотра;
    • из раскрывающегося списка в поле Light Type (Тип освещения) выберите соответствующий тип источника света: Spotlight (Прожектор), если хотите, чтобы по умолчанию пучок света был узким, конусообразным и давал пятно эллиптической формы;

Рис. 18.134. Исходное изображение в режиме RGB

Рис. 18.135. Выбор эффекта

Рис. 18.136. Установка параметров эффекта освещения

Рис. 18.137. Эллиптическое световое пятно при самой высокой интенсивности источника Spotlight и стиле Default

а)

б)

Рис. 18.138. Освещение типа Spotlight в режиме Wide Focus (а) и Narrow Focus (б)

Рис. 18.139. Перемещение граничных манипуляторов по направлению к центру

а)

б)

Рис. 18.140. Поворот луча света влево (а) и перемещение концевого манипулятора вовнутрь эллипса, благодаря чему область освещения становится круговой (б)

    • установите ползунок Intensity (Интенсивность) на необходимую отметку для изменения яркости света. Позиция Full (Полностью) определяет самый яркий свет (рис. 18.137), a Negative (Отрицательно) - темный;
    • для типа освещения Spotlight (Прожектор) можно переместить ползунок Focus (Фокус), чтобы отрегулировать освещение внутри эллипса. Если установить ползунок в положение Wide Focus (Широкий фокус), то свет становится ярче при приближении к границам эллипса (рис. 18.138а). При перемещении ползунка в положение Narrow Focus (Узкий фокус) изображение выглядит иначе (рис. 18.1386);
    • чтобы изменить цвет освещения, щелкните по полю образца цвета и выберите нужный оттенок на палитре.
  6. В области предварительного просмотра можно выполнить любое из перечисленных ниже действий:
    • перетащите центральную точку эллипса, чтобы сместить весь пучок света;
    • перетащите любой из граничных манипуляторов эллипса по направлению к центру, чтобы сузить луч света и увеличить его яркость (рис. 18.139);
    • в случае эллиптической области перетащите любой из боковых манипуляторов, чтобы изменить направление света или чтобы расширить или сузить пучок света (рис. 18.140а, б).
  7. Передвиньте ползунки, расположенные в разделе Properties (Свойства), чтобы отрегулировать следующие свойства поверхности объекта в активном слое:
    • Gloss (Фактура) определяет силу отражения света той поверхностью, на которую он падает;
    • Material (Материал) определяет, как изображение отражает цвет источника света: Plastic (Пластик) -отражается цвет освещения, Metall (Металл) - отражается цвет самого объекта;
    • Exposure (Экспозиция) освещает или затемняет весь слой изображения (рис. 18.141а, б);
    • Ambience (Подсветка) следит за балансом между источником света и освещенностью всего изображения (рис. 18.142а, б). Перемещайте этот ползунок осторожно.

    Щелкните по образцу цвета, чтобы выбрать какой-либо другой оттенок для подсветки.

  8. Выполните любое из перечисленных ниже действий:
    • чтобы добавить установленные параметры во всплывающее меню Style (Стиль), щелкните по кнопке Save (Сохранить);
    • для того чтобы добавить еще один источник света, перетащите значок в виде горящей лампочки в окно предварительного просмотра (рис. 18.143);

а)

б)

Рис. 18.141. Освещение при установке ползунка Exposure на отметке (a) Over (Максимум) и (б) Under (Минимум)

а)

б)

Рис. 18.142. Освещение при установке ползунка Ambience около отметки (a) Positive (Положительный) и (б) Negative (Отрицательный)

Рис. 18.143. Перемещение нового источника света в окно предварительного просмотра

Рис. 18.144. Свет от источника освещения типа Omni

    • для того чтобы удалить источник света, просто перетащите его центральную точку на кнопку в виде корзины;
    • чтобы создать копию источника света, нажмите клавишу Alt и перетащите его центральную точку в нужное место.
  9. Нажмите кнопку ОК.

Последние установленные параметры фильтра Lighting Effects (Эффекты освещения) будут сохранены в диалоговом окне до тех пор, пока их не изменят или не закроют программу Photoshop. Чтобы восстановить свойства фильтра, установленные по умолчанию, выберите другой стиль из всплывающего меню Style (Стиль), а затем в этом же меню включите опцию Default (По умолчанию). Щелкните по кнопке Delete (Удалить), чтобы удалить выбранный стиль из всплывающего меню.

Для создания текстурного эффекта освещения выберите из раскрывающегося списка в разделе Texture Channel (Текстурный канал) альфа-канал, содержащий текстуру. Передвиньте ползунок Height (Высота) и отрегулируйте высоту текстуры. Эта функция лучше всего подходит к типу освещения Spotlight (Прожектор).

Свет типа Omni (Лампа) создает сферическую световую область и похож на свет фонаря, направленного перпендикулярно изображению (рис. 18.144). Перетаскивая граничный манипулятор светового пятна, можно изменить размер области освещения.

Нажав клавишу Shift и перетаскивая граничный манипулятор эллипса, можно изменить его размер (при этом угол не меняется). Чтобы изменить угол или направление света, не меняя размера эллипса, нажмите клавишу Ctrl и перетащите радиус.

Для создания небольшого светового пятна выберите тип освещения Spotlight (Прожектор), подвиньте ползунок Intensity (Интенсивность) на отметку 55, а ползунок Focus (Фокус) - на отметку 30. Затем перетащите боковые манипуляторы эллипса в направлении центра, чтобы сузить его. Чтобы осветить другую часть изображения, переместите весь эллипс целиком, перетащив его центральную точку.

Если фон изображения был чересчур затемнен вследствие применения фильтра Lighting Effects (Эффекты освещения), то воспользуйтесь им еще раз для того, чтобы осветить темную область и показать дополнительные детали изображения. Передвиньте ползунки Exposure (Экспозиция) и Ambience (Подсветка) в разделе Properties (Свойства) немного вправо.

Примеры применения фильтра Lighting Effects

Для создания изображения, приведенного на рис. 18.145, был использован тип освещения Spotlight (Прожектор) с широким фокусом. При этом эллиптическое световое пятно было повернуто, и его форма была изменена. Ползунок Exposure (Экспозиция) был немного сдвинут к отметке Over (Максимум), чтобы увеличить яркость источника света, а ползунок Ambience (Подсветка) - немного влево, чтобы затемнить фон изображения. Затем, нажав клавишу Alt, мы перетащили эллипс, чтобы скопировать источник света и осветить лицо справа. И наконец, был создан новый источник света с малой интенсивностью, чтобы осветить фон изображения (рис. 18.146).

Рис. 18.145. Свет от источника освещения типа Spotlight

Рис. 18.146. Расположение эллипсов источников света, использованных для получения рис. 18.145


  • Глава 19. Команда Liquify
    • Деформация изображения с помощью команды Liquify
      • Отображение сетки
      • Реконструкция изображения
      • Перенос искажений из замаскированных областей на незамаскированные
      • Расшифровка режимов

Глава №19.

Команда Liquify

Команда Liquify (Исказить) позволяет скручивать, изгибать, растягивать и другими способами деформировать слой изображения.

Так же, как и в случае команды Extract (Извлечь), в диалоговом окне команды Liquify есть окно предварительного просмотра, в котором можно видеть все изображение целиком (рис. 19.1).

Деформировать или реконструировать изображение можно только с помощью кисти, размер которой и степень воздействия на изображение регулируются (подобно кистям других видов в программе Photoshop). Также можно воспользоваться инструментом Freeze (Заморозить), чтобы предотвратить искажение отдельных областей изображения аналогично тому, как это делается с помощью маски. Если вы хотите частично или полностью отменить те искажения, которые были внесены, воспользуйтесь инструментом Reconstruct (Реконструировать). Внесенные изменения не станут постоянными до тех пор, пока вы не щелкнете по кнопке ОК и не закроете окно.

Рис. 19.1. Диалоговое окно команды Liquify после применения инструмента Twirl Clockwise к изображению Эйфелевой башни

Деформация изображения с помощью команды Liquify

Для большей безопасности работайте с дубликатом слоя или сделайте снимок исходного изображения с помощью палитры History (История).

  1. Выберите слой, содержимое которого вы хотите подвергнуть искажению. При активизации флажка Backdrop действие инструмента Liquify можно распространить лишь на один из нескольких слоев по выбору, а не на все, как предусмотрено по умолчанию. При этом в поле Opality (Непрозрачность) можно также регулировать прозрачность слоя. Команда Liquify (Исказить) работает только с растровым слоем и не может быть применена к слою редактируемого текста или слою фигуры.
  2. Выберите команду Liquify в меню Filter (Фильтр) или нажмите комбинацию клавиш Ctrl+Shift+X.
  3. Для деформации заданного изображения воспользуйтесь инструментами диалогового окна Liquify (рис. 19.2). Сначала в разделе Tool Options (Опции инструмента) (рис. 19.3) введите размер кисти (параметр Brush Size), установив значение в диапазоне от 1 до 600 пикселов, а также величину нажима кисти (параметр Brush Pressure) от 1 до 100% и величину колебаний шума (параметр Turbulent Jitter), чтобы определить, как будет происходить искажение изображения. Эти три параметра относятся ко всем инструментам команды Liquify. Б случае, если вы используете планшет, можно установить флажок Stylus Pressure (Нажим пера), чтобы нажим пера влиял на значение параметра Brush Pressure.

Рис. 19.2. Инструменты в диалоговом окне Liquify

Рис. 19.3. Раздел Tool Options диалогового окна Liquify

Рис. 19.4. Раздел Freeze Options диалогового окна Liquify

  4. По желанию. Активизируйте инструмент Freeze (Заморозить), щелкнув по пиктограмме fg (вторая снизу) или нажав клавишу F, чтобы замаскировать некоторые области изображения, которые не должны подвергаться искажению. Далее выберите цвет из раскрывающегося списка Freeze Color (Цвет маски) в разделе View Options (Режимы просмотра). По умолчанию установлен красный цвет, такой же цвет используется при работе с быстрой маской. Закрасьте те области, которые следует оставить в текущем состоянии. Если произошла ошибка, то переходите к следующему пункту.
  5. По желанию. Для того чтобы убрать защиту с замаскированных («замороженных») областей, активизируйте инструмент Thaw (Разморозить), «горячая» клавиша Т, и рисуйте с его помощью.
  6. Выполните любое из перечисленных ниже действий:
    • для того чтобы инвертировать маску, щелкните по кнопке Invert (Инвертировать) в разделе Freeze Area (Область маски);
    • чтобы удалить маску со всего изображения (в результате чего все изображение снова можно редактировать), щелкните по кнопке Thaw All (Разморозить все) - см. рис. 19.4;
    • для того чтобы спрятать маску, созданную при помощи инструмента Freeze (Заморозить), снимите флажок Show Frozen Areas (Показать маскированные области) в разделе View Options (Режимы просмотра).
  7. Активизируйте один из инструментов искажения (нажмите соответствующую «горячую» клавишу) и рисуйте на изображении в диалоговом окне. Возможности инструментов указаны ниже:
    • инструмент Warp (Деформация) -клавиша W — сдвигает точки в направлении движения кисти (рис. 19.5, стрелка показывает направление движения кисти);
    • инструмент Turbulence (Волнение) -клавиша А или пиктограмма т\ -раздвигает точки по направлению движения кисти. Изображение в области действия кисти выглядит как бы размытым водой (рис. 19.6);
    • инструменты Twirl Clockwise (Закрутка по часовой стрелке) - клавиша R или пиктограмма J| | - и Twirl Counterclockwise (Закрутка против часовой стрелки) - клавиша L или пиктограмма ;§у - поворачивают пикселы, пока вы держите нажатой кнопку мыши либо тащите изображение. Чем больше величина параметра Brush Pressure (Нажим кисти), тем быстрее происходит поворот (рис. 19.1);

Рис. 19.5. Результат применения инструмента Warp

Рис. 19.6. Результат применения инструмента Turbulence

Рис. 19.7. Результат применения инструмента Pucker

Рис. 19.8. Результат использования инструмента Reflection

    • инструменты Pucker (Складка) - клавиша Р или пиктограмма Bloat (Раздувание) - клавиша В или пиктограмма <§у - перемещают точки к центру кисти или в противоположном направлении, пока вы держите нажатой кнопку мыши или тащите изображение (рис. 19.7). Чем больше величина параметра Brush Pressure (Нажим кисти), тем быстрее двигаются точки;
    • инструмент Shift Pixels (Сдвиг пикселов) - клавиша S - перемещает пикселы в определенном направлении, зависящем от направления движения кисти. По умолчанию пикселы сдвигаются влево от направления движения кисти. Нажав клавишу Alt, можно переместить их вправо;
    • инструмент Reflection (Отражение) - клавиша М - копирует точки слева от линии направления кисти и перемещает их в область действия этого инструмента, но только в «отраженном» виде. На рис. 19.8 показано, как инструмент Reflection был использован для того, чтобы передвинуть на изображении реку Сену поближе к Эйфе-левой башне. В результате получился великолепный эффект отражения. Для этого понадобилось всего два штриха кистью.

Указанный инструмент использовал точки справа от верхней линии (верхнего штриха) и слева от нижней линии (штриха). Нажав клавишу Alt, можно копировать точки с противоположной стороны относительно положения кисти (рис. 19.9).

Попробуйте заморозить ту область, точки которой следует отразить, а потом воспользуйтесь инструментом Reflection (Отражение).

  8. Для того чтобы частично или полностью отменить действие команды Liquify (Исказить), следуйте инструкциям, приведенным в этой главе, раздел «Реконструкция изображения».
  9. Щелкните по кнопке ОК, чтобы зафиксировать внесенные изменения и вернуться к окну изображения.

Чтобы применить инструмент Freeze к определенной области, выделите ее до того, как будете применять команду Liquify (Исказить). Сохраните выделение в альфа-канале, потом воспользуйтесь командой Liquify из меню Image (Изображение), а затем во всплывающем меню Channel (Канал) раздела Freeze Area (Область маски) найдите альфа-канал. Можно щелкнуть по кнопке Invert (Инвертировать), чтобы поменять местами замаскированные и незамаскированные области изображения.

Рис. 19.9. Результат применения инструмента Reflection при нажатой клавише Alt

Рис. 19.10. Раздел View Options с установками, принимаемыми по умолчанию

Рис. 19.11. Искаженное изображение Эйфелевой башни, полученное при помощи инструмента Warp

Рис. 19.12. Вид сетки при спрятанном изображении

Рис. 19.13. Кнопки загрузки и сохранения сетки в диалоговом окне Liquify

Отображение сетки

Для того чтобы было легче следить за вносимыми изменениями, на изображение можно нанести сетку. Линии сетки будут с такими же искажениями, что и само изображение. Сетка бывает особенно полезна в том случае, если в изображении мало четких границ. Она может пригодиться и при использовании инструмента Reconstruct (Реконструировать). Плотность сетки и ее цвет можно регулировать.

  1. В разделе View Options (Режимы просмотра) установите флажок Show Mesh (Показать сетку) -см. рис. 19.10. При этом изображение будет покрыто линиями, расположенными на одинаковом расстоянии друг от друга (рис. 19.11).
  2. Выполните любое из следующих действий:
    • выберите соответствующий размер сетки из всплывающего меню Mesh Size (Размер сетки);
    • задайте с помощью всплывающего меню Mesh Color (Цвет сетки) ее цвет;
    • если включена опция Show Mesh (Показать сетку) и необходимо спрятать изображение, то снимите флажок Show Image (Показать изображение) - см. рис. 19.12. Искажение будет видно более четко на сетке.

Вы можете сохранить созданную сетку, щелкнув по кнопке Save Mesh... для последующего применения. Чтобы загрузить ранее сохраненную сетку, щелкните по кнопке Load Mesh... (рис. 19.13).

Реконструкция изображения

После того как было искажено изображение, можно воспользоваться средствами раздела Reconstruction (Реконструкция) и инструментом Reconstruct (Реконструировать), чтобы отменить внесенные изменения частично или полностью, или чтобы распространить искажение и на другие области изображения (рис. 19.14).

Удаление всех внесенных изменений

Щелкните по кнопке Revert (Восстановить) в разделе Reconstruction (Реконструкция). Изображение в окне предварительного просмотра (включая замаскированные области) вернется к состоянию, в котором оно находилось при открытии диалогового окна Liquify (Исказить). Не путайте кнопку Revert (Восстановить) с режимом Revert для кисти.

Восстановление незамаскированных областей

  1. Из всплывающего меню Mode (Режим) в разделе Reconstruction (Реконструкция) выберите режим Revert (Восстановить).
  2. Щелкните по кнопке Reconstruct (Реконструировать). Незамаскированные области изображения вернутся к состоянию, в котором они находились, когда было открыто диалоговое окно Liquify (Исказить). При этом замаскированные области не будут затронуты.

Восстановление отдельных незамаскированных областей до первоначального состояния

  1. Из всплывающего меню Mode (Режим) в разделе Reconstruction (Реконструкция) выберите вариант Revert (Восстановить).

Рис. 19.14. Раздел Reconstruction

Рис. 19.15. Всплывающее меню Mode в разделе Reconstruction

  2. Воспользуйтесь инструментом Reconstruct (Реконструировать), которому соответствует клавиша Е , чтобы закрасить области, подлежащие восстановлению. Восстановление происходит значительно быстрее там, где находится центр кисти.

Перенос искажений из замаскированных областей на незамаскированные

Возможно, при работе с командой Liquify (Исказить) вы решили заморозить область, которая была искажена. Инструмент Reconstruct (Реконструировать) позволяет распространять искажение из замаскированных областей на незамаскированные весьма интересными способами. Также с помощью этого инструмента можно использовать искажение одной части изображения в качестве образца для другой.

  1. Замаскируйте с помощью инструмента Freeze (Заморозить) одну или несколько областей, которые уже были искажены. В данном случае границы изображения тоже станут зафиксированными. Попробуйте восстановить изображение между двумя замаскированными областями.
  2. Из всплывающего меню Mode (Режим) в области Reconstruction (Реконструкция) выберите какой-либо из режимов, за исключением режима Revert (Восстановить) - рис. 19.15.
  3. Активизируйте инструмент Reconstruct (Реконструировать), нажав клавишу Е. Воспользуйтесь им, чтобы рисовать на изображении и, таким образом, как бы реконструировать незамаскированные области. Наиболее быстро изображение восстанавливается там, где находится центр кисти. Но можно сделать и иначе.

Щелкните по кнопке Reconstruct (Реконструировать), чтобы восстановить исходное состояние всех незамаскированных областей. При восстановлении внесенные изменения отменяются в обратном порядке, подобно фильму, который показывается наоборот. Чтобы остановить процесс, нажмите клавишу «пробел».

Для того чтобы увеличить изображение области, подвергаемой искажению, выделите область до того, как применять команду Liquify. Выделенная область будет увеличена в окне предварительного просмотра. Команды View > Zoom In (Вид > Увеличить) или View > Zoom Out (Вид > Уменьшить) недоступны в диалоговом окне Liquify (Исказить).

Для того чтобы отменить все внесенные изменения изображения и установки инструментов, не закрывайте диалоговое окно, нажмите клавишу Alt и щелкните по кнопке Cancel (Отмена). Тем самым к изображению будет применена команда Reset (Восстановить).

Расшифровка режимов

В режимах Rigid (Строгий), Stiff (Сильный), Smooth (Плавный) и Loose (Свободный) искажение распространяется с замаскированных областей на незамаскированные, причем по-разному. В результате области частично искажаются и частично реставрируются. Режимы Smooth и Loose больше искажают изображение и устанавливают плавный переход между замаскированными и незамаскированными областями. Режимы Rigid и Stiff больше восстанавливают изображение, при этом границы между областями оказываются более четкими. Чтобы распространить искажение, щелкните кнопкой мыши или перетащите курсор на незамаскированные области.

В нижней части всплывающего меню Mode (Режим) есть три варианта режимов копирования параметров искажения определенной области в другую незамаскированную область изображения. Режим Displace (Co смещением) копирует смещение исходной области, двигая картинку из одной части изображения в другую. Режим Amplitwist (С поворотом) - перемещение, вращение и масштабирование исходной области. Режим Affine (Афин ный) - все параметры искажения, включая перемещение, вращение, масштаб по горизонтали и вертикали, а также перекос.


  • Глава 2. Цвет в программе Photoshop
    • Основные сведения о цвете
      • Пикселы
      • Цветовые представления RGB и CMYK
      • Каналы
      • Режимы изображения
      • Режимы смешивания
    • Управление цветом
      • Калибровка
      • Предопределенные наборы характеристик для управления цветом
      • Выбор характеристик для рабочего пространства
      • Создание собственной системы управления цветом
      • Настройка параметров операции преобразования
      • Изменение или удаление цветового профиля документа
      • Преобразование цветового профиля документа
      • Тестирование цвета

Глава №2.

Цвет в программе Photoshop

Рис. 2.1. Изображение крупным планом, на котором видны отдельные пикселы

В этой главе рассматриваются основные понятия, связанные с цветом (модели цвета, режимы изображения и режимы смешивания), а также рассказывается о возможностях управления цветом в программе Photoshop.

Основные сведения о цвете

Пикселы

Изображение, видимое на экране в программе Photoshop, является растровым, то есть представляет собой совокупность точек различных цветов, расположенных в узлах прямоугольной сетки. Каждая точка, называемая пикселом, изображает какой-либо цвет или тень. Увеличив часть изображения, можно редактировать отдельные пикселы (рис. 2.1).

Любое изображение в программе Photoshop является растровым, независимо от того, было ли оно отсканировано, импортировано из другого приложения или же полностью создано в этой программе с помощью инструментов рисования и редактирования. Программы, работающие с растровыми изображениями, идеальны для создания живописных, фотографических или фотореалистичных изображений, содержащих едва уловимые различия цветов. Если протащить курсор через какую-либо область слоя в то время, как выбран один из инструментов рисования, пикселы под курсором будут перекрашены.

Цветовые представления RGB и CMYK

Для вывода цветного изображения на монитор используются красный, зеленый и синий (Red, Green, Blue - RGB) лучи. Если смешать эти три основных цвета в чистом виде, получится белый цвет (рис. 2.2).

При четырехцветной печати используются три основных краски: голубой (С, cyan), пурпурный (М, magenta) и желтый (Y, yellow) - рис. 2.3.

При их смешивании получается темный, непрозрачный цвет. Для того чтобы получить насыщенный черный цвет, обычно в принтерах смешиваются черные чернила (К, black) с небольшим количеством голубых, пурпурных и/или желтых чернил.

Отображение цвета на экране монитора часто меняется и зависит от особенностей освещения, температуры монитора и цвета окружающих предметов. Кроме того, многие цвета, видимые в реальной жизни, не могут быть выведены при печати, не все цвета, отображаемые на экране, могут быть напечатаны, а некоторые цвета печати не видны на экране монитора. Все мониторы отображают цвета в соответствии с моделью RGB, CMYK-цвета лишь симулируются. Но модель CMYK важна только для печати. Если же вы хотите отправить изображение по сети или вывести на устройство записи на кинопленку, о его преобразовании из режима RGB в CMYK беспокоиться не нужно.

Рис. 2.2. Сложение цветов на мониторе компьютера

Рис. 2.3. Основные цвета типографской краски

Рис. 2.4. Восклицательный знак на палитре Color

Рис. 2.5. Восклицательные знаки на палитре Info

Если вы выберете не печатаемый (не входящий в гамму) цвет, на палитре Color (Цвет) появится восклицательный знак (рис. 2.4). Такие же знаки будут появляться и на палитре Info (Информация), если цвет пиксела, на который указывает курсор, не входит в гамму (рис. 2.5).

С помощью команды Gamut Warning (Предупреждение о гамме) в программе Photoshop можно задать замену непечатаемых цветов изображения серым цветом и затем с помощью инструмента Sponge (Губка) преобразовать их во входящие в гамму цвета.

При выборе цветов в программе Photoshop из панели выбора или палитры Color можно использовать цветовую модель Grayscale (Полутоновое изображение), RGB (red-green-blue - красный-зеленый-синий), CMYK (cyan-magenta-yellow-black -голубой-пурпурный-желтый-черный) или Lab (lightness-a axis-b axis - яркость и цвет на осях а и b).

Каналы

Каждое изображение в программе Photoshop состоит из одного и более полупрозрачных рисунков определенного цвета, называемых каналами. Например, изображение в режиме RGB составлено из красного, зеленого и синего каналов. Для получения наглядного представления о них откройте цветное изображение, а затем на палитре Channels щелкните по одному из элементов Red, Green, Blue, чтобы отображался только этот канал. Затем, щелкнув по элементу RGB (комбинация клавиш Ctrl+~), восстановите полное представление изображения. Если каналы не отображаются в цвете, в окне Edit > Preferences > Display&Cursors установите флажок Color Channels in Color (Каналы в цвете).

Иногда корректировка цвета касается только отдельного канала, но обычно изменения проводятся и отображаются в многоканальном, композитном изображении (самый верхний элемент на палитре Channels) и влияют на все каналы изображения одновременно. Специальные полутоновые каналы, используемые для сохранения выделенной области в качестве маски, называются альфа-каналами, и их можно добавить к изображению (рис. 2.6а). Также можно добавить канал плашечного цвета (рис. 2.66). Редактировать допускается только выделенные в данный момент каналы.

Чем больше каналов содержит изображение, тем больше памяти оно занимает. Размер изображения в режиме RGB с тремя каналами (красный, зеленый и синий) будет в три раза больше, нежели то же изображение в полутоновом режиме с одним каналом. Это же изображение в режиме CMYK будет содержать четыре канала и займет еще больше дискового пространства.

Web-графика

Если вы создаете изображение для Web-сайта, воспользуйтесь цветовой моделью RGB. Помните, что RGB-цвета или цвета из любой другой модели в данном случае могут не соответствовать цветовой палитре Web-браузера (см. главу 23, раздел «Согласование цветов в программе Photoshop и других приложениях»). Для получения более качественных результатов загрузите одну из палитр Web или Visibone в палитру Swatches и воспользуйтесь опциями Web Color Sliders (Ползунки Web-цветов) и Make Ramp Web Safe (Сделать цвета подходящими для Web) из меню палитры Color.

Рис. 2.6. Каналы изображения

Количество каналов по умолчанию для каждого режима изображения

В табл. 2.1 указано, какое количество каналов определяется по умолчанию для каждого режима представления цветов.

Таблица 2.1

Один | Три | Четыре
Bitmap | RGB | CMYK
Grayscale | Lab |
Duotone | Multichannel |
Indexed Color |  |

Рис. 2.7. Подменю Mode

Рис. 2.8. Подменю установки параметров пробного отпечатка

Режимы изображения

Изображение можно преобразовать, отобразить и редактировать в любом из восьми режимов: Bitmap (Битовая карта), Grayscale (Полутоновой), Duotone (Двутоно-вый), Indexed Color (Индексированный цвет), RGB, CMYK, Lab и Multichannel (Многоканальный). Просто выберите необходимый режим из подменю Image > Mode (Изображение > Режим) - см. рис. 2.7.

Для того чтобы воспользоваться недоступным режимом (его имя выглядит тусклым), сначала необходимо преобразовать изображение в другое представление. Например, если вы хотите преобразовать изображение в режим Indexed Color, оно должно находиться в режиме RGB или Grayscale.

Некоторые изменения режима изображения вызывают заметные сдвиги цвета; другие касаются лишь едва уловимых нюансов. Разительные перемены могут произойти при преобразовании изображения из режима RGB в режим CMYK, так как выводимые на печать цвета будут заменены насыщенными, яркими RGB-цветами. Точность соответствия цветов может уменьшиться, если многократно преобразовать изображение из режима RGB в CMYK и обратно.

Сканеры среднего и низкого класса обычно позволяют получить только RGB-изображения. Если вы создаете изображение, которое впоследствии будет распечатано, для ускорения редактирования и применения фильтров работайте с ним в режиме RGB, а затем, когда будете готовы вывести изображение на печать, преобразуйте его в представление CMYK. Для того чтобы предварительно просмотреть изображение в режиме CMYK таким, каким он будет на печати, воспользуйтесь командами подменю View > Proof Setup (Вид > Установки пробного отпечатка) (рис. 2.8) в сочетании с командами подменю View > Proof Colors (Вид > Цвета пробного отпечатка) или нажмите комбинацию клавиш Ctrl+Y.

Можно предварительно просмотреть изображение в режиме CMYK в одном окне и открыть второе окно, в котором то же изображение будет отображаться без предварительного преобразования в представление CMYK.

Некоторые преобразования вызывают объединение слоев, например преобразование в режим Indexed Color, Multichannel или Bitmap. При остальных преобразованиях, если вы хотите наверняка сохранить слои, установите флажок Don't Flatten (He объединять слои).

Сканеры последних моделей создают CMYK-изображения, и чтобы не потерять данные о цветах, этот режим не следует менять. Если для вас обременительно работать с такими большими файлами, можно использовать схему замены изображения на копии с более низким разрешением, сохранить команды с помощью палитры Actions и затем применить действие к изображению с высоким разрешением в режиме CMYK. Однако некоторые операции все равно придется производить вручную, например нанесение штрихов инструментом Brush.

Некоторые устройства вывода требуют, чтобы изображение было сохранено в определенном представлении. Доступность некоторых команд и опций инструментов в программе Photoshop также может меняться в зависимости от текущего режима изображения.

Далее вкратце рассказано о режимах изображения.

В режиме Bitmap (рис. 2.9, 2.11), пикселы либо на 100% белые либо на 100% черные, нет доступа к слоям, фильтрам, а также командам подменю Adjustments

Рис. 2.9. Изображение в представлении Bitmap, метод преобразования Diffusion Dither

Рис. 2.10. Изображение в представлении Grayscale

Рис. 2.11. Режим Bitmap

Рис. 2.12. Режим Grayscale

Рис. 2.13. Режим Indexed Color

Рис. 2.14. Режим RGB

Рис. 2.15. Режим CMYK

(Корректировки), кроме команды Invert (Обратить). Прежде чем преобразовать изображение в это представление, необходимо, чтобы оно имело представление Grayscale.

В режиме Grayscale (рис. 2.10, 2.12) пикселы могут быть черными, белыми и иметь до 254 оттенков серого. Если преобразовать цветное изображение в полутоновое, затем сохранить и закрыть, информация о яркости сохранится, но информация о цвете будет безвозвратно утеряна.

Изображение в режиме Indexed Color (см. рис. 2.13) содержит один канал, а в таблице цветов может быть максимум 256 цветов или оттенков (8-битовое представление цвета). Это максимальное число цветов, доступных в наиболее приемлемых для Web форматах GIF и PNG-8. Однако в программе Photoshop лучше использовать команду Save for Web (Сохранить с учетом особенностей Web) при подготовке графики для Web-браузеров. Зачастую при использовании изображений в мультимедийных приложениях бывает полезно уменьшать число их цветов до 8-битового представления. Также можно преобразовать изображение в режим Indexed Color, чтобы создать художественные цветовые эффекты.

Режим RGB - наиболее универсальный, так как только в этом режиме доступны все фильтры и опции инструментов в программе Photoshop (рис. 2.14). Некоторые видео и мультимедийные приложения могут импортировать RGB-изображения в формате Photoshop.

Photoshop - одна из немногих программ, которые позволяют отображать и редактировать изображение в режиме CMYK (рис. 2.15). Изображение можно преобразовать в этот режим, когда оно уже готово для печати на цветном принтере или когда необходимо выполнить цветоделение.

Режим Lab (рис. 2.16) имеет три канала, он был разработан для того, чтобы повысить совместимость между принтерами и мониторами при отображении цветов. Каналы содержат информацию о яркости и двух цветах: одном из гаммы от-зелено-го-к-красному и другом из гаммы от-сине-го-к-желтому. В представление Lab (или RGB) в программе Photoshop обычно преобразуются фотоизображения. Иногда файлы сохраняют в этом режиме для экспорта их в другие операционные системы.

Режим Duotone (рис. 2.17) соответствует методу печати, при котором используются две или более печатные формы для получения более насыщенного и глубокого цвета в полутоновом изображении.

Изображение в режиме Multichannel (рис. 2.18) состоит из нескольких полутоновых каналов с 256 оттенками цвета в каждом. Этот режим используется при печати некоторых полутоновых изображений. Кроме того, с помощью данного режима можно собрать отдельные каналы из различных изображений, прежде чем преобразовать новое изображение в цветное. При переходе в режим Multichannel сохраняются каналы заказного цвета (spot color channel). Если преобразовать изображение из режима.RGB в Multichannel, то каналы Red, Green и Blue будут преобразованы в Cyan, Magenta'n Yellow соответственно. В результате изображение может стать немного светлее, но значительных изменений не произойдет.

Режимы смешивания

Режим смешивания можно выбрать на панели опций, в палитре Layers или в диалоговых окнах Fill (Залить), Stroke (Очертить), Fade (Ослабить) или Fill Path (Залить контур). Режим смешивания, выбранный для инструмента или слоя, определяет, как инструмент или слой будут изменять пикселы, находящиеся под ними (далее эти пикселы называются «базовым цветом»). Слой смешивания (blend layer) -слой, для которого выбран какой-либо режим смешивания.

Рис. 2.16. Режим Lab

Рис. 2.17. Режим Duotone

Рис. 2.18. Режим Multichannel

Рис. 2.19. Режим смешивания Normal

Рис. 2.20. Режим смешивания Dissolve

Для того чтобы попеременно переключать режимы смешивания для выбранного инструмента, пользуйтесь сочетаниями клавиш Shift+«плюс» или Shift+«минус».

Если для целевого слоя на палитре Layers установлен флажок Lock transparent pixels (Блокировать прозрачные точки), то будут перекрашены или отредактированы только пикселы, но не прозрачные области.

Уровень непрозрачности

При выборе значения непрозрачности для инструмента не забудьте умножить это число на значение непрозрачности слоя, на котором вы работаете. Например, если вы выбрали непрозрачность 60% для инструмента Brush и при этом работаете на слое с непрозрачностью 50%, то в результате штрих кисти будет иметь 30% непрозрачности.

Характеристики режимов смешивания

В режиме Normal (Нормальный) все базовые цвета-изменяются (рис. 2.19).

Для изображения, имеющего представление Bitmap или Indexed Color, режим смешивания Normal называется Threshold (Пороговый).

В режиме Dissolve (Растворение) создается похожая на известковую, сухая текстура, имеющая цвет рисования или слоя смешивания (рис. 2.20). Чем выше значение параметров нажима или непрозрачности, тем более твердым кажется мазок кисти.

Режим Behind (Позади) не доступен для слоев. Изменены будут только прозрачные области, а не пикселы базового цвета (выключена опция Lock transparent pixels (Блокировать прозрачные точки)). Получается, словно вы рисуете на изнаночной стороне чистой ацетатной ткани. Очень удобный режим для создания теней. Однако его нельзя использовать для фона.

Режим Clear (Очистка) не доступен для слоев. В том месте, где наносятся штрихи, базовый цвет становится прозрачным (выключена опция Lock transparent pixels (Блокировать прозрачные точки)). Этот режим можно применить только для многослойного изображения при использовании инструментов Paint Bucket (Ведро с краской), Line (Линия) с включенной опцией Fill Region (Залить область) либо при применении команды Fill (Залить), Stroke (Очертить), Fill Path (Залить контур) или Stroke Path (Очертить контур). Данный режим нельзя использовать по отношению к фону.

В режиме Darken (Затемнить) те базовые цвета, которые светлее цвета рисования или слоя смешивания, будут изменены, другие цвета останутся в прежнем виде (рис. 2.21). Воспользуйтесь данным режимом, если цвет рисования темнее базового цвета, который вы хотите изменить.

В режиме Multiply (Умножение) темный цвет рисования или слоя смешивания замещает более светлые области базового цвета, чтобы воспроизвести эффект затемнения (рис. 2.22). Светлый цвет рисования или слоя смешивания тоже затемняет базовый цвет, но не так сильно. Очень хороший режим при создании полупрозрачных теней.

В режиме Color Burn (Форсирование цвета) темный цвет рисования или слоя смешивания затемняет базовый цвет, если же цвет рисования или слоя смешивания светлый, то базовый цвет будет немного осветлен (рис. 2.23).

Рис. 2.21. Режим смешивания Darken

Рис. 2.22. Режим смешивания Multiply

Рис. 2.23. Режим смешивания Color Burn

Рис. 2.24. Режим смешивания Linear Burn

Рис. 2.25. Режим смешивания Lighten

Рис. 2.26. Режим смешивания Screen

Рис. 2.27. Режим смешивания Color Dodge

Рис. 2.28. Режим смешивания Linear Dodge

Результат смешивания в режиме Linear Burn (Линейное форсирование) показан на рис. 2.24.

В режиме Lighten (Осветлить) те базовые цвета, которые темнее цвета рисования или слоя смешивания, будут изменены, другие же останутся прежними (рис. 2.25). Воспользуйтесь данным режимом, если цвет рисования светлее того базового цвета, который вы хотите изменить.

В режиме Screen (Экран) светлый цвет рисования или слоя смешивания замещает темные области базового цвета, таким образом создается более светлый, обесцвеченный базовый цвет (рис. 2.26). Темный цвет рисования или слоя смешивания тоже осветляет базовый цвет, но не так сильно.

В режиме Color Dodge (Комбинирование цветов) базовый цвет осветляется, если цвет рисования или слоя смешивания светлый, в противном случае базовый цвет лишь немного осветляется (рис. 2.27).

Результат смешивания в режиме Linear Dodge (Линейное комбинирование) показан на рис. 2.28.

В режиме Overlay (Наложение) затемняются темные области и осветляются светлые области базового цвета (рис. 2.29). При этом сохраняется информация о яркости. Черный и белый цвета не изменяются, так что в изображении остаются все детали.

В режиме Soft Light (Мягкий свет) осветляется базовый цвет, если цвет рисования или слоя смешивания светлый (рис. 2.30). Если цвет рисования или слоя смешивания темный, базовый цвет затемняется. При этом сохраняются значения яркости базового цвета. При использовании этого режима создается мягкий, едва уловимый эффект освещения.

В режиме Hard light (Яркий свет) базовый цвет обесцвечивается, если цвет рисования или слоя смешивания светлый, и затемняется, если цвет рисования или слоя смешивания темный (рис. 2.31). Увеличивается контраст между базовым цветом и цветом слоя. Очень хороший режим при создании бликов и сложных эффектов.

Результаты смешивания в режимах Vivid Light (Яркий свет), Linear Light (Линейный свет), Pin Light (Точечный свет) показаны на рис. 2.32-2.34.

В режиме Difference (Различие) создается эффект негатива для базового цвета (рис. 2.35). Если цвет рисования или слоя смешивания светлый, то эффект негатива (или инвертирования) будет более явным. При использовании данного режима происходит заметное искажение цвета.

В режиме Exclusion (Исключение) в тех местах, где цвет рисования или слоя смешивания темный, базовый цвет становится серым. Там же, где цвета светлые, базовый цвет инвертируется (рис. 2.36).

В режиме Hue (Тон) тон цвета берется со слоя смешивания. Насыщенность и яркость базового цвета при этом не меняются.

В режиме Color (Цвет) применяются тон и насыщенность цвета слоя смешивания. Значения яркости базового цвета не меняются, так что детали изображения остаются видны. Хороший режим для легкого окрашивания изображения.

В режиме Saturation (Насыщенность) насыщенность цвета берется со слоя смешивания. При этом тон и яркость базового цвета не меняются.

В режиме Luminosity (Яркость света) значения яркости базового цвета замещаются значениями яркости цвета рисования или слоя смешивания. При этом тон и насыщенность базового цвета не затрагиваются.

Рис. 2.29. Режим смешивания Overlay

Рис. 2.30. Режим смешивания Soft Light

Рис. 2.32. Режим смешивания Vivid Light

Рис. 2.33. Режим смешивания Linear Light

Рис. 2.34. Режим смешивания Pin Light

Рис. 2.35. Режим смешивания Difference

Рис. 2.36. Режим смешивания Exclusion

Управление цветом

Различные устройства ввода/вывода, а также компьютерные программы по-разному обрабатывают цвет, поэтому у вас может возникнуть множество проблем. Например, если открыть графический объект в нескольких различных программах по обработке изображений и в Web-браузере, то в каждом случае цвета изображения будут выглядеть по-разному. При этом ни в одной программе они могут не соответствовать цветам картинки, изначально вами отсканированной. Распечатайте изображение, и вполне вероятно, что результат также будет отличаться от всех виденных вами вариантов. Иногда такие различия могут показаться незначительными. Но при других обстоятельствах подобные изменения цвета способны нанести серьезный ущерб вашей разработке и превратить прекрасный проект в катастрофу.

Многие из этих проблем помогает решить система управления цветом, интерпретирующая цвета. Хорошая система знает, как устройства ввода/вывода и различные программы воспринимают цвет, и может корректировать цвет при перемещении изображения между ними, так что оно будет одинаковым во всех программах и при выводе на любое устройство. Цветовой профиль представляет собой математическое описание цветового пространства устройства. Программы Illustrator 10 и Photoshop 7 используют профили ICC (International Color Consortium - международный консорциум цвета), так что вашей системе управления цветом предоставляется полная информация о том, как определенное устройство обрабатывает цвет.

Большинство средств управления цветом в программе Photoshop находится в диалоговом окне Color Settings (Характеристики цвета), вызываемом с помощью меню Edit (Правка). В этом окне дан список предопределенных установок для различных ситуаций, возникающих в издательском деле, включая допечатную обработку и вывод в сеть.

Если в другой программе компании Adobe (например, Illustrator 10) были изменены текущие характеристики цвета, то при загрузке программы Photoshop 7 может появиться предупреждающее сообщение (рис. 2.37). Щелкните по кнопке Synchronize (Синхронизовать), чтобы характеристики цвета в программе Photoshop пришли в соответствие с характеристиками цвета другой программы.

Программа Photoshop 7 поддерживает систему управления цветом для файлов RGB и CMYK, для файлов, использующих пла-шечные цвета, и файлов с полутоновыми изображениями. Эта система указывает программе, как работать с цветом при открытии графических файлов, имеющих или не имеющих цветовые профили.

Проконсультируйтесь насчет управления цветом со службой допечатной подготовки (если таковая имеется) организации, для которой вы готовите издательские материалы. Убедитесь, что вы правильно работаете с цветом.

Если вы хотите использовать один и тот же графический объект для разных целей, например для сети и для печати, то система управления цветом поможет вам и в этом.

Рис. 2.37. Окно с предупреждением о необходимости согласования текущих характеристик цвета

Рис. 2.38. Окно утилиты Adobe Gamma в режиме Step by Step

Калибровка

Первое, что надо сделать, чтобы обеспечить соответствие цветов, - калибровка монитора. В процессе этой операции вы задаете пространство RGB-цветов, отображаемых вашим монитором, с помощью утилиты Adobe Gamma, которая автоматически устанавливается вместе с программой Photoshop и другими приложениями компании Adobe. При этом будут откорректированы контраст и яркость, гамма, баланс цвета и белая точка монитора.

Утилита Adobe Gamma создаст ICC-npo-филь, используемый программой Photoshop в качестве рабочего RGB-пространства, что позволит точно воспроизводить цвета изображений.

Произвести калибровку монитора и сохранить характеристики в виде IСС-профиля можно только один раз для всех приложений.

  1. Дайте монитору 30 минут для разогрева, чтобы отображение цветов стабилизировалось, установите постоянное освещение в комнате.
  2. Сделайте цвет рабочего стола серым.
  3. Система Windows 98/ME: выберите команду меню Start > Settings > Control Panels (Пуск > Установки > Панель управления), затем откройте окно утилиты Adobe Gamma.
  4. Система Windows NT/2000/XP: запустите утилиту Adobe Gamma.cpl из папки C:\Program Files\Common Files\Adobe\ Calibration или дважды щелкните по пиктограмме Adobe Gamma в папке Photoshop 7\Goodies\ Calibration.
  5. Выберите режим Step-by-Step (Wizard)(По шагам (Мастер)) (рис. 2.38) или включите режим Control Panel (Панель управления), чтобы просто выбрать характеристики в окне без каких-либо пояснений. (Если окно Adobe Gamma открывается непосредственно, вы можете пропустить этот шаг.)

Щелкните по кнопке Next (Далее). При использовании режима Wizard (Мастер) эта кнопка позволяет переходить от одного диалогового окна к другому.

  6. Оставьте установленный по умолчанию ICC-профиль без изменений или щелкните по кнопке Load (Загрузить) и выберите тот профиль, который наиболее точно соответствует вашему монитору (рис. 2.39).
  7. Увеличьте значения яркости и контраста; сделайте значение контраста максимальным и подкорректируйте яркость, чтобы чередующиеся серые квадраты на верхней панели стали как можно более темными, но не черными; в это время нижняя панель должна оставаться белой.
  8. В группе Phosphors (Люминофоры) выберите тип монитора либо укажите вариант Custom (По выбору пользователя) и введите координаты цветности, которые были определены производителем вашего монитора.
  9. Серый квадратик представляет полутоновой режим работы монитора. Откорректируйте гамму, передвигая ползунок таким образом, чтобы цвет меньшего однотонного квадратика соответствовал цвету внешнего «полосатого» квадрата. Есть и еще один способ, который, возможно, покажется вам более простым: снимите флажок View Single Gamma Only (Отображать только гамму) и откорректируйте отдельно красный, зеленый и синий цвета.
  10. В поле Desired (Желательно) выберите принимаемое по умолчанию значение для вашей системы (для системы Windows это значение равно 2.2).

Рис. 2.39. Окно утилиты Adobe Gamma в процессе калибровки-при выключенной опции View Sincjle Gamma Only

  11. В поле Hardware (Аппаратура) укажите белую точку для монитора, которая была определена производителем монитора, или щелкните по кнопке Measure (Измерение) и следуйте инструкциям.
  12. В поле Adjusted (Настроенный) выберите Same as Hardware (Как и аппаратура) или, если знаете температуру, при которой будет видно изображение, вы можете выбрать значение из всплывающего меню либо выбрать вариант Custom и ввести температуру.

Эта опция доступна не для всех мониторов.

  13. 3акройте окно Adobe Gamma и сохраните профиль в папку Windows\System\Color с расширением .icm.

Программа Photoshop может использовать этот профиль в качестве рабочего RGB-пространства в диалоговом окне Color Settings (подробнее см. далее).

Если изменить значения яркости или контраста монитора либо изменить освещенность комнаты, необходимо заново произвести калибровку монитора. Также помните, что описанный метод является простейшим. Калибровка на профессиональном уровне требует более точного измерения характеристик монитора с помощью дорогих устройств, например колориметра и спектрометра.

Предопределенные наборы характеристик для управления цветом

  1. Откройте окно Edit > Color Settings (Правка > Характеристики цвета).
  2. Из всплывающего меню Settings (Характеристики) выберите желаемую конфигурацию:
    • Color Management Off (Нет управления цветом) имитирует поведение приложений, не поддерживающих управление цветом. Эта опция -неплохой выбор для проектов, предназначенных для видео или презентации на экране;
    • Emulate Photoshop 4 (Эмуляция Photoshop 4) использует те же приемы работы с цветом, что и Photoshop 4 и более ранние версии. При выборе этой опции цветовые профили не распознаются, и их нельзя сохранить;
    • U.S. Prepress Defaults (Выполняемая по умолчанию предпечатная подготовка в США) использует характеристики, основанные на обычных правилах печати в США. При выборе вариантов European или Japanese Prepress рабочее CMYK-пространство изменяется в соответствии со стандартами печати для данного региона;
    • Photoshop 5 Default Spaces (Установленные по умолчанию рабочие пространства Photoshop 5) использует те же рабочие пространства, что и установленные по умолчанию для Photoshop 5;
    • Web Graphics Defaults (Принимаемые по умолчанию характеристики графики для Web) управляет цветом с учетом последующего вывода в сеть. Использует RGB-профиль.

В диалоговом окне Color Settings (Характеристики цвета), показанном на рис. 2.40, есть область Description (Описание), где отображается ценная информация о той опции, на которую в данный момент наведен курсор. Воспользуйтесь этой уникальной возможностью!

Программа Photoshop 7 позволяет задавать характеристики цвета для конкретного документа, то есть каждый открытый документ содержит профиль для контроля за тем, как предварительно отображается документ и как происходит управление цветом при выводе документа. Текущее рабочее пространство используется для предварительного просмотра документа, у которого нет своего встроенного профиля. Теперь программа Photoshop больше не открывает в принудительном порядке все документы с использованием текущего рабочего пространства. Это существенное улучшение в системе управления цветом.

Возможные параметры RGB-пространства

Брюс Фрейзер (Bruce Fraser) предлагает использовать следующий профиль монитора и координаты основных цветов (табл. 2.2):

  • гамма 2.2;
  • белая точка 6500К;
  • люминофоры Custom.

Таблица 2.2. Координаты основных цветов

 | X | Y
Красный | 0,6400 | 0,3300
Зеленый | 0,2800 | 0,6500
Синий | 0,1500 | 0,0600

Выбор характеристик для рабочего пространства

Вы можете выбрать рабочие цветовые пространства, которые определяют, как будет обрабатываться документ, в котором цвет имеет представление RGB и CMYK. (Насчет характеристик CMYK посоветуйтесь в отделе технического обслуживания.) Также можно указать режим растискивания точек (dot gain) и плашечный цвет (spot color) или гамму для полутоновых изображений. Далее рассказано о характеристиках предопределенных RGB-пространств.

Рис. 2.40. Диалоговое окно Color Settings с выбранной опцией Web Graphics Defaults

Цветовое пространство Adobe RGB (1998) предоставляет широкий диапазон цветов. Этот вариант будет наилучшим, если вы собираетесь преобразовывать изображение из режима RGB в режим CMYK, но для работы в сети лучше выбирать другую опцию.

Опция sRGB IEC61966-2.1 - хороший выбор для работы в сети, так как данное пространство отражает характеристики типичного монитора. Многие производители аппаратуры и программного обеспечения используют его в качестве пространства, принимаемого по умолчанию для сканеров, принтеров невысокого класса или младших моделей и программ. Не стоит использовать sRGB IEC61966-2.1 при подготовке материала к печати, лучше воспользоваться пространствами Apple RGB или Color Match RGB. Пространство Apple RGB полезно в тех случаях, когда планируется отображать файлы на Mac-мониторах, так как оно отражает характеристики стандартных 13-дюймовых мониторов компании Apple. Также это хороший выбор при работе с файлами, созданными при помощи старых версий программ, например Adobe Photoshop 4 и более ранних.

Пространство ColorMatch RGB дает меньшее количество цветов, нежели Adobe RGB (1998). Тем не менее, оно полностью соответствует цветовому пространству мониторов Radius Pressview и полезно в издательском деле.

Если выбрать опцию Monitor RGB, рабочее пространство RGB будет соответствовать профилю монитора. Это очень полезная характеристика, если знаешь, что другие приложения, которые будут использоваться при разработке проекта, не поддерживают систему управления цветом. Помните, если вы поделитесь вашей разработкой с другим пользователем, то в качестве рабочего пространства RGB будет использован профиль его монитора, и соответствие цветов может нарушиться.

Создание собственной системы управления цветом

Можно выбрать собственную систему управления цветом, которая будет подсказывать программе Photoshop, как обрабатывать изображения, не соответствующие текущим характеристикам цвета.

  1. Откройте диалоговое окно Edit > Color Settings (рис. 2.41).
  2. Из всплывающего меню Settings выберите какие-либо предопределенные установки, отличные от Emulate Photoshop 4.
  3. Укажите стратегию управления цветом в группе Color Management Policies:
    • если выбрать Off (Нет), программа Photoshop не будет управлять цветом импортированных или открытых файлов;
    • выберите вариант Preserve Embedded Profiles (Сохранять встраиваемые профили), если предполагаете работать с документами, для которых как требуется, так и не требуется управление цветом. В результате с каждым файлом будет связан цветовой профиль. Помните, что в программе Photoshop 7 у каждого открытого документа может быть свой собственный профиль;
    • выберите Convert to Working Space (Преобразовать в рабочее пространство), если хотите, чтобы все документы отражали одно и то же цветовое рабочее пространство. Это самый лучший выбор для работы в сети;
    • в строке Profile Mismatches (Несоответствие профилей) надо поставить флажок Ask When Opening (Спрашивать при открытии), чтобы программа Photoshop выводила сообщение, если цветовой профиль открываемого файла не соответствует выбранному рабочему пространству. При выборе этой опции можно заменить систему управления цветом при открытии документа;
    • поставьте флажок Ask When Pasting (Спрашивать при вставке), чтобы программа Photoshop выводила сообщение, если возникает несоответствие профилей при вставке цветных данных в документ. При выборе этой
    • опции можно заменить имеющуюся систему управления цветом при4 вставке данных;
    • для файлов без профилей в строке Missing Profiles (Отсутствие профиля) поставьте флажок Ask When Opening (Спрашивать при открытии), тогда программа Photoshop будет выводить сообщение с предложением прикрепить профиль к файлу.
  4. Щелкните по кнопке ОК.

Настройка параметров операции преобразования

  1. Откройте диалоговое окно Edit > Color Settings.
  2. Установите флажок Advanced Mode (Расширенный режим) - см. рис. 2.42.
  3. В группе Conversion Options (Опции преобразования) выберите значение параметра Engine (Движок) системы управления цветом, который будет использоваться для преобразования цветов различных цветовых пространств: Adobe (АСЕ) использует систему управления цветом и цветовой движок Adobe; Microsoft ICM использует систему, предоставляемую Windows 98 и Windows 2000. Другие СММ можно выбрать, если предполагается работать с какими-либо определенными устройствами вывода.

Рис. 2.41. Диалоговое окно Color Settings

  4. Выберите значение параметра Intent (Цель), чтобы определить, как будут изменяться цвета при переходе из одного цветового пространства в другое:
    • Perceptual (Восприятие) - изменение цветов происходит таким образом, чтобы они казались естественными для человеческого глаза, хотя сами цвета меняются; хороший выбор для изображений с множеством оттенков;
    • Saturation (Насыщенность) - при переходе сохраняются живые цвета, хотя точность совпадения цветов может и нарушиться; хороший выбор для диаграмм и бизнес-графиков; Absolute Colorimetric (Абсолютный колориметрический) - при переходе сохраняются без изменения цвета, входящие в целевую цветовую палитру, но сботношение между цветами, не входящими в данную гамму, изменяется, так как программа все-таки пытается сохранить и эти цвета;

Рис. 2.42. Установка опций преобразования в диалоговом окне Color Settings

    • Relative Colorimetric (Относительный колориметрический) - принимаемые по умолчанию значения для всех предопределенных установок те же, как и в случае Absolute Colorimetric, за исключением одного: белая точка или самый яркий свет исходного цветового пространства сравнивается с белой точкой целевого пространства, и цвета соответственно сдвигаются. Точность результата зависит от точности данных о белой точке в профиле изображения.

Различия, обусловленные выбором из перечисленных выше вариантов, будут видны только при печати или преобразовании изображения в представление другого рабочего пространства.

Установите флажок Use Black Point Compensation (Использовать замену черной точки), если хотите откорректировать различия между черными точками разных цветовых пространств. При выборе этой опции весь диапазон цветов исходного пространства будет распределен по всему диапазону цветов целевого пространства. Если же не поставить здесь флажок, то черный цвет может стать серым.

Рекомендуем также устанавливать этот флажок при переходе из пространства RGB в CMYK, но обязательно проконсультируйтесь с типографией, если собираетесь осуществить преобразование изображения из CMYK в CMYK.

Установите флажок Use Dither (Использовать размывание), если хотите, чтобы программа Photoshop смешивала цвета при преобразовании между различными цветовыми пространствами изображений, каждый канал цо-торых представлен восьмью битами. Иногда при преобразовании изображения из одного пространства в другое цвета, отсутствующие в целевом пространстве, утрачиваются, и в итоге могут появиться полосы или какие-либо другие дефекты. При выборе этой опции программа Photoshop будет смешивать несколько похожих цветов, чтобы заменить недостающий цвет. Таким образом, изображение будет более гладким, но может увеличиться размер файла.

Рекомендуем устанавливать флажок Use Dither при преобразовании изображений, подготовленных для печати, между пространствами RGB и CMYK, но лучше выключить эту опцию для Web-графики. В диалоговом окне Save for Web (Сохранить с учетом особенностей Web) представлены более точные средства контроля за сглаживанием изображения.

  5. Щелкните по кнопке ОК.

Если сохранять файл в формате, который поддерживает встроенные профили (например, в формате Photoshop или PDF), можно установить флажок Embed ICC Profile (Встроить профиль ICC), чтобы сохранить профиль в документе.

Для того чтобы сохранить выбранные характеристики для дальнейшего использования, в диалоговом окне Color Settings щелкните по кнопке Save (Сохранить). Если хотите, чтобы файл с этими характеристиками присутствовал во всплывающем меню Settings, то сохраните его в папке \Program Files\Common Files\Ado-be\Color\Settings. Когда вы захотите воспользоваться сохраненными характеристиками, выберите имя файла во всплывающем меню Settings. Для того чтобы загрузить файл характеристик, не содержащийся в папке Settings (то есть отсутствующий в меню Settings), в диалоговом окне Custom Settings (Характеристики по выбору пользователя) щелкните по кнопке Load (Загрузить).

Изменение или удаление цветового профиля документа

Позднее вы можете решить, что хотите изменить цветовой профиль документа или вообще удалить его. Например, захотите вывести документ определенным образом и соответственно подкорректиро-вать профиль. Также эта необходимость может возникнуть, если вы изменили мнение насчет параметров системы управления цветом. Команда Assign Profile (Определить профиль) позволяет проинтерпретировать данные о цвете непосредственно в цветовом пространстве нового профиля (или в отсутствие такового), в результате цвета могут заметно измениться. Однако при использовании команды Convert to Profile (Преобразовать профиль) номера цветов вычисляются заново прежде, чем будет применен новый профиль, - так программа пытается сохранить текущий вид документа. В любом случае не снимайте флажок Preview (Предварительный просмотр), чтобы иметь возможность заранее видеть, что получится.

  1. Выберите команду меню Image > Mode > Assign Profile (Изображение > Режим > Определить профиль) -см. рис. 2.43.
  2. Поставьте переключатель в положение Don't Color Manage This Document (He управлять цветом этого документа), чтобы удалить цветовой профиль, или отметьте строку Working (Рабочий), где также указан цветовой режим документа и название используемого рабочего пространства, чтобы связать рабочее пространство с документом, у которого нет какого-либо профиля либо профиль отличается от рабочего пространства. Если переключатель установлен в положение Profile (Профиль), можно определить другой профиль для документа. Выберите из всплывающего меню какой-либо профиль.
  3. Щелкните по кнопке ОК.

Если сохранить (или экспортировать) файл в формате, поддерживающем встроенные профили, можно установить или не устанавливать опцию Embed ICC Profile (Встроить профиль ICС). Лучше, чтобы эта опция была включена до тех пор, пока не появится какая-либо особая причина для ее отмены.

Связанный с файлом профиль будет отображаться в разделе Source Space (Исходное пространство) окна File > Print (Файл > Печать). Профиль документа также будет показан в строке состояния, если из всплывающего меню этой строки, расположенной внизу окна приложения или документа, выбрать команду Document Profile (Профиль документа).

Рис. 2.43. Диалоговое окно Assign Profile

Преобразование цветового профиля документа

  1. Откройте диалоговое окно Image > Mode > Convert to Profile (Изображение > Режим > Преобразовать профиль) - см. рис. 2.44.
  2. Из всплывающего меню Destination Space (Целевое пространство) выберите то пространство, в которое вы хотите преобразовать документ. Это не должно быть текущее рабочее пространство.

Подробнее о характеристиках преобразования см. раздел «Настройка параметров операции преобразования» в этой главе.

Тестирование цвета

Определение системы управления цветом -это, конечно, важный и хороший процесс, но порой вам достаточно знать, как будет выглядеть документ при печати или на мониторах Windows или Macintosh в качестве части Web-странички. Проверить это можно программным образом. Хотя предлагаемый метод менее точен, чем непосредственная распечатка изображения или просмотр его на различных мониторах, он дает основное представление о том, как ваше творение будет смотреться при различных значениях параметров.

  1. Из подменю View > Proof Setup (Вид > Установки пробного отпечатка) выберите тип представления изображения, который вы хотите имитировать:
    • Custom (По выбору пользователя) позволит с помощью диалогового окна Proof Setup создать цветовую модель для определенного устройства вывода (рис. 2.45). Для этого из всплывающего меню Profile (Профиль) выберите цветовой профиль для данного устройства вывода, затем установите или снимите флажок Preserve Color Numbers (Сохранять номера цветов), если эта опция доступна. При установленном флажке изображение будет выглядеть так, как будто оно без преобразования выводится в цветовом пространстве пробного отпечатка. Если же снять флажок, то программа будет имитировать преобразование пространств, и придется задать желаемые параметры преобразования в поле Intent, см. выше раздел «Настройка параметров операции преобразования»;

Рис. 2.44. Диалоговое окно Convert to Profile

Рис. 2.45. Диалоговое окно Proof Setup

Опция Preserve Color Numbers (Сохранять номера цветов) доступна только тогда, когда цветовой режим текущего файла совпадает с профилем устройства вывода, выбранным в диалоговом окне Proof Setup (Установки пробного отпечатка). Например, если цветовой режим документа - RGB и выбранный профиль отпечатка также RGB, то опция Preserve Color Numbers будет доступна.

    • установите в группе Simulate (Имитировать) флажок Paper White (Белая бумага), чтобы увидеть тень, появляющуюся при печати, как это определено в профиле документа;
    • установите в группе Simulate (Имитировать) флажок Ink Black (Черная краска), чтобы увидеть весь диапазон серых оттенков, определенных в профиле документа;
    • в случае выбора опции Working CMYK (Рабочий CMYK), пробный отпечаток будет создан на основе рабочего пространства CMYK, как определено в диалоговом окне Color Settings;
    • если вы выберете варианты Working Cyan Plate (Рабочий голубой фотошаблон), Working Magenta Plate (Рабочий фуксиновый фотошаблон), Working Yellow Plate (Рабочий желтый фотошаблон), Working Black Plate (Рабочий черный фотошаблон) или Working CMY (Рабочий CMY), то пробный отпечаток будет сделан с использованием указанной краски, как определено в текущем рабочем пространстве CMYK;
    • варианты Macintosh RGB или Windows RGB предопределяют, что пробный отпечаток будет сделан с использованием профиля монитора Macintosh или Windows;
    • если выбрать вариант Monitor RGB (Монитор RGB), при выводе пробного отпечатка будет использован профиль вашего монитора.
  2. Автоматически будет установлен режим View > Proof Colors (Вид > Цвета пробного отпечатка), так чтобы цвета можно было предварительно просмотреть. Снимите этот флажок, если не хотите делать предварительного отпечатка.

Щелкните по кнопке Save (Сохранить), чтобы сохранить выбранные параметры пробного отпечатка. Сохраненные установки находятся в подменю P roof Setup.

О том, как настраивать характеристики системы управления цветом в окнах Print Options (Параметры печати) и Print (Печать), см. главу 22.


  • Глава 20. Автоматизация
    • Действия
      • Создание нового набора действий
      • Запись действия
      • Вставка паузы в действие
      • Включение и отключение команд при воспроизведении действия
      • Применение действия к изображению
      • Применение действия к группе изображений
      • Именование файлов при пакетной обработке
      • Создание дроплета из действия
      • Добавление команды в действие
      • Удаление команды из действия
      • Контроль за выполнением действия с помощью модальных окон
      • Изменение порядка команд
      • Полная перезапись действия с помощью изменения установок диалогового окна
      • Изменение одной команды, входящей в действие
      • Копирование действия
      • Удаление всего действия
      • Сохранение набора действий в файле
      • Загрузка дополнительных наборов действий в палитру Actions
      • Замена текущего набора действий другим набором
      • Выполнение одного действия в рамках другого
    • Другие команды автоматизации
      • Изменение режима отображения
      • Создание контактного листа
      • Подгонка размеров изображения по ширине и высоте
      • Преобразование файла формата PDF в формат программы Photoshop PSD
      • Пакет рисунков
      • Создание Web-галереи

Глава №20.

Автоматизация

Действие (action) представляет собой записанную последовательность команд меню, операций, выполняемых с помощью инструментов, или функций по редактированию изображения. Причем эта последовательность может быть воспроизведена как для одного, так и для нескольких файлов. Действия особенно полезны, когда необходимо применить одни и те же команды редактирования последовательно к нескольким изображениям, например последовательность фильтров или команд из подменю Adjustments (Корректировки). Также можно сохранить последовательность коротких шагов и вложить их в одно действие, чтобы подготовить несколько изображений к печати или преобразовать их в другой формат или режим.

Действие обычно выполняется нажатием одной клавиши, хотя может состоять из невероятно сложного набора команд, которые затрагивают другие действия или обрабатывают целую группу изображений. Действия помогают сберечь от пары секунд до нескольких часов вашего рабочего времени в зависимости от области их применения. Начните с записи нескольких элементарных действий. Затем можно будет программировать более сложные процессы - ваша работа только ускорится.

Действия создаются в двух программах: Photoshop и ImageReady. С помощью палитры Actions (Действия), находящейся в режиме списка (или редактирования), можно исключать команду, включать или выключать паузу для ввода в диалоговое окно, изменять порядок команд, записывать дополнительные команды, удалять команды и записывать действия и/или наборы действий в файл. На рис. 20.1 показано, как выглядит палитра Actions по умолчанию (при загрузке). Палитра Actions имеет также кнопочный режим (рис. 20.2). Чтобы включить/выключить его, выберите пункт Button Mode (Кнопочный режим) в меню палитры Actions. Цвета кнопок и «горячие» клавиши в этом режиме отображаются так, как было указано в диалоговом окне Action Options (Опции действий).

Каждому действию может быть сопоставлена клавиша. Также получить доступ к действию можно посредством так называемых дроплетов (droplet) - маленьких приложений, созданных из действий. Перетаскивание файла или папки с файлами на пиктограмму дроплета активизирует действие.

Сделайте снимок изображения, прежде чем воспроизводить действие. Благодаря этому можно будет быстро вернуть изображение к первоначальному состоянию и не придется отменять выполненные шаги.

Чтобы развернуть или свернуть полный список шагов, входящих в заданное действие, нажмите клавишу Alt и в палитре Actions (Действия), находящейся в режиме списка, щелкните по стрелке в виде треугольника (он повернут вправо).

Рис. 20.1. Палитра Actions в режиме списка

Рис. 20.2. Палитра Actions в кнопочном режиме

Рис. 20.3. Кнопка Create New Action

Рис. 20.4. Поле для ввода имени набора

Рис. 20.5. Кнопка Create New Action

Рис. 20.6. Ввод имени действия

Действия

Действия сохраняются в специальных наборах на палитре Actions. Создание наборов - удобный способ организации действий, предназначенных для выполнения определенной задачи.

Создание нового набора действий

  1. Щелкните по кнопке Create New Action (Создать набор действий) в нижней части палитры Actions (Действия) - см. рис. 20.3.
  2. Введите имя набора (рис. 20.4) и щелкните по кнопке ОК.

При создании какого-либо действия сохраняются используемые вами команды. Все сохраненные команды появятся с некоторым смещением в списке созданного действия на палитре Actions.

Некоторые операции, например нанесение штрихов кистью, нельзя записать.

Запись действия

  1. Откройте изображение или создайте новое. Для большей безопасности экспериментируйте с записью и воспроизведением какого-либо действия, используя копию файла.
  2. Щелкните по кнопке Create New Action (Создать действие) в нижней части палитры Actions (Действия) показанной на рис. 20.5, или выберите команду New Action в меню палитры.
  3. Введите имя действия (рис. 20.6).
  4. По желанию. В диалоговом окне New Action (Создать действие) выберите для заданного действия какую-либо функциональную клавишу в поле Function Key (Функциональная клавиша) и/или цвет в поле Color (Цвет). Выбранный цвет будет отображаться только в кнопочном режиме.
  5. Щелкните по кнопке Record (Записать).
  6. Выполните серию команд, которые необходимо записать в виде действия, как при редактировании изображения. При вводе значений переменных в диалоговом окне команды и последующем щелчке по кнопке ОК эти значения также будут записываться. Если вы передумали и не хотите записывать введенное значение, щелкните по кнопке Cancel (Отмена).
  7. Щелкните по кнопке Stop (Стоп) или нажмите клавишу Esc, чтобы завершить запись действия.
  8. Теперь созданное действие появится в списке на палитре Actions (Действия). Щелкните по треугольной стрелке (режим списка), чтобы свернуть список шагов, входящих в данное действие.

Возможности при записи действия

Ниже приведен перечень команд, инструментов и функций, которые можно включить в записываемое действие.

  • инструмент Slice (Ломтик);
  • палитра Swatches (Образцы);
  • инструмент Magic Eraser (Волшебный ластик);
  • палитра Color (Цвет);
  • инструмент Shape (Фигура);
  • палитра Channels (Каналы);
  • инструмент Eyedropper (Пипетка);
  • палитра Styles (Стили);
  • выбор опций инструмента;
  • установка некоторых значений в окне Preferences.

Все относительно

Запись операции, которая зависит от положения какого-либо объекта (например, операции выделения, использования инструмента Slice (Ломтик), градиента, «волшебной палочки», контура или заметок) включает в себя текущие единицы измерения. Единицы измерения могут быть абсолютными (дюйм или цицеро) или относительными (процент). Операция, записываемая с использованием абсолютных величин, не может быть применена к изображению, которое меньше по размеру того, что использовалось при записи операции. В то время как операцию, использующую относительные величины, можно применять к изображению, имеющему другие единицы измерения и другой размер.

В меню палитры выберите команду Action Options (Опции действия), откроется диалоговое окно, в котором можно переименовать действие, а также изменить соответствующие ему функциональные клавиши или цвет.

Включите в действие команду Save (Сохранить) с выводом предупреждения об этом При использовании команды Save As (Сохранить как) убедитесь, что имя файла не изменится. Возможно, вы захотите установить паузу для диалогового окна Save, чтобы предотвратить перезапись существующих файлов (см. ниже). Как удалить команду Save или любую другую, рассказано далее.

Рис. 20.7. Ввод информационного сообщения

Рис. 20.8. Окно сообщения с кнопкой Continue

Если не установлен флажок Allow Continue (Разрешить продолжение), то можно щелкнуть по кнопке Stop (Стоп) в любой момент воспроизведения, а затем по кнопке Play (Проиграть) на палитре Actions (Действия), чтобы возобновить выполнение.

Вставка паузы в действие

В действие можно вставить паузу, при этом воспроизведение будет прерываться, что позволит выполнять операции, которые невозможно записать (например, нанесение штрихов кистью и рисование случайным образом расположенных деталей). Когда выполнение таких операций будет завершено, надо щелкнуть по кнопке Play (Проиграть) во второй раз, и воспроизведение будет продолжено. Во время паузы можно выводить какое-либо информационное или предупреждающее сообщение.

  1. При создании действия остановитесь в том месте, где необходимо сделать паузу. Для уже существующего действия щелкните по имени команды, после которой необходимо вставить паузу.
  2. В меню палитры Actions (Действия) выберите команду Insert Stop (Вставить паузу).
  3. Введите информационное или предупреждающее сообщение для пользователя, который будет воспроизводить заданное действие (рис. 20.7). Не лишним будет и напоминание о том, что после выполнения некоторых операций необходимо щелкнуть по кнопке Play (Проиграть) на палитре Actions (Действия), чтобы возобновить воспроизведение. Это сообщение появится только тогда, когда действие будет приостановлено.
  4. По желанию. Установите флажок Allow Continue (Разрешить продолжение), показанный на рис. 20.7, чтобы вставить в окно сообщения кнопку Continue (Продолжить) - см. рис. 20.8. Это позволит пользователю продолжить воспроизведение без выполнения каких-либо действий вручную.
  5. Щелкните по кнопке ОК.
  6. Команда Stop (Стоп) будет вставлена после выделенной на первом шаге команды (рис. 20.9).

Если действие воспроизводится в то время, как палитра Actions (Действия) находится в кнопочном режиме, то кнопка Play (Проиграть) будет недоступна. В этом случае, чтобы возобновить воспроизведение после паузы, снова щелкните по имени действия (цвет кнопки Play станет красным). Помните, что надо выбирать режим списка для палитры, если вы планируете использовать паузы.

Включение и отключение команд при воспроизведении действия

  1. Убедитесь, что палитра Actions (Действия) находится в режиме списка (а не в кнопочном режиме). В кнопочном режиме можно только воспроизводить целиком все действие, при этом команды, которые были ранее отключены, не будут выполняться.
  2. На палитре Actions щелкните по треугольнику слева от имени действия, чтобы открыть список входящих в него команд, если он еще не открыт.
  3. Щелкните по кнопке в самой левой колонке, чтобы снять флажок и исключить команду из действия при его воспроизведении (рис. 20.10). Если вы потом захотите снова установить флажок и включить команду, щелкните там же еще раз.

Рис. 20.9. Вставленная пауза

Рис. 20.10. Временное исключение шага Feather из действия

Рис. 20.11. Меню Playback Options

Команды управления воспроизведением

В меню Playback Options (Опции воспроизведения) палитры Actions (Действия) только в режиме списка доступны четыре следующих команды управления воспроизведением действия (рис. 20.11):

  • Accelerated (Ускоренное) - самое быстрое воспроизведение;
  • Step by Step (Пошаговое) - при включении этой опции открывается список команд, входящих в действие. Каждый шаг сопровождается выделением соответствующей команды на палитре перед ее выполнением;
  • Pause for [ ] seconds (Пауза на [ ] секунд) - режим похож на Step by Step, но перед каждым шагом выдерживается пауза, определяемая пользователем;
  • Pause for Audio Annotation (Пауза для звукового уведомления) - в этом случае пауза устанавливается для того, чтобы во время воспроизведения было проиграно звуковое сообщение.

Для того чтобы выполнить действие начиная с какой-то определенной команды, выделите ее имя и щелкните по кнопке Play (Проиграть) либо выберите команду Play в меню палитры Actions (Действия).

Чтобы выполнить одну команду, входящую в число команд действия, щелкните по ее имени и, нажав клавишу Ctrl, щелкните по кнопке Play, либо, нажав эту же клавишу, дважды щелкните по имени команды.

Применение действия к изображению

  1. Откройте изображение, для которого следует воспроизвести заданное действие.
  2. Выберите режим списка (отключите кнопочный режим) на палитре Actions.
  3. Выделите имя действия на палитре.
  4. Щелкните по кнопке Play (Проиграть) на палитре (рис. 20.12) или создайте дроплет для этого действия, а затем перетащите файлы на его пиктограмму (как создать дроплет, написано далее в разделе «Создание дроплета из действия»).

Применение действия к группе изображений

Возможность использовать команду Batch (Пакетная обработка) - одно из наиболее важных свойств действия.

Пакетная обработка файлов завершается по команде Stop, входящей в действие. Если вы планируете использовать действие для пакетной обработки, необходимо удалить из него все паузы.

  1. Убедитесь, что все файлы, предназначенные для обработки, находятся в одной папке.
  2. Выполните команду File > Automate > Batch (Файл > Автоматизация > Пакетная обработка).
  3. Выберите во всплывающем меню Set (Набор) подходящий элемент и выберите действие во всплывающем меню Action (рис. 20.13).

Рис. 20.12. Кнопка Play

Рис. 20.13. Диалоговое окно команды Batch

  4. В поле Source (Источник) выберите вариант Folder (Папка) и щелкните по кнопке Choose (Выбрать), чтобы найти папку с файлами, которые вы хотите обработать.
  5. Выберите в поле Destination (Приемник) режим None (Нет), чтобы после обработки файлы остались открытыми; или выберите режим Save and Close (Сохранить и закрыть), чтобы записать файлы после обработки поверх оригиналов; или режим Folder (Папка), если хотите сохранить файлы в новой папке (щелкните по кнопке Choose (Выбрать), чтобы указать папку, куда будут помещены файлы).
  6. По желанию. Если на предыдущем шаге вы выбрали вариант Folder (Папка) и установили флажок Override Action «Save in» Commands (Заменять команды «Сохранить в» в действии), то изображение будет сохранено в папке, выбранной на шаге 5, при выполнении команды Save (Сохранить) из воспроизводимого действия.
  7. Щелкните по кнопке ОК. Начнется пакетная обработка группы файлов.

Для более эффективной пакетной обработки заранее приведите в порядок файлы и папки. Убедитесь, что все необходимые файлы находятся в одной папке и существует папка-приемник!

В целях эффективного использования оперативной памяти установите значение параметра History States (Количество запоминаемых состояний) в диалоговом окне Preferences (Установки) равным 1. Вы даже можете включить запись и перезапись состояний изображения в само действие!

Именование файлов при пакетной обработке

Если в качестве значения поля Destination (Приемник) выбран вариант Folder (Папка), становится доступным множество параметров, определяющих правила именования обработанных файлов. Например, можно давать файлам имена с использованием последовательных номеров или букв так, чтобы они не замещали друг друга. Также можно использовать опции, гарантирующие совместимость имен файлов с различными операционными системами.

  1. Выполните команду File > Automate >Batch (Файл > Автоматизация > Пакетная обработка).
  2. Выберите режим Folder (Папка) в поле Destination (Приемник).
  3. В разделе File Naming (Наименование файлов) выберите из раскрывающихся списков необходимые параметры или введите сами любые имена для файлов (рис. 20.14).
  4. Получившееся имя файла будет отображаться в поле Example (Пример). Убедитесь, что это именно то, что вам нужно.
  5. Установите подходящий флажок в строке Compatibility (Совместимость): Windows, Mac OS или Unix.

Рис. 20.14. Выбор опций именования файлов

Файлы, обрабатываемые с помощью команды Batch (Пакетная обработка), всегда сохраняются в исходном формате. Для того чтобы сохранить их в другом формате, при создании действия включите в него команду Save As (Сохранить как), не вписывая никакого имени, затем укажите команду Close (Закрыть). При выборе параметров для пакетной обработки убедитесь, что установлен флажок Override Action «Save in» Commands (Заменять команды «Сохранить в» в действии).

  6. По желанию. По умолчанию программа Photoshop остановит обработку группы файлов при появлении сообщения об ошибке. Можно назначить режим воспроизведения, при котором программа не обращает внимания на такие сообщения, а только записывает их в текстовый файл. Для этого выберите вариант Log Errors to File (Записывать ошибки в файл) в меню поля Errors (Ошибки). В результате, если появляется ошибка, то сообщение о ней будет выведено после обработки пакета. Для того чтобы просмотреть запротоколированные сообщения об ошибках, щелкните по кнопке Save As (Сохранить как) и присвойте имя файлу, содержащему эти сообщения.

Было бы неплохо перед запуском команды Batch (Пакетная обработка) срздать папку, где будут сохраняться обработанные в пакетном режиме файлы.

Создание дроплета из действия

В программе Photoshop есть дополнительная функция преобразования действия в небольшое приложение, называемое дроплетом. Дроплет может находиться на рабочем столе или в папке в ожидании «действия». Если перетащить файл или папку с файлами на пиктограмму дроплета, то они будут автоматически обработаны определенным образом.

Как только дроплет был создан, его могут применять другие пользователи даже на других компьютерах, так как дроплет - самостоятельное «действие». Если программа Photoshop 7 еще не открыта, то при перетаскивании графических файлов на пиктограмму дроплета программа сама запустится, чтобы дроплет мог выполнить свою работу.

  1. Выполните команду File > Automate > Create Droplet (Файл > Автоматизация > Создать дроплет).
  2. Щелкните по кнопке Choose (Выбрать) в разделе Save Droplet In (Сохранить дроплет в) и выберите место, где будет храниться дроплет (рис. 20.15).
  3. В разделе Play (Проиграть) выберите подходящий вариант из всплывающего меню Set (Набор), а затем и само действие из всплывающего меню Action (Действие).
  4. Установите флажки в тех опциях воспроизведения, которые необходимы для заданного дроплета.
  5. Выберите параметры в разделе Destination (Приемник) (см. шаги 5-6 в предыдущем разделе).
  6. Щелкните по кнопке ОК. Программа создаст мини-приложение - дроплет (рис. 20.16).

Рис. 20.15. Окно Create Droplet

Рис. 20.16. Значок дроплета

В программе ImageReady можно создать дроплет простым перетаскиванием действия на рабочий стол.

Рис. 20.17. Кнопки управления записью действия на палитре Actions

Для того чтобы скопировать команду из одного действия в другое, откройте оба списка команд, входящих в эти действия, и, нажав клавишу Alt, перетащите нужную команду из одного списка в другой. Если при перетаскивании не нажимать на клавишу Alt, то команда будет вырезана из первого списка. Будьте осторожны при копировании команды Save (Сохранить): в ней может содержаться специфическая информация, которая приемлема только для первого действия.

Если вы хотите сохранить список действий в виде набора, выполните инструкции раздела «Сохранение набора действий в файле» этой главы до того, как будут удалены какие-либо команды из палитры Actions (Действия).

Добавление команды в действие

Команда, которую можно выполнить только при определенных условиях (например, команда Feather требует наличия выделенной области), может -быть добавлена в действие только в том случае, если вы устанавливаете в нем требуемые условия.

  1. На палитре Actions (Действия) щелкните по треугольнику слева от имени операции, чтобы открыть список содержащихся в ней команд, если он еще не открыт. Затем выделите имя команды, после которой необходимо вставить новую.
  2. В меню палитры Actions выберите команду Start Recording (Начать запись) или щелкните по кнопке Record (Записать) - см. рис. 20.17.
  3. Выполните необходимые шаги для записи той команды, которую следует добавить.
  4. Щелкните по кнопке Stop (Стоп), показанной на рис. 20.17, чтобы остановить запись.

Редактирование записи

В существующее действие можно вставить команду с помощью команды Insert Menu Item (Вставить пункт меню) из меню палитры Actions. Однако таким образом нельзя записать параметры, устанавливаемые в диалоговом окне какой-либо команды. Программа откроет диалоговое окно Insert Menu Item, в котором пользователь сможет ввести команду, и затем воспроизведение будет возобновлено. Рекомендуем воспользоваться информацией из предыдущего раздела, чтобы узнать, как вставить паузу для работы с диалоговым окном произвольной команды.

Удаление команды из действия

  1. Выделите имя команды, которую следует удалить (рис. 20.18). Нажав клавишу Shift, щелчком мыши можно выделить и другие команды, если это необходимо.
  2. Щелкните по кнопке Delete (Удалить), которая имеет вид корзины и расположена в нижней части палитры Actions (Действия), и щелкните по кнопке ОК. Другой способ удаления - перетащить команду на кнопку Delete.

Рис. 20.18. Удаление команды

Рис. 20.19. Включение режима контроля на палитре Actions

Контроль за выполнением действия с помощью модальных окон

Контроль за выполнением какой-либо операции с помощью модальных окон реализуется путем установки пауз в последовательности команд. Включить указанную функцию контроля можно для любой команды, которая использует диалоговое окно, или инструмента, при работе с которым необходимо нажать клавишу Enter. Если включен режим контроля за выполнением операции, то при появлении диалогового окна можно будет установить другие параметры выполнения команды либо щелкнуть по кнопке ОК, чтобы оставить без изменения параметры, установленные при записи действия.

  1. Убедитесь, что палитра Actions (Действия) находится в режиме списка (не в кнопочном режиме).
  2. Щелкните на этой палитре по треугольнику слева от имени операции, чтобы открыть список входящих в нее команд, если он еще не открыт.
  3. Щелкните во второй слева колонке, чтобы появился значок диалогового окна (рис. 20.19). Если хотите удалить этот значок, то щелкните в указанном месте еще раз. Воспроизведение действия будет приостановлено, и появится диалоговое окно, в котором можно будет вводить новые значения переменных, принять установленные значения или отменить команду. Воспроизведение будет возобновлено после закрытия диалогового окна.

Изменение порядка команд

Изменение порядка команд в действии при его воспроизведении может привести к неожиданному эффекту.

  1. На палитре Actions (Действия) щелкните по треугольнику слева от имени операции, чтобы открыть список входящих в нее команд, если он еще не открыт.
  2. Перетащите любую команду вверх или вниз по списку (рис. 20.20).

Полная перезапись действия с помощью изменения установок диалогового окна

  1. Щелкните по имени действия, которое следует изменить.
  2. В меню палитры Actions (Действия) выполните команду Record Again (Перезаписать).

    Начнется воспроизведение действия с остановками на командах, которые используют диалоговые окна.

  3. В каждом открывшемся окне введите новые значения переменных, если это необходимо, затем щелкните по кнопке ОК. При закрытии диалогового окна перезапись будет возобновлена.
  4. Для того чтобы остановить перезапись, щелкните по кнопке Cancel (Отмена) в диалоговом окне либо по кнопке Stop (Стоп) в нижней части палитры Actions.

Рис. 20.20. Перетаскивание команды Fill вверх по списку

Рис. 20.21. Команда, которая будет изменена

Рис. 20.22. Дублирование действия путем перетаскивания на кнопку Create new action

Изменение одной команды, входящей в действие

  1. На палитре Actions (Действия) дважды щелкните по команде, которую необходимо изменить (рис. 20.21).
  2. Введите новые значения параметров.
  3. Щелкните по кнопке ОК. Чтобы не сохранять внесенные изменения, щелкните по кнопке Cancel (Отмена).

Копирование действия

Если у вас есть желание поэкспериментировать с действием либо добавить к нему некоторые команды, но при этом не повлиять на оригинал, то воспользуйтесь его дубликатом.

Щелкните по имени действия, которое следует скопировать, а затем в меню палитры Actions (Действия) выполните команду Duplicate (Дублировать) или перетащите имя копируемого действия на кнопку Create new action (Создать новое действие) в нижней части палитры Actions (Действия) - см. рис. 20.22.

Удаление всего действия

  1. Выделите имя действия, которое следует удалить.
  2. Щелкните по кнопке Delete (в виде корзины) в нижней части палитры Actions и щелкните по кнопке ОК. Альтернативный способ: нажав клавишу Alt, щелкните по кнопке Delete (Удалить).

Сохранение набора действий в файле

Действия автоматически сохраняются в наборах действий (набор может содержать как одно, так и несколько действий). Для того чтобы сохранить набор действий в отдельном файле, следует выполнить инструкции, приведенные ниже. Впоследствии этот файл можно будет использовать на другом компьютере, а также он будет служить копией, чтобы предотвратить случайную потерю данных.

  1. Щелкните по набору действий, который необходимо сохранить.
  2. В меню палитры Actions (Действия) выполните команду Save Actions (Сохранить действия) - см. рис. 20.23.
  3. Введите имя файла, в котором будет храниться набор.
  4. Выберите место, куда будет помещен этот файл.
  5. Щелкните по кнопке Save (Сохранить). Новый файл будет рассматриваться как один набор независимо от числа действий, входящих в него.

Если, нажав клавишу Alt, перетащить действие из одного набора в другой, то оно автоматически скопируется.

Рис. 20.23. Меню палитры Actions

Где хранятся действия?

Все действия, которые видны в списке палитры Actions (Действия), хранятся в файле Actions Palette.psp. Этот файл находится в каталоге Adobe Photoshop 7.0 Settings. Действия хранятся в этом файле, пока не будут заменены или пока файл не будет удален. Для того чтобы случайно не удалить набор действий, сохраните его в отдельном файле!

Для более удобного доступа сохраните созданный набор действий в каталоге Presets/Photoshop Actions. Тогда эти действия появятся в нижней части меню палитры Actions.

Загрузка дополнительных наборов действий в палитру Actions

  1. Щелкните по имени набора действий, после которого следует загрузить новый.
  2. В меню палитры Actions (Действия) выполните команду Load Actions (Загрузить действия) - см. рис. 20.23.
  3. Найдите и выделите тот файл с набором действий, который следует загрузить.
  4. Щелкните по кнопке Load/Open (Загрузить/Открыть) или выберите имя набора действий в нижней части меню палитры Actions. Эти наборы хранятся в каталоге Presets/Photoshop Actions.

Замена текущего набора действий другим набором

  1. В меню палитры Actions выполните команду Replace Actions (Заменить действия).
  2. Найдите и выделите файл с набором действий, который следует заменить.
  3. Щелкните по кнопке Load/Open (Загрузить/Открыть) .

Выполнение одного действия в рамках другого

В ходе выполнения одного действия можно выполнить какое-либо другое.

Все команды действия, которое будет добавлено в другое действие, будут выполнены, и это отразится на текущем изображении. Убедитесь в том, что вы используете копию изображения!

  1. Откройте файл.
  2. На палитре Actions (Действия) щелкните по треугольнику слева от имени операции, чтобы открыть список входящих в нее команд, если он еще не открыт. Затем выберите команду, после которой следует добавить действие (рис. 20.24).
  3. Щелкните по кнопке Record (Записать) -см. рис. 20.24.
  4. Выберите действие, которое необходимо добавить (рис. 20.24).
  5. Щелкните по кнопке Play (Проиграть), чтобы записать одно действие в другое (будьте внимательны: нельзя дважды щелкнуть по имени действия). Все команды, входящие в добавленное действие, будут выполнены. Новая команда в списке команд действия будет иметь вид Play Action [имя действия] of set [имя набора] (Воспроизвести действие [имя действия] из набора [имя набора]) - см. рис. 20.25.
  6. Щелкните по кнопке Stop (Стоп), когда закончите изменение исходного действия.

Рис. 20.24. Добавление действия Gradient Map после команды Multiple Actions действия Myset

Рис. 20.25. Выполнение действия Gradient Map после команды Multiple Actions действия Myset

Действие может состоять из нескольких других действий, но будьте осторожны и планируйте все заранее. Действие может быть перемещено, изменено или недоступно при следующем обращении к нему. Потратьте некоторое время на то, чтобы привести в порядок созданные вами действия и их наборы, и регулярно сохраняйте их.

Рис. 20.26. Команды автоматизации в меню File

Другие команды автоматизации

Наряду с командами Batch (Пакетная обработка) и Create Droplet (Создать дроплет) в подменю Automate (Автоматизация) есть еще шесть команд, которые работают очень быстро и эффективно (рис. 20.26):

  • Conditional Mode Change (Изменение режима отображения по условию);
  • Contact Sheet II (Контактный лист II);
  • Fit Image (Подгонка изображения);
  • Multi-Page PDF to PSD (Многостраничный PDF-файл в формат PSD);
  • Picture Package (Пакет рисунков);
  • Web Photo Gallery (Web-галерея фотографий).

Эти команды сводят последовательность выполнения множества сложных команд к установке параметров в одном диалоговом окне. В скором времени компания Adobe сможет предложить больше подобных команд, и, конечно же, другие разработчики постараются не уступать ей в этом. Ведь если компьютер хорошо выполняет какие-либо функции, пусть он их и выполняет.

Изменение режима отображения

При добавлении команды Conditional Mode Change в действие можно быть уверенным, что все обработанные изображения будут находиться в соответствующем режиме.

  1. Выберите команду File > Automate > Conditional Mode Change (Файл > Автоматизация > Изменение режима отображения по условию).
  2. Укажите в разделе Source Mode (Исходный режим) режим изображения, который следует изменить (рис. 20.27).
  3. Выберите соответствующий режим отображения в выпадающем меню Mode (Режим) в разделе Target Mode (Целевой режим). Если целевой режим не подходит ни для одного исходного режима, то появится диалоговое окно с предупреждающим сообщением (чтобы убрать его с экрана, щелкните по кнопке ОК) - см. рис. 20.28.
  4. Щелкните по кнопке ОК.

Создание контактного листа

Контактный лист (contact sheet) представляет собой страницу с миниатюрами изображений. Все миниатюры на этом листе имеют одинаковые размеры. В лист могут быть включены также и названия файлов в качестве подписей к рисункам.

  1. Переместите все изображения, которые надо включить в контактный лист(-ы), в одну папку или подкаталоги этой папки. Убедитесь, что все файлы, которые необходимо добавить в контактный лист, сохранены в приемлемом для программы Photoshop формате. И наконец, удостоверьтесь, что ни один файл не открыт.

Рис. 20.27. Окно Conditional Mode Change

Рис. 20.28. Окно с предупреждением о несоответствии режимов

Рис. 20.29. Окно Contact Sheet II

  2. Выполните команду File > Automate > Contact Sheet II (Файл > Автоматизация > Контактный лист II).
  3. Щелкните по кнопке Select (Выбрать), найдите папку с изображениями для контактного листа, а затем щелкните по кнопке Select [имя папки] (Выделить [имя папки]) -см. рис. 20.29.

    По желанию. Установите флажок Include All Subfolders (Включить все подкаталоги), если необходимо включить в контактный лист не только файлы, находящиеся в обозначенной папке, но и файлы из подкаталогов этой папки.

  4. В диалоговом окне Contact Sheet II (Контактный лист II) выберите соответствующие единицы измерения в раскрывающихся списках полей Width (Ширина) и Height (Высота) раздела Document (Документ). Затем введите в указанные поля значения ширины и высоты для контактного листа.
  5. Выберите необходимое разрешение в поле Resolution (Разрешение) раздела Document (Документ).
  6. Выберите также Mode (Режим) для контактного листа.
  7. В разделе Thumbnails (Миниатюры) диалогового окна выберите подходящий вариант расположения миниатюр в раскрывающемся списке поля Place (Поместить): по столбцам или по строкам. Далее введите число строк и столбцов контактного листа. При этом можно предварительно просмотреть вид листа в правой части диалогового окна.
  8. По желанию. Установите флажок Use Filename As Caption (Использовать имя файла в качестве подписи), чтобы под каждой миниатюрой отображалось имя соответствующего файла. При включении данной опции укажите нужные значения параметров Font (Тип шрифта) и Font Size (Кегль).
  9. Щелкните по кнопке ОК (рис. 20.30).

Подгонка размеров изображения по ширине и высоте

Предупреждаем, что команда Fit Image (Подгонка изображения) изменяет размеры изображения с помощью повторной его выборки (добавляя или удаляя пикселы). При этом разрешение изображения остается постоянным.

  1. Откройте файл.
  2. Выполните команду File > Automate > Fit Image (Файл > Автоматизация > Подгонка изображения).
  3. Введите предельные значения параметров в разделе Constrain Within (Граничные значения) в поля Width (Ширина) и Height (Высота).

    Наименьшая из величин будет использована для подгонки изображения. Например, размеры исходного изображения равны 210x237, и вы вводите значение 275 в поле Height и значение 1500 - в поле Width. Изображение будет подогнано в соответствии со значением 275 и с сохранением исходных пропорций, то есть ширина будет равна 310.

  4. Щелкните по кнопке ОК.

Рис. 20.30. Контактный лист с подписями в виде имен соответствующих файлов

Рис. 20.31. Окно Fit Image

Рис. 20.32. Выбор файла для преобразования

Преобразование файла формата PDF в формат программы Photoshop PSD

Многостраничный файл в формате PDF из программы Acrobat может быть импортирован в программу Photoshop. Подробнее о формате PDF рассказано в разделах «Открытие файлов в формате EPS, PDF или программы Illustrator как нового изобра жения» и «Сохранение файлов» главы 3. (PSD - формат файла в программе Photoshop.)

  1. Выполните команду File > Automate > MultiPage PDF to PSD (Файл > Автоматизация > Многостраничный PDF в PSD).
  2. В разделе Source PDF (Исходный файл формата PDF) щелкните по кнопке Choose (Выбрать) и выделите файл формата PDF, который необходимо преобразовать (рис. 20.32).
  3. В разделе Page Range (Диапазон страниц) поставьте переключатель в положение All (Все) или воспользуйтесь двумя другими полями для прямого указания диапазона страниц. Неплохо было бы заранее ознакомиться с исходным файлом в формате PDF, так как вы не сможете сейчас просмотреть его.
  4. В разделе Output Options (Опции вывода) введите значение разрешения для изображения (поле Resolution (Разрешение)). Для файла формата PDF, предназначенного для печати, введите минимальное разрешение в 250 пикселов на дюйм, чтобы текст можно было преобразовывать в растровый формат. Разрешение в 72 пиксела на дюйм будет оптимальным для файла формата PDF, который планируется разместить в сети.
  5. В том же разделе выберите соответствующий вариант в раскрывающемся списке поля Mode (Режим). Впоследствии режим отображения можно будет изменить. Если установить флажок Anti-aliased (Сглаживание), то границы букв будут немного смягчены, но литеры станут немного уже.
  6. В разделе Destination (Приемник) либо оставьте без изменения имя в поле Base Name (Базовое имя), либо введите другое имя для преобразованного файла. К имени будет присоединено расширение 000l.psd, 0002.psd и т.д., чтобы идентифицировать страницы исходного файла.
  7. Щелкните по кнопке Choose (Выбрать), найдите и выделите папку, в которой будут сохранены преобразованные файлы.
  8. Щелкните по кнопке ОК. В процессе преобразования окна с изображениями будут быстро появляться на экране и исчезать. После окончания преобразования все файлы будут помещены в папку, выбранную на шаге 6. Их можно открывать и редактировать, как и остальные файлы Photoshop.

Пакет рисунков

Команда Picture Package (Пакет рисунков) распределяет на одном листе одинаковые изображения различного размера подобно пробным отпечаткам, которые делают обычные фотостудии. Можно выбирать всевозможные конфигурации изображений разных размеров.

  1. Выполните команду меню File > Automate > Picture Package (Файл > Автоматизация > Пакет рисунков).

Рис. 20.33. Левая часть окна Picture Package

Рис. 20.34. Правая часть окна Picture Package

  2. Из всплывающего меню Use, показанного на рис. 20.33, выберите Frontmost Document (Использовать текущий документ), чтобы воспользоваться активным изображением, либо File (Файл) или Folder (Папка), чтобы указать папку или файл для обработки.
  3. В разделе Document (Документ) диалогового окна выберите соответствующий вариант из раскрывающегося списка Layout (Макет), чтобы указать размер изображения, отображаемого на листе. Макет можно будет увидеть в правой части диалогового окна, показанной на рис. 20.34. Далее выберите необходимый вариант из раскрывающегося списка Resolution (Разрешение) для файла, содержащего пакет рисунков, и режим отображения для него (параметр Mode (Режим)).
  4. Щелкните по кнопке ОК или нажмите клавишу Enter. А теперь ничего не делайте, подождите, пока команда выполнит всю работу за вас (посмотреть, что происходит, можно в палитре History (История)). В данном примере мы использовали схему (2)4х5&(2)2.5х3.5&(4)2х2.5 для команды Picture Package (Альбом). Кроме этой есть множество других схем упаковки.
  5. Сохраните полученный файл в требуемом формате.

Нажмите клавишу Esc, чтобы остановить выполнение команды.

Если хотите создать свои собственные схемы упаковки, обратитесь к интерактивной справочной системе Adobe Photoshop - разделу, посвященному изменению схем упаковки рисунков (Customizing picture package layouts).

Создание Web-галереи

С помощью команды Web Photo Gallery (Web-галерея фотографий) можно экспортировать сразу несколько изображений в виде Web-сайта. Photoshop сделает за вас всю работу. Вы автоматически получите: домашнюю страничку index.htm с галереей фотографий, которую можно открыть с помощью любого графического Web-браузера. Отдельные странички с изображениями в формате JPEG будут помещены в подкаталог images; файлы HTML-страниц в подкаталог pages; и миниатюры изображений в формате JPEG - в подкаталог thumbnails.

Когда вы будете готовы загрузить вашу Web-галерею на сервер, то узнайте у своего провайдера, какие существуют правила при создании имен файлов и папок, а также попросите инструкции по их загрузке.

  1. Убедитесь, что изображения, которые следует использовать для создания галереи, находятся в одной папке.
  2. Выполните команду File > Automate > Web Photo Gallery (Файл > Автоматизация > Web-галерея фотографий).
  3. Выберите для вашего Web-сайта соответствующий стиль из меню Style (Стили):
    • Horizontal Dark (По горизонтали), Farme (В рамке), Light (Светлый) или Patterned (Узорчатый);
    • Simple (Простой);
    • Table (Таблица), Table Blue (Голубая таблица);
    • Vertical Frame (По вертикали), Slide Show 1 (Показ в режиме слайдов 1) или Slide Show 2 (Показ в режиме слайдов 2).

    Любой стиль можно просмотреть в окне предварительного просмотра.

Рис. 20.35. Опция Banner

Рис. 20.36. Опция Large Images

  4. Во всплывающем меню Options (Опции) выберите нужный вариант текстовой информации, размера изображения, разрешения, используемых шрифтов, правил наименования файлов и цвета ссылок.

    Если вы выбрали вариант Banner (Бан-нер), введите информацию, которая будет появляться на каждой странице галереи (рис. 20.35): Site Name (Имя сайта), Photographer (Имя фотографа), Contact Info (Контакты), Date (Дата), Font (Тип шрифта), Font Size (Кегль) для текста на баннере.

    Активизируйте опцию Large Images (Большие изображения) из раскрывающегося списка в разделе Options (Опции) и выберите качество изображений, их размер и толщину рамки. Все эти параметры будут применены на каждой странице галереи (рис. 20.36).

    Толщина рамки каждого изображения измеряется в пикселах. Если установить флажок Resize Images (Изменить размеры изображений), то программа Photoshop будет изменять размеры исходных изображений для того, чтобы расположить их на отдельных страничках; если же не устанавливать указанный флажок, то размер изображений меняться не будет.

    Если включена опция Large Images (Большие изображения), то выберите какой-либо вариант для грубой оценки размера из всплывающего меню Resize Images (Изменять размеры изображений) или введите определенное процентное соотношение для изменения размеров. Также выберите подходящий вариант от 0 до 12 во всплывающем меню JPEG Quality (Качество JPEG-изображения). Чем выше качество, тем больше размер файла. Указать качество изображения можно и с помощью ползунка. Если использован этот способ, то посмотрите, как меняются значения во всплывающем меню JPEG Quality.

    Во всплывающем меню раздела Options (Опции) выберите вариант Thumbnails (Миниатюры), чтобы установить параметры домашней странички Web-галереи (рис. 20.37).

    Выберите параметры шрифта для текста, размер миниатюр изображения (поле Size) и схему расположения миниатюр (введите соответствующие значения в поля Columns (Столбцы), Rows (Строки), Border Size (Толщина рамки)). Во всплывающем меню раздела Options (Опции) выберите вариант Custom Colors (Цвета по выбору пользователя), чтобы выбрать фоновый цвет, цвет текста на баннере, .а также цвет ссылок (рис. 30.38). Щелкните по цветовой палитре, чтобы непосредственно изменить цвет (помните, что лучше, по возможности, использовать Web-цвета).

  5. Щелкните по кнопке Browse (Источник), найдите папку с изображениями, которые следует использовать, а затем щелкните по кнопке Select (Выделить).

    По желанию. Установите флажок Include All Subdirectories (Включить все подкаталоги), если необходимо разместить в Web-галерее не только файлы с изображениями, находящиеся в указанной папке, но и файлы из всех вложенных папок.

  6. Щелкните по кнопке Destination (Приемник), обозначьте папку, в которой необходимо сохранить HTML-файлы, которые будут получены в результате выполнения данной команды, и щелкните по кнопке Select (Выделить).

Рис. 20.37. Опция Thumbnails

Рис. 20.38. Опция Custom Colors

Рис. 20.39. Домашняя страничка, представляющая собой Web-галерею фотографий

Рис. 20.40. Увеличенное центральное изображение с домашней странички

  7. Щелкните по кнопке ОК. Программа Photoshop создаст следующие файлы:
    • по крайне мере, одну домашнюю страничку под именем index.htm:
    • JPEG-файлы для изображений и их миниатюр;
    • HTML-файлы для других страничек сайта.

Храните все файлы и папки, относящиеся к галерее фотографий, в одной общей папке, чтобы сохранить связи между ними.

Если щелкнуть по миниатюре или заголовку в Web-браузере, появится изображение в увеличенном размере. Также можно использовать кнопки со стрелками, чтобы посетитель странички мог вернуться к предыдущей картинке, потом перейти к следующей или вернуться к домашней страничке (рис. 20.39).

Кнопки со стрелками будут сохранены в отдельных файлах подкаталога images в выбранной вами папке-приемнике. Они будут называться home.gif, previous.gif и next.gif. Любое из этих изображений можно открыть с помощью программы ImageReady и отредактировать, а также заменить каким-либо другим изображением. Если вы решили воспользоваться последним вариантом, то в меню File (Файл) выполните команду Save Optimized (Сохранить с оптимизацией) и сохраните новые изображения кнопок под теми же именами в той же папке. При появлении любого предупреждающего окна отвечайте Yes (Да).

Если вы хотите изменить серый цвет исходных стрелок на кнопках, в палитре Optimize (Оптимизация) программы ImageReady измените значение параметра GIF palette (Палитра GIF) с Custom (по выбору пользователя) на другое. Затем выполните команду Image > Adjustments > Hue/Saturation (Изображение > Корректировки > Тон/Насыщенность), чтобы раскрасить данную стрелку, или перетащите другое изображение в главное окно программы, чтобы использовать его взамен стрелки.

Пользуйтесь файлами интерактивной справочной системы программы Adobe Photoshop. В разделе Customizing and creating web photo gallery styles (Изменение и создание стилей Web-галерей фотографий) приведена более подробная информация по этой теме.


  • Глава 21. Общие установки программы Photoshop
    • Память и кэш-память изображения
    • Основные установки
    • Сохранение файлов
    • Отображение и курсоры
    • Прозрачность и цветовой охват
    • Единицы измерения и линейки
    • Направляющие линии и сетка
    • Дополнительные модули и рабочий диск
    • Использование диалогового окна Preset Manager
      • Библиотеки образцов
      • Восстановление или замещение образца
      • Сохранение подмножества образцов в отдельной библиотеке
      • Сохранение нового образца в новой библиотеке

Глава №21.

Общие установки программы Photoshop

Рис. 21.1. Подменю разделов диалогового окна Preferences

Общие установки программы Photoshop применяются ко всему приложению и определяют, например, какие единицы измерения используются, или отображаются ли каналы в соответствующем им цвете. В большинстве случаев изменение установок незамедлительно влияет на файлы, и лишь иногда требуется перезагрузка программы (эти исключения указаны). Все изменения общих установок сохраняются при выходе из программы Photoshop. Для более быстрого и легкого доступа к диалоговым окнам установок нажмите комбинацию клавиш Ctrl+K - откроется диалоговое окно General (Общие). Затем воспользуйтесь тем же сочетанием клавиш или подменю Preferences (Установки) меню Edit (Правка), чтобы открыть другие диалоговые окна. Либо щелкните по кнопке Next (Вперед) или Prev (Назад) в правой части диалогового окна, чтобы перейти на другую страницу (рис. 21.1).

Чтобы восстановить значения установок, действующие по умолчанию, во время загрузки программы держите нажатыми сочетания клавиш Ctrl+Alt+Shift. Щелкните по кнопке Yes (Да), чтобы удалить файл установок в программе Photoshop. To же самое проделайте и при загрузке компонента Photoshop - программы ImageReady.

Память и кэш-память изображения

Кэш-память изображения предназначена для ускорения перерисовки экрана при редактировании или корректировке цвета изображений с высоким разрешением. Копии изображения с меньшим разрешением сохраняются в отдельных кэш-буферах и используются для обновления изображения на экране. Чем выше (от 1 до 8) значение параметра Cache Levels (Количество уровней кэш) в группе параметров Cache settings (Параметры кэш-памяти), тем больше буферов используется, тем быстрее происходит перерисовка экрана (рис. 21.2).

Установите флажок Use cache for histograms (Использовать кэш для гистограмм), чтобы в диалоговых окнах Levels (Уровни) и Histogram (Гистограмма) гистограммы отображались более быстро, но менее точно.

В поле Used by Photoshop можно указать объем физической памяти, который предназначен для работы Photoshop. Если в компьютере установлено менее чем 256 Мб физического ОЗУ, то имеет смысл увеличить долю, предоставленную Photoshop, до 75-80%. Если же предполагается параллельно запускать другие программы и при этом имеется- большой объем памяти, то заданную по умолчанию величину можно и уменьшить. Однако, если объем памяти, выделенной Photoshop, составит 90 Мб и меньше, то более чем вероятно существенное снижение быстродействия. Если Photoshop работает под управлением Windows NT/2000/XP, то данные настройки лучше не изменять без большой необходимости, поскольку в таком случае все управление памятью отдается «на откуп» самой операционной системе.

Рис. 21.2. Раздел Memory & Image Cache диалогового окна Preferences

Рис. 21.3. Раздел General диалогового окна Preferences

Основные установки

Номера элементов списка, приведенного ниже, соответствуют цифрам на рис. 21.3.

  1. Выберите в поле Color Picker (Выбор цвета) пункт Adobe, чтобы получить доступ к палитре цветов приложения. Если необходимо задать в программе Photoshop цвета, соответствующие цветам браузера, то выберите вариант Adobe или Windows.
  2. В поле Interpolation (Интерполяция), которое управляет повторной интерпретацией изображения (в результате проведения повторной выборки или трансформации изображения), выберите следующие варианты:
    • Bicubic (Бикубическая) - медленная интерполяция, дающая самое высокое качество изображения;
    • Nearest neighbor (Ближайший сосед) - быстрая интерполяция, но качество изображения плохое.
  3. Выберите «горячие клавиши» для команды Redo (Повторить) из всплывающего меню Redo Key (Клавиша команды Redo).
  4. Введите в поле History States (Количество запоминаемых состояний) количество событий (от 1 до 100), которые могут одновременно отображаться в палитре History (История).
  5. Установите флажок Export Clipboard (Экспорт буфера обмена), чтобы содержимое буфера обмена сохранилось при выходе из программы Photoshop.
  6. Установите флажок Show Tool Tips (Показывать всплывающие подсказки), чтобы на экране отображалось название инструмента или значка, на который указывает курсор.
  7. Если не установлен флажок Keyboard Zoom Resizes Windows (Изменение размеров окна с клавиатуры), то размер окна с изображением не будет меняться при приближении или удалении изображения с помощью сочетания клавиш Сtrl+«плюс»/«минус».
  8. Включите опцию Auto-update open documents (Автосохранение открытых документов), чтобы документы автоматически сохранялись при переходе из программы Photoshop в ImageReady и обратно. Документы обновляются автоматически, независимо от того, включена ли эта опция или нет.
  9. Установите флажок Show Asian Text Options (Показывать параметры текста на азиатских языках), чтобы отображались опции китайского, японского и корейского шрифтов с возможностью их изменения.
  10. Включите опцию Веер When Done (Звуковой сигнал после выполнения), чтобы звучал сигнал, когда команда, которой требуется время для выполнения операции, завершила ее.
  11. Если включена опция Dynamic Color Sliders (Динамичная шкала), то цвета в палитре Color (Цвет) будут меняться при перемещении ползунков. Выключите эту опцию, чтобы ускорить процесс выбора цвета.
  12. Если установлен флажок Save Palette Locations (Сохранять расположение палитр), то при запуске программы палитры будут открываться на том же месте, где они находились до выхода из нее.
  13. Если включена опция Show Font Names in English (Показывать тип шрифта на английском), то наименование типа шрифта будет отображаться во всплывающем меню Font (Шрифт) на английском языке.
  14. Если включена опция Use Shift Key for Tool Switch (Использовать клавишу Shift для переключения инструментов), то доступ к инструментам одной группы можно осуществить, нажав одновременно клавишу Shift и клавишу с соответствующей буквой. Например, нажатие комбинации клавиш Shift+R попеременно переключает инструменты Blur (Размытие), Sharpen (Резкость) и Smudge (Палец).
  15. При включении опции Use Smart Quotes область, занятая вводимым текстом, будет автоматически расширяться, пока сам ввод не будет закончен.
  16. Щелкните по кнопке Reset All Warning Dialogs (Восстановить все предупреждающие окна), в результате чего снова будут появляться предупреждающие сообщения, которые были отключены при установке в диалоговых окнах флажка Don't Show Again (He отображать в следующий раз).

Рис. 21.4. Раздел File Handing диалогового окна Preferences

Сохранение файлов

Номера элементов списка, приведенного ниже, соответствуют цифрам на рис. 21.4.

  1. В поле Image Previews (Миниатюры изображений) выберите вариант Never Save (He сохранять никогда), чтобы сохранять файлы без миниатюр, Always Save (Сохранять всегда), чтобы сохранять файлы с миниатюрами, или Ask-When Saving (По заказу), чтобы для каждого отдельного файла при его первом сохранении решать, нужна ли миниатюра.
  2. Выберите в поле File Extension (Расширение имени файла) пункт Use Lower Case (Использовать маленькие буквы). Включение этой опции позволит избежать многих сложностей при межплатформенном обмене файлами.
  3. В области File Compatibility (Совместимость файлов) установите флажок Treat all TIFF files as enhanced TIFF when reading, если хотите сохранить максимум дополнительной вспомогательной информации. Но учтите, что это существенно затруднит обмен файлами.
  4. При установке флажка Enable Workgroup Functionality (Использовать расширения для рабочих групп) будет также задействовано поведение программы при работе с общими ресурсами в сети. В поле Check Out from Server (Проверять исходящие с сервера) и Update from Server .(Обновлять на сервере) доступно три варианта: Ask (По требованию), Allways (Всегда) и Never (Никогда). Если эти возможности не задействованы, названные средства лучше отключить.
  5. В поле Recent file list contains [ ] files (В список недавно использовавшихся файлов включать [ ] файлов) введите число файлов (от 1 до 30), которые будут отображаться в подменю Open Recent (Недавно использовавшиеся) меню File (Файл).

Отображение и курсоры

Номера элементов списка, приведенного ниже, соответствуют цифрам на рис. 21.5.

  1. Установите флажок Color Channels in Color (Цветовые каналы в цвете), чтобы отображать отдельные каналы RGB и CMYK в соответствующем им цвете на палитре Channels (Каналы). В противном случае каналы будут отображаться оттенками серого цвета.
  2. Включите опцию Use Diffusion Dither (Использовать диффузионную интерполяцию растра), если ваш монитор работает в режиме 8-битного цвета. При включении этой опции программа Photoshop будет «размывать» изображение,, чтобы повысить степень соответствия цветов.
  3. Установите флажок Use Pixel Doubling (Использовать сдваивание пикселов), чтобы ускорить перерисовку миниатюр за счет отображения сначала сохраненной копии более низкого качества. В действительности на качество изображения это никак не влияет: опция просто ускоряет процесс перерисовки.
  4. В области Painting Cursors (Курсоры инструментов рисования) для инструментов Gradient (Градиент), Line (Линия), Eraser (Ластик), Pencil (Карандаш), Airbrush (Аэрограф), Paintbrush (Кисть), Rubber Stamp (Штамп), Pattern Stamp (Штамп узора), Smudge (Палец), Blur (Размытие), Sharpen (Резкость), Dodge (Осветлитель), Burn (За-темнитель) и Sponge (Губка) выберите пункт Standard (Стандартный), чтобы курсор принимал вид пиктограммы используемого инструмента (рис. 21.6), или Precise (Точный), чтобы курсор имел вид перекрестия (рис. 21.7), или Brush Size (Размер кисти), чтобы видеть кружок, размер которого точно соответствует диаметру инструмента (до 999 пикселов) - рис. 21.8.

Рис. 21.5. Раздел Display & Cursors диалогового окна Preferences

Рис. 21.6. Вид курсора в режиме Standard

Рис. 21.7. Вид курсора в режиме Precise

Рис. 21.8. Вид курсора в режиме Brush Size

  5. Для инструментов, с помощью которых нельзя рисовать (например, Rectangular Marquee (Прямоугольная область), Lasso (Лассо), Polygon Lasso (Полигональное лассо), Magic Wand (Волшебная палочка), Crop (Кадрирование), Eyedropper (Пипетка), Реп (Перо), Gradient (Градиент), Line (Линия), Paint Backet (Ведро с краской), Magnetic Lasso (Магнитное лассо), Magnetic Pen (Магнитное перо), Measure (Измеритель) и Color Sampler (Цветовая проба)), включите в области Other Cursors (Другие курсоры) опцию Standard (Стандартный) или Precise (Точный).

В зависимости от установленных параметров нажатие клавиши Caps Lock переключает вид курсора: Standard на Precise, Precise на Brush Size (Размер кисти) или Brush Size на Precise.

Прозрачность и цветовой охват

Номера элементов списка, приведенного ниже, соответствуют цифрам на рис. 21.11б.

  1. Шахматная сетка используется для того, чтобы показать прозрачные области слоя (области, не содержащие непрозрачных пикселов). Можно выбрать различные размеры клеток во всплывающем меню Grid Size (Шаг сетки) - см. рис. 21.9-21.11.
  2. В области Transparency Settings (Параметры прозрачности) измените опцию Grid Colors (Цвета сетки) для шахматной сетки (рис. 21.11а), выбрав варианты Light (Светлый), Medium (Средний), Dark (Темный), Red (Красный), Orange (Оранжевый), Green (Зеленый), Blue (Голубой) или Purple (Пурпурный). Для установки других цветов найдите пункт Custom (По выбору пользователя).
  3. Установите флажок Use video alpha (requires hardware support) (Использовать видео-канал (требуется аппаратная поддержка)), если у вас 32-битная видеокарта, которая позволяет использовать хроматический ключ при редактировании видео. Благодаря этому можно смотреть сквозь определенные области видеоизображения.

Рис. 21.9. Раздел Transparency & Gamut диалогового окна Preferences

Рис. 21.10. Исходное изображение на фоне шахматной сетки

Рис. 21.11. Изображение после выбора значений Large в поле Grid Size и Medium в поле Grid Colors

  4. Для того чтобы изменить цвет, которым обозначаются не входящие в гамму цвета при использовании команды Gamut Warning (Предупреждение о гамме), щелкните по квадратику Color и выберите цвет из цветовой палитры. Можно уменьшить значение параметра Opacity (Непрозрачность) в разделе Gamut Warning, чтобы было проще видеть расположенное ниже цветное изображение.

Единицы измерения и линейки

Номера элементов списка, приведенного ниже, соответствуют цифрам на рис. 21.12.

  1. Выберите единицы измерения (табл. 21.1) из всплывающего меню Rulers (Линейки) в разделе Units (Единицы измерения) для вертикальной и горизонтальной линеек, расположенных в окне изображения (чтобы отобразить линейки, выполните команду меню View > Show Rulers (Вид > Показать линейки)).

    Из всплывающего меню Туре (Текст) выберите такие же или другие единицы измерения.

Если поменять единицы измерения в палитре Info (Информация), показанной на рис. 21.13, в рассматриваемом диалоговом окне также изменятся единицы измерения и наоборот.

Данную страницу диалогового окна Preferences можно открыть двойным щелчком мыши по линейке в окне изображения.

  2. В области Column Size (Размер столбца) введите значения в поля Width (Ширина) и Gutter (Межстолбцовый промежуток), чтобы команды linage Size (Размер изображения) и Canvas Size (Размер холста) более точно подгоняли изображение по размеру столбцов при компоновке страниц.
  3. В области Point/Pica Size (Размер пункта/цицеро) используйте опцию PostScript (72 points/inch) (PostScript 72 пункта на дюйм), принимаемую по умолчанию, чтобы программа применяла новый метод вычисления количества пикселов, приходящихся на один дюйм.

Рис. 21.12. Раздел Units & Rulers в диалоговом окне Preferences

Рис. 21.13. Палитра Info

Таблица 21.1. Обозначение различных единиц измерения

Единица измерения | Обозначение
Pixels (Пиксел) | рх
Inches (Дюйм) | in или "
Centimeters (Сантиметр) | Cm
Points (Пункт) | Pt
Picas (Цицеро) | Р
Percent (Процент) | %

Рис. 21.14. Раздел Guides & Grid в диалоговом окне Preferences

Рис. 21.15. Расположение направляющих линий и линий сетки

Или активизируйте опцию Traditional (Традиционный), при этом будет использоваться соотношение 72,27 пункта на дюйм.

Направляющие линии и сетка

Номера элементов списка, приведенного ниже, соответствуют цифрам на рис. 21.14.

Изменения, произведенные в диалоговом окне, сразу же отображаются в окне изображения.

  1. Выберите необходимый цвет для подвижных направляющих в разделе Guides (Направляющие) из всплывающего меню Color (Цвет). Щелкните по цветному квадратику, чтобы выбрать оттенок из палитры цветов.
  2. Из всплывающего меню Style (Стиль) выберите вариант Lines (Сплошные линии) или Dashed Lines (Пунктирные линии).
  3. В разделе Grid (Сетка) выберите необходимый цвет для сетки из всплывающего меню Color (Цвет). Сетка не отображается при печати. Для того чтобы выбрать оттенок из палитры цветов, щелкните по цветному квадратику.
  4. Для стиля сетки выберите значение Lines, Dashed Lines или Dots (Точки).
  5. Для того чтобы линии сетки были расположены с определенным шагом (рис. 21.15), выберите единицы измерения в выпадающем меню, затем введите значение в поле Gridline every (Линия через каждые). Если в качестве единицы измерения выбран процент (percent), то линии сетки появятся на расстоянии, определяемом указанным значением процента, отсчет ведется от левого края изображения.
  6. Для того чтобы добавить тонкие линии сетки между более жирными линиями, расположенными в соответствии со значением, выбранным в поле Gridline every, введите нужное значение в поле Subdivisions (Внутренние деления).

Дополнительные модули и рабочий диск

Номера элементов списка, приведенного ниже, соответствуют цифрам на рис. 21.16.

Изменения, внесенные в данном диалоговом окне, вступят в силу только после перезагрузки программы Photoshop.

  1. Установите флажок Additional Plug-ins Folder (Папка дополнительных модулей), затем щелкните по кнопке Choose (Выбрать), если хотите переопределить месторасположение папки или воспользоваться другой папкой. Программе Photoshop необходимо знать местонахождение папки, чтобы получить доступ к встроенным модулям сторонних производителей. Внутренний каталог Plug-Ins самой программы Photoshop должен оставаться на своем месте, за исключением каких-либо особых обстоятельств. Его перемещение может затруднить доступ к фильтрам, командам Import (Импорт), Export (Экспорт) и эффектам, а также к некоторым форматам файлов при сохранении.
  2. Диск First (Первый) используется в случае, когда оперативной памяти недостаточно для обработки или хранения данных (по желанию вместо него можно выбрать и другой рабочий диск). В первом всплывающем меню выберите любой доступный жесткий диск. По умолчанию установлено значение Startup (Загрузочный).

Рис. 21.16. Раздел Plug-ins&Scratch Disk Preferences в диалоговом окне Preferences

При желании можно выбрать Second (Второй), Third (Третий) или Fourth (Четвертый) дисковый том, чтобы программа в случае необходимости могла использовать дополнительное дисковое пространство. Если же жесткий диск имеет только один раздел, то, конечно, может быть только один рабочий диск.

Если рабочий диск является съемным и вы его вынете при работе программы Photoshop, то программа «зависнет».

Использование диалогового окна Preset Manager

Вы уже познакомились со многими панелями, имеющимися в программе Photoshop 7, например панелью выбора кисти и градиента. Палитра Swatches (Образцы) тоже представляет собой панель выбора. Каждый элемент панели выбора называется образцом, а набор образцов - библиотекой. Диалоговое окно Preset Manager (Менеджер настроек) используется, когда необходимо упорядочить, добавить, заменить или восстановить исходное положение элементов, расположенных на любой из панелей выбора. Одни и те же операции могут быть применены к разным панелям. Изменения, внесенные в панель выбора образцов, отражаются в диалоговом окне Preset Manager и наоборот.

  1. Выполните команду меню Edit > Preset Manager (Правка > Менеджер настроек).
  2. Рекомендация. Щелкните по стрелке в кружочке, расположенной в верхней части диалогового окна, и выберите вид образцов:
    • Text Only (Только текст);
    • Small Thumbnail (Мелкие миниатюры);
    • Large Thumbnail (Крупные миниатюры);
    • Small List (Мелкий список);
    • Large List (Крупный список).
  3. Из всплывающего меню Preset Type (Тип образца) выберите категорию образцов (рис. 21.17).
  4. Выполните любое из перечисленных ниже действий:
    • щелкните по стрелке в кружочке и выберите имя библиотеки из нижней части меню. Щелкните по кнопке Append (Добавить), чтобы добавить новую библиотеку к текущей, или по ОК, чтобы заменить текущую библиотеку новой;
    • щелкните по кнопке Load (Загрузить), чтобы добавить новую библиотеку к текущей;
    • выделите образец (нажав клавишу Shift, можно выделить несколько образцов), затем щелкните по кнопке Delete (Удалить) (на палитре Swatches нельзя выделить несколько образцов цвета при нажатии Shift). Установленные по умолчанию образцы могут быть удалены и восстановлены в любой момент.
  5. Щелкните по кнопке Done (Готово). Отредактированная панель выбора будет обновлена.

Рис. 21.17. Выбор категории образцов

К файлам библиотек образцов могут параллельно обращаться все пользователи программы Photoshop.

Рис. 21.18. Меню окна Preset Manager

Библиотеки образцов

Каждому типу библиотеки соответствует свое собственное расширение файла и папка, расположенная в каталоге Photoshop/ Presets.

Библиотеки образцов, используемых по умолчанию, не отображаются в панели выбора или меню окна Preset Manager. Эти библиотеки расположены в папке Windows/Application Data/Adobe/Photo-shop/7.0/Adobe Photoshop 7 Settings. В Windows 2000/XP Professional этот каталог находится в папке с пользовательским профилем.

Восстановление или замещение образца

  1. В меню Edit (Правка) выполните команду Preset Manager (Менеджер настроек).
  2. Из всплывающего меню Preset Type (Тип образца) выберите тип образца, который необходимо восстановить или заменить.
  3. Рекомендация. Поскольку вновь добавленные и несохраненные образцы автоматически удаляются, рекомендуем сохранить текущую библиотеку перед ее редактированием или заменой.
  4. В меню окна Preset Manager (Менеджер настроек) - см. рис. 21.18:
  • выполните команду Reset (Восстановить) [тип образца], чтобы восстановить библиотеку выбранного типа, установленную по умолчанию, затем щелкните по кнопке Append (Добавить), чтобы добавить образцы этой библиотеки в текущую библиотеку, или щелкните по кнопке ОК, чтобы заменить текущую библиотеку используемой
  • по умолчанию (щелкните по кнопке Cancel (Отмена), если передумали);
  • выполните команду Replace (Заменить) [тип образца], чтобы заменить текущую библиотеку другой.

Восстановить или заменить библиотеку можно также с помощью соответствующей панели выбора.

Сохранение подмножества образцов в отдельной библиотеке

Пользуясь опциями диалогового окна Preset Manager, можно скопировать набор выбранных образцов из открытой библиотеки в новую.

  1. В меню Edit (Правка) выполните команду Preset Manager (Менеджер настроек).
  2. Из всплывающего меню Preset Type (Тип образца) выберите тип образцов, которые необходимо сохранить в отдельной библиотеке.
  3. Нажав клавишу Shift, выделите образцы, которые следует сохранить (рис. 21.19). Этот метод нельзя использовать при работе с панелью Swatches (Образцы).
  4. Щелкните по кнопке Save Set (Сохранить набор). Не меняйте месторасположение будущей библиотеки, установленное по умолчанию, а затем введите имя библиотеки.
  5. Щелкните по кнопке ОК.

Рис. 21.19. Выделение сохраняемых образцов

Для того чтобы переименовать образец в библиотеке, дважды щелкните по нему или выделите его, затем выполните команду Rename (Переименовать) и введите новое имя кисти, образца цвета или другого элемента библиотеки, а потом щелкните по кнопке ОК. Если выбрано несколько образцов, придется ввести несколько имен.

В диалоговом окне Preset Manager можно выбрать несколько образцов одновременно, а на панели выбора - только один.

Сохранение нового образца в новой библиотеке

Если вы создали новую кисть, узор или фигуру посредством меню Edit (Правка), добавили новый образец цвета в палитру Swatches (Образцы), новый стиль в палитру Styles (Стили), создали новый градиент в диалоговом окне Gradient Editor (Редактор градиента) или новый контур в окне выбора контуров, то новый элемент появится на панели выбора соответствующего инструмента, кнопка вызова которой расположена на панели опций инструмента. Также новый элемент будет включен в меню Preset Type (Тип образца) диалогового окна Preset Manager.

Новый образец будет временно сохранен в файле установок программы Adobe Photoshop и появится на панели выбора, даже если вы перезагрузите программу. Он будет находиться там до тех пор, пока вы не откроете другую библиотеку этой же категории (например, другую библиотеку кистей) или не восстановите исходное состояние панели выбора или категории, куда входит эта панель, с помощью диалогового окна Preset Manager. Если вы выполните любое из вышеперечисленных действий, то новый образец будет удален. Как сохранить его, написано ниже.

  1. Создайте новый образец для панели выбора.
  2. В меню панели выполните команду Save (Сохранить) [тип образца] (рис. 21.20) или с помощью меню Edit (Правка) откройте окно Preset Manager, выберите соответствующий вариант в меню Preset Type (Тип образца), выделите элемент, который необходимо сохранить (нажав клавишу Shift, можно выделить несколько элементов), а затем щелкните по кнопке Save Set (Сохранить набор).

Рекомендуем воспользоваться диалоговым окном Preset Manager, чтобы можно было ограничить количество элементов, которые будут сохранены в новой библиотеке. Также, на наш взгляд, проще и нагляднее добавить несколько элементов в библиотеку, чем присоединять к ней другую большую библиотеку.

  3. Введите имя, оставьте без изменения расширение файла и его месторасположение, затем щелкните по кнопке Save (Сохранить).

Для того чтобы только что созданная библиотека появилась в меню панели выбора, а также в меню Preset Type в диалоговом окне Preset Manager, необходимо выйти из программы Photoshop и перезагрузить ее (рис. 21.21).

Рис. 21.20. Команда Save Shapes- в меню диалогового окна Preset Manager

Рис. 21.21. Новая библиотека в меню диалогового окна Preset Manager и во всплывающем меню Preset Type


  • Глава 22. Печать
    • Печать изображения из программы Photoshop
      • Распечатка на черно-белом лазерном принтере
      • Печать на цветном принтере, поддерживающем язык PostScript
      • Подготовка файла к печати на принтере IRIS, принтере с термической возгонкой красителя или фотонаборном устройстве
      • Диалоговое окно Print with Preview
      • Дополнительные опции печати
      • Применение треппинга
      • Печать нескольких копий изображения на одной странице
    • Подготовка файлов для других приложений
      • Перенос файлов из программы Photoshop в QuarkXPress
      • Перенос файлов из программы Photoshop в InDesign
      • Подготовка в программе Photoshop файлов для устройства вывода на пленку
      • Перенос файлов из программы Photoshop в Illustrator
      • Перенос файлов из программы Photoshop в CorelDRAW
      • Сохранение изображения в формате EPS
      • Сохранение изображения в формате DCS 2.0
      • Сохранение изображения в формате TIFF
      • Сохранение RGB-изображения в формате BMP или PICT
    • Двухцветные изображения
      • Создание дуплекса
      • Печать полутонового изображения с использованием красок PANTONE
    • Основы воспроизведения цвета
      • Выбор параметров в окне Custom CMYK
      • Сохранение параметров режима CMYK в виде настройки
      • Создание установок пробного отпечатка
      • Корректировка цветов, не входящих в цветовую гамму
      • Коррекция цвета

Глава №22.

Печать

Изображение в программе Photoshop может быть распечатано на лазерном или цветном принтере (например, струйном или устройстве с термической возгонкой красителя) или фотонаборном автомате. Изображение может быть импортировано из программы Photoshop и распечатано средствами графического редактора, такого как FreeHand или Illustrator; программы верстки, например QuarkXPress или InDesign; мультимедийного приложения, такого как Director или After Effects; либо подготовлено для просмотра в режиме реального времени (подробнее об этом см. главу 23).

В этой главе содержатся инструкции по выводу изображения на печать с использованием разных печатающих устройств, применению треппинга, подготовке изображения для другого приложения, сохранению файла в форматах EPS, DCS, TIFF, BMP или PICT, созданию двухцветных изображений, а также использованию цветов из каталога PANTONE. Последняя часть этой главы посвящена основам воспроизведения цвета. О том, как распечатать плашечный цветовой канал, см. раздел «Печать изображения с каналами заказного цвета» главы 11.

Нажмите и удерживайте кнопку мыши, указывая на левый нижний угол окна приложения, чтобы отобразить миниатюру текущей страницы, показывающую расположение картинки на листе бумаги. Чтобы получить информацию о файле, нажмите клавишу Alt и удерживайте нажатой кнопку мыши, указывая на то же поле (рис. 22.1).

В табл. 22.1 приведены данные, касающиеся разрешения устройств вывода на печать.

Рис. 22.1. Информация о файле и миниатюра страницы

Таблица 22.1. Разрешение устройств вывода на печать

Hewlett Packard LaserJet | 600 или 1200dpi
Hewlett Packard DeskJet | 600x300/2400x1200 dpi
IRIS SmartJet | 300 dpi (выглядит как 1600 dpi)
3M Rainbow | 300 dpi
Canon Color Laser/Fiery | 400-600 dpi
Epson Stylus Color/Photo струйный | 1440x720 dpi
Фотонаборное устройство вывода Linotronic | 1200-4000 dpi

Печать изображения из программы Photoshop

Только видимые слои и каналы будут отображаться при печати.

Распечатка на черно-белом лазерном принтере

  1. Выполните команду меню File > Print with Preview (Файл > Печать с предварительным просмотром) или нажмите сочетание клавиш Ctrl+P. При этом должен быть установлен флажок Show More Options (Показывать дополнительные опции).
  2. Установите требуемый режим в разделе Source Space (Цветовое пространство источника) - см. рис. 22.2.

    Опция Document (Документ) предполагает использование цветового профиля изображения (об управлении цветом см. главу 2), Proof Setup (Установки пробного отпечатка) - цветового профиля, который вы выбрали в диалоговом окне Proof Setup, вызываемом при помощи меню Edit (Правка).

Рис. 22.2. Диалоговое окно дополнительных опций печати. Параметры режима цветового пространства

  3. В разделе Print Space (Цветовое пространство принтера) в списке Profile (Профиль) выберите вариант Same As Source (Как у источника), чтобы произвести печать с использованием профиля, выбранного на предыдущем шаге. Если необходимо распечатать документ с использованием профиля другого цветового пространства, устройства офсетной печати, монитора или принтера, то выберите соответствующий профиль из всплывающего меню.
  4. Если доступен список Intent (Цель), то не меняйте в нем установленный по умолчанию вариант Relative Colori-metric (Относительная колориметрия). Выбираемое в списке Intent значение определяет, как будет преобразован цвет при использовании профиля, отличного от профиля источника.
  5. Убедитесь, что в диалоговом окне Print (Печать) не установлен флажок Print to File (Печать в файл).
  6. Щелкните по кнопке ОК.

Для того чтобы распечатать только часть изображения, выделите эту область с помощью инструмента Rectangular Marquee (Прямоугольная область). Затем в разделе Print Range (Диапазон страниц) диалогового окна Print (Печать) установите переключатель в положение Selection (Выделенная область).

Избыточное разрешение

Если разрешение изображения в два с половиной раза выше разрешения экрана (то есть выше разрешения, которое вам необходимо), то при отправке изображения на печать вы получите предупреждение. В этом случае скопируйте файл, выполнив команду меню File <=> Save As (Файл > Сохранить как), установив флажок As a Copy (Как копию), а затем уменьшите разрешение изображения, воспользовавшись командой Image > Image Size (Изображение > Размер изображения).

Печать на цветном принтере, поддерживающем язык PostScript

  1. Для того чтобы распечатать изображение на принтере PostScript Level 2 (или более высокого уровня), выберите соответствующие цветовые характеристики для устройства вывода на печать (в нашем примере использована цветовая модель CMYK). Воспользуйтесь командами Image > Mode > CMYK Color (Изображение > Режим > Цвет CMYK) и вы увидите результаты на экране.
  2. Выполните команду меню File > Page Setup (Файл > Параметры страницы) или нажмите комбинацию клавиш Ctrl+Shift+P.

    Выберите подходящий цветной принтер из выпадающего меню Name (Имя). Помните, что драйвер принтера должен быть установлен в вашей системе, тогда его имя появится в этом меню. Щелкните по кнопке ОК.

  3. Выполните команду File > Print with Preview (Файл > Печать с предпро-смотром) или воспользуйтесь комбинацией клавиш Ctrl+P.
  4. В разделе Source Space (Пространство источника) активизируйте опцию Document (Документ). Скорее всего, там будут присутствовать варианты U.S. Web Coated или Untagged CMYK, если вы не выбрали другое цветовое пространство CMYK в диалоговом окне Color Settings (Характеристики цвета).
  5. В разделе Print Space (Пространство принтера) из списка Profile (Профиль) выберите вариант Same As Source (Как у источника), чтобы печатать с помощью профиля исходного изображения. В процессе печати цвет не будет преобразовываться. Или подумайте, может быть, следует активизировать опцию PostScript Color Management (Управление цветом PostScript), если профиля принтера нет в списке Profile. При включении этой опции принтеру будет отправлена вся информация о цвете файла вместе с профилем Source Space. Принтер (а не программа Photoshop) будет управлять процессом преобразования цвета.

Единственный способ узнать, какое из значений параметра Print Space является лучшим, - это распечатать несколько пробных листов. Попробуйте задать различные цветовые пространства и решите, какие из них дают самые лучшие результаты при печати.

  6. Выберите вариант Relative Colorimetric (Относительная колориметрия) во всплывающем меню Intent (Цель), если оно доступно. Уже говорилось, что опция Intent определяет, как будет преобразован цвет, если профиль принтера имеет значение, отличное от Same As Source (Как у источника).
  7. Щелкните по кнопке Setup (Параметры), затем по Properties (Свойства), выберите опцию Color (Цвет) и щелкните по кнопке ОК.
  8. Щелкните по кнопке Print (Печать).

Если хотите распечатать только один слой или канал, перед выполнением команды File > Print (Файл > Печать) сделайте так, чтобы только этот слой или канал были видимыми.

Рис. 22.3. Окно Halftone Screens

Сервисная служба советовала нам не использовать цветовую модель Lab color в качестве режима изображения или профиля в списке Profile (Профиль) раздела Print Space (Цветовое пространство принтера). Почему? Дело в том, что очень мало пользователей осуществляют калибровку своих мониторов или редактируют изображения в режиме Lab. Также при печати изображения в режиме Lab на принтере с термической возгонкой красителя или принтере IRIS напечатанное изображение будет испещрено полосками, некоторые цвета могут сместиться. Ьсли же изображение находится в режиме CMYK, то результаты печати окажутся намного лучше. Проконсультируйтесь с соответствующей сервисной службой и сделайте несколько пробных отпечатков, воспользовавшись их советами.

Растры

Для принтера PostScript Level 2 в диалоговом окне Page Setup (Параметры страницы) щелкните по кнопке Screens (Растры). В системе Mac OS эта опция доступна только, если во всплывающем меню активизирована опция Adobe Photoshop 6. Затем снимите флажок Use Printer's Default Screens (Использовать принимаемый по умолчанию растр принтера) и установите флажок Use Accurate Screens (Использовать точные растры высокого разрешения) - см. рис. 22.3. Ничего не меняйте в поле Ink (Краска). Установка значений параметров в окне Halftone Screens (Полутоновый растр) произведет какой-либо эффект только в том случае, если распечатать документ из программы Photoshop или сохранить файл в формате EPS либо DCS 2, а затем распечатать, на принтере, поддерживающем язык PostScript.

Подготовка файла к печати на принтере IRIS, принтере с термической возгонкой красителя или фотонаборном устройстве

Перед печатью файла сохраните изображение с разрешением, соответствующим разрешению цветного принтера или фотонаборного устройства, с помощью которого вы будете его распечатывать.

  1. Для того чтобы распечатать файл на принтере PostScript Level 2, выполните команду меню File > Page Setup (Файл > Параметры страницы) и затем щелкните по кнопке Screens (Растры), снимите флажок Use Printer's Default Screens (Использовать принимаемый по умолчанию растр принтера), активизируйте опцию Use Accurate Screens (Использовать точные растры высокого разрешения) и дважды щелкните по кнопке ОК. Убедитесь, что в подменю File > Mode (Изображение > Режим) выбран вариант CMYK Color (Цвет CMYK), прежде чем сохранять файл в формате EPS.
  2. Воспользуйтесь командой File > Save As (Файл > Сохранить как), установив флажок As a Copy (Как копию) (комбинация клавиш Ctrl+Shift+S).
  3. Выберите папку, в которой будет сохранен файл.
  4. Выберите формат Photoshop EPS и щелкните по кнопке Save (Сохранить).
  5. Воспользуйтесь опцией Preview (Предварительный просмотр) - см. рис. 22.4. Выберите в списке Encoding (Кодировка) пункт Binary (Двоичная).

Рис. 22.4. Диалоговое окно EPS Options (Windows)

  6. Если в диалоговом окне Halftone Screens (Полутоновые растры) были изменены некоторые параметры (по совету сервисной службы), то установите флажок Include Halftone Screen (Включить полутоновый растр).
  7. Щелкните по кнопке ОК.

Основы цветоделения

Преобразуйте изображение в режим CMYK Color, затем выполните команду File > Print (Файл > Печать). В разделе Source Space (Пространство источника) поставьте переключатель в положение Document (Документ).'Рядом будет надпись U.S.Web Coated (SWOP) v2, если вы не выбрали другую опцию в диалоговом окне Color Setting (Характеристики цвета). В разделе Print Space (Цветовое пространство принтера) выберите опцию Separations (Цветоделение) в поле Profile (Профиль); затем щелкните по кнопке Print (Печать).

В диалоговом окне Print Options (Параметры печати) включите одну из следующих опций для того, чтобы проставить специальные типографские метки:

  • Calibration Bars (Калибровочные шкалы);
  • Registration Marks (Метки совмещения);
  • Corner Crop Marks (Угловые метки обреза);
  • Center Crop Marks (Боковые метки обреза);
  • Labels (Маркировка).

Некоторые из этих параметров могут быть недоступны при использовании принтера, не поддерживающего PostScript.

Диалоговое окно Print with Preview

Окно Print with Preview (Просмотр перед печатью) показано на рис. 22.5.

  1. Установите флажок Center Image (Изображение в центре), чтобы поместить изображение в центре страницы, либо снимите этот флажок и введите новые значения расстояния от верха и от левого края страницы, чтобы переместить изображение на странице.
  2. В разделе Scaled Print Size (Масштабирование при печати) поменяйте величину в поле Scale (Масштаб) или введите какие-либо значения в поля Height (Высота) и Width (Ширина), чтобы увеличить или уменьшить размеры изображения только для печати.

Параметры Scale, Height и Width связаны, так что изменение одной из этих опций соответственно повлияет и на другие.

  3. Установите флажок Scale to Fit Media (Масштабировать с подгонкой по размерам страницы). При этом изображение будет подогнано так, чтобы соответствовать размеру бумаги, выбранному при выполнении команды File > Page Setup (Файл > Параметры страницы).
  4. Установите флажок Show Bounding Box (Показать габаритную рамку), и изображение будет окружено пунктирной рамкой, показывающей его границы. Перетащите манипулятор или одну из границ, чтобы изменить размеры изображения только для печати.
  5. Если с помощью инструмента Rectangular Marquee (Прямоугольная область) выделена часть изображения, то можно активизировать опцию Print Selected Area (Печатать выделенную область), чтобы был напечатан только этот фрагмент.
  6. Установите флажок Show More Options (Дополнительные настройки), чтобы стали доступными группы параметров Output (Вывод) и Color Management (Управление цветом).

Рис. 22.5. Диалоговое окно Print with Preview

  7. В разделе Output (Вывод) имеется флажок Include Vector Data (Включить векторные данные). Установите его, чтобы программа Photoshop отпечатала границы векторных объектов (текста и фигур) с максимально высоким разрешением принтера.
  8. Щелкните по кнопке Print....

Дополнительные опции печати

Дополнительные опции печати находятся в диалоговом окне Print with Preview (Просмотр перед печатью) - см. рис. 22.6.

  1. Если вы хотите распечатать цветной фон для изображения, щелкните по кнопке Background (Фон) и выберите соответствующий цвет.
  2. Щелкните по кнопке Border (Рамка), чтобы напечатать черную рамку вокруг изображения. Потом выберите единицы измерения и введите значение в поле Width (Ширина), но не более десяти точек.

Рис. 22.6. Диалоговое окно параметров печати

  3. Щелчок по кнопке Bleed (Печать изображения в обрез) позволяет печатать ограничительные метки на определенном расстоянии Width (Ширина) от границы изображения (максимум 9,01 точек).
  4. Включение опции Caption (Заголовок) позволяет печатать текст, введенный в диалоговом окне при выполнении команды File > File Info (Файл > Информация о файле), вне области изображения.
  5. Опция Calibration Bars (Калибровочные шкалы) создает черно-белую и/или цветную полосу градации цвета вне изображения.
  6. Опция Registration Marks (Метки совмещения) создает метки, которые при печати позволяют точно совместить отдельные формы цветоделенных изображений.
  7. Опции Corner Crop Marks (Угловые метки обреза) и Center Crop Marks (Боковые метки обреза) создают короткие линии, которые указывают типографии обрезной формат издания.
  8. Опция Labels (Маркировка) позволяет печатать название изображения и наименования его каналов.

    Расположение перечисленных типографских меток относительно изображения показано на рис. 22.7.

  9. Если необходимо произвести вывод изображения в виде слайда, то узнайте в типографии, следует ли использовать опцию Negative (Негатив) или Emulsion Down (Эмульсией вниз).

Рис. 22.7. Расположение типографских меток относительно изображения

Рис. 22.8. Изображение, требующее применения треппинга

Рис. 22.9. Выбор значения в поле Width при выполнении команды Trap

  10. Опция Interpolation (Интерполяция) позволяет уменьшить неровности (зубчатость) контура при печати на принтерах PostScript Level 2 (и более высокого уровня).

Применение треппинга

При использовании команды Trap (Треп-пинг) программа Photoshop слегка надвигает друг на друга однотонные области изображения, чтобы предотвратить появление белых промежутков, что может случиться в случае сдвига меток совмещения или бумаги. Такое наложение необходимо только в том случае, если две смежные области используют менее двух одинаковых цветов из четырех основных (рис. 22.8). Для изображения с плавными цветовыми переходами или фотографического изображения треппинг не нужен.

Команда Trap объединяет все слои и использует только метод растяжения (spreading), в отличие от других аналогичных команд приложений, которые могут пользоваться методом сжатия (choking). Проконсультируйтесь в типографии, прежде чем использовать эту команду. Примените ее к копии изображения и сохраните оригинал без использования треппинга.

  1. Откройте изображение, к которому необходимо применить треппинг, и убедитесь, что оно находится в режиме CMYK Color (Цвет CMYK).
  2. Выполните команду Trap (Треппинг) из меню Image (Изображение).
  3. Если появится запрос о подтверждении, то щелкните по кнопке ОК.
  4. Введите значение, рекомендованное в типографии, в поле Width (Ширина) - см. рис. 22.9.
  5. Щелкните по кнопке ОК.

Печать нескольких копий изображения на одной странице

Одним из новшеств, появившихся в Photoshop 7, является возможность печати на одной странице разных изображений или копий одной картинки. Раньше для этого приходилось прибегать к помощи других приложений или проводить целый ряд дополнительных манипуляций в Photoshop. Необходимо было увеличить холст до размеров листа, на котором будет проходить печать, и вручную разместить на нем копии или разные картинки. Теперь эта процедура полностью автоматизирована.

  1. Выполните команду File > Automate > Picture Package (Файл > Автоматизация > Альбом) - см. рис. 22.10.
  2. Выберите источник в поле Use:
    • Frontmost Document - изображение из активного окна;
    • File - произвольный графический файл в поддерживаемом Photoshop формате;
    • Folder - группа файлов, находящихся в одном каталоге.

3. Выберите размер листа бумаги в поле Page Size (для листа формата А4 лучше использовать размер 8x10 дюймов, A3-11x17).

Рис. 22.10. Диалоговое окно команды Picture Package.

  4. Выберите количество копий (от 1 до 20) на листе в поле Layout.
  5. В случае выбора источника File в каждом из окон укажите графический файл.
  6. Задайте разрешение печати в поле Resolution.
  7. Задайте цветовую модель в поле Mode.
  8. По желанию. Введите текст комментария в поле Custom Text, предварительно выбрав в поле Content вариант Custom Text.
  9. Щелкните по кнопке ОК.

Создание альбома может занять много времени и требует большого расхода системных ресурсов, поэтому прежде чем выполнять команду Picture Package, лучше закрыть все остальные приложения.

Подготовка файлов для других приложений

Перенос файлов из программы Photoshop в QuarkXPress

Чтобы выполнить в программе QuarkXPress цветоделение изображения, созданного в программе Photoshop, преобразуйте его в режим CMYK, прежде чем импортировать в программу QuarkXPress. Различные фотонаборные устройства предъявляют различные требования к формату изображения, так что узнайте в отделе подготовки публикаций, сохранить ли изображение в формате TIFF, EPS или в одном из двух форматов DCS (см. соответствующие разделы этой главы). Воспользуйтесь форматом TIFF, если предполагаете применить средства управления цветом в программе QuarkXPress 4 или 5.

Перенос файлов из программы Photoshop в InDesign

Программа InDesign может выполнить цветоделение изображения в формате Photoshop PDF (режим RGB или CMYK), а также импортировать напрямую PSD-файлы. Также программа может считать профиль ICC, включенный в файл Photoshop.

Подготовка в программе Photoshop файлов для устройства вывода на пленку

В издательской индустрии для создания высококачественных изображений широко используются цветные диапозитивы. Файл из программы Photoshop может быть передан на устройство вывода на пленку для создания цветного диапозитива.

Параметры вывода изображения на подобное устройство могут варьироваться в зависимости от устройства. Однако в любом случае необходимо, чтобы число точек по высоте и ширине соответствовало значениям, требуемым для данного устройства. Если исходное изображение предполагается получить путем сканирования, то следует принять во внимание требования устройства вывода на пленку при установке разрешения сканера, размеров изображения и файла, в который записывается изображение.

Допустим, например, что вам необходимо создать цветной диапозитив размером 4x5 дюймов на устройстве вывода на пленку Solitaire. Ваша сервисная служба сообщит вам, что для вывода изображения на устройство Solitaire вы можете использовать четырехкилобайтовые изображение размером 4096x3276 пикселов с разрешением 819 dpi; восьмикилобайтовые изображение размером 8192x6553 пикселов с разрешением 1638 dpi или 16-килобайто-вые изображение размером 16384x13107 пикселов с разрешением 3276 dpi. Другие устройства вывода на пленку могут требовать других значений разрешения.

Выполните команду File > New (Файл > Создать), введите необходимые размеры изображения и его разрешение, а затем выберите режим RGB Color. Щелкните по кнопке ОК и создайте готовое изображение в программе Photoshop. Или запишите разрешение и размеры изображения и передайте эти данные в отдел подготовки публикаций, чтобы они отсканировали изображение с учетом ваших требований.

Сохранение прозрачного фона

Рис. 22.11. Раздел File Handing в диалоговом окне Preferences

и при этом сохранить фон прозрачным, сохраните изображение вместе с контуром отсечения слоев (см. главу 16, раздел «Контуры отсечения слоев»).

Проверка параметров настройки диалогового окна Preferences

Прежде чем сохранять файл для дальнейшего его использования в другой программе, выясните, необходимо ли для работы с ней установить флажок Maximize Backwards Compatibility (Максимизировать совместимость форматов) в разделе Saving Files (Сохранение файлов) диалогового окна Preferences (Установки), чтобы можно было открыть в этой программе файл в формате Photoshop (рис. 22.11). Эта опция позволяет сохранить композитное изображение для предварительного просмотра (наряду с копиями слоев) для приложений, которые не поддерживают слои. Также сохраняется растровая копия каждого векторного объекта для приложений, не работающих с векторными данными. Имейте в виду, что при активизации этой опции понадобится больше времени для сохранения файла, а также возрастет его размер. Кроме того, некоторые приложения требуют сохранения миниатюры изображения (поле Image Previews (Предварительный просмотр изображений,)) - см. рис. 22.11. Но если вы создаете Web-файл, не выбирайте эту опцию, чтобы сэкономить дисковое пространство и ускорить процесс загрузки файла.

Перенос файлов из программы Photoshop в Illustrator

Разработчики программы Photoshop обеспечили ее максимальную совместимость с Illustrator. Если перетащить выделенную область или слой из программы Photoshop в Illustrator, то в последней, на палитре Layers (Слои), появится изображение в виде группы, содержащей собственно картинку и контур отсечения. При этом не будут учитываться значения непрозрачности, режимы смешивания, маски и отсеченные области изображения.

С помощью инструмента Path Component Selection (Выбор компонентов контура) можно перетащить контур отсечения слоев из программы Photoshop в Illustrator. Либо можно воспользоваться командой Export Paths to Illustrator (Экспорт контуров в Illustrator) меню File в программе Photoshop, чтобы экспортировать сохраненный контур, а затем открыть этот файл в программе Illustrator. В любом случае контур станет в программе Illustrator редактируемым векторным объектом без какой-либо заливки или обводки.

Если просто скопировать слой в программе Photoshop и вставить его в Illustrator, то маска слоя или контур отсечения слоев будут проигнорированы.

Если установить флажок Link (Связь) в диалоговом окне Place (Поместить) программы Illustrator и поместить в нем изображение из программы Photoshop, то оно появится на палитре Layers (Слои) в качестве слоя некоторого изображения. Изображение будет иметь надлежащую маску, но некоторые режимы смешивания могут дать неожиданные эффекты.

Если изображение было перенесено из программы Photoshop при снятом флажке Link (Связь) или открыто в программе Illustrator, то можно будет выбирать, преобразовать ли слои в объекты или в единый слой, полученный в результате объединения слоев. Если вы выбрали режим преобразования слоев программы Photoshop в объекты, то каждый объект появит ся на своем собственном вложенном слое в пределах подслоя изображения. При этом фон останется отдельным непрозрачным слоем. Его можно будет удалять или редактировать в программе Illustrator.

Все значения параметров непрозрачности и режимов смешивания будут сохранены и в дальнейшем могут быть отредактированы в программе Illustrator. Маски слоя и контуры отсечения станут непрозрачными масками. Все контуры отсечения, представленные на палитре Paths (Контуры) и сохраненные в файле Photoshop, останутся действующими. При этом слои фигур станут слоями изображения, а не векторными объектами. У каждого отдельного слоя будут границы, соответствующие размеру исходного изображения в программе Photoshop.

Если вы выберете режим объединения слоев изображения в один слой, то все значения прозрачности, режимы смешивания и эффекты маски слоя будут видимыми, но их нельзя будет редактировать в программе Illustrator. Все контуры отсечения, представленные на палитре Paths и сохраненные в файле Photoshop, останутся действующими.

Разрешение любого изображения в формате TIFF, EPS или PSD не будет изменено при открытии и перемещении файла из программы Photoshop в Illustrator. Но изображение поменяет цветовой режим на режим, установленный в программе Illustrator. К импортированному изображению могут быть применены растровые фильтры, растровые эффекты и некоторые векторные эффекты программы Illustrator.

Перенос файлов из программы Photoshop в CorelDRAW

Сохраните файл в одном из форматов EPS, TIFF, JPEG, BMP или PSD (формат программы Photoshop) в цветовом режиме RGB или CMYK. В программе CorelDRAW воспользуйтесь командой File > Import (Файл > Импорт), чтобы открыть файл. В качестве альтернативы можно перетащить слой, либо скопировать и вставить слой или выделенную область из программы Photoshop в окно программы CorelDRAW. Программа CorelDRAW 9 (или более поздняя версия) может работать с изображениями, имеющими слои и импортированными из программь: Photoshop. При этом каждый слой станет отдельным объектом. Можно воспользоваться командой Export Paths to Illustrator (Экспорт контуров в Illustrator), чтобы экспортировать контур из программы Photoshop в файл, а затем открыть его в программе CorelDRAW.

Как только файл импортирован в программу CorelDRAW, растровое изображение можно перемещать, редактировать, преобразовывать в другой цветовой режим или изменить глубину цвета; а также сделать повторную выборку изображения, изменяя его размер и/или разрешение. Можно создать цветовую маску в программе CorelDRAW, чтобы замаскировать некоторые области растрового изображения.

Сохранение изображения в формате EPS

Формат EPS очень удобен для импорта изображения из Photoshop в Illustrator или программу верстки (например, QuarkXPress, PageMaker или InDesign). Распечатать EPS-файл можно только на принтере, поддерживающем или эмулирующем язык PostScript.

  1. Если предполагается, что в других приложениях будет осуществляться цветоделение, то выполните команды Image > Mode > CMYK Color (Изображение > Режим > Цвет CMYK).
  2. Воспользуйтесь командой меню File > Save As (Файл > Сохранить как) или нажмите комбинацию клавиш Ctrl+ Shift+S.
  3. Введите имя файла и выберите папку, в которой он будет сохранен.
  4. Выберите формат Photoshop EPS.
  5. По желанию. Установите флажок Embed Color Profile (Встроить цветовой профиль), чтобы программа Photoshop вставила цветовой профиль, идентифицирующий рабочее цветовое пространство. Также можно включить режим Use Proof Setup (Использовать установки пробного отпечатка). Если включить эту опцию, то к файлу будет присоединена «экранная версия» - то есть на экране будет предварительно видно, как распечатается изображение на определенном типе принтера. Подробнее об управлении цветом рассказано в главе 2.

    Щелкните по кнопке Save. Обратите внимание: слои будут объединены.

Рис. 22.12. Диалоговое окно EPS Options

  6. Во всплывающем меню Preview (Предварительный просмотр) включите опцию 1 bit/pixel (1 бит/пиксел), чтобы сохранить файл с возможностью предварительного просмотра в черно-белом режиме, или выберите 8 bits/pixel (8 бит/пиксел), чтобы сохранить файл с возможностью предварительного просмотра в полутоновом или цветном режиме (рис. 22.12).
  7. В большинстве случаев следует выбрать вид кодировки Binary (Двоичная), так как файлы с двоичной кодировкой меньше по размеру и быстрее обрабатываются по сравнению с ASCII-файлами. Однако для некоторых приложений, принтеров, поддерживающих PostScript, и утилит печати, которые не могут обрабатывать файл с двоичной кодировкой, придется выбрать способ кодировки ASCII. JPEG - самый быстрый метод кодировки, но при его применении теряются некоторые данные. JPEG-файл может быть распечатан только на принтере PostScript Level 2 или принтере более высокого уровня.
  8. Если в диалоговом окне Halftone Screens (Полутоновые растры) была изменена линиатура, угол или форма точек растра, то установите флажок Include Halftone Screen (Включить полутоновый растр).
  9. Опция PostScript Color Management (Управление цветом PostScript) преобразует данные о цвете файла в цветовое пространство принтера. Не включайте эту опцию, если собираетесь импортировать файл в другое приложение, обладающее средствами управления цветом, иначе цвет может измениться непредсказуемым образом!
  10. Если на странице находятся векторные элементы (фигуры или текст), то установите флажок Include Vector Data (Включить векторные данные). Обратите внимание на то, что сохраненные в EPS-файле векторные данные доступны в других приложениях, но если вы снова откроете этот файл в программе Photoshop, то векторные данные будут преобразованы в растровое представление.
  11. Включите флажок Image Interpolation (Интерполяция изображения), если изображение имеет низкое разрешение и к нему необходимо применить сглаживание.
  12. Щелкните по кнопке ОК.

Сохранение изображения в формате DCS 2.0

Формат DCS является вариантом формата EPS и имеет две версии. Формат DCS 1.0 (Desktop Color Separation - настольное цветоделение) заново выполняет цветоделение для изображения в программе Photoshop и создает пять связанных файлов, один для каждого канала CMYK и один для смешанного канала CMYK. Более новый формат DCS 2.0 сохраняет все альфа-каналы и шишечные цветовые каналы наряду с цветовыми каналами, а также позволяет выбирать, сохранить ли каналы комбинированных цветов в одном файле или в нескольких. DCS-файл может быть распечатан только на принтере, поддерживающем язык PostScript.

  1. Выполните команды Image > Mode > CMYK Color (Изображение > Режим > Цвет CMYK) и затем воспользуйтесь командой Save As (Сохранить как) в меню File (Файл) или нажмите комбинацию клавиш Ctrl+Shift+S. Введите имя файла и укажите папку, в которой будет сохранен файл, а затем выберите формат Photoshop, DCS 2.0.

Рис. 22.13. Диалоговое окно DCS 2.0 Format

  2. Рекомендация. Установите флажок Embed Color Profile (Встроить цветовой профиль) или Use Proof Setup (Использовать установки пробного отпечатка). Подробнее см. п. 5 раздела «Сохранение изображения в формате EPS» этой главы. Щелкните по кнопке Save (Сохранить).
  3. Из всплывающего меню Preview (Предварительный просмотр) выберите опцию 1 bit/pixel (1 бит/пиксел), чтобы сохранить файл с возможностью предварительно просмотра в черно-белых тонах; или опцию 8 bit/pixel (8 бит/ пиксел), чтобы сохранить файл с возможностью предварительного просмотра в полутонах или цвете.
  4. В поле DCS укажите вариант Single File (Один файл), что обеспечит вывод всех результатов цветоделения в один файл, или вариант Multiple File (Несколько файлов), чтобы создать по одному файлу для каждого отдельного цвета. Кроме того, выберите способ предварительного просмотра: No Composite (He композитное изображение), Grayscale Composite (Полутоновое композитное изображение) или Color Composite (Цветное композитное изображение) -см. рис. 22.13.
  5. Выберите способ кодировки: Binary (Двоичная), ASCII или JPEG (со сжатием).
  6. Проверьте, что отключены флажки Include Halftone Screen (Включить полутоновый растр) и Include Transfer Function (Включить функцию передачи). Пусть сотрудники отдела подготовки публикаций помогут вам выбрать установки для этих опций.
  7. Установите флажок Include Vector Data (Включить векторные данные), если в изображении есть какая-либо векторная графика (фигуры или текст).
  8. Включите опцию Image Interpolation (Интерполяция изображения), если необходимо применить сглаживание к изображению с низким разрешением.
  9. Щелкните по кнопке ОК.

Режим Multichannel

Можно сохранить изображение, имеющее режим Multichannel (Многоканальный), в формате Photoshop DCS 2.0 в одном или нескольких файлах. Этот формат позволяет сохранять каналы. Изображение в режиме Multichannel не может быть сохранено в формате EPS, если требуется композитная печать (на одной странице). Изменение режима изображения на Multichannel приводит к объединению всех слоев и преобразованию каналов изображения в каналы заказного цвета.

Сохранение изображения в формате TIFF

Файл в формате TIFF может быть импортирован многими приложениями, включая QuarkXPress, PageMaker и InDesign. Для этого формата распознаются профили цвета, и возможна установка параметров управления цветом. Программы QuarkXPress, PageMaker и InDesign могут выполнить цветоделение для изображения, имеющего режим CMYK и сохраненного в формате TIFF.

Программа Photoshop позволяет сохранять слои в формате TIFF, для этого установите флажок Layers (Слои). Также можно включить опцию сохранения пла-шечных цветовых каналов и примечаний к файлу.

Для доступа к расширенным возможностям формата TIFF выполните команды Edit> Preferences > File Handling (Правка > Установки > Сохранение файлов) и установите флажок Enable advanced TIFF save options (Включить дополнительные опции сохранения формата TIFF).

Только немногие программы для верстки и графические редакторы могут работать со слоями в формате TIFF, поэтому при импортировании изображения в формате TIFF будет применена операция объединения слоев.

  1. Выполните команды Image > Mode > CMYK Color (Изображение > Режим > Цвет CMYK), затем в меню File (Файл) воспользуйтесь командой Save As (Сохранить как) или нажмите комбинацию клавиш Ctrl+Shift+S. Введите имя файла и обозначьте папку, в которой он будет сохранен.
  2. Выберите формат TIFF.
  3. Рекомендация. Не все программы могут импортировать TIFF-файлы с альфа-каналами. Если программа, в которую следует импортировать файл, не распознает такие файлы, то снимите флажок Alpha Channels (Альфа-каналы), чтобы отбросить их. Установите или снимите флажки Save (Сохранить), если используются расширенные возможности формата TIFF.
  4. Рекомендация. Установите флажок Embed Color Profile (Встроить цветовой профиль), чтобы программа Photoshop включила текущий цветовой профиль в файл в формате TIFF. Подробнее об управлении цветом рассказано в главе 2.

Рис. 22.14. Диалоговое окно TIFF Options

  5. Щелкните по кнопке Save (Сохранить).
  6. Если доступны расширенные свойства TIFF-файла, выберите какой-либо метод сжатия в разделе Compression (Сжатие) - см. рис. 22.14. Все методы сжатия уменьшают размер файла. Однако некоторые программы не могут открыть TIFF-файл, уплотненный с помощью метода JPEG или ZIP. В данном случае рекомендуем использовать метод сжатия LZW; при этом данные изображения не будут утеряны.

Если необходимо выполнить цветоделение файла, то сервисные службы рекомендуют не пользоваться никакими методами сжатия.

  7. Выберите вариант IBM PC или Macintosh в зависимости от платформы, куда будет экспортирован файл.
  8. Если доступны расширенные параметры формата TIFF, установите флажок Save Image Pyramid (Сохранить пирамиду изображения), чтобы создать файл, содержащий элементы изображения с различным разрешением. Программа Photoshop, в отличие от InDesign, не предлагает каких-либо опций для открытия пирамид изображений.

    Установите флажок Save Transparency (Сохранить прозрачность), если в изображении есть прозрачные области.

  9. Щелкните по кнопке ОК.

Программа Photoshop не может сохранить прозрачные области, не сохранив и слои. Поэтому убедитесь, что включены обе опции.

Сохранение RGB-изображения в формате BMP или PICT

BMP или PICT-файл может быть открыт или помещен в качестве растрового изображения в программе Adobe Illustrator. Оба типа файлов могут быть импортированы во многие мультимедийные приложения.

Однако оба они не доступны для изображений, использующих CMYK.

  1. Выполните команду Save As (Сохранить как) в меню File (Файл).
  2. Введите имя файла и определите папку, в которой будет сохранен файл.
  3. Выберите формат BMP, щелкните по кнопке Save (Сохранить) и затем выберите нужную опцию в разделе File Format (Формат файла).
  4. Включите одну из опций разделе Depth (Глубина) - см. рис. 22.15.
  5. Выберите метод сжатия. Параметры для изменения степени сжатия файлов в формате JPEG доступны только для изображения с 32-битным разрешением. Чем ниже качество (quality) сжатия, тем лучше сжимается файл. Если в дальнейшем необходимо импортировать файл в мультимедийное приложение, то воспользуйтесь разрешением 16 бит/пиксел.
  6. Щелкните по кнопке ОК.

Рис. 22.15. Окно BMP Options

Сжатие файла

Для того чтобы уменьшить размер файла, воспользуйтесь программами сжатия, например WinZip или PKZip. Эти программы сжимают файл без потери каких-либо данных.

Если у вас нет программ сжатия, воспользуйтесь командой Save As (Сохранить как) из меню File (Файл) и выберите формат TIFF из всплывающего меню Format (Формат). Если хотите сохранить файл без альфа-каналов, снимите флажок Alpha Channels (Альфа-каналы). Щелкните по кнопке Save. В разделе Compression (Сжатие) диалогового окна TIFF Options (Опции формата TIFF) установите флажок LZW или ZIP. Такое сжатие также не вызывает потери данных. Однако учтите, что не все приложения смогут импортировать файл в формате TIFF при использовании LZW или Zip-сжатия. А некоторые приложения импортируют подобный файл, только если он не содержит альфа-каналов.

Если необходимо сохранить изображение для последующего его вывода на печать, лучше не использовать формат JPEG, так как при таком сжатии теряются данные. Потеря данных может оказаться незаметной на экране, но будет видна при печати на принтерах с высоким разрешением. JPEG-файлы наиболее удобны при загрузке файла в сеть.

Двухцветные изображения

Лишь около 50 оттенков цвета могут быть распечатаны с помощью одной печатной формы, поэтому в типографии часто просят использовать для печати полутоновых изображений две или более печатных форм вместо одной, добавляя промежуточные или яркие тона, чтобы расширить диапазон цвета в изображении. Дополнительные печатные формы могут быть серыми или цветными. В программе Photoshop можно преобразовать изображение в режим Duotone (Двухтоно-вый), чтобы создать дуплексное (две печатных формы), триплексное (три печатных формы) или квадроплексное (четыре печатных формы) изображение.

Печать дуплекса имеет свои особенности, так что посоветуйтесь по данному вопросу с сотрудниками вашей типографии. Эффект дуплексного представления изображения невозможно испробовать на цветном принтере, поддерживающем язык PostScript. Надежным можно считать лишь пробный отпечаток. Если вы только начали работать с дуплексами, то попробуйте стандартные варианты кривых (для двуцветной, трехцветной или четырехцветной печати), которые есть в программе Photoshop. Можно загрузить их и использовать без изменения либо приспособить под собственные нужды. Щелкните по кнопке Load (Загрузить) в диалоговом окне Duotone Options (Параметры дуплекса), и затем откройте папку Photoshop/Presets/Duotone.

Создание дуплекса

  1. Выполните команды меню Image > Mode> Grayscale (Изображение > Режим > Градации серого). Лучше всего применять эту функцию к высококонтрастному изображению.
  2. Затем воспользуйтесь командами Image > Mode > Duotone (Изображение > Режим > Двухкрасочный).
  3. Установите флажок Preview (Предварительный просмотр), чтобы сразу увидеть изменения цвета и кривых.
  4. Во всплывающем меню Туре (Тип) выберите пункт Duotone (Двухкрасочный) - см. рис. 22.16а.
  5. Щелкните по цветному квадратику Ink 2 (Краска 2) - см. рис. 22.16в. Ink 1 -самая темная краска; чем больше номер краски, тем она должна быть светлее.
  6. Для того чтобы выбрать образец определенного цвета, например, из каталога PANTONE, из всплывающего меню Book (Книга) выберите подходящий вариант, затем введите номер цвета (рис. 22.16г) или щелкните по образцу. Спокойные цвета в двухтоновом изображении смотрятся лучше, чем яркие.

    Есть и другой способ. Для того чтобы выбрать основные цвета, щелкните по панели выбора цвета и введите процентные значения в поля С, М, Y и К для цвета в модели CMYK.

  7. Щелкните по кнопке ОК.
  8. Для основного цвета введите имя в поле рядом с цветным квадратиком. Если выбран цвет из палитры, то не меняйте имя, которое уже имеется.
  9. Щелкните по кривой в строке Ink 2 (Краска 2) - см. рис. 22.166.

Рис. 22.16. Диалоговое окно Duotone Options

Рис. 22.17. Диалоговое окно Doutone Curve

  10. Перетащите кривую вверх/вниз в диалоговом окне Doutone Curve (Кривая дуплекса) - см. рис. 22.17. Для того чтобы дуплексное изображение выглядело хорошо, кривые красок 1 и 2 должны отличаться друг от друга.
  11. Щелкните по кнопке ОК.
  12. Щелкните по кривой Ink 1 (Краска 1) и повторите шаги 10 и 11.
  13. По желанию. Щелкните по кнопке Save (Сохранить), чтобы сохранить текущие установки для других изображений.
  14. Щелкните по кнопке ОК, чтобы закрыть диалоговое окно.
  15. Сохраните файл в формате EPS.

Для того чтобы уменьшить насыщенность черного цвета для светлых тонов, введите значение 0 в поле 5% для кривой Ink 1. Для того чтобы уменьшить насыщенность цвета темных областей, введите значение 85 в поле 100% для кривой Ink 2.

Если вы воспользовались цветом из каталога красок PANTONE и собираетесь печатать изображение с помощью программы для верстки или графического редактора, то установите флажок Short PANTONE Names (Короткие имена PANTONE) в диалоговом окне, открывающемся при выполнении команд Edit > Preferences > General (Правка > Установки > Общие).

Три и четыре тона

Печать трехтонового (три краски) или четырехтонового (четыре краски) изображения требует четко определить последовательность, в которой будут накладываться краски. Можно воспользоваться диалоговым окном Overprint Colors (Наложение цветов), чтобы увидеть на экране различные варианты следования цвета друг за другом, но установки этого окна не будут влиять на то, как напечатается изображение. Посоветуйтесь с сотрудниками вашей типографии по вопросу печати подобных изображений.

Диалоговое окно Duotone Options (Параметры дуплекса) открывается с теми параметрами, которые были установлены в последний раз при открытии этого окна. Если тип изображения был изменен, а вам необходимо восстановить последние установленные параметры, то нажмите клавишу Alt и щелкните по кнопке Reset (Восстановить).

Замечательные кривые

Изменение формы кривой дуплекса повлияет на интенсивность краски при воспроизведении светлых, темных и средних тонов изображения. Если кривая имеет вид, представленный на рис. 22.16в, то краска Ink 2 будет соответствовать средним тонам. Для того чтобы создать четкое дуплексное изображение, попробуйте распределить краски 1 и 2 по разным тоновым диапазонам.

Пример. Воспользуйтесь черным цветом в качестве краски 1 в темных областях изображения, немного меньше - в промежуточных, и совсем в небольших количествах - в самых светлых. Затем используйте краску 2: более насыщенный цвет для промежуточных и светлых областей и менее насыщенный - для темных.

Рис. 22.18. Диалоговое окно Doutone Curve для однокрасочного изображения

Печать полутонового изображения с использованием красок PANTONE

Далее представлен не требующий больших затрат, но эффективный способ расширения диапазона оттенков для полутонового изображения. Оно будет распечатано как однотонное с помощью одной краски (с использованием одной печатной формы).

  1. Откройте полутоновое изображение.
  2. Выполните команды Image > Mode > Duotone (Изображение > Режим > Двухкрасочный).
  3. Из выпадающего меню Туре (Тип) выберите вариант Monotone (Однокрасочный).
  4. Щелкните по цветному квадратику Ink 1 и затем по кнопке Custom (По выбору пользователя), выберите соответствующий цвет из каталога красок PANTONE и щелкните по кнопке ОК.
  5. В диалоговом окне Duotone Options (Параметры дуплекса) щелкните по кривой Ink 1.
  6. В поле 100% введите необходимое значение окраски (в процентах) - см. рис. 22.18. Оставьте в поле 0% значение О и не вводите какие-либо значения в другие поля. Щелкните по кнопке ОК.
  7. Еще раз щелкните по кнопке ОК, чтобы закрыть диалоговое окно.
  8. Сохраните файл в формате EPS.

Основы воспроизведения цвета

Монитор использует сложение цветов (красного, зеленого и синего), в то время как устройства офсетной печати применяют вычитание цветов, используя краски модели CMYK или плашечные цвета. Получение действительно корректного воспроизведения цветов с использованием модели CMYK при офсетной печати -это настоящее искусство. Отпечатанное изображение будет походить на изображение на экране, только если монитор будет калиброван в соответствии с параметрами устройства вывода на печать.

В этом разделе обсуждается офсетная печать изображения. О том, как загрузить изображение в сеть, рассказано в главе 23.

Программа Photoshop определяет, как преобразовать изображение в режиме RGB в режим CMYK и как предварительно просмотреть изображение в режиме CMYK, используя параметры, установленные в диалоговом окне, открывающемся после выполнения команды Image > Color Settings (Изображение > Характеристики цвета). Некоторые разделы этого окна рассматриваются далее.

Три основных шага при проведении цве-тоделейия:

  1. Выбрать значения параметров в окне Color Settings.
  2. Создать пробный отпечаток с этими параметрами.
  3. Сравнить экранное изображение с пробным отпечатком.

Выбор параметров в окне Custom CMYK

  1. Воспользуйтесь командой Edit > Color Settings (Правка > Характеристики цвета).
  2. В разделе Working Spaces (Рабочие пространства) из всплывающего меню CMYK выберите принимаемые по умолчанию в США характеристики, которые будут соответствовать выбранному устройству печати и типу бумаги (если только вы не распечатываете файл в Японии или Европе).
  3. Если необходимо изменить параметры режима CMYK, то выберите пункт Custom CMYK (Настройка CMYK). Введите имя нового набора параметров цвета и выберите или введите требуемые опции в разделе Ink Options (Параметры красок) для офсетной печати (рис. 22.19), такие как Ink Colors (Цвета красок) и Dot Gain (Растискивание). Посоветуйтесь с сотрудниками вашей типографии по поводу этих характеристик. На рис. 22.19 показано диалоговое окно Custom CMYK (Настройка CMYK), в котором были изменены значения в полях Black Ink Limit (Предел черной краски) и Total Ink Limit (Общий предел краски) в соответствии с советами типографии. Результат виден на графике.

Другие характеристики офсетной печати вводятся в разделе Separation Options (Параметры цветоделения), но так как эти характеристики тесно связаны с типом устройства печати, необходимо проконсультироваться по этому вопросу в типографии.

Рис. 22.19. Диалоговое окно Proof Setup

Переключатель Separation Type (Тип цветоделения) дает программе Photoshop информацию о том, какой алгоритм используется при печати: метод GCR (Gray Component Replacement - Замещение серого компонента) или UCR (Undercolor Removal - Удаление паразитных цветов), и как используется черная краска.

Опция Black Generation (Содержание черного) регулирует содержание черной краски при преобразовании RGB-составляющих в краски CMY. Черная краска заменяет определенную долю CMY-красок, чтобы предотвратить получение грязного цвета при смешивании. Значение в поле Black Generation определяет, какое количество черной краски используется для замены.

И наконец, в каждой типографии используется свое собственное процентное содержание красок в каждой печатной форме. Некоторые типографии используют менее 100%. Узнайте в вашей типографии допустимое значение поля Total Ink Limit (Общий предел краски).

Ниже приведены советы, которые помогут вам работать с цветом в программе Photoshop 7.

Учет требований типографии

Как было отмечено, цветоделение - это искусство. Начните с того, что обсудите следующие вопросы в типографии, чтобы можно было выбрать правильные параметры разрешения для сканера и установить определенные значения в диалоговом окне Custom CMYK (Настройки CMYK).

Какое значение линиатуры будет использоваться при офсетной печати изображения? Это поможет вам выбрать соответствующее разрешение сканера.

Какое значение растискивания можно выбрать для данного типа бумаги и устройства печати? Соответствующее значение растискивания может быть указано в диалоговом окне Custom CMYK.

Какой метод печати будет использоваться - UCR или GCR? С помощью метода GCR получаются лучшие результаты при печати. В диалоговом окне Custom CMYK эта опция включена по умолчанию.

Каково общий предел использования красок и предел черной краски для данного устройства печати? Настройка этих значений также может быть выполнена в диалоговом окне Custom CMYK.

Измените значения перечисленных параметров, прежде чем поменять режим RGB на CMYK. Если необходимо изменить эти характеристики после изменения режима, придется преобразовать изображение обратно в режим RGB, изменить характеристики и потом снова поменять режим на CMYK.

В каком формате следует сохранить файл? Узнайте в типографии, какой формат файла необходим.

Параметры цветовой пробы

Для того чтобы в палитре Info (Информация) отображалась общая информация о процентном содержании красок в пикселах, расположенных непосредственно под указателем, выберите режим Total Ink (Все краски) из всплывающего меню, расположенного под значком «пипетки» на указанной палитре (рис. 22.20). Отображаемые значения зависят от текущих параметров CMYK.

Рис. 22.20. Отображение процентного содержания красок CMYK на палитре Info

Рис. 22.21. Диалоговое окно Color Settings

Сохранение параметров режима CMYK в виде настройки

Вместо того чтобы каждый раз при преобразовании изображения из режима RGB в режим CMYK заново вводить указанные характеристики, можно сохранить их в виде настройки с помощью диалогового окна Custom CMYK (Настройки CMYK).

  1. После того как вы введете CMYK-параметры в диалоговом окне Custom CMYK (Настройки CMYK), укажите имя новых настроек в поле Name и щелкните по кнопке ОК.
  2. В окне Color Settings (Характеристики цвета) щелкните по кнопке Save (Сохранить) - см. рис. 22.21. Введите имя файла, оставьте без изменений папку, в которой будет сохранен файл, и снова щелкните по кнопке Save.
  3. Введите какие-либо комментарии в диалоговом окне Color Settings Comment (Комментарии к параметрам цвета) и дважды щелкните по кнопке ОК. В следующий раз при выводе документа на то же устройство офсетной печати откройте диалоговое окно Color Settings и из всплывающего меню Settings (Характеристики) выберите установки, которые только что были сохранены.

Эти установки влияют на преобразование изображения из режима RGB в режим CMYK. Если впоследствии необходимо будет изменить параметры преобразования, то придется снова преобразовать изображение из режима RGB в режим CMYK. Всегда сохраняйте копию вашего изображения в режиме RGB, чтобы потом иметь возможность для его повторного преобразования.

Еще одна возможность

Для того чтобы сохранить выбранные параметры CMYK в виде цветового профиля, в диалоговом окне Color Settings (Характеристики цвета), в разделе Working Spaces (Рабочие пространства) из всплывающего меню CMYK выберите пункт Save CMYK (Сохранить CMYK). Оставьте без изменений имя файла, его расширение и папку, в которой будет сохранен файл, и потом щелкните по кнопке Save (Сохранить). Теперь доступ к новому профилю можно получить, выбрав в меню CMYK пункт Load (Загрузить).

Создание установок пробного отпечатка

С помощью команд Proof Colors (Цвета пробного отпечатка) и Proof Setup (Установки пробного отпечатка) можно предварительно просмотреть изображение на экране в соответствии с выбранным профилем CMYK, сформированным при выполнении вышеуказанных шагов, или с цветовым профилем тех устройств вывода на печать, которые доступны в вашей операционной системе. Экранный вариант дает довольно точное представление о том, как будет выглядеть изображение после его распечатки на том или ином печатающем устройстве.

  1. Выполните команды View > Proof Setup > Custom (Вид > Установки пробного отпечатка > По выбору пользователя).
  2. Из всплывающего меню Profile (Профиль) выберите CMYK-профиль, созданный при выполнении вышеуказанных шагов (рис. 22.22). Если в окне Color Settings установлен созданный вами CMYK-профиль (об этом подробно рассказано выше), то в таком случае в списке профилей будет выбран именно он. Если это не так, то в нижней части меню найдите нужный вам профиль.

Рис. 22.22. Диалоговое окно Proof Setup

  3. Выберите значение параметра Intent (Цель). По данному вопросу посоветуйтесь в вашей типографии. Подробнее об этой опции см. раздел «Настройка параметров операции преобразования» главы 2.
  4. Щелкните по кнопке Save и введите имя файла. Оставьте расширение и месторасположение файла без изменений. Щелкните по кнопке Save еще раз, затем щелкните по кнопке ОК.
  5. В меню View (Вид) выполните команду Proof Colors (Цвета пробного отпечатка) или нажмите комбинацию клавиш Ctrl+Y, чтобы включить функцию предварительного просмотра (рядом должна появиться галочка). Сохраненный профиль пробного отпечатка будет находиться в нижней части подменю Proof Setup.

Если установлен флажок Proof Colors, то имя используемого профиля предварительного отпечатка будет отображено рядом с именем документа.

Опцию Proof Colors необходимо включать для каждого открытого документа. Экранное представление изображения в режиме RGB теперь будет соответствовать тому набору параметров, который был выбран в подменю Proof Setup (в данном случае CMYK-профиль), но действительный вид изображения будет изменен только при его преобразовании в режим CMYK с использованием текущих значений в диалоговом окне Color Settings.

Корректировка цветов, не входящих в цветовую гамму

Если преобразовать изображение в режим CMYK, то его цвета автоматически будут преобразованы в цветовую гамму принтера. Однако иногда бывает необходимо увидеть области изображения, которые содержат цвета, не входящие в число печатаемых, причем сначала в режиме RGB, а затем самостоятельно изменить их. Выполните действия, описанные ниже, чтобы отобразить цвета, не входящие в цветовую гамму, а затем преобразуйте их в печатаемые.

Заменители цветов в режиме CMYK создаются на основе установленных для CMYK параметров в диалоговом окне Color Settings (Характеристики цвета), так что сначала введите необходимые значения в этом окне (см. раздел «Выбор параметров в окне Custom CMYK» этой главы).

  1. Откройте изображение в режиме RGB.
  2. Воспользуйтесь командой меню View > Gamut Warning (Вид > Предупреждение о гамме).
  3. Рекомендация. Для того чтобы изменить только непечатаемые цвета, не входящие в цветовую гамму, воспользуйтесь командами Select > Color Range (Выделить > Диапазон цветов). Затем из всплывающего меню Select выберите пункт Out of Gamut (He входящие в гамму) и щелкните по кнопке ОК.
  4. Выберите инструмент Sponge (Губка), который активизируется с помощью комбинации клавиш Shift+O.
  5. На панели опций инструмента из всплывающего меню Mode (Режим) выберите вариант Desaturate (Обесцветить), силу нажима в процентах в поле Pressure (Давление), а также вид кисти на соответствующей панели.
  6. Выделите слой.
  7. Перетащите курсор через серые области, где находятся цвета, не входящие в цветовую гамму. После обесцвечивания будет меняться их цвет. Но не надо слишком уменьшать насыщенность, а то цвета станут скучными.

Для того чтобы предварительно просмотреть изображение в режиме CMYK, вновь выполните команду View > Gamut Warning (Вид > Предупреждение о гамме), чтобы снять соответствующий флажок. Затем убедитесь, что в подменю View > Proof Setup (Вид > Установки пробного отпечатка) выбран профиль Working CMYK (Рабочий CMYK). Это позволит увидеть заданные вами параметры режима CMYK в диалоговом окне Color Settings (Характеристики цвета). И наконец, воспользуйтесь командой меню View > Proof Colors.

При размещении указателя в областях, содержащих не входящие в цветовую гамму цвета, на палитре Info (Информация) рядом со значениями CMYK цветовой пробы появится восклицательный знак.

Другой способ обесцвечивания

Можно воспользоваться командами Image > Adjustments > Hue/Saturation (Изображение > Корректировки > Тон/Насыщенность) вместо использования инструмента Sponge (Губка), чтобы отрегулировать цвета, не входящие в цветовую гамму. Переместите ползунок Saturation (Насыщенность) влево, чтобы обесцветить изображение.

Коррекция цвета

Такая сложная тема, как коррекция цвета, не может быть подробно рассмотрена в данном руководстве. Данная операция требует применения разнообразных команд, включая Levels (Уровни), Curves (Кривые), Color Balance (Баланс цвета) и Unsharp Mask (Маска нерезкости). Некоторую информацию можно получить из следующих книг:

  • Fraser В. Production Essentials;
  • Fleishman G., Roth S. Real World Scanning and Halftones.

Здесь же указаны только основные шаги, которые необходимо выполнить для коррекции цвета:

  1. Произведите калибровку монитора.
  2. Откройте PhotoCD-изображение в программе Photoshop.
  3. Обозначьте границы тона, чтобы определить самые темные и самые светлые области изображения, и затем отметьте самое высокое и самое низкое значение тона. Эти значения должны предоставить в типографии. (Цвета, не входящие в этот диапазон, будут плохо выглядеть при печати.)
  4. Сбалансируйте цвет, чтобы предотвратить нежелательные резкие скачки цвета на изображении. Можно скорректировать все цвета или только нейтральные серые области изображения.
  5. Воспользуйтесь командой Unsharp Mask (Нерезкое маскирование), чтобы сделать изображение более четким.
  6. Сделайте пробный отпечаток CMYK-изображения и проанализируйте результат, чтобы определить точные характеристики цвета.
  7. Скорректируйте изображение в программе Photoshop, выведите и проанализируйте другой пробный отпечаток.

Вывод на экран. Выполняйте коррекцию цвета в режиме RGB. Предварительно просмотрите изображение на других мониторах или с помощью какого-либо браузера.

Вывод на печать. Если вы работаете с отсканированным Изображением в режиме CMYK, то всю корректировку цвета выполняйте в этом режиме. Для изображения, в котором далее будет осуществляться цветоделение, компания Adobe рекомендует сначала использовать режим RGB, а затем преобразовать изображение в режим CMYK с установкой соответствующих характеристик цвета.

Воспользуйтесь корректирующими слоями для коррекции цвета, чтобы в дальнейшем можно было настроить изображение с использованием копии, в которой были сохранены слои.

Пробные отпечатки

Для определения наилучших параметров настройки неплохо было бы сделать пробный отпечаток в режиме CMYK. Воспользуйтесь тестовым изображением CMYK, именуемым Ole No Moire (в файле Testpict.jpg для Windows), которое для этих целей предоставляет программа Photoshop. Оно находится на компакт-диске в папке Goodies/Calibrate. Однако, прежде чем открыть тестовое изображение, в диалоговом окне Color Settings (Характеристики цвета) в поле Profile Mismatches (Несоответствие профиля) установите флажок Ask Before Opening (Спрашивать перед открытием). Теперь откройте изображение. Если появится предупреждающее окно Missing Profile (Профиль отсутствует), то щелкните по кнопке Leave as is (Оставить как есть), то есть не меняйте цвет, и щелкните по кнопке ОК.


  • Глава 23. Работа с Web и программой ImageReady
    • Режим Indexed Color
      • Преобразование изображения в режим Indexed Color
      • Редактирование таблицы цветов изображения в режиме Indexed Color
      • Создание специальной палитры в программе ImageReady для изображений в режиме Indexed Color
      • Применение специальной палитры к другим изображениям
    • Из программы Photoshop в LiveMotion
      • Подготовка многослойного файла к переносу из программы Photoshop в LiveMotion
      • Возникновение ореола при копировании сглаженных объектов в другие программы
    • Из программы Photoshop в After Effects
      • Согласование цветов в программе Photoshop и других приложениях
    • Создание в программе Photoshop изображений для сети
      • Размер изображения
      • Формат GIF
      • Глубина цвета
      • Формат JPEG
      • Размытие
      • Сглаживание
      • Форматы PNG-8 и PNG-24
      • Панель инструментов в программе ImageReady
      • Оптимизация изображений для сети в программе ImageReady
      • Оптимизация изображений в формате GIF и PNG-8
      • Применение взвешенной оптимизации
      • Предварительный просмотр в программе ImageReady
      • Команда Jump to
      • Быстрая оптимизация
      • Создание и применение дроплета
      • Оптимизация изображений в формате JPEG или PNG-24
      • Приведение цвета однотонных областей к Web-цветам
      • Предварительный просмотр результатов возможного размытия оптимизированного изображения в браузере
      • Предварительный просмотр изображения
      • Изменение гаммы оптимизированного файла
      • Предварительный просмотр оптимизированного изображения в браузере
      • Сохранение файла в программе ImageReady
      • Сохранение оптимизированного файла в программе ImageReady
      • Обновление существующего HTML-файла
      • Изменение заголовка Web-страницы и вставка информации об авторских правах
      • Ввод текста в программе ImageReady
      • Советы по созданию текста для сети
    • Деление изображения на ломтики
      • Разрезание изображения на ломтики с помощью команд
      • Разбиение изображения на ломтики вручную
      • Создание ломтика на основе слоя
      • Преобразование ломтика, созданного автоматически или на основе слоя, в пользовательский ломтик
      • Удаление ломтиков
      • Изменение размера пользовательских ломтиков
      • Связывание ссылок с ломтиками изображения
      • Изменение порядка следования ломтиков
      • Выравнивание пользовательских ломтиков вдоль общей границы
      • Равномерное распределение пользовательских ломтиков вдоль одной оси
      • Создание карты изображения на основе слоя
      • Создание карты изображения с помощью инструмента
      • Переход от карты изображения на основе слоя к карте, созданной при помощи инструмента
      • Как спрятать или показать карту изображения
      • Выделение карты изображения
      • Удаление карты изображения
      • Выравнивание карт изображения, созданных с помощью инструментов, вдоль общей границы
      • Равномерное распределение карт изображения, созданных при помощи инструментов, вдоль одной оси
      • Оптимизация отдельного ломтика изображения
      • Копирование настроек оптимизации от одного ломтика к другому
      • Связывание ломтиков
      • Разъединение ломтиков
      • Прикрепление тега Alt к какому-либо ломтику или целому изображению
    • Ролловеры
      • Создание ролловера для ломтика
      • Создание ролловера с использованием эффекта слоя
      • Предварительный просмотр ролловера в ImageReady
      • Предварительный просмотр ролловера в Web-браузере
      • Создание вторичного ролловера
      • Создание кнопки для Web-страницы
    • GIF-анимация
      • Перемещение элемента изображения с помощью анимации
      • Постепенное исчезновение или появление картинки
      • Удаление кадров из анимации
      • Выбор параметров воспроизведения анимации
      • Предварительный просмотр анимации
      • Анимация покачивания предметов
      • Редактирование анимации
      • Воспроизведение анимации в обратном порядке до первого кадра
      • Применение второго анимационного эффекта к существующей анимации
      • Уменьшение размера изображения
      • Обрезка изображения
      • Ролловер, инициирующий анимацию
      • Создание анимации с искажением текста
      • Удаление или корректировка искаженного текста
      • Сохранение GIF-анимации
      • Открытие анимации в формате GIF
      • Оптимизация анимации
    • Эффекты слоя
      • Применение эффектов слоя в программе ImageReady
      • Удаление эффекта слоя
      • Другие возможности для работы со слоями в программе ImageReady
      • Применение стиля к слою
      • Сохранение эффекта слоя в качестве стиля
    • Заполнение фона повторяющимся узором
      • Создание файла «черепицы»
      • Предварительный просмотр мозаичного фона
      • Использование HTML-файла в качестве фона
      • Удаление HTML-файла «черепицы» или однотонной фоновой окраски изображения
      • Диалоговое окно Save for Web в программе Photoshop

Глава №23.

Работа с Web и программирование Imageready

Рис. 23.1. Сайт microsoft.com

При выполнении упражнений этой главы вы будете постоянно переходить из программы Photoshop в ImageReady и обратно.

Программа ImageReady имеет серьезные проблемы с отображением кириллицы. Поэтому в целом ряде случаев придется пользоваться HTML-редактором. В частности, для редактирования текста в поле Alt или при создании ролловеров.

В этой главе рассказывается, как подготовить Photoshop-изображения для последующего их использования в мультимедийных системах или в Internet, причем в режиме реального времени. Рассматриваются методы преобразования изображения в режим Indexed Color, использования Photoshop-изображений в программах Live-Motion и After Effects и подготовки их к просмотру в сети с помощью программы ImageReady.

Так как Web-графика выводится на экране, в эту главу включены сведения, касающиеся подготовки изображений для последующего показа на мониторе. При подготовке графики для просмотра на экране (в отличие от подготовки к печати) особенно важной становится проблема хранения и передачи данных. Поэтому сначала будет рассказано о преобразовании изображений в режим Indexed Color, то есть о методе сжатия файлов, при котором сохраняется достаточно много информации о цвете.

Как только вы закончите подготовку изображений, можете окунаться в реальный мир Всемирной паутины (рис. 23.1). Готовы прямо сейчас? Тогда сразу переходите к разделу «Подготовка в программе Photoshop изображений для сети».

Режим Indexed Color

Некоторые видео- и мультимедийные программы, а также компьютерные системы не способны импортировать изображение из программы Photoshop, если оно содержит более 256 цветов (цвет представлен более чем 8 битами). При преобразовании изображения в режим Indexed Color можно уменьшить количество элементов в таблице цветов.

При преобразовании многослойного изображения в режим Indexed Color все слои будут объединены. Воспользуйтесь командой Save as (Сохранить как), чтобы работать с копией изображения.

Преобразование изображения в режим Indexed Color

  1. Убедитесь, что изображение находится в режиме RGB.
  2. Выполните команды Image > Mode > Indexed Color (Изображение > Режим > Индексированный цвет) и щелкните по кнопке ОК.
    • При желании установите флажок Preview (Предварительный просмотр), потом выберите один из следующих пунктов в поле Palette (Палитра) - см. рис. 23.2:
    • Exact (Точная), если изображение содержит 256 или меньше цветов. При этом ни один цвет не будет удален;
    • System (Mac OS) (Системная (Mac OS)), если собираетесь экспортировать файл в приложение, которое воспринимает только палитру Мае OS, установленную по умолчанию;
    • System (Windows) (Системная (Windows)), если собираетесь экспортировать изображение в приложения на платформе Windows;

Рис. 23.2. Всплывающее меню Palette

    • Web (Сетевая), если намереваетесь загружать файл в сеть. Эта опция ограничивает набор цветов изображения тем множеством, которое доступно в большинстве Web-браузеров;
    • Uniform (Равномерная), чтобы создать таблицу цветов, равномерно распределенных по спектру. При этом не учитываются преобладающие цвета изображения;
    • Local (Локальная) (Perceptual (Учитывающая восприятие), Selective (Селективная) или Adaptive (Адаптивная)), чтобычюздать таблицу цветов на основе только тех цветов, которые входят в изображение;
    • Master (Специальная) использует специальную таблицу цветов, созданную заранее на основе группы изображений.

      Выберите вариант Perceptual, Selective или Adaptive в зависимости от того, какие цвета желательно сохранить при преобразовании изображения в режим Indexed Color. Подробнее об этих трех палитрах говорится в разделе «Оптимизация изображений для сети в программе ImageReady» этой главы;

    • Custom (По выбору пользователя), чтобы создать собственную палитру. При желании отредактируйте таблицу цветов и щелкните по кнопке ОК. (Щелкните по кнопке Save (Сохранить), если вы хотите и в дальнейшем использовать таблицу цветов. Щелчок по кнопке Load (Загрузить) позволит загрузить ранее сохраненную таблицу.) Щелкните по кнопке ОК и пропустите следующие шаги;
    • Previous (Предыдущая), чтобы использовать палитру, применявшуюся в предыдущем преобразовании, если оно выполнялось.
  4. Если была активизирована одна из опций Local или Master (Perceptual, Selective или Adaptive) или выбран вариант Uniform, то следует ввести количество цветов в таблице (рис. 23.3). Чем меньше цветов в изображении, тем меньше размер файла, но тем хуже качество картинки.
  5. Выберите один из следующих пунктов всплывающего меню Forced (Принудительно), чтобы добавить определенные цвета в таблицу:
    • Black and White (Черный и белый) добавляет чисто черный и чисто белый цвета;
    • Primaries (Базовые цвета) добавляет красный, зеленый, синий, циановый, фуксин, желтый, черный и белый;
    • Web добавляет 216 Web-цветов (остальные цвета соответствуют палитре Selective);
    • Custom (По выбору пользователя) добавляет определенные пользователем цвета.
  6. Установите флажок Transparency (Про-. зрачность), чтобы сохранить прозрачные области изображения. Либо снимите этот флажок, в таком случае прозрачные области будут залиты цветом, заданным в поле Matte (Кайма), либо белым, если в этом поле выбран пункт None (Нет).

Если изображение содержит прозрачные области, то выберите подходящий цвет в поле Matte (Кайма), чтобы заполнить частично прозрачные области по краю изображения.

Рис. 23.3. Ввод количества цветов в поле Colors

Рисование в режиме Indexed Color

В режиме Indexed Color с помощью инструментов Pencil (Карандаш) и Brush (Кисть) можно наносить только полностью непрозрачные мазки. Для этих инструментов оставьте ползунок Opacity (Непрозрачность) на отметке 100%. Единственный режим смешивания, при котором можно уменьшить непрозрачность, - это Dissolve (Растворить).

Опция Forced

Если необходимо проконтролировать, какие цвета будут выбраны для палитры цветов помимо тех, которые предлагает опция Forced (Принудительно), то выделите область (или несколько областей), содержащую те цвета, которые следует поместить на палитру, прежде чем переводить изображение в режим Indexed Color, и затем в поле Palette на шаге 3 выберите один из пунктов Local (Perceptual), Local (Selective) или Local (Adaptive).

Также можно воспользоваться опцией Master, чтобы контролировать цвета изображения (подробнее об этом написано в разделе «Создание специальной палитры в программе ImageReady для изображений в режиме Indexed Color» настоящей главы).

  7. Выберите один из пунктов меню Dither (Размытие): None (Нет), Diffusion (Диффузия), Pattern (Узор) или Noise (Шум), чтобы имитировать дополнительные оттенки, которых нет в таблице цветов. Если выбран вариант None, то изображения с резкими переходами цвета будут выглядеть, как плакаты, так что пользуйтесь этой опцией только в случае, когда таких резких переходов цвета нет. Опция Diffusion (Диффузия) приводит к замене цвета на ближайший оттенок, но иногда может сделать заметными отдельные точки. Вариант Pattern имитирует недостающие оттенки, используя повторяющийся узор. Опция Noise создает едва уловимый эффект появления отдельных точек в том месте, где проходит граница между цветами.
  8. Если в меню Dither (Размытие) был выбран пункт Diffusion, то можно ввести значение в поле Amount (Количество), чтобы регулировать процент цветов, которые будут затронуты данной операцией. Выбирая эту опцию, установите флажок Preserve Exact Colors (Сохранять точные цвета), при этом размытие не будет применяться к тем областям, где цвет изображения полностью соответствуют какому-либо цвету из палитры. Не пытайтесь предварительно просмотреть полученный эффект, так как, скорее всего, вы не увидите никакой разницы.
  9. Щелкните по кнопке ОК.

Редактирование таблицы цветов изображения в режиме Indexed Color

  1. Выполните команды Image > Mode > Color Table (Изображение > Режим > Таблица цветов). В результате откроется диалоговое окно Color Table (Таблица цветов), в котором будут показаны все цвета изображения (рис. 23.4), в том числе образец, соответствующий прозрачным пикселам (на рисунке - в нижнем правом углу), если в диалоговом окне Indexed Color (Индексированный цвет) установлен флажок Transparency (Прозрачность).
  2. Щелкните по какому-либо цвету, чтобы изменить его, или, перетащив указатель через несколько цветов, выделите их.
  3. Переместите ползунок вверх или вниз по вертикальной шкале, чтобы выбрать соответствующий тон (рис. 23.5в). Затем щелкните по оттенку этого тона в большом цветном квадрате (рис. 23.56).
  4. Рекомендация. Для того чтобы выбирать только цвета, подходящие для сети, установите флажок Only Web Colors (Только Web-цвета) - см. рис. 23.5а. Если же этот флажок не установлен, то при выборе цвета, показ которого в сети не гарантирован, рядом с ним появится предупреждающий значок (рис. 23.5г). Если щелкнуть по нему, то программа Photoshop найдет ближайший заменитель данного цвета, который наверняка подойдет для Web-изображений.

Рис. 23.4. Диалоговое окно Color Table

Рис. 23.5. Панель выбора цвета

Уменьшайте!

Для того чтобы уменьшить количество цветов в таблице изображения в режиме Indexed Color до двух цветов и промежуточных оттенков, сначала выполните команды Image > Mode > Color Table (Изображение > Режим > Таблица цветов). Перетащите курсор с первого цвета в левом верхнем углу до последнего в нижнем правом. В окне Color Picker (Выбор цвета) выберите первый цвет:

  • переместите ползунок по вертикальной шкале, чтобы выбрать соответствующий тон (рис. 23.5а);
  • щелкните по оттенку тона в большом цветном квадрате (рис. 23.56);
  • щелкните по кнопке ОК.

Затем выберите второй цвет. Чтобы получить лучшие результаты, сначала выберите теплый цвет, а потом холодный или наоборот. Щелкните по кнопке ОК, чтобы закрыть панель выбора цветов и затем снова щелкните по ОК.

  5. Щелкните по кнопке ОК. Если при выполнении шага 2 было выбрано более одного цвета, то измените второй цвет и щелкните по ОК.
  6. Щелкните по кнопке ОК.

Для того чтобы добавить произвольный цвет в полутоновое изображение, преобразуйте его в режим Indexed Color, а затем отредактируйте таблицу цветов. Воспользуйтесь таблицей Black Body (Черный цвет) или Spectrum (Спектр).

Создание специальной палитры в программе ImageReady для изображений в режиме Indexed Color

Специальные палитры программы ImageReady гарантируют, что каждое изображение, входящее в некоторую группу, использует одну и ту же цветовую палитру. Они помогают экономить пространство на компакт-диске и с их помощью, например, можно добиться того, чтобы GIF-файлы на вашем сайте использовали те же цвета, что содержатся в логотипе вашей компании.

При создании специальной палитры необходимо добавить в нее цвета из одного или нескольких изображений, затем сохранить палитру и присвоить ей имя. Потом данную палитру можно будет применять к другим изображениям, цвета которых должны соответствовать цветам данной группы изображений.

  1. Если ранее была создана специальная палитра, то очистите ее, выполнив команды меню Image > Master Palette > Clear Master Palette (Изображение > Специальная палитра > Очистить специальную палитру).
  2. Откройте изображение, цвета которого будут использованы при создании специальной палитры.
  3. Выполните команды Image > Master Palette > Add to Master Palette (Изображение > Специальная палитра > Добавить в специальную палитру) -см. рис. 23.6.
  4. Повторите шаги 2-3, чтобы добавить в специальную палитру цвета из других изображений.

Рис. 23.6. Подменю Image > Master Palette

Рис. 23.7. Сохранение палитры

Рис. 23.8. Выбор специальной палитры в меню Color reduction algorithm

  5. Как только вы добавили все необходимые цвета, воспользуйтесь командами Image > Master Palette > Build Master Palette (Изображение> Специальная палитра > Построить специальную палитру).
  6. И наконец, выполните команды Image > Master Palette > Save Master Palette (Изображение > Специальная палитра> Сохранить специальную палитру).
  7. По умолчанию, новая палитра будет сохранена с расширением .act в папке Presets/Optimized Colors (рис. 23.7). Задайте имя палитры и щелкните по кнопке Save (Сохранить). Теперь можно применять эту палитру к другим изображениям.

Применение специальной палитры к другим изображениям

  1. Откройте изображение в программе ImageReady.
  2. На палитре Optimize (Оптимизация) выберите из всплывающего меню Color reduction algorithm (Алгоритм сокращения цветов) специальную палитру, которую следует использовать в изображении (рис. 23.8). Цвета изображения будут изменены в соответствии с палитрой. В этом можно убедиться, открыв вкладку Optimize для окна изображения.

Для того чтобы воспользоваться палитрой, созданной в другом приложении, из меню палитры Color Table выберите пункт Load Color Table (Загрузить таблицу цветов). Затем откройте папку, в которой находится нужная палитра.

Из программы Photoshop в LiveMotion

Многослойный файл, созданный в программе Photoshop, может быть использован в качестве основы для создания анимации в программе LiveMotion, Web-приложении компании Adobe. Можно использовать палитру Layers (Слои) в программе Photoshop как сценарий, чтобы создать последовательность изображений. Скройте или покажите отдельные элементы слоев, чтобы предварительно просмотреть изображение. Переместите слои в окне изображений с помощью инструмента Move (Перемещение), чтобы предварительно просмотреть анимацию, а затем откройте файл в программе LiveMotion.

Одним из способов открытия в программе LiveMotion многослойного файла, созданного в Photoshop, является использование команды Place (Разместить). Есть еще один вариант - перетащить слой из программы Photoshop в композицию программы LiveMotion.

При размещении многослойного Photoshop-файла (рис. 23.9) в программе Live-Motion он преобразуется в однослойный объект. Однако после размещения можно воспользоваться командой Object > Convert Layers Into (Объект > Преобразовать слои в), чтобы преобразовать слои либо в отдельные объекты (рис. 23.10), расположенные на отдельных слоях, либо в последовательность кадров на одном слое. Любой из полученных в результате такого преобразования объектов можно будет выделить с помощью редактора Timeline (Шкала времени) в программе LiveMotion и усовершенствовать. Такие объекты так же, как и любые другие объекты программы LiveMotion, могут быть включены в анимацию.

Рис. 23.9. Многослойное изображение в программе Photoshop

Рис. 23.10. Перенос многослойного файла из Photoshop в программу LiveMotion с преобразованием слоев в отдельные объекты

Рис. 23.11. Палитра Layers в программе Photoshop, показывающая отдельные слои изображения, включая фон

Рис. 23.12. Список Timeline в программе LiveMotion после размещения многослойного зайла из программы Photoshop

Рис. 23.13. Список Timeline после выполнения команд Object > Convert Layer Into > Objects

При редактировании объектов с помощью команды Edit Original (Правка исходного объекта) программы LiveMotion любой объект, перемещенный из программы Photoshop в LiveMotion, можно переместить обратно и править в программе Photoshop (на самом деле вы будете работать с копией исходного файла). Когда отредактированная копия файла будет сохранена в программе Photoshop, соответствующие изменения будут автоматически произведены и в LiveMotion. Это значит, что вы можете быстро редактировать анимацию в программе Live-Motion, пользуясь всем набором инструментов Photoshop.

Слои Photoshop-изображения, преобразованные в отдельные объекты LiveMotion, сохраняют порядок следования, в котором они были расположены в программе Photoshop (рис. 23.11-23.13). Самый нижний слой теперь будет находиться в нижней части списка Timeline (Шкала времени) в программе LiveMotion. Так что подумайте заранее о том, в каком порядке расположить слои, прежде чем переместить их из программы Photoshop в Live-Motion.

Подготовка многослойного файла к переносу из программы Photoshop в LiveMotion

Для того чтобы упростить процесс размещения Photoshop-изображения в программе LiveMotion, произведите следующие действия в первой программе:

  • убедитесь, что в изображении имеется непрозрачный фон (Background), а не слой с названием Layer 0. Если возможно, ничем не заполняйте фон. После размещения и преобразования изображения в программе LiveMotion фон станет объектом с однотонной окраской, который при желании можно удалить;
  • создайте альфа-канал, если необходимо очертить какую-либо фигуру в программе LiveMotion. Удостоверьтесь, что альфа-канал имеет черный фон, на котором расположен белый контур фигуры;
  • преобразуйте в растровый формат все векторные слои, слои заливки и фигур. При этом все контуры отсечения слоев будут преобразованы в маски слоя. При размещении маски слоя в программе LiveMotion она обеспечит отсечение содержимого слоя. Маски слоя называются альфа-каналами и отображаются на палитре Properties (Свойства) в программе LiveMotion.

    Градиентные слои будут успешно размещены в программе LiveMotion только в том случае, если их предварительно преобразовать в растровый формат. При этом маски слоев надо либо применить, либо отбросить;

  • преобразуйте файл в режим RGB;
  • если многослойный файл из программы Photoshop будет размещен в Live-Motion в качестве сложного однослойного объекта, то будут сохранены все эффекты, связанные со значениями непрозрачности и корректирующими слоями, эффекты слоя, а также эффекты режимов смешивания. Однако, если после этого к данному файлу применить команду Convert Layers Into (Преобразовать слои в), все эффекты будут аннулированы. Если необходимо сохранить вышеперечисленные эффекты, то оставьте объект в программе LiveMotion в виде одного слоя и не преобразуйте его в отдельные объекты. Однако следует отметить, что программа LiveMotion дает гораздо больше возможностей для создания различных эффектов, чем Photoshop;
  • если необходимо работать с редактируемым текстом, то введите его в программе LiveMotion, так как после размещения файла из программы Photoshop текст будет преобразован в растр;
  • применять фильтры можно как в программе Photoshop, так и в LiveMotion. В первой программе больше выбор фильтров, но последняя позволяет скрывать или удалять отдельные эффекты фильтров.

Возникновение ореола при копировании сглаженных объектов в другие программы

Для того чтобы создать гладкие переходы между фигурами, программа Photoshop добавляет точки по краям объекта (этот процесс называется сглаживанием). Точки постепенно меняются от полностью непрозрачных до прозрачных. Поэтому при выделении объекта некоторые точки фона также попадают в выделенную область, так как край объекта является полупрозрачным.

Рис. 23.14. Удаление эффекта сглаживания

Рис. 23.15. Изображения, вставленные в другую программу: без уменьшения выделенной области слева); с уменьшением выделенной области, чтобы удалить ореол (справа)

Если вставить выделенную область из программы Photoshop в сложное изображение с иным цветом фона в другой программе, то вокруг этой области появится небольшой, но заметный (и нежелательный) ореол. Также эффект ореола будет виден при использовании объекта в анимации, где он движется на фоне, цвет которого неоднороден или постепенно изменяется.

Чтобы предотвратить возникновение ореола, сначала выделите объект в программе Photoshop, не выделяя его сглаженных границ. Нажав клавишу Ctrl, щелкните по имени слоя, чтобы выделить объект, и затем увеличьте масштаб, по крайней мере, до 200%, так чтобы можно было четко видеть границы объекта. Выполните команды Select > Modify > Contract (Выделить> Изменить > Уменьшить), чтобы ужать выделенную область на один или два пиксела. При этом будет удален эффект сглаживания. И наконец, скопируйте объект и вставьте его в другую программу. Рис. 23.14-23.15 иллюстрируют этот процесс. Чтобы получить изображение, приведенное на рис. 23.14, с помощью инструмента Magic Wand (Волшебная палочка) был выделен белый фон, затем выделенную область инвертировали, при этом некоторая часть сглаженной границы вошла в выделение. Была применена команда Select > Modify > Contract (Выделить > Изменить > Уменьшить), чтобы уменьшить выделение на один пиксел.

Из программы Photoshop в After Effects

Многослойное изображение, созданное в программе Photoshop, можно импортировать в программу After Effects 4.1 компании Adobe и разместить его в окне Time Layout (Расписание), чтобы создать анимационные эффекты для вывода на видео или просмотра при помощи программы QuickTime. Файл, содержащий слои, может быть импортирован из программы Photoshop в After Effects в виде составного файла. Отдельные слои и группы слоев при этом сохраняются.

В качестве альтернативы можно импортировать изображение со слоями из программы Photoshop в After Effects как предварительно скомпонованное. Для того чтобы сохранить все слои, в том числе и корректирующие, эффекты слоя, режимы смешивания и альфа-каналы без изменений, для импорта изображения воспользуйтесь командами File > Import > Photoshop as Comp (Файл > Импорт > Photoshop-файл как Comp) в программе After Effects. Редактируемые текстовые слои правильно интерпретируются программой After Effects, поэтому нет необходимости их предварительно преобразовывать. Маски слоя также будут импортированы и корректно визуализированы программой After Effects.

Группа отсечения из программы Photoshop будет импортирована в After Effects как предварительно скомпонованная. Благодаря этому ее можно размещать и редактировать, как единое целое. Если дважды щелкнуть по такому объекту в окне After Effects Project (Проект After Effects), то в окне Time Layout (Расписание) будут отображены отдельные слои группы отсечения.

К альфа-каналам, содержащимся в файле Photoshop, можно применить команду Set Matte Effect (Эффект покрытия). Любые другие каналы будут проигнорированы.

Иногда одно и то же изображение используется как для печати (обычное разрешение таких изображений составляет 250 dpi и выше), так и в проекте программы After Effects. He следует использовать в программе After Effects файлы с высоким разрешением, вместо этого создайте копию файла с надлежащим разрешением и размерами при помощи команды Image Size (Размер изображения) из меню File (Файл) в программе Photoshop.

Согласование цветов в программе Photoshop и других приложениях

Если необходимо создать цвет в программе Photoshop с использованием тех же значений RGB, что используются в Macromedia Director или Netscape Navigator, то, возможно, не удастся достичь полного совпадения, так как в программах Director и Navigator используются палитры цветов Windows Color Picker или Apple Color Picker (в зависимости от платформы) для определений значений RGB, в то время как программа Photoshop по умолчанию использует свою собственную палитру цветов.

Если использовать палитры Windows или Apple вместо палитры Photoshop, то при смешивании цветов RGB на палитре Color в программе Photoshop полученный цвет будет полностью соответствовать тому, который используется в программе Director. Для того чтобы поменять палитру, воспользуйтесь командами Edit => Preferences > General (Правка > Установки > Общие) и во всплывающем меню Colors Picker (Выбор цветов) выберите пункт Windows или Apple, а затем щелкните по кнопке ОК. Не забудьте снова переключить палитру, когда закончите работу.

Из программы Photoshop на видео

Если у вас имеется система для создания видео Avid, то установите размеры изображения равными 720x486 пикселов (D-I NTSC)- Для просмотра с помощью программы QuickTime подходят любые размеры изображения. Для обеих систем Avid и QuickTime рекомендуется использовать разрешение в 72 dpi. He волнуйтесь, если у вас разрешение выше.

Создание в программе Photoshop изображений для сети

Основные шаги при создании изображения в программе Photoshop для его просмотра в режиме реального времени могут показаться простыми:

  • создайте изображение в режиме RGB;
  • сохраните его;
  • перейдите в программу ImageReady 7.0;
  • оптимизируйте файл, предназначенный для загрузки в сеть.

Но если изображение стало зернистым или точечным, либо его цвета изменились не-жиданным образом, либо оно очень долго загружается при просмотре Web-странички, то это значит, что вы упустили какую-то важную деталь.

Далее рассматриваются четыре основных момента, на которые следует обратить внимание при создании изображения для сети:

Стандартные PAL и SECAM работают с изображениями 800x600 пикселов.

  • размер изображения;
  • палитра цветов;
  • глубина цвета;
  • формат файла (GIF или JPEG).

Вот перечень «золотых» правил по созданию Web-изображений:

  1. Пусть содержимое изображения - содержит ли оно однотонные области или имеет плавные переходы цветов -определяет наиболее подходящий формат файла.
  2. Используйте такой размер файла, какой считаете наиболее практичным, соотнося размер файла с качеством изображения. И помните правило просмотра изображений с однотонными областями в браузерах для любой программно-аппаратной платформы: используйте Web-цвета в палитре, а также заменяйте цвета однотонных областей на Web-цвета.
  3. Постарайтесь уменьшить количество элементов в таблице цветов.
  4. Просмотрите изображение с помощью Web-браузера на чужом компьютере, чтобы оценить, насколько быстро оно загружается и насколько хорошо (плохо) выглядит.

Размер изображения

Для того чтобы рассчитать размер изображения, необходимо заранее знать размер монитора, а также скорость модема потенциального пользователя, который будет просматривать Web-страничку. В большинстве случаев следует создавать изображение размером 800x600 пикселов (обычный размер монитора) и для модема со скоростью передачи 56 Кб/с (наиболее распространенная скорость).

Указанный размер будет иметь окно Web-браузера, так что максимальный размер изображения составит около 10 дюймов в ширину (740 пикселов) и 7,5 дюймов в длину (550 пикселов). Разрешение изображения должно быть равным 72 dpi.

При вычислении размера файла изображения не полагайтесь на размер документа, отображаемый в строке состояния программой Photoshop. Вместо этого перейдите в программу ImageReady (щелкните по соответствующей пиктограмме в нижней части палитры инструментов в программе Photoshop), оптимизируйте файл, убедитесь, что выбран пункт Original/ Optimized File Sizes (Исходные/Оптимальные размеры файла) из всплывающего меню Image Information (Информация об изображении), расположенного в нижней части основного окна, и запишите информацию о размере файла (рис. 23.16 и 23.17).

Сохранив файл в формате GIF или JPEG, можно значительно уменьшить его размер, так как эти форматы содержат встроенные алгоритмы сжатия.

Для того чтобы определить фактический размер файла, щелкните правой кнопкой мыши по имени файла в окне Explorer (Проводник) и из всплывающего меню выберите пункт Properties (Свойства).

Если вы знаете точный размер файла, то можно подсчитать, сколько времени нужно для его загрузки по сети. Но лучше выберите пункт Size/Download Time (Размер/Время загрузки) из всплывающего меню Image Information (Информация об изображении) в программе ImageReady, чтобы получить информацию с учетом разных скоростей модема (рис. 23.18).

Рис. 23.16. Исходное изображение в программе ImageReady

Рис. 23.17. Всплывающее меню Image Information

Рис. 23.18. Сведения о времени загрузки файла по сети в программе ImageReady

Рис. 23.19. GIF-файл размером 20 Кб,с изображением в стиле плаката (5 уровней)

Рис. 23.20. GIF-файл размером 120 Кб, содержащий изображение с плавным переходом. цветов

Степень сжатия файла в форматах GIF или JPEG зависит от того, насколько можно уплотнить изображение (рис. 23.19 и 23.20). Оба формата немного ухудшают качество изображения. Но уменьшение размера файла того стоит, поскольку такой файл будет гораздо быстрее загружаться по сети. Программа ImageReady предлагает метод взвешенной оптимизации файла, который позволяет вам выборочно сжимать различные области изображения (подробнее об этом рассказано в разделе «Применение взвешенной оптимизации» настоящей главы).

Загрузка файла размером 50 Кб с помощью модема со скоростью 56 Кб/с займет 9 секунд.

Ниже приведены сведения о сжатии файлов различных типов:

  • документ с однотонным фоном и несколькими однотонными фигурами существенно уменьшится при сжатии (предположительно размер файла будет в пределах от 20 Кб до 50 Кб);
  • большой документ (более 100 Кб) со множеством цветных областей, текстур или узоров (например, если текстура Add Noise (Добавить шум) покрывает большую часть изображения) уменьшится незначительно;
  • при использовании формата GIF фотографическое изображение с плавным переходом тонов может уплотниться не так существенно, как изображение с однотонными областями. Но если ему придать плакатный стиль (от 4 до 8 уровней), то размер файла будет практически равен размеру файла изображения с однотонными фигурами, однако при этом будут утрачены плавные переходы цветов. Лучше для изображений фотографического типа использовать формат JPEG.

Подведем итог. Если изображение должно быть большим (размером не менее 500x400 пикселов), то в идеале оно должно содержать набор крупных однотонных фигур. Для изображения, представляющего собой хитросплетение фигур различного цвета, постарайтесь уменьшить размер, так чтобы оно занимало только часть окна Web-браузера.

Орнамент, полностью покрывающий фон окна браузера, обычно формируется с помощью метода мозаичной укладки (tiling) в программе по созданию Web-страниц или с помощью HTML-кода. Также с помощью программы ImageReady можно создать код и генерировать эффект «черепицы» для фона (см. раздел «Мозаичный фон» этой главы).

Сделайте снимок окна браузера, затем откройте полученный файл в программе Photoshop и вставьте его в документ в виде самого нижнего слоя. Теперь можно проектировать изображение с учетом размера окна браузера.

Формат GIF

Формат GIF - это 8-битный формат файла, то есть изображение в этом формате может содержать максимум 256 цветов. Однако он считается стандартным, так как у большинства пользователей сети 8-битные мониторы, на которых может отображаться максимум 256 цветов, а не тысячи и миллионы оттенков, которые делают изображение наиболее приятным для глаз. Формат GIF очень хорош для изображений, содержащих однотонные области и фигуры с четко определенными границами (рис. 23.21), например для текста (рис. 23.22).

Рис. 23.21. Изображение, подходящее для хранения в формате GIF

Рис. 23.22. Гибридное изображение, содержащее текст и области с плавным переходом цветов

Если необходимо заполнить большую область изображения градиентом и предполагается затем преобразовать файл в формат GIF, то создайте градиент в направлении сверху-вниз. Размер файлов с такими градиентами меньше, чем при использовании градиента с направлением справа-налево или диагонального градиента.

Для того чтобы сохранить изображение в формате GIF и увидеть, как оно будет смотреться в браузере, воспользуйтесь в программе Photoshop командой File & Save for Web (Файл > Сохранить для Web), либо оптимизируйте и сохраните его в программе ImageReady (см. раздел «Оптимизация изображений в формате GIF или PNG-8» этой главы).

Выбор цвета для изображения в формате GIF должен основываться на том, какие цвета действительно отображаются в палитре Web-браузера. В основном, цветовые палитры браузеров 8-битные, то есть на экране может отображаться 256 цветов. Цвета, не входящие в палитру, воспроизводятся посредством размытия (dithering), специального метода перемешивания пикселов доступных цветов для имитации других оттенков.

Для того чтобы предотвратить появление неожиданных эффектов в результате такой операции, подумайте, может, стоит оптимизировать изображение в программе ImageReady с использованием палитры Web-цветов. Или привязать к Web большую часть цветов изображения и потом в программе ImageReady вручную заменить на Web-цвета окраску однотонных областей. Подробнее эти методы рассматриваются далее. Замена цвета особенно важна для однотонных областей. Для более точного управления операцией размытия и уменьшения количества используемых цветов можно применить метод взвешенной оптимизации (см. раздел «Применение взвешенной оптимизации» этой главы).

Глубина цвета

При уменьшении глубины цвета уменьшается количество цветов, используемых в изображении, что, в свою очередь, приводит к уменьшению размера файла и ускорению его загрузки по сети. С уменьшением количества цветов границы областей изображения могут стать ступенчатыми, а цвета - более скучными, йо при этом получается файл меньшего размера.

В 8-битном изображении можно сократить количество цветов с исходных 256 цветов при помощи диалогового окна Indexed Color в программе Photoshop (устаревший способ), диалогового окна Save for Web (Сохранить для Web) в программе Photoshop 7 (лучше) или палитры Optimize (Оптимизация) в программе ImageReady (самый эффективный способ). Последние два способа позволяют предварительно просмотреть изображение с меньшим количеством цветов.

Всегда предварительно просматривайте изображение в масштабе 100%, чтобы оценить качество цвета.

Данные о зависимости количества цветов и глубины цвета приведены в табл. 23.1.

Таблица 23.1. Глубина цвета

Количество цветом | Глубина цвета в битах
256 | В
128 | 7
64 | 6
32 | 5
16 | 4
8 | 3
4 | 2
2 | 1

Рис. 23.23. Изображение, пригодное для хранения в формате JPEG

Рис. 23.24. Искажения на границах литер и однотонных областей, возникающие в результате преобразования в формат JPEG

Рис. 23.25. То же изображение в формате GIF

Формат JPEG

Формат JPEG может быть лучшим вариантом для точной передачи изображений с плавным переходом цветов (то есть для изображений фотографического типа (рис. 23.23) или содержащих оттенки одного цвета), а также в ситуации, если у пользователя, просматривающего изображение, есть 24-битный монитор, который может отображать миллионы цветов.

Преимущество формата JPEG заключается в том, что он сжимает 24-битное изображение так же эффективно, как формат GIF сжимает 8-битное.

Недостатки JPEG состоят в следующем:

  1. JPEG-файл нужно распаковывать при просмотре Web-страницы, что требует времени.
  2. JPEG - не самый лучший вариант для изображений, содержащих однотонные области или текст, так как подобный метод сжатия вносит искажения на четко определенных границах изображений такого сорта (рис. 23.24-23.25).
  3. Не все пользователи сети используют 24-битное отражение цветов. JPEG-изображение будет искажено на 8-битном мониторе. При этом размытие изображения с плавными переходами цвета будет менее заметно, чем в случае изображения, содержащего однотонные области с отчетливыми границами. Можно уменьшить глубину цвета до 8 бит, чтобы предварительно просмотреть изображение в таком виде, либо просто воспользоваться командой View > Preview > Browser Dither (Вид > Предварительный просмотр > Размытие в браузере) в программе ImageReady. Если в изображении нет текста или объектов с четкими границами, возможно, JPEG-файл и «выживет» при переключении на 8-битный цвет.

Файлы в формате JPEG могут быть оптимизированы с использованием формата Progressive JPEG, поддерживаемого браузерами Nestcape Navigator и Internet Explorer (версия 4.0 и выше). При загрузке на Web-страницу картинки и в таком формате детализация изображения увеличивается постепенно.

Если выбран формат JPEG, то можно поэкспериментировать с оптимизацией изображения в программе ImageReady или в диалоговом окне Save for Web (Сохранить для Web) программы Photoshop. Затем, выбрав опцию 4-Up (4 варианта), можно предварительно просмотреть несколько версий изображения с различной степенью сжатия. Подумайте, какая степень уплотнения наиболее приемлема, сопоставив размер файла с качеством изображения. В программе ImageReady можно сохранить оптимизированный файл отдельно и при этом оставить нетронутым исходное изображение для дальнейшего использования.

Каждый раз при оптимизации изображения с помощью формата JPEG теряется некоторая часть данных. Чем выше степень сжатия, тем больше информации утрачивается. Чтобы предотвратить это, сначала отредактируйте и сохраните изображение в программе Photoshop. Затем перейдите в программу ImageReady, при желании выполните дальнейшее редактирование, оптимизируйте файл и, наконец, воспользуйтесь командой File > Save Optimized (Файл > Сохранить с оптимизацией), чтобы сохранить файл в формате JPEG.

Размытие

Размытие (dithering) - перемешивание двух цветов из палитры для имитации третьего.

Данный метод используется, когда необходимо, чтобы изображение с ограниченным количеством цветов (256 или менее) содержало большее количество оттенков. Обычно он применяется к изображениям с плавным переходом цветов, чтобы увеличить диапазон используемых оттенков, но в жизни ничего не дается даром, и поэтому после применения данного метода изображение может покрыться точками.

Зачастую результат размытия изображений с однотонными фигурами получается не слишком эстетичным. Это происходит вследствие того, что палитра браузера смешивает пикселы, чтобы воссоздать отсутствующий в ней цвет. Для таких изображений лучше создавать цвета в программах Photoshop или ImageReady с помощью ползунков, а также панели выбора Web-цветов на палитре Color (Цвет). Однотонные области должны быть выделены, а их цвета заменены на ближайшие Web-цвета.

На изображениях с плавным переходом цветов уже имеются участки, где смешаны пикселы. Некоторые картинки очень хорошо смотрятся на Web-страничке без дополнительного размытия и всего с 256 цветами. Однако чем меньше элементов в палитре изображения с плавным переходом цветов, тем больше будет видно «швов» при переходе от одного цвета к другому. Степень размытия можно выбрать в программе ImageReady или в диалоговом окне Save for Web (Сохранить для Web) программы Photoshop 7. Чем больше эта величина, тем менее заметной будет граница при переходе цветов, но более заметными будут отдельные точки на изображении (рис. 23.26-23.27). Подумайте, какое из двух зол, на ваш взгляд, меньшее.

Рис. 23.26. Увеличенное изображение при небольшой величине размытия

Рис. 23.27. То же изображение с более высокой степенью размытия

Еще одно замечание. Операция размытия добавляет в файл «шум» и дополнительные цвета, так что в результате использования этого приема сжатие оказывается менее эффективным - можно не получить желаемой степени уплотнения. В этом случае, как и всегда при создании файла для сети, надо найти оптимальное соотношение качества изображения и размера файла.

Сглаживание

Функция сглаживания смешивает границы объекта с фоном. Смешивание достигается путем добавления вдоль границы объекта точек с постепенно уменьшающимся уровнем непрозрачности. При компоновке изображений в программе Photoshop сглаживание помогает смягчить резкие переходы от одной фигуры к другой.

Если не использовать функцию сглаживания, изображение будет выглядеть более четко, так как граничные пикселы не будут смешаны с фоном.

Если выделить некоторую область при включенной опции сглаживания, то вместе с объектом выделятся и точки фона, расположенные рядом с границей изображения. Если скопировать и вставить такую область в изображение, расположив ее на однотонном фоне, то станет видна окантовка из присоединенных точек. Чтобы этого не случилось, прежде чем выделять область, снимите флажок Anti-aliased (Сглаживание) на панели опций инструментов выделения, Lasso (Лассо) или Magic Wand (Волшебная палочка).

Также можно воспользоваться опцией Matte (Кайма) на палитре Optimize (Оптимизация) программы ImageReady, чтобы указать, каким образом будут интерпретироваться частично прозрачные точки (те точки, которые появляются при сглаживании) в форматах GIF и JPEG. Обе программы Photoshop и ImageReady позволяют контролировать степень сглаживания текста. Можно активизировать эту опцию и сохранять ее при переносе файла из одной программы в другую. Новые средства управления каймой и сглаживанием позволяют удалить нежелательные ореолы вокруг изображений.

Для того чтобы выделить изображение в слое, не выделяя при этом полупрозрачных точек, расположенных на границе объекта, нажмите клавишу Ctrl и щелкните по имени слоя. Затем выполните команды Select > Modify > Contract (Выделить > Изменить > Уменьшить), чтобы ужать выделение на один пиксел.

Окно Save for Web в программе Photoshop

Многие средства оптимизации файлов объединены в диалоговом окне File > Save for Web (Файл > Сохранить для Web) программы Photoshop (рис. 23.28). В верхней части главного окна имеются четыре вкладки для предварительного просмотра: Original (Исходное изображение), Optimized (Оптимизированное изображение), 2-Up (Два варианта) и 4-Up (4 варианта). Кроме того, в этом окне расположены таблица цветов и средства управления форматом, каймой, качеством изображения и др. Также имеется меню Preview (Предварительный просмотр) и кнопка Preview in [browser] (Предварительный просмотр в [браузер]). В этой главе основное внимание уделено оптимизации

Рис. 23.28. Диалоговое окно Save for Web программы Photoshop

изображений в программе ImageReady, но те же операции можно произвести эквивалентными средствами и в диалоговом окне Save for Web (Сохранить для Web) программы Photoshop. Подробнее об этом диалоговом окне рассказано в разделе «Диалоговое окно Save for Web в программе Photoshop» настоящей главы. -

Форматы PNG-8 и PNG-24

Оба формата PNG могут сохранять полупрозрачные области (например, смягченные растушеванные границы), используя метод под названием альфа-прозрачность. В этом случае у точки может быть 256 уровней непрозрачности, начиная с полной прозрачности и заканчивая полной непрозрачностью. В формате PNG-8 максимально возможное количество цветов оптимизированного изображения - 256, этот формат похож на GIF. В формате PNG-24 у изображения могут быть миллионы цветов, этот формат, в свою очередь, похож на JPEG. В форматах PNG используется метод сжатия без потерь данных.

Какие же существуют ограничения при использовании форматов PNG? Например, в этом формате нельзя создать анимацию (а в формате GIF можно), кроме того, файлы в формате PNG-24 больше по размеру аналогичных JPEG-файлов. И, что еще важнее, форматы PNG непосредственно не поддерживается двумя основными Web-браузерами, за исключением версий Internet Explorer 4.0 и Netscape Navigator 6 и более поздних. Предыдущим версиям этих программ для отображения картинок в данном формате требуется встраиваемый модуль, например PNG Live. Чем же плохи эти модули? Пользователь, возможно, не захочет тратить время на загрузку встраиваемого модуля, а без него ваш сайт не будет смотреться так же выигрышно, как при его использовании.

Панель инструментов в программе ImageReady

Панель инструментов в программе ImageReady аналогична панели инструментов в программе Photoshop, но в ней есть дополнительные Web-инструменты для создания карт изображения, их просмотра, просмотра ломтиков изображений (slice), предварительного просмотра роллове-ров (rollover) и перехода в Web-браузер (рис. 23.29). Щелкнув по кнопке Jump to (Перейти к), вы сможете перейти в программу Photoshop.

Рис. 23.29. Панель инструментов в программе ImageReady

В нижней части всплывающей палитры, содержащей перечень инструментов, входящих в одну группу, находится стрелка, предназначенная для создания отдельной палитры с пиктограммами данных инструментов. Для этого при нажатой кнопке мыши укажите курсором на стрелку и отпустите кнопку (рис. 23.29).

Как и в программе Photoshop, теперь в программе ImageReady есть панель опций инструмента, вид которой зависит от того, какой инструмент активизирован рис. 23.30 и 23.31). Перетащите левый край панели опций, чтобы поместить ее в другом месте рабочего стола. Для того чтобы свернуть панель опций в программе ImageReady, дважды щелкните по ее левому краю (рис. 23.32).

Оптимизация изображений для сети в программе ImageReady

Оптимизация - процесс выбора такого формата файла, его размера и цветовых параметров, которые позволяют в максимально возможной степени сохранить качество изображения, но при этом обеспечить высокую скорость загрузки его по сети. В принципе, можно оптимизировать изображение и в программе Photoshop с помощью диалогового окна, вызываемого командой File > Save for Web (Файл > Сохранить для Web), однако лучше перейти в программу ImageReady и воспользоваться там специальными палитрами оптимизации, содержащими более широкий набор опций.

Если вы освоите программу ImageReady, вам не составит труда пользоваться диалоговым окном Save for Web программы Photoshop, так как их опции практически идентичны. Диалоговое окно Save for Web рассматривается в конце главы.

Рис. 23.30. Панель опций инструмента Rectangle shape

Рис. 23.31. Панель опций инструмента Туре

Рис. 23.32. Свернутая панель опций инструмента Туре

Программа ImageReady предлагает множество различных опций оптимизации. В этом разделе вы познакомитесь с основными операциями. Никогда не забывайте, что ваша основная цель - уменьшить размер файла, не допуская заметного ухудшения качества изображения.

GIF и JPEG - два формата, обычно используемых для графики в сети. Рекомендуем применять формат GIF в случае, когда изображение содержит элементы с четкими границами, например однотонные области, штриховой рисунок и текст. Формат PNG-8, похожий на GIF, использует те же параметры палитры Optimize (Оптимизация), что и GIF, и результаты оптимизации практически идентичны. Оптимизированный файл в формате GIF или PNG-8 может содержать до 256 цветов.

Вы можете воспользоваться командой Save а Сору (Сохранить копию) программы Photoshop, чтобы сохранить копии файла в формате GIF или JPEG, но мы считаем, что программа ImageReady предлагает лучшие способы сохранения файла в этих форматах за счет более широкого набора средств оптимизации и предварительного просмотра. Поэтому основное внимание уделено оптимизации файлов формата GIF и JPEG именно в программе ImageReady.

Четыре цветовые палитры формата GIF

То, что Web-дизайнеры обычно называют «цветовые палитры», в программе ImageReady получило название «алгоритмы сокращения, количества цветов (color reduction algorithms)»

Существует четыре алгоритма сокращения количества цветов в формате GIF:

  • Perceptual (Учитывающий восприятие) - создает таблицу на основе текущих цветов изображения. При этом особое внимание уделяется тому, как человек воспринимает цвета. Преимущество данной таблицы заключается в сохранений целостности цвета;
  • Selective (Селективный) - создает таблицу цветов на основе текущих цветов изображения. Опции Perceptual и Selective похожи, но последняя в большей степени нацелена на сохранение цветов однотонных элементов изображения, а также Web-цветов;
  • Adaptive (Адаптивный) - создает таблицу на основе части цветового спектра, где представлено большинство оттенков изображения. Эта опция формирует оптимизированный файл немного большего размера;

При переключении опций Perceptual, Selective, Adaptive сохраняются все Web-цвета, входящие в таблицу цветов изображения.

Web - создает таблицу цветов, подгоняя цвета изображения к тем, которые имеются в стандартной палитре Web. Данная опция формирует наименьшее количество цветов и, соответственно, наименьший по размеру файл, но качество изображения может быть хуже, чем при выборе других опций.

Рис. 23.33. Вкладка 2-Up в программе ImageReady

Рис. 23.34. Палитра Optimize программы ImageReady

Оптимизация изображений в формате GIF и PNG-8

Для оптимизации изображений в формате GIF и PNG-8 выполните следующие действия.

  1. Если вы работаете в программе Photoshop, то сохраните файл и щелкните в нижней части панели инструментов по кнопке Jump to (Перейти к) или же нажмите комбинацию клавиш Ctrl+ Shift+M. Начнет работать программа ImageReady, если она не была запущена ранее, и в ней будет открыто изображение.

    Второй вариант: в программе ImageReady выполните команду File > Open (Файл > Открыть), а затем выделите имя изображения и щелкните по кнопке Open (Открыть).

  2. Откройте вкладку 2-Up (2 варианта) в верхней части окна изображения, чтобы одновременно видеть исходное и оптимизированное изображение в области предварительно просмотра (рис. 23.33).
  3. Отобразите палитру Optimize (Оптимизация) с помощью команды меню Window > Show Optimize (Окно > Показать палитру Optimize).
  4. Из всплывающего меню Settings (Настройки), показанного на рис. 23.34, выберите какое-либо сочетание настроек оптимизации из имеющихся вариантов настроек. Оставьте выбранный вариант настроек без изменений и сохраните файл или выполните следующие шаги и задайте значения настроек оптимизации по своему выбору.
  5. Из всплывающего меню с форматами файлов выберите GIF или PNG-8.
  6. Активизируйте палитру из следующего всплывающего меню (подробнее о возможных опциях говорилось выше). Форматы GIF и PNG-8 поддерживают всего 256 цветов.

    Опции Perceptual (Учитывающий восприятие), Selective (Селективный) и Adaptive (Адаптивный) интерпретируют цвета в оптимизированном изображении, используя цвета исходного (рис. 23.35).

    Опция Web меняет цвета изображения на доступные в Web (рис. 23.36). Обычно это не самый лучший вариант для изображения с плавными переходами цветов, эффектами смешивания или градиентами.

    Опция Custom (По выбору пользователя) оптимизирует цвета изображения на основе палитры, ранее сохраненной в программе Photoshop или ImageReady.

    При выборе опций Mac OS и Windows цвета изображения оптимизируются на основе стандартной палитры соответствующей операционной системы.

  7. Из следующего всплывающего меню выберите способ перемешивания пикселов: No Dither (Нет), Diffusion (Диффузия), Pattern (Узор) или Noise (Шум). Данная опция позволяет имитировать недостающие оттенки для изображения с 8-битным цветом (этот эффект нельзя увидеть на палитре) за счет увеличения размера файла. При выборе варианта Diffusion создается едва заметный эффект с наименьшим увеличением размера файла.

    Выберите значение в процентах в поле Dither (Размытие). Большая величина позволяет имитировать больше цветов-заменителей, что также отразится и на размере файла (рис. 23.37, 23.38).

Рис. 23.35. Результат оптимизации изображения с помощью палитры Selective

Рис. 23.36. Появление отдельных точек на изображении после оптимизации с помощью палитры Web

Рис. 23.37. Результат оптимизации изображения с помощью палитры Selective при высоком значении параметра Dither

Рис. 23.38. Результат оптимизации изображения с помощью палитры Web при высоком значении параметра Dither (появилось множество точек, как и следовало ожидать)

Другой способ имитации цветов описан в разделе «Применение взвешенной оптимизации» этой главы.

  8. Укажите в поле Colors (Цвета) максимально возможное количество элементов для создания таблицы цветов (воспользуйтесь стандартной настройкой из выпадающего меню или введите точное значение). Для палитр Web, Windows и Mac по умолчанию в этом поле стоит Auto (Авто). Эта опция автоматически устанавливает количество элементов в таблице цветов равным либо количеству цветов в изображении, либо 256 в зависимости от того, какое значение меньше. Можно выбрать другой вариант настройки или ввести точное количество цветов, если вы по каким-то причинам не хотите пользоваться опцией Auto.
  9. Установите флажок Transparency (Прозрачность), чтобы программа ImageReady сохранила все прозрачные точки изображения (области слоя, где виден шахматный узор). Формат GIF, в отличие от PNG-8, не поддерживает полупрозрачные точки. (О том, как быть в этом случае, рассказано в разделе «Постепенное исчезновение».) Данная опция позволяет создавать непрямоугольные границы изображения. Если флажок Transparency не установлен, то прозрачные точки будут заполнены цветом, указанным в поле Matte (Кайма).
  10. Для того чтобы контролировать, как частично прозрачные точки вдоль границ изображения будут смешиваться с фоном Web-страницы (подобно границам объектов при сглаживании), используйте опцию Matte (Кайма). Задайте в этом поле цвет, совпадающий с цветом фона Web-страницы, если известно, какой он. На рис. 23.39 показано GIF-изображение, которое было получено при следующих условиях: установлен флажок Transparency, а в поле Matte выбран цвет. В результате появилась тонкая линия из цветных точек вдоль границ каждой фигуры.

    Если цвет фона неизвестен, выберите пункт None (Нет) в списке Matte, результатом будут жесткие, зазубренные границы (рис. 23.40). В обоих случаях исключается появление эффекта ореола вдоль границ изображения при отображении его в сети. Любой эффект смягчения границ (например, Drop Shadow (Отбросить тень)), примененный к прозрачным областям, приведет к заливке цветом, указанным в поле Matte.

  11. Установите флажок Interlaced (Через строку), чтобы детализация GIF или PNG-изображения постепенно возрастала по мере загрузки его на Web-страницу. При этом немного увеличится размер файла.
  12. Переместите ползунок Web Snap (Привязка к палитре Web) на соответствующую отметку в процентах, чтобы задать диапазон цветов, которые автоматически заменяются Web-эквивалентами. Чем выше значение данного параметра, тем меньше различных цветов будет в изображении и меньше размер файла, но тем заметнее станут отдельные точки изображения и в целом его стиль приблизится к плакатному (рис. 23.41).

Рис. 23.39. Изображение в формате GIF

Рис. 23.40. То же изображение при значении None в поле Matte

Рис. 23.41. Плакатный стиль изображения, полученный в результате выбора большого значения в поле Web Snap

Постепенное исчезновение

Прозрачные области изображений в форматах GIF и JPEG не могут иметь сглаженных границ без применения опции Transparency. Если необходимо, чтобы изображение плавно переходило в однотонный фон (как при применении эффекта Drop Shadow (Отбросить тень) или Outer Glow (Внешнее свечение)), создайте два слоя в документе с помощью программы Photoshop или ImageReady: однотонный нижний, окрашенный Web-цветом, который будет использован на Web-страничке, и верхний, содержащий элемент изображения со смягченными растушеванными границами или эффект, такой как Drop Shadow.

Гибридные изображения

Для гибридного изображения, содержащего не только однотонные области или текст, но также и фотографические фрагменты, самым лучшим вариантом будет использование формата GIF в сочетании с палитрой Perceptual (Учитывающий восприятие), Selective (Селективный) или Adaptive (Адаптивный), но только не палитрой Web. Эта комбинация позволит подобрать для однотонных областей Web-цвета и достаточно качественно отобразить фрагменты с плавными переходами цвета

  13. По желанию. Только для GIF-файлов можно установить значение параметра Lossy (С потерей), чтобы сделать размер файла оптимизированного изображения еще меньше. Как следует из названия опции, некоторые данные будут утеряны, но незначительное снижение качества изображения может быть оправдано уменьшением размера файла. (Как с помощью канала осуществлять контроль за объемом утраченных данных, рассказано в разделе «Применение взвешенной оптимизации» этой главы.)
  14. Сохраните файл, следуя рекомендациям, данным в разделах «Сохранение файла в ImageReady» и «Сохранение оптимизированного файла в ImageReady».

Для того чтобы сохранить текущий набор параметров палитры, выберите пункт Save Settings (Сохранить настройки) из меню палитры. Введите имя с расширением .irs. Найдите и откройте папку Adobe Photoshop 7/ Optimize Settings, затем щелкните по кнопке Save. Теперь сохраненный набор настроек будет отображаться во всплывающем меню Settings (Установки) в программе ImageReady, а также в диалоговом окне Save for Web (Сохранить для Web) в программе Photoshop.

Для того чтобы не потерять текущие настройки, сохраните их в наборе Temp (Временный). Каждый раз при сохранении старый файл будет заменен новым.

Применение взвешенной оптимизации

Взвешенная оптимизация - возможность в программе ImageReady 7, с помощью которой можно установить верхнюю и нижнюю границы качества при сжатии изображений в формате GIF, PNG и JPEG. Если создать и сохранить канал выделенной области, то верхнее ограничение будет применено к белой области канала (области, расположенной внутри выделения), а нижнее ограничение - к черной (расположенной за пределами выделенной области). Также можно указать алгоритм сокращения количества цветов и метод размытия для форматов GIF и PNG-8; предельный уровень потери данных для GIF и уровень качества изображения в целом для JPEG.

Для использования взвешенной оптимизации выполните следующие действия.

  1. Создайте канал, выделив область изображения и выполнив команду Save Selection (Сохранить выделенную область) из меню Select (Выделить).
  2. Оставьте без изменений вариант New (Создать новый канал) во всплывающем меню Channel (Канал), введите какое-либо имя в поле Name (Имя) и щелкните по кнопке ОК (рис. 23.42).
  3. На палитре Optimize (Оптимизация) щелкните по любой кнопке Channel (Канал). Эти кнопки расположены рядом со списком алгоритмов сокращения цветов (рис. 23.43) или с полями Lossy (С потерей) и Dither (Размытие) для форматов GIF и PNG; либо рядом с полем Quality (Качество) для формата JPEG (рис. 23.44).

Рис. 23.42. Диалоговое окно Save Selection

Рис. 23.43. Палитра Optimize для формата GIF

Рис. 23.44. Палитра Optimize для формата JPEG

  4. Из всплывающего меню Channel (Канал) выберите канал выделенной области. Также установите значения в полях Maximum (Максимум) и Minimum (Минимум) с помощью ползунка, стрелочек или текстового окна, а затем щелкните по кнопке ОК (рис. 23.45).

При выполнении шага 3 можно также воспользоваться каналом, созданным в программе Photoshop.

Рис. 23.45. Диалоговое окно Feather Selection

Рис. 23.46. Предварительный просмотр оптимизированного изображения с помощью вкладки 4-Up

Предварительный просмотр в программе ImageReady

Откройте вкладку 4-Up (4 варианта) в основном окне, чтобы иметь возможность одновременно видеть исходное изображение и еще три версии оптимизированного изображения на панели предварительного просмотра. Программа ImageReady воспользуется значениями палитры Optimize (Оптимизация) для создания первой версии, и затем автоматически создаст две других как варианты текущих настроек оптимизации. Можно щелкнуть по любому из четырех изображений на панели предварительного просмотра и затем в палитре Optimize изменить некоторые настройки только для выбранного изображения.

Изображение(-я) на панели предварительного просмотра будет обновляться каждый раз, как меняются значения параметров на палитре Optimize. Для того чтобы остановить процесс обновления, щелкните по кнопке Stop (Остановить) (рис. 23.46в) в строке «градусника», отображающего ход выполнения операции (рис. 23.46а). В правом нижнем углу изображения появится треугольный значок приостановки предварительного просмотра (рис. 23.466). Если вы снова измените значения каких-либо параметров на палитре Optimize или щелкнете по треугольнику, то изображение автоматически обновится.

При использовании команды Save Optimized (Сохранить с оптимизацией) будут сохранены настройки оптимизации для выбранного изображения на панели предварительного просмотра (но не исходного изображения на этой же панели). Помните об этом при предварительном просмотре с помощью вкладки 4-Up.

Команда Jump to

Запустите одновременно Photoshop и ImageReady, тогда вы сможете быстро редактировать один и тот же файл в любой программе. Для того чтобы переходить из одной программы в другую и обратно, воспользуйтесь командой Jump to (Перейти к), соответствующей кнопкой на панели инструментов или комбинацией клавиш Ctrl+Shift+M.

Программы Photoshop и ImageReady работают синхронно. Файл может быть одновременно открыт в обеих программах, и изменения, сделанные в одной программе, соответственно отразятся и в другой. Показанный на рис. 23.47 «градусник» выполнения появится в нижней части окна, если открыть файл в ImageReady, отредактировать его в программе Photoshop, а затем снова вернуться в ImageReady.

Независимо от того, будет ли установлен флажок Auto-Update Files (Автоматическое обновление файлов) в разделе General (Общие) окна Preferences (Установки) программы ImageReady или Auto-update open documents (Автоматическое сохранение открытых документов) в программе Photoshop, файлы будут автоматически обновляться в этих программах.

Если вы начали работу с изображением в ImageReady, операции редактирования, выполненные в программе Photoshop, будут представлены в виде одного элемента Update From Photoshop (Обновление из Photoshop) на палитре History (История) программы ImageReady. На палитре History (История) программы Photoshop также будет находиться событие Update from ImageReady (Обновление из ImageReady), если какие-либо действия были до этого произведены над изображением в программе ImageReady. В любой момент можно щелкнуть по элементу более раннего состояния, чтобы отменить операции редактирования, выполненные в другой программе.

Рис. 23.47. Отображение в программе ImageReady файла, отредактированного в программе Photoshop

Рис. 23.48. Диалоговое окно Optimize to File Size

Команда Revert (Восстановить) теперь фиксируется на палитре History (История) программы Photoshop или ImageReady и не приводит к удалению предшествующих элементов состояния. Это значит, что команду Revert также можно отменить.

Быстрая оптимизация

Почему бы не предоставить возможность программе ImageReady решать все за вас? Все, что от вас требуется - это определить размер оптимизированного изображения.

Быстрая оптимизация выполняется следующим образом.

  1. В меню палитры Optimize (Оптимизация) выберите команду Optimize to File Size (Оптимизировать до достижения указанного размера файла).
  2. Введите значение в поле Desired File Size (Желательный размер файла), чтобы определить размер оптимизированного файла (рис. 23.48).
  3. Включите одну из опций в разделе Start With (Начать с): Current Settings (Текущие настройки), чтобы использовать текущие настройки палитры оптимизации, или Auto Select GIF/JPEG (Автоматический выбор GIF или JPEG), чтобы программа ImageReady сама выбрала метод оптимизации.
  4. Если изображение состоит из ломтиков, то в области Use (Использовать) можно активизировать одну из опций Use Current Slice (Использовать текущий ломтик), Each Slice (Каждый ломтик) или Total of All Slices (Все ломтики) - см. рис. 23.48.
  5. Щелкните по кнопке ОК. Программа ImageReady быстро выберет настройки оптимизации и создаст оптимизированный файл заданного размера.

Создание и применение дроплета

Дроплет - это небольшое по размеру, но мощное приложение, сохраняющее настройки оптимизации, которые действовали в момент его создания, и применяющее их к изображению по указанию пользователя.

  1. На палитре Optimize (Оптимизация) щелкните по значку Droplet (Дроплет) - см. рис. 23.49, выберите папку, в которой будет храниться файл, и затем щелкните по кнопке Save (Сохранить) или просто перетащите значок дроплета с палитры Optimize на рабочий стол.
  2. Чтобы выполнить оптимизацию одного файла или целой папки файлов в соответствии с настройками, сохраненными в дроплете, перетащите файл или папку на его значок, расположенный на рабочем столе. Оптимизированный(-е) файл(-ы) будет сохранен в той же папке, что и дроплет.

Для того чтобы дроплет мог выполнить .свою работу, необходимо предварительно запустить программу ImageReady и/или Photoshop.

Дважды щелкните по пиктограмме дроплета (рис. 23.50), затем дважды щелкните по команде Batch Options (Параметры пакетной обработки), показанной на рис. 23.51, чтобы открыть одноименное диалоговое окно.

Рис. 23.49. Палитра Optimize

Рис. 23.50. Пиктограмма Droplet на рабочем столе

Рис. 23.51. Окно дроплета

Оптимизация изображений в формате JPEG или PNG-24

Формат JPEG - один из возможных форматов для проведения оптимизации изображений с плавными переходами цвета с дальнейшим отображением их в сети (фотографий, рисунков, градиентов или их сочетаний). Если для оптимизации выбран формат JPEG, то глубина цвета в 24 бит будет сохранена, но это сможет оценить только владелец монитора, способного отображать миллионы цветов (имеющего глубину цвета равную 24 битам). Однако не следует забывать, что формат JPEG использует такой метод сжатия, при котором некоторые данные все же теряются.

Формат PNG-24 похож на JPEG. Отличие состоит в том, что PNG поддерживает множество степеней прозрачности точек, расположенных вдоль, границ, а также в этом формате используется не приводящий к потерям метод сжатия. Файлы в формате PNG-24 больше по размеру, чем эквивалентные JPEG-файлы.

Оптимизация изображений в формате JPEG или PNG-24 выполняется следующим образом.

  1. Если вы работаете в программе Photoshop, то сохраните файл и щелкните по кнопке Jump to (Перейти к) в нижней части инструментальной панели. Загрузится программа ImageReady, если она еще не запущена. Альтернативный способ: в ImageReady выполните команду File > Open (Файл > Открыть), а затем выделите изображение и щелкните по кнопке Open (Открыть).
  2. Выберите вкладку 2-Up (2 варианта) в верхней части главного окна, чтобы одновременно видеть исходное изображение и оптимизированный вариант.
  3. Откройте палитру Optimize, выполнив команду Window > Show Optimize (Окно > Показать палитру Optimize) -см. рис. 23.52.
  4. Из всплывающего меню Settings (На стройки) выберите вариант JPEG High (JPEG с высоким качеством), JPEG Low (JPEG с низким качеством), JPEG Medium (JPEG со средним качеством) или PNG-24, все остальное оставьте без изменений и сохраните файл (рис. 23.53-23.55). Если вы хотите выбрать другие настройки оптимизации, выполните следующие шаги.
  5. Из всплывающего меню выберите формат JPEG.
  6. А из следующего - вариант Low (Низкое), Medium (Среднее), High (Высокое) или Maximum (Максимальное), чтобы определить качество сжатия файла. Можно сделать и иначе.

    Передвиньте ползунок Quality (Качество) на отметку степени сжатия. Посмотрите, как изменится при этом значение в расположенном рядом всплывающем окне. (Для того чтобы изменять степень сжатия с помощью канала выделенной области, изучите раздел «Применение взвешенной оптимизации» данной главы.)

    Никогда не забывайте, что чем ниже степень сжатия (или выше качество изображения), тем больше размер файла.

  7. Установите флажок Progressive (Постепенно), чтобы оптимизированное изображение отображалось на Web-страничке с возрастающей детализацией.

Рис. 23.52. Палитра Optimize в программе ImageReady

Рис. 23.53. Оптимизированный JPEG-файл, значение качества High

Рис. 23.54. Оптимизированный JPEG-файл, значение качества Medium

Рис. 23.55. Оптимизированный JPEG-файл, значение качества Low

  8. Увеличьте степень размытия в поле Blur (Размытие), чтобы уменьшить видимость дефектов, которые появляются при сжатии файла, а также для того, чтобы уменьшить размер файла. Будьте осторожны, не увеличьте это значение чрезмерно, иначе изображение окажется сглаженным слишком сильно. Потом значение в поле Blur можно будет уменьшить, чтобы восстановить резкость изображения.
  9. По желанию. Установите флажок ICC Profile (Профиль ICC), чтобы включить в оптимизированное изображение профиль ICC. Для использования этой опции необходимо, чтобы профиль был включен в изображение с помощью программы Photoshop. См. ниже раздел «Проверка цветовых профилей».
  10. Выберите в поле Matte (Кайма) какой-либо цвет, который будет использоваться для прозрачных областей исходного изображения. Если выбрать вариант None (Нет), то прозрачные области станут белыми.

Формат JPEG не поддерживает прозрачность. Для того чтобы имитировать прозрачность с помощью цвета, указанного в поле Matte, установите его таким же, что и цвет фона Web-страницы, если последний известен.

  11. По желанию. Установите флажок Optimize (Оптимизация), чтобы как можно лучше сжать файл.

Ранние версии браузеров (3.0 и ниже) могут не распознать JPEG-файл, сохраненный с использованием этой опции.

  12. Сохраните файл, следуя рекомендациям, приведенным в разделах «Сохранение файла в ImageReady» и «Сохранение оптимизированного файла в ImageReady» этой главы.

Для того чтобы сохранить текущие настройки оптимизации под каким-либо именем, обратитесь к примечанию после раздела «Оптимизация изображений в формате GIF или PNG-8».

JPEG-файлы и Web-цвета

При использовании метода сжатия JPEG к файлу добавляются ложные детали, из-за чего Web-цвета JPEG-изображения после сжатия оказываются не входящими в Web-палитру. Это не страшно, так как формат JPEG обычно используется для оптимизации изображений с плавным переходом цвета, и их размытие браузером не вызывает нежелательных эффектов. Не пытайтесь добиться соответствия цвета JPEG-файла цветам в GIF-файле или цвету фона Web-странички, поскольку при сжатии изображения цвета будут смещены и размыты.

Рис. 23.56. Выбор цвета однотонной области с помощью инструмента Eyedropper

Рис. 23.57. Таблица цветов в программе ImageReady

Нажав клавишу Shift, с помощью инструмента Eyedropper (Пипетка) щелкните по другим однотонным областям изображения, чтобы выбрать несколько цветов, затем сразу замените их на Web-цвета. Либо с помощью инструментов Lasso (Лассо), Magic Wand (Волшебная палочка) или инструментов группы Marquee (Область) выделите некоторую область изображения, затем из меню палитры Color Table (Таблица цветов) выберите команду Select All From Selection (Выделить все в выделенной области) и щелкните по кнопке Web Snap в нижней части палитры.

Приведение цвета однотонных областей к Web-цветам

Скажем, у вас есть изображение, которое необходимо оптимизировать в формате GIF с использованием палитры Perceptual (Учитывающая восприятие), Selective (Селективная) или Adaptive (Адаптивная), но в изображении есть однотонные области, цвет которых не входит в палитру Web. Прежде чем загружать изображение в сеть, можно заменить цвета таких областей близкими Web-цветами.

  1. Откройте изображение в программе ImageReady и произведите его оптимизацию в формате GIF.
  2. Выберите инструмент Eyedropper (Пипетка).
  3. Щелкните по однотонной области, цвет которой следует заменить Web-цветом (рис. 23.56).
  4. Откройте таблицу цветов. Образец цвета, по которому вы только что щелкнули, будет выделен (рис. 23.57).
  5. Щелкните по кнопке Web Snap (Приведение к палитре Web) в нижней части палитры. На выделенном образце цвета появится значок в виде алмаза -это означает, что цвет был изменен на эквивалентный ему Web-цвет.
  6. По желанию. Щелкните по кнопке Lock Color (Заблокировать цвет), чтобы сохранить данный элемент в таблице цветов, даже если количество цветов в палитре GIF будет сокращено.

Предварительный просмотр результатов возможного размытия оптимизированного изображения в браузере

С помощью различных методов предварительного просмотра в программе ImageReady можно получить довольно точное представление о том, как будет выглядеть оптимизированное изображение в режиме реального времени. Это поможет выбрать соответствующие настройки оптимизации.

В соответствии с данными, опубликованными на сайте Websnapshot.com. примерно у 10% пользователей Internet 8-битный монитор, который отображает максимум 256 цветов. С другой стороны, все графические браузеры используют палитру из 216 цветов. Для имитации цветов, не входящих в эту палитру, но содержащихся в изображении, используется метод размытия.

  1. Откройте изображение в программе ImageReady и вызовите, по крайней мере, одно оптимизированное изображение в главном окне.
  2. Выполните команды View > Preview > Browser Dither (Вид > Предварительный просмотр > Размытие в браузере) или нажмите комбинацию клавиш Ctrl+ Shift+Y - см. рис. 23.58 и 23.59. В результате миллионы цветов изображения будут сокращены до 8-битной цветовой палитры.

Рис. 23.58. Оптимизированное JPEG-изображение, опция Browser Dither выключена

Рис. 23.59. То же изображение с включенной опцией Browser Dither

Управление размытием

При оптимизации изображения в программе ImageReady применяется метод размытия для имитации цветов, содержащихся в исходном изображении, но отсутствующих в цветовой палитре оптимизированного изображения. Можно контролировать степень размытия, используя поле Dither (Размытие) на палитре Optimize (Оптимизация). Если увеличить его значение, то цвета оптимизированного изображения будут более точно воспроизводить цвета исходного, но размер файла немного увеличится.

Значение параметра Web Snap (Приведение к палитре Web) на палитре Optimize (Оптимизация) также влияет на степень размытия изображения в браузере. Чем выше это значение, тем меньше будет размыто изображение и тем меньше окажется размер файла. Чем больше цветов оптимизированного изображения соответствует 8-битной палитре браузера, тем меньше изменится изображение при включении опции Browser Dither (Размытие в браузере). Некоторая степень размытия приемлема и для изображений с плавным переходом цвета, поскольку тогда они выглядят лучше, чем при разбиении изображения на полосы, вызванном высоким значением параметра Web Snap (Приведение к палитре Web).

Предварительный просмотр изображения

Различные операционные системы используют разные значения гаммы, в результате чего внешний вид изображений может искажаться. При создании Web-графики важно предварительно просмотреть и скорректировать изображение для различных платформ.

Перейдя в режим предварительного просмотра изображения в программе ImageReady, выполните команду Standard Windows Color (Стандартные цвета Windows), чтобы имитировать контрастность изображения.

Воспользуйтесь командой View> Preview > Uncompensated Color (Вид > Предварительный просмотр > Не компенсировать цвет), чтобы предварительно просмотреть изображение без компенсации гаммы.

Включите опцию Embedded Color Profile (Встроенный цветовой профиль), чтобы привести изображение в окне предварительного просмотра в программе ImageReady (для RGB-монитора) в соответствие с профилем, включенным в изображение в программе Photoshop. Эта опция будет недоступна, если в изображении нет профиля.

Нажимая сочетания клавиш Ctrl+Alt+Y, можно попеременно переключать четыре опции предварительного просмотра. Но очень сложно уследить за тем, какой вариант предварительного просмотра отображается в данный момент.

Рис. 23.60. Диалоговое окно Gamma

Рис. 23.61. Темное изображение

Рис. 23.62. Светлое изображение

Изменение гаммы оптимизированного файла

  1. Перейдя в режим предварительного просмотра оптимизированного изображения в ImageReady, воспользуйтесь командами Image > Adjustments > Gamma (Изображение > Корректировки > Гамма).
  2. Щелкните по кнопке Windows to Macintosh (Из Windows в Macintosh), чтобы изменить установленное значение гаммы на гамму Mac OS (рис. 23.60). Изображение будет выглядеть темнее (рис. 23.61).

    Можно поступить и иначе. Щелкните по кнопке Macintosh to Windows (Из Macintosh в Windows), чтобы изменить установленное значение гаммы изображения на гамму Windows. В системе Mac OS изображение будет выглядеть светлее (рис. 23.62).

    В каждом случае особенности платформы компенсируются при помощи затемнения или осветления изображения.

  3. Щелкните по кнопке ОК.

Также можно передвинуть ползунок, чтобы вручную установить значение гаммы между значениями, определяемыми кнопками Windows to Macintosh и Macintosh to Windows, либо указать другое значение гаммы для любой из платформ. Значение гаммы -относительная величина. Если изменить ее, закрыть, а затем снова открыть диалоговое окно, то настройка примет свое первоначальное значение равное 1.

Сохранение кода

Существует два метода копирования исходного кода из программы ImageReady в любой HTML-редактор. Первый: выделите исходный код, который расположен в нижней части окна браузера, щелкнув мышью и перетаскивая курсор (рис. 23.63), затем скопируйте и вставьте его в HTML-редактор или программу создания Web-страниц. Второй: в программе ImageReady воспользуйтесь командами Edit > Сору HTML Code > For All Slices (Правка > Копировать HTML-код > Для всех ломтиков) применительно к открытому файлу, затем вставьте исходный код в HTML-редактор или программу создания Web-страниц.

Предварительный просмотр оптимизированного изображения в браузере

Для более точной имитации вида изображения в сети щелкните по кнопке Preview in Browser (Предварительный просмотр в браузере) в программе ImageReady. Можно выбрать любой браузер среди тех, которые установлены в вашей системе.

Такая операция не покажет действительного времени загрузки изображения через Internet, и вид картинки будет зависеть от типа используемого монитора. Тем не менее, эта функция очень полезна.

  1. Открыв оптимизированное изображение в программе ImageReady, щелкните на панели инструментов по кнопке Preview in Browser (Предварительный просмотр в браузере), либо нажмите соответствующую кнопку и выберите браузер из подменю.

Рис. 23.63. Изображение и исходный HTML-код в программе ImageReady

Рис. 23.64. Диалоговое окно Save

  2. Браузер будет запущен, и изображение загрузится в окно (рис. 23.63). Созданные в ImageReady GIF-анимация и ролловеры также будут отображены на экране.
  3. Если необходимо, закройте браузер и затем щелкните по любой палитре или окну ImageReady, чтобы вернуться в эту программу.

Предварительно просмотрите ваши файлы, загрузив их через сеть, на обеих компьютерных платформах с использованием различных мониторов.

Если глубина цвета на мониторе выше, чем 8 бит, а необходимо увидеть, как будет выглядеть изображение на 8-битном браузере, то сначала сократите количество цветов до 256 и затем загрузите браузер. Данный метод и предварительный просмотр с помощью опции Browser Dither (Размытие в браузере) в программе ImageReady отличаются незначительно.

Сохранение файла в программе ImageReady

  1. Убедитесь, что вы работаете в программе ImageReady, и что открыт файл, который следует сохранить. Затем выполните команду File> Save (Файл > Сохранить) или нажмите комбинацию клавиш Ctrl+S.
  2. Введите имя файла и оставьте расширение файла без изменения (рис. 23.64). Выберите папку, в которой следует сохранить файл, и щелкните по кнопке Save (Сохранить). Файл будет автоматически сохранен в формате Photoshop. При этом в файл не будут включены настройки оптимизации.

Сохранение оптимизированного файла в программе ImageReady

Выполните приведенную ниже последовательность действий, чтобы сохранить оптимизированный файл вместе с настройками, выбранными в палитре Optimize (Оптимизация).

  1. Выполните команду File О Save Optimized (Файл > Сохранить с оптимизацией) или нажмите комбинацию клавиш Ctrl+Alt+S.
  2. Для того чтобы контролировать, как будет сохранен файл, выберите один из пунктов во всплывающем меню Format (Формат) - см. рис. 23.65:
    • HTML and Images (HTML и изображения), чтобы создать HTML-файл и сохранить ломтики изображения в отдельном файле;
    • Images Only (Только изображения), чтобы сохранить только ломтики изображения;
    • HTML Only (Только HTML), чтобы создать HTML-файл, не сохраняя при этом файлы изображения. Отдельному HTML-файлу будет автоматически присвоено расширение .htm или .html, он будет сохранен в том же каталоге, где находится оптимизированный файл.
  3. Установите флажок Include GoLive Code (Включить код GoLive), если необходимо редактировать HTML-код или Java-скрипт в программе GoLive компании Adobe.
  4. По желанию. Щелкните по кнопке Output Settings (Настройки вывода) и затем во всплывающем меню выберите пункт HTML, чтобы задать HTML-установки форматирования и кодирования (рис. 23.66). Воспользуйтесь опциями данного окна, чтобы добиться соответствия HTML-файлов в программе ImageReady и HTML-редакторах. Щелкните по кнопке ОК или предварительно выполните следующие шаги.

Рис. 23.65. Всплывающее меню Format в диалоговом окне Save Optimized As

Рис. 23.66. Диалоговое окно Output Settings в режиме HTML

Рис. 23.67. Диалоговое окно Output Settings в режиме Saving Files

Воспользуйтесь командой Save as (Сохранить как) или Save Optimized As (Сохранить с оптимизацией как), чтобы сохранить копию файла под другим именем.

Для того чтобы связать с изображением URL или ярлык Alt, воспользуйтесь палитрой Slice (Ломтик) (см. раздел «Прикрепление ярлыка Alt к ломтику или целому изображению» этой главы).

  5. Из второго всплывающего меню выберите пункт Saving Files (Сохранение файлов). Благодаря этому вы сможете указать в разделе File Naming (Именование файлов) правила именования файлов, генерируемых автоматически, таких как файлы ломтиков и кадров роллове-ра, сохраняемые вместе с оптимизированным изображением и используемые на Web-страничке (рис. 23.66).

    Посоветуйтесь со специалистом по созданию HTML-файлов, прежде чем изменять значения настроек. Выберите составные части имени файла в каждом поле с помощью различных всплывающих меню в разделе File Naming (Именование файлов). Если выбранные вами составные части имени файла смотрятся нелепо, то верните им значения по умолчанию.

    Активизируйте одну из опций в области Filename Compatibility (Совмести мость имен файлов).

    Установите любые флажки в разделе Optimized Files (Оптимизированные файлы). Выберите папку, в которой следует сохранить автоматически создаваемые файлы.

  6. Щелкните по кнопке ОК, чтобы закрыть диалоговое окно Output Settings (Настройки вывода).
  7. Введите имя файла, выберите его месторасположение и щелкните по кнопке Save (Сохранить).

Обновление существующего HTML-файла

Если вы отредактировали оптимизированный файл и хотите обновить соответствующий HTML-файл, то воспользуйтесь командой File > Update HTML (Файл > Обновить HTML файл), выделите HTML-файл, щелкните по кнопке Open (Открыть), затем, когда обновление будет завершено, по кнопке ОК. HTML-код, созданный для оптимизированного изображения, будет также обновлен, даже если он был скопирован и вставлен в больший HTML-файл, и даже если в этом файле содержатся данные и из других файлов изображений.

Изменение заголовка Web-страницы и вставка информации об авторских правах

С помощью диалогового окна Image Info (Информация об изображении) можно изменять содержащийся в HTML-файле заголовок окна браузера или вставлять информацию об авторских правах в HTML-файл.

  1. Если изображение открыто в программе ImageReady, то выполните команду меню File > File Info (Файл > Информация о файле) или нажмите комбинацию клавиш Ctrl+ Shift+K.
  2. В поле Page Title (Заголовок страницы) измените заголовок (рис. 23.68), отображаемый в соответствующей строке окна браузера (текст находится между спецификаторами <TITLE>). По умолчанию заголовок страницы совпадает с заголовком файла изображения. В дополнение к указанным выше действиям

Рис. 23.68. Диалоговое окно Image Info (или вместо них) можно ввести информацию в поле Copyright (Авторские права), чтобы включить в HTML-файл соответствующие сведения.

  3. Щелкните по кнопке ОК.

Ввод текста в программе ImageReady

В программе ImageReady можно создавать и редактировать текст так же, как и в Photoshop. Как и в программе Photoshop, текст в ImageReady вводится непосредственно в изображение, и его стиль допускается изменять с помощью панели опций, палитры Character (Шрифт) или Paragraph (Абзац). Этим программы ImageReady и Photoshop также похожи на Adobe Illustrator. Для того чтобы узнать, как создать текст в программе ImageReady, обратитесь к главе 17.

К тому же, в программе ImageReady, как и в Photoshop, текст автоматически появляется на своем собственном слое, и его разрешается редактировать до тех пор, пока слой не будет преобразован в растровый формат. К редактируемому тексту можно применить любой из эффектов слоя или стиль, при этом он останется редактируемым. При оптимизации в программе ImageReady текст преобразуется в растровый формат, как и остальная часть изображения.

Необходимо отметить некоторые различия между программами Photoshop и ImageReady: в последней нельзя создать выделенную область из текста, преобразовать текст в рабочий контур или в фигуру.

  1. Убедитесь, что в главном окне выбрана вкладка исходного изображения.
  2. Активизируйте инструмент Туре (Текст) или Vertical Type (Вертикальный текст), воспользовавшись клавишей Т или комбинацией клавиш Shift+T.
  3. Щелкните в окне изображения там, где должно быть начало текста. Появится мерцающий курсор (рис. 23.69).
  4. Выполните шаги, описанные в разделе «Создание текста» главы 17, чтобы создать текст в режиме построчного ввода или как абзац (рис. 23.70)

Эффекты слоя в программе ImageReady

В программе ImageReady, как и в Photoshop, имеются эффекты слоя. Это дает великолепную возможность применять спецэффекты к тексту, потому что эффекты слоя легко приспособить к конкретным условиям и при необходимости изменить. Можно даже перетащить эффект (или эффекты) с палитры Layers (Слои) на палитру Styles (Стили), чтобы сохранить его (их) в качестве стиля (раздел «Сохранение эффекта слоя в виде стиля»), а потом применять этот стиль по отношению к другим слоям. Допускается перетаскивать как имена отдельных эффектов, так и целые панели эффектов, то есть комбинацию эффектов.

Рис. 23.69. Начало вставки текста

Рис, 23.70. Введенный текст

Советы по созданию текста для сети

Воспользуйтесь следующими советами при создании текста в сети:

  • для редактируемого и преобразованного в растровый формат текста сохраняются все атрибуты текстового слоя и опции сглаживания при переходе из программы Photoshop в ImageReady и обратно;
  • текст в программах Photoshop и ImageReady может быть сглажен. Так как при сглаживании добавляются цветные пикселы вдоль границ литер, также добавляются новые элементы в таблицу цветов, в результате немного увеличивается размер файла;
  • некоторые считают, что мелкий текст, если он создается для сети, должен быть сглажен. Мы же думаем иначе -маленький по размеру текст лучше смотрится, если не применять к нему операцию сглаживания. Воспользуйтесь средствами предварительного просмотра в программе ImageReady, чтобы решить данный вопрос самостоятельно;
  • при создании текста для сети воспользуйтесь шрифтом большего размера, чем тот, который применили бы при выводе на печать. Так текст будет выглядеть более отчетливо на экране;

Один и тот же кегль на Web-страничке будет по-разному смотреться на экранах UNIX-подобных ОС из-за различий в разрешении мониторов (72 ppi для Mac OS и 96 ppi для Windows). Просмотрите свою страничку или сайт на обеих платформах.

  • можно включить или выключить стили начертания текста Faux Bold (Ложный полужирный) или Faux Italic (Ложный курсив) в меню палитры Character (Шрифт) в программе ImageReady. Эти опции были специально заготовлены для тех шрифтов, у которых нет встроенного полужирного стиля или курсива. Также есть опция Underline (Подчеркнутый) для создания ссылок (не настоящих ссылок!) в виде подчеркнутого текста;
  • во избежание размытия не забудьте подобрать для текста Web-цвет. Для этого в программе ImageReady с помощью инструмента Eyedropper (Пипетка) щелкните по литере, затем замените цвет наиболее близким Web-эквивалентом с помощью палитры Color Table (Таблица цветов). Подробнее об этом написано в разделе «Приведение цвета однотонных областей к Web-цветам».

Для того чтобы выполнить приведение к Web-цветам в программе Photoshop, дважды щелкните по миниатюре с буквой «Т» на текстовом слое, затем щелкните по образцу цвета на панели опций или палитре Character (Шрифт). В окне Color Picker (Выбор цвета) либо щелкните по значку, предупреждающему о несоответствии Web-цветам, чтобы подобрать наиболее близкий Web-заменитель, либо установите флажок Only Web Colors (Только Web-цвета) и щелкните по кнопке ОК.

Оптимизация гибридных изображений

Смешанные изображения, содержащие одновременно элементы с плавным переходом цвета и однотонные области (например, текст), смотрятся несколько вызывающе (рис. 23.71).

Рис. 23.71. Гибридное изображение

Рис. 23.72. Ломтики различных типов

И в программе Photoshop, и в ImageReady можно воспользоваться специальными функциями разделения изображения на ломтики, чтобы отделить различные области смешанного изображения, а потом применить к ним различные способы оптимизации. Чтобы облегчить деление смешанного изображения на ломтики, лучше, по возможности, расположить текст там, где он не будет закрывать фрагменты с плавным переходом цвета. Произведите оптимизацию текстовых фрагментов изображения в формате GIF и фрагментов с плавным переходом цвета в формате JPEG. (Более подробно об этом рассказано в разделе «Деление изображения на ломтики».)

Деление изображения на ломтики

Операция разрезания изображения на ломтики (slice) состоит в том, что картинка делится на отдельные зоны, что позволяет ускорить загрузку изображения большого размера. Совокупность небольших ломтиков загружается быстрее, чем одно большое изображение. Браузер последовательно собирает ломтики в единую картинку, используя HTML-таблицы и фреймы.

Ломтики, создаваемые при помощи инструмента Slice (Ломтик), называются «пользовательскими ломтиками» (рис. 23.72а). Размер «ломтиков слоя» (о них рассказывается ниже в разделе «Создание ломтиков слоя» данной главы) выбирается автоматически таким образом, чтобы в них вошли все видимые пикселы выделенного слоя (рис. 23.726). При создании ломтиков обоих типов (и пользовательских, и ломтиков слоя) программа ImageReady делит оставшуюся часть изображения на «автоматически создаваемые ломтики», которые имеют метки серого цвета (рис. 23.72в).

Ломтики можно создавать, выделять, редактировать и просматривать как в программе ImageReady, так и в программе Photoshop. Мы предпочитаем использовать ImageReady, поскольку она предоставляет более широкий набор средств для работы с ломтиками. Для вызова на экран палитры Slice (Ломтик) в программе ImageReady выполните команду Window с> Show Slice (Окно => Показать палитру Slice) или щелкните по кнопке Slice, Palette (Палитра Slice) на панели опций инструмента Slice Select (Выделение ломтиков). В программе Photoshop щелкните по кнопке Slice Options (Опции ломтиков) на панели опций инструмента Slice Select (Выделение ломтиков), чтобы вызвать окно Slice Options (Опции ломтиков). И палитра, и диалоговое окно предоставляют одинаковый набор средств для работы с ломтиками.

За сценой

В HTML-файле таблица может быть использована в качестве решетки, которая контролирует расположение графики и текста на Web-странице. Ячейки таблицы можно закодировать так, чтобы они содержали отдельные изображения или данные либо ломтики большого графического изображения. Фреймы работают как отдельные окна внутри большего окна браузера. Во фрейме может отображаться HTML-графика, страничка или сайт независимо от других фреймов на этой же странице. Для того чтобы подробнее изучить HTML-таблицы и фреймы, обратитесь к книгам Линды Уэйнманн (Lynda Weinmann) «Designing Web Graphics.3» или «Creative HTML Design» (обе книги изданы компанией New Riders Publishing); Элизабет Кастро (Elizabeth Castro) «HTML 4 for the World Wide Web» (издательство Peachpit Press); или Чака Маскьяно (Chuck Musciano) и Билла Кеннеди (Bill Kennedy) «HTML: Definitive Guide» (издательство O'Reilly&Associates)

Рис. 23.73. Диалоговое окно Divide Slice

Рис. 23.74. Изображение, поделенное на шесть ломтиков

Разрезание изображения на ломтики с помощью команд

  1. Выполните команду меню Slices > Promote to User-slice (Ломтики > Преобразовать в пользовательский ломтик), а затем воспользуйтесь командой Divide Slice (Разделить ломтик). Установите флажок Preview (Предварительный просмотр).
  2. Установите флажок Divide Horizontally Into (Разделить по горизонтали на), чтобы получить горизонтально расположенные ломтики (рис. 23.73), а затем введите количество ломтиков в поле slices down, evenly spaced (одинаковых ломтиков) или высоту каждого ломтика в поле pixels per slice (пикселов на ломтик).

    В дополнение к указанным действиям или вместо них установите флажок Divide Vertically Into (Разделить по вертикали на), чтобы получить вертикально расположенные ломтики, затем введите количество ломтиков в поле slices across, evenly spaced (одинаковых ломтиков), либо значение ширины каждого ломтика в поле pixels per slice (пикселов на ломтик).

  3. Щелкните по кнопке ОК. В верхнем левом углу каждого ломтика появится метка, которая определяет его номер. Нумерация начинается с 01 и идет слева-направо и сверху-вниз (рис. 23.74).

После применения команды Divide Slice (Разделить ломтик) будут выделены все ломтики. Для того чтобы выделить только один ломтик, активизируйте инструмент Slice Select (Выделение ломтиков) с помощью клавиши К (комбинации клавиш Shift+K) и щелкните по нужному ломтику.

Разбиение изображения на ломтики вручную

С помощью инструмента Slice (Ломтик) можно вручную контролировать расположение ломтиков. Можно изменять размер пользовательских ломтиков, перемещать их и заново производить разбиение; но эти операции неприменимы к автоматически создаваемым ломтикам.

  1. Активизируйте инструмент Slice (Ломтик), нажав клавишу К (комбинацию клавиш Shift+K).
  2. Щелкните мышью в окне изображения и перетащите указатель по диагонали, чтобы обозначить первый ломтик (рис. 23.75 и 23.76). Б верхнем левом углу появится метка с номером ломтика, а вокруг нового ломтика -тонкая пунктирная рамка, обозначающая границу ломтика, и манипуляторы, позволяющие изменять его размеры. Программа ImageReady автоматически разобьет оставшуюся часть изображения на ломтики.
  3. По желанию. Нарисуйте дополнительные ломтики с помощью инструмента Slice. Каждому новому ломтику будет присвоен соответствующий номер. Программа ImageReady заново поделит в автоматическом режиме оставшееся изображение на ломтики и присвоит им новые номера.
  4. По желанию. Для того чтобы поделить ломтик на более мелкие пользовательские ломтики, активизируйте инструмент Slice Select (Выделение ломтиков) с помощью клавиши К (сочетания клавиш Shift+K), щелкните по пользовательскому или автоматически созданному ломтику для того, чтобы выделить его, а затем выполните команду Slices > Divide Slice (Ломтик > Разделить ломтик) и щелкните по кнопке ОК. Каждому новому ломтику будет присвоен собственный номер.

Рис. 23.75. Создание ломтика с помощью инструмента Slice

Рис. 23.76. Новый ломтик

Рис. 23.77. Панель Color Adjustments в диалоговом окне Slices

Выделенный ломтик будет отображаться нормально в отличие от невыделенного, который окажется серым. В программе ImageReady, чтобы отрегулировать, насколько темным или светлым будет выделенный ломтик, надо задать значения в процентах в полях User-slices (Пользовательские ломтики) и/или Auto-slices (Автоматически создаваемые ломтики) в области Color Adjustments (Корректировки цвета) в диалоговом окне, открываемом при помощи команд Edit > Preferences > Slices (Правка > Установки > Ломтики) - см. рис. 23.77.

Шаблон для ломтиков

Для того чтобы спроектировать расположение ломтиков до их создания, отобразите линейки по краям изображения (комбинации клавиш Ctrl+R), перетащите направляющие и оставьте их там, где следует разместить границы ломтиков, а затем воспользуйтесь командой Slices > Create Slices from Guides (Ломтики > Создать ломтики по направляющим).

Эта команда удалит ранее существовавшие ломтики. Так как направляющие тянутся от одного края окна к другому, то можно создать подобие шахматной доски с «клетками» разного размера. Затем можно изменить размер ломтиков, перетаскивая границы, либо соединить несколько выделенных ломтиков в один с помощью команды Slices >Combine Slices (Ломтики > Объединить ломтики), но такая операция может оказаться более трудоемкой, чем изначальное построение ломтиков с помощью инструмента Slice.

Создание ломтика на основе слоя

Границы ломтиков слоя автоматически обновляются при трансформации, перемещении слоя и добавлении эффектов слоя. Такие ломтики особенно удобны при создании ролловера с различными эффектами (например, с отбрасыванием тени), увеличивающими площадь слоя.

Чтобы создать ломтик на основе слоя, выделите слой на палитре Layers (Слои), а затем воспользуйтесь командой New Layer Based Slice (Создать ломтик на основе слоя) в меню Layer (Слой).

Преобразование ломтика, созданного автоматически или на основе слоя, в пользовательский ломтик

  1. Выберите инструмент Slice Select (Выделение ломтиков), нажав клавишу К или сочетание клавиш Shift+K.
  2. Щелкните по ломтику, который следует преобразовать.
  3. Воспользуйтесь командой Promote to User-slice (Преобразовать в пользовательский ломтик) в меню Slices (Ломтики).

Удаление ломтиков

  1. Активизируйте инструмент Slice Select (Выделение ломтиков) с помощью клавиши К или комбинации клавиш Shift+K.
  2. Для того чтобы удалить один ломтик, щелкните по нему. Если вы хотите удалить несколько ломтиков, то, нажав клавишу Shift, выделите их щелчком мыши. Затем в меню Slices (Ломтики) или меню палитры Slice (Ломтик) выполните команду Delete Slice (Удалить ломтик), либо просто нажмите клавишу Backspace. Для того чтобы удалить все ломтики изображения, воспользуйтесь командой меню Slices > Delete All (Ломтики > Удалить все).

Изменение размера пользовательских ломтиков

Если уменьшить размеры пользовательского ломтика, то программа ImageReady автоматически сформирует и снова пронумерует автоматически создаваемые ломтики, чтобы заполнить ими образовавшиеся пустоты.

Если увеличить какой-либо ломтик, то он может закрыть ломтики, расположенные за ним. Можно вручную удалить любой из спрятанных ломтиков. Однако делать это необязательно, поскольку при сохранении оптимизированного файла перекрывающиеся ломтики и ячейки таблицы будут удалены. Для того чтобы увидеть спрятанные ломтики, воспользуйтесь кнопкой управления видимостью ломтиков на панели опций инструмента Slice Select (Выделение ломтиков).

Рис. 23.78. Изменение размера пользовательского ломтика

Рис. 23.79. Перераспределение автоматически создаваемых ломтиков после изменения размеров пользовательского ломтика

Рис. 23.80. Скрытие (а) и показ (б) ломтиков при помощи кнопки Slice Visibility

  1. Выберите инструмент Slice Select (Выделение ломтиков), Автоматически будут показаны границы ломтиков.
  2. Щелкните по пользовательскому ломтику, размер которого следует изменить.
  3. Перетащите боковой манипулятор рамки вдоль одной из осей координат, чтобы изменить размер ломтика, либо угловой манипулятор, чтобы изменить размер сразу по двум направлениям (рис. 23.78 и 23.79).

Как спрятать или показать метки и границы ломтиков

Щелкните по кнопке Slice Visibility (Отображение ломтиков) на панели инструментов (рис. 23.80), либо нажмите клавишу Q, чтобы скрыть или показать ломтики. В программе Photoshop эту операцию можно выполнить с помощью команд View > Show > Slices (Вид > Показать > Ломтики).

По умолчанию в каждом документе изначально имеется один автоматически создаваемый ломтик, размеры которого совпадают с размерами изображения. Он помечен светло-серой меткой и номером 01.

Связывание ссылок с ломтиками изображения

К ломтику можно прикрепить ссылку (URL) на какую-либо Web-страничку. Если щелкнуть по этому ломтику, то пользователь автоматически будет попадать на Web-страничку, которая имеет соответствующий URL-адрес. Обычно ломтики со ссылками создаются поверх графических элементов (кнопок, слов или значков), так чтобы пользователь Internet с легкостью мог их обнаружить.

В программе ImageReady можно создать несколько ломтиков для одного изображения и к каждому из них прикрепить свой URL-адрес. Определение всех ссылок изображения с помощью ломтиков позволяет обойтись без создания, выравнивания и изменения размеров множества слоев изображения.

  1. Откройте или создайте изображение, содержащее элементы, которые будут использоваться в качестве ссылок. Обычно такими элементами являются кнопки, миниатюры изображений или пиктограммы (рис. 23.81). Набор ссылок, расположенных в строке или столбце, называется панелью навигации (navigation bar).
  2. Выберите инструмент Slice (Ломтик), нажав клавишу К или комбинацию клавиш Shift+K.
  3. Перетащите указатель по диагонали каждого фрагмента изображения, чтобы создать ломтики, которые следует преобразовать в ссылки (рис. 23.82).
  4. Активизируйте инструмент Slice Select (Выделение ломтиков) с помощью клавиши К или комбинации клавиш Shift+K.

Рис. 23.81. Элементы изображения, которые станут ссылками

Рис. 23.82. Создание ломтиков для каждого элемента изображения

  5. Щелкните по какому-нибудь ломтику. На палитре Slice (Ломтик) появится его миниатюра. (Выполните предварительно команду меню Window > Show Slice (Окно > Показать ломтик), чтобы открыть палитру, если она еще не открыта.)

Рис. 23.83. Ввод URL-адреса

Объединение ломтиков

Для того чтобы объединить пользовательские и автоматически создаваемые ломтики в один большой ломтик, выделите несколько ломтиков и выполните команду Slices > Combine Slices (Ломтики > Объединить ломтики). Результатом будет наименьший пользовательский ломтик, границы которого охватывают все выделенные части изображения.

  6. В поле URL введите необходимый Internet-адрес (рис. 23.83).
  7. По желанию. Значение в поле Target (Цель) сообщает браузеру, в какой HTML-фрейм загрузить содержимое ссылки и какие HTML-фреймы сохранить. Поле Target становится доступным для ввода информации только после того, как был введен адрес в поле URL.

    Нажатием клавиши Tab можно переместиться в эту область палитры, а затем из выпадающего меню выбрать один из следующих пунктов:

    • __blank (Пустой) - открыть новое окно браузера для содержимого ссылки;
    • _self (Сам) - загрузить данные ссылки в HTML-фрейм ломтика;
    • _parent (Предок) — заменить текущие HTML-фреймы данными ссыл ки;
    • _top (Верхний) - загрузить содержимое ссылки в окно браузера (эта опция похожа на опцию _parent).
  8. Повторите шаги 5-7 для других ломтиков, с которыми необходимо связать ссылки.

Изменение порядка следования ломтиков

Перекрывающие друг друга ломтики отображаются и нумеруются в порядке создания. В любой момент можно изменить порядок следования пользовательских ломтиков и ломтиков, созданных на основе слоя.

  1. Активизируйте инструмент Slice Select (Выделение ломтиков), нажав клавишу К или комбинацию клавиш Shift+K, и щелкните по ломтику, расположение которого относительно других ломтиков в стеке следует изменить (рис. 23.84).
  2. Щелкните по той кнопке на панели опций инструмента, где указан порядок следования, который необходимо установить (недоступные кнопки будут серыми, как показано на рис. 23.85). Порядок следования ломтиков будет изменен (рис. 23.86).

Рис. 23.84. Ломтик №13, находящийся позади других ломтиков изображения

Рис. 23.85. Кнопки, управляющие порядком следования ломтиков

Рис. 23.86. Ломтик №13 теперь имеет номер 6 и находится поверх остальных ломтиков

Рис. 23.87. Кнопки выравнивания на панели опций инструмента Slice Select

Рис. 23.88. Кнопки распределения ломтиков на панели опций инструмента Slice Select

Выравнивание пользовательских ломтиков вдоль общей границы

Если выровнять пользовательские ломтики вдоль общей границы изображения или равномерно расположить их вдоль осей координат, то, возможно, уменьшится время загрузки HTML-файлов. Ломтики, созданные на основе слоя, выровнять или распределить нельзя, так как их месторасположение привязано к слою.

  1. Выберите инструмент Slice Select (Выделение ломтиков), нажав клавишу Shift, щелчком мыши выделите ломтики, которые необходимо выровнять.
  2. На панели опций щелкните по одной из кнопок выравнивания (рис. 23.87).

Равномерное распределение пользовательских ломтиков вдоль одной оси

  1. Выберите инструмент Slice Select (Выделение ломтиков) клавиши К или комбинации клавиш Shift+K, затем, нажав клавишу Shift, выделите те ломтики, которые следует распределить.
  2. Щелкните по одной из шести кнопок распределения, расположенных на панели опций (рис. 23.88).

Создание карты изображения на основе слоя

Карта изображения (image map) содержит «кнопки» произвольной формы, каждая из которых имеет собственную URL-ссылку (рис. 23.89). Воспользуйтесь этим способом, если области, с которыми необходимо связать URL-адреса, имеют непрямоугольную форму или вы предпочитаете работать с одним файлом изображения вместо нескольких файлов для каждого ломтика.

Программа ImageReady позволяет создавать карты изображений при помощи слоя или инструмента. Карта на основе слоя, включающая в себя все непрозрачные фрагменты слоя, автоматически обновляется каждый раз, когда редактируется слой. Карты, созданные при помощи инструментов, могут быть выровнены по общей границе или распределены вдоль одной оси. Настройки и размеры карты, созданной при помощи инструмента, допускается копировать. Несложно превратить карту, созданную на основе слоя, в карту, созданную при помощи инструмента.

  1. На палитре Layers (Слои) выберите слой с прозрачными областями (рис. 23.90). Непрозрачные пикселы станут «горячими» точками карты изображения.
  2. Воспользуйтесь командой Layer > New Layer Based Image Map Area (Слой > Создать новую область карты изображения на основе слоя). Прямоугольная карта изображения окружит непрозрачные области слоя.
  3. Из всплывающего меню Shape (Фигура) палитры Image Map (Карта изображения) выберите форму «кнопки»:

Рис. 23.89. Изображение с несколькими перекрывающимися элементами, подходящее для создания карты изображения с помощью палитры Layer Options

Рис. 23.90. Создание карты изображения на основе слоя

Рис. 23.91. Выбор формы кнопки и ввод URL-адреса на палитре Image Map

Можно изменить форму фигуры на карте изображения с помощью инструмента Image Map Select (Выделение карты изображения), клавиша Р (комбинация клавиш Shift+ Р). Активизировав этот инструмент, выберите форму фигуры из всплывающего меню Shape (Форма), расположенного на палитре Image Map (Карта изображения).

При использовании опции Polygon (Многоугольник) в поле Quality (Качество) или с помощью ползунка можно задать точность, с которой карта изображения должна повторять очертания изображения.

Программа ImageReady может кодировать карту изображения в HTML либо для клиента, либо для сервера. Для того чтобы выбрать одну из этих опций, щелкните по кнопке Output Settings (Настройки вывода) в диалоговом окне Save Optimized (Сохранить с оптимизацией), а затем выберите тип карты из всплывающего меню Туре (Тип) в разделе Image Maps (Карты изображения).

Rectangle (Прямоугольник), Circle (Круг) или Polygon (Многоугольник) (рис. 23.91).

  4. Введите URL-адрес (включая префикс http://) - см. рис. 23.91. Введенный адрес появится под именем слоя на палитре Layers (Слои), как показано на рис. 23.90.
  5. По желанию. В поле Target (Цель) содержится информация о том, в какой HTML-фрейм будет загружаться содержимое ссылки, а какие HTML-фреймы следует сохранить. Это поле становится доступным только после того, как был введен URL-адрес.
  6. По желанию. В поле Alt (Альтернатива) введите слово или слова, которые станут появляться, если браузер пользователя не будет отображать соответствующую картинку (рис. 23.91).
  7. Повторите шаги 1-6 для других слоев изображения.

Создание карты изображения с помощью инструмента

  1. Выберите один из инструментов: Rectangle Image Map (Прямоугольная карта изображения), Circle Image Map (Круглая карта изображения) или Polygon Image Map (Полигональная карта изображения), нажимая клавишу Р или комбинацию клавиш Shift+P.
  2. Нарисуйте прямоугольник или окружность вокруг какой-либо области в окне изображения. Нажав клавишу Shift, можно нарисовать квадрат. При нажатии клавиши Alt прямоугольник или окружность будут рисоваться относительно выбранного центра. Есть и другой способ. Постройте многоугольник: щелкнув в окне изображения, укажите начальную точку фигуры, затем щелчком мыши отмечайте каждую следующую точку, пока не окружите желаемую область ломаной. Дважды щелкните в любом месте, чтобы автоматически замкнуть выделение (рис. 23.92).
  3. Введите URL-адрес (включая префикс http://) на палитре Image Map.
  4. По желанию. Поле Target (Цель) на палитре Image Map (Карта ссылок) определяет, в какой HTML-фрейм будет загружено содержимое ссылки и какие HTML-фреймы будут сохранены (см. раздел «Связывание ссылок с ломтиками изображения»). Данное поле доступно только тогда, когда в поле URL введен адрес.

Рис. 23.92. Многоугольник, построенный с помощью инструмента Polygon Image Map

Рис. 23.93. Ввод точных размеров фигуры на панели опций

Рис. 23.94. Поля, определяющие размеры карты, на палитре Image Map

Рис. 23.95. Перемещение границы карты

  5. По желанию. В поле Alt (Альтернатива) на палитре Image Map введите слово или слова, которые появятся, если браузер пользователя не будет отображать соответствующую картинку.
  6. Повторите шаги 1-6, чтобы создать другие карты изображения.

Для того чтобы указать точные размеры прямоугольника или окружности, прежде чем нарисовать эти фигуры, на панели опций установите флажок Fixed Size (Фиксированный размер) и введите значения в поля Width (Ширина) и Height (Высота) - см. рис. 23.93.

Для того чтобы с большой точностью переместить или изменить размеры прямоугольника или окружности после того, как вы уже нарисовали эти фигуры, воспользуйтесь полями X и Y или W (Width - ширина) и Н (Height - высота) на палитре Image Map (рис. 23.94). Либо активизируйте инструмент Image Map Select (Выделение карты изображения) с помощью пиктограммы «й^, щелкните по одному из манипуляторов карты и переместите его (рис. 23.95).

Переход от карты изображения на основе слоя к карте, созданной при помощи инструмента

  1. Активизируйте инструмент Image Map Select (Выделение карты изображения) клавиши Р (комбинации клавиш Shift+P) и щелкните по карте, созданной на основе слоя, которую следует преобразовать.
  2. В меню палитры Image Map (Карта изображения) выберите пункт Promote Layer Based Image Map Area (Преобразовать область карты, созданной на основе слоя).

Как спрятать или показать карту изображения

Щелкните на панели инструментов по кнопке Image Map (Карта изображения) либо нажмите клавишу А, чтобы спрятать/показать карту (рис. 23.96) или воспользуйтесь командами View > Show > Image Maps (Вид > Показать > Карты изображения).

В программе ImageReady можно корректировать вид карты изображения (цвет, видимость линий и габаритной рамки). Для этого предназначено диалоговое окно (рис. 23.97), которое открывается при помощи команд Edit > Preferences > Image Maps (Правка > Установки > Карты изображения).

Выделение карты изображения

  1. Убедитесь, что карты изображения видны, и выберите инструмент Image Map Select (Выделение карты изображения), нажав клавишу Р или комбинацию клавиш Shift+P.

Рис. 23.96. Кнопка переключения режима видимости карты изображения на панели инструментов

Рис. 23.97. Корректировка вида карты изображения

  2. Щелкните по карте в окне изображения (нажав клавишу Shift, можно выделить несколько карт).

Удаление карты изображения

Выделите карту изображения и нажмите клавишу Enter или в меню палитры Image Map (Карта изображения) выберите пункт Delete Image Map Area (Удалить область карты изображения).

Выравнивание карт изображения, созданных с помощью инструментов, вдоль общей границы

Если выровнять карты изображения, созданные при помощи инструментов, вдоль общей границы или равномерно распределить их вдоль одной оси, то можно создать меньшие по размеру HTML-файлы, которые, соответственно, будут быстрее загружаться. Карты изображения, созданные на основе слоя, выровнять или равномерно распределить нельзя, так как их расположение связано со слоем.

  1. Активизируйте инструмент Image Map Select (Выделение карты изображения) клавиши Р (сочетания клавиш Shift+P). Нажав клавишу Shift, щелкните по картам, которые следует выровнять.
  2. Щелкните по одной из кнопок выравнивания на панели опций.

Равномерное распределение карт изображения, созданных при помощи инструментов, вдоль одной оси

  1. Активизируйте инструмент Image Map Select (Выделение карты изображения) с помощью клавиши Р (сочетания клавиш Shift+P). Нажав клавишу Shift, щелкните по картам, которые необходимо равномерно распределить.
  2. Щелкните по одной из шести кнопок распределения, расположенных на панели опций (рис. 23.98).

Оптимизация отдельного ломтика изображения

Если вы работаете с гибридным изображением, которое содержит элементы с четко определенными границами (например, текст или штриховой рисунок) и элементы с плавным переходом цвета, то постарайтесь создать отдельный ломтик для каждой зоны. Затем можно будет произвести различную оптимизацию ломтиков в зависимости от их типа. Например, показанный на рис. 23.99 элемент с плавным переходом цвета (рубанок) должен быть преобразован в формат JPEG, в то время как векторный элемент (горящая лампочка) - в формат GIF.

  1. Активизируйте инструмент Slice Select (Выделение ломтика), нажав клавишу К (комбинацию клавиш Shift+K).
  2. Щелкните по какому-либо ломтику.

Рис. 23.98. Кнопки распределения карт, расположенные на панели опций

Рис. 23.99. Гибридное изображение

Рис. 23.100. Копирование настроек оптимизации путем перетаскивания пиктограммы дроплета с палитры Optimize (внизу) на ломтик изображения (вверху)

  3. Выберите настройки оптимизации в соответствующей палитре. Для четко очерченных областей воспользуйтесь форматом GIF, а для областей с плавным переходом цвета - JPEG.

Если выбрать несколько ломтиков с различными настройками оптимизации, то в палитре Optimize (Оптимизация) будут отображаться только те настройки, которые у этих ломтиков совпадают. Однако при изменении доступных для модификации значений они будут применены ко всем выделенным ломтикам.

Если вы впоследствии решите, что следует применить однотипную оптимизацию ко всем ломтикам, то активизируйте инструмент Slice Select (Выделение ломтика), выполните команду меню Select > All Slices (Выделить > Все ломтики) и затем установите необходимые значения параметров на палитре Optimize (Оптимизация). Если выполнить команду Select > Deselect Slices (Выделить > Отменить выделение ломтиков), то палитра Optimize станет пустой.

Копирование настроек оптимизации от одного ломтика к другому

Предлагаемый способ копирования настроек оптимизации является довольно быстрым и эффективным.

  1. Активизируйте инструмент Slice Select (Выделение ломтика), нажав клавишу К или комбинацию клавиш Shift+K.
  2. Щелкните по ломтику, параметры оптимизации которого следует скопировать.
  3. Перетащите значок дроплета с палитры Optimize (Оптимизация) на любой невыделенный ломтик, в результате чего к нему будут применены настройки из палитры (рис. 23.100).

Связывание ломтиков

Если связать пользовательские ломтики, то они автоматически будут использовать одни и те же настройки оптимизации. Связанные ломтики в формате GIF будут также использовать одну таблицу цветов и один шаблон размытия, что поможет скрыть резкие переходы от одного фрагмента к другому.

  1. Активизируйте инструмент Slice Select (Выделение ломтика) с помощью клавиши К (комбинации клавиш Shift+K).
  2. Щелкните по какому-нибудь ломтику. Нажав клавишу Shift, можно выделить несколько ломтиков (рис. 23.101).
  3. Выполните команду Slices > Link Slices (Ломтики > Связать ломтики). Теперь метки связанных ломтиков будут иметь одинаковый цвет (рис. 23.102).

Для того чтобы к уже связанным ломтикам добавить еще один, выделите его, а также все связанные ломтики, а затем воспользуйтесь командой Slices > Linked Slices (Ломтики > Связанные ломтики).

Рис. 23.101. Выделение трех ломтиков

Рис. 23.102. Метки связанных ломтиков, окрашенные одним цветом

Разъединение ломтиков

Для того чтобы отсоединить один ломтик от совокупности связанных ломтиков, щелкните по нему мышью, предварительно активизировав инструмент Slice Select (Выделение ломтика), которому соответствует клавиша К (сочетание клавиш Shift+K), и выполните команду Slices > Unlink Slice (Ломтики > Отсоединить ломтик).

Чтобы отсоединить набор ломтиков, щелкните по одному элементу из этого набора с помощью инструмента Slice Select (Выделение ломтика) и воспользуйтесь командой Slices > Unlink Set (Ломтики > Отсоединить набор).

Если вы хотите разъединить все ломтики изображения, воспользуйтесь командой Slices > Unlink All (Ломтики > Отсоединить все).

Автоматически создаваемые программой ImageReady ломтики уже связаны между собой. Если отсоединить такой ломтик от остальных, то он превратится в пользовательский.

Прикрепление тега Alt к какому-либо ломтику или целому изображению

В старых версиях неграфических Web-браузеров (или в любых браузерах, в которых выключена опция Show Pictures (Отображать рисунки)) будет отображаться текст, но не графика. Чтобы в таких браузерах изображение появлялось в виде однотипного значка с текстом, Web-дизайнеры прикрепляют к каждому графическому объекту уникальный тег Alt (Альтернатива). Такие теги позволяют пользователям с ослабленным зрением работать с текстовыми

Рис. 23.103. Ввод текста в поле Alt

браузерами, которые озвучивают ссылки. Далее рассказано, как добавить тег Alt в программе ImageReady.

  1. Откройте палитру Slice (Ломтик). Если палитра не отображается в развернутом виде, то дважды щелкните по ее заголовку.
  2. По желанию. Щелкните мышью по ломтику, предварительно активизировав инструмент Slice Select (Выделение ломтика).
  3. В поле Туре палитры Slice введите слово или слова, которые при необходимости будут заменять изображение (рис. 23.103).

Даже если вместо изображения в окне браузера показывается текст (тег Alt), все URL-ссылки будут связывать пользователя с указанным сайтом.

Ролловеры

Теперь, когда вам уже известно кое-что о ломтиках, пришло время узнать и еще об одном виде «горячей» точки - ролло-вере. Ролловер представляет собой некое событие, которое происходит при щелчке мышью или перемещении курсора над какой-либо областью Web-страницы, содержащей встроенные варианты собственных модификаций.

Рис. 23.104. Добавление эффекта Drop Shadow (a) к изображению лампочки (б)

Рис. 23.105. Замена одного изображения другим

Рис. 23.106. Появление текста при наведении курсора на пиктограмму

Можно создать ролловеры трех основных типов:

  • изменение области изображения (например, изменение цвета или эффекта слоя) - см. рис. 23.104;
  • замена одного изображения другим (рис. 23.105);
  • появление текста или графического объекта в другой части окна браузера, когда указатель мыши наведен на кнопку, ключ.евое слово или значок (рис. 23.106).

Ролловеры - как бы «голос» Web-странички. Они определяют ее ключевые области, на которые пользователь должен навести указатель или щелкнуть мышью. С ними страничка становится более интересной.

Для того чтобы создать ролловер, необходимо сначала разделить изображение на ломтики. (Так что прочтите сначала разделы о разбиении изображения на ломтики - не жульничайте!) В программе ImageReady можно создать ролловер с помощью палитры Rollover (Ролловер) или путем отображения и скрытия слоев на палитре Layers (Слои). В ImageReady все, на что способен ролловер, - это показать или скрыть некоторые слои в соответствии со встроенными инструкциями. (Как создать ролловер с помощью эффекта слоя, рассказано в соответствующем разделе. А тому, что такое вторичный рол- • ловер и как его создать, посвящен раздел «Создание вторичного ролловера».)

Создание ролловера для ломтика

  1. Откройте изображение, содержащее ломтики, и отобразите палитру Slice (Ломтик).
  2. Активизируйте инструмент Slice Select (Выделение ломтиков) с помощью клавиши К (сочетания клавиш Shift+K) и щелкните по ломтику, для которого следует создать ролловер.
  3. Если элемент изображения, на основе которого должен быть создан ролловер, не имеет своего собственного слоя, воспользуйтесь командой Select > Create Selection from Slice (Выделить> Создать выделение из ломтика), а потом выполните команды Layers > New > Layer via Сору (Слои > Новый > Слой из копии) или нажмите комбинацию клавиш Ctrl+J. Если изображение, принадлежащее ломтику, уже находится на отдельном слое, то создайте дубликат слоя с помощью палитры Layers (Слои).
  4. Откройте вкладку Rollover (Ролловер). Миниатюра выделенного ломтика будет видна на палитре.
  5. В нижней части палитры щелкните по кнопке Create new rollover state (Создать новое состояние ролловера) - см. рис. 23.107. Копия выделенного ломтика появится на палитре в качестве новой миниатюры.
  6. Программа ImageReady по умолчанию автоматически связывает состояния курсора и кнопки мыши с миниатюрами ролловеров в такой последовательности: Over (Над), Down (Нажатие) и Click (Щелчок). Если же необходимо изменить эту последовательность, то из всплывающего меню, расположенного над миниатюрой нового ролловера, который вы создадите при выполнении последующих шагов, выберите состояние, которое будет инициировать ролловер (рис. 23.106):

Рис. 23.107. Выбор состояния курсора и кнопки мыши, инициирующего ролловер

Рис. 23.108. Инвертирование цвета изображения в состоянии Over

Рис. 23.109. Скрытие исходного слоя и показ дубликата на палитре Layers

  • Over - курсор находится над ломтиком, кнопка мыши не нажата;
  • Down - курсор находится над ломтиком, кнопка мыши нажата. Некоторые Web-дизайнеры любят выводить специальную картинку-при на-жатии кнопки мыши;
  • Click - щелчок кнопкой мыши по указанному ломтику (кнопка нажата и отпущена). При этом браузер попытается установить связь в сети, используя URL-адрес, прикрепленный к данному ломтику.
  7. Отредактируйте изображение на отдельном слое или на дубликате сдоя (см. шаг 3), чтобы оно как-то отличалось от исходного. Инвертируйте цвет слоя (рис. 23.108) или измените яркость с помощью команд Image > Adjustments О Invert (Изображение > Корректировки > Обратить), примените к слою текстурный или искажающий фильтр (см. раздел «Еще кое-что о ролловерах») или измените цвета и их насыщенность в слое. Также можно заменить изображение на совершенно другое или использовать новое изображение в качестве дополнения к уже существующему, расположенному в пределах ломтика. При этом изображение на исходном слое не изменится.
  8. На палитре Layers (Слои.) отобразите дубликат слоя и скройте исходный слой (рис. 23.109).
  9. Переключайте на палитре Rollover (Ролловер) состояние Normal и миниатюры ролловеров и наблюдайте за видом исходного изображения в основном окне. На палитре Rollover отображаются все изменения, происходящие на палитре Layers (Слои) по мере выбора миниатюр ролловеров. Чтобы картинка в окне предварительного просмотра была более достоверной, воспользуйтесь командой File > Preview in [браузер] (Файл > Предварительный просмотр в [браузер]) либо новой функцией предварительного просмотра программы ImageReady (см. раздел «Предварительный просмотр роллове-ра в программе ImageReady»),

При редактировании слоя всегда помните о том, какая миниатюра выбрана на палитре Rollover. Все миниатюры должны содержать различные виды изображения.

Общее количество слоев изображения остается прежним независимо от типа ролло-вера, с которым вы работаете. Если создать слой для одного действия, то он будет автоматически скопирован и для других. Для того чтобы миниатюры менялись в зависимости от текущего состояния, необходимо прятать или показывать различные слои и эффекты слоя.

Можно создать отдельное изображение для каждого состояния ролловера (например, один значок для режима Over (Над) и другой - для режима Click (Щелчок)). Просто не забудьте создать отдельный слой или эффект слоя для каждого состояния.

Для того чтобы выбрать размер миниатюры, отображаемой на палитре Rollover (Ролловер), дважды щелкните по серому фону палитры (или выберите команду Palette Options (Опции палитры) в меню палитры Rollover). Крупные миниатюры легче рассматривать. У палитр Animation (Анимация) или Slice (Ломтик) свои собственные размеры миниатюр.

Для того чтобы создать ролловер, в котором новое изображение добавляется к уже существующему, создайте новую картинку на скопированном или дополнительном слое. Далее убедитесь, что ее размеры и местоположение сочетаются с исходным изображением (рис. 23.110 и 23.111). В этом случае исходный слой будет всегда виден.

Рис. 23.110. Изображение в состоянии золловора Normal

Рис. 23.111. То же изображение в состоянии Over. Злой с нарисованным от руки эффектом вешнего свечения виден под слоем с лампочкой

Рис. 23.112.Исходная кнопка

Рис. 23.113. Кнопка после применения фильтра Radial Blur

Рис. 23.114. Кнопка после применения фильтра Pinch

Еще кое-что о ролловерах

Предлагаем вам использовать следующие приемы при редактировании скопированного слоя (см. шаг 7 раздела «Создание ролловера для ломтика»).

Для создания эффекта расширения/сжатия изображения с помощью ролловера выполните масштабирование картинки на скопированном слое, воспользовавшись командами Edit > Transform > Scale (Правка> Трансформировать > Масштабирование) или Filter => Blur > Radial Blur (Фильтр > Размытие > Радиальное). В результате изображение будет растянуто (рис. 23.112 и 23.113). А при выполнении команд Filter > Distort > Pinch (Фильтр > Искажение > Дисторсия) (с отрицательным значением параметра Amount (Количество)) изображение будет выпячено (рис. 23.114).

Для того чтобы кнопка или область изображения казались перевернутыми, воспользуйтесь командами Edit > Transform > Flip Horizontal (Правка > Трансформировать > Перевернуть вдоль горизонтали) или Flip Vertically (Перевернуть вдоль вертикали) - см. рис. 23.105.

Создание ролловера с использованием эффекта слоя

Эффекты слоя имеют одно важное преимущество: при их использовании вам не придется копировать слой, чтобы достичь видимой разницы между различными состояниями ролловера, так как разные эффекты слоя могут быть применены (или выключены) по отношению к одному и тому же слою изображения.

  1. Активизируйте инструмент Slice Select (Выделение ломтика), которому соответствует пиктограмма и щелкните по какому-либо ломтику изображения.
  2. В нижней части палитры Rollover (Рол-ловер) щелкните по кнопке Create new rollover state (Создать новое состояние ролловера).
  3. Из всплывающего меню выберите состояние ролловера для миниатюры нового ролловера.
  4. Откройте палитру Layers (Слои).
  5. Выберите слой, на котором имеются прозрачные области (слой bulb на рис. 23.115).
  6. Выберите эффект из всплывающего меню Add layer effects (Добавить эффект слоя), вызываемого при помощи пиктограммы .щ, расположенной в нижней части палитры Layers (Слои). Попробуйте применить эффект Inner Shadow (Внутренняя тень), чтобы изменить цвет вдоль границы изображения, или Outer Glow (Внешнее свечение), чтобы изменить цвет области, расположенной вокруг изображения (рис. 23.116 и 23.117).
  7. Теперь в палитре Layer Options (Опции слоя) будут отображаться параметры того эффекта, который был только что выбран. Для того чтобы усилить эффект, увеличьте значения в полях Size (Размер), Distance (Расстояние), Depth (Глубина) или Intensity (Интенсивность). Если вы хотите использовать эффект Bevel and Emboss (Скос и рельеф) и тем самым придать изображению объемный вид, отметьте на соответствующей палитре противоположное значение опции (например, Up (Вверх) вместо Down (Вниз)), чтобы изменить направление освещения на противоположное и имитировать вогнутость того варианта изображения, который связан с ролловером (см. раздел

Рис. 23.115. Выбор слоя на палитре Layers

Рис. 23.116. Применение к слою эффекта Outer Glow

а)

б)

Рис. 23.117. Исходное изображение (а) и изображение после применения эффекта Outer Glow, предназначенное для состояния ролловера Over (б)

Рис. 23.118. Эффекты слоя ролловера

«Применение эффекта Bevel and Emboss» главы 14). Воспользуйтесь эффектом Color Fill (Заливка цветом), установив низкое значение непрозрачности, что позволит оттенить изображение и усилить эффект вогнутости.

  8. Предварительно просмотрите ролловер (см. раздел «Предварительный просмотр ролловера в ImageReady» этой главы).

В палитре Styles (Стили) программы ImageReady содержатся эффекты слоя или их сочетания, которые можно использовать (см. раздел «Применение стиля к слою» этой главы).

Эффект слоя можно увидеть на палитре Layers (Слои) и на изображении только тогда, когда выделена соответствующая миниатюра состояния ролловера (рис. 23.118).

Как удалить эффект (эффекты) слоя, рассказано в разделе «Эффекты слоя» главы 14.

Предварительный просмотр ролловера в ImageReady

Теперь можно предварительно просмотреть ролловер в программе ImageReady.

  1. Щелкните по кнопке Rollover Preview (Предварительный просмотр ролловера) на панели инструментов или нажмите клавишу Y. Альтернативный вариант: на палитре Rollover (Ролловер) щелкните по кнопке Preview (Предварительный просмотр).
  2. Наведите указатель на изображение, чтобы увидеть действие ролловера. Для того чтобы прервать выполнение этого действия, снова щелкните по кнопке Play (Проиграть) или Preview.

Предварительный просмотр ролловера в Web-браузере

  1. Сохраните файл в программе ImageReady.
  2. В подменю File > Preview (Файл > Предварительный просмотр) выберите браузер, установленный на вашем компьютере. Второй способ: щелкните по кнопке Preview in Default Browser (Предварительный просмотр в браузере по умолчанию), расположенной на панели инструментов. Третий способ: нажмите комбинацию клавиш Ctrl+ Alt+T.
  3. В браузере проведите курсор поверх области изображения, содержащей рол-ловер (состояние Over (Над)), нажмите кнопку мыши (состояние Down (Нажатие)) или щелкните мышью по этой области (состояние Click (Щелчок)).

Можно проверить правильность URL-адреса, даже если вы в данный момент не подключены к Internet. Наведите курсор на ломтик, содержащий ссылку, и тогда соответствующий URL-адрес появится в нижней части окна браузера.

Невозможно протестировать состояние Down в ранних (до 4.0) версиях браузеров Navigator или Explorer. В этих версиях по нажатию кнопки мыши открывается контекстное меню.

Рис. 23.119. Когда выбрана миниатюра состояния Over

Рис. 23.120.... слой с изображением котелка (bowler Irg) становится видимым

Создание вторичного ролловера

При использовании вторичных ролловеров (secondary rollover), когда пользователь помещает курсор над ключевым словом, изображением или пиктограммой, появляется дополнительный текст или дополнительное изображение. Если же отодвинуть курсор от перечисленных элементов, то дополнительная информация исчезнет. С помощью вторичных ролловеров можно снизить визуальную нагрузку на пользователя, так как уменьшается количество информации, которая изначально появляется на Web-страничке (в виде текста или изображений).

  1. Выберите инструмент Slice (Ломтик), нажав клавишу К или сочетание клавиш Shift+K.
  2. Нарисуйте новый ломтик в изображении, который станет состоянием Normal (Нормальный) для ролловера. Новая миниатюра появится и на палитре Slice (Ломтик), и на палитре Rollover (Ролловер).
  3. В нижней части палитры Rollover щелкните по кнопке ^^щ Create new rollover state (Создать новое состояние ролловера). Копия текущего ломтика появится в качестве новой миниатюры на палитре.
  4. Из всплывающего меню, расположенного над этой миниатюрой, выберите состояние Over (Над) - см. рис. 23.119.
  5. Создайте новый слой, а затем дополнительный текст или изображение в этом слое (рис. 23.120). Альтернативный вариант: с помощью команд Сору (Копировать) и Paste (Вставить) или простым перетаскиванием создайте новый слой, а затем отредактируйте изображение в этом слое.
  6. С помощью инструмента Move (Перемещение) переместите слой туда, где он должен располагаться на изображении (рис. 23.121). В этом примере создан столбец из маленьких изображений, каждое из которых представлено отдельным ломтиком. Увеличенные варианты изображений использованы для создания вторичных ролловеров.
  7. Щелкните по миниатюре состояния Normal (Нормальный) и убедитесь, что в этом состоянии новый слой спрятан. Ненароком не спрячьте слой, содержащий исходную область, для которой был создан ролловер (рис. 23.122 и 23.123).

Создание кнопки для Web-страницы

  1. На палитре Rollover (Ролловер) щелкните по миниатюре состояния Normal (Нормальный).
  2. Выберите инструмент для построения фигуры: Rectangle (Прямоугольник), Rounded Rectangle (Прямоугольник с закругленными углами) или Ellipse (Эллипс). Поочередно выбирать эти инструменты можно с помощью клавиши U или комбинации клавиш Shift+U.
  3. На панели опций щелкните по кнопке Create New Shape Layer (Создать слой фигуры).
  4. Выберите основной цвет, а затем перетащите указатель курсора по диагонали, чтобы нарисовать фигуру (рис. 23.124). Она автоматически появится на своем собственном слое.

Рис. 23.121. Компоновка изображений

Рис. 23.122. Скрытие слоя (bowler Irg) после выбора миниатюры состояния Normal

Рис. 23.123. Скрытие изображения котелка в состоянии Normal

Рис. 23.124 Новая фигура

Рис. 23.125. Стиль button-up и результат его применения к фигуре

  5. По желанию. Для того чтобы применить заранее определенный эффект слоя к кнопке, откройте палитру Styles (Стили) и перетащите имя стиля или образец с палитры на слой с кнопкой на палитре Layers (Слои) или на фигуру в окне изображения (рис. 23.125). Можно сделать и иначе: выделите фигуру и щелкните по имени стиля на соответствующей палитре.

Если применить к слою готовый эффект слоя, который уже включает в себя состояния ролловера, то фигура автоматически будет разделена на ломтики,

  6. С помощью инструмента Slice (Ломтик) прочертите границы ломтика вокруг новой кнопки, находящейся в состоянии Normal (Нормальный). Миниатюра нового ломтика появится и на палитре Slice (Ломтик), и на палитре Rollover (Ролловер).
  7. Повторите шаги 3-9 раздела «Создание ролловера для ломтика изображения», чтобы создать ролловер для кнопки (рис. 23.126).

Рис. 23.126. Использование стиля button-down для ролловера в состоянии Over

GIF-анимация

При GIF-анимации набор кадров изображения воспроизводится в порядке, определенном пользователем. Для Web-страницы можно создать различные анимационные эффекты: сделать так, чтобы текст или графика перемещались, постепенно исчезали или появлялись, либо изменялись другим способом.

Для подготовки анимации в программе ImageReady необходимо создать множество кадров изображения с помощью палитры Animation (Анимация), показанной на рис. 23.127. Затем можно редактировать отдельные слои каждого кадра с помощью палитры Layers (Слои), причем у каждого кадра будет собственная уникальная совокупность установок на палитре Layers. И наконец, надо сохранить последовательность кадров в виде одного GIF-файла — теперь анимация готова для просмотра в интерактивном режиме.

В этой книге рассказывается о создании двух основных эффектов анимации: перемещении элемента слоя и его постепенном исчезновении или появлении. Как только вы освоите основы, то сможете приступить к созданию более сложных анимационных проектов.

Перемещение элемента изображения с помощью анимации

Создадим анимационный эффект для какого-либо изображения.

  1. Откройте или создайте изображение, содержащее фоновый слой и прозрачный слой с рисунком какого-либо предмета (рис. 23.128). Как это сделать, рассказано в разделе «Маскирование фигур с помощью команды Extract» главы 5 и разделах, посвященных различным методам стирания изображения, в конце главы 12.

Рис. 23.127. Палитра Animation

Рис. 23.128. Слои изображения на вкладке Layers

Рис. 23.129. Перемещение элемента слоя к краю основного окна

Рис. 23.130. Перетаскивание элемента изображения к другому краю основного окна

Рис. 23.131. Исходный (начальный) и скопированный (последний) кадры анимации

  2. Откройте палитру Animation (Анимация), щелкнув по вкладке Animation (Анимация) или выполнив команду Window > Show Animation (Окно > Показать палитру Animation).
  3. Выберите слой на палитре Layers (Слои).
  4. С помощью инструмента Move (Перемещение) перетащите элемент изображения к краю основного окна (рис. 23.129). Соответствующая миниатюра на палитре Animation будет обновлена, чтобы отобразить новое положение элемента.
  5. В нижней части палитры Animation щелкните по кнопке Duplicate current frame (Дублировать текущий кадр). Скопированный кадр будет выделен.
  6. Слой, выбранный на шаге 3, должен оставаться выделенным.
  7. С помощью инструмента Move (клавиша V) перетащите элемент слоя на другую сторону основного окна (рис. 23.130). Текущая миниатюра на палитре Animation будет соответствующим образом обновлена (рис. 23.131). Оставьте этот слой выделенным!
  8. На палитре Animation щелкните по кнопке Tween (Промежуточные кадры) для построения промежуточных кадров между уже выбранными.
  9. В диалоговом окне Tween (Промежуточные кадры) поставьте переключатель Layers (Слои) в одно из следующих положений:
  • All Layers (Все слои), чтобы скопировать точки со всех слоев в новые кадры - даже тех слоев, которые не были изменены (рис. 23.132). Эта опция также позволит запомнить изменения, произведенные одновременно в двух и более слоях;
  • Selected Layer (Выделенный слой), чтобы скопировать точки только выделенного слоя в новые кадры. Все другие слои будут спрятаны.

Затем установите в группе Parameters (Параметры) флажки тех параметров, которые будут изменяться в промежуточных кадрах: Position (Расположение), Opacity (Непрозрачность) и/или Effects (Эффекты) (подробнее об эффектах см. раздел «Эффекты слоя» главы 14).

Из всплывающего меню Tween with (Диапазон промежуточных кадров) выберите режим Previous Frame (Добавление промежуточных кадров между выделенным кадром и предыдущим).

Если до открытия диалогового окна Tween (Промежуточные кадры) было выделено несколько кадров, то во всплывающем меню Tween with (Диапазон промежуточных кадров) будет доступна только опция Selection (Добавление промежуточных кадров между выделенными).

Рис. 23.132. Диалоговое окно Tween

Другие опции анимации

Нажав клавишу Shift и щелкая мышью, можно выделить несколько кадров. Перетащите один или группу кадров на нужное место.

Для того чтобы разместить каждый кадр в слое, выберите из меню палитры Animation (Анимация) пункт Flatten Frames Into Layers (Поместить кадры в слои). Существовавшие до этого слои не будут удалены.

С помощью команды Revert Frames (Обратный порядок кадров) из меню палитры Animation можно поменять последовательность воспроизведения кадров. Эта опция эквивалента воспроизведению анимации в обратном порядке.

Рис. 23.133. Палитра Animation после добавления промежуточных кадров

Повторное создание промежуточных кадров

Для того чтобы повторить операцию создания промежуточных кадров, выделите все ранее созданные промежуточные кадры, щелкая мышью при нажатой клавише Shift, и перетащите их на кнопку Delete (Удалить). Отредактируйте один из двух оставшихся кадров, а затем снова примените команду Tween (Промежуточные кадры).

Далее укажите в поле Frames to Add (Добавить кадры) количество кадров, которое будет добавлено (от 1 до 100). Чем выше это значение, тем более плавной (без разрывов) будет анимация, но размер файла и время его загрузки увеличится.

  10. Щелкните по кнопке ОК (рис. 23.133). Теперь можно предварительно просмотреть анимацию (см. раздел «Предварительный просмотр анимации»). При воспроизведении элемент слоя будет плавно перемещаться от одного края основного окна к другому.

Можно использовать текстовый слой при анимации, причем его даже не придется преобразовывать в растровое представление. Можно создать эффект постепенного исчезновения или появления, а также перемещения текста вдоль окна изображения либо использовать его для других эффектов анимации.

Если необходимо, чтобы загрузка и воспроизведение анимации происходили быстро, то используйте маленькие размеры кадров (примерно 200x200 пикселов или меньше).

Постепенное исчезновение или появление картинки

Если вы хотите, чтобы картинка исчезала или появлялась с одновременным перемещением по Web-странице или без него, необходимо отрегулировать непрозрачность изображения вместе с корректировкой его расположения или без этого. Следуйте инструкциям, которые изложены в разделе «Перемещение элемента изображения с помощью анимации», но при выполнении шага 4 выберите начальное значение непрозрачности слоя (рис. 23.134). Затем при выполнении шага 7 выберите конечное значение непрозрачности (рис. 23.135). Убедитесь, что установлен флажок Opacity (Непрозрачность) в диалоговом окне Tween (Промежуточные кадры) - см. рис. 23.136.

Удаление кадров из анимации

Для того чтобы удалить кадр, щелкните по нему, затем выполните команду Delete Frame (Удалить кадр) в меню палитры Animation (Анимация), либо перетащите кадр на кнопку Delete (Удалить), расположенную на палитре (это действие может быть отменено). Если вы хотите удалить все кадры анимации, за исключением первого, в меню палитры Animation воспользуйтесь командой Delete Animation (Удалить анимацию) и щелкните по кнопке Delete (Удалить).

Рис. 23.134. Установка значения в поле Opacity для первого кадра анимации

Рис. 23.135. Установка значения в поле Opacity для второго кадра анимации

Рис. 23.136. После построения промежуточных кадров рубанок перемещается влево, и постепенно появляется слово «Plane»

Рис. 23.137. Опции воспроизведения анимации

Не переходите к другой программе и не открывайте ее, а также-не выбирайте команду Preview in [browser] (Предварительный просмотр в [браузер]) во время воспроизведения анимации. Дело в том, что воспроизведение будет продолжаться в фоновом режиме и отнимать время у того приложения, в которое вы перешли.

Выбор параметров воспроизведения анимации

Из всплывающего меню, расположенного в нижнем левом углу палитры Animation (Анимация), выберите режим воспроизведения, указывающий, как будет воспроизводиться цнимация: Once (Однократно) или Forever (Непрерывно в цикле) -см. рис. 23.137. Либо включите опцию Other (Иначе), чтобы указать определенное количество воспроизведений анимации, а затем щелкните по кнопке ОК. Старайтесь не создавать анимацию, воспроизводимую до бесконечности - это может не понравиться человеку, просматривающему Web-страницу.

Чтобы определить длительность показа отдельного выделенного кадра в процессе воспроизведения, выберите значение времени задержки (delay value) из всплывающего меню Select frame delay time (Выбрать время задержки кадра), расположенного под кадром на палитре Animation (Анимация) - см. рис. 23.137. Для каждого кадра может быть установлено свое время задержки. Опция No delay (Без задержки) эквивалентна нулевой задержке. Также можно выбрать опцию Other (Другое) и указать время задержки (от 0 до 240 сек), а затем щелкнуть по кнопке ОК.

Настройки, касающиеся цикличности и времени задержки, будут сохранены вместе с файлом и станут управлять воспроизведением анимации при просмотре Web-страницы с помощью браузера.

Параметры, которые можно изменять при создании промежуточных кадров

В анимацию можно включить изменение расположения элемента слоя, изменение прозрачности слоя либо переход от одного эффекта слоя к другому (за исключением эффекта Gradient/Pattern (Градиент/Узор), который нельзя использовать в сочетании с командой Tween (Промежуточные кадры)). Либо можно просто создавать промежуточные кадры между моментами включения и выключения эффекта слоя (эффекты слоя рассмотрены в разделе «Эффекты слоя» главы 14). Так как все эти преобразования задаются с помощью палитры Layers (Слои), то они никак не влияют на настоящие точки слоя. (Анимационный эффект, рассмотренный далее в разделе «Анимация покачивания предметов», влияет на пикселы слоя.)

Предварительный просмотр анимации

Осуществим предварительный просмотр анимации.

  1. В основном окне выберите вкладку Original (Исходное изображение) или Optimized (Оптимизированное изображение).
  2. Если первый кадр не выделен, то в нижней части палитры Animation (Анимация) щелкните по кнопке Select first frame (Выделить первый кадр) - см. рис. 23.138.

Рис. 23.138. Кнопки управления воспроизведением на палитре Animation

Рис. 23.139. Дублирование кадра анимации

  3. Щелкните по кнопке Play (Проиграть) -см. рис. 23.138. Анимация будет воспроизводиться чуть медленнее, чем должна. (Предварительный просмотр в программе ImageReady происходит медленнее, чем в браузере.)
  4. Щелкните по кнопке Stop (Остановить), которая имеет вид квадрата, чтобы приостановить воспроизведение (рис. 23.138).
  5. Сохраните файл, затем щелкните по кнопке Default Browser (Предварительный просмотр в браузере по умолчанию), расположенной на панели инструментов. Щелкните по кнопке Back (Назад), чтобы вернуться в программу ImageReady, когда просмотр будет закончен. Если анимация не воспроизводится в браузере, следуйте инструкциям, которые даны в разделах «Кадрирование изображения» и «Уменьшение размера изображения».

Анимация покачивания предметов

Далее рассмотрено, как сделать так, чтобы элемент слоя покачивался из стороны в сторону. Этот тип анимации затрагивает точки слоя и копируется во все существующие кадры. Необходимо создавать дубликат слоя для каждого этапа движения.

Создадим анимацию, в которой объект будет перемещаться в определенном направлении и обратно.

  1. Откройте изображение и палитру Animation (Анимация).
  2. В нижней части палитры Animation щелкните по кнопке Duplicate current frame (Дублировать текущий кадр) - см. рис. 23.139. Теперь будет выделен дубликат кадра.
  3. На палитре Animation щелкните по кнопке Tween (Промежуточные кадры), а затем поставьте переключатель Layers (Слои) в положение All Layers (Все слой), введите число кадров в поле Frames to Add (Добавить кадры), чтобы создать анимацию, и щелкните по кнопке ОК.
  4. Щелкните по кадру, в котором должно начаться покачивание.
  5. На палитре Layers (Слои) создайте дубликат того слоя, изображение которого будет двигаться.
  6. Отредактируйте дубликат слоя (например, чуть поверните, добавьте немного мазков кистью, подкорректируйте цвет или измените его другим способом). Спрячьте исходный слой, чтобы увидеть внесенные изменения. На рис. 23.140 виден отредактированный слой receiver left tilt, в то время как исходный слой receiver спрятан. Трубка телефона наклонена влево (рис. 23.140). Изменения отразятся в выделенном кадре на палитре Animation.
  7. Щелкните по следующему кадру (либо по кнопке Next Frame (Следующий кадр) в нижней части палитры Layers (Слои)). Сделайте исходный слой receiver видимым и спрячьте его отредактированный дубликат receiver left tilt (рис. 23.141).
  8. Щелкните по следующему кадру. Теперь покажите отредактированный дубликат слоя и спрячьте исходный слой.
  9. Так попеременно показывайте/прячьте слои для оставшихся кадров анимации.

Рис. 23.140. Телефон с наклоненной влево трубкой и слои изображения на палитре Layers

Рис. 23.141. Телефон в исходном положении и слои изображения на палитре Layers

Рис. 23.142. Очередность кадров анимации

Рис. 23.143. Три слоя на палитре Layers

Дополнительное редактирование

Если необходимо еще раз изменить исходный элемент слоя, то создайте еще один дубликат и отредактируйте его. Затем в одном кадре анимации сделайте видимым исходный слой и спрячьте дубликаты. В следующем кадре отобразите первый дубликат слоя и спрячьте второй и исходный слои. В третьем кадре покажите второй дубликат и спрячьте исходный слой вместе с первым дубликатом и т.д. Приведенные рисунки иллюстрируют эти действия. На рис. 23.142а виден слой receiver left tilt (телефонная трубка наклонена влево), на рис. 23.142б виден слой receiver (телефонная трубка расположена горизонтально) и, наконец, на рис. 23.142в виден слой receiver right tilt (телефонная трубка наклонена вправо). Слои, используемые в анимации, показаны на рис. 23.143.

Редактирование анимации

Если после создания анимации вы отредактируете пикселы слоя (например, раскрасите, откорректируете цвет и яркость или каким-либо образом преобразуете слой), то внесенные изменения автоматически будут применены ко всем кадрам анимации, в которых виден данный слой.

Если же вы спрячете или покажете слой, измените расположение элемента слоя, непрозрачность или режим смешивания либо измените эффект слоя в одном кадре, эти изменения не будут скопированы в другие кадры. Дело в том, что такие изменения производятся с помощью палитры Layers (Слои) и не затрагивают реально существующих точек слоя. Если же необходимо внести перечисленные изменения во все кадры анимации, то в меню палитры Animation воспользуйтесь командой Match Layer Across Frames (Привести в соответствие слои во всех кадрах).

Так как некоторые виды изменений, вносимых с помощью палитры Layers (Слои), могут быть выполнены при помощи установки в диалоговом окне Tween (Промежуточные кадры) флажков Position (Расположение), Opacity (Непрозрачность) и Effects (Эффекты), то в любой момент можно изменять значения перечисленных параметров для отдельных кадров, не затрагивая остальные.

Команда Match Layer Across Frames удаляет все изменения, которые были внесены в слой при создании промежуточных кадров. Если это недопустимо, редактируйте кадры анимации при помощи методов, описанных в разделе «Применение второго анимационного эффекта к существующей анимации».

Воспроизведение анимации в обратном порядке до первого кадра

В этом разделе рассказывается о том, как дополнить анимацию ею же самой или ее частью, но воспроизводимой в обратной последовательности. Во время воспроизведения анимация будет плавно проигрываться в прямом, а затем обратном направлении.

  1. Выделите последний кадр на палитре Animation (Анимация).
  2. Щелкните по кнопке Tween (Промежуточные кадры), расположенной на этой же палитре.
  3. Поставьте переключатель Layers (Слои) в положение All Layers (Все слои), установите флажки для всех параметров, выберите пункт First Frame (Первый кадр) в меню Tween with (Диапазон промежуточных кадров) и введите соответствующее значение в поле Frame to Add (Добавить кадры).
  4. Щелкните по кнопке ОК.

Применение второго анимационного эффекта к существующей анимации

Этот раздел адресован тем читателям, кто уже создал анимационный эффект и теперь решил добавить еще один эффект для другого слоя.

  1. Выберите или создайте слой, к которому следует применить анимационный эффект.
  2. На палитре Animation (Анимация) щелкните по тому кадру, с которого будет начинаться эффект анимации (рис. 23.144).
  3. Расположите изображение слоя желаемым образом в кадре, соответствующем началу анимационной последовательности. При необходимости отрегулируйте его непрозрачность или примените какие-либо эффекты (рис. 23.145).
  4. Щелкните по конечному кадру анимационной последовательности.
  5. В конечном кадре измените положение изображения слоя или значение непрозрачности, удалите или, наоборот, примените эффекты слоя. Не снимайте выделение со слоя!
  6. Если при выполнении шагов 2-4 выбраны первый и последний кадры анимации соответственно, то выполните команду Select All Frames (Выделить все кадры) из меню палитры Animation. Если же при выполнении этих шагов первый и последний кадры анимации выбраны не были, то щелкните по кадру (для шага 2), затем, нажав клавишу Shift, щелкните по кадру, который будет последним. Теперь выделен некоторый ряд кадров. 7. Щелкните по кнопке Tween (Промежуточные кадры), расположенной на палитре Animation, чтобы сразу же создать промежуточные кадры. Второй способ: в меню палитры Animation выполните команду Tween. Установите переключатель Layers (Слои) в положение All Layers (Все слои), установите флажки для тех параметров, которые только что изменили (Position (Расположение), Opacity (Непрозрачность) или Effects (Эффекты)), а затем щелкните по кнопке ОК. На рис. 23.146 показаны начальный кадр (эффект Outer Glow, непрозрачность 4%), промежуточный и последний кадр (эффект Outer Glow, непрозрачность 100%) второго эффекта анимации.

Рис. 23.144. Первая анимация

Рис. 23.145. Результат применения к слою iogо команды Invert и эффекта Outer Glow

Рис. 23.146. Результат добавления второго эффекта анимации

Второй эффект анимации будет постепенно «проявляться» в кадрах, выбранных на таге 6. Существовавшие до этого анимационные эффекты будут сохранены.

Уменьшение размера изображения

Если созданная анимация слишком велика для воспроизведения в браузере либо слишком долго загружается на Web-страничку, то можно выполнить следующие действия: уменьшить размер файла с помощью команды Image Size (Размер изображения) в меню Image (Изображение) или обрезать изображение. Независимо от того, какой способ выбран, убедитесь, что работаете с копией файла (чтобы создать ее, воспользуйтесь командой File > Save As (Файл > Сохранить как)).

  1. Выполните команду Image > Image Size (Изображение > Размер изображения).
  2. Уменьшите значения в полях Width (Ширина) и Height (Высота) до 200x200 пикселов (или 150x300) либо итого меньше (рис. 23.147).
  3. Убедитесь, что в меню Quality (Качество) выбран вариант интерполяции Smooth (Bicubic) (Гладкая (Бикубическая)).
  4. Щелкните по кнопке ОК.

Рис. 23.147. Диалоговое окно Image Size в программе ImageReady

Рис. 23.148. Кнопки управления воспроизведением на палитре A nimation

Рис. 23.149. Последовательность кадров на палитре Animation

Рис. 23.150. Панель опций инструмента Crop

Обрезка изображения

  1. Если при анимации изображение движется от одного края основного окна к другому, то на палитре Animation (Анимация) щелкните по кадру где-то в середине анимационной последовательности (рис. 23.148 и 23.149). Если изображение остается в центре основного окна, то щелкните по любому кадру.
  2. Откройте палитру Info (Информация) и перетащите ее, чтобы отделить от группы палитр.
  3. Выберите инструмент Crop (Кадриро-вать), нажав клавишу С, или щелкните по пиктограмме %|j.
  4. На панели опций поставьте переключатель Cropped Area (Отсекаемая область) в одно из положений - см. рис. 23.150:
    • Delete (Удалить) - чтобы удалить точки, расположенные за границами рамки;
    • Hide (Спрятать) - чтобы сохранить эти точки. Воспользуйтесь данной опцией, если элемент слоя движется от одного края изображения к другому либо элемент фонового слоя движется позади меньшего объекта слоя, находящегося на переднем плане. При воспроизведении анимации спрятанные области будут отображаться за пределами границ рамки кадрирования. Позднее с помощью инструмента Move (Перемещение) можно вручную скорректировать расположение слоя относительно границ рамки кадрирования.
  5. Перетащите курсор инструмента Crop (Кадрировать) по диагонали, чтобы указать меньшие размеры изображения (рис. 23.151), наблюдая за значениями W и Н (размеры рамки для обрезанной области) на панели Info (Информация). Если необходимо, переместите границы созданной рамки, чтобы достичь желаемого размера. Уменьшите размеры примерно до 200x200 пикселов (или 150x300 пикселов) или еще меньше (см. ниже первый совет).
  6. Чтобы применить эффект кадрирования, дважды щелкните мышью внутри рамки или нажмите клавишу Enter.
  7. Предварительно просмотрите анимацию (как это сделать, написано в разделе «Предварительный просмотр анимации») - см. рис. 23.152.

200x200 (или 150x300) пикселов - это рекомендуемый размер рамки кадрирования. Если необходимо использовать другие размеры, то в палитре History (История) щелкните по элементу состояния, предшествующему применению команды Crop (Кадриро-вать). Каждый раз просматривайте полученный результат с помощью команды File > Preview in [browser] (Файл > Предварительный просмотр в [браузер]) программы ImageReady. А чтобы увидеть реальное воспроизведение анимации, загрузите ее на Web-страничку, чтобы потом просмотреть через Internet.

Скорость воспроизведения анимации частично определяется скоростью центрального процессора в компьютере пользователя, версией используемого браузера и объемом оперативной памяти, в данный момент выделенной для него.

Рис. 23.151. Рамка кадрирования

Рис 23.152. Постепенное исчезновение изображения за границами рамки кадрирования

Другие способы сокращения размеров файлов

В дополнение к кадрированию изображения можно также уменьшить размер файла, сократив количество слоев и кадров в анимационной последовательности или уменьшив количество элементов в таблице цветов. Помните, что чем меньше размер файла, тем быстрее он загружается.

Рис. 23.153. Создание новой миниатюры ролловера (стиль button-up заменен на button-down)

Рис. 23.154. Добавление кадров в анимационную последовательность

Рис. 23.155. Выделение миниатюры ролловера в состоянии Normal

Рис. 23.156. Первый кадр

Ролловер, инициирующий анимацию

Можно создать вторичный ролловер, который будет инициировать анимационный эффект, и тем самым сделает Web-страничку более живой и интересной. Для этого вам потребуются все ваши навыки по созданию ролловеров и анимации.

  1. На палитре Rollover (Ролловер) создайте новую миниатюру для выделенного ломтика изображения, желательно в состоянии Over (Над) (как это сделать, написано в разделе «Создание ролловера для ломтика изображения») - см. рис. 23.153.
  2. Перетащите вкладку Animation (Анимация) и расположите ее отдельно от других палитр.
  3. Выделите миниатюру нового ролловера на палитре Rollover (но не состояние Normal (Нормальный)), щелкните по палитре Animation и создайте кадры и события анимации (см. раздел «Перемещение элемента изображения с помощью анимации») - рис. 23.154.
  4. Щелкните по миниатюре ролловера в состоянии Normal (рис. 23.155). Все кадры, за исключением первого, временно исчезнут с палитры Animation (рис. 23.156).
  5. Сохраните файл и просмотрите его с помощью команды File > Preview in [browser] (Файл > Предварительный просмотр в [браузер]).

Создание анимации с искажением текста

Новая функция искажения текста, которая позволяет применить 14 различных эффектов искажения, упрощает создание анимации текста.

  1. Откройте или создайте изображение, содержащее фоновый слой и прозрачный слой с редактируемым текстом.
  2. В палитре Layers (Слои) выберите текстовый слой (рис. 23.157).
  3. Откройте палитру Animation (Анимация), выделите первый кадр, а затем щелкните по кнопке Duplicate current frame (Дублировать текущий кадр).
  4. На панели опций инструмента Туре (Текст) щелкните по кнопке Warp (Деформировать) - см. рис. 23.158.
  5. В диалоговом окне Warp Text (Деформировать текст) произведите необходимые настройки.

Из всплывающего меню Style (Стиль) выберите стиль деформации (рис. 23.159). Включите опцию Horizontal (Горизонтально) или Vertical (Вертикально), чтобы указать направление искажения текста. Затем с помощью ползунка или полей Bend (Изгиб), Horizontal Distortion (Искажение по горизонтали) и Vertical Distortion (Искажение по вертикали) установите необходимые значения для получения соответствующего эффекта. В главном окне документа можно увидеть результат.

  6. Щелкните по кнопке ОК (рис. 23.160).

Рис. 23.157. Выделение текстового слоя на палитре Layers

Рис. 23.158. Кнопка Warp на панели опций инструмента. Туре

Рис. 23.159. Установка значений параметров Style и Bend в диалоговом окне Warp Text

Рис. 23.160. Кадры анимации искажения текста

  7. В текущем кадре на палитре Animation будет отображен деформированный текст. Не снимая выделения с кадра, на этой же палитре щелкните по кнопке Tween (Промежуточные кадры). Поставьте переключатель Layers (Слои) в положение All Layers (Все слои), введите соответствующее число в поле Frame to Add (Добавить кадры) и щелкните по кнопке ОК.
  8. Выберите время задержки для кадров и щелкните по кнопке Play (Проиграть) на палитре Animation, чтобы начать воспроизведение.

Для деформированного вертикального текста могут быть доступны не все возможности анимации.

Удаление или корректировка искаженного текста

  1. Выберите слой искаженного текста.
  2. На панели опций инструмента Щ Туре (Текст) щелкните по кнопке Warp (Деформировать).
  3. Для того чтобы удалить эффект деформации текста, выберите во всплывающем меню Style (Стиль) пункт None (Нет).

Если вы хотите скорректировать искажение, обусловленное упомянутым эффектом, выберите другой вариант из меню Style ли6o примените другое направление искривления или-задайте другие значения параметров Bend (Изгиб), Horizontal Dis-torsion (Искажение по горизонтали) или Vertical Distorsion (Искажение по вертикали).

Также можно на палитре Animation выделить какой-либо кадр и по-другому исказить текст только в этом кадре.

Сохранение GIF-анимации

Если выполнить команду File > Save (Файл > Сохранить), то файл анимации будет сохранен в формате Photoshop; текущие настройки формата GIF на палитре Optimize (Оптимизация) будут также сохранены вместе с файлом. Выберите варианты Perceptual (Учитывающий восприятие), Selective (Селективный) или Adaptive (Адаптивный) в этой палитре, а также метод размытия, который поможет сгладить переходы от одного кадра к другому. Команда Save (Сохранить) никак не повлияет на палитру Layers (Слои) (сравните с командой Save Optimized (Сохранить с оптимизацией), о которой рассказывается далее) - см. рис. 23.161. Сохраненный файл можно будет в дальнейшем редактировать.

Если воспользоваться командой File > Save Optimized (Файл > Сохранить с оптимизацией), которой соответствует комбинация клавиш Ctrl+Option+S, то автоматически устанавливается формат GIF, а не Photoshop. За исключением одного случая: если в файле содержится ролло-вер, инициирующий анимацию, автоматически будет установлен формат HTML вместо GIF. Команда Save Optimized существенно влияет на слои. Вместо того, чтобы сохранить отдельные элементы слоя, которые составляют анимацию, команда сопоставляет каждый слой отдельному кадру анимационной последовательности (рис. 23.162). Посмотрите, какие изменения произойдут на палитре Layers (Слои) после того, как вы снова откроете файл, сохраненный командой Save Optimized (Сохранить с оптимизацией). Подробнее об этой команде рассказано в разделе «Сохранение оптимизированного файла в ImageReady».

Рис. 23.161. Пока файл остается в формате Photoshop, каждый элемент анимации находится на отдельном слое

Рис. 23.162. Сопоставление слоев кадрам анимации в результате использования команды Save Optimized

Рис. 23.163. Опция Optimize By в диалоговом окне Optimize Animation

Открытие анимации в формате GIF

Единственное видимое преимущество использования формата GIF - это возможность применения или редактирования настроек оптимизации файла.

  1. Выполните команду File > Open (Файл > Открыть) либо нажмите комбинацию клавиш Ctrl+O.
  2. Найдите название файла с расширением .gif и щелкните по нему.
  3. Щелкните по кнопке Open (Открыть). Кадры анимационной последовательности при этом будут сохранены. Однако на палитре Layers (Слои) теперь станет отображаться последовательность слоев: по одному слою для каждого кадра. Отдельные элементы слоя теперь нельзя редактировать независимо от других кадров!

Оптимизация анимации

  1. В меню палитры Optimize (Оптимизация) воспользуйтесь командой Optimize Animation (Оптимизировать анимацию).
  2. В группе параметров Optimize By (Оптимизировать с помощью) установите флажок Bounding Box (Габаритная рамка), чтобы сохранить первоначальный кадр, а также только те области, которые изменяются при переходе от одного кадра к другому (рис. 23.163). В результате уменьшится размер файла, но в то же время не все программы-редакторы, воспринимающие формат GIF, смогут работать с данным файлом.

В дополнение к этим действиям или вместо них установите флажок Redundant Pixel Removal (Удалить лишние.точки), чтобы удалить те точки объекта или фона, которые не меняются, то есть повторно выводятся при загрузке каждого нового кадра. Это также поможет уменьшить размер файла.

Ни одна из этих опций не изменит фактического вида анимации, все изменения происходят «за сценой».

Эффекты слоя

Программа ImageReady предлагает тот же набор эффектов слоя, что и Photoshop (см. раздел «Эффекты слоя» главы 14). Но программа Photoshop регулирует свойства слоя с помощью диалогового окна Layer Style (Стиль слоя), a ImageReady - с помощью контекстной палитры опций слоя.

Эффекты в программе ImageReady обладают теми же характеристиками, что и в Photoshop: их названия отображаются под именем слоя, к которому они применены; эффекты перемещаются вместе со слоем; на элементах палитры есть обращенные вправо стрелочки, с помощью которых можно открыть или закрыть список эффектов. У каждого эффекта есть свой собственный значок, позволяющий отобразить или скрыть данный эффект.

Применение эффектов слоя в программе ImageReady

  1. Выделите слой.
  2. Выберите эффект с помощью команды меню Layer > Layer Style (Слой > Стиль слоя) или из всплывающего меню Add layer effect (Добавить эффект слоя), расположенного в нижней части палитры Layers (Слои) - см. рис. 23.164.

Сглаживание границ при использовании эффектов слоя

При использовании большинства эффектов слоя создаются тени и цветные области со сглаженными границами. Такие границы не всегда хорошо оптимизируются в формате GIF, но этот формат - единственный, который можно применять для анимации. Помните об этом при ее создании и обязательно просматривайте результат с помощью команды File > Preview in [браузер] (Файл > Предварительный просмотр в [браузер]).

Рис. 23.164. Меню эффектов слоя в палитре Layers

Рис. 23.165. Палитра опций эффекта Bevel and Emboss

Рис. 23.166. Основная палитра Layer Options

Рис. 23.167. Контекстное меню слоев и эффектов

  3. На палитре опций слоя (рис. 23.165) выберите параметры эффекта (для каждого эффекта в палитре будут отображаться различные опции).
  4. До желанию. Примените дополнительные эффекты к этому же слою.
  5. Щелкните по любому имени слоя, чтобы вернуть основную палитру Layer Options (Опции слоя) - см. рис. 23.166. Подробнее о содержимом этой палитры см. раздел «Смешивание слоев» главы 14. Если на палитре не видны данные опции, то в меню палитры воспользуйтесь командой Show Options (Показать опции).

Можно скопировать эффект, перетащив его на другой слой. Если вы хотите скопировать все эффекты одного слоя на другой слой, перетащите на него главную панель эффектов слоя Effects (Эффекты).

Щелкните по стрелке, направленной вверх/ вниз и расположенной рядом с названием палитры Options (Параметры), чтобы увидеть дополнительные опции (например, Contour (Контур)) для каждого эффекта. Активизируйте все опции для эффектов Bevel and Emboss (Скос и рельеф)!

Для того чтобы получить доступ к контекстному меню слоя или эффекта, щелкните правой кнопкой мыши по имени слоя, имени эффекта слоя или по главной панели эффектов Effects (рис. 23.167).

Удаление эффекта слоя

Для того чтобы удалить эффект слоя, перетащите его на кнопку Delete (Удалить), расположенную на палитре. Если же надо удалить все эффекты, примененные к какому-либо слою, перетащите главную панель Effects (Эффекты) на кнопку Delete (рис. 23.168).

Другие возможности для работы со слоями в программе ImageReady

Существуют и другие методы работы со слоями в программе ImageReady:

  • есть простой способ запомнить, какие команды редактирования изображения автоматически применяются к кадрам анимации, а какие нет: изменения, вносимые с помощью палитры Layers, (Слои) не затрагивают реальных точек и, таким образом, автоматически не влияют на анимационные кадры или состояния ролловера. К ним относятся: изменение режима смешивания, корректировка непрозрачности слоя, отображение или скрытие слоя, применение или корректировка эффекта или перемещение элементов слоя. (Как вы помните, перемещение картинки может осуществляться и без палитры Layers.) Все другие изменения, вносимые без использования палитры Layers, автоматически применяются к анимационным кадрам;
  • для того чтобы облегчить поиск и перемещение от одного кадра к другому на палитре Animation (Анимация), можно использовать номер текущего кадра, кнопки Next frame (Следующий кадр) или Previous frame (Предыдущий кадр), расположенные на палитре Layers (рис. 23.169);

Рис. 23.168. Удаление всех эффектов слоя путем перетаскивания главной панели эффектов на кнопку Delete

Рис. 23.169. Кнопки палитры Layers для перемещения между кадрами

Рис. 23.170. Режим отображения Small Thumbnail

Рис. 23.171. Режим отображение Large Thumbnail на палитре Styles в программе ImageReady

  • чтобы выровнять на Web-странице элементы изображения (например, навигационные кнопки), свяжите соответствующие слои и воспользуйтесь командой Layer > Align Linked (Слой > Выровнять связанные слои) (см. раздел «Связывание слоев» главы 14);
  • для того чтобы упорядочить слои и эффекты, создайте наборы слоев, которые можно прятать или отображать по мере необходимости (см. разделы «Скрытие и показ слоя» и «Создание набора слоев» главы 7).
  • для защиты слоев и наборов слоев в программе ImageReady есть расширенное множество средств блокировки (см. разделы «Блокировка слоя» и «Блокировка прозрачных точек» главы 7).

Палитра Styles (Стили) очень удобна для хранения отдельных эффектов или их сочетаний. После сохраненения в этой палитре эффект или сочетание эффектов можно применить к любому слою, просто щелкнув мышью. Одни и те же стили доступны и в ImageReady, и в программе Photoshop 7 (они хранятся в папке Adobe Photoshop 7/Presets/Styles).

В программе ImageReady в меню опций палитры Styles (Стили) выберите один из трех режимов отображения: Small Thumbnail (Маленькая миниатюра), Small List (Короткий список) или Large Thumbnail (Крупная миниатюра). В режиме отображения Small Thumbnail миниатюры стилей, содержащих ролловеры, помечены в верхнем левом углу треугольником (подробнее об этом написано в разделе «Сохранение эффекта слоя в качестве стиля») см. рис. 23.170. В отличие от Photoshop, в программе Image Ready в режиме Large Thumbnail отображаются не только миниатюры стилей, но и список их имен (рис. 23.171).

Применение стиля к слою

Выберите слой, затем щелкните по стилю на палитре Styles (Стили) - см. рис. 23.171. Или перетащите имя стиля или его образец на любой выделенный или не выделенный слой на палитре Layers (Слои), как показано на рис. 23.172. Или перетащите имя стиля или образец на фигуру в окне изображения.

Если применить стиль к слою, все использованные ранее эффекты будут заменены эффектами выбранного стиля. Если же держать нажатой клавишу Shift и дважды щелкнуть по имени слоя или перетащить это имя, то эффекты стиля будут добавлены, но не заменят существующих эффектов за исключением ситуации, когда имя вновь примененного эффекта стиля совпадает с именем существующего эффекта: в этом случае новый эффект заменит примененный ранее.

Сохранение эффекта слоя в качестве стиля

  1. В программе Photoshop или ImageReady откройте палитру Styles (Стили).
  2. Перетащите один слой с каким-либо эффектом на эту палитру. А для того, чтобы сохранить сочетание эффектов, перетащите панель эффектов с палитры Layers (Слои) на палитру Styles (Стили) - см. рис. 23.173.

    Независимо от того, каким методом пользоваться, будет создан вариант стиля под названием New Style 1 (Новый стиль 1).

  3. Не снимая выделения со стиля, выберите из меню палитры Styles пункт Style Options (Опции стиля), а затем переименуйте стиль и щелкните по кнопке ОК (рис. 23.174).

Рис. 23.172. Перемещение выбранного варианта стиля из палитры Styles на слой, расположенный на палитре Layers

Стили ролловеров

В программе Photoshop 7 состояния рол-ловера могут храниться в виде стиля наряду с эффектами слоя. Создайте ломтик на основе слоя в программе ImageReady. Затем создайте ролловер для этого слоя. Перетащите имя слоя или фигуру со слоя на палитру Styles (Стили), либо выделите имя слоя и из меню палитры Styles выберите пункт New Style (Создать новый стиль). Убедитесь, что в диалоговом окне Style Options (Опции стиля) установлен флажок Include Rollover States (Включить состояния ролловера) - см. рис. 23.174. Щелкните по кнопке ОК. Теперь можно перетащить миниатюру стиля ролловера (она помечена треугольником в верхнем правом углу) из палитры Styles (Стили) на имя слоя или фигуру слоя в окне изображения, чтобы применить этот ролловер. Либо просто щелкните по миниатюре, чтобы применить ролловер к активному слою.

Заполнение фона повторяющимся узором

Для заполнения фона Web-страниц довольно часто используется повторяющийся рисунок, представляющий собой небольшие изображения, расположенные в шахматном порядке и похожие на черепицу. Почему же не использовать для этого большую картинку, заполняющую всю страницу целиком? Во-первых, потому что маленький файл «черепицы» будет загружаться гораздо быстрее, чем большое изображение. И, во-вторых, с помощью «черепицы» всегда можно заполнить все окно браузера независимо от его размера.

Рис. 23.173. Перетаскивание эффекта или панели эффектов Effects с палитры Layers на палитру Styles

Рис. 23.174. Переименование нового стиля в окне опций стиля

Программа ImageReady позволяет преобразовать изображение в HTML-файл элемента «черепицы», а затем использовать этот файл в качестве фона какого-либо изображения (см. раздел «Использование HTML-файла в качестве фона»). Фон будет отображаться при предварительном просмотре файла в браузере. Также можно указать цвет вместо «черепицы» для заливки фона Web-страницы.

Создание файла «черепицы»

  1. В программе ImageReady откройте изображение, которое будет использоваться в качестве «черепицы». По возможности выберите низко контрастное изображение с близкими оттенками цветов, так чтобы картинки и текст, загружаемые поверх повторяющегося узора, было легко рассматривать и читать. Если изображение содержит ломтики, то воспользуйтесь командой Slices > Delete All (Ломтики > Удалить все).
  2. Кадрируйте изображение, если необходимо использовать только его часть.
  3. Выполните команды Filter > Other > Tile Maker (Фильтр > Другие > Создать черепицу) - см. рис. 23.175.
  4. Включите опцию Blend Edges (Совместить края), чтобы края каждого элемента «черепицы» перекрывались с соседним элементом. Введите значение в процентах (от 1 до 20) в поле Width (Ширина), чтобы определить степень наложения краев мозаичных элементов (рис. 23.175)

Рис. 23.175. Диалоговое окно Tile Maker

Рис. 23.176. «Черепица» с перекрывающимися краями

Рис. 23.177. Узор, созданный без применения фильтра Tile Maker; края элементов не перекрываются

  5. Установите флажок Resize Tile to Fill Image (Изменять размер «черепицы» при заполнении изображения), чтобы размер «черепицы» соответствовал текущему размеру изображения. Если этот флажок не будет установлен, то элемент «черепицы» уменьшится в размерах в соответствии со значением в поле Width (Ширина). На рис. 23.176 показан узор, созданный при установленной опции Blend Edges (Совместить края), значении в поле Width (Ширина) равном 10% и установленном флажке Resize Tile to Fill Image (Изменять размер «черепицы» при заполнении изображения). Сравните его с узором, показанным на рис. 23.177. Альтернативный вариант - установите флажок Kaleidoscope Tile (Калейдоскоп), чтобы программа создала абстрактное изображение из исходного.
  6. Щелкните по кнопке ОК.
  7. Выполните команду File > Save Optimized (Файл > Сохранить с оптимизацией) либо нажмите клавиши Ctrl+ Alt+S, измените имя файла, выберите папку, в которой он будет храниться, и щелкните по кнопке Save (Сохранить).

Предварительный просмотр мозаичного фона

  1. Откройте файл в программе ImageReady.
  2. Удалите все ломтики.
  3. Выполните команды File > Output Settings > Background (Файл > Настрой ки вывода > Фон).
  4. Поставьте переключатель View As (Просмотреть как) в положение Background (Фон) - см. рис. 23.178.
  5. Щелкните по кнопке ОК.
  6. Для того чтобы просмотреть фон, на панели инструментов щелкните по кнопке Preview in Default Browser (Предварительный просмотр в браузере по умолчанию), либо выберите браузер из списка доступных.

В диалоговом окне File > Save Optimized (Файл > Сохранить с оптимизацией) или Save Optimized As (Сохранить с оптимизацией как), щелкните по кнопке Output Settings (Настройки вывода), чтобы вывести диалоговое окно Output Settings (Настройки вывода), из второго всплывающего меню выберите вариант Background, затем выполните шаги 3-4.

Упрощайте!

Несмотря на то, -что программа ImageReady способна создать «черепичный» HTML-фон, возможно, вы захотите связать такой фон с Web-страницей при помощи специальных программ, таких как GoLive компании Adobe, HomeSite или Dreamweaver компании Macromedia. Узнайте у Web-программиста или специалиста по Web-страницам, какую программу лучше использовать, чтобы включить код фона в код Web-страницы.

Рис. 23.178. Окно настроек вывода Output Settings в режиме Background

Советы по созданию фонового узора

Вот несколько советов по созданию фонового узора:

  • изображение будет повторяться, чтобы заполнить все окно браузера. Если в этом нет необходимости, то есть вы хотите, чтобы фоновое изображение вообще не повторялось, то создайте большой оптимизированный файл (примерно 800x800 пикселов) с небольшим количеством цветов и фигур;
  • если в файле, который был выбран для фонового изображения, содержится анимация, то она автоматически будет воспроизводиться на Web-странице для каждого элемента фона. Сложно для восприятия, но, возможно, это именно то, что вы искали.

Рис. 23.179. Окно Output Settings в режиме Image

Использование HTML-файла в качестве фона

  1. Откройте изображение.
  2. Воспользуйтесь командами File> Output Settings > Background (Файл > Настройки вывода > Фон).
  3. Поставьте переключатель View As (Просмотреть как) в положение Image (Изображение), если она доступна (рис. 23.179).
  4. В поле Image (Изображение) щелкните по кнопке Choose (Выбрать), выделите оптимизированный файл и щелкните по кнопке Open (Открыть).

    Чтобы указать однотонный цвет для фона, в разделе Background выберите его из всплывающего меню Color (Цвет), рядом с которым есть образец цвета (рис. 23.179), либо щелкните по образцу цвета и выберите цвет из палитры (установите флажок Only Web Colors (Только Web-цвета)). Этот цвет будет отображаться при загрузке изображения и будет виден сквозь прозрачные области основного изображения или элемента «черепицы».

  5. Щелкните по кнопке ОК.
  6. Для того чтобы просмотреть фон, щелкните на панели инструментов по кнопке Preview in Default Browser (Предварительный просмотр в браузере по умолчанию), либо нажмите эту кнопку и выберите браузер из списка.

Удаление HTML-файла «черепицы» или однотонной фоновой окраски изображения

  1. Откройте изображение и воспользуйтесь командами File > Output Settings > Background (Файл > Настройки вывода > Фон).
  2. Удалите имя файла в поле Image (Изображение) или из всплывающего меню Color (Цвет) выберите вариант None (Нет).
  3. Щелкните по кнопке ОК.

Диалоговое окно Save for Web в программе Photoshop

Нас бы мучила совесть, если бы, в конце концов, мы не показали, как выглядит диалоговое окно Save for Web (Сохранить для Web) в программе Photoshop. Ранее было сказано, что окно Save for Web похоже на окно Lite в ImageReady. В программе ImageReady есть все те же настройки оптимизации, что и в диалоговом окне Save for Web, и даже больше, гораздо больше. Если вам необходимо изучить возможности окна Save for Web, то воспользуйтесь указателями (рис. 23.180) и найдите в главе 23 соответствующие разделы по программе ImageReady.

Чтобы открыть диалоговое окно Save for Web, воспользуйтесь комбинацией клавиш Ctrl+Shift+Alt+S

Рис. 23.180. Диалоговое окно Save for Web


  • Приложение

Приложение.

"горячие" клавиши

Команды общего назначения

Показать/спрятать все палитры, включая палитру инструментов | Tab
Показать/спрятать все палитры за исключением палитры инструментов | Shitt+Tab
Отменить действие Принять внесенные изменения в любом диалоговом окне | Ctrl+Z Enter
Изменить в диалоговом окне клавишу Cancel (Отменить) на Reset (Восстановить) | Alt
Отменить изменения в любом диалоговом окне | Esc или Ctrl+«точка»
Закрыть диалоговое окно текста с помощью клавиатуры | Enter (на цифровой клавиатуре)
Активизировать кнопку в диалоговом окне, содержащем предупреждение | Первая буква кнопки (например, N для No (Нет))
Увеличить значение в выделенном поле на 1 (или 0,1) | Стрелка «вверх»
Увеличить значение в выделенном поле на 10 (или 1) | Shift+стрелка «вверх»
Уменьшить значение в выделенном поле на 1 (или на 0,1) | Стрелка «вниз»
Уменьшить значение в выделенном поле на 10 (или на 1) | Shift+стрелка «вниз»
Изменить угол на 15° | Shift+перетащить радиус
Отменить изменение положения всплывающего скользящего указателя (кнопка мыши не нажата) | Esc
Принять (подтвердить) изменение положения всплывающего скользящего указателя (кнопка мыши не нажата) | Enter
Вернуть скользящий указатель в предыдущее положение (кнопка мыши нажата) | Нажмите Alt и перемещайте курсор за границу скользящего указателя
Вызов системы помощи | F1
Интерактивный доступ к сайту компании Adobe | Щелкните по верхнему значку с изображением глаза на панелиинструментов
Палитры
Показать/скрыть палитру | F6
Color (Цвет) |
Показать/скрыть палитру | F7
Layers (Слои) |
Показать/скрыть палитру | F8
Info (Информация) |
Показать/скрыть палитру | F9
Actions (Действия) |
Инструменты |
Выбор инструмента |
Rectangular Marquee | М
(Прямоугольная область) Move (Перемещение) | V
Lasso (Лассо) | L
Magic Wand (Волшебная палочка) | W
Crop (Кадрировать) | С
Slice (Ломтик) | К
Brush/Pencil (Кисть/Карандаш) | В
Rubber Stamp (Штамп) | S
Healing Brush/Patch (Корректирующая кисть/Заплатка) | J
History Brush (Восстанавливающая кисть) | Y
Eraser (Ластик) | Е
Blur (Размытие) | R
Dodge (Осветлитель) | 0
Pen (Перо) | Р
Add-anchor-point (Добавить узловую точку) | + (плюс)
Delete-anchor-point (Удалить узловую точку) | - (минус)
Direct-selection (Прямое выделение) | А
Туре (Текст) | Т
Measure (Измеритель) | U
Gradient/Paint Bucket (Градиент/Ведро с краской) | G
Notes (Примечания) | N
Eyedropper (Пипетка) | I
Hand (Рука) | Н
Zoom (Масштаб) | Z
Переключение инструментов |
Группа Marquee (Выделение) | Shift+M
Группа Lasso (Лассо) | Shift+L
Группа Rubber Stamp (Штамп) | Shlft+S
Инструменты Blur (Размытие), Sharpen (Резкость) и Smudge (Палец) | Shift+R
Инструменты тонирования | Shift+0
Группа Реп (Перо) | Shitt+P
Инструмент Туре (Текст) | Shift+T
Группа Eyedropper (Пипетка) | Shift+l
Переключение между вышеуказанными инструментами | Alt+щелчок мышью по кнопке инструмента
Временное включение инструментов | Ctrl
Инструмент Move (Перемещение) Точный курсор (в виде перекрестия) | Caps Lock
С инструмента Pencil (Карандаш) на Eyedropper (Пипетка) | Alt
С инструмента Line (Линия) на Eyedropper (Пипетка) | Alt
С инструмента Paint Bucket (Ведро с краской) на Eyedropper (Пипетка) | Alt
С инструмента Blur (Размытие) на Sharpen (Резкость) и обратно | Alt
С инструмента Dodge (Осветлитель) на Burn (Затемнитель) и обратно | Alt
Характеристики инструмента |
Изменение непрозрачности кисти с шагом 10% | Цифра (2 = 20%, 3 = 30%)
Привязка инструмента |
Привязка инструмента к горизонтальной или вертикальной оси (Eraser (Ластик), Brash (Кисть), Pencil (Карандаш), Blur (Размытие), Sharpen (Резкость), Smudge (Палец), Dodge (Осветлитель) или Bum (Затемнитель)) | Shifl+перетаскивание курсора
Рисовать, стирать и т.д. по прямым линиям (Eraser (Ластик), Palntbrash (Кисть), Pencil (Карандаш), Blur (Размытие), Sharpen (Резкость), Smudge (Палец), Dodge (Осветлитель) или Bum (Затемнитель)) | Shft+щелчок мышью
Рисовать под углом 45° (Line (Линия), Gradients (Градиент) или Convert-point (Преобразовать узел)) | Shifl+перетаскивание курсора
Инструмент Crop (Кадрировать) |
Повернуть рамку кадрирования | Перетаскивание курсора вне рамки
Переместить рамку кадрирования | Перетаскиваниекурсора внутри рамки
Изменить размеры рамки кадрирования Сохранить пропорции рамки кадрирования | Перетаскивание границ рамки Shift+перетаскивание за угол рамки
Изменить размер рамки кадрирования с фиксацией центра Применить кадрирование | Alt+перемещение манипуляторов рамки Enter
Инструмент Slice (Ломтик) |
Переключение между инструментом Slice (Ломтик) и Slice Selection (Выделение ломтика) | Ctrl
Нарисовать квадратный ломтик | Shift+перетаскивание Alt+перетаскивание
Рисовать из центра Рисовать квадратный ломтик из центра | Alt+Shift+перетаскивание
Переместить ломтик по время создания Включить/выключить привязку к ломтикам | «пробел»+перетаскивание Ctrl во время рисования
Инструмент Move (Перемещение) |
Перетаскивать под углом 45° Копировать выделение или слой | Shift+перетаскивание курсора Alt+перетаскивание курсора
Сдвигать слой/выделенную область на один пиксел | Ctrl+клавиша со стрелкой
Сдвигать слой/выделенную область на десять пикселов | Ctrl+Shift+клавиша со стрелкой
Инструмент Lasso (Лассо) |
Добавить в выделенную область | Shift+ щелкните мышью, затем рисуйте
Удалить из выделенной области | Alt+щелкните мышью, затем рисуйте
Пересечь с выделенной областью | Alt+Shift+ щелкните мышью, затем рисуйте
Рисовать с помощью инструмента Poligonal Lasso (Полигональное лассо) | Щелкните мышью, затем нажмите Alt и рисуйте
Инструмент Poligonal Lasso (Полигональное лассо) |
Добавить в выделенную область | Shifl+щелкните мышью, затем рисуйте
Удалить из выделенной области | Alt+щелкните мышью, затем рисуйте
Пересечь с выделенной областью | Alt+Shift+ щелкните мышью, затем рисуйте
Рисовать с помощью инструмента Lasso (Лассо) | Alt+перетаскивайте курсор
Рисовать под углом 45° | Shift+перетаскивайте курсор
Инструмент Magnetic Lasso (Магнитное лассо) |
Добавить в выделенную область | Shift+щелкните мышью, затем рисуйте
Удалить из выделенной области | Alt+щелкните мышью, затем рисуйте
Пересечь с выделенной областью | Alt+Shift+ щелкните мышью, затем рисуйте
Добавить точку | Щелкните мышью
Замкнуть контур | Двойной щелчок мышью или Enter
Удалить последнюю точку | Backspace/Delete
Замкнуть контур в начальной точке | Щелкните по первой точке Alt+двойной щелчок мышью
Замкнуть контур отрезком прямой | Alt+перетаскивайте курсор
Переключиться на инструмент Lasso (Лассо) |
Переключиться на инструмент Poligonal Lasso (Полигональное лассо) | Alt+щелчок мышью
Инструмент Eraser (Ластик) | Alt+перетаскивайте курсор Alt
Стереть до указанного состояния на палитре History (Истфия) | Dodge (Осветлитель)
Инструмент Smudge (Палец) |
Инструмент Smudge (Палец) | Alt
Использовать основной цвет |
Инструменты Burn | Alt+Shift+W
Инструменты Burn | Alt+Shift+V
Инструменты Burn | Alt+Shift+Z
Инструменты Burn (Затемнитель) и Dodge (Осветлитель) в режиме Highlights (Светлые тона) | Alt+Shift+Z
Инструмент Sponge (Губка) |
В режиме Desaturate (Обесцветить) | Alt+Shift+J
В режиме Saturate (Окрасить) | Alt+Shift+A
Инструмент Measure (Измеритель) | Shift+перетаскивайте курсор
Угол наклона 45° Создать измеритель угла | Alt+щелкните мышью+перетащите курсор на конечную точку
Инструмент Paint Bucket (Ведро с краской |
Изменить цвет вне холста | Shift+щелкните мышью вне холста
Инструмент Eyedropper (Пипетка) |
Выбрать цвет фона | Alt+щелкните мышью Shift
Переключиться на инструмент Color Sampler (Цветовая проба) | Alt+Shift+щелкните мышью по метке
Удалить цветовую метку | Alt+щелкните мышью по метке
Инструмент Color Sampler (Цветовая проба) |
Удалить цветовую метку | Alt+щелкните мышью по метке
Отображение |
Изменение масштаба |
Увеличить | Сtrl+«пробел»+щелкните или перетащите либо Сtrl+Аlt+«плюс»
Масштаб 100% | Двойной щелчок мышью по инструменту Zoom (Масштаб)
Подгонка по размеру окна | Двойной щелчок мышью по инструменту Hand (Рука)
Уменьшить | Сtrl+Аlt+«пробел»+щелкните или Сtrl+Аlt+«минус»
Подгонка по размеру экрана | Ctrl+0
Действительные точки | Ctrl+Alt+0
Увеличить, не изменяя размеров окна | Сtrl+«плюс»
Уменьшить, не изменяя размеров окна | Сtrl+"-"
Инструмент Hand (Рука) |
Переключиться на увеличение масштаба | Ctrl
Переключиться на уменьшение масштаба | Alt
Подгонка изображения по размерам экрана | Двойной щелчок мышью по значку инструмента
Инструмент Zoom (Масштаб) |
Уменьшить Фактический размер | Alt+щелчок мышью
Показать/спрятать | Двойной щелчок мышью по значку инструмента
Показать/спрятать границы | Ctrl+H
Показать/спрятать контур | Ctrl+Shlft+H
Показать/спрятать линейки | Ctrl+R
Показать/спрятать направляющие линии | Ctrt+" (кавычки)
Сетка и направляющие линии | Shift+Ctrt+; (точка с запятой)
Привязка к направляющим линиям Зафиксировать направляющие линии | Alt+Ctrl+; (точка с запятой)
Поменять направление линии (по горизонтали/по вертикали) | Alt+перетащите линию
Привязка направляющей линии к линейке | Shift+перетащите линию
Перемещение изображения в окне |
Прокрутить вверх на размер одного экрана Прокрутить вверх на десять единиц Прокрутить вниз на размер одного экрана | Page Up Shift+Page Up Page Down
Прокрутить вниз на десять единиц | Shift+Page Up
Прокрутить влево на размер одного экрана | Ctrl+Page Up
Прокрутить влево на десять единиц | Ctrt+Shift+Page Up
Прокрутить вправо на размер одного экрана | Ctrl+Page Down
Прокрутить вправо на десять единиц | Ctrl+Shift+Page Down
Передвинуть влево | Home
Передвинуть вправо | End
Палитра Navigator (Навигация) |
Прокрутить видимую область изображения | Перетащите рамку просмотра
Переместить поле зрения на другую часть изображения | Щелкните в области предварительного просмотра
Показать другую область изображения | Ctrl+перетащите курсор в области предварительного просмотра
Режимы экрана |
Переключение режимов Standard/Full Screen Screen(Стандратный/В полный экран) и Menu/Full Screen (Меню/В полный экран) | F
Включение/Выключение меню в режиме Full Screen with Menu (В полный экран с меню) | Shlft+F
Вид |
Preview >CMYK (Предварительный просмотр > CMYK) | Ctrl+Y
Выполнить команду Gamut Warning (Предупреждение о гамме) | Ctrl+Shlft+Y
Меню File (Файл) |
New (Создать) | Ctrl+N
Open (Открыть) | Ctrl+0
Open as (Открыть как) | Ctrl+Alt+0
Browse (Просмотр) | Shift+Ctrl+0
Close (Закрьпь) | Ctrl+w
Save (Сохранить) | Ctrl+S
Revert (Обратить) | F12
save a copy (сохранить копию) | Ctrl+Altt+S
Save as (Сохранить как) | Ctrl+Shift+S
Page Setup (Параметры страницы) | Ctrl+Shlft+P
Print (Печать) | Ctrl+P
Preferences > General (Установки > Общие) | Ctrl+K
Saving Files (Сохранение файлов) Display & Cursors (Отображение и курсоры) | Ctrl+2 Ctrl+3
Transparency & Gamut (Прозрачность и гамма) | Ctrl+4
Units & Ruler (Единицы измерения и линейка) | Ctrl+5
Guides & Grid (Сетка и направляющие линии) | Ctrl+6
Plug-Ins & Scratch Disks (Встраиваемые модули и временные диски) | Ctrl+7
Memory & Image Cache (Память и кэш изображения) | Ctrl+8
Exit/Quit (Выйти/Закончить) Создать с характеристиками по умолчанию | Ctrl+0 CW+Alt+N
Последние значения установок | Ctrl+Alt+K
Команды, использующие буфер обмена
Cut (Вырезать) | Ctrl+X
Сору (Копировать) | Ctrl+C
Copy Merged (Копировать объединение) | Ctrl+Shlft+C
Past (Вставить) | Ctrl+V
Past Into (Вставить в) | Ctrl+Shift+V
Режимы смешивания слоя |
Установить для слоя следующий режим смешивания | Shift+"плюс"
Установить для слоя предыдущий режим смешивания | Shift+«минyc»
Режимы смешивания для кисти и слоя |
Normal (Нормальный) | Alt+ShifUN
Dissolve (Растворение) Multiply (Умножение) | Alt+Shift+l Alt+Shlft+M
Screen (Экран) | AlttShifttS
Overlay (Наложение) | Alt+Shift+O
Soft Light (Мягкий свет) | Alt+Sift+F
Hard Light (Яркий свет) Color Dodge (Комбинирование цветов) | Alt+Shlft+H Alt+ShifltD
Color Burn (Форсирование цвета) Darken (Затемнить) | Alt+Shitt+B Alt+Shlft+K
Lighten (Осветить) | Alt+Shitt+G
Difference (Различие) Exclusion (Исключение) | Alt+Shift+E Alt+Shlft+X
Hue (Тон) Saturation (Насыщенность) | Alt+Shift+U Alt+ShifUT
Color (Цвет) | Alt+Shitt+C
Luminosity (Яркость света) | Alt+Shitt+Y
Threshold (Порог (режим Bitmap)) | AlttShlfttL
Behind (Позади) | Alt+Shift+Q
Linear Dodge (Линейное комбинирование) | AlttShifl+W
Linear Bum (Линейное форсирование) | AH+Shitt+A
Pin Light (Точечный свет) Vivid Light (Яркий свет) | AlttShitt+Z Alt+Shirt+V
Цвет |
Цвета |
Поменять друг с другом основной и фоновый цвет | X
Восстановить цвета, установленные по умолчанию | D
Заливка |
Открыть диалоговое окно Fill (Заливка) | Shift+Backspace
Залить основным цветом | Alt+Detete/Backspace
Залить основным цветом в режиме Preserve Transparency (Сохранить прозрачность) | Shift+Alt+Delete/Backspace
Залить фоновым цветом | Ctrl+Delete/Backspace
Залить фоновым цветом в режиме Preserve Transparency (Сохранить прозрачность) | Shift+Ctrl+ Delete/Backspace
Залить, используя активный элемент палитры History (История) | Ctrl+Alt+Backspace
Палитра Color (Цвет) |
Перемещаться между цветовыми панелями | Shift+щелкните по цветовой панели
Выбрать определенную панель цвета | Щелкните правой кнопкой мыши по цветовой панели
Палитра Swatches (Образцы) |
Добавить основной цвет в виде нового образца | Щелкните по пустому месту на палитре
Вставить новый образец | Shift+Alt+щелкните в палитре
Заменить образец цвета основным цветом | Shift+щелкните по образцу
Выбрать образец в качестве фонового цвета | Щелните по образцу Аlt Чщелкните по образцу
Удалить образец Выбрать образец в качестве основного цвета | Сtrl+щелкните по образцу
Кисти |
Палитра Brushes (Кисти) Выбрать первую кисть Выбрать предыдущую кисть | Shffl+1 [
Выбрать следующую кисть | ]
Выбрать последнюю кисть Удалить кисть | Shift*) АпЧщелкните по пиктограмме кисти
Переименовать кисть | Дважды щелкните по пиктограмме кисти
Выделение |
Выделить все | Ctrl+A
Снять выделение | Ctrl+D
Снова выделить | Ctrl+Shilt+D
Инвертировать | Ctrl+Shift+l
Растушевать | Ctrl+Alt+D
Сдвинуть рамку выделения на один пиксел | Стрелка «вверх»
Сдвинуть рамку выделения на десять пикселов | Shlft+стрелка «вверх»
Фильтры |
Снова применить последний использовавшийся фильтр | Ctrl+F
Постепенное исчезновение эффекта последнего фильтра | Ctrl+Shift+F
Применить фильтр с последними установленными характеристиками | Ctrl+Alt+F
Диалоговое окно Lighting Effects (Эффекгы освещения) |
Клонировать источник света в области предварительного просмотра | Alt+перетащите источник света
Удалить источник света в области предварительного просмотра | Delete
Коррекция светового пятна манипулятор | Shift+перетащите манипулятор
Коррекция угла освещения без изменения светового пятна | Ctrl+перетащите манипулятор
Слои Меню Layer (Слой) |
New > Layer (Создать > Слой) | Ctrl+Shift+N
Создать слой без вызова диалогового окна | Ctrl+Alt+Shift+N
Создать слой путем копирования | Ctrl+J
Создать слой из вырезанной области | Ctrl+Shitt+J
Сгруппировать слой с предыдущими | Ctrl+G
Разгруппировать слои | Ctrl+Shift+G
Merge Down/Linked/Group (Слить c нижним/свяэанные/группу) | Ctrl+E
Merge Visible (Слить видимые слои) | Shift+Ctrl+E
Палитра Layers (Слои) Показать/спрятать слой | Щелкните по значку в виде глаза
Переключить режим показа всех слоев/только конкретного слоя | Alt+щелкните по значку в виде глаза
Показать/спрятать несколько слоев | Щелкните и перетащите курсор по столбцу значков в виде глаза
Связать слой с выделенным слоем | Щелкните по пиктограмме связей
Включить/выключить опцию связывания нескольких слоев | Щелкните и перетащите курсор по столбцу пиктограмм связей
Создать новый, пустой слой | Щелкните по кнопке Create new layer (Создать новый слой)
Создать новый, пустой слой с помощью диалогового окна Layer Options (Опции слоя) | Alt+щелкните по кнопке Create new layer (Создать новый слой)
Скопировать слой | Перетащите слой на кнопку Create new layer (Создать новый слой)
Удалить слой с появлением окна предупреждения | Щелкните по кнопке Delete current layer (Удалить выделенный слой)
Удалить слой без появления окна предупреждения | Alt+щелкните по кнопке Delete current выделенный слой)
Изменить непрозрачность слоя (%) | Клавиши с цифрами (2 = 20%, 3 = 30%) / (слэш)
Включить опцию Preserve Transparency (Сохранять прозрачность) для слоя | Ctrl+щелкните по образцу слоя
Загрузить точки слоя в виде выделенной области | Ctrl+Shift+щелкните по образцу слоя
Добавить точки слоя в выделенную область | Ctrl+Alt+щелкните по образцу слоя
Удалить точки слоя из выделенной области | Ctrl+Alt+Shlft+ щелкните по образцу слоя
Оставить только те точки слоя, которые пересекаются с выделенной областью | Ctrl+Alt+Shlft+ щелкните по образцу слоя
Выделить верхний слой | Shitt+Alt+]
Выделить следующий слой (расположенный сверху) | Alt+]
Выделить предыдущий слой (расположенный снизу) | Alt+[
Выделить нижний слой | Shift+Alt+[
Редактировать свойства слоя | Дважды щелкните по имени слоя
Эффекты слоя |
Включить/выключить эффект без появления диалогового окна | Alt+соответствующий пункт меню
Отредактировать свойства эффекта слоя | Дважды щелкните по значку эффекта слоя
Очистить эффект слоя | Alt+дважды щелкните по значку эффекта
Переместить эффект | Перетащите эффект в изображении
Переместить эффект под углом 45° | Shift+перетащите эффект в изображении
Диалоговое окно Layer Effects (Эффекть слоя) |
Drop shadow (Отбросить тень) | Ctrl+1
Inner shadow (Внутренняя тень) | Ctrl+2
Outer glow (Внешнее свечение) | Ctrl+3
Inner glow (Внутреннее свечение) | Ctrl+4
Bevel and emboss (Скос и рельеф) | Ctrl+5
Корректирующие слои |
Создать корректирующий слой | Ctrl+щелкните no кнопке Create new layer (Создать новый слой)
Редактировать корректирующий слой | Щелкните по значку корректировки
Маски слоя |
Создать маску слоя с опцией Reveal All/Reveal Selection (Показать все/Показать выделение) | Щелкните по кнопке маски
Создать маску слоя с опцией Hide All/Hide Selection (Спрятать все/Спрятать выделение) | Alt+щелкните по кнопке маски
Создать/удалить связь между слоем и маской слоя | Щелкните по значку Lock layer mask (Блокировать маску слоя)
Открыть диалоговое окно Layer Mask Options (Свойства маски слоя) | Дважды щелкните по миниатюре маски слоя
Включить/выключить маску слоя | Shlft+щелкните по миниатюре маски слоя
Включить/выключить режим красного света | \ (слэш)
Включить просмотр только маски слоя/маски слоя вместе с остальным изображением | Аlt+щелкните по миниатюре маски слоя
Включить опцию Group/Ungroup with previous (Сгруппировать/Разгруппировать с предыдущим слоем) | Alt+щелкните по линии, разделяющей слои
Слияние слоев |
Слить копию выделенного слоя со слоем, расположенным под ним | Alt+команда Merge Down
Слить копии- всех видимых слоев с выделенным слоем | Аlt+команда Merge Visible
Слить копии связанных слоев со слоем, расположенным ниже | Alt+команда Merge Linked
Изменение порядка следования слоев |
Расположить над всеми | Ctrl+Shift+]
Расположить перед следующим слоем | Ctrl+[
Расположить под всеми слоями | Ctrl+Shift+]
Поместить под предыдущим слоем | Ctrl+[
Палитра Channels (Каналы) |
Включить отдельные каналы | Ctrl+[клавиша 1-9]
Включить все каналы | Ctrt+~ (тильда)
Показать/спрятать канал | Щелкните по значку в виде глаза
Добавить/удалить канал из набора каналов | Shm+ щелкните по каналу
Создать новый канал | Щелкните по кнопке New Channel (Создать канал)
Создать новый канал с помощью диалогового окна Channel Options (Опции канала) | Alt+щелкните по кнопке New Channel (Создать канал)
Скопировать канал | Перетащите канал на кнопку New Channel (Создать канал)
Удалить кашл с появлением предупреждающего окна | Щелкните по кнопке Delete Channel (Удалить канал)
Удалить канал без появления предупреждающего окна | Alt+щелкните по кнопке Delete Channel (Удалить канал)
Создать новый канал плашечного цвета | Ctrl+щелкните по кнопке New Channel (Создать канал)
Создать новый канал из выделенной области | Щелкните по кнопке Save Selection (Сохранить выделение)
Создать новый канал из выделенной области с помощьк диалогового окна Channel Options (Опции канала) | Alt+щелкните по кнопке Save Selection (Сохранить выделение)
Загрузить канал в качестве выделения | Щелкните по кнопке Lоаd Selection (Загрузить выделение)или Ctrl+щелкните по миниатюре канала
Добавить канал в выделенную область | Shift+щелкните по кнопке Load Selection (Загрузить выделение) или Ctrl+Shift+ щелкните по миниатюре канала
Вычесть канал из выделенной области | Alt+щелкните покнопке Load Selection (Загрузить выделение) или Ctrl+Alt+ щелкните по миниатюре канала
Пересечение канала и выделенной области Изменять свойства канала | Alt+Shift+щелкните по кнопке Load Selection (Загрузить выделение) или Ctrl+Alt+Shift+щелкните по миниатюре Дважды щелкните по имени канала
Быстрая маска |
Включить/выключить быструю маску | Q
Инвертировать режим быстрой маски | Alt+щелкните по кнопке Quick Mask (Быстрая маска)
Открыть диалоговое окно Options Quick Mask (Опции быстрой маски) | Дважды щелкните по кнопке QUICK MASK (Быстрая маска)
Контуры |
Палитра Paths (Контуры) |
Создать новый контур | Щелкните по кнопке New Path (Создать контур)
Создать новый контур с помощью диалогового окна New Path (Создать контур) | Alt+щелкните по кнопке New Path (Создать контур)
Копировать контур Удалить контур с выводом предупреждающего окна | Перетащите контур на кнопку New Path (Создать контур) Щелкните по кнопке Delete Path (Удалить контур)
Удалить контур без вывода предупреждающего очна | Alt+щелкните по кнопке Delete Path (Удалить контур)
Сохранить рабочий контур в виде контура | Перетащите рабочий контур на кнопку New Path (Создать контур)
Преобразовать выделенную область в рабочий контур | Щелкните по кнопке Make Work Path (Создать рабочий контур)
Преобразовать выделенную область в рабочий контур с помощью диалогового окна Work Path (Рабочий контур) | Alt+щелкните по кнопке Make Work Path (Создать рабочий контур)
Преобразовать контур в выделенную область | Щелкните по кнопке Load Selection (Загрузить выделение)
Преобразовать контур в выделенную область с помощью диалогового окна Make Selection (Создать выделение) | Alt+щелкните по кнопке Load Selection (Загрузить выделение)
Очертить/залить контур |
Очертить контур основным цветом | Щелкните по кнопке Stroke Path (Очертить контур)
Очертить контур с использованием диалогового окна Stroke Path (Очертить контур) | Alt+щелкните Stroke Path (Очертить контур)
Залить контур основным цветом | Щелкните по кнопке Fill Path (Залить контур)
Залить контур с использованием диалогового окна Fill Path (Залить контур) | Alt+щелкните по кнопке Fill Path (Залить контур)
Контуры и выделенные области |
Загрузить контур как выделенную область | Ctrt+щелкните по миниатюре контура
Добавить контур к выделенной области | Ctrl+Shift+щелкните по миниатюре контура
Удалить контур из выделенной области | Ctrl+Alt+щелкните по миниатюре контура
Пересечение контура и выделения | Ctrl+Alt+Shift+щелкните по миниатюре
История |
Палитра History (История) |
Перейти вперед/назад на один шаг | Ctrl+Z
Перейти на шаг вперед | Shlft+Ctrl+Z
Перейти на шаг назад | Alt+Ctrl+Z
Скопировать состояние (отличное от текущего) | Alt+щелкните по элементу палитры
Создать новый снимок | Щелкните по кнопке Create new snapshot (Создать снимок)
Создать новый документ из состояния/снимка | Щелкните по кнопке Create new document (Создать документ)
Инструмент History brush (Восстанавливмщая кисть) | Shift+перетащите курсор
Привязка к горизонтальной или вертикальной оси Рисовать прямые линии | Shift+щелкните мышью
Трансформация |
Произвольная трансформация Transform > Again (Трансформировать > Снова) | Ctrl+T
Произвольная трансформация с дублированием | Ctrl+Shift+T
Повтор операции трансформации с дублированием | Ctrl+Alt+T
Изменить масштаб относительно центра (произвольная трансформация) | Ctrl+Alt+Shift+T
Скос относительно центра (произвольная трансформация) | Alt+перетащите угловой манипулятор
Alt+перетащите угловой манипулятор | Ctrl+Alt+Shlft+перетащите боковой манипулятор
Levels (Уровни) Auto Levels (Автоуровни) | Ctrl + L.
Curves (Кривые) | Ctrl+Shift+L Ctrl+M
Color Balance (Баланс цвета) | Ctrl+B
Hue/Saturation (Тон/Насыщенность) | Ctrt+U
Desaturate (Обесцветить) | Ctrl+Shltt+U
Invert (Инвертировать) | Ctrt+U
Повторное открытие диалогового окна |
Levels (Уровни) с последними установками | Ctrl+Alt+L
Curves (Кривые) с последними установками | Ctrl+Alt+M
Color Balance (Баланс цвета) с последними установками | Ctrl+Alt+B
Hue/Saturation (Тон/Насыщенность) с последними установками | CtrltAlttU
Текст |
Инструмент Туре (Текст) |
Начало текста | Щелкните или щелкните и перетащите курсор
Повторное редактирование текста | Щелкните по тексту в изображении
Диалоговое окно Туре (Текст) |
Увеличить текст на изображении | Сtrl+«плюс»
Уменьшить текст на изображении | Ctrl+«минус»
Выравнивание |
По левому/верхнему краю | Ctrl+Shlft+L
По центру | Ctrl+Shlft+C
По правому/нижнему краю | Ctrl+Shift+R
Кегль |
Увеличить кегль на два пункта | Ctrl+Shift+>
Увеличить кегль на десять пунктов | Ctrl+Alt+Shift+>
Уменьшить кегль на два пункта | Ctrl+Shift+<
Уменьшить кегль на десять пунктов | Ctrl+Alt+Shift+<
Межстрочный интервал |
Увеличить интервал на два пункта | Alt+стрелка «вниз»
Увеличить интервал на десять пунктов | Ctrl+Alt+стрелка «вниз»
Уменьшить интервал на два пункта | Alt+стрелка «вверх»
Уменьшить интервал на десять пунктов | Ctrl+Alt+стрелка «вверх»
Кернинг/межбуквенное расстояние |
Увеличить расстояние на 20/1000 широкого пробела | Alt+стрелка «вправо»
Увеличить расстояние на 100/1000 широкого пробела | Ctrl+Alt+стрелка «вправо»
Уменьшить расстояние на 20/1000 широкого пробела | Alt+стрелка «влево»
Уменьшить расстояние на 100/1000 широкого пробела | Ctrl+Alt+стрелка «влево»
Перемещение базовой линии |
Вверх на два пункта | Alt+Shlft+стрелка «вверх»
Вверх на десять пунктов | Ctrl+Alt+Shlft+стрелка «вверх»
Вниз на два пункта | Alt+Shift+стрелка «вниз»
Вниз на десять пунктов | Ctrl+Alt+Shift+стрелка «вниз»
Перемещение позиции вставки |
Вправо на одну букву | Стрелка «вправо»
Влево на одну букву | Стрелка «влево»
Вверх на одну строчку | Стрелка «вверх»
Вниз на одну строчку | Стрелка «вниз»
Вправо на одно слово | Ctrl+стрелка «вправо»
Влево на одно слово | Ctrl+стрелка «влево»
Выделение |
Слово | Двойной щелчок мышь
Буква справа | Shift+стрелка «вправо»
Буква слева | Shift+стрелка «влево»
Слово справа | Ctrl+Snift+стрелка «вправо»
Слово слева | Ctrl+Shift+стрелка «влево»
Верхняя строчка | Shift+стрелка «вверх»
Нижняя строчка | Shift+стрелка «вниз»
Все буквы | Ctrl+A
Все буквы, начиная с позиции вставки Shitt+щелчок мышью | Shift+щелкните мышью и рисуйте
Инструменты Type Mask (Маска ) и Vertical Type Mask (Маска текста вертикального текста) |
Добавить в выделенную область | Shift+щелкните мышью и рисуйте
Удалить из выделенной области | Alt+щелкните мышью и рисуйте
Пересечь с выделением | Alt+Shlft +щелкните мышью, затем рисуйте
Начало текста | Щелкните и перетаскивайте курсор
Диалоговое окно Curves (Кривые) |
Добавить цвет в виде новой точки кривой | Ctrl+щелкните по изображению
Добавить цвет в виде отдельных точек каждой кривой | Ctrl+Shift+щелчок мышью
Переместить точки | Клавиши со стрелками
Переместить точки на расстояние, кратное 10 единицам | Shlft+клавиши со стрелками
Добавить точку | Щелкните по сетке
Удалить точку | Ctrl+щелкните по точке
Снять выделение с точек | Ctrl+D
Переключение грубой/точной сетки | Аlt+щелкните по сетке
Выделить следующую точку | Ctrl+Tab
Выделить, предыдущую точку | Ctrl + Shift+Tab
Выделить несколько точек | Shift+щелчок мышью
Диалоговое окно Hue/Saturation (Тон/Насыщенность) |
Переместить диапазон оттенков на новое место | Щелкните по изображению
Добавить в диапазон оттенков | Shlft+щелкните/перетащите курсор по изображению
Удалить из диапазона оттенков | Аlt+щелкните/перетащите курсор по изображению
Редактировать отдельные цвета | Ctrl+~ (тильда)
Редактировать композитное изображение | Ctrl+[клавиша 1-6]
Диалоговое окно 3D Transform (Трехмерная трансформация) |
Инструмент Select (Выделить) | V
Инструмент Direct selection (Непосредственное выделение] | А
Инструмент Cube (Куб) | М
Инструмент Sphere (Сфера) | N
Инструмент Cylinder (Цилиндр) | С
Инструмент Add-anchor-point (Добавить опорную точку) | + (ПЛЮС)
Инструмент Detete-anchor-point (Удалить опорную точку) | - (минус)
Инструмент Pan Camera (Панорамная камера) | Е
Инструмент Trackball (Трекбол) | R
Инструмент Hand (Рука) | Н
Инструмент Zoom (Масштаб) | Z
Переключить инструменты Select/Direct selection (Выделить/Непосредственное выделение) | Ctrl+Tab
Панорама изображения | «Пробел» +перетащите изображение
Увеличить масштаб | Ctrl+«пробел» ;+перетащите/щелкните по изображению
Уменьшить масштаб | Ctrl+Аlt+«пробел» +щелкните по изображению


  • Глава 3. Начало работы
    • Запуск программы
    • Источники изображений
      • Сканирование
      • Основные сведения о программном обеспечении для сканирования
      • Режим 16 бит на канал
      • Сканирование в программе Photoshop
      • Определение правильного разрешения при сканировании или для существующего изображения
      • Разрешение для Web-графики
      • Использование строки состояния
      • Размер файла
      • Создание нового изображения
      • Открытие изображения в программе Photoshop
      • Миниатюры
      • Открытие файла Kodak Photo CD
      • Открытие файлов в формате EPS, PDF или программы Illustrator как нового изображения
      • Размещение файлов в формате EPS, PDF или программы Adobe Illustrator в существующем изображении Photoshop
    • Сохранение файлов
      • Сохранение нового изображения
      • Сохранение слоев, векторов и эффектов
    • Управление изображениями
      • Изменение масштаба просмотра с помощью палитры Navigator
      • Изменение масштаба просмотра изображения. с помощью инструмента Zoom
      • Перемещение увеличенного изображения в окне
      • Изменение режима показа изображений на экране
      • Показ одного изображения в двух окнах
      • Изменение цвета рабочего холста
    • Закрытие изображения
      • Выход из программы Photoshop

Глава №3.

Начало раброты

В этой главе вы узнаете, как начать работу: запустить Photoshop, отсканировать изображение, создать новое, открыть уже существующее и разместить любое изображение в программе Photoshop. Также здесь будет рассказано о том, как изменять размеры и разрешение изображения, размер файла; увеличить размер холста (canvas), на котором располагается изображение; как обрезать, перевернуть, повернуть, сохранить, копировать и закрыть изображение. Кроме того, вы узнаете, как изменять масштаб просмотра изображения, перемещать изображение в окне и переключать режимы показа изображений на экране.

Запуск программы

В операционной системе Windows 95, 98, ME, 2000, ХР или NT щелкните по кнопке Start (Пуск), расположенной на панели задач, выберите Programs (Программы), затем Adobe, Photoshop 7.0 и щелкните по элементу Adobe Photoshop 7.0 (рис. 3.1).

(Если у вас на рабочем столе нет пиктограммы для программы Photoshop, откройте папку Adobe Photoshop и перетащите значок из этой папки на рабочий стол.)

Рис. 3.1. Запуск программы Photoshop 7.0

Второй способ: откройте папку Adobe Photoshop в каталоге My Computer (Мой компьютер) и дважды щелкните по папке программы Photoshop (рис. 3.2).

Третий способ: дважды щелкните мышью по пиктограмме какого-либо файла в формате Photoshop (рис. 3.3)

Рис. 3.2. Папка Photoshop 7.0

Рис. 3.3. Файлы в формате Photoshop

Рис. 3.4. Форматы изображений программы Photoshop

Источники изображений

Любое изображение можно создать, открыть, редактировать и сохранить в 12 различных форматах Photoshop (рис. 3.4). Но обычно используются только несколько форматов: TIFF, GIF, JPEG, EPS и собственный формат файла программы Photoshop.

Благодаря тому, что программа Photoshop воспринимает такое множество форматов, изображение для нее можно получить практически из любого источника: со сканера, из графического редактора, с компакт-диска, фотоснимка, видеоизображения и даже из других операционных систем. Также изображение может быть полностью создано в самой программе Photoshop.

Сканирование

С помощью сканирующего устройства или цифровой камеры и соответствующего программного обеспечения слайды, картинки или фотографии могут быть переведены в цифровую форму, так что компьютер сможет их воспринять, отображать, редактировать, а затем распечатать. Можно сканировать, используя непосредственно программу Photoshop или другое программное обеспечение, и сохранить данные в таком формате, который воспринимает Photoshop.

Для того чтобы с помощью сканера создать высококачественное изображение, которое в дальнейшем будет распечатано, внимательно выбирайте исходный материал. Некоторые сканеры уменьшают диапазон оттенков изображения и таким образом увеличивают его контрастность, поэтому лучше брать фотографию с хорошим балансом цвета. Если планируете самостоятельно сканировать изображение, тщательно продумайте значения параметров сканирования.

Качество отсканированного изображения частично зависит от типа используемого сканера. Если вы собираетесь значительно изменять изображение в программе Photoshop (например, применять фильтры или наносить большое количество штрихов кистью), вполне подойдет недорогой планшетный сканер, который создаст RGB-изображение. Для более точной передачи цвета и деталей изображения воспользуйтесь сканером с приставкой для работы со слайдами или слайд-сканером, чтобы отсканировать и прозрачные оригиналы.

Если вам нужны высококачественные профессиональные изображения, отсканируйте ваш материал в сервисном центре на CCD-сканере с высоким разрешением, таком как Scitex Smart-Scanner, либо на барабанном сканере. Сканеры последних моделей могут отображать широкий диапазон цвета и тени и улавливать едва различимые отличия в яркости, даже в темных областях. Обычно они создают CMYK-изображения, имеющие большой размер.

Основные сведения о программном обеспечении для сканирования

Обычно программное обеспечение для сканирования предлагает множество опций. Наиболее важные, присутствующие (под разными названиями) практически во всех программах, описаны ниже. Качество и размер отсканированного файла определяются указанными режимом, разрешением и масштабом, а также тем, будете ли вы обрезать изображение.

Поместив фотографию или рисунок в сканер, щелкните по кнопке Preview (Предварительный просмотр) или PreScan (Предварительная информация о сканировании).

Рис. 3.5. Разрешение 72 ppi

Рис. 3.6. Разрешение 150 ppi

Рис. 3.7. Разрешение 300 ppi

Прежде чем начинать сканирование, укажите значение параметра Scan mode (Режим сканирования). Выберите Black-and-White Line Art (Черно-белый), не дающий никаких оттенков серого, Grayscale (Полутоновой) или Color (Цветной), воспроизводящий миллионы цветов, если они имеются на изображении. Файл изображения, отсканированного в цвете, будет примерно в три раза больше по размеру, чем файл, полученный в режиме Grayscale.

Разрешение сканера измеряется в пикселах на дюйм (ppi) и задается параметром Resolution (Разрешение) - см. рис. 3.5-3.7. Чем выше разрешение изображения, тем больше точек, а значит, и информации о деталях изображения оно содержит. Но размер файла в этом случае также будет больше.

Чтобы сэкономить ресурсы компьютера, выберите минимальное разрешение, которое позволит получить желаемое качество при выводе изображения на выбранное устройство. Не указывайте разрешение выше, чем вам действительно нужно: размер изображения будет больше, чем необходимо, понадобится больше времени для его отображения на экране, в сети или при печати, но при этом вы не получите какого-либо улучшения качества. С другой стороны, при слишком низком разрешении распечатанное изображение выглядит грубым, неровным и нечетким [Как показывает опыт, оптимальным разрешением для сканирования фотографий является 200-300 ppi, а для полиграфических оригиналов — 600 ppi.].

Прежде чем выбрать разрешение для печати изображения, узнайте в типографии, какое разрешение имеет установленное там печатающее или фотонаборное устройство, а также какая будет использоваться линиатура растра. (Разрешение сканера отличается от разрешения устройства вывода.)

Обычно для полутонового изображения следует задавать разрешение, в полтора раза превышающее линиатуру растра (количество линий на дюйм) вашего устройства вывода, или в два раза превышающее линиатуру растра цветного изображения. Высокое разрешение сканера (600 ppi или больше) требуется для штрихового рисунка [Высокое разрешение необходимо также применять для сканирования полиграфической продукции, так как это позволит удалить полиграфический растр с минимальными потерями,]. Например, если типография собирается использовать для черно-белой печати 133 линии на экран, то следует задать разрешение сканера равным 200 ppi. Если материал к печати предполагается готовить с помощью фотонаборного устройства, у которого отсутствует технология полутонов, попросите порекомендовать вам соответствующее разрешение сканера. Рассчитать соответствующий размер файла вам поможет табл. 3.2 на стр. 98.

Если вы планируете использовать только часть изображения, необходимо выполнить кадрирование. Чтобы получить нужный фрагмент, переместите границы сканируемой области в окне предварительного просмотра. Обрезка изображения может значительно уменьшить размер будущего файла.

В некоторых случаях требуется определить масштаб. Если вы хотите увеличить размер изображения, выберите масштаб, превышающий 100%. При увеличении изображения или его разрешения в прогр'амме Photoshop или любом другом приложении изображение может оказаться размытым, так как программа использует математический метод интерполяции, чтобы создать дополнительные данные. Достоверная информация об изображении записывается только во время процесса сканирования.

Таблица 3.1. Инструменты и команды редактирования изображения, доступные в режиме 16 бит на канал

Инструменты | Команды из Подменю Adjustments | Другое
Marquee | Levels | Canvas Size
Lasso | Auto Levels | Histogram
Measure | Auto Contrast | Duplicate
Zoom | Curves | Image Size
Hand | Color Balance | Rotate Canvas
Eyedropper | Brightness/ Contrast | Некоторые фильтры
Slice | Hue/Saturation |
Color Sample | Channel Mixer |
Crop | Gradient Map |
Clone Stamp | Invert |
History Brush | Equalize |
Инструменты группы Pen |  |

После установки всех параметров можно начинать само сканирование. Щелкните по кнопке Scan (Сканировать) и выберите папку, где будет сохранен файл.

Режим 16 бит на канал

Сканер среднего качества может создавать цифровое представление изображения, в котором каждому каналу соответствует 12-14 битов данных. Сканеры последних моделей выдают представление, в котором на каждый канал приходится до 16 бит данных. Если у 16-битного сканера есть также широкий диапазон цветов и хорошая оптическая плотность (по крайней мере 3,3), то дополнительные пикселы будут более точно отображать цвет и тень, даже в темных областях. В программе Photoshop можно открыть CMYK-файл, в котором приходится 16 бит на канал (в общей сложности 64 бит на 4 канала). Вся исходная информация об изображении сохраняется, и изображение можно редактировать и корректировать. Однако перед печатью необходимо преобразовать 16-битное изображение в 8-битное при помощи команды Image > Mode $ 8 Bits/Channel (Изображение > Режим > 8 бит на канал). Следует помнить о двух ограничениях для таких изображений. Во-первых, 16-битное изображение может иметь только один слой. Во-вторых, не любую команду редактирования можно будет применять к такому изображению в программе Photoshop. Команды и инструменты, доступные в режиме 16 бит на канал, перечислены в табл. 3.1.

Для того чтобы сканировать с .помощью программы Photoshop, встраиваемый модуль сканера или модуль Twain должен находиться в папке Import-Export, внутри каталога Adobe Photoshop\Plug-lns.

Вызов модуля сканирования

При первом вызове модуля сканирования из подменю File > Import (Файл > Импорт) выберите вариант Twain_32 Source, укажите тип устройства (сканер) Twain (рис. 3.8) и затем выполните команду Twain_32 или WIA. Теперь для того, чтобы получить доступ к программе сканирования, надо будет просто выбрать в меню File пункт Import > Twain_32 или Import > WIA. Импорт изображений по протоколу WIA возможен только в Windows МЕ/2000/ХР при том условии, что драйвер сканера или цифровой фотокамеры поддерживает данную технологию. WIA (Windows Image Acquirisation) -дальнейшее развитие технологии TWAIN, предложенное Microsoft. WIA является более жестким и всеобъемлющим стандартом, чем TWAIN. Это касается даже интерфейса: WIA драйверы разных устройств имеют абсолютно одинаковый внешний вид. Кроме того, WIA драйвер обладает намного более высоким быстродействием. Однако WIA больше ориентирован на цифровые камеры, а драйверы сканеров существенно менее функциональны, чем фирменное программное обеспечение (рис. 3.9 и 3.10). Плюс ко всему, WIA не имеет функций, ориентированных на оцифровку слайдов и негативов. (Подробнее о модулях сканирования рассказано в документации к программе Photoshop.)

Рис. 3.8. Окно настройки параметров сканирования в TWAIN-драйвере

Рис. 3.9. Окно настройки параметров сканирования в WIA-драйвере

Рис. 3.10. Окно приема изображений с цифровой фотокамеры

Если у вашего сканера нет совместимого с программой Photoshop драйвера, отсканируйте изображение с помощью другого приложения, сохраните его в формате TIFF, а затем откройте в программе Photoshop, как и любое другое изображение.

Для того чтобы правильно рассчитать разрешение сканера, следуйте инструкциям, изложенным далее.

Сканирование в программе Photoshop

  1. Выберите модуль сканирования или выполните команду File > Import > Twain_32 (Файл > Импорт > Twain_32) или File > Import > WIA.
  2. Щелкните по кнопке Prescan (Предварительная информация о сканировании). Обратите внимание на то, как изменяется размер файла при изменении режима, разрешения и масштаба сканирования (см. рис. 3.8 и 3.9).
  3. Следуя инструкциям, данным выше (раздел «Основные сведения о программном обеспечении для сканирования» этой главы), выберите разрешение и режим сканирования.
  4. По желанию. Выберите другой масштаб сканирования и/или область изображения в окне предварительного просмотра.
  5. Щелкните по кнопке Scan (Сканировать). Отсканированное изображение появится в новом окне без названия.
  6. Сохраните изображение (см. раздел «Сохранение файлов» этой главы). Если необходима коррекция цвета, обратитесь к главе 22, раздел «Воспроизведение цвета». Если вы собираетесь повернуть изображение, прочтите главу 4, раздел «Поворот изображения на определенный угол».

Определение правильного разрешения при сканировании или для существующего изображения

Разрешение изображения в программе Photoshop, как и любого другого растрового изображения, не связано с разрешением монитора, так что оно может быть задано для конкретного устройства вывода с изменением размера файла или без него.

Если масштаб просмотра в программе Photoshop равен 100%, изображение, разрешение которого превосходит разрешение монитора, будет выглядеть на экране больше, чем при печати.

Всегда лучше сканировать изображение именно с теми значениями размера и разрешения, которые необходимы для устройства вывода.

  1. Создайте новый RGB-документ с помощью команды File > New (Файл > Новый), задайте его ширину и длину, выберите разрешение изображения 72 ppi, затем щелкните по кнопке ОК (на шаге 5 разрешение изображения будет подкорректировано).
  2. Откройте окно Image > Image Size (Изображение > Размер изображения).
  3. В правой части окна щелкните по кнопке Auto (Авто).
  4. Введите в поле Descreen (или Screen, в разных драйверах принряты разные названия) линиатуру растра устройства вывода, измеряемую числом линий на дюйм (lpi - lines per inch), то есть то значение, которое будет использовать типография (рис. 3.11). В целом ряде программ сканирования фильтр Descreen не имеет настроек, его можно только включить или выключить. Иногда для подавления муара и полиграфического растра в программах сканирования предусмотрены фильтры размытия. Так что данный аспект необходимо уточнить в документации на сканер.
  5. Поставьте переключатель Quality (Качество) в положение Draft (Обычное), что соответствует 1хлиниатура растра, Good (Хорошее) - 1,5хлиниатура растра или Best (Лучшее) - 2хлиниатура растра.
  6. Щелкните по кнопке ОК.
  7. Запишите значение поля Resolution (Разрешение), расположенного в группе Document Size (Размер документа) окна Image Size. Именно это значение и следует ввести при сканировании изображения.

Рис. 3.11. Изменение размера изображения

Если вы планируете в дальнейшем увеличивать/уменьшать масштаб изображения, необходимо умножить разрешение на этот масштаб, чтобы получить верное значение разрешения сканера. Но если вы изменяете масштаб изображения в процессе сканирования, ничего умножать не нужно.

  8. Щелкните по кнопке ОК. Теперь у изображения правильное разрешение.

В табл. 3.2 и 3.3 приведены справочные сведения, которые помогут вам определить размеры файлов отсканированных изображений и потенциальное количество уровней серого при различных значениях разрешения устройств вывода и линиатуры растра.

Таблица 3.2. Размеры файлов отсканированных изображений

Размер (в дюймах) | PPI (разрешение) | Черно-белое (1 бит) | Полутоновое (8 бит) | Цвет CMYK (24 бита)
2x3 | 150 | 17 К | 132 К | 528 К
 | 300 | 67 К | 528 К | 2.06 MB
4x5 | 150 | 56 К | 440 К | 1.72MB
 | 300 | 221 К | 1.72 MB | 6.87 MB
8x10 | 150 | 220 К | 1.72 MB | 6.87 MB
 | 300 | 879 К | 6.87 MB | 27.50 MB

Размеры указаны для однослойного файла в формате TIFF без каких-либо альфа-каналов.

Таблица 3.3. Потенциальное количество уровней серого при различных значениях разрешения устройств вывода и линиатуры растра

Разрешение устройства Линиатура растра (LPI)
 | вывода (DPI) | 60 | 85 | 100 | 133 | 150
Лазерные принтеры | 300 600 | 26 101 | 13 51 | 37 | 21 |
Фотонаборные устройства | 1270 2540 | 256* | 224 256* | 162 256* | 92 256* | 72 256*

Узнайте в типографии, какую линиатуру растра необходимо установить при создании файла изображения. Также выясните в отделе допечатной подготовки, какое разрешение следует указать для фотонаборного устройства. Некоторые фотонаборные устройства могут иметь разрешение более 2540 dpi. Заметьте, что при увеличении значения линиатуры растра и постоянном разрешении число оттенков серого падает.

Принтеры PostScript Level 2 могут создать максимум 256 оттенков серого. А принтеры PostScript Level 3 предоставляют большее количество оттенков.

Разрешение для Web-графики

При создании изображения для сети сначала оцените примерный размер окна браузера пользователя, затем рассчитайте, какую часть окна вы хотите закрыть данным изображением. Сначала определите, какое разрешение монитора скорее всего будет у пользователя сети. По сведениям, представленным на Web-сайте websnapshot. com, создатели которого отслеживают такую информацию, у более чем половины мониторов разрешение составляет 800x600 пикселов. Если вычесть пространство, занимаемое панелями меню, полосой прокрутки и другими управляющими элементами, являющимися неотъемлемой частью интерфейса, останется «холст» размером 740x460 пикселов. Однако большинство пользователей сети не заполняют весь экран окном браузера, так что рассчитывать на большее, чем 660x420, не приходится.

Поэтому создайте пустой документ с разрешением 660x420 пикселов, 72 пиксела на дюйм и используйте его как шаблон. При работе расположите документ в виде фона, чтобы при создании изображений для Web-страницы знать, какую часть экрана он занимает.

Использование строки состояния

При работе в системе Windows выберите Window > Show Status Bar (Окно > Показать строку состояния), чтобы отобразить строку состояния, или Hide Status Ваг (Спрятать строку состояния), чтобы скрыть ее.

Если во всплывающем меню строки состояния, расположенной внизу окна приложения/изображения, отмечен пункт Document Sizes (Размеры документа), в строке состояния показывается размер файла для изображения, в котором слои объединены (первая цифра), и размер файла для многослойного изображения (вторая цифра) -рис. 3.12.

Рис. 3.12. Меню для выбора информации, отображаемой в строке состояния

Если активизирована опция Document profile (Профиль документа), то в строке состояния отображается цветовой профиль документа, если же документ не содержит какого-либо профиля, появится слово «Untagged».

При выборе пункта Scratch Sizes (Объем памяти) в строке состояния отображается размер пространства, занимаемого открытыми в данный момент документами (слева) и объем оперативной памяти, доступной в данный момент программе Photoshop (справа). Если первая цифра превышает вторую, значит, программа Photoshop использует виртуальную память.

Выбрав опцию Efficiency (Эффективность), в строке состояния вы увидите долю времени, в течение которого программа работает в оперативной памяти. Если эта доля меньше 100%, значит, используется временная область на диске.

При выборе пункта Current Tool (Текущий инструмент) отображается имя инструмента, используемого в данный момент.

Кроме того, нажав и удерживая кнопку мыши над строкой состояния, вы сможете предварительно просмотреть страницу, то есть увидеть, как изображение соотносится с размером листа бумаги (включая маркеры, управляющие печатью, если таковые имеются).

Размер файла

При работе в Windows, чтобы узнать действительный размер файла изображения, с помощью программы Windows Explorer откройте папку, в которой находится интересующий вас файл, и посмотрите в колонку Size (Размер) - рис. 3.13. Для получения более точной цифры щелкните правой кнопкой мыши по пиктограмме файла и в появившемся меню выберите пункт Properties (Свойства).

Независимо от того, какая опция выбрана во всплывающем меню строки состояния, всегда можно, нажав клавишу Alt, нажать и удерживать кнопку мыши над строкой состояния, чтобы вывести на экран информацию о размерах изображения, количестве каналов, режиме и разрешении.

Создание нового изображения

  1. Выберите File > New (Файл > Новый) или воспользуйтесь комбинацией клавиш Ctrl+N.
  2. Введите какое-либо имя в поле Name (Имя)-рис. 3.14.
  3. В выпадающих меню, расположенных рядом с полями Width (Ширина) и Height (Высота), выберите единицу измерения.
  4. Введите значения параметров Width и Height.
  5. Введите значение параметра Resolution (Разрешение), необходимое для вывода изображения независимо от того, будет ли оно выводиться на фотонаборное устройство или передаваться по сети (вопросы выбора разрешения рассматривались в этой главе выше).
  6. Из всплывающего меню Mode (Режим) выберите режим изображения. Позднее можно будет преобразовать изображение в другой режим (подробнее о режимах см. главу 2, раздел «Режимы изображения»). .
  7. Поставьте переключатель Contents (Содержимое) в положение White (Белый) или Background Color (Фоновый цвет). О том, как выбрать фоновый цвет, рассказано в главе 10. Либо отметьте опцию Transparent (Прозрачный), если хотите, чтобы фон стал слоем изображения.

Рис. 3.13. Окно со сведениями о файлах

Рис. 3.14. Окно параметров нового изображения

Рис. 3.15. Окно нового безымянного изображения

Изображение, которое содержит один или более слоев, может быть сохранено только в форматах Photoshop, PDF или Advanced TIFF. Если вы собираетесь экспортировать файл в другое приложение, необходимо сохранить копию изображения с объединенными слоями в другом формате, так как только некоторые приложения могут воспринимать прозрачность слоя. (Подробнее о слоях и прозрачности см. главы 7 и 14.)

  8. Щелкните по кнопке ОК (клавиша Enter). Появится окно изображения (рис. 3.15).

Если хотите, чтобы значения, вводимые в окне New, совпадали со значениями для другого открытого документа, при открытом окне New в нижней части меню Window (Окно) выберите имя изображения, обладающего требуемыми свойствами.

Если какое-либо изображение из программ Photoshop или Illustrator находится в буфере обмена, то в окне New автоматически будут отображены его (изображения) размеры. Для того чтобы предотвратить это, при вызове команды меню File > New держите нажатой клавишу Alt.

Открытие изображения в программе Photoshop

Для того чтобы открыть файл Adobe Illustrator, следуйте инструкциям, приведенным в разделах «Открытие файлов в формате EPS, PDF или программы Illustrator как нового изображения» или «Размещение файлов в формате EPS, PDF или программы Illustrator в существующем изображении Photoshop» данной главы.

  1. Выберите команду меню File > Open (Файл > Открыть), File > Browse (Файл > Просмотр) или воспользуйтесь комбинацией клавиш Ctrl+O.
  2. Выделите файл, который хотите открыть (рис. 3.16). Если изображение было сохранено с уменьшенной копией для предварительного просмотра, щелкните по кнопке Show Preview (Предварительный просмотр), чтобы увидеть образец изображения. В случае открытия с помощью команды File > Browse все изображения в поддерживаемых форматах будут показаны в виде их уменьшенных копий, и достаточно просто щелкнуть мышью по необходимому (рис. 3.17).

    Имейте в виду, что построение миниатюр может занять некоторое время, при большом количестве изображений в каталоге весьма значительное.

    Для того чтобы были показаны файлы всех форматов, следует из выпадающего меню Files of type (Типы файлов) выбрать вариант All Formats (Все форматы).

    Как только изображение открыто, его можно сохранять в любом из поддерживаемых программой Photoshop форматов.

Если имя файла, который вы хотите открыть, не появляется в списке файлов, это значит, что встроенный модуль для данного формата не установлен для программы Photoshop. Установите его.

  3. Выделите имя файла и щелкните по кнопке Open (Открыть) или дважды щелкните по имени файла.

Рис. 3.16. Открытие файла

Рис. 3.17. Открытие файла с помощью команды Browse

Рис. 3.18. Значок файла в формате Photoshop в окне программы Windows Explorer

В случае несовпадения профилей действуйте согласно рекомендациям, данным в главе 2, раздел «Создание собственной системы управления цветом».

Для некоторых форматов может появиться еще одно диалоговое окно. Например, если открывать EPS, Adobe Illustrator или PDF-файл, который еще не был преобразован из векторной формы в растровую, появится диалоговое окно Rasterize Generic Format (Растеризация формата). В этом случае обратитесь к разделу «Открытие файлов в формате EPS, PDF или программы Illustrator как нового изображения» этой главы.

Для открытия некоторых форматов требуются специальные встроенные модули, например Scitex Ctrl или PICT Resource. Получить доступ к ним можно, выбрав команду меню File > Import (Файл > Импорт).

Для того чтобы указать конкретный формат файла при его открытии, выполните команду меню File > Open As (Файл > Открыть как) и из выпадающего меню выберите необходимый формат, затем щелкните по кнопке Open (Открыть).

Для быстрого перехода между открытыми окнами изображений воспользуйтесь «горячими» клавишами Ctrl+Tab.

Для того чтобы снова открыть файл, который недавно был закрыт, выберите его имя из подменю File > Open Recent (Файл > Недавно открытые).

Миниатюры

В Windows для того, чтобы создать миниатюрные копии изображений для программы Проводник (Windows Explorer), которые будут отображаться, когда в меню Views (Вид) выбрана опция Large Icon (Крупные значки), устанавливайте флажок Save Thumbnail (Сохранить образец) при сохранении файлов. Чтобы создать миниатюры, отображаемые в окне Open (Открыть), для всех последовательно сохраняемых файлов, откройте окно Edit > Preferences > Saving Files (Правка > Установки > Сохранение файлов), затем выберите в поле Image Previews (Предварительный просмотр изображений) вариант Always Save (Всегда сохранять) - см. рис. 3.19. Миниатюра появится только в том случае, если файл изображения имеет расширение PSD, JPG, PDF или TIF. Чтобы при сохранении файлов создавать миниатюры только для некоторых из них, выберите в поле Image Previews (Предварительный просмотр изображений) вариант Ask When Saving (Спрашивать при сохранении). При сохранении изображения размером в несколько мегабайт с возможностью предварительного просмотра может увеличиться размер файла. Чтобы создать образцы для всех последовательно сохраняемых. изображений, которые будут впоследствии показаны в диалоговом окне Open (Открыть), установите флажок Windows Thumbnail (Миниатюра Windows).

Открытие файла Kodak Photo CD

В программе Photoshop файлы в формате Kodak Photo CD открываются с помощью диалогового окна Kodak PCD Format (Формат Kodak PCD). Изображение в формате Photo CD может быть преобразовано в представление RGB или Lab Color.

  1. Выберите команду меню File > Open (Файл > Открыть) или воспользуйтесь комбинацией клавиш Ctrl+O.
  2. Найдите файл в формате Photo CD и дважды щелкните по его имени или выделите имя файла в формате Photo CD и щелкните по кнопке Open (Открыть).

Рис. 3.19. Установки операции сохранения файлов в системе Windows

  3. В группе параметров Source Image (Исходное изображение), показанных на рис. 3.20, выберите значение Resolution (Разрешение). Изображение размером 768x512 пикселов займет примерно площадь 10,5x7 дюймов. Ширина и высота изображения появятся во всплывающем меню Resolution (Разрешение). Выберите профиль устройства ввода из всплывающего меню Profile (Профиль). В поле Image Info (Информация об изображении) можно получить информацию о типе пленки и сканера.
  4. В группе параметров Destination Image (Целевое изображение) укажите разрешение для открытого изображения. Эта величина в совокупности с указанными размерами изображения будет определять размер изображения на экране. Выберите цветовое пространство (RGB или Lab) для открытого изображения. Установите в нужное положение переключатель Orientation (Ориентация).
  5. Щелкните по кнопке ОК. Изображение будет открыто в программе Photoshop.

Профили файлов Kodak

Компания Kodak использует модели 4045 и 4050 устройства считывания с пленки, а также версию 3.4 профилей преобразования PhotoCD (табл. 3.4).

Таблица 3.4. Профили файлов Kodak

Профиль | Применение
Photo CD 4050E-6 V3.4 | Сканирование Ektachrome на модели 4050
Photo CD 4050K-14 V3.4 | Сканирование Kodachrome на модели 4050
Photo CD Color Negative V3.0 | Сканирование цветных негативов на сканерах младших моделей или без указания модели
Photo CD Universal E-6 V3.2 | Сканирование Universal Ektachrome на сканерах младших моделей или без указания модели
Photo CD Universal K-14 V3.2 | Сканирование Universal Kodachrome на сканерах младших моделей или без указания модели

Рис. 3.20. Диалоговое окно DCP Format в системе Windows

Открытие файлов в формате EPS, PDF или программы Illustrator как нового изображения

Когда файл в формате EPS или Adobe Illustrator открывают или размещают в программе Photoshop, его преобразуют из исходного объектно-ориентированного формата в растровый формат Photoshop. Следуйте нижеприведенным инструкциям, чтобы открыть файл в формате EPS или Adobe Illustrator как новый. Либо обратитесь к разделу «Размещение файлов в формате EPS, PDF или программы Adobe Illustrator в существующем изображении Photoshop» этой главы, чтобы разместить EPS-файл в существующем файле Photoshop.

Для того чтобы открыть одностраничный PDF-файл, можно воспользоваться командой Open (Открыть) (см. ниже) или Place (Разместить), о чем написано в разделе «Размещение файлов в формате EPS, PDF или программы Adobe Illustrator в существующем изображении Photoshop». А для того чтобы открыть многостраничный PDF-файл как несколько изображений в формате Photoshop, выберите команду File > Automate > MultiPage PDF to PSD (Файл > Автоматизация > Многостраничный PDF в PSD). Подробнее об этом рассказано в главе 20, раздел «Преобразование файла формата PDF в формат программы Photoshop».

В программе Photoshop 7 файлы программы Illustrator 9 и 10 представлены как имеющие формат.Generic PDF (не EPS).

  1. Выберите команду меню File > Open (Файл > Открыть) или воспользуйтесь комбинацией клавиш Ctrl+O.
  2. Если имя файла отсутствует в списке, из выпадающего меню Files of type (Тип файлов) выберите All Formats (Все форматы).

Рис. 3.21. Загрузка многостраничного PDF-файла

Рис. 3.22. Окно для ввода номера страницы

Рис. 3.23. Диалоговое окно Rasterize Generic EPS format

Рис. 3.24. Диалоговое окно Rasterize Generic PDF format

  3. Найдите и выделите файл, который необходимо открыть, потом щелкните по кнопке Open (Открыть) или дважды щелкните по имени файла.

При открытии PDF-файла, содержащего более одной страницы, будет открыто другое диалоговое окно (рис. 3.21). Щелкните по стрелке «вперед» или «назад», чтобы найти страницу, которую хотите открыть, затем щелкните по кнопке ОК. Либо щелкните по кнопке Go to page... (Перейти к странице...), введите номер страницы и дважды щелкните по кнопке ОК (рис. 3.22).

  4. По желанию. В диалоговом окне Rasterize Generic EPS (или PDF) format (Растеризация формата Generic EPS (или PDF)) установите флажок Constrain Proportions (Сохранять пропорции), чтобы сохранялось соотношение высоты и ширины изображения (рис. 3.23-3.24).
  5. По желанию. Из ниспадающих меню, расположенных рядом с полями Width (Ширина) и Height (Высота), выберите единицы измерения и введите размеры изображения.
  6. В поле Resolution (Разрешение) введите разрешение, необходимое для вашего изображения. Ввод правильного значения перед преобразованием в растровое представление улучшит вид готового изображения.
  7. Из всплывающего меню Mode (Режим) выберите режим изображения (см. главу 2, раздел «Режимы изображения»).
  8. Установите флажок Anti-aliased (Сглаживание), чтобы сгладить неровности и смягчить границы переходов.
  9. Щелкните по кнопке ОК.

Если в PDF-файле содержатся установки, касающиеся безопасности, их необходимо отключить с помощью программы Acrobat Exchange прежде, чем открывать файл.

PDF- и EPS-файлы открываются с прозрачным фоном. Для того чтобы получить белый фон, создайте новый слой, сделайте фоновый цвет белым (или каким-либо другим по вашему желанию), затем выберите команду Layer > New > Background from Layer (Слой > Новый > Фон из слоя).

Размещение файлов в формате EPS, PDF или программы Adobe Illustrator в существующем изображении Photoshop

Когда вы размещаете объектно-ориентированное (векторное) изображение в программе Photoshop, оно становится растровым и воспроизводится в соответствии с разрешением Photoshop-изображения. Чем выше разрешение, тем лучше результат рендеринга.

Также можно перетащить контур из окна изображения программы Illustrator в окно изображения программы Photoshop, где он появится на новом слое.

  1. Откройте изображение в программе Photoshop.
  2. Выберите команду меню File > Place (Файл > Разместить).
  3. Найдите и выделите файл, который хотите открыть (рис. 3.26). В случае размещения многостраничного PDF-файла выберите страницу и щелкните по кнопке ОК (см. раздел «Открытие файла в формате EPS, PDF или программы Illustrator как нового изображения» этой главы).
  4. Щелкните по кнопке Place (Разместить). Поверх изображения появится рамка. Если необходимо, сделайте паузу, чтобы дать возможность новой картинке появиться внутри нее (рис. 3.27).

Рис. 3.25. Диалоговое окно Paste

Рис. 3.26. Диалоговое окно Place

Рис. 3.27. Размещение слова «Delphi», созданного в программе Adobe Illustrator, в файле Photoshop

Рис. 3.28. Импортирование музыкальных нот и других фигур, созданных в программе Illustrator, в программу Photoshop

  5. По желанию. Выполните любой из нижеследующих шагов (с помощью команды Undo можно отменить любой из них).

    Для изменения размера вновь размещенного изображения перетащите манипулятор ограничивающей рамки. Нажав клавишу Shift, можно сохранить пропорции изображения при изменении его размеров.

    Для того чтобы переместить изображение, щелкните мышью внутри рамки и, удерживая кнопку мыши нажатой, перетащите изображение.

    Если вы хотите повернуть изображение, разместите курсор за пределами ограничивающей его рамки и тащите мышь с нажатой кнопкой. Можно переместить точку центра, чтобы повернуть изображение относительно других осей.

  6. Для того чтобы зафиксировать положение изображения, нажмите клавишу Enter или дважды щелкните внутри ограничивающей его рамки. Изображение появится на новом слое (рис. 3.28).

Для удаления размещенного изображения нажмите клавишу Esc до или во время преобразования его в растровое. Если данная операция уже выполнена, перетащите слой изображения на кнопку Trash (Удалить) на палитре Layers (Слои).

Сохранение файлов

Инструкции по сохранению файлов в форматах EPS, DCS, PICT и TIFF вы найдете в главе 22. О форматах GIF и JPEG рассказывается в главе 23.

Сохранение нового изображения

  1. Выберите команду File > Save (Файл > Сохранить) или воспользуйтесь комбинацией клавиш Ctrl+S.
  2. В поле File name (Имя файла) введите имя файла.
  3. Выберите месторасположение файла. Для того чтобы указать другую папку или диск, выберите ее/его из ниспадающего меню, расположенного в верхней части диалогового окна.
  4. Из всплывающего меню Save As (Сохранить как) выберите формат файла (рис. 3.29). Многослойные изображения могут быть сохранены только в форматах Photoshop, Advanced TIFF и Photoshop PDF.
  5. В группе параметров Save (Сохранить) установите необходимые флажки; также можно поставить флажок Color: Embed Color Profile (Цвет: Встроенный цветовой профиль), если в файле содержится профиль, а формат, в котором вы его сохраняете, поддерживает встроенные профили (подробнее об этом см. главу 2, раздел «Изменение или удаление цветового профиля документа»).
  6. Щелкните по кнопке Save (Сохранить).

Также если хотите, чтобы с каждым изображением, содержащим слои, автоматически сохранялась копия без слоев, установите флажок Maximize backwards compatibility in Photoshop formats (Максимальная совместимость форматов Photoshop). Это полезно, если изображение будет экспортировано в другое приложение.

Рис. 3.29. Диалоговое окно Save As

Сохранение слоев, векторов и эффектов

Форматы Photoshop, Advanced TIFF и Photoshop PDF - единственные форматы, в которых сохраняются следующие элементы:

  • несколько слоев и прозрачность слоя;
  • корректирующие слои;
  • редактируемые текстовые слои;
  • эффекты слоя;
  • сетки и направляющие линии;
  • ICC-профили системы управления цветом (в форматах PICT, JPEG, DCS и EPS также сохраняются профили);
  • режим изображения Lab (в форматах EPS и DCS тоже сохраняется этот режим).

Изображение в режиме Duotone не может быть сохранено в формате Advanced TIFF.

Объединяйте слои на копии изображения, а не на оригинале, чтобы потом можно было работать с многослойным изображением (см. в этой главе раздел «Сохранение нового изображения»).

При выполнении команды Save (Сохранить) предыдущая версия изображения замещается текущей.

Сохранение существующего изображения

Чтобы сохранить изображение, выберите команду File> Save (Файл > Сохранить) или воспользуйтесь комбинацией клавиш Ctrl+S.

Возврат к последней сохраненной версии

Выберите команду File > Revert (Файл > Обратить), чтобы восстановить последнюю сохраненную версию документа. Палитра History (История), о которой подробнее рассказано в главе 8, позволяет отменить несколько действий. Ее партнер - инструмент History Brush (Восстанавливающая кисть) - используется для восстановления отдельных областей изображения. Команда Revert отображается на палитре History в виде отдельного события, так что ее можно при необходимости отменить, щелкнув по более раннему событию.

Сохранение новой версии изображения

Используя команду Save As (Сохранить как), можно сохранить изображение в другом режиме или воспользоваться копией для вариаций с дизайном. Например, можно сохранить версию изображения в режиме CMYK, а исходное изображение оставить в режиме RGB.

  1. Выберите File > Save As (Файл > Сохранить как) или воспользуйтесь комбинацией клавиш Ctrl-H Shift+S.
  2. Введите новое имя или измените существующее в поле File name (Имя файла) (рис. 3.30). Установите флажок Use Lower Case Extension (Расширение строчными буквами), чтобы расширение было написано маленькими буквами.
  3. Выберите папку, в которой будет сохранена новая версия изображения.
  4. Из всплывающего меню Save As (Сохранить как) выберите другой формат файла. Доступными будут только те форматы, которые поддерживают текущий режим изображения.

Если выбранный формат не поддерживает многослойных изображений, опция Layers (Слои) автоматически станет недоступной, а сохраненное изображение не будет иметь слоев.

Рис. 3.30. Диалоговое окно Save As

  5. По желанию поставьте флажки в группе параметров Save (Сохранить), а также флажок Embed Color Profile (Встроить цветовой профиль), если эта опция доступна (подробнее об этом см. главу 2, раздел «Изменение или удаление цветового профиля документа»).

Установите флажок Save As a Copy (Сохранить в виде копии), чтобы сохранить копию файла и продолжить работу с оригиналом.

  6. Щелкните по кнопке Save (Сохранить). О сохранении файлов в форматах EPS, TIFF, PICT рассказано в главе 22, разделы «Сохранение изображения в формате EPS», «Сохранение изображения в формате TIFF» и «Сохранение RGB-изображения в формате BMP или PICT». По поводу других форматов обратитесь к справочнику пользователя по Adobe Photoshop. Новая версия файла останется открытой, исходное изображение будет автоматически закрыто.

Если вы не изменили имя файла и щелкнули по кнопке Save (Сохранить), появится окно с предупреждающим сообщением. Щелкните по кнопке Replace (Заменить), чтобы заменить исходный файл, или по кнопке Cancel (Отмена), чтобы вернуться к диалоговому окну Save As (Сохранить как).

Управление изображениями

В этой части главы вы узнаете, как изменить масштаб просмотра изображения, переместить изображение в окне, переключить режимы отображения картинки на экране, одновременно показывать изображение в двух окнах и изменить цвет рабочего холста.

Можно показывать изображение в окне целиком или увеличить какую-либо его часть, чтобы работать с деталями (рис. 3.31). Масштаб просмотра в процентах указан в трех местах: в заголовке окна изображения, в левом нижнем углу окна приложения/ изображения и в левом нижнем углу палитры Navigator (Навигация). Масштаб просмотра изображения никак не влияет на размер изображения при печати.

Изменение масштаба просмотра с помощью палитры Navigator

Введите новое значение масштаба в процентах или в виде отношения (например, 1:1 или 1:4) в левом нижнем углу окна изображения, затем нажмите клавишу Enter -см. рис. 3.32а. Если необходимо сохранить данное поле активным, воспользуйтесь комбинацией клавиш Shift+Enter. Щелкните по кнопке Zoom out (Уменьшить масштаб), чтобы уменьшить масштаб видимой части изображения (рис. 3.326). Перемещайте ползунок Zoom slider (Ползунок масштабирования), чтобы изменить масштаб видимой части изображения в ту или другую сторону (рис. 3.32в). Щелкните по кнопке Zoom in (Увеличить масштаб), если надо увеличить масштаб видимой части изображения (рис. 3.32г). Чтобы переместить изображение в окне, перетаскивайте

Команда Duplicate

Команда Image > Duplicate (Изображение > Дублировать) копирует изображение и все его слои, маски слоя и каналы и загружает информацию в память. Копия файла не сохраняется на диске до тех пор, пока не выбрана команда File > Save (Файл > Сохранить). Преимущество команды Duplicate (Дублировать) состоит в том, что на копии файла можно пробовать различные вариации, не затрагивая при этом исходный файл. Однако копию файла следует использовать с предосторожностями, так как если программа зависнет или произойдет сбой системы, вы потеряете все, что находится в памяти, включая и копию изображения!

Рис. 3.31. Увеличенная часть изображения

Рис. 3.32. Палитра Navigator

Для того чтобы изменить цвет границ поля зрения на палитре Navigator (Навигация), из меню палитры выберите элемент Palette Options (Опции палитры), затем из всплывающего меню Color (Цвет) или щелчком мыши выберите образец цвета, а затем в окне Color Picker выберите нужный оттенок.

«Горячие» клавиши для изменения масштаба просмотра

Изменять масштаб просмотра удобнее всего с помощью «горячих» клавиш (табл. 3.5).

рамку поля зрения (рис. 3.32д). Чтобы увеличить ограниченную рамкой часть изображения, перетаскивайте мышь при нажатой клавише Ctrl.

Также масштаб просмотра можно изменить, дважды щелкнув по значению в левом нижнем углу окна приложения/изображения. Введите желаемое значение и нажмите клавишу Enter.

Изменение масштаба просмотра изображения с помощью инструмента Zoom

  1. Выберите инструмент Zoom (Масштаб) или нажмите клавишу Z.

Таблица 3.5. «Горячие» клавиши для изменения масштаба просмотра

Операция | «Горячие» клавиши
Увеличить (не изменяя размеров окна) | Сtrl+«плюс»
Уменьшить (не изменяя размеров окна) | Сtrl+« минус»
Увеличить (изменяя размеры окна) | Ctrl+Alt+«плюс»
Уменьшить (изменяя размеры окна) | Сtrl+АН+«минус»
Режим Actual pixels / масштаб 1 00% | Ctrl+Alt+О (ноль)
Подогнать по размеру экрана | Ctrl+О (ноль)

Рис. 3.33. Панель опций инструмента Zoom

  2. На панели опций снимите флажок Resize Windows to Fit (Изменять размер окон для подгонки), чтобы размер окон не изменялся при изменении масштаба просмотра (рис. 3.33). Установка флажка Ignore Palettes (Игнорировать палитры) позволит раскрыть изображение во весь экран.
  3. Для того чтобы увеличить изображение, щелкните в окне изображения (рис. 3.34) или нарисуйте рамку вокруг области, которую хотите увеличить.

Чтобы уменьшить масштаб просмотра, щелкните в окне изображения при нажатой клавише Alt - рис. 3.35.

Чтобы увидеть реальный размер изображения, щелкните по кнопке Actual Pixels (Реальный размер), расположенной на панели опций.

Размер изображения на экране будет равен реальному размеру напечатанного изображения только тогда, когда масштаб будет равен 100%, и разрешения изображения и монитора будут совпадать.

Если вы хотите отобразить изображение целиком так, чтобы его размер был максимально большим, то есть заполняющим окно приложения/изображения, на панели опций щелкните по кнопке Fit On Screen (Подогнать по размеру экрана) или воспользуйтесь комбинацией клавиш Ctrl+0.

Щелкните по кнопке Print Size (Размер при печати), расположенной на панели опций, чтобы изображение было отображено так, как будет выглядеть при печати.

Рис. 3.34. Увеличение масштаба просмотра с помощью инструмента Zoom (знак «плюс» в пиктограмме курсора)

Рис. 3.35. Уменьшение масштаба просмотра (знак «минус» в пиктограмме курсора)

Рис. 3.36. Перемещение рамки поля зрения на палитре Navigator

Рис. 3.37. Перемещение изображения с помощью инструмента Hand

При нажатой комбинации клавиш Ctrl+пробел щелкните мышью или перетащите ее, чтобы увеличить изображение в то время, как активизирован другой инструмент или открыто диалоговое окно с возможностью предварительного просмотра. При нажатых клавишах Alt+пробел щелчком мыши можно уменьшить масштаб. Для того чтобы размеры окна автоматически изменялись при изменении масштаба просмотра с помощью «горячих» клавиш, в окне Edit > Preferences > General (Правка > Установки > Общие) установите флажок Keyboard Zoom Resizes Windows (Изменение размеров окна с клавиатуры).

Если же вам не нравится этот способ, можно воспользоваться более медленным вариантом: изменить масштаб просмотра, выбрав команду View > Zoom in или Zoom out (Вид > Увеличить или Уменьшить).

Перемещение увеличенного изображения в окне

Если полосы прокрутки неактивны, то изображение показано полностью, и нет никакой необходимости перемещать его.

Чтобы передвинуть изображение в окне, щелкните вне рамки поля зрения или переместите ее на палитре Navigator (Навигация) - рис. 3.36.

Можно также щелкнуть по стрелкам, направленным вниз/вверх, в полосе прокрутки, которая расположена в окне изображения. Перетащите скользящий указатель полосы прокрутки, чтобы быстро переместить изображение.

Еще один способ перемещения изображения: активизируйте инструмент Hand (Рука) и перетащите курсор в окне изображения (рис. 3.37).

В приложении найдите информацию о «горячих» клавишах для перемещения изображения в окне.

Изменение режима показа изображений на экране

Щелкните по кнопке Standard screen mode (Стандартный экран), расположенной в левом нижнем углу панели инструментов (рис. 3.38), или нажмите клавишу F, чтобы на экране присутствовало изображение, панель меню, палитры и полоса прокрутки. Это обычный режим работы программы Photoshop.

Если щелкнуть по кнопке Full screen mode with menu bar (Полноэкранный режим с панелью меню) или нажать клавишу F, изображение будет показано во весь экран без полос прокрутки, но при этом останутся панель меню и палитры (рис. 3.39). Область вокруг изображения будет серой. Это хороший способ увидеть изображение во всем его блеске.

После щелчка по кнопке Full screen mode (Полноэкранный режим) в правом нижнем углу панели инструментов или нажатия клавиши F (рис. 3.38) изображение будет показано во весь экран, при этом будут видны палитры, но не будет панели меню и полос прокрутки. Область вокруг изображения окажется ярко-черного цвета.

Нажмите клавишу Tab, чтобы показать/ скрыть панель инструментов и любые открытые палитры. Либо нажмите комбинацию клавиш Shift+Tab, чтобы показать/ скрыть только палитры, при этом оставив открытой панель инструментов.

С помощью инструмента Hand (Рука), который активизируется нажатием клавиши Н, или палитры Navigator (Навигация) можно переместить увеличенное изображение, если полосы прокрутки спрятаны. Нажмите и удерживайте клавишу пробела, чтобы воспользоваться инструментом Hand (Рука) в то время, как активизирован другой инструмент.

Рис. 3.38. Кнопки режимов отображения на панели инструментов

Рис. 3.39. Полноэкранный режим с панелью меню

Рис. 3.40. Показ изображения в двух окнах

Рис. 3.41. Изменение цвета рабочего холста при помощи инструмента Paint Bucket

Показ одного изображения в двух окнах

Количество изображений, которые могут быть открыты одновременно, зависит от доступной оперативной памяти и пространства на диске. Можно одновременно открыть одно и то же изображение в двух окнах: одно с большим масштабом, например 400%, чтобы редактировать мелкие детали изображения, и второе - с меньшим масштабом, например 100%, чтобы видеть изображение целиком. Или оставить изображение в режиме RGB в одном окне, а для этого же изображения в другом окне выбрать цветовое пространство View > Proof Setup > Working CMYK (Вид > Установки пробного отпечатка > Рабочий CMYK). Палитра History для обоих окон будет идентична.

  1. Когда изображение открыто, выберите пункт меню View > New View (Вид > Новый вид). То же самое изображение появится в другом окне (рис. 3.40).
  2. По желанию. Переместите любое из окон, перетащив заголовок, и/или измените размер окна.

Изменение цвета рабочего холста

Цвет рабочего холста одинаков для всех открытых изображений. Чтобы его изменить, следуйте инструкциям, приведенным ниже.

  1. Если необходимо, увеличьте окно изображения, так чтобы была видна хотя бы часть рабочего холста.
  2. Выберите основной цвет (см. начало главы 10).
  3. Воспользуйтесь инструментом Paint Bucket (Ведро с краской), активизировав его нажатием клавиши G или сочетания Shift+G.
  4. Нажав клавишу Shift, щелкните по холсту (рис. 3.41). Эту операцию нельзя отменить. Для того чтобы восстановить серый цвет, установленный по умолчанию, выберите 20% серого в качестве основного цвета из палитры Color (Цвет), затем снова щелкните по холсту, нажав клавишу Shift.

Закрытие изображения

Щелкните по кнопке закрытия, расположенной в верхнем правом углу окна изображения (рис. 3.42). Закрыть изображение можно также, выбрав команду File > Close (Файл > Закрыть) или нажав комбинацию клавиш Ctrl+W.

Если вы попробуете закрыть изображение, которое было изменено после последнего сохранения, появится окно с предупреждающим сообщением (рис. 3.43). Щелкните по кнопке Don't Save (He сохранять), чтобы закрыть файл без внесенных изменений, либо по кнопке Save (Сохранить), чтобы сохранить файл прежде, чем закрыть его, либо по кнопке Cancel (Отмена), чтобы не закрывать изображение.

Выход из программы Photoshop

При работе в Windows выберите команду меню File > Exit (Файл > Выход), или нажмите комбинацию клавиш Ctrl+Q), или щелкните по кнопке закрытия окна приложения.

Все открытые файлы Photoshop будут закрыты. Если какие-либо несохраненные изменения были внесены в открытый файл, то появится предупреждающее сообщение (рис. 3.44). Щелкните по кнопке Don't Save (He сохранять), чтобы закрыть файл без внесенных изменений, либо по кнопке Save (Сохранить), чтобы сохранить файл прежде, чем выйти из программы, либо по кнопке Cancel (Отмена), чтобы не закрывать программу.

Рис. 3.42. Кнопка закрытия окна

Рис. 3.43. Окно с предупреждающим сообщением при закрытии изображения

Рис. 3.44. Окно с предупреждающим сообщением при закрытии программы


  • Глава 4. Основные сведения о растровых изображениях
    • Изменение размеров изображения и разрешения
      • Изменение размеров изображения в пикселах при выводе на экран
      • Изменение размеров изображения при выводе на печать
      • Изменение разрешения изображения
      • Подгонка изображения по заданным размерам
      • Автоматическое изменение размеров изображения
      • Применение фильтра Unsharp Mask
    • Изменение параметров холста
      • Изменение размера холста
      • Кадрирование изображения с помощью рамки
      • Указание размеров и разрешения при обрезке изображения
      • Увеличение холста изображения с помощью инструмента Crop
      • Кадрирование изображения с помощью команды Crop
      • Обрезка изображения с помощью команды Trim
      • Переворачивание изображения
      • Поворот изображения на определенный угол

Глава №4.

Основные сведения о растровых изображениях

Рис. 4.1. Окно Image Size

В этой главе вы узнаете, как изменять размеры изображения и разрешение, как сделать изображение четче, изменить размер холста, обрезать изображение, переворачивать и поворачивать его.

В программе Photoshop при изменении размеров изображения с сохранением текущего разрешения (установлен флажок Resample Image (Отслеживать изменения)) происходит интерполяция, что ухудшает качество картинки. Вот почему всегда лучше сканировать или создавать изображение того размера, который вам нужен. Если же интерполяция неизбежна, то после примените фильтр Unsharp Mask (Маска нерезкости), чтобы повысить резкость изображения (см. раздел «Применение фильтpa Unsharp Mask» этой главы).

Изменение размеров изображения и разрешения

Изменение размеров изображения в пикселах при выводе на экран

  1. Выберите команду меню Image > Image Size (Изображение > Размер изображения).
  2. Убедитесь, что флажок Resample Image (Отслеживать изменения) установлен (рис. 4.1).
  3. Для того чтобы сохранить соотношение ширины и высоты изображения, не снимайте флажок Constrain Proportions (Сохранять пропорции).
  4. Установите разрешение равным 72 ppi.
  5. Введите новые значения параметров группы Pixel Dimensions (Размеры в пикселах): Width (Ширина) и/или Height (Высота).
  6. Щелкните по кнопке ОК.

Изменение размеров изображения при выводе на печать

  1. Выберите команду меню Image > Image Size (Изображение > Размер изображения).
  2. Установите флажок Constrain Proportions (Сохранять пропорции), если хотите сохранить соотношение ширины и высоты изображения (рис. 4.2). Если же хотите изменять ширину изображения независимо от высоты, снимите этот флажок.
  3. По желанию. Для того чтобы сохранить разрешение изображения, установите флажок Resample Image (Отслеживать изменения), показанный на рис. 4.2, и выберите один из методов интерполяции: Nearest Neighbour (Ближайший сосед), Bilinear (Билинейный) или Bicubic (Бикубический). Бикубическая интерполяция наименее негативно влияет на качество изображения.
  4. Из всплывающих меню полей Width (Ширина) и Height (Высота), расположенных в группе Document Size (Размер документа), выберите единицы измерения.

Рис. 4.2. Установка флажков в окне Image Size

  5. Введите новые значения в поля Width (Ширина) и Height (Высота). Если флажок Resample Image (Отслеживать изменения) не установлен, разрешение изменится.
  6. Щелкните по кнопке ОК.

Чтобы восстановить исходные установки окна Image Size (Размер изображения), нажмите клавишу Alt и одновременно щелкните по кнопке Reset (Восстановить).

Также для изменения размера и масштаба изображения при выводе на печать можно воспользоваться диалоговым окном, вызываемым командой File > Print with Preview (Файл > Печать с предварительным просмотром), но при этом разрешение изображения будет изменено.

Предварительный просмотр печати

Для того чтобы сопоставить размер изображения с размером листа бумаги, нажмите и удерживайте кнопку мыши, указывая на строку состояния, расположенную внизу окна изображения, либо выберите команду меню File > Print with Preview (Файл > Печать с предварительным просмотром). Если вы хотите показать на экране изображение такого размера, каким он будет при печати, воспользуйтесь пунктом меню View > Print Size (Вид > Размер при печати) - см. рис. 4.3.

Рис. 4.3. Предварительный просмотр печати

Преимущества высокого разрешения

После сканирования в изображении содержится определенное число пикселов, и его размеры и разрешение при печати взаимозависимы. При изменении разрешения или размеров изображения общее количество пикселов сохраняется в том случае, если в диалоговом окне Image > Image Size (Изображение > Размер изображения) снят флажок Resample Image (Отслеживать изменения). При установке этого флажка увеличение разрешения изображения (числа пикселов на дюйм) приведет к уменьшению размеров изображения при печати и наоборот.

Если у файла разрешение больше, чем нужно (более чем в два раза превышает лини-, атуру растра), можно «распределить» дополнительные пикселы по параметрам группы Document Size, сняв флажок Resample Image (теперь ширина, высота и разрешение взаимозависимы), и затем уменьшить разрешение до величины, в два раза превышающей линиатуру растра. Значения ширины и высоты автоматически увеличатся, размер файла и число пикселов останутся прежними, ни одного пиксела не будет добавлено или удалено из изображения. Если необходимо увеличить размеры изображения, установите флажок Resample Image (Отслеживать изменения) и введите значение в поле Width (Ширина). Значение высоты изменится пропорционально, увеличится размер файла и число пикселов, но для этого потребуется интерполяция, так что после нажатия кнопки ОК необходимо повысить резкость изображения, применив фильтр Unsharp Mask (Маска нерезкости). Подробнее об этом см. раздел «Применение фильтра Unsharp Mask» данной главы.

Изменение разрешения изображения

Если увеличить разрешение, то есть провести интерполяцию, установив флажок Resample Image (Отслеживать изменения), будут добавлены пикселы, увеличится размер файла, но резкость уменьшится. Если уменьшить разрешение, из файла будет удалена некоторая информация, и восстановить ее можно только с помощью палитры History до закрытия файла. Размытость изображения после проведения интерполяции будет видна только при печати изображения, на экране это заметить невозможно. Именно поэтому лучше сканировать или создавать изображение нужного размера. За подробными инструкциями по поводу того, как увеличить резкость изображения после интерполяции, обратитесь к разделу «Применение фильтра Unsharp Mask» этой главы. (Также см. гла-' ву 3, разделы «Основные сведения о программном обеспечении для сканирования» и «Определение правильного разрешения при сканировании или для существующего изображения»).

  1. Выберите команду меню Image > Image Size (Изображение > Размер изображения).
  2. Для того чтобы сохранить размеры изображения (ширину и высоту), установите флажок Resample Image (Отслеживать изменения) - см. рис. 4.4. Если необходимо сохранить общее число пикселов изображения, снимите этот флажок. Ширина и высота будут изменяться, чтобы общее число пикселов было сохранено.
  3. Введите какое-либо число в поле Resolution (Разрешение).
  4. Щелкните по кнопке ОК.

Рис. 4.4. Флажок Resample Image, управляющий интерполяцией изображения

Инструмент History Brush (Восстанавливающая кисть) не будет работать на изображении, полученном в результате интерполяции. Данное состояние изображения станет для этого инструмента исходным.

Рис. 4.5. Окно команды Fit Image

Подгонка изображения по заданным размерам

Команда Fit Image (Подогнать изображение) не влияет на разрешение изображения, только на его физические размеры. Воспользуйтесь этой командой, если хотите уменьшить изображение.

  1. Выберите команду File > Automate > Fit Image (Файл > Автоматически > Подогнать изображение) - см. рис. 4.5.
  2. Введите значения ширины или высоты в пикселах. Другое поле будет автоматически подкорректировано после того, как вы щелкнете по кнопке ОК, так что соотношение ширина/высота будет сохранено.
  3. Щелкните по кнопке ОК.

Автоматическое изменение размеров изображения

Команда Resize Image (Изменить размеры изображения) копирует изображение и автоматически изменяет размеры дубликата. Вы должны лишь установить значения в последовательно появляющихся диалоговых окнах, все остальное за вас сделает программа Photoshop.

  1. Выберите команду меню Help > Resize Image (Помощь > Изменить размеры изображения).
  2. Установите переключатель в положение Print (Печать) или Online (Онлайн), как показано на рис. 4.6, затем щелкните по кнопке Next (Дальше).
  3. Введите желаемый размер изображения при выводе (рис. 4.7), затем щелкните по кнопке Next (Дальше). Если на предыдущем шаге вы установили режим Online, щелкните по кнопке Finish (Готово). Для вывода изображения на печать выполните оставшиеся шаги.
  4. Отметьте предложенное значение или введите другую линиатуру растра в соответствии с указаниями типографии (рис. 4.8), затем щелкните по кнопке Next (Дальше).
  5. Передвиньте ползунок Quality (Качество), представленный на рис. 4.9, и обратите внимание на окончательный размер изображения, показанный в области Results (Результат). Если ниже было выведено какое-либо сообщение, прочитайте его. Если хотите продолжить, щелкните по кнопке Next (Дальше).
  6. Щелкните по кнопке Finish (Готово) (рис. 4.10) и сохраните изображение, размеры которого были изменены. Либо щелкните по кнопке Cancel (Отмена).

Рис. 4.6, Выбор позиции переключателя

Рис. 4.7. Ввод желаемого размера изображения при печати

Рис. 4.8. Ввод линиатуры растра

Рис. 4.9. Выбор желаемого качества изображения

Рис. 4.10. Завершение операции по изменению размера изображения

Рис. 4.11. Исходное изображение, немного нечеткое

Рис. 4.12. Параметры фильтра Unsharp Mask

Применение фильтра Unsharp Mask

Если вы изменили размеры или разрешение изображения при установленном флажке Resample Image (Отслеживать изменения), а затем перевели изображение в режим CMYK или как-то трансформировали, то изображение может стать менее четким из-за проведения интерполяции. Несмотря на название, фильтр Unsharp Mask (Маска нерезкости) производит эффект фокусировки. Он увеличивает контрастность между соседними точками, если они уже контрастируют друг.с другом. Можно указать следующие параметры фильтра: степень повышения резкости при помощи параметра Amount (Количество); количество окружающих пикселов, изменяемых вокруг каждой точки, контраст которой увеличивается (параметр Radius (Радиус)); а также определить, на какие точки будет оказывать действие фильтр, и на какие не будет, указав минимальный уровень существующего контраста (параметр Threshold (Порог)).

Эффект от применения фильтра Unsharp Mask может быть больше заметен на экране, нежели при выводе на принтер с высоким разрешением.

  1. Выберите элемент меню Filter > Sharpen > Unsharp Mask (Фильтр > Резкость > Нерезкое маскирование) - см. рис. 4.11.
  2. Определите в процентах значение параметра Amount (Количество), которое указывает, насколько будет увеличен контраст между пикселами (рис. 4.12). Выберите небольшое значение (ниже 50) для фигур или естественных объектов; укажите большее значение, если в изображении содержатся объекты с четкими границами. Чрезмерно большое значение создаст заметный ореол вокруг высококонтрастных областей (рис. 4.13). Чем больше изображение, тем меньше следует увеличивать резкость. Для изображений с высоким разрешением выберите значение параметра Amount (Количество) в пределах между 150 и 200%.
  3. Выбрать правильное значение параметра Radius (Радиус) немного сложнее: необходимо учитывать окончательный размер изображения, разрешение и что представлено на изображений. Выберите величину параметра Radius в диапазоне от 0,1 до 250 и определите таким образом число изменяемых пикселов вокруг высококонтрастных границ. Попробуйте начать с величины между 1 и 2. Большее значение может создать чрезмерную контрастность в областях, которые и так уже контрастны (рис. 4.14).

    Чем выше разрешение изображения, тем больше пикселов находится на границе между высококонтрастными областями, соответственно требуется большее значение радиуса. Попробуйте задать большое значение радиуса для низкоконтрастного изображения и Меньшее значение для сложного, высококонтрастного изображения.

Чем выше значение радиуса, тем меньше может быть значение параметра Amount и наоборот.

  4. Выберите значение параметра Threshold (Порог) в диапазоне от 0 до 255 для определения минимальной контрастности, которой должна обладать область, прежде чем она будет изменена. Если указать 0, то фильтр будет применен ко всему изображению. Величина больше 0 вызовет увеличение резкости вдоль высококонтрастных границ и менее заметное увеличение резкости в низкоконтрастных областях. Если увеличить значение параметра Threshold (Порог), можно увеличить и значение параметров Amount (Количество) и Radius (Радиус), чтобы усилить резкость границ и при этом не переусердствовать в областях, где это не нужно. Для того чтобы предотвратить возникновение шума, укажите значение параметра Threshold (Порог) между 8 и 20 (рис. 4.15).
  5. Щелкните по кнопке ОК.

Рис. 4.13. Возникновение ореолов вокруг границ и центра цветов в результате применения фильтра Unsharp Mask со значениями Amount -160%, Radius -1,5, Threshold - О

Рис. 4.14. Неестественный контраст и резкость в результате применения фильтра Unsharp Mask со значениями Amount -130%, Radius - 6,0, Threshold - О

Рис. 4.15. Сохранение мягких переходов цвета в лепестках и фоне в результате применения фильтра Unsharp Mask со значениями Amount -160%, Radius -1,5, Threshold -15

Чтобы смягчить зернистость отсканированного изображения, примените фильтр Filter > Blur > Gaussian Blur (Фильтр > Размытие > Размытие по Гауссу) с небольшим значением (меньше 1) и затем один или два раза примените Filter > Sharpen > Sharpen Edges (Фильтр > Резкость > Резкость контуров), чтобы сделать изображение более четким.

Для того чтобы не ждать, пока предварительный результат после применения фильтра Unsharp Mask для большого изображения будет показан во весь экран, сначала определите приблизительные значения параметров, используя только окно предварительного просмотра, затем установите флажок Preview (Предварительный просмотр), чтобы увидеть резулыат работы во весь экран, и затем при необходимости подкорректируйте значения.

Попробуйте применить фильтр Unsharp Mask к одному или двум отдельным цветовым каналам (например, только красному и зеленому каналам в RGB-изображении). Если вы увеличиваете резкость двух отдельных каналов, укажите одно и то же значение радиуса. Можно преобразовать изображение в режим Lab и применить фильтр к каналу L, чтобы усилить яркость, не затрагивая цветные пикселы.

Изменение параметров холста

Команда Canvas Size (Размер холста) изменяет область изображения, допускающую редактирование.

Если вы хотите вручную увеличить размеры холста прямо в окне изображения, воспользуйтесь инструментом Crop (Кадриро-_вать), работа с которым описана в разделе «Увеличение холста изображения с помощью инструмента Crop» данной главы. Также с помощью этого инструмента можно уменьшить размер изображения.

Изменение размера холста

  1. Если у изображения (рис. 4.16) есть фон, выберите фоновый цвет (см. начало главы 10).
  2. Откройте диалоговое окно Image > Canvas Size (Изображение > Размер холста) - см. рис. 4.17.
  3. По желанию. Из любого всплывающего меню выберите какую-нибудь другую единицу измерения. Если выбрать вариант columns (колонки), то в качестве приращения будет использоваться значение Column Size: Width (Размер колонок: Ширина).
  4. Введите новое значение в поле Width (Ширина) и/или Height (Высота). Изменение одной величины (ширины или высоты) никак не влияет на другую.
  5. По желанию. Можно задать относительное изменение ширины или высоты. Для этого установите флажок Relative (Относительно) и введите в поле Width (Ширина) и/или Height (Высота) то значение, на которое вы хотите увеличить или уменьшить размер холста.

Рис. 4.16. Исходное изображение

Рис. 4.17. Диалоговое окно Canvas Size

Рис. 4.18. Изображение с добавленными пикселами холста

Рис. 4.19. Левая сторона панели опций инструмента Crop после рисования рамки

Рис. 4.20. Правая сторона панели опций инструмента Crop после рисования рамки

Рис. 4.21. Выделение сохраняемой части изображения

  6. По желанию. Для того чтобы переместить изображение относительно нового холста, щелкните по незанятому квадратику Anchor (Якорь). Светлый элемент показывает текущее расположение изображения.
  7. Щелкните по кнопке ОК. Все дополнительные области будут автоматически залиты текущим фоновым цветом (за исключением случая, когда фон представляет собой прозрачный слой, тогда дополнительная область холста будет прозрачной) - см. рис. 4.18.

Кадрирование изображения с помощью рамки

Изображение может быть обрезано с помощью инструмента Crop (Кадрировать), команды Crop (Кадрировать) или команды Trim (Подрезать). В программе Photoshop 7 содержатся несколько новых опций для инструмента Crop (Кадрировать).

  1. Выберите инструмент Crop (Кадрировать), или нажав клавишу С.
  2. Нарисуйте рамку вокруг той области изображения, которую вы хотите сохранить (рис. 4.19-4.21).
  3. Выполните любое из нижеследующих действий на панели опций инструмента Crop (Кадрировать).

    Установите флажок Shield cropped area (Прикрыть область кадрирования), если хотите, чтобы область за пределами рамки была затемнена (это поможет лучше увидеть, что останется). Щелкните по образцу Color (Цвет), если хотите изменить цвет затемненной области и выберите значение параметра Opacity (Непрозрачность) для этого цвета.

    Если вы кадрируете слой, поставьте переключатель Cropped Area (Отсекаемая область) в положение Delete (Удалить), чтобы удалить область, не заключенную в рамку, или Hide (Спрятать), чтобы сохранить область вместе с файлом и чтобы область находилась за пределами изображения. С помощью инструмента Move (Переместить) можно переместить спрятанные пикселы слоя, находящиеся за пределами изображения. Эта функция не доступна для фона.

    Описание опции Perspective (Перспектива) приведено в интерактивной документации Photoshop.

  4. Выполните любой из нижеследующих шагов.

    Для того чтобы изменить размер рамки, перетащите один из маркеров ее границы (курсор примет вид двухсторонней стрелки). Если при этом нажать клавишу Shift, будут сохранены пропорции рамки. Нажав клавишу Alt, можно изменить размер рамки относительно ее центра.

    Чтобы передвинуть рамку, поместите курсор внутри рамки и перетащите ее. Если надо повернуть рамку, поместите курсор за ее пределами (появится изогнутая стрелочка) и тащите его по кругу. Чтобы изменить положение оси, вокруг которой будете поворачивать рамку, предварительно перетащите кружок, находящийся в центре рамки. (Нельзя повернуть рамку, если изображение имеет представление Bitmap.)

  5. Нажмите клавишу Enter. Результат показан на рис. 4.22. Чтобы завершить операцию, можно также дважды щелкнуть мышью внутри рамки. Если вы повернули рамку, потребуется некоторое время на завершение операции обрезки.

Рис. 4.22. Обрезанное изображение

Рис. 4.23. Левая часть панели опций инструмента Crop до того, как будет нарисована рамка

Рис. 4.24. Правая часть панели опций инструмента Crop до того, как будет нарисована рамка

Для того чтобы отменить процесс обрезки до того, как действие будет выполнено, нажмите клавишу Esc.

Если вы хотите усилить резкость после обрезки изображения, примените фильтр Un-sharp Mask (см. раздел «Применение фильтра Unsharp Mask» этой главы).

Указание размеров и разрешения при обрезке изображения

  1. Выберите инструмент Crop (Кадриро-вать), или нажав клавишу С.
  2. На панели опций инструмента введите значения в поля Width (Ширина) и/или Height (Высота), как показано на рис. 4.23, или щелкните по кнопке Front Image (Внешнее изображение), чтобы ввести в эти поля ширину, высоту и разрешение текущего изображения (рис. 4.24). Воспользуйтесь данной опцией, если хотите обрезать одно изображение соответственно размерам другого открытого изображения.

Рамка обрезки будет соответствовать соотношению указанной ширины и высоты.

  3. По желанию. Измените значение параметра Resolution (Разрешение). Если после того, как вы щелкнули по кнопке Front Image (Внешнее изображение), разрешение было увеличено, а затем изображение обрезано, то размер изображения при печати уменьшится. Если уменьшить текущее разрешение и обрезать изображение, то размер при печати увеличится. В обоих случаях общее число пикселов останется неизменным.

    Щелкните по кнопке Clear (Очистить), чтобы очистить поля Width (Ширина), Height (Высота) и Resolution (Разрешение).

  4. Перетащите рамку кадрирования, затем дважды щелкните внутри нее или нажмите клавишу Enter.

Обычно рамка обрезки прикрепляется к границе изображения. Чтобы избежать этого (скажем, вы хотите обрезать изображение, чуть-чуть отступив от границ), начните рисовать рамку, затем нажмите и не отпускайте клавиши Ctrl+Shift в то время, как рисуете рамку рядом с границей изображения.

Если надо обрезать одно изображение так, чтобы оно точно умещалось в границах другого, откройте оба изображения, активируйте целевое изображение, выберите инструмент Crop, на панели его опций щелкните по кнопке Front Image (Внешнее изображение), сделайте активным то изображение, которое вы хотите обрезать и нарисуйте пунктирную рамку. После обрезки, нажав клавишу Shift, перетащите слой или скопируйте и вставьте слой в целевое изображение. Разрешение будет автоматически подкорректировано.

Увеличение холста изображения с помощью инструмента Crop

Если произвести обрезку с помощью рамки, размер которой больше размера самого изображения, увеличится размер холста изображения.

  1. Увеличьте окно изображения так, что? бы был виден рабочий холст (серая область) вокруг изображения.
  2. Выберите инструмент Crop, или нажав клавишу С.

Рис. 4.25. Перемещение маркеров рамки за пределы холста

Рис. 4.26. Заливка добавленных пикселов текущим фоновым цветом (темно-серым) и изменение пропорций изображения

  3. Нарисуйте рамку обрезки внутри изображения.
  4. Перетащите маркеры рамки в область рабочего холста (рис. 4.25, 4.26). Если границы изображения вышли за границу холста, эти области будут включены в холст.
  5. Дважды щелкните мышью внутри рамки или нажмите клавишу Enter. Если пикселы не были скрыты, дополнительная область холста либо будет залита текущим фоновым цветом, если самый нижний слой - фон, либо будет прозрачной, если самым нижним является какой-либо иной слой.

Кадрирование изображения с помощью команды Crop

Команда Crop (Кадрировать) полезна только в том случае, если нет необходимости использовать опции, предоставляемые инструментом Crop. Начинайте с создания рамки выделения.

  1. Выберите инструмент Rectangular Marquee (Прямоугольная область) или нажмите клавишу М.
  2. Нарисуйте рамку вокруг области, которую вы хотите сохранить.

    Для того чтобы отрегулировать размер рамки, установите в поле Style (Стиль) на панели опций инструмента значение Fixed Size (Фиксированный размер) или Fixed Aspect Ratio (Сохранять отношение сторон), затем щелкните мышью по изображению.

  3. Выберите команду Image > Crop (Изображение > Кадрировать).

Обрезка изображения с помощью команды Trim

Для того чтобы быстро удалить лишние прозрачные или цветные области вокруг изображения, воспользуйтесь командой Trim (Подрезать).

  1. Выберите команду Image > Trim (Изображение > Подрезать).
  2. Выберите одно из положений переключателя Based On (На основе) - см. рис. 4.27:
    • Transparent pixels (Прозрачные пикселы) - удаляются лишние прозрачные точки на границе изображения, при этом сохраняются все пикселы изображения;
    • Top Left Pixel Color (Цвет верхнего левого пиксела) - удаляются любые граничные области, цвет которых совпадает с цветом верхнего левого пиксела изображения;
    • Bottom Right Pixel Color (Цвет нижнего правого пиксела) - удаляются любые граничные области, цвет которых совпадает с цветом нижнего правого пиксела изображения.
  3. Выберите области, которые вы хотите подрезать: Тор (Верхняя), Bottom (Нижняя), Right (Правая) или Left (Левая).
  4. Щелкните по кнопке ОК.

Рис. 4.27. Окно команды Trim, удаляющей лишние прозрачные или цветные области в зависимости от того, какая опция выбрана

Рис. 4.28. Исходное изображение

Рис. 4.29. Изображение, перевернутое вдоль горизонтали

Рис. 4.30. Изображение, перевернутое вдоль вертикали

Переворачивание изображения

Команды Rotate Canvas > Flip Horizontal и Flip Vertical (Повернуть холст > Перевернуть вдоль горизонтали и Перевернуть вдоль вертикали), о которых рассказывается ниже, переворачивают все слои изображения. Если же вы хотите перевернуть только один слой, то лучше воспользуйтесь командой Edit > Transform > Flip Horizontal или Flip Vertical (Правка > Трансформировать > Перевернуть вдоль горизонтали или Перевернуть вдоль вертикали).

Для того чтобы перевернуть изображение справа налево, выберите команду Image > Rotate Canvas > Flip Canvas Horizontal (Изображение > Повернуть холст > Перевернуть вдоль горизонтали) - см. рис. 4.28, 4.29.

Чтобы перевернуть изображение сверху вниз и создать зеркальное изображение, выберите Image > Rotate Canvas > Flip Canvas Vertical (Изображение > Повернуть холст с> Перевернуть холст вдоль вертикали). Результат показан на рис. 4.30.

Поворот изображения на определенный угол

Команды группы Rotate Canvas вращают все слои изображения. Если же вы хотите повернуть только один слой, воспользуйтесь командой поворота из подменю Edit > Transform (Правка > Трансформировать).

Чтобы повернуть изображение на предопределенный угол, выберите команду Image > Rotate Canvas > 180°, 90° CW или 90° CCW (Изображение > Повернуть холст > На 180°, 90° по часовой стрелке или на 90° против часовой стрелки).

Если же вам надо повернуть изображение на произвольный угол, выполните указанные ниже действия.

  1. Выберите команду Image > Rotate Canvas > Arbitrary (Изображение > Повернуть холст > Произвольно).
  2. В поле Angle (Угол) введите какое-либо число в пределах от -359.99° до 359.99° (рис. 4.31).

Для того чтобы выпрямить искривленное отсканированное изображение, измерьте угол с помощью инструмента Measure и введите это значение.

  3. Поставьте переключатель в положение °CW (По часовой стрелке) или °CCW (Против часовой стрелки).
  4. Щелкните по кнопке ОК (рис. 4.32).

Рис. 4.31. Диалоговое окно Rotate Canvas

Рис. 4.32. Изображение, повернутое на 180° Сравните с рис. 4.29 и рис. 4.30


  • Глава 5. Выделение
    • Выделение целого слоя
    • Выделение прямоугольной или эллиптической области
    • Создание выделенной области произвольной формы
    • Создание выделения в форме многоугольника
    • Выделение пикселов в зависимости от их цвета
    • Выделение с помощью инструмента Magnetic Lasso
    • Панель опций инструмента Magnetic Lasso
    • Выделение области по цвету
    • Создание выделенной области в виде полосы
    • Выделение узкой полосы вокруг выделенной области
    • Снятие выделения
    • Повторное выделение области
    • Удаление выделенной области
    • Перемещение рамки выделения
    • Инвертирование выделенной области
    • Скрытие рамки выделения
    • Изменение рамки выделения
      • Изменение рамки выделения посредством команды меню
    • Добавление точек к выделенной области
    • Удаление точек из выделенной области
    • Выделение пересечения двух выделенных областей
    • Виньетирование изображения
    • Маскирование фигур с помощью команды Extract
    • Сохранение контура извлеченного изображения в канале

Глава №5.

Выделение

Когда на изображении есть выделенная активная область, то редактировать можно только ее, остальная часть изображения защищена. Границы выделенной области представляют собой перемещаемую рамку. В этой главе рассказывается о создании выделенной области с помощью инструментов Rectangular Marquee (Прямоугольная область), Elliptical Marquee (Овальная область), Lasso (Лассо), Polygonal Lasso (Полигональное лассо), Magic Wand (Волшебная палочка) и Magnetic Lasso (Магнитное лассо), а также с помощью команд Color Range (Диапазон цветов) и Extract (Извлечь). Кроме того, вы узнаете, как создать выделенные области разных форм; как выделить области по цвету; как снять выделение, выделить еще раз, инвертировать или удалить выделенную область; как переместить или спрятать рамку выделения; как изменять, добавлять или удалять точки из выделенной области, а также как виньетировать изображение.

В любой выделенной области содержатся пикселы того слоя, который в данный момент активен. Если с помощью инструмента Move (Переместить) сдвинуть выделенную область, расположенную на фоне изображения, открывшийся участок будет автоматически залит фоновым цветом. С другой стороны, если с помощью этого же инструмента переместить выделенную область, расположенную на слое, то открывшаяся область станет прозрачной. (Подробнее о слоях читайте в главе 7.)

Границы выделенной области могут быть преобразованы в контур, что позволит более точно управлять изменением ее формы, а затем обратно в границы выделения (см. главу 16, разделы «Преобразование выделенной области в контур» и «Преобразование контура в границу выделения»). Режим Quick Mask (Быстрая маска), действующий подобно выделению, но позволяющий рисовать на изображении, рассматривается в главе 15.

Выделение целого слоя

Выберите слой, затем воспользуйтесь командой меню Select О All (Выделить > Все) или нажмите комбинацию клавиш Ctrl+A. Рамка окружит весь слой целиком.

Для того чтобы выделить только непрозрачные пикселы слоя, нажмите клавишу Ctrl и щелкните по имени слоя на палитре Layers (Слои) - рис. 5.1, 5.2. Либо щелкните по образцу слоя правой кнопкой мыши и из контекстного меню выберите элемент Select Layer Transparency (Выделить прозрачные пикселы слоя).

Выделение прямоугольной или эллиптической области

  1. Выберите слой изображения.
  2. Активизируйте инструмент Rectangular Marquee (Прямоугольная область) или Elliptical Marquee (Овальная область), нажав клавишу М или сочетание Shift+M (рис. 5.3).

Рис. 5.1. Выделение непрозрачных пикселов слоя щелчком мыши по имени слоя при нажатой клавише Ctrl

Рис. 5.2. Выделенные непрозрачные точки слоя

Рис. 5.3. Меню инструментов выделения

Рис. 5.4. Выделение области фиксированного размера

Рис. 5.5. Ввод значения параметра Feather для смягчения границ выделенной области

Рис. 5.6. Направление движения курсора при создании прямоугольной выделенной области

Рис. 5.7. Направление движения курсора при создании эллиптической выделенной области

  3. По желанию. Если выбран инструмент Rectangular Marquee (Прямоугольная область) или Elliptical Marquee (Овальная область), то для определения точных размеров выделенной области из всплывающего меню Style (Стиль), расположенного на панели опций, выберите пункт Fixed Size (Фиксированный размер), как показано на рис. 5.4, затем введите значения ширины и высоты. Однако помните, что размер в пикселах рассчитывается в соответствии с разрешением файла, а не монитора, так что рамка при одних и тех же числовых значениях окажется больше для файла с низким разрешением, чем для файла с высоким разрешением. Для того чтобы указать соотношение ширины и высоты выделенной области (например, 3:1), из всплывающего меню Style (Стиль) выберите пункт Fixed Aspect Ratio (Сохранять отношение сторон) и введите значения ширины и высоты. Введите одно и то же значение в оба поля, чтобы создать круг или квадрат.
  4. По желанию. Чтобы смягчить границы выделенной области, на панели опций до того, как создать выделение, введите значение параметра Feather (Растуше-вывание) большее 0 (рис. 5.5). Для инструмента Elliptical Marquee (Овальная область) можно установить или снять флажок Anti-aliased (Сглаживание).
  5. Если вы указали фиксированный размер выделяемой области (или выбрали инструмент Single Row Marquee (Строка пикселов) или Single Column Marquee (Столбец пикселов)), щелкните по изображению. Во всех других случаях тащите курсор мыши по диагонали выделяемой области (рис. 5.6, 5.7). Появится пунктирная рамка. Для того чтобы создать круг или квадрат, при стиле Normal (Нормальный) начните тащить курсор и закончите рисовать рамку, держа нажатой клавишу Shift. Нажмите и не отпускайте клавишу пробела, чтобы переместить рамку в процессе ее создания. Для того чтобы передвинуть уже построенную рамку, перетащите курсор, поместив его внутри рамки.

В то время как вы тащите курсор, на палитре Info (Информация) рядом с буквами W и Н будут отображаться размеры выделенной области.

Как добавить или удалить точки из выделенной области, рассказано в разделах «Добавление точек к выделенной области» и «Удаление точек из выделенной области» этой главы.

Прежде чем воспользоваться инструментом выделения, на панели опций установите флажок Anti-aliased (Сглаживание), чтобы создать выделенную область со смягченными границами, переходящими в прозрачные точки. Снимите этот флажок, если требуется выделить область с резкими, четкими границами (рис. 5.8).

Так как довольно сложно снова выделить точно такую же область (если только не сохранять ее в виде альфа-канала или контура), постарайтесь завершить работу с выделенной областью прежде, чем снять с нее выделение.

Создание выделенной области произвольной формы

Если фигура, которую вы хотите выделить, имеет слишком сложную форму, обрисуйте ее границу с помощью инструмента Реп (Перо) или Freeform Pen (Свободное перо) вместо инструмента Lasso (Лассо) и затем преобразуйте контур в выделение. Результат будет более точным. Также можно преобразовать границы уже выделенной области в контур, что позволит более точно управлять формой границ.

Рис. 5.8. Граница выделенной области при установленном (справа) и снятом (слева) флажке Anti-aliased

Рис. 5.9. Граница области, построенная при помощи инструмента Lasso

Рис. 5.10. Область с прямыми сторонами, выделенная с помощью инструмента Polygon Lasso

  1. Выберите слой изображения.
  2. Активизируйте инструмент Lasso (Лассо), щелкнув по пиктограмме §?'! или нажав клавишу L или Shift+L.
  3. По желанию. На панели опций инструмента введите значение параметра Feather (Растушевывание), чтобы сгладить границы выделенной области.
  4. Нажав кнопку мыши, обведите курсор вокруг какой-либо области слоя (рис. 5.9). Когда вы отпустите кнопку, концы незамкнутой границы автоматически буду соединены.

Для того чтобы смягчить границы выделенной области после ее создания, воспользуйтесь командой Select > Feather (Выделить > Растушевать) или нажмите комбинацию клавиш Ctrl+Alt+D.

Если вам надо построить отрезок прямой при работе с инструментом Lasso (Лассо), то, не отпуская кнопку мыши, нажмите клавишу Alt и щелкайте мышью, чтобы создать углы. Перетащите курсор, а затем отпустите клавишу, и можете продолжать создание произвольной выделенной области.

Создание выделения в форме многоугольника

  1. Выберите слой изображения.
  2. Активизируйте инструмент Polygon Lasso (Полигональное лассо), или нажав клавишу L или Shift+L.
  3. Если необходимо построить прямые стороны, щелкайте мышью там, где должны быть углы (рис. 5.10). Для того чтобы замкнуть границу, щелкните по начальной точке (рядом с курсором появится маленький кружочек). Либо, нажав клавишу Ctrl, щелкните в любом месте изображения, в результате чего граница выделенной области будет автоматически замкнута.

    Нажав клавишу Alt, можно в ходе построения полигонального выделения нарисовать криволинейный сегмент. Чтобы возобновить создание прямолинейных участков, достаточно отпустить клавишу.

    Нажав клавишу Shift, можно создать прямолинейные участки выделения под фиксированным углом, кратным 45°.

    Нажмите клавишу Delete, чтобы стереть последний созданный угол. Не отпускайте эту клавишу, если надо стереть несколько углов.

Выделение пикселов в зависимости от их цвета

Если щелкнуть по какому-либо пикселу слоя инструментом Magic Wand (Волшебная палочка), будут выделены смежные пикселы одного оттенка или одного уровня прозрачности. Затем к полученной области можно добавить не смежные с ней пикселы, похожие по цвету, с помощью команды Similar (Похожие) либо пикселы другого цвета, нажав клавишу Shift и щелкнув по пикселу данного цвета.

  1. Выберите слой изображения.
  2. Активизируйте инструмент Magic Wand (Волшебная палочка), или нажав клавишу W.
  3. Если на панели опций (рис. 5.12) инструмента установлен флажок Contiguous (Смежные), то в выделенную область войдут только те пикселы, которые «связаны» с первым пикселом, по которому вы щелкнете. Снимите этот флажок, чтобы выделить пикселы и из несмежных областей.

Рис. 5.11. Левая часть панели опций инструмента Magic Wand

  4. На панели опций инструмента установите флажок Use All Layers (Использовать все слои), чтобы для выделенной области брать пикселы из всех слоев, которые в данный момент отображены на экране. Допускается редактировать пикселы только активного слоя, но можно внести изменения внутри одной и той же рамки выделения и в последующие слои.

    Снимите флажок Use All Layers (Использовать все слои), чтобы выбирать пикселы только активного слоя.

    Установите флажок Anti-aliased (Сглаживание), чтобы сделать более гладкими границы выделенной области.

  5. Щелкните по какому-либо оттенку цвета в окне изображения.
  6. Выполните любой из нижеследующих шагов.

Для того чтобы увеличить выделенную область с учетом текущего значения параметра Tolerance (Допуск), которое можно увидеть на панели опций инструмента Magic Wand (Волшебная палочка), воспользуйтесь командой Select > Grow (Выделить > Увеличить) столько раз, сколько необходимо (выберите маленькое значение допуска). Также получить доступ к этой команде можно, щелкнув правой кнопкой мыши.

Для того чтобы выделить дополнительные, несмежные области такого же оттенка с использованием того же значения допуска, выберите команду Select "Ф Similar (Выделить > Похожие).

Рис. 5.12. Правая часть панели опций инструмента Magic Wand

Рис. 5.13. Выделенная область, созданная с помощью инструмента Magic Wand при значении допуска равном 10

Рис. 5.14. Выделенная область, созданная с помощью инструмента Magic Wand при значении допуска равном 40

Чтобы изменить диапазон цветов, с которыми работает инструмент Magic Wand (Волшебная палочка), на панели опций инструмента в поле Tolerance введите значение от 0 до 255 (рис. 5.11), а затем снова щелкните по изображению. При значении допуска равном 32 инструмент Magic Wand (Волшебная палочка) будет выделять пикселы в диапазоне от цвета на 16 единиц темнее и до цвета на 16 единиц светлее того, по которому вы щелкнули. Введите значение 0, чтобы выделить только один оттенок. Для того чтобы постепенно увеличить или уменьшить диапазон оттенков, с которыми работает инструмент, изменяйте значение допуска между щелчками мыши (рис. 5.13, 5.14). Чем выше это значение, тем шире диапазон выделяемых оттенков.

Воспользуйтесь командой Edit > Undo (Правка > Отменить) либо нажмите комбинацию клавиш Ctrl+Z чтобы снять выделение с последней созданной выделенной области.

Для того чтобы быстро выделить все непрозрачные пикселы слоя (не фона), нажмите клавишу Ctrl, щелкните по имени слоя.

Для того чтобы добавить или удалить точки из выделенной области, следуйте инструкциям, приведенным в разделах «Добавление точек к выделенной области» и «Удаление точек из выделенной области» этой главы.

Для того чтобы ужать или расширить выделенную область на определенное количество пикселов, выберите соответствующую команду из подменю Select > Modify (Выделить > Изменить).

Для того чтобы удалить однотонный фон вокруг фигуры, сначала выделите фон изображения с помощью инструмента Magic Wand (Волшебная палочка), а затем нажмите клавишу Backspace.

Выделение с помощью инструмента Magnetic Lasso

При разработке инструмента Magnetic Lasso (Магнитное лассо) и команды Extract (Извлечь), о которой рассказывается в разделе «Маскирование фигур с помощью команды Extract» этой главы, компания Adobe постаралась облегчить процесс выделения фигур неправильной формы и фигур, имеющих размытые, смазанные или сложные границы. Ни один из предложенных способов полностью не решает проблемы, но все равно это довольно полезные инструменты.

Инструмент Magnetic Lasso (Магнитное лассо) автоматически создает выделенную область в то время, как вы перемещаете или перетаскиваете курсор. Граница области «прилипает» к ближайшему отличительному оттенку цвета или тени, который определяет границу фигуры.

Инструменту Magnetic Lasso требуется много времени и оперативной памяти. Если слишком быстро перемещать или перетаскивать курсор, инструмент может не успевать следить за происходящим.

  1. Выберите слой изображения.
  2. Активизируйте инструмент Magnetic Lasso (Магнитное лассо), щелкнув по пиктограмме fj или нажав клавишу L или Shift+L.
  3. По желанию. Измените любые параметры на панели опций инструмента, подробнее о них рассказано в разделе «Панель опций инструмента Magnetic Lasso» этой главы.
  4. Щелкните по изображению, чтобы создать первую промежуточную точку. Переместите курсор - при этом кнопку мыши нажимать не обязательно -вдоль границы фигуры, которую вы хотите выделить (рис. 5.15). В то время как вы перемещаете или перетаскиваете курсор, линия выделения будет «прилипать» к границе фигуры. Появляющиеся в процессе перемещения курсора временные точки исчезнут, как только вы замкнете контур.

Рис. 5.15. Построение границы выделенной области

Рис. 5.16. Граница выделенной области после замыкания

Для того чтобы временно увеличить контраст какого-либо изображения и тем самым повысить эффективность инструмента Magnetic Lasso (Магнитное лассо), из всплывающего меню Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенного внизу палитры Layers (Слои), выберите элемент Brightness/Contrast (Яркость/Контраст) и переместите ползунок Contrast (Контраст) вправо. Удалите корректирующий слой, когда закончите работать с инструментом Magnetic Lasso (Магнитное лассо).

Нажмите клавишу Esc, чтобы удалить начатую линию выделения (затем можно начать заново). Нажмите клавишу Delete, чтобы стереть последнюю поставленную промежуточную точку.

Если вы работаете с инструментом Magnetic Lasso (Магнитное лассо) и хотите временно активизировать инструмент Polygon Lasso (Полигональное лассо), то нажмите клавишу Alt и, удерживая ее, щелкните по изображению. Чтобы в аналогичной ситуации воспользоваться инструментом Lasso (Лассо), нажмите клавишу Alt и тащите курсор.

  5. Если линия выделения начинает «прилипать» к соседним фигурам, которые вы не собираетесь выделять, щелкните по краю фигуры, которую хотите выделить, чтобы вручную добавить промежуточную точку. Продолжайте перемещать или перетаскивать курсор, чтобы закончить выделение области.
  6. Для того чтобы замкнуть границу выделения (рис. 5.16), дважды щелкните мышью по какой-либо точке фигуры или по начальной точке (рядом с курсором инструмента Magnetic Lasso (Магнитное лассо) появится маленький кружочек).

Можно также нажать клавишу Enter или щелкнуть по изображению при нажатой клавише Ctrl или, наконец, нажав клавишу Alt, дважды щелкнуть по изображению, чтобы замкнуть границу выделенной области отрезком прямой.

Панель опций инструмента Magnetic Lasso

Значение параметра Feather (Растушевывание) определяет степень смягчения границ выделенной области (рис. 5.17).

Параметр Width (Ширина) может меняться от 1 до 40 и задает размер в пикселах области, с которой работает инструмент при размещении точек границы выделения (рис. 5.18). Выберите большое значение для высококонтрастного изображения с четкими границами. Для изображения с едва заметными изменениями контраста или маленькими, расположенными близко друг от друга фигурами, лучше указывать небольшое значение. Благодаря этому выделенная область окажется более точной, и линия не будет перекидываться от одной границы к другой.

Если в окне Edit > Preferences > Display&Cursors (Правка > Установки > Отображение&курсоры) в группе Other Cursors (Другие курсоры) выбрать вариант Precise (Точно), курсор примет вид круга с перекрестием в центре, диаметр которого будет соответствовать текущему значению параметра Width инструмента (рис. 5.19). Для того чтобы временно переключиться в режим Precise, нажмите клавишу CapsLock.

Для того чтобы в процессе создания выделенной области уменьшить значение параметра Width на 1 пиксел, нажмите клавишу [, для увеличения его на 1 пиксел нажмите ].

Параметр Edge Contrast (Контраст границ) меняется в диапазоне от-1 до 100 и указывает степень контрастности, необходимой для распознавания границы фигуры. Выберите небольшое значение для низкоконтрастных изображений.

Если вы ввели маленькое или большое значение ширины, введите подобное и для контраста границ.

Рис. 5.17. Левая часть панели опций инструмента Magnetic Lasso

Рис. 5.18. Правая часть панели опция инструмента Magnetic Lasso

Рис. 5.19. Вид курсора в режиме Precise

Параметр Frequency (Частота) меняется в диапазоне от 0 до 100 и определяет, насколько часто ставятся промежуточные точки при создании выделенной области. Чем ниже частота, тем меньше точек. Выберите большое значение, чтобы точно выделить контур фигуры неправильной формы.

Выделение области по цвету

С помощью команды Color Range (Диапазон цветов) можно выделить области в зависимости от цвета изображения или задав диапазон яркости или тона.

  1. Выберите слой. Команда Color Range (Диапазон цветов) выбирает цвета из всех видимых слоев, но редактировать можно только активный. Чтобы ограничить обрабатываемый участок, изначально выделите какую-либо область изображения.

Рис. 5.20. Диалоговое окно Color Range

  2. Выполните команду Select> Color Range (Выделить > Диапазон цветов). На экране появится окно, показанное на рис. 5.20.
  3. Выберите какой-либо пункт из всплывающего меню поля Select (Выделить) -рис. 5.20а. Можно ограничить выделяемую область указанием стандартного диапазона цветов (например, Reds (Красные), Yellows (Желтые)), диапазона яркости (Highlights (Яркие тона), Mid-tones (Средние тона) или Shadows (Темные тона)) или конкретного цвета, выбранного с помощью пипетки. Опция Out of Gamut (He входящие в гамму) может быть использована только для изображения в режиме Lab или RGB. Если задан стандартный диапазон цветов, а в изображении содержатся только слабые оттенки выбранного цвета, появится предупреждающее сообщение о том, что рамка выделения имеется, но ее не видно.
  4. Выберите опцию Selection Preview (Предварительный просмотр выделения), чтобы иметь возможность заранее увидеть выделенные области изображения (рис. 5.20в).
  5. Если хотите предварительно просмотреть выделенную область, поставьте переключатель в положение Selection (Выделенная область); чтобы вновь увидеть изображение целиком, поставьте переключатель в положение Image (Изображение). Либо нажмите и удерживайте клавишу Ctrl, чтобы переключаться с одной опции на другую. Если изображение выходит за пределы окна, воспользуйтесь опцией Image (Изображение) - в окне предварительного просмотра будет показано изображение целиком, что упростит процесс выделения.
  6. Если на шаге 3 вы выбрали опцию Sampled Colors (Выбранные цвета), щелкните кнопкой мыши или перетащите курсор в виде-пипетки в окне изображения, чтобы выбрать цвета.
  7. По желанию. Передвиньте ползунок Fuzziness (Размытость) вправо, чтобы расширить диапазон отбираемых оттенков, и влево в противоположном случае (рис. 5.206).
  8. По желанию. Если на шаге 3 выбрана опция Sampled Colors (Выбранные цвета), то, нажав клавишу Shift, щелкните в окне изображения или окне предварительного просмотра, чтобы добавить больше оттенков в выделяемую область. Нажав клавишу Alt и щелкнув кнопкой мыши, можно удалить оттенок из выделяемой области. Либо в диалоговом окне Color Range (Диапазон цветов) щелкнуть по изображению пипетки со знаком «плюс» или «минус», а затем щелкнуть в окне изображения или предварительного просмотра, не держа при этом нажатой клавишу Shift, Alt или Option.
  9. Щелкните по кнопке ОК.

Если нажать на кнопку Save (Сохранить) (рис. 5.20д), можно записать в файл, а затем вновь загрузить из файла, нажав на кнопку Load (Загрузить) (рис. 5.20г), текущие установки окна Color Range.

Создание выделенной области в виде полосы

  1. Выберите слой.
  2. Активизируйте инструмент Rectangular Marquee (Прямоугольная область) или Elliptical Marquee (Овальная область), нажав клавишу М или Shift+M, и создайте выделенную область, перетаскивая курсор, либо выполните команду Select > All (Выделить > Все) или воспользуйтесь комбинацией клавиш Ctrl+A.
  3. Нажав клавишу Alt, перетащите курсор, чтобы создать меньшую выделенную область внутри первой (рис. 5.21). О том, как удалить точки из выделенной области с помощью другого метода, рассказано в разделе «Удаление точек из выделенной области».

На рис. 5.22 показан другой метод выделения подобных областей. С помощью инструмента Marquee была выделена центральная область, затем была выполнена команда Inverse (Инвертировать), чтобы поменять местами выделенную и невыделенную области; таким образом, внешняя область стала выделенной. Чтобы оттенить выделенную область, была применена команда Levels (Уровни).

Выделение узкой полосы вокруг выделенной области

  1. Создайте выделенную область.
  2. Выберите команду Select > Modify > Border (Выделить > Изменить > Граница).
  3. Введите желаемое значение ширины (от 1 до 64) в пикселах (рис. 5.23).

Рис. 5.21. Выделенная область в виде рамки, созданная с помощью инструмента Rectangular Marquee

Рис. 5.22. Выделение рамки с помощью команды Inverse

Рис. 5.23. Ввод желаемого значения ширины

Рис. 5.24. Полученная выделенная область

Рис. 5.25. Снятие выделения с области при помощи щелчка внутри выделенной области

  4. Щелкните по кнопке ОК. Новая выделенная область будет представлять собой узкую ровную полоску, края которой равно удалены от границы исходной выделенной области (рис. 5.24).

Снятие выделения

Чтобы снять выделение с области независимо от того, какой инструмент активизирован, воспользуйтесь командой Select > Deselect (Выделить > Снять выделение), либо нажмите комбинацию клавиш Ctrl+D, либо щелкните внутри выделенной области с помотцью любого инструмента из группы инструментов выделения (рис. 5.25).

Если щелкнуть вне выделенной области при активизированном инструменте Magic Wand (Волшебная палочка), Polygon Lasso (Полигональное лассо) или Magnetic Lasso (Магнитное лассо), то будет создана новая выделенная область.

Довольно сложно дважды выделить одну и ту же область, так что снимайте выделение с области только тогда, когда вы уверены, что закончили работать с ней. Если вы нечаянно все-таки сняли выделение, немедленно воспользуйтесь командой Undo (Отменить). Если же вы считаете, что данная выделенная область может понадобиться вам в дальнейшем, сохраните ее в виде контура или в альфа-канале.

Повторное выделение области

Чтобы заново выделить область, которая была выделена последней, выполните команду Select > Reselect (Выделить > Снова выделить) или нажмите комбинацию клавиш Ctrl+Shift+D.

Если на палитре History щелкнуть по элементу предыдущего состояния, в котором была задействована выделенная область, то при помощи команды Reselect можно снова выделить эту область.

Если из слоя удалить выделенную область, соответствующий участок станет прозрачным (рис. 5.26). При удалении области из фона соответствующий участок будет залит фоновым цветом (рис. 5.27).

Удаление выделенной области

Чтобы удалить выделенную область, нажмите клавишу Backspace или Delete. Можно также воспользоваться командой Edit > Clear (Правка > Очистить) либо, если выделенную область надо поместить в буфер обмена, командой Edit > Cut (Правка > Вырезать) или комбинацией клавиш Ctrl+X.

Перемещение рамки выделения

Следуйте нижеприведенному руководству, чтобы переместить только рамку выделения, а не точки, входящие в выделенную область.

  1. По желанию. Для более точного размещения рамки выполните команду View > Show > Grid (Вид > Показать > Сетка) или перетащите направляющую(ие) линию(и) горизонтальной или вертикальной линейки. Также выполните команды View > Snap To > Guides (Вид > Прикрепить к > Направляющие линии) и/или View > Snap To > Grid (Вид > Прикрепить к > Сетка).
  2. Активизируйте любой инструмент выделения.

Рис. 5.26. Результат удаления выделенной области из слоя

Рис. 5.27. Результат удаления выделенной области из фона

Рис. 5.28. Перемещение рамки выделения

Рис. 5.29. Исходная выделенная область -выделен утенок

Рис. 5.30. Выделенная область после инвертирования - теперь выделен фон

  3. Тащите курсор, поместив его внутрь выделенной области (рис. 5.28). Нажмите и удерживайте клавишу Shift после начала перетаскивания курсора, чтобы перемещать рамку под углом 45°, или нажмите одну из клавиш со стрелкой, чтобы переместить рамку на один пиксел в соответствующем направлении.

С помощью инструмента выделения можно перетащить рамку выделения из окна одного изображения в окно другого.

Если с помощью инструмента Move переместить выделенную область на слое, то точки, входящие в эту область, будут вырезаны из слоя, а освободившееся место станет прозрачным. С другой стороны, если выделенная область будет перемещена на фоне, то освободившееся место окрасится в фоновый цвет.

Инвертирование выделенной области

Чтобы поменять местами выделенную и невыделенную области, выполните команду Select > Inverse (Выделить > Инвертировать) или нажмите комбинацию клавиш Ctrl+Shift+I - см. рис. 5.29, 5.30.

Снова воспользуйтесь командой Inverse (Инвертировать) либо нажмите те же «горячие» клавиши, чтобы вернуться к исходной выделенной области.

Довольно просто выделить фигуру на однотонном фоне: активизируйте инструмент Magic Wand (Волшебная палочка), на панели опций введите в поле Tolerance (Допуск) значение 5 или меньше, щелкните по однотонному фону, чтобы выделить его целиком, затем воспользуйтесь командой Select > Inverse (Выделить > Инвертировать).

Скрытие рамки выделения

Порой граница выделенной области («марширующие муравьи») может раздражать или отвлекать внимание. Для того чтобы временно ее скрыть, следуйте приведенным ниже инструкциям. Границы выделения можно скрыть даже тогда, когда открыто диалоговое окно из меню Image (Изображение) или Filter (Фильтр).

Выберите команду View > Show > Selection Edges (Вид > Показать > Границы выделения), выделенная область при этом останется активной.

Для того чтобы снова отобразить рамку выделения, вновь воспользуйтесь командой View > Show > Selection Edges (Вид > Показать > Границы выделения).

«Горячие» клавиши Ctrl+H показывают/ прячут те элементы изображения и окна изображения, которые в данный момент доступны в подменю Show (Показать). Диалоговое окно Show Extras Options (Показать дополнительные опции), приведенное на рис. 5.31, вызывается командой View > Show > Show Extras Options (Вид > Показать > Показать дополнительные опции) и используется для определения состава подменю Show (Показать).

Чтобы убедиться, что выделенная область все еще активна, вызовите меню Select (Выделить). Если область активна, большинство крманд меню будут доступны.

Изменение рамки выделения

Команда Transform Selection (Трансформировать выделение), о которой рассказывается ниже, влияет только на рамку выделения, но не на точки области. Для того чтобы трансформировать содержимое выделенной области, можно воспользоваться командой из подменю Edit > Transform (Правка > Трансформировать) или трансформировать точки области с помощью габаритного контейнера (см. главу 7, раздел «Трансформация слоя простым перетаскиванием курсора»).

Рис. 5.31. Выбор элементов, показываемых/ скрываемых с помощью «горячих» клавиш Ctrl+H

Рис. 5.32. Изменение размеров рамки выделения

Рис. 5.33. Увеличение рамки, не влияющее на ее содержимое

Рис. 5.34. Подменю команд изменения замки выделения

Выберите команду Select > Transform Selection (Выделить > Трансформировать выделение), затем для выполнения переворота, поворота, изменения масштаба и т.д. (рис. 5.32, 5.33) обратитесь к соответствующим разделам главы 7.

Щелкните правой кнопкой мыши по изображению, затем выберите какую-либо команду трансформации из контекстного меню.

Изменение рамки выделения посредством команды меню

Чтобы изменить рамку выделения, выберите команду Select > Modify > Smooth (Выделить > Изменить > Сгладить) (рис. 5.34), Expand (Расширить) или Contract (Уменьшить), введите требуемое значение и щелкните по кнопке ОК.

Можно также воспользоваться командой Select > Grow (Выделить > Увеличить) или Similar (Похожие). Эти две команды используют текущее значение допуска инструмента Magic Wand (Волшебная палочка), о чем говорилось в разделе «Выделение области по цвету» данной главы. Затем можно повторить любую из этих команд, чтобы еще увеличить выделенную область.

Добавление точек к выделенной области

Активизируйте любой инструмент выделения кроме Magic Wand (Волшебная палочка), на панели опций щелкните по кнопке Add to selection (Добавить в выделенную область) - см. рис. 5.35. Если необходимо, выберите другие характеристики инструмента, затем перетащите курсор через область, которую нужно добавить к выделенной (рис. 5.36, 5.37). Можно не нажимать кнопку Add to selection, а просто расположить курсор над выделенной областью и, нажав клавишу Shift, протащить его через область, которую необходимо добавить.

Можно также активизировать инструмент Magic Wand (Волшебная палочка), щелкнуть по кнопке Add to selection (Добавить в выделенную область) на панели опций, затем щелкнуть вне выделенной области. (Для того чтобы не щелкать по кнопке Add to selection, нажмите клавишу Shift и щелкните вне выделенной области.)

Если дополнительная выделенная область немного перекрывает исходную, она станет частью новой выделенной области большего размера. Если же не перекрывает, будет создана вторая отдельная выделенная область.

Удаление точек из выделенной области

Активизируйте любой инструмент выделения кроме Magic Wand (Волшебная палочка), на панели опций щелкните по кнопке Subtract from selection (Удалить из выделенной области) - см. рис. 5.35. Если необходимо, выберите характеристики инструмента, затем перетащите курсор через область, которую нужно «вычесть» из выделенной. Чтобы не нажимать кнопку Subtract from selection, просто нажмите клавишу Alt и протащите курсор через область, которую необходимо удалить.

Рис. 5.35. Кнопки опций инструментов выделения

Рис. 5.36. Исходная выделенная область

Рис. 5.37. Результат добавления дополнительной выделенной области

Рис. 5.38. Рисование круговой выделенной области поверх существующей при нажатых клавишах Alt+Shift

Рис. 5.39. Результат пересечения двух выделенных областей

Можно также активизировать инструмент Magic Wand (Волшебная палочка), на панели опций щелкнуть по кнопке Subtract from selection (Удалить из выделенной области), затем щелкнуть мышью внутри выделенной области. (Чтобы не нажимать кнопку на панели опций, нажмите клавишу Alt и щелкните внутри выделенной области.)

Выделение пересечения двух выделенных областей

  1. При активной выделенной области выберите какой-либо инструмент выделения.
  2. На панели опций щелкните по кнопке Intersect with selection (Пересечь с выделением) - см. рис. 5.35. Затем создайте новую выделенную область, перекрывающую текущую (рис. 5.38, 5.39). Для того чтобы не нажимать кнопку Intersect with selection на панели опций, нажмите клавиши Alt+Shift и перетащите курсор.

Виньетирование изображения

  1. Выберите слой в многослойном изображении и выключите кнопку Lock transparent pixels (Блокировать прозрачные точки). Обрамление изображения, которое вы собираетесь создать, будет постепенно переходить в слой или слои, расположенные ниже выделенного.

    Для изображения, содержащего только фон, выберите фоновый цвет, который заполнит окружающую область (см. начало главы 10).

  2. Активизируйте инструмент Rectangular Marquee или Elliptical Marquee (клавиша М или Shift+M), либо инструмент Lasso (клавиша L или Shift+L).
  3. На панели опций в поле Feather (Pac-тушевывание) введите значение равное 15 или 20 пикселам. В качестве альтернативы можно растушевать выделенную область после ее создания (после шага 4), выбрав команду Select > Feather (Выделить > Растушевать).
  4. Создайте выделенную область (рис. 5.40).
  5. Выполните команду Select > Inverse (Выделить > Инвертировать) или воспользуйтесь комбинацией клавиш Ctrl+ Shift+I.
  6. Теперь нажмите клавишу Backspace или Delete.
  7. Снимите выделение, нажав комбинацию клавиш Ctrl+D - см. рис. 5.41-5.44.

Рис. 5.40. Исходная область со смягченными границами

Рис. 5.41. Изображение после виньетирования

Рис. 5.42. Исходное изображение (родственники Питера - без шуток)

Рис. 5.43. Изображение после виньетирования

Рис. 5.44. Результат применения фильтра Glass к изображению, полученному на шаге 6

Маскирование фигур с помощью команды Extract

Если когда-либо вам приходилось создавать маску для фигуры со сложной границей (человек с курчавыми волосами или пейзаж с животным), вы оцените команду Extract (Извлечь). Самая замечательная ее возможность заключается в том, что создание маски происходит в окне предварительного просмотра прямо в окне Extract (рис. 5.45), так что вы можете редактировать ее до тех пор, пока не убедитесь, что получили именно тот результат, который нужен. Когда-вы нажмете кнопку ОК, замаскированная область будет сохранена, остальные участки станут прозрачными.

Для большей безопасности работайте на копии изображения или, по крайней мере, на дубликате слоя. Также можно сделать снимок исходного изображения.

  1. Выберите слой, из которого вы хотите извлечь изображение.
  2. Выполните команду Filter > Extract (Фильтр > Извлечь) или нажмите комбинацию клавиш Cfrl+Alt+X. Появится диалоговое окно во весь экран, размер которого можно изменять.

Рис. 5.45. Результат оконтуривания и заливки фигуры орла

  3. Сначала воспользуйтесь инструментом Edge Highlighter (Выделение границы), чтобы создать маску для границы объекта, а затем активизируйте инструмент Fill (Заливка) и щелкните внутри объекта, чтобы залить его заданным цветом.

    На панели инструментов диалогового окна (рис. 5.46) выберите инструмент Edge Highlighter (клавиша В). В группе параметров Tool Options (Опции инструмента), показанной на рис. 5.47, введите значение параметра Brush Size (Размер кисти) в пикселах. Чем четче граница объекта, который вы собираетесь извлечь, тем меньший размер кисти вам понадобится. Укажите большой размер кисти, если у фигуры широкие, неровные границы.

    Выберите цвет выделения в меню Highlight (Выделение) - красный, зеленый или синий. Если вы указали вариант Other (Другое), на панели выбора цветов укажите желаемый оттенок.

  4. По желанию. Если вы собираетесь обвести четкие границы (например, геометрической фигуры), установите флажок Smart Highlighting (Умное выделение). Ширина выделения будет минимальной, но достаточной для покрытия границ фигуры независимо от текущего размера кисти.
  5. Протащите курсор вокруг границы изображения, которое хотите извлечь. Замкните рамку, чтобы получить замкнутую фигуру. Тащите курсор непосредственно вдоль границы изображения, чтобы «захватить» все завитки или бахрому. Нет необходимости тащить курсор вдоль края холста, если объект простирается настолько далеко.

Рис. 5.46. Панель инструментов окна Extract

Рис. 5.47. Параметры команды Extract

  6. По желанию. Увеличьте значение параметра Smooth (Гладко) в группе Extraction (Извлечение), чтобы исключить ненужные пикселы.
  7. На панели инструментов активизируйте инструмент Fill (Заливка), щелкнув по второй по счету пиктограмме или нажав клавишу G, и выберите цвет заливки.

Щелкните по области изображения, которую вы хотите извлечь. (Щелкните еще раз, чтобы удалить заливку.)

Для того чтобы извлечь пикселы определенного цвета, вместо использования инстру-мента Fill (Заливка) установите флажок Force Foreground (Использовать основной цвет), активизируйте инструмент Eyedropper (Пипетка), нажав клавишу I, и щелкните по какому-либо цвету в окне изображения. Либо щелкните по образцу цвета в поле Color и выберите желаемый оттенок на панели выбора цветов.

  8. С помощью инструмента Eraser (Ластик), которому соответствует клавиша Е, можно снять маску с определенных областей, если это необходимо. Выберите значение параметра Brush Size (Размер кисти) в группе Tool Options (Опции инструмента).

Для того чтобы увеличить масштаб окна предварительного просмотра, нажмите сочетание клавиш Ctri+знак «плюс», если же хотите его уменьшить, используйте комбинацию Ctrl+знак «минус». Также можно воспользоваться инструментом Zoom (Масштаб). Щелкая мышью при нажатой клавише AR, вы уменьшите масштаб просмотра.

Если масштаб предварительного просмотра превышает 100%, можно с помощью клавиши Н активизировать инструмент Hand (Рука) и перемещать изображение в окне предварительного просмотра (нажмите клавишу пробела, чтобы временно получить доступ к этому инструменту).

  9. Щелкните по кнопке Preview (Предварительный просмотр), затем в области предварительного просмотра окна Extract выполните любое из указанных ниже действий.

    Установите флажок/флажки Show Highlight (Показать выделение) и/или Show Fill (Показать заливку).

    Выберите в поле Show (Показать) вариант Extracted (Извлеченное), чтобы увидеть извлеченное изображение. Вариант Original (Исходное) позволит вернуться к исходной картинке.

    Выберите в поле Display (Отображение) значение None (Нет), чтобы фон был прозрачным. Если вы укажете Black Matte (Черное покрытие), Gray Matte (Серое покрытие) или White Matte (Белое покрытие), извлеченное изображение будет показано на черном, сером или белом фоне соответственно. Вариант Other (Другое) позволяет выбрать иной цвет, а в случае Mask (Маска) удаляемая область станет черной, а защищенная - белой.

  10. Для того чтобы подчистить маску, выполните любое из указанных ниже действий.

    Воспользуйтесь инструментом Cleanup (Очистить) (клавиша С), который постепенно уменьшает непрозрачность. Чтобы восстановить исходное значение непрозрачности, нажмите клавишу Alt и перетащите курсор.

    Воспользуйтесь инструментом Edge Touchup (Коррекция границы) (клавиша Т), который постепенно делает границы более четкими.

    Измените значение параметра Smooth.

  11. Щелкните по кнопке ОК. После этого, если вы захотите восстановить потерянные области, воспользуйтесь инструментом History brush (Восстанавливающая кисть) - см. рис. 5.48, 5.49. Для стирания лишнего вручную используйте инструмент Eraser (Ластик).

Сохранение контура извлеченного изображения в канале

Для того чтобы обведенный маркером участок соответствовал форме выделенной области, создайте такую область, выберите команду Select > Modify > Border (Выделить > Изменить > Граница), задайте ширину равной примерно 9 пикселам и щелкните по кнопке ОК. Инвертируйте выделенную область и сохраните ее в альфа-канале. Затем выполните команду Image > Extract (Изображение > Извлечь) и из всплывающего меню поля Channel (Канал), находящегося в группе Extraction (Извлечение), выберите этот альфаканал. И наконец, с помощью клавиши G активизируйте инструмент Fill (Заливка) и щелкните внутри выделенной области.

Рис. 5.48. Результат извлечения фигуры орла (в некоторых областях команда Extract перестаралась)

Рис. 5.49. Вид орла после применения инструмента Art History Brush (Художественная восстанавливающая кисть)


  • Глава 6. Компоновка
    • Перемещение
      • Перемещение содержимого выделенной области
      • Перемещение и копирование выделенной области
      • Выравнивание слоя или слоев по рамке выделения
      • Основные сведения о буфере обмена
    • Копирование
      • Копирование и вставка выделенной области
      • Перетаскивание выделенной области между изображениями
      • Вставка в выделенную область
      • Вставка фрагмента в изображение меньшего размера
    • Увеличение резкости и размытие изображений
    • Использование линеек и направляющих линий
      • Изменение положения начальной точки линейки
      • Использование режима Snap
      • Создание направляющей линии
      • Использование инструмента Measure
      • Клонирование областей в одном изображении
      • Использование инструмента Pattern Stamp
      • Использование инструмента Healing Brush
      • Использование инструмента Patch Tool
      • Клонирование фрагмента одного изображения с переносом в другое
      • Растушевка выделенной области
      • Устранение швов в слое
      • Сглаживание границы выделенной области

Глава №6.

Компоновка

В этой главе рассказывается о различных методах компоновки элементов изображения: буфере обмена (команды Cut (Вырезать), Сору (Копировать), Paste (Вставить) и Paste Into (Вставить в)), перетаскивании, клонировании и использовании образцов. Кроме того, говорится о методах точного расположения и выравнивания элементов изображения, а также сглаживания швов между ними.

Перемещение

Здесь и в разделе, рассказывающем о перетаскивании и копировании, речь идет о перемещении точек изображения. (О том, как переместить только рамку выделения, описано в главе 5, раздел «Перемещение рамки выделения».)

Перемещение содержимого выделенной области

  1. По желанию. Чтобы точно расположить выделенную область, выберите пункт меню View > Show > Grid (Вид > Показать > Сетка), либо нажмите комбинацию клавиш Ctrl+Alt+', либо перетащите направляющую(ие) линию(и) любой из линеек. Также включите опции View > Snap To > Guides (Вид > Прикрепить к > Направляющие линии) и Snap То > Grid (Прикрепить к > Сетка).
  2. Если выделенная область имеет фон, выберите его цвет. Область, которая откроется при перемещении выделения, будет автоматически залита фоновым цветом. Если выделенная область расположёна на слое, то открывшаяся область станет прозрачной.
  3. Активизируйте инструмент Move (Перемещение), или нажав клавишу V. Также этот инструмент можно активизировать, просто нажав клавишу Ctrl во время работы с большинством других инструментов.
  4. Расположите курсор над выделенной областью (курсор примет вид ножниц), затем тащите его. Рамка выделения будет перемещена вместе с содержимым выделенной области (рис. 6.1-6.3).

Когда вы снимете выделение с области, ее точки вернутся обратно на исходный слой, на свое новое место независимо от того, какой слой в данный момент будет активным.

Нажмите любую из клавиш со стрелкой, чтобы переместить рамку выделения на 1 пиксел в соответствующем направлении.

Перемещение и копирование выделенной области

  1. Активизируйте инструмент Move (Перемещение), или нажав клавишу V. Также этот инструмент можно активизировать, просто нажав клавишу Ctrl во время работы с большинством других инструментов.

    Нажав клавишу Alt, перетащите выделенную область, которую хотите скопировать (сначала отпустите кнопку мыши, а затем уже клавишу). Все скопированные пикселы останутся при этом выделенными (рис. 6.4, 6.5).

Рис. 6.1. Перемещение выделенной области на слое

Рис. 6.2. Открывшаяся прозрачная область

Рис. 6.3. Перемещение выделенной области на фоне с заливкой открывшейся области фоновым цветом

Рис. 6.4. Перемещение выделенной области

Рис. 6.5. Копия выделенных пикселов

Рис. 6.6. Кнопки команд выравнивания на панели опций инструмента Move

Нажмите клавишу Alt и клавишу со стрелкой, чтобы сместить копию выделенной области на 1 пиксел в соответствующем направлении. Нажав клавиши Alt+Shift и клавишу со стрелкой, можно переместить копию на 10 пикселов.

Выравнивание слоя или слоев по рамке выделения

Команды группы Align to Selection (Выровнять по выделению) выравнивают пикселы слоя по активной в данный момент рамке выделения. Если необходимо выровнять объекты, расположенные в разных слоях, можно отдельно выровнять каждый из них по одной и той же рамке либо сначала связать их (см. главу 14, раздел «Связывание слоев»), а затем выровнять их все сразу.

  1. Создайте выделенную область.
  2. Выберите какой-либо слой или один слой из группы связанных слоев.
  3. Активизируйте инструмент Move (Перемещение), на панели опций инструмента (рис. 6.6) щелкните по какой-либо кнопке выравнивания или выберите одну из команд меню Layer >Align To Selection> Top Edges (Слой> Выровнять по выделению > Верхние границы), Vertical Centers (Положение центров по вертикали), Bottom Edges (Нижние границы), Left Edges (Левые края), Horizontal Centers (Положение центров по горизонтали) или Right Edges (Правые края).

    Пикселы слоя будут выровнены по отношению к границам или центру рамки выделения в зависимости от того, какую опцию выравнивания вы выбрали.

Основные сведения о буфере обмена

Можно воспользоваться командами Edit > Cut (Правка > Вырезать) или Сору (Копировать), чтобы сохранить выделение в области временного хранения данных, называемой буфером обмена, затем выполнить команду Edit > Paste (Правка > Вставить) или Paste Into (Вставить в), чтобы вставить пикселы из буфера обмена в другой слой этого же изображения или вообще в другое изображение. Команды Cut (Вырезать), Сору (Копировать) и Paste Into (Вставить в) доступны только тогда, когда выделенная область активна.

Если создать выделенную область и выбрать команду Edit > Cut (Правка > Вырезать), область будет перемещена в буфер обмена. (Команда Clear (Очистить) не затрагивает буфер обмена.) Если вы вырезаете или очищаете выделенную область, расположенную на фоне, открывшийся участок будет залит текущим фоновым цветом. Если удалить выделенную область, расположенную на слое, то освободившийся участок будет прозрачным.

Чтобы получить более мягкие переходы между вставленным фрагментом и слоем, на панели опций инструмента выделения поставьте флажок Anti-Aliased (Сглаживание) до того, как вы этим инструментом воспользуетесь.

При помощи команды Edit > Paste (Правка > Вставить) вставляются пикселы из

буфера обмена в новый слой, при этом вставленные точки, оказавшиеся за пререлами окна изображения, будут сохранены. Можно передвинуть слой целиком, чтобы увидеть эти пикселы. Если сохранить документ, то находящиеся за пределами окна точки также будут сохранены. Если в дальнейшем вы отрежете часть слоя, на панели опций инструмента Crop (Кадрирование) поставьте переключатель Cropped Area (Отсекаемая область) в положение Hide (Спрятать), если не хотите, чтобы точки были удалены.

Одни и те же пикселы, находящиеся в буфере обмена, можно вставлять неограниченное число раз. Если в диалоговом окне Edit > Preferences > General (Правка > Установки > Общие) установлен флажок Export Clipboard (Экспорт буфера обмена), данные, находящиеся в буфере обмена, будут храниться во временной памяти системы, даже если вы выйдете из программы Photoshop. В буфере обмена в одно и то же время может находиться только одна выделенная область, и каждый раз при выполнении команд Cut (Вырезать) или Сору (Копировать) данные в буфере обмена будут замещаться новыми.

Размеры, показываемые в диалоговом окне New (Новый) при создании изображения, автоматически приводятся в соответствие с размерами изображения, находящегося в буфере обмена.

Если в буфере обмена содержится большой фрагмент, объем доступной памяти для других операций будет уменьшен. Для того чтобы очистить буфер обмена и освободить память, выберите команду Edit > Purge > Clipboard (Правка > Очистить > Буфер обмена). Эту операцию нельзя отменить.

Копирование

Прежде чем воспользоваться любой командой, работающей с буфером обмена, или копировать изображение методом перетаскивания, сравните размеры исходного изображения с размерами целевого. Если копируемый фрагмент больше целевого изображения, то некоторая часть копируемых пикселов при их вставке или перетаскивании окажется за границей окна изображения и не будет видна. Если вы хотите увидеть скрытые пикселы, передвиньте слой с помощью инструмента Move (Перемещение).

Размер выделенной области может поменяться при вставке или перетаскивании и по другой причине: это связано с разрешением целевого изображения. Если оно выше разрешения исходного изображения, копируемый фрагмент будет выглядеть меньше при вставке или перетаскивании. И наоборот, если разрешение целевого изображения ниже, чем разрешение исходного, копируемый фрагмент будет больше.

Если вы хотите, чтобы фрагмент сохранил свой размер, прежде чем скопировать его, сравняйте разрешения (и размеры, если хотите) исходного и целевого изображений с помощью диалогового окна Image > Image Size (Изображение > Размер изображения). О том, как выполнить вставку в изображение меньшего размера, рассказано в разделе «Вставка фрагмента в изображение меньшего размера».

Копирование и вставка выделенной области

  1. Выделите область на слое или фоне. Для того чтобы растушевать ее границу, выберите команду Select > Feather (Выделить > Растушевать) и введите требуемое значение.
  2. Выберите команду Edit > Сору (Правка > Копировать) или нажмите комбинацию клавиш Ctrl+C (Windows) или Cmd+C (Mac OS) — см. рис. 6.7. Если же хотите вырезать область, выберите Edit > Cut (Правка > Вырезать).
  3. Выберите слой, куда будете вставлять скопированную область.
  4. Воспользуйтесь командой Edit > Paste (Правка > Вставить) или нажмите комбинацию клавиш Ctrl+V - см. рис. 6.8.
  5. По желанию. Измените положение слоя относительно остальных слоев, переместите или подкорректируйте его края.

Чтобы превратить выделенную область в новый слой, выберите команду Layer > New > Layer Via Сору (Слой > Новый > Посредством копирования) или Layer Via Cut (Посредством вырезания). Подробнее об этом рассказано в главе 7, раздел «Превращение выделенной области в слой».

Перетаскивание выделенной области между изображениями

Если перетащить выделенные пикселы с одного изображения в другое, они будут скопированы на новый слой целевого изображения. Метод перетаскивания (drag-and-drop) не затрагивает буфер обмена, экономит память и сохраняет содержимое буфера. Если ваш монитор слишком мал, чтобы одновременно отображать два окна изображения, воспользуйтесь методом копирования-вставки.

  1. Откройте исходное и целевое изображения и расположите окна так, чтобы они не закрывали друг друга полностью.
  2. В исходном изображении выделите какую-либо область, расположенную на слое или фоне.

Рис. 6.7. Перемещение области фона в буфер обмена посредством команды Edit > Сору

Рис. 6.8. Расположение вставленного фрагмента в новом слое

Рис. 6.9. Перетаскивание выделенной области с фона с временной заливкой фоновым цветом открывшегося участка

Рис. 6.10. Появление черной границы в окне целевого изображения

  3. Активизируйте инструмент Move (Перемещение) или нажав клавишу V. Также доступ к этому инструменту можно получить, нажав клавишу Ctrl во время работы многих других инструментов.
  4. На панели опций инструмента Move установите флажок Show Bounding Box (Показать границы), если необходимо, чтобы была видна рамка выделенной области.
  5. Перетащите выделенный фрагмент на целевое изображение, отпустите кнопку мыши там, где хотите поместить его (рис. 6.9-6.11). Скопированный образ появится на новом слое. С помощью инструмента Move (Перемещение) можно его переместить. При этом исходное изображение не изменится.

При перетаскивании выделенной области нажмите клавишу Shift, чтобы автоматически поместить выделение в центр целевого изображения. Отпустить кнопку мыши можно в любой момент, когда курсор находится где-либо в окне целевого изображения.

Рис. 6.11. Появление скопированного изображения в целевом окне после того, как отпущена кнопка мыши

О том, как перетащить целый слой в другое изображение, рассказано в главе 7, разделы «Перетаскивание слоя в другое изображение».

Перетаскивание - единственный способ копирования слоя фигуры из одного документа в другой. Чтобы выделить слой фигуры, нажмите клавишу Ctrl и щелкните по нему.

Вставка в выделенную область

Если воспользоваться командой Paste Into (Вставить в) для того, чтобы вставить содержимое буфера обмена в выделенную область, автоматически будет создан новый слой и активная рамка выделения станет границей маски слоя. Затем вставленное изображение можно переместить внутри маски слоя или изменить форму самой маски, так чтобы стало видно большее или меньшее число пикселов.

  1. Выделите область слоя. Если вы хотите растушевать выделенную область, выберите команду Select > Feather (Выделить > Растушевать) и введите требуемое значение.
  2. Выполните команду Edit > Сору (Правка > Копировать), чтобы скопировать пикселы только активного слоя или Edit > Copy Merged (Правка > Копировать объединенные слои) (комбинация клавиш Ctrl+Shift+C), чтобы скопировать пикселы выделенной области всех видимых в данных момент слоев.
  3. Оставьте тот же слой активным либо выделите другой слой, либо выберите какой-либо слой другого изображения.
  4. Выделите область (области), в которую вы хотите вставить содержимое буфера обмена.

Рис. 6.12. Результат вставки изображения нот в слой текста

Рис. 6.13. Перемещение содержимого слоя относительно маски слоя с помощью инструмента Move

Рис. 6.14. Появление вставленного изображения на новом слое с автоматическим созданием маски слоя

  5. Выберите команду Edit > Paste Into (Правка > Вставить в) или нажмите комбинацию клавиш Ctrl+Shift+V. Будет создан новый слой и маска слоя (рис. 6.12-6.14).

    Для создания эффекта, показанного на рис. 6.12, «музыкальный» слой был выделен и скопирован. В другом изображении при нажатой клавише Ctrl щелкнули по слою текста, затем выполнили команду Edit > Paste Into (Правка > Вставить в). В результате появился новый слой.

  6. Можно также использовать дополнительные опции.

Иногда после вставки в слой содержимого буфера маска слоя скрывает некоторые пикселы. Для того чтобы переместить маску слоя относительно слоя, активизируйте инструмент Move (Перемещение), щелкните по миниатюре маски слоя (см. рис. 6.14) и перетащите курсор в окне изображения. Для того чтобы переместить содержимое слоя, щелкните по его миниатюре и перетащите курсор в окне изображения.

Если раскрасить маску слоя в окне изображения белым цветом, будет показано больше точек, если черным - некоторые точки окажутся скрыты.

Для того чтобы переместить слой и маску слоя одновременно, щелкните мышью между миниатюрами слоя и маски слоя, в результате чего они будут связаны (повторной щелчок по пиктограмме связи разрушит связь), затем активизируйте инструмент Move (Перемещение) и перетащите курсор в окне изображения.

Вставка фрагмента в изображение меньшего размера

Обычно в программе Photoshop при перемещении большой выделенной области или слоя либо их вставке в другое изображение все текущие или вставленные пикселы слоя сохраняются, даже если они расположены за его видимой границей. Если вы хотите подрезать изображение при вставке, следуйте приведенным ниже инструкциям, но перед выполнением каких-либо операций прочитайте раздел «Копирование» этой главы.

  1. Щелкните по окну целевого изображения, затем нажмите и удерживайте кнопку мыши при нажатой клавише Alt, расположив курсор над строкой состояния, находящейся внизу окна изображения. Запомните ширину, высоту и разрешение изображения.
  2. Щелкните мышью в окне исходного изображения, выберите команду Image > Duplicate (Изображение > Дублировать) и щелкните по кнопке ОК.
  3. При активном окне дубликата изображения выберите команду Image > Image Size (Изображение > Размер изображения).
  4. Установите флажок Resample Image (Отслеживать изменения) и измените разрешение так, чтобы оно совпадало с разрешением целевого изображения (рис. 6.15). В поле Print Size (Размер при печати) укажите значения параметров Width (Ширина) и Height (Высота) меньшие, чем те, которые вы запомнили на шаге 1. Щелкните по кнопке ОК.
  5. Выберите слой, который хотите скопировать.

Рис. 6.15. Изменение размеров и разрешения изображения

За границей слоя

Для того чтобы удалить пикселы, расположенные на пределами слоя, убедитесь, что слой активен и выберите команду Edit > Select All (Правка > Выделить все), а затем Image > Crop (Изображение > Кадрировать). Удаление лишних пикселов уменьшит размер файла.

Если применить команду редактирования изображения, например фильтр, ко всему слою, то точки, расположенные за пределами слоя, также будут изменены. Чтобы сделать их видимыми в окне изображения, увеличьте размер холста (Image > Canvas Size (Изображение > Размер холста)).

Для того чтобы выделить точки, расположенные за пределами слоя, нажмите клавишу Ctrl и щелкните по имени слоя на палитре Layers (Слои) - не используйте команду Edit > Select All (Правка> Выделить все).

  6. Воспользуйтесь командой Select > All (Выделить > Все), чтобы выделить слой, затем выберите команду Edit > Сору (Правка > Копировать), щелкните в окне целевого изображения и выберите команду Edit О Paste (Правка > Вставить); или, нажав клавишу Shift, перетащите имя исходного слоя в окно целевого изображения.
  7. Закройте дубликат изображения. Если хотите, сохраните исходное изображение.

Вместо шагов 3 и 4 можно выбрать команду File > Automate > Fit Image (Файл > Автоматизация > Подгонка изображения) и ввести желаемые значения ширины и высоты (из шага 1). Команда Fit Image (Подгонка изображения) не изменит разрешения изображения; разрешение скопированного или перетащенного слоя станет равным разрешению целевого файла.

Увеличение резкости и размытие изображений

Инструмент Blur (Размытие) уменьшает контраст между точками. Воспользуйтесь им, чтобы смягчить границы между фрагментами изображения. Инструмент Sharpen (Резкость) увеличивает контраст между пикселами, поэтому его используют для того, чтобы очертить границы фигур. Ни один из этих инструментов не может быть использован для изображения в режиме Bitmap или Indexed Color.

  1. Активизируйте инструмент Blur (Размытие) или Sharpen (Резкость) (клавиша R или Shift+R). Для каждого инструмента на панели опций сохраняются собственные значения параметров.

Рис. 6.16. Панель опций инструмента Blur

  2. На панели опций выбранного инструмента (рис. 6.16) щелкните по стрелке поля Brush (Кисть) и выберите кисть с четкими или расплывчатыми контурами.

    Выберите режим смешивания в поле Mode (Режим). Вариант Normal (Нормальный) означает увеличение резкости/размытия пикселов любого оттенка. В случае Darken (Темный) воздействие оказывается только на те пикселы, которые темнее основного цвета. В режиме Lighten (Светлый) - только на те пикселы, которые светлее основного цвета. В режиме Hue (Тон) или Color (Цвет) инструмент несколько усилит дополнительные цвета, а в режиме Saturation (Насыщенность) - существующие цвета. Режим Luminosity (Яркость) означает увеличение яркости. (Режимы смешивания подробно описаны в главе 2, раздел «Режимы смешивания».) Различия в режимах более заметны при работе с инструментом Sharpen (Резкость), нежели с инструментом Blur (Размытие). Выберите величину параметра Pressure (Нажим) в процентах. Сначала попробуйте небольшое значение (скажем, 30%).

Щелкните по изображению правой кнопкой мыши, чтобы выбрать режим смешивания.

Рис. 6.17. Исходное изображение

Рис. 6.18. Результат применения инструмента Sharpen к изображению цветка, расположенному в центре, и инструмента Blur к оставшейся части картинки

  3. По желанию. На панели опций установите флажок Use All Layers (Использовать все слои), чтобы взять пикселы, расположенные под курсором, и с других видимых слоев; в дальнейшем пикселы будут размещены в активном слое.
  4. В окне изображения протащите курсор через ту область, резкость или размытие которой необходимо увеличить (рис. 6.17,6.18). Для усиления эффекта повторите операцию.

Для того чтобы структура изображения не стала зернистой, установите среднее значение нажима для инструмента Sharpen (Резкость) и на одну и ту же область наносите только один штрих.

Используйте все, что у вас есть

Если на панели опций инструментов Magic Wand (Волшебная палочка), Smudge (Палец), Sharpen (Резкость), Blur (Размытие) или Clone Stamp (Клонирующий штамп) снят флажок Use All Layers (Использовать все слои), вы увеличите резкость, размоете границы и т.д. только того слоя, который выбран в данный момент. Если же этот флажок установлен, влияние будет оказано на расположенные под курсором пикселы всех видимых в данный момент слоев. Включите эту опцию и попробуйте перенести пикселы на новый слой.

Использование линеек и направляющих линий

Сетка, линейки и направляющие линии помогают точно расположить объекты.

Чтобы линейки были видны на экране, выберите пункт меню View > Rulers (Вид > Линейки) или нажмите комбинацию клавиш Ctrl+R. В окне изображения сверху и слева появятся линейки, а текущее

положение курсора будет обозначено пунктирным указателем на каждой из линеек (рис. 6.19). Для того чтобы спрятать линейки, снова выберите пункт меню View > Rulers (Вид > Линейки).

Для того чтобы быстро открыть раздел Units&Rulers (Единицы измерения и линейки) диалогового окна Preferences (Установки) и изменить единицы измерения линеек, дважды щелкните по любой линейке.

Изменение положения начальной точки линейки

Начальная точка линейки - точка, от которой измеряется координата объекта.

  1. По желанию. Для того чтобы начальная точка линейки была прикреплена к линии сетки, сначала включите режим показа сетки, выбрав пункт меню View Ф Show > Grid (Вид > Показать > Сетка) или нажав комбинацию клавиш Ctrl+ Alt+'. Затем можно будет воспользоваться командой View > Snap To > Grid (Вид > Прикрепить к > Сетка).

    Для того чтобы начальная точка линейки была прикреплена к направляющей линии, выберите View > Snap To > Guides (Вид > Прикрепить к > Направляющие линии), затем перетащите направляющую линию в окно изображения, если вы еще этого не сделали.

    Более подробную информацию о прикреплении вы найдете в разделе «Использование режима Snap» этой главы.

  2. Перетащите начальную точку с пересечения линеек, расположенного в верхнем левом углу окна изображения, по диагонали изображения (рис. 6.20, 6.21). Обратите внимание на то, где теперь располагаются нули на линейках.

Рис. 6.19. Линейки в окне изображения

Рис. 6.20. Перетаскивание начальной точки линеек

Рис. 6.21. Новая начальная точка линеек

Для того чтобы восстановить исходное положение начальной точки, дважды щелкните по квадратику на пересечении линеек, расположенному в верхнем левом углу окна изображения.

Использование режима Snap

Режим Snap работает как электронный «буксирный трос». При включенной опции View > Snap (Вид > Прикрепить) и перемещении границы выделения, ломтика (slice) изображения, курсора инструмента рисования, контура или фигуры перемещаемый элемент будет прикреплен к ближайшей направляющей линии, линии сетки, ломтику изображения или границе документа в зависимости от того, какая опция выбрана в подменю View > Snap To (Вид > Прикрепить к).

  1. Выберите пункт меню View > Snap To> Guides (Вид > Прикрепить к > Направляющие линии), Grid (Сетка), Slices (Ломтики), Document Bounds (Границы документа), All (Все вышеперечисленное) или None (Ничего).

Для того чтобы включить опцию Snap To > Grid (Прикрепить к > Сетка), сетка должна быть видна (View > Show > Grid (Вид > Показать > Сетка)).

  2. Убедитесь, что включена опция View > Snap (Вид > Прикрепить) - рядом должна стоять галочка. Если опция отключена, включить ее можно с помощью комбинации клавиш Ctrl+;.

Сетка представляет собой не выводимые на печать линии, используемые для выравнивания элементов изображения. Направляющие линии - отдельные объекты, которые можно перетаскивать в окне изображения. При включенной опции View > Snap То > Guides (Вид > Прикрепить к >

Направляющие линии) выделенная область или курсор инструмента будут прикреплены к направляющей линии при перемещении на расстояние в 8 пикселов от нее. Аналогично работает команда View > Snap To > Grid (Вид > Прикрепить к > Сетка).

Выберите пункт меню View > Show > Grid (Вид > Показать > Сетка) или нажмите комбинацию клавиш Ctrl+Alt+' -см. рис. 6.24. Для того чтобы скрыть сетку, выберите этот пункт еще раз. Показ сетки может быть включен и выключен для отдельных файлов.

Отображение и прикрепление различных элементов

Отобразить или скрыть границы выделенной области, целевой контур, сетку, направляющие линии, ломтики, примечания или все вышеперечисленное можно посредством команд подменю View > Show (Вид > Показать) - см. рис. 6.22. Команда Show Extras (Показать дополнительные) показывает/скрывает только доступные в данный момент элементы из подменю Show (Показать).

Чтобы включить возможность прикрепления к направляющим линиям, сетке, ломтикам, границам документа или ко всему вышеперечисленному, воспользуйтесь командами из подменю View > Snap То (Вид > Прикрепить к) - см. рис. 6.23. Команда Snap (Прикрепить) включает/ выключает все выбранные в данный момент опции подменю Snap To (Прикрепить к).

Рис. 6.22. Подменю Show

Рис. 6.23. Подменю Snap To

Рис. 6.24. Линии сетки

Рис. 6.25. Перетаскивание направляющей линии в окно изображения

Расположение направляющей линии в указанной позиции

  1. Выберите команду View > New Guide (Вид > Новая направляющая линия).
  2. Поставьте переключатель Orientation (Ориентация) в положение Horizontal (Горизонтальная) или Vertical (Вертикальная) - см. рис. 6.26.
  3. Введите желаемое значение в поле Position (Положение) в любых единицах измерения.
  4. Щелкните по кнопке ОК.

Рис. 6.26. Окно New Guide

Создание направляющей линии

Убедитесь в том, что линейки присутствуют на экране, затем в окно изображения перетащите линию с горизонтальной или вертикальной линейки (рис. 6.25). При включенной опции Snap (Прикрепить) нажмите клавишу Shift и расположите линию так, чтобы она была прикреплена к делению линейки. Если на экран выводится сетка и включена опция View > Snap То > Grid (Вид > Прикрепить к > Сетка), направляющая линия будет прикреплена к линии сетки. Также направляющую линию можно прикрепить к рамке выделения.

Если вы хотите зафиксировать все направляющие линии, так чтобы нельзя было сдвинуть их с помощью инструмента Move (Перемещение), выберите команду View > Lock Guides (Вид > Блокировать направляющие линии) или нажмите комбинацию клавиш Ctrl+Alt+;

Нажав клавишу Аlt при создании направляющих линий, вы сможете переключиться с вертикального расположения линий на горизонтальное (или наоборот).

Чтобы изменить положение существующей направляющей линии, перетащите ее с помощью инструмента Move (Перемещение), убедившись, что направляющие линии не зафиксированы. Направляющие будут сохранять взаимное расположение при изменении размеров изображения, если они не зафиксированы.

В диалоговом окне Edit > Preferences > Guides&Grid (Правка > Установки > Направляющие линии и сетка) можно выбрать новый цвет и стиль направляющей линии. Активизируйте инструмент Move (Перемещение) и дважды щелкните по направляющей линии, чтобы быстро открыть это диалоговое окно.

Удаление направляющих линий

Для того чтобы удалить одну направляющую линию, с помощью инструмента Move (Перемещение) перетащите ее за пределы окна изображения или удалите все направляющие линии с помощью команды View > Clear Guides (Вид > Очистить направляющие линии).

Использование инструмента Measure

  1. Выберите инструмент Measure (Измеритель), нажав клавишу I или Shift+I; теперь он находится во всплывающей палитре инструмента Eyedropper.
  2. Перетащите курсор в окне изображения (рис. 6.27). Угол наклона (А) и длина (D) полученной линии будут показаны на палитре Info (Информация) -см. рис. 6.28. Если перетаскивать курсор при нажатой клавише Shift, угол наклона будет кратен 45°.
  3. По желанию. После того как вы уже нарисовали одну линию с помощью инструмента Measure (Измеритель), нажмите клавишу Alt и перетащите курсор с одного из концов линии, чтобы построить угол (рис. 6.29). Его величина будет указана на палитре Info (Информация) - см. рис. 6.30. В любой момент можно подкорректировать угол, перетащив одну из конечных точек линии.
  4. После окончания работы с инструментом Measure (Измеритель) выберите другой инструмент. Если же снова активизировать этот инструмент, построенные ранее линии вновь появятся на экране. Для того чтобы удалить эти линии, перетащите их за пределы изображения с помощью инструмента Measure (Измеритель).

Рис. 6.27. Перетаскивание курсора в окне изображения с помощью инструмента Measure

Рис. 6.28. Данные об угле наклона (А) и длине (D) линии на палитре Info

Рис. 6.29. Построение угла путем перетаскивания курсора при нажатой клавише Alt

Рис. 6.30. Данные о длине линий D1 и D2 и величине угла между ними (А) на палитре Info

Рис. 6.31. Левая часть панели опций инструмента Clone Stamp

Рис. 6.32. Правая часть панели опций инструмента Clone Stamp

Рис. 6.33. Перетаскивание курсора в области, где должен находиться клон изображения, при установленном флажке Aligned

Воспользовавшись инструментом Measure (Измеритель), можно перетащить линию измерения или измеритель угла в другую часть изображения. Тащите за любую часть линии за исключением крайней точки, если только вы не хотите поменять угол.

Клонирование областей в одном изображении

Инструмент Clone Stamp (Клонирующий штамп) используется для переноса клона объекта с одного слоя на другой в пределах одного и того же многослойного изображения или с одного изображения на другое.

  1. Активизируйте инструмент Clone Stamp (Клонирующий штамп), или нажав клавишу S или Shift+S.
  2. На панели опций инструмента (рис. 6.31, 6.32) щелкните по стрелке поля Brush (Кисть), затем выберите размер кисти, подходящий для области, которую вы хотите клонировать.

    Выберите режим смешивания в поле Mode (Режим), а также значение параметра Opacity (Непрозрачность) в процентах.

    Установите флажок Aligned (Выровненный), чтобы создать единый неразрывный клон области, связанный с одной исходной точкой. Можно отпустить кнопку мыши и перейти к другому фрагменту и, кроме того, изменить режим и размер кисти между нанесением штрихов (рис. 6.33). Снимите флажок Aligned (Выровненный), чтобы создать несколько клонов, соответствующих одной и той же исходной точке. Курсор в виде перекрестия будет возвращаться к этой исходной точке каждый раз, как вы отпускаете кнопку мыши (рис. 6.34).

    Установите флажок Use All Layers (Использовать все слои), чтобы выбирать пикселы со всех видимых в данный момент слоев, по которым вы щелкаете при нажатой клавише Alt. Снимите этот флажок, чтобы выбирать пикселы только с активного слоя.

  3. На палитре Layers (Слои) выберите слой, фрагмент которого хотите клонировать.
  4. В окне изображения, нажав клавишу Alt, щелкните по области слоя, которую вы хотите клонировать, чтобы создать исходную точку. Не щелкайте по прозрачной области слоя, там нечего клонировать.
  5. На этом же слое перетаскивайте курсор в то место, где, по вашему мнению, должна появиться копия фрагмента изображения. (Можно также выбрать или создать другой слой, а затем перетаскивать там курсор.) На экране появятся два курсора: перекрестие над исходной точкой и курсор инструмента Clone Stamp (Клонирующий штамп) или пиктограмма кисти там, где вы перетаскиваете курсор. Картинка, над которой находится перекрестие, «проявится» в том месте, где вы перетаскиваете курсор, и заменит нижележащие пикселы.

Если на палитре Layers (Слои) установлен флажок Lock transparent pixels (Блокировать прозрачные точки), клонированный образ будет появляться только там, где слой непрозрачен.

  6. По желанию. Чтобы создать новую исходную точку для операции клонирова-ния, нажмите клавишу Alt и щелкните по другой области исходного изображения.

В перерывах между нанесением штрихов можно изменять значения параметров на панели опций инструмента Clone Stamp. Для создания эффекта наложения («двойной экспозиции») выберите небольшое значение непрозрачности, тогда лежащие ниже пикселы будет слегка проглядывать сквозь клонированные (рис. 6.35).

Рис. 6.34. Создание нескольких клонов изображения при снятом флажке Aligned

Рис. 6.35. Создание эффекта наложения при значении непрозрачности равном 50%

Чтобы клонировать изображение, соответствующее более раннему этапу работы, воспользуйтесь инструментом History Brush.

Рис. 6.36. Выделение области для использования ее в качестве узора

Рис. 6.37. Результат клонирования узора при различных значениях непрозрачности инструмента Pattern Stamp

Использование инструмента Pattern Stamp

  1. Для создания собственного узора (pattern) активизируйте инструмент Rectangular Marquee (Прямоугольная область), выделите область изображения (рис. 6.36), затем выберите команду Edit > Define Pattern (Правка > Определить узор), введите какое-либо имя, щелкните по кнопке ОК и снимите выделение с области (комбинация клавиш Ctrl+D).
  2. Активизируйте инструмент Pattern Stamp (Штамп узора), или нажав клавишу S или Shift+S.
  3. На панели опций инструмента выберите аналогичные характеристики, что и для инструмента Clone Stamp (см. выше). Установите флажок Aligned (Выровненный), чтобы узор располагался в строгом соответствии с сеткой независимо от того, сколько штрихов вы наносите. Снимите этот флажок, если хотите, чтобы узор выглядел более хаотично.

    Щелкните по стрелке поля Pattern (Узор), выберите образец на выпадающей панели (рис. 6.38). Определенный вами на шаге 1 узор должен быть последним в списке.

  4. Перетаскивайте курсор на каком-либо слое того же или другого изображения, чтобы клонировать узор (рис. 6.37). Для этого инструмента не требуется указания какой-либо исходной точки.

Щелкните правой кнопкой мыши в окне изображения, чтобы выбрать другую кисть.

Рис. 6.38. Выбор узора на панели

Использование инструмента Healing Brush

В состав Photoshop 7 включен новый инструмент Healing Brush. Данное средство предназначено, в первую очередь, для устранения дефектов изображений, таких как «шум», мелкие царапины, следы пыли и т.п. Healing Brush действует в этих случаях бережно и «умно», сохраняя светотени, текстуру и другие атрибуты оригинала. Это делает Healing Brush незаменим средством ретуширования. С его помощью можно с минимальными усилиями восстановить поврежденные фрагменты изображений волосяных покровов или удалить с фотографии родинки, веснушки и другие мелкие детали.

Healing Brush вызывается через главную панель инструментов или нажатием клавиш J или Shift+J.

Данный инструмент является разновидностью инструмента Stamp Tool и имеет те же особенности использования. Есть лишь некоторые отличия в настройке: отсутствует регулировка прозрачности и интенсивности закрашивания (параметры Opacity и Flow). Инструмент Healing Brush имеет два режима работы: Sampled (По образцу) и Pattern (Текстурное) (рис. 6.39). В первом случае вы получитяе в свое распоряжение более «интеллектуальный» инструмент

Clone Stamp, во втором - улучшенный вариант инструмента Pattern Stamp.

Действие инструмента Clone Stamp может распространяться на все слои (если включена опция Use all layers), а инструмент Healing Brush влияет только на активный слой.

Использование инструмента Patch Tool

Данный инструмент предназначен для исправления достаточно больших поврежденных участков по образу и подобию сохранившихся. Чтобы воспользоваться инструментом Patch Tool, выполните следующие действия:

  1. Вызовите данный инструмент, щелкнув по его пиктограмме на панели инструментов или нажав клавиши J или Shift+J (рис. 6.40).
  2. Щелкните по кнопке Source на настроечной палитре инструмента и выделите область-источник с помощью лассо (рис. 6.41а).
  3. Щелкните по кнопке Destination и выделите поврежденную область (рис. 6.41б).
  4. Щелкните по кнопке Heal Selection (см. рис. 6.40).

Рис. 6.39. Панель опций инструмента Healing Brush

Рис. 6.40. Панель опций инструмента Patch

а)

б)

Рис. 6.41. Выделение области-источника и области-приемника

Рис. 6.42. Левая часть панели опций инструмента Clone Stamp

Рис. 6.43. Правая часть панели опций инструмента Clone Stamp

Клокирование фрагмента одного изображения с переносом в другое

С помощью инструмента Clone Stamp можно клонировать фрагмент картинки с переносом из одного изображения в другое. Воспользуйтесь этим приемом, чтобы собрать участки различных открытых изображений в одном изображении. Для этого переносите фрагменты в новый документ с белым или однотонным фоном, используя кисть со смягченными границами.

  1. Откройте два изображения и расположите два окна рядом.
  2. Если оба изображения цветные, выберите для них одинаковый режим. Также можно переносить клонируемые фрагменты между цветным и полутоновым изображением.

Для того чтобы сохранить слои, выберите опцию Don't Flatten (He объединять).

  3. Активизируйте инструмент Clone Stamp (Клонирующий штамп), или нажав клавишу S или Shift+S.
  4. На панели опций инструмента (рис. 6.42, 6.43) щелкните по стрелке поля Brush (Кисть) и выберите кисть нужной формы.

    Выберите режим смешивания в поле Mode (Режим) и значение параметра Opacity (Непрозрачность).

    Установите флажок Aligned (Выровненный), чтобы воссоздать непрерывную область, начиная с исходной точки, либо снимите флажок, чтобы создать несколько клонов исходного изображения.

  5. Щелкните мышью в окне изображения, куда вы хотите клонировать исходное изображение, и выберите слой для него.
  6. Нажав клавишу Alt, щелкните по области исходного (неактивного) изображения, где расположен клонируемый объект (см. рис. 6.44, 6.45).
  7. В окне целевого (активного) изображения перетаскивайте курсор, чтобы получить клон исходного объекта.

Растушевка выделенной области

Примените команду Feather (Растушевать), чтобы размыть границу выделенной области на заданную ширину с той и с другой стороны рамки выделения. Например, при радиусе растушевки равном 5 пикселам растушеванная область будет иметь ширину в 10 пикселов.

Эффект растушевки не будет заметен до тех пор, пока вы не измените выделенную область с помощью инструмента рисования, копирования/вставки фрагмента, перемещения, заливки цветом, применения какого-либо фильтра или команды из меню Image (Изображение).

  1. Выберите команду Select > Feather (Выделить > Растушевать), нажав комбинацию клавиш Ctrl+Alt+D.
  2. В поле Radius (Радиус) введите число, не превышающее 250. Ширина затрагиваемой области зависит от разрешения изображения. Чем выше разрешение, тем больший радиус растушевки необходимо указать.
  3. Щелкните по кнопке ОК или нажмите клавишу Enter - см. рис. 6.47, 6.48.

Если радиус растушевки слишком велик для выделенной области, появится сообщение: No pixels are more than 50% selected (Нельзя растушевать более половины выделенных пикселов).

Рис. 6.44. Исходное изображение и его клон в целевом окне

Рис. 6.45. Результат клонирования изображения с переносом в новый документ, имеющий белый фон

Чтобы указать радиус растушевки при создании выделенной области, автивизируйте инструмент Marquee или Lasso и на панели опций введите требуемую величину.

Рис. 6.46. «Смешение»,

Рис. 6.47. Исходное изображение, границы выделенной области растушеваны

Рис. 6.48. Результат инвертирования выделенной области и нажатия клавиши Delete

Для создания изображения, показанного на рис. 6.46, Дэвид Хамфри скомпоновал отсканированное украшение, собственные рисунки, фотографии и прочие элементы. Он подкорректировал уровень яркости различных компонентов в отдельных слоях с помощью режимов смешивания (Darken, Multiply) и инструментов Eraser и Burn.

Устранение швов в слое

Для того чтобы убрать заметные швы после вставки или перемещения пикселов слоя, воспользуйтесь командой Defringe (Удалить бахрому). Эта команда перекрашивает пикселы на границе выделенной области в соответствии с цветом пикселов, расположенных на определенном расстоянии внутри области.

Если перемещенный или вставленный фрагмент изначально располагался на черном фоне и был сглажен, можно воспользоваться командой Layer > Matting > Remove Black Matte (Слой > Кайма > Удалить черную кайму), чтобы удалить ненужные остатки фона. Выберите команду Remove White Matte (Удалить белую кайму), если фрагмент изначально располагался на белом фоне.

  1. Выделите слой, в который был вставлен фрагмент изображения, и выберите команду Layer > Matting > Defringe (Слой > Кайма > Удалить бахрому).
  2. Введите какое-либо значение в поле Width (Ширина) - см. рис. 6.49. Сначала попробуйте ввести небольшое значение (1,2 или 3 пиксела), так чтобы границы не потеряли своей определенности. Данная команда может также оказать влияние на некоторые неграничные области.
  3. Щелкните по кнопке ОК.

Сглаживание границы выделенной области

Команда Smooth (Сгладить) добавляет или удаляет невыделенные пикселы к/из выделенной области в соответствии с заданным значением радиуса. Это хороший способ избавиться от лишних точек, особенно после использования инструмента Magic Wand (Волшебная палочка).

  1. Выберите команду Select > Modify > Smooth (Выделить > Изменить > Сгладить).
  2. Введите величину радиуса (от 1 до 100 пикселов) - см. рис. 6.50. Если большинство пикселов в этом радиусе выделены, то оставшиеся также будут выделены; если же большинство пикселов в радиусе не выделены, то эти точки будут удалены из выделенной области.
  3. Щелкните по кнопке ОК (рис. 6.51, 6.52).

Рис. 6.49. Использование команды Defringe для удаления швов на смонтированном изображении

Рис. 6.50. Подчистка выделенной области с помощью команды Smooth

Рис. 6.51. Исходная область, выделенная инструментом Magic Wand

Рис. 6.52. Результат применения команды Smooth с радиусом равным 3


  • Глава 7. Слои
    • Создание нового слоя
      • Превращение выделенной области в слой
      • Дублирование слоя в одном и том же изображении
    • Операции над слоями
      • Скрытие и показ слоя
      • Переворачивание слоя
      • Удаление слоя
      • Трансформация слоя простым перетаскиванием курсора
      • Произвольная трансформация слоя
      • Трансформация слоя при помощи ввода точных числовых значений
      • Изменение порядка следования слоев
      • Преобразование фона в слой и слоя в фон
      • Перемещение слоя
      • Создание набора слоев
      • Блокировка слоя
      • Создание слоя заливки
    • Инструменты для работы со слоями
      • Инструменты для работы со слоями
      • Задействование всех слоев
      • Сохранение копии слоя в новом файле
      • Перетаскивание слоя в другое изображение
      • Копирование и вставка видимой области слоя в другое изображение
    • Слияние и объединение слоев
      • Слияние двух слоев
      • Слияние нескольких слоев
      • Объединение слоев

Глава №7.

Слои

Слои похожи на чистые лоскутки ацетатной ткани: непрозрачные там, где есть какой-либо рисунок, и прозрачные там, где рисунка нет. Для каждого слоя можно задать собственный уровень непрозрачности и режим, управляющий тем, как этот слой сочетается со слоями, расположенными ниже него. Можно изменить порядок расположения слоев, а также связать с любым слоем маску слоя. Нельзя одновременно редактировать несколько слоев: когда вы изменяете часть изображения, другие слои при этом не затрагиваются.

Если при создании нового изображения в раскрывшемся после выполнения команды меню File > New (Файл > Новый) диалоговом окне установить переключатель Contents (Содержание) в положение White (Белый) или Background Color (Фоновый цвет), самая нижняя часть изображения станет фоном, то есть не будет слоем. Если же выбрать вариант Transparent (Прозрачный), самая нижняя часть изображения окажется слоем. В любой момент к изображению можно добавить дополнительные слои.

На палитре Layers (Слои) расположен список слоев, начиная с самого верхнего и заканчивая самым нижним. Конечно же, Background (Фон) будет находиться в конце списка (рис. 7.1). Слой, выделенный в данный момент на палитре (активный), - единственный, который можно редактировать. Чтобы активизировать какой-либо слой, достаточно щелкнуть по его имени. Имя активного слоя (или слово Background) отображается в заголовке окна изображения.

Рис. 7.1. Палитра Layers

Если вы уже изучили, как вставить выделенную область в слой или создать текст, то вы знаете, что в обоих случаях автоматически создается новый слой. Из главы 9 вы узнаете о такой разновидности слоев, как корректирующие слои, которые используются для предварительного просмотра эффектов корректировки цвета на нижележащих слоях. В этой же главе изложена основная информация о слоях.

Рис. 7.2. Отображение размера документа в строке состояния

Если сохранить изображения в любом формате кроме формата Photoshop (.psd) или Advanced TIFF (.tif), все слои будут объединены, а прозрачные точки самого нижнего слоя станут непрозрачного белого цвета. Что касается изменения режима изображения (например, преобразование из режима RGB в CMYK), то если вы хотите сохранить слои, установите флажок Don't Flatten (He объединять) или Don't Merge (He сливать).

Рис. 7.3. Кнопка создания нового слоя на палитре Layers

Рис. 7.4. Окно выбора параметров вновь создаваемого слоя

Рис. 7.5. Выбор размера миниатюры слоя

В изображении может содержаться столько слоев, сколько позволяет свободная память и место на диске. Пикселы, расположенные на каждом слое, занимают определенное дисковое пространство, поэтому когда вы закончите работать с большим изображением, лучше объединить или слить слои, чтобы уменьшить размер файла (рис. 7.2).

Создание нового слоя

  1. Для того чтобы создать на 100% непрозрачный слой в режиме Normal (Нормальный), щелкните по кнопке Create New Layer (Создать новый слой), расположенной внизу палитры Layers (Слои) - см. рис. 7.3. Никаких других действий в этом случае не потребуется.

    Если же вы хотите при создании слоя задать его свойства, из меню палитры Layers (Слои) выберите команду New Layer (Новый слой) либо, нажав клавишу Alt, щелкните по кнопке Create New Layer внизу палитры Layers, затем выполните последующие шаги.

  2. В поле Name (Имя), показанном на рис. 7.4, введите какое-либо имя нового слоя. Поставьте флажок Group With Previous Layer (Сгруппировать с предыдущим слоем), чтобы новый слой стал частью группы отсечения (подробнее об этом рассказано в главе 14, раздел «Группы отсечений»).

    Выберите цвет для области на палитре Layers (Слои), расположенной под пиктограммой в виде глаза и пиктограммой кисти.

    Выберите другое значение параметров Mode (Режим смешивания) и Opacity (Непрозрачность), позднее эти характеристики могут быть изменены.

  3. Щелкните по кнопке ОК. Новый слой появится непосредственно над слоем, который до этого был активным.

Для того чтобы ускорить работу с большим файлом в программе Photoshop, из меню палитры Layers (Слои) выберите пункт Palette Options (Опции палитры), затем выберите наименьший размер для миниатюры слоя или вариант None (Нет) - см. рис. 7.5.

Превращение выделенной области в слой

  1. Создайте выделенную область.
  2. Для того чтобы разместить копию выделенных пикселов на новом слое и оставить исходный слой без изменений, выполните команду Layer > New > Layer Via Сору (Слой > Новый > Посредством копирования) либо воспользуйтесь комбинацией клавиш Ctrl+J. Для того чтобы разместить выделенные точки на новом слое и удалить их с исходного, выберите команду Layer > New > Layer Via Cut (Слой >Новый > Посредством вырезания) либо воспользуйтесь комбинацией клавиш Ctrl+ Shift+J - см. рис. 7.6 и 7.7.
  3. По желанию. Щелкните по значку в виде глаза для исходного слоя, чтобы временно скрыть его.

Дублирование слоя в одном и том же изображении

Для создания нового слоя с автоматически генерируемым именем перетащите имя слоя, дубликат которого вы хотите создать, на кнопку Create New Layer (Создать новый слой), расположенную . внизу палитры Layers (Слои). Дубликат слоя появится над исходным слоем и станет активным. Для того чтобы дать имя дубликату слоя при его создании, щелкните правой кнопкой мыши по слою, который вы хотите дублировать, и выберите команду Duplicate Layer (Дублировать слой) либо, нажав клавишу Alt, перетащите слой на кнопку Create New Layer. В поле As (Как) введите имя дубликата слоя и щелкните по кнопке ОК (рис. 7.8, 7.9).

Рис. 7.6. Слой исходного фона

Рис. 7.7. Создание нового слоя в результате вырезания фрагмента фона

Рис. 7.8. Выбор команды дублирования слоя из контекстного меню

Рис. 7.9. Дубликат слоя на палитре Layers

Рис. 7.10. Пиктограмма, управляющая видимостью слоя

Если вы собираетесь распечатать изобра-жение, помните, что распечатаны будут толь-ко видимые слои. Аналогично при слиянии слоев: только видимые слои можно слить (о слиянии и объединении слоев рассказано в конце этой главы). Будьте особенно осторожны при использовании команды Flatten Image (Плоское изображение): спрятанные слои в расчет не берутся.

Операции над слоями

Есть по крайне мере две причины для того, чтобы временно скрывать слои, с которыми вы в данный момент не работаете. Первая - они отвлекают внимание, и вторая -без них производительность программы Photoshop повышается.

Скрытие и показ слоя

На палитре Layers (Слои) щелкните по значку в виде глаза, соответствующему тому слою, который вы хотите скрыть (рис. 7.10-7.12). Щелкните по тому же квадратику еще раз, чтобы снова отобразить слой.

Перетащите курсор, удерживая нажатой кнопку мыши, по колонке с пиктограммами в виде глаза, чтобы спрятать или показать несколько слоев.

Рис. 7.11. Изображение со спрятанным слоем Layer 1

Нажав клавишу Alt, щелкните по значку в виде глаза, чтобы спрятать все слои (включая фон), кроме того, по значку которого вы щелкнули. Нажмите клавишу Alt и щелкните еще раз, чтобы снова отобразить все слои.

Щелкните правой кнопкой мыши по колонке, где находятся значки в виде глаза, и из контекстного меню выберите пункт Show/ Hide all other layers (Показать/ скрыть все другие слои). Также существует возможность пометить любой слой одним из цветов, доступных в контекстном меню (рис. 7.13).

Переворачивание слоя

  1. На палитре Layers (Слои) выберите слой, который вы хотите перевернуть. Любые слои, связанные с активным, также будут перевернуты.
  2. Выберите команду Edit >Transform > Flip Horizontal (Правка > Трансформировать > Перевернуть по горизонтали) или Flip Vertical (Перевернуть по вертикали) - см рис. 7.14 и 7.15.

Рис. 7.12. Изображение с видимым слоем Layer 1

Рис. 7.13. Контекстное меню

Рис. 7.14. Исходное изображение

Рис. 7.15. Результат перевертывания слоя Layer 1 по горизонтали

Рис. 7.16. Удаление слоя Layer 1 при помощи контекстного меню

Рис. 7.17. Результат удаления слоя Layer 1

Удаление слоя

На палитре Layers (Слои) щелкните по имени слоя, который вы хотите удалить. Затем щелкните по кнопке Trash (Корзина) и выберите Yes (Да) либо, нажав клавишу Alt, щелкните по кнопке корзины, чтобы не появлялось окно с вопросом.

Еще один способ удаления слоя: щелкните правой кнопкой мыши по имени слоя, который хотите удалить, из контекстного меню выберите команду Delete Layer (Удалить слой) и щелкните по варианту ответа Yes (рис. 7.16 и 7.17).

Передумали? Нет проблем. Выберите команду Edit > Undo (Правка > Отменить) или на палитре History (История) щелкните по предыдущему состоянию.

Трансформация слоя простым перетаскиванием курсора

  1. На палитре Layers (Слои) активизируйте слой, который хотите трансформировать. Любые слои, связанные с данным, также будут изменены. Нельзя трансформировать изображение, в котором приходится 16 бит на канал. По желанию. Создайте выделенную область, чтобы трансформировать только выделенные пикселы.
  2. Выберите команду Edit > Transform > Scale (Правка > Трансформировать > Масштаб), Rotate (Поворот), Skew (Скос), Distort (Искажение) или Perspective (Перспектива). Вокруг непрозрачной части слоя появится однотонная рамка.
  3. По желанию. Чтобы трансформировать слой или выделенную область относительно точки, не являющейся центром, переместите опорную точку (рис. 7.18).

Эту точку можно переместить даже за пределы габаритной рамки.

Если вы собираетесь трансформировать слой несколько раз, то в целях экономии времени и сохранения качества изображения, после выполнения первой команды примените дополнительные команды преобразования, а затем зафиксируйте сразу все внесенные изменения (шаг 5).

  4. Чтобы изменить размер изображения по горизонтали и вертикали, перетащите угол рамки (рис. 7.18). Для изменения размеров только по вертикали или только по горизонтали перетащите боковую границу рамки. Нажав клавишу Shift, можно сохранить соотношение ширины и высоты. Нажмите клавишу Alt и вы сможете изменять масштаб изображения относительно опорной точки. Чтобы повернуть изображение, поместите курсор рядом с манипулятором рамки, хоть внутри, хоть снаружи (курсор примет вид двусторонней стрелки), и тащите курсор по кругу (рис. 7.19). Нажмите клавишу Shift, и у вас появится возможность повернуть изображение на угол кратный 15°.

    При выполнении операции скоса перетащите угловой манипулятор, если требуется изменить только его положение, либо перетащите манипулятор боковой стороны, чтобы наклонить изображение относительно горизонтальной или вертикальной оси. Нажмите клавишу Alt и скос будет происходить симметрично относительно центра слоя.

    При выполнении команды Distort (Искажение) - см. рис. 7.20 - перетащите угловой манипулятор рамки в любую требуемую точку, либо перетащите манипулятор боковой границы, чтобы исказить ее относительно горизонтальной и/или вертикальной оси. Нажмите клавишу Alt, и искажение слоя будет симметричным относительно центра слоя. Данная операция позволяет более заметно изменить изображение, нежели скос.

Рис. 7.18. Изменение масштаба изображения

Рис. 7.19. Поворот изображения

Рис. 7.20. Результат выполнения команды Distort

Рис. 7.21. Исходное изображение

Рис. 7.22. Результат выполнения команды Perspective

При выполнении команды Perspective (Перспектива) перетащите угловой манипулятор вдоль вертикальной или горизонтальной оси, чтобы создать перспективу вдоль выбранной оси (рис. 7.21 и 7.22). Остальные углы изменятся соответственно. Либо перетащите манипулятор боковой границы, чтобы наклонить исходное изображение относительно горизонтальной или вертикальной осц.

  5. Для того чтобы зафиксировать внесенные изменения, дважды щелкните мышью внутри габаритной рамки либо щелкните по кнопке Щ на панели опций (или нажмите клавишу Enter). Чтобы отменить трансформацию, щелкните по кнопке £| или нажмите клавишу Esc.

Для отмены последнего перемещения манипулятора рамки выполните команду Edit > Undo (Правка > Отменить).

Для того чтобы переместить слой (или выделенную область) целиком, перетащите курсор мыши внутри габаритной рамки.

В диалоговом окне, которое вызывается с помощью команды Edit > Preferences > General (Правка > Установки > Общие) либо комбинации клавиш Ctrl+K, выберите метод интерполяции для команд трансформации. Вариант Bicubic (Бикубический,)- самый лучший, но самый медленный метод - дает наименьшее ухудшение качества изображения.

Для того чтобы повторить последнюю операцию трансформации, выберите команду Edit > Transform > Again (Правка > Трансформировать > Снова) либо воспользуйтесь комбинацией клавиш Ctrl+ Shift+T.

Чтобы трансформировать дубликат выделенной области, при выборе команды держите нажатой клавишу Alt либо воспользуйтесь «горячими» клавишами: Ctrl+Alt+T.

Помимо трансформации слоя можно трансформировать альфа-канал, границу выделенной области (см. главу 5, раздел «Изменение рамки выделения»), контур (см. главу 16, «Изменение формы контура») или несвязанную активную маску слоя.

Произвольная трансформация слоя

Так как вы уже знакомы с отдельными командами трансформации, возможно, вы захотите начать работу и с командой Free Transform (Произвольная трансформация), особенно если вам необходимо провести серию преобразований. В этом случае вы получите доступ к различным комбинациям «горячих» клавиш - нет необходимости выбирать каждую команду из меню. И что лучше всего, реальные действия над исходным изображением проводятся только один раз, в тот момент, когда вы подтверждаете необходимость внесения изменений.

  1. На палитре Layers (Слои) выберите слой, который вы хотите трансформировать. Все связанные с ним слои также будут изменены. Нельзя применять операции трансформации к изображениям, каналы которых представлены 16 битами каждый. По желанию. Создайте выделенную область, чтобы ограничить трансформацию только ею.
  2. Выберите команду Edit > Free Transform (Правка > Произвольная трансформация) либо воспользуйтесь комбинацией клавиш Ctrl+T.

    Можно также активизировать инструмент Move. (Перемещение) и на панели опций установить флажок Show Bounding Box (Показать габаритную рамку).

Эта опция может служить помехой для опции Auto Select Layer (Автовыделение слоя), о которой рассказано ниже, в разделе «Быстрое выделение слоя».

  3. Выполните операции трансформации, как описано в пункте 4 предыдущего раздела, принимая во внимание следующие отличия:
    • для выполнения команды Skew перетаскивайте курсор при нажатых клавишах Ctrl+Shift;
    • для выполнения команды Distort перетаскивайте курсор при нажатой клавише Ctrl;
    • для выполнения команды Perspective перетаскивайте угловой манипулятор рамки при нажатых клавишах Ctrl+Alt+Shift.

    Трансформация изображения автоматически будет выполняться относительно центра слоя.

  4. Зафиксировать внесенные изменения можно тремя способами: дважды щелкните мышью внутри рамки, или нажмите клавишу Enter. Для отмены изменений щелкните по кнопке Esc.

    Необходимо либо принять изменения, либо отменить их, чтобы вернуться к обычному редактированию.

При изменении слоя или выделенной области обратите внимание на значения ширины (W), высоты (Н), угла поворота (А) и горизонтального (Н) или вертикального скоса (V) на панели опций или палитре Info (Информация).

При трансформации слоя (или выделенной области, расположенной на слое) любое освободившееся после преобразования пространство станет прозрачным. Если изменять выделенную область, расположенную на фоне, освободившееся пространство будет залито фоновым цветом.

Трансформация слоя при помощи ввода точных числовых значений

Этот раздел предназначен для тех, кто предпочитает изменять слой, вводя точные числовые значения, а не перетаскивая курсор. Поля для ввода значений появляются на панели опций после выбора операции трансформации.

Рис. 7.23. Вид фрагмента панели опций при выборе команды Free Transform

  1. На палитре Layers (Слои) выберите слой, который хотите трансформировать. Все слои, связанные с ним, также будут изменены.
  2. Выберите команду Edit > Free Transform (Правка > Произвольная трансформация) либо нажмите комбинацию клавиш Ctrl+T.
  3. На панели опций выберите расположение опорной точки, которая будет использоваться при перемещении, вращении и переворачивании изображения. Для этого щелкните по одному из 9 маленьких квадратиков или в окне изображения перетащите опорную точку в требуемую позицию.

    Можно также щелкнуть по кнопке Use relative positioning for reference point (Использовать относительные координаты опорной точки), чтобы значения в полях X и Y стали равными 0; в противном случае значения в этих полях будут отображать абсолютное положение опорной точки, измеренное относительно верхнего левого угла слоя. (Щелкните по этой кнопке еще раз, чтобы выключить опцию. Для выбора других единиц измерения щелкните правой кнопкой мыши по какому-либо значению.)

  4. Выполните любой из перечисленных ниже шагов:
  • для перемещения слоя введите новые значения в поля X и Y (рис. 7.23);

Для перемещения слоя или выделенной области на определенное расстояние сначала необходимо установить положение опорной точки. В противном случае будет перемещена опорная точка, а не слой.

  • для выполнения масштабирования слоя введите значения ширины (W) и/или высоты (Н) в процентах (рис. 7.24). Чтобы выбрать другие единицы измерения, щелкните правой кнопкой мыши по любой из величин и выберите нужный вариант из всплывающего меню;
  • для поворота слоя введите угол поворота (рис. 7.25);
  • щелкните по кнопке Maintain aspect ratio (Сохранять пропорции по горизонтали и вертикали), чтобы сохранить текущее отношение ширины к высоте;
  • для скоса слоя введите значение угла наклона относительно горизонтали и/или вертикали (см. рис. 7.25).
  5. Для того чтобы зафиксировать внесенные изменения, дважды щелкните мышью внутри габаритной рамки, (рис. 7.26), либо нажмите клавишу Enter. Чтобы отменить трансформацию, или нажмите клавишу Esc.

Активизируйте инструмент Measure (Измеритель), нажав комбинацию клавиш Shlft+l, перетащите курсор в окне изображения, чтобы определить угол, затем, не меняя инструмент, выберите команду Edit > Transform > Rotate (Правка > Трансформация > Поворот). Слой будет автоматически повернут на заданный угол.

Рис. 7.24. Поля параметров, управляющих масштабированием

Рис. 7.25. Поля параметров, управляющих вращением и скосом

Рис. 7.26. Кнопки фиксации и отмены трансформации

Рис. 7.27. Исходное изображение

Рис. 7.28. Перетаскивание слоя WORDS вверх

Рис. 7.29. Новое расположение слоев

Рис. 7.30. Вид изображения после изменения порядка следования слоев в стеке

Изменение порядка следования слоев

  1. На палитре Layers (Слои) щелкните по имени слоя, положение которого относительно других слоев вы хотите изменить.
  2. Перетащите имя слоя вверх или вниз по палитре и отпустите кнопку мыши, когда темная горизонтальная линия займет нужное положение (рис. 7.27-7.30).

Положение активного слоя относительно других слоев можно изменить и другим способом: выбрав команду Layer > Arrange > Bring to Front (Слой > Расположить > Поверх остальных), Bring Forward (Перенести вверх), Send Backward (Перенести вниз) или Send to Back (Ниже остальных). «Горячие» клавиши, соответствующие этим командам, приведены в табл. 7.1. Помните, что нельзя расположить какой-либо слой под фоном.

Для того чтобы переместить фон вверх в списке слоев, сначала необходимо преобразовать его в слой (см. раздел «Преобразование фона в слой и слоя в фон» этой главы).

Таблица 7.1. «Горячие» клавиши для изменения положения активного слоя в стеке слоев

Операция | Сочетание клавиш
Перенести вверх | Ctrl+]
Поверх остальных | Ctrl+Shift+]
Перенести вниз | Ctrl+[
Ниже остальных | Ctrl+Shift+[

Преобразование фона в слой и слоя в фон

Стандартные операции, применимые к слою (например, изменение положения относительно остальных слоев, выбор режима смешивания или значения непрозрачности, создание маски слоя), не могут быть осуществлены по отношению к фону до тех пор, пока его не преобразовали в слой.

На палитре Layers .(Слои) щелкните по фону (рис. 7.31), введите новое имя (рис. 7.32), выберите значения параметров Mode (Режим) и Opacity (Непрозрачность) для слоя и щелкните по кнопке ОК (рис. 7.33).

Второй способ: нажав клавишу Alt, дважды щелкните по элементу фона на палитре Layers (Слои), чтобы пропустить ввод данных в диалоговом окне.

Если необходимо создать фон для файла, у которого фона нет, можно преобразовать существующий слой в фон.

  1. Выберите слой.
  2. Воспользуйтесь командой Layer > New > Background From Layer (Слой > Новый > Фон из слоя). Новый фон будет расположен внизу всех слоев на палитре Layers (Слои).

Перемещение слоя

О том, как переместить сразу несколько слоев, рассказано в главе 14, раздел «Связывание слоев».

  1. На палитре Layers (Слои) выберите слой, который вы хотите переместить.
  2. Активизируйте инструмент Move (Перемещение), которому соответствует клавиша V и пиктограмма 1%.1, либо нажмите и удерживайте клавишу Ctrl.
  3. Перетащите курсор в окне изображения. Весь слой целиком будет перемещен (рис. 7.34 и 7.35).

Рис. 7.31. Активизация фона

Рис. 7.32. Ввод имени слоя

Рис. 7.33. Результат превращения фона в слой

Рис. 7.34. Исходное изображение

Рис. 7.35. Результат перемещения текстового слоя с помощью инструмента Move

Рис. 7.36. Контекстное меню выбора слоя

При активизированном инструменте Move (Перемещение) нажмите какую-либо клавишу со стрелкой, чтобы переместить активный слой на 1 пиксел в соответствующем направлении. Если же при этом нажать еще и клавишу Shift, то слой будет перемещен сразу на 10 пикселов. (Не нажимайте клавишу Alt одновременно с клавишей со стрелкой, так как в этом случае будет создан дубликат слоя.)

Если пикселы оказались за текущими границами изображения, не беспокойтесь, они будут сохранены вместе с изображением.

Если на панели опций установлен флажок Auto Select Layer (Автовыделение слоя), можно быстро выделить слой, щелкнув курсором инструмента Move (Перемещение) по любым видимым пикселам. Однако если эта опция включена, то вы не сможете перетащить какую-либо область слоя, прозрачность которой выше 50%.

Чтобы при работе с инструментом Move (Перемещение) обеспечить наиболее быстрый предварительный просмотр изображений с высоким разрешением, откройте диалоговое окно Edit > Preferences > Display&Cursors (Правка > Установки > Отображение и курсоры) и установите флажок Use Pixel Doubling (Использовать увеличение пикселов). При перетаскивании пикселов они будут временно удваиваться в размере (разрешение уменьшится вполовину).

Быстрое выделение слоя

Если активизирован инструмент Move (Перемещение), щелкните правой кнопкой мыши в окне изображения и из контекстного меню выберите слой (рис. 7.36). Нажмите дополнительно к указанным клавишу Ctrl, если активизирован другой инструмент. В меню появятся только слои, содержащие непрозрачные точки в позиции, на которую указывает курсор.

При активизированном инструменте Move нажмите клавишу Ctrl и щелкните по какому-либо объекту в окне изображения, чтобы быстро активизировать слой, содержащий этот объект.

Создание набора слоев

В программе Photoshop 7 реализован довольно удобный метод для работы со слоями: создание набора слоев (layer set). Если слои включены в набор, можно отобразить на палитре Layers (Слои) только имя этого набора или щелкнуть по стрелке (рис. 7.37), чтобы увидеть имена всех слоев, входящих в набор. Наборы делают работу с палитрой Layers (Слои) намного проще, особенно в случае многослойных изображений.

Корректирующие слои и режимы смешивания слоев, входящих в набор, влияют только на слои, входящие в этот набор. Так что еще одно достоинство использования наборов - возможность ограничивать действие режимов смешивания и корректирующих слоев определенной группой слоев. К тому же, как и отдельный слой, целый набор слоев может быть изменен при помощи маски слоя. За исключением случая, когда установлен режим смешивания слоев Pass Through (Пройти сквозь), который задан по умолчанию для набора слоев, набор ведет себя так, как будто слои слиты в один.

  1. Внизу палитры Layers (Слои) щелкните по кнопке Create new set (Создать новый набор), показанной на рис. 7.38.

    Можно также выполнить команду Layer > New > Layer Set (Слой > Новый > Набор слоев) и, если необходимо, изменить данные в полях Name (Имя), Color (Цвет), Mode (Режим смешивания) или значение параметра

Рис. 7.37. Слои WORDS и FLOWER, входящие в набор Set 1

Рис. 7.38. Кнопка Create new set на палитре Layers

Рис. 7.39. Средства блокировки слоев

Opacity (Непрозрачность), а затем щелкнуть по кнопке ОК.

  2. На палитре Layers (Слои) перетащите каждый слой, который хотите включить в набор, на пиктограмму набора (см. рис. 7.37).

Блокировка слоя

Опция Lock (Блокировка) в программе Photoshop 7 помогает предотвратить случайные изменения изображения.

  1. На палитре Layers (Слои) выберите слой, который хотите заблокировать.
  2. Установите флажок Lock position (Блокировать положение), чтобы заблокировать положение слоя (рис. 7.39). Теперь нельзя переместить слой, но редактировать его все еще можно.

Если установить флажок Lock all (Заблокировать все), слой будет защищен от всех операций редактирования.

О том, как заблокировать прозрачные точки или пикселы изображения (первые два флажка), см. раздел «Блокировка прозрачных точек» этой главы.

Удаление слоя из набора

Для того чтобы вывести какой-либо слой из набора, протащите его имя поверх имени текущего или другого набора либо расположите его над или под именем какого-либо слоя, не входящего в этот набор.

Создание слоя заливки

Слой заливки (fill layer) работает так же, как и корректирующий слой, за исключением того, что содержит однотонную окраску, градиент или узор. Как и корректирующий слой, слой заливки можно редактировать или удалять, не влияя при этом на остальные слои (о корректирующих слоях читайте в начале главы 9).

  1. На палитре Layers (Слои) выберите слой, поверх которого должен появиться слой заливки (позднее его можно будет переместить).
  2. Из всплывающего меню Create new fill or adjustment layer (Создание нового слоя заливки или корректирующего слоя), кнопка вызова которого расположена внизу палитры Layers (Слои) -см. рис. 7.40, - выберите вариант Solid Color (Однотонный цвет), Gradient (Градиент) или Pattern (Узор).

    Если при создании слоя необходимо задать его параметры, выберите команду меню Layer > New Fill Layer > Solid Color (Слой > Новый слой заливки > Однотонный цвет), Gradient (Градиент) или Pattern (Узор). Затем выполните любой из указанных ниже шагов: введите имя слоя; выберите цвет для области на палитре Layers (Слои), на которой расположены пиктограммы с изображением глаза и кисти/связи; выберите другое значение непрозрачности и режим смешивания или установите флажок Group With Previous Layer (Сгруппировать с предыдущим слоем), чтобы новый слой вошел в группу отсечения (см. главу 14, раздел «Группа отсечений»). Щелкните по кнопке ОК. Впоследствии все эти опции могут быть изменены.

Рис. 7.40. Палитра Layers

Рис. 7.41. Выбор опций для слоя заливки узором

  3. В случае однотонной окраски (вариант Solid Color) выберите для слоя цвет на панели Color Picker (Выбор цвета) и щелкните по кнопке ОК.

В случае Gradient (Градиент) также выберите подходящий образец и укажите для него значения параметров Style (Стиль), Angle (Угол) и Scale (Масштаб). Об опциях Reverse (Обратить), Dither (Размыть) и Align with Layer (Выровнять со слоем) рассказано в главе 13, раздел «Применение градиента в качестве слоя заливки».

В случае Pattern (Узор) выберите образец рисунка, а также масштаб в процентах (от 1 до 1000) - см. рис. 7.41.

По желанию. Выполните одно из следующих действий:

  • снимите флажок Link with Layer (Связать со слоем), чтобы узор оставался неподвижным при перемещении слоя;
  • щелкните по кнопке Snap to Origin (Прикрепить к начальной точке), чтобы узор был привязан к текущей начальной точке линейки, то есть к точке, в которой пересекаются нулевые значения на вертикальной и горизонтальной линейках (см. главу 14, раздел «Применение эффекта Pattern Overlay»);
  • щелкните по кнопке Create new preset (Создать новый образец), чтобы создать образец.
  4. Щелкните по кнопке ОК.

С помощью палитры Layers (Слои) подкор-ректируйте режим и непрозрачность слоя заливки.

Инструменты для работы со слоями

Для изменения пикселов активного слоя можно воспользоваться любым инструментом редактирования или рисования, однако помните, что на результат работы инструмента влияет не только режим смешивания и значение непрозрачности, выбранные для инструмента на его панели опций, но и режим смешивания и непрозрачность самого слоя (рис. 7.42). Например, если непрозрачность слоя составляет 60%, то инструмент с 100% непрозрачности будет работать со значением непрозрачности в 60%; если же непрозрачность, заданная для инструмента, ниже 100%, то итоговое значение непрозрачности будет еще ниже. В случае, показанном на рис. 7.42, непрозрачность слоя составляет 75% (палитра Layers), а уровень непрозрачности инструмента Paintbrush (Кисть) - 50% (панель опций), итоговая непрозрачность штриха кисти будет равна 37%.

Блокировка прозрачных точек

Если на палитре Layers (Слои) установлен флажок Lock transparent pixels (Блокировать прозрачные точки), то редактировать или перекрашивать можно только непрозрачные точки слоя (рис. 7.43 и 7.44); пустые области останутся неизменными (эта опция замещает опцию Preserve Transparency (Сохранять прозрачность) программы Photoshop 5). Если же вы хотите создать видимые точки, опцию Lock transparent pixels надо выключить. Помните, что ее можно включать и выключать для любых отдельных слоев.

Рис. 7.42. Несовпадение уровней прозрачности активного слоя и текущего инструмента

Рис. 7.43. Установка режима Lock transparent pixels для текстового слоя

Рис. 7.44. Результат перекрашивания текстового слоя - прозрачные точки не затронуты

Опция Lock transparent pixels (Блокировать прозрачные точки) будет всегда включена для текстового слоя, который не подвергался рендерингу. В противном случае (для текстового слоя после рендеринга) данный режим можно включать и выключать.

Если воспользоваться инструментом Eraser (Ластик), установив на его панели опций флажок Lock transparent pixels (Блокировать прозрачные точки), то видимые точки не будут удалены, а приобретут текущий фоновый цвет.

Нажмите клавишу / (слэш), чтобы включить/выключить опцию Lock transparent pixels (Блокировать призрачные точки).

Можно изменить размер и цвет шахматного рисунка, который используется для обозначения прозрачных областей слоя, или вообще отключить его применение. Для этого вызовите диалоговое окно Edit > Preferences > Transparency & Gamut (Правка > Установки > Прозрачность и гамма) либо нажмите комбинацию клавиш Ctrl+K, а затем Ctrl+4.

Задействование всех слоев

Если на панели опций инструмента Blur (Размытие), Sharpen (Резкость), Smudge (Палец), Paint Bucket (Ведро с краской), Magic Eraser (Волшебный ластик) или Magic Wand (Волшебная палочка) установлен флажок Use All Layers (Использовать все слои), то инструмент будет выбирать точки со всех видимых в данный момент слоев. Независимо от того, включена ли эта опция или нет, изменять можно точки только активного слоя.

Сохранение копии слоя в новом файле

Скажем, вы собираетесь выполнить операцию, которая обязательно вызовет объединение слоев изображения, например, хотите преобразовать документ в режим Indexed Color (Индексированный цвет), не поддерживающий многослойных изображений, или сохранить файл в формате, отличном от формата Photoshop. Если при этом вы хотите сохранить копии некоторых отдельных слоев до того, как они будут объединены, действуйте по приведенным ниже инструкциям. Отдельные слои можно сохранить в новом документе или уже существующем, открытом.

  1. На палитре Layers (Слои) выберите слой, копию которого вы хотите сохранить.
  2. Щелкните по нему правой кнопкой мыши и из контекстного меню выберите команду Duplicate Layer (Дублировать слой).
  3. Выберите в группе Destination (Целевой) значение New (Новый) в поле Document (Документ) - см. рис. 7.45.
  4. В поле As (Как) введите имя слоя, под которым он появится в новом файле.
  5. В поле Name (Имя) в группе Destination (Целевой) укажите имя для нового файла.
  6. Щелкните по кнопке ОК и сохраните новый документ.

Перетаскивание слоя в другое изображение

Существует два способа для перетаскивания/копирования слоев из одного изображения в другое. Выберите метод в зависимости от того, какую область каждого слоя вам необходимо скопировать, и хотите ли вы копировать связанные слои. При перетаскивании имени слоя с палитры Layers (Слои) в окно целевого изображения области, выходящие за границы изображения, также будут скопированы. Этот метод описывается первым. Если же вы хотите обрезать подобные области при копировании слоя, воспользуйтесь вторым методом; только он позволяет скопировать связанные слои.

Рис. 7.45. Диалоговое окно Duplicate Layer

Использование палитры Layers

  1. Откройте оба изображения: первое, содержащее слой, который, вы хотите скопировать (рис. 7.46), и второе, куда он будет скопирован (целевое изображение). Убедитесь, что их окна не закрывают друг друга полностью.
  2. Щелкните по окну исходного изображения.
  3. На палитре Layers (Слои) щелкните по имени слоя, который вы хотите скопировать (рис. 7.47). При этом может быть активизирован любой инструмент.
  4. Перетащите имя слоя с палитры Layers (Слои) в окно целевого изображения (см. рис. 7.47). Отпустите кнопку мыши тогда, когда темная граница займет требуемое положение. Добавленный слой будет расположен поверх ранее активного слоя в целевом изображении (рис. 7.48).

Рис. 7.46. Исходное изображение

Рис. 7.47. Перетаскивание имени слоя в окно целевого изображения

Использование инструмента Move

В этом разделе описан метод, позволяющий копировать отдельные слои или несколько связанных слоев из одного изображения в другое.

  1. Откройте изображение, содержащее слой, который вы хотите скопировать (исходное изображение), и изображение, куда он будет помещен (целевое изображение).
  2. На палитре Layers (Слои) щелкните по имени слоя, который вы хотите копировать. Если необходимо перетащить несколько слоев, убедитесь, что они связаны (см. главу 14, раздел «Связывание слоев»),
  3. По желанию. Щелкните по окну целевого изображения, а затем по имени того слоя на палитре Layers (Слои), поверх которого вы хотите разместить скопированный слой.

Рис. 7.48. Вид целевого изображения после добавления слоя FAN

  4. Активизируйте инструмент Move (Перемещение), нажав клавишу V или щелкнув по пиктограмме >^!.
  5. Щелкните по окну исходного изображения. Перетащите активный слой (слои) из исходного изображения в окно целевого изображения (рис. 7.49). Новый слой (слои) будет расположен там, где вы отпустите кнопку мыши, поверх ранее активного слоя (рис. 7.50).
  6. По желанию: Воспользуйтесь инструментом Move (Перемещение), чтобы изменить расположение нового слоя в окне целевого изображения.
  7. По желанию: Измените расположение нового слоя или слоев относительно остальных слоев в стеке (перетащите их вверх/вниз на палитре Layers (Слои)).

Для того чтобы скопировать слой в центр целевого изображения, начните перетаскивать слой, затем нажмите и удерживайте клавишу Shift и продолжайте перетаскивание.

Изменение размера изображения при копировании

При копировании или перетаскивании изображений между документами они воспроизводятся в соответствии с разрешением целевого изображения. Если разрешение целевого изображения выше разрешения исходного, то картинка при вставке или перетаскивании будет выглядеть меньшей. И наоборот, если разрешение целевого изображения меньше разрешения исходного, картинка будет выглядеть большей. Если некоторые точки вставленного слоя выходят за пределы холста целевого изображения, можно воспользоваться инструментом Move (Перемещение), чтобы переместить их в область просмотра. Спрятанные пикселы будут сохранены вместе с изображением.

Рис. 7.49. Перетаскивание слоя с цветком из окна исходного изображения в окно целевого изображения

Рис. 7.50. Новый слой на целевом изображении

Копирование и вставка видимой области слоя в другое изображение

Воспользуйтесь буфером обмена (командами Сору (Копировать) и Paste (Вставить)), если хотите скопировать только видимые точки слоя (при масштабе просмотра в 100%) и не хотите копировать какие-либо точки, расположенные за границей слоя.

  1. На палитре Layers (Слои) активизируйте слой, который хотите скопировать.
  2. Выберите команду Select > All (Выделить > Все) или нажмите комбинацию клавиш Ctrl+A. В выделенную область не будут включены точки, расположенные за границей холста.
  3. Выберите команду Edit > Сору (Правка > Копировать) или нажмите комбинацию клавиш Ctrl+C.
  4. Щелкните по окну целевого изображения.
  5. Выберите команду Edit > Paste (Правка > Вставить) или нажмите комбинацию клавиш Ctrl+V. Вставленные пикселы появятся на новом слое. Изменить положение слоя относительно остальных слоев можно с помощью палитры Layers (Слои).
  6. Снова щелкните по исходному окну изображения и выберите команду Select > Deselect (Выделить > Снять выделение) или нажмите комбинацию клавиш Ctrl+D, чтобы выделенная область стала неактивной.

Слияние и объединение слоев

Печальная истина состоит с том, что большинство форматов, кроме форматов Photoshop (.psd), Photoshop PDF (.pdf) и Advanced TIFF (.tif) не поддерживают много-слойность изображений. Для экспорта файла в другое приложение также необходимо объединить слои. Мы считаем, что в данной ситуации наилучший способ - сохранить копию файла с объединенными слоями с помощью диалогового окна File > Save As (Файл > Сохранить как), в котором установлен флажок As a Copy (Как копию), при этом многослойное изображение останется открытым. Таким образом, многослойная версия изображения будет сохранена навечно, так что позднее у вас будет возможность замучить ее до смерти.

Если вы настолько самоуверенны, что считаете изображение полностью готовым, можно объединить его слои с помощью команды Flatten Image (Плоское изображение), о которой рассказано в разделе «Объединение слоев». Эта операция хороша тем, что при необходимости позволяет освободить дисковое пространство, ведь изображения с объединенными слоями гораздо меньше по размеру, нежели многослойные.

В то время как команда Flatten Image (Плоское изображение) выполняется тогда, когда работа с файлом завершена, то команды Merge Down (Слить с нижним) и Merge Visible (Слить видимые) обычно используются в процессе редактирования изображения. Воспользовавшись любой to этих команд, можно слить вместе два или более слоев, оставив другие слои нетронутыми.

Рис. 7.51. Активизация слоя SHELL

Рис. 7.52. Результат выполнения команды Merge Down

Рис. 7.53. Выделение слоя SHELL и фона, слои FLOWER и RECTANGLE спрятаны

Рис. 7.54. Результат выполнения команды Merge Visible

Слияние двух слоев

  1. Активизируйте верхний слой из двух, которые вы хотите слить. У него не может быть маски слоя. Если выбрать набор слоев, все слои, входящие в него, будут слиты в один.
  2. Из меню палитры Layers (Слои) выберите команду Merge Down (Слить с нижним) или нажмите комбинацию клавиш Ctrl+E. Активный слой будет слит со слоем, расположенным непосредственно под ним (рис. 7.51, 7.52). Для слияния набора слоев выберите команду Merge Layer Set (Слить набор.слоев).

Слияние нескольких слоев

Команда Merge Visible (Слить видимые) соединяет все видимые в данный момент слои в один видимый, который занимает место самого нижнего видимого слоя, при этом спрятанные слои не меняются.

  1. Убедитесь, что видимы только те слои, которые вы хотите слить (у всех них должен иметься значок в виде глаза на палитре Layers (Слои)), и спрячьте какие-либо слои, которые вы не хотите затрагивать. Не обязательно, чтобы они были расположены последовательно. Скройте фон, если не хотите, чтобы результат операции стал фоном изображения.
  2. Активизируйте любой из слоев, которые предполагается слить. Осторожно! Если в операции участвует редактируемый текстовый или корректирующий слой, после слияния его будет нельзя редактировать.
  3. Из меню палитры Layers (Слои) выберите команду Merge Visible (Слить видимые) или нажмите комбинацию клавиш Ctrl+Shift+E - см. рис. 7.53 и 7.54.

Объединение слоев

Команда Flatten Image (Плоское изображение) объединяет видимые в данный момент слои, располагает результат на месте самого нижнего видимого слоя и удаляет спрятанные слои.

  1. Убедитесь, что все слои, которые вы хотите объединить, видны (у них имеется значок в виде глаза) - см. рис. 7.55. Неважно, какой слой в данный момент является активным.
  2. Из меню палитры Layers (Слои) выберите команду Flatten Image (Плоское изображение). Если в файле содержатся какие-либо спрятанные слои, появится предупреждение; чтобы завершить операцию, щелкните по кнопке ОК (рис. 7.56). Если в самом нижнем слое были какие-либо прозрачные точки, они станут белыми.

Другие команды слияния

Чтобы слить копии всех видимых в данный момент слоев или наборов слоев в самый нижний видимый слой (это может быть новый, специально созданный слой), при нажатой кнопке Alt из меню Layer (Слой) или меню палитры Layers (Слои) выберите команду Merge Visible (Слить видимые).

Для слияния связанных слоев из меню палитры Layers или меню Layer выберите команду Merge Linked (Слить связанные). Эта команда удаляет спрятанные связанные слои. Прежде чем ее выполнить, необходимо связать слои в наборе слоев (нельзя использовать просто набор).

Для слияния слоев в группе отсечения активизируйте слой, имя которого подчеркнуто, а затем из меню Layer или меню палитры Layers выберите команду Merge Group (Слить группу). Эта команда удаляет спрятанные слои или спрятанные слои, входящие в группу.

Рис. 7.55. Видимые слои, подготовленные к объединению

Рис. 7.56. Результат выполнения команды Flatten Image (слой SHELL удален)


  • Глава 8. События
    • Использование палитры History
      • Линейный и нелинейный режим
      • Очистка палитры
      • Операции над элементами списка состояний
    • Использование снимков
      • Создание снимка состояния
      • Перевод изображения в состояние, соответствующее снимку
      • Удаление снимка
      • Создание нового документа из элемента состояния или снимка
    • Восстановление и стирание фрагментов изображения
      • Использование инструмента History Brush
      • Заливка выделенной области или слоя с использованием элемента состояния
      • Использование инструмента Art History Brush
      • Восстановление изображения до определенного состояния

Глава №8.

События

В этой главе рассказано, как использовать палитру History (История), чтобы выборочно отменить до 99 операций по редактированию, каждой из которых соответствует определенное состояние изображения. Также вы узнаете, как восстанавливать выбранные области изображений с помощью инструмента History Brush (Восстанавливающая кисть) или Art History Brush (Художественная восстанавливающая кисть.), заполняя выделенную область изображением, соответствующим какому-либо состоянию, либо стирая с изображения результат последующих операций редактирования.

Палитра History (История) содержит список последних операций, выполненных над изображением, причем самый нижний элемент списка представляет собой самую последнюю операцию. Если щелкнуть по какому-либо предыдущему элементу списка, изображение будет восстановлено до указанного момента редактирования. Что непосредственно происходит с изображением, зависит от того, в каком режиме находится палитра - линейном или нелинейном, поэтому очень важно понимать, чем отличаются эти режимы.

Использование палитры History

Линейный и нелинейный режим

Существует два способа использования палитры History (История): линейный и нелинейный режим. Выбрать режим можно, сняв/установив флажок Allow Non-Linear History (Разрешить нелинейность событий) в диалоговом окне History Options (Опции палитры History) - см. рис. 8.1. Чтобы вызвать это окно, в меню палитры выберите пункт History Options.

В линейном режиме, если щелкнуть по элементу, который соответствует предыдущему состоянию, и возобновить с него процесс редактирования изображения либо удалить его, все последующие элементы (ставшие тусклыми) будут удалены (рис. 8.2).

Если палитра History (История) находится в нелинейном режиме и вы щелкнули по одному из элементов списка или удалили его, то последующие элементы не будут удалены и не станут тусклыми. Если возобновить процесс редактирования изображения с какого-либо раннего состояния, новые операции будут размещены в последних элементах списка на палитре, а предыдущие - сохранены. Если удалить один из ранних элементов, а затем щелкнуть по последнему элементу списка, эффект от удаленной операции все равно будет присутствовать на изображении. Таким образом, нелинейный режим - более гибкий из двух возможных.

Когда имеет смысл работать в нелинейном режиме? Когда вам нужна большая гибкость действий. Скажем, вы наносите кистью мазки на слой, пробуете различные режимы смешивания для этого слоя, а затем останавливаетесь на том варианте, который вам больше всего симпатичен. Если хотите уменьшить количество элементов на палитре, можно удалить относящиеся к другим режимам смешивания, независимо от того, расположены ли они раньше или позже момента, в который был выбран вами подходящий режим.

Рис. 8.1. Опции палитры History

Рис. 8.2. Палитра History в линейном режиме

Максимальное количество состояний

Для того чтобы указать число состояний, которое может одновременно отображаться на палитре в процессе редактирования, введите какое-либо число (от 1 до 100) в поле History States (Состояния) в диалоговом окне Edit > Preferences > General (Правка > Установки > Общие). В предыдущих версиях Photoshop это поле находилось в диалоговом окне History Options (Опции палитры History). Если в процессе редактирования достигнуто максимальное количество состояний, то более ранние шаги будут автоматически удалены, чтобы освободить место для новых.

Зачем же тогда нужен линейный режим? Он пригодится в том случае, если нелинейный режим вас смущает и сбивает с толку или если вы хотите, чтобы при возврате к предыдущему состоянию воздействие последующих операций было ликвидировано.

Очистка палитры

Если закрыть изображение или выполнить команду File > Revert (Файл >Вернуть назад), то список всех состояний этого изображения будет удален с палитры. Для того чтобы сохранить события при восстановлении изображения, вместо использования команды Revert (Вернуть назад) переведите палитру в нелинейный режим, щелкните по предыдущему состоянию или по миниатюре первого снимка, расположенной вверху палитры (подробнее о снимках рассказано в разделе «Использование снимков»).

Для того чтобы очистить палитру History (История) для всех открытых в данный момент изображений и освободить память, выберите команду Edit > Purge > Histories (Правка > Очистить > Истории). Если же хотите очистить палитру только для текущего документа, из меню палитры выберите команду Clear History (Очистить историю). Команду Purge (Очистить) отменить нельзя, a Clear History (Очистить историю) -можно.

Максимальное количество запоминаемых состояний зависит от различных факторов: размера изображения, характера операций, производимых над изображением, и текущего объема доступной памяти. Для каждого открытого изображения сохраняется свой собственный список состояний.

Операции над элементами списка состояний

Если палитра находится в линейном режиме (опция Allow Non-Linear History (Разрешить нелинейность событий) выключена), элементы состояний, расположенные ниже того, по которому вы щелкнете, станут тусклыми. Если удалить выбранное состояние или продолжить редактирование с него, все ставшие тусклыми элементы будут удалены. Если вы передумали, немедленно выполните команду Undo (Отменить). Если же палитра находится в нелинейном режиме, можно восстановить документ до последней стадии редактирования, просто щелкнув по самому нижнему элементу.

Возврат к одному из предыдущих состояний

Чтобы вернуться к одному из предыдущих состояний, на палитре History (История) щелкните по соответствующему элементу (рис. 8.3, 8.4).

Можно также из меню палитры выбрать команды Step Forward (Перейти к следующему состоянию) или Step Backward (Перейти к предыдущему состоянию) или нажать «горячие» клавиши команд, указанные в табл. 8.1. Наконец, можно передвинуть ползунок, расположенный слева на палитре, до желаемого состояния.

Таблица 8.1. «Горячие» клавиши для палитры History

Операция | Сочетание клавиш
Перейти к следующему состоянию | Ctrl+Shift+Z
Перейти к предыдущему состоянию | Ctrl+Alt+Z

Рис. 8.3. Переход к предыдущему состоянию в линейном режиме

Рис. 8.4. Переход к предыдущему состоянию в нелинейном режиме

Дублирование состояния

  1. Включите опцию Allow Non-Linear History (Разрешить нелинейность событий).
  2. Нажмите клавишу Alt и щелкните по какому-либо элементу. Его копия будет расположена в самом низу списка состояний, то есть окажется самым последним состоянием.

Если включена опция Allow Non-Linear History (Разрешить нелинейность событий) и вы удаляете элемент списка состояний, то будет удален только он. Если вы удаляете элемент списка, когда опция выключена, все последующие элементы будут удалены вместе с ним. Чтобы восстановить их, можно воспользоваться командой Edit > Undo (Правка >Отменить).

Удаление состояния

Перетащите имя того состояния, которое вы хотите удалить, на кнопку с изображением корзины Delete current state (текущего состояния), расположенную на палитре History (История).

Продолжайте щелкать по этой кнопке, нажав клавишу Alt, чтобы удалить несколько последовательных событий, предшествующих текущему событию.

Использование снимков

Снимок (snapshot) - это что-то вроде копии состояния, но в отличие от состояния снимок останется на палитре, даже если элемент, на основе которого он был создан, будет удален (из-за того, что было достигнуто максимальное количество состояний в палитре или палитра была очищена). Поэтому лучше создать снимок прежде, чем выполнить серию шагов по редактированию или применить последовательность действий к изображению. Осторожно! При закрытии изображения все снимки удаляются.

Создание снимка состояния

Для того чтобы снимок автоматически создавался при начале каждого сеанса работы с изображением, в диалоговом окне History Options (Опции палитры History) установите флажок Automatically Create First Snapshot (Автоматически создавать первый снимок). Если вы хотите, чтобы снимок автоматически создавался каждый раз при сохранении файла, поставьте флажок Automatically Create New Snapshot When Saving (Автоматически создавать новый снимок при сохранении).

  1. Щелкните по элементу, на основе которого вы хотите создать снимок (рис. 8.5).
  2. Щелкните по кнопке Create new snapshot (Создать новый снимок) - см. рис. 8.5. Если в окне опций палитры History установлен флажок Show New Snapshot Dialog by Default (По умолчанию отображать диалоговое окно для нового снимка), появится диалоговое окно New Snapshot (Новый снимок); затем переходите к выполнению следующих шагов.

    Чтобы задать опции для создания снимка, минуя изменение опций History, из меню палитры выберите пункт New Snapshot (Новый снимок) либо нажмите клавишу Alt и щелкните по кнопке Create new snapshot (Создать новый снимок). Можно также щелкнуть правой кнопкой мыши по элементу состояния и из контекстного меню выбрать команду Create new snapshot (Создать новый снимок).

  3. Введите имя снимка (рис. 8.6).

Рис. 8.5. Создание снимка

Рис. 8.6. Ввод имени снимка и выбор опций слоя

Рис. 8.7. Палитра History после создания нового снимка

  4. Выберите в поле From (Из) вариант Full Document (Весь документ), чтобы сделать снимок всех слоев изображения в указанный момент; или Merged Layers (Слитые слои), чтобы создать снимок, в котором все слои изображения были бы слиты; или Current Layer (Текущий слой), чтобы создать снимок только активного в заданный момент времени слоя.
  5. Щелкните по кнопке ОК. Новая миниатюра снимка появится вверху палитры (рис. 8.7).

Перевод изображения в состояние, соответствующее снимку

Первый способ: щелкните по миниатюре снимка. Если выключена опция Allow Non-Linear History (Разрешить нелинейность событий) и после создания снимка изображение было изменено, документ вернется в состояние, которое было при создании снимка, и все последующие элементы списка состояний станут тусклыми. Если затем возобновить редактирование, все тусклые элементы будут удалены. Если же опция Allow Non-Linear History включена, то последующие состояния останутся на палитре.

Второй способ: независимо от выбранного режима работы палитры History (История) нажмите клавишу Alt и щелкните по миниатюре снимка. Остальные элементы останутся доступными, а состояние; соответствующее снимку, станет самым последним элементом списка.

Удаление снимка

Щелкните по миниатюре снимка, из меню палитры выберите команду Delete (Удалить) или щелкните по кнопке с изображением корзины, затем нажмите кнопку Yes. Можно также просто перетащить миниатюру снимка на кнопку Trash (Корзина).

Создание нового документа из элемента состояния или снимка

Преобразовав снимок или состояние в новый документ, вы застрахуете себя на случай «зависания» программы — будет что-то, к чему можно вернуться в случае сбоев системы.

За один раз можно скопировать только одно состояние.

Чтобы создать новый документ, перетащите снимок или элемент состояния на кнопку Create new document from current state (Создать новый документ из текущего состояния), как показано на рис. 8.8, или щелкните по какому-либо снимку или состоянию, а затем по кнопке Create new document from current state (Создать новый документ из текущего состояния).

Можно также щелкнуть правой кнопкой мыши по-снимку или состоянию и из контекстного меню выбрать пункт New document (Новый документ).

В результате появится окно нового изображения с таким же заголовком, как у элемента состояния, на основе которого было создано изображение, а первый элемент списка состояний нового изображения будет называться Duplicate State (Дублировать событие) - см. рис. 8.9. Сохраните новое изображение!

Рис. 8.8. Перетаскивание снимка или элемента состояния на кнопку Create new document from current state

Рис. 8.9. Дубликат снимка в новом документе

Важное примечание

Для того чтобы заменить содержимое одного изображения некоторым состоянием другого, перетащите соответствующий элемент из палитры History исходного изображения в окно целевого изображения.

Рис. 8.10. Панель опций инструмента History Brush

Восстановление и стирание фрагментов изображения

На палитре History (История) можно выбрать любой снимок или состояние и использовать его в качестве источника для инструмента History Brush (Восстанавливающая кисть). Перетаскивая курсор данного инструмента, вы восстановите пикселы изображения до выбранного состояния. Аналогичный результат можно получить с помощью опции From Saved (Из сохраненного) инструмента Rubber Stamp (Штамп).

Использование инструмента History Brush

Нельзя использовать инструмент History Brush (Восстанавливающая кисть) для изображения, общее число пикселов которого было изменено после его открытия (например, после проведения повторной выборки, обрезки, изменения режима изображения или размера холста).

  1. Активизируйте инструмент History Brush (Восстанавливающая кисть), нажав клавишу Y или Shift+Y.
  2. На панели опций инструмента выберите значение параметров Mode (Режим смешивания) и Opacity (Непрозрачность) - см. рис. 8.10. Щелкните по стрелке в поле Brush (Кисть) и выберите форму кисти из выпадающей панели.
  3. На палитре History (История) щелкните по пустому квадратику, расположенному слева от элемента состояния или снимка, который вы хотите использовать в качестве источника для инструмента History Brush (Восстанавливающая кисть); после щелчка в квадратике появится значок инструмента.
  4. Выберите слой, на котором вы хотите восстановить пикселы.
  5. Нанесите штрихи на изображение. Информация о пикселах предыдущего состояния заменит информацию о пикселах в тех местах, где вы нанесете штрихи (рис. 8.11, 8.12).

Вот пример того, как можно использовать инструмент History Brush (Восстанавливающая кисть) для восстановления более раннего состояния изображения. Вы нанесли несколько мазков кистью на слой, но позже решили, что некоторые из них было бы неплохо отменить. Если щелкнуть по какому-либо элементу состояния, то все последующие операции редактирования будут удалены. Вместо этого щелкните по квадратику состояния, которое предшествовало нанесению мазков кистью, чтобы задать источник для инструмента History Brush (Восстанавливающая кисть). Затем на палитре Layers (Слои) щелкните по слою, на который были нанесены мазки, активизируйте инструмент History Brush, нажав клавишу Y, и нанесите штрихи там, где это необходимо.

Для того чтобы перенести пикселы из более позднего состояния в более раннее, щелкните по элементу более раннего состояния и выберите более позднее состояние в качестве источника для инструмента History Brush (Восстанавливающая кисть).

Рис. 8.11. Исходное изображение

Рис. 8.12. Изображение, восстановленное после применения фильтра Graphic Pen (Тушь)

Снимок в качестве источника для инструмента History Brush

Измените слой (например, примените команду корректировки, фильтр или нарисуйте что-нибудь на слое), сделайте снимок текущего состояния, затем удалите это состояние или выполните команду Undo (Отменить). Поставьте значок инструмента History Brush (Восстанавливающая кисть) рядом со снимком, затем с помощью этого инструмента нанесите мазки кистью там, где хотите восстановить изображение.

Рис. 8.13. Выбор параметров команды Fill

Рис. 8.14. Исходное изображение

Рис. 8.15. Результат заливкм изображения дерева, к которому был применен фильтр Glass Стекло), пикселами предыдущего состояния

Заливка выделенной области или слоя с использованием элемента состояния

Команда Fill (Залить) в режиме Use: History (Использовать: История) не может быть применена к изображению, общее число пикселов которого было изменено со времени его открытия (например, была проведена повторная выборка, обрезка, изменение режима изображения или размера холста). К тому же слои с векторными данными (текстом и фигурами) не могут быть восстановлены с помощью инструмента History Brush (Восстанавливающая кисть), как, впрочем, нельзя восстановить и контур отсечения на измененном слое изображения.

  1. Выберите слой, содержащий пикселы.
  2. По желанию. Создайте выделенную область.
  3. На палитре History (История) щелкните в самой левой колонке радом с элементом того состояния, которое вы хотите использовать в качестве заливки (там появится значок инструмента History Brush (Восстанавливающая кисть)).
  4. Выберите команду Edit > Fill (Правка >Залить).
  5. Затем в выпадающем списке поля Use (Использовать) выберите вариант History (История) - см. рис. 8.13.
  6. Задайте значения параметров Mode (Режим смешивания) и Opacity (Непрозрачность).
  7. Щелкните по кнопке ОК (рис. 8.14,8.15).

Использование инструмента Art History Brush

Инструмент Art History Brush (Художественная восстанавливающая кисть) позволяет наносить на изображение пикселы предыдущего состояния или снимка с применением различных форм кистей (на самом деле, по нашему скромному мнению, все виды кистей - Tight Long (Плотная длинная), Loose Curl (Произвольные завитки) и т.д. - выглядят словно множество червей) - см. рис. 8.16, 8.17. При использовании кисти смешиваются цвета соседних точек, причем на результат влияет текущее значение параметра Tolerance (Допуск).

  1. Выполните несколько операций редактирования изображения, чтобы на палитре History (История) появился список состояний. Затем можно залить окно изображения белым цветом.
  2. На палитре History (История) щелкните в самой левой колонке рядом с тем состоянием или снимком, с которого вы хотите брать информацию о пикселах при нанесении штрихов. Появится значок инструмента History Brush (Восстанавливающая кисть).
  3. Активизируйте инструмент Art History Brush (Художественная восстанавливающая кисть), нажав Клавишу Y или Shift+Y .
  4. На панели опций щелкните по стрелке поля Brush (Кисть) и выберите вид кисти на выпадающей панели.

    Задайте значения параметров Mode (Режим смешивания) и Opacity (Непрозрачность). Выберите значение параметра Style (Стиль рисования) из выпадающего меню и значение параметра Tolerance (Допуск) в пределах от 0 до 100%, чтобы указать, насколько сильно цвет рисования может отличаться от цвета исходного состояния или снимка. Чем меньше величина данного параметра, тем больше цвет рисования может отклониться от исходного цвета.

Рис. 8.16. Полутоновое изображение после применения фильтра Find Edges (Найти края)

Рис. 8.17. Результат применения инструмента Art History Brush в режиме Darken (Затемнить) с использованием кисти Loose Long (Произвольная длинная) и параметром Tolerance равным 100%

Выберите значение параметра Area (Область) в диапазоне от 0 до 500 пикселов, чтобы определить размер области, которую могут покрыть штрихи кисти. Чем шире область, тем большее количество завитушек и линий будет нанесено на изображение.

  5. Выберите слой, нанесите штрихи в окне изображения. Чем дольше держать нажатой кнопку мыши над одной и той же точкой, тем больше цветов будет смешано.

Рис. 8.18. Результат применения к снимку фильтра Rough Pastels (Пастель)

Рис. 8.19. Восстановление лица, области живота и пальцев ног ангела с помощью инструмента Eraser в режиме Erase to History

В перерывах между мазками можно изменять форму штриха или корректировать другие параметры на панели инструмента Art History Brush (Художественная восстанавливающая кисть), можно даже выбрать другое исходное состояние на палитре History (История). Благодаря этому изображение будет выглядеть более естественно. Другой способ сделать изображение уникальным и неповторимым - создать кисть особого вида (об этом говорится в главе 12, разделы «Изменение существующей кисти», «Создание новой кисти» и «Создание кисти на основе изображения»).

Восстановление изображения до определенного состояния

С помощью инструмента Eraser (Ластик) в режиме Erase to History (Восстановить до состояния) можно восстановить пикселы, соответствующие текущему активному состоянию на палитре History (История) -см. рис. 8.18 и 8.19. Преимущество использования инструмента Eraser (Ластик) заключается в том, что в дополнение к параметру Opacity (Непрозрачность) можно выбрать тип инструмента: Brush (Кисть), Pencil (Карандаш) или Block (Блок).

Опцию Erase to History (Восстановить до состояния) нельзя применить к изображению, общее число пикселов которого было изменено после его открытия (например, была проведена повторная выборка, обрезка, был изменен режим изображения или размер холста).

  1. Активизируйте инструмент Eraser (Ластик), нажав клавишу Е или Shift+Е.
  2. Выделите слой изображения, не являющийся слоем фигуры.
  3. На панели опций инструмента щелкните по стрелке в поле Brush (Кисть) и выберите вид кисти на выпадающей панели.

    Выберите в поле Mode (Режим) тип инструмента: Brush (Кисть), Pencil (Карандаш) или Block (Блок), а также значения параметров Opacity (Непрозрачность).

    Установите флажок Erase to History (Восстановить до состояния).

  4. Установите состояние-источник для инструмента, щелкнув в самой левой колонке палитры History (История) рядом с элементом какого-либо состояния или снимка.
  5. На палитре Layers (Слои) выберите какой-либо слой.
  6. Перетаскивая курсор в окне изображения, нанесите штрихи на нужную область.


  • Глава 9. Команды корректировки
    • Основные сведения о командах корректировки
    • Корректирующие слои
      • Создание корректирующего слоя
      • Изменение корректирующего слоя
      • Выбор опций смешивания для корректирующего слоя
      • Выбор другой команды для существующего корректирующего слоя
      • Слияние корректирующего слоя с нижележащим
      • Способы использования корректирующих слоев
    • Команды корректировки
      • Команда Auto Contrast
      • Выравнивание яркости слоя
      • Инвертирование светлой и темной окраски
      • Увеличение контрастности изображения
      • Создание плаката
      • Корректировка яркости и контраста
      • Корректировка яркости и контраста с помощью окна Levels
      • «Экранирование» слоя
      • Инструменты Dodge и Burn
      • Ограничение действия корректирующего слоя с помощью маски
      • Превращение слоя в полутоновой с помощью команды Channel Mixer
      • Команда Auto Color

Глава №9.

Команды корректировки

Рис. 9.1. Подменю Image > Adjustments

О том, как корректировать цвет при помощи команд Hue/Saturation (Тон/Насыщенность), Desaturate (Уменьшение насыщенности), Replace Color (Замена цвета) и других команд из подменю Image > Adjustments (Изображение > Корректировки), показанного на рис. 9.1, рассказано в главе 11.

В этой главе рассмотрено множество методов настройки светлых и темных тонов в изображении. Можно выполнить элементарные настройки, например инвертировать слой так, что он будет выглядеть, словно негатив, или придать ему вид плаката, ограничив количество уровней яркости заданным числом. Можно провести более точную корректировку светлых, средних или темных тонов слоя и их контраста с использованием таких средств, как Levels (Уровни) или Curves (Кривые). Можно затемнить небольшие области вручную, воспользовавшись инструментом Burn (Затемнение) или осветлить их с помощью инструмента Dodge (Осветление).

Основные сведения о командах корректировки

Далее представлены рекомендации по применению команд корректировки:

  • для удобства редактирования используйте корректирующие слои (инструкции вы найдете ниже, в разделе «Корректирующие слои»);
  • чтобы применить команду корректировки к выделенной области слоя, а не ко всему слою, создайте выделение прежде, чем выбирать команду;
  • для восстановления значений параметров в диалоговом окне нажмите клавишу Alt и щелкните по кнопке Reset (Восстановить);
  • пользуйтесь опцией Preview (Предварительный просмотр) в диалоговых окнах команд подменю Adjustments (Корректировки), чтобы видеть, как будет выглядеть изображение после применения команды. При включении этой опции более точно отображаются цвета в режиме CMYK;
  • для того чтобы постепенно уменьшить эффект применения команды, воспользуйтесь командой Edit > Fade (Правка > Ослабить) или нажмите комбинацию
  • клавиш Ctrl+Shift+F - теперь эта функция доступна не только для фильтров;
  • для того чтобы снова открыть диалоговое окно с последними установленными, а не со стандартными значениями параметров, нажмите клавишу Alt при выборе команды либо добавьте к «горячим» клавишам Alt.

Корректирующие слои

Есть два способа применения команд корректировки. Они могут быть применены непосредственно к текущему слою (или к выделенной области текущего слоя) либо применяться к изображению посредством корректирующего слоя. Мы предпочитаем последний метод, так как он предоставляет большую гибкость.
В отличие от обычных корректирующий слой влияет на все видимые слои, расположенные под ним, а не только на текущий. Но особая прелесть применения корректирующего слоя заключается в том, что в действительности он не изменяет пикселы до тех пор, пока не будет слит со слоем, расположенным под ним (при помощи комбинации клавиш Ctrl+E), так что можно экспериментировать с различными эффектами. Корректирующие слои - удобный способ предварительной оценки результата корректировки цвета. На этой и последующих страницах будет рассказано, как создать и использовать корректирующий слой. Если хотите, можно пропустить эту часть и сначала прочитать об отдельных командах корректировки (раздел «Команды корректировки», а затем вернуться сюда.

Создание корректирующего слоя

  1. Выберите слой, поверх которого хотите расположить корректирующий.
  2. Из всплывающего меню, которое вызывается щелчком по кнопке Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои), выберите команду корректировки (рис. 9.2,9.3).

Рис. 9.2. Всплывающее меню на палитре Layers

Рис. 9.3. Корректирующий слой на палитре Layers

Можно также выбрать команду из подменю Layer > New Adjustment Layer (Слой > Новый корректирующий слой) и щелкнуть по кнопке ОК. Миниатюра корректирующего слоя содержит пиктограмму одной из команд корректировки и ползунок, напоминающий о том, что данная команда допускает редактирование и изменение.

  3. Проведите какие-либо операции корректировки и щелкните по кнопке ОК.

Изменение корректирующего слоя

  1. На палитре Layers (Слои) дважды щелкните по миниатюре корректирующего слоя (она расположена слева) или (более медленный вариант) щелкните по имени корректирующего слоя, затем выберите команду Layer > Layer Content Options (Слой > Опции содержимого слоя).
  2. Произведите нужные изменения в диалоговом окне и затем щелкните по кнопке ОК.

Для того чтобы скопировать корректирующий слой из одного изображения в другое, перетащите его с палитры Layers (Слои) исходного изображения в окно целевого изображения.

Выбор опций смешивания для корректирующего слоя

С помощью диалогового окна Layer Style (Стиль слоя) можно управлять тем, как корректирующий слой смешивается со слоями, расположенными под ним.

  1. На палитре Layers (Слои) дважды щелкните по имени корректирующего слоя (или какого-либо обычного слоя).
  2. Убедитесь, что в левой части окна Layer Style (Стиль слоя) выбран пункт Blending Options (Опции смешивания).
  3. Измените значения параметров Blend Mode (Режим смешивания) и/или Opacity (Непрозрачность), расположенных в разделе General Blending (Общие параметры смешивания) - см. рис. 9.4.
  4. Измените любые опции в разделе Advanced Blending (Дополнительные опции смешивания).

    Снимите флажки Channels (Каналы) с тех каналов, которые вы хотите исключить при смешивании с нижележащими слоями. Чтобы установить диапазон смешивания для каждого канала, выберите из всплывающего меню Blend If (Смешивать если) какой-либо канал; для работы со всеми каналами одновременно оставьте значение Gray (Серый) в качестве выбранного пункта всплывающего меню. Текущий режим изображения (например, RGB или CMYK) определяет, какие каналы доступны.

    Передвиньте вправо левый ползунок поля This Layer (Этот слой), чтобы удалить темные области с активного слоя. Переместите влево правый ползунок того же поля, чтобы удалить светлые пятна с активного слоя.

    Передвиньте вправо левый ползунок поля Underlying Layer (Нижележащий слой), чтобы стали видны темные области слоя, расположенного непосредственно под активным слоем. Переместите влево правый ползунок этого поля, чтобы стали видны светлые пятна слоя, расположенного непосредственно под активным.

  5. Щелкните по кнопке ОК.

Рис. 9.4. Выбор опций смешивания для корректирующего слоя диалоговом окне Layer Style

Рис. 9.5. Выбор корректирующего слоя

Рис. 9.6. Результат применения значений Brightness/Contrast (Яркость/Контраст) к фону после слияния с ним корректирующего слоя.

Корректирующий слой не может быть слит с каким-либо другим корректирующим слоем, поскольку в таких слоях нет пикселов, то есть сливать просто нечего. Однако можно соединить несколько корректирующих слоев со слоем (слоями) изображения при помощи команды Merge Visible (Слить видимые) или Flatten Image (Плоское изображение). Как это сделать, рассказано в главе 7, раздел «Слияние и объединение слоев».

Выбор другой команды для существующего корректирующего слоя

Можно оставить корректирующий слой там, где он находится, и изменить команду корректировки, которая содержится в нем (например, Levels, Curves или Brightness/Contrast).

  1. На палитре Layers (Слои) выберите какой-либо корректирующий слой.
  2. Из подменю Layer > Change Layer Content (Слой > Изменить содержимое слоя) выберите команду, которая должна заменить существующую.

Для того чтобы удалить корректирующий слой, перетащите его на кнопку Trash (Корзина).

Слияние корректирующего слоя с нижележащим

При слиянии корректирующего слоя с нижележащим изменения станут постоянными, так что убедитесь, что действительно хотите «увековечить» изменения прежде, чем продолжить корректировку. Если вы передумали, выполните команду Edit > Undo (Правка > Отменить) или щелкните по предшествующему состоянию на палитре History (История).

  1. Выберите корректирующий слой, который вы хотите слить с нижележащим (рис. 9.5).
  2. Из меню палитры Layers (Слои) выберите команду Merge Down (Слить с нижним) или нажмите комбинацию клавиш Ctrl+E (рис. 9.6).

Способы использования корректирующих слоев

Измените режим смешивания корректирующего слоя (палитра Layers (Слои)), чтобы создать разнообразные визуальные эффекты с участием нижележащих слоев (рис. 9.7). Например, попробуйте установить режим Overlay (Наложение), чтобы увеличить контраст; Multiply (Умножение), чтобы затемнить изображение, или Screen (Экран), чтобы осветлить его. Можно создать стек из нескольких корректирующих слоев, затем скрыть некоторые слои или уменьшить их непрозрачность, чтобы увидеть, как изменяется нижележащее изображение (см. рис. 9.7). Если вы хотите сравнить действие различных значений параметров одной и той же команды, создайте несколько одинаковых корректирующих слоев, например Levels (Уровни) или Color Balance (Баланс цвета), скройте их все, а затем показывайте попеременно по одному. Можно изменить порядок взаимного расположения корректирующих слоев либо изменить их положение относительно остальных слоев.

Для того чтобы корректирующий слой не влиял на нижележащий, переместите его поверх корректирующего.

При необходимости ограничить область действия корректирующего слоя выделите требуемую область прежде, чем создавать подобный слой. Выделенная область будет иметь белый цвет на миниатюре маски слоя (рис. 9.7, 9.8). Раскрасьте (залейте) черным цветом корректирующий слой, чтобы удалить эффект от его применения, либо белым цветом, чтобы этот эффект стал виден. Подробнее о масках корректирующего слоя рассказано в разделе «Ограничение действия корректирующего слоя с помощью маски».

Рис. 9.7. Скрытие/показ корректирующих слоев

Рис. 9.8. Применение корректирующего слоя к выделенной области

Рис. 9.9. Результат ограничения области влияния корректирующего слоя с помощью команды Brightness/Contrast

Рис. 9.10. Исходное изображение

Рис. 9.11. Результат применения команды Auto Contrast

Обычно корректирующий слой влияет на все видимые слои, расположенные ниже, но можно использовать отсекающую группу, чтобы ограничить эффект корректировки слоем или слоями, с которым (которыми) он сгруппирован (см. главу 14, раздел «Создание маски слоя»). При вызове команды Layer > New Adjustment Layer (Слой > Новый корректирующий слой) в диалоговом окне New Layer (Новый слой) можно поставить флажок Group With Previous Layer (Сгруппировать с предыдущим слоем).

О том, как использовать команду Gradient Map (Градиентная карта), говорится в главе 13, раздел «Применение градиентной карты к слою».

Команды корректировки

Далее будет рассказано, как использовать некоторые команды из подменю Image > Adjustments (Изображение > Корректировки). Они могут быть применены к слою непосредственно или с помощью корректирующего слоя. Сначала испробуйте команды на полутоновом изображении, чтобы узнать, как они работают, и только после этого применяйте их к цветному изображению.

Команда Auto Contrast

Простая команда Auto Contrast (Автоконтраст) преобразует самые светлые пикселы в белые, а самые темные - в черные, и распределяет между ними уровни серого.

Чтобы получить такой результат, вызовите команду из меню Image > Adjustments > Auto Contrast (Изображение > Корректировки > Автоконтраст) или нажмите комбинацию клавиш Ctrl+Alt+Shift+L - см. рис. 9.10,9.11.

Выравнивание яркости слоя

Команда Equalize (Выровнять) перераспределяет уровни яркости активного слоя. Она может улучшить изображение, которому не хватает контрастности или которое оказалось слишком темным.

Выберите команду Image > Adjustments > Equalize (Изображение > Корректировки > Выровнять). Чтобы ограничить область действия команды, выделите некоторую область слоя прежде, чем выбирать команду, затем в диалоговом окне Equalize (Выровнять) установите флажок Equalize selected area only (Выровнять яркость только выделенной области). Для корректировки целого слоя с учетом самого светлого и самого темного цвета выделенной области установите флажок Equalize entire image based on selected area (Выровнять все изображение на основе выделенной области) -см. рис. 9.12-9.14.

Инвертирование светлой и темной окраски

Выберите команду Invert (Инвертировать), чтобы слой или фон стали выглядеть словно негатив. С помощью этой команды можно также превратить негатив в позитив, но с точки зрения фотографов это не самый удачный способ. Значения яркости и/или цвета каждого пиксела будут замещены противоположными.

Выберите слой, после этого выполните команду Image > Adjustments > Invert (Изображение > Корректировки > Инвертировать) или же нажмите комбинацию клавиш Ctrl+I - см. рис. 9.15, 9.16.

Чтобы выполнить инвертирование нижележащих слоев при помощи корректирующего слоя, из всплывающего меню, которое вызывается щелчком по кнопке

Рис. 9.12. Диалоговое окно Equalize

Рис. 9.13. Исходное изображение

Рис. 9.14. Результат применения команды Equalize

Рис. 9.15. Исходное изображение

Рис. 9.16 Инвертированное изображение

Рис. 9.17. Исходное изображение

Рис. 9.18. Выбор порогового значения

Рис. 9.19. Результат применения команды Threshold

Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои), выберите команду Invert (Инвертировать).

Увеличение контрастности изображения

С помощью диалогового окна Threshold (Порог) можно увеличить контраст текущего слоя или фона, преобразовав цветные или серые пикселы в черные и белые.

  1. Выберите какой-либо слой или фон (см. рис. 9.17), а затем воспользуйтесь командой Image > Adjustments > Threshold (Изображение > Корректировки > Порог).

    Чтобы задействовать корректирующий слой, из всплывающего меню, которое вызывается при помощи кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои), выберите команду Threshold (Порог).

  2. Передвиньте ползунок вправо, чтобы увеличить число черных пикселов (см. рис. 9.18), или влево, чтобы увеличить число белых.

    Можно также в поле Threshold Level (Уровень порога) ввести какое-либо значение (от 1 до 255). Пикселы светлее выбранного значения станут белыми, а остальные - черными.

  3. Щелкните по кнопке ОК (рис. 9.19).

Создание плаката

Воспользуйтесь командой Posterize (Превратить в плакат), чтобы уменьшить количество цветов или уровней значений в текущем слое или фоне до определенного числа. Мы обожаем эту простую команду.

  1. Выберите слой (рис. 9.20), затем используйте команду Image > Adjustments > Posterize (Изображение > Корректировки > Превратить в плакат).

    Чтобы задействовать корректирующий слой, выберите пункт Posterize (Превратить в плакат) из всплывающего меню, которое вызывается при помощи кнопки Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).

  2. Убедитесь, что стоит флажок Preview (Предварительный просмотр), и введите в поле Levels (Уровни) число от 2 до 255 (рис. 9.21). Чтобы создать эффект трафаретной печати или плакатного стиля, введите величину в пределах между 4 и 8.
  3. Щелкните по кнопке ОК (рис. 9.22).

Если число темных оттенков в изображении было, уменьшено после применения команды Posterize (Превратить в плакат) или же цвета были изменены другим способом, без использования корректирующего слоя, а затем изображение было сохранено и закрыто, исходные данные об уровне цвета будут безвозвратно утеряны.

Создайте слой с градиентной окраской, используя два или более цветов, затем поверх него расположите корректирующий слой Posterize (Превратить в плакат) - на изображении появятся заметные цветные полоски.

Рис. 9.20. Исходное изображение

Рис. 9.21. Ввод желаемого числа цветов

Рис. 9.22. Результат выполнения команды Posterize

Рис. 9.23. Исходное изображение

Рис. 9.24. Выбор уровня яркости и контраста

Рис. 9.25. Результат сдвига вправо ползунка Brightness

Рис. 9.26. Результат совместной настройки яркости и контраста

Корректировка яркости и контраста

Если для корректировки цвета воспользоваться командой Levels (Уровни), вы сможете по отдельности и более точно настроить светлые, средние и темные тона, но проще использовать команду Brightness/Contrast (Яркость/Контраст), о которой рассказывается ниже.

  1. Выберите слой (рис., 9.23), затем воспользуйтесь командой Image a Adjustments a Brightness/Contrast (Изображение а Корректировки а Яркость/Контраст).

    Чтобы задействовать корректирующий слой, из всплывающего меню, которое вызывается щелчком по кнопке Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои), выберите пункт Brightness/Contrast (Яркость/Контраст).

  2. Для того чобы немного осветлить слой, передвиньте ползунок яркости вправо (рис. 9.24), если же надо затемнить слой, передвиньте этот ползунок влево. Можно также в поле Brightness (Яркость) указать какое-либо значение от -100 до 100.
  3. Для увеличения контраста передвиньте ползунок Contrast (Контраст) вправо, для его уменьшения - влево. Можно также ввести в поле Contrast (Контраст) какую-либо величину от -100 до 100.
  4. Щелкните по кнопке ОК (рис. 9.25,9.26).

Корректировка яркости и контраста с помощью окна Levels

С помощью диалогового окна Levels (Уровни) проведите тонкую настройку светлых, средних или темных тонов. Изо дня в день это диалоговое окно используется для корректировки большинства изображений.

  1. Выберите слой (рис. 9.27), затем воспользуйтесь командой Image > Adjustments > Levels (Изображение > Корректировки > Уровни) или нажмите комбинацию клавиш Ctrl+L.

    Чтобы задействовать корректирующий слой, выберите пункт Levels (Уровни) из всплывающего меню, которое вызывается щелчком по кнопке Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).

  2. Выполните любой из перечисленных ниже шагов (рис. 9.28).
  • для увеличения яркости светлых тонов и контраста передвиньте белый ползунок Input Levels (Входные уровни) влево. Ползунок средних тонов также переместится. Подкор-ректируйте при необходимости его положение;
  • чтобы сделать темные тона еще темнее, передвиньте черный ползунок Input Levels (Входные уровни) вправо. Ползунок средних тонов также переместится, при необходимости подкорректируйте его положение;
  • для независимой настройки средних тонов передвигайте средний ползунок Input Levels (Входные уровни);
  • чтобы уменьшить контраст и осветлить изображение, передвиньте черный ползунок Output Levels (Выходные уровни)вправо;
  • для уменьшения контраста и затемнения изображения передвиньте белый ползунок Output Levels (Выход ные уровни) влево.

Рис. 9.27. Исходное изображение

Рис. 9.28. Диалоговое окно Levels

Рис. 9.29. Результат корректировки уровней

Рис. 9.30. Результат применения команды Levels к выделенной области изображения

Рис. 9.31. Исходное изображение

Вместо перемещения ползунков можно ввести нужные значения в поля Input Levels (Входные уровни) и Output Levels (Выходные уровни). Для сохранения текущих установок щелкните по кнопке Save (Сохранить). Воспользуйтесь кнопкой Load (Загрузить), чтобы снова применить сохраненные установки к другим изображениям.

  3. Щелкните по кнопке ОК (рис. 9.29-9.30).

Для автоматической настройки уровней выберите команду Image > Adjustments > Auto Levels (Изображение > Корректировки > Автоуровни), либо нажмите комбинацию клавиш Ctrl+Shitt+L, либо в диалоговом окне Levels (Уровни) щелкните по кнопке Auto (Авто).

Чтобы увеличить контраст изображения, передвиньте черный и белый ползунки Input Levels (Входные уровни) как можно ближе друг к другу.

«Экранирование» слоя

В этом разделе описан другой способ использования команды Levels (Уровни).

  1. Выберите какой-либо слой или фон (рис. 9.31,9.35), воспользуйтесь командой Image > Adjustments > Levels (Изображение > Корректировки > Уррвни) или нажмите комбинацию клавиш Ctrl+L.

    Чтобы задействовать корректирующий слой, выберите пункт Levels (Уровни) из всплывающего меню, которое вызывается щелчком по кнопке Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).

  2. Для уменьшения контраста передвиньте белый ползунок Input Levels (Входные уровни) немного влево (рис. 9.32), а черный ползунок Output Levels (Выходные уровни) - немного вправо.
  3. Для осветления средних тонов передвиньте средний ползунок Input Levels (Входные уровни) влево.
  4. Щелкните по кнопке ОК (рис. 9.33,9.36).

Для того чтобы слой выглядел, как негатив, поменяйте местами расположение двух ползунков Output (рис. 9.34). Чем дальше друг от друга вы передвинете ползунки, тем сильнее будут изменены величины яркости и контраста (они примут обратные значения). Попробуйте при-. менить команду Invert (Инвертировать) для получения похожего эффекта.

Инструменты Dodge и Burn

Для осветления пикселов в небольших областях вручную воспользуйтесь инструментом Dodge (Осветление); для затемнения - инструментом Burn (Затемнение). Для каждого инструмента можно задать вид кисти и другие опции.

  1. Выберите слой.

Инструменты Dodge (Осветление) и Burn (Затемнение) нельзя применить к изображению, имеющему режим Bitmap или Indexed Color.

  2. Выберите инструмент Dodge (Осветление) или Burn (Затемнение); выбрать их можно с помощью «горячих» клавиш О или Shift+O.
  3. На панели опций (рис. 9.37) щелкните по стрелке в поле Brush (Кисть), затем на выпадающей панели выберите тип кисти с резкими или мягкими границами.

Рис. 9.32. Диалоговое окно Levels

Рис. 9.33. Результат «экранирования»

Рис. 9.34. Результат изменения положения ползунков Output на противоположное

Рис. 9.35. Исходное изображение

Рис. 9.36. «Экранированное» изображение

Рис. 9.37. Выбор опций инструментов Dodge и Burn

Для создания гладкой, светлой или темной линии осветлите или затемните контур, выбрав команду Stroke Path (Обводка контура) и инструмент Dodge (Осветление) или Burn (Затемнение). Подробнее об этом рассказано в главе 16, раздел «Обводка контура».

Рис. 9.38. Темные точки на фоне изображения

Использование широкой мягкой кисти даст более гладкие переходы цвета.

Из всплывающего меню Range (Диапазон) выберите Shadows (Темные тона), Midtones (Средние тона) или Highlights (Светлые тона), чтобы осветлять или затемнять только пикселы, входящие в указанный диапазон.

Выберите значение параметра Exposure (Воздействие) в пределах от 1% (низкая интенсивность) до 100% (высокая интенсивность). Для начала выберите небольшое значение (20-30%), чтобы инструмент не слишком быстро осветлял или затемнял области.

  4. Нанесите штрихи на любую область слоя. Делайте паузу между штрихами, чтобы программа успевала отображать изменения на экране (рис. 9.38, 9.39). Для осветления или затемнения точек, расположенных на прямой линии, щелкните по изображению, переместите курсор, затем, нажав клавишу Shift, щелкните по изображению еще раз.

Если вы слишком осветлили или затемнили область, воспользуйтесь командой Edit a Undo (Правка а Отменить) или палитрой History (История) для удаления соответствующих операций. Не пытайтесь исправить дефект при помощи инструмента с противоположными возможностями -изображение будет все в пятнах.

Рис. 9.39. Результат применения инструмента Dodge с опцией Shadows

Ограничение действия корректирующего слоя с помощью маски

Существует два способа ограничить воздействие корректирующего слоя определенной областью изображения. Первый -создать выделенную область перед созданием корректирующего слоя. Второй - создать выделенную область или рисовать черным цветом на корректирующем слое после его создания (инструкции изложены ниже). Подробнее о масках слоя рассказано в главе 14, раздел «Маски слоя».

  1. Выберите корректирующий слой. Установите черный цвет в качестве основного. Палитра Color (Цвет) автоматически станет полутоновой.
  2. Чтобы маскировать эффект корректирующего слоя, создайте выделенную область (например, с помощью инструментов Rectangular Marquee (Прямоугольная область), Lasso (Лассо ) или Magic Wand (Волшебная палочка)), выберите команду Edit О Fill (Правка "Ф Залить) или нажмите комбинацию клавиш Shift+Delete, в поле Use (Использовать) укажите Foreground color (Основной цвет), затем щелкните по кнопке ОК.

    Второй способ: активизируйте инструмент Brush (Кисть) нажатием на клавишу В, укажите значение Normal (Нормальный) для параметра Mode (Режим) и значение параметра Opacity (Непрозрачность) равное 100% на панели опций, затем раскрасьте изображение (рис. 9.40). Для частичного маскирования эффекта корректирующего слоя выберите меньшее значение непрозрачности.

  3. Чтобы восстановить эффект корректирующего слоя, раскрасьте ц ли залейте соответствующую область белым цветом.

    Если должна быть задействована лишь небольшая область корректирующего слоя, залейте весь слой черным цветом, а затем раскрасьте определенные фрагменты белым.

    Для того чтобы эффект корректировки был виден на всем изображении, залейте весь корректирующий слой белым цветом.

Если вы хотите ослабить эффект корректирующего слоя для всего изображения на какой-либо процент, уменьшите непрозрачность слоя, передвинув ползунок Opacity (Непрозрачность) на палитре Layers (Слои) - см. рис. 9.41.

Пo умолчанию в корректирующем слое содержится растровая маска слоя. Как создать отсекающий контур (векторную маску) для корректирующего слоя, рассказано в главе 16, раздел «Создание контура отсечения слоя».

При работе с маской слоя используйте следующие «горячие» клавиши (подробная информация о «горячих» клавишах приведена в приложении):

  • нажмите клавишу Alt и щелкните по миниатюре маски корректирующего слоя, чтобы увидеть маску в окне изображения;
  • нажав клавиши Alt+Shift, щелкните по миниатюре маски корректирующего слоя, чтобы увидеть маску в виде ру-билитового покрытия;

Рис. 9.40. Результат маскирования левой части корректирующего слоя Threshold при помощи окраски этой части черным цветом

Рис. 9.41. Результат уменьшения непрозрачности корректирующего слоя Threshold до 60%

Рис. 9.42. Диалоговое окно Channel Mixer

  • нажмите клавишу Shift и щелкните по миниатюре маски корректирующего слоя, чтобы временно отключить эту маску;
  • нажмите клавишу Ctrl и щелкните по миниатюре маски корректирующего слоя, чтобы преобразовать незамаскированную область в выделенную.

Превращение слоя в полутоновой с помощью команды Channel Mixer

  1. Выберите какой-либо слой или фон, затем выполните команду Image > Adjustments > Channel Mixer (Изображение > Корректировки > Смеситель каналов).

    Чтобы задействовать корректирующий слой, выберите пункт Channel Mixer (Смеситель каналов) из всплывающего меню, которое вызывается щелчком по кнопке Create new fill or adjustment layer (Создать новый слой заливки или корректирующий слой), расположенной внизу палитры Layers (Слои).

  2. Поставьте флажок Monochrome (Монохромный) - см. рис. 9.42. Слой или изображение станет полутоновым, в выпадающем меню Output Channel (Выходной канал) будет единственная доступная опция - Gray (Серый).
  3. Передвиньте любой из ползунков группы Source Channels (Исходные каналы), чтобы изменить уровень вклада данного канала в степень яркости полутонового изображения. Перетащите ползунок влево, чтобы уменьшить влияние этого цвета, или вправо, чтобы увеличить.
  4. Передвиньте ползунок Constant (Константа) влево, если надо добавить больше черного, или вправо - для добавления белого.
  5. Щелкните по кнопке ОК. Изображение пока находится в исходном цветовом режиме. Если хотите, можно преобразовать его в режим Grayscale (Полутоновый).

Если применить команду Channel Mixer (Смеситель каналов) к слою, для него можно выбрать другое значение непрозрачности или другой режим смешивания.

Для того чтобы добавить цвет в слой, в диалоговом окне Channel Mixer (Смеситель каналов) сначала поставьте флажок Monochrome (Монохромный), а затем снимите его, чтобы восстановить цвет выходных каналов. Выберите значение в поле Output Channel (Выходной канал) и передвиньте куда-либо ползунки группы Source Channels (Исходные каналы), чтобы воспроизвести другой оттенок. Повторите операцию для любого другого выходного канала (каналов).

Попробуйте один из стандартных эффектов

Прежде чем использовать один из стандартных эффектов команды Channel Mixer (Смеситель каналов), например RGB Rotate Channels (Ротация RGB-каналов) или CMYK Swap Cyan&Magenta (Перестановка голубого и фуксинового каналов), убедитесь, что папка Channel Mixer Presets скопирована с компакт-диска в папку Adobe Photoshop 7.0/Presets. Для загрузки эффекта в диалоговом окне Channel Mixer (Смеситель каналов) щелкните по кнопке Load (Загрузить), в каталоге приложения откройте папку Presets/Channel Mixer Presets, там откройте любой из четырех подкаталогов и дважды щелкните по имени файла эффекта смешивания. В Windows имеются следующие имена: Channel Swap, Grayscale, Special Effects и YCC Color.

Команда Auto Color

Эта простая команда служит для устранения желтой или голубой засветки изображений, которая появляется, если фотосъемка проводилась при искусственном освещении. И в том, и в другом случае достаточно изменить яркость и контрастность синей синего канала RGB изображения.

Чтобы устранить паразитный оттенок, необходимо выполнить команду Image > Adjustments > Auto Color (Изображение > Корректировки > Автоцвет) или нажать комбинацию клавиш Shift+Ctrl+B.


  • Предисловие

    • Предисловие

    Adobe Photoshop 7 просто обречен на то, чтобы стать суперхитом сезона среди программных продуктов. Тем более, что он, как и все версии этого пакета с нечетными порядковыми номерами, содержит заметные новшества. Например, в Photoshop 3 появилась поддержка слоев, в пятой версии - многоуровневая отмена неудачных действий и очень полезный инструмент Magnetic Lasso, в базовую поставку Photoshop 5.5 была включена программа ImageReady для работы с Web-графикой. Параллельно шло обновление и других продуктов Adobe, предназначенных для полиграфии и дизайна: векторного редактора Illustrator, программы верстки InDesign, визуального HTML-редактор GoLive, векторно-анимационного пакета LiveMotion, средства для создания мультимедийных презентаций AfterEffects.

    Не стала исключением и седьмая версия Photoshop. Разработчики устранили целый ряд недостатков этой программы, которые существенно осложняли жизнь пользователям Windows и Mac OS X. В частности, Photoshop 7 наконец «научился» использовать системную виртуальную память, в результате чего «аппетиты» в расходе системных ресурсов, прежде всего, физического ОЗУ, намного уменьшились по сравнению с предыдущей версией. Особенно это заметно при обработке больших изображений высокого разрешения. Также существенно снижен риск «зависания» системы, вызванного разрастанием собственного файла подкачки Photoshop до неконтролируемых объемов. Теперь Photoshop намного лучше работает при запуске одновременно с ним других приложений, в том числе и при использовании настроек по умолчанию (раньше на экспериментальный подбор нужных параметров уходило немало времени).

    Если бы Adobe ограничилась только исправлением вышеперечисленных недостатков, этого все равно было бы достаточно для оправдания выпуска новой версии. Однако программисты Adobe не ограничились исправлением проблем функционирования Photoshop в многозадачных операционных системах. Заметно расширены многие известные возможности пакета и добавлены новые.

    В состав Photoshop и ImageReady включен модуль быстрого просмотра и управления группами изображений. Раньше для этого необходимо было устанавливать утилиты сторонних разработчиков, например ACDSee или ThumbsPlus.

    Включены фильтры импорта и экспорта изображений в формате WBMP, который используется в карманных компьютерах (PDA). При этом автоматически производится оптимизация изображений с учетом жестких ограничений данного формата, причем с минимумом потерь в качестве картинки.

    Photoshop часто критиковали за то, что с помощью его штатных инструментов можно было печатать лишь одну копию изображения на одном листе. Теперь же появился инструмент, который позволяет размещать на одной странице несколько изображений или копий одной картинки. Кроме того, данному средству легко найти и другие применения, в частности, использовать его для создания Web-галерей с возможностью предварительного просмотра изображений в виде миниатюр.

    В Photoshop 7 впервые включены средства, ориентированные на групповую работу. В поставку «коробочной» версии входят серверные расширения AfterCast, позволяющие обеспечить совместный доступ к файлам разным пользователям всевозможных продуктов Adobe. Если кто-либо из пользователей внесет какие-либо изменения в файл, это увидят все, кто с ним работает. Однако настройка AfterCast - дело системного администратора, поэтому те, кто использует Photoshop только дома, с этими инструментами, скорее всего, не столкнутся.

    По-настоящему революционные изменения претерпели средства рисования. Теперь кисть (аэрограф) имеет 12 параметров настройки, что втрое больше, чем было в предшествующих версиях. Это позволяет более достоверно имитировать традиционные живописные инструменты. В качестве шаблона допускается использовать любые растровые изображения. Значительно улучшены также средства создания текстур на основе фрагментов изображений.

    В новой версии программы появилось новое средство ретуширования Healing Brush. Его можно применять в качестве улучшенного варианта инструмента Clone Stamp или как средство быстрого устранения различных артефактов на том или ином участке изображения. При этом полностью сохраняются игра светотеней и рисунок текстуры оригинала. Разработчики рекомендуют использовать Healing Brush для удаления следов пыли, мелких царапин, а также для скрытия морщин, родинок, веснушек на портретных фотографиях.

    В поставку Photoshop 7 включен инструмент AutoColor, с помощью которого можно избавиться от посторонней засветки. Использование этого инструмента существенно облегчит исправление фотографий, отснятых при искусственном освещении, как полученных с помощью цифровой камеры, так и оцифрованных обычных. Неплохие результаты дает AutoColor и при удалении маски с отсканированных негативов. В состав Photoshop впервые включены средства проверки правописания.

    Существенно обновилась программа Ima-geReady, предназначенная для работы с Web-графикой. Номер ее версии теперь совпадает с Photoshop. В ImageReady изменено управление ролловерами и анимациями, что сделало этот процесс более простым и наглядным по сравнению с прежними версиями. Усовершенствованы средства оптимизации графики, предназначенной для размещения в Internet. Раньше работа данных модулей часто была объектом критики и вынуждала Web-мастеров использовать программные продукты других фирм. Но теперь поводов для недовольства стало существенно меньше. Photoshop и ImageReady дают «на выходе» файлы, объем которых не отличается от того, который будет получен при обработке в конкурирующих программных продуктах.

    Этим новшества, включенные в Photoshop 7, конечно же, не ограничиваются. Выше приведены лишь наиболее значимые. О них и других усовершенствованиях подробнее написано в соответствующих главах данной книги.

    Принятые обозначения

    Полужирным шрифтом в тексте оформляются элементы интерфейса: названия окон, пунктов меню, команд, а также клавиш.

    Курсивом помечены базовые термины и определения.

    Алгоритм выполнения тех или иных операций обычно оформляется как нумерованный список, например:

    1. Нажмите клавишу Z.
    2. Снимите флажок Resize Windows to Fit (Изменять размер окон для подгонки).

    Web-адреса выделены подчеркиванием.

    В книге также используется несколько особых значков для привлечения внимания к определенным отрывкам текста.

    Примечание. Этот значок предваряет дополнительную информацию, относящуюся к излагаемому материалу.

    Совет. Так помечены советы, которые помогут вам в практической работе.

    Внимание. Данный знак обращает ваше внимание на важные сведения, касающиеся функционирования программы Photoshop.