Иллюстрированный самоучитель по Sound Forge

    • Предисловие
    • Глава 1. Основы MIDI и цифрового звука
    • Глава 2. Начинаем работу с Sound Forge
    • Глава 3. Настройка программы Sound Forge
    • Глава 4. Работа со звуковыми файлами
    • Глава 5. Работа в Sound Forge
    • Глава 6. Запись и воспроизведение
    • Глава 7. Основы редактирования
    • Глава 8. Функции обработки
    • Глава 9. Эффекты в программе Sound Forge
    • Глава 10. Дополнительные инструменты для работы со звуком
    • Глава 11. Подготовка файлов для мультимедиа и Интернета
    • Глава 12. Используем Sound Forge с MIDI
    • Глава 13. Sound Forge и сэмнлирование
    • Приложение . Использование Sound Forge совместно с программой ACID


Глава 1. Основы MIDI и цифрового звука
  • Основы MIDI и цифрового звука
  • Что такое MIDI?
  • Что такое цифровой звук?
  • Так в чем же разница?


Основы MIDI и цифрового звука

Если вы человек того же типа, что и автор, вы предпочтете немедленно начать изучение Sound Forge. Однако, если вам непонятны основные концепции и термины, связанные с компьютерной музыкой, вам будет трудно разобраться в этой книге. Поэтому для того, чтобы дать вам краткий обзор самых важных аспектов технологии компьютерной музыки, в этой главе сделано следующее:

  • дано определение языка MIDI и объяснены принципы его работы;
  • дано определение цифрового звука и объяснены принципы его работы;
  • объяснено различие интерфейса MIDI и цифрового звука.

Что такое MIDI?

MIDI (Musical Instrument Digital Interface — цифровой интерфейс музыкальных инструментов) представляет собой специальный компьютерный язык, позволяющий электронным музыкальным инструментам (например, клавишным синтезаторам) "переговариваться" с компьютерами. Он работает приблизительно так: предположим, вы используете в качестве музыкального инструмента клавишный синтезатор. Каждая клавиша на синтезаторе имеет соответствующий электронный переключатель. Когда вы нажимаете клавишу, соответствующий ей переключатель активизируется и посылает сигнал компьютерной микросхеме внутри вашей клавиатуры. Далее микросхема посылает этот сигнал имеющемуся в вашей клавиатуре интерфейсу MIDI, который преобразует сигнал в сообщения MIDI и, в свою очередь, посылает эти сигналы интерфейсу MIDI на вашем компьютере.

Замечание

Интерфейс MIDI представляет собой устройство внутри вашего компьютера, позволяющее понимать ему язык MIDI. По существу, вы можете рассматривать его как некоего переводчика. Когда электронный музыкальный инструмент посылает сообщения MIDI компьютеру, интерфейс MIDI получает эти сообщения и преобразует их в понятные компьютеру сигналы.

Сообщения MIDI содержат информацию, сообщающую компьютеру, что была нажата клавиша (сообщение Note On); какая это была клавиша (имя ноты, представленное в виде числа) и как резко вы нажали клавишу (MIDI velocity). Например, если вы нажали на клавиатуре синтезатора клавишу Си первой октавы, компьютеру посылается сообщение Note On, означающее, что вы нажали какую-то клавишу. Затем посылается сообщение, содержащее число 60, которое говорит компьютеру о том, что была нажата клавиша Си первой октавы. Последнее посылаемое сообщение содержит число в диапазоне от 1 до 127 (1 означает очень легкое нажатие, а 127 — очень резкое), сообщающее компьютеру, как резко вы нажали клавишу.

Рис. 1.1. Здесь показано, как сообщения MIDI записываются и проигрываются с помощью компьютера

Различные сообщения MIDI представляют все органы управления на клавиатуре. Кроме каждой клавиши, сообщения MIDI представляют колесо модуляции, колесо изменения тона и т. п. Ваш компьютер может запоминать сообщения MIDI, посланные ему в процессе вашей игры на клавиатуре. Можно запоминать и временные параметры исполнения (интервалы между нажатиями клавиш и длительность нажатия каждой клавиши). Потом компьютер может послать эти сообщения MIDI обратно клавиатуре с теми же временными параметрами, после чего у вас возникнет впечатление, что вы играете музыку, не касаясь клавиш. Основной алгоритм таков: вы играете музыкальный фрагмент на клавиатуре. Ваше исполнение сохраняется в памяти компьютера как набор инструкций. Далее компьютер посылает эти инструкции обратно клавиатуре, и вы слышите музыкальный фрагмент точно так, как исполнили его, включая все ошибки и нюансы (рис. 1.1).


Что такое цифровой звук

Цифровой звук (digital audio) является представлением звука в виде чисел. Запись звука как цифрового звука подобна записи звука на магнитофон. Предположим, к вашему компьютеру подключен микрофон. Когда раздается какой-либо звук (речь, пение, игра на музыкальных инструментах или просто какой-либо шум), микрофон "слышит" его и преобразует звук в электрический сигнал. Затем микрофон посылает сигнал звуковой карте на компьютере, которая преобразует сигнал в числа. Эти числа называются сэмплами (samples).

Замечание

Звуковая карта (sound card) представляет собой устройство, вставляемое в компьютер, которое позволяет компьютеру понимать электрические сигналы от любых звуковых устройств. Вы можете рассматривать звуковую карту как "переводчика". Когда звуковое устройство (например, микрофон, электронный музыкальный инструмент, проигрыватель компакт-дисков или другое устройство, способное выводить аудиосигнал) посылает сигналы на компьютер, звуковая карта принимает эти сигналы и преобразует их в числа, которые может понимать компьютер.

Сэмплы содержат информацию, сообщающую компьютеру, как записанный сигнал звучал в определенные моменты времени. Чем больше сэмплов использовано для представления сигнала, тем выше качество записанного сигнала. Например, чтобы создать звукозапись в цифровом виде, имеющую такое же качество, как запись на компакт-диске, компьютер должен получать 44 100 сэмплов в секунду. Число сэмплов, полученных в секунду, называется частотой сэмплирования (sampling rate).

Размер каждого отдельного сэмпла также влияет на качество записываемого звука. Этот размер называется разрядностью (bit depth). Чем больше разрядность, тем выше качество звука. Например, для создания цифровой звукозаписи с таким качеством, как запись на компакт-диске, каждый сэмпл должен иметь размер 16 битов.

Замечание

Для представления чисел в компьютерах используется двоичная форма. Разряд двоичного числа называется битом, каждый бит представляет собой одно из двух чисел: 1 или 0. С помощью комбинирования битов компьютеры могут отображать любые числа. Например, любое число от 0 до 255 представляется в виде восьмибитного числа. С помощью 16 битов можно представить числа в диапазоне от 0 до 65 535.

Ваш компьютер может сохранять все посланные ему сэмплы. Временные характеристики сэмпла также сохраняются. В последующем компьютер может посылать сэмплы обратно звуковой карте с такими же интервалами, так что вы услышите звук в точности таким же, как он был записан. Основная концепция выглядит так: звуковая карта записывает электрический сигнал от аудиоустройства (например, микрофона или проигрывателя компакт-дисков). Звуковая карта преобразует сигналы в наборы чисел, именуемые сэмплами, которые хранятся в компьютере. При воспроизведении сэмплы посылаются обратно звуковой карте, которая преобразует их в электрический сигнал. Сигнал посылается на звуковые колонки (или другое аудиоустройство), и вы слышите звук точно таким же, как вы его записали (рис. 1.2).

Рис. 1.2. На этом рисунке показано, как звук преобразуется в числовую форму, чтобы его можно было записывать и воспроизводить на компьютере

Так в чем же разница?

После прочтения описания MIDI и цифрового звука вы можете по-прежнему не понимать, в чем же заключается разница между ними. Ведь оба процесса записывают сигналы, посланные компьютеру, а потом воспроизводят их, не правда ли? А дело в том, что когда вы записываете данные MIDI, вы не записываете реальный звук. Вы записываете только инструкции для воспроизведения. Это похоже на то, как музыкант играет по нотам, где нотам соответствуют данные MIDI, а музыканту — компьютер. Музыкант (или компьютер) читает ноты (или данные MIDI), а затем сохраняет их в памяти. Затем музыкант играет мелодию на музыкальном инструменте. Что, если музыкант возьмет другой инструмент для исполнения? Игра останется той же, а звук изменится. То же самое происходит и с данными MIDI.

Клавишный синтезатор может издавать любые звуки, но воспроизведение тех же данных MIDI с помощью клавиатуры будет точно таким же.

Когда вы записываете цифровой звук, вы записываете реальный звук. Если вы записываете исполнение музыкального произведения как цифровой звук, вы не можете изменить звук в этом исполнении, как описывалось выше. Благодаря этим различиям MIDI и цифровой звук имеют свои достоинства и недостатки. Поскольку MIDI записывается в виде данных для воспроизведения, а не как реальный звук, у вас значительно больше свободы для манипулирования звуком, чем при работе с цифровым звуком. Например, вы с легкостью можете исправить ошибку, изменив высоту звука. Данные MIDI могут быть преобразованы в стандартную нотную запись, что невозможно сделать с цифровым звуком. С другой стороны, MIDI невозможно использовать для записи того, что требует реального звука, например звуковых эффектов или вокала. С помощью цифрового звука вы можете записывать любые звуки. И вы можете быть уверены, что воспроизведение всегда будет точно таким же, как и в момент записи. В случае MIDI у вас такой уверенности нет, поскольку, хотя данные MIDI остаются неизменными, устройство, используемое для воспроизведения, может быть изменено.

Мы надеемся, что это описание разъяснило вам разницу между MIDI и цифровым звуком. Вам потребуется знать еще несколько родственных терминов, но мы их поясним в разных местах книги в ходе рассказа. Пока что, после того, как вы поняли различие между MIDI и цифровым звуком, мы можем начать разговор о том, ради чего вы купили эту книгу — как использовать программу Sound Forge.


Глава 10. Дополнительные инструменты для работы со звуком
  • Дополнительные инструменты для работы со звуком
  • Если нужно исправить запись
    • Восстановление стереофонического звука
    • Восстановление с заменой
    • Восстановление с интерполяцией
  • Спектральный анализ
    • Применение спектрального анализа
    • Определение ноты
    • Ручной поиск проблем в записи
  • Синтез
    • Функция DTMF/MF
    • Функция Simple Synthesis
    • Пример простого синтеза
    • Функция FM Synthesis


Дополнительные инструменты для работы со звуком

Программа Sound Forge содержит так много инструментов и функций, что составить какую-либо их классификацию очень трудно, потому что четко разделить их какие-либо категории весьма сложно. Некоторые используются для редактирования, другие — для обработки, третьи — для добавления эффектов. Существует еще несколько инструментов, не подпадающих ни под одну из этих категорий. Они дают вам возможность восстанавливать, анализировать и синтезировать аудиоданные. Вот вопросы, которые мы рассмотрим в этой главе:

  • восстановление аудиоданных с помощью функций Repair;
  • исследование аудиоданных с помощью спектрального анализа;
  • создание новых звуков с помощью простого синтеза;
  • создание новых звуков с помощью FM-синтеза.

Если нужно исправить запись

В главе 7 мы говорили об инструменте Pencil и о том, как его использовать при работе с вашими аудиоданными. Программа Sound Forge 5.0 содержит несколько новых функций, еще больше упрощающих разрешение проблем, возникающих при работе с аудиоданными (например, удаление хлопков, щелчков).

Восстановление стереофонического звука

Если вы когда-нибудь столкнетесь с ситуацией, когда один из каналов вашего стереофонического аудиофайла поврежден, а другой в порядке, вы можете использовать для быстрого и легкого решения проблемы функцию Repair/Copy Other Channel. Вот как это делается:

1. Если место, где происходит сбой, вам неизвестно, используйте функцию Find, описанную в главе 5. В противном случае используйте прокрутку и масштабирование в окне данных, чтобы увидеть проблему в графике звукового сигнала.

2. Если сбой мал (не больше 10 миллисекунд длиной), поместите указатель текущей позиции в точку, находящуюся приблизительно посередине проблемного участка. Если вы использовали функцию Find, это должно было произойти автоматически. Убедитесь, что указатель текущей позиции находится именно в том канале, где имеется проблема, при необходимости добейтесь этого с помощью клавиши <ТаЬ> (рис. 10.1).

Рис. 10.1. С помощью клавиши <Таb> добейтесь, чтобы был обработан только тот канал, где имеется проблема

3. Если длина части со сбоем больше, создайте выделение, охватывающее проблемные данные. Убедитесь, что выделение находится только в том канале, где имеется проблема, при необходимости добейтесь этого с помощью клавиши <ТаЬ> (рис. 10.2).

4. Выполните команду меню Tools -> Repair -> Copy Other Channel. Если вы поместили указатель текущей позиции в центр проблемного участка, программа Sound Forge скопирует 10 миллисекунд данных (5 миллисекунд до и 5 миллисекунд после указателя текущей позиции) из нормального канала в сбойный. Если вы сделали выделение, программа Sound Forge скопирует то же количество данных, которое содержится в выделении (до 0,5 секунды) из нормального канала в сбойный канал.

Совет

Функция Repair/Copy Other Channel работает лучше всего тогда, когда данные в обоих каналах похожи. Если данные сильно отличаются, функция может не работать. В этом случае попробуйте другие функции из группы Repair.

Рис. 10.2. Если длина сбойной части большая, создайте выделение

Восстановление с заменой

Если данные в двух каналах вашего стереофонического аудиофайла в той точке, где имеется проблема, сильно отличаются друг от друга, вы можете попробовать заменить их на данные из того же канала с помощью функции Repair Replace. Эта функция также работает в том случае, если ваш файл монофонический. Функция Repair Replace работает почти так же, как и функция восстановления канала, за исключением того, что нормальные данные берутся из звукового фрагмента, находящегося непосредственно перед проблемной областью. Для применения функции Repair Replace необходимо выполнить следующие шаги:

1. Если место, где происходит сбой, вам неизвестно, используйте функцию Find, описанную в главе 5. В противном случае используйте прокрутку и масштабирование в окне данных, чтобы увидеть проблему в графике звукового сигнала.

2. Если сбой мал (не больше 15 миллисекунд длиной), поместите указатель текущей позиции в точку, находящуюся приблизительно посередине проблемного участка. Если вы использовали функцию Find, это должно было произойти автоматически. Если вы работаете со стереофоническим файлом, убедитесь, что указатель текущей позиции находится только в том канале, где имеется проблема, при необходимости добейтесь этого с помощью клавиши <Таb>.

3. Если длина сбойной части больше, создайте выделение, охватывающее проблемные данные. Если вы работаете со стереофоническим файлом, убедитесь, что выделение находится только в том канале, где имеется проблема, при необходимости добейтесь этого с помощью клавиши <Таb>.

4. Выполните команду меню Tools -> Repair -> Replace. Если вы поместили указатель текущей позиции в центр проблемного участка, программа Sound Forge заменит 15 миллисекунд данных, окружающих указатель, 15 миллисекундами данных, непосредственно предшествующих проблемному участку. Если вы сделали выделение, программа Sound Forge скопирует то же количество данных, которое содержится в выделении (до 0,5 секунды) из данных, непосредственно предшествующих проблемному участку.

Совет

Функция Repair Replace работает лучше всего на больших участках со щелчками и проблемами. Однако, если будет сделано слишком много замен, могут появиться странные эффекты эха. В таком случае попробуйте вместо этой функции использовать функцию Repair Interpolate.

Восстановление с интерполяцией

Функция Repair Interpolate является наиболее сложной из функций группы Repair. Однако это не значит, что она работает лучше. Вам придется поэкспериментировать. Функция Repair Interpolate устраняет проблемы, делая сначала логические предположения, на что звуковой сигнал должен быть похож при отсутствии проблемы, а затем заменяет сбойные данные расчетными данными. Вот как эта функция работает:

1. Если место, где происходит сбой, вам неизвестно, используйте функцию Find, описанную в главе 5. В противном случае используйте прокрутку и масштабирование в окне данных, чтобы увидеть проблему в графике звукового сигнала.

2. Функция Repair Interpolate лучше всего работает на маленьких сбоях (до 5 миллисекунд). Для каждой маленькой проблемы поместите указатель текущей позиции в точку, находящуюся приблизительно посередине проблемного участка. Если вы использовали функцию Find, это должно было произойти автоматически. Если длина сбойной части несколько больше, создайте выделение, охватывающее проблемные данные. Если вы работаете со стереофоническим файлом, убедитесь, что выделение находится только в том канале, где имеется проблема, при необходимости добейтесь этого с помощью клавиши <Таb>.

3. Выполните команду меню Tools -> Repair -> Interpolate.

Программа Sound Forge проанализирует аудиоданные и заменит проблемную часть на те данные, которые, по ее расчету, должны здесь быть. В некоторых случаях это может не сработать, а даже наоборот — только породит новую проблему. Тогда попытайтесь использовать какую-либо другую функцию из группы Repair. Поэкспериментируйте со всеми функциями, чтобы выяснить, какая из них лучше всего работает с вашими поврежденными аудиоданными.


Спектральный анализ

В главе 8 мы рассказывали о частотах, аудиоспектре и о том, как можно создавать различные звуки с помощью многочисленных одновременных вибраций на разных частотах. Мы также говорили о том, как вы можете изменять тональные характеристики (или тембр) звука с помощью эквализации. Но для того, чтобы узнать, какие частоты должны быть подняты или обрезаны, чтобы получить желаемые изменения, вы должны выяснить, какие частоты (и их амплитуды) представлены в звуке. Вот здесь нужен спектральный анализ.

Если у вас есть стереофонический компонент, имеющий функцию вывода анимированного графика, изменяющегося в процессе воспроизведения звука, то вы имеете некоторое представление о спектральном анализе. Этот анимированный график показывает амплитуды различных частот в проигрываемой музыке. Он может рассказать вам, что в записи слишком много басов или слишком много высоких частот, и позволит сделать соответствующие регулировки, чтобы музыка звучала лучше. Функция Spectrum Analysis программы Sound Forge также дает вам возможность это сделать, но со значительно большей точностью.

Вы можете использовать функцию Spectrum Analysis для анализа содержания частот в вашем аудиофайле и для определения, какие частоты являются громкими, а какие — тихими. Вы можете также использовать данную функцию для поиска основного тона звука или для отслеживания странных шумов в вашей записи (например, гула или жужжания). После этого вы можете использовать для внесения изменений эквализацию или функции настройки тона. Вот как работает функция Spectrum Analysis:

1. Выделите в вашем аудиофайле данные, которые вы хотите проанализировать. Если вы хотите проанализировать весь файл, не выделяйте никакие данные или выделите все, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Tools -> Spectrum Analysis, чтобы открыть окно Spectrum Analysis - ; (рис. 10.3). В этом окне вы увидите график, показывающий значения звуковых частот по горизонтальной шкале и значения амплитуды по вертикальной шкале. Вы можете посмотреть на график, выбрать частоту и найти амплитуду этой частоты внутри ваших аудиоданных. Если вы анализируете монофонический файл, вы увидите один график. Если вы анализируете стереофонический файл, вы увидите два графика (один — для левого канала и один — для правого).

Рис. 10.3. Используйте функцию Spectrum Analysis для анализа частот содержимого ваших аудиоданных

3. При первом открытии окна график будет смасштабирован на всю длину файла, поэтому выбрать конкретные частоты будет трудно. Чтобы отмасштабировать его до определенной частоты или группы частот, щелкните левой кнопкой мыши посередине графика и нарисуйте прямоугольник вокруг частот, которые вы хотите рассмотреть более подробно (рис. 10.4).

Совет

Как и в любом другом окне, вы также можете изменить размер окна путем перетаскивания его углов. Это позволит вам увеличить график для вывода большего количества значений.

Совет

В то время, когда вы передвигаете мышь внутри графика, рядом с указателем мыши выводится значение амплитуды (в децибелах) и частоты (в герцах). Прижав указатель мыши к верхней точке полосы частот, вы сможете прочесть значение амплитуды для этой частоты. Выполнив команду меню Options -> Show Position, вы можете включить или выключить эту функцию, а выбрав команду Options -> Show Notes, вы увидите рядом с указателем мыши значения нот для частот, которые вы рассматриваете.

4. Когда вы растягиваете график, полосы прокрутки слева и снизу графика становятся активными. Они работают так же, как и любые другие полосы прокрутки в окне и позволяют вам просматривать различные части графика. Вы можете также выбрать команду меню Display -> Grab/Pan для использования мыши в качестве инструмента прокрутки. В этом режиме, когда вы щелкаете мышью внутри графика и протягиваете мышь, график перемещается. Чтобы вернуться в режим масштабирования, просто выберите команду Display -> Grab/Pan снова.

Рис. 10.4. Изменение масштаба графика

5. Чтобы показать весь диапазон частот, выберите команду меню Display -> Zoom Out Full. А для того чтобы показать весь диапазон амплитуд, выберите команду Display -> Normalize dB.

Совет

Вы можете также изменить масштаб графика, выбрав команду меню Display -> Zoom To Range. Чтобы установить диапазон для данной функции, выберите команду Options -> Settings, после чего откроется диалоговое окно Spectrum Settings - ;. В группе Display Range установите минимальное и максимальное значения для диапазона частот (по горизонтали) графика, а затем — минимальное и максимальное значения для диапазона амплитуд (по вертикали) графика с помощью параметров Ceiling (-149 to 0 dB) и Floor (-150 to -1 dB), соответственно.

6. Чтобы частоты на графике отображались в логарифмической шкале, а не в линейной, выберите команду Display -> Logarithmic. По существу, это означает, что в данном режиме на графике будет показан более широкий диапазон низких частот. Поэтому, если вы работаете с аудиоданными с большим количеством низкочастотного содержимого (например, партией бас-гитары), вам, может быть, гораздо удобнее рассматривать график с логарифмической шкалой.

7. Вы можете изменить внешний вид графика и другими способами. Первоначально вы видите режим Bar Graph (столбцовая диаграмма). Это очень удобный режим, поскольку он показывает для выводимых частот отдельные столбцы. Кроме того, существуют еще режимы Line Graph (линейный график) и Filled Graph (заполненный график). Чтобы использовать эти режимы, просто выберите команду меню Display -> Line Graph или Display -> Filled Graph.

8. Поскольку функция Spectrum Analysis использует обычное окно вместо диалогового, вы можете держать его открытым в процессе редактирования аудиоданных. Если вы вернетесь в окно данных и выделите другой фрагмент данных, вы сможете переключиться в уже открытое окно Spectrum Analysis - ; для анализа новых данных. Однако график не обновляется автоматически, поэтому для того, чтобы обновить график, выберите команду Update.

Совет

Если вы хотите, чтобы график обновлялся автоматически каждый раз, когда вы выделяете новый фрагмент данных или редактируете данные, выберите команду меню Options -> Auto Update в окне Spectrum Analysis - ;.

Совет

Вы можете также заставить функцию Spectrum Analysis показывать графики для различных частей ваших аудиоданных одновременно. Выберите команду меню Options -> Settings для открытия диалогового окна Spectrum Settings - ;. Параметр Slices displayed (1 to 64) позволяет выбрать, сколько графиков будет показано на экране (до 64), а затем указать, будут ли они показаны в прямом (Forward) или обратном (Backward) порядке в соответствии с данными в вашем файле. Нажмите на кнопку ОК. В зависимости от количества графиков, которое вы выбрали, функция Spectrum Analysis разобьет ваш аудиофайл на такое же количество частей и покажет для каждой части свой график. Графики будут показаны либо с начала файла, либо с конца, в зависимости от того, какой из переключателей, Forward или Backward, был выбран.

9. Функция Spectrum Analysis может быть также использована в режиме реального времени. Если вы выберете команду меню Options -> Monitor Playback, график будет изменяться по мере воспроизведения. Кроме того, вы можете также использовать эту функцию для анализа звука, поступающего в вашу звуковую карту в режиме реального времени. Это означает, что вы можете подключить микрофон к звуковой карте, говорить в него что-нибудь и наблюдать на графике частотное содержимое звука. Чтобы получить такую возможность, выполните команду меню Options -> Monitor Input.

10. Чтобы установить точность функции Spectrum Analysis, выберите команду меню Options -> Settings для открытия диалогового окна Spectrum Settings - ; (рис. 10.5).

Рис. 10.5. Настройте точность функции Spectrum Analysis в диалоговом окне Spectrum Settings - ;

11. Функция Spectrum Analysis использует воображаемое окно по мере того, как анализирует выделенные вами данные, раздел за разделом. Размер этого окна (в сэмплах) определяется параметром FFT size. Чем больше окно, тем точнее анализ, но тем медленнее обработка. Хорошим значением является 2048, как компромисс между точностью и скоростью обработки.

12. Параметр FFT overlap (0 to 99%) определяет, насколько каждая позиция анализа перекрывает предыдущую позицию. Опять-таки, чем больше перекрытие, тем точнее анализ, но медленнее обработка. Обычно 75% является хорошим значением.

13. В раскрывающемся списке Smoothing windows можно определить, какой алгоритм будет использоваться для анализа ваших данных. Вы можете поэкспериментировать с этим параметром для того, чтобы найти наиболее подходящий вариант для материала, который вы анализируете, но чаще всего вы, вероятно, будете использовать вариант Blackmail-Harris, дающий наибольшую точность.

14. Есть еще несколько наборов настроек графика, которые вы можете выбрать в зависимости от типа анализируемых данных. Попробуйте поэкспериментировать с ними. Закончив процесс настройки, щелкните на кнопке ОК.

15. Кроме режимов Bar Graph, Line Graph и Filled Graph, функция Spectrum Analysis также имеет режим Sonogram. Чтобы активизировать его, выберите команду меню Display -> Sonogram (Color), после чего увидите график, подобный показанному на рис. 10.6. Вместо частоты и амплитуды этот график показывает зависимость частоты (по вертикали) от времени (по горизонтали). Это означает, что на графике вы сможете увидеть в выделенных данных все частоты в конкретный момент времени. Не только это, но и различные цвета представляют амплитуды частот. В нижней части окна вы увидите шкалу, показывающую, какие цвета соответствуют каким амплитудам в децибелах.

Рис. 10.6. Кроме режимов Bar, Line, and Filled Graph, существует режим Sonogram

16. Как и в других режимах, вы можете двигать указатель мыши вдоль графика, при этом будут отображаться амплитуды конкретных частот в виде чисел. Режим Sonogram не позволяет вам масштабировать или перемещать график. А в процессе воспроизведения вы увидите, как указатель текущей позиции прокручивается внутри графика, вместо того, чтобы изменялся сам график.

17. Если вы хотите изменить интенсивность цветов на графике, просто переместите ползунок, расположенный непосредственно под графиком. Перемещение вправо увеличивает интенсивность цветов, а перемещение влево — уменьшает.

18. Вы можете также выбрать черно-белый режим Sonogram с помощью команды меню Display -> Sonogram (В & W).

19. Чтобы настроить точность в режиме Sonogram, выполните команду меню Options -> Settings для открытия диалогового окна Spectrum Settings - ;. После этого настройте параметр Set sonogram resolution (1 to 10,000 samplings). Чем выше его значение, тем более точным будет график в режиме Sonogram, но для его создания потребуется больше времени. Значение по умолчанию 200 обычно работает хорошо. Щелкните по кнопке ОК.

Совет

Если вы хотите вывести график на печать в любом из режимов, просто выполните команду меню Options -> Print.

20. Закончив работу с функцией Spectrum Analysis, закройте окно с помощью команды меню Options -> Close.

Применение спектрального анализа

Конечно, одно знание, как использовать функцию Spectrum Analysis, не дает представления, зачем вам может потребоваться использовать ее. Поэтому мы приведем пару примеров.

О Определение ноты

Предположим, у вас есть запись инструментального произведения и вы хотите знать, какую ноту инструмент играет в конкретной точке вашего аудиофайла. Вот как вы можете выяснить это:

1. Выделите в вашем аудиофайле данные, которые содержат только ноту, высоту которой вы хотите узнать.

2. Выберите команду меню Tools -> Spectrum Analysis.

3. Верните нормальный режим вывода, выбрав команду меню Display -> Normal Display, если это еще не сделано.

4. Теперь посмотрите на правую нижнюю часть окна Spectrum Analysis - ;. Здесь вы увидите текстовое описание различных настроек текущего графика. Кроме того, вы увидите текст "Prominent Frequency". Справа от этого текста показана самая заметная частота в выделенных данных и нота (или высота тона), представленная этой частотой.

Ручной поиск проблем в записи

Мы уже говорили в этой главе о том, как восстанавливать ваши аудиодан-ные с помощью группы функций Repair. А также рассказывали об использовании функции Find для поиска сбойных участков в ваших данных, но иногда даже функция Find не работает и вам приходится искать сбойные участки вручную. В большинстве случаев вы легко можете услышать их, но при этом не всегда можете точно обнаружить точку, в которой наблюдается проблема. В таких случаях функция Spectrum Analysis вам может помочь.

1. Найдите область в ваших данных, внутри которой располагается проблемный участок, и выделите ее.

2. Выберите команду меню Tools -> Spectrum Analysis.

3. Выберите команду меню Display -> Sonogram (Color).

4. Найдите на графике тонкие пики цвета (рис. 10.7). Это проблемные области или щелчки в ваших аудиоданных.

Рис. 10.7. Используйте режим Sonogram для поиска сбойных участков в ваших аудиоданных

5. Посмотрите момент времени, в который происходит сбой, под графиком.

6. Измените масштаб времени в окне данных, чтобы найти проблему на графике звукового сигнала.

7. Как разрешить проблему, смотрите в пошаговых инструкциях, приведенных выше в этой главе.


Синтез

Кроме всех тех функций редактирования, обработки и добавления эффектов, которые мы описывали в предыдущих главах, программа Sound Forge позволяет создавать звуки "с нуля" с помощью тройки функций синтеза. Эти функции дают вам возможность поэкспериментировать с некоторым количеством различных типов синтеза из программы Sound Forge. Никакие другие программные или аппаратные компоненты вам не потребуются. Вы сможете имитировать телефонные сигналы, реализовывать простой аддитивный или субтрактивный синтез и создавать некоторые действительно сложные звуки FM-синтеза.

Замечание

Мы не будем вдаваться в детали аддитивного и субтрактивного синтеза и FM-синтеза или в общие вопросы синтеза звука. Этой теме посвящены многие специальные книги. Однако вы можете найти хорошую вступительную информацию на следующих Web-сайтах: http://tilt.largo.fl.us/faq/synthfaq.html и http://nmc.uoregon.edu/emi/emp_win/rnain.html

Функция DTMF/MF

Функция DTMF/MF позволяет вам генерировать телефонные сигналы. Мы не знаем, зачем это может потребоваться. Но есть песни, в которых телефонные гудки используются в качестве эффектов, так что, может быть, и вам эта функция пригодится. Как бы то ни было, вот как она работает:

1. Создайте новый пустой аудиофайл, выбрав команду меню File -> New и установив соответствующие параметры в диалоговом окне New Window, или откройте существующий аудиофайл. Как это делать, мы обсуждали в главе 4. Если вы откроете существующий аудиофайл, поместите указатель текущей позиции в то место файла, куда вы хотите вставить телефонные сигналы.

2. Выберите команду меню Tools -> Synthesis -> DTMF/MF Tones, чтобы открыть диалоговое окно DTMF/MF Tones (рис. 10.8).

3. Установите параметр Dial string (1234567890ABCD**). Это телефонный номер, который вы хотите имитировать. Так же как и на обычном телефонном аппарате, вы можете вводить числа, буквы и некоторые другие символы.

4. Выберите один из двух переключателей группы Tone style to generate. Аббревиатура DTMF расшифровывается как Dual Tone Multi-Frequency (тональный набор с разделением частот). Это название типа звуковых сигналов, генерируемых стандартными телефонными аппаратами. Аббревиатура MF расшифровывается как Multi-Frequency (многочастотный). Это название типа звуковых сигналов, используемых внутри телефонных компаний для управления функционированием телефонных сетей.

Рис. 10.8. Используйте функцию DTMF/MF для генерации телефонных сигналов

5. Установите параметр Single tone length (0.001 to 2 seconds). Этот параметр определяет длину (в секундах) каждого отдельного генерируемого тона. Чтобы создать тон средней длины, используйте значение в районе 0.200.

6. Установите параметр Break length (0.001 to 2 seconds). Этот параметр определяет продолжительность тишины (в секундах) между каждым отдельным тоном. Чтобы имитировать нормальную скорость тонального набора, используйте значение в районе 0.100.

7. В дополнение к параметру Break length (0.001 to 2 seconds) вы можете также вставлять характерные паузы между тоначьными сигналами набора. Для этого выберите значение параметра Pause character (запятая, используемая в качестве значения по умолчанию, работает хорошо). Добавьте к параметру Dial string запятые там, где вы хотите, чтобы были паузы. Затем установите параметр Pause length (0.001 to 5 seconds) (в секундах), указывающий, насколько долгой будет пауза, когда Pause character встретится в строке Dial string во время генерирования тональных сигналов.

8. Установите флажок Fade the edges of each tone. Это позволит предотвратить появление проблем, так что вам лучше всегда оставлять этот флажок установленным.

9. Если вы вставляете тональные сигналы в существующий аудиофайл и хотите, чтобы они были вставлены в текущей позиции, выберите в раскрывающемся списке Insert new tone sequence at вариант Cursor. Вы можете также выбрать, куда будут вставляться тональные сигналы — в начало или в конец файла. Если вы создаете новый файл, вам не нужно устанавливать этот параметр.

10. Установите параметр Amplitude (-Inf. to 0 dB), указывающий, насколько громкими будут тональные сигналы.

11. Нажмите на кнопку Preview, чтобы услышать, как будут звучать ваши данные, прежде чем программа Sound Forge реально изменит их.

12. Нажмите на кнопку ОК.

Программа Sound Forge сгенерирует сигналы телефонного тонального набора в соответствии с установленными вами параметрами.

Функция Simple Synthesis

Функция Simple Synthesis позволяет вам генерировать самые базовые звуки типа тех, которые вы можете обнаружить в синтезаторе. Вы можете использовать эту функцию для проведения экспериментов с различными типами синтеза и для создания ваших собственных уникальных синтезированных звуков. Как следует из ее названия, функция Simple Synthesis очень проста в использовании. Вот как она работает:

1. Создайте новый пустой аудиофайл, выбрав команду меню File -> New и установив соответствующие параметры в диалоговом окне New Window, или откройте существующий аудиофайл. Как это сделать, мы рассказывали в главе 4. Вы открываете существующий аудиофайл и помещаете указатель текущей позиции в то место файла, куда вы хотите вставить синтезированный ЗВУК.

2. Выберите команду меню Tools -> Synthesis -> Simple, чтобы открыть диалоговое окно Simple Synthesis (рис. 10.9).

3. Выберите нужный вариант из раскрывающегося списка Waveform shape. Этот параметр определяет тип базового сигнала, который вы хотите сгенерировать. Доступны варианты Sine, Square, Saw, Triangle, Noise и Absolute Sine. Попробуйте каждый из них, чтобы понять, на что они похожи.

4. Установите параметр Length (0.001 to 60.0 seconds). Этот параметр определяет длину (в секундах) генерируемого аудиосигнала.

5. Установите параметр Frequency (0.01 to 22,050 Hz). Этот параметр определяет частоту (или высоту) генерируемого звука.

6. Если вы вставляете звук в существующий аудиофайл и хотите, чтобы он был вставлен в текущей позиции, выберите в раскрывающемся списке Insert new waveform at вариант Cursor. Вы можете также выбрать, куда будет вставлен звук, в начало или в конец файла. Если вы создаете новый файл, вам не нужно устанавливать этот параметр.

Рис. 10.9. Генерация базовых звуков выполняется с помощью функции Simple Synthesis

7. Установите параметр Amplitude (-Inf. to 0 dB), указывающий, насколько громким будет звук.

8. Нажмите на кнопку Preview, чтобы услышать, как будут звучать ваши данные, прежде чем программа Sound Forge реально изменит их.

9. Нажмите на кнопку ОК.

Программа Sound Forge сгенерирует звуки в соответствии с установленными вами параметрами.

Пример простого синтеза

Однако что вы можете делать с помощью функции Simple Synthesis, кроме создания базовых синтезированных звуков? Используя функцию Simple Synthesis совместно с некоторыми другими функциями программы Sound Forge, вы можете создавать синтезированные записи "с нуля". Например:

1. Создайте новый пустой аудиофайл, выбрав команду меню File -> New и установив соответствующие параметры в диалоговом окне New Window.

2. Выполните команду меню Tools -> Synthesis -> Simple, чтобы открыть диалоговое окно Simple Synthesis - Sound 13.

3. Выберите в раскрывающемся списке Waveform shape вариант Square.

4. Установите значение параметра Length равным 3.

5. Установите значение параметра Frequency равным 261,6, что соответствует высоте ноты До первой октавы.

6. Установите значение параметра Amplitude равным — 12 дБ.

7. Нажмите на кнопку ОК. После этого первый синтезированный базовый тон будет создан.

8. Создайте новый пустой аудиофайл, выбрав команду меню File -> New и установив соответствующие параметры в диалоговом окне New Window.

9. Выберите пункт меню Tools -> Synthesis -> Simple, чтобы открыть диалоговое окно Simple Synthesis .

10. Выберите в раскрывающемся списке Waveform shape пункт Saw .

11. Установите значение параметра Length равным 3.

12. Установите значение параметра Frequency равным 466,2, что соответствует высоте ноты Си-бемоль первой октавы.

13. Установите значение параметра Amplitude равным —12 дБ.

14. Нажмите на кнопку ОК. После этого будет создан второй синтезированный базовый тон.

15. Выделите и скопируйте все данные из второго синтезированного тона.

16. Выделите все данные первого синтезированного тона.

17. Выберите команду меню Edit -> Paste Special -> Mix для открытия диалогового окна Mix.

18. Выберите в раскрывающемся списке Preset набор настроек 50/50 Mix и щелкните на кнопке ОК . В результате будет создан смикшированный составной тон.

19. Выберите команду меню Process -> Fade -> Graphic для открытия диалогового окна Graphic Fade.

20. Выберите в раскрывающемся списке Preset набор настроек пункт -6 dB Exponential Fade Out и нажмите на кнопку ОК.

21. Выберите команду меню Effects -> Flange/Wah-Wah для открытия диалогового окна Flange/Wah-Wah.

22. Выберите в раскрывающемся списке Preset набор настроек Fast Flange и нажмите на кнопку ОК.

23. Выберите команду меню Effects -> Reverb для открытия диалогового окна Reverh.

24. Выберите в раскрывающемся списке Preset набор настроек Metal Tank Preset и нажмите на кнопку ОК.

25. Воспроизведите полученный аудиофайл.

Не правда ли, здорово? Вы только что создали звук синтезатора "с нуля" и приведенный пример демонстрирует только несколько функций программы Sound Forge, которые вы можете использовать при разработке собственных звуков. Не бойтесь экспериментировать со всеми остальными функциями обработки и эффектами. Вы может наткнуться на действительно замечательные звуки. А если вы найдете что-нибудь, что вам очень понравится, сохраните этот звук в виде файла WAV, чтобы впоследствии использовать в ваших новых записях.

Функция FM Synthesis

Функция FM Synthesis позволяет вам создавать более сложные синтезированные звуки с использованием приемов FM-синтеза. Многие старые модели синтезаторов Yamaha (например, TX81Z) использовали эту форму синтеза. Путем комбинирования многих простых звуковых сигналов в различных сочетаниях FM-синтез позволяет вам создавать некоторые очень реалистичные и многие не совсем реалистичные звуки. Вот как работает функция FM Synthesis:

1. Создайте новый пустой аудиофайл, выполнив команду меню File -> New и установив соответствующие параметры в диалоговом окне New Window, или откройте существующий аудиофайл. Как это сделать, мы рассказывали в главе 4. Если вы открываете существующий аудиофайл, поместите указатель текущей позиции в то место файла, куда вы хотите вставить синтезированный звук.

2. Выполните команду меню Tools -> Synthesis -> FM, чтобы открыть диалоговое окно FM Synthesis - SoundlS (рис. 10.10).

3. Установите значение параметра Total output waveform length (0.001 to 60.000 seconds). Этот параметр определяет длину (в секундах) создаваемого аудиосигнала.

4. Выберите вариант параметра Configuration. Этот параметр определяет, сколько операторов вы хотите использовать для генерации вашего звука и как они будут соединены. Чтобы понять, какие типы звуков создаются при каждом из вариантов, вам придется поэкспериментировать.

Замечание

В FM-синтезе оператор представляет собой базовый генератор сигнала. Вы можете рассматривать оператор как одну функцию Simple Synthesis с парой дополнительных параметров. Функция FM Synthesis позволяет вам использовать до четырех операторов, так что она похожа на объединение четырех функций Simple Synthesis в одной. Кроме того, операторы могут быть соединены друг с другом различными способами. Например, в некоторых вариантах параметра Configuration вы заметите, что вывод одного оператора направляется в другой оператор. Это означает, что первый оператор был использован для модулирования частоты второго оператора. Такая техника позволяет создавать весьма сложные звуки .

Рис. 10.10. Используйте для создания сложных звуковых сигналов функцию FM Synthesis

5. Группа переключателей Current operator позволяет вам выбрать, с каким оператором вы собираетесь сейчас работать. Все операторы имеют одинаковое количество и типы параметров, так что мы расскажем только о параметрах для переключателя 1.

6. Определите амплитудную огибающую для текущего оператора с помощью графика амплитуды. Этот график работает точно так же, как график в функции Envelope, о которой мы рассказывали в zwee 9. Амплитудная огибающая управляет громкостью звука для оператора в зависимости от времени.

7. Выберите вариант в раскрывающемся списке Operator shape. Этот параметр определяет тип базового сигнала, который вы хотите использовать для данного оператора. Вы можете выбрать из вариантов Sine, Square, Saw, Triangle, Noise и Absolute Sine, так же как и в функции Simple Synthesis.

8. Установите значение параметра Frequency (0.00 to 22.050 Hz). Этот параметр определяет частоту (или высоту тона), используемую для данного оператора.

9. Установите параметр Feedback (0 to 100%). Данный параметр позволяет вам посылать вывод текущего оператора ему самому, т. е. вы можете заставить оператор модулировать свою собственную частоту в дополнение к той, которая была смодулирована другим оператором. Поэкспериментируйте с этим параметром, чтобы посмотреть, как он влияет на звук, который вы пытаетесь создать.

10. Установите параметр Amplitude (-Inf. to 0 dB), чтобы указать, насколько громким будет окончательный вывод текущего оператора.

11. Если вы используете больше одного оператора, повторите шаги с 5 по 10 для каждого дополнительного оператора.

12. Если вы вставляете звук в существующий аудиофайл и хотите, чтобы он был вставлен в текущей позиции, выберите в раскрывающемся списке Insert waveform at вариант Cursor. Вы можете также выбрать, куда будет вставлен звук, в начало или в коней файла. Если вы создаете новый файл, вам не нужно устанавливать этот параметр.

13. Нажмите на кнопку Preview, чтобы услышать, как будут звучать ваши данные, прежде чем программа Sound Forge реально изменит их.

14. Нажмите на кнопку ОК.

Программа Sound Forge сгенерирует звуки в соответствии с установленными вами параметрами. Для некоторых примеров звуков, которые вы можете создать с помощью функции FM Synthesis, не забудьте посмотреть наборы настроек из поставки программы.

Совет

Попробуйте сохранить некоторые звуки в виде файлов WAV, а затем использовать их для параметра Impulses функции Acoustic Mirror. Единственное ограничение заключается в том, что длина файлов не должна превышать 12 секунд. С помощью этой техники вы можете создавать весьма причудливые имитации внешней среды.


Глава 11. Подготовка файлов для мультимедиа и Интернета
  • Подготовка файлов для мультимедиа и Интернета
  • Работа с видеофайлами
    • Полоса видео
    • Функция Number Frames
    • Функция Go To
    • Копирование
    • Можно ли редактировать видео?
    • Вырезание
    • Вставка
    • Окно предварительного просмотра видео
  • Подготовка файлов для Интернета
    • Удаление смещения по оси амплитуды
    • Применение выравнивания
    • Применение динамической обработки
    • Нормализация
  • Работа с компакт-диском в программе Sound Forge
    • Функция Create CD
    • Извлечение звуковых данных с компакт-диска


Подготовка файлов для мультимедиа и Интернета

В дополнение к обычным средствам создания звуковых файлов программа Sound Forge включает в себя некоторые функции, помогающие создавать и редактировать файлы для мультимедиа и Интернета. В программе Sound Forge вы можете открыть видеофайл, добавить к нему новую звуковую дорожку или отредактировать существующую. Вы также можете сохранять видеофайлы вместе с отредактированными звуковыми файлами. Средства редактирования и обработки, имеющиеся в программе Sound Forge, упрощают подготовку файлов к распространению в Интернете и включают возможность сохранения в форматах RealAudio, MP3 или Windows Media. Программа Sound Forge даже позволяет записывать звуковые данные на компакт-диск, а также переписывать их с него. Предоставляя эти возможности, программа Sound Forge обеспечивает вас всем необходимым для того, чтобы вы могли подготовить ваши записи для всех возможных применений. Ниже следует список тем, которые мы осветим в этой главе:

  • работа с видеофайлами;
  • подготовка данных к распространению через Интернет;
  • переписывание данных с компакт-диска;
  • запись данных на компакт-диск.

Работа с видеофайлами

В главе 4 мы рассказывали, что нужно сделать, чтобы открыть и сохранить видеофайл. Но мы ничего не говорили про то, как работать с видеоданными, открытыми в программе Sound Forge. На самом деле, работа с ними не сильно отличается от работы со звуковыми файлами; разница лишь в том, что видеозапись состоит не только из звуковой дорожки, но и из видеоряда.

Полоса видео

Когда вы открываете видеофайл в программе Sound Forge, первым делом вы замечаете, что к окну данных добавилась новая секция (рис. 11.1). Эта секция называется полосой видео. Она отображает уменьшенные версии кадров видеоданных из текущего файла. Эти кадры показывают, что происходит в видеоряде в разные моменты времени. Они также позволяют увидеть, как синхронизированы видео- и аудиоданные.

Рис. 11.1. полоса видео в окне данных позволяет увидеть видеоряд

Рис. 11.2. Вы можете отключить воспроизведение видеоряда в полосе видео, используя пункт меню Animate

Если вы включите воспроизведение файла, то заметите, что, по мере того как указатель текущей позиции будет двигаться в окне данных, полоса видео начнет показывать видеоряд вместе со звуковой дорожкой. Попробуйте, и вы поймете, что мы имеем в виду. Если вы не хотите следить за видеорядом, вы можете отключить эту возможность, щелкнув на полосе видео правой кнопкой мыши и выбрав пункт Animate из контекстного меню (рис. 11.2).

Функция Number Frames

Щелкнув правой кнопкой мыши на полосе видео и выбрав из контекстного меню пункт Number Frames, вы можете указать, следует ли программе Sound Forge отображать номера кадров видеоряда в пределах полосы видео (рис. 11.3). Использование номеров кадров может быть полезно, когда вы хотите указать, в каком месте видеоряда должен появиться тот или иной звук или часть звуковой дорожки.

Рис. 11.3. Используйте функцию Number Frames для отображения номеров кадров в полосе видео

Функция Go To

Полосу видео можно также использовать для навигации по файлу. Просто щелкните правой кнопкой мыши на одной из секций полосы видео и выберите из контекстного меню пункт Go To. Указатель текущей позиции перейдет на начало соответствующей секции. Это дает возможность быстрого прослушивания разных секций видеофайла.

Копирование

Щелкнув правой кнопкой мыши на полосе видео и выбрав пункт Сору из контекстного меню, вы заставите программу Sound Forge скопировать текущий кадр видеоряда в буфер. Поскольку редактировать видеоданные в программе Sound Forge нельзя, мы, честно говоря, не знаем, зачем вообще нужна эта функция.

Можно ли редактировать видео?

Программа Sound Forge не позволяет вам вносить какие-либо изменения в видеоряд. Для этого вам понадобится специализированная программа редактирования видео. Тем не менее, вы можете редактировать звуковые данные в видеофайле так же, как вы это делаете в звуковом файле, а также изменять длину файла.

Вырезание

Если вы вырежете какую-нибудь часть звуковых данных из вашего видеофайла, сам видеоряд не подвергнется изменениям. Как показано на рис. 11.4, длина звуковой дорожки сократится, а длина видеоряда— нет. При воспроизведении такого файла видеоряд после окончания звуковой дорожки продолжится, но без звука.

Рис. 11.4. Вырезание звуковых данных из видеофайла не влияет на длину видеоряда

Вставка

Вы можете увеличить длину видеофайла, вставив в него дополнительные данные. В таком случае, если в файле больше звуковых данных, чем видеоматериала, конец его будет заполнен пустыми кадрами (рис. 11.5). Это значит, что при воспроизведении файла в конце его вы услышите звук, но не увидите изображения. Таким образом, в известном смысле вы можете добавлять кадры в файл, но они будут пустыми.

Рис. 11.5. Вставка дополнительных звуковых данных в видеофайл приводит к появлению в его конце пустых кадров

Рис. 11.6. Измените размер полосы видео, перетащив серую линию, расположенную чуть ниже видеоряда

Совет

Если вы находите, что работать с полосой видео трудно из-за ее размера, поместите курсор мыши над тонкой серой линией, находящейся под полосой видео. Затем щелкните мышью и перетащите нижний конец полосы видео вниз, чтобы увеличить ее размер (рис. 11.6).

Окно предварительного просмотра видео

В дополнение к полосе видео программа Sound Forge позволяет просматривать видеоряд в более удобном виде с помощью окна предварительного просмотра (рис. 11.7). Чтобы открыть это окно, выберите команду меню View -> Video Preview.

Рис. 11.7. Используйте окно предварительного просмотра видео, чтобы воспроизводить видеоряд в более удобном для вас виде

Главное различие между полосой видео и окном предварительного просмотра видео состоит в том, что последнее предусматривает специальную область просмотра, отведенную только под видеоданные. В дополнение к этому окно предварительного просмотра позволяет просматривать видеоряд в окне любого размера (конечно же, учитывая ограничения, накладываемые размером вашего монитора). Как и в случае с любым другим окном в системе Windows, вы можете изменить размер окна предварительного просмотра, перетащив его стороны или углы. В зависимости от режима работы, это может также повлечь изменение размера видеоряда. Изначально окно предварительного просмотра видео отображает видеозапись в режиме Integral Stretch (рис. 11.8). В этом режиме размер видео останется неизменным, как бы вы ни увеличивали само окно.

Рис. 11.8. Изначально окно предварительного просмотра видео работает в режиме integral Stretch

Совет

Во время просмотра в режиме Integral Stretch фоновый цвет окна предварительного просмотра видео может не соответствовать фоновому цвету видеоряда. Чтобы изменить фоновый цвет окна, щелкните в любом месте окна правой кнопкой мыши и выберите один из пунктов контекстного меню — White Background, Black Background или Default Background.

Если вы хотите, чтобы видеоряд заполнял все пространство окна предварительного просмотра видео, щелкните в этом окне правой кнопкой мыши и выберите пункт Stretch To Window из контекстного меню. В результате этого размер видеоряда растянется, достигнув размера окна Однако эта растяжка может исказить изображение, сделав его трудным для восприятия.

Рис. 11.9. Используйте режим Stretch To Window чтобы растянуть размер видеоряда до размера окна

Совет

Если ваш компьютер работает медленно, растяжка видео в окне предварительного просмотра может привести к еще большему замедлению работы Если случилось именно так, щелкните правой кнопкой мыши в окне предварительного просмотра и выберите из контекстного меню пункт Passive Update. Теперь программа Sound Forge будет обновлять видеоданные только тогда, когда процессор не загружен.

Если вы хотите изменить размер видеоряда, но сохранить его пропорции используйте режим Preserve Aspect. Щелкнув правой кнопкой мыши в окне предварительного просмотра видео и выбрав пункт Preserve Aspect вы можете изменить размер видеоряда, не искажая его (рис. 11.10).

Рис. 11.10. Используйте режим Preserve Aspect, чтобы растянуть размер видеоряда, не искажая его

Совет

Если у вас есть дополнительный внешний монитор, подключенный к вашему компьютеру, вы можете дать указание программе Sound Forge отображать данные из окна предварительного просмотра видео на вашем внешнем мониторе. Для этого щелкните в окне правой кнопкой мыши и выберите из контекстного меню пункт External Monitor. Эта возможность доступна, только если ваша видеокарта ее поддерживает.


Подготовка файлов для Интернета

Мы уже рассказывали о том, как сохранять звуковые файлы в форматах RealAudio, MP3 и Windows Media (см. главу 4). Но мы ничего не говорили о том, как обрабатывать файлы перед сохранением их в этих форматах. Поскольку все названные форматы — и RealAudio, и МРЗ, и Windows Media — используют сжатие данных для уменьшения размера файла, чтобы его было легче скачивать из Интернета, то иногда такое сжатие может повлиять на качество звука. Вы можете свести к минимуму потери качества, проделав несколько процедур по обработке файла, прежде чем преобразовывать его в тот или иной из перечисленных форматов.

Удаление смещения по оси амплитуды

В главе 8 мы говорили о том, что каждый раз перед обработкой файла нужно удалять смещение по оси амплитуды, которое может присутствовать в вашем файле. В противном случае в файле могут появиться нежелательные изменения. Чтобы удалить смещение по оси амплитуды, сделайте следующее:

1. Выделите все данные в вашем звуковом файле, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> DC Offset, чтобы открыть диалоговое окно DC Offset.

3. Выберите в раскрывающемся списке Name пункт Remove DC offset (scan entire sound file).

4. Нажмите на кнопку ОК.

Применение выравнивания

Выровняйте ваш файл, имея в виду, что большая часть высокочастотного и особо низкочастотного содержания может быть потеряна при сохранении файла в одном из форматов, использующих сжатие данных. Нужно будет поэкспериментировать, но лучше всего начать с обрезания высоких (ниже 60 Гц) и низких (выше 10 кГц) частот. Это поможет избежать деформаций звука, которая может произойти при сжатии данных. Чтобы возместить убытки от урезания частот, вы можете повысить значения нетронутых низких частот до 200 Гц. Также можно повысить средние частоты до 2,5 кГц. Этим вы выведете на первый план более важное содержимое вашей записи, например вокал (если он есть). Замечательно, что программа Sound Forge позволяет совершить выравнивание в один заход. Вот как это делается:

1. Выделите все данные в вашем звуковом файле, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> EQ -> Paragraphic, чтобы открыть диалоговое окно Paragraphic EQ - Slap bass.wav.

3. Установите флажок Enable low-shelf. Укажите в расположенном справа от флажка поле значение 60 Гц. Затем сделайте соответствующий уровень равным -Inf. Это повлечет урезание всех частот ниже 60 Гц, как мы указывали ранее.

4. Установите флажок Enable high-shelf (-Inf. to 25 dB). Укажите в расположенном справа поле значение 10 000 Гц. Затем сделайте соответствующий уровень равным —Inf. Это повлечет, как уже говорилось ранее, урезание всех частот выше 10 кГц.

5. Установите уровень на первой параметрической полосе равным +3,0 дБ, после чего соответствующую центральную частоту установите равной 200 Гц. Этим вы повысите значение низких частот примерно до 200 Гц. Можете поэкспериментировать со степенью повышения частот, но мы не стали бы превышать значение +6,0 дБ.

6. Установите уровень на второй параметрической полосе равным +3,0 дБ. После этого соответствующую центральную частоту укажите равной 2500 Гц. Этим вы повысите значение средних частот примерно до 2500 Гц. Можете поэкспериментировать со степенью повышения частот, но мы не стали бы превышать значение +6,0 дБ.

7. Для остальных параметров оставьте значение по умолчанию. По окончании работы диалоговое окно Paragraphic EQ должно выглядеть так, как показано на рис. 11.11.

Рис. 11.11. Для выравнивания файла используйте функцию Paragraphic EQ

8. Нажмите на кнопку Preview, чтобы проверить результат перед тем, как утвердить сделанные изменения. Если вы услышите какие-либо шумы и искажения, попробуйте снизить уровень на одной или обеих параметрических полосах.

9. Нажмите на кнопку ОК.

Применение динамической обработки

Преобразование файла в формат RealAudio, MP3 или Windows Media может повлечь за собой не только изменение некоторых частот, но и сужение динамического (амплитудного) диапазона, что создаст впечатление плоского, тусклого звука. Применение динамической обработки перед преобразованием даст вам возможность контролировать конечные уровни сигнала, а не оставлять их на произвол судьбы. Для выполнения динамической обработки вам нужно будет использовать функцию Graphic Dynamics программы Sound Forge:

1. Выделите все данные в вашем файле, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Effects -> Dynamics -> Graphic, чтобы открыть диалоговое окно Graphic Dynamics.

3. Выберите из раскрывающегося списка Preset набор настроек 2:1 Compression Starting At -18 dB. Если желаете, можете поэкспериментировать с параметром Ratio. Обычно значение коэффициента находится между 2:1 и 4:1, но может варьироваться в зависимости от материала, так что вам придется решать самим. Однако будьте осторожны: излишняя динамическая обработка может привести к появлению нежелательных помех, в результате чего звук станет тусклым и безжизненным.

4. Нажмите на кнопку Preview, чтобы проверить результат перед тем, как утвердить сделанные изменения. Если вы услышите какие-либо шумы и искажения, попробуйте уменьшить значение параметра Output gain.

5. Нажмите на кнопку ОК.

Нормализация

Последнее, что нужно сделать перед сохранением файла в одном из форматов, использующих сжатие данных, — нормализовать его. В главе 8 мы уже рассказывали о том, что нормализация повышает громкость звукового сигнала настолько, насколько это возможно сделать, не вызвав появление шумов и искажений. Это гарантирует, что в вашем файле будут использоваться наивысшие возможные значения цифрового разрешения и амплитуды. Также обеспечивается использование наибольшей громкости при преобразовании файла, поскольку это помогает скрыть шум на уровне низких частот и возможные последствия сжатия данных. Чтобы произвести нормализацию, используйте функцию Normalize программы Sound Forge:

1. Выделите все данные в вашем файле, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> Normalize, чтобы открыть диалоговое окно Normalize.

3. Выберите из раскрывающегося списка Preset набор настроек Maximize Peak Value.

4. Нажмите на кнопку Scan Levels, чтобы определить наивысший уровень сигнала вашего файла.

5. Установите значение параметра Normalize To между -0,50 и -1 дБ. Таким образом, вы сможете избежать нормализации до 0 дБ (или 100%), потому что процессы преобразования в форматы RealAudio, MP3 и Windows Media не всегда справляются с сигналами, равными 0 дБ. Иногда они "задыхаются", сталкиваясь с таким высоким сигналом, поэтому лучше всего оставить немного динамического пространства, чтобы преобразование прошло успешно.

6. Нажмите на кнопку Preview, чтобы проверить результат перед тем, как вы утвердите сделанные изменения. Если вы услышите какие-либо шумы и искажения, попробуйте уменьшить значение параметра Normalize To.

7. Нажмите на кнопку ОК.

8. Теперь ваш файл полностью подготовлен к преобразованию в форматы RealAudio, MP3 и Windows Media.


Работа с компакт-диском в программе Sound Forge

Разумеется, вы захотите распространять ваши записи не только через Интернет. Возможно, вам понадобится переносить записи на компакт-диск еще чаще, чем загружать их на Web-сервер. Программа Sound Forge располагает двумя функциями, позволяющими записывать звуковые данные на компакт-диск и считывать их с него.

Функция Create CD

Функция Create CD позволяет записывать звуковые файлы на компакт-диск — по одному файлу за раз. Это очень простая функция, и она, в отличие от многих других программ записи на компакт-диск, не снабжена никакими дополнительными возможностями. Вот как она работает:

1. Удостоверьтесь в том, что частота сэмплирования и разрядность вашего файла равны 44,1 кГц и 16 бит соответственно. Если это не так, используйте функцию Dither или Resample, как указано в главе 8.

2. Вставьте в дисковод пустой компакт-диск.

3. Выберите команду меню Tools -> Create CD, чтобы открыть диалоговое окно Create CD . В нем содержится информация о том, сколько места на компакт-диске требуется для записи данного файла и сколько на этом диске осталось свободного времени.

4. Нажмите на кнопку Add Audio. Программа Sound Forge запишет ваш файл на компакт-диск.

5. Если вы хотите переписать еще один файл, нажмите на кнопку Cancel. Откройте другой файл и повторите шаги с 1 по 3.

6. Закончив копировать файлы на компакт-диск, нажмите на кнопку Close Disc. В результате диск окончательно "запечатается", и теперь его можно будет воспроизводить на любом проигрывателе компакт-дисков.

Замечание

Если вы хотите в будущем добавлять на этот диск новые записи, вам не следует его закрывать. Оставив его открытым, вы сможете продолжить запись файлов на него в следующий раз. Тем не менее, открытый диск не может быть воспроизведен на стандартном проигрывателе компакт-дисков. Для этого вам необходимо его закрыть.

Извлечение звуковых данных с компакт-диск а

Программа Sound Forge также позволяет считывать звуковые данные с существующего аналогового компакт-диска. Эта возможность может пригодиться, если у вас есть диск, на котором записан ваш старый материал, для которого вы хотите произвести ремастеринг. Другой пример — если у вас есть аналоговый диск с записью звуковых эффектов, которые вы хотите использовать в вашем текущем проекте. Чтобы извлечь звуковые данные с компакт-диска, используйте функцию Extract Audio From CD. Вот как с ней обращаться:

1. Вставьте компакт-диск в дисковод вашего компьютера.

2. Выполните команду меню Tools -> Extract Audio From CD, чтобы открыть диалоговое окно Extract Audio from CD (рис. 11.12).

Рис. 11.12. Используйте функцию Extract Audio From CD, чтобы переписать звуковые данные с аналогового компакт-диска

3. В раскрывающемся списке Drive перечислены все дисководы компакт-дисков, имеющиеся в вашей системе. Выберите из этого списка необходимый дисковод.

4. Если вы хотите переписать с компакт-диска только некоторые записи, выберите переключатель Read by tracks. После этого вы увидите список записей на компакт-диске, время их начала и окончания и длины. Выделите записи, которые вы хотите переписать.

5. Если вы хотите переписать все записи с компакт-диска, выберите переключатель Read entire CD.

6. Если вы хотите переписать определенный временной отрезок записи на компакт-диске, выберите переключатель Read by range. Установите значения параметров Start и End для отрезка, который собираетесь переписать. Вы можете корректировать длину отрезка с помощью параметра Length.

7. Если вы хотите, чтобы программа Sound Forge автоматически создавала области для каждой переписанной с диска записи, установите флажок Create regions for each track.

8. Если вы хотите, чтобы программа Sound Forge автоматически создавала маркеры в начале каждой переписанной с диска записи, установите флажок Create markers for each index change.

9. Выберите значение параметра Speed, который определяет скорость чтения информации с компакт-диска. В большинстве случаев следует указать пункт Мах.

10. Нажмите на кнопку Play, чтобы прослушать выбранные записи, которые вы собираетесь переписать с компакт-диска.

11. Нажмите на кнопку ОК.

Если вы при этом активизируете переключатель Read by tracks, программа Sound Forge извлечет выделенные записи, поместив каждую из них в отдельное окно данных. Если вы активизируете переключатель Read entire CD, программа Sound Forge перепишет все данные с компакт-диска в одно окно данных. А если вы при этом активизируете переключатель Read by range, программа Sound Forge перепишет только определенный отрезок данных с диска, также поместив его в одно окно данных.

Совет

Дополнительная информация об извлечении звуковых данных с компакт-диска содержится в приложении 2.


Глава 12. Используем Sound Forge с MIDI
  • Используем Sound Forge с MIDI
  • Виртуальная клавиатура MIDI
    • Конфигурирование клавиатуры
    • Установка порта вывода
    • Установка MIDI-канала
    • Установка громкости
    • Включение клавиатуры
    • Игра на клавиатуре
    • Изменение размера клавиатуры
    • Изменение набора октав
    • Изменение имитируемого инструмента
    • Игра аккордами
  • Виртуальный маршрутизатор MIDI
    • Установка и настройка виртуального маршрутизатора MIDI
    • Изменение настроек виртуального маршрутизатора
  • Синхронизация цифрового синтезатора и программы Sound Forge
  • Запуск программы Sound Forge из цифрового синтезатора
    • Создание звукового файла
    • Запуск воспроизведения


Используем Sound Forge с MIDI

Несмотря на то, что программа Sound Forge предназначена для работы с цифровым звуком, она, тем не менее, содержит некоторые функции, связанные с MIDI, которые могут вам пригодиться. Например, вы можете синхронизировать цифровой музыкальный синтезатор с программой Sound Forge, чтобы эти программы, установленные на одном компьютере, воспроизводили звуковые данные согласованно. Вы также можете заставить программу Sound Forge работать в качестве устройства воспроизведения цифрового звука, запускаемого с помощью нот MIDI с клавиатуры или секвенсора. Эти дополнительные возможности расширяют функциональность программы Sound Forge и выводят ее за рамки обычных приложений редактирования цифрового звука. Вот какие темы мы будем раскрывать в этой главе:

  • виртуальная клавиатура MIDI;
  • виртуальный маршрутизатор MIDI;
  • синхронизация цифрового синтезатора и программы Sound Forge;
  • запуск программы Sound Forge из цифрового музыкального синтезатора.

Виртуальная клавиатура MIDI

Если у вас нет MIDI-инструмента или же вы хотите быстро воспроизвести MIDI-звук, вы можете использовать виртуальную клавиатуру MIDI. Это программа, позволяющая вам использовать мышь для отсылки сообщений Note On. С помощью нее также удобно проверять работоспособность MIDI-интерфейса или прослушивать MIDI-звук, используя звуковую карту. Кроме того, вы можете использовать виртуальную клавиатуру для запуска устройства воспроизведения сэмплов после создания сэмплерной петли в программе Sound Forge (о сэмплировании мы подробно поговорим в главе 13). Виртуальная клавиатура MIDI работает точно так же, как и настоящая; единственное различие в том, что это программа, а не аппаратное устройство. Чтобы открыть виртуальную клавиатуру, выберите команду меню View -> Keyboard (рис. 12.1).

Рис. 12.1. Используйте виртуальную клавиатуру MIDI, чтобы иметь возможность работать с MIDI-звуком с помощью мыши

Конфигурирование клавиатуры

Прежде чем использовать виртуальную клавиатуру, вам нужно установить некоторые параметры — как и на настоящей клавиатуре. Это такие параметры, как порт вывода MIDI, MIDI-канал и скорость нажатия клавиши MIDI (громкость), которые вы хотите, чтобы воспроизводились во время игры.

Установка порта вывода

В первую очередь вам нужно установить порт вывода MIDI, чтобы указать, куда клавиатура должна отсылать данные. Чтобы сделать это, нажмите на кнопку MIDI Out и выберите название порта вывода из появившегося меню (рис. 12.2).

Рис. 12.2. Нажмите на кнопку MIDI Out, чтобы установить порт вывода MIDI

Установка MIDI-канала

Вам также необходимо указать, какой MIDI-канал вы хотите использовать. Виртуальная клавиатура будет отсылать MIDI-данные только на выбранный вами канал. По умолчанию на клавиатуре установлен MIDI-канал 1. Если вы хотите изменить эту настройку, воспользуйтесь счетчиком, находящимся рядом с дисплеем MIDI-канала (рис. 12.3). Нажмите стрелку вверх, чтобы увеличить индекс MIDI-канала, или стрелку вниз, чтобы уменьшить его.

Рис. 12.3. Вы можете изменить MIDI-канал, используя счетчик, находящийся рядом с дисплеем MIDI-канала

Установка громкости

Параметр громкости регулирует скорость нажатия клавиши MIDI каждой ноты, посылаемой клавиатурой. По умолчанию установлено максимальное значение этого параметра — 127. Возможно, вам не потребуется изменять данное значение, но если потребуется, просто опустите или поднимите ползунок параметра громкости (рис. 12.4). Чтобы увеличить значение, необходимо поднять ползунок, а чтобы уменьшить — опустить.

Рис. 12.4. Вы можете изменить громкость, используя ползунок параметра громкости

Включение клавиатуры

Наконец, вы должны включить виртуальную клавиатуру с помощью кнопки On/Off (рис. 12.5). Возможно, необходимость в этом покажется вам странной, поскольку мы имеем дело с программой. Однако выключить клавиатуру может быть полезно, если вы не хотите, чтобы MIDI-данные были отосланы случайно.

Рис. 12.5. Используйте кнопку On/Off, чтобы включать и выключать клавиатуру

Игра на клавиатуре

На клавиатуре можно играть, нажимая левой кнопкой мыши на клавиши (рис. 12.6). Во время нажатия клавиатура посылает сообщение Note On MIDI-порту и каналу, которые вы выбрали ранее, с указанной громкостью. Чем дольше вы держите кнопку мыши в нажатом состоянии, тем длиннее получается звук.

Рис. 12.6. На клавиатуре можно играть, нажимая левой кнопкой мыши на клавиши

Совет

Если вы хотите сыграть на клавиатуре последовательность нот (гамму), удерживайте левую кнопку мыши и перемещайте курсор по клавишам. Таким образом, будут сыграны все ноты, на которые вы укажете курсором.

Изменение размера клавиатуры

Если вам кажется, что клавиши слишком малы, вы с легкостью можете сделать их больше. Чтобы изменить размер клавиатуры, просто перетащите углы или края окна клавиатуры, как вы бы сделали в любом другом окне Windows (рис. 12.7).

Рис. 12.7. Вы можете изменить размер клавиатуры, перетащив углы или края ее окна

Изменение набора октав

Вы, наверное, обратили внимание на то, что на виртуальной клавиатуре показано только три октавы, а не 88 клавиш, как на настоящей клавиатуре. Если вы хотите воспользоваться октавами, не показанными на клавиатуре, вы можете изменить положение клавиш с помощью кнопок Octave (рис. 12.8). Нажмите левую кнопку, чтобы опуститься на октаву вниз, или правую кнопку, чтобы подняться на октаву вверх. На всех нотах До на клавиатуре показаны номера октав.

Рис. 12.8. Вы можете изменить набор октав на клавиатуре с помощью кнопок Octave

Изменение имитируемого инструмента

Клавиатура отсылает два вида сообщений: Note On и Program Change; последнее содержит информацию об имитируемом музыкальном инструменте. Сначала проверьте, настроена ли клавиатура на отсылку сообщений Program Change. Для этого нажмите на кнопку MIDI Out и удостоверьтесь в том, что пункт Send Program Changes, находящийся внизу контекстного меню, помечен (рис. 12.9).

Рис. 12.9. Включите функцию Send Program Changes, используя кнопку MIDI Out

Чтобы изменить имитируемый инструмент, используйте раскрывающийся список Instrument (рис. 12.10). В этом списке перечислены все 127 инструментов (звуков), которые можно сымитировать. Если ваш синтезатор не поддерживает спецификацию General MIDI, выберите инструмент, используя стандартные номера изменения программ MIDI (от 0 до 127), показанные рядом с названиями инструментов. После того как вы выберете инструмент, клавиатура пошлет сообщение Program Change вашему синтезатору. После этого звук при игре на клавиатуре изменится.

Рис. 12.10. Используйте раскрывающийся список Instrument, чтобы изменить имитируемый инструмент

Игра аккордами

Поскольку на клавиатуре вы играете посредством мыши, то при нормальных обстоятельствах вы сможете сыграть только одну ноту за раз. Тем не менее, виртуальная клавиатура предоставляет несколько режимов, позволяющих играть аккордами и октавами. Чтобы включить один из этих режимов, воспользуйтесь раскрывающимся списком Note (рис. 12.11).

Рис. 12.11. Используйте раскрывающийся список Note, чтобы включить один из специальных режимов виртуальной клавиатуры

Выберите из этого списка нужный аккорд. Есть также возможность игры октавами. После того как вы сделали свой выбор, начинайте играть. Теперь, один раз нажав на клавишу, вы услышите не ноту, а выбранный вами аккорд. Этот аккорд будет построен на ноте, соответствующей нажатой вами клавише. Например, если из раскрывающегося списка Note вы выбрали пункт Major, а потом нажали клавишу До, вы услышите До-мажорный аккорд. Поэкспериментируйте с разными аккордами прежде, чем перейти к следующему разделу.


Виртуальный маршрутизатор MIDI

Обычно вы работаете только с MIDI-программой и ни с чем более. Вы используете ее для сочинения музыки, подключая ваш компьютер к синтезатору через аппаратный MIDI-интерфейс. При этом MIDI-программа отсылает MIDI-данные MIDI-интерфейсу, который, в свою очередь, отсылает данные синтезатору. Затем синтезатор воспроизводит указанные вами данные. Однако в наше время компьютеры стали достаточно мощными, чтобы можно было пользоваться несколькими программами сразу. Некоторые из этих программ теперь могут заменить аппаратные синтезаторы таким образом, что и MIDI-программа, и MIDI-синтезатор будут находиться в составе компьютера. В этом случае также отпадет необходимость в аппаратном MIDI-интерфейсе. Вместо него вам понадобится программный MIDI-интерфейс. Вот тут-то нам и пригодится виртуальный маршрутизатор MIDI компании Sonic Foundry. Виртуальный маршрутизатор действует как программный MIDI-интерфейс и позволяет отсылать MIDI-данные из одной программы в другую при том условии, что обе эти программы запущены на одном компьютере.

Так зачем нам нужен виртуальный маршрутизатор MIDI? Собственно, одну его функцию мы уже обозначили: управлять аппаратным синтезатором с помощью цифрового. Но относительно программы Sound Forge на ум приходит еще пара идей. Одна из них — возможность синхронизации цифрового синтезатора с программой Sound Forge, чтобы можно было одновременно и согласованно воспроизводить звуковой файл в программе Sound Forge и MIDI-данные с помощью цифрового синтезатора. С другой стороны, вы можете использовать программу Sound Forge как устройство воспроизведения сэмплов и запускать в ней воспроизведение звуковых файлов с помощью цифрового синтезатора. Об этих двух возможностях мы поговорим позже. Сначала позвольте объяснить, как устанавливать и настраивать виртуальный маршрутизатор MIDI.

Установка и настройка виртуального маршрутизатора MIDI

Виртуальный маршрутизатор MIDI не может быть установлен вместе с программой Sound Forge, так что вам придется устанавливать его отдельно. Для этого сделайте следующее:

1. В Windows нажмите на кнопку Start (Пуск) и выберите команду Settings -> Control Panel (Настройка -> Панель управления), чтобы открыть Панель управления Windows (рис. 12.12).

2. Выберите на Панели управления пункт Add New Hardware (Установка оборудования), чтобы открыть окно Add New Hardware Wizard (Мастер установки нового оборудования) (рис. 12.13).

3. Нажмите на кнопку Next (Далее).

4. Еще раз нажмите на кнопку Next (Далее), чтобы посмотреть список установленных устройств (рис. 12.14).

5. Выберите пункт No,the device isn't in the list (Нет, устройство в списке отсутствует).

6. Нажмите на кнопку Next (Далее).

7. На следующей странице мастер спросит: "Do you want Windows to search for your new hardware?" ("Хотите ли вы, чтобы Windows произвела поиск нового оборудования?"). Выберите переключатель No , i want to select the hardware from a list (Нет, я хочу выбрать устройство из списка).

8. Нажмите на кнопку Next (Далее), чтобы посмотреть список Hardware types (Типы устройств) (рис. 12.15).

9. В списке Hardware types (Типы устройств) выберите пункт Sound, video and game controllers (Звуковые, видео и игровые контроллеры). Затем нажмите на кнопку Next (Далее).

Рис. 12.12. Откройте Панель управления Windows, чтобы запустить установку виртуального маршрутизатора MIDI

Рис. 12.13. Откройте окно Add New Hardware Wizard

Рис. 12.14. Посмотрите список установленных устройств и выберите нужный пункт

Рис. 12.15. Выберите пункт из списка Hardware types

10. На следующей странице нажмите на кнопку Have disk (Установить с диска), чтобы открыть диалоговое окно Install From Disk (Установка с диска) (рис. 12.16).

11. Вставьте диск с программой Sound Forge в ваш дисковод для компакт-дисков.

12. В поле Copy manufacturer's files from (Копировать файлы с диска) введите D:\Extras\virtual MIDI Router 4. 0\win9x (где D — метка вашего дисковода для компакт-дисков). Затем нажмите на кнопку ОК, чтобы открыть диалоговое окно Select Device (Установка устройства) (рис. 12.17).

Рис. 12.16. В диалоговом окне Install From Disk укажите местоположение виртуального маршрутизатора MIDI

Рис. 12.17. В диалоговом окне Select Device выберите пункт Sonic Foundry Virtual MIDI Router (16 bit)

13. В поле Models (Модели) укажите Sonic Foundry Virtual MIDI Router (16 bit). Затем нажмите на кнопку ОК.

14. На последней странице Мастера установки нового оборудования нажмите на кнопку Finish (Готово).

15. Теперь виртуальный маршрутизатор MIDI будет установлен, после чего на экране появится диалоговое окно Configure Sonic Foundry VMR .

16. Виртуальный маршрутизатор MIDI позволяет использовать до четырех виртуальных MIDI-портов. Укажите, сколько таких портов вы хотите использовать, выбрав один из пунктов в раскрывающемся списке Virtual MIDI Routing Ports (1-4). Затем нажмите на кнопку ОК.

Предупреждение

Загрузка операционной системы Windows может окончиться неудачей, если в вашей системе установлено больше 11 устройств MIDI. Это возможно, если к вашему компьютеру подключен либо один многопортовый MIDI-интерфейс, либо несколько обычных (хотя у нас Windows 98SE и 14 установленных устройств MIDI, и при этом никаких проблем). Если после установки виртуального маршрутизатора MIDI появились системные ошибки, попробуйте уменьшить количество используемых им портов (см. следующий раздел) или вообще деинсталлируйте его.

17. Перезагрузите Windows.

18. После перезагрузки Windows вы можете использовать виртуштьный маршрутизатор.

Замечание

Если вы работаете с программой Sound Forge в среде Windows NT, процедура установки виртуального маршрутизатора будет несколько иной. Ознакомьтесь с документацией по программе Sound Forge для получения подробных инструкций.

Изменение настроек виртуального маршрутизатора

Если вам будет нужно изменить количество виртуальных MIDI-портов, используемых виртуальным маршрутизатором, сделайте следующее:

1. В Windows нажмите на кнопку Start (Пуск) и выберите команду меню Settings -> Control Panel (Настройка -> Панель управления), чтобы открыть Панель управления Windows.

2. На Панели управления выберите иконку Multimedia (Звук и мультимедиа), чтобы открыть диалоговое окно Multimedia Properties (Свойства: Звук и мультимедиа) (рис. 12.18).

Рис. 12.18. Используйте диалоговое окно Multimedia Properties, чтобы изменить настройки виртуального маршрутизатора

3. Выберите вкладку Devices (Устройства), щелкните на знаке "плюс" рядом с пунктом MIDI Devices And Instruments (Устройства и инструменты MIDI).

4. Затем выберите из списка Multimedia devices пункт 1 Sonic Foundry MIDI Router. Если пунктов с этим названием несколько, выберите любой из них (рис. 12.19).

5. Нажмите на кнопку Properties (Свойства), чтобы открыть диалоговое окно 1 Sonic Foundry MIDI Router Properties (рис. 12.20).

6. Нажмите на кнопку Settings (Настройки), чтобы открыть диалоговое окно Configure Sonic Foundry VMR.

7. Выберите в этом окне новое количество используемых виртуальных MIDI-портов с помощью раскрывающегося списка Virtual MIDI Routing Ports.

Рис. 12.19. Доступ к настройкам виртуального маршрутизатора можно получить на вкладке Devices

Рис. 12.20. Установки виртуального маршрутизатора можно изменить, используя диалоговое окно 1 Sonic Foundry MIDI Router Properties

8. Нажмите на кнопку ОК.

9. Нажмите на кнопку ОК в диалоговом окне 1 Sonic Foundry MIDI Router Properties.

10. Нажмите на кнопку ОК в диалоговом окне Multimedia Properties (Свойства: Звук и мультимедиа).

11. Перезагрузите Windows.

После того как Windows перезагрузится, виртуальный маршрутизатор будет использовать указанное количество виртуальных MIDI-портов.


Синхронизация цифрового синтезатора и программы Sound Forge

Несколько ранее мы упоминали об одной из функций виртуального маршрутизатора, а именно о синхронизации цифрового синтезатора и программы Sound Forge. В результате вы сможете одновременно и согласованно воспроизводить звуковой файл в программе Sound Forge и MIDI-данные на цифровом синтезаторе. Естественно, обе программы будут одновременно работать на одном компьютере. Чтобы продемонстрировать такой вариант использования виртуального маршрутизатора, мы будем использовать цифровой синтезатор Pro Audio 9 из программы Cakewalk Music Software, но вы можете использовать любой другой цифровой синтезатор, предоставляющий возможность синхронизации. Мы уже объясняли принципы синхронизации в главе 6, поэтому здесь не будем на них подробно останавливаться. Вместо этого приведем пошаговую инструкцию, с помощью которой вы справитесь с поставленной задачей.

1. Запустите программу Cakewalk Pro Audio 9 (мы предполагаем, что вы умеете пользоваться вашим цифровым синтезатором).

2. Откройте файл проекта, содержащий MIDI-данные, которые вы хотите синхронизировать с программой Sound Forge.

3. Выполните команду меню Options -> Project, чтобы открыть диалоговое окно Project Options, затем откройте вкладку Clock (рис. 12.21).

4. В группе Source выберите переключатель SMPTE/MTC.

5. В группе SMPTE/MTC Format выберите переключатель 30 Frame Nondrop.

6. Нажмите на кнопку ОК.

7. Выберите команду меню Options -> MIDI Devices, чтобы открыть диалоговое окно MIDI Ports (рис. 12.22).

Рис. 12.21. Используйте диалоговое окно Project Options чтобы определить настройки синхронизации для синтезатора Pro Audio 9

Рис. 12.22. Используйте диалоговое окно MIDI Ports чтобы определить MIDI-порты, которые будут использоваться синтезатором Pro Audio 9

8. В поле Input Ports выберите пункт Sonic Foundry MIDI Router. Если пунктов с таким названием несколько, выберите тот, что начинается с цифры 1, т. е. 1 Sonic Foundry MIDI Router.

9. Нажмите на кнопку ОК.

10. Запустите программу Sound Forge.

11. Выполните команду меню Options -> Preferences, чтобы открыть диалоговое окно Preferences, затем перейдите на вкладку MIDI/Sync (рис. 12.23).

Рис. 12.23. Используйте диалоговое окно Preferences, чтобы определить настройки синхронизации для программы Sound Forge

12. Выберите пункт Sonic Foundry MIDI Router из раскрывающегося списка параметра Output. Если есть несколько пунктов с таким названием, выберите тот пункт, который начинается с цифры 1, т. е. 1 Sonic Foundry MIDI Router.

13. Убедитесь, что флажок Use 30 frames per second for SMPTE Non-Drop установлен.

14. Нажмите на кнопку ОК.

15. Чтобы изменить систему мер на линейке времени окна данных, выполните команду Mеню Options -> Status Format -> SMPTE Non-Drop.

16. Включите выход синхронизации, выбрав команду меню Options -> MIDI Output Sync.

В программе Cakewalk Pro Audio 9 начните воспроизведение. При этом Pro Audio отреагирует не сразу. Вместо этого появится сообщение "Waiting for 30 Frame (Non-Drop)".

1. В программе Sound Forge запустите воспроизведение звукового файла. Программа пошлет код синхронизации синтезатору Pro Audio, используя виртуальный маршрутизатор, и обе программы (Sound Forge и Pro Audio) одновременно начнут воспроизведение.

2. Чтобы остановить воспроизведение, пользуйтесь командами программы Sound Forge, но не Pro Audio. Или же дождитесь окончания звукового файла, по достижении которого обе программы автоматически прекратят воспроизведение.

Вы можете использовать эту процедуру в разных ситуациях. Например, если вы редактируете вокальную партию в программе Sound Forge, но хотите услышать, как она звучит на фоне музыки, которую вы сочинили в вашем цифровом синтезаторе. Просто поэкспериментируйте, и мы уверены, что вы найдете подходящее применение этой возможности.


Запуск программы Sound Forge из цифрового синтезатора

Еще одна функция виртуального маршрутизатора — запускать воспроизведение звуковых данных в программе Sound Forge из цифрового синтезатора. При этом маршрутизатор связывается с программой Sound Forge, но не посредством синхронизации. Вместо нее используются области и MIDI-триггеры. Как и в предыдущем примере, мы будем использовать цифровой синтезатор Pro Audio 9 программы Cakewalk Music Software, но данная процедура может быть проделана при наличии любого другого синтезатора.

Создание звукового файла

В первую очередь вам необходимо создать звуковой файл в программе Sound Forge, содержащий данные, воспроизведение которых вы хотите запустить, используя цифровой синтезатор. Этот файл может содержать любую информацию — от звуков музыкальных инструментов или звуковых эффектов до вокальных пассажей или любых других данных. Чтобы создать файл, сделайте следующее:

1. Запустите программу Sound Forge и выполните команду меню File -> New , чтобы создать новый звуковой файл. Убедитесь, что формат этого файла (разрядность, частота сэмплирования и количество каналов) идентичен формату данных, которые вы будете в данный файл добавлять.

2. Откройте звуковой файл, содержимое которого вы хотите добавить в новый файл.

Совет

Если вы хотите добавить в новый файл звуковые данные с компакт-диска, вы можете использовать команду меню Extract Audio -> From CD. К тому же, вы можете применить функции Simple Synthesis и FM Synthesis, чтобы создать собственные звуковые эффекты и использовать их в вашем звуковом файле.

3. Выделите данные в открытом звуковом файле и вставьте их в новый файл.

Совет

Выделяя данные в открытом звуковом файле, убедитесь, что в начале и в конце выделенной области нет фрагментов тишины. Этим вы гарантируете, что воспроизведение данных начнется сразу же, как только вы запустите файл из цифрового синтезатора.

4. Выделите данные, которые вы только что вставили в новый звуковой файл.

5. Выполните команду меню Special -> Regions List -> Add, чтобы открыть диалоговое окно Add Marker/Region (рис. 12.24).

Рис. 12.24. Используйте диалоговое окно Add Marker/Region чтобы создать область данных в вашем новом файле

6. Все параметры в этом диалоговом окне (кроме параметра Trigger) должны быть уже настроены, поскольку вы предварительно создали выделенную область. Но если вы, для лучшей узнаваемости, хотите изменить имя новой области, введите новое имя в поле параметра Name.

7. Определите для новой области MIDI-триггер, выбрав пункт MIDI: Note On - Play из раскрывающегося списка, находящегося в области Trigger. Затем выберите для этой области канал и ноту. Позже вы должны будете использовать тот же MIDI-канал и ноту, чтобы запускать воспроизведение данной области.

8. Нажмите на кнопку ОК.

9. Выполните команду меню Special -> Transport -> Go To End, чтобы переместить указатель текущего положения на конец нового звукового файла. Вы должны будете вставить новую порцию данных именно сюда.

10. Закройте файл, выделенную область из которого вы вставляли в новый файл.

11. Повторите шаги со 2 по 10 для каждого нового фрагмента данных, который вы хотите вставить в новый файл. Присваивая MIDI-канал и ноту для MIDI-триггера каждой новой области, возможно, будет разумно все время использовать одинаковый канал, но разные ноты.

12. Сохраните новый звуковой файл в формате WAV, при этом не забудьте выбрать пункт Save Regions and Playlist In.WAV/AVI files из раскрывающегося списка Rgns/Playlist в диалоговом окне Save As.

Теперь вы можете запускать воспроизведение данных в программе Sound Forge с помощью виртуального маршрутизатора MIDI и цифрового синтезатора.

Запуск воспроизведения

После того как вы создали звуковой файл, содержащий области с присвоенными им MIDI-триггерами, вы можете начинать подготавливать программу Sound Forge и ваш цифровой синтезатор (в нашем случае — Cakewalk Pro Audio 9) к взаимодействию. Вот как это делается.

1. Запустите программу Cakewalk Pro Audio 9. Мы предполагаем, что вы умеете работать с цифровыми синтезаторами.

2. Создайте новый проект (или же откройте уже существующий) и новую MIDI-дорожку, содержащую ноты, которые должны запустить области файла, созданного в программе Sound Forge. Убедитесь, что это те же самые ноты, которые вы задали в свойствах MIDI-триггеров областей звукового файла. Также присвойте данной MIDI-дорожке тот же MIDI-канал, который вы присвоили областям звукового файла.

3. Выполните команду меню Options -> MIDI Devices, чтобы открыть диалоговое окно MIDI Ports.

4. Выберите пункт Sonic Foundry MIDI Router из списка Output. Если пунктов с таким названием несколько, выберите тот, что начинается с цифры 1, т. е. 1 Sonic Foundry MIDI Router.

5. Нажмите на кнопку ОК.

6. Запустите программу Sound Forge.

7. Откройте звуковой файл, который должен быть запущен.

8. Выполните команду меню Options -> Preferences, чтобы открыть диалоговое окно Preferences, и перейдите на вкладку MIDI/Sync.

9. Выберите пункт Sonic Foundry MIDI Router из раскрывающегося списка Input. Если пунктов с таким названием несколько, выберите тот, что начинается с цифры 1, т. е. 1 Sonic Foundry MIDI Router.

10. Нажмите на кнопку ОК.

11. Выполните команду меню Options -> MIDI Input Sync/Trigger, чтобы включить MIDI-триггеры в программе Sound Forge.

12. Перейдите в программу Cakewalk и запустите воспроизведение вашего проекта.

Программа Cakewalk при этом пошлет информацию о MIDI-ноте на MIDI-канал, который вы выбрали, через виртуальный маршрутизатор в программу Sound Forge, где начнется воспроизведение соответствующей области открытого звукового файла.

Совет

Вы также можете использовать виртуальную клавиатуру MIDI, чтобы запускать воспроизведение областей. Просто присвойте выходу клавиатуры тот порт маршрутизатора, который вы используете в программе Sound Forge. В нашей ситуации это будет "1 Sonic Foundry MIDI Router". После этого, когда вы будете нажимать на клавиши виртуальной клавиатуры, соответствующие нотам MIDI-триггеров областей вашего звукового файла, будет запускаться их воспроизведение.


Глава 13. Sound Forge и сэмнлирование
  • Sound Forge и сэмнлирование
  • Что такое сэмплы?
  • Создание и редактирование сэмплов
    • Разовые сэмплы
    • Циклические сэмплы
    • Поддерживающие сэмплы
    • Тюнер цикла
    • Поддерживающий сэмпл с завершающим фрагментом
  • Сохранение и передача сэмплов
    • Передача сэмпла
    • Получение сэмплов


Sound Forge и сэмплирование

Наши поздравления! Вы добрались до последней главы этой книги. Вы научились записывать, редактировать, обрабатывать и даже совместно использовать звуковые файлы. Но все же есть одна сфера приложения программы Sound Forge, о которой мы пока не рассказывали. Это — уникальные функции и инструменты, позволяющие создавать ваши собственные сэмплы. Таким образом, в этой главе мы обсудим тему сэмплирования, включая следующие вопросы:

  • что такое сэмплы;
  • создание и редактирование сэмплов;
  • использование тюнера цикла;
  • сохранение и передача сэмплов.

Что такое сэмплы?

Ознакомившись с функциями Simple Synthesis и FM Synthesis (о которых мы рассказывали в главе 10), вы поняли, что создание звуков при помощи фундаментальных синтетических методов предполагает использование базовых диаграмм сигналов. Но такие методы не позволяют вам создавать достаточно реалистичные звуки. По этой причине многие современные MIDI-инструменты и звуковые карты используют воспроизведение сэмплов для создания звуков. Метод воспроизведения сэмплов позволяет добиться высокой реалистичности. Причина заключается в том, что устройства воспроизведения сэмплов имеют дело со звуками и музыкальными инструментами реального мира. Когда устройство воспроизведения сэмплов получает сообщение MIDI Note On, то вместо создания электронного звука оно воспроизводит цифровой сэмпл, который может содержать любой реальный звук — от фортепиано до волчьего воя.

Отличие сэмплов от обычных аудиозаписей состоит в том, что их длина незначительна (хотя не всегда) и они обычно воспроизводятся циклично (раз за разом). К тому же, фактически существует три вида сэмплов: разовые сэмплы (One-shot samples), которые обычно используются для создания звуковых эффектов или ударных звуков и воспроизводятся один раз от начала до конца, цикличность отсутствует; циклические сэмплы (Loop samples), также называемые сэмплерными петлями — они имитируют целые инструментальные партии, например четыре такта партии ударных инструментов; поддерживающие сэмплы (Sustaining samples), они обычно используются для имитации акустических инструментов, реализуемой с использованием сообщений MIDI Note.

Создание и редактирование сэмплов

Сэмплы можно использовать в самых разных целях, а программа Sound Forge предоставляет вам возможность создавать и управлять своими собственными сэмплами. Чтобы вы уяснили, как использовать эти возможности, мы приведем несколько примеров, показывающих, как создавать и редактировать все типы сэмплов, упомянутые ранее.

Разовые сэмплы

Создать разовый сэмпл легче всего, в основном, потому, что он представляет собой просто аудиозапись с некоторыми специфическими параметрами. Цикличность в разовых сэмплах отсутствует. Чтобы создать такой сэмпл, сделайте следующее:

1. Выберите команду меню File -> New, чтобы открыть диалоговое окно New Window. В нашем случае мы попросим вас определить параметры частоты сэмплирования, разрядности и количества каналов как 44 100 Гц, 16 бит и Mono соответственно. Затем нажмите на кнопку ОК, чтобы создать новый звуковой файл.

2. Выберите команду меню Tools -> Synthesis -> FM, чтобы открыть диалоговое окно FM Synthesis. Укажите набор настроек Another One и нажмите на кнопку ОК (рис. 13.1). В нашем примере для обеспечения звуковых данных мы используем функцию FM Synthesis, но в принципе вы можете использовать все, что хотите: звук ударного инструмента, вокальную партию, звуковой эффект — все, что может воспроизводиться однократно, без применения цикличности.

3. Выполните команду меню Edit -> Select All, чтобы выделить все данные в вашем звуковом файле.

4. Выберите команду меню Special -> Create Sample Loop, чтобы открыть диалоговое окно Edit Sample - Sound3 (рис. 13.2).

5. Чтобы создать разовый сэмпл, выберите в группе переключателей Sample type переключатель One shot.

Рис. 13.1. Используйте функцию FM Synthesis, чтобы создать разовый сэмпл со звуковым эффектом

Рис. 13.2. Используйте диалоговое окно Edit Sample - Sounds, чтобы преобразовать ваш звуковой файл в сэмпл

6. Введите обозначение ноты в поле параметра MIDI unity note of sample (C-l to G9). Этим обозначается тональность записи в вашем сэмпле. Это значит, что если вы проиграете ваш сэмпл при помощи устройства воспроизведения сэмплов и используя обозначенную ноту, то он будет звучать так же, как звучит сейчас в программе Sound Forge. Но если вы будете использовать другую ноту, тональность сэмпла будет изменена и он будет звучать выше или ниже относительно оригинальной записи, в зависимости от этой ноты. В случае с разовыми сэмплами вы можете ввести в поле MIDI unity note of sample (C-l to G9) любое значение.

7. Введите значение в поле параметра Fine tune (O.OOO to 99.999 cents). На самом деле вам нет нужды использовать этот параметр. Он информирует ваше устройство воспроизведения сэмплов о необходимости изменения тональности сэмпла во время его воспроизведения. Но если вам все-таки нужно настроить сэмпл, параметр в вашем распоряжении.

8. Введите значения параметров SMPTE format и SMPTE offset. Опять же, эти параметры необязательны. В большинстве случаев вы можете их проигнорировать. Однако некоторые устройства воспроизведения сэмплов позволяют настраивать сдвиг SMPTE в целях SMPTE-синхронизации. Поэтому при необходимости вы можете воспользоваться этим параметром.

9. Нажмите на кнопку ОК.

Вот и все, что нужно сделать, чтобы создать разовый сэмпл. Теперь вы можете либо сохранить файл для использования в программном устройстве воспроизведения сэмплов, либо переслать его внешнему устройству. Об этом мы более подробно поговорим в дальнейшем.

Циклические сэмплы

Циклические сэмплы (или сэмплерные петли) создавать немногим сложнее, чем разовые. Сегодня, благодаря широкому распространению программных устройств воспроизведения сэмплов (таких, как ACID компании Sonic Foundry), они также являются очень популярным типом сэмплов. Программные устройства воспроизведения сэмплов позволяют создавать полноценные музыкальные произведения путем соединения циклических сэмплов, при этом ничего более не требуется. Вы даже можете купить коллекцию циклических сэмплов, записанную на компакт-диск в профессиональной студии. Некоторые компании занимаются продажей таких дисков. Стоит открыть текущий номер журнала "Electronic Musician" или "Keyboard", и вы сразу наткнетесь на множество объявлений, рекламирующих диски с сэмплами. Конечно же, купить сэмплы не так приятно, как создать их самому. А для того чтобы создать циклический сэмпл, необходимо сделать следующее:

1. Выберите команду меню File -> New , чтобы открыть диалоговое окно New Window. В нашем случае мы попросим вас определить параметры частоты сэмплирования, разрядности и количества каналов как 44 100 Гц, 16 бит и Mono , соответственно. Затем нажмите на кнопку ОК, чтобы создать новый звуковой файл.

2. Выполните команду меню Tools -> Synthesis -> FM, чтобы открыть диалоговое окно FM Synthesis. Выберите набор настроек Something Else и нажмите на кнопку ОК (рис. 13.3). В нашем примере для обеспечения звуковых данных мы используем функцию FM Synthesis, но в принципе вы можете использовать все, что хотите, например партию ударных инструментов или гитарный гриф — все, что может воспроизводиться в циклическом режиме.

Рис. 13.3. Используйте функцию FM Synthesis, чтобы создать циклический сэмпл

3. Выполните команду меню Edit -> Select All, чтобы выделить все данные в вашем файле.

4. Выберите команду меню Special -> Create Sample Loop, чтобы открыть диалоговое окно Edit Sample - Sound4 (рис. 13.4).

5. Чтобы создать циклический сэмпл, выберите переключатель Sustaining из группы Sample type.

6. Если вы хотите установить бесконечную цикличность (а обычно требуется именно это), выберите переключатель Infinite loop. Если вы хотите, чтобы сэмпл повторялся ограниченное количество раз, выберите переключатель Loop count (I to 999) и введите количество повторений. Эта функция может работать, а может и не работать в вашем устройстве воспроизведения сэмплов. В большинстве случаев цикличность контролируется MIDI-устройством. При этом количество повторений сэмпла зависит от того, как долго в таком устройстве удерживается нота, инициирующая запуск сэмпла.

7. Вы можете обозначить начальную и конечную точку цикла в пределах сэмпла, выбрав систему мер из списка Input format и настроив параметры Start, End и Length. Поскольку вы ранее создали выделенную область, вам не требуется настраивать эти параметры.

Рис. 13.4. Используйте диалоговое окно Edit Sample - Sound4, чтобы преобразовать ваш звуковой файл в циклический сэмпл

8. Введите обозначение ноты с помощью расположенного сбоку счетчика в поле параметра MIDI unity note of sample (C-l to G9).

Рис. 13.5. Когда в файл добавляются точки начала и конца цикла, он становится циклическим сэмплом

9. Укажите соответствующее значение с помощью расположенного сбоку от поля Fine tune (O.OOO to 99.999 cents) счетчика, если это, конечно же, требуется.

10. Введите значения параметров SMPTE format и SMPTE offset, если это требуется.

11. Нажмите на кнопку ОК. Ваш звуковой файл теперь снабжен точками начала и конца цикла, расположенными, соответственно, в начале и конце файла (рис. 13.5). Эти точки укажут вашему устройству воспроизведения сэмплов параметры цикла. В нашем случае сэмпл будет повторяться с начала до конца.

Поддерживающие сэмплы

Поддерживающие сэмплы, как и сэмплерные петли, могут воспроизводиться в бесконечном цикле, но в этом случае повторяется не весь сэмпл, а только его часть. Определение такого повторяющегося фрагмента несколько усложняет создание поддерживающих сэмплов. Однако нет причин беспокоиться. Данная процедура не так уж сложна, просто придется применить метод проб и ошибок. Чтобы создать поддерживающий сэмпл, сделайте следующее:

1. Выберите команду меню File -> New , чтобы открыть диалоговое окно New Window. В нашем случае мы попросим вас определить параметры частоты сэмплирования, разрядности и количества каналов как 44,100 Гц, 16 бит и Mono соответственно. Затем нажмите на кнопку ОК, чтобы создать новый звуковой файл.

2. Выберите команду меню Tools -> Synthesis -> FM, чтобы открыть диалоговое окно FM Synthesis. Выберите набор настроек FM Horn и отрегулируйте параметр Configuration таким образом, чтобы использовался только один оператор (это самая главная установка), затем нажмите на кнопку ОК . Полученный после этих действий результат показан на рис. 13.6. В нашем примере для обеспечения звуковых данных мы используем функцию FM Synthesis, но в принципе вы можете использовать все, что хотите: звук фортепиано, партию ударных инструментов или гитарный гриф — все, что имитирует звук реального музыкального инструмента и может непрерывно повторяться.

3. На этот раз вам необходимо выделить не все данные файла, а только ту его часть, которая будет использоваться в качестве поддерживающей петли. Именно эта часть сэмпла будет повторяться, пока вы нажимаете клавишу на вашей MIDI-клавиатуре. По этой причине нужно найти часть файла, при переходе от конца к началу которой не будет слышно никаких "швов". Чтобы определить такую область файла, вам придется поэкспериментировать, но в конце концов вы ее обязательно найдете. В нашем случае вам нужно создать выделенную область, похожую на ту, что изображена на рис. 13.7.

Рис. 13.6. Используйте функцию FM Synthesis, чтобы подготовить данные для создания поддерживающего сэмпла

Рис. 13.7. Используйте мышь, чтобы быстро создать выделенную область

4. Установите флажок Play looped, расположенную в нижней части окна данных, чтобы проверить, как звучит ваша выделенная область, при повторении в цикле. Результат неплох, но не идеален, не так ли? Это мы сейчас исправим.

Рис. 13.8. Установите флажок Play looped, чтобы проверить звучание данных в выделенной области

5. Выполните команду меню Special -> Create Sample Loop, чтобы открыть диалоговое окно Edit Sample - SoundS (рис. 13.9).

Рис. 13.9. Используйте диалоговое окно Edit Sample - Sounds, чтобы преобразовать выделенную область в петлю

6. Выберите переключатель Sustaining из группы Sample type.

7. Выберите переключатель Infinite loop. Поскольку мы имеем дело с готовой выделенной областью, значения параметров Start, End и Length уже должны быть установлены.

8. Введите обозначение ноты в поле параметра MIDI unity note of sample (C-l to G9).

9. Введите значение параметра Fine tune (0.000 to 99.999 cents), если это требуется.

10. Введите значения параметров SMPTE format и SMPTE offset, если это требуется.

11. Нажмите на кнопку ОК. Ваш звуковой файл теперь снабжен точками начала и конца цикла, расположенными, соответственно, в начале и в конце файла (рис. 13.10).

Рис. 13.10. Закройте диалоговое окно Edit Sample - Sounds, чтобы создать точки начала и конца цикла для вашей выделенной области

Если вы правильно обозначили выделенную область, то вам больше не потребуется ничего делать для создания поддерживающего сэмпла. Однако в большинстве случаев правильно расставить точки начала и конца цикла с первого захода не удается. Во время прослушивания выделенной области в предыдущем примере вы, наверное, услышали щелчки и сбои при переходе от конца к началу области при циклическом воспроизведении. Этот эффект присутствовал потому, что точки начала и конца цикла для этой выделенной области не были должным образом отрегулированы. Программа Sound Forge предоставляет специальный инструмент, предназначенный для точной настройки точек, называемый тюнером цикла (Loop tuner).

Тюнер цикла

Когда вы создаете цикл, ваша цель — сделать переход от конца к началу повторяемого фрагмента как можно более гладким. В идеале вы вообще не должны замечать, что такой переход имел место. Добиться этого с помощью простого корректирования границ выделенной области вряд ли возможно, поэтому инструмент, который называется тюнер цикла, сильно облегчит вашу задачу. Чтобы использовать тюнер цикла для точной настройки сэмпла из предыдущего примера, сделайте следующее:

1. Предположим, что файл с сэмплом, о котором шла речь в предыдущем примере, у вас открыт. Выберите команду меню View -> Loop Tuner, чтобы открыть тюнер цикла (рис. 13.11). Обратите внимание на появившуюся под диаграммой сигналов область окна данных. Это и есть тюнер цикла, который, в сущности, является лишь частью окна данных. Это значит, что каждое открытое в программе Sound Forge окно может быть снабжено своим собственным тюнером цикла.

Рис. 13.11. Тюнер цикла является частью окна данных

2. Взгляните на тюнер цикла. Как и окно данных, он показывает форму волны ваших данных, но делает это по-особому. Вертикальная линия в центре тюнера цикла проходит через точку, в которой смыкаются конец цикла (слева от линии) и его начало (справа от линии) при циклическом воспроизведении. В этой точке сигнал должен пересекать нулевой уровень, чтобы переход был как можно более гладким. К тому же, во избежание эффекта "стука" диаграмма сигналов должна быть выше нулевой оси по одну сторону от точки перехода и ниже нулевой оси по другую сторону от этой точки. В нашем примере, как видите, по обе стороны от точки перехода диаграмма сигналов находится выше нулевой оси, поэтому мы и слышим "стук" при переходе (рис. 13.12).

Рис. 13.12. Недостаточно гладкий переход может послужить причиной появления эффекта "стука"

3. Чтобы исправить погрешности, вам нужно скорректировать положение точек начала и конца цикла. Чтобы сделать это с достаточной степенью точности, воспользуйтесь средствами управления, расположенными в нижней части тюнера цикла и позволяющими передвигать точку конца цикла в стороны до ближайшего пересечения с нулевым уровнем. Вы также можете перемещать точку конца цикла по диаграмме сигналов на единицу каждый раз, пользуясь элементами управления точной настройки позиции. Точка начала цикла корректируется таким же способом (рис. 13.13). В нашем случае вам необходимо переместить точку конца цикла на позицию 27,861, а точку начала цикла — на позицию 14,432.

Рис. 13.13. Используйте элементы управления точной настройки позиции, чтобы окончательно отрегулировать точки начала и конца цикла

4. Используйте панель управления воспроизведением в нижней части тюнера цикла, чтобы проверить звучание перехода после проделанных корректировок. Нажмите на кнопку Play pre-loop, чтобы воспроизвести фрагмент сэмпла, предшествующий переходу, на кнопку Play post-loop, чтобы воспроизвести фрагмент сэмпла, следующий за переходом, и на кнопку Play loop, чтобы воспроизвести переход. Затем снова нажмите на кнопку Play loop, чтобы остановить воспроизведение (рис. 13.14).

5. После этого переход должен быть незаметен. Чтобы зафиксировать точки перехода, нажмите на кнопку Lock loop length.

Теперь у вас есть поддерживающий сэмпл с замечательным переходом.

Рис. 13.14. Используйте панель управления воспроизведением, чтобы проверить звучание перехода

Поддерживающий сэмпл с завершающим фрагментом

Ранее мы упоминали о том, что существуют три вида сэмплов. Это действительно так, но существует еще одна разновидность поддерживающих сэмплов. Она позволяет задать два фрагмента — повторяющийся и завершающий. Процедура создания такого сэмпла отличается несколькими дополнительными действиями:

1. Откройте существующий звуковой файл или создайте новый.

2. Выделите область данных, которая послужит повторяющимся фрагментом.

3. Выполните команду меню Special -> Create Sample Loop, чтобы открыть диалоговое окно Edit Sample - SoundS (рис. 13.15).

4. Выберите переключатель Sustaining with Release из группы Sample type.

5. Выберите переключатель Sustaining из группы Loop to edit.

Рис. 13.15. Воспользуйтесь диалоговым окном Edit Sample - Sounds, чтобы создать поддерживающий сэмпл с завершающим фрагментом

6. Выберите переключатель Loop count (I to 999) и введите число повторений основного фрагмента.

7. Установите значения параметров MIDI unity note of sample (C-l to G9), Fine tune (0.000 to 99.999 cents) и SMPTE format/offset.

8. Нажмите на кнопку ОК.

9. Выделите область данных, которая послужит завершающим фрагментом (рис. 13.16).

10. Выполните команду меню Special -> Edit Sample, чтобы открыть диалоговое окно Edit Sample - SoundS.

11. Включите переключатель Release из группы Loop to edit.

12. Включите переключатель Loop count (1 to 99) и укажите количество повторений завершающего фрагмента.

13. Нажмите на кнопку Selection, чтобы открыть диалоговое окно Set Selection. Затем выберите набор настроек Current Selection и нажмите на кнопку ОК.

14. Нажмите на кнопку ОК в диалоговом окне Edit Sample - SoundS.

Теперь у вас есть сэмпл, содержащий два фрагмента. При воспроизведении фрагмента сначала будут проигрываться данные перед первым циклом. После этого первый цикл будет повторен столько раз, сколько вы указали. Далее будут воспроизведены данные между первым и вторым циклами, затем второй цикл будет повторен указанное количество раз. В самом конце будет воспроизведена последняя часть сэмпла.

Рис. 13.16. Создайте еще одну выделенную область, чтобы обозначить завершающий фрагмент


Сохранение и передача сэмплов

Закончив создание и редактирование сэмпла, вы должны его сохранить. Обязательно сохраните его в формате WAV и выберите пункт Save Regions and Playlist in .WAV/.AVI files параметра Rgns/Playlist. Если вы сделаете по-другому, информация о точках начала и конца цикла будет потеряна.

Передача сэмпла

Если у вас есть внешнее устройство воспроизведения сэмплов, вы можете передать ваш новый сэмпл этому устройству, используя функцию Sampler программы Sound Forge. Чтобы передать ваш сэмпл такому устройству, проделайте следующее:

1. Убедитесь, что файл с вашим сэмплом открыт, затем выберите пункт меню Tools -> Sampler, чтобы открыть диалоговое окно Sampler - Sounds (рис. 13.17).

2. Установите значение параметра Logical send/receive sample number (0 to 16,383). Это должен быть номер, который ваше устройство воспроизведения сэмплов использует как ссылку на местоположение сэмпла. Подробности вы можете найти в документации к вашему устройству.

Рис. 13.17. Используйте функцию Sampler, чтобы передать ваш сэмпл внешнему устройству воспроизведения сэмплов

3. Нажмите кнопку Configure, чтобы открыть диалоговое окно Sampler Configuration - SoundS (рис. 13.18).

Рис. 13.18. Используйте диалоговое окно Sampler Configuration - Sounds, чтобы сообщить программе Sound Forge тип вашего устройства воспроизведения сэмплов

4. Выберите необходимый вариант из раскрывающегося списка Sampler model. Если ваше устройство указано в этом списке, выберите его название и нажмите кнопку ОК . В противном случае выберите пункт SMDI or SDS capable sampler из того же списка.

5. Если ваше устройство подсоединено к компьютеру с помощью MIDI-интерфейса, активизируйте переключатель MIDI. В противном случае выберите переключатель SCSI.

6. Из списка MIDI Out выберите порт вывода MIDI, к которому подключено ваше устройство.

Дальнейшие ваши действия зависят от того, к какому порту ввода подключено ваше устройство. Если ваше устройство подключено к порту ввода MIDI, осуществите следующие действия:

1. Из списка MIDI In выберите порт ввода MIDI.

2. Для параметра MIDI channel укажите канал, на который настроено ваше устройство.

3. Установите флажок Open loop, если ваше устройство не использует подтверждение установления связи. Подробности вы можете найти в документации к вашему устройству.

4. Если ваше устройство посылает запрос перед тем, как ему будет можно передавать сэмплы, установите флажок Wait for request when sending samples. Подробности вы можете найти в документации к вашему устройству.

Если же ваше устройство подключено к компьютеру посредством SCSI-интерфейса, выполните следующие действия:

1. Установите переключатель SCSI.

2. Выберите схему SCSI-соединения вашего устройства к компьютеру из списка Sample bias.

3. Нажмите на кнопку ОК.

4. Нажмите на кнопку Send Sample.

5. Нажмите на кнопку Close.

Получение сэмплов

Вы можете не только передавать сэмплы внешнему устройству, но и получать их от внешнего устройства. Это осуществляется почти так же, как и передача сэмплов, за исключением некоторых моментов. Если вы выбрали в диалоговом окне Sampler Configuration - SoundS переключатель MIDI, а ваше устройство должно получить запрос для того, чтобы вы могли получить от него сэмпл, установите флажок Send request when retrieving samples. И еще — в диалоговом окне Sampler - SoundS нажмите на кнопку Get Sample вместо Send Sample. Учтите — полученный сэмпл заменяет собой содержание активного окна данных.

Совет

Чтобы получить более подробную информацию о создании сэмплов, а также о том, как создавать сэмплы специально для программы ACID компании Sonic Foundry, прочитайте приложение 1.


Глава 2. Начинаем работу с Sound Forge
  • Начинаем работу с Sound Forge
  • Какую версию Sound Forge вы используете?
  • Получите последнее обновление продукта
  • Беглое знакомство с программой Sound Forge
    • Аудиофайлы
    • Рабочее пространство
    • Окно данных
    • Меню
    • Диалоговое окно Record
    • Спектральный анализ
  • Различия между программами Sound Forge и Sound Forge XP Studio
  • Настройка вашей системы для повышения производительности
    • Процессор
    • Оперативная память
    • Виртуальная память
    • Жесткий диск
    • Видеоадаптер
    • Сетевая карта
    • Звуковая карта
    • Настройка аппаратного профиля Sound Forge
  • Где получить справку?


Начинаем работу с Sound Forge

Теперь, когда у вас уже есть общее представление о технологиях MIDI и цифрового звука, понять функциональность Sound Forge будет несложно. Вот на какие вопросы вы найдете ответы в этой главе:

  • как получить последние обновления продукта;
  • почему стоит зарегистрировать ваше программное обеспечение; ,
  • основные возможности Sound Forge;
  • в чем различие между Sound Forge и Sound Forge XP;
  • какие настройки нужно выполнить на вашем компьютере, чтобы повысить его производительность;
  • где получить помощь в случае возникновения проблем.

Какую версию Sound Forge вы используете?

Большая часть материала этой книги относится к Sound Forge версии 5.0. Если у вас установлена более ранняя версия программы, в ваших же интересах обновить ее, особенно если вы используете версию 3.0 или более раннюю. С тех пор в программу были внесены значительные изменения и усовершенствования. Пятая версия содержит улучшения и новые возможности. Программные расширения (plug-ins) Spectrum Analysis и Acoustic Mirror, которые раньше поставлялись отдельно, теперь входят в поставку продукта. Саму функцию Acoustic Mirror имеет смысл обновить.

Конечно, даже если у вас установлена версия 5.0 программы Sound Forge, это необязательно значит, что у вас последняя версия. Компания Sonic Foundry постоянно вносит в программу исправления и усовершенствования. Проблемы, которые появлялись у вас при работе с программой, могут исчезнуть после обновления. Чтобы точно выяснить, какую версию вы используете, запустите Sound Forge и выберите в меню Help пункт About Sound Forge. Появится диалоговое окно, подобное показанному на рис. 2.1, где вы найдете номер версии. После этого проверьте, не появилось ли более свежее обновление.

Рис. 2.1. Диалоговое окно About Sonic Foundry Sound Forge показывает номер текущей версии программы

Получите последнее обновление продукта

Хотя было бы приятно получать обновления продукта автоматически, большинство компаний (за исключением разве что Microsoft), не может позволить себе рассылать своим пользователям компакт-диски каждый раз, когда появляется новое обновление. Это одна из причин, по которым Интернет получил такую популярность. Иногда решением ваших проблем может оказаться загрузка обновления. На Web-сервере компании Sonic Foundry есть раздел, где вы можете найти свежие обновления всех продуктов компании. Для получения обновления выполните следующую последовательность действий:

1. Подключитесь к Интернету, запустите ваш Web-браузер и введите следующий адрес: http://www.sonicfoundry.com/download/ . Вы попадете на страницу Sonic Foundry Downloads, показанную на рис. 2.2.

Рис. 2.2. Вы можете загрузить обновления со страницы Sonic Foundry Downloads

2. Выберите из списка возможностей Updates.

3. Из списка имеющихся обновлений выберите интересующий вас продукт.

4. Щелкните на соответствующей ссылке для загрузки. На появившейся странице введите регистрационный номер вашего продукта. После этого вы попадете на последнюю страницу, откуда сможете загрузить обновление.

5. Создайте на компьютере временный каталог и загрузите обновление в этот каталог.

6. Запустите файл и программа будет обновлена. Вот и все.

Замечание

Вам кажется, что вы нашли ошибку в программе? Тот факт, что продукт выпущен в продажу, не означает, что он идеален. Улучшения вносятся постоянно. Вот почему появляются обновления. Если вы постоянно сталкиваетесь с проблемой при работе с программой Sonic Foundry и можете воспроизвести проблему, выполнив несколько определенных шагов, это может означать, что вы нашли ошибку в программе. Попросите других пользователей воспроизвести проблему, выполнив ту же последовательность действий на их компьютерах. Если у них возникает та же проблема, напишите письмо в компанию Sonic Foundry, заполнив форму на следующей Web-странице: http://www.sonicfoundry.com/support/supportmail.asp , чтобы разработчики узнали об этой проблеме. Они могут уже знать о данной проблеме и работать над ее исправлением. Если же об этой ошибке они узнают впервые, то, хоть это не принесет вам славы, вы облегчите жизнь другим пользователям программы.


Беглое знакомство с программой Sound Forge

Поскольку Sound Forge является очень мощным приложением, вы можете его использовать для решения различных задач. В число таких задач входят редактирование и мастеринг звука, разработка звуковых эффектов и сэмплерных петель, подготовка компакт-дисков, создание аудиофайлов для Интернета и даже завершающий этап создания фильмов и видеоклипов. Программа Sound Forge имеет несколько функций для выполнения этих и многих других задач. В сочетании с вашим любимым программным секвенсором Sound Forge позволяет создавать такие же записи, какие создаются в профессиональных студиях. Используя Sound Forge, вы обнаружите в его инструментах исключительную гибкость и функциональность.

Аудиофайлы

Поскольку программа Sound Forge является приложением для редактирования звука, у нее нет собственного формата для хранения данных, поскольку звуковые данные можно хранить в различных форматах. Двумя наиболее популярными форматами являются WAV (на платформе Windows) и AIFF (на платформе Macintosh). Эти форматы так популярны, что стали стандартными, однако существуют и другие форматы файлов, имеющие свои недостатки и преимущества по сравнению с WAV и AIFF. В число таких форматов входят МРЗ, Window Media и RealAudio. Программа Sound Forge может открывать и сохранять файлы более чем тринадцати различных форматов, это не считая форматов АСМ. О форматах файлов мы поговорим в главе 4.

Рабочее пространство

Для работы с аудиофайлами в программе Sound Forge имеется рабочее пространство (Workspace). Это главная часть интерфейса программы, в которой находится окно данных (о котором мы сейчас поговорим) для каждого из открытых аудиофайлов. В программе Sound Forge можно иметь одновременно несколько открытых аудиофайлов (рис. 2.3).

Рис. 2.3. Рабочее пространство является тем местом, где вы будете работать с аудиофайлами в программе Sound Forge

В рабочем пространстве также находятся индикаторы воспроизведения, на которых вы увидите выходной уровень проигрываемых аудиоданньгх. Вы можете сохранить расположение элементов рабочего пространства в специальные файлы рабочего пространства и в последующем загрузить их, что является быстрым и простым способом настройки Sound Forge для каждого из ваших проектов. О рабочем пространстве мы поговорим в главе 3.

Окно данных

Когда вы открываете аудиофайл в Sound Forge, его данные выводятся в окне данных (Data Window). Если открыто сразу несколько файлов, для каждого из них имеется свое окно данных. Когда вы работаете с аудиофайлом, вы можете видеть изображение звуковых волн, представляющее данные из этого файла, как видно на рис. 2.4.

Окно данных позволяет вам не только видеть данные аудиофайла, но и редактировать и обрабатывать их. Кроме того, вы можете добавлять эффекты. На протяжении всей книги, мы будем рассказывать вам об окне данных и работе с ним.

Рис. 2.4. Каждый аудиофайл, открытый в Sound Forge, выводится в своем окне данных

Меню

Почти ко всем функциям редактирования, обработки и добавления эффектов можно получить доступ через меню. Чаще всего вам придется пользоваться меню Special, Process, Effects и Tools (рис. 2.5).

Рис. 2.5. Большая часть функций Sound Forge доступна через меню

Каждое меню содержит свою группу функций. Меню Special содержит большую часть функций навигации, записи и воспроизведения. Меню Process содержит функции обработки звука, например эквалайзер и управление амплитудой. В меню Effects, как очевидно из названия, находятся различные эффекты. Наконец, меню Tools предоставляет дополнительные возможности, которые нельзя отнести к вышеперечисленным категориям, например спектральный анализ (Spectrum Analysis). О возможностях обработки звука мы поговорим в главах 8, 9 и 10.

Диалоговое окно Record

Кроме открытия и сохранения существующих звуковых файлов, вы может также использовать программу Sound Forge для создания и записи новых файлов. Для записи звука предназначено диалоговое окно Record (рис. 2.6).

Рис. 2.6. Вы можете записывать новые аудиофайлы в Sound Forge с помощью диалогового окна Record

Программа Sound Forge позволяет записывать звук с разрядностью до 64 и множеством частот сэмплирования от 8 Гц до 192 кГц. Диалоговое окно Record имеет свой набор индикаторов уровня входного сигнала и даже обеспечивает синхронизацию MTC/SMPTE. О записи звука с помощью программы Sound Forge мы будем говорить в главе 6.

Спектральный анализ

Одной из мощнейших функций, имеющихся в Sound Forge, является спектральный анализ (Spectrum Analysis). Хотя функция спектрального анализа может показаться сложной, на самом деле использовать ее несложно. Имеет смысл потратить некоторое время на то, чтобы понять, как она работает. Коротко говоря, функция спектрального анализа позволяет вам исследовать ваши аудиоданные с помощью специальных диаграмм, которые выводят амплитуду и частоты, обнаруженные в данных. Это позволяет обрабатывать данные и реально "видеть" эффект обработки. Это весьма мощная функция, так что о ней мы поговорим в главе 10.

Различия между программами Sound Forge и Sound Forge XP Studio

Не каждому нужна вся мощь такого профессионального приложения для редактирования цифрового звука, как Sound Forge. Обычным пользователям, а тем более новичкам, для которых музыка — только хобби, достаточно будет другого продукта из того же семейства: Sound Forge XP Studio. По существу, Sound Forge XP Studio представляет собой просто урезанную версию программы Sound Forge. Она обладает той же основной функциональностью, но в ней отсутствуют некоторые продвинутые возможности.

Программа Sound Forge XP Studio предназначена для тех пользователей, которым редактирование звука необходимо на любительском или полупрофессиональном уровне. Основные возможности редактирования и обработки звука в ней достаточно мощные, но отсутствуют такие функции, как поддержка подключаемых модулей DirectX и предварительный просмотр обработки. Количество функций обработки в ней ограничено, например имеется только восемь эффектов (против семнадцати в Sound Forge) и есть только графическая эквализация (в отличие от графической, параметрической и параграфической в Sound Forge).

Здесь мы только коснулись некоторых функций Sound Forge XP Studio в сравнении с Sound Forge. Для подробного сравнения компания Sonic Foundry выпустила полный список функций, имеющихся в каждом из этих продуктов. Вы можете найти его на Web-сервере компании Sonic Foundry http://www.sonicfoundry.com .

Одной из мощнейших функций, имеющихся в Sound Forge, является спектральный анализ (Spectrum Analysis). Хотя функция спектрального анализа может показаться сложной, на самом деле использовать ее несложно. Имеет смысл потратить некоторое время на то, чтобы понять, как она работает. Коротко говоря, функция спектрального анализа позволяет вам исследовать ваши аудиоданные с помощью специальных диаграмм, которые выводят амплитуду и частоты, обнаруженные в данных. Это позволяет обрабатывать данные и реально "видеть" эффект обработки. Это весьма мощная функция, так что о ней мы поговорим в главе 10.


Настройка вашей системы для повышения производительности

Компания Sonic Foundry указывает в качестве минимальных требований для работы программы Sound Forge компьютер с процессором Pentium с частотой 90 МГц и по крайней мере 16 Мбайт оперативной памяти. Конечно, у вас должна быть также звуковая карта, которая поддерживается операционной системой Windows. Если ваш компьютер удовлетворяет этим требованиям, все, что вам потребуется — установить программу на компьютер. Если же вы хотите добиться максимальной производительности при работе с Sound Forge, вам нужно произвести некоторую настройку компьютера.

Процессор

Из процессора выжать очень много вам вряд ли удастся, если не заменить его на более новый и быстрый или вообще не купить новый компьютер. Чем новее и быстрее ваш центральный процессор, тем выше будет производительность компьютера и программы Sound Forge. По производительности процессоры идут в следующем порядке: Pentium, Pentium MMX, Pentium Pro, Pentium II, Celeron, Pentium III, Pentium IV (на момент перевода книги). Можно также поставить процессор компании AMD, однако в этом случае есть некоторая вероятность несовместимости компьютера и звуковой карты. Некоторые звуковые карты не работают на таких процессорах, так что обратите на это внимание перед покупкой. Все сводится к тому, что программа Sound Forge обрабатывает звук значительно быстрее, чем самый мощный процессор, поэтому наличие быстрого процессора позволяет уменьшить период ожидания. Кроме того, в случае мощного процессора программа Sound Forge работает более ровно.

Если вы хотите проверить, как используется производительность вашего процессора при выполнении разных задач, в составе операционной системы Windows имеется программа System Monitor (Системный монитор). Чтобы использовать ее, выполните следующие шаги:

1. Если программа System Monitor не установлена, откройте Windows Control Panel (Панель управления). Сделайте двойной щелчок на значке Add/Remove Programs (Установка и удаление программ) и выберите вкладку Windows Setup (Установка Windows) в диалоговом окне Add/Remove Programs Properties (Свойства: Установка и удаление программ). Затем укажите в списке пункт Accessories (Служебные), щелкните на кнопке Details (Состав), выберите в появившемся списке элемент System Monitor (Системный монитор) и щелкните на кнопке ОК для закрытия диалогового окна. После этого операционная система Windows установит программу System Monitor.

2. Откройте System Monitor, щелкнув на кнопке Start (Пуск) и выбрав в меню Programs -> Accessories -> System Tools -> System Monitor

( Программы -> Стандартные -> Служебные -> Системный монитор) . Общий вид программы показан на рис. 2.7.

3. Выберите в меню этой программы Edit -> Add Item (Правка -» Добавить показатель). В появившемся диалоговом окне щелкните на элементе Кег-

nel (Ядро) списка Category (Категория). Затем щелкните на элементе Processor Usage (Использование процессора) в списке Item (Показатель) и нажмите на кнопку ОК.

4. В зависимости от текущих установок, вы увидите линейную диаграмму, гистограмму или числовое представление данных. Другое представление вы можете выбрать в меню View (Вид).

Рис. 2.7. Программа System Monitor позволяет оценить загрузку процессора

Теперь System Monitor будет непрерывно показывать изменения загрузки процессора.

Оперативная память

Вы, вероятно, уже знаете, что чем больше оперативной памяти установлено на компьютере, тем лучше. Это тем более верно для сложных приложений, каким является Sound Forge. Хотя компания Sonic Foundry и указывает в качестве минимальных требований 16 Мбайт оперативной памяти, лучше иметь по меньшей мере 64 Мбайт. Это позволяет значительно ускорить работу системы. При большем объеме оперативной памяти меньше вероятность того, что операционной системе Windows придется обращаться к виртуальной памяти.

Виртуальная память

Чтобы обмануть компьютер и заставить его думать, что установлено больше памяти, чем есть на самом деле, Windows использует часть жесткого диска в роли виртуальной памяти. Каждый раз при своем запуске Windows создает на жестком диске файл подкачки под названием win386.swp. Этот файл изменяет свой размер в зависимости от того, какие задачи выполняются на компьютере. Когда вы пытаетесь использовать больше памяти, чем установлено на компьютере, Windows сохраняет избыточные данные в файле подкачки. Например, если на компьютере установлено 32 Мбайт оперативной памяти, а вы запустили одновременно четыре различных программы, каждой из которых требуется 16 Мбайт, два из этих приложений, по идее, не могут быть запущены. Однако Windows просто использует виртуальную память для того, чтобы получить 32 Мбайт дополнительной памяти. Поскольку виртуальная память использует для хранения данных жесткий диск, скорость доступа к которому несравнимо ниже, чем к оперативной памяти, работа с файлом подкачки резко замедляет работу компьютера. Вот одна из причин, по которой компьютер с большим объемом оперативной памяти работает быстрее.

Жесткий диск

Скорость вашего жесткого диска является одним из важнейших факторов, влияющих на то, насколько быстро программа Sound Forge будет выполнять задачи редактирования больших звуковых файлов. В отношении производительности интерфейс SCSI лучше, чем IDE, но хороший диск с интерфейсом E-IDE может быть столь же хорош, как и диск SCSI. При выборе диска нужно обратить внимание на несколько параметров. Среднее время поиска (average seek time) должно быть как можно меньше, желательно, 9 мс или меньше. Скорость вращения (rotation speed) должна быть больше, наиболее распространенными скоростями сейчас являются 5400 и 7200 об./мин. Скорость передачи данных большого объема (sustained data transfer speed) тоже должна быть как можно больше, не меньше 5 Мбайт/сек. Другим важным обстоятельством является способ подключения карты контроллера жесткого диска внутри компьютера. Подключение через разъем PCI предпочтительнее, чем через разъем ISA.

Между прочим, с помощью программы System Monitor можно протестировать производительность жесткого диска подобно тому, как вы можете протестировать процессор (см. разд. "Процессор " выше в этой главе).

Не говоря об обновлении жесткого диска, стоит сказать, что есть прием, позволяющий несколько ускорить работу существующего диска. Это установка прямого доступа к памяти (DMA) для контроллера жесткого диска. При этом жесткий диск обращается к памяти компьютера напрямую, без их обработки данных процессором. Если ваш жесткий диск поддерживает прямой доступ к памяти, вы можете активизировать его следующим образом:

1. Откройте Windows Control Panel (Панель управления). Сделайте двойной щелчок на значке System (Система), затем выберите вкладку Device Manager (Устройства) в диалоговом окне System Properties (Свойства: Система).

2. В списке устройств разверните группу Disk Drives (Дисковые накопители) и выберите ваш жесткий диск. Его название может выглядеть как-то подобно "Generic IDE Disk".

3. Щелкните на кнопке Properties (Свойства), затем выберите вкладку Settings (Настройки) в диалоговом окне свойств диска. Диалоговое окно должно выглядеть примерно так, как показано на рис. 2.8.

Рис. 2.8 . В этом диалоговом окне свойств диска показаны настройки жесткого диска

4. Установите флажок DMA в группе Options (Параметры) и щелкните на кнопке ОК для закрытия диалогового окна.

После перезапуска Windows ваш жесткий диск будет иметь непосредственный доступ к памяти компьютера, что может дать заметное увеличение скорости.

Видеоадаптер

Верите вы или нет, но видеоадаптер может влиять на производительность компьютера. Во-первых, аппаратное ускорение видеокарты может вызвать проблемы с воспроизведением звука. Если у вас видеокарта на шине PCI, a звук иногда прерывается щелчками и другими неожиданными звуками, это может означать, что установлено слишком высокое аппаратное ускорение видеокарты. Попробуйте протащить окно программы по экрану во время воспроизведения цифрового звукового файла. Влияет ли это действие на проигрывание звука? Если да, то для устранения проблемы попробуйте уменьшить или отключить аппаратное ускорение видеокарты. Для этого выполните следующую последовательность действий:

1. Откройте Windows Control Panel (Панель управления). Сделайте двойной щелчок на значке System (Система).

2. В диалоговом окне System Properties (Свойства: Система) выберите вкладку Performance (Быстродействие). Затем щелкните на кнопке Graphics (Графика) в группе Advanced Settings (Дополнительные параметры).

3. В диалоговом окне Advanced Graphics Settings (Дополнительная настройка видеоадаптера) переместите ползунок Hardware acceleration (Аппаратное ускорение) влево для уменьшения или полного отключения аппаратного ускорения видеокарты. Диалоговое окно должно выглядеть примерно так, как показано на рис. 2.9.

Рис. 2.9. Степень аппаратного ускорения видеокарты устанавливается в диалоговом окне Advanced Graphics Settings

4. Вы можете полностью отключить аппаратное ускорение, а можете и не делать этого. Наилучшее значение можно подобрать экспериментальным путем. После того как вы найдете оптимальное положение ползунка, щелкните на кнопке ОК для закрытия этого диалогового окна.

Новые настройки войдут в силу после перезагрузки Windows. Если у вас видеокарта на новейшей шине AGP, вам не придется беспокоиться о проблемах, связанных с аппаратным ускорением. Такие видеокарты получают доступ к оперативной памяти напрямую, не взаимодействуя с шиной PCI, поэтому обычно не вызывают вышеописанных проблем.

Другими настройками экрана, способными повлиять на производительность системы, являются хранители экрана, разрешение монитора и глубина цвета. При выполнении задач, требующих большой загрузки процессора, лучше отключить хранитель экрана. Даже когда он ничего не выводит на экран, он все равно в фоновом режиме отслеживает активность системы и тем самым дополнительно загружает процессор. Кроме того, некоторые хранители экрана не знают, что делает компьютер в данный момент времени, и активизируются в самой середине процесса записи. Чтобы отключить хранитель экрана, выполните следующие действия:

1. Щелкните правой кнопкой мыши где-нибудь на рабочем столе и выберите из контекстного меню пункт Properties (Свойства).

2. Откройте вкладку Screen Saver (Заставка) диалогового окна Display Properties (Свойства: Экран). Диалоговое окно должно выглядеть примерно так, как показано на рис. 2.10.

Рис. 2.10. В диалоговом окне Display Properties вы можете настроить многие параметры Windows, включая хранители экрана

3. Выберите элемент (None) (Нет) в раскрывающемся списке в группе Screen Saver (Заставка) и щелкните на кнопке ОК.

Разрешение экрана и глубина цвета влияют на то, насколько точно ваш монитор показывает графику. Большая глубина цвета означает, что выводится больше цветов, а более высокое разрешение приводит к тому, что изображение будет более резким. Но чем выше разрешение и глубина цвета, тем больше работы должен выполнить компьютер. Увеличение значений этих параметров может заметно замедлить работу компьютера, особенно если на нем установлен старый процессор. Лучшим выбором является разрешение 800 х 600 и количество цветов, равное 256. Обычно более высокие значения и не нужны, но вы можете поэкспериментировать, как высокие значения влияют на производительность компьютера. При этом уменьшение глубины цвета дает больше пользы, чем уменьшение разрешения.

Замечание

Хотя программа Sound Forge может работать при любой глубине цвета, она лучше выглядит при 16-битном цвете. Поэтому, если ваш компьютер поддерживает это разрешение, попробуйте установить его.

Рис. 2.11. В диалоговом окне Display Properties

вы можете настроить многие параметры Windows, включая разрешение экрана и глубину цвета

Для того чтобы изменить глубину цвета и разрешение, выполните следующие действия:

1. Щелкните правой кнопкой мыши в любом месте рабочего стола и выберите из контекстного меню пункт Properties (Свойства).

2. Откройте вкладку Settings (Настройки) диалогового окна Display Properties (Свойства: Экран). Диалоговое окно должно выглядеть примерно так, как показано на рис. 2.11.

3. Выберите в раскрывающемся списке в группе Colors (Цветовые палитры) элемент 256 Colors (256 цветов). Затем перетащите ползунок в группе Screen area (Область экрана) влево, пока разрешение не достигнет значения 800 х 600. Затем щелкните на кнопке ОК.

После перезагрузки Windows ваш монитор будет работать с установленным разрешением и глубиной цвета. Привыкание к новым настройкам может занять некоторое время, если до этого вы постоянно работали при более высоких значениях, но это не смертельно. Зато вы заметите, насколько быстрее заработает Windows.

Сетевая карта

Если ваш компьютер подключен к сети, вы можете захотеть использовать для редактирования и записи звука другой компьютер или отключить сетевую карту на время работы с программой Sound Forge. Сетевая активность дает большую нагрузку на процессор и может сильно замедлить работу компьютера. Простейший способ отключить компьютер от сети — просто вытащить сетевой кабель из сетевой карты. Однако еще больше увеличить производительность можно, отключив сетевую карту следующим образом:

1. Откройте Windows Control Panel (Панель управления). Сделайте двойной щелчок на значке System (Система), затем скройте вкладку Device Manager (Устройства) диалогового окна System Properties (Свойства: Система).

2. В списке устройств разверните группу Network adapters (Сетевые платы) и выберите вашу сетевую карту. Ее название обычно отражает название продукта. Оно может выглядеть, например, как "EZ-Link USB Adapter".

3. Щелкните на кнопке Properties (Свойства) для открытия диалогового окна свойств сетевой платы. Диалоговое окно должно выглядеть примерно так, как показано на рис. 2.12.

4. Установите флажок Disable in this hardware profile (Отключено в данной конфигурации) в группе Device usage (Использование устройства) и щелкните на кнопке ОК для закрытия диалогового окна.

Windows отключит сетевую карту без необходимости перезагрузки. Теперь вы можете просто закрыть диалоговое окно System Properties (Свойства: Система).

Рис. 2.12. В этом диалоговом окне свойств сетевой карты показано состояние устройства

Звуковая карта

Что касается звуковых карт, то мы можем дать только один совет: производительность звуковой карты на шине PCI значительно выше, чем на шине ISA. Новейшие звуковые карты на шине PCI обычно имеют более совершенную звуковую схему, предназначенную для того, чтобы максимально разгрузить центральный процессор от работы по обработке звука. Также будет неплохо, если ваша карта будет поддерживать функции Direct Sound технологии DirectX компании Microsoft. Такой тип карты обеспечивает большую совместимость приложений и иногда большую производительность.

Еще одни важный момент: в том случае, если вы действительно хотите обеспечить наилучшее качество звука, приобретайте аудиоинтерфейс, а не звуковую карту. Разница в том, что аудиоинтерфейс поставляется с внешним корпусом, закрывающим схему и контакты. В результате аудиоинтерфейс не подвержен влиянию шумов, образующихся внутри компьютера. Обычная звуковая карта расположена очень близко к другим компьютерным схемам, дающим различные наводки. Конечно, аудиоинтерфейс стоит значительно дороже, так что решайте сами, нужно ли вам тратить лишние деньги.

Одним из самых распространенных читательских вопросов является следующий: "Звуковую карту какой марки лучше всего покупать?" На рынке есть столько различных звуковых карт, имеющих самые разные возможности, что дать однозначный ответ просто невозможно. Однако мы можем рассказать, на какие возможности следует обратить внимание, чтобы сделать осмысленный выбор.

Мы уже упоминали, что вам нужно искать предназначенную для персональных компьютеров звуковую карту, совместимую с технологией DirectX. Вам также нужно разобраться в типах разъемов, имеющихся в карте. Типичная звуковая карта имеет несколько различных входных и выходных гнезд, включая линейный вход и выход, микрофонный вход и выход на динамики. Линейный вход и выход предназначены для обмена сигналами с кассетным магнитофоном, радиоприемником, электронной клавиатурой и другими стандартными аудиоустройствами. Микрофоны генерируют очень слабый электрических сигнал, поэтому для них требуется отдельный вход, подключенный к внутреннему усилителю на звуковой карте. Динамики тоже требуют отдельного гнезда со встроенным усилителем для того, чтобы выдавать сигнал достаточной мощности. Некоторые карты высокого класса имеют гнезда для цифрового входа и выхода. Такие специальные разъемы позволяют подключать звуковую карту непосредственно к совместимым устройствам, например проигрывателям компакт-дисков и цифровых магнитофонов. Использование этих разъемов дает звук максимально возможного качества, поскольку не требуется преобразования звукового сигнала в аналоговую форму. Кроме того, надо понимать, что разъемы могут иметь разную форму. Дешевые звуковые карты обычно имеют одинаковые гнезда диаметром 1/8 дюйма, используемые для микрофонов на аудиоплеерах. Для обеспечения лучшего качества существуют гнезда диаметром 1/4 дюйма, разъемы RCA и XLR. Разъемы могут быть также сбалансированными или несбалансированными. Сбалансированные разъемы обеспечивают экранирование от радиопомех, в то время как несбалансированные разъемы такой защиты не дают.

Если вы хотите иметь возможность производить запись одновременно от нескольких источников звука, вам потребуется карта с несколькими аудио-разъемами. Большинство звуковых карт среднего класса смешивает все входящие сигналы в один стереосигнал, но карты высокого класса (которые, конечно же, стоят гораздо дороже) позволяют записывать звук от каждого подключенного устройства в отдельный стереоканал. Эта возможность очень полезна для студий звукозаписи, но нужна она не каждому. Вы также можете поискать полнодуплексную звуковую карту. Это означает, что карта может одновременно записывать звук и воспроизводить его, в отличие от полудуплексной карты, которая в каждый момент может выполнять только одну из этих задач.

Каждому хочется получить аудиосигнал высокого качества. В процессе записи частота сэмплирования (о которой мы говорили в главе I) играет ведущую роль в качестве записи. Чем выше частота сэмплирования, тем лучше звук. Частота сэмплирования для записи с качеством компакт-диска равна 44,1 кГц (44 100 сэмплов в секунду) и все имеющиеся в настоящее время в продаже звуковые карты поддерживают ее. Профессиональные карты могут поддерживать частоту сэмплирования 48 кГц и выше. Разрядность карты (которую мы тоже обсуждали в главе Г) также влияет на качество звука. Чем она выше, тем выше качество звука. Стандартом для записи с качеством компакт-диска является 16 бит, он поддерживается всеми звуковыми картами. Некоторые карты (в основном дорогие) поддерживают разрядность до 20, 22 и даже 24 бит.

Другими числовыми характеристиками, на которые вам нужно обратить внимание, являются отношение сигнала к шуму и частотная характеристика. Как и для вышеупомянутых характеристик, чем больше значение, тем лучше. Поскольку все электронные устройства генерируют шум, отношение сигнала к шуму звуковой карты показывает, во сколько раз сигнал сильнее, чем шум, производимый звуковой картой. Чем выше значение, тем тише карта. Хорошее значение отношения сигнала к шуму не ниже 90 дБ. Частотная характеристика представляет собой диапазон чисел, основанный на возможностях человеческого слуха. Частотная характеристика человеческого слуха составляет приблизительно от 20 Гц до 20 кГц. Хорошая звуковая карта должна охватывать по крайней мере этот диапазон, а лучше — более широкий.

Если вы хотите приобрести звуковую карту со встроенным синтезатором MIDI, существует несколько дополнительных возможностей, о которых вам нужно знать. На старых звуковых картах использовались синтезаторы, основанные на методе частотной модуляции (frequency modulation). К сожалению, этот метод недалеко ушел от тех звуков, которые издает стандартный встроенный динамик персонального компьютера. Хоть метод частотной модуляции хорошо работает со звуками органа или колокольчиков, со звуками других инструментов возникают проблемы. На сегодняшний день в звуковых картах используется другая технология, именуемая волновым синтезом (wavetable synthesis). Она позволяет создавать очень реалистичные звуки. Эта технология основана на том, что для воспроизведения звука используются заранее записанные звуки настоящих инструментов. Когда синтезатор получает сообщение MIDI Note On, вместо создания звука "с нуля" (как в случае метода частотной модуляции), он воспроизводит маленькую цифровую запись, в качестве которой может выступать какой угодно звук, от звука рояля до кваканья лягушек. Единственный недостаток волнового синтеза заключается в том, что большое количество сэмплов должно храниться в оперативной памяти или в ПЗУ. Достаточно упомянуть, что чем больше объем оперативной памяти или ПЗУ на звуковой карте, тем лучше.

Также нужно обратить внимание на степень контроля над воспроизведением сэмплов из волновых таблиц, которую дает карта. Все современные звуковые карты поддерживают стандарт General MIDI (GM), представляющий набор из 128 заранее определенных звуков, которые должны быть на любом совместимом с этим стандартом синтезаторе, и расположение в памяти (или номера программ MIDI) данных звуков. Это гарантирует, что если звуковая карта получит команду выполнить программу номер 37, будет воспроизведен звук электрической бас-гитары, а не звук саксофона. Однако, в отличие от профессиональных синтезаторов, GM не поддерживает никакого программирования параметров звука. Вот почему появились форматы GS и XG. Формат GS компании Roland расширяет стандарт GM путем предоставления дополнительных звуков и программного контроля над некоторыми параметрами синтезатора. Формат XG компании Yamaha идет еще дальше. Он требует наличия трех отдельных процессоров для реализации эффектов, предлагает более десятка программируемых параметров синтезатора (например, яркость звука) и более сотни наборов из 128 звуков каждый. Поэтому ищите карту, поддерживающую хотя бы один из форматов GS и XG.

Пользуясь этими рекомендациями и потратив некоторое время на исследование рынка, вы сможете приобрести карту, отвечающую вашим требованиям. Желаем вам удачи!

Настройка аппаратного профиля Sound Forge

Конечно, выполнение вышеупомянутых изменений на вашем компьютере каждый раз перед началом работы с программой Sound Forge и возвращение компьютера в прежнее состояние после работы с Sound Forge — занятие малоосмысленное. К счастью, операционная система Windows имеет удобную функцию, именуемую аппаратным профилем (hardware profile). Вы можете рассматривать аппаратный профиль как набор заранее заданных установок. С помощью аппаратных профилей вы можете сохранить несколько различных настроек Windows под одним именем, а в последующем вызывать эти настройки как единый набор. Например, вы можете создать один профиль для обычной работы, другой — для игр, третий — для редактирования и записи звука и т. д. Создание аппаратного профиля не представляет сложностей. Выполните следующие шаги:

1. Откройте Windows Control Panel (Панель управления). Сделайте двойной щелчок на значке System (Система), затем выберите вкладку Hardware Profiles (Профили оборудования) в диалоговом окне System Properties (Свойства: Система). Диалоговое окно должно выглядеть примерно так, как показано на рис. 2.13.

2. Скорее всего, в списке будет присутствовать единственный профиль по умолчанию, который называется "Original Configuration". В этом профиле хранятся текущие настройки системы. Щелкните на этом профиле.

3. Щелкните на кнопке Сору (Копировать) для создания копии исходного профиля "Original Configuration".

4. В диалоговом окне Copy Profile (Копирование профиля) введите в качестве имени нового профиля строку "Sound Forge Configuration". Затем щелкните на кнопке ОК для закрытия диалогового окна.

5. Перезагрузите компьютер. При запуске Windows предложит выбрать аппаратный профиль. Выберите профиль "Sound Forge Configuration".

6. Выполните те операции, которые мы обсуждали в предыдущих подразделах — настройку прямого доступа к памяти, видеоакселератора и т. п.

Рис. 2.13. Вкладка Hardware Profiles диалогового окна System Properties показывает различные конфигурации оборудования

Теперь при каждом запуске Windows вы сможете выбрать аппаратный профиль, необходимый именно для тех задач, которыми вы собираетесь заниматься в этом сеансе работы с компьютером. Единственная настройка из числа описанных, которая не сохраняется в аппаратном профиле, это экранная заставка. Вам придется менять ее каждый раз вручную. Впрочем, даже автор сам всегда оставляет заставку отключенной. Если нужно уйти от компьютера больше, чем на 15 минут, он просто выключает монитор.

Где получить справку?

Компания Sonic Foundry предлагает несколько способов получения справки в случае возникновения проблем при работе с программой Sound Forge. Двумя наиболее очевидными местами являются руководство пользователя и файл встроенной справки. При первых признаках появления проблем просмотрите имеющуюся информацию об их разрешении. Если вам не удается найти ответ в этих источниках, посетите Web-узел компании Sonic Foundry.

Страница Product Support Web-сервера компании Sonic Foundry ( http://wvw.somcfomdiy.com/) содержит массу полезной информации, в том числе список часто задаваемых вопросов и ответов на них и технические документы, в которых изложены подробности по многим вопросам. Сначала посмотрите эти документы. Если и здесь решения проблемы найти не удастся, обратитесь к форуму Sonic Foundry ( http://www.sonicfomdry.com/Forums/ ) , где вы сможете обменяться советами и прочей информацией с другими пользователями программы Sound Forge. Те проблемы, с которыми вы сталкиваетесь, могли раньше появиться у других пользователей, которые уже знают пути их решения. Кроме того, обратитесь к приложению 4 данной книги.


Глава 3. Настройка программы Sound Forge
  • Настройка программы Sound Forge
  • Общие настройки
    • Показ логотипа и ежедневных советов
    • Полноэкранный режим
    • Подтверждение закрытия программы
  • Связывание файлов определенных типов с Sound Forge
  • Рабочее пространство
    • Цвета
    • Панели инструментов
    • Изменение положения панелей инструментов
    • Изменение видимости панелей инструментов
    • Параметры размещения окон данных
    • Сохранение и загрузка настроек рабочего пространства
    • Клавиатурные сокращения
    • MIDI Triggers
  • Настройки MIDI
    • Настройка портов MIDI
    • Аудионастройки
    • Каталог для временных файлов
    • Настройки записи и воспроизведения
    • Параметры Interpolate и Position Bias
    • Буфер в оперативной памяти
    • Предварительная загрузка


Настройка программы Sound Forge

Хотя мы все можем быть пользователями программы Sound Forge, это вовсе не значит, что мы работаем с ней совершенно одинаково. У каждого есть свои приемы работы и предпочтения. К счастью, Sound Forge дает каждому возможность настроить программу по своему вкусу. В этой главе вы узнаете, как:

  • сделать Sound Forge программой по умолчанию для различных типов звуковых файлов;
  • настроить рабочее пространство программы, включая цвета, панели инструментов, расположение окон и другие общие настройки;
  • настроить параметры MIDI;
  • настроить параметры звука.

Общие настройки

Программа Sound Forge дает возможность настроить некоторые общие параметры, влияющие на всю работу программы, в том числе показ логотипа и ежедневных советов, полноэкранный режим, подтверждение закрытия программы и фоновую текстуру. Это не самые важные вещи, но все же они влияют на эффективность работы с программой.

Показ логотипа и ежедневных советов

Скорее всего, вы сразу захотите изменить поведение программы Sound Forge, автоматически выводящей логотип и диалоговое окно ежедневных советов при запуске программы. Вряд ли вам интересно каждый раз читать номер версии программы, а если вы хотите посмотреть советы, вы можете просто выбрать пункт меню Help -> Tip of the Day. После отключения этих функций Sound Forge будет загружаться немного быстрее. Для этого выполните следующие шаги:

1. Выберите пункт меню Options -> Preferences для открытия диалогового окна Preferences, в котором откройте вкладку General, как показано на рис. 3.1.

Рис. 3.1. В диалоговом окне Preferences вы можете настроить многие общие параметры

2. В списке General options сделайте двойной щелчок на флажке Show a Tip of the Day on startup, чтобы отключить эту функцию.

3. В том же списке сделайте двойной щелчок на флажке Show logo splash-screen on startup, чтобы отключить эту функцию.

4. Щелкните на кнопке ОК.

Теперь при запуске программы Sound Forge вам не нужно будет делать лишние щелчки мышью для того, чтобы начать работу с программой.

Замечание

В диалоговом окне Preferences есть множество других параметров, позволяющих изменить поведение программы Sound Forge. О них мы еще будем говорить в этой главе и на протяжении всей книги.

Полноэкранный режим

Если вы хотите полностью использовать пространство монитора, вы можете активизировать полноэкранный режим. В этом случае Sound Forge будет открывать свое рабочее пространство на всю ширину и высоту экрана. Это особенно полезно, если вы работаете с несколькими аудиофайлами одновременно.

Обычно вы можете активизировать полноэкранный режим, выбрав пункт меню View -> Full Screen, но делать это при каждом запуске программы довольно скучно. Поэтому, если вы предпочитаете всегда работать в Sound Forge в полноэкранном режиме, можно настроить автоматический переход в этот режим. Процедура примерно такая же, что и для показа логотипа и ежедневных советов. Просто выберите пункт меню Options -> Preferences для открытия диалогового окна Preferences и перейдите на вкладку General. Затем сделайте двойной щелчок на флажке Always open full-screen в списке параметров и щелкните на кнопке ОК. С этого момента программа Sound Forge будет открываться в полноэкранном режиме.

Подтверждение закрытия программы

Если вы склонны к случайным щелчкам мыши, можно настроить Sound Forge так, чтобы она запрашивала подтверждение вашего желания выйти из программы. В большинстве случаев эта возможность вам не потребуется. Даже если данная функция отключена, программа Sound Forge предупредит вас, если при попытке выйти из программы окажется, что какие-то данные не сохранены. Так что, в сущности, возможность вывода подтверждающего диалогового окна перед закрытием программы вам не нужна, поэтому она по умолчанию отключена. Но если вы захотите добавить некоторую степень защиты, активизируйте эту функцию, выбрав пункт меню Options -> Preferences для открытия диалогового окна Preferences, и перейдите на вкладку General. Затем сделайте двойной щелчок на флажке Confirm on close в списке параметров и щелкните на кнопке ОК. С этого момента программа Sound Forge будет запрашивать у вас подтверждения того, что вы хотите выйти из программы.

Связывание файлов определенных типов с Sound Forge

Программа Sound Forge поддерживает многие типы аудиофайлов. В их число входят файлы WAV, AIFF, МРЗ и т. д. (более подробное описание типов файлов вы найдете в главе 4). По умолчанию в процессе установки ни один из типов файлов не регистрируется как обрабатываемый по умолчанию программой Sound Forge. Это означает, что если вы сделаете двойной щелчок на значке аудиофайла в Windows Explorer (Проводнике Windows), файл будет открыт или воспроизведен не с помощью Sound Forge, а с помощью какой-либо другой программы.

Если вы хотите, чтобы в результате двойного щелчка на значках определенных типов аудиофайлов эти файлы открывались в Sound Forge, вы легко сможете связать эти типы файлов с программой Sound Forge с помощью функции Sound File Associations. Просто выполните следующие шаги:

1. В программе Sound Forge выберите пункт меню Options -> Preferences.

2. В диалоговом окне Preferences октройте вкладку File.

3. Щелкните на кнопке Associate Sound File Extension для открытия диалогового окна Sound File Associations, показанного на рис. 3.2.

Рис. 3.2. Диалоговое окно Sound File Associations

4. В списке File types to associate перечислены все типы зарегистрированных в операционной системе файлов, которые можно связать с программой Sound Forge. Первый столбец содержит трехсимвольные расширения файлов. Во втором столбце приведено описательное имя типа файлов. В третьем столбце указано название программы, с которой данный тип файлов связан в настоящий момент. Чтобы связать тип файла с программой Sound Forge, сделайте двойной щелчок на соответствующей этому типу файлов строке, чтобы был установлен флажок в левой части строки.

5. Для того чтобы связать все типы файлов, имеющиеся в списке, с Sound Forge, щелкните на кнопке Select All. Щелчок на кнопке Select None приводит к противоположному результату.

6. Закончив выбор типов файлов, нажмите на кнопку ОК.

7. Sound Forge выдаст предупреждение, содержащее слова "this may overwrite file associations used by other applications" (этим вы можете разорвать связь типов файлов с другими приложениями). Щелкните на кнопке Yes.

8. Щелкните на кнопке ОК для закрытия диалогового окна Preferences.

С этого момента после двойного щелчка в Windows Explorer (Проводнике Windows) на значке файла связанного типа он будет открыт в программе Sound Forge.


Рабочее пространство

Вы можете изменить не только общее поведение программы Sound Forge и связанные с ней типы файлов, но и внешний вид программы, а также ее реакцию на ваши команды. Настроив рабочее пространство Sound Forge, вы сможете увеличить эффективность программы и сделать работу с ней более удобной. В число настраиваемых параметров входят цвета, панели инструментов, компоновка окон данных и комбинации клавиш.

Цвета

Программа Sound Forge позволяет изменять цвета многих своих графических элементов. Однако нам не потребовалось вносить значительные изменения в цветовую палитру программы. Цвета по умолчанию вполне нас удовлетворяют. Однако ваш вкус может существенно отличаться. Для изменения набора цветов, используемых в Sound Forge, выполните следующие шаги:

1. В программе Sound Forge выберите пункт меню Options -> Preferences.

2. В диалоговом окне Preferences выберите вкладку Display, как показано на рис. 3.3.

3. В нижней части диалогового окна находится раскрывающийся список Color preference for, в котором перечислены все элементы интерфейса программы, цвета которых вы можете изменить. Чтобы изменить цвет элемента, выберите его из списка.

Совет

Чтобы прочитать описание каждого элемента интерфейса, приведенного в списке, щелкните на кнопке Help (Справка) (кнопка со знаком вопроса) в строке заголовка диалогового окна.

4. Выберите переключатель Custom, чтобы изменить вид выделенного в списке элемента интерфейса.

5. Чтобы создать собственный цвет для элемента интерфейса, измените значения параметров Red, Green и Blue путем перетаскивания ползунков или щелкая на кнопках со стрелками. Сочетание трех значений образует конечный цвет, показанный в маленьком прямоугольнике в нижнем левом углу диалогового окна.

6. Повторите шаги 3—5 для каждого элемента интерфейса, цвет которого вы хотите изменить.

Рис. 3.3. Вкладка Display диалогового окна Preferences

7. Закончив изменения, щелкните на кнопке ОК для закрытия диалогового окна Preferences.

Изменения цветовой палитры вступят в силу немедленно после закрытия диалогового окна Preferences. Чтобы восстановить значения по умолчанию просто повторите вышеперечисленные шаги, но для каждого элемента выберите переключатель Default вместо переключателя Custom.

Панели инструментов

Для увеличения производительности работы пользователя программа Sound Forge содержит несколько панелей инструментов для быстрого доступа к основным функциям. Они позволяют одним щелчком на кнопке панели инструментов добиться того же результата, что и при переходе по вложенным меню. Панели инструментов имеются для стандартных функций работы с файлами, элементов управления записью и воспроизведением и т. п. Программа Sound Forge позволяет изменять положение панелей инструментов. Кроме того, поскольку ненужные панели инструментов только занимают место на экране, вы можете скрыть любую панель, а при необходимости снова показать.

Изменение положения панелей инструментов

Как и в большинстве других программ, работающих под управлением операционной системы Windows, вы можете закреплять панели инструментов сверху, снизу и даже сбоку от рабочего пространства. А если вы перетащите панель инструментов в любое место в пределах рабочего пространства, она превратится в небольшое плавающее окно, как показано на рис. 3.4.

Рис. 3.4. Плавающие панели инструментов

Изменение видимости панелей инструментов

Чтобы изменить видимость панелей инструментов, вам нужно открыть вкладку Toolbars диалогового окна Preferences. Для этого выберите пункт меню Options -> Preferences, выберите вкладку Toolbars и вы увидите диалоговое окно, показанное на рис. 3.5.

Установив флажок слева от необходимого элемента, вы укажете, будет ли соответствующая панель инструментов показана на экране. Например, если вы снимете флажок слева от элемента Standard, панель инструментов Standard File Functions исчезнет с экрана.

Рис. 3.5. Вкладка Toolbars диалогового окна Preferences

Замечание

Единственное, что не очень удобно в настройке панелей инструментов, так это то, что их нельзя настроить каким-либо иным способом, например изменить набор кнопок в панели инструментов или создать собственную специальную панель инструментов для доступа к наиболее часто используемым функциям. Правда, обходной путь имеется (см. разд. "Клавиатурные сокращения" ниже в этой главе), который рассматривается нами в совете, в котором упоминается продукт QuicKeys.

Параметры размещения окон данных

Поскольку программа Sound Forge позволяет открыть одновременно несколько файлов, вам приходится иметь дело с несколькими окнами данных, о которых мы говорили в главе 2 и которые будут объяснены более подробно в следующих главах. Когда вы закрываете программу Sound Forge, размер и положение текущего окна данных, а также имя открытого в нем файла сохраняются автоматически. Эта возможность весьма удобна, поскольку при следующем запуске программы вы видите то же самое, что и перед последним выходом из нее. Однако, приобретя определенный опыт работы с Sound Forge, вы обнаружите, что в некоторых ситуациях удобнее иметь заранее настроенные параметры окна данных.

Например, предположим, что вы работаете с четырьмя различными аудиофайлами. Вы можете расположить их так, чтобы каждое окно аудиофайла занимало четверть рабочего пространства, как показано на рис. 3.6.

Рис. 3.6. Размер и положение текущего окна данных, а также имя открытого в нем файла автоматически сохраняются при закрытии программы Sound Forge

Что, если у вас есть несколько различных настроек, каждую из которых вы предпочитаете использовать на различных стадиях проекта? Вот здесь оказываются полезными файлы рабочего пространства. Используя файлы рабочего пространства, вы можете сохранять размеры, положение и имя открытого файла для каждого открытого в данный момент окна данных. Впоследствии вы сможете загрузить сохраненные файлы рабочего пространства, обеспечить простую и быструю организацию рабочего пространства. Для этого служат пункты меню File -> Workspace -> Open и File -> Workspace -> Save As .

Сохранение и загрузка настроек рабочего пространства

Сохранение и загрузка настроек рабочего пространства производятся следующим образом:

1. Откройте аудиофайл, с которым вы хотите работать.

2. Настройте размеры и положения окон данных на рабочем пространстве так, как вы хотите их сохранить.

3. Выберите пункт меню File -> Workspace -> Save As для открытия диалогового окна Save Workspace, как показано на рис. 3.7.

Рис. 3.7. Диалоговое окно Save Workspace

4. Введите имя нового файла рабочего пространства в поле File name.

Совет

Введя описательное имя для файла, вы упростите себе поиск нужной конфигурации при загрузке. Например, можно включить в имя файла имена всех открытых аудиофайлов и информацию об их расположении — Drums-Bass-Guitar-Piano-QuarterScreen.swf.

5. Щелкните на кнопке Save для сохранения нового файла рабочего пространства.

6. Чтобы загрузить ваш новый (или сохраненный ранее) файл, просто выберите пункт меню File -> Workspace -> Open для открытия диалогового окна Open Workspace.

7. Выберите из списка файл и щелкните на кнопке Open. Файл рабочего пространства будет загружен, а конфигурация окон данных изменится соответствующим образом.

Клавиатурные сокращения

Как и в большинстве программ для операционной системы Windows, в Sound Forge существуют комбинации клавиш для большинства функций. Подобно панелям инструментов, они дают вам быстрый доступ к возможностям программы. Вместо того чтобы последовательно щелкать на элементах меню, вы можете просто нажать комбинацию клавиш на клавиатуре компьютера. Многие из этих комбинаций клавиш приводятся в меню — справа от названия соответствующего пункта, (см. комбинации клавиш в меню File на рис. 3.8).

Рис. 3.8. Комбинации клавиш меню File

Чтобы увидеть полный список комбинаций клавиш в Sound Forge, выберите пункт меню Help -> Keyboard Shortcuts. Вы не можете ни изменить какие-либо из комбинаций клавиш по умолчанию, ни добавить ваши собственные. Однако существует частичное решение этой проблемы — функция под названием MIDI Triggers.

MIDI Triggers

Функция MIDI Triggers (Триггеры MIDI) дает возможность присваивать номеру функции внутри Sound Forge ноту MIDI и управляющие сообщения.

Замечание

Существует семь типов сообщений MIDI, каждый из которых реализует свой тип функциональности в языке MIDI. В число этих категорий входят: Notes, Key Aftertouch, Channel Aftertouch, Controllers, Program Changes, Pitch Bend и System Exclusive.

Категория Notes (ноты) относится к сообщениям MIDI Note On и MIDI Note Off. Когда вы нажимаете клавишу на клавиатуре MIDI, генерируется сообщение MIDI Note On. Когда вы отпускаете клавишу, генерируется сообщение MIDI Note Off.

На некоторых клавиатурах MIDI в дополнение к нажатию клавиши вы можете удерживать ее с различным давлением. Это давление называется Aftertouch. В зависимости от программы, заложенной в синтезатор, сообщение Aftertouch позволяет управлять громкостью и даже оттенком звука. Сообщение Aftertouch имеет варианты Key Aftertouch и Channel Aftertouch. Key Aftertouch обеспечивает различные уровни давления для каждой клавиши на клавиатуре. Channel Aftertouch реализует единый уровень давления для всей клавиатуры.

Существует широкий диапазон сообщений MIDI категории Controller. По существу, эти сообщения позволяют вам управлять различными аспектами вашего синтезатора или устройства MIDI. Некоторые управляющие сообщения позволяют контролировать уровень, а другие — позицию источников стереофонического звука. Их так много, что рассказать про все из них мы просто не имеем возможности, да это и не имеет смысла.

Категория Program Changes (именуемая также Patch Changes) позволяет выбирать звук из множества звуков, доступных в синтезаторе MIDI. Например, сообщение MIDI Program Change #1 может активизировать в синтезаторе звук рояля, а сообщение Program Change #10 — звук металлофона.

Сообщения категории Pitch Bend (изменение тона) позволяют временно изменить звучание инструмента MIDI. Многие клавиатуры MIDI имеют рычажок или колесико, позволяющее регулировать изменение тона. Вращение этого колесика заставляет инструмент посылать сообщения Pitch Bend (именуемые также Pitch Wheel).

Сообщения категории System Exclusive относятся к специальным данным MIDI, которые, в свою очередь, относятся исключительно к инструменту, посылающему или получающему сообщение. Например, производитель синтезатора MIDI может включить в него специальные функции, которыми невозможно управлять с помощью стандартных сообщений MIDI. Используя сообщения категории System Exclusive, производитель предоставляет вам доступ к этим специальным функциям, сохраняя при этом совместимость с языком MIDI.

Это означает, что вы можете использовать некоторые из клавиш на клавиатуре или устройстве MIDI для имитации комбинации клавиш. Например, вы можете присвоить вызов функции, которую в программе Sound Forge обычно вызывают через меню Special -> Transport -> Play, клавише Си первой октавы на клавиатуре MIDI. Тогда после нажатия клавиши Си первой октавы на клавиатуре MIDI программа Sound Forge воспроизведет аудио-данные из активного окна данных.

Совет

Если ваша музыкальная студия устроена так, что компьютер расположен не слишком близко к клавиатуре или контроллеру MIDI, использование функции триггеров MIDI является отличным способом доступа к программе Sound Forge. Например, если вы хотите иметь возможность запускать и останавливать воспроизведение звука в Sound Forge через клавиатуру MIDI, просто присвойте один из триггеров MIDI-функции с помощью команды Special -> Transport -> Play, а другой триггер MIDI-функции через команду Special -> Transport -> Stop.

Вы можете с легкостью создавать собственные триггеры в диалоговом окне MIDI Triggers. Это делается так:

1. Выберите пункт меню Options -> MIDI Triggers для открытия диалогового окна MIDI Triggers, показанного на рис. 3.9.

Рис. 3.9. Вы можете создавать триггеры MIDI в диалоговом окне MIDI Triggers

2. В столбце Event выделите функцию программы Sound Forge, для которой вы хотите создать триггер MIDI.

3. В группе Trigger включите либо переключатель Note, либо переключатель Controller для присвоения триггеру MIDI ноты MIDI или контроллера MIDI соответственно.

4. Если вы выбираете переключатель Note, выберите также значение для параметра Channel (I to 16), который присваивает триггеру MIDI конкретный канал MIDI. А затем выберите значение для параметра Note (C-1 to G6), который определяет ноту MIDI, используемую в качестве триггера MIDI.

5. Если вы выбираете переключатель Controller, параметру Channel также нужно присвоить значение, а затем выбрать значение для параметра Controller, который присваивает триггеру MIDI конкретный контроллер MIDI.

Совет

Вместо ввода значений для параметров Note и Controller с помощью клавиатуры компьютера, вы также можете использовать клавиатуру MIDI для тех же целей. Просто установите флажок Enable MIDI Input Sync/Trigger (for training triggers). После этого активизируйте клавишу или контроллер на клавиатуре MIDI. Значения параметров будут установлены автоматически.

6. После того как вы настроите все триггеры MIDI, сохраните текущую конфигурацию, щелкнув на кнопке Save As и введя название в диалоговом окне Save Preset.

Совет

Вы можете сохранять сколько угодно конфигураций триггеров MIDI. Это удобно, если вы хотите использовать с каждым устройством отдельную конфигурацию.

7. Закончив, щелкните на кнопке ОК.

После того как вы создадите (или измените) набор триггеров MIDI, вы заметите, что активизация определенных органов управления на вашем устройстве MIDI будет запускать соответствующие им функции в программе Sound Forge.

Совет

Если вы создаете триггеры MIDI, активизация связанных с ними нот или контроллеров на вашем устройстве MIDI вызовет связанные с ними функции в программе Sound Forge. Вряд ли вам это нужно в процессе исполнения, вам нужен быстрый способ включения и выключения триггеров MIDI. В столбце Event поля диалогового окна MIDI Triggers имеется функция, именуемая Enable/Disable Triggers. Вы можете присвоить этой функции триггер MIDI, который будет служить для нее выключателем. Это позволит вам включать и выключать триггеры MIDI без необходимости доступа к диалоговому окну MIDI Triggers каждый раз.

Возможно, вы обратили внимание на то, что мы упоминали триггеры MIDI только как частичное решение проблемы комбинаций клавиш. И после рассмотрения диалогового окна MIDI Triggers, вероятно, уже знаете, почему. В сущности, программа Sound Forge позволяет вам создавать триггеры MIDI только для части ее функций, а не для всех. Единственный способ обойти эту проблему — приобрести отдельную программу под названием QuicKeys.

Программа QuicKeys, разработанная компанией СЕ Software, представляет собой программу автоматизации персонального компьютера. Она позволяет записывать на компьютере последовательности нажатий клавиш и щелчки мышью. Затем вы можете присвоить этим записям любые комбинации клавиш, какие только пожелаете. Вы даже можете создавать свои собственные панели инструментов для использования внутри приложений, установленных на вашем компьютере. Это очень мощная программа. Вы можете приобрести QuicKeys (а также найти дополнительную информацию о продукте) на Web-сайте http://cesoft.com .


Настройки MIDI

Sound Forge представляет собой приложение для редактирования цифрового звука, так что, казалось бы, необходимости в функциональности MIDI нет. Однако поскольку программа Sound Forge содержит возможности записи и воспроизведения звука, разработчики компании Sonic Foundry включили в программу и функции синхронизации. Это означает, что вы можете использовать программу Sound Forge совместно с другим программным обеспечением (например, секвенсором MIDI) и другими устройствами (например, внешними ленточными магнитофонами). Мы еще поговорим о синхронизации и использовании Sound Forge с другими программами и устройствами в главах 6 и 12. Между тем, вам нужно сообщить программе Sound Forge, какие порты ввода и вывода MIDI на вашем интерфейсе MIDI вы хотите использовать.

Замечание

Как мы рассказывали в главе 1, интерфейс MIDI представляет собой устройство, подключенное к вашему компьютеру и позволяющее ему понимать язык MIDI. Каждый интерфейс MIDI имеет, по крайней мере, два разъема, именуемых портами MIDI (MIDI ports). Порт MIDI In используется для получения данных MIDI. Порт MIDI Out предназначен для отправки данных MIDI. Некоторые сложные интерфейсы MIDI имеют несколько пар портов MIDI. Например, мы используем Music Quest SPort/SE, имеющий восемь портов MIDI In и MIDI Out, что позволяет подключать к компьютеру несколько инструментов MIDI.

Настройка портов MIDI

Чтобы выяснить, какие порты MIDI программа Sound Forge использует в данный момент или назначить порты по своему усмотрению, выполните следующие действия:

1. Выберите пункт меню Options -> Preferences для открытия диалогового окна Preferences. Затем выберите вкладку MIDI/Sync, как показано на рис. З.10.

2. В раскрывающемся списке Output выберите порт вывода MIDI, который вы хотите использовать. Этот параметр указывает, какой порт вывода программа Sound Forge будет использовать для отправки данных MIDI.

3. В раскрывающемся списке Input выберите порт ввода MIDI, который вы хотите использовать. Этот параметр указывает, какой порт ввода программа Sound Forge будет использовать для получения данных MIDI.

4. Щелкните на кнопке ОК.

Теперь программа Sound Forge настроена на использование конкретных портов MIDI для отправки и получения данных MIDI.

Рис. 3.10. Вкладка MIDI/Sync диалогового окна Preferences

Рис. 3.11. Диалоговое окно Multimedia Properties

Замечание

В обоих раскрывающихся списках Input и Output имеется дополнительный элемент MIDI Mapper. Выбор этого варианта указывает, что программа Sound Forge должна использовать настройки MIDI Mapper операционной системы Windows. Получить доступ к этим настройкам можно, нажав кнопку Start (Пуск) и выбрав в меню Settings -> Control Panel (Настройки -> Панель управления), затем сделав двойной щелчок на значке Multimedia (Мультимедиа) и в появившемся диалоговом окне Multimedia Properties (Свойства: Мультимедиа), показанном на рис. 3.11, выбрав вкладку MIDI. Здесь вы можете указать операционной системе Windows, что сообщения MIDI должны направляться различным устройствам MIDI по отдельным каналам MIDI. Например, если у вас есть два различных устройства MIDI, подключенных к компьютеру, вы можете заставить Windows посылать любые данные MIDI, поступающие через каналы с номерами от 1 до 10, первому устройству, а любые данные MIDI, поступающие через каналы с номерами от 11 до 16, — второму устройству. Но для использования MIDI в программе Sound Forge вам не нужно применять вариант MIDI Mapper. Вместо этого выберите в столбце Event один из других портов MIDI.

Аудионастройки

Поскольку главным назначением программы Sound Forge является работа с цифровым звуком, аудионастроек в ней несколько больше, чем настроек MIDI. Большинство из них служат для достижения наилучшей производительности записи и воспроизведения в Sound Forge. Но есть и несколько других настроек, позволяющих отрегулировать дополнительные аспекты поведения программы Sound Forge, относящиеся к аудио, например, где сохранять аудиоданные и какие порты звуковой карты использовать для записи и воспроизведения.

Программа установки Sound Forge пытается определить возможные аудио-настройки, и хотя эти настройки работают хорошо, вы можете изменить их. Однако изменение настроек может оказаться непростым занятием и, к сожалению, твердых правил на этот счет нет. Тем не менее ниже мы приводим несколько рекомендаций.

Каталог для временных файлов

Когда вы открываете существующий аудиофайл (или создаете новый) в Sound Forge, программа создает временный файл для хранения аудиоданных в процессе редактирования файла. Если вы используете функции Undo/Redo и Clipboard (о которых мы поговорим в главе 7), то Sound Forge создает также несколько других временных файлов. Для хранения всех этих временных файлов программа Sound Forge использует единственный каталог на жестком диске. Изначально таким каталогом является тот каталог, в который установлена программа Sound Forge (по умолчанию C:\Program Files\Sound Forge), но вы можете изменить эту настройку.

В каких случаях вам может потребоваться изменить расположение каталога временных файлов? В процессе записи, воспроизведения и редактирования звука программа Sound Forge интенсивно использует жесткий диск. В сущности, это означает, что чем более быстрый жесткий диск у вас, тем быстрее работает Sound Forge. Поэтому, если у вас есть возможность использовать исключительно для хранения аудиоданных отдельный (и более мощный) диск, укажите его в настройках Sound Forge. Кроме того, в некоторых случаях (которые мы обсудим в главе 4) программа Sound Forge может сохранять файлы быстрее, если каталог временных файлов совпадает с местом хранения всех остальных аудиоданных.

Рис. 3.12. Вкладка Perform диалогового окна Preferences

Для изменения расположения каталога временных файлов выполните следующие шаги:

1. Создайте новый каталог для временных файлов с помощью программы Windows Explorer (Проводник Windows) на выбранном вами жестком диске. Для данного примера предположим, что у вас есть два жестких диска, один С:, а другой D:. На диске D: вы храните все свои аудиоданные, поэтому вам стоит создать новый каталог здесь. Вы можете назвать его, например, D:\Sound Forge Temp Files\.

2. В программе Sound Forge выберите пункт меню Option -> Preferences для открытия диалогового окна Preferences. Затем выберите вкладку Perform, как показано на рис. 3.12.

3. Щелкните на кнопке Browse для открытия диалогового окна Browse for Folder, показанного на рис. 3.13.

Рис. 3.13. Диалоговое окно Browse for Folder

4. Выберите из списка жесткий диск, на котором будет расположен новый каталог для временных файлов.

5. Выберите из списка новый каталог для временных файлов.

6. Дважды щелкните на кнопке ОК для закрытия обоих диалоговых окон.

С этого момента при открытии существующего файла или создании нового программа Sound Forge будет сохранять временные данные в указанном вами новом каталоге для временных файлов.

Настройки записи и воспроизведения

Так же как вы указывали программе Sound Forge, какие порты ввода и вывода использовать для MIDI, вы можете указать, какие порты ввода и вывода звуковой карты вы хотите использовать для записи и воспроизведения звука. Поскольку программа Sound Forge не позволяет осуществлять запись на несколько дорожек, вам нужно присвоить только один порт для записи и один для воспроизведения.

Вот как это сделать:

1. Выберите пункт меню Option -> Preferences для открытия диалогового окна Preferences. Затем выберите вкладку Wave, как показано на рис. 3.14.

Рис. 3.14. На вкладке Wave диалогового окна Preferences

2. В раскрывающемся списке Playback выберите порт вывода звуковой карты, который вы хотите использовать.

3. В раскрывающемся списке Record выберите порт ввода звуковой карты, который вы хотите использовать.

Замечание

Вы заметите, что в дополнение к портам ввода и вывода в обоих раскрывающихся списках Playback и Record имеется дополнительный элемент, именуемый Microsoft Sound Mapper. Выбирая этот вариант, вы говорите программе Sound Forge, что она должна использовать настройки звуковой карты, указанные в Microsoft Sound Mapper. Получить доступ к этим настройкам можно, нажав кнопку Start (Пуск) и выбрав в меню Settings -> Control Panel (Настройки -> Панель управления), затем сделав двойной щелчок на значке Multimedia (Мультимедиа) и в появившемся диалоговом окне Multimedia Properties (Свойства: Мультимедиа), показанном на рис. 3.11, выбрав вкладку Audio. Здесь вы можете указать операционной системе Windows, что она должна автематически управлять тем, какие порты ввода и вывода звуковой карты используются для аудиоданных.

Кроме того, Microsoft Sound Mapper предоставляет дополнительные возможности, например сжатие и преобразование аудиоданных. О сжатии аудиоданных мы поговорим в главе 4. Преобразование аудиоданных происходит в тех случаях, когда вы пытаетесь воспроизвести звуковой файл, имеющий разрядность или частоту сэмплирования, не поддерживаемые вашей звуковой картой. В подобных случаях Microsoft Sound Mapper может автоматически преобразовать данные так, чтобы программа Sound Forge могла воспроизводить аудиоданные через вашу звуковую карту. К сожалению, в зависимости от мощности вашего компьютера, эта обработка в режиме реального времени может оказаться слишком большой нагрузкой для компьютера, поэтому обычно лучше, чтобы программа Sound Forge посылала аудиоданные непосредственно на вход и выход вашей звуковой карты, а не использовала Microsoft Sound Mapper. Только убедитесь, что формат ваших аудиоданных поддерживается вашей звуковой картой и у вас нет необходимости в Microsoft Sound Mapper, если вы не используете сжатие (о котором, как мы уже упоминали, мы поговорим ниже).

4. Щелкните на кнопке ОК.

Параметры Interpolate и Position Bias

При настройке портов ввода и вывода звуковой карты вы могли заметить пару других параметров, связанных с раскрывающимися списками Playback и Recording на вкладке Wave диалогового окна Properties. Это параметры Interpolate и Position Bias.

В процессе записи и воспроизведения программа Sound Forge показывает счетчик, который демонстрирует (в терминах определенного измерения, например времени), в какой точке текущего аудиофайла данные записываются или воспроизводятся. Обычно значение для этого счетчика предоставляет программное обеспечение драйвера вашей звуковой карты, но, к сожалению, драйверы многих звуковых карт неточно сообщают эти значения. Это означает, что во время записи счетчики времени будут уходить или в процессе воспроизведения ваши маркеры (о которых мы поговорим в главе 5) будут неправильно позиционированы внутри ваших данных.

Для разрешения данной проблемы в программе Sound Forge имеются параметры Interpolate и Position Bias. Функция Interpolate позволяет программе Sound Forge самой предоставлять значения счетчика в процессе записи и воспроизведения, не опираясь на потенциально неточные данные от драйвера звуковой карты. По умолчанию функция Interpolate активизирована как для записи, так и для воспроизведения. Если вы хотите отключить эту функцию, выполните следующие действия:

1. Выберите пункт меню Options -> Preferences для открытия диалогового окна Preferences.

2. Откройте вкладку Wave (см. рис. 3.14).

3. Снимите флажок Interpolate play position for inaccurate devices для отключения функции Interpolate при воспроизведении.

4. Снимите флажок Interpolate record position for inaccurate devices для отключения функции Interpolate при записи.

5. Щелкните на кнопке ОК.

Функция Position Bias позволяет вам указать сдвиг, который программа Sound Forge должна добавить к значению счетчика для компенсации неточности драйвера звуковой карты. По умолчанию значение параметра Position Bias, как для записи, так и для воспроизведения, равно нулю. Но если вы обнаружите, что в процессе записи значение счетчика либо отстает от реального звука, либо опережает его, разрешите проблему путем присвоения значений параметрам Position Bias. Просто сделайте следующее:

1. Выберите пункт меню Options -> Preferences для открытия диалогового окна Preferences.

2. Откройте вкладку Wave.

3. Настройте величину уменьшения или увеличения значения счетчика с помощью ползунка Play position bias ( -64 to 64) или его стрелок.

4. Настройте величину уменьшения или увеличения значения счетчика с помощью ползунка Record position bias (-64 to 64) или его стрелок.

Замечание

В большинстве случаев неверное значение счетчика, предоставляемое звуковой картой, обычно опережает реальный звук. По этой причине значение параметра Position Bias обычно положительное. Типичными значениями являются 4, 8, 16 и 32, соответствующие типичным неточностям многих драйверов звуковых карт. Поэкспериментируйте с этими значениями, а затем настройте параметры Position Bias, чтобы получать точное значение счетчика.

5. Щелкните на кнопке ОК

Буфер в оперативной памяти

Программа Sound Forge использует часть оперативной памяти вашего компьютера в качестве небольшого буфера для записи и воспроизведения. Этот буфер позволяет оптимизировать производительность программы при записи и воспроизведении и устранить перескакивания и паузы в аудиоданных. Если вы обнаружите проблемы с производительностью в процессе записи или воспроизведения, попробуйте увеличить размер буфера. Впрочем, в большинстве случаев значения по умолчанию, 512 Кбайт, вполне достаточно. Чтобы настроить размер буфера, выполните следующие шаги:

1. Выберите пункт меню Options -> Preferences для открытия диалогового окна Preferences.

2. Откройте вкладку Wave (см. рис. 3.14).

3. Отрегулируйте положение ползунка в нижней части диалогового окна для изменения значения параметра Total buffer size (kilobytes).

Замечание

При увеличении размера буфера вы можете столкнуться с ситуацией, что при запуске воспроизведения из программы Sound Forge станет заметна некоторая задержка. Это происходит потому, что программа должна сначала загрузить данные в буфер, а лишь после этого начать воспроизведение. Но это небольшая плата за увеличение производительности, поскольку в результате вы больше не встретите перескакиваний и пауз в ваших данных.

4. Щелкните на кнопке ОК.

Предварительная загрузка

Программа Sound Forge содержит еще один параметр, позволяющий увеличить производительность воспроизведения. Параметр Preload позволяет вам определить, какой объем данных будет послан драйверу звуковой карты до того, как он начнет воспроизведение. Это тоже позволяет избежать перескакивания и пауз при воспроизведении. По умолчанию данный параметр имеет значение ноль, т. е. деактивизирован. Если у вас нет проблем, оставьте параметр Preload отключенным. Но если необходимость возникнет, настроить его можно так:

1. Выберите пункт меню Options -> Preferences для открытия диалогового окна Preferences.

2. Откройте вкладку Wave (см. рис. 3.14).

3. Отрегулируйте ползунок в нижней части диалогового окна для изменения значения параметра Preload size (kilobytes).

Замечание

При увеличении величины параметра Preload size (kilobytes) вы можете столкнуться с ситуацией, что при запуске воспроизведения из программы Sound Forge станет заметна некоторая задержка. Это происходит потому, что программа должна сначала загрузить данные в буфер и только потом начать воспроизведение. Но это лишь небольшая плата за увеличение производительности, поскольку в результате вы больше не встретите перескакиваний и пауз в ваших данных.

Внимание

Некоторые звуковые карты не поддерживают рассматриваемый параметр. Вы сразу заметите это, если при воспроизведении звука после изменения величины параметра Preload size (kilobytes) услышите шум или потерю фрагментов записи. В таком случае верните данному параметру нулевое значение и больше не трогайте. Для устранения проблем с производительностью вместо этого параметра попробуйте настроить вышеупомянутый буфер оперативной памяти.

4. Нажмите на кнопку ОК.


Глава 4. Работа со звуковыми файлами
  • Работа со звуковыми файлами
  • Понятие форматов аудиофайлов
    • Формат Dialogic VOX
    • Формат InterVoice
    • Формат Macintosh AIFF (.AIF/.SND)
    • Формат Macintosh Resource
    • Формат MPEG Audio
    • Формат NeXT/Sun
    • Формат RealMedia
    • Формат Sound Designer 1
    • Формат Video for Windows
    • Формат Microsoft Wave
    • Формат Windows Media Audio
    • Формат RAW
  • Открытие аудиофайлов
    • Открытие файлов Video For Windows
    • Открытие файлов RAW
    • Восстановление поврежденного файла
  • Создание новых аудиофайлов
  • Сохранение аудиофайлов
    • Сохранение файлов RAW
    • Сохранение файлов Video For Windows
    • Сохранение файлов MPEG Audio
    • Сохранение файлов RealMedia
    • Сохранение файлов Windows Media Audio


Работа со звуковыми файлами

Как мы уже упоминали в главе 2, из-за того, что Sound Forge является программой редактирования звука, она не имеет своего собственного формата файлов. Поскольку аудиоданные могут быть сохранены во множестве форматов, программа Sound Forge должна поддерживать различные типы аудиофайлов. Вы не можете выполнять никакие задачи в программе Sound Forge без того, чтобы сначала создать новый аудиофайл или открыть существующий. Поэтому в настоящей главе мы обсудим следующие вопросы работы с аудиофайлами:

  • понятие различных форматов аудиофайлов;
  • как открыть существующий аудиофайл;
  • как создавать новый аудиофайл;
  • как сохранять аудиофайл.

Понятие форматов аудиофайлов

В процессе развития индустрии звукозаписи для решения различных задач были разработаны различные физические методы хранения аудиоданных, например виниловые пластинки, магнитная лента, компакт-диски, теперь — DVD, и т. д., точно таким же образом появилось множество различных компьютерных методов хранения аудиоданных. Мы знаем эти методы как форматы аудиофайлов. Формат аудиофайла представляет собой просто спецификацию, описывающую структуру, в которой аудиоданные хранятся в файле. Например, один формат аудиофайлов может указывать, что биты и байты аудиоданных должны быть сохранены в определенном порядке, а другой формат — что данные должны быть сохранены в совершенно другом порядке.

Конечно, это очень упрощенное объяснение, но общий его смысл заключается в том, что одни и те же аудиоданные могут быть сохранены множеством различных способов.

Почему вы не можете обойтись одним форматом аудиоданных? А потому, что вы можете использовать ваши аудиоданные для различных задач, например для воспроизведения в дисководе для компакт-дисков, для записи музыки или звуковых эффектов в видеоиграх, для записи дорожки фильма или видеоклипа или даже для загрузки через Интернет. Для каждой задачи может потребоваться, чтобы ваши аудиоданные были сохранены своим способом. Например, звук для компакт-диска должен быть сохранен с использованием разрядности 16 бит и частоты сэмплирования 44,1 кГц. Однако для загрузки звука через Интернет нам лучше использовать другую разрядность и частоту сэмплирования, поскольку каждая минута 16-битного, 44-килогерцевого звука занимает около 10 Мбайт. Это слишком большой объем данных для того, чтобы его можно было пропускать через медленные телефонные линии.

Кроме различий в разрядности и частоте сэмплирования, некоторые форматы аудиофайлов предлагают также сжатие данных. Это означает, что сохраняя звук в определенных форматах файлов, вы уменьшаете размер ваших аудиофайлов для того, чтобы их можно было использовать в случаях низкой пропускной способности сетей, например в Интернете. В некоторых случаях сжатие не влияет на качество звука, но в большинстве случаев ухудшение звука наблюдается. При сжатии вам приходится находить компромисс между качеством звука и размером файла, который вы в конце концов получите. Существует много различных схем сжатия, и о них мы вкратце поговорим.

Существование различных форматов аудиофайлов объясняется также и тем, что за годы развития компьютеров получили распространение несколько основных компьютерных платформ. В их число входят Amiga, Macintosh, NEXT и персональные компьютеры с операционной системой Windows. Чтобы дать вам максимально возможную гибкость, программа Sound Forge позволяет открывать и сохранять аудиофайлы во множестве различных форматов. Некоторые из них вам никогда не придется использовать, но все равно неплохо знать, что вы можете с ними сделать, если такая необходимость возникнет. Рассмотрим форматы аудиофайлов, которые поддерживает программа Sound Forge.

Формат Dialogic VOX

Это оптимизированный формат аудиофайлов, используемый в основном для телефонных приложений. Формат Dialogic VOX позволяет сохранять 16-битные аудиоданные и сжимать их, преобразуя в 4-битные аудиоданные, что дает степень сжатия 4:1. Это означает, что вы можете сохранять очень большие файлы, значительно сжимая их. Конечно, качество звука при этом страдает, да и этот формат поддерживает только монофонические данные. Файлы в формате Dialogic VOX имеют расширение vox, для их сжатия используется метод ADPCM.

Замечание

РСМ (pulse code modulation — импульсно-кодовая модуляция) представляет собой метод кодирования, используемый для представления несжатых аудио-данных. Это наиболее общий метод конфигурирования аудиоданных, он используется во многих существующих форматах файлов. ADPCM (adaptive delta pulse code modulation — адаптивная импульсно-кодовая модуляция) является методом кодирования, применяемым для представления сжатых аудиоданных. Существует стандартный метод ADPCM, утвержденный IMA (International Multimedia Association — Международная Ассоциация Мультимедиа). Существует также большое количество вариаций, разработанных различными компаниями, например Microsoft. Различные варианты приводят к появлению файлов различного качества и размера.

Формат InterVoice

Подобно формату Dialogic VOX, формат InterVoice предназначен для использования в приложениях телефонии. Он поддерживает только 8-битные монофонические аудиоданные, зато имеет несколько различных схем сжатия. В число этих схем входят как A-Law, так и u-Law. Файлы InterVoice имеют расширение ivc.

Замечание

A-Law представляет собой схему сжатия звука, оптимизированную для сжатия голосовых аудиоданных, и широко используется для телекоммуникационных приложений в США. Схема сжатия A-Law позволяет перекодировать 16-битный звук РСМ в 8-битный звук РСМ. Эта схема очень похожа на u-Law, за исключением того, что эти схемы используют различные методы кодирования и декодирования.

u-Law (или mu-Law) тоже является схемой сжатия, оптимизированной для сжатия голосовых аудиоданных, но используется для телекоммуникационных приложений в Европе. Как и A-Law, схема u-Law позволяет перекодировку 16-битного звука РСМ в 8-битный звук РСМ.

Формат Macintosh AIFF (.AIF/.SND)

Это стандартный формат файлов для сохранения аудиоданных на платформе Macintosh. Если вам когда-нибудь потребуется пересылать аудиофайлы между персональным компьютером и компьютером Macintosh, используйте именно этот формат. Он поддерживает 8- и 16-битные монофонические и стереофонические аудиоданные. Файлы этого формата могут содержать заголовок Mac-Binary, а могут и не иметь его. Если файл данного типа не содержит заголовка Mac-Binary, он, скорее всего, имеет расширение aif. Если файл данного типа содержит заголовок Mac-Binary, то Sound Forge откроет его, но идентифицирует как файл формата Macintosh Resource (см. следующий раздел). В этом случае файл, скорее всего, имеет расширение snd.

Замечание

При сохранении файлов на компьютерах Macintosh к ним добавляется так называемый заголовок Mac-Binary. Это маленький фрагмент информации, записываемый в начале файла, идентифицирующий тип файла для операционной системы Mac OS и других приложений. Таким способом компьютеры Macintosh сообщают, что содержит файл: текст, графику или, например, аудиоданные. Подробности, касающиеся того, как компьютеры Macintosh работают с файлами, можно найти на Web-сайте http://www.apple.com/ .

Формат Macintosh Resource

Формат файлов Macintosh Resource также используется для хранения звуковых файлов, но для него является обязательным наличие заголовка Mac-Binary, (расширение — snd). Программа Sound Forge умеет открывать файлы этого формата. Она просто игнорирует заголовок Mac-Binary. Однако сохранять файлы в этом формате Sound Forge не может, поскольку файлы Macintosh Resource являются настоящими файлами Macintosh, а персональные компьютеры не могут сохранять данные как файлы Macintosh.

Формат MPEG Audio

Наверняка вы слышали о формате звуковых файлов МРЗ. На сегодняшний день для пользователей Интернета это последний писк моды. Сообщения об этом формате проникли даже в выпуски новостей в традиционных СМИ, поскольку он используется для пересылки нелегальных звукозаписей через Интернет. Почему же этот формат так популярен? Причина заключается в том, что этот формат позволяет сжимать аудиоданные приблизительно в 12 раз, сохраняя при этом качество, близкое к качеству записей на компакт-дисках. Программа Sound Forge обеспечивает как открытие, так и сохранение файлов МРЗ.

Формат NeXT/Sun

Подобно формату Macintosh AIFF, формат аудиофайлов NeXT/Sun также является стандартным форматом, но не для персональных компьютеров или машин Macintosh, а для компьютеров NeXT и Sun Spare station. Этот формат поддерживает много типов аудиоданных, в том числе 8- и 16-битные, моно и стерео. Кроме того, он также поддерживает множество схем сжатия, однако программа Sound Forge поддерживает только наиболее распространенное сжатие (u-Law) для этого формата. Если вам часто доводится загружать из Интернета аудиофайлы, вы наверняка встречали файлы с расширением аи. Большинство из этих файлов представляет собой 16-битный звук, сжатый до 8-битных данных u-Law для пересылки через Интернет или для использования в приложениях Java.

Замечание

Возможно, вы заметили, что одно и то же расширение snd используется для различных форматов аудиофайлов. Так как же их различать? Если в названии файла нет указания на тип файла, то загрузите файл в Sound Forge. В процессе открытия файла программа Sound Forge проанализирует его данные и определит формат.

Формат RealMedia

Если вы проводите много времени в Интернете, этот формат тоже должен быть знаком вам. Формат файлов RealMedia позволяет создавать потоковые аудио- и видеофайлы для передачи через Интернет. Он предлагает сложные собственные функции сжатия, позволяющие передавать аудио- и видеоданные через Интернет (даже через медленные телефонные линии) в режиме реального времени. Это означает, что вы можете начинать прослушивать или просматривать данные еще до того, как они будут полностью скачаны на жесткий диск вашего компьютера. Формат RealMedia был создан компанией RealNetworks. Если вас интересуют подробности этой технологии, посетите Web-сайт данной компании http://www.real.com/ .

Формат Sound Designer 1

Еще один формат аудиофайлов, Sound Designer 1, предназначен специально для конкретного приложения — Sound Designer 1, используемого на компьютерах Macintosh. Подобно формату SampleVision, он поддерживает только 16-битный монофонический звук. Файлы имеют расширение dig или sd.

Формат Video for Windows

Верите вы или нет, но в дополнение к аудиоданным программа Sound Forge позволяет загружать и сохранять видеоданные в форме файлов avi. Вы не сможете редактировать видеоданные, но редактирование аудиоданных, хранимых в файле avi, вполне возможно. Формат AVI (Audio Video Interleaved — Чередование видео и аудио) представляет собой специальный цифровой формат файлов, разработанный для работы с видео на компьютерах. AVI является форматом для операционной системы Windows, а это означает, что любой компьютер с операционной системой Windows может воспроизводить файлы AVI. Формат предоставляет несколько различных схем сжатия для сохраняемых в нем видео- и аудиоданных. Кроме того, файлы AVI поддерживают многодорожечный звук, но программа Sound Forge позволяет работать только с одной звуковой дорожкой.

Формат Microsoft Wave

Подобно формату МРЗ, формат Wave представляет собой еще один очень популярный формат аудиофайлов, о котором вы наверняка слышали. Формат Wave является форматом для операционной системы Windows, а это означает, что любой компьютер с операционной системой Windows может воспроизводить файлы Wave. Формат поддерживает множество различных типов аудиоданных, в том числе 8- и 16-битные, моно и стерео. Формат Wave также имеет поддержку для огромного количества различных схем сжатия, включая многие варианты ADPCM через Microsoft ACM (Audio Compression Manager — Менеджер сжатия звука). АСМ является прозрачно работающей частью операционной системы Windows, предоставляющей доступ к любым схемам сжатия, установленным на компьютере. Операционная система Windows поставляется с несколькими различными схемами, а на вашем компьютере наверняка есть несколько других схем от производителей аудиопродуктов. Если вы работаете с операционной системой Windows, вы, вероятно, в 90% случаев будете использовать для работы со звуком формат Wave. Большая часть программного обеспечения для работы со звуком и музыкой на платформе Windows поддерживает этот формат. Файлы в формате Wave имеют расширение wav.

Формат Windows Media Audio

Подобно RealMedia, Windows Media Audio является специальным форматом аудиофайлов, позволяющим создавать потоковые аудиофайлы для передачи через Интернет. Он является форматом для операционной системы Windows, а это означает, что любой компьютер с операционной системой Windows (с установленной программой Windows Media Player) может воспроизводить файлы Windows Media Audio. Формат Windows Media Audio поддерживает также и видеоданные, но программа Sound Forge поддерживает только звуковую часть этого формата. Кроме того, Sound Forge может только сохранять в данном формате — она не может открывать файлы Windows Media Audio. Подобно формату RealMedia, Windows Media Audio содержит собственные сложные функции сжатия, позволяющие передавать аудиоданные через Интернет в режиме реального времени. Другим сходством с RealMedia является то, что сжатие влияет на качество звуковых данных. Файлы Windows Media имеют расширения wma и asf. Детали этого формата можно найти на странице http://www.microsoft.com/windowsmedia/ .

Формат RAW

Файлы формата RAW содержат простые аудиоданные PGM. Данные не сохраняются в конкретном формате (в отличие от вышеупомянутых форматов). Когда вы сохраняете файл RAW, он содержит чистые аудиоданные. А когда вы загружаете файл RAW в программу Sound Forge, вы должны указать определенные параметры для того, чтобы файл мог загрузиться. В настоящее время Sound Forge позволяет открывать и сохранять только файлы RAW с 8- или 16-битным несжатым звуком РСМ или сжатым звуком A-Law или u-Law.

Совет

Более подробную информацию об этих форматах аудиофайлов вы можете найти на странице Audio File Format FAQ (Frequently Asked Questions — Часто задаваемые вопросы по форматам аудиофайлов) по адресу: http://home.sprynet.com/ ~cbagwell/audio.html.


Открытие аудиофайлов

Есть два способа открытия существующих аудиофайлов в программе Sound Forge. Более быстрый способ состоит в использовании нижней части меню File (рис. 4.1). Там перечислены последние файлы, открывавшиеся в программе.

Рис. 4.1. Файлы, которые раньше были открыты в программе Sound Forge, перечислены в нижней части меню File

Для того чтобы открыть один из этих файлов, просто перейдите в меню File и щелкните на имени файла, который вы хотите открыть. Программа Sound Forge отслеживает последние файлы (их количество может варьироваться от двух до девяти), с которыми вы работали. Если список достиг максимально допустимой длины, открытие нового файла приводит к тому, что нижнее имя файла исчезает из списка — естественно, с самим файлом ничего не происходит, просто в меню File исчезает ссылка на него. Вы можете установить максимальное число файлов в этом списке в диалоговом окне Preferences. Просто выберите Options -> Preferences и перейдите на вкладку General. Убедитесь, что флажок Recently used file list (2 to 9), расположенный в нижней части диалогового окна, установлен. Затем просто введите число от 2 до 9 для установки максимального числа файлов, включаемых в список.

Вы можете также открыть существующий аудиофайл с помощью функции Open программы Sound Forge. Для этого проделайте следующие действия:

1. Выберите File -> Open для вывода диалогового окна Open (рис. 4.2). Обратите внимание, что функциональность этого диалогового окна несколько больше, чем в стандартном диалоговом окне File Open операционной системы Windows.

Рис. 4.2. Диалоговое окно Open

2. Найдите в раскрывающемся списке Look in папку, в которой хранится файл. Вместо этого вы также можете найти в раскрывающемся списке Recent последние открывавшиеся папки.

3. В раскрывающемся списке Files of type выберите тип открываемого аудиофайла.

4. Из появившегося списка файлов выберите нужный. Если флажок Auto play помечен, программа Sound Forge начнет воспроизведение выбранного файла до его открытия. Если же вы сбросите флажок Auto play, вы можете запустить воспроизведение файла вручную с помощью кнопки Play .

5. Для остановки воспроизведения файла щелкните на кнопке Stop.

В нижней части диалогового окна Open вы можете увидеть параметры выбранного файла: заголовок аудиофайла, тип файла, длину файла (в минутах, секундах, кадрах и сэмплах), формат данных (PGM, ADPCM и т. п.), атрибуты данных (частота сэмплирования, разрядность, моно или стерео), имеют ли данные свойства сэмплерной петли (такие, как опорная нота или тип петли), сдвиг SMPTE, присвоенный данным, содержит ли файл области или атрибуты списка воспроизведения, а также комментарии, добавленные к файлу в виде текста (не беспокойтесь, если некоторые из упомянутых здесь терминов вам непонятны — мы их еще обсудим).

Чтобы получить еще более подробную информацию о файле, щелкните на кнопке More, после чего откроется диалоговое окно Properties - Clipped voice.wav, показанное на рис. 4.3. Изучив свойства файла, щелкните на кнопке Cancel для закрытия диалогового окна.

Рис. 4.3. Диалоговое окно Properties - Clipped voice.wav

Если вам нужно просто скопировать какие-то данные из файла без его редактирования и вы хотите обеспечить его неизменность, вы можете открыть файл в режиме "только для чтения". Для активизации этого режима следует просто установить флажок Open as read-only. Это позволит открыть файл для воспроизведения и копирования, но вы никак не сможете его изменить. Когда вы открываете файл в программе Sound Forge, программа сначала автоматически создает временную копию этого файла, так что любые сделанные вами изменения не влияют на исходный файл до тех пор, пока вы не выполните операцию сохранения. Это позволяет экспериментировать с редактированием и обработкой, не опасаясь потери исходных данных. Если же вы захотите работать непосредственно с исходным файлом, установите флажок Operate directly on the sound file. Преимущество такого подхода заключается в том, что открытие файла происходит быстрее и экономится дисковое пространство. Недостаток состоит в том. что исходные данные в процессе редактирования изменяются, но вы можете создать перед началом редактирования файла его резервную копию.

Некоторые звукозаписывающие приложения сохраняют левый и правый каналы стереозвука в двух отдельных монофонических файлах. Вместе эти файлы образуют стереосигнал. Для совместимости с приложениями такого типа Sound Forge позволяет объединять два монофонических файла в один стереофонический файл (один файл для левого канала, а другой — для правого). Для этого установите флажок Merge L/R to stereo. В таком случае вам придется выбрать два открываемых файла. Выберите первый файл, а затем — второй, щелкнув на названии файла при нажатой клавише <Ctrl>. Щелкните на кнопке Open, и все выбранные файлы будут открыты.

Совет

С помощью клавиши <Ctrl> на клавиатуре компьютера вы можете также открыть одновременно несколько независимых аудиофайлов. Sound Forge откроет каждый файл в отдельном окне данных.

После того как файлы открыты, Sound Forge выводит на экран окно (или несколько окон) данных. Программа также показывает в строке состояния в нижней части рабочего пространства атрибуты и длину файла в активном окне данных. Кроме того, в строке состояния вы можете видеть, сколько места (в мегабайтах) осталось на диске после открытия файлов.

Открытие файлов Video For Windows

При открытии файла avi может потребоваться несколько дополнительных шагов. Как мы уже упоминали, формат Video For Windows поддерживает несколько видео- и аудиодорожек (именуемых также потоками). Однако программа Sound Forge поддерживает работу только с одним видеопотоком и одним аудиопстоком в файле avi. Поэтому после того, как вы щелкнете на кнопке Open в диалоговом окне Open (как мы рассказывали выше), вам может потребоваться указать еще несколько параметров, если файл avi содержит несколько потоков данных. Вот эти шаги:

1. После того как вы выберете файл avi и щелкнете на кнопке Open в диалоговом окне Open, появится диалоговое окно Video Stream, показанное на рис. 4.4.

Рис. 4.4. Диалоговое окно Video Stream

2. Все аудио- и видеопотоки, имеющиеся в файле avi, перечислены здесь. В левой части списка показаны два черных ромбика. Один указывает открываемый видеопоток, а второй — открываемый аудиопоток. Чтобы изменить этот выбор, просто щелкните на пустом пространстве прямо перед знаком плюс возле соответствующего потока.

Совет

Чтобы увидеть свойства аудио- или видеопотока, щелкните на знаке плюс перед именем потока в списке.

3. Нажмите на кнопку ОК.

После этого программа Sound Forge откроет файл avi с выбранными вами аудио- и видеопотоками.

Открытие файлов RAW

Поскольку файл RAW представляет собой не что иное, как чистые аудиоданные, программа Sound Forge при открытии файла не знает его атрибутов. Вместо этого вы должны сами сказать программе, какие атрибуты использовать при открытии файла RAW. Поэтому после того как вы щелкнете на кнопке Open в диалоговом окне Open вам потребуется выбрать некоторые дополнительные параметры. Вот шаги, которые необходимо выполнить:

1. После того как вы выберете файл RAW и щелкните на кнопке Open в диалоговом окне Open, откроется диалоговое окно Raw File Type - Click guitar denoised.wav, показанное на рис. 4.5.

Рис. 4.5. Диалоговое окно Raw File Type - Click guitar denoised.wav

2. Разработчики из компании Sonic Foundry упростили пользователям работу, предоставив несколько заранее созданных наборов настроек В раскрывающемся списке Name вы можете посмотреть, нет ли здесь нужных вам атрибутов файлов. Если есть, выберите набор из списка и пропустите остаток этого подраздела.

Замечание

Вы также можете сохранить собственные наборы настроек, которые будут включены в раскрывающийся список Name. После того как вы настроили все параметры, щелкните на кнопке Save As. В диалоговом окне Save Preset введите имя нового набора и щелкните на кнопке ОК. О наборах настроек мы еще поговорим в главе 8.

3. Выберите частоту сэмплирования для аудиофайла с помощью раскрывающегося списка Sample rate (2.000 to 192.000 Hz).

4. Укажите тип сэмпла или разрядность для аудиофайла, выбрав один из параметров в блоке Sample type.

5. Выберите формат для аудиофайла в блоке Format. Это чисто технический параметр. Вы используете его для того, чтобы указать программе Sound Forge, как хранить биты аудиоданных — как тип Unsigned или как тип Signed. Большинство файлов использует вариант Signed.

6. Определите, будет ли аудиофайл монофоническим или стереофоническим, выбрав вариант в блоке Channels.

7. Выберите порядок записи байтов аудиоданных в файл в блоке Byte order. Если это аудиофайл для персонального компьютера, выберите вариант Little endian (Intel). Если это аудиофайл для компьютера Macintosh, выберите вариант Big endian (Motorola).

8. Если вы знаете, что в файле перед аудиоданными хранятся другие данные, укажите, сколько байтов данных, не являющихся звуком, включено в начале файла, введя число в поле Header (0 to 536.870.912 bytes).

9. Если вы знаете, что в файле после аудиоданных хранятся другие данные, укажите, сколько байтов данных, не являющихся звуком, включено в конце файла, введя число в поле Trailer (0 to 536.870.912 bytes).

10. Щелкните на кнопке ОК.

После этого программа Sound Forge откроет файл RAW, используя выбранные вами атрибуты. Если указанные атрибуты неверны, Sound Forge откроет файл, но вы получите никуда не годные данные. Если вы попытаетесь воспроизвести файл, то услышите только шум. Поэтому, если кто-нибудь пошлет вам файл аудиоданных RAW, узнайте у отправителя атрибуты файла, чтобы избежать ненужной траты времени и ошибок.

Восстановление поврежденного файла

Если вы не установите флажок Operate directly on the sound file при открытии файла, Sound Forge автоматически создаст временный файл для открываемого вами файла. Если в процессе редактирования произойдет сбой в работе компьютера, программа Sound Forge обладает способностью восстанавливать временный файл, содержащий редактируемые аудиоданные. Это очень полезная возможность, поскольку никогда не известно, когда операционная система Windows 98 даст сбой, а такое происходит нередко.

Для того чтобы восстановить файл:

1. После сбоя компьютера перезагрузитесь, а затем запустите программу Sound Forge. Когда вы запускаете программу, она автоматически обнаруживает все временные аудиофайлы, которые могут быть на жестком диске. Если таковые находятся, Sound Forge выводит диалоговое окно Crash Recovery, показанное на рис. 4.6.

Рис. 4.6. Диалоговое окно Crash Recovery

2. В списке файлов выберите те файлы, которые вы хотите восстановить, и щелкните на кнопке Recover.

3. Если вы знаете, что файлы вам не потребуются, просто удалите их, нажав на кнопку Delete.

4. Если вас не заботит восстановление или удаление файлов, просто щелкните на кнопке Ignore. Однако при этом файлы останутся на диске, занимая место, так что, скорее всего, в какой-то момент вы все-таки решите восстановить или удалить файлы.

После того как вы восстановите файлы, программа Sound Forge заменит их расширения на wav и сохранит файлы в вашем каталоге для временных файлов (об этом мы говорили в главе 3). Чтобы использовать эти файлы, просто откройте их, как вы открываете любые другие аудиофайлы.

Совет

Полезно сразу переименовать файлы, чтобы впоследствии не запутаться, когда какой файл был создан. После восстановления файлы получают автоматически сгенерированные имена типа FORGEOOO.WAV.


Создание новых аудиофайлов

Создание нового аудиофайла с помощью программы Sound Forge чрезвычайно просто. Откройте пункт меню File -> New и определите атрибуты нового файла. Вот какую последовательность действий нужно выполнить:

1. Выберите пункт меню File -> New для открытия диалогового окна New Window, показанного на рис. 4.7.

Рис. 4.7. Диалоговое окно New Window

2. Выберите в раскрывающемся списке Sample rate (2.000 to 192.000 Hz) частоту сэмплирования для нового файла.

3. Выберите в группе Sample size разрядность для нового файла.

4. Определите в группе Channels, будет ли файл монофоническим или стереофоническим.

Замечание

Когда вы изменяете любой из этих параметров, Sound Forge выводит ориентировочную длину (в поле Maximum editing time) в часах, минутах и секундах файла, который вы можете создать, учитывая оставшееся свободное место на жестком диске.

5. Щелкните на кнопке ОК.

После этого программа Sound Forge откроет новое, пустое окно данных, которое вам предстоит заполнить аудиоданными.

Замечание

Вы также можете создавать новые аудиофайлы с помощью функции записи звука программы Sound Forge, которая автоматически создает новый аудиофайл с данными, которые вы записываете. Об этом мы подробнее поговорим в главе 6.

Сохранение аудиофайлов

В программе Sound Forge имеются три различных команды для сохранения аудиофайлов: Save, Save As и Save All. Команда Save является самым быстрым способом сохранения аудиофайла, с которым вы работаете в данный момент. Просто выберите пункт меню File -> Save (или нажмите комбинацию клавиш <Ctrl> + <S> на клавиатуре компьютера) и файл будет сохранен. Команда Save As позволяет указать формат, в котором вы хотите сохранить открытый в данный момент аудиофайл. Для этого проделайте следующие шаги:

1. Выберите пункт меню File -> Save As для вывода диалогового окна Save As, показанного на рис. 4.8. Обратите внимание, что это диалоговое окно имеет большую функциональность, чем стандартное диалоговое окно сохранения файлов операционной системы Windows.

Рис. 4.8. Диалоговое окно Save As

2. В раскрывающемся списке Save in найдите папку, в которой вы хотите сохранить файл, или в раскрывающемся списке Recent выберите одну из недавно использовавшихся папок.

3. Введите имя аудиофайла (если оно еще отсутствует) в поле File name.

4. Выберите в раскрывающемся списке Save as type тип сохраняемого аудиофайла.

5. В раскрывающемся списке Format выберите формат (РСМ, ADPCM и т. п.) сохранения аудиоданных.

6. Выберите в раскрывающемся списке Attributes те атрибуты (частоту сэмплирования, разрядность, моно или стерео), которые вы хотели бы использовать при сохранении аудиоданных.

Совет

Частота сэмплирования для файла всегда устанавливается равной текущей частоте сэмплирования файла. Вы не можете изменить этот атрибут при сохранении файла. Чтобы изменить частоту сэмплирования, вы должны обработать файл с помощью функции Process -> Resample до сохранения. Об этой функции мы еще поговорим в главе 8.

7. Если вы уже создали области или список воспроизведения для вашего аудиофайла (об этих функциях мы поговорим в главах 5 и 6), вы можете сохранить эту информацию несколькими способами с помощью списка Rgns/Playlist. Если вы не хотите сохранять эту информацию, выберите из списка пункт Do Not Save Regions or Playlist. Если вы хотите оставить эти данные внедренными в файл (что возможно только для типов файлов Wave и AVI), выберите пункт Save Regions and Playlist in .WAV/.AVI files. Вы можете также сохранить информацию в отдельном файле в специальном формате внешнего списка воспроизведения (файл с расширением sfl) программы Sound Forge, в формате Session 8 (файл с расширением prm — для использования с продуктом Digidesign Session 8) или в формате Windows Media Script (файл с расширением txt — для использования с файлами Windows Media).

8. Если вы сохраняете ваш файл как Microsoft Wave (расширение wav), Windows Media (расширение asf), Video For Windows (расширение avi), RealMedia (расширение rm), RealNetworks G2 (также расширение rm) или MPEG Audio (расширение трЗ), вы можете внедрить в файл итоговую информацию. Для этого установите флажок Save Summary Information in file (.WAV, .AVI, .ASF, .RM).

9. Чтобы отредактировать или просмотреть итоговую информацию для файла, щелкните на кнопке Summary, после чего откроется диалоговое окно Properties, показанное на рис. 4.9.

10. Отредактируйте поля Title, Subject, Engineer, Copyright и Comments.

11. Вы можете также присоединить к файлу рисунок, щелкнув на кнопке Picture. В диалоговом окне Open Picture просто выберите файл в формате Windows Bitmap (bmp), Windows Cursor (cur) или Windows Icon (ico) для присоединения, а затем щелкните на кнопке Open.

Рис. 4.9. Диалоговое окно Properties - Running water with very low frequencies

Совет

Большинство графических приложений для Windows позволяют вам создавать собственные файлы Windows Bitmap (bmp). Для целей идентификации вы можете взять свою фотографию, отсканировать ее и сохранить в формате Windows Bitmap, а затем присоединить ее ко всем вашим аудиофайлам.

12. Если вы хотите включить в файл еще больше информации, щелкните на кнопке Extended для открытия диалогового окна Extended Summary, показанного на рис. 4.10.

13. В поле Fields располагается вся дополнительная информация, которую вы можете включить в файл. Чтобы включить в файл конкретную часть информации, установите соответствующий флажок. После этого введите текст с информацией в поле Contents. Чтобы увидеть описание каждого элемента, указанного в поле Fields, просто выделите элемент и прочтите описание в нижней части диалогового окна.

Совет

Когда вы сохраняете файл в Sound Forge как Microsoft Wave (wav), Windows Media (asf), Video For Windows (avi), RealMedia (rm) или MPEG Audio (mp3), в файл включается набор итоговой информации по умолчанию. Если вы хотите, чтобы итоговая информация для текущего файла использовалась по умолчанию для всех вновь сохраняемых файлов, просто нажмите на кнопку Default, a затем — на кнопку Yes.

Рис. 4.10. Диалоговое окно Extended Summary - Running water with very low frequencies

14. Щелкните на кнопке OK в диалоговом окне Extended Summary - Running water with very low frequencies.

15. Нажмите на кнопку OK в диалоговом окне Properties.

16. Если вы сохраняете файл как Microsoft Wave (wav) и включили в файл информацию сэмплерной петли, вы можете сохранить эту информацию, установив флажок Save Sampler Information in file.

17. Щелкните на кнопке Save для сохранения файла.

После этого программа Sound Forge сохранит файл со всеми указанными вами настройками. Однако в зависимости от типа файла, который вы выбрали в раскрывающемся списке Save as type, может оказаться, что вам придется выполнить еще несколько дополнительных шагов, прежде чем файл будет сохранен.

Команда Save All позволяет сохранить все открытые в данный момент аудиофайлы (если у вас открыто больше одного файла). Просто выберите пункт меню File -> Save All. Sound Forge для каждого отдельного файла спросит вас, уверены ли вы, что хотите сохранить его.

Совет

Если при выборе пункта меню File -> Save All вы будете держать нажатой клавишу <Shift>, Sound Forge не будет требовать подтверждения сохранения каждого открытого файла. Все файлы будут просто сохранены. Такой способ гораздо быстрее.

Сохранение файлов RAW

Дополнительные шаги, которые вам нужно выполнить при сохранении файла RAW, почти идентичны открытию файла RAW. После того как вы щелкнете на кнопке Save в диалоговом окне Save As, появится диалоговое окно Save Raw File Type. Это диалоговое окно почти ничем не отличается от окна Raw File Type, в нем только отсутствуют поля Header и Trailer. Все остальные параметры те же самые: Sample type, Format, Channels и Byte order. Просто укажите значения для этих параметров, щелкните на кнопке ОК, и ваш файл RAW будет сохранен. Не забудьте записать использованные при сохранении настройки, чтобы использовать их при открытии этого файла в будущем.

Сохранение файлов Video For Windows

Дополнительные шаги, которые вам нужно выполнить при сохранении файлов с расширением avi, подобны шагам, выполняемым при открытии файлов, но есть различия, требующие подробного объяснения. Вот эти дополнительные шаги, необходимые при сохранении файлов с расширением avi:

1. После того как вы щелкнете на кнопке Save в диалоговом окне Save As, появится диалоговое окно Video Save Options, показанное на рис. 4.11.

Рис. 4.11. Диалоговое окно Video Save Options

2. Все аудио- и видеопотоки, которые есть в файле, показаны в этом окне. Установите флажки в левой половине поля для тех потоков, которые вы хотите сохранить.

3. Чтобы изменить имя потока, щелкните правой кнопкой мыши на имени потока и выберите пункт Edit, а затем введите новое имя для потока.

Совет

Чтобы увидеть свойства аудио- и видеопотока, щелкните на знаке плюс перед именем потока.

4. Чтобы сделать копию текущего аудиопотока и сохранить его в новый аудиопоток, установите флажок Save audio to a new stream. Это может оказаться удобным, если вы планируете в дальнейшем редактировать данный файл в приложении редактирования видео (например, в программе Vegas Video компании Sonic Foundry) и вам требуются дополнительные аудио-потоки.

5. Если вы хотите изменить размер видеокадров с оригинального на какой-либо другой, вы можете это сделать, выбрав новый размер кадра из раскрывающегося списка Re-size video frames to. Вы можете также установить нестандартный размер видеокадров, выбрав в списке пункт Custom, а затем введя новые значения для параметров New Width и New Height.

6. Щелкните на кнопке ОК для открытия диалогового окна Compression Options (рис. 4.12). Поскольку аудио- и видеоданные (особенно если они объединены в виде avi-файлов) занимают очень большой объем, их потоки необходимо сжимать, особенно когда они предназначены для хранения на носителях с ограниченным объемом, например компакт-дисках. Это диалоговое окно позволяет вам установить сжатие для каждого аудио- и видеопотока в файлах с расширением avi.

Рис. 4.12. Диалоговое окно Compression Options

7. Большинство avi-файлов, с которыми вы работаете, уже имеют какое-либо сжатие. В таком случае вы увидите указанную в параметре Current Format величину этого сжатия. Чтобы изменить сжатие для видеопотока, выберите поток в раскрывающемся списке Choose a stream и щелкните на кнопке Options, чтобы открыть диалоговое окно Video Compression, показанное на рис. 4.13.

Рис. 4.13. Диалоговое окно Video Compression

Совет

Если ваш файл уже сжат, лучше не изменять сжатие, поскольку дополнительное сжатие уже сжатых данных понизит качество этих данных.

8. Выберите в раскрывающемся списке Compressor схему сжатия.

9. В зависимости от выбранной вами схемы сжатия элементы Compression Quality, Key Frame Every и Data Rate могут быть недоступны. Если они доступны, присвойте им соответствующие значения. Элемент управления Compression Quality позволяет установить степень сжатия видеопотока, а флажок Key Frame Every — количество ключевых кадров, которые будут включены в видеопоток. Ключевые кадры представляют собой индивидуальные видеокадры, имеющие меньшую степень сжатия или вообще не имеющие сжатия. Чем больше ключевых кадров включено в видеопоток, тем выше качество видео, но ниже степень сжатия (то есть больший размер кадра). Флажок Data Rate позволяет установить объем данных в секунду, требуемый для воспроизведения avi-файла в режиме реального времени. Базовая скорость передачи данных для дисковода компакт-дисков равна 150 Кбайт/сек., но современные дисководы могут передавать данные во много раз быстрее, так что у вас не должно быть проблем с более высокими скоростями. Жесткие диски передают данные еще быстрее, так что настройка скорости передачи данных зависит от того, где вы собираетесь воспроизводить ваш файл.

10. Некоторые из схем сжатия имеют свои дополнительные параметры, которые вы можете настраивать. Доступ к этим параметрам вы получаете после щелчка на кнопке Configure. К сожалению, огромное количество различных схем сжатия не позволяет хоть сколько-нибудь серьезно охватить их, так что здесь вам придется разбираться самостоятельно.

11. Если вы хотите получить представление о том, как ваше видео будет выглядеть при новых параметрах сжатия, щелкните на кнопке Preview.

12. Нажмите на кнопку ОК для закрытия диалогового окна Video Compression.

13. Чтобы изменить сжатие для аудиопотока, выберите поток из раскрывающегося списка Choose a stream в диалоговом окне Compression Options и щелкните на кнопке Options для открытия диалогового окна Sound Selection, показанного на рис. 4.14.

Рис. 4.14. Диалоговое окно Sound Selection

14. Есть несколько заранее установленных наборов значений, которые вы можете использовать, выбрав набор в списке Name. Вы также можете сохранить ваш собственный набор значений, щелкнув на кнопке Save As. Если вы выбираете набор значений, следующие два шага вы можете пропустить.

15. Выберите схему сжатия для аудиопотока из раскрывающегося списка Format.

16. В зависимости от выбранной вами схемы сжатия, вы можете также выбрать атрибуты (частоту сэмплирования, разрядность, моно или стерео) для аудиопотока, используя раскрывающийся список Attributes.

17. Щелкните на кнопке ОК, чтобы закрыть диалоговое окно Sound Selection.

18. Установите флажок Interleave every. Его активизация приводит к тому, что данные в avi-файле структурируются так, что сегменты аудио- и видеоданных чередуются и при воспроизведении считываются последовательно. Это хороший способ увеличить производительность при воспроизведении ваших файлов, особенно если они предназначены для записи на компакт-диск. Значение в поле Frames справа от флажка Interleave Every позволяет вам указать интервал между аудио- и видеосегментами. Значение, равное 1, обычно является нормальным.

19. Щелкните на кнопке ОК.

После этого программа Sound Forge сохраняет ваш avi-файл со всеми указанными вами настройками.

Сохранение файлов MPEG Audio

Дополнительные шаги, которые вам нужно выполнить при сохранении файлов МРЗ, позволяют вам настроить различные параметры сжатия, поскольку МРЗ является форматом со сжатием. Вот эти дополнительные шаги, необходимые при сохранении файлов в формате МРЗ:

1. После того как вы щелкнете на кнопке Save в диалоговом окне Save As , появится диалоговое окно Sonic Foundry МРЗ Plug-In (рис. 4.15).

Рис. 4.15. Диалоговое окно Sonic Foundry МРЗ Plug-In

2. На вкладке Encode выберите разрядность в раскрывающемся списке Bitrate. Разрядность позволяет вам устанавливать, какой объем данных должен быть прочтен из файла для достижения надежного воспроизведения. Чем выше разрядность, тем лучше качество звука, но и размер файла при этом больше. Чем ниже разрядность, тем хуже качество звука, зато размер файла уменьшается. Большинство файлов МРЗ, которые вы можете найти в Интернете, используют разрядность 128 Кбит/сек. Это значение обеспечивает разумный баланс между качеством звука и размером файла.

3. Укажите положение бегунка Quality. Этот параметр определяет качество и скорость процесса кодирования. Чем больше значение параметра Quality, тем лучше происходит процесс кодирования, что приводит к повышению качества звука. Мы всегда оставляем его в положении Highest quality.

4. Установите флажок VBR Quality. Активизация данного флажка заставляет программу Sound Forge варьировать разрядность в ходе процесса кодирования. Иногда это помогает достичь высококачественного звука при меньшем размере файла, но это зависит от материала, который вы кодируете. Для достижения наилучших результатов требуется поэкспериментировать. Мы обычно оставляем этот флажок сброшенным.

5. Если ваш исходный аудиофайл является стереофоническим, а вы хотите в процессе кодирования МРЗ конвертировать его в монофонический, установите флажок Convert to mono. Это может уменьшить размер файла и иногда улучшить качество звука, где присутствует только голос. В остальных случаях лучше оставить этот флажок сброшенным.

6. Если вы хотите включить в файл маркировки, указывающие, что материал защищен авторским правом, является частным или оригинальным, установите флажки Copyrighted, Private или Original material соответственно. Эти параметры никак не влияют на звук, они просто сообщают программе, воспроизводящей файл МРЗ, что этот файл имеет определенные характеристики.

7. Перейдите на вкладку ID3 Summary.

8. Если вы хотите сохранить в файле какую-то текстовую информацию, установите флажок Save ED3 tag to file.

9. Выберите ID3 Version 1, чтобы добавить информацию об названии композиции, исполнителе, альбоме, годе выпуска и жанре музыки в поля Title, Artist, Album, Year и Genre соответственно, а также свои комментарии в поле Comments. Выберите ЮЗ Version 2 для добавления всей вышеперечисленной информации, а также данных об авторских правах. Вы можете включить в файл обе версии тегов IDS. Эту информацию может показывать программа, воспроизводящая файл МРЗ.

10. Щелкните на кнопке ОК.

После этого программа Sound Forge сохранит ваш файл МРЗ со всеми указанными вами настройками.

Сохранение файлов RealMedia

Как и при сохранении в формате MPEG Audio, при сохранении файлов в формате RealMedia вы должны выполнить дополнительные шаги, которые позволяют вам установить различные параметры сжатия, а также несколько других параметров, специфичных для потокового звука. Формат RealMedia позволяет вам сохранять и аудио-, и видеоданные. Чтобы сохранить файл в формате RealMedia, проделайте следующие действия:

1. После того как вы щелкнете на кнопке Save в диалоговом окне Save As, появится диалоговое окно Custom Settings, показанное на рис. 4.16.

Рис. 4.16. Диалоговое окно Custom Settings

2. На вкладке Encode Setting в раскрывающемся списке Player compatibility укажите программе Sound Forge, какое программное обеспечение для воспроизведения файлов будут использовать посетители вашего Web-сайта. Это позволит вам создать файлы, совместимые со старыми версиями программного обеспечения. Скорее всего, вы в большинстве случаев предпочтете оставить вариант G2 RealPlayer.

3. Выберите скорость соединения, которую будут использовать посетители вашего Web-сайта для доступа к Интернету. Вы можете выбрать варианты от 28К modem до 512k DSL/Cable. Лучше выбрать более медленный вариант, если у вас нет уверенности, что все посетители сайта имеют скоростной доступ к Интернету.

4. Выберите тип аудиоданных, которые вы кодируете, в раскрывающемся списке Audio format.

5. Выберите тип видеоданных, которые вы кодируете, в списке Video quality.

6. В блоке File type установите переключатель SureStream (TM) -RealServer G2 compatible, если вы будете использовать для передачи файла через Интернет программное обеспечение RealServer. Если же вы будете использовать для передачи файла через Интернет обычный Web-сервер, установите переключатель Single Rate - RealServer and web server compatible.

7. Если вы хотите изменить размер видеокадров с оригинального на какой-либо другой, вы можете это сделать, выбрав новый размер кадра из списка Re-size video frames to. Вы можете также установить нестандартный размер видеокадров, выбрав в раскрывающемся списке элемент Custom, а затем введя новые значения для параметров New width (32 to 800) и New height (32 to 600).

8. Если вы хотите настроить еще более специфические параметры для управления кодированием ваших данных, щелкните на кнопке Advanced. Однако вам нечасто придется иметь дело с этими настройками.

9. На вкладке Video установите флажок Enable 2-Pass Encoding. Это заставляет программу Sound Forge тратить больше времени на исследование данных, в результате чего достигается лучшее качество. Так что, если вы не боитесь потратить чуть больше времени на кодирование вашего файла, пометьте этот флажок.

10. Установите флажок Enable Variable Bit Rate Encoding. Этот параметр также улучшает качество звука, но может приводить к появлению небольшой паузы перед началом воспроизведения.

11. Установите флажок Enable Loss Protection. Эта функция внедряет в ваши данные специальные коды, которые помогут избежать потери данных при воспроизведении через плохое соединение с Интернетом. Этот флажок тоже имеет смысл пометить.

12. На вкладке Advanced Video оставьте все значения по умолчанию.

13. На вкладке Summary установите флажок Enable Perfect Play. Если этот флажок установлен, программа воспроизведения G2 загрузит весь файл до того, как начнется воспроизведение. Таким образом, файл будет воспроизводиться с жесткого диска пользователя, что даст более высокое качество, чем при потоковом воспроизведении через Интернет.

14. Установите флажок Allow Mobile Play. Если этот флажок установлен, слушатели смогут загружать ваш файл и прослушивать его на аудио-плейере. Этот параметр применим только к аудиофайлам G2.

15. Установите флажок Allow Recording. Если этот флажок помечен, слушатели вашего потокового звука через Интернет смогут записать его на жесткий диск.

16. Введите любую текстовую информацию, которую вы хотите внедрить в файл, включая название (Title), автора (Author), авторские права (Copyright) и комментарии (Comments).

17. Щелкните на кнопке ОК.

После этого программа Sound Forge сохранит ваш файл RealMedia со всеми указанными вами настройками.

Замечание

Если вы хотите узнать побольше о файлах RealMedia, посетите Web-сайт для разработчиков компании RealNetworks. Там имеется огромное количество бесплатной информации об этой технологии, в том числе статьи и руководства. Сайт расположен по адресу http://www.realnetworks.com/devzone/index.html .

Сохранение файлов Windows Media Audio

Хотя формат Windows Media поддерживает и аудио-, и видеоданные (подобно RealMedia), однако программа Sound Forge поддерживает только аспекты технологии Windows Media, относящиеся к звуку. Технология Windows Media имеет сходство с RealMedia, правда, между ними есть и значительные различия, требующие подробного разъяснения. Чтобы сохранить свой файл в формате Windows Media Audio, сделайте следующее:

1. После того как вы щелкнете на кнопке Save в диалоговом окне Save As, появится диалоговое окно Save to Windows Media, показанное на рис. 4.17.

Рис. 4.17. Диалоговое окно Save to Windows Media

2. В списке Template выберите пункт, соответствующий типу аудиоданных, которые вы кодируете. Каждый из предлагаемых вариантов включает в себя описание и подробности, касающиеся типа сжатия, который будет использоваться в вашем файле.

3. Вы можете создать свой собственный шаблон настроек сжатия. Просто щелкните на кнопке Custom и следуйте инструкциям, которые содержит Мастер создания шаблонов Template Wizard. Когда вы закончите, новый шаблон будет находиться в списке Template диалогового окна Save to Windows Media.

4. Используйте блок Properties для ввода произвольной текстовой информации, которую вы хотите внедрить в файл. Эта информация включает сведения о названии композиции (Title), авторе (Author), авторских правах (Copyright), описание (Description) и рейтинг (Rating).

5. Установите флажки Use markers in source file и Use script commands in source file, если вы хотите внедрить в файл Windows Media Audio специальные события, используя маркеры (Markers) программы Sound Forge (о маркерах см. главу 5). Эти специальные события могут включать дополнительную информацию для идентификации файла, URL-адреса Web-сайта и даже компьютерные программы-сценарии. Подробности в замечании, находящемся в конце этого раздела.

6. Щелкните на кнопке ОК.

После этого программа Sound Forge сохранит ваш файл Windows Media Audio со всеми указанными вами настройками.

Замечание

Если вы хотите узнать побольше о создании файлов Windows Media, посетите Web-сайт Windows Media. Там имеется огромное количество бесплатной информации об этой технологии, в том числе статьи и руководства. Сайт расположен по адресу http://vww.microsoft.coin/wtadowsmedia/ .


Глава 5. Работа в Sound Forge
  • Работа в Sound Forge
  • Текущая позиция
    • Показ текущего положения
    • Указатель текущего положения
    • Установка текущей позиции
    • В цифровом виде
    • В графическом виде
    • Область просмотра
  • Меню Transport
    • Функция Go To Start
    • Функция Rewind
    • Функция Forward
    • Функция Go To End
  • Маркеры
    • Создание маркеров
    • Редактирование маркеров
    • Изменение имени и триггера
    • Изменение времени
    • Копирование маркера
    • Удаление маркера
    • Управление маркерами
    • Использование окна Regions - Example music bed
    • Использование функции Go To
  • Области
    • Создание области
    • Использование диалогового окна Add Marker/Region - Example music bed
    • Использование функции Auto Region
    • Редактирование областей
    • Изменение имени и триггера
    • Изменение времени
    • Создание копии области
    • Разделение области на части
    • Удаление области
    • Навигация с использованием областей
    • Использование окна Regions - Example music bed
    • Использование функции Go To
    • Сохранение и загрузка областей
    • Сохранение областей
    • Загрузка областей
    • Функция Extract Regions
  • Где этот звук?


Работа в Sound Forge

Чтобы записывать, воспроизводить и редактировать звукозаписи в Sound Forge, нужно уметь ориентироваться в содержании файлов. Из главы 2 вы могли узнать, что в Sound Forge существует окно данных, позволяющее обрабатывать звуковые данные. Sound Forge располагает и некоторыми другими функциями, упрощающими работу с окном данных. Таким образом, в этой главе мы рассмотрим следующие вопросы:

  • как использовать текущую позицию;
  • как использовать функцию Go To;
  • как маркировать позиции в пределах файла;
  • как искать конкретные данные в пределах файла.

Текущая позиция

Из главы 1 вы узнали о том, что во время записи учитываются не только звуковые данные, но и временные параметры исполнения. Это значит, что во время прослушивания вы услышите в точности то, что записали.

В Sound Forge существует понятие текущей позиции. Оно показывает текущее положение на временной шкале файла. Например, начало файла имеет текущее положение, равное 00:00:00 (в формате часы : минуты : секунды). Чтобы переместиться на позицию 2 минуты 5 секунд, нужно сделать значение текущего положения равным 00:02:05. Можно задать значение в миллисекундах, например 00:05:02:010, т. е. 5 минут 2 секунды 10 миллисекунд.

Значение текущего положения также обновляется в режиме реального времени. Это значит, что в процессе воспроизведения оно постоянно изменяется. Таким образом, когда вы проигрываете файл, происходит непрерывный отсчет текущего положения.

Показ текущего положения

Существует несколько видов представления текущего положения. В цифровом виде значение текущего положения отображается на панели воспроизведения окна данных (рис. 5.1).

Рис. 5.1. Значение текущей позиции на панели воспроизведения окна данных

Для отображения значения текущего положения можно также использовать дисплей времени (Time Display) (рис. 5.2). Чтобы открыть дисплей времени, воспользуйтесь командой Time Display меню View.

Рис. 5.2. Использование дисплея времени для отображения значения текущего положения

Рис. 5.3. Дисплей времени в увеличенном масштабе

Совет

Возможно, вы испытываете затруднения из-за того, что аппаратура вашей домашней студии находится на изрядном расстоянии от компьютера, поэтому вам трудно разглядеть значение текущего положения, как в окне данных, так и на дисплее времени. Выйти из этой ситуации можно, увеличив размер дисплея времени. Для этого просто захватите курсором мыши любой край дисплея времени и перетащите его в сторону — так, как вы сделали бы с любым окном в Windows, чтобы изменить его размер. Таким образом, Sound Forge увеличит масштаб дисплея времени, как это показано на рис. 5.3.

Указатель текущего положения

Значение текущего положения может отображаться не только в цифровом, но и в графическом виде. Текущее положение отображается в виде указателя текущей позиции — вертикальной линии, тянущейся от верхнего до нижнего края окна данных. По мере того как значение текущей позиции изменяется — вручную или автоматически в режиме реального времени — указатель обозначает его графически. Чтобы понять, что мы имеем в виду, попробуйте сделать следующее:

1. В меню File выберите пункт Open и откройте один из файлов-примеров, входящих в поставку Sound Forge, например TUTMUSIC.WAV (рис. 5.4).

Рис. 5.4. Файл TUTMUSIC.WAV в окне данных

2. Выберите команду меню Special -> Transport -> Play или нажмите клавишу <Пробел>, чтобы воспроизвести файл.

Посмотрите на окно данных. Видите указатель текущей позиции, двигающийся по окну во время воспроизведения?

Обратите внимание на ряд чисел над верхним краем указателя текущей позиции. Это — линейка времени (Time Ruler). Она показывает промежутки времени для открытого звукового файла. Вы можете выровнять указатель текущей позиции с каким-либо значением линейки времени, что поможет быстро оценить значение текущей позиции.

Установка текущей позиции

Как видите, значение текущей позиции автоматически изменяется по мере того, как воспроизводится файл. Но вы также можете устанавливать его вручную, когда воспроизведение отключено. Sound Forge предоставляет такую возможность, чтобы вы могли редактировать любую часть файла (подробную информацию о редактировании см. ,в главе 7).

В цифровом виде

Изменить значение текущей позиции просто. Если вы хотите установить конкретное числовое значение, используйте функцию Go To. Вот как это сделать:

1. В меню Edit выберите пункт Go То, чтобы открыть диалоговое окно Go To - Example music bed (рис. 5.5).

Рис. 5.5. Диалоговое окно Go To - Example music bed

2. Sound Forge предоставляет быстрый доступ к некоторому количеству предопределенных временных точек файла с помощью раскрывающегося списка Go To. Чтобы использовать одну из этих точек, просто выберите ее из списка и перейдите к шагу 5.

3. Для более точной установки укажите желаемое значение времени в списке Position.

Совет

Если вы хотите быстро установить значение текущей позиции, необязательно вводить все цифровые значения. К примеру, для установки значения, равного 5 секундам 10 миллисекундам, введите 5.010. Вот и все. Нет нужды вводить значения часов и минут, поскольку они все равно равны нулю.

4. Можно задать значение текущей позиции, используя разные системы счисления времени. Для этого выберите подходящую систему из раскрывающегося списка Input format. Кроме того, вы можете пользоваться форматами, отличными от времени, для ввода значений. Среди возможных форматов — сэмплы (о них см. главу 1), такты, размеры и кадры формата SMPTE.

Замечание

SMPTE (Society of Motion Picture and Television Engineers — Общество кино- и телеинженеров) — это специальный временной код, используемый для синхронизации аудио- и видеоданных и других целей. Этот код был разработан НАСА для точного отслеживания данных, относящихся к космическим полетам. В программе Sound Forge SMPTE используется для расчета времени звучания файлов. Программа автоматически преобразует обычные значения времени в часы, минуты, секунды и кадры, используемые в SMPTE. В формате SMPTE именно кадр избран единицей измерения, поскольку этот формат чаще всего используется с кино-, видео- и телевизионными материалами. Видеозапись состоит из последовательности неподвижных кадров, сменяющих друг друга с высокой скоростью. Во время воспроизведения кадры воспринимаются как движущаяся картинка. Формат SMPTE позволяет синхронизировать видеозапись по отдельным кадрам. Обычно на одну секунду видеозаписи приходится 30 кадров, но бывает и по-другому — в зависимости от формата записи. Более подробно об использовании SMPTE вы узнаете из главы 6. Сейчас достаточно знать, что можно установить значение текущей позиции, используя разные единицы измерения — часы, минуты, секунды и кадры.

5. После того как вы ввели значение текущей позиции, нажмите на кнопку ОК.

Программа Sound Forge изменит значение текущей позиции в соответствии с введенным вами числом, а также переведет указатель текущей позиции на новое место.

В графическом виде

Помните, как в разд. "Указатель текущего положения" данной главы мы приво-'дили описание линейки времени окна данных? Вы можете быстро изменить значение текущей позиции. Для этого проделайте следующие действия:

1. Щелкните кнопкой мыши в области диаграммы окна данных (большая область под линейкой времени).

2. Выберите пункт Open в меню File и откройте один из файлов примеров, поставляемых в комплекте Sound Forge. Для этого примера вы опять можете открыть файл TUTMUSIC.WAV.

3. Щелкните кнопкой мыши в области диаграммы окна данных, как показано на рис. 5.6.

Рис. 5.6. Изменение значения текущей позиции

Еще раз щелкните в другом месте. Видите, как меняется значение текущей позиции? Оно изменяется в строгом соответствии с тем, в какой части диаграммы вы щелкнули. При этом точное значение отображается на линейке времени.

Совет

Мы уже упоминали о том, что, используя диалоговое окно Go To - Example music bed, вы имеете возможность вводить значения времени в разных форматах. Вы также можете поменять формат отображения значений для линейки времени. Чтобы сделать это, щелкните на ней правой кнопкой мыши и выберите в контекстном меню необходимый формат.

Область просмотра

Есть еще один способ установить значение текущей позиции графически — использовать область просмотра. Область просмотра — это часть окна данных, расположенная непосредственно над линейкой времени (рис. 5.7). Просто щелкните кнопкой мыши в этой области, как вы уже делали в случае с областью диаграммы. Вот и все.

Замечание

Область просмотра также предоставляет некоторые другие возможности, о которых мы поговорим далее. Но если говорить о навигации, область просмотра позволяет иметь доступ ко всему файлу, даже если он не полностью умещается на экране. Например, если вы откроете очень длинный звуковой файл, он в любом случае не поместится в окне данных. Чтобы установить значение текущей позиции в той части файла, которая находится "за кадром", вам придется воспользоваться полосой прокрутки окна данных, а потом щелкнуть кнопкой мыши в области диаграммы. В то же время, используя область просмотра, вы сможете установить значение текущей позиции, щелкнув мышью в этой области всего один раз, не переходя к той части файла, которая не помещается в окне данных. Щелкнув же в области просмотра дважды, вы сможете и установить значение текущей позиции, и прокрутить окно данных до этой позиции.

Рис. 5.7. Установка значения текущей позиции


Меню Transport

Установить значение текущей позиции можно цифровым и графическим способами, но Sound Forge предоставляет еще несколько функций, служащих той же цели. Эти функции — часть меню Transport. Чтобы воспользоваться ими, просто выберите команду Special -> Transport. Ниже приведен список этих функций и разъяснено их назначение.

Функция Go To Start

Название этой функции говорит само за себя. Она позволяет установить значение текущей позиции равным 00:00:00, т. е. перейти на начало файла.

Функция Rewind

Функция Rewind устанавливает значение текущей позиции путем вычитания некоторого временного промежутка из предыдущего значения. Таким образом, указатель текущей позиции сдвигается ближе к началу файла. Вычитаемый временной промежуток зависит от того, какой уровень масштабирования (zoom level) вы используете. О масштабировании в программе Sound Forge мы поговорим в главе 7.

Функция Forward

Функция Forward имеет действие, обратное действию функции Rewind, — она прибавляет к значению текущей позиции некоторый временной промежуток, передвигая указатель текущей позиции ближе к концу файла. Прибавляемый временной промежуток также зависит от используемого уровня мае штабирования.

Функция Go To End

Действие этой функции очевидно. Она позволяет установить значение текущей позиции на конец файла.

Совет

Вы можете пользоваться описанными выше функциями меню Transport с помощью клавиатуры — это будет даже быстрее. Вот соответствия функций и клавиш:

Go To Start — <Home>, Go To End — <End>, Rewind — <Page Up>, Forward — <Page Down>. Чтобы минимально изменить значение текущей позиции, воспользуйтесь клавишами со стрелками < <- > и < -> >.


Маркеры

Методы установки значения текущей позиции, описанные выше, основаны либо на числах, либо на предопределенных обозначениях, например конец или начало файла. Эти методы очень удобны, когда файл, с которым вы работаете, вам хорошо знаком и вы знаете, где в нем что находится. Но если вы только что записали материал, бывает очень полезно присвоить имена некоторому количеству мест в пределах файла, чтобы было легче в нем ориентироваться. Для этого существуют маркеры (markers).

Маркеры позволяют задать имена для любой временной точки файла, например для начала вокального пассажа. С их помощью можно быстро переходить от одной такой точки к другой.

Создание маркеров

Создать маркер очень просто. Собственно, все, что вам нужно — это установить указатель текущей позиции на место, которое вы хотите промаркировать, открыть диалоговое окно Add Marker/Region и ввести имя маркера. Чтобы создать маркер, сделайте следующее:

1. Установите значение текущей позиции на то место, где вы хотите поставить маркер. Как вы уже знаете, сделать это можно двумя способами — цифровым и графическим.

2. Щелкните правой кнопкой мыши в области маркеров (она расположена под линейкой времени в окне данных), как показано на рис. 5.8.

Рис. 5.8. Область маркеров расположена под линейкой времени в окне данных

3. Выберите в контекстном меню пункт Add Marker/Region. После этого откроется диалоговое окно Add Marker/Region - Example music bed (рис. 5.9).

4. Введите имя маркера.

5. Убедитесь, что из группы Туре выбран переключатель Marker. О переключателе Region мы поговорим ниже в этой же главе.

6. Поскольку вы уже установили значение текущей позиции для этого маркера, вам не нужно ее менять. Но если вы хотите скорректировать позицию, укажите новое значение в поле Start. Как и в случае с диалоговым окном Go To - Example music bed, упомянутым ранее, вы можете выбрать формат, который вы хотите использовать при установке текущей позиции, с помощью раскрывающегося списка Input format.

7. Помните, в главе 3 мы рассказывали о триггерах MIDI? В дополнение ко всем другим своим возможностям, Sound Forge может совмещать триггеры с маркерами. Это позволяет начинать воспроизведение файла на вашем внешнем MIDI-устройстве (например, на синтезаторе) с любого места. Чтобы совместить триггер с маркером, выберите один из пунктов списка в группе Trigger. Выбор пункта MIDI: Note On-Play позволяет начать воспроизведение с помощью заданного сообщения Note On. Пункт MIDI: Note On-Play/Note Off-Stop инициирует воспроизведение посредством сообщения Note On и остановит его по получении последующего сообщения Note Off. Пункт MIDI: Note On-Queue/Note Off-Play установит значение текущего положения на позицию маркера и начнет воспроизведение по получении сообщения Note Off.

Рис. 5.9. Диалоговое окно Add Marker/Region

8. Укажите номер MIDI-канала, который будет использовать ваш триггер, в списке Channel (I to 16).

9. Укажите высоту ноты MIDI, которую будет использовать триггер, в списке Note (C-1 to G9).

10. Нажмите кнопку ОК.

После этого ваш маркер и его имя будут занесены в область маркеров, находящуюся под линейкой времени в окне данных.

Совет

Обычно, в to время как вы добавляете маркеры в файл, он не воспроизводится. Но вы также можете добавлять маркеры в режиме реального времени. Для этого просто нажмите на клавиатуре клавишу <М>, и Sound Forge создаст новый маркер на текущей позиции. Этому маркеру сразу будет присвоено временное имя, которое вы впоследствии сможете изменить.

Редактирование маркеров

Редактировать существующие маркеры так же просто, как и создавать новые. Вы можете менять их имена, время и MIDI-тригтеры, а также копировать и удалять их.

Изменение имени и триггера

Чтобы изменить имя или триггер маркера, сделайте следующее:

1. Правой кнопкой мыши щелкните на маркере в области маркеров окна данных и в открывшемся меню выберите пункт Edit, чтобы открыть диалоговое окно Edit Marker/Region - Example music bed (оно выглядит так же, как и диалоговое окно Add Marker/Region - Example music bed). Вместо этого вы можете выбрать пункт Regions List в меню View, чтобы открыть окно Regions - Example music bed (рис. 5.10). В этом окне выберите из списка нужный маркер и откройте диалоговое окно Edit Marker/ Regions - Example music bed двойным щелчком мыши.

Рис. 5.10. Диалоговое окно Regions

2. Введите новое имя маркера.

3. Выберите новый MIDI-триггер для маркера.

4. Нажмите на кнопку ОК.

Изменение времени

Чтобы изменить значение времени для маркера цифровым способом, сделайте следующее:

1. Правой кнопкой мыши щелкните на маркере в области маркеров окна данных и в открывшемся меню выберите команду Edit, чтобы открыть диалоговое окно Edit Marker/Region - Example music bed (оно выглядит так же, как и диалоговое окно Add Marker/Region - Example music bed). Вместо этого вы можете выбрать команду Regions List в меню View, чтобы открыть окно Regions - Example music bed. В этом окне выберите из списка нужный маркер, и двойным щелчком мыши откройте диалоговое окно Edit Marker/Regions - Example music bed.

2. Выберите формат времени, который вы хотите использовать, из раскрывающегося списка Input format.

3. Введите новое значение времени для данного маркера.

4. Нажмите на кнопку ОК.

Вы также можете поменять значение времени для маркера графическим способом, просто перетащив его мышкой на другое место в области маркеров окна данных. Перетащите маркер влево, чтобы уменьшить значение времени, или вправо, чтобы увеличить его. Просто, правда? Вдобавок к этому вы можете приравнять значение времени маркера к значению текущей позиции. Для этого щелкните на маркере правой кнопкой мыши и выберите из меню команду Update. Команда Go To выполняет противоположную операцию — приравнивает значение текущей позиции к значению времени маркера.

Копирование маркера

Чтобы создать копию маркера, сделайте следующее:

1. Щелкните мышкой на маркере в области маркеров окна данных, чтобы выделить его. Вместо этого вы можете выбрать пункт Regions List в меню View, чтобы открыть окно Regions - Example music bed и выбрать нужный маркер из списка.

2. Выберите команду меню Special -> Regions List -> Replicate, чтобы создать точную копию выделенного маркера. Вместо этого вы можете щелкнуть на названии маркера в списке окна Regions - Example music bed правой кнопкой мыши и выбрать пункт Replicate из меню.

3. Изначально копия маркера будет иметь те же характеристики (включая имя и время), что и оригинал. Таким образом, вам нужно будет отредактировать копию, чтобы изменить ее параметры.

Удаление маркера

Вы можете удалить маркер двумя способами — либо прямо в окне данных, либо с помощью окна Regions - Example music bed. Вот как это делается:

1. Если вы хотите удалить маркер в окне данных, щелкните на нужном маркере, чтобы выделить его.

2. Если вы хотите воспользоваться окном Regions - Example music bed, выберите пункт Regions List в меню View, чтобы открыть данное окно. После этого выделите маркер, который вы хотите удалить.

3. Щелкните на маркере правой кнопкой мыши и выберите из контекстного меню пункт Delete. Вместо этого вы можете выбрать Special -> Regions List -> Delete.

Управление маркерами

Если бы с помощью маркеров нельзя было передвигаться по фрагментам файла, в них (маркерах) не было бы никакого смысла. А надо просто выделить имя маркера, и текущему положению будет автоматически присвоено значение времени этого маркера. Вы можете перейти к конкретному маркеру двумя способами — используя либо окно Regions - Example music bed, либо функцию Go To.

Использование окна Regions - Example music bed

Чтобы перейти к определенному маркеру, используя окно Regions - Example music bed, сделайте следующее:

1. Выберите команду Regions List в меню View, чтобы открыть окно Regions -Example music bed.

2. Выберите маркер, к которому вы хотели бы перейти.

3. После этого Sound Forge установит значение текущей позиции в соответствии со значением времени маркера, а указатель текущей позиции в окне данных перейдет на новое место.

Использование функции Go To

Чтобы перейти к определенному маркеру, используя функцию Go To, сделайте следующее:

1. Выберите команду Go To в меню Edit, чтобы открыть диалоговое окно Go To - Example music bed.

2. Выберите нужный маркер из раскрывающегося списка Go To.

3. Нажмите на кнопку ОК.

После этого Sound Forge установит значение текущей позиции в соответствии со значением времени маркера, а указатель текущей позиции в окне данных перейдет на новое место.

Совет

Чтобы быстро перейти к следующему или предыдущему маркеру в окне данных, просто нажмите комбинации клавиш <Ctrl>+<<-> или <Ctrl>+<->>.


Области

В дополнение к маркерам, Sound Forge позволяет помечать разные сегменты файла, используя функцию Regions. Разница между маркерами и областями заключается лишь в том, что первые определяют отдельную точку на временной шкале, а вторые — промежуток от одной точки до другой. Кроме начальной точки, области характеризуются конечной точкой и расстоянием между ними. Области прекрасно подходят для определения конкретных сегментов файла, обеспечивая удобство воспроизведения и редактирования. Так же как в случае с маркерами, вы можете задать имя каждой области вашего файла. Например, если вы работаете с записью вокальной партии, вы можете легко промаркировать отдельные пассажи. После этого вам будет удобно переходить от пассажа к пассажу или редактировать их.

Создание области

Вы можете создать область двумя способами — вручную, используя диалоговое окно Add Marker/Region - Example music bed, или автоматически, используя функцию Auto Region.

Использование диалогового окна Add Marker/Region - Example music bed

Чтобы создать область, используя диалоговое окно Add Marker/Region - Example music bed, сделайте следующее:

1. Щелкните мышью и перетащите курсор в сторону в области диаграммы окна данных, чтобы выделить часть данных вашего файла, из которой вы хотите создать область (рис. 5.11). Подробнее о выделении данных мы поговорим в главе 7.

Рис. 5.11. Создание области

2. Выберите команду меню Special -> Regions List -> Add, чтобы открыть диалоговое окно Add Marker/Region - Example music bed, показанное на рис. 5.12.

3. Введите имя области.

Рис. 5.12. Диалоговое окно Add Marker/Region используется для создания как маркеров, так и областей

4. Убедитесь, что в группе Туре установлен переключатель Region.

5. Поскольку вы выделили ту часть файла, которую хотите сделать областью, значения в раскрывающихся списках Start, End и Length уже должны быть установлены. Тем не менее, если вы хотите скорректировать эти данные, введите новые значения в соответствующие поля. Что касается диалогового окна Go To, упомянутого ранее, вы можете выбрать формат, который вы хотите использовать при установке текущей позиции, из раскрывающегося списка Input format.

6. Как и в случае с маркерами, вы можете установить MIDI-триггер для созданной области, причем это будет даже полезнее. Например, если у вас есть файл с несколькими разными вокальными пассажами, то во время записи или живого исполнения вы сможете воспроизвести их в произвольной последовательности, благодаря областям и триггерам.

7. Нажмите на кнопку ОК.

Теперь созданная вами область и ее имя появятся в области маркеров окна данных, расположенной под линейкой времени.

Совет

Чтобы совсем быстро создать область, выделите часть данных и нажмите клавишу <R>, затем нажмите кнопку ОК. Созданной области будет присвоено временное имя, которое вы в любой момент сможете изменить.

Использование функции Auto Region

Функция Auto Region позволяет создавать области автоматически, путем сканирования данных звукового файла, используя заданные вами параметры. Для определения этих характеристик файла Sound Forge использует цифровой шлюз сигнала. Цифровой шлюз открывается в том месте файла, котором уровень сигнала (громкости) выше, чем тот, который вы указали. Эта часть данных определяется как допустимый допустимый звук или начало области. Когда уровень громкости падает ниже заданного уровня, шлюз сигнала закрывается, а область на этом месте заканчивается, после чего функция Auto Region опять начинает искать место допустимого звука, чтобы создать новую область. Этот цикл повторяется до самого конца файла.

Чтобы создать новую область, использую функцию Auto Region , сделайте следующее:

1. Выполните команду Auto Region меню Tools чтобы открыть диалоговое окно Auto Region - Example music bed, показанное на рис. 5.13.

Рис. 5.13. Диалоговое окно Auto Region

2. Установите параметр Minimum level (0.1 to 100.0%), переместив соответ-свующии движок вверх или вниз по шкале. Этот параметр определяет насколько сильным должен быть уровень громкости, чтобы шлюз сигнала открылся, определив данные как допустимый звук и положив начало области.

3. Установите параметр Attack sensitivity (1 to 100.0%), переместив соответствующий движок вверх или вниз по шкале. Этот параметр определяет, как быстро шлюз сигнала откроется и создаст начало области. Если вы установите слишком большое значение для этого параметра, шлюз сигнала будет реагировать на любое кратковременное повышение сигнала, создавая нежелательные области. Если же значение данного параметра будет слишком мало, шлюз сигнала может создать меньше областей, чем вы того хотели бы. Вам придется поэкспериментировать, прежде чем вы сделаете правильную установку для того материала, с которым работаете.

4. Установите параметр Release sensitivity (0.I to 100.0%), переместив соответсвующий движок вверх или вниз по шкале. Этот параметр подобен предыдущему, но выполняет противоположную функцию. Он определяет, как быстро шлюз сигнала закроется и создаст конец области. Если вы установите слишком большое значение для этого параметра, шлюз сигнала будет реагировать на любое кратковременное понижение сигнала, обрывая области в неподходящих местах. Если же значение параметра будет слишком мало, шлюз сигнала может не распознать конец некоторых областей. Опять же, прежде чем вы найдете нужное решение, вам придется поэкспериментировать.

5. Установите параметр Minimum beat duration (0.01 to 3 seconds). Этот параметр определяет, как долго (в секундах) шлюз сигнала будет оставаться открытым даже в том случае, если было обнаружено понижение уровня громкости. По существу, это значит, что именно такой период времени должен истечь прежде, чем может быть создана новая область. Если вы установите низкое значение для этого параметра, шлюз сигнала сможет определять кратковременные изменения громкости, например барабанную дробь. Установив высокое значение для этого параметра, вы лишите шлюз сигнала такой возможности.

6. Установите флажок Use release point for end of region, если вы не хотите, чтобы сегменты с низким сигналом (например, тишина) включались в области. Сбросьте этот флажок, если хотите, чтобы конец предыдущей области совпадал с началом последующей.

7. Нажмите на кнопку ОК.

После этого Sound Forge изучит ваш файл и создаст области в соответствии

с заданными вами параметрами.

Совет

Чтобы понять, как лучше использовать параметры функции Auto Region, вы можете просмотреть варианты установок по умолчанию, предоставляемые программой Sound Forge. Для этого воспользуйтесь раскрывающимся списком Name в верхней части диалогового окна Auto Region - Example music bed.

Функция Auto Region также может создавать области, основываясь на музыкальных параметрах, таких как темп, размер и такт. Для этого вы должны определить темп звуковых данных и указать функции Auto Region, какой размер и количество тактов стоит использовать для создания области. Вот как это сделать:

1. Выделите часть данных, занимающую один такт, в области диаграммы окна данных. Возможно, вам понадобится несколько раз прослушать запись, чтобы найти ту часть данных, которую стоит выделить.

2. Выберите команду меню Special -> Edit Tempo, чтобы открыть диалоговое окно Edit Tempo - Example music bed, показанное на рис. 5.14.

Рис. 5.14. Диалоговое окно Edit Tempo

3. Поскольку вы выделили нужную часть данных, значения параметров Start, End и Length должны быть уже заданы, но, если хотите, вы можете внести некоторые изменения.

4. Установите параметр Number of Beats in a Measure, определяющий количество метрических единиц в такте. Например, если размер вашей записи — 4/4, следует установить значение, равное 4.

5. Установите параметр Selection Length in Beats. Этот параметр сообщает программе Sound Forge, сколько метрических единиц содержится в выделенной части данных. Например, если размер вашей записи — 4/4 (то есть в одном такте содержится 4 метрических единицы), а в выделенной части данных содержится один такт, следует установить значение, равное 4.

6. Теперь программа Sound Forge должна автоматически установить значение параметра Tempo in Beats per minute. Если это значение неверно, вы можете откорректировать его. Учтите, что, когда вы меняете значение данного параметра, Sound Forge автоматически подгоняет значение параметра Selection Length in Beats, и наоборот.

7. Окончательно настроив значения параметров, нажмите кнопку ОК.

8. В окне данных щелкните правой кнопкой мыши на линейке времени и выберите из контекстного меню команду Measures & Beats. В результате этого значение текущей позиции будет отображаться в формате тактов и метрических единиц.

9. Выполните команду меню Tools -> Auto Region, чтобы открыть диалоговое окно Auto Region - Example music bed.

10. Установите флажок Build regions using the current tempo.

11. Укажите соответствующие значения одноименных параметров в списках Measures (0 to 100) и Beats (0 to 100). Эти параметры взаимосвязаны, они определяют частоту создания новых областей в вашем файле. Например, если вы хотите, чтобы новая область создавалась каждую метрическую единицу, установите значение параметра Measures (0 to 100) равным 0, а параметра Beats (0 to 100) — равным 1. Чтобы новая область создавалась каждый такт, установите значение параметра Measures (0 to 100) равным 1, а параметра Beats (0 to 100) — 0. Если вы хотите, чтобы новая область создавалась каждые 7 метрических единиц, установите значение параметра Measures (0 to 100) равным 1, а параметра Beats (0 to 100) — 3. Все эти примеры подразумевают, что размер вашего файла — 4/4.

12. Нажмите на кнопку ОК.

Программа Sound Forge создаст новые области в соответствии с заданными параметрами темпа, тактов и метрических единиц. Позиции начала и конца созданных областей должны выровняться с соответствующими значениями на линейке времени.

Совет

В программе Sound Forge есть еще один способ создания областей. Если ваш файл содержит маркеры, их можно преобразовать в области, выбрав команду меню Special -> Regions List -> Markers To Regions.

Редактирование областей

Как и в случае с маркерами, вы можете редактировать созданные области — изменять их имена, параметры начала и конца, копировать их, разбивать на более мелкие области и удалять.

Изменение имени и триггера

Чтобы изменить имя или триггер MIDI-области, сделайте следующее:

1. В области маркеров окна данных щелкните правой кнопкой мыши на нужной области и выберите из контекстного меню пункт Edit, чтобы открыть диалоговое окно Edit Marker/Region - Example music bed. Вместо этого можно выбрать пункт Regions List меню View, чтобы открыть окно Regions - Example music bed, и сделать двойной щелчок в списке на нужной области.

2. Введите новое имя области.

3. Установите новые настройки триггера MIDI для области.

4. Нажмите на кнопку ОК.

Изменение времени

Чтобы изменить значение параметров начала и конца области цифровым способом, осуществите следующую последовательность действий:

1. В области маркеров окна данных щелкните правой кнопкой мыши на нужной области и выберите из контекстного меню пункт Edit, чтобы открыть диалоговое окно Edit Marker/Region - Example music bed. Вместо этого можно выбрать пункт Regions List меню View, чтобы открыть окно Regions - Example music bed и дважды щелкнуть на нужной области списка.

2. Выберите формат, который вы хотите использовать, с помощью раскрывающегося списка Input format.

3. Укажите новые значения соответствующих параметров с помощью списков Start и End. Изменение этих параметров повлечет за собой автоматическое изменение параметра Length. Изменение параметра Length вручную приведет к автоматической корректировке значения параметра End.

4. Нажмите на кнопку ОК.

Вы также можете изменить значения времени области графическим способом. Для этого вам нужно просто перетащить мышью указатели начала и конца области, находящиеся в области маркеров окна данных. Перетащите один из указателей влево, чтобы уменьшить значение, или вправо, чтобы увеличить. Как и в случае с маркерами, это очень простой метод. Кроме того, вы можете быстро выделить данные в пределах области, щелкнув правой кнопкой мыши на любом из указателей и выбрав пункт Select из контекстного меню.

Создание копии области

Чтобы создать копию области, сделайте следующее:

1. Щелкните мышью на указателе начала (или конца) области, находящемся в области маркеров окна данных, чтобы выделить данные в пределах области. Вместо этого вы можете выполнить команду Regions List меню View, чтобы открыть окно Regions - Example music bed, и выделить необходимую область из списка.

2. Выполните команду меню Special -> Regions List -> Replicate, чтобы создать точную копию выделенной области. Вместо этого вы можете щелкнуть правой кнопкой мыши на нужной области в окне Regions - Example music bed и выбрать команду Replicate из контекстного меню. Этим вы создадите копию указателей начала и конца области, а не данных, содержащихся в ней. Помните, что области просто маркируют части данных, но не содержат самих этих данных.

Сначала копия области будет иметь те же характеристики (включая имя и значения времени), что и оригинал. Таким образом, вам нужно будет изменить параметры новой области.

Разделение области на части

Вы можете не только создать копию области, но и разбить ее на две новых. Например, если ваша область содержит два такта, а вы бы хотели разделить ее на две, содержащих по одному такту, эта функция вам очень поможет. Чтобы разделить область, сделайте следующее:

1. Щелкните мышью на указателе начала (или конца) области, находящемся в области маркеров окна данных, чтобы выделить данные в пределах области. Вместо этого вы можете выбрать комнаду Regions List меню View, чтобы открыть окно Regions - Example music bad, и выделить нужную область из списка.

2. Установите значение текущей позиции на точку, которая должна стать разделителем двух новых областей. Эта точка станет концом одной новой области и началом другой.

3. Выберите команду меню Special -> Regions List -> Replicate.

4. Выберите команду меню Special -> Regions List -> Replicate, чтобы создать точную копию выделенной области. Вместо этого вы можете щелкнуть правой кнопкой мыши на нужной области в окне Regions - Example music bed и выбрать пункт Replicate из контекстного меню.

Программа Sound Forge создаст две новых области из одной старой.

Удаление области

Вы можете удалить область двумя способами — либо прямо в окне данных, либо с помощью окна Regions - Example music bed. Вот как это делается:

1. Если вы хотите использовать окно данных, щелкните мышью на одном из указателей области, чтобы выделить ее.

2. Если вы хотите использовать окно Regions - Example music bed, выполните команду Regions List из меню View, чтобы открыть это окно. Выберите из списка область, которую вы хотите удалить.

3. Щелкните правой кнопкой мыши на одном из указателей области в окне данных или на нужной области из списка в окне Regions - Example music bed и выберите из контекстного меню пункт Delete. Вместо этого вы можете выполнить команду Special -> Regions List -> Delete.

Совет

Можно удалить сразу все области, содержащиеся в файле, просто выбрав команду меню Special -» Regions List -> Clear.

Навигация с использованием областей

Как и в случае с маркерами, вы можете использовать области для навигации по звуковому файлу. Перейти к определенной области в пределах файла можно двумя способами — используя либо окно Regions - Example music bed, либо функцию Go To.

Использование окна Regions - Example music bed

Чтобы перейти к определенной области, используя окно Regions - Example music bed, сделайте следующее:

1. Выберите команду Regions List в меню View, чтобы открыть окно Regions -Example music bed.

2. Выберите область, к которой вы хотите перейти.

3. После этого программа Sound Forge совместит значение текущей позиции с позицией начала нужной вам области, а указатель текущей позиции в окне данных будет перенесен на соответствующее место.

Использование функции Go To

Чтобы перейти к определенной области, используя функцию Go To , сделайте следующее:

1. Выберите команду меню Go To меню Edit, чтобы открыть диалоговое окно Go To - Example music bed.

2. Выберите область из раскрывающегося списка Go To.

3. Нажмите на кнопку ОК .

После этого программа Sound Forge совместит значение текущей позиции с позицией начала нужной вам области, а указатель текущей позиции в окне данных будет перенесен на соответствующее место.

Совет

Чтобы быстро перейти к следующему или предыдущему указателю области в окне данных, просто нажмите комбинацию клавиш <Ctrl>+<<-> или <Ctrl>+<->>.

Сохранение и загрузка областей

Когда вы сохраняете ваш звуковой файл в формате WAV или AVI, области сохраняются вместе с ним. Но, к сожалению, это единственные форматы, позволяющие хранить информацию об областях вместе со звуковыми данными. Что делать, если вам надо сохранить файл в другом формате, но вы хотите также сохранить и области? В этом случае программа Sound Forge позволяет сохранять области в отдельном файле.

Сохранение областей

Чтобы сохранить области в отдельном файле, сделайте следующее:

1. Выберите команду меню Special -> Regions -> List -> Save As, чтобы открыть диалоговое окно Save Regions/PIaylist - Example music bed. Это окно выглядит так же, как любое другое окно сохранения в операционной системе Windows.

2. Выберите папку, в которой вы хотите сохранить файл с областями.

3. Введите имя файла.

4. Выберите тип файла из раскрывающегося списка Save As Type. Информация об областях может быть сохранена в файлах трех типов: Playlist File (sfl), запатентованный формат фирмы Sonic Foundry; Session 8 File (prm), формат, используемый в музыкальных программах фирмы Session 8; Windows Media Script File (txt), формат, используемый программой Windows Media Player фирмы Microsoft.

5. Нажмите на кнопку Save .

Загрузка областей

Чтобы загрузить файл с информацией об областях обратно в программу Sound Forge для использования с вашим звуковым файлом, сделайте следующее:

1. Выполните команаду меню Special -> Regions List -> Open, чтобы открыть диалоговое окно Open Regions/PIaylist - Example music bed. Это окно выглядит так же, как и любое другое окно открытия в операционной системе Windows.

2. Выберите папку, в которой хранится файл с областями.

3. Выберите тип файла из раскрывающегося списка Files Of Type, чтобы отображались только файлы с соответствующим расширением.

4. Выберите файл, который вы хотите открыть.

5. Нажмите на кнопку Open.

Совет

Функции загрузки и сохранения информации об областях могут быть также использованы для создания сразу нескольких комплектов областей для одного звукового файла. Например, если вы работаете с записью вокала, можно использовать один комплект областей для выделения всех фраз, а другой — для выделения мотивов в пределах каждой фразы. Это особенно полезно при воспроизведении и редактировании, о чем мы еще поговорим в нескольких главах этой книги.

Функция Extract Regions

Еще одна удобная функция, имеющая отношение к областям, — функция Extract Regions. Она особенно полезна при редактировании, поскольку позволяет разделить ваш звуковой файл на несколько мелких файлов, соответствующих областям в оригинальном файле. Например, представьте себе, что вы редактируете запись вокала, и в вашем файле есть несколько областей, выделяющих вокальные фразы. Возможно, вам нужно будет создать отдельные файлы для каждой фразы, чтобы использовать их по отдельности в работе вашего устройства сэмплирования MIDI. Функция Extract Regions намного облегчает вашу задачу. Вот как работает эта функция:

1. После того как вы создали все области в вашем файле, выполните команду Extract Regions меню Tools, чтобы открыть диалоговое окно Extract Regions - Example music bed, показанное на рис. 5.15.

Рис. 5.15. Функция Extract Regions позволяет создавать новые файлы на базе имеющихся областей

2. Из списка выберите области, которые вы хотите выделить в отдельные файлы. Если вы хотите создать отдельные файлы из всех существующих областей, нажмите на кнопку Select All.

3. Выберите папку, в которой будут сохранены новые файлы — вы можете либо вручную ввести путь к папке в поле Destination folder, либо использовать кнопку Browse.

4. Введите слово или фразу, с которой будут начинаться названия новых файлов, в поле File name prefix.

5. Если вы хотите использовать длинные имена файлов, задействуйте флажок Use Long File Names for destination file names. В противном случае установите необходимое число в списке Start file counter index (0 to 998). Тогда программа Sound Forge будет использовать нумерацию при задании новым файлам имен и отсчет будет вестись, начиная с введенного числа.

6. Нажмите на кнопку Extract.

После этого программа Sound Forge создаст несколько файлов в формате WAV, в которых будет содержаться информация из областей оригинального файла. Сам оригинальный файл изменен не будет.


Где этот звук

До настоящего времени мы рассказывали о том, как перемещаться на конкретную точку данных посредством установки значения текущей позиции. А что если вы не знаете, на какую именно позицию вам надо перейти? Например, представьте, что в каком-либо месте вашего файла вы услышали пощелкивание или потрескивание, но не можете точно определить, где это место. Вместо того чтобы раз за разом проигрывать файл и пытаться найти это пощелкивание методом проб и ошибок, лучше использовать функцию Find, предоставляемую программой Sound Forge.

Эта функция автоматически исследует ваш файл на предмет разного рода амплитудных звуков. Такими звуками являются шумы в форме нежелательного пощелкивания и потрескивания; сигналы, равные или превышающие заданный вами уровень; области тишины, а также наивысшие уровни сигнала в данном файле. Эта функция очень удобна, когда приходится искать определенные точки в пределах файла (как, например, участки тишины или запись вокала), его маркеров или областей. Данная функция также удобна при редактировании — об этом мы поговорим в главе 7. Пока что вы можете воспользоваться функцией Find в целях навигации, например:

1. Выполните команду меню Special -> Transport -> Go To Start, чтобы установить значение текущей позиции на начало файла. Если этого не сделать, функция Find начнет поиск с установленной в данный момент текущей позиции, а не с начала файла. Это значит, что если значение текущей позиции равно 00:00:10, то функция Find проигнорирует первые 10 секунд файла.

2. Выполните команду Find меню Tools, чтобы открыть диалоговое окно Find - Example music bed, показанное на рис. 5.16.

Рис 5.16. Диалоговое окно Find

3. С помощью раскрывающегося списка выберите тип амплитудных данных, которые вы ищите. Укажите пункт Glitch, чтобы найти любые пощелкивания и потрескивания, которые могли возникнуть из-за некачественного редактирования или, возможно, из-за того, что оригинал записи был записан на виниловом диске. Выберите пункт Level Equal To Or Above, чтобы найти все сигналы, по уровню равные указанному вами значению или превышающие его. Эта возможность особенно полезна, если вам нужно найти в вашем файле обрезанные или искаженные данные. Выберите пункт End Of Silent Region, чтобы найти конец ближайшей области тишины. Эта возможность облегчает поиск (и маркировку) отдельных вокальных фраз или даже ударов барабанных палочек. Выберите пункт Largest Peak, чтобы найти наивысший для данного файла уровень сигнала. Это необходимо, в том числе, для того, чтобы выровнять максимальные уровни сигнала для нескольких файлов, например для тех, которые вы собираетесь записать на один компакт-диск.

Замечание

Обрезание (или искажение) данных происходит, когда уровень сигнала превышает 100% (или 0 дБ, о чем мы немного поговорим позже). При этом верхний и нижний края волны обрезаются и при воспроизведении кажутся искаженными.

4. Установите с помощью соответствующего движка параметр Threshold slope (-60 to -6 dB). Этот параметр работает по-разному, в зависимости от того, какой тип амплитудных данных из раскрывающегося списка Find вы выбрали. В случае с пунктом Glitch параметр Threshold slope (-60 to -6 dB) определяет крутизну шумового всплеска (шумовые всплески — проще говоря, пощелкивание и потрескивание — на диаграмме выглядят как острые выступы, и степень этих выступов измеряется крутизной). Если вы выбрали пункт Level Equal To Or Above, параметр Threshold slope (-60 to -6 dB) определит уровень сигнала (громкости), который вы хотите найти. Если вы выбрали пункт End Of Silent Region, параметр Threshold slope (-60 to -6 dB) определяет уровень сигнала, позволяющий считать эту часть данных областью тишины. Значение параметра Threshold slope (-60 to -6 dB) не требуется устанавливать, если из раскрывающегося списка вы выбрали пункт Largest Peak.

Замечание

Значение параметра Threshold slope (-60 to -6 dB) измеряется в децибеллах (дБ). Данный термин трудно объяснить, особенно в тексте, подобном этому. Самое простое определение — единица измерения, применяющаяся для определения громкости звука. В случае с цифровым звуком максимально возможный уровень его громкости равен 0 дБ. Задание более высокого уровня приведет к обрезанию данных. Чтобы узнать больше о децибеллах в Sound Forge, выберите пункт Contents меню Help. Затем перейдите к статье глоссария, называющейся Decibel (dB).

5. Установите значение параметра Sensitivity. Этот параметр имеет отношение только к пункту Glitch (0 to 100) списка Find. Он указывает программе, насколько тщательно нужно проверять данные при поиске шумовых всплесков. Высокое значение означает, что любой всплеск с крутизной выше установленного уровня будет рассматриваться как шум. Низкое значение указывает программе Sound Forge, что необходимо более тщательно проанализировать всплески, чтобы классифицировать их как шумы.

Совет

Если вы слышите шум, но программа Sound Forge не определяет его, попробуйте понизить значение параметра Threshold slope (-60 to -6 dB) и повысить значение Sensitivity (0 to 100). Если же, напротив, программа выявляет шумы там, где их нет, уменьшите значение Threshold slope (-60 to -6 dB) и увеличьте значение параметра Sensitivity (0 to 100).

6. Нажмите на кнопку ОК .

Программа Sound Forge начнет поиск данных, используя заданные вами параметры. Она также изменит значение текущей позиции и перенесет указатель текущей позиции на соответствующее место.

Совет

Чтобы быстро задействовать функцию Find, используя заданные ранее установки и не открывая диалоговое окно Find, нажмите комбинацию клавиш <Ctrl>+<Y>.


Глава 6. Запись и воспроизведение
  • Запись и воспроизведение
  • Предварительные параметры
    • Свойства записи
    • Частота сэмплирования и разрядность
    • Количество каналов
    • Смещение по оси амплитуды
    • Определение пробелов
  • Основы записи и режим Auto Retake
  • Режим Multiple-Take
    • Режим Multiple takes creating Regions
    • Режим Multiple takes (no Regions)
    • Создание нового окна
  • Режим Punch-In
  • Удаленная запись
  • Синхронизация
    • Основные положения
    • Временной код SMPTE/MIDI
    • Синхронизация с использованием SMPTE (запись)
    • Синхронизация с использованием SMPTE (воспроизведение)


Запись и воспроизведение

В главе 3 мы уже упоминали о том, что программа Sound Forge не предоставляет средств для многодорожечной записи и воспроизведения. Это значит, что вы можете записывать или проигрывать только один стереофонический файл за один раз. Так работает большинство программ редактирования звуковых данных. Главное их предназначение — редактирование, но они также предоставляют возможность создания стереофонической записи живого концерта или новых звуков для устройства сэмплирования MIDI. Программа Sound Forge обеспечивает пользователей широким спектром возможностей, связанных с записью и воспроизведением. В этой главе мы рассмотрим следующие темы:

  • параметры, которые следует устанавливать перед записью;
  • как записывать звуковые данные, используя различные доступные методы;
  • как воспроизводить звуковые данные, используя различные доступные методы;
  • как исправлять ошибки с использованием функции Punch-In;
  • что такое синхронизация и как ее использовать.

Предварительные параметры

Перед тем как вы приступите к записи с использованием программы Sound Forge, вам будет полезно ознакомиться с некоторыми установками параметров записи. Эти параметры позволят вам конфигурировать программу Sound Forge в соответствии с условиями записи. Среди таких параметров — свойства записи, регулировка смещения по оси амплитуды и выявление промежутка в записи. Все перечисленные параметры можно отрегулировать с помощью диалогового окна Record (рис. 6.1).

Собственно говоря, в программе Sound Forge все операции, связанные с записью, осуществляются через диалоговое окно Record. Чтобы открыть его, выберите команду меню Special -> Transport -> Record. О записи как таковой мы поговорим далее в этой главе, а сейчас объясним, что означает каждый из тех параметров, которые необходимо установить перед записью.

Рис. 6.1. Процедуре записи в программе Sound Forge должна предшествовать настройка некоторых параметров

Свойства записи

В первую очередь вы должны сообщить программе Sound Forge, какие технические параметры записи вы хотите использовать. Другими словами, вам нужно установить разрядность, частоту сэмплирования и количество каналов для новой записи.

Рис. 6.2. Вы можете изменить значения разрядности, частоты сэмплирования и количества каналов для вашей новой записи посредством диалогового окна New Window

Когда вы в первый раз открываете диалоговое окно Record, программа автоматически устанавливает значения этих параметров по умолчанию (обычно эти значения равны 16-bit, 44,100 Hz, Mono). Если вы хотите изменить эти параметры, нажмите кнопку New в группе Recording attributes диалогового окна Record, чтобы открыть другое диалоговое окно — New Window (рис. 6.2).

Частота сэмплирования и разрядность

О значении терминов "частота сэмплирования" и "разрядность" вы могли узнать из главы 1. Программа Sound Forge предоставляет вам возможность установить эти параметры для предстоящей записи. В зависимости от возможностей вашей звуковой карты вы можете использовать частоту сэмплирования до 192 000 Гц и разрядность до 32 бит.

Так какие же значения следует использовать? Конечно же, чем выше значения частоты сэмплирования и разрядность, тем лучше качество записи. Но высокие значения также предполагают большую загруженность системы, а данные в таком случае занимают больше памяти и дискового пространства. Кроме того, если входной сигнал некачественен (например, если вы используете дешевый микрофон для записи вокала), высокие значения не помогут улучшить качество записи.

Если ваш компьютер достаточно производителен, у вас установлено достаточно оперативной памяти и имеется много свободного дискового пространства, вам следует использовать, по меньшей мере, частоту сэмплирования 96 000 Гц и разрядность 24 бит. Использование таких значений гарантирует высокое качество записи. Конечно, можно использовать и более высокие значения, значительно улучшающие качество аудиосигнала. Однако большинство людей, скорее всего, не услышат этой разницы в качестве, особенно если вы собираетесь переписывать свои записи на компакт-диск, который требует частоты сэмплирования 44 100 Гц и разрядности 16 бит.

Так зачем же использовать высокие параметры, если вы в конце концов будете перегонять запись на компакт-диск? Главным образом, это надо делать из-за математических ошибок. Дело в том, что, когда звук записывается в виде цифровых данных, для представления аудиосигнала используется ограниченное количество чисел. Когда вы редактируете или обрабатываете вашу запись, программа Sound Forge (как и любая другая программа редактирования звука) производит математические вычисления, выполняющие разные задачи. Никакой математический процесс не может избежать крошечных погрешностей, потому что данные округляются и урезаются. Эти погрешности создают небольшие шумы и помехи, добавляемые в аудиосигнал. В большинстве случаев такие шумы незаметны, но если вы много раз редактируете и обрабатываете запись, они могут в конце концов стать слышимыми.

Чтобы установить частоту сэмплирования и разрядность для вашей новой записи, просто выберите подходящие значения параметров Sample rate и Sample size в диалоговом окне New Window.

Замечание

Мы уже упоминали о том, что данные, помещаемые на компакт-диск, должны иметь частоту сэмплирования 44 100 Гц и разрядность 16 бит. Эти значения не могут быть ниже или выше — они должны быть именно такими. Конечно, первоначально вы можете записывать материал, используя другие значения. Например, если на вашем компьютере установлено недостаточно оперативной памяти и не хватает свободного дискового пространства, вам захочется использовать более низкие значения. Однако мы не рекомендовали бы так делать, если в этом нет необходимости, поскольку чем ниже значения, тем хуже качество. При записи вы также можете использовать более высокие значения, повышающие качество данных. Тем не менее, когда придет время записывать эти данные на компакт-диск, вам все-таки придется изменить значения частоты сэмплирования и разрядности на упомянутые ранее. Преобразовать частоту сэмплирования и разрядность в программе Sound Forge можно, используя функции Resample и Dither, о которых мы вам расскажем в главе 8.

Количество каналов

Поскольку программа Sound Forge не предоставляет средств для многодорожечной записи (то есть вы не можете записывать разные инструменты поодиночке, а затем воспроизводить эти записи как отдельные, но синхронизированные звуковые дорожки), можно использовать только два типа файлов — монофонические (одноканальные) и стереофонические (двух-канальные). Чтобы установить количество каналов для вашей новой записи, отметьте нужный флажок в группе Channels диалогового окна New Window.

Совет

Несмотря на то, что программа Sound Forge позволяет создавать только одно-канальные и двуканальные записи, вы можете создать псевдо-многодоро-жечную запись, работая в режиме стерео. Поскольку стереофоническая запись содержит два отдельных канала (один для левого динамика, другой — для правого), вы можете одновременно записывать один источник звука в левый канал, а другой — в правый. Этот прием может вам пригодиться, например тогда, когда нужно в одно и то же время записать два голоса. Программа Sound Forge позволяет редактировать и обрабатывать каждый канал стереофонической записи отдельно, таким образом, вы можете без труда работать независимо с каждым голосом.

Смещение по оси амплитуды

Если у вас установлена недостаточно мощная звуковая карта, качество записи может быть не идеальным. Между звуковой картой и устройством ввода могут возникать конфликты (особенно, если вы используете дешевую карту, такую как Sound Blaster). В этом случае излишек потока добавляется к входящему сигналу и конечная диаграмма сигналов отклоняется от нулевой оси. Это явление известно как смещение по оси амплитуды (DC offset).

Замечание

Диаграмма сигналов— это графическое представление звука. Попытаемся объяснить ее действие, используя аналогию со стаканчиком и веревкой. Возможно, когда вы были ребенком, вы пробовали создать систему двусторонней связи между вашей комнатой и садовым домиком, используя только пару бумажных стаканчиков и длинный кусок веревки. Вы протыкали дырку в донышках стаканчиков, а затем привязывали концы веревки к двум стаканчикам. Ваш приятель находился в садовом домике, а вы — в своей комнате, при этом вы говорили в стаканчик как в микрофон, а ваш друг прикладывал свое ухо к другому стаканчику и слышал вас. Почему у вас это получалось?

Дело в том, что, когда вы говорите, звук вашего голоса создает вибрацию в нижней части стаканчика, при этом он работает как микрофон. Веревка тоже начинает вибрировать, и форма волны передается на второй стаканчик, который работает как динамик, позволяя вашему другу услышать вашу речь. Если бы вы могли остановить вибрирующую веревку и рассмотреть ее получше, вы бы заметили, что она похожа на диаграмму сигналов в окне данных (рис. 6.3).

Рис. 6.3. Если бы вы могли остановить вибрирующую веревку и рассмотреть ее получше, то вы бы заметили, что она похожа на диаграмму сигналов в окне данных

Как видите, диаграмма сигналов представляет собой кривую линию, похожую на вибрирующую веревку. Линия, называемая нулевой осью, по горизонтали проходит через центр диаграммы. Нулевая ось — это последовательность точек диаграммы, в которых не происходит никаких вибраций, т. е. нет звука. Таким образом, значение звуковых данных на нулевой оси равно нулю (это значение также известно как нулевая амплитуда). Когда волна перемещается вниз и вверх от нулевой оси, происходят вибрации, т. е. имеет место звук. Значение амплитуды в точке диаграммы зависит от того, насколько выше или ниже нулевой оси в данный момент времени (отображаемый на линейке времени окна данных) находится эта точка. Вы можете узнать значение амплитуды, используя линейку уровней окна данных. О разных элементах этого диалогового окна подробно рассказывается в главе 7.

Если ваша диаграмма сигналов смещена относительно нулевой оси из-за смещения по оси амплитуды, то возможно появление шумов и других отклонений во время редактирования и обработки. Чтобы устранить смещение по оси амплитуды во время записи, вам нужно просто настроить программу Sound Forge, чтобы во время записи к данным прибавлялось какое-либо устойчивое значение амплитуды. Это послужит гарантией того, что центр сигнала будет находиться на нулевой оси. В диалоговом окне Record пометьте флажок DC adjust и нажмите на кнопку Calibrate. Вот и все .

Совет

Каждый раз при замене звуковой карты, устройства ввода или даже изменении параметров записи нужно заново проводить калибровку, потому что изменения такого рода могут повлечь за собой смещение по оси амплитуды.

Определение пробелов

Если у вашего компьютера низкое быстродействие, то звуковая карта иногда может генерировать данные быстрее, чем программа Sound Forge может их записать. Следствием этого может быть появление пробелов (сбоев или очень непродолжительных интервалов тишины) во время записи. Пробелы также могут появляться из-за сбоев драйверов звуковой карты. Во время записи вы можете заставить программу Sound Forge реагировать на пробелы одним из трех способов: пропускать их, исправлять или останавливать запись. Вызовите контекстное меню, щелкнув правой кнопкой мыши на любой пустой области диалогового окна Record (рис. 6.4).

Если вы хотите, чтобы программа Sound Forge пропускала все пробелы, выберите пункт меню Gap Detection -> Ignore. Если вы хотите, чтобы программа Sound Forge помещала маркер на все точки файла, в которых появились пробелы, выберите пункт Gap Detection -> Mark. Если вы хотите, чтобы программа Sound Forge прерывала запись при возникновении пробела, выберите пункт Gap Detection -> Stop.

Замечание

Если во время записи возникают пробелы, возможно, вам следует обновить вашу систему. Наиболее полезны обновления оперативной памяти и скорости вращения жесткого диска. Эти два параметра наиболее важны в случае с аудиозаписью. Разумеется, более быстрый процессор тоже может повлиять на ситуацию. Но перед тем как вы потратите ваши трудом и потом заработанные денежки, просмотрите еще раз советы по оптимизации системы, которые мы давали в главе 2.

Рис. 6.4. Установите параметр Gap Detection, щелкнув правой кнопкой мыши на любой пустой области диалогового окна Record


Основы записи и режим Auto Retake

Теперь вы готовы начать запись, используя программу Sound Forge. В этом нет ничего сложного, но вам нужно выполнить несколько действий, чтобы убедиться в том, что все идет гладко. Здесь и в последующих разделах мы расскажем вам о разных способах создания, записей в программе Sound Forge. Сначала давайте изучим основные моменты записи. Чтобы начать, сделайте следующее:

1. Создайте новый звуковой файл, выбрав пункт New в меню File, чтобы открыть диалоговое окно New Window.

2. Установите частоту сэмплирования, разрядность и количество каналов, которые вы хотите использовать в вашем новом файле. Нажмите на кнопку ОК.

3. Выберите пункт меню Special -> Transport -> Record, чтобы открыть диалоговое окно Record.

4. Пометьте флажок DC adjust и нажмите на кнопку Calibrate, чтобы компенсировать смещение по оси амплитуды, которое может появиться из-за несовершенства аппаратных средств вашего компьютера.

5. Выберите режим записи Automatic retake (automatically rewind), используя раскрывающийся список Mode (рис. 6.5). Позже мы поясним, что представляет собой этот режим.

Рис. 6.5. Выберите наиболее подходящий вам режим записи из раскрывающегося списка Mode

6. Установите флажок Monitor. Обратите внимание на появившиеся измерители записи, отображающие текущий уровень входящего сигнала в дБ (рис. 6.6).

Совет

Щелкните на измерителях правой кнопкой мыши, чтобы установить другой охват или длину отображения вершин и спадов уровня сигнала. Вы можете вернуть параметры измерителей в исходное положение, выбрав пункт Reset Clip или нажав на кнопку Reset. В дополнение ко всему, функция Aggressive Update позволяет более точно отображать изменение уровня сигнала, используя приоритетную обработку данных. Если выбран пункт Aggressive Update, то эта функция требует большей производительности компьютера, но не настолько, чтобы вы заметили изменение — если только вы не работаете на очень медленной машине.

7. Установите уровень входного сигнала для вашей звуковой карты, чтобы он был не очень высок, но и не слишком низок. Для этого вам придется использовать программный микшер, который должен входить в поставку вашей звуковой карты. На панели задач Windows найдите маленькую желтую иконку с изображением громкоговорителя и двойным щелчком мыши откройте ваш микшер. В окне микшера выберите пункт меню Options -> Properties, чтобы открыть диалоговое окно Properties. В группе Adjust Volume for выберите пункт Recording и убедитесь в том, что все флажки внизу окна помечены. После этого нажмите на кнопку ОК, чтобы перейти к движкам управления вашего микшера (рис. 6.7).

Рис. 6.6. Измерители записи отображают текущий уровень входящего сигнала в дБ

Рис. 6.7. Используйте микшер, входящий в поставку звуковой карты, чтобы отрегулировать уровень входного сигнала

8. В группе движков под названием Line-In установите флажок Select. Он указывает звуковой карте на то, что вы хотите записать данные, используя входное линейное соединение. Если вы хотите применить другое соединение (например, микрофон или внутренний CD-плейер), воспользуйтесь группой движков, связанных с соответствующим соединением.

Замечание

Выше указано, как использовать для записи стандартную звуковую карту под Windows. Возможно, ваша карта использует какой-нибудь другой метод регулировки уровня входного сигнала. В этом случае вам потребуется ознакомиться с документацией к вашей звуковой карте, чтобы выяснить, как правильно регулировать сигнал.

9. Получив доступ к регуляторам уровня входного сигнала для вашей звуковой карты, начинайте воспроизводить материал, который вы собираетесь записывать. Убедитесь, что воспроизведение происходит на самом высоком уровне громкости, который вы собираетесь использовать при записи. По мере того как материал воспроизводится, измерители записи в диалоговом окне Record должны загораться, отображая текущий уровень входного сигнала. Отрегулируйте уровень сигнала (посредством ползунка громкости в группе Line-In вашего программного микшера) таким образом, чтобы во время воспроизведения самой громкой части записываемого материала измерители записи не загорались красным цветом. Если это произойдет, значит, вы перегрузили входной сигнал, и дальнейшая запись на этом уровне приведет к искажению материла. Если измерители записи загораются на уровне примерно 6 дБ во время воспроизведения самой громкой части материала, значит, вы правильно произвели регулировку уровня входного сигнала.

10. Нажмите на кнопку Record (с изображением большой красной точки), чтобы начать записывать.

Совет

Если между тем, как вы нажали кнопку Record, и непосредственным началом записи прошло некоторое время, значит, надо сначала нажать на кнопку Prepare. В результате программа Sound Forge подготовит буферы записи и звуковую карту к записи. Скорее всего, вам не понадобится этого делать, но применение такой возможности обеспечит более точные результаты при использовании режима записи Punch-In. Об этом мы поговорим позже.

11. Начните воспроизводить материал, который вы хотите записать. Во время записи индикатор Time recorded показывает, сколько прошло времени с начала записи; индикатор Time left on drive показывает, сколько пространства осталось на вашем жестком диске, в формате часы : минуты : секунды : миллисекунды. Вы можете изменить формат для обоих индикаторов, выбрав другой пункт из раскрывающегося списка Input format.

Совет

Посредством нажатия кнопки Marker (с изображением буквы М) вы можете расставлять маркеры по файлу прямо во время записи. Это может быть полезно, если вам необходимо отследить расположение каких-либо мест в записи или разделить файл на несколько секций. Например, когда вы записываете собственные звуковые эффекты, вам может понадобиться записать несколько вариантов одного и того же звука, такого как удар по мусорному ведру или имитация ударного инструмента. Каждый раз после того, как вы стукнули по ведру, вы сможете приостановить запись и создать маркер, чтобы обозначить очередной удар. После того как запись закончена, вы можете с легкостью разбить файл на несколько более мелких (в каждом из которых будет содержаться один вариант), используя функцию Markers to Regions. Для этого просто выберите команду меню Special -Ь Regions List -> Markers To Regions. Эту функцию мы рассматривали в главе 5.

12. Закончив, нажмите на кнопку Stop (на ней изображен большой черный квадрат), чтобы остановить запись. Кнопка Stop на самом деле находится в том же месте, что и кнопка Record. Когда запись отключена, эта кнопка действует как Record, но во время записи она превращается в Stop. После окончания записи программа Sound Forge отобразит новую диаграмму сигналов в окне данных, которое вы открыли перед началом записи (рис. 6.8). Вы можете чуть передвинуть диалоговое окно Record, чтобы полностью увидеть диаграмму.

Рис. 6.8. После окончания записи программа Sound Forge отображает новую диаграмму сигналов в окне данных, которое вы открыли перед началом записи

13. Нажмите на кнопку Play (с изображением зеленого треугольника) в диалоговом окне Record, чтобы прослушать новую запись. Ранее мы предлагали вам установить режим записи Automatic retake. Это значит, что программа Sound Forge автоматически "перемотает" запись (то есть установит курсор текущей позиции) на начало. Таким образом, если вам не понравился результат, вы можете просто переписать материал, повторив все описанные выше действия, начиная с шага 7.

14. Если вы остались довольны записью, просто нажмите на кнопку Close, чтобы закрыть диалоговое окно Record.

Предупреждение

Не забудьте сохранить файл после окончания записи. По идее, это делать необязательно, но это уместная мера предосторожности, потому что никто не знает, когда ваш компьютер решит зависнуть. Чтобы не потерять замечательную запись, выберите пункт Save в меню File (или нажмите комбинацию клавиш <Ctrl>+<S>).

Совет

Если вся аппаратура вашей домашней студии (включая компьютер) находится в одном помещении, а вы записываете ваш материал, используя микрофон, ваши записи будут содержать шум, создаваемый аппаратурой (включая вентилятор внутри вашего компьютера). Чтобы выйти из этой неприятной ситуации, вам, возможно, захочется установить микрофон и один из ваших инструментов MIDI в другом помещении, соединив их с компьютером посредством длинных кабелей. После этого вы сможете установить несколько MIDI-триггеров (о них мы рассказывали в главе 3), чтобы иметь возможность удаленной работы с программой Sound Forge. В этом случае ваш микрофон не запишет посторонних шумов.


Режим Multiple

Используя режим записи Automatic Retake, вы имеете возможность без труда переписать ваш материал, потому что программа Sound Forge автоматически "перематывает" файл на начало. Однако в этом случае, переписывая, вы уничтожите предыдущий вариант. Что если вы хотите сохранить все записанные версии, а потом выбрать лучшую из них? Вы можете сделать это, используя одну из трех существующих разновидностей режима записи Multiple-Take.

Режим Multiple takes creating Regions

Режим записи Multiple takes creating Regions позволяет вам создавать множество вариантов записи, расположенных один за другим и сохраняемых в одном звуковом файле, разделенном на области. О таких областях речь уже шла в главе 5. Чтобы использовать этот режим записи, сделайте следующее:

1. Создайте новый звуковой файл, выбрав команду меню File -> New , чтобы открыть диалоговое окно New Window.

2. Установите частоту сэмплирования, разрядность и количество каналов для нового файла. Затем нажмите на кнопку ОК.

3. Выберите команду меню Special -> Transport -> Record, чтобы открыть диалоговое окно Record.

4. Пометьте флажок DC adjust и нажмите на кнопку Calibrate, чтобы компенсировать смещение по оси амплитуды, которое может появиться из-за несовершенства аппаратных средств вашего компьютера.

5. Выберите из раскрывающегося списка Mode режим записи Multiple takes creating Regions.

6. Установите флажок Monitor. Обратите внимание на появившиеся индикаторы записи, отображающие текущий уровень входящего сигнала в дБ.

7. Установите уровень входного сигнала для вашей звуковой карты, чтобы он был не очень высоким, но и не слишком низким. Для того чтобы сделать это, вам придется использовать программный микшер, входящий в поставку вашей звуковой карты. На панели задач Windows найдите маленький желтый значок с изображением громкоговорителя и двойным щелчком мыши откройте ваш микшер. В окне микшера выберите команду меню Options -> Properties, чтобы открыть диалоговое окно Properties. В группе Adjust Volume for установите переключатель Recording и убедитесь в том, что все флажки внизу окна помечены. После этого нажмите на кнопку ОК , чтобы вывести элементы управления записью микшера вашей звуковой карты.

8. В группе элементов управления под названием Line-In установите флажок Select . Он указывает звуковой карте на то, что вы хотите записать данные, используя входное линейное соединение. Если вы хотите применить другое соединение (например, микрофон или внутренний дисковод для компакт-дисков), используйте группу элементов управления, связанную с соответствующим соединением.

Замечание

Выше указано, как использовать для записи стандартную звуковую карту для Windows. Возможно, ваша карта применяет какой-нибудь другой метод регулировки уровня входного сигнала. В этом случае вам потребуется ознакомиться с документацией к вашей звуковой карте, чтобы выяснить, как правильно регулировать сигнал.

9. Получив доступ к регуляторам уровня входного сигнала для вашей звуковой карты, начните воспроизводить материал, который вы собираетесь записывать. Убедитесь, что воспроизведение происходит на высшем уровне громкости, который вы собираетесь использовать при записи. По мере того как материал воспроизводится, индикаторы записи в диалоговом окне Record должны загораться, отображая текущий уровень входного сигнала. Отрегулируйте уровень сигнала (посредством ползунка управления громкостью в группе Line-In вашего программного микшера) таким образом, чтобы во время воспроизведения самой громкой части записываемого материала индикаторы записи не загорались красным цветом. Если это произойдет, значит, вы перегрузили входной сигнал и дальнейшая запись на этом уровне приведет к искажению материала. Если индикаторы записи загораются на уровне примерно 6 дБ во время воспроизведения самой громкой части материала, значит, вы правильно произвели регулировку уровня входного сигнала.

10. Нажмите на кнопку Record (с изображением большой красной точки), чтобы начать запись.

Совет

Если между тем, как вы нажали на кнопку Record, и непосредственным началом записи прошло некоторое время, значит, надо сначала нажать на кнопку Prepare. В результате этого программа Sound Forge подготовит к записи буферы записи и звуковую карту. Скорее всего, вам не понадобится это делать, но использование такой возможности обеспечит более точные результаты при использовании режима записи Punch-In. Об этом мы поговорим позже.

11. Начните воспроизводить материал, который вы хотите записать. Во время записи индикатор Time recorded показывает, сколько прошло времени с начала записи; индикатор Time left on drive показывает, сколько пространства осталось на вашем жестком диске, в формате часы:минуты:секунды:миллисекунды. Вы можете изменить формат для обоих индикаторов, выбрав другой вариант из раскрывающегося списка Input format.

12. Закончив, нажмите кнопку Stop (на ней изображен большой черный квадрат), чтобы остановить запись. Кнопка Stop на самом деле находится в том же месте, что и кнопка Record. Когда запись отключена, эта кнопка действует как Record , но во время записи она превращается в Stop. После окончания записи программа Sound Forge отобразит новую диаграмму сигналов в окне данных, которое вы открыли перед началом записи. Вы можете чуть передвинуть диалоговое окно Record, чтобы полностью увидеть диаграмму.

13. Поскольку используется режим записи Multiple takes creating Regions, программа Sound Forge не станет перемещать указатель текущей позиции с конца текущей записи. Таким образом, чтобы записать еще один вариант (область), повторите описанные выше действия, начиная с шага 10.

14. По окончании записи всех вариантов нажмите на кнопку Close, чтобы закрыть диалоговое окно Record.

Теперь ваш звуковой файл будет содержать все записанные варианты, каждый из которых будет занимать отдельную область. Если вы хотите выделить каждую область в отдельный файл, используйте функцию Extract Regions (о ней мы говорили в главе 5).

Предупреждение

Не забудьте сохранить файл после окончания записи. По идее, это делать необязательно, но это уместная мера предосторожности, потому что никто не знает, когда ваш компьютер решит зависнуть. Чтобы не потерять замечательную запись, выберите пункт Save меню File (или нажмите <Ctrl>+<S> на вашей клавиатуре) и спите спокойно.

Режим Multiple takes (no Regions)

Режим записи Multiple takes (no Regions) аналогичен режиму Multiple takes creating Regions, за исключением того, что он не создает областей для каждого варианта записи. Вместо этого вам предоставляется возможность либо пометить каждый вариант вручную, используя маркеры, либо использовать отрезки тишины между вариантами в качестве разделителей. Чтобы использовать режим записи Multiple takes (no Regions), выполните те же действия, что и в случае с режимом Multiple takes creating Regions. Единственная разница заключается лишь в том, что, выполняя шаг 5, вам надо будет выбрать из выпадающего списка Mode режим Multiple takes (no Regions).

Создание нового окна

Режим записи Create a new window for each take аналогичен двум предыдущим режимам, за исключением того, что он помещает каждый новый вариант записи в новое окно данных. Чтобы использовать режим записи Create a new window for each take, выполните те же действия, что и в случае с режимом Multiple takes creating regions. Единственная разница состоит лишь в том, что, выполняя шаг 5, вам надо будет выбрать из выпадающего списка Mode режим Create a new window for each take.


Режим Punch-In

Вы, наверное, полагаете, что, сделав ошибку во время записи, вы можете исправить ее, только создав новую запись. Это не так. Используя предоставляемый программой Sound Forge режим записи Punch-In, вы можете перезаписывать материал лишь частично, оставляя в неприкосновенности удачные части записи.

Используя режим записи Punch-In, вы можете заставить программу Sound Forge автоматически начинать и прерывать запись в любых местах файла. Таким образом, вам предоставляется возможность переписать определенные части вашего файла, а не целый файл. Режим записи Punch-In аналогичен другим режимам, за исключением некоторых отличий. Вот как им пользоваться:

1. Предположим, вы хотите исправить некоторые ошибки в только что созданной записи. Для начала выберите из раскрывающегося списка Mode диалогового окна Record режим записи Punch-In.

2. Введите значение параметра Start — час, минуту, секунду и миллисекунду, с которых программа Sound Forge должна будет начать запись. Значение параметра End, обозначающего время окончания записи, нужно ввести в том же формате. Часть файла, расположенная между значениями этих параметров, должна содержать материал, который вы хотите переписать.

Совет

Установить значения параметров Start и End проще, создав область, содержащую часть данных, которую вы хотите переписать. Создать эту область нужно до того, как вы откроете диалоговое окно Record. О правилах создания областей мы говорили в главе 5. После того как вы создали область, откройте диалоговое окно Record и нажмите на кнопку Selection, чтобы открыть диалоговое окно Set Selection - Logoff.wav (рис. 6.9). В этом окне выберите нужную область из выпадающего списка Selection. Затем нажмите на кнопку ОК. Теперь параметры Start и End будут установлены автоматически, исходя из начальной и конечной точек области. Пользоваться этим способом удобнее, чем пытаться угадать значения параметров Start и End.

Рис. 6.9 . Для установки значений параметров Start и End проще использовать диалоговое окно Set Selection

3. Установите флажок Review pre/post-roll (0 to 30 seconds), располагающийся в нижней части диалогового окна Record. После этого введите число секунд, в течение которых программа Sound Forge будет проигрывать файл до и после новой записи. Эта возможность позволяет вам приготовиться к началу записи и услышать, насколько гладким получился переход от новой записи к старой.

4. Нажмите на кнопку Record (с изображением большой красной точки), чтобы начать запись. В зависимости от того, какое количество секунд вы ввели в поле напротив флажка Review pre/post-roll (0 to 30 seconds), вы услышите часть старого материала перед началом новой записи.

5. Начните играть на вашем музыкальном инструменте до того, как начнется запись. Когда воспроизведение достигнет значения параметра Start, программа автоматически включит запись нового материала вместо старого.

6. Когда указатель текущей позиции достигнет значения параметра End, программа Sound Forge остановит запись. В зависимости от того, какое количество секунд вы ввели в поле напротив флажка Review post-roll (0 to 30 seconds), вы услышите часть старого материала после окончания новой записи. Программа Sound Forge заменит старый материал, располагавшийся между значениями параметров Start и End , новым. Если в этот раз вы не допустили никаких ошибок, то запись готова.

7. Прослушайте новую запись, нажав на кнопку Play (с изображением зеленого треугольника). Если вы удовлетворены услышанным, переходите к следующему шагу. Если нет. вернитесь к шагу 4.

8. После окончания записи нажмите на кнопку Close, чтобы закрыть диалоговое окно Record.

Предупреждение

Не забудьте сохранить файл после окончания записи. По идее, это делать необязательно, но это уместная мера предосторожности, потому что никто не знает, когда ваш компьютер решит зависнуть. Чтобы не потерять замечательную запись, выберите пункт Save меню File (или нажмите комбинацию клавиш <Ctrl>+<S>).

Удаленная запись

Термин удаленная запись (remote recording) может вводить в заблуждение, но этот режим записи не похож на все ранее перечисленные. Он не позволяет управлять программой Sound Forge дистанционно. Просто нажатие на кнопку Remote в диалоговом окне Record прячет главное программное окно, оставляя на экране лишь маленькое окошко, содержащее важнейшие средства управления из диалогового окна Record (рис. 6.10).

Все средства управления в окне Record Remote работают в точности так, как и в диалоговом окне Record. Так зачем же нужен режим удаленной записи?

Дело в том, что она позволяет работать одновременно с программой Sound Forge и какой-либо другой программой. Скажем, вы хотите осуществить стереофоническую цифровую запись MIDI-композиции, созданной с использованием цифрового синтезатора. Это можно сделать, одновременно запустив цифровой синтезатор и программу Sound Forge. Используя режим удаленной записи, намного проще пользоваться обеими программами в одно и то же время. Начав воспроизведение с помощью цифрового синтезатора и запустив запись в окне Record Remote программы Sound Forge, вы можете без труда записать вашу MIDI-композицию, как в режиме стерео.

Рис. 6.10. Окно Record Remote является сжатой версией диалогового окна Record


Синхронизация

Еще один момент, касающийся записи, о котором вам нужно знать, — это синхронизация. Это очень сложная тема, немного выходящая за рамки нашего предмета, но вам синхронизация может понадобиться в некоторых ситуациях. Мы попытаемся объяснить основы этой темы и опишем, как использовать синхронизацию, когда программа Sound Forge синхронизируется с внешним устройством и наоборот.

Основные положения

Музыка основывается на времени. Без времени ее не существует. Чтобы записать или воспроизвести звуковые данные, программе Sound Forge требуется следить за временем. Программа использует информацию о времени, чтобы отслеживать положение указателя текущей позиции во время записи и воспроизведения. Когда программа Sound Forge работает самостоятельно, она использует для получения информации о времени встроенные в звуковую карту часы. Таким образом, именно встроенные часы обеспечивают расчет времени, необходимый для функционирования текущей позиции, во время записи и воспроизведения. Это называется внутренней синхронизацией.

Однако иногда вам может потребоваться синхронизировать программу Sound Forge с каким-либо внешним устройством. Например, если у вас есть видеопленка, содержащая материал, к которому вы хотите добавить текст или музыку, вы можете использовать программу Sound Forge, синхронизировав ее с видеопленкой. В этой ситуации видеомагнитофон будет выступать как первичное устройство, а программа Sound Forge — как вторичное. Первичное устройство будет посылать сообщения вторичному, указывая, когда начинать и заканчивать работу, а также, какое измерение времени использовать, чтобы эти два устройства были синхронизированы друг с другом. Для этого нужно использовать так называемый временной код SMPTE/MIDI.

Временной код SMPTE/MIDI

Мы рассказывали о SMPTE в главе 5, и вы знаете, что это система отсчета времени, использующая часы, минуты, секунды и кадры (как на видеопленке). Но как именно функционирует эта система, мы пока не объясняли.

Замечание

Временной код SMPTE/MIDI часто используется для синхронизации не только с видеоносителями, но и с внешними многодорожечными магнитофонами, которые известны как деки DAT (Digital Audio Tape — цифровая аудиопленка). Процедура синхронизации с этими устройствами аналогична приведенной ниже.

SMPTE — это сложный звуковой сигнал, записанный на одну дорожку пленки (в случае с видео он записан на одну из стереофонических звуковых дорожек) с использованием генератора временного кода. Такой сигнал содержит информацию об абсолютном времени звучания пленки в часах, минутах, секундах и кадрах. Программа (например, Sound Forge), считывающая этот код, может быть синхронизирована с любой отметкой времени на пленке. В нашем примере с видео видеомагнитофон — первичное устройство, а программа Sound Forge — вторичное. Во время воспроизведения пленки в видеомагнитофоне программа Sound Forge запишет нужные звуковые данные до определенной временной точки в часах, минутах, секундах и кадрах.

Прочтение временного кода с пленки возможно только с использованием преобразователя SMPTE, который переводит код SMPTE в формат МТС (MIDI Time Code — временной код MIDI). Временной код MIDI прочитывается интерфейсом MIDI и посылается в программу Sound Forge при помощи порта ввода MIDI, настройка которого описывается в главе 3. Временной код MIDI эквивалентен коду SMPTE, за исключением того, что он существует в виде специальных сообщений MIDI, а не как звуковой сигнал. Когда программа Sound Forge получает временной код MIDI, она подсчитывает текущую позицию, соответствующую точному отсчету времени. Это значит, что вы можете начать воспроизведение в любом месте пленки, и программа Sound Forge начнет запись именно в том же месте файла.

Синхронизация с использованием SMPTE (запись)

Предположим, вы хотите добавить к видеоряду текст. Видеозапись может быть вашей или может принадлежать вашему заказчику. Чтобы синхронизировать программу Sound Forge с видеозаписью, вам нужно сделать следующее:

1. Если вы работаете с вашей собственной видеозаписью, в нее необходимо добавить временной код SMPTE, используя генератор SMPTE. Этот процесс называется нанесением дорожки, и мы не будем вдаваться в подробности. Вам всего лишь нужно приобрести генератор SMPTE и найти в руководстве инструкции, объясняющие, как нанести временной код на пленку. Если вы работаете с пленкой заказчика, то, возможно, он нанес на пленку код прежде, чем выслать ее вам.

Совет

Для чтения временного кода с пленки вам также понадобится преобразователь SMPTE. Если у вас установлен профессиональный MIDI-интерфейс, то он, возможно, предоставляет функции преобразования и генерирования временного кода SMPTE. Посмотрите руководство по эксплуатации MIDI-интерфейса, чтобы проверить, так ли это. В этом случае вы можете сэкономить немного денег. Мы используем интерфейс Music Quest 8Port/SE, укомплектованный множеством MIDI-портов и имеющий возможность преобразования и генерирования временного кода SMPTE. К сожалению, этот интерфейс больше не продается, но на сайте компании Midiman (www.midiman.com) можно найти похожую модель.

2. Создайте новый звуковой файл, выбрав пункт меню File -> New, чтобы открыть диалоговое окно New Window.

3. Установите частоту сэмплирования, разрядность и количество канатов для нового файла. Затем нажмите на кнопку ОК.

4. Выберите команду меню Options -> Preferences, чтобы открыть диалоговое окно Preferences. Перейдите на вкладку MIDI/Sync. Выберите из раскрывающегося списка Input подходящий порт ввода MIDI. Об установке параметров MIDI мы подробно рассказывали в главе 3.

5. Выберите пункт меню Special -> Transport -> Record, чтобы открыть диалоговое окно Record.

6. Установите флажок DC adjust и нажмите на кнопку Calibrate, чтобы компенсировать смещение по оси амплитуды, которое может появиться из-за несовершенства аппаратных средств вашего компьютера.

7. Выберите из выпадающего списка Mode режим записи Automatic retake (automatically rewind).

8. Установите флажок Monitor. Обратите внимание на появившиеся индикаторы записи, отображающие текущий уровень входящего сигнала в децибеллах.

9. Установите уровень входного сигнала для вашей звуковой карты, чтобы он был не очень высоким, но и не слишком низким. Чтобы сделать это, вам придется использовать программный микшер, который должен входить в поставку вашей звуковой карты. На панели задач Windows найдите маленький желтый значок с изображением громкоговорителя и двойным щелчком мыши откройте ваш микшер. В окне микшера выберите команду меню Options -> Properties, чтобы открыть диалоговое окно Properties. В группе Adjust Volume for выберите переключатель Recording и убедитесь в том, что все флажки внизу окна помечены. После этого нажмите на кнопку ОК, чтобы вывести элементы управления вашего микшера.

10. В группе элементов управления под названием Line-In установите флажок Select . Он указывает звуковой карте на то, что вы хотите записать данные, используя входное линейное соединение. Если вы хотите применить другое соединение (например, микрофон или внутренний дисковод для компакт-дисков), используйте группу элементов управления, связанную с соответствующим соединением.

11. Получив доступ к регуляторам уровня входного сигнала для вашей звуковой карты, начинайте воспроизводить материал, который вы собираетесь записывать. Убедитесь, что воспроизведение происходит на высшем уровне громкости, который вы собираетесь использовать при записи. По мере того как материал будет воспроизводиться, индикаторы записи в диалоговом окне Record должны загораться, отображая текущий уровень входного сигнала. Отрегулируйте уровень сигнала (посредством ползунка управления громкостью в группе Line-In вашего программного микшера) таким образом, чтобы во время воспроизведения самой громкой части записываемого материала индикаторы записи не загорались красным цветом. Если это произойдет, значит, вы перегрузили входной сигнал, и дальнейшая запись на таком уровне приведет к искажению материала. Если индикаторы записи загораются на уровне примерно 6 дБ во время воспроизведения самой громкой части материала, значит, вы правильно произвели регулировку уровня входного сигнала.

12. Нажмите на кнопку Sync , чтобы открыть диалоговое окно Record Synchronization (рис. 6.11).

13. Установите флажок Enable MTC/SMPTE Input Synchronization.

14. Если вы хотите, чтобы запись началась автоматически в определенный момент времени в соответствии с показаниями временного кода SMPTE, установите флажок Start, а затем введите время SMPTE в часах, минутах, секундах и кадрах. В противном случае запись начнется в момент получения временного кода от внешнего устройства.

15. Если вы хотите, чтобы запись закончилась в определенный момент времени в соответствии с показаниями временного кода SMPTE, установите флажок End и затем введите время SMPTE в часах, минутах, секундах и кадрах. В противном случае вам придется вручную прерывать запись при помощи кнопки Stop.

Рис. 6.11. Диалоговое окно Record Synchronization для установки параметров синхронизации

16. Нажмите на кнопку Close , чтобы закрыть диалоговое окно Record Synchronization.

17. Используя раскрывающийся список Input format, выберите ту разновидность формата SMPTE sync, которую вы хотите использовать. Если вы записываете звуковую дорожку на собственную видеопленку, используйте формат SMPTE Non-Drop. Если вы работаете с пленкой заказчика, он должен сообщить вам, какой формат лучше использовать.

Замечание

Разные типы видеоматериалов используют для записи разные скорости протяжки ленты. Частота смены кадров зависит от того, сколько кадров в секунду производится при записи. Для кинопленки используют 24 кадра в секунду. Для видеопленки используются разные частоты смены кадров, в зависимости от того, записывается ли материал в черно-белом или в цветном режиме и т. д. Почитайте руководство по использованию вашего устройства генерирования/чтения SMPTE, чтобы получить исчерпывающую информацию о частотах смены кадров.

18. Нажмите на кнопку Prepare, чтобы приготовить программу Sound Forge к поступлению данных SMPTE/MTC. При этом зажжется зеленый индикатор с надписью [Prepared] (рис. 6.12).

19. Запустите воспроизведение на первичном устройстве (в нашем случае — запустите пленку в видеомагнитофоне). Это устройство пошлет код SMPTE программе Sound Forge. Если вы ввели какое-либо значение в поле Start, программа Sound Forge не начнет запись, пока не будет достигнуто соответствующее значение времени. В противном случае запись начнется немедленно.

Рис. 6.12. После того как вы нажмете кнопку Prepare, зажжется зеленый индикатор, сообщающий о том, что программа готова к поступлению данных SMPTE/MTC

20. Если вы ввели какое-либо значение в поле End, программа Sound Forge автоматически прервет запись по достижении соответствующего значения времени. Если вы не ввели никакого значения, вам придется нажать на кнопку Stop там, где вы хотите прервать запись. После окончания записи не забудьте остановить воспроизведение на первичном устройстве.

21. По окончании записи нажмите на кнопку Close, чтобы закрыть диалоговое окно Record.

Синхронизация с использованием SMPTE (воспроизведение)

Вы можете также столкнуться с ситуацией, когда будет необходимо синхронизировать внешнее устройство с файлом в программе Sound Forge при воспроизведении. В этом случае требуется сделать следующее:

1. Откройте файл в программе Sound Forge.

2. Выберите команду меню Options -> Preferences, чтобы открыть диалоговое окно Preferences. Перейдите на вкладку MIDI/Sync. Выберите из раскрывающегося списка Output подходящий порт ввода MIDI. Это должен быть порт, к которому подключено ваше внешнее устройство. Об установке параметров MIDI мы подробно рассказывали в главе 3.

3. Выберите пункт меню Options -> MIDI Output Sync, чтобы включить выход МТС из программы Sound Forge.

4. Настройте ваше внешнее устройство так, чтобы оно могло принимать сигналы SMPTE/MTC. Вам придется обратиться к руководству по эксплуатации вашего внешнего устройства, чтобы узнать, как это сделать.

5. Возможно, вам понадобится ввести значение смещения SMPTE/MTC в часах, минутах, секундах и кадрах. Например, если вы синхронизируете кассетную деку с программой Sound Forge, а запись на кассете начинается не с самого начала, вам, скорее всего, необходимо будет настроить программу Sound Forge так, чтобы код SMPTE/MTC был отослан внешнему устройству (значение смещения по умолчанию равно 00:00:00:00) не сразу, а через некоторое время. Чтобы установить смещение воспроизведения выберите команду меню Options -> Preferences. Перейдите на вкладку MIDI/Sync. Установите флажок Enable SMPTE Playback Offset и введите значение времени в часах, минутах, секундах и кадрах.

6. Запустите воспроизведение на внешнем устройстве. Вместо воспроизведения оно должно дождаться входящего сигнала SMPTE/MTC.

7. В программе Sound Forge выберите пункт меню Special -> Transport -> Play, чтобы запустить воспроизведение текущего звукового файла. Программа Sound Forge начнет воспроизведение и одновременно пошлет сигнал SMPTE/MTC внешнему устройству, которое, в свою очередь, тоже должно начать воспроизведение, синхронизированное с файлом в программе.

Запутались? Действительно, мы уже говорили о том, что синхронизация — сложная тема. Вы можете найти дополнительную информацию в руководстве по программе Sound Forge и в справочном файле этой программы, но, возможно, то, что там написано, вам будет трудно понять. Лучший способ это сделать — как можно больше экспериментировать с синхронизацией или прочитать книгу по звукозаписи для начинающих. Вам все-таки стоит изучить синхронизацию, если вы постоянно сталкиваетесь с необходимостью ее использования.


Глава 7. Основы редактирования
  • Основы редактирования
  • Окно данных
    • Прокрутка
    • Масштабирование
    • Инструмент Magnify
    • Выделение и инструмент Edit
    • Диалоговое окно Set Selection
    • Изменение выделенной области
    • Подгонка выделенной области
  • Копирование, вырезание, вставка данных и другие операции
    • Специальные возможности вставки
    • Перезапись
    • Дублирование
    • Вставка в новое окно
    • Сведение
    • Функция Paste Crossfade
  • Ошибки при редактировании
  • Инструмент Pencil


Основы редактирования

После того как запись окончена, можно приступать к редактированию. С этим программа Sound Forge справляется блистательно. Она предоставляет обширный набор инструментов для редактирования, обработки данных и наложения звуковых эффектов. С их помощью вы можете делать с вашими записями все, что вам заблагорассудится. Инструменты обработки данных и наложения эффектов будут описаны в главах 8 и 9, а в данной главе мы обсудим следующие темы:

  • работа с окном данных;
  • выделение фрагментов звуковых данных;
  • копирование, вырезание, удаление, кадрирование и вставка звуковых данных;
  • использование команд Undo/Redo и Undo/Redo History;
  • использование инструментов Edit, Magnify и Pencil.

Предупреждение

Советуем вам всегда создавать резервную копию звукового файла перед тем, как его редактировать. В этом случае, даже если в процессе редактирования вы что-нибудь перепутаете, вы всегда сможете возвратиться к исходным данным (см. также приложение 2).

Окно данных

Каждый раз, когда вы открываете существующий звуковой файл или записываете новый, программа Sound Forge отображает окно данных (Data Window), показанное на рис. 7.1.

Окно данных позволяет просматривать, редактировать и обрабатывать звуковые данные. Одновременно может быть открыто несколько окон данных; соответственно, вы можете работать сразу с двумя и более файлами. Вы уже научились ориентироваться среди элементов Sound Forge и записывать новые звуковые файлы, однако мы еще не рассказывали о том, как обрабатывать звуковые данные, используя окно данных. Под обработкой в данном случае понимаются выделение фрагментов данных, копирование, вырезание, вставка и другие подобные операции.

Рис. 7.1. Окно данных в программе Sound Forge

Прокрутка

Как вы уже знаете, окно данных отображает звуковые данные в виде диаграммы сигналов, показывающей форму волны. Если вы работаете с монофонической (одноканальной) записью, вы увидите одну диаграмму; если же открыта стереофоническая (двухканальная) запись, диаграмм будет две. Верхняя диаграмма изображает левый канал, нижняя — правый. Расстояние от левого края диаграммы до правого показывает длину файла. В большинстве случаев данные целого файла не помещаются в окне. В таких ситуациях необходимо использовать полосу прокрутки окна данных, расположенную между нижним краем диаграммы и панелью воспроизведения. Эта полоса прокрутки ничем не отличается от аналогичных элементов в стандартных приложениях под Windows. Чтобы перемещаться между фрагментами записи, вы можете либо щелкать по стрелкам прокрутки, либо перетаскивать бегунок на полосе прокрутки. Прокручивая полосу вправо, вы увеличиваете значение линейки времени (Time Ruler) и получаете возможность просмотреть данные до конца файла. Тем не менее прокрутка не меняет значение указателя текущей позиции (о нем вы могли узнать из главы 5).

Масштабирование

Окно данных также предоставляет возможность масштабирования, благодаря которой вы можете увеличить диаграмму, чтобы выполнить редактирование наиболее аккуратно. Взгляните на нижний край окна данных, и вы увидите две группы кнопок (одна — слева, другая — справа от полосы прокрутки), на которых изображены лупы. С помощью правой группы кнопок (Time Zoom — масштабирование времени) масштаб диаграммы увеличивается горизонтально, уточняя значение времени. Таким образом, щелкнув на кнопке Time Zoom In (увеличить масштабирование времени), на которой изображена большая лупа, вы увидите более детализированное отображение данных. Обратная функция — у кнопки Time Zoom Out (уменьшить масштабирование времени), на которой изображена маленькая лупа. Используя масштабирование времени, вы заметите, что значения линейки времени изменяются в сторону детализации, так же как и значение индикатора разрешения, расположенного справа от полосы прокрутки. Индикатор разрешения показывает текущую степень масштабирования в виде коэффициента. Степень масштабирования 1:1 дает наибольшую возможную детализацию диаграммы. Значение, дающее наименьшую детализацию, зависит от длины диаграммы. По умолчанию степень масштабирования равна 1:4,096.

Совет

Вы можете изменить значение степени масштабирования по умолчанию. Для этого с помощью меню Options откройте диалоговое окно Preferences, перейдите на вкладку Display и выберите новую степень масштабирования из раскрывающегося списка Normal Zoom Ratio.

Группа кнопок слева от полосы прокрутки (Level Zoom — масштабирование уровней) функционирует так же, как и кнопки масштабирования времени, но масштаб диаграммы изменяется вертикально. Нажатие на кнопку Level Zoom In (на ней изображена большая лупа) приведет к увеличению масштаба отображения уровня сигнала на диаграмме сигналов. Кнопка Level Zoom Out (та, на которой изображена маленькая лупа) выполняет обратную операцию. Все ваши манипуляции с этими кнопками отражаются на линейке уровней (расположенной в левой части окна данных), масштаб которой изменяется в зависимости от различных уровней сигнала, отображаемого на диаграмме сигналов.

Совет

Линейка уровней может отображать уровни сигнала в дБ (dB) или в процентах. Чтобы выбрать один из этих вариантов, просто щелкните правой кнопкой мыши на линейке уровней и выберите подходящий пункт — Label In dB или Label In Percent.

Кроме самих кнопок масштабирования, обратите внимание на маленькую вертикальную линейку, расположенную между двумя группами этих кнопок. Путем перетаскивания ползунка этой линейки в ту или другую сторону вы можете быстро изменить масштабирование уровней или времени. Перетащите ползунок влево, чтобы уменьшить масштаб, или вправо, чтобы увеличить его.

Совет

Для быстрого изменения значения масштабирования вы можете воспользоваться командой меню View -> Zoom Level and View -> Zoom Time.

Инструмент Magnify

В дополнение к кнопкам Time Zoom In и Time Zoom Out и меню Zoom программа Sound Forge располагает инструментом Magnify. Он используется для выделения и увеличения некоторого диапазона данных. Чтобы использовать этот инструмент, сделайте следующее:

1. Выберите команду меню Edit -> Tool -> Magnify, чтобы привести инструмент Magnify в действие. Вы также можете нажать на кнопку Magnify Tool на стандартной панели инструментов (см. главу 3). А еще можно щелкнуть на переключателе инструментов редактирования, расположенном на пересечении линейки времени и линейки уровней в окне данных.

2. Перенесите курсор мыши в область диаграммы окна данных, при этом курсор должен принять форму лупы.

3. В области диаграммы курсором мыши начертите прямоугольник вокруг области, которую вы хотите увеличить (рис. 7.2).

Рис. 7.2. Используя инструмент Magnify, выделите мышью область данных, которую вы хотите увеличить

4. Отпустите кнопку мыши. Программа Sound Forge увеличит данные, находящиеся в пределах начерченного прямоугольника (причем и горизонтально по времени, и вертикально по уровню — в зависимости от параметров прямоугольника).

После этого инструмент Magnify будет все еще включен, поэтому, если хотите, вы можете им еще раз воспользоваться. Чтобы возобновить работу инструмента редактирования (о котором мы позже упомянем), выберите Edit -> Tool -> Edit. Вместо этого вы можете нажать кнопку Edit Tool на стандартной панели инструментов или щелкнуть на кнопке переключения инструментов редактирования, расположенной на пересечении линейки времени и линейки уровней в окне данных.

Выделение и инструмент Edit

Чтобы выполнять разные операции с данными вашего файла, вы должны иметь возможность эти данные выделять. В программе Sound Forge такая операция осуществляется несколькими способами. Самый распространенный способ — простое передвижение курсора мыши в пределах области диаграммы окна данных. Для этого включите инструмент Edit (в программе Sound Forge он используется для выделения данных), выбрав команду меню Edit -> Tool -> Edit. Вместо этого вы можете нажать на кнопку Edit Tool на стандартной панели инструментов или кнопку, расположенную на пересечении линейки времени и линейки уровней в окне данных. Затем просто выделите часть данных в области диаграммы окна данных.

Совет

Во время работы со стереофоническими записями вы можете выделять данные по отдельности из левого и правого каналов или же из обоих каналов сразу. Чтобы выделить данные из обоих каналов, начертите прямоугольник вокруг нужного сегмента данных в средней (по горизонтали) части диаграммы. Чтобы выделить данные только из левого канала, начертите прямоугольник вокруг сегмента данных в верхней части диаграммы. При этом обратите внимание на то, что к курсору мыши присоединилась маленькая буква "L", напоминающая, что вы работаете только с данными левого канала. Чтобы выделить данные только из правого канала, начертите прямоугольник вокруг сегмента данных в нижней части диаграммы. Так же, как и в случае с левым каналом, рядом с курсором мыши должна появиться маленькая буква "R", говорящая о том, что будет выделена только информация из правого канала.

Обратите внимание на то, что, когда вы выделяете часть данных в окне данных, значения строки состояния выделения изменяются. Первое значение показывает, где находится начало выделенной области, а второе — указывает на ее конец. Третье же значение отображает длину текущей выделенной области. Эти значения даются в том же формате, что и значения линейки времени. Изменение формата для линейки времени (для этого необходимо щелкнуть на линейке правой кнопкой мыши и выбрать подходящий формат из контекстного меню) приведет и к изменению формата для строки состояния выделения.

Существует несколько способов выделения данных, назовем два из них:

  • чтобы выделить все данные файла, выберите пункт Select All меню Edit или нажмите комбинацию клавиш <Ctrl>+<A>;
  • чтобы отключить выделение и заново его включить, выберите пункт Toggle Selection меню Special или нажмите клавишу <S>.

Диалоговое окно Set Selection

Чтобы более точно определить границы выделяемой области, вы можете ввести цифровые значения параметров Start, End и Length, используя диалоговое окно Set Selection . Вот как это делается:

1. Выберите пункт меню Edit -> Selection -> Set, чтобы открыть диалоговое окно Set Selection (рис. 7.3).

Рис. 7.3. Диалоговое окно Set Selection позволяет определить параметры выделяемой области, используя числовые значения

2. Выберите формат для значений, которые вы будете вводить, с помощью раскрывающегося списка Input format. Например, если вы хотите ввести значения в формате тактов и метрических единиц, а не в формате времени, выберите пункт Measures & Beats.

3. Если вы работаете со стереофоническим звуковым файлом, воспользуйтесь раскрывающимся списком Channel, чтобы указать программе, выделять ли данные из обоих каналов или только из одного из них.

4. Введите значение параметра Start, чтобы указать, где будет начинаться выделенная область.

5. Введите значение параметра End, чтобы указать, где выделенная область будет заканчиваться.

6. Вы также можете указать длину выделенной области, используя параметр Length, но это приведет к корректировке значения параметра End.

7. Чтобы воспроизвести данные в пределах выделенной области, нажмите на кнопку Play.

8. Закончив установку параметров выделения, нажмите на кнопку ОК. Вы увидите выделенную область в окне данных.

Изменение выделенной области

После того как вы создали выделенную область, может оказаться, что она нуждается в некоторой корректировке. Это может быть сделано с помощью простого перетаскивания мышью границы выделенной области. Изменение выделенной области выполняется одним из следующих способов.

  • Если вы хотите изменить значение начала или конца выделенной области, переместите курсор мыши на соответствующую границу области — курсор должен принять форму двунаправленной стрелки. Теперь перетащите границу вправо или влево, чтобы сделать выделенную область короче или длиннее.
  • Увеличить выделенную область можно следующим образом. Нажмите и удерживайте клавишу <Shift> на вашей клавиатуре, щелкая при этом мышью в области диаграммы за пределами выделенной области. Щелкнув справа от области, вы увеличите значение параметра End, а щелкнув слева — уменьшите значение параметра Start.

Совет

Вы можете создавать и изменять выделенные области, используя только клавиатуру. Существует 15 различных комбинаций клавиш, соответствующих командам, связанным с выделением. Чтобы посмотреть список этих комбинаций, откройте файл справки программы Sound Forge, выбрав пункт Contents and Index меню Help. Зайдите в раздел Shortcuts, затем в подраздел Keyboard Shortcuts. Выберите пункт Waveform Display Keyboard Shortcuts, затем — Selecting Data. Список перед вами.

Подгонка выделенной области

Во многих случаях вам может понадобиться подогнать начало и (или) конец выделенной области к определенному значению времени на линейке времени. С помощью мыши это сделать достаточно сложно, но программа Sound Forge располагает возможностями, полезными для разрешения этой ситуации:

  • чтобы подогнать обе границы выделенной области к ближайшему округленному значению времени на линейке времени, выберите команду меню Edit -> Selection -> Snap To Time;
  • чтобы подогнать только начало выделенной области к ближайшему округленному значению времени на линейке времени, установите указатель текущего положения на начало области, переместив туда курсор мыши (при этом курсор должен принять форму двунаправленной стрелки) и щелкните левой кнопкой мыши. После этого выберите команду меню Edit -> Selection -> Snap Edge To Time;
  • чтобы подогнать только конец выделенной области к ближайшему округленному значению времени на линейке времени, установите указатель текущего положения на конец области, переместив туда курсор мыши (при этом курсор должен принять форму двухсторонней стрелки) и щелкните левой кнопкой мыши. После этого выберите команду меню Edit -> Selection -> Snap Edge To Time.

Еще важнее бывает иметь возможность подогнать начало и (или) конец выделенной области к нулевому уровню данных на диаграмме сигналов.

Замечание

Помните описание нулевой оси, приведенное в главе 6? Любая точка на диаграмме сигналов, лежащая на нулевой оси, называется нулевым уровнем. По мере того как сигнал перемещается вверх и вниз, он пересекает нулевую ось.

Почему так важно, чтобы ваши выделенные области были выровнены с нулевым уровнем? Потому что нулевой уровень характеризуется отсутствием какого бы то ни было звука, поэтому он очень удобен при редактировании данных, например когда вы вырезаете и вставляете отдельные части файла. Если, редактируя файл, вы не используете нулевой уровень, существует возможность возникновения шумов в виде слышимых щелчков и потрескиваний. Это может случиться по разным причинам — например, если вы вырезаете отрезок данных, начинающийся с точки, содержащей звук, а не тишину. Шумы также могут возникнуть, когда вы сводите два отрезка данных — если эти отрезки не ограничены нулевым уровнем, трудно гарантировать, что они идеально сойдутся.

Чтобы подогнать выделенную область к нулевому уровню, сделайте следующее:

  • чтобы подогнать начало и конец выделенной области к ближайшим нулевым уровням, выберите команду меню Edit -> Selection -> Snap To Zero;
  • чтобы подогнать только начало выделенной области к ближайшему нулевому уровню, установите указатель текущего положения на начало области, переместив туда курсор мыши (при этом курсор должен принять форму двунаправленной стрелки), и щелкните левой кнопкой мыши. После этого выберите команду меню Edit -> Selection -> Snap Edge To Zero;
  • чтобы подогнать только конец выделенной области к ближайшему нулевому уровню, установите указатель текущего положения на конец области, переместив туда курсор мыши (при этом курсор должен принять форму двунаправленной стрелки), и щелкните левой кнопкой мыши. После этого выберите команду меню Edit -> Selection -> Snap Edge To Zero.

Совет

Если вы хотите, чтобы ваши выделенные области автоматически подгонялись к округленному значению времени или к нулевому уровню, выберите пункты Auto Snap To Time или Auto Snap To Zero меню Options.


Копирование, вырезание, вставка данных и другие операции

После того как вы создали выделенную область, вы можете совершать разные операции с данными из этой области. Наиболее распространенные из возможных операций — копирование данных в буфер (область временного хранения данных), вырезание и перемещение их из файла в буфер, удаление, подгонка и кадрирование, а также вставка данных. Выполнять эти действия следует таким образом:

  • чтобы удалить данные, выберите пункт Delete меню Edit или нажмите клавишу <Delete>;
  • чтобы удалить из файла все данные, кроме выделенных, выберите пункт Trim/Crop меню Edit или нажмите комбинацию клавиш <Ctrl>+<T>;
  • чтобы скопировать данные в буфер, выберите пункт Сору меню Edit. При этом сами данные в выделенной области остаются нетронутыми, просто будет создана их копия;
  • чтобы вырезать данные из файла и поместить их в буфер, выберите пункт Cut меню Edit , в результате чего выделенные данные будут перенесены из файла в буфер. Это то же самое, что сначала скопировать данные, а затем удалить их;
  • чтобы вставить данные из буфера в звуковой файл, установите указатель текущей позиции туда, куда вы хотите вставить необходимые данные. После этого выберите пункт Paste меню Edit . Данные из буфера будут вставлены в файл, начиная с текущей позиции. Если после текущей позиции имеются другие данные, они будут "отодвинуты" вперед, чтобы освободить место для данных из буфера.

Совет

Данные, скопированные или вырезанные из файла, посылаются в буфер. Чтобы получить статистическую информацию о данных, помещенных в буфер, выберите команду меню View -> Clipboard -> Contents. Вы сможете узнать о формате, свойствах, длине, количестве сэмплов и размере (в байтах) звуковых данных, хранящихся в буфере. Можно даже прослушать эти данные, выбрав команду меню View -> Clipboard -> Play.

Специальные возможности вставки

У вас может возникнуть ситуация, когда вставка данных из буфера в файл — это будет не совсем то, что вам нужно. Возможно, вы захотите использовать данные из буфера иначе, поэтому программа Sound Forge предоставляет пять специальных возможностей, связанных с вставкой данных из буфера.

Перезапись

Функция перезаписи позволяет заменять выделенную область файла данными из буфера. Например, если вы пытаетесь объединить несколько файлов одного содержания, но разного качества, вы можете копировать часть из одного файла и вставить в другой, заменив, таким образом, некачественную запись более качественной. Вот как работает функция перезаписи:

1. Выделите и скопируйте данные, которые вы хотите использовать для перезаписи, поместив их в буфер.

2. Выделите данные, которые вы хотите перезаписать. Эти данные могут находиться как в текущем, так и в другом файле.

3. Выберите команду меню Edit -> Paste Special -> Overwrite.

Программа Sound Forge заменит выделенную область данными из буфера. Однако существуют две ситуации, когда дела будут обстоять не совсем так. Во-первых, если выделенная область длиннее данных, находящихся в буфере, будет перезаписана только часть этой области. Оставшиеся данные останутся нетронутыми. Во-вторых, если выделенная область короче данных, находящихся в буфере, область будет перезаписана целиком, но в нее не поместится вся информация из буфера. В большинстве случаев вам потребуется сделать так, чтобы выделенная область и данные, содержащиеся в буфере, совпадали по длине.

Дублирование

Функция дублирования позволяет многократно вставлять данные в выделенную область. Например, предположим, что у вас есть партия ударных инструментов длиной в одну метрическую единицу и вы хотите заполнить этой партией еще четыре единицы. В этом случае, воспользовавшись функцией дублирования, вы легко справитесь с задачей. Вот как работает эта функция:

1. Выделите и копируйте в буфер данные, которые вы хотите использовать для дублирования.

2. Создайте новую выделенную область в текущем или новом файле и убедитесь, что длина этой области является кратной длине данных, которые вы собираетесь дублировать. Таким образом, если вы хотите вставить данные, хранящиеся в буфере, четыре раза, новая выделенная область должна быть в четыре раза длиннее этих данных.

3. Выберите команду меню Edit -> Paste Special -> Replicate, чтобы открыть диалоговое окно Replicate (рис. 7.4).

Рис. 7.4. Функция дублирования позволяет многократно вставлять данные, содержащиеся в буфере

4. Если длина новой выделенной области не является кратной длине данных из буфера, эта область может быть заполнена данными полностью или частично. Другими словами, если длина данных в буфере равна одной метрической единице, а длина выделенной области равна трем с половиной метрическим единицам, часть в конце области может быть не заполнена. Если в диалоговом окне Replicate вы выберете переключатель Whole copies, для заполнения выделенной области будут использованы только целые копии данных из буфера. То есть в нашем случае только три копии данных будут вставлены в выделенную область. Но если вы выберете переключатель Copy partials, будет заполнена вся выделенная область. Для нас это означает, что первые три метрических единицы выделенной области будут заполнены целыми копиями данных из буфера, а последняя часть области будет содержать только половину данных. Выберите наиболее подходящий для вас пункт.

5. Нажмите на кнопку ОК.

Программа Sound Forge произведет вставку данных из буфера столько раз, сколько это будет необходимо для того, чтобы заполнить выделенную область.

Вставка в новое окно

Функция вставки в новое окно — простейшая из всей группы функций вставки. Чтобы использовать эту функцию, выделите и скопируйте данные в буфер. Затем выполните команду меню Edit -> Paste Special -> Paste To New.

Программа Sound Forge извлечет данные из буфера и поместит их в новое окно данных, готовое к редактированию и сохранению в качестве независимого звукового файла.

Сведение

Функция сведения позволяет сводить данные из буфера с данными в открытом звуковом файле. Например, если вы хотите наложить вокальную партию на фоновую музыку, вы можете использовать эту функцию. Вот как она работает:

1. Выделите и скопируйте в буфер данные, которые вы хотите использовать для сведения.

2. В том файле, в который вы собираетесь вставить данные из буфера, установите указатель текущей позиции или создайте выделенную область, чтобы определить, куда именно эти данные требуется поместить.

3. Выберите команду меню Edit -> Paste Special -> Mix, чтобы открыть диалоговое окно Mix (рис. 7.5).

Рис. 7.5. Функция сведения позволяет сводить данные из буфера с данными в открытом звуковом файле.

4. Если в файле, в который вы хотите вставить данные из буфера, вы создадите выделенную область (а не установите указатель текущей позиции), можно будет определить, в какой точке начнется сведение — в начале или в конце выделенной области. Выберите один из двух переключателей из группы Start mix at: или Start selection или End selection.

5. Отрегулируйте движки Volume в группах Source: Clipboard и Destination: . Эти настройки определяют соотношение громкостей данных из буфера и из файла после сведения. Вы можете проверить, как будет звучать эта запись после сведения, нажав на кнопку Preview.

6. После установки громкостей нажмите на кнопку Preview еще раз и проверьте, не становится ли звук глухим. Это может произойти из-за подавления фазы, которая происходит, когда громкость одного сигнала уменьшается, а громкость другого увеличивается, причем одновременно на одну и ту же величину. Таким образом, два сигнала перекрывают друг друга, в результате чего смешанный сигнал звучит глухо. Если это произошло, попробуйте установить флажок Invert data для одного из сигналов, но не для обоих сразу. Это приводит к инвертированию сигнала и обычно помогает разрешить проблему.

7. Если инвертирование сигнала не помогает, попробуйте использовать параметр Tune (-500 to 500 ms). Он позволяет немного изменить позицию начала сведения в файле. Это приведет к тому, что данные из буфера будут наложены на данные из файла чуть дальше, после текущей точки сведения или перед ней. В результате два сигнала не будут точно выровнены и их громкости будут изменены не одновременно, а это позволит избежать подавления фазы. Чтобы отрегулировать значение параметра Tune (-500 to 500 ms), введите любое значение (в миллисекундах) от —500 до +500. Используя кнопку Preview, проверьте, как будет звучать сведенный вариант.

8. Если вы хотите, чтобы громкость данных файла изменилась только в той его части, где произойдет сведение, задействуйте флажок Apply destination volume to overlapping area only. В противном случае значение громкости файла, которое вы установили с помощью ползунка Volume в группе Destination:, будет применено для всего файла. В большинстве случаев этот флажок стоит установить.

9. Если вы активизировали флажок Apply destination volume to overlapping area only, можно также установить автоматическое плавное изменение уровня сигнала перед сведенным участком данных и после него. Эта возможность очень полезна при сведении вокальной партии и фоновой музыки. Когда вокальная партия начинается, фон приглушается, а когда она заканчивается, уровень громкости фона восстанавливается. Чтобы воспользоваться функцией изменения уровня сигнала, установите флажок Pre/Post-fade destination edges (0 to 5 sees). Затем укажите, в течение какого времени звук должен затухать перед участком микширования, а потом усиливаться по окончании этого участка. Например, выберите пункт Fast Duck (-6 dB) из раскрывающегося списка Name диалогового окна Mix.

Замечание

Изменение уровня сигнала бывает двух типов. Плавное увеличение громкости обычно называется усилением звука, а ее уменьшение — затуханием. В приведенном выше примере затухание фоновой музыки в течение участка микширования и ее усиление по окончании этого участка обычно называется погружением.

10. Нажмите на кнопку ОК.

Программа Sound Forge сведет данные из буфера и из файла в соответствии с произведенными установками.

Функция Paste Crossfade

Функция Paste Crossfade подобна функции Paste Mix в том, что она позволяет вам смешивать данные из буфера обмена с данными открытого аудиофайла. Однако функция Paste Crossfade несколько шире. Она представляет собой специальный вид микширования, который может оказаться удобным, в том случае, если вы хотите сделать плавный переход от одного стиля музыки к другому или от одного инструмента к другому. Она особенно полезна, когда вы добавляете звук к видеоданным: вы можете плавно перейти от одного типа фоновой музыки к другому в соответствии с изменением сцены. Конечно, для нее существует и множество других применений.

Когда вы применяете эту функцию к двум фрагментам звука, она обычно работает следующим образом: при воспроизведении полученного смешанного звука громкость одного из исходных фрагментов нарастает, а другой фрагмент затихает. Эти переходы могут быть быстрыми или медленными, а также могут осуществляться на различных уровнях, независимых друг от друга. Все зависит от того, как вы используете эту функцию. Чтобы применить ее, сделайте следующее:

1. Выделите и скопируйте данные, которые вы хотите использовать для микширования, чтобы они оказались в буфере обмена.

2. Установите текущую позицию или создайте выделение в другом открытом файле, чтобы указать, куда будет помещен смикшированный звук.

3. Выполните команду меню Edit -> Paste Special -> Crossfade, чтобы открыть диалоговое окно Crossfade (рис. 7.6).

4. Если в файле, в который вы хотите вставить данные из буфера, вы создадите выделенную область (а не установите указатель текущей позиции), можно будет определить, в какой точке начнется сведение — в начале или в конце выделенной области. Выберите один из двух переключателей из группы Start crossfade at: или Start of selection, или End of selection.

5. Отрегулируйте положение четырех ползунков: в группе Source — ползунки Start level и End level, в группе Destination:— ползунки Start level и End level. Они устанавливают громкости обоих используемых записей в начале и в конце перехода. Например, если вы хотите, чтобы во время перехода данные из буфера усиливались, а данные из файла затухали, установите следующие значения: в первой группе значение Start level — -Inf. dB, a End level — 0,0 dB; во второй группе — Start level — 0,0 dB и End level — -Inf. dB.

Рис. 7.6. Функция перехода аналогична функции сведения, за исключением того, что она позволяет одновременно накладывать затухание на одну запись, а усиление — на другую

6. Если произошло подавление фазы, используйте параметр Tune (о нем мы рассказывали в разделе данной главы, посвященном функции сведения).

7. Нажмите на кнопку ОК .

Программа Sound Forge сведет две записи и создаст переход между ними в соответствии с произведенными установками.


Ошибки при редактировании

Программа Sound Forge предоставляет функцию отмены (Undo), позволяющую аннулировать любую операцию, произведенную во время редактирования звукового файла. Скорее всего, эта функция вам знакома, поскольку она включена в большинство программ, связанных с обработкой данных, например в программы редактирования текста. Таким образом, если при редактировании вы сделали ошибку, просто выберите команду меню Edit -> Undo или нажмите комбинацию клавиш <Ctrl>+<Z>. Если после отмены какой-либо операции вы решили, что этого совсем не следовало делать, вы можете отменить и действие функции отмены, выбрав команду меню Edit -> Redo или нажав комбинацию клавиш <Ctrl>+<Shift>+<Z>.

Программа Sound Forge располагает еще более мощным средством исправления ошибок — функцией Undo/Redo History. Она запоминает последовательность действий, произведенных вами при редактировании звукового файла, и позволяет отменить и повторно выполнить каждое из этих действий от начала до конца (или от конца к началу) текущей сессии редактирования. Каждое окно данных снабжено своим собственным журналом действий, поэтому можно отменять и повторно выполнять действия независимо для каждого из файлов, с которыми вы одновременно работаете.

Журнал действий для каждого окна данных не сохраняется, поэтому, закрыв какое-либо из этих окон, вы теряете возможность отменять и повторно выполнять действия, совершенные с соответствующим звуковым файлом.

Чтобы получить доступ к журналу действий, выберите команду меню View -> Undo/Redo History, после чего откроется диалоговое окно Undo/Redo (рис. 7.7).

Рис. 7.7. Диалоговое окно Undo/Redo

В верхней части этого окна находится список действий, которые можно отменить. В нижней части окна перечислены действия, которые можно повторно выполнить. Каждая запись в этих списках содержит описание действия и диапазон времени в формате часы:минуты:секунды:миллисекунды, обозначающий часть файла, к которой было применено данное действие. В дополнение к этому каждая запись снабжена маленькой кнопкой воспроизведения. Нажав на нее, вы услышите, как звучит ваша запись на определенном этапе обработки. Чтобы вернуться к какому-либо этапу из журнала действий, сделайте двойной щелчок мышью на соответствующей записи. Окно Undo/Redo можно оставить открытым на время работы с файлом.

Функция отмены и сохранения предоставляет еще несколько полезных возможностей, а именно:

  • если вы не хотите иметь возможность отменять и повторно выполнять действия, можете отключить функцию Undo/Redo для текущего окна данных, выбрав пункт меню Edit -> Disable Undo/Redo;
  • если вы хотите отменить все действия, совершенные в текущем окне данных, выполните команду меню Edit -> Undo All;
  • если вы хотите очистить журнал действий для текущего окна данных (таким образом теряя возможность отмены действий, но освобождая некоторое количество оперативной памяти и дискового пространства), выполните команду меню Special -> Undo/Redo History -> Clear;
  • если вы хотите очистить журнал действий для всех открытых окон данных, выполните команду меню Special -> Undo/Redo History -> Clear All.

Совет

Вы можете изменить количество действий, содержащихся в журнале действий, чтобы освободить часть оперативной памяти и дискового пространства. Просто выберите пункт Preferences меню Options, чтобы открыть диалоговое окно Preferences. Щелкните на вкладке Editing. Установите флажки Limit number of undo buffers to и Limit number of redo buffers to. Введите максимальное число действий (от 0 до 999), которое может содержать журнал действий. Нажмите на кнопку ОК.

Инструмент Pencil

Одним из основных инструментов редактирования данных в программе Sound Forge является инструмент Pencil. Он позволяет вам "рисовать" звуковые данные в файле. Но не подумайте, что инструмент Pencil дает возможность создавать новые звуки или что-нибудь в этом роде. Главное его предназначение — выполнять точную корректировку ваших звуковых данных. Например, если в вашей записи обнаружился какой-нибудь шум, вы можете удалить его с помощью инструмента Pencil. Вот пример того, как можно использовать этот инструмент:

1. Найдите шум в файле на слух или воспользуйтесь инструментом Find, описанным в главе 5.

2. Увеличьте масштаб диаграммы в области шумов. Обычно на диаграмме помехи отображаются в виде резких искажений кривой, как показано на рис. 7.8.

Рис. 7.8. Шумы обычно выглядят как резкие выступы кривой на диаграмме сигналов

Замечание

Инструмент Pencil работает, только если масштаб диаграммы равен 1:32 или больше. Убедитесь, что используется именно этот масштаб. Возможно, вы захотите использовать масштаб 1:1 для более легкого и точного редактирования.

3. Включите инструмент Pencil, выбрав команду меню Edit -> Tool -> Pencil

или нажав на кнопку Pencil Tool на стандартной панели инструментов.

4. Наведите курсор мыши на нулевую ось диаграммы сигналов, непосредственно перед тем местом, где имеется шум (рис. 7.9).

Рис. 7.9. Чтобы удалить шум, поместите курсор на нулевую ось диаграммы сигналов прямо перед помехой

5. Нажмите левую кнопку мыши и, не отпуская ее, начертите кривую, подобную тем, что расположены до или после области шума (рис. 7.10).

Рис. 7.10. Удалите шум на диаграмме, начертив на его месте более сглаженную кривую

Совет

Для более точного исправления используйте стрелки на вашей клавиатуре, удерживая левую кнопку мыши.

6. Начертив кривую, отпустите левую кнопку мыши.

Во время воспроизведения файла проверьте, исчез ли шум. Если нет, отмените действие инструмента Pencil и попробуйте еще раз.


Глава 8. Функции обработки
  • Функции обработки
  • Предварительные установки
    • Загрузка набора настроек
    • Сохранение набора настроек
    • Удаление набора настроек
    • Менеджер настроек
    • Сохранение пакета настроек в файле
    • Открытие файла пакета настроек
  • Подготовка звуковых данных к редактированиюt
    • Удаление смещения по оси амплитуды
    • Изменение разрядности
    • Изменение частоты сэмплирования
  • Работа с фрагментами тишины
    • Удаление фрагментов тишины
    • Вставка тишины
    • Приглушение звука
  • Изменение громкости звука
    • Функция Volume
    • Применение усиления и затухания звука
    • Сложное постепенное изменение громкости
    • Нормализация звука
    • Воспринимаемая громкость
  • Работа со стереофоническими записями
    • Изменение каналов
    • Панорамирование
    • Увеличение и уменьшение стереополя
    • Обработка боковых записей
  • Эквализация
    • Графическая эквализация
    • Функция Parametric EQ
    • Функция Paragraphic EQ
  • Воспроизведение в обратном направлении
  • Переворачивание данных
  • Изменение длины


Функции обработки

Из главы 7 вы узнали о некоторых важнейших возможностях программы Sound Forge, связанных с редактированием, включая работу в окне данных (и предоставляемые им сервисы), функции копирования, вырезания, вставки, удаления звуковых данных и т. д. И хотя это очень мощные функции, вы, наверное, спрашиваете себя: и это все? Ничего подобного! В дополнение к этому базовому инструментарию в состав программы Sound Forge входит обширный комплекс дополнительных функций редактирования. Их можно использовать для изменения таких параметров аудиозаписи, как амплитуда (громкость), эквализация (частотный спектр), длина и т. п. Вот о чем мы расскажем в этой главе:

  • предварительные установки и использование менеджера установок;
  • операции с тишиной в звуковых данных;
  • управление качеством звуковых данных;
  • изменение громкости звуковых данных;
  • эквализация;
  • разные средства управления звуковыми данными.

Предварительные установки

Работая со многими функциями редактирования в программе Sound Forge, вы всегда оперируете большим количеством параметров. Рано или поздно вам может понадобиться сохранить подобранную вами комбинацию установок для использования в будущем. Функция предварительных установок, содержащаяся в программе Sound Forge, позволяет это сделать. Предварительные установки дают возможность запоминать и повторно загружать значения параметров какой-либо функции. Они применяются в отдельных диалоговых окнах функций, таких как окно Mix - Funky saxophone riff (рис. 8.1), о котором мы рассказывали в главе 7.

Рис. 8.1. Доступ к предварительным установкам осуществляется из отдельных диалоговых окон функций, таких, как окно Mix

Загрузка набора настроек

В верхней части диалогового окна вы заметите раскрывающийся список Name. Этот параметр позволяет вам загрузить набор настроек в текущем диалоговом окне для текущей функции. Чтобы загрузить набор настроек, просто выберите его имя из раскрывающегося списка Name (рис. 8.2).

Сохранение набора настроек

Если вы хотите сохранить текущие значения параметров, сделайте следующее:

1. Нажмите на кнопку Save As, чтобы открыть диалоговое окно Save Preset (рис. 8.3).

2. Введите имя нового набора настроек.

3. Нажмите на кнопку ОК.

Обратите внимание, что имя вашего нового набора настроек теперь содержится в раскрывающемся списке Name.

Рис. 8.2. Раскрывающийся список Name позволяет вам загрузить набор настроек

Рис. 8.3. Используйте диалоговое окно Save Preset, чтобы сохранить текущие значения параметров

Удаление набора настроек

Вы также можете удалять набор настроек из раскрывающегося списка Name. Просто выберите набор настроек из этого списка, а затем нажмите кнопку Delete.

Замечание

Вы не можете удалять наборы настроек, заданные по умолчанию программой Sound Forge .

Менеджер настроек

Если вы будете работать с программой Sound Forge регулярно, то, скорее всего, у вас накопится целая коллекция установок для разных функций обработки и редактирования. Что, если вы захотите обменяться установками со знакомым пользователем программы Sound Forge? С другой стороны, вам может понадобиться установить программу Sound Forge на другом компьютере и перенести туда все ваши установки. Также полезно хранить резервную копию вашей коллекции установок. Все это говорится к тому, что менеджер настроек программы Sound Forge позволит справиться со всеми перечисленными задачами. Чтобы воспользоваться менеджером настроек, выберите команду Tools -> Preset Manager, чтобы открыть диалоговое окно Preset Manager (рис. 8.4).

Рис. 8.4. Диалоговое окно менеджера настроек

В верхней части этого диалогового окна находится поле Presets, в котором перечислены все наборы настроек, имеющихся в текущей установке программы Sound Forge. Первоначально в поле Presets содержатся названия меню Process, Effects, Tools и DirectX. Щелкните на знаке плюс рядом с одним из названий, и вы увидите список функций, доступных из данного меню. Щелкните на знаке плюс рядом с одним из имен функций, чтобы увидеть список установок, доступных для данной функции (рис. 8.5).

Рис. 8.5. В поле Presets содержатся имеющиеся наборы установок

В нижней части диалогового окна Preset Manager находится поле Preset package contents, в котором находится список наборов настроек, подлежащих сохранению. Изначально поле Preset package contents пустое, но вы без труда можете добавить в него любые установки, после чего сохранить их в виде файла, предназначенного для сохранения резервной копии или совместной работы.

Сохранение пакета настроек в файле

Чтобы сохранить список наборов настроек, сделайте следующее:

1. Выберите установку из поля Presets, щелкнув по ней мышкой.

2. Добавьте установку в поле Preset package contents, нажав кнопку Add (на ней изображен знак плюс — рис. 8.6).

3. Чтобы удалить набор настроек из поля Preset package contents, нажмите на кнопку Delete (на ней изображен большой красный крест), расположенную рядом с кнопкой Add.

4. Повторяйте шаги 1—3 до тех пор, пока все наборы настроек, которые вы хотите сохранить, не окажутся в поле Preset package contents.

5. Нажмите на кнопку Save As, чтобы открыть диалоговое окно Save Preset Package (рис. 8.7).

Рис. 8.6. Кнопка Add позволяет вам добавить набор настроек в поле Preset package contents

Рис. 8.7. Сохраните ваши установки, используя диалоговое окно Save Preset Package

6. Выберите папку, в которую будет сохранен файл пакета установок, используя раскрывающийся список Save in.

7. Введите имя файла пакета установок в поле File name.

8. Если вы хотите добавить в файл пакета установок какую-либо описательную информацию (например, название, имя автора, имя обладателя авторских прав, комментарии), установите флажок Save Summary Information in the preset package и введите соответствующую информацию.

9. Нажмите на кнопку Save.

Выбранные вами наборы настроек будут сохранены в файле пакета настроек (sfz) в папке, которую вы указали. Теперь вы сможете использовать этот файл как резервную копию или даже передать его другому пользователю программы Sound Forge. Естественно, у вас должна быть возможность открыть этот файл в будущем. Менеджер настроек позволяет это делать.

Открытие файла пакета настроек

1. В менеджере установок нажмите на кнопку Open, чтобы открыть диалоговое окно Open (рис. 8.8).

Рис. 8.8. Откройте файл пакета установок, используя диалоговое окно Open

2. Найдите файл пакета настроек, который вы хотите открыть, и нажмите на кнопку Open, чтобы открыть диалоговое окно Preset Package (рис. 8.9).

Рис. 8.9. Используйте диалоговое окно Preset Package, чтобы выбрать настройки, которые нужно открыть

3. Из списка наборов настроек выберите те, которые вы хотите импортировать в текущую установку программы Sound Forge, отметив флажком слева от имени каждый набор. Первоначально будут выделены все наборы настроек, так что, если вы не хотите импортировать какие-либо из них, просто снимите соответствующие флажки.

4. Нажмите на кнопку ОК.

Выделенные вами наборы настроек из файла пакета настроек будут добавлены в текущую установку программы Sound Forge. В следующий раз, когда вы будете использовать функцию, к которой относились те или иные наборы настроек, вы увидите их в раскрывающемся списке Name.

Совет

Работая с менеджером настроек, вы можете корректировать параметры любого набора настроек, содержащегося в списке поля Presets. Просто выберите необходимый набор настроек и нажмите на кнопку Settings. В результате этого откроется диалоговое окно соответствующей функции. Скорректируйте параметры данной функции, а затем сохраните набор настроек — как это делается, мы объясняли выше в этой главе.


Подготовка звуковых данных к редактированию

В главе 6 мы рассказывали о том, как удалить смещение по оси амплитуды, установить разрядность и частоту сэмплирования для нового звукового файла, который вы собираетесь записать. Но что если у вас есть готовый файл, с которым нужно проделать те же операции — удалить смещение по оси амплитуды, изменить частоту сэмплирования и разрядность? Программа Sound Forge содержит три отдельных функции, предназначенных именно для этих целей.

Удаление смещения по оси амплитуды

Выше (в главе 6) говорилось о том, что качество записи напрямую зависит от используемой вами звуковой карты. Во многих случаях между звуковой картой и устройством ввода могут возникать конфликты (особенно, если вы используете дешевую карту, такую как Sound Blaster). В этом случае излишек потока добавляется к входящему сигналу и конечная диаграмма сигналов отклоняется от нулевой оси. Это явление известно как смещение по оси амплитуды. Чтобы удалить из существующего звукового файла смещение по оси амплитуды, проделайте следующие действия:

1. Выделите в вашем звуковом файле часть данных, из которой вы хотите удалить смещение по оси амплитуды. Если вы хотите обработать весь файл, то либо вообще не выделяйте данные, либо выделите их полностью, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> DC Offset, чтобы открыть диалоговое окно DC Offset (рис. 8.10).

Рис. 8.10. Удалите смещение по оси амплитуды из вашего звукового файла, используя диалоговое окно DC Offset

3. Если вы хотите, чтобы программа Sound Forge автоматически выявила и удалила все имеющиеся смещения по оси амплитуды, выберите переключатель Automatically detect and remove.

4. Если вам известна величина смещения по оси амплитуды в вашем файле и вы хотите удалить его вручную, выберите переключатель Adjust DC offset by (-32,768 to 32,767). Затем введите число сэмплов, на которое должна быть выровнена диаграмма сигналов по нулевой оси. Например, если смещение по оси амплитуды вашего файла равно 95, введите значение —95, чтобы сумма двух чисел равнялась нулю, т. е. отсутствию смещения по оси амплитуды.

Совет

Чтобы выяснить величину смещения по оси амплитуды в звуковом файле, выберите команду меню Tools -> Statistics, чтобы открыть диалоговое окно Statistics. В нем содержится информация о разных параметрах звукового файла, в том числе и о смещении по оси амплитуды.

5. Если вы работаете с очень длинным файлом, установите флажок Compute DC offset from first 5 seconds only. Этим вы заставите программу Sound Forge проверить лишь первые 5 секунд вашего файла для выяснения величины смещения по оси амплитуды.

Предупреждение

Обычно функция Compute DC offset from first 5 seconds only работает нормально. Однако, если ваш файл начинается с длительного промежутка тишины или с плавного усиления звука, вам следует отключить эту срункцию. В данных обстоятельствах, если функция будет включена, программа Sound Forge не сможет корректно определить величину смещения по оси амплитуды.

6. Нажмите на кнопку ОК.

После этого смещение по оси амплитуды будет удалено либо в пределах выделенной области, либо во всем файле.

Совет

Если вы работаете с файлом и не знаете, содержит ли он смещение по оси амплитуды, всегда используйте функцию DC Offset перед началом любых других операций, связанных с редактированием. Если вы этого не сделаете, смещение по оси амплитуды может послужить причиной появления шумов и других звуковых аномалий в вашем файле.

Изменение разрядности

Во многих случаях вам может понадобиться изменить значение разрядности существующего звукового файла. Например, если вы записали и отредактировали файл, используя разрядность 24 бита, но хотите впоследствии записать этот файл на компакт-диск, вам необходимо будет снизить разрядность до 16 битов, поскольку аналоговый компакт-диск может использовать только такую разрядность. Чтобы изменить значение разрядности существующего звукового файла, сделайте следующее:

1. Выберите команду меню Process -> Bit-Depth Converter, чтобы открыть диалоговое окно Bit-Depth Converter (рис. 8.11).

Рис. 8.11. Конвертер разрядности позволяет изменять разрядность звукового файла

2. Выберите новую разрядность для вашего звукового файла, используя раскрывающийся список Bit-depth.

Совет

Если вы повысите разрядность вашего файла, это не повлечет улучшения его качества. Например, если у вас был 8-битный звуковой файл и вы повысили его разрядность до 16 битов, он все равно будет звучать как 8-битный, поскольку именно с такой разрядностью он был записан. Но есть, по крайней мере, один плюс, связанный с повышением разрядности файла, — увеличится его разрешение, и дальнейшее редактирование и обработка этого файла не приведут к появлению шумов. Например, если вы хотите отредактировать 8-битный звуковой файл, не помешает повысить его разрядность. С другой стороны, если вы понизите разрядность звукового файла, это как раз понизит его качество, поэтому если вы решили это сделать, не забудьте создать резервную копию оригинала. Например, если у вас есть 24-битный звуковой файл и вы хотите снизить его разрядность до 16 битов, чтобы иметь возможность записать его на компакт-диск, обязательно сохраните копию 24-битной версии для последующего редактирования и обработки.

3. Выберите вариант из раскрывающегося списка Dither. Этот параметр позволяет определить, сколько дополнительного шума вы хотите наложить на сигнал, чтобы скрыть шум квантования (см. Замечание ниже), который возникает из-за преобразования разрядности. В случае повышения разрядности стоит выбрать для этого параметра значение None. Если же вы собираетесь понизить разрядность, вам придется поэкспериментировать с этим параметром, чтобы выяснить, какое его значение работает лучше.

Замечание

Когда вы преобразуете аналоговый звуковой сигнал в цифровую форму, этот сигнал определяется с использованием конечного диапазона чисел. Чем ниже разрядность файла, тем меньшие числа выделяются для определения сигнала, что приводит к более высокому уровню шумов, В случае понижения разрядности этот процесс может привести к появлению так называемого шума квантования. Этот шум образуется из-за того, что числа, представляющие сигнал в файле с большей разрядностью, должны быть округлены до значений, соответствующих меньшей разрядности. Чтобы скрыть шум квантования, вы можете добавить в данные дополнительный шум. Может показаться странным, что для того чтобы понизить слышимые шумы, нужно добавить дополнительный шум, но он помогает смягчить, так сказать, "шероховатости" сигнала, характеризующие шум квантования.

4. Выберите значение параметра Noise shaping. Он позволяет переместить возможные шумы в область более высоких частот, которые менее доступны для человеческого слуха. Вам придется поэкспериментировать с этим параметром, чтобы найти наиболее подходящее для вашего файла значение.

Совет

Если частота сэмплирования вашего файла ниже 44 100 Гц, следует выбрать для параметра Noise shaping значение Off. Эта необходимость объясняется тем, что файлы с низкими частотами сэмплирования также характеризуются более низким частотным диапазоном. Использование параметра Noise shaping для подобных файлов может привести к увеличению уровня шума.

5. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

Совет

По умолчанию функция Preview воспроизводит только первые 4 секунды из выделенных данных. Вы можете изменить это время, выбрав команду меню Options -> Preferences, чтобы открыть диалоговое окно Preferences. На вкладке Previews измените значение параметра Limit Preview To, введя желаемое количество секунд (от 1 до 600). Вы также можете указать функции Preview, проигрывать ли измененную область непрерывно, уменьшать ли ее громкость в конце и реагировать ли на изменения значения параметров, совершенные во время воспроизведения. Вы также можете заставить эту функцию проигрывать отрывки данных, находящиеся перед и после выделенной области, чтобы иметь возможность оценить разницу между обработанными и необработанными частями файла. Чтобы воспользоваться этими возможностями, просто установите соответствующие флажки и введите значения в числовые поля. Они не требуют дополнительного пояснения.

6. Нажмите на кнопку ОК.

Разрядность вашего звукового файла будет изменена в соответствии с заданными значениями параметров.

Изменение частоты сэмплирования

Как и в случае с разрядностью, бывают ситуации, когда необходимо изменить частоту сэмплирования существующего звукового файла. И снова на ум приходит пример с записью звуковых данных на компакт-диск. Аналоговый компакт-диск может работать только с частотой сэмплирования, равной 44 100 Гц. Чтобы изменить частоту сэмплирования звукового файла, сделайте следующее:

1. Выберите команду меню Process -> Resample, чтобы открыть диалоговое окно Resample (рис. 8.12).

Рис. 8.12. Функция Resample позволяет изменить частоту сэмплирования звукового файла

2. Определите новую частоту сэмплирования, используя параметр New sample rate (2.000 to 192.000 Hz).

Совет

Если вы повысите частоту сэмплирования вашего файла, это не повлечет улучшения его качества. Например, если у вас был звуковой файл с частотой сэмплирования 22 кГц, а вы повысили частоту до 44,1 кГц (чтобы записать этот файл на компакт-диск), он все равно будет звучать как 22-килогерцевый, поскольку именно с этой частотой он был записан. Но есть, по крайней мере, один плюс, связанный с повышением частоты сэмплирования файла — в результате этого увеличится разрешение файла и дальнейшие его редактирование и обработка не приведут к появлению шумов. Например, если вы хотите отредактировать 22-килогерцевый звуковой файл, не помешает повысить его частоту сэмплирования. С другой стороны, если вы понизите частоту сэмплирования звукового файла, это понизит его качество, поэтому, если вы все-таки решили это сделать, не забудьте создать резервную копию оригинала. Например, если у вас есть 48-килогерцевый звуковой файл и вы хотите снизить его частоту сэмплирования до 44,1 кГц, чтобы иметь возможность записать его на компакт-диск, обязательно сохраните копию версии с частотой 48 кГц для последующего редактирования и обработки.

3. Выберите значение параметра Interpolation accuracy (I to 4). Он позволяет определить точность процесса преобразования частоты сэмплирования. Низкое значение означает быструю, но менее точную обработку. Высокое значение подразумевает более медленную, но более точную обработку. Если длина вашего файла не очень велика, стоит выбрать значение, равное 4.

4. Если вы понижаете частоту сэмплирования, обязательно установите флажок Apply an anti-alias filter during resample. Это исключает возможность преобразования высокочастотных данных на входе в шумы на выходе, т. е. при применении более низкой частоты сэмплирования.

5. Если вы хотите, не внося изменения в данные, просто изменить скорость воспроизведения, установите флажок Set the sample rate only (do not re-sample). Использование этой функции повлечет за собой также изменение высоты тона. Ее стоит использовать, если кто-нибудь дал вам файл с неправильной скоростью воспроизведения.

6. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

7. Нажмите на кнопку ОК.

Частота сэмплирования вашего файла будет изменена в соответствии с заданными значениями параметров.

Совет

Когда вы понижаете разрядность или частоту сэмплирования, вы теряете высокочастотные данные в вашем файле. Это может привести к тому, что звук станет тусклым. Чтобы не допустить этого, попробуйте обработать файл с помощью функции Smooth/Enhance программы Sound Forge. Выделите часть данных, которую вы хотите обработать, и выберите команду меню Process -> Smooth/Enhance, чтобы открыть диалоговое окно Smooth/Enhance. Затем переместите ползунок параметра Operation. Вам придется поэкспериментировать, чтобы найти подходящее значение. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения. Если вы удовлетворены услышанным, нажмите на кнопку ОК.


Работа с фрагментами тишины

Программа Sound Forge предоставляет несколько функций, позволяющих управлять фрагментами тишины в звуковых данных. Бывают случаи, когда из вашего файла желательно удалить тишину, например неудобные паузы между вокальными пассажами или репликами диалога. Напротив, иногда в данные бывает полезно добавить фрагменты тишины — к примеру, чтобы создать паузу между музыкальными фразами. Справиться с этими задачами вам помогут функции Auto Trim/Crop, Insert Silence и Mute.

Удаление фрагментов тишины

Функция Auto Trim/Crop автоматически удалит фрагменты тишины из звукового файла путем поиска в данных определенных характеристик, которые вы укажете. Чтобы обнаружить эти характеристики, функция Auto Trim/Crop использует цифровой шлюз сигнала. В зависимости от установленных вами параметров, шлюз сигнала открывается, когда функция Auto Trim/Crop обнаруживает часть данных, уровень сигнала (громкость) которой выше, чем тот, который вы указали. Эта часть данных расценивается как приемлемая и пропускается. Когда уровень сигнала падает ниже указанного вами, шлюз сигнала расценивает такую часть как конец секции (или начало фрагмента тишины) и закрывается. Затем функция Auto Trim/Crop ищет следующую секцию, имеющую достаточный уровень сигнала, и удаляет все данные между двумя секциями. Таким образом, обрабатывается вся выделенная вами область или весь файл.

Чтобы автоматически удалить фрагменты тишины, используя функцию Auto Trim/Crop, проделайте следующее:

1. Выделите в вашем файле часть данных, из которой вы хотите удалить фрагменты тишины. Если вы хотите обработать файл полностью, то либо ничего не выделяйте, либо выделите весь файл, выбрав команду меню Edit -> Select All.

2. Выберите команду меню Process -> Auto Trim/Crop, чтобы открыть диалоговое окно Auto Trim/Crop (рис. 8.13).

Рис. 8.13. Функция Auto Trim/Crop позволяет вам удалить фрагменты тишины из звукового файла

3. Выберите тип обработки, используя раскрывающийся список Function Тип Keep edges outside of the selection удаляет фрагменты тишины внутри выделенной области но не затрагивает данные вне этой области. Тип Remove edges outs.de of the selection позволяет удалить фрагменты тишины в границах выделенной области, а также все данные (даже отличные от тишины) находящиеся за ее пределами. Этот тип может быть полезен в случае, если вы хотите сохранить только определенную часть данных и удалить остальное. Тип Remove Silence between phrases (creates regions) удаляет фрагменты тишины между фразами (например, в вокальном диалоге) в пределах выделенной области или целого файла. При этом для каждой такой фразы создается отдельная область (об областях мы рассказывали в главе 5). Используйте тип обработки Remove data beyond loop points, чтобы удалить все данные (а не только тишину) после выбранной петли в звуковом файле (про петли подробно будет рассказано в главе 13). Тип Remove data from start and limit file length удаляет тишину в начале звукового файла, а также обрезает конец файла в определенной точке, ограничивая таким образом длину файла.

4. Установите значение параметра Attack threshold (-Inf. to 0 dB) передвигая его ползунок вверх и вниз. Этот параметр определяет уровень громкости звуковых данных, необходимый для открытия шлюза сигнала и соответственно, идентификации данных как приемлемых и определения стартовой точки отрезка. Единственный случай, когда вам не нужно устанавливать значение этого параметра - если вы используете тип обработки Remove data beyond loop points.

5. Установите значения параметра Release threshold (-Inf. to 0 dB), передвигая соответствующий ползунок вверх и вниз. Этот параметр определяет уровень громкости звуковых данных, необходимый для закрытия шлюза сигнала и, соответственно, идентификации конечной точки отрезка. Единственный случай, когда вам не нужно устанавливать значение этого параметра — если вы пользуетесь типом обработки Remove data beyond loop points.

6. Если вы хотите, чтобы части вашего файла после обработки звучали достаточно ровно, стоит применить мягкое затухание и усиление звука на границах отрезков. Чтобы сделать так, просто укажите количество миллисекунд в полях параметров Fade in (0 to 5,000 ms) и Fade out (0 to 5,000 ms) с помощью расположенных сбоку счетчиков. Значение, поставленное по умолчанию и равное 20 миллисекундам, обычно дает хорошие результаты. Если вы используете тип обработки Remove data beyond loop points, вам не требуется устанавливать эти параметры.

7. Если вы выбрали тип обработки Remove silence between phrases (creates regions), вам понадобится установить значение параметра Minimum inter-phrase silence (0.1 to 3.0 seconds). Он указывает функции Auto Trim/Crop, сколько секунд (от 0,1 до 3) тишины должно быть между фразами, чтобы можно было создать новую область. Например, если вы удаляете фрагменты тишины между задиктованными предложениями, стоит установить как можно более высокое значение этого параметра, чтобы функция по ошибке не удаляла паузы между словами. Чтобы найти правильное решение, вам потребуется рассмотреть на практике несколько вариантов.

8. Если вы выбрали тип обработки Remove data beyond loop points, вам также потребуется установить значение параметра Minimum length following loop end (0 to 48.000 samples). Он указывает функции Auto Trim/Crop оставить определенное количество сэмплов после конечной точки петли. Это делается для того, чтобы не допустить некорректной работы проигрывателей сэмплов, поскольку не все они используют правильные точки петель. (Мы подробнее остановимся на петлях и проигрывателях сэмплов в главе 13.)

9. Если вы выбрали тип обработки Remove data from start and limit file length, вам понадобится указать значение параметров Auto Delete From Start и Maximum Output Size. Параметр Auto Delete From Start указывает функции Auto Trim/Crop, что необходимо удалить определенный отрезок данных (измеряемый в секундах) в начале файла, независимо от того, содержит ли он тишину или нет. Параметр Maximum Output Size указывает функции Auto Trim/Crop, что нужно ограничить длину файла определенным значением (также измеряемым в секундах).

10. Нажмите на кнопку ОК.

Программа Sound Forge отсканирует выделенную область или весь ваш файл и удалит фрагменты тишины, руководствуясь заданными параметрами функции Auto Trim/Crop.

Вставка тишины

Вам может потребоваться не удалить фрагмент тишины, а, наоборот, вставить его в ваш звуковой файл. Функция Insert Silence предназначена именно для этих целей. Вот как она работает:

1. Если вы хотите вставить фрагмент тишины в определенную точку вашего звукового файла, установите в эту точку указатель текущей позиции.

2. Выберите команду меню Process -» Insert SUence, чтобы открыть диалоговое окно Insert Silence (рис. 8.14).

Рис. 8.14. Функция Insert Silence позволяет добавлять фрагменты тишины в ваш звуковой файл

3. Введите желаемую длительность фрагмента тишины (измеряемую в часах минутах, секундах и кадрах), используя поле со счетчиком Insert (nr:mn:sc:xxx).

4. Выберите из раскрывающегося списка at вариант, определяющий в какой точке файла необходимо вставить фрагмент тишины. Если вы хотите вставить его в определенной точке, выберите пункт Cursor Чтобы добавить фрагмент тишины в начало или конец файла, выберите пункты Start 01 Ше или End of file соответственно.

5. Нажмите на кнопку ОК.

Фрагмент тишины будет вставлен в ваш звуковой файл в соответствии с заданными параметрами. Если вы выбрали вставку в определенную точку файла то данные, находящиеся после этой точки, будут сдвинуты вперед и длина файла увеличится.

Приглушение звука

Функция Mute похожа на функцию Insert Silence в том смысле, что она позволяет помещать в состав звукового файла тишину. Но, в отличие от функции Insert Silence, она не вставляет фрагменты тишины. Вместо этого функция Mute просто стирает все выделенные данные, превращая их в тишину. Чтобы воспользоваться этой функцией, просто создайте в вашем звуковом файле выделенную область и выберите команду меню Process -> Mute. При этом все содержимое выделенной области будет преобразовано в тишину.


Изменение громкости звука

Одна из основных операций со звуковыми данными — это изменение их уровня сигнала (громкости). Существует бесчисленное множество причин, которые могут побудить вас изменить громкость файла, поэтому программа Sound Forge предоставляет несколько различных функций, позволяющих справиться с этой задачей. Эти функции называются Volume, Fade и Normalize.

Функция Volume

Чтобы просто увеличить или уменьшить уровень сигнала для выделенной области или всего файла, вам нужно воспользоваться функцией Volume. Вот как работает эта функция:

1. Создайте в вашем файле выделенную область, громкость которой вы хотите изменить. Если вы хотите обработать файл полностью, тогда либо вообще не выделяйте данные, либо выделите их полностью, выбрав команду меню Edit -> Select All.

2. Выберите команду меню Process -> Volume, чтобы открыть диалоговое окно Volume (рис. 8.15).

3. Чтобы изменить громкость ваших данных, выберите значение параметра Gain (-Inf. to 20 dB). Чтобы увеличить громкость, передвиньте ползунок вверх, а чтобы уменьшить — вниз. С помощью этого метода вы не сможете установить абсолютное значение. Громкость просто будет увеличена или уменьшена на ту величину, которую вы определите.

Предупреждение

Помните, как в главе 6 мы описывали установку уровня входного сигнала в процессе записи? Мы предупреждали вас, что нельзя излишне повышать этот уровень, поскольку это может привести к перегрузке входного сигнала и искажению данных. Так вот, повышая громкость звуковых данных, придерживайтесь того же правила. Чрезмерное повышение громкости может повлечь за собой "обрезание" данных. Это происходит, когда программа Sound Forge пытается поднять уровень сигнала выше 100% (в соответствии с показаниями линейки сигнала окна данных). При этом верхняя и нижняя оконечности диаграммы сигналов отсекаются и звук деформируется. Итак, используя функцию Volume будьте осторожны. Следите за диаграммами громкости сигналов и обязательно проверяйте звучание записи перед тем, как внести окончательные изменения Если окажется, что запись деформирована, используйте команду Undo чтобы отменить повышение громкости.

Рис. 8.15. Функция Volume позволяет изменить громкость вашего файла

4. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того как программа Sound Forge произведет в нем фактические изменения. '

5. Нажмите на кнопку ОК .

Программа Sound Forge увеличит или уменьшит громкость вашего звукового файла в соответствии с произведенными установками.

Применение усиления и затухания звука

В дополнение к основным операциям изменения громкости программа Sound Forge позволяет вам применять эффекты усиления и затухания звука в вашем файле. J

Замечание

Усиление- это постепенное, ровное увеличение громкости звука. В музыкальной терминологии такое усиление называется крещендо. Затухание представляет собой прямо противоположное явление - постепенное, ровное уменьшение громкости звука. Музыканты называют это изменение звука термином диминуэндо.

Чтобы применить усиление или затухание в ваших звуковых данных, сделайте следующее:

1. Создайте в вашем файле выделенную область, к которой вы хотите применить затухание или усиление. Если вы хотите обработать файл полностью, тогда либо вообще не выделяйте данные, либо выделите их полностью, выбрав команду меню Edit -> Select All.

2. Чтобы применить усиление, выберите команду меню Process -> Fade -> In.

3. Чтобы применить затухание, выберите команду меню Process -> Fade -> Out.

Программа Sound Forge изменит громкость ваших данных в соответствии с указанными параметрами.

Сложное постепенное изменение громкости

Несмотря на то, что функции Fade in и Fade out позволяют вам постепенно изменять громкость звука, подобное изменение происходит линейно. Это означает, что громкость увеличивается или уменьшается равномерно. Если вы хотите поэкспериментировать с изменением громкости, используйте функцию Graphic Fade. Вот как это сделать:

1. Выделите в вашем файле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> Fade -> Graphic, чтобы открыть диалоговое окно Graphic Fade (рис. 8.16). В этом окне изображен график. На левой оси графика указываются значения амплитуды, которые могут варьироваться от 0 до 400% (в зависимости от значения параметра Maximum Gain, находящегося под графиком). На графике изображена кривая, показывающая изменение громкости ваших звуковых данных. Левый край этой кривой представляет начало выделенной области, а правый край — ее конец. Если положение кривой таково, что левый ее край находится внизу графика, а правый — вверху, это значит, что по отношению к вашим звуковым данным будет применено линейное усиление. Это объясняется тем, что левый край кривой находится напротив значения 0%, а правый — напротив значения 100%. Таким образом, громкость звуковых данных увеличится с 0 до 100%. Понятно, как работает эта функция?

Совет

При работе со стереофоническим файлом можно включить отображение диаграммы сигналов в качестве фона графика, установив флажок Show wave. Вы также можете указать программе, отображать ли содержимое обоих каналов или только одного из них, выбрав пункт из расположенного справа раскрывающегося списка. Это не влияет на сам процесс изменения громкости. Если вы хотите применить изменение громкости только к одному из каналов, вам нужно до открытия диалогового окна Graphic Fade выделить данные только из этого канала.

Рис. 8.16. Вы можете использовать функцию Graphic Fade для внедрения сложного постепенного изменения громкости

3. Вы можете изменить форму кривой графика двумя способами. Можно просто выбрать одну из предварительных установок, воспользовавшись раскрывающимся списком Name. А осуществить подобное изменение можно графическим способом с помощью маленьких квадратиков на краях кривой. Эти квадратики называются точками огибающей.

4. Если вы хотите, чтобы изменение громкости было действительно сложным, вы можете добавить еще несколько точек огибающей, щелкнув на кривой в любом ее месте. Чем больше точек вы добавите (а их может быть не больше 16), тем точнее вы сможете изменять форму линии (рис. 8.17).

5. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

6. Нажмите на кнопку ОК.

Рис. 8.17. Вы можете сделать изменение громкости действительно сложным, добавив к огибающей несколько дополнительных точек

Программа Sound Forge изменит громкость вашей выделенной области в соответствии с параметрами, установленными вами в диалоговом окне Graphic Fade - Funky saxophone riff.

Нормализация звука

Функция Normalize, как и функция Volume, увеличивает громкость звука, но несколько иным образом. Она сначала исследует файл на предмет самого высокого уровня сигнала, а потом вычитает этот уровень из максимально возможного, который равен 100% (или тому значению, которое вы установили). Функция Normalize использует получившуюся разность при увеличении громкости звуковых данных. В конце концов, самый высокий уровень сигнала в данном файле доводится до 100% (или до указанного вами значения), а более низкие уровни пропорционально увеличиваются.

Другими словами, если самый высокий уровень сигнала в вашем файле равен 80%, а максимально возможный уровень — 100%, то функция Normalize вычитает 80% из 100% и результат становится равен 20%. Затем громкость всех звуковых данных в вашем файле увеличивается на полученные 20%. Таким образом, вы можете использовать функцию Normalize, чтобы увеличить громкость ваших звуковых данных без последствий, т. е. без отсечения части данных.

Чтобы использовать функцию Normalize, сделайте следующее:

1. Выделите в вашем файле данные, которые вы хотите нормализовать. Чтобы обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выбрав команду меню Edit -> Select All.

2. Выберите команду меню Process -> Normalize, чтобы открыть диалоговое окно Normalize (рис. 8.18).

Рис. 8.18. Вы можете нормализовать громкость ваших звуковых данных, используя функцию Normalize

3. Для параметра Normalize using включите переключатель Peak level (о переключателе Average RMS power (loudness) мы поговорим чуть позже).

4. Нажмите на кнопку Scan Levels, чтобы найти самый высокий уровень сигнала ваших звуковых данных.

5. Установите значение параметра Normalize to (-60 to 0 dB), перемещая соответствующий ползунок вверх или вниз. Таким образом вы установите максимально возможный уровень сигнала, который будет учитываться при нормализации. В большинстве случаев вам следует устанавливать значение, равное 100%, но если вы хотите в дальнейшем редактировать или обрабатывать ваши данные, лучше указать более низкий уровень, например 50% или —6 дБ. Дело в том, что во время обработки файла громкость может повыситься, и это послужит причиной отсечения части данных.

Совет

Вы также можете нормализовать ваши данные до максимального уровня сигнала, взятого из другого файла. Это гарантирует одинаковую громкость нескольких файлов, что бывает полезно, например, при переписывании их на компакт-диск. Чтобы выполнить эту задачу, откройте первый аудиофайл и выберите команду меню Process -> Normalize. Нажмите на кнопку Scan Levels. Затем нажмите на кнопку Cancel. После этого откройте другой звуковой файл и выберите команду меню Process -> Normalize. Установите флажок Use current scan level (do not scan selection) и нажмите на кнопку ОК, Таким образом, второй звуковой файл будет нормализован до того же уровня сигнала, что и первый.

6. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

7. Нажмите на кнопку ОК.

Программа Sound Forge нормализует громкость ваших звуковых данных в соответствии с заданными параметрами.

Воспринимаемая громкость

Функция Normalize также может выполнять более сложную обработку, вычисляя среднюю воспринимаемую громкость. В этом режиме функция Normalize не просто находит самый высокий уровень сигнала в звуковом файле. Она измеряет громкость файла с точки зрения человеческого восприятия. Это явление называется воспринимаемой громкостью. Даже если реальная громкость звука находится на определенном уровне, этот звук может иногда восприниматься как более громкий; причина чего — свойства человеческого слуха. Данная тема слишком сложна, чтобы вдаваться в излишние подробности. Заметим лишь, что при балансировании уровней сигнала нескольких файлов нормализация, основанная на воспринимаемой громкости, обычно более эффективна, чем просто вычисление наивысшего уровня сигнала.

Во время анализа звукового файла функция Normalize, вычисляющая воспринимаемую громкость, использует цифровой шлюз сигнала, как и функция Auto Trim/Crop, описанная ранее в этой главе. Чтобы использовать функцию Normalize, базирующуюся на воспринимаемой громкости, осуществите следующее:

1. Выделите в вашем файле данные, которые вы хотите нормализовать. Чтобы обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> Normalize, чтобы открыть диалоговое окно Normalize (см. рис. 8.18).

3. В группе Normalize using выберите переключатель Average RMS power (loudness).

4. Установите значение параметра Ignore below (-Inf. to 0 dB), используя соответствующий ползунок, чтобы определить порог допустимого уровня звука. Значение этого параметра должно быть на пару дБ выше уровня, который воспринимается как тишина. Все значения ниже порога при вычислении средней воспринимаемой громкости будут проигнорированы. Значение параметра Ignore below (-Inf. to 0 dB), скорее всего, будет близко к —45 дБ, но это зависит от конкретных данных.

5. Установите значение параметра Attack time (1 to 500 ms). Этот параметр указывает программе, насколько быстро следует открывать цифровой шлюз сигнала, чтобы учесть допустимые уровни звука при анализе данных. Если в вашем файле содержатся часто сменяющие друг друга звуки (вроде ударов барабанных палочек), вам лучше установить как можно более низкое значение. Установка высокого значения приведет к тому, что частые звуки не будут учтены. Приемлемое значение равняется приблизительно 200 миллисекундам, но это зависит от конкретных данных.

6. Установите значение параметра Release time (I to 500 ms). Этот параметр указывает программе, насколько быстро следует закрывать цифровой шлюз сигнала при анализе сигналов, уровень которых ниже допустимого. Если вы хотите, чтобы при вычислении средней воспринимаемой громкости было учтено как можно больше материала, вам нужно установить достаточно высокое значение. Установка более низкого значения сузит спектр уровней сигналов, учитываемых при анализе данных. Значение 200 миллисекунд является приемлемым, но, опять же, судите сами, исходя из параметров ваших данных.

7. Вследствие некоторой ограниченности человеческого слуха очень низкие и очень высокие частоты услышать труднее, чем средние. Чтобы исправить положение, в диалоговом окне Normalize предусмотрен флажок Use equal loudness contour. В большинстве случаев этот флажок целесообразнее установить.

8. Нажмите на кнопку Scan Levels, чтобы вычислить среднюю воспринимаемую громкость для ваших звуковых данных.

9. Установите значение параметра Normalize to (-60 to 0 dB), чтобы нормализовать данные, используя среднюю воспринимаемую громкость.

Предупреждение

Поскольку режим Average RMS Power работает с воспринимаемой громкостью, а не с реальными уровнями сигнала, будьте осторожны, устанавливая значение параметра Normalize to (-60 to 0 dB). Выбор слишком высокого значения может привести к деформации звука или отсечению части данных. Вы никогда не ошибетесь, если при использовании режима Average RMS Power не будете превышать значение -6 дБ для параметра Normalize to (-60 to 0 dB).

10. Для лучшей защиты от отсечения данных вы можете выбрать желаемый вариант из раскрывающегося списка If clipping occurs. В большинстве случаев стоит выбрать вариант Apply dynamic compression, кроме случаев, когда в вашу задачу входит именно деформирование звука (например, при работе с записью электрогитары).

11. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

12. Нажмите на кнопку ОК.

Программа Sound Forge нормализует громкость ваших звуковых данных, учитывая значения параметров.


Работа со стереофоническими записями

Программа Sound Forge располагает несколькими средствами отдельной обработки каналов в стереофонических записях. Например, вы можете преобразовать стереофонические записи в монофонические и наоборот. Вы также можете перемещать звуки по стереополю для реализации различных эффектов. Справиться с этими и другими задачами помогают преобразователь каналов и функция Pan/Expand.

Изменение каналов

Если вам нужно преобразовать стереофонический файл в монофонический или наоборот, воспользуйтесь функцией Channel Converter. Для этого сделайте следующее:

1. Выберите команду меню Process -> Channel Converter, чтобы открыть диалоговое окно Channel Converter (рис. 8.19).

2. Установите значение параметра Output channels. Если вы хотите перевести ваш файл в монофонический режим, выберите переключатель Mono. Чтобы перевести файл в стереофонический режим, установите переключатель Stereo.

3. Если вы хотите выполнить простое прямое преобразование, установите флажок Convert to specified output channels only (no custom mixing), после чего нажмите на кнопку OK и пропустите все последующие шаги.

4. Если вы хотите отрегулировать уровни сигнала для левого и правого каналов, а также определить их пропорцию в конечном файле, тогда не устанавливайте флажок Convert to specified output channels only (no custom mixing).

5. В группе New left channel отрегулируйте ползунки параметров From left (-200 to 200%)и From right (-200 to 200%). Если вы преобразуете запись в монофонический режим, доступен будет только параметр From left (-200 to 200%). Этот параметр определяет, какая часть сигнала из левого канала исходного файла будет добавлена в левый канал конечного файла. Параметр From right (-200 to 200%) определяет, какая часть сигнала из правого канала исходного файла будет добавлена в левый канал конечного файла.

Рис. 8.19. Функция Channel Converter позволяет преобразовать стереофонические файлы в монофонические и наоборот

6. В группе New right channel отрегулируйте ползунки параметров From left (-200 to 200%) и From right (-200 to 200%). Если вы преобразуете запись в монофонический режим, доступен будет только параметр From left (-200 to 200%). Он определяет, какая часть сигнала из левого канала исходного файла будет добавлена в правый канал конечного файла. Параметр From right (-200 to 200%) определяет, какая часть сигнала из правого канала исходного файла будет добавлена в правый канал конечного файла.

7. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения. Если вы не удовлетворены услышанным, попробуйте по-другому отрегулировать ползунки параметров в обеих группах.

8. Окончательно отрегулировав уровни в группах New left channel и New right channel, вновь нажмите на кнопку Preview. В этот раз послушайте, не стал ли звук "глухим". Это может произойти из-за подавления фазы, которая происходит, когда громкость одного сигнала уменьшается, а громкость другого увеличивается, причем одновременно и на одну и ту же величину. Таким образом, два сигнала перекрывают друг друга, в результате чего звук становится "глухим". Если это произошло, попробуйте установить флажок Invert left channel mix или Invert right channel mix, но только не оба сразу. В результате этого сигнал инвертируется, что обычно помогает разрешить проблему.

9. Нажмите на кнопку ОК.

Программа Sound Forge преобразует ваш звуковой файл в соответствии с определенными вами установками. Используя функцию Channel Converter, вы также можете создать некоторые эффекты, например псевдостереосигнал из монофонического сигнала. Не забудьте проверить действие предварительных установок этой функции, чтобы понять ее возможности.

Панорамирование

Функция Pan/Expand позволяет определить, как будет слышен звук в звуковом поле между двумя динамиками. Можно сделать так, что звук будет восприниматься исходящим из левой или правой колонки, а также из звукового поля между ними. Этот эффект называется панорамированием. Функция Pan/Expand обладает и некоторыми другими возможностями, о которых мы также коротко расскажем. Чтобы использовать функцию Pan/Expand, сделайте следующее:

1. Выделите в вашем файле данные, которые вы хотите нормализовать. Чтобы обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выбрав команду меню Edit -> Select All.

2. Выберите команду меню Process -> Pan/Expand, чтобы открыть диалоговое окно Pan/Expand (рис. 8.20).

3. Установите в раскрывающемся списке Process mode одноименный параметр. Выберите пункт Pan (preserve stereo separation), чтобы выполнить панорамирование без сведения левого и правого каналов. Это может быть полезно, если у вас есть стереофоническая запись (например, сопровождающей вокальной группы) и вы не собираетесь изменять сам сигнал, но хотите панорамировать группу голосов в определенную область стереопо-ля. Если вы выберете пункт Pan (mix channels before panning), панорамирование будет проведено совместно со сведением левого и правого каналов стереофонической записи. Эта возможность может пригодиться, если необходимо изменить все стереополе, а не отдельный сигнал. Попробуйте воспользоваться обоими пунктами, чтобы уловить разницу на слух.

4. В окне Pan/Expand , помимо параметра Process mode,

вы обнаружите график. Его левая шкала отображает позиционирование стереофонического сигнала — он может быть в центре стереополя, а также в левой или правой его части. На графике изображена линия, отображающая характеристики панорамирования, которое вы хотите применить к вашим звуковым данным. Левый край линии представляет начало выделенной области, а правый край — ее конец. Если положение линии таково, что левый ее край находится внизу графика, а правый — вверху, это значит, что по отношению к вашим звуковым данным будет применено линейное панорамирование. Это объясняется тем, что левый край линии находится в правой части стереополя, а правый край — в левой его части. Таким образом, звук сначала будет доноситься из правого динамика, а затем плавно перейдет в левый. Понятно, как работает эта функция?

Рис. 8.20. Вы можете панорамировать данные из стереофонического звукового файла, используя функцию Pan/Expand

Совет

При работе со стереофоническим файлом можно включить отображение диаграммы сигналов в качестве фона графика, установив флажок Show wave. Вы также можете указать программе, отображать ли содержимое обоих каналов или только одного из них, выбрав соответствующий пункт из расположенного рядом списка. Это никак не повлияет на сам процесс панорамирования.

5. Вы можете изменить форму линии панорамирования графическим способом, оперируя маленькими квадратиками на ее концах. Эти квадратики называются точками огибающей.

6. Если вы хотите выполнить сложное панорамирование, вы можете добавить еще несколько точек огибающей, щелкнув в любом месте линии.

Чем больше точек вы добавите (а их может быть не больше 16), тем точнее вы сможете изменять форму линии (рис. 8.21).

Рис. 8.21. Вы можете выполнять сложное панорамирование, добавляя к огибающей новые точки

7. Отрегулируйте ползунок параметра Output gain (-60 to 20 dB), чтобы определить громкость файла после обработки.

8. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

9. Нажмите на кнопку ОК.

Программа Sound Forge выполнит панорамирование ваших звуковых данных в соответствии с характеристиками линии панорамирования, указанными в диалоговом окне Pan/Expand - Funky saxophone riff.

Увеличение и уменьшение стереополя

Функция Pan/Expand дает возможность не только панорамировать звук, но и сжимать и расширять все стереополе. Другими словами, вы можете сжимать стереополе вашей стереофонической записи таким образом, что оно будет казаться уже (поскольку левая и правая части стереополя будут максимально приближены к середине расстояния между двумя динамиками).

Вы также можете расширять стереополе (в этом случае левая и правая части стереополя будут максимально удалены друг от друга, в результате чего будет создаваться впечатление, что границы стереополя находятся шире расстояния между динамиками). Чтобы понять, что мы имеем в виду, нужно прослушать полученный результат. Чтобы сжать или расширить стереополе, сделайте следующее:

1. Выделите в вашем файле данные, которые вы хотите нормализовать. Чтобы обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выбрав команду меню Edit -> Select All.

2. Выберите команду меню Process -> Pan/Expand, чтобы открыть диалоговое окно Pan/Expand - Funky saxophone riff.

3. Выберите пункт Stereo Expand из раскрывающегося списка Process mode.

4. Обратите внимание, что в левой части графика (о которой мы говорили в предыдущем подразделе) теперь находятся значения Center, Normal и Wide. Чем ближе линия к нижней части графика, тем сильнее левая и правая части стереополя приближены друг к другу. Чем ближе линия к верхней части графика, тем больше левая и правая части стереополя удалены друг от друга. Как и в случае с панорамированием, левый край линии представляет начало выделенной области, а правый край — ее конец.

Совет

При работе со стереофоническим файлом можно включить отображение диаграммы сигналов в качестве фона графика, установоив флажок Show wave. Вы также можете указать программе, отображать ли содержимое обоих каналов или только одного из них, выбрав необходимый пункт из расположенного сбоку раскрывающегося. Это никак не повлияет на сам процесс панорамирования.

5. Отрегулируйте сжатие или расширение стереополя, оперируя точками огибающей, находящимися на концах линии.

6. Если вы хотите выполнить сложное панорамирование, вы можете добавить еще несколько точек огибающей, щелкая в любом месте линии. Чем больше точек вы добавите (а их может быть не больше 16), тем точнее вы сможете изменять форму линии (см. рис. 8.21).

7. Отрегулируйте ползунок параметра Output gain (-60 to 60 dB), чтобы определить громкость файла после обработки.

8. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

9. Нажмите на кнопку ОК.

Программа Sound Forge произведет сжатие или расширение стереополя, руководствуясь характеристиками линии, указанными в диалоговом окне Pan/Expand - Funky saxophone riff.

Обработка боковых записей

Наконец, с помощью функции Pan/Expand можно обрабатывать боковые записи.

Замечание

Боковая запись (Mid-Side Recording) — это специальный тип записи, при которой один микрофон направлен прямо на исполнителя и записывает средний (центральный) канал, а другой микрофон расположен под углом 90 градусов по отношению к исполнителю, при этом записывается боковой (стерео) канал. Обычно для воспроизведения подобных записей нужен специальный декодер, но их также можно преобразовать в обычные стереофонические записи.

Чтобы преобразовать боковую запись, используя функцию Pan/Expand, сделайте следующее:

1. Выделите в вашем файле данные, которые вы хотите нормализовать. Чтобы обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выполнив команду меню Edit -> Select All.

2. Выберите команду меню Process -> Pan/Expand, чтобы открыть диалоговое окно Pan/Expand - Funky saxophone riff.

3. Выберите из раскрывающегося списка Process mode вариант Mix Mid-Side (MS) recording to left and right channels.

4. Линия, проходящая по графику, должна находиться в его центре и быть выровнена по значению Normal на левой оси графика (рис. 8.22).

Рис. 8.22. Поместите линию в центр графика, чтобы преобразовать боковую запись

5. Отрегулируйте ползунок параметра Output gain (-60 to 60 dB), чтобы определить громкость файла после обработки.

6. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

7. Нажмите на кнопку ОК.

Программа Sound Forge преобразует вашу боковую запись в обыкновенную стереофоническую.


Эквализация

В вашей машине есть радио? А может быть, даже магнитола или проигрыватель компакт-дисков? Если есть, то вы, скорее всего, уже пользовались эквализацией, сами того не ведая. Дело в том, что регулирование нижних и верхних частот на вашем автомобильном радиоприемнике — это тоже форма эквализации. Эквализация позволяет вам регулировать тональные характеристики звукового сигнала, увеличивая или уменьшая амплитуду различных частот звукового спектра.

Замечание

Когда музыкальный объект (например, струна) вибрирует, он издает звук. Скорость вибрации называется частотой, которая измеряется в колебаниях (или циклах) в секунду. Эта единица измерения называется герцем (Гц, Hz). Если объект вибрирует 60 раз в секунду, это значит, что частота равна 60 Гц. Сложность состоит в том, что большинство объектов вибрируют с разной частотой в одно и то же время. Комбинация этих вибраций составляет отдельный звук (или тембр) вибрирующего объекта. Именно поэтому колокол звучит как колокол, рожок звучит как рожок и т. д. Естественно, люди не могут воспринимать очень медленные или очень быстрые вибрации. Формально диапазон человеческого слуха ограничивается значениями 20 Гц и 20 кГц (1 кГц равен 1000 Гц). Этот диапазон известен как звуковой спектр. Эквализация позволяет вам оперировать частотами звукового спектра, а поскольку звуки содержат множество таких частот, вы можете изменять их тональные характеристики (или тембр). Разумеется, это объяснение очень поверхностно. Если вы действительно хотите узнать больше об акустике, купите хорошую книжку, посвященную записи звука, например "Home Recording for Musicians by Craig Anderton" (Music Sales Corp., 1996, ISBN 0-8256-1500-3).

Другими словами, используя эквализацию, вы можете усиливать бас, увеличивать эффект присутствия, уменьшать рокот, а иногда и устранять шум из ваших данных. Кроме того, вы можете использовать эквализацию как эффект. Замечали, как иногда в современной танцевальной музыке голос звучит так, как будто он исходит из телефонной трубки или из старого радиоприемника? Этот эффект достигается с помощью эквализации.

Программа Sound Forge предоставляет три различных типа эквализации: графическая эквализация, параметрическая и параграфическая. Существует также функция Smooth/Enhance, о которой мы поговорим позже. Все названные типы эквализации имеют свои плюсы и минусы.

Графическая эквализация

Возможно, вы уже знакомы с графическими эквалайзерами, потому что они иногда присутствуют на домашних стереосистемах. Функция Graphic EQ программы Sound Forge имитирует аппаратные графические эквалайзеры) (рис. 8.23).

Рис. 8.23. Функция Graphic EQ напоминает настоящий графический эквалайзер

В основном режиме работы функция Graphic EQ дает возможность регулировать 10 разных частот (называемых дорожками). Каждую дорожку можно повысить на 24 дБ или понизить до -Inf. (минус бесконечности, что равносильно полному исключению данной частоты из спектра). Чтобы увеличить или уменьшить амплитуду определенной частоты, вам нужно просто передвинуть вверх или вниз соответствующий ползунок. Но здесь проявляется слабая сторона графической эквализации. Несмотря на то, что ее очень просто использовать, число частот, которыми можно управлять, ограничено. Вы не можете изменить частоты, находящиеся ниже, выше или между имеющимися частотами. Как бы то ни было, функция Graphic EQ очень полезна в тех случаях, когда нужно быстро применить эквализацию, а используя усложненный режим, вы можете частично обойти это ограничение Вот как работает функция Graphic EQ: шраничение. вот как

1. Вам необходимо выделить в вашем файле данные, которые вы хотите обработать. Для того чтобы обработать весь файл, либо ничего не вьшеляйте, либо выделите все данные, выбрав команду меню Edit -> Select All

2. Выполните команду меню Process -> EQ -> Graphic чтобы открыть диалоговое окно Graphic EQ .' Затем выберите 10 -дорожечный режим, перейдя на вкладку 10 Band в нижней части окна

3. Оперируйте ползунками, чтобы отрегулировать нужные частоты.

Совет

Чтобы быстро вернуть ползунок в положение 0 дБ, дважды щелкните на нем мышью.

Предупреждение

Будьте осторожны, повышая уровень частот, поскольку этим вы увеличиваете общую громкость данных. Излишне увеличив громкость, вы можете вызвать появление шумов.

4. Если вы просто хотите выполнить базовую эквализацию, пропустите дальнейшие действия вплоть до шага 10. В противном случае откройте вкладку 20 Band, чтобы перейти в 20-дорожечный режим (рис. 8.24)

Рис. 8.24. Вы можете выполнить более точную регулировку уровня частот, используя 20-дорожечный режим

5. Обратите внимание, что изменения, сделанные вами в 10-дорожечном режиме, остались в силе при переходе в другой режим. Теперь выполните более точную эквализацию ваших данных.

6. Если использования 20-дорожечного режима достаточно для завершения эквализации, пропустите дальнейшие действия вплоть до шага 10. В противном случае перейдите на вкладку Envelope (рис. 8.25).

Рис. 8.25. В режиме Envelope функция Graphic EQ позволяет вам вносить изменения посредством графика

7. В режиме Envelope функция Graphic EQ принимает совершенно новый вид. Вместо ползунков вы видите график. Горизонтальная шкала графика отображает изменяемые частоты, варьирующиеся от 20 Гц до 20 кГц. Вертикачьная шкала графика показывает амплитуду для каждой частоты; ее охват простирается от -Inf. до +24 дБ. На графике изображена линия, представляющая эквализационную кривую. Все точки этой линии, находящиеся на отметке выше 0 дБ, представляют частоты, которые будут усилены. Все, что находится ниже 0 дБ, будет удалено.

8. Вы можете изменять форму линии, оперируя точками огибающей. При перетаскивании мышкой какой-нибудь из точек вы увидите, что значения амплитуды отображаются в правом верхнем углу графика.

9. Если вы хотите создать сложную эквализационную кривую, вы можете добавить новые точки огибающей, щелкая мышью в любом месте линии. Чем больше точек вы создадите, тем точнее будет изменяться форма линии (рис. 8.26).

Рис. 8.26. Вы можете создать более сложную эквализационную кривую, добавляя к ней новые точки огибающей

10. Установите значение параметра Accuracy, чтобы определить качество эквализации, которое вы хотите использовать. Чем выше качество, тем медленнее идет процесс эквализации. Но если вы имеете дело с не очень большим файлом, то лучше всего выбрать пункт High (show, great for all bands).

11. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения. Если вы слышите помехи, попробуйте отрегулировать параметр Output gain (-60 to 60 dB) таким образом, чтобы общая громкость данных была уменьшена. Попытайтесь установить значение -1 дБ, а затем поэкспериментируйте.

12. Нажмите на кнопку ОК.

Программа Sound Forge проведет эквализацию ваших звуковых данных, опираясь на заданные вами характеристики эквализационной кривой.

Функция Parametric EQ

Параметрическая эквализация является несколько более мощной и гибкой, чем графическая эквализация. При использовании функции Parametric EQ вы не ограничены установкой частот. Вы можете указывать точные значения частот. Да, при использовании режима Envelope функции Graphic EQ вы можете указывать частоты — но неточно. Ограничением является разрешение графика. Функцию Parametric EQ использовать несложно, но мы можем лучше объяснить ее, показав, как она работает:

1. Выделите в вашем файле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> EQ -> Parametric, чтобы открыть диалоговое окно Parametric EQ (рис. 8.27).

Рис. 8.27. Функция Parametric EQ позволяет вам точно указывать частоты

3. Выберите из раскрывающегося списка Filter style один из вариантов: Low-Frequency Shelf, High-Frequency Shelf, Band-pass или Band-Notch/Boost.

4. Установите значение параметра Center frequency (20 to 22,050 Hz). Если вы выберете в раскрывающемся списке Filter style вариант Low-Frequency Shelf, все частоты ниже Center frequency (20 to 22,050 Hz) будут либо обрезаны, либо подняты. Если вы выберете в раскрывающемся списке Filter style вариант High-Frequency Shelf, все частоты выше Center frequency (20 to 22,050 Hz) будут либо обрезаны, либо подняты. Если вы выберете в списке Filter style вариант Band-pass, частоты выше или ниже Center frequency (20 to 22,050 Hz) будут обрезаны или подняты. Если вы выберете в раскрывающемся списке Filter style вариант Band-Notch/Boost, частота Center frequency (20 to 22,050 Hz) будет обрезана или поднята.

5. Если вы выберете в раскрывающемся списке Filter style варианты Low-Frequency Shelf или High-Frequency Shelf, вам потребуется настроить параметр Transition Width. Этот параметр определяет, какие частоты выше или ниже Center frequency (20 to 22,050 Hz) будут затронуты Чем ниже значение, тем более острой будет кривая эквализации в точке Center frequency. Чем выше значение, тем более гладкой будет кривая эквализации.

6.Если вы выберете в раскрывающемся списке Filter style варианты Band-pass или Band-Notch/Boost, вам потребуется настроить параметр Band width. Этот параметр определяет, какие частоты будут затронуты вблизи параметра Center frequency (20 to 22,050 Hz). Чем ниже значение, тем меньше частот будет затронуто.

7.Настройте параметр Amount (-60 to 20dB). Этот параметр определяет, насколько обрезаются или поднимаются указанные частоты Он может находиться в диапазоне от -60 дБ до +20 дБ.

8.Установите значение параметра Accuracy , указывающего качество эквализации, которое вы хотите испольховать. Чем выше качество, тем медленнее обработка. Но если ваш файл не слишком огромен, вы обычно можете использовать значение High (Slow, great for all frequencies) , дающее наилучшее качество.

9. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения. Если вы услышите, что звук обрезан, настройте параметр Output gain так, чтобы общая громкость эквализации была уменьшена.Попытайтесь опустить его до -1 дБ и дальше действовать методом подбора.

10. Нажмите на кнопку ОК .

Программа Sound Forge применит эквализацию к вашим звуковым данным, учитывая значения параметров в диалоговом окне Parametric EQ Funky saxophone riff.

Функция Paragraphic EQ

Самой мощной функцией эквализации в программе Sound Forge является Paragraphic EQ. Функция Paragraphic EQ объединяет многие возможности из различных функций эквализации, которые мы уже обсуждали. Если вы посмотрите на диалоговое окно Paragraphic EQ - Funky saxophone riff (рис. 8.28), то увидите частотный график в верхней правой части.

На данном графике показана кривая эквализации (как в функции Graphic EQ), но такой график нельзя изменять непосредственно т к он показывяет кривую эквализации, созданную на основе значений остальньх параметров.

Функция Paragraphic EQ содержит также четыре независимых параметрических эквалайзера, в каждом из которых имеются элементы управления Gain, Width и Center frequency. Принципы работы всех этих элементов были нами рассмотрены выше. Единственное отличие заключается в том, что если в данном случае параметр Gain эквалайзера имеет значение 0 дБ, это означает, что эквалайзер отключен. Чтобы включить эквалайзер, увеличьте значение параметра Gain. После этого остальные элементы управления станут доступными. Кроме того, функция Paragraphic EQ содержит низкоуровневый и высокоуровневый эквалайзеры, каждый из которых имеет настраиваемые элементы управления Gain и Center frequency. Еще одно различие между функцией Paragraphic EQ и другими функциями эквалайзера заключается в том, что вместо главного элемента управления Gain в функции Paragraphic EQ имеются элементы управления Dry out (-Inf. to 25 dB) и Wet out (-25 to 25 dB). Это позволяет вам смешивать исходные аудиоданные с эквализован-ными аудиоданными и определять их соотношение в обработанном звуке. Параметр Dry out (-Inf. to 25 dB) управляет уровнем исходного звука, а параметр Wet out (-25 to 25 dB) — уровнем эквализованного звука.

Рис. 8.28. Функция Paragraphic EQ является объединением нескольких функций эквализации

Так что, в сущности, функция Paragraphic EQ является комбинацией четырех параметрических эквалайзеров, а также низкоуровневого и высокоуровневого эквалайзеров. Объединение всех функций этих эквалайзеров дает возможность создавать очень сложные процедуры эквализации. Чтобы понять, насколько мощной может быть функция Paragraphic EQ, попробуйте поработать с некоторыми наборами настроек из раскрывающегося списка Name.


Воспроизведение в обратном направлении

Если вы прожили на свете достаточно долго, чтобы помнить виниловые пластинки, то не приходилось ли вам когда-нибудь воспроизводить запись в обратном направлении, чтобы выяснить, а не оставила ли ваша любимая группа в своих песнях каких-нибудь сатанинских сообщений или, например, рецепта их любимого чечевичного супа? То же самое вы можете проделать с вашими аудиоданными. Программа Sound Forge позволяет вам воспроизводить данные в файле (или в выделении) в обратном порядке.

У этой функции не так много практических применений, но в сочетании с другими функциями обработки она может дать некоторые замечательные эффекты. Чтобы использовать эту функцию, просто выделите данные, которые вы хотите изменить, и выполните команду меню Process -> Reverse. Теперь данные будут воспроизводиться в обратном направлении. Если вы не выделите никакие данные, будут обработаны данные всего файла.

Переворачивание данных

В главе 7 мы говорили о функции Paste Mix и о том, как при смешивании определенных звуковых файлов происходит подавление фазы. Подавление фазы осуществляется тогда, когда громкость одного аудиосигнала увеличивается, а громкость другого аудиосигнала уменьшается в то же самое время и на точно ту же величину. Из-за этого эффекта звуки погашают друг друга, смешанный звук становится глухим. В диалоговом окне функции Paste Mix находится флажок Invert data, который переворачивает аудиосигнал вокруг нулевой оси. Это иногда помогает избежать подавления фазы.

Программа Sound Forge позволяет вам переворачивать данные в аудиофайле вручную с помощью функции Invert/Flip. Чтобы использовать ее, просто выделите данные, которые вы хотите изменить, и выберите команду меню Process -> Invert/Flip. Данные будут перевернуты. Если вы не выделили никакие данные, будут перевернуты все данные в файле.

Изменение длины

Обычно, когда вы изменяете длину аудиоданных, высота тона тоже изменяется. Укоротите данные, и высота тона увеличится. Удлините данные, и высота тона уменьшится. В большинстве случаев вы предпочтете избежать изменения высоты тона. К счастью, программа Sound Forge содержит функцию, позволяющую изменить длину ваших аудиоданных без воздействия на высоту тона. Эта функция называется Time Compress/Expand, вот как она работает:

1. Выделите в вашем файле аудиоданные, которые вы хотите обработать. Если вы хотите обработать весь файл, либо ничего не выделяйте, либо выделите все данные, выбрав команду меню Edit -> Select All.

2. Выполните команду меню Process -> Time Stretch , чтобы открыть диалоговое окно Time Stretch (рис. 8.29).

Рис. 8.29. Функция Time Stretch позволяет вам изменять продолжительность звука, не меняя его высоты тона

3. Выберите необходимый вам пункт из раскрывающегося списка Mode. Для того чтобы предоставить лучший тип обработки, функция Time Compress/Expand принимает во внимание тип аудиоданных, которые вы обрабатываете. Вы должны выбрать из раскрывающегося списка вариант, соответствующий типу обрабатываемых данных. Например, если вы обрабатываете ударные инструменты, не имеющие определенного тона, вы можете использовать вариант AlT.Drums, unpitched (minimum echo). Для того чтобы найти правильный вариант, вам придется немного поэксперименировать.

4. Выберите необходимый вариант из раскрывающегося списка Input format. Вы можете выбрать указание новой длины ваших аудиоданных в процентах, как темп или в виде конкретной продолжительности.

5. В зависимости от того, какой вариант вы выберете в списке Input format. появится соответствующий элемент управления, который позволит вам указать длину аудиоданных. Если вы выберете вариант Percentage, будет доступен параметр Final Percentage (50.000 to 500.000%). Если вы выберете вариант Tempo — параметр Final Tempo. А если вы выберете вариант Time, будет доступен параметр Final Time. Настройте имеющийся параметр так, чтобы указать новую длину ваших аудиоданных.

6. Нажмите на кнопку Preview, чтобы услышать, как звучит файл, до того, как программа Sound Forge произведет в нем фактические изменения.

7. Нажмите на кнопку ОК.

Программа Sound Forge изменит длину ваших звуковых данных, учитывая значения параметров диалогового окна Time Compress/Expand .


Глава 9. Эффекты в программе Sound Forge
  • Эффекты в программе Sound Forge
  • Эффекты эха
    • Функция Simple Delay
    • Функция Multi-Tap Delay
    • Функция Chorus
    • Функция Flange/Wah-Wah
  • Эффекты высоты тона
    • Функция Pitch Bend
    • Функция Pitch Shift
    • Функция Vibrato
  • Эффекты громкости
    • Функция Amplitude Modulation
    • Функция Distortion
    • Функция Graphic Dynamics
    • Функция Multi-Band Dynamics
    • Функция Envelope
    • Функция Gapper/Snipper
    • Функция Noise Gate
  • Реверберация
    • Функция Reverb
    • Функция Acoustic Mirror
  • Функция Wave Hammer
  • Надстройки и DirectX
    • Меню DirectX
    • Audio Plug-In Chainer


Эффекты в программе Sound Forge

Так же как добавление в блюдо специй делает его вкуснее, добавление эффектов к вашим аудиоданным делает их звучание лучше. Эффекты могут превратить тусклую, безжизненную запись в произведение искусства. Например, вы можете применить эффект эха и фоновое окружение, чтобы создать иллюзию, что звук был записан в каких-то конкретных условиях, например в концертном зале. Вы можете также использовать эффекты для придания глубины вокальной партии. Этот список можно продолжать до бесконечности. Программа Sound Forge содержит большое количество функций для создания различных эффектов, оживляющих ваши аудиоданные. Хотя применение таких эффектов к вашим данным не представляет большой сложности, понять, что они делают и как их использовать, не всегда удается сразу. В этой главе мы обсудим следующие темы:

  • реверберация и акустическое зеркало;
  • задержки, хорус и флэнжер;
  • изменение тона и сдвиг тона;
  • сжатие, ограничение и другие эффекты;
  • подключаемые модули и меню DirectX.

Эффекты эха

Не правда ли, вы ведь знаете, что такое эхо? Это повторяющийся звук, имитирующий исходный звук. Например, если вы выкрикнете какое-то слово в большом замкнутом помещении (таком, как концертный зал или каньон), вы будете слышать это слово многократно повторяющимся до тех пор, пока оно не стихнет. Подобный эффект также называется задержка (delay). Задержку можно использовать для создания различных типов эффектов, а не только эха. Программа Sound Forge содержит несколько функций, позволяющих вам создавать эти эффекты.

Функция Simple Delay

Функция Simple Delay (простая задержка) позволяет применять базовые эффекты эха к вашим аудиоданным. Чтобы использовать эту функцию, выполните следующие действия:

1. Выберите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Delay/Echo -> Simple для того, чтобы открыть диалоговое окно Simple Delay (рис. 9.1).

Рис. 9.1. Используйте функцию Simple Delay для добавления базовых эффектов эха к вашим аудиоданным

3. Установите значение параметра Delay time (0.001 to 5.0 seconds). Данный параметр определяет, сколько времени (в секундах) пройдет перед каждым эхом. Вы можете установить значение параметра Delay time (0.001 to 5.0 seconds) в интервале от 0,001 до 5 секунд.

Совет

Многие профессиональные музыканты используют задержку для синхронизации эха с музыкой. Например, вы можете сделать так, что эхо будет появляться с каждой четвертной нотой, восьмой, шестнадцатой и т. д. Для этого требуется всего лишь немного математики.

Начнем с расчета времени задержки, необходимого для синхронизации эха с каждой четвертной нотой. Для этого просто разделите 60 000 (количество миллисекунд в одной минуте) на текущий темп (измеряемый в ударах в минуту) записанной вами музыки. Таким образом, для темпа 120 ударов в минуту вы получите 500 миллисекунд (то есть полсекунды). Если вы установите значение параметра Delay time (0.001 to 5.0 seconds) равным 0,500, эхо будет звучать одновременно с каждой четвертной нотой вашей музыки.

Чтобы рассчитать время задержки для других значений ноты, вам просто нужно умножить или разделить. Поскольку восьмая нота является половиной от четвертной, просто разделите 500 на 2, в результате чего получите 250 миллисекунд (или 0,250 секунды). Шестнадцатая нота является половиной от восьмой, так что делим 250 на 2 и получаем 125 миллисекунд (или 0,125 секунды). Если же вы хотите вычислить значения для больших значений нот, просто умножайте на 2. Поскольку половинная нота вдвое длиннее четвертной ноты, умножьте 500 на 2, и вы получите 1000 миллисекунд (или 1 секунду), и т. д.

4. Установите значения параметров Dry out (-Inf. to 0 dB) и Delay out (-Inf. to 0 dB). Когда вы применяете эффект к вашим исходным данным, вы можете определить, какая доля эффекта и какая доля исходных данных будет в итоговом звуке. Таким образом, вы имеете возможность приложить эффект в определенной степени, не заглушая полностью исходные данные. Параметр Dry out (-Inf. to 0 dB) определяет, какая часть исходных данных будет слышна в обработанном звуке, а параметр Delay out (0.001 to 5.0 seconds) — какую часть эффекты вы услышите в обработанном звуке.

5. Установите флажок Multiple delays (Feedback) и значение параметра Decay time (0.I to 20.0 seconds). С некоторыми эффектами вы можете взять полученный сигнал и прогнать его заново, чтобы применить эффект несколько раз. Это называется обратной связью. Полученный звук может быть различным в зависимости от эффекта. В функции Simple Delay флажок Multiple delays (Feedback) и параметр Decay time (0.1 to 20.0 seconds) управляют тем, сколько раз используется эхо. Если вы активизируете флажок Multiple delays (Feedback), эхо повторится больше одного раза. А чем ниже значение параметра Decay time (O.I to 20.0 seconds), тем меньше количество повторений эха. Чем выше значение параметра Decay time (O.I to 20.0 seconds), тем больше количество повторений эха. К сожалению, из значения параметра Decay time (O.I to 20.0 seconds) невозможно точно определить, сколько раз повторится эхо. Тут вам придется поэкспериментировать.

6. Щелкните по кнопке Preview, чтобы услышать, как файл будет звучать, не внося фактических изменений в данные.

7. Щелкните по кнопке ОК.

Программа Sound Forge применит к вашим аудиоданным функцию Simple Delay в соответствии с вашими настройками.

Функция Multi-Tap Delay

Функция Multi-Tap Delay позволяет вам создавать очень сложные эффекты эха за счет установки сразу нескольких задержек, подобно одновременной установке нескольких эффектов Simple Delay для обработки ваших аудиоданных.

Вот как работает функция Multi-Tap Delay:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Delay/Echo -> Multi-Tap для того, чтобы открыть диалоговое окно Multi-Tap Delay (рис. 9.2).

Рис. 9.2. Функция Multi-Tap Delay позволяет вам создавать очень сложные эффекты эха

3. Установите значения параметров Dry out (-Inf. to 0 dB) и Wet out (-Inf. to 0 dB) . Эти параметры работают точно так же, как и одноименные параметры функции Simple Delay.

4. Установите значение параметра Input gain (-Inf. to 0 dB). Этот параметр определяет, какая часть исходного звука может быть обработана. Чаше всего данный параметр оставляют равным 0 децибел.

5. Установите параметры Mod. rate (0.1 to 10.0 Hz) и Mod. depth (0.1 to 10.0%). Эти параметры описать несколько труднее. Они позволяют добавить к вашим аудиоданным эффект "трели" вместе с эхом. Звук становится также похожим на тремоло, которое вы слышите на электрооргане. Параметр Mod. rate (O.I to 10.0 Hz) определяет скорость (в герцах или циклах в секунду) "трели", а параметр Mod. depth (0.I to 10.0%) определяет, на какую часть аудиоданных эффект будет действовать. Это одна из функций, для понимания действия которой требуется поэкспериментировать.

6. Установите значение параметра Feedback (0 to 150%). Этот параметр работает как сочетание флажка Multiple delays (Feedback) и параметра Decay time (0.1 to 20.0 seconds) функции Simple Delay.

7. Если вы хотите применить к вашему эффекту задержки низкочастотный эквалайзер, активизируйте и установите параметр Low-pass start freq. (Hz). Он позволяет вам отфильтровывать некоторые высокие частоты, чтобы эмулировать среду с более сильным эхом, например маленькую комнату.

8. Установите значение параметра Number of taps (1 to 8). Этот параметр определяет, сколько различных задержек вы хотите установить в эффекте, общим числом до восьми. После настройки параметра Number of taps (1 to 8) вы заметите, что переключатели Current tap (1—8) стали доступными.

9. Каждая задержка имеет свои параметры Тар gain, Delay и Pan. Это означает, что вы можете управлять исходным уровнем громкости, временем эха и панорамированием в стереополе каждой задержки. Чтобы настроить параметры для конкретной задержки, выберите номер задержки в группе переключателей Current tap. После этого настройте параметры Тар gain, Delay и Pan для данной задержки. Для каждой из восьми задержек вы можете сделать это отдельно.

10. После настройки параметров каждой задержки вы заметите изменения на графике, располагающемся непосредственно под переключателями Current tap. Этот график (именуемый эхограммой) позволяет вам визуально оценивать результаты влияния выбранных параметров на эхо. Каждая линия представляет эхо. Длина линии соответствует громкости эха, измеряемой в процентах (вертикальная шкала графика) от исходного звука. Расстояние линии от вертикальной шкалы графика представляет время, когда эхо прозвучит после исходного звука. Красная линия отображает выбранную в данный момент времени задержку. Остальные доступные задержки представлены черными линиями. Голубыми линями представлено эхо, полученное в результате настройки параметра Feedback (0 to 150%). Чтобы определить, какой период времени будет показывать эхограмма, выберите соответствующий пункт из раскрывающегося списка Graph Resolution (Delay ms).

11. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

12. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Multi-Tap Delay к вашим аудиодан-ным в соответствии с установленными параметрами. Поэкспериментируйте с наборами установок для функции Multi-Tap Delay, поставляемыми с программой Sound Forge. Они продемонстрируют вам реальную мощь этой функции.

Функция Chorus

Верите ли вы или нет, но функция Chorus программы Sound Forge содержит многие из параметров функций Simple Delay и Multi-Tap Delay. Почему? Технически хорус является формой задержки. Для достижения результата хорус использует задержку и расстройку. Однако при использовании хоруса вы не услышите эха, поскольку задержка чрезвычайно мала. Вместо этого хорус заставляет ваши аудиоданные звучать "богаче" или "полнее". Название "хорус" происходит из того обстоятельства, что при хоровом пении звук становится более полным, поскольку каждый певец поет несколько не в лад и не в такт — но не настолько, чтобы музыка звучала плохо, а фактически лучше. Вы можете использовать функцию Chorus программы Sound Forge для достижения похожих результатов с вашими аудиоданными. Для использования функции Chorus выполните следующие шаги:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Chorus для того, чтобы открыть диалоговое окно Chorus (рис. 9.3).

3. Установите значение параметра Chorus out delay (0.1 to 100.0 ms). Этот параметр работает подобно параметру Delay time (O.I to 20.0 seconds) функции Simple Delay. Единственное отличие заключается в том, что параметр Chorus out delay (0.1 to 100.0 ms) ограничен 100 миллисекундами. Если вы присвоите этому параметру достаточно высокое значение, вы можете действительно получить короткое многократно повторяющееся эхо. Однако для добавления к вашему звуку эффекта хоруса вы должны установить значение этого параметра между 20 и 40.

4. Установите значения параметров Dry out (-Inf. to 0 dB), Chorus out (-Inf. to 0 dB) и Input gain (-Inf. to 0 dB). Параметр Chorus out (-Inf. to 0 dB) в точности соответствует параметру Delay out (0.1 to 20.0 seconds) функции Simple Delay. Параметры Dry out (-Inf. to 0 dB) и Input gain (-Inf. to 0 dB) мы описали в предыдущем разделе.

5. Установите значение параметра Feedback (0 to 100%). Вместо установки количества повторений эха (как в функции Multi-Tap Delay) этот параметр определяет "глубину" хоруса. Чем выше значение, тем "глубже" хорус.

6. Установите значения параметров Modulation rate (0.001 to 20.0 Hz) и Modulation depth (1 to 100%). Вместо добавления к вашему звуку "трели" (как в функции Multi-Tap Delay) эти параметры определяют, как к хорусу добавляется расстраивание. Параметр Modulation rate (0.001 to 20.0 Hz)

указывает, как быстро произойдет расстраивание, а параметр Modulation depth (I to 100%) — степень расстраивания. Высокое значение параметра Modulation depth (I to 100%) приводит к тому, что ваши аудиоданные действительно звучат расстроенно (что обычно нежелательно), а низкое значение дает приятный эффект хоруса.

Рис. 9.3. Функция Chorus заставляет ваши аудиоданные звучать "богаче" или "полнее"

7. Установите значение параметра Attenuate high frequencies above (Hz). Этот параметр работает точно так же, как параметр Low-pass start freq функции Multi-Tap Delay.

8. Установите значение параметра Chorus size (1 to 3). Этот параметр позволяет вам определять, сколько раз ваши аудиоданные обрабатываются функцией Chorus. Вы можете применить функцию до трех раз подряд, что дает очень глубокий эффект хоруса. Подбор оптимальных настроек возможен только экспериментальным путем.

9. Установите флажки Invert the chorus phase и Invert the feedback phase.

В главе 7 мы говорили о функции Paste Mix и о том, как может происходить подавление фазы, когда вы микшируете вместе определенные звуковые файлы. Подавление фазы происходит, когда громкость одного звукового сигнала увеличивается, а громкость другого звукового сигнала одновременно уменьшается на ту же величину. Благодаря этому явлению они отменяют друг друга, делая микшированный звук "глухим". С помощью флажков Invert the chorus phase или Invert the feedback phase вы при необходимости можете устранить подавление фазы.

10. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

11. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Chorus к вашим аудиоданным в соответствии с установленными параметрами.

Функция Flange/Wah-Wah

Хотя функция Flange/Wah-Wah не имеет таких же параметров, как функция Simple Delay, флэнжер, тем не менее, является формой задержки. То же самое относится и к фейзеру и к эффекту Wah-Wah, получить доступ к которым также можно через функцию Flange/Wah-Wah. Эти эффекты приводят к очень странным типам "космических", "свистящих" звуков и звуков с "трелью" путем микширования слегка задержанной версии исходного звука с исходной версией звука. Как и в случае создания хоруса, вы не услышите эха, поскольку задержка очень мала. На что эти эффекты похожи, описать трудно, так что поэкспериментируйте сами. Чтобы использовать функцию Flange/Wah-Wah, выполните следующие шаги:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Flange/Wah-Wah для того, чтобы открыть диалоговое окно Flange/Wah-Wah (рис. 9.4).

3. Выберите вид эффекта (Flange, Phase или Wah-Wah) в группе переключателей Effect.

4. Установите значения параметров Dry out (-Inf. to 12 dB) и Wet out (-Inf. to 12 dB). Они работают так же, как и параметры Dry ut (-Inf. to 0 dB) и Chorus out (-Inf. to 0 dB) функции Chorus.

5. Установите значение параметра Rate (0.001 to 20.0 Hz). Этот параметр управляет скоростью эффекта во всех трех режимах операции: Flange, Phase или Wah-Wah.

6. Установите значение параметра Depth (I to 100%). Если вы выберете режим Flange, параметр Depth (I to 100%) будет в таком случае управлять тем, в какой степени эффект флэнжера применяется к вашим аудиоданным. Если вы выберете режим Phase, параметр Depth (I to 100%) будет управлять диапазоном частот, на которые влияет эффект фейзера. Если вы выберете режим Wah-Wah, параметр Depth (I to 100%) будет управлять диапазоном частот, на которые влияет эффект Wah-Wah.

Рис. 9.4. Функция Flange/Wah-Wah придаст вашим аудиоданным действительно странное звучание

7. Если вы выбрали режим Flange, вы можете перейти к шагу 9. В противном случае установите параметр Center frequency (Hz). В обоих режимах, Phase и Wah-Wah, параметр Center frequency (Hz) управляет частотой, на которой эффекты фейзера или Wah-Wah, наиболее ярко выражены. Например, если вы обрабатываете запись пения тенора, вам нужно установить значение параметра Center frequency (Hz) равным приблизительно 261 Гц, чтобы применить эффект к центру диапазона голоса тенора (диапазон тенора — приблизительно 130 и 493 Гц). Конечно, это только один пример. Поэкспериментируйте, чтобы найти правильные настройки для вашего аудиоматериала.

8. Установите значение параметра Resonance (I to 100%). Для обоих режимов, Phase и Wah-Wah, параметр Resonance (I to 100%) управляет тем, насколько четко выражены в ваших аудиоданных эффекты фейзера и Wah-Wah. Чем ниже значение параметра Resonance (I to 100%), тем слабее выражен эффект. Чем выше значение параметра Resonance (I to 100%), тем сильнее выражен эффект.

9. Щелкните на кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

10. Нажмите по кнопку ОК.

Программа Sound Forge применит функцию Flange/Wah-Wah к вашим аудиоданным в соответствии с установленными параметрами.


Эффекты высоты тона

Бывают ситуации, когда вам нужно изменить высоту тона ваших аудиодан-ных. Например, вам может потребоваться подкорректировать голос сфальшивившего певца или инструментальное сопровождение. Программа Sound Forge содержит три различных функции, позволяющих вам изменять высоту тона ваших данных разными способами. К таким функциям относятся Pitch Bend, Pitch Shift и Vibrato. Рассмотрим их все по порядку.

Функция Pitch Bend

Функция Pitch Bend позволяет изменять высоту тона аудиоданных за период времени. Например, с помощью этой функции вы можете сделать так, что ваш звук будет медленно повышаться от начала до конца записи, если вам нужен такой эффект. Функция Pitch Bend весьма универсальна. Вот как она работает:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Pitch -> Bend для того, чтобы открыть диалоговое окно Pitch Bend (рис. 9.5). В этом диалоговом окне вы увидите график. На левой шкале графика показаны значения высоты тона, которые могут находиться в диапазоне от —24 до +24 полутонов (в соответствии с параметром Range (+/-24), ползунок установки которого расположен непосредственно около графика, слева). На графике показана линия, представляющая собой изгиб высоты тона, который будет применен к выделенным аудиоданным. Если смотреть на линию слева направо, левый ее конец представляет начало выделения аудиоданных, а правый — конец выделения аудиоданных. Если бы линия была настроена так, что левый конец был бы внизу графика, а правый — вверху, к вашим аудиоданным было бы применено быстрое понижение тона, а затем его постепенное повышение. Это происходит потому, как вы можете видеть, что левый конец линии установлен на высоте тона, меньшей, чем нормальная (представленной нулем в середине графика), а правый конец — на высоте тона, большей, чем нормальная. Поэтому высота тона должна быстро начаться при меньшем значении, постепенно вырасти до нормальной, а затем — до высшего значения. Поняли, как это работает?

( Совет )

Если вы применяете изгиб высоты тона к стереофайлу, вы можете включить показ ваших аудиоданных на фоне графика, установив флажок Show wave. Вы можете также выбрать, чтобы были показаны данные только из правого или левого канала или смикшированный звук из обоих каналов, выбрав вариант из раскрывающегося списка, расположенного рядом с флажком Show wave. Однако это не влияет на то, как изгиб высоты тона применяется к вашим данным. Если вы хотите применить изгиб высоты тона только к одному из стереоканалов, вам необходимо выделить только данные из этого канала перед тем, как вы откроете диалоговое окно Pitch Bend .

Рис. 9.5. Используйте функцию Pitch Bend для постепенного изменения высоты тона ваших аудиоданных

3. Вы можете изменить форму линии изгиба высоты тона одним из двух способов. Можно просто выбрать один из готовых наборов параметров в раскрывающемся списке Name. В качестве альтернативы вы можете изменить линию высоты тона, щелкая на маленьких квадратиках на концах линии и перетаскивая их. Эти квадратики называются точками огибающей (Envelope Points).

4. Если вы хотите создать какие-то действительно сложные изгибы высоты тона, вы можете добавить дополнительные точки огибающей, щелкая в любом месте линии высоты тона. Чем больше точек огибающей вы добавите (максимально допустимое их количество равно 16), тем большую гибкость вы получите при изменении формы линии (рис. 9.6).

5. Если вы хотите настроить диапазон изгиба высоты тона (одновременно с масштабом высоты тона на графике), используйте параметр Range, о котором мы уже говорили. Для небольших изгибов высоты тона используйте маленькие значения, а для более заметных изгибов высоты тона — большие значения.

Рис. 9.6. Вы можете создать действительно сложные изгибы высоты добавлением дополнительных точек огибающей

6. Щелкните на кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

7. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Pitch Bend к вашим аудиодан-ным в соответствии с установленными параметрами.

Функция Pitch Shift

Обычно, когда вы изменяете высоту тона аудиоданных, их длина также меняется. Увеличьте высоту тона и данные станут короче; уменьшите высоту тона и данные станут длиннее. Именно это происходит при использовании функции Pitch Bend. К счастью, вы можете использовать функцию Pitch Shift программы Sound Forge для изменения высоты тона без изменения длины аудиоданных. Вот как работает функция Pitch Shift:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Pitch -> Shift для того, чтобы открыть диалоговое окно Pitch Shift (рис. 9.7).

3. Установите значения параметров Semitones to shift pitch by (-12 to 12) и Cents to shift pitch by (-100.0 to 100.0). Эти параметры управляют тем, насколько высота тона будет сдвинута вверх или вниз. Для больших изменений используйте параметр Semitones to shift pitch by (-12 to 12). Для более точной настройки используйте параметр Cents to shift pitch by (-100.0 to 100.0). В терминах высоты тона каждый полутон содержит 100 центов.

Рис. 9.7. Используйте функцию Pitch Shift для изменения высоты тона ваших аудиоданных без изменения их длины

Совет

Единственная проблема, на которую нужно обратить внимание, заключается в том, что сдвиг высоты тона может породить нежелательные искажения, если вы используете слишком большой интервал. Лучше всего оставаться в пределах большой терции (четыре полутона) вверх или вниз, если это возможно.

4. Установите значение параметра Accuracy (I low to 3 high) для того, чтобы указать качество обработки сдвига высоты тона, которое вы хотите использовать. Чем выше качество, тем медленнее обработка. Если ваш аудиофайл имеет не самые огромные размеры, лучше использовать значение High, соответствующее наилучшему качеству.

5. При повышении высоты тона звука в данные может быть внесено искажение. Для того чтобы решить подобную проблему, установите флажок Apply an and-alias filter during pitch shift. Если вы понижаете высоту тона ваших аудиоданных, вам не нужно заботиться об этом.

6. Если вы не хотите, чтобы длина ваших аудиоданных изменялась при применении сдвига высоты тона, установите флажок Preserve duration. После этого выберите вариант из раскрывающегося списка Mode. Выберите соответствующий вариант в зависимости от типа данных, которые вы собираетесь обработать. Например, если вы обрабатываете нетональные ударные инструменты, вы можете использовать вариант Drums, Un-pitched. Правильные настройки вы можете найти путем эксперимента.

7. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

8. Щелкните по кнопке ОК.

Программа Sound Forge применит функцию Pitch Shift к вашим аудиодан-ным в соответствии с установленными параметрами.

Функция Vibrato

Функция Vibrato подобна функции Pitch Bend, но вместо изгиба высоты тона она непрерывно модулирует (или "вибрирует") высоту тона вверх и вниз. При еле заметном применении это дает некоторый эффект трели. При более активном применении вы можете также добиться весьма необычных эффектов изменения высоты тона. Вот как работает функция Vibrato:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Vibrato для того, чтобы открыть диалоговое окно Vibrato (рис. 9.8). В этом диалоговом окне вы увидите график. На левой шкале графика показаны значения высоты тона, которые могут находиться в диапазоне от —24 до +24 полутонов (в соответствии с параметром Semitones (+/-Z4), ползунок установки которого расположен непосредственно слева от графика). На графике изображена линия, представляющая вибрато, которое будет применено к выделенным аудиоданным. Линия составляет один цикл (или вибрацию). Такая вибрация последовательно повторяется с определенной скоростью до тех пор, пока не будет применена ко всему выделению аудиоданных. Это не очень просто описать, но один раз попробовав, вы поймете смысл.

3. Вы может изменить форму линии вибрато одним из двух способов: просто выберите один из возможных наборов установок в раскрывающемся списке Name или измените линию вибрато графически, щелкая на маленьких квадратиках (точках огибающей) на концах линии и перетаскивая их.

Рис. 9.8. Используйте функцию Vibrato для добавления эффектов изменения высоты тона к вашим аудиоданным

4. Если вы хотите создавать действительно сложные эффекты вибрато, вы можете добавить дополнительные точки огибающей, щелкая в любом месте линии вибрато. Чем больше точек огибающей вы добавите, тем больше гибкости вы будете иметь при изменении формы линии.

Совет

Поскольку линия вибрато представляет один цикл колебания (или вибрацию), левый и правый края линии должны заканчиваться на графике на одной и той же вертикальной позиции. Например, они оба могут лежать на нулевой линии в середине графика. Это нужно для сглаживания эффекта вибрато. Если концы линии не находятся на одной и той же вертикальной позиции, в вашей записи могут появиться треск и щелчки. Для решения этой проблемы вы можете попробовать установить флажок Blend graph edges и посмотреть, исчезли ли после этого треск и щелчки.

5. Если вы хотите настроить диапазон вибрато (одновременно с масштабом высоты тона на графике), используйте параметр Semitones (+/-24), уполишавшийся выше. Для легкого вибрато используйте маленькие значения, а для более заметного — большие.

6. Установите значение параметра Modulation freq (0.001 to 1,000 Hz). Этот параметр управляет скоростью вибрато. Высокие значения дают эффект трели, малые — в большей степени эффект изгиба высоты тона.

Совет

Для очень слабого эффекта вибрато выберите набор настроек Vibrato 2. Затем измените значение параметра Semitones (+/-24) так, чтобы диапазон стал от -0,45 до +0,45 полутонов. Наконец, установите значение параметра Modulation freq (0.001 to 1,000 Hz) равным 9,000. Именно такие настройки мы используем в своем наборе настроек Subtle Vibrato Preset.

7. С помощью движка Output gain (-Inf. to 24 dB) укажите уровень громкости файла после обработки. Таким способом вы можете сделать ваш звук громче или тише.

8. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

9. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Vibrato к вашим аудиоданным в соответствии с установленными параметрами.


Эффекты громкости

В дополнение ко всем функциям обработки уровня громкости, о которых мы говорили в главе 8, программа Sound Forge содержит еще несколько функций, которые управляют громкостью для создания эффектов. С помощью этих функций вы можете применять к вашим аудиоданным амплитудную модуляцию, искажение, сжатие и многие другие типы обработки. В этом разделе мы последовательно рассмотрим все эти функции.

Функция Amplitude Modulation

Функция Amplitude Modulation работает почти идентично функции Vibrato, за исключением того, что вместо частот модуляции (или "вибрации"), функция Amplitude Modulation модулирует амплитуды (или громкость) ваших аудиоданных. С помощью этой функции вы можете достигать таких эффектов, как тремоло на электрооргане. Вот как работает функция Amplitude Modulation:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2 Выполните команду меню Effects -> Amplitude Modulation для того, чтобы открыть диалоговое окно Amplitude Modulation - Funky saxophone nff (рис 9 9) В этом диалоговом окне вы увидите график. На левой оси графика показаны значения амплитуды, которые могут находиться в диапазоне от -Inf. до 0 децибел (в соответствии с параметром Amplitude (-Inf. to 0 dB) движок управления значением которого расположен непосредственно слева от графика). На графике показана кривая, представляющая изменения громкости, которые будут применены к выделенным аудиоданным в зависимости от времени. Линия составляет один цикл (или вибрацию). 1а-кая вибрация последовательно повторяется с определенной скоростью до тех пор, пока не будет применена ко всему выделению аудиоданных. Это не очень просто описать, но один раз попробовав, вы поймете смысл.

Рис 9 9. Используйте функцию Amplitude Modulation для добавления^ вашим аудиоданным эффектов изменения громкости

3 Вы можете изменить форму амплитудной линии одним из двух способов: выберите один из возможных наборов установок в раскрывающемся списке Name или измените линию вибрато графически, щелкая на маленьких квадратиках (точках огибающей) на концах линии и перетаскивая их.

4. Если вы хотите создавать действительно сложные эффекты изменения громкости, вы можете добавить дополнительные точки огибающей, щелкая в любом месте амплитудной линии. Чем больше точек огибающей вы добавите, тем больше гибкости вы будете иметь при изменении формы линии.

Совет

Поскольку амплитудная линия представляет один цикл колебания (или вибрацию), левый и правый края линии должны заканчиваться на графике на одной и той же вертикальной позиции. Например, они оба могут лежать на линии в середине графика. Это нужно для сглаживания эффекта изменения громкости. Если концы линии не находятся на одной и той же вертикальной позиции, в вашей записи могут появиться треск и щелчки. Для разрешения этой проблемы вы можете попробовать установить флажок Blend graph edges и посмотреть, исчезли ли после этого треск и щелчки.

5. Если вы хотите настроить диапазон изменений громкости (одновременно с масштабом амплитуды на графике), примените параметр Amplitude (-Inf. to 0 dB), упоминавшийся выше. Для небольших изменений используйте маленькие значения. Для более заметных изменений используйте большие значения.

6. Установите значение параметра Mod. fireq. (0.001 to 5,000 Hz). Этот параметр управляет скоростью изменений громкости. Высокие значения дают эффект тремоло, а малые — в большей степени медленные, но гладкие изменения громкости.

Совет

Для очень слабого эффекта тремоло выберите набор настроек, который называется Sine. Затем измените значение параметра Amplitude (-Inf. to 0 dB) таким образом, чтобы диапазон стал от -2,9 до -5,8. Наконец, установите значение параметра Mod. freq. (0.001 to 5,000 Hz) равным 10. Именно такие настройки мы используем в нашем наборе настроек Subtle Tremolo Preset.

7. Установите значение параметра Low-pass start freq. (Hz). Этот параметр работает так же, как параметр Low-pass start freq. (Hz) функции Multi-Tab Delay. По существу, он позволяет вам отфильтровывать некоторые из высоких частот ваших аудиоданных.

8. Настройте параметры Dry out (-Inf. to 0 dB) и Wet out (-Inf. to 0 dB). Мы их уже описывали в данной главе.

9. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

10. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Amplitude Modulation к вашим аудиоданным в соответствии с установленными параметрами.

Совет

Если вы применяете функцию Amplitude Modulation к стереофоническому файлу, вы можете создавать некоторые отличные эффекты автоматического панорамирования путем настройки параметра Stereo pan (0 to 100%) в диалоговом окне Amplitude Modulation . Установите для этого параметра низкое значение, если хотите получить слабый эффект панорамирования, а для действительно быстрого движения в стереополе используйте большое значение.

Функция Distortion

В большинстве случаев мы стараемся избежать искажений (distortion) в процессе записи. Однако иногда искажение может оказаться полезным. Например, если вы хотите украсить гитарную партию, добавление небольшого искажения может придать ей действительно замечательный звук. Или если вы хотите добавить к вокальной партии немного хрипотцы. Использование искажения как эффекта может оказаться здесь удобным. Вот здесь пригодится функция Distortion программы Sound Forge и вот как она работает:

1. Выделите в вашем аудиофайле данные, которые хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выберите команду меню Effects -> Distortion для того, чтобы открыть диалоговое окно Distortion (рис. 9.10). В этом диалоговом окне вы увидите график. На вертикальной шкале графика показаны значения выходной амплитуды, а на горизонтальной — входная амплитуда. Внутри графика имеется линия, представляющая соотношение входной амплитуды и выходной амплитуды. Первоначально линия рисуется диагонально и вы "читаете" ее слева направо. Такая линия показывает соотношение 1:1 между входной амплитудой и выходной амплитудой, т. е., если входной уровень равен 1 дБ, то и выходной уровень тоже равен 1 дБ.

3. Вы можете изменить форму линии графически, щелкая на маленьких квадратиках (точках огибающей) на концах линии и перетаскивая их. Реальная польза от функции Distortion проявляется, когда вы добавляете новые точки огибающей, щелкая в различных местах линии. Когда вы добавляете новые точки и изменяете форму линии, это оказывает влияние на амплитуду ваших аудиоданных. Если вы передвигаете точки огибающей на графике вверх, амплитуда растет. Если вы передвигаете точки огибающей на графике вниз, амплитуда уменьшается. Уменьшение амплитуды мало что дает, а вот увеличение амплитуды может привести к появлению эффекта искажения ваших аудиоданных. Например, если вы добавите к графику точки огибающей там, где входной и выходной уровни пересекаются при —48 дБ, а затем поднимете эту точку так, что входной уровень останется равным -48 дБ, а выходной уровень станет равным 24 дБ, вы услышите в ваших аудиоданных небольшое искажение Это происходит потому, что когда входная амплитуда достигает значения 48 дБ, выходная амплитуда увеличивается на 24 дБ. Поэкспериментируйте с этим эффектом и вы поймете, что мы имели в виду.

Рис. 9.10. Используйте функцию Distortion для добавления к вашим аудиоданным эффекта искажения

4. Кроме того, функция Distortion позволяет вам настраивать амплитуду различных частей ваших аудиоданных. Форма аудиосигнала имеет положительные и отрицательные части. Положительные части аудиосигнала - это те, которые находятся выше нулевой оси. Соответственно отрицательные части находятся ниже нулевой оси. Выбрав режим в раскрывающемся списке Graph polarity edit mode и нажав на кнопку Positive/Negative, вы можете создать на графике две линии, которые управляют тем, как функция Distortion влияет на различные части вашего аудиосигнала. Если вы выберете режим Individual, вы сможете создать на графике две независимые линии для положительных и отрицательных аудиоданных. Используйте кнопку Positive/Negative для переключения между линиями, которые вы хотите редактировать. Если вы выберете режим Synchronize, и положительные, и отрицательные данные будут управляться одной линией. Если вы выберете режим Mirror Y, положительные и отрицательные линии будут отражаться на вертикальной оси графика. Если вы выберете режим Mirror X , положительные и отрицательные линии будут отражаться на горизонтальной оси графика. Если вы выберете режим Mirror X/Y , положительные и отрицательные линии будут отражаться и на горизонтальной оси, и на вертикальной оси графика. Мы понимаем, что это звучит очень сложно — но это так и есть. Если вы некоторое время поэкспериментируете с данным эффектом, вы начнете понимать его смысл.

5. Если вы хотите управлять тем, насколько ваши аудиоданные могут изменяться в зависимости от времени, установите флажок Slew rate (I to 100). Чем меньше значение, тем меньше изменение. Чем выше значение, тем больше изменение. Низкое значение иногда может оказаться полезным для остановки сигнала из фрагмента, не затрагивая при этом эффекта искажения.

6. Установите значение параметра Low-pass start freq для фильтрации некоторых высоких частот ваших аудиоданных. Этот параметр может быть полезен, если у вас имеется действительно сильный эффект искажения, но на высоких частотах появляется нежелательный гул. Данный параметр помогает удалить такой гул.

7. Установите значения параметров Dry out (-Inf. to 0 dB) и Wet out (-Inf. to 24 dB). Эти параметры работают так же, как и остальные параметры Dry out и Wet out, описанные выше в этой главе.

8. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

9. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Distortion к вашим аудиоданным в соответствии с установленными параметрами.

Функция Graphic Dynamics

Функция Graphic Dynamics позволяет применять к вашим аудиоданным эффекты сжатия и ограничения. Что это значит? Чтобы объяснить это, необходимо рассказать о процессе записи вокала. Предположим, вы записали вокалиста, не имеющего хороших навыков работы с микрофоном. Когда он поет, то остается постоянно на одном месте перед микрофоном. Профессиональные певцы знают, что в тихих частях песни они должны приблизиться к микрофону, а на громких участках отодвинуться от микрофона, чтобы обеспечить один уровень амплитуды при записи. Если певец не делает этого, амплитуда записанного звука может оказаться очень неровной. Вот здесь пригодится сжатие и ограничение. Сжатие позволяет вам уплотнить аудиосигнал так, что уровни амплитуды будут более ровными. Ограничение позволяет уменьшить рост амплитуды до определенного уровня во избежание обрезания. Такое может произойти, если исполнитель поет слишком громко. Чтобы использовать функцию Graphic Dynamics, сделайте следующее:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Dynamics -> Graphic для того, чтобы открыть диалоговое окно Graphic Dynamics (рис. 9.11). В этом окне присутствует график, подобный графику в окне функции Distortion. На вертикальной оси графика показаны значения выходной амплитуды, а на горизонтальной — входной. Внутри графика имеется линия, представляющая соотношение входной и выходной амплитуд. Первоначально линия рисуется диагонально и вы "читаете" ее слева направо. Такая линия показывает соотношение 1:1 между входной и выходной амплитудами, т. е., если входной уровень равен 1 дБ, то и выходной тоже равен 1 дБ. Даже несмотря на то, что вы можете добавить к графику дополнительные точки огибающей, как и в случае с функцией Distortion, для создания эффектов сжатия и ограничения вам это не нужно.

3. Установите значение параметра Threshold (-80 to -0.1 dB). Функция Graphic Dynamics использует цифровой шлюз сигнала для идентификации частей ваших аудиоданных, которые нужно обработать. Параметр Threshold (-80 to -0.1 dB) определяет, при каком уровне амплитуды начнется сжатие или ограничение ваших аудиоданных. Когда амплитуда ваших аудиоданных достигает порогового уровня, начинается обработка.

4. Установите значение параметра Ratio (1.0.1 to Inf.:1). Этот параметр определяет степень обработки ваших аудиоданных. Соотношение 1:1 означает отсутствие обработки. Соотношение 2:1 означает, что на каждые 2 дБ увеличения входной амплитуды приходится только 1 дБ увеличения выходной амплитуды. Таким образом, амплитуда сжимается. Если вы присвоите параметру Ratio (1.0.1 to Inf.:1) наибольшее возможное значение (Inf:l), это приведет к ограничению, так что вне зависимости от громкости входной амплитуды она будет ограничена уровнем, установленным параметром Threshold (-80 to -0.1 dB).

5. Установите значение параметра Attack (0 to 500 ms). Этот параметр определяет, насколько быстро начинается обработка после того, как входной уровень достиг порогового значения. Например, если входной уровень достигает порогового значения, он необязательно будет сжат немедленно. Низкое значение параметра Attack (0 to 500 ms) означает, что сигнал не будет сжиматься до окончания некоторого интервала времени. Это хороший способ обеспечить, чтобы быстрые части записи с использованием ударных инструментов остались нетронутыми, а длинные плавные части были сжаты. Однако если вы хотите ограничить сигнал, лучше применить действительно быстрое значение параметра Attack (0 to 500 ms) (порядка 1 мс).

Рис. 9.11. Используйте функцию Graphic Dynamics для применения к аудиоданным сжатия и ограничения

6. Установите значение параметра Release (0 to 5,000 ms). Данный параметр определяет, насколько быстро после того, как входной уровень опустился ниже порогового значения, останавливается обработка (или закрывается цифровой шлюз сигнала). Если вы установите значение параметра Release (0 to 5,000 ms) слишком низким, ваши аудиоданные могут оказаться обрезанными. Более длинное значение параметра Release (0 to 5,000 ms) позволяет добиться при обработке более натурального звука. Для поиска правильных значений вам придется поэкспериментировать.

7. Установите флажок Sync stereo gain. Если вы обрабатываете стереофонический звук, вы, скорее всего, предпочтете, чтобы этот флажок был установлен. Это гарантирует, что оба канала стереозвука будут обработаны одинаково.

8. Установите флажок Auto gain compensate. В вышеупомянутом примере с пением мы говорили о сглаживании уровней амплитуды в записи вокального исполнения. Когда вы сжимаете сигнал, его уровни высокой амплитуды уменьшаются, но уровни низкой амплитуды остаются неизменными. Для того чтобы сделать уровни амплитуды ровными, низкие уровни необходимо поднять. Установка флажка Auto gain compensate увеличивает в ваших аудиоданных уровни низкой амплитуды, так что после применения сжатия вы получите более ровный звук.

9. Установите значение параметра Output gain ( -25 to 25 dB). Этот параметр позволяет вам настраивать общую амплитуду звука после обработки.

10. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

11. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Graphic Dynamics к вашим ау-диоданным в соответствии с установленными параметрами.

Функция Multi-Band Dynamics

Подобно функции Graphic Dynamics, функция Multi-Band Dynamics позволяет вам применять к аудиоданным сжатие и ограничение. Однако эта функция имеет одно важное отличие: она позволяет вам обрабатывать различные диапазоны частот независимо друг от друга. Почему это важно? Возможно, вы замечали при записи пения, что у некоторых певцов в словах, содержащих букву "с", получается некоторое шипение. Обычно такой звук в записи нежелателен. Удалить шипение можно путем сжатия некоторых частот в звуковом спектре. Чтобы использовать функцию Multi-Band Dynamics, выполните следующие действия:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Dynamics -> Multi-Band для того, чтобы открыть диалоговое окно Multi-Band Dynamics - Sibilants and Plo-siver (рис. 9.12).

3. Функция Multi-Band Dynamics фактически содержит четыре функции сжатия/ограничения. Имеются четыре набора элементов управления, именуемых дорожками (Band). Каждая дорожка может быть включена или выключена с помощью флажка Band I bypass или Band 2 bypass.

Первые две дорожки располагаются на вкладке Bands 1 & 2 (ярлычки вкладок находятся внизу диалогового окна). Второй набор дорожек находится на вкладке Bands 3 & 4. Все дорожки идентичны. Вы можете активизировать дорожку, сняв ее флажок Band I bypass или Band 2 bypass. В данном примере снимите флажок Band 1 bypass.

Рис. 9.12. Используйте функцию Multi-Band Dynamics для применения сжатия и ограничения к определенным диапазонам частот в ваших аудиоданных

4. Установите значение параметра Threshold. Этот параметр работает так же, как параметр Threshold функции Graphic Dynamics.

Совет

Функция Multi-Band Dynamics имеет также возможность автоматического обнаружения порога. Если эта возможность активизирована, пороговый уровень определяется автоматически, когда вы нажимаете на кнопку Preview для прослушивания вашей записи до того, как фактически обрабатывать ее. Чтобы включить эту возможность, установите флажок Capture threshold в нижней части диалогового окна. Функция Capture Threshold может оказаться полезной для обнаружения исходных значений параметра Threshold. Впоследствии вы можете отключить функцию Capture Threshold, чтобы сделать дополнительные регулировки параметра Threshold перед обработкой.

5. Установите значение параметра Amount. Данный параметр работает так же, как и параметр Ratio (1.01 to Inf.:l) функции Graphic Dynamics.

6. Установите значение параметра Gain. Этот параметр управляет выходной амплитудой текущей дорожки, с которой вы работаете. Вы можете использовать параметр Gain для определения, в какой степени результаты обработки каждой дорожки будут присутствовать в конечном выводе функции Multi-Band Dynamics.

7. Установите значение параметра Attack time (0 to 500 ms). Этот параметр работает так же, как и параметр Attack функции Graphic Dynamics.

8. Установите значение параметра Release time (0 to 5,000 ms). Этот параметр работает так же, как и параметр Release функции Graphic Dynamics.

9. Выберите необходимый вариант в раскрывающемся списке Туре. Этот параметр определяет тип эквалайзера, который вы хотите использовать для обработки ваших аудиоданных. Мы рассказывали об этих типах эквалайзеров в разд. "Функция Parametric EQ" главы 8. Вариант Low-shelf позволяет отфильтровывать низкие частоты. Вариант High-shelf позволяет отфильтровывать высокие частоты. Вариант Band-notch дает возможность отфильтровывать конкретные частоты. Например, если вы хотите удалить из записи шипение, вам стоит использовать вариант Band-notch.

10. Установите значение параметра Center (50 to 15,000 Hz). Этот параметр определяет частоту, при превышении которой или при которой ваши аудиоданные будут сжаты. Мы также говорили об этом в разд. "Функция Parametric EQ" главы 8. В примере с шипением хорошим значением данного параметра будет 5000 Гц.

11. Если вы выбрали вариант Band-notch, вам также потребуется установить параметр Width (0.3 to 3 oct.). Этот параметр определяет, в какой степени будут затронуты частоты вокруг частоты, указанной с помощью движка Center. Низкое значение приведет к тому, что фокус будет в основном на частоте, которую вы указали. Высокое значение приведет к тому, что будет обработан диапазон частот вокруг частоты, которую вы указали с помощью движка Center. В примере с шипением лучше начать с небольшого значения порядка 1,0.

12. Повторите шаги с 3 по 11 для каждой дорожки, которую вы хотите использовать.

13. Установите флажок Sync stereo channels. Если вы обрабатываете стереофонический звук, вы, скорее всего, захотите установить данный флажок.

Это гарантирует, что оба канала в стереофонических аудиоданных будут обработаны одинаково.

14. Установите значение параметра Output gain (-25 to 25 dB). Этот параметр позволяет вам регулировать общую амплитуду из всех дорожек в функции Multi-Band Dynamics.

15. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

Совет

Когда вы предварительно прослушиваете ваши аудио-данные, вы можете использовать индикаторы уровня каждой дорожки для отслеживания входного уровня, выходного уровня и уровня сжатия. Просто убедитесь, что флажок Enable meters (расположенный в нижней части диалогового окна) помечен. Вы можете переключаться между мониторингом входного или выходного уровней, щелкая на кнопке Input/Output (расположенной непосредственно под каждым набором индикаторов). Кроме того, если вы хотите услышать вашу запись, обработанную только на одной дорожке, чтобы убедиться в правильности выбранных вами настроек, просто установите флажок Solo для этой дорожки. Сброс флажка Solo включает обработку для всех остальных доступных дорожек.

16. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Multi-Band Dynamics к вашим аудиоданным в соответствии с установленными параметрами.

Функция Envelope

Верите ли вы или нет, функция Envelope работает фактически так же, как и функция Graphic Fade, о которой мы говорили в главе 8. В документации по программе The Sound Forge говорится, что "в отличие от функции Graphic Fade, которая просто приводит к затуханию звукового сигнал на определенную величину за единицу времени, в функции Envelope усиление вычисляется в каждый момент динамически для получения точной огибающей". Однако нам кажется, что функция Graphic Fade генерирует более качественный звук и является даже более гибкой, поскольку вы при желании можете увеличивать амплитуду более чем на 100%. В любом случае для того, чтобы использовать функцию Envelope, нужно выполнить следующие шаги:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Envelope для того, чтобы открыть диалоговое окно Envelope (рис. 9.13). В этом окне отображен график. На вертикальной оси графика показаны значения амплитуды, которая может быть в диапазоне от 0 до 100%. На графике изображена линия, представляющая амплитудную огибающую, которая будет применена к выделенным аудиоданным. Если вы посмотрите на линию слева направо, левый край линии представляет начало выделения аудиоданных, а правый — конец выделения аудиоданных. Если линия настроена так, что левый край находится внизу графика, а правый край — наверху, то к амплитуде аудиоданных будет применено линейное увеличение, поскольку, как вы можете видеть из графика, левый край линии установлен в позиции 0%, а правый край — в позиции 100%. Таким образом, уровень громкости будет начинаться с нуля и расти до 100%. Видите, как это работает?

Рис. 9.13. Функция Envelope почти полностью совпадает с функцией Graphic Fade

Совет

Если вы применяете к стереофоническому файлу затухание, то если вы установили флажок Show wave, аудиоданные будут показываться на фоне графика. Вы можете также выбрать, показывать ли данные из левого или правого канала или смикшированные данные из обоих каналов, выбрав соответствующий вариант из раскрывающегося списка, расположенного рядом с флажком Show wave. Это не влияет на то, как затухание применяется к вашим аудиоданным. Если вы хотите применить затухание только к одному из стереоканалов, вам необходимо выделить данные только из этого канала до того, как вы откроете диалоговое окно Envelope .

3. Вы можете изменить форму огибающей одним из двух способов: либо выбрав один из готовых наборов настроек в раскрывающемся списке Name, либо изменив огибающую графически, щелкнув на меленьком квадратике (точке огибающей) на конце линии и перетащив ее мышкой в другое положение.

4. Если вы хотите создавать действительно сложные огибающие, вы можете добавлять к огибающей новые точки, щелкая мышью в любом месте огибающей. Чем больше точек вы добавите к огибающей (их может быть не больше шестнадцати), тем большей гибкости вы достигнете в изменении формы линии.

5. Установите флажок Smooth gain to minimize distortion on steep slopes. Это приведет к тому, что изменения амплитуды будут применяться не слишком резко, чтобы избежать искажений. Обычно лучше оставлять данный флажок установленным.

6. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

7. Нажмите на кнопку ОК.

Программа Sound Forge изменит уровень громкости выделенных аудио-данных в соответствии с параметрами, установленными в диалоговом окне Envelope - Funky saxophone riff.

Функция Gapper/Snipper

Функция Capper/Snipper является несколько странной, не из-за эффектов, которые она производит, а из-за способа, которым она их реализует. Добавляя к вашей записи фрагменты данных или обрезая их, функция Capper/ Snipper позволяет вам генерировать эффекты тремоло, трели и заикания. Фрагменты данных, применяемые к вашей записи или удаляемые из нее, столь малы, что не разрушают запись, а приводят к появлению интересных звуков. Проблема с функцией Capper/Snipper заключается в том, что при добавлении данных в вашу запись или при удалении данных из нее длина записи также изменяется, что может оказаться нежелательным. Тогда вам нужно после применения функции Gapper/Snipper всегда использовать функцию Time Compress/Expand для исправления длины записи. В любом случае, функция Gapper/Snipper работает так:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выберите пункт меню Effects -> Gapper/Snipper для того, чтобы открыть диалоговое окно Gapper/Snipper - Funky saxophone riff (рис. 9.14).

3. Выберите переключатель в группе Effect. Если вы активизируете переключатель Capper (insert), в ваши аудиоданные будут добавлены маленькие фрагменты тишины, что увеличит длину файла. А если вы активизируете переключатель Snipper (cut), из ваших аудиоданных будут вырезаны маленькие фрагменты данных, в результате чего файл укоротится.

Рис. 9.14. Используйте функцию Capper/Snipper для применения к вашим аудиоданным эффектов тремоло, трели и заикания

4. Установите значение параметра Freq to gap/snip events (0.001 to 1,000 Hz). Этот параметр определяет, сколько пробелов будет добавлено или сколько фрагментов будет вырезано из аудиоданных. Чем ниже значение, тем меньше пробелов и вырезаний. Чем выше значение, тем больше пробелов и вырезаний. Высокие значения могут привести к появлению эффекта гула, если они использованы в режиме Snipper, и к эффекту заикания в режиме Capper.

5. Установите значение параметра Length of one event (.0001 to 1,000 Hz). Этот параметр определяет длину каждого пробела или вырезания (в секундах), применяемого к вашим аудиоданным. Чем ниже значение этого параметра, тем короче пробелы или вырезания. Чем выше значение данного параметра, тем длиннее пробелы или вырезания. Используйте маленькие значения для слабых эффектов, а большие значение для действительного изменения исходной формы ваших аудиоданных.

6. Если вы обнаружите, что применение этих эффектов вызывает проблемы со звуком, настройте параметр Fade edges of each event (1 to 50%), чтобы сгладить края каждого пробела или вырезания. Это поможет вам избавиться от всех возможных проблем.

7. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

8. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Capper/Snipper к вашим аудио-данным в соответствии с установленными параметрами.

Функция Noise Gate

Мы уже говорили о цифровых шлюзах сигнала по отношению к другим функциям, например сжатию и ограничению. Вы также можете использовать цифровые шлюзы сигнала независимо для удаления частей вашей аудиозаписи. Например, если вы хотите, чтобы тихие части (например, промежутки между фразами) в записи вокала были действительно бесшумными, вы можете использовать для этих целей цифровой шлюз сигнала. Функция Noise Gate предоставляет такой тип эффекта, и вот как это делается:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Noise Gate для того, чтобы открыть диалоговое окно Noise Gate (рис. 9.15).

Рис. 9.15. Используйте функцию Noise Gate, чтобы сделать тихие части записи действительно бесшумными

3. Установите значение параметра Threshold level (-Inf. to 0 dB). Параметр Threshold level (-Inf. to 0dB) определяет, при какой амплитуде звуку можно будет пройти через цифровой шлюз сигнала без изменений. Все, что ниже значения параметра Threshold level (-Inf. to 0 dB), не будет пропущено через шлюз и, таким образом, превращено в тишину.

4. Установите значение параметра Attack time (1 to 500 ms). Этот параметр определяет, насколько быстро цифровой шлюз сигнала откроется и позволит звуку пройти после того, как входной уровень достигнет порогового значения. Низкое значение параметра будет сохранять все быстрые, ударные звуки неизменными. Высокое значение заставит шлюз открываться медленнее, тем самым пропуская меньше аудиоданных.

5. Установите значение параметра Release time (1 to 5,000 ms). Этот параметр определяет, насколько быстро после того, как входной уровень опустился ниже порогового значения, закрывается цифровой шлюз сигнала. Низкое значение заставляет шлюз закрываться быстрее. Опять-таки, это лучше для ударных звуков. Высокое значение заставляет шлюз закрываться медленнее. Это хорошо для звуков, имеющих длительное затухание, например для длительной ноты на фортепиано и звуков с сильной реверберацией.

6. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

7. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Noise Gate к вашим аудиоданным в соответствии с установленными параметрами.


Реверберация

Подобно некоторым из упомянутых выше функций, реверберация также является формой затухания, но особой, поскольку вместо отчетливого эха реверберация добавляет сложную последовательность очень коротких эффектов эха, имитирующих искусственную среду. Другими словами, реверберация создает плотный набор эффектов эха, настолько близко прилегающих друг к другу, что они производят такое впечатление, что исходный звук воспроизводится в другой среде, например в большом концертном зале. Используя эффекты реверберации программы Sound Forge, вы можете заставить вашу музыку звучать так, как будто ее играют в самых разных местах, например на арене, в клубе или даже "живьем" на сцене. Программа Sound Forge содержит два эффекта реверберации — Reverb и Acoustic Mirror.

Функция Reverb

Для базовых эффектов реверберации программа Sound Forge предоставляет функцию Reverb. Чтобы применить функцию Reverb к вашим аудиоданным, выполните следующие шаги:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Reverb для того, чтобы открыть диалоговое окно Reverb (рис. 9.16).

Рис. 9.16. Используйте функцию Reverb для применения к вашим аудиоданным базовых эффектов реверберации

3. Выберите один из пунктов раскрывающегося списка Reverberation mode. Этот параметр определяет тип среды, которую вы пытаетесь имитировать. Названия вариантов говорят сами за себя. Например, чтобы имитировать маленькое помещение, выберите вариант Bright small room, чтобы имитировать большое помещение, выберите вариант Cavernous space и т. п.

4. Установите значения параметров Dry out (-Inf. to 0 dB) и Reverb out (-Inf. to 0 dB). Мы уже объясняли в этой главе назначение данных параметров. Они подобны параметрам Dry out (-Inf. to 0 dB) и Wet out (-Inf. to 0 dB), используемым в других функциях. Однако нужно заметить, что в случае реверберации параметры Dry out (-Inf. to 0 dB) и Reverb out (-Inf. to 0 dB) также влияют на то, как эффект звучит. Если вы установите значение параметра Dry out (-Inf. to 0 dB) высоким, а параметра Reverb out (-Inf. to 0 dB) — низким, то ваши аудиоданные будут звучать так, как будто они исходят из точки, находящейся ближе к передней части воображаемого окружения. Если вы установите значение параметра Dry out (-Inf. to 0 dB) низким, а параметра Reverb out (-Inf. to 0 dB) — высоким, то ваши аудиоданные будут звучать так, как будто они исходят из точки, находящейся дальше. Например, если вы хотите эмулировать звучание, слышимое в самых задних рядах концертного зала, можете установить значение параметра Dry out (-Inf. to 0 dB) низким, а параметра Reverb out (-Inf. to 0 dB) — высоким. Для достижения желаемого результата вам придется поэкспериментировать.

5. Выберите значение для параметра Early reflection style. Когда вы делаете запись в замкнутом помещении, всегда происходят эффекты быстрого эха в результате отражения от поверхностей (например, стен), перед которыми вы находитесь. Такие эффекты эха именуются ранними отражениями (early reflections). Для того чтобы ваша имитация реверберации звучала более реально, программа Sound Forge предоставляет этот параметр, с помощью которого вы можете управлять содержимым раннего отражения в вашем эффекте реверберации. Выбор параметра зависит от окружения, которое вы пытаетесь эмулировать. Для маленьких помещений выберите режим с меньшим временем (измеряемым в миллисекундах), например Mode 2 (8 ms). Для более объемных помещений выберите режим с большим временем, например Mode 6 (36 ms). Для достижения лучших результатов вам придется поэкспериментировать.

6. Установите значение параметра Early out (-Inf. to 0 dB). Этот параметр определяет, насколько громкими будут ранние отражения в эффекте реверберации. Чем меньше помещение, тем меньше ранних отражений слышно, и наоборот.

7. Установите значение параметра Decay time (0.5 to 5.0 sees.). Когда вы применяете к вашим данным реверберацию, вы должны представить тип среды, который хотите создать. Это поможет вам установить параметры. Технически параметр Decay time (0.5 to 5.0 sees.) определяет, насколько долго будет продолжаться затухание реверберации, но вы можете рассматривать его как средство управления тем, насколько большой будет искусственная среда. Чем меньше значение параметра Decay time (0.5 to 5.0 sees.), тем меньше среда, и наоборот. Таким образом, если вы хотите, чтобы ваша запись звучала так, как будто она сделана в маленькой комнате, для параметра Decay time (0.5 to 5.0 sees.) хорошим значением может быть 0,5 секунды. Если вы хотите, чтобы ваша запись звучала так, как будто она сделана в большом пространстве, параметр Decay time (0.5 to 5.0 sees.) может иметь значение около 3 секунд.

8. Установите значение параметра Pre-delay (Off to 200 ms). этот параметр сходен с параметром Decay time (0.5 to 5.0 sees.), за исключением того, что параметр Рте-delay (Off to 200 ms) определяет время между тем, когда ваш звук впервые становится слышен, и моментом, когда начинается эффект реверберации. Это дает вам даже больше контроля в определении вашей искусственной среды. Для маленьких пространств используйте низкие значения (например, 1 миллисекунду), а для больших — высокие (например, 70 миллисекунд).

9. Установите значения параметров Attenuate bass freqs below и Attenuate high freqs above. Если вы думаете, что эти параметры похожи на настройки эквализации, вы правы. Использование данных параметров также помогает более реально эмулировать окружения, поскольку маленькие закрытые помещения имеют тенденцию подавлять некоторые частоты звукового диапазона, а в более крупных помещениях звук обычно ярче, т. е. они поддерживают больший диапазон частот. Параметры Attenuate bass и Attenuate high работают так же, как и функции эквализации High-pass и Low-pass , которые мы уже описывали. Если вы установите флажок параметра Attenuate bass и частоту этого параметра (в Гц), любым более высоким частотам будет разрешено проходить и они будут включены в эффект, а любые частоты ниже этого значения будут обрезаны. Если вы установите флажок параметра Attenuate high и его частоту, любым более низким частотам будет разрешено проходить, а любые частоты выше этого значения будут обрезаны. Примеры того, как можно устанавливать эти параметры, вы можете найти в поставляемых с программой наборах настроек.

10. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

11. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Reverb к вашим аудиоданным в соответствии с установленными параметрами.

Функция Acoustic Mirror

Функция Acoustic Mirror также позволяет эмулировать среду, но она значительно сложнее, чем функция Reverb. Имитации функции Acoustic Mirror основаны на реальных средах. Вот как работает эта функция:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Effects -> Acoustic Mirror для того, чтобы открыть диалоговое окно Acoustic Mirror (рис. 9.17).

3. Выберите значение параметра Impulse. Имитации среды функции Acoustic Mirror основаны на реальных средах и используют файлы, которые компания Sonic Foundry называет импульсными файлами (Impulse files). Импульсный файл похож на реальную запись акустического пространства или акустическую подпись. Он моделирует характеристики реальной среды, например концертного зала или даже кухни в чьем-то доме. Программа Sound Forge поставляется с большим набором импульсных файлов, которые вы можете использовать для имитации такого звучания ваших записей, как будто они были записаны в реальной среде. Если в раскрывающемся списке Impulse отсутствуют имена файлов, нажмите на кнопку Browse, чтобы открыть диалоговое окно Open Impulse File и выбрать таким образом файл. Импульсные файлы имеют расширение sfi.

Рис. 9.17. Используйте функцию Acoustic Mirror, чтобы применить к вашим аудиоданным эффект имитации сложной среды

Совет

В дополнение к созданию среды импульсные файлы можно использовать для моделирования характеристик различного звукового оборудования, в том числе микрофонов. Это значит, что с помощью функции Acoustic Mirror вы можете создать впечатление, что запись была сделана с помощью определенного типа микрофона, даже если такого микрофона у вас нет. Программа Sound Forge поставляется с несколькими импульсными файлами для имитации микрофонов, которые вы можете использовать. Эффект отличный!

Кроме того, функция Acoustic Mirror позволяет использовать любой обычный файл WAV длиной менее 12 секунд как основу для его обработки. С помощью данной функции вы можете получить действительно причудливые эффекты таким способом. Просто выберите импульсный файл вместо файла WAV в качестве значения параметра Impulse. Звуковые эффекты работают действительно хорошо. Например, попробуйте использовать короткий звук автомобильного сигнала и обработать ваши аудиоданные с его помощью. Ваши аудиоданные получат характеристики автомобильного сигнала. Забавно, не правда ли? Вы можете также использовать функции синтезатора программы Sound Forge для создания файлов WAV с помощью функции Acoustic Mirror. О функциях синтезатора мы поговорим в главе 10.

4. Установите значения параметров Dry out и Wet out. Эти параметры работают так же, как и параметры Dry out и Reverb out функции Reverb.

5. Установите значение параметра Response width (0 to 100). Данный параметр позволяет управлять шириной стереополя. Это похоже на функцию Pan/Expand, о которой мы говорили в главе 8. Если ему присвоено значение 50, вы получите обычный стереоэффект. Чем ближе значение параметра Response width (0 to 100) к нулю, тем уже стереополе. Это означает, что запись будет звучать так, как будто звук сжат между стереофоническими колонками. Если вы установите параметру Response width (0 to 100) значение 0, вы фактически преобразуете стереофонический сигнал в монофонический. Чем ближе значение параметра Response width (0 to 100) к 100, тем шире стереополе. Это означает, что запись будет звучать так, как будто звук растянут за стереофонические колонки.

6. Установите значение параметра Response delay (-500 to 500 ms). Этот параметр подобен параметру Pre-delay функции Reverb. Положительное значение (в миллисекундах) заставит обрабатываемую запись звучать позже, чем исходный звук. Вы можете применять это для имитации большего пространства. Для некоторых странных эффектов вы можете использовать отрицательное значение, что заставит обрабатываемую запись фактически звучать раньше, чем исходный звук. Это слегка похоже на то как, если бы реверберация была слышна раньше звука, вызвавшего реверберацию.

7. Установите значение параметра Pan (left to right, -100 to 100). Этот параметр работает подобно всем остальным параметрам панорамирования, которые мы уже упоминали. Он позволяет вам панорамировать обрабатываемую запись к любой позиции в стереополе.

8. Мы уже объясняли, как функция Reverb позволяет использовать параметр Decay time, который управляет тем, насколько долго будет продолжаться затухание реверберации (или позволяет вам управлять тем, насколько большим будет ваше искусственное окружение). Параметр Apply envelope and limit decay to (seconds) функции Acoustic Mirror подобен параметру Decay time. Параметр Apply envelope and limit decay to (seconds) позволяет вам управлять длиной выбранного вами импульсного файла, который, в свою очередь, управляет длиной обработки, связанной с окружением. Это означает, что вы можете использовать его для управления размерами помещения, которое вы эмулируете. Например, если вы выберете импульсный файл, имитирующий область кухни в доме с помощью параметра Apply envelope and limit decay to (seconds), вы можете управлять размером кухни. Просто установите флажок и введите количество секунд (которое ограничено длиной используемого вами импульсного файла). Для имитации малого пространства введите маленькое значение. Для имитации большого пространства введите большое значение. Однако параметр Apply envelope and limit decay to (seconds) предоставляет, если вам потребуется, даже еще больше контроля. Щелкните на ярлычке вкладки Envelope в нижней части диалогового окна Acoustic Mirror . Вы увидите график, представляющий амплитуду (левая сторона) импульсного файла в зависимости от времени (снизу). Этот график работает точно так же, как и график функции Envelope, о котором мы говорили выше. Единственное отличие заключается в том, что данный график управляет амплитудой импульсного файла, примененного к вашей записи, а не к амплитуде всего выделения аудиоданных.

9. Вернитесь на вкладку General, установите значения параметров Low-shelf start freq (Hz) и High-shelf start freq (Hz). Эти параметры работают так же, как и параметры Attenuate bass freqs below и Attenuate high freqs above функции Reverb.

10. Если вы работаете не со стереофоническими данными, а с монофоническими, вы по-прежнему можете имитировать стереофоническую среду с помощью функции Acoustic Mirror. Просто установите флажок Convert mono to stereo, и ваша запись будет преобразована в стереофоническую, когда вы примените к ней функцию Acoustic Mirror.

11. Установите параметр Quality/speed (I low/fast to 5 high/show), чтобы указать качество обработки функцией Acoustic Mirror, которое вы хотите использовать. Чем выше качество, тем медленнее обработка. Но если ваш файл не имеет огромных размеров, вы можете обычно использовать наилучшее значение, равное 5 (или high/slow).

12. Щелкните по кнопке Preview, чтобы услышать звучание файла до внесения в него реальных изменений.

13. Нажмите на кнопку ОК.

Программа Sound Forge применит функцию Acoustic Mirror к вашим аудио-данным в соответствии с установленными параметрами.

Замечание

Работая с функцией Acoustic Mirror, вы можете обратить внимание на две дополнительных вкладки в нижней части диалогового окна — Summary и Recover. Вкладка Summary содержит информацию об импульсном файле, который вы используете, такую, как атрибут файла, автор, авторские права и прочие комментарии, которые автор мог включить в файл. Иногда вы можете даже увидеть картинку среды, использованной для создания импульсного файла, если автор включил ее. Вкладка Recover используется для создания собственных импульсных файлов. К сожалению, это весьма сложная тема, выходящая за рамки данной книги. Если вам это интересно, вы можете обратиться к файлам справки программы Sound Forge за информацией о создании импульсных файлов. Однако следует вас предупредить, что процедура эта очень длинная и непростая.


Функция Wave Hammer

Функция Wave Hammer представляет собой конгломерат эффектов. Она содержит эквализацию, цифровой шлюз сигнала, эффекты сжатия и ограничения, объединенные вместе. Функция Wave Hammer в первую очередь используется как инструмент мастеринга. После того как вы отредактировали и обработали ваши аудиоданные, вы обычно выполняете процесс мастеринга ваших аудиоданных перед тем, как записать их на компакт-диск. Функция Wave Hammer позволяет применять в одной операции много различных типов обработки для того, чтобы привести файлы к окончательному состоянию.

Когда вы впервые откроете диалоговое окно Wave Hammer (выполнив команду меню Effects -> Wave Hammer), вы увидите вкладку Main, предоставляющую доступ к общим параметрам всех остальных разделов этого диалогового окна (рис. 9.18).

Чтобы включить обработку в конкретной секции, установите флажок Enable. Щелкнув по соответствующей вкладке внизу диалогового окна, вы получите доступ к более подробным параметрам каждого раздела диалогового окна.

Нам на самом деле не нужно подробно описывать эту функцию, поскольку обо всех ее составных частях вы уже слышали. Все функции, входящие в Wave Hammer, работают так же, как и функции, описанные выше в этой главе и в главе 8. Эквализация в функции Wave Hammer похожа на функцию Paragraphic EQ, также описанную в главе 8. Шлюз в функции Wave Hammer похож на функцию Noise Gate, описанную выше в этой главе. Compress и Limit в функции Wave Hammer также похожи на функцию Graphic Dynamics, описанную выше в этой главе. А функция Dither в Wave Hammer ничем не отличается от функции Dither, описанной в главе 8.

Совет

Вы можете попробовать создать свой собственный тип функции Wave Hammer путем объединения вместе некоторых различных функций обработки программы Sound Forge с помощью надстройки Audio Plug-In Chainer (описанной ниже в этой главе).

Рис. 9.18. Функция Wave Hammer позволяет применить эквализацию, цифровой шлюз сигнала, эффекты сжатия и ограничения вместе

Надстройки и DirectX

В дополнение ко всем эффектам, которые мы уже описали, программа Sound Forge позволяет вам получить доступ к эффектам, созданным сторонними компаниями и разработчиками, в форме надстроек (plug-ins) DirectX.

Замечание

Надстройка представляет собой маленькую компьютерную программу, которая сама по себе ничего не делает, но если ее использовать в приложении-контейнере, она добавит к контейнеру новую функциональность. Вы можете использовать надстройки для удобного добавления функциональности к программе. В случае программы Sound Forge, надстройки дают вам дополнительные способы обработки аудиоданных. Фактически, компания Sonic Foundry предлагает продукты-надстройки на коммерческой основе (XFX1, XFX 2, XFX 3, Acoustic Mirror и Noise Reduction), хотя все они, кроме Noise Reduction, уже включены в состав Sound Forge 5.

Компания Sonic Foundry не является единственным поставщиком надстроек для программы Sound Forge. Вы можете использовать надстройки от многих сторонних разработчиков, поскольку многие надстройки программируются с помощью стандартного компьютерного кода. Программа Sound Forge позволяет вам использовать любые настройки, совместимые со стандартом DirectX. DirectX представляет собой специальный компьютерный код, встроенный в операционную систему Windows, который управляет всеми функциями мультимедиа операционной системы, в том числе воспроизведением звука и видео. Поэтому, если вы ищете новые надстройки, чтобы добавить их в программу Sound Forge, убедитесь, что они совместимы со стандартом DirectX (это должно быть указано на упаковке), и вы можете быть уверены, что они будут работать.

Совет

Хорошим источником надстроек DirectX, которые вы можете использовать бесплатно, является сервер http://www.directxfiles.com/ .

Меню DirectX

Все надстройки DirectX доступны в программе Sound Forge через меню DirectX (рис. 9.19).

Рис. 9.19, Используйте меню DirectX для доступа к любым установленным надстройкам DirectX

Просто выделите какие-либо аудиоданные, выберите название надстройки в меню DirectX, и вы получите доступ к надстройке DirectX, установленной на вашем компьютере. Чтобы узнать, как использовать конкретную надстройку, вам необходимо будет прочитать документацию, поставляемую с надстройкой.

Audio Plug-In Chainer

Программа Sound Forge содержит одну надстройку DirectX, которая сама по себе не осуществляет никакой обработки данных, но которая позволяет вам создавать объединенные наборы настроек. Как мы упоминали в главе 8, программа Sound Forge позволяет вам сохранять настройки для большинства функций в виде набора настроек. Таким образом, вы легко можете использовать созданные вами параметры редактирования, просто вызвав их по имени, вместо того, чтобы указывать настройки каждый раз, когда вы используете функцию. Наборы настроек позволяют сэкономить немало времени, но, к сожалению, вы можете сохранять эти наборы только для каждой отдельной функции. Что делать, если вы хотите объединить несколько функций для создания целого процесса редактирования? Например, предположим, что вы хотите добавить немного эквализации перед тем, как обрабатывать данные с помощью реверберации? Для этого вам потребуется выделить аудиоданные, использовать одну из функций эквализации, а затем применить для обработки данных функцию Reverb. Для каждой функции вам придется произвести соответствующую настройку параметров. Если вы объедините функции в цепочку, все, что вам потребуется сделать, — это выделить необходимые данные и запустить цепочку функций. Вот здесь и потребуется Audio Plug-In Chainer. Надстройка Audio Plug-In Chainer позволяет вам объединить в цепочку некоторые функции программы Sound Forge так, что вы сможете обрабатывать ваши аудиоданные с помощью нескольких функций (с заранее установленными параметрами) в один прием. Вот как работает надстройка Audio Plug-In Chainer:

1. Выделите в вашем аудиофайле данные, которые вы хотите обработать. Если вы хотите обработать весь файл, не выделяйте никаких данных или выделите все с помощью команды меню Edit -> Select All.

2. Выполните команду меню Tools -> Audio Plug-In Chainer для того, чтобы открыть диалоговое окно Plug-In Chainer (рис. 9.20).

3. Нажмите на кнопку Add Plug-In (с изображенным на ней знаком "плюс") для того, чтобы открыть диалоговое окно Add Plug-Ins (рис. 9.21).

4. Выберите из списка надстройку и щелкните на кнопке Add . Выбранная надстройка (или функция) будет добавлена к списку Plug-Ins в диалоговом окне Plug-In Chainer .

Рис. 9.20. Используйте надстройку Audio Plug-In Chainer для объединения в цепочку отдельных функций обработки программы Sound Forge

Рис. 9.21. Добавьте надстройку к цепочке в диалоговом окне Plug-Ins Explorer

5. Выделите надстройку в списке и нажмите на кнопку Properties. Откроется диалоговое окно, соответствующее надстройке или функции, в котором вы сможете настроить параметры функции или надстройки. Закончив настройку, щелкните на кнопке Close.

6. Повторяйте шаги с 3 по 5 до тех пор, пока все нужные надстройки не будут внесены в список Plug-Ins.

7. Чтобы удалить надстройку из списка Plug-Ins, выделите надстройку и щелкните на кнопке Delete Plug-In (на которой изображен красный крестик). Если же вы хотите удалить из списка все надстройки, нажмите на кнопку Clear All.

8. Чтобы переместить надстройку вверх или вниз, щелкните по кнопке Move Up (со стрелкой вверх) или Move Down (со стрелкой вниз). Это позволяет изменять порядок обработки данных.

9. Нажмите на кнопку Preview, чтобы услышать звучание файла до внесения в него реальных изменений. В процессе предварительного прослушивания вы сможете пропускать функцию или прослушивать ее в режиме "соло", если установите в столбцах списка флажки Bypass или Solo.

10. Не забудьте сохранить новую цепочку надстроек как набор настроек. Таким образом, в следующий раз, когда вы захотите обработать ваши аудиоданные с помощью конкретных надстроек, все, что вам придется сделать — это выбрать набор настроек вместо того, чтобы создавать цепочку "с нуля".

11. Нажмите на кнопку ОК.

Программа Sound Forge применит все настройки, перечисленные в надстройке Audio Plug-In Chainer, к вашим аудиоданным в соответствии с установленными параметрами.


Приложение 1. Использование Sound Forge совместно с программой ACID
  • Использование Sound Forge совместно с программой ACID
  • ACID Looping Tools
    • Уменьшение выделения вдвое
    • Увеличение выделения вдвое
    • Сдвиг выделения влево или вправо
    • Действие инструмента Rotate Audio
  • Редактирование свойств петли ACID
    • Переключатель One-Shot
    • Переключатель Loop
    • Параметр Number of beats
    • Раскрывающийся список Root note for transposing
    • Переключатель Disk-Based
  • Подготовка ACID-файла — пошаговый пример


Использование Sound Forge совместно с программой ACID

В главе 13 мы объяснили, как можно создавать и редактировать ваши собственные сэмплерные петли, а также как переносить их на внешние аппаратные сэмплерные устройства. Мы также упоминали, как можно использовать сэмплерные петли внутри программных приложений для сочинения музыки. Одним из таких программных приложений является ACID компании Sonic Foundry. Программа ACID представляет собой инструмент для сочинения на основе сэмплерных петель, который позволяет вам встраивать отдельные сэмплерные петли в законченные композиции. Особенность программы ACID в том, что она берет на себя рутинную работу приведения в соответствие темпа воспроизведения и высоты тона каждой петли, которую вы используете в вашей композиции.

Хотя программа ACID отлично подходит для работы с любыми сэмплерными петлями в формате файлов WAV (описание файлов WAV приведено в главе 4), она дает наилучшие результаты в том случае, если вы заранее сделаете петли с помощью специального процесса подготовки петель для ACID. Такая подготовка сэмплерной петли включает в себя добавление к аудиофайлу дополнительной информации, которая позволяет программе ACID узнать основной темп, высоту тона и свойства воспроизведения файла. После этого программа ACID может точнее сдвигать темп и высоту петли.

Если у вас уже есть программа ACID, вы легко можете готовить для нее файлы из нее же самой. Однако на всякий случай программа Sound Forge содержит несколько специальных инструментов, чтобы вы могли подготовить ваши файлы для использования в программе ACID, даже если этой программы у вас нет. Кроме того, может оказаться удобнее готовить файлы для программы ACID из программы Sound Forge, если вы создаете большое количество оригинальных петель.

ACID Looping Tools

Первый набор специальных инструментов, которые содержит программа Sound Forge, называется ACID Looping Tools (Инструменты для работы с петлями ACID). Эти инструменты на самом деле не выполняют никакой работы по подготовке ваших файлов для работы в программе ACID. Такие инструменты можно использовать для создания сэмплерных петель любого типа, а не только петель для программы ACID. Данные инструменты особенно полезны при работе с петлями, содержащими большое количество мелких ритмических элементов.

Уменьшение выделения вдвое

Инструмент Halve Selection позволяет вам уменьшить текущее выделение данных вдвое. Это означает, что если у вас есть две секунды выделенных аудиоданных (рис. П1.1), то с помощью инструмента Halve Selection вы легко можете уменьшить размер выделения до одной секунды аудиоданных (рис. П1.2).

Рис. П1.1. Две секунды выделенных аудиоданных перед использованием инструмента Halve Selection

Эта процедура ничего не делает с самими аудиоданными; она просто изменяет объем выделенных в настоящий момент данных. Такой инструмент может быть очень полезен, например, если у вас выделен двухтактовый басовый риф, но вы хотите быстро и легко применить эффект только к одному такту данных. Для того чтобы использовать инструмент Halve Selection, просто выполните команду меню Special -> ACID Looping Tools -> Halve Selection. Если никакие данные не выделены, активизация инструмента ни к чему не приведет.

Рис. П1.2. Одна секунда выделенных аудиоданных после использования инструмента Halve Selection над данными из предыдущего примера

Увеличение выделения вдвое

Инструмент Double Selection является полной противоположностью инструменту Halve Selection. Вместо уменьшения текущего выделения вдвое он увеличивает выделение вдвое. Это означает, что если у вас выделено две секунды аудиоданных (рис. П1.3), с помощью инструмента Double Selection вы сможете увеличить выделение до четырех секунд аудиоданных (рис. П1.4).

Рис. П1.3. Две секунды выделенных аудиоданных перед использованием инструмента Double Selection

Рис. П1.4. Четыре секунды выделенных аудиоданных после использования инструмента Double Selection над данными из предыдущего примера

И в этом случае такая процедура ничего не делает с самими аудиоданными; она просто изменяет объем выделенных в настоящий момент данных. Этот инструмент может быть очень полезен, например, если у вас выделен один размер рифа ударных инструментов, но вы хотите быстро и легко выделить и вырезать из петли два размера. Чтобы использовать инструмент Double Selection, просто выполните команду меню Special -> ACID Looping Tools -> Double Selection. Если никакие данные не выделены, активизация инструмента ни к чему не приведет.

Сдвиг выделения влево или вправо

Вместо уменьшения или увеличения объема выделенных данных инструменты Shift Selection Left и Shift Selection Right перемещают выделение внутри файла влево или вправо на величину выделенных данных. Другими словами, если у вас есть петля длиной три такта, а вы выделили второй такт петли (рис. П1.5), выбор инструмента Shift Selection Left снимает выделение со второго такта и выделяет первый (рис. П1.6), поскольку выделение перемещается на один такт влево. Если вы выберете инструмент Shift Selection Right, то выделение со второго такта также будет снято, но на сей раз будет выделен третий такт, поскольку выделение перемещается на один такт вправо (рис. П1.7). Чтобы использовать инструменты Shift Selection Left или Shift Selection Right, выполните команды меню Special -> ACID Looping Tools -> Shift Selection Left или Special -> ACID Looping Tools -» Shift Selection Right соответственно.

Рис. П1.5. Трехтактовая сэмплерная петля с выделенным вторым тактом

Рис. П1.6. Та же самая трехтактовая сэмплерная петля с выделенным первым тактом после применения инструмента Shift Selection Left

Рис. П1.7. Та же самая трехтактовая сэмплерная петля с выделенным третьим тактом после применения инструмента Shift Selection Right

Действие инструмента Rotate Audio

Последним в наборе ACID Looping Tools является инструмент, именуемый Rotate Audio. В отличие от вышеупомянутых инструментов, этот инструмент действительно изменяет аудиоданные в файле. Инструмент Rotate Audio Tool "поворачивает" аудиоданные от одного конца вашего файла до другого в зависимости от текущего выделения данных. Например, предположим, что у вас выделен небольшой фрагмент в начале вашего аудиофайла (рис. П1.8).

Рис. П1.8. Небольшой фрагмент в начале аудиофайла

Если вы выполните команду меню Special -> ACID Looping Tools -> Rotate Audio, выделенные в настоящий момент данные будут вырезаны, а затем вставлены в конец файла (рис. П1.9).

Рис. П1.9. То же самое небольшое выделение данных после применения инструмента Rotate Audio перемещено в конец аудиофайла

Теперь, если у вас первоначально был выбран фрагмент данных в конце файла, инструмент Rotate Audio вырежет данные из конца файла и вставит их в начало файла. Видите, как это работает? Такой инструмент очень полезен, если вы хотите быстро и легко переместить первый или последний фрагмент петли в противоположный конец, или наоборот.

Замечание

При использовании инструмента Rotate Audio есть два исключения. Одно заключается в том, что если у вас не выделены никакие данные, будет вырезана первая четверть файла от начала и вставлена в конец. Другим исключением является то, что если у вас выделен фрагмент данных в середине файла, инструмент Rotate Audio просто ничего не сделает.


Редактирование свойств петли ACID

Как мы уже упоминали, для того, чтобы подготовить вашу сэмплерную петлю для использования в программе ACID, вам необходимо выполнить специальные действия, заключающиеся в добавлении к аудиофайлу дополнительной информации. Для этого вы должны использовать диалоговое окно Edit ACID Properties (рис. П1.10), получить доступ к которому можно с помощью команды меню Special -> Edit ACID Properties.

Рис. П1.10. Диалоговое окно Edit ACID Properties позволяет вам подготовить сэмплерные петли к использованию в программе ACID

В этом диалоговом окне имеется несколько переключателей. После выбора соответствующих настроек программа ACID сможет определить правильный способ обработки вашей сэмплерной петли после ее загрузки в проект ACID.

Переключатель One-Shot

Первый переключатель в диалоговом окне Edit ACID Properties называется One-Shot. Если предполагается, что ваша сэмплерная петля будет воспроизводиться только один раз, а не повторяться многократно, вам тогда необходимо выбрать этот переключатель. Сэмпл, созданный с использованием переключателя One-Shot, не растягивается во времени вместе с изменениями темпа проекта ACID, а высота тона сэмпла не изменяется в результате изменений тональности проекта ACID. Хорошим примером сэмпла, созданного с помощью переключателя One-Shot, является звук удара тарелок.

Переключатель Loop

Второй переключатель в диалоговом окне Edit ACID Properties называется Loop. Его нужно использовать в том случае, если ваша сэмплерная петля должна воспроизводиться многократно, пример — повторение рифа бас-гитары. Сэмплерные петли, созданные с использованием переключателя Loop, в программе ACID будут растягиваться во времени, а их высота тона будет меняться в зависимости от изменений темпа и тональности проекта ACID. Для того чтобы программа ACID могла правильно изменить петлю, она должна знать первоначальный темп и высоту тона петли.

Параметр Number of beats

Чтобы указать темп вашей петли, вы просто должны ввести количество музыкальных тактов, которые содержит петля, в поле Number of beats (1 to 10,000). Вы можете вычислить, сколько тактов имеется в вашей петле, сосчитав их во время воспроизведения. Пример мы приведем ниже, в этом же приложении. Нужно заметить, что если вы введете неправильное количество тактов, программа ACID не сумеет воспроизвести вашу петлю с нужной скоростью. Например, если ваша петля содержит 16 тактов, а вы введете в поле Number of beats (1 to 10,000) число 8, программа ACID воспроизведет вашу петлю вдвое быстрее, чем надо.

Раскрывающийся список Root note for transposing

Чтобы указать высоту тона вашей петли, вы просто выбираете значение ноты из раскрывающегося списка Root note for transposing. Эта базовая нота представляет собой исходную высоту тона, на которой была записана ваша сэмплерная петля. Необходимо знать это заранее, иначе вам потребуется вычислить ее вручную с помощью камертона.

Совет

Используя функцию Spectrum Analysis (описанную в главе 10), вы иногда можете найти базовую ноту сэмплерной петли. Просто выделите все данные в вашей петле и выполните команду меню Tools -> Spectrum Analysis, чтобы проанализировать данные. В нижней части диалогового окна Spectrum Analysis программа Sound Forge показывает наиболее заметную частоту (высоту тона) ваших данных. В большинстве случаев это будет базовая нота.

Еще одна вещь, которую необходимо иметь в виду, это то, что если вы хотите, чтобы ваша сэмплерная петля растягивалась во времени, но не была транспонирована (как, вероятно, в большинстве петель на базе ударных), выберите в раскрывающемся списке Root note for transposing вариант Don't transpose.

Переключатель Disk-Based

Большинство сэмплерных петель, используемых в проекте ACID, воспроизводятся из памяти вашего компьютера, но если у вас очень длинные сэмплы (например, целая вокальная дорожка), вашему компьютеру может не хватить памяти для воспроизведения этих сэмплов. В таком случае вы имеете возможность указать, чтобы программа ACID воспроизводила ваш сэмпл, считывая его непосредственно с жесткого диска. Чтобы сделать так, вы просто должны выбрать в диалоговом окне Edit ACID Properties переключатель Disk-Based. Высота сэмплов, созданных с использованием переключателя Disk-Based, не может быть транспонирована, но если вы укажете темп, вы сможете сделать так, что программа ACID будет растягивать сэмплы во времени. Для этого просто введите темп (количество тактов в минуту) сэмпла в поле Tempo (60 to 240 bpm). Вам потребуется знать темп, с которым сэмпл был первоначально записан.

Подготовка ACID-файла — пошаговый пример

Теперь, когда вы знаете обо всех специальных инструментах ACID, имеющихся в программе Sound Forge, давайте посмотрим пошаговый пример того, как на практике использовать эти инструменты для подготовки файла.

1. Выполните команду File -> Open, чтобы открыть диалоговое окно Open. Выберите ваш файл. Для этого примера давайте используем один из файлов, включенных в поставку программы Sound Forge. Выберите файл под названием TUTFILL.WAV. Щелкните на кнопке Open.

2. Нажмите клавишу <Пробел>, чтобы воспроизвести файл. Это сэмплер-ная петля с барабанным боем. Поскольку этот файл — не сэмпл с единственным инструментом, который может воспроизводиться только один раз, мы можем сказать, что это не сэмпл типа One-Shot. А поскольку он достаточно мал, чтобы его можно было воспроизводить из памяти компьютера, его нельзя отнести и к сэмплам типа Disk-Based. Это означает, что для программы ACID мы должны выбрать тип Loop. Прежде чем мы отредактируем свойства ACID для петли, нам необходимо выяснить, сколько тактов содержит файл. Воспроизведите его еще несколько раз и посмотрите, можете ли вы сосчитать такты.

3. Выполните команду меню Special -> Edit ACID Properties, чтобы открыть диалоговое окно Edit ACID Properties .

4. Выберите переключатель Loop.

5. В поле Number of beats (1 to 10,000) введите значение 4. Правильно вы определили?

6. Поскольку это петля на базе ударных, здесь нет высоты тона, а мы не хотим, чтобы программа ACID по ошибке транспонировала петлю. Поэтому в раскрывающемся списке Root note for transposing выберите вариант Don't transpose.

7. Нажмите на кнопку ОК.

8. Сохраните ваш файл.

Внимание

Когда вы сохраняете ваш новый подготовленный для использования в программе ACID файл, используйте либо формат WAV, либо формат AIF. Если вы будете работать с каким-нибудь иным форматом, дополнительная информация для программы ACID, добавленная к файлу, не будет сохранена. Кроме того, программа ACID может открывать только аудиофайлы в форматах WAV или AIF. Далее в раскрывающемся списке Format диалогового окна Save As выберите вариант РСМ. Программа ACID может открывать только несжатые аудиофайлы. Наконец, в раскрывающемся списке Rgns/Playlist выберите вариант Save Regions And Playlist In WAV/AVI Files и установите флажок Save summary information in file.


Предисловие

Это первая книга, полностью посвященная продукту Sound Forge компании Sonic Foundry. Вы можете найти множество книг об использовании компьютеров для создания и записи музыки, в которых имеется некоторая информация о Sound Forge, но ни в одной из них нет полного описания продукта. Конечно, Sound Forge поставляется с отличным описанием в электронной форме на компакт-диске, но, как и большинство руководств, его можно рассматривать только как набор описаний функций.

Вместо того чтобы просто описывать возможности программы и то, как они работают, мы постараемся дать подробное описание программы и покажем, как использовать продукт, на пошаговых примерах и упражнениях, которые помогут вам лучше разобраться в том, как нужно редактировать звук. Мы разъясним все имеющиеся возможности так, чтобы вы могли их понять и сразу использовать. Пользователям программы Sound Forge XP Studio будет интересно узнать, что все функции этой программы имеются и в Sound Forge. Для них эта книга тоже будет полезна.

Так зачем же вам ее читать? А вот зачем. Мы пользовались программой Sound Forge с самой первой ее версии. Нами было написано несколько обзорных статей о Sound Forge и других продуктах компании Sonic Foundry для различных журналов, посвященных электронной музыке. Кроме того, автор работал вместе с сотрудниками компании Sonic Foundry, узнавая у них о Sound Forge все, что возможно. За это им огромное спасибо. Они помогли точно изложить информацию в этой книге с технической точки зрения. А мы, теперь очень хорошо зная этот продукт, просто хотели бы поделиться своими знаниями с вами.

Чтение этой книги предполагает, что программа Sound Forge установлена на вашем компьютере и вы знаете, как ее запустить. Кроме того, вам стоит хотя бы бегло просмотреть руководство, поставляемое с программой, а настройка ваших внешних аудиоустройств и инструментов MIDI должна быть уже выполнена. Естественно, мы полагаем, что вы умеете выполнять такие действия с мышью, как щелчок, двойной щелчок, перетаскивание, щелчок правой кнопкой и т. п. Вы также должны уметь работать с такими базовыми инструментами Windows, как Windows Explorer (Проводник) и Control Panel (Панель управления). Кроме того, вы должны иметь доступ к Интернету или у вас должен быть друг, который сможет предоставить вам хотя бы на время такой доступ. Если эти условия уже выполнены, то все, что вам потребуется, — это активный интерес к изучению того, как выжать максимум из программы Sound Forge.

Структура книги

Хотя мы старались избежать совпадения содержания этой книги с содержанием руководства, поставляемого с программой Sound Forge, это не всегда оказывалось возможным. Хотелось бы быть уверенным в том, что вы поймете все основные функции программы, а для этого потребовалось в начале объяснить некоторые базовые понятия. Однако эта книга значительно чаще отвечает на вопросы "как сделать", чем рассказывает "эта функция делает то-то и то-то".

Главы 1 и 2 представляют собой введение в компьютерную музыку и программное обеспечение. В этих главах объясняется важность регистрации и то, как получить справку, а также главные возможности и менее заметные части программы и их совместная работа. Здесь вы также найдете краткое описание различий между Sound Forge и Sound Forge XP.

Глава 3 показывает, как заставить Sound Forge работать так, как вы хотите. В этой главе объясняются параметры программы и настройка рабочего пространства. Из нее вы узнаете, как найти оптимальные параметры для MIDI и работы со звуком.

В главе 4 рассказывается о том, как работать со звуковыми файлами, т. е. приводятся пошаговые инструкции для открытия, закрытия и сохранения существующих звуковых файлов.

Прочитав главы 5 и 6, вы узнаете, как ориентироваться в программе Sound Forge и как записывать и воспроизводить звуковые файлы. В этих главах приводятся инструкции по записи и воспроизведению файлов и описано, как синхронизировать Sound Forge через SMPTE. Мы расскажем, в чем заключается важность указателя текущей позиции и как использовать меню Transport и функции Go To, Markers и Zoom. После прочтения этой главы вы сможете "управлять" программой Sound Forge как профессионал.

Благодаря информации, изложенной в главах 7 и 8, вы подготовитесь к редактированию. Сначала мы объясним вам основы, в том числе расскажем об окне данных, меню Edit и инструменте Edit. Затем вы сможете исследовать инструменты обработки более подробно.

Глава 9 рассказывает о таких инструментах программы, как эффекты. С помощью этих инструментов вы можете делать поразительные вещи. Мы опишем все функции эффектов и покажем, как их правильно использовать. Мы даже предоставим несколько своих примеров, которые вы сможете потом использовать при редактировании звука.

В главе 10 описываются все "примочки", поставляемые с Sound Forge. В их число входят пакетная обработка файлов, спектральный анализ звука, статистика аудиоданных и даже некий базовый синтез звука. В некоторых ситуациях многие из этих функций оказываются удобными.

Те, кто интересуется созданием файлов для мультимедиа и для Интернета, найдут для себя очень много полезной информации в главе 11, в которой будет показано, как использовать программу Sound Forge для добавления звука к видео и как экспортировать звуковые файлы в различные форматы, предназначенные специально для распространения в Интернете, включая RealAudio, Window Media и МРЗ.

Наконец, главы 12 и 13 приведут вас к более сложным возможностям программы Sound Forge. В их числе запуск аудиофайлов через MIDI, использование Virtual MIDI Router, а также создание ваших собственных циклов.

Надеемся, что после прочтения этой книги вы будете в совершенстве знать, как пользоваться программой Sound Forge, и получите от этого удовольствие.

Используемые в книге соглашения

Когда вы начнете читать, вы заметите, что в книге приведена весьма концентрированная и полезная информация. Незначительных моментов в ней весьма мало. Мы не стали утомлять вас ненужными эпизодами или повторяющимися данными. Но мы использовали несколько соглашений для выделения определенных типов информации.

Совет

Советы представляют собой дополнительную информацию, относящуюся к обсуждаемой теме и, в некоторых случаях, личный опыт или конкретные приемы, не описанные в других местах.

Замечание

Иногда вам полезно будет узнать определенные моменты, касающиеся текущего вопроса. Замечания дают дополнительный материал, помогающий вам избежать проблем, а также содержат соответствующие рекомендации.

Предупреждение

Предупреждения указывают на действия или команды, которые могут привести к необратимым изменениям ваших файлов или вызвать потенциальные проблемы в будущем. Читайте их внимательно, поскольку они могут содержать важную информацию, позволяющую обеспечить безопасность ваших файлов, программного обеспечения и аппаратных средств, и помогут избежать потери результатов работы.