Иллюстрированный самоучитель по CubaseSX

  • Введение
  • Глава 1. Основы, без которых не обойтись
  • Глава 2. Подготовка программы к эффективной работе
  • Глава 3. Транспортная панель
  • Глава 4. Работа в окне проекта
  • Глава 5. Маршрутизация аудиопотоков
  • Глава 6. Подробно о работе с MIDI
  • Глава 7. Browse Project. Управление темпом
  • Глава 8. О работе с нотатором
  • Глава 9. Работа с MIDI-плагинами
  • Глава 10. Применение VSTi
  • Глава 11. Использование приложений, поддерживающих протокол ReWire
  • Глава 12. Подробно об обработке аудиоданных
  • Глава 13. Применение VST-плагинов
  • Глава 14. Сведение композиции
  • Глава 15. VST System Link — организация работы студийных компьютеров в сети
  • Глава 16. Обзор команд главного меню


Глава 1. Основы, без которых не обойтись

    • Основы, без которых не обойтись
    • 1.1. MIDI: аппаратная составляющая. Подключение MIDI-клавиатуры к звуковой карте
    • 1.1.1. Musical Instrument Digital Interface (MIDI)
    • 1.1.2. Структура элементарного МЮ1-сигнала
    • 1.1.3. Соединительные MIDI-разъемы и MIDl-кабель
    • 1.1.4. Принцип соединения MIDI-устройств
    • 1.1.5. MIDI-сигналы в разъеме игрового порта звуковой карты
    • 1.1.6. Подключение к звуковой карте MIDI-клавиатуры и MIDI-синтезатора
    • 1.1.7. Решение проблемы самовозбуждения MIDI-системы
    • 1.2. Формат MIDI-данных. Типы MIDI-сообщений в Cubase SX
    • 1.2.1. Note — сообщение о нажатии MIDI-клавиши
    • 1.2.2. Controller — сообщение о состоянии контроллера
    • 1.2.3. Program Change — сообщение о смене MIDI-инструмента
    • 1.2.4. Aftertouch — сообщение о силе давления на нажатые клавиши
    • 1.2.5. Pitchband — управление регулятором тона
    • 1.2.6. SysEx (System Exclusive) — привилегированные системные сообщения
    • 1.3. MlDI-секвенсор. Дискретная шкала времени
    • 1.4. Оцифровка звука
    • 1.4.1. Аналого-цифровое преобразование
    • 1.4.2. Цифроаналоговое преобразование
    • 1.4.3. О некоторых проблемах, связанных с ЦАП/АЦП
    • 1.5. Методы синтеза звуков. Синтезаторы и сэмплеры
    • 1.5.1. Синтезаторы
    • 1.5.2. Сэмплеры
    • 1.5.3. VST и VSTi
    • 1.6. Структура микшера
    • 1.6.1. Канальный модуль
    • Подключение источников сигнала
    • Фантомное питание
    • Insert — подключение эффектов и обработок последовательного действия
    • 1.6.2. Шины. Подключение эффектов параллельного действия
    • 1.6.3. Мастер-модуль
    • 1.6.4. Автоматизация
    • 1.7. Представление музыкальной информации в Cubase SX
    • 1.7.1. Порты, каналы, MIDI- и аудиотреки, части. Подтреки и огибающие
    • 1.7.2. Список сообщений
    • 1.7.3. Отпечатки клавиш
    • 1.7.4. Ноты
    • 1.8. Эффекты и обработки
    • 1.9. Сущность наиболее важных звуковых эффектов
    • 1.9.1. Вибрато
    • Амплитудное вибрато и тремоло
    • Частотное вибрато
    • Тембровое вибрато
    • 1.9.2. Эффекты, основанные на задержке сигнала
    • Дилэй
    • Флэнжер и фэйзер
    • Хорус
    • Реверберация
    • 1.9.3. Дистошн
    • 1.9.4. Вокодер
    • 1.9.5. Pitch Shifter — изменение высоты тона
    • 1.10. Сущность наиболее важных обработок
    • 1.10.1. Частотная фильтрация
    • 1.10.2. Динамическая обработка
    • 1.11. Измерители и анализаторы
    • 1.11.1. Измеритель уровня аудиосигнала
    • 1.11.2. Анализатор спектра аудиосигнала
    • Классический спектр
    • Текущий спектр
    • Мгновенный спектр
    • Взвешенный спектр
    • Быстрое преобразование Фурье
    • Измерение спектра в Cubase SX
    • Анализ спектра и фильтрация при сведении композиции
    • 1.12. Surround — объемный звук
    • 1.12.1. Немного истории
    • 1.12.2. Формат 5.1
    • 1.12.3. Особенности оборудования студии формата 5.1
    • 1.12.4. Особенности сведения в круговую панораму
    • 1.13. Выполнение основных операций в Cubase SX
    • 1.13.1. Загрузка файла с проектом
    • 1.13.2. Воспроизведение сонга
    • 1.13.3. Открытие и закрытие проекта
    • 1.13.4. Сохранение проекта. Форматы файлов
    • 1.13.5. Запись MIDI-трека
    • Локаторы
    • Музыкальное время в Cubase SX
    • Первая попытка записи с MIDI-клавиатуры
    • 1.13.6. Запись звуковых данных с внешнего источника
    • Создание аудиотрека
    • Выбор портов ввода и вывода
    • Настройка уровня сигнала


Основы, без которых не обойтись

В этой книге мы рассказываем о работе с программой Cubase SX, столь многофункциональной, что ее вряд ли уже можно назвать музыкальным и звуковым редактором. Cubase SX — это виртуальная звуковая студия. В ней есть все, что, в принципе, должно быть в настоящей студии.

  • Секвенсор для записи и редактирования MIDI-композиций.
  • Множество музыкальных инструментов как мелодических, так и ударных, объединенных в синтезаторы.
  • Многоканальный цифровой магнитофон для записи звука.
  • Приборы динамической обработки, частотные фильтры.
  • Приборы обработки эффектами отдельных MIDI- и аудиотреков или всей композиции в целом.
  • Микшер для сведения треков в стереофоническую фонограмму (а также многоканальную Surround-фонограмму).
  • Измерительные приборы и индикаторы.
  • Система коммутации студийного оборудования и управления им.

Единственное, существенное отличие представленного в программе оборудования от того, которое вы можете увидеть в реальной студии, — его виртуальность. Однако с точки зрения пользователя нет большой разницы в том, с чем предстоит иметь дело: со студийным "железом" или с "софтовой" студией. В любом случае перечисленный набор аппаратуры в умелых руках позволяет решить любую задачу, возникающую в процессе создания музыкальной композиции. Вместе с тем, если этим богатством владеет безграмотный человек, то реальная студия превращается просто в сотни килограммов железа, а виртуальная — в сотни мегабайт цифрового кода, бессмысленно и бесполезно занимающего место на жестком диске.
Многофункциональность виртуальной студии, сложность и разнообразие явлений и алгоритмов, положенных в основу ее работы, приводят к тому, что пользователь такой программы должен быть специалистом широкого профиля.
Лучшие современные программы сопровождаются подробной и удобной справочной системой. Казалось бы, пользуясь ею, можно научиться применять программу по назначению. Однако как вы считаете, можно ли, например, доверить свое здоровье человеку только на том основании, что у него на книжной полке стоят несколько томов медицинских справочников? Думаем, ответ очевиден. Для того чтобы считаться и, тем более, на деле быть врачом, музыкантом, звукорежиссером, недостаточно иметь в своем распоряжении соответствующий справочник. Нужны специальные знания (хотя бы для того, чтобы суметь сформулировать вопрос для справочной системы и понять ответ на него). Как минимум, необходимо владеть терминологией и научными основами в той предметной области, в которой вы намерены себя проявить. Именно поэтому книгу, посвященную описанию конкретной программы, мы начинаем с главы, содержащей базовые сведения. Без них вряд ли удастся эффективно использовать возможности, заложенные в программе.
В этой главе мы договоримся о терминологии и познакомим вас с принципами построения и функционирования элементов виртуальной звуковой студии.


1.1. MIDI: аппаратная составляющая. Подключение MIDI-клавиатуры к звуковой карте

Подключение MIDI-клавиатуры к звуковой карте, установленной в компьютер, осуществляется посредством MIDI-интерфейса. Для того чтобы выполнить необходимые соединения, совсем не обязательно вызывать специалиста. Вы в состоянии сделать это сами. А все, что необходимо знать о MIDI-интерфейсе, вы сейчас прочтете.


1.1.1. Musical Instrument Digital Interface (MIDI)

Начнем со слова "интерфейс". Интерфейс (Interface) — система унифицированных связей и сигналов, посредством которых устройства или программы взаимодействуют между собой.
Musical Instrument Digital Interface (MIDI) — цифровой интерфейс музыкальных инструментов. Стандарт на интерфейс создан ведущими производителями музыкальных инструментов: Yamaha, Roland, Korg, E-mu и др.
Различают аппаратный MIDI-интерфейс и формат MIDI-данных. Аппаратный интерфейс используется для физического соединения источника и приемника сообщений, формат данных — для создания, хранения и передачи MIDI-сообщений. Вопросы, связанные с форматом данных, мы рассмотрим в разд. 1.2, а сейчас познакомимся с аппаратной составляющей MIDI-интерфейса.
MIDI-интерфейс — это старт-стопный последовательный асинхронный интерфейс "токовая петля".
Словосочетание "старт-стопный" означает, что в каждом передаваемом сообщении обязательно должны содержаться признаки того, что процесс передачи начат (сигнал "Старт") и завершен (сигнал "Стоп").
В последовательном интерфейсе двоичные данные передаются не одновременно, а поочередно (последовательно).
Асинхронность интерфейса состоит в том, что начало передачи данных в нем не привязано к какому-либо определенному моменту времени. Передача осуществляется тогда, когда в этом возникает необходимость. Нажали на клавишу — в интерфейсе появилось сообщение об этом.
Передающая сторона интерфейса активна, на ней имеется источник тока и коммутирующий элемент (в конечном счете, выключатель), а приемная — пассивна, на ней расположен только прибор-приемник тока. Принцип токовой петли заключается в том, что как только цепь выключателя будет замкнута, ток через нее потечет от положительного полюса источника (на передающей стороне) через "прямой" соединительный проводник кабеля, далее через приемник тока (на приемной стороне) и по "обратному" проводнику кабеля возвратится на приемную сторону ("втечет" в отрицательный полюс источника). Вот вам и токовая петля. Проходя сквозь приемник, ток выполнит предписанную ему роль: приведет в действие чувствительный элемент, в результате чего в приемнике и будет зафиксирован пришедший сигнал.


1.1.2. Структура элементарного MIDI-сигнала

Активный передатчик формирует токовую посылку с силой тока 5 мА. Токовая посылка соответствует логическому нулю, бестоковая — логической единице. Структура элементарного MIDI-сигнала (рис. 1.1) характеризуется следующими признаками: 7 битов данных, один бит (старший) статусный, один бит старта, один бит стопа. Проверка на четность отсутствует.
Вы видите, что столовый бит — единичный, а не нулевой. То есть в состоянии "Стоп" ток в цепи не течет. Это очень разумно. Экономится энергия и ресурсы элементов интерфейса. Ведь основную часть времени в M1DI-системе никаких событий не происходит: в среднем протяженность пауз значительно больше, чем протяженность тех интервалов времени, когда вы
играете на MIDI-клавиатуре. Правда, ток может отсутствовать в цепи не только потому, что нет сообщений, но и из-за ее обрыва. Для своевременного выявления неисправного состояния MIDI-сети предусмотрена периодическая передача специального тестового сигнала. Если по прошествии определенного времени приемник его не обнаружит, то это будет считаться аварией, после чего MIDI-система отработает заранее обусловленную последовательность действий.

Рис. 1.1.Структура элементарного MIDI-сигнала

Пропускная способность MIDI-канала 3,125 кбайт/с. Команды могут быть одно-, двух- и трехбайтными. Первый байт — статусный. Он определяет действие команды. За ним могут следовать 1 — 2 байта данных. Старший бит статусного байта 1, а байта данных — 0.


1.1.3. Соединительные MIDI-разъемы и MIDI-кабель

Полноценное MIDI-устройство имеет три соединительных разъема: MIDI In (вход), MIDI Out (выход) и MIDI Thru (на разъем MIDI Thru через буфер ретранслируется копия сигнала, поступающего с внешнего MIDI-устройства на вход MIDI In). Все разъемы — пятиконтактные. Контакты 4 и 5 — сигнальные, контакт 2 — экран. Полярность сигналов определяется относительно источника тока: контакт 4 — плюс (ток вытекает из вывода), контакт 5 — минус (ток втекает в вывод). Таким образом, для разъемов MIDI Out и MIDI Thru назначение контактов одно и то же, для разъема MIDI In — обратное.

Рис. 1.2. Схема распайки разъемов MIDI-кабеля

Для соединения используется двужильный экранированный кабель. Соединение разъемов на двух концах кабеля — прямое (2-2, 4-4, 5-5). Схема распайки разъёмов MIDI-кабеля представлена на рис. 1.2.


1.1.4. Принцип соединения MIDI-устройств

Принцип соединения двух MIDI-устройств показан на рис. 1.3. Контакт передатчика, с которого во внешнюю цепь снимается сигнал, называется MIDI TXD (Transmitter Data). Контакт приемника, на который из внешней цепи должен поступать сигнал, — MIDI RXD (Receiver Data).

Рис. 1.3. Принцип соединения двух MIDI-устройств

Аппаратная часть интерфейса MIDI замечательна тем, что разработчики предусмотрели в ней несколько мер, направленных на снижение уровня шума и помех. К простейшим, но достаточно эффективным мерам относится обязательное экранирование кабелей, соединяющих MIDI-устройства. Экран представляет собой проволочную оплетку, которая защищает проводники от проникновения в них электромагнитных волн, несущих помехи. И, что не менее важно, экран предотвращает излучение электромагнитных волн в окружающее пространство самим MIDI-кабелем. Посредством экрана помехи не проникают с одного инструмента на другой, так как в соответствии со стандартом MIDI исключено электрическое соединение экрана с корпусами одновременно двух MIDI-устройств. Самое главное, помехи не могут попасть с одного инструмента на другой еще и потому, что даже сигнальные провода не имеют непосредственной (говорят: гальванической) связи одновременно и с прибором-передатчиком, и с прибором-приемником MIDI-сообщений. Разумеется, здесь нет парадокса: если по проводам передается информация, значит, связь есть, но эта связь в действительности не гальваническая, а оптическая. Во входной цепи интерфейса MIDI включена пара оптоэлектронных приборов. Светодиод начинает светиться, когда по кабелю передается логический ноль, и гаснет, если передается логическая единица. Свет направлен на фотодиод, ток через который тем сильнее, чем сильнее этот прибор освещен. Цепочка преобразования сигналов такова: электрический ток — свет — электрический ток. Таким способом создается непреодолимое препятствие на пути протекания токов, несущих в себе помехи (величины этих токов недостаточно, чтобы светодиод стал излучать свет), в то же время цифровые сигналы проходят совершенно свободно.
Стандартом предусмотрено, что в сети MIDl-устройств в одно и то же время только одно из них может быть передатчиком MIDI-сообщений, а все остальные — только приемниками. Один MIDI-передатчик допускает подключение до четырех приемников.
На рис. 1.4 представлен вариант подключения MIDI-устройств к MIDI-интерфейсу звуковой карты, установленной в компьютер.

Рис. 1.4. Подключение MIDI-устройств к звуковой карте


1.1.5. MIDI-сигналы в разъеме игрового порта звуковой карты

Следует заметить, что у звуковых карт, как правило, отсутствуют стандартные MIDI-разъемы. Это связано с тем, что габариты не позволяют разместить их в прорезях на задней стенке компьютера, предназначенных для закрепления плат расширения. "Полуфабрикаты" MIDI-сигналов (MIDI RXD и MIDI TXD) выводятся на контакты разъема игрового порта (рис. 1.5).
Для правильной ориентации в номерах контактов нужно учесть, что разъем показан таким, каким он представлялся бы наблюдателю, сидящему внутри компьютера. Не очень удобная точка наблюдения, но именно ей соответствует рисунок, обычно приводимый в описании звуковой карты. Чтобы не запутать вас, на рис. 1.5 мы не стали менять направления взгляда.

Рис. 1.5. Назначение некоторых контактов разъема игрового порта

Большинство контактов предназначено для подключения джойстика, однако, они нас сейчас не интересуют. Обратите внимание на следующие контакты:

  • 4, 5 — соединенные с общим проводом блока питания компьютера или, как иногда говорят, с корпусом, с землей (на схемах это соединение обозначают GND);
  • 1, 8, 9 — соединенные с выводом +5 В источника питания компьютера;
  • 15 — на который из внешних цепей должен поступать сигнал MIDI RXD (Receiver Data);
  • 12 — с которого во внешнюю цепь снимается сигнал MIDI TXD (Transmitter Data).
Наличие контактов 12 и 15, а также соответствующих им сигналов позволяет производителям и продавцам утверждать, что данная звуковая карта снабжена интерфейсом MIDI. Однако на деле сигналы MIDI TXD и MIDI RXD следует рассматривать как полуфабрикаты настоящих MIDI-сигналов. С их помощью можно принимать и передавать информацию, представленную стандартными для компьютеров значениями напряжения (говорят, уровнями транзисторно-транзисторной логики — TTL). И даже если заменить один из пятиконтактных разъемов MIDI-кабеля на разъем, соответствующий тому, что изображен на рис. 1.8, то подключить через этот кабель синтезатор к звуковой карте не удастся. Дело в том, что сигнал MIDI TXD не будет правильно восприниматься светодиодом, с помощью которого в интерфейсе MIDI передают полезные сигналы и прерывают гальваническую связь MIDI-устройств друг с другом.
Для подключения звуковой карты к MlDI-устройствам необходим переходной кабель-адаптер, содержащий оптронную развязку.
При соединении MIDI-устройств нужно придерживаться несложного правила: кабель не должен соединять одноименные разъемы двух устройств, т. е. нельзя соединять MIDI Out одного устройства с MIDI Out другого, также MIDI In с MIDI In. Однако если вы случайно ошиблись, ничего страшного не случится: в схеме MIDI-интерфейса есть необходимая защита.
А вот один кабель или два следует протягивать между MlDI-устройствами, зависит от того, что это за устройства и в каких целях они используются.
Сначала рассмотрим наиболее вероятную ситуацию. Допустим, вы приобрели MIDI-клавиатуру и хотите подключить ее к звуковой карте, воспользовавшись MIDI-интерфейсом. Нет ничего проще, однако прежде необходимо разобраться, чем же отличается MIDI-клавиатура от клавишного электронного музыкального инструмента (синтезатора). Последний содержит и клавиатуру, и блок синтеза, поэтому в состоянии самостоятельно формировать звуки. Все современные синтезаторы оснащены MIDI-интерфейсом. MIDI-клавиатура не обладает способностью синтезировать звук. Она предназначена лишь для того, чтобы посредством MIDI-интерфейса управлять работой внешнего (по отношению к ней) синтезатора. Это, прежде всего, наиболее дешевый вариант совместного использования нескольких синтезаторов. В этом случае они могут не иметь собственных клавиатур, чем и определяется их относительно низкая стоимость. Синтезатор, который не имеет собственной клавиатуры, принято называть тон-генератором.


1.1.6. Подключение к звуковой карте MIDI-клавиатуры и MIDI-синтезатора

Вернемся к вопросу о подключении MIDI-клавиатуры к звуковой карте (рис. 1.6).
Действительно, сделать это очень просто: в гнездо MIDI Out клавиатуры вставьте вилку MIDI In адаптера, а 15-контактный разъем MIDI-адаптера соедините с разъемом игрового порта, расположенным на звуковой карте. MIDI-клавиатура здесь будет играть роль ведущего MIDI-устройства, а звуковая карта — ведомого.

Рис. 1.6. Подключение MIDI-клавиатуры к звуковой карте

Если у вас уже имеется современная, с широкими функциональными возможностями звуковая карта и вы хотите исполнять музыку не с помощью мыши, а проверенным дедовским способом, перебирая белые и черные клавиши, то MIDI-клавиатура — это выход из положения. Заметим, что в продаже имеются музыкальные синтезаторы с клавиатурой и MIDI-интер-фейсом. Некоторые из них (относительно простые) немногим дороже MIDI-клавиатур. В режимах исполнения и записи композиции синтезатор можно использовать в качестве MIDI-клавиатуры. Для этого следует выполнить такое же соединение, как и в случае подключения MIDI-клавиатуры: MIDI Out синтезатора соединить с входом MIDI In адаптера.
При проигрывании композиции внешний синтезатор с клавиатурой можно использовать как дополнение к звуковой карте и извлекать из него звуки тех инструментов, которые отсутствуют в палитре звуковой карты. Для реализации этой возможности выход MIDI Out адаптера следует соединить со входом MIDI In синтезатора (рис. 1.7).

Рис. 1.7. Схема подключения внешнего синтезатора к звуковой карте


1.1.7. Решение проблемы самовозбуждения MIDI-системы

При некорректном выборе режима работы музыкального редактора соединение по схеме, приведенной на рис. 1.7, может вызвать неприятный эффект: поданное с клавиатуры сообщение, например нажатие клавиши, поступит на звуковую карту, а оттуда вновь в синтезатор, а с синтезатора вновь на звуковую карту... И так до бесконечности. Система зациклится, возбудится и перегрузится. Звуки будут слышны неинтересные. Что следует сделать, чтобы избежать этого?
Из рис. 1.7 следует, что оба устройства — и звуковая карта и синтезатор — одновременно оказываются и MIDI-приемниками и MIDI-передатчиками. Это недопустимо. Тривиальный выход — отключить второй кабель на время использования синтезатора в качестве MIDI-клавиатуры и подключить его при воспроизведении записанной ранее мелодии, — крайне неудобен. Все эти отключения, подключения, поверьте, кончатся плохо. Проще и безопасней для аппаратуры и вашего кошелька выполнить необходимую коммутацию на логическом уровне. Делается это или непосредственно в синтезаторе (выключателем Local Off), или в музыкальном редакторе.
Однако было бы правильнее решить проблему зацикливания, манипулируя опциями ретрансляции MIDI-сообщений. Суть дела состоит в том, что MIDI-информация, поступающая на вход устройства (или программы, в нашем случае Cubase SX), транслируется на его выход. Рассмотрим классический пример, когда синтезатор звуковой карты используется совместно с внешним синтезатором, который, в свою очередь, еще и выполняет функции MIDI-клавиатуры. Зацикливание неминуемо возникнет в том случае, если вы выберете трек, у которого в качестве портов ввода/вывода заданы порты, физически подключенные к внешнему синтезатору. Последовательность возникновения нежелательного эффекта зацикливания такова:
1. Вы нажимаете на синтезаторе клавишу, синтезатор воспроизводит соответствующую ноту.
2. MIDI-сообщение типа Note On (см. разд. 1.2.1) поступает в звуковой редактор.
3. В звуковом редакторе, благодаря ретрансляции MIDI-сообщений, это же сообщение передается на входной порт синтезатора.
4. Синтезатор, получив сообщение Note On, отрабатывает его, воспроизводя соответствующую ноту (заметьте, уже не в первый раз).
5. В синтезаторе тоже работает ретрансляция MIDI-сообщений (можно ли ее отключить и как это сделать — ищите в руководстве пользователя), поэтому дальше см. п. 2.
Чтобы разорвать эту цепочку, следует отключить ретрансляцию MIDI-сообщений или в синтезаторе, или в программе (как правило, в музыкальных редакторах эта опция по умолчанию включена). В Cubase SX следует поступить так: откройте меню File, выберите команду Preferences. Откроется диалоговое окно Preferences. В дереве, находящемся в левой части окна, выберите ветвь MIDI. На открывшейся вкладке MIDI сбросьте флажок MIDI Thru Active. Теперь зацикливания не будет. Убедиться в этом можно, нажав ОК, после чего диалоговое окно Preferences закроется. Можно также нажать кнопку Apply, окно Preferences останется открытым, а изменения, внесенные вами, будут применены.
При сброшенном флажке MIDI Thru Active теряется возможность использовать внешний синтезатор в качестве MIDI-клавиатуры для управления встроенным синтезатором звуковой карты.


1.2. Формат MIDI-данных. Типы MIDI-сообщений в Cubase SX

К категории MIDI в программе Cubase SX относятся следующие сообщения: Note, Controller, Program Change, Aftertouch, Pitchband, SysEx.
Кроме того, предусмотрены сообщения SMF и Text. Сообщения этих двух типов не принадлежат к категории MIDI-сообщений и не влияют на синтез звука. Сообщения SMF относятся к сообщениям нотации. Сообщение Text (текстовая метка, комментарий) имеет единственный параметр — текстовую строку. Они отображаются только в списке сообщений редактора List Editor, а также над нотным станом (в окне редактора Score Editor) и предназначены для записи комментариев или текста песни.
Рассмотрим подробнее сообщения категории MIDI.


1.2.1. Note — сообщение о нажатии MIDI-клавиши

Note — это сообщение о том, что нажата клавиша MIDI-клавиатуры. Параметры сообщения — нота (используется символьное обозначение), громкость и длительность.
Сообщения Note формируются программой на основе стандартных канальных MIDI-сообщений Note On (включение ноты) формата 9k nn vv и Note Off (выключение ноты) формата 8k nn vv, где k — номер MIDI-канала, nn — номер ноты, w — скорость (Velocity) нажатия клавиши (в Note On), no умолчанию соответствующая громкости звучания ноты, или скорость ее отпускания (в Note Off). Причем числа 9k, 8k, nn и w — шестнадцатеричные.
Сообщение о включении/выключении ноты MIDI-клавиатура генерирует при нажатии/отпускании клавиши. При этом MIDI-синтезатор включает/ выключает генератор соответствующего звука.
В MIDI номер ноты задается абсолютным номером полутона в диапазоне 0-127, причем центральной фортепианной клавише — ноте до первой октавы — соответствует десятичный номер 60. В соответствии с принятой стандартом MIDI нумерацией октав (с нуля) эта нота имеет обозначение С5. Однако в Cubase SX система нумерации MIDl-октав несколько иная: отсчет октав начинается не с 0, а с —2. Поэтому центральная нота обозначена как СЗ.
Скорость (Velocity) нажатия/отпускания клавиши характеризуется десятичным числом от 0 до 127. Скорость нажатия соответствует силе удара по клавише. Чувствительная к скорости нажатия (динамическая) клавиатура выдает реальные значения этого параметра. Нечувствительная — значения 64 (десятичные).
Сообщение Note On с параметром vv = 00 эквивалентно сообщению Note Off для этой же клавиши. В простых синтезаторах информация о скорости нажатия клавиши используется для управления громкостью извлекаемого звука, в более сложных — еще и для управления фильтрами (например, большей громкости соответствует более звонкий звук) либо для выбора нужного сэмпла.
Хотя MIDI-клавиатурой формируются два сообщения (Note On и Note Off), программа преобразует их в одно типа Note, с тремя временными параметрами: временем включения ноты (нажатия MIDI-клавиши), временем выключения ноты (отпусканием MIDI-клавиши) и продолжительностью удержания MIDI-клавиши нажатой. Независимыми являются только два параметра.


1.2.2. Controller — сообщение о состоянии контроллера

Controller — сообщение о состоянии контроллера. Параметры сообщения — тип контроллера и его состояние. В спецификации MIDI этому сообщению соответствует сообщение Control Change формата Bk cc vv, где k — номер MIDI-канала, ее — номер, vv — значение контроллера. В литературе принято обозначать сообщение Control Change сокращенно, например, СС91 — сообщение о смене значения контроллера глубины эффекта реверберации.
MIDI-контроллеры делятся на контроллеры непрерывного действия (связанные с рукоятками, движками, регуляторами и т. п.) и переключатели (педали, кнопки и т. п.), имеющие два дискретных состояния (On/Off— включено/выключено). Для переключателей значения контроллера 0—63 означают выключенное состояние, а 64—127 — включенное.
В соответствии со спецификацией General MIDI принята следующая нумерация контроллеров:

  • № 0-31 — старший байт значения контроллеров непрерывного действия;
  • № 32-63 — младший байт значений контроллеров непрерывного действия;
  • № 64-95 — переключатели;
  • № 96-119 — зарезервированы;
  • № 120-127 — специальные канальные сообщения.
На сообщения, содержащие старший или младший байт значения контроллера, MIDI-устройства реагируют немедленно. Причем в качестве недостающего байта значения контроллера используется либо ранее переданное, либо установленное по умолчанию значение. Это позволяет, передав однажды неизменный байт, в дальнейшем передавать только изменившийся байт значения контроллера.
Спецификацией General MIDI определены следующие контроллеры:
  • № 1 — Modulation — контроллер глубины частотной модуляции;
  • № 2 — Breath — духовой контроллер;
  • № 4 — Foot Controller — ножной контроллер;
  • № 5 — Portamento Time — контроллер времени портаменто (портаменто — плавный переход по частоте от ноты к ноте);
  • № 7 — Volume — контроллер громкости звука в канале;
  • № 8 — Balance — контроллер баланса стереоканалов;
  • № 10 — Pan — контроллер панорамы;
  • № 11 — Expression — контроллер экспрессивности звука;
  • № 64 — Sustain Pedal, Holdl — контроллер педали удержания звучания нот;
  • № 65 — Portamento — контроллер включения/выключения режима портаменто;
  • № 66 — Sostenuto Pedal — контроллер педали удержания звучания нот, включенных во время действия педали;
  • № 67 — Soft Pedal — контроллер педали приглушения звука.


1.2.3. Program Change — сообщение о смене MIDI-инструмента

Program Change — сообщение о смене MIDI-инструмента (тембра, патча, программы). Параметры сообщения — способ выбора банка, номер банка, номер инструмента в банке.
Поскольку MIDI-инструменты распределены по банкам, в спецификации MIDI сообщению Program Change соответствует совокупность сообщений: Program Change, Bank Select MSB и Bank Select LSB.
Для выбора MIDI-инструмента предназначено сообщение Program Change формата Ck pp, где k — номер MIDI-канала, pp — номер MIDI-инструмента.
Для переключения банков служат контроллеры:

  • № 0 — Bank Select MSB — контроллер выбора банка (старший байт);
  • № 32 — Bank Select LSB — контроллер выбора банка (младший байт).
Одним MIDI-устройствам для переключения банков требуется только один из этих контроллеров, другим — оба. Обработка MIDI-устройством команды смены банка и MIDI-инструмента может занять значительное время (десятки миллисекунд и более).
В спецификации General MIDI регистрируемые (Registered Parameter Number — RPN) и нерегистрируемые (Non-Registered Parameter Number — NRPN) параметры введены дополнительно для расширенного управления синтезом.
Номера RPN и NRPN передаются при помощи контроллеров:
  • № 98 — NRPN LSB — контроллер младшего байта параметра NRPN;
  • № 99 — NRPN MSB — контроллер старшего байта параметра NRPN;
  • № 100 — RPN LSB — контроллер младшего байта параметра RPN;
  • № 101 — RPN MSB — контроллер старшего байта параметра RPN.
MIDI-устройство запоминает однажды переданные ему сообщения RPN или NRPN, после которых передаются значения соответствующего параметра при помощи контроллеров:
  • № 6 — Data Entry MSB — контроллер вводимых данных (старший байт);
  • № 38 — Data Entry LSB — контроллер вводимых данных (младший байт).
Такой механизм передачи сообщений можно охарактеризовать как "контроллер в контроллере". Стандартом определена интерпретация только трех RPN (их значения задаются старшими байтами параметров Data Entry):
  • RPN 0 — Pitch Bend Sensitivity — контроллер для изменения чувствительности колеса сдвига тона (Pitch Bend);
  • RPN I — Fine Tuning — контроллер для точной подстройки строя синтезатора;
  • RPN 2 — Coarse Tuning — контроллер для грубой подстройки строя синтезатора.
RPN 0 определяет количество полутонов, на которое смещается высота тона при получении сообщения Pitch Bend Change с максимально допустимым абсолютным значением параметра. По умолчанию принимается диапазон перестройки частоты на плюс-минус два полутона.
В сообщении RPN 0 содержится параметр X, определяющий ширину диапазона перестройки тона. Он рассчитывается по формуле X = 1284N+C, где N — ширина диапазона в полутонах, С — уточнение ширины диапазона в центах (сотых долях полутона). Некоторые синтезаторы (например, поддерживающие спецификации GS или XG) воспринимают только целое число полутонов (значение параметра С игнорируется). Чтобы, например, установить ширину диапазона перестройки частоты колеса сдвига тона равной плюс-минус одной октаве, нужно передать сообщение NRPN 0 1536. Число 1536 рассчитано следующим образом: 128412 = 1536 (12 — количество полутонов в октаве).
RPN 1 и RPN 2 позволяют сместить строй инструмента в MIDI-канале на заданное количество центов при точной или полутонов при грубой подстройке. За относительный ноль принимается значение 64.
Интерпретация остальных контроллеров RPN и NRPN стандартом не определена. Каждый производитель MIDI-аппаратуры может использовать их по своему усмотрению.
Спецификацией Roland GS (General Synth) определены дополнительные контроллеры:
  • № 91 — Reverb Level — контроллер глубины реверберации;
  • № 93 — Chorus Level — контроллер глубины хоруса.
Спецификацией Yamaha XG (extended General) определены контроллеры, которые не предусмотрены спецификацией Roland GS:
  • № 71 — Harmonic Content — контроллер глубины резонанса фильтра;
  • № 72 — Release Time — контроллер времени затухания звука после выключения ноты;
  • № 73 — Attack Time — контроллер времени нарастания звука после включения ноты;
  • № 74 — Brightness — контроллер частоты среза фильтра;
  • № 84 — Portamento Control — контроллер номера ноты, начиная с которой будет выполнено плавное скольжение по частоте до очередной включенной ноты (портаменто);
  • № 94 — Variation Level — контроллер глубины эффекта Variation;
  • № 96 — RPN Increment — контроллер увеличения значения RPN на 1, значение контроллера RPN Increment игнорируется;
  • № 97 — RPN Decrement — контроллер уменьшения значения RPN на 1, значение контроллера RPN Decrement игнорируется.
Таким образом, устройства, соответствующие спецификациям GM, GS и XG, обладают различными возможностями по управлению параметрами синтеза. Исчерпывающие сведения о контроллерах, регистрируемых и нерегистрируемых параметрах можно найти только в документации на конкретные модели звуковых карт, синтезаторов и модулей синтеза.


1.2.4. Aftertouch — сообщение о силе давления на нажатые клавиши

Aftertouch — сообщение о силе давления на все нажатые клавиши, с которыми связан текущий MIDI-канал. Параметр сообщения — давление. В спецификации MIDI этому сообщению соответствует сообщение Channel Pressure, или Channel Aftertouch, формата Dk pp, где k — номер MIDI-канала, рр — давление.
Сообщение Aftertouch несет информацию об изменении давления на клавиши после прикосновения к ним. Простые модели клавиатур не имеют датчика давления. Модели средней сложности имеют датчик, общий для всех клавиш, и посылают сообщения Channel Pressure, предварительно усреднив давление на все нажатые клавиши. Сложные модели оборудованы отдельным для каждой клавиши датчиком и посылают сообщения об изменении состояния каждого датчика. Реакция синтезатора на эти сообщения стандартом не определена. Обычно синтезаторы с функцией Aftertouch поддерживают команды ассоциирования сообщений с выбранным параметром синтеза (с громкостью, модуляцией, параметром фильтра или эффекта и т. п.).


1.2.5. Pitchband — управление регулятором тона

Pitchband — управление регулятором тона. Параметр сообщения — положение регулятора тона, задаваемое числом от -8192 до 8191. В спецификации General MIDI этому сообщению соответствует сообщение Pitch Bend Change формата Ek II mm, где k — номер MIDI-канала, 11 — младший байт, mm — старший байт значения контроллера. Контроллер задает смещение высоты тона для всех сообщений типа Note, передаваемых по данному MIDI-каналу. Значение контроллера изменяется от 0 до 16 383; среднее значение (8192) принимается за относительный ноль. Чувствительность контроллера Pitchband может изменяться при помощи регистрируемого параметра RPN 0. По умолчанию в качестве предельного значения смещения тона принимается интервал в два полутона (с любым знаком).


1.2.6. SysEx (System Exclusive) — привилегированные системные сообщения

SysEx (System Exclusive) — сообщения, предназначенные для обмена специфической информацией, которая по усмотрению производителя MIDI-устройства может иметь различное назначение. С помощью сообщений этих типов синтезатору подаются такие команды, как, например, сброс (Reset), смена типа эффекта и т. п. В спецификации MIDI эти сообщения относятся к привилегированным системным сообщениям (System Exclusive). Параметром таких сообщений является блок данных — последовательность шестнадцатеричных чисел. В начале блока данных обязательно передается число FO, а завершает его число F7. Привилегированные системные сообщения чем-то похожи на машинные коды и предназначены для интерпретатора MIDI-команд синтезатора.


1.3. MIDI-секвенсор. Дискретная шкала времени

Итак, посылая MIDI-сообщения, можно управлять работой синтезатора, передавать ему команды, определяющие момент начала извлечения определенной ноты, ее длительность, а также значения множества параметров синтеза звука. Эти команды можно посылать в реальном времени, нажимая клавиши MIDI-клавиатуры и изменяя положения различных регуляторов и переключателей, расположенных на ней. Но можно поступать и по-другому: заранее записать всю последовательность действий, преобразованных в MIDI-сообщения, в запоминающее устройство, а позже, когда в этом возникнет необходимость, считать MIDI-сообщения из запоминающего устройства и направить их в синтезатор. Причем вводить данные в запоминающее устройство можно с помощью все той же MIDI-клавиатуры. Что дает такое промежуточное звено? Возникают, как минимум, пять принципиально важных возможностей.
1. При записи сообщений можно играть на MIDI-клавиатуре в значительно меньшем темпе, чем требуется при исполнении конкретного произведения, а воспроизводить запись — быстрее. В итоге с любой композицией, сколь сложной она ни была бы, справится любой человек, даже не обладающий навыками игры на музыкальном инструменте.
2. Записанные данные можно подвергать редактированию в целях устранения исполнительских погрешностей или придания исполнению определенного стиля.
3. Можно записывать не всю партию, а только ту ее часть, которая составляет один период. Например, можно записать один куплет и один припев, а затем скопировать эти две части и в необходимом количестве экземпляров вставить в партию.
4. Можно поочередно записать все партии и скомпоновать из них цельное музыкальное произведение.
5. В небольшом по объему запоминающем устройстве можно хранить очень много продолжительных композиций. Ведь MIDI-сообщение не передает сам звук или какие-то его характеристики, а только команды, которые выполняются устройством-получателем.
Программа, предназначенная для записи, редактирования и воспроизведения последовательности MIDI-сообщений, называется MIDI-секвенсором.
Конечно, существуют и аппаратные секвенсоры. Некоторые из них выполнены в виде отдельного устройства, а другие входят в состав синтезаторов. Программные секвенсоры выгодно отличаются от аппаратных. Наглядность отображения данных, неограниченное количество композиций и партий в композициях, сохраняемое в памяти, развитые средства редактирования — вот неполный перечень их преимуществ.
Совокупность данных, с которыми работает секвенсор, называют сонгом или проектом. Кроме последовательности MIDI-сообщений в проекте может храниться всевозможная дополнительная информация: начальные установки секвенсора и синтезатора, названия отдельных партий, данные автоматизации (например, команды управления микшером), ссылки на другие данные (не относящиеся к MIDI). Проект можно сохранить в памяти компьютера в виде файла.
Современные программные MIDI-секвенсоры, как правило, входят в состав музыкальных редакторов, которые позволяют работать не только с MIDI-сообщениями, но также и со звуком, представленным в цифровой форме, и даже с оцифрованным изображением. Как вы уже знаете, к числу программ с наиболее развитыми средствами редактирования MIDI- и аудио-данных принадлежит и Cubase SX.
MIDI-сообщения дискретны по своей сути. И дело не только в том, что каждое сообщение выражается числом, которое может принимать только строго определенные значения. Существенно также, что поток MIDI-сообщений дискретен во времени. Они не могут передаваться непрерывно. Передача и обработка элементарных сигналов в MIDI осуществляется с конечной скоростью в определенные тактовые моменты, привязанные к началу передачи сообщения. Причем непосредственно в аппаратной части интерфейса сообщения передаются только последовательно: одно за другим, без какого-либо перекрытия во времени. Когда вы приступите к изучению MIDI-редакторов программы Cubase SX, то у вас может создаться впечатление, что в секвенсоре параллельно существует несколько потоков MIDI-сообщений. Но это кажущаяся параллельность. Такая иллюзия возникает только из-за того, что информация в MIDI-редакторе визуально отображается как несколько расположенных параллельно треков, на каждом из которых записывается и редактируется какая-нибудь одна партия. На самом деле данные со всех этих треков, сколько бы их ни было, хоть тысяча, передаются синтезатору последовательно через все тот же соединитель MIDI-интерфейса: два проводника. Конечно, в системе может быть и не один MIDI-интерфейс, а несколько, и не один синтезатор, а тоже несколько, но сейчас речь не об этом.
Предположим, что на MIDI-клавиатуре взят и записан в секвенсор аккорд из трех нот. Это значит, при воспроизведении композиции 3 ноты должны зазвучать одновременно. Однако соответствующие сообщения секвенсор передаст синтезатору не одновременно, а одно за другим. Скорость передачи сообщений по MIDI выбрана такой, что на слух временное рассогласование будет незаметно, но нужно понимать, что оно принципиально неустранимо. А если в композиции сотня партий, причем в доброй половине из них записаны аккорды? Не исключено, что в этом случае не только станет заметным рассогласование во времени между звучанием тех нот, которые вообще-то должны браться одновременно, но наступят и более неприятные последствия. Может оказаться, что интерфейс (речь идет о MIDI) еще не успеет передать все сообщения, относящиеся к одному моменту (ноты, которые должны, к примеру, звучать в первой четверти), как уже нужно будет передавать сообщения, соответствующие следующему моменту (пойдет вторая четверть и должны быть сыграны следующие ноты). Интерфейс окажется перегруженным. Если при исполнении задействованы контроллеры непрерывного (точнее говоря, квазинепрерывного) действия (связанные со слайдерами, рукоятками, колесами и т. п.), которые создают не поток, а целый океан сообщений, то перегрузка интерфейса возможна даже при небольшом количестве партий и одновременно исполняемых нот.
Когда разрабатывались требования к стандарту MIDI, никто, вероятно, и предположить не мог, что через четверть века скорость обмена данными внутри компьютера будет измеряться гигабитами в секунду, и MIDI-интерфейс станет настоящим тормозом, самым узким местом в компьютерной системе обработки музыки.
Для того чтобы уменьшить вероятность возникновения перегрузки MIDI-интерфейса, разработчики сознательно ограничивают разрешающую способность секвенсоров по времени. Она выбирается, исходя из двух противоречивых условий. С одной стороны нужно, чтобы дискретность записи и передачи сообщений не препятствовала музыканту в выражении самых тончайших ритмических нюансов. Для этого временная шкала секвенсора должна быть поделена на очень короткие отрезки. С другой стороны требуется, чтобы для произведений, типичных с точки зрения насыщенности музыкальными партиями, перегрузка MIDI-интерфейса не возникала или возникала бы, но с очень малой вероятностью.
Шкала времени секвенсора образована на основе трех единиц измерения: музыкальных тактов, музыкальных долей и тиков.
Самая большая единица здесь — такт. Доля составляет определенную часть такта. Это привычные для музыканта понятия. Такие единицы измерения временных интервалов оказываются особенно полезными при работе с секвенсором посредством специального транслятора MIDI-сообщений в графические символы нотного письма — нотного редактора или нотатора. Нотатор способен отображать ноты и паузы той длительности, которая не короче выбранной величины доли. В Cubase SX выбирать величину доли можно в пределах от половинной с точкой до шестьдесятчетвертой триоли. Для традиционной нотной записи партитур этого более чем достаточно. Ноты и паузы, короче шестьдесятчетвертой триоли в нотной записи не отображаются. Хотя реально в секвенсоре можно записать значительно более короткие звуки, с существенно меньшим шагом во времени. Разрешающая способность секвенсора равна одному временному кванту, который носит название тик.
Тик составляет определенную очень маленькую часть четвертной доли такта.
Чем больше в доле тиков, тем тоньше ритмические нюансы, которые удастся записать. В Cubase SX разрешающая способность секвенсора составляет 480 тиков в четвертной доле, 120 тиков соответствуют шестнадцатой ноте. Это ювелирный инструмент музыканта: получается, что можно записать ноту (или паузу) в 120 раз короче шестнадцатой!


1.4. Оцифровка звука

Для получения приемлемого качества записи компьютерной музыки необходимо пользоваться аппаратурой, способной его обеспечить. К параметрам, от которых это зависит, относятся, в первую очередь:

  • Разрядность аналого-цифрового и цифроаналогового преобразователей звуковой карты;
  • Диапазон частот дискретизации.
Разрядность звуковой карты существенно влияет на качество звука. Однако перед тем как перейти к более детальному обсуждению этого вопроса, следует пояснить, что речь идет о разрядности аналого-цифрового преобразователя (АЦП) (Analog/Digital Converter — ADC) и цифроаналогового преобразователя (ЦАП) (Digital/Analog Converter — DAC).
Звуковые карты двойного назначения имеют в своем составе одновременно два функционально независимых узла: синтезатор и устройство оцифровки звуковых сигналов, поступающих с внешнего источника. В каждый из узлов входит как минимум по одному ЦАП. В устройстве оцифровки, кроме того, имеется АЦП. Некоторые полупрофессиональные звуковые карты оборудованы 24-битными ЦАП/АЦП. Звуковые редакторы, работая с любыми звуковыми картами, в том числе и 16-битными, в процессе преобразований отсчетов сигнала используют арифметику с разрядностью двоичного представления числа, превышающей 16. Это позволяет уменьшить погрешность, накапливающуюся в процессе выполнения сложных алгоритмов обработки, которая в противном случае проявлялась бы как искажение звука.


1.4.1. Аналого-цифровое преобразование

Почему же столь важно наличие большого числа разрядов в устройствах ЦАП и АЦП? Дело заключается в том, что непрерывный (аналоговый) сигнал преобразуется в цифровой с некоторой погрешностью. Эта погрешность тем больше, чем меньше уровней квантования сигнала, т. е. чем дальше отстоят друг от друга допустимые значения квантованного сигнала. Число уровней квантования в свою очередь зависит от разрядности АЦП/ЦАП. Погрешности, возникающие в результате замены аналогового сигнала рядом квантованных по уровню отсчетов, можно рассматривать как его искажения, вызванные воздействием помехи. Эту помеху принято образно называть шумом квантования.
Шум квантования представляет собой разность соответствующих значений реального и квантованного по уровню сигналов.
В случае превышения сигналом значения самого верхнего уровня квантования ("старшего" кванта), а также в случае, когда значение сигнала оказывается меньше нижнего уровня квантования ("младшего" кванта), т. е. при цифровом ограничении сигнала, возникают искажения, более заметные по сравнению с шумом квантования. Для исключения искажений этого типа динамические диапазоны сигнала и АЦП должны соответствовать друг другу: значения сигнала должны располагаться между уровнями, соответствующими младшему и старшему квантам. При записи внешних источников звука это достигается с помощью регулировки их уровня, кроме того, применяется сжатие (компрессия) динамического диапазона, о которой речь пойдет в разд. 1.10.2.
В звуковых редакторах существует операция нормализации амплитуды сигнала. После ее применения наименьшее значение сигнала станет равным верхнему уровню младшего кванта, а наибольшее — нижнему уровню старшего кванта. Таким образом, от ограничения сигнал сверху и снизу будет защищен промежутками, шириной в один квант.
Для нормированного сигнала относительная величина максимальной погрешности квантования равна 1/N, где N — число уровней квантования. Этой же величиной, представленной в логарифмических единицах (децибелах), оценивается уровень шумов квантования АЦП звуковой карты. Уровень шумов квантования определяется по формуле: D = 201g (1/N). Для восьмиразрядного АЦП N = 256, D = -48 дБ; для шестнадцатиразрядного — N = 65536,; D= -96 дБ и для двадцатиразрядного АЦП N = 1648576, D = -120 дБ. Эти цифры наглядно демонстрируют, что с ростом разрядности АЦП шум квантования уменьшается. Приемлемым считается шестнадцатиразрядное представление сигнала, являющееся в настоящее время стандартным для воспроизведения звука, записанного в цифровой форме. С точки зрения снижения уровня шумов квантования дальнейшее увеличение разрядности АЦП особого смысла не имеет, т. к. уровень шумов, возникших по другим причинам (тепловые шумы, а также импульсные помехи, генерируемые элементами схемы компьютера и распространяющиеся либо по цепям питания, либо в виде электромагнитных волн), все равно оказывается значительно выше, чем -96 дБ.
Однако увеличение разрядности АЦП обусловлено еще одним условием — стремлением расширить его динамический диапазон. Динамический диапазон некоторого устройства обработки может быть определен выражением D = 201g (Smax/Smin), где Smax и Smin — максимальное и минимальное значения сигнала, который может быть преобразован в цифровую форму без искажения и потери информации. Вы уже, наверное, догадались, что минимальное значение сигнала не может быть меньше, чем напряжение, соответствующее одному кванту, а максимальное — не должно превышать величины напряжения, соответствующего N квантам. Поэтому выражение для динамического диапазона АЦП звуковой карты примет вид: D = 201g (N). Ведь можно считать, что Smax= kN, a Smin = k1, где k — некоторый постоянный коэффициент пропорциональности, учитывающий соответствие электрических величин (тока или напряжения) номерам уровней квантования.
Из сравнения выражений для А и D становится ясно, что при одинаковой разрядности АЦП эти величины будут отличаться лишь знаками. Поэтому динамический диапазон для шестнадцатиразрядного АЦП составляет 96 дБ, для двадцатиразрядного — 120 дБ. Иными словами, для записи звучания некоторого источника звука, динамический диапазон которого равен 120 дБ, требуется двадцатиразрядный АЦП. Если такого нет, а имеется только шестнадцатиразрядный, то динамический диапазон звука должен быть сжат на 24 дБ: со 120 дБ до 96 дБ.
В принципе, существуют методы и устройства сжатия (компрессии) динамического диапазона звука, и мы еще будем говорить о них (см. разд. 1.10.2). Но то, что они проделывают со звуком, как ни смягчай формулировки, все равно, представляет собой его искажение. Именно поэтому так важно для оцифровки звука использовать АЦП, имеющий максимальное количество разрядов. Динамические диапазоны большинства источников звука вполне соответствуют динамическому диапазону 16-битной звуковой карты. Кроме того, 24-битное или 32-битное представление сигнала применяется в основном на этапе обработки звука. Конечная аудиопродукция (CD Digital Audio и DAT) реализуется в 16-битном формате.
После того как мы немного разобрались с разрядностью АЦП звуковой карты, пришло время поговорить о частоте дискретизации.
В процессе работы АЦП происходит не только квантование сигнала по уровню, но и его дискретизация во времени. Сигнал, непрерывно изменяющийся во времени, заменяют рядом отсчетов этого сигнала. Обычно отсчеты сигнала берутся через одинаковые промежутки времени. Интуитивно ясно, что если отсчеты отстоят друг от друга на слишком большие интервалы, то при дискретизации может произойти потеря информации: важные изменения сигнала могут быть "пропущены" преобразователем, если они произойдут не в те моменты, когда были взяты отсчеты. Получается, что отсчеты следует брать с максимальной частотой. Естественным пределом служит быстродействие преобразователя. Кроме того, чем больше отсчетов приходится на единицу времени, тем больший размер памяти необходим для хранения информации.
Проблема отыскания разумного компромисса между частотой взятия отсчетов сигнала и расходованием ресурсов трактов преобразования и передачи информации возникла задолго до того, как на свет появились первые звуковые карты. В результате исследований было сформулировано правило, которое принято называть теоремой Найквиста — Котельникова.
Если поставить перед собой задачу обойтись без формул и использования серьезных научных терминов типа "система ортогональных функций", то суть теоремы Найквиста — Котельникова можно объяснить следующим образом. Сигнал, представленный последовательностью дискретных отсчетов, можно вновь преобразовать в исходный (непрерывный) вид без потери информации только в том случае, если интервал межу соседними отсчетами не превышает половины периода самого высокочастотного колебания, содержащегося в спектре сигнала.
Из сказанного следует, что восстановить без искажений можно только сигнал, спектр которого ограничен некоторой частотой Fmax. Теоретически все реальные сигналы имеют бесконечные спектры. Спектры реальных сигналов, хотя и не бесконечны, но могут быть весьма широкими. Для того чтобы при дискретизации избежать искажений, вызванных этим обстоятельством, сигнал вначале пропускают через фильтр, подавляющий в нем все частоты, которые превышают заданное значение Fmax, и лишь затем производят дискретизацию. Согласно теореме Найквиста — Котельникова частота дискретизации, с которой следует брать отсчеты, составляет Fд = 2Fmax. Теорема получена для идеализированных условий. Если учесть реальные свойства сигналов и устройств преобразования, то частоту дискретизации следует выбирать с некоторым запасом по сравнению со значением, полученным из предыдущего выражения.
В стандарте CD Digital Audio частота дискретизации равна 44,1 кГц. Для цифровых звуковых магнитофонов (DAT) стандартная частота дискретизации составляет 48 кГц. Звуковые карты, как правило, способны работать в широком диапазоне частот дискретизации.
В последнее время становится все более популярным стандарт DVD-audio, где частота дискретизации может быть равной 44,1/48/88.2/96 кГц, разрешающая способность 16/20/24 бит, количество каналов — до 6.


1.4.2. Цифроаналоговое преобразование

Для воспроизведения звукового сигнала, записанного в цифровой форме, необходимо преобразовать его в аналоговый сигнал.
Цифроаналоговое преобразование в общем случае происходит в два этапа. На первом этапе из потока цифровых данных с помощью цифро-аналогового преобразователя выделяют отсчеты сигнала, следующие с частотой дискретизации. На втором этапе путем сглаживания (интерполяции) из дискретных отсчетов формируется непрерывный во времени аналоговый сигнал.
На выходе простейшего ЦАП сигнал представляет собой последовательность узких импульсов, имеющих многочисленные высокочастотные спектральные компоненты. На аналоговый фильтр в этом случае возлагается задача полностью пропустить сигнал нужного частотного диапазона (например, 20 Гц — 20 кГц) и по возможности наиболее полно подавить ненужные высокочастотные компоненты. К сожалению, аналоговому фильтру выполнить такие противоречивые требования не под силу. Поэтому цифровой сигнал сначала интерполируют, то есть вставляют дополнительные отсчеты, вычисленные по специальным алгоритмам, и тем самым резко увеличивают частоту дискретизации. При этом исходный спектр полезного сигнала не искажается, а сигнал оказывается дискретизированным на значительно более высокой частоте. Это приводит к тому, что побочные спектральные компоненты на выходе ЦАП далеко отстоят от частотных компонентов основного сигнала и, чтобы отфильтровать их, достаточно простого аналогового фильтра.
После первого этапа цифроаналогового преобразования информация о величине звукового сигнала имеется только в определенные моменты, соответствующие частоте дискретизации АЦП. Дополнительная информация о форме сигнала между отсчетами отсутствует. Задачей второго этапа цифро-аналогового преобразования является восстановление значения сигнала между отсчетами, или интерполяция.
Наибольшее распространение получили линейные методы интерполяции формы сигнала по его дискретным отсчетам, основанные на использовании цифровых фильтров. В исходную последовательность отсчетов сигнала вставляются дополнительные нулевые отсчеты. Новая полученная последовательность подается на интерполирующий цифровой фильтр, в котором нулевые отсчеты преобразуются в очень точно реконструированные отсчеты исходного сигнала. Затем для сглаживания и окончательного восстановления сигнал подается на простой аналоговый фильтр. Полученный в результате цифроаналогового преобразования звуковой сигнал, как правило, попадает в микшер звуковой карты.


1.4.3.0 некоторых проблемах, связанных с ЦАП/АЦП

Обычно шум квантования представляют как разность соответствующих значений реального и квантованного по уровню сигналов (рис. 1.8, а, б).
Такое представление не совсем верно.
На рис. 1.8, а на самом деле цифровой сигнал не показан. Ступенчатая линия — это отображение аналогового сигнала, восстановленного из цифрового с использованием интерполяции нулевого порядка. Если из исходного аналогового сигнала вычесть эту ступенчатую линию, то получится очень странная и некрасивая линия (рис. 1.8, б). Некоторые авторы пишут, что это и есть шум квантования. Но, во-первых, кто сказал, что нужно заменять цифровой сигнал непрерывными ступеньками, и почему именно ступеньками, а не наклонными отрезками прямых линий или кривыми? Во-вторых, в действительности мы имеем право сравнивать непрерывные и дискретные сигналы только в моменты, соответствующие дискретным отсчетам. Поэтому и шум квантования следует представлять последовательностью дискретных отсчетов (рис. 1.8, в).

Рис. 1.8. Иллюстрация процесса квантования сигнала (интерполяция нулевого порядка)

В теоретических работах для представления дискретных сигналов используют функцию отсчетов (дельта-функцию) — бесконечно большой по амплитуде и бесконечно короткий по времени импульс. Площадь дельта-функции равна единице. Разумеется, функции отсчетов в природе не существуют. На практике они заменяются прямоугольными импульсами малой длительности.
Если взять последовательность смещенных во времени функций отсчетов и умножить ее на ординаты кривой линии, соответствующей аналоговому сигналу, то получится дискретный по времени сигнал, который можно представить графически так, как показано на рис. 1.8, в. В данном случае это и есть шум квантования, представленный дискретными отсчетами.
Не существует и идеальных фильтров, с помощью которых можно было бы точь-в-точь восстановить аналоговый сигнал по его дискретным значениям. Однако в современных АЦП используются методы, позволяющие свести погрешности, обусловленные неидеальностью преобразования, к разумному минимуму.
На рис. 1.9, а показан исходный аналоговый сигнал и сигнал, восстановленный из цифрового с использованием интерполяции 1-го порядка (отсчеты соединяются отрезками прямых линий).
Видно, что разница между исходным и восстановленным сигналом (рис. 1.9, б) гораздо меньше, чем при использовании интерполяции нулевого порядка (рис. 1.8, а). А ведь в современных ЦАП используются гораздо более сложные алгоритмы восстановления аналогового сигнала.
Что касается цифрового шума квантования (рис. 1.8, в), бесспорно, при цифроаналоговом преобразовании он трансформируется в некий аналоговый шум. Вид этого шумового колебания будет зависеть от конкретного
АЦП, но его уровень будет гораздо меньше, чем уровень шумового процесса, показанного на рис. 1.8, б.
Распространенная среди сторонников аналогового звука страшилка "Результат дискретизации ужасно отличается от исходного сигнала" основана именно на неадекватном представлении шума квантования (рис. 1.8, б).

Рис. 1.10. Квантование сигнала по уровню и искажения при клиппировании сигнала

Из рис. 1.10 видно, что в случае превышения сигналом значения самого верхнего уровня квантования ("старшего" кванта), а также в случае, когда значение сигнала оказывается меньше нижнего уровня квантования ("младшего" кванта), т. е. при ограничении сигнала, возникают искажения. Они могут быть гораздо более заметными по сравнению с шумом квантования.
Для исключения искажений этого типа динамические диапазоны сигнала и АЦП должны соответствовать друг другу.
Следует упомянуть еще об одном заблуждении. Иногда им грешат даже профессиональные звукорежиссеры. Они утверждают примерно следующее: "Поведение восстановленного сигнала в промежутках между отсчетами не определено, он может изменяться произвольным образом". Однако, говоря так, они забывают о том, что спектр аналогового сигнала, подвергающегося цифроаналоговому преобразованию, обязательно должен быть ограничен. Поэтому при аналого-цифровом преобразовании его значения между дискретными отсчетами не могут быть произвольными и поддаются однозначному восстановлению по этим отсчетам.
Довольно часто изготовители, доказывая преимущество своих звуковых карт, подчеркивают такое обстоятельство, как наличие у звуковой карты цифрового входа и/или выхода. Действительно, если звуковая карта имеет выход, на который сигналы поступают не в аналоговой (после ЦАП), а в цифровой форме, это позволяет уменьшить искажения, связанные с дополнительными преобразованиями при дальнейшей цифровой обработке сигнала вне звуковой карты.
В соответствии с концепцией виртуальной студии звукозаписи вся обработка должна выполняться средствами одного PC. С помощью этого же PC можно получить и конечный продукт — компакт-диск. ЦАП высокого качества нужен только лишь для мониторинга, т. е. для того, чтобы слышать происходящее в виртуальной студии. Наличие цифрового выхода в виртуальной студии дает преимущества только тогда, когда требуется выполнить запись на DAT или подключить высококачественные акустические мониторы, снабженные цифровым входом.
Наличие цифрового входа в виртуальной студии может быть актуальным в том случае, если вас не устраивает качество работы встроенного в звуковую карту АЦП и вы хотите использовать более качественный внешний АЦП. Кроме этого, цифровой вход может быть полезен, если требуется "перегнать" запись с DAT в PC.
Шум квантования. Как с ним бороться? Если для представления звука использовать 24- или 32-битные отсчеты, то о шуме квантования можно забыть (так он слаб). Да вот беда — основным потребительским аудиоформатом является формат компакт-дисков: 16 бит/44,1 кГц/стерео. Поэтому разрядность представления звуковых данных приходится понижать. Даже при 16-битном разрешении звука шум квантования неуловимо мал, тем не менее, он обладает одной пренеприятнейшей особенностью: этот шум коррелирован с полезным сигналом. Именно шум квантования принимает самое активное участие в формировании негативного образа цифрового звука в умах людей — он плоский, металлический, пластмассовый и т. п. Как только раньше ни называли 16-битный звук! Так было до появления специальных методов обработки цифрового звука, называемых дитерингом (dithering) и нойзшейшнгом (noise shaping). Суть дитеринга состоит в том, что до понижения разрядности к полезному сигналу подмешивается очень слабый специфичный шум. В результате шум квантования попросту забивается этим шумом, который в силу своих статистических свойств гораздо меньше действует на психику человека. Конечно, в результате получается более шумная запись, но шум этот, как и шум квантования, практически неуловим на слух.
Еще один метод борьбы с шумом квантования, нойзшейпинг, заключается в применении специальных алгоритмов округления значений звуковых отсчетов при понижении разрядности. После применения нойзшейпинга большая часть энергии шума квантования сосредоточена в области высоких частот, к которым человеческий слуховой аппарат наименее восприимчив. Обычно нойзшейпинг применяется совместно с дитерингом..
Есть еще комплекс проблем: транкейт (от truncate — усечь) — то, что раньше мы называли понижением разрядности цифрового звука. Был сигнал 24-битным, стал 16-битным — произошел транкейт. С одной стороны, понижение разрядности цифрового звука дело обычное. Стоило ли вводить специальный термин? Однако термином truncate обозначают целый комплекс проблем, возникающих при работе с цифровым звуком, разрядность которого больше 16. Прежде всего, это неконтролируемое вами понижение разрядности (оно происходит втайне от вас или вы просто не обратили на него внимания). Допустим, сигнал проходит через три соединенных последовательно цифровых устройства обработки звука. Пусть для их соединения используется интерфейс S/PDIF. Внешне все кажется нормально: три красивых прибора соединены стандартными кабелями, все работает. Что еще нужно? Но кто-то из людей, коммутирующих эти устройства между собой, не разобрался в том, что только первый и последний приборы данной цепочки 24-битные, а средний 16-битный. Эти приборы легко нашли между собой язык: каждый из 24-битных приборов при установлении связи по S/PDIF выяснил, что подключен к 16-битному устройству и переключился в соответствующий режим. В результате при передаче сигнала от первого устройства ко второму произошел транкейт, причем персонал студии этого даже и не заметил. А как вы уже знаете, шум квантования 16-битного сигнала — вещь не очень приятная. Если в процессе обработки фонограммы транкейт происходит неоднократно, то качество звучания будет постепенно понижаться.
Вы скажете, что у вас нет своей цифровой студии с оборудованием стоимостью в десятки тысяч долларов. Но проблема транкейта может подстерегать вас и в персональной студии звукозаписи на базе PC. Обработали свой 24-битный WAV-файл 16-битным plug-in-модулем реверберации — вот вам и транкейт.
Единственный способ борьбы со случайным транкейтом — внимательно читайте инструкции, поставляемые с оборудованием. Что же касается программ, plug-in-модулей в частности, то для контроля за ними существуют специальные утилиты.


1.5. Методы синтеза звуков. Синтезаторы и сэмплеры

Начало относительно широкого использования возможностей электротехники (а в дальнейшем и электроники) в музыке относится к середине 30-х годов XX века. В этот период Л. Хаммонд запатентовал электрический орган, представлявший собой набор электромеханических генераторов, каждый из которых вырабатывал колебания с частотой, соответствующей частоте одной из нот. Для исполнителя же, в конечном счете, самым важным в этом инструменте было то, что управление органом Хаммонда осуществлялось с помощью привычной органной клавиатуры. В те времена от такого электрического инструмента требовалось, в основном, чтобы его звучание было максимально похоже на звучание старшего брата — духового органа.


1.5.1. Синтезаторы

В процессе бурного развития электроники совершенствовались методы и устройства генерации и обработки звуковых колебаний в электронных органах и в подобных им электронных музыкальных инструментах. Все больше внимания уделялось вопросам темброобразования как для более точной имитации звучания традиционных инструментов, так и в целях получения новых, необычных тембров. Основным методом темброобразования оставался аддитивный (от английского "additive") метод, применявшийся еще в органе Хаммонда. Этот метод заключается в том, что результирующий тембр формируется путем сложения нескольких исходных колебаний.
При использовании в качестве исходных колебаний синусоидальных сигналов с кратными (отличающимися в целое число раз) частотами и регулируемыми амплитудами отдельных составляющих можно получить большое количество самых разнообразных тембров. Такая разновидность аддитивного метода называется гармоническим синтезом тембра.
Другой разновидностью аддитивного метода является регистровый синтез. В этом случае в качестве исходных используют колебания более сложной формы, например, пилообразные или прямоугольные.
И в том, и в другом случаях для точного воспроизведения звучания заданного музыкального инструмента требуется очень большое (теоретически бесконечно большое) число исходных колебаний. Чем меньше исходных колебаний, тем сильнее отличается синтезированный звук от звучания имитируемого инструмента. На практике оказывается, что даже при полутора-двух десятках исходных колебаний звучание синтезатора лишь в основном напоминает то, что хотелось получить. И здесь, как это часто случается, на помощь технике приходит сам человек. Наша психика устроена так, что если нами будут опознаны хоть какие-нибудь характерные признаки знакомого музыкального инструмента, то в сознании произойдет подмена фактического звучания на воображаемое и на проявляющиеся в дальнейшем огрехи имитации реагировать мы будем значительно слабее, чем они того заслуживают.
Но (даже с учетом этого нашего замечательного свойства) проблема формирования большого числа исходных сигналов остается актуальной. Ее решение значительно упростилось с появлением и развитием цифровых устройств, работающих с сигналами, имеющими прямоугольную форму. Реализация этих устройств в виде интегральных микросхем практически сняла ограничение на количество исходных сигналов. А потом наступило время, когда гармонический синтез, реализуемый довольно громоздкими и дорогостоящими устройствами, не выдержал конкуренции со стороны регистрового синтеза и был вытеснен последним.
Наряду с рассмотренным аддитивным методом, в синтезаторах широко применяется и субтрактивный метод (от английского "subtractive" — вычитание). Сущность этого метода заключается в том, что новый тембр создается путем изменения соотношений между отдельными составляющими в спектре первоначального колебания. Реализуется этот метод как бы в два этапа. Сначала формируются колебания, основные частоты которых соответствуют частотам нот. Главное требование к первоначальному колебанию сводится к тому, что оно должно иметь как можно более богато развитый тембр (иметь большое количество спектральных составляющих). На втором этапе с помощью частотных фильтров из первоначального колебания выделяют частотные составляющие, характерные для имитируемого музыкального инструмента. Этот метод также удобно реализовать на базе быстродействующих цифровых интегральных микросхем. В теории сигналов давно доказано (и экспериментально подтверждено), что спектр импульсной последовательности тем шире, чем короче каждый импульс. Поэтому первоначальными сигналами могут служить последовательности коротких прямоугольных импульсов.
Таким образом, при синтезе звуков в электронных музыкальных инструментах аддитивный и субтрактивный методы мирно уживаются и дополняют друг друга.
Развитие электронных музыкальных инструментов стимулировало создание электронных музыкальных синтезаторов. В синтезаторах, с одной стороны, нашли свое дальнейшее развитие ранее применявшиеся методы синтеза звука, с другой стороны, были внедрены и принципиально новые методы. Однако не это составляет основное отличие синтезаторов. Главное заключается в том, что за счет использования микропроцессоров для управления синтезом звуков в них имеется возможность быстрого и очень просто выполняемого перехода от одного имитируемого (или синтезируемого) инструмента к другому. И еще одно отличие: за счет применения запоминающих устройств большого объема имеется возможность хранения и постоянного дополнения гигантского количества алгоритмов синтеза звуков. Переход от одного синтезируемого инструмента к другому происходит за время, значительно меньшее, чем длительность самой короткой ноты. На практике это означает, что, в принципе, каждую очередную ноту синтезатор может сыграть другим тембром (инструментом). Кроме того, в состав синтезатора входят несколько идентичных блоков синтеза, поэтому и одновременно взятые ноты могут быть исполнены как бы различными музыкальными инструментами.
Не сразу синтезаторы стали такими совершенными. Первые электронные синтезаторы звуков скорее представляли собой специализированные, причем аналоговые, а не цифровые, вычислительные машины. Из-за сложности и недостаточной оперативности управления они были предназначены, в основном, не для исполнительских целей, а для экспериментов, проводимых в интересах совершенствования электронных музыкальных инструментов, создания звуковых эффектов для озвучивания кинофильмов и исследований в области электроакустики.
Развитие технологии аналоговых интегральных микросхем позволило со временем реализовать отработанные методы синтеза в сравнительно доступных как в отношении управляемости, так и в отношении стоимости исполнительских инструментах. Приоритет в этой области принадлежит Р. Мугу, выпустившему в 1964 году первый такой синтезатор. Его основой стал генератор, управляемый напряжением, который способен формировать сигналы прямоугольной, пилообразной и синусоидальной формы. Различные варианты соединения таких генераторов и сложения их выходных сигналов позволили получить обширную палитру новых "электронных" звуков. Такой метод синтеза получил название: "FM-аддитивный метод". Метод основан на частотной модуляции: изменении частоты сигнала в соответствии с законом изменения некоторого управляющего напряжения. Со временем было накоплено большое количество таких алгоритмов управления частотами генераторов Муга, которые представляли ценность в музыкальном отношении, и поэтому закладывались в блоки управления новых синтезаторов.
В результате развития цифровой техники произошел естественный переход от аналоговых к цифровым формирователям колебаний, способным генерировать сигналы произвольной формы. Сами формирователи могут быть реализованы как аппаратно, так и программно, а форма генерируемого сигнала в виде цифрового алгоритма управления формирователями хранится в запоминающем устройстве. Возможность использования большого числа формирователей (порядка нескольких десятков), которые имеют независимое управление частотой колебаний и огибающей амплитуды (размаха колебаний) сигналов, для синтеза каждого голоса музыкального инструмента позволила говорить о переходе на качественно новый по сравнению с аналоговыми синтезаторами уровень. Описанный принцип синтеза звуков с некоторыми модернизациями применяется и в синтезаторах звуковых карт. Кроме того, синтезаторы большей части звуковых карт устроены проще и, в связи с этим, обладают меньшими возможностями по сравнению с "начинкой" электронных музыкальных синтезаторов.
Итак, при FM-методе синтез звука с необходимым тембром производится на основе использования нескольких генераторов звуковых частот при их взаимной модуляции. Совокупность генератора и схемы, управляющей этим генератором, принято называть оператором. Схема соединения операторов и параметры каждого оператора (частота, амплитуда и закон их изменения во времени) определяют тембр звучания. Количество операторов определяет максимальное число синтезируемых тембров. В звуковых картах используется как двухоператорный, так и четырехоператорный синтез. Виртуальные синтезаторы позволяют реализовать значительно более сложные алгоритмы синтеза.
В операторе следует выделять два структурных элемента: частотный модулятор и генератор огибающей. Частотный модулятор определяет высоту тона, а генератор огибающей определяет относительно медленное изменение амплитуды колебания во времени и, тем самым, тембр звука. Звуковые колебания, формируемые различными музыкальными инструментами, имеют различные огибающие. Однако любую огибающую можно условно расчленить на несколько характерных фаз, которые принято называть: attack (атака), decay (спад), sustain (поддержка), release (освобождение). Пояснением сказанного служит рис. 1.11.
Например, при нажатии на клавишу фортепиано, действительно, сначала амплитуда колебаний быстро возрастает до максимального значения, затем несколько спадает, потом в течение некоторого времени остается практически постоянной и, наконец, колебания медленно затухают.
В более совершенных синтезаторах элементарный процесс извлечения звука состоит не из четырех, а из шести фаз (рис. 1.12). Это позволяет получить большее сходство синтезируемого звучания и его естественного образца.
Неоспоримое достоинство FM-синтеза состоит в том, что на его основе можно получить несчетное количество "электронных" тембров. Немаловажно также то обстоятельство, что не требуется заранее записывать и хранить в памяти синтезируемые звуки. Достаточно хранить алгоритм их синтеза.

Рис. 1.11. Четыре фазы огибающей сигнала

Рис. 1.12. Шесть фаз огибающей сигнала

Метод частотно-модуляционного синтеза развивается и широко используется. Накоплено большое количество алгоритмов синтеза оригинальных звучаний. В принципе, как мы уже и говорили, для этого метода нет невозможного.
Вопрос заключается только в том, ценой каких аппаратурных затрат достигается желаемый результат. Но, в соответствии с законами развития, сильная сторона метода со временем превратилась в свою противоположность. Сила метода состоит в том, что любой звук может быть получен модуляцией частоты генератора. Слабость метода заключается в том, что для синтеза любого звучания используется только генератор и только его частотная модуляция, причем процесс синтеза во времени совмещен с процессом исполнения музыки. Почти одно и то же заключено в этих двух фразах — да не совсем. Выходит, что возможности синтеза ограничиваются не только сложностью аппаратурной реализации, но и сложностью алгоритма управления синтезатором в реальном времени. Поясним эту мысль. Для точного воспроизведения звучания какого-то традиционного музыкального инструмента, во-первых, требуется значительное число модулируемых генераторов. Во-вторых, управлять их частотой следует по очень сложному алгоритму, ибо только таковой в состоянии учесть малейшие оттенки звучания, присущие именно данному инструменту. Например, концертный рояль воспроизводит около 4,5 тысяч различимых на слух тембров. Алгоритм должен успевать считываться, вычисляться и передаваться, словом, выполняться компьютером. А генераторы должны успевать его отрабатывать. Поэтому качество синтеза ограничивается также и быстродействием компьютера.
Технические возможности микропроцессорной системы управления не в такой степени сказывались бы на качестве звука, если бы его синтез производился не в реальном времени, а заранее, если бы результаты синтеза сохранялись и использовались при исполнении музыки. Правда, тогда пришлось бы отказаться и от привычного FM-синтезатора. Так оно, в общем, и произошло.


1.5.2. Сэмплеры

В конце семидесятых годов прошлого века был создан цифровой музыкальный инструмент, в котором реализован принципиально иной подход к синтезу музыки, получивший название "sampling". Буквально это слово означает отбор образцов. Суть этого способа состоит в том, что для синтеза звука используются сгенерированные не в реальном времени, а заранее фрагменты, хранящиеся в памяти инструмента. В частности (и чаще всего), эти фрагменты могут быть получены путем записи в цифровой форме натуральных звуков. Синтезаторы, в которых воплощен такой принцип, называются сэмплерами, а образцы звучания — сэмплами. Процесс записи сэмплов принято называть оцифровкой или сэмплированием. В целях экономии необходимой памяти сэмплы могут храниться в виде нескольких фрагментов: фрагмента начала звука, фрагмента стационарной фазы и фрагмента завершения звука. Фазы начала и завершения звука (вспомним рис. 1.11) при исполнении воспроизводятся без изменений, а стационарная фаза "зацикливается" на время нажатия клавиши.
Конечно же, сэмплы, записанные с помощью микрофонов, расположенных, например, вблизи рояля, до того, как оказаться в памяти синтезатора, подвергаются нескольким процедурам обработки. Запись очищают от посторонних звуков, подчеркивают стереоэффект и производят частотную коррекцию. В принципе существуют и аппаратура, и программное обеспечение, позволяющие отредактировать заготовку сэмпла, а то и вовсе сконструировать звучание по своему усмотрению.
Для одного и того же инструмента могут быть записаны сэмплы, относящиеся к различным приемам игры и соответствующие различной динамике звукоизвлечения, например: игра на рояле с использованием педали — и без нее, сильный удар по клавише — и мягкое касание. При воспроизведении различные динамические оттенки исполнения получают комбинированием этих сэмплов в различной пропорции.
У рассматриваемого метода есть еще и другое название — волновой синтез. Закодированные наборы образцов хранимых звуков называют волновыми таблицами (Wave Table). О звуковых картах, реализующих рассматриваемый метод синтеза, говорят, что они поддерживают режим Wave Table (WT).
Одна из основных проблем волнового синтеза состоит в том, что для хранения голосов инструментов требуется запоминающее устройство очень большого объема. Если бы задача решалась "в лоб", т. е. запоминалось бы звучание каждой ноты инструмента, то проблема, скорее всего, и по сей день оставалась бы неразрешимой. Значительного сокращения необходимой памяти достигают за счет того, что запоминается звучание немногих нот (в пределе — одной). Формирование звучания остальных нот происходит путем изменения скорости воспроизведения сэмпла в той степени, каково отношение частоты извлекаемой ноты к частоте ноты, хранящейся в памяти.
Как с помощью одного музыкального тона синтезатор получает другой? Допустим, исходный сэмпл оцифрован на частоте 44,1 кГц. Теперь, если мы будем воспроизводить его на удвоенной частоте дискретизации 88,2 кГц, т. е. вдвое быстрее, высота звука возрастет на октаву. Если же воспроизводить сигнал на пониженной частоте дискретизации, то высота звука соответственно уменьшится. Таким образом, если воспроизводить сэмпл на измененной соответствующим образом частоте дискретизации, в принципе можно получить звук любой высоты.
Однако такой подход содержит неприятный момент. Одновременно со смещением величины тактовой частоты и высоты звука будет изменяться длительность атаки и скорость затухания сигнала. Так, если мы удвоим тактовую частоту, то наряду с удвоением высоты звука в два раза уменьшится общее время звучания сигнала (так как он будет проигрываться в два раза быстрее). Отсюда вдвое сократится длительность атаки, и вдвое возрастет скорость затухания звука. Это вызовет искажение общего впечатления о звуке. Тембр воспроизводимого сигнала заденут и более серьезные изменения.
В реальном музыкальном инструменте при изменении высоты звука форма амплитудно-частотной характеристики (АЧХ) излучающих звук поверхностей, местоположение на оси частот, величина ее максимумов и провалов механических и акустических резонансов обычно не изменяются. А вот при изменении скорости воспроизведения оцифрованного сигнала вместе с частотой основного тона изменится и форма АЧХ (растянется или сожмется, максимумы и минимумы сместятся по оси частот). Конечно, это сильно исказит звук. Кроме того, в некоторых музыкальных инструментах (пианино, гитара и т. д.) звуки разной частоты формируются с помощью различающихся механически элементов конструкции (струны с оплеткой и без нее; несколько струн, настроенных в унисон). В этом случае звук, полученный с помощью удвоения скорости воспроизведения оцифрованного сигнала, может изначально не соответствовать реальному на октаву более высокому звуку.
Поэтому в WT-синтезаторах применяется несколько другой способ изменения высоты звука. Оцифровывается несколько разных по высоте сигналов (сэмплов) реального музыкального инструмента, перекрывающих весь его частотный диапазон. Шаг по частоте должен быть достаточно мал, чтобы изменения тембра, связанные с конструктивными особенностями инструмента, при смещении частоты основного тона с помощью варьирования частоты дискретизации не были заметны на слух.
В недорогих устройствах считается достаточной оцифровка через половину октавы. При генерации звука определенной высоты WT-синтезатор определяет, в каком частотном диапазоне находится звук, и использует соответствующие сэмплы из своей таблицы, корректируя их частоту основного тона точно до требуемой высоты, виртуально подстраивая частоту дискретизации. Под виртуальностью подразумевается следующее. Частота дискретизации выходного сигнала жестко стабилизирована кварцевым генератором (например, 44,1 кГц). Звук музыкального инструмента также дискредитирован на частоте 44,1 кГц. Для изменения высоты тона надо выбирать отсчеты сигнала из таблицы с частотой, немного отличной от 44,1 кГц, а подавать на ЦАП с частотой, точно равной 44,1 кГц. Это полностью аналогично изменению частоты дискретизации данных и, естественно, будет восприниматься слухом как изменение высоты основного тона сигнала.
Кроме того, синтез звучания некоторых музыкальных инструментов становится более реалистичным и выразительным при одновременном воспроизведении нескольких сэмплов. То есть звук инструмента может генерироваться WT-синтезатором путем наложения звучания нескольких сэмплов.
С помощью специальных программ-редакторов можно изменить (подкор-ректировать) содержание любого произвольного слоя, изменяя форму волны, высоту тона сэмпла, включить использование обычных или управляемых генераторами фильтров и т. д. Таким образом можно добиться самого необычного звучания.
Поскольку качество звучания звуковой карты с WT-синтезатором напрямую зависит от качества звучания образцов инструментов, хранящихся в памяти карты, желательно иметь сэмплы высокого качества (с высоким разрешением записи), что в свою очередь приводит к росту объема банка инструментов.
Для гипотетического устройства, имеющего диапазон частот генерируемого звука в пять октав, при оцифровке через интервал в один тон по высоте с частотой дискретизации 48 кГц и разрядностью данных 24 бита понадобится около 7 Мбайт 1-секундных отрезков сигнала реального музыкального инструмента. Однако WT-синтезаторы некоторых звуковых карт имеют меньший объем памяти, хотя могут имитировать более ста инструментов. Достигается это несколькими методами. Звук оцифровывается с большим шагом по частоте основного тона и подвергается различным видам компрессии. В таблице хранятся отрезки сигнала значительно меньшей по времени длины, чем одна секунда. При этом для синтеза длительных нот применяется зацикливание (многократное повторное воспроизведение отрезка сигнала). Отрезок как бы превращается в кольцо. Естественно, для гладкого, без щелчков на стыке кольца требуется специальная обработка отрезка сигнала. Он должен содержать целое число периодов основного тона, а отсчеты около стыка должны быть обработаны специальной сглаживающей программой.
Патчи для инструментов с малой длительностью звучания (ударных) обычно записываются полностью, а для остальных может записываться лишь начало, конец звука и небольшая "средняя" часть, которая затем проигрывается в цикле в течение нужного времени.
В процессе воспроизведения звука специальный процессор выполняет операции над патчами, изменяя их амплитуду, частоту и таким образом формируя звук требуемой громкости, полностью соответствующий необходимому тембру.
Безусловным достоинством синтеза на основе таблицы волн является предельная реалистичность звучания классических инструментов и простота получения звука.
Основой "голоса" WT-синтезатора является цифровой звук. В этом и заключается самое главное отличие WT- от FM-синтезаторов, у которых "голосовыми связками" являются генераторы аналоговых колебаний строго определенных форм. В принципе, используя FM-синтез, можно получить очень большое количество тембров. Однако на основе одной и той же волновой формы при использовании WT-синтезатора можно получить еще большее количество тембров (а ведь количество сэмплов ограничивается только объемом памяти). Все дело в том, что WT-синтезатор — это не просто "маленький цифровой магнитофончик", который может в цикле и с разной скоростью (а значит и в различной тональности) воспроизводить свою фонограмму — сэмпл. Кроме этого он может проделывать самые разные операции над генерируемым звуком: пропускать его через резонансный фильтр,
модулировать его как по амплитуде, так и по частоте, накладывать различные эффекты...
Для того чтобы в дальнейшем понимать смысл действий по редактированию музыки, необходимо познакомиться с архитектурой звукового элемента типичного синтезатора. Звуковой элемент — это некоторый аппаратным путем реализованный блок полифонического синтезатора, который воспроизводит звучание только одного голоса. Слово "полифонический" означает, что у синтезатора таких блоков много и каждый из них в определенный момент времени занимается генерацией только одного звука. Когда вы берете аккорд на MIDI-клавиатуре, не подозревая того, вы запускаете в работу столько звуковых элементов, сколько нот в аккорде, а в некоторых случаях и больше. Вариант структурной схемы типичного звукового элемента показан на рис. 1.13.

Рис. 1.13. Структурная схема типичного звукового элемента

Сразу отметим, что все преобразования над сэмплом происходят в цифровом виде. Какие же именно преобразования претерпевает сэмпл, прежде чем попасть на выход синтезатора?
Сердце звукового элемента — осциллятор (oscillator) — тот самый воображаемый цифровой магнитофончик, о котором мы говорили совсем недавно.
Это устройство воспроизводит сэмпл с заданной скоростью. Скорость воспроизведения зависит от номера нажатой MIDI-клавиши. Кроме того, этот "магнитофончик" может воспроизводить звук в цикле: "докрутил" звук до отметки конца цикла и быстро перескочил к метке начала цикла (и так — по кругу). А можно сделать так, чтобы, как только вы отпускаете MIDI-клавишу, "магнитофончик" выходил из цикла и начинал воспроизводить все фазы сэмпла подряд, пока сэмпл не закончится.
С осциллятора цифровая информация о звуке попадает на резонансный НЧ-фильтр (Resonant Low Pass Filter), с помощью которого можно изменять спектр сэмпла, получая при этом очень интересные эффекты, например, эффект, называемый "Wah-wah" ("Вау-вау"). Частотная характеристика фильтра определяется двумя параметрами: частотой среза (Filter Cutoff) и коэффициентом усиления фильтра на частоте среза (Resonance). Последний из параметров часто обозначается как Filter Q.
После фильтра звук попадает на усилитель (Amplifier), где ему придается заданная в пространстве "громкость-время" форма — амплитудная огибающая.
Теперь звук почти готов к употреблению. Остается пропустить его некоторую часть через эффект-процессор (Effects Engine), чтобы реализовать эффекты реверберации и хоруса (Reverb, Chorus). Наверное, требуется пояснить, что значит "некоторая часть звука". Звуковой сигнал следует двумя путями: первый путь ведет сразу в обход эффект-процессора, а второй — через эффект-процессор. На первом пути звук не претерпевает никаких изменений. Проходя же по второму пути, звук, например, полностью превращается в свое эхо. Затем эти пути вновь сходятся: исходный звук смешивается со своим эхом. Очевидно, что регулировать глубину эффектов можно, изменяя уровень сигнала, следующего вторым путем.
Теперь звук полностью готов к употреблению и поступает на ЦАП синтезатора, а затем или на микшер звуковой карты, или непосредственно на цифровой выход в стандарте S/PDIF, если таковой имеется у данной звуковой карты.
Кроме рассмотренных блоков, в которых происходит генерация и преобразование звукового сигнала, обычно существуют еще вспомогательные генераторы, создающие низкочастотные колебания (Low Frequency Oscillator). На схеме в качестве примера показаны два таких генератора: LFO1 и LFO2. Низкочастотные колебания требуются для реализации эффектов частотной (частотное вибрато) и амплитудной (амплитудное вибрато, тремоло) модуляции, а также тембрового вибрато (эффекта "Вау-вау"). Для каждого из генераторов регулируется два параметра: Delay — задержка начала низкочастотной генерации от момента начала звучания сэмпла, Freq — частота колебаний.
Генераторы огибающих Pitch/Filter и Volume Envelope Modulation предназначены для управления высотой тона (Pitch), параметрами фильтра (Filter) и громкостью (Volume) непосредственно в процессе воспроизведения сэмпла.
В отличие от традиционного четырехфазного представления звуков ADSR (аббревиатура от Attack, Decay, Sustain, Release) в рассматриваемом гипотетическом синтезаторе звук делится на шесть фаз (DAHDSR): Delay (задержка), Attack (атака), Hold (удержание), Decay (спад), Sustain (поддержка) и Release (освобождение). Именно по этой причине на блоке Envelope Parameters (параметры огибающей) изображено шесть регуляторов, каждый из которых символизирует возможность управления определенной фазой звука. Перечисленные фазы показаны на рис. 1.12.
Кроме основных блоков, на структурной схеме символически показаны манипуляторы (ручки, при помощи которых можно регулировать тот или иной параметр звукового элемента). Конечно же, никаких ручек физически не существует, все настройки — это числа, которые хранятся в памяти драйвера, обслуживающего синтезатор.
Треугольниками обозначены модуляторы. Для того чтобы вы лучше поняли их назначение, приведем пример из повседневной жизни. Все пользуются водопроводным краном. В кране течет вода. Интенсивность ее протекания (если можно так выразится) характеризуется положением ручки крана. А теперь проведем аналогию между водопроводным краном и модулятором в схеме синтезатора: кран — модулятор, вода — исходный сигнал (например, низкочастотные колебания от LFO1), ручка — модулирующий сигнал (например, LFO1 to Pitch), положение ручки — параметр регулировки, т. е. просто число, характеризующее глубину модуляции (в нашем примере речь идет о частотной модуляции — частотном вибрато).
Сэмплирование — это запись образцов звучания (сэмплов) того или иного реального музыкального инструмента. Сэмплирование является основой волнового синтеза музыкальных звуков. Вы уже знаете, что аппаратные или программные устройства, использующие этот метод синтеза, называются сэмплерами.
Если при частотно-модуляционном синтезе (FM-синтезе) новые звучания получают за счет разнообразной обработки простейших стандартных колебаний, то основой волнового синтеза являются заранее записанные звуки традиционных музыкальных инструментов или звуки, сопровождающие различные процессы в природе и технике. С сэмплами можно делать все, что угодно. Можно оставить их такими, как есть, и сэмплер будет звучать голосами, почти неотличимыми от голосов инструментов-первоисточников. Можно подвергнуть сэмплы модуляции, фильтрации, воздействию эффектов и получить самые фантастические, неземные звуки.
В принципе, сэмпл — это не что иное, как сохраненная в памяти синтезатора последовательность цифровых отсчетов, получившихся в результате ана-лого-цифрового преобразования звука музыкального инструмента.
Технология, которая позволяет "привязывать" сэмплы к отдельным клавишам или к группам клавиш MIDI-клавиатуры, называется мультисэмплингом (Multi-Sampling). Суть данной технологии можно пояснить графически так, как это сделано на рис. 1.14, а.

Рис. 1.14. Примеры использования технологий мультисэмплинга и многослойности

У реальных инструментов тембр зависит от высоты звука. Спектральная характеристика звука изменяет свою форму в зависимости от частоты. Например, у фортепиано тембр звука каждой из клавиш будет хоть немного, но все-таки отличаться даже от своих ближайших клавиш-соседей, не говоря уже о клавишах, расположенных предельно далеко друг от друга — в начале и в конце клавиатуры. Если бы не существовала проблема экономии памяти, то можно записать звучание музыкального инструмента для каждой ноты, а полученные сэмплы привязать к каждой из клавиш MIDI-клавиатуры. Но в этом случае для размещения звукового банка потребуется значительный объем памяти. В принципе, такой подход может быть реализован в программном сэмплере Gigastudio. Собственно, отсюда и происходит приставка Giga- в названии программы: банки сэмплов могут занимать гигабайты. Однако это не всегда оправданно, поэтому в памяти обычно хранятся сэмплы не для каждой ноты, а лишь для некоторых. В этом случае изменение высоты звучания достигается путем изменения скорости воспроизведения сэмпла. Группы клавиш, для которых записываются сэмплы, выбираются так, чтобы в пределах каждой из них вариации тембра звучания реального инструмента были бы не заметны на слух. Это позволяет существенно снизить затраты памяти и в то же время получить вполне качественный, близкий к живому звук.
Для получения разных нот сэмплы воспроизводятся с разной скоростью, при этом изменяется их длина (время звучания сэмпла или период его циклического воспроизведения). Нота, соответствующая воспроизведению сэмпла со штатной скоростью (когда частота дискретизации при его воспроизведении такая же, как была при записи), называется базовой нотой.
Если использовать малое количество сэмплов, распределенных по MIDI-клавиатуре, то эффект изменения длительности сэмплов будет слишком заметен. Кроме того, при воспроизведении сэмпла со скоростью, существенно ниже той, на которой он был записан, из него пропадают высокочастотные составляющие, присутствующие в тембре любого (даже басового) инструмента.
Приведем простой пример. Пусть изначально сэмпл был записан для ноты до пятой MIDI-октавы (при нумерации октав, начиная с нулевой) с частотой дискретизации 44,1 кГц. Это значит, что для этой ноты спектр звука потенциально может простираться до 44,1/2 = 22,05 кГц (по теореме Найкви-ста — Котельникова). Для того чтобы получить ноту до четвертой октавы, синтезатор должен воспроизводить этот сэмпл со скоростью в два раза ниже той, на которой он был записан, то есть с частотой дискретизации 22,05 кГц. По теореме Найквиста — Котельникова: 22,05/2 = 11,025 кГц — максимальная частота звукового сигнала. Это значит, что в спектре сигнала область частотного диапазона размером 11,025 кГц будет, отсутствовать, т. е. спектр звука будет ограничен в области высоких частот значением 11,025 кГц.
Чтобы свести эти неприятные эффекты к минимуму, достаточно распределения двух-трех сэмплов на октаву.
В домашних условиях попытка создать свой собственный качественный инструмент, например, записать звучание акустической гитары, вряд ли увенчается успехом. Для таких целей нужна лаборатория, оснащенная специальным оборудованием. Поэтому в качестве "стандартных" инструментов все-таки лучше использовать звуковые банки, созданные специалистами.
Существует еще одна важная особенность мультисэмплинга. Связав сэмплы различных инструментов с различными группами клавиш, можно получить одновременно несколько инструментов на одной MIDI-клавиатуре, например, для левой руки — контрабас, для правой — флейту. Это значит, что вы можете управлять по одному MIDI-каналу несколькими инструментами одновременно. Правда, при этом сузятся диапазоны звучания этих инструментов, ведь MIDI-клавиш всего 128. Но этого должно хватить. Тем более что для управления компьютерными аналогами "живых" инструментов, такими как, например, фортепиано, используется далеко не все 128 MIDI-клавиш.
Музыкальные инструменты (условные контрабас и флейту) можно заменить на спецэффекты, например на различные фразы, произнесенные человеком, звуки различных природных и технических объектов.
Еще одно понятие, связанное с сэмплерами, — многослойность (Multi-Layering) — технология, позволяющая воспроизводить одновременно несколько сэмплов для озвучивания одного инструмента. Как видно на рис. 1.14, б, в данном случае "слои" — это сэмплы, которые расположены как бы друг над другом.
Поговорим о том, как можно использовать данную технологию. Первое, что приходит на ум, — это возможность создания сложных, изменяющихся во времени тембров. Многослойность можно применять для создания стереофонических инструментов для тех сэмплеров, которые не поддерживают стереофонические сэмплы. С помощью многослойности обойти это ограничение просто. Если у вас имеется WAV-файл в формате 16 бит/стерео, то достаточно разделить каждый файл на два сэмпла 16 бит/моно и задействовать эти сэмплы в одном инструменте. Теперь остается только развести сэмплы в разные стороны панорамы: сэмпл, который раньше соответствовал левому каналу стереофонического WAV-файла, — в предельно левое положение, а сэмпл, соответствующий правому каналу, — в предельно правое. Кроме того, многослойность используется обычно для более точной передачи особенностей звучания живых инструментов в зависимости от силы нажатий на клавиши. Нажали клавишу с одной силой — звучит один сэмпл. Если нажать эту же клавишу с другой силой — зазвучит другой. Пример одновременного использования технологий мультисэмплинга и многослойности приведен на рис. 1.14, в.
Как уже говорилось, в сэмплерах для изменения высоты тона воспроизводимых сэмплов изменяется скорость их воспроизведения. Вроде бы все просто и понятно. Но на практике реализовать это очень сложно. Допустим, полифония сэмплера составляет 64 голоса — одновременно могут воспроизводиться 64 сэмпла. При этом каждый из них может воспроизводиться на своей скорости. Но на выходе сэмплера должен быть один поток звуковых данных, с одной фиксированной частотой дискретизации. Как объединить все сэмплы, которые должны воспроизводиться с разными скоростями, в один цифровой поток? Об этом вы можете прочитать в книге [12]. Как вы уже поняли, сэмплер — устройство достаточно сложное. Современные сэмплеры по своей сути являются неким гибридом синтезатора и многоканального цифрового магнитофона, который может воспроизводить сэмплы с разными скоростями. Сэмплы в этом синтезаторе используются в качестве осцилляторов — генераторов сигналов звуковой частоты. В своей практике вы обязательно столкнетесь с объектами, которые именуются лупами и грувами. Классический барабанный луп — это фрагмент барабанной партии, записанный в определенном темпе, длина которого кратна целому числу тактов. Если воспроизводить такой фрагмент в цикле (отсюда и название лупа — "Loop" — петля (существительное), двигаться по кругу (глагол)), то создастся ощущение непрерывной игры. Лупы могут быть и не барабанными. Это может быть любой фрагмент музыки, зацикливание которого приведет к ощущению непрерывной игры.
В настоящее время на дисках и в Internet можно найти множество коллекций лупов. Композиция будет звучать очень монотонно, если на всем ее протяжении будет звучать всего один луп. Поэтому лупы обычно поставляются наборами, в пределах которых все лупы записаны в одном темпе на одних инструментах, но соответствуют разным частям композиции. Например, вступлению, переходам и т. п. Однако несмотря на это, найти подходящий луп для вашей композиции не просто. Что значит "подходящий"? Это значит то, что он вам должен нравиться, быть уместным в композиции определенного стиля и подходить по темпу. Допустим, вам понравился какой-то луп, который был записан в темпе 126 долей в минуту. Да вот беда, темп вашей композиции равен 140. К тому же вы не уверены, что вам не придется изменить темп до какого-то третьего значения. Можно было бы изменить длительность лупа с помощью звукового редактора (например, Cool Edit Pro 12]) таким образом, чтобы подогнать луп под нужный вам темп. Однако при этом изменится тональность лупа. Алгоритмы изменения длительности сэмпла без изменения его тональности эффективно работают только с аудиосигналами, содержащими чистый тон. Звуки барабанов и перкуссии являются аудиосигналами шумоподобными, поэтому результаты работы подобных ачгоритмов будут неудовлетворительными. Многие разработчики музыкальных программ внедрили в своих продуктах такие алгоритмы работы с лупами, при которых в лупе выделяются отдельные звуки (Slices). После этого программа может автоматически изменять положения этих звуков в лупе, подстраиваясь под заданный темп.
Однако мало того, чтобы луп был согласован по темпу. Суть лупа в его циклическом звучании. Это означает, что начало и конец зацикленного фрагмента должны естественно сопрягаться друг с другом. В месте стыка недопустимы перепады амплитуды аудиосигнала. В противном случае будут слышны щелчки.
Совсем не обязательно лупы могут быть только барабанными. В своей практике вам обязательно придется работать и с грувами — мелодическими лупами. Если барабанный луп достаточно подогнать к сонгу по темпу, то грув нужно подгонять еще и по тону.
Изменение тональности грува достигается путем изменения скорости воспроизведения его отдельных частей.


1.5.3.VST и VSTi

В последнее время чрезвычайно популярными стали аудиоэффекты, обработки и виртуальные инструменты, реализованные программным путем и работающие в режиме реального времени. Они могут представлять собой как самостоятельные приложения, так и плагины, предназначенные для использования из других приложений — приложений-хостов. Вообще плагины — нечто несамостоятельное, некий подключаемый "довесок" к программе или устройству, благодаря чему эта программа или устройство получает новые возможности. Приложение-хост — это та программа, которая позволяет подключать к себе плагины. Взаимодействие хоста с плагином регламентируется интерфейсом прикладных программ (Application Programming Interface — API). В настоящее время наиболее популярными "музыкальными" API на платформе PC можно считать VST и DX.
DX — технология, обеспечивающая взаимодействие приложений-хостов с виртуальными эффектами и инструментами (синтезаторами; сэмплерами; эффектами, управляемыми по MIDI, и др.) посредством интерфейса прикладных программ Microsoft DirectX. После установки DX-плагинов в систему они становятся доступными из любых приложений, позволяющих использовать данную технологию.
В равной степени распространены VST-плагины. VST — Virtual Studio Technology — API фирмы Steinberg. Virtual Studio Technology изначально разрабатывалась для применения в программных продуктах Steinberg (в частности, в Cubase VST). Поэтому нет ничего удивительного в том, что и программа Cubase SX ориентирована на работу с VST-плагинами.
Вообще с поддержкой плагинов различных стандартов в Cubase SX дела обстоят следующим образом:

  • в полной мере поддерживаются VST-плагины (и эффекты, и инструменты - VST1);
  • DX-плагины поддерживаются с ограничениями: Cubase SX не отличает DX-плагины эффектов от плагинов инструментов DXi, поэтому применение DXi из Cubase SX нам не представляется возможным; не поддерживается автоматизация параметров DX-плагинов.
Все плагины фирмы Steinberg поддерживают стандарт VST. Наиболее мощные по возможностям и качеству звучания (поэтому и наиболее популярные) плагины третьих фирм поддерживают оба стандарта: и DX, и VST. Поэтому в дальнейшем мы будем говорить только о применении VST-плагинов.
Инсталляция VST-плагинов, входящих в поставку Cubase SX, осуществляется во время установки самой программы Cubase SX, и вам не нужно прикладывать никаких усилий для того, чтобы эти плагины в дальнейшем были доступны. Если же вы собираетесь инсталлировать дополнительные плагины, то следует понимать, что для Cubase SX важно, чтобы программные модули плагинов находились в определенной папке. По умолчанию это C:/PROGRAM FILES/STEINBERG/CUBASE SX/VSTPLUGINS. В случае необходимости можно указать другую папку, используемую для хранения плагинов, и дать Cubase SX команду обновить информацию о плагинах. Дело в том, что в настройках каждого приложения-хоста имеется путь к папке с VST-плагинами. У разных приложений этот путь по умолчанию разный. И если вы хотите использовать одни и те же VST-плагины из разных приложений, то в настройках каждого из них должна быть указана одна и та же папка.
VST-инструменты (VSTi) — это, по существу, плагины, управляемые по протоколу MIDI. Для того чтобы задействовать в Cubase SX какой-либо виртуальный инструмент, требуется выполнить минимальное количество действий: подключить плагин VSTi к проекту и выбрать на одном из MIDI-треков в качестве выходного порта виртуальный MIDI-порт данного инструмента.
Различным аспектам применения VST-плагинов посвящено несколько разделов данной книги. В частности, методика подключения VSTi описана в разд. 4.1.3, автоматизация VST-плагинов (эффектов и инструментов) описана в разд. 4.7.8, методика получения информации о VST-плагинах изложена в разд. 5.6.1. О применении VST-плагинов в многоканальных проектах вы прочтете в разд. 5.6.2. Применение VSTi рассмотрено в главе 10, а описание VST-плагинов приведено в главе 13.
У каждого VST-инструмента есть свои особенности. Большинство из инструментов уникально: в них используются различные типы синтеза звука, они отличаются архитектурой и методами обработки генерируемого звука. Многие из них обладают собственным, как правило, ни с чем не совместимым набором MIDI-контроллеров. Однако перечень этих контроллеров, банков и патчей может передаваться в приложение-хост. В этом случае вы обращаетесь к требуемому контроллеру уже не по номеру, а по его названию. Выбирать и корректировать тембры удобнее всего в окне самого VST-инструмента. Все настройки VST-инструмента, сделанные в этом окне, сохраняются непосредственно в проекте.
Мультитембральными VST-инструментами можно управлять по нескольким MIDI-каналам с нескольких MIDI-треков. Для того чтобы свести к минимуму задержку между поступлением MIDI-команды VST-инструменту и ее реализацией в звуке, требуется достаточно мощный процессор и звуковая карта с ASIO-драйверами. Однако если вы не собираетесь играть на VST-инструменте с клавиатуры, то эта задержка значения не имеет. На MIDI-треке, управляющем VST-инструментом, вы располагаете партию для данного инструмента, записав ее нотами или с помощью отпечатков клавиш. Можно записать партию с MIDI-клавиатуры на другой трек, озвучиваемый аппаратным синтезатором, а затем перенести на трек, управляющий VST-инструментом. При воспроизведении проекта приложение-хост учтет то, что VST-инструменты откликаются с запозданием, и будет посылать MIDI-команды для них чуть раньше, чем для других MIDI-инструментов. В результате VST-инструменты будут звучать синхронно со всем сонгом.
Что касается субъективного качества звука, генерируемого виртуальными синтезаторами (и VST-инструментами, в частности), то оно зависит исключительно от разработчиков. Существует множество виртуальных синтезаторов с возможностями игрушки. Но попадаются и такие, которые не уступают по качеству звучания своим аппаратным прототипам, а по возможностям и гибкости в управлении оставляют их далеко позади.
Если вы работаете с аппаратным синтезатором, то для "переброски" MIDI-партии этого инструмента на аудиотрек или в WAV-файл требуется делать внутреннее пересведение: нужно воспроизводить MIDI-треки, относящиеся к данному синтезатору, и одновременно записывать звучание синтезатора на аудиотрек. Качество записи при этом зависит от самого синтезатора, соединительных кабелей и качества АЦП звуковой карты. А цифровые выходы имеются далеко не у всех "железных" синтезаторов.
Совсем другое дело — виртуальные инструменты. Вы можете сами определять формат звуковых данных проекта Cubase SX. Соответственно все виртуальные инструменты будут работать в заданном формате. При этом ничто не мешает вам использовать 24 бита для представления звукового сигнала. И никакого шума.
Итак, вы можете использовать VST-инструменты и добиться серьезных результатов, обладая всего лишь компьютером с достаточно мощным процессором и звуковой картой с минимальными возможностями. Стоимость такой домашней студии гораздо меньше, чем студии с несколькими аппаратными синтезаторами и сэмплерами. Единственные два требования к звуковой карте состоят в том, что она должна обеспечивать качественное аналого-цифровое преобразование для записи вокала и живых инструментов и качественное цифро-аналоговое преобразование для мониторинга (вы должны слышать результаты своих действий).


1.6. Структура микшера

В тех случаях, когда необходимо проводить запись или сведение сигналов, поступающих от нескольких различных источников, без микшера (микшерного пульта) обойтись очень трудно. На страницах книги вы не раз встретитесь с виртуальным микшером Cubase SX и его элементами, реализованными программным способом. Вообще, микшеры, используемые в современных виртуальных студиях, по своим возможностям, да и по дизайну, очень напоминают настоящие аппаратные микшеры. Поэтому есть смысл познакомиться со структурой типичного микшера, а также с назначением его основных элементов.
Микшер позволяет решать несколько задач. Некоторые из них перечислены ниже.

  • Микширование (смешивание) в заданных пропорциях сигналов, поступающих от различных источников.
  • Согласование уровня сигнала источника с чувствительностью и динамическим диапазоном устройства записи, обработки, усиления.
  • Измерение уровня выходного микса (а в ряде ситуаций и канальных) сигналов.
  • Оперативное регулирование уровня сигналов.
  • Эквализация (корректирование частотных характеристик сигналов).
  • Направление сигналов на внешние устройства динамической обработки и эффект-процессоры, регулирование уровней сигналов, посылаемых на эти устройства и возвращаемых с них.
  • Коммутация сигналов.
  • Переключение фазы канального сигнала.
  • Формирование микса, направляемого на контрольные мониторы или на наушники исполнителей.
  • Заглушение (мьютирование) отдельных каналов и переключение их в режим solo.
Внешний вид типичного микшера представлен на рис. 1.15.

Рис. 1.15. Внешний вид типичного микшера

Условно в микшере можно выделить элементы, перечисленные ниже.

  • Секция канальных модулей (иногда канальный модуль называют входным каналом микшера). Каждый из канальных модулей содержит элементы коммутации и регулировки, с помощью которых ведется раздельная обработка канальных сигналов.
  • Шины параллельного подключения эффектов (шины Aux). С их помощью один или несколько каналов подключаются к внешним устройствам обработки сигналов с последующим возвратом обработанного сигнала в общий микс.
  • Мастер-модуль. В нем канальные сигналы и сигналы, возвращенные с внешних устройств обработки, объединяются в одну или несколько пар стереосигналов, производится измерение и регулировка уровня смикши-рованного сигнала.
  • Модуль формирования контрольного сигнала. В нем формируется микс, поступающий на вход усилителя, подключенного к контрольным мониторам или наушникам.


1.6.1. Канальный модуль

На панели канального модуля сосредоточено большинство элементов управления микшером. Канальный модуль позволяет:

  • подключать к микшеру источник звука (микрофон, а также электрогитару, синтезатор, магнитофон, CD-плеер и другие линейные источники сигналов);
  • управлять уровнем громкости источника;
  • осуществлять коррекцию частотных характеристик сигнала с помощью эквалайзера;
  • направлять сигналы на выходы системы (основной и мониторный);
  • направлять сигналы на дополнительные шины подключения эффектов (шины Aux).
В каждом канальном модуле есть средства выбора различных источников (микрофонный/линейный) и предоставляется возможность установить предварительное усиление для каждого из них. Обобщенная функциональная схема канального модуля представлена на рис. 1.16.

Рис. 1.16. Обобщенная функциональная схема канального модуля

Канальный эквалайзер служит для управления частотной характеристикой входного сигнала как в целях ее коррекции, так и для достижения определенного художественного эффекта.
Фейдер канала позволяет оперативно регулировать уровень сигнала.


Подключение источников сигнала

Для подключения источников сигнала предусмотрены гнезда разъемов различных типов. Как минимум, имеются трехконтактный разъем типа XLR (подключается микрофон) и гнездо для моноджека (подключаются линейные источники сигнала). Селектор входа (переключатель MIC/LINE) определяет, какое гнездо разъема и какие элементы усиления будут использованы данным каналом.
Кнопка ослабления сигнала (имеется не на всех микшерах) позволяет понижать уровень сигнала (на 20-30 дБ) до того, как он попадет на какой-либо усилительный элемент микшера. Это позволяет избежать перегрузок от сигналов повышенного уровня.
В некоторых микшерах имеется переключатель фазы (на схеме не показан), который используется для исправления последствий неверной коммутации проводов или для изменения фазы, когда размещение системы из нескольких микрофонов этого требует. Одному положению переключателя соответствует нулевой сдвиг фазы, второму — сдвиг фазы на 180° (иными словами, сигнал инвертируется). Этот переключатель, как правило, действует только на сбалансированный микрофонный вход и не влияет на вход линейный.


Фантомное питание

Фантомное питание подается только на сбалансированный микрофонный вход и является источником питания конденсаторных микрофонов. Название фантомное объясняется тем, что для подачи напряжения питания не требуются дополнительные проводники. Питание 48 В на конденсаторный микрофон подается по сигнальным проводникам. Для разделения цепей постоянного и переменного тока применяются конденсаторы. Пользоваться выключателем фантомного питания следует предельно осторожно. Если микрофонный вход скоммутирован с несбалансированным источником сигнала, случайное включение фантомного питания может привести к поломке прибора, так как на него будет подано напряжение 48 В.
На сбалансированные источники сигнала фантомное питание не оказывает негативного воздействия.
Фантомное питание можно использовать также и для подключения электрогитары или клавиатуры. Однако при этом нужно:

  • применять специальные распределительные устройства, понижающие напряжение фантомного питания до величины, на которую рассчитано подключаемое устройство;
  • следить, чтобы источник фантомного питания не оказался перегружен устройством, потребляющим недопустимо большой ток.
Регулятор предварительного усиления позволяет привести в соответствие уровни источника сигнала и микшера. Тем самым компенсируется, например, разброс в громкостях звучания голосов различных певцов и в уровнях сигналов различных источников (микрофон, гитара и т. п.).
Предварительное усиление необходимо регулировать при нажатой кнопке Solo, расположенной рядом с фейдером канала. Эта кнопка позволяет выделить канальный сигнал из общего микса, проверить уровень и оценить качество звука в канале независимо от общего микса. Кнопка Solo имеется не на всех микшерах и на схеме (см. рис. 1.16) она не показана. Усиление на входе следует отрегулировать таким образом, чтобы пиковые отметки индикатора уровня находились на границе красной зоны (О VU), но не оставались в ней подолгу.
Эквалайзер микшера обычно имеет три полосы частот: низкую, среднюю и высокую. В микшерах, стоящих не очень дорого, используются полупараметрические эквалайзеры. В них для всех или некоторых полос можно выбрать частотный диапазон, с которым будет работать эквалайзер. Полупараметрический эквалайзер не позволяет регулировать добротность фильтра в отличие от параметрического. С перестройкой центральной частоты фильтра эквалайзера изменяется полоса пропускания и в полупараметрическом эквалайзере скомпенсировать это изменение невозможно.
В дорогих микшерах используются параметрические эквалайзеры, которые позволяют независимо регулировать и центральную частоту, и добротность (полосу пропускания).
Если все метки на вращающихся ручках направлены строго вертикально вверх, то эквалайзер находится в нейтральном положении. При вращении ручки по часовой стрелке происходит усиление сигнала в выбранном частотном диапазоне, против часовой стрелки — подавление.
Для поиска частоты эквализации есть смысл усиливать сигнал, тогда станут заметны изъяны звука на этой частоте. Для достижения тонального баланса целесообразно применять не усиление частот того сигнала, который вы хотите выделить (что может вызвать его искажение), а, наоборот, подавление частот остальных сигналов.


Insert — подключение эффектов и обработок последовательного действия

После эквалайзера (а в некоторых микшерах перед ним, как показано на рис. 1.16) сигнал проступает на разрыв (Insert) и затем на фейдер канала.
Разрыв (Insert) представляет собой гнездо разъема типа "стереоджек" с несколько необычно скоммутированными контактными группами. Если в гнездо не вставлена ответная часть разъема, то сигнал проходит с выхода эквалайзера на вход фейдера. Однако если ответная часть разъема вставлена в гнездо, то цепь действительно оказывается разорванной. Вместо нее по подключенному к ответной части разъема кабелю с двумя сигнальными проводниками сигнал с выхода эквалайзера сначала попадает на вход внешнего устройства обработки, например, ревербератора (данная линия называется посылом), а затем возвращается в микшер по линии, которая называется возвратом. Именно за счет наличия гнезда разъема Insert, посыла и возврата каждый канал можно обработать эффектами независимо от других каналов.
После разъема Insert (либо после эквалайзера) сигнал поступает на фейдер канала, предназначенный для оперативного регулирования уровня канального сигнала. В недорогих микшерах данный регулятор управляется вращающейся ручкой. Но более удобна слайдерная (движковая) конструкция фейдера. Положение канальных фейдеров относительно друг друга создает общее представление о соотношении уровней сигналов в каналах.
Фейдер обычно имеет маркировку его оптимального положения (0 дБ). Для повышения уровня оставлен некоторый запас (10—15 дБ), но в основном предусматривается его уменьшение. Когда фейдер находится в положении — бесконечности, сигнал максимально ослаблен.
После фейдера в схеме пульта расположен регулятор панорамы, определяющий баланс сигнала между левым и правым выходами. Обычно регулятор панорамы является источником сигнала для главного стереовыхода.
Префейдерные посылы используются для организации мониторинга. Сигнал снимается до того, как он пройдет фейдер канала, поэтому уровень отбираемого сигнала не зависит от положения фейдера канала. Это удобно с той точки зрения, что мониторный микс для артистов, находящихся на сцене (или для исполнителя и звукооператора), и звук в зрительном зале (или на входе записывающего устройства) становятся независимыми. Однако при необходимости корректировок приходится манипулировать и фейдером канала, и префейдерными ручками Aux.
Постфейдерньгй посыл (сигнал, снимаемый после фейдера канала) используется для эффектов. Пропорции между уровнем сигнала, подаваемого на внешние приборы обработки звука, и уровнем сигнала в канале при этом сохраняются.
Как правило, микшеры позволяют подключать Aux как до, так и после фейдера. Делается это с помощью специального переключателя или перемычки.


1.6.2. Шины. Подключение эффектов параллельного действия

В ряде моделей имеются коммутаторы, которые определяют маршрут дальнейшего прохождения сигнала и направляют его на различные выходные шины.
Кроме основных шин, в микшере есть и дополнительные шины Aux, позволяющие организовать мониторинг (озвучивание всей сцены или подачу миксов на индивидуальные мониторные системы, например, наушники исполнителей) и подключать дополнительные приборы обработки. Любая шины Aux является общей для всех каналов, и сигналы направляются на один и тот же прибор, где они и обрабатываются.
Для последовательного подключения эффекта, действующего только на один канал, служит разрыв (Insert).
Последовательные эффекты или обработки заменяют исходный сигнал собственным. Такими эффектами могут быть, например, хорус, флэнжер (см. разд. 1.6), а обработками — эквалайзер, гейт, компрессор. Последовательные эффекты включаются в разрыв в тех случаях, когда нужно обработать ими сигнал только одного канала. Для одновременной обработки эффектом нескольких источников можно подключать их через шины Aux. Необработанный звук при этом можно получить путем регулировки баланса или глубины эффекта на самом приборе обработки.
Параллельные эффекты не заменяют исходный сигнал собственным, а лишь добавляют к исходному сигналу его обработанный вариант. Параллельные эффекты подключают через шины Aux, причем эффект оказывается доступным для всех каналов и для каждого из них можно установить свою глубину эффекта. После обработки эффектом параллельного действия сигнал возвращается на основную шину микшера, где смешивается с остальными сигналами. В результате в общем миксе присутствует и исходный сигнал, и обработанный.
Степень обработки эффектом сигнала того или иного канала устанавливают регулятором уровня посыла.
Обычно у эффектов имеется регулятор Dry/Wet. Он может называться и по-другому, но его суть от этого не меняется — это отношение исходного и обработанного сигналов на выходе эффекта. Желательно, чтобы на выходе эффекта, подключенного к шине Aux, был только обработанный сигнал. В противном случае исходный сигнал вернется в общий микс, где смешается с таким же сигналом с выхода аудиотрека. Понятно, что за счет сложения двух одинаковых сигналов увеличится их общая громкость. Это в лучшем случае. А в худшем случае вы получите совершенно непрогнозируемый результат за счет того, что фаза необработанного сигнала на выходе эффекта в принципе может отличаться от фазы этого же сигнала на выходе аудиотрека.
Если же эффектом требуется обработать только один канал, то эффект можно включить в разрыв (Insert) и добиться требуемых соотношений между обработанным и необработанным сигналами регулировкой Dry/Wet.
Рассмотрим элементы коммутации и регулировки, имеющиеся в каждом канальном модуле.


1.6.3. Мастер-модуль

В мастер-модуле микшера сосредоточены регуляторы уровня левого и правого каналов, регулятор панорамы стереомикса, измеритель уровня сигнала на выходе микшера. Здесь же, как правило, находится и регулятор уровня микса, поступающего на тот выход микшера, к которому подключены контрольные мониторы или наушники.
Разумеется, от модели к модели микшера состав элементов коммутации и управления варьируется. Микшеры отличаются количеством каналов (и моно, и стерео), но рассмотренные элементы, как правило, есть во всех микшерах.
Практически все MIDI- и аудиоредакторы содержат виртуальные микшеры, более или менее успешно имитирующие своих железных собратьев. Не является исключением и Cubase SX.
Ко многим звуковым картам прилагаются драйверы, по существу являющиеся специализированными виртуальными микшерами.


1.6.4. Автоматизация

Наиболее совершенные (как правило, цифровые) микшеры обладают функцией автоматизации. Поддержка микшером автоматизации означает, что оператор может заранее записать, отредактировать и затем автоматически воспроизвести все свои манипуляции с элементами управления микшера. Перемещения регуляторов, рукояток, слайдеров и изменения состояний переключателей, имеющихся на панели микшера, преобразуются в нестандартные MIDI-сообщения (данные автоматизации), которые, в свою очередь, запоминаются в устройстве, подобном секвенсору. В необходимое время включается воспроизведение автоматизации, данные из секвенсора поступают на соответствующие исполнительные элементы (электронные или механические). Оператор отдыхает, а невидимые руки крутят ручки и передвигают слайдеры.
Автоматизированный микшер превращается и в мощнейший инструмент создания сложных сценариев развития событий во время живого выступления, и в средство динамического управления параметрами мультитрековой композиции при ее сведении. Автоматизированными могут быть не только микшеры, но и самые различные приборы обработки звука, устройства для создания звуковых и световых эффектов и т. п.
Наиболее развитые музыкальные редакторы, к числу которых относится и Cubase SX, имеют в своем составе автоматизируемые виртуальные микшеры. Кроме того, посредством автоматизации можно управлять параметрами эффектов реального времени и виртуальных инструментов.
В Cubase SX для хранения данных автоматизации используются специальные сообщения, которые описывают положение узловых точек, формирующих огибающие автоматизации. Огибающие автоматизации — квазинепрерывные графики (выглядят как непрерывная линия, хотя, на самом деле, сообщения записываются и воспроизводятся в дискретные моменты секвенсорного времени), описывающие поведение того или иного автоматизируемого параметра во времени. Огибающие автоматизации образуются путем линейной интерполяции значений автоматизируемого параметра в узловых точках.
Применению автоматизации в Cubase SX посвящен разд. 4.8.


1.7. Представление музыкальной информации в Cubase SX

В музыкальном редакторе Cubase SX MIDI-данные отображаются и записываются в виде нот, клипов, отпечатков фортепианных клавиш, табулатур, списка сообщений, графиков изменения параметров синтеза, данных автоматизации.
Композиция состоит из отдельных треков, за каждым из которых может быть закреплен любой MIDI-инструмент из любого банка любого MIDI-устройства (синтезатора, сэмплера), в том числе виртуального. Допускается смена инструмента в любой момент. Отдельные ноты или любой фрагмент композиции с помощью стандартных приемов могут быть подвергнуты редактированию. Возможна запись и редактирование цифрового стереозвука. Есть встроенные MIDI- и аудиоэффекты. Программа совместима с VST-инструментами и VST-плагинами эффектов, которые можно применять в реальном времени (см. главы 10 и 13), а также с DirectX-плагинами и DirectX-инструментами. Имеется виртуальный аналог интеллектуального микшера.


1.7.1. Порты, каналы, MIDI- и аудиотреки, части. Подтреки и огибающие

Взаимодействие любого музыкального редактора с музыкальным аппаратным или программным (виртуальным) MIDI-оборудованием осуществляется через программные же порты ввода и порты вывода MIDI- или звуковых данных. Если речь идет о портах для обмена данными с аппаратным устройством, то в терминологии музыкального редактора (Cubase SX, в частности) под портами можно понимать драйверы данного устройства. Однако у одного аппаратного устройства может быть несколько программных портов. Широко известен пример: существуют звуковые карты, синтезаторы которых поддерживают более чем 16 MIDI-каналов. Поскольку согласно спецификации GM может быть только 16 MIDI-каналов, то для взаимодействия с такими синтезаторами в операционной системе создается два (или более) программных MIDI-порта.
Роль входного MIDI-порта чаще всего исполняет порт MIDI In звуковой карты, к которому подключена MIDI-клавиатура. Наиболее типичный пример выходного MIDI-порта: MIDI-вход синтезатора, размещенного на звуковой карте, или порт MIDI Out звуковой карты, к которому подключен внешний синтезатор. Приведем еще примеры входных и выходных MIDI-портов:

  • MIDI-вход и выход виртуального синтезатора (VSTi);
  • порты виртуального MIDI-кабеля, посредством которого "соединяются" друг с другом программные MIDI-секвенсоры или синтезаторы;
  • порты виртуальных устройств программного MIDI-секвенсора или синтезатора, подключенного к Cubase SX посредством протокола обмена музыкальными данными ReWire.
Каждый MIDI-порт, в свою очередь, содержит 16 MIDI-каналов, сообщения которым адресуются независимо друг от друга. Получается, что, имея в своем распоряжении MIDI-систему с единственным выходным MIDI-портом и не пользуясь MIDI-сообщениями о смене MIDI-инструментов, вы в состоянии создать композицию, в которой общее число партий не превышает 16. Для двух портов максимальное число партий составит 32, для трех — 48 и т. д. Конечно, если какие-то партии не перекрываются во времени, то они могут быть адресованы одному и тому же MIDI-каналу, просто нужно в начале каждой партии вставлять сообщение о смене MIDI-инструмента.
Кроме MIDI-информации, музыкальные редакторы должны обмениваться с внешним аппаратным и программным миром адиопотоками. Взаимодействие осуществляется через программные аудиопорты, которые в свою очередь связаны с драйверами оборудования. Обычно входному аудиопорту соответствует АЦП звуковой карты. От состояния элементов коммутации входов звуковой карты, в свою очередь, зависит то, какой источник звукового сигнала оказывается подключенным к АЦП. Выходной аудиопорт, как правило, — ЦАП звуковой карты. Профессиональные звуковые карты бывают многоканальными: имеют несколько портов ввода/вывода оцифрованного звука.
Разработчик Cubase SX, фирма Steinberg, продвигает свой собственный интерфейс прикладных программ, обеспечивающий обмен данными между звуковым оборудованием и программами. Называется он ASIO (Audio Stream In/Out). Использование ASIO в обход стандартных средств Windows позволяет сократить время реакции виртуальных инструментов и устройств обработки звука на поступающие команды до нескольких (1 —2) миллисекунд.
Спецификация ASIO является открытой. Это означает, что производитель оборудования, написавший ASIO-драйвер, ничего за это не должен платить фирме Steinberg. А из-за огромного авторитета Steinberg практически каждый производитель стремится снабдить свою, пусть даже мультимедийную, звуковую карту ASIO-драйвером и с гордостью разместить соответствующий логотип на упаковке и в рекламном проспекте.
Использование ASIO-драйверов, в свою очередь, позволяет в большей степени (по сравнению со стандартными драйверами Windows) задействовать возможности оборудования.
В качестве примера сравним возможности звуковой карты SB Audigy при использовании стандартных драйверов и ASIO-драйвера. Если используется стандартный драйвер, то доступен всего один входной порт (стереофонический), хотя к самой карте могут быть подключены несколько источников аудиосигнала. Сигналы каких источников и с каким уровнем следует направлять в этот единственный входной порт, определяется настройками микшера звуковой карты. Выходной порт тоже один и тоже стереофонический. Если задействовать ASIO-драйвер этой же карты, то картина изменится кардинальным образом: 6 входных стереофонических портов (включая порт интерфейса S/PDIF) и 7 пар выходных портов. Первые шесть пар портов соответствуют каналам системы объемного звука с обработкой аппаратным процессором эффектов звуковой карты и без обработки. Последняя пара портов фактически является посылом на этот аппаратный процессор.
В любом музыкальном редакторе присутствуют MIDI- и аудиотреки. Треки предназначены для хранения информации, адресованной определенному аппаратному или виртуальному устройству. Для каждого из треков независимо можно задать входной и выходной порты. В режиме записи на трек сохраняется та информация, которая поступает через входной порт. При воспроизведении информация, хранящаяся на треке, будет передаваться на его выходной порт. Если говорить о MIDI-треках, то для каждого трека в отдельности можно задать:
  • входной MIDI-порт, к которому подключена, например, MIDI-клавиатура;
  • выходной MIDI-порт (к которому подключен внешний синтезатор, сэмплер или какое-либо другое аппаратное или виртуальное MIDI-устройство);
  • номер MIDI-канала, по которому будут передаваться MIDI-данные.
Для аудиотреков можно задать входной и выходной аудиопорты. Если карта поддерживает систему объемного звучания, то выходные порты можно использовать по-разному. Например, можно задействовать каждый из этих портов по отдельности (звук с одного трека воспроизводить через один канал, а звук другого трека — через другой и т. д.). В Cubase SX реализована поддержка многоканальных систем вплоть до 5.1. Заключается она в том, что в качестве выходного порта аудиотрека можно выбрать выходной виртуальный аудиопорт SurroundPan. В Cubase SX предусмотрена возможность увязки данного виртуального порта с существующими реально выходными портами многоканальной системы. Ваша задача — размещать виртуальные источники звука вокруг себя (делается это с помощью виртуальных регуляторов, по своей сути напоминающих джойстик), а задача Cubase SX — распределять соответствующим образом сигналы по каналам системы объемного звучания.
В принципе, в музыкальном редакторе музыку можно создавать, не применяя режим записи. Соответственно входные MIDI- и аудиопорты могут вообще не использоваться. Как такое возможно? Вы можете создать музыку графическим способом (расставляя ноты или отпечатки MIDI-клавиш), импортировать уже готовые MIDI-файлы, содержащие некие "полуфабрикаты" для вашего будущего произведения (например, ритмические партии). Что касается аудиотреков, то вы можете импортировать аудиофайлы из библиотек сэмплов. Но вот без выходных портов MIDI- и аудиотреков не обойтись. Надо же как-то музыку воспроизводить.
Само собой разумеется, что треков в проекте песни или инструментальной композиции может быть несколько (а именно, столько, сколько вам нужно). Абсолютно независимо друг от друга треки могут находиться в режиме записи или режиме воспроизведения. Предположим, что над многотрековым проектом вы работаете в одиночку. Тогда процесс вашей работы выглядит примерно так. Вы поочередно записываете партии разных инструментов на разные треки. Сначала вы записываете партию одного инструмента. Потом вы записываете партию другого инструмента уже на другой трек. Во время записи второго трека вы слышите звучание партии, записанной на первый трек и свою собственную игру. При записи партии третьего инструмента на третий трек вы слышите звучание первых двух треков и свою собственную игру и т. д. В принципе, если возможности аппаратуры позволяют, вы можете производить одновременную запись нескольких источников MIDI-и/или аудиоданных на разные треки (выполнять многоканальную запись).
В Cubase SX MIDI- и аудиоданные хранятся в виде сообщений. Пример MIDI-сообщения: Note (нажатие MIDI-клавиши), параметры данного сообщения — номер клавиши, время удержания в нажатом состоянии и скорость, с которой клавиша была нажата. Что понимать под аудиосообщением? Аудиосообщение — объект, содержащий ссылку на звуковой файл и набор атрибутов, относящихся к тому, когда и как данный файл следует воспроизводить и как отображать в проекте соответствующий ему графический объект. В терминологии Cubase SX звуковой файл называется клипом.
В Cubase SX существует понятие часть — это объект, предназначенный для хранения сообщений. Часть располагается на одном треке и может не содержать ни одного сообщения или содержать сколько угодно сообщений. Производя операции редактирования с частью, вы тем самым производите эти операции с множеством сообщений как с единым целым.
MIDI-сообщения не могут храниться вне частей. В момент включения режима записи на соответствующих треках автоматически создаются части, и в них по мере поступления размещаются записываемые данные. Если за время работы программы в режиме записи никакая информация не поступила, то созданные пустые части будут автоматически уничтожены.
В отличие от MIDI-сообщений, аудиосообщения могут храниться вне частей непосредственно на аудиотреках.
Следует различать части, предназначенные для хранения MIDI-сообщений, и части, предназначенные для хранения аудиосообщений. В Cubase SX существует жесткое ограничение — MIDI-части могут располагаться только на MIDI-треках, а аудиочасти — только на аудиотреках. Проявляется это ограничение, например, в том, что вам не удастся перетащить MIDI-часть на аудиотрек.
На рис. 1.17 вы видите окно Cubase SX Project программы Cubase SX. Это окно проекта. По горизонтали оно поделено на три области. Левая и средняя области относятся к секции атрибутов треков. От правой области (секции треков) секция атрибутов треков отделена перемещаемым бордюром. Секция атрибутов треков подразделяется на список треков (средняя область) и поле инспектора (левая область). В списке треков один над другим располагаются поля, каждое из которых соответствует своему треку. В этих полях доступны лишь основные атрибуты треков: имя трека, его состояние (заглушен или звучит, солирует, подготовлен к записи), громкость, панорама и ряд других атрибутов. В главе 4 имеется исчерпывающее описание всех типов треков и соответствующих им атрибутов.
Область инспектора представляет собою панель, на которой сосредоточены опции выбора большого числа параметров одного из треков. Какого именно? Когда вы щелкаете левой кнопкой мыши на одном из полей в списке треков, трек оказывается выделенным более светлой окраской. На рис. 1.17 на выделенный трек указывает стрелка курсора мыши. Вы можете использовать клавиши <вверх> и <вниз> для выбора того трека, атрибуты которого будут отображаться в поле инспектора. В дальнейшем вы узнаете, что выделенной может оказаться группа треков. Однако даже в этом случае в поле инспектора будут доступны атрибуты только одного из них.
Прямоугольники, расположенные один под другим в правой части окна, — части, содержащие MIDI-сообщения.
До сих пор мы упоминали только MIDI- и аудиосообщения. Однако в Cubase SX существуют сообщения и других категорий. Например, существуют сообщения, содержащие текст. У них всего один параметр — текстовая строка. С их помощью можно набрать комментарии или текст песни.
А кроме MIDI- и аудиотреков в Cubase SX существуют еще несколько видов вспомогательных треков. В качестве примера можно привести треки-контейнеры, предназначенные для хранения внутри себя других треков.
С их помощью можно придать проекту некую структуру и сократить количество отображаемых в окне проекта треков. Однако на эти треки невозможно записать какую-либо информацию. Тем не менее, как графические объекты эти треки отображаются в окне проекта.

Рис. 1.17. Окно Cubase SX Project

Итак, треки Cubase SX представляют собой графические объекты, созданные для удобства пользователя. Нагляднее и удобнее каждому инструменту назначать отдельный трек. Хотя на одном и том же треке, в принципе, могут располагаться партии разных инструментов. С помощью специального MIDI-сообщения в заданном месте трека можно подать синтезатору или сэмплеру команду смены инструмента. Однако команда для смены выходного MIDI- или аудиопорта не существует.
На самом деле вряд ли удастся выделить внутри компьютера или внутри программы что-то, напоминающее звуковую дорожку на магнитной ленте. Скорее всего, эта информация не только разбросана по разным адресам, но и сами адреса непрерывно меняются. Но для пользователя трек остается треком. При нотном представлении это проявляется в том, что каждому инструменту отводится свой нотоносец. С каждым треком ассоциирован отдельный модуль виртуального микшера.
В одном предельном случае часть — это одно сообщение, в другом — все сообщения, размещенные на одном треке.
Части же, расположенные на треках, имеют вполне определенный смысл — хранение фрагмента композиции, принадлежащего одному треку. Приведем примеры того, что может быть содержанием части:

  • один или несколько тактов;
  • логически завершенный фрагмент трека, относящийся, скажем, к куплету или припеву;
  • все сообщения, принадлежащие одному треку.
Последний пример не имеет особого смысла, поскольку полезный эффект от существования частей можно получить лишь в первых двух случаях. На рис. 1.17 показан пример проекта Cubase SX, полученного путем импорта MIDI-файла. Структура MIDI-файла такова, что MIDI-сообщения хранятся непосредственно на треках. Однако в процессе их импорта Cubase SX создает части, поскольку в проекте данной программы хранение MIDI-сообщений вне частей не предусмотрено. В результате мы получили такую картину: на каждом непустом треке имеется по одной части, в которую собраны все сообщения данного трека. Кстати, существуют MIDI-файлы такого формата (MIDI Format 0), в котором вообще отсутствуют треки. Все сообщения, адресованные разным MIDI-каналам, "свалены" в одну кучу.
Что касается технологии частей, то она позволяет в сотни раз ускорить работу компьютерного музыканта. В каких ситуациях? Например, записали вы 4 такта барабанной партии, выделили их в отдельную часть и путем копирования размножили часть так, что образовалась партия, насчитывающая десятки, а то и сотни тактов.
Или: записали один куплет и один припев песни, выделили это в часть и размножили в необходимом количестве экземпляров.
Еще один пример. Записали солирующую партию в исполнении фортепиано. Захотелось найти какой-то оригинальный тембр. Вот он — синтезированный звук плачущей флейты! Но у этого звука большое время атаки, он медленно нарастает. Создается впечатление запаздывания. Хорошо бы сделать так, чтобы ноты этой партии брались с небольшим опережением. Если вы не работаете с клипами, то станете передвигать каждую ноту, на что уйдет уйма времени. Да еще придется делать это не один раз. А вот после объединения партии в часть, все ноты вы сможете переместить одним легким движением руки с мышью.
Часть можно скопировать, вырезать, мышью перенести в любое место проекта. Можно применить к выделенной части любую обработку, MIDI- или аудиоэффекты. Несколько частей можно объединить в одну.
Части и треки — это средство обзора композиции в целом, с высоты птичьего полета. Они, по сути дела, являются инструментами дирижера. Это не только наглядное графическое отображение структуры проекта, но и возможность быстрого и легкого переноса партий и их фрагментов во времени и пространстве музыкального произведения (с трека на трек).
Мы уже говорили об огибающих — графиках, с помощью которых в Cubase SX осуществляется управление виртуальным микшером, VST-плагинами и VST-инструментами. В Cubase SX, в отличие от многих других программ, работа пользователя с огибающими организована очень удобно. Наряду с треками, предусмотрены еще и подтреки. На каждом из них вы можете редактировать по одной огибающей. В результате графики не наслаиваются друг на друга. Доступ к подтрекам и огибающим осуществляется из окна проекта Cubase SX Project.
Подтрек открывается щелчком на маленькой кнопке, помеченной знаком + (плюс) и расположенной в левом нижнем углу каждого из полей списка треков (см. рис. 1.18). Открываете один подтрек, ассоциируете его с одним из параметров (например, с панорамой). У этого подтрека тоже есть кнопка, помеченная знаком +. Открываете еще один подтрек, ассоциируете его с другим параметром (например, с громкостью). И у этого подтрека тоже есть кнопка, помеченная знаком +. В общем, вы можете открыть столько подтреков, сколько надо (рис. 1.18).

Рис. 1.18. Открыты 2 подтрека, на которых нарисованы огибающие громкости (Volume) и панорамы (Pan)

Подтреки называются так именно из-за того, что на них хранится часть информации, принадлежащей какому-то треку. У каждого подтрека имеется небольшой набор собственных атрибутов.
Детальное описание элементов окна Cubase SX Project читайте в главе 4.


1.7.2. Список сообщений

Для редактирования сообщений предназначен специальный редактор List Editor (рис. 1.19).

Рис. 1.19.Окно редактора List Editor

Каждое сообщение (event) занимает в списке одну строчку и, по существу, представляет собой указание, которое должен выполнить музыкальный синтезатор в определенный момент.
Для MIDI-редактора сообщения — это наиболее естественная форма представления музыкальной информации. Более того, MIDI-система способна принимать и выполнять только те сигналы, которые являются MIDI-сообщениями. Вы записываете ноты, наносите отпечатки клавиш, рисуете графики изменения параметров синтеза, а компьютер, в конечном счете, все равно преобразует их в сообщения.
Вы уже знаете, что MIDI-сообщения — это всего лишь закодированные числами команды синтезатору. Наиболее часто встречаются команды Note On (включить звучание определенной ноты в такой-то момент с такой-то громкостью) и Note Off (выключить звучание ноты в такой-то момент). Все MIDI-ноты пронумерованы от 0 до 127.
Кроме этих команд MIDI-сообщения могут содержать указания о смене инструмента, перестройке частотного фильтра, нажатии педали, виде и глубине эффекта, а также многое другое. Соответствие чисел командам стандартизировано. Правда, одновременно имеют хождение целых четыре стандарта: GM, GS, XG и GM2. Смысл основных команд в них, к счастью, совпадает. Подробнее о соответствии стандартных MIDl-сообщений тем сообщениям, с которыми работает Cubase SX, мы рассказали в разд. 1.2.
Редактор MIDI-сообшений есть в музыкальной программе каждой уважающей себя фирмы. В окне редактора List Editor программы Cubase SX можно редактировать не только MIDI-сообщения, но и сообщения еще двух типов: текстовые комментарии и сообщения нотации. Окно редактора открывается командой главного меню MIDI > Open List Editor.
В левой части окна List Editor находится таблица — список сообщений. В ячейках таблицы содержится тип сообщения, время выполнения сообщения и его параметры. Редактирование содержания таблицы производится с клавиатуры компьютера или мышью с помощью меню и полей ввода.
В правой части расположена секция графического редактирования сообщений. Здесь с помощью инструмента [image] (Draw) редактируются существующие и записываются новые сообщения, а нежелательные сообщения удаляются с помощью инструмента [image] (Erase). Подробнее о работе с редактором List Editor читайте в главе 6.


1.7.3. Отпечатки клавиш

Конечно, подготовленному музыканту привычнее работать с нотными записями. К сожалению, далеко не каждому талантливому человеку судьба дала возможность обучиться теории музыки. Видимо, разработчики программ тоже понимали, что не все пользователи смогут выразить музыкальную идею нотами. Однако каждая фирма заинтересована в расширении числа покупателей своей продукции. Найденное решение просто и на удивление удобно. Мы называем его образно: "Отпечатки клавиш". Для редактирования отпечатков клавиш предназначено окно Key Editor (рис. 1.20). Оно открывается командой главного меню MIDI > Open Key Editor.
Вместо пяти нотных линеек здесь их 128. По одной линейке для каждой ноты из числа тех, что способен воспроизводить MIDI-синтезатор. Такое количество нотных линеек позволяет обойтись без ключей и знаков альтерации. И это еще не все. Для того чтобы не нужно было постоянно пересчитывать нотные линейки, в окне редактора Key Editor отображается виртуальная клавиатура, подобная фортепианной. Каждая нотная линейка
начинается от определенной клавиши. Клавиши можно как бы нажимать, щелкая на них мышью. Вы немедленно услышите звучание соответствующей ноты. Это помогает ориентироваться в линейках на слух. Но, вообще-то, обозначение той клавиши, на которую указывает курсор мыши, отображается в поле подсказки.

Рис. 1.20. Окно редактора Key Editor

По сути дела, клавиатура — это вертикальная ось системы координат, в которой вам нужно записывать музыку. А горизонтальная ось — это, конечно, ось времени. Правда, время здесь измеряется в музыкальных единицах: тактах и долях. На рабочем поле окна видны линии, обозначающие границы тактов и их долей.
Запись музыки в окне редактора Key Editor действительно выглядит, как следы отпечатков клавиш. Отпечаток необходимой клавиши начинается и заканчивается в необходимые моменты музыкального времени. На экране он представлен как цветной прямоугольник.
Вертикальная координата положения прямоугольника соответствует MIDI-номеру ноты, то есть высоте звука. Левая сторона прямоугольника приходится на момент начала извлечения звука. Длина прямоугольника по горизонтали пропорциональна длительности ноты. И все это избавляет вас от массы проблем. Не обязательно помнить обозначения нот и пауз разной длительности, знать, что такое триоль, квинтоль, пунктирная нота, лига, фермата. Просто рисуйте прямоугольники разной длины и оценивайте звучание.
Для записи отпечатка клавиши служит инструмент [image] (Draw), для удаления — инструмент [image] (Erase). Перетаскивают отпечаток клавиши по вертикали и горизонтали, изменяют его длину, как обычно, мышью. Для выполнения перечисленных операций необходимо предварительно выбрать инструмент [image] (Object Selection).
В окне редактора отпечатков клавиш есть много полезных инструментов. Можно заранее настроить карандаш на запись звуков определенной длительности, можно прослушать, как звучат отпечатки клавиш, можно даже одновременно наблюдать и редактировать несколько партий.
Детальное описание работы с отпечатками фортепианных клавиш вы найдете в главе 6.


1.7.4. Ноты

Итак, Cubase SX допускает представление и редактирование музыки в различных формах. Но редактор не имел бы права именоваться музыкальным, если бы не позволял оперировать привычными нотами и символами нотного письма. Для этого в состав программы входит нотный редактор, нотатор.
Самое главное свойство MIDI-нотатора (окно редактора Score Editor, рис. 1.21), в котором музыкальная информация отображается в нотной форме, заключается в том, что можно не только читать нотную запись, но и воспроизводить ее звучание.
И еще одна важная особенность: ноты записываются несколькими способами. Например, щелкаете кнопкой мыши на линейках нотного стана, наигрываете партию на MIDI-клавиатуре.
Для того чтобы открыть окно Score Editor, воспользуйтесь командой главного меню MIDI > Open Score Editor. Окно нотатора похоже на страничку нотной тетради: нотные станы, поделенные на такты.
В любом месте можно вставить или удалить такт, обозначить необходимые ключевые знаки.
С помощью инструмента [image] (Draw) записывают ноты любой длительности, пунктирные ноты, триоли, другие символы нотного письма. С помощью инструмента [image] (Erase) исправляют ошибки.
Для тех, кто неуверенно ориентируется, на какой линейке в том или ином ключе располагается определенная нота, в программе предусмотрена подсказка. В ней содержится обозначение ноты, соответствующей положению курсора мыши.

Рис. 1.21. Окно Score Editor

Партитура в целом или отдельные партии выводятся для печати на принтер.
Вся информация, записанная в форме нот, автоматически отображается: в редакторе отпечатков клавиш Key Editor, в списке сообщений редактора List Editor, в окне Cubase SX Project в виде частей на треках.
Подробности о работе с нотатором читайте в главе 8.


1.8. Эффекты и обработки

Использование звуковых карт, плат оцифровки звука, программ - звуковых редакторов предоставляет компьютерному музыканту довольно широкие возможности по применению в музыкальных композициях различных звуковых эффектов и приемов обработки звука. Далее мы будем различать эффекты и обработки. В чем состоит разница между ними? Обработки — это те преобразования исходного аудиосигнала, которые направлены на повышение его качества (в некотором оговоренном смысле). Примеры обработок:

  • шумоподавление в целях избавления от помех, сопровождающих полезный аудиосигнал;
  • динамическая обработка уровня сигнала, позволяющая устранить случайные перепады громкости;
  • фильтрация спектральных составляющих, необходимая для подчеркивания характерного тембра инструмента или голоса, а также для обеспечения "прозрачности" звучания композиции.
Эффекты — это тоже обработки, но только такие, в результате которых у звука появляются свойства, которых у него исходно не было.
Применение эффектов не всегда приводит к улучшению объективных свойств звука. Например, эффект дистошн, широко используемый в практике гитаристов, на самом деле есть не что иное, как специально организованное сильнейшее искажение исходного сигнала, подобное тому, которое возникает при перегрузке усилителя. Но применительно к гитаре и для определенных музыкальных стилей такой эффект оказывается уместен и позволяет получить желаемый эстетический результат.
Как правило, эффекты имитируют (иногда утрированно) какие-либо природные процессы и явления, сопровождающие излучение, распространение звуковых колебаний и восприятие их человеком. Например, эффект эхо имитирует отражение звука от преграды, эффект дилэй — многолучевой характер распространения звука в ограниченном пространстве, эффект реверберация — способность помещения, с одной стороны, накапливать энергию звуковых колебаний (многократно переотражать звуковые волны), а с другой, — постепенно поглощать эту энергию, превращая ее в тепло, нагревающее поверхности помещения.
В ряде случаев бывает очень трудно отличить эффект от обработки. Скажем, за счет фильтрации можно так исказить голос человека, что он будет восприниматься звучащим из телефонной трубки. Обработка это или эффект?
Иногда эффекты и обработки применяются совместно. Например, лучшие алгоритмы реверберации учитывают различия в поглощении средой распространения звуковых волн разной длины: за счет использования частотного фильтра эффектом обрабатывается не весь спектр сигнала, а только определенная его часть.
Те эффекты и обработки, которые применяются к MIDI-сообщениям, принято называть MIDI-эффектами. Если же преобразованию подвергается оцифрованный звук, то речь идет об аудиоэффектах и аудиообработках. Эффекты и обработки могут быть встроены в программу и неотделимы от нее. В таком случае они способны функционировать лишь в составе конкретного музыкального или звукового редактора.
Эффекты и обработки могут быть реализованы в виде специализированных программ. Для выполнения необходимых преобразований MIDI- или аудио-данные должны быть импортированы в подобные программы.
Однако наибольшее распространение получили MIDI- и аудиоплагины — модули, подключаемые к программе-хосту. Такое решение позволяет практически безгранично наращивать возможности основной программы. Программа как бы непрерывно обновляется и совершенствуется без какой-либо переработки ее кода и интерфейса. К Cubase SX аудиоплагины подключаются посредством интерфейса прикладных программ VST. Имеется также возможность подключать DirectX-эффекты.


1.9. Сущность наиболее важных звуковых эффектов

Звуковые эффекты могут быть созданы аппаратным путем, и тогда их можно использовать в реальном времени, как, например, это сделано в высококачественных звуковых картах. Для этого в их состав включены цифровые сигнальные процессоры. Цифровой сигнальный процессор (Digital Signal Processor — DSP) позволяет обрабатывать звуковые сигналы в реальном времени. В основе его принципа действия лежит аналого-цифровое преобразование сигнала с последующей обработкой, основанной на нескольких алгоритмах цифровой фильтрации и цифровой задержки. Правда, полноценный DSP чрезвычайно дорого стоит, поэтому применяется только в специализированных устройствах профессионального назначения. Сигнальные процессоры мультимедийных звуковых карт представляют собой устройства, значительно упрощенные по сравнению со своими старшими братьями. Обычно они ориентированы на создание эффектов в играх и обладают ограниченными возможностями с точки зрения применения эффектов в домашней музыкальной студии.
Выбор эффектов и управление их параметрами производится по MIDI с помощью контроллеров. В составе большинства музыкальных редакторов имеется соответствующий интерфейс, позволяющий управлять контроллерами эффектов различными способами. Чаще всего это делается путем "рисования" графика изменения параметра эффекта. Контроллер эффекта может быть также ассоциирован с одним из регуляторов виртуального микшера, входящего в состав музыкального или звукового редактора.
В компьютерных студиях звуковые эффекты часто создаются программным способом. И реализация эффектов, и управление ими осуществляется с помощью звуковых редакторов. Обработке подвергается заранее записанный в цифровой форме звуковой сигнал. Недостатком программной реализации некоторых звуковых эффектов является невозможность их использования в реальном времени, в процессе записи. Достоинство заключается в том, что отказ от обработки в реальном времени позволяет применять самые сложные алгоритмы, требующие больших временных затрат, поэтому число различных звуковых эффектов и число вариантов каждого эффекта в этом случае значительно превышает то, что достижимо при аппаратной реализации. Кроме того, имеется возможность практически неограниченного "вложения" эффектов один в другой. Предел устанавливается не техническими (точнее, не математическими) возможностями, а здравым смыслом и эстетическими критериями. Основной способ применения эффектов в Cubase SX — их применение в реальном времени. О том, как воспользоваться ими, мы расскажем на страницах книги. Сначала нужно получить хотя бы исходные представления о сущности основных звуковых эффектов: вибрато, тремоло, дилэй (delay), флэнжер (flanger), фэйзер (phaser), xopyc (chorus), реверберация (reverb).


1.9.1. Вибрато

В самом общем смысле суть эффекта вибрато заключается в периодическом изменении одного из параметров звукового колебания: амплитуды, частоты или фазы. Изменение параметра происходит с очень малой частотой — единицы герц. Различают амплитудное, частотное и фазовое вибрато. В любом случае результатом является обогащение спектра исходного звукового колебания. Читатели, знакомые с основами радиотехники, понимают, что, по сути дела, происходит модуляция звукового колебания низкочастотным сигналом. Законы физики неумолимы — спектр сигнала при этом действительно расширяется.
Кроме того, имеется еще и тембровое вибрато, о котором мы поговорим чуть позже.
Как и многие другие электронные звуковые эффекты, вибрато имеет свои естественные прототипы, уходящие корнями в народную и классическую инструментальную и вокальную музыку.
Владение приемом вибрато отличает очень хорошего певца от просто хорошего. Скрипка в руках талантливого музыканта потому и звучит так божественно, что, совершая едва заметные перемещения вдоль грифа пальцев, прижимающих струны, он осуществляет частотное вибрато. Тремоло (частный случай амплитудного вибрато) является основным приемом игры на мандолине.
Первоначально словом "вибрато" именовалась модуляция любого параметра звукового колебания. Но со временем некоторые из разновидностей этого эффекта получили свое название. Во многих публикациях по электронной музыке теперь под вибрато подразумевают только вибрато частотное. На наш взгляд это не совсем верно, следует различать амплитудное вибрато, частотное вибрато и тембровое вибрато. У фазового вибрато имеется специальное название — фэйзер (phaser).


Амплитудное вибрато и тремоло

Амплитудное вибрато включает в себя собственно амплитудное вибрато и тремоло.
Сущность амплитудного вибрато состоит в периодическом изменении амплитуды звукового сигнала. Частота, с которой это происходит, должна быть очень небольшой (от долей герца до 10—12 Гц). Если частота вибрато находится вне этих пределов, то необходимый эстетический эффект не достигается.
Тембр сигнала с амплитудным вибрато богаче по сравнению с тембром исходного сигнала. С таким спектром можно проделывать различные манипуляции, например, изменять уровни спектральных составляющих с помощью фильтров.
Степень проявления эффекта характеризуется глубиной вибрато: m = AS/S, где AS — максимальное изменение амплитуды сигнала с вибрато, S — амплитуда исходного сигнала. Диапазон допустимых значений глубины вибрато — от О до 1. Оптимальная с точки зрения художественного результата частота амплитудного вибрато составляет 6—8 Гц.
Особой разновидностью амплитудного вибрато является тремоло. Отличительные признаки тремоло: относительно высокая частота вибрации (10—12 Гц), максимальная глубина (т = 1) и импульсная форма результирующего сигнала.
В аналоговых устройствах амплитудное вибрато реализуется с помощью перемножителей сигналов. Существует много различных принципиальных схем устройств вибрато. Основная проблема аналоговых устройств — неполное подавление управляющего сигнала. При большой глубине вибрато это проявляется в виде ясно прослушивающегося "стука" с частотой модуляции.
Компьютерные музыканты встретятся с двумя вариантами реализации амплитудного вибрато: аппаратным и программным. Аппаратный способ предполагает наличие в структуре звуковой карты усилителей с управляемым коэффициентом усиления. Программный способ заключается в перемножении значений цифровых отсчетов звуковых колебаний со значениями отсчетов функции (обычно синусоидальной), описывающей управляющий сигнал.
При обработке вокальных партий нужно пользоваться амплитудным вибрато очень осторожно, глубина его не должна быть большой, а тремоло совсем недопустимо.


Частотное вибрато

Суть частотного вибрато заключается в периодическом изменении частоты звукового колебания.
В музыке частотное вибрато получило широкое распространение лишь после создания электронных музыкальных инструментов. Реализовать этот эффект на адаптеризированных акустических инструментах довольно сложно. Правда, у соло-гитары конструкция предоставляет такую возможность. Натяжение всех струн можно одновременно изменять с помощью специального механизма: подвижной подставки для крепления струн и рычага. Частотное вибрато здесь исполняется вручную.
Реализация частотного вибрато в электромузыкальных инструментах и синтезаторах проста и естественна. Работу всех узлов электронных музыкальных синтезаторов как аппаратных, так и реализованных программным путем, синхронизирует опорный генератор. Если изменять его частоту, то будут изменяться частоты и всех синтезируемых колебаний. В радиотехнике этот процесс называется частотной модуляцией. Если изменение частоты производится по периодическому закону, то в результате получается частотное вибрато. По существу дела, при частотном вибрато также расширяется спектр исходного сигнала, тембр перестает быть постоянным, а периодически изменяется во времени.
Красивое звучание получается только в том случае, когда глубина частотного вибрато (относительное изменение частоты звука) невелика. Как известно, в соответствии с хроматической гаммой введена единица музыкальных интервалов, в 1200 раз меньшая, чем октава — цент. Интервал между соседними полутонами в темперированной гамме равен в точности 100 центам. Колебание высоты тона при частотном вибрато не должно превышать нескольких десятков центов. В противном случае создается впечатление нарушения строя инструмента.
Частотное вибрато используется и само по себе и входит составной частью в более сложные звуковые эффекты.


Тембровое вибрато

Эффект тембрового вибрато также предназначен для изменения спектра звуковых колебаний. Физическая сущность этого эффекта состоит в том, что исходное колебание с богатым тембром пропускается через полосовой частотный фильтр, у которого периодически изменяется либо частота настройки, либо полоса пропускания, либо по различным законам изменяются оба параметра. При этом фильтр выделяет из всего спектра исходного колебания те частотные составляющие, которые попадают в "мгновенную" полосу его пропускания. Так как полоса пропускания "дышит" по ширине и "гуляет" по частоте, то тембр сигнала периодически изменяется.
Кроме автоматического тембрового вибрато используют еще и ручное (чаще даже "ножное" — с управлением от педали). Такой вариант эффекта известен под названиями "вау-вау".
Необыкновенно красиво звучит электрогитара, сигнал которой пропущен через блок тембрового вибрато, если цикл перестройки фильтра синхронизирован с моментом возникновения колебания струны. Звук каждого очередного взятого аккорда перетекает от одного края своей тембральной области до другого.
Если звуковая карта содержит перестраиваемые резонансные фильтры или хотя бы фильтры нижних частот с перестраиваемой частотой среза, то этот эффект может быть создан и аппаратным способом в реальном времени.


1.9.2. Эффекты, основанные на задержке сигнала

В этом разделе мы познакомим вас с сущностью ряда эффектов, основанных на задержке сигнала, таких как:

  • Дилэй (Delay)
  • Флэнжер (Flanger)
  • Фэйзер (Phaser)
  • Хорус (Chorus)
  • Реверберация (Reverb)
О реализации данных эффектов в Cubase SX речь пойдет в главе 13.


Дилэй

Необходимость в эффекте дилэй (delay) возникла с началом применения стереофонии. Сама природа слухового аппарата человека предполагает в большинстве ситуаций поступление в мозг двух звуковых сигналов, отличающихся временами прихода. Если источник звука находится "перед глазами": на перпендикуляре, проведенном к линии, проходящей через уши, то прямой звук от источника достигает обоих ушей в одно и то же время. Во всех остальных случаях расстояния от источника до ушей различны, поэтому одно либо другое ухо воспринимает звук первым. Проведем несложные расчеты. Время задержки (разницы во времени приема сигналов ушами) будет максимальным в том случае, когда источник расположен напротив одного из ушей. Так как расстояние между ушами — около 20 см, то максимальная задержка может составлять около 6 мс. Этим величинам соответствует волна звукового колебания с частотой около 1,7 кГц. Для более высокочастотных звуковых колебаний длина волны становится меньше, чем расстояние между ушами, и разница во времени приема сигналов ушами становится неощутимой. Предельная частота колебаний, задержка которых воспринимается человеком, зависит от направления на источник. Она растет по мере того, как источник звука смещается от точки, расположенной напротив одного из ушей, к точке, расположенной перед человеком.
Дилэй применяется прежде всего в том случае, когда запись голоса или акустического музыкального инструмента, выполненную с помощью единственного микрофона, "встраивают" в стереофоническую композицию. Этот эффект служит основой технологии создания стереозаписей.
Но дилэй может применяться и для получения эффекта однократного повторения каких-либо звуков. Величина задержки между прямым сигналом и его задержанной копией в этом случае выбирается большей, чем естественная задержка в 8 мс. Какая именно задержка должна быть выбрана? Ответ на этот вопрос определяется несколькими факторами. Прежде всего, следует руководствоваться эстетическими критериями, художественной целью и здравым смыслом. Для коротких и резких звуков время задержки, при котором основной сигнал и его копия различимы, меньше, чем для протяженных звуков. Для произведений, исполняемых в медленном темпе, задержка может быть больше, чем для быстрых композиций.
При определенных соотношениях громкостей прямого и задержанного сигналов может иметь место психоакустический эффект изменения кажущегося расположения источника звука на стереопанораме. Согласитесь, что, например, "перескоки" рояля с места на место по ходу прослушивания произведения очень трудно обосновать как с эстетических позиций, так и с точки зрения верности воспроизведения реального звучания. Как и любой эффект, дилэй нужно применять в разумных пределах и не обязательно на протяжении всей композиции.
Этот эффект реализуется с помощью устройств, способных осуществлять задержку акустического или электрического сигналов. Таким устройством сейчас чаще всего служит цифровая линия задержки, представляющая собой цепочку из элементарных ячеек — триггеров задержки. Для наших целей достаточно знать, что принцип действия триггера задержки сводится к следующему: символ двоичного сигнала, поступивший в некоторый тактовый момент на его вход, появится на его выходе не мгновенно, а только в очередной тактовый момент. Общее время задержки в линии тем больше, чем больше триггеров задержки включено в цепочку, и тем меньше, чем меньше тактовый интервал (чем больше тактовая частота). В качестве цифровых линий задержки можно использовать запоминающие устройства. Известны специальные алгоритмы адресации ячеек запоминающих устройств, обеспечивающие "скольжение" информации "вдоль" адресного пространства. Разумеется, для применения цифровой линии задержки сигнал должен быть сначала преобразован в цифровую форму. А после прохождения копией сигнала линии задержки происходит цифроаналоговое преобразование. Исходный сигнал и его задержанная копия могут быть как раздельно направлены в различные стереоканалы, так и смешаны в различных пропорциях. Суммарный сигнал можно направить либо в один из стереоканалов, либо в оба.
В звуковых редакторах дилэй реализуется программным (математическим) путем за счет изменения относительной нумерации отсчетов исходного сигнала и его копии.
Возможны такие, например, разновидности задержки, при которых формируются несколько задержанных на различное время копий сигнала. Реализация эффекта delay в программе Cubase SX рассмотрена в главе 13.
В виртуальных дилэях, как и в их аппаратных прототипах, обязательно имеются регуляторы глубины и частоты модуляции задержанного сигнала, а также регулятор коэффициента обратной связи (feedback). Сигнал с выхода подается опять в линию задержки. Время затухания устанавливается регулятором обратной связи. Чтобы однократное повторение превратилось в настоящее повторяющееся эхо, коэффициент обратной связи надо увеличить. Как правило, и в реальных, и в виртуальных устройствах имеется регулятор, при помощи которого можно подобрать такое время задержки, чтобы оно соответствовало темпу композиции.


Флэнжер и фэйзер

В основу звуковых эффектов флэнжер (flanger) и фэйзер (phaser) также положена задержка сигнала.
В аналоговых устройствах флэнжер реализуется при помощи гребенчатых фильтров, которые могут строиться на линиях задержки. Характерная форма амплитудно-частотной характеристики (АЧХ) создается за счет сдвига фазы при распространении сигнала в линии задержки и сложения реализаций задержанного сигнала.
Меняя параметры гебенчатого фильтра, можно в значительной степени изменять первоначальный тембр звука.
Гребенчатая АЧХ фильтра обусловлена тем, что для некоторых частот задержанные копии сигнала складываются в фазе и поэтому усиливаются, для других частот — в противофазе и поэтому взаимоуничтожаются. Периодическая структура АЧХ определяется периодическим характером составляющих аудиосигнала (синусоид).
Совершенно не случайно в старые времена флэнжером часто пытались заменить реверберацию. Реверберация возникает за счет многократного отражения звуковых волн от стен, потолка и пола помещения. При этом звуковые колебания по пути к слушателю претерпевают различные по величине задержки (фазовые сдвиги). Имеет место интерференция колебаний. Если исследовать любое помещение с заметными реверберационными свойствами, то обнаружится, что его АЧХ имеет гребенчатую форму.
Как мы уже сказали, дилэй имитирует эффект неодновременного восприятия мозгом человека звуковых сигналов. Эффект повторного звучания может быть вызван и распространением звука от источника к приемнику различными путями (например, звук может приходить, во-первых, напрямую и, во-вторых, отразившись от препятствия, находящегося чуть в стороне от прямого пути). В том и в другом случаях время задержки остается постоянным. В реальной жизни этому соответствует маловероятная ситуация, когда источник звука, приемник звука и отражающие предметы неподвижны относительно друг друга. При этом частота звука не изменяется, каким бы путем и в какое бы ухо он ни приходил.
Если же какой-либо из трех элементов подвижен, то частота принимаемого звука не может оставаться той же, что и частота звука переданного. Это и есть проявление того самого эффекта Доплера, который в учебниках традиционно поясняется на примере изменения высоты звучания гудка движущегося паровоза.
Итак, реальные музыкальные звуки при распространении претерпевают не только расщепление на несколько звуковых волн и различную (для каждой из них) задержку, но и неодинаковое изменение частот для разных спектральных составляющих.
И флэнжер, и фэйзер имитируют (каждый по-своему) проявления взаимного перемещения упомянутых трех элементов: источника, приемника и отражателя звука. По сути дела, оба эффекта представляют собой сочетание задержки звукового сигнала с частотной или фазовой модуляцией. Разница между ними чисто количественная. Флэнжер отличается от фейзера тем, что для первого эффекта время задержки копии (или времена задержек копий) и изменение частот сигнала значительно большее, чем для второго. Образно говоря, флэнжер наблюдался бы в том случае, когда певец мчался бы к зрителю, сидящему в зале, со скоростью автомобиля. А вот для того чтобы ощутить фэйзер в его, так сказать, первозданном виде, движущегося источника звука не требуется, зрителю достаточно часто-часто вертеть головой из стороны в сторону.
Упомянутые количественные отличия эффектов приводят и к отличиям качественным: во-первых, звуки, обработанные ими, приобретают различные акустические и музыкальные свойства, во-вторых, эффекты реализуются различными техническими средствами.
Значения времени задержек, характерные для флэнжера, существенно превышают период звукового колебания, поэтому для реализации эффекта используют многоразрядные и многоотводные цифровые линии задержки. С каждого из отводов снимается свой сигнал, который в свою очередь подвергается частотной модуляции.
Для фэйзера, наоборот, характерно столь малое время задержки, что оно оказывается сравнимо с периодом звукового колебания. При таких малых относительных сдвигах принято говорить уже не о задержке копий сигнала во времени, а о разности их фаз. Если эта разность фаз не остается постоянной, а изменяется по периодическому закону, то мы имеем дело с эффектом Phaser. Так что можно считать фэйзер предельным случаем флэнжера. Но если внимательно прочитать еще раз этот абзац, то можно понять, что фэйзер — это фазовое вибрато.
Чего только ни придумывали в относительно старые времена, чтобы реализовать эти эффекты!
Например, чтобы получить флэнжер, вместо одной акустической системы использовали несколько систем, размещенных на различных расстояниях от слушателей. В определенные моменты производили поочередное подключение источника сигнала к акустическим системам таким образом, что создавалось впечатление приближения или удаления источника звука. Задержку звука выполняли и с помощью магнитофонов со сквозным трактом запись/воспроизведение. Одна головка записывает, другая — воспроизводит звук с задержкой на время, необходимое для перемещения ленты от головки к головке. Для частотной модуляции особых мер можно было и не придумывать. Каждому аналоговому магнитофону присущ естественный недостаток, называемый детонацией, которая проявляется в виде "плавания звука". Стоило чуть-чуть специально усилить этот эффект, изменяя напряжение, питающее двигатель, и получалась частотная модуляция.
Для реализации фэйзера методами аналоговой техники использовали цепочки электрически управляемых фазовращателей. А иногда можно было наблюдать и такую картину: в акустической системе, подключенной к электромузыкальному инструменту или электрогитаре, вдруг начинало вращаться что-то вроде вентилятора. Звук пересекался подвижными лопастями, отражался от них, получалась фазовая модуляция. Представляете, сколько усилий предпринималось только ради того, чтобы оживить тембр звучания инструментов! Современные звуковые редакторы позволяют без особых усилий со стороны пользователя реализовать гигантское количество различных звуковых эффектов.


Хорус

Хорус (chorus) проявляется как эффект исполнения одного и того же звука или всей партии не одним-единственным инструментом или певцом, а несколькими. Искусственно выполненный эффект является моделью звучания настоящего хора. В том, что хоровое пение или одновременное звучание нескольких музыкальных инструментов украшает и оживляет музыкальное произведение, сомнений, вероятно, нет ни у кого.
С одной стороны, голоса певцов и звуки инструментов при исполнении одинаковой ноты должны звучать одинаково, а к этому стремятся и музыканты, и дирижер. Но из-за индивидуальных различий источников звук все равно получается разным. В пространстве, тракте звукоусиления и в слуховом аппарате человека эти немного неодинаковые колебания взаимодействуют, образуются так называемые биения. Спектр звука обогащается и, самое главное, течет, переливается.
Можно считать, что предельным случаем хоруса является одновременное звучание слегка отличающихся по частоте двух источников — унисон.
Унисон был известен задолго до появления синтезаторов. В основе сочного и живого звучания двенадцатиструнной гитары и аккордеона лежит унисон. В аккордеоне, например, звук каждой ноты генерируется узлом, содержащим два источника колебаний (язычка), специально настроенных "в разлив" — с небольшой (в единицы герц) разницей в частотах. В двенадцатиструнной гитаре звук извлекается одновременно из пары струн. Разница в частотах образуется естественным путем из-за невозможности идеально одинаково настроить струны инструмента.
Вот именно наличие этой ничтожной разницы в частотах голосов певцов или инструментов и служит причиной красивого звучания унисона (для двух голосов) или хоруса (для более двух голосов).
В цифровых электромузыкальных инструментах, напротив, частоты пары вторичных генераторов могут быть получены абсолютно равными друг другу. В таком звучании отсутствует жизнь, потому что оно слишком правильное. Для оживления электронного звучания и создания впечатления игры нескольких инструментов и используют хорус.
Существует довольно много разновидностей алгоритмов хоруса. Но все они сводятся к следующему:

  • исходный сигнал разделяется на два или несколько каналов;
  • в каждом из каналов спектр сигнала сдвигают по частоте на определенную величину. Частотные сдвиги очень малы, они составляют доли Гц и в ряде случаев изменяются во времени;
  • в каждом из каналов сигнал немного задерживают во времени, причем, величина задержки может меняться (поэтому хорус относится к числу эффектов, основанных на задержке сигнала);
  • каждый из каналов позиционирует в свою точку на стереопанораме;
  • сигналы, полученные таким способом, складывают.
В итоге получается сигнал, спектр которого непрерывно изменяется, причем период полного цикла этого изменения столь велик, что повторяемость спектральных свойств сигнала не ощущается.
Хорус настолько украшает звучание инструментов, что ныне он стал одним из эффектов, имеющихся практически в каждом синтезаторе и многих звуковых картах.
Обработка аудиосигнала звуковыми редакторами позволяет получить массу разновидностей этого эффекта. Вместе с тем, не следует чрезмерно увлекаться им, так как это может привести к ухудшению разборчивости звучания голоса, к "засорению" акустической атмосферы композиции.


Реверберация

Реверберация (reverb) относится к наиболее интересным и популярным звуковым эффектам. Сущность реверберации состоит в том, что исходный звуковой сигнал смешивается со своими копиями, задержанными относительно него на различные интервалы времени. Этим реверберация напоминает ди-лэй. Отличие заключается в том, что при реверберации число задержанных копий сигнала может быть значительно больше, чем для дилэя. Теоретически число копий может быть бесконечным. Кроме того, при реверберации чем больше время запаздывания копии сигнала, тем меньше ее амплитуда (громкость). Эффект зависит от того, каковы временные промежутки между копиями сигналов и какова скорость уменьшения уровней их громкости. Если промежутки между копиями малы, то получается собственно эффект реверберации. Возникает ощущение объемного гулкого помещения. Звуки музыкальных инструментов становятся сочными, объемными, с богатым тембровым составом. Голоса певцов приобретают напевность, недостатки, присущие им, становятся малозаметными.
Если промежутки между копиями велики (более 100 мс), то правильнее говорить не об эффекте реверберации, а об эффекте "эхо". Интервалы между соответствующими звуками при этом становятся различимыми. Звуки перестают сливаться, кажутся отражениями от удаленных преград.
Первым ушей слушателя достигает прямой звук. Этот сигнал приходит к слушателю по кратчайшему пути. Поэтому интенсивность его больше, чем интенсивности других сигналов. Прямой сигнал несет информацию только о расположении источника звука справа или слева от слушателя.
Несколько отстав от прямого сигнала, затем приходят ранние (первичные) отражения. Эта составляющая звукового поля претерпевает одно — два отражения от ограждающих поверхностей (стен, пола, потолка). Взаимодействуя с поверхностями, звуковая волна не только отражается от них, но и отдает им часть своей энергии. Энергия расходуется на нагрев поверхностей. Поэтому интенсивность ранних отражений меньше (но не намного) интенсивности прямого сигнала. Ранние отражения проявляются как ясно различимые эхо-сигналы. Временные промежутки между ними достаточно велики, т. к. велики разности длин путей, по которым сигналы доходят до слушателя. Например, волна может отразиться от боковой или от тыльной стены. Возможно, что часть волн, относящихся к ранним отражениям, испытают не одно, а несколько отражений. Ранние отражения несут в себе информацию не только о месте расположения исполнителя, но и о размерах помещения. Именно данные отражения вносят наибольший вклад в пространственное ощущение акустики зала. К ранним отражениям относят те копии первичного сигнала, которые отстают от прямого сигнала не более, чем на 60 мс.
Вторичные и последующие (поздние) отражения — это звуковые волны, многократно отраженные от каждой из поверхностей. По мере увеличения числа переотражений интенсивность аудиосигнала заметно уменьшается. Кроме того, изменяется спектральный состав звуковых колебаний. Дело в том, что из-за различий в конфигурации отражающих поверхностей л в свойствах материалов покрытий разные спектральные составляющие аудиосигнала отражаются не одинаково. Какие-то из них поглощаются сильнее, поэтому затухают быстрее.
По мере возрастания номеров вторичных отражений они рассеиваются, их число увеличивается. Постепенно они перестают восприниматься как отдельные звуки, сливаются в один сплошной постепенно затухающий отзвук. Это и есть собственно реверберация.
Теоретически затухание звука длится бесконечно. На практике, для того чтобы можно было сравнивать между собой различные реверберационные процессы (а главное реверберационные свойства помещений), введено понятие времени реверберации. Время реверберации — это такое время, за которое уровень реверберирующего сигнала уменьшается на 60 дБ.
Основным элементом, реализующим эффект реверберации, является устройство, создающее эхо-сигнал.
Интересна история развития таких устройств. Первоначально радиостудии и солидные концертные залы содержали эхо-камеры. Эхо-камера представляет собой комнату с отражающими стенами, в которую помещен источник звукового сигнала (громкоговоритель) и приемник (микрофон). По сути дела, такая эхо-камера является уменьшенной моделью реального зрительного зала, в котором не всегда удается создать необходимую акустическую атмосферу. В эхо-камере с трудом, но можно было в некоторых пределах управлять распределением интенсивностей и времен распространения переотраженных сигналов, устанавливая отражающие или поглощающие звук перегородки. Преимущество эхо-камеры состоит в том, что затухание звука происходит в ней естественным путем (что очень трудно обеспечить другими способами имитации эффекта реверберации). В то время как звук продолжает реверберировать в трех измерениях, волна разбивается на множество отражений, которые достигают микрофона во все более уменьшающиеся промежутки времени задолго до того, как звук полностью затихнет. Недостатки эхо-камер связаны с их относительно малыми размерами, при этом вследствие собственных резонансов помещения спектр сигнала искажается в области средних частот. Определенную проблему представляет надежная звукоизоляция помещения эхо-камеры. Но самое главное заключается в том, что эхо-камера не может служить распространенным инструментом получения искусственной реверберации, так как она слишком дорога и громоздка.
Наряду с эхо-камерами для имитации реверберации использовали стальные пластины, точнее довольно-таки большие листы. Колебания в них вводили и снимали с помощью устройств, по конструкции и принципу действия похожих на электромагнитные головные телефоны. Для получения удовлетворительной равномерности амплитудно-частотной характеристики толщина листа должна быть выдержана с точностью, которую не позволяют достичь обычные технологии проката стали. Реверберация здесь была не трехмерной, а плоской. Сигнал имел характерный металлический призвук.
В середине 60-х годов XX века для получения эффекта реверберации стали применять пружинные ревербераторы. С помощью электромагнитного преобразователя, соединенного с одним из концов пружины, в ней возбуждаются механические колебания, которые с задержкой достигают второго конца пружины, связанного с датчиком. Эффект повторения звука обусловлен многократным отражением волн механических колебаний от концов пружины.
Качество звука в пружинном ревербераторе чрезвычайно низкое. Пружина воспринимает любые колебания воздуха и пола, между акустической системой и пружиной существует практически неустранимая обратная связь, звук имеет ярко выраженную "металлическую" окраску. Время реверберации не регулируется.
На смену этим несовершенным устройствам пришли ревербераторы магнитофонные. Принцип формирования в них эхо-сигнала состоит в том, что исходный сигнал записывается на ленту записывающей магнитной головкой, а через время, необходимое для перемещения данной точки ленты к воспроизводящей головке, считывается ею. Через цепь обратной связи уменьшенный по амплитуде задержанный сигнал вновь подается на запись, что и создает эффект многократного повторения звука с постепенным затуханием. Качество звука определяется параметрами магнитофона. Недостаток магнитофонного ревербератора заключается в том, что при приемлемых скоростях протяжки ленты удается получить только эффект эха. Для получения собственно реверберации требуется либо еще сильнее сблизить магнитные головки (чего не позволяет сделать их конструкция), либо значительно увеличить скорость протяжки ленты.
С развитием цифровой техники и появлением интегральных микросхем, содержащих в одном корпусе сотни и тысячи цифровых элементов задержки, появилась возможность создавать высококачественные цифровые ревербераторы. В таких устройствах сигнал может быть задержан на любое время, необходимое как для получения реверберации, так и для получения эха. Ревербератор отличается от цифрового устройства, реализующего дилэй, только тем, что содержит обратную связь (feedback), необходимую для формирования затухающих повторений сигнала.
Цепь обратной связи отсылает часть сигнала с выхода обратно в линию задержки, тем самым получается повторяющееся эхо. Коэффициент обратной связи должен быть меньше единицы, иначе каждое новое эхо будет возрастать по уровню, а не затухать. Может получиться эффект, подобный самовозбуждению акустической системы.
В некоторых виртуальных ревербераторах предусмотрен модулятор фазы. Его действие проявляется в том, что при коротком времени затухания возникает едва заметное изменение тона.
В звуковых картах реверберация, в конечном счете, основана именно на цифровой задержке сигналов. Поэтому может показаться лишним рассказ об остальных способах создания этого эффекта. Но в наши дни не счесть звуковых редакторов, в которые встроена та самая эхо-камера. Конечно, не само гулкое помещение втиснуто в компьютер, а его математическая модель. Для чего это понадобилось делать? Эхо-камера принципиально отличается от всех остальных устройств тем, что реверберация в ней настоящая: трехмерная, объемная. Во всех же остальных устройствах это и не реверберация даже, а ее плоское, двумерное (а то и одномерное) подобие. Модель эхо-камеры позволяет воссоздавать акустику любого помещения. Она даже лучше, чем настоящая эхо-камера, потому что допускает оперативное изменение размеров моделируемого помещения и отражающих свойств стен, пола, потолка. Более того, это не одна, а целых две эхо-камеры, с отдельно устанавливаемыми координатами источников и приемников звука. И это еще не все. Во многих программах, предназначенных для синтеза голосов новых музыкальных инструментов, смоделирован и эффект реверберации, как бы реализуемый с помощью того самого стального листа. Наблюдая такое развитие средств реверберации, можно предположить, что когда-нибудь появятся и математические модели пружинных и магнитофонных ревербераторов. Ведь совсем не исключено, что есть люди, испытывающие ностальгические чувства по отношению к звукам музыки, окрашенным дребезгом пружин или шипением магнитной ленты.
Варианты виртуальных ревербераторов, реализованных в программе Cubase SX, рассмотрены в главе 13.


1.9.3. Дистошн

Дистошн (distortion) — преднамеренное искажение формы аудиосигнала, придающее ему резкий, скрежещущий оттенок. Чаще всего дистошн применяется в качестве гитарного эффекта. Получается перегрузкой усилителя вплоть до появления в усилителе ограничений и даже его самовозбуждения. Благодаря этому сигнал становится похож на прямоугольный, отчего в нем появляется большое количество новых гармоник, резко расширяющих спектр. Этот эффект применяется в нескольких вариациях (fuzz, overdrive и т. п.), различающихся:

  • способом ограничения сигнала (обычное или сглаженное, весь спектр или полоса частот, весь амплитудный диапазон или его часть);
  • соотношением исходного и искаженного сигналов в выходном миксе;
  • частотными характеристиками усилителей (наличие/отсутствие фильтров на выходе).
Варианты эффекта дистошн, реализованные в программе Cubase SX, рассмотрены в главе 13.


1.9.4. Вокодер

Вокодер (voice coder) — устройство синтеза речи на основе произвольного входного сигнала с богатым спектром. Речевой синтез реализуется обычно при помощи формантных преобразований: выделение из сигнала с достаточным спектром нужного набора формант с нужными соотношениями придает сигналу свойства соответствующего гласного звука. Изначально вокодеры использовались для передачи кодированной речи. Путем анализа исходного речевого сигнала из него выделяется информация об изменении положений формант при переходе от звука к звуку. Эта информация кодируется и передается по линии связи, а на приемном конце блок управляемых фильтров и усилителей синтезирует речь заново.
Подавая на блок речевого синтеза сигнал, например электрогитары, и произнося слова в микрофон блока анализа, можно получить эффект "разговаривающей гитары". При подаче сигнала с синтезатора получается "голос робота". А если подать сигнал, близкий по спектру к колебаниям голосовых связок, но отличающийся по частоте, то изменится регистр голоса — мужской на женский или детский, и наоборот.
Виртуальный вокодер, входящий в состав Cubase SX, рассмотрен в главе 13.


1.9.5. Pitch Shifter — изменение высоты тона

Большинство реальных и виртуальных устройств обработки звука имитируют эффекты, которые существуют в природе. Но устройства изменения высоты тона (Pitch Shifter) относятся к совершенно особому типу процессоров, так как тот сигнал, что получается в результате их работы, не.имеет аналога в окружающем мире.
Pitch Shifter делает интересное преобразование: он позволяет получить копию входного сигнала, но высота тона этой копии может быть изменена на величину от нескольких центов до октавы и более.
Принцип действия Pitch Shifter в общем заключается в том, что сигнал записывается в память с фиксированной скоростью, а считывание может производиться быстрее или медленнее — в зависимости от того, вверх или вниз относительного входного сигнала должен быть изменен тон.
Сигнал с измененной высотой тона может быть задержан по отношению к входному. Это используется для более натурального имитирования искусственного унисона: два инструмента играют одно и то же, но есть небольшая разница во времени и высоте.
На этом позвольте завершить рассказ о сущности основных эффектов, имеющихся в музыкальных и звуковых редакторах.


1.10. Сущность наиболее важных обработок

Из числа различных обработок, реализованных в звуковых редакторах, чаще всего применяются на практике две их разновидности: частотная фильтрация и преобразование динамического диапазона. Сейчас мы ограничимся лишь самыми необходимыми сведениями.


1.10.1. Частотная фильтрация

Фильтрация — это процесс обработки электрического звукового сигнала частотноизбирательными устройствами с целью изменения спектрального состава (тембра) сигнала. Задачами такой обработки могут быть:

  • амплитудно-частотная коррекция сигнала (усиление или ослабление отдельных частотных составляющих);
  • полное подавление спектра сигнала или шумов в определенной полосе частот.
Например, если микрофон, акустическая система или еще какой-либо элемент звукового тракта имеют неравномерную амплитудно-частотную характеристику, то с помощью фильтров эти неравномерности могут быть сглажены. Если в результате анализа спектра выяснилось, что в некоторой области частот в основном сосредоточена энергия помех, а энергии сигнала совсем немного, то посредством фильтрации все колебания в этом диапазоне частот можно подавить.
Для осуществления фильтрации созданы самые различные устройства: отдельные корректирующие и формантные фильтры, устройства для разделения звука на несколько каналов по частотному признаку (кроссоверы), двухполосные и многополосные регуляторы тембра (эквалайзеры), фильтры присутствия и т. д.
Основой фильтров, реализованных программным путем в составе звуковых редакторов, служит спектральный анализ. Любой реальный сигнал может быть представлен в виде набора коэффициентов разложения в ряд по гармоническим функциям. Фильтрация сводится к умножению спектральных коэффициентов на соответствующие значения передаточной функции фильтра. Если спектр представлен в комплексной форме, то сигнал описывается совокупностью амплитудного и фазового спектров (АС и ФС), а фильтры — амплитудно-частотными и фазо-частотными характеристиками (АЧХ и ФЧХ). АЧХ представляет собой зависимость коэффициента передачи фильтра от частоты. ФЧХ отражает сдвиг фазы выходного сигнала по отношению ко входному в зависимости от частоты. В этом случае фильтрация эквивалентна перемножению АС на АЧХ и алгебраическому сложению ФС с ФЧХ.
Классический спектральный анализ из-за наличия большого количества операций перемножения занимает очень много процессорного времени и при значительном числе отсчетов сигнала неосуществим в реальном темпе обработки. Для сокращения времени спектрального анализа дискретных сигналов разработаны специальные алгоритмы, учитывающие наличие связей между различными отсчетами сигнала и устраняющие повторяющиеся операции. Одним из таких алгоритмов является быстрое преобразование Фурье (БПФ).
В зависимости от расположения полосы пропускания на оси частот фильтры подразделяются на:
  • фильтры нижних частот (ФНЧ) (Low Pass), типичные АЧХ и ФЧХ которых показаны на рис. 1.22;
  • фильтры верхних частот (ФВЧ) (High Pass), их АЧХ и ФЧХ показаны на рис. 1.23;
  • полоснопропускающие (полосовые) фильтры (Band Pass) (рис. 1.24);
  • полоснозадерживающие (режекторные) фильтры (Band Stop) (рис. 1.25).
На рисунках по горизонтальным осям отложено значение частоты, по вертикальным осям отложены значения передаточных функций K(f) или фазовых сдвигов [image] (t) в зависимости от частоты.
Тот участок АЧХ, где коэффициент передачи не равен нулю, соответствует полосе пропускания фильтра. В полосе задерживания (или подавления), напротив, коэффициент передачи фильтра должен быть минимальным (в идеальном случае нулевым).
Характеристики, представленные на рис. 1.22-1.25 являются идеализированными: реальные фильтры, строго говоря, не позволяют обеспечить равенство передаточной функции нулю вне полосы пропускания. Колебания в полосе подавления пусть и значительно ослабленные, все равно проникают через фильтр.
Реальные фильтры низких и высоких частот характеризуются следующими основными параметрами:
  • частотой среза;
  • шириной полосы пропускания;
  • неравномерностью характеристики в полосе пропускания;
  • крутизной ската характеристики в области перехода от полосы пропускания к полосе задерживания.
Для полосового фильтра добавляется еще один параметр — добротность, под которой понимают отношение центральной частоты фильтра к полосе его пропускания.

Рис. 1.22. АЧХ и ФЧХ фильтра

Рис. 1.23. АЧХ и ФЧХ фильтра нижних частот верхних частот

Рис. 1.24. АЧХ и ФЧХ полосового

Рис. 1.25. АЧХ и ФЧХ режекторного фильтра фильтра

Весьма распространенной ошибкой является пренебрежение учетом влияния на форму сигнала фазо-частотной характеристики фильтра. Фаза важна потому, что сигнал, прошедший через фильтр без изменения амплитуды в полосе пропускания, может быть искажен по форме, если временное запаздывание при прохождении через фильтр не будет постоянным для разных частот. Одинаковое время задержки соответствует линейной зависимости фазы от частоты. Из рисунков видно, что для ФНЧ и ФВЧ зависимость фазы от частоты можно считать линейной лишь в окрестностях частот среза, а для полосового фильтра — в окрестностях резонансной (центральной) частоты. Таким образом, следует ясно представлять себе, что фильтрация широкополосных звуковых колебаний будет обязательно сопровождаться фазовыми искажениями, приводящими к изменению формы фильтруемого сигнала.
Работая со звуковыми редакторами, вы будете часто пользоваться эквалайзерами.
Эквалайзеры представляют собой устройства, объединяющие в себе несколько фильтров, предназначенные для изменения спектральных свойств (тембра) обрабатываемого сигнала. Первоначально эквалайзер (equalizer, EQ), в основном, выполнял функции устройства, компенсирующего неравномерность того или иного участка тракта усиления и преобразования звукового сигнала.
При наличии эквалайзера можно как бы выровнять исходно неровную АЧХ. Известны несколько различных по назначению и по устройству типов эквалайзеров, среди них есть и те, с которыми вы встретитесь, пользуясь Cubase SX:

  • графический эквалайзер;
  • параметрический эквалайзер;
  • фильтр присутствия.
Графический эквалайзер — это набор полосовых фильтров с фиксированными центральными частотами и переменным коэффициентом усиления, которым можно управлять при помощи слайдера. В качестве регуляторов принято использовать именно ползунки, так как положение их ручек представляет собой некое подобие графика АЧХ эквалайзера. Именно поэтому такие эквалайзеры принято называть "графическими" — пользователь как бы рисует ползунками необходимую ему кривую АЧХ.
Итак, графический эквалайзер — это набор полосовых фильтров, которые полностью отделяют друг от друга определенные полосы частот. Для того чтобы иметь возможность управлять частотной характеристикой во всей области звуковых частот, такие фильтры соединены параллельно. На вход всех фильтров подается один и тот же сигнал, и задача каждого фильтра состоит в том, чтобы усилить или ослабить "свой" участок спектра в соответствии с положением регулятора коэффициента усиления (слайдера).
Частоты, на которых осуществляется регулирование в графических эквалайзерах, унифицированы и выбираются из ряда стандартных частот, перекрывающих весь звуковой диапазон и отстоящих друг от друга на некоторый интервал. Этот интервал может составлять октаву, ее половину или треть октавы. Наибольшие возможности, естественно, имеют третьоктавные графические эквалайзеры, которые в силу этого и получили наибольшее распространение. Число полос регулирования может составлять до 31 в серьезных профессиональных моделях.
Самый низкочастотный фильтр эквалайзера не обязательно должен быть полосовым, он может быть и фильтром нижних частот. Аналогично самый высокочастотный фильтр может быть фильтром верхних частот.
Наиболее часто графические эквалайзеры применяются для обработки суммарного сигнала, "доводки" общей картины, а не фильтрации отдельных составляющих. С помощью графического эквалайзера можно приближенно сформировать необходимую АЧХ системы обработки звука или акустической системы: поднять усиление в одних областях спектра и уменьшить его в других. Однако графический эквалайзер (даже многополосный) мало пригоден для ювелирной частотной коррекции. Ведь центральные частоты фильтров неизменны. Они могут и не совпадать в точности с теми частотами, на которых следует подчеркнуть или, напротив, подавить спектральные составляющие. В подобных случаях на помощь приходит параметрический эквалайзер.
Параметрический эквалайзер позволяет управлять не только коэффициентом усиления фильтра, но и его центральной частотой, а также добротностью (по существу, шириной полосы пропускания). При наличии некоторого опыта вы сможете точно устанавливать значения этих параметров таким образом, чтобы подчеркнуть звук отдельного инструмента или удалить нежелательную помеху (например, фон 50 Гц или частоту самовозбуждения акустической системы) с минимальным влиянием на остальные элементы звукового образа.
Для формирования АЧХ сложного вида применяются многополосные параметрические эквалайзеры, параметры каждого из которых можно изменять независимо.
Фильтр присутствия (presence) позволяет добиться впечатления, что звучащий инструмент (или певец) находится в одной комнате со слушателем. На самом деле это не что иное, как регулируемый полосовой фильтр, центральная частота которого лежит где-то в диапазоне от 2 до 6 кГц.
Подробнее о фильтрах и их применении вы можете прочитать в кни-ге [12].


1.10.2. Динамическая обработка

О сущности динамической обработки мы ограничимся лишь изложением кратких сведений о назначении различных приборов динамической обработки, работа которых моделируется в Cubase SX.
В зависимости от выполняемых функций различают следующие приборы динамической обработки:

  • ограничители уровней;
  • компрессоры динамического диапазона;
  • экспандеры динамического диапазона;
  • пороговые шумоподавители (гейты).
Ограничитель уровня (лимитер) — это авторегулятор уровня, у которого коэффициент передачи изменяется так, что при превышении номинального уровня входным сигналом уровни сигналов на его выходе остаются практически постоянными, близкими к номинальному значению. При входных сигналах, не превышающих номинального значения, ограничитель уровня работает как обычный линейный усилитель. Лимитер должен реагировать на изменение уровня мгновенно.
Компрессор — такое устройство, коэффициент передачи которого возрастает по мере уменьшения уровня входного сигнала.
Действие компрессора приводит к повышению средней мощности и, следовательно, громкости звучания обрабатываемого сигнала, а также к сжатию его динамического диапазона.
Экспандер имеет амплитудную характеристику, обратную по отношению к амплитудной характеристике компрессора. Экспандер применяют в том случае, когда необходимо восстановить динамический диапазон, предварительно преобразованный компрессором. Система, состоящая из последовательно включенных компрессора и экспандера, называется компандером. Она используется для снижения уровня шумов в трактах записи или передачи звуковых сигналов.
Пороговый шумоподавителъ (гейт) — это авторегулятор, у которого коэффициент передачи изменяется так, что при уровнях входного сигнала меньше порогового амплитуда сигнала на выходе близка к нулю. При входных сигналах, уровень которых превышает пороговое значение, пороговый шумопо-давитель работает как обычный линейный усилитель.
Любой прибор динамической обработки в своем составе имеет два функциональных элемента — основной канал и канал управления.
Задача канала управления заключается в обнаружении момента пересечения аудиосигналом порогового значения, измерении уровня аудиосигнала относительно порога и выработке управляющего напряжения.
Результат обработки зависит от вида характеристики регулируемого элемента основного канала. Например, если с ростом управляющего напряжения, подаваемого на регулируемый элемент, его коэффициент передачи уменьшается, то получается компрессор, если увеличивается, то — экспандер.
Оценку инерционности устройств динамической обработки осуществляют на основе анализа двух временных характеристик: времени срабатывания и времени восстановления.
Для регулируемых звеньев всех устройств динамической обработки кроме гейта срабатыванием принято считать реакцию устройства на увеличение уровня сигнала, а восстановлением — на его уменьшение. Время срабатывания — это интервал между моментом, когда от источника начинает подаваться сигнал с уровнем на 6 дБ выше номинального значения, и моментом, когда выходной уровень уменьшается с 6 дБ до 2 дБ по отношению к номинальному значению.
Время восстановления — это интервал между моментом, когда уровень сигнала от источника снижается с 6 дБ до номинального значения 0 дБ, и моментом, когда выходной уровень увеличивается от —6 до —2 дБ по отношению к номинальному значению.
Для гейта срабатыванием принято считать уменьшение усиления при пропадании полезного сигнала, а восстановлением — восстановление усиления при появлении полезного сигнала.
Одной из наиболее часто применяемой разновидностью динамической обработки является компрессия — сжатие динамического диапазона.
Субъективно компрессия проявляется как увеличение громкости звука. Он становится более "плотным". И это не удивительно. Ведь в результате компрессии можно достичь увеличения средней мощности неискаженного сигнала. По сути дела компрессия сводится к автоматическому управлению усилением. Когда уровень сигнала становится слишком большим, усиление уменьшается, а при нормальном уровне сигнала усилению возвращается исходное значение.
Результат компрессии зависит от правильного выбора значений нескольких основных параметров. К важнейшим из них относятся:
  • порог срабатывания (Threshold);
  • коэффициент компрессии или коэффициент сжатия (Compression Ratio);
  • компенсирующее усиление (Makeup Gain);
  • время атаки (Attack Time);
  • время восстановления (Release Time).
Порог срабатывания определяет уровень, при превышении которого компрессор начинает управлять усилением (иногда говорят, что он находится в активном состоянии). До тех пор пока значение уровня сигнала меньше порогового, компрессор не воздействует на сигнал (компрессор находится в пассивном или выключенном состоянии). От величины порога зависит, коснется ли обработка только отдельных пиков или сигнал будет подвергаться компрессии постоянно.
Коэффициент компрессии (сжатия) определяет степень сжатия динамического диапазона сигнала, имеющего уровень выше порогового. Численно он равен отношению уровня сигнала на выходе работающего компрессора к уровню сигнала на его входе.
Например, коэффициент компрессии 2:1 означает, что изменение уровня входного сигнала на 2 дБ вызовет изменение уровня выходного сигнала только на 1 дБ. На практике именно такое отношение часто применяется, хотя иногда приходится устанавливать более высокие значения. Если коэффициент компрессии установлен, скажем, в пропорции 20:1 и больше, то получается режим ограничения. Это значит, что если на входе появляется сигнал, превышающий установленный уровень, то сигнал на выходе практически не будет усилен.
Абсолютному ограничению соответствует коэффициент компрессии "Бесконечность:!", но на практике величины отношений больше, чем 20:1, дают такой же эффект.
Время атаки определяет, насколько быстро компрессор будет реагировать на сигналы с уровнем выше порогового.
При больших значениях параметра Attack Time компрессор, вероятнее всего, не будет успевать отслеживать резкие увеличения уровня входного сигнала. В сигнале на выходе компрессора будут присутствовать пики.
Если значение параметра Attack Time мало, то можно практически исключить возникновение пиков сигнала при скачкообразном увеличении его уровня. Однако при этом звучание может стать недостаточно акцентированным.
Время восстановления — это время, за которое компрессор выходит из активного состояния после падения уровня сигнала ниже порогового.
Если время восстановления слишком велико, то компрессор дольше находится в активном состоянии и воздействует на динамический диапазон даже тогда, когда это нежелательно. Это дает заметный на слух эффект пульсации звука, так как компрессия не приводит к сглаживанию сигнала.
При малом времени восстановления обеспечивается более существенное сглаживание. Но в тех ситуациях, когда уровень входного сигнала постоянно колеблется в окрестностях порогового значения, возможно возникновение эффекта "захлебывания".
Подбор оптимального времени восстановления основан на поиске компромисса. Обычно рекомендуется для инструментальной музыки в качестве грубого приближения и отправной точки для более тонкой настройки выбирать время восстановления около 500 мс. Это соответствует промежутку между двумя тактами при темпе 120 четвертей в минуту.
Восприятие музыки зависит от динамического диапазона, так как динамика позволяет передать эмоциональное содержание. Если совершенно сгладить динамику, сделать один неизменный средний уровень, то получится музыка, которую неинтересно слушать.
Неопытный вокалист обычно допускает большие перепады в громкости. В результате некоторые слова тонут в общем звучании музыки, а другие, наоборот, слышны слишком громко. Поэтому при записи вокала всегда используется компрессия.
Когда у вокалиста есть проблемы с шипящими звуками, а смена типа микрофона и его расположения не приводит к исправлению ситуации, тогда при сведении стоит использовать компрессор в режиме деэсера, в котором устраняются свистящие и шипящие согласные в вокальной партии. Если путем фильтрации при помощи внешнего эквалайзера подавить все низкие частоты, поступающие на вход канала управления, компрессор будет реагировать только на высокочастотные звуки. В таком случае сигнал, управляющий компрессором, формируется только из тех компонентов исходного аудиосигнала, что составляют свист и шипение. В этом и заключается принцип действия деэсера. Выбор частотных составляющих, на которые надо повлиять, производится на слух. Эквалайзер, включенный в канал управления компрессором, должен усиливать частоты в области 4-10 кГц. Однако нужно подобрать точную АЧХ.


1.11. Измерители и анализаторы

Заниматься записью и преобразованием звуковых данных вслепую, не измеряя их параметров, а значит и не представляя себе их свойств, нет никакого смысла. В распоряжении современного звукорежиссера имеется большое количество самых разнообразных измерительных приборов, позволяющих оперативно контролировать ход записи и редактирования звука. С их помощью можно своевременно обнаружить факт возникновения искажений, выявить то место в студийном комплексе, где возникают искажения, и выработать правильное решение, направленное на устранение искажений. И даже когда аппаратура работает нормально, то, если вы хотите получить звук высокого качества, без измерений все равно не обойтись. Наибольшую пользу способны принести те измерительные приборы, которые визуализируют какие-либо параметры звуковых колебаний. К числу таких приборов можно отнести: осциллограф, измеритель уровня сигнала, анализатор спектра, измеритель статистических характеристик сигнала и анализатор качества стереосигнала. Здесь же в силу ограниченности объема данного издания мы кратко остановимся лишь на приборах тех двух видов, виртуальные аналоги которых представлены непосредственно в программе Cubase SX: измерителе уровня сигнала и анализаторе спектра.


1.11.1. Измеритель уровня аудиосигнала

Мы ограничимся изложением того минимума сведений, который необходим для успешной работы с программой Cubase SX.
Уровень аудиосигнала характеризует сигнал в определенный момент и представляет собой выраженное в децибелах выпрямленное и усредненное за некоторый предшествующий промежуток времени напряжение аудиосигнала.
Теоретически наиболее просто усреднять мгновенное значение выпрямленного напряжения с постоянным весовым коэффициентом.
Вид зависимости уровня сигнала от времени определяется как особенностями самого аудиосигнала, так и выбранным интервалом усреднения Т.
При Т -> 0 временные зависимости средних значений выпрямленного сигнала практически не отличаются от временных зависимостей его мгновенных значений.
При увеличении Т средние значения выпрямленного сигнала будут тем меньше меняться во времени, чем больше интервал усреднения Т. Данные обстоятельства нужно учитывать, пользуясь измерителями уровня сигнала. Выбор Т -> 0 соответствует пиковому измерителю уровня. При малых значениях Т речь идет о квазипиковых измерителях. Большие значение Т означают, что вы имеете дело со среднеквадратическим измерителем уровня (RMS-измерителем уровня). В этом названии нет ничего странного: вычисление среднеквадратического значения эквивалентно операции усреднения модуля функции.
Слуховое ощущение в каждый момент текущего времени определяется не только мгновенным значением сигнала в этот момент, но и предыдущими его значениями. Последние сказываются на слуховом ощущении тем меньше, чем раньше они появились по отношению к текущему моменту. Поэтому при определении уровня аудиосигнала усреднение его выпрямленных мгновенных значений следует выполнять не с постоянным, а с переменным множителем веса, убывающим в направлении прошедшего времени. Наиболее подходящим приближением, достаточно хорошо соответствующим реальным свойствам человеческого слуха, является экспоненциальная весовая функция.
Изменяющееся во времени выпрямленное напряжение, усредненное за определенный период с заданным множителем веса и выраженное в децибелах, называется динамическим уровнем аудиосигнала.
Уровень определяется не только мгновенными значениями аудиосигнала, но и временной зависимостью множителя веса и длительностью "памяти" измерительного устройства. Поэтому, говоря об уровнях, следует обязательно учитывать временные характеристики приборов, которыми они измерены.
Если, подводя итог, ограничиться одной фразой, то можно сказать, что уровень сигнала — это результат усреднения значений сигнала. Причем усреднение производится особым образом и за определенный интервал времени.
Итак, до начала записи необходимо установить уровень сигнала, поступающего на аналого-цифровой преобразователь (АЦП) звуковой карты. Сложнее всего дело с выбором уровня сигнала обстоит при записи с микрофона.
Напомним, что уровень сигнала измеряется в логарифмических единицах децибелах (дБ). Номинальный уровень соответствует 0 дБ. С одной стороны, уровень сигнала должен быть достаточно велик, чтобы разрядность звуковой карты использовалась эффективно. Если усиление тракта, предшествующего АЦП, установлено, например, таким, что в пиках уровень достигает отметки —3 дБ, это означает, что из 16 бит АЦП своей звуковой карты вы фактически используете только 15. Если максимальный уровень сигнала еще ниже, то и эквивалентная разрядность АЦП будет еще меньше.
С другой стороны, сигнал не должен превышать уровня 0 дБ. Иначе произойдет переполнение разрядной сетки АЦП, что проявит себя как очень неприятные на слух нелинейные искажения.
По этим двум причинам между микрофоном и входом звуковой карты хорошо бы включить компрессор, сужающий динамический диапазон сигнала. Фактически компрессор сглаживает разницу между самыми тихими и самыми громкими звуками. И разряды АЦП используются "с толком", и вероятность перегрузки уменьшается. Но если компрессора у вас нет, можно попросить исполнителя либо стараться петь без значительных перепадов в громкости, либо регулировать уровень записываемого сигнала путем приближения и удаления по отношению к микрофону. Правда, это требует от певца наличия определенных навыков, да и тембр голоса оказывается различным при расположении микрофона на разном удалении от источника звука.
Если у вас имеется аппаратный микшер, то уровень громкости вы можете регулировать вручную. С помощью микшера, встроенного в звуковую карту, нечего и думать об оперативном регулировании уровня сигнала. Слишком на малое число ступенек "разбита" характеристика регулятора уровня входного сигнала микшера звуковой карты. Поэтому плавной регулировки не получится. Уровень будет изменяться сразу на значительную величину. Скачки громкости будут явно заметны на слух. Однако именно с помощью микшера звуковой карты перед началом сеанса записи вам следует произвести необходимую коммутацию и установить оптимальный уровень входного сигнала. Хотя, заметим, не всегда эту удастся сделать, некоторые драйверы не предоставляют доступа к регулятору уровня входного сигнала звуковой карты. В этом случае ничего не остается, как только регулировать уровень с помощью элементов управления аппаратною микшера, подключенного к аудиовходу звуковой карты.
А теперь наступило время отыскать в Cubase SX место, где располагается измеритель уровня. Точнее говоря, таких мест несколько. Укажем для начала только два из них. Один экземпляр измерителя уровня находится в окне Cubase SX Project в секции атрибутов треков в поле каждого из треков. Им можно пользоваться в том случае, когда масштаб изображения по вертикали увеличен до максимального предела (рис. 1.26).

Рис. 1.26. Окно Cubase SX Project. Отображается аудиотрек и два измерителя уровня

Второй экземпляр измерителя уровня расположен в поле инспектора. Чтобы увидеть его, нужно щелкнуть на значке [image] расположенном в правом верхнем углу панели Channel. В результате панель развернется (рис. 1.26), и мы увидим, что на ней кроме измерителя уровня располагается еще ряд элементов, относящихся к данному треку. Заметим, что среди них есть и регулятор уровня сигнала, снимаемого с выхода трека.
Если и физическое, и логическое подключения источника звукового сигнала выполнены верно и, следовательно, сигнал поступает на входной аудиопорт трека, то измеритель уровня будет функционировать. Высота светящегося столбика (индикатора уровня) будет изменяться в соответствии с изменением уровня сигнала. Значения локальных максимумов уровня будут отображаться в поле, расположенном над индикатором.
Определенная информация об уровне сигнала содержится в цвете свечения сегментов индикатора. Если верхушка индикатора в основном окрашена в желтый цвет, то это означает, что выбран оптимальный уровень. Когда индикатор не выходит за пределы синей и зеленой зоны — уровень занижен. Наличие красных всплесков свидетельствует о случаях перегрузки — уровень завышен.
Цветовое отображение информации всегда наглядно. И в данном случае разработчики тоже нашли хорошее решение, но приходится признать, что определенное неудобство составляет отсутствие разметки шкалы измерителя уровня. Те безымянные деления, что видны слева от него, относятся не к измерителю, а к регулятору. А точное значение коэффициента передачи регулятора в дБ отображается и устанавливается в поле ввода, которое находится под регулятором.


1.11.2. Анализатор спектра аудиосигнала

О спектральной форме представления сигнала ограничимся лишь пояснением основных терминов.


Классический спектр

Начать разбираться в сущности спектральных представлений лучше с разложения в ряд Фурье периодического сигнала. Всякая периодическая функция (с ограничениями, носящими абстрактный характер) может быть представлена в виде разложения в ряд по тригонометрическим функциям

(1.1)

Таким образом, периодическая функция s(t) представлена суммой слагаемых, каждое из которых есть не что иное, как косинусоидальное колебание с амплитудой сk и начальной фазой [image].
Совокупность коэффициентов сk называется амплитудным спектром сигнала, а [image] — фазовым спектром.
Частоты всех синусоидальных колебаний, из которых составляется периодическая функция s(t), кратны основной частоте F =1/Т. Отдельные составляющие называются гармониками. Колебание с частотой F называется первой гармоникой (k = 1), с частотой 2F— второй гармоникой (k = 2) и т. д.
Ряд Фурье дает разложение периодической функции по тригонометрическим функциям. Это разложение можно применить и к непериодической функции, которую рассматривают как предельный случай периодической функции при неограниченном возрастании периода.
Если Т-> [image], то F-> df, a 2pk/T-> w (параметр w— круговая текущая частота, изменяющаяся непрерывно). Не хотелось бы здесь рассказывать подробно обо всех математических преобразованиях, которые необходимо выполнить при таком предельном переходе. Поэтому сразу приведем итоговые формулы, которые являются основными соотношениями теории спектров. Они представляют собой пару преобразований Фурье, связывающих между собой две функции: вещественную функцию времени s(t) и комплексную функцию частоты G(w):

Формула (1.2) называется интегралом Фурье в комплексной форме. В данном случае предполагается, что функция непериодическая, поэтому она может быть представлена только суммой бесконечно большого числа бесконечно близких по частоте колебаний с бесконечно малыми амплитудами.
Если ряд Фурье представляет периодическую функцию суммой хотя и бесконечного числа синусоид, но с частотами, имеющими определенные дискретные значения, то интеграл Фурье представляет непериодическую функцию суммой синусоид и косинусоид с непрерывной последовательностью частот. Иногда говорят, что в .составе непериодического сигнала есть колебания всех частот. В случае непериодического сигнала говорить об амплитудах отдельных спектральных составляющих нет смысла, т. к. это бесконечно малые величины. На самом деле параметр G(w) выражает не непосредственно амплитуду, а так называемую спектральную плотность. Обычно эту деталь опускают и называют G(w) комплексным спектром непериодической функции, а абсолютное значение этой величины — просто спектром.
В специальной литературе можно найти теоремы, позволяющие облегчить спектральные преобразования сигналов, а также соотношения и графики, описывающие спектры сигналов различной формы.


Текущий спектр

Классическое определение спектра основывается на преобразовании Фурье, причем интегрирование по времени выполняется в бесконечных пределах и спектр зависит только от частоты. Однако бесконечная длительность какого-либо процесса — это абстракция, не имеющая ничего общего с реальностью.
Если анализируемая функция есть отображение некоторого реального физического процесса, то сведения о функции С(w) мы получаем лишь в результате наших наблюдений. Следовательно, при вычислении спектра мы можем выполнить интегрирование лишь от момента начала анализа до текущего момента времени t, а не до момента, устремленного в бесконечное будущее.
Текущий спектр определяется как результат преобразования Фурье, но с переменным верхним пределом интегрирования, в качестве которого фигурирует текущее время. Поэтому текущий спектр является функцией не только частоты, но и времени.
В начале раздела мы воспользовались понятием периодической функции. На самом деле периодическая функция — лишь весьма полезная математическая абстракция. Ведь всякий природный процесс имеет начало и конец.
Принято называть реальный циклический процесс периодическим, если он длится достаточно долго. Мерилом длительности служит число "периодов", которое должно быть намного больше единицы. Периодичность процесса проявляется лишь с течением времени, когда прорисовываются его характерные черты. Текущий спектр и отражает это развитие процесса.
Спектр процесса (за короткий отрезок времени) однороден, так как короткий отрезок процесса — это просто короткий одиночный импульс. Если в дальнейшем происходит периодическое повторение некоторого цикла явления, то в текущем спектре начинают формироваться максимумы на основной частоте и ее гармониках. Эти пики становятся все более острыми и высокими, а значение спектральной плотности в интервалах между максимумами убывает, и при t -> [image] сплошной текущий спектр вырождается в линейчатый спектр периодического процесса.
Конечно, и при достаточно большой (не обязательно бесконечной) длительности процесса пики делаются настолько узкими, что их можно трактовать как линии.
Таким образом, периодический процесс — это предел, к которому может стремиться с течением времени реальный повторяющийся процесс. Аналогично и спектр (в его классическом определении) такого процесса есть предел, к которому стремится текущий спектр при увеличении времени интегрирования до бесконечности.
Например, при интегрировании в бесконечных пределах спектр синусоиды представляет собой единственную линию на частоте, равной частоте этой синусоиды.
Но как на практике измеряется текущий спектр, например, той же синусоиды? Мы включаем анализатор спектра, а спустя какое-то время выключаем его. Получается, что измеряется не спектр бесконечного синусоидального колебания, а спектр его более или менее протяженного отрезка. Это значит, что фактически исследуется спектр прямоугольного импульса с синусоидальным заполнением. Сказанное объясняет причину того, что даже для синусоидального колебания при уменьшении времени интегрирования спектральная линия расширяется, появляются боковые лепестки спектральной функции, ее нули все более удаляются друг от друга. Ведь именно так и должен вести себя спектр прямоугольного импульса при уменьшении его длительности.
Таким образом, текущий спектр в большей степени отражает свойства сигналов, проявляющиеся в реальных условиях их генерирования и обработки, нежели спектр, полученный на бесконечном временном интервале.


Мгновенный спектр

Текущий спектр — только мостик от частотного к временному описанию процесса. Представьте себе, что вы анализируете текущий спектр от начала до конца музыкального произведения, не слыша его. Вполне возможно, вы получите такой график спектральной функции, что в среднем за время анализа спектр будет выглядеть относительно широким. Рассматривая график, можно прийти, например, к следующему выводу: произведение исполняется одновременно на нескольких инструментах. В тембре звучания одних инструментов преобладают низкочастотные, других — средне- и высокочастотные составляющие.
Потом вы выводите сигнал на акустическую систему и оказывается, что это запись дуэта мужчины и женщины в сопровождении фортепиано. На самом деле тембр звука периодически меняется. Пока звучит баритон, в нем преобладают бархатные низкочастотные составляющие, а когда диалог продолжает сопрано, кажется, что звенит колокольчик. Но все эти нюансы оказались усреднены, сглажены, завуалированы в ходе спектрального анализа.
Для чего же нужны тогда все эти измерения спектра, если они не дают достоверной картины реального развития тембра музыкального произведения? На основе такого анализа трудно построить детальную стратегию последующей обработки фонограммы. Все дело в том, что не только спектр, вычисленный на бесконечном временном интервале, но и текущий спектр — слишком грубый инструмент в тех случаях, когда анализируемый процесс не стационарен. Для того чтобы сблизить частотное и временное представления сигнала, было введено понятие мгновенный спектр. Мгновенный спектр — это спектр короткого отрезка процесса длительностью [image] T, непосредственно предшествующего данному моменту времени t.
В этом определении мы имеем дело со скользящим интегрированием: интервал интегрирования имеет постоянную длину, но перемещается по оси времени. А вот относительно текущего времени этот интервал расположен неизменно.
Страшно далеко это определение спектра от того, что давно придумали великие математики. И все же в руках звукорежиссера именно мгновенный спектр является наиболее эффективным инструментом анализа свойств записываемого или уже записанного звука. Все дело в том, что реальные звуковые сигналы, с которыми нам приходится сталкиваться, одинаково непохожи на обе крайние математические абстракции — бесконечное во времени сверхузкополосное синусоидальное колебание и бесконечный в частотной области (сверхширокополосный) белый шум.
Музыка, которую создают с помощью синтезатора, отличается особенно заметной нестационарностью тембра. Может быть, именно поэтому в звуковых редакторах уже давно используются средства анализа текущего и мгновенного спектра.


Взвешенный спектр

Вы познакомились с тремя подходами к вычислению спектра и даже вынуждены были вникать в непростые математические соотношения. Но это еще не финал. Продолжим погружение в суть спектральных преобразований. И вновь речь пойдет о влиянии времени на результаты спектрального анализа.
Как вычисляется одна-единственная точка графика спектра? Исчерпывающий ответ на этот вопрос дают формулы. Хочется, однако, чтобы их вид не приводил вас в состояние трепета. Главное, чтобы вы понимали их смысл, поэтому попытаемся разъяснить обычными словами то, что записано математическими символами.
Итак, сначала выбирается частота f0. Реальный или виртуальный генератор формирует синусоиду этой частоты и условно единичной амплитуды. Исследуемый сигнал нормируется по амплитуде. Начиная с какого-то определенного момента f0, с шагом [image] t (чем меньше [image] t, тем лучше) в моменты времени t0, t1, t2, t3,...ti,...,tN-1 c этой синусоидой и исследуемым сигналом проделываются следующие операции:

  • берется отсчет синусоиды;
  • берется отсчет исследуемого сигнала;
  • эти отсчеты перемножаются;
  • результаты перемножения суммируются с накоплением.
В некоторый момент процесс измерения спектра на частоте f0 завершается. Накопленная сумма делится на общее число отсчетов. Вычисленное значение G(f0) запоминается и, возможно, отображается как одна точка графика. Затем накопленная сумма обнуляется, значение частоты изменяется на величину [image] f (выбирается новое значение частоты f1). И вся последовательность операций повторяется до тех пор, пока "пробежкой" по ряду частот f0,f1,f2,...,fN-1 не будет перекрыт весь заданный диапазон.
Описанная процедура вычисления спектрального коэффициента одновременно есть не что иное, как вычисление взаимокорреляционной функции исследуемого сигнала и синусоиды заданной частоты. Иными словами, в процессе вычисления спектральной составляющей выясняется степень сходства исследуемого сигнала со стандартным (базисным) сигналом, в данном случае с синусоидой. Или можно сказать еще и так: выясняется, в какой пропорции синусоида "содержится" в исследуемом сигнале.
Если исследуемый сигнал уже записан и в нашем распоряжении есть цифровой анализатор спектра, способный сколь угодно долго хранить результаты промежуточных вычислений, то измерение текущего спектра и мгновенного спектра вполне осуществимо по описанной выше процедуре.
Все значительно сложнее, когда анализ ведется в реальном времени. В самом деле, допустим, что одна спектральная составляющая вычислена. Изменяем частоту синусоиды и хотим приступить к вычислению следующей спектральной составляющей. Но анализируемый фрагмент сигнала остался в прошлом. Его не повторить. Поэтому вторая спектральная составляющая будет вычислена для второго фрагмента сигнала, третья — для третьего и т. д. Это уже не текущий спектр, а просто разрозненный набор отдельных спектральных коэффициентов, каждый из которых в ничтожно малой степени характеризует совершенно разные и, возможно, не связанные между собой фрагменты сигнала.
Конечно, спектральный анализ можно проводить по параллельной схеме, одновременно вычисляя множество значений спектральной функции для различных частот. Однако это в значительной степени усложнит аппаратуру.
Уместен и такой вопрос: насколько адекватен описанный математический алгоритм тому спектральному анализу, который проводится реальными анализаторами спектра, и тому, который выполняется органами слуха и мозгом человека? Ответ: не вполне.
Основная проблема состоит в том, что прибор, анализирующий спектр, и человек обладают конечной памятью. Былые события, подробности хода любого процесса постепенно стираются из нее. Это означает, что чем более удалены в прошлое отсчеты анализируемого сигнала, тем меньший вклад они вносят в накопление той самой суммы произведений отсчетов, которая, в конце концов, определяет значение спектрального коэффициента.
Учет реальных свойств памяти анализаторов спектра осуществляется с помощью весовых функций. Весовая функция описывает зависимость вклада предшествующих отсчетов исследуемого сигнала в вычисляемый спектр. Наглядное представление о весовой функции дает форма так называемого спектрального окна.
Тот спектральный анализ, о котором мы вели речь до сих пор, соответствует спектральному окну прямоугольной формы: весовая функция равна единице в пределах спектрального окна и равна нулю вне его. При анализе текущего спектра начало спектрального окна совпадает с началом отсчета времени, а конец приходится на текущий момент. Текущее время идет вперед, правая граница спектрального окна смещается, поэтому каждому конкретному моменту завершения анализа соответствует своя ширина спектрального окна. Если вычисляется мгновенный спектр, то спектральное окно скользит вдоль оси времени, не изменяя своей ширины.
Однако в большей степени суть реального спектрального анализа отражает экспоненциальная весовая функция. Кстати говоря, экспонента и синусоида — прямо-таки магические функции. Многие существующие в природе колебательные процессы описываются экспонентой при их возникновении и затухании, а синусоидой — на этапе продолжительного существования. В частности, по экспоненциальному закону затухают колебания в колебательном контуре, который служит основой реальных анализаторов спектра, т. е. как раз по экспоненте колебательный контур "забывает" величину спектральной составляющей, некогда возбудившей его. И именно по экспоненциальному закону стирается в памяти человека информация о прошедших событиях. Прямоугольное и экспоненциальное спектральные окна используется при вычислении спектра наиболее часто. Первое соответствует идеальному анализатору с бесконечно большой памятью, второе удачно отражает свойства человеческого мозга и реальных анализаторов спектра на основе резонансных фильтров. Вместе с тем, хотя не столь широко, применяются и другие весовые функции. Трудно дать конкретные рекомендации по поводу предпочтительности использования той или иной весовой функции для спектрального анализа звуковых сигналов (за исключением экспоненциальной функции, о пользе которой сказано уже достаточно). Пожалуй, единственный совет может состоять в том, что следует остановиться на какой-то одной весовой функции. Только тогда у вас будет уверенность в том, что различия результатов анализа обусловлены различием свойств сигналов, а не методов расчета. Целесообразно также выбирать одну и ту же весовую функцию, когда при работе с одним и тем же сигналом вы решаете несколько задач, в которых применяются спектральные преобразования.


Быстрое преобразование Фурье

До сих пор, знакомясь с сущностью спектральных представлений, мы предполагали, что сигнал является аналоговым, т. е. описывается непрерывной функцией. На самом деле компьютер способен обрабатывать только цифровые сигналы — дискретные во времени и квантованные по уровню. Поэтому аналоговый сигнал подвергается аналого-цифровому преобразованию (АЦП). Затем с сигналом в цифровой форме производятся все необходимые операции, в частности, спектральный анализ, причем вместо обычного спектрального преобразования производится так называемое дискретное преобразование Фурье (ДПФ). Непрерывное время и непрерывная частота заменяются на соответствующие дискретные величины, а место взятия интегралов осуществляется суммирование.
Однако на практике мало кто пользуется ДПФ. Дело в том, что для вычисления дискретного преобразования Фурье последовательности N элементов требуется выполнить N2 операций с комплексными числами. Если длины обрабатываемых массивов цифровых отсчетов звуковых колебаний имеют порядок тысячи и более, то использовать эти алгоритмы дискретного спектрального анализа затруднительно (особенно в реальном времени). Выходом из положения явился алгоритм быстрого преобразования Фурье (БПФ). Значительно сократить число выполняемых операций здесь удается за счет того, что обработка входного массива сводится к нахождению ДПФ-массивов с меньшим числом элементов. Для метода БПФ существенно, что число отсчетов составляет целую степень двойки (N =2p, где р — целое число). Это обусловлено тем, что одной из операций, входящей в алгоритм БПФ, является последовательное деление интервала вычисления ДПФ на две части. Поэтому точное вычисление БПФ возможно лишь в случае, когда число отсчетов в сигнале равно 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4096, IP. Если данное условие не выполняется, приходится дополнять сигнал некоторым количеством отсчетов, имеющих нулевое значение. Например, для выполнения БПФ сигнал, содержащий 60 значащих отсчетов, нужно дополнить четырьмя нулевыми отсчетами. Конечно, приписка отсчетов равноценна изменению сигнала, что приводит к возникновению дополнительной погрешности вычисления спектра. Но, как правило, погрешность невелика и, учитывая заметное повышение скорости расчетов, с ней можно смириться.
Приближенно можно считать, что объем вычислений по алгоритму БПФ пропорционален произведению N х log2N, где N — количество отсчетов сигнала. А если решать задачу расчета спектра "в лоб", не пользуясь алгоритмами быстрых преобразований, то объем вычислений ориентировочно будет пропорционален произведению N х N. Если бы не БПФ, то для фильтрации, спектрального анализа и синтеза сигналов не хватило бы быстродействия самого современного компьютера. Не верится? Давайте прикинем. Очень скоро вы узнаете, что в примере установок параметров, соответствующих рис. 1.27, сигнал представлен 4096-ю отсчетами. Тогда для БПФ: 4096 х log24096 = 4096 х 12 = 49152, а для "небыстрого" алгоритма: 4096 х 4096 = 16777216. Отношение 16777216/49152 = 341,(3) приблизительно равно выигрышу во времени выполнения вычислений по алгоритму БПФ.
О чем говорят эти цифры? Пусть на вашем компьютере для расчета фильтра по алгоритму БПФ требуется 10 секунд. Та же самая задача при использовании обычного алгоритма спектрального анализа заняла бы почти час. Какое уж тут может быть творчество! Либо, чтобы все-таки уложиться в 10 секунд, потребовался бы компьютер, работающий в 341 раз быстрее, чем ваш.
При расчете спектра протяженных сигналов приходится не дополнять отсчеты до целой степени двойки, а поступать совершенно наоборот: использовать для вычислений не все отсчеты сигнала, а, к примеру, каждый сотый, тысячный, десятитысячный. Судите сами. В одной секунде оцифрованного стереофонического звука при частоте дискретизации 44,1 кГц содержится 88200 отсчетов. Тогда в одной минуте — 5292000, а в 4 минутах (типичная длительность композиции) — 21168000 отсчетов. В качестве примера средствами Cubase SX мы проанализировали спектр 4-минутной композиции. На нашем компьютере для этого понадобилось 10 секунд. При этом было выбрано число отсчетов, равное 4096 (что для анализатора спектра Cubase SX в два раза меньше максимального). Если бы программа использовала для вычислений все отсчеты, которыми представлена композиция (более 21 миллиона отсчетов), то для решения этой задачи ей потребовалось бы непрерывно работать больше 14 часов.
Существуют аудиоредакторы, позволяющие не только анализировать текущий и мгновенный спектры, но также и редактировать звуковой сигнал, представленный в спектральной форме. Примером подобной программы может служить аудиоредактор Cool Edit Pro 2. Конечно, от такой универсальной программы, как Cubase SX, нельзя требовать, чтобы она позволяла обращаться со спектром так же свободно, как и специализированный звуковой редактор. Вместе с тем, в Cubase SX возможности для проведения спектрального анализа все же имеются.


Измерение спектра в Cubase SX

Команда, инициализирующая анализатор спектра, имеющийся в Cubase SX, доступна только при следующих условиях: в проекте существует хотя бы один аудиотрек, на треке имеются аудиоданные и выделен хотя бы фрагмент части с аудиоданными. Для выделения фрагмента нажмите кнопку [image] в окне Cubase SX Project, затем нажмите левую кнопку мыши и проведите курсором мыши от одной границы предполагаемого выделения до другой. После этого отпустите кнопку мыши. Для выделения всей части сделайте на ней двойной щелчок левой кнопкой мыши. Если хотя бы один трек выделен при нажатой кнопке [image] , то спектральный анализ будет автоматически проводиться поочередно на каждом треке.
Доступ к анализатору спектра в Cubase SX осуществляется из главного меню командой Audio > Spectrum Analyzer. Этой командой отрывается диалоговое окно Spectrum Analyzer (рис. 1.27), предназначенное для выбора режима спектрального анализа.
В окне диалога Spectrum Analyzer имеются следующие опции:

  • Size in Samples — объем выборки (число отсчетов, на основе которых будет выполняться БПФ). Чем больше число, выбранное в этом поле, тем точнее анализ и тем больше времени потребуется для его проведения.
  • Size of Overlap — степень наложения блоков выборок в процессе спектрального анализа. Оптимальное значение этого параметра устанавливается автоматически при изменении числа в поле Size in Samples. В любом случае значение данного параметра должно быть меньше, чем значение параметра in Samples. Если попытаться задать значения Size of Overlap и Size in Samples равными, то программа закроется без всякого предупреждения и сохранения текущего проекта в файле.
  • Window used — раскрывающийся список для выбора вида спектрального окна.
  • Normalized values — флажок включения нормализации полученных значений. При установленном флажке наибольшее значение спектральной функции будет приравнено к уровню 0 дБ или к значению 1.
  • From Stereo — раскрывающийся список для выбора режима обработки стереосигнала. Возможные варианты: анализ монофонического сигнала, полученного суммированием сигналов правого и левого каналов, анализ сигнала левого канала, анализ сигнала правого канала, раздельный анализ сигналов каждого из стереоканалов (спектры отображаются графиками, которые отличаются цветом).

Рис. 1.27. Окно Spectrum Analyzer для выбора параметров анализа спектра

Когда вы нажмете кнопку Process, начнется спектральный анализ выборки сигнала, находящейся в выделенном фрагменте. Будет вычисляться спектр. Спустя некоторое время расчет спектра завершится и откроется окно с графиком спектра (рис. 1.28).
Обладая некоторым опытом общения с анализатором и профессиональным чутьем, по спектру сигнала вы сможете, например, разыскать на графике даже небольшой выброс, в котором сосредоточена основная энергия помехи. Затем с помощью фильтра можно удалить этот выброс из спектра сигнала, существенно улучшив при этом отношение полезного сигнала к шуму.
Если окно с графиком спектра покажется мелковатым, вы можете увеличить его традиционным способом с помощью мыши.

Рис. 1.28. Окно Spectrum Analyzer с результатами анализа спектра

Рис. 1.29. Спектр сигнала при логарифмическом масштабировании оси частот

А теперь рассмотрим график внимательнее. По горизонтальной оси откладывается частота в герцах, по вертикальной — уровень компонентов сигнала на этой частоте.
Если флажок dB установлен, то значения спектральной функции откладываются в логарифмической шкале, оцифрованной в децибелах, если сброшен — в линейной шкале (либо ненормированной, либо нормированной к единице).
При сброшенном флажке Freq. log горизонтальная ось размечается в линейном масштабе, в котором удобнее рассматривать весь спектр в целом, включая и его высокочастотную область. Если этот флажок установлен, то по горизонтали назначается логарифмический масштаб. Логарифмический масштаб позволяет в деталях наблюдать низкочастотную часть спектра. Для сравнения на рис. 1.29 при логарифмической шкале по оси частот показан спектр того же самого сигнала, для которого на рис. 1.28 выбран линейный масштаб.
Справа вверху располагается поле, в котором отображаются данные о'значениях спектральной функции сигналов правого и левого канала для той частоты, на которую в данный момент указывает курсор мыши. Сама частота также отображается в поле. Сказанное справедливо при условии, что курсор находится в пределах координатного поля. При перемещении курсора значения параметров изменяются. Если курсор находится вне пределов координатного поля, то значения отображаемых параметров не меняются, причем они соответствуют той частоте, при которой курсор, покидая координатное поле, пересек его границу.
Обратите внимание на то, что числа, отображаемые в поле, не являются координатами курсора мыши. В этом поле вы видите координату курсора мыши на оси частот и соответствующее ей значение спектра. Это упрощает процесс численного измерения значений спектральной функции. Вам не нужно прицеливаться в конкретную точку на координатной плоскости. Достаточно добиться, чтобы в поле появилось искомое значение частоты, а значение спектра для нее программа предъявит вам автоматически. Точка на графике, которой соответствуют числа, отображаемые в поле, выделяется зеленой окружностью, а проекции этой точки на координатные оси отмечаются зелеными черточками.
Возможно, вам понадобится рассмотреть в подробностях поведение спектральной функции на каком-либо ее конкретном участке. В полях Min. и Мах. вы можете задать нижнюю и верхнюю границы частотного диапазона, отображаемого в окне.
В поле Precision: программа отображает значение разрешающей способности измерения спектра, которая зависит от объема выборки (см. поле ввода Size in Samples на рис. 1.27).
В единственном раскрывающемся списке выбирают один из двух вариантов оцифровки горизонтальной оси координат:

  • Frequency (Hz) — в традиционных единицах измерения частоты (герцах).
  • Note (С) — "в нотах". Вместо значений соответствующих частот шкала будет размечена символами С0, C1, C2, ..., С10, которые означают ноты до различных октав (например, до пятой октавы соответствует частоте 523,251 Гц).
При установленном флажке Active всякий раз, когда вы станете выбирать команду Audio > Spectrum Analyzer, очередной график с результатами анализа будет отображаться в том же самом окне (заменяя собой предшествующий график). Если флажок сброшен, новые результаты спектрального анализа появятся в отдельных окнах. Последний режим очень удобен, так как позволяет сравнивать спектры сигналов, записанных на различных треках, что чрезвычайно важно при обработке отдельных музыкальных партий фильтрами в процессе сведения композиции.


Анализ спектра и фильтрация при сведении композиции

Раз уж мы заговорили о сведении, то упомянем о том, что оно включает в себя несколько этапов:
1. Индивидуальный контроль отсутствия ошибок в партии каждого инструмента.
2. Перезапись партий в исполнении MIDI-инструментов (если таковые есть в композиции) на аудиотреки.
3. Выставление ориентировочного баланса уровней всех партий и предварительное панорамирование.
4. Корректировка частотных характеристик партий.
5. Динамическая обработка звуковых сигналов.
6. Обработка эффектами.
7. Динамическое изменение уровня аудиосигнала каждого трека (в каких-то местах каждая партия должна звучать несколько громче, в каких-то — тише).
8. Уточнение относительных уровней, уточнение распределения партий по панораме.
Сейчас речь идет о спектральном анализе, поэтому остановимся лишь на четвертом этапе: коррекции частотных характеристик партий. С помощью эквалайзеров нужно добиться гармоничного сочетания всех партий. Сделать так, чтобы в звучании каждого инструмента присутствовали характерные тембры и, вместе с тем, чтобы, по возможности, их спектры не перекрывались: энергия сигналов равномерно распределялась бы в пределах звукового диапазона частот. Только в этом случае удастся добиться прозрачности звучания композиции. Начинать такую работу нужно со спектрального анализа сигналов каждого из треков в отдельности. Для того чтобы наглядно пояснить то, о чем сейчас идет речь, рассмотрим простой пример. Пусть имеется три трека и требуется их сбалансировать по тембру. Проведем спектральный анализ каждого трека с помощью Spectrum Analyzer, причем флажок Active сбросим. Полученные графики спектральных функций представлены на рис. 1.30.

Рис. 1.30. Результат спектрального анализа аудиосигналов на трех треках

Разработчики Cubase SX не приводят детальных сведений об алгоритме спектрального анализа, реализованного в программе. Поэтому в процессе работы над книгой мы решили провести сравнение полученных результатов с теми, что дает какой-либо другой виртуальный анализатор спектра. В качестве альтернативного мы выбрали анализатор спектра программы Cool Edit Pro 2, детально описанный нами в книге [10]. Анализировались одни и те же тестовые сигналы, спектры которых были нам заранее известны, т. к. их описание имеется в научных литературных источниках. Также проводился анализ сигналов, полученных путем перезаписи на аудиотреки MIDI-инструментов. По результатам этого эксперимента можно сделать следующие выводы.
1. Анализатор спектра Cubase SX дает большую погрешность на частотах ниже 40—50 Гц. Создается впечатление, что в этом диапазоне существует некий порог чувствительности измерителя. Об этом косвенно свидетельствует такой, например, результат: сигнал на треке № 3 (нижний график на рис. 1.30) был обработан фильтром, ослабившим все частоты в диапазоне 0—50 Гц на 30 дБ. На слух результат такой обработки заметен хорошо: из звучания рояля исчез призвук, похожий на слабые удары по бас-барабану, который в необработанном сигнале слышен в моменты нажатия клавиш. Однако спектральный анализ отфильтрованного сигнала средствами Cubase SX показал, что уровень спектральной функции остался прежним (все те же -26 дБ), хотя должен был бы снизиться до -56 дБ. Причиной этого может быть ограниченное время анализа. Кроме того, даже при наибольшем числе анализируемых отсчетов (Size in Samples) разрешающая способность анализатора спектра Cubase SX составляет около 6 Гц, а график всего рассматриваемого низкочастотного участка спектра строится лишь по 8—10 точкам. Анализатор спектра программы Cool Edit Pro 2 "заметил" понижение уровня низкочастотных составляющих фильтром.
2. Анализатор Cubase SX вычисляет спектр либо на участке трека, выделенном при нажатой кнопке [image] , либо на всем треке (поочередно на каждом треке, если хотя бы один трек выделен при нажатой кнопке [image] ). Иными словами, измеряется мгновенный спектр, поэтому вид графика спектра зависит от расположения и протяженности выделенного фрагмента.
3. Анализатор Cubase SX сглаживает разброс между значениями соседних локальных максимумов и минимумов спектральной функции. Чтобы убедиться в этом, достаточно сравнить рис. 1.31 и 1.32. На первом из рисунков показан спектр, измеренный анализатором Cubase SX, на втором — Cool Edit Pro 2. Анализируется один и тот же сигнал. В результате подобного сглаживания пользователю нетрудно допустить ошибку в оценке того, какие спектральные компоненты аудиосигнала следует считать существенными, а какие — нет, так как создается субъективное впечатление, будто значения спектральной функции с ростом частоты уменьшаются быстрее, чем это происходит на самом деле.

Рис. 1.31. Спектр сигнала, измеренный средствами Cubase SX

Рис. 1.32. Спектр сигнала, измеренный средствами Cool Edit Pro 2

А теперь возвратимся к рис. 1.30 и рассмотрим его сверху вниз.

На треке № 3 записана партия баса, на треке № 2 — аккомпанирующего инструмента, на треке № 1 — солирующего инструмента. Результаты спектрального анализа соответствуют такому распределению инструментов. Спектр сигнала на треке № 3 сосредоточен в основном в области частот 20 Гц - 400 Гц, на треке № 2 - 60 Гц - 2 кГц, на треке № 1 - 60 Гц - 8 кГц.
Напрашивается такая последовательность обработки сигналов частотными фильтрами:

  • к треку № 3 можно применить фильтр нижних частот с частотой среза 400 Гц для того, чтобы полностью подавить высокочастотные составляющие. Уровень передачи сигнала в полосе подавления фильтра можно установить порядка -30 дБ — -40 дБ (или минимально возможный для эквалайзера, имеющегося в вашем распоряжении);
  • на треке № 2 можно без потери качества подавить спектральные составляющие, лежащие ниже 60 Гц. Для этого сигнал следует обработать фильтром верхних частот с частотой среза 60 Гц. Кроме того, фильтром нижних частот можно подавить спектральные составляющие, расположенные выше 2 кГц — 3 кГц;
  • на треке № 1 полосно-подавляющим фильтром можно ослабить на 10 дБ — 15 дБ спектр в полосе частот 500 Гц — 1,5 кГц (приблизительно). Это позволит устранить маскировку звука аккомпанирующего инструмента, записанного на треке № 2.
В целом после такой обработки фильтрами уменьшится уровень нелинейных искажений в области нижних частот, а в звучании композиции появится прозрачность.
Заметим, что рассмотренный вариант фильтрации — не единственный. В зависимости от поставленной цели можно попытаться реализовать несколько различных стратегий обработки фильтрами сигналов, имеющих такие спектры. Анализатор спектра лишь помогает сориентироваться, а контролировать качество звука, полученного в результате фильтрации, следует только на слух.


1.12. Surround — объемный звук

С тех пор, как существует звукозапись, и слушатели, и конструкторы аппаратуры испытывают неистребимое желание сделать звук, записанный и затем воспроизведенный, в максимальной степени похожим на оригинал. Чего только не делают разработчики аудиотехники для того, чтобы приблизиться к идеалу: сражаются с шумом, минимизируют искажения, расширяют частотный и динамический диапазоны элементов тракта записи-передачи-воспроизведения звукового сигнала. А кроме всего прочего они стремятся заставить звуковое поле, создаваемое акустическими системами, передавать слушателю информацию о направлении на источники звуков и об акустических свойствах того помещения, в котором производилась запись.
На первом этапе своего развития звукозапись и радиовещание были монофоническими. Звук, раздающийся из динамика, до неузнаваемости отличался от живого звука концертного зала: искаженный баланс между различными музыкальными инструментами, искаженный тембр и, главное, полностью утраченная пространственность. Это очень серьезный недостаток. Ведь слуховой анализатор человека обладает способностью к пеленгации источников звука, что помогает нам ориентироваться в пространстве. Если же все звуки исходят из одной точки — это кажется противоестественным.


1.12.1. Немного истории

Первые эксперименты по получению объемного звучания (с помощью трех — семи каналов) проводились еще в 30-е годы прошлого века. Сравнительные испытания многоканальных и монофонических систем дали удивительные результаты. Было установлено, что при воспроизведении даже 2-х раздельных каналов субъективное качество звука резко улучшается. А самое поразительное заключается в том, что эксперты предпочитали стереозвук даже в тех случаях, когда им предъявляли объективно более качественные, но монофонические фонограммы. Решающим преимуществом стала возможность пространственной локализации кажущихся источников звука (рис. 1.33).

Рис. 1.33. Распределение кажущихся источников звука на стереопанораме

На начальном этапе разработчики решили ограничиться двумя каналами. Это, конечно, в первую очередь было обусловлено небогатыми возможностями аппаратуры тех времен: грампластинки реально позволяли разместить только два полноценных канала.
Стереозвук дает некоторую прозрачность звучания: партии отдельных инструментов становятся более различимыми на фоне оркестра. Кроме того, стереосистема способна воспроизвести подобие звуковой атмосферы помещения, в котором выполнялась запись. Началась эра 2-канальных стереофонических систем. Постепенно появились стереофонические грампластинки и стереопроигрыватели, стереомагнитофоны, стереофоническое радиовещание.
В свою очередь стереозвучание имеет существенный недостаток. Стереопанорама ограничена углом между направлениями на громкоговорители и получается плоской. Такое звучание лишено естественности реального звукового поля, когда человек способен воспринимать реальные источники практически со всех направлений и оценивать расстояние до источников звука. Создающееся у слушателя ощущение объемного звучания могло бы существенно обогатить тембры музыкальных инструментов и голосов певцов. При этом можно было бы имитировать реверберационный процесс, свойственный помещению, в котором произведена запись.
Одной из первых попыток преодоления недостатков, присущих стереофоническим системам, стала квадрофония. Для воспроизведения квадрофонических фонограмм используются 4 акустические системы (рис. 1.34).
Первые бытовые квадросистемы появились в начале 70-годов прошлого века. Казалось, что их ждет славное будущее. Однако этого не произошло. Причин тому есть несколько. Одна из них традиционна для многих новинок техники и заключается в том, что производители квадрофонической аппаратуры так и не смогли прийти к единому стандарту записи и воспроизведения 4-канального звука. Свою роль сыграли несовершенство и большая стоимость приборов четырехканальной записи-воспроизведения. Но главное заключается в другом: с переходом от "стерео" к "квадро" в те времена новое качество звука не возникло. Квадрофонические системы, так же как и стереофонические, не обеспечивали полной передачи свойств реального звукового поля. Недостатков было только два, но они существенны:

  • при квадрофонии 70-годов прошлого века не получалась круговая стереопанорама — слушатель ощущал обычную стереопанораму перед собой и еще одну стереопанораму сзади себя;
  • все мнимые источники звука располагались в одной плоскости на линиях между динамиками, поэтому объемного трехмерного звучания по-прежнему не было.
Следует заметить, что эти недостатки обусловлены не столько ограниченными возможностями четырехканального воспроизведения звука, сколько трудностями реализации панорамирования кажущихся источников звука
при записи. При подготовке фонограмм для современных многоканальных систем этот фактор учитывается. Важную роль при этом играет именно компьютер, способный справиться с моделированием объемных реверберационных процессов и предоставляющий звукорежиссеру удобные регуляторы для перемещения источников звука по круговой панораме.

Рис. 1.34. Распределение кажущихся источников звука на квадропанораме

Но в те далекие времена квадрофония отступила, а стереофония победила и стала развиваться по линии миниатюризации аппаратуры, улучшения ее технических и потребительских качеств, перехода к новым носителям — компакт-кассетам и компакт-дискам. Перед звукозаписывающими компаниями и производителями аудиоаппаратуры все еще существовал широчайший фронт работ и емкий рынок сбыта. В который раз они предлагали слушателям смену фонотек. Накопленный на грампластинках за предшествующие десятилетия музыкальный материал, обновленный и адаптированный сначала под монофонические катушечные магнитофоны, затем реализованный на компакт-кассетах в стереоформате, в очередной раз предлагался меломанам, но теперь уже на лазерных дисках.
Однако в самом конце XX века стереофония, кажется, все-таки начала сдавать свои позиции. Цифровые технологии записи звука, а также емкие,, удобные и дешевые носители сняли ранее существовавшую проблему хранения многоканальных фонограмм большой длительности. Кроме того, в звуке, передающем акустические свойства окружающего пространства, появилась острая потребность. Виртуальные графические миры компьютерных игр становятся все более сложными и похожими на реальность, а значит, требуют и адекватного звукового оформления. Кинематограф, переживший кризис в состязании с телевидением, возродился в виде домашних кинотеатров и кинозалов нового формата, основное отличие которых от предшественников кроется не в изображении, а в принципиально новом звуке (хотя и качество изображения тоже улучшилось, благодаря DVD и современным проекционным средствам).
Новая эра в звукозаписи началась в результате исследований, выполненных инженерами Dolby Laboratories (http://dolby.com). Это был принципиально новый подход к передаче многоканального звука. Отличие от традиционного способа заключалось, прежде всего, в том, что для хранения аудиосигналов двух дополнительных каналов использовалось матричное кодирование, т. е. их подмешивание к основным двум каналам. Изменился и способ размещения акустических систем — дополнительно к традиционному для квадрофонии расположению акустических систем по углам помещения добавлен центральный канал, размещенный между правым и левым фронтальными каналами, чтобы сохранить широкую стереобазу для зрителей, сидящих на боковых местах, а за спинами размещен канал эффектов (Surround). Так появилась система нового кинотеатрального звучания Dolby ® Stereo.
Как вы уже знаете, этот четырехканальный формат является матричным форматом, при котором звук, предназначенный для каждого из четырех каналов, кодируется и записывается на два канала, а при воспроизведении декодируется вновь в четыре канала: левый, центральный, правый и задний. Сигнал заднего канала, как правило, направляется на две тыловые акустические системы одновременно. Впервые формат Dolby ® Stereo был применен в фильме "Star Wars" в 1975 году.
Используемая технология кодирования не позволяла обеспечить разделение между каналами более 8 дБ. Позже она была изменена, и разделение между каналами достигло 15 дБ, но частотный диапазон заднего канала остался ограниченным в диапазоне 100 Гц — 7 кГц.

Рис. 1.35. Размещение излучателей звука в системе Dolby ® Stereo

Системой воспроизведения совершенно нового качества, совместимой со старым стандартом звукозаписи, стала система Dolby ® Pro Logic ®. В ней был применен декодер, реализующий пространственную фокусировку звуковых образов — технологию, используемую для снижения взаимного проникновения сигналов одного канала в другой. В Dolby ® Pro Logic ® также появилась возможность создавать задержку звукового сигнала в тыловом канале. Тем самым было обеспечено согласование геометрических и акустических характеристик конкретного помещения с характеристиками "эталонного кинозала", под который при производстве сводился мультитрековый звук. Очень важно, что к настоящему времени накоплено огромное количество музыки, фильмов, телепрограмм, записанных на различных современных носителях со звуком в формате Dolby ® Pro Logic ®. А потом наступила эпоха цифрового кодирования и цифровой записи многоканального объемного звука, и появилась система Dolby ® Digital. Для кодирования цифрового звука в ней используется алгоритм, называемый АС-3 (Dolby's third generation audio coding algorithm — алгоритм кодирования звука Dolby третьего поколения). АС-3 представляет собой алгоритм компрессии многоканального звука (количество независимых каналов от 1 до 6) с потерями. Достижения в области психоакустики, учитывающие особенности человеческого слухового аппарата, используются в нем для принятия решения о том, какую часть информации в аудиосигнале можно отбросить, чтобы это было не очень заметно для человеческого уха. При кодировании алгоритмом АС-3 могут использоваться битрейты от 32 Кбит/с (для одного монофонического канала с минимальным качеством) до 640 Кбит/с (для каналов 5.1 с минимальными потерями качества). Типичный битрейт для 5.1 записей составляет 385 Кбит/с.
Кодер Dolby® Digital поддерживает частоты дискретизации цифровых данных 32 кГц, 44,1 кГц и 48 кГц при разрядности 16, 18 или 20 бит. Предусмотрена возможность увеличения разрядности до 24 бит. Используется сжатие данных с потерями, однако качество звука все равно получается выше, чем у предшествующих аналоговых систем. Dolby® Digital может обеспечить кодирование до 6 каналов в формате 5.1, где 5 — это каналы с полным частотным диапазоном (2020 000 Гц) и .1 — канал низкочастотных (менее 120 Гц) эффектов (LFE).
Объемность акустических сцен, более четкая детализация, естественность перемещений источников звука из фронтальной области в тыловую, стереофоническое звучание в тыловой области — все это обеспечило успех системы.
Следующий шаг эволюции систем объемного звучания — система Dolby ® Digital EX, которую можно считать надстройкой над Dolby ® Digital. В Dolby ® Digital EX, как и в Dolby ® Digital физически может кодироваться до 6 независимых каналов (5.1), однако, за счет использования матричного кодирования, в левый и в правый тыловые каналы подмешивается информация еще одного или двух surround-каналов. Благодаря такому решению сохранена совместимость с оборудованием Dolby ® Digital, и в то же время, за счет введения дополнительных surround-каналов (6.1, 7.1) на оборудовании Dolby ® Digital EX достигается еще более высокая точность локализации звуковых источников в пространстве.
Конечно, многоканальным звуком занимается не только Dolby Lab.
Например, фирма RSP Technologies создала матричную систему Circle Surround, которая имеет тыловой канал с полным диапазоном частот и тем самым оказывается наилучшим образом приспособленной для воспроизведения музыки. Новая версия Circle Surround может также работать в шести -канальном режиме с раздельными тыловыми каналами и каналом сабвуфера (сверхнизкочастотной акустической системы).
В настоящее время можно говорить о распространении нового потребительского формата: DVD-audio. Звуковые данные на этом носителе могут храниться с использованием различных алгоритмов кодирования, включая Dolby ® Digital. Однако в связи с большой емкостью носителя DVD (4,7 Гб на однослойном диске) необходимость сжатия звуковой информации с потерями отпадает. На DVD-audio можно хранить многоканальные записи в формате вплоть до 24 бит/96 кГц без какого либо сжатия и, соответственно, без каких-либо потерь.


1.12.2. Формат 5.1

Обозначение "5.1" указывает на количество каналов, но не несет в себе информации о каком-либо определенном способе кодирования многоканального звука. Используется пять каналов с полным частотным диапазоном (левый передний, центральный, правый передний, левый задний и правый задний), а также один низкочастотный канал (с диапазоном от 3 до 120 Гц), подключаемый к сабвуферу (рис. 1.36).
В этой системе 5.1 формируется круговая стереопанорама. Поскольку на сверхнизких частотах наш слух практически лишен способности определять направление на источник звука, место расположения сабвуфера не имеет существенного значения.
Сабвуфер применяется и в обычных стереосистемах. В его канал подается низкочастотная часть спектра суммарного сигнала стереоканалов, в результате чего обеспечивается гарантированное воспроизведение басовых звуков. Однако в системе 5.1 канал низкочастотных эффектов играет особую роль. Его стоит рассматривать не как низкочастотную компоненту многополосной акустической системы, а именно как независимый канал низкочастотных эффектов.
При записи на магнитофон для большинства систем 5.1 принят следующий порядок каналов (начиная с первой дорожки): левый передний, центральный, правый передний, левый задний, правый задний и низкочастотный каналы. В ряде случаев (например, в многоканальных звуковых картах) предусмотрен и другой порядок: левый передний, правый передний, левый задний, правый задний, центральный, низкочастотный.
По мнению специалистов, формат 5.1 является наиболее перспективным, поскольку поддерживается основными разработчиками. Важно, что имеются подходящие носители (DVD).

Рис. 1.36. Размещение излучателей звука в системе 5.1

И хотя пока не принят единый стандарт и одновременно существует несколько систем кодирования для 5.1, однако фиаско "первобытной" квадрофонии вряд ли повторится, даже если "выживет" не одна, а несколько различных систем кодирования. Принципиальное отличие формата 5.1 от квадрофонии тридцатилетней давности заключается в том, что в данном случае аудиосигнал имеет цифровую форму, поэтому создание универсального декодера, способного работать со звуком, закодированным различными системами, не вызовет особых трудностей и не приведет к заметному удорожанию аппаратуры.
В успехе формата 5.1 заинтересованы производители аудио-, видеоаппаратуры, компьютеров, компьютерных комплектующих и программ. К нему с интересом относятся потребители: зрители, слушатели, геймеры. Звукорежиссеры и музыканты находят в этом формате новые выразительные средства для реализации творческих замыслов и усиления влияния на наши эмоции. Формат действительно придает воспроизводимому звуку новое качество: слушатель окружен им. Правда, виртуальный звуковой мир и в этом случае не дотягивает до реального. В синтезированном звуковом пространстве источник звука может находиться справа, слева, спереди, сзади, перемещаясь в этих "координатах". А у настоящего звукового пространства, кроме того, есть еще "верх" и "низ".


1.12.3. Особенности оборудования студии формата 5.1

Сейчас мы поговорим только об основных элементах звуковой студии, к которым в первую очередь следует отнести:

  • микшер;
  • устройство многоканальной записи;
  • приборы обработки и эффектов;
  • мониторы для прослушивания фонограмм.
Основным инструментом сведения многоканального звука является микшер, снабженный средствами панорамирования.
В стереоформате для размещения кажущегося источника звука в определенном месте предназначен регулятор панорамы. Им вы устанавливаете относительные уровни звуковых сигналов, которые подаются в каждый из двух каналов, и тем самым определяете положение источника звука между двумя акустическими системами. При работе с многоканальным звуком вам надо управлять аналогичным процессом в 5 каналах, кроме того, конечно, требуется также регулировать и канал сабвуфера. Поэтому при использовании традиционного микшера для позиционирования одного источника звука необходимо манипулировать несколькими регуляторами. Заметим, что состояние фейдеров, управляющих уровнем сигнала, и регуляторов панорамы в каждом канале трудно сопоставить с положением кажущегося источника звука на круговой панораме. Еще сложнее заставить звук перемещаться по заданной траектории. Это возможно только в микшерах с автоматизацией. В качестве регулятора круговой панорамы в микшере, предназначенном для работы с многоканальным звуком, очень подошел бы джойстик.
Ко всему прочему, микшер, способный работать с объемным звуком, должен иметь не один, а несколько выходов (по числу каналов). Например, в системе 5.1 у микшера должно быть не менее 6 выходов. Оборудование стереофонической студии звукозаписи стоит недешево, а уж о цене студии формата 5.1 и подумать страшно!
Дороговаты также и устройства записи многоканального звука. Они должны иметь 6 и более каналов. Причем крайне желательно, чтобы звук в них представлялся не менее чем 24 разрядами.
Микшеры и цифровые магнитофоны — устройства, многоканальные по своей сути. Поэтому некоторые из моделей, предназначенных для работы со стереозвуком, можно с большим или меньшим удобством применять и в студии формата 5.1. А вот с эквалайзерами, приборами динамической обработки и особенно эффектами дело обстоит сложнее. Конечно, можно обеспечить 6 каналов, собрав "батарею" из 3-х двухканальных приборов. Однако об осмысленной регулировке параметров в этом случае говорить не приходится. Вообразите себе, например, трудности создания в многоканальной системе реалистичной реверберации.
Достойной заменой цифровым магнитофонам и аппаратным микшерам могут служить программные мультитрековые студии и имеющиеся в составе некоторых из них виртуальные микшеры, позволяющие управлять панорамированием с помощью обычной мыши. Удобный в работе и наглядно отображающий положение источника звука на круговой панораме surround-микшер имеется в программе Cubase SX (см. главу 5).
Не всякий владелец домашней студии стереофонического формата может позволить себе иметь мониторную акустическую стереосистему. Однако в случае сведения в стерео приемлемым выходом из положения являются относительно дешевые мониторные наушники. А в формате 5.1 стереонаушники вас не спасут. Без пяти широкополосных акустических систем (а также сабвуфера) не обойтись.
При работе со стереозвуком основными требованиями к мониторам являются: равномерность их частотной характеристики, низкий уровень искажений и полная идентичность двух акустических систем.
Аналогичные требования можно было бы предъявить и к пяти широкополосным мониторам формата 5.1. Они вроде бы тоже должны быть абсолютно одинаковыми. Но в таком случае сведение в круговую панораму вы будете осуществлять в условиях, отличающихся от тех, в которых будут находиться многие слушатели вашей композиции. Дело в том, что у большинства владельцев домашних театров тыловые акустические системы не только по мощности слабее фронтальных, но, кроме того, они могут иметь конструктивное исполнение другого типа. В свою очередь, центральная акустическая система зачастую отличается от крайних передних. Получается, что впечатление слушателя может не совпадать с тем, которое замышляли вы.
Заметим, что подобная проблема существует и при работе со стереозвуком: сведение осуществляется на студийных мониторах, а воспроизведение — на самой различной акустике, начиная от высококачественных колонок и кончая динамиками переносного кассетного магнитофона. Правда, в процессе мастеринга фонограммы должны проходить тест на совместимость с оборудованием низкого качества, да и одной из основных задач этого этапа является адаптация записи к конкретному типу носителя.
Что касается канала низкочастотных эффектов системы 5.1, то при сведении музыкальной композиции сабвуфер вообще не должен использоваться, если по художественному замыслу в музыкальной композиции не присутствует эффект типа взрыва, выстрела из пушки и т. п.
Но опыт прошлых лет, когда царствовал формат CD-audio, показывает, что всякие официальные рекомендации по использованию формата выполняются только на первых порах. Постепенно звукорежиссеры и продюсеры в своих творческих замыслах становятся смелее и пересекают ту черту, которая называется "официальными рекомендациями". Как нам подсказывает интуиция, в конечном итоге низкочастотный канал системы 5.1 будет использоваться "на полную катушку": там, где это нужно и где не нужно. Например, сама собою напрашивается идея задействовать низкочастотный канал для усиления ударов басового барабана в танцевальной музыке.
Как организовать мониторинг при сведении многоканального звука? Об этом идут споры. Однако большинство специалистов рекомендует использовать одинаковую акустику, не внося поправку на несовершенство домашних систем. Мониторы следует располагать на равном расстоянии от слушателя, в частности, три фронтальных монитора должны образовать дугу, а не прямую линию. Если это невозможно, то следует соответственно снизить громкость центрального монитора.
А как в идеале должны располагаться мониторы системы 5.1? Представьте себе, что вы находитесь в центре системы 5.1. Центральный монитор должен располагаться перед вами. Воображаемая линия между вами и центральным монитором является осью, относительно которой будет определяться расположение остальных мониторов. Левый и правый фронтальные каналы располагаются под углами -30° и 30° относительно этой оси. Таким образом, угол "левый монитор-вы-правый монитор" составляет 60°. В случае необходимости этот угол может быть уменьшен до 50° — 45°. Сабвуфер тоже должен располагаться где-нибудь перед вами. Тыловые мониторы должны располагаться под углами -110° (левый тыловой) и 110° (правый тыловой). В идеале все мониторы должны быть равноудалены от вас и откалиброваны таким образом, чтобы при подаче сигналов одинакового уровня на разные мониторы вы слышали их с одинаковой громкостью. Высота размещения мониторов — на уровне вашей головы или немного выше.


1.12.4. Особенности сведения в круговую панораму

Серьезно занимаясь проблемой обработки звука, мы на протяжении многих лет внимательно следим за публикациями, имеющими отношение к этой теме. Поэтому можем уверенно констатировать, что работ, посвященных вопросам технологии сведения в стерео, не так уж и много. А вот статей, содержащих конкретные рекомендации по созданию многоканальных записей, практически нет совсем. Видимо, это можно объяснить тем, что проблема нова, отсутствует необходимый опыт, нет сложившихся традиций. Во всяком случае, самостоятельные музыкальные произведения, сведенные в круговую панораму, еще не стали массовым явлением. Многоканальный звук, в основном, существует как дополнение к видеоизображению. Ясно, что подходы к панорамированию звука для саундтрека кинофильма и звука музыкальной композиции должны отличаться. При сопровождении видео требуется размещать основной звук спереди, так как именно на экране перед зрителем происходит действие. Задние каналы используются для придания звуку объема и реализации специальных эффектов. Конечно, при работе с surround-музыкой можно ориентироваться на наработки, имеющиеся в области создания звука для современной кинопродукции. То есть можно поместить основной звук спереди, слегка окружая слушателя, а тыловые каналы использовать для воссоздания акустики окружающей среды и перемещения второстепенных источников звука. И все же, если речь идет о музыкальном произведении, которое создается без расчета на увязку с видеосюжетом, то автор может пользоваться полной свободой в применении новых выразительных средств, заложенных в собственно круговой панораме. Например, вы можете "посадить" слушателя среди исполнителей, передвигать вокруг него все звуковое поле или отдельные источники звука, перемещать их в "глубину" панорамы.
Правда, спецэффекты панорамирования лучше использовать в меру. Например, вряд ли есть смысл конструировать виртуальный рояль, клавиатура которого, судя по звучанию, выглядит окружностью, охватывающей слушателя. Звуки ударных, помещенных в тыловые каналы, и особенно внезапные громкие звуки, раздающиеся сзади, вполне1 могут стать причиной, по которой ваше песня не станет хитом. Мало кому может понравиться, если придется то и дело рефлекторно оборачиваться или подскакивать от испуга.
При подготовке стереофонических записей мы вынуждены сознательно ограничивать себя в использовании возможностей стереопанорамы применительно к некоторым музыкальным инструментам. Причем ограничения продиктованы не только художественными, но и техническими соображениями. Например, совершенно нет смысла смещать бас с центра стереопанорамы. Во-первых, потому, что все равно в области низких частот стереоэффект проявляется очень слабо. Во-вторых, если бас панорамировать влево или вправо, то мощность одной из акустических систем не будет использоваться в полной мере. А это уже серьезный недостаток, так как на низкочастотную область спектра всегда приходится заметная доля общей мощности звукового сигнала.
Аналогичные проблемы имеются и в системах 5.1, хотя задачу формирования низкочастотных звуков здесь решает сабвуфер. Одна из таких проблем — использование центрального канала. В кино он предназначен для привязки доминирующих звуков к изображению, чтобы зрители, сидящие не по центру, воспринимали эти звуки, исходящими с экрана. В музыке те звуки, которые в стерео обычно направляются в левый и правый каналы равномерно (основной вокал, бас, часть барабанов), лучше распределять между центральным и фронтальными каналами. Это позволит избежать перегрузки центрального канала. Кроме того, различимость звуков увеличивается, если одни из них больше направлять в центральный канал, а другие — одновременно в левый и правый передние каналы.
Формат 5.1 предоставляет массу новых возможностей в применении эффектов, подобных дилэю и реверберации. Реверберационный сигнал может располагаться в том же направлении, что и прямой сигнал. Вместе с тем, подобно тому, как в стереозаписях перекрестное направление реверберации приводит к кажущемуся расширению стереобазы, впечатление увеличения объема виртуального помещения можно получить, если реверберацию фронтальных звуков сделать чуть сзади, а тыловых — чуть спереди. Не только сами кажущиеся источники звука, но и эхо-сигналы, порожденные ими, можно динамически перемещать в пределах круговой панорамы.
При сведении в круговую панораму появляются дополнительные признаки, по которым слух может выделять отдельные партии: направление на источник звука в пределах 360° и, в какой-то мере, расстояние до него (глубина панорамы). Поэтому нет особой необходимости производить частотную фильтрацию с целью выделения одних звуков на фоне других, а также изменять громкость инструментов по ходу песни или компрессировать отдельные аудиосигналы.
Что касается дополнительной обработки компрессором уже сведенной композиции, то такая операция представляется недопустимой. Она может привести к возникновению смещения положений кажущихся источников звука, предварительно позиционированных в определенных точках. А те из источников, текущие значения уровня сигналов которых в какой-то момент превысят порог срабатывания компрессора, будут к тому же и хаотично "перемещаться" по случайным траекториям. Думается, что ситуация изменится лишь с появлением широкодоступных многоканальных виртуальных эффектов и обработок, реализующих алгоритмы обработки, в которых учитывается специфика панорамирования объемного звука и психоакустический фактор. В настоящее время зачатки подобных алгоритмов можно найти в программных кодеках, преобразующих, например, WAV-файлы, располагающиеся на 6 отдельных треках в единый цифровой поток АС-3. К сожалению, суть таких алгоритмов скрыта от пользователя, а число параметров, доступных для регулировки, чрезвычайно мало.
Представляется, что обеспечение моносовместимости записей, сведенных в формате 5.1, нереально. Обеспечение стереосовместимости готовой фонограммы тоже проблематично. Видимо, единственно правильным решением будет целенаправленное и раздельное сведение композиции в моно, стерео и в формат 5.1.
Сущность, задачи и этапы мастеринга применительно к стереофоническим фонограммам - прямо скажем, проблема эта весьма непроста. А с мастерингом в многоканальных форматах дело обстоит еще сложнее. Многое еще не ясно. Не фильтровать, не компрессировать, не контролировать моносовместимость, не осуществлять подготовку к выводу альбома на различные носители. А что же тогда следует делать с записями 5.1 на этапе мастеринга?
И еще об одной вещи хочется сказать. Вы можете слушать FM-радио или CD и заниматься при этом своими делами, например, читать эту книгу. При этом важно, чтобы звук был комфортным: не должно быть перепадов громкости и тембра, отвлекающих от основного занятия. А вот слушать композицию в формате 5.1 "краем уха" практически невозможно. Сам по себе формат 5.1 подразумевает погружение слушателя в музыку. Поэтому еще один подход может заключаться в том, чтобы на этапе мастеринга в формате 5.1 не делать ничего, кроме, возможно, нормализации. То есть вся ответственность за субъективное качество конечной фонограммы переносится на этап сведения, а мастеринг осуществляется по принципу "что есть, то есть". А если же все-таки слушателю потребуется более комфортное звучание без перепадов громкости, то он может включить на своей системе соответствующую опцию (типа Enable Dynamic Range Compression — компрессия динамического диапазона).
Вопросы, связанные с пространственным панорамированием средствами Cubase SX, рассмотрены в разд. 4.2.2 и 5.4.


1.13. Выполнение основных операций в Cubase SX

В этом разделе мы познакомим начинающих пользователей программы Cubase SX с методиками выполнения самых необходимых операций. В первую очередь вам необходимо научиться загружать существующие файлы с проектами, воспроизводить сонг, создавать новый проект, записывать MIDI- и аудиотреки. Перечисленные элементарные операции лежат в основе работы над любой композицией. Освоив их, вы сможете затем двигаться дальше в изучении более сложных функций программы.


1.13.1. Загрузка файла с проектом

В меню File выберите команду Open. Откроется диалоговое окно Open Project (рис. 1.37), предназначенное для загрузки файла проекта.

Рис. 1.37.Диалоговое окно Open Project

В поле Look in: следует выбрать необходимую папку. Появится список файлов, находящихся в ней. В этом списке нужно найти и выделить файл, предназначенный для загрузки. Его имя отобразится в поле File name:. Остается нажать кнопку Open и файл откроется. Для того чтобы открыть файл, можно также сделать двойной щелчок на его имени в списке.
Если вы хотите увидеть имена всех файлов, хранящихся в выбранной папке, то в раскрывающемся списке Files of type: выберите строчку Any Type (*.*). Однако с помощью окна Open Project загрузить в Cubase SX вам удастся файлы только одного из двух типов:

  • Cubase Project File — файлы проектов программы Cubase SX, имеющие расширение CPR;
  • Nuendo Project File — файлы проектов программы Nuendo, имеющие расширение NPR.
Если в раскрывающемся списке Files of type: выбрать строчку Cubase Project File (*.срr), то в списке останутся только файлы проектов программы Cubase SX. При выборе в этом списке строчки Nuendo Project File (*.npr) — только файлы проектов программы Nuendo. Когда выбрана строчка All Types (*.cpr;*.npr) — и те и другие. Таким образом, списком Files of type: можно пользоваться как фильтром, сокращающим количество имен файлов, просматриваемых перед загрузкой, и облегчающим обнаружение необходимого файла.
Если у вас пока нет собственных файлов в формате Cubase Project File, то в целях обучения загрузке проектов и воспроизведению сонга воспользуйтесь файлами, находящимися в папке PROJECTS на диске, который сопровождает книгу.
Не нужно думать, будто программа Cubase SX способна работать только с файлами Cubase Project File и Nuendo Project File. Просто файлы других типов могут быть импортированы в программу не при помощи команды Open, а посредством других команд.
После загрузки файла в окне проекта на треках появится изображение частей. Если в проекте есть MIDI-сообщения, то в редакторе Score Editor появятся ноты, в редакторе Key Editor — отпечатки клавиш, а в редакторе List Editor — список сообщений. Можно в деталях рассмотреть, как устроена компьютерная музыка, написанная другими авторами. Но лучше, конечно, не только смотреть, но и слушать.


1.13.2. Воспроизведение сонга

Для воспроизведения сонга, загруженного в Cubase SX, воспользуйтесь кнопкой [image] расположенной на Transport Panel (рис. 1.38).

Рис. 1.38. Transport Panel. Нажата кнопка Play

Воспроизведение начнется с Т9го момента в композиции, которому соответствует положение указателя текущей позиции. Указатель текущей позиции виден во всех тех окнах программы, где присутствует временная координата. Он представляет собой вертикальную линию, которая в режиме "Stop" находится в той точке временной оси, в которой ее застала команда остановки воспроизведения или записи. В режиме записи и воспроизведения указатель текущей позиции скользит вдоль оси времени, отмечая те ноты, события, отсчеты оцифрованного звука, которые воспроизводятся (записываются) в данный момент. Для перемещения указателя текущей позиции к началу сонга служит кнопка [image] , к концу — кнопка [image] . Медленное перемещение указателя текущей позиции назад или вперед осуществляется нажатием кнопок [image] или [image] .

Для остановки воспроизведения нажмите кнопку [image] . Пуск и остановку воспроизведения можно также осуществлять нажатием клавиши <Spacebar> на компьютерной клавиатуре.
В главе 3 мы детально познакомим вас с Transport Panel. На этой панели кроме названных расположены и другие элементы, предназначенные для управления записью и воспроизведением сонга.


1.13.3. Открытие и закрытие проекта

Подготовку к записи своего первого MIDI-трека начните с того, что очистите память компьютера от предыдущего сонга, который вы прослушивали, выполняя рекомендации предыдущего раздела: в меню File выберите команду Close. Если в процессе работы с проектом вы внесли в него хоть одно изменение, то откроется окно, представленное на рис. 1.39.

Рис. 1.39. Запрос подтверждения решения о сохранении проекта с внесенными в него изменениями

Если вам нужно сохранить проект в измененном виде под прежним именем, то нажмите кнопку Save. Если же, например, изменения были внесены случайно или ошибочно и сохранять их нет смысла, то нажмите кнопку Don't Save. Нажав кнопку Cancel, вы тем самым откажетесь от закрытия проекта.
В принципе, Cubase SX позволяет держать открытыми одновременно несколько проектов, один из которых является активным. Но на первом этапе освоения программы лучше не усложнять себе задачу и работать только с одним открытым проектом. Итак, больше открытых проектов нет, а вы готовитесь к записи своего первого сонга. Начинать нужно с создания нового проекта.
Чтобы заготовить файл для нового проекта, в меню File выберите команду New Project. Откроется диалоговое окно New Project (рис. 1.40).

Рис. 1.40. Диалоговое окно New Project

У вас есть возможность выбрать для своего проекта один из заранее предусмотренных в программе шаблонов. Шаблон определяет:

  • сколько и каких (MIDI- и аудиотреков) будет в проекте;
  • какие атрибуты треков будут установлены для каждого из треков;
  • множество значений различных параметров, которые в большинстве шаблонов остаются принятыми по умолчанию.
Термин атрибуты в данном случае означает набор большого числа параметров трека. В качестве примера, перечислим некоторые из них:
  • название трека;
  • Channel — номер MIDI-канала, закрепленного за треком;
  • Bank and Programs — выбранный для трека MIDI-инструмент;
  • Input — порт ввода;
  • Output — порт вывода;
  • Volume — значение параметра, определяющего начальную громкость, установленную для трека;
  • Pan — значение параметра, определяющего начальную панораму трека (кажущееся положение источника звука на стереопанораме);
  • перечень подключенных к треку MIDI-эффектов реального времени или WST-плагинов и значения их параметров;
  • Delay — значение параметра, определяющего смещение во времени событий на треке относительно тактовой сетки.
Все подробности о работе с треками и их атрибутами вы узнаете в главе 4.
Среди шаблонов проектов, содержащихся в окне New Project, представленном на рис. 1.40, есть те, что поставляются вместе с программой, но есть и "самодельные". Со временем вы сами поймете, с какими конфигурациями программы вам приходится работать чаще всего, и сохраните их в виде шаблонов. Для этого нужно воспользоваться командой File > Save as Template, в открывшемся окне диалога задать имя шаблона и нажать кнопку ОК.
Если выбрать шаблон Empty (см. рис. 1.40), то откроется абсолютно чистое и пустое окно проекта, и далее вам нужно будет своими силами создавать в нем треки и устанавливать их атрибуты.
Сейчас же мы предлагаем вам обойти проблему установки атрибутов треков, выбрав шаблон проекта, приспособленный специально для записи MIDI-треков. В окне диалога New Project выделите строку 16 Track MIDI Sequencer и нажмите кнопку ОК. В результате сначала возникнет окно Select directory, в котором следует указать папку для хранения файла с будущим проектом.

Рис. 1.41. Окно Select directory

Рис. 1.42. Окно Cubase SX Project с выбранным шаблоном проекта

Вы можете нажать кнопку ОК, окно Select directory закроется, а в качестве папки проекта будет выбрана текущая папка. Можно нажать кнопку Create и создать новую папку, указав ее имя в открывшемся окне Select/Create new directory. После того как и в этом окне вы нажмете кнопку ОК, проект наконец-то будет создан, а перед вами предстанет во всей красе одно из основных окон программы — окно проекта Cubase SX Project (рис. 1.42).
Именно в этом окне наглядно представлена структура шаблона проекта:

  • в нем 16 треков (если видны не все треки, можно воспользоваться вертикальной полосой прокрутки);
  • номера треков специально установлены равными номерам MIDI-каналов (так проще ориентироваться);
  • начальный уровень громкости для каждого трека установлен равным 100 единицам (максимально возможное его значение составляет 127);
  • источники звука на всех треках панорамированы в центр (Pan = Off);
  • ни для одного трека не выбран MIDI-инструмент (bnk:off, prgroff). Фактически это означает то, что команда смены инструмента вообще не посылалась синтезатору. Поэтому, вероятнее всего, на данном канале будет звучать патч Grand Piano, который обычно автоматически устанавливается при инициализации синтезатора для всех MIDI-каналов кроме MIDI-канала 10, предназначенного для ударных инструментов.
Эти и некоторые другие сведения об атрибутах трека вы узнаете, переключая секции инспектора треков, расположенного справа.
Чтобы в дальнейшем не отвлекаться, есть смысл до начала записи выбрать для всех треков соответствующие MIDI-инструменты (программы, звуки, патчи, голоса). На первых порах, пока вы еще не умеете пользоваться богатейшими возможностями виртуальных VST-инструментов, вполне можно обойтись звуками, имеющимися в стандартном банке General MIDI вашей звуковой карты. Для трека MIDI 01 подберите подходящее по звучанию пианино, а сам трек можно переименовать в Piano, набрав это слово в поле ввода, расположенном в верхней части панели инспектора. Для трека MIDI 02, переименовав его в Bass, возьмите один из басовых инструментов. Для трека MIDI 03, переименовав его в Accompaniment, выберите, например, одну из гитар и т. д.
По умолчанию в данном шаблоне для каждого их 16 треков выбраны все существующие в вашей системе каналы ввода MIDl-данных (in: All MIDI Inputs). Это прекрасно подходит для того, чтобы записывать на трек результаты вашей игры на MIDI-клавиатуре. А вот порт вывода MIDI-сообщений по умолчанию не выбран (out: Not Connected). Устраните непорядок, выбрав в раскрывающемся списке Output вместо строки out: Not Connected какую-либо другую строку, означающую название порта управления синтезатором вашей звуковой карты или виртуальным синтезатором, подключенным к Cubase SX. Для начала, двигаясь от простого к сложному, выберите порт звуковой карты, установленной в вашем компьютере. В том компьютере, на котором готовился графический материал главы, установлена звуковая карта SB Live!. Поэтому в раскрывающемся списке Output имеется строка SB Live! Synth А. Если выбрать ее, то вместо отдельных раскрывающихся списков bnk: и prg: появится общий список Bank and Programs, в котором скрыты все MIDI-инструменты, соответствующие стандарту General MIDI: .

MIDI-инструмент можно выбрать двумя способами:
  • щелкая на стрелках раскрывающегося списка Bank and Programs каждого из треков, вы будете последовательно пролистывать список MIDI-инструментов;
  • двойным щелчком на поле этого раскрывающегося списка вы получите доступ к окну, в котором перечислены все банки и все MIDI-инструменты текущего банка (рис. 1.43).

Рис. 1.43. Окно выбора MIDI-инструментов

Выбор MIDI-инструмента для трека сводится к выделению одного из элементов данного меню.
При желании вы можете использовать не только стандартный банк GM, но и дополнительные банки инструментов в формате SoundFont 2 или банки виртуальных синтезаторов, подключенных к Cubase SX.
В целях упрощения процедуры поиска MIDI-инструментов в окне, представленном на рис. 1.43, предусмотрен фильтр. Наберите в поле Filter имя искомого инструмента, и соответствующая строка тут же появится в окне. Если вы не помните полного имени MIDI-инструмента — не страшно. Список, отображаемый в окне, можно существенно сократить. Для этого достаточно набрать в поле Filter хотя бы несколько букв, входящих в имя. На рис. 1.44 представлен пример: набраны буквы str, в списке остались имена только тех инструментов, в которые эти буквы входят.

Рис. 1.44. Пример применения фильтра имен MIDI-инструментов

Теперь, когда и MIDI-клавиатура подключена, и MIDI-инструменты для треков выбраны, можно послушать, как они звучат, а заодно и отрепетировать каждую из партий будущей композиции. Звучать будет тот трек (те треки), на котором (которых) вы нажмете одну из кнопок: или [image] .


1.13.4. Сохранение проекта. Форматы файлов

Запись еще не началась, но мы бы советовали уже сохранить ваш проект. Под проектом понимается файл, в котором кроме звуковых и МIDI-данных содержатся также всевозможные установки (созданные треки, подключенные эффекты, данные автоматизации управления виртуальным микшером, выбранные параметры, открытые окна, установленные режимы, текущая позиция, с которой начнется запись или воспроизведение, и многое другое).
Для первого сохранения файла с текущим проектом служит команда Save As меню File. По этой команде откроется диалоговое окно Save As, изображенное на рис. 1.45.

Рис. 1.45. Диалоговое окно Save As

В этом окне выберите каталог (в раскрывающемся списке Look in:), введите имя (в поле File name:) и нажмите кнопку Save. В окне Save As имеется также раскрывающийся список Files of type:, поэтому может создаться впечатление, будто есть выбор типа и расширения сохраняемого файла. Однако в Cubase SX (в отличие от предыдущих версий программы Cubase) проект можно сохранять в единственном формате: Cubase Project File (с расширением CPR).
Имеется возможность экспортировать из Cubase SX содержимое MIDI-треков в MIDI-файлы, а содержимое аудиотреков — в WAV-файлы (команды File > Export > MIDI File и File > Export > Audio Mixdown). Это может пригодиться, если работу над MIDI- или аудиоданными необходимо будет продолжить в какой-то другой программе.
Заметим, что для обеспечения некоторой совместимости с предыдущими версиями программы предусмотрено импортирование в Cubase SX WAV-файлов и MIDI-файлов, а также файлов с такими объектами, как сонг, аранжировка и часть (команды File > Import > Audio File..., File > Import > MIDI File..., File > Import > Cubase Song, File > Import > Cubase Arrangement, File > Import > Cubase Part...). Следует учитывать, что импортирование данных из файлов перечисленных типов (кроме WAV- и MIDI-файлов) осуществляется с некоторыми потерями.


1.13.5. Запись MIDI-трека

Запись MIDI-композиции можно осуществлять различными способами, но удобнее всего делать это с помощью MIDI-клавиатуры. Это и быстрее и позволяет сохранить стиль исполнителя. Без MIDI-клавиатуры вам вряд ли удастся придать звучанию произведения "драйв", характерный для мастерской игры "в живую".
Запись можно начинать с любого трека, выбранного вами. Для этого следует в поле необходимого трека нажать маленькую кнопку [image] (Record Enable). Кнопка окрасится в красный цвет.
Наигрывать партии композиции на MIDI-клавиатуре удобно под метроном (см. разд. 2.8).


Локаторы

В программе Cubase SX имеются локаторы, выполняющие различные функции. Этих локаторов два — левый и правый (Left Locator, Right Locator). Если вы нажимаете на транспортной панели кнопку [image] (Record), когда программа находится в режиме останова, то запись начнется от места, обозначенного левым локатором. Положения локаторов указаны графически на линейке в верхней части окна проекта [image] (локатор можно перемещать вдоль линейки, ухватившись за него курсором мыши), а также цифрами в левой части транспортной панели (рис. 1.46).

Рис. 1.46. Фрагмент транспортной панели. Индикатор положения локаторов

Существует также способ точной установки локатора. В программе Cubase SX любые цифровые поля (в том числе и поля значений локаторов) менять очень просто: щелчок в этом поле левой кнопкой мыши делает поле доступным для редактирования. Чтобы увеличить или уменьшить значение, воспользуйтесь клавишами вверх и вниз.
Для того чтобы начать запись "сначала", то есть с первого такта, установите левый локатор в положение 0001.01.01.000, что означает "первый такт, первая четвертная доля, первая четвертая часть первой доли, нулевой тик".


Музыкальное время в Cubase SX

В Cubase SX счет музыкального времени организован своеобразно. Рассмотрим для примера показания счетчика, который находится на транспортной панели и отображает положение указателя текущей позиции (рис. 1.47).

Рис. 1.47. Фрагмент транспортной панели. Счетчик указателя текущей позиции

Счет времени ведется следующим способом:
1. Подсчитываются такты, и их количество отображается числом, расположенным слева от левой точки (в примере на рис. 1.46 это число составляет 6064). На первый взгляд кажется, что в проекте может быть не более 9999 тактов. На самом деле это не так. По мере необходимости в счетчике тактов появляются дополнительные разряды.
2. Внутри каждого такта подсчитываются доли (в примере на рис. 1.46 это число составляет 03). Количество долей в такте определяется тем, какой музыкальный размер вы зададите (дробь в правой области транспортной панели), максимальное разрешенное число долей составляет 16.
3. Внутри каждой доли подсчитываются части долей (в примере на рис. 1.46 это число составляет 01). Каждая четвертная доля автоматически делится на 4 части, восьмая — на 2, шестнадцатая доля на части неделима (в ней заключена ровно одна часть).
4. Каждая часть доли в свою очередь делится на 120 тиков (в примере на рис. 1.46 это число составляет 038). Счет тиков ведется от 0 до 119. Таким образом, на шестнадцатую долю приходится 120 тиков, а на четвертную — 480.
Такая организация счета музыкального времени поначалу иногда вводит в заблуждение: некоторые пользователи воспринимают обе правые группы цифр как количество тиков. Игнорируя правую точку, такие пользователи могли бы запись, приведенную в примере (01.038 — первая часть, 38 тиков), истолковать абсолютно неправильно как 1038 тиков. Нам даже как-то встретилась публикация, автор которой, вероятно, не разобравшись с показаниями счетчика, утверждает, что в Cubase максимальная разрешающая способность секвенсора составляет более 15 тысяч тиков на четверть. Это совершенно неверно. Разрешающая способность Cubase SX равна 480 тикам на четверть.
Теперь в правой части транспортной панели установите нужный музыкальный темп и размер (в полях, расположенных справа от кнопок Click и Master). Размер устанавливается в традиционном формате, например, 3/4, 6/8, 2/2 и т. п. Темп устанавливается в стандартных единицах "количество долей в секунду".
Для того чтобы легче было сыграть отрывок ровно, нажмите кнопку Click на панели управления. В этом случае метроном будет "отбивать" каждую долю такта. Для того чтобы быстро, "на ходу" включать или выключать кнопку Click, можно просто нажимать клавишу < С >.


Первая попытка записи с MIDI-клавиатуры

Итак, MIDI-трек выбран, левый локатор установлен, метроном подготовлен, можно начинать запись.
Приступайте к записи, нажав на транспортной панели кнопку [image] (Record). Наиграйте задуманную вами партию на МIDI-клавиатуре.Для завершения записи фрагмента нажмите на транспортной панели кнопку [image] (Stop), либо на компьютерной клавиатуре нажмите <Spacebar>. Записанные MIDI-сообщения появятся на MIDI-треках в объектах, которые в терминологии Cubase SX называются частями. О частях мы будем говорить еще не один раз. Пока что для простоты можете считать, что в результате записи вы заполнили MIDI-сообщениями некоторые фрагменты MIDI-треков.
Если вам не понравилось то, что вы записали (а в самый первый раз так оно, вероятно, и будет), можно отменить результаты записи. Для этого в меню Edit выберите пункт Undo или нажмите комбинацию клавиш <Ctrl> + <z>. Сыграйте на MIDI-клавиатуре поочередно все партии. Помните, что вам не обязательно записывать музыкальное произведение целиком. Его можно "собрать по частям" из отдельно записанных и отредактированных фрагментов.
Записанные партии нужно отредактировать, устранив ошибки. Затем следует разнести виртуальные источники звука по стереопанораме и добиться необходимого баланса в совместном звучании партий композиции для каждого трека. Можно обработать некоторые MIDI-треки эффектами (например, реверберацией и хорусом), но особенно увлекаться этим не следует. В дальнейшем вам, скорее всего, захочется переписать партии с MIDI-треков на аудиотреки с тем, чтобы уже к ним применить гораздо более разнообразные и интересные аудиоэффекты. Поэтому предпочтительнее оставлять исходные MIDI-треки "сухими": без каких-либо обработок.


1.13.6. Запись звуковых данных с внешнего источника

Надеемся, что первый опыт записи MIDI-аккомпанемента у вас удался, да и файл с проектом вы сохранить не забыли. В таком случае можно начинать подготовку к дополнению полученной записи вокальной партией или партией в исполнении реального акустического музыкального инструмента. Но сначала нужно подключить микрофон к звуковой карте.
Предположим, у вас уже есть микрофон. Он подключен к микрофонному входу звуковой карты либо непосредственно, либо через согласующий усилитель, либо через микшер. При записи вокала также понадобятся наушники. С их помощью исполнитель будет слушать аккомпанемент.
Вообще-то для записи и редактирования звука предназначены специальные программы — звуковые редакторы, например, Cool Edit Pro.
Возможностей такого редактора было бы достаточно, если бы вы решили записывать речь. Им можно было бы обойтись также и при записи вокала, если бы в вашем распоряжении уже была "минусовая" фонограмма будущей песни, сохраненная в WAV-файле. И он, конечно, пригодится вам, когда дело дойдет до "чистки" вокальной партии. Но многие музыканты приступают к записи вокала сразу же после того, как в MIDI-редакторе (секвенсоре) создадут MIDI-треки с аккомпанементом (MIDI-трек — это трек, ассоциированный с MIDI-портами ввода и вывода, предназначенный для хранения MIDI-данных). И это довольно разумно. Ведь воспроизведение MIDI-треков, сколько бы их ни было, занимает меньшую часть ресурсов компьютера по сравнению с воспроизведением оцифрованного звука. В принципе, MIDI-инструменты никогда не поздно переписать на аудио-треки (аудиотрек — трек, ассоциированный с аудиопортами ввода и вывода, предназначенный для хранения аудиосообщений — сообщений о начале воспроизведения звуковых файлов). И даже желательно, в конце концов, сделать это для того, чтобы появилась возможность обработать каждый инструмент различными звуковыми эффектами. И все же получается, что неизбежен этап одновременной работы с аудио- и MIDI-треками, поэтому без универсального музыкального редактора не обойтись. Разумеется, в качестве такого редактора в данной книге мы будем рассматривать Cubase SX.
Загрузите в программу файл с той MIDI-композицией, к которой собираетесь дописывать вокальную партию. Откроется окно проекта программы Cubase SX.


Создание аудиотрека

Вам нужно создать аудиотрек для записи пения. Для этого в меню Project выберите команду Add Track > Audio. К существовавшим ранее MIDI-трекам добавится аудиотрек (рис. 1.48). Он пока чист.
Чтобы работать было удобно, можно увеличить масштаб отображения треков по вертикали кнопкой Zoom In Vertical, расположенной в нижней области вертикальной линейки прокрутки.
Для созданного трека нужно задать ряд его параметров — выбрать атрибуты. Доступ к атрибутам осуществляется с помощью элементов интерфейса, расположенных на поле инспектора. Не все из представленных там возможностей понадобятся вам при записи звука с микрофона. Например, не будем использовать пока аудиоэффекты. Кстати говоря, исходную запись целесообразно выполнить без какой-либо обработки эффектами и в таком виде хранить, а экспериментировать с ее копией. Не станем также изменять предусмотренные по умолчанию начальные значения уровня громкости (Vol = 0.0) и панорамы (Pan = С, будет ощущение, что источник звука расположен в ее центре). Вот без чего нельзя обойтись, так это без портов ввода и вывода.

Рис. 1.48. Окно Cubase SX Project с частями, записанными на MIDI-треках, и созданным аудиотреком


Выбор портов ввода и вывода

Для выбора порта ввода звуковых данных служит раскрывающийся список [image] (Input Routing), расположенный на панели инспектора.
В зависимости от формата аудиотрека (моно или стерео) стереофонические порты могут быть логически разбиты на два монофонических:
1. Источник звука левого канала.
2. Источник звука правого канала.
Стереофоническому источнику звука должен соответствовать стереофонический аудиотрек. А если вы ведете запись с помощью единственного монофонического микрофона, то не обязательно выбирать стереофонический формат трека. Звук все равно будет монофоническим, а такой трек займет
файл удвоенного объема по сравнению с монофоническим вариантом. Для переключения формата трека с монофонического на стереофонический и наоборот следует воспользоваться кнопкой Stereo Switch, расположенной на панели инспектора. Вид кнопки изменяется: означает, что включен монофонический формат, [image] - стереофонический.
Но не спешите расстраиваться по поводу монофоничности фонограммы записанного голоса. Даже в профессиональных студиях вокал, как правило, записывается в монофоническом формате. Чтобы выполнить стереозапись голоса, нужны особые условия и либо пара определенным образом расположенных идентичных микрофонов, либо специальный стереомикрофон. Монофонический формат трека никогда не Поздно преобразовать в стереофонический, но делать этого вам, скорее всего, не придется, так как придать записи объемное псевдостереофоническое звучание можно с помощью обработки эффектами, основанными на задержке сигнала. Об этом написано в главе 13.
Для того чтобы звуковые данные с трека поступали на определенное устройство воспроизведения, необходимо выбрать соответствующий порт вывода. На данном этапе обучения работе с Cubase SX просто убедитесь, что в списке [image] (Output Routing) выбрана основная шина виртуальный порт вывода, обозначаемый буквами BUS 1.
Значения некоторых параметров, отвечающих за качество записи и воспроизведения звука, выбираются в окне Project Setup, которое открывается командой Project > Project Setup. Выбор устройств воспроизведения звука осуществляется в окне Device Setup (команда Devices > Device Setup). Формат звуковых данных (от стерео до 5.1) выбирают в окне VST Master Setup (команда Devices > VST Master Setup). С помощью опций этих окон производится утонченное конфигурирование канала цифрового звука. Но это уже высший пилотаж. Для первоначального же освоения технологии записи звука вполне достаточно будет значений параметров, которые предусмотрены по умолчанию.


Настройка уровня сигнала

Последнее, что осталось сделать до начала записи, — установить уровень сигнала, поступающего на аналого-цифровой преобразователь звуковой карты. О теоретических основах измерения уровня сигнала мы рассказали в разд. 1.11.1. Сейчас пришло время практики. С помощью микшера звуковой карты вам следует произвести необходимую коммутацию и установить оптимальный уровень входного сигнала. Пытаться подробно описывать эту процедуру нет смысла, так как звуковые карты и соответствующие им драйверы микшеров могут быть самыми разными. Контролируется уровень с помощью измерителя уровня сигнала программы Cubase SX (рис. 1.26).
После завершения всех подготовительных операций наконец-то можно и приступить непосредственно к записи звука на аудиотрек.
В поле трека (или на панели инспектора) окна Cubase SX Project нажмите маленькую кнопочку [image] (Enable Record), она окрасится в красный цвет, что означает готовность трека к записи. После этого певец должен прочистить горло, устроиться удобнее перед микрофоном, набрать в легкие воздух и ждать, когда вы нажмете кнопку [image] (Record) на транспортной панели программы Cubase SX. Нажимайте! Поле трека стало красным. Зазвучал аккомпанемент, песня полилась.
Итак, мы рассказали начинающим компьютерным музыкантам о том, как выполнить самые необходимые операции: подключить MIDI-клавиатуру и микрофон к звуковой карте, загрузить, сохранить и воспроизвести файл с проектом, записать MIDI- и аудиотреки. А теперь приступим к детальному изучению возможностей программы Cubase SX.


Глава 10. Применение VSTi

    • Применение VSTi
    • 10.1. Псевдоаналоговый синтезатор А1
    • 10.1.1. Архитектура синтеза
    • 10.1.2. Исполнительские параметры
    • 10.2. Синтезатор звучания бас-гитары Vb-1
    • 10.3. Драм-машина Lm-7


Применение VSTi

В предыдущих разделах книги уже рассмотрены многие вопросы, связанные с применением VSTi. Перечислим основные из них.

  • Сущность VSTi (см. разд. 1.5.3).
  • Подключение VSTi (см. разд. 4.1.3).
  • Автоматизация параметров VSTi (см. разд. 4.7.8).
  • Маршрутизация сигналов, генерируемых VSTi, их обработка VST-плаги-нами. особенности управления VSTi (см. главу 5, разд. 5.3.2, разд. 5.3.3).
  • Получение информации о плагинах, включая VSTi (см. разд. 5.6.1).

Напомним, что VSTi — это программный интерфейс, позволяющий подключать виртуальные инструменты (синтезаторы, сэмплеры, управляемые по MIDI процессоры эффектов и др.) к приложениям — виртуальным студиям. По своей сути VSTi являются VST-штагинами, управляемыми по протоколу MIDI и генерирующими аудиосигнал. Обмен данными с VSTi по MIDI может быть двусторонним, т. е. VSTi могут не только получать MIDI-команды, но и сами их генерировать. Поэтому панели VSTi можно расценивать как виртуальные MIDI-контроллеры.
Многие VSTi включают в себя процессоры эффектов (реверберации, хоруса, задержки и др.). Однако зачастую имеет смысл использовать внешние по отношению к VSTi эффекты и обработки, общие и для VSTi и для аудиотреков. Согласитесь, когда для обработки VSTi используется один алгоритм реверберации, а для аудиотрека другой, то звучать это будет не совсем естественно. Кроме того, в области создания VST-эффектов и VSTi уже давно сложилось некое разделение труда: какие-то производители специализируются на создании шикарных VSTi, а какие-то создают неплохие эффекты и обработки. Поэтому наилучшего результата можно добиться путем комбинирования передовых разработок разных производителей.
В некоторых VSTi предусмотрена возможность вывода генерируемого сигнала не по одному, а по нескольким каналам. После подключения VSTi к проекту в микшере Cubase SX появляются модули, соответствующие каждому из каналов VSTi. Они мало чем отличаются от модулей аудиотреков. Для каждого из каналов независимо вы можете использовать эффекты и обработки, реализованные в виде VST-плагинов.
Мы уже говорили, что сосчитать общее число VST-плагинов, разработанных в мире, не представляется возможным. То же самое справедливо и в отношении VSTi, ведь VSTi можно рассматривать как частный случай VST.
Частота появления новых VSTi велика. Соответственно велика и скорость морального старения существующих VSTi. Поэтому, работая над этой главой, мы поставили себе задачу познакомить вас лишь с теми тремя VSTi, которые входят в поставку Cubase SX, но не входили в поставку предыдущих версий Cubase.
После подключения VSTi к проекту его панель можно вызвать двумя способами. Способ первый — щелчком на кнопке [image] в том слоте окна VST Instruments (см. разд. 4.1.1), к которому подключен нужный VSTi. Способ второй — щелчком на кнопке [image] в основной секции инспектора того MIDI-трека, который настроен на работу с нужным VSTi (см. разд. 4.1.2). На панели VSTi собраны все доступные для пользователя параметры. В верхней части панели каждого VSTi имеются элементы, общие для всех VSTi [image] . Перечислим их слева направо: кнопка временного отключения VSTi, кнопка включения режима воспроизведения автоматизации (R), кнопка включения режима записи автоматизации (W), кнопки для перебора пресетов, список пресетов. Нажатием на кнопку File открывается меню, содержащее следующие команды:

  • Load Bank — загрузить банк пресетов из файла;
  • Save Bank — сохранить банк пресетов в файле;
  • Load Instrument — загрузить отдельный пресет из файла;
  • Save Instrument — сохранить текущий пресет в файле.

Под пресетом понимается совокупность всех пользовательских настроек. Перечисленные элементы являются общими для всех VSTi потому, что они в действительности являются принадлежностью Cubase SX. Если открыть тот же самый VSTi из какого-нибудь другого приложения, то изменится состав и дизайн перечисленных элементов в соответствии с дизайном приложения-хоста. В дальнейшем мы будем говорить только об элементах интерфейса, являющихся принадлежностью конкретного VSTi.


10.1. Псевдоаналоговый синтезатор А1

Знакомьтесь — однотембральный полифонический псевдоаналоговый синтезатор А1 (рис. 10.1). Основные характеристики: 16-голосная полифония, 2 осциллятора, фильтр с переключаемой характеристикой, встроенный эффект хорус/флэнжер. Нам удалось насчитать четыре метода синтеза, поддерживаемых А1: широтно-импульсная модуляция (ШИМ), частотная модуляция (ЧМ), кольцевая модуляция, аддитивный синтез.

Рис. 10.1. Панель псевдоаналогового синтезатора А1

Поскольку синтезатор однотембральный, управлять им можно по любому MIDI-каналу. Вернее, при настройке MIDI-трека на работу с А1 вообще не требуется задавать какой-то конкретный MIDI-канал. То есть в поле out: основной секции инспектора MIDI-трека следует вместо MIDI-канала указать ANY ("любой").
В нижней части панели А1 имеется виртуальная MIDI-клавиатура. Ее можно использовать для того, чтобы в условиях отсутствия настоящей MIDI-клавиатуры послушать звучание текущего пресета. В отличие от некоторых других VSTi, после подключения А1 к проекту возникает только его входной виртуальный MIDI-порт. То есть команды, поступающие от MIDI-клав-иатуры, как, впрочем, и от других устройств управления, невозможно записать на MIDI-трек. Конечно, потеря не велика. Вы можете в полной мере использовать автоматизацию для записи изменений положений элементов управления А1 в режиме реального времени.
Панель А1 поделена на секции, каждая из которых содержит параметры определенного блока синтезатора и названа по имени этого блока. В центральной части панели А1 (над группой Filter Envelope) имеется специальная информационная строка. Когда вы будете изменять значение какого-либо параметра, в данной строке будут отображаться следующие сведения:

  • название секции, к которой принадлежит параметр (Section);
  • название параметра (Parameter);
  • значение параметра (Value);
  • номер MIDI-контроллера, которым параметр управляется (Ctrl.).


10.1.1. Архитектура синтеза

В основе А1 лежат два осциллятора Oscillator 1 и Oscillator 2 — два генератора сигналов звуковой частоты. Генератор низкочастотных сигналов LFO используется для создания таких эффектов, как вибрато, тремоло, "вау-вау" и др. Два генератора огибающих (Filter Envelope и Amplifier Envelope ) нужны для формирования изменяющегося во времени тембра. В секции микшера (Mixer ) сигналы с выходов осцилляторов могут просто смешиваться (этому соответствует аддитивный метод синтеза) и/или перемножаться (метод синтеза — кольцевая модуляция). Кроме того, в микшере к ним может подмешиваться шумоподобный сигнал (Noise ). Благодаря наличию генератора шума имеется возможность создавать всевозможные эффекты типа "шум ветра" или "морской прибой", перкуссионные звуки. Сигнал с выхода микшера проходит обработку фильтром (Filter ) и модулируется по амплитуде генератором Amplifier Envelope . Теперь рассмотрим параметры синтеза подробнее.

Рис. 10.2. Параметры осцилляторов

Секции осцилляторов показаны на рис. 10.2. Перечислим параметры, общие для обоих осцилляторов:

  • сдвоенный регулятор Semitone/Octave — смещение частоты осциллятора с шагом полутон/октава;
  • Detune — смещение частоты осциллятора в долях центров;
  • кнопки выбора формы волны ( [image] — синусоидальная, [image] — треугольная, [image] — пилообразная, [image] — прямоугольная с изменяемой скважностью);
  • PW — скважность прямоугольной волны;
  • PWMod — глубина модуляции параметра PW генератором LFO (для создания переливающегося звука);
  • PitchMod — глубина модуляции частоты осциллятора генератором LFO (для создания эффекта частотного вибрато).

Для Oscillator 1 доступны два дополнительных параметра:

  • FM — глубина частотной модуляции (сигнал Oscillator 2 модулирует сигнал Oscillator 1 );
  • FMEnv — модуляция параметра FM генератором Filter Envelope .

Секция генератора низкочастотных сигналов LFO показана на рис. 10.3.
Форма генерируемой волны выбирается с помощью шести кнопок, расположенных в правой части группы LFO . Кнопкой Sync , включается синхронизация частоты LFO с темпом проекта. Положением регулятора Speed задается частота генерируемого сигнала. В режиме Sync частота задается в долях такта. Если режим Sync выключен, частота LFO задается в герцах.
С выходов осцилляторов сигналы поступают в блок микшера, которому соответствует секция Mixer (рис. 10.4). Регуляторами Osc 1 и Osc 2 задаются уровни сигналов осцилляторов. Регулятором RingMod задается глубина кольцевой модуляции (уровень сигнала, полученного в результате перемножения сигналов осцилляторов, в общем миксе). Регулятором Noise задается уровень шумоподобного сигнала.

Рис. 10.3. Параметры генератора низкочастотных сигналов

Рис. 10.4. Секция Mixer

Сигнал с выхода микшера проходит обработку фильтром. Параметры фильтра показаны на рис. 10.5. В правой верхней части секции Filter расположены кнопки выбора типа фильтра. С помощью кнопок 12dB и 24dB задается наклон характеристики фильтра: 12 dB на октаву или 24 dB на октаву, соответственно.

Рис. 10.5. Параметры фильтра

Перечислим остальные параметры.

  • Cutoff — частота среза.
  • Resonance — подъем характеристики на частоте среза (резонанс).
  • Drive — глубина эффекта дистошн.
  • Envelope — глубина модуляции параметра Cutoff генератором огибающей Filter Envelope .
  • Velocity — степень влияния скорости нажатия клавиши на параметр Cutoff .
  • CutoffMod — глубина модуляции параметра Cutoff генератором LFO .
  • Keytrack — степень влияния номера MIDI-клавиши на параметр Cutoff .

Параметры генератора Filter Envelope доступны в одноименной секции (рис. 10.6). Вы можете влиять на фазы генератора с помощью регуляторов Attack (время атаки), Decay (время спада до уровня Sustain ), Release (время освобождения). Однако это удобнее делать в графической форме путем перемещения узлов графика изменения сигнала на выходе генератора во времени (по горизонтали — время, по вертикали уровень сигнала).

Рис. 10.6. Секция Filter Envelope

Традиционно запуск генераторов огибающих происходит в момент нажатия MIDI-клавиши. Начало фазы Release соответствует моменту, когда MIDI-клавиша отпущена. На выходе генератора формируется не периодический сигнал, а сигнал, который плавно изменяется во времени в соответствии с графиком.
Обработанный фильтром сигнал подается на вход усилителя, которому соответствует секция Amplifier (рис. 10.7). Доступные параметры:

  • Velocity — степень влияния скорости нажатия клавиши на коэффициент усиления;
  • Volume — общая громкость;
  • Mono — включение одноголосного режима синтезатора.

Последний параметр не имеет никакого отношения к усилителю. Видимо, разработчикам его просто некуда было пристроить.
В синтезаторе А1 имеется еще один генератор огибающей: Amplifier Envelope . Он полностью аналогичен генератору Filter Envelope , но используется для другой цели: амплитудной модуляции (сигнал с выхода Amplifier Envelope воздействует на коэффициент усиления).
Пока мы еще не очень далеко ушли от параметра Mono , следует упомянуть поле Voices , в котором вы можете задать полифонию синтезатора. Данное поле не входит ни в одну из секций панели А1. Изменить полифонию можно следующим образом: хватаетесь мышью за поле и тащите его вверх или вниз. Конечно, само поле остается на месте, но число внутри него будет увеличиваться или уменьшаться.

Рис. 10.7. Секция Amplifier

Рис. 10.8. Секция эффекта

Сигнал с выхода усилителя проходит обработку в блоке эффекта. Соответствующая секция панели А1 называется Chorus/Flanger (рис. 10.8). Кнопка On включает блок эффекта. Регулятором Speed задается частота модуляции времени задержки копий сигнала. Feedback — глубина обратной связи. Depth — глубина эффекта. Кнопка Quad включает режим, в котором увеличивается количество задерживаемых копий сигнала, и в результате получается более насыщенное звучание.


10.1.2. Исполнительские параметры

Знаете, какое устройство, расположенное на MIDI-клавиатуре, является следующим по важности после самих белых и черных клавиш? Это колесо модуляции. Правда, в некоторых MIDI-клавиатурах оно совмещено с колесом изменения тона в одном регуляторе, похожем на джойстик, но суть от этого не изменяется.
Вы можете определять реакцию А1 на изменение положения колеса модуляции. Соответствующие параметры доступны в секции Mod Wheel (рис. 10.9):

  • PitchMod — степень воздействия колеса на параметры PitchMod осцилляторов (частотное вибрато);
  • CutoffMod — степень воздействия колеса на параметр PitchMod фильтра (эффект "вау-вау");
  • Cutoff — степень воздействия колеса на параметр Cutoff фильтра (управление частотой среза).

Мы уже говорили о том, что в нижней части панели А1 имеется виртуальная MIDI-клавиатура. На этой клавиатуре как раз присутствуют и колесо модуляции Mod , и колесо изменения тона Pitch , хотя вряд ли их всерьез можно использовать. Слева от них имеется поле В.-Range . В нем задается диапазон, в пределах которого тон может изменяться колесом Pitch . Параметр B.-Range может быть полезен, т. к. он относится не к конкретному "игрушечному колесику", а вообще к тому, как А1 будет интерпретировать MIDI-сообщения от колеса изменения тона.
Синтезатор А1 поддерживает портаменто (плавное изменение высоты тона при переходе от одной ноты к другой). Включается портаменто с помощью кнопки On , расположенной в секции Glide (рис. 10.10). Скорость перехода задается регулятором Speed .

Рис. 10.9. Секция Mod Wheel

Рис. 10.10. Секция Glide

Само собой разумеется, вы можете управлять любым параметром А1 по MIDI. Однако в большинстве случаев для этого удобнее использовать автоматизацию Cubase SX. Включаете кнопки R и W в верхней части панели А1, запускаете проект на воспроизведение, вращаете любые регуляторы — все ваши действия сохраняются на специальном треке (см. разд. 4.7.8).


10.2. Синтезатор звучания бас-гитары Vb-1

Инструмент Vb-1 — это однотембральный полифонический (четыре голоса) синтезатор физического моделирования, имитирующий звучание бас-гитары. В Vb-1 применены алгоритмы физического моделирования, имитирующие процессы генерации звука в реальных музыкальных инструментах (например, колебания струны). Благодаря этому, звучание Vb-1 действительно очень похоже на звучание настоящей бас-гитары.
Так же, как и А-1, инструментом Vb-1 можно управлять по любому MIDI-каналу (не важно, по какому именно). Vb-1 воспринимает сообщения типа Note , а также сообщения о смене значений контроллеров громкости и панорамы. Не густо по сравнению с А-1, у которого каждый параметр может управляться отдельным контроллером. Однако такова специфика Vb-1.

Рис. 10.11. Панель Vb-1

Панель Vb-1 показана на рис. 10.11. Непосредственно под изображением струн расположен магнитный звукосниматель (Pick-up). Его можно перемещать вдоль струн. Над струнами изображен медиатор (Pick). Перемещением его вдоль струн задается позиция, в которой происходит удар по струне (щипок). От положения этих двух элементов существенно зависит тембр звука.
Регулятором Shape задается характер щипка. Регулятором Damper задается подъем демпфера, а регулятором Vol. — общая громкость.


10.3. Драм-машина Lm-7

Lm-7 12-голосная драм-машина (drum machine) с 24-битными сэмплами. Обычно под драм-машиной понимается устройство, совмещающее в себе синтезатор ударных звуков и секвенсор. Lm-7 не совсем подходит под такое определение. Это скорее проигрыватель сэмплов, управляемый по MIDI. Однако производители назвали Lm-7 именно драм-машиной, поэтому и мы будем придерживаться этой же терминологии. В поставку Lm-7 входит 6 наборов (sets) ударных звуков. По умолчанию загружен банк из трех наборов: Compressor, 909 и Percussion. Конкретный набор выбирается в качестве пресета VSTi. Остальные три набора (Fusion, DrumNbass, Modulation) будут доступны, если загрузить файл банка пресетов Im7_second_set.fxb, который по умолчанию располагается в папке C:\Program Files\Steinberg\Cubase SX\ Vstplugins\Drums. В нижней части панели Lm-7 (рис. 10.12) расположен набор из 12 пэдов, каждый из которых соответствует своему ударному звуку. Нажимая на пэды мышью, вы можете извлекать звуки. Но это не является основным назначением пэдов. Как только вы щелкнете на каком-либо из пэдов, соответствующий пэду звук получит статус текущего (над пэдом загорится светодиод).

Рис. 10.12. Панель Lm-7

В правой части панели Lm-7 расположена линейка из трех параметров:

  • Velocity — чувствительность Lm-7 к скорости нажатия клавиши (глобальный параметр, относится ко всем звукам);
  • Panorama — расположение текущего звука на стереопанораме;
  • Volume — общая громкость.

Обращаем ваше внимание на то, что параметр Panorama относится только к текущему звуку.
Каждому ударному звуку соответствует по паре регуляторов:

  • Vol . — громкость конкретного звука в общем миксе;
  • Tune — высота тона (скорость воспроизведения сэмпла ударного звука).

Как видите, все достаточно просто. Осталось рассмотреть вопросы, связанные с управлением Lm-7 no MIDI.
Управлять Lm-7 можно по любому из MIDI-каналов. Единственный тип сообщений, воспринимаемый Lm-7 — сообщения типа Note . Каждому ударному звуку соответствует своя MIDI-клавиша. Таблица соответствия приведена в описании Cubase SX. Но работать с Lm-7 можно и не заглядывая в эту таблицу. Ударные звуки на MIDI-клавиатуре можно "нащупать" (это будет быстрее, чем поиск в руководстве).
В завершение главы хочется отметить высокое качество звучания Lm-7 и высказать сожаления по поводу скудных возможностей управления этим инструментом.


Глава 11. Использование приложений, поддерживающих протокол ReWire

    • Использование приложений, поддерживающих протокол ReWire
    • 11.1. Подключение приложений ReWire к Cubase SX
    • 11.2. Управление устройствами Reason
    • 11.3. Особенности совместного применения Cubase SX и приложений Re Wire


Использование приложений, поддерживающих протокол ReWire

В Cubase SX имеется поддержка технологии ReWire 2.0, предназначенной для обмена аудиоданными между приложениями. Что это означает? Самый яркий пример, иллюстрирующий возможности ReWire — вы можете подключить к своему проекту виртуальную студию Propellerhead Reason и использовать ее, словно это VSTi. В Reason версии 2.0 имеется свой секвенсор, однако он объективно проигрывает секвенсору Cubase SX по возможностям. Например, отсутствует представление музыкальной информации в виде списка сообщений и нот. Кроме того, секвенсор Reason не позволяет работать с аудиоинформацией. Конечно, вы можете отредактировать аудиофайл в редакторе третьей фирмы, загрузить его в виртуальный сэмплер и управлять им по MIDI. Однако на практике это очень неудобно. Подключив Reason к Cubase SX, вы получаете в свое распоряжение одновременно и мощь виртуальных синтезаторов, сэмплеров, паттерновых секвенсоров, драм-машин, а также других устройств виртуальной студии Reason, и гибкость секвенсора Cubase SX. Кроме того, какие-то вещи все же удобнее делать в секвенсоре Reason. Протокол ReWire обеспечивает точную синхронизацию транспорта и локаторов Cubase SX и Reason. О синхронизации аудиопотоков с точностью до сэмпла и говорить не стоит, т. к. Reason при подключении к Cubase SX фактически работает в качестве плагина. Такой режим работы называется ReWire Slave Mode. Никаких проблем с синхронизацией и быть не может, т. к. оба приложения сливаются в нечто целое. Reason — не единственное приложение, которое можно подключить к Cubase SX no ReWire. Например, знаменитый Rebirth 338 также поддерживает ReWire. Однако в качестве иллюстрации технологии ReWire мы выбрали пример совместного использования именно Cubase SX и Reason.


11.1. Подключение приложений ReWire к Cubase SX

Перейдем к практике. При соединении двух приложений по ReWire важен порядок, в котором эти приложения запускаются. В первую очередь следует запускать Cubase SX. Программа Cubase SX распознает наличие установленных приложений, поддерживающих ReWire. Причем не обязательно, чтобы эти приложения были запущены. В списке Devices окна Device Setup, вызываемого командой главного меню Devices > Device Setup, появляется устройство с названием приложения (в нашем случае Reason). Соответствующая команда появляется в подменю Device главного меню. Воспользуемся командой главного меню Devices > Reason, в результате чего откроется окно Reason (рис. 11.1).

Рис. 11.1. Окно Reason

В данном окне представлена таблица соответствия выходных каналов Reason каналам микшера Cubase SX. В левом столбце ReWire представлены названия каналов Reason. В среднем столбце ACTIVE расположен ряд кнопок включения соответствующих каналов. В правом столбце VST LABEL расположены названия для этих же каналов в микшере Cubase SX. По умолчанию в Reason используются первые два канала, которые образуют стереопару. Кроме них, в принципе, доступны еще 62 канала. Будут ли они задействованы реально или нет — зависит от проекта, который вы загрузите в Reason. Давайте включим первые два канала. При этом произойдет любопытная вещь: оба канала получат одинаковое название в графе VST LABEL. Дело в том, что сразу после того, как вы включаете канал ReWire, в микшере Cubase SX появляется соответствующий модуль. Первым двум каналам Reason соответствует стереофонический модуль, который может иметь только одно название. Остальные каналы Reason задуманы как монофонические. Однако вы можете комбинировать их как угодно: хоть в стереопары, хоть в 5.1. Но, как бы там ни было, при включении любого из каналов Channel 3 — Channel 64 в микшере Cubase SX будет появляться по одному монофоническому модулю. Откроем микшер Cubase SX (для этого, например, можно использовать клавишу <F3>) и посмотрим, что там получилось (рис. 11.2).

Рис. 11.2. Микшер Cubase SX

Напомним: для того, чтобы модули каналов ReWire были доступны, на основной панели микшера должна быть включена кнопка [image] (Show/HideReWire Channels). Модули, соответствующие каналам ReWire, отличаются от остальных модулей микшера наличием символа [image] в левой нижней части. Теперь можно запустить Reason. Средствами Reason создается или загружается ранее созданный проект, в котором присутствуют нужные вам устройства и выполнена их коммутация.


11.2. Управление устройствами Reason

В принципе, для управления устройствами Reason вы можете использовать секвенсор Reason. Никаких проблем не возникнет: указатели текущей позиции и локаторы Cubase SX и Reason будут синхронизированы. Запускаете воспроизведение в Cubase SX — запускается воспроизведение и в Reason. И наоборот, все команды, подаваемые с транспортной панели Reason, будут выполняться Cubase SX. Темп, естественно, также будет синхронизирован. Но вы можете управлять устройствами Reason непосредственно из Cubase SX. Для этого нужно в качестве выходного порта любого из MIDI-треков проекта Cubase SX выбрать устройство из проекта Reason (рис. 11.3). Остальные параметры (номер MIDI-канала и прочее) — не важны. После этого MIDI-сообщения с трека Cubase SX будут передаваться выбранному устройству Reason, a Reason будет генерировать звуковой сигнал, который будет возвращаться в микшер Cubase SX.

Рис. 11.3. Выбор устройства из проекта Reason в качестве выходного порта MIDI-трека

Повторимся, напомнив, что Reason позволяет выводить звук по 64 каналам. Для каждого из этих каналов (кроме первых двух, которые всегда в паре) в микшере Cubase SX будет создано по отдельному модулю. Соответственно для каждого из каналов вы можете использовать специфические обработки посредством VST-плагинов. Кстати, в инспекторе MIDI-треков проекта Cubase SX среди доступных входных портов будут присутствовать MIDI-порты устройств из проекта Reason. To есть вы можете использовать элементы управления устройствами Reason в качестве MIDI-контроллеров, записывать все команды от них на MIDI-треки Cubase SX.


11.3. Особенности совместного применения Cubase SX и приложений ReWire

Пять обстоятельств, на которые следует обратить внимание. 1. Приложения ReWire (так для краткости будем называть приложения, подключаемые к Cubase SX по протоколу ReWire) по своей сути являются самостоятельными и могут допускать использование любых аппаратных (или программных) MIDI-контроллеров. Например, если вы хотите управлять Reason независимо от Cubase SX, то для этого потребуется отдельный MIDI-порт, с подключенным к нему отдельным MIDI-контрол-лером/МШ1-клавиатурой. Если у вас всего одна MIDI-клавиатура и один MIDI-порт, то нужно определиться, с каким из приложений вы хотите его использовать и выполнить соответствующие настройки — в одном приложении этот порт освободить, в другом — задействовать. Поскольку наша книга посвящена Cubase SX, то мы подразумеваем, что Cubase SX настроен на работу с MIDI-клавиатурой, и MIDI-команды от нее передаются на текущий MIDI-трек. Если этот MIDI-трек настроен на работу с одним из виртуальных устройств Reason и включен режим MIDI Thru (см. разд. 4.1.1.), то MIDI-команды будут передаваться по ReWire данному устройству. 2. Когда вы подключаете к Cubase SX приложение ReWire, то настройки аудиоинтерфейса последнего не имеют никакого значения. Скорее всего, они даже не будут вам доступны. Вместо них будет отображаться предупреждение о том, что приложение работает в режиме ReWire Slave Mode. Частота дискретизации и разрядность цифрового сигнала будут определяться настройками аудиоинтерфейса ведущего (Master) приложения, которым в данном случае является Cubase SX. Здесь-то и могут скрываться подводные камни. Не исключено, что какие-то приложения ReWire могут, в принципе, не поддерживать некоторые частоты дискретизации из тех, что поддерживаются Cubase SX. Например, нам не удалось заставить Reason 2 нормально работать с Cubase SX, в настройках которого была задана частота дискретизации 96 кГц. Звук из Reason выводился с периодическими перерывами. Возможны также и другие проявления данной проблемы. 3. Вам не удастся посылать команды смены MIDI-инструмента для приложений ReWire: последние не будут на них реагировать. То есть бессмысленно пытаться выбрать какой-нибудь инструмент в поле Prg инспектора MIDI-трека Cubase SX, настроенного на работу с Reason. Выбирайте нужные патчи непосредственно в Reason. 4. В отличие от VSTi вы сможете подключить к своему проекту лишь один экземпляр одного ReWire приложения. Если на вашем компьютере установлено несколько приложений ReWire, то вы можете использовать все их одновременно в своем проекте, но, опять-таки, лишь по одному экземпляру — одно приложение Reason, одно ReBirth и т. д. 5. При использовании приложений ReWire всегда следует помнить о том, что теперь ваш проект состоит из двух компонентов — проект Cubase SX и проект приложения ReWire. Например, в проект Reason могут входить собственно файл проекта (расширение RNS) и файлы ReFill (расширение RFL) с библиотеками сэмплов и патчей, используемых в проекте. Ко всем этим файлам следует так же бережно относиться, как и к файлам проекта Cubase SX. Теперь они являются частью общего проекта и правильнее всего хранить их в одной папке. И еще один важный совет в заключение. После окончания работы с проектом закрывать приложения нужно в такой последовательности: сначала закрываете приложение ReWire и только потом закрываете Cubase SX. Каковы могут быть последствия, если не соблюдать этот порядок? Например, может оказаться, что придется переустанавливать приложение ReWire.


Глава 12. Подробно об обработке аудиоданных

    • Подробно об обработке аудиоданных
    • 12.1. Использование Audio Part Editor для редактирования аудиосообщений в пределах части
    • 12.2. Редактирование аудиосообщений с помощью Sample Editor
    • 12.2.1. Редактирование аудиосообщений
    • 12.2.2. Что такое деструктивное редактирование?
    • 12.2.3. Работа с регионами
    • 12.2.4. Работа с лупами
    • 12.3. Создание шаблонов для Groove Quantize
    • 12.4. Pool, импорт звука и видео
    • 12.5. Применение встроенных обработок
    • 12.5.1. Noise Gate
    • 12.5.2. Pitch Shift
    • 12.5.3. Stereo Flip
    • 12.5.4. Time Stretch
    • 12.6. Выявление тишины
    • 12.7. История обработки и статистика аудиоданных, функция Freeze Edits


Подробно об обработке аудиоданных

Мы уже неоднократно затрагивали вопросы, связанные с записью звуковых данных средствами Cubase SX. В разд. 4.4.3 описана подготовка аудиотреков к записи и пояснены многочисленные способы переключения Cubase SX в режим записи. В разд. 4.4.5 содержатся сведения об операциях, которые можно выполнять с частями и аудиосообщениями средствами окна проекта.
В разд. 1.11.2 приведена методика использования результатов спектрального анализа при сведении стереофонических фонограмм.
В данной главе мы расскажем о том, какие еще средства Cubase SX можно использовать для обработки звуковых данных.
Важным условием успешной записи вокала и живых инструментов является обеспечение мониторинга. В Cubase SX можно использовать три вида мониторинга:

  • внешний мониторинг — выводимый на мониторы сигнал не проходит сквозь Cubase SX;
  • ASIO Direct Monitoring (сквозной мониторинг) — сигнал, выводимый на мониторы, не проходит сквозь Cubase SX, но проходит сквозь микшер звуковой карты, которым управляет Cubase SX. Условие — драйверы звуковой карты должны поддерживать сквозной мониторинг;
  • внутренний мониторинг — сигнал проходит сквозь Cubase SX и подвергается обработке подключенными плагинами. Условие — звуковая карта должна поддерживать режим full duplex. Недостаток — задержка, возникающая при прохождении сигнала сквозь Cubase SX.

Какой вид мониторинга использовать — решать вам. Мы порекомендовали бы использовать ASIO Direct Monitoring (если есть возможность) или внешний мониторинг. О настройках Cubase SX, затрагивающих мониторинг, см. в разд. 2.7.
В Cubase SX запись многодорожечного проекта можно осуществлять следующими способами:

  • последовательная запись — запись осуществляется сначала на один трек, потом на второй, на третий и т. д.;
  • многодорожечная запись — запись осуществляется сразу на несколько треков.

Для осуществления многодорожечной записи требуется звуковая карта с несколькими независимыми входами, поддерживаемыми на уровне драйверов.
В процессе записи звука на треках проекта Cubase SX создаются объекты, называемые аудиосообщениями. Напомним, что аудиосообщения включают в себя ссылку на звуковой файл и набор атрибутов. Аудиосообщения могут выглядеть по-разному в зависимости от настройки Cubase SX.
Командой File > Preferences откройте окно Preferences и выберите секцию Event Display > Audio (рис. 12.1).

Рис. 12.1. Окно Preferences (секция Event > Display)

Опция Interpolate Audio Images включает интерполяцию звуковых отсчетов при отображении волновых форм. Заметить результаты интерполяции можно только при очень большом увеличении изображения волновой формы (рис. 12.2). Естественно, на качестве звука опция Interpolate Audio Images никак не отражается. Сглаживание "ступенек" реального сигнала осуществляется в самом АЦП за счет применения фильтра нижних частот.

Рис. 12.2. Отображение волновой формы без применения интерполяции (а), и с применением интерполяции (б)

Рис. 12.3. Различные стили отображения волновых форм

В списке Wave Image Style выбирается стиль отображения волновых форм:

  • Solid — волновая форма, ограниченная амплитудной огибающей заливается темным цветом (рис. 12.3, а);
  • Framed — отображается только амплитудная огибающая (рис. 12.3, б);
  • Solid and Framed — амплитудная огибающая отображается темным цветом, а область, ограниченная ею, заливается белым цветом (рис. 12.3, в).

Последний стиль можно считать самым красивым, однако он больше остальных отнимает вычислительные ресурсы компьютера. На устаревших компьютерах это может оказаться ощутимым.
Если включена опция Show Event Volume Curves Always, то амплитудные огибающие аудиосообщений будут отображаться даже тогда, когда аудиосообщение не является выделенным.


12.1. Использование Audio Part Editor для редактирования аудиосообщений в пределах части

В ходе редактирования проекта аудиосообщения, размещенные на одном треке, могут объединяться в объекты более высокого логического уровня — части. Аудиочасти образуются в результате склеивания двух и более аудиосообщений с помощью инструмента Glue (кнопка [image] на панели инструментов окна проекта). Еще один способ объединения нескольких аудио-сообщений в одну часть — выделить нужные сообщения и воспользоваться командой главного меню Audio > Events to Part или аналогичной командой контекстного меню секции треков.
Если сделать двойной щелчок на аудиочасти, то откроется окно Audio Part Editor (рис. 12.4).

Рис. 12.4. Окно Audio Part Editor

Данное окно предназначено для редактирования аудиосообщений в пределах части. При этом по отношению к аудиочастям доступны такие же приемы редактирования, как и в окне проекта.
В верхней части окна Audio Part Editor расположена панель инструментов, большинство элементов которой заимствовано из аналогичной панели окна проекта. Мы перечислим лишь те из них, которые там не имеют аналогов.
Кнопка [image] (Show Info) подобна кнопке [image] (Show Event Infoline), расположенной на панели инструментов окна проекта: она открывает/скрывает информационное поле, расположенное ниже панели инструментов. Назначение данного поля — отображение и редактирование параметров выбранного объекта (в данном случае аудиосообщения).
Кнопка [image] (Solo Editor) включает режим Solo для редактируемой части. При воспроизведении всего проекта будет слышна только одна та часть, которая в данный момент открыта в окне Audio Part Editor.
Кнопки [image] (Play) и [image] (Loop), расположенные в окне Audio Part Editor, пo своим функциям отличаются от аналогичных по виду кнопок окна проекта. Кнопка [image] (Play) запускает воспроизведение редактируемой аудиочасти. Причем воспроизведение осуществляется непосредственно на первую выходную шину (по умолчанию она называется BUS 1), минуя какие-либо эффекты и обработки. Если выделено хотя бы одно аудиосообщение, то воспроизведение начинается с его левой границы вне зависимости от того, где располагался до этого указатель текущей позиции. Вообще, в режиме воспроизведения указатель текущей позиции окна Audio Part Editor не связан с указателем текущей позиции проекта.
Кнопка [image] (Loop) включает режим циклического воспроизведения выделенных аудиосообщений.
Остановить воспроизведение можно повторным нажатием кнопки [image] (Play).
В окне Audio Part Editor аудиосообшения могут размещаться на разных уровнях (рис. 12.5).

Рис. 12.5. Окно Audio Part Editor (аудиосообщения расположены на разных уровнях)

На рис. 12.5 два аудиосообшения располагаются на разных уровнях. После запуска воспроизведения будет звучать аудиосообщение, расположенное выше второго. Когда указатель текущей позиции дойдет до начала второго аудиосо-обшения (на рисунке эта позиция отмечена курсором), начнет воспроизводиться второе сообщение. Воспроизведение первого сообщения в этот момент прекратится, т. е. приоритет его уровня ниже приоритета того уровня, на котором расположено второе аудиосообщение. У всех уровней разные приоритеты. Самый низкий приоритет у верхнего уровня, а самый высокий — у нижнего. Количество уровней не ограничено. Вы можете перемещать аудио-сообщения с уровня на уровень, используя Drag & Drop (перетаскивать с помощью мыши). Если удерживать при этом нажатой клавишу <Ctrl>, то перемещение аудиосообщения в горизонтальном направлении станет невозможным. Всегда воспроизводится то аудиосообщение, которое в данный момент имеет наивысший приоритет (расположено ниже остальных).

Рис. 12.6. Окно Audio Part Editor (изменение положения маркера S)

Следует обратить внимание на то, что в окне Audio Part Editor доступны для редактирования в графической форме атрибуты Snap аудиосообщений: при выделении аудиосообщения у него появляется маркер S (Snap) (рис. 12.6), который можно перемешать вдоль аудиосообщения. Это реперная точка, по которой осуществляется привязка (см. разд. 4.4.4) позиции аудиосообщения во времени. По умолчанию она совпадает с началом аудиосообщения, поэтому кажется, что привязка аудиосообщений осуществляется по их левым границам. На рис. 12.7 проиллюстрирована следующая ситуация:

  • включен режим привязки к началам тактов (нажата кнопка [image] (Snap), в поле Grid Selector выбран режим Ваr);
  • маркер S не совпадает с началом аудиосообщения;
  • при перемещении аудиосообщения оно "примагнитилось" маркером S к началу 4 такта;
  • левая граница аудиосообщений не совпадает с началом такта.

Рис. 12.7. Привязка аудиосообщения к началу такта по маркеру S

На самом деле, вы можете управлять маркером S даже из окна проекта: выделите нужное аудиосообщение, установите указатель текущей позиции в то место, где должен располагаться маркер S, и вызовите команду главного меню Audio > Snap Point to Cursor.
О редактировании амплитудных огибающих аудиосообщений мы довольно подробно рассказали в разд. 4.4.5. Поэтому сейчас осталось лишь упомянуть об одной команде главного меню, имеющей отношение к этой проблеме. Команда Audio > Adjust Fades to Range перемещает узлы амплитудной огибающей так, чтобы они располагались на границах выделенной области звукового сообщения. Соответственно применять эту команду можно совместно с инструментом [image] (Range Selection) как из окна проекта, так и из окна Audio Part Editor.
А теперь вопрос "на засыпку": как вывести аудиосообщения из части, чтобы они находились непосредственно на аудиотреках? Ответ: для этого есть специальная команда главного меню Audio > Dissolve Part.


12.2. Редактирование аудиосообщений с помощью Sample Editor

В каком окне бы вы не работали (в окне проекта или в окне Audio Part Editor), но если сделать двойной щелчок на аудиосообщений инструментом Object Selection ( [image] ), то откроется окно Sample Editor. В нем для редактирования будет доступен звуковой файл, на который ссылается аудиосообщение.

Рис. 12.8. Окно Sample Editor

Основной элемент окна — это область, в которой отображена и доступна для редактирования волновая форма звукового файла. Естественно, вы можете изменять масштаб (zoom) отображения по вертикали и по горизонтали подобно тому, как это делается в других окнах Cubase SX.
Для быстрого доступа к нужной части звукового файла удобно пользоваться специальной областью окна, называемой thumbnail display, которая является полным аналогом области Show Overview (см. разд. 4.4.2), доступной в окне проекта. Область thumbnail display расположена непосредственно под панелью инструментов. В ней отображается волновая форма всего звукового файла. Синяя рамка соответствует области звукового файла, доступной для редактирования. Вы можете передвигать границы рамки, при этом будет автоматически осуществляться горизонтальный скроллинг и изменяться горизонтальный масштаб. Вы можете перемещать рамку вдоль волновой формы, что аналогично горизонтальному скроллингу.
Еще один элемент окна Simple Editor, упоминание о котором уместно в начале раздела: кнопка [image] (Show Info) скрывает/показывает информационную строку, расположенную под изображением волновой формы и содержащую три поля:

  • формат и длительность звукового файла;
  • формат представления времени (доступен для изменения);
  • координаты выделенной области; количество изменений, внесенных в звуковой файл; числовое представление масштаба.

Окно Sample Editor имеет несколько функциональных назначений и может иметь различный вид. Щелчком правой кнопки мыши на окне Sample Editor вызовите контекстное меню. Первые шесть команд этого меню дублируют первые шесть кнопок на панели инструментов. Дальше идут команды, дублирующие команды главного меню программы. Последней строкой контекстного меню окна Sample Editor является подменю Elements. С его помощью можно включать/отключать элементы окна Sample Editor. Перечислим их:

  • Audio Events (дублирует кнопку [image] панели инструментов) — показывает/скрывает маркеры начала и окончания аудиосообщения, а также маркер атрибута Snap;
  • Regions (дублирует кнопку [image] (панели инструментов) — показывает/скрывает секцию регионов;
  • Info Line (дублирует кнопку [image] ( панели инструментов) — показывает/скрывает информационную строку;
  • Level Scale — показывает/скрывает шкалу уровня сигнала, расположенную вдоль правой границы окна. У этой шкалы имеется свое собственное контекстное меню, в котором можно выбрать способ градуировки: в % или в дБ;
  • Zero Axis — показывает/скрывает линию нулевого уровня сигнала;
  • Half Level Axis — показывает/скрывает линии, соответствующие уровню сигнала в 50% (-6дБ) от максимально возможного.

Освежим в памяти сущность аудиосообщений. В терминологии Cubase SX аудиосообщение — это объект, включающий в себя ссылку на звуковой файл и набор атрибутов. В частности, имеются такие атрибуты, как начало и окончание аудиосообщения — адреса точек относительно начала звукового файла, которые считаются началом и окончанием аудиосообщения. Воспроизводится и отображается в окне проекта только та область звукового файла, которая заключена между маркерами начала и окончания аудиосообщения: Event Start и Event End, соответственно. В окне Sample Editor (см. рис. 12.7) эта область выделена светлым цветом. Те фрагменты волновой формы, которые располагаются за пределами области Event Start — Event End, выделены темно-серым цветом.
Кнопки [image] на панели инструментов запускают воспроизведение звукового файла и включают режим циклического воспроизведения соответственно. Обратите внимание, что в данном случае речь идет о воспроизведении именно звукового файла, а не аудиосообщения. Воспроизводиться будут даже те фрагменты файла, которые лежат вне границ аудиосообщения (в темно-серой области).
Еще одно понятие, о котором стоит вспомнить, — регионы. О том, что это такое, мы рассказали в разд. 4.4.3 (подразды "Режимы записи, циклическая запись, регионы аудиосообщений"). По своей сути, регионы являются парами маркеров — две координаты, задаваемые от начала звукового файла. Все, что находится между этими маркерами, — регион. В окне проекта и окне Audio Part Editor может отображаться (и, соответственно, воспроизводиться) только один из регионов одного аудиосообщения. Для выбора нужного региона сделайте щелчок на аудиосообщений правой кнопкой мыши и в контекстном меню выберите Set to Region > название нужного региона. Самое интересное заключается в том, что регионы могут как угодно пересекаться друг с другом и вообще выходить за пределы границ аудиосообщений. Дело в том, что регионы не являются принадлежностью (атрибутами) аудиосообщений. Но и в самих звуковых файлах они тоже не хранятся. Для простоты можно принять следующую "картину мира": в проекте Cubase SX хранятся объекты-ссылки на звуковые файлы. Но эти объекты являются строительным материалом и для аудиосообщений, и для регионов. То есть можно считать, что аудиосообщения и регионы — объекты, расположенные на одном логическом уровне.
Редактировать регионы можно с помощью секции регионов окна Sample Editor. Но об этом немного позже (см. разд. 12.2.3).


12.2.1. Редактирование аудиосообщений

Редактирование звуковых файлов можно осуществлять даже на уровне отдельных звуковых отсчетов.
Увеличивайте детализацию изображения до тех пор, пока не станут видны отдельные звуковые отсчеты (рис. 12.9, а). Делается это с помощью инструмента [image] (Zoom) или регуляторов масштаба, расположенных в правом нижнем углу области, в которой отображается волновая форма.
Теперь можно пользоваться инструментом [image] (Draw), чтобы рисовать новую волновую форму (рис. 12.9, б). Таким образом можно вручную удалять из звукового файла дефекты, носящие характер кратковременных импульсов (щелчки, треск).
Можно использовать любые приемы редактирования, характерные для традиционных звуковых редакторов: выделять фрагменты звукового файла, копировать или вырезать их в буфер обмена, удалять, вставлять их из буфера обмена. Такое редактирование называется нелинейным.
Для выделения фрагмента звукового файла предназначен инструмент [image] (Range Selection). На панели инструментов расположены два поля Selection:
в них с точностью до одного звукового отсчета можно отредактировать начальную и конечную позиции выделенной области. В поле Range отображается длительность выделенного фрагмента.

Рис. 12.9. Редактирование волновой формы

Применять инструмент [image] (Range Selection) предпочтительнее в режиме Snap to Zero Crossing, включаемом кнопкой [image] . Границы выделенной области будут автоматически корректироваться программой так, чтобы они приходились на точку пересечения волновой формой линии нулевого уровня. Это защита от возможных щелчков на границах редактируемых фрагментов звукового файла.
Для работы с буфером обмена можно пользоваться соответствующими командами главного меню или контекстного меню, вызываемого щелчком правой кнопкой мыши в окне Sample Editor. Однако на практике удобнее выучить и пользоваться комбинациями клавиш для:

  • копирования — <Ctrl> + <С>;
  • вырезания — <Ctrl> + <Х>;
  • вставки из буфера — <Ctrl> + <V>.

Чтобы осуществить вставку фрагмента звукового файла из буфера обмена, следует с помощью инструмента [image] (Range Selection) выделить область звукового файла. Вставка будет осуществляться в позицию, соответствующую левой границе выделенной области. В принципе, выделенной области как таковой может и не быть: она может иметь вид вертикальной линии, т. е. иметь минимальную ширину. Чтобы получить такую линию, достаточно щелкнуть инструментом [image] (Range Selection) в нужной позиции звукового файла.
Напомним, что в разных аудиосообщениях могут использоваться одни и те же звуковые файлы. Когда вы начнете вносить изменения в звуковой файл данного аудиосообщения, может возникнуть предупреждение, показанное на рис. 12.10. Если нажать кнопку New Version, то на базе существующего будет создан новый звуковой файл, который вы и будете в дальнейшем редактировать. Соответственно звуковое сообщение будет ссылаться уже на этот новый файл.

Рис. 12.10. Запрос решения о создании нового звукового файла

Если нажать кнопку Continue, то новый файл создан не будет, и все ваши действия отразятся на звучании остальных аудиосообщений, ссылающихся на этот же звуковой файл.


12.2.2. Что такое деструктивное редактирование?

Работа с буфером обмена — это далеко не единственная технология редактирования звукового файла. В подменю Audio главного меню и контекстном меню окна Sample Editor имеется множество команд, работающих применительно к выделенному фрагменту. О командах обработки, входящих в подменю Audio > Process, мы поговорим в разд. 12.5. Для обработки звуковых данных можно применять VST- и DirectX-плагины, доступные в подменю Audio > Plug-Ins. Описание VST-плагинов, входящих в поставку Cubase SX, приведено в главе 13.
Стоит заметить, что применять команды подменю Audio можно не только из окна Sample Editor. Например, их можно вызывать, находясь в окне проекта: выделяете нужные аудиосообщения или части и вызываете нужную команду. Следует понимать разницу между недеструктивным и деструктивным редактированием.
Деструктивное редактирование — это редактирование, при котором вносятся изменения непосредственно в сам звуковой файл. Конечно, можно воспользоваться командой Edit > Undo, чтобы отменить деструктивное действие.
Недеструктивное редактирование — это когда в сами звуковые файлы изменения не вносятся, а новое звучание этих файлов достигается за счет изменения атрибутов аудиосообщений (громкость, атака, затухание и др.), применения эффектов, работающих в реальном времени, применения автоматизации. Ведь один и тот же VST-плагин можно применить по-разному. Например, если подключить его в разрыв аудиотрека (в режиме вставки) — это будет недеструктивное редактирование. Если вызвать этот же плагин из подменю Audio > Plug-Ins применительно к выделенным звуковым сообщениям и частям, то это уже деструктивное редактирование. Деструктивное — не значит плохое. Деструктивное редактирование решает свои задачи, а недеструктивное — свои. Например, нет никакого смысла подключать к аудиотреку плагин, предназначенный для удаления щелчков, ради того, чтобы удалить всего одну помеху. В данном случае правильным решением будет применение деструктивного редактирования: открываете окно Sample Editor для аудиосообщения, содержащего дефект; выделяете область, в которой имеется дефект; устраняете дефект с помощью специализированного плагина или методом рисования новой волновой формы. В данном случае вы уверены в том, что через несколько сеансов работы над проектом вам не потребуется вернуться к исходному варианту, в котором дефект присутствовал.
Еще пример, на этот раз противоположный. Нет никакого смысла применять эффект хоруса из меню Audio > Plug-Ins. Здесь деструктивное редактирование ни к чему. А если через несколько сеансов работы над проектом вы захотите изменить параметры хоруса? Придется разыскивать исходный необработанный файл и повторять с ним все действия, которые были выполнены до момента применения эффекта. То есть здесь как раз уместно недеструктивное редактирование — подключение эффекта в разрыв аудиотрека и, при необходимости, использование автоматизации.


12.2.3. Работа с регионами

Одной из основных функций окна Sample Editor является редактирование регионов. Секция регионов располагается в правой части окна. Кнопка [image] (Show Regions) открывает/скрывает эту секцию. Создать регион очень просто: выделяете часть звуковой волны (будущий регион) и нажимаете кнопку Add в секции регионов (рис. 12.11). Альтернативный способ — воспользоваться командой главного меню Audio > Create region(s).

Рис. 12.11. Окно Sample Editor (создание региона)

В списке регионов, включающем в себя три графы: Description (описание), Start (начало региона) и End (окончание региона), появится новый элемент — новый регион. По умолчанию он будет называться Region 1, но вы сразу же можете изменить это название. Также вы можете в любой момент изменить границы региона или в списке регионов, или непосредственно на изображении волновой формы. Границам регионов соответствуют маркеры, название которых состоит из названий регионов и слов Start (если это маркер начала региона) или End (если это маркер окончания региона). В нашем случае маркеры называются Region 1 Start и Region 1 End. Аналогичным образом вы можете создавать и редактировать любое количество регионов. Но отображаться в графической форме будут только маркеры текущего региона — того региона, который в данный момент выбран в списке регионов.
Кроме копки Add в секции регионов расположено еще несколько кнопок. Перечислим их:

  • Remove — удалить текущий регион;
  • Select — выделить область звукового файла, соответствующую текущему региону;
  • Play — воспроизвести текущий регион.

Вообще, Cubase SX удивительная по гибкости программа. С ней можно делать все, что угодно. Возможностей так много, что для некоторых из них тяжело привести практические примеры использования. Как, например, использовать регионы? Основное их назначение — применение режима циклической записи для создания нескольких дублей (регионов) одной и той же партии вокала или живого инструмента (см. разд. 4.4.4.).

Рис. 12.12. Создание аудиосообщения из региона

А вообще, с регионами можно делать очень многое. Например, из них можно создавать аудиосообщения. В списке регионов на самом деле не три графы, а четыре. Самая первая графа не имеет названия. Тем не менее, можно мышью схватить поле этой графы, соответствующее нужному региону (рис. 12.12, а) и перетащить регион в окно проекта или в окно Audio Part Editor (рис. 12.12, б). Когда вы отпустите кнопку мыши, на выбранном вами месте возникнет новое аудиосообщение (рис. 12.12, в). Его начало и окончание будут соответствовать границам региона.
Также вы можете использовать команду главного меню Audio > Events from Regions для того, чтобы создать из всех регионов звукового файла набор аудиосообщений.
Еще одна вспомогательная функция — Audio > Events as Region — работает следующим образом: создает регион, начало и окончание которого соответствуют началу и окончанию аудиосообщения.


12.2.4. Работа с лупами

Прежде чем перейти к рассказу о работе с лупами, на всякий случай напомним о том, что же такое лупы. Классический барабанный луп — это фрагмент барабанной партии, записанный в определенном темпе. Причем длина лупа кратна целому числу тактов. Если воспроизводить такой фрагмент в цикле (отсюда и название лупа — "Loop" — петля (существительное), двигаться по кругу (глагол)), то создастся ощущение непрерывной игры. Лупы могут быть не только барабанными, но и мелодическими (грувами). Зацикленный грув вызывает ощущение непрерывной игры.
В настоящее время на дисках и в Internet можно найти множество коллекций лупов. Композиция будет звучать очень монотонно, если на всем ее протяжении будет звучать всего один луп. Поэтому лупы обычно поставляются наборами, в пределах которых все лупы записаны в одном темпе на одних инструментах, но соответствуют разным частям композиции. Например, вступлению, переходам и т. п.
Несмотря на большое количество коллекций лупов, найти подходящий луп для вашей композиции не просто. Что значит "подходящий"? Это значит то, что он вам должен нравиться, быть уместным в композиции определенного стиля и подходить по темпу. Допустим, вам понравился какой-то луп, который был записан в темпе 126 долей в минуту. Да вот беда, темп вашей композиции равен 120. К тому же вы не уверены, что вам не придется изменить темп до какого-то третьего значения. Можно было бы изменить длительность лупа с помощью звукового редактора (например, с помощью Cool Edit Pro, подробно рассмотренного в книгах [10, 12, 45]) таким образом, чтобы подогнать луп под нужный вам темп. Однако при этом изменится тональность лупа. Алгоритмы изменения длительности сэмпла без изменения его тональности эффективно работают только с аудиосигналами, содержащими
чистый тон. Звуки барабанов и перкуссии являются аудиосигналами шумоподобными, поэтому результаты работы таких алгоритмов не всегда являются удовлетворительными. Решение этой проблемы уже давно найдено и используется во многих программных продуктах, включая Cubase SX: в лупе выделяются отдельные звуки (Slices). После этого программа может автоматически изменять положения этих звуков в лупе, подстраиваясь под заданный темп.
На рис. 12.13, а показана волновая форма барабанного лупа. После применения специальных команд к аудиосообщению в нем будут автоматически выделены фрагменты (Slices), соответствующие отдельным звукам (рис. 12.13, б). Границы этих фрагментов называются Hitpoints. При изменении общего темпа проекта каждый из этих фрагментов будет смещаться по времени так, чтобы длительность одного такта лупа соответствовала длительности одного такта проекта. Однако каждый из фрагментов будет воспроизводиться со своей нормальной скоростью и поэтому их тембр не изменится. На рис. 12.13, 6 показано смещение фрагментов при увеличении темпа, на рис. 12.13, в — при его уменьшении.
На практике все обстоит очень просто. Для импорта звуковых файлов в проект Cubase SX существует команда главного меню File > Import > Audio File. Ею следует воспользоваться для того, чтобы импортировать нужный барабанный луп. В результате откроется диалоговое окно, предназначенное для выбора файла и оснащенное плеером звуковых файлов. То есть вы можете прослушивать файлы еще до того, как они попадут в проект Cubase SX. В этом же окне можно включить опцию Auto Play: при выборе очередного звукового файла будет автоматически запускаться его воспроизведение. Cubase SX поддерживает множество различных форматов звуковых файлов, включая и специальные форматы для лупов (в них уже предусмотрено разбиение волновой формы на Slices). Итак, выбираете нужный файл и нажимаете ОК — он оказывается в вашем проекте в виде аудиосообщения на текущем аудиотреке на том месте, где расположился указатель текущей позиции. Делаете двойной щелчок на этом аудиосообщении и оказываетесь в окне Sample Editor. На панели инструментов имеется кнопка [image] (Hitpoint Mode). Нажимая ее, вы даете Cubase SX понять, что данная волновая форма является лупом и обращаться с ней нужно соответствующим образом. При первом нажатии кнопки [image] (Hitpoint Mode) будет отработан специальный алгоритм. Он выделит в волновой форме все участки, которые, "по его мнению", можно считать отдельными звуками. Запустить этот алгоритм на исполнение можно командой Audio > Hitpoints > Calculate, однако в большинстве случаев в этом нет необходимости.
После этого на изображении волновой формы появятся маркеры — Hitpoints. На рис. 12.14 мы навели на один из таких маркеров курсор мыши. Кроме того, изменится и вид панели инструментов, на ней появятся новые элементы.

Рис. 12.13. Иллюстрация алгоритма изменения темпа лупа

Рис. 12.14. Окно Sample Editor (режим Hitpoint Mode)

Положением регулятора Hitpoint Sensitivity определяется чувствительность алгоритма, детектирующего резкие изменения в характере волновой формы и расставляющего Hitpoints. Во всяком случае, положение этого регулятора должно быть выбрано таким, чтобы количество маркеров Hitpoints соответствовало видимому количеству ударных звуков и не превышало его.
Приемлемым можно считать среднее положение регулятора. В списке Use можно выбрать то, что следует считать основой для расстановки Hitpoints:

  • Sensitivity — положение регулятора Hitpoint Sensitivity;
  • 1/4, 1/8, 1/16, 1/32 — вне зависимости от положения регулятора будут расставляться те Hitpoints, которые окажутся ближе всего к началам заданных долей такта.

Использовать режимы 1/4, 1/8, 1/16, 1/32 можно в том случае, если вы уверены, что остальные настройки верны. А назначения настроек таковы:

  • Bars и Beats — длина лупа (количество целых тактов и дополнительных долей в лупе);
  • Signature — музыкальный размер лупа;
  • Original Tempo — тот темп лупа, с которым он был записан (темп рассчитывается на основе предыдущих параметров).

В большинстве случаев все автоматически рассчитывается так, как надо, и никакие настройки менять не требуется.
Вы можете редактировать непосредственно сами маркеры Hitpoints. А с помощью инструмента [image] (Draw) вы можете создавать свои собственные маркеры. На панели инструментов также имеется переключаемый инструмент Hitpoint Edit, который выполняет одну из следующих функций:
(Disable) — отключение маркеров, сгенерированных программой, и удаление маркеров, созданных пользователем; [image] (Lock) — блокировка маркеров: заблокированные маркеры не будут исчезать при уменьшении значения Hitpoint Sensitivity;
(Move) — режим перемещения маркеров. Интересно ведет себя инструмент [image] (Play): когда вы щелкаете на волновой форме, происходит ее воспроизведение от начала или ближайшего слева маркера Hitpoint до конца или ближайшего справа маркера Hitpoint. Короче говоря, с его помощью вы можете слушать, как звучат отдельные фрагменты лупа (Slices).
Подведем промежуточный итог. В окне Sample Editor можно разбить луп на несколько фрагментов, используя маркеры Hitpoint. При этом вы можете откорректировать их количество и расположение. Однако в большинстве случаев это не требуется.
Переходим к завершающему этапу: вызываем команду главного меню Audio > Hitpoints > Create Audio Slices. Дальше произойдет интересная вещь: луп будет разбит на несколько отдельных аудиосообщений, границы которых будут соответствовать маркерам Hitpoints. Все аудиосообщения будут объединены в одну часть. Находясь в окне проекта, вы можете сделать двойной щелчок на этой части, чтобы рассмотреть результат в окне Audio Part Editor (рис. 12.15). Теперь исходный темп лупа не будет иметь никакого значения: луп будет воспроизводиться в соответствии с темпом проекта.

Рис. 12.15. Окно Audio Part Editor (луп разбит на несколько аудиосообщений)

Средствами окна проекта и командами Edit > Repeat или Edit > Fill Loop (см. разд. 4.4.5, подраздел "Копирование") можно размножить часть синхронизированного с темпом проекта лупа в нужных количествах. При этом все копии части будут ссылаться на один и тот же звуковой файл, следовательно, дополнительного места на диске будет занято совсем немного.
На рис. 12.16 показаны два аудиотрека. На верхнем аудиотреке расположено исходное аудиосообщение с лупом. Как видно, его окончание не соответствует началу нового такта — исходный темп лупа не соответствует темпу проекта.

Рис. 12.16. Исходный луп и результат его преобразования

Рис. 12.17. Исходная часть с лупом (вверху) и результат применения команды Close Gaps (внизу)

На нижнем аудиотреке расположена последовательность частей, полученных из исходного аудиосообщения по описанной ранее методике. Границы этих сообщений соответствуют началам тактов, они синхронизированы с темпом проекта.
Если темп проекта незначительно превышает исходный темп лупа, то после его синхронизации с темпом проекта на слух не будет заметно никаких артефактов. Если темп проекта меньше исходного темпа лупа, то это уже может быть ощутимо: между отдельными частями лупа будут слышны и видны паузы (см. рис. 12.15). Но и против этих пауз существует средство: к части, содержащей луп, нужно применить команду Audio > Close Gaps (разд. 4.4.5, подраздел "Склеивание, заполнение пауз"). Команда отработает с заметной задержкой: с помощью сложного алгоритма будут генерироваться недостающие фрагменты звуковой волны. В результате его работы паузы между фрагментами лупа будут заполнены так, что от них не останется и следа (рис. 12.17). Причем луп после этого будет звучать естественно.
В завершение раздела хотим сделать несколько замечаний. Во-первых, так же, как и маркеры регионов, маркеры Hitpoints не являются атрибутом аудиосообщений и не хранятся в звуковом файле. Во-вторых, механизм разметки звукового файла на отдельные фрагменты с помощью маркеров Hit-points можно использовать не только при работе с лупами. Например, Hitpoints удобно пользоваться в том случае, если нужно нарезать из одного звукового файла несколько аудиосообщений. В окне Sample Editor вы расставляете Hitpoints так, как вам нужно. Контролируете их расположение прослушиванием отдельных частей. Затем вызываете команду главного меню Audio > Hitpoints > Divide Audio Events, и исходное звуковое сообщение разрезается на несколько новых звуковых сообщений в соответствии с расположением Hitpoints.
Вы можете превратить части звукового сообщения, разделенные маркерами Hitpoints, в регионы этого же сообщения с помощью команды главного меню Audio > Create Region(s).


12.3. Создание шаблонов для Groove Quantize

В разд. 6.6, мы говорили о том, что одной из целей квантизации может являться преобразование ритмической структуры обрабатываемой партии в соответствии с образцовой партией. Такой алгоритм квантизации получил название Groove Quantize. Образцовая партия служит шаблоном, под который подгоняется ритм других партий.
В целях генерации шаблонов для Groove Quantize можно использовать Hitpoints.
За основу шаблонов можно брать звуковые файлы с записями реальной игры исполнителя. Так мы и сделаем:

  • импортируем в проект аудиофайл (командой File > Import > Audio File);
  • откроем окно Sample Editor;
  • установим локаторы на границы фрагмента, соответствующего одному такту (рис. 12.18);
  • командой Audio > Hitpoints > Create Groove Quantize создадим шаблон для Groove Quantize.

Рис. 12.18. В окне Sample Editor расставлены Hitpoints, необходимые для создания шаблона

Теперь командой Project > Add Track > MIDI создадим MIDI-трек, а командой MIDI > Quantize Setup откроем окно Quantize Setup.
Шаблону автоматически присваивается имя, состоящее из имени аудиотрека, к которому была применена данная команда, и слова "Sliced" (в нашем случае Audio 01_12 Sliced). Найдем и выберем это имя в списке пресетов окна Quantize Setup. После этого ритмическая структура шаблона будет отображена в окне Quantize Setup (рис. 12.19).
Если применить команду Audio > Hitpoints > Create Groove Quantize к одному и тому же аудиосообщению несколько раз, то в списке появятся несколько пресетов с одинаковыми именами, но, возможно, с различной структурой.
Откроем для созданного MIDI-трека окно Key Editor. Обратим внимание на параметры квантизации. В поле Quantize автоматически появилась надпись, совпадающая с именем пресета (Audio 01_12 Sliced). В поле Length Quant. можно выбрать строку Linked to Quantize, если нужно, чтобы длительность нот, которые мы вскоре запишем, совпадала с текущим шагом квантизации.
Нажмем кнопку [image] (Snap). Тактовая сетка в окне Key Editor будет преобразована согласно ритмическому шаблону. Теперь если инструментом [image] (Draw) записывать в окне отпечатки клавиш, то их начала автоматически окажутся привязанными к узлам сетки квантизации, соответствующей созданному шаблону. Результат представлен на рис. 12.20.

Рис. 12.19. Структура шаблона Groove Quantize в окне Quantize Setup

Рис. 12.20. Ритм партии баса, полученный на основе Groove Quantize

Для большей наглядности после проведения Groove Quantize мы "укоротили" отпечатки клавиш, временно изменив содержимое поля Length Quant. и выбрав команду MIDI > Advanced Quantize > Quantize Lengths.


12.4. Pool, импорт звука и видео

Вообще понятие пул (pool) очень часто используется в технике, когда какие-то объекты, сходные по своей природе, объединены в одном месте. Например, существует модемный пул (множество модемов собранных в одном месте), который обеспечивает многоканальный доступ к каким-либо информационным ресурсам, или пул адресов — диапазон, из которого сервер может выдавать адреса для своих клиентов. Пул в Cubase SX — это то место, где собрана вся информация о звуковых файлах и видеофайлах, связанных с проектом. Важно понимать, что значит "связанных с проектом". Вы можете импортировать звуковой или видеофайл в пул, но не размещать соответствующее сообщение ни на одном из треков проекта. То есть с одной стороны, файл может принадлежать проекту, а с другой стороны, он совсем не обязательно должен в этом проекте использоваться. Также нужно понимать, что пул является принадлежностью проекта. То есть у каждого проекта свой пул.
В пуле хранятся не сами файлы, а лишь ссылки на них. В терминологии Cubase SX эти ссылки называются клипами. У одного клипа может быть несколько версий. Причем каждая из версий ссылается на один и тот же файл. Разные версии клипов могут содержать различные регионы и разные наборы маркеров Hitpoints.
Окно пула (рис. 12.21) открывается с помощью кнопки [image] (Open Pool), расположенной на панели инструментов окна проекта, или командой главного меню Project > Pool, или комбинацией клавиш <АН> + <1>.

Рис. 12.21. Окно Pool

Информация в окне Pool отображается в виде таблицы. Левая ее графа содержит дерево Media (носители). По умолчанию в этом дереве присутствуют три папки:

  • Audio — здесь собрана информация о звуковых клипах;
  • Video — здесь собрана информация о видеоклипах;
  • Trash — мусорная корзина, в которую бросаются ненужные клипы.

В папках Audio и Video в случае необходимости можно создавать вложенные папки. Для этого следует выбрать нужную папку, щелкнуть правой кнопкой мыши и в контекстном меню выбрать команду Create Folder.
Итак, в дереве Media собраны названия файлов, а в остальной части таблицы приведена информация об этих файлах:

  • Used — сколько ссылок на данный клип имеется в проекте (количество аудио или видеосообщений, ссылающихся на данный клип). Если в данном поле пусто — значит клип не используется;
  • Status — состояние папки или клипа, отображаемое с помощью иконок;
  • Info — информация о файле: формат представления данных, длительность и т. п.;
  • Туре — тип файла;
  • Date — дата создания файла;
  • Origin Time — оригинальная позиция, начиная с которой данный клип (или его регион) был записан или импортирован в проект;
  • Image — миниатюрное изображение волновой формы звукового клипа или региона;
  • Path — путь к файлу.

По любому из перечисленных полей можно выполнить сортировку. Направление сортировки задается щелчком на названии нужного поля (после каждого повторного щелчка направление изменяется на противоположное).
Следует обращать внимание на статус клипа в том случае, если ему соответствует иконка с символом "х" (это значит, что соответствующий клипу файл находится за пределами папки проекта) или символ "?". Последний статус — повод для тревоги: на файл имеется ссылка, но по указанному пути он не обнаружен (он был перемещен или удален). В верхней части окна Pool имеется панель инструментов. С кнопками [image] вы должны быть уже знакомы (показать/скрыть информационную строку со статистикой по имеющимся клипам, воспроизвести выбранный клип, режим циклического воспроизведения).
Щелчком на поле View вызывается меню. Первые его восемь команд показывают/скрывают соответствующие графы таблицы, кроме дерева Media. Команда Show All показывает все графы таблицы, a Hide All — скрывает все графы, кроме Media. Команда Optimize Width оптимизирует ширину граф.
Кнопки + All и - All разворачивают и сворачивают все папки на дереве Media.
Кнопка Import вызывает диалоговое окно Import Medium, в котором можно выбрать и прослушать звуковой и видеофайл для последующего импорта в проект.
Кнопка Search делает доступной секцию поиска файлов (рис. 12.22).

Рис. 12.22. Окно Pool (секция поиска файлов)

В поле Name следует указать любую подстрок}', которая может присутствовать в имени искомого файла. Например, если указать "cde", то будут найдены все файлы, содержащие эту последовательность символов (например, "ab_CDeFg.wav"). В списке Folder выбирается один или несколько дисков, на которых следует осуществлять поиск. В этом же списке присутствует элемент Select Search Path. Если его выбрать, откроется окно Select Directory — выбора папки, в которой следует осуществлять поиск. Кнопка Search запускает процесс поиска и на его время замещается кнопкой Stop (остановить поиск).
Файлы, удовлетворяющие условиям поиска, по мере их нахождения будут помещаться в список, расположенный в правой части секции (Name, Path — имя файла и путь к нему).
В секции поиска файлов имеется плеер, позволяющий воспроизвести найденные файлы. Если включена опция Auto Play, то воспроизведение выбранного в списке файла будет запускаться автоматически.
Выбранные в списке файлы можно импортировать в пул кнопкой Import.
Вернемся к панели инструментов окна Pool (см. рис. 12.21). Последние элементы на ней — информационная строка, в которой указан путь к папке проекта, и папка, в которой будут размещаться записываемые файлы.
Из окна Pool клипы или регионы можно перетаскивать в окно проекта или Audio Part Editor. Можно подвергать их обработке, производить изменение формата.
Для работы с окном Pool в главном меню имеется подменю Pool с набором специальных команд. Эти же команды доступны в контекстном меню окна Pool. Правда, как и любое контекстное меню Cubase SX, оно может содержать различный перечень команд в зависимости от того, какой из объектов в данный момент выбран. Эти команды могут применяться к папкам дерева Media, к отдельным выделенным файлам или к группам выделенных файлов. Перечислим все возможные команды:

  • Import Medium — импортировать звуковой или видео файл;
  • Import Audio CD — импортировать звук с треков CD Digital Audio;
  • Import Pool — загрузить состояние пула из файла;
  • Export Pool — сохранить состояние пула в файл;
  • Find Missing Files — поиск тех файлов, на которые ссылаются клипы со, статусом "?";
  • Remove Missing Files — удалить из пула клипы со статусом "?";
  • Reconstruct — восстановление потерянного файла по истории его редактирования (возможно только в том случае, если файл имеет статус "Reconstructible");
  • Convert Files — преобразование формата файла;
  • Conform Files — изменить формат файлов в соответствии с форматом, принятым в данном проекте;
  • Create Folder — создать вложенную папку;
  • Empty Trash — очистить мусорную корзину;
  • Remove Unused Media — удалить из пула неиспользуемые в проекте клипы;
  • Prepare Archive — подготовка проекта к архивированию (все внешние файлы копируются в папку проекта, а также выполняются другие мероприятия);
  • Set Pool Record Folder — задать папку, в которой будут храниться записываемые файлы;
  • Minimize File — минимизировать объем памяти, занимаемый файлами, за счет удаления не используемых в проекте фрагментов;
  • Update Origin — обновить параметры Origin Time в соответствии с текущим расположением сообщений в проекте;
  • New Version — создать новую версию клипа;
  • Insert into Project > At Cursor — используя выделенный клип, создать в проекте аудио- или видеосообщения, начиная с указателя текущей позиции;
  • Insert into Project > At Origin — создать в проекте аудиосообщение или видеосообщение в позиции Origin Time;
  • Select In Project — выделить в проекте сообщения, в которых используются файлы, выделенные в пуле;
  • Find In Pool — поиск файлов в пуле по заданному критерию.

Удалить выбранный клип можно командой главного меню Edit > Delete (или клавишей <Backspace>). Вам будет выдан запрос: удалить клип из пула или перенести его в мусорную корзину. В любом из этих случаев все связанные с клипом сообщения тоже будут удалены. При удалении клипа из пула не происходит физического удаления файла, на который этот клип ссылается. А вот если вы захотите отчистить мусорную корзину, будет выдан запрос: стереть файлы физически (Erase) или просто удалить их из пула.


12.5. Применение встроенных обработок

Команды обработки звуковых данных средствами, встроенными в программу, содержатся в подменю Audio > Process.
Первые три команды открывают диалоговые окна, с помощью которых реализуется деструктивное редактирование амплитуды оцифрованных звуковых колебаний:

  • Envelope — модулировать амплитуду выбранных аудиоданных огибающей (ее форма задается в открывшемся диалоговом окне);
  • Fade In — редактировать параметры функции Fade In (открывается диалоговое окно Fade In);
  • Fade Out — редактировать параметры функции Fade Out (открывается диалоговое окно Fade Out).

Внешне окна Fade In и Fade Out очень похожи на окна, описанные в разд. 4.4.5 (см. рис. 4.47, а и рис. 4.47, б). Отличие состоит в том, что здесь функции окон применяются к выделенным аудиоданным и изменяют их, а окна, о которых речь идет в разд. 4.4.5, используются для построения огибающих. Огибающие реально доступны в графическом виде, их всегда можно перерисовать заново, реализуя недеструктивное редактирование.
Перечислим остальные команды обработки звуковых данных, содержащиеся в подменю Audio > Process:

  • Gain — изменить уровень сигнала для выбранных аудиоданных. Командой открывается окно, в котором следует установить необходимый уровень усиления (или ослабления) сигнала, а также длительности кросс-фейда в начале и в конце выделенного аудиосообщения;
  • Merge Clipboard — смешать звуковые данные из буфера обмена со звуковыми данными, содержащимися в выделенных объектах. Функция доступна только в том случае, если аудиоданные были вырезаны или скопированы из Sample Editor;
  • Noise Gate — выделить фрагменты, в которых звуковые данные не превышают заданного уровня, и заменить их на абсолютную тишину (обработать звуковые данные гейтом);
  • Normalize — произвести нормализацию отсчетов звуковых данных к заданному уровню. Командой открывается окно, в котором следует установить необходимый уровень нормализации сигнала, а также задать длительности кроссфейда в начале и в конце обрабатываемого аудиосообщения;
  • Phase Reverse — инвертировать фазу в выбранном стереоканале. Командой открывается окно, в котором следует выбрать канал (правый, левый или оба канала), а также установить длительности кроссфейда в начале и в конце обрабатываемого аудиосообшения;
  • Pitch Shift — сдвинуть высоту тона выделенного фрагмента аудиоданных;
  • Remove DC Offset — удалить постоянную составляющую из выделенных аудиоданных (одна из операций, необходимых для предотвращения возникновения щелчков в местах склейки фрагментов аудиоданных);
  • Reverse — реверсировать выделенные аудиосообщения (переписать аудиоданные в обратном направлении, поменять местами начало и конец аудиосообщения);
  • Silence — заменить выделенные аудиоданные на абсолютную тишину;
  • Stereo Flip — панорамировать выбранным способом левый и/или правый стереоканалы;
  • Time Stretch — изменить длительность и темп выбранного фрагмента аудиоданных, не затрагивая высоту его звучания.

Назначение некоторых функций не нуждается в подробных разъяснениях, поэтому остановимся только на командах Noise Gate, Pitch Shift, Stereo Flip и Time Stretch.


12.5.1. Noise Gate

Командой Audio > Process > Noise Gate открывается окно Noise Gate, представленное на рис. 12.23.

Рис. 12.23. Окно Noise Gate

Суть обработки заключается в том, что программа просматривает выделенные аудиоданные, находит те из них, уровень которых не превышает заданного порога, и заменяет их тишиной. Фактически здесь реализован виртуальный гейт (см. разд. 1.10.2). В окне можно выбрать следующие параметры гейта:

  • Threshold — порог срабатывания гейта;
  • Attack Time — время, которое требуется для гейта, чтобы открыться полностью после того, как уровень звукового сигнала превысит пороговый уровень;
  • Min. Opening Time — минимальное время, в течение которого уровень звукового сигнала должен оставаться выше порога для того, чтобы гейт оставался открытым;
  • Release Time — время, которое требуется для гейта, чтобы закрыться полностью после того, как уровень звукового сигнала станет ниже порогового уровня.

Если установлен флажок Linked Channels, то гейт открывается только в том случае, когда порог будет одновременно превышен уровнями сигналов и левого, и правого каналов.
Кнопкой More открывается дополнительная секция окна (рис. 12.24).

Рис. 12.24. Расширенный вариант окна Noise Gate

Регулятором Dry/Wet mix устанавливается соотношение между уровнями исходного и обработанного сигналов в итоговом миксе.
Флажком Pre-CrossFade включается кроссфейд в начале обрабатываемого фрагмента аудиоданных, а соответствующим слайдером регулируется время кроссфейда. Флажок и слайдер Post-CrossFade обеспечивают кроссфейд в конце обрабатываемого фрагмента аудиоданных.
Нажав кнопку Preview, можно предварительно прослушать звучание, которое приобретут аудиоданные после обработки.
Для того чтобы программа приступила к выполнению обработки, следует нажать кнопку Process.
Аналогичные элементы имеются и в других окнах. В следующих разделах мы их описывать больше не будем.


12.5.2. Pitch Shift

Командой Audio > Process > Pitch Shift открывается окно Pitch Shift (рис. 12.25, 12.26).
Pitch Shift позволяет изменять высоту тона выделенного фрагмента аудиоданных, не затрагивая его длину. Основное применение функции состоит в транспонировании в другие тональности записанных вокальных партий и партий в исполнении реальных инструментов. Кроме того, с помощью Pitch Shift можно корректировать по высоте те фрагменты партии, которые певцом или музыкантом исполнены фальшиво. Поскольку одновременно можно задавать не один, а несколько интервалов транспонирования, Pitch Shift способен выполнять также роль гармонайзера: формировать заданные аккорды, основанные на тоне обрабатываемого фрагмента аудиоданных.

Рис.12.25. Окно Pitch Shift, вкладка Transpose

В окне Pitch Shift имеются две вкладки: вкладка Transpose, предназначенная для сдвига высоты тона на определенную неизменную величину, и вкладка Envelope, позволяющая графическим способом задавать изменение тона во времени.
Рассмотрим сначала вкладку Transpose (рис. 12.25). Самым заметным элементом вкладки является изображение клавиатуры (Keyboard Display). Клавиатура позволяет в графической форме задать интервал (интервалы) транспонирования в полутонах.
Красным цветом выделена клавиша, соответствующая основному тону.
К фактической тональности или высоте тона исходных аудиоданных красная клавиша имеет косвенное отношение. Например, если вы обрабатываете звук до, исполненный вокалистом, а в качестве основной ноты выбрали ре, это вовсе не значит, что после обработки до превратится в ре. Выделенная красным цветом клавиша просто служит началом системы координат, точкой, относительно которой отсчитывается интервал транспонирования. При желании вы можете переместить красную метку в другую область клавиатуры, нажав <Alt> и щелкнув на необходимой клавише. Для смены основной ноты служат также элементы группы Pitch Shift Base. В раскрывающихся списках Root note/Pitch выбираются необходимая октава и базовая нота в пределах октавы.
Чтобы определить интервал транспонирования, щелкните на одной из клавиш. Вы услышите соответствующий ей звук, а сама клавиша окрасится в синий цвет. Интервал транспонирования можно определить, подсчитывая полутона (клавиши) непосредственно на клавиатуре. Кроме того, он отображается и задается также в поле Transpose_Semitones группы Pitch Settings. Если установлен флажок Multi Shift, то можно пометить синим цветом несколько клавиш, с тем чтобы создать аккорд. Повторным щелчком на клавише синяя подсветка с нее снимается.
Поле ввода Fine Tune и слайдер Cents обеспечивают корректировку высоты тона с точностью до цента, что как раз и позволяет устранять ошибки исполнения.
С помощью поля ввода Volume и слайдера Amplitude независимо для каждой клавиши можно задать свой уровень громкости (в процентах от уровня громкости исходного звука). Это позволяет создавать многоголосные партии, в которые, кроме основного вокала, входит также и бэк-вокал (он, как правило, должен звучать тише).
Нажав кнопку Listen Chord, можно предварительно прослушать сформированный аккорд.
В группе Pitch Shift Mode сосредоточены элементы, предназначенные для выбора разновидностей алгоритма преобразования.
Поле ввода Accuracy и слайдер Sound — Rhythm доступны, если в списке Algorithm выбран вариант Timebandit. С их помощью выбирается приоритетная цель преобразования. При малых значениях параметра предпочтение будет отдано тональным свойствам обрабатываемого материала, при больших — ритмическим.
В списке Algorithm можно выбрать МРЕХ Algorithm — алгоритм преобразования, отличающийся более высоким качеством, но работающий относительно медленно и не предназначенный для использования в реальном времени (поэтому кнопкой Preview воспользоваться не удастся).
Если обработке подвергается вокальный материал, то разработчики рекомендуют установить флажок Formant Mode для того, чтобы при транспонировании сохранить формантные признаки, присущие голосу исполнителя.
Если установлен флажок Time Correction, то при транспонировании тона сохранится неизменной продолжительность обрабатываемого фрагмента. В противном случае при повышении тона фрагмент станет короче, а при понижении — длиннее.
На вкладке Envelope (рис. 12.26) осуществляется графическое изменение тона во времени.

Рис. 12.26. Окно Pitch Shift, вкладка Envelope

Щелчком на графике создается узел. Можно образовать неограниченное количество узлов, каждый из которых можно перемещать, задавая тем самым форму графика. Горизонтальный размер графического дисплея соответствует длине выделенного участка аудиотрека.
Кнопками Curve Kind выбирается способ интерполяции участков графика, заключенных между узловыми точками: отрезками прямой или гладкими кривыми (сплайнами).
Нажатием кнопки Reset график "сбрасывается" в нейтральное состояние, приобретая вид прямой горизонтальной линии.
В поле Range: в количестве полутонов указывается максимальный диапазон изменения тона.
Остальные элементы знакомы вам по описанию вкладки Transpose.
К сожалению, отсутствие разметки временной шкалы затрудняет применение вкладки Envelope, потому что невозможно точно увязать график с конкретными местами на аудиотреке.


12.5.3. Stereo Flip

Командой Audio > Process > Stereo Flip открывается окно Stereo Flip, представленное на рис. 12.27.

Рис. 12.27. Окно Stereo Flip

Окно позволяет различным образом комбинировать сигналы левого и правого стереоканалов, записанные на аудиотреке. Вариант обработки выбирается в раскрывающемся списке Mode:

  • Flip Left-Right — аудиоданньге из левого канала поместить в правый канал и наоборот;
  • Left to Stereo — скопировать аудиоданные из левого канала в правый канал;
  • Right to Stereo — скопировать аудиоданные из правого канала в левый канал;
  • Merge — объединить оба стереоканала в один монофонический;
  • Subtract — вычесть аудиоданные левого канала из правого канала и наоборот. В итоге будет удален или существенно подавлен звук источника, который в исходном сигнале был панорамирован в центр. Как правило, в центре расположен основной вокал. Поэтому алгоритм Subtract позволяет преобразовать полноценную фонограмму в аккомпанемент для караоке.


12.5.4. Time Stretch

Командой Audio > Process > Time Stretch открывается окно Time Stretch, представленное на рис. 12.28.
С помощью этой функции можно изменить длину и "темп" выбранного фрагмента аудиоданных, не затрагивая высоту тона.
Параметры исходного материала отображаются в группе Input:

  • Length in Samples — количество звуковых отсчетов в выделенном фрагменте;
  • Length in Seconds — продолжительность выделенного фрагмента в секундах;
  • Tempo in BPM — темп, установленный для проекта;
  • Bars — продолжительность выделенного фрагмента в формате такт .доля.часть доли.тик.;
  • Time Signature — музыкальный размер, установленный для проекта.

Рис. 12.28. Окно Time Stretch

В группе Output отображаются параметры, которыми будет характеризоваться выделенный фрагмент аудиоданных после преобразования:

  • Samples — количество звуковых отсчетов;
  • Seconds — продолжительность полученного аудиосообщения в секундах;
  • ВРМ — новое значение темпа;
  • Range — новые границы аудиосообшения.

Если нажать кнопку Set to Locators Range, то параметры аудиосообщения, отображаемые в группе Output, будут привязаны к области, ограниченной левым и правым локаторами.
В обычном режиме растяжение или сжатие исходного аудиосообщения возможно в пределах +/-125 % (поле Time Stretch и слайдер Compress — Expand). Однако если установить флажок Effect, то коэффициент преобразования длительности может быть значительно увеличен.
Поле ввода Accuracy, слайдер Sound — Rhythm и список Algorithm знакомы вам по материалам разд. 12.5.2.
Конечно, ход преобразований нужно обязательно контролировать на слух, потому что не для всякого исходного материала результат будет приемлемым.


12.6. Выявление тишины

Команда Audio > Detect Silence предназначена для выявления участков звуковых данных, на которых амплитуда звуковых колебаний ниже заданного уровня. Команда используется для выделения из продолжительных сообщений (в которых, наряду с полезной информацией, имеются участки с тишиной) более коротких фрагментов, целиком заполненных звуковыми данными.
Функция Detect Silence вообще не затрагивает аудиоданных. Не происходит никакой их обработки, никакой замены звуковых данных абсолютной тишиной, нет и никакой экономии дисковой памяти. Функция выделяет участки с тишиной, затем (если выбрана опция Strip Silence) разбивает исходное сообщение на несколько сообщений, которые ссылаются на один и тот же файл (совершенно не измененный), но границы этих сообщений подогнаны так, чтобы в них не попадала тишина. Если выбрана опция Add as Regions, то аудиоклип (см. разд. 12.4) разбивается на регионы, не содержащие тишины. Регионы — это просто метки, поэтому в данном случае также не происходит никакой экономии дисковой памяти. В дальнейшем из регионов можно создать сообщения.
Команда Audio > Detect Silence вызывает одноименное диалоговое окно (рис. 12.29).
Можно выделить несколько объектов на разных треках — окно Detect Silence будет по очереди открываться для каждого из объектов.
Функцией Detect Silence реализуется следующий алгоритм. Представьте себе ключ (выключатель), который может находиться в одном из двух состояний: замкнутом (сигнал проходит) и разомкнутом (сигнал не проходит). Программа анализирует звук: как только уровень сигнала превысит порог открывания звукового канала (Open Threshold), ключ замкнется, звуковой сигнал, пройдет со входа на выход ключа. Если уровень сигнала опустится ниже второго порога — порога закрывания звукового канала (Close Threshold), ключ снова разомкнется и наступит тишина. Двухпороговый алгоритм разделения аудиоданных на участки, содержащие полезный сигнал и не содержащие его, позволяет, с одной стороны, надежно отсечь ненужные шумы, а с другой — избежать искажения звучания музыкальных инструментов или голоса певца в фазе затухания звука. Замыкание/размыкание ключа может выполняться и в соответствии с более сложным алгоритмом анализа звуковых данных, с использованием задержек. Например, когда амплитуда звукового сигнала станет меньше заданного порога Close Threshold, ключ еще некоторое время (Min. Opening Time) будет замкнут. Аналогичным образом в поле Min. Closing Time можно задать время удержания ключа в разомкнутом состоянии после превышения уровнем сигнала второго порога (Open Threshold). Это позволяет избежать частых переключений при кратковременных резких изменениях уровня сигнала, которые на слух иногда воспринимаются значительно неприятнее, чем шум в паузах.

Рис. 12.29. Диалоговое окно Detect Silence

Еще один тип задержки — Pre-Roll. Однако назвать Pre-Roll задержкой можно только с большой натяжкой. Это, скорее, упреждение, чем задержка. Вектор этой задержки направлен в сторону, противоположную вектору времени. Может ли такое быть? Конечно! Ведь не зря многие считают возможности PC безграничными. Итак, в поле Pre-Roll программе указывается некоторый интервал времени. Компьютер анализирует звуковые данные, определяет момент возрастания уровня сигнала и заранее замыкает воображаемый ключ так, чтобы фаза атаки звука была слышна целиком. Это самое
"заранее" как раз и определяется величиной Pre-Roll. Наиболее часто ненулевое значение Pre-Roll используется при работе с вокальным материалом и речью (чтобы исключить пропадание начальных звуков слов).
Задержка, указанная в поле Post-Roll, позволяет сохранить естественное звучание окончаний слов, фазы затухания звука музыкальных инструментов, эха, реверберации. Звук будет проходить на выход ключа еще некоторое время после того, как пороговое устройство выявит резкое уменьшение его уровня.
По существу, в данном случае мы имеем дело с программной реализацией идеального гейта. Правда, на самом деле, вместо замыкания и размыкания ключа в некоторые моменты эти места просто обозначаются метками. Порядок применения Detect Silence:

  • выделите аудиосообщение и выберите команду Audio > Detect Silence;
  • выполните ориентировочные настройки и нажмите кнопку Compute;
  • проанализируйте график (вы увидите, какие именно фрагменты программа будет считать тишиной при выбранных параметрах), уточните настройки (при необходимости еще раз нажмите кнопку Compute) и наконец-то нажмите кнопку Process.

Результат зависит от того, какой флажок выбран:

  • Add as Regions — аудиоклип, на который ссылается аудиосообщение, будет разбит на регионы, не содержащие тишины;
  • Strip Silence — будет создано несколько аудиосообщений, не содержащих тишины.


12.7. История обработки и статистика аудиоданных, функция Freeze Edits

Если один и тот же звуковой файл используется в нескольких сообщениях, то перед применением разрушающего редактирования к одному из них Cubase SX предложит создать копию этого файла и дальше работать с ней (чтобы не воздействовать на остальные аудиосообщения).
В процессе деструктивного редактирования результаты обработки звуковых сообщений сохраняются во временных файлах. Кроме того, сохраняется информация о том, какая команда и с какими параметрами была применена. Благодаря этому, можно использовать команду Edit > Undo.
Посмотреть историю разрушающего редактирования звуковых файлов можно в окне Offline Process History, которое открывается командой Audio > Offline Process History. Там же можно произвести изменения истории редактирования — удалить какие-то обработки или изменить их параметры. После этого результирующий файл будет пересчитан с учетом новых параметров и всех ранее выполненных обработок.
Командой Audio > Statistics запускается процедура сбора статистической информации о выделенном аудиосообщении, по окончанию которой открывается окно Statistics. В нем содержатся следующие сведения:

  • Максимальное и минимальное значения звуковых отсчетов
  • Пиковое значение амплитуды
  • Величина и знак постоянной составляющей сигнала
  • Разрядность представления и частота сэмплирования звуковых данных
  • Локальные максимум и минимум среднеквадратических значений сигнала
  • Среднее (для всего выделенного аудиосообщения) значение уровня сигнала

Некоторые из перечисленных данных могут оказаться полезными при выборе параметров таких обработок, как преобразование уровня сигнала, нормализация, динамическая обработка.
Функция Freeze Edits (команда Audio > Freeze Edits) переписывает результаты всех обработок из временных файлов в постоянные. При этом программа запрашивает ваше решение: заменить существующие (исходные необработанные файлы) или создать новые файлы. В случае создания новых файлов ссылки на старые файлы по-прежнему останутся в пуле. Но все аудиосообщения, подвергшиеся деструктивному редактированию, будут основаны на новых версиях клипов (см. разд. 12.4), которые будут ссылаться на новые файлы.


Глава 13. Применение VST-плагинов

    • Применение VST-плагинов
    • 13.1. VST-плагины группы Delay
    • 13.1.1. DoubleDelay
    • 13.1.2. ModDelay
    • 13.2. VST-плагины группы Distortion
    • 13.2.1. Da Tube
    • 13.2.2. Overdrive
    • 13.2.3. Quadra Fuzz
    • 13.3. VST-плагины группы Dynamics
    • 13.3.1. DeEsser
    • 13.3.2. Dynamics
    • 13.3.3. VSTDynamics
    • 13.4. VST-плагин StepFilter
    • 13.5. VST-плагины группы Modulation
    • 13.5.1. Chorus
    • 13.5.2. Flanger и Symphonic
    • 13.5.3. Metalizer
    • 13.5.4. Phaser
    • 13.5.5. RingModulator
    • 13.5.6. Rotary
    • 13.5.7. Tranceformer
    • 13.6. VST-плагины группы Other
    • 13.6.1. Bitcrusher
    • 13.6.2. Chopper
    • 13.6.3. Grungelizer
    • 13.6.4. Vocoder
    • 13.7. VST-плагины группы Reverb
    • 13.7.1. Reverb A
    • 13.7.2. Reverb B
    • 13.8. Симулятор магнитофонного дилэя


Применение VST-плагинов

В предыдущих разделах книги уже рассмотрены многие вопросы, связанные с применением VST-плагинов. Перечислим только основные из них.

  • Сущность звуковых эффектов (см. разд. 1.9)
  • Основные параметры звукового движка VST (см. разд. 2.5)
  • Подключение VST-плагинов (см. разд. 5.6)
  • Получение информации о плагинах (см. разд. 5.6.1)
  • Применение эффектов параллельного действия в многоканальных проектах (см. разд. 5.6.2)
  • Подключение плагинов к мастер-секции микшера (см. разд. 5.6.2)
  • Автоматизация VST-аудиоэффектов (см. разд. 4.7.8)

Для обработки аудиотреков и VSTi вы можете использовать любые из VST-плагинов, как входящие в поставку Cubase SX, так и приобретенные вами отдельно от программы.
Вы можете применять плагины не только в качестве эффектов реального времени, но и для деструктивного редактирования аудиосообщений. Выделите одно или несколько аудиосообщений, затем в подменю Audio > Plagins главного меню выберите нужный плагин, настройте его параметры и нажмите Process. Для предварительного прослушивания результата применения плагина нажмите в его окне кнопку Preview.
Общее число VST-плагинов, разработанных в мире, сосчитать практически невозможно, настолько их много. Информацию о VST-плагинах, установленных на вашем компьютере, вы можете получить в окне Plug-in Information (см. разд. 5.6.1, рис. 5.13). В поставку Cubase SX их входит около 50. Наиболее удобно классифицировать имеющиеся плагины в соответствии с их списком в секции Inserts аудиотрека (окно Cubase SX Project), аналогичный список имеется также и в подменю Audio > Plug-ins.
Плагины здесь сгруппированы по функциональному назначению:

  • Cubase 5 Plug-ins — плагины, перешедшие из профаммы Cubase VST;
  • Delay — варианты эффекта "дилэй";
  • Distortion — варианты эффекта "дистошн";
  • Dynamics — динамическая обработка;
  • Filter — фильтр с динамическим управлением частотой среза и глубиной резонанса;
  • Modulation — эффекты, связанные с модуляцией (периодическим изменением) параметров звука;
  • Other — прочие эффекты, не относящиеся к тем группам эффектов, которые соответствуют устоявшейся классификации;
  • Reverb — варианты эффекта "реверберация";
  • Surround — многоканальные плагины;
  • DirectX — эффекты и виртуальные инструменты, подключаемые посредством DirectX; содержание подменю зависит от того, какие DX-эффекты и DX-инструменты установлены на компьютере.

Мы не будем останавливаться на плагинах, входящих в группу Cubase 5 Plug-ins. DX-плагины в поставку Cubase SX просто не входят, хотя если у вас таковые имеются, ничто не мешает использовать их. О сущности звуковых эффектов и обработок, а также о назначении их основных параметров мы рассказали в разд. 1.9. С единственным плагином Mix6to2, имеющимся в группе Surround, вы познакомитесь в главе 14. Поэтому остается только кратко рассмотреть особенности плагинов, входящих в группы: Delay, Distortion, Dynamics, Filter, Modulation, Other и Reverb.


13.1. VST-плагины группы Delay

В профессиональной виртуальной студии Cubase SX эффектов, основанных на задержке сигнала, не счесть. Среди них есть и два дилэя: DoubleDelay и ModDelay, отличающиеся интерфейсом и набором регулируемых параметров.


13.1.1. DoubleDelay

Как следует из названия, в плагине DoubleDelay реализован эффект Delay (см. разд. 1.9.2), причем для каждого из двух стереоканалов выбор большей части параметров осуществляется независимо.
В окне плагина DoubleDelay (рис. 13.1) можно регулировать величину задержки (DelayTimel, DelayTimeZ), значение коэффициента обратной связи (Feedback), произвольно панорамировать обработанный сигнал (Pan1, Pan2), а также синхронизировать задержку с темпом музыкальной композиции (Tempo Syncl, Tempo Syncl).

Рис. 13.1. Окно эффекта DoubleDelay

Здесь предусмотрены два канала задержки, а изменения положений ручек регулировки наглядно отображаются на двух графиках.
Слайдером Mix регулируется пропорция, в которой на выходе эффекта смешиваются обработанный и исходный сигналы.
В верхней части окна расположены элементы, идентичные тем, что вы найдете и в окнах всех остальных эффектов:
— кнопка временного отключения плагина (плагин включен, когда она нажата);
— кнопка включения режима записи автоматизации параметров эффекта;
— кнопка включения режима воспроизведения данных автоматизации;
— кнопки последовательного пролистывания пресетов, перечень которых можно увидеть в списке, расположенном справа. В правой верхней части окна расположен раскрывающийся список File, пользуясь командами которого, вы можете сохранить в файле и загрузить из него собственные установки параметров эффекта.


13.1.2. ModDelay

В окне плагина ModDelay (рис. 13.2) также реализован эффект Delay.

Рис. 13.2. Окно эффекта ModDelay

У плагина ModDelay есть два существенных отличия от плагина DoubleDelay.
1. Регулировки в окне плагина ModDelay осуществляются только для обоих стреоканалов одновременно.
2. Время задержки можно модулировать (периодически изменять), глубина модуляции регулируется (DelayMod).


13.2. VST-плагины группы Distortion

В этой группе собраны плагины, реализующие различные варианты эффекта Distortion (см. раз. 1.9.3).


13.2.1. Da Tube

Окно плагина DaTube представлено на рис. 13.3.
Здесь моделируется звучание, характерное для перегруженного лампового усилителя. Регулируются степень искажений (Drive), соотношение исходного и обработанного сигналов в выходном миксе (Balance) и уровень выходного сигнала (Output). Украшением окна является индикатор перегрузки, выполненный в виде электронной лампы. Чем сильнее перегружен усилитель, тем ярче светится лампа. В реальных электронных лампах свечение разреженного газа под воздействием протекающего тока действительно имеет место.

Рис. 13.3. Окно эффекта DaTube


13.2.2. Overdrive

Плагин Overdrive (рис. 13.4), как и остальные эффекты группы Distortion — на любителя. Суть его состоит в изощренном искажении сигнала.

Рис. 13.4. Окно эффекта Overdrive

Для того чтобы вы сумели исковеркать сигнал до неузнаваемости, в окне есть достаточное количество регулировок и опций. Можно "поддать жару" уже на входе эффекта (регулировкой уровня входного сигнала Input). Предусмотрена обработка сигнала трехполосным графическим эквалайзером (Bass, Mid, High). Кнопкой Speakersimulation включается имитация искажений сигнала в громкоговорителе, конкретный алгоритм можно выбрать в раскрывающемся списке.
На графике символически показан характер изменения спектра сигнала (см. разд. 1.11.2), обработанного эффектом. Если степень искажений (Drive) не велика, на графике видны две спектральные составляющие: спектр сигнала на входе (как будто сам сигнал имеет синусоидальную форму) и спектр его второй гармоники. При увеличении значения Drive в спектре появляется множество высших гармоник, которые и отображаются на графике. Обращаем ваше внимание, что в данном случае речь не идет о реальном анализаторе спектра. График — не более чем остроумно задуманный индикатор положения ручек Bass и Drive.


13.2.3. QuadraFuzz

Плагин QuadraFuzz (рис. 13.5), предназначен для получения эффекта Fuzz, в основе которого лежит все то же искажение сигнала за счет ограничения его амплитуды. Таким путем спектр исходного сигнала обогащается. Плагин QuadraFuzz отличается от простейшего эффекта Fuzz, тем, что в нем ведется раздельная обработка спектра сигнала четырьмя фильтрами. Уровень сигнала, посылаемого в каждый из фильтров, устанавливается регуляторами Low, Low Mid, High Mid, High. Банк пресетов выбирается в раскрывающемся списке, а выбор конкретного пресета осуществляется с помощью слайдера Presets.

Рис. 13.5. Окно эффекта QuadraFuzz

Если нажать на кнопку Edit, то откроется дополнительная секция окна (рис. 13.6), предназначенная для редактирования амплитудно-частотных характеристик фильтров (см. разд. 1.10.1).
Передвигая мышью ромбики, находящиеся на шкале частоты, можно изменить границы раздела полос фильтров. Ромбиком, находящимся на вершине характеристики, изменяется коэффициент передачи в полосе пропускания соответствующего фильтра. Кнопками, расположенными в правой части дополнительной секции окна, переключается добротность фильтра. Самая высокая добротность соответствует включенной нижней кнопке.
Результат обработки оценивается на слух.

Рис. 13.6. Окно эффекта QuadraFuzz в режиме редактирования пресетов


13.3. VST-плагины группы Dynamics

В группе Dynamics собраны плагины, реализующие различные варианты динамической обработки.


13.3.1. DeEsser

В плагине DeEsser (рис. 13.7) реализовано компрессирование динамического диапазона сигнала в полосе частот, характерных для свистящих и шипящих звуков.

Рис. 13.7. Окно плагина DeEsser

Регулировка степени подавления свистящих звуков осуществляется ручкой S-Reduction, а срабатывание компрессора отображается на сегментированном индикаторе.
Если нажать кнопку Auto Threshold, то порог срабатывания компрессора программа будет выбирать автоматически. Кнопками Male и Female выбирается алгоритм, оптимизированный для обработки мужских и женских голосов.


13.3.2. Dynamics

Плагин Dynamics (рис. 13.8) представляет собой модуль динамической обработки, состоящий из компрессора, лимитера и спектрального гейта. Каждый из виртуальных приборов имеет свой порядковый номер, благодаря чему, при помощи переключателя Routing, можно менять порядок включения динамических обработок.

Рис. 13.8. Окно плагина Dynamics

Компрессор снабжен графическим дисплеем для отображения графика компрессии. Ниже дисплея располагается индикатор степени сжатия и переключатели способа детектирования (Peak/RMS). Регуляторами Threshold и Ratio устанавливаются порог срабатывания компрессора и степень сжатия. Ручками Attack и Release устанавливаются постоянные времени срабатывания и восстановления. Время восстановления может устанавливаться автоматически, это происходит после нажатия кнопки Auto. Уровень выходного сигнала компрессора регулируется ручкой MakeUpGain.
Спектральный гейт имеет регулятор порогового уровня (Threshold), а также регуляторы постоянной времени срабатывания (Attack), поддержки (Hold) и восстановления (Release). Гейт может работать либо по схеме с обратной регулировкой, либо по схеме с прямой регулировкой. Второй режим включается кнопкой Predict. Порог срабатывания может быть установлен автоматически кнопкой Calibrate. Возможна автоматическая установка времени восстановления. Над регуляторами гейта расположен трехпозиционный переключатель режимов работы детекторной цепи. В первом положении (Off) детекторная цепь и гейт вместе с ней становятся частотно-независимыми. Во втором положении (On) частотный диапазон детекторной цепи определяется границами, установленными слайдерами Trigger Frequency Range. В третьем положении (Listen) можно прослушать звучание аудиосигнала, прошедшего через саму детекторную цепь.
Лимитер имеет регулятор уровня срабатывания (Threshold) и индикатор работы (Limit). Время восстановления может устанавливаться автоматически или регулятором Release.
Подробное разъяснение сущности динамических обработок, их параметров и описание технологии применения вы найдете в разд. 1.10.2.


13.3.3. VSTDynamics

Плагин VSTDynamics (рис. 13.9) представляет собой модуль динамической обработки, так же как и Dynamics. Однако в VSTDynamics кроме компрессора (KOMPRESSOR), лимитера (LIMITER) и спектрального гейта (AUTO GATE) есть также стабилизатор уровня (AUTO LEVEL).

Рис. 13.9. Окно плагина VSTDynamics

Уровень сигнала на выходе компрессора отображается "стрелочным" индикатором SOFT CLIP.
Очередность включения виртуальных приборов обработки показана на структурной схеме, находящейся в правой нижней части окна.


13.4. VST-плагин StepFilter

В группе Filter имеется единственный плагин StepFilter (рис. 13.10), который представляет собой фильтр с динамическим управлением частотой среза и усилением в полосе обработки.
График изменения частоты среза задается в координатном поле Cutoff, а график изменения усиления — в координатном поле Resonance.

Рис. 13.10. Окно плагина StepFilter

Исходные значения двух параметров задаются регуляторами BaseCutoff и Base Resonance. Регулятор Glide определяет характер интерполяции графиков (степень плавности "скольжения" параметров от одного дискретного значения к другому).
Слайдером, расположенным в нижней части окна, выбирается тип фильтра: фильтр нижних частот, полоснопропускающий фильтр или фильтр верхних частот.
В раскрывающемся списке Sine выбирается период времени (в долях такта), на протяжении которого будет происходить полный цикл перестройки параметров.
Подробные сведения о фильтрах различного типа вы найдете в разд. 1.10.1.


13.5. VST-плагины группы Modulation

В группу Modulation объединены эффекты, в которых используется модуляция (периодическое изменение) того или иного параметра.


13.5.1. Chorus

Плагин Chorus (рис. 13.11) реализует несложный хорус.

Рис. 13.11. Окно плагина Chorus

Регулятором Frequency устанавливается частота модуляции, а регулятором Delay — глубина эффекта.
Переключатель Stages позволяет выбрать количество дополнительных звучащих голосов.
Сущность эффекта хорус рассмотрена в разд. 1.9.2.


13.5.2. Flanger и Symphonic

Плагины Flanger (рис. 13.12) и Symphonic (рис. 13.13) представляют собой варианты комбинированного эффекта, сочетающего в себе фленжер и авто-панер (устройство, управляющее панорамой сигнала в соответствии с заданным законом). Сущность эффектов подобного рода рассмотрена в разд. 1.9.2. Окна эффектов очень похожи. В каждом из них отображаются ширина стереопанорамы и качественный график изменения задержки сигнала.
Фейдером Mix регулируется соотношение уровней исходного и обработанного сигналов, регуляторы Delay и Depth изменяют время задержки и глубину эффекта. Регулятор StereoBasis отвечает за ширину стереобазы. Регулятор Rate определяет частоту модуляции времени задержки. Автоматическое панорамирование темпозависимое, зависимость устанавливается элементами группы TempoSync. В плагине Flanger ручкой Feedback регулируется коэффициент обратной связи.

Рис. 13.12.Окно плагина Flanger

Рис. 13.13. Окно плагина Symphonic


13.5.3. Metalizer

Плагин Metalizer (рис. 13.14) позволяет получить эффект "металлического" звучания. По сути дела он представляет собой резонансный фильтр, центральная частота которого перестраивается по периодическому закону. Необычное звучание достигается также тем, что фильтр охвачен цепью обратной связи.
Регулятором Feedback задается глубина (коэффициент) обратной связи.
Регулятор Топе управляет частотной характеристикой цепи обратной связи. Действие регулятора сильнее выражено при больших значениях Feedback.

Рис. 13.14. Окно плагина Metalizer

On — кнопка включения динамического управления фильтром. Если она выключена, эффект превращается в обыкновенный фильтр с неизменными во времени параметрами.
Значения параметра Sharpness связаны с полосой пропускания перестраиваемого фильтра. Чем больше Sharpness, тем уже полоса и тем более выражено проявление резонансных свойств фильтра.
Кнопкой Mono можно выбрать либо монофонический, либо стереофонический формат сигнала на выходе плагина.


13.5.4. Phaser

Плагин Phaser реализует одноименный эффект, сочетающийся с автопанорамированием. Окно плагина Phaser (рис. 13.15) очень похоже на окна, знакомые вам по рис. 13.12 и 13.13.

Рис. 13.15. Окно плагина Phaser

Элементы регулировки, аналогичные тем, что имеются в окне Phaser, мы рассмотрели в разд. 13.5.2. Сущность эффекта описана в разд. 1.9.2.


13.5.5. RingModulator

Плагин RingModulator (рис. 13.16) перемножает отсчеты входного аудиосигнала на отсчеты периодического колебания, вырабатываемого генератором, имеющимся в плагине. Назовем это колебание опорным.

Рис. 13.16. Окно плагина RingModulator

В аналоговой технике такую функцию выполняет устройство, которое называется кольцевым модулятором. Из теории сигналов известно, что при перемножении двух гармонических колебаний возникает бесконечно большое количество колебаний, частоты которых равны всем возможным комбинациям частот перемножаемых колебаний и их гармоник [8, 12, 45|. Даже если бы обрабатываемый сигнал был синусоидальным, то в итоге его взаимодействия в кольцевом модуляторе с еще одним синусоидальным сигналом было бы сформировано колебание, имеющее довольно широкий спектр. Однако любой реальный обрабатываемый сигнал с самого начала отличается от синусоиды, да и второй сигнал (формируемый в плагине) может иметь сложную форму. Поэтому результатом работы плагина будет чрезвычайно широкополосное колебание, содержащее в своем спектре гармонические и комбинационные составляющие.
Генератор плагина формирует опорные колебания сложной структуры следующим способом. Сначала в осцилляторе (Oscillator) вырабатываются колебания в виде последовательности прямоугольных или пилообразных импульсов. Затем амплитуда этих колебаний подвергается изменению в соответствии с огибающей, форма которой, в свою очередь, определяется параметрами генератора низкочастотных колебаний (LFO). И только после всех этих операций сформированный опорный сигнал перемножается с обрабатываемым сигналом.
Окно плагина разделено на две группы. В левой группе (Oscillator) сосредоточены элементы управления осциллятором:

  • LFO Amount — регулятор глубины модуляции сигнала осциллятора сигналом LFO;
  • Env. Amount — регулятор степени влияния огибающей обрабатываемого сигнала на частоту сигнала осциллятора. При Env. Amount = 0 влияние отсутствует. Если Env. Amount > 0, то громкий входной сигнал увеличит частоту, если Env. Amount < 0 — уменьшит;
  • Range — переключатель частотного диапазона осциллятора;
  • Frequency — регулятор частоты в пределах +/- 2 октавы от значения, выбранного переключателем Range;
  • Roll-Off — регулятор степени подавления высоких частот в колебании на выходе осциллятора.

В группе LFO находятся элементы управления генератором огибающей:

  • Speed — регулятор параметра, связанного с частотой LFO;
  • Env. Amount — регулятор степени влияния огибающей обрабатываемого сигнала на частоту колебания на выходе LFO;
  • Invert Stereo — кнопка инвертирования сигнала правого канала на выходе LFO в целях расширения стереобазы;
  • Lock L<R — кнопка переключения режима управления правым и левым каналами. Если она включена, то сигналы в стереоканалах перемножаются с одним и тем же опорным сигналом, в противном случае — с разными;
  • Attack и Decay — регуляторы формы элементов сигнала LFO.

С помощью кнопок, на которых изображены прямоугольные и треугольные символы, выбирают форму сигналов осциллятора и генератора LFO.


13.5.6. Rotary

Плагин Rotary (рис. 13.17) моделирует эффект, который в прежние времена получали путем вращения динамика.
Во время такого вращения у звука, достигающего слушателя, периодически изменяется громкость, тембр и в небольших пределах частота. В ряде устройств вместо того, чтобы вращать сам динамик, перед ним размещали вращающуюся крыльчатку, подобную тем, что используются в вентиляторах.

Рис. 13.17. Окно плагина Rotary

Иногда такой эффект называют фейзером, иногда лесли. В любом случае, в основе эффекта лежит явление изменения частоты колебаний, излучаемых источником, движущимся по отношению к слушателю. Если угловая скорость вращения динамиков переменна, то результат может напоминать хорус.
В плагине смоделирована стереофоническая акустическая система. Каждый ее излучатель состоит из двух вращающихся динамиков — низкочастотного и высокочастотного. Граница раздела частот между ними устанавливается регулятором Crossover Freq.
Регуляторами Low Slow и Low Fast устанавливается скорость вращения низкочастотного динамика. Первый из регуляторов действует в том случае, когда в списке Speed выбрана строка Slow, второй — когда выбрана строка Fast. Таким образом, можно заранее подобрать два различных значения скорости вращения и в дальнейшем быстро их переключать. Регуляторы High Slow и High Fast аналогичным образом управляют скоростью вращения высокочастотного динамика.
Регуляторы Low Rate и High Rate позволяют управлять временем "раскрутки" соответствующих динамиков. При малых значениях Low Rate и High Rate динамики будут долго "набирать обороты", а при больших "пустятся с места в карьер".
Регулятор Overdrive имитирует перегрузку динамиков и позволяет управлять ее уровнем.
Плагин многофункционален, он моделирует не просто стереофоническую акустическую систему с вращающимися динамиками. Предполагается, что звук, излученный динамиками, сначала попадает в микрофоны (отдельно левого и правого каналов) и только после этого поступает в тракт записи. То есть фактически мы имеем дело с двумя комбиками (по одному на каждый стереоканал). Регулятором Mic Angle можно имитировать изменение угла между акустическими осями микрофона и акустической системы (меняется тембр звука). Регулятор Mic Distance позволяет "приближать" к акустической системе или "удалять" от нее микрофон: имитируется изменение отношения энергии прямого звука к энергии звука рассеянного. В результате меняется звуковой план.
Регуляторами Low Rotor Amp Mod. и High Rotor Amp Mod. изменяется глубина амплитудной модуляции в низкочастотном и высокочастотном каналах соответственно. В реальных устройствах глубокая амплитудная модуляция будет в том случае, когда динамик имеет узкую характеристику направленности и в тыловой зоне вращающегося динамика находится акустический экран (звук из "отвернутого" динамика не доходит до слушателя или микрофона). Альтернативный вариант: динамик неподвижен, а перед ним размещен вращающийся акустический экран, в котором имеется отверстие. Когда динамик "выглядывает" в отверстие, звук слышен громко, когда "прячется" за экраном — почти не слышен.
Регулятором Low Rotor Mix Level изменяется уровень сигнала низкочастотного канала (вклад низкочастотного динамика в итоговый звук).
В отличие от низкочастотного динамика, в высокочастотном, кроме амплитудной модуляции, реализуется также и частотная. Глубина частотной модуляции изменяется регулятором High Rotor Freq. Mod.. Имитируется периодическое изменение скорости вращения высокочастотного динамика. Данный факт свидетельствует о том, что разработчик плагина прекрасно понимает физику процессов, протекающих в тех реальных устройствах, которые он моделирует. Действительно, габариты и масса низкочастотного динамика всегда велики, такой динамик инерционен, и было бы трудно заставлять его изменять скорость вращения. Другое дело — маленький и легкий высокочастотный динамик.
Регулятор Phasing позволяет изменить разность фаз сигналов, модулирующих звук в высокочастотном канале по амплитуде и частоте.
Для переключения режима управления скоростью служат кнопки группы Mode. Если включена кнопка [image] то становится доступным раскрывающийся список Speed, в котором и производится выбор скорости.
Раскрывающийся список Speed позволяет остановить вращение (Stop) или сменить "медленное" вращение (Slow) на "быстрое" (Fast). На самом деле переключение происходит между значениями Low Slow — High Slow для низкочастотного динамика и Low Fast — High Fast для высокочастотного.
В плагине предусмотрено изменение скорости вращения посредством MIDI-сообщений. Управление передается MIDI-системе при включенной кнопке [image] . Как только вы подключаете плагин Rotary к проекту, в списке Out: основной секции инспектора MIDI-трека окна проекта появляется выходной порт под названием Rotary. Если для одного из MIDI-треков назначить этот порт, то в части, созданной на данном треке, можно записывать сигналы управления скоростью. Задействованный контроллер должен совпадать с контроллером, выбранным в раскрывающемся списке MIDICtrl. окна плагина Rotary.


13.5.7. Tranceformer

Плагин Tranceformer (рис. 13.18) подобно плагину RingModulator (см. разд. 13.5.5) перемножает входной аудиосигнал на периодическое опорное колебание, вырабатываемое генератором, имеющимся в плагине. Далее полученный в результате перемножения сигнал пропускается через перестраиваемый фильтр. Опорное колебание может быть промодулировано по амплитуде колебанием инфранизкой частоты (его частота не превышает 10 Гц), сформированным в генераторе огибающей. В итоге достигается следующий эффект: тон обрабатываемого звука преобразуется к некоторой преобладающей высоте и совершает колебания в ее окрестностях.

Рис. 13.18. Окно плагина Tranceformer

Кнопками, расположенными под графическим дисплеем, выбирают форму огибающей.
Регулятором Топе перестраивается частота опорного колебания и тем самым изменяется преобладающий тон формируемого звука.
Регулятор Depth позволяет изменять глубину модуляции опорного колебания, а регулятор Speed — частоту модулирующего сигнала, который поступает с выхода генератора огибающей.


13.6. VST-плагины группы Other

В группе Other собраны плагины, которые реализуют довольно-таки разнородные эффекты.


13.6.1. Bitcrusher

Плагин Bitcrusher (рис. 13.19) воссоздает обработку звукового сигнала аналого-цифровыми преобразователями различного качества. Он позволяет имитировать изменение разрядности представления сигнала и уменьшение частоты сэмплирования.

Рис. 13.19. Окно плагина Bitcrusher

Кнопками группы Mode выбирается один из алгоритмов обработки. Суть алгоритмов разработчик не раскрывает, однако наши эксперименты показали, что, вероятнее всего, происходит переключение частотной характеристики фильтра.
Регулятором Depth изменяется разрядность представления звука. Правда, не совсем понятно, что бы могли означать нецелые числа, появляющиеся над регулятором. Как понимать, например, "шестнадцать целых, три десятых разряда"? Скорее всего, речь идет о некой "эквивалентной разрядности", о показателе, опосредованно связанном с истинной разрядностью представления звуковых отсчетов.
Регулятором Sample Divider можно выбрать коэффициент прореживания звуковых выборок. Например, если им установить число 2, то на выход плагина будет поступать каждая вторая выборка, если установить число 65, то — каждая шестьдесят пятая. В общем, этот плагин предназначен для того, чтобы портить цифровой звук.


13.6.2. Chopper

He совсем понятно, почему плагин Chopper (рис. 13.20) попал в группу Other. Нам кажется, что логичнее было бы поместить его среди эффектов, основанных на модуляции. По сути дела, в нем реализовано амплитудное вибрато (см. разд. 1.9.1). Единственное заметное отличие от классического амплитудного вибрато состоит в том, что для модуляции сигналов в левом и правом стереоканалах используются не одинаковые низкочастотные колебания, а колебания, сдвинутые друг относительно друга на четверть периода. Если, например, выбрать модулирующее колебание гармонической формы, то в один канал будет поступать синусоида, а во второй — косинусоида. В итоге создастся впечатление вращающегося звука, точнее, звука, источник которого совершает плавные циклические перемещения слева направо и обратно.

Рис. 13.20. Окно плагина Chopper

Регуляторами Depth и Speed изменяют глубину модуляции и частоту модулирующего сигнала соответственно.


13.6.3. Grungelizer

Плагин Grungelizer (рис. 13.21) специально предназначен для внесения в звук различных искажений и помех. Этим он напоминает плагин Bitcrusher, рассмотренный в разд. 13.6.1. Правда, моделируются в них устройства, даты рождения которых отличаются больше, чем на 100 лет. Bitcrusher демонстрирует нам, на что способен плохой аналого-цифровой преобразователь, a Grungelizer — на что способен "хороший" граммофон.

Рис. 13.21. Окно плагина Grungelizer

При помощи этого эффекта можно:

  • добавить к звуку щелчки грампластинки, рассчитанной на различную стандартную скорость вращения (Crackle);
  • смоделировать проигрывание пластинки на древнем граммофоне (EQ), раструб которого к тому же может оказаться повернутым к слушателю "разными боками";
  • подмешать к звуку музыки шум (Noise), причин возникновения которого в звуковоспроизводящей аппаратуре во все времена хватало с избытком;
  • изменить степень изношенности иглы звукоснимателя и тем самым еще добавить искажений (Distort);
  • добавить гудение, вызванное наводками от линии электропитания (АС), и переключить частоту переменного тока;
  • переместиться во времени в позапрошлый век (при помощи регулятора Timeline) и тем самым послушать свою музыку не на граммофоне, а на совершенно древнем патефоне.

Для кого-то этот эффект — забавная нелепица. Но для кого-то он может служить источником ностальгических чувств и катализатором приятных воспоминаний о прекрасных временах, когда ни музыкантам, ни слушателям не приходилось мучиться над проблемами наподобие таких: "цифра или аналог", "виртуальная студия или студийное железо".


13.6.4. Vocoder

О вокодерах уже шла речь в разд. 1.9.4. Однако мы хотим сейчас сделать еще некоторые необходимые пояснения, имеющие непосредственное отношение к реализации вокодера в плагине Vocoder.
Вокодеры различных типов были разработаны в целях экономии частотных ресурсов радиолинии при передаче речевых сообщений. Вместо того чтобы передавать собственно речевой сигнал, передают только некоторые его параметры, которые на приемной стороне управляют синтезатором речи. Основу синтезатора речи составляют три элемента: генератор тонального сигнала для формирования гласных звуков, генератор шума для формирования согласных и система формантных фильтров для воссоздания индивидуальных особенностей голоса. Конструирование вокодеров, способных не только разборчиво воспроизводить речь, но и сохранять узнаваемость голоса говорящего человека, оказалось нелегкой задачей. После всех преобразований голос человека становится похожим на голос робота. Однако для систем голосовой связи это вполне терпимо. Если же не ставить перед собой задачу приближения звучания голоса, обработанного вокодером, к звучанию оригинала, а рассматривать вокодер как специфический эффект, то можно получить интересные результаты.
Вокодер как эффект, применяемый в музыке, позволяет перенести свойства одного (модулирующего) сигнала на другой сигнал, который иногда называют носителем (carrier). Часто в качестве сигнала-модулятора используется голос человека, а в качестве носителя — сигнал, формируемый музыкальным синтезатором. Так достигается эффект "говорящего" музыкального инструмента.
Окно плагина Vocoder представлено на рис. 13.22.

Рис. 13.22.Окно плагина Vocoder

Основа работы вокодера состоит в том, что спектр исходного сигнала-модулятора делится на множество частотных полос. Характеристики звука в этих частотных полосах можно использовать для модуляции носителя.
В плагине Vocoder предусмотрен собственный встроенный формирователь сигнала-носителя. В его основу положен простой мультитембральный синтезатор. Вместе с тем, имеется возможность использовать внешний высококачественный синтезатор.
В правой секции окна находятся элементы регулировки, влияющие на работу анализатора параметров модулирующего сигнала.
Number of Bands — количество полос, на которые разбивается спектр анализируемого сигнала. Если полос мало, эффект будет более заметным. При большом числе полос разборчивость звучания голоса улучшается.
Bandwidth — ширина полосы пропускания каждого фильтра. Узкие полосы подчеркивают резонансные свойства фильтров, голос будет содержать звенящие призвуки.
Min. Freq. и Max. Freq. — границы обрабатываемого частотного диапазона.
High Thru — регулятором можно обеспечить прохождение на выход плагина высокочастотных составляющих, характерных для свистящих звуков (наподобие "с"), которые имеются в исходном сигнале.
Talk Thru — регулировка уровня исходного сигнала, проходящего на выход плагина в моменты, когда играются ноты.
Gap Thru — регулировка уровня исходного сигнала, проходящего на выход плагина в моменты, когда ноты не играются (доступна только в режиме MIDI).
Это позволяет применять вокодер к треку с записанным вокалом только в отдельных местах.
log< >lin — регулировка характера изменения полос пропускания фильтров в пределах границы обрабатываемого частотного диапазона. В положении log< регулятор обеспечивает логарифмический закон изменения полос пропускания фильтров: с увеличением номера фильтра полоса удваивается, т. е. для каждого из фильтров она составляет октаву. В положении >lin полосы всех фильтров (измеренные в герцах) одинаковы. Регулятор оказывает влияние на тембр звука.
Регулятором Env.Speed изменяются продолжительности фаз attack и release огибающей включения вокодера. При малых значениях параметра будет происходить немедленное включение вокодера в момент появления входного сигнала и мгновенное выключение в момент его исчезновения. Большие значения параметра заставят вокодер включаться и выключаться постепенно. В крайнем правом положении регулятора устанавливается режим Hold: синтезатор вообще перестает реагировать на сигнал-модулятор.
Встроенный синтезатор сигнала-носителя позволяет формировать до 8 голосов (по 2 генератора на каждый голос).
Элементы управления встроенным синтезатором сосредоточены в левой секции окна. Перечислим их:

  • Voices — количество голосов синтезатора;
  • Pitch Bend — регулятор сдвига высоты тона;
  • Fine Tune — точная подстройка высоты тона;
  • Noise — уровень шума;
  • NoiseMod. — регулятор глубины модуляции шума;
  • P.Drift — регулятор уровня случайного изменения высоты тона;
  • P.Glide — регулятор скорости портаменто (перехода от одной ноты к другой);
  • P.Bright — регулятор частоты среза фильтра нижних частот (lowpass-фильтра), на генератор шума влияния не оказывает;
  • P.Detune — регулятор расстройки одного из двух генераторов (в каждом голосе), позволяет получить эффект унисона;
  • Emphasis — регулятор частоты среза фильтра верхних частот (highpass-фильтра);
  • LFO Rate — регулятор частоты LFO-генератора, используемого для вибрато;
  • Vibrato — регулятор глубины вибрато.

Рассмотрим особенности функционирования плагина в каждом из трех возможных режимах: MIDI, External и MIDI + External.
Если нажата кнопка MIDI, то вокодеру требуется и звуковой сигнал-модулятор, и сигнал на выходе MIDI-трека (носитель).
Соблюдайте следующий порядок настройки вокодера в режиме MIDI:
1. Выберите источник сигнала-модулятора. Им может быть звуковой материал, записанный на любом аудиотреке, или даже живой звук, поступающий на вход аудиотрека. Последнее имеет смысл в том только случае, когда ваша звуковая карта обладает малой величиной задержки (latency). Наиболее подходящим материалом для сигнала-модулятора является речь, вокал и звуки ударных инструментов.
2. Выберите Vocoder в качестве эффекта, подключенного в режиме Insert к аудиотреку с сигналом-модулятором. Откройте окно плагина Vocoder.
3. Нажмите кнопку MIDI в группе MODE.
4. В окне проекта Cubase SX выберите MIDI-трек. Трек может быть пустым или содержащим данные, это не имеет принципиального значения. Если
вы хотите "играть" на вокодере в реальном времени, то для трека следует включить режим записи или мониторинга, чтобы на Vocoder поступали сообщения с выходного MIDI-порта, ассоциированного с треком.
5. В раскрывающемся списке out: основной секции инспектора MIDI-трека выберите Vocoder. Теперь сообщения с выходного MIDI-порта трека направлены в Vocoder. Об их поступлении будет свидетельствовать индикатор, расположенный под кнопками группы MODE.
Вокодер готов к работе. Допустим, что вы используете в качестве сигнала-модулятора звуковые сообщения, записанные на аудиотреке, а сигнал-носитель получаете, играя на MIDI-клавиатуре в реальном времени.
В таком случае удостоверьтесь в том, что для MIDI-трека подготовлен режим записи, включите Cubase SX в режим воспроизведения и играйте на MIDI-клавиатуре.
А теперь перейдем к настройке и использованию вокодера в режиме External. В этом режиме модулятор и носитель могут быть любыми двумя звуковыми источниками. Большинство параметров вокодера и встроенного в него синтезатора недоступны.
Рассмотрим порядок настройки вокодера в режиме External.
1. Командой Project > Add Track > Group Channel создайте групповой трек.
2. Откройте (разместите на пустом аудиотреке) аудиофайл, который вы хотите использовать в качестве сигнала-носителя.
3. Панорамируйте аудиотрек вправо.
4. Назначьте в качестве выходного порта аудиотрека Group Channel: в списке out: выберите Group 01.
5. Откройте аудиофайл, который вы хотите использовать как источник сигнала-модулятора (разместите его на втором пустом аудиотреке). Для работы вокодера требуется, чтобы сообщения, записанные на двух аудио-треках, воспроизводились одновременно.
6. Панорамируйте второй аудиотрек влево.
7. Назначьте в качестве выходного порта второго аудиотрека Group Channel: в списке out: выберите Group 01.
8. Выберите Vocoder в качестве эффекта, подключенного в режиме Insert к групповому треку. Откройте окно плагина Vocoder и в группе MODE нажмите кнопку Ext.
Вокодер готов к работе. Осталось только включить в Cubase SX режим воспроизведения.
Порядок подготовки вокодера к работе в режимах MIDI + External и External практически одинаков. Особенность режима MIDI + External заключается в том, что нужно создать MIDI-трек, в раскрывающемся списке out: основной секции инспектора этого MIDI-трека выбрать Vocoder и включить режим записи или мониторинга. Затем следует открыть окно плагина Vocoder и в группе MODE нажать кнопку MIDI+Ext..
Теперь MIDI-сообщения будут поступать в синтезатор вокодера, и его звук будет смешиваться со звуком сигнала-носителя.


13.7. VST-плагины группы Reverb

В мощной профессиональной виртуальной студии Cubase SX средства для создания реверберации не могут отсутствовать по определению. И действительно, плагинов, реализующих реверберацию, здесь несколько. Остановимся на двух: Reverb А и Reverb В.


13.7.1. Reverb A

Плагин Reverb А (рис. 13.23) отличается наглядным интерфейсом, в котором ничего не стоит разобраться даже начинающему компьютерному музыканту.

Рис. 13.23. Окно плагина Reverb A

Слайдером PREDELAY регулируется время запаздывания начала реверберационного процесса по отношению к породившему его звуку. Слайдер ROOMSIZE предназначен для пропорционального изменения размеров виртуального помещения. Слайдером REVERBTIME регулируется время реверберации. Самое интересное заключается в том, что все изменения любого из этих трех параметров сразу же отображаются на соответствующих картинках: звуковой импульс отдаляется от динамика или приближается к нему, "кубик" изменяется в размерах, вытягивается или "поджимается" реверберационный хвост.
Кроме того, в окне, конечно, имеются элементы управления частотой среза фильтров (группа FILTER, регуляторы High Cut, Low Cut) и регулятор Mix микширования исходного (Dry) и обработанного эффектом (Wet) аудиосигналов.
Разработчики предусмотрели несколько пресетов со стандартным набором типов реверберации. Параметры эффекта можно сохранить в файле и загрузить из него. Важно, что с помощью кнопок R и W можно организовать запись в реальном времени и последующее воспроизведение всех ваших операций с регуляторами.


13.7.2. Reverb В

Плагин Reverb В (рис. 13.24) представляет собой реверберацию с упрощенным набором параметров управления:

  • RoomSize — размер помещения;
  • ReverbTime — время реверберации;
  • PreDelay — время запаздывания начала реверберационного процесса;
  • Damp — параметр, связанный со скоростью затухания высокочастотных компонентов реверберирующего сигнала.

Рис. 13.24. Окно плагина Reverb В

Смысл реверберации раскрыт в разд. 1.9.2, там же описана связь параметров модели и реального физического процесса, а также приведены рекомендации по применению эффекта.


13.8. Симулятор магнитофонного дилэя

Мы не собирались рассматривать VST-плагины, доставшиеся Cubase SX в наследство от Cubase VST. Однако один из них показался нам забавным и поучительным. Речь идет о плагине Karlette, входящем в группу Cubase 5 Plug-ins.
Помните, в разд. 1.9.2 мы рассказывали, как получить эффект многократного эха с помощью многоголовочного магнитофона? А вот и он сам (рис. 13.25).

Рис. 13.25. Окно симулятора магнитофонного дилэя

Конечно, на рисунке вы видите не настоящий магнитофон с его постукивающим электродвигателем, посвистывающим лентопротяжным механизмом и пощелкивающей в месте склейки лентой, пущенной по кольцу. Это только похожая на настоящую и наглядно выполненная панель управления эффектом, который называется Karlette, а реально является дилэем с четырьмя независимыми каналами управления параметрами. Вверху панели показана записывающая головка, а внизу выстроились в ряд 4 воспроизводящие головки. Трудно удержаться от ехидного замечания в адрес дизайнеров, разработавших облик панели. Всё они предусмотрели. Даже проводники, с помощью которых головки соединяются со схемой прибора, покрыты разноцветной изоляцией, а головки болтиков блестят, будто они и в самом деле никелированные. И все же один немаловажный элемент — стирающую головку — они забыли изобразить. А ведь если бы перед тем, как подать к записывающей головке ленту, ее не очищали от предыдущей записи, образовалась бы звуковая каша. Но этот недостаток имеет исключительно декоративный характер. На самом деле, алгоритм, имитирующий магнитофонный дилэй, работает правильно, а вы можете подбирать параметры эффекта на свой вкус.
Возле каждой из воспроизводящих головок расположен регулятор времени задержки Delay (в реальном магнитофоне для изменения задержки пришлось бы передвигать головки вдоль канала транспортировки ленты). Если включить кнопку Sync, то задержка станет ритмизированной: кратной некоторой заданной доле музыкального такта. Соотношение уровней исходного и обработанного сигналов регулируется слайдером Wet — Dry. В каждом из каналов задержки доступны 4 параметра:

  • Volume — уровень сигнала, обработанного в данном канале, поступающего на выход эффекта;
  • Pan — панорама сигнала, обработанного эффектом;
  • Damp — степень демпфирования (чем ближе значение параметра к 1, тем быстрее затихают высокочастотные составляющие эха);
  • Feedback — коэффициент обратной связи.

На этом мы завершаем главу, в которой вы познакомились с новыми VST-плагинами, поставляемыми вместе с Cubase SX. Остается сказать, что это, конечно, хорошие, но не самые лучшие виртуальные эффекты и обработки. Разнообразные и значительно более совершенные VST-плагины вы сможете приобрести отдельно от программы Cubase SX. Но рассказ о них — это тема совсем другой книги.


Глава 14. Сведение композиции

    • Сведение композиции
    • 14.1. Общие принципы сведения в стерео
    • 14.1.1. Обработка аудиотреков и треков VSTi
    • 14.1.2. Панорамирование
    • 14.1.3. Применение эффектов
    • 14.2. Общие принципы сведения в 5.1
    • 14.3. Работа с видео
    • 14.4. Экспорт сведенной композиции


Сведение композиции

Сведение — процесс формирования законченной композиции из многодо-рожечного проекта. Причем занятие это, безусловно, творческое. Однако за годы существования звукозаписи выработались некие рекомендации, в соответствии с которыми следует выполнять сведение. Этой проблеме можно было бы посвятить отдельную книгу, причем желательно, чтобы ее авторами были несколько звукорежиссеров, продюсеров, инженеров, обладающих многолетним опытом работы в сфере звукозаписи. Только в этом случае можно было бы получить более-менее объективное руководство по сведению. Но пока такой книги нет. Разумеется, мы не берем на себя смелость рассчитывать, что данная глава сможет ее заменить. Она адресована музыкантам, готовящим demo-запись в своей домашней студии на базе Cubase SX. Ее следует воспринимать как набор самых общих рекомендаций, выполнение которых позволит избежать грубых ошибок.
Если в проекте задействованы аппаратные синтезаторы или программные синтезаторы, работающие в качестве самостоятельных приложений (не являющихся плагинами VSTi и не подключенные к Cubase SX no протоколу ReWire), то перед сведением соответствующие партии следует переписать на отдельные аудиотреки.
Запись партий аппаратных синтезаторов осуществляется точно так же, как и запись любых внешних по отношению к компьютеру источников звука.

  • Линейный или цифровой выход внешнего синтезатора коммутируется с линейным или цифровым входом звуковой карты (если это еще не было сделано).
  • В проекте Cubase SX создается аудиотрек, он подготавливается к записи аудиоданных с того порта, к которому подключен синтезатор.
  • MIDI-трек, управляющий внешним синтезатором, переключается в режим Solo.
  • Проект запускается на воспроизведение (звучит только партия внешнего синтезатора), выполняется регулирование уровня записываемого сигнала.
  • Проект переключается в режим записи.

Вряд ли отдельные партии внешнего синтезатора следуют сквозь весь проект. Поэтому чтобы не расходовать дисковое пространство попусту, следует пользоваться режимами punch in и punch out (см. разд. 4.4.3, подраздел "Способы переключения программы в режим записи").
С внешними программными синтезаторами дело обстоит несколько проще. Обычно в них имеются средства экспорта воспроизводимого ими сигнала в звуковой файл. Такое средство, например, имеется в программном сэмплере Gigastudio. Важно проследить, чтобы формат экспортируемого звукового файла был таким же, как у остальных файлов проекта Cubase SX (см. разд. 2.11). Если это невозможно, то должны совпадать хотя бы частоты сэмплирования. Потом звуковой файл с партией внешнего программного синтезатора можно импортировать в проект Cubase SX командой главного меню File > Import > Audio File или средствами окна Pool (см. разд. 12.4).
Есть ли смысл перебрасывать партии VSTi на аудиотреки? Особого смысла нет. Это следует делать лишь в том случае, когда нужно освободить ресурсы процессора для других VSTi и эффектов. При этом, естественно, возрастет нагрузка на дисковую систему. В Cubase SX имеется индикатор загрузки процессора и дисков, вызываемый командой главного меню Devices > VST Performance. С его помощью вы всегда можете держать ситуацию под контролем.
Важный вопрос — использовать ли эффекты и обработки, встроенные во внешний синтезатор? Вопрос актуален потому, что качество эффектов в аппаратных синтезаторах, как правило, превосходит качество эффектов, реализуемых посредством VST-плагинов, входящих в поставку Cubase SX. Если речь идет об эффектах, которые уместно использовать в режиме вставки (хо-рус, флэнжер, дистошн и др.), то их использовать можно смело. Эффекты, которые обычно используются в качестве эффектов параллельного действия и формируют акустическое пространство композиции (реверберация, задержка), должны быть едиными для разных треков проекта. То есть от реверберации, задержки и др. эффектов, реализованных в синтезаторе, иногда лучше отказаться в пользу менее качественных VST-плагинов.
Если в дальнейшем вы предполагаете воспользоваться услугами профессиональной студии, то от эффектов синтезатора следует однозначно отказаться. Свой материал вы все равно понесете в студию в "сухом" виде (аудиотреки без каких-либо обработок).
Вокальные партии имеет смысл почистить от шумов. Если для записи вокала использовать хороший конденсаторный микрофон (например, Nevaton МС 416), качественные предусилитель и звуковую карту, а запись проводить в более-менее заглушенном помещении, то шума аппаратуры как такового фактически не будет. Останется удалить шумы, издаваемые самим вокалистом в паузах между фразами или непосредственно во время исполнения. Делать это лучше с помощью специализированного звукового редактора, например, Cool Edit Pro 2. Может возникнуть вопрос — как передать звуковые сообщения из Cubase SX во внешний звуковой редактор? Это как раз не проблема. Ведь все звуковые файлы, используемые в проекте, хранятся в соответствующем каталоге в папке Audio. Однако прежде чем приступать к редактированию этих файлов, Cubase SX лучше закрыть.
Итак, мультитрековый проект сформирован и готов к сведению.


14.1. Общие принципы сведения в стерео

Начнем с основных задач, решаемых при сведении:

  • Применение обработок
  • Панорамирование
  • Подбор громкости треков
  • Применение эффектов

В каком порядке следует осуществлять сведение? Некоторые звукорежиссеры советуют заглушить все треки, кроме барабанов и басов, и с них начинать сведение, а вокальные партии оставить "на потом". Другие специалисты дают прямо противоположные рекомендации — начинать сведение с вокала. Но практика показывает, что, в каком бы порядке сведение не выполнялось, коррективы в настройки различных треков придется вносить неоднократно.


14.1.1. Обработка аудиотреков и треков VSTi

Наиболее часто используемой при сведении обработкой является компрессия. Цель компрессии — понизить динамический диапазон сигнала, записанного на треке, и таким образом устранить сильные перепады громкости, повысить разборчивость вокала. Соответственно, компрессия применяется в режиме вставки только для тех треков, для которых она действительно нужна (вокал, акустические инструменты). Компрессию стоит использовать разумно. Иногда вместо компрессии предпочтительнее использовать автоматизацию для удержания заданного уровня громкости. Зачастую компрессором пользуются как эффектом для изменения характера звучания ритмической секции.
В поп-музыке очень часто используется эффект хорус. Если требуется применить хорус к вокальной партии, то предпочтительнее реализовать этот эффект естественным путем еще на этапе записи. То есть несколько раз выполнить запись одной и той же вокальной партии, с размещением полученных дублей в параллель на разных треках. А механизм регионов (см. разд. 4.4.3, подраздел "Режимы записи, циклическая запись, регионы аудиосообщений" и разд. 12.2.3) может существенно облегчить вам работу по манипулированию дублями. Еще большего эффекта можно достичь, если развести дубли вокальной партии в разные точки панорамы.
Эквализация (обработка треков частотными фильтрами) используется для того, чтобы подчеркнуть какие-то особенности тембра инструмента или, наоборот, ограничить его спектр. Все это относится к задаче повышения прозрачности (разборчивости) композиции. Каждый из инструментов по отдельности может звучать сколь угодно красиво, "сочно" и "жирно". Однако общий микс из таких инструментов будет представлять собой мутную кашу: спектры инструментов накладываются друг на друга и человеческое ухо уже с трудом может выделить отдельные партии инструментов. За счет разумной эквализации можно существенно повысить прозрачность композиции.
Основным элементом современной танцевальной музыки является большой барабан (base drum). Основная часть энергии большого барабана сосредоточена в диапазоне частот 100—250 Гц. Спектр бас-гитары или замещающего ее электронного инструмента накладывается на спектр большого барабана и может занимать полосу частот от 40 Гц до 800 Гц. Это не страшно, т. к. большой барабан обычно работает в паре с бас-гитарой (они взаимодополняют друг друга). Но, тем не менее, следует достигнуть некоего частотного баланса между большим барабаном и бас-гитарой. Присутствие сигналов других инструментов в диапазоне частот ниже 300 Гц нежелательно: они будут мешать большому барабану и бас-гитаре, что приведет к неразборчивости ритмической и мелодической основы композиции. В начале ударного звука большого барабана обязательно должен присутствовать начальный щелчок. Щелчок занимает полосу от 1 кГц и выше. Этот щелчок также важен для ощущения ритма. Иногда этот щелчок стоит подчеркнуть.
Некоторым музыкантам постоянно "не хватает низов". Когда "болезнь" переходит в более тяжелую стадию, они начинают применять более радикальные меры — программными средствами генерируют сэмплы, содержащие очень низкие звуки (вплоть до инфразвука). Основное лекарство от этой болезни заключается в покупке нормальных мониторов (которые способны воспроизводить низкочастотные звуки). Второе средство — образование. Не углубляясь в подробности, скажем, что инфразвук и постоянная составляющая в сигнале — злейший враг звукозаписи, который загружает звуковые тракты и в то же время не воспроизводится ни одной акустической системой (а может даже и вывести ее из строя). При записи через звуковую карту инфразвуковые составляющие сигнала отсекаются фильтром. Мы провели эксперимент — импортировали в проект Cubase SX звуковой файл с синусоидальными инфразвуковыми колебаниями, сгенерированными программно (частота колебаний 10 Гц). При воспроизведении индикаторы уровня сигнала показывали присутствие сильного сигнала, но ничего, естественно, слышно не было. Затем мы экспортировали проект в звуковой файл и выполнили его анализ специальными программными средствами. Результаты эксперимента таковы: инфразвук беспрепятственно прошел сквозь Cubase SX. Этот факт имеет большое значение. В последнее время производится огромное количество VSTi и нельзя поручиться за то, что какие-то из них не генерируют инфразвуковых сигналов. Вам придется самостоятельно выявлять инфразвук и бороться с ним с помощью фильтров.
Вообще современные синтезаторы и сэмплеры (как программные, так и аппаратные) обладают широкими возможностями в плане корректировки тембра. Поэтому в первую очередь следует пытаться достигнуть частотного баланса композиции за счет подбора тембров.
Эквализацию вокала лучше вообще не делать, т. к. любая обработка человеческого голоса заметна очень сильно. Необходимость в корректировке вокала отпадет сама собою, если использовать качественный звукозаписывающий тракт (конденсаторный микрофон, хороший микрофонный предусилитель, качественный АЦП). Единственное, что может понадобиться, — обработка вокала фильтром верхних частот, чтобы отсечь низкочастотные компоненты сигнала (ниже 300 Гц). Все равно они не несут никакой полезной информации и только делают звук мутным.
Эквалайзер можно использовать и в качестве эффекта. Например, если требуется передать, что до источника звука очень большое расстояние, соответствующий трек можно обработать эквалайзером так, чтобы подавить высокочастотные и низкочастотные компоненты. Вспомните ситуацию, когда вы стоите на дороге, а мимо вас проезжает одиночная машина. По мере ее удаления со звуком мотора происходят такие вещи, словно невидимый звукорежиссер крутит на микшере ручки трехполосного эквалайзера. От шума машины остаются только средние частоты. Высокочастотные колебания поглощаются воздухом и окружающими предметами, низкочастотные безвозвратно рассеиваются во всех направлениях (в том числе уходят под землю) и до вас доходит лишь малая их часть. Средние частоты тоже поглощаются и рассеиваются, но не так интенсивно.


14.1.2. Панорамирование

В центр помещается основной вокал и партии всех инструментов, обладающих низкочастотным тембром (большой барабан, бас-гитара). Человеческий слуховой аппарат не в состоянии определить направление на источник низкочастотного сигнала. По этой причине низкочастотные сигналы равномерно распределяются между стереоканалами (располагаются в центре панорамы). Все остальные инструменты и бэк-вокал можно панорамировать как угодно. Тем не менее, следует придерживаться здравого смысла. В реальной жизни не существует такой ситуации, при которой здоровый человек воспринимал бы звуковой сигнал от удаленного источника только одним ухом.
А помещение источника в крайнюю точку стереопанорамы как раз соответствует такой ситуации.
Как бы вы не панорамировали инструменты, оба стереоканала должны быть загружены примерно одинаково. Если вы помещаете какой-то инструмент в левую часть панорамы, значит, должны поместить что-то и в правую часть панорамы, чтобы сбалансировать стереокартину.
Размещение всех инструментов около центра панорамы также можно считать грубой ошибкой. Фактически переходя к монофоническому формату, вы сами себе осложняете жизнь. Вам будет очень сложно добиться разборчивости отдельных партий, если все они размещены в одной точке.
Кстати, о моно. Как бы вы не разбрасывали инструменты по стереопанора-ме, моносовместимость при этом никак не пострадает. Проблемы с моносовместимостью могут появиться только вследствие применения эффектов, воздействующих на фазу сигнала в стереоканалах. К таким эффектам относятся всевозможные расширители стереобазы. Еще одной причиной мононесовместимости может стать применение очень коротких задержек, сопоставимых с периодом одного звукового колебания.
Регуляторы панорамы и фейдеры громкости — это еще не все инструменты, влияющие на формирование акустической картины. С их помощью можно задавать направление на источник звука и расстояние до него (чем слабее сигнал, тем дальше источник). Однако равноудаленные от слушателя источники изначально могут иметь разные громкости.


14.1.3. Применение эффектов

Наиболее часто применяемый эффект — реверберация. Благодаря наличию реверберации у слушателя возникает ощущение реалистичности звуковой картины. Ведь в реальном мире реверберация присутствует в любой среде, где может распространяться звук. Уровень реверберации следует подбирать осторожно. Если немного переборщить, то никакой реалистичности не останется.
Реверберация — это еще один инструмент, позволяющий передавать расстояние до кажущегося источника звука. Если реверберация очень слабая — значит, кажущийся источник не громкий, но располагается очень близко от слушателя. Если уровень реверберации сопоставим с уровнем прямого сигнала от источника, значит источник сильный и располагается на значительном удалении от слушателя.
Реверберацию следует применять в качестве эффекта параллельного действия (в режиме посыла), поскольку на одном участке композиции тип реверберации должен быть общим для разных треков. Ведь не может же быть такого, что расположенные в одном помещении инструменты вызывают разную реверберацию.
Родственный реверберации эффект — задержка — может применяться не только в качестве эха, но и в качестве специального эффекта. Используя однократную очень короткую задержку (около 20 мс) можно получить очень интересный результат, если переместить трек в одну крайнюю точку панорамы, а сигнал с выхода задержки — в противоположную крайнюю точку панорамы. Причем уровни необработанного задержкой и задержанного сигнала следует сделать примерно одинаковыми. В результате у слушателя возникнет комбинация сразу нескольких ощущений. Источник звука будет казаться растянутым на всю ширину стереопанорамы. И одновременно с этим будет казаться, что звук приходит со стороны незадержанного сигнала.
Не следует применять эффекты, основанные на задержке (включая реверберацию), к большому барабану и бас-гитаре. Применение эффектов к источникам низкочастотных сигналов — это уже спецэффект, который можно использовать иногда, но не на протяжении всей композиции.
Вообще любые эффекты нужно применять небольшими порциями. Ведь назначение любого эффекта — привлечь внимание слушателя к каким-то определенным звукам. А если вся ваша композиция будет состоять только из эффектов, то ничего хорошего из этого не выйдет.


14.2. Общие принципы сведения в 5.1

Формат 5.1 следует считать не альтернативой формату стерео, а его развитием. Поэтому большая часть рекомендаций, относящихся к вопросам сведения в стерео, годится и для формата 5.1. Некоторые особенности сведения в круговую панораму мы описали в разд. 1.12.4.
Свести многотрековый проект в стерео проще, чем в моно. В распоряжении звукорежиссера по сравнению с монофоническим форматом имеется дополнительное измерение, в котором можно размещать звуковые источники. Проще добиться прозрачности композиции, поскольку источники можно разместить на стереопанораме так, чтобы они не мешали друг другу. Однако вместе с появлением стерео появился дополнительный критерий оценки качества фонограммы — стереофоничность. Это свойство характеризует степень, в которой звукорежиссеру удалось реализовать возможности сте-реоформата для воплощения идеи композиции. С одной стороны сводить в стерео проще, чем в моно, а с другой стороны, звукорежиссер обязан выкладываться, чтобы максимально задействовать возможности формата.
Когда появился формат 5.1, стало еще проще. На круговой панораме инструментам стало еще просторнее, и можно сделать так, что они совсем не будут мешать друг другу. Однако вместе с новыми возможностями звукорежиссер получает дополнительные негласные обязанности. Он обязан использовать все средства, появление которых обусловлено переходом к новому формату.
Следует учитывать, что в отличие от стереосистемы, каналы системы 5.1 не являются равноценными в плане информативности. Они по-разному расположены относительно слушателя. На фронтальные каналы ложится основная информационная нагрузка. А тыловые каналы следует считать вспомогательными, поскольку человек в принципе плохо воспринимает информацию, поступающую сзади (воспринимает ее "периферийным" слухом). Основное назначение тыловых каналов — создание общей акустической атмосферы, эффекта присутствия. Канал низкочастотных эффектов предназначен для передачи сигналов, занимающих полосу частот от 20 до 80 Гц. Понятно, что в такой узкой полосе частот в принципе невозможно передать много звуковой информации.
Итак, как осуществлять панорамирование? Как и в случае стерео, при панорамировании в 5.1 в центр помещается основной вокал и партии всех инструментов, обладающих низкочастотным тембром. Для формирования звукового образа в центре можно использовать непосредственно центральный канал (это является предпочтительным) или каналы L и R. В последнем случае образ посередине панорамы будет фантомным (как в стерео). В случае необходимости можно задействовать все три канала L, С и R для усиления образов на фронтальной части панорамы. Однако ситуация, когда в нескольких каналах присутствует один и тот же сигнал, является нежелательной. Ведь неизвестна конфигурация акустической системы у слушателя и неизвестно его расположение относительно этой системы. Возможно возникновение неприятных эффектов, связанных с интерференцией звуковых волн. Не исключен конфликт фантомного образа, создаваемого каналами L и R в центре панорамы с образом, формируемым центральным каналом.
Итак, все, что должно располагаться в центре, желательно воспроизводить через центральный канал. Пары каналов L-C и C-R следует использовать для формирования образов, расположенных не в самом центре, а на фронтальной части панорамы.
Тыловые каналы можно использовать для второстепенных партий, которые не несут основную информационную нагрузку: подклады (pads), шумы, реверберация/эхо от источников, размещенных во фронтальной части панорамы, кратковременные эффекты, допускающие отвлечение внимания слушателя от фронтальной части панорамы.
Естественно, не должно быть никакой резкой границы между фронтальной и тыловой частью круговой панорамы. Информационная нагрузка композиции должна быть плавно смещена во фронтальную часть панорамы. Равномерная информационная загрузка всех каналов (как в стерео) нежелательна. Иначе у слушателя может возникнуть ощущение, что он слушает оркестр не со стороны, а изнутри.
Конечно, никаких существенных ограничений на использование различных каналов системы 5.1 в поп-музыке быть не может. Время все расставит на свои места. Поживем — увидим, какие рекомендации будут выработаны мировой звукорежиссурой лет через 5.
В канал LFE можно направить сигнал инструментов, обладающих низкочастотным тембром (большой барабан, бас-гитара). Когда средствами Cubase SX вы направляете сигнал с трека в канал LFE, не происходит никакой его обработки. То есть сигнал, подаваемый в канал LFE, может занимать полосу частот от 20 Гц до 20 кГц и выше (в зависимости от формата звуковых данных). Это не очень хорошо. Поэтому мы рекомендуем средствами окна VST Master Effects (см. разд. 5.6.3) подключить к каналу LFE VST-плагин монофонического фильтра нижних частот (рис. 14.1). Такой плагин, например, имеется в пакете Waves Gold (http://www.waves.com). Фильтр нижних частот следует настроить так, чтобы он подавлял компоненты сигнала, частота которых выше 80 Гц. Кстати, заодно можно защитить канал LFE и от возможных инфразвуковых составляющих, для чего следует настроить плагин на работу в качестве полосового фильтра, пропускающего частоты от 20 Гц до 80 Гц.

Рис. 14.1. Подключение ФНЧ к каналу LFE

Остальные каналы L, С, R, Ls и Rs можно обработать фильтром верхних частот. Тем самым вы разгрузите перечисленные каналы от низкочастотных составляющих сигналов, которые в принципе не могут воспроизводиться акустической системой, но занимают определенные ресурсы. Интересен вопрос совместимости многоканальной фонограммы с форматом стерео. Ведь слушатель в любой момент может переключить свою систему в режим стерео. Зачем это нужно? Например, для того, чтобы послушать DVD-Audio в машине. Что при этом произойдет? Это зависит от алгоритма mixdown кодека (mixdown — микширование для уменьшения количества каналов). Обычно канал С подмешивается к каналам L и R с понижением уровня. Каналы Ls и Rs тоже подмешиваются к каналам L и R соответственно. Канал LFE может быть подмешан к каналам L и R, а может быть отброшен. Подмешивание может происходить без всякой дополнительной обработки. Для нас это проще, так как в данном случае мы можем проконтролировать совместимость фонограммы 5.1 со стерео с помощью специального VST-плагина Mix6to2 (рис. 14.2). Данный плагин подключается к мастер-секции микшера Cubase SX для реализации mixdown 6 каналов в 2.

Рис. 14.2. Окно плагина Mix6to2

Сам по себе Mix6to2 представляет собою простой микшер. Однако вы можете не тратить время на его настройку, т. к. присутствуют все необходимые пресеты, для реализации mixdown каналов различных систем объемного звучания в стерео.
Однако плеер конечного слушателя может выполнять mixdown 5.1 в стерео с применением специальной обработки, после которой, как предполагается, объемность звуковой картины будет сохранена. Достигается это путем изменения фазы каналов Ls и Rs. Что с конкретной фонограммой получится в результате — остается только гадать.


14.3. Работа с видео

Cubase SX можно использовать для создания звукового трека к фильму. При этом можно использовать студийный видеомагнитофон, синхронизированный с Cubase SX по временному коду (см. разд. 2.9) или импортировать видеофайл непосредственно в проект. Cubase SX может выступать в роли плеера видеофайлов, что позволяет подгонять звук и музыку под видеоизображение. Для воспроизведения видео может использоваться один из трех API: DirectShow, QuickTime, Video for Windows. Если установлена плата ввода/вывода видео и соответствующие драйверы, то воспроизведение видеоданных может осуществляться на аппаратном уровне с выводом видеосигнала на отдельный видеомонитор.
Если же у вас нет никакого специального оборудования, видео может воспроизводиться программно, в одном из окон Cubase SX. Однако любые операции с видео, даже простое воспроизведение, создают ощутимую нагрузку на процессор.
Результатом работы над звуковой дорожкой, в конечном счете, будет звуковой файл, который нужно будет объединять с видео с помощью видеоредактора или другого специального программного обеспечения. Поэтому качество, с которым видео будет воспроизводиться в Cubase SX, не имеет особого значения. Главное, чтобы вы. могли ориентироваться в видеофильме. Специально для работы в Cubase SX вы можете создать версию видеофайла с низкой разрешающей способностью видеоизображения и, как следствие, не создающего существенной нагрузки на процессор при воспроизведении.
Импорт видео в проект осуществляется командой File > Import > Video File или средствами окна Pool (см. разд. 12.4). После импорта видеофайла в проект автоматически будет создан видеотрек, на котором будет размещено импортированное видеосообщение (рис. 14.3). При импорте видеофайлы никогда не копируются в каталог проекта. В проекте на эти файлы сохраняется лишь ссылка. Если видеофайл содержит звуковую дорожку, то она будет импортирована в проект в виде звукового сообщения, размещенного на аудиотреке.

Рис. 14.3. Видеотрек содержит видеосообщение

Видеосообщение представляет собой поименованный объект, содержащий ссылку на видеофайл. Вы можете выполнять минимальный набор действий над видеосообщениями (перемещать, разрезать, удалять, изменять атрибуты, которых очень немного). На видеотреке может располагаться несколько видеосообщений. В проекте может быть всего один видеотрек. При записи/воспроизведении проекта видео будет воспроизводиться в отдельном окне (рис. 14.4), которое вызывается командой главного меню Devices > Video или клавишей <F8>.
Для того чтобы настроить параметры вывода видеоизображения, доступные в Cubase SX, в списке Devices окна Device Setup, вызываемого командой Devices > Device Setup, выберите Video Player (рис. 14.5). В правой части окна будут доступны следующие параметры:

  • Playback Method — способ воспроизведения (DirectShow Video, QuickTime, Video for Windows);
  • Video Window — размер окна, в котором будет выводиться видеоизображение (Big Size — размер окна будет соответствовать разрешающей способности видеоизображения, Small Size — четверть площади исходного видеоизображения, Tiny Size — совсем маленькая картинка).

Рис. 14.4. Окно, в котором воспроизводится видео

Рис. 14.5. Параметры вывода видео

Опции отображения видеосообщений доступны в секции Event Display > Video окна Preferences, вызываемого командой главного меню File Preferences (рис. 14.6).

Рис. 14.6. Опции отображения видеосообщений

Вернее, опция фактически одна: Show Video Thumbnails — отображать маленькие картинки из видеоизображения вдоль видеосообщения. В поле Video Cache Size задается размер буфера, выделенного для этой цели. Если прорисовка картинок будет занимать слишком много времени, можно попытаться увеличить размер буфера.
Подведем итог. Вы можете импортировать видео в Cubase SX, создавать звуковую дорожку под это видео и экспортировать ее в виде звукового файла.


14.4. Экспорт сведенной композиции

Какие бы вы задачи не решали с помощью Cubase SX, командой, завершающей работу над проектом, будет команда главного меню File > Export > MIDI File или File > Export > Audio Mixdown. Первая команда производит экспорт MIDI-информации из проекта. При этом, естественно, теряются все аудиосообщения, аудиоэффекты реального времени, автоматизация. Но и эта команда может быть полезной в том случае, если вы использовали Cubase SX исключительно в качестве MIDI-секвенсора. Вторая команда вам понадобится, если вы использовали Cubase SX по основному назначению — в качестве виртуальной звуковой студии. В конечном счете, вы захотите превратить свой проект в готовый продукт и довести его до слушателя.
В самом начале главы мы предупреждали вас о необходимости переноса партий MIDI-инструментов (не VSTi) на аудиотреки. Во-первых, выполнять сведение в MIDI не совсем правильно, хотя бы из-за того, что вы не сможете применять пространственное панорамирование и обработку VST-плагинами. Во-вторых, экспортировать можно или MIDI-, или аудиоинформацию. Соответственно, если вы хотите получить из своего проекта трек для записи на CD Digital Audio, то вся информация проекта должна быть представлена в виде аудиотреков и/или MIDI-треков, управляющих VSTi.
Прежде чем воспользоваться командой File > Export > Audio Mixdown, следует выделить экспортируемый фрагмент проекта с помощью левого и правого локаторов.
С термином mixdown мы недавно встречались. В данном случае он имеет такой же смысл — микширование неограниченного числа треков в одну фонограмму, количество каналов которой будет соответствовать используемому формату (стерео — 2 канала, 5.1 — шесть каналов). В данном случае экспорт означает вывод аудиоинформации не через выходные порты (VST Outputs, см. разд. 2.6), а в один или несколько звуковых файлов. Причем Cubase SX производит расчет экспортируемой информации не в режиме реального времени. То есть вы можете задействовать в своем проекте сколько угодно VST-плагинов и сколько угодно аудиотреков. Ваша система может не справляться с воспроизведением такого проекта. Однако экспорт такого "перегруженного" проекта в звуковой файл пройдет без сучка и задоринки.
Итак, командой File > Export > Audio Mixdown открывается диалоговое окно Export Audio Mixdown, показанное на рис. 14.7.
Нужно выбрать папку, куда следует экспортировать звуковой файл. В поле File Name вводится имя файла, в списке Files of type выбирается тип звукового файла. По умолчанию выбран тип "Wave File (.wav)", но доступны еще несколько типов, включая mрЗ.
В списке Coding выбирается способ кодирования звуковой информации в файле из тех способов, что доступны для данного типа файлов.
Для типа "Wave File (.wav)" доступен единственный способ кодирования "PCM/uncompressed Waves". В результате получится WAV-файл без применения какого-либо сжатия.
Вид остальной части окна Export Audio Mixdown зависит от того, какой тип звукового файла был выбран. Мы рассмотрим только случай экспорта проекта в обычный WAV-файл.
В списке Channels следует выбрать вариант сохранения информации, принадлежащей разным каналам. Приведем опции, доступные для форматов стерео и 5.1:

  • Mono — свести все каналы в моно;
  • Stereo Split — сохранить стереоканалы в виде двух монофонических файлов;
  • Stereo Interleaved — сохранить стереоканалы в виде одного стереофонического файла;
  • 6 Chan. Split — сохранить каналы 5.1 в виде шести монофонических файлов;
  • 6 Chan. Interleaved — сохранить каналы системы 5.1 в виде одного шестиканального файла.

Рис. 14.7. Окно Export Audio Mixdown

Формат WAV-файлов допускает хранение большого количества каналов (больше двух), однако многоканальные WAV-файлы поддерживаются далеко не всеми программами. Поэтому в большинстве случаев звук формата 5.1 целесообразно экспортировать в шесть отдельных монофонических файлов. В названиях этих файлов будут содержаться номера. Нумерация файлов будет соответствовать порядку расположения каналов системы 5.1 в мастер-секции микшера Cubase SX. Чтобы в дальнейшем не запутаться, сразу после экспорта имеет смысл дополнить названия этих файлов буквами, обозначающими каналы системы 5.1 (L, R, Ls, Rs, С, LFE).
В списке Resolution выбирается количество двоичных разрядов, используемых для представления звуковых отсчетов. Что следует в этом списке выбирать? Если вы предполагаете осуществлять мастеринг средствами специализированных программ (например, таких как T-RackS 2, то выбирать нужно такую форму представления звуковых данных, которая поддерживается приложением для мастеринга. Во всяком случае, количество разрядов должно быть более 16.
Не исключен вариант, что мастеринг уже фактически выполнен в среде Cubase SX. Для этой цели существуют специальные плагины, которые следует подключать к мастер-секции микшера, например, iZotope Ozone 2 (http://www.izotope.com). В этом случае количество разрядов должно соответствовать конечному носителю фонограммы. Например, 16 для CD Digital Audio и от 16 до 24 для DVD-Audio.
В списке Sample Rate задается частота сэмплирования для экспортируемых файлов. Мы настоятельно рекомендуем оставить этот параметр таким, чтобы он соответствовал частоте сэмплирования, принятой для данного проекта. В случае необходимости конвертировать формат файла лучше с помощью специализированного звукового редактора, например, Cool Edit Pro 2 ).
В группе Include доступны следующие опции:

  • Automation — учитывать при экспорте автоматизацию;
  • Effects — учитывать при экспорте обработки и эффекты.

При экспорте сведенного проекта эти опции следует включить, иначе вся ваша работа по сведению просто окажется бессмысленной!
В группе Import доступны следующие опции, позволяющие импортировать полученные в результате экспорта файлы в проект:

  • Pool — импортировать в пул, но не размещать на аудиотреке;
  • Audio Track — импортировать с размещением на аудиотреке.

Опции групп Include и Import полезны в том случае, если вы хотите осуществить внутреннее переведение: перебросить несколько звуковых сообщений или партий VSTi в один новый звуковой файл.
Если все готово, можно нажимать кнопку Save. Экспорт проекта, состоящего из нескольких треков и длительностью в несколько минут, займет ощутимый промежуток времени. При этом в виде файлов будет сохранена вся информация, которая выводится через выходные аудиопорты при воспроизведении выделенного локаторами фрагмента проекта. Если какие-то треки или отдельные аудиосообщения отключены (Disable) или замьютированы (Mute), то в сохраненном миксе они присутствовать не будут.
Может возникнуть вопрос: понятно, что делать со стереофоническими WAV-файлами (их можно записать на CD Digital Audio) или с файлами трЗ (их можно опубликовать в Internet), но что делать с шестью файлами, соответствующими каналам системы 5.1? Возможные варианты:

  • с помощью специального программного обеспечения их можно преобразовать в формат АСЗ (Dolby ® Digital) и опубликовать в Internet, на CD-ROM или в качестве звуковой дорожки к фильму на DVD;
  • с помощью специального программного обеспечения их можно преобразовать в двухканальный WAV-файл, содержащий сигнал, закодированный в формате Dolby ® Pro Logic, и записать его в качестве трека на обыкновенный CD Digital Audio;
  • с помощью программного обеспечения, поставляемого вместе с приводом DVD-R, их можно записать на DVD-Audio.

Как видите, в любом случае требуется специальное программное обеспечение, описание которого выходит за рамки данной книги. Однако если уж вы научились работать с Cubase SX, то освоить это "специальное программное обеспечение" сможете и подавно. Программа Sonic Foundry Soft Encode (http://www.sonicfoundry.com)позволяет группу отдельных монофонических WAV-файлов кодировать в АСЗ-файлы. Вы последовательно импортируете монофонические WAV-файлы и указываете, каким каналам системы 5.1 они соответствуют. В случае необходимости настраиваете опции и командой File > Save As сохраняете АСЗ-файл.

Конечно, даже в этой относительно простой программе существует какое-то количество опций и сервисных функций. Но нет такого программного средства, которое не мог бы освоить человек. Ведь созданы эти средства людьми и для людей.


VST System Link — организация работы студийных компьютеров в сети

Cubase SX поддерживает межплатформенную технологию VST System Link, предназначенную для объединения вычислительных ресурсов двух и более компьютеров. Задействованные в проекте компьютеры могут принадлежать как к платформе PC, так и к платформе Apple Macintosh. Главное, чтобы на этих компьютерах были установлены программные продукты, поддерживающие технологию VST System Link. На наш взгляд, данная технология, безусловно, заслуживает особого внимания. Однако она не позволяет повысить вычислительную мощность виртуальной студии без заметных финансовых затрат по нескольким причинам.
Причина 1. При организации такой компьютерной сети в качестве информационной среды могут использоваться только цифровые интерфейсы для передачи звука: S/PDIF, ADAT, TDIF или AES. Соответственно, на каждом из компьютеров в сети VST System Link должна присутствовать профессиональная звуковая карта или адаптер с цифровым интерфейсом (желательно многоканальным) и поддержкой ASIO.
Причина 2. Вам придется приобрести столько экземпляров программного обеспечения, поддерживающего технологию VST System Link, сколько компьютеров будет задействовано в сети. Допустим, на одном из компьютеров сети установлен Cubase SX. Для каждого следующего компьютера нужно дополнительно приобрести по экземпляру или Cubase SX, или другого продукта фирмы Steinberg, поддерживающего VST System Link. Видимо, разработчики понимают, что такое решение является слишком дорогим, и поэтому выпустили продукт под названием V-Stack, который по своей сути является стеком для подключения VST-плагинов (включая VSTi) и DX-плагинов. На одном компьютере сети VST System Link вы устанавливаете Cubase SX, а на остальных — по экземпляру V-Stack. В результате вычислительная мощность системы возрастает, a V-Stack стоит гораздо дешевле Cubase SX.
Причина 3. Накопление задержки. Существует задержка (latency) между поступлением команды виртуальному устройству (например, VSTi) и моментом ее фактического исполнения. Время задержки зависит от параметров аудиоинтерфейса (см. раздел 2.5), которые устанавливаются в соответствии с возможностями драйверов звуковой карты и вычислительной мощностью системы. При использовании VST System Link общая задержка виртуальной студии будет складываться из задержек, возникающих в аудиоинтерфейсах компьютеров, объединенных в сеть. Чем больше компьютеров в сети, тем больше задержка.
Поделимся своими мыслями на счет того, какой бы мы (пользователи Cubase SX) хотели видеть VST System Link. За счет применения "традиционных" для локальных вычислительных сетей (LAN) технологий (например, Fast Ethernet или Gigabit Ethernet) можно повысить пропускную способность каналов для обмена звуковыми данными и командной информацией, а также снизить стоимость сетевого оборудования. Продукт, аналогичный V-Stack, мог бы входить в комплект Cubase SX. Данное приложение могло бы функционировать по принципу плагина: принимать командную и звуковую информацию и возвращать звуковые данные в буфер приложения-хоста. Уже из буфера звуковые данные могли бы воспроизводиться на заданный выходной аудиопорт приложения-хоста. При таком подходе задержка в виртуальной студии не носила бы аддитивного характера. А возможность масштабирования мощности виртуальной студии с минимальными (для пользователя) затратами была бы действительно революционным шагом в развитии музыкального программного обеспечения. Мечтать не вредно, а пока что студия на базе VST System Link no своей стоимости сопоставима со студией, в которой применяются аппаратные синтезаторы и процессоры эффектов. Тогда зачем покупать дополнительно компьютер, профессиональную звуковую карту и программное обеспечение, если за эти деньги можно приобрести аппаратный синтезатор категории Hi-End и подключить его к имеющемуся компьютеру через цифровой интерфейс? Поэтому применять VST System Link имеет смысл в том случае, если в студии уже имеется несколько компьютеров с установленным программным обеспечением, поддерживающим VST System Link.
При использовании VST System Link следует помнить о том, что ваш проект является распределенным — состоит из нескольких проектов, размешенных на разных компьютерах. Файлы проектов могут иметь различный формат, но являются частью общего проекта. Поэтому следует заботиться о резервировании всех файлов, задействованных в едином проекте на разных компьютерах. Проекты, размещенные на разных компьютерах, должны иметь одинаковый формат представления звуковых данных и одинаковый темп.
Вам предстоит много перемещаться между компьютерами, объединенными посредством VST System Link. Чтобы не метаться от одного компьютера к другому, целесообразно использовать специальное устройство-коммутатор — KVM switch, позволяющее использовать один монитор, одну клавиатуру и мышь для управления несколькими компьютерами. Такие коммутаторы выпускаются фирмами: American Power Conversion Corp. (http://www.apc.com), Raritan Computer, Inc (http://www.raritan.com), D-Link Systems, Inc. (http://www.d-link.com) и многими другими. Одновременно вы можете работать только с одним компьютером. Выбор текущего компьютера осуществляется нажатием кнопки на KVM switch.
Давайте рассмотрим случай, когда в студии имеется два компьютера, оснащенных звуковыми картами с цифровым интерфейсом (например, S/PDIF). На обоих компьютерах установлен продукт Cubase SX. Объединим эти компьютеры в сеть с помощью VST System Link.
С помощью соответствующего кабеля цифровой выход первого компьютера (S/PDIF Out) соединим с цифровым входом другого компьютера (S/PDIF In). И, наоборот, цифровой выход второго компьютера соединим с цифровым входом первого компьютера. Микшеры звуковых карт должны быть настроены таким образом, чтобы сигнал с цифрового входа не транслировался на цифровой выход.
Для передачи служебной информации в VST System Link по умолчанию используются младшие биты слов звуковых данных. Например, если интерфейс S/PDIFF является 24-битным, то для передачи звуковых данных будет использоваться только 23 бита. Один бит будет задействован для служебных целей (передача управляющей информации, MIDI, временного кода и т. д.). Потеря одного бита при исходном 24-битном разрешении — это не страшно и практически не заметно на слух. Другое дело, если интерфейс 16-битный. Вспомните, как сильно отличается качество 8-битного звука от 16-битного. А 16-битный звук от 24-битного сможет отличить уже далеко не каждый. Поэтому потеря одного бита при исходном 16-битном разрешении существенна. Разрешение в 15 бит — это уже маловато.
Необходимым условием для нормального функционирования VST System Link является установление устойчивой двухсторонней связи между компьютерами. То есть на этапе установления связи можно забыть о существовании VST System Link и воспринимать компьютеры как некие цифровые устройства, которые следует корректно соединить друг с другом через цифровой интерфейс. Все процедуры, описанные ниже, следует проделать на обоих компьютерах.
Командой главного меню Devices > VST Inputs (<F5>) откройте окно конфигурирования входных аудиопортов виртуальной студии (см. разд. 2.6). Включите порт, соответствующий интерфейсу S/PDIF In (рис. 15.1).
Командой VST Outputs (<F4>) откройте окно конфигурирования выходных аудиопортов (см. разд. 2.6). Включите порт, соответствующий интерфейсу S/PDIF Out (рис. 15.2).

Рис. 15.1. Окно VST Inputs, задействованы порты S/PDIF In

Рис. 15.2. Окно VST Outputs, задействована ниша, соответствующая портам S/PDIF Out

Командой главного меню Devices > Device Setup... откройте окно Device Setup, в списке Devices данного окна выберите секцию VST Multitrack, вкладку Setup (рис. 15.3).

Рис. 15.3. Окно Device Setup, секция VST Multitrack, вкладка Setup

Один из компьютеров должен являться источником синхросигнала, а другой должен использовать этот сигнал для синхронизации с первым. В списке Clock Source выбирается источник синхронизации:
  • Internal — внутренний (от генератора звуковой карты);
  • External — внешний (от синхросигнала, получаемого через цифровой порт);
  • See Control Panel — в зависимости от настроек панели управления звуковой картой.
Если в списке Clock Source доступен элемент See Control Panel, то следует воспользоваться кнопкой Control Panel, чтобы вызвать панель управления звуковой карты.
На рис. 15.4, а показана вкладка Hardware Settings панели управления звуковой картой M-Audio Audiophile 2496. В данном случае в группе Master Clock выбрана опция Internal Xtal, что означает использование внутреннего тактового генератора. Этот компьютер будет являться источником сигналов синхронизации. На другом компьютере на аналогичной панели следует выбрать опцию S/PDIF In (15.4, б), что означает синхронизацию по сигналу, поступающему через порт S/PDIF In. Под опцией S/PDIF In расположено информационное поле. Если в нем отображается Locked, это значит, что синхронизация аудиоинтерфейсов звуковых карт достигнута.

Рис. 15.4. Панель управления звуковой картой M-Audio Audiophiie 2496

Имеет смысл провести тест: воспроизводить в цикле сэмпл на одном компьютере и добиваться того, чтобы соответствующий сигнал попадал на другой компьютер и наоборот.

Рис. 15.5. Окно Device Setup, секция VST System Link

Теперь опять вернемся к вкладке Setup секции VST System Link окна Device Setup, но на этот раз в списке Devices выберем VST System Link (рис. 15.5).
В списке ASIO Input следует выбрать входной порт, соответствующий цифровому интерфейсу, с помощью которого связаны компьютеры. В списке ASIO Out выберите выходной порт цифрового интерфейса, задействованного под VST System Link.
Включите опцию Active, активирующую VST System Link. Если все в порядке, то в нижней части окна отобразится перечень компьютеров, готовых к совместной работе. В терминологии Cubase SX они называются устройствами (Device). Название конкретного устройства в сети формируется из сокращенного названия операционной системы (например, Win) и названия продукта, поддерживающего VST System Link. При желании имена устройств в сети можно изменить.
Теперь можно включить опцию Online — работа в режиме VST System Link. Эту же процедуру следует проделать и на другом компьютере. При обмене данными между компьютерами будут мигать индикаторы R (Receive — прием) и Т (Transmit — передача).
Первое, что бросается в глаза, — в режиме VST System Link будут синхронизированы транспорты приложений. Оба проекта будут воспроизводиться синхронно. Если вы заглянете в окно Synchronization Setup (см. разд. 2.9), то увидите, что в группе Time Code Source будет автоматически выбрана опция VST System Link.
Вы можете разместить часть аудиотреков общего проекта на одном компьютере, а часть на другом. В редких случаях за счет особенностей оборудования может проявиться смещение аудиоматериала на разных компьютерах: треки одного компьютера воспроизводятся чуть раньше или чуть позже, чем на другом. В этом случае полной синхронизации можно добиться настройкой параметра Offset.
Вы можете разместить часть VSTi общего проекта на одном компьютере, а часть на другом. Управлять ими можно с любого из компьютеров. Рассмотрим самую сложную ситуацию, когда MIDI-трек располагается на одном компьютере, а управляемый им VSTi — на другом. Виртуальные MIDI-порты для связи компьютеров организуются в рамках VST System Link. В полях Ins и Outs группы MIDI (см. рис. 15.5) следует задать нужное для вас количество виртуальных MIDI-портов (не более 16). На управляющем MIDI-треке одного компьютера в качестве выходного порта выберите любой свободный порт VST System Link. Эти порты так и называются System Link 1, System Link 2 и т. д. Что значит "свободный" порт? Учет того, какие виртуальные MIDI-порты System Link используются, а какие нет, вы должны вести самостоятельно.
На другом компьютере подключите к проекту нужный VSTi, создайте MIDI-трек и настройте его на работу с этим VSTi. В качестве входного MIDI-порта выберите System Link с тем же номером, который был выбран на первом компьютере в качестве выходного порта управляющего MIDI-трека. Что теперь будет происходить? MIDI-данные, воспроизводимые с управляющего MIDI-трека, размещенного на первом компьютере, будут передаваться на входной порт MIDI-трека, размещенного на втором компьютере. При условии, что включен режим MIDI Thru и режим мониторинга (а по умолчанию эти режимы включены), MIDI-данные со входного порта MIDI-трека на втором компьютере будут транслироваться на его выходной порт, в качестве которого выбран VSTi. В результате получится, что VSTi, подключенный к проекту на втором компьютере, будет управляться MIDI-треком с первого компьютера. О MIDI Thru, режиме мониторинга и о подключении VSTi мы рассказали в разд. 4.1.1, 4.1.2, 4.1.3.
Вы уже, вероятно, поняли, что технология VST System Link используется для синхронизации транспортов проектов, размещенных на разных компьютерах, синхронизации звуковых потоков и обмена MIDI-данными между приложениями, поддерживающими данную технологию. Возникают вопросы: как распределить нагрузку, связанную с использованием VST-и DirectX-плагинов для обработки аудиотреков и VSTi, как осуществлять сведение проектов, разнесенных по разным компьютерам?
Как мы уже говорили, вы можете разнести аудиотреки и VSTi по разным компьютерам. Ничто не мешает использовать плагины для их обработки. Если аудиотрек находится на одном компьютере, то и плагин для его обработки следует подключать на этом же компьютере. Если вы хотите разместить аудиотрек на одном компьютере, а плагин для его обработки на другом — ситуация резко усложняется. Сигнал с аудиотрека или VSTi, размещенного на одном компьютере, следует передавать на другой компьютер посредством цифрового интерфейса (например, S/PDIF), транслировать через "фиктивный" аудиотрек (не содержащий звуковых данных), созданный на втором компьютере в режиме ASIO Direct Monitoring (см. разд. 2.7). К этому аудио-треку и следует подключать эффекты последовательного действия или делать с него посылы на эффекты параллельного действия. Аналогичным образом можно осуществлять сведение треков, размещенных на разных компьютерах, средствами одного из этих компьютеров. Это неудобно хотя бы потому, что для каждого трека или группы треков нужно иметь по независимому порту цифрового интерфейса.
Для домашней студии с ограниченным бюджетом мы предлагаем следующее решение проблемы сведения. Есть два компьютера, условно назовем их А и В. Нагрузка между этими компьютерами распределяется или равномерно, или по принципу — на одном компьютере только аудиотреки и плагины для их обработки, на другом компьютере только MIDI-треки, VSTi и плагины для их обработки. Сведение осуществляется поэтапно — сначала сводятся тре-ки/VSTi, размещенные на одном компьютере, потом — на другом компьютере. Контрольные мониторы подключены к компьютеру А. Для всех треков/VSTi компьютера В в качестве выходного порта выбирается шина, соответствующая цифровому интерфейсу, по которому данные из компьютера В передаются в компьютер А. Для этого можно использовать тот же интерфейс, который задействован для организации System Link. Естественно, разрешающая способность звуковых данных будет уже на один бит меньше. Таким образом, воспроизведение проекта компьютера В будет осуществляться на контрольные мониторы, подключенные к компьютеру А.
Есть определенная выгода от использования внешнего аппаратного микшера. Вы подключаете линейные выходы звуковых карт обоих компьютеров к аппаратному микшеру, к нему же подключаются контрольные мониторы. Тогда цифровой интерфейс между компьютерами можно задействовать исключительно для обмена управляющей данными, передаваемыми по протоколу System Link. Для этого следует включить опцию Active ASIO Ports for Data only (рис. 5.15). Передача аудиоданных через порты, задействованные под System Link, станет невозможной, зато для данных System Link будет отведена вся пропускная способность цифрового интерфейса. Это позволит избежать сбоев при передаче MIDI-данных и сигналов синхронизации.
Если вы собираетесь работать в формате 5.1, то задача усложняется. Вам потребуется или внешний микшер, поддерживающий данный формат, или многоканальные звуковые карты с количеством каналов цифрового интерфейса не менее 6.
Как вы уже поняли, все компьютеры в сети System Link на уровне приложений являются равноправными. Среди них нет ни ведомых, ни ведущих. В принципе, вы можете объединить в сеть System Link сколько угодно компьютеров. Архитектуру такой сети можно назвать кольцом: выход первого компьютера соединяется со входом второго, выход второго — со входом третьего и т. д., выход последнего — со входом первого. Все компьютеры в таком кольце будут синхронизированы и объединены в нечто целое. Вы можете использовать один из компьютеров для сведения. В этом случае все дополнительные выходы всех остальных компьютеров должны соединяться со входами этого компьютера-микшера. А вообще вы можете как угодно коммутировать дополнительные входы и выходы компьютеров между собою. Внешний аппаратный микшер также не будет лишним.
Единственная неприятность — сети типа кольца в принципе очень уязвимы. Если выйдет из строя хотя бы один компьютер, или собьются его настройки, то "рухнет" (down) вся сеть. В этом случае может оказаться полезной опция Self Test (рис. 15.5). Соединяете цифровой выход тестируемого компьютера с цифровом входом этого же компьютера и включаете Self Test. Если тестирование прошло удачно, значит, данный компьютер не является источником проблемы. Не стоит также забывать, что проблемы могут создавать не только пользователи, программы и компьютеры, но и соединительные кабели. Кабели — это как раз то, на чем не стоит экономить.


Глава 16. Обзор команд главного меню

    • Обзор команд главного меню
    • 16.1. File — работа с файлами
    • 16.2. Edit — редактирование
    • 16.3. Project — работа с проектом
    • 16.4. Audio — работа с цифровым звуком
    • 16.5. MIDI- работа с MIDI
    • 16.6. Scores — опции нотатора
    • 16.7. Pool— команды для работы с пулом
    • 16.8. Transport— управление воспроизведением, записью и синхронизацией
    • 16.9. Devices— конфигурирование устройств виртуальной студии
    • 16.10. Window — управление отображением
    • 16.11. Help — помощь и справочная информация


Обзор команд главного меню

Подавляющее большинство команд главного меню были рассмотрены в предыдущих главах книги. Данную главу следует расценивать как краткий справочник.


16.1. File — работа с файлами

В меню File сосредоточены команды и подменю, предназначенные для работы с файлами. Рассмотрим их назначение.
New Project (<Ctrl> + <N>) — создать новый проект (см. разд. 2.11).
Open... (<Ctrl> + <O>) — открыть существующий проект (файл с расширением CPR). Одновременно можно открыть несколько проектов. Но лишь один из них может быть активным. Активный проект обозначен красным индикатором в вершине левого угла окна Project. Именно к активному проекту применяются все действия, которые вы выполняете в процессе редактирования.
Close (<Ctrl> + <W>) — закрыть текущий проект. Текущим проектом является тот, окно которого находится в фокусе (обрамление окна выделено ярким цветом). Команда вызывает окно диалога, в котором вы должны выбрать, следует или не следует сохранять проект перед его закрытием. Если проекту не было еще присвоено имя, то откроется окно диалога, в котором вы сможете выбрать имя файла и путь к месту его хранения.
Save (<Ctrl> + <S>) — сохранить текущий проект в файле с прежним именем (и в прежней папке).
Save As... (<Ctrl> + <Shift> + <S>) — сохранить проект в файле с новым именем. В окне, открывающемся этой командой, можно указать имя сохраняемого файла и выбрать путь к месту его хранения.
Save Project to New Folder... — сохранить проект в новой папке.
Save as Template... — сохранить проект в качестве шаблона. В открывшемся окне следует ввести имя шаблона и нажать кнопку ОК, после этого шаблон будет доступен в окне New Project.
Revert — отменить изменения, внесенные в проект в процессе редактирования (вернуться к ранее сохраненному файлу проекта).
Page Setup... и Print... — открыть окна для выбора параметров страницы с нотной партитурой и режима ее печати на принтере. Команды доступны лишь в том случае, когда открыто окно нотатора (MIDI > Open Score Editor) и в меню Scores выбран страничный режим отображения (Page Mode).
Import — подменю, предназначенное для выбора импортируемого объекта. Возможны следующие варианты:

  • Audio File... — импортировать аудиофайл;
  • Audio CD... — импортировать один или несколько треков с CD Digital Audio;
  • Video File... — импортировать видеофайл;
  • Cubase Song, Cubase Arrangement, Cubase Part... — импортировать файлы с сонгами, аранжировками и частями — объектами, которыми оперировали предыдущие версии программы Cubase (начиная с версии 3.7). Следует учитывать, что импортирование данных из файлов перечисленных типов осуществляется с некоторыми потерями;
  • MIDI File... — импортировать стандартные MIDI-файлы типа 0 (все данные размещаются на одном треке) или типа 1 (данные размещаются на нескольких треках). »

Export — подменю, предназначенное для выбора экспортируемого объекта. Предусмотрены два варианта:

  • MIDI File... — MIDI-треки проекта экспортируются в стандартный MIDI-файл (командой открывается окно, предназначенное для выбора имени файла и папки);
  • Audio Mixdown... — экспорт проекта в один или несколько звуковых файлов (см. разд. 14.3).

Preferences... — команда открывает окно диалога Preferences, в котором доступны тонкие настройки Cubase SX и пользовательские предпочтения:

  • Audio — опции записи и импорта аудиоданных (см. разд. 4.4.3, подраздел "Режимы записи, циклическая запись, регионы аудиосообщений"):
    • Time Stretch Tool — параметры работы алгоритма Time Stretch (см. разд. 4.4.5, подраздел "Перемещение границ частей и аудиосообщений, алгоритм Time Stretch ");
    • Broadcast Wave — содержание полей, позволяющих идентифицировать автора в файлах формата Broadcast Wave File (см. разд. 2.11);

  • Editing — опции редактирования (отдельные опции описаны в разд. 4.4.3 и в разд.4.7.2):
    • Tool Modifiers — настройка горячих клавиш, используемых при редактировании.

  • Event Display — опции отображения сообщений:
    • Audio — опции отображения аудиосообщений (см. главу 12);
    • MIDI — опции отображения MIDI-сообщений (см. главу 6);
    • Video — опции отображения видеосообщений (см. разд. 4.3).

  • MIDI — опции MIDI-подсистемы Cubase SX (см. главу 6):
    • Function Parameters — отдельные опции MIDI-подсистемы;
    • Chase Events Filter — фильтр передаваемых MIDI-сообщений при изменении текущей позиции проекта (см. разд. 4.4.2);
    • Filter — настройки фильтра MIDI-сообщений, поступающих через входные MIDI-порты (см. разд. 2.2).

  • Scores — опции редактирования в окне Score Editor:
    • Event Layer — распределение графических объектов окна Score Editor по различным слоям (см. разд. 8.4).

  • Transport — опции транспортной подсистемы Cubase SX.
  • User Interface — опции пользовательского интерфейса:
    • Controls — режимы работы управляющих элементов интерфейса.

  • VST — дополнительные параметры звукового движка Cubase SX (см. разд. 2.7).

Key Commands... — редактировать соответствие горячих клавиш выполняемым командам и макросы. Имеется возможность загрузки таблиц горячих клавиш, соответствующих предыдущим версиям Cubase и музыкальным редакторам третьих фирм (Cakewalk SONAR, Emagic Logic). Макросы — последовательности внутренних команд Cubase SX. Вызвать созданные макросы можно из подменю Edit > Macros или командой с внешнего управляющего устройства (см. разд. 2.3).
Recent Projects — подменю для загрузки последних проектов, с которыми вы работали.
Quit (<Ctrl> + <Q>) — выход из Cubase SX.


16.2. Edit— редактирование

В меню Edit собраны команды и подменю, с помощью которых выполняются основные операции по редактированию материала проекта. Кратко рассмотрим их назначение.
Undo (<Ctrl> + <Z>) — отменить ранее выполненное действие.
Redo (<Ctrl> + <Shift> + <Z>) — повторить отмененное действие.
History... — редактировать предысторию (стэк) выполненных, отмененных и повторенных действий (см. разд. 4.4.5, подраздел "Удаление, отмена последней операции").
Cut (<Ctrl> + <X>) — вырезать выделенные объекты.
Copy (<Ctrl> + <С>) — копировать выделенные объекты (поместить в буфер обмена).
Paste (<Ctrl> + <V>) — вставить данные из буфера обмена, начиная с текущей позиции курсора.
Paste at Origin (<Alt> + <V>) — вставить блок данных из буфера обмена обратно в его первоначальную позицию.
Delete (<Backspace>) — удалить выделенные объекты.
Split at Cursor (<Alt> + <X>) — разрезать часть в том месте, где находится курсор.
Split Loop — разрезать часть в местах, совпадающих с положениями левого и правого локаторов.
Range — подменю, предназначенное для удаления, вставки и перемещения сообщений, находящихся на одном или нескольких треках в пределах выделенного интервала. Команды, данного подменю описаны в разд. 4.4.5 (подраздел "Инструмент Range Selection").
Select — подменю, предназначенное для выделения различных объектов проекта. Команды данного подменю описаны в разд. 4.4.5 (подразделы "Выделение " и "Инструмент Range Selection").
Duplicate (<Ctrl> + <D>) — дуплицирование выделенных объектов.
Repeat... (<Ctrl> + <K>) — многократное копирование выделенных объектов.
Fill Loop — заполнение фрагмента проекта копиями выделенного объекта. Предыдущие три команды описаны в разд. 4.4.5 (подраздел "Копирование").
Move to — подменю, включающее в себя команды для перемещения выделенных объектов:

  • Cursor — переместить в текущую позицию проекта;
  • Origin — переместить выделенное аудисообщение в позицию Origin Time (см. разд. 12.4);
  • Front — отобразить выделенный объект поверх других;
  • Back — переместить выделенный объект на самый нижний слой.

Понятие слоев пояснено в разд. 4.4.3 (подраздел "Режимы записи, циклическая запись, регионы аудиосообщений").
Convert to Real Copy — конвертирование связанных объектов в независимые копии (см. разд. 4.4.5, подраздел "Копирование").
Lock... (<Ctrl> + <Shift> + <L>) — запрет редактирования определенных атрибутов выделенных объектов.
Unlock (<Ctrl> + <Shift> + <U>) — снятие атрибута Lock с выделенных объектов.
Mute (<Shift> + <M>) — заглушение выделенных объектов.
Unmute (<Shift> + <U>) — снятие атрибута Mute с выделенных объектов.
Zoom — подменю, в котором собраны команды, предназначенные для управления масштабом отображения графических объектов:

  • Zoom In (<H>) — увеличить размер изображения по горизонтали. Каждое очередное применение команды приводит к дискретному увеличению масштаба в небольших пределах, причем изображение "растягивается" симметрично относительно положения курсора проекта;
  • Zoom Out (<G>) — уменьшить размер изображения по горизонтали;
  • Zoom Full (<Shift> + <F>) — увеличить размер отображения по горизонтали таким образом, чтобы на экране был виден весь проект от его первого объекта до последнего;
  • Zoom to Selection (<Alt> + <S>) — увеличить размер изображения по горизонтали таким образом, чтобы на экране были видны все выделенные объекты;
  • Zoom to Event (<Shift> + <E>) — опция доступна только в Sample Editor: сделать так, чтобы волновая форма, заключенная между метками начала и окончания аудиосообщения, занимала всю видимую область окна;
  • Zoom In Vertical — увеличить размер изображения по вертикали;
  • Zoom Out Vertical — уменьшить размер изображения по вертикали;
  • Zoom In Tracks (<Alt> + <!>) — увеличить ширину выделенных треков;
  • Zoom Out Tracks (<Ctrl> + <T>) — уменьшить ширину выделенных треков;
  • Zoom Tracks Exclusive (<Ctrl> + <l>) — существенно увеличить ширину выделенных треков.

Macros — подменю, содержащее пользовательские макросы (см. разд. 16.1, описание команды Key Commands...).


16.3. Project— работа с проектом

В меню собраны команды и подменю, предназначенные для создания новых треков, управления отображением некоторых элементов проекта, а также команды, открывающие ряд окон диалога.
Add Track — подменю, включающее в себя команды создания треков различного типа:

  • Audio — создать аудиотрек (см. разд. 4.2);
  • Folder — создать трек-контейнер (см. разд. 4.6);
  • Group Channel — создать групповой трек (см. разд. 4.3);
  • MIDI — создать MIDI-трек (см. разд. 4.1);
  • Marker — создать трек маркеров (см. разд. 4.7);
  • Master Automation — создать трек автоматизации мастер-секции (см. разд. 4.7.8);
  • Video — создать видеотрек;
  • Multiple — добавить заданное количество треков одного из трех типов (MIDI, Audio Group, Channel).

Remove Selected Tracks — удалить выбранные треки.
Show Used Automation — показать все подтреки, содержащие данные автоматизации.
Hide All Automation — скрыть все подтреки с автоматизацией.
Pool (<Ctrl> + <Р>) — открыть окно пула (см. разд. 12.4).
Markers (<Ctrl> + <М>) — открыть окно редактора маркеров (см. разд. 4.7).
Tempo Track (<Ctrl> + <Т>) — открыть окно графического редактора темпа и сообщений о смене музыкального размера (см. разд. 7.2.1).
Browser (<Ctrl> + <В>) — открыть окно Browse Project (см. разд. 7.1).
Beat Calculator... — открыть окно калькулятора, предназначенного для вычисления темпа (см. разд. 7.2.2).
Notepad — открыть окно блокнота для записи текстовой информации о проекте.
Project Setup... (<Shift> + <S>) — открыть окно диалога для выбора параметров проекта (см. разд. 2.11).
Auto Fades Settings... — открыть окно параметров автоматического фейда и кроссфейда (см. разд. 4.4.5, подраздел "Амплитудные огибающие аудиосообще-ний; пересечение аудиосообщений, Auto Fades, Auto Crossfades").


16.4. Audio — работа с цифровым звуком

В меню Audio собраны команды и подменю, предназначенные для редактирования и анализа данных, имеющихся на аудиотреках.
Process — подменю, содержащее команды обработки выделенных звуковых данных средствами, встроенными в программу. Подробности см. в разд. 12.5.
Plug-ins — подменю, содержащее команды вызова Plug-in-модулей для проведения разрушающей обработки выделенных звуковых данных. Подробности см. в главе 13.
Spectrum Analyzer — открыть окно анализатора спектра для выделенных аудиосообщений (см. разд. 1.11.2 "Измерение спектра в Cubase SX").
Statistics — открыть окно сбора статистической информации о выделенных аудиоданных.
Hitpoints — подменю (доступно в Sample Editor), с помощью команд которого реализуется функция, позволяющая обнаруживать в аудиоданных и помечать маркерами моменты резкого перепада уровня сигнала (см. разд. J2.2.4).
Detect Silence — открыть окно Detect Silence, позволяющее для каждого из выделенных аудиотреков задать критерии, в соответствии с которыми будут определены участки, не содержащие отсчетов полезного сигнала (см. разд. 12.6).
Event as Region — переместить границы аудиосообщения так, чтобы они совпадали с границами региона (см. разд. 4.4.3, подраздел "Режимы записи, циклическая запись, регионы аудиосообщений" и разд. 12.2.3).
Event from Regions — создать аудиосообщения из регионов аудиоклипа (понятие клипа введено в разд. 12.4).
Create Region(s) — создать регион, соответствующий выделенному фрагменту волновой формы (в окне Sample Editor).
Events to Part — создать часть, включающую в себя выделенные аудиосообщения.
Close Gaps — заполнить промежутки между аудиосообщениями (см. разд. 4.4.5, подраздел "Склеивание, заполнение пауз" и разд. 12.2.4).
Dissolve Part — аннулировать выделенную часть. В результате применения этой команды аудиосообщения, ранее объединенные в часть, становятся независимыми.
Snap point to cursor — установить маркер S аудиосообщения в текущую позицию проекта (см. разд. 12.1).
Bounce Selection — пересчитать выделенные звуковые данные с учетом автоматизации и подключенных эффектов, создать новый звуковой файл.
Crossfade (<X>) — выполнить кроссфейд в зоне пересечения аудиосообщений.
Remove Fades — сбросить настройки амплитудной огибающей аудиосообщения.
Open Fade Editor(s) — открыть окна Fade In, Fade Out для редактирования амплитудной огибающей выделенных аудиосообщений (см. разд. 4.4.5, подраздел "Амплитудные огибающие аудиосообщений; пересечение аудиосообщений, Auto Fades, Auto Crossfades").
Find Selected in Pool (<Ctrl> + <F>) — открыть окно Pool и показать в нем выделенные объекты.
Adjust Fades to Range (<A>) — переместить узлы амплитудной огибающей так, чтобы они располагались на границах выделенной области звукового сообщения.
Offline Process History — открыть окно Offline Process History для просмотра и изменения истории разрушающего редактирования.
Freeze Edits — сохранить результаты разрушающего редактирования из временных файлов в постоянные. Последние две команды описаны в разд. 12.7.


16.5. MIDI- работа с MIDI

В меню MIDI сосредоточены команды, открывающие MIDI-редакторы, а также реализующие различные способы квантизации и функции обработки MIDI-сообщений.
Open Key Editor — открыть окно Key Editor (см. разд. 6.3).
Open Score Editor (<Ctrl> + <R>) — открыть окно нотатора Score Editor (см. главу 8).
Open Drum Editor — открыть редактор барабанных партий Drum Editor (см. разд. 6.4).
Open List Editor (<Ctrl> + <G>) — открыть редактор списка сообщений List Editor (см. разд. 6.2).
Over Quantize (<Q>) — произвести полную квантизацию моментов наступления событий в соответствии с сеткой квантизации, выбранной в раскрывающемся списке Quantize окна Key Editor (см. разд. 6.6.2).
Iterative Quantize — выполнить итеративную (приближенную) квантизацию (см. разд. 6.6.2), при которой начальные моменты событий переместятся не точно в узлы сетки квантизации, а в некоторую их окрестность, ширина которой определяется значением параметра Iterative Strength (выбирается в окне диалога Quantize Setup).
Quantize Setup — открыть окно диалога Quantize Setup, предназначенное для выбора параметров квантизации (см. разд. 6.6.1).
Advanced Quantize — подменю, содержащее дополнительные команды, относящиеся к функции квантизации, подробно описанные в разд. 6.6.2.
Transpose... — открыть окно диалога Transpose, предназначенное для транспонирования выделенных MIDI-нот (см.разд. 6.7.1).
Merge MIDI in Loop — объединить все MIDI-события, находящиеся на незаглушенных треках между левым и правым локаторами, в единую часть. Часть размещается на выбранном треке. Командой открывается окно диалога MIDI Merge Options, в котором следует выбрать опции формирования части (см. разд. 6.7.2).
Dissolve Part — распределить выделенную часть по отдельным трекам. Командой открывается окно диалога, в котором следует выбрать критерий такого распределения (см. разд. 6.7.3).
O-Note Conversion — преобразование номеров нот в соответствии с Drum Map (см. разд. 6.7.4).
Functions — подменю, в котором собраны команды, выполняющие ряд редактирующих функций (см. разд. 6.8);
Logical Editor... — открыть окно Logical Editor (см. разд. 6.5).
Logical Presets — подменю выбора пресетов для логического редактора.
Drum Map Setup... — открыть окно редактора барабанной карты Drum Map Setup (см. разд. 4.1.2).
Reset — сброс MIDI-контроллеров в состояние по умолчанию.


16.6. Scores — опции нотатора

В меню Scores находятся команды и подменю, имеющие отношения к работе в окне Score Editor. Их назначение кратко рассмотрено в разд. 8.3.


16.7. Pool— команды для работы с пулом

Меню Pool содержит набор специализированных команд для импорта аудио- и видеоданных, сохранения и восстановления конфигурации пула, специальные команды для работы со звуковыми файлами. Команды данного подменю описаны в разд. 12.4.


16.8. Transport—управление воспроизведением, записью и синхронизацией

В меню Transport находятся команды управления воспроизведением, записью и синхронизацией. Рассмотрим их назначение.
Transport Panel (<F2>) — команда, позволяющая скрыть или отобразить транспортную панель.
Locators to Selection (<P>) — совместить локаторы с границами выделенной области трека.
Locate Selection (<L>) — установить указатель текущей позиции к левой границе выделенной области трека.
Locate Next Marker (<Shift> + <N>) — установить указатель текущей позиции к следующему маркеру.
Locate Previous Marker (<Shift> + <B>) — установить указатель текущей позиции к предыдущему маркеру.
Locate Next Event (<N>) — установить указатель текущей позиции к следующему сообщению.
Locate Previous Event (<B>) — установить указатель текущей позиции к предыдущему сообщению.
Play from Selection Start — воспроизвести один такт, начиная с левой границы выделенной области.
Play from Selection End — воспроизвести один такт, начиная с правой границы выделенной области.
Play until Selection Start — воспроизвести один такт, предшествующий левой границе выделенной области.
Play until Selection End — воспроизвести один такт, предшествующий правой границе выделенной области.
Play until Next Marker — воспроизвести участок от текущей позиции до следующего маркера
Play Selection Range (<Alt> + <Пробел>) — воспроизвести выделенный участок.
Loop Selection (<Shift> + <G>) — циклически воспроизводить выделенный участок (локаторы автоматически перемещаются к границам выделенного участка).
Use Pre/Post-Roll — использовать параметры Pre/Post-Roll (см. разд. 3.3) при записи.
Start Record at Left Locator — начать запись с позиции левого локатора.
Metronome Setup — открыть окно настройки метронома (см. разд. 2.8).
Metronome On (<C>) — включить метроном.
Sync Setup — открыть окно настройки синхронизации (см. разд. 2.9).
Sync Online (<T>) — включить режим синхронизации.


16.9. Devices — конфигурирование устройств виртуальной студии

В меню Devices находятся команды, предназначенные для доступа к параметрам виртуальной студии. Состав команд может варьироваться в зависимости от того, какое оборудование и программы используются в вашей виртуальной студии. Рассмотрим назначение наиболее общих команд.
MIDI Device Manager — вызывает окно, в котором можно описать для Cubase SX возможности подключенных MIDI-устройств (см. разд. 2.1).
Mixer (<F3>) — открывает окно микшера Cubase SX (см. главу 5).
Plug-in Information — открывает окно с информацией о плагинах (см. разд. 5.6.1).
True Tape — открывает окно специального плагина, эмулирующего запись на аналоговую магнитную ленту (см. разд. 2.10).
VST Inputs (<F5>) — открывает окно конфигурирования входных аудиопортов виртуальной студии (см. разд. 2.6).
VST Instruments (<F11>) — открывает окно со слотами для подключения VST1 (см. разд. 4.1.3).
VST Master Effects (<F7>) — открывает окно со слотами для подключения плагинов к мастер-секции микшера (см. разд. 5.5 и разд. 5.6.3).
VST Master Setup — открывает окно конфигурирования мастер-секции микшера (см. разд. 2.6).
VST Outputs (<F4>) — открывает окно конфигурирования выходных аудио-портов виртуальной студии (см. разд. 2.6).
VST Performance (<F12>) — открывает окно с индикаторами загрузки процессора и дисковой системы.
VST Send Effects (<F6>) — открывает окно со слотами для подключения плагинов, работающих в режиме посыла (см. разд. 4.2.2, подраздел "Секция Sends" и разд. 5.6.2).
Video (<F8>) — открывает окно для воспроизведения видео (см. разд. 14.3).
Show Panel — открывает панель с кнопками, вызывающими окна с параметрами устройств виртуальной студии. Данная панель дублирует функции меню Devices.
Device Setup... — открывает окно, в котором собраны параметры различных устройств. Перечислим основные группы параметров:

  • All MIDI Inputs — настройки концентратора All MIDI Inputs (см. разд. 2.2);
  • Default MIDI Ports — выбор входного и выходного MIDI-портов, устанавливаемых по умолчанию для вновь создаваемых MIDI-треков (см. разд. 2.2);
  • Direct Music — список MIDI-портов, доступных в системе посредством API DirectX (см. разд. 2.2);
  • VST Multitrack — настройки параметров аудиоинтерфейса и звукового движка (см. разд. 2.5);
  • VST System Link — настройки Cubase SX для работы в сети студийных компьютеров в целях распределения вычислительной нагрузки, связанной с обработкой музыки (см. главу 15);
  • Video Player — настройки проигрывателя видео (см. разд. 14.3).


16.10. Window— управление отображением

Команды меню Window предназначены для управления отображением. Перечислим их:

  • Close — закрыть активное окно;
  • Close All — закрыть все окна проекта (если последние изменения не были сохранены в файле, возникнет окно с запросом подтверждения команды);
  • Minimize All — минимизировать все окна, открытые в проекте;
  • Restore All — отменить минимизацию окон;
  • Tile Horizontal — разместить окна, открытые в проекте, одно над другим;
  • Tile Vertical — разместить окна, открытые в проекте, одно рядом с другим;
  • Cascade — разместить каскадом окна, открытые в проекте;
  • Window Layout — подменю, содержащее команды редактирования раскладок окон, сохраняемых с проектом;
  • Windows... — открыть окно органайзера, предназначенного для работы с окнами.

В нижней секции меню расположен список открытых окон (The open windows list).


16.11. Help — помощь и справочная информация

Перечислим команды меню Help.
HTML Help — подменю вызова справочной системы в формате HTML.
Documentation (Acrobat PDF format) — подменю вызова справочной системы в формате PDF.
Steinberg on the Web — подменю, содержащее команды соединения с сайтами Steinberg посредством Internet.
About Cubase SX/SL — вызов окна, содержащего основные сведения о программе.


Глава 2. Подготовка программы к эффективной работе. Создание проекта

    • Подготовка программы к эффективной работе. Создание проекта
    • 2.1. Описание MIDI-устройств, подключенных к компьютеру
    • 2.2. Настройка MIDI-портов
    • 2.3. Настройка Cubase SX на работу с внешними устройствами управления
    • 2.4. Загрузка банков SoundFont
    • 2.5. Настройка параметров аудиоинтерфейса, основные параметры звукового движка VST
    • 2.6. Входы и выходы виртуальной звуковой студии, обеспечение пространственного панорамирования
    • 2.7. Мониторинг, дополнительные параметры звукового движка VST
    • 2.8. Настройка метронома
    • 2.9. Синхронизация Cubase SX с внешними устройствами
    • 2.10. Применение технологии ТгиеТаре
    • 2.11. Создание проекта и настройка его параметров


Подготовка программы к эффективной работе. Создание проекта

Вы установили Cubase SX на свой компьютер. Поздравляем! Что дальше? После первого запуска откроется диалоговое окно (рис. 2.1, а), где вам предстоит решить за программу, чем ей заняться в ближайшем будущем: тестировать конфигурацию AS1O Multimedia Driver или пропустить тест и продолжить загрузку. Рекомендуется все же пройти тест. После нажатия кнопки ОК откроется еще одно окно (рис. 2.1, б). В нем будет отображаться ход тестирования. Нажатие кнопки Cancel приведет к отмене теста — этого делать не стоит. После завершения теста, мы надеемся, возникнет сообщение об успешном его завершении (рис. 2.1, б). После нажатия кнопки ОК продолжится запуск Cubase SX.

Рис. 2.1, а. Первичное тестирование

Рис. 2.1 (б, в). Первичное тестирование

В принципе, программа уже готова к работе — она будет воспроизводить звук и передавать команды заданным MIDI-устройствам. Тем не менее, мы рекомендуем не пропускать данную главу. Как и в любом другом современном музыкальном редакторе, в Cubase SX имеется множество параметров, от которых может зависеть качество создаваемого музыкального материала и комфортность работы с программой. Кроме того, любой современный музыкальный редактор, в отличие от множества других программ (например, офисных или дизайнерских), является системой реального времени. Отсюда вытекает особая значимость параметров, влияющих на работу программы. Прежде чем приступать к рассмотрению каких-либо окон, перечислим некоторые термины с кратким пояснением. Без понимания сути терминов просто не обойтись.
ММЕ (Multi-Media Extensions) — мультимедийный API (Application Programming Interface — интерфейс прикладных программ) фирмы Microsoft, появившийся еще в Windows 3.1. Для Windows 3.0 его можно было установить в виде отдельного программного продукта. На сегодняшний день его можно считать морально устаревшим, не обеспечивающим высокоскоростное взаимодействие приложений с драйверами устройств (звуковыми картами, в частности).
DirectX — современный мультимедийный API фирмы Microsoft, обеспечивающий высокоскоростное взаимодействие приложений с драйверами различных устройств: звуковых карт, видеокарт, устройств ввода и др. Кроме того, в DirectX имеется поддержка множества всяких функций преобразования графики и звука, реализованных программно.
ASIO (Audio Stream In/Out — ввод/вывод аудиопотока) — API, продвигаемый фирмой Steinberg, позволяет производить обмен звуковыми данными непосредственно между драйверами звуковых карт и звуковым программным обеспечением. Использование звуковых карт, драйверы которых имеют поддержку ASIO, позволяет "развивать" экстремально низкие задержки при использовании плагинов, при микшировании звуковых потоков и т. п. Здесь имеется в виду задержка между поступлением какой-либо команды и моментом ее фактического воплощения в звуке.
Учитывая то, что продукты Steinberg являются очень популярными, практически все современные звуковые карты поддерживают ASIO. Официальная поддержка ASIO имеется даже в мультимедийных картах SB Audigy и SB Audigy 2, не говоря уже о полупрофессиональных и профессиональных звуковых картах. Что значит "официальная поддержка" ASIO? Дело в том, что некоторые производители, видимо, исходя из маркетинговых соображений, не снабжают свои мультимедийные звуковые карты ASIO-драйверами. Но зачастую находится один человек или целая группа энтузиастов-программистов, которые разрабатывают эти драйверы самостоятельно. Вот и получается, например, что официально звуковые карты семейства SB Live! ASIO не поддерживают, но существуют неофициальные ASlO-драйверы, которые очень даже не плохо справляются со своей задачей — обеспечивают минимальную задержку около 3 мс. Можно спорить о том, насколько это законно — бесплатно выполнять работу производителя оборудования, которую он почему-то не сделал сам, но и никому не поручал. Мы же просто приведем ссылку на сайт, где можно скачать альтернативные драйверы, с поддержкой ASIO для звуковых карт семейств SB Live!/Audigy: http://kxproject.com.
Итак, теперь вы достаточно подкованы для того, чтобы осмыслить процесс, произошедший при первом запуске Cubase SX и проиллюстрированный рис. 2.1, а, б, в. Произошло тестирование работы Cubase SX со звуковой картой посредством ММЕ. Задача этого процесса — обеспечить возможность записи/воспроизведения цифрового звука, поскольку ММЕ поддерживается драйверами подавляющего большинства звуковых карт. Какие при этом будут задержки при использовании плагинов — значения не имеет. Главное, чтобы при первом запуске программа работала. Выводить же Cubase SX на "расчетную мощность" с минимальными задержками и оптимальными настройками — это уже ваша задача.
Если вы внимательно посмотрите на рис. 2.1, а, б, в, то можете спросить: при чем же здесь ММЕ, если речь идет о настройке "ASIO Multimedia Driver"?
Обмен данными между Cubase SX и звуковой картой подразумевает наличие двух компонент: программного интерфейса со стороны Cubase SX и программного интерфейса со стороны драйвера звуковой карты. Cubase SX работает только с ASIO. Поэтому чтобы обеспечить работу Cubase SX со звуковыми картами, драйверы которых не поддерживают ASIO, существуют программные адаптеры ММЕ в ASIO и DirectX в ASIO, называемые ASIO Multimedia Driver и ASIO Full Duplex DirectX Driver, соответственно. Вместе с Cubase SX устанавливаются два приложения, предназначенные для настройки этих программных адаптеров: ASIO Multimedia Setup и ASIO DirectX Full Duplex Setup. Существует еще один вариант программного адаптера: ASIO DirectX Driver (без Full Duplex). Если при инсталляции Cubase SX установилась такая компонента, а не ASIO DirectX Full Duplex Setup, то, по всей видимости, ваша звуковая карта не работает в режиме одновременной записи/воспроизведения. Cubase SX в этом случае будет работать только в режиме воспроизведения. Правильным решением в данном случае было бы приобретение современной звуковой карты без подобных проблем.
Подведем промежуточный итог. Если драйверы звуковой карты поддерживают ASIO, то в Cubase SX следует использовать именно эти драйверы. Если поддержки ASIO нет, но имеется поддержка DirectX, то следует использовать ASIO Full Duplex DirectX Driver или ASIO DirectX Driver. Если вы являетесь "счастливым" обладателем раритетной звуковой карты, которая ничего из перечисленного не поддерживает, то следует оставить все как есть по умолчанию (ASIO Multimedia Driver) и работать через ММЕ.
Все вышесказанное является лишь нашим обоснованием необходимости прочтения данной главы. Если вам не терпится задействовать ASIO-драйвер своей звуковой карты, то можете прямо сейчас перейти к чтению разд. 2.5. А мы пойдем своим чередом и постараемся по порядку рассказать о том, что знаем сами.
Откройте подменю Devices (устройства) главного меню Cubase SX. Первое, что бросается в глаза, — это обилие команд, начинающихся с аббревиатуры "VST". С терминами VST (Virtual Studio Technology) и VSTi (VST Instruments) мы познакомили вас в предыдущей главе. Все команды, начинающиеся с "VST", предназначены для конфигурирования виртуальной студии: настройки портов ввода/вывода цифрового звука, подключения компонентов этой студии (плагинов). Однако кроме виртуальных синтезаторов и сэмпле-ров в вашей студии могут иметься вполне реальные MIDI-инструменты. Десяток лет назад предыдущая фраза могла бы показаться, по меньшей мере, бредом. Сегодняшняя реальность такова, что держать парк Hi-End-син-тезаторов и сэмплеров может позволить себе или серьезная коммерческая студия, или студия очень удачного в коммерческом плане проекта. Программные Hi-End-синтезаторы и сэмплеры — совсем другое дело, это уже не роскошь. Зачастую аппаратные инструменты используются для того, чтобы было с чем выступать на сцене. Но если инструмент уже имеется в наличии, то почему бы не включить его в состав своей виртуальной студии? Допустим, физически синтезатор уже подключен к компьютеру посредством интерфейса MIDI (пусть это будет синтезатор, поддерживающий спецификацию XG фирмы Yamaha). Теперь нужно сделать так, чтобы виртуальная студия Cubase SX "знала" о существовании этого синтезатора и обеспечила для вас комфортный доступ к его ресурсам.


2.1. Описание MIDI-устройств, подключенных к компьютеру

Командой главного меню Devices > MIDI Device Manager откройте диалоговое окно, показанное на рис. 2.2.

Рис. 2.2. Диалоговое окно MIDI Device Manager

В список Installed Devices (установленные устройства) вы должны добавить элемент, соответствующий вашему синтезатору. Нажмите кнопку Install Device, появится диалоговое окно, показанное на рис. 2.3. Понятно, что в этом списке следует выбрать название своего устройства и нажать кнопку ОК.

Рис. 2.3. Диалоговое окно Add MIDI Device

После этого осуществится загрузка названий инструментов, поддерживаемых выбранным синтезатором, и MIDI-команд для их выбора. Обратите внимание на список, содержащий названия MIDI-устройств, показанный на рис. 2.3. Он называется Scripts (сценарии). Выбирая элемент данного списка, вы выбираете некий сценарий для того, чтобы загрузить его в Cubase SX. "Сценарий" — понятие достаточно широкое. В программировании сценариями (scripts) обычно называются последовательности неких команд высокого уровня. В данном случае сценарии тоже содержат в себе команды — наборы MIDI-команд. Причем разные сценарии объединены в своеобразные банки — выбирая один элемент в списке Scripts, вы тем самым выбираете совокупность сценариев, имеющих отношение к определенному MIDI-устройству. Давайте выберем элемент XG Device и нажмем ОК. Мы осуществили загрузку сценариев для MIDI-устройства, соответствующего спецификации XG, коим и является наш синтезатор.
В данном случае сценарии содержат MIDI-команды для выбора пресетов синтезатора. В каждом из сценариев присутствует команда смены банка и команда смены инструмента в банке.
Сценарии объединены в удобную иерархическую структуру (Patch Banks), которую можно просматривать в левой нижней части окна MIDI Device Manager (рис. 2.4) при условии, что нажата кнопка Patch Banks.
В терминологии Cubase SX элементы, расположенные в верхнем уровне данного дерева (в корне), называются банками. В данном случае имеется два банка: XG Voice (мелодические звуки) и XG Drumkits (ударные звуки). В папки банков может быть вложено сколько угодно других папок. Их назначение заключается в том, чтобы иметь название и служить контейнерами для других папок или скриптов. Скрипты являются объектами древовидной структуры не имеющими потомков (листьями).
Дерево Patch Banks нужно исключительно для того, чтобы обеспечить удобный доступ к пресетам синтезатора. Однако его структура определяется его создателем и не связана с логикой хранения пресетов в самом синтезаторе. Например, в папке XG Voices > Piano > GrandPno собраны скрипты для выбора вариаций звучания Grand Piano. А по спецификации XG все эти пресеты размещаются в различных банках синтезатора.
Заметим, что вы можете использовать клавиши управления курсором для перемещения по дереву Patch Banks.
При выборе элемента дерева, соответствующего сценарию, его содержимое отображается в правой нижней части окна (рис. 2.4.).
Сценарии представлены в виде таблиц, в которых каждая графа соответствует одному MIDI-сообщению. Таблицы имеют следующие столбцы:

  • MIDI Message Name — наименование MIDl-сообщения;
  • Value — значение параметра MIDI-сообщения;
  • Valid Range — допустимые значения для параметров данного MIDI-сообщения;
  • MIDI Message Bytes — шестнадцатеричное представление MIDI-сообщений.

В сценариях могут использоваться MIDI-сообщения только трех типов:

  • Bank Select — выбор банка;
  • Program Change — смена инструмента в банке;
  • Controller Change (CC) — изменение значения заданного MIDI-контроллера.

В безымянном списке, в котором по умолчанию установлен элемент Not Connected (не подключен), следует выбрать выходной MIDI-порт, к которому подключен внешний синтезатор.
Если нажать кнопку Bank Assignment, то вид окна MIDI Device Manager изменится (рис. 2.5). Вы можете поставить в соответствие определенным банкам MIDI-каналы синтезатора.

Рис. 2.4. Диалоговое окно MIDI Device Manager (добавлено устройство XG Device)

Рис. 2.5. Диалоговое окно MIDI Device Manager (нажата кнопка Bank Assignment)

В принципе, к вашему компьютеру может быть подключено сколько угодно внешних синтезаторов. Естественно, для этого в системе должно иметься соответствующее количество MIDI-портов. Все подключенные синтезаторы следует добавить в список Installed Devices, расположенный в диалоговом окне MIDI Device Manager. Если сценарии для нужного синтезатора отсутствуют в списке Scripts окна Add MIDI Device (напомним, что данное окно вызывается нажатием кнопки Install Device), то имеет смысл поискать их в Internet.
Кнопкой Import Setup открывается стандартное диалоговое окно для загрузки файлов. С его помощью осуществляется загрузка банков сценариев, хранящихся в файлах формата Steinberg XML (файлы с расширением XML). Вообще XML (extensible Markup Language) — это метаязык для записи структурированных данных. В Cubase SX он широко используется для хранения всевозможных пресетов. Если найти сценарии для имеющегося синтезатора не удается, можно создать их самостоятельно с "нуля" или модифицировать уже имеющийся банк сценариев.
Давайте создадим свой собственный банк скриптов. В диалоговом окне MIDI Device Manager нажмите кнопку Install Device, а в появившемся окне Add Midi Device (рис. 2.3) выберите Define New и нажмите ОК. Появится диалоговое окно Type in MIDI Device Name, в единственное текстовое поле которого следует ввести имя MIDI-устройства, для которого создается банк скриптов. Мы назвали это устройство My Device и нажали ОК. После этого устройство My Device появилось в списке Installed Devices диалогового окна MIDI Device Manager (рис. 2.6). Выберем это устройство в списке: структура только что созданного банка включает в себя одну папку Empty Bank и сценарий Off, который не содержит ни одной MIDI-команды.
Для того чтобы сделать банк сценариев доступным для редактирования, нужно установить флажок Enable Edit. После этого станет доступным поле Commands. Щелчок левой кнопкой мыши на этом поле вызовет появление следующего меню:

  • Create Bank — создать банк (папку, расположенную в корне дерева Patch Banks);
  • New Folder — создать новую папку; возникнет диалоговое окно, в котором следует ввести название новой папки; новая папка будет вложена в ту папку, которая была выбрана в момент вызова команды;
  • New Preset — создать новый сценарий;
  • Add Multiple Presets — создать множество сценариев.

Кстати, последние три команды также имеются в контекстном меню, вызываемом щелчком правой кнопки мыши на окне MIDI Device Manager. Кроме того, в этом меню имеется опция Always on Top. Если ее включить, то данное окно всегда будет находиться "на поверхности" экрана, над другими окнами, вне зависимости от того, активно оно или нет.

Рис. 2.6. Диалоговое окно MIDI Device Manager (создан банк скриптов для устройства My Device)

Вы можете переименовывать папки и сценарии. Для этого нужно выбрать нужный элемент и сделать на нем щелчок: его название станет доступным для редактирования.
Вы можете использовать технологию Drug & Drop для редактирования структуры дерева Patch Banks: нажатием левой кнопки мыши захватываете нужный сценарий или папку; удерживая левую кнопку нажатой, перетаскиваете захваченный элемент на нужное место в дереве и отпускаете кнопку.
Чтобы удалить папку или сценарий, следует выбрать соответствующий элемент дерева и воспользоваться командой главного меню программы Edit > Delete.
Ну а теперь о главном — о редактировании сценариев.
Начнем с того, что у вас есть "пустой" сценарий. Щелкаете на пустом поле таблицы команд сценария, расположенном в столбце MIDI Message Name, и выбираете нужное MIDI-сообщение (рис. 2.7, а). Чтобы добавить еще одно сообщение, щелкаете на следующем пустом поле в столбце MIDI Message Name и вновь выбираете нужное MIDI-сообщение (рис. 2.7, б). Таким способом можно добавлять в сценарий сколько угодно MIDI-сообщений.

Рис. 2.7. Создание сценария

Простейший работоспособный сценарий должен содержать следующую последовательность команд: команда выбора банка, команда выбора инструмента в банке. Потом может следовать сколько угодно команд типа Control Change. Но обычно необходимости в этом нет. Параметры MlDI-команд задаются в полях, расположенных в столбце Value.
Если возникнет необходимость в удалении какой-либо команды из сценария, то действовать нужно следующим образом: выбираете любое поле в строке команды и нажимаете клавишу <Delete>. В случае необходимости команду удаления можно будет отменить с помощью кнопки Undo, расположенной над столбцом MIDI Message Name.
Если требуется удалить сразу несколько сценариев, то можно воспользоваться клавишами <Ctrl> или <Shift>, чтобы сначала выделить группу сценариев, а затем их удалить. Вариант с использованием <Ctrl>: удерживая нажатой эту клавишу, с помощью мыши выбирайте удаляемые сценарии. Вариант с использованием клавиши <Shift>: удерживая нажатой эту клавишу, с помощью мыши выберите сценарии, соответствующие границам удаляемого диапазона.
Обратите внимание на то, что кнопка Bank Assignment (соответствие банков сценариев MIDI-каналам) будет доступна только в том случае, если в дереве Patch Banks имеется не один, а несколько банков.
Рассмотрим подробнее команду Add Multiple Presets, входящую в меню Commands. Данная команда поможет вам "одним махом" создать множество сценариев по единому шаблону. На рис. 2.8. показано диалоговое окно, которое откроется при вызове команды Add Multiple Presets.

Рис. 2.8. Создание множества сценариев по единому шаблону

В окне Add Multiple Presets нужно создать шаблон, по которому автоматически будут создаваться сценарии. Допустим, в этом шаблоне всего одна MIDI- команда - Program Change. В поле Range задается диапазон изменения значения параметров данной команды. Например, если задать этот диапазон равным 63-127, то после нажатия кнопки ОК будет создано 64 сценария, содержащих одну единственную команду Program Change. Значения параметров этой команды в разных сценариях будут варьироваться от 63 до 127. Названия сценариев будут состоять из общей для всех части, заданной в поле Default Name (по умолчанию Preset), и значений параметров MIDI-команд (в нашем примере всего одна команда): Preset 63, Preset 64, Preset 65, Preset 127. Эти названия нужно будет привести в соответствие с названиями инструментов синтезатора.
Как правило, в сценарии должна присутствовать команда смены банка. Если вы хотите "одним махом" добавить инструменты только одного банка синтезатора, то в поле Range команды смены банка следует указать N-N, где N — номер банка. Пример: 0-0 — будут добавлены скрипты только для инструментов из банка № 0. Если же задать в поле Range диапазон, охватывающий несколько банков, то будут созданы сценарии для каждого из этих банков. Пример: значение параметра команды смены банка варьируется в пределах от 1 до 8, а значение параметра смены инструмента в банке — от 63 до 127. В результате мы получим 8 х 64 = 512 сценариев для всех возможных комбинаций значений параметров обеих команд.
Итак, если вы создаете банк сценариев для своего синтезатора, то каждому патчу вашего синтезатора должен соответствовать сценарий с MIDI-командами выбора данного патча. Работа не простая, но необходимая. Однако мы рекомендуем заняться этим позже — после того, как вы освоите работу с Cubase SX и научитесь использовать сценарии на практике.
В дальнейшем вы можете сохранить свой банк сценариев: в окне MIDI Device Manager (см. рис. 2.6) нажимаете кнопку Export Setup, появляется стандартное диалоговое окно для сохранения файлов, вводите имя сохраняемого XML-файла, нажимаете ОК.
Если вы захотите удалить банк сценариев какого-либо устройства, то его название следует выбрать в списке Installed Devices окна MIDI Device Manager и воспользоваться кнопкой Remove Device.
Вниманию владельцев звуковых карт, поддерживающих технологию Sound-Font (SB Audigy/Audigy 2, SB Live и др.)! Если вы используете аппаратный сэмплер своей карты, то названия инструментов из банков SoimdFont будут загружаться в Cubase SX автоматически. Поэтому никаких действий в окне MIDI Device Manager совершать не следует.
Аппаратные сэмплеры звуковых карт SB Audigy/Live!, безусловно, хороши, однако в ряде случаев предпочтительнее пользоваться программными сэм-плерами, реализованными в виде VSTi-плагинов (например, сэмплер Halion фирмы Steinberg). Обусловлено это следующими причинами:

  • современные VSTi-сэмплеры поддерживают практически все существующие форматы сэмплерных банков, позволяют загружать сэмплы с дисков формата АКАI;
  • вы можете обрабатывать сигналы с выходов VSTi-сэмплеров эффектами реального времени, реализованными в виде VST-плагинов независимо для разных каналов;
  • партии VSTi-сэмплеров можно конвертировать непосредственно в звуковые файлы нужного формата без каких-либо дополнительных цифро-аналоговых или аналого-цифровых преобразований;
  • вы можете использовать surround-панарамирование независимо для каждого из каналов VSTi-сэмплера.

При использовании VSTi названия их банков и патчей загружаются в Cubase SX автоматически.


2.2. Настройка MIDI-nортов

Командой главного меню Devices > Device Setup откройте диалоговое окно Device Setup, показанное на рис. 2.9. В левой части этого окна расположен список Devices, в котором перечислены все аппаратные и программные устройства, имеющиеся в системе. К таким устройствам, в частности, относятся входные и выходные MIDI- и аудиопорты. Заметим, что если мы говорим "устройство имеется в системе", это значит, что его аппаратная часть (если таковая имеется) и соответствующие драйверы установлены и нормально функционируют.
При выборе раздела в списке Devices на вкладке Setup отображаются его доступные для редактирования параметры. О вкладке Add/Remote мы поговорим позже. А сейчас перечислим основные устройства в том порядке, в котором их удобнее изучать.
В разделе DirectMusic имеется список MIDI-портов, доступных в системе посредством API DirectX. Среди них могут быть порты как реальных устройств, так и виртуальных синтезаторов, являющихся не плагинами, а самостоятельными программами. Пример такого программного синтезатора: Microsoft GS Wavetable SW Synth.
На всякий случай напомним, что посредством интерфейса ASIO осуществляется передача только цифрового звука между Cubase SX и звуковой картой. Поэтому использование DirectX, а не ASIO, для обмена MIDI-данными — это совершенно нормально. Трафик MIDI-данных на несколько порядков меньше трафика звуковых данных. Поэтому быстродействие программного интерфейса в данном случае не критично. Не исключен и вариант, когда MIDI-порты эмулируются DirectX. To есть взаимодействие с ними в действительности осуществляется по цепочке DirectX—MME. Но это не вызовет никаких затруднений при работе с MIDI-портами. В данном случае в названиях портов будет присутствовать надпись [Emulated].

Рис. 2.9. Диалоговое окно Device Setup, раздел DirectMusic

Список MIDI-портов включает в себя следующие графы:

  • Dir — направление передачи данных; In — входной порт, Out — выходной порт;
  • Device — название порта;
  • Active — активность порта. Порт находится в активном состоянии, если на работу с ним настроен какой-нибудь плагин или MIDI-трек;
  • Show — сделать порт доступным из проекта Cubase SX (Yes — да, No — нет).

Для редактирования в данном случае доступы только параметры Device и Show. Имеет смысл исключить те MIDl-порты, которые вы не собираетесь использовать в своем проекте.
Редактирование осуществляется следующим образом. Для переключения значений Yes/No параметра Show следует сделать щелчок на соответствующем поле. Если требуется изменить название порта, то также следует сделать щелчок на нужном поле в графе Device, после чего текстовая строка с названием порта станет доступной для редактирования. После завершения редактирования названия следует нажать <Enter>, чтобы сохранить изменения, или <Esc>, чтобы восстановить исходное название.
Возможен еще и такой вариант, когда драйверы звуковой карты поддерживают работу только через ММЕ. В этом случае раздел DirectMusic окажется пустым, а аналогичный список доступных MIDI-портов следует искать в разделе Windows MIDI.
Отметим, что практически все MIDI-устройства могут принимать сообщения по 16 каналам. Для каждого из каналов могут быть заданы свои MIDI-инструменты (тембры, патчи, программы — в данном случае это синонимы). Таким образом, один синтезатор может одновременно воспроизвести звучание 16 MIDI-инструментов. Если вы используете несколько синтезаторов, например два, то в вашем распоряжении уже 32 MIDI-канала. Это значит, что одновременно могут звучать 32 различных MIDI-инструмента (16 инструментов одного синтезатора и 16 — другого).
Современные MIDI-устройства могут принимать сообщения более чем по 16 каналам. Для того чтобы обойти ограничение спецификации MIDI, заключающееся в том, что одно устройство может иметь не более 16-и MIDI-каналов, для каждого устройства создается по несколько виртуальных (а иногда и аппаратных) MIDI-портов. Например, синтезаторы звуковых карт SB Livel/Audigy/Audigy 2 являются 32-канальными и имеют по два 16-канальных виртуальных порта, называемых Synth А и Synth В.
В Cubase SX имеется некий виртуальный MIDI-порт, называемый All MIDI Inputs. Его можно выбирать в качестве входного порта MIDI-треков. Назначение порта All MIDI Inputs заключается в объединении нескольких реально существующих входных MIDI-портов в один виртуальный. По сути дела, All MIDI Inputs представляет собой концентратор (hub), в котором объединяются сообщения, получаемые с нескольких входных портов. Практическая польза от этого порта заключается в том, что в ряде случаев его наличие позволяет сэкономить деньги и не покупать MIDI-концентратор, реализованный аппаратно. Пример такого случая: у вас имеется два аппаратных устройства: MIDI-клавиатура и специализированный MIDI-контрол-лер. Если требуется записывать MIDI-данные, поступающие от этих устройств, то All MIDI Inputs поможет вам обойтись без MIDI-концентратора. Разумеется, это возможно только при условии, что вы располагаете либо двумя звуковыми картами, либо звуковой картой, имеющей два физических разъема MIDI In.
В разделе All MIDI Inputs (рис. 2.10) доступен список входных MIDI-портов, сообщения которых могут объединяться в концентраторе All MIDI Inputs. Для тех портов, объединение которых в концентраторе All MIDI Inputs нежелательно, следует установить значение параметра Active в положение No.
В нашем примере присутствует всего один входной порт, поэтому пример не очень нагляден. Но в принципе, портов может быть много. Причем доступны в списке будут только те входные порты, для которых параметр Show в разделе DirectMusic установлен в положение Yes.

Рис. 2.10. Диалоговое окно Device Setup, раздел All MIDI Inputs

Рис. 2.11. Диалоговое окно Device Setup, раздел Default MIDI Ports

В разделе Default MIDI Ports окна Devce Setup (рис. 2.11) имеются списки MIDI Input и MIDI Output, в которых можно соответственно выбрать входной и выходной MIDI-порты, устанавливаемые для вновь создаваемых MIDI-треков по умолчанию.
Если у вас всего один входной MIDI-порт, к которому подключена MIDI-клавиатура, и вы собираетесь работать преимущественно с VSTi, то список MIDI Output лучше не трогать (оставить там Not Connected — не выбран ни один из портов). А в списке MIDI Input следует выбрать тот самый единственный входной MIDI-порт. Как много своего времени вы потратите на работу с Cubase SX? Даже если вы за все это время создадите всего сотню MIDI-треков, то вам уже не нужно будет сотню раз назначать входной порт.
В разделе MIDI > Filter диалогового окна Preferences (рис. 2.12), вызываемого командой File > Preferences, доступны параметры фильтрации MIDI-сообщений, поступающих через входные MIDI-порты.

Рис. 2.12. Диалоговое окно Preferences (раздел MIDI > Filter)

В группе Record выбираются типы сообщений, которые следует фильтровать (не пропускать) при записи. Аналогичный перечень типов сообщений имеется в группе Thru — эти типы будут фильтроваться в режиме трансляции
MIDI-сообщений с входных портов MIDI-треков на выходные. Перечислим доступные типы сообщений:

  • Note — сообщения о нажатии MIDI-клавиш;
  • Poly Pressure — давление на отдельные клавиши;
  • Controller — сообщения об изменениях значений контроллеров;
  • Program Change — смена инструмента;
  • Aftertouch — усредненное давление на клавиши в одном MIDI-канале;
  • Pitchbend — сдвиг высоты тона;
  • Sysex — привилегированные системные сообщения.

Сообщения, поступающие по MIDI-каналам, выбранным в группе Channels, не следует пропускать. В группе Controller уточняется, сообщения каких именно контроллеров подлежат фильтрации. В верхней части группы расположено поле, в котором следует выбрать нежелательный контроллер. Кнопкой Add выбранный контроллер заносится в список фильтруемых контроллеров. Чтобы исключить контроллер из этого "черного" списка, следует выбрать его и нажать кнопку Remove.


2.3. Настройка Cubase SX на работу с внешними устройствами управления

В действительности мы продолжаем рассмотрение окна Device Setup, вызываемого командой главного меню Devices > Device Setup. Но вынуждены сделать небольшое отступление.
Понятие "внешние устройства управления" (их еще называют control surfaces и remote devices) объединяет в себе любые устройства, предназначение которых состоит исключительно в управлении другими MIDI-устройствами или программами, применяемыми в звукозаписи. Например, к устройствам управления можно отнести любую MIDI-клавиатуру, которую можно рассматривать как пульт управления внешними по отношению к ней аппаратными и программными синтезаторами и сэмплерами. Существуют и более "навороченные" по сравнению с традиционной MIDI-клавиатурой устройства, содержащие множество фейдеров и регуляторов. Внешне они напоминают микшеры, но их единственное предназначение — интерпретация ваших манипуляций с регуляторами в MlDI-команды и передача их другим устройствам или программам, которые в свою очередь выполняют функции микшеров, но не имеют удобного управления с помощью ручек и фейдеров. На рис. 2.13 показаны два таких устройства: CM. Labs MotorMix (рис. 2.13, а) и Tascam US-428 (рис. 1.13, б). Подключив одно подобное устройство (или даже несколько) к компьютеру, на котором установлен Cubase SX, вы значительно облегчите себе жизнь и существенно сократите пробег мыши: все основные виртуальные регуляторы микшера (параметров треков) Cubase SX можно будет перемещать без ее помощи.

Рис. 2.13. Устройства управления С.М. Labs MotorMix (а) и Tascam US-428 (б)

Рис. 2.14. Диалоговое окно Device Setup, вкладка Add/Remove

Взаимодействие Cubase SX с устройствами управления осуществляется посредством специальных плагинов. Они обеспечивают интерпретацию MIDI-сообщений, поступающих от устройств управления, во внутренние команды Cubase SX. В поставку Cubase SX входят несколько таких плагинов. Их список доступен на вкладке Add/Remove окна Device Setup (рис. 2.14).
Если вы являетесь счастливым обладателем одного из этих устройств, то ваши действия должны быть такими: выбираете нужное устройство в списке и нажимаете кнопку Add (добавить). Выбранное устройство добавляется в список Devices, расположенный в левой части окна. Если устройство не одно, то описанную операцию следует проделать столько раз, сколько устройств управления у вас имеется.
Появление выбранного устройства в списке Devices говорит о том, что музыкальный редактор Cubase SX знает о его существовании и готов с ним работать. Однако чтобы начать работу с этим устройством реально, следует выполнить кое-какие приготовления (как минимум, указать MIDI-порты, к которым это устройство подключено). Дальнейшие ваши действия: выбираете данное устройство в списке Devices, а в правой части окна выбираете вкладку Setup. На этой вкладке (рис. 2.15) имеются два списка — MIDI Input и MIDI Output. В них следует выбрать входной и выходной порты, посредством которых будет осуществляться обмен данными с устройством.
Вид остальной части окна на вкладке Setup будет зависеть от того, какое устройство выбрано. В нашем случае выбрано устройство С.М. Labs MotorMix, и таблица, расположенная под списками MIDI Input и MIDI Output, относится именно к данному устройству, хотя аналогичные таблицы могут быть доступны и для других устройств. Назначение этих таблиц — описание того, как Cubase SX должен интерпретировать различные команды, подаваемые нажатием кнопок, вращением регуляторов, перемещением фейдеров. В нашем примере таблица содержит три графы: Button — названия клавиш (или комбинаций клавиш), Category — категория внутренних команд Cubase SX, Command — конкретная команда из указанной категории. Например, нажатие кнопки L1 на С.М. Labs MotorMix приведет к выполнению команды Record из категории Transport (рис. 2.15), т. е. произойдет включение режима записи.
После выполнения любых действий на вкладке Setup с параметрами выбранного устройства управления следует нажать клавишу Apply, иначе изменения не сохранятся.
Как правило, устройства управления рассчитаны на управление небольшим количеством линеек виртуального микшера/треков. В любом случае аппаратных линеек для управления треками гораздо меньше, чем потенциально возможных виртуальных треков в проекте Cubase SX. Допустим, ваше устройство управления может управлять восьмью треками. А в вашем проекте 24 трека. Как тут быть?

Рис. 2.15. Настройка Cubase SX на работу с устройством С.М. Labs MotorMix

После того как выбранное устройство управления оказывается в списке Devices окна Device Setup, в подменю Devices главного меню имеет смысл поискать новую команду, соответствующую данному устройству. Например, устройству Tascam US-428 будет соответствовать команда главного меню Devices > Tascam US-428. Выбор данной команды приводит к появлению окна, показанного на рис. 2.16.

Рис. 2.16. Окно Tascam US-428

Единственный элемент, имеющийся в данном окне, — это список. В нем вы можете выбрать группу линеек микшера Cubase SX, которой будет управлять устройство Tascam US-428: VST Mixer 1-8 — линейки с 1 по 8, VST Mixer 9-16 — линейки с 9 по 16 и т. д. А как быть, если для вашего устройства в Cubase SX не существует специального плагина? На этот случай в Cubase SX существует универсальный плагин, называемый Generic Remote. Он позволяет организовать эффективное и гибкое использование самых различных устройств, вырабатывающих управляющие MIDI-сообщения: от MIDI-клавиатур различной сложности до сколь угодно сложных специализированных MIDI-контроллеров.
После добавления данного плагина в список Devices окна Device Setup, станут доступны его параметры (рис. 2.17). Впечатляет? Поэтому первым делом, чтобы не возиться самому с многочисленными настройками, стоит поискать в Internet файл конфигурации Generic Remote для вашего устройства. Возможные пути поиска: на сайте фирмы Steinberg (http://www.steinberg.net), на сайте производителя устройства, где угодно. Может быть, вам удастся найти специальный плагин для Cubase SX. Если же вы найдете файл конфигурации для Generic Remote (в формате XML), то загрузить его можно следующим способом: нажимаете кнопку Import, в стандартном диалоговом окне выбора файла указываете путь к нужному файлу и нажимаете кнопку Open.

Рис. 2.17. Параметры универсального плагина Generic Remote

Что делать, если файл настройки Generic Remote для вашего устройства управления найти не удалось, но это устройство имеется, и глупо его не использовать? Ничего не поделаешь, придется настраивать Generic Remote.
К сожалению, мы не можем предоставить вам описание данного плагина. В этом случае книга получилась бы гораздо толще и дороже. В руководстве пользователя Cubase SX приведены спецификации всех плагинов, входящих в поставку, включая Generic Remote.
В данном разделе, пожалуй, осталось рассказать лишь о том, как отключить ненужные плагины устройств управления. Находясь в окне Device setup, в списке Devices выбираете ненужное устройство, а на вкладке Add/Remove нажимаете кнопку Remove.


2.4. Загрузка банков SoundFont

Если говорить предельно кратко, то SoundFonts — это файлы звуковых банков, в которых хранятся сэмплы и параметры синтеза. С точки зрения пользователя, SoundFonts — это инструменты, которые можно загружать в память звуковой карты.
На момент написания данной книги формат SoundFont поддерживают множество моделей звуковых карт фирмы Creative. Из этого множества актуальными можно считать карты SB Live!, SB Audigy/Audigy 2. Cubase SX распознает присутствие устройства, поддерживающего банки SoundFont. При этом осуществляется автоматическая загрузка специального плагина, обеспечивающего пользователю комфортную работу с SoundFont. Поэтому не удивляйтесь тому, что MIDI-порты, соответствующие синтезатору, который поддерживает SoundFont, будут все время находиться в состоянии Active. С этими портами взаимодействует плагин. В списке Devices окна Device Setup, вызываемого командой главного меню Devices > Device Setup, появится соответствующий элемент, вернее два элемента. В звуковых картах SB Live! (с последними драйверами) и SB Audigy/Audigy 2 присутствует по два логически независимых синтезатора, в каждый из которых можно загружать свой набор банков SoundFont.
При использовании неофициальных драйверов SB Live!, SB Audigy/Audigy 2 Cubase SX может не признать наличие SoundFont-совместимых устройств в вашей системе!
Каждому из SoundFont-устройств в подменю Devices главного меню Cubase SX будет соответствовать специальная команда. Например, при использовании звуковой карты SB Audigy будут доступны команды Devices > SB Audigy Synth A [DF80] и Devices > SB Audigy Synth В [DF80]. Если вызвать любую из этих команд, откроется окно менеджера банков SoundFont для соответствующего устройства. Возможный вид окна показан на рис. 2.18. Данное окно включает в себя следующие элементы:

  • Banks — список логических банков, фактически загруженных в звуковую карту. В нашем примере данный список состоит из 12 элементов, однако все эти банки физически хранятся в одном файле SoundFont, который по умолчанию загружается при запуске Windows.
  • Patches — список инструментов, присутствующих в том логическом банке, который выбран в списке Banks.

Рис. 2.18. Менеджер банков SoundFont

В правой части окна расположен ряд кнопок:

  • Load Bank — открыть диалоговое окно Load SoundFont Bank (рис. 2.19), с помощью которого осуществляется выбор и загрузка файла SoundFont;
  • Clear Bank — выгрузить банк, выбранный в списке Banks (команда работает применительно к любым банкам, кроме стандартного);
  • Edit Bank — вызвать редактор, ассоциированный с файлами SoundFont, и загрузить в него выбранный банк для редактирования;
  • Reload Bank — выполнить перезагрузку выбранного банка;
  • Clear Patch — выгрузить инструмент, выбранный в списке Patches;
  • Save Set — открыть диалоговое окно Save Soundfont Set, с помощью которого можно сохранить конфигурацию загруженных банков SoundFont в специальный файл с расширением SFS;
  • Load Set — открывает диалоговое окно Load Soundfont Set, с помощью которого можно загрузить ранее сохраненную конфигурацию банков SoundFont из SFS-файла.

Опция Store in Project позволяет сохранить конфигурацию загруженных банков SoundFont в файле проекта Cubase SX.

Рис. 2.19. Выбор файла SoundFont для загрузки

В принципе, загружать банки SoundFont можно с помощью программного обеспечения звуковой карты. При этом у вас будут даже некоторые преимущества. Средствами менеджера банков SoundFont Cubase SX загружаются банки только формата SoundFont 2.x (расширение SF2). Современное программное обеспечение звуковых карт SB Livel/Audigy/Audigy 2, кроме файлов SF2, позволяет загружать еще и файлы SBK (SoundFont I), DLS и WAV.
Однако, несмотря ни на что, предпочтительнее пользоваться менеджером SoundFont Cubase SX. Единственная причина: информацию о загруженных банках SoundFont можно хранить в самом проекте. Каждому из проектов может соответствовать своя конфигурация банков SoundFont. При открытии проекта соответствующие банки SoundFont будут загружаться автоматически.
Следует обратить внимание на то, что банки SoundFont, загруженные средствами Cubase SX, не будут автоматически выгружаться ни при закрытии проекта, ни при закрытии Cubase SX.


2.5. Настройка параметров аудиоинтерфейса, основные параметры звукового движка VST

Настройка аудиоинтерфейса занимает особое место. Любому, даже самому современному персональному компьютеру тяжело справиться с гигантским объемом вычислений, необходимых для высококачественной обработки звуковых данных. Для каждой конкретной конфигурации компьютера существует свое максимально допустимое количество звуковых треков и аудиоэффектов реального времени, с которыми компьютер способен работать. Вы должны понимать, что при неправильном выборе значений параметров аудиоинтерфейса, возможности компьютера не будут использованы в полном объеме.
При инсталляции программы часть необходимых настроек производится автоматически. Но, как вы уже знаете, по умолчанию Cubase SX настраивается на работу со звуковой картой посредством API MME, что исключает возможность полноценной работы с аудиоплагинами и VSTi. Мы настойчиво рекомендуем использовать при работе с Cubase SX звуковую карту, драйверы которой поддерживают ASIO. В конце концов, полупрофессиональная карта с поддержкой ASIO является далеко не самым дорогим компонентом виртуальной студии и стоит дешевле и компьютера, и Cubase SX.
Прежде чем переходить к рассмотрению параметров, доступных в Cubase SX, сделаем важное замечание. Как известно, оптимизация компонентов и параметров компьютера для достижения максимального быстродействия — важная задача для звукозаписи на компьютере. На эту тему издано много книг, а в Internet имеется масса статей. Мы приведем лишь самые основные рекомендации.
1. Операционная система на платформе PC — это, безусловно, должна быть Windows XP (на момент издания книги ничего более "крутого" для PC не существует).
2. Процессор — чем быстрее, тем лучше. В Cubase SX предусмотрена оптимизация под разные типы процессоров. При запуске Cubase SX в зависимости от того, какой у вас процессор, будут загружаться разные варианты программного кода. Не обязательно иметь многопроцессорную систему. Многопроцессорность сильно удорожает компьютер, но общее быстродействие рабочей станции (заметьте, не сервера) при этом увеличивается не намного. На момент издания книги оптимальным решением можно считать использование системы на базе одного процессора Pentium 4 с поддержкой технологии НТ (Hyper-Threading).
3. Оперативная память — это то, чего никогда не бывает много. Чем ее больше, тем лучше. По-настоящему комфортная работа с Windows 2000/XP и Cubase SX начинается тогда, когда присутствует хотя бы 512 Мбайт оперативной памяти.
4. Желательно иметь более одного дискового накопителя (hard disk drives). На одном накопителе следует держать операционную систему и программы, на втором — хранить проекты Cubase SX (включая аудиофайлы). Третий накопитель тоже не будет лишним. На нем можно хранить библиотеки сэмплов, используемые программными сэмплерами.
5. В Windows 2000/XP следует отключить протоколирование (logs) дискового трафика. Для этого в командной строке нужно набрать команду diskperf — n <Enter>.
6. Для всех дисков с файловой системой NTFS следует отключить индексирование: в свойствах дисков отключить опцию Allow Indexing Servicing.
7. При использовании дисков EIDE необходимо проследить, чтобы в Windows 2000/XP была включена поддержка режима UDMA 66/100. Обратите на эту деталь особое внимание, если у вас чипсет Intel. Естественно, сами накопители должны поддерживать режим UDMA 66/100. В системном реестре Windows 2000/XP, в разделе HKEY_LOCAL_ MACHINE\System\CurrentControlSet\ Control\Class\{4D36E96A-E325- llCE-BFC1-08002BE10318}\0000 должна присутствовать переменная "EnableUDMA66" типа DWORD. Если такой переменной нет — ее следует создать. Значение переменной должно быть равно 1. Эта переменная включает поддержку и UDMA 66, и UDMA 100. После внесения изменений в реестр компьютер нужно перезагрузить.
8. Наша восьмая рекомендация не имеет никакого отношения к быстродействию, но ее также лучше выполнить. Средствами Windows отключите озвучивание всевозможных событий (вывод сообщений, запуск приложений и т. п.). Соответствующая звуковая схема называется "No Sounds". При работе с музыкой и звуком отсутствие постороннего "шума" имеет важное значение.
Существует еще масса полезных советов, позволяющих из компьютера "выжать" всю производительность до последней капли. Все советы сводятся к отключению всех лишних с точки зрения музыкальных программ функций и служб операционной системы. Это приводит к существенному ограничению функциональности компьютера (например, к невозможности работать в Internet или локальной сети). Но чудес не бывает, и при удачном стечении обстоятельств вам, может быть, удастся таким образом увеличить производительность в лучшем случае на 1—2%. При этом ваш персональный компьютер разучится заниматься чем-либо другим, кроме звукозаписи. Поэтому еще один наш совет таков: не мучайте свой компьютер слишком сильно. Если для работы вам серьезно не хватает быстродействия, не тратьте свое время и нервы на копание в системном реестре, а просто сходите в магазин и купите новые компоненты: процессор, материнскую плату, память, диски.
Возвратимся в Cubase SX. Командой главного меню Devices > Device Setup откройте диалоговое окно Device Setup, выберите раздел VST Muititrack и вкладку Setup (рис. 2.20).
На данной вкладке доступны основные параметры звукового движка (VST Engine) Cubase SX.
Number of Disk Buffers — количество буферов, используемое при операциях чтения/записи. Disk Buffer Size — размер одного дискового буфера. Данные параметры следует рассматривать совместно. Но если вы задумаете проводить эксперименты по их изменению, то начинать нужно с изменения параметра Number of Disk Buffers. Уменьшение количества и размера буферов влечет за собой возрастание нагрузки на процессор. Увеличение количества и размера буферов ведет к пропорциональному увеличению расходования оперативной памяти.

Рис. 2.20. Диалоговое окно Device Setup, раздел VST Multitrack

В списке ASIO Driver нужно выбрать драйвер, который будет использоваться для ввода/вывода цифрового звука. Как мы уже говорили, здесь возможны следующие варианты:

  • ASIO Full Duplex DirectX Driver или ASIO DirectX Driver — программный адаптер, который позволит Cubase SX работать со звуковой картой посредством DirectX;
  • ASIO Multimedia Driver программный адаптер, который позволит Cubase SX работать со звуковой картой посредством ММЕ;
  • драйвер звуковой карты, поддерживающий AS1O — позволит Cubase SX работать со звуковой картой напрямую.

Как будет называться элемент списка ASIO Driver, соответствующий последнему варианту, — зависит от производителя. Но, как бы там ни было, этот вариант является предпочтительным. В нашем случае ASIO-драйвер звуковой карты SB Audigy называется "Creative ASIO". При переключении звукового драйвера возникнет окно с предупреждением. В этом окне свои намерения следует подтвердить нажатием кнопки Switch (переключить).
Кнопкой Control Panel открывается панель управления аудиоинтерфейса звуковой карты. Данная панель не является окном Cubase SX, а относится к программному обеспечению звуковой карты. Соответственно, у различных звуковых карт могут быть разные панели управления аудиоинтерфейсом (рис. 2.21, а, б).

Рис. 2.21. Панели управления аудиоинтерфейсами звуковых карт SB Audigy (a) и M-Audio Audiophile 2496 (б)

Тем не менее, общим в них всегда является наличие параметра Latency (задержка при вводе/выводе звуковых данных), напрямую связанная с размером буфера, через который происходит обмен звуковыми данными. Чем меньше задержка, тем лучше. Однако при малых значениях задержки могут возникнуть проблемы, которые будут ощутимы на слух в виде хруста и выпадений звука. Причины возникновения этих проблем могут быть различными. Самая банальная — нехватка быстродействия системы: звуковая карта готова выводить звуковой поток через маленький буфер, обеспечивающий маленькую задержку, однако вся остальная система (процессор, жесткий диск, память, программы) не в состоянии обеспечивать непрерывный вывод звукового потока при таком размере буфера. Бывает и такое, что описанные проблемы возникают на самом современном компьютере. В этом случае проблема, скорее всего, заключается в драйверах самой звуковой карты. Нужно скачать с сайта производителя самые свежие драйверы, в которых, возможно, уже выявлены и устранены недостатки.
В любом случае значение Latency подбирается опытным путем. Устанавливаете наименьшее значение Latency. Воспроизводите проект, содержащий аудиотреки и использующий VST-плагины. Если слышен хруст, треск и т. п., то немного увеличиваете Latency. Повторяете опыт. И так до тех пор, пока проблемы с выводом звука не будут устранены.
Вернемся к рассмотрению окна диалога Device Setup (раздел VST Multitrack, вкладка Setup), показанного на рис. 2.20.
В списке Clock Source выбирается источник синхронизации. Для мультимедийных звуковых карт в качестве такого источника может использоваться только внутренний генератор самой карты. В данном списке ему соответствует элемент Internal. Профессиональные карты, ориентированные на работу в составе цифровой студии, могут использовать синхросигналы от других устройств.
Введение синхронизирующего сигнала, общего для всех цифровых устройств (включая компьютер), в студии используется для борьбы с джиггером. Джиттер (jitter) — небольшие случайные изменения местоположения фронтов импульсов прямоугольной формы (дрожание фазы), посредством которых передаются цифровые сообщения. В результате возникновения джиггера звуковые отсчеты следуют во времени неравномерно. Источник джиттера — нестабильность тактовых генераторов и систем фазовой автоподстройки частоты (при выделении синхросигнала из общего потока цифровых данных, передаваемых последовательно).
Источником единого синхросигнала может быть одно из устройств. Его называют ведущим (master). Остальные устройства — ведомые (slave) — отключают свой собственный генератор и используют синхросигнал ведущего. Такая система синхронизации называется master-clock.
Итак, в зависимости от возможностей вашей звуковой карты в списке Clock Source могут быть доступны и другие элементы, отличные от Internal. Однако не исключен и такой вариант, что выбор источника синхронизации может осуществляться на панели управления аудиоинтерфейсом звуковой карты. В качестве примера можно привести панели управления аудиоинтерфейсом звуковой карты М-Audio Audiophile 2496 (рис. 2.21, б). В группе Master Clock выбирается источник синхронизации: внутренний генератор или синхросигнал от внешнего устройства, поступающий через интерфейс S/PDIF. Вновь вернемся к рассмотрению диалогового окна Device Setup (раздел VST Multitrack, вкладка Setup), показанного на рис. 2.20, и постараемся больше не перескакивать на сопутствующие темы. Перечислим доступные опции.
Release ASIO Driver in Background — освобождать драйвер звуковой карты, когда Cubase SX теряет фокус (когда активно окно другой программы или приложение Cubase SX свернуто). На практике это означает невозможность воспроизведения/записи проекта, когда Cubase SX находится в фоновом режиме, что не всегда удобно. Когда драйвер звуковой карты освобожден, то его могут использовать другие приложения.
Direct Monitoring — включить режим ASIO Direct Monitoring (о назначении режима см. в разд. 2.7}. Данный режим должен поддерживаться ASIO-драйвером звуковой карты. Например, драйвер звуковой карты M-Audio Audiophile 2496 поддерживает данный режим, но на панели управления, вид которой показан на рис. 2.21, б, опция Disable Control of the Monitor Mixer and Patchbay/Router by Audio Applications должна быть отключена.
Кнопка Expert (рис. 2.20) открывает диалоговое окно VST Engine Expert Settings (рис. 2.22). То есть подразумевается, что параметры звукового движка, доступные в данном окне, могут изменять только эксперты. Мы приведем описание этих параметров, но если вы экспертом себя не считаете, то ничего трогать не надо.

Рис. 2.22. Диалоговое окно VST Engine Expert Settings

Audio Priority — приоритет звукового движка по сравнению с остальными программными компонентами Cubase SX. Если Cubase SX используется в основном в качестве MlDI-секвенсора, управляющего MIDI-устройствами, приоритет звукового движка можно понизить вплоть до значения Low. Если же вы собираетесь использовать Cubase SX исключительно в качестве мультитрекового звукового редактора, то приоритет звукового движка можно повысить до Very High.
Preload Amount — размер буфера, расположенного в оперативной памяти и предназначенного для хранения звуковых данных. В данном буфере хранятся звуковые данные фрагмента проекта, соответствующего интервалу [текущая позиция проекта, текущая позиция проекта + Preload Amount].
Non Buffered Read и Non Buffered Write — небуферизированное чтение и запись звуковых данных, соответственно. Опции можно отключить в том случае, если проект базируется исключительно на применении грувов и лупов (см. главу 12).
Lower Latency — режим минимальной задержки отклика программы на действия пользователя. Отключение данной опции оправдано только в том случае, если устранить выпадения звука и треск при воспроизведении проекта иными способами не представляется возможным.
Multi Processing — поддержка многопроцессорности. Данная опция доступна, если в вашей системе два и более процессоров, или один процессор Pentium 4 НТ. Естественно, операционная система должна поддерживать мультипроцессорность. У Windows 2000/XP с этим все в порядке. Честно говоря, мы не можем себе представить ситуацию, при которой опцию Multi Processing следовало бы отключить.
Нажатием кнопки Default все параметры, доступные в окне VST Engine Expert Settings, устанавливаются в состояние, принятое по умолчанию.
Дополнительные параметры звукового движка доступны в разделе VST окна Preferences, вызываемого командой главного меню File > Preferences (см. разд. 2.7).


2.6. Входы и выходы виртуальной звуковой студии, обеспечение пространственного панорамирования

У Cubase SX, как и полагается звуковой студии, имеются входы и выходы. Входы (VST Inputs) — это аудиопорты, через которые звуковые данные поступают в Cubase SX из внешнего мира (через аудиоинтерфейс). Выходы (VST Outputs) — выходные аудиопорты, через которые Cubase SX выводит результаты своей работы. Количество входов и выходов зависит от возможностей оборудования и его драйверов. Например, при использовании обыкновенных (не ASIO) драйверов для звуковой карты SB Audigy доступен всего один стереофонический вход и один стереофонический выход. При использовании ASIO-драйверов количество стереофонических входов возрастает до 6, а количество выходов до 7. Правда, не все пары выходов следует считать стереопарами, но об этом чуть позже.
Командой главного меню Devices > VST Inputs откройте диалогового окно VST Inputs, показанное на рис. 2.23. Данное окно содержит список доступных входных портов. Порты разбиты по парам, хотя эту группировку можно считать условной. Каждый из портов можно рассматривать как независимый монофонический канал. В графе Port перечислены названия портов в терминологии драйвера звуковой карты. В графе Active расположены кнопки включения портов. Включить порт — значит сделать его доступным из проекта. Включать порты можно только попарно — одна кнопка включения на каждую пару портов, причем неважно, являются ли эти порты стереопарой или нет. В графе Label перечислены названия портов, используемые в проекте Cubase SX. По умолчанию портам присваиваются следующие названия: IN 1, IN 2 и т. д. Однако это не совсем удобно, т. к. при большом количестве портов можно запутаться в их назначении. Поэтому имеет смысл переименовать порты так, как вам это будет удобно.

Рис. 2.23. Диалоговое окно VST Inputs

Особое внимание хочется обратить на название портов в поле Port. В этих названиях скрыто назначение порта. Например, Mix (Pre-EQ) L/R означает, что сигнал данного порта "снимается" с микшера звуковой карты SB Audigy до того, как он пройдет обработку эквалайзером. Или же SPDIF In L/R — означает, что данный порт соответствует интерфейсу S/PDIF In. Было бы правильным, если бы вы сразу определились, какие порты вам понадобятся (их следует включить), а какие нет (их следует оставить выключенными).
Отключение портов, задействованных в проекте, приводит к сбросу соответствующих настроек аудиотреков. В этом случае будет выдано предупреждение, и вы можете отказаться от затеи.
Командой главного меню Devices > VST Outputs или нажатием клавиши <F4> откройте диалоговое окно VST Outputs, показанное на рис. 2.24.
Внешне это окно похоже на микшер. Однако в действительности ничего общего с микшером здесь нет: не происходит микширования как такового В данном окне VST Outputs представлены независимые выходные шины В конечном счете, все сигналы с аудиотреков и VST-плагинов будут поступать на эти шины. На какие именно — определяется в свойствах треков или шин для подключения эффектов параллельного действия.

Рис. 2.24. Диалоговое окно VST Outputs

Каждой выходной шине в окне VST Outputs соответствует своя линейка (strip). Количество шин равно половине числа доступных выходных портов: каждая из шин соответствует паре монофонических выходных портов. В нижней части каждой из шин присутствуют объединенные названия выходных портов (например Wave/МРЗ 1+2 на рис. 2.24). Если щелкнуть на названии пары выходных портов, то появится меню, содержащее все доступные пары портов. С помощью этого меню можно переназначить данную шину на другую пару портов. Однако вам не удастся добиться того, чтобы две или более шин были настроены на одни и те же порты. Как только вы переназначаете одну шину, происходит переназначение другой шины (которая раньше работала с выбранными портами) на освободившуюся пару портов.
Так же, как и в случае с входными аудиопортами, названия выходных портов несут определенный смысл. В качестве примера рассмотрим выходные порты, доступные при использовании ASIO-драйвера звуковой карты SB Audigy.
Порты Wave/МРЗ 1+2, Wave/МРЗ 3+4, Wave/МРЗ 5+6 соответствуют шести каналам системы объемного звучания 5.1. Причем сигналы, выводимые из Cubase SX через эти порты, будут проходить дальнейшую обработку эффект-процессором звуковой SB Audigy (эффекты реверберации, хоруса и т. д.). Если звуковая карта настроена на работу со стереофонической аудиосистемой, то все перечисленные порты будут соответствовать одному и тому же физическому линейному выходу звуковой карты.
Порты Rear L/R, Front L/R, Center LFE тоже соответствуют шести каналам системы объемного звучания 5.1. Однако в данном случае сигналы, выводимые из Cubase SX через эти порты, не будут проходить обработку эффект-процессором звуковой карты SB Audigy. Существует одно исключение: если звуковая карта настроена на работу со стереофонической аудиосистемой, то все перечисленные порты будут соответствовать одному и тому же физическому линейному выходу звуковой карты. Но прежде чем сигналы попадут на этот выход, их фаза будет изменена в соответствии с тем, к какому каналу системы 5.1 они относятся. В результате, работая даже в наушниках, вы можете использовать пространственное панорамирование. Те звуки, которые должны звучать "сзади", будут звучать "как будто сзади". Единственное замечание, которое мы хотим сделать относительно SB Audigy от себя лично, — если вы работаете в наушниках, то в настройках карты задавайте конфигурацию 2 Speakers (две колонки), а не Headphones (наушники), поскольку в последнем случае звук будет исковеркан известным только фирме Creative образом.
Последний выходной порт SB Audigy называется Reverb. Сигнал, посланный на этот выходной порт, будет обработан эффектом реверберации, реализованным аппаратно, причем в общий микс звуковой карты вернется только обработанный (wet) сигнал. Благодаря наличию этого выхода, вы можете посылать сигнал аудиотреков на аппаратный эффект-процессор звуковой карты и пользоваться эффектом реверберации, реализованным аппаратно. Единственная неприятность — данный эффект является стереофоническим и при использовании системы 5.1 будет звучать только в левом и правом фронтальных каналах.
Может возникнуть вопрос: почему мы так часто упоминаем в своих примерах звуковые карты семейства SoundBlaster? Некоторые нас критикуют за это, оценивая наш профессионализм по стоимости звуковых карт, которые упоминаются. Мы не будем оправдываться перед ними, а вам по секрету скажем, что, несмотря на все имеющиеся недостатки, старшие модели семейства SoundBlaster по своим характеристикам приближаются к полупрофессиональным устройствам, благодаря чему пользуются большой популярностью. А мы рассчитываем на то, чтобы проверка наших примеров на практике была доступна если не всем читателям, то хотя бы большинству.
А теперь вернемся к рассмотрению окна VST Outputs, показанного на рис. 2.24. Если вы в дальнейшем собираетесь применять пространственное панорамирование и многоканальную систему, то имеет важное значение порядок, в котором порты будут распределены по шинам. Наши рекомендации для системы 5.1 и звуковых карт семейства SBAudigy/Audigy 2 таковы:

  • первая слева шина должна соответствовать левому и правому фронтальным каналам;
  • вторая шина должна соответствовать левому и правому тыловым каналам;
  • третья шина должна соответствовать центральному и сабвуферному каналам.

Все перечисленные шины должны быть включены. Включение/выключение шин осуществляется с помощью кнопок [image] . Заметьте, первую шину отключить невозможно — у нее нет кнопки [image] . У каждой из шин имеются фейдеры громкости, индикаторы уровня и перегрузки. В дальнейшем в случае возникновения перегрузки уровень сигнала можно будет уменьшить. С помощью кнопки [image] (Linked/Unlinked Fades) включается режим, при котором оба феидера каждой из пар выходных каналов работают взаимосвязанно. Над фейдерами располагаются поля, в которых в числовой форме отображаются пиковые значения уровня сигнала.
По умолчанию шинам присваиваются названия BUS 1, BUS 2 и т. д. Названия можете изменить на удобные для вас.
Дальше начинаются вещи, логика которых с трудом доступна пониманию, но мы все же попытаемся их объяснить. Виртуальный микшер Cubase SX устроен таким образом, что в качестве выходного порта для любого аудио-трека или шины может быть выбрана любая из выходных шин VST Outputs. Но у микшера Cubase SX имеется мастер-секция, куда вроде бы должны, в конечном счете, сводиться все потоки цифрового звука. Однако гарантированно в мастер-секцию попадает сигнал только с первой выходной шины. Остальные выходные шины могут быть никак не связаны с мастер-секцией. Из интерфейса Cubase SX не следует логика маршрутизации сигналов. Может показаться, что сигналы с выходных шин попадают в мастер-секцию. Но тогда возникает противоречие: из интерфейса окна VST Outputs следует, что выходные шины являются последним перевалочным пунктом, после которого сигналы покидают Cubase SX через выходные аудиопорты. Если же считать, что сначала сигналы проходят мастер-секцию, а потом уже попадают на выходные шины, то как тогда объяснить следующую вещь: индикаторы уровня сигнала мастер-секции реагируют на изменения уровня сигнала средствами окна VST Outputs?
Надеемся, что мы вас уже достаточно убедили в серьезности проблемы. А теперь дадим ответы на поставленные вопросы.
Все-таки Cubase SX — это программа, виртуальная реальность. А в VR (virtual reality), как известно, может твориться все, что угодно. Микшер Cubase SX не является прямой аналогией аппаратного микшера, он лишь заимствовал некоторые черты аппаратного микшера. Поэтому мы предлагаем следующее объяснение "непонятным вещам". Мастер-секция объединяет в себе одну или несколько выходных шин логически. То есть, если выходная шина является участником мастер-секции микшера, то это означает, что кроме собственного регулятора уровня сигнала над этой шиной, появляется дополнительный контроль со стороны мастер-секции. На рис. 2.24 оба канала первой шины имеют метки L и R. Это значит, что в данный момент именно эти каналы находятся под контролем мастер-секции, которая сконфигурирована для работы в формате Stereo: L — левый канал, R — правый.
При экспорте проекта в звуковой файл, могут экспортироваться только те каналы, которые соответствуют выходным шинам, объединенным в мастер-секции. Выходные шины, не включенные в мастер-секцию, можно использовать на свое усмотрение. Например, с их помощью можно отправлять сигналы с аудиотреков на внешнюю обработку (аппаратным оборудованием класса Hi-End), а после обработки возвращать в общий микс через входные порты (VST Inputs). Если звуковая карта имеет цифровой интерфейс и поддерживает синхронизацию master-clock, то обработку треков Cubase SX внешним высококлассным цифровым оборудованием можно провести вообще без каких-либо потерь из-за ЦАП-АЦП, джитера и прочих неприятностей.
Командой главного меню Devices > VST Master Setup открывается окно VST Master Setup, показанное на рис. 2.25. В этом окне вы можете задать конфигурацию мастер-секции.

Рис. 2.25. Диалоговое окно VST Master Setup

В списке Presets следует выбрать формат, в котором вы будете работать: Stereo (рис. 2.25, a), Quadro (4 канала: 2 фронтальных, 2 тыловых), Surround (4 канала: 3 фронтальных, 1 тыловой), Standard 3:2 (5 каналов: 3 фронтальных, 2 тыловых), 5.1 Surround (рис. 2.25, б), 5.1 SMPTE/ITU, 5.1 Film Alternative. Последние три формата являются разновидностями формата 5.1 и отличаются друг от друга порядком следования каналов. Справа от списка условно отображается расположение акустических систем для выбранного формата (редактировать его невозможно). Основным элементом окна VST Master Setup является список каналов, включающий в себя три графы:

  • # — номер канала по порядку;
  • Label — метка канала, которая отображается на линейках выходных шин в окне VST Outputs;
  • Name — логическое название канала;
  • Output — выходной канал (реальный канал выходной шины).

Список каналов содержит такое количество и порядок следования каналов, которое соответствует выбранному формату. Вы можете редактировать поля Label и Name, но не можете изменять порядок следования каналов. Вы не можете переназначать выходные каналы. Это происходит автоматически: программа заносит в графу Output каналы включенных выходных шин в том порядке, в каком они расположены в окне VST Outputs. Поэтому и следует обращать внимание на порядок, в котором выходные порты назначены шинам в окне VST Outputs. Иначе могут возникнуть казусы. Например, если в окне VST Outputs включен всего один канал, а мастер-шина настроена на работу в формате 5.1, то сигналы всех шести логических каналов будут выводиться на одну стереопару единственной включенной выходной шины. Понятно, что в такой конфигурации ни о каком пространственном панорамировании и речи быть не может.
Если вы выполнили нашу рекомендацию относительно порядка следования выходных портов в окне VST Outputs для формата 5.1 и звуковой карты SBAudigy/Audigy 2, то теперь в окне VST Master Setup следует выбрать формат 5.1 Surround. При этом все станет на свои места, и вы на практике сможете сводить шестиканальный звук.
Для того чтобы использовать пространственное панорамирование в формате 5.1, достаточно иметь любую звуковую карту, у которой имеется 6 независимых выходных каналов или 3 стереофонических выхода, доступных в окне VST Outputs. Пяти каналам должны соответствовать пять мониторов (в идеале одинаковых), а шестому каналу — сабвуфер. Наличие или отсутствие возможности у звуковой карты декодировать поток данных в формате Dolby ® Digital значения не имеет.
Наверное, в этом месте будет уместно рассказать о том, как в Cubase SX реализована поддержка пространственного панорамирования. В поставку Cubase SX входит специальный плагин, называемый SurroundPan. Если выбрать его в качестве выходного порта аудиотрека, то для данного трека станут доступны очень удобные графические средства, позволяющие расположить источник звука, соответствующий данному треку в нужной точке виртуального пространства, окружающего слушателя. Фактически SurroundPan представляет собой специализированный микшер. На вход этого микшера подается сигнал с выхода аудиотрека (моно или стерео). Выходы микшера SurroundPan (от 2 до 6 каналов в зависимости от настроек окна VST Master Setup) подключены к мастер-секции микшера. В соответствии с настройками пользователя, выполненными посредством графических средств, происходит распределение исходных сигналов между выходными каналами SurroundPan. Самое любопытное заключается в том, что плагин SurroundPan имеет 8 выходных каналов. То есть SurroundPan позволяет осуществлять пространственное панорамирование в формате 7.1. По всей видимости, имеет место умышленное ограничение возможностей Cubase SX. Единственное разумное на наш взгляд объяснение этому — маркетинговые соображения, по которым если пользователю позарез понадобится осуществить сведение в формате 6.1 или 7.1, то он будет вынужден приобрести другой программный продукт фирмы Steinberg — Nuendo. Но вас это не должно расстраивать. Форматы 6.1 и 7.1 пока еще нельзя считать потребительскими. Из всех имеющихся носителей многоканального звука на звание "потребительского формата" может претендовать только DVD. Звук на DVD может храниться в разных форматах, однако один трек может быть не более чем 6-канальным, что соответствует формату 5.1. Формат Dolby ® Digital EX тоже подразумевает присутствие всего 6 физических каналов. Хотя, конечно, поддержка форматов 6.1 и 7.1 в Cubase SX не помешала бы.
Не надолго вернемся к окну VST Master Setup (рис. 2.25). Благодаря наличию кнопки Store (сохранить), может показаться, что имеется возможность добавления собственных форматов в список Presets. Но, к сожалению, это не так. Все, что вы можете сделать, — сохранить изменения, полученные путем переименования полей Label и Name, в своем собственном пресете. Можно как угодно переименовывать метки и логические названия каналов, но выйти за пределы перечисленных форматов вам не удастся. Единственный положительный момент заключается в том, что с помощью кнопки Remove можно удалять только пользовательские пресеты. Представляете, как было бы обидно, если бы вы случайно удалили заводские пресеты. начиная от Stereo и заканчивая 5.1 Film Alternative. Ведь пользовательские пресеты можно создавать только на базе "заводских". Что бы вы тогда делали? Переустанавливали Cubase SX? ;-)


2.7. Мониторинг, дополнительные параметры звукового движка VST

В осуществлении записи "живой" музыки и вокала следует решить две проблемы: мониторинг и "доставка" аккомпанемента вокалисту/исполнителю.
Если вы не собираетесь осуществлять запись с микрофона — вам проще, остается только одна проблема: мониторинг.
Под мониторингом подразумевается акустический контроль процесса звукозаписи на всех этапах: вы должны слушать то, что записываете, а также результаты обработки звука, сведения и мастеринга. Понятно, что мониторинг подразумевает контроль в режиме реального времени. Простите за каламбур, но для мониторинга нужны мониторы — высококлассные акустические системы. В отличие от бытовых акустических систем, студийные мониторы обладают условно линейной АЧХ. "Условно" потому, что получить идеальную прямую линию АЧХ в реальной жизни невозможно. Приведем кратчайшую классификацию мониторов. Мониторы бывают дальней и ближней зоны. Для домашней студии больше подходят мониторы ближней зоны, т. к. они имеют небольшие размеры. Кроме того, в профессиональных студиях большая часть сведения выполняется на мониторах ближней зоны и только небольшая часть работы — на мониторах дальней зоны.
Мониторы бывают пассивными и активными. Активные мониторы, в отличие от пассивных, содержат в своем корпусе усилитель мощности. Лучшим решением для домашней студии можно считать небольшие активные мониторы ближней зоны. На начальной стадии обучения современным технологиям звукозаписи в качестве мониторов можно использовать головные мониторы (высококачественные наушники с линейной характеристикой) или акустическую систему домашнего музыкального центра. При этом следует отключить встроенный эквалайзер и всевозможные системы, влияющие на тембр воспроизводимой фонограммы. На худой конец, можно использовать компьютерную акустическую систему средней или высшей стоимостной категории.
При работе в формате стерео достаточно наличие двух мониторов. Мониторы должны располагаться перед вами таким образом, чтобы вы находились в зоне наибольшего стереоэффекта: в одном из углов равностороннего треугольника, в двух из которых расположены акустические системы, а в третьем вы.
При работе в формате 5.1 потребуется 5 мониторов и 1 сабвуфер. О расположении мониторов системы 5.1. мы рассказали в разд. 1.12.3.
При записи с микрофона вокала, акустических инструментов, электрогитары (комбик-микрофон) звучание аккомпанемента не должно попадать в микрофон. В профессиональных студиях эта проблема решается за счет использования как минимум двух звукоизолированных помещений, а в домашних студиях — за счет использования головных мониторов. Причем вокалистам будет удобнее работать с открытыми наушниками. В этом случае они будут слышать себя не только через наушники, но и через окружающее акустическое пространство.
Для мониторинга вокала и любых внешних инструментов лучше использовать внешний мониторинг. При внешнем мониторинге задействуется внешний аппаратный микшер или микшер звуковой карты. Сигнал от микрофона должен следовать по двум маршрутам. Первый маршрут: от микрофона на входной порт Cubase SX для последующей записи на аудиотрек. Само собой разумеется, в данном сигнале не должен присутствовать аккомпанемент. Второй маршрут: от микрофона в микшер, где микрофонный сигнал должен смешиваться с сигналом аккомпанемента, воспроизводимого в Cubase SX; от микшера в наушники вокалиста/исполнителя. В идеале для каждого вокалиста/исполнителя в группе должен создаваться свой микс. В случае внешнего мониторинга Cubase SX не принимает никакого участия в самом процессе мониторинга и выполняет лишь роль цифрового магнитофона.
В Cubase SX имеется поддержка режима мониторинга, называемого ASIO Direct Monitoring. Данный режим похож на внешний мониторинг тем, что Cubase SX по-прежнему выступает в роли цифрового магнитофона: сигнал не проходит сквозь входные-выходные порты Cubase SX наружу. Однако Cubase SX может косвенно принимать участие в формировании мониторно-го микса: имеется возможность управлять микшером звуковой карты непосредственно из Cubase SX. Осуществление ASIO Direct Monitoring возможно только в том случае, если данный режим поддерживается ASIO-драйвером звуковой карты. Поддержка спецификации ASIO 2.0 при этом является необходимым условием, но недостаточным. Включение режима осуществляется в разделе VST Multitrack окна Device Setup, вызываемого командой Device > Device Setup (см. разд. 2.5).
Еще один вид мониторинга, поддерживаемый в Cubase SX, — внутренний мониторинг. В данном режиме сигнал от внешних источников проходит "сквозь" Cubase SX: через входные порты поступает на аудиотреки, в режиме реального времени проходит обработку подключенными плагинами, через выходные порты покидает Cubase SX. В режиме внутреннего мониторинга Cubase SX может выступать в роли процессора эффектов, работающего в режиме реального времени. У данного режима несколько достоинств. Например, вы еще до начала записи можете получить представление о том, как будет звучать записанная партия с учетом подключенных эффектов. Основной недостаток — задержка, возникающая при прохождении сигнала сквозь Cubase SX. При использовании внешнего мониторинга задержка практически отсутствует: сигнал от микрофона через микшер в наушники распространяется со скоростью, немногим уступающей скорости света. Задержка при внутреннем мониторинге может варьироваться от нескольких миллисекунд до нескольких сотен миллисекунд, в зависимости от настроек аудиоинтерфейса. Однако в большинстве случаев задержку в несколько миллисекунд можно считать несущественной.
Для того чтобы внутренний мониторинг был возможен, драйвер звуковой карты должен поддерживать режим full duplex (одновременную запись и воспроизведение). Для того чтобы сократить задержку до минимума, драйвер звуковой карты должен поддерживать ASIO.
У внутреннего мониторинга Cubase SX в свою очередь также имеются различные режимы работы. Командой главного меню File > Preferences откройте окно Preferences (предпочтения), в левой части окна выберите раздел VST. В правой части окна будут доступны дополнительные параметры звукового движка. Среди них имеется список Auto Monitoring (рис. 2.26).

Рис. 2.26. Окно диалога Preferences (раздел VST)

В данном списке вы можете выбрать один из режимов внутреннего мониторинга:

  • Manual — ручное включение внутреннего мониторинга нажатием соответствующей кнопки аудиотрека (см. разд. 4.2.1);
  • While Record Enabled — мониторинг будет включаться автоматически при включении атрибутов Record Enable аудиотреков;
  • While Record Running — мониторинг будет автоматически включаться только во время записи;
  • Tapemachine Style — мониторинг будет работать в режиме остановки и в режиме записи, а в режиме воспроизведения он будет отключаться.

Перечислим остальные дополнительные параметры звукового движка.
Параметр Scrub Response (Speed) — время отклика инструмента Scrub (см. разд. 4.4.2).
Индикаторы уровней сигналов Cubase SX могут работать в режиме индикации пиков. При этом горизонтальными черточками будет отображаться максимальный уровень сигнала. Параметр VU-Meter Peak's Hold Time определяет время, по прошествии которого показания этих черточек будут сбрасываться.
Опция Preload Waves Plugins on Startup должна быть включена в том случае, если вы собираетесь применять плагины фирмы Waves Ltd. (http://www.waves.com).


2.8. Настройка метронома

Метроном позволяет исполнителю на слух синхронизировать свою игру или пение с аккомпанементом. Пользуясь метрономом, некоторые партии можно записывать даже при отсутствии аккомпанемента.
Для того чтобы включить метроном, воспользуйтесь командой главного меню Transport > Metronome On. Командой главного меню Transport > Metronome Setup вызовите диалоговое окно Metronome Setup, показанное на рис. 2.27. В этом окне метроном настраивается таким образом, чтобы вам было удобно им пользоваться.

Рис. 2.27. Диалоговое окно Metronome Setup

Первым делом вы должны выбрать источник звука. Если установить флажок MIDI Click, то сигналы метронома будут генерироваться MIDI-системой (тем синтезатором, порт которого будет выбран в раскрывающемся списке MIDI Output). При установленном флажке Audio Click звук метронома формируется специальным генератором.
Если выбран вариант MIDI Click, то можно установить следующие параметры метронома:

  • Channel — MIDI-канал, по которому синтезатору будут передаваться сообщения от формирователя сигналов метронома. По умолчанию установлен канал № 10, в спецификации GM соответствующий ударным инструментам;
  • High Note — инструмент, звуком которого будет воспроизводиться сигнал метронома, соответствующий сильной доле такта;
  • High Velocity — громкость сигнала, соответствующего сильной доле такта;
  • Low Note — инструмент, звуком которого будут воспроизводиться сигналы метронома, соответствующие слабым долям такта;
  • Low Velocity — громкость сигнала, соответствующего слабым долям такта.

Если выбран вариант Audio Click, то для регулировки слайдером Volume доступна только громкость звучания сигналов метронома.
Если установлен флажок Precounter, то перед началом записи будет производиться предварительный отсчет метрономом. Это позволяет участникам сеанса записи сконцентрироваться, а исполнителям заранее уловить темп и ритм произведения.
В поле Precount Bars устанавливают количество тактов, предшествующих началу записи, в которых будет производиться предварительный отсчет метрономом. Например, если Precount Bars = 2, то когда вы нажмете на транспортной панели кнопку Record, метроном отсчитает два такта, и только после этого начнется запись.
Если установлен флажок From Master Track, то ритм (музыкальный размер) и темп предварительного отсчета будут сформированы на основе данных, имеющихся на Tempo Track.
Если установлен флажок Use Signature, то музыкальный размер предварительного отсчета вы сможете задать в поле ввода. Для изменения числителя дроби нужно пользоваться стрелочками, расположенными по левую сторону поля ввода, знаменателя — по правую. Имейте в виду, что этим вы зададите только размер предварительного отсчета. Как только начнется запись или воспроизведение, управление метрономом перейдет к Tempo Track, а музыкальный размер, в котором будет работать метроном, будет определяться содержимым соответствующего поля ввода на транспортной панели.
В группе Click during вам следует определить условия, при которых будет слышен звук метронома (во время записи — Record и/или во время воспроизведения — Play).
Если установлен флажок Use Count Base, то в соседнем с ним поле ввода вы можете для метронома установить специфический музыкальный размер, не совпадающий с музыкальным размером проекта. Например: в проекте установлен размер 4/4, а в поле Use Count Base — 1/8. В такой ситуации метроном будет отбивать не четвертные доли, а восьмые.
Отметим, что сигналы метронома слышны участникам работы над проектом, но не записываются на MIDI- и аудиотреки.


2.9. Синхронизация Cubase SX с внешними устройствами

Если вы предполагаете использовать Cubase SX в составе студии, оснащенной различными устройствами, требующими синхронизации (магнитофоны, видеомагнитофоны, секвенсоры и др.), следует принять соответствующие меры и настроить параметры синхронизации в Cubase SX.
Вообще говоря, данный раздел следует считать обзорным. Он полезен, в первую очередь, для тех, кто имеет слабое представление о технологиях, используемых в аудио/видеостудиях.
Нужно понимать, что синхронизация — понятие многообразное. В разд. 2.5 мы затрагивали вопрос синхронизации аудиоинтерфейса компьютера с внешним оборудованием. В том случае речь шла о синхронизации звуковых потоков с точностью до одного звукового отсчета (sample) посредством master-clock. В данном разделе мы будем говорить об адресно-временной синхронизации (синхронизации темпа или временных отметок) и синхронизации по управлению (синхронизация транспорта). Пример: если вы подводите указатель текущей позиции Cubase SX к отметке 00:02:10:00 (2 минуты 10 секунд от начала проекта) и запускаете воспроизведение, то на студийном видеомагнитофоне воспроизведение видеоролика должно начаться с этой же отметки.
Cubase SX может выступать в качестве различных с точки зрения участия в процессе синхронизации устройств:

  • Master — ведущее устройство, генерирующее синхросигнал;
  • Slave — ведомое устройство, подстраивающееся под синхросигнал других устройств;
  • одновременно и Master, и Slave — Cubase SX получает синхросигнал от одного устройства и передает его другим устройствам. Для последних Cubase SX является ведущим.

Основные способы адресно-временной синхронизации:

  • Timecode (временной код) — в синхросигнале передаются временные отметки в формате час:минута:секунда:кадр. Временной код позволяет синхронизировать различные студийные устройства с точностью до кадра. Существует множество стандартов временного кода. Например, сигналы стандартов SMPTE (Society of Motion Picture and Television Engineers) и EBU (European Broadcast Union) рассчитаны на передачу через звуковой тракт студии (могут быть записаны на магнитофон). Стандарт МТС (MIDI Time Code) регламентирует передачу временного кода посредством интерфейса MIDI. Синхросигналы формата VITC (Vertical Interval Time Code) хранятся в видеоизображении.
  • MIDI Clock — посредством интерфейса MIDI передаются сигналы для синхронизации темпа секвенсоров.

Для синхронизации транспорта используется протокол ММС (MIDI Machine Control), который, как и следует из названия, тоже передается посредством интерфейса MIDI.
Ни один из перечисленных выше стандартов в принципе не позволяет достичь синхронизации цифровых устройств с точностью до одного звукового отсчета. Решить проблему синхронизации в цифровой студии можно за счет применения и адресно-временной синхронизации (например, МТС), и синхронизации транспорта (ММС), и синхронизации master-clock. Еще одно решение: применение системы синхронизации АРР (ASIO Positioning Protocol), продвигаемой фирмой Steinberg. С помощью данного прокола можно с точностью до сэмпла синхронизировать цифровые устройства (которые должны поддерживать АРР). Если же студия включает в себя еще и аналоговую часть, то синхронизация с аналоговыми устройствами по АРР, конечно же, невозможна. Для синхронизации с ними стоит использовать "традиционные" протоколы и сопутствующее оборудование: SMPTE, МТС и др.
Возвращаемся к освоению Cubase SX. Командой Transport > Sync Setup откройте диалоговое окно Sync Setup, показанное на рис. 2.28.

Рис. 2.28. Диалоговое окно Synchronization Setup

В группе Timecode Source выбирается способ синхронизации по временному коду: None (не использовать временной код вообще), MIDI Timecode, ASIO Positioning Protocol и, наконец, VST System Link (рассмотрению этой системы посвящена глава 15).
В группе Options доступны опции обработки входящего временного кода:

  • Drop Out Time — количество допустимых выпаданий (пропущенных кадров); в случае превышения этого лимита Cubase SX перейдет в режим остановки;
  • Lock Time — минимальное количество успешно принятых кадров временного кода, после которого синхронизация считается достигнутой;
  • Ignore Hours — игнорировать значение полей "час" в коде час:минута:секунда:кадр.

В группе MIDI Time Code Settings выбирается входной MIDI-порт, через который Cubase SX будет получать временной код МТС.
В группе Send MIDI Time Code выбираются выходные MIDI-порты, через которые Cubase SX будет передавать временной код МТС для других устройств.
В группе Send MIDI Clock выбираются, выходные MIDI-порты, через которые Cubase SX будет передавать сигналы MIDI Clock.
В группе Machine Control выбирается, использовать ли синхронизацию транспорта (MIDI Machine Control) или нет (None).
В группе Machine Control Settings выбираются входной MIDI-порт (MIDI Input) и выходной MIDI-порт (MIDI Output), через которые будут приниматься и передаваться управляющие команды ММС.
Может возникнуть вопрос, как же осуществить синхронизацию Cubase SX с внешними устройствами по протоколу SMPTE? Во-первых, существуют конверторы, преобразующие один тип кода в другой (например, SMPTE в МТС и МТС в SMPTE). Поэтому принципиально возможна интеграция Cubase SX в студию, где некоторые из устройств синхронизируются только по SMPTE. Во-вторых, в поставку Cubase SX входит VST-плагин SMPTE Generator, который генерирует код SMPTE. Он позволяет обойтись без конвертора МТС в SMPTE в системе, где Cubase SX выступает в роли ведущего (Master) устройства. Забегая вперед, скажем, что пользоваться этим плаги-ном можно, например, так: он включается в разрыв аудиотрека (в режиме Insert), а в качестве выходного порта аудиотрека выбирается тот аудиопорт, к которому, в конечном счете, подключено ведомое (Slave) устройство. На панели плагина включается кнопка Link, после чего ведомому устройству будет передаваться временной код, соответствующий текущей позиции проекта. Описание VST-плагинов, входящих в поставку Cubase SX, см. в главе 13.
Чтобы задействовать плагин SMPTE Generator по назначению, понадобится звуковая карта с несколькими независимыми выходами. Для этого подойдет даже мультимедийная карта SB Audigy — у нее имеется 6 независимых выходных каналов. Правда, в этом случае вы не сможете работать в формате 5.1, т. к. один из 6 каналов будет занят под передачу кода SMPTE. У SB Audigy 2 независимых каналов уже 7 — вы можете работать в формате 5.1 и использовать SMPTE Generator.


2.10. Применение технологии ТruеТаре

В поставку Cubase SX входит специальный плагин True Tape, имитирующий насыщение магнитной ленты. Звучание аудиотреков, записанных с помощью True Tape, будет похоже на звучание студийных аналоговых магнитофонов.
Командой главного меню Devices > True Tape откройте панель плагина True Таре (рис. 2.29).

Рис. 2.29. Панель ТruеТаре

Чтобы активизировать плагин, следует нажать кнопку [image] . Единственным регулятором задается уровень насыщения магнитной ленты. Вот, сооственно, и все. Если вы оставите данный плагин включенным, то во время записи сигналы, поступающие через входные порты аудиотреков, будут обрабатываться True Tape в режиме реального времени. Естественно, в дальнейшем в любой момент вы можете включить или отключить True Tape.


2.11. Создание проекта и настройка его параметров

Воспользуемся командой главного меню File > New Project, чтобы создать новый проект. Откроется диалоговое окно New Project (рис. 2.30), в котором можно выбрать один из шаблонов, который следует использовать при создании проекта:

  • Empty — проект не будет содержать ни одного трека;
  • Music for Picture PAL — проект будет содержать четыре аудиотрека и настройки, оптимизированные для видеоряда в формате PAL;
  • 24 Track Audio Recorder — проект будет содержать 24 аудиотрека;
  • 16 Track MIDI Sequencer — проект будет содержать 16 MIDI-треков;
  • Music for Picture NTSC — проект будет содержать четыре аудиотрека и настройки, оптимизированные для видеоряда в формате NTSC;
  • 16 Track Surround Mix — проект будет содержать 16 аудиотреков, и у каждого из них в качестве выходного порта будет установлен особый порт SurroundPan (реализованный в виде специализированного плагина), предназначенный для работы с системами объемного звучания;
  • Stereo Mastering Setup — проект будет содержать один аудиотрек и один маркерный трек.

Рис. 2.30. Диалоговое окно New Project

Вне зависимости от того, какой шаблон вы выбрали для создания проекта, впоследствии любые треки можно удалять или, наоборот, создавать, а любые настройки можно изменять. Для "чистоты эксперимента" мы создадим проект на основе шаблона Empty.
После того как вы выберете шаблон и нажмете ОК, возникнет еще одно диалоговое окно Select directory (рис. 2.31). В нем следует выбрать диск или папку, в которой будут располагаться файлы проекта.
Если вы еще только собираетесь создать нужную папку, то с помощью кнопки Create вызовите диалоговое окно Select/Create new directoty (рис. 2.32), а в нем впишите название новой папки и нажмите ОК. Папка будет создана.

Рис. 2.31. Диалоговое окно Select directory

Рис. 2.32. Диалоговое окно Select/Create new directory

После выбора нужной папки и закрытия окна Select directory кнопкой OK проект будет создан. Впоследствии в указанной папке появятся несколько вложенных папок:

  • Audio — исходные звуковые файлы, используемые в проекте;
  • Edits — отредактированные звуковые файлы;
  • Fades — фрагменты звуковых файлов, содержащие переходы громкости (Fade In, Fade Out);
  • Images — индексные служебные файлы, необходимые для ускорения доступа к звуковым файлам.

Сразу после создания проект хранится где-то среди временных файлов. Поэтому чтобы его не потерять, стоит воспользоваться командой File Save и сохранить его в виде файла с заданным именем и известным расположением. При первом вызове команда File Save работает аналогично команде File Save As — открывает окно Save As (рис. 2.33), в котором следует задать путь и название для сохраняемого файла. В принципе, файл проекта может располагаться где угодно. Однако было бы правильнее сохранить его в том же каталоге, в котором будут располагаться все остальные файлы проекта. Расширение файла проекта Cubase SX — CPR.

Рис. 2.33. Диалоговое окно Save As

Итак, файл проекта сохранен. Впоследствии его всегда можно будет загрузить с помощью команды File > Open. Если вы захотите закрыть проект (выгрузить его из Cubase SX), то сделать это можно командой File > Close. Если проект был изменен с момента последнего сохранения, то появится предложение о сохранении проекта. Если с момента последнего сохранения проекта были созданы новые звуковые файлы, а вы отказались сохранить проект, то эти файлы останутся "бездомными", т. к. не существует ни одного проекта, с которым они были бы связаны. Поэтому вам будет предложено или оставить их, или удалить.
Перечислим еще несколько команд подменю File главного меню, смысл которых следует знать на данном этапе изучения Cubase SX:

  • Save Project to New Folder — переместить текущий проект (со всеми входящими в него файлами) в другую папку;
  • Save as Template — сохранить текущий проект в качестве шаблона;
  • Revert — возвратиться к последней сохраненной версии проекта.

Прежде чем приступать к работе с проектом, стоит проверить его основные параметры, а в случае необходимости изменить их. Командой главного меню Project > Project Setup откройте окно диалога Project Setup (рис. 2.34). До сих пор мы говорили только о настройках, влияющих на работу Cubase SX в целом. В данном окне доступны лишь параметры, имеющие отношение только к одному конкретному проекту, который в данный момент является активным.

Рис. 2.34. Диалоговое окно Project Setup

Перечислим параметры, доступные в диалоговом окне Project Setup.
Start — начало проекта, точка начала шкалы времени. Параметр задается в формате часы:минуты:секунды:сотые доли секунды. Параметр важен при синхронизации Cubase SX с внешним аудио/видео/кинооборудованием.
Length — длина проекта. В случае необходимости длина проекта будет увеличиваться автоматически.
Frame Rate — частота кадров. Данный параметр используется в том случае, если Cubase SX синхронизируется с внешними устройствами, причем Cubase SX выступает в качестве источника синхронизации (master). Если Cubase SX выступает в качестве ведомого устройства (slave), то данный параметр выставляется автоматически.
Display Format — формат, используемый для представления шкалы времени в проекте. Этот же параметр доступен на транспортной панели (см. описание доступных форматов в разд, 3.1).
Display Offset — визуальное смещение шкалы времени в отрицательную сторону. Данный параметр позволяет компенсировать значение Start, если оно больше нуля. Допустим, при работе над некой глобальной задачей значение Start пришлось установить равным 00:20:00:00. Задав значение Display Offset тоже равным 00:20:00:00, мы получим то, что на внутренней шкале времени Cubase SX проект будет начинаться с временной отметки 00:00:00:00 (это удобно при работе с проектом). Тем не менее, внешнее оборудование, с которым установлена синхронизация, будет "полагать", что проект начинается на отметке 00:20:00:00, что и требовалось для конкретной задачи.
А на следующие параметры стоит обратить особое внимание.
Sample Rate — частота дискретизации, используемая при записи звука. Перечень доступных частот дискретизации определяется возможностями звуковой карты и возможностями ее драйвера. Следует выбирать такую частоту дискретизации, которая бы соответствовала задачам проекта. Если в качестве конечного носителя фонограммы предполагается использовать CD-audio, то ее следует выбирать равной 44100 Hz (или 88200 Hz). Если же в качестве конечного носителя фонограммы предполагается использовать не только CD-audio, то частоту дискретизации лучше выбирать кратной 48000 Hz (т. е. или 48000, или 96000). В конечном счете, аудиофайлы, полученные в результате сведения проекта, можно будет конвертировать в нужный формат или с помощью Cubase SX, или с помощью программных средств третьих фирм, например, звукового редактора Cool Edit Pro, работу с которым мы подробно описали в книгах [10, 12, 45]. Последний вариант является даже более предпочтительным.
Record Format — разрядность, используемая для представления звуковых отсчетов. Перечень допустимых значений данного параметра не ограничен возможностями оборудования. Например, единственным поддерживаемым ASIO-драйверами звуковых карт SB Audigy/Audigy 2 форматом является 16 bit/ 48000 Hz. Тем не менее, вы можете использовать 24- и 32-битное представления звуковых данных в файлах, записываемых с помощью данной карты. В дальнейшем это позволит свести до минимума погрешности, накапливаемые в ходе обработки аудиотреков. Понятно, что чем больше разрядов используется для представления звуковых данных, тем лучше. Однако чем больше места на диске эти данные будут занимать, тем больше будет дисковый трафик при записи/воспроизведении аудиотреков и тем меньше аудио-треков можно будет использовать в проекте.
В дальнейшем в любой момент вы сможете изменить формат представления звуковых данных с помощью параметров Sample Rate и Record Format. Следует учитывать, что все звуковые файлы, используемые в проекте, должны иметь одинаковый формат. Поэтому при его смене будет выдано два предупреждения: запрос на разрешение конвертирования существующих в проекте звуковых файлов в новый формат (без этого смена формата невозможна) и запрос на сохранение исходных файлов. Вообще к смене формата звуковых данных лучше не прибегать, т. к. при выполнении операции конвертирования деградирует качество. Но если без конвертирования не обойтись, то исходные файлы стоит сохранить. Конечно, суммарный объем, занимаемый звуковыми файлами, возрастет. Но зато в любой момент вы сможете вернуться к исходному формату без каких-либо потерь, обусловленных конвертированием.
Рассмотрим остальные параметры окна Project Setup.
Record File Type — тип аудиофайлов, записываемых в ходе работы над проектом. Доступны следующие типы:

  • Wave File — "обычные" для платформы PC звуковые файлы (внутренний формат RIFF, расширение WAV);
  • Broadcast Wave File — WAV-файлы, в которых имеются дополнительные поля, позволяющие идентифицировать автора;
  • AIFF — звуковые файлы, "обычные" для платформы Мае.

Во всех случаях для представления звуковых данных используется РСМ — импульсно-кодовая модуляция.
Stereo Pan Law — размер компенсации потери энергии при стереофоническом панорамировании. Доступны следующие варианты: -3dB (по умолчанию), -6dB и 0dB (не компенсировать потерю энергии). Например, если Stereo Pan Law = —3 dB, то при панорамировании сигнала в крайнюю левую точку его уровень в левом канале вырастет на 3 дБ. Это нужно для того, чтобы компенсировать потерю энергии — ведь в правом канале сигнал будет полностью отсутствовать и без компенсации суммарная энергия стереоканалов существенно бы уменьшилась. В данном случае понятие "энергия" эквивалентно понятию "громкость". Подробнее о стереофоническом панорамировании см. в разд. 4.2.2.
Следует учитывать, что когда выбран режим -3dB или -6dB, уровни всех сигналов в проекте занижаются соответственно на 3 или 6 дБ для того, чтобы избежать клиппирования при панорамировании.

Рис. 2.35. Диалоговое окно Preferences (раздел Broadcast Wave)

Раз уж мы упомянули о поддержке Cubase SX звуковых файлов формата Broadcast Wave File, то стоит рассказать о том, где заполняются поля, позволяющие идентифицировать автора. Командой главного меню File > Preferences откройте диалоговое окно Preferences, перейдите в раздел Broadcast Wave (рис. 2.35).
В правой части окна доступны три текстовых поля, которые будут добавляться ко всем файлам формата Broadcast Wave, создаваемым в ходе работы над проектом: Description (описание), Author (автор), Reference (ссылка: URL, e-mail и др.). Эти же данные будут по умолчанию использоваться при экспорте проекта в файл формата Broadcast Wave File.


Глава 3. Транспортная панель

    • Транспортная панель
    • 3.1. Группа Main Transport
    • 3.2. Группа Locators
    • 3.3. Группа Pre-/Post-Roll
    • 3.4. Группа Master + Sync
    • 3.5. Группы Record Mode и Activity


Транспортная панель

Основное, но не единственное назначение транспортной панели — управление записью и воспроизведением проекта Cubase SX.
Транспортная панель (рис. 3.1.) может располагаться в любой части главного окна программы, она всегда находится над остальными окнами. Перемещать панель можно, ухватившись мышью за любую ее часть, свободную от элементов управления. Лучше всего для этой цели подходят пустые поля, расположенные около горизонтальных границ панели.
Скрыть транспортную панель можно нажатием клавиши <F2> или выбрав команду главного меню Transport > Transport Panel. Чтобы вернуть транспортную панель на экран, следует повторно воспользоваться командой Transport > Transport Panel или нажать клавишу <F2>.

Рис. 3.1. Транспортная панель

На транспортной панели расположено несколько групп управляющих элементов. Вы можете настроить транспортную панель таким образом, чтобы отображались не все эти группы, а только те, которыми вы пользуетесь чаще всего. В контекстном меню, вызываемом щелчком правой кнопки мыши, можно выбрать, какие группы следует отображать, а какие нет. У каждой группы имеется свое название, однако на самой транспортной панели эти названия не отображаются.
В нижней части контекстного меню имеется три команды:

  • Buttons Only — отображать только кнопки деки (см. в разд. 3.1 определение деки);
  • Time Display Only — отображать только поле координаты текущей позиции;
  • Show All — отображать все элементы панели.

Рассмотрим все группы транспортной панели в порядке убывания их важности (с нашей субъективной, естественно, точки зрения).


3.1. Группа Main Transport

Основным элементом транспортной панели можно считать группу Main Transport (рис. 3.2).

Рис. 3.2. Группа Main Transport

В данной группе расположен ряд кнопок для управления записью/воспроизведением/перемоткой проекта. Обычно набор таких кнопок называют декой. Что значит "перемотка проекта"? В любом секвенсоре присутствует такое понятие, как текущая позиция. В режиме остановки (когда воспроизведения/записи не происходит) текущая позиция — это координата, начиная с которой будет осуществляться его воспроизведение и, как правило, запись. Отсчет координаты ведется от начала проекта. Во время воспроизведения/записи текущая позиция соответствует тому месту проекта, которое воспроизводится/записывается в данный момент. Во всех окнах Cubase SX, служащих для графического представления музыкальной информации и звука, присутствует указатель текущей позиции — специальный маркер в виде вертикальной линии. Во время воспроизведения этот маркер плавно перемещается слева направо — значение координаты текущей позиции увеличивается. В любой момент можно осуществить мгновенный (скачкообразный) или просто быстрый переход в нужную позицию проекта. По аналогии с магнитофоном это и означает "перемотать" проект. В Cubase SX для быстрого перемещения по проекту имеется множество средств. Одно из них — дека.
На практике управлять процессом записи/воспроизведения, нажимая с помощью мыши виртуальные кнопки деки, не очень удобно. Поэтому действие большинства из кнопок деки дублируется определенными клавишами
на дополнительной цифровой клавиатуре компьютера. Причем не имеет значения, включен ли на дополнительной клавиатуре режим Num Lock или нет, клавиши все равно работают. Перечислим кнопки деки слева направо с указанием соответствующих клавиш:
(Go to project start) <.> — перемещение в начало проекта;
(Rewind) <-> — перемотка к началу проекта;
(Fast Rewind) <+> — перемотка от начала проекта;
(Go to project end) — перемещение в конец проекта;
(Stop) <0> — остановка воспроизведения/записи;
(Play) <Enter> — воспроизведение проекта;
(Record) <*> — запись треков, у которых включен атрибут Record Enable. Над кнопками деки располагается поле, в котором в различных формах отображена и доступна для изменения текущая позиция проекта. Одна из возможных форм — цифровая. На рис. 3.2 текущая позиция проекта представлена набором из 11 цифр в формате такт.доля.часть доли.тик (120 тиков в шестнадцатой доле). Подробно особенности такого формата представления времени описаны в разд. Т. 13.5.
Щелчком на символе [image] расположенном в правой части поля текущей позиции, открывается меню, в котором можно выбрать нужный формат представления времени. Каждому из форматов соответствует свой символ, который отображается справа от цифрового представления текущей позиции проекта. Перечислим доступные форматы:

  • Bars + Beats ( [image] ) — "музыкальный формат" такт.доля.часть доли.тик (данный формат задан по умолчанию);
  • Seconds ( [image] ) — линейный формат времени часы:минуты:секунды.миллисекунды;
  • 24 fps ( [image] ) — формат времени, принятый в 35-миллиметровом кино, часы:минуты:секунды:кадры (24 кадра в секунду);
  • 25 fps ( [image] ) — телевизионный формат времени, принятый в Европе, часы:минуты:секунды:кадры (25 полных кадров в секунду для стандартов PAL и SECAM);
  • 29.97 fps ( [image] ) — телевизионный формат времени, принятый в США и Японии, часы:минуты:секунды:кадры (29.97 кадров в секунду для стандарта NTSC);
  • 30 fps ( [image] ) — формат времени 30 кадров в секунду (используется в США только для работы со звуком);
  • 29.97 dfps ( [image] ) — формат времени NTSC с применением системы Drop Frame, когда каждый 1000-й кадр отбрасывается (29.97 кадров в секунду). Данный формат часто используется в США при работе с видео;
  • 30 dfps ( [image] ) — формат, аналогичный предыдущему, за исключением частоты кадров, которая составляет 30 кадров в секунду. Данный формат используется очень редко;
  • Samples ( [image] ) — формат, представляющий собой одно число — количество звуковых отсчетов.

В различных ситуациях удобнее использовать различные форматы представления времени. Например, если вы работаете над аранжировкой, в которой преобладают MIDI-данные, удобнее работать в формате Bars + Beats. Формат Samples более удобен при сведении аудиотреков или в процессе мастеринга. Если с помощью Cubase SX создается звуковая дорожка к видеотреку, импортированному в проект командой главного меню File > Import > Video File, то удобнее работать с телевизионными форматами времени. В таком случае следует выбрать тот же формат представления времени, что и в импортированном видеофайле. Простейший способ узнать этот формат — заглянуть в свойства видеофайла средствами Windows и посмотреть, какая там используется частота кадров.
В левой части поля текущей позиции расположены символы + и —. Щелкая на них с помощью левой кнопкой мыши, можно увеличивать или уменьшать значение текущей позиции на одну элементарную для действующего формата представления времени единицу.
Вы можете ввести новое значение текущей позиции с клавиатуры: щелкаете на нужном разряде (разряд станет выделенным), вводите с клавиатуры новое значение (выделение перемещается к следующему разряду). Под разрядом в данном случае мы понимаем группу цифр, расположенных подряд и отделенных точкой (.) или двоеточием (:) от остальных разрядов.
Имеется возможность плавного изменения значений разрядов. Для этого надо подвести курсор мыши к верхней или нижней части нужного разряда так, чтобы курсор принял вид [image] или [image] соответственно. Если теперь нажать и удерживать нажатой левую кнопку мыши, значение разряда будет плавно увеличиваться или уменьшаться. Одиночный щелчок изменяет значение разряда на единицу.
Если требуется перемещаться по проекту на большие расстояния, то удобнее пользоваться специальным ползунком-диаграммой [image] расположенным в нижней 'части поля текущей позиции проекта.


3.2. Группа Locators

В проекте Cubase SX всегда присутствуют два специальных маркера, называемых левым и правым локаторами. С помощью них обозначается отрезок проекта. Для чего? Например, для того, чтобы воспроизводить этот отрезок в цикле или экспортировать в звуковой файл. Множество функций Cubase SX работают применительно к отрезку проекта, заключенному между локаторами. По умолчанию оба локатора находятся в самом начале проекта — точке с координатами 0001.01.01.000 (формат времени Bars + Beats).
Позиции левого (L) и правого (R) локаторов доступны для редактирования в группе Locators, показанной на рис. 3.3. Для того чтобы перенести текущую позицию проекта на место левого или правого локатора, удобно пользоваться кнопками L либо R или клавишами <1> или <2> на дополнительной цифровой клавиатуре.

Рис. 3.3. Группа Locators

В группе Locators расположены четыре кнопки:
AQ — включение/выключение режима автоматической квантизации (квантизации подвергаются все записываемые MIDI-сообщения типа Note);
(punch in) — автоматическое переключение в режим записи из режима воспроизведения при достижении указателем текущей позиции левого локатора;
(Loop) — включение/выключение режима циклического воспроизведения/записи;
(punch out) — автоматический переход из режима записи в режим вос- произведения при достижении указателем текущей позиции правого локатора. В разд. 4.4.3 мы расскажем о применении перечисленных выше кнопок на практике.


3.3. Группа Pre-/Post-Roll

Группа Pre-/Post-Roll (рис. 3.4) содержит два числовых параметра: Preroll (в верхней части) и Postroll (в нижней части). Оба параметра связаны с работой программы в режиме записи.

Рис. 3.4. Группа Pre-/Post-Roll

Программа будет "обращать внимание" на значение этих параметров в том случае, если в главном меню включена опция Transport > Use Pre-/Post-Roll.
Значение Preroll используется следующим образом. В случае включения режима записи кнопкой деки [image] (Record) или клавишей <*> Cubase SX фактически будет выполнять следующие действия:

  • "перемотку" текущей позиции проекта по направлению к началу проекта на интервал времени, указанный в поле Preroll;
  • запуск воспроизведения;
  • переключение в режим записи при достижении указателем текущей позиции проекта того места, с которого сразу должна была бы начаться запись, если бы не был задействован режим Preroll.

Короче говоря, можно считать, что значение поля Preroll — это время, выделенное на то, чтобы, готовясь к записи, собраться с духом.
Заметить работу режима Postroll можно только в том случае, если включена опция Stop after Automatic Panch Out (остановка воспроизведения после автоматического выхода из режима записи), доступная в разделе Transport окна Preferences, вызываемого командой главного меню File > Preferences.
При включенном режиме punch out (кнопка [image] ) запись будет продол-
жаться до тех пор, пока указатель текущей позиции проекта не поравняется с позицией правого локатора. Затем в течение времени, заданного параметром Postroll, будет осуществляться воспроизведение проекта. По прошествии данного времени воспроизведение будет автоматически остановлено.
Для чего такие сложности? Многочисленные "мелочи", всевозможные опции и режимы могут сделать работу в Cubase SX более комфортной. Речь, естественно, идет о повседневном профессиональном применении программы.


3.4. Группа Master + Sync

В группе Master + Sync доступны кнопки включения/выключения метронома и различных режимов, связанных с синхронизацией, а также поля, служащие для отображения и редактирования темпа и музыкального размера проекта.

Рис. 3.5. Группа Master + Sync

Нажатием на кнопку Click (или командой главного меню Project > Metronome On, или клавишей <С>) включается/выключается метроном. Окно настройки метронома вызывается командой главного меню Project > Metronome Setup (см. разд. 2.8).
Кнопка Master включает/выключает режим, в котором управление темпом воспроизведения/записи осуществляется специальным треком проекта, называемым Tempo Track. Окно этого трека вызывается командой главного меню Project > Tempo Track или комбинацией клавиш <Аlt> + <9> (см. главу 7). Фактически Tempo Track представляет собой график изменения темпа во времени.
Кнопка Sync (или команда главного меню Transport > Sync Online, или клавиша <Т>) — включение/выключение режима синхронизации с внешним оборудованием. Настройка параметров синхронизации осуществляется с помощью окна Synchronization Setup, вызываемого командой главного меню Transport > Sync Setup (см. разд. 2.9).
Справа от перечисленных кнопок расположено поле, служащее для отображения и редактирования следующих параметров:

  • Темп (доступен для редактирования, если только выключен режим Master);
  • Музыкальный размер.

Кроме того, в поле располагается индикатор синхронизации с внешним оборудованием, который служит для отображения следующих состояний: Offline (отсутствие синхронизации), Idle (готовность к синхронизации) и Lock NN (синхронизация установлена, NN — формат, количество кадров в секунду).
Конечно, программа Cubase SX рассчитана на работу в составе студии, оснащенной всевозможным оборудованием, требующим синхронизации (например, многоканальные магнитофоны, видеомагнитофоны и т. п.). Если же речь идет о применении Cubase SX в качестве самостоятельной виртуальной студии на базе компьютера, то все возможные проблемы синхронизации с внешним оборудованием отпадают сами собой в связи с отсутствием последнего.


3.5. Группы Record Mode и Activity

Следуя логике изложения, мы обязаны упомянуть, хотя бы формально, о том, что на транспортной панели имеется группа Record Mode (рис. 3.6). Она служит для переключения режимов записи. Однако рассмотрение особенностей этих режимов на данном этапе изучения программы не имеет смысла. О них мы расскажем в разд. 4.4.3.
В группе Activity (рис. 3.7) расположены два индикатора, отображающие активность входных (In) и выходных (Out) MIDI-портов. Осуществляется индикация процесса обмена только с внешними по отношению к Cubase SX MIDI-устройствами.

Рис. 3.6. Группа Record Mode

Рис. 3.7. Группа Activity

Под внешними MIDI-устройствами следует понимать любые устройства, взаимодействие с которыми осуществляется через программные порты, доступные в системе. Например, встроенный в звуковую карту синтезатор/сэмплер считается не чем иным, как внешним MIDI-устройством. После установки драйверов звуковой карты в системе среди прочих портов появляется MIDI-порт для передачи данных встроенному синтезатору.
Однако виртуальные MIDI-порты, возникающие после подключения VSTi к проекту, относятся только к Cubase SX, соответственно VSTi — внутренние (для Cubase SX) MIDI-устройства.


Глава 4. Работа в окне проекта

    • Работа в окне проекта
    • 4.1. Атрибуты MIDI-трека. Использование MIDI-эффектов и VSTi
    • 4.1.1. Атрибуты MIDI-трека, доступные из списка треков
    • 4.1.2. Атрибуты и параметры MIDI-трека, доступные в поле инспектора; редактирование барабанной карты; применение MIDI-эффектов
    • Основная секция инспектора MIDI-трека
    • Секция Track Parameters
    • Секция Inserts, подключение MIDI-эффектов
    • Секция Sends
    • Секция Channel
    • 4.1.3. Подключение VSTi
    • 4.2. Атрибуты аудиотрека
    • 4.2.1. Атрибуты аудиотрека, доступные из списка треков
    • 4.2.2. Атрибуты и параметры аудиотрека, доступные в поле инспектора; применение аудиоэффектов реального времени
    • Основная секция инспектора аудиотрека; немного о пространственном панорамировании
    • Секция Inserts
    • Секция Equalizers
    • Секция Sends
    • Секция Channel
    • 4.3. Назначение и атрибуты групповых треков
    • 4.4. Секция треков
    • 4.4.1. Части (parts), первое знакомство
    • 4.4.2. Шкала времени Ruler, указатель текущей позиции, расширенные функции управления воспроизведением проекта и изменение масштаба отображения графических объектов секции треков
    • 4.4.3. Запись MIDI и звука
    • Подготовка MIDI- и аудиотреков к записи
    • Способы переключения программы в режим записи
    • Режимы записи, циклическая запись, регионы аудиосообщений
    • 4.4.4. Привязка графических объектов, первое знакомство с квантизацией
    • 4.4.5. Операции над частями и аудиосообщениями
    • Выделение
    • Удаление, отмена последней операции
    • Перемещение
    • Разрезание
    • Склеивание, заполнение пауз
    • Копирование
    • Инструмент Range Selection
    • Амплитудные огибающие аудиосообщений; пересечение аудиосообщений, Auto Fades, Auto Crossfades
    • Перемещение границ частей и аудиосообщений, алгоритм Time Stretch
    • Мьютирование и блокирование частей и аудиосообщений
    • 4.5. Операции над треками
    • 4.6. Треки-контейнеры
    • 4.7. Трек маркеров (Marker Track) и все, что с ним связано
    • 4.8. Автоматизация
    • 4.8.1. Запись автоматизации
    • 4.8.2. Формирование и редактирование огибающих автоматизации
    • 4.8.3. Автоматизация MIDI-треков
    • 4.8.4. Автоматизация аудиотреков и групповых треков
    • 4.8.5. Автоматизация VSTi и аудиоэффектов, мастер-секции микшера
    • 4.9. Атрибуты объектов проекта, поле Infoline


Работа в окне проекта

Окно проекта Cubase SX Project (рис. 4.1.) можно считать основным окном. Именно этим окном вам придется пользоваться чаще всего. В Cubase SX одновременно может быть открыто несколько проектов. В заголовке окна каждого из проектов отображается имя файла проекта. Если же проект не был сохранен в файле, вместо имени файла будет присутствовать надпись untitled.
За понятием "проект" стоит нечто большее, чем просто окно. В проекте задействованы ресурсы программных и аппаратных устройств, которые настроены определенным образом именно под этот проект. И в то же время в Cubase SX одновременно может присутствовать несколько проектов. Как же быть с аппаратными ресурсами, являющимися общими для всех проектов? Проблема разделения ресурсов между проектами в Cubase SX решается следующим образом: проектов может быть много, но активным может быть только один из них. Активному проекту полностью принадлежат все ресурсы виртуальной студии. В некоторых музыкальных редакторах (например, SONAR) активным является тот проект, окно которого активно. В Cubase SX активный проект назначается нажатием безымянной кнопки, расположенной в левом верхнем углу окна Cubase SX Project. У активного проекта эта кнопка окрашена в красноватый цвет, у неактивного — в серый.
Окно включает в себя следующие составляющие. В верхней части окна располагается панель инструментов, в числе которых есть и кнопки управления записью/воспроизведением проекта, которые частично дублируют функции транспортной панели.
Под панелями инструментов располагается информационная строка (Infoline), в которой отображаются параметры выбранных объектов проекта. Кроме того, отображаемые в информационной строке параметры доступны для редактирования. Скрыть или отобразить информационную строку можно с помощью кнопки [image] расположенной на панели инструментов.

Рис. 4.1. Окно Cubase SX Project (не создано ни одного трека)

Как видно из рис. 4.1, вся остальная область окна проекта разбита на три части. Проект, представленный на рис. 4.1, пока не содержит ни одного трека. Но в будущем, после того как вы создадите хотя бы один трек (рис. 4.2), в средней части расположится список треков (Track list). В списке друг над другом будут располагаться поля треков и поля подтреков, содержащих автоматизацию. В этих полях будут доступны атрибуты и основные параметры треков.
В нижней части списка треков расположена информационная строка, в которой отображается формат звуковых данных и максимальная суммарная длительность звуковых файлов проекта. Последний параметр вычисляется исходя из того, сколько свободного места имеется на том диске, на котором расположена папка проекта.
Слева от списка треков находится поле, называемое инспектором (Inspector). В этом поле будут доступны для редактирования параметры выбранного трека. Поле инспектора можно скрыть или отобразить с помощью кнопки [image] , расположенной на панели инструментов.
Справа от списка треков располагается область, в которой в графическом виде будет отображаться содержимое треков — это секция треков. Каждому полю в списке треков соответствует своя полоса в секции треков. На одном треке принято размещать партии, принадлежащие одному инструменту.
Горизонталь в секции треков соответствует оси времени, которая берет начало от левой границы секции. В верхней части секции треков имеется шкала времени (Ruler). Она служит не только для отображения меток времени, но и предоставляет возможность управлять положением локаторов и указателем текущей позиции.


4.1. Атрибуты MIDI-трека. Использование MIDI-эффектов и VSTi

Давайте создадим MIDI-трек. Для этого можно воспользоваться командой главного меню Project > Add Track > MIDI. Альтернативный способ — воспользоваться командой Add MIDI Track из контекстного меню списка треков. Результат показан на рис. 4.2.

Рис. 4.2. Окно Cubase SX Project (добавлен MIDI-трек)


4.1.1. Атрибуты MIDI-трека, доступные из списка треков

В списке треков появилось поле созданного трека (рис. 4.3, а). О том, что данный трек является именно MIDI-треком, свидетельствует символ [image] имеющийся в его поле.
Размеры поля трека можно изменять, ухватившись курсором мыши за его правую или нижнюю границу. От размеров поля трека зависит расположение и количество видимых кнопок и полей (рис. 4.3, а, б, в).

Рис. 4.3 (а, б). Поле MIDI-трека

Рис. 4.3, в. Поле MIDI-трека

Мы перечислим атрибуты MIDI-трека, показанные на рис. 4.3, б. Многие из них дублируются на панели инспектора. О них мы поговорим в следующем разделе.
Название трека является его атрибутом. В нашем примере трек называется MIDI 01. Названия создаваемым трекам присваиваются автоматически. Если создать еще один MIDI-трек, то он будет называться MIDI 02, следующий MIDI 03 и т. д. Однако в любой момент название трека вы можете изменить. Для этого следует сделать двойной щелчок на поле с названием трека (поле станет доступным для редактирования) и ввести новое название.
— атрибут Mute. Когда он включен, данная кнопка подкрашена в желтый цвет и данный трек заглушен.
— атрибут Solo. При его включении данная кнопка оказывается подкрашенной красным цветом, а все остальные треки переходят в состояние Mute.
— атрибут готовности к записи Record Enable.
Сразу после создания нового трека атрибут Record Enable включен (кнопка [image] подкрашена красным цветом). Происходит это потому, что вновь созданный трек является выделенным, а в настройках Cubase SX по умолчанию установлен флажок Enable Record on Selected Track — включать атрибут готовности к записи у выделенных треков. Данная опция доступна в разделе Editing окна Preferences, вызываемого командой главного меню File > Preferences. Если запустить проект на запись, то информация, поступающая на входной MIDI-порт, с которым ассоциирован трек, будет сохраняться на данном треке. Вы можете включить атрибуты Record Enable одновременно для нескольких треков.
Здесь нам следует сделать небольшое отступление и рассмотреть один важный вопрос, касающийся режима Record Enable и режима мониторинга. Если включен атрибут Record Enable, то во время записи MIDI-данные, поступающие на входной MIDI-порт, ассоциированный с MIDI-треком, будут сохраняться на этом треке. Но будет ли при этом звучать тот инструмент, которому адресованы записываемые MIDI-команды? Не обязательно. При включении атрибута Record Enable незримо для пользователя включается режим мониторинга. В нем все данные, поступающие на вход MIDI-трека, транслируются на выходной MIDI-порт, с которым данный трек ассоциирован. При этом до начала записи и во время записи вы можете слышать собственную игру на MIDI-клавиатуре. Однако мониторинг будет осуществляться только в том случае, если включена опция MIDI Thru Active. Напомним путь к данной опции. Командой File > Preferences главного меню открывается диалоговое окно Preferences. Далее следует выбрать раздел MIDI, и опция станет доступной для включения/выключения.
Вы можете использовать мониторинг отдельно от режима Record Enable. Режим мониторинга включается кнопкой [image] , при этом кнопка [image] может быть выключена. Например, кнопка [image] окажется полезной в том случае, если в процессе записи требуется слышать звучание какого-либо трека, управляемого внешним MIDI-контроллером или секвенсором, но не требуется осуществлять запись MIDI-информации, поступающей именно на этот трек.
В правой части поля MIDI-трека имеется индикатор, который условно можно назвать индикатором уровня сигнала. Он загорается в момент поступления команды нажатия MIDI-клавиши. Высота светящегося столбика пропорциональна параметру Velocity (скорости нажатия MIDI-клавиши). При удержании MIDI-клавиши нажатой высота столбика плавно уменьшается. После того как MIDI-клавиша отпущена, высота столбика уменьшается очень быстро. Действительно, например, для инструмента Grand Piano громкость его звучания после нажатия MIDI-клавиши будет изменяться по описанному выше закону. Однако инструменты такого класса, как подкладки (pad'bi) будут звучать ровно до тех пор, пока MIDI-клавиша будет удерживаться нажатой. И громкость их звучания если и варьируется, то по более сложному закону. Что касается звучания ударных инструментов, то после фазы атаки их громкость обычно спадает независимо от того, удерживается нажатой MIDI-клавиша или нет. Именно поэтому мы сказали, что описываемый индикатор можно назвать индикатором уровня сигнала лишь условно. Ведь MIDI-трек не получает и не может получать аудиоинформацию с выхода управляемого им синтезатора или сэмплера.
Перечислим остальные атрибуты MIDI-трека, показанные на рис. 4.3, б.
Кнопки [image] (Read) и [image] (Write) разрешают воспроизведение и запись автоматизации.
Кнопка [image] (Edit VST Channel) вызывает появление линейки микшера, соответствующей данному MIDI-треку или панели соответствующего VSTi, если этот инструмент указан в качестве выходного порта трека.
(Bypass Inserts) — временное отключение MIDI-эффектов, подключенных в режиме вставки (эффекты последовательного действия).
(Disable Sends) — отключение посылов (шин, к которым подключаются MIDI-эффекты параллельного действия).
(Drum Map) — вызывает меню, в котором можно выбрать барабанную карту, ассоциированную с данным MIDI-треком, или команду Drum Map Setup, вызывающую редактор барабанных карт. Барабанная карта — таблица соответствия ударных инструментов MIDI-нотам, MIDI-каналам и MIDI-инструментам. С помощью барабанных карт звуки различных инструментов, управляемых через различные MIDI-порты, можно объединять в наборы.
Кнопка [image] (Lock) блокирует или разблокирует трек. Изменение информации, хранящейся на заблокированном треке, невозможно.
В левом нижнем углу поля трека имеется маленькая кнопка с символом + или —. С ее помощью открываются или скрываются поля подтреков, предназначенных для записи автоматизации. Об автоматизации мы поговорим отдельно (см. разд. 4.8), а сейчас перейдем к рассмотрению поля инспектора.


4.1.2. Атрибуты и параметры MIDI-трека, доступные в поле инспектора; редактирование барабанной карты; применение MIDI-эффектов

Поле инспектора MIDI-трека (рис. 4.4.) состоит из пяти секций:

  • основная секция, включающая в себя название трека и содержащая его основные параметры;
  • секция Track Parameters, содержащая параметры некоторых алгоритмов преобразования MIDI-информации, работающих во время воспроизведения трека;
  • секция Inserts, предназначенная для подключения MIDI-эффектов последовательного действия;
  • секция Sends, предназначенная для подключения MIDI-эффектов параллельного действия;
  • секция Channel, которая содержит одну единственную линейку микшера Cubase SX, соответствующую данному MIDI-треку.

В правой верхней части каждой из секций имеется кнопка [image] или [image] с помощью которой данную секцию можно скрыть или, наоборот, сделать доступной. В скрытом виде отображаются только заголовки секций с их названиями и одной-двумя кнопками. Если в настройки какой-либо секции внесены изменения, отличные от принятых по умолчанию, то поле с кнопкой [image] или [image] соответствующей секции будет подсвечено синим или зеленым цветом.

Рис. 4.4. Инспектор MIDI-трека (основная секция)


Основная секция инспектора MIDI-трека

Рассмотрим элементы основной секции (рис. 4.4) в порядке убывания их значимости.
В списке in: следует выбрать входной MIDI-порт, к которому подключен MIDI-контроллер (MIDI-клавиатура). Информация, поступающая через этот порт, будет сохраняться на треке в режиме записи.
В списке out: следует выбрать выходной MIDI-порт или название MIDI-устройства, которому будет адресоваться информация, воспроизводимая с данного трека. Напомним, что настройка Cabase SX для работы с конкретными MIDI-устройствами осуществляется в окне MIDI Device Manager (см. разд. 2.1.).
Если вы выберете в поле out: такое устройство, что в окне MIDI Device Manager не указан выходной MIDI-порт, к которому данное устройство подключено, то возникнет окно, показанное на рис. 4.5. Оно дублирует некоторые функции окна MIDI Device Manager.
В списке chn: (см. рис. 4.4) выбирается MlDI-канал, по которому будет воспроизводиться информация данного трека.
Если в качестве выходного MIDI-порта выбран синтезатор, скрипты для выбора патчей которого загружены в Cubase SX с помощью окна MIDI Device Manager, то в основной секции инспектора будет доступно поле [image] . Щелчком мыши на этом поле открывается браузер (обозреватель) патчей (рис. 4.6, а). С его помощью очень удобно перебирать патчи по их названиям, не задумываясь о том. какие они имеют номера и в каких банках находятся. Кроме того, вы можете сделать так, чтобы отображались не все доступные патчи, а только те из них, названия которых содержат последовательность символов, заданную в поле Filter. Например, если ввести в это поле "рпо", то в браузере отобразятся все патчи, содержащие данную подстроку. В нашем случае эта подстрока имеется в названиях всех патчей, имеющих отношение к звучанию фортепиано, пианино, электропианино и т. п. (рис. 4.6, б).
Если в поле out: (см. рис. 4.4) выбран некий выходной MIDI-порт и Cubase SX "не знает", какое устройство к нему подключено (т. е. не загружены скрипты для выбора патчей), то вместо поля [image] в основной секции инспектора будут доступны поля [image] . В поле bnk: задается номер банка патчей, а в поле prg: — номер нужного патча в этом банке.
Щелчком мыши на поле [image] вызывается меню, аналогичное тому, что вызывается кнопкой [image] (Drum Map) из поля MIDI-трека.
В данном меню можно выбрать барабанную карту, которая будет ассоциирована с данным MIDI-треком, или команду Drum Map Setup, вызывающую редактор барабанных карт. По умолчанию доступна только одна барабанная карта GM Map, которая соответствует распределению звуков ударных инструментов спецификации GM на MIDI-клавиатуре. Окно редактора барабанных карт показано на рис. 4.7.

Рис. 4.5. Окно My Device Setup

Рис. 4.6.Браузер патчей

Рис. 4.7. Окно диалога Drum Map Setup

В левой части редактора присутствует список барабанных карт Drum Maps. В правой части окна в виде таблицы располагается выбранная в списке Drum Maps карта (текущая карта). Создать новую карту можно нажатием на кнопку New Map. Новая барабанная карта будет иметь следующее название: Empty Map и, возможно, порядковый номер, если карт с таким же названием больше, чем одна. Чтобы изменить название карты, сделайте двойной щелчок мыши на старом названии карты в списке Drum Maps (поле с названием переключится в режим редактирования) и введите новое название.
Кнопкой New Copy осуществляется создание копии выбранной в данный момент карты. С помощью кнопок Load и Save осуществляется загрузка и сохранение текущей карты в файлы с расширением DRM.
Если нажать кнопку ОК, то окно редактора барабанных карт закроется и не более того. Если же нажать кнопку Assign, то данное окно тоже закроется, но при этом текущий MIDI-трек будет ассоциирован с той барабанной картой, которая была выбрана в списке Drum Maps.
А теперь рассмотрим собственно барабанную карту. Как мы уже говорили, это, по сути дела, таблица, состоящая из следующих полей:

  • Pitch — название ноты (не доступно для редактирования);
  • Instrument — название ударного звука (доступно для редактирования);
  • Quantize — длительность, к которой квантизируется сообщение;
  • М — атрибут Mute (заглушить ударный звук);
  • I-Note (Input Note, входящая нота) — при поступлении в Cubase SX данного MIDI-сообщения будет воспроизводиться ударный звук, соответствующий сообщению, указанному в поле графы O-Note;
  • O-Note (Output Note, выходная нота) — сообщение, которое будет посылаться MIDI-инструменту при воспроизведении данного ударного звука;
  • Channel — номер MIDI-канала;
  • Output — выходной MIDI-порт.

Если в качестве последнего параметра выбрать Default, то MIDI-сообщения будут адресоваться тому MIDI-порту, который выбран в списке Default, расположенном в левом нижнем углу окна Drum Maps Setup.
Вернемся к рассмотрению основной секции инспектора MIDI-трека (см. рис. 4.4).
Символами [image] [image] и [image] в основной секции инспектора обозначены регуляторы громкости, панорамы и время в миллисекундах, на которое при воспроизведении будут смещены все MIDI-команды, записанные на данном треке. Чтобы изменить положение регулятора, следует выполнить следующие действия:

  • подвести к регулятору курсор мыши;
  • нажать и удерживать нажатой левую кнопку мыши (возникнет более крупное изображение регулятора);
  • перемещать курсор мыши в горизонтальном или вертикальном направлении в зависимости от того, как расположен регулятор (в данном случае регуляторы [image] , [image] и [image] расположены горизонтально).

На практике перемещать регуляторы гораздо проще, чем читать описание того, как это следует делать. Обычно около регулятора присутствует поле, которое не только отображает значение регулируемого параметра, но и позволяет его редактировать в цифровой форме.
Обратите внимание на то, что крайнее левое положение регуляторов громкости и панорамы не соответствует нулевым значениям параметров, как можно было бы предположить. В таком положении регуляторов сообщения об изменении громкости и панорамы не посылаются на выходной порт вовсе. Эта особенность позволяет избежать конфликтов в ситуации, когда несколько треков управляют одним и тем же синтезатором по одному и тому же MIDI-каналу.
В основной панели инспектора присутствуют кнопки [image] (Mute), [image] (Solo), [image] (Enable Record) и [image] (Monitor), [image] (Lock), [image] (Read), [image] (Write). Назначение перечисленных кнопок мы уже рассмотрели.
Кнопка [image] или [image] переключает способ представления времени для данного трека. При использовании музыкального времени (нажата кнопка [image] ) все события, сохраненные на треке, привязываются к шкале, в основе которой лежат музыкальные единицы (такты, доли, тики). Однако промежуток времени в секундах от начала трека до определенного события будет зависеть от темпа. При использовании линейного времени (нажата кнопка [image] ) промежуток от начала трека до определенного события не будет зависеть от темпа. Однако при изменении темпа будет происходить смещение событий относительно шкалы музыкального времени.
Cubase SX позволяет преобразовывать входящие MIDI-данные "на лету", т. е. еще до того, когда они будут записаны на трек. Например, можно конвертировать один вид MIDI-сообщений в другой.
Кнопка [image] открывает диалоговое окно Input Transformer (рис. 4.8, а), с помощью которого определяются параметры фильтрации и преобразования MIDI-данных, поступающих со входного MIDI-порта на трек. Фактически имеется четыре независимых модуля преобразования/обработки MIDI-данных. В группе Active Module следует отметить номера тех модулей, которые должны работать. В группе Selected Module выбирается номер того модуля, параметры которого будут доступны для редактирования.
В списке Mode выбирается режим работы выбранного модуля:

  • Filter — фильтрация MIDI-сообщений;
  • Transform — преобразование MIDI-сообщений.

В окне Input Transformer имеется два списка: в верхнем (столбцы Filter Target, Condition) определяются условия фильтрации, в нижнем (столбцы Action Target, Operation) определяются параметры преобразования MIDI-сообщения. Напротив каждого из списков имеется пара кнопок: Add Line (добавить строку в список) и Delete Line (удалить строку из списка).

Рис. 4.8.Диалоговое окно Input Transformer

Если выбран режим фильтрации, то будут использоваться параметры из верхнего списка. В режиме преобразования имеет значение содержимое обоих списков.
Рассмотрим использование окна Input Transformer на примере. Для начала настроим его на фильтрацию сообщений определенного типа. Задействуем модуль 1 в режиме Filter. С помощью кнопки Add Line добавим строку в верхний список и будем редактировать ее содержимое. В поле Filter Target выберем способ фильтрации Type Is (по типу сообщения). В поле Condition выберем условие фильтрации Equal. В поле Parameter 1 выберем Note. В результате строка будет содержать следующее условие: Type Is Equal Note, что можно трактовать как "фильтровать (не пропускать) сообщения типа Note". Если теперь попробовать что-нибудь сыграть на MIDI-клавиатуре, подключенной к входному MIDl-порту, на работу с которым настроен трек, то ничего не произойдет — сообщения о нажатиях клавиш отсекаются фильтром. В то же время, сообщения любых типов, отличных от Note, будут проходить сквозь фильтр. Если же в поле Condition задать условие Unequal, то, наоборот, сквозь фильтр будут проходить только сообщения типа Note. Сообщения любых других типов сквозь фильтр не пройдут.
Вернем прежнее условие (Equal) и переключим модуль в режим Transform. Теперь условие фильтрации приобретет новый смысл: если в режиме фильтрации сообщения, удовлетворяющие определенным условиям, не пропускались, то теперь они будут пропускаться фильтром, но после этого они подвергнутся преобразованию в соответствии с параметрами, заданными в нижнем списке. То есть условия, заданные в верхнем списке, выделяют те сообщения из общего потока MIDI-данных, которые следует преобразовать.
Нажатием кнопки Add Line добавим строку в нижний список. Попробуем транспонировать ноты на 12 (или сколько угодно) полутонов вверх. Для этого в поле Action Target выберем параметр Value 1 (первый параметр MIDI-сообщений, у сообщения Note — это номер MIDI-клавиши). В поле Operation (операция) выберем Add (добавить). В поле Parameter 1 нужно ввести число полутонов, которое следует добавить к номеру MIDI-клавиши (рис. 4.8, б).
Аналогичным образом можно формировать гораздо более сложные условия фильтрации и преобразования MIDI-команд, ведь оба списка окна Input Transformer могут содержать сколько угодно строк с различными условиями. Кроме того, ведь всего существует четыре модуля, у каждого из которых имеется свой такой список. Однако мы больше не будем задерживаться на рассмотрении возможностей окна Input Transformer. В дальнейшем мы подробно рассмотрим работу с редактором Logical Editor (см. разд. 6.5.), который очень похож на окно Input Transformer. Разница заключается в том, что окно Input Transformer предназначено для редактирования параметров фильтрации и преобразования MIDI-данных в реальном времени, а с помощью окна Logical Editor осуществляется фильтрация и преобразование MIDI-данных, уже сохраненных на треке. Кроме того, в Cubase SX входит MIDI-плагин Transform, работающий в режиме реального времени. В данном плагине полностью реализованы возможности редактора Logical Editor.
Фильтрация MIDI-сообщений может осуществляться в глобальных масштабах (для всего проекта в целом). Напомним, что командой File > Preferences вызывается диалоговое окно Preferences. В разделе MIDI > Filter доступны параметры фильтрации MIDI-сообщений, поступающих через входные порты. Их мы рассмотрели в разд. 2.2. Обратите внимание на то, что по умолчанию фильтруются (не пропускаются) сообщения типа SysEx. Иногда этот факт вызывает проблемы у начинающих пользователей Cubase SX.
Если в качестве выходного порта MIDI-трека используется VSTi, то кнопка [image] откроет панель этого инструмента. О подключении VSTi к проекту п настройке MIDI-треков на работу с ними мы расскажем в разд. 4.1.3. Если MIDI-трек не используется для управления VSTi, то при нажатии на кнопку [image] откроется окно, показанное на рис. 4.9. В заголовке данного окна отображается название текущего трека. Несмотря на это, официально данное окно носит название VST Channel Settings.

Рис. 4.9. Окно VST Channel Settings (вариант окна для MIDI-трека)

В Cubase SX имеется виртуальный микшер, каждый модуль (strip) которого соответствует определенному треку. Окно, показанное на рис. 4.9, содержит в себе все элементы одного канала микшера, соответствующего MIDI-треку. Микшеру посвящена глава 5.


Секция Track Parameters

Секция Track Parameters (рис. 4.10) содержит параметры некоторых алгоритмов преобразования MIDI-сообщений типа Note, работающих во время воспроизведения трека.
В предыдущем разделе мы рассмотрели пример, в котором с помощью Input Transformer можно транспонировать ноты еще до того, как они были записаны на трек. В секции Track Parameters имеется параметр Transpose — количество полутонов, на которое ноты будут транспонироваться при воспроизведении трека.
Vel. Shift — значение, которое будет складываться со значением параметра Velocity каждого сообщения типа Note (смещение параметра Velocity).
Vel. Соmр. — степень компрессии параметра Velocity. О том, что представляет собой эффект компрессии применительно к MIDI-нотам, мы расскажем в разд. 9.4, посвященном MIDI-эффекту реального времени Compress.

Рис. 4.10. Инспектор (секция Track Parameters)

Len. Соmр. — изменение длительностей нот. Например, если задать значение этого параметра равным 3/4, то при воспроизведении длительности нот сократятся на 1/4, т. е. станут равными 3/4 от их первоначальной длительности.
Random — внесение случайных изменений (рандомизация) в параметры сообщений типа Note, их координаты на временной оси и длительности. За счет рандомизации можно получить звучание, напоминающее игру живого исполнителя. В двух списках, расположенных непосредственно под надписью Random, выбираются параметры, подлежащие рандомизации. В терминологии Cubase SX эти параметры называются Target (цель работы алгоритма):

  • Position — позиция на оси времени;
  • Pitch — высота тона;
  • Velocity — скорость нажатия на MIDI-клавишу;
  • Length — длительность ноты;
  • OFF — рандомизация отключена.

В полях Min и Мах задаются границы случайных отклонений.
Range — ограничение диапазона, в котором могут находиться параметры MIDI-сообщений, или фильтрация тех MIDI-сообщений, параметры которых не выходят за границы заданного диапазона. В двух списках, расположенных непосредственно под надписью Range, выбираются следующие целевые параметры:

  • Vel.Limit — ограничение параметра Velocity;
  • Vel.Filter — фильтрация нот по параметру Velocity (будут звучать только те ноты, у которых этот параметр не выходит за границы заданного диапазона);
  • Note Limit — ограничение высоты нот;
  • Note Filter — фильтрация нот по высоте (будут звучать только те ноты, высота которых не выходит за границы заданного диапазона);

В полях Min и Мах задаются границы допустимых диапазонов.
Вот пример, иллюстрирующий работу ограничения. Допустим, на треке сохранены три сообщения типа Note со значениями параметра Velocity, равными 40, 70, 127, и включено ограничение Velocity (Vel.Limit) с параметрами Min = 50, Max = 90. Теперь давайте посмотрим, что будет при воспроизведении. Поскольку Velocity первой ноты меньше нижней границы допустимых значений (40 < 50), то произойдет ограничение: реально будет воспроизведена нота с Velocity = 50. Параметр Velocity второй ноты попадает в диапазон допустимых значений (50 < 70 < 90), поэтому нота будет воспроизведена без изменения его значения. Параметр Velocity третьей ноты превышает верхнюю границу допустимых значений (127 > 90), поэтому сработает ограничение и реально будет воспроизведена нота с Velocity = 90.
В начале раздела мы сказали, что алгоритмы преобразования MIDI-информации, управление которыми осуществляется из рассматриваемой секции инспектора, работают только применительно к MIDI-данным, воспроизводимым с трека. Однако в случае, если включен режим MIDI Thru (а по умолчанию он включен), то MIDI-данные, поступающие на входной порт MIDI-трека, будут ретранслироваться на его выходной порт. С большой натяжкой можно считать, что в этом случае MIDI-данные, поступающие на входной порт MIDI-трека, как бы воспроизводятся. Некоторые алгоритмы обработки MIDI-сообщений, параметры которых доступны в секции Track Parameters, будут работать применительно к ретранслируемым в режиме MIDI Thru MIDI-сообщениям. Это касается алгоритмов, затрагивающих параметры Velocity и Pitch. Данные параметры передаются вместе с сообщениями о нажатии MIDI-клавиш, поэтому программа может обрабатывать их в реальном времени. Другое дело — алгоритмы, затрагивающие длительность нот и их расположение во времени. Они в принципе не могут работать в режиме реального времени, поскольку программе не известно, когда вы нажмете клавишу на MIDI-клавиатуре и сколько времени продержите ее нажатой.
Обращаем ваше внимание на кнопку [image] , расположенную на заголовке секции Track Parameters. С ее помощью осуществляется временное отключение всех алгоритмов обработки MIDI-сообщений, управляемых из данной секции.


Секция Inserts, подключение MIDI-эффектов

Секция Inserts (рис. 4.11) служит для подключения MIDI-эффектов последовательного действия. Эффекты последовательного действия подключаются , к треку по цепочке: при воспроизведении данных с трека происходит их обработка сначала одним эффектом, потом другим и т. д. Иными словами, на вход очередного эффекта поступают данные, уже обработанные предыдущим эффектом. После обработки последним эффектом данные поступают на выходной порт трека.

Рис. 4.11. Инспектор (секция Inserts)

В секции имеются четыре ячейки для подключения эффектов. В каждой из них есть список для выбора нужного эффекта. По умолчанию во всех списках выбран элемент No Effect (эффект не подключен). В Cubase SX доступны следующие MIDI-эффекты:

  • Arpache 5 — арпеджиатор;
  • AutoPan — автоматическое панорамирование;
  • Chorder — генератор аккордов;
  • Compress — компрессор параметра Velocity;
  • Control — генерация сообщений типа Control Change;
  • Density — прореживание или генерация дополнительных нот;
  • Micro Tuner — индивидуальная подстройка каждой ноты в октаве;
  • MidiEcho — генерация эха;
  • Note 2 СС — конвертор MIDI-сообщения типа Note в сообщения типа Control Change;
  • Quantizer — квантизатор;
  • Step Designer — паттерновый секвенсор;
  • Track Control — контрольная панель для управления основными параметрами синтезаторов стандартов GS и XG;
  • Track FX — набор эффектов, идентичных тем, что доступны из секции Track Parameters плюс еще два эффекта — смещение во времени (аналогичный параметр доступен в основной секции) и Scale Transpose (транспозиция в соответствии с тональностью композиции);
  • Transformer — эффект реального времени, возможности которого аналогичны возможностям редактора Logical Editor (см. разд. 6.5).

Подробно MIDI-эффекты будут рассмотрены в главе 9. А сейчас вернемся к рассмотрению секции Inserts инспектора.
Итак, подключение эффектов осуществляется довольно просто: щелкаете на надписи No Effect или на названии уже подключенного эффекта (чтобы заменить этот эффект) и выбираете нужный эффект из меню (рис. 4.12, а).

Рис. 4.12. Инспектор (секция Inserts, подключение эффектов)

В зависимости от того, какие из эффектов подключены, их параметры могут быть доступны или не доступны из секции Inserts. На рис. 4.12, б показано, что подключено четыре эффекта: Arpache 5, AutoPan, Control и Compress.
Однако для редактирования доступны параметры лишь двух эффектов: Control и Compress. С помощью кнопок [image] можно вызывать окна тех эффектов, параметры которых не доступны в секции Inserts. С помощью этой же кнопки можно скрыть и вновь сделать доступными параметры тех эффектов, которые отображаются непосредственно в секции Inserts.
С помощью кнопки [image] эффекты можно временно отключать. Кнопка расположенная в заголовке секции Inserts, временно отключает все эффекты, подключенные в секции.
На всякий случай поясним, какая разница между выражениями "отключить эффект" и "временно отключить эффект". Отключить эффект — значит задать No Effect для той ячейки секции, к которой он был подключен. При этом все выполненные вами изменения параметров эффекта пропадут. Временно отключить эффект — значит воспользоваться кнопкой [image] и исключить эффект из цепи обработки (bypass). В любой момент с помощью этой же кнопки вы сможете вернуть эффект в цепь обработки, при этом все ранее выполненные настройки данного эффекта сохраняются.


Секция Sends

Основным назначением секции Sends (посылы) является обеспечение подключения MlDI-эффектов параллельного действия (рис. 4.13).

Рис. 4.13. Инспектор (секция Sends)

Эффекты параллельного действия подключаются к треку независимо друг от друга. На вход каждого из эффектов посылаются данные непосредственно с трека. После обработки данные поступают на указанный выходной порт, который может отличаться от выходного порта трека.
В Cubase SX к каждому из MIDI-треков вы можете подключить до четырех эффектов параллельного действия. Каждому из эффектов соответствует своя ячейка секции Sends, состоящая из нескольких раскрывающихся списков и кнопок. По умолчанию эффекты не подключены ни к одной из ячеек, чему соответствует надпись No Effect. Подключение эффектов осуществляется точно так же, как и в секции Inserts: выбором названия эффекта из списка. После подключения эффекта следует задать выходной порт, которому будут адресоваться обработанные данные. По умолчанию вместо названий выходных портов фигурируют надписи Not Connected (нет соединения). Кроме порта можно задать номер MIDI-канала, по которому будут передаваться данные. По умолчанию для всех эффектов выбран канал 1. В списке для выбора номера MIDI-канала кроме номеров от 1 до 16 присутствует еще и элемент ANY (любой). Выбор этого элемента означает, что после обработки эффектом MIDI-данные будут передаваться по тому же каналу, что задан для данного MIDI-трека. В каждой из ячеек секции Sends имеются следующие кнопки: — включение/выключение посыла;
— отображение/скрытие параметров эффекта в секции Sends или вызов окна эффекта;
— переключение Pre/Post.
Обратите внимание на то, что кнопка [image] служит для включения/выключения именно посыла, а не эффекта. Дело в том, что, как мы уже говорили, обеспечение подключения MIDI-эффектов параллельного действия является основным назначением секции Sends. Но это назначение не является единственным. Вы можете использовать посылы и без подключения каких-либо эффектов. Ведь с помощью посылов вы можете направлять копию потока MIDI-данных, поступающих с трека, на любой MIDI-канал любого выходного порта. Эту особенность можно использовать для создания сложных тембров, когда одни и те же ноты передаются разным синтезаторам. Само собой разумеется, что направлять информацию можно не только на порты, которые физически присутствуют в системе, но и на порты виртуальных синтезаторов VSTi, задействованных в конкретном проекте.


Секция Channel

Мы повторимся, сказав, что секция Channel (рис. 4.14) содержит одну единственную линейку микшера Cubase SX, которая соответствует данному MIDI-треку.
Больше нам сейчас добавить нечего, поскольку детальный анализ микшера Cubase SX еще впереди, рассматривать же одну из его линеек (с урезанными возможностями) смысла нет.


4.1.3. Подключение VSTi

Командой главного меню Devices > VST Instruments вызовите окно, показанное на рис. 4.15.

Рис. 4.14. Инспектор (секция Channel)

Рис. 4.15. Окно VST Instruments

В данном окне имеется 32 слота для подключения VSTi, которые соответственно пронумерованы цифрами от 1 до 32. По умолчанию VSTi не подключены ни к одному из слотов, и в каждом слоте имеется надпись No VST Instrument (нет VSTi). Заметим, что для данного окна доступна опция Always on Top, вызываемая щелчком правой кнопкой мыши на нем. Если опция включена, то в ходе работы с Cubase SX окно не будет перекрываться другими окнами и всегда будет оставаться на поверхности. Удобно, когда список подключенных инструментов всегда перед глазами.
Чтобы подключить VSTi к нужному слоту, щелкните на соответствующей надписи No VST Instrument левой кнопкой мыши. Возникнет меню, содержащее названия доступных VSTi. Возможный вид этого меню показан на рис. 4.16, а. После выбора VSTi он окажется подключенным к тому слоту, на котором вы щелкали мышью, вызывая меню (рис. 4.16, б).
Непустой слот отличается от пустых: вместо надписи No VST Instrument появилось название подключенного VSTi (в нашем случае a1). Под названием VSTi отображается название текущего патча, загруженного в инструмент.
Его название можно редактировать. С помощью кнопки [image] вызывается список патчей из текущего банка. Альтернативный способ выбора патчей — их последовательный перебор с помощью кнопок

Рис. 4.16. Подключение VSTi

Кнопкой [image] открывается окно VSTi. VSTi — это плагины, т. е. уникальные программы. Соответственно у разных VSTi окна выглядят по-разному: на них вынесены различные органы управления, присущие для конкретного VST, они имеют различный дизайн. Детальному описанию VSTi посвящена глава 10. Допустим, что кнопкой [image] вы открыли окно VSTi, отрегулировали различные параметры синтеза, добившись нужного звучания. В результате получился уникальный, созданный лично вами патч. Теперь, чтобы его сохранить, нужно воспользоваться кнопкой File. Эта кнопка присутствует и в окне VST Instruments, и в окне любого из VSTi. Кнопка File вызывает меню, состоящее из следующих пунктов:

  • Load Bank — загрузить банк патчей из файла;
  • Save Bank — сохранить банк патчей в файл;
  • Load Instrument — загрузить один патч из файла и сделать его текущим;
  • Save Instrument — сохранить текущий патч в файле.

Стоит упомянуть о кнопке [image] служащей для временного отключения VSTi.
В дальнейшем, если возникнет ситуация, когда необходимый VSTi не звучит, хотя и подключен по всем правилам, проверьте состояние этой кнопки.
Итак, после подключения VSTi к одному из слотов окна VST Instruments можно считать данный инструмент подключенным к проекту. Остается настроить какой-либо MIDI-трек на работу с этим VSTi.
Сделать это очень просто: в параметрах необходимого трека в качестве выходного MIDI-порта укажите название требуемого VSTi (рис. 4.17, а). Этот виртуальный MIDI-порт появился в вашем проекте сразу после подключения VSTi в слот окна VST Instruments.

Рис. 4.17. Выбор VSTi в качестве выходного порта MIDI-трека (а), выбор нужного патча с помощью браузера (б)

Если в качестве входного порта MIDI-трека установлен порт, к которому подключена MIDI-клавиатура, то вы сможете играть на ней звуками VSTi. Напомним, что это возможно в том случае, когда включен режим MIDI Thru и для конкретного MIDI-трека включен мониторинг (оба режима по умолчанию включены).
Вы можете подключать несколько экземпляров одного и того же VSTi. Это имеет смысл делать в том случае, если VSTi являются однотембральными, а вам нужно звучание нескольких патчей одного и того же VSTi. Названия виртуальных MIDI-портов разных экземпляров одного и того же VSTi будут иметь следующий формат: название VSTi, порядковый номер (кроме 1).
Кстати, выбирать патчи VSTi удобнее всего с помощью браузера патчей, расположенного в основной секции инспектора (рис. 4.17, б).
VSTi реализованы посредством VST-плагинов, управляемых по протоколу MIDI. На выходе любого VST-плагина — поток аудиоданных. В конечном счете, этот поток поступает на один из выходных аудиопортов Cubase SX (VST Outputs). Но было бы заманчиво обрабатывать выходной сигнал VSTi любыми аудиоэффектами, доступными из Cubase SX. Это возможно. При подключении VSTi к проекту для данного инструмента на виртуальном микшере Cubase SX (см. главу 5) создается отдельный модуль. По своим функциональным возможностям он практически не отличается от тех модулей микшера, которые соответствуют аудиотрекам. Читая разд. 4.7.8, вам предстоит разобраться в том, как работает автоматизация параметров синтеза VSTi. Забегая вперед, скажем, что для автоматизации VSTi используется специальный трек, на котором (на разных подтреках) могут храниться данные автоматизации всех VSTi, используемых в проекте.


4.2. Атрибуты аудиотрека

Создадим аудиотрек (рис. 4.18). Для этого можно воспользоваться командой главного меню Project > Add Track > Audio. Альтернативный способ — воспользоваться командой Add Audio Track из контекстного меню списка треков.

Рис. 4.18. Окно Cubase SX Project (добавлен аудиотрек}


4.2.1. Атрибуты аудиотрека, доступные из списка треков

В списке треков появилось поле созданного трека (см. рис. 4.18). О том, что данный трек является именно аудиотреком, свидетельствует символ [image] имеющийся в его поле.

Рис. 4.19. Поле аудиотрека в списке треков

Только два атрибута в поле аудиотрека являются присущими именно аудио-, а не MIDI-треку:
— временное отключение эквалайзера;
— переключатель моно/стерео.
Кнопкой [image] включается внутренний мониторинг — трансляция потока звуковых данных сквозь Cubase SX. Аналогичная кнопка имеется и среди атрибутов MIDI-трека. Мониторинг звука является достаточно серьезной проблемой, рассмотренной в разд. 2.7.
Все остальные атрибуты аналогичны тем, что имеются у MIDI-треков. Естественно, следует учитывать, что если речь идет о подключении к аудиотрекам эффектов реального времени, то подразумевается подключение VST-или DX-плагинов, а не MIDI-плагинов.
В правой части поля атрибута аудиотрека имеется индикатор уровня сигнала. В отличие от аналогичного индикатора MIDI-трека он показывает реальный уровень сигнала. С помощью контекстного меню окна Mixer вы можете изменить режим работы всех индикаторов уровня аудиосигналов, присутствующих в проекте (см. разд. 5.2).


4.2.2. Атрибуты и параметры аудиотрека, доступные в поле инспектора; применение аудиоэффектов реального времени

Поле инспектора аудиотрека (рис. 4.20) состоит из пяти секций:

  • основная секция содержит основные параметры трека;
  • секция Inserts служит для подключения аудиоэффектов последовательного действия;
  • секция Equalizers содержит элементы управления параметрическими эквалайзерами;
  • секция Sends служит для подключения аудиоэффектов параллельного действия;
  • секция Channel содержит одну единственную линейку микшера Cubase SX, которая соответствует данному треку.

Параметрические эквалайзеры, в принципе, тоже являются аудиоэффектами реального времени. Однако следует учитывать то, что данные эффекты являются неотъемлемой частью аудиотрека. Они как бы встроены в него. Когда же мы говорим о подключении аудиоэффектов параллельного или последовательного действия, то подразумеваем под этим подключение к аудиотреку VST- или DX-плагинов.


Основная секция инспектора аудиотрека; немного о пространственном панорамировании

Как видно из рис. 4.20, внешне основная секция инспектора аудиотрека мало отличается от аналогичной секции инспектора MIDI-трека. Однако принципиальные отличия все же имеются.

Рис. 4.20. Инспектор аудиотрека (основная секция)

Кнопка [image] — переключает режимы моно/стерео.
Командой главного меню Project > Auto Fades Settings вызывается диалоговое окно Auto Fades, с помощью которого задаются параметры автоматического фейда и кроссфейда. Эти параметры распространяются на все аудио-треки проекта. Однако имеется возможность определять эти параметры индивидуально для каждого из аудиотреков. С помощью кнопки [image] вызывается диалоговое окно Auto Fades — Track:<название трека>. Оно аналогично окну Auto Fades, однако параметры, доступные в нем, распространяются только на текущий трек.
Кнопка [image] открывает диалоговое окно VST Channel Settings, показанное на рис. 4.21. Хотя в заголовке данного окна отображается только название трека, официальное название окна именно VST Channel Settings.
С окном VST Channel Settings мы уже встречались, когда рассматривали атрибуты MIDI-трека. Теперь мы столкнулись с вариантом этого же окна, предназначенным для управления аудиотреком. Можете провести эксперимент: оставить данное окно открытым и выбрать в качестве текущего MIDI-трек. Содержание окна VST Channel Settings изменится соответствующим
образом. Обратите внимание: когда вы щелкнете мышью на окне проекта, чтобы выбрать трек, то окно проекта получит фокус и может закрыть собою окно VST Channel Settings. Поднять VST Channel Settings на "поверхность экрана" (над остальными окнами) можно, выбрав название текущего трека из меню Window.

Рис. 4.21. Диалоговое окно VST Channel Settings (вариант для аудиотрека)

Однако вернемся к рассмотрению окна VST Channel Settings, вызванного для аудиотрека (см. рис. 4.21). В нем собраны практически все параметры аудиотрека. Большинство элементов данного окна дублируется в других секциях инспектора и окна Mixer, которое мы рассмотрим в главе 5. Если приглядеться, то окно VST Channel Settings можно разделить на четыре области (слева направо):

  • секция фейдера громкости, панорамы и других параметров;
  • секция эффектов параллельного действия;
  • секция эквалайзера;
  • секция эффектов последовательного действия.

Особое внимание стоит обратить на секцию эквалайзера, а именно на верхнюю ее часть, в которой отображается амплитудно-частотная характеристика (АЧХ). Здесь АЧХ эквалайзера аудиотрека можно редактировать в графической форме: с помощью курсора мыши вы размещаете узлы АЧХ, расположение которых определяет настройку параметрических фильтров.
С помощью кнопки [image] осуществляется сохранение настроек эквалайзера в пресете, а с помощью кнопки [image] текущий пресет удаляется. Выбрать нужный пресет можно в списке, расположенном левее этих кнопок. По умолчанию пресетам присваиваются названия Preset 1, Preset 2 и т. д. Вы можете переименовать нужный пресет, как вам угодно. Для этого сначала сделайте двойной щелчок на списке пресетов. А затем в возникшем диалоговом окне Type In Preset Name введите название пресета и нажмите ОК.
После каких-либо манипуляций с окном VST Channel Settings могут оказаться полезными кнопки [image] , которые приводят соответствующие секции в исходное состояние.
Вернемся к рассмотрению основной секции инспектора аудиотрека (см. рис. 4.20).
Напомним, что мы рассматриваем те элементы управления, которые отсутствуют в инспекторе MIDI-трека или отличаются от его аналогичных элементов.
В нижней части основной секции имеются два поля: in и out. Здесь можно выбрать входной и выходной порты аудиотрека. Напомним, что с помощью окон VST Inputs и VST Outputs, вызываемых командами главного меню Devices > VST Inputs и Devices > VST Outputs соответственно (см. разд. 2.6), вы можете посмотреть, какие каналы или шины ввода/вывода цифрового звука вам в принципе доступны (это зависит от аппаратных возможностей звуковой карты и ее драйверов). В этих же окнах вы можете включать, выключать, а также переименовывать каналы и шины в случае необходимости.
Итак, в качестве выходного порта аудиотрека можно выбрать канал (например. Left — левый стереоканал), шину (например, BUS 1 — стереопару, включающую в себя каналы Left и Right) или SurroundPan — пространственное панорамирование.
Сделаем небольшое отступление. Для размещения источников звука на стереопанораме фактически используется всего одна координата — удаление источника от центра панорамы (координата лево- право). В зависимости от значения этой координаты будет изменяться громкость сигнала в стереоканалах. Например, при панорамировании источника звука влево громкость сигнала этого источника в левом канале останется без изменений или возрастет в зависимости от выбранного метода панорамирования (параметр Stereo Pan Law окна Project Setup — см. разд. 2.9), а его же громкость в правом канале будет уменьшаться до полного исчезновения сигнала. Если расположить источник звука в центре стереопанорамы, причем сам источник является монофоническим (не имеет кажущейся протяженности по стереопанораме), то его сигнал в левом и правом стереоканалах будет одинаковым. Если же в центре стереопанорамы разместить стереофонический источник звука, то громкость его собственных стереоканалов изменяться не будет. Так устроено стереофоническое панорамирование. Программа изменяет в стереоканалах громкость сигнала, воспроизводимого с трека, в соответствии с описанным выше принципом.
В случае пространственного панорамирования для расположения звуковых источников вокруг слушателя используется уже две координаты: лево- право и впереди- позади. В принципе, не важно, сколько каналов в вашей акустической системе: их может быть по-прежнему всего два, но если в качестве выходного порта аудиотрека выбран SurroundPan, то для позиционирования звуковых источников в пространстве будет использоваться уже две координаты. Напомним, что с помощью команды Devices > VST Master Setup открывается окно диалога VST Master Setup. В этом окне вы указываете Cubase SX, какая именно акустическая система у вас используется (см. разд. 2.6). В зависимости от этого будут применяться конкретные алгоритмы пространственного панорамирования.
В принципе, пространственное панорамирование по своей сути ничем не отличается от панорамирования в стерео. Как и в случае стерео, в зависимости от заданных вами координат источника звука программа будет изменять громкость его сигнала в разных каналах таким образом, чтобы получить его соответствующую пространственную локализацию. Вся разница в количестве каналов. Допустим, у вас квадрофоническая система (четыре канала — левый/правый фронтальные и левый/правый тыловые) и вы размещаете в пространстве монофонический источник. Если его поместить перед собой, то будут звучать левый и правый фронтальные каналы. При перемещении источника слева от себя будут звучать левые фронтальный и тыловой каналы. При размещении источника где-то далеко сзади и слева будет звучать только левый тыловой канат. Еще пример: система 5.1. Фронтальные каналы: левый, центральный, правый; тыловые каналы: левый, правый. При размещении источника перед собой будет звучать центральный канал. При размещении источника справа от себя будут звучать правые фронтальный и тыловой каналы и т. д. Правда, в системе 5.1. имеется еще один канал (в названии системы он обозначается единичкой) — канал сабвуфера. Человек не в состоянии определять направление на источник низкочастотного звука, поэтому где физически будет размещаться сабвуфер — справа, слева, спереди или сзади — не имеет значения. В дальнейшем вы увидите, что в Cubase SX в полной мере поддерживаются возможности многоканальных аудиосистем вплоть до 5.1. И, естественно, у вас будет возможность управлять уровнем сигнала в канале сабвуфера.
А сейчас, совсем не надолго, вернемся к основной секции инспектора аудиотрека (см. рис. 4.20). Допустим, в качестве выходного порта аудиотрека выбран SurroundPan. При этом вид регулятора панорамы в основной секции инспектора останется неизменным и не появится никакого нового регулятора, позволяющего перемещать источник вдоль второй координатной линии (вперед-назад). Поддержка пространственного панорамирования в полной мере реализована в секции Channel инспектора аудиотрека и в микшере (окно Mixer). Кроме того, пространственное панорамирование поддерживается автоматизацией. Это, например, означает, что вы можете заставить как угодно перемещаться вокруг слушателя звук, воспроизводимый с аудиотрека.


Секция Inserts

Секция Inserts (рис. 4.22) служит для подключения аудиоэффектов последовательного действия. Эффекты последовательного действия подключаются к треку по цепочке: при воспроизведении данных с трека происходит их обработка сначала одним эффектом, потом другим и т. д. Иными словами, на вход очередного эффекта поступают данные, уже обработанные предыдущим эффектом. После обработки последним эффектом данные поступают на выходной порт трека.

Рис. 4.22. Секция Inserts инспектора аудиотрека

К аудиотреку можно подключить до восьми эффектов последовательного действия. Слоты для подключения эффектов обозначены цифрами от 1 до 8. По умолчанию ни к одному из них не подключено ни одного эффекта: в каждом из слотов в поле названия эффекта присутствует надпись No Effect (нет эффекта). Чтобы подключить эффект к нужному слоту, щелкните на соответствующей надписи No Effect левой кнопкой мыши, возникнет система меню, включающая в себя все доступные VST- и DX-плагины. В ней и следует выбрать нужный эффект. Надпись No Effect заменится названием подключенного эффекта. Если хотите в этот же слот подключить другой эффект — щелкните по названию ненужного эффекта, появляется меню — выбираете нужный эффект. Если эффект требуется просто отключить — вместо нового эффекта следует выбрать No Effect.
Кнопками [image] имеющимися у каждого из восьми слотов, осуществляется временное отключение эффектов (bypass). Кнопка [image] расположенная на заголовке поля Inserts, предназначена для временного отключения всех эффектов последовательного действия, подключенных к треку.
Кнопки [image] , расположенные около каждого из слотов, служат для вызова панелей эффектов, подключенных к соответствующим слотам. Аналогичная кнопка имеется и на заголовке поля Inserts. Она вызывает диалоговое окно Channel Strip (рис. 4.21).
Вообще кнопки [image] и [image] имеются в заголовках последующих секций инспектора аудиотреков. Мы больше не будем упоминать о них, т. к. их назначение для разных секций остается неизменным.


Секция Equalizers

Секция Equalizers (рис. 4.23) содержит поля четырех фильтров, условно названных hi, hi mid, lo mid и lo. В каждой из секций имеется по три регулятора, расположенных горизонтально. Верхним регулятором задается степень усиления или ослабления сигнала на частоте, заданной средним регулятором. Нижним регулятором задается добротность фильтра.
У каждого из фильтров имеется по кнопке [image] для их временного отключения.

Рис. 4.23. Секция Equalizers инспектора аудиотрека


Секция Sends

Маршрутизация потоков цифрового звука в Cubase SX осуществляется подобно маршрутизации сигналов в классическом аппаратном микшере. Как вы уже знаете, к аудиоканалам можно подключить эффекты в режиме вставки (Insertion). Второй способ применения эффектов в микшере заключается в их подключении к шинам Aux: сигнал с каждого из каналов можно послать на любую из этих шин. После обработки внешними процессорами эффектов сигнал возвращается в общий микс. Регулятором уровня посылаемого на шину сигнала определяется глубина эффекта. Аналогичный способ применения эффектов параллельного действия реализован и в Cubase SX.
В секции Sends (посылы) расположены восемь регуляторов (рис. 4.24, а), обозначенных цифрами от 1 до 8. Каждый из них управляет уровнем сигнала, посылаемого с аудиотрека на одну из восьми шин. В принципе, эти шины можно было бы назвать шинами Aux, но в Cubase SX они не называются никак.

Рис. 4.24. Секция Sends инспектора аудиотрека

Регуляторы уровня посылаемого сигнала распложены горизонтально и на рис. 4.24, а находятся под надписями No Effect.
Кнопка [image] служит для включения/выключения посыла. Кнопкой [image] открывается панель эффекта, на который осуществляется посыл. Кнопкой [image] осуществляется переключение режима посыла: Post или Рrе. Напомним, что режим Рrе — это когда сигнал "отводится" на посыл до того, как он пройдет регулировку уровня громкости, a Post — после регулировки уровня громкости.
С помощью кнопки [image] , расположенной на заголовке секции Sends или команды Devices > VST Send Effects, открывается диалоговое окно VST Send Effects, показанное на рис, 4.25, а. В данном окне имеется восемь слотов-шин для подключения аудиоэффектов. Подключим к первому слоту какой-либо VST- или DX-плагин (рис. 4.25, б). Мы уже неоднократно описывали процедуру подключения эффектов (например, при рассмотрении секции Inserts).
Основное, на что следует обратить здесь внимание, — список, расположенный в правом нижнем углу слота. На нашем рисунке в нем по умолчанию выбран элемент Master. В данном списке выбирается одна из доступных основных шин. На нее будет возвращаться сигнал, обработанный эффектом.

Рис. 4.25.Диалоговое окно VST Send Effects

Итак, сигнал с любого из аудиотреков можно послать на любой из восьми эффектов, подключаемых в окне VST Send Effects. Обработанные сигналы будут возвращены на заданные основные шины. Скорее всего, по умолчанию для вас доступна всего одна основная шина, называемая Master. На эту же шину по умолчанию сводятся сигналы со всех треков. Напомним, что с помощью команды Devices > VST Outputs открывается окно VST Outputs, в котором можно посмотреть, какие основные шины, в принципе, имеются в вашем распоряжении (их состав и особенности зависят от возможностей звуковой карты и ее драйверов). В этом же окне можно включать/выключать основные шины, а также переименовывать их.
Вкратце рассмотрим элементы окна VST Send Effects, доступные при условии, что подключен хотя бы один эффект (рис. 4.25, 6).
Кнопка [image] служит для временного отключения эффекта. Кнопкой [image] открывается панель эффекта. У вас есть возможность перебирать пресеты с настройками эффекта, не открывая его панели. Для этого служат кнопки [image] и [image] Справа от этих кнопок расположено поле-список, в котором отображается название текущего пресета. В нем же можно выбрать пресет по названию. Над кнопками [image] и [image] расположен регулятор уровня сигнала, подаваемого на вход эффекта.
Кнопка File открывает меню, содержащее команды сохранения в файл и считывания из файла отдельных пресетов или целых банков пресетов. Итак, к первому слоту окна VST Send Effects мы подключили эффект. Теперь вернемся к рассмотрению секции Sends инспектора аудиотрека (рис. 4.24, б). Как видите, первый регулятор посыла теперь имеет название эффекта. Обращайте внимание не состояние кнопки [image] (включение/выключение посыла). Подключение эффекта в окне VST Send Effects не означает автоматического включения посыла. Это логично, ведь аудиоэффекты параллельного действия являются общими для всех треков. Подключение эффекта не должно привести к его наложению на все треки, эффекты следует вводить в проект плавно, добавлять "по вкусу".
В завершении раздела хотим обратить ваше внимание на одну особенность применения аудиоэффектов. Практически в каждом из эффектов присутствует параметр, определяющий отношение уровней обработанного и исходного сигнала на выходе эффекта. Обычно этот параметр называется Dry/Wet. Однако в тех VST-плагинах, которые входят в поставку с Cubase, этот параметр называется Mix, хотя возможны и комбинации (например, регулятор называется Mix, а с ним рядом располагаются два поля Dry и Wet). Если эффект подключен к треку в режиме вставки (Inserts), то значение данного параметра подбирается в зависимости от конкретного эффекта. Например, для реверберации значение Dry должно быть больше Wet. Для компрессии на выходе эффекта должен присутствовать только обработанный сигнал (Dry = 0%, Wet = 100% или Mix = 100%). Конечно, жестких правил по применению приведенных в качестве примера эффектов не существует, но любые другие значения Dry/Wet будут просто бессмысленными. Если же аудиоэффект подключен в качестве эффекта параллельного действия (Sends), то в его параметрах следует задавать Dry = 0 %, Wet = 100 % или Mix = 100 %. Тогда соответствующими регуляторами посыла вы сможете регулировать глубину эффекта независимо для каждого из треков. В противном случае необработанный сигнал с выхода эффекта (ведь "противный случай" — это когда Dry > 0 %) будет смешиваться с таким же сигналом с выхода трека. В большинстве ситуаций (когда сигналы с трека и с выхода эффекта поступают на одну и ту же шину) это бессмысленно. Отсюда правило — эффекты, для которых значение Dry должно быть больше 0 или равно 100 % (например, компрессор), применять в качестве эффектов параллельного действия не следует.


Секция Channel

Секция Channel (рис. 4.26, а) содержит одну единственную линейку микшера Cubase SX, которая соответствует данному аудиотреку. Особо стоит отметить, что по сравнению с возможностями микшера (окна Mixer), возможности этой секции инспектора аудиотрека являются сильно урезанными. Тем не менее, если в качестве выходного порта аудиотрека задан виртуальный порт SurroundPan, в секции Channel можно осуществлять пространственное панорамирование. Вместо регулятора стереопанорамы будет доступно поле в форме кружка с точкой [image] Кружок символизирует окружающее пространство, точка — расположение источника звука в этом пространстве (рис. 4.26, б). Точку можно перемещать, но это не самый удобный способ панорамирования. Если сделать двойной щелчок на данном поле, откроется окно Рanner, с помощью которого можно тонко управлять пространственным панорамированием. Подробное описание данного окна мы приведем в разд. 5.4.

Рис. 4.26. Секция Channel инспектора аудиотрека


4.3. Назначение и атрибуты групповых треков

Групповые треки являются вспомогательными. Как и следует из их названия, они предназначены для группировки сигналов от нескольких аудиотреков в целях обработки полученного субмикса одним набором эффектов.
Давайте создадим групповой трек. Для этого можно воспользоваться командой главного меню Project > Add Track > Group Channel. Альтернативный способ — воспользоваться командой Add Group Channel Track из контекстного меню списка треков. Еще нам понадобится минимум два аудиотрека. Их мы и будем группировать. На рис. 4.27 проиллюстрировано следующее: созданы три аудиотрека (Audio 01 — Audio 03) и один групповой трек (Group 01), показано поле группового трека в списке треков и основная секция инспектора группового трека.

Рис. 4.27. Создан групповой трек

В качестве выходных портов группируемых аудиотреков следует выбрать название созданного группового трека (в нашем примере — Group 01). После микширования сигналы сгруппированных треков будут проходить обработку эффектами, подключенными к групповому треку. Применение эффектов к групповому треку ничем не отличается от применения эффектов к аудио-трекам. У инспектора группового трека, как и у инспектора аудиотрека, тоже имеются аналогичные секции Inserts, Equalizers и Sends.
Основная секция инспектора группового трека представляет собой "урезанный вариант" аналогичной секции аудиотрека. Может возникнуть вопрос: куда девается сигнал с выхода группового трека, ведь в основной секции его инспектора нет поля для выбора выходного порта? Здесь-то нам в первый раз и пригодится секция Channel (рис. 4.28, а). Она содержит одну-единственную линейку микшера Cubase SX, которая соответствует данному групповому треку, а только с помощью микшера можно задать выходной аудиопорт для группового трека.

Рис. 4.28. Выбор выходного аудиопорта для группового трека

В самой нижней части линейки отображается название выходного порта группового трека. Если на нем щелкнуть (рис. 4.28, а), то возникнет меню, показанное на рис. 4.28, б. В этом меню и осуществляется выбор выходного аудиопорта. В нашем примере этот выбор невелик. Однако в качестве выходного порта можно было бы выбрать другой групповой трек, если бы он присутствовал в проекте. В принципе, так (по цепочке) можно было бы соединить между собой сколько угодно треков. Для чего это нужно — решать вам. Мы лишь приведем пример использования механизма группировки треков.
Допустим, у вас имеется шесть аудиотреков. Три из них нужно обработать компрессором с одними параметрами, а три других трека — также компрессором, но уже с другими параметрами. Кроме того, нужно иметь возможность корректировки тембра эквалайзером всех этих треков одновременно. Таковы условия вымышленного примера. Если бы не существовало групповых треков, то эта задача решалась бы следующим образом.
К каждому из треков в режиме вставки следовало бы подключить по эффекту компрессии (всего 6 экземпляров плагина компрессора!). Вторая часть задачи — одновременная корректировка тембра всех треков — не решалась бы в принципе. Пришлось бы по очереди выполнять настройки эквалайзера для каждого из треков (фактически было бы задействовано 6 эквалайзеров!). Теперь расскажем о том, как эффектно решается поставленная задача с помощью групповых треков.
Первые три трека объединяются в группу, к ней подключается один эффект компрессии. Вторые три трека объединяются во вторую группу, к ней тоже подключается эффект компрессии, но уже с другими параметрами. Обе группы объединяются в третью группу, и осуществляется регулировка тембра всей группы с помощью эквалайзера третьего группового трека. Итого задействовано два эффекта компрессии и один эквалайзер. Задача решена, ресурсы процессора сэкономлены.


4.4. Секция треков

Секция треков располагается справа от списка треков (рис. 4.29). Каждому полю в списке треков соответствует своя горизонтальная полоса в секции треков. Эта полоса, собственно, и есть трек. Полосы отгорожены друг от друга тонкими "выпуклыми" границами, которые не так-то просто разглядеть на рисунке, но реально они существуют.

Рис. 4.29. Окно Cubase SX Project (большую часть занимает секция треков)


4.4.1. Части (parts), первое знакомство

В нашем примере в проекте имеется два трека: MIDI- и аудиотрек. На них, соответственно, могут храниться MIDI- и аудиосообщения. Однако любые сообщения могут храниться лишь внутри так называемых частей (parts), которые, в свою очередь, хранятся на треках. Причем MIDI-сообщения могут храниться только в MIDI-частях, которые могут располагаться только на MIDI-треках. Аудиосообщения могут храниться непосредственно на аудиотреках.
Части создаются автоматически во время записи MIDI- или аудиоинформации. Однако существует и другой путь создания частей. Нажмите кнопку [image] расположенную на панели инструментов окна проекта. Данный инструмент называется Draw (рисовать). Нарисуем с его помощью прямоугольник, расположенный на MIDI-треке. Для этого подведем курсор к тому месту трека, где будет находиться одна из сторон прямоугольника (рис. 4.30, а), нажмем левую кнопку мыши и потащим курсор мыши по горизонтали (4.30, б). Около курсора будет отображаться текущая координата курсора на оси времени и длина (Length) рисуемого прямоугольника. Когда мы отпустим кнопку мыши, возникнет некий прямоугольный объект (на рис. 4.30, в он называется MIDI 01). Этот объект есть не что иное, как часть. В данном случае она не содержит внутри себя ни одного MIDI-сообщения.

Рис. 4.30.Создание части с помощью инструмента Draw

Нажмите кнопку [image] расположенную на панели инструментов окна проекта. Инструмент называется Object Selection (выбор объекта). После этого сделайте двойной щелчок над только что нарисованной частью. Если вы не изменили соответствующую опцию диалогового окна Preferences, вызываемого командой главного меню File > Preferences, то после двойного щелчка откроется окно Key Editor (рис. 4.31, а) — редактор отпечатков клавиш.

Рис. 4.31. Рисование отпечатков клавиш

С его помощью вы можете нарисовать (рис. 4.31, а, б) и отредактировать отпечатки MIDI-клавиш. Чтобы нарисовать отпечаток клавиши, воспользуйтесь инструментом [image] (Draw), расположенным на панели инструментов окна Key Editor. Каждый из этих отпечатков соответствует сообщению типа Note. Когда вы будете их рисовать, будет звучать тот инструмент, на работу с которым настроен данный MIDI-трек.
Все отпечатки клавиш, которые вы нарисуете, будут относиться только к той части, щелчком на которой был вызван редактор Key Editor. Закроем окно редактора отпечатков клавиш (подробно мы поговорим о нем в разд. 6.3), и посмотрим, что получилось с нашей частью (рис. 4.32, а).
Теперь часть не пуста, в ней появились горизонтальные черточки — они соответствуют сообщениям типа Note.
В принципе, сообщения могут находиться за пределами части. Дело в том, что вы можете передвигать вертикальные границы части. Для этого в нижних углах части имеются маленькие белые квадраты. Ухватившись за любой из этих квадратов, вы можете передвигать границу в любом направлении, например в направлении другой границы (рис. 4.32, б).

Рис. 4.32. В часть добавлено два сообщения типа Note

Вы можете так "задвинуть" границу части, что она вообще не будет иметь протяженности на оси времени (рис. 4.32, в). Тем не менее, все сообщения, находящиеся внутри части, останутся на своих местах. В этом легко убедиться, если вернуть границу части на ее прежнее место (рис. 4.32, г). Прямоугольник части следует воспринимать как некое окно: если сообщения видны в этом окне, они будут воспроизводиться при воспроизведении всего проекта. Если они скрыты за пределами окна, то и воспроизводиться не будут. Тем не менее, если данные сообщения в принципе существуют, то они будут существовать вне зависимости от того, видим мы их или нет.
На панели инструментов окна проекта (справа) имеется поле Color Selector (выглядит как цветовая палитра). Щелчком на данном поле открывается меню, в котором можно задать цвет для выбранной части (или группы частей). В этом же меню имеется команда Select Colors. Она открывает диалоговое окно Event Colors Setup, с помощью которого можно очень тонко настраивать оттенки цветов в палитре. Есть ли в этом необходимость — решать вам.


4.4.2. Шкала времени Ruler, указатель текущей позиции, расширенные функции управления воспроизведением проекта и изменение масштаба отображения графических объектов секции треков

В верхней части секции треков расположена черная шкала времени (Ruler) с номерами тактов. Если вы не изменили опцию Display Format в диалоговом окне Project Setup, вызываемого командой главного меню Project > Project Setup, то. по умолчанию шкала времени будет отградуирована в формате такт: доля (Basr+Beats). Цифры от 1 до 4 на рис. 4.33 — это номера тактов. Если вы хотите быстро изменить формат шкалы времени, щелкните на кнопке [image] расположенной справа от шкалы. Возникнет раскрывающийся список, в котором вы сможете выбрать новый формат времени.

Рис. 4.33. Шкала времени и указатель текущей позиции проекта

В действительности шкала времени разделена невидимой горизонтальной границей на две половины. Если один раз щелкнуть на нижней половине, то в точку, соответствующую положению курсора, переместится указатель текущей позиции проекта — вертикальная линия. Начиная от указателя текущей позиции, будет осуществляться воспроизведение проекта, если вы подадите соответствующую команду. Когда вы перемещаете указатель текущей позиции в необходимое место проекта и запускаете воспроизведение, программа проделывает невидимую работу — приводит MIDI-устройства в состояние, актуальное для данной позиции проекта. Если где-то перед текущей позицией проекта находятся сообщения о смене MIDI-инструмента, об изменении значений каких-либо контроллеров и т. п., то соответствующие MIDI-сообщения передаются на выходные порты MIDI-треков в момент, предшествующий началу воспроизведения.
В разделе Chase Events Filter окна Preferences, вызываемого командой главного меню Edit > Preferences, вы можете исключить отдельные виды сообщений из перечня актуализируемых. Например, по умолчанию установлен флажок Sysex. Это значит, что актуальные для новой позиции проекта сообщения типа Sysex не будут пересылаться при запуске воспроизведения.
Во время воспроизведения линия указателя текущей позиции будет плавно перемещаться слева направо, указывая на то место проекта, которое воспроизводится в данный момент.
Если на панели инструментов окна проекта нажата кнопка [image] (Autoscroll), то во время воспроизведения проекта будет осуществляться автоматический скроллинг секции треков и текущая позиция проекта всегда будет находиться в зоне видимости. В противном случае указатель текущей позиции может уйти за пределы видимой области проекта.
Воспроизведение проекта может быть инициировано нажатием кнопки [image] (Start) на панели инструментов окна проекта или на транспортной панели. Чтобы остановить воспроизведение проекта, можно воспользоваться кнопкой [image] (Stop). Однако это не единственный способ запуска/остановки воспроизведения. Конечно, можно пользоваться горячими клавишами, но в Cubase SX существуют расширенные функции для управления воспроизведением проекта. Например, двойной щелчок на нижней половине шкалы времени вызывает воспроизведение проекта, начиная с позиции курсора.
На панели инструментов окна проекта имеется кнопка [image] (Scrub) или [image] (Play), точнее, на одном и том же месте может располагаться одна из названных кнопок. Например, если в данный момент доступна кнопка [image] (Scrub), а вам потребуется кнопка [image] (Play), то следует выполнить следующие действия:

  • нажать кнопку [image] (Scrub) (она окрасится в бирюзовый цвет);
  • повторным щелчком на кнопке [image] (Scrub) вызвать меню;
  • в меню выбрать другую функцию для кнопки — Play.

При смене функции изменится и изображение кнопки, поэтому можно говорить о двух кнопках, которые могут располагаться на одном и том же месте. С подобными кнопками вы еще не раз столкнетесь. От всех остальных они отличаются наличием маленького треугольника в правом нижнем углу.
А теперь вернемся к выяснению того, для чего, собственно, нужны инструменты [image] (Scrub) и [image] (Play). Инструменту [image] (Scrub) в секции треков соответствует курсор мыши [image] . Если сделать один щелчок левой кнопкой мыши, то указатель текущей позиции переместится в позицию курсора. Если перемещать курсор мыши, удерживая нажатой ее левую кнопку, то начнется воспроизведение проекта. Однако воспроизведение будет несколько специфичным: указатель текущей позиции будет стремиться поспеть за курсором мыши. Причем чем дальше указатель от курсора, тем с большей скоростью будет осуществляться воспроизведение. А по мере приближения указателя к курсору скорость воспроизведения будет замедляться. Однако если слишком резко дернуть курсор, то указатель текущей позиции не станет за ним гоняться, а просто "прыгнет" к нему. При таких делах и речи быть не может о том, чтобы воспроизведение осуществлялось в соответствии с заданным темпом. Воспроизведение вообще может осуществляться в обратную сторону! Для чего же нужен режим Scrub? Представьте, что перед вами проигрыватель виниловых дисков. Рукой вы можете замедлить вращение диска, остановить его или заставить вращаться в обратном направлении. Такими приемами часто пользуются DJ. Режим Scrub позволяет использовать эти приемы в Cubase SX, но несколько в других целях: вы можете тщательно, неоднократно прослушать нужный фрагмент проекта, не отвлекаясь при этом на лишние нажатия кнопок.
Режим [image] (Play) тоже служит этой цели, но является более консервативным: если разместить курсор мыши (в данном режиме он примет вид [image] над секцией треков, нажать и удерживать нажатой левую кнопку мыши, то начнется воспроизведение проекта с нормальной скоростью, начиная с позиции курсора. Как только вы отпустите кнопку мыши, воспроизведение прекратится.
Вернемся к рассмотрению шкалы времени. Если подвести курсор мыши к верхней половине шкалы времени, то он примет форму карандаша. С помощью карандаша вы можете обозначить отрезок проекта, ограниченный левым и правым локаторами (рис. 4.34, а). Графически локаторы отображаются в виде треугольников, соединенных линией. О том, что такое локаторы и для чего они нужны, мы рассказали в разд. 3.2. На всякий случай
напомним, что локаторы — это многофункциональные указатели, ограничивающие на оси времени некую область проекта, с которой предполагается выполнять какие-либо действия. Например, если сделать двойной щелчок на области какого-либо трека, расположенной между локаторами, то в этом месте будет создана часть.
Ухватившись курсором за один из локаторов, вы можете перемещать его в горизонтальном направлении. Обратите внимание на то, что отрезок проекта, ограниченный локаторами, можно нечаянно "вывернуть на изнанку". Это произойдет в том случае, если правый локатор окажется левее левого локатора, а левый локатор, соответственно, окажется правее правого (рис. 4.34, б). В этом случае некоторые функции просто не будут работать. Например, вы не сможете включить режим циклического воспроизведения/записи. Напомним, что данный режим включается кнопкой [image] , расположенной на транспортной панели или на панели инструментов окна проекта.

Рис. 4.34. Выделение отрезка проекта локаторами

В области окна проекта, занимаемой секцией треков, присутствуют полосы прокрутки, с помощью которых вы можете выбирать фрагмент проекта, отображаемый в секции и доступный для редактирования. Полосы прокрутки — не самый удобный способ "перемотки" проекта. Тем не менее, такой способ существует, и вы можете его использовать. Если у вашей мыши имеется колесо для скроллинга, то в данном случае вы его можете задействовать: щелкаете один раз на полосе прокрутки (чтобы она получила фокус), после чего вращаете колесо — происходит скроллинг.
В правом нижнем углу окна проекта имеются поля [image] . С их помощью вы можете изменять масштаб отображения графических объектов секции треков по горизонтали и по вертикали. Слева от такого поля назначенного для изменения масштаба по горизонтали, расположена кнопка [image] . Нажатием на нее вызывается меню команд, связанных с изменением масштаба по горизонтали. Перечислим их:

  • Zoom Full — изменить масштаб так, чтобы в секции треков умещались все части проекта;
  • Zoom to Locators — изменить масштаб так, чтобы область проекта, ограниченная локаторами, занимала всю секцию треков;
  • Add — сохранить текущий масштаб в виде пресета;
  • Organize — вызвать окно органайзера пресетов горизонтального масштаба.

Вызов команды Add приведет к появлению стандартного для Cubase SX окна диалога Type In Preset Name для ввода названия сохраняемого пресета. После сохранения нового пресета соответствующий пункт добавится в меню, команды которого мы только что перечислили.
Команда Organizer вызывает окно, показанное на рис. 4.35. Окно содержит список имеющихся пресетов масштаба по горизонтали Zoom Presets. С помощью кнопки Rename вы можете переименовать выбранный пресет, а с помощью кнопки Delete — удалить его.

Рис. 4.35.Органайзер пресетов масштаба по горизонтали

Над полем, предназначенным для изменения масштаба по вертикали, также имеется кнопка > [image] . Нажатием на нее вызывается меню команд, связанных с изменением масштаба по вертикали:

  • Zoom Tracks 1 Rows — установить такой масштаб и высоту треков, чтобы в соответствующих им полях списка треков умещалось по одному ряду атрибутов;
  • Zoom Tracks 2 Rows и Zoom Tracks 3 Rows — команды аналогичны предыдущей с поправкой, что ширина полей треков будет соответствовать 2 и 3 рядам атрибутов;
  • Zoom Tracks 4 Rows — команда подобна предыдущим, только количество рядов атрибутов треков задается вами в окне диалога Type in number of rows;
  • Zoom Tracks Full — установить такую высоту треков, чтобы они все умещались в окне проекта (по вертикали);
  • Zoom 4 Tracks и Zoom 8 Tracks — установить такую высоту треков, чтобы в окне проекта по вертикали умещалось 4 и 8 треков соответственно;
  • Zoom N Tracks — команда подобна предыдущим, только количество видимых в окне проекта треков вы задаете сами в диалоговом окне Type in number of tracks;
  • Zoom Tracks Minimal — установить минимальную высоту треков;
  • Если включена опция Snap Track Heights, то изменять высоту отдельных треков вы сможете с дискретностью, соответствующей одному ряду атрибутов.

В правой верхней области секции треков имеется расположенный вертикально регулятор. С его помощью можно изменять масштаб отображения сообщений в частях. Например, на рис. 4.36, а, б показан вид MIDI-часги при разных положениях регулятора. Каждая горизонтальная черта в ней соответствует MIDI-сообщению.

Рис. 4.36. Изменение масштаба отображения сообщений в частях

В Cubase SX предусмотрено мощное средство для управления масштабом отображения проекта по вертикали и быстрого доступа к любой точке проекта.
На панели инструментов окна проекта имеется кнопка [image] (Show Overview). Если ее нажать, под панелью инструментов окна проекта появится дополнительная область Overview (обзор), возможный вид которой показан на рис. 4.37. Маленькими закрашенными прямоугольниками на ней отображаются части. Большая прямоугольная рамка (the track view rectangle) соответствует области проекта, отображаемой в секции треков. Ухватившись мышью за вертикальный край рамки, вы можете изменять размер прямоугольника по горизонтали. Размер видимой области проекта изменится. При этом, естественно, изменится масштаб отображения объектов секции треков таким образом, чтобы видимая область вписалась в размер секции треков.

Рис. 4.37. Поле обзора проекта

Вы можете ухватиться за прямоугольную рамку обзора и перетащить в горизонтальном направлении (хвататься нужно за нижнюю половинку области, ограниченной рамкой). При этом в секции треков будет осуществляться скроллинг, соответствующий перемещению рамки.
Еще одна возможность: вы можете нарисовать рамку на новом месте. Подводите курсор мыши в нужное место на поле обзора проекта, нажмите левую кнопку мыши, удерживайте ее и перемещайте курсор по горизонтали. Когда вы отпустите кнопку мыши, рамка обзора окажется на новом месте: ее вертикальные границы будут соответствовать позициям курсора в моменты нажатия и отпускания кнопки мыши.
В Cubase SX имеется еще одно средство управления масштабом секции треков! На панели инструментов окна проекта имеется кнопка [image] (Zoom).
Если с помощью данного инструмента выделить область секции треков, то вертикальный и горизонтальный масштабы изменятся таким образом, чтобы выделенная область занимала всю секцию треков. На всякий случай поясним, что "выделить область" фактически означает построить с помощью курсора мыши прямоугольник так, как это делается в графических редакторах. Кстати, вы можете использовать инструмент [image] (Zoom) и по-другому: щелкать им на области треков. При этом масштаб будет увеличиваться (изображение будет становиться более детальным). Если использовать инструмент [image] (Zoom) в сочетании с одной из клавиш: <Ctrl>, <Shift> или <АН>, то результат будет следующим:

  • (Zoom) + <Alt> — уменьшение масштаба по горизонтали;
  • (Zoom) + <Shift> — весь проект будет сделан видимым;
  • (Zoom) + <Ctrl> — уменьшение масштаба по горизонтали и по вертикали.


4.4.3. Запись MIDI и звука

Проведем несколько практических занятий по осуществлению записи MIDI- и аудиоинформации. Заметим, что в Cubase SX существует возможность импортирования MIDI- и аудиофайлов, файлов в форматах предыдущих версий Cubase. To есть запись MIDI и звука — не единственный возможный источник материала для вашего проекта.


Подготовка MIDI- и аудиотреков к записи

Подготовим какой-нибудь один MIDI- или аудиотрек к записи. Подготовка MIDI-трека сводится к выполнению следующих действий:

  • создать MIDI-трек (если в этом есть необходимость);
  • если трек уже существует, нужно щелкнуть на соответствующем поле в списке треков. При этом данный трек окажется выделенным, его атрибут Record Enable (готовность к записи) окажется включенным (при условии, что в настройках — File > Preferences > Editing — установлен флажок Enable Record on Selected Track), инспектор будет отображать атрибуты данного трека;
  • если атрибут Record Enable выключен (такое возможно при сброшенном флажке Enable Record on Selected Track), то его следует включить;
  • в поле in: основной секции инспектора следует выбрать входной MIDI-порт, к которому подключена MIDI-клавиатура;
  • в поле out: следует выбрать MIDI-порт, к которому подключен синтезатор или сэмплер, звуками которого вы собираетесь играть на MID1-клавиатуре;
  • если требуется, следует выбрать выходной MIDI-канал, банк, патч, соответствующий нужному тембру, или выбрать непосредственно сам тембр по его названию.

Если вы собираетесь играть звуками виртуального инструмента VST, то соответствующий инструмент должен быть предварительно подключен к вашему проекту (см. разд. 4.1.3).
Подготовка аудиотрека к записи по своей идеологии ничем не отличается от подготовки MIDI-трека. Вся разница заключается в том, что для данного трека вы должны указать в качестве входного аудиопорта тот порт, который соответствует микрофону или какому-либо другому источнику аудиосигнала. Однако у записи звука имеется своя особенность: вы должны правильно подобрать уровень записываемого сигнала. При включенном атрибуте Record Enable индикатор уровня сигнала аудиотрека будет показывать уровень сигнала, поступающего через заданный входной аудиопорт. Вы должны попросить вокалиста или исполнителя спеть или сыграть ту партию, которую предполагается записать. В ходе этой репетиции регулятором микшера звуковой карты вы должны подобрать уровень записываемого сигнала таким, чтобы не происходило клиппирования (индикатор не должен попадать в красную зону) и в то же время сигнал должен быть достаточно сильным. При этом удобнее всего пользоваться индикатором уровня сигнала, расположенным в секции Channel поля инспектора.
Вы будете вынуждены обратить внимание на то, что регулятор уровня сигнала, являющийся атрибутом трека, никак не воздействует на уровень сигнала, поступающего на трек. Он управляет уровнем сигнала, воспроизводимого с трека и не более того.
Подбирать уровень записываемого сигнала нужно с помощью микшера звуковой карты. Однако в некоторых случаях, обусловленных особенностями драйверов звуковой карты, сделать это затруднительно. Например, при использовании ASIO-драйверов некоторых звуковых карт сигнал с их кодека поступает в Cubase SX, минуя микшер. Единственный способ подбора уровня сигнала в данном случае — воспользоваться регулировками микрофонного предусилителя или микшера, через который к компьютеру подключен микрофон либо другой источник аудиосигнала. Приведем пример еще одной возможной проблемы на примере работы со звуковой картой SB Audigy. Допустим, микрофон подключен непосредственно к микрофонному входу звуковой карты. Записать сигнал, поступающий с микрофона, можно через ASIO-порты, которые на панели VST Inputs (см. разд. 2.6) называются MIX (Pre-EQ) L/R или MIX (Post-EQ) L/R. С помощью микшера данной звуковой карты вы сможете регулировать уровень микрофонного сигнала в общем миксе. Однако во время записи в этот микс попадет звучание остальных треков вашего проекта, а ведь вам нужно записать только сигнал от микрофона!
Чтобы избежать каких-либо проблем с записью вокала или акустических инструментов, мы рекомендуем использовать в домашней звуковой студии для этой цели следующее оборудование:

  • полупрофессиональную звуковую карту класса M-Audio Audiophile 2496, единственным назначением которой является высококачественная запись и воспроизведение цифрового звука (подобные звуковые карты стоят не дороже мультимедийных звуковых карт из верхней ценовой категории);
  • высококачественный микрофонный предусилитель (возможно, в составе микшера);
  • высококачественный микрофон (желательно конденсаторный).

Конечно, такой комплект стоит дороже мультимедийной звуковой карты и мультимедийного микрофона, однако без него вы просто не сможете реализовать возможности Cubase SX. Если же вы предполагаете использовать Cubase SX только для записи инструментальных композиций без привлечения живых инструментов, тогда, естественно, перечисленное выше оборудование может и не понадобиться. Тем не менее, вы должны иметь качественную звуковую карту хотя бы для того, чтобы слушать результаты вашей деятельности.
Еще она деталь, на которую следует обратить внимание при записи звука, — имеет смысл задать такой режим для аудиотрека (моно или стерео), который бы соответствовал реальным свойствам записываемого сигнала. Например, если вы записываете звук с монофонического микрофона, то трек, соответственно, имеет смысл сделать монофоническим. Если вы записываете звучание стереофонического синтезатора, трек должен быть стереофоническим.
Напомним, что до записи и во время нее вы можете использовать внутренний мониторинг (см. разд. 2.7).


Способы переключения программы в режим записи

Будем считать, что MIDI- или аудиотрек готов к записи. Переключить программу в режим записи можно несколькими способами. Приведем некоторые из них.

Способ 1. На шкале времени The ruler следует подвести левый локатор к той позиции, начиная с которой необходимо произвести запись. Нажать кнопку [image] (Record) на транспортной панели или на панели инструментов окна проекта.
Способ 2. Отвести указатель текущей позиции проекта левее того места, начиная с которого необходимо осуществить запись. Кнопкой [image] (Start) на транспортной панели или на панели инструментов окна проекта запустить воспроизведение проекта. Когда указатель текущей позиции дойдет до нужного места, нажать кнопку [image] для переключения в режим записи.
Способ 3. На шкале времени The ruler следует подвести левый локатор к той позиции, начиная с которой необходимо произвести запись. Отвести указатель текущей позиции проекта левее левого локатора. На транспортной панели нажать кнопку [image] (punch in). Кнопкой [image] (Start) на транспортной панели или на панели инструментов окна проекта запустить воспроизведение проекта. Когда указатель текущей позиции подойдет к позиции левого локатора, произойдет автоматическое переключение в режим записи. Если же вместо кнопки [image] нажать кнопку [image] то запись начнется сразу с той позиции, что соответствует левому локатору.
Способ 4. Данный способ является развитием способа 3. Если нажать на транспортной панели кнопку [image] (punch out), то при достижении указателем текущей позиции правого локатора произойдет автоматический выход из режима записи. То есть получается, что с помощью левого и правого локаторов вы ограничиваете отрезок проекта, в пределах которого будет автоматически выполняться запись. Повторимся, что вы должны проследить за тем, чтобы левый локатор не оказался правее правого и наоборот. В противном случае выполнить запись не удастся.
Режим записи бок о бок соседствует с режимом воспроизведения. То есть невозможно запустить программу в режиме записи, чтобы при этом не работал режим воспроизведения. Если в вашем проекте уже существуют другие треки с записанными на них партиями инструментов, то в режиме записи вы будете слышать их звучание.
В режиме записи вам (или исполнителю, с которым вы работаете) следует исполнить то, ради чего организован сеанс записи (спеть вокальную партию в микрофон или сыграть мелодию на MIDI-клавиатуре). Чтобы остановить запись, воспользуйтесь кнопкой [image] (Stop) на транспортной панели или панели инструментов окна проекта.
В результате записи MIDI, должна появиться часть, содержащая записанные сообщения. В результате записи звука, на аудиотреке должно появиться звуковое сообщение, возможный вид которого показан на рис. 4.38.

Рис. 4.38. Аудиосообщение содержит вокальную партию

Знаете, как убедиться в том, что данный графический объект является именно аудиосообщением, а не частью? Если выбрать аудиосообщение, щелкнув на нем, в его верхней части появятся три маленьких фигуры (два треугольника и квадрат), называемых узлами. Перемещая их, можно сформировать огибающую громкости для данного аудиосообщения. У частей огибающих не бывает.
Если вы собираетесь выполнить запись на MIDI-трек, который уже содержит какую-то информацию, то стоит обратить внимание на существование описанных ниже режимов записи.


Режимы записи, циклическая запись, регионы аудиосообщений

На транспортной панели имеется область, показанная на рис. 4.39. В ее верхней части (поле Rec Mode) щелчком на надписи Normal или Merge переключается способ записи новой части, если она нахлестывается на ту часть, что уже существует:

  • Normal — новая часть будет замешать собою существующую;
  • Merge — новые сообщения будут дописываться в существующую часть.

Рис. 4.39. Режимы записи, доступные с транспортной панели

В последнем случае в старой части сохранятся и те сообщения, что там уже присутствовали, и записанные вновь.
Что касается аудиосообщений и аудиочастей, то на них описанные режимы записи не распространяются. При записи новых аудиосообщений поверх существующих аудиосообщений или частей происходит их наслоение. Аудиосообщения оказываются как бы одно над другим. Новые сообщения находятся на поверхности экрана, а старые оказываются "под ними". При воспроизведении выводится та аудиоинформация, которая находится именно на поверхности. С помощью команды То Front контекстного меню, вызываемого щелчком правой кнопки мыши над "слоеными" аудиосообщениями или частями, вы можете выбрать любые из них для отображения на поверхности экрана. В дальнейшем вы можете растащить наслоившиеся аудиосообщения на разные треки или в разные позиции одного трека. Одним словом, никаких потерь информации при записи одного аудиосообщения поверх другого не происходит.
На транспортной панели имеется кнопка [image] (Loop), включающая режим циклического воспроизведения/записи. Циклическую запись можно применять в комбинации со всеми способами записи, описанными в предыдущем разделе.
С точки зрения пользователя, циклическая запись происходит следующим образом:

  • запись происходит только на отрезке проекта, ограниченном левым и правым локаторами;
  • при достижении указателем текущей позиции правого локатора, указатель перескакивает в позицию левого локатора (в начало цикла), и так происходит до тех пор, пока вы не нажмете кнопку [image] (Stop).

Существуют два режима циклической записи MIDI-сообщений. В нижней части области транспортной панели, показанной на рис. 4.39, имеется поле Cycle Rec. Щелчком на надписи Mix или Overwrite переключаются режимы циклической записи:

  • Mix — при каждом циклическом проходе от левого локатора к правому новые сообщения будут добавляться в часть без удаления уже существующих сообщений;
  • Overwrite — при каждом очередном проходе ранее записанные сообщения будут удаляться.

Первый режим может быть полезен, например, в том случае, если вы хотите записать партию ударных инструментов за несколько проходов: при первом проходе прописываете партию большого барабана, при втором — партию малого барабана и т. д.
Второй режим может быть полезен в том случае, если вы хотите записать импровизацию: запускаете циклическую запись и импровизируете. Если чувствуете, что последний вариант вам понравился, — останавливаете запись.
Описанные режимы циклической записи опять-таки не распространяются на запись звука.
Для аудиосообщений существуют другие режимы циклической записи. Однако прежде чем перейти к их рассмотрению, следует немного углубиться в изучение сущности аудиосообщений Cubase SX.
Как мы уже говорили, аудиосообщение представляет собой объект, содержащий ссылку на звуковой файл и набор неких атрибутов. Среди этих атрибутов, например, имеются координаты узлов, формирующих огибающую громкости, атрибуты Event Start и Event End — координаты начала и окончания воспроизводимой области звукового файла, отсчитываемые от его начала, и др. Однако в данный момент нас больше интересует то, что аудиосообщения могут быть как бы многослойными — содержать несколько регионов. Один аудиофайл может быть разбит на несколько регионов. Физически, конечно, звуковой файл остается неделимым, и отсчеты звуковых волн хранятся последовательно — в том же порядке, в каком они были записаны. Но среди атрибутов аудиосообшений могут присутствовать метки начат и окончаний регионов (координаты границ регионов, задаваемые от начала сэмпла). Причем не существует никаких жестких ограничений на расположение этих меток. Поэтому регионы могут иметь произвольную длину (не выходящую за пределы сэмпла) и располагаться внахлест. Однако метка начала региона не может располагаться после метки ее окончания, Cubase SX просто не допускает этого. В окне проекта может отображаться и воспроизводиться только один регион аудиосообщения. Если вызвать контекстное меню, щелкнув правой кнопкой мыши на аудиосообщений, то в нем будет доступна команда Set To Region, с помощью которой можно выбрать тот регион сообщения, который будет использоваться в проекте. Если уж нам быть совсем точными, то в действительности при выборе региона из окна проекта происходит вот что: координата метки Event Start приравнивается к координате начала выбранного региона, а координата Event End приравнивается к координате его окончания.
А сейчас вернемся к рассмотрению режимов циклической записи аудиосообшений.
Командой главного меню File > Preferences открывается диалоговое окно, содержащее всевозможные опции Cubase SX. В левой части окна следует выбрать раздел Audio, тогда в правой части окна станут доступными опции, имеющие отношение к записи звука (рис. 4.40).

Рис. 4.40. Окно Preferences, раздел Audio

Среди них имеется список Cycle Record Mode (режим циклической записи). В нем можно выбрать один из трех режимов циклической записи звука.

  • Create Regions — при каждом очередном проходе цикла внутри аудиосообщения будет создаваться новый регион. В результате прохода нескольких циклов будет записано многослойное аудиосообщение, а на поверхности (воспроизводимым) будет тот регион, что был записан в последнюю очередь;
  • Create Events — при каждом проходе цикла будет создаваться новое аудиосообшение. В результате аудиосообщения окажутся наслоенными друг на друга;
  • Create Events + Regions — комбинация первых двух режимов. В результате циклической записи будут создаваться новые аудиосообщения. А в каждом из аудиосообщений будут создаваться регионы, соответствующие каждому из проходов цикла. В результате записи N проходов цикла у вас образуется N практически одинаковых аудиосообщений, каждое из которых будет содержать N регионов.

Может создаться впечатление, что последний способ является расточительным из-за того, что общее число регионов окажется равным N в квадрате. Однако в действительности все сообщения будут создаваться на базе одного и того же звукового файла (все сообщения будут содержать ссылку на один и тот же файл). А для хранения в памяти компьютера меток требуется несопоставимо меньше места, чем для хранения аудиоданных.
Допустим, что вы выполнили циклическую запись фрагмента вокальной партии, и при этом использовался режим Create Regions. В результате у вас образовалось аудиосообщение, содержащее несколько регионов. Каждый из регионов соответствует разным вариантам исполнения партии. С помощью команды контекстного меню Set To Region (о ней мы уже упоминали) вы можете перебирать варианты исполнения.
Последнее замечание, которое мы хотим сделать относительно циклической записи, — следите за тем, чтобы кнопка [image] (punch out) на транспортной панели не оказалась случайно нажатой. Иначе после первого прохода цикла программа выйдет из режима записи, и дальше будет продолжаться циклическое воспроизведение.


4.4.4. Привязка графических объектов, первое знакомство с квантизацией

Все операции по перемещению любых графических объектов и частей, в частности, выполняются с помощью мыши. Однако разрешающая способность любого манипулятора ограничена. Без специальных средств было бы очень трудно, например, совместить начало перемещаемой части с началом такта в том масштабе, в котором выполняется основная работа в секции треков.
Средство это существует во многих редакторах, включая Cubase SX. Называется оно Snap (привязка).
Режим привязки включается кнопкой [image] (Snap), расположенной на панели инструментов окна проекта. Справа от этой кнопки расположено поле Snap Mode Selector (выбор режима привязки), показанное на рис. 4.41. Щелчком на нем открывается меню, содержащее различные режимы привязки. Каждый режим имеет свое графическое обозначение и название. Перечислим их.

  • Grid [image] — привязка к узлам невидимой сетки;
  • Events [image] — привязка к границам (началам и окончаниям) сообщений;
  • Shuffle [image] — режим "перетасовки", при котором перемещаемые части или аудиосообщения могут следовать только друг за другом;
  • Magnetic Cursor ( [image] ) — привязка к указателю текущей позиции;
  • Grid + Cursor ( [image] ) — комбинация режимов Grid и Magnetic Cursor;
  • Events + Cursor ( [image] ) — комбинация режимов Events и Magnetic Cursor;
  • Events + Grid + Cursor ( [image] ) — комбинация режимов Events, Grid и Magnetic Cursor.

Рис. 4.41. Поля Mode Selector, Grid Selector, Quantize Setup (слева направо)

Наиболее универсальным можно считать режим Grid. Когда он включен, перемешаемые пользователем графические объекты (включая локаторы) "прилипают" к узлам невидимой сетки. Шаг сетки задается в поле Grid Selector, расположенном справа от поля Snap Mode Selector (рис. 4.41):

  • Ваr — использовать шаг сетки, равный такту;
  • Beat — использовать шаг сетки, равный доле;
  • Use Quantize — использовать шаг сетки такой же, как и шаг квантизации.

Квантизация предназначена для коррекции неидеальности "живой" игры музыканта. Понятие квантизации бок о бок идет с понятием привязки объектов к сетке, но применяется квантизация только к сообщениям типа Note (сообщение о нажатии MIDI-клавиши).
Традиционная квантизация — это привязка начальных позиции и протяженности сообщения типа Note к узлам невидимой сетки, расположенной вдоль оси времени, поэтому моменты возникновения и длительности звуков будут кратны шагу сетки. С точки зрения пользователя квантизация выглядит так: выделяете одну или несколько MlDl-частей (или отдельные сообщения внутри части) и подаете специальную команду. После этого начала или длительности нот (в зависимости от команды) притягиваются к ближайшим узлам сетки. Существует еще режим автоматической квантизации, включаемый кнопкой AQ, расположенной на транспортной панели. В этом режиме квантизации будут подвергаться все записываемые сообщения типа Note.
Шаг квантизации выбирается в меню, вызываемом щелчком на поле Quantize Selector (рис. 4.41), расположенном справа от поля Grid Selector. Кроме стандартных пресетов, в данном меню вы можете выбрать команду Setup, открывающую окно диалога Quantize Setup. В данном окне вы можете более тонко настроить работу квантизации. В частности, можно сделать привязку нот к узлам сетки нежесткой. Это позволит частично сохранить неидеальность живой игры и тем самым избежать ощущения "компьютерности".
Подробно о квантизации мы расскажем в главе 6.
В завершение раздела заметим, что если включен режим привязки к сетке, то это распространяется и на объекты, создаваемые при записи (части и аудиосообщения).


4.4.5. Операции над частями и аудиосообщениями

Над частями и аудиосообщениями можно производить какие угодно операции: перемещать, разрезать, копировать, удалять, объединять и т. д. Но для того чтобы выполнять какие-либо действия над объектами проекта, предварительно их следует выделить.


Выделение

В верхней области секции треков имеется панель инструментов. Проверьте, чтобы кнопка [image] (Object Selection) на панели инструментов окна проекта быть нажата — это означает, что курсор мыши будет работать как инструмент для выделения и перемещения графических объектов. Чтобы выделить одну часть или аудиосообщение, достаточно щелкнуть на нем кнопкой мыши. Чтобы снять выделение, нужно щелкнуть на любом свободном месте секции треков.
Группа треков выделяется следующим образом. С помощью курсора мыши, словно в графическом редакторе, рисуется прямоугольник, полностью охватывающий те части и аудиосообщения, которые следует выделить. Охваченные этим прямоугольником объекты оказываются выделенными (рис. 4.42, а, б, в). Еще один способ выделения нескольких частей: нажмите и удерживайте нажатой кнопку <Shift>, затем "перещелкайте" нужные части. Если вам требуется выделить все объекты, расположенные на одном треке, то для этого существует специальная команда. Щелкните правой кнопкой мыши на поле нужного трека в списке треков, возникнет контекстное меню трека, в котором следует выбрать команду Select All Events. В главном меню Cubase SX имеется большой набор команд для выделения объектов проекта. Все они собраны в подменю Edit > Select. Перечислим те из них, что доступны из окна проекта:

  • All — выделить все объекты (сочетание клавиш <Ctrl> + <A>);
  • None — снять выделение со всех объектов (сочетание клавиш <Ctrl> + <Shift> + <A>);
  • In Loop — выделить все объекты, полностью или частично попадающие в область между левым и правым локаторами;
  • From Start to Cursor — выделить все объекты, расположенные на интервале от начала проекта до указателя текущей позиции;
  • From Cursor to End — выделить все объекты, расположенные после указателя текущей позиции;
  • All on Selected Tracks — выделить все объекты на выделенных треках.

Рис. 4.42. Выделение группы аудиосообщений

Чтобы выделить сразу несколько треков, следует "перещелкать" их поля в списке треков, удерживая нажатой клавишу <Ctrl>. Альтернативный вариант — щелкнуть на поле первого трека, входящего в группу выделяемых треков, затем, удерживая нажатой клавишу <Shift>, щелкнуть на поле последнего трека группы.


Удаление, отмена последней операции

Самая простая операция с выделенными объектами (частями или аудиосообщениями) — их удаление — выполняется нажатием клавиши <Delete> или <Backspace>, либо командой главного меню программы Edit > Delete, либо командой Edit > Delete контекстного меню, вызываемого щелчком правой кнопкой мыши на области секции треков, содержащей части или аудиосообщения.
Но и это еще не все. На панели инструментов окна проекта имеется кнопка [image] (Erase) — ластик. Если данная кнопка нажата, то щелчок на объекте приводит к его удалению.
Отменить удаление (как и любую другую последнюю из операций, выполненных над объектами проекта) можно командой главного меню Edit > Undo или нажав комбинацию клавиш <Ctrl> + <Z>. В отличие от предыдущих версий Cubase, в Cubase SX поддерживается бесконечное количество отмен (вплоть до первой операции в сеансе работы с проектом). Однако существуют и такие операции, которые не могут быть отменены в принципе. На невозможность отмены мы будем обращать ваше внимание особо.
Если вы уже воспользовались командой Edit > Undo, то имеется возможность ее отменить (вернуть все в то состояние, которое было до ее выполнения). Для этого существует команда Edit > Redo (клавиши <Ctrl> + <Shift> + <Z>). Еще одна команда, связанная с рассматриваемой темой, — Edit > History, вызывает окно диалога Edit History (история редактирования). В данном окне присутствует список всех команд, которые были выполнены в текущем сеансе работы с проектом. Если вы хотите отменить сразу несколько команд, то вместо того, чтобы многократно подавать команду Edit > Undo, удобнее щелкнуть на нужной команде в истории. Ваш проект незамедлительно перейдет в то состояние, в котором он находился после команды, выбранной вами в списке. Это похоже на путешествие во времени. Однако в отличие от машины времени возможности Cubase SX вполне реальны. Причем вы можете путешествовать по истории редактирования как назад, так и вперед (естественно, только до тех команд, которые вы реально подавали). Почему "естественно"? Потому, что настоящей машины времени все же не существует и Cubase SX не может знать того, какие команды вы будете подавать в будущем.


Перемещение

Чтобы переместить одиночный объект, не обязательно его предварительно выделять. Хватайте его и тащите на нужное место (при условии, что кнопка [image] на панели инструментов окна проекта нажата). Как только вы захватите объект мышью, он выделится автоматически.
Если требуется переместить сразу группу объектов, то предварительно все их следует выделить. После этого следует ухватиться за любой из объектов данной группы и перетащить его на новое место.
При перетаскивании объекты раздваиваются. Вы хватаете объект мышью и тащите, при этом вы перетаскиваете его изображение. Но до тех пор, пока вы не отпустите кнопку мыши и не "положите" объект на новое место, на его старом месте остается копия его изображения.
Если вам требуется переместить один или несколько объектов за пределы видимой области, то ваши действия должны быть таковыми:

  • схватите объект(ы) левой кнопкой мыши и подведите курсор к правой или левой границе секции треков, программа начнет перематывать видимую область проекта в соответствующем направлении;
  • когда появится нужное вам место, отодвиньте курсор от границы вглубь секции треков;
  • установите перетаскиваемый объект в требуемое место и отпустите левую кнопку мыши.

Не обязательно перемещать объекты методом Drag and Drop. Вы можете воспользоваться буфером обмена для их перемещения. Скопируйте или вырежьте части и аудиосообщения в буфер обмена, затем вставляйте в требуемое место трека, определяемое указателем текущей позиции. Обратите внимание на то, что объекты всегда вставляются на тот же трек, с которого они были скопированы или вырезаны в буфер обмена.
Перечислим соответствующие команды главного меню:

  • Edit > Cut (клавиши <Ctrl> + <X>) — вырезать в буфер (скопировать выделенные объекты в буфер, а исходные копии удалить);
  • Edit > Сору (клавиши <Ctrl> + <С>) — копировать в буфер;
  • Edit > Paste (клавиши <Ctii> + <V>) — вставить из буфера;
  • Edit > Paste at Origin (клавиши <Alt> + <V>) — вставка объектов из буфера обмена на то же место, в котором они находились до копирования или вырезания.

Не забывайте и о существовании контекстного меню, вызываемого щелчком правой кнопки мыши над секцией треков. В нем продублированы все команды для работы с буфером обмена.
Будьте внимательны! Все аудиосообщения, хранимые на одном треке, должны иметь одинаковый формат. То есть на одном треке должны храниться или только стереофонические аудиосообщения, или только монофонические. В случае конфликта (когда на одном треке хранятся сообщения разных форматов) какие-то сообщения будут воспроизводиться, а какие-то не будут.
Кстати, если переместить аудиосообщение или часть в ту область секции треков, где треки отсутствуют, то для этого объекта будет создан новый MIDI- или аудиотрек (в зависимости от типа объекта).
Обратите внимание на одну деталь. Когда вы осуществляете захват графического объекта и начинаете его перемещать, то перемещение происходит не сразу, а спустя короткий, но ощутимый интервал времени. Задержка нужна для того, чтобы исключить случайное перемещение объектов, когда вы на них щелкаете. За длительность задержки отвечает специальный параметр, называемый Drag Delay. Доступ к нему осуществляется через окно Preferences, вызываемое командой главного меню File > Preferences. Параметр Drag Delay доступен в разделе Editing и задается в миллисекундах.


Разрезание

Переходим к разрезанию. Что значит выражение "разрезать часть или сообщение"? Все просто: была одна часть, разрезали ее — стало две части.
Самый простой способ разрезания объектов — с помощью инструмента Split, которому соответствует кнопка [image] на панели инструментов секции треков. Нажмите эту кнопку и попробуйте разрезать несколько частей или аудиотреков, щелкая на них левой кнопкой мыши.

Рис. 4.43. Разрезание аудиоссобщения

Если включен режим Snap (привязка), то разрезы будут появляться не обязательно там, где вы щелкнули, а в месте, которое соответствует условиям привязки (например, в ближайшем узле сетки). Причем еще до того, как вы разрежете объект, место будущего разреза будет отмечено тонкой горизонтальной линией, а около курсора мыши (в форме ножниц) будет отображаться подсказка с координатами будущего разреза (рис. 4.43, а).
После щелчка левой кнопкой мыши на границе раздела возникнет синяя линия — соприкасающиеся гранимы двух новых объектов. Теперь можно воспользоваться инструментом [image] и отнести один из отрезанных объектов на новое место (рис. 4.43, б).
Если вам требуется разрезать сразу несколько частей, расположенных на разных треках, то удобнее воспользоваться командой главного меню Edit > Split at Cursor (клавиши <Alt> + <X>), которая выполняет разрезание предварительно выделенных объектов по линии указателя текущей позиции проекта. Аналогичная команда имеется и в контекстном меню аудиосообщений.
Стоит упомянуть еще об одной команде главного меню: Edit > Split Loop. Аналогичная команда тоже имеется и в контекстном меню секции треков. В данном случае разрезание объектов произойдет по границам области проекта, определяемой положениями левого и правого локаторов.
Интересную особенность имеет разрезание аудиосообщений. Как мы уже говорили, аудиосообщение — это ссылка на звуковой файл и набор атрибутов. Когда вы разрезаете аудиосообщение, то в результате получаются два новых аудиосообщения, каждое из которых ссылается на один и тот же звуковой файл. С самим файлом не производится никаких операций. В дальнейшем вы можете раздвинуть границы аудиосообщений на всю длину этого файла. В этом случае у вас получится два абсолютно одинаковых аудиосообщения и не останется никаких следов разреза.
А теперь настало время поговорить о перемещении границ аудиосообщений и частей.


Склеивание, заполнение пауз

Склеить несколько объектов в один достаточно просто. Делается это с помощью инструмента [image] (Glue), расположенного на панели инструментов окна проекта. Вы просто щелкаете на нужной части или по аудиосообщению, и данный объект сливается со следующим за ним на треке объектом. Причем совершенно неважно, на каком расстоянии друг от друга расположены склеиваемые объекты.

Рис. 4.44. Склеивание двух объектов

Склеивание проиллюстрировано рис. 4.44, а, б. Следует сделать замечание относительно склеивания аудиосообщений. Дело в том, что как такового склеивания аудиосообщений не происходит. В результате "склеивания" аудиосообщения объединяются в одну часть, но по своей сути остаются разными сообщениями. Если вы захотите их объединить в одно сообщение, то следует их выделить (достаточно выделить часть, в которой они находятся) и воспользоваться командой главного меню Audio > Bounce Selection. Но прибегать к данной команде стоит лишь в том случае, когда это действительно необходимо. Данная команда относится к категории разрушающего редактирования. На основании выделенных аудиосообщений рассчитывается новое сообщение, которое заменяет собою исходные. При этом учитываются все атрибуты исходных сообщений (амплитудная огибающая, метки начала и окончания сообщения и др.). Перед заменой аудиосообщений на вновь рассчитанное будет выдано соответствующее предупреждение, и вы можете отказаться от своей затеи.
В данном разделе стоит упомянуть еще об одной интересной команде Cubase SX, позволяющей заполнять паузы между аудиосообщениями. Команда вызывается из главного меню Audio > Close Gaps (аналогичная команда имеется и в контекстном меню аудиосообщений) и работает применительно к выделенному сообщению, за которым следует пауза. Допустим, у нас имеется два аудиосообщения, расположенные так, как показано на рис. 4.44, а. С помощью упомянутой команды можно было бы заполнить пустое пространство между ними за счет растяжения левого сообщения. Правда, в данном случае применять ее нет смысла, но при использовании лупов и грувов (см. главу 12) она бывает незаменимой.


Копирование

Как мы уже говорили, основной способ копирования частей и аудиосообщений — копирование через буфер обмена: команды Edit > Copy (копировать в буфер) и Edit > Paste (вставить из буфера) главного меню или контекстного меню секции треков. Аналогичные команды имеются в подавляющем большинстве приложений Windows, и вы наверняка знаете, как ими пользоваться. Больший интерес представляют специфические команды копирования, которые есть только в Cubase SX.
Начнем с рассмотрения довольно простой команды Edit > Duplicate. Она создает копию выделенного объекта, которая располагается следом за ним. Эту и следующие команды копирования можно применять одновременно к нескольким объектам, которые могут располагаться даже на разных треках.
Если требуется размножить выделенные сообщения в больших количествах, удобнее воспользоваться командой Edit > Repeat (ее можно вызвать сочетанием клавиш <Ctrl> + <K>). Откроется диалоговое окно Repeat Events, в котором следует указать, сколько копий выделенных объектов следует сделать (параметр Count), и при необходимости установить флажок Shared. После нажатия кнопки ОК предварительно выделенные объекты будут размножены и размещены последовательно друг за другом. Если был установлен флажок Shared, то все эти объекты окажутся связанными между собою: любое изменение одного из связанных объектов повлечет аналогичные изменения во всех его копиях. Визуально связанные объекты отличаются от нормальных наличием символа [image] . Чтобы развязать объекты, следует выделить их и воспользоваться командой Edit > Convert to Real Copy. В случае применения этой команды к связанным аудиосообщениям, будут созданы копии использованных в них звуковых файлов.
Еще более интересна команда копирования: Edit > Fill Loop. Она выполняет многократное копирование выделенных объектов таким образом, чтобы заполнить копиями область проекта, ограниченную левым и правым локаторами.
Применение любых команд копирования к аудиосообщениям приводит к созданию связанных копий. Чтобы развязать их, пользуйтесь командой Edit > Convert to Real Copy.


Инструмент Range Selection

На панели инструментов окна проекта имеется кнопка [image] (Range Selection). С помощью данного инструмента, так же как и с помощью инструмента [image] (Obiect Selection), можно выделять объекты, расположенные в секции треков. Однако с помощью инструмента [image] объекты можно выбирать целиком.
Вам не удастся выбрать половину какой-нибудь части или аудиосообщения. Инструмент [image] (Range Selection), как и следует из его названия, позволяет выбрать прямоугольную область в секции треков, включающую в себя как целые объекты, так и их фрагменты. Над всем, что попадет в данную область, можно выполнять любые действия: копирование или вырезание в буфер обмена, перемещение, удаление.
Если задействован инструмент [image] (Range Selection), то в вашем распоряжении оказываются еще две специальные команды главного меню для выделения объектов:

  • Edit > Select > Left Selection Side to Cursor (клавиша <Е>) — оставить выделенной только ту часть выделенной области, что находится слева от указателя текущей позиции;
  • Edit > Select > Right Selection Side to Cursor (клавиша <D>) — оставить выделенной только ту часть выделенной области, что находится справа от указателя текущей позиции.

На рис. 4.45 приведен пример использования данного инструмента. У нас имеется два аудиосообщения, расположенные на разных треках. Мы подводим курсор к углу области, которую хотим выделить (рис. 4.45, а). Удерживая нажатой левую кнопку мыши, выделяем прямоугольную область. Даже после того как вы отпустите кнопку мыши, в любой момент вы можете передвинуть границы выделенной области, ухватившись за них мышью. А если ухватиться мышью за саму область (рис. 4.45, б), то ее можно перетащить в любое место проекта. В процессе перемещения, пока левая кнопка мыши удерживается нажатой, около курсора будет отображаться позиция левой границы перемещаемой области (рис. 4.45, в). После завершения перемещения (когда вы отпустите левую кнопку мыши), вы обнаружите, что вместе с областью переместились и вес объекты (и даже их фрагменты!), которые изначально присутствовали в ней (рис. 4.45, <?).

Рис. 4.45. Применение Range Selection

В главном меню программы существует подменю Edit > Range, содержащее набор команд, работающих совместно с инструментом [image] (Range Selection). Перечислим эти команды:

  • Cut Time (клавиши <Ctrl> + <Shift> + <Х>) — вырезать все, что оказалось в выделенной области, в буфер обмена; передвинуть все, что оказалось справа от вырезанной области, так", чтобы заполнить образовавшийся пробел;
  • Delete Time * (<Shift> + <Backspace>) — команда похожа на предыдущую, но происходит не вырезание, а удаление выделенной области;
  • Paste Time * (<Ctrl> + <Shift> + <V>) — вставить фрагмент проекта из буфера обмена; вставка осуществляется начиная с левой границы выделенной области; все, что находится на месте вставки, сдвигается вправо (чтобы освободить место под вставляемый фрагмент);
  • Paste Time at Original * — команда аналогична предыдущей, но вставка фрагмента проекта из буфера происходит начиная с той позиции, в которой данный фрагмент находился прежде, чем попасть в буфер;
  • Split (<Shift> + <X>) — разрезать объекты по границам выделенной области;
  • Crop — передвинуть границы объектов, частично попавших в выделенную область, таким образом, чтобы их границы совпадали с границами выделенной области;
  • Insert Silence * (<Ctrl> + <Shift> + <E>) — освободить выделенную область за счет перемещения вправо всех объектов, попавших в нее.

Команды, которые мы пометили символом "*", могут работать совместно с инструментом [image] (Object Selection). Вместо области проекта, выделенной инструментом [image] (Range Selection), где нужно, используется область проекта, ограниченная левым и правым локаторами. При описании команды Edit > Range > Crop мы упомянули возможность перемещения границ объектов (частей и аудиосообщений). Подробно мы поговорим об этом чуть позже.


Амплитудные огибающие аудиосообщений; пересечение аудиосообщений, Auto Fades, Auto Crossfades

В пределах каждого из аудиосообщений вы можете сформировать амплитудную огибающую. Никаких специальных команд для того, чтобы создать эту огибающую, подавать не нужно. Она является неотъемлемым свойством аудиосообщения и присутствует в нем изначально. Правда, форма этой огибаюшей по умолчанию такова, что она никак не влияет на звучание аудио-сообщения: фазы атаки и затухания отсутствуют, громкость соответствует нормальной громкости звучания сообщения.
Амплитудная огибающая аудиосообщения имеет три фазы: Fade In (возрастание громкости), поддержка (громкость не изменяется) и Fade Out (спад громкости). Каждой из фаз соответствует свой узел. По- умолчанию узлы расположены следующим образом:

  • узел Fade In — в левом верхнем углу графического объекта аудиосообщения;
  • узел поддержки — в центре на верхней границе;
  • узел Fade Out — в правом верхнем углу.

Рис. 4.46 (а-г). Формирование амплитудной огибающей аудиосообщения

Рис. 4.46 (д, е). Формирование амплитудной огибающей аудиосообщения

Немного практики. С помощью инструмента [image] хватаемся за узел Fade In (рис. 4.46, а) и тащим его вправо (4.46, 6). При этом около курсора отображается подсказка, в которой указана позиция завершения фазы Fade In (относительно начала временной оси проекта) и ее длительность (относительно начала аудиосообщения).
Хватаемся за узел фазы поддержки и тащим его вниз (рис. 4.46, в). Около курсора отображается следующая подсказка: максимально возможный уровень сигнала в аудиосообщении в фазе поддержки, а в скобках — изменение амплитуды по сравнению с последней редакцией огибающей.
После того как мы перетащим узел Fade Out влево, получится примерно то, что показано на рис. 4.46, г. В процессе формирования амплитудной огибающей вы увидите, как соответствующим образом изменяется волновая форма, отображающаяся внутри прямоугольника-аудиосообщения.
В своем примере мы перемещали узел поддержки вниз, уменьшая тем самым общую громкость аудиосообщения. Однако данный узел можно перемещать и вверх (за пределы графического объекта аудиосообщения): хватаемся за узел поддержки (рис. 4.46, д) и тащим его вверх (рис. 4.47, в). При этом сам узел и огибающая не выйдут за верхнюю границу прямоугольника аудиосообщения, но фактическая громкость будет увеличиваться.
Операция формирования амплитудной огибающей относится к категории неразрушающего редактирования: в аудиофайл, содержащий исходный сэмпл, не вносится никаких изменений. Отрезки аудиосообшений. содержащие переходы Fade In и Fade Out, рассчитываются сразу после того, как вы закончили перемещать соответствующие узлы и отпустили кнопку мыши. Результаты расчетов сохраняются во временных файлах, находящихся в папке <Ваш проект>/Fades. Во время воспроизведения соответствующие фрагменты исходного звукового файла подменяются на эти временные файлы, заготовленные заранее. Такой подход, видимо, позволяет снизить загрузку процессора во время воспроизведения проекта. Кстати, амплитудные огибающие на фазах Fade In и Fade Out могут иметь очень сложную форму, и задавать ее можете вы. Выделим одно или несколько аудиосообщений и воспользуемся командой главного меню Audio > Open Fades Editor(s). Аналогичная команда имеется и в контекстном меню аудиосообщений. А работает она так: если хотя бы у одного из выделенных сообщений длительность фазы Fade In отлична от нуля, откроется окно Fade In, показанное на рис. 4.47, а, если хотя бы у одного из выделенных сообщений длительность фазы Fade Out отлична от нуля, откроется окно Fade Out, показанное на рис. 4.47, б.
Как видно из рис. 4.47, оба окна очень похожи друг на друга, за исключением того, что одно предназначено для редактирования огибающей в фазе Fade In, а другое — в фазе Fade Out.
Основным элементом этих окон является поле с изображением волновых форм и огибающей на участке Fade In или Fade Out. Светло-серым цветом отображается исходная волновая форма, темно-серым — волновая форма, которая будет получена за счет применения амплитудной огибающей. С помощью мыши вы можете придать огибающей произвольную форму, расставляя в нужных местах узлы. В верхней части окон имеются две кнопки, определяющие способ интерполяции (соединения) узлов:
(Spline Interpolation) — интерполяция узлов по методу сплайнов (кривая проходит сквозь все узлы, ее крутизна в целом минимизирована). (Linear Interpolation) — интерполяция полиномом первого порядка (кривая представляет собой набор отрезков, границами которых являются узлы).

Рис. 4.47. Редактирование Fade In и Fade Out

С помощью кнопок [image] или [image] выбираются различные предустановки огибающей. Если вы нажмете одну из этих кнопок, то все имеющиеся узлы будут удалены, а вместо них будут созданы новые, расположенные таким образом, чтобы кривая имела форму, показанную на соответствующей кнопке.
Изменения, внесенные в форму огибающей, вступят в силу после нажатия кнопки ОК или Apply, но пока этого не произошло, нажатием кнопки [image] (Restore) можно сбросить все настройки и вернуть действующую в данный момент форму огибающей (ту форму огибающей, которой обладает аудиосообщение).
После нажатия кнопки As Default, у всех вновь создаваемых аудиосообще-ний амплитудная огибающая в фазе Fade In или Fade Out будет иметь такую же форму, как и та, что присутствует на момент нажатия в окне Fade In или Fade Out.
Естественно, вы можете сохранять и впоследствии загружать свои собственные формы огибающей в виде пресетов. Для этого предназначена стандартная для Cubase SX группа Presets.
Как видите, можно сформировать сколь угодно сложную амплитудную огибающую, но только на участках Fade In или Fade Out. А что делать, если требуется сформировать сложную огибающую где-то посредине аудиосообщения? В этом случае можно растянуть фазу Fade In или Fade Out на нужную длину (вплоть до того, чтобы охватить все сообщение) и отредактировать форму амплитудной огибающей. При этом стоит иметь в виду, что крайние точки огибающей в фазах Fade In и Fade Out имеют фиксированные значения. Например, фаза Fade In всегда начинается с нулевого уровня сигнала и заканчивается максимальным уровнем сигнала.
Если требуется выполнить плавный переход от одного сообщения к другому, то сделать это можно, разместив аудиосообщения на разных треках так, чтобы они нахлестывались во времени (рис. 4.48). У одного сообщения нужно сформировать Fade Out, а у другого — Fade In так, чтобы одно сообщение плавно затихало, а второе плавно набирало громкость. Этим способом следует пользоваться в том случае, когда пересекающиеся аудиосообщения имеют разный формат (одно — стерео, другое — моно).

Рис. 4.48. Пересечение двух аудиосообщений во времени

Однако в большинстве случаев удобнее, если пересекающиеся сообщения расположены на одном треке. Как мы уже говорили, в случае пересечения нескольких аудиосообщений на одном треке, они оказываются как бы одно над другим. В каждый момент воспроизводится то сообщение, которое оказалось над всеми остальными. Тем не менее, организовать плавный переход от одного аудиосообшения к другому можно, даже если они находятся на одном треке. При этом сообщения должны иметь одинаковый формат (оба сообщения или моно, или стерео).
Проделаем следующее. Расположим два аудиосообщения "внахлест" так, как показано на рис. 4.49, а. Область пересечения двух аудиосообщений окрашена темно-серым цветом. Проследите за тем, что хотя бы одно из пересекающихся аудиосообщений было выделено. Теперь воспользуемся командой главного меню Audio > Crossfade (или аналогичной командой контекстного меню секции треков). В результате область пересечения аудиосообщенй
получит особый статус и будет выглядеть примерно так, как показано на рис. 4.49, б. Даже из рисунка видно, что пересекающиеся аудиосообщения плавно переходят одно в другое. На рис. 4.49, а область пересечения фактически принадлежала правому сообщению, именно оно и воспроизводилось, т. к. было выше левого сообщения. На рис. 4.49, б волновая форма области пересечения отличается: в ней присутствуют черты не только второго сообщения.

Рис. 4.49. Взаимопроникновение аудиосообщений и перемещение границ Crossfade

Если сделать двойной щелчок на области пересечения или повторно воспользоваться командой Audio > Crossfade, то возникнет диалоговое окно Crossfade, показанное на рис. 4.50.

Рис. 4.50. Диалоговое окно Crossfade

В окне Crossfade вы можете отредактировать амплитудные огибающие аудиосообщений в области их пересечения подобно тому, как это делается в окнах Fade In и Fade Out (рис. 4.47). Естественно, окно Crossfade имеет присущие только ему элементы. В нижней части окна расположено поле. в котором отображается волновая форма, получающаяся в результате пересечения аудиосообщений. Светлыми линиями в этом поле показаны амплитудные огибающие каждого из сообщений в отдельности, а синей линией — результирующая амплитудная огибающая. Если в точке пересечения светлых линий она имеет провал, то это означает следующее: одно аудиосообщение слишком сильно затихает еще до того, когда второе аудиосообщение успеет набрать громкость. Если синяя линия имеет подъем, то это означает: второе сообщение набирает громкость еще до того, как первое существенно затихает. Прямая синяя линия — гарантия плавности перехода.
Кнопки Play Fade позволяют прослушать звучание каждого из аудиосообщений на участке пересечения с учетом амплитудной огибающей. Кнопки Play Dry позволяют прослушать эти же участки аудиосообщений, но без учета амплитудной огибающей. Кнопка Play запускает воспроизведение результирующей волновой формы.
Опции Equal Power и Equal Gain включают особый режим редактирования амплитудных огибающих. Они становятся как бы связанными между собой. Изменение огибающей одного сообщения влечет за собой изменение огибающей другого сообщения.
В режиме Equal Power вы можете только перемещать единственный узел по горизонтали. Формы огибающих от вас не зависят. Они таковы, чтобы обеспечить постоянство энергии результирующей волновой формы на всем участке пересечения (при условии, что волновые формы пересекающихся сообщений имеют равные энергии).
В режиме Equal Gain вы можете задать какую угодно форму амплитудной огибающей для одного из аудиосообщений. Но форма огибающей другого сообщения всегда будет симметрична ей, и результирующая огибающая (синяя линия) всегда будет прямой. В группе Length вы можете изменить длительность фазы перехода одного сообщения в другое. Однако удобнее всего сделать это из окна проекта: хватаетесь за границу области Crossfade и тащите ее в нужном направлении (рис. 4.49, в). В действительности границы области Crossfade есть не что иное, как границы аудиосообщений. Если продолжать перемещение границы зоны Crossfade, то при ее выходе из зоны пересечения аудиосообщений эта зона исчезнет, а вы обнаружите, что ухватились за границу аудиосообщения (рис. 4.49, г).
С помощью команды главного меню Audio > Remove Fades можно привести амплитудную огибающую одного или нескольких выделенных аудиосообшений в состояние, принятое по умолчанию, т. е. фактически удалить ее.
Если не принимать никаких специальных мер, то на границах аудиосообщений (особенно после перемещения границ или разрезания аудиосообщений) при воспроизведении могут возникать щелчки. Допустим, вы разрезаете аудиосообщение на границе музыкального такта. Чему равно значение звукового отсчета в этом месте? Скорее всего, это не 0, т. к. вероятность этого очень мала. Представьте, как отсчет за отсчетом воспроизводится волновая форма аудиосообщения. Воспроизводится последний звуковой отсчет, значение которого отлично от 0. Но воспроизведение проекта на этом не заканчивается, и вместо отсутствующих отсчетов аудиосообщений начинают воспроизводиться звуковые отсчеты, значение которых равно 0: на границе аудиосообщения происходит резкий перепад от ненулевых значений отсчетов к нулю. Если сразу за аудиосообщением следует другое, то ситуация может еще более усугубиться, так как перепад может быть еще большим (от одного ненулевого значения к другому, с противоположным знаком). Чем больше перепад, тем громче щелчок. Чтобы его избежать, в профессиональных музыкальных и звуковых редакторах используются функции Auto Fades. Они могут называться и по-другому, но их суть от этого не меняется. Когда аудиосообщение начинает воспроизводиться, за короткий промежуток времени его громкость относительно плавно возрастает от 0 до нормального значения. А за небольшой промежуток времени до завершения аудиосообщения его громкость начинает плавно уменьшаться до 0. Резкие перепады отсутствуют, отсутствуют и щелчки.
В Cubase SX дело обстоит аналогичным образом. Если на одном треке пересекаются во времени два и более аудиосообщений и для них не применяется функция Crossfade, то звучать будут только те сообщения, которые в каждый конкретный момент расположены на поверхности экрана. А чтобы избежать щелчков на границах разделов между сообщениями, применяется функция Auto Crossfades. По своей сути она аналогична функции Crossfade. но применяется обычно на очень коротком промежутке времени. Параметры функций Auto Fades и Auto Crossfades можно контролировать на двух уровнях: на уровне проекта и на уровне отдельных треков. Командой главного меню Project > Auto Fades Settings вызывается окно диалога Auto Fades, содержащее настройки функций Auto Fades и Auto Crossfades, действующие для всего проекта в целом. Если же щелкнуть правой кнопкой мыши на поле какого-то аудиотрека в списке треков, а затем выбрать в контекстном меню команду Auto Fades Settings, то тогда также откроется диалоговое окно Auto Fades (рис. 4.51), но его настройки будут относиться только к конкретному треку.
В правой верхней части данного окна расположены три переключателя, с помощью которых осуществляется включение описанных выше функций (Auto Fade In, Auto Fade Out, Auto Crossfades). В поле Length задается длительность переходов (от 1 до 500 мс). Если нажать кнопку As Default, то все настройки, выполненные в данном окне, будут использоваться при создании новых проектов.
Если включена опция Use Project Settings, то применительно к треку, для которого было вызвано данное диалоговое окно, будут использоваться глобальные настройки Auto Fade In, Auto Fade Out, Auto Crossfades, относящиеся ко всему проекту, а все настройки, выполненные в рассматриваемом окне, будут относиться к категории глобальных (распространяться на весь проект). В аналогичном окне, вызываемом командой Project > Auto Fades Settings, данная опция отсутствует, потому что настройки этого окна и так распространяются на весь проект. Итак, какие же настройки доступны? В окне Auto Fades имеются две вкладки:

  • Fades (рис. 4.51, а) — параметры функций Fade In и Auto Fade Out;
  • Crossfades (рис. 4.51, б) — параметры функции Auto Crossfades.

Все элементы, расположенные на этих вкладках, вам уже знакомы по окнам Fade In, Fade Out и Crossfade. С их помощью вы можете сформировать огибающую, используемую для модуляции амплитуды аудиосообщений при работе функций Fade In, Auto Fade Out и Auto Crossfades. Эти огибающие нигде не представлены в графическом виде (функции прозрачны для пользователя). Нужно просто помнить о том, что они применяются для обработки "пограничных" отсчетов аудиосообщений, и знать, где конфигурируются их параметры.

Рис. 4.51. Диалоговое окно Auto Fades

Следует заметить, что при использовании функций Fade In, Auto Fade Out и Auto Crossfades волновые формы у границ аудиосообщений рассчитываются в режиме реального времени в ходе воспроизведения проекта. Это создает дополнительную нагрузку на процессор. Нагрузка эта сравнительно небольшая, и заметить ее можно разве что при большом количестве коротких аудиосообщений. Но, тем не менее, нагрузка эта присутствует.
И еще одно важное замечание. В настройках Cubase SX (окно Preferences, вызываемое командой File > Preferences, раздел Editing) имеется флажок Delete Overlaps (удалять пересечения). По умолчанию он сброшен, но если его установить, то вам не удастся добиться того, чтобы аудиосообщения нахлестывались друг на друга, и, как следствие, вы не сможете воспользоваться командой Audio > Crossfade. Если попробовать переместить одно аудио-сообщение таким образом, чтобы оно пересекалось во времени на одном треке с другим аудиосообщением, то границы последнего будут автоматически перемещены так, чтобы пересечения все равно не произошло.


Перемещение границ частей и аудиосообщений, алгоритм Time Stretch

В нижних углах прямоугольников, обозначающих части (и MIDI-, и аудио-части) и аудиосообщения, расположены белые узлы (рис. 4.52, а). Ухватившись за них инструментом [image] , а можно перемещать границы частей или аудиосообщений (рис. 4.52, б, в). В момент перемещения границы около курсора отображается подсказка с ее текущей координатой и длительностью части или аудиосообщения в скобках. Границы аудиосообщения — это маркеры, координаты, задаваемые от начала звукового файла и ограничивающие тот фрагмент этого файла, который будет воспроизводиться. Вы никогда не сможете переместить границы аудиосообщения за пределы соответствующего ему звукового файла.
Совсем другое дело — границы частей (и MIDI-, и аудиочастей). Их вы можете перемещать, как угодно. При этом позиции сообщений, хранимых в частях, изменяться не будут.
На кнопке [image] (Object Selection) в нижнем правом углу показан треугольник. Это означает, что у соответствующего инструмента имеется несколько функций. Если на кнопке [image] щелкнуть уже после того, как она выбрана (подсвечена голубым цветом), то возникнет меню, в котором для данного инструмента можно выбрать одну из трех функций:

  • Normal Sizing [image] — нормальное перемещение границ (описано выше);
  • Sizing Moves Contents [image] — при перемещении любой из границ вместе с нею будет перемещаться и содержимое части или аудиосообщения;
  • Sizing Applies Time Stretch [image] — при перемещении любой из границ будет происходить растяжение или сжатие во времени (в зависимости от направления перемещения) содержимого части или аудиосообшения.

Рис. 4.52. Изменение границ аудиосообщения

Рис. 4.53. Перемещение границы аудиосообщения вместе с его содержимым

Около названий функций в скобках приведены соответствующие виды кнопки Object Selection. По умолчанию установлен режим Normal Sizing [image] . С ним вы уже знакомы.
На рис. 4.53 проиллюстрирован режим Sizing Moves Contents [image] . Мы ухватились за левую границу аудиосообщения и потащили ее направо (рис. 4.53, а). Вместе с границей стала перемещаться и волновая форма (рис. 4.53, б).
Особый интерес представляет режим Sizing Applies Time Stretch [image] . Если изменять границы части, содержащей MIDI-сообщения, то позиции этих сообщений на оси времени и длительности будут изменяться пропорционально изменению длительности части. Все сообщения будут "вписаны" в новые границы части.

Рис. 4.54. Изменение длительности звучания сэмпла без изменения высоты тона

Если же режим Sizing Applies Time Stretch [image] применяется к аудиосообщению или к части, содержащей аудиосообщения, то по отношению к сэмплам будет применяться один из алгоритмов, известных под общим названием алгоритмы Time Stretch (изменение длительности звучания сэмпла без изменения высоты его тона). Алгоритмы будут применяться таким образом, чтобы вписать сэмплы в границы аудиосообшения или части. Пример: хватаемся за границу аудиосообшения (рис. 4.54, а) и переносим ее в горизонтальном направлении (рис. 4.54, б). После того как граница будет "отпущена", возникнет диалоговое окно Processing (рис. 4.55), в котором будет отображаться ход обработки. После завершения обработки длительность сэмпла изменится (рис. 4.54, в), но не изменится его тон и содержание. Если сэмпл содержит вокальную партию, то изменится темп ее исполнения, но не изменится ее тональность.

Рис. 4.55. Процесс обработки звуковых данных

Рис. 4.56. Параметры работы алгоритма Time Stretch

Естественно, незаметной работа данного алгоритма останется только при небольшом в процентном соотношении изменении длительности сэмпла.
Кроме того, качество работы алгоритма зависит еще и от его параметров, которые доступны в диалоговом окне Preferences в разделе Time Stretch Tool (рис. 4.56). Напомним, что данное окно вызывается командой главного меню File > Preferences.
В списке Algorithm выбирается конкретный тип алгоритма Time Stretch: МРЕХ Algorithm, Timebandit, ТВ - Drum (по умолчанию). Нельзя сказать, что какой-то определенный алгоритм лучше других. Просто они разные, для одного сэмпла лучше подходит один алгоритм, для другого — другой. Алгоритм ТВ - Drum ориентирован на работу с ударными звуками (барабанными лупами).
Под списком Algorithm расположен регулятор, с помощью которого изменяется значение параметра Accuracy. Минимальное значение Accuracy (-5) соответствует оптимизации алгоритма под тональные звуки, а максимальное значение (5) — оптимизации под ритмические звуки. Данный параметр используется только алгоритмом Timebandit.
Если включена опция Always use Drum Mode for Close Gaps, то независимо от того, какой алгоритм выбран в списке Algorithm, для выполнения команды главного меню Audio > Close Gaps будет использоваться алгоритм ТВ -Drum. Напомним, что данная команда нужна для заполнения промежутков между выделенными аудиосообщениями. Заполнение осуществляется как раз за счет растяжения аудиосообщений с использованием алгоритмов Time Stretch.
Следует отметить, что в Cubase SX существует еще команда главного меню Audio > Process > Time Stretch (ее эквивалент в контекстном меню секции треков команда Process > Time Stretch). Данная команда тоже позволяет изменять длительность предварительно выделенных аудиосообщений. Однако в большинстве случаев удобнее пользоваться именно инструментом Sizing Applies Time Stretch [image] . В обоих случаях доступны одни и те же алгоритмы Time Stretch. Но при использовании команды Audio > Process > Time Stretch вам придется в числовой форме задать степень растяжения/сжатия аудиосообщений.


Мьютирование и блокирование частей и аудиосообщений

Заглушить можно не только трек (напомним, что делается это включением атрибута Mute), но и отдельные части или аудиосообщения. На панели инструментов главного окна имеется кнопка [image] (Mute). Если воспользоваться данным инструментом и щелкнуть на части или аудиосообщений, то соответствующий объект окажется заглушенным (приобретет светло-серый цвет, не будет воспроизводиться). Чтобы снять атрибут Mute, следует выполнить повторный щелчок по мьютированному объекту. Эти же действия с выделенными объектами можно проделать с помощью команд главного меню Edit > Mute (клавиши <Shift> + <M>) и Edit > Unmute (<Shift> + <U>). Аналогичные команды существуют и в контекстном меню секции треков.
Вы уже знаете, что можно блокировать целые треки. Для этого у каждого трека существует специальный атрибут Lock. Но существует возможность блокирования отдельных частей и аудиосообщений. Блокируемый объект следует выделить и воспользоваться командой главного меню Edit > Lock, или аналогичной командой контекстного меню секции треков, или комбинацией клавиш <Ctrl> + <Shift> + <L>. На изображении части или аудио-сообщения появится символ замка [image] и вы больше не сможете ни переместить данный объект, ни его отредактировать. Если воспользоваться командой Edit > Lock применительно к заблокированному объекту повторно, то откроется окно диалога Lock Event Attributes, в котором будут доступны следующие опции:

  • Position Locked — блокирована начальная позиция объекта;
  • Size Locked — блокированы границы объекта;
  • Others Locked — блокированы прочие свойства объекта.

Снимая некоторые из этих опций, вы можете частично разблокировать объект. Если требуется разблокировать объект полностью, следует воспользоваться командой главного меню Edit > Unlock (<Ctrl> + <Shift> + <U>) или аналогичной командой контекстного меню секции треков. Перед разблокированием объекта его следует выделить.
Стоит упомянуть об опции Lock Event Attributes, доступной в разделе Editing окна Preferences, вызываемого командой главного меню File > Preferences.
По своей сути данная опция является списком, в котором можно выбрать, какие именно атрибуты будут блокироваться у объекта при применении команды блокирования. По умолчанию блокируются Position + Size + Other, т. е. все атрибуты объекта.


4.5. Операции над треками

Можно перемещать не только графические объекты, расположенные на треках, но и сами треки. Делается это очень просто. В списке треков хватаетесь за поле нужного трека (рис. 4.57, а) и перемещаете его в вертикальном направлении. Вернее, сам трек остается на месте, а перемещается яркая горизонтальная полоса, указывающая на то место, куда будет перемещен трек (рис. 4.57, б).
Если эта полоса зеленая, то перемещение возможно и произойдет сразу после того, как будет отпущена кнопка мыши (рис. 4.57, в). Если полоса красная, то перемещение трека в указанную позицию невозможно. Такая ситуация может возникнуть, если, например, вы захотите перетащить трек в ту же позицию, где он в данный момент находится.

Рис. 4.57. Перемещение трека

Само собою разумеется, что при перемещении полей в списке треков будут перемещаться и сами треки в секции треков. Трек всегда располагается напротив соответствующего ему поля в списке треков.
Вообще, когда речь идет об операциях над треками, то связанные с этим команды удобнее выбирать в контекстном меню, вызываемом щелчком правой кнопки мыши на поле необходимого трека в списке треков. Перечислим такие команды:

  • Duplicate Track — создать точную копию трека;
  • Disable Track/Enable Track — включить/выключить трек. Информация с выключенных треков не воспроизводится, что приводит к снижению дисковой активности. Но если к треку в режиме вставки подключены плагины, то выключение трека не приведет к снижению нагрузки на процессор;
  • Remove Track — удалить трек;
  • Add Multiple Tracks — добавить несколько треков;
  • Remove Selected Tracks — удалить выделенные треки (треков может быть несколько).

Чтобы выделить несколько треков, следует "перещелкать" их поля в списке треков, удерживая нажатой клавишу <Ctrl>. Можно также выделить группу треков, удерживая нажатой клавишу <Shift>. Это стандартный для Windows способ выделения нескольких элементов.
Давайте подробнее остановимся на команде Add Multiple Tracks. Если ее вызвать, появится диалоговое окно, показанное на рис. 4.58.

Рис. 4.58. Добавление нескольких треков

В списке Track следует выбрать тип добавляемых треков (MIDI, Audio, Group Channel). В поле Count нужно ввести количество добавляемых треков и нажать ОК. Эта простая процедура иногда позволяет сэкономить немного времени.


4.6. Треки-контейнеры

С помощью треков-контейнеров (folder tracks) можно улучшить структуру проекта. Единственная функция треков-контейнеров — они могут хранить внутри себя другие треки.
Давайте создадим трек-контейнер. Для этого можно воспользоваться командой главного меню Project > Add Track > Folder. Альтернативный способ — воспользоваться командой Add Folder Track из контекстного меню списка треков. Дополнительно создадим несколько треков для того, чтобы поместить их внутрь трека-контейнера. Рис. 4.59 иллюстрирует следующее: созданы MIDI-трек (MIDI 01), аудиотрек (Audio 01) и трек-контейнер (Folder); текущим выбран трек-контейнер, показано поле его инспектора.

Рис. 4.59. Создан трек-контейнер

Рис. 4.60. Перемещение треков в контейнер

Давайте перетащим MIDI-трек внутрь трека-контейнера, используя метод Drag and Drop. Для этого ухватимся за поле перетаскиваемого трека в списке треков (рис, 4.60, а) в месте, свободном от атрибутов. Возникнет красная горизонтальная полоса. Удерживая левую кнопку мыши нажатой, перетащим полосу в центр поля трека-контейнера. Полоса должна превратиться в зеленую стрелку (рис. 4.60, б). Теперь кнопку мыши можно отпустить, и MIDI-трек окажется внутри трека-контейнера. Аналогичным образом перетащим второй трек внутрь трека-контейнера. Результат показан на рис. 4.61.
И MIDI-, и аудиотреки расположены под треком-контейнером, а их поля в списке треков смещены относительно поля трека-контейнера вправо. В левой нижней части трека-контейнера расположен символ "—" (на рис. 4.61 на него указывает стрелка курсора мыши). Если на нем щелкнуть, содержимое трека-контейнера будет скрыто. Визуально в проекте будет присутствовать один трек-контейнер, остальные треки будут "спрятаны" внутри него.

Рис. 4.61. В контейнер помещены два трека

В поле инспектора трека-контейнера будет отображаться древовидная структура, соответствующая содержимому трека-контейнера (рис. 4.62, а).

Рис. 4.62. Инспектор трека-контейнера

В нашем примере дерево состоит всего лишь из корня (Folder) и двух "листьев" (MIDI 01 и Audio 01). Но, в принципе, мы могли бы вложить в трек-контейнер и другие треки-контейнеры, а в них, в свою очередь, тоже вложить треки-контейнеры. Тогда бы дерево было бы действительно ветвистым деревом (рис. 4.63).
Если щелкнуть по названию одного из треков, вложенных в трек-контейнер (рис. 4.62, б), под полем инспектора трека-контейнера отобразится аналогичное поле соответствующего трека.
Какая практическая польза от треков-контейнеров? Они позволяют сократить количество видимых треков в проекте и обеспечивают быстрый доступ к параметрам скрытых треков. Кроме того, у треков-контейнеров также имеются атрибуты: Mute, Solo, Record Enable и др. Изменение состояния этих атрибутов влечет за собой соответствующее изменение аналогичных атрибутов у всех вложенных треков.

Рис. 4.63. Иллюстрация возможности построения ветвистого дерева треков


4.7. Трек маркеров (Marker Track) и все, что с ним связано

С помощью маркеров можно пометить какие-либо временные позиции в проекте. Например, можно установить маркер в начале припева и присвоить ему имя "Refrain". В дальнейшем можно будет быстро переместиться в начало припева, щелкнув на соответствующем маркере, доступном в списке маркеров.
Командой главного меню Project > Markers вызывается окно редактора маркеров Marker, показанное на рис. 4.64.
С окном Marker удобнее всего работать, если оно всегда располагается поверх других окон. Чтобы закрепить его на поверхности экрана, следует щелкнуть правой кнопкой мыши на данном окне и в контекстном меню (содержащем всего один пункт) включить опцию Always On Top.
Окно Marker содержит список всех маркеров, имеющихся в проекте. По умолчанию в любом проекте присутствует два особых маркера, имеющих идентификаторы (ID) L и R. Они уже известны вам как левый и правый локаторы. Удалить эти маркеры невозможно.
Новые маркеры в проект добавляются при помощи кнопки Add. Позиция нового маркера будет соответствовать указателю текущей позиции проекта. Идентификаторы новым маркерам присваиваются автоматически — это целые числа от 3 (числа 1 и 2 формально заняты левым и правым локаторами). Сразу после создания нового маркера станет доступным поле Description для ввода текста — обозначения маркера. Введите текст (например, "Refrain") и нажмите <Enter>.
В дальнейшем для того, чтобы осуществить прыжок в позицию проекта, обозначенную маркером, следует щелкнуть на пустом поле, расположенном перед строкой нужного маркера в списке. Указатель текущей позиции проекта перейдет в позицию маркера (Position) и перед строкой маркера возникнет символ [image] . Им помечается тот маркер, который в данный момент ближе всего расположен к указателю текущей позиции проекта.
Однако мы описали не самый удобный способ перехода по маркерам (хотя бы из-за того, что окно Marker должно быть открыто). Первые девять идентификаторов маркеров (L, R, 1,2, 3, ... 9) соответствуют клавишам на цифровой клавиатуре (numeric keypad). Например, нажимаете клавишу <3> на цифровой клавиатуре, и указатель текущей позиции прыгает к маркеру с ID, равным 3. Причем не имеет значения, включен ли режим Num Lock или нет. Клавиша <0> закреплена за началом проекта: нажимаете ее и попадаете в начало проекта. В случае необходимости ID маркеров можно переназначить. Для этого следует сделать двойной щелчок на поле ID нужного маркера и ввести туда новое число. Если маркер с таким же ID уже существует, то ему будет присвоен исходный номер того маркера, ID которого вы заменяете.
Переместить маркер можно, задав в поле Position новое его местоположение. Данное поле станет доступным, если сделать на нем двойной щелчок.
Чтобы удалить маркер, надо щелкнуть на соответствующей ему строке в списке маркеров (маркер окажется выделенным) и нажать кнопку Remove. А если вместо кнопки Remove нажать кнопку Move, то выделенный маркер переместится в текущую позицию проекта. Это второй способ перемещения маркеров.
Естественно, можно выделить сразу несколько маркеров. Делается это как обычно, с помощью клавиши <Ctrl> или <Shift>.
Как следует из рис. 4.64, маркерами могут помечаться не только отдельные точки на оси времени, но и целые отрезки. Маркеры могут иметь конечную позицию (End) и, соответственно, длину (Length). Маркеры, имеющие продолжительность на оси времени, называются циклическими. В списке Show выбирается то, какие маркеры следует отображать: АН — все маркеры, Markers — обычные маркеры (не циклические), Cycle Markers — циклические маркеры. По умолчанию отображаются все маркеры. При этом, когда вы нажимаете кнопку Add, создаваться будут обычные маркеры. Чтобы создать циклический маркер, в списке Show следует выбрать Cycle Markers. Тогда при создании нового маркера кнопкой Add будет создаваться именно циклический маркер: его начало будет совпадать с позицией левого локатора, а окончание — с позицией правого.

Рис. 4.64. Окно редактора маркеров

Идентификаторы циклических маркеров — тоже числа, но они отображаются в квадратных скобках. Невозможно ассоциировать циклический маркер с клавишей на цифровой клавиатуре. Однако циклические маркеры лучше всего подходят для визуализации различных частей проекта (например, вступления, куплета, припева и т. п.).
Для визуализации маркеров в окне проекта служит специальный трек — трек маркеров (marker track). В проекте может быть всего один такой трек. Создать трек маркеров можно командой главного меню Project > Add Track > Marker или командой Add Marker Track контекстного меню списка треков.

Рис. 4.65. Трек маркеров

На рис. 4.65 показаны все три элемента трека маркеров: инспектор, поле в списке треков и, собственно, сам трек с маркерами.
Инспектор трека маркеров представляет собой не что иное, как окне Marker, рассмотренное выше. Поле инспектора даже так и называется Marker.
Рассмотрим поле трека маркера в списке треков. Оно содержит три поля и три кнопки. Перечислим кнопки:
(Add Marker) — добавление маркера в текущую позицию проекта;
(Add Cycle Marker) — добавление циклического маркера, начало и окончание которого будут соответствовать расположению левого и правого локаторов;
— переключить способ представления времени: музыкальное или линейное. Аналогичные переключатели имеются у MIDI- и у аудиотреков. Три поля трека маркера в списке треков предназначены для подачи команд. Щелкаете на поле; открывается список, содержащий маркеры; выбираете маркер; выполняется связанная с этим маркером и полем команда. Перечислим поля:

  • Locate — переместить указатель текущей позиции в позицию выбранного маркера;
  • Cycle — переместить левый и правый локаторы в позиции начала и окончания циклического маркера;
  • Zoom — изменить горизонтальный масштаб секции треков так, чтобы выбранный циклический маркер занимал всю видимую область.

А теперь скажем несколько слов о том, как отображаются маркеры в секции треков, и о том, что с ними можно делать.
Обычные маркеры отображаются в виде цветных вертикальных черточек. Около каждого из маркеров отображается или его ID, или его описание (Description), если таковое существует. Двойной щелчок на изображении маркера эквивалентен команде Locate.
Циклические маркеры похожи на букву "Н": две вертикальные черточки (соответствующие началу и окончанию маркера), центры которых связаны горизонтальной линией. На рис. 4.65 циклический маркер имеет идентификатор 1 (или в списке маркеров). Двойной щелчок на изображении циклического маркера эквивалентен команде Cycle.
Вы можете добавлять новые маркеры с помощью карандаша, выделять одиночные маркеры или группы маркеров, перемещать их с помощью мыши, удалять их при помощи ластика. Одним словом, с маркерами можно делать все то же, что и с любыми другими графическими объектами. Хотя, пожалуй, имеются и отличия: например, вы не сможете копировать выделенные маркеры в буфер обмена, а команда Edit > Cut (вырезать в буфер обмена) на самом деле приводит к их удалению.


4.8. Автоматизация

Автоматизация — одна из важнейших функций Cubase SX, позволяющая сохранять, редактировать и воспроизводить изменения параметров микширования и эффектов. Во время записи автоматизации все ваши манипуляции с параметрами микширования (панорамирование, громкость и т. д.) и изменения параметров эффектов будут сохраняться на треках проекта в виде данных автоматизации. Данные автоматизации — специальные сообщения, описывающие изменения автоматизируемых параметров во времени. Им соответствуют графические объекты (узлы), определяющие форму огибающих автоматизации — графиков изменения автоматизируемых параметров во времени.


4.8.1. Запись автоматизации

Немного практики. Выберите какой-нибудь трек. Неважно какой — MIDI-или аудиотрек. Включите для него атрибуты W (Write Enable) — разрешена запись автоматизации) и R (Read Enable) — разрешено воспроизведение данных автоматизации). Запустите проект на воспроизведение (именно на воспроизведение, а не на запись). Во время воспроизведения подвигайте какой-нибудь регулятор (или даже несколько регуляторов), например регулятор громкости или панорамы. Остановите воспроизведение, отмотайте проект в начало, вновь запустите воспроизведение. Регулятор, который вы двигали раньше, начнет повторять ваши движения, но уже без вашей помощи. Так работает автоматизация. Все ваши движения были сохранены в виде специальных данных и теперь воспроизводятся. На панели инструментов окна проекта имеется символ [image] . Справа от него расположен раскрывающийся список, в котором можно выбрать один из трех режимов записи автоматизации:

  • Touch Fader — запись автоматизации начинается сразу после того, как вы коснетесь какого-либо регулятора (захватите его курсором мыши), и прекращается сразу после того, как регулятор будет отпущен;
  • Autolatch — запись автоматизации начинается сразу после того, как вы коснетесь какого-либо регулятора, и будет прекращена только после того, как вы выключите атрибут трека W (Write Enable);
  • X-Over — запись автоматизации начинается сразу после того, как вы коснетесь какого-либо регулятора, и будет прекращена сразу после того, как записываемая огибающая автоматизации пересечет уже существующую огибающую автоматизации этого же параметра.

По умолчанию выбран режим Touch Fader. Режим Autolatch полезно применять тогда, когда требуется "затереть" существующие данные автоматизации новыми. Режим X-Over полезен, когда требуется внести изменения в существующие огибающие автоматизации, но избежать при этом их резких скачков.
Самый быстрый способ получить доступ к данным автоматизации трека — воспользоваться командой Show Used Automation контекстного меню, вызываемого щелчком правой кнопкой мыши на нужном поле трека в списке треков. Эта команда откроет подтреки, содержащие данные автоматизации. Если воспользоваться командой главного меню Project > Show Used Automation, то откроются все подтреки, содержащие данные автоматизации всех треков проекта. Если после вызова команды ничего не произошло — значит данные автоматизации отсутствуют (не были записаны, не были сформированы или были удалены).
Вообще вернее было бы сказать, что подтреки не содержат данных автоматизации, а служат для их отображения и редактирования.
В левом нижнем углу поля любого трека в списке треков имеется символ "+". Если на нем щелкнуть, то раскроется подтрек, предназначенный для хранения данных автоматизации. Символ "+" превратится в "—". Если теперь щелкнуть на нем — подтрек будет скрыт.

Рис. 4.66. Подтрек, содержащий огибающую автоматизации панорамы

Сам подтрек действительно располагается под треком, к которому он принадлежит. Его поле в списке треков немного смешено вправо относительно полей треков. Возможный вид подтрека с данными автоматизации показан на рис. 4.66.
В нижней части поля подтрека имеется символ "+". щелкнув на котором, можно открыть еще один подтрек. У него, в свою очередь, также будет кнопка в виде "+". У одного трека может быть столько подтреков, сколько вам потребуется. Каждый из подтреков не является уникальным. Любой из подтреков может служить для отображения и редактирования данных автоматизации любого из параметров трека. Назначение подтрека переключается: в правой верхней части области подтрека в списке треков имеется поле, в котором отображается название параметра, на отображение данных автоматизации которого настроен подтрек. Щелчком на данном поле открывается меню, в котором перечислены основные параметры, подлежащие автоматизации, и специальные команды (рис. 4.67, а).

Рис. 4.67. Выбор параметра, подлежащего автоматизации

Выбрав один из параметров, вы тем самым переключите подтрек на отображение автоматизации данного параметра. Если около названия параметра в меню присутствует символ "*", то это означает, что для данного параметра существует автоматизация. Когда вы его выберете, на подтреке будет отображаться соответствующая огибающая, которая, по всей видимости, будет отличаться от горизонтальной прямой линии.
Осталось упомянуть три специальные команды:

  • More — открыть диалоговое окно Add Parameter (рис. 4.67, б), в котором перечислены все параметры, подлежащие автоматизации, а не только те, что перечислены в меню, показанном на рис. 4.67, а.
  • Remove Parameter — скрыть подтрек и удалить данные автоматизации. Команда главного меню Edit > Undo (отмена последнего действия) при этом не действует!
  • Remove Unused Parameters — скрыть все неиспользуемые подтреки, т. е. те подтреки, которые не отображают никакой автоматизации (она не была записана или сформирована).


4.8.2. Формирование и редактирование огибающих автоматизации

Данные автоматизации представляются в виде тонких разноцветных линий, называемых огибающими. Вернее было бы сказать, что огибающие будут цветными в том случае, если для соответствующих подтреков включен атрибут R (Read Enable). Положение точки линии (по вертикали) соответствует значению автоматизированного параметра в текущей позиции проекта. Узловые точки огибающих обозначаются маленькими черными квадратиками. По своей сути огибающие автоматизации — это графики изменения автоматизируемого параметра во времени. Огибающая, имеющая вид прямой линии, означает отсутствие изменений автоматизируемого параметра во времени.
Вы можете сформировать огибающую автоматизации нужной вам формы с помощью мыши. Однако сделать это возможно только в том случае, если для соответствующих потреков включен атрибут R (Read Enable). В противном случае с помощью мыши вы сможете перемещать горизонтальную прямую черную линию, высота которой соответствует значению параметра. Однако говорить об автоматизации данного параметра здесь уже нельзя. Перемещая эту линию, вы изменяете его статическое значение, которое будет оставаться неизменным при воспроизведении проекта.
Итак, если это необходимо, включите атрибут R (Read Enable) и попробуйте вместе с нами сформировать огибающую автоматизации какого-либо параметра (например, панорамы). Еще одно необходимое для этого условие — вы должны пользоваться инструментом [image] (Object Selections), который вам уже хорошо знаком.
На подтреке бледным цветом отображается содержимое основного трека: MlDI-сообщения (в виде черточек) или волновые формы аудиосообщений (рис. 4.68, а). По умолчанию огибающая имеет вид горизонтальной линии. Чтобы "переломить" эту линию, в месте перелома следует создать узел. В свою очередь, для того чтобы создать узел, следует подвести курсор мыши как можно ближе к огибающей автоматизации и выполнить щелчок. Узел возникнет в виде маленького квадрата (скорее, даже в виде жирной точки). Как и любой другой графический объект, узел может находиться в двух состояниях: он может быть выделен (для совершения каких-либо операций над ним) или не выделен. Сразу после создания узел имеет статус выделенного и окрашен в красный цвет. Однако как только вы создадите еще один узел (рис. 4.68, б), первый потеряет статус выделенного и сменит красный цвет на черный. Давайте попробуем переместить вновь созданный узел (рис. 4.68, в). Понятно, что для этого следует ухватиться за него мышью и тянуть в нужном направлении. При этом около курсора будет отображаться подсказка с координатами узла: одна координата — позиция на шкале времени (в нашем примере — это 5.1.1.), другая — значение автоматизируемого параметра в точке узла (в нашем случае автоматизации подлежит панорама, значение панорамы — L 48).

Рис. 4.68. Формирование огибающей автоматизации

Сформируем еще один узел огибающей автоматизации (рис. 4.68, г). При включенном режиме привязки графических объектов [image] (Snap) возможные координаты узлов в полной степени зависят от ограничений, накладываемых данным режимом. Естественно, речь идет только о координатах на оси времени.
Если вы будете внимательны, то заметите, что огибающая перед первым и последним узлами имеет вид горизонтальной линии. Изменение автоматизируемого параметра будет происходить только на отрезках между узлами. К сожалению, в Cubase SX интерполяция значений параметра между узлами огибающих осуществляется только прямыми линиями (линейная интерполяция). Например, в музыкальном редакторе SONAR интерполяция узлов огибающих может осуществляться линиями различного вида. Благодаря этому можно описать огибающую сложной формы небольшим количеством узлов, что существенно облегчает ее редактирование. В Cubase SX для описания огибающей сложной формы потребуется большое количество узлов. Если возникнет необходимость немного изменить форму огибающей, то для этого придется поочередно передвигать все узлы, из которых она состоит. А каждый из узлов может передвигаться только в пределах, ограниченных соседними узлами. Поэтому для формирования сложной огибающей удобнее использовать инструмент [image] (Draw): вы просто рисуете огибающую курсором мыши, словно карандашом. Сам курсор при этом как раз имеет вид карандаша [image] Следует обратить внимание на одну деталь. Когда вы рисуете огибающую с помощью инструмента [image] (Draw) или осуществляете запись автоматизации, формируется огромное количество узлов, в точности описывающих ваши движения (рис. 4.69, а). Как только вы прекратите запись или рисование огибающей, значительное количество узлов исчезнет (рис. 4.69, б). Как раз для того чтобы сделать редактирование формы огибающей осуществимым на практике, программа произведет прореживание узлов. При этом огибающая в целом сохранит свою форму, но мельчайшие подробности исчезнут.

Рис. 4.69. Запись автоматизации

За прореживание узлов отвечает специальный параметр, называемый Automation Reduction Level. Чтобы получить доступ к нему, вызовите команду главного меню File > Preferences. Возникнет окно Preferences, в котором следует выбрать раздел Editing. Глубина прореживания определяется положением регулятора Automation Reduction Level.
Несколько облегчить жизнь в ряде случаев может набор инструментов. скрывающихся за кнопкой [image] ;
(Draw), расположенной на панели инструментов окна проекта. С их помощью вы можете легким движением руки формировать огибающие относительно сложных форм. Перечислим их:
(Line) — отрезок прямой линии;
(Parabola) — линия параболической формы;
(Sine) — линия синусоидальной формы;
(Triangle) — линия периодической треугольной формы;
(Square) — линия периодической прямоугольной формы.
Если не включены режимы [image] (Snap) и Grid (в поле Snap Mode Selector на панели инструментов окна проекта), тогда длительность периода синусоиды, волн треугольной и прямоугольной форм равна одному музыкальному такту. В том случае, когда длительность периода нужно изменить, включите перечисленные режимы и задайте длительность, выбрав соответствующие режимы в полях Grid Selector и (если требуется) Quantize Selector. В качестве примера создадим огибающую в форме параболы, для чего воспользуемся инструментом [image] (Parabola). Подведем курсор мыши к началу параболического участка огибающей, нажмем левую кнопку мыши и переместим курсор мыши в ту позицию, которая будет соответствовать окончанию формируемого участка (рис. 4.70, а). Сам курсор при этом будет иметь вид [image] . Будущая форма огибающей будет показана темно-серой линией.

Рис. 4.70. Создание огибающей в форме параболы

Как только вы отпустите кнопку мыши, огибающая параболической формы будет создана (рис. 4.70, б). При этом будет использован механизм прореживания узлов. В нашем случае "парабола" описана четырьмя узлами. Возможно выполнение операций над группами узлов. Нужные узлы следует выделить с помощью инструментов [image] (Object Selections) или [image] (Range Selections). Затем можно ухватиться за один из выделенных узлов и перетащить всю группу. Выделенные узлы можно копировать или вырезать в буфер обмена. Впоследствии их можно будет вставить в текущую позицию проекта. Выделенные узлы можно удалить, нажав клавишу <Delete>. Автоматизация параметров треков разных видов и плагинов имеет свои особенности. Их анализу посвящены следующие разделы.


4.8.3. Автоматизация MIDI-треков

У MIDI-треков автоматизации подлежат следующие параметры:

  • Volume — громкость MIDI-трека;
  • Pan — панорама MIDI-трека;
  • Mute — мьютирование MIDI-трека;
  • Send 1 Enable — Send 4 Enable — включение/выключение посылов на MIDI-эффекты параллельного действия;
  • Track Parameters on/off switch — включение/выключение всех алгоритмов обработки MIDI-сообщений, управляемых из секции Track Parameters инспектора MIDI-трека;
  • Insert 1 Enable — Insert 4 Enable — включение/выключение MIDI-эффектов последовательного действия;
  • Transpose — транспонирование высоты звука;
  • Vel. Shift — смещение параметра Velocity;
  • Random 1-2 Min/Max/Target — параметры рандомизации;
  • Range 1-2 Min/Max/Target — параметры алгоритма Range;
  • Параметры MIDI-эффектов последовательного действия;
  • Параметры MIDI-эффектов параллельного действия.

Параметры MIDI-эффектов будут доступны для автоматизации в том случае, если соответствующие эффекты подключены к MIDI-треку. На первый взгляд перечень параметров, подлежащих автоматизации, может показаться скромным. Как, например, автоматизировать MIDI-контроллеры, отличные от Volume и Pan? В вашем распоряжении имеется множество MIDI-эффектов, включая эффект Control. С его помощью можно управлять любыми MIDI-контроллерами. А значения параметров данного эффекта (т. е. MIDI-контроллеры) подлежат автоматизации. Пример: требуется построить огибающую для управления MIDI-контроллером Brightness (№74 — управление частотой среза фильтра). Наши действия:
1. В секции Inserts инспектора MIDI-трека подключаем эффект Control (рис. 4.71, а).
2. В качестве одного из параметров данного эффекта, например, вместо BankSel MSB (рис. 4.71, б), выбираем Brightness (рис. 4.71, в).
В результате, MIDI-контроллер Brightness (№74) становится доступным для автоматизации (рис. 4.72).
Хотим обратить ваше внимание на одну деталь. Допустим, вы автоматизируете параметр Pan. В каком виде будут сохраняться данные автоматизации на MIDI-треке? Можно было бы предположить, что автоматизация данного параметра будет записана посредством MIDI-сообщений Controller №10 (Pan).

Рис. 4.71. Подключение MIDI-эффекта Control и выбор MIDI-контроллера Brightness (74) для последующей автоматизации

Рис. 4.72.Автоматизация MIDI-контроллера Brightness (74)

В действительности любая автоматизация в Cubase SX сохраняется в виде специализированных сообщений. Эти сообщения отражают расположение узлов на графиках, описывающих изменения автоматизируемых параметров во времени. Конечно же, при воспроизведении данных автоматизации, в конечном счете, MIDI-устройству (синтезатору, сэмплеру и т. д.) будут передаваться именно MIDI-сообщения. Но формироваться они будут "на лету": программа знает, как расположены узлы графиков, интерполирует их, в нужные моменты времени посылает на выходные порты MIDI-треков соответствующие MIDI-сообщения об изменении положений MIDI-контрол-леров. В то же время внутри MIDI-частей могут храниться серии сообщений типа Controller, которые, в принципе, могут вступать в конфликт с данными автоматизации. Пример: данные автоматизации описывают перемещение инструмента на панораме из центра вправо, и в то же время на треке хранится последовательность MIDI-сообщений, описывающая перемещение инструмента на панораме из центра влево. Что мы реально при этом услышим? Поскольку MIDI-сообщения, формируемые на основании данных автоматизации, и MIDI-сообщения, воспроизводимые с трека, будут посылаться в разные моменты (хотя бы потому, что интерфейс MIDI является последовательным), возникнет "дрожание" контроллера (в нашем случае панорамы). Панорама будет "метаться" слева направо и наоборот десятки раз в секунду.


4.8.4. Автоматизация аудиотреков и групповых треков

У аудиотреков и групповых треков автоматизации подлежат следующие параметры:

  • Volume — громкость трека;
  • Pan Left-Right — панорамирование по оси влево-вправо;
  • Pan Front-Rear — панорамирование по оси вперед-назад (для системы объемного звучания);
  • Mute — мьютирование трека;
  • EQ Master Bypass — временное отключение трекового эквалайзера;
  • FX Send Bypass — временное отключение посылов на эффекты параллельного действия;
  • параметры каждого из четырех фильтров эквалайзера;
  • включение/выключение каждого из восьми посылов;
  • уровень каждого из восьми посылов;
  • переключение pre/post для каждого из восьми посылов;
  • параметры панорамирования системы объемного звучания;
  • переключение пресетов для эффектов последовательного действия;
  • параметры эффектов последовательного действия.


4.8.5. Автоматизация VSTi и аудиоэффектов, мастер-секции микшера

Автоматизировать параметры виртуальных инструментов VSTi можно двумя способами. Первый способ заключается в использовании "стандартных" возможностей автоматизации MIDI-треков для управления параметрами виртуальных синтезаторов VSTi. Из документации на программный синтезатор можно узнать, какими MIDI-контроллерами управляются нужные параметры, и воспользоваться методикой, описанной в разд. 4.7.5, для автоматизации этих параметров с помощью MIDI-плагина Control.
Однако второй способ автоматизации VSTi гораздо удобнее первого. Ведь спецификация VSTi изначально разрабатывалась для интеграции программных синтезаторов в проект Cubase. Это означает, что после подключения к проекту, VSTi становится как бы его частью. В Cubase SX предусмотрен специальный трек для хранения данных автоматизации всех VSTi, задействованных в проекте (VST Instrument Automation). В проекте такой трек может быть только в единственном экземпляре. Данный трек фактически является контейнером для треков, содержащих автоматизацию параметров различных VSTi — каждому VSTi соответствует по одному такому треку. У каждого из этих треков в свою очередь также могут быть подтреки, содержащие данные автоматизации различных параметров этого VSTi.
Однако специальной команды, создающей данный трек, не существует. Как же быть? В верхней части панели каждого из VSTi имеется набор стандартных для плагинов Cubase SX органов управления. Среди них имеются знакомые вам кнопки R (Read Enable — воспроизведение данных автоматизации) и W (Write Enable — запись данных автоматизации). Первое нажатие кнопки W — это и есть команда создания трека-контейнера VST Instrument Automation и трека автоматизации конкретного VSTi. Все вышеизложенное может показаться запутанным, но на практике все обстоит очень просто. В разд. 4.1.3 мы рассказали о том, как VSTi подключаются к проекту. В качестве примера мы задействовали инструмент a1. Теперь давайте создадим трек для автоматизации параметров его синтеза.
Исходные данные: к проекту подключен VSTi a1, один из MIDI-треков настроен на работу с данным инструментом (в качестве выходного порта выбран a1). В основной секции данного MIDI-трека нажмем кнопку е для того, чтобы вызвать появление панели инструмента a1 (рис. 4.73).
Напомним, что вызвать панель VSTi можно и по-другому (посредством команды главного меню Devices > VST Instruments и окна диалога VST Instruments). Все, что нам требуется проделать в данном примере, — нажать кнопку W на панели инструмента. На рис. 4.73 к этой кнопке подведен курсор.
Сразу после этого в списке треков возникнут поля трека-контейнера VST Instrument Automation и трека автоматизации a1 (рис. 4.74). Кнопку R также не помешает нажать (чтобы записанные или сформированные в дальнейшем данные автоматизации воспроизводились).
Дальше возможны два варианта. Вариант первый — запускаем проект на воспроизведение и вращаем различные ручки на панели VSTi. Все действия будут сохранены в виде данных автоматизации. Вариант второй — формируем огибающие автоматизации для нужных параметров. Щелчком на поле Unknown (рис. 4.74) вызываем список параметров конкретного VSTi, подлежащих автоматизации, выбираем нужный параметр, формируем огибающую.
Если нужно автоматизировать еще один параметр, щелкаем на символе "+" в левом нижнем углу поля автоматизации VSTi — откроется еще один под-трек. У него, в свою очередь, тоже будет доступно поле с символом "+" То есть можно открывать столько подтреков, сколько нужно.

Рис. 4.73. Панель виртуального синтезатора а1

Рис. 4.74. Поле трека автоматизации а1 в списке треков

Ответьте на контрольный вопрос. Допустим, вы подключили еще один VSTi и хотите его автоматизировать. Как создать соответствующий трек? Правильно, нужно открыть панель данного инструмента и нажать кнопку W.
На всякий случай заметим, что инспектор трека-контейнера Devices > VST Instruments содержит список треков автоматизации VSTi. А сами треки автоматизации VSTi поля инспектора просто не имеют.
Поговорим об автоматизации параметров аудиоэффектов. Если эффект подключен к аудиотреку в качестве эффекта последовательного действия (в секции Inserts инспектора аудиотрека), то все его параметры будут доступны для автоматизации в рамках данного трека. Но ведь в проекте могут использоваться и эффекты параллельного действия (подключенные в окне VST Send Effects, вызываемом командой главного меню Devices > VST Send Effects), которые не ассоциируются ни с одним из аудиотреков. Как их автоматизировать? В данном случае имеется полная аналогия с автоматизацией VSTi: нажимаете кнопку W на панели аудиоэффекта, автоматически создается трек-контейнер Effect Automation и трек автоматизации данного эффекта. Можете записывать свои манипуляции с параметрами эффекта во время воспроизведения проекта, можете формировать огибающие автоматизации — на ваше усмотрение.
Тема данного раздела была бы не раскрыта, если бы мы не рассказали об автоматизации мастер-секции микшера Cubase SX. Однако нам придется немного забежать вперед и вкратце рассказать о том, что же представляет из себя мастер-секция микшера. Как вы знаете, у каждого аудиотрека или группового трека имеется выходной порт. Для нескольких аудиотреков или групповых треков может быть задан один и тот же выходной аудиопорт. Поэтому можно говорить о том, что выходные аудиопорты по своей сути являются шинами — на них объединяются сигналы от разных треков. Кстати, по умолчанию стереопары выходных портов так и называются BUS 1, BUS 2 и т. д. (bus — шина). На эти же шины осуществляется вывод сигналов, возвращаемых после обработки эффектами параллельного действия. Аудиотре-ки и групповые треки соответствуют линейкам виртуального микшера Cubase SX. Кроме всего прочего, в данном микшере имеется мастер-секция. В мастер-секции собраны все шины (выходные порты). Поэтому имеется возможность управлять общей громкостью всех аудиотреков, групповых треков и VSTi, используемых в проекте. Кроме того, к мастер-секции могут быть подключены аудиоэффекты последовательного действия. Все это нужно для осуществления мастеринга непосредственно с помощью Cubase SX и VST-плагинов.
В дальнейшем вы увидите, что на мастер-секции микшера также имеются кнопки R (Read Enable — воспроизведение данных автоматизации) и W (Write Enable — запись данных автоматизации). Первое нажатие кнопки W является командой создания специализированного трека-контейнера Master Automation. Этот трек-контейнер предназначен для хранения треков с данными автоматизации следующих параметров:

  • громкость каждой из шин в отдельности (BUS Volume);
  • общая громкость (Master Gain);
  • общие уровни посылов на эффекты параллельного действия, подключаемые в окне VST Send Effects (Effect Input Level).


4.9. Атрибуты объектов проекта, поле Infoline

На панели инструментов окна проекта имеется кнопка [image] (Show Event Infoline). Если ее включить, под панелью инструментов возникнет информационное поле Infoline, отображающее значения основных атрибутов выделенной части или аудиосообщения (рис. 4.75).

Рис. 4.75. Поле Event Infoline

Альтернативный способ показать или скрыть данное поле — воспользоваться командой контекстного меню секции треков или поля инспектора Show Info/Hide Info.
Все атрибуты, отображаемые на панели Infoline, доступны для редактирования. Причем редактировать их на данной панели в ряде случаев удобнее, чем какими-либо другими путями.
Перечислим атрибуты, доступные для MIDI-части:

  • Name — название части;
  • Start — позиция начала части;
  • End — позиция окончания части;
  • Length — длина части;
  • Offset — смещение левой границы части относительно ее начального положения;
  • Mute — атрибут мьютирования;
  • Lock — атрибуты блокирования части;
  • Transpose — транспонирование в полутонах.

Набор атрибутов части, содержащей аудиосообщения, будет отличаться от описанного выше отсутствием атрибута Transpose.
А набор атрибутов аудиосообщения будет отличаться существенно:

  • File — название звукового файла;
  • Description — описание аудиосообщения;
  • Start — начальная позиция;
  • End — конечная позиция;
  • Length — длительность аудиосообщения;
  • Offset — начало аудиосообщения, которое задается в виде смещения относительно начала звукового файла;
  • Snap — реперная точка;
  • Volume — громкость аудиосообщения;
  • Fade In — длительность фазы нарастания громкости;
  • Fade Out — длительность затухания громкости;
  • Mute — мьютирование;
  • Lock — атрибуты блокирования аудиосообщения.

Особо хочется выделить параметр Snap. Дело в том, что в каждом звуковом сообщении имеется специальный маркер, который определяет смещение особой опорной точки относительно начала клипа. По умолчанию она совпадает с началом аудиосообщения, но может располагаться и внутри него.
При перемещении аудиосообщения привязка (см. разд. 4.4.4) будет осуществляться именно к этой точке, а не к его началу. Параметр Snap определяет положение опорной точки на оси времени. Если значение Snap отличается от Start, то опорная точка не совпадает с началом аудиосообщения.
Атрибуты узлов огибающих автоматизации (которые по своей сути тоже являются сообщениями):

  • Туре — автоматизируемый параметр;
  • Start — позиция узла на оси времени;
  • Value — значение автоматизируемого параметра в точке узла (высота узла на графике).

Атрибуты имеются абсолютно у всех объектов проекта, включая видеофайлы, которые могут быть импортированы в проект командой главного меню File > Import > Video File. Однако нет особого смысла их перечислять.


Глава 5. Использование микшера

    • Использование микшера
    • 5.1. Маршрутизация аудиопотоков
    • 5.2. Режимы отображения окна Mixer, общая панель, операции над модулями микшера
    • 5.3. Модули и мастер-секция микшера
    • 5.3.1. Модуль аудиотрека
    • 5.3.2. Модули VSTi и группового трека
    • 5.3.3. Модуль MlDI-трека, особенности применения VSTi
    • 5.4. Пространственное панорамирование
    • 5.5. Мастер-секция микшера
    • 5.6. Подключение VST-плагинов
    • 5.6.1. Получение информации о плагинах
    • 5.6.2. Применение эффектов параллельного действия в многоканальных проектах
    • 5.6.3. Подключение плагинов к мастер-секции микшера


Использование микшера

Недаром программы, подобные Cubase SX, принято называть виртуальными студиями. Виртуальная студия включает в себя множество различных устройств, среди которых имеются MIDI-секвенсор, многоканальный цифровой магнитофон, обработки и эффекты, проигрыватель видео и, конечно, микшер. Однако в отличие от традиционной студии, в Cubase SX не всегда возможно выделить отдельные устройства, провести между ними границы.
Кнопкой [image] (Track Mixer) на панели инструментов окна проекта, или командой главного меню Devices > Mixer, или клавишей <F3> открывается окно Mixer, возможный вид которого показан на рис. 5.1.

Рис. 5.1. Окно Mixer

Нам было бы проще, если бы виртуальный микшер Cubase SX однозначно соответствовал данному окну. Но все обстоит несколько сложнее. Можно считать, что вся программа Cubase SX представляет собой микшер, в который интегрированы другие устройства. Модули (strips) данного микшера соответствуют MIDI-, аудио- и групповым трекам. Какие именно модули должны быть в вашем микшере и в каком порядке они должны располагаться — определяете вы сами, когда создаете и перемещаете треки в окне проекта.


5.1. Маршрутизация аудиопотоков

Зная особенности Cubase SX, мы построили функциональную схему его микшера (рис. 5.2). Некоторые вещи мы сократили, чтобы этот рисунок не выходил за пределы одной страницы. Например, на данной схеме не представлена маршрутизация MIDI-сообщений от входных MIDI-портов к выходным. Каждому MIDI-треку в микшере соответствует свой модуль. На своей же схеме мы показали только аудиочасть микшера, хотя присутствие MIDI-треков, управляющих VSTi, обозначено. Прямоугольник MIDI Track, символизирующий MIDI-трек, который управляет VSTi, мы расположили за пределами затененной области — аудиочасти микшера.

Рис. 5.2. Функциональная схема микшера (аудиочасть)

Итак, что же здесь изображено? Виртуальная звуковая студия имеет входные (VST Inputs) аудиопорты. Доступ пользователя к списку доступных портов осуществляется через окно VST Inputs (команда главного меню Devices > VST Inputs, клавиша <F5>, описание приведено в разд. 2.6). Поскольку
данные из одного и того же MIDI-порта могут передаваться на разные аудиотреки, входные порты по своей сути являются шинами. На нашей схеме показан всего один аудиотрек, но нужно понимать, что их может быть много. Аудиотрек может быть подключен к любому из доступных входных аудиопортов, поэтому связь шин VST Inputs с аудиотреком показана пунктирной стрелкой.
В проекте Cubase SX может быть использовано до 32 экземпляров VSTi. Когда в окне VST Instruments (команда главного меню Devices > VST Instruments, клавиша <F11>, описание приведено в разд. 4.1.3) вы подключаете VSTi, в микшере появляется соответствующий модуль, который по своему виду очень напоминает модуль аудиотрека, но не имеет входного аудиопорта. Существуют многоканальные VSTi. Например, сэмплер Halion фирмы Steinberg имеет 4 выходных стереофонических канала и 4 монофонических. Каждому каналу VSTi соответствует отдельный модуль микшера. Благодаря этому вы можете по-разному обрабатывать сигналы разных каналов. Управление любым VSTi может осуществляться с любого MIDI-трека: у нужного MIDI-трека в качестве выходного MIDI-порта выбирается нужный VSTi.
К модулям аудиотреков и к модулям VSTi можно подключать до 8 VST-плагинов в режиме вставки.
Для подключения эффектов параллельного действия предусмотрены 8 шин. К каждой из этих шин средствами окна VST Send Effects (команда главного меню Devices > VST Send Effects, клавиша <F6>, описание приведено в разд. 4.2.2} можно подключить только по одному эффекту.
Отдельно стоит упомянуть о групповых треках. Наличие групповых треков существенно расширяет возможности применения эффектов. Групповые треки также можно считать шинами, поскольку на вход одного и того же трека могут поступать сигналы от множества других треков. Вы можете указать один и тот же групповой трек в качестве выходного порта для нескольких модулей микшера. В результате суммарный сигнал этих модулей можно обработать одним набором эффектов последовательного действия. Ведь к групповым трекам тоже можно подключать эффекты в режиме вставки. Кроме того, вы можете использовать групповые треки вместо шин VST Send Effects для применения эффектов последовательного действия. Для этого нужно отвести сигнал с нужного модуля в режиме посыла (send) на шину нужного группового трека. Преимущество такого подхода: к одной шине VST Send Effects можно подключить только один эффект, а к групповому треку можно подключить цепочку из нескольких (до 8) эффектов. На нашей схеме обозначен только один групповой трек, а в действительности их количество ограничено лишь здравым смыслом. По своим функциям модули групповых треков очень похожи на линейки аудиотреков и VSTi. Основное отличие модулей групповых треков от модулей аудиотреков заключается в том, что их невозможно подключить к входному порту. Имеют место следующие ограничения:
  • невозможно осуществить посыл' (send) сигнала группового трека на этот же трек;
  • в качестве выходного порта группового трека может быть выбран другой групповой трек из тех, что расположены после первого.

Сигналы с выходов треков и шин VST Send Effects, в конечном счете, попадают на выходные порты-шины (VST Outputs). На нашей схеме представлен вариант конфигурации микшера для системы 5.1. Имеется 6 независимых шин, соответствующих выходам L, R, Ls, Rs, С и LFE. Кроме того, имеются три выходные шины BUS 1, BUS 2 и BUS 3, в которых перечисленные выходы объединены попарно. Для простоты мы отобразили на схеме только эти шины и в скобках указали, каким выходам в системе 5.1 соответствует каждая их этих шин. Любую из перечисленных шин можно не только выбрать в качестве выходного порта, но и отправить на нее сигнал в режиме посыла (send). Управление параметрами доступных выходных шин осуществляется средствами окна VST Outputs (команда главного меню Devices > VST Outputs, клавиша <F4>, описание приведено в разд. 2.6). Как минимум, одна выходная шина (BUS 1) логически подчинена мастер-модулю микшера (Master). Фейдером Master Gain мастер-модуля регулируются уровни сигналов на всех выходных шинах, подчиненных мастер-модулю. Конфигурация мастер-модуля — состав подчиненных ему выходных шин определяется в окне VST Master Setup (команда главного меню Devices > VST Master Setup, описание приведено в разд. 2.6). Мастер-модулю микшера соответствует шина Master, которая может быть выбрана в качестве выходного порта для треков и эффектов, подключенных в окне VST Send Effects. Однако непосредственное подключение выходов треков к шине Master осуществляется только посредством плагина SurroundPan, который обеспечивает круговое панорамирование. При выборе SurroundPan в качестве выходного порта трека создается экземпляр этого плагина для данного трека. По своей сути SurroundPan является минимикшером, снабженным интерфейсом, удобным для кругового панорамирования и распределяющим сигнал от монофонического или стереофонического трека между несколькими выходными портами, объединенными в шине Master.
Если же вы работаете в формате Stereo, то следует иметь в виду, что по умолчанию в качестве выходного порта каждому из треков устанавливается первая доступная выходная шина (BUS 1), которую в окне VST Inputs невозможно отключить. Получается такая картина: с одной стороны, сигнал с трека выводится на шину BUS 1, а не на шину Master, и в то же время, сигнал этой выходной шины будет обрабатываться эффектами (VST Master Effects), подключенными к мастер-модулю, и регулироваться фейдером Master Gain (общая громкость). Возможно это потому, что данная шина контролируется мастер-модулем. Под контроль мастер-шины можно взять и другие шины, но исключить шину BUS 1 из списка контролируемых невозможно. Правда, ее можно переименовать, но от этого ровным счетом ничего не изменится. В завершение раздела стоит отметить одну деталь. Невозможно осуществить посыл сигналов треков (send) на шину Master. Поэтому на нашей схеме стрелки от выходов треков Send 1 Send 8 проходят мимо шины Master.


5.2. Режимы отображения окна Mixer, общая панель, операции над модулями микшера

Надеемся, что после описания схемы возможных аудиопотоков Cubase SX освоение элементов окна Mixer (рис. 5.1) станет более простым.
Вид данного окна в большой степени зависит от состояния кнопок, расположенных вдоль его левой вертикальной границы на общей панели (Common Panel). Кроме кнопок в левой части окна имеется темное поле с символом [image] . Если щелкнуть на этом поле, откроется меню, в котором можно выбрать режим отображения окна Mixer:

  • Normal — окно имеет минимальную высоту и вмещает в себя один ряд модулей микшера;
  • Expand — расширенный режим, в котором высота окна увеличивается более чем в два раза, что позволяет вынести на панель микшера дополнительные элементы. Переключение между режимами Normal/ Expand можно осуществлять с помощью кнопки [image] (Extended/Normal Mixer);
  • Narrow — режим, при котором все модули микшера имеют минимальную ширину (данный режим сбрасывается при переключении в Expand);
  • Wide — режим, при котором все модули микшера имеют нормальную ширину;
  • Inserts или кнопка [image] (в режиме Expand) — отображать над модулями микшера слоты для подключения эффектов последовательного действия;
  • EQs или кнопка [image] (в режиме Expand) — отображать над модулями микшера эквалайзеры;
  • EQ + или кнопка [image] (в режиме Expand) — альтернативный способ отображения эквалайзеров, при котором их параметры доступны в виде вращающихся регуляторов;
  • Sends или кнопка [image] (в режиме Expand) — отображать поля с параметрами посылов;
  • Sends + или кнопка [image] (в режиме Expand) — альтернативный режим отображения посылов, при котором параметры посылов доступны в виде вращающихся регуляторов;
  • Disk или кнопка [image] — отображать модули аудиотреков;
  • Groups или кнопка [image] — отображать модули групповых треков;
  • VSTi или кнопка [image] — отображать модули VSTi;
  • Rewire или кнопка [image] — отображать модули каналов ReWire. О том, что это такое, мы расскажем в главе 11;
  • MIDI или кнопка [image] — отображать модули MIDI-треков;
  • Hideable — опция отображения всех скрытых модулей.

Описанные выше команды работают применительно ко всем модулям микшера. Однако на каждом из модулей имеется свое собственное меню, вызываемое щелчком на поле с символом [image] . В меню доступны команды, которые выполняются применительно к данному модулю: Narrow, Wide, Inserts, EQs, EQ +, Sends, Sends + и Hideable. Последняя команда-опция скрывает модуль. Чтобы вернуть на экран невидимый модуль, следует включить опцию отображения всех скрытых модулей и отключить опцию Hideable индивидуально для нужного модуля. После этого можно отключить опцию отображения всех скрытых модулей — нужный модуль вновь станет видимым, а остальные модули-невидимки (у которых включена опция Hideable) скроются.
Как вы уже, наверное, поняли, различные модули могут отображаться по-разному: иметь сокращенную или полную ширину, в расширенном режиме над модулями могут отображаться различные наборы параметров. Конфигурации модулей микшера можно сохранить в виде пресетов. Кнопка [image] (Create/Select Channel View Sets) — открывает меню, в котором доступны следующие команды:

  • Add — сохранить текущие настройки модулей микшера в виде пресета;
  • Название пресета — загрузить настройки модуля из пресета. Выбранный пресет считается текущим (отмечен галочкой);
  • Remove — удалить текущий пресет.

В нижней части каждого из модулей имеются два поля. В самом нижнем поле отображается название выходного порта/шины, к которому подключен данный модуль. Если на нем щелкнуть, то откроется меню, в котором для данного модуля можно выбрать другой выходной порт. В том поле, что расположено чуть выше, отображается название модуля (и соответствующего ему трека в окне проекта). Если сделать на этом поле двойной щелчок, то название модуля станет доступным для редактирования. Если же сделать одинарный щелчок, то данный модуль (и соответствующий ему трек) получит статус выбранного, и оба его нижних поля окажутся выделенными ярким цветом. Вы можете выбрать одновременно несколько модулей микшера. Для этого следует "перещелкать" названия нужных модулей, удерживая нажатой клавишу <Shift>. После этого может возникнуть затруднительная ситуация: как снять выделение с модулей? Для этого можно воспользоваться кнопкой [image] (Select Channel). Нажатие этой кнопки открывает меню, в котором можно выбрать один единственный модуль, который будет считаться выбранным. Все остальные модули при этом потеряют статус выбранных. Вместо кнопки [image] (Select Channel) вы можете использовать клавиши <<-> и <->> для перемещения единственного выбранного модуля на шаг влево/вправо. Кстати, с помощью клавиш <вверх> и <вниз> можно перемещать фейдер громкости выбранного модуля.
Какие же операции можно выполнять над выбранными модулями? Например, операции передачи значений их параметров через буфер обмена, для чего на общей панели предусмотрены следующие кнопки:
— копировать значения атрибутов выбранных модулей в буфер обмена;
— вставить значения атрибутов из буфера обмена в выбранные модули.
Если щелкнуть правой кнопкой мыши на любом месте окна Mixer, то появится контекстное меню, содержащее следующие команды:

  • Link Channels — связать фейдеры громкости и регуляторы уровней посылов (sends) у выделенных треков. Если потребуется изменить положение какого-либо фейдера независимо от фейдеров остальных связанных треков, то это можно сделать удерживая нажатой клавишу <Аlt>;
  • Unlink Channels — сделать фейдеры и регуляторы выделенных треков независимыми;
  • Save Selected Channels — сохранить настройки выделенных модулей в файл;
  • Load Selected Channels — загрузить настройки выделенных модулей из файла;
  • Save VST Master, Sends and VSTi — сохранить настройки мастер-секции, посылов и модулей VSTi в файл;
  • Load VST Master, Sends and VSTi — загрузить настройки мастер-секции, посылов и модулей VSTi из файла;
  • Save VST Master FX — сохранить настройки эффектов, подключенных к мастер-секции в файл;
  • Load VST Master FX — загрузить настройки эффектов мастер-секции из файла;
  • Save All Mixer Settings — сохранить все настройки микшера в файл;
  • Load All Mixer Settings — загрузить все настройки микшера из файла;
  • VU-Meter Fast — режим работы индикаторов уровней сигналов с малым временем интеграции: столбики индикаторов будут быстро реагировать на кратковременные изменения уровня сигнала;
  • VU-Meter Hold — режим работы индикаторов уровней сигналов, при котором пиковые значения уровней сигналов будут отображаться в виде горизонтальных черточек. Время, через которое показания пикового индикатора будут сбрасываться, задается параметром VU-Meter Peak's Hold Time, доступным в окне Preferences в категории VST (см. разд. 2.7).

Рассмотрим некоторые из перечисленных команд более подробно. Во-первых, следует упомянуть о кнопке [image] (Show Master), с помощью которой можно отобразить или скрыть мастер-секцию микшера. Ведь многие из перечисленных команд затрагивали именно ее.
Для сохранения настроек любых параметров микшера используются файлы одного единственного типа, имеющие расширение VMX. Однако вам не удастся, например, выполнить такой фокус: сохранить все настройки микшера командой Save All Mixer Settings, а потом воспользоваться командой Load VST Master FX для того, чтобы из ранее сохраненного файла загрузить только те данные, которые касаются настроек эффектов мастер-секции. Несмотря на одинаковый тип файлов, структура хранимой в них информации будет зависеть от того, какой командой данный файл был создан. Поэтому в именах сохраняемых файлов целесообразно отражать их содержимое.
При операциях сохранения/загрузки следует учитывать, что информация о выбранных модулях в файлах хранится без привязки к каким бы то ни было реальным адресам. Допустим, вы сохранили настройки трех модулей, которые в вашем микшере имели условные номера 1, 3, 4. В файле будут храниться настройки трех абстрактных модулей. Вы можете выбрать модули 5, 8, 10 и загрузить в них настройки из ранее сохраненного файла.
Еще нужно помнить о том, что сохраненные файлы настроек всего микшера предназначены именно для той конфигурации микшера, которая имела место в момент сохранения. Допустим, в момент сохранения в вашем микшере присутствовало 10 модулей. Вы решили использовать эти настройки для другого своего проекта, в котором пока нет ни одного трека и, следовательно, нет ни одного модуля микшера. Этот подход ошибочен: после выполнения команды Load All Mixer Settings в микшере не появится ни одного модуля. Настройки модулей можно загрузить только в существующие модули. Если в вашем проекте будут присутствовать хотя бы 5 модулей, то в них будут загружены настройки первых 5 модулей из тех 10, которые хранятся в файле.
Еще стоит упомянуть о нескольких кнопках, которые тоже расположены на общей панели. Кнопки [image] и [image] отключают соответствующие атрибуты (Mute и Solo) на всех модулях микшера. Кнопки [image] и [image] включают/выключают соответствующие атрибуты (Read Automation — воспроизведение автоматизации и Write Automation — запись автоматизации) на всех модулях микшера.


5.3. Модули и мастер-секция микшера

Может показаться, что мы слишком сильно забежали вперед, рассказав о том, какие операции можно производить над модулями микшера, не описав эти самые модули. Но если вы читали предыдущую главу, то в следующем разделе вы ничего принципиально нового не найдете. Описание модулей и мастер-секции микшера — простая формальность.


5.3.1. Модуль аудиотрека

Модуль аудиотрека показан на рис. 5.3, а. А на рис. 5.3, б показан этот же модуль, но в режиме Narrow (минимальная ширина). В последнем случае на модуле доступен минимальный набор параметров. Подробнее остановимся на анализе модуля в режиме Wide (полная ширина). По набору своих параметров модуль аудиотрека очень похож на модули VSTi и групповых треков. В левой нижней части модуля расположен символ [image] идентифицирующий данный модуль именно как модуль аудиотрека.

Рис. 5.3. Линейка аудиотрека

В правой части модуля расположены фейдер громкости и индикатор уровня сигнала. В поле, расположенном под фейдером, в цифровой форме отображается его положение. В поле, расположенном над фейдером, отображается пиковое значение уровня сигнала. Перечислим сверху вниз элементы, расположенные справа от фейдера:
— регулятор панорамы;
— кнопка включения/выключения атрибута Mute;
— кнопка включения атрибута Solo;
— кнопка включения режима воспроизведения автоматизации;
— кнопка включения режима записи автоматизации;
— кнопка открывает окно VST Channel Settings (рис. 5.5);
— кнопка временного отключения эффектов, подключенных в режиме вставки;
— кнопка временного отключения трекового эквалайзера;
— кнопка временного отключения посылов;
— атриоут готовности к записи;
— кнопка включения мониторинга.
Как и у любого другого модуля, у модуля аудиотрека в нижней части имеются два поля: поле выбора выходного порта и поле названия модуля/трека. В верхней части модуля расположено поле выбора входного порта.
В расширенном режиме (Expand) модуль аудиотрека может иметь продолжение, расположенное над его основной частью — такая своеобразная надстройка. Щелчком на поле с символом [image] открывается меню, в котором можно выбрать тип нужной секции:

  • Inserts — слоты для подключения эффектов последовательного действия (рис 5.4, а);
  • EQs — эквалайзер (рис 5.4, б);
  • EQ + — эквалайзер с вращающимися регуляторами (рис 5.4, <?);
  • Sends — отображать поля с параметрами посылов (рис 5.4, г);
  • Sends + — посылы с вращающимися регуляторами (рис 5.4, д).

В этом же меню можно выбрать режим отображения модуля:

  • Narrow — минимальна ширина;
  • Wide — нормальная ширина;
  • Hideable — не отображать данный модуль.

Перечисленные секции (рис. 5.4, а, б, в, г, д) выполняют те же самые функции, что и соответствующие им секции инспектора аудиотрека в окне проекта. Отличия заключаются лишь в дизайне.

Рис. 5.4. Возможные надстройки над линейкой аудиотрека

Об окне VST Channel Settings (рис. 5.5) мы уже упоминали в разд. 4.1.2. и в разд. 4.2.2. Напомним, что основное назначение данного окна — это интеграция всех параметров одного из каналов микшера. В левой части окна имеются некоторые из тех кнопок, что присутствуют на общей панели микшера, и кнопка инициализации текущего канала микшера [image] (Initialize Channel). "Инициализация" в данном случае означает сброс всех настроек.

Рис. 5.5. Окно VST Channel Settings

Содержание остальной части окна зависит от того, какой из модулей микшера является текущим. На рис. 5.5. представлен вид окна VST Channel Settings для канала микшера, соответствующего аудиотреку. В данном случае это окно состоит из следующих компонентов: модуль (strip) аудиотрека, секция Inserts, секция эквалайзера, секция Sends. Секция эквалайзера окна VST Channel Settings описана в разд. 4.2.2.


5.3.2. Модули VSTi и группового трека

Модули VSTi (рис. 5.6, а) и группового трека (рис. 5.6, б) мало чем отличаются от модуля аудиотрека и по дизайну, и по функциям.

Рис. 5.6. Модули VSTi (а) и группового трека (б)

Имеются лишь небольшие отличия. У данных модулей нет и не может быть входных портов. Чтобы модули различались между собой, в нижней части каждого из них имеется по символу: — соответствует VSTi, [image] — соответствует групповому треку.
Особо хочется обратить внимание на модуль VSTi. В окне проекта ему не соответствует ни один трек. Один или несколько модулей VSTi появляются в микшере сразу после подключения VSTi к проекту. При этом наличие управляющего MIDI-трека не является обязательным. То есть модули VSTi и модули тех MIDI-треков, для которых данный VSTi выбран в качестве выходного порта, живут отдельной жизнью. Причем модули VSTi "живут" только в окне Mixer.
Напомним, что сигналы, генерируемые VSTi, вы можете обрабатывать эффектами последовательного или параллельного действия и эквалайзером точно так же, как это делается применительно к аудиотрекам.


5.3.3. Модуль MIDI-трека, особенности применения VSTi

По умолчанию модули MIDI-треков отображаются в режиме Narrow (рис. 5.7, а). Этим разработчики, видимо, подчеркивают невысокую значимость модулей MIDI-треков в окне Mixer. Дело в том, что основная работа с MIDI-треками осуществляется именно в окне проекта.

Рис. 5.7. Линейка MIDI-трека

Возможный вид модуля MIDI-трека в режиме Wide показан на рис. 5.7, б: Как видите, отличия от дизайна модуля аудиотрека опять-таки незначительные: отсутствует кнопка временного отключения эквалайзера (в связи с отсутствием последнего), в левой нижней части модуля находится символ [image] идентифицирующий его как модуль MIDI-трека. Столбик на "индикаторе уровня сигнала", расположенном в правой части модуля, подскакивает в такт поступающим сообщениям типа Note на высоту, пропорциональную значениям параметра Velocity. Обратите внимание на положения фейдера и регулятора панорамы, принятые по умолчанию: "Off1 означает, что панорама и/или громкость не определена — MIDI-устройству не было передано ни одного соответствующего сообщения.
Возникает интересный вопрос, опять-таки касающийся применения VSTi. Модуль VSTi управляется MIDI-треком. Так как же, в конечном счете, лучше управлять такими параметрами, как громкость и панорама: посредством MIDI-сообщений (с модуля MIDI-трека) или средствами модуля VSTi?
Однозначного ответа быть не может. Например, существует высококачественный VSTi Edirol SuperQuartet v. 1.0, обладающий уникальным по красоте звучанием (http://www.edirol.com). Он является полифоническим и содержит свои собственные эффекты. Но, при всех своих достоинствах, данный VSTi является двухканальным — на выходе у него стереосигнал. При подключении этого плагина к проекту Cubase SX в микшере появится всего один модуль VSTi. Поэтому в данном случае раздельное управление громкостью и панорамированием инструментов можно осуществлять только посредством MIDI-сообщений. Для каждого из инструментов SuperQuartet, управляемых по разным MIDI-каналам, вы создаете по одному MIDI-треку и с них управляете панорамой и громкостью. Но самое интересное заключается в том, что управлять громкостью, панорамой и другими параметрами VSTi в конкретном примере удобнее всего, пользуясь панелью самого SuperQuartet.
Еще пример: драм-машина VSTi Dr-008 фирмы FXpansion (http://www.fxpansion.com) является многоканальной. Каждому из каналов соответствует свой модуль VSTi в микшере Cubase SX. Вы можете направлять группы внутренних шин Dr-008 на разные модули VSTi и, соответственно, обрабатывать их сигналы по-разному. Однако и в этом случае панорамирование и управление громкостью отдельных ударных звуков удобнее осуществлять средствами панели самого Dr-008.
Последний пример: синтезатор VSTi FM7 фирмы Nativelnstruments (http://www.nativeinstruments.de/) является однотембральным, на выходе у него стереосигнал. В данном случае управление громкостью и панорамой можно осуществлять как с MIDI-трека, так и с модуля VSTi. Что предпочтительнее, опять-таки, сказать невозможно. Хотя если вы работаете в многоканальном формате (например, в 5.1), то выбора у вас не остается. Все существующие на данный момент VSTi являются источниками стерео-сигнала. А пространственное панорамирование можно осуществлять только средствами модулей VSTi, аудио- и групповых треков микшера.


5.4. Пространственное панорамирование

Если в качестве выходного порта модуля VSTi, аудио- или группового трека выбран плагин SurroundPan, то вместо регулятора стереопанорамы будет доступно уже знакомое вам поле пространственного панорамирования. С ним мы уже встречались в разд. 4.2.2. Это поле можно использовать для перемещения источника звуков на круговой панораме, однако это далеко не всегда удобно: маленькие размеры поля, сравнимые с разрешающей способностью мыши, затрудняют точное позиционирование. И еще одно: независимо от того, является ли модуль микшера монофоническим или стереофоническим, в поле пространственного панорамирования в виде точки будет отображаться всего один источник звука, соответствующий одному из стереоканалов.
Если сделать двойной щелчок на данном поле, то откроется окно Рanner рис. 5.8, а), с помощью которого можно точно управлять пространственным панорамированием. Вообще, вид данного окна зависит от настроек мастер-секции микшера. Напомним, что командой главного меню Device > Master Setup открывается диалоговое окно Master Setup, в котором можно зыбрать один из многоканальных форматов. Данное окно описано в разд. 2.6. А мы рассмотрим вариант окна Рanner при использовании формата 5.1.

Рис. 5.8. Окно Panner

Символами [image] условно обозначено расположение фронтальных акустических систем, а символами [image] — расположение тыловых акустических систем. Если щелкать на любом из этих символов и удерживать при этом нажатой клавишу <Alt>, то будет происходить отключение/включение соответствующих каналов. Расположение монофонического источника звука символизируется расположением на квадратном поле окна "горошины" с буквой М: . Вы можете перемещать источник по полю так, как вам угодно. При этом из динамиков [image] и [image] в направлении центра будет выдвигаться нечто, похожее на ленту (рис. Ь.8, 6). Длины этих лент будут пропорциональны уровню сигнала в соответствующих каналах. Сами же уровни сигнала в цифровой форме отображаются под и над символами [image] и [image] .
Регулятором Center Level определяется степень участия центрального канала в формировании кажущегося расположения источника звука. Если передвинуть этот регулятор в крайнее левое положение, то центральный канал окажется вообще незадействованным. В крайнем правом положении вся "нагрузка" будет перераспределена от левого и правого фронтальных каналов к центральному каналу. Регулятором LFE задается уровень сигнала, посылаемого в канал низкочастотных эффектов.
Существуют различные режимы работы SurroundPan. По умолчанию включен режим Mono Mix. Если SurroundPan подключен к источнику стереофонического звука (стереофонический аудиотрек, VSTi или групповой трек), то в режиме Mono Mix сигналы обоих стереоканалов суммируются в один монофонический. Поэтому режим Mono Mix целесообразно использовать для монофонических аудиотреков или для сигналов, которые по своему формату хоть и являются стереофоническими, но, в действительности, не обладают стереофоническими свойствами (одинаковый сигнал в обоих каналах). Если щелкнуть на поле с надписью Mono Mix, то откроется меню, в котором будут доступны и другие режимы: Y-Mirror, X-Mirror и XY-Mirror. В любом из этих режимов стереопара представляется уже в виде двух "горошин" (рис. 5.8, в), подписанных буквами L (левый) и R (правый). Вы можете ухватиться за любую из них и переместить на любое место квадратного поля окна, символизирующего окружающее пространство. Источник другого стереоканала при этом будет тоже перемещаться, причем перемещение будет происходить симметрично. Ось симметрии зависит от выбранного режима:

  • Y-Mirror — симметрия относительно вертикальной оси;
  • X-Mirror — симметрия относительно горизонтальной оси;
  • XY-Mirror — симметрия относительно центра.

Над регулятором LFE расположены три регулятора: Front, Back и Y. Они управляют дивергенцией — степенью участия различных каналов в формировании фантомного образа звукового источника. Звучит довольно загадочно, поэтому будем последовательно переходить от более простых примеров к более сложным. Для начала рассмотрим стереосистему. Как сделать так, чтобы кажущийся (фантомный) звуковой образ располагался в центре панорамы? Нужно, чтобы сигналы этого источника в левом и правом канале имели одинаковый уровень. В данном случае в формировании фантомного образа участвуют два канала (все, что имеются в наличии). В многоканальной системе дела обстоят точно так же. В формировании фантомного образа, расположенного где-то между мониторами (speakers), участвуют как минимум те два канала, между мониторами которых расположен кажущийся источник (рис. 5.9, а). Если начать перемещать источник по направлению к центру, к формированию его образа подключатся и другие каналы (рис. 5.9, б). Направление на источник не изменится, но уже будет казаться, что он переместился ближе к слушателю. Продолжаем эксперимент и увеличиваем значение каждого из параметров Front, Back и Y до значения 50% (рис. 5.9, в). Положение символа [image] в окне Рanner не изменилось, но теперь в формировании его образа участвуют все каналы, причем участвуют очень активно (со всех мониторов идет громкий сигнал). В результате кажется, что источник расположен достаточно близко к слушателю. Но ведь от символа [image] до центра квадратного поля еще далеко! Если продолжать двигать источник к центру, то покажется, что он находится где-то совсем близко от слушателя, но все-таки еще не на его месте.

Рис. 5.9. Окно Panner (перемещение источника справа в направлении к центру)

Так что же такое дивергенция? С точки зрения пользователя, это масштаб и форма того пространства, в котором формируется фантомный звуковой источник. С помощью регуляторов Front, Back и Y задаются три параметра, характеризующих это пространство: ширина пространства спереди, ширина пространства сзади и протяженность пространства в направлении, параллельном оси слушатель-центральный канал. Визуально конфигурация дивергенции отображается в виде пунктирного четырехугольника. Если все три параметра равны, то этот прямоугольник превращается в квадрат.
С точки зрения реализации акустического пространства, параметры Front, Back и Y связаны с изменением вклада каждого из излучателей в формирование кажущихся положений источников звука.
Как пользоваться всеми описанными выше инструментами панорамирования? Во-первых, не стоит забывать о традиционных средствах передачи особенностей окружающего пространства: громкость источника, его тембр, громкость и тембр реверберации. А во-вторых, никаких конкретных советов тут быть не может, только общие: больше практики, чаше слушайте "фирменные" записи в многоканальных форматах, используйте пространственное панорамирование осторожно. На рис. 5.10 показана аварийная ситуация, когда все каналы перегружены: все три параметра Front, Back и Y равны 100%, уровни сигналов во всех каналах (кроме LFE) максимальны (об этом также свидетельствуют красные рамки вокруг всех символов [image] и [image] . Куда бы вы не переместили символ [image] кажущееся расположение источника звука не изменится — его можно охарактеризовать как "со всех сторон".
В заключение раздела хотим обратить ваше внимание на следующую деталь. Если щелкнуть на надписи [image] , окно Рanner будет отображать сведения об авторах и версии плагина. Повторный щелчок на любом месте окна — появится перечень горячих клавиш, которые можно использовать при работе с плагином. Однако на практике вы сможете использовать далеко не все из них. Дело в том, что Cubase SX тоже поддерживает всевозможные горячие клавиши, и будет происходить перехват сообщений об их нажатии. Чтобы вернуть окно Fanner в исходный вид, следует сделать еще один щелчок на любом его месте.

Рис. 5.10. Окно Panner (каналы перегружены)


5.5. Мастер-секция микшера

Напомним, что отобразить или скрыть мастер-секцию можно с помощью кнопки [image] (Show Master), расположенной на общей панели микшера. Мастер-секция микшера является самым простым элементом интерфейса микшера (рис. 5.11, а). В ней имеются индикаторы уровней сигналов каждого из выходных каналов, подконтрольных мастер-секции. Над индикаторами уровней расположены индикаторы перегрузки, которые загораются в том случае, если происходит клиппирование (ограничение сигнала на максимально возможном уровне).
Справа расположен фейдер общей громкости (Master Gain), а над ним две кнопки:
— открывает диалоговое окно VST Master Effects (рис. 5.12), в котором расположены восемь слотов для подключения эффектов последовательного действия. Это же окно можно вызвать командой главного меню Devices > VST Master Effects или клавишей <F7>;
— временное отключение эффектов последовательного действия.

Рис. 5.11. Мастер-секция и ее возможная надстройка

Рис. 5.12. Окно VST Master Effects

В расширенном режиме окна Mixer у модуля мастер-эффекта появляется надстройка (рис. 5.11, б), которая по своим функциям частично дублирует окно VST Master Effects.
Первые шесть слотов для подключения эффектов последовательного действия работают в режиме Рге (до прохождения сигналами фейдера Master Gain). Сюда обычно подключают мастеринговые плагины: высококачественный многополосный компрессор, эквалайзер, лимитер и т. п.
Слоты 7 и 8 работают в режиме Post (после прохождения сигналами фейдера Master Gain). Эти слоты предназначены для подключения плагинов, используемых на последней стадии мастеринга перед понижением разрядности (например, дитеринг). Само понижение разрядности (по вашему желанию) может происходить во время экспорта проекта в один или несколько звуковых файлов. Для этого существует команда главного меню File > Export > Audio Mixdown, которая позволяет сохранить область проекта, ограниченную локаторами в один монофонический, стерео- или многоканальный звуковой файл или в несколько монофонических файлов заданного формата.


5.6. Подключение VST-плагинов

Напомним, что в режиме вставки (Insert) целесообразно подключать те эффекты, параметры которых должны подбираться индивидуально для разных модулей микшера. К таковым в частности относится динамическая обработка. В режиме посыла (Send) целесообразно использовать те эффекты, которыми предполагается обрабатывать сигналы нескольких треков, причем в общем миксе должны присутствовать как исходные сигналы, так и обработанные эффектом.
Например, эффект реверберации должен быть общим если не для всего проекта, то для какой-то группы треков уж точно. Было бы странно и неестественно, если бы однотипные источники звука, расположенные неподалеку, звучали одновременно с разной реверберацией. Ведь они, вроде бы, находятся в одном помещении, пусть и виртуальном. Одно помещение — одна реверберация. Используя один эффект реверберации, подключенный в один из слотов VST Send Effects для нескольких модулей, вы автоматически получаете совместимость разных источников звука по характеру реверберации. А за счет того, что для обработки сигналов разных модулей используется один и тот же экземпляр плагина (в данном случае реверберации), вы экономите системные ресурсы.
Ну а теперь поговорим о подводных камнях. В разд. 1.6.2 мы обращали ваше внимание на то, что при подключении эффекта в режиме Send регулировка Dry/Wet должна быть установлена в положение Dry = 0, Wet = 100%: обработанный сигнал должен полностью заменять исходный.
Нужно это в первую очередь для того, чтобы избежать неприятных последствий, вызванных задержкой, которая может возникать не только в программных плагинах, но и в эффектах, реализованных аппаратно. Эту задержку (delay) не стоит путать задержкой реакции Cubase SX на действия пользователя (latency), которая обусловлена необходимостью буферизации звуковых данных при операциях их ввода/вывода. А последствия могут быть такими: сигнал, проходящий обработку, задерживается (пусть даже на несколько звуковых отсчетов), затем возвращается на шину Master или BUS, где смешивается с незадержанным исходным сигналом. Если параметр Dry * 0, то получится, что необработанный сигнал смешивается со своей же копией, но задержанной во времени. Звучит это не очень приятно. Однако не так страшен черт, как его малюют. Задержка возникает далеко не во всех эффектах, а только в тех, которые выполняют анализ входного сигнала перед его обработкой. В основном, это относится к некоторым плагинам и устройствам, выполняющим динамическую обработку. А такую обработку как раз следует применять в режиме вставки, и поэтому параметр Dry должен быть равен 0 (исходный сигнал полностью заменяется обработанным). В этом случае задержка не страшна: сигнал немного задерживается, но не смешивается со своей незадержанной копией.


5.6.1. Получение информации о плагинах

Как же узнать, работает ли устройство с задержкой или нет? Командой главного меню Devices > Plug-in Information откройте диалоговое окно Plug-in Information, показанное на рис. 5.13.

Рис. 5.13. Окно Plug-In Information

В данном окне имеется три вкладки:

  • VST Plug-ins — информация о VST-плагинах;
  • DirectX Plug-ins — информация о DX-плагинах;
  • MIDI Plug-ins — информация о MIDI-плагинах.

Наиболее полными являются сведения о VST-плагинах. Здесь присутствует таблица, состоящая из следующих граф:

  • левая безымянная графа содержит атрибуты отключения плагинов: если снять галочку, соответствующий плагин будет недоступен из проекта;
  • вторая безымянная графа слева — количество загруженных в память экземпляров плагина;
  • Name — название плагина;
  • Nb I/O — количество входных и выходных каналов модуля;
  • Category — категория, к которой относится плагин;
  • Vendor — фирма-производитель;
  • VST Version — версия API VST, на работу с которым рассчитан модуль. Например, если модуль рассчитан на VST 2.0, то он будет работать и с VST 2.2, однако при этом не будет использовать преимущества более новой версии VST;
  • Delay (sample) — та самая задержка, наличие которой нас сейчас интересует. Задержка задается в звуковых отсчетах,
  • Nb Params — количество параметров плагина, доступных для пользователя;
  • Nb Programs — количество пресетов;
  • Modified — дата последней модификации плагина;
  • Folder — путь к файлу плагина.

В поле Shared VST Plug-ins Folder отображается путь к папке VST-плагинов, общей для всех приложений, использующих их. Нажав кнопку Choose, вы можете выбрать другую папку общих плагинов, а кнопкой Update — обновить таблицу с информацией о доступных плагинах.
Итак, далеко не у каждого эффекта значение Delay отлично от 0. Если же Delay > 0, то этот факт следует учитывать.
С применением эффектов и обработок не возникает никаких проблем, если вы работаете в формате стерео. Проблемы возникают при работе в многоканальных форматах.


5.6.2. Применение эффектов параллельного действия в многоканальных проектах

Можно выделить два комплекса проблем:

  • дефицит многоканальных плагинов;
  • многоканальные плагины можно подключать только к мастер-секции микшера;

Обработка многоканального звука — дело тонкое. Сохранить пространственную панораму при мастеринге многоканального звука можно только при использовании специализированных многоканальных плагинов. А их на момент написания данной книги можно пересчитать по пальцам. Кроме того, большинство из существующих многоканальных VST-плагинов не работает с Cubase SX, а работает только с другим продуктом фирмы Steinberg — Nuendo. Мы не сомневаемся, что в скором времени появится огромное количество многоканальных плагинов. Но в описываемой в данной книге версии Cubase SX их применение будет ограничено лишь мастер-секцией микшера. Почему это плохо? Рассмотрим проблему на примере эффекта реверберации. В принципе, можно подключить эффект реверберации к мастер-секции. На протяжении всей композиции у слушателя будет создаваться впечатление того, что он находится в помещении, характеристики которого определяются параметрами реверберации. В отдельных случаях это приемлемо, но в общем случае — нет. Ведь не зря же не принято подключать эффект реверберации к мастер-секции микшера при работе в формате стерео! Это очень ограничивает возможности звукорежиссера при формировании акустического пространства композиции. В разных частях композиции могут использоваться разные типы реверберации — слушатель переносится из одного окружения в другое, испытывает при этом какие-то эмоции. Кроме того, для разных партий может и должна использоваться разная глубина реверберации. Ведь с помощью нее можно передать расстояние от слушателя до кажущегося источника звука. Всего этого вы лишаетесь при подключении эффекта реверберации к мастер-модулю.
Как с этим бороться? На данном этапе можно применять обычные стереофонические эффекты. Рассмотрим способы применения стереофонической реверберации в многоканальном проекте. Но предварительно полезно освежить в памяти схему, представленную на рис. 5.2.
Способ 1. Подключаем плагин реверберации к одному из слотов окна VST Sends Effects. В настройках эффекта задаем параметры Dry = 0/Wet = 100%. В качестве выходной шины (куда будет подаваться обработанный сигнал) можно выбрать многоканальную шину Master или одну из двухканальных выходных шин (рис. 5.14).
При выводе обработанного сигнала на шину Master реально он будет попадать только на два первых канала шины — на левый и правый фронтальные. При выводе обработанного стереофонической реверберацией сигнала на другие шины он окажется или в левом и правом тыловых каналах или в центральном и LFE-каналах. Последний случай вообще является недопустимым. Предыдущие два случая можно отнести к категории "наивного surround". В свое время, когда только появился формат стерео, применялись такие способы панорамирования, при котором сигналы различных инструментов и вокала присутствовали только в одном из двух каналов. Например, гитара — в левом канале, вокал — в правом. Эмоциональный эффек тот такого панорамирования яркий, но звучание неестественное. Такой подход к панорамированию позже получил название "наивное стерео". По аналогии с "наивным стерео" самое время ввести понятие "наивного surround". Что же такое "наивный surround" в данном случае? Например, это когда реверберация присутствует только в двух каналах многоканальной системы. Безусловно, у слушателя будет яркое впечатление от того, что, например, вокал он слышит из центрального канала, а его реверберацию — из тыловых каналов. В некоторых случаях это приемлемо, но не всегда.

Рис. 5.14. Окно VST Send Effects (выбор выходной шины)

Рис. 5.15. Эффект реверберации подключен к модулю группового трека

Способ 2. Подключаем плагин реверберации к модулю группового трека в режиме вставки (рис. 5.15, а). В настройках эффекта задаем параметры Dry = 0, Wet = 100%. В качестве выходного порта модуля выбираем SurroundPan. Размещаем источники, соответствующие левому и правому каналам реверберации так, чтобы их сигналы присутствовали в нескольких каналах многоканальной системы (рис. 5.15, б). Теперь можно осуществлять посыл сигналов на модуль группового трека с других модулей. Уровень посылаемого сигнала будет соответствовать глубине эффекта.
Такой подход позволяет понизить степень "наивности" звучания стереофонической реверберации в системе 5.1. Однако от ощущения плоскости реверберации избавиться не удастся. Как не круги, но она остается стереофонической.


5.6.3. Подключение плагинов к мастер-секции микшера

Слоты мастер-секции микшера используются для подключения плагинов, применяемых на стадии мастеринга. В настоящий момент существует множество высококачественных плагинов, позволяющих реализовывать цифровой мастеринг в пределах виртуальной студии Cubase SX. Так обстоят дела с плагинами, работающими в формате стерео. Что касается многоканальных плагинов, то с ними дела обстоят ровным счетом так, как мы уже говорили — они в дефиците. В поставку Cubase SX входит лишь один многоканальный плагин Mix6to2. По своей сути данный плагин является всего лишь микшером, вся задача которого сводится к сведению шестиканального звука в стереопару. Причем здесь не используется никакого матричного кодирования, и звука в формате Dolby ® Pro Logic на выходе данного эффекта не получится. Тем не менее, вы можете подключать к мастер-секции микшера плагины с любым количеством каналов, в том числе и стереофонических. И мы формально обязаны сообщить вам о том, как это делается.

Рис. 5.16. Эффект реверберации подключен к модулю группового трека

Рис. 5.17. Коммутация входов и выходов плагина с каналами шины Master

После подключения стереофонического плагина к многоканальной шине Master по умолчанию осуществляется обработка первых двух каналов шины. В окне VST Master Effects (команда главного меню Devices > VST Master Effects или клавиша <F7>), в левой части того слота, к которому подключен плагин, станет доступным специальное поле. На рис. 5.16 на это поле наведен курсор мыши. В поле отображаются маршруты сигналов, проходящих по каналам шины Master. Щелчком на данном поле открывается окно Patch Editor (рис. 5.16). Узкий прямоугольник, расположенный горизонтально, символизирует плагин. Сверху вниз по разным каналам шины Master следуют сигналы. На рис. 5.16 каналы обозначены как L, R, Ls, Rs, С, LFE, что соответствует формату 5.1. Сигналы первых двух каналов L и R обрабатываются плагином (входят в прямоугольник и выходят из него). Сигналы остальных четырех каналов обходят прямоугольник стороной. Допустим, вы хотите подвергнуть обработке плагином сигнал канала С. "Схватите" мышью символ, обозначающий выход плагина (рис. 5.17, а), и тащите его к линии, символизирующей канал С (рис. 5.17, б). Потом схватитесь за символ, обозначающий вход плагина (рис. 5.17, в), и тоже перетаскивайте его к каналу С (рис. 5.17, г).
В результате описанных действий плагином будут обрабатываться сигналы каналов L и С. Аналогичным образом осуществляется коммутация входов/выходов многоканальных плагинов. Вся разница в том, что у многоканальных плагинов может быть больше входов и/или выходов, чем 2.
Единственное, что в январе 2003 года, когда пишутся эти строки, осталось добавить ко всему вышесказанному: мы с нетерпением ждем выхода новых версий Cubase SX с расширенной поддержкой многоканальных эффектов и новых многоканальных плагинов хороших и разных.


Глава 6. Подробно о работе с MIDI

    • Подробно о работе с MIDI
    • 6.1. Подготовка к работе с MlDI-данными
    • 6.1.1. Выбор параметров отображения MIDl-сообщений
    • 6.1.2. Выбор опций записи и воспроизведения MIDl-сообщений
    • 6.1.3. Выбор параметров MIDI-функций
    • 6.1.4. Выбор параметров функции Chase
    • 6.2. Работа в редакторе List Editor
    • 6.2.1. Назначение секций окна редактора List Editor
    • 6.2.2. Инструменты окна List Editor, редактирование сообщений
    • Обзор инструментов окна List Editor
    • Управление отображением сообщений
    • Вставка новых сообщений
    • 6.2.3. Работа с сообщениями типа NRPN
    • 6.2.4. Работа с привилегированными системными сообщениями
    • 6.2.5. Редактирование нот с MIDI-клавиатуры
    • 6.2.6. Пошаговый ввод нот
    • 6.3. Работа в редакторе Key Editor
    • 6.3.1. Инструменты окна Key Editor
    • 6.3.2. Секция отпечатков клавиш
    • 6.3.3. Секция графического редактирования параметров MIDI-сообщений
    • 6.4. Работа в редакторе Drum Editor
    • 6.4.1. Особенности инструментов редактора Drum Editor
    • 6.4.2. Редактирование партий ударных инструментов
    • 6.5. Работа в Logical Editor
    • 6.6. Применение квантизации
    • 6.6.1. Выбор параметров квантизации
    • 6.6.2. Суть различных алгоритмов квантизации
    • 6.7. Применение команд меню MIDI
    • 6.7.1 Transpose... — транспонирование выделенных MIDI-нот
    • 6.7.2. Merge MIDI in Loop — перезапись MIDI-сообщений с разных треков на один; применение MIDI-плагинов
    • 6.7.3. Dissolve Part — распределение сообщений с выделенной части по отдельным трекам
    • 6.7.4. O-Note Conversion — преобразование номеров нот в соответствии с Drum Map
    • 6.8. Применение функций, доступных из подменю MIDI > Functions
    • 6.8.1. Delete Notes... — удаление нот, имеющих заданные параметры
    • 6.8.2. Velocity... — преобразование значений параметра Velocity сообщений Note On


Подробно о работе с MIDI

В этой главе мы подробно рассмотрим все средства редактирования MIDI-сообщений, имеющиеся в Cubase SX. А их очень даже не мало. Как известно, в программу Cubase SX по наследству перешли лучшие находки, зарекомендовавшие себя в ее более ранних версиях. История развития и совершенствования продуктов, в имени которых присутствует слово "Cubase", началась с программного MIDI-секвенсора. Звук, аудиоэффекты и виртуальные инструменты появились в Cubase позже. Не удивительно, что MID1-составляющая программы доведена ее разработчиками до состояния, близкого к совершенству. В программе представлены все ставшие классическими способы численного и графического редактирования MIDI-данных, все мыслимые функции их обработки, масса интересных MIDI-эффектов.
Нам кажется уместным сказать здесь о том, что некоторые компьютерные музыканты не совсем верно понимают роль MIDI в работе над музыкальными композициями. Слово "MIDI" рядом со словом "музыка" часто употребляется в негативном и даже в ругательном смысле. Такие пользователи утверждают примерно следующее: "Музыка, записанная "вживую" с микрофона, в том числе с помощью программы-звукового редактора, — это высший класс. Музыка, полученная на основе добротных сэмплов, лупов и грувов все в том же звуковом редакторе, — это нормально. Музыка, исполняемая синтезатором звуковой карты под управлением MIDI-секвенсора, — примитив". Это неверно, прежде всего потому, что MIDI — всего лишь основа технологии записи, редактирования и воспроизведения команд, управляющих синтезатором. Качество звука определяется не секвенсором, а синтезатором. Да и качество самой музыки зависит не столько от MIDI-секвенсора, сколько от умения музыканта использовать его возможности. Ругать секвенсор так же бессмысленно, как и, например, сетовать, что песня не удалась, так как ее ноты вы записывали не гусиным пером, а шариковой ручкой. Справедливости ради скажем, что еще несколько лет назад действительно были основания критиковать компьютерную MIDI-музыку. Слишком велик был разрыв в качестве синтеза звуков мультимедийными картами и дорогими профессиональными музыкальными синтезаторами (хотя и те и другие управлялись и управляются по MIDI). Однако сейчас наступила эпоха бурного развития виртуальных синтезаторов, которые под управлением MIDI-секвенсора формируют звук, не уступающий по своим свойствам тому, что создается лучшими образцами реальных инструментов. Поэтому музыкант, недооценивающий MIDI, обречен на неудачу. Пожалуй, можно считать, что MIDI ныне переживает второе рождение. Конечно, рамки стандарта, созданного почти четверть века назад, стали тесноватыми. Это ведет к тому, что MIDI-технология развивается. Кроме того, зарождаются более совершенные технологии управления музыкальными инструментами и студийным оборудованием, в основе которых, однако, все равно лежат принципы, апробированные в MIDI.
Итак, приступим к изучению тех возможностей записи и редактирования MIDI-сообщений, которые таятся в Cubase SX.
И начнем с того, что подготовим программу к работе с MIDI-данными, причем сделаем это более тщательно и детально, чем при подготовке к выполнению элементарных операций на начальном уровне, описанных в разд. 1.13.


6.1. Подготовка к работе с MIDI-данными

Подготовка к работе с MIDI-данными включает в себя довольно большое количество операций. В предыдущих главах мы уже рассмотрели многие из них:

  • подключение к звуковой карте MIDI—клавиатуры или MIDI-синтезатора (разд. 1.1);
  • настройка MIDI-портов (разд. 2.2);
  • настройка параметров проекта (разд. 2.9);
  • загрузка файла с проектом, открытие и закрытие проекта, сохранение проекта (разд. 1.13);
  • настройка метронома (разд. 2.8);
  • описание MIDI-усгройств, подключенных к компьютеру (разд. 2.1);
  • загрузка банков SoundFont (разд. 2.4);
  • импорт MIDI-файлов и файлов в форматах предыдущих версий Cubase (разд. 1.13);
  • выбор параметров фильтрации MIDI-сообщений, поступающих через входные MIDI-порты (разд. 2.2);
  • подготовка MIDI-треков к записи и осуществление записи (глава 4).

Осталось познакомить вас лишь с несколькими операциями из числа тех, которые есть смысл проводить до начала работы с MIDI-проектом, и среди них:

  • выбор параметров отображения MIDl-сообшений;
  • выбор опций записи и воспроизведения MIDI-сообщений;
  • выбор параметров MIDI-функций;
  • выбор параметров функции Chase.


6.1.1. Выбор параметров отображения MIDI-сообщений

Командой главного меню File > Preferences откройте окно Preferences и в левой части окна выберите раздел Event Display - MIDI. В правой части окна будут доступны опции управления отображением MIDI-сообщений (рис. 6.1).

Рис. 6.1.Диалоговое окно Preferences (раздел Event Display - MIDI)

В раскрывающемся списке Default Edit Action вы можете по своему вкусу выбрать тот MIDI-редактор, который будет открываться двойным щелчком левой кнопки мыши на части, находящейся на MlDI-треке в окне проекта. По умолчанию будет открываться Key Editor, который, и в самом деле, используется чаще остальных редакторов (List Editor, Logical Editor, Drum Editor).
Раскрывающийся список Part Data Mode позволяет выбрать форму отображения сообщений типа Note на MIDI-треке в окне проекта:

  • No Data — не отображать никак;
  • Lines — отображать в виде горизонтальных линий, длина которых пропорциональна длительности ноты;
  • Scores — отображать в виде символов нот (без признаков длительности);
  • Drums — отображать в виде символов, принятых для записи партий ударных инструментов.

Если установлен флажок Show Controllers, то кроме сообщений типа Note в частях на MIDI-треках в окне проекта будут отображаться также и другие сообщения (например, типа Controller) в виде вертикальных линий, высота которых пропорциональна значению параметра контроллера.
Если установлен флажок Edit as Drums when Drum Map is assigned, то в частях на MIDI-треках, которые ассоциированы с барабанными картами, сообщения типа Note будут отображаться в виде символов, принятых для записи партий ударных инструментов. Кроме того, двойным щелчком на такой части будет открываться окно Drum Editor (независимо от того, какой редактор выбран в раскрывающемся списке Default Edit Action).
В раскрывающемся списке Note Name Style вы можете выбрать систему обозначения нот, которая будет использоваться при их отображении в окнах редакторов:

  • MIDI — символами А, В, С, D, E, F, G и # в сочетании с обозначением номера MlDI-октавы (от -2 до 8);
  • MIDI and Value — кроме символов, характерных для предыдущего варианта, будут отображаться также номера MIDI-ног (от 0 до 127);
  • DoReMi — в виде слоговых обозначений нот (Do, Re, Mi, Fa, Sol, La, Si и #) в сочетании с обозначением номера MIDI-октавы;
  • Classic — символами А, В, С, D, E, F, G и # (для MIDI-октав с —2 по 1), причем октава обозначается количеством штрихов в нижнем индексе (для MIDI-октав с —2 по 0); символами а, Ь, с, d, e, f, g и # (для MIDI-октав со 2 по 8), причем октава обозначается количеством штрихов в верхнем индексе (для MIDI-октав с 3 по 8);
  • Classic (German) — обозначения аналогичны предусмотренным в варианте Classic за одним исключением: вместо символа альтерации # (диез) к символу, обозначающему ноту, добавляется окончание is. Например, Cis — до-диез первой октавы, dis — ре-диез второй октавы (в системе нумерации Cubase SX).


6.1.2. Выбор опций записи и воспроизведения MIDI-сообщений

Командой главного меню File > Preferences откройте окно Preferences и в левой части окна выберите раздел MIDI. В правой части окна будут доступны опции записи и воспроизведения MlDI-сообщений (рис. 6.2).

Рис. 6.2. Диалоговое окно Preferences (раздел MIDI)

Если установлен флажок Snap Record Parts to Bars, то любая MIDI-часть, полученная в результате записи, будет автоматически удлиняться таким образом, чтобы она оканчивалась точно на границе со следующим тактом. Это делает более удобным дальнейшее редактирование (например, копирование и перемещение частей).
При установленном флажке MIDI Thru Active автоматически будет обеспечен мониторинг записываемого MIDI-трека. В результате вы будете слышать то, что играете на MIDI-клавиатуре (подробнее о мониторинге читайте в разд. 2.7). Если между клавиатурой и звуковой картой связь по MIDI установлена в обоих направлениях, то для предотвращения самовозбуждения MIDI-системы вы должны на MIDI-клавиатуре выбрать режим "Local Off (подробнее о проблеме самовозбуждения MIDI-системы см. в разд. 1.1).
При установленном флажке Reset on Record End no окончании записи Cubase SX будет посылать синтезатору сообщение Reset о сбросе его установок в состояние, предусмотренное по умолчанию. Если установлен флажок Reset on Part End, то сообщение Reset будет формироваться в процессе воспроизведения по окончании каждой очередной части. При установленном флажке Reset on Stop сообщение Reset будет формироваться при остановке записи или воспроизведения. Эти опции могут быть полезными для того, чтобы в следующих сеансах записи или воспроизведения не сохранялись те установки параметров синтеза, которые использовались ранее.
Если установлен флажок "Note On" Priority, то сообщения о нажатии клавиш (Note On) приобретают приоритет по отношению к любым другим MIDI-сообщениям. Это может быть существенно в том случае, когда MIDI-интерфейс оказывается перегруженным сообщениями, так как обеспечивается гарантированная передача сообщений наиболее важного типа. Это означает, что если из-за перегрузки какие-то сообщения не удается передать, то программа пожертвует любым другим сообщением, но только не тем, в котором содержится информация о нажатии клавиши. Действительно, какой смысл в том, что синтезатор получит сообщение, например, об изменении высоты звука на несколько центов, если команда о начале формирования самого звука к нему не попадет?
В поле ввода Length Correction вы можете в тиках выбрать интервал времени, которым должно быть отделено начало следующей ноты от окончания предыдущей. Наличие такого интервала необходимо для корректного управления по одному и тому же MIDl-каналу формированием нот, имеющих одинаковые номера.
Предположим, что идет запись одновременно на несколько MIDI-треков, а вы в это время открыли часть для ее редактирования в каком-либо из MIDl-редакторов. Если установлен флажок Solo Record in Editors, то в подобной ситуации режим записи сохранится только для того трека, на котором находится редактируемая часть. Разработчики считают, что так удобнее.
В поле ввода Record Catch Range in ms вы можете в миллисекундах выбрать интервал времени опережения фактического включения режима записи по отношению к моменту, соответствующему положению левого локатора. Это позволяет избежать досадных случаев пропуска записи первой ноты, которые могут происходить из-за того, что вы сыграли ее чуть раньше, чем указатель текущей позиции достиг левого локатора.


6.1.3. Выбор параметров MIDI-функций

Командой главного меню File > Preferences откройте окно Preferences и в левой части окна выберите секцию MIDI — Functions Parameters. В правой части окна будут доступны две опции управления отображением MIDI-сообщений.
В поле ввода Legato Overlap производится настройка функции Legato (команда главного меню MIDI > Legato). Если Legato Overlap = 0, то после применения функции Legato к выделенным нотам окончание каждой предыдущей ноты будет точно совпадать с началом следующей. Если Legato Overlap > 0, то ноты будут перекрываться. Интервал перекрытия (в тиках) будет равен числу, введенному в поле Legato Overlap. При Legato Overlap < 0 между нотами будет оставлен соответствующий промежуток.
От состояния флажка Split MIDI events зависит результат применения функции Split в окне проекта в тех случаях, когда место разрезания части приходится не на промежуток между нотами, а на саму ноту. При установленном флажке нота будет разрезана на две более короткие. Одна из вновь образованных нот окажется в предшествующей (левой) части, а вторая — в последующей (правой) части. Если флажок сброшен, нота останется только в левой части, причем ее длительность будет сокращена (у звука будет отрезан и удален "хвост").


6.1.4. Выбор параметров функции Chase

Начнем с того, что напомним назначение функции Chase, с которой вы впервые встретились в разд. 4.4.2. В частях на MIDI-треках записаны, как правило, не только сообщения о нажатии на MIDI-клавиши, но и сообщения других типов. Это могут быть, например, сообщения об изменении различных параметров синтеза, о смене MIDI-инструмента и т. д. Если воспроизведение происходит с самого начала трека, то все сообщения последовательно считываются с трека и посылаются синтезатору. Все в порядке. А что будет, если воспроизведение стартует не с начала трека? Некоторые сообщения будут пропущены, останутся "за бортом". Синтезатор даже и "не узнает", что они записаны где-то там на треке в частях, которые не были воспроизведены. Получится, что музыка будет воспроизводиться совсем не тем инструментом, совсем не с теми громкостью, панорамой и реверберации, что были задуманы вами. Так вот, чтобы такого не случалось, в Cubase SX и предусмотрена функция Chase.
Ее суть заключается в том, что сразу же после включения режима записи или воспроизведения программа учтет все MlDl-сообщения, заключенные между началом трека и позицией старта.
В секции MIDI — Chase Events Filter диалогового окна Preferences (рис. 6.3), вызываемого командой File > Preferences, можно выбрать те типы MIDI-сообщений, которые не будут учитываться функцией Chase.
Напомним смысл типов сообщений, перечисленных в секции MIDI - Chase Events Filter:

  • Note — сообщения о нажатии MIDI-клавиш;
  • Poly Pressure — давление на отдельные нажатые клавиши;
  • Controller — сообщения об изменениях значений контроллеров;
  • Program Change — смена инструмента;
  • Aftertouch — усредненное давление на нажатые клавиши в одном MIDI-канале;
  • Pitchbend — сдвиг высоты тона;
  • Sysex — привилегированные системные сообщения.

Рис. 6.3. Диалоговое окно Preferences (секция MIDI - Chase Events Filter)

Функцией Chase не будут восприниматься сообщения тех типов, для которых установлены флажки.
Приведем пример. Допустим, что для некоторого трека в основной секции инспектора выбран инструмент Harmonica. Пусть при этом в части на треке записано сообщение о смене MIDI-инструмента: в начале 32-го такта выбран инструмент Viola. Вы мышью переместили указатель текущей позиции в 33-й такт и включили воспроизведение. Если флажок Program Change установлен, то вы услышите губную гармонику (сообщение о смене инструмента не будет воспринято программой), а если флажок сброшен — скрипку.
После завершения подготовки программы можно переходить непосредственно к записи и редактированию MIDI-сообщений. В Cubase SX есть несколько редакторов, позволяющих работать с MIDI-данными, представленными в самых различных формах (см. разд. 1.7). Пожалуй, есть смысл начать с того редактора, в котором вы можете работать непосредственно с MIDI-сообщениями. Вам понадобится умение ориентироваться в MIDI-сообшениях различных типов, поэтому нелишним будет освежить в памяти содержание разд. 1.2.


6.2. Работа в редакторе List Editor

List Editor относится к наиболее важным редакторам программы. В принципе, практически все, на что способна программа Cubase SX в части работы с MIDI-сообщениями, можно реализовать в этом редакторе, хотя сделать это будет не всегда легко. Информация в окне List Editor отображается в форме, наиболее близкой к форме представления информации в MIDI-системе — в виде сообщений (с параметрами), привязанных к определен-*ным моментам времени и относящихся к конкретному треку.
Командой главного меню MIDI > Open List Editor откройте окно редактора List Editor (рис. 6.4). Команды вызова этого и остальных MIDI-редакторов доступны лишь в том случае, когда в окне проекта выделена хотя бы одна часть. Если выделены несколько частей, то в окне редактора отображаются сообщения той части, которая расположена ближе к началу трека.

Рис. 6.4. Окно редактора List Editor


6.2.1. Назначение секций окна редактора List Editor

Давайте осмотримся. Основное пространство окно редактора List Editor пo вертикали поделено на три секции:

  • левая секция — список сообщений (List), предназначенный для численного отображения и редактирования параметров сообщений;
  • средняя секция — графический дисплей (Event Display), предназначенный для отображения и графического редактирования сообщений;
  • правая секция — столбец Value (Value Display), предназначенный для графического редактирования некоторых параметров сообщений.

В левой секции окна List Editor находится таблица — список всех MIDI-сообщений в выделенной части, записанных подряд так, как они реально расположены в файле. Исключение составляют только MIDI-сообщения Note Off (формируются MIDI-клавиатурой, когда вы отпускаете нажатую клавишу). Для удобства просмотра непосредственно они не выводятся на экран, зато у MIDI-сообщений Note On (нажатие на клавишу), обозначенных в списке как Note, присутствует такой параметр, как End (время окончания звучания ноты).
Каждое сообщение (Event) занимает в списке одну строчку и, по существу, представляет собой указание, которое должен выполнить музыкальный синтезатор в определенный момент. Каждая строка в списке соответствует какому-либо сообщению (событию). Все события привязаны ко времени. Чем раньше наступает событие, тем выше в списке находится строка.
В списке отображаются сообщения, содержащиеся в той части, которую вы выделили в окне проекта. Если в части много сообщений, то не все из них одновременно доступны для просмотра и редактирования. Вывести на экран любой фрагмент списка можно с помощью вертикальной полосы прокрутки.
Возможность просмотра всех MIDI-сообшений подряд в одном списке оказывается полезной в тех ситуациях, когда не удается другими способами найти ошибку (лишнее или неправильное MIDI-сообщение).
Список всех MIDI-сообщений выводится в девять столбцов. Вы можете менять расположение столбцов, перетаскивая мышью их заголовки. Далее мы рассмотрим столбцы в том порядке, в котором они размещаются по умолчанию.
В первом из них, обозначенном как L, отображается перемещение указателя текущей позиции при воспроизведении: стрелочка указывает на то сообщение, которое в данный момент воспроизводится (или на котором воспроиз-"ведение было остановлено). Для того чтобы переместить эту стрелочку, воспользуйтесь клавишами <+> или <->.
Строку списка можно выделить щелчком на любом ее месте. Если на панели инструментов нажата кнопка [image] , а в выделенной строке записана нота, то вы услышите ее звучание. Пошаговое прослушивание в прямом направлении производится с помощью клавиши <вниз> (происходит движение вниз по списку), в обратном — клавиши <вверх> (происходит движение вверх по списку).
Во втором столбце (Туре) указывается тип сообщения (Note, Program Change, Controller и т. д.).
В третьем столбце (Start) указывается позиция MIDI-события в партии в формате такт.доля.часть доли.тик (см. разд. 113.5). Для сообщения Note в четвертом столбце (End) в том же формате указывается время окончания звучания ноты, а в пятом столбце (Length) ее длительность.
В шестом столбце (Data 1) отображается первый байт значения сообщения. Для сообщений Note — это высота тона в формате, выбранном в окне Preferences (см. разд. 6.1). Для сообщений Controller — это номер контроллера или его имя, для Program Change — номер программы (тембра, MIDI-инструмента, патча), для Aftertouch — значение силы давления на клавишу. Для Pitchbend — значение первого байта, соответствующего грубой настройке высоты.
В седьмом столбце (Data 2) отображается второй байт значения сообщения. Для сообщений Note — это Velocity. Для сообщений Controller — это значение контроллера. Для сообщений других типов значение в этом столбце отсутствует.
В восьмом столбце (Comment) могут содержаться текстовые комментарии, например, пометки, позволяющие легче ориентироваться в списке сообщений, или любые сведения, которые автор композиции пожелает сообщить пользователям.
В девятом столбце (Channel) отображается номер MIDI-канала, с которым ассоциировано данное сообщение. В Cubase SX этот номер канала имеет значение, только если весь MIDI-трек направлен в канал ANY (в инспекторе окна проекта). В противном случае MIDI-сообшения трека выводятся в MIDI-канал, указанный в окне проекта, а значения номеров каналов, содержащиеся в MIDI-сообщениях, игнорируются.
Редактирование содержания таблицы производится с клавиатуры компьютера или мышью с помощью меню и полей ввода. Щелкнув на любом MIDI-сообщении, вы его выделите. Двойной щелчок на любом параметре позволяет редактировать его значение. Нельзя изменять только значения в столбце Туре, а также в пустых полях. Поочередными щелчками на MIDI-сообщениях с одновременным удержанием клавиши <Shift> можно выделить несколько MIDI-сообщений. Далее к ним можно применить какую-либо функцию. Их можно удалить с помощью клавиши <Delete>, а также команды Edit > Delete главного или контекстного меню.
В средней секции окна List Editor расположена секция графического редактирования сообщений. По горизонтали здесь отложены такты и их доли, а по вертикали — позиция в списке. Поскольку в списке все события расположены последовательно, в графической части редактора они располагаются "лесенкой". Здесь с помощью инструмента [image] (Draw) редактируются существующие и записываются новые сообщения, а нежелательные сообщения удаляются с помощью инструмента [image] (Erase). Применимы также и другие инструменты, о которых мы расскажем чуть позже.
В правой секции окна List Editor располагается столбец Value (Value Display), который предназначен для графического редактирования некоторых параметров сообщений. Для сообщений Note — это Velocity. Для сообщений Controller — это значение контроллера, для Program Change — номер программы (тембра, MIDI-инструмента, патча), для Aftertouch — значение силы давления на клавишу. Для Pitchbend — значение первого байта, соответствующего грубой настройке высоты.
Регулируемый параметр отображается в виде горизонтально расположенных столбиков. Длина столбика пропорциональна величине параметра. Каждый столбик, по сути дела, служит элементом регулировки. Для того чтобы помочь пользователю быстрее сориентироваться, регуляторы Velocity выделены черным цветом, а остальных параметров — серым. Из всех инструментов, имеющихся в окне List Editor, здесь фактически действует только [image] (Draw). He случайно при перемещении в правую секцию окна редактора курсор мыши приобретает форму карандаша. Щелкнув на столбике, его можно укоротить, уменьшив тем самым величину соответствующего параметра. А если ухватиться за столбик мышью и перемещать ее влево-вправо, то вы получите в свое распоряжение плавный регулятор. Чтобы перейти к редактированию соседних параметров, не обязательно отпускать кнопку мыши.
Обратите внимание на то, что при изменении длины столбика одновременно будет изменяться число в ячейке одного из столбцов левой секции (Data 1 или Data 2), а также цвет прямоугольника, отображающего соответствующее сообщение в средней секции окна редактора.
С назначением правой секции окна редактора вы теперь, вероятно, разобрались. Давайте сравним роли левой (список сообщений List) и средней (Event Display) секций окна List Editor. С одной стороны, они частично дублируют друг друга: в обеих можно изменять время поступления и длительность сообщения типа Note. Правда, в левой секции это делается численным способом (а значит, и с высокой точностью), а в правой — графическим (следовательно, приближенно). Но не в этом состоит самое главное отличие. Принципиально другое. В левой секции можно отредактировать любые параметры любого сообщения и удалить его, но нельзя вставить новое сообщение. Сделать это можно, только работая в средней секции.
До сих пор мы занимались только тем, что учились ориентироваться в пределах окна List Editor, теперь настало время научиться работать в нем.


6.2.2. Инструменты окна List Editor, редактирование сообщений

В настоящем разделе мы познакомимся с инструментами окна List Editor, подробнее остановимся на некоторых приемах, позволяющих более эффективно использовать возможности List Editor. Речь пойдет о поиске сообщений определенного типа, методике вставки новых сообщений, работе с сообщениями типа NRPN и SysEx, редактировании нот с MIDI-клавиатуры, пошаговом вводе нот.


Обзор инструментов окна List Editor

Инструменты окна List Editor располагаются в его верхней части. Среди них есть кнопки, раскрывающиеся списки и одно поле ввода (рис. 6.5).

Рис. 6.5. Инструменты окна List Editor

Рассмотрим назначение инструментов окна List Editor.
(Solo Editor) — кнопка включения режима "Соло" для части, редактируемой в окне List Editor. Иными словами, работая с каким-то треком, вы можете слушать только его, а звук остальных треков отключить. Кнопка не связана с аналогичными инструментами, находящимися в окне проекта (например, в основной секции инспектора трека). После закрытия окна List Editor режим "Соло", включенный в нем, автоматически отменяется.
(Object Selection) — кнопка выделения объектов в левой и средней секциях окна List Editor. Пользуясь ею, можно выделить как отдельное сообщение, так и целую группу сообщений. Для этого в левой секции окна достаточно нажать левую кнопку мыши и провести ее курсором по нескольким строкам списка. В средней секции нужно "нарисовать" пунктирный прямоугольник, охватывающий выделяемые объекты.
(Draw) — основной инструмент, с помощью которого в окне производится вставка сообщений и редактирование их параметров.
(Erase) — инструмент удаления сообщений.
(Zoom) — инструмент изменения масштаба отображения по горизонтали (в средней секции окна). При его применении в сочетании с нажатой клавишей <Alt> изображение уменьшается, без клавиши <Alt> — увеличивается.
(Mute) — инструмент мьютирования (заглушения) отдельного сообщения или целой группы сообщений (действует в средней секции окна). Заглушенные сообщения не удаляются из части, однако при воспроизведении они игнорируются.
(Autoscroll) — кнопка включения режима автоматической прокрутки по вертикали изображения в окне в режиме записи или воспроизведения. Если кнопка нажата, то на экране всегда видно сообщение, которое воспроизводится в данный момент. Кнопка доступна, если выключен режим пошагового ввода, т. е. не нажата кнопка [image] (Step Input). Далее идут:

  • раскрывающийся список Insert, предназначенный для выбора типа вставляемого сообщения;
  • поле Mouse Position, в котором отображается позиция курсора мыши при условии что он находится в пределах средней секции окна. Если нажата кнопка [image] (Step Input), то на месте Mouse Position появляется поле ввода Insert Position, в котором отображается и может быть отредактирована позиция вставки сообщения;
  • кнопка [image] (Snap), предназначенная для включения режима привязки вставляемых сообщений к долям тактов;
  • раскрывающийся список Quantize, предназначенный для выбора шага квантизации, с которым располагаются вставляемые сообщения;
  • раскрывающийся список Length Quant., предназначенный для выбора шага квантизации длительности сообщений;
  • раскрывающийся список Mask и кнопка [image] позволяющие выбирать сообщения, отображаемые в окне List Editor;
  • раскрывающийся список Colors, предназначенный для выбора цветовой гаммы отображения параметров сообщений;
  • кнопка [image] (Auto Play), предназначенная для включения режима прослушивания звучания нот при выборе в левой секции окна сообщений типа Note.

В левой части панели инструментов расположены еще 6 кнопок (на рис. 6.5 видно, что 4 из них недоступны), с ними мы познакомим вас несколько позже.


Управление отображением сообщений

В части может содержаться очень много сообщений. Если все они будут отображаться в окне List Editor, то поиск нужного сообщения может стать очень утомительной работой, требующей концентрации внимания. Для того чтобы упростить поиск сообщений, некоторые из них можно временно скрыть. Для этого в окне List Editor есть специальные средства. Среди инструментов, расположенных в верхней области окна, найдите кнопку [image] (Chow/Hide Filter View). Нажав на нее, можно открыть (или, наоборот, скрыть) панель управления отображением сообщений различных типов (рис. 6.6).

Рис. 6.6. Панель управления отображением сообщений

Если не установлен ни один флажок, то в списке будут отображаться все сообщения, имеющиеся в выделенной части. Устанавливая тот или иной флажок, вы скроете сообщения определенных типов. Например, можно оставить видимыми на экране только сообщения типа Note или сообщения типа Program Change. Согласитесь, что работать только с определенной группой сообщений будет удобнее, чем со всеми сразу.
В окне List Editor предусмотрено еще одно средство выбора отображаемых сообщений: раскрывающийся список Mask. Как им пользоваться?
Выделите в списке окна List Editor MIDI-сообщение того типа, который вы хотите видеть на экране, и затем выберите в раскрывающемся списке Mask строку Event Types. В списке окна List Editor останутся только сообщения выбранного типа, а остальные будут скрыты от ваших глаз. Например, если вы выделили в списке, сообщение типа Note, то только сообщения этого типа и останутся на экране в результате применения функции Mask.
Если же в списке окна List Editor выбрать сообщение типа Controller, а в раскрывающемся списке Mask выбрать строку Controller and Event Types, то вы увидите только те сообщения, у которых с выбранным совпадает не только тип, но и значение Data 1. Например, если вы выбрали Controller — Sustain, то после применения Controller and Event Types в списке будут видны только контроллеры сустейн-педали.
Если в раскрывающемся списке Mask выбрать строку Event Channels, то в списке останутся только сообщения, ассоциированные с определенным MIDI-каналом.
Для того чтобы снова перейти в режим просмотра всех сообщений, нужно в раскрывающемся списке Mask выбрать строку Nothing.


Вставка новых сообщений

Теперь расскажем о том, как вставлять новые сообщения. Пусть в список, представленный на рис. 6.4, нужно вставить сообщение о смене MIDI-инструмента (программы). В начале трека выбран MIDI-инструмент Acoustic Piano (в стандартном GM-банке — MIDI-инструмент № 1), а нам хочется, чтобы партию, записанную в части на этом треке, начиная с 17-го такта, исполнял MIDI-инструмент Electric Piano (в стандартном GM-банке — № 3).
Первым делом уберем с экрана все лишние сообщения, установив на панели управления отображением сообщений (см. рис. 6.5) все флажки, кроме единственного флажка Program Change. Картина существенно упростится. Теперь выберем инструмент вставки сообщений [image] (Draw) и в средней секции окна указатель текущей позиции поставим на начало 17-го такта (рис. 6.7).

Рис. 6.7. Пример редактируемого списка сообщений

В списке Insert, расположенном в верхней части окна среди других инструментов, выберем тип вставляемого сообщения (в данном случае Program Change). Наведем указатель мыши на начало 17-го такта, чуть ниже последней заполненной строки списка, и сделаем щелчок левой кнопкой мыши. В списке появится еще одна строка с сообщением .типа Program Change (рис. 6.8).

Рис. 6.8. Новое сообщение о смене MIDI-инструмента в списке окна List Editor

Посмотрим на плоды своих трудов. Во-первых, видно (поле в столбце Start), что сообщение вставлено не точно в позицию начала 17-го такта. Ошибка
при наведении курсора мыши на 17-й такт в средней секции окна составила в данном случае 76 тиков. Если это принципиально (когда, например, первая нота в семнадцатом такте звучит раньше), то щелкнем на поле тиков в ячейке Start и введем в него число 0.
Во-вторых, пока что смены инструмента не произошло: ведь вставленным оказался инструмент № 1. Щелкнем на ячейке столбца Data 1 и вместо числа 1 с клавиатуры введем в нее 3 (можно также воспользоваться клавишами <вверх> и <вниз>). Вот теперь, наконец-то, дело сделано. Смена инструмента завершена (рис. 6.9).

Рис. 6.9. Смена MIDI-инструмента в списке окна List Editor завершена

Заметим, что установка сообщений точно в начало доли такта в средней зоне окна возможна, если на панели инструментов нажата кнопка [image] (Snap). Шаг сетки, к которой будут привязаны вставляемые сообщения, выбирается в раскрывающемся списке Quantize.
В списке Length Quant, выбирают дискретные значения длительности вставляемых сообщений типа Note.
Методика записи и редактирования сообщений других типов аналогична рассмотренной.


6.2.3. Работа с сообщениями типа N RPN

В документации на звуковые карты сведения о нерегистрируемых параметрах (NRPN), как правило, приводятся в виде таблиц, в которых содержатся значения младшего и старшего байтов номеров NRPN. В Cubase SX они (LSB и MSB) также вводятся раздельно.
Значения LSB и MSB в документации на звуковые карты приводятся в шестнадцатеричной системе счисления, а в окне List Editor значения параметров этих сообщений необходимо указывать в десятичной. Поэтому, чтобы ввести в программу номер NRPN, значения его старшего и младшего байтов необходимо перевести в десятичную систему счисления. Для этого откройте инженерный калькулятор из набора стандартных программ Windows и выберите шестнадцатеричную систему счисления (опцией Hex). Введите значение NRPN LSB и поменяйте систему счисления на десятичную (опцией Dec). Калькулятор покажет десятичное значение NRPN LSB. Таким же образом получите десятичное значение NRPN MSB.
Рассмотрим пример. В синтезаторах, поддерживающих MlDI-специ-фикацию XG, предусмотрена возможность управления частотой среза фильтра — параметром Filter Cutoff Frequency — посредством NRPN, у которого LSB = 20h и MSB = Olh. Символ h означает шестнадцатеричную систему счисления. С помощью калькулятора получим десятичные значения: Ь8В = 32и MSB = 01.
Для ввода NRPN LSB предназначен контроллер № 98, а для ввода NRPN MSB — контроллер № 99. Для ввода старшего байта (MSB) значения NRPN служит контроллер № 6 (Data Entry MSB). Младший байт (LSB) значения NRPN нам не понадобится, так как для XG-совместимых MIDI-устройств он по умолчанию равен нулю.
Допустим, вы хотите установить максимальную частоту среза фильтра (десятичное значение 127). Для этого в окне List Editor вы должны вставить три сообщения типа Controller, в ячейках столбцов Data 1 выбрать имена контроллеров NRPN MSB, NRPN LSB и DataEnt MSB, а в ячейках столбцов Data 2 ввести значения контроллеров: 32, 1 и 127 (рис. 6.10).

Рис. 6.10. Пример использования сообщений NRPN

Следует заметить, что целью описанного выше примера является иллюстрация принципа работы с NRPN. На практике применять NRPN для управления синтезаторами, совместимыми с XG, особого смысла нет (вы легко сможете найти очень удобные графические редакторы), а управление частотой среза проще осуществлять с помощью контроллера № 74. Тем не менее, существуют синтезаторы, у которых "достучаться" до большинства параметров синтеза можно только посредством NRPN, например, синтезаторы широко известных звуковых карт SB Live!.


6.2.4. Работа с привилегированными системными сообщениями

Вероятно, вы уже заметили, что в раскрывающемся списке Insert есть строка SysEx, это означает, что в окне List Editor можно создавать и редактировать привилегированные системные MIDI-сообщения (SysEx — System Exclusive Message).
Управление большинством скрытых ресурсов MIDI-синтезаторов осуществляется посредством системных сообщений. С помощью системных сообщений можно управлять, например, параметрами эффект-процессора, осуществлять доступ к ячейкам памяти синтезатора, в которых хранятся те или иные параметры синтеза, загружать в память синтезатора установки патчей и т. п.
Системные сообщения представляют собой последовательность двузначных шестнадцатеричных чисел (одно такое число соответствует байту). Каждое системное сообщение начинается с числа F0 — идентификатора начала системного сообщения. Затем следует идентификатор устройства (фирмы-производителя этого устройства) или устройства, с которым совместим данный синтезатор. Например, синтезаторы фирмы Yamaha кодируются числом 43, фирмы Roland — 41, EMU — 18. После идентификатора следует последовательность кодов, длина и формат которой определяется моделью синтезатора (устанавливается производителем) и типом передаваемых сообщений. Завершается системное сообщение всегда числом F7 — идентификатором конца системного сообщения (ЕОХ — End Of eXclusive).
О том, какие системные сообщения "понимает" ваш синтезатор, можно узнать из его технического описания. Как правило, эти сведения приводятся в виде таблицы, содержащей тип системного сообщения, его формат и назначение отдельных байтов. Например, сведения о поддерживаемых синтезаторами стандарта XG системных сообщениях могут выглядеть следующим образом:

11110000 F0 Exclusive status
01000011 43 YAMAHA ID
00010001 In Device Number
01001100 4C XG Model ID
0aaaaaaa aa Address High
0aaaaaaa aa Address Mid
Qaaaaaaa aa Address Low
0dddddd dd Data
11110111 F7 End of Exclusive
В первом столбце содержатся двоичные коды системных сообщений, во втором — их шестнадцатеричные коды. Прописными (большими) буквами обозначаются шестнадцатеричные цифры от А до F, а строчными (маленькими) — переменные. В приведенном примере пппп — номер устройства (синтезатора), которому адресовано сообщение; аа — адрес одной или нескольких ячеек памяти синтезатора, содержащих параметр, значение которого нужно изменить. В данном случае для передачи адреса используется три сегмента: старший (High), средний (Mid) и младший (Low) байты. Переменные dd — это данные, которые необходимо записать в память по указанному адресу. В правом столбце приведены сведения о назначении байта. Конкретные значения переменных в системных сообщениях следует искать в других таблицах, которые, в свою очередь, могут содержать ссылки на следующие таблицы. Разобраться с этими таблицами не так-то просто, но можно, если захотеть. Чтобы, например, для звуковой карты, поддерживающей спецификацию XG, выбрать реверберацию типа Tunel (звук, как в тоннеле), последовательность системных сообщений должна выглядеть так: F0 43 10 4С 02 01 00 11 00 F7. О применении системных сообщений для смены типа эффекта в некоторых звуковых картах мы подробно рассказали в книгах [6, 9, 11, 46]. Наиболее распространенное применение системных сообщений — передача синтезатору команды сброса в исходное состояние.
Итак, если вы хотите получить доступ ко всем без исключения ресурсам синтезатора, без редактора системных сообщений SysEx вам не обойтись. Как добраться до такого редактора в Cubase SX? Сейчас мы вам об этом расскажем на примере записи сообщения о системном сбросе синтезатора, соответствующего спецификации GM. Оно необходимо для того, чтобы привести систему управления синтезатора в правильное исходное состояние. Подобное сообщение желательно вставлять в начале каждого проекта в часть на один из его MIDI-треков. Слово "подобное" означает здесь то, что сообщение о сбросе должно соответствовать стандарту, который поддерживается синтезатором. Конкретно, следует формировать следующие сообщения:
  • Для GM-синтезатора - F0 7E 7F 09 01 F7;
  • Для ХС-синтезатора - FO 43 10 4С 00 00 7Е 00 F7;
  • Для GS-синтезатора — F0 41 10 42 12 40 00 7F 00 41 F7.

В раскрывающемся списке Insert выберите строку SysEx и известным вам способом вставьте в начало списка сообщение типа SysEx (рис. 6.11).
Сообщение типа SysEx вставлено, но оно пока пусто (содержит только признаки начала и конца SysEx). Обратите внимание на ячейку в столбце Comment, именно там отображается содержание сообщения, в данном случае символы F0,F7. Щелкните на этой ячейке для того, чтобы открыть окно редактора системных сообщений MIDI-Sysex-Editor (рис. 6.12).

Рис. 6.11. В список вставлено сообщение типа SysEx

Рис. 6.12. Окно MIDI-Sysex-Editor

Сообщение может быть очень длинным, тогда оно займет много строк. Чтобы легче было в строках ориентироваться, по мере ввода байтов сообщения они автоматически нумеруются: в столбце Address приводится шестнадцате-ричный номер первого байта в строке. Для сведения в правом столбце (ASCII) приводится содержание каждой строки сообщения, отображенное в виде символов, соответствующих ASCII-кодировке. Это всё вспомогательные элементы окна. Главное здесь столбцы 1 — 7 и инструменты записи байтов. Напомним, что мы собираемся сформировать следующее содержание сообщения: F0 7E 7F 09 01 F7 (здесь все числа шестнадцатеричные).
Начальный и конечный байты уже введены (удалить их невозможно). Для ввода нового байта первым делом нажмите кнопку Insert. Строка удлинится на одну позицию, в которой пока будет записаны два нуля. Щелчком на этой позиции сделайте ее доступной для ввода и с клавиатуры введите 01. Дело в том, что последовательность вводится в обратном порядке, и сейчас для ввода доступно содержание предпоследнего байта. Затем опять нажмите кнопку Insert и введите 09. Повторяйте так, пока не введете все содержание сообщения (рис. 6.13).

Рис. 6.13. Введено содержание сообщения о сбросе GM-синтезатора

Если содержание сообщения в руководстве пользователя представлено в десятеричной или двоичной системах счисления — не беда. В окно редактора системных сообщений MIDI-Sysex-Editor встроен калькулятор. Он позволяет вам в поле Binary вводить двоичное число, которое после нажатия клавиши <Enter> программа автоматически преобразует в десятичное (поле Decimal) и введет в ту позицию на рабочем поле окна, которая в данный момент выделена зеленой рамкой. Аналогичным образом будет обстоять дело, если начать с ввода десятичного числа в поле Decimal. Оно будет преобразовано и в двоичную и в шестнадцатеричную формы. Калькулятор "умеет считать" до десятичного числа 127, а большего от него и не требуется. Введенную последовательность байтов есть смысл сохранить в файле с расширением SYX, воспользовавшись кнопкой Export. В Internet можно разыскать "готовые к употреблению" банки системных сообщений и загрузить их в свой синтезатор. Для этого служит кнопка Import.
После проверки и исправления (при необходимости) введенной последовательности байтов нажмите ОК. Содержание SysEx появится в столбце Comment окна List Editor (рис. 6.14).

Рис. 6.14. В списке появилось сообщения о сбросе GM-синтезатора


6.2.5. Редактирование нот с MIDI-клавиатуры

Всем хороши описанные выше способы редактирования MIDI-сообщений в окне List Editor. Но есть одно неудобство: пользуясь ими, трудно передать ощущение, присущее реальной игре на инструменте. Нота разложена на некие математические составляющие. И не каждый музыкант сможет научиться быстро оценивать влияние того или иного редактируемого параметра на звучание, получающееся в итоге всех манипуляций с кнопками и полями ввода. Хорошо бы иметь возможность вместо этого просто сыграть необходимую ноту с необходимой громкостью! И, конечно, в программе Cubase SX предусмотрена такая функция. Она включается кнопкой [image] (MIDI Input). Панель инструментов после этого несколько меняет свой вид (рис. 6.15). Становятся доступны кнопки, расположенные в ее правой области (сравните с рис. 6.5).

Рис. 6.15. Инструменты окна List Editor в режиме редактирования с MIDI-клавиатуры

Параметры сообщения, которые будут восприниматься редактором при нажатии вами MlDI-клавиш, выбираются специальными кнопками.
(Record Pitch) — будет записываться номер MIDI-ноты.
(Record NoteOn Velocity) — будет записываться Velocity сообщения Note On (скорость перемещения клавиши при ее нажатии, которую можно считать пропорционально связанной с громкостью звучания ноты).
(Record NoteOfF Velocity) — будет записываться Velocity сообщения Note Off (скорость возвращения нажатой клавиши в исходное положение после того, как вы ее отпустите). Трудно однозначно ассоциировать Note Off Velocity с конкретным свойством звучания ноты, тем более что далеко не все клавиатуры формируют в сообщении Note Off значение Velocity. Итак, подключите MIDI-клавиатуру. Нажмите кнопку [image] (MIDI Input). Нажмите в любом необходимом сочетании кнопки [image] (Record Pitch), [image] (Record NoteOn Velocity), [image] (Record NoteOff Velocity). В окне List Editor выберите ноту, которую вы хотите отредактировать.
Сыграйте на MIDI-клавиатуре необходимую ноту с необходимой силой удара по клавише. Выделение "перескочит" на следующее сообщение в списке. Но главное, что в столбцах Data 1 и Data 2 того сообщения, редактированием которого вы занимались, появятся значения параметров, введенные в результате вашей "живой" игры. Если результат не понравится, можно вновь выделить необходимое сообщение и повторить попытку.
Обращаем ваше внимание на то, что таким путем меняется только высота тона и громкость звучания ноты. Временные параметры сообщения (время начала и продолжительность звучания) остаются прежними. Поэтому можем предложить вам такое применение описанному способу редактирования. Не задумываясь о мелодической составляющей, создайте заранее необходимый ритмический рисунок, записав любым путем произвольную последовательность нот. Например, можно в режиме записи просто "отстучать" ритм на одной и той же клавише MIDI-клавиатуры. В вашем распоряжении окажется ритмический шаблон, который теперь будет легче наполнить мелодическим содержанием.


6.2.6. Пошаговый ввод нот

Режим пошагового ввода полезен в том случае, когда вы по каким-то причинам не в состоянии сыграть определенный фрагмент композиции в реальном времени, точно выдерживая моменты взятия нот или аккордов.
Приступая к пошаговому вводу нот, не забудьте подключить MIDI-клавиатуру!
Для перехода в пошаговый режим нажмите кнопку [image] (Step Input). Панель инструментов после этого несколько изменит свой вид (рис. 6.16). Станет доступной кнопка [image] (Insert Mode), а поле Mouse Position изменит свое название на Insert Position (сравните с рис. 6.15).
Выберите записываемые параметры, нажав кнопки [image] (Record Pitch), [image] (Record NoteOn Velocity), [image] (Record NoteOff Velocity) в любом необходимом сочетании. Если кнопка [image] (Record Pitch) останется выключенной, то вместо тех нот, которые вы в дальнейшем сыграете на MIDI-клавиатуре будет записываться нота СЗ.

Рис. 6.16. Инструменты окна List Editor в режиме пошагового ввода

С помощью инструмента [image] или клавишами <<->, <->> установите позицию начала пошаговой записи (в средней секции окна она отмечается вертикальной синей линией). При необходимости уточните ее в поле ввода Insert Position. В раскрывающемся списке Quantize выберите шаг, с которым будут записываться очередные ноты, а в раскрывающемся списке Length Quant — длительность записываемых нот.
А теперь можете нажимать клавиши MIDI-клавиатуры, извлекая отдельные ноты или целые аккорды. Соответствующие сообщения будут появляться в окне List Editor. Если нужно ввести паузу — воспользуйтесь клавишей <->>, и указатель позиции ввода перескочит через долю. Конечно, после каждого нажатия клавиш необходимо будет уточнять точку записи и длительность очередной ноты. Вот так, не торопясь, шаг за шагом вы и справитесь с записью любого самого быстрого пассажа. Если, прослушав полученный результат, вы придете к выводу, что где-либо посредине записанной последовательности вы пропустили ноту, не спешите удалять все ноты, расположенные после места, где возникла ошибка. Нажмите кнопку [image] (Insert Mode) и установите указатель позиции записи в точку, где должна быть записана пропущенная нота. Сыграйте ее на MIDI-клавиатуре. Нота будет вставлена на свое место, а остальные сообщения, располагавшиеся в точке записи и правее ее, будут одновременно (как единое целое) сдвинуты еще далее вправо на величину шага квантизации.
По окончании сеанса пошаговой записи не забудьте выключить кнопку [image] (Step Input).
Теоретически с помощью опций окна Event List можно вставлять в список сообщения любых типов и выполнять операции по их редактированию. Однако на практике оказывается, что сообщения некоторых типов удобнее записывать, пользуясь другими средствами, имеющимися в программе. Ноты лучше наиграть на MIDI-клавиатуре, записать в нотаторе (Score Editor) или в редакторе отпечатков фортепианных клавиш (Key Editor). Уровнем громкости и значениями контроллеров непрерывного действия удобнее управлять, рисуя графики изменения параметров в окне Key Editor или огибающие автоматизации в окне Cubase SX Project.


6.3. Работа в редакторе Key Editor

Окно Key Editor программы Cubase SX предназначено для выполнения двух чрезвычайно важных функций:

  • графического редактирования отпечатков клавиш;
  • графического редактирования параметров MIDI-сообщений.

Окно отрывается командой MIDI > Open Key Editor при условии, что в окне проекта выделена хотя бы одна из MIDI-частей.
Если будут выделены несколько частей, то их сообщения будут одновременно доступны для редактирования в окне Key Editor даже в том случае, если части размещаются на разных треках. Сообщения, принадлежащие активной части, имеют яркий цвет, сообщения всех остальных частей серые. Стоит "тронуть мышью" сообщение неактивной части, как та становится активной. Таким образом, в окне Key Editor поддерживается мультитрековый режим. Для того чтобы не запутаться в том, сообщения какого трека или какой части вы редактируете в данный момент, используйте обозначение различными цветами сообщений, принадлежащих разным частям, или сообщений, ассоциированных с разными MIDI-каналами.
Возможно, некоторым музыкантам это покажется странным, но именно Key Editor (рис. 6.17) является наиболее удобным при редактировании MIDI-информации.

Рис. 6.17. Окно Key Editor


6.3.1. Инструменты окна Key Editor

В окне Key Editor видны две секции: секция отпечатков клавиш (Note Display) и секция графического редактирования параметров MIDI-сообщений (Controller Display). Верхняя секция служит для отображения собственно отпечатков клавиш фортепиано, а нижняя — для графического управления параметрами синтеза звука. Изменять размеры секций можно, перемещая мышью разделительную линию вверх или вниз.
В верхней секции имеется вертикальная полоса прокрутки. Пользуясь ею, можно просмотреть любой участок виртуальной MIDI-клавиатуры (от ноты С-2 до ноты G8).
По краям вертикальной и горизонтальной полос прокрутки размещены слайдеры для уменьшения или увеличения масштаба изображения. При достаточно крупном масштабе отображения по вертикали на отпечатках клавиш появляются обозначения нот, которым они соответствуют.
В верхней части окна расположены инструменты редактирования отпечатков клавиш и параметров MIDI-сообщений.
Если нажать кнопку [image] (Show Info), то под панелью инструментов появится информационная строка (рис. 6.18), в которой отображаются параметры (Start, End, Length, Pitch, Velocity, Channel, Off Velocity) выделенного отпечатка клавиши.

Рис. 6.18. Окно Key Editor, открыта информационная строка

Если выделены несколько отпечатков, то в информационной строке отображаются параметры того из них, который был выделен первым, причем цвет шрифта изменяется.
Следующие два инструмента знакомы вам: такие же точно элементы есть и в окне List Editor.
(Solo Editor) — кнопка включения режима "Соло" для части, редактируемой в окне Key Editor.
(Object Selection) — кнопка выделения объектов в верхней и нижней секциях окна Key Editor. С помощью этого инструмента можно выделить как отдельные объекты, так и целые их группы. Выделенные отпечатки клавиш можно перетаскивать на любое место верхней секции, удалять или копировать в буфер обмена. Выделенные в нижней секции графики можно удалять. Одновременно с этим будут удалены и те отпечатки клавиш, которым удаленные графики соответствовали. С помощью этого инструмента можно не только перемещать отпечатки клавиш, но и изменять их размер. Ухватившись за левую или правую стороны выделенного отпечатка, можно изменить длительность звука. Ухватившись за среднюю часть прямоугольника, можно изменить положение отпечатка клавиши во времени или изменить высоту тона. Любые изменения отпечатков клавиш будут вызывать соответствующие изменения в списке MIDI-сообщений и в нотной записи. Инструментом [image] (Draw) окна Key Editor производится вставка отпечатков клавиш и редактирование их параметров. Данный инструмент несколько отличается от аналогичного по назначению инструмента окна List Editor (обратите внимание на треугольник в углу кнопки). Треугольник означает, что двойным щелчком на кнопке [image] отрывается меню, в котором выбирается разновидность инструмента вставки. То есть под этой кнопкой "скрывается" не один, а сразу несколько инструментов. С их помощью можно рисовать графики, составленные из элементов определенной формы, например, параболических, пилообразных, синусоидальных и т. д. На наш взгляд, эта возможность актуальна только при редактировании параметров в нижней секции окна. Если применить данный набор инструментов в верхней секции, то ноты, расположенные на созданных таким путем траекториях, вряд ли будут выражать какую-либо осмысленную музыкальную идею. Исключение составляет разве что такой вариант инструмента, как [image] (Paint). Проводя им в горизонтальном направлении, можно нарисовать последовательность отпечатков клавиш, местоположение и длина которых будут определяться установками, выполненными в полях Quantize и Length Quant.
(Erase) — инструмент для удаления звуков. Этим инструментом работают точно так же, как обычным канцелярским ластиком. Нажмите левую кнопку мыши и проведите курсор по тем отпечаткам клавиш (или графикам изменения значений параметров MIDI-сообщений), которые вам не нужны. Удалить выделенные отпечатки клавиш или графики можно и с помощью клавиши <Delete>.
(Zoom) — инструмент изменения масштаба отображения по горизонтали.
(Mute) — инструмент мьютирования отдельного отпечатка клавиши или целой их группы. Выберите этот инструмент и щелкните на отпечатке. Он сменит цвет своей окраски на белый и окажется заглушенным. При воспроизведении или записи именно его вы не услышите. Отменяется мьютирование повторным щелчком на отпечатке. Для того чтобы заглушить группу отпечатков клавиш, выберите этот инструмент и, удерживая нажатой левую кнопку мыши, "нарисуйте" прямоугольник, охватывающий необходимые отпечатки. Однако не советуем увлекаться применением инструмента
(Mute) к группе отпечатков. Для того чтобы отменить их мьютирование, вам нужно будет вспомнить, какой именно пунктирный прямоугольник вы рисовали, заглушая отпечатки, и нарисовать точно такой же еще раз. Вряд ли это удастся сделать, поэтому с части отпечатков мьютирование будет снято, но зато заглушатся какие-нибудь другие отпечатки, впервые попавшие в пунктирный прямоугольник. Командой Undo отменить применение инструмента [image] (Mute), к сожалению, нельзя. Инструментом [image] (Split) можно разрезать отпечаток клавиши на две части. Если выделены несколько отпечатков, расположенных на одной вертикали, то все они будут разрезаны. По отношению к операции Split команда Undo действует.
Инструмент [image] (Glue), наоборот, служит для склеивания отпечатков клавиш, расположенных на одной и той же горизонтали. Пощелкайте им, и вы увидите, как относительно короткие отпечатки удлиняются и объединяются. При этом всем последующим отпечаткам присваиваются свойства (например, значение Velocity) того из них, который был расположен левее.
Инструмент [image] (Autoscroll) — знакомая вам кнопка включения режима автоматической прокрутки изображения в окне (по горизонтали) в режиме записи или воспроизведения.
Правее расположены два поля. В верхнем поле отображается вертикальная координата курсора мыши (если он находится в пределах верхней секции окна Key Editor). В нижнем поле в обычном режиме отображается горизонтальная координата курсора мыши. В режиме пошагового ввода в этом поле отображается и в случае необходимости редактируется позиция ввода очередной ноты.
Среди других полей ввода находится поле Insert Velocity. В нем можно выбрать значение Velocity, которое будет присваиваться сообщениям типа Note, когда вы будете вставлять отпечатки клавиш.
Все остальные инструменты знакомы вам, так как они ничем не отличаются от тех, что имеются в окне List Editor (см. разд. 6.2). Поэтому просто перечислим их.

  • Кнопка [image] (Snap), предназначенная для включения режима привязки вставляемых сообщений к долям тактов (она действует и применительно к графикам в нижней секции окна).
  • Раскрывающийся список Quantize, предназначенный для выбора шага квантизации, с которым располагаются вставляемые сообщения.
  • Раскрывающийся список Length Quant, предназначенный для выбора шага квантизации длительности сообщений.
  • Раскрывающийся список Colors, предназначенный для выбора цветовой гаммы отображения параметров сообщений.
  • Кнопка [image] (Auto Play), предназначенная для включения режима прослушивания звучания нот.
  • Кнопка [image] (Step Input), предназначенная для включения пошагового режима записи отпечатков клавиш с MIDI-клавиатуры.
  • Кнопка [image] (MIDI Input), предназначенная для включения режима редактирования отпечатков клавиш с MIDI-клавиатуры.
  • Кнопка [image] (Insert Mode) включения режима сдвига существующих отпечатков клавиш вправо от позиции вставки.
  • Кнопки [image] (Record Pitch), [image] (Record NoteOn Velocity), [image] (Record NoteOff Velocity) выбора параметров сообщения, которые будут восприниматься редактором при нажатии вами MIDI-клавиш.

Несколько слов скажем о раскрывающемся списке Colors. Выбирая в нем ту или иную строку, вы сможете влиять на цветовое отображение параметров сообщений в окнах List Editor и Key Editor:

  • Velocity — ноты (для краткости так назовем и отпечатки клавиш в окне Key Editor, и объекты в средней секции окна List Editor) будут окрашиваться в разные цвета в зависимости от значения их Velocity. Установка этого режима позволяет следить за уровнем Velocity, даже если в нижней секции окна Key Editor в данный момент отображается другой параметр. По умолчанию "тихие" ноты отображаются синим цветом, который по мере увеличения Velocity постепенно переходит в красный;
  • Pitch — окраска каждой ноты будет зависеть от ее номера в пределах октавы: все до разных октав окрашиваются в один цвет, до-диез — в другой и т. д.;
  • Channel — ноты, ассоциированные с определенным MIDI-каналом, будут окрашиваться в свой цвет;
  • Part — ноты будут окрашиваться в тот цвет, который в окне проекта выбран для данной части.

На окраску собственно нот в окне Score Editor все это никакого влияния не оказывает.
Для всех вариантов, кроме Part, можно редактировать палитру цветов, вызвав командой Setup соответствующее окно. Его название и набор опций видоизменяются в зависимости от того, какой режим окраски (Channel, Pitch или Velocity) является текущим.


6.3.2. Секция отпечатков клавиш

Отпечатки клавиш фортепиано отображаются прямоугольниками, длина которых соответствует длительности звука. Чтобы определить высоту тона (номер ноты), достаточно посмотреть, какой клавише клавиатуры, расположенной слева, соответствует отпечаток.
Хотя мы и говорим о клавишах фортепиано, на самом деле в окне изображена клавиатура, соответствующая стандарту MIDI (она имеет почти одиннадцать октав). Очевидно, что все клавиши не могут уместиться в окне, поэтому отображается лишь небольшой участок клавиатуры. С помощью полосы прокрутки в правой части окна можно вывести на экран любой участок клавиатуры. Некоторые клавиши подписаны: С хх, где хх — номер октавы. Например, СЗ означает до третьей октавы (в системе нумерации Cubase SX). Кроме того, в полях [image] расположенных на панели инструментов, отображаются координаты курсора мыши: по вертикали — обозначение ноты и MIDI-номер клавиши, а по горизонтали — время с точностью до тика.
Перемещаться вдоль клавиатуры можно не только с помощью вертикальной полосы прокрутки. Если щелкнуть на изображении клавиатуры и переместить курсор по вертикали до границы видимой части клавиатуры, изображение начнет прокручиваться. Раздастся звук, характерный для игры "глиссандо", как будто вы скользите пальцем по настоящей фортепианной клавиатуре.
Перемещаться вдоль окна отпечатков клавиш можно не только с помощью горизонтальной полосы прокрутки, но и пользуясь клавишами <->> или <<->. При этом будет осуществляться пошаговый переход к очередному соседнему отпечатку клавиши.
Если на компьютерной клавиатуре предварительно нажать клавишу <Ctrl>, то щелчком мыши на какой-либо клавише виртуальной клавиатуры можно выделить все соответствующие ей ноты данной части. При этом не имеет значения расположение нот во времени. Это полезно, когда нужно для всего трека изменить, например, громкость звучания конкретной ноты (например, командой MIDI > Functions > Velocity). Предварительно нажав клавишу <Shift>, мышью можно выделить сразу несколько различных по высоте нот.
Если нажать <Ctrl> и повторно щелкнуть на одной из нот, входящих в выделенную группу, то это приведет к снятию выделения со всех ранее выделенных нот (кроме той, на которой этот щелчок выполнен).
Если нажата кнопка [image] (Show Info), то непосредственно над секцией отпечатков клавиш окна Key Editor (см. рис. 6.18) располагается информационная строка, содержащая 7 полей ввода. В этих полях вы можете редактировать (или просто наблюдать) следующие параметры выделенного отпечатка клавиши:

  • Start — время, соответствующее положению начала отпечатка клавиши (в формате такт.доля.часть доли.тик);
  • End — время, соответствующее положению окончания отпечатка клавиши Length — длительность MIDl-ноты (длина отпечатка клавиши);
  • Pitch — обозначение и номер MIDI-ноты, которой соответствует отпечаток клавиши;
  • Velocity — значение параметра Velocity сообщения Note On;
  • Channel — номер MIDI-канала по которому передается сообщение о включении выделенной ноты;
  • Off Velocity — значение параметра Velocity сообщения Note Off.

Редактировать содержимое полей можно как непосредственно вводя в них необходимые числовые значения, так и с помощью клавиш <вверх> или <вниз>. Итак, работа в верхней секции окна Key Editor сводится к вставке и редактированию (различными способами) отпечатков клавиш в соответствии с вашим композиторским замыслом.


6.3.3. Секция графического редактирования параметров MIDI-сообщений

Секция графического редактирования занимает нижнюю область окна Key Editor. Каждый звук характеризуется не только высотой и длительностью, но также громкостью и еще рядом параметров. Как вы уже знаете, MIDI-сообщения о нажатии клавиши несут в себе информацию об изменении громкости звука. В окне Key Editor можно управлять громкостью звучания нот, соответствующих отдельным отпечаткам. Громкость можно задавать как в цифровой, так и в графической форме. Кроме громкости, теоретически можно управлять любым параметром, поддерживаемым MIDI-устройством. Однако на практике управление такими параметрами, как, например, NRPN, предполагающими точную установку значения, бывает затруднительно.
Значения отдельных параметров отображаются в виде вертикальных линий, высоту которых вы можете изменять с помощью соответствующих инструментов.
В левой части секции графического редактирования окна Key Editor расположен раскрывающийся список (рис. 6.19) — меню, содержащее перечень сообщений, параметры которых доступны для редактирования в секции управления параметрами. На рис. 6.18 в этом меню выбран элемент Velocity.
Если в этом меню выбрать команду Setup, то откроется окно Controllers Menu Setup (рис. 6.20).

Рис. 6.19. Пример меню выбора редактируемого параметра

Рис. 6.20. Окно Controllers Menu Setup

Окно состоит из двух областей. В левой области перечислены контроллеры, включенные в меню секции графического редактирования. В правой — все оставшиеся возможные контроллеры. Вы можете изменять содержание левой области. Если хотите сократить список контроллеров, выделите имя одного из них (или нескольких) и нажмите кнопку >>>. Соответствующие строки переместятся из левой области окна Controllers Menu Setup в правую. Если список нужно пополнить, то выделите необходимую строку в правой области и нажмите кнопку <<<. Затем нажмите ОК. Обновление меню свершится.
Работа в секции графического редактирования окна Key Editor сводится к выбору редактируемого параметра и к изменению высоты столбиков, отображающих значение того или иного параметра. В этих целях можно использовать инструменты [image] (Draw) и [image] (Erase).
Рассмотрим особенности действия различных вариантов инструмента [image] (Draw).
(Draw) и [image] (Paint) — можно рисовать столбики произвольной высоты, редактировать параметры отдельно взятого отпечатка клавиши.
(Line) — можно рисовать графики изменения параметра, состоящие из отрезков прямых линий (пример применения представлен на рис. 6.21).
(Parabola) — можно рисовать графики изменения параметра, состоящие из линий параболической формы (рис. 6.22).
(Sine) — можно рисовать графики изменения параметра, состоящие из линий синусоидальной формы (рис. 6.23).
(Triangle) — можно рисовать графики изменения параметра, состоящие из пилообразных кривых (рис. 6.24).
(Square) — можно рисовать графики изменения параметра, состоящие из последовательности прямоугольных импульсов (рис. 6.25).

Рис. 6.21. Пример применения инструмента Line

Рис. 6.22. Пример применения инструмента Parabola

Рис. 6.23. Пример применения инструмента Sine

Рис. 6.24. Пример применения инструмента Triangle

Рис. 6.25. Пример применения инструмента Square

Вы видите, что однократное применение любого из этих инструментов приводит к изменению параметров сразу многих сообщений. Инструменты удобны тем, что однократный выбор команды Undo также сразу отменяет все эти изменения.
По умолчанию в секции графического редактирования отображается график изменения одного из параметров (см., например, рис. 6.18). Однако при желании вы можете наблюдать и редактировать одновременно несколько параметров и даже все параметры, включенные в меню (см., например, рис. 6.19).
Для того чтобы добавить в секцию графического редактирования линейку с графиком изменения еще одного параметра, выполните следующие действия. Щелчком правой кнопки мыши откройте контекстное меню и в нем выберите команду Create New Controller Lane. Появится вторая линейка с графиком изменения текущего параметра. В меню (см. рис. 6.19) выберите необходимый параметр, например, Pan. В качестве примера на рис. 6.26 приведен вид окна Key Editor, в котором для отображения одновременно выведены графики параметров Velocity и Pan.

Рис. 6.26. В окне Key Editor отображаются графики Velocity и Pan

Когда вам захочется скрыть линейку с графиком какого-либо параметра, щелкните на ней правой кнопкой мыши и в открывшемся контекстном меню выберите команду Remove this Lane. Таким способом можно закрыть вообще все линейки.
Несколько слов скажем об особенностях графического управления некоторыми параметрами.
С помощью сообщений Pitchbend можно передавать данные о положении колеса изменения тона. Положение колеса изменяется от —8192 до 8191. Как правило, по умолчанию чувствительность колеса устанавливается равной ±2 полутона. Это значит, что положение колеса -8192 соответствует понижению высоты звука на 2 полутона, а 8191 — повышению высоты звука на 2 полутона. Чувствительность колеса можно запрограммировать с помощью регистрируемого параметра RPN 0. Регистрируемые параметры (RPN) применяются также для подстройки строя синтезатора.
Нерегистрируемые параметры NRPN с одними и теми же номерами у различных производителей музыкальных инструментов и студийного оборудования могут использоваться для разных целей (в отличие от RPN).
На практике управлять параметрами NRPN с помощью опций окна Key Editor трудно. Дело в том, что значение NRPN складывается из NRPN LSB и NRPN MSB (это относится и к RPN тоже). Поэтому для того чтобы получить численный результат, имеющий определенный смысл, вам потребуется производить вычисления, которые, кроме сложения, должны включать в себя еще и перевод чисел из десятичной системы в шестнадцатеричную и обратно.
Итак, мы рассмотрели окно Key Editor, позволяющее редактировать партии мелодических инструментов, представленные в виде последовательности отпечатков клавиш.


6.4. Работа в редакторе Drum Editor

Если редактируемый MIDI-трек (точнее редактируемая часть, находящаяся на MIDI-треке) содержит сообщения для ударных инструментов, то вместо Key Editor удобнее применять другой редактор — Drum Editor. Его окно (рис. 6.27) открывается командой MIDI > Open Drum Editor.
В этом случае вместо прямоугольных отпечатков клавиш вы видите ромбики, обозначающие начальные моменты формирования звуков ударных — отпечатки ударных инструментов, а вместо клавиш фортепиано — названия ритмических инструментов (в столбце Instrument), а также обозначения клавиш, которым они соответствуют (в столбце Pitch).
Работа в окне Drum Editor, в конечном счете, сводится к тому, что вы должны:

  • в верхней секции окна в необходимых долях тактов расставлять ромбики — отпечатки необходимых ударных инструментов;
  • для каждого отпечатка ударных инструментов задавать параметры синтеза, рисуя их графики в нижней секции окна (как минимум, задавать изменение Velocity).

Рис. 6.27. Окно Drum Editor. В раскрывающемся списке Map выбрана строка No Drum Map

Окно Drum Editor как нельзя лучше приспособлено для обеспечения такой деятельности. Не удивительно, что оно отличается особой структурой и наличием специфических инструментов.


6.4.1. Особенности инструментов редактора Drum Editor

Понятно, что работа с ударными музыкальными инструментами хотя и имеет свои особенности, но, вместе с тем, является частным случаем работы с музыкальными инструментами вообще. Поэтому среди инструментов окна Drum Editor вы найдете кнопки, поля ввода и раскрывающиеся списки, знакомые по ранее рассмотренным окнам MIDI-редакторов List Editor и Key Editor. Их мы рассматривать не будем. Остановимся лишь на новых инструментах. Их всего три:
(Solo Instrument) — кнопка включения режима сольного прослушивания партии выделенного ударного инструмента (при воспроизведении или записи);
(Drumstick) — кнопка записи ромбиков-отпечатков ударных инструментов в верхней секции окна (основной рабочий инструмент в Drum Editor);
(Use Global Quantize) — кнопка включения квантизации, общей для всех ударных инструментов. Определенные особенности также проявляются в двух элементах, имеющихся и в Key Editor:

  • инструмент [image] действует только в нижней секции окна, а среди его разновидностей нет варианта Draw;
  • в качестве вертикальной координаты в соответствующем поле вместо номера ноты отображается название ударного инструмента.


6.4.2. Редактирование партий ударных инструментов

Итак, для каждого ударного инструмента выделена своя строка в верхней секции, которая, в свою очередь, состоит из двух областей. В правой области располагаются линейки, поделенные на такты и доли тактов. Именно на них инструментом [image] (Drumstick) и следует наносить отпечатки ударных инструментов. В левой области есть несколько столбцов (их количество и назначение зависит от того, выбрана ли какая-либо барабанная карта в раскрывающемся списке Map). Под барабанной картой понимается система соответствия звучащих ударных инструментов MIDI-сообщениям Note On, поступающим по определенному каналу от определенных MIDI-клавиш.
Сначала рассмотрим структуру левой области верхней секции окна при условии, что барабанная карта не выбрана (в раскрывающемся списке Map выбрана строка No Drum Map). Фактически в этом случае будет установлено стандартное для GM закрепление ударных инструментов за MIDI-клавишами (см. рис. 6.27).
В такой ситуации левая область окна поделена на 4 столбца.
1. Безымянный столбец, щелкая на ячейках которого, можно выделить определенный ударный инструмент и услышать его звучание.
2. Столбец Pitch, в котором указаны обозначения и номера MIDI-клавиш (нот). Содержание ячеек данного столбца для редактирования недоступно.
3. Столбец Instrument, в котором указаны названия ударных инструментов. Текст в ячейках данного столбца доступен для редактирования.
4. Столбец Quantize, в ячейках данного столбца для партии каждого ударного инструмента можно ввести свое значение шага квантизации.
Реальное влияние на процесс редактирования партий ударных инструментов оказывает только содержимое ячеек последнего из перечисленных столбцов. Чтобы разобраться в этом, рассмотрим методику записи отпечатков ударных инструментов для одной из партий. Допустим, что удары инструмента Bass Drum должны приходиться на начало такта и происходить раз в такт.
Поэтому для инструмента Bass Drum в поле столбца Quantize введем 1/1 Note. Для этого следует щелкнуть на поле Quantize и в открывшемся меню выбрать одну из стандартных длительностей. Теперь убедимся, что кнопка [image] (Use Global Quantize) выключена. В противном случае на результат будет влиять содержание раскрывающегося списка, находящегося под ней. Далее выберем инструмент [image] (Drumstick). Подготовка к записи партии завершена. Приступайте к главному. В правой области окна нацельте указатель мыши на любую точку линейки, которая соответствует инструменту Bass Drum, нажмите левую кнопку мыши и проведите ее указателем вдоль линейки. Отпечатки ударного инструмента будут установлены точно в назначенные места: в начало каждого такта (рис. 6.28).

Рис. 6.28. Записана партия инструмента Bass Drum

Направление перемещения указателя мыши не имеет значение. Можно двигать его вправо, но можно и влево. Главное, чтобы один и тот же такт он не проходил дважды. Иначе, при повторном проходе ранее нанесенные отпечатки будут удалены.
Аналогично записываются партии других ударных инструментов. Причем для каждой из них в поле столбца Quantize можно задать свой шаг квантизации. Так, например, на рис. 6.29 для Side Stick выбран шаг квантизации 1/2 Note, поэтому отпечатки этого инструмента оказались вставлены через полтакта.
В отличие от окна Key Editor в нижней секции рассматриваемого редактора отображаются параметры (например, значение Velocity) не одновременно всех инструментов (клавиш), а только того из них, который выбран в верхней секции (на рис. 6.29, например, таким инструментом является Closed Hi-Hat). Поэтому и редактировать параметры можно для каждого инструмента в отдельности, что в случае ударных очень удобно.

Рис. 6.29. Пример записи партий ударных (для каждой партии выбран свой шаг квантизации)

Если кнопка [image] (Use Global Quantize) включена, то программа игнорирует значения шага квантизации, установленные для каждого инструмента в отдельности, и все отпечатки будут "рисоваться" в тех долях, которые определяются содержанием раскрывающегося списка, находящегося под данной кнопкой.
Получается, что при записи партии средствами окна Drum Editor наименьший шаг записи ударов равен шестьдесятчетвертой доле. Это, конечно, совсем не плохо. Однако если понадобится внести в партию еще более тонкие ритмические нюансы, то придется перейти в окно List Editor и в нем отредактировать содержание столбца Start для каждого сообщения: сдвинуть сообщения вперед-назад на несколько тиков.
Итак, мы разобрались в структуре окна для того случая, когда барабанная карта не выбрана. А теперь в раскрывающемся списке Map выберем, например, строку GM Map. Вид окна Drum Editor после этого изменился (рис. 6.30). Если барабанная карта для трека выбрана, то двойным щелчком на нем в окне проекта открывается окно Drum Editor, а не Key Editor.
В левой области появились еще 5 столбцов.
1. М — щелкая на ячейках этого столбца, можно заглушить любые ударные инструменты. При редактировании нескольких партий такая возможность дает дополнительные удобства.
2. I-Note — в этом столбце указывается фактическое соответствие канала данного инструмента (строки таблицы) определенной ноте во входном потоке MlDI-сообщений.
3. O-Note — в этом столбце указывается фактическое соответствие канала данного инструмента (строки таблицы) определенной ноте в выходном потоке MIDI-сообщений.
4. Channel — MIDI-канал, ассоциированный с данным ударным инструментом. Канал можно выбрать в меню, открывающемся щелчком на соответствующей ячейке столбца Channel.
5. Output — выходной MIDI-порт, которому будут посылаться сообщения. Щелчком на ячейке открывается меню выбора выходного порта.

Рис. 6.30. Окно Drum Editor. В раскрывающемся списке Map выбрана строка GM Map

Дополнительные столбцы левой секции окна приобретают значение в том случае, когда вы записываете партии ударных инструментов с MIDI-клавиатуры или синтезатора, имеющих нестандартную раскладку ударных инструментов. Редактируя содержание столбцов I-Note и O-Note, можно установить любое соответствие ударных клавишам. Правда, думается, что дело до этого не дойдет. В комплекте с Cubase SX поставляется множество файлов с самыми различными вариантами Drum Map. Командой MIDI > Drum Map Setup открывается окно Drum Map Setup, с помощью которого любую из этих барабанных карт можно загрузить в программу, после чего новая барабанная карта становится доступной и в раскрывающемся списке Map окна Drum Editor. Подробно о работе с окном Drum Map Setup мы рассказали в разд. 4.1.2.
Вы уже, вероятно, поняли, что "входная" нота (клавиша, с помощью которой вы вводите сообщение для данного ударного инструмента) и "выходная" (реально звучащий ударный инструмент) могут не совпадать. Это можно использовать для создания исполнителю комфортных условий. Например, если вы играете партию ударных вживую и один из задействованных тембров расположен на клавиатуре далеко от остальных, то вам будет неудобно все время "тянуться" к этой удаленной клавише. Назначьте для данного ударного инструмента более близкую клавишу в качестве входной, а выходную оставьте прежней. Тогда у вас все инструменты окажутся под рукой.
В завершение раздела осталось сказать, что редактирование параметров MIDI-сообщений в нижней секции окна Drum Editor ничем не отличается от аналогичной процедуры в окне Key Editor, описанной нами в разд. 6.3.2.


6.5. Работа в Logical Editor

Работа над музыкальной композицией — это не только творчество. Приходится также выполнять массу рутинных операций, отнимающих много сил. Особо нудным занятием является редактирование однотипных параметров серии однотипных MIDI-сообщений. То нужно найти все ноты с определенным номером для того, чтобы затем отредактировать какой-либо из их параметров; то нужно, избавляясь от огрехов исполнения, удалить случайные ноты (как правило, очень короткие или очень тихие); то нужно транспонировать часть нот; то нужно удалить из списка сообщения определенного типа. Композиций у вас много, да все они содержат не по одному десятку треков, а сообщений на них — не сосчитать. Сколько драгоценного времени может уйти на подобную работу!
Нечто похожее наблюдается в математике, когда приходится, например, для получения графика тысячи раз повторять вычисления по одной и той же формуле, подставляя различные исходные данные. Математики давно изобрели способ облегчения своей и нашей жизни — программирование. Программист один раз пишет последовательность команд, а многократное их выполнение возлагает на вычислительную машину. В основе такого подхода лежит один из языков программирования, обеспечивающий перевод инструкций, формулируемых в удобном для человека виде, в код, понятный машине. Многие Windows-приложения содержат в себе встроенные языки программирования, позволяющие автоматизировать повторяющиеся операции и расширить функциональные возможности приложения. Так, например, в программе Cakewalk SONAR имеется встроенный язык CAL, позволяющий писать достаточно сложные программы обработки MIDI-данных. С нашей точки зрения, Logical Editor также можно рассматривать как графическое средство доступа к языку программирования последовательности операций с MIDI-сообще-ниями. Пожалуй, от типичных средств редактирования содержания компьютерных программ Logical Editor отличается лишь относительной простотой да еще формой составления программ. При работе с Logical Editor вам не потребуется вести посимвольную запись операторов программы. Вы их будете выбирать из числа тех, что предлагаются в меню и в списках.
В названии редактора слово "логический" присутствует не случайно. Ведь суть работы с Logical Editor состоит в следующем:
1. Вы задаете признаки, по которым программа должна выявить определенные MIDl-сообщения. Критерии поиска формулируются как совокупность логических условий. Например, на обычном человеческом языке это может выглядеть так: "Найти все MIDl-сообщения типа Note, для которых Velocity < 10".
2. Вы указываете программе последовательность действий, которые она должна выполнить по отношению к выявленным сообщениям. Например: "Удалить".
3. Вы определяете область, в пределах которой программа должна выполнять ваше задание. Например, выделяете часть на MIDI-треке.
Иными словами, в работе с редактором вы постоянно используете логические условия.
Вообще говоря, в математике существует обширный раздел, который так и называется "Логика". Одной из задач логики является исследование эффективных способов построения сложных логических высказываний на основе элементарных логических операторов. Среди различных логических систем особое место занимает двоичная (булева) логика, в которой и исходные объекты и результаты их обработки принимают только два значения. Обычно эти значения обозначаются как 0 и 1, или как ЛОЖЬ (FALSE) и ИСТИНА (TRUE). В частности, доказано, что самые сложные отношения между объектами (условия) могут быть выражены на основе суперпозиции всего лишь двух элементарных логических функций (операторов). Разработчики Logical Editor выполнили это условие с избытком: в качестве таких операторов выбраны три функции: NOT, AND и OR. Функции AND и OR присутствуют в явном виде, они так и обозначены: AND и OR. Функции NOT в явном виде вы здесь не найдете, но фактически, выбирая одно из двух условий Equal или Unequal, вы будете иметь дело именно с ней.
NOT — функция одной переменной. Она принимает значение 1, когда переменная равна 0, и 0, когда переменная равна 1.
Остальные логические функции позволяют работать с различным числом логических переменных. Для функций AND и OR минимальное количество переменных равно двум. Логические функции задаются в виде таблиц истинности. В табл. 6.1 приведена таблица истинности функции AND, а в табл. 6.2 — функции OR.

Таблица 6.1. Функция AND

Х2\Х, | 0 | 1
0 | 0 | 0
1 | 0 | 1

Таблица 6.2. Функция OR

Х2\Х, | 0 | 1
1 | 1 | 1
1 | 1 | 1
В верхней строке каждой таблицы приведены значения первой логической переменной (\i). В левом столбце — значения второй логической переменной (х2). На пересечении строки и столбца записан результат операции. Например, (1 AND 0) = 0, (1 AND 1) = 1, (0 OR 1) = 1
Словами табл. 6.1 можно описать так: в результате операции AND получится ИСТИНА, только в том случае, если обе переменные (х1 и х2) принимают значение ИСТИНА.
Смысл табл. 6.2 иной: в результате операции OR получится ИСТИНА, в том случае, если хотя бы одна из переменных (x1 или х2) принимает значение ИСТИНА.
Возможно, некоторым музыкантам и это легкое прикосновение к математике покажется слишком сложным. Но если вы хотите научиться пользоваться Logical Editor, то ничего не поделаешь, без понимания хотя бы элементарных вещей не обойтись. Ведь именно путем построения цепочки логических операторов вам предстоит объяснять программе задачу, которую вы ей ставите. Известная программистская мудрость гласит: "Что запрограммируешь, то и получишь". Не хотелось бы, чтобы, применяя Logical Editor, вместо удовольствия от работы, вы получали неожиданные неприятности.
Окно Logical Editor (рис. 6.31) открывается командой MIDI > Open Logical Editor.
С помощью Logical Editor определяются параметры поиска и преобразования MIDI-сообшений, записанных в части на MIDI-треке. Возможные варианты действий:
  • преобразование свойств найденных сообщений;
  • удаление найденных сообщений;
  • вставка новых сообщений, параметры которых определенным образом связаны с найденными сообщениями.

В окне Logical Editor имеется два рабочих поля: в верхнем (столбцы (, Filter Target, Condition, Parameter 1, Parameter 2, Bar Range, ), bool) определяются условия фильтрации.

Рис. 6.31. Окно Logical Editor

В нижнем рабочем поле (столбцы Action Target, Operation, Parameter 1,Parameter 2) определяются параметры преобразования MIDI-сообщения. Напротив каждого из рабочих полей имеется пара кнопок: Add Line (добавить строку в список на рабочем поле) и Delete Line (удалить строку из списка на рабочем поле).
В строках верхнего рабочего поля вам предстоит набирать программу, согласно которой будет проводиться выявление сообщений, характеризующихся определенными признаками. В строках нижнего рабочего поля предстоит формулировать конкретное задание для Logical Editor, т. е. указывать действия, которые должны быть выполнены в отношении выявленных сообщений.
Рабочие поля можно сравнить с двумя разграфленными листками обыкновенного блокнота. На первом вы составляете описание какого-либо объекта (например, "женщина, молодая, красивая"), а на втором пишете, что нужно будет с таким объектом сделать, если он вам встретится (например, "познакомиться").
Оба рабочих поля понадобятся вам не всегда. Если, допустим, требуется удалить определенные сообщения, то такая операция программируется без использования нижнего рабочего поля. Однако когда вы соберетесь преобразовать сообщения, то необходимо будет определить, какие свойства должны быть изменены и каким именно образом.
Задача логическому редактору в общем виде формулируется путем выбора одной из строк в раскрывающемся списке, который расположен в левом верхнем углу окна Logical Editor:

  • Delete — удалить найденные сообщения;
  • Transform — преобразовать сообщения;
  • Insert — вставить сообщения, найденные в соответствии с заданными условиями;
  • Insert Exclusive — вставить сообщения за исключением найденных в соответствии с заданными условиями;
  • Сору — копировать сообщения, преобразовать их согласно заданным условиям и вставить на другой трек;
  • Extract — извлечь найденные сообщения и вставить их на другой трек;
  • Select — выделить найденные сообщения с тем, чтобы вы могли продолжить работу с ними в другом редакторе.

В поле, расположенном справа, содержатся пояснения к выбранной задаче преобразования.
Разработчики утверждают, что средствами Logical Editor можно выполнить преобразования любой сложности. И это очень похоже на правду. Во всяком случае, количество различных вариантов преобразований подсчитать очень трудно. Никому из нас не удалось бы перебрать их и за всю свою жизнь. Logical Editor, как и любое устройство, логика которого построена не по жесткой схеме, а программируется, сам может считаться объектом творчества. Поэтому бессмысленно пытаться обучать вас выполнению 5, 10, 20 конкретных преобразований. Все, чем мы можем вам помочь в освоении Logical Editor, так это разъяснить общие принципы его применения. Вот и продолжим это занятие.
Рассмотрим использование окна Logical Editor на примере одного из пресетов. Откроем список Presets и выберем пресет standard set 2 > del patch changes. Судя по названию, пресет предназначен для удаления из списка сообщений о смене MIDI-инструмента.
Программа преобразований загрузилась в Logical Editor. Посмотрим, как это отразилось на содержании окна (рис. 6.32).
В безымянном раскрывающемся списке, расположенном в верхнем левом углу окна, появилась надпись Delete. Значит, сообщения действительно будут удаляться. Справа в поле комментария содержится пояснение о том, что будут удалены все сообщения, удовлетворяющие условиям фильтрации.
Условие фильтрации набрано в верхнем рабочем поле. Но здесь трудно охватить запись взглядом. Поэтому для справки соответствующее логическое выражение приведено и в информационной строке, расположенной чуть ниже. В данном случае условие выглядит следующим образом:

( Туре = Program OR ( Type = Controller AND ( Valuel = 0 OR Valuel = 32 ) ))
Попробуем расшифровать эту запись. Начнем с пары внешних скобок — ( и ). Они служат признаками начала и конца логического оператора, определяющего условия фильтрации. Сообщения каких типов будут удалены?
Или типа Program Change (см. выражение Туре = Program), или типа Controller (см. выражение Туре = Controller). О том, что именно "или — или", свидетельствует первый слева оператор OR. Все ли сообщения типа Controller будут удалены? Нет, не все, а только те, которые, будучи сообщениями данного типа, одновременно удовлетворяют дополнительным условиям: имеют значения своего параметра, равные или 0, или 32. Об этом свидетельствует выражение (Туре = Controller AND ( Valuel = О OR Valuel — 32 )). Как известно, контроллер № 0 — это BankSel LSB (младший байт сообщения о выборе банка), а контроллер № 32 — это BankSel MSB (старший байт сообщения о выборе банка). Итак, действительно, в рассмотренном условии запрограммировано удаление всех возможных сообщений, связанных со сменой MIDI-инструмента. Даже предусмотрен тот факт, что в различных MIDI-спецификациях предусмотрены различные способы адресации банка.

Рис. 6.32. Окно Logical Editor с загруженным пресетом del patch changes

Рис. 6.33. Верхнее рабочее поле с введенным условием преобразования

Теперь рассмотрим внимательнее верхнее рабочее поле (рис. 6.33) с тем, чтобы понять, каким образом только что проанализированное условие оказалось там записанным.
Содержание условия следует читать слева направо и сверху вниз, как мы обычно читаем книгу. Немного сбивают с толку длинные пробелы между некоторыми элементами, но со временем к этому можно привыкнуть.
Верхняя строка содержит заголовки столбцов. Они одновременно являются названиями списков, раскрывающихся двойным щелчком на соответствующей ячейке.
Получается следующее:

  • в одной строке можно записать некоторое выражение, заключенное в скобки. Количество скобок в пределах от 0 до 3 выбирается в ячейках ( и ). Cubase SX автоматически проверяет выполнение правил синтаксиса, присущих для данного языка программирования. Одно из них заключается в том, что количество закрывающих скобок должно быть равно количеству открывающих;
  • в ячейке столбца bool можно записать один из двух логических операторов (Оr или And).

Выражение, записанное в строке, может состоять из следующих компонентов.
1. Filter Target — признак (объект) фильтрации. Выбор осуществляется из вариантов: Type Is (по типу сообщения); Position (по позиции сообщения); Length (по длине сообщения); Value 1 (по значению первого параметра сообщения); Value 2 (по значению второго параметра сообщения); Channel (по MIDI-каналу); Property (по атрибуту сообщения — muted, selected, locked); Value 3 (по значению третьего параметра сообщения).
2. Condition — условие фильтрации (состояние признака фильтрации). Выбор осуществляется из вариантов, число и смысл которых зависит от объекта фильтрации, выбранного в столбце Filter Target. Например, для объекта Channel такими вариантами будут: Equal (равно), Unequal (неравно), Bigger (больше), Bigger or Equal (больше или равно), Less (меньше), Less or Equal (меньше или равно), Inside Range (находится в заданном диапазоне), Outside Range (находится вне заданного диапазона).
3. Parameter 1, Parameter 2 — значения параметров.
4. Ваr Range — временной диапазон поиска сообщений в пределах каждого такта. Столбец доступен только в том случае, когда в столбце Filter Target выбран объект Position, а в столбце Condition — признаки Inside Bar Range или Outside Bar Range.
Итак, для составления программы поиска и преобразований сообщений необходимо путем выбора элементов в раскрывающихся списках заполнять ячейки в строках верхнего и нижнего рабочих полей.
Для применения Logical Editor нажмите кнопку Do It.
Хотим предупредить, что в ходе подготовки материала данного раздела мы изредка сталкивались с неприятным явлением. В ряде случаев на выбор в Logical Editor недопустимого сочетания параметров программа Cubase SX реагировала еще более недопустимым, на наш взгляд, образом: сообщала об ошибке и тут же закрывалась с потерей всех данных.
Не станем углубляться дальше. Не очень верится в то, что вы всерьез займетесь разработкой собственных алгоритмов для Logical Editor (особенно если не обладаете соответствующей подготовкой в области программирования). А вот разобраться в смысле преобразований, которые сохранены создателями Cubase SX в виде пресетов, вам теперь вполне по силам. Там вы обнаружите очень полезные вещи. Советуем вам в свободное время поэкспериментировать с содержимым раскрывающегося списка Presets, применяя пресеты для обработки какого-либо несложного и хорошо знакомого вам материала. Кстати говоря, списки пресетов Logical Editor содержатся также и в системе подменю, которые открываются командой MIDI > Logical Presets.
Напомним, что в разд. 4.1.2 рассмотрен пример применения для преобразования MIDI-сообщений окна Input Transformer, которое очень похоже на окно Logical Editor. Разница заключается в том, что окно Input Transformer предназначено для редактирования параметров фильтрации и преобразования MIDI-данных в реальном времени, а с помощью окна Logical Editor осуществляется фильтрация и преобразование MIDI-данных, уже сохраненных на треке. Кроме того, в Cubase SX имеется работающий в режиме реального времени MIDI-плагин Transform, который является полным аналогом Logical Editor.
Те команды и функции, которые применяются в процессе редактирования MIDI-сообщений, сосредоточены в меню MIDI. В предыдущих разделах текущей главы мы уже обращались к командам, открывающим различные MIDI-редакторы (за исключением Score Editor — этот редактор мы рассмотрим в главе 7). С работой в окне Drum Map Setup, которое открывается командой MIDI > Drum Map Setup, мы познакомили вас в разд. 4.1.2. За пределами нашего повествования пока остались функции, доступные в подменю MIDI > Functions, и группа команд, связанных с квантизацией.


6.6. Применение квантизации

В самом общем смысле суть квантизации состоит в привязке начальных моментов MIDI-сообщений и/или их протяженности во времени к выбранной дискретной сетке. Перечислим наиболее распространенные задачи квантизации.
1. Выравнивание неточно сыгранной последовательности нот по заданным долям такта.
2. Преобразование ритмической структуры обрабатываемой партии в соответствии с образцовой партией.
3. Внесение небольших "случайных" отклонений моментов взятия нот и их длительностей от идеально равномерной тактовой сетки. Такая обработка имитирует игру исполнителя-человека и позволяет избавиться от впечатления навязчивой механистичности в звучании партий, созданных с помощью MIDI-секвенсора.
В Cubase SX предусмотрено много различных алгоритмов квантизации. Перед тем как перейти к их анализу, рассмотрим команду Quantize Setup, которой открывается диалоговое окно Quantize Setup, предназначенное для выбора параметров квантизации.


6.6.1. Выбор параметров квантизации

Итак, откроем диалоговое окно Quantize Setup (рис. 6.34) и рассмотрим его содержание.

Рис. 6.34. Диалоговое окно Quantize Setup

В средней части окна расположено поле (Grid Display), в котором (в пределах одного такта) наглядно отображается сетка квантизации и те изменения, которые происходят с ней при выборе различных значений параметров и алгоритмов квантизации.
В верхней части окна находится группа Grid Quantize, элементы которой предназначены для установки сетки квантизации — положения на оси времени тех точек, к которым в результате квантизации будут привязываться сообщения. В группу входят:
1. Раскрывающийся список Grid, в котором выбирают основной шаг квантизации в пределах от целой до стодвадцатьвосьмой длительности.
2. Раскрывающийся список Туре, предназначенный для перехода:

  • к пунктирной длительности (Dotted — удлинение шага квантизации на половину основной длительности, в нотной записи такие длительности обозначаются как "нота с точкой");
  • к длительности, позволяющей образовывать триоли (Triplet — деление основной длительности не на две части, а на три).

Еще большую гибкость в вопросе выбора шага квантизации даст вам поле ввода Tuplet. С его помощью такт и основные доли такта можно разделить на любое количество частей. Это позволяет формировать любые триолеобразные ритмические фигуры, базирующиеся на квинтолях (рис. 6.35), секстолях, септолях и т. д.
С помощью слайдера Swing можно сместить каждый второй узел сетки квантизации относительно его обычного положения (рис. 6.36). При воспроизведении квантизированной таким образом музыки действительно возникает ощущение свинга.
Слайдер Magnetic Area позволяет определить в окрестностях узлов сетки квантизации размер тех областей (рис. 6.37), в пределах которых квантизация будет оказывать влияние на ноты ("притягивать" их к узлам). Ноты, находящиеся вне Magnetic Area, могут быть не затронуты квантизацией. Это также служит разрушению ощущения монотонности в образе идеально ровной MIDI-музыки. Область захвата отображается на поле Grid Display в виде голубых прямоугольников, длина каждого из которых пропорциональна значению Magnetic Area.

Рис. 6.35. Такт разделен сеткой квантизации на 5 частей

Рис. 6.36. Пример сетки квантизации, Grid = 1/8, Swing = 50 %

Рис. 6.37. Пример сетки квантизации, Grid = 1/8, Magnetic Area = 20%

А вот в поле Non Quantize можно ввести в тиках ширину области, в пределах которой квантизация, наоборот, не будет оказывать влияния на ноты. Это, с одной стороны, позволит сохранить небольшие отклонения от равномерной игры, которые как раз и являются одним из признаков стиля музыканта-профессионала, а с другой стороны, позволит устранять грубые исполнительские ошибки. Напомним, что в Cubase SX на четвертную длительность приходится 120 тиков.
Если в поле Random Quantize ввести ненулевое значение (в тиках), то сообщения будут квантизироваться к случайным позициям в пределах указанного "расстояния" от сетки квантизации.
В поле Iterative Strength в процентах вводится параметр, определяющий область действия алгоритма квантизации, который приводится в действие командой MIDI > Iterative Quantize (ее мы охарактеризуем чуть позже).
Обращаем ваше внимание на то, что любые изменения сетки квантизации, выполненные в диалоговом окне Quantize Setup, немедленно находят отражение в окне Key Editor: изменяется "густота" вертикальных линий сетки в правой секции. Кроме того, изменение параметров Grid, Type и Tuplet мгновенно отображается также в поле Quantize, имеющемся в окнах Key Editor и List Editor. А вот для того чтобы применить установленную квантизацию к MlDI-сообщениям, записанным на треке в выделенной части, нужно нажать кнопку Apply.


6.6.2. Суть различных алгоритмов квантизации

После того как вы выбрали параметры квантизации, можно применять ее на практике. Доступ к соответствующим командам осуществляется либо из контекстного меню, либо из меню MIDI.
Непосредственно в меню MIDI (или в подменю MIDI контекстного меню) имеются 2 команды квантизации:

  • Over Quantize — произвести полную квантизацию моментов наступления событий в соответствии с сеткой квантизации, выбранной в раскрывающемся списке Quantize окна Key Editor;
  • Iterative Quantize — выполнить итеративную (приближенную) квантизацию, при которой начальные моменты событий переместятся не точно в узлы сетки квантизации, а в некоторую их окрестность, ширина которой определяется значением параметра Iterative Strength (выбирается в окне диалога Quantize Setup).

Кроме того, в подменю Advanced Quantize содержатся 4 дополнительные команды, относящиеся к квантизации. Рассмотрим суть каждой из них.
1. Quantize Lengths — выполнять квантизацию только продолжительности событий, не затрагивая их начальные моменты. Команда доступна только при открытых окнах редакторов Key Editor или List Editor.
2. Quantize Ends — выполнять квантизацию только моментов окончания событий.
3. Undo Quantize — отменить ранее выполненную квантизацию. Данная команда в отличие от отмен, которые выполняются командой Edit > Undo, оказывает влияние только на операции квантизации, не затрагивая другие разновидности редактирования. Вместе с тем, применение Undo Quantize отображается в предыстории редактирования окна Edit History.
4. Freeze Quantize — стереть из предыстории квантизации информацию о первоначальных положениях и протяженности событий. После применения данной команды к выделенным сообщениям их текущие положения и длительности программа будет считать исходными. Если ранее квантизация не выполнялась, то команда не окажет никакого влияния. Если квантизация имела место, то после применения команды MIDI > Advanced Quantize > Freeze Quantize не будет действовать команда MIDI > Advanced Quantize > Undo Quantize. Однако и в последнем случае отменить квантизацию все-таки можно. Для этого следует воспользоваться командой Edit > Undo.
Обилие алгоритмов квантизации — это то, чем всегда гордились поклонники музыкальных редакторов, в именах которых имеется слово "Cubase". Суть этих алгоритмов за долгие годы не претерпела значительных изменений. Поэтому при желании вы сможете найти их подробное описание в книгах, посвященных ранним версиям программы Cubase. Мы же на этом завершаем тему квантизации.
В заключение хочется обратить ваше внимание только на одно обстоятельство. Квантизацию можно отнести к тем средствам программы, которые позволяют в автоматическом режиме выполнять одновременную обработку большого количества сообщений в соответствии с заданным алгоритмом. Это может помогать в работе, но только в том случае, когда вы хорошо представляете себе, что получится в ее результате при различных начальных условиях. Поэтому советуем вам вводить в свою практику различные приемы квантизации постепенно, после того, как на понятных вам примерах вы испытаете их в действии.


6.7. Применение команд меню MIDI

В меню MIDI имеются следующие команды: Transpose..., Merge MIDI in Loop, Dissolve Part, O-Note Conversion и Reset.
Командой Reset вы можете послать синтезатору сигнал сброса MIDI-контроллеров в состояние по умолчанию. Такая необходимость возникает чаще всего в тех случаях, когда происходит случайное "подвисание" ноты: сообщение Note On прошло, a Note Off — нет. Остальные команды требуют чуть более подробного пояснения.


6.7.1. Transpose... — транспонирование выделенных MIDI-нот

Командой MIDI > Transpose... открывается диалоговое окно Transpose (рис. 6.38), предназначенное для транспонирования выделенных MIDI-нот.

Рис. 6.38. Диалоговое окно Transpose

В поле ввода Semitones вы должны указать интервал транспонирования (в количестве полутонов. Положительное число означает транспонирование вверх, отрицательное — вниз. Алгоритм работы Transpose состоит в том, что к номерам нот, записанных в части на треке, прибавляется число, введенное вами в поле Semitones.
Разработчики программы предлагают нам самим решать, как быть в тех случаях, когда в результате транспонирования ноты могут "забраться" слишком высоко или "опуститься" слишком низко. Если установлен флажок Keep Notes in Range, то максимальный диапазон транспонирования будет ограничен значениями, введенными в полях ввода Upper Barrier и Lower Barrier. Советуем не менять его значения, установленного по умолчанию (от С-2/0 до G8/127). В этом случае, даже если в промежуточном результате вычислений, сопровождающих транспонирование, номер ноты выйдет за допустимый интервал [0, 127], ничего страшного не случится. Программа автоматически прибавит к промежуточному результату или число 12, или -12, и ноты окажутся в пределах существующих MIDI-октав. В итоге, нота до по-прежнему останется нотой до, нота ре — ре и т. д.
Если же в полях ввода Upper Barrier и Lower Barrier вы зададите слишком узкий допустимый диапазон транспонирования, то его алгоритм будет иным способом реагировать на возникновение "пограничных конфликтов":

  • если сумма номера исходной ноты и числа, заданного в поле ввода Semitones, превысит число, заданное в поле ввода Upper Barrier, то в итоге будет создана нота с номером, равным числу, заданному в поле ввода Upper Barrier;
  • если сумма номера исходной ноты и числа, заданного в поле ввода Semitones, станет меньше числа, заданного в поле ввода Lower Barrier, то в итоге будет создана нота с номером, равным числу, заданному в поле ввода Lower Barrier.

В таких ситуациях вероятным становится непредсказуемое изменение нот: нота до вполне может превратиться, например, в ноту ля или в любую другую.
Этому окну можно найти довольно необычное применение. Если в полях Upper Barrier и Lower Barrier ввести одно и то же значение, то все ноты, содержащиеся в выделенной части, превратятся именно в ту ноту, которая указана в данных полях. Понадобиться это может в тех случаях, когда вам захочется из мелодической партии выделить ритм "в чистом виде".


6.7.2. Merge MIDI in Loop — перезапись MIDI-сообщений с разных треков на один; применение MIDI-плагинов

Команда Merge MIDI in Loop позволяет объединить все MIDI-сообщения, находящиеся на незаглушенных треках между левым и правым локаторами, в единую часть. Часть размещается на выбранном треке. Командой открывается диалоговое окно MIDI Merge Options, в котором следует определить опции формирования части.
Обращаем ваше внимание на важное обстоятельство: успешное применение команды возможно только при условии, что для каждого из MIDI-треков выбран выходной порт!
Наибольшая польза от команды Merge MIDI in Loop может быть получена в том случае, когда она используется для применения результатов работы MIDI-плагинов.
MIDl-плагины в Cubase SX, в основном, используются в реальном времени. Для этого вы сначала должны подключить MIDI-плагин к проекту одним из двух способов:

  • в режиме вставки как эффекты последовательного действия (в секции Inserts инспектора или в аналогичной секции микшера);
  • в режиме посыла как эффекты параллельного действия (в секции Sends инспектора или в аналогичной секции микшера).

Затем вы можете регулировать параметры плагина в его окне. Результат работы плагина, минуя трек Cubase SX, будет поступать непосредственно на выходной MIDI-порт программы (все подробности о работе с MIDI-плаги-нами читайте в главе 9).
На работу плагина в реальном времени тратится некоторая часть ресурсов компьютера. Если к проекту подключено много плагинов, то нагрузка на компьютер может стать существенной. Поэтому хорошо было бы обладать инструментом для пересчета результатов работы плагина в MIDI-сообщения, записываемые вместо исходных непосредственно в часть на MIDI-треке. Подобрали параметры плагина в реальном времени, убедились в том, что результаты его работы вас устраивают — и давайте команду на их запись. А плагин после этого уже и не нужен. Отключайте его от проекта.
Именно таким средством и является диалоговое окно MIDI Merge Options (рис. 6.39), которое открывается командой MIDI > Merge MIDI in Loop.

Рис. 6.39. Диалоговое окно MIDI Merge Options

В окне находятся только три флажка: Include Inserts, Include Sends и Erase Destination.
Если установлен флажок Include Inserts, то в процессе перезаписи данных с одного MIDI-трека на другой будут учтены все преобразования, которые осуществляются MIDI-плагинами, подключенными в режиме вставки как эффекты последовательного действия (в секции Inserts инспектора или в аналогичной секции микшера).
Если установлен флажок Include Sends, то в процессе перезаписи данных с одного MIDI-трека на другой будут учтены все преобразования, которые осуществляются MIDI-плагинами, подключенными в режиме посыла как эффекты параллельного действия (в секции Sends инспектора или в аналогичной секции микшера).
Если установлен флажок Erase Destination, то после выполнения команды исходные данные из фрагментов частей, задействованных в обработке, будут удалены.
В главе 9 мы научим вас, как использовать команду Merge MIDI in Loop для исследования сущности MIDI-плагинов, имеющихся в Cubase SX.


6.7.3. Dissolve Part— распределение сообщений с выделенной части по отдельным трекам

Команда MIDI > Dissolve Part служит для распределения MIDI-сообщений с выделенной части (или с нескольких выделенных частей одного или нескольких треков) по отдельным трекам. Обращаем ваше внимание на то, что команда доступна, если вы работаете в окне Cubase SX Project, и лишь в том случае, когда имеется хотя бы одна часть, выделенная при включенной кнопке [image] Командой открывается диалоговое окно (рис. 6.40). в котором следует выбрать критерий распределения сообщений. Возможны два варианта:

  • Separate Channels — по признаку принадлежности сообщений к определенному MIDI-каналу (будет установлено соответствие "трек — MIDI-канал";
  • Separate Pitches — по номеру MIDI-ноты (на каждом из треков будут собраны сообщения, характеризующиеся одинаковым номером ноты).

Рис. 6.40. Диалоговое окно Dissolve Part

Если все сообщения в выделенной части ассоциированы с одним и тем же MIDI-каналом, то опция Separate Channels недоступна.
Опция Separate Channels может оказаться полезной для обратного преобразования MIDI-данных, обработанных командой MIDI > Merge MIDI in Loop. Конечно, для возврата в исходное состояние удобнее пользоваться командой Edit > Undo. Однако в тех случаях, когда это оказывается невозможным (например, когда вы "одумались" лишь после сохранения и закрытия проекта), команда MIDI > Dissolve Part и опция Separate Channels могут выручить. Данная опция может пригодиться также при работе с M1DI-данными, импортированными в Cubase SX из стандартных MIDI-файлов формата 0, в которых абсолютно все сообщения хранятся на одном треке.
Опция Separate Pitches на практике часто используется для разноса по нескольким трекам партий различных ударных инструментов. Некоторые музыканты считают, что так их удобнее редактировать. Хотя это, скорее, дань привычке. Вспомните, как удобно организована работа в окне Drum Editor: все партии ударных видны, а параметры каждой партии можно редактировать независимо от других.


6.7.4. O-Note Conversion— преобразование номеров нот в соответствии с Drum Map

Мы уже рассказывали о Drum Map в разд. 4.1.2 и разд. 6.4. Напомним, что Drum Map можно считать своего рода перекодировщиком, который в соответствии с заданным правилом меняет номера нот, поступающих в него (I-Note), на новые номера. Те ноты, которые формируются на выходе Drum Map, в Cubase SX обозначены как O-Note. Drum Map применяется в составе редактора Drum Editor. Данные два средства, по сути дела, совместно выполняют роль MIDI-плагина реального времени. При игре на MIDI-клавиатуре I-Note поступают в Drum Map с нее, в режиме воспроизведения — с MIDI-трека Cubase SX, a O-Note в любом случае отправляются в выходной MIDI-порт программы.
Команда O-Note Conversion позволяет записать ноты, номера которых преобразованы в соответствии с Drum Map, на MIDI-трек.
Команда доступна только в том случае, когда для MIDI-трека назначена барабанная карта, т. е. если в раскрывающемся списке mар: основной секции инспектора трека выбрана любая строка, кроме No Drum Map.
Заметим, что в барабанной карте две различные I-Note не могут соответствовать одной O-Note. Например, сочетание I-Note = СЗ/60 -> O-Note = ЕЗ/64 и I-Note = ЕЗ/64 -> O-Note = ЕЗ/64 является запрещенным. Поэтому в такой ситуации программа откажется выполнять команду O-Note Conversion и выдаст сообщение о некорректности "навязываемых" ей преобразований. Конфликт, обозначенный в приведенном примере, можно разрешить следующим образом: I-Note = СЗ/60 -» O-Note = ЕЗ/64 и I-Note = ЕЗ/64 -> O-Note = СЗ/60.


6.8. Применение функций, доступных из подменю MIDI > Functions

MIDI > Functions — подменю, в котором собраны команды, выполняющие ряд редактирующих функций:

  • Legato — удлинение MIDI-нот до их слияния. В результате применения этой функции каждая MIDI- нота удлиняется таким образом, чтобы либо ее окончание достигало начала следующей ноты, либо между нотами оставался промежуток заданной длительности, либо ноты накладывались друг на друга. Параметры функции Legato задаются в диалоговом окне Preferences (команда File > Preferences, вкладка MIDI - Function Parameters);
  • Fixed Lengths — изменение длительности всех MlDI-нот до заданного значения. Длительность, к которой будут преобразованы ноты, выбирается в раскрывающемся списке Quantize окна Key Editor (или окна List Editor);
  • Delete Doubles — удаление двойных нот. Двойные ноты — это ноты, имеющие одинаковые номера и расположенные в одинаковых временных позициях. Они могут возникать при записи в циклическом режиме, а также в процессе редактирования. Двойные ноты напрасно расходуют полифонию синтезатора, причем их звучание, как правило, отличается в худшую сторону от звучания отдельных нот из-за небольшого и непредсказуемого временного рассогласования;
  • Delete Controllers — удаление всех сообщений, кроме MIDI-нот из выделенной части;
  • Delete Notes... — удаление нот, имеющих заданные параметры;
  • Restrict Polyphony — редактирование длительности одновременно звучащих нот с целью уменьшения их числа. Командой Restrict Polyphony открывается диалоговое окно, предназначенное для выбора допустимого количества голосов, используемых при воспроизведении выделенных нот или частей. Функция полезна в том случае, когда в вашем распоряжении имеется звуковая карта или синтезатор с небольшой полифонией. Реально функция сокращает длительность нот таким образом, чтобы одни ноты успевали отзвучать до начала следующих;
  • Pedals to Note Length — преобразование длительности нот с учетом наличия сообщений о включении сустейн-педали. Функция выявляет имеющиеся сообщения о включении и выключении сустейн-педали, удлиняет ноты, к которым эти сообщения относятся. После этого сами сообщения о включении и выключении сустейн-педали удаляются. Таким способом несколько разгружается MlDI-интерфейс;
  • Delete Overlaps (mono) — устранение перекрытия во времени MIDI-нот с одинаковыми номерами. Для правильной работы некоторых синтезаторов требуется, чтобы сообщение Note Off предшествующей ноты шло обязательно раньше, чем сообщение Note On следующей ноты. Команда решает эту проблему автоматически;
  • Delete Overlaps (poly) — устранение перекрытия во времени MIDI-нот с любыми номерами;
  • Velocity... — преобразование значений параметра Velocity сообщений Note On;
  • Fixed Velocity — присвоение параметру Velocity сообщений Note On заданного значения, которое равно числу, введенному в поле Insert Velocity окна Key Editor;
  • Reverse — перезапись выделенных нот в обратном порядке. При этом меняется только очередность звучания нот (например, было: до, ре, ми, а станет: ми, ре, до), но не характер звукоизвлечения: каждый звук по-прежнему будет начинаться с фазы атаки и завершаться фазой затухания.

Назначение большинства перечисленных функций достаточно понятно и без дополнительных пояснений. Поэтому остановимся только на двух функциях: Delete Notes... и Velocity....


6.8.1. Delete Notes... — удаление нот, имеющих заданные параметры

Команда MIDI > Functions > Delete Notes... открывает диалоговое окно, Delete Notes (рис. 6.41), предназначенное для выбора критериев удаляемых нот.

Рис. 6.41. Диалоговое окно Delete Notes

Если установлен флажок Minimum Length, то в результате применения функции из выделенной части будут удалены ноты, длительность которых меньше, чем число, введенное в поле Minimum Length (в тиках). Диаграмма, расположенная чуть ниже, служит инструментом быстрого ввода допустимой длительности ноты. Щелчком на черной (правой) части диаграммы выбирается ее масштаб (четверть, такт, два такта, четыре такта). Щелчок на светлой части диаграммы фактически превращает ее в слайдер, которым число в поле Minimum Length можно изменять быстро и в больших пределах. Если установлен флажок Minimum Velocity, то функция будет применена к нотам, Velocity которых меньше, чем число, введенное в поле Minimum Velocity.
От содержания поля Remove when under зависит логика принятия решения об удалении ноты. Для смены содержания поля нужно на нем щелкнуть. Если выбран вариант One Of, то нота будет удалена, если хотя бы один из ее признаков отвечает установленным критериям (или длительность, или Velocity меньше заданных значений). Вариант Both означает, что для удаления ноты должны быть выполнены оба условия (и длительность и Velocity меньше заданных значений).
На практике функцию Delete Notes применяют для удаления так называемых нот-призраков (случайных очень коротких или очень тихих нот). Ноты-призраки могут появляться в результате "грязного" стиля игры на MIDI-клавиатуре, но в первую очередь это характерно для игры на MIDI-гитаре. На слух такие ноты могут быть заметны слабо. Искать их в окне List Editor, просматривая километровые списки сообщений, — занятие неблагодарное. Вместе с тем, пользы от них никакой, один только вред: напрасно занимают полифонию синтезатора, дают случайные призвуки. Поэтому обработать функцией Delete Notes партию, сыгранную вживую, будет нелишним.
В четвертной длительности 480 тиков, в шестнадцатой — 120, в тридцатьвторой — 60, в шестьдесятчетвертой — 30. Вряд ли в реальной музыкальной практике возникает необходимость играть более короткие ноты (да и многие ли музыканты смогли бы их осознанно сыграть?). Поэтому ноты, короче 30 тиков, можно считать аномальными и подлежащими удалению. Точно так же маловероятно неслучайное извлечение очень тихих нот (с Velocity менее 10—15 единиц). А уж если нота и слишком коротка, и слишком тиха — это уж точно результат ошибки исполнителя.


6.8.2. Velocity... — преобразование значений параметра Velocity сообщений Note On

Команда MIDI > Functions > Velocity... открывает диалоговое окно Velocity (рис. 6.42), предназначенное для выбора алгоритма преобразования значений Velocity в сообщениях типа Note.

Рис. 6.42. Диалоговое окно Velocity

Функция действует на выделенную часть (или на несколько выделенных частей).
В окне имеются два поля ввода, назначение которых претерпевает изменение в зависимости от выбранного типа преобразования.
Тип преобразования значений Velocity выбирают в раскрывающемся списке Туре. Возможны три варианта типа преобразования (Add/Subtract, Compress/Expand, Limit), которые мы сейчас и рассмотрим.
Преобразование типа Add/Subtract заключается в том, что к значениям Velocity нот будет прибавлено одно и то же число. Оно должно быть указано в верхнем поле ввода, которое в этом случае будет иметь название Amount. Положительные значения числа увеличивают Velocity нот, отрицательные — уменьшают.
Преобразование типа Compress/Expand заключается в том, что значения Velocity нот будут умножены на постоянный коэффициент. Он в процентах задается в верхнем поле ввода (Ratio). Значения коэффициента, превышающие 100 %, означают увеличение Velocity, не превышающие — уменьшение. Например, если у исходной ноты Velocity = 100, a Ratio = 40 %, то после применения функции получится Velocity = 40. Максимальное значение Ratio не ограничено. Однако это на практике не очень важно, так как если, например, попытаться Velocity = 100 умножить всего лишь на 2 (т. е. установить Ratio = 200 %), то все равно в итоге получится Velocity = 127.
Преобразование типа Limit заключается в том, что значения Velocity нот будут ограничены в пределах диапазона, заданного в верхнем (Upper) и нижнем (Lower) полях ввода. На ноты, Velocity которых попадает в разрешенный диапазон, функция не воздействует никаким образом. Нотам, у которых Velocity > Upper, будет присваиваться Velocity = Upper. Нотам, у которых Velocity < Lower, будет присваиваться Velocity = Lower. Таким образом, в отношении параметра Velocity применяется операция, аналогичная жесткому ограничению звукового сигнала (см. разд. 1.10.2).


Глава 7. Browse Project. Управление темпом

    • Browse Project. Управление темпом
    • 7.1. Представление проекта в окне Browse Project
    • 7.2. Управление темпом и музыкальным размером
    • 7.2.1. Tempo Track
    • 7.2.2. Beat Calculator


Browse Project Управление темпом

В данной главе мы расскажем о двух окнах: Browse Project и Tempo Track. Browse Project — это единственное место в Cubase SX, где собрана абсолютно вся информация об используемых в проекте объектах. Судите сами: в окне проекта доступно много объектов проекта, но не все — нет доступа к параметрам модулей VSTi. Модули VSTi доступны в микшере, однако микшер — есть микшер, в нем недоступно содержание треков. В окнах Key Editor и List Editor для редактирования доступна только информация MIDI-частей. Ни в одном из перечисленных окон (кроме, конечно, Browse Project) не доступна информация, хранимая на особом треке Tempo Track, который управляет темпом. В Browse Project доступно все, включая сообщения об изменении темпа. Однако данное окно нельзя считать основным — форма, в которой в нем представлена информация, удобна скорее для программиста, чем для музыканта.


7.1. Представление проекта в окне Browse Project

Окно Browse Project открывается командой Project > Browser. Возможный вид окна Browse Project представлен на рис. 7.1. В левой части окна находится секция Project Structure. Здесь структура проекта представлена в древовидной форме. Корень дерева — название проекта — расположен в верхней части секции Project Structure.
В дереве присутствуют папки всех имеющихся в проекте треков. Если раскрыть папку трека, то в ней будут доступны другие папки, которые в свою очередь соответствуют объектам более низкого логического уровня: частям, аудиосообщениям, подтрекам автоматизации. Например, на рис. 7.1 мы выбрали папку MIDI 01 (так называется часть), которая размещена в папке Track Data (данные, хранимые на треке), которая в свою очередь вложена в папку GROOVE, соответствующую одноименному MIDl-треку. В правой части окна отображается содержание выбранного объекта. В данном случае это список сообщений, хранимых в части. Возможности данного списка напоминают возможности окна List Editor. Вы можете изменять значения параметров сообщений, удалять или добавлять сообщения. Для этого в верхней части окна имеется кнопка Add (добавить), а слева от нее — список, из которого выбирается тип добавляемого сообщения. Новое сообщение добавляется в текущую позицию проекта. Справа от кнопки Add находится список Filter. В нем можно выбрать один единственный тип сообщений, которые будут показываться. В списке Domain выбирается формат представления времени.

Рис. 7.1. Окно Browse Project

С помощью кнопок +A1I и -АН, расположенных в левой верхней части окна, можно одним махом развернуть или свернуть все папки секции Project Structure.
В правой верхней части окна имеется флажок Sync Selection, который по умолчанию установлен. Данная опция означает синхронизацию выделения объектов окна Browse Project и окна проекта. Например, если в окне проекта выделить аудиосообщение, то это же аудиосообшение в окне Browse Project будет показано и выделено в дереве проекта. И наоборот, если выделить MIDI-часть в окне Browse Project, то она окажется выделенной и в окне проекта.
С помощью контекстного меню, которое открывается щелчком правой кнопки мыши, в окне Browse Project можно вызывать различные команды групп Edit (редактирование), Select (выделение), Project (команды подменю Project главного меню) и Add Track (добавить трек).
Мы привели пример, когда выбран объект MIDI-трека. Нужно понимать, что в правой части окна могут отображаться любые объекты, которые по отношению к выбранному в дереве объекту являются вложенными. Например, если выбрать папку аудиотрека, то в правой части окна будет доступен список из аудиосообщений и частей, хранящихся на данном треке.
Двумя последними элементами дерева проекта всегда являются специальные треки Tempo Track (управление темпом) и Signature Track (управление музыкальным размером). Средствами окна Browse Project вы можете добавлять на эти треки сообщения об изменении темпа и музыкального размера. Однако делать это удобнее с помощью окна Tempo Track.


7.2. Управление темпом и музыкальным размером

В Cubase SX существует особый трек, предназначенный для удобного и наглядного управления темпом. Однако доступ к нему реализован вне окна проекта. Трек управления темпом, по сути, представляет отдельное окно-редактор. Тем не менее, трек управления темпом является именно треком, существует в проекте с момента создания самого проекта и является неотъемлемым от проекта.


7.2.1. Tempo Track

Окно трека управления темпом Tempo Track (рис. 7.2) вызывается командой главного меню Project > Tempo Track, аналогичной командой контекстного меню окна проекта или сочетанием клавиш <Alt> + <9>.
На рабочем поле окна располагается график зависимости темпа от времени. С помощью вертикальной полосы прокрутки и регулятора вертикального масштаба видимым можно сделать любой участок графика изменения темпа.
Начало координатных осей соответствует нулевой позиции в проекте и нулевому темпу. Правда, темп, равный нулю, программа не позволит установить: минимально возможный темп — 1 доля в минуту, максимальный темп — 300 долей в минуту.

Рис. 7.2. Трек управления темпом

На рис. 7.2 график темпа выглядит как прямая горизонтальная линия. Это значит, что на данном интервале времени темп постоянен.
В левом верхнем углу окна расположена панель, инструменты которой предназначены для редактирования существующего или создания нового графика изменения темпа:
(Object Selection) — инструмент, с помощью которого можно выделять и перемещать узлы — графические объекты, расположение которых определяет форму графика;

(Erase) — инструмент для удаления узлов;

(Zoom) — инструмент для управления масштабом графика;

(Draw) — карандаш для рисования узлов графика изменения темпа и сообщений смены музыкального размера;

(Autoscroll) — автоматический горизонтальный скроллинг вслед за указателем текущей позиции проекта;

(Snap) — режим привязки узлов графика к тактам. Со всеми перечисленными инструментами вы уже знакомы по окну проекта.
Обратите внимание на кнопку Master, которая дублирует такую же кнопку на транспортной панели (см. раздел 3.4): если кнопка нажата, то Tempo Track контролирует темп проекта. В противном случае темп и музыкальный размер для всего проекта будут постоянными (задать их можно на транспортной панели или в полях Temp и Signature окна Tempo Track).
Редактирование графика изменения темпа не многим отличается от редактирования огибающих автоматизации. Однако различия имеются. Вы можете выделять не только узлы графика, но и участки графика между узлами. Для выделенных участков графика в списке Curve на панели инструментов можно выбрать способ интерполяции узлов:

  • Jump — скачкообразное изменение темпа (интерполяция 0 порядка), пример приведен на рис. 7.3, а;
  • Ramp — соединение узлов отрезками прямых (интерполяция 1 порядка), пример приведен на рис. 7.3, б.

Рис. 7.3. Способы интерполяции узлов графика изменения темпа: Jump (a), Ramp (б)

Аналогичные параметры доступны в списке Insert Curve, но относятся они не к существующим и выделенным отрезкам графика, а к тем его фрагментам, которые еще предстоит нарисовать инструментом [image] (Draw).

Непосредственно над графиком изменения темпа находится поле для размещения сообщений о смене музыкального размера. Для краткости назовем его полем музыкального размера. По умолчанию в самом начале проекта в это поле записан размер 4/4. Вы можете выделить его инструментом [image] (Object Selection) и задать в поле Signature новое значение размера. Изменить музыкальный размер в произвольном месте проекта очень просто. Инструментом [image] (Draw) щелкните в нужном месте поля музыкального размера. Создастся новое сообщение о смене музыкального размера (рис. 7.4). Пока это сообщение выделено, задайте в поле Signature нужное значение музыкального размера.

Рис. 7.4. Создание сообщения об изменении музыкального размера


7.2.2. Beat Calculator...

Наш рассказ об управлении темпом проекта Cubase SX был бы не полным, если бы мы не рассказали об одном интересном инструменте, позволяющем точно определить темп любого музыкального материала (MIDI- или аудио).
Командой Project > Beat Calculator откройте окно Beat Calculator (рис. 7.5, a) и, не закрывая его, выделите в окне проекта нужные части или аудиосообщения. Если нажать кнопку Refresh в окне Beat Calculator, то будет рассчитан темп выделенного аудиоматериала. Значение темпа появится в поле ВРМ (рис. 7.5, б}. Чтобы рассчитанный темп соответствовал действительности, в поле Beats следует указать количество тактов, содержащихся по вашему мнению в выделенном материале.

Рис. 7.5. Окно Beat Calculator...

Рис. 7.6. Окно Тар Tempo

Имеется возможность задать темп, "отбивая" его клавишей пробела или щелчками левой кнопки мыши. Нажатием кнопки Тар Tempo откройте одноименное окно (рис. 7.6). Отбивайте темп клавишей пробела или щелчками на поле с надписью Тар the space bar or mouse button to set tempo. Press the ESC key when you are done.. Текущее значение темпа будет отображаться в поле ВРМ. Для завершения работы с окном следует нажать <Esc>. Значение темпа из поля ВРМ окна Тар Tempo будет перенесено в поле ВРМ окна Beat Calculator, окно Тар Tempo будет закрыто.
Итак, темп рассчитан. Теперь можно воспользоваться кнопкой At Tempo Track Start, чтобы установить рассчитанный темп в самом начале проекта. Воспользуйтесь кнопкой At Selection Start, если требуется установить рассчитанный темп в точке, совпадающей с началом выделенной области проекта.


Глава 8. О работе с нотатором

    • О работе с нотатором
    • 8.1. Знакомимся с окном Score Editor
    • 8.2. Особенности инструментов окна Score Editor
    • 8.3. Содержание меню Scores
    • 8.4. Запись нот с помощью мыши


О работе с нотатором

Окно нотатора Score Editor предназначено для редактирования нотных записей, соответствующих MIDI-сообщениям в частях на треках. В нотном редакторе из всех MIDI-сообщений доступны только сообщения типа Note. Они отображаются здесь в привычном для музыкантов виде.
В последнее время многие пользователи приходят к выводу, что редактировать MIDI-музыку в подобных редакторах не очень удобно. MID1-сообщения большинства типов недоступны здесь не только для редактирования, но и для просмотра. Да и собственно символы нот, размещенные на нотном стане, не вполне точно отображают даже начальные моменты и длительность сообщений типа Note. Это связано с тем, что разрешающая способность нотатора равна шестьдесят четвертой доле такта, что в 30 раз хуже разрешающей способности MIDI-секвенсора программы. Кроме того, хранить музыкальные композиции и обмениваться ими значительно удобнее в электронной форме, в виде файла проекта, а не в виде стопки бумажных листов с нотными записями. Само собой разумеется, что в нотной форме не находят отражение такие компоненты проекта и параметры, как аудиоданные, автоматизация, эффекты, баланс уровней, панорама и т. д. Одним словом, нотатор — самый грубый и несовременный инструмент работы с MIDI-музыкой из числа имеющихся в Cubase SX. Он нужен в основном тем музыкантам, которые не признают (или не знают) иных форм записи музыки, кроме нотного письма.
Не хотелось бы, чтобы сказанное было воспринято вами как критика нотного редактора именно программы Cubase SX. На самом деле он великолепен. Просто всему есть свое место и свое время. Нотатор любого музыкального редактора не может сравниться с соответствующим MIDI-секвенсором по возможностям в управлении музыкой. Любой нотный редактор есть не что иное, как специализированная графическая надстройка над MIDI-редакто-ром. Если же говорить о решении таких задач, как распечатка партий для музыкантов, играющих на традиционных инструментах, и подготовка к изданию партитур музыкальных произведений, то можно утверждать, что здесь функциональные возможности Cubase SX сравнимы с возможностями лучших специализированных программ.
Получается, что если вы занимаетесь электронной музыкой, то нотный редактор вам не нужен, потому что он не способен управлять и малой частью параметров ее синтеза. Если вы занимаетесь подготовкой партитур к изданию, то, скорее всего, уже работаете в одной из специально созданных для этого программ и не захотите без особой нужды менять свой инструментарий. А вот если вы хорошо знаете нотную грамоту, но пока недостаточно освоили современные формы записи и редактирования музыки (все эти MIDI-сообшения, контроллеры, отпечатки клавиш, барабанные карты, огибающие), то нотный редактор вполне может оказаться тем мостиком, который приведет вас в компьютерную музыку. Во всяком случае, с его помощью вы сможете создать ритмомелодическую основу, скелет будущей электронной композиции, ее грубую модель, приближение первого порядка. Однако для этого вам не понадобятся все возможности, имеющиеся в нотаторе Cubase SX как в издательской системе. На виртуальной нотной странице вы можете сколько угодно "рисовать" все мыслимые символы нотного письма. Но они так и останутся просто значками. Из всего, что вы разместите на нотных страницах, программа будет в состоянии воспринять только ноты и паузы между ними.
И еще одно обстоятельство. В книге ограниченного объема все равно невозможно уделить должного внимания Score Editor без ущерба для остальных составных частей Cubase SX. A Score Editor вполне мог бы стать предметом отдельной книги. В доказательство этому достаточно привести один аргумент: фирменное руководство пользователя Score Editor насчитывает более 300 страниц. В нем содержится все необходимое для тех людей, которые решат применять Score Editor в качестве издательской системы.
Все сказанное объясняет причины, по которым мы решили не рассматривать нотный редактор столь же подробно, как рассмотрели остальные редакторы, имеющиеся в Cubase SX. Мы хотим, чтобы вы просто научились в нем ориентироваться, а также выполнять запись нот и элементарные операции редактирования.


8.1. Знакомимся с окном Score Editor

Для вызова Score Editor необходимо после выделения нужной партии (одной или нескольких MIDI-частей) выбрать команду MIDI > Open Score Editor или нажать <Ctrl> + <R>.
В окне Score Editor MIDI-сообщения представлены в виде традиционной нотной записи. Возможный вид этого окна показан на рис. 8.1.

Рис. 8.1. Окно Score Editor, открытое для выделенной части на одном MIDI-треке. Режим Edit Mode

Нотный редактор позволяет просматривать и редактировать одновременно несколько партий, расположенных на различных треках. В этом случае одновременно звучащие партии открываются в виде партитуры (рис. 8.2).

Рис. 8.2. Окно Score Editor, открытое для выделенных частей на двух MIDI-треках

Score Editor способен функционировать в двух режимах — режиме редактирования (Edit Mode) и страничном режиме (Page Mode). Редактировать ноты предпочтительнее в Edit Mode (рис. 8.1). Режимы переключаются командой, находящейся в верхней строке меню Scores (она меняет название — Edit Mode или Page Mode). В последнем случае партитура выглядит так, как она будет отпечатана на странице (рис. 8.3).

Рис. 8.3. Окно Score Editor. Режим Page Mode

Редактируемый нотный стан выделяется щелчком на нем при нажатой кнопке [image] (Object Selection) и обозначается вертикальной пунктирной линией (левее ключа). Позиция курсора мыши в нотном тексте отображается в знакомом вам поле [image] расположенном в верхней области окна Score Editor, однако ориентироваться по нему чрезвычайно неудобно. Все нормально, пока курсор мыши находится в пределах редактируемого нотного стана (от ЕЗ до F4 в скрипичном ключе). Но все остальные MIDI-ноты будут находиться вне изображения редактируемого нотного стана на скрытых от глаз добавочных линиях, иногда на таком большом удалении от него по вертикали, что курсор мыши вы увидите на фоне других нотных станов. В такой ситуации запутаться в том, что именно вы сейчас редактируете, совсем не трудно. Правда, существует особый режим, при котором перемещение курсора мыши в больших пределах по вертикали вызывает смену редактируемых нотоносцев. Режим включается кнопкой L, расположенной на панели дополнительных инструментов (рис. 8.4).


8.2. Особенности инструментов окна Score Editor

Среди инструментов, расположенных в левой верхней области окна, есть знакомые вам по окну Key Editor:
(Show Info), включение режима отображения информационной строки (Info line);
(Solo Editor) — кнопка включения режима "Соло";
(Object Selection) — кнопка выделения объектов;
(Erase) — инструмент удаления нот и любых других символов;
(Zoom) — инструмент изменения масштаба отображения (действует только в Page Mode);
(Split) — инструмент для удаления лиг, которыми соединяются одинаковые ноты (одна протяженная нота "разрезается" на две более короткие);
(Glue) — инструмент для объединения одинаковых нот лигами (ноты "склеиваются"). Вместе с тем, в окне Score Editor есть и несколько новых инструментов, о которых мы сейчас и поговорим.
Кнопкой [image] (Iconbar) включается отображение панели дополнительных инструментов (Extended toolbar), представленной на рис. 8.4.
Кнопкой [image] (Filter) включается отображение панели (Display filter bar), с помощью которой можно выборочно скрывать или отображать некоторые элементы нотной записи (рис. 8.5).
(Insert Note) — инструмент записи нот.
(Display Quantize) — кнопка вставки маркеров квантизации и вызова окна Quantize Setup (рис. 8.6), предназначенного для выбора опций квантизации отображения нот.
(Graphic Move) — инструмент вставки графических объектов, которые могут выполнять роль примечаний для пользователя. Например, при нажатой кнопке [image] (Graphic Move) существует возможность вставки в произвольный такт символа ключа, который фактически не изменит закрепление нот за линейками нотоносца в отличие от аналогичной операции, выполненной при нажатой кнопке [image] (Object Selection).
(Cut Notes) — инструмент, позволяющий отобразить ноту некоторой длительности в виде нескольких соединенных лигами нот меньших длительностей. На результат применения инструмента влияют параметры квантизации, установленные в окне Score Editor. Для применения инструмента нужно выбрать его и щелкнуть на ноте (отмена производится повторным щелчком). На панели дополнительных инструментов (рис. 8.4) кнопки сгруппированы по их функциональной принадлежности.

Рис. 8.4. Панель дополнительных инструментов

Первые 4 кнопки в группе Insert связаны с возможностью выделения последовательностей нот в линии голосов. С помощью них можно выбрать голос (если редактирование производится на полифоническом нотоносце).
Далее следуют инструменты выбора длительности вставляемых нот [image] (от целой до шестьдесятчетвертой). Они изменяют значение в поле Length и одновременно выбирают инструмент [image] (Insert Note). Сочетая эти копки с кнопками [image] можно также записать ноту с точкой или триоль.
Кнопки Enharm. Shift [image] позволяют производить энгармоническую замену знаков альтерации в нотной записи. Для выбранной ноты подбирается по возможности энгармонически равная нота с выбранным знаком альтерации. При этом кнопка off означает энгармоническую замену на ноту без знака альтерации, а кнопка No просто убирает знак альтерации, не меняя графическое расположение ноты. Кнопкой со знаком вопроса вы можете по своему желанию добавить перед выбранной нотой любой знак альтерации, в том числе и такой, необходимость которого не обусловлена контекстом партии. Кнопка с изображением скобок заключает знак альтерации в скобки.
В группе Functions [image] слева направо расположены следующие инструменты:

  • Get Info — вызов окна Staff Settings;
  • Flip — изменение ориентации штилей нот: вверх или вниз;
  • Group — группирование нот с помощью ребер длительности;
  • Auto Layout — инструмент оптимизации горизонтального размера отображения содержимого такта (тактов);
  • Hide — скрыть символы, находящиеся в выделенной области;
  • Position Panel — открыть окно отображения координат курсора мыши;
  • Make Chords — инструмент создания аккордов;
  • Force Update — принудительное обновление изображения на экране.

Кнопки, расположенные в группе Layer, имеют отношение к организации послойного отображения нотных записей.
На рис. 8.5 представлена панель фильтра отображаемых элементов.

Рис. 8.5. Панель фильтра отображаемых элементов

Элемент отображается, если установлен соответствующий флажок:
Bar Handles — показывать хэндлы такта. Хендл — маленький квадратик вблизи тактовой черты, ухватившись за который, можно перенести или скопировать содержимое такта методом Drag and Drop. При этом откроется окно диалога, в котором следует выбрать те элементы, которые должны быть перенесены;

  • Hidden Notes — показать ранее скрытые ноты;
  • Hide Displays — показать маркеры всех скрытых элементов (за исключением нот);
  • Quantize Displays — показать маркеры квантизации, вставленные с помощью кнопки Display Quantize;
  • Layout Tool — показать маркеры применения инструмента Graphic Move;
  • Grouping Displays — показать маркеры применения инструмента Group;
  • Cutflag — показать маркеры применения инструмента Cut Notes;
  • Split Rests — показать маркеры разделения многотактовых пауз;
  • Stems/Beams — показать маркеры редактирования штилей или флажков нот.

Рассмотрим окно Quantize Setup (рис. 8.6), которое открывается кнопкой [image] (Display Quantize). Параметры, выбранные в нем, влияют только на отображение нот и не затрагивают собственно MIDI-сообщения.
В раскрывающихся списках Notes и Rests следует указать наименьшие длительности нот и пауз, которые используются для записи вашей музыки.

Рис. 8.6. Окно Quantize Setup

В окне имеется 4 флажка:

  • No Overlap — включение особого режима отображения перекрывающихся нот;
  • Syncopation — включение режима разрешения синкоп;
  • 2+2 16th Groups — включение режима группирования шестнадцатых нот;
  • Consolidate Rests — включение режима объединения двух последовательных пауз в одну (суммарной длительности).

Кнопка Restore to Staff предназначена для установки параметров окна Quantize Setup в соответствии с параметрами, выбранными в окне Score Editor.
Кроме нот вы можете оперировать огромным количеством символов нотного письма. Они расположены на 10 отдельных палитрах, доступ к которым можно получить командой Scores > Symbol Palettes. В открывшемся подменю вы увидите название каждой палитры (одна из них — Layout Palette — доступна только в страничном режиме). Здесь есть ключи смены размера и тональности, знаки артикуляции, графические символы нот и знаков альтерации, лиги и динамические нюансы, знаки трели, тремоло, арпеджиато и другие. В интересующей вас палитре можно выбрать любой символ, после чего вставить его в нужное место партитуры с помощью мыши, курсор которой в таком случае приобретает вид карандаша.
Если вы сделаете двойной щелчок слева от нотного стана, или выберете команду Scores > Staff Settings > Setup, или нажмете кнопку Get Info на панели дополнительных инструментов, то откроется окно Staff Settings, в котором можно выполнить различные установки нотного стана. На 4-х вкладках данного окна кроме основных опций имеются также опции, относящиеся к полифоническому режиму и отображению табулатур гитарных аккордов, которые в книге не анализируются. Мы не будем рассматривать это окно также по той причине, что некоторые его опции дублируются в отдельных окнах, о которых мы поговорим чуть позже.


8.3. Содержание меню Scores

В меню Scores находятся команды и подменю, имеющие непосредственное отношение к работе в окне Score Editor.
Edit Mode/ Page Mode — переключение режима редактирования нотной страницы.
Symbol Pallets — подменю вызова палитр, содержащих наборы различных символов нотного письма.
Global Settings — подменю общих установок.
Layout Settings — подменю установок, имеющих отношение к расположению элементов в окне Score Editor (для режима Page Mode).
Staff Settings — подменю установок параметров нотоносца.
Global Functions — подменю общих функций.
Layout Functions — подменю функций, имеющих отношение к расположению элементов на рабочем поле окна Score Editor.
Staff Functions — подменю функций, имеющих отношение к нотоносцу.
Auto Layout — подменю, содержащее команды оптимизации расположения элементов на рабочем поле окна Score Editor.
Align Elements — подменю, содержащее команды выравнивания расположения элементов нотоносца.
Text — подменю, содержащее команды настройки параметров текста.
Move to Voice — перемещение выделенных нот между голосами. Команда доступна, если выбран полифонический режим.
Move to Staff — перемещение выделенных нот на другой нотоносец, команда доступна, если для редактирования в окне Score Editor одновременно выбраны части, расположенные на нескольких треках.
Move to String — перемещение выделенных нот на другую струну. Команда доступна, если для нотоносца выбран режим отображения табулатур.


8.4. Запись нот с помощью мыши

После краткого знакомства с меню Scores, окном Score Editor и его инструментами попробуем записать ноты, но не с MIDI-клавиатуры, а пользуясь мышью.
Сначала создадим нотный стан и подготовим его к работе. Для этого первым делом в окне Cubase SX Project создадим MIDI-трек, на нем создадим часть (например длиной в 4 такта) и выделим ее. Станет доступной команда MIDI > Score Editor, которой мы и откроем окно Score Editor (рис. 8.7).

Рис. 8.7. Подготовлен нотный стан

Далее найдем в правой области панели дополнительных инструментов группу Layer и нажмем кнопку 1. Дело в том, что в Score Editor, как и во многих графических редакторах, итоговое изображение складывается из изображений, расположенных в отдельных слоях. По умолчанию все графические объекты находятся в слое № 1. Разнести их по разным слоям можно, пользуясь опциями категории Scores-Event Layer окна Preferences, которое открывается командой File > Preferences.
Продолжим подготовку и сделаем двойной щелчок на ключе в начале нотного стана. Откроется окно Edit Clef (рис. 8.8), в котором, пользуясь слайдером, можно выбрать один из предусмотренных теорией музыки ключей. Допустим, что нам требуется басовый ключ. Выберем его и нажмем ОК.
Теперь сделаем двойной щелчок на дроби, которой обозначен музыкальный размер (по умолчанию установлен размер 4/4). Откроется окно Edit Time Signature (рис. 8.9), в котором, следует выбрать необходимый размер.

Рис. 8.8. Окно Edit Clef

Рис. 8.9. Окно Edit Time Signature

Кнопки, имеющиеся в окне, служат для ускоренного выбора размеров 4/4 или 2/2 соответственно. Оставим 4/4 и нажмем ОК.
Нотный стан подготовлен. Теперь в окне Score Editor среди основных инструментов выберем инструмент для записи нот [image] (Insert Note). Убедимся, что на панели дополнительных инструментов выбрана нота необходимой длительности, тщательно нацелимся на нужную линейку и сделаем щелчок левой кнопкой мыши. Если с первого раза промахнетесь, то можно воспользоваться инструментом [image] (Erase) для удаления ноты или командой Edit > Undo для отмены операции по ее записи. И вот так, шаг за шагом, нота за нотой запишите необходимую партию, например, такую, как представлена на рис. 8.10.

Рис. 8.10. Записаны первые 4 такта партии

Если необходимо использовать какой-либо необычный символ ноты, выберите его в окне, которое открывается правым щелчком на ноте (рис. 8.11).

Рис. 8.11. Окно выбора символа ноты

После записи нот соответствующие объекты появятся также в окнах Key Editor и List Editor. В последнем редакторе, кроме сообщений типа Note, вы можете также увидеть сообщения нотации, не являющиеся стандартными MIDI-сообщениями. Их можно редактировать в List Editor, однако MIDI-системой они не воспринимаются. Например, вы можете написать под нотным станом примечание о динамическом оттенке исполнения рр (pianissimo), однако громкость воспроизводимых нот на самом деле не уменьшится. Этим нотатор Cubase SX уступает нотатору программы Cakewalk Overture, который способен конвертировать в MIDI-сооб-щения не только ноты, он и еще ряд символов сокращенного нотного письма.
Итак, ваше знакомство с нотатором Cubase SX состоялось, и мы завершаем главу. Тем музыкантам, которые намерены овладеть всеми возможностями Score Editor в целях его применения для подготовки партитур к изданию, рекомендуем обратиться к достаточно полному и хорошо иллюстрированному разделу Score Layout and Printing фирменного руководства пользователя.


Глава 9. Работа с MIDI-плагинами

    • Работа с MIDI-плагинами
    • 9.1. Arpache 5 — MIDI-арпеджиатор
    • 9.2. AutoPan — формирователь последовательности сообщений Control Change
    • 9.3. Chorder — формирователь аккордов заданного типа
    • 9.4. Compress — компрессор значений параметра Velocity
    • 9.5. Micro Tuner— корректор высоты звучания нот
    • 9.6. MidiEcho — многократное повторение нот, имитация эха
    • 9.7. Step Designer— паттерновый секвенсор


Работа с MIDI-плагинами

В рассматриваемой версии программы Cubase SX реализовано четырнадцать MIDI-плагинов реального времени.
1. Arpache 5 — арпеджиатор (формирователь последовательности коротких нот на основе протяженной ноты или аккорда).
2. AutoPan — формирователь последовательности сообщений об изменении значений заданного контроллера, по умолчанию установленный в режим автоматического панорамирования.
3. Chorder — формирователь аккордов заданного типа.
4. Compress — компрессор значений параметра Velocity.
5. Control — формирователь сообщений типа Control Change (сообщений о смене значений MIDI-контроллеров). С помощью одного экземпляра плагина, подключенного к MIDI-треку, можно управлять любыми восемью MIDI-контроллерами.
6. Density — регулятор "плотности" нот на треке, обеспечивающий прореживание нот или, напротив, генерацию дополнительных нот. Для редактирования доступен единственный параметр Density. При Density = 100 %, эффект не оказывает на ноты никакого влияния. Если Density < 100 %, то некоторые ноты, выбранные случайным образом, будут заглушены. При Density > 100 % будут дополнительно сформированы новые ноты.
7. Micro Tuner — точный корректор высоты звучания нот, обеспечивающий индивидуальную подстройку каждой ноты в октаве.
8. MidiEcho — многократное повторение нот, имитация эха.
9. Note 2 СС — конвертор MIDI-сообщения типа Note в сообщения типа Control Change.
10. Quantizer — квантизатор, работающий в реальном времени.
11. Step Designer — паттерновый секвенсор.
12. Track Control — контрольная панель для управления основными параметрами синтезаторов, соответствующих стандартам GS и XG.
13. Track FX — набор эффектов, идентичных тем, что доступны из секции Track Parameters инспектора, включающий в себя еще два дополнительных эффекта — смещение во времени (аналогичный параметр доступен в основной секции инспектора) и Scale Transpose (транспозиция в соответствии с тональностью композиции).
14. Transformer — эффект реального времени, возможности которого аналогичны возможностям редактора Logical Editor (см. разд. 6.5).
При работе с MIDI-плагинами как с эффектами реального времени программа в режиме воспроизведения считывает с трека MIDI-сообщения и, применяя к ним выбранный эффект, либо формирует и воспроизводит другие MIDI-сообщения, либо, наоборот, не воспроизводит часть сообщений.
Для применения Control, Density, Track Control, Note 2 CC и Track FX вполне достаточно приведенных выше кратких пояснений, смысл параметров эффекта Quantizer проанатазирован при рассмотрении настроек функции квантизации (см. разд. 6.6.1), а работа с Transformer ничем не отличается от работы с редактором Logical Editor, который рассмотрен в разд. 6.5. Оставшиеся MIDI-эффекты мы рассмотрим подробнее.
Технология подключения MIDI-эффектов к проекту подробно описана в разд. 4.1.2. Поэтому здесь мы напомним только самое главное.
С перечнем установленных MIDI-эффектов вы можете ознакомиться на вкладке MIDI Plug-ins окна Plug-in Information (рис. 9.1), которое открывается командой Devices > Plug-in Information.

Рис. 9.1. Окно Plug-in Information с перечнем установленных MIDI-эффектов

Вкладка MIDI Plug-ins организована в виде таблицы, каждая строка которой соответствует одному MIDI-эффекту. В ячейках столбцов Name, Vendor и File приведены соответственно названия эффектов, сведения о разработчике и имена файлов, в которых эффекты хранятся. Второй столбец слева содержит информацию о количестве экземпляров каждого эффекта, подключенных в данный момент к проекту. Если ячейка левого столбца отмечена галочкой, то соответствующий эффект будет доступен для подключения к MIDI-треку (в секциях Inserts и Sends инспектора и в микшере). После редактирования содержания ячеек этого столбца или инсталляции новых MIDI-эффектов необходимо нажать кнопку Update, чтобы изменения, внесенные вами, были применены к программе.
MIDI-плагины могут быть подключены к проекту двумя способами.

  • В режиме вставки как эффекты последовательного действия (в секции Inserts инспектора или в аналогичной секции микшера).
  • В режиме посыла как эффекты параллельного действия (в секции Sends инспектора или в аналогичной секции микшера).

Об особенностях таких вариантов организации работы с эффектами достаточно подробно рассказано в главе 4. У нас сложилось впечатление, что, в отличие от аудиоэффектов, MIDI-эффекты, имеющиеся в составе Cubase SX, в основном и задумывались разработчиками как эффекты последовательного действия, поэтому с ними проще работать в режиме вставки. Хотя сказанное не означает, что их нельзя подключать к проекту в режиме посыла. Просто тогда необходимо помнить о том, что управление синтезатором будет осуществляться и исходными MIDI-сообщениями, воспроизводимыми с трека, и MIDI-сообщениями, полученными в результате работы эффекта. В ряде случаев такое сочетание позволяет получить оригинальный результат (например, можно одну и ту же партию параллельно исполнять разными MIDI-инструментами, причем для одного из них применить эффект MidiEcho). Однако в некоторых ситуациях подключение MIDI-эффектов посредством секции Sends нежелательно. Например, в результате работы эффекта Micro Tuner каждую ноту можно индивидуально настроить на частоту, отличающуюся от частоты, предусмотренной равномерно темперированной шкалой. Параллельное подключение этого эффекта не имеет никакого смысла: будут звучать пары нот, расстроенных друг относительно друга.
Итак, для подключения MIDI-эффекта к MIDI-треку выберите трек из окна проекта, разверните секцию Inserts инспектора и раскройте список эффектов одного их четырех имеющихся в ней слотов (рис. 9.2).
Щелкните на необходимом эффекте, и он будет подключен к проекту. Откроется окно эффекта. Для того чтобы скрыть его или вновь отобразить на экране, можно воспользоваться маленькой кнопкой, помеченной как е и расположенной в секции Inserts инспектора рядом с раскрывающимся списком эффектов (слева вверху).

Рис. 9.2. Список MIDI-эффектов в секции Inserts инспектора

Заметим, что в Cubase SX предусмотрена возможность использования MIDI-плагинов, разработанных для программ Cakewalk Pro Audio и SONAR. Поэтому, если возможностей "родных" плагинов Cubase SX вам станет мало, скачайте программу MFX Wrapper, воспользовавшись ссылкой ftp://ftp.steinberg.net/ download/pc/ Cubase_SX/ Update_SX_102/MFX_wrapper_update_108.zip. Распакуйте файл с MFX Wrapper в папку Steinberg/Cubase SX/Components. Если на вашем компьютере установлены плагины, совместимые с Cakewalk, то они появятся на вкладке MIDI Plug-ins окна Plug-in Information и станут доступными для применения в Cubase SX. В том случае, когда при разработке "посторонних" MIDI-плагинов использованы недокументированные возможности Cakewalk/SONAR, с Cubase SX такие плагины работать не будут.
На диске, сопровождающем книгу, представлены демоверсии двух MIDI-плагинов, разработанных MusicLab, Inc.: SlicyDrummer и Fill-in Drummer.
SlicyDrummer — простой, но удобный инструмент для быстрого создания лупов ритмических партий. Луп конструируется путем объединения отдельных слоев. В каждом слое находится паттерн с фрагментом партии того или иного ударного инструмента. Плагин Fill-in Drummer специально предназначен для создания барабанных вступлений, заполнений и окончаний и позволяет существенно разнообразить ритмические партии. Профессиональные версии плагинов вы найдете на сайте www.rausiclab.com фирмы MusicLab, Inc.
А теперь перейдем к более или менее детальному изучению MIDI-плагинов, имеющихся в Cubase SX.


9.1. Arpache 5— MIDI-арпеджиатор

Первым в списке MIDI-эффектов числится Arpache 5 — эффект, хорошо известный музыкантам как прием игры арпеджио. На рис. 9.3 представлено окно эффекта Arpache 5.

Рис. 9.3. Окно эффекта Arpache 5

Можно изучать этот и другие MIDI-эффекты, прослушивая результаты их применения к различным исходным MIDI-партиям, но уловить таким способом суть эффекта будет непросто. Мы неоднократно говорили уже о том, что в Cubase SX основным способом использования MIDI-эффектов является их применение в реальном времени. Но, к счастью, в программе есть и средство, пользуясь которым, можно пересчитать данные на треке в соответствии с алгоритмом подключенного эффекта. Речь идет о команде главного меню MIDI > Merge MIDI in Loop. Команда доступна в том случае, когда вы работаете в окне проекта. Она действует на MIDI-данные, относящиеся к выделенному треку и расположенные в пределах интервала, ограниченного левым и правым локаторами. Причем команда сработает (данные будут пересчитаны) лишь в том случае, когда для трека выбран один из имеющихся выходных портов.
Выполнив все перечисленные условия, выберите команду MIDI > Merge MIDI in Loop. Откроется окно MIDI Merge Options (рис. 9.4). В окне, во-первых, следует выбрать те эффекты, которые программа будет учитывать при пересчете данных. Если установлен лишь флажок Include Inserts, то будут учитываться только эффекты, подключенные в режиме вставки (например, в секции Inserts инспектора). Установленный флажок Include Sends означает, что будут также учитываться и эффекты, подключенные в режиме посыла (например, в секции Sends). Во-вторых, вы должны определить, как следует поступить с исходными данными после завершения пересчета. Для того чтобы они были удалены, нужно установить флажок Erase Destination. В данном случае есть смысл установить флажки в соответствии с рис. 9.4 и нажать ОК.

Рис. 9.4. Диалоговое окно MIDI Merge Options

После применения команды Merge MIDI in Loop можно "заглянуть" на трек с помощью любого редактора MIDI-данных, например Key Editor, с тем, чтобы сравнить результат работы эффекта и исходный материал. Согласитесь, что только так можно в деталях разобраться в тонкостях функционирования MIDI-эффектов. Применим рассмотренный метод для изучения эффекта Arpache 5. Разумеется, использование эффекта имеет смысл только тогда, когда обработке им подвергается не единственная нота, а аккорд. Однако для того чтобы результаты воздействия эффекта при выборе различных значений его параметров были заметнее, сначала рассмотрим простой пример. Запишем единственную ноту до (С4). В окне Key Editor это будет выглядеть так, как показано на рис. 9.5.
Применим эффект Arpache 5 с параметрами, установленными в соответствии с рис. 9.3. Результат представлен на рис. 9.6.
Из рисунка видно, что суть эффекта состоит в поочередном взятии нескольких нот, определенным образом связанных с исходной нотой. Так играют на арфе. Термин "арпеджио" и означает — "подобно арфе".
В окне Arpache 5 можно выбрать ряд параметров исполнения арпеджио. В группе Playmode расположены кнопки, управляющие порядком следования нот в арпеджио:
— восходящее арпеджио (Up, Up);
— нисходящее арпеджио (Down, Down);

Рис. 9.5. Нота С4 в окне Key Editor

Рис. 9.6.Результат применения эффекта Arpache 5 к ноте С4, длительностью в один такт (режим Up, Up)

Рис. 9.7. Результат применения эффекта Arpache 5 к ноте С4 (режим Up, Down)

Рис. 9.8. Результат применения эффекта Arpache 5 с включенной опцией THRU

Рис. 9.9. Результат применения эффекта Arpache 5 (параметр Semi-Range = 24)

Рис. 9.10. Результат применения эффекта Arpache 5 к аккорду До мажор, сыгранному целыми нотами

— восходяще-нисходящее арпеджио (Up, Down);
— арпеджио со случайным чередованием шагов вверх и вниз;
— арпеджио, заданное пользователем;
— кнопка включения режима, при котором порядок взятия нот арпеджио определяется пользователем. Сравните рис. 9.6 и рис. 9.7, на которых изображены результаты применения эффекта при нажатых кнопках [image] (Up, Up) и [image] (Up, Down) соответственно, и вам станет ясно, на что влияют эти кнопки.
Если включена кнопка [image] то в части на треке, наряду с нотами, созданными MlUl-арпеджиатором, будут сохранены и ноты, записанные вами до применения эффекта Arpache 5, как показано на рис. 9.8. Исходные ноты словно "проникают" сквозь эффект.
В поле Quantize в диапазоне от тридцать второй триоли до целой с точкой длительности выбирают величину шага тактовой сетки, к узлам которой привязываются начала нот в арпеджио. В поле Length в тех же пределах выбирают длительность нот. Если, например, задать Quantize = 8, a Length = 16, то арпеджио будет сыграно шестнадцатыми нотами, начала которых совпадут с началами восьмых долей такта. Если Length = Quantize, то арпеджио исполняется связно (легато), если Length < Quantize — отрывисто (стаккато).
В поле Semi-Range указывается диапазон арпеджио (количество полутонов в пределах от 6 до 116). Рисунки 9.6 — 9.8 получены при условии, что Semi-Range = 36, т. е. диапазон арпеджио составлял 3 октавы. Если установить Semi-Range = 24 и применить эффект, то отпечатки клавиш в окне Key Editor будут располагаться так, как показано на рис. 9.9.
Конечно, эффект арпеджио приобретает реальный смысл в том случае, когда им обрабатывается не последовательность одиночных нот, а последовательность аккордов. На рис. 9.10 представлен пример применения эффекта к аккорду До мажор.
Из рисунка видно, как именно исполняется арпеджио: поочередно берутся входящие в аккорд ноты двух соседних октав. Диапазон арпеджио в данном случае был установлен равным 23 полутонам (Semi-Range = 23).
Кнопка [image] в нажатом состоянии изменяет свой вид — [image] , и только в этом случае становятся доступными кнопка [image] и группа Play Order. В группе Play Urder находятся 8 переключателей, с помощью которых можно задать пользовательский порядок исполнения арпеджио, при котором, в частности, следующий цикл арпеджио будет начинаться от заданной ноты. Каждый переключатель ассоциирован с одним из восьми очередных узлов временной (тактовой) сетки: первый переключатель — с первым узлом, второй — со вторым и т. д. Если все переключатели находятся в состоянии Off, то не будет сформирована ни одна нота. А если, например, набрать в полях переключателей группы Play Order последовательность чисел 12344321, то результат применения эффекта к аккорду До мажор (длительностью в 2 такта) будет таким, как показано на рис. 9.11.

Рис. 9.11. Эффект применен к аккорду До мажор, а в группе Play Order набрана последовательность 12344321

Для того чтобы помочь вам лучше уяснить смысл чисел, набираемых в группе Play Order, приведем еще один пример. На рис. 9.12 показан результат применения эффекта к аккорду До мажор при условии, что в группе Play Order набрана последовательность 21344312.
На рис. 9.12 хорошо видно, что в начале первого элементарного цикла арпеджио (первая половина первого такта) сначала берется вторая нота аккорда, а затем первая, а в конце цикла — сначала первая нота, а потом вторая. Именно такой порядок и задает последовательность 21344312.
В раскрывающемся списке Presets вы найдете готовые пресеты. Если захотите сохранить для будущего использования какие-то понравившиеся вам сочетания параметров эффекта, нажмите маленькую кнопку, помеченную символом +. Откроется окно, в котором следует ввести имя нового пресета, после чего нажать ОК. В списке Presets появится новая строка. Для удаления ненужного пресета выберите его в списке Presets и нажмите кнопку, помеченную символом —. Аналогичным образом организована работа с пресетами и в окнах остальных эффектов.

Рис. 9.12. Эффект применен к аккорду До мажор, а в группе Play Order набрана последовательность 21344312

Основное назначение рассматриваемого эффекта состоит в том, чтобы автоматически формировать партии с разнообразными ритмическими рисунками, мелодическая составляющая которых основана на заранее записанной последовательности аккордов.
Очень сложные, практически неповторяющиеся ритмические рисунки можно получить путем последовательного включения нескольких экземпляров эффекта, в каждом из которых выбрано свое собственное сочетание параметров.
В заключение дадим совет. Не применяйте эффект ко всему треку, на котором записана мелодия. В противном случае, арпеджио будет строиться на всех звуках мелодии, в том числе, и на неаккордовых. В сочетании с гармонией аккомпанемента это будет звучать фальшиво. Что же делать? Предлагаем три варианта ответа на этот вопрос.
1. Поочередно выделяйте фрагменты, не содержащие неаккордовых звуков, и для каждого них применяйте эффект.
2. Применяйте эффект к треку, на котором у вас записана партия одного из аккомпанирующих инструментов.
3. Запишите на отдельный трек непрерывную последовательность аккордов. С этим треком и экспериментируйте.
И, конечно, обязательно контролируйте на слух получающийся результат.


9.2. AutoPan — формирователь последовательности сообщений Control Change

Судя по названию следующего MIDI-эффекта (AutoPan, рис. 9.13), он предназначен для автоматического перемещения по стереопанораме кажущегося MIDI-источника звука. На самом деле, автопанорамирование — лишь одна из задач, с которой в состоянии справиться эффект, а его реальные возможности значительно шире.

Рис. 9.13. Окно эффекта AutoPan

В принципе, эффект представляет собой виртуальный функциональный низкочастотный генератор (LFO), который способен вырабатывать сигналы различной формы (синусоида, последовательности прямоугольных и пилообразных импульсов, хаотические колебания) и с помощью этих сигналов управлять параметрами синтеза звука (значениями контроллеров). Вероятно, выбор названия для эффекта обусловлен тем, что по умолчанию он настроен на управление панорамой.
Рассмотрим интерфейс окна эффекта. В его верхней части расположены кнопки выбора формы управляющего сигнала, достаточно наглядно обозначенные и поэтому не требующие дополнительных пояснений.
Значения нескольких параметров вводятся в соответствующих полях. Делается это одним из традиционных для Cubase SX способов: набором числа с компьютерной клавиатуры, щелчками на стрелочках, расположенных в правой части поля, или перемещением с помощью мыши горизонтальной диаграммы голубого цвета, которая, если щелкнуть на ней, превращается в слайдер.
В поле Period вводится значение периода колебаний. Относительно малые значения времени отображаются как доли такта, большие — в сотнях и тысячах тиков.
В поле Density вводится значение параметра, обозначенного как "плотность", фактически определяющего соотношение между длительностями положительной и отрицательной полуволн управляющего сигнала. В частности, для управляющего сигнала в виде последовательности прямоугольных импульсов этот параметр имеет смысл скважности. Под скважностью понимается отношение периода последовательности к длительности импульса. Например, в режиме автопанорамирования этот параметр определяет то, в течение какой части периода звучащая точка будет находиться в левой части выбранного участка панорамы, а в течение какой — в правой.
Сам диапазон изменения модулируемого параметра (в частности, протяженность панорамы) задается в полях Min и Мах.
Чем, кроме панорамы, может управлять эффект? Ответ на этот вопрос можно получить, поработав слайдером поля ввода Controller. Вы увидите, как в поле будут поочередно появляться названия или номера контроллеров. В частности, там есть и контроллер № 10 (Pan).
Поле Amp Mod доступно не всегда, а только при выборе тех контроллеров, для которых есть смысл управлять глубиной амплитудной модуляции.
В раскрывающемся списке Presets вы найдете три группы готовых пресетов. В первой (Pan) сосредоточены пресеты, связанные с автопанорамированием, во второй (Filter) — с частотной фильтрацией, в третьей (Expresion) — с динамическим управлением экспрессией (обычно путем изменения громкости). Будут ли работать все пресеты, зависит от того, какие контроллеры из числа задействованных в них поддерживаются синтезатором, имеющимся в вашей звуковой карте, или виртуальным синтезатором, подключенным к проекту.


9.3. Chorder— формирователь аккордов заданного типа

Chorder — MIDI-процессор аккордов, позволяющий различными способами назначать аккорды на отдельные клавиши MIDI-клавиатуры. Окно эффекта представлено на рис. 9.14.

Рис. 9.14. Окно эффекта Chorder

Один из 3-х возможных режимов работы плагина выбирается нажатием на соответствующую кнопку: Normal, Octave или Global.
В режиме Normal (рис. 9.15) вы можете назначить для каждой клавиши на MIDI-клавиатуре свой (произвольный) аккорд. Делается это следующим образом:

  • щелкнув на клавише нижней виртуальной клавиатуры (Trigger Note), выберите ноту (клавишу), для которой вы хотите назначить аккорд;
  • установите желательный аккорд для этой ноты, поочередно щелкая на клавишах верхней виртуальной клавиатуры (Chord Setup), при этом учтите, что выделение клавиши снимается повторным щелчком на ней;
  • повторите описанные действия с любыми другими клавишами, которые вы хотите использовать.

Если теперь на MIDI-клавиатуре, подключенной к звуковой карте и настроенной на работу с данным треком, нажимать клавиши, которые вы связали с аккордами, то вместо звуков отдельных нот будут слышны назначенные аккорды. Приведем пример. Если вы сделаете все так, как показано на рис. 9.15, а, то, нажав на подключенной MIDI-клавиатуре клавишу СЗ, вы услышите звучание аккорда До мажор (С). Важно понимать, что с каждой клавишей можно связать совершенно любой аккорд! Например, на рис. 9.15, б с той же клавишей СЗ связан аккорд ля минор (Аm).
Честно говоря, полезность такого режима вызывает некоторое сомнение. Получается, что нужно заранее вручную установить соответствие каждой клавиши определенному аккорду, сохранить результаты работы в пресете и, главное, запомнить это соответствие (не в памяти компьютера, а -в своей собственной!), с тем чтобы в будущем извлекать аккорды, нажимая на одну из клавиш. Не проще ли в нужный момент взять на клавиатуре необходимый аккорд традиционным способом?
У рассматриваемого режима есть и еще один не менее экзотический способ применения. Если в часть на треке, к которому подключен MIDI-плагин Chorder, заранее записать последовательность нот, то при воспроизведении вместо них будут звучать аккорды, ассоциированные с соответствующими клавишами. Например, если установки выполнены в соответствии с рис. 9.15, б, то всякий раз, когда на треке встретится нота СЗ, будет звучать аккорд Ат.
Напомним, что командой главного меню MIDI > Merge MIDI in Loop эффект можно применить не в реальном времени: ноты, заранее записанные в часть на трек, можно заменить на соответствующие им аккорды.
Основное условие успешного использования MIDI-плагина Chorder в режиме Normal — знание вами принципов построения аккордов. Начинающие музыканты-любители ухитряются сводить всю гармонию своих композиций к трем типам аккордов: мажорным трезвучиям, минорным трезвучиям и доминантсептаккордам. Конечно, такой гармонический состав не в состоянии украсить аккомпанемент. Сравните: программа-аранжировщик, YamahaVisual Arranger, которую многие считают игрушкой, предоставляет пользователю выбор из аккордов 30-и типов, а более серьезный автоаранжировщик Band-in-a-Box позволяет оперировать аккордами 123-х типов. Количество типов аккордов, их расширений и обращений, которые способен автоматически формировать гитарный MIDI-плагин Rhythm'n'Chords 2 Pro, рассмотренный нами в книгах [7, 9, И, 46], не поддается счету.

Рис. 9.15. С клавишей СЗ связан аккорд С (а) или аккорд Ат (б)

Если вы все-таки решите использовать MIDI-плагин Chorder в режиме Normal, вам может пригодиться справочник по аккордам основных типов, построенных от каждой из нот (рис. 9.16).
Перейдем к рассмотрению режима Octave. Режим Octave подобен режиму Normal, но вы можете назначить только один аккорд для каждой MIDI-клавиши в октаве (т. е. всего двенадцать различных аккордов). Для выбора MIDI-клавиши по-прежнему служит нижняя виртуальная клавиатура (Trigger Note), которая в режиме Octave состоит из клавиш только одной октавы (рис. 9.17).

Рис. 9.16. Аккорды основных типов

Рис. 9.16. Аккорды основных типов (продолжение)

Рис. 9.17. Окно MIDI-плагина Chorder в режиме Octave

Желательный аккорд для выбранной клавиши набирается на клавишах верхней виртуальной клавиатуры (Chord Setup).
Когда вы, например, играете ноту С в любой октаве (это может быть СЗ, С4 или соответствующая нота любой другой октавы), будет слышен аккорд, связанный с клавишей С. Если выполнить установки, представленные на рис. 9.17, то таким аккордом будет До мажор (С). Правда, аккорды все же строятся с учетом принадлежности нажатой клавиши к той или иной октаве. Например, если в данном случае вы нажмете MIDI-клавишу СЗ, то аккорд будет составлен из нот СЗ, ЕЗ, G3. Если же нажата MIDI-клавиша С4, то в аккорде прозвучат ноты С4, Е4, G4.
Перейдем к режиму Global использования MIDI-плагина Chorder. В режиме Global (рис. 9.18) можно выбрать аккорд единственного типа, который и будет исполняться с соответствующим смещением по высоте, когда вы станете нажимать различные клавиши MIDI-клавиатуры.
Пример, приведенный на рис. 9.18 соответствует такой ситуации: для любой клавиши назначено мажорное трезвучие: терцовый тон отстоит от основного на 4 полутона, квинтовый — на 7 полутонов. Это означает, что при нажатии на клавишу С будет сыгран аккорд С, при нажатии на клавишу С* — аккорд С* и т. д. Если же на клавишах виртуальной клавиатуры Chord Setup набрать минорное трезвучие, то именно аккорд этого типа и будет извлекаться: при нажатии на клавишу С будет сыгран аккорд Ст, при нажатии на клавишу С* — аккорд С#т, при нажатии на клавишу D — аккорд Dm и т. д.

Рис. 9.18. Окно MIDI-плагина Chorder в режиме Global, набрано мажорное трезвучие

В левом нижнем углу окна плагина расположена группа, которая в руководстве пользователя называется Switch Setup. С помощью опций группы с каждой MIDI-клавишей можно связать до восьми различных аккордов: т. е. максимум 8 различных аккордов в режиме Global, 12x8 аккордов в режиме Octave и 128 х 8 аккордов в режиме Normal.
По умолчанию нажата кнопка [image] отключающая остальные опции группы Switch Setup (т. е. на каждую клавишу формируется только по одному аккорду). Именно в этом режиме мы и изучали работу плагина до сих пор.
Выбор одного из аккордов, ассоциированных с данной клавишей, может производиться двумя способами, которым соответствуют кнопки [image] и [image].. Если нажата кнопка [image] то выбор аккорда осуществляется в зависимости от значения параметра Velocity — скорости, с которой "вдавливается" клавиша, когда вы ее нажимаете.
Если нажата кнопка [image] |, то выбор аккорда осуществляется в зависимости от соотношения номеров двух поочередно нажатых MIDI-клавиш.
В поле ввода Use вы должны назначить максимальное количество аккордов, ассоциируемых с одной клавишей. Например, если в поле Use ввести число 8, то нажатием на одну клавишу можно будет, в принципе, сформировать 8 аккордов. По мере увеличения числа в поле Use становятся доступными очередные кнопки Zone Select. При Use = 8 доступны все 8 кнопок.
Рассмотрим программирование плагина для управления в зависимости от параметра Velocity (при нажатой кнопке [image] . Полный диапазон значений Velocity (1—127) разделен на зоны согласно числу, введенному в поле Use. Например, если вы установите Use = 2, то будут созданы две зоны значений Velocity: 1—63 и 64—127. Нажмете на клавишу потихоньку (Velocity < 64) — будет извлечен первый аккорд (тот, который вы ассоциируете с клавишей при нажатой кнопке Zone Select № 1). Ударите по клавише энергично (Velocity > 64) — прозвучит второй аккорд (тот, который вы ассоциируете с клавишей при нажатой кнопке Zone Select № 2). Максимальное число зон значений Velocity 8: 1-15, 16-31, 32-47, 48-63, 64-79, 80-95, 96-111, 112—127. Каждой зоне соответствует одна из 8 кнопок Zone Select. Теоретически вы можете запрограммировать MIDI-клавишу на формирование одного из 8 аккордов. Вопрос только в том, сможете ли вы столь строго дозировать силу своих ударов по клавишам, чтобы осуществлять безошибочный ввод аккордов.
Второй способ извлечения различных аккордов надежнее. Вам не потребуется годами оттачивать специфическую технику игры на MIDI-клавиатуре, как при управлении за счет изменения Velocity. Нажмите кнопку [image] и выбор аккорда будет осуществляться поочередным нажатием двух MIDI-клавиш. В этом случае клавиатуру тоже сначала нужно запрограммировать: каждой кнопке Zone Select нужно сопоставить свой аккорд. Нажмите кнопку № 1 и на виртуальной клавиатуре Chord Setup наберите первый аккорд, затем нажмите кнопку № 2 и на виртуальной клавиатуре Chord Setup наберите второй аккорд и т. д. При игре для извлечения определенного аккорда нужно последовательно нажимать на две MIDI-клавиши. Та клавиша, которая будет нажата первой, определит тональность аккорда (ноту, от которой он будет построен — Root key). Следом нужно нажать клавишу, расположенную правее ранее нажатой. Она определит тип (номер) аккорда. Здесь правило соответствия несложно: расстояние в полутонах между парой нажатых клавиш соответствует номеру кнопки Zone Select. Рассмотрим пример.
Допустим, что кнопке Zone Select № 1 вы сопоставили мажорное трезвучие (Major Chords), набрав на виртуальной клавиатуре Chord Setup ноты С, Е, G, кнопке № 2 — минорное трезвучие (Minor Chords), набрав С, D*, G, кнопке № 3 — доминантсептаккорд (7th Chords), набрав С, Е, G, А*. Тогда, последовательно нажав на MIDI-клавиатуре клавиши С и С*, вы сыграете аккорд С. Нажав С и D, сыграете СП1. Нажав С и D*, сыграете Су. А вот что произойдет, если вы захотите построить аккорды от ноты ми (Е): нажав клавиши Е и F, вы сыграете аккорд Е, нажав Е и F*, сыграете аккорд Ет, нажав Е и G, сыграете аккорд Еу.
Получается, что таким способом можно запрограммировать клавиатуру на извлечение аккордов восьми типов. Этого, в принципе, уже хватит для того, чтобы гармония аккомпанемента выглядела достаточно ярко.
Плохо только одно: такая двухклавишная процедура выбора аккордов не совпадает с теми процедурами, которые уже стали фактическим стандартом. Например, в некоторых синтезаторах фирмы Yamaha, мажорный аккорд извлекается нажатием на клавишу основного тона, для извлечения же минорного аккорда нужно дополнительно нажать ближайшую слева черную клавишу, а для извлечения септаккорда — ближайшую слева белую клавишу.
В раскрывающемся списке Presets имеются две группы пресетов. В группе Chord Menu содержатся варианты настройки плагина. Ценность представляет группа One Chord, где сосредоточены пресеты, позволяющие автоматически набрать аккорды восьми типов.
В целом, как вы видите, плагин позволяет реализовать довольно гибкие технологии формирования аккордов и, в первую очередь, может быть полезен тем пользователям, которые не очень хорошо знакомы с теорией гармонии и испытывают трудности при построении аккордов.


9.4. Compress — компрессор значений параметра Velocity

Каждый компьютерный музыкант знает, сколько времени занимает редактирование Velocity в MIDI-сообщениях, особенно, если треки записаны в результате игры на чувствительной к этому параметру MIDI-клавиатуре. Отвлекаясь от творчества, вы вынуждены заниматься монотонной работой, "перелопачивать" гигантские массивы нот, подправляя Velocity то здесь, то там. Так вот, MIDI-плагин реального времени Compress работает именно с Velocity и позволяет вам реализовать динамическую обработку "уровня громкости" MIDI-сообщений.
Compress представляет собой аналог компрессора (или экспандера) динамического диапазона (см. разд. 1.10.2). Настоящие компрессоры и экспандеры воздействуют на амплитуду звуковых колебаний, а в результате такого воздействия у слушателя создается желаемое впечатление об изменении громкости звука. MIDI-эффект воздействует не на отсчеты оцифрованного звука, а на параметр Velocity MIDI-сообщений типа Note.
Доступ к элементам регулировки параметров плагина Compress, в отличие от многих других MIDI-плагинов, входящих в комплект Cubase SX, осуществляется не из специального окна. Как вы видите на рис. 9.19, при подключении эффекта к проекту соответствующие регуляторы встраиваются непосредственно в поле Inserts (или поле Sends) инспектора.

Рис. 9.19. Секция Inserts инспектора с подключенным плагином Compress

Действие устройства динамической обработки зависит от вида его амплитудной характеристики (зависимости амплитуды выходного сигнала от амплитуды сигнала на входе устройства). Амплитудная характеристика в простейшем случае может быть задана всего несколькими параметрами: порогом срабатывания (Threshold), коэффициентами компрессии (или экспандирования) (Ratio) и коэффициентом компенсационного усиления (Gain).
На сообщения, величина Velocity которых не превышает установленного значения Threshold, эффект никак не воздействует. Обрабатываются только те сообщения, у которых Velocity > Threshold. Результат обработки зависит от значения параметра Ratio. Если Ratio больше единицы, то значения Velocity на выходе эффекта уменьшаются, тем самым, сжимается их динамический диапазон. Так реализуется компрессия. Например, при Ratio = 2:1 и Threshold = 80 те значения Velocity, которые на входе эффекта превышают 80 единиц, на выходе эффекта будут уменьшены в 2 раза. Если, скажем, в такой ситуации значения Velocity всех входных сообщений составляют 100 единиц, то на выходе эффекта все они станут равными 90 единицам (80 + 20/2).
Для расширения динамического диапазона (реализации экспандирования), наоборот, следует установить Ratio меньше единицы. Например, при Ratio = 1:2 те значения, для Velocity которых выполняется неравенство Velocity > Threshold, на выходе эффекта будут больше, чем на входе.
При внешне идентичных амплитудных характеристиках плагина Compress и реального прибора, обрабатывающего звуковой сигнал, результаты их работы на слух будут восприниматься по-разному. Дело заключается, в частности, в том, что амплитудные характеристики реальных приборов строятся в логарифмическом масштабе, а плагина Compress — в линейном.
Заметим, что в книгах [11, 46] мы подробно описачи MIDI-плагин MusicLab (www.musiclab.com) VeloMaster, который обладает наглядным интерфейсом и объединяет в себе MIDI-аналоги всех мыслимых устройств динамической обработки: компрессора, экспандера, лимитера, гейта, а также всевозможных их комбинаций.


9.5. Micro Tuner— корректор высоты звучания нот

Для того чтобы лучше оценить пользу, которую может принести плагин Micro Tuner, поговорим сначала о проблеме музыкального строя. Музыкальным строем называется соотношение высот звуков музыкальной системы. В свою очередь музыкальная система представляет собой ряд звуков, находящихся между собой в определенных высотных взаимоотношениях.
Наиболее распространенный ныне равномерно темперированный строй предусматривает деление всего диапазона инструмента на промежутки, граничные частоты которых относятся одна к другой как 2:1. Этот музыкальный интервал назван октавой. Каждая октава разделена на 12 равных интервалов, соответствующих 12 клавишам октавы фортепиано, из которых 7 белых и 5 черных. Интервал между соседними нотами составляет полтона.
Для удобства отсчета отклонений высоты тона логарифм отношения частот, составляющих полутон, разделен на 100 равных частей. Получившуюся логарифмическую единицу называют центом.
Однако музыкальные практики и теоретики не сразу пришли к такой системе, да и в наши дни не все однозначно согласны с ней. В чем же здесь дело?
Дело в тех таинственных, загадочных, непознанных свойствах человеческого сознания, без существования которых никогда бы не возникло явление, которое мы называем музыкой. Дело в самом человеке, в восприятии им звуков разной высоты. Дело в том, что не из любых звуков можно составить мелодию, доставляющую человеку удовольствие.
Еще в давние времена люди заметили, что для слуха приятны только сочетания звуков с определенным соотношением частот. Для слуха древних европейцев, например, наиболее благозвучными оказались сочетания звуков, частоты которых относятся друг к другу как 4:5 или 5:6. Соответственно, музыканты старались настроить свои инструменты так, чтобы все звуки, издаваемые ими, находились в таких соотношениях. Восьмая нота звучала "так же", как первая, и вообще, любая последовательность повторялась через каждые семь нот. С тех пор и принято весь музыкальный ряд делить на октавы. В результате между двумя соседними нотами, частоты которых отличаются в два раза, оказывалось 6 звуков, образующих трезвучия. Это те ноты, которые в наши дни соответствуют белым клавишам рояля. Интервал между соседними нотами был разным и мог составлять либо тон, либо полтона.
Такая неравномерность звукоряда доставляла музыкантам много неудобств. Действительно, если вы сочините некую мелодию, которая играется только на белых клавишах рояля, начиная с до, то сочетание звуков будет, в основном, приятно слуху. Но как сыграть только на белых клавишах ту же самую мелодию, начав ее, например, с ре? Или вопрос еще забавнее: как взять мажорное трезвучие от ноты ре (состоящее из нот D, F*, А), пользуясь только белыми клавишами? Никак.
Пытаясь устранить подобные трудности, древние музыканты догадались вставить дополнительные ноты в тех местах, где интервал между нотами равнялся одному тону. Теперь нот всего стало двенадцать, а интервал между любыми двумя из них стал примерно равен полутону. Взгляните на MIDI-клавиатуру: основные ноты на ней белого цвета, а дополнительные — черного. Так появилась возможность играть любую мелодию начиная с любой ноты (в любой тональности).
Однако и после введения дополнительных нот не все проблемы оказались решены. Например, получилось, что целый тон равнялся отношению частот 9/8 или 10/9, а полтона 16/15, то есть арифметически два полутона не равнялись одному целому тону. Поэтому музыканты вынуждены были для каждой мелодии подбирать место вставки дополнительных звуков на слух, а при переходе из тональности в тональность все равно требовалась подстройка инструмента.
Как же следует расположить ноты, чтобы вообще не перестраивать инструмент? Считается, что ответ на этот вопрос найден Пифагором. Он заметил, что отношение частот двух соседних нот всегда отличается, а отношение частот двух нот, отстоящих друг от дружки на четыре позиции, наоборот, всегда постоянно и составляет 3/2. Такое созвучие теперь называют квинтой. Взяв квинту за основу, Пифагор вывел музыкальную формулу fn = (3/2)nf, где f— частота базовой ноты, от которой ведется отсчет, n — порядковый номер ноты, частоту которой надо найти, fn — искомое значение. В результате последовательного применения этой формулы получаются звуки, отстоящие друг от друга на квинту. В этом ряду есть все ноты звукоряда. И хотя они относятся к разным октавам, но, поделив или умножив частоту нужного звука на два, можно перенести его в соседнюю октаву. Повторяя операцию деления (или умножения) несколько раз, можно заполнить весь диапазон инструмента.
Однако при детальном анализе становится ясно, что некоторые ноты в пифагоровом строе чуть-чуть отличаются по частоте от нот природного строя. Эти различия и являются той ценой, которую приходится платить за удобство — отсутствие необходимости перенастроек инструмента. Различия практически незаметны на слух, но они существуют.
Кроме того, получается, что частоты дополнительных нот, полученных повышением на полтона одной основной ноты и понижением на полтона соседней (справа, если иметь в виду клавиши) основной ноты (т. е. бемолей и диезов), которые должны совпадать, в пифагоровом строе не совпадают. И это различие настолько невелико, что проблема решается настройкой инструмента, на некое среднее значение.
Однако возникла более серьезная проблема: если звукоряд строить по формуле Пифагора, то целое число квинт не укладывается в целое число октав. Такое несоответствие получило название "пифагорова комма". Пифагорова комма — не только кажущийся математический парадокс. Главное, что и при пифагоровой системе невозможно играть в произвольной тональности, не фальшивя.
Особенно сильно страдали от этого органисты. Ведь настройка органа — чрезвычайно трудоемкий процесс, лишний раз этого делать не захочется. Поэтому они шли на компромиссное решение — настройку органа только для игры в нескольких распространенных тональностях. Не случайно и решена эта проблема была именно органистом Андреасом Веркмейстером.
Веркмейстер поступил просто: вместо природного звукоряда создал свой собственный, положив в основу системы три постулата:
1. Отношение частот одинаковых нот в соседних октавах должно быть равно двум.
2. Между этими частотами должно лежать ровно двенадцать нот, по числу полутонов в октаве.
3. Все полутона должны быть равны.
В соответствии с этими постулатами Веркмейстер разбил октаву на двенадцать абсолютно равных полутонов. Такой звукоряд был назван темперированным. Слово темперация (от лат. temperatio — правильное соотношение, соразмерность) в музыке означает выравнивание интервальных отношений между ступенями звуковысотной системы. Сущность темперации состоит в небольших изменениях величины интервалов по сравнению с их акустически точной величиной (по натуральному звукоряду). В 12-ступенном равномерно темперированном строе все чистые квинты уменьшены на 1/12 пифагоровой коммы; от этого строй стал замкнутым, октава оказалась разделенной на 12 равных полутонов и все одноименные интервалы стали одинаковыми по величине.
Сразу решилось множество проблем. Исчезла пифагорова комма, стало возможным абсолютно свободно переходить из одной тональности в другую и начинать мелодию с любой ноты.
Однако за удобство настройки инструментов и в этой системе приходится платить. Если в октаве Пифагора слегка фальшивили только три ноты, то в октаве Веркмейстера вообще не сохранилось ни одной ноты природного звукоряда. Можно сказать, что абсолютно все ноты в ней фальшивые, поэтому их звучание, в принципе, не может доставлять человеку максимального удовольствия. Правда, каждая нота фальшивит чуть-чуть, но искушенному слуху это заметно, да и неискушенный, наверное, на уровне подсознания тоже ощущает такую неидеальность. Система прижилась. Что бы мы там ни думали о соотношении наших врожденных и приобретенных свойств, но воспитание и привычка все же — великие силы. Многие цивилизованные народы, населяющие Землю, едва ли не в полном составе, ныне слушают музыку, составленную из фальшивых звуков, и радуются. Не последняя роль в этом принадлежит великому Баху, поспособствовавшему утверждению темперированного звукоряда тем, что он первым написал цикл произведений в двенадцати мажорных и двенадцати минорных тональностях.
Споры о ценности того или иного строя продолжаются, хотя они, пожалуй, носят чисто теоретический и философский характер. Многие ли любители музыки смогут отличить ре-диез от ми-бемоля в Пифагоровом или чистом (натуральном) строе? Существует мнение, что равномерная темперация — это своеобразный теоретический компромисс, позволяющий наиболее удобным способом использовать возможности инструментов с фиксированным строем. Вместе с тем, без инструментального сопровождения певцу труднее петь в темперированном строе, чем в чистом. На смычковых инструментах, на которых нет ладов, можно играть в любом строе. Получается, что разница в строях важна для исполнителей высшего класса и наиболее продвинутых слушателей.
Однако MIDI-технология позволяет осуществить настройку инструмента любым мыслимым способом, установить программным путем любой сколь угодно экзотический лад. При этом, нажимая на MIDI-клавиши, мы можем услышать звуки, частоты которых настроены нужным нам образом. И в Cubase SX существует средство, способное удовлетворить поклонников любого строя. Вы уже, наверное, догадались, что таким средством является плагин Micro Tuner (рис. 9.20).
Интерфейс плагина Micro Tuner предельно прост, и работа с ним тоже проста. Два ряда полей ввода символизируют клавиши одной октавы. Нижний ряд соответствует белым клавишам, верхний — черным. Левое поле ввода соответствует ноте С. В каждом поле можно ввести число, означающее величину расстройки соответствующей ноты (в центах) по отношению к равномерно темперированной шкале. Главное, нужно знать, какие именно числа вводить. В качестве справочного пособия можно использовать содержимое списка пресетов. Здесь перечислены названия ряда классических и экспериментальных строев.

Рис. 9.20. Окно плагина Micro Tuner

Фактически плагин представляет собой удобное средство для формирования MIDI-сообщений RPN 1 (Fine Tuning) об изменении значений контроллера точной подстройки строя синтезатора (см. разд. 1.2.3).
В раскрывающемся списке Convert нужно выбрать характер синтезатора, с которым предстоит работать плагину. Выбор осуществляется между виртуальным и аппаратным синтезаторами, которые по-разному воспринимают сообщения о величине точной подстройки высоты тона.


9.6. MidiEcho — многократное повторение нот, имитация эха

MIDI-эффект MidiEcho (рис. 9.21) предназначен для создания ряда повторений ноты и имитирует эхо.

Рис. 9.21. Окно плагина MidiEcho

Громкость повторяемых нот может отличаться от громкости исходной ноты. Повторяемые ноты могут быть транспонированы относительно исходных по высоте.
Рассмотрим параметры, доступные для редактирования в окне эффекта MidiEcho.
Quantize — шаг квантизации. К нему будут привязаны повторяемые MIDI-сообщения. Например, если установить Quantize = 4, то все эхо-сообщения, начиная со второго, будут повторяться через четвертную долю такта независимо от времени поступления исходных сообщений и значения параметра Echo-Quant (см. рис. 9.22). Для того чтобы обеспечить ритмизированную задержку, при которой повторяемые сигналы в точности совпадают с долями такта, удобнее вводить значения Quantize с помощью стрелок, находящихся в правой части поля. Величина задержки будет отображаться в долях такта. Если нужно ввести произвольное значение, воспользуйтесь слайдером. Величина задержки в таком случае будет отображаться в тиках.

Рис. 9.22. Результат применения плагина MidiEcho. Quantize = 4, Echo-Quant. = 8, Velo Decay = -36

Length — протяженность задержанных MIDI-сообщений. Этот параметр, так же как и предыдущий, можно установить в точности равным той или иной доле такта, что подчеркнет ритм обрабатываемой партии. Параметры Length и LengthDecay взаимосвязаны.
Repeat — количество повторов. При выборе количества повторов следует учитывать значение параметра Velocity Decay и наоборот. Так, если Velocity ноты достигнет нуля после шага, номер которого меньше числа, заданного в поле ввода Repeat, то оставшиеся повторы программа генерировать будет, но с Velocity — 1, т. е. фактически эти повторы не будут слышны.
Echo-Quant. — величина задержки между исходной нотой и ее первым повторением (параметр взаимосвязан с Echo Decay).
Velo Decay — приращение уровня громкости с каждым повторением ноты. Если значение параметра больше 0, громкость будет увеличиваться.
Pitch Decay — количество полутонов, на которое следует транспонировать каждую ноту при очередном повторе (рис. 9.23).
Echo Decay — величина приращения времени задержки при каждом очередном повторении сообщения. Если Echo Decay = 100, то время между отдельными эхо-сигналами не изменяется. При Echo Decay > 100 повторные сигналы становятся более редкими, а при Echo Decay <100 они учащаются (рис. 9.23).

Рис. 9.23. Результат применения плагина MidiEcho. Repeat = 6, Velo Decay = -10, Pitch Decay = 2, Echo Decay = 95

Еще раз обращаем ваше внимание на то, что MidiEcho (как и другие MIDI-эффекты) воздействует не на отсчеты оцифрованного звука, а на параметры MIDI-сообщений.


9.7. Step Designer— паттерновый секвенсор

MIDI-плагин Step Designer предназначен для пошаговой записи мелодических паттернов длительностью в один такт. Это может пригодиться, например, в том случае, когда нужно записать быстрый пассаж, неисполнимый в реальном времени. Вы заранее, не торопясь, набираете последовательность нот, затем включаете Cubase SX в режим воспроизведения и слышите игру некоего виртуоза. Часто также методом пошаговой записи создают периодически повторяющийся фрагмент отдельной партии — паттерн (pattern). По существу, в паттерне содержатся указания синтезатору: извлекать заданные ноты заданных длительности и громкости в заданных долях такта. Так почему бы не назвать паттерн партией? Потому, что в отличие от партии, длительность которой может быть равна длительности композиции, паттерн, полученный с помощью MIDI-плагина Step Designer, состоит лишь из одного такта. В паттерне описывается правило формирования ритмического и мелодического рисунка на временном интервале, соответствующем некоторому периоду композиции. Композиция в целом состоит из нескольких периодов. Поскольку каждая композиция включает в себя различные части (фазы), такие, как вступление, фрагменты основной части, переходы между ними, кода, то для каждой из них существуют или могут быть созданы свои паттерны. Использование паттернов сокращает время работы над аккомпанементом.
Окно плагина Step Designer (рис. 9.24), по существу, представляет клавишный редактор, который, правда, по сравнению с Key Editor обладает специфическими функциональными возможностями.

Рис. 9.24. Окно плагина Step Designer

На клавишный редактор окно плагина Step Designer похоже тем, что на его верхнем рабочем поле можно "рисовать" музыку в координатах "нота — доля такта". Делается это щелчками левой кнопкой мыши на прямоугольных ячейках, расположенных напротив обозначений соответствующих нот в необходимых временных позициях. Для прокрутки отображаемого диапазона клавиатуры вверх или вниз, нужно воспользоваться кнопками [image] и [image] группы Shift Oct. Заметим, что прокрутка происходит очень своеобразно. До тех
пор, пока ни одна из имеющихся в паттерне нот не достигнет верхней или нижней границ поля, по вертикали перемещаются ноты. Затем ноты остаются на месте, а с шагом в октаву прокручиваются "клавиши". И еще одно. Когда окно программы Cubase SX сворачивается или когда оно вновь становится активным, в плагине происходит автоматическая прокрутка. Поэтому не удивляйтесь, если, отвлекшись на десяток минут, чтобы принять почту из Internet, по возвращении в окно плагина Step Designer вы обнаружите, что введенные вами символы сместились по вертикали (к счастью вместе с соответствующими нотами).
В нижнем рабочем поле (так же как и в аналогичной секции окна Key Editor) рисуются графики изменения параметров нот (значений контроллеров). Быстрый выбор одного из 4-х контроллеров осуществляется в раскрывающемся списке Controllers. Причем два верхних элемента списка (Velocity и Gate) неизменны, а два оставшихся можно менять, открыв кнопкой Setup окно со списками контроллеров. Строго говоря, Gate не является стандартным MIDI-контроллером. Скорее, это особый режим редактирования длительности нот, записанных в верхнем рабочем поле. Выбрав в раскрывающемся списке Controllers строку Gate, вы можете управлять длительностью нот. Для этого достаточно рисовать в нижнем рабочем поле столбики разной высоты.
При работе с плагином Step Designer приходится соблюдать ограничение: в одну временную позицию можно установить только одну ноту (нельзя оперировать аккордами).
Параметр Quantize определяет длительность нот, которые формируются в результате работы плагина.
Основная идея применения плагина Step Designer состоит в том, что ноты, введенные в нем, Cubase SX в режиме воспроизведения проигрывает циклически (они многократно повторяются). В рабочих полях плагина зацикленный участок выделяется подсветкой. Длительность цикла зависит от того, какое число введено в поле Length (в пределах от 1 до 32). А от соотношения длительности цикла и значения параметра Quantize зависит получающийся ритмический рисунок. Он может получиться различным даже при внешне одинаковом содержании паттерна. Поясним сказанное на примере. Допустим, что в окне плагина набрана последовательность нот, представленная на рис. 9.25, причем Quantize = 32 и Length = 32. Тогда после применения плагина на интервале в два такта получатся отпечатки клавиш, представленные на рис. 9.26.
Получился двухтактовый цикл, причем в каждом из тактов тридцатьвторые ноты расположены в первой и третьей тридцатьвторых долях. Период повторения цикла составляет 32 тридцатьвторые доли.
Теперь, сохранив остальные параметры плагина неизменными, установим Length = 2. Результат представлен на рис. 9.27: период повторения цикла составляет 2 тридцатьвторые доли.

Рис. 9.25. Окно плагина Step Designer (Quantize = 32, Length = 32)

Рис. 9.26. Результат применения плагина Step Designer (Quantize = 32, Length = 32)

Рис. 9.27. Результат применения плагина Step Designer (Quantize= 32, Length = 2)

Параметр Swing влияет на величину псевдослучайного отклонения расположения нот от равномерной тактовой сетки.
Между рабочими полями расположена линейка Tie, состоящая из очень маленьких кнопок, выполненных в виде точек. Если щелкать на таких кнопках, то некоторые из них будут включаться (подсвечиваться красным цветом). Программа не позволит включить те кнопки, которые включать нельзя (с учетом конкретного заполнения паттерна). Включенная кнопка Tie может означать удвоение длительности предшествующей ноты, если в позиции паттерна, соответствующей включенной кнопке, вы до этого ноту не записали (рис. 9.28, а, б, в).

Рис. 9.28. Результаты применения плагина Step Designer: а — пример паттерна, б — кнопка Tie 2 выключена, в — кнопка Tie 2 включена

Если в позиции паттерна, соответствующей включенной кнопке, а также и в предшествующей позиции вы до этого записали ноты, то включенная кнопка Tie объединит две эти ноты в одну. По существу, выполняется функция, которую в нотной записи принято обозначать символом лиги. Если исходные две ноты соответствуют звукам разной высоты (например, С и А), то при включении кнопки Tie вторая нота автоматически будет перемещена в одну строку с первой (из последовательности С, А получится последовательность С, С). Объединить можно не только две, но и любое другое количество нот. Ноты, расположенные в тех позициях, где кнопки Tie включены, недоступны для редактирования.
Кнопки >R и <L группы Shift Time предназначены для одновременного пошагового циклического сдвига содержимого паттерна. Например, если один раз нажать кнопку >R, то нота, которая была в первой позиции, переместится во вторую, во второй — в третью, ... в тридцать первой — в тридцать вторую, в тридцать второй — в первую. В качестве примера на рис. 29, а приведен исходный паттерн, а на рис. 29, б — паттерн, полученный после трехкратного применения кнопки Shift Time > R.

Рис. 9.29. Результаты применения кнопок Shift Time > R и Reverse: a — исходный паттерн, б — паттерн после трехкратного применения кнопки Shift Time > R, в — к исходному паттерну применена кнопка Reverse

Кнопкой Reverse осуществляется поворот содержимого паттерна (зеркальное отображение) относительно вертикальной оси симметрии (относительно границы между 16 и 17 долями). Иными словами, начало и конец паттерна при этом меняются местами (рис. 29, в). Повторное нажатие кнопки Reverse возвратит паттерну исходный вид.
В обшей сложности для одного экземпляра плагина можно создать и запомнить в качестве одного пресета 100 паттернов. Для перехода к паттерну с другим номером воспользуйтесь полем ввода Pattern.
С помощью кнопки Сору содержимое текущего паттерна можно скопировать в буфер обмена, а с помощью кнопки Paste — вставить в другой паттерн. Кнопкой Reset текущий паттерн "обнуляется": из него удаляются все ноты, а контроллеры приводятся в состояние по умолчанию.
Как только вы нажмете копку Rand., паттерн окажется заполненным случайной последовательностью нот. Для многих из нас эта копка может показаться элементом, применение которого порождает совершенно бессмысленный результат. Правда, поклонники стохастизма в музыке могут и не согласиться с таким мнением и даже, вероятно, обрадуются, узнав о существовании копки Rand.. Ведь, зачастую, для генерации случайных нот они вынуждены использовать совершенно несовременные, трудоемкие и даже примитивные технологии наподобие метания шестигранной игральной кости.
Если же вы, возложив на эту копку композиторские функции, попытаетесь автоматизировать процесс сочинения, например, танцевальной музыки, то запаситесь терпением. Лишь немногие случайные последовательности нот будут интересны в мелодическом отношении. Попробуйте сами, но только имейте в виду, что общее количество комбинаций выражается числом 1232. Это означает, что если бы даже перебор вариантов был не случайным, а регулярным, и при условии, что на каждую попытку уходила бы 1 минута, то для полного завершения такой работы потребовалось бы примерно 65 000 000 000 000 000 000 000 000 000 лет. Для сравнения: возраст нашей вселенной оценивается некоторыми учеными в 14 500 000 000 лет.
О чем говорят эти выкладки?
Во-первых, случайное формирование двух одинаковых паттернов вами лично или любыми другими пользователями программы практически невозможно. Хотя, конечно, многое зависит от качества генератора случайных чисел, однако при таком количестве возможных реализаций вероятность выпадения двух одинаковых комбинаций ничтожно мала. Варианты практически неповторимы даже на протяжении всей оставшейся жизни человечества, даже если все люди на Земле только и будут заниматься тем, что нажимать кнопку Rand.. Представьте, как вам будет обидно, если задним числом вдруг поймете, что паттерн, сгенерированный программой, когда вы не в этот, а в предыдущий раз нажали кнопку Rand., содержал гениальную мелодию! В данном случае даже компьютер прошлое вернуть, увы, не в состоянии. Ведь в отношении операций редактирования, проводимых внутри плагинов, функция Undo не действует. Поэтому лучше на всякий случай сохранять каждый полученный паттерн, внимательно прослушивать полученный результат, а удалять его, лишь убедившись, что он вам точно не нравится.
А во-вторых, лучше сочинять музыку не путем нажатия на кнопку, а в результате творческого озарения. Дело пойдет значительно быстрее, потому что массу комбинаций нот ваше сознание (или подсознание?) признает непригодными, а в ваши пальцы, летающие над клавишами, сами собой попадут сигналы только о тех немногих последовательностях звуков, которые могут стать музыкой.


Введение

Современные компьютерные музыкальные редакторы универсальны. Они позволяют работать с музыкой и звуком на всех этапах создания композиции. Имея в своем распоряжении достаточно мощный компьютер со звуковой картой, MIDI-клавиатуру и микрофон, вы сможете сохранить наброски мелодии; гармонизировать и аранжировать произведение; подобрать самые подходящие для него звуки; записать голоса вокалистов и партии живых инструментов; обработать полученные треки различными эффектами; свести композицию, добившись необходимого громкостного, частотного баланса и наиболее впечатляющего распределения звуков на стереопанораме (или даже на круговой панораме); выполнить мастеринг; подготовить альбом для записи на различные носители.
Словом, техника и программное обеспечение способны на многое, надо только суметь ими воспользоваться. Конечно, для этого нужны знания. А их можно почерпнуть из книг, в частности, из нашей книги. В ней детально описывается методика работы с программой, которая позволяет обеспечить полный контроль над всеми элементами и этапами процесса создания музыкального произведения. Книга посвящена программе Cubase SX и ее технологиям, предназначенным для работы с музыкой и звуком, которыми могут воспользоваться как начинающие, так и совершенствующиеся компьютерные музыканты.
Cubase SX принадлежит к числу наиболее мощных музыкальных редакторов профессионального уровня. Многие сотрудники студий звукозаписи склонны считать инструментом настоящего профессионала только Cubase. Хотя с таким мнением можно и поспорить. Существует несколько программ, обладающих приблизительно одинаковыми возможностями, и причины, по которым тот или иной человек выбирает одну из них, бывает также трудно объяснить, как и любовь, возникшую с первого взгляда.
Версии программы Cubase SX можно считать прямыми наследницами целой серии программ, в именах которых присутствует слово "Cubase". Кроме того, заметно влияние и на идеологию, и на интерфейс Cubase SX менее известной широкому кругу пользователей, но очень интересной программы Nuendo. Многое из лучшего, имеющегося в этих программах, перешло в Cubase SX, а кроме того, здесь появились и новые эффективные средства создания музыки и обработки звука.
В книге описана именно наиболее мощная и полнофункциональная современная версия программы (Cubase SX), а не упрощенный ее вариант (Cubase SL).
По существу программа Cubase SX переросла тот уровень, который соответствует понятию "музыкальный редактор", и стала полноценной виртуальной студией. За счет появления совершенных виртуальных синтезаторов, эффектов и обработок Cubase SX все менее и менее нуждается в реальной студийной аппаратуре. Хотя при наличии таковой Cubase SX прекрасно справляется с ролью программной среды, которая интегрирует виртуальные и аппаратные компоненты в эффективно функционирующее единое целое. При этом немаловажное значение имеет внедренная в Cubase SX технология VST System Link, позволяющая распределять задачи, связанные с ресурсоемкими вычислениями, между несколькими компьютерами, объединенными в сеть.
К основным свойствам Cubase SX можно отнести следующие:
  • возможность записи и редактирования MIDI-композиций;
  • наличие MIDI-эффектов;
  • возможность записи, редактирования и воспроизведения звука оцифрованного с частотой дискретизации до 96 кГц и разрядностью до 32 бит;
  • поддержка нескольких многоканальных форматов звука (surround) вплоть до формата 5.1;
  • возможность работы с VST-плагинами и DX-плагинами (аудиоэффектами реального времени);
  • возможность автоматизации любого параметра воспроизведения, обработки и синтеза звука;
  • наличие подключаемых виртуальных синтезаторов (VST-инструментов);
  • поддержка звуковых банков SoundFont;
  • импорт и экспорт цифрового звука в различных форматах;
  • воспроизведение цифрового видео;
  • представление музыки в виде нот, отпечатков клавиш фортепиано, списка сообщений;
  • графическое управление параметрами синтеза звука;
  • микширование сигналов и управление студийным оборудованием;
  • практически неограниченное число уровней отмены операций редактирования;
  • наличие удобных средств для работы с лупами.
Совместно с Cubase SX поставляются VST-инструменты. Управление ими, как и настоящими синтезаторами/сэмплерами, может осуществляться и с помощью традиционных MIDI-команд, и с помощью данных автоматизации, записанных на MIDI-треки, в виде огибающих (интерактивных графиков изменения тех или иных параметров).
В поставку Cubase SX включено большое количество VST-аудиоплагинов, отличающихся способностью к управлению посредством автоматизации и наличием большого количества интересных пресетов. Здесь есть и виртуальные приборы динамической обработки, и частотные фильтры, и множество самых различных звуковых эффектов (от банальной реверберации до экзотического модулятора, придающего голосу человека звучание, которое могло бы возникнуть, если бы наши голосовые связки были сделаны из металла).
Имеются средства поддержки внешних управляющих устройств. Можно отредактировать таблицу закрепления ударных инструментов за клавишами MIDI-клавиатуры. Есть специальный редактор, предназначенный для создания партий ударных инструментов. Нотный редактор, входящий в Cubase SX, по своим возможностям сравним с лучшими образцами специализированных программ, предназначенных для подготовки партитур к изданию. Клавишный MIDI-редактор позволяет записывать музыку тем пользователям, которые не владеют нотной грамотой. Редактор-список сообщений обеспечивает прецизионную точность установки значений параметров синтеза, длительностей и моментов извлечения звуков. Программа в лучших традициях Cubase оснащена развитой системой функций, преобразующих MIDI-сообщения в соответствии с заданными алгоритмами. В связи с этим следует упомянуть группу функций квантизации, позволяющих и устранить погрешности исполнения музыки, и обработать записанную партию в соответствии с неким образцовым стилем. Оригинальное звучание MIDI-партий можно получить с помощью встроенных в программу MIDI-эффектов. Автоматизация сколь угодно сложных преобразований MIDI-данных реализуется посредством логического редактора.
Всех достоинств не перечесть! Самое главное состоит в том, что программа удобна в работе, надежно функционирует и предоставляет пользователям все средства, необходимые для эффективного редактирования MIDI- и аудиокомпозиций.
А теперь рассмотрим структуру книги. Книга состоит из 16 глав, предисловия, введения, заключения, приложения и списка литературы. Книгу сопровождает компакт-диск в формате CD-Extra.
Первая глава содержит сведения теоретического и прикладного характера, необходимые для осознанного и эффективного использования программы. В ней мы рассказали о:
  • сущности интерфейса MIDI, типах MIDI-сообщений в Cubase SX, MIDI-секвенсоре и его дискретной шкале времени;
  • аналого-цифровом и цифроаналоговом преобразованиях;
  • методах синтеза звуков, принципах функционирования синтезаторов и сэмплеров;
  • структуре микшера и назначении его основных элементов;
  • формах представления музыкальной информации, реализованных в Cubase SX
  • сущности звуковых эффектов;
  • сущности наиболее важных обработок, таких как частотная фильтрация и динамическая обработка;
  • измерении уровня и анализе спектра аудиосигнала в Cubase SX.
Много внимания уделено объемному звуку (surround), особенностям оборудования студии формата 5.1 и сведения в круговую панораму.
В данной главе вы сможете найти рекомендации по подключению к звуковой карте MIDI-клавиатуры и микрофона, а также, не вникая в тонкости и подробности, научиться проделывать в Cubase SX такие операции, как:
  • Загрузка, создание и сохранение файла проекта
  • Воспроизведение и запись MIDI-файла
  • Запись аудиотрека
Словом, здесь есть всё, необходимое для того, чтобы приступить к работе с программой и выполнять эту работу, ясно понимая смысл тех или иных действий.
Во второй главе рассмотрена чрезвычайно важная проблема — подготовка программы Cubase SX к эффективной профессиональной работе. От того, насколько грамотно вы выполните все необходимые подготовительные операции, зависит качество полученных вами результатов.
Описаны опции, содержащиеся в тех окнах диалога, которыми вам придется воспользоваться при подготовке программы к работе. Рассмотрены такие вопросы, как:
  • настройка MIDI-портов;
  • настройка канала цифрового звука;
  • выбор и настройка используемых MIDI-устройств, загрузка и редактирование инструментов;
  • загрузка банков SoundFont;
  • обеспечение пространственного панорамирования;
  • организация мониторинга;
  • настройка метронома;
  • синхронизация Cubase SX с внешними устройствами;
  • создание проекта и настройка его параметров.
Рекомендуем по мере освоения новых приемов практической работы периодически возвращаться к первой главе. Это позволит глубже понять назначение операций по подготовке программы к работе и их связь с конечным результатом.
В третьей главе рассматривается транспортная панель, которой вам предстоит пользоваться постоянно. Описано назначение групп управляющих элементов, имеющихся на панели, основными из которых являются:
  • Main Transport — кнопки для управления записью/воспроизведением/ перемоткой; элементы редактирования текущей позиции проекта и выбора формата представления времени;
  • Locators — элементы редактирования позиций левого и правого локаторов; кнопки включения автоматической квантизации, автоматического переключения в режим записи и возврата в режим воспроизведения, а также включения циклического режима;
  • Pre-/Post-Roll — элементы включения удобного для пользователя алгоритма перехода в режим записи и выхода из него;
  • Master + Sync — элементы включения метронома и различных режимов, связанных с синхронизацией; поля редактирования темпа и музыкального размера проекта.
Ваши действия в отношении элементов транспортной панели со временем необходимо довести до автоматизма.
В четвертой главе рассматривается структура окна Cubase SX Project и назначение его инструментов. В окне проекта сосредоточены не только средства выбора различных атрибутов треков (таких, как, например, банк инструментов, MIDI-инструмент, порты ввода/вывода и многих других), но и графические средства микширования и автоматизации, а также элементы, предназначенные для подключения MIDI- и аудиоэффектов, управления их параметрами. Подробно описаны:
  • атрибуты MIDI-трека и аудиотрека;
  • элементы основной секции инспектора трека, а также секций Track Parameters, Inserts, Sends и Channel;
  • подключение и использование MIDI-эффектов, аудиоэффектов и VSTi (виртуальных инструментов — синтезаторов и сэмплеров);
  • назначение групповых треков и их атрибуты;
  • операции над частями и аудиосообщениями;
  • регионы аудиосообщений и циклическая запись;
  • амплитудные огибающие аудиосообщений;
  • обработка пересекающихся аудиосообщений, Auto Fades, Auto Crossfades;
  • перемещение границ частей и аудиосообщений, алгоритм Time Stretch;
  • операции над треками, треки-контейнеры (Folder Tracks), трек маркеров (Marker Track);
  • запись автоматизации, формирование и редактирование огибающих;
  • автоматизация мастер-секции микшера, MIDI-треков, аудиотреков, групповых треков, VSTi и аудиоэффектов.
К окну Cubase SX Project вам придется обращаться постоянно. Без понимания назначения его элементов эффективная работа в Cubase SX невозможна.
Пятая глава посвящена работе с микшером Cubase SX. Рассмотрены режимы отображения окна Mixer, операции над модулями микшера, маршрутизация аудиопотоков, общая панель, модули и мастер-секция микшера. Описаны методики подключения VST-плагинов и получения информации о них. Проанализированы особенности пространственного панорамирования и применения эффектов параллельного действия в многоканальных проектах.
В шестой главе приведено детальное описание технологий записи и редактирования MIDI-сообщений. В начале главы рассматриваются завершающие операции по подготовке к работе с MIDI-данными.
В этой главе описана также работа в редакторе List Editor, в котором музыкальная композиция представляется в виде списка сообщений; пояснено назначение секций окна редактора List Editor; приведена методика редактирования списка сообщений.
На конкретных примерах описан процесс управления параметрами синтеза с помощью нерегистрируемых параметров (NRPN), редактирование нот с MIDI-клавиатуры и пошаговый ввод нот.
Использование глубинных ресурсов синтезаторов звуковых карт возможно только посредством привилегированных системных сообщений (Sysex). Разъяснена структура системных сообщений. Приведено описание окна MIDI-Sysex-Editor, которое позволяет загрузить, отредактировать, сохранить и внести в список системные сообщения.
Описана технология работы в окне Key Editor. В нем музыка наглядно представлена в виде отпечатков клавиш. Именно Key Editor позволяет записывать и редактировать музыкальные композиции людям талантливым, но недостаточно владеющим нотной грамотой. Приведено описание инструментов окна и рассмотрена методика работы с ними.
Представлена технология создания партий ударных инструментов в редакторе Drum Editor. Пояснен принцип использования редактора Logical Editor. Подробно изложены вопросы применения квантизации, в том числе, суть различных алгоритмов квантизации и выбор параметров квантизации.
Описаны команды меню MIDI: транспонирование MIDI-нот; перезапись MIDI-сообщений с разных треков на один; применение MIDI-плагинов;
распределение MIDI-сообщений с одного на несколько треков; преобразование номеров нот в соответствии с Drum Map и др.
Пояснены функции, доступные из подменю MIDI > Functions, среди них: удлинение MIDI-нот до их слияния; удаление всех сообщений за исключением MIDI-нот; удаление нот, имеющих заданные параметры; устранение перекрытия MIDI-нот во времени; перезапись выделенных нот в обратном порядке.
В седьмой главе рассмотрена работа в двух окнах: Browse Project и Tempo Track.
Окно Browse Project — это единственный элемент интерфейса Cubase SX, где собрана абсолютно вся информация об используемых в проекте объектах. В левой части окна структура проекта представлена в древовидной форме. В дереве присутствуют папки всех имеющихся в проекте треков. Если раскрыть папку трека, то в ней будут доступны папки, которые в свою очередь соответствуют объектам более низкого логического уровня: частям, аудиосообщениям, подтрекам автоматизации. Приведены рекомендации по использованию окна Browse Project в процессе работы над проектом.
В Cubase SX существует особый трек (Tempo Track), предназначенный для удобного и наглядного управления темпом, который по сути представляет отдельное окно-редактор. Описана методика редактирования графика изменения темпа и сообщений о смене музыкального размера.
В восьмой главе в общих чертах рассмотрена работа в окне нотатора Score Editor. Нотатор программы обеспечивает традиционную нотную запись музыки и двунаправленную транскрипцию: ноты — MIDI-сообщения; MIDI-сооб-щения — ноты. Score Editor по существу представляет собой специализированный графический и текстовый редактор, обеспечивающий подготовку партитур музыкальных композиций к выводу на бумажный носитель. Однако разрешающая способность нотатора уступает разрешающей способности MIDI-секвенсора (это характерно для нотаторов любых MIDI-редакторов). Кроме того, Score Editor не обеспечивает редактирование каких-либо других сообщений, кроме сообщений о включении и выключении MIDI-нот.
Описана методика выполнения элементарных операций записи и редактирования нот композиции.
Девятая глава посвящена MIDI-эффектам. В рассматриваемой версии программы Cubase SX реализовано четырнадцать MIDI-плагинов реального времени:
  • Arpache 5 — арпеджиатор (формирователь последовательности коротких нот на основе протяженной ноты или аккорда);
  • AutoPan — формирователь последовательности сообщений об изменении значений заданного контроллера, по умолчанию настроенный в режим автоматического панорамирования;
  • Chorder — формирователь аккордов заданного типа;
  • Compress — компрессор значений параметра Velocity;
  • Control — формирователь сообщений о смене значений MIDI-контрол-леров;
  • Density — регулятор "плотности" нот на треке, обеспечивающий прореживание или, напротив, генерацию дополнительных нот;
  • Micro Tuner — точный корректор высоты звучания нот, обеспечивающий индивидуальную подстройку каждой ноты в октаве;
  • MidiEcho — многократное повторение нот, имитация эха;
  • Note 2 СС — конвертор MIDI-сообщения типа Note в сообщения типа Control Change;
  • Quantizer — квантизатор, работающий в реальном времени;
  • Step Designer — паттерновый секвенсор;
  • Track Control — контрольная панель для управления основными параметрами синтезаторов стандартов GS и XG;
  • Track FX — набор эффектов, включающий в себя смещение во времени и транспозицию;
  • Transformer — эффект реального времени, возможности которого аналогичны возможностям редактора Logical Editor.
Подробно описаны диалоговые окна, предназначенные для редактирования параметров наиболее сложных эффектов.
Десятая глава посвящена применению VSTi. В поставку Cubase SX входит очень большое количество виртуальных инструментов. Еще больше VSTi можно приобрести отдельно от программы и подключить к ней в качестве плагинов. Для того чтобы описать даже малую часть виртуальных инструментов, доступных пользователям в наши дни, потребовалось бы несколько книг. В данной книге рассмотрены общие принципы применения VSTi и описаны только три виртуальных инструмента (впервые вошедшие в поставку Cubase):
  • A1 — псевдоаналоговый синтезатор;
  • Vb-1 — однотембральный полифонический синтезатор физического моделирования, имитирующий звучание бас-гитары;
  • Lm-7 — 12-голосная драм-машина с 24-битными сэмплами.
Высказаны рекомендации по применению VSTi совместно с VST-плагинами эффектов, рассмотрено назначение всех элементов, имеющихся в окнах перечисленных VSTi.
Одиннадцатая глава посвящена вопросам совместного использования Cubase SX и приложений, поддерживающих технологию ReWire, предназначенную для обмена аудиоданными между различными программами.
Возможности ReWire проиллюстрированы на примере подключения к проекту Cubase SX виртуальной студии Propellerhead Reason и использования ее в качестве VSTi.
Описан порядок запуска приложений ReWire и выхода из них. Рассмотрена технология управления устройствами Reason непосредственно из Cubase SX. Высказаны важные советы, касающиеся принципов организации совместной работы двух приложений.
В двенадцатой главе подробно описаны методики применения имеющихся в Cubase SX средств обработки аудиоданных. Приведены технологии:
  • использования окна Audio Part Editor для редактирования аудиосообщений в пределах части;
  • редактирования аудиосообщений с помощью окна Sample Editor;
  • редактирования регионов и работы с ними в режиме циклической записи для создания дублей;
  • редактирования аудиофайлов на уровне отдельных звуковых отсчетов;
  • работы с лупами и редактирования маркеров Hitpoints;
  • генерации шаблонов для Groove Quantize с использованием Hitpoints.
Рассмотрено окно Pool и разъяснены способы использования информации, имеющейся в нем.
Описано назначение команды обработки звуковых данных средствами, встроенными в программу, которые содержатся в меню Audio > Process.
Подробно рассмотрен порядок применения команд:
  • Noise Gate — выявление и замена тишиной аудиоданных, уровень которых не превышает заданного порога;
  • Pitch Shift — изменение высоты тона выделенного фрагмента аудиоданных без изменения его длины;
  • Stereo Flip — комбинирование сигналов левого и правого стереоканалов, записанных на аудиотреке;
  • Time Stretch — изменение длины и "темпа" выбранного фрагмента аудиоданных без изменения высоты его тона.
Кроме того, описаны средства для выявления участков звуковых данных, на которых амплитуда звуковых колебаний ниже заданного уровня, порядок просмотра и изменения истории разрушающего редактирования, способ сбора статистической информации о выделенном аудиосообщений, команда для сохранения результатов всех обработок из временных файлов в постоянные.
В тринадцатой главе проанализированы аудиоэффекты, которые поставляются вместе с программой и могут быть классифицированы по функциональному назначению:
  • Cubase 5 Plug-ins — плагины, перешедшие из программы Cubase VST;
  • Delay — варианты эффекта Delay;
  • Distortion — варианты эффекта Distortion;
  • Dynamics — динамическая обработка;
  • Filter — фильтр с динамическим управлением частотой среза и глубиной резонанса;
  • Modulation — эффекты, связанные с модуляцией (периодическим изменением) параметров звука;
  • Other — прочие эффекты, не относящиеся к тем группам эффектов, которые соответствуют устоявшейся классификации;
  • Reverb — варианты реверберации;
  • Surround — многоканальные плагины;
  • Direct X — эффекты и виртуальные инструменты, подключаемые посредством DirectX.
Подробно рассмотрены аудиоэффекты:
  • DoubleDelay и ModDelay — дилэи, отличающиеся интерфейсом и набором регулируемых параметров;
  • DaTube, Overdrive и QuadraFuzz — различные варианты эффекта Distortion;
  • DeEsser, Dynamics, VSTDynamics — различные варианты динамической обработки;
  • StepFilter — фильтр с динамическим управлением частотой среза и усилением в полосе обработки;
  • Chorus, Flanger, Symphonic, Metalizer, Phaser, RingModulator, Rotary, Tranceformer — эффекты, в которых используется модуляция того или иного параметра;
  • BitCrusher — имитатор обработки звукового сигнала аналого-цифровыми преобразователями различного качества;
  • Chopper — амплитудное вибрато;
  • Grungelizer — имитатор различных искажений и помех, характерных для граммофона и патефона;
  • Vocoder — виртуальный вокодер;
  • Reverb А и Reverb В — варианты реверберации, отличающиеся наборами регулируемых параметров и дизайном окон;
  • Karlette — симулятор магнитофонного дилэя.
Даны рекомендации по применению эффектов в режиме реального времени и пересчета данных.
Четырнадцатая глава посвящена сведению композиции в стереоформат и формат 5.1.
Проанализированы особенности сведения при использовании внешнего синтезатора и VSTi. Рассмотрены задачи, решаемые при сведении: применение обработок, панорамирование, подбор громкости треков, применение эффектов. Изложены общие принципы сведения в 5.1. Описана методика применения VST-плагина Mix6to2 для выполнения операции mixdown каналов из 5.1 в 2. Рассмотрены вопросы работы с видео и технология экспорта сведенной композиции в файлы различных типов.
В пятнадцатой главе рассмотрены вопросы организации работы студийных компьютеров в сети на основе VST System Link. Проанализированы достоинства и недостатки использования компьютеров, объединенных в сеть посредством VST System Link. Описана технология соединения компьютеров, конфигурирования объединенной аудиосистемы. Рассмотрены особенности синхронизации проектов. Предложены варианты распределения нагрузки между компьютерами, входящими в сеть, а также варианты мониторинга и сведения распределенных проектов.
В шестнадцатой главе приведен обзор главного меню. В каждом из 11 меню сосредоточены по одной функционально однородной группе команд и меню:
  • Работы с файлами
  • Редактирования
  • Работы с проектом
  • Обработки аудиоданных
  • Обработки MIDI-данных
  • Настройки нотатора
  • Работы с пулом
  • Перемещения по проекту и управления воспроизведением и записью
  • Взаимодействия с реальными и виртуальными устройствами
  • Управления окнами
  • Получения помощи
Многие команды главного меню дублируются в контекстных меню. Приведено назначение команд. Пояснены те команды, которые не были рассмотрены в предыдущих главах книги.