Иллюстрированный самоучитель по записи лазерных дисков

Введение

ГЛАВА 1. Какие диски мы можем создавать и что для этого надо?

ГЛАВА 2. Знакомство с программами Easy CD Creator и WinOnCD

  • Знакомство №1. Программа Easy CD Creator
  • Знакомство №2. Другие программы из пакета Easy CD Creator Deluxe
  • Рабочее окно программы Easy CD Creator 4 Deluxe при создании аудиодисков
  • Рабочее окно программы CD Spin Doctor
  • Рабочее окно программы CD Copier
  • Рабочее окно программы Jewel Case Creator
  • Рабочее окно программы Video CD Creator
  • Рабочее окно программы Session Selector
  • Рабочее окно программы Sound Editor
  • Знакомство №3. Программа WinOnCD

ГЛАВА 3. Создаем архивы программ и данных на компакт-дисках

  • Знакомство №1. Создаем CD-ROM с помощью Easy CD Creator
  • Знакомство №2. Дописываем CD-ROM с помощью Easy CD Creator
  • Знакомство №3. Загрузочный CD-ROM с помощью Easy CD Creator
  • Знакомство №4. Создаем CD-ROM с помощью WinOnCD
  • Знакомство №5. Дописываем CD-ROM с помощью WinOnCD
  • Знакомство №6. Загрузочный CD-ROM с помощью WinOnCD
  • Знакомство №7. Копируем CD-ROM'ы
  • Знакомство №8. Записываем, читаем и стираем файлы с CD-RW с помощью Проводника

ГЛАВА 4. Любимая музыка на собственных компакт-дисках

  • Знакомство №1. Как подключить магнитофон или проигрыватель виниловых пластинок к звуковой плате?
  • Знакомство №2. Записываем музыку с лент и пластинок на компьютер
  • Знакомство №3. Копируем аудиотреки с других AudioCD
  • Знакомство №4. Выравнивание громкости звучания всех WAV-файлов
  • Знакомство №5. Создаем AudioCD с помощью CD Spin Doctor
  • Знакомство №6. Создаем AudioCD с помощью Easy CD Creator
  • Знакомство №7. Создаем AudioCD с помощью WinOnCD
  • Знакомство №8. Сжимаем музыку в формат МРЗ, с помощью Easy CD Creator
  • Знакомство №9. Сжимаем музыку в формат МРЗ с помощью МРЗ Producer
  • Знакомство №10. Создаем автоматически загружаемый CD-ROM с файлами МРЗ

ГЛАВА 5. Переносим видеозаписи на Video CD

  • Знакомство №1. Способы кодирования и компрессии видеосигнала
  • Знакомство №2. Видеокарты для нелинейного видеомонтажа
  • Знакомство №3. Записываем видеоизображение на жесткий диск
  • Знакомство №4. Создаем VideoCD с помощью программы WinOnCD
  • Знакомство №5. Проигрывание VideoCD на компьютере
  • Знакомство №6. Компрессия видеофайлов с помощью XingMpeg Encoder
  • Знакомство №7. Создание VideoCD с помощью программы Easy CD Creator

ГЛАВА 6. Создаем фотоархив на CD-ROM и Video CD

  • Знакомство №1. Какие фотоальбомы на компакт-дисках мы сможем делать?
  • Знакомство №2. Устройства ввода изображения
  • Знакомство №3. Основные форматы хранения изображения и их характеристики
  • Знакомство №4. Основные параметры и особенности формата PhotoCD
  • Знакомство №5. Формат изображений для нашего фотоальбома
  • Знакомство №6. Краткий обзор программного обеспечения для создания фотоальбомов и слайд-шоу
  • Знакомство №7. Сканирование и сохранение видеофайлов
  • Знакомство №8. Фотоальбом с помощью программы PowerPoint 2000

    Часть 1. (Рабочее окно программы Microsoft Power Point 2000 Добавление слайдов в проект презентации и создание надписей Использование готовых шаблонов презентации Создание слайда с содержанием презентации Создание слайдов с изображениями Добавление кнопок управления )
    Часть 2. (Создание гиперссылок Создание произвольного показа слайдов Настойка режима смены слайдов Работа со звуком Сохранение проекта презентации на жестком диске Предварительный просмотр созданной презентации Сохранение готовой презентации на CD-ROM)

  • Знакомство №9. Создание CD-ROM со слайд-шоу с помощью программы Фотослайдер
  • Знакомство №10. Создание слайд-шоу на VideoCD

ГЛАВА 7. Зачем нам диск караоке и как его сделать?

  • Знакомство №1. Проигрывание готовых файлов караоке
  • Знакомство №2. Создаем свои файлы караоке
  • Знакомство №3. Музыка отдельно, слова отдельно

ГЛАВА 8. Технология DVD-дисков с точки зрения потребителя

  • Знакомство №1. Подробнее о разных форматах DVD
  • Знакомство №2. Видео, звук и титры с VideoDVD-диска
  • Знакомство №3. Региональная блокировка и защита от копирования

ГЛАВА 9. Выбор DVD-привода, просмотр, создание и копирование VideoDVD-дисков

  • Знакомство №1. Как выбрать привод DVD-ROM?
  • Знакомство №2. Просмотр DVD-видео и обход региональной защиты
  • Знакомство №3. Копирование DVD-видео на жесткий диск или CD-ROM'ы
  • Знакомство №4. Создание собственного VideoDVD-диска (Подготовка файлов Авторинг Мастеринг)


Untitled Document

ГЛАВА 1 Kaкue дucкu мы можем создавать и что для этого надо?

В этой главе мы расскажем о том, что такое диски CD-ROM, CD-R, CD-RW, AudioCD, VideoCD, DVD-ROM, DVD-R, DVD-RAM, DVD+RW, DVD-RW, DVD-Video, DVD-Audio, какие диски из перечисленных выше мы можем создавать сами и что для этого надо.

CD-ROM (произносится "Си-Ди-Ром") - сокращение от английского Compact Disk Read Only Memory (Память на компакт-диске только для чтения). Термином CD-ROM обозначается как сам компакт-диск, так и устройство для его чтения (Рис. 1.1); это же замечание можно отнести и к терминам CD-R, CD-RW, DVD-ROM, DVD-R, DVD-RAM, DVD+RW, DVD-RW.

Рис. 1.1. Накопитель CD-ROM

Как уже упоминалось ранее, на компакт-диск можно записать до 650 Мб информации. Данные записываются на спиральную дорожку, которая раскручивается от центра диска к его краю. На дорожке расположены микроуглубления, с помощью которых кодируется информация. Если быть более точным, то она кодируется чередованием углублений и промежутков между ними на дорожке. Углубления не отражают свет, а промежутки между углублениями его отражают, и именно это позволяет их отличать при чтении информации с помощью лазерной головки. Информация на компакт-диске защищена от механических повреждений прозрачным лаковым или полимерным покрытием. Существует несколько форматов записи информации на диски CD-ROM, поэтому некоторые компакт-диски могут не читаться на старых дисководах, которые "понимают" не все форматы. Дисководы CD-ROM обычно относят к устройствам мультимедиа (Multimedia - среда со многими видами информации), так как на компьютерных компакт-дисках CD-ROM можно записывать и воспроизводить
самую разную информацию - текстовую, звуковую (музыку и речь), цветные картинки и движущиеся изображения (анимация и видео).
Система загрузки компакт-диска CD-ROM может быть выполнена в двух вариантах: с использованием специального контейнера (картриджа) для диска (caddy), вставляемого в приемное отверстие дисковода, и с использованием выдвижного лотка (tray), на который кладется сам компакт-диск. При использовании обычного выдвижного лотка дисковод можно установить только в горизонтальное положение, но некоторые дисководы допускают монтаж в вертикальном положении. В этом случае конструкция лотка предусматривает фиксаторы, удерживающие компакт-диск при выдвинутом лотке.
В заводских условиях углубления на подложке компакт-диска продавливаются специальной пресс-формой. Затем на информационный рельеф диска напыляется отражающее покрытие из алюминия, золота, серебра, другого металла или сплава, а само отражающее покрытие защищается слоем поликарбоната или лака, на который наносятся надписи и рисунки.
Чтобы создать свой компакт-диск, необходимо устройство для записи компакт-дисков - CD-рекордер (CD-Recorder) - и программа для записи дисков. Две такие программы описываются здесь, в главе "Знакомство с программами Easy CD Creator и WinOnCD". В этой же главе приводятся списки моделей рекордеров, с которыми работают эти программы. CD-рекордеры бывают двух типов: CD-R и CD-RW (см. ниже), которые подключаются к компьютеру как обычный дисковод для чтения компакт-дисков CD-ROM. Интерфейс подключения может быть IDE или SCSI.
CD-R (CD-Recorder - Записывающий CD) - устройство для однократной записи компакт-дисков. Для записи своего компакт-диска на таком устройстве необходим специальный пустой компакт-диск, который тоже называется CD-R (CD-Recordable - Записываемый CD). На компьютерном жаргоне такой диск называют "болванкой". Информация на диске CD-R записывается лазерным лучом. В процессе записи лазерный луч нагревает участки пластика, который темнеет и перестает пропускать свет к отражающему слою, образуя тем самым последовательность отражающих и не отражающих свет участков диска для кодирования информации.
Отражающий слой для дисков CD-R обычно изготавливается из золотой пленки, поэтому такие диски называются "золотыми". Хотя способы записи информации на обычные компакт-диски CD-ROM и на диски CD-R различны, результат один и тот же - последовательность отражающих и неотражающих участков, которую может прочесть любой дисковод CD-ROM.
На диск CD-R можно записать информацию только один раз, и перезаписать ее уже невозможно. В отличие от магнитных и магнитооптических носителей, диск CD-R нельзя нечаянно стереть, он обеспечивает очень высокую надежность хранения информации, поэтому диски CD-R идеально подходят для создания долговременных архивов.
Для записи дисков CD-R необходимо установить специальное программное обеспечение, которое обычно поставляется вместе с устройством для записи.
CD-RW (CD-Rewritable - Перезаписываемый CD) - устройство, которое подключается к персональному компьютеру и позволяет многократно записывать и стирать информацию с компакт-диска. Это устройство может называться еще CD-E (CD-Erasable - стираемый CD). Емкость носителя CD-RW составляет 650 Мб и равна емкости стандартных дисков CD-ROM и CD-R.
Диски CD-RW считываются только на новых универсальных накопителях CD-ROM и DVD-ROM, рассчитанных на работу с различными носителями, т.е. удовлетворяющих спецификации MultiRead (Чтение различных типов данных). Диски CD-RW при чтении более "капризны", так как из-менение отражательных свойств у них намного меньше, чем у CD-R и CD-ROM.
Для записи дисков CD-RW используется то же программное обеспечение, с помощью которого записывают диски CD-R. Программа сама распознает тип диска и может выполнить функцию стирания диска перед записью новых данных.
AudioCD (Звуковой CD) - это компакт-диск, на котором записаны не компьютерные программы и данные, а звуковые дорожки - речь или музыка. Диски AudioCD называются еще CD-DA (CD-Digital Audio - CD-цифровой звук). Звук на диски AudioCD пишется в стандарте Red Book (Красная книга), т.е. исходный стереофонический звуковой сигнал оцифровывается с частотой дискретизации 44,1 Кгц. Каждый отсчет исходного сигнала представляется отдельным 16-разрядным словом, т.е. занимает 2 байта. Таким образом, каждая секунда звучания занимает
44100 * (2 канала) * (2 байта) = 176400 байт, а одна минута занимает соответственно
176400 * 60 = 10584000 байт,
т.е. около 10 Мб. Стандартная продолжительность звучания всего компакт-диска AudioCD составляет 74 минуты, т.е. на нем записано около 740 Мб аудиоданных. На компьютерном же диске CD-ROM, в отличие от диска AudioCD, умещается всего 650 Мб данных. Это связано с тем, что хотя и музыка, и компьютерные данные пишутся в одинаковые сектора, но на дисках AudioCD и VideoCD данные занимают все 2352 байта сектора, а на компьютерных дисках CD-ROM собственно данные занимают только 2048 байт, а остальные 304 отведены под различную служебную информацию (коды синхронизации, заголовки и коды коррекции ошибок). Здесь уместно заметить, что разметка компакт-дисков осуществляется по шкале времени и адрес сектора указывается в виде минута:секунда:сектор. В 1 секунде - 75 секторов.
Если вы хотите создавать свои AudioCD, то для этого нужны только рекордер и программы, позволяющие копировать песни с других AudioCD. Программное обеспечение, используемое для записи дисков CD-R и CD-RW, обычно включает в себя функции, специально предназначенные для записи аудиодисков. Если же вы хотите записать на диск не стандартные 74 минуты, а несколько часов музыки, то вам понадобится программа для сжатия музыки в формат МРЗ. Такие диски, правда, можно будет слушать только на компьютере, а на CD-плеере они воспроизводиться не будут. О том, как создавать свои аудиодиски, написано в главе "Любимая музыка на собственных компакт-дисках".
Диски AudioCD можно проигрывать не только на CD-плеерах, но и на обычных дисководах для компакт-дисков, поскольку для компьютерных и аудио компакт-дисков применяется один и тот же принцип записи данных. По внешнему виду аудио компакт-диски ничем не отличаются от компьютерных компакт-дисков, различается только формат записи данных.
VideoCD - компакт-диск, на котором записано видеоизображение качества VHS (качество, которое обеспечивает обычный бытовой видеомагнитофон) и звуковое сопровождение качества AudioCD. Диски VideoCD содержат 74 минуты видео. Чтобы разместить на них такое количество видео и аудиоданных, информацию необходимо сжимать. Данные для записи на диски VideoCD сжимаются в соответствии со стандартом кодирования MPEG-1. Стандарт MPEG-1 был разработан с учетом возможностей 2-скоростных дисководов CD-ROM и компьютеров с процессором Intel-80486. Базовый алгоритм кодирования ограничивает скорость передачи данных диапазоном 150-225 Кбайт/сек с разрешением 352 х 288 точек (PAL) или 320 х 240 точек (NTSC) при частоте смены 25 или 30 кадров в секунду соответственно. При воспроизведении такое изображение можно растянуть аппаратными или программными средствами на полный экран, и хотя при этом теряется качество, зато остается возможность проигрывать полноэкранное видео даже с двухскоростных дисководов CD-ROM.
Для того, чтобы увидеть картинку и услышать звук на персональном компьютере, вам необходимо иметь устройство декодирования формата MPEG - MPEG-декодер и любую звуковую карту. Декодирование может быть программным или аппаратным. Программное декодирование поддерживает большинство современных видеокарт и не требует дополнительных устройств. Но в этом случае качество изображения напрямую зависит от используемого в компьютере микропроцессора, и, чтобы добиться приемлемой картинки, рекомендуется использовать процессор не хуже Pentium-233 и хорошую видеокарту с видеопамятью не менее 2 Мб. Аппаратное деко-дирование загружает процессор значительно меньше и производится специальной микросхемой, входящей в состав видеокарты или отдельной платы.
Для записи своего собственного диска VideoCD необходимо иметь устройство CD-R или CD-RW, видеокарту, способную перехватывать видеоизображение от внешних источников (видеомагнитофона, телевизора, видеокамеры и т.п.), и программное обеспечение для подготовки и записи видеоданных на диск. О том, как создать свой диск VideoCD, можно прочесть в главе "Переносим видеозаписи на VideoCD".
DVD (Digital Versatile Disc - Цифровой универсальный диск) - это оптические диски нового поколения с большой емкостью, которые применяются для хранения полнометражных фильмов и музыки сверхвысокого качества, компьютерных программ и данных. DVD - это следующий шаг в развитии оптических компакт-дисков. Объем данных, записанных на диск DVD может достигать 17 Гбайт. Вначале сокращение DVD обозначало Digital Video Disc - цифровой видеодиск, но затем под этим сокращением стали подразумевать цифровой универсальный диск, поскольку на диске DVD можно хранить самую разную информацию: компьютерные данные, полнометражные фильмы с качеством, превосходящим качество фильмов на лазерных дисках (Laser Disc, или LD), звукозаписи с качеством, лучшим чем на дисках AudioCD. Так же как и компакт-диски CD, диски DVD бывают только для чтения (DVD-ROM), с однократной записью (DVD-R) и с многократной записью, причем для последних существует несколько несовместимых друг с другом форматов записи: DVD-RAM, DVD+RW и DVD-R/W.
DVD-ROM - диск DVD только для чтения. По внешнему виду и физическим размерам диски DVD похожи на обычные диски CD-ROM, но они могут хранить в 26 раз больше данных. Стандартный однослойный односторонний диск DVD-ROM может хранить 4,7 Гбайт данных, а двухслойный односто-ронний диск DVD-ROM - до 8,5 Гбайт. Кроме этого, диски DVD-ROM могут быть двухсторонними, что увеличивает емкость одного диска до 17 Гбайт. Дисководы DVD могут читать обычные диски CD-ROM и звуковые компакт-диски, но на дисководе CD-ROM нельзя читать диски DVD.
Диски DVD-ROM изготавливаются в заводских условиях, на персональном компьютере их изготовить нельзя.
DVD-R, DVD-RAM, DVD+RW и DVD-R/W - это устройства, предназначенные для записи дисков DVD, причем диск DVD-R можно записать только один раз. Для записи дисков DVD-R используется технология, подобная технологии записи дисков CD-R. Технология записи дисков DVD-R постоянно улучшается, и теперь на такой диск можно записать уже не 3,95 Гбайт, как прежде, а 4,7 Гбайт, как и на одном слое диска DVD-ROM. Но такие диски DVD-R могут не читаться на DVD-дисководах первых поколений.
В перезаписываемых дисках DVD-RAM используется технология, отличная от технологии записи дисков DVD-R, поэтому они не читаются на большинстве современных дисководов DVD из-за различных методов исправления ошибок, другой отражающей способности и т.п. Емкость диска DVD-RAM составляет 2,58 Гбайт, хотя уже появились дисководы, способные записывать диски "стандартного" объема 4,7 Гбайт. Односторонние диски DVD-RAM бывают как в картриджах, так и без них. Существует два типа картриджей: запечатанный, из которого диск извлечь нельзя, и картридж, из которого диск можно извлечь. Записать диск можно только тогда, когда он находится в картридже. Двухсторонние диски DVD-RAM бывают только в запечатанных картриджах.
Конкурирующая с DVD-RAM технология перезаписываемых дисков DVD+RW позволяет записывать 2,8 Гбайт данных на сторону; диски DVD+RW не помещаются в специальный картридж и выглядят как обычный компакт-диск CD-ROM. Дисководы DVD+RW читают диски DVD-ROM и CD, но не читают диски DVD-RAM. Существующие плееры DVD-Video и дисководы DVD-ROM не могут читать диски DVD+RW. Дисково-ды DVD+RW второго поколения будут способны записывать 4,7 Гбайт на диск DVD+RW и совместимы с большинством ныне существующих плее-ров и дисководов DVD-ROM, а также приводами DVD-R и DVD-RAM. Они также смогут писать на диски CD-R и CD-RW.
Фирма Pioneer предложила еще один формат перезаписываемых DVD-дисков - DVD-RW (их называют еще DVD-R/W или DVD-ER), вмещаю-щих 4,7 Гбайт данных. В отличие от дисков DVD-RAM и DVD+RW, диски DVD-RW могут быть прочитаны на большинстве существующих на сегодняшний день дисководов.
Кроме перечисленных трех стандартов для перезаписываемых дисков, существуют и другие, поэтому пока не ясно, какой именно стандарт возьмет верх в конкурентной борьбе.
DVD-Video - диски DVD, на которых записаны видеофильмы в цифровом формате MPEG-2. Диски DVD-Video проигрываются в DVD-плеерах, подключенных к телевизионному приемнику. Они также могут проигрываться на компьютерных дисководах DVD-ROM. Разница между дисками DVD-Video и DVD-ROM точно такая же, как между музыкальными дисками Audio CD и компьютерными дисками CD-ROM. При записи видеофильмов на диски DVD-Video применяется стандарт сжатия изображения MPEG-2, а для сжатия звукового сопровождения - стандарт Dolby Digital. Dolby Digital имеет 5 независимых звуковых каналов (левый, центральный, правый, левый задний, правый задний) и отдельный канал для сабвуфера.
На одностороннем однослойном диске DVD-Video помещается около 2 часов высококачественного цифрового видеоизображения. На диск DVD-Video можно записать широкоформатные фильмы, которые могут воспроизводиться на стандартных или широкоэкранных телевизорах. Видеофильм на диске DVD-Video может содержать до 8 звуковых дорожек на разных языках, до 8 каналов каждая и до 32 дорожек субтитров. Во время воспроизведения видеофильма зритель имеет возможность выбрать любую из 9 камер, которыми снимался фильм. DVD-плееры поддерживают эк-ранные меню и простые интерактивные возможности, которые могут применяться в играх, обучающих программах и т.п. Диски DVD-Video обеспечивают быстрый переход к любой части фильма, включая поиск по заголовку, главе, дорожке и времени исполнения. Другими достоинствами дисков DVD являются их долговечность, невосприимчивость к магнитным полям, небольшие размеры.
Большинство плееров DVD-Video поддерживает стандартный набор возможностей, таких как: выбор языка, медленный, быстрый и обычный просмотр, блокировку воспроизведения всего фильма или его отдельных фрагментов с нежелательными сценами, воспроизведение выбранных разделов в желательной последовательности, цифровые аудиовыходы РСМ стерео и Dolby Digital, совместимость с дисками AudioCD.
DVD-плееры, компьютерные дисководы DVD-ROM и сами диски DVD-Video имеют встроенный код географической зоны; код диска должен соответствовать коду плеера. Например диск DVD-Video с кодом 1 (США, Канада) не будет проигрываться на DVD-плеере с кодом 2 (Европа). Это происходит потому, что после принятия соглашения о применении единого стандарта DVD для записи видеофильмов, ведущие киностудии по-требовали дополнительных гарантий того, что кинофильмы, предназначенные для одного рынка, будут недоступны для других. В результате весь мир был поделен на шесть зон, в которых применяются различные региональные коды и диски.
Для некоторых дисководов DVD-ROM и DVD-плееров можно менять код зоны ограниченное или неограниченное число раз.
Чтобы смотреть или копировать фрагменты или весь диск DVD-Video, кроме дисковода DVD-ROM, нужен аппаратный или программный декодер MPEG-2, причем декодировать формат MPEG-2 программно с удовлетворительным качеством можно только на компьютерах с процессором Pentium-450 и выше. Даже на хорошем компьютере для просмотра видеофильмов на дисках DVD-Video лучше иметь плату аппаратного декодиро-вания MPEG-2. Чтобы скопировать диск DVD-Video или его фрагмент, необходима специальная программа расшифровки формата MPEG-2 и дополнительное оборудование. Обо всем этом можно прочесть в главе "Все, что вы хотели знать о DVD, но боялись спросить".
DVD-Audio - формат музыкальных дисков нового поколения. В этом формате каждый импульс исходного звукового сигнала может представляться 16, 20 или 24 разрядами при частоте дискретизации от 44.1 до 192 кГц на каждом из двух каналов, обеспечивая, таким образом, высочайшее качество звучания. Поддерживается также шестиканальный формат Dolby Digital. Существующие плееры дисков DVD-Video могут воспроизводить только аудиодорожки Dolby Digital, находящиеся внутри видеоинформации, но ожидается появление комбинированных плееров DVD- Audio/Video. В дисках DVD-Audio не применяются региональные коды, однако в целях зашиты от копирования в плеерах DVD-Audio не будет цифрового выхода, а в цифровые данные будут внедряться различные неслышимые сигналы (цифровые подписи и пр.). Диски DVD-Audio могут содержать также фрагменты видео, графику, тексты и другую цифровую информацию.
Существуют компакт-диски, на которые записывается смешанная информация, например, диски формата CD Extra. На них аудиодорожки записаны в первой сессии, и одна дорожка с данными записана во второй сессии. Музыкальные дорожки таких компакт-дисков можно проигрывать на CD-плеере, а на дисководе CD-ROM можно не только слушать музыку, но и читать дорожку с данными. Забегая немного вперед, скажем, что на одном компакт-диске может быть записана одна или несколько сессий (Session), а каждая сессия может состоять из одной или нескольких дорожек (Track). Еще один формат, который позволяет смешивать аудио и компьютерные данные - это Mixed-Mode (Смешанный режим). Формат дисков Mixed- Mode отличается от формата CD Extra тем, что в одной сессии сначала записывается одна дорожка с данными, а затем одна или несколько аудиодорожек. Такой компакт-диск также можно проигрывать на обычном музыкальном CD-плеере, но первая дорожка будет звучать как случайный шум.
Следует упомянуть также формат компакт-дисков Photo CD, предложенный фирмой Kodak для записи на диск фотографий высокого качества. Каждый кадр с 35 -мм пленки оцифровывается и записывается на диск с пятью различными разрешениями. Один слайд в сжатом виде занимает около 6 Мб, поэтому на один компакт-диск можно записать не более 100 фотографий. Компакт-диски Photo CD можно просматривать как на специальных устройствах, так и на дисководах CD-ROM персонального компьютера.
На компактдиски мы можем также записывать караоке (Karaoke) - файлы в специальном формате, которые могут проигрываться программным проигрывателем. Караоке первоначально появилось в Японии. Это вид развлечения, в котором любители петь исполняют популярные песни под аккомпанемент предварительно записанной музыки без слов. Слова песни, которые должны петься в настоящий момент, либо появляются на экране монитора, либо закрашиваются на нем другим цветом. Таким образом начинающие певцы могут легко запомнить слова и петь их вовремя.
Для создания и воспроизведения файлов караоке необходимо иметь только аудиокарту, микрофон и соответствующее программное обеспечение. О том, где найти готовые файлы караоке, как создать караоке самому и что для этого нужно, читайте в главе "Зачем нам диск караоке и как его сделать?".


Untitled Document

ГЛАВА 2. Знакомство с программами Easy CD Creator и WinOnCD

В предыдущей главе вы познакомились с различными принципами записи информации на компакт-диски. В этой главе мы рассмотрим программы, с помощью которых вы сможете быстро записать на лазерный диск необходимую вам информацию. Таких программ существует достаточно много, но мы познакомимся с двумя, наиболее популярными, программами Easy CD Creator 4.0 Deluxe и WinOnCD 3.5. Выбор этих программ обусловлен также их простым интерфейсом, возможностью создания с их помощью компакт-дисков с различными способами записи, наличием дополнительных компонентов для копирования информации с одного компакт-диска на другой.


Untitled Document

Знакомство 1. Программа Easy CD Creator

Программа Easy CD Creator 4.0 Deluxe фирмы Adaptec представляет собой пакет, состоящий из нескольких программ, предназначенных для создания и записи различных компакт-дисков, и работает под управлением операцион-ной системы Windows 95/98/NT. Программа может входить в комплект вместе с записывающим дисководом CD-R/RW или загружена из Интернета с сервера фирмы Adaptec по адресу: http://www.adaptec.com. Установка пакета очень проста и представляет собой последовательность появляющихся на экране диалогов, в которых вы должны принять условия лицензионного соглашения и указать имя папки, в которую будут скопированы файлы пакета. По окончании копирования необходимых файлов программа установки создаст в разделе Программы (Program) основного меню папку Adaptec Easy CD Creator, поместит на ваш рабочий стол свой ярлык [image] и установит в правой части панели задач значок своего агента [image]. Затем программа установки предложит вам перезагрузить компьютер. После перезагрузки на экране появится диалог Adaptec Create CD, в котором вам будет предложено посетить сайт компании Adaptec в Интернете, чтобы проверить, обновлялась ли программа с момента ее выпуска или нет (Рис. 2.1).
Если вы подключены к Интернету, то можете запустить программу Adaptec WebCheckUp с помощью кнопки Yes диалога и обновить свою версию программы. Чтобы этот диалог не

Рис. 2.1. Диалог Adaptec Create CD

появлялся каждый раз при запуске компьютера, необходимо установить флажок Don't show me this dialog again (He показывать мне этот диалог снова), на экране появится диалог СгеateCD (Рис. 2.2) с информацией о том, что программа Adaptec Web-CheckUp может быть запущена в любой момент времени с помощью пускового меню.

Puc. 2.2. Диалог CreateCD

Нажмите кнопку ОК. Диалог CreateCD (Рис. 2.2) будет закрыт.
Нажмите кнопку No, чтобы закрыть диалог Adaptec Create CD (Рис. 2.1), если не хотите запускать программу Adaptec Web-CheckUp.
После чего и вы сможете пользоваться любой программой из пакета программ Easy CD Creator 4.0 Deluxe.
Чтобы запустить программу Easy CD Creator, выполните следующие действия.
Дважды щелкните мышью на ярлыке [image], расположенном на рабочем столе. На экране появится основное меню программы Easy CD Creator 4 (Рис. 2.3).

Рис. 2.З. Основное меню программы Easy CD Creator 4

С помощью этого меню можно вызвать основные программы, входящие в состав программы Easy CD Creator 4.0 Deluxe. Меню состоит из вертикального ряда кнопок с пиктограммой и названием пункта меню. Если подвести указатель мыши к любому из пунктов меню, то вид указателя мыши изменяется, изображение кнопки приобретает нажатый вид, а в окно правой части меню выводится краткая информация о назначении данного пункта. В верхней левой части меню расположены стандартные кнопки управления окном, позволяющие свернуть или закрыть основное меню программы Easy CD Creator 4.
Щелкните мышью на кнопке основного меню Data CD (Диск с данными). На экране на время загрузки программы появится заставка программы (Рис. 2.4).

Puc. 2.4. Заставка программы Easy CD Creator 4

По окончанию загрузки на экране появится рабочее окно программы с Помощником в правой нижней части (Рис. 2.5).

Puc. 2.5. Рабочее окно программы Easy CD Creator с Помощником

Использование Помощника напоминает вам на первых порах последовательность действий при создании CD-ROM-диска.
Щелкните мышью на надписи Show Me (Показать мне), расположенной в "реплике" Помощника, чтобы более детально рассмотреть процесс создания CD-ROM-диска. На экране появится окно Помощника (Рис. 2.6).

Рис. 2.6. Окно Помощника

В этом окне описаны два основных шага, необходимых при создании макeтa будущего CD-ROM-диска.
Нажмите кнопку [image], расположенную в верхнем левом углу окна Помощника, чтобы закрыть его.
Нажмите кнопку [image], расположенную в верхней части рабочего окна, чтобы убрать с него Помощника. На экране останется только рабочее окно программы (Рис. 2.7).
Рабочее окно программы состоит из следующих основных элементов.
Заголовок окна - стандартный элемент окна для программ, работающих под управлением операционных систем Windows 95/98/NT, содержит логотип, имя файла-макета создаваемого в настоящий момент компакт-диска и звание программы. Макет - это образ будущего компакт-диска, который отображает структуру папок и содержащихся в них файлов с именем и размером. Пока диск еще не создан, структуру папок и их содержание можно произвольно менять.
Кнопки управления окном - расположены в правой части заголовка окна и предназначены для управления рабочим окном, с помощью них вы можете свернуть, развернуть на полный экран или закрыть рабочее окно программы.
Основное меню - также является стандартным элементом окон программ, oстающих под управлением операционных систем Windows 95/98/NT, оно содержит названия основных групп команд, доступных программе. С помощью основного меню можно выполнить любую имеющуюся в программе команду.

Рис. 2.7. Рабочее окно программы Easy CD Creator

Панель инструментов - содержит кнопки, связанные с наиболее часто выполняемыми командами.
Строка состояния - содержит текущую информацию о выполняемой в данный момент команде, типе используемого дисковода CD-RW и т.д.
Шкала заполнения CD-ROM-диска - указывает общий объем информации в мегабайтах макета или частично записанного CD-ROM-диска. По этой шкале можно определить размер свободного пространства на записываемом компакт-диске.

Основное поле рабочего окна программы разбито на две части. В верхней части расположено окно проводника, с помощью него вы можете просматривать содержание дисковых накопителей, подключенных к вашему компьютеру. В левой части окна проводника отображается дерево каталогов вашего компьютера, аналогично программе Проводник, входящей в состав операционной системы Windows 95/98/NT. В нижней части основного поля рабочего окна программы расположено окно макета CD-ROM-диска, который вы создаете. В левой части окна макета CD-ROM-диска отображается структура каталогов создаваемого CD-ROM-диска.
Перед тем как приступить к созданию и записи CD-ROM-дисков, рекомендуется произвести тестирование оборудования, установленного на вашем компьютере. Для этого выполните следующие действия. Для проведения тестирования нужно приготовить три компакт-диска. Один диск должен быть чистым, т.е. заготовкой, другой должен содержать любые данные, т.е. подойдет любой записанный CD-ROM, и третий - содержать аудиодорожки, т.е. обычный аудио компакт-диск.

Установите аудиокомпактдиск в устройство которое может его прочитать(CD-ROM, CD-R, CD-RW).
Нажмите кнопку Test (Тестировать), на экране сначала появится диалог System Test (Системный тест), отображающий процесс тестирования скорости передачи данных из файла небольшого
размера (Рис. 2.9), а затем - файла размером 6 Мб (Рис. 2.10).
Выберите команду меню Tools * System Tests (Сервис * Системные тесты). На экране появится диалог System Test (Системный тест) (Рис. 2.8).

Выберите в окне Devices (Устройства) диск С: и установите флажок Data Transfer Rate Test (Тест скорости передачи данных).

Puc. 2.8. Диалог System Test (Системный тест)

Puc. 2.9. Диалог System Test (Системный тест),
отображающий процесс тестирования скорости
передачи данных из файла небольшого размера

Puc. 2.10. Диалог System Test (Системный тест),
отображающий процесс тестирования скорости
передачи данных из файла размером 6 Мб
После чего в группе элементов управления Data Transfer Rate Test диалога (Рис. 2.8), в строках Small Files (Небольшой файл) и Large File (Большой файл) появятся измеренные значения скорости передачи данных в Кбайт/сек.
Теперь можно перейти к тестированию дисковода CD-ROM, для этого выполните следующие действия.

Выберите в окне Devices (Устройства) диалога System Test (Системный тест) (Рис. 2.8) диск с установленным аудиодиском, вид диалога при этом изменится в соответствии с Рис. 2.11.

Рис. 2.11. Вид диалога System Test (Системный тест) при выборе дисковода с аудиокомпакт-диском

На этом этапе тестирования программа оценит скоростные характеристики устройства чтения компакт-дисков при передаче цифровых аудиоданных, записанных на компакт-диске в оперативную память компьютера.
150 Кбит/сек - это минимальная скорость передачи, при которой возможно качественное воспроизведение записанного на компакт-диске звука. Она принята за единицу при оценке скоростных параметров различных устройств чтения компакт-дисков, т.е. 150 Кбит/сек - это 1-я скорость, 300 Кбит/сек - 2-я и т.д.

Установите флажок Audio Extraction Test (Тест извлечения цифрового аудио) и нажмите кнопку Test (Тестировать). На экране появится диалог System Test (Системный тест), отображающий процесс проверки скорости извлечения цифровой аудиоинформации (Рис. 2.12).
После окончания тестирования в группе элементов управления Audio Extraction Test (Тест извлечения цифрового аудио) диалога System Test (Системный тест) (Рис. 2.11), в строке Audio Extraction Speed (Скорость извлечения цифрового аудио), появится информация о скорости чтения аудиокомпакт-диска.

Извлеките аудиокомпакт-диск из дисковода и замените его на любой CD-ROM-диск.

Рис. 2.12. Диалог System Test (Системный тест), отображающий
процесс проверки скорости извлечения цифровой аудиоинформации

Сбросьте флажок Audio Extraction Test (Тест воспроизведения аудио).
Установите флажок Data Transfer Rate Test (Тест скорости передачи данных) и нажмите кнопку Test (Тестировать). На экране появится диалог System Test (Системный тест), отображающий проверку подходящих данных для тестирования скорости передачи (Рис. 2.13).

Рис. 2.13. Диалог System Test (Системный тест), отображающий проверку подходящих данных для тестирования скорости передачи

на установленном в дисковод CD-ROM, диске будут найдены подходящие для теста данные, то на экране последовательно появятся диалоги, отображающие процесс тестирования скорости чтения данных из файла малого и большого размера. После чего полученные данные появятся в группе элементов управления Data Transfer Rate Test (Скорость передачи данных) диалога System Test (Системный тест) (Рис. 2.11), в строках Small Files (Файл малого размера), Large Files (Файл большого размера) и Read Speed (Скорость чтения).
Если на установленном в дисковод CD-ROM-диске не будут найдены подходящие для теста данные, то на экране появится диалог Easy CD Engine (Рис. 2.14) с информацией о том, что на CD-ROM-диске нет файла, подходящего для теста скорости чтения.

Рис. 2.14. Диалог Easy CD Engine

В этом случае необходимо установить в дисковод другой CD-ROM-диск и повторно запустить тест.
После тестирования скоростных свойств дисковода для чтения компакт-дисков нужно протестировать ваш CD-R/RW-дисковод. Для этого выполните следующие действия.

Выберите в окне Device (Устройства) диалога System Test (Системный
тест) (Рис. 2.8) дисковод для записи компакт-дисков.
Установите в дисковод для записи компакт-дисков CD-ROM-диск, содержащий данные.
Установите флажок Data Transfer Rate Test (Тест проверки скорости передачи данных) и нажмите кнопку Test (Тестировать). На экране появится описанная выше последовательность диалогов, отражающих состояние прохождения теста.
По окончании тестирования информация о скоростных параметрах вашего пишущего дисковода будет отражена в группе элементов управления Data Transfer Rate Test (Тест проверки скорости передачи данных).
Сбросьте флажок Data Transfer Rate Test (Тест проверки скорости передачи данных) и установите флажок Audio Extractor Test (Тест цифрового воспроизведения аудиоданных).
Извлеките компакт-диск с данными из дисковода и установите на его место аудиокомпакт-диск.
Закройте лоток дисковода и нажмите кнопку Test (тестировать). На экране появится диалог, отображающий процесс тестирования.
По окончании тестирования в группе элементов управления Audio Extractor Test (Тест цифрового воспроизведения аудиоданных) появится результат измерения скорости воспроизведения цифрового аудиосигнала.
Извлеките из записывающего дисковода аудиокомпакт-диск, установите пустой записываемый или перезаписываемый компакт-диск и закройте поток дисковода.

В диалоге System Test (Системный тест) сбросьте флажок Audio Extractor Test (Тест цифрового воспроизведения аудиоданных) и становите флажок Recording Test (Тест записи).

Нажмите кнопку Test (Тестировать). На экране появится диалог CD-Recorder System Test Progress (Прогресс-индикатор прохождения системного теста CD-рекордера), показывающий процесс проxождения имитации записи данных на компакт-диск.

После прохождения теста записи данных, будет произведен тест записи цифровых аудиоданных. В зависимости от скоростных параметров вашего дисковода для записи компакт-дисков, может быть произведено несколько тестов записи данных и цифрового аудио сигнала для каждого скоростного режима. После завершения прохождения теста записи в группе элементов управления Recording Test (Тест записи) появится информация о всех поддерживаемых скоростных режимах записи вашего дисковода.

На этом тестирование оборудования вашего компьютера завершено, и вы можете приступить к созданию макета будущего компакт-диска.
Процесс создания макета CD-ROM-диска предельно прост: вы выбираете в окне проводника файлы или целые папки файлов и перетаскиваете их мышью в окно макета CD-ROM-диска. Более подробно о том, как и какие CD-ROM-диски вы можете создавать, будет описано в одной из следующих глав.

Перед тем, как непосредственно приступить к созданию и записи CD-дисков, рассмотрим дополнительные программы, входящие в пакет программ Easy CD Creator Deluxe. Рабочее окно программы Easy CD Creator нам пока больше не нужно, поэтому его можно закрыть, щелкнув мышью на кнопке [image], расположенную в правой части заголовка рабочего окна.


Untitled Document

Знакомство 2.Другие программы из naкema Easy CD Creator Deluxe

В пакет программ Easy CD Creator Deluxe входят несколько различных программ, которые могут вам пригодиться в процессе создания собственных компакт-дисков. Условно их можно разделить на две группы: основные программы, с помощью которых можно создавать и записывать различные компакт-диски, и дополнительные, выполняющие вспомогательные и сервисные функции. К основным программам относятся:

  • Easy CD Creator - программа для создания и записи компакт-дисков с данными или музыкой;
  • CD Spin Doctor - программы для записи аудиоинформации с различных источников аудиосигнала на компакт-диск;
  • CD Copier - программа, предназначенная для копирования компакт-дисков;
  • Video CD Creator - программа для создания и записи видеокомпакт-дисков;
  • Jewel Case Creator - программа для создания и печати обложек для компакт-дисков.
    К дополнительным программам относятся:
  • Session Selector - программа для получения информации о компакт-диске и выбора записанных на нем сессий;
  • Sound Editor - программа для редактирования звуковых файлов и добавления к ним различных эффектов;
  • Web-CheckUp - программа, предназначенная для обновления и загрузки дополнительных компонентов программы Easy CD Creator.

Основные программы пакета могут быть вызваны с помощью основного меню программы Easy CD Creator 4 Deluxe (Рис. 2.3) или агента Adaptec Create CD, пиктограмма которого расположена в правой части пусковой панели. Дополнительные программы пакета могут быть запущены с по-мощью пускового меню. Познакомимся более подробно с рабочими окнами перечисленных программ.


Untitled Document

Знакомство 3. Программа WinOnCD
Программа WinOnCD версии 3.5 разработана в 1997 году фирмой CeQuadrat и предназначена для создания и записи различных видов компакт-дисков. Программа может быть загружена из Интернета с сервера компании CeQuadrat по адресу: http://www.cequadrat.com . По этому же адресу вы можете найти драйверы (управляющие программы) для записывающих дисковых накопителей различных фирм-производителей.
После получения программы необходимо разархивировать ее в отдельной папке и выполнить установку, запустив на выполнение файл install.exe. Программа установки не сложна и представляет собой последовательность появляющихся на экране диалогов, в которых вас попросят принять условия лицензионного соглашения, ввести регистрационный номер программы и выбрать папку, в которую будут скопированы необходимые для работы программы файлы.
После того, как все необходимые для работы файлы будут скопированы, программа установки предложит вам перезагрузить компьютер, чтобы изменения, произведенные ей в системных файлах, вступили в силу, и вы могли начать пользоваться программой. После перезагрузки на экране появится окно программы SpeedoMeter, входящей в состав WinOnCD.
Программа Speedometer предназначена для тестирования скоростных параметров жесткого диска, установленного в вашем компьютере, с целью определения максимально возможной скорости записи информации на компакт-диск.

Из открывающего списка Select Drive (Выберите устройство) выберите имя жесткого диска или его раздела и нажмите кнопку Go (Начать).

Программа начнет тестировать выбранный диск.
Следует иметь ввиду, что на жестком диске должно быть не менее 60 Мб свободного дискового
пространства, в противном случае результаты тестирования могут быть не точными. По окончании тестирования результаты анализа скоростных свойств жесткого диска будут выведены в таблицу диалога. В нижней части таблицы в графе recommended recording speed
(рекомендуемая скорость записи) расположены два столбца с метками коэффициентов скорости записи.
Если метки зеленого цвета, то это означает, что запись на этой скорости возможна. Если при тестировании скорости вашего жесткого диска некоторые метки коэффициентов скоростей остались красного цвета, то попробуйте произвести тестирование другого жесткого диска или его раздела.

Нажмите кнопку Exit (Выход), чтобы закончить работу с программой. Диалог программы SpeedoMeter будет закрыт.
Перейдем к знакомству с рабочим окном программы WinOnCD. Для этого выполните следующие действия.
Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы CeQuadrat WinOnCD 3.5 OEM (Program * CeQudrat * WinOnCD 3.5 OEM). На экране появится диалог Select your recording drive (Выберите ваше записывающее устройство).В верхнем окне этого диалога отображен список всех подключенных к вашему компьютеру дисководов для чтения или записи компакт-дисков.
Выберите из списка в верхнем окне диалога ваш дисковод для записи компакт-дисков и нажмите кнопку ОК. Диалог закроется, и на экране появится диалог New Project (Новый проект) (Рис. 2.44).

2.44. диалог New Project (Новый проект)

Диалог New Project (Новый проект) (Рис. 2.44) предназначен для того, чтобы вы могли выбрать тип создаваемого компакт-диска, так как от этого зависит вид рабочего окна и набор функций программы. По умолчанию выбирается режим создания компакт-диска с данными. Вы можете отключить появления этого окна при запуске программы, для этого необходимо сбросить флажок Show this box at startup (Показывать это окно при запуске), расположенный в нижней части окна. С помощью вкладки окна Open Project (Открыть проект) вы можете открыть сохраненный ранее проект макета компакт-диска.

Нажмите кнопку ОК. Диалог New Project (Новый проект) закроется, и на экране появится окно Browse for Folder (Обзор папки) (Рис. 2.45).
В этом окне вы должны указать папку, в которой будет храниться образ создаваемого вами компакт-диска. При выборе папки для хранения образа диска следует учитывать результаты тестирования скоростных параметров вашего жесткого диска, полученных

Рис. 2.45. Окно Browse for Folder(Обзор папки)

с помощью программы SpeedoMeter. Это означает, что папку для хранения образа создаваемого диска лучше всего выбрать на том жестком диске или его разделе, где полученные программой SpeedoMeter результаты тестиро-вания скорости оказались выше и имеется больший размер свободного пространства.

Выберите в окне Browse for Folder (Обзор папки) папку для хранения образа диска и нажмите кнопку ОК. Окно Browse for Folder (Обзор папки) закроется, а на экране на фоне рабочего окна программы WinOnCD появится окно Tip of the Day (Совет дня) (Рис. 2.46).

Рис. 2.46. Окно Tip of the Day (Совет дня)

В этом окне даются советы, как и какие диски вы можете создавать и как пользоваться программой WinOnCD, которые будут появляться каждый раз при запуске программы случайным образом. С помощью кнопки Next Tip (Следующий совет) вы можете просмотреть другие полезные советы и получить дополнительную информацию о программе. Чтобы отключить по-явление окна с советами дня, при старте программы необходимо сбросить флажок Show Tips on Startup (Показывать советы при запуске).

Сбросьте флажок Show Tips on Startup (Показывать советы при запуске) и нажмите кнопку Close (Закрыть), расположенную в нижней части окна. Окно Tip of the Day (Совет дня) закроется, а на экране останется рабочее окно программы WinOnCD (Рис. 2.47).

Рабочее окно программы состоит из следующих основных элементов.

Заголовок окна - содержит логотип программы, имя проекта создаваемого компакт-диска и название программы.

Рис. 2.47. Рабочее окно программы WinOnCD

Кнопки управления окном - расположены в правой части заголовка, и позволяют свернуть, развернуть на весь экран или закрыть рабочее окно программы.

Основное меню - расположено под заголовком окна, и содержит названия групп команд, доступных программе. С помощью основного меню можно вызвать любую из имеющихся в программе команд.

Панель инструментов - содержит кнопки, связанные с наиболее часто вызываемыми командами основного набора.

Панель инструментов редактора CD-ROM - состоит из кнопок, связанных с командами, позволяющими изменять макет компакт-диска (сортировать файлы на макете, менять положение папки в дереве каталога и т.п.)

Область просмотра имен исходных файлов и папок - служит для проcмотра и выбора файлов, папок и аудиодорожек, которые будут записаны компакт-диск.

Дерево файловой системы - предназначено для отображения файловой системы вашего компьютера.

Заголовок окна макета создаваемого компакт-диска - содержит в левой части логотип и название файловой системы создаваемого макета, а в правой части кнопку управления окном, которая позволяет развернуть окно макета на все рабочее окно программы WinOnCD.

Область просмотра имен файлов и папок на макете компакт-диска - служит для отображения информации о файлах, которые вы поместили на макет компакт-диска.

Область просмотра дерева каталогов макета компакт-диска - отображает структуру дерева папок на макете создаваемого компакт-диска.

Кнопки переключения режимов - изменяет вид окна макета создаваемого компакт-диска:

Tracks (Дорожки) - переключает окно макета в режим отображения ин-формации об аудиодорожках, которые содержит макет;

Editor (Редактор) - позволяет добавлять, удалять и перемещать файлы и папки на макете компакт-диска

Artwork (Художество) - переключает окно макета в режим, предназначен-ный для оформления обложки компакт-диска;

Disc (Диск) - переключает окно макета в режим записи компакт-диска.

Шкала заполнения CD-ROM-диска - показывает объем информации на макете и оставшееся свободное пространство на компакт-диске.

Кнопка Настройки - вызывает на экран диалог настроек, в котором вы можете выбрать устройство для записи компакт-диска, папку для хранения образа компакт-диска и временных файлов и скорость извлечения цифрового аудиосигнала.

Строка состояния - отображает текущее состояние программы и поясняет действия, которые может вызвать та или иная команда.

Программа WinOnCD достаточно проста в работе, в чем вы сможете убедиться в следующих главах этой книги, где будет подробно описан процесс создания различных типов компакт-дисков.


Untitled Document

Рабочее oкнo программы Easy CD Creator 4 Deluxe при создании ayдuoдucкoв

В предыдущем знакомстве мы рассмотрели рабочее окно программы Easy CD Creator, предназначенное для создания и записи CD-ROM-дисков. Рассмотрим окно этой же программы, но предназначенное для создания и мписи аудиокомпакт-дисков.
Дважды щелкните мышью на ярлыке [image] расположенном на рабочем столе. На экране появится окно основного меню Easy CD Creator 4 Deluxe (Рис. 2.3).
Выберите команду Audio (Аудио) основного меню Easy CD Creator 4 Deluxe, вид меню изменится в соответствии с Рис. 2.17.

Рис. 2.17. Вид меню Easy CD Creator 4 Deluxe

Установите в дисковод для чтения компакт-дисков любой аудиодиск.

Выберите команду Audio CD (Аудио CD), на время загрузки на экране появится заставка (Рис. 2.4), а затем рабочее окно программы Easy CD Creator для создания и записи аудиокомпакт-дисков (Рис. 2.18).

Рис. 2.18. Рабочее окно программы Easy CD Creator для создания и записи аудиокомпакт-дисков

Рабочее окно программы Easy CD Creator, предназначенное для создания и записи аудиокомпакт-дисков состоит из тех же основных элементов, что и рабочее окно для создания и записи CD-ROM-дисков (Рис. 2.7), с той лишь разницей, что в окне проводника отображаются аудиодорожки, записанные на компакт-диске, установленном в дисководе для чтения компакт-дисков.

Вы можете прослушать любую из аудиодорожек компакт-диска, для этого выполните следующие действия.
Выберите в правой части окна проводника любую аудио дорожку и нажмите кнопку [image], расположенную на панели инструментов. На экране появится окно CD Player (Проигрыватель компакт-диска) (Рис. 2.19).

С помощью кнопок управления, расположенных в нижней части окна, вы можете остановить воспроизведение и перейти к прослушиванию следующей или предыдущей аудиодорожки. В правом верхнем углу окна проигрывателя компакт-дисков расположены кнопки управления окном, с помощью которых его можно свернуть или закрыть.

Рис. 2.19. Окно CD Player (Проигрыватель компакт-дисков)

Закройте окно CD Player (Проигрыватель компакт-дисков), щелкнув мышью на кнопке [image], в верхнем правом углу.
С помощью кнопки [image] расположенной на панели инструментов, можно преобразовать выбранную аудиодорожку компакт-диска в звуковой файл и сохранить его на жестком диске. После этого полученный звуковой файл можно отредактировать с помощью программы Sound Editor, входящей в комплект Easy CD Creator Deluxe.
С помощью кнопки [image] вы можете обратиться к базе данных компакт-дисков, расположенной в Интернете, и получить полную информацию об установленном в дисководе аудиодиске, включая его название, имя исполнителя и названия песен. Для этого вы должны установить связь с Интернетом и нажать кнопку [image] расположенную на панели инструментов.
На экране появится диалог CDDB Internet download (Загрузка базы данных компакт-дисков из Интернета) (Рис. 2.20).

Рис. 2.20. Диалог CDDB Internet Download
(Загрузка базы данных компакт-дисков из Интернета)

Спустя некоторое время, необходимое для подключения к серверу и загрузки данных, диалог будет закрыт, а в правой части окна проводника явится информация об имени исполнителя, названии компакт-диска и аудиодорожек.
О том, как записать аудиокомпакт-диск, мы познакомимся в одной из последующих глав книги. Окно программы Easy CD Creator, предназначенное для создания и записи аудиодисков, нам пока больше не нужно, поэтому вы можете закрыть его с помощью кнопки [image], расположенной в правой части заголовка окна.


Untitled Document

Рабочее oкнo программы CD Spin Doctor
Рассмотрим рабочее окно программы CD Spin Doctor, для этого выполните следующие действия.
Дважды щелкните мышью на ярлыке [image], расположенном на рабочем столе. На экране появится окно основного меню Easy CD Creator 4 Deluxe (Рис. 2.3).
Выберите команду Audio (Аудио) основного меню Easy CD Creator 4 Deluxe, вид меню изменится в соответствии с Рис. 2.17.
Выберите команду Spin Doctor. На экране появится рабочее окно программы CD Spin Doctor (Рис. 2.21).

Рис. 2.21. Рабочее окно программы CD Spin Doctor

Рабочее окно программы CD Spin Doctor состоит из следующих основнь: элементов:

Заголовок окна - стандартный для программ, работающих под управлением операционной системы Windows 95/98/NT, элемент рабочего окна. Содержит в левой части логотип и название программы, а в правой части кнопки управления окном;

Основное меню - содержит названия групп команд, доступных программе. С помощью основного меню можно вызвать любую, имеющуюся в программе команду;

Панель инструментов - содержит кнопки, связанные с наиболее часто используемыми командами программы. Если подвести указатель мыши к любой из кнопок панели управления, то на экране на короткое время появится всплывающая подсказка с именем связанной с этой кнопкой команды;

Строка состояния - отображает текущее состояние программы;

Панель источника аудиосигнала - предназначена для выбора и отображения состояния источника аудиосигнала;

Панель устройства записи - предназначена для выбора и отображения стояния устройства записи аудиосигнала;

Кнопка начала записи - предназначена для старта процесса записи аудиосигнала от источника на выбранное устройство записи (CD-рекордер, жеcткий диск или устройство воспроизведения, например, звуковую карту).

C помощью программы CD Spin Doctor можно создавать свои собственные аудиокомпакт-диски, записывая на них музыкальные произведения или звукозаписи с различных источников, например, с грампластинок, магнитофона или микрофона. Программа имеет дополнительные средства для выравнивания уровня записи аудиодорожек, записанных с разных источников. подавления щелчков и помех, возникающих при записи с грампластинок и магнитофона, а также дополнительные эффекты для создания собственного аудиодиска. О том, как пользоваться программой, будет подробно описано в одной из следующих глав книги.

Закройте рабочее окно программы CD Spin Doctor с помощью кнопки [image]. расположенной в правой части заголовка окна.


Untitled Document

Рабочее oкнo программы CD Copier
Познакомимся с рабочим окном еще одной программы из комплекта Easy Creator Deluxe, предназначенной для копирования компакт-дисков.
Дважды щелкните мышью на ярлыке [image] расположенном на рабочем столе. На экране появится окно основного меню Easy CD Creator 4 Deluxe (Рис. 2.3).

Выберите команду CD Copier (Копирование компакт-диска). На экране появится диалог Welcome to Adaptec CD Copier (Добро пожаловать в программу копирования компакт-дисков фирмы Adaptec) (Рис. 2.22).

Рис. 2.22. Диалог Welcome to Adaptec CD Copier
(Добро пожаловать в программу копирования CD-дисков)

Чтобы этот диалог не появлялся каждый раз при запуске программы CD Copier, вы можете установить флажок Don't show this again (He показы-вать это снова), расположенный в нижней части диалога.
Нажмите кнопку ОК. Диалог закроется, а на экране появится рабочее окно программы CD Copier (Рис. 2.23).

Рис. 2.23. Рабочее окно программы CD Copier

Программа предназначена для быстрого копирования или тиражирования CD-дисков или их образов, находящихся на жестком диске, причем сразу всего диска целиком без возможности выбора отдельных аудиодорожек или данных. Следует отметить, что не все CD-диски могут быть скопированы без ошибок. Проблемы могут возникнуть, как из-за совместимости различных устройств чтения и записи CD-дисков, так и из-за различных способов записи информации на компакт-диск, а также драйверов чтения различных форматов CD-дисков, установленных на вашем компьютере.
Кроме того, диски, имеющие формат записи с использованием системы защиты от несанкционированного копирования, также могут быть скопированы с ошибками. Поэтому разработчики программы перед началом копирования рекомендуют произвести тестирование, установив флажок Test & Copy (Тестировать и копировать), расположенный в правой части рабочего окна программы.

Рабочее окно программы CD Copier состоит из заголовка окна, основного меню, строки состояния и двух вкладок. На вкладке Source and Destination (Исходное и конечное устройства) из открывающегося списка Source (Исходное устройство) необходимо выбрать устройство чтения копируемого компакт-диска, а из открывающегося списка Destination (Конечное устройство) - дисковод для записи компакт-дисков, установленный на вашем компьютере.
В правой части рабочего окна, в поле ввода Number of copies (Количество копий) устанавливается необходимое вам число копий копируемого диска. На вкладке Advanced (Дополнительные настройки) (Рис. 2.24) из открывающегося списка Current CD Recorder speed (Текущая скорость записи CD-диска) выбирается скорость, на которой будет производится запись компакт-диска.

Рис. 2.24. Вкладка Advanced (Дополнительные настройки)

Если ваш компьютер оборудован только одним записывающим дисководом, то вы все равно можете использовать программу CD Copier. В этом случае сначала на жестком диске вашего компьютера будет создан образ копируемого компакт-диска, а затем он будет записан на чистый компакт-диск.
Для этого необходимо на вкладке Advanced (Дополнительные настройки) в группе элементов управления Disk Copy (Дисковая копия) установить флажок Copy source CD to the hard drive first (Копировать исходный CD-диск сначала на жесткий диск) и указать в поле ввода, расположенном в нижней части группы элементов, полный путь к каталогу жесткого диска, где будет храниться образ компакт-диска. При этом надо учитывать, чтобы на жестком диске было достаточно свободного места для создания образа копируемого компакт-диска, не менее 650 Мб. Файл образа компакт-диска имеет расширение *.cif. Чтобы начать процесс копирования, достаточно нажать кнопку Сору (Копировать), расположенную в правой нижней части рабочего окна.

Закройте рабочее окно программы CD Copier щелчком мыши на кнопке [image], расположенной в правой части заголовка рабочего окна.


Untitled Document

Рабочее oкнo программы Jewel Case Creator
Познакомимся с программой создания обложек для компакт-дисков - Jewel Case Creator из комплекта Easy CD Creator Deluxe.
Дважды щелкните мышью на ярлыке [image] расположенном на рабочем столе. На экране появится окно основного меню Easy CD Creator 4 Deluxe (Рис. 2.3).

Выберите команду Jewel Case Creator (Создание обложки). На экране появится рабочее окно программы Jewel Case Creator с Помощником в правом нижнем углу (Рис. 2.25).

Рис. 2.25. Рабочее окно программы Jewel Case Creator

Чтобы убрать Помощника с экрана, выполните следующие действия.

Щелкните правой кнопкой мыши на изображении Помощника и в появившемся на экране контекстном меню выберите команду Hide (Скрыть).
Рабочее окно программы состоит из уже знакомых нам по рассмотренным ранее программам элементов: заголовка окна, кнопок управления окном, панели инструментов и строки состояния. Следует отметить, что вид панели инструментов можно изменить, добавив или убрав дополнительные панели кнопок. Для этого выполните следующие действия.
Щелкните правой кнопкой мыши на панели инструментов. На экране появится контекстное меню для панели инструментов (Рис. 2.26).

Рис. 2.26. Контекстное меню для панели инструментов

В контекстном меню для панели инструментов символом бюллетеня отмечены те панели, которые уже установлены в рабочем окне. Чтобы добавить новую или убрать уже имеющуюся панель инструментов, достаточно установить или сбросить щелчком мыши символ бюллетеня рядом с пунктом контекстного меню.

Основное поле рабочего окна программы Jewel Case Creator разделено на две части. В левой части в окне Page (Страница) расположены кнопки переключения видов макета обложки, а в правой части отображается сам макет. Макет обложки состоит из трех частей: лицевой части, которая в состоит из внешней (Front cover) и внутренней (Inside cover) стороны, задней части (Back cover) и этикетки компакт-диска (CD Label).
Каждая часть макета обложки снабжена фоновым рисунком и полями с названиями диска, именем исполнителя и названием аудиодорожек. Вы можете по своему желанию менять фоновый рисунок, размер и положение надписей на макете. В программе содержится несколько вариантов (тем) оформления макета обложки, чтобы посмотреть их, выполните следующие действия.

Выберите команду меню Format * Change Theme (Формат * Изменить тему На экране появится диалог Change Theme (Изменить тему) (Рис. 2.27).
В этом диалоге в окне Available Themes (Доступные темы) содержатся названия тем оформления обложки. В окне Preview (Просмотр) вы можете наблюдать изменение внешнего вида макета в зависимости от выбранной в окне Available Themes (Доступные темы) названия темы и принять изменения с помощью кнопки ОК, расположенной в нижней части диалога.Чтобы отказаться от изменений, необходимо нажать кнопку Cancel(Возврат).

2.27. Диалог Change Theme (Изменить тему)

В программе имеется возможность экспорта заголовков дорожек и названия компакт-диска для размещения их на обложке. Если о содержании аудиокомпакт-диска ничего не известно, то программа сама обратится к базе данных, расположенной на сервере в Интернете и получит необходимую информацию. Возможно, что данных о вашем компакт-диске не окажется в базе, но все-таки попробуйте. База данных действительно очень большая и содержит данные о компакт-дисках как отечественного, так и зарубежного производства. Для этого выполните следующие действия.

Установите любой аудиокомпакт-диск в дисковод для чтения компакт-дисков.
Установите связь с Интернетом, используя программу удаленного доступа или локальную сеть.
Выполните команду меню View * Zoom * 75% (Просмотр * Увеличение * 75%), чтобы в области просмотра макета обложки был виден макет целиком.
Выполните команду меню Add * CD Contents (Добавить * Содержание компакт-диска), если данные о содержании установленного в дисководе диска не вводились ранее, то на экране появится диалог CDDB Internet download (Загрузка базы данных компакт-дисков из Интернета) (Рис. 2.20). По завершении загрузки, данные о содержании диска будут помещены в поля макета обложки.

С помощью команд форматирования вы можете изменить параметры шрифта и выравнивание в полях ввода текста. После завершения редактирования макета обложки вы можете распечатать на принтере, установив предварительно параметры страницы. Для этого выполните следующие действия.

Выберите команду меню File * Рage Setup (Файл * Параметры границы). На экране появится диалог Page Setup (Параметры страницы).
Диалог состоит из трех вкладок, на каждой из которых из открывающегося списка Current paper type (Текущий тип бумаги) необходимо выбрать такой тип бумаги, на котором сможет разместиться макет обложки компакт-диска. В окне Area of paper to print (Область листа бумаги для печати) схематично изображается расположение макета обложки компакт-диска на листе бумаги.

Нажмите кнопку ОК, чтобы изменения вступили в силу и закрыть диалог Page Setup (Параметры страницы).
Теперь вы можете вывести макет обложки на принтер, выбрав команду меню File * Print (Файл * Печатать).
Закройте окно программы Jewel Case Creator, щелчком мыши на кнопке [image], расположенной в правой части заголовка рабочего окна.


Untitled Document

Рабочее oкнo программы Video CD Creator
Рассмотрим рабочее окно программы Video CD Creator, также входящую в основной комплект программ Easy CD Creator.
Дважды щелкните мышью на ярлыке [image], расположенном на рабочем столе. На экране появится окно основного меню Easy CD Creator 4 Deluxe (Рис. 2.3).

Выберите команду Photo & Video (Фото и Видео). Вид окна основного меню изменится в соответствии с Рис. 2.30.

Рис. 2.30. Вид окна основного меню Easy CD Creator 4 Deluxe

Выберите команду Video CD (Видео компакт-диск). На экране на время, необходимое для загрузки программы, появится заставка Easу CD Creator Deluxe (Рис. 2.4), а затем на фоне рабочего окна будет выведен диалог Video CD Creator Wizard (Мастер создания видеодисков, (Рис. 2.31).

Рис. 2.31. Диалог Video CD Creator Wizard (Мастер создания видеодисков)

Напомним, мастером называется последовательность диалогов, ведущая вас к конкретной конечной цели. Подробно о том, как создать и записать с помощью мастера видеокомпакт-диск, мы расскажем в одной из глав этой книги, а пока познакомимся только с рабочим окном программы.

Нажмите кнопку Отмена (Cancel), диалог Video CD Creator Wizard (Мастер создания видеодисков) закроется, и на экране останется только рабочее окно программы Video CD Creator (Рис. 2.32).

Рис. 2.32. Рабочее окно программы Video CD Creator

Так же как и рабочие окна других программ, рабочее окно программы Video CD Creator состоит из заголовка окна, кнопок управления окном, основного меню, панели инструментов и строки состояния.
Основное поле рабочего окна разделено на две части. В левой - расположена область Clips in Video CD Layout (Клипы в макете видеодиска). Она предназначена для отображения имен видеофайлов (видеоклипов), входящих в макет видеодиска.
В правой части рабочего окна расположена область Contents of Video CD Layout (Содержание макета видеодиска). Она состоит из двух вкладок: Sequences (Последовательность), отображающей последовательность воспроизведения записанных видеоклипов при непрерывном воспроизведении и Menus (Меню), которое вы можете создать на видеодиске, чтобы иметь возможность воспроизводить отдельные видеоклипы в произвольной последовательности.

Закройте рабочее окно программы Video CD Creator, щелчком мыши на кнопке [image], расположенной в правой части заголовка рабочего окна.


Untitled Document

Рабочее oкнo программы Session Selector
Теперь кратко рассмотрим дополнительные программы из комплекта Easy CD Creator Deluxe.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * Adaptec Easy CD Creator 4 * Features * Session Selector (Program * Adaptec Easy CD Creator 4 * Features * Session Selector). На экране на фоне рабочего окна программы Session Selector (Выбор сессий) появится диалог Adaptec Session Selector с приглашением и кратким описанием назначения программы (Рис. 2.33).

Рис. 2.33. Диалог Adaptec Session Selector
с приглашением и кратким описанием назначения программы

Сбросьте флажок Display at Startup (Показывать при запуске), чтобы этот диалог не появлялся при следующем запуске программы, и нажми-те кнопку ОК. Диалог закроется, а на экране останется рабочее окно программы Session Selector (Выбор сессий) (Рис. 2.34).

Рис. 2.34. Рабочее окно программы Session Selector (Выбор сессий)

Компакт-диски с аудиодорожками или файлами данных могут быть записаны за несколько циклов записи (сессий). Если при записи очередной сессии информация о предыдущей сессии не экспортировалась, то доступной для чтения будет последняя сессия записи на компакт-диске. Остальные сессии не будут "видны" для программ и вы не сможете загружать и использовать файлы, записанные на них. Чтобы вы могли использовать записанные таким образом файлы, вам нужна программа Session Selector.
Рабочее окно программы состоит из заголовка окна, основного меню, панели инструментов, строки состояния и рабочего поля, разделенного на две части. В левой части расположено окно All CD-ROM Drives (Все CD-ROM-устройства), в котором выводится список всех подключенных к вашему компьютеру устройств для чтения или записи компакт-дисков.
В правой части рабочего окна в виде таблицы выводится информация о количестве сессий, записанных на компакт-диске, который установлен в выбранный в окне All CD-ROM Drives (Все CD-ROM-устройства) дисковод.
Установите любой компакт-диск в любой из дисководов и нажмите клавишу [image], чтобы обновить информацию в рабочем окне программы.
Рабочее окно отобразит заголовок компакт-диска и объем информации, содержащейся на нем (Рис. 2.35).

Рис. 2.35. Рабочее окно с заголовком и объемом информации, содержащемся на компакт-диске

Выберите в окне All CD-ROM Drives (Все CD-ROM устройства) имя дисковода с установленным компакт-диском. В окне Contents of Е: (Содержание диска Е:) будет отражено количество сессий и размер информации, записанной в каждой сессии (Рис. 2.36).

Рис. 2.36. Рабочее окно программы, отображающее сессии, записанные на компакт-диске

Последняя сессия активна и помечена буквой дисковода (Е:). Данные, записанные именно в этой сессии, будут доступны. Если же импорта информации о данных, записанных в предыдущих сессиях, в последнюю сессию не производилось, то, чтобы получить доступ к ним, необходимо сделать нужную сессию активной. Для этого выполните следующие действия.

В окне Contents of Е: (Содержание диска Е:) выберите сессию, которую нужно активизировать.

Выполните команду меню Tools Activate Session (Сервис Активизировать сессию). На экране появится диалог Adaptec Session Selector с сообщением о том, что нужно подождать, пока активизируется сессия.

Через некоторое время, необходимое для активизации сессии, диалог Adaptec Session Selector будет закрыт, и вы сможете получить доступ к информации активной сессии.

Закройте рабочее окно программы Session Selector, щелчком мыши на кнопке [image], расположенной в правой части заголовка рабочего окна.


Untitled Document

Рабочее oкнo программы Sound Editor
Кратко опишем рабочее окно еще одной дополнительной программы из комплекта Easy CD Creator Deluxe - программы Sound Editor (Звуковой редактор).

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * Adaptec Easy CD Creator 4 * Features * Sound Editor (Program * Adaptec Easy CD Creator 4 * Features * Sound Editor). На экране появится рабочее окно программы Sound Editor (Рис. 2.38).

Рабочее окно программы Sound Editor состоит из заголовка окна, кнопок управления окном, основного меню, строки состояния, в правой части которого отображаются основные параметры редактируемого звукового файла. Над строкой состояния расположен индикатор уровня сигнала левого и правого канала редактируемого звукового файла.

Рис 2.38. Рабочее окно программы Sound Editor

Откройте любой звуковой файл с расширением *.wav, выполнив команду меню File Open (Файл Открыть). На экране появится диалог Открытие файла (Open) (Рис. 2.39).

Рис. 2.39. Диалог Открытие файла(Open)

Используя этот диалог,перейдите в папку C:\Windows\Media. в окне диалога будут отображены имена звуковых файлов, хранящихся в выбранной папке.
Выберите любой файл, например Chimes.wav, и нажмите кнопку Открыть (Open). Диалог закроется, а в рабочем окне программы Sound Editor появится окно Chimes, отображающее в графической форме загруженный файл (Рис. 2.40).

Как видно из Рис. 2.40, после открытия звукового файла, в paбочем окне появились дополнительные пункты основного меню, а в правой части строки состояния информация о параметрах загруженного файла.

Вы можете выделить мышью часть или весь открытый файл и преобразовать его с помощью команд пункта меню Effects (Эффекты). Программа поддерживает следующие звуковые эффекты:
Рис. 2.40. Рабочее окно программы Sound Editor с загруженным файлом

  • Amplify (Усиление) - этот эффект позволяет изменить громкость, редактируемого сигнала в процентах отдельно по каждому каналу;
  • DC Offset (Direct Current Offset) (Установка постоянной составляющей) - позволяет обнулить величину постоянной составляющей тока в звуковом файле; если она присутствовала во входном сигнале при записи. Это позволит избежать искажений записанного звукового сигнала.
  • Echo (Эхо) - добавляет к исходному сигналу эффект эхо с заданными параметрами задержки и уровня;
  • Fade (Затухание) - позволяет плавно изменять громкость выделенного фрагмента или всего звукового файла;
  • Flange (Гребенка) - реализует эффект "флэйнжер", т.е. обрабатывает,исходный сигнал с помощью специального гребенчатого фильтра, в результате получается иллюзия вращения и перемещения мнимого источника звука;
  • Format Conversion (Преобразование формата) - позволяет изменять частоту дискретизации, режим записи (стерео или моно) и глубину оцифровки (16 бит или 8 бит), что заметно влияет на качество сигнала и размер звукового файла;
  • Graphic EQ (Графический эквалайзер) - позволяет усиливать или ослаблять громкость исходного сигнала в десяти частотных диапазонах;
  • Invert (Инвертировать) - позволяет менять местами правый и левый каналы стереозаписи, установив флажок Swap channels (Поменять каналы) диалога Inversion setting (Установки инверсии), а также инвертировать звуковой сигнал в каждом из стереоканалов. Эта функция может быть полезна, если вы записали отдельно сигналы для левого и правого канала, а потом соединили их в одном стереофайле. В этом случае может оказаться, что сигналы левого и правого каналов окажутся в противофазе. Т.е. когда в одном канале звуковая волна достигает максимума громкости, в другом в это же время минимум. При этом истинное звучание искажается и необходимо воспользоваться инвертированием одного из каналов.
  • Pitch Shift (Изменение тона) - позволяет изменять высоту основного тона исходного сигнала. При обработке речи этим эффектом можно до неузнаваемости изменить записанный голос.

Кроме перечисленных возможностей программа позволяет копировать отдельные участки или целиком звуковые файлы в буфер обмена, а затем вставлять его содержимое в любое место другого открытого звукового файла.

Закройте рабочее окно программы Session Selector щелчком мыши на кнопке [image], расположенной в правой части заголовка рабочего окна.

На этом обзор основных и дополнительных программ, входящих в состав Easy CD Creator 4 Deluxe, закончен. Перейдем к обзору основных возможностей еще одной программы, предназначенной для создания и записи компакт-дисков - WinOnCD.


Untitled Document

ГЛАВА 3.Создаем архивы программ и данных на кoмnaкт-дucкax

Большинство программ при записи дисков CD-R и CD-RW позволяют выбирать различные файловые системы в зависимости от того, на каком компьютере и в какой операционной системе будет использоваться записанный компакт-диск. Существует множество файловых систем, предназначенных для использования в той или иной операционной системе.
Например, файловая система Joliet используется в операционной системе Windows 95/98, а файловая система ISO 9660 используется в операционной системе MS-DOS. Файловые системы отличаются друг от друга способом представления имен файлов, набором атрибутов файла, организацией каталогов и многими другими свойствами. Каждая операционная система обычно "понимает" несколько файловых систем, но все-таки диски, записанные с использованием определенной файловой системы, могут читаться не всеми операционными системами. Например, диск, записанный в файловой системе Joliet, не будет читаться в операционной системе MS Windows NT 3.51.
Чтобы осмысленно выбирать тип файловой системы при записи компакт-диска, давайте рассмотрим основные их типы.

Стандарт ISO 9660 Level 1 (8+3) допускает использование от 1 до 8 символов в имени файла и до 3 символов в расширении имени файла.
Символы,допустимые в именах файлов включают заглавные английские буквы от А до Z, цифры от 0 до 9 и символ подчеркивания "_". Файлы записываются непрерывно в виде последовательности смежных секторов, а уровень вложенности каталогов не может быть более 8. Файловая система ISO 9660 Level 1 является наиболее универсальной, т.е. может читаться различными операционными системами (MS DOS, MS Windows 3.1/95/98/2000/NT, UNIX, МасОS и др.)
Стандарт ISO 9660 Level 2 позволяет использовать в именах файлов до 32 символов, включая пробелы и русские буквы. Допускается до 32 уровней вложенности каталогов.
Стандарт ISO 9660 Level 3 в дополнение к стандарту ISO 9660 Level 2 позволяет фрагментировать файлы, т.е. записывать их в несмежные сектора. Это может случиться, например, при работе программ, использующих режим пакетной записи на компакт-диск (Packet Writing). О режиме пакетной записи будет рассказано чуть позже в этой главе.
Файловая система Joliet является расширением стандарта ISO 9660 Level 1 и поддерживает запись на компакт-диски файлов с длинными именами в операционной системе MS Windows /95/98/2000/NT. Эта файловая система позволяет использовать в именах файлов до 64 символов, включая пробелы; при этом можно применять как обычные однобайтовые символы, так и двухбайтовые символы Unicode. Для того, чтобы диски с файловой системой Joliet читались в операционных системах MS DOS или MS Windows 3.1, программа записи, кроме длинных имен, должна также записывать и короткие (8+3) имена файлов.

Стандарт файловой системы UDF (Universal Disk Format - Универсальный формат диска) специально предназначен для записи оптических дисков. Диски с файловой системой UDF читаются операционными системами MS Windows/95/98/2000/NT.
Файловая система Rock Ridge является расширением стандарта ISO-9660 для UNIX-подобных операционных систем и может также читаться на персональных компьютерах Макинтош (Macintosh). Операционные системы MS DOS и MS Windows эту файловую систему не поддерживают.
Файловая система HFS используется в персональных компьютерах Макинтош, Apple II, и Amiga. Длина имени файла не может превышать 31 символ.
Как уже упоминалось ранее, запись дисков выполняется с помощью специальных программ, две из которых были описаны в предыдущей главе. Рассмотрим особенности записи информации на компакт-диски. На одном диске может быть записана одна или несколько сессий (Session). Каждая сессия может состоять из одной или нескольких дорожек (Track). Данные на дорожку пишутся блоками по 2352 байта, которые по аналогии с жесткими дисками называются секторами. В дисках AudioCD и VideoCD данные занимают все 2352 байта сектора, а в компьютерных дисках собственно данные занимают 2048 байт, а остальные 304 отведены под различную служебную информацию (коды синхронизации, заголовки и коды коррекции ошибок). Существуют три основных метода записи на компакт-диски. Это:

  • Track-at-Once (Дорожка за один прием);
  • Disc-at-Once (Диск за один прием);
  • Packet Writing (Пакетная запись).

В режиме Track-at-Once (Дорожка за один прием), записывающий лазер выключается после записи очередной дорожки и снова включается при записи следующей, даже если несколько дорожек записываются подряд в одной операции записи. Процесс записи одной дорожки представляет собой единую операцию и не может быть прерван, иначе весь диск будет испорчен. Дорожки, записанные в режиме Track-at-Once, разделены промежутками (Gaps) длительностью в 2 сек. В режиме Track-at-Once пишутся многосессионные диски CD-ROM, которые допускают дозапись дант ных. Данные дозаписываются в отдельной сессии, при этом заново формируется оглавление всего диска. Сессия может быть записана либо полностью за один прием с закрытием сессии по окончании записи, либо в несколько приемов без закрытия сессии.

В режиме Disc-at-Once (Диск за один прием) одна или более дорожек записываются без выключения лазера, и по окончании записи диск закрывается. После того, как диск закрыт, на него уже невозможно дописать новые данные. Режим записи Disc-at-Once применяется только для чистых дисков и не может быть использован для записи на диски, на которые уже записаны одна или более сессий.
Этот режим можно использовать, например, для записи аудиодисков без промежутков между дорожками. Если вы хотите создать мастер-диск, т.е. диск, с которого промышленным способом будут штамповаться алюминиевые диски, то его надо обязательно записывать в режиме Disc-at-Once, поскольку устройства для изготовления матриц обычно не допускают промежутков между дорожками. Диски, записанные за один прием, являются наиболее универсальными и читаются любыми дисководами CD-ROM.

В режиме записи Packet Writing (Пакетная запись) информация на диск пишется небольшими порциями - пакетами, что позволяет использовать предварительно отформатированный диск CD-RW точно так же, как обычный диск, т.е. стирать, переименовывать и редактировать файлы прямо на компакт-диске. Такой режим поддерживает, например, программа Adaptec DirectCD. Компакт-диски, обеспечивающие режим записи Packet Writing (Пакетная запись) иногда также называют дисками DirectCD.

Если на жестком диске достаточно свободного места, то при создании компакт-диска можно предварительно создать его образ, который записывается в единый файл на жестком диске. Подготовка образа компакт-диска целесообразна при создании нескольких одинаковых компакт-дисков. В этом случае экономится время при обработке файлов. При создании компакт-диска из предварительно созданного образа также уменьшается вероятность исчерпания буфера и порчи диска при записи.

Для чтения перезаписываемых компакт-дисков CD-RW применяется другая длина волны, чем для чтения однократно записываемых дисков CD-ROM, поэтому диски CD-RW могут не читаться на старых дисководах CD-ROM. Большинство современных устройств CD-ROM поддерживают технологию MultiRead (Множественное чтение), поэтому они могут читать перезаписываемые диски тоже.


Untitled Document

Знакомство 1. Создаем CD-ROM с помощью Easy CD Creator
В этом знакомстве мы создадим компакт-диск с помощью мастера создания дисков программы Easy CD Creator. Для запуска различных компонентов программы Easy CD Creator мы будем пользоваться значком [image], расположенным в правой части Панели задач (Taskbar) операционной системы Windows. Если значка [image] на Панели задач (Taskbar) нет, установим его следующим образом.

Выберите команду главного меню Программы * Adaptec Easy CD Creator 4 * Create CD (Programs * Adaptec Easy CD Creator 4 * Create CD). На экране появится основное меню программы Easy CD Creator 4 (Рис. 3.1).

Рис. 3.1. Основное меню программы Easy CD Creator 4

Если установить указатель мыши на любую кнопку в левой части окна, содержащего меню, то справа отображается текст о назначении кнопки.

Щелкните правой кнопкой мыши на заголовке окна и из появившегося контекстного меню выберите команду Add icon to tray (Добавить значок на Панель задач). В правой части Панели задач (Taskbar) операционной системы Windows появится значок [image].

Теперь можно приступить к созданию компакт-диска. Чтобы нам были доступны все функции программы Easy CD Creator, мы запустим ее не с помощью кнопки Data CD (Компакт-диск данных) основного меню, а из главного меню операционной системы Windows. Например, если запустить программу Easy CD Creator с помощью кнопки Data CD (Компакт-диск данных) основного меню, то нельзя будет создать загрузочный компакт-диск, музыкальный компакт-диск и т.п.

Закройте основное меню программы Easy CD Creator 4, нажав кнопку [image] в заголовке окна, содержащего основное меню.
Установите пустой компакт-диск CD-R в дисковод для записи компакт-дисков.
Запустите программу Easy CD Creator, нажав кнопку Пуск (Start) на Панели задач (Taskbar) операционной системы Windows и выбрав команду главного меню Программы o Adaptec Easy CD Creator 4 * Features * Easy CD Creator (Programs * Adaptec Easy CD Creator * Возможности * Easy CD Creator). Ha экране появится заставка, которая отображается во время загрузки программы Easy CD Creator (Рис. 3.2).

Рис. 3.2. Заставка программы Easy CD Creator 4

По окончании загрузки заставка исчезнет и на экране появится рабочее окно программы Easy CD Creator (Рис. 3.3).

Рабочее окно программы Easy CD Creator будет иметь вид как на Рис. 3.3, если в меню View (вид) галочкой отмечены пункты Tool Bar (Панель инструментов), Status Bar (Строка состояния), CD Info Bar (Строка информации о компакт-диске), Show Windows Explorer (Показать окно Проводника) и Show Explorer Bar (Показать дерево папок проводника).

Рис. 3.3. Рабочее окно программы Easy CD Creator
Если нажать кнопку [image] на панели инструментов, то на экране появится Помощник (CD Guide) [image], который в каждый момент времени подсказывает, что можно делать дальше. Если сопровождающий Помощника текст мешает рассмотреть находящуюся под ним часть окна, то Помощник можно перетащить в другую часть экрана.
Отказаться от услуг Помощника можно, нажав кнопку [image] Напомним, что в верхней половине рабочего окна программы Easy CD Creator отображается информация о файловой системе вашего компьютера точно так же, как в стандартной программе Проводник (Explorer), а в нижней части отображается макет файловой системы создаваемого компакт-диска тоже как в программе Проводник (Explorer).

Вы можете добавлять файлы и папки в макет создаваемого диска, просто перетаскивая их мышью из верхней половины окна в нижнюю.
Сначала макет файловой системы создаваемого компакт-диска пустой, о чем свидетельствует его имя в левой нижней части окна - Empty Data Layout (Пустой макет данных). Как только мы добавим в макет какой-либо файл или папку, имя макета изменится на случайное, например, 000314_1245. При создании компакт-диска имя макета данных станет меткой самого диска. Эта метка впоследствии отображается, например, в программе Проводник (Explorer). Имя макета данных формируется случайным образом при создании нового макета, но его можно изменить и сформировать собственное имя. Для изменения свойств макета данных необходимо выполнить следующие действия.

Щелкните правой кнопкой мыши на имени макета данных (сейчас оно Empty Data Layout (Пустой макет данных) и из появившегося контекстного меню выберите команду Properties (Свойства). На экране появится диалог CD Layout Properties
(Свойства макета компакт-диска) (Рис. 3.4).
На вкладке General (Общие) в поле ввода Volume Label (Метка тома) введите с клавиатуры новую метку компакт-диска.
Чтобы в метке тома можно было использовать длинные имена и русские буквы, включая пробелы, для компакт-диска необходимо выбрать файловую систему JOLIET.

Рис. 3.4. Диалог CD Layout Properties
(Свойства макета компакт-диска)

Из списка File System (Файловая система), выберите JOLIET, чтобы можно было использовать длинные имена и русские буквы в именах файлов и папок. Кроме метки тома и типа файловой системы, для создаваемого компакт-диска можно установить и другие свойства.

В группе элементов управления Optimization (Оптимизация) установка переключателя Preserve normal file ordering (Сохранить нормальный порядок файлов) обеспечивает запись файлов на компакт-диск в том порядке, в котором они находятся в макете данных. Установка флажка Single data track only (Единственная дорожка данных) необходима в том случае, когда вы создаете мастер-диск для дальнейшего тиражирования. Тогда все данные, указанные в макете, запишутся на одной дорожке компакт-диска.

Установка переключателя Re-order files to maximize CD creation speed (Переупорядочить файлы для достижения максимальной скорости создания диска) обеспечивает запись файлов на компакт-диск в таком порядке, чтобы максимально ускорить процесс создания диска.

Установка переключателя Re-order files to maximize usable CD space (Переупорядочить файлы для максимальной экономии места на диске) обеспечивает запись файлов на компакт-диск в таком порядке, чтобы сохранить как можно больше места на компакт-диске.

Флажок Automatically import previous session (Автоматически импортировать предыдущую сессию) устанавливается в случае, когда вы записываете на диск несколько сессий и хотите, чтобы данные, записанные в предыдущих сессиях, были также доступны для чтения. Если этот флажок сброшен, то вам надо импортировать предыдущую сессию вручную, выбрав команду меню CD * Import Session (CD * Импортировать сессию).

Флажок Automatically verify File System (Автоматически проверять файловую систему) устанавливается для того, чтобы после записи файлов на компакт-диск производилось их сравнение с оригиналами.

Переключатель Mode 1: CDROM (Режим 1: CDROM) устанавливается в случае, если вы собираетесь записать на компакт-диск только одну сессию.

Переключатель Mode 2: CDROM XA (Режим 2: CDROM XA) устанавливается в случае, если вы собираетесь записать на компакт-диск несколько сессий.

Кнопка Save as Default (Сохранить как установки по умолчанию) позволяет сделать текущие установки установками по умолчанию.

Установите переключатель Preserve normal file ordering (Сохранить нормальный порядок файлов), флажки Single data track only (Единственная дорожка данных) и Automatically import previous session (Автоматически импортировать предыдущую сессию), переключатель Mode 2: CDROM ХА (Режим 2: CDROM XA) и нажмите кнопку Save as Default (Сохранить как установки по умолчанию). Выбранные нами установки станут установками по умолчанию для новых макетов данных.
Нажмите кнопку ОК. Диалог CD Layout Properties (Свойства макета компакт-диска) закроется, и установки вступят в силу.
Выделите файл, который вы хотите переписать на компакт-диск, и нажмите кнопку [image] на панели инструментов. Имя файла будет помещено в макет данных компакт-диска.

Напомним, что в списке папок и файлов можно выделять не только отдельные файлы, но и целые папки и диски, а также группы папок, файлов и дисков. Выделение файлов, расположенных в списке подряд, осуществляется мышью при нажатой клавише "Shift" . а расположенных вразброс - при нажатой клавише "Ctrl" . По мере добавления файлов в макет происходит заполнение строки информации о компакт-диске, находящейся в нижней части диалога, и вы можете определить по шкале, сколько еще свободного места осталось на компакт-диске. В строке состояния программы показывается примерное количество памяти в мегабайтах, которое будут занимать на компакт-диске уже выбранные файлы.

Если вы по ошибке добавили в макет не тот файл или папку, то их можно удалить из макета следующим образом.

Выделите имя файла или папки в макете данных и нажмите клавишу "Delete". На экране появится диалог с просьбой подтвердить удаление (Рис. 3.5).

Рис. 3.5. Диалог о подтверждении удаления файла из макета данных

Подтвердите удаление, нажав кнопку Yes (Да). Диалог о подтверждении удаления файла из макета данных исчезнет, и имя файла будет удалено из макета данных. Будьте внимательны при удалении имен файлов из макета данных - выделяйте имена файлов в макете, т.е. в нижней половине рабочего окна программы Easy CD Creator, а не в верхней его части. В последнем случае удалится не имя файла из макета данных, а сам исходный файл с диска!
Выберите и добавьте в макет данных компакт-диска все папки и файлы, которые вы хотите записать, и нажмите [image] на панели инструментов. На экране появится диалог CD Creation (Рис. 3.6).

Рис. 3.6. Диалог CD Creation Setup Setup (Установки (Установки создания компакт-диска) создания компакт-диска)

В этом диалоге можно выбрать устройство для записи компакт-диска в списке Target Devices (Целевое устройство), скорость записи диска в списке Write Speed (Скорость записи) и количество копий в поле со счетчиком Number of Copies (Количество копий). Значения по умолчанию в этих полях обычно оставляют без изменений.

Нажмите кнопку Advanced (Дополнительные), чтобы установить дополнительные параметры записи компакт-диска. В диалоге CD Creation Setup (Установки создания компакт-диска) появятся дополнительные элементы управления (Рис. 3.7).

Рис. 3.7. Диалог CD Creation Setup (Установки создания компакт-диска) с дополнительными элементами управления .

В группе элементов управления Create Option (Параметры создания) можно выбрать выполнение теста перед фактической записью данных на компакт-диск. Тест эмулирует процесс записи с выключенным лазером. При выполнении теста проверяется, достаточна ли скорость передачи данных с дисков, содержащих исходные файлы, для того, чтобы поток данных для записи на компакт-диск не прерывался. Использование тестовой записи не является обязательным.
Тест нужно выполнять только при первых попытках записи, чтобы узнать возможности вашего оборудования. Выполнение теста занимает столько же времени, сколько и обычная запись, т.е. 74 минуты при однократной скорости записи, 36 минут при двукратной скорости и т.д.

Установка флажка Write CD-Text Info (Записать информацию CD-текст) позволяет включить в компакт-диск информацию о наименовании компакт-диска, именах исполнителей и дорожек и т.п. Эта информация может отображаться только на плеерах, поддерживающих отображение информации CD-Text (CD-текст).

В группе переключателей Write Method (Метод записи) выбирается метод записи диска: Track-At Once (Дорожка за один прием), Session-At Once (Сессия за один прием) или Disc-At Once (Диск за один прием). При выборе режима Track-At Once (Дорожка за один прием) дополнительно указывается способ закрытия после окончания записи: или Leave Session Open (Оставить сессию открытой), или Close Session and Leave CD Open (Закрыть сессию и оставить диск открытым), или Close CD (Закрыть диск). Напомним, что после закрытия диска вы не сможете записать на него другие данные.

Установите переключатели Test and Create CD (Проверить и создать диск), Track-At Once (Дорожка за один прием), Close Session and Leave CD Open (Закрыть сессию и оставить диск открытым) и нажмите кнопку ОК. На экране появится диалог CD Creation Process (Процесс создания компакт-диска) (Рис. 3.8).

Рис. 3.8. Диалог CD Creation Process (Процесс создания компакт-диска)

В диалоге CD Creation Process (Процесс создания компакт-диска) отображается процесс проверки и записи компакт-диска. В диалоге также показывается информация об общем количестве записанных на диск дорожек и файлов, скорости записи и текущей фазе создания компакт-диска.

Если в дисководе для записи компакт-дисков установлен диск CD-RW, то перед записью на экране появится диалог с предупреждением, что такие диски будут читаться только на устройствах CD-ROM, поддерживающих технологию MultiRead (Множественное чтение) (Рис. 3.9).

Рис. 3.9. Диалог с предупреждением о том, что для записи используется диск CD-RW

В этом случае необходимо нажать кнопку ОК для продолжения работы. Предупреждающий диалог исчезнет и процесс создания компакт-диска будет продолжен.

Если какой-либо из файлов, предназначенных для записи на компакт-диск, открыт в другой программе, то на экране появится диалог Find Data File (Найти файл данных) с сообщением об этом (Рис. 3.10).

Рис. 3.10. Диалог Find Data File (Найти файл данных)

Кнопка Find (Найти) помогает найти заблокированные файлы, показывая в диалоге Find Data File (Найти файл данных) имя заблокированного файла и папку, содержащую этот файл (Рис. 3.11).

Рис. 3.11. Диалог Find Data File (Найти файл данных)

Чтобы закрыть диалог Find Data File (Найти файл данных) с найденным файлом, необходимо нажать кнопку Cancel (Отменить).

После того, как вы найдете все заблокированные файлы и закроете их в программах, которые открыли эти файлы, нажмите кнопку Retry (Попытаться еще раз). Диалог Find Data File (Найти файл данных) исчезнет и процесс создания компакт-диска будет продолжен.

Для пропуска заблокированного файла и исключения его из макета данных, надо нажать кнопку Skip (Пропустить) в диалоге Find Data File (Найти файл данных).

По окончании процесса создания компакт-диска программа выдаст команду выдвинуть и вновь задвинуть лоток записывающего устройства, и в диалоге CD Creation Process (Процесс создания компакт-диска) появится сообщение об успешном создании компакт-диска (Рис. 3.12).

Рис. 3.12. Диалог CD Creation Process (Процесс создания компакт-диска), с сообщением об успешном создании компакт-диска

Нажмите кнопку ОК. Диалог CD Creation Process (Процесс создания компакт-диска) исчезнет и на экране останется лишь рабочее окно программы Easy CD Creator.

Макет данных созданного компакт-диска можно сохранить на жестком диске для дальнейшего редактирования и создания на его основе новых компакт-дисков.

Для сохранения макета компакт-диска выберите команду меню File * Save (Файл * Сохранить). На экране появится диалог Save As (Сохранить как) (Рис. 3.13).

Рис. 3. 13. Диалог Save As (Сохранить как)

Укажите диск из раскрывающегося списка Save in (Сохранить в), выберите папку из списка папок, в поле ввода File name (Имя файла) введите имя файла с клавиатуры и нажмите кнопку Save (Сохранить). Макет компакт-диска будет сохранен в выбранной папке, и диалог Save As (Сохранить как) исчезнет с экрана.

В этом знакомстве мы записали одну сессию на пустом компакт-диске с помощью программы Easy CD Creator. В следующем знакомстве мы допишем на компакт-диск новые данные и изменим его метку.


Untitled Document

Знакомство 2. Дописываем CD-ROM с помощью Easy CD Creator

В этом знакомстве мы допишем данные на компакт-диск, созданный в предыдущем знакомстве. Мы также изменим метку диска, которая первоначально была сформирована при записи первой сессии.

Для того, чтобы данные из предыдущих сессий читались после записи на компакт-диск еще одной сессии, то предыдущие сессии необходимо импортировать во вновь записываемую сессию. Если этого не сделать, то стандартными программами, например, программой Проводник (Explorer), мы сможем читать данные только последней записанной сессии. Хотя существуют специальные программы, которые могут читать данные даже не импортированных сессий.
Одна из таких программ - это Session Selector, входящая в комплект программ Adaptec Easy CD Creator. При импорте сессии считывается ее оглавление - ТОС (Table of Contents), и при записи новой сессии формируется новое объединенное оглавление.
Таким образом, если при записи каждой очередной сессии производился импорт предыдущей сессии, то при записи новой сессии достаточно импортировать только одну предыдущую сессию, поскольку она уже содержит оглавление всех сессий, записанных на диск.

Напомним, что дописать данные на компакт-диск мы можем только в том случае, если диск не был закрыт при последней операции записи данных. Ранее мы настроили программу Easy CD Creator таким образом, чтобы по умолчанию диск не закрывался, поэтому мы сможем добавить данные на диск (конечно, если на нем еще осталось свободное место). Кроме этого, мы настроили программу так, чтобы при записи данных на диск автоматически импортировалась предыдущая сессия, чтобы иметь доступ не только к последней записанной сессии, но и ко всему диску.

В предыдущем знакомстве мы не закрывали программу Easy CD Creator, поэтому сейчас на экране должно быть ее рабочее окно с макетом записанного компакт-диска. Сам компакт-диск тоже должен находиться в дисководе для записи компакт-дисков.
Нажмите кнопку [image] на панели инструментов, чтобы создать новый макет данных. В нижней части рабочего окна программы Easy CD Creator будет создан пустой макет данных.
Чтобы узнать количество свободных блоков на компакт-диске, выберите команду меню CD * CD Information (Компакт-диск * Информация о компакт-диске). На экране появится диалог CD Information (Информация о компакт-диске) (Рис. 3.14).

В диалоге отображаются тип выбранного диска, общее число свободных и записанных блоков, а в отдельной таблице - информация о каждой записанной сессии. Напомним, что каждый блок для компьютерных компакт-дисков равен 2048 байт. В диалоге CD Information (Информация о компакт-диске) можно также переписать дорожку с компакт-диска в файл.

В случае музыкального диска это будет кнопка Extract Audio (Извлечь аудио), а в случае диска данных - кнопка Read Track (Прочесть дорожку). Кроме этого, можно стереть диск CD-RW (кнопка Erase (Стереть)), попытаться восстановить испорченный компакт-диск (кнопка Recover (Восстановить)) и, при необходимости, закрыть незакрытую сессию на компакт-диске.

Рис. 3.14. Диалог CD Information (Информация о компакт-диске)

Нажмите кнопку Close (Закрыть), чтобы закрыть диалог CD Information (Информация о компакт-диске). Диалог исчезнет с экрана.
Добавьте файл или папку в новый макет данных, как это описано в предыдущем знакомстве.

Как только мы добавим хотя бы один файл в новый макет, предыдущая сессия будет автоматически импортирована, и все имена файлов и папок, записанных в предыдущей сессии, будут добавлены в новый макет данных. Это происходит потому, что в предыдущем знакомстве мы установили флажок Automatically import previous session (Автоматически импортировать предыдущую сессию) при настройке программы.

Меткой диска останется метка, записанная в предыдущей сессии. Сейчас ее можно изменить следующим образом.

Щелкните правой кнопкой мыши на метке диска в левой части макета данных и из появившегося контекстного меню выберите команду Rename (Переименовать). Метка диска будет выделена.
Введите с клавиатуры новую метку диска Мои данные и нажмите клавишу "Enter" . Метка диска будет изменена (Рис. 3.15).
Перетащите мышью все файлы и папки, которые вы хотите записать на компакт-диск, из верхней части рабочего окна программы Easy CD Creator в макет данных создаваемого компакт-диска.

Работа в верхней и нижней половине рабочего окна программы Easy CD Creator ничем не отличается от работы в программе Проводник (Explorer) операционной системы MS Windows.

Рис. 3.15. Макет диска с измененной меткой диска
Выберите команду меню File * Create CD (Файл * Создать компакт-диск) или нажмите кнопку [image] на панели инструментов программы Easy CD Creator. На экране появится диалог CD Creation Setup (Установки создания компакт-диска) (Рис. 3.7).

На этот раз мы не будем выполнять тест перед записью данных. Тест выполнялся в предыдущем знакомстве, поэтому необходимости в нем нет.

Установите переключатели Create CD (Создать диск), Track-At Once (Дорожка за один прием), Close Session and Leave CD Open (Закрыть сессию и оставить диск открытым) и нажмите кнопку Set as Default (Установить по умолчанию). Выбранные установки станут установками по умолчанию при создании следующих компакт-дисков.
Нажмите кнопку ОК. На экране появится диалог CD Creation Process (Процесс создания компакт-диска) (Рис. 3.8).
По окончании процесса создания компакт-диска, в диалоге CD Creation Process (Процесс создания компакт-диска) появится сообщение об успешном создании компакт-диска (Рис. 3.12).
Нажмите кнопку ОК в диалоге CD Creation Process (Процесс создания компакт-диска). Диалог исчезнет, и на экране останется рабочее окно программы Easy CD Creator, в нижней части которого отображается макет только что созданного диска.

Этот макет можно также сохранить на жестком диске, как это было описано ранее.
Итак, мы дописали на компакт-диск еще одну сессию и изменили метку компакт-диска.


Untitled Document

Знакомство 3. Загрузочный CD-ROM с помощью Easy CD Creator

С помощью программы Easy CD Creator очень просто создавать загрузочные компакт-диски. С них можно загружать компьютер точно так же, как с жесткого диска или загрузочной дискеты. Часто на загружаемые компакт-диски записывают программы для проверки и настройки персонального компьютера и используют эти диски в случае потери данных на жестком диске и невозможности с него загрузиться. Такие компакт-диски часто называют реаниматорами.

Загрузочные компакт-диски могут быть также полезны, например, для резервного копирования жесткого диска с определенной конфигурацией операционной системы и установленных в ней программ.
Такие компакт-диски можно использовать для быстрой установки или восстановления операционной системы Windows, причем можно быстро восстановить операционную систему уже вместе с установленными в ней прикладными программами, каждую из которых иначе пришлось бы устанавливать заново.
Описываемый ниже алгоритм быстрого сброса на жесткий диск операционной системы вместе с установленными в ней программами очень удобно использовать не только для восстановления определенной конфигурации операционной системы на одном компьютере, но и для установки Windows и программ на одинаковые или похожие по внутренней аппаратуре компьютеры. Держать в запасе "чистую" операционную систему с установленными в ней только необходимыми программами очень удобно в том случае, если вы любите экспериментировать с новыми программами или постоянно устанавливаете новые игры и удаляете старые.
Как известно, постоянная установка новых программ и удаление старых - прямой путь к краху операционной системы Windows. Вот тогда-то вам и пригодится компакт-диск с операционной системой и установленными в ней программами для быстрого восстановления работоспособности компьютера. Следует отметить, что даже если у вас большой парк разных компьютеров, то все равно описываемый ниже алгоритм позволит сэкономить вам время для установки или восстановления Windows, так как в этом случае вы можете создать по одному загрузочному компакт-диску для каждой машины.
На разных загрузочных компакт-дисках можно хранить различные конфигурации операционной системы и установленных в ней программ для одного и того же компьютера. Это может оказаться нужным для быстрого перехода к работе над разными проектами, требующими разного набора установленных в системе прикладных программ.

Для того, чтобы быстро в будущем устанавливать или восстанавливать операционную систему Windows, надо сначала установить операционную систему на "чистый" жесткий диск, затем установить все необходимые программы, без которых вы не мыслите свою работу, например, архиваторы и антивирусы, или даже весь MS Office. Установка операционной системы и прикладных программ выходит за рамки данной книги. Теперь вы получили "чистый" образ операционной системы, который можно записать на компакт-диск и затем легко воссоздавать при крахе Windows, т.е. все будет каждый раз восстанавливаться в том виде и с теми необходимыми программами, которые вы установите вначале.
Но если записать каталоги Windows и Program Files просто на компакт-диск, то при восстановлении простым копированием все файлы получат атрибут только-для-чтения (Read-only), что может привести к неправильной работе многих программ. Поэтому лучше заархивировать все необходимые для восстановления папки и файлы в самораспаковывающийся архив, а потом распаковать его при необходимости восстановления операционной системы
Именно так мы и поступим - таким образом вы не только узнаете как создавать загрузочный CD-ROM, но и сразу познакомитесь с очень полезным способом восстановления операционной системы Самораспаковывающийся архив - это программа, которая содержит в себе упакованные файлы, и при запуске распаковывает их на диск. Такой архив удобен тем, что не требует дополнительных программ для извлечения данных - все делает небольшой программный модуль, который встраивается в архив.
Перед тем, как рассматривать процедуру подготовки операционной системы Windows к сохранению на CD-ROM и ее восстановления на жестком диске, отметим некоторые важные моменты.

  • При подготовке загрузочного компакт-диска мы не можем загружать с него операционную систему Windows 95/98, а только операционную систему MS-DOS или операционную систему, которая не записывает данные на диск во время загрузки. Операционная система Windows 95/98 во время загрузки записывает данные на диск, поэтому не может загружаться с компакт-диска.
  • В операционной системе Windows 95/98 могут выполняться как 16-разрядные, так и 32-разрядные программы, а в операционной систем MS-DOS могут выполняться только 16-разрядные программы. Поэтом архивировать файлы приложений и файлы самой операционной систг мы можно только 16-разрядными архиваторами, иначе после загрузки MS-DOS с компакт-диска, архивы нечем будет распаковать.
  • В операционной системе Windows 95/98 используются длинные имена файлов, а в операционной системе MS-DOS только короткие (8+3 Следовательно, нужны такие 16-разрядные архиваторы, которые умели бы сохранять в архивах длинные имена файлов при работе под управлением операционной системы Windows 95/98. Такими архиваторами являются последние версии "досовских" 16-разрядных архиваторов RAR и ARJ. Архиваторы же WINRAR и WINZIP, а также практически все архиваторы с красивой графической оболочкой, являются 32-разрядным, и их использовать нельзя.
  • Тем не менее, при работе под управлением операционной системы MS-DOS ни архиватор RAR, ни архиватор ARJ не умеют восстанавливать длинные имена файлов, даже если они есть в архиве.

Следовательно, нужна дополнительная программа, которая могла бы восстанавливать в операционной системе MS-DOS длинные имена файлов. Такой программой является профамма DOSLFNBK, ранние версии которой можно бесплатно скачать на странице разработчика по адресу:

http://www8.pair.com/dmurdoch/programs/

Для того, чтобы подготовить образ операционной системы для записи на загрузочный компакт-диск, надо выполнить следующие действия:

1. Переписать в корневой каталог диска С: профамму DOSLFNBK.
2. Перезагрузить систему в режиме MS-DOS.
3. Выполнить команды MS-DOS:

С:\
CD\
DOSLFNBK C:\

В результате в корневом каталоге диска С: получится файл C:\BACKUP.LFN, содержащий список соответствия коротких и длинных имен всех файлов на диске С:.

4. Заархивировать все файлы из корневого каталога диска С:, папку Windows и папку Program Files вместе со всеми подпапками в самораспаковывающийся архив лучше формата RAR или ARJ, так как не все архиваторы упаковывают файлы с атрибутами системный и скрытый, а программы RAR и ARJ могут это делать.
5. Записать этот самораспаковывающийся архив на загрузочный компакт-диск. В корневой каталог загрузочного диска также надо добавить файлы SYS.COM и DELTREE.EXE из каталога C:\Windows\Command. Так как версии программ могут изменяться, то имеет смысл сделать два архива - один чистый Windows до установки прикладных программ, другой - после установки нужных прикладных программ.

Программа SYS.COM нужна для быстрой установки операционной системы MS-DOS на отформатированный жесткий диск. Программа DELTREE.EXE нужна для быстрого удаления каталогов с испорченной версией операционной системы Windows.

Записав все это на загрузочный компакт-диск, вы можете использовать его для быстрого восстановления системы. Для этого можно загрузиться непосредственно с компакт-диска, но если ваша базовая система ввода-вывода BIOS не поддерживает загрузку с компакт-дисков, то загрузитесь с загрузочной дискеты Windows, на которой есть драйверы CD-ROM привода. Чтобы восстановить операционную систему Windows, необходимо выполнить следующие действия:

1. Удалить каталоги Program Files (в операционной системе MS-DOS он будет называться PROGRA~1) и папку Windows с помощью программы DELTREE.EXE.
2. Выполнить команду SYS С:, чтобы восстановить загрузочный сектор жесткого диска.
3. Сделать текущим корневой каталог диска С: с помощью команд С: и CD\.
4. Запустить с компакт-диска самораспаковывающийся архив, например, командой D:\ARJARC.EXE.
5. После распаковки архива на жесткий диск восстановить длинные имена файлов с помощью команды DOSLFNBK /r.
6. Перезагрузиться с винчестера.

Следует отметить, что если места на жестком диске достаточно, то лучше переименовать старые каталоги Program Files (в операционной системе MS-DOS он будет называться PROGRA-1) и папку Windows в какие-нибудь нейтральные имена типа 1 или 2, так как удаление с помощью программы DELTREE.EXE занимает значительное время; быстрее будет удалить переименованные каталоги с помощью программы Проводник (Explorer) после восстановления операционной системы Windows.

Чтобы загружаться с компакт-диска, необходимо, чтобы эту возможность поддерживала базовая система ввода-вывода (BIOS) материнской платы вашего компьютера. В случае, если у вас дисковод CD-ROM с интерфейсом SCSI, то возможность загрузки с компакт-диска должна поддерживать система BIOS SCSI-контроллера. Большинство современных компьютеров поддерживает загрузку с компакт-дисков.

Перед созданием загрузочного компакт-диска необходимо подготовить обычную загрузочную дискету и проверить, загружается ли с нее ваш компьютер. Минимальный состав файлов на загрузочной дискете может быть примерно таким:

IO.SYS
MSDOS.SYS
COMMAND.COM
AUTOEXEC.BAT
CONFIG.SYS
HIT-IDE.SYS
MSCDEX.EXE

Чтобы операционная система MS DOS, которая загружается с дискеты, могла читать файлы с дисковода CD-ROM, файл AUTOEXEC.BAT может содержать единственную команду запуска драйвера MSCDEX.EXE

MSCDEX.EXE /D:MSCD002 /M:8 а файл CONFIG.SYS может содержать также единственную команду загрузки драйвера вашего устройства CD-ROM, например,

DEVICE=HIT-IDE.SYS /D:MSCD002

для загрузки драйвера дисковода CD-ROM фирмы Hitachi. Если у вас дисковод CD-ROM другой фирмы, то последняя строка также будет другой, так как файл драйвера HIT-IDE.SYS для дисковода Hitachi не подойдет для дисководов других фирм. Следовательно, созданный на основе этой дискеты загрузочный компакт-диск подойдет для загрузки только компьютеров с дисководами фирмы Hitachi.

В операционной системе MS Windows 98 при создании загрузочной дискеты на нее автоматически копируются драйверы дисковода CD-ROM, а в командные файлы AUTOEXEC.BAT и CONFIG.SYS записываются команды для их установки. Загруженная с этой дискеты система сможет читать данные с большинства дисководов CD-ROM.
Но при создании загрузочной дискеты в операционной системе MS Windows 95 драйверы компакт-диска на дискету не записываются, поэтому после создания дискеты необходимо вручную переписать на нее драйверы CD-ROM и в файлы AUTOEXEC.BAT и CONFIG.SYS добавить любым текстовым редактором команды для их установки. Процедура создания загрузочной дискеты для операционных систем MS Windows 95 и MS Windows 98 очень проста и одинакова.

Нажмите кнопку Пуск (Start) на Панели задач (Taskbar) операционной системы Windows. На экране появится главное меню операционной системы Windows.
Выберите команду главного меню Настройка * Панель управления (Settings * Control Panel). На экране появится окно Панель управления (Control panel) (Рис. 3.16).

Рис. 3.16. Окно Панель управления (Control panel)

Дважды щелкните мышью на строке Установка и удаление программ (Add/Remove Programs). На экране появится диалог Свойства: Установка и удаление программ (Add/Remove Programs Properties) (Рис. 3.17).

В диалоге Свойства: Установка и удаление программ (Add/Remove Programs Properties) выберите вкладку Загрузочный диск (Startup Disk) (Рис. 3.18).

Рис. 3.17. Диалог Свойства:Установка и удаление программ (Add/Remove Programs Properties)

Рис. 3.18. Вкладка Загрузочный диск (Startup Disk)диалога Свойства: Установка и удаление программ (Add/Remove Programs Properties)

  • Установите в дисковод CD-ROM компакт-диск, с которого вы устанавливали операционную систему Windows, и нажмите кнопку Создать диск (Create Disk). На вкладке Загрузочный диск (Startup Disk) диалога Свойства: Установка и удаление программ (Add/Remove Programs Properties) начнет отображаться процесс создания загрузочной дискеты, и на экране появится диалог Вставка диска (Insert Disk) (Рис. 3.19)
  • Установите чистую дискету в дисковод и нажмите кнопку ОК. Диалог Вставка диска (Insert Disk) исчезнет, и на дискету перепишутся с компакт-диска необходимые файлы.

Рис. 3.19. Диалог Вставка диска (Insert Disk)

Если на вашей дискете были какие-либо файлы, то при создании загрузочной дискеты они будут уничтожены. Если вы забудете установить в дисковод CD-ROM компакт-диск с дистрибутивом операционной системы Windows, то вам будет выдано напоминание об этом (Рис. 3.20).

В этом случае необходимо установить требуемый компакт-диск и нажать кнопку ОК.

Рис. 3.20. Диалог с напоминанием о необходимости установить компакт-диск

По окончании создания загрузочной дискеты нажмите кнопку ОК в диалоге Свойства: Установка и удаление программ (Add/Remove Programs Properties), чтобы закрыть его.
Закройте окно Панель управления (Control panel), нажав кнопку [image] в заголовке окна.

Загрузочная дискета готова, и можно приступать к созданию самого загрузочного компакт-диска. В предыдущем знакомстве мы не выходили из программы Easy CD Creator, поэтому ее рабочее окно должно быть на экране вашего монитора.

Для создания загрузочного компакт-диска программа Easy CD Creator должна быть запущена из главного меню операционной системы Windows с помощью команды Программы * Adaptec Easy CD Creator 4 * Features * Easy CD Creator (Programs * Adaptec Easy CD Creator * Возможности *Easy CD Creator).
Чтобы создать новый макет загрузочного компакт-диска, нажмите стрелку [image], расположенную рядом с кнопкой [image] на панели инструментов программы Easy CD Creator . На экране появится список типов компакт-дисков, которые можно создать в программе (Рис. 3.21).

Рис. 3.21. Список типов компакт-дисков, которые можно создать в программе Easy CD Creator

Если запустить программу Easy CD Creator с помощью команд: Data CD (Диск данных) из контекстного меню значка [image] расположенного в правой части Панели задач (Taskbar), то на панели инструментов рабочего окна программы стрелки [image] рядом с кнопкой [image] не будет и вы не сможете выбрать создание загрузочного компакт-диска.

Выберите из списка команду Bootable CD (Загрузочный компакт-диск На экране появится диалог с предложением сохранить предыдущий макет данных компакт-диска (Рис. 3.22).

Рис. 3.22. Диалог с предложением сохранить макет данных компакт-диска

Нажмите кнопку No (Нет), чтобы отказаться от сохранения предыдущего макета данных. Диалог с предложением сохранить макет данных компакт-диска исчезнет, и на экране появится диалог Prepare Bootable Files (Подготовьте загрузочные файлы) (Рис. 3.23).

В диалоге Prepare Bootable Files (Подготовьте загрузочные файлы) содержится просьба установить загрузочную дискету в дисковод. Загрузочная дискета у нас уже находится в дисководе, поэтому можно продолжать работу.

Рис. 3.23. Диалог Prepare Bootable Files
(Подготовьте загрузочные файлы)

Нажмите кнопку ОК. Диалог Prepare Bootable Files (Подготовьте загрузочные файлы) исчезнет и на экране появится сообщение о чтении информации с загрузочной дискеты (Рис. 3.24).

Рис. 3.24. Сообщение о чтении информации с загрузочной дискеты

 При чтении загрузочной дискеты программа Easy CD Creator проверяет ее формат и выдает сообщение о неверном формате загрузочной дискеты (Рис. 3.25), если он не соответствует установленным требованиям. При этом с самой неверной дискеты иногда можно загрузиться обычным образом.

Рис. 3.25. Сообщение об ошибке при создании загружаемого образа дискеты

По окончании чтения информации с загрузочной дискеты сообщение, приведенное на Рис. 3.24, исчезнет с экрана, и в макете компакт-диска
появятся два новых файла (Рис. 3.26). В файле BOOTIMG.BIN содержится образ загрузочной дискеты, и он совместно с файлом BOOTCAT.BIN обеспечивает загрузку с компакт-диска. Переименуем метку диска.

Рис. 3.26. Макет данных с файлами, обеспечивающими загрузку с компакт-диска

 Щелкните правой кнопкой мыши на метке диска в левой части макета данных и из появившегося контекстного меню выберите команду Rename (Переименовать). Метка компакт-диска будет выделена. Введите с клавиатуры новую метку диска MY_BOOT и нажмите клавишу Enter. Метка диска будет изменена.
При создании загрузочных компакт-дисков следует иметь в виду, что для них автоматически выбирается файловая система ISO9660, поэтому в метке диска можно использовать только английские буквы и символ подчеркивания "_". Файловую систему JOLIET для загрузочных компакт-дисков использовать нельзя.
В макет данных компакт-диска помещена загрузочная информация с дискеты, а остальное содержимое компакт-диска формируется точно так же, как мы это делали в двух предыдущих знакомствах.

Перетащите мышью файлы и папки из верхней части рабочего окна программы Easy CD Creator, где отображается содержимое файловой системы вашего компьютера, в его нижнюю часть, где отображается макет создаваемого компакт-диска. Поскольку при создании загрузочных компакт-дисков используется файловая система ISO9660, то все длинные имена файлов и папок в макете данных будут преобразованы в короткие.
Выберите команду меню File * Create CD (Файл * Создать компакт-диск) или нажмите кнопку
на панели инструментов программы Easy CD Creator. На экране появится диалог CD Creation Setup
(Установки создания компакт-диска) (Рис. 3.7).

Установите переключатели Create CD (Создать диск), Track-At Once (Дорожка за один прием), Close Session and Leave CD Open (Закрыть сессию и оставить диск открытым) и нажмите кнопку ОК. На экране появится диалог CD Creation Process (Процесс создания компакт-диска) (Рис. 3.8).

По окончании процесса создания компакт-диска программа выдаст команду выдвинуть и вновь задвинуть лоток записывающего устройства, и в диалоге CD Creation Process (Процесс создания компакт-диска) появится сообщение об успешном создании компакт-диска (Рис. 3.12).

Нажмите кнопку ОК в диалоге CD Creation Process (Процесс создания компакт-диска). Диалог исчезнет, и на экране останется рабочее окно программы Easy CD Creator, в нижней части которого отображается макет только что созданного диска.

Этот макет можно сохранить на жестком диске для дальнейшего использования.

Завершите работу с программой Easy CD Creator, выбрав команду меню File * Exit (Файл * Выход). Рабочее окно программы закроется, и она завершит свою работу.

Если теперь изменить установки BIOS так, чтобы разрешить загрузку с компакт-диска и загрузиться с только что созданного диска, то после загрузки на экране появится подсказка операционной системы MS-DOS вида А:>.

Содержимое диска А: - это содержимое загрузочной дискеты, использованной при изготовлении загрузочного компакт-диска. Для обращения к дисководу для чтения дискет используется имя устройства В:, имена жестких дисков остаются неизменными.

Если при изготовлении загрузочного компакт-диска использовалась дискета, созданная операционной системой Windows 98, то в системе появляется дополнительный виртуальный диск размером 2 Мб, на котором расположены сервисные программы. Эти программы появляются в результате распаковки сжатого файла, расположенного на загрузочной дискете.
Если бы сервисные программы не были упакованы в один сжатый файл, то они бы просто не поместились на загрузочной дискете размером 1,44 Мб. Виртуальный диск будет назван буквой, следующей за буквой, используемой для названия последнего жесткого диска. Например, если у вас жесткие диски С: и D:, то именем виртуального диска будет Е:, а для компакт-диска будет использовано имя F:.

Если посмотреть содержимое самого загрузочного компакт-диска, то на нем будут расположены уже упоминавшиеся файлы BOOTIMG.BIN и BOOTCAT.BIN, а также файлы и папки, добавленные в макет компакт-щека при создании диска. Если не загружаться с компакт-диска, а загрузить операционную систему Windows обычным образом, то невозможно получить доступ к файлам загрузочной части - они доступны только при загрузке с самого компакт-диска.

Итак, мы создали загрузочный компакт-диск с помощью программы Easy CD Creator. В следующих знакомствах мы запишем сессию на компакт-диск, допишем на него данные и создадим загрузочный диск с помощью программы WinOnCD.


Untitled Document

Знакомство 4. Создаем CD-ROM с помощью WinOnCD

Создадим компакт-диск с данными с помощью мастера создания дисков программы WinOnCD.

Запустите мастер создания компакт-дисков программы WinOnCD, нажав кнопку Пуск (Start) на Панели задач (Taskbar) операционной системы Windows и выбрав команду главного меню Программы * CeQuadrat * WinOnCD Wizard (Programs * CeQuadrat * Мастер создания компакт-дисков программы WinOnCD). На экране появятся два окна: в левой половине экрана первый диалог мастера создания компакт-дисков, а в правой половине экрана - рабочее окно программы WinOnCD (Рис. 3.27).

Рис. 3.27. Первый диалог мастера создания компакт-дисков и рабочее окно программы WinOnCD

В первом диалоге мастера создания компакт-дисков содержится приветствие и не предлагается выполнить никаких практических шагов.
Щелкните мышью на значке [image] в нижней части первого диалога для продолжения работы. На экране появится второй диалог мастера создания компакт-дисков (Рис. 3.28).

Во втором диалоге можно выбрать тип создаваемого компакт-диска, установив один из переключателей: Data CD (Диск данных), AudioCD (Музыкальный диск), CD Copy (Копия диска) или VideoCD (Диск видео).
Установите переключатель Data CD (Диск данных) и щелкните мышью на значке [image] для продолжения работы. На экране появится третий диалог мастера создания компакт-дисков (Рис. 3.29).

Рис. 3.28. Второй диалог мастера создания компакт-дисков

Рис. 3.29. Третий диалог мастера создания компакт-дисков

В третьем диалоге необходимо указать, добавляете ли вы данные на уже записанный компакт-диск.
Установите переключатель No (Нет) и щелкните мышью на значке [image] для продолжения работы. На экране появится четвертый диалог мастера создания компакт-дисков (Рис. 3.30).

В поле ввода четвертого диалога мастера создания компакт-дисков введите с клавиатуры новую метку компакт-диска Мой диск и щелкните мышью на значке [image] для продолжения работы. На экране появится пятый диалог мастера создания компакт-дисков, а в рабочем окне программы WinOnCD будут отмечены его разные части с помощью кружочков с номерами (Рис. 3.31).

Рис. 3.30. Четвертый диалог мастера создания компакт-дисков

Напомним, что в части [image] рабочего окна программы WinOnCD отображается дерево папок файловой системы вашего компьютера, в части - [image] сами файлы и папки, а в части [image] - имена файлов и папок в макете создаваемого компакт-диска.

Рис 3.31. Пятый диалог мастера создания компакт-дисков

Выбирая диски в части [image] рабочего окна программы WinOnCD, файлы и папки в части [image] и перетаскивая их мышью в часть [image] рабочего окна, создайте макет будущего компакт-диска.

В макете компакт-диска вы можете переименовывать файлы, перемещать их из папки в папку точно так же, как вы это делаете в программе Проводник (Explorer).
По окончании создания макета компакт-диска щелкните мышью на значке [image] для продолжения работы.На экране появится шестой диалог мастера создания компакт-дисков (Рис. 3.32).

В шестом диалоге предлагается выбрать установки по умолчанию или отказаться от стандартных установок (переключатель No(Нет) )Установите переключатель Normal settings (Обычные установки) и щелкните мышью на значке [image] для продолжения работы. На экране появится заключительный диалог мастера создания компакт-дисков и рабочее окно программы WinOnCD (Рис. 3.33).

Рис 3.32. Шестой диалог мастера создания компакт-дисков

Рис. 3.33. Заключительный диалог мастера создания компакт-дисков и рабочее окно программы WinOnCD

Закройте заключительный диалог мастера создания компакт-дисков, нажав кнопку [image] в его заголовке. Рабочее окно программы WinOnCD развернется на весь экран (Рис. 3.34).

Рис. 3.34. Рабочее окно программы WinOnCD в режиме установки параметров записи компакт-диска

Назначение параметров, которые можно установить в этом окне, уже подробно обсуждалось при знакомстве с программой Easy CD Creator, но здесь мы кратко повторим их еще раз.
В группе переключателей Fixation (Фиксация) выбирается закрытие сессии или всего диска по окончании записи. Можно выбрать один из следующих переключателей:

  • Create Multisession CD, current session is closed and additional sessions possible (Создать несколько сессий, текущая сессия закрывается и можно записать дополнительные сессии);
  • Close disc. Sessions cannot be added later (Закрыть диск. Больше сессий не может быть добавлено).
    В группе переключателей Test Write (Тестовая запись) можно выбрать один из следующих переключателей:
  • Simulate writing only (Только имитировать запись);
  • Simulate writing once, then write if successful (Имитировать один раз запись и записать при успешной имитации);
  • Write immediately (Записать сразу).

    В группе элементов управления Output (Вывод) можно выбрать устройство записи из списка Write to (Записать на), посмотреть информацию об устройстве записи, нажав кнопку Recorder info (Информация об устройстве записи), и выбрать скорость записи из списка Speed (Скорость).

    В группе переключателей Write mode (Режим записи) можно выбрать один из следующих переключателей:

  • Track at once (Дорожка за один раз);
  • Disc/Session at once (Диск/Сессия за один раз).

При достаточно высокой скорости чтения с исходных дисков можно установить флажок Write 'on the fly' is possible (Допускается 'запись на лету'). Это позволит повысить скорость записи компакт-диска, поскольку записываемые данные будут писаться на компакт-диск сразу, и не будет предварительной подготовки дорожки на жестком диске. Если вы не уверены в производительности своего компьютера, то этот флажок лучше не устанавливать.

Также можно установить поле со счетчиком Number of copies (Количество копий) и восстановить параметры по умолчанию, нажав кнопку Refresh (Обновить).
Измените, при необходимости, стандартные установки и нажмите кнопку [image] в окне Disc Properties and Recording Settings / CD-XA disc (Свойства диска и параметры записи / Диск CD-XA). На экране появится диалог Make CD (Создание компакт-диска), в котором отображается процесс создания компакт-диска (Рис. 3.35).

Рис. 3.35. Диалог Make CD (Создание компакт-диска)

По окончании процесса создания компакт-диска на экране появится диалог с сообщением об успешной записи компакт-диска (Рис. 3.36).

Рис. 3.36. Сообщение об успешном создании компакт-диска

Нажмите кнопку ОК. Диалог с сообщением об успешной записи компакт-диска исчезнет с экрана и программа выдаст команду выдвинуть лоток с записанным компакт-диском.

Завершите работу с программой WinOnCD, выбрав команду меню File * Exit (Файл * Выйти). На экране появится диалог с предложением сохранить макет компакт-диска (Рис. 3.37).

Рис. 3.37. Диалог с предложением сохранить макет компакт-диска

 Нажмите кнопку No (Нет). Программа WinOnCD завершит работу и ее рабочее окно исчезнет с экрана.

Итак, первая сессия с данными записана на компакт-диск с помощью мастера создания дисков программы WinOnCD. В следующем знакомстве мы добавим на компакт-диск еще одну сессию.


Untitled Document

Знакомство 5. Дописываем CD-ROM с помощью WinOnCD

В этом знакомстве мы допишем данные на диск, записанный в предыдущем знакомстве. Допишем данные также с помощью программы WinOnCD, но на этот раз мы не будем пользоваться услугами мастера создания компакт-дисков.

Запустите программу WinOnCD, нажав кнопку Пуск (Start) на Панели задач (Taskbar) операционной системы Windows и выбрав команду главного меню Программы * CeQuadrat * WinOnCD (Programs * CeQuadrat * WinOnCD). На экране появится заставка программы (Рис. 3.2) и, вслед за ней, диалог New Project (Новый проект) (Рис. 3.38).

Если вместо этого диалога на экране сразу появляется рабочее окно программы WinOnCD (Рис. 3.40), то диалог New Project (Новый проект) может быть вызван из программы при выборе команды меню File * New (Файл * Новый).

Рис. 3.38. Диалог New Project (Новый проект)

На вкладке Favorites (Избранные) выделите мышью значок [image] Append Session (ISO 9660 / Joliet) (Добавить сессию (ISO 9660 / Joliet)) и нажмите кнопку ОК. На экране на короткое время появится диалог, в котором отображается процесс импортирования предыдущей сессии (Рис. 3.39).

Рис. 3.39. Диалог, отображающий процесс импортирования предыдущей сессии

По окончании процесса импортирования предыдущей сессии диалог, отображающий этот процесс, исчезнет, и на экране появится рабочее окно программы WinOnCD (Рис. 3.40).

Как видно из рисунка, программа автоматически импортировала сессию, записанную в предыдущем знакомстве. Осталось только добавить файлы и папки в макет компакт-диска, как мы уже делали это ранее, и дописать еше одну сессию.

Выбирая папки и файлы в верхней половине рабочего окна программы WinOnCD и перетаскивая их мышью в нижнюю часть рабочего окна, добавьте их в макет будущего компакт-диска.

Рис. 3.40. Рабочее программы WinOnCD с импортированной сессией

Как уже упоминалось ранее, в макете компакт-диска вы можете переименовывать файлы, перемещать их из папки в папку точно так же, как это делается в программе Проводник (Explorer).
По окончании создания макета компакт-диска нажмите кнопку [image] Disc (Диск) в левой нижней части рабочего окна программы WinOnCD или выберите команду меню Record * Make CD (Запись * Создать компакт-диск), чтобы переключить рабочее окно программы в режим установки параметров записи компакт-диска (Рис. 3.34).
Установите желаемые параметры записи компакт-диска и нажмите кнопку [image] в окне Disc Properties and Recording Settings / CD-XA disc (Свойства диска и параметры записи / Диск CD-XA). На экране появится диалог Make CD (Создание компакт-диска), в котором отображается процесс создания компакт-диска (Рис. 3.35). По окончании процесса создания компакт-диска на экране появится диалог с сообщением об успешной записи компакт-диска (Рис. 3.36).

Нажмите в диалоге кнопку ОК. Диалог с сообщением об успешной записи компакт-диска исчезнет с экрана и программа выдаст команду выдвинуть лоток с записанным компакт-диском.

Мы дописали на компакт-диск вторую сессию с данными. Чтобы убедиться в этом, можно посмотреть информацию о записанном компакт-диске.

Установите записанный компакт-диск в привод CD-ROM.

Выберите команду меню Record * Disc Info (Запись * Информация о диске). На экране появится диалог CD Information (Информация о компакт-диске) (Рис. 3.41).

Рис. 3.41. Диалог CD Information (Информация о компакт-диске)

На вкладке Disc Info (Информация о диске) диалога CD Information (Информация о компакт-диске) отображаются следующие данные:

  • Disk Type (Тип диска);
  • Disk Size (Объем диска);
  • Number of Sessions (Число сессий). Это число на единицу больше числа фактически записанных сессий;
  • Number of Tracks (Число дорожек);
  • Free Space (Свободное пространство);
  • Space Required (Требуемое пространство);
  • Write Address (Адрес записи). Адрес записи новой сессии задается в виде минуты:секунды:сектор. Каждая секунда содержит 75 секторов. Напомним, что на компьютерном компакт-диске с данными каждый сектор содержит блок данных размером в 2048 байт;
  • Required Write Address (Требуемый адрес записи);

Вы можете самостоятельно посмотреть дополнительную информацию о компакт-диске на других вкладках диалога CD Information (Информация о компакт-диске).

Закройте диалог CD Information (Информация о компакт-диске), нажав в нем кнопку ОК.
Завершите работу с программой WinOnCD, выбрав команду меню File * Exit (Файл * Выйти). На экране появится диалог с предложением сохранить макет компакт-диска (Рис. 3.37).
Нажмите в диалоге кнопку No (Нет), чтобы отказаться от сохранения макета компакт-диска. Программа WinOnCD завершит работу, и ее рабочее окно исчезнет с экрана.

Мы дописали на компакт-диск две сессии с данными с помощью программы WinOnCD. В следующем знакомстве с помощью этой же программы мы создадим загрузочный компакт-диск.


Untitled Document

Знакомство 6. Загрузочный CD-ROM с помощью WinOnCD

 Если при создании загрузочного компакт-диска с помощью программы Easy CD Creator используется загрузочная дискета, то программа WinOnCD может в качестве загрузочной части компакт-диска использовать не только загрузочную дискету, но и загружаемый раздел жесткого диска (обычно это диск С:).
Для этого загружаемый раздел жесткого диска должен быть не более 650 Мб, чтобы полностью уместиться на компакт-диске. Кроме этого, загружаемая операционная система не должна ничего записывать на диск в процессе загрузки. Такой операционной системой может быть, например, MS-DOS или Windows 3.x. Операционные системы Windows 95/98/NT не могут обойтись без записи на диск во время загрузки. Они, в частности, создают и записывают на диск копию системного реестра, поэтому раздел жесткого диска с операционной системой Windows 95/98/NT использовать в качестве загружаемой части компакт-диска нельзя.

Загрузочные компакт-диски, созданные с помощью программы WinOnCD, точно так же, как и созданные с помощью программы Easy CD Creator, можно использовать как при восстановлении работоспособности компьютера (реаниматоры), так и для быстрого восстановления на жестком диске операционной системы и установленных в ней прикладных программ.

Приступим к созданию загрузочного компакт-диска с помощью программы WinOnCD. Если при этом вы хотите использовать загрузочную дискету, то ее надо предварительно создать, как это было описано в знакомстве "Загрузочный CD-ROM с помощью Easy CD Creator" этой главы.

Запустите программу WinOnCD, нажав кнопку Пуск (Start) на Панели задач (Taskbar) операционной системы Windows и выбрав команду главного меню Программы * CeQuadrat * WinOnCD (Programs * CeQuadrat * WinOnCD). На экране появится заставка программы (Рис. 3.2) и, вслед за ней, диалог New Project (Новый проект) (Рис. 3.38).

Как уже упоминалось ранее, если вместо диалога New Project (Новый проект) на экране сразу появляется рабочее окно программы WinOnCD (Рис. 3.40), то этот диалог может быть вызван из программы с помощью команды меню File * New (Файл * Новый).

Выберите вкладку Data (Данные) в диалоге New Project (Новый проект) (Рис. 3.42).

Рис. 3.42. Вкладка Data (Данные) диалога New Project (Новый проект)

На вкладке Data (Данные) выберите элемент Bootable CD (Загружаемый компакт-диск) и нажмите кнопку ОК. На экране появится рабочее окно программы WinOnCD с макетом загрузочного компакт-диска (Рис. 3.43).

Рис. 3.43. Рабочее окно программы WinOnCD с макетом загрузочного компакт-диска

Установите в дисковод А: загрузочную дискету.
Перетащите мышью имя диска А: из верхней половины рабочего окна программы WinOnCD в его нижнюю половину на строку 01: Boot source: undefined (01: Источник загрузки: не определен). Текст в строке изменится на 01: Boot source: 1440 Kbyte copy of drive A: (01: Источник загрузки: 1440 Кбайт копия диска А:).

Следует иметь в виду, что при формировании загрузочной части макета компакт-диска в нее можно перетаскивать только весь диск целиком. Отдельные файлы и папки перетаскивать в загрузочную часть макета нельзя.

В макете компакт-диска выделите вторую строку, в которой указываются тип создаваемой на диске файловой системы и метка компакт-диска, и нажмите кнопку [image] Editor (Редактор) в окне макета компакт-диска. В окне макета компакт-диска появится панель инструментов, и его внешний вид изменится (Рис. 3.44).

Рис. 3.44. Рабочее окно программы WinOnCD

Щелкните правой кнопкой мыши на метке диска в левой части макета данных и из появившегося контекстного меню выберите команду Volume label (Метка тома). Метка диска будет выделена.
Введите с клавиатуры новую метку диска My bootable disc (Мой загрузочный диск) и нажмите клавишу "Enter" . Метка диска будет изменена на MY_BOOTABLE_DISC. Мы видим, что все буквы в метке диска заменились на прописные, а недопустимые в стандарте ISO 9660 символы (пробелы) заменились на символ "_". Заметим, что в стандарте ISO 9660 нельзя использовать русские буквы для метки тома.
Перетащите мышью файлы и папки из верхней части рабочего окна программы WinOnCD, где отображается содержимое файловой системы вашего компьютера, в его нижнюю часть, где сейчас отображается макет не загружаемой части создаваемого компакт-диска. Поскольку при создании загрузочных компакт-дисков используется файловая система ISO 9660, то все длинные имена файлов и папок в макете данных будут преобразованы в короткие.
Выбирая папки и файлы в верхней половине рабочего окна программы WinOnCD и перетаскивая мышью в нижнюю часть рабочего окна, добавьте их в макет компакт-диска.
По окончании создания макета компакт-диска нажмите кнопку [image] Disc (Диск) в левой нижней части рабочего окна программы WinOnCD или выберите команду меню Record * Make CD (Запись * Создать компакт-диск), чтобы переключить рабочее окно программы в режим установки параметров записи компакт-диска (Рис. 3.34).
Установите желаемые параметры записи компакт-диска и нажмите кнопку [image] в окне Disc Properties and Recording Settings / CD-XA disc (Свойства диска и параметры записи / Диск CD-XA). На экране появится диалог Make CD (Создание компакт-диска), в котором отображается процесс создания компакт-диска (Рис. 3.35).
По окончании процесса создания компакт-диска на экране появится диалог с сообщением об успешной записи (Рис. 3.36).
Нажмите в диалоге кнопку ОК. Диалог с сообщением об успешной записи компакт-диска исчезнет с экрана, и программа выдаст команду выдвинуть лоток с записанным компакт-диском.
Завершите работу с программой WinOnCD, выбрав команду меню File * Exit (Файл * Выйти). На экране появится диалог с предложением сохранить макет компакт-диска (Рис. 3.37).
Нажмите в диалоге кнопку No (Нет), чтобы отказаться от сохранения макета компакт-диска. Программа WinOnCD завершит работу, и ее рабочее окно исчезнет с экрана.

При загрузке с созданного компакт-диска на экране появится подсказка той операционной системы, которая была на дискете или в разделе жесткого диска, использованного при создании загрузочного диска.
Обычно это подсказка А:> операционной системы MS-DOS. Содержимое диска А: это содержимое загрузочной дискеты или раздела жесткого диска, использованного при изготовлении загрузочного компакт-диска; для обращения к дисководу для чтения дискет используется имя устройства В:, имена жестких дисков остаются неизменными. Если при изготовлении загрузочного компакт-диска использовалась дискета созданная операционной системой Windows 98, то в системе появляется дополнительный виртуальный диск размером 2 Мб, на котором расположены сервисные программы. Для имени виртуального диска используется буква, следующая за буквой, используемой для названия последнего жесткого диска. Например, если у вас жесткие диски С: и D:, то именем виртуального диска будет Е:, а для компакт-диска будет использовано имя F:.

Если не загружаться с компакт-диска, а загрузить операционную систему Windows обычным образом, то загрузочная часть компакт-диска не видна - видны только файлы и папки, записанные в незагружаемую часть диска. Как упоминалось ранее, программа WinOnCD обладает, по сравнению с программой Easy CD Creator, дополнительной возможностью использовать раздел жесткого диска в качестве загружаемой части компакт-диска. Но зато она не производит проверку загрузочной дискеты или раздела жесткого диска на правильность. Даже если исходная дискета или раздел жесткого диска имеют неверный формат, они будут использованы программой WinOnCD в качестве загружаемой части компакт-диска, и тогда созданный компакт-диск не будет загружаться. Такую ошибку обнаружить чрезвычайно трудно, потому что с самой дискеты система может прекрасно загружаться, и вы можете испортить много пустых компакт-дисков, прежде чем замените исходную загрузочную дискету. А вот программа Easy CD Creator проверяет исходную загрузочную дискету и сразу выдает сообщение о ее неверном формате, даже если с нее можно загрузиться.


Untitled Document

Знакомство 7. Копируем CD-ROM'ы

Если в предыдущих знакомствах мы выборочно копировали файлы и папки с помощью программ Easy CD Creator и WinOnCD, то сейчас мы скопируем компакт-диск с компьютерными данными целиком с помощью программы CD Copier, входящей в комплект программ Adaptec Easy CD Creator.

Из-за технических ограничений дисководов CD-ROM, CD-R и CD-RW не все типы компакт-дисков могут быть скопированы без ошибок. При копировании дисков с помощью программы CD Copier рекомендуется всегда использовать режим предварительной тестовой записи компакт-диска (режим Test & Copy (Проверить и копировать)). Однако даже после успешной тестовой записи вы можете получить некачественную копию без единого сообщения об ошибке. Это может случиться, например, в том случае, если исходный диск имеет данные между дорожками или другие средства защиты от копирования. Ниже приведены замечания по копированию некоторых типов компакт-дисков с помощью программы CD Copier.

При копировании музыкальных дисков необходимо убедиться в том, что ваш дисковод CD-ROM имеет возможность читать звук в цифровом виде. Протестировать дисковод можно в программе Easy CD Creator следующим образом.

Установите музыкальный компакт-диск, который вы собираетесь копировать, в дисковод CD-ROM.
Щелкните правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar) и выберите из контекстного меню команду Audio * Audio CD (Аудио * Аудио компакт-диск). На экране появится рабочее окно программы Easy CD Creator (Рис. 3.45).

Рис. 3.45. Рабочее окно программы Easy CD Creator

В верхней части рабочего окна программы Easy CD Creator показывается содержимое найденного программой музыкального компакт-диска.

Выберите команду меню Tools * System Tests (Сервис * Системные тесты). На экране появится диалог System Test (Системный тест) (Рис. 3.46).

Рис 3.46. Диалог Системный тест

В левой части диалога выберите дисковод CD-ROM с музыкальным диском, установите флажок Audio Extraction Test (Проверка извлечения звука) и нажмите кнопку Test (Проверка). На экране появится диалог, показывающий процесс выполнения теста (Рис. 3.47).

Рис. 3.47. Диалог, показывающий процесс выполнения теста

По окончании проверки в диалоге System Tests (Системные тесты) под флажком Audio Extraction Test (Проверка извлечения звука) будет показана скорость извлечения аудио с выбранного устройства CD-ROM (Рис. 3.48).

Рис. 3.48. Диалог System Tests (Системные тесты) с вычисленной скоростью чтения цифрового звука

Если скорость чтения цифрового звука меньше 1х (150 Кбайт/сек), то при копировании музыкальных компакт-дисков необходимо сначала копировать исходный компакт-диск на жесткий диск, а затем переписывать его с винчестера на целевой компакт-диск. Весь музыкальный компакт-диск или отдельные его дорожки можно копировать также с помощью программы Easy CD Creator, работа с которой описывается в предыдущих знакомствах.

Чтобы закрыть диалог System Tests (Системные тесты), нажмите кнопку Close. (Закрыть). Диалог исчезнет с экрана.
Завершите работу с программой Easy CD Creator, выбрав команду меню File * Exit (Файл * Выход). Рабочее окно программы закроется, и она завершит свою работу.

При копировании компакт-дисков DirectCD следует иметь в виду, что старые дисководы CD-ROM, не поддерживающие технологию MultiRead (Множественное чтение), не могут читать диски DirectCD. Некоторые компакт-диски Mixed-Mode (Смешанный режим) могут копироваться некачественно либо потому, что они защищены от копирования, либо из-за различных отклонений от стандарта при записи исходного компакт-диска.
При копировании компакт-дисков CD Extra часть аудиоданных может быть потеряна, если на исходном компакт-диске пауза между дорожками составляет менее 2 сек. Напомним, что компакт-диски DirectCD - это диски, записанные в режиме Packet Writing (Пакетная запись); диски Mixed-Mode (Смешанный режим) содержат единственную сессию, в которой сначала записана одна дорожка с данными, а затем одна или несколько аудиодорожек; а диски CD Extra содержат две сессии: в первой записана одна или несколько аудиодорожек, а во второй записана одна дорожка с данными.

Копировать компакт-диски с помощью программы CD Copier очень просто. Для этого необходимо установить исходный компакт-диск (который мы собираемся копировать) в дисковод CD-ROM, а в дисковод CD-R или CD-RW поместить чистый диск CD-R (CD-RW). После этого запускается программа CD Copier и дается команда копирования. Но копировать диски можно, даже если на вашем компьютере нет дисковода CD-ROM, а есть только дисковод CD-R или CD-RW. В этом случае исходный компакт-диск копируется сначала в файл на жестком диске, затем исходный диск в сководе меняется на целевой и на него переписывается содержимое файла. Выполним практические шаги для копирования компакт-диска.

Установите исходный компакт-диск в дисковод CD-ROM, а в дисковод CD-R или CD-RW - чистый диск CD-R (CD-RW). Щелкните правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar) и выберите из контекстного меню команду CD Copier (Копирование компакт-дисков). На экране появится диалог Welcome to Adaptec CD Copier (Добро пожаловать в программу Adaptec CD Copier) (Рис. 3.49).

Рис. 3.49. Диалог Welcome to Adaptec CD Copier (Добро пожаловать в программу Adaptec CD Copier)

В диалоге Welcome to Adaptec CD Copier (Добро пожаловать в программу Adaptec CD Copier) напоминается, что вы не должны нарушать авторские права при копировании дисков с помощью данной программы. Если установить флажок Don't show this again (He показывать это в следующий раз), то диалог Welcome to Adaptec CD Copier (Добро пожаловать в программу Adaptec CD Copier) не будет появляться при последующих запусках программы CD Copier.

Нажмите кнопку ОК. Диалог Welcome to Adaptec CD Copier (Добро пожаловать в программу Adaptec CD Copier) закроется, и на экране появится рабочее окно программы CD Copier (Рис. 3.50).

Рис. 3.50. Рабочее окно программы CD Copier

В списке Copy from (Копировать из) выбирается дисковод, на котором находится копируемый компакт-диск, а в списке Record to (Копировать в) указывается дисковод CD-R (CD-RW), на котором находится чистый диск для записи. Вы можете указать один и тот же дисковод CD-R (CD-RW) и в качестве источника, и в качестве целевого диска. В этом случае перепись дорожек происходит через жесткий диск и после чтения (записи) каждой дорожки надо будет менять исходный и целевой компакт-диски.

При смене имени дисковода Copy from (Копировать из) автоматически проверяется производительность выбранного дисковода и его способность читать цифровой звук. При этом на экране появляется окно, в котором отображается процесс проверки (Рис. 3.51).

Рис. 3.51. Процесс проверки производительности дисковода CD-ROM

Выберите имена дисководов в списках Copy from (Копировать из) и Record to (Копировать в), а затем перейдите на вкладку Advanced (Дополнительные) (Рис. 3.52).

Рис. 3.52. Вкладка Advanced (Дополнительные) рабочего окна программы CD Copier

На вкладке Advanced (Дополнительные) выберите скорость записи компакт-диска в списке CD-Recorder speed (Скорость устройства записи компакт-дисков). Если при копировании музыкальных дисков исходный и целевой компакт-диски находятся на разных дисководах, то скорость записи не должна превышать скорость извлечения цифрового звука с исходного дисковода CD-ROM. В случае, если вы установите скорость записи, превышающую возможности вашего оборудования, на экране появится сообщение об этом с предложением выбрать меньшую скорость для записи компакт-диска

Если меньшую скорость записи компакт-диска выбрать нельзя, то необходимо установить флажок Copy source CD to your hard drive first (Копировать исходный компакт-диск сначала на жесткий диск) и выбрать папку на жестком диске для временного хранения содержимого исходного диска в группе элементов управления Disc Copy (Копировать диски). Перед процессом копирования программа проверит доступное пространство на жестком диске, и, в случае недостатка на нем места, об этом будет также выдано сообщение (Рис. 3.54).

Рис. 3.54. Сообщение о недостатке места на жестком диске

В поле со счетчиком Number of Copies (Количество копий) на вкладке Advanced (Дополнительные) в рабочем окне программы CD Copier устанавливается число копий компакт-диска. Переключатель Test (Тест) устанавливается, если вы просто хотите проверить скорость передачи данных с исходного компакт-диска без записи данных на целевой диск. Запись данных осуществляется в тестовом режиме с выключенным лазером. Установка переключателя Test & Copy (Проверить и копировать) позволяет выполнить тестовую запись перед копированием диска. При установке переключателя Сору (Копировать) тестовая запись перед копированием не производится. Флажок Disc-at-Once (Диск за один прием) можно установить для сохранения точно таких же пауз между дорожками, какие есть на исходном музыкальном диске. При этом после записи всех дорожек диск закрывается.

На вкладке Advanced (Дополнительные) рабочего окна программы CD Copier установите переключатель Test & Copy (Проверить и копировать).
Установите флажок Copy source CD to your hard drive first (Копировать исходный компакт-диск сначала на жесткий диск) и нажмите кнопку
Сору (Копировать). Программа начнет просматривать дорожки исходного компакт-диска. При этом процесс просмотра отображается на экране (Рис. 3.55).

Рис. 3.55. Процесс просмотра дорожек исходного компакт-диска

По окончании просмотра дорожек исходного компакт-диска начинается процесс его создания (Рис. 3.8).
Когда диск будет скопирован, программа выдаст команду выдвинуть и вновь задвинуть лоток записывающего устройства, и в диалоге CD Creation Process (Процесс создания компакт-диска) появится сообщение об успешном создании компакт-диска (Рис. 3.12).

Нажмите кнопку ОК. Диалог CD Creation Process (Процесс создания компакт-диска) исчезнет, и на экране останется лишь рабочее окно программы CD Copier.
Завершите работу программы CD Copier, выбрав команду меню File * Exit (Файл * Выйти). Рабочее окно программы CD Copier исчезнет с экрана.

Если не удается достичь качественного копирования музыкальных компакт-дисков с помощью программы CD Copier, то можно попробовать копировать их программой Easy CD Creator, так как в ней больше возможностей настройки различных параметров, позволяющих повысить качество копирования. О том, как создавать свои музыкальные диски с помощью программы CD Spin Doctor, входящей в комплект программ Easy CD Creator рассказывается в следующей главе.


Untitled Document

Знакомство 8. Записываем, читаем и стираем файлы с CD-RW с помощью Проводника
Мы уже упоминали о том, что в режиме записи Packet Writing (Пакетная запись) информация на диск пишется небольшими порциями - пакетами, что позволяет использовать предварительно отформатированный диск CD-RW точно так же, как обычный диск, т.е. стирать, переименовывать и редактировать файлы прямо на компакт-диске.
Компакт-диски, обеспечивающие режим записи Packet Writing (Пакетная запись) иногда также называют дисками DirectCD. Такой режим поддерживает, например, программа Adaptec DirectCD. Она не входит в комплект программ Adaptec Easy CD Creator, а устанавливается отдельно. После установки программу можно обновить на сайте разработчика, на странице:
http://www.adaptec.com/support/advisor/cdrupdates/dcdwinversions.html.
Программа DirectCD позволяет обращаться с диском CD-RW точно так же, как с обычной дискетой или жестким диском, т.е. писать, читать и редактировать файлы на CD-RW с помощью любой программы, которая может писать на диск и читать с диска. Можно, например, редактировать документы на диске CD-RW с помощью редактора Word.

Процесс установки программы Adaptec DirectCD мы описывать не будем: он очень простой - в нескольких диалогах мастера установки необходимо только выбрать папку для установки программы, да и ту можно оставить по умолчанию. После установки программы на Панели задач (Taskbar) появится значок программы [image]. Чтобы с помощью программы Adaptec DirectCD использовать диск CD-RW как обычный жесткий диск, выполните следующие действия.

Нажмите кнопку Пуск (Start) на Панели задач (Taskbar) и выберите команду главного меню Программы * Adaptec DirectCD * Adaptec DirectCD (Programs * Adaptec DirectCD * Adaptec DirectCD). На экране появится первый диалог мастера подготовки DirectCD (Рис. 3.56).

Этот же диалог появляется при двойном щелчке на значке [image], расположенном на Панели задач (Taskbar).
В диалоге сообщается о том, что мастер подготовит диск CD-RW к работе с любым приложением Windows.

Рис. 3.56. Первый диалог мастера подготовки DirectCD

Нажмите кнопку Next (Далее) для продолжения. На экране появится второй диалог мастера подготовки DirectCD (Рис. 3.57).

Рис. 3.57. Второй диалог мастера подготовки DirectCD

В диалоге предупреждается о том, что диск будет отформатирован и все имеющиеся на нем данные будут потеряны.

Нажмите кнопку Next (Далее) для продолжения. На экране появится третий диалог мастера подготовки DirectCD (Рис. 3.58).

Рис. 3.58. Третий диалог мастера подготовки DirectCD

В этом диалоге можно задать метку диска длиной до 11 символов.
Введите с клавиатуры метку диска и нажмите кнопку Finish (Завершить) для продолжения. На экране появится четвертый диалог мастера подготовки DirectCD (Рис. 3.59).

Рис. 3.59. Четвертый диалог мастера подготовки DirectCD

В четвертом диалоге мастера подготовки DirectCD говорится, что все готово к форматированию диска, и что процесс форматирования займет 50-90 минут.

Нажмите кнопку ОК, чтобы начать форматирование компакт-диска. На экране появится пятый диалог мастера подготовки DirectCD, в котором отображается процесс форматирования компакт-диска (Рис. 3.60).

Рис. 3.60. Пятый диалог мастера подготовки DirectCD

По окончании процесса форматирования компакт-диска на экране появится диалог мастера подготовки DirectCD с сообщением о готовности компакт-диска к работе (Рис. 3.61).

Рис. 3.61. Заключительный диалог мастера подготовки DirectCD

В заключительном диалоге говорится еще о том, что привод CD-R/CD-RW закрыт для предотвращения случайной потери данных при работе под управлением DirectCD, и что для извлечения компакт-диска необходимо использовать команду мастера DirectCD.
Если сбросить флажок Display this notification agan when a DirectCD disk is ready for read and write (Показывать это сообщение опять, когда диск DirectCD будет готов), то этот диалог больше появляться не будет. Иначе он будет выводиться на экран всякий раз при установке в привод CD-R/CD-RW компакт-диска DirectCD. Теперь вы можете пользоваться компакт-диском CD-RW как обычной дискетой или жестким диском, то есть писать на него данные и читать их любой программой.

Компакт-диск DirectCD можно отформатировать, если щелкнуть правой кнопкой мыши на значке [image]. расположенном на Панели задач (Taskbar) и выбрать команду контекстного меню Format (Формат). При этом на экране появится диалог о форматировании мастера подготовки DirectCD. Можно установить переключатель Quick (Быстрое) или Full (Полное) и нажать кнопку Next (Далее).
После ввода в диалоге метки диска (Рис.3-58), он будет отформатирован. Для просмотра и установки параметров привода CD-R/CD-RW щелкните правой кнопкой мыши на значке [image] расположенном на Панели задач <Taskbar), и из появившегося контекстного меню выберите команду Properties (Свойства). На экране появится диалог CD-RW Properties (Свойства CD-RW) (Рис. 3.63)

На вкладке General (Общие), в поле Label (Метка) показывается метка компакт-диска. Кроме этого, можно посмотреть следующие параметры компакт-диска CD-RW:

Рис. 3.63. Вкладка General (Общие) диалога CD-RW Properties (Свойства CD-RW)

  • Туре (Тип диска);
  • File system (Файловая система);
  • Used space (Используемое пространство) в мегабайтах;
  • Free space (Свободное пространство) в мегабайтах;
  • Capacity (Общий объем);
  • Drive (Устройство) - имя устройства в файловой системе.

Выберите вкладку Settings (Установки) (Рис. 3.64).

Рис. 3.64. Вкладка Settings (Установки) диалога CD-RW Properties (Свойства CD-RW)

На вкладке Settings (Установки) можно посмотреть следующие параметры привода CD-RW:

  • Name (Наименование);
  • Туре (Тип привода);
  • Firmware revision (Версия оборудования);
  • Target ID (Идентификатор);
  • Logical unit number (Логический номер устройства);
  • Media Type (Тип носителя);
  • Current Read Speed (Текущая скорость чтения);
  • Current Write Speed (Текущая скорость записи).

Выберите вкладку DirectCD Wizard (Мастер DirectCD) (Рис. 3.65).

Рис. 3.65. Вкладка DirectCD Wizard (Мастер DirectCD) диалога CD-RW Properties (Свойства CD-RW)

На вкладке DirectCD Wizard (Мастер DirectCD) можно установить/сбросить флажки для изменения различных параметров мастера DirectCD:
Enable standard CD-ROM compatibility (Совместимость со стандартными CD-ROM);
Display the "Eject Disc" wizard before ejecting a DirectCD disc (Отображать мастер "Извлечь диск" перед извлечением диска DirectCD);
Display disc creation options upon insertion of blank media (Отображать параметры создания диска при установке пустого носителя);
Display the "DirectCD Disc Ready" notification when a DirectCD disc is ready for read and write (Показывать уведомление "DirectCD диск готов" когда диск DirectCD готов для чтения и записи);
Display Eject Notification (Показывать уведомление об извлечении диска);
Display Adaptec DirectCD startup banner (Показывать заставку при запуске программы).

Закройте диалог CD-RW Properties (Свойства CD-RW), нажав кнопку ОК.
Чтобы извлечь компакт-диск из привода CD-R/CD-RW, щелкните правой кнопкой мыши на значке [image], расположенном на Панели задач (Taskbar), и из появившегося контекстного меню выберите команду Eject (Извлечь). На экране появится диалог с сообщением об извлечении диска DirectCD (Рис. 3.66), лоток с компакт-диском выдвинется, и вы можете сменить диск.

Рис. 3.66. Диалог с сообщением об извлечении диска DirectCD

Если сбросить флажок Display this notification again (Показывать это сообщение опять), то этот диалог больше появляться не будет.


Untitled Document

ГЛАВА 4.Любимая музыка на собственных компакт-дucкax

Имея в своем распоряжении CD-рекордер (CD-Recorder), вы можете создавать собственные компакт-диски с любимыми мелодиями. Эти мелодии можно переписать с виниловых дисков, магнитных лент, бытовых CD-плееров, радио и телевизионных приемников, микрофона, компьютерных приводов CD-ROM и любых других источников звука, которые можно подключить к аудиокарте персонального компьютера. При этом существуют 2 пути:

1. Создать такой компакт-диск с музыкой, который можно будет проиграть только на компьютере, но зато на него может поместиться более 5 часов музыки.
2. Создать полноценный AudioCD, который можно будет проигрывать как на компьютере, так и на бытовых CD-плеерах. При этом на диск поместится не более 74 минут музыки.

В чем различие двух подходов? Первый путь подразумевает, что вы будете записывать музыку из разных источников на жесткий диск компьютера и преобразовывать ее в формат, в обиходе кратко называемый МРЗ [МП-ТРИ]. Полное название формата - MPEG Audio Layer 3. МРЗ - обычное расширение имен файлов такого формата.
Формат МРЗ интересен тем, что может сильно сжимать звуковую информацию за счет некоторого ухудшения качества фонограммы, незаметного на слух. Степень сжатия звукового сигнала характеризуется величиной потока результирующих данных, который измеряется в килобитах в секунду. Чем ниже поток результирующих данных, тем выше степень сжатия, и тем больше потеря качества звука. Считается, что при сжатии исходного аудиопотока до скорости 256 Кбит/с (сжатие примерно 1:6) качество звука соответствует качеству AudioCD.
Вы можете найти файлы МРЗ в большом количестве в Интернете. Музыкальный CD с файлами МРЗ создается как обычный CD-ROM с данными. Подробно этот процесс описан в главе "Создаем архивы программ и данных на CD-ROM". В этой главе мы расскажем о том, как переписать любимую музыку из разных источников и создать свои файлы МРЗ.
Для проигрывания файлов в формате МРЗ вам понадобится специальная программа (в Windows 98 - это стандартная программа Универсальный проигрыватель). Такую программу имеет смысл записать на тот же CD-ROM, что и файлы МРЗ, и автоматически запускать при установке вашего диска с музыкой в дисковод. Как это сделать, рассказано в данной главе.
Чтобы записать настоящий AudioCD, который можно будет проигрывать не только на компьютере, но и на бытовых CD-плеерах, надо подготовить вашу музыку и другие фонограммы в файлах формата WAV. Если музыку вы переписали из Интернета или с CD-ROM дисков в виде файлов формата МРЗ или другого формата, отличного от WAV, то чтобы записать такую музыку на свой диск AudioCD, эти файлы надо предварительно преобразовать в формат WAV.
Процесс создания AudioCD диска из WAV-файлов похож на процесс создания CD-ROM диска, но имеет свои особенности. Следует отметить, что один WAV-файл записывается на AudioCD как один трек, другими словами, как одна песня. На диске между песнями автоматически записывается пауза; таких треков на AudioCD может быть до 99.

Для записи звука из различных источников, равно как и преобразования форматов файлов, мы будем пользоваться программой CD Spin Doctor. В программе WinOnCD средств записи звука от внешних источников нет. Программа CD Spin Doctor может читать звук из различных аудиоисточников: виниловых дисков, магнитных лент, бытовых CD-плееров, радио и телевизионных приемников, микрофона, компьютерных приводов CD-ROM и т.п. При этом аппаратная часть звуковой карты оцифровывает звук и предоставляет его программе CD Spin Doctor в том виде, в котором он записывается в WAV-файлах.
Программа CD Spin Doctor может записывать звук либо в формате WAV, т.е. без преобразования и сжатия, либо в формате МРЗ, т.е. предварительно сжав звуковой поток. Программа может сразу записывать звук из внешнего источника на AudioCD, но лучше сначала записать звук на жесткий диск, а только потом - на AudioCD. Дело в том, что при записи на компакт-диск, данные должны поступать непрерывным потоком и не прерываться, иначе компакт-диск будет испорчен. Поэтому в CD-рекордерах имеется аппаратный буфер, куда постоянно подкачиваются данные для записи. Во время прямой записи звука с внешнего источника на AudioCD высока вероятность исчерпания буфера данных и порчи диска.
В случае предварительной записи аудиоданных на жесткий диск, во-первых, вероятность исчерпания буфера данных намного меньше, и, во-вторых, аудиоданные перед записью можно обработать, пропустив их через различные фильтры, выровнять громкость и т.п. Перед записью на диск AudioCD музыкальных произведений, полученных из разных аудиоисточников, сначала надо выровнять их громкость, иначе потом придется от песни к песне крутить ручку громкости на CD-плеере. Выровнять громкость можно как с помощью самой программы CD Spin Doctor, так и с помощью программы Sound Editor, входящей в комплект программ Easy CD Creator. Оба варианта выравнивания громкости звука рассматриваются в этой главе.

Особо следует отметить то, каким образом вы можете копировать отдельные песни с одного AudioCD на свой. Дело в том, что CD-ROM привод (или CD-Recorder) для проигрывания AudioCD подключается отдельным проводом к звуковой карте, и вы можете считывать звук со звуковой карты в процессе проигрывания нужной песни - трека исходного AudioCD. В процессе такого копирования происходит лишнее преобразование звука цифра-аналог-цифра, при котором неизбежно ухудшение качества звука. Чтобы этого не произошло, надо копировать песни с AudioCD цифровым способом прямо в файл формата WAV - это гарантирует копирование 1 в 1 без каких-либо искажений, но некоторые старые CD-ROM приводы не поддерживают такую возможность. Как скопировать 1 в 1, будет также рассказано в этой главе.

Отметим, что перезаписываемые компакт-диски CD-RW не рекомендуется использовать для записи дисков AudioCD, поскольку они не будут воспроизводиться на большинстве CD-плееров и некоторых дисководах CD-ROM.

В этой главе мы подготовим файлы с помощью программы CD Spin Doctor, а записывать диски будем с помощью CD Spin Doctor, Easy CD Creator и WinOnCD.


Untitled Document

Знакомство 1. Kaк подключить магнитофон или проигрыватель виниловых плacmuнoк к звуковой плате?
Чтобы переписать музыку с магнитофонной ленты или виниловых пластинок на компакт-диск, надо подключить магнитофон или проигрыватель грампластинок к компьютеру. Внешние источники звука подключаются к звуковой карте персонального компьютера. При подключении внешних источников звука линейный выход внешнего источника соединяется с линейным входом звуковой карты с помощью специального аудиокабеля. Линейный выход отечественных аудиоустройств обычно выполнен в виде круглой пяти-контактной розетки; в этом случае для подключения внешнего аудиоустройства к персональному компьютеру используется кабель с круглой пятиконтактной вилкой с одной стороны и штекером с другой стороны. Круглая пятиконтактная вилка кабеля подключается к линейному выходу внешнего аудио-устройства, а штекер подключается к линейному входу звуковой карты. В импортной аудиотехнике линейный выход стереосигнала .обычно выполнен в виде пары розеток, по одному для каждого канала. В этом случае для подключения аудиоустройства к персональному компьютеру импортных аудиоустройств необходим кабель, один из концов которого представляет собой пару штекеров. В случае, если у вас отечественное аудиоустройство, но есть кабель, то вам может понадобиться переходник.

Подключите ваш магнитофон или проигрыватель пластинок к компьютеру, соединив аудиокабелем линейный выход магнитофона или проигрывателя с линейным входом звуковой карты.

После подключения внешнего источника звука к компьютеру необходимо отрегулировать уровень записи и можно начинать переписывать песни на компакт-диск.


Untitled Document

Знакомство 2. Записываем музыку с лент и пластинок на компьютер

В предыдущем знакомстве мы подключили к компьютеру внешний источник звука, в качестве которого может выступать магнитофон, проигрыватель грампластинок, радиоприемник и т.п. Сейчас мы покажем, как переписать музыку с грампластинки или магнитофонной кассеты на жесткий диск компьютера. Сначала мы установим уровни записи с помощью стандартной программы Регулятор громкости (Volume Control), входящей в состав операционной системы Windows, познакомимся со всеми настройками программы CD Spin Doctor, а затем перепишем мелодии на жесткий диск, удалив из них шумы.

Мы подготовим файлы с помощью программы CD Spin Doctor, а записывать диски AudioCD будем с помощью следующих программ: программы CD Spin Doctor, которая входит в комплект программ Adaptec Easy CD Creator, с помощью самой программы Easy CD Creator и с помощью программы WinOnCD.

Программа CD Spin Doctor позволяет создавать собственные диски AudioCD, собранные из самых различных музыкальных источников, включая компакт-диски, грампластинки, кассетные ленты, радио и телепередачи, звуковые файлы и т.п. Ниже приведена таблица, в которой сравниваются возможности программ CD Spin Doctor и Easy CD Creator.

Возможности | Easy CD Creator | CD Spin Doctor
Запись песен с грампластинок, кассетных лент CD-плееров на компакт-диск | - | Да
Возможность фильтровать звук, разбивать дорожки, выравнивать громкость звучания для дорожек | - | Да
Редактирование пауз между дорожками | Да | -
Создание макета компакт-диска, т.е. файла, содержащего список песен и порядок их записи | Да | -
Создание всего компакт-диска за один прием | Да | -
Создание одной дорожки за один прием | - | Да
Запись файлов МРЗ | Да | Да
Возможность добавить плавное увеличение громкости звука в начале дорожки и затухание звука в конце дорожки | Да | Да
Возможность загрузить имена музыкальных компакт-дисков и названия песен из Интернета | Да | Да

В большинстве случаев при создании музыкальных компакт-дисков необходимо сначала записать исходные мелодии на жесткий диск. Это бывает нужно, когда мелодии необходимо предварительно обработать, т.е. убрать посторонний шум, выровнять громкость и т.п. Также рекомендуется предварительно записывать мелодии на жесткий диск, когда они переписываются с устройств, подключенных к компьютеру через звуковую карту. Это повышает вероятность успешной записи на компакт-диск. Мелодии записываются на жесткий диск как WAV-файлы, а это требует значительных затрат дискового пространства - примерно 10 Мб на каждую минуту звучания. Таким образом, для размещения полного 74-минутного диска AudioCD потребуется как минимум 740 Мб свободного дискового пространства.

Прежде чем переписывать музыку с грампластинок или магнитофона, установим уровни записи с помощью стандартных средств операционной системы Windows.

Дважды щелкните мышью на значке динамика [image] в правой части Панели задач (Taskbar). На экране появится окно Громкость (Volume Control) (Рис. 4.6).

Рис. 4.6. Окно Громкость (Volume Control)

Если значка динамика нет, то окно Громкость (Volume Control) можно вызвать, нажав кнопку Пуск (Start) на Панели задач (Taskbar) и выбрав команду главного меню Программы * Стандартные * Развлечения * Регулятор уровня (Programs * Accessories * Entertainment * Volume Control).

Сбросьте флажок Выкл. все (Mute all) и флажок Выкл. (Mute) для линейного входа (Line in). Остальные флажки Выкл. (Mute) установите, чтобы не было лишних помех при записи звука с линейного входа.

Включите подключенный к звуковой карте проигрыватель грампластинок или магнитофон и с помощью регуляторов отрегулируйте уровень громкости и баланс между левой и правой колонками.
Нажмите кнопку Прочие (Advanced) и в появившемся диалоге Дополнительные параметры: Громкость (Advanced Controls for Volume Control) отрегулируйте уровни Высокие частоты (Treble) и Низкие частоты (Bass) (Рис. 4.7).
Закройте окно Дополнительные параметры: Громкость (Advanced Controls for Volume Control),нажав кнопку Закрыть(Close).
Закройте окно Громкость (Volume Control), нажав кнопку [image] в заголовке окна.
Установите пустой диск CD-R или CD-RW в устройство записи компакт-дисков.

рис. 4.7. Диалог Дополнительные параметры: Громкость (Advanced Controls for Volume Control

Запустите программу CD Spin Doctor, щелкнув правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar) и выбрав из контекстного меню команду Audio * CD Spin Doctor (Аудио * CD Spin Doctor). На экране появится рабочее окно программы CD Spin Doctor (Рис. 4.8).

Рис. 4.8. Рабочее окно программы CD Spin Doctor

Если внешний вид рабочего окна программы CD Spin Doctor отличается от приведенного на Рис. 4.8, то можно вернуть ему исходный вид, нажав кнопку [image] на панели инструментов.
Чтобы выбрать источник, с которого вы хотите записать музыку на компакт-диск, нажмите кнопку [image] в левой половине рабочего окна программы CD Spin Doctor. На экране появится диалог Select Music Source (Выберите источник музыки) (Рис. 4.9).

Рис. 4.9. Диалог Select Music Source (Выберите источник музыки)

В диалоге Select Music Source (Выберите источник музыки) можно выбрать:

Digital CD-ROM (Цифровой компакт-диск) - один из имеющихся на вашем компьютере приводов CD-ROM;
LP - Long Play(ing) (record) - проигрыватель грампластинок; Таре (Лента) - магнитофон, подключенный к аудиокарте;
CD Player (CD-проигрыватель) - проигрыватель компакт-дисков, подключенный к аудиокарте;
Other Input (Другие устройства) - другие устройства, подключенные к аудиокарте персонального компьютера;
File(s) on hard drive (Файлы на жестком диске) - звуковые файлы на жестком диске.

Хотя устройства LP (Проигрыватель грампластинок), Таре (Лента), CD Player (CD-проигрыватель) и Other Input (Другие устройства) подключаются к одному и тому же входу аудиокарты персонального компьютера, но следует выбирать правильный вариант источника звука, поскольку при чтении с устройства могут использоваться определенные для него фильтры, а для разных устройств они разные.

Еще раз напомним, что цифровой CD-ROM характеризуется тем, что с него можно читать аудиоданные в цифровом виде и писать их в файл без лишнего преобразования цифра-аналог-цифра. CD-ROM, не поддерживающий чтение аудиоданных в цифровом виде, обязательно должен быть подключен к звуковой карте специальным аудиокабелем.

Из списка устройств выберите LP (Проигрыватель грампластинок) или Таре (Магнитофон), которое вы подключили к звуковой карте в предыдущем знакомстве, и нажмите кнопку Select (Выбрать). Левая половина рабочего окна программы CD Spin Doctor изменится, как показано на Рис. 4.10.

Рис. 4.10. Рабочее окно программы CD Spin Doctor при выборе магнитофона в качестве источника музыки

В этом окне вы можете установить флажок Automatically stop recording when silent (Автоматически останавливать запись когда тихо), чтобы не записывать паузы в звучании. Если флажок установлен, то при поиске пауз учитываетея чувствительность, установленная на вкладке Track Splitting (разбиение на дорожки) диалога Option Properties (Свойства параметров) (Рис. 4.16).

- Нажмите кнопку Options (Параметры), чтобы установить параметры записи. На экране появится диалог Recording Options (Параметры записи) (Рис. 4.11).

В диалоге Recording Options (Параметры записи) можно выбрать параметры, которые можно было бы установить и на панели инструментов программы CD Spin Doctor путем фиксации соответствующих кнопок. Изображения большинства кнопок с одинаковыми функциями в диалоге и на панели инструментов похожи. Рассмотрим назначение кнопок в диалоге Recording Options (Параметры записи).

Рис. 4.11. Диалог Recording Options (Параметры записи)

Фиксация кнопки [image] в нажатом состоянии позволяет удалять из исходной аудиозаписи щелчки, свист, шипение и другие дефекты. Это бывает нужно, например, при переписи аудиозаписей с поцарапанных пластинок.
Фиксация кнопки [image] в нажатом состоянии позволяет произвести различные преобразования записываемого звука: придание ему металлического оттенка (как у робота), эффекта звучания в концертном зале, понижение или повышение высоты звука (мужской и женский голос) и т.д.

Фиксация кнопки [image] в нажатом состоянии позволяет обнаруживать паузы в исходной аудиозаписи и разбивать запись на отдельные дорожки. При использовании этой возможности необходима предварительная запись исходных аудиоданных на жесткий диск.

Фиксация кнопки [image] в нажатом состоянии позволяет выровнять громкость выбранных дорожек. Такая необходимость возникает при записи из различных источников, имеющих разный уровень громкости звука. При использовании этой возможности необходима предварительная запись исходных аудиоданных на жесткий диск.
Фиксация кнопки [image] позволяет предварительно прослушать результаты преобразования звука, выбранного одной из перечисленных выше кнопок. При выборе этой возможности необходима предварительная запись исходных аудиоданных на жесткий диск . Кнопку [image] можно нажать, только если нажата одна из кнопок [image], [image], [image], [image].

Кнопка [image] позволяет выполнять тестовую запись на компакт-диск перед действительной записью.
Нажмите кнопку [image], чтобы удалить из исходной аудиозаписи щелчки, свист, шипение и другие дефекты. Кнопка [image] должна остаться в нажатом состоянии.
Установим параметры очистки звука и, заодно, подробнее познакомимся со всеми перечисленными выше возможностями программы CD Spin Doctor.
Нажмите кнопку Properties (Свойства) в диалоге Recording Options (Параметры записи). На экране появится диалог Option Properties (Свойства параметров) (Рис. 4.12).

Рис. 4.12. Диалог Option Properties (Свойства параметров)

На вкладке Cleaning (Очистка) диалога Option Properties (Свойства параметров) определяются фильтры, применяемые к исходной аудиозаписи.
Фильтры выбираются установкой следующих флажков:

Noise Filtering (Подавление шума). Перемещение движка вверх увеличивает степень фильтрации исходных аудиоданных;
Pop Removal (Удаление щелчков). Перемещение движка вверх увеличивает степень фильтрации исходных аудиоданных;
Adjust for source type (Настройка для источника звука). Установка этого флажка позволяет программе CD Spin Doctor использовать параметры, предварительно установленные для таких устройств как проигрыватель грампластинок или магнитофон.

Установите все три флажка Noise Filtering (Подавление шума), Pop Removal (Удаление щелчков) и Adjust for source type (Настройка для источника звука) для установки всех фильтров очистки звука.
Вы можете прослушать результаты обработки звука, нажав кнопку [image] на вкладке Cleaning (Очистка) диалога Option Properties (Свойства параметров). Необходимо поэкспериментировать с различными уровнями фильтрации звука, чтобы получить наилучший результат. Результат очистки звука зависит не только от качества источника музыки, но и от качества звуковой платы, используемой в вашем компьютере.

Фильтры, установленные на вкладке Cleaning (Очистка) диалога Option Properties (Свойства параметров), будут действовать только при нажатой в диалоге Recording Options (Параметры записи) или на панели инструментов программы CD Spin Doctor кнопке [image]. Выберите вкладку Morphing I (Преобразование I) (Рис. 4.13).

Рис. 4.13. Вкладка Morphing I (Преобразование I) диалога Option Properties (Свойства параметров)

На этой вкладке можно определить преобразования исходной аудиозаписи,
установкой следующих флажков:

Concert Hall (Концертный зал). Добавляет музыке глубину, заставляет зву
чать записи моно как стерео и придает "широту" стереомузыке; ;
Reverb (Реверберация). Добавляет послезвучание (эхо) к исходной аудиозаписи. Перемещайте движок для изменения степени реверберации;
GenderBlender (Высота тона). Буквальный перевод - "Смеситель полов". Перемещайте движок для изменения высоты звука. С помощью этого преобразования вы можете сделать, например, женский голос ниже, а мужской выше.
Вы можете прослушать результаты преобразования звука, нажав кнопку [image] на вкладке Morphing I (Преобразование I) диалога Option Properties (Свойства параметров).
Преобразования, определенные на вкладке Morphing I (Преобразование I) диалога Option Properties (Свойства параметров), будут действовать только при нажатой в диалоге Recording Options (Параметры записи) или на панели инструментов программы CD Spin Doctor кнопке [image] Выберите вкладку Morphing II (Преобразование И) (Рис. 4.14).

Рис. 4.14. Вкладка Morphing II (Преобразование II) диалога Option Properties (Свойства параметров)

На этой вкладке можно определить преобразования исходной аудиозаписи установкой следующих флажков:

Мetalizer (Металлизатор). Придает музыке и голосу роботоподобное звучание;
TalkBox (Разговор). Установка этого флажка возможна при выборе звукового файла, который будет модулировать музыку. Таким образом, например, можно придать гитаре звучание человеческого голоса;
TimeWarp (Сдвиг по времени). При сдвиге по времени назад к исходному звуку добавляются шум и щелчки, а при сдвиге вперед звук приобретает более искусственное звучание. Вы можете прослушать результаты преобразования звука, нажав кнопку [image] на вкладке Morphing II (Преобразование II) диалога Option Properties (Свойства параметров).
Преобразования, определенные на вкладке Morphing II (Преобразование 2) диалога Option Properties (Свойства параметров), будут действовать только при нажатой в диалоге Recording Options (Параметры записи) или на панели инструментов программы CD Spin Doctor кнопке
Выберите вкладку Temporary Files (Временные файлы) (Рис. 4.15).

Рис. 4.15. Вкладка Temporary Files (Временные файлы) диалога Option Properties (Свойства параметров)

Программа CD Spin Doctor позволяет выбрать место для размещения временных файлов путем установки одного из следующих переключателей:

Put temporary files where there is the most room (Разместить временные файлы там, где больше всего места). Программа разместит временные файлы на том жестком диске, где больше всего свободного места;
Put temporary files in this directory (Разместить временные файлы в каталоге). Каталог для размещения временных файлов вы должны выбрать сами, нажав кнопку Browse (Обзор).
На этой вкладке можно также установить флажок Do not delete temporary files after an error or cancellation (He удалять временные файлы после ошибки или отмены операции). Это позволяет сохранить временные файлы для дальнейшего использования.

Выберите вкладку Track Splitting (Разбиение на дорожки) (Рис. 4.16).

Рис. 4.16. Вкладка Track Splitting (Разбиение на дорожки) диалога Option Properties (Свойства параметров)

На вкладке Track Splitting (Разбиение на дорожки) можно установить количество дорожек, на которые будут разбиты исходные музыкальные записи, или выбрать автоматическое разбиение на дорожки. Для этого надо установить один из следующих переключателей:

Split into tracks (Разбить на дорожки). Количество дорожек, на которые вы хотите разбить исходные музыкальные записи, устанавливается ручную в поле со счетчиком;
Split wherever a silence is detected (Разбивать везде, где встретится пауза). автоматическое разбиение на дорожки работает для большинства проигрывателей виниловых дисков.
Для увеличения чувствительности при поиске пауз нужно передвинуть рычажок вправо. Чем больше чувствительность, тем более короткие паузы могут обнаруживаться при их автоматическом поиске.
Чувствительность, установленная с помощью движка, влияет также на поиск пауз при уставе флажка Automatically stop recording when silent (Автоматически навливать запись, когда тихо) в рабочем окне программы CD Spin Doctог при выборе аналогового устройства в качестве источника музыки 4.10). Разбиение на дорожки, определенное параметрами, установленными на вкладке Track Splitting (Разбиение на дорожки) диалога Option Properties (Свойства параметров), будет производиться только при нажатой в диалоге Recording Options (Параметры записи) или на панели инструментов программы CD Spin Doctor кнопке

Выберите вкладку Internet (Интернет) (Рис. 4.17).

Рис. 4.17. Вкладка Internet (Интернет) диалога Option Properties (Свойства параметров)

Вы можете использовать Интернет для доступа к службе CDDB™, в базе данных которой записана информация о существующих коммерческих музыкальных компакт-дисках. Для каждого компакт-диска можно загрузить его наименование и список песен.

На вкладке Internet (Интернет) вы можете установить флажок Access the Internet using a proxy server (Доступ в Интернет через прокси-сервер), если локальная сеть вашего предприятия подключена к Интернету через прокси-сервер. В этом случае необходимо указать адрес и порт прокси-сервера в полях Address (Адрес) и Port (Порт). Если вы затрудняетесь при указании адреса и порта прокси-сервера, то обратитесь к системному администратору локальной сети вашего предприятия.

Выберите вкладку МРЗ Files (Файлы МРЗ) (Рис. 4.18).

МРЗ - это метод сжатия аудиофайлов, а также формат записи сжатых аудиофайлов. Файлы МРЗ можно записать как файлы данных и затем проиграть их на компьютере с помощью программного МРЗ-плеера. Их можно преобразовать в формат WAV-файлов и записать на компакт-диск, чтобы потом проиграть на обычном CD-плеере.

Рис. 4.18. Вкладка МРЗ Files (Файлы МРЗ) диалога Option Properties (Свойства параметров)

На вкладке МРЗ Files (Файлы МРЗ) можно выбрать степень сжатия исходного аудиофайла. Чем ниже поток результирующих данных, который измеряется в килобитах в секунду, тем выше степень сжатия и тем больше потеря качества звука. Считается, что при сжатии исходного аудиопотока до скорости 256 Кбит/с (сжатие примерно 1:6) качество звука соответствует качеству CD. Если предлагаемые в программе CD Spin Doctor параметры сжатия вас не устраивают, то сжать аудиофайл можно отдельной программой. Об этом будет рассказано в одном из следующих знакомств. Можно также установить флажок Write my МРЗ files with a RIFF header (Записывать мои МРЗ файлы с заголовками RIFF). RIFF - Resource Interchange File Format (Формат файла обмена ресурсами) - это формат, разработанный корпорацией Microsoft, для создания сложных файлов из существующих файлов AVI, WAV, MIDI и других мультимедиа форматов. Мы рассмотрели все параметры, которые можно установить в программе СD Spin Doctor. Продолжим создание музыкального компакт-диска.

Нажмите кнопку ОК в диалоге Option Properties (Свойства параметров), чтобы установленные параметры вступили в силу. Диалог Option Properties (Свойства параметров) исчезнет с экрана.

- Нажмите кнопку ОК в диалоге Recording Options (Параметры записи). Диалог исчезнет с экрана.
Мы видим, что в рабочем окне программы CD Spin Doctor нажата кнопка [image] и в нижней части экрана рядом с кнопкой Options (Параметры) появился соответствующий значок, показывающий, что включены фильтры "чистки звука".
Нажмите кнопку [image] в правой половине рабочего окна программы CD Spin Doctor, чтобы выбрать устройство или файл, куда вы собираетесь записать музыку. На экране появится диалог Select Music Destination (Выберите место для записи музыки) (Рис. 4.19).

Рис. 4.19. Диалог Select Music Destination (Выберите место для записи музыки)

В этом диалоге можно выбрать следующие устройства или файлы для записи музыки:

  • CD Recorder (Устройство записи компакт-дисков). Программа CD Spin Doctor перечисляет все устройства CD-R и CD-RW, подключенные к вашему компьютеру. Одно из этих устройств выбирается, когда вы готовы записать мелодии на компакт-диск;
  • File(s) on hard drive (Файл(ы) на жестком диске). На жесткий диск файлы записываются в формате WAV; этот формат требует около 10 Мб на каждую минуту звучания;
  • МРЗ file(s) on hard drive (Файл(ы) МРЗ на жестком диске). На жесткий диск файлы записываются в формате МРЗ. Преобразование мелодии в формат МРЗ происходит в соответствии с параметрами, установленными на вкладке МРЗ Files (Файлы МРЗ) диалога Option Properties (Свойства параметров);
  • Audio (Аудио). Этот выбор позволяет прослушивать выбранные мелодии перед записью их на компакт-диск. Этот режим удобен тем, что позволяет оценить результаты всех настроек различных фильтров и, при необходимости, изменить их перед тем, как начать запись звука на диск.

Пока мы еще не готовы записывать мелодии на компакт-диск. Сначала нам надо переписать их на винчестер.

Выберите строку File(s) on hard drive (Файл(ы) на жестком диске) и нажмите кнопку Select (Выбрать). Правая половина рабочего окна программы CD Spin Doctor изменится, как показано на Рис. 4.20.

Рис. 4.20. Рабочее окно программы CD Spin Doctor при выборе файла для записи музыки

Рядом с кнопкой [image] в правой половине рабочего окна программы CD Spin Doctor отображается имя папки, в которую будет записываться мелодия, а в поле Space available on disc (Место, доступное на диске) показывается количество свободного места на выбранном диске в мегабайтах и время записи в формате (минуты:секунды).

Выберем диск и папку для записи файлов с мелодиями. Для этого лучше всего предварительно создать новую папку на диске, где достаточно свободного места. Напомним, что для размещения полного 74-минутного лиска AudioCD потребуется не менее 740 Мб свободного дискового пространства. Новую пустую папку вы можете создать с помощью программы Проводник (Explorer), запустив ее прямо во время работы программы CD Spin Doctor. Нажмите длинную кнопку Сhange Directory (Изменить
каталог) в правой половине окна программы CD Spin Doctor, чтобы выбрать диск и папку для записи файлов с мелодиями.

Рис.4.21. Диалог Browse for Folder (Обзор папок)

На экране появится диалог Browse for Folder (Обзор папок) (Рис. 4.21). В диалоге Browse for Folder (Обзор папок) выбирается диск и папка на жестком диске для записи мелодий. Выбирать можно только диски, находящиеся на вашем компьютере. Сетевой диск выбирать нельзя. Выберите диск и папку для размещения мелодий в формате WAV и нажмите кнопку ОК. Диалог Browse for Folder (Обзор папок) исчезнет с экрана.
Нажмите кнопку [image] в правой половине рабочего окна программы CD Spin Doctor чтобы начать запись файла На экране появится диалог Ready To Record (Готов к записи) (Рис. 4.22).

Рис. 4.22 Диалог Readу Tо Recоrd (Готов к записи)

В диалоге Ready To Record (Готов к записи) предлагается нажать кнопку Record (Записать) и тут же включить магнитофон или проигрыватель виниловых дисков. Для магнитофона запись начинается немедленно после нажатия кнопки Record (Записать).

Нажмите кнопку Record (Записать) в диалоге Ready To Record (Готов к записи) и включите магнитофон или проигрыватель виниловых дисков, предварительно установленный на выбранной мелодии. Песня начнет записываться в файл и на экране появится диалог Recording Progress (Ход записи), отображающий процесс записи (Рис. 4.23).

Рис. 4.23 Диалог Ход записи

Вы можете установить флажок Freeze the animation (Заморозить анимацию), чтобы воспроизведение анимации не мешало процессу записи данных на компакт-диск на недостаточно производительном компьютере.
Как только мелодия закончится, нажмите кнопку Stop (Остановить) для прекращения записи в файл. Диалог Recording Progress (Ход записи) исчезнет с экрана, и в правой части рабочего окна программы CD Spin Doctor появится имя записанного файла (Рис. 4.24).

Рис. 4.24. Рабочее окно программы CD Spin Doctor после записи мелодии в файл

Выбранная вами мелодия записана в файл Sampled Audio.wav, имя которого появилось в таблице, где в графе Duration (Длительность) отображается еще информация о длительности звучания файла в формате [минуты:секунды], а в графе File size (Размер файла) - число занимаемых им мегабайт на диске.

Если дважды щелкнуть мышью на имени файла, то он будет воспроизведен программой, которая определена в вашей системе для проигрывания WAV-файлов.
Чтобы в дальнейшем не запутаться во множестве однотипных имен, переименуем записанный файл. В качестве нового имени файла можно выбрать название песни.
Чтобы переименовать файл, щелкните на его имени правой кнопкой мыши и выберите из контекстного меню команду Rename (Переименовать). Имя файла выделится.

Введите с клавиатуры новое имя файла, лучше длинное и понятное, например полное название песни по-русски, расширение .wav оставьте
без изменений, и нажмите клавишу Enter. Файл будет переименован.
Установите ленту на магнитофоне или головку на проигрывателе грампластинок перед другой мелодией и повторите запись мелодии на жесткий диск.

Когда все песни будут записаны на жесткий диск и переименованы, можно выровнять их громкость и переписать с жесткого диска на компакт-диск. Но сначала мы перепишем на винчестер еще песни с диска AudioCD.

Завершите работу с программой CD Spin Doctor, выбрав команду меню File * Exit (Файл * Выход). Рабочее окно программы закроется, и программа завершит свою работу.


Untitled Document

Знакомство 3.Копируем ayдuompeкu с других AudioCD

Как уже отмечалось, музыку с дисков AudioCD можно записать так же, как и с лент или пластинок, если подключить CD-плеер к компьютеру, но в этом случае в аудиозапись будут внесены дополнительные помехи.
Поэтому мы просто скопируем с музыкального компакт-диска дорожку (т.е. нужную песню или музыкальное произведение) сначала в файл формата WAV (при этом просто копируются цифровые данные), а затем перепишем звуковые файлы на компакт-диск. В этом знакомстве мы будем переписывать музыку с дисков AudioCD также с помощью программы CD Spin Doctor.

Установите пустой диск CD-R или CD-RW в устройство записи компакт-дисков.
Установите компакт-диск, с которого вы собираетесь переписывать мелодии, в дисковод CD-ROM.
Если на вашем компьютере есть только устройство записи компакт-дисков, а дисковода CD-ROM нет, тогда сначала в устройство записи компакт-дисков необходимо установить компакт-диск, с которого вы собираетесь переписывать мелодии.
Запустите программу CD Spin Doctor, щелкнув правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar), и выбрав из контекстного меню команду Audio * CD Spin Doctor (Аудио * CD Spin Doctor). На экране появится рабочее окно программы CD Spin Doctor (Рис. 4.25).

Рис. 4.25. Рабочее окно программы CD Spin Doctor

Программа CD Spin Doctor запоминает состояние параметров при завершении работы, поэтому внешний вид рабочего окна должен быть примерно таким, как при выходе из программы в предыдущем знакомстве.

Чтобы выбрать источник музыки, которую вы хотите записать на компакт-диск, выберите команду меню Select * New Source (Выбрать * Новый источник), на экране появится диалог Select Music Source (Выберите источник музыки) (Рис. 4.9). В диалоге Select Music Source (Выберите источник музыки) из списка устройств выберите Digital CD-ROM (Цифровой компакт-диск). На экране появится диалог Select Track(s) to Record (Выберите дорожки для записи) (Рис. 4.26). Если у вас есть выход в Интернет то вы можете загрузить имена мелодий, записанных на ваш компакт-диск, из базы данных CDDB. Для этого необходимо выполнить следующие действия. Подключитесь к сети Интернет.

Нажмите кнопку Select Tracks to Record (Выберите дорожки для записи). На экране появится диалог CDDB Internet download (Загрузка Интернет CDDB) с сообщением о подключении к базе данных CDDB (Рис. 4.27).

Рис. 4.27. Диалог CDDB Internet download (Загрузка Интернет CDDB)

Через некоторое время после подключения и поиска в базе данных CDDB на экране появится диалог CDDB Internet Resolution (Уточнение Интернет CDDB) В диалоге CDDB Internet Resolution (Уточнение Интернет CDDB) перечисляются компакт-диски, найденные в базе данных CDDB™, параметры которых совпадают с вашим компакт-диском. В нашем случае найден единственный компакт-диск.

Выберите название вашего компакт-диска и нажмите кнопку ОК. Диалог CDDB Internet Resolution (Уточнение Интернет CDDB) исчезнет с экрана, и на короткое время опять появится диалог CDDB Internet download (Загрузка Интернет CDDB) (Рис. 4.27).
После загрузки названий мелодий они появятся в диалоге Select Track(s) to Record (Выберите дорожки для записи)
Отключитесь от сети Интернет.

(Выберите дорожки для записи) с названиями мелодий

Выделите в диалоге Select Track(s) to Record (Выберите дорожки для записи) все мелодии, которые вы хотите переписать с компакт-диска, и нажмите кнопку ОК. Диалог Select Track(s) to Record (Выберите дорожки для записи) исчезнет с экрана, и выбранные файлы появятся в списке файлов в левой половине рабочего окна программы CD Spin Doctor

Напомним, что для того, чтобы выделить несколько файлов в списке, необходимо при их выделении мышью удерживать клавишу Shift (для выделения группы файлов, расположенных в списке подряд) или Сtrl (для добавления очередного файла к уже выделенным).

Добавлять файлы можно и по одному, каждый раз вызывая диалог Select Track(s) to Record (Выберите дорожки для записи) с помощью длинной кнопки Select track(s) to record (Выберите дорожки для записи) в левой половине рабочего окна программы CD Spin Doctor, выделяя очередную дорожку в диалоге Select Track(s) to Record (Выберите дорожки для записи) и нажимая в нем кнопку ОК.

В именах дорожек могут встречаться символы, недопустимые в именах файлов (например, символ "/"). Такие дорожки необходимо переименовать, заменив недопустимые символы, например, пробелом. Если оставить в имени дорожки недопустимые символы, то файл не будет записываться на жесткий диск.

Чтобы переименовать дорожку, щелкните на ее имени правой кнопкой мыши и выберите из контекстного меню команду Rename (Переименовать). Имя дорожки выделится.
Введите с клавиатуры новое имя дорожки и нажмите клавишу "Enter" . Дорожка будет переименована.
После того, как вы выберете все дорожки на исходном компакт-диске, выберите команду меню Select * New Destination (Выбрать * Новый приемник). На экране появится диалог Select Music Destination (Выберите место для записи музыки) (Рис. 4.19).
Выберите в диалоге Select Music Destination (Выберите место для записи музыки) строку File(s) on hard drive (Файл(ы) на жестком диске) и нажмите кнопку Select (Выбрать). В правой половине рабочего окна программы CD Spin Doctor будет показан каталог жесткого диска, который был выбран для временной записи аудиофайлов в последний раз.

Вы можете выбрать другой диск и папку для временной записи файлов с мелодиями с помощью длинной кнопки Change Directory (Изменить каталог) в правой половине рабочего окна программы CD Spin Doctor.
Нажмите кнопку [image] в правой половине рабочего окна программы CD Spin Doctor, чтобы начать копирование выбранных дорожек в файлы. На экране появится диалог Recording Progress (Ход записи), отображающий процесс переписи выбранных дорожек в файлы (Рис. 4.23).
По окончании процесса переписи дорожек в файлы диалог Recording Progress (Ход записи) исчезнет с экрана, и в правой части рабочего окна программы CD Spin Doctor появятся имена записанных файлов Если дважды щелкнуть мышью на имени файла, то он будет воспроизведен проигрывателем, который определен в вашей системе для проигрывания WAV-файлов.
Завершите работу с программой CD Spin Doctor, выбрав команду меню File * Exit (Файл * Выход). Рабочее окно программы закроется и программа завершит свою работу.

В предыдущих знакомствах мы подготовили на жестком диске WAV-файлы, источником которых были магнитофон, проигрыватель грампластинок или Audio-CD. Отдельно отметим, что файлы формата МРЗ также можно преобразовать в WAV-файлы перед записью их на свой Audio-CD. Программа CD Spin Doctor может разжимать МРЗ-файлы любой степени сжатия (хотя сама умеет сжимать их только от 8 Кбит/сек до 128 Кбит/сек).

Теперь, когда дорожки переписаны с исходного компакт-диска на жесткий диск, можно добавить к ним другие мелодии из WAV-файлов, выровнять громкость всех мелодий и переписать их с жесткого диска на компакт-диск. Именно этим мы и займемся в следующих знакомствах.


Untitled Document

Знакомство 4. Выравнивание громкости звучания всех WAV-файлов

В двух предыдущих знакомствах мы переписали мелодии с магнитофона и с компакт-диска на жесткий диск. Поскольку мелодии записывались из разных аудиоисточников, то они, наверняка, имеют различную громкость, поэтому ее необходимо выровнять, иначе потом придется от песни к песне крутить ручку громкости на CD-плеере.
Мы уже упоминали о том, как это сделать в программе CD Spin Doctor (фиксация кнопки [image] в диалоге Recording Options (Параметры записи) (Рис. 4.11), а сейчас выровняем громкость с помощью программы Sound Editor. Sound Editor - программа довольно примитивная, и если вы будете часто записывать собственные Audio-CD, то имеет смысл познакомиться с более профессиональной программой, например, Sound Forge. Но в этом знакомстве мы рассмотрим именно Sound Editor. Процесс выравнивания громкости заключается в следующем.

  • Прослушивая подготовленные WAV-файлы с помощью проигрывателя Windows или прямо в программе Sound Editor (о ней позже), надо найти файл, который звучит тише всех.
  • Уменьшить громкость звучания остальных WAV-файлов в программе Sound Editor так, чтобы они звучали примерно одинаково, и как самый негромкий файл.

Вы спросите: а почему бы не увеличить громкость звучания самого тихого файла? Для цифрового звука это лучше не делать - могут появиться искажения, хотя можно попробовать. Следует отметить, что если разброс громкостей различных файлов очень значительный, то имеет смысл записать самые тихие файлы повторно с большим уровнем записи, разумеется, если они записываются из аналогового источника, а не копируются цифровым способом прямо с Audio-CD.

Выравнивание громкости может занять значительное время, так как придется прослушать каждый файл не один раз, поэтому, может быть, лучше сначала записать свой Audio-CD как есть, а потом, слушая его на бытовом CD-плеере или компьютере, отметить песни, для которых приходится крутить ручку громкости, и затем попробовать изменить громкость только выбранных файлов. Разумеется, если есть возможность, можно создать Audio-CD на диске CD-RW и слушать его на компьютере с помощью самого CD-рекордера, чтобы не портить лишний диск CD-R.

Запустите программу Sound Editor, нажав кнопку Пуск (Start) на Панели задач (Taskbar) и выбрав команду главного меню Программы * Adaptec Easy CD Creator * Features * Sound Editor (Programs Adaptec Easy CD * Creator Features * Sound Editor). На экране появится рабочее окно программы Sound Editor (Рис. 4.32).

Puc. 4.32. Рабочее окно программы Sound Editor

Разверните рабочее окно программы Sound Editor на весь экран, нажав кнопку [image] в заголовке окна.
Загрузите WAV-файл с помощью команды меню File * Open (Файл * Открыть) и разверните окно загруженного файла, нажав кнопку [image] в заголовке окна (Рис. 4.33).

Puc. 4.33. Рабочее окно программы Sound Editor с загруженным звуковым файлом

Чтобы начать проигрывать файл, нажмите кнопку [image] на панели инструментов рабочего окна программы.
Чтобы остановить проигрывание файла, нажмите кнопку [image] на панели инструментов рабочего окна программы.
Чтобы отрегулировать громкость, выберите команду меню Effects * Amplify (Эффекты * Усилить). На экране появится диалог Amplification Settings (Установки усиления) (Рис. 4.34).

Puc. 4.34. Диалог Amplification Settings (Установки усиления)

Вы можете выбрать уровень громкости левого (Left) и правого (Right) канала в пределах от 0% до 200% от уровня исходного сигнала.

Установите с помощью ползунков нужный уровень громкости и нажмите кнопку Preview (Предварительное прослушивание). Небольшой фрагмент записи будет воспроизведен с выбранным усилением.

Если нажать кнопку ОК, то результат будет применен ко всему файлу. Имеет смысл запустить две разных копии программы Sound Editor, попеременно слушая то образцовый файл, то настраиваемый; при этом надо останавливать проигрывание в одном окне, прежде чем запускать его в другом, иначе появится сообщение о занятости WAV-устройства (Рис. 4.35).

Если вы решили увеличить громкость какого-то файла сверх 100%, то имеет смысл прослушать всю фонограмму от начала до конца на предмет отсутствия неприятных искажений. Можно прослушать только участки с максимальной амплитудой. Для этого надо с помощью движка Zoom (Масштаб) подобрать масштаб просмотра амплитудных кривых и, прокручивая изображение фонограммы, находить участки с большой амплитудой, выделять их и прослушивать. Чтобы выделить фрагмент записи, необходимо нажать левую кнопку мыши на начале фрагмента, и не отпуская ее, переместить мышь в конец фрагмента и отпустить кнопку мыши. Фрагмент записи будет выделен. При нажатии кнопки [image] на панели инструментов будет воспроизводиться выделенный фрагмент.

Рис. 4.35 Сообщение о занятости WAV-устройства

По окончании работы с программой Sound Editor выберите команду меню File * Exit (Файл * Выход). Рабочее окно программы Sound Editor закроется и программа завершит свою работу.

Мелодии записаны на жесткий диск в формате WAV-файлов, громкость всех мелодий выровнена, и теперь можно переписать их на компакт-диск.


Untitled Document

Знакомство 5. Создаем AudioCD с помощью CD Spin Doctor

В этом знакомстве мы запишем мелодии с жесткого диска на компакт-диск с помощью программы CD Spin Doctor. Для этого необходимо выполнить следующие действия.

Запустите программу CD Spin Doctor, щелкнув правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar), и выбрав из контекстного меню команду Audio * CD Spin Doctor (Аудио * CD Spin Doctor). На экране появится рабочее окно программы CD Spin Doctor (Рис. 4.25).
Выберите команду меню Select * New Source (Выбрать * Новый источник). На экране появится диалог Select Music Source (Выберите источник музыки) (Рис. 4.9).
В диалоге Select Music Source (Выберите источник музыки) выберите File(s) on hard drive (Файл(ы) на жестком диске) и нажмите кнопку Select (Выбрать). На экране появится диалог Open (Открыть) (Рис. 4.36).

Puc. 4.36. Диалог Open (Открыть)

В диалоге Open (Открыть) в поле со списком Look in (Папка) выберите диск, а в списке папок - папку, в которую вы записали мелодии. Чтобы открыть папку, надо дважды щелкнуть на ней мышью.

Выделите все мелодии, которые вы хотите записать на компакт-диск, и нажмите кнопку Add (Добавить). Диалог Open (Открыть) исчезнет с экрана, и выбранные файлы появятся в списке файлов в левой половине рабочего окна программы CD Spin Doctor (Рис. 4.37).

Puc. 4.37. Рабочее окно программы CD Spin Doctor при выборе файлов в качестве источника звука

Напомним, что для того, чтобы выделить несколько файлов в списке, необходимо мышью удерживать клавишу "Shift" (для выделения группы файлов, расположенных в списке подряд) или "Ctrl" (для добавления очередного файла к уже выделенным).

Добавлять файлы можно и по одному, каждый раз вызывая диалог Open (Открыть) с помощью длинной кнопки Add File(s) (Добавить файл(ы)) в левой половине рабочего окна программы CD Spin Doctor (Рис. 4.37), выделяя очередной файл в диалоге Open (Открыть) и нажимая в нем кнопку Add (Добавить).

В таблице файлов, предназначенных для записи на компакт-диск, в левой половине рабочего окна программы CD Spin Doctor в графе Duration (Длительность) отображается информация о длительности звучания файла в формате [минуты:секунды], а под таблицей в поле Total (Всего) показывается количество файлов, их суммарный размер в мегабайтах и общая длительность звучания.

Файлы будут записываться на компакт-диск в том порядке, в котором они перечислены в таблице файлов. Чтобы изменить порядок записи файлов, вы можете перетащить мышью его имя в списке выше или ниже. Нажмите кнопку [image] в правой половине рабочего окна программы CD Spin Doctor, чтобы выбрать устройство или файл, куда вы собираетесь записать музыку. На экране появится диалог Select Music Destination (Выберите место для записи музыки) (Рис. 4.19).

В диалоге Select Music Destination (Выберите место для записи музыки) выберите строку CD Recorder (Устройство записи компакт-дисков) и нажмите кнопку Select (Выбрать). Правая половина рабочего окна программы CD Spin Doctor изменится, как показано на Рис. 4.38.

Puc. 4.38. Рабочее окно программы CD Spin Doctor при выборе устройства записи компакт-дисков для записи музыки

В правой половине рабочего окна программы CD Spin Doctor показывается информация о выбранном устройстве записи компакт-дисков (имя дисковода и скорость записи) и об установленном в нем компакт-диске.

В поле ввода Title (Название) можно указать название компакт-диска, которое появляется вместе с названиями песен в макете обложки, которую вы будете делать с помощью программы Jewel Case Creator. Название компакт-диска может показываться также некоторыми программными CD-плеерами. Ввведите с клавиатуры в поле ввода Title (Название) название компакт-диска, например, Мои любимые песни. Поскольку исходные мелодии уже были очищены при их записи на жесткий диск, то нет необходимости очищать звук еще раз при переписи звука с жесткого диска на компакт-диск.
Отожмите кнопку [image] на панели инструментов программы CD Spin Doctor, чтобы отменить фильтры очистки звука.
Нажмите кнопку [image] на панели инструментов программы CD Spin Doctor, чтобы включить тестовую запись файлов на компакт-диск перед действительной записью. Нажмите кнопку [image] в правой половине рабочего окна программы CD Spin Doctor, чтобы начать запись файлов на компакт-диск. Если вы используете для записи музыки перезаписываемый компакт-диск, то на экране появится диалог You are using CD-RW media (Вы используете носитель CD-RW) (Рис. 4.39).

Puc. 4.39. Диалог You are using CD-RW media (Вы используете носитель CD-RW)

В этом диалоге предупреждается, что перезаписываемые компакт-диски CD-RW не будут воспроизводиться на большинстве CD-плееров и некоторых дисководах CD-ROM. Вы можете нажать кнопку ОК для продолжения записи или отказаться от нее, нажав кнопку Cancel (Отмена). При использовании обычных дисков CD-R на экране появится диалог Recording Progress (Ход записи), в котором отображается процесс тестовой записи файлов на компакт-диск (Рис. 4.23).

При успешном завершении тестовой записи компакт-диска на экране появится диалог Test was successful (Тест был успешным) (Рис. 4.40).
В диалоге Test was successful (Тест был успешным) задается вопрос о том, хотите ли вы произвести действительную запись на компакт-диск.
Нажмите кнопку Yes (Да) в диалоге Test was successful (Тест был успешным).

Рис. 4.40. Диалог Test was successful (Тест был успешным)

На экране вновь появится диалог Recording Progress (Ход записи), отображающий процесс записи файлов на компакт диск (Рис. 4.23).
По окончании записи файлов на компакт-диск диалог Recording Progress (Ход записи) закроется, и в правой половине рабочего окна программы CD Spin Doctor будет показано содержимое записанного компакт-диска (Рис. 4.41).

Puc. 4.41. Рабочее окно программы CD Spin Doctor после записи файлов на компакт-диск

В поле Space available on CD (Место, доступное на диске) показывается оставшееся на компакт-диске свободное место. Если свободного места на компакт-диске достаточно, то вы можете дописать туда еще несколько мелодий. Если же места больше нет, то диск надо закрыть, иначе его нельзя будет воспроизвести на некоторых CD-плеерах.

Закройте компакт-диск, нажав длинную кнопку Close CD now (Закрыть компакт-диск сейчас). На экране появится диалог Unclosed CD (Незакрытый компакт-диск) (Рис. 4.42).

Puc. 4.42. Диалог Unclosed CD (Незакрытый компакт-диск) В диалоге Unclosed CD (Незакрытый компакт-диск)

предупреждается, что после закрытия диска на него нельзя будет ничего записать.

Нажмите кнопку Close CD (Закрыть компакт-диск). На экране появится диалог Recording Progress (Ход записи) (Рис. 4.23), отображающий процесс закрытия диска.

По окончании закрытия диска программа выдвинет и вновь задвинет лоток с готовым компакт-диском, и диалог Recording Progress (Ход записи) исчезнет с экрана.

Завершите работу с программой CD Spin Doctor, выбрав команду меню File * Exit (Файл * Выход). Программа CD Spin Doctor завершит работу, и ее рабочее окно исчезнет с экрана.

Итак, мы с помощью программы CD Spin Doctor переписали песни с жесткого диска на компакт-диск.


Untitled Document

Знакомство 6. Создаем AudioCD с помощью Easy CD Creator

Если в предыдущем знакомстве мы создавали компакт-диски с помощью программы CD Spin Doctor, то сейчас создадим диск AudioCD с помощью программы Easy CD Creator. Вы можете создавать собственные музыкальные диски из любой комбинации аудиодорожек на компакт-дисках, файлов WAV или МРЗ. Во время записи программа будет просить установить нужные компакт-диски с выбранными вами аудиодорожками.

Установите пустой диск CD-R или CD-RW в устройство записи компакт-дисков.
Напомним, что диски AudioCD, записанные на перезаписываемые компакт-диски CD-RW, не будут проигрываться на обычных бытовых CD-плеерах. Они также не будут проигрываться на старых компьютерных дисководах CD-ROM.
Щелкните правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar), и выберите из контекстного меню команду Audio * Audio CD (Аудио * Аудио компакт-диск). На экране появится рабочее окно программы Easy CD Creator (Рис. 4.43).
Перетащите мышью аудиодорожки с компакт-дисков, а также все файлы и папки, которые вы хотите записать на компакт-диск, из верхней части рабочего окна программы Easy CD Creator в его нижнюю половину.

При создании макета музыкального компакт-диска вы можете перетаскивать аудиодорожки с разных компакт-дисков - впоследствии программа Easy CD Creator сама попросит установить тот или иной диск в процессе записи.

Puc. 4.43. Рабочее окно программы Easy CD Creator

По мере добавления мелодий в макет компакт-диска в нижней части рабочего окна программы Easy CD Creator заполняется линейный индикатор, показывающий наполнение компакт-диска (Рис. 4.44).

Puc. 4.44. Рабочее окно программы Easy CD Creator при создании музыкальных компакт-дисков Audio CD

Градуировка под линейным индикатором дается в минутах. Напомним, что на музыкальный компакт-диск помещается 74 минуты звучания.
Список мелодий, предназначенных для записи на компакт-диск, показывается в таблице, в колонках которой отображается следующая информация:

  • Name (Имя) - название мелодии или файла на диске;
  • Duration (Длительность) - длительность звучания мелодии в виде [минуты:секунды:сектор] (на диске AudioCD в секунде 75 секторов по 2352 байта в каждом секторе);
  • From (Откуда) - исходное местонахождение мелодии;
  • Pause (Пауза) - пауза в секундах перед записью мелодии на компакт-диск;
  • Start (Начало) - начальная позиция мелодии на компакт-диске в виде [минуты:секунды:сектор];
  • Fade In (Возрастание) - количество времени в виде [секунды:сектор], в течение которого громкость звука в начале мелодии возрастает от нуля до нормального значения;
  • Fade Out (Затухание) - количество времени в виде [секунды:сектор], в течение которого громкость звука в конце мелодии уменьшается от нормального значения до нуля;
  • Cross Fade (Перекрестное затухание) - количество времени в виде [секунды:сектор], в течение которого затухание звука в конце одной мелодии переходит в возрастание громкости звука в начале следующей. При указании перекрестного затухания, достаточно указать только затухание для выбранной мелодии, а для следующей мелодии значение Fade In (Возрастание) указывать не надо - оно будет установлено автоматически.

Чтобы установить значения затухания для дорожки, щелкните на ее имени правой кнопкой мыши и из появившегося контекстного меню выберите команду Properties (Свойства). На экране появится диалог Audio Track Properties (Свойства аудио-дорожки) (Рис. 4.45).
В группе элементов управления Effects / Duration (Эффекты / Длительность) установите переключатель Fade In (Возрастание) и укажите необходимую длительность возрастания громкости звука в поле со счетчиком, которое находится справа от переключателя

Puc. 4.45. Диалог Audio Track Properties (Свойства аудиодорожки)

Точно так же вы можете установить величину затухания, установив переключатель Fade Out (Затухание), и величину перекрестного затухания, установив переключатель Cross Fade (Перекрестное затухание).

В поле ввода Name (Имя) вы можете ввести с клавиатуры новое название мелодии.

Нажмите кнопку ОК. Диалог Audio Track Properties (Свойства аудиодорожки) закроется, и в таблице со списком мелодий появятся новые значения затуханий для выбранной мелодии.
Чтобы прослушать результат применения эффекта затухания перед записью на компакт-диск, выберите мелодию или несколько мелодий из списка в макете компакт-диска и выберите команду меню Track * Preview (Дорожка * Предварительное прослушивание). На экране появится окно проигрывателя Preview (Прослушивание), и выбранная мелодия начнет проигрываться.
По окончании прослушивания мелодии закройте окно проигрывателя Preview (Прослушивание), нажав кнопку [image] в его заголовке.
Когда вы сформируете список мелодий, предназначенных для записи на компакт-диск, выберите команду меню File * Create CD (Файл * Создать компакт-диск) или нажмите кнопку [image] на панели инструментов программы Easy CD Creator. На экране появится диалог CD Creation Setup (Установки создания компакт-диска) (Рис. 4.46).

Puc. 4.46. Диалог CD Creation Setup (Установки создания компакт-диска)

Если у вас набралось достаточно мелодий для записи полного компакт-диска, тогда вам необходимо закрыть диск после окончания записи. Для этого надо установить переключатель Track-At Once (Дорожка за один прием) и Close CD (Закрыть компакт-диск). Напомним, что после закрытия диска вы уже ничего не сможете на него записать. Если вы не закроете компакт-диск, то вы сможете прослушивать его на компьютерных дисководах CD-ROM, но некоторые бытовые CD-плееры его не смогут воспроизводить.

Если же на компакт-диске достаточно места для записи еще нескольких мелодий, тогда вам необходимо установить переключатели Track-At Once (Дорожка за один прием) и Leave Session Open (Оставить сессию открытой). Если вы закроете сессию, то следующие аудиодорожки будут записаны во второй сессии. На компьютере многосессионные диски вы сможете проигрывать, но на бытовых CD-плеерах могут возникнуть проблемы. Если вы оставите сессию открытой, то следующие дорожки будут записаны в этой же сессии. Правда диск с незакрытой сессией пока не сможет воспроизводиться ни на компьютере, ни на бытовом CD-плеере.

Установите переключатели Test and Create CD (Проверить и создать диск), Track-At Once (Дорожка за один прием), Close CD (Закрыть компакт-диск) и нажмите кнопку ОК. На экране появится диалог CD Creation Process (Процесс создания компакт-диска) (Рис. 4.47).

Puc. 4.47. Диалог CD Creation Process (Процесс создания компакт-диска)

Если в дисководе для записи компакт-дисков установлен диск CD-RW, то на экране появится диалог с предупреждением, что такие диски будут читаться только на устройствах CD-ROM, которые поддерживают технологию MultiRead (Множественное чтение) (Рис. 4.48).

Puc. 4.48. Диалог с предупреждением о том, что для записи используется диск CD-RW

В этом случае необходимо нажать кнопку ОК для продолжения работы. Предупреждающий диалог исчезнет, и процесс создания компакт-диска будет продолжен. По окончании процесса создания компакт-диска в диалоге CD Creation Process (Процесс создания компакт-диска) появится сообщение об успешном создании компакт-диска (Рис. 4.49), и лоток с созданным диском выдвинется и вновь установится в рабочее положение на дисководе для записи компакт-дисков.

Puc. 4.49. Диалог CD Creation Process (Процесс создания компакт-диска), с сообщением об успешном создании компакт-диска

Нажмите кнопку ОК в диалоге CD Creation Process (Процесс создания компакт-диска). Диалог исчезнет и на экране останется рабочее окно программы Easy CD Creator, в нижней части которого отображается макет только что созданного диска AudioCD.

Завершите работу с программой Easy CD Creator, выбрав команду меню File * Exit (Файл * Выход). На экране появится диалог с предложением сохранить макет созданного компакт-диска (Рис. 4.50).

Puc. 4.50. Диалог с предложением сохранить макет компакт-диска

Нажмите кнопку No (Нет), чтобы отказаться от сохранения макета компакт-диска. Диалог с предложением сохранить макет компакт-диска исчезнет с экрана, рабочее окно программы Easy CD Creator закроется, и она завершит свою работу. Мы создали диск AudioCD с помощью программы Easy CD Creator, добавив эффекты затухания в начало и конец мелодий.


Untitled Document

Знакомство 7. Создаем AudioCD с помощью WinOnCD

Теперь запишем наши WAV-файлы на диск AudioCD с помощью программы WinOnCD.

Установите пустой компакт-диск CD-R в привод CD-ROM.
Запустите программу WinOnCD, нажав кнопку Пуск (Start) на Панели задач (Taskbar) операционной системы Windows и выбрав команду главного меню Программы * CeQuadrat * WinOnCD (Programs * CeQuadrat * WinOnCD). На экране появится заставка программы и вслед за ней диалог New Project (Новый проект) (Рис. 4.51).

Puc. 4.51. Диалог New Project (Новый проект)

Если диалог New Project (Новый проект) не появился, а сразу открылось рабочее окно программы WinOnCD, то в нем необходимо выбрать команду меню File * New (Файл * Новый). На экране появится диалог New Project (Новый проект) (Рис. 4.51).

В поле ввода Project name (Имя проекта) введите с клавиатуры метку будущего компакт-диска AudioCD.
Выберите из списка проектов CD Digital Audio (Компакт-диск с цифровым звуком) и нажмите кнопку ОК. На экране появится рабочее окно программы WinOnCD (Рис. 4.52).

Puc. 4.52. Рабочее окно программы WinOnCD с макетом диска AudioCD

Выбирая WAV-файлы в верхней половине рабочего окна программы WinOnCD и перетаскивая мышью в нижнюю часть рабочего окна, добавьте их в макет будущего диска AudioCD.

Программа позволяет перетащить в макет диска AudioCD только файлы звукозаписи. Напомним, что, при необходимости, вы можете переименовать файлы в макете компакт-диска. Вы можете выбрать в макете любой файл и, нажав кнопку Editor (Редактор) в левой нижней части рабочего окна программы WinOnCD, отредактировать музыкальный файл, т.е. изменить его громкость, применить к нему различные звуковые эффекты и т.п.
По окончании создания макета компакт-диска AudioCD нажмите кнопку [image] Disc (Диск) в левой нижней части рабочего окна программы WinOnCD или выберите команду меню Record * Make CD (Запись * Создать компакт-диск), чтобы переключить рабочее окно программы в режим установки параметров записи компакт-диска (Рис. 4.53). Установите желаемые параметры записи компакт-диска и нажмите кнопку [image] в окне Disc Properties and Recording Settings / CD-XA disc (Свойства диска и параметры записи / Диск CD-XA). На экране появится диалог Make CD (Создание компакт-диска), в котором отображается процесс создания компакт-диска (Рис. 4.54).

Puc. 4.53. Рабочее окно программы WinOnCD в режиме установки параметров записи компакт-диска

По окончании процесса создания компакт-диска на экране появится диалог с сообщением об успешной записи компакт-диска (Рис. 4.55).

Puc. 4.54. Диалог Make CD (Создание компакт-диска)

Puc. 4.55. Сообщение об успешном создании компакт-диска

Нажмите в диалоге кнопку ОК. Диалог с сообщением об успешной записи компакт-диска исчезнет с экрана и программа выдаст команду выдвинуть лоток с записанным компакт-диском.

Мы записали мелодии на диск AudioCD.

Чтобы посмотреть информацию о записанном диске, установите его в привод CD-ROM и выберите команду меню Record * Disc Info (Запись * Информация о диске). На экране появится диалог CD Information (Информация о компакт-диске) (Рис. 4.56).

Puc. 4.56. Диалог CD Information (Информация о компакт-диске)

На вкладке Disc Info (Информация о диске) диалога CD Information (Информация о компакт-диске) отображаются следующие данные:

  • Disk Type (Тип диска);
  • Disk Size (Объем диска);
  • Number of Sessions (Число сессий). Это число на единицу больше числа фактически записанных сессий;
  • Number of Tracks (Число дорожек) - число мелодий, записанных на диск;
  • Free Space (Свободное пространство). Указано None (Нет), т.к. мы не можем добавлять песни на диск AudioCD после его записи;
  • Space Required (Требуемое пространство) - параметр не имеет смысла для диска AudioCD;
  • Write Address (Адрес записи). Адрес записи новой сессии задается в виде минуты:секунды:сектор. Каждая секунда содержит 75 секторов.

Напомним, что на компьютерном компакт-диске с данными каждый сектор содержит блок данных размером в 2048 байт. У диска AudioCD может быть только одна сессия, поэтому этот параметр установлен в None (Нет);
Required Write Address (Требуемый адрес записи) - параметр не имеет смысла для диска AudioCD;
На вкладке Tracks (Дорожки) диалога CD information (Информация о компакт-диске) отображается информация о записанных дорожках (Рис. 4.57).

Puc. 4.57. Вкладка Tracks (Дорожки) диалога CD Information (Информация о компакт-диске)

Выберите вкладку Close Disc/Session (Закрыть диск/Сессию) (Рис. 4.58).

Puc. 4.58. Вкладка Close Disc/Session (Закрыть диск/Сессию) диалога CD Information (Информация о компакт-диске)

При создании нашего диска AudioCD при установках параметров записи компакт-диска по умолчанию был установлен переключатель Close CD.
Tracks cannot be added later (Закрыть диск. Больше дорожек добавить будет нельзя) (Рис. 4.53). Поэтому на вкладке Close Disc/Session (Закрыть диск/Сессию) диалога CD Information (Информация о компакт-диске) недоступны переключатели для закрытия сессии и диска. Но если бы мы при записи диска не выбрали его закрытие, то его надо было бы закрыть, чтобы записанные мелодии могли проигрываться и на CD-ROM, и на CD-плеерах.

Чтобы закрыть незакрытый диск, установите переключатель Finalize CD (no additional sessions possible) (Завершить CD (запись дополнительных сессий невозможна)) и нажмите кнопку Finalize (Завершить).
Закройте диалог CD Information (Информация о компакт-диске), нажав в нем кнопку ОК.
Завершите работу с программой WinOnCD, выбрав команду меню File * Exit (Файл * Выйти). На экране появится диалог с предложением сохранить макет компакт-диска (Рис. 4.59).

Puc. 4.59. Диалог с предложением сохранить макет компакт-диска

Нажмите в диалоге кнопку No (Нет), чтобы отказаться от сохранения макета компакт-диска. Программа WinOnCD завершит работу, и ее рабочее окно исчезнет с экрана.

Мы записали диск AudioCD с помощью программы WinOnCD.


Untitled Document

Знакомство 8. Сжимаем музыку в формат МРЗ с помощью Easy CD Creator

В предыдущих знакомствах этой главы мы создавали музыкальные диски AudioCD, на которые помещается 74 минуты звучания. Напомним, что на диски AudioCD пишутся аудиофайлы WAV в стандарте Red Book (Красная книга), когда исходный стереофонический звуковой сигнал оцифровывается с частотой дискретизации 44,1 КГц.
Каждый отсчет исходного сигнала представляется отдельным 16-разрядным словом (2 байта), таким образом, каждая минута звучания занимает около 10 Мб. Чтобы воспроизводить музыкальные диски AudioCD, достаточно односкоростного дисковода CD-ROM, т.е. дисковода, способного передавать 150 Кбайт/сек. Собственно, скорость воспроизведения дисков AudioCD и была взята в качестве единицы измерения "скорости" дисководов CD-ROM.
Как уже упоминалось ранее, звук формата Red Book (Красная книга) можно сжать примерно в 6 раз без заметного ухудшения его качества. Можно его, конечно, сжать и в 25 и более раз, но тогда потери качества звука будут заметны даже обычному слушателю. При большом коэффициенте сжатия музыка будет звучать так, как она звучит по радио или телевизору, а при очень больших коэффициентах сжатия - как по телефону. Одним из наиболее распространенных форматов сжатия звука является МРЗ - это метод сжатия аудиофайлов, а также формат записи сжатых аудиофайлов. Файлы МРЗ можно записать как файлы данных и затем проиграть их на компьютере с помощью программного МРЗ-плеера. В этом случае на компакт-диск можно записать не 74 минуты, а около 5,5 часов качественного звука. Правда на CD-плеере такой компакт-диск прослушать уже будет нельзя. Итак, чтобы записать на компакт-диск намного больше песен, чем помещается на диск AudioCD, и потом прослушивать их на компьютере, необходимо:

  • Подготовить аудиофайлы в формате МРЗ на жестком диске. Это можно сделать с помощью программы Easy CD Creator или CD Spin Doctor или любой другой программы;
  • Переписать аудиофайлы в формате МРЗ с жесткого диска на компакт-диск, как это уже было описано в главе "Создаем архивы программ и данных на CD-ROM".

Дополнительно на компакт-диск с файлами МРЗ можно записать программу для их воспроизведения, чтобы все было под рукой в одном месте. Более того, эту программу можно автоматически запустить при установке компакт-диска в дисковод CD-ROM. О том, как сделать автозапуск, подробно написано в одном из следующих знакомств. Поскольку запись файлов данных на компакт-диск уже была подробно описана ранее, то в этом знакомстве мы коснемся только преобразования аудиофайлов в формат МРЗ. Сейчас мы будем преобразовывать аудиофайлы с помощью уже знакомых нам программ Easy CD Creator и CD Spin Doctor. С помощью программы Easy CD Creator можно преобразовать аудиодорож-ки, записанные на компакт-диске AudioCD, в файлы МРЗ.

Запустите программу Easy CD Creator, щелкнув правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar), и выберите из контекстного меню команду Audio * Audio CD (Аудио * Аудио компакт-диск). На экране появится рабочее окно программы Easy CD Creator (Рис. 4.43).
В дереве папок, расположенном в левой части верхней половины рабочего окна программы Easy CD Creator, выберите дисковод CD-ROM с установленным в нем диском AudioCD.
В правой части верхней половины рабочего окна программы Easy CD Creator, где показывается содержимое компакт-диска, выберите одну или несколько дорожек, которые вы хотите преобразовать в формат МРЗ и записать на жесткий диск. Напомним, что для того, чтобы выделить несколько файлов в списке, необходимо при их выделении мышью удерживать клавишу "Shift" (для выделения группы файлов, расположенных в списке подряд) или "Ctrl" (для добавления очередного файла к уже выделенным).
Выберите команду меню Track * Extract to file (Дорожка * Извлечь в файл) или нажмите кнопку [image] на панели задач программы Easy CD Creator. На экране (при выборе двух дорожек) появится диалог Extract 2 Audio Track(s) to File(s) (Извлечь 2 аудиодорожки в файлы).
В списке Save in (Сохранить в) выберите жесткий диск, на который вы хотите записать файлы МРЗ.
В списке папок выберите папку для записи файлов МРЗ.

Имена файлов МРЗ генерируются автоматически из имен дорожек путем замены недопустимых символов символом подчеркивания "_" и добавления к полученному имени расширения .МРЗ.

В списке Save as type (Сохранить как тип) выберите MPEG Layer-3 compressed Audio (*.MP3) (Сжатое аудио MPEG уровень-3 (*.МРЗ)).
В списке Format (Формат) выберите степень сжатия исходной аудиодорожки.
Напомним, что степень сжатия определяется скоростью потока результирующих аудиоданных, который измеряется в килобитах в секунду. Чем ниже скорость потока результирующих данных, тем выше степень сжатия и тем больше потеря качества звука. Считается, что при сжатии исходного аудиопотока до скорости 256 Кбит/с (сжатие 1:6) качество звука соответствует качеству CD.
В списке Format (Формат), лучшее, что можно выбрать из предлагаемых значений - это 56 Кбит/с, 22050 Гц, стерео. Это соответствует сжатию в 25 раз. Остальные предлагаемые в списке значения дают еще большее сжатие и, соответственно, еще худшее качество преобразованного звука.
Нажмите кнопку Save (Сохранить) для преобразования аудиодорожки в формат файла МРЗ. На экране появится диалог Extracting Audio Track to File - Track 01 of 02 (Извлечение аудиодорожки в файл - 01 из 02) По окончании преобразования выбранных дорожек в файлы МРЗ диалог Extracting Audio Track to File - Track 01 of 02 (Извлечение аудиодорожки в файл - 01 из 02) закроется, и файлы будут записаны на жесткий диск. Эти файлы могут быть использованы для записи на компакт-диск. Мы завершили процесс преобразования аудиодорожек в формат файлов МРЗ.
Завершите работу с программой Easy CD Creator, выбрав команду меню File * Exit (Файл * Выход). Программа Easy CD Creator завершит работу и ее рабочее окно исчезнет с экрана.
В отличие от программы Easy CD Creator, программа CD Spin Doctor может преобразовывать в формат МРЗ не только аудиодорожки с компакт-диска AudioCD, но и аудиофайлы формата WAV, а также входной аудиопоток с подключенного к компьютеру магнитофона, проигрывателя грампластинок или любого другого источника звука.
Запустите программу CD Spin Doctor, щелкнув правой кнопкой мыши на значке [image], расположенном в правой части Панели задач (Taskbar), и выбрав из контекстного меню команду Audio * CD Spin Doctor (Аудио * CD Spin Doctor). На экране появится рабочее окно программы CD Spin Doctor (Рис. 4.8).
Чтобы выбрать источник музыки, которую вы хотите преобразовать в формат МРЗ, выберите команду меню Select * New Source (Выбрать * Новый источник). На экране появится диалог Select Music Source (Выберите источник музыки) (Рис. 4.9).
В диалоге Select Music Source (Выберите источник музыки) выберите источник музыки, которую вы хотите преобразовать в формат МРЗ, и нажмите кнопку Select (Выбрать).
Чтобы выбрать файлы МРЗ для записи музыки, выберите команду меню Select * New Destination (Выбрать o Новый приемник). На экране появится диалог Select Music Destination (Выберите место для записи музыки) (Рис. 4.19).
В диалоге Select Music Destination (Выберите место для записи музыки) выберите строку МРЗ file(s) on hard drive (Файл(ы) МРЗ на жестком диске) и нажмите кнопку Select (Выбрать). В правой половине рабочего окна программы CD Spin Doctor будет показан каталог жесткого диска, который был выбран для временной записи аудиофайлов в последний раз. Вы можете выбрать другой диск и папку для временной записи файлов с мелодиями с помощью длинной кнопки Change Directory (Изменить каталог) в правой половине рабочего окна программы CD Spin Doctor.
Выберите команду меню Options * Properties (Параметры * Свойства). На экране появится диалог Option Properties (Свойства параметров) (Рис. 4.12).
В диалоге Option Properties (Свойства параметров) выберите вкладку МРЗ Files (Файлы МРЗ) (Рис. 4.18).
На вкладке МРЗ Files (Файлы МРЗ) выберите степень сжатия исходного аудиофайла и нажмите кнопку ОК. Диалог Option Properties (Свойства параметров) исчезнет с экрана.
Нажмите кнопку [image] в правой половине рабочего окна программы CD Spin Doctor, чтобы начать копирование выбранных дорожек в файлы. На экране появится диалог Recording Progress (Ход записи), отображающий процесс переписи выбранных дорожек в файлы (Рис. 4.23).
По окончании процесса переписи дорожек в файлы диалог Recording Progress (Ход записи) исчезнет с экрана, и в правой части рабочего окна программы CD Spin Doctor появятся имена записанных файлов.
Завершите работу с программой CD Spin Doctor, выбрав команду меню File * Exit (Файл "o Выход). Программа CD Spin Doctor завершит работу, и ее рабочее окно исчезнет с экрана.

Еще раз напомним, что хотя программа CD Spin Doctor может создавать МРЗ-файлы только со степенью сжатия от 8 Кбит/сек до 128 Кбит/сек, но она способна разжимать готовые МРЗ-файлы любой степени сжатия (256 Кбит/сек и более).


Untitled Document

Знакомство 9. Сжимаем музыку в формат МРЗ с помощью МРЗ Producer

Хотя для преобразования аудиофайлов из формата WAV в формат МРЗ можно воспользоваться программами Easy CD Creator или CD Spin Doctor, как это было сделано в предыдущем опыте, но они сжимают файлы слишком сильно (в 25 и более раз, вплоть до сжатия в 200 раз). Потери качества звука при таких коэффициентах сжатия уже заметны. Если предлагаемые в программе CD Spin Doctor параметры сжатия звука вас не устраивают, то преобразовать аудиофайлы из формата WAV в формат МРЗ можно отдельной программой. В Интернете можно найти множество бесплатных и условно бесплатных программ для преобразования аудиофайлов в формат МРЗ. Например, только на сайте mp3.com можно бесплатно скачать несколько программ как для проигрывания файлов МРЗ (http://software.mp3.com/software/featured/windows/player/), так и для преобразования аудиофайлов в формат МРЗ (http://software.mp3.com/software/featured/windows/encoder/). Одна и та же программа обычно и преобразовывает файлы в формат МРЗ, и проигрывает их.

Другие программы для проигрывания МРЗ файлов и для преобразования аудиофайлов в формат МРЗ можно найти, задав поиск словосочетания МРЗ player или МРЗ encoder на любом поисковом сервере Интернета, например, на www.yandex.ru .

На сегодняшний день существуют три основных алгоритма для кодирования музыки в формат МРЗ. Это алгоритмы компаний Fraunhofer-IIS, Xing Technologies и алгоритм международной организации по стандартам ISO. Некоторые программы работы со звуком, например GoldWave, имеют функцию сохранения файла в формате МРЗ, но при этом не имеют в своем составе программных модулей для кодирования, а пользуются для этого динамическими библиотеками (DLL) на основе кода ISO. Эти бесплатные динамические библиотеки, например, lame_enc.dll (http://www.mp3-tech.org/software/encoders/lame.zip) или BladeEnc.dll (http://bladeenc.mp3.no/binaries/BladeDLL-091 -intel.zip), достаточно скачать из Интернета и переписать к себе в каталог Windows/System. Кодеры на основе кода от Fraunhofer-IIS работают достаточно быстро и качественно, но не обеспечивают степень сжатия 4:1 (320 Кбит/с). Кодеры на основе кода от Xing быстры, но некачественны. Кодеры на основе кода от ISO очень медленны, но обеспечивают высокое качество и степени сжатия до 4:1.

Здесь мы познакомимся с программой .mp3 Producer, которая написана на основе кода от Fraunhofer-IIS. Ее можно найти в Интернете, задав поиск словосочетания МРЗ Producer на любой поисковой машине. Установка программы производится из самораспаковывающегося архива и очень проста - можно принимать все предлагаемые по умолчанию варианты.

После установки запустите программу, нажав кнопку Пуск (Start) на Панели задач (Taskbar) и выбрав команду главного меню Программы * .mp3 Producer Freeware * .mрЗ Producer (Programs * .mрЗ Producer Freeware * .mрЗ Producer). На экране появится рабочее окно программы .mрЗ Producer

В верхней части рабочего окна программы .mрЗ Producer расположена строка меню для выбора различных команд для работы с программой. В группе элементов управления Encoding File (Кодирование файла) в поле Input (Входной) отображается имя входного WAV-файла, а в поле Output (Выход) - имя выходного файла в формате МРЗ. Кнопка Select Input (Выбор входного файла) предназначена для выбора WAV-файла для сжатия, а кнопка Set Output (Установить выходной файл) - для выбора имени закодированного файла. В нижней половине окна расположены переключатели и поле со списком для выбора степени сжатия файла. Напомним, что степень сжатия звукового сигнала характеризуется величиной потока результирующих данных, который измеряется в килобитах в секунду. Чем ниже поток результирующих данных, тем выше степень сжатия, и тем больше потеря качества звука Считается, что при сжатии исходного аудиопотока до скорости 6 Кбит/сек (сжатие примерно 1:6) качество звука соответствует качеству АudioCD.

Установка переключателя Nice Quality, Lowest Bitrate (Неплохое качество, самая низкая скорость потока данных) дает самую высокую степень сжатия исходного аудиофайла (8 Кбит/сек, 11025 кГц, моно).

Установка переключателя Best Quality for 28.8 Modems (Лучшее качество для модемов 28,8) позволяет получить результирующий МРЗ-файл (24 Кбит/сек, 11025 кГц, стерео), пригодный для передачи по модему, который обеспечивает скорость передачи данных 28,8 Кбит/сек.

Установка переключателя Superior Quality for ISDN (Превосходное качество для ISDN) позволяет получить результирующий МРЗ-файл (64 Кбит/сек, 22050 кГц, стерео), пригодный для передачи по цифровым каналам. Если же установить переключатель слева от поля со списком, то из списка можно выбрать любую предлагаемую степень сжатия. Кнопка Prelisten (Предварительное прослушивание) позволяет прослушать результат преобразования перед кодированием. Кнопка Encode (Закодировать) позволяет начать кодирование. В самом низу окна расположен линейный индикатор, в котором отображается процесс кодирования.

Для выбора WAV-файла для кодирования нажмите кнопку Select Input (Выбор входного файла). На экране появится стандартный диалог.
Выберите в диалоге WAV-файл для преобразования и нажмите кнопку Открыть (Open). Диалог Открытие файла (Open File) исчезнет с экрана.В рабочем окне программы .mp3 Producer автоматически сформируется имя выходного файла, которое образуется из имени исходного файла путем добавления к нему Layer-3. Обратите внимание, что расширение имени файла осталось wav. Если вас
не устраивает имя файла или вы хотите изменить расширение на .mрЗ, то это можно сделать, нажав кнопку Set Output (Установить выходной файл) и изменив имя файла в стандартном диалоге Сохранить (Save).
В поле со списком выберите 256 kBit/s, 44,100 Hz, Stereo и нажмите кнопку Encode (Закодировать). Программа начнет преобразование файла.
По окончании преобразования всех аудиофайлов, предназначенных для записи на компакт-диск, завершите работу с программой, выбрав команду меню File * Exit (Файл * Выход). Рабочее окно программы закроется, и она завершит свою работу.

Итак, файлы в формате МРЗ готовы, и вы можете записать их на компакт-диск и прослушивать на компьютере.


Untitled Document

Знакомство 10. Создаем автоматически загружаемый CD-ROM с файлами МРЗ

Компакт-диск с МРЗ-файлами создается как обычный диск CD-ROM. Процесс создания такого диска подробно описан в главе "Создаем архивы программ и данных на CD-ROM".

Дополнительно на компакт-диск с файлами МРЗ можно записать программу для их воспроизведения, чтобы все было под рукой в одном месте. Более того, эту программу можно автоматически запустить при установке компакт-диска в дисковод CD-ROM.

Опишем этот процесс подробнее. В качестве программы для воспроизведения файлов МРЗ возьмем широко известную бесплатную программу Winamp, которую можно скачать из Интернета по адресу www.winamp.com. Мы рассмотрим вариант программы Winamp Lite 2.64 (Lite - облегченный).

Процесс установки программы мы описывать не будем, так как он очень простой и не требует никакого выбора - надо просто принимать все параметры по умолчанию, которые предлагает мастер установки.

После установки запустите программу, нажав кнопку Пуск (Start) на Панели задач (Taskbar) и выбрав команду главного меню Программы * Winamp * Winamp (Programs * Winamp * Winamp). На экране появится окно МРЗ-плеера Winamp (Рис. 4.65).

Puc. 4.65. Окно МРЗ-плеера Winamp

В левом верхнем углу окна плеера находится кнопка для вызова меню, из которого можно выбирать команды по управлению процессом проигрывания, выбора внешнего вида плеера и т.п. В правом верхнем углу окна плеера находятся три кнопки - для минимизации окна плеера, для свора-чивания его в узкую полоску и восстановления окна в прежнем виде, для закрытия окна.
На панели индикатора показывается время от начала проигрывания мелодии, динамически изменяющийся спектр проигрываемой мелодии, причем вид этого спектра можно выбрать по команде меню Visualization * Visualization options (Визуализация * Параметры визуализации). Справа, под заголовком окна отображается бегущая строка о характеристиках проигрываемого файла - длительности его звучания, наименовании, исполнителе и т.п. Под бегущей строкой показываются характеристики сжатия файла МРЗ - скорость потока, частота оцифровки, число каналов (моно, стерео). Еще ниже расположены ползунки для управления громкостью воспроизведения и баланса между левым и правым каналами для стереозаписей. Рядом с ползунками находятся две кнопки - для показа/скрытия окна эквалайзера и для показа/скрытия окна со списком мелодий. Ниже этих элементов управления расположена полоса для быстрой установки позиции внутри мелодии. В процессе воспроизведения ползунок перемещается по этой полосе. В нижней части окна плеера располагаются кнопки, назначение которых ясно из их названий на Рис. 4.65.

Интересной особенностью программы Winamp является то, что внешний вид ее рабочего окна, форма, цвет и расположение кнопок управления можно изменять, как бы надевая новый "наряд" на рабочее окно. Это осуществляется при выборе команды Skins (Одежки). При этом можно подключиться к Интернету и выбрать команду Skins * Get more skins! (Одежки * Получить еще одежки), чтобы скачать дополнительные одежки для плеера.

По умолчанию программа Winamp устанавливается в каталог Program Files/Winamp. Но если переписать весь этот каталог на компакт-диск, то программа будет запускаться и с компакт-диска. Мало того, она может воспроизводить файл МРЗ, имя которого задано в командной строке вызова программы Winamp. Это свойство удобно использовать для того, чтобы при установке компакт-диска с файлами МРЗ, автоматически начал проигрываться какой-либо МРЗ-файл. При установке компакт-диска с файлами МРЗ и программой Winamp в привод CD-ROM, программу Winamp можно запускать автоматически с помощью файла автозагрузки Autorun.inf.

Файл автозагрузки Autorun.inf, если он есть, всегда размещается в корневом каталоге компакт-диска и служит для запуска программы, находящейся на компакт-диске. Это обычный текстовый файл, который может быть создан, например, программой Блокнот (Notepad). В нашем случае файл автозагрузки Autorun.inf может быть примерно таким:

[AutoRun]
open=/Winamp/Winamp. exe

В последней строке после знака равенства указывается полный путь к исполняемому файлу программы на компакт-диске.

Тогда, если в свойствах вашего дисковода CD-ROM установлен флажок Автоматическое распознавание диска (Auto insert notification), то при установке компакт-диска с файлами МРЗ в привод CD-ROM будет автоматически запускаться программа Winamp.

Можно даже сделать так, чтобы при запуске программы Winamp она автоматически начинала проигрывать какую-либо песню. Для этого во второй строке после пробела необходимо указать имя файла МРЗ в качестве параметра запуска программы:

[AutoRun]
open=/Winamp/Winamp.exe
/Songs/ABBA/Thank_you_for_the_music.mp3

Мы рассмотрели в этой главе большинство аспектов создания дисков AudioCD.


Untitled Document

ГЛАВА 5.Переносим Видеозаписи на VideoCD

В настоящее время практически в каждом доме есть цветной телевизор и видеомагнитофон, и видеокамера уже перестала быть редкостью. Однако все отснятые, записанные и приобретенные видеозаписи хранятся на магнитных видеокассетах. Магнитные носители информации, как известно, очень сильно подвержены различным повреждениям, начиная от механических: неосторожного обращения или неисправности механизма видеомагнитофона, и кончая повреждениями, вызванными магнитными полями, перепадами температур и длительным хранением.

Как не старайтесь вы уберечь свою любимую видеозапись, рано или поздно она потеряет свои качества, на экране появятся помехи, полосы и срывы изображения. От всех выше перечисленных недостатков свободны оптические диски, они не боятся магнитных полей, перепадов температур, повышенной или пониженной влажности и устойчивы к механическим повреждением.
Еще одно немаловажное преимущество оптических компакт-дисков в том, что они занимают гораздо меньше места, чем традиционные видеокассеты. В настоящее время многие фирмы выпускают видеодиски с фильмами и музыкальными видеоклипами, их можно просмотреть на персональном компьютере, на видео- или DVD-плеере, однако последние не достаточно широко распространены, в основном, за счет своей высокой стоимости. Поэтому, если в вашем распоряжении имеется современный компьютер, оборудованный устройством для записи компакт-дисков, вы можете переписать все имеющиеся у вас видеокассеты на компакт-диски.

В этой главе мы рассмотрим, как переносить видеозаписи на компакт-диски, познакомимся с различными способами сжатия видеосигнала, режимами видеозахвата и оборудованием, которое вам потребуется для того, чтобы создать свой собственный видеоархив на компакт-дисках.


Untitled Document

Знакомство 1. Способы кодирования и компрессии видеосигнала

В настоящее время в мире существуют три стандарта представления цветного телевизионного видеосигнала: PAL, SECAM и NTSC. Все они преобразуют исходный аналоговый видеосигнал в форму, удобную для передачи по линии связи. Несмотря на различие в методе кодирования видеоинформации, все три системы телевидения представляют исходный телевизионный сигнал в виде сигнала яркости (Y) и двух цветоразностных (R-Y) и (B-Y) сигнала, а затем каждая по-своему кодирует его. В телевизоре принятый сигнал декодируется, и с помощью специальной матрицы из сигналов Y, R-Y и B-Y восстанавливаются исходные составляющие цвета: R (red) - красный, G (green) - зеленый и В (blue) - синий, которые затем подаются на соответствующие электронные пушки кинескопа. Видеосигнал, содержащий смесь яркостного и цветоразностных сигналов называют композитным.

Современные видеомагнитофоны и телевизоры оборудованы композитными и S-Video внешними разъемами, для подключения аппаратуры VHS и S-VHS-качества. Разница между ними в том, что для подключения аппаратуры качества VHS используется композитный видео вход/выход, где смесь яркостного и цветоразностных сигналов передается по одному проводу. При подключении аппаратуры S-VHS-качества используются S-Video-входы/выходы, где композитный видеосигнал передается по двум проводам. По одному передается информация о яркости, а по другому - смесь цветоразностных сигналов. Это позволяет видеоаппаратуре не использовать для разделения яркостного и цветоразностного сигналов специальные фильтры и при этом терять в качестве и разрешении. В остальном сигналы на S-Video и композитном выходах одинаковые, что позволяет объединить соответствующие контакты S-Video-разъема и подать сигнал на композитный вход видеоаппаратуры. Этот сигнал обычно и используют для записи на видеомагнитофон или для ввода в компьютер. Для того, чтобы записать видеосигнал на диск персонального компьютера, необходимо его перевести в цифровую форму, поэтому все устройства, предназначенные для видеозахвата, содержат в себе аналогово-цифровой преобразователь (АЦП), который может быть в зависимости от его типа 10-ти или 8-ми разрядным. Для восстановления видеосигнала из цифровой формы в аналоговую используется цифро-аналоговый преобразователь (ЦАП).

Один кадр телевизионного изображения представляется в цифровом виде, как поле 768x576 точек, или как еще говорят, пикселов - от английской аббревиатуры pixel (picture element) в системе PAL/SECAM и 640x480 в NTSC. Такое представление одного кадра считается полным, при этом используется так называемый квадратный (square) пиксель. Без заметного ухудшения качества изображения часто используется разрешение 704x576 пикселов для PAL/SECAM и 704x480 для NTSC, при этом пиксель считается прямоугольным, соответствующим рекомендациям CCIR 601 (Comite* Consultatif International des Radio Communications) - Интернационального комитета по радиочастотам. При этом, так как человеческий глаз более чувствителен к перепадам яркости, чем к цвету, то более важна точная передача сигнала яркости. Поэтому при оцифровке видеосигнала соотношение числа отсчетов сигнала яркости и цветоразностных сигналов принято в соотношении 4:2:2, т.е. частота измерения сигнала Y в два раза выше, чем частота измерения сигналов R-Y и B-Y. То есть, одна строка оцифрованного телевизионного видеосигнала содержит 768 измерений яркости и по 384 измерения каждого из цветоразностных сигналов. Соотношение частот оцифровки яркости и цвета также определяет качество изображения, которое впоследствии может быть восстановлено. Это отношение может выражаться соотношениями от 4:1:1 для формата DV до 4:4:4 для Digital формата.
Оцифровка по стандарту 4:4:4 предполагает использование одной и той же частоты дискретизации для яркостного и цветоразностных сигналов. Выбор такого способа оцифровки очень хорошо стыкуется с системами PAL/SECAM и NTSC, разница заключена в количестве строк и кадров в секунду (576/25 для PAL/SECAM и 486/30 для NTSC).

Нетрудно подсчитать, что при использовании 10-битного АЦП одна секунда оцифрованной видеозаписи будет занимать на диске файл размером 27684000 байт, а для хранения всего 49 секунд видеоинформации со звуком вам потребуется более 1 Гб свободного дискового пространства. Чтобы уменьшить размеры файла с видеоинформацией, применяют различные компрессоры или кодеки - сокращение от слов кодер-декодер. Но наиболее распространенными являются два метода сжатия: M-JPEG (Motion-JPEG Joint Photographic Experts Group - стандарт компрессии изображения) и MPEG (Motion Pictures Experts Group - экспертная группа по движущимся изображениям). Оба метода основаны на так называемом дискретно-косинусном преобразовании изображения, разработанным для формата JPEG. Отличие состоит в том, что при сжатии по методу M-JPEG устраняется внутрикадровая избыточность, т. е. это фактически JPEG, но примененный к каждому кадру изображения и поддерживающий чересстрочную развертку. Такое сжатие устраняет избыточность каждого кадра в отдельности, т.е. удаляет избыточную информацию, которая незаметна для восприятия, и при этом не анализирует изменения между соседними кадрами видеосигнала. Сжатие по методу MPEG кроме устранения внутри-кадровой избыточности, устраняет и межкадровую, т.е. сначала из ключевого кадра удаляется избыточность информации о изображении, а затем удаляется избыточность информации об изображении только изменений, которые произошли в изображении при смене ключевого кадра следующим за ним кадром.
Метод MPEG, имеет две разновидности: MPEG1 и MPEG2. Метод MPEG1 не поддерживает чересстрочной развертки и работает только с половинным разрешением (не более 352x288 точек). Для сохранения оцифрованного видеосигнала с полным разрешением нужно использовать формат MPEG2. Следует отметить, что MPEG-сжатие существенно сложнее M-JPEG и требует специального оборудования и программного обеспечения. Существующие же упрощенные MPEG-кодаки по качеству сжатия видеоизображения мало отличаются от устройств, поддерживающих M-JPEG-компрессию, т.к. плохо устраняют межкадровую избыточность. Главной целью применения различных методов сжатия является ограничение потока видеоданных на ваш жесткий диск. Отношение исходного объема данных о видеосигнале к объему данных, полученному в результате сжатия называют коэффициентом компрессии. На практике применяют коэффициенты сжатия от 1:1 (без сжатия) до 30:1 (уменьшение количества данных о кадре в 30 раз). Чем выше применяется коэффициент компрессии, тем хуже качество оцифрованного видео. Условно зависимость качества видеосигнала от коэффициента компрессии можно представить в виде таблицы.

Коэффициент компрессии | Качество видеосигнала | Время, за которое расходуется 1 Гбайт дискового пространства
без компрессии, но 4:2:2 |  | около 49 сек
от 2:1 до 4:1 | Betacam SP | 1,5. . . 3 мин
от 5:1 до 8:1 | S-VHS, Hi-8 | 4. . 6 мин
от 9:1 до 12:1 | VHS, Video-8 (SP) | 7. . 9 мин
от 13:1 до 15:1 | VHS, Video-8 (LP) | 10. . 12 мин

Теперь, после знакомства с принципами кодирования и сжатия видеосигнала, перейдем к рассмотрению устройств, предназначенных для видеозахвата, определим минимальные требования к компьютеру и более подробно карту miroVIDEO DC30 plus.


Untitled Document

Знакомство 2. Buдeoкapmы для нелинейного видеомонтажа

Устройства, предназначенные для оцифровки видеосигнала, называют еще видеокартами или платами для нелинейного монтажа. Такое название обусловлено тем, что вы можете в любой момент времени получить доступ к любой части, секунде или кадру записанного видеоклипа, т.е. не потребуется многократная перемотка и последующее воспроизведение для того, чтобы вставить один фрагмент клипа в определенное место. При нелинейном монтаже вы просто выделяете нужный участок клипа на экране компьютера и вставляете его в нужное место.
Все устройства для захвата и оцифровки видеосигнала содержат набор микросхем, который позволяет аппаратно, т.е. на самой плате, сжимать поток видеоинформации. Чаще всего в профессиональных и полупрофессиональных платах используется метод M-JPEG. На жестком диске оцифрованный видеосигнал сохраняется с расширением *.avi для дальнейшего редактирования. Следует отметить, что в AVI-файле может содержаться видеоинформация, сжатая любым способом (М- JPEG, MPEG1, MPEG2 и др.). Возможность последующего его воспроизведения целиком зависит от установленных на вашем компьютере видеодрайверов и программных декодеров. Кроме того, чтобы использовать свой компьютер для видеомонтажа, он должен обладать следующими минимальными характеристиками:

  • Процессор - Pentium 133 МГц;
  • Операционная система - Windows 95/98;
  • Оперативная память - 32 Мб;
  • Звуковая карта;
  • Акустическая система;
  • Микрофон (для ввода голосовых комментариев поверх фонограммы);
  • Размер свободного пространства жесткого диска - 600 Мб * 3,6 Гб, что в зависимости от степени компрессии и разрешения составляет около 10 минут видеоданных.
    Рекомендованные требования следующие:
  • Процессор - Pentium II (на частоте системной шины 100 МГц);
  • Объем оперативной памяти - 128 Мб;
  • Отдельный жесткий диск с интерфейсом E-IDE или SCSI большой емкости;
  • Наличие звуковой карты, акустической системы и микрофона.

Ниже приведена таблица с основными возможностями плат для нелинейного видеомонтажа, которые можно встретить на рынке.

 | VideoNT | Video Blaster RT300 | VideoNT Pro | Aver Video Commander3 | miro Video DC20
Метод компрессии | MPEG1 | Intel Indeo Video | MPEG1 | M-JPEG | M-JPEG
Разрешение видео (для PAL/SECAM) | 352x288 24 бит | 320x240 8 бит | 352x288 24 бит | 768x576 24 бит | 768x576 24 бит
Цифровой поток | 12,5 кадр/с | 25 кадр/с | 25 кадр/с | 25 кадр/с | 25 кадр/с
Сжатие для кадра | в 10-60 раз | - | в 10-60 раз | 1:10 | 1:7
ТВ- системы на "ввод" | PAL SECAM NTSC | PAL NTSC | PAL SECAM NTSC | PAL SECAM NTSC | PAL SECAM NTSC
Видеовходы | 1 комп., 1 S-Video | 3 комп., 1 S-Video | 1 комп., 1 S-Video | 2 комп., 1 S-Video | 1 комп., 1 S-Video
"Живое" окно на VGA | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра
Оцифровка звука | Нет | Нет | MPEG1 | Нет | Нет
Захват ТВ -кадра без компрессии | 768x576 24 бит | Нет | 768x576 24 бит | 768x576 24 бит | Нет
ТВ-вывод | Нет | Нет | Нет | Нет | PAL, NTSC
Шина | ISA | ISA | ISA | ISA | PCI
Дополнительные возможности | - | - | Редактирование MPEG-файлов | - | -
Рекомендации по использованию | Мультимедиа -видео, качест-венный захват кадров | Мультимедиа -видео | Мультимедиа -видео, демо-кадров CD, качественный захват | Ввод "живого" видео, качест-венный захват кадров | Нелинейный монтаж S-VHS-каче-ства

 | miroVideo DC1 | FASTF60 | FASTFPS60 | Quadrant Q-Motion | miroVideo DC30 plus | FASTAV- Master
Метод компрессии | M-JPEG | M-JPEG | M-JPEG | M-JPEG | M-JPEG | M-JPEG
Разрешение видео (для PAL/SECAM) | 384x288 24 бит | 768x576 24 бит | 768x576 24 бит | 768x576 24 бит | 768x576 24 бит | 768x576 24 бит
Цифровой поток | 12,5 кадр/с | 25 кадр/с | 25 кадр/с | 25 кадр/с | 25 кадр/с PAL/SECAM30 кадр/с NTSC | 25 кадр/с
Сжатие для кадра | 1:7 | 1:18 | 1:1 | 1:10 | 1:3 | 1:5
ТВ- системы на "ввод" | PAL SECAM NTSC | PAL NTSC | PAL SECAM NTSC | PAL NTSC | PAL SECAM NTSC | PAL SECAM NTSC
Видеовходы | 1 комп., 1 S-Video | 1 комп., 1 S-Video | 1 комп., 1 S-Video RGB | 1 комп., 1 S-Video | 1 комп., 1 S-Video | 1 комп., 1 S-Video
"Живое" окно на VGA | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра | Нет, только для предва-рительного просмотра
Оцифровка звука | Нет | Нет | Нет | Нет | Да | Да
Захват ТВ -кадра без компрессии | Нет | Нет | Нет | Нет | Нет | Нет
ТВ-вывод | PAL/NTSC | PAL/NTSC | PAL/NTSC | PAL/NTSC | PAL/NTSC | PAL, NTSC
Шина | ISA | ISA | ISA | PCI | PCI | PCI
Дополнительные возможности | - | - | - | - | Оцифровка звука и воспроиз-ведение | Оцифровка звука и воспроиз-ведение
Рекомендации по использованию | Нелинейный монтаж VHS-качества | Нелинейный монтаж VHS-качества | Нелинейный монтаж VHS-качества | Нелинейный монтаж S-VHS-качества | Нелинейный монтаж S-VHS-качества | Нелинейный монтаж S-VHS-каче-ства

Поясним, что термин "живое" окно на VGA, по сути, означает возможность платы видеозахвата непрерывно выводить исходный видеосигнал на экран монитора компьютера в отдельном окне, которое может располагаться поверх всех остальных окон запущенных на компьютере программ.

Надо отметить, что в последнее время на рынке появились комбинированные видеокарты, которые кроме своего основного назначения - вывода видеоинформации на экран монитора, имеют дополнительно функции акселератора трехмерной графики, телевизионного приемника и ввода-вывода внешнего видеосигнала. Однако в большинстве случаев их технические характеристики существенно уступают специализированным платам видеозахвата.

Рассмотрим более подробно одну из популярных плат для нелинейного видеомонтажа miroVIDEO DC30 plus (Рис. 5.1) производства компании Pinnacle System. Описание приемов работы с этой платой поможет вам получить необходимые знания, которые пригодятся при освоении других плат серии DC этой фирмы, так как многие их настройки и режимы работы очень схожи.
Плата собрана на чипе Zoran ZR36050, который и реализует аппаратное сжатие в формате M-JPEG в реальном времени, т.е. на лету.

Степень сжатия можно плавно регулировать в больших пределах: от 2,5:1 до 32:1. Минимальное значение компрессии зависит от выбранного разрешения и приведено в таблице.

Puc. 5.1.Плата для нелинейного видеомонтажа miroVIDEO DC30plus

Входной сигнал | Размер кадра | Степень компрессии
SECAM | 768x576 | 3,0 : 1
PAL | 768x576 | 3,0 : 1
NTSC | 720x480 | 2,7:1

Наименьшее значение компрессии составляет 2,4:1 при размере кадра 704x432 (с включенной опцией 16:9). Эта опция нужна при захвате видеосигнала, который передает изображение с соотношением ширины к высоте равным 16:9, т.е. широкоэкранное изображение. Размер экрана обычного телевизора имеет соотношение ширины и высоты равное 4:3, поэтому при демонстрации видеосигнала формата 16:9 на экране сверху и снизу будут черные полосы. А так как при захвате эти полосы можно отрезать и не сжимать, то можно уменьшить коэффициент сжатия полезного изображения.

Также плата содержит набор микросхем для оцифровки аудиосигнала. Это означает, что синхронизация звука и видео осуществляется в самой карте, а по качеству оцифровки звука и соотношению сигнал/шум она превосходит многие бытовые звуковые карты. Как и у многих аналогичных современных плат используется быстрая 32-битная PCI-шина версии 2.1 с поддержкой технологии Plug&Play (Установил-и-работай), которая при условии исправности прочих компонентов компьютера правильно опознается операционной системой Windows 95/98. Одним из принципиальных новшеств стало применение в этой плате технологии Bus Mastering (это захват управления PCI-шиной периферийным устройством, подключенным к этой шине), что позволило значительно повысить надежность оцифровки видео за счет разгрузки процессора при операциях ввода/вывода видеопотока.

Плата оборудована пятью внешними и пятью внутренними разъемами для подключения видео и аудио источников сигнала . Внутренний разъем шины 12С практического применения пока не имеет. В комплект поставки платы входит специальный аудио-кабель , который подключается к комбинированному аудио-разъему и обеспечивает переход на стандартные разъемы стандарта RCA "тюльпан". Отдельно можно приобрести выносной коммутационный блок, который сделает работу с платой более удобной. Вместе с платой поставляется компакт-диск с необходимыми драйверами и вспомогательными программами, с помощью которых вы можете произвести все необходимые настройки.
В настоящее время с сайта компании Pinnacle System в Интернете вы можете получить новые драйверы для плат серии DC30 по адресу:

http://www.pinnaclesys.com.

Перед установкой драйверов рекомендуется установить программу Adobe Premiere 4.2 или более поздней версии. Установочная программа запрашивает местонахождение папки этого видеоредактора и добавляет туда файлы с типовыми настройками для проектов и при необходимости программу mirolNSTANT, которая представляет собой набор программных plug-in (дополнительный программный модуль) модулей к программе Adobe Premiere 4.2, и позволяет полностью, преодолеть ограничение на размер редактируемого файла в 2 Гб. После установки драйверов и перезагрузки компьютера на экране появится диалог miroVIDEO DC30 series Hardware Test (Тест оборудования miroVIDEO DC30)(Series - переводится как серии, дело в том, что карты DC30 выпускаются в различных модификациях.)

Нажмите кнопку Test (Тестировать), чтобы произвести тест оборудования, установленного на вашем компьютере. При этом экран монитора временно погаснет. Через несколько секунд изображение на экране восстановится, и в группе элементов управления Test (Тест оборудования) будут выведены результаты теста В случае, если тест оборудования закончился неудачно, рекомендуется переустановить плату в другой свободный PCI-слот и повторить проверку. Далее необходимо произвести тестирование скоростных параметров жесткого диска. Для этого выполните следующие действия.

Нажмите кнопку EXPERT. На экране появится диалог miroVIDEO EXPERT (Extended PERformance Test) (Расширенный тест производительности miroVIDEO)

Тестирование заключается в создании и последующем чтении на указанном диске файла определенного размера, по умолчанию - 100 Мб. В результате чего производится измерение скоростных параметров жесткого диска. Это необходимо для того, чтобы определить, будет ли ваш жесткий диск успевать записывать данные, поступающие из платы видеозахвата при захвате видеосигнала, и передавать данные в нее при воспроизведении.

В группе элементов управления Harddisk Speed (Скорость жесткого диска) из открывающего списка выберите имя вашего жесткого диска, на котором будут храниться записанные видеоклипы.
Нажмите кнопку Start test (Начать тест). В группах элементов управления Test Result (Анализ результатов) и Harddisk speed (Скорость жесткого диска) появится информация о измерянных параметрах.

Если на вашем компьютере установлено несколько жестких дисков или жесткий диск разделен на несколько логических подразделов, то желательно провести тесты всех жестких дисков и разделов, чтобы определить, какой диск или раздел показывает лучшие скоростные результаты. После чего сохраните результаты тестирования, для этого выполните следующие действия.

Нажмите кнопку Store (Запомнить), чтобы сохранить результаты теста.
Нажмите кнопку Close (Закрыть), чтобы закрыть диалог.

Нажмите кнопку ОК в диалоге miroVIDEO DC30 series Hardware Test (Тест оборудования miroVIDEO DC30), чтобы закрыть его.

Программа установки драйверов создаст папке Program Files папку DC3, и поместит туда все необходимые для работы с картой программы, на рабочий стол будет помещен ярлык программы miroVIDEO Capture предназначенную для захвата видео, а в правой части панели задач значок для быстрого доступа к настройкам выходных параметров платы.

На этом тестирование и установка драйверов карты miroVIDEO DC30 plus заканчивается, и вы можете приступать к захвату видеосигнала с различных источников.


Untitled Document

Знакомство 3. Записываем видеоизображение на жесткий дuск

Перед началом записи видеоинформации необходимо подключить с по мощью специального кабеля источник видеосигнала (выходной разъем телевизора, видеомагнитофона или видеокамеры). Плата имеет два входа для видеосигнала S -Video (mini DIN 8 -pin) и Composite (RCA - "тюльпан") (Рис. 5.2). Многие современные телевизоры и все без исключения видеомагнитофоны и видеокамеры имеют раздельные или комбинированные разъемы для вывода видео- и звукового сигнала. Вам необходимо определить, разъемами какого типа должен быть оснащен кабель для подключения к карте видеозахвата. Кроме того, карта обеспечивает режим "сквозного канала", т.е. при записи видеосигнала, например, с видеомагнитофона или камеры, вы можете просматривать записываемый материал на экране вашего телевизора. Для этого необходимо соединить внешний выходной разъем платы с входным видеоразъемом телевизора и настроить плату на вывод видеоизображения. Для этого выполните следующие действия.

Щелкните мышью на значке Р, расположенном в правой части панели задач. На экране появится контекстное меню значка ( (Показать настройки). На экране появится окно меню значка miroVIDEO DC30 series Control (Настройки miroVIDEO DC30).
В группе элементов управления Video Out (видеовыход) из открывающего списка Standard (Стандарт) выберите систему кодирования видеосигнала, которую поддерживает ваш телевизор.
Из открывающего списка Output Device (Выходное устройство), выберите тип видеовыхода (S-Video или Composite), к которому вы подключили телевизор.
Установите флажок Video output & preview (Выход видео и предварительный просмотр), чтобы просматривать записываемый и записанный материал на экране телевизора.

Нажмите кнопку ОК, чтобы закрыть окно miroVIDEO DC30 series Control (Настройки miroVIDEO DC30).

Как уже отмечалось ранее, плата обладает функциями ввода звукового сигнала. Если в вашем компьютере установлена и звуковая плата, то вы можете использовать для ввода звукового сопровождения только одно из этих устройств. По умолчанию в операционной системе Windows 95/98/NT используется микшерное устройство звуковой платы. Поэтому, для того чтобы записывать звуковое сопровождение с помощью платы miroVIDEO, вам необходимо выполнить следующие действия.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Настройки * Панель управления (Preference * Control Panel). На экране появится окно Панель управления (Control Panel) (Рис. 5.11). В зависимости от настроек отображения папок, в окне Панель управления (Control Panel), вы увидите либо строки с мелкими значками, либо крупные значки с подписями.

Puc. 5.11. Панель управления (Control Panel)

Дважды щелкните мышью на строке или значке Мультимедиа (Multimedia). На экране появится диалог Свойства мультимедиа (Multimedia Properties).
Перейдите на вкладку Аудио (Audio) (Рис. 5.12).
В группе элементов управления Запись (Recording) из открывающего списка Основное устройство (Preferred device) выберите строку miroVIDEO DC30 series.
Нажмите кнопку Применить (Apply), чтобы изменения вступили в силу.

Для того чтобы отрегулировать уровень записи микшерным устройством платы miroVIDEO DC30 plus, выполните следующие действия.

Puc. 5.12. Вкладка Аудио (Audio) диалога Свойства мультимедиа (Multimedia Properties)

Нажмите кнопку расположенную в группе элементов управления Запись (Recording). На экране появится окно Record Control (Контроль записи) (Рис. 5.13).

Puc. 5.13. Окно Record Control (Контроль записи)

Выберите команду меню Параметры * Свойства (Option * Properties). На экране появится диалог Свойства (Properties) (Рис. 5.14).

Puc. 5.14. Диалог Свойства (Properties)

Из открывающего списка Микшер (Mixer) выберите строку miroVIDEO DC30 series и нажмите кнопку ОК. Диалог Свойства (Properties) закроется, а на экране появится окно Recording Control miroVIDEO DC30 plus (Контроль записи платы miroVIDEO DC30 plus).

Сбросьте флажок Выкл (Off), расположенный в группе элементов управления External In (Внешний вход), и установите регулятор Громкость (Volume) в среднее положение, если вы будете использовать для записи звукового сопровождения внешний разъем платы.
Если вы будете использовать для записи звука внутренний разъем, то выполните следующие действия.
Сбросьте флажок Выкл (Off), расположенный в группе элементов управления Internal In (Внутренний вход), и установите регулятор Громкость (Volume) в среднее положение.
Нажмите кнопку [image] расположенную в заголовке окна Recording Control miroVIDEO DC30 plus (Контроль записи платы miroVIDEO DC30 plus), чтобы закрыть его.
Нажмите кнопку [image], расположенную в заголовке окна Recording Control (Контроль записи), чтобы закрыть его.

Нажмите кнопку ОК в нижней части окна Свойства мультимедиа (Multimedia Properties), чтобы закрыть его.

После этого микшерные свойства платы miroVIDEO DC plus станут доступны и вы сможете записывать через нее звуковое сопровождение к видеосигналу. Для подключения источника звукового сигнала используется отдельный аудиокабель, который подключается к плате видеозахвата через переходник.

Как отмечалось ранее, в составе драйверов для платы miroVIDEO DC30 plus входят программы для настройки и тестирования платы, захвата видео- и аудиосигналов, а также специальная программа для обеспечения захвата видеоизображения из программы Adobe Premiere. Программа Adobe Premiere предназначена для видеомонтажа, с ее помощью вы можете редактировать видеофильмы, накладывать титры и звуковое сопровождение, создавать различные заставки и видеоэффекты. Чтобы произвести захват видеоизображения из программы Adobe Premiere, выполните следующие действия.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * Adobe * Premiere 5.5 * Adobe Premiere 5.5 (Program * Adobe * Premiere 5.5 * Adobe Premiere 5.5). На экране появится диалог Установки нового проекта (New Project Settings) (Рис. 5.16).

Puc. 5.16. Диалог Установки нового проекта (New Project Settings)

В окне Текущие установки (Current Settings) выводится информация о будущем проекте: размер кадра, применяемый компрессор, количество кадров в секунду и формат звукового сопровождения. Все эти установки влияют на качество результирующего изображения, полученного в процессе видеомонтажа, и размеры окончательного файла с видеоданными, поэтому приходится выбирать наиболее подходящие установки, находя компромисс между качеством, скоростью и размером вашего жесткого диска. Мы рассмотрим вариант установок для записи видеосигнала с качеством VHS и предназначенного для создания в дальнейшем видеодиска VideoCD. Для этого выполните следующие действия.

Из открывающего списка Тип видеофайлов (Editing Mode) нужно выбрать, какого вида файл вы хотите получить после монтажа.

Разница между ними в том, что для упаковки в тот или иной формат используются различные компрессоры. Кроме этого, на формат Video для Windows накладываются дополнительные ограничения на длину результирующего файла, который не может превышать 2 Гб. Но, как уже отмечалось выше, использование карты miroVIDEO DC30 plus позволяет обойти это ограничение за счет применения технологии miroINSTANT.
Ограничение размера результирующего файла в 2 Гб вызвано RIFF структурой самого AVI-файла. Выход из этого положения один - разрезать длинный видеофрагмент на части не более 2 Гб, а затем последовательно воспроизводить их.

Однако при этом возникает другая проблема, связанная с пропаданием изображения и звука на стыках видеофайлов при их последовательном воспроизведении. Для плат серии DC30 эту проблему решает программа SmartPlay, а для плат, начиная с серии DC30 plus и выше, технология miroINSTANT. miroINSTANT - это дополнительный программный модуль к программе Adobe Premiere, предназначенный для ускорения просчета видеороликов, экономии дискового пространства и преодоления 2-гигабайтного барьера при экспорте результатов монтажа в видеофайл. Принцип его работы заключается в том, что при экспорте фрагменты видеофайла, которые не подвергались редактированию, остаются без изменения. Пересчитываются и сохраняются в отдельных файлах лишь переходы от одного фрагмента к другому. В результате получается набор коротких AVT-файлов и неизмененных фрагментов. При этом экономится до 50% дискового пространства. К сожалению, применение технологии miroINSTANT возможно только при использовании современных плат видеозахвата семейства miroVIDEO: DCSOplus, DC50, DC1000, DV200, DV300. Для плат более старых моделей эта технология принудительно запрещена.

Из открывающего списка Тип видеофайлов (Editing Mode) выберите строку Video для Windows (Video for Windows).
Из открывающего списка Скорость (Timebase) выберите 25, а из открывающего списка Учет кадров (Time Display) - 25 fps Timecode
(временной код 25 кадров/сек).
Из открывающего списка Установки нового проекта (New Project Settings) выберите строку Установки видео (Video Settings). Вид диалога изменится в соответствии с Рис. 5.17.

Puc. 5.17. Вид диалога при установке видеопараметров

Из открывающего списка Программа сжатия (Compressor) выберите строку miroVIDEO DC30 plus M-JPEG (16).

Так как мы захватываем видео для последующей записи на компакт-диск, то размер кадра нет смысла устанавливать более 352x288, так как именно этот формат используется при сжатии по алгоритму MPEG-1. Дело в том, что формат VideoCD предполагает, что размер кадра изображения не превышает 352x288 пикселов и скорость потока данных не превышает 1150 Кбит/сек для видео и 224 Кбит/сек для аудиоинформации, а именно такую скорость можно обеспечить при сжатии видеофайла по алгоритму MPEG1. То есть, видеодиск, записанный только таким способом, будет нормально воспроизводится и компьютером, и бытовым Video CD-плеером. Можно, конечно, захватывать и больший размер кадра, но при использовании впоследствии некоторых программ кодировщиков, например, кодера программы WinOnCD, для кодирования исходного видеофайла по алгоритму MPEG1, часть кадра изображения может быть утрачена. Об этом более подробно будет описано в знакомстве о создании видеодиска с помощью программы WinOnCD.

Из открывающего списка Скорость (кадр/сек) (Frame Rate) выберите строку 25.
В группе элементов управления Качество (Quality) в поле ввода % введите желаемое значение качества изображения, например 75. Здесь надо иметь в виду, что чем выше качество результирующего изображения вы хотите получить, тем больше будет размер файла, в котором оно будет хранится, и наоборот, чем хуже качество изображения, тем меньше будет размер файла.

Из открывающего списка Установки нового проекта (New Project Settings) выберите строку Установки звука (Audio Settings). Вид диалога изменится в соответствии с Рис. 5.18.

Puc. 5.18. Вид диалога Установки нового проекта (New Project Settings) при настройке записи звукового сопровождения

Все установки, которые вы можете установить в этом диалоге, влияют на качество записи звука и на размер результирующего файла. Мы установим качество оцифровки звукового сопровождения такое же, как у компакт-диска: частота дискретизации 44100 Гц и формат 16 бит-стерео. Однако большинство бытовых видеокамер и видеомагнитофонов не обеспечивает запись звука такого качества. Поэтому вы можете установить режим захвата звука в соответствии с техническим описанием на вашу воспроизводящую аппаратуру, так как устанавливать более высокое качество бессмысленно. Исключение составляет использование в качестве исходного материала компакт-диски или Hi-Fi видеокассеты.

Из открывающего списка Частота дискретизации (Rate) выберите строку 44 кГц.
Из открывающего списка Формат (Format) выберите строку 16 Бит -Стерео или 16 Бит - Моно.
Из открывающего списка Тип (Туре) выберите строку Несжатый (Uncompressed).
Из открывающего списка Чередование (Interleave) выберите строку 1 сек.

Все произведенные выше установки касаются только параметров проекта видеофильма программы Adobe Premiere, т.е. определяют параметры результирующего видеофайла, полученного в результате монтажа. Далее необходимо настроить параметры видеозахвата. Для этого выполните следующие действия.

Из открывающего списка Установки нового проекта (New Project Settings) выберите строку Установки захвата (Capture Settings). Вид диалога изменится в соответствии с Рис. 5.19.

Puc. 5.19. Вид диалога Установки нового проекта (New Project Settings) при настройке видеозахвата

Из открывающего списка Формат захвата (Capture Format) выберите строку Video for Windows (Видео для Windows).
Из открывающего списка Скорость (Rate) выберите строку 25.
Установите флажок Захват видео (Capture Video).
Установите флажок Захват звука (Capture Audio).
Из открывающего списка Рейтинг (Rate) выберите строку 44 кГц.
Из открывающего списка Формат (Format) выберите строку 16 Бит -Стерео или 16 Бит - Моно, в зависимости от типа записываемого звукового сигнала.
Из открывающего списка Тип (Туре) выберите строку Несжатый (Uncompressed).
Нажмите кнопку VfW Установки (VfW Settings), на экране появится диалог Параметры захвата Video for Windows (Video for Windows Capture Options)В группе элементов управления Установки драйверов (Driver Settings) нажмите кнопку Формат видео (Video Format). На экране появится диалог miroVIDEO DC30 series Video Format (Видеоформат платы miroVIDEO DC30).

В группе элементов управления Frame adjust (Регулировка кадра) установите переключатель Horizontal (Горизонтальная) в положение Half resolution (Половина разрешения), а переключатель Vertical (Вертикальная) - в положение One field (Одно поле).
Переключатель Frame ratio (Кадровое соотношение) установите в положение 4:3 (при захвате обычного телевизионного сигнала) или 16:9 (при захвате широкоэкранного видеосигнала).
Переключатель Pixel ratio (Соотношение пикселя) установите в положение Square (Квадратный).

Нажмите кнопку Cropping (Обрезка), в правой части диалога откроется : окно Cropping (Обрезка) и установите переключатель в положение TV (Телевизионный).
В группе элементов управления Quality adjustments (Настройки качества) установите ползунок линейки Compression (Компрессия) в положение 2,5:1, ползунок линейки Data rate (Поток данных) при этом переместится в крайне правое положение.
В нижней части диалога в области Data rate (25 fps) (Поток данных при 25 кадрах/сек) вы сможете оценить Frame size (Размер кадра) в Кбайтах/кадр и Capture file size (Размер захваченного файла) в минутах/Гбайт.

Нажмите кнопку ОК, расположенную в верхней части диалога, чтобы закрыть его. Нажмите кнопку Видео ввод (Video Input) диалога Параметры захвата Video for Windows (Video for Windows Capture Options). На экране появится диалог miroVIDEO DC30 series Video Input (Видеовход платы miroVIDEO DC30) В этом диалоге из открывающего списка Input (Вход) необходимо выбрать тип используемого входного разъема платы (S-Video или Composite), к которому подключен ваш источник видеосигнала, а из открывающего списка Standard (Стандарт) вид кодировки записываемого видеосигнала (PAL, SECAM или NTSC). Из открывающего списка Pixel ratio (Соотношение пикселя) выберите строку Square (Квадратный). Нажмите кнопку ОК. Диалог miroVIDEO DC30 series Video Input (Видеовход платы miroVIDEO DC30) будет закрыт. Напомним, что при использовании "квадратного" пикселя представление захваченного кадра считается полным, а использование "прямоугольного" - соответствующим рекомендациям CCIR 601, без заметного ухудшения качества.
Остальные настройки можно провести позже, вызывая необходимые диалоги непосредственно перед захватом видеосигнала.

Нажмите кнопку ОК, чтобы закрыть диалог Параметры захвата Video for Windows (Video for Windows Capture Options).
Нажмите кнопку ОК, чтобы закрыть диалог Установки нового проекта (New Project Settings). На экране появится рабочее окно программы Adobe Premiere (Рис. 5.23).

Puc. 5.23. Рабочее окно программы Adobe Premiere

Рабочее окно программы состоит из следующих составных элементов.
Заголовок окна - содержит логотип и название программы. Кнопки управления окном - расположены в правой части заголовка, с их помощью можно свернуть на панель задач, развернуть на весь экран или закрыть рабочее окно программы.

Основное меню - содержит названия групп команд, доступных программе. С помощью основного меню можно вызвать любую из имеющихся в программе команд.

Рабочая область - занимает основную часть рабочего окна программы. В ней в зависимости от выбранного режима просмотра располагаются различные дополнительные окна программы. Каждое дополнительное окно программы имеет свой заголовок и кнопки управления окном, позволяющие в любой момент времени минимизировать, развернуть или закрыть окно.

Окно монитора - дополнительное окно, предназначенное для просмотра исходных видеоклипов и результатов монтажа и редактирования.

Окно проекта - дополнительное окно, позволяющее просматривать составные части проекта и их основные свойства.

Окно монтажного стола - дополнительное окно, которое непосредственно используется для монтажа и редактирования видеоинформации и звуковой дорожки.

Окно навигатора - дополнительное окно, позволяющее быстро перемещаться от одного фрагмента фильма к другому.

Окно транзакций - предназначено для выбора различных вариантов перехода от одного видеофрагмента к другому в уже смонтированном фильме.

Вы можете расположить дополнительные окна в удобном для вас порядке. Для этого достаточно захватить заголовок дополнительного окна мышью и перетащить окно в удобную для работы часть рабочего поля программы. Кроме того, вы можете по желанию изменить размеры любого дополнительного окна, для этого необходимо подвести указатель мыши к краю окна, нажать левую кнопку мыши и, не отпуская ее, растянуть окно до желаемых размеров.

Чтобы произвести захват видеосигнала необходимо выполнить следующие действия.

Puc. 5.24. Окно Захват ролика (Movie Capture - С:)

Выберите команду меню Файл * Захват * Захват видео (File * Capture * Movie Capture). На экране появится окно Захват ролика - С: (Movie Capture - С:) (Рис. 5.24).

В этом окне вы можете просматривать исходный видеосигнал. Если изображение в окне отсутствует, то убедитесь, что кабель от воспроизводящего устройства подключен к выбранному в диалоге miroVIDEO DC30 series Video Input (Видеовход платы miroVIDEO DC30) (Рис. 5.22) разъему, а само устройство включено в режим воспроизведения. В зависимости от выбранного режима захвата и предварительного просмотра изображение может выводиться с небольшим запаздыванием и рывками, но это не скажется на качестве захвата. Если вы используете для контроля входного изображения телевизор, подключенный через сквозной канал, то изображение будет стабильным.
Перед началом записи вы можете еще раз проверить установки видеозахвата, для этого выполните следующие действия.

Щелкните правой кнопкой мыши в любом месте окна Захват ролика (Movie Capture - С:), на экране появится контекстное меню для видеозахвата (Рис. 5.25).

Puc. 5.25. Контекстное меню для видеозахвата

Выберите команду контекстного меню VfW Установки (VfW Settings). На экране появится диалог Параметры захвата Video for Windows (Video for Windows Capture Settings).

Как устанавливать различные режимы видеозахвата, мы рассматривали ранее. Отметим только, что откорректировать яркость (Brightness), контрастность (Contrast), цветовую насыщенность (Saturation) и четкость (Sharpness) захватываемого изображения вы можете с помощью диалога miroVIDEO DC30 series Video Input (Видеовход платы miroVIDEO DC30), перемещая соответствующие регуляторы и контролируя результат в окне Захват ролика - С: (Movie Capture - С:) (Рис. 5.24).

Нажмите кнопку Запись (Record). Изображение в окне Захват ролика (Movie Capture - С:) (Рис. 5.24) перестанет изменяться, а в нижней части окна появится информационная строка о количестве записанных и пропущенных кадров, а также общее время записи . Надо отметить, что пропущенных кадров не должно быть, иначе теряется весь смысл захвата видеоролика. Поэтому надо попытаться любыми способами избежать пропуска кадров. Пропущенные кадры могут появляться в двух случаях: если ваш жесткий диск не справляется с потоком данных, и если в исходном видеосигнале много помех. В первом случае можно попытаться увеличить степень сжатия исходного сигнала и тем самым уменьшить скорость потока видеоданных. Во втором случае нужно попытаться разобраться в источнике помех. Причиной может быть плохое соединение видеокабеля с платой видеозахвата, использование плохо экранированного кабеля, некачественная пленка в видеокассете или неисправность видео-воспроизводящей аппаратуры. Если с первыми двумя недостатками еще можно побороться, то в двух последних случаях избежать пропущенных кадров скорее всего не удастся.

В верхней части окна появляется строка (Курсор спрятан. Нажмите Escape для остановки записи) (Cursor is hidden. Click or press Escape to stop recording).

Нажмите клавишу ЕSC, чтобы остановить запись. На экране появится окно Клип: Teмп1.avi (Clip: Templ.avi) (Рис. 5.27).

Изображение внутри окна может отсутствовать, или вместо него может находиться логотип платы miroVIDEO DC30. Это зависит от установленного видеорежима дисплея и от используемой вами видеокарты. Но, несмотря на отсутствие изображения, вы можете просмотреть записанный видеосюжет на телевизоре, подключенном к плате miroVIDEO DC plus с помощью кнопки , расположенной в нижней части окна.

Puc. 5.27. Окно Клип: Teмп1.avi (Clip: Temp1.аvi)

Чтобы добавить записанный видеоролик к проекту, выполните следующие действия.

Щелкните правой кнопкой мыши в любом месте окна Клип: Teмп1.avi (Clip: Templ.avi). На экране появится контекстное меню для окна клипа (Рис. 5.28).

Рис 5.28. Контекстное меню

Выберите команду контекстного меню Добавить этот клип (Add This Clip). На экране появится диалог с сообщением о необходимости сохранить клип на диске (Рис. 5.29).

Puc. 5.29. Диалог с сообщением о необходимости сохранить клип на диске

Нажмите кнопку ОК. На экране появится диалог Сохранить файл (Save File) (Рис. 5.30).

Выберите папку и введите в поле ввода Имя файла (File Name) название записанного клипа.
Нажмите кнопку Сохранить (Save), диалог закроется, а клип будет добавлен в проект (Рис. 5.31).

Puc. 5.31. Вид рабочего окна программы Adobe Premiere при добавлении клипа к проекту

Закройте окно Клип: Teмп1.avi (Clip: Templ.avi) с помощью кнопки [image], расположенной в правой части заголовка окна.
Теперь можно записать еще один или несколько фрагментов описанным выше способом и приступить к редактированию и монтажу, поместив записанные клипы в окно монтажного стола. Для этого выполните следующие действия.

Выберите окно Проект: Безимен1.ррj (Project: Untitlel.ppj) щелчком мыши в любом месте окна и подведите указатель мыши к строке с именем добавленного клипа, нажмите левую кнопку мыши, и удерживая ее нажатой, перетащите клип в окно Монтажный стол (Timeline) (Рис. 5.32).

Puc. 5.32. Окно Монтажный стол с добавленным видеороликом

Одновременно с добавлением клипа на монтажный стол в правой части окна Монитор (Monitor) появится первый кадр захваченного клипа. Как видно из Рис. 5.32, видеоклип на монтажном столе представлен в виде двух дорожек: видео и звуковой, что позволяет редактировать видео- и аудиоинформацию отдельно.

Мы рассмотрели возможность захвата видеороликов с помощью встроенной функции программы Adobe Premiere, но в составе драйверов DC30 версии 1.41 имеется программа видеозахвата miroVIDEO Capture, которая более проста и наглядна. Кратко познакомимся с ее рабочим окном и основными возможностями и настройками.

  • Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
  • Выберите команду пускового меню Программы * DC30 series * miroVIDEO Capture (Program * DC30 series o miroVIDEO Capture). Ha время загрузки на экране появится заставка фирмы Pinnacle System.

По окончании загрузки на экране появится рабочее окно программы miroVIDEO Capture. Рабочее окно программы состоит из заголовка, содержащего название программы и название проекта, в правой части заголовка имеются кнопки управления окном, и вкладок, на которых расположены органы управления и контроля процессом записи.

Нажмите кнопку Advanced (Расширенные возможности), расположенную на вкладке Mode (Режим), чтобы использовать дополнительные настройки платы видеозахвата.
Перейдите на вкладку Projects (Проекты). Вид рабочего окна изменится, вы можете создать новый, переименовать существующий и удалить старый проект. Установкой переключателя Standard (Стандарт) выбирается стандарт записываемого телевизионного сигнала (PAL, SECAM, NTSC и т. д.). В группе элементов управления Frame Resolution (Разрешение кадра) расположен переключатель Full - Half - Quarter (Полный - Половина - Четверть), для установки необходимого размера захватываемого кадра и флажок TV Cropping
Обрезка телевизионного кадра. В окошке Resolution (Разрешение), расположенном в правой части вкладки, вы можете контролировать выбранный размер кадра. Из открывающегося списка Frames/Sec (Кадры/сек) выбирается необходимая частота кадров видеозахвата. В группе элементов
управления Audio (Звукозапись) с помощью переключателей устанавливается режим записи звукового сопровождения.
Перейдите на вкладку Settings (Установки).

На этой вкладке расположены основные органы управления качеством изображением и регуляторы уровня записи звукового сопровождения. В правой верхней части вкладки, в группе элементов управления Input selection (Выбор входа), с помощью кнопок выбираются видео и аудиовходы платы, к которым подключены устройства воспроизведения. В группе элементов управления Image settings (Настройки изображения) расположены регуляторы яркости, контрастности, насыщенности и четкости оцифровываемого изображения. Все изменения, произведенные вами над изображением, можно проконтролировать в окне Live Video (Preview) (Живое видео (Просмотр)), расположенном в левом верхнем углу вкладки.
Уровень записи звукового сопровождения устанавливается с помощью регуляторов., расположенных в группе элементов управления Audio level (Уровень звукового сопровождения), отдельно для каждого канала. Уровень можно контролировать с помощью двух индикаторов, расположенных справа от регуляторов.
Флажок Linked together (Объединить вместе) служит для синхронного управления регуляторами уровня, если его установить регуляторы будут перемещаться одновременно. Установка флажка + 20 db input gain (Усилить на 20 дБ) позволяет усилить сигнал звукового сопровождения на 20 дБ, что необходимо при записи сигнала с микрофона. В группе элементов управления Data rate (Скорость потока данных) с помощью . нейного регулятора устанавливается необходимая величина скорости передачи данных.
В строке Compression (Коэффициент сжатия) индицируется степень сжатия исходного видеосигнала, соответствующая выбранной скорости потока данных. В нижней части вкладки в виде таблицы отображается информация о дисковой системе вашего компьютера с указанием имени, общей емкости и размера свободного пространства каждого жесткого диска или его логической части. Кроме того, в таблице указывается максимально возможная скорость потока данных и максимальное время записи видеосигнала. В этой таблице вам необходимо выбрать диск, на который будет производиться запись. Пиктограммой расположенной в левой части строки таблицы, отмечается текущий выбранный для записи диск.

Перейдите на вкладку Recording (Установки записи).

В правой части вкладки выводятся информация об установленных режимах аудио- и видеозахвата. В левой части вкладки расположено окно предварительного просмотра. В группе элементов управления Capture time время захвата) можно ограничить время записи видеосигнала, указав в :е ввода необходимое время в секундах и установив флажок. С помощью кнопки расположенной в нижней части окна, включается режимзаписи видеосигнала. Во время записи в строке, расположенной под окном просмотра, индицируется текущий режим работы и время записи, а кнопки начала записи изменится, с ее помощью вы можете в любой момент времени прервать запись. В нижней левой части вкладки в поле ввода Next file to capture (Следующий файл для захвата) вы можете ввести любое удобное для вас имя файла для видеозахвата. После завершения записи видеосигнала вы сразу можете приступить к оцифровке следующего видеофрагмента.

Перейдите на вкладку Clips (Клипы).

В правой части вкладки расположено окно с информацией о видеофайлах, записанных в рамках создаваемого проекта. В левой части вкладки находятся окно просмотра клипа и кнопки управления воспроизведением.

Чтобы выйти и закончить работу с программой, можно воспользоваться кнопкой Quit (Выход), расположенной в нижней правой части рабочего окна.

Записанные программой miroVIDEO Capture видеофайлы в дальнейшем могут быть открыты и смонтированы программой Adobe Premiere.
Мы рассмотрели возможности захвата видеоизображения и звукового сопровождения. Конечно, полученные таким образом файлы можно просто записать на компакт-диск, однако при воспроизведении таких файлов на другнж компьютерах могут возникнуть трудности, связанные с установленными нв них программами воспроизведения видеофайлов и драйверов.
И, конечно, не может быть и речи о возможности воспроизведении такого диска на проигрывателе видеодисков. Для создания полноценного видеодиска необходимо произвести кодирование по алгоритму MPEG1, и только после этого запись полученного видеофайла на видеодиск. Рассмотрим эти операции более подробно.


Untitled Document

Знакомство 4. Создаем VideoCD с помощью программы WinOnCD

В предыдущих знакомствах мы рассматривали процесс захвата и оцифровки видео- и аудиоинформации, но для создания полностью совместимого со всеми устройствами чтения лазерного видеодиска необходимо соблюсти некоторые условия. Дело в том, что для создания полноценного Video-CD нужно, чтобы он отвечал стандарту WhiteBook 2.0, а это означает, что видеоинформация должна быть закодирована по алгоритму MPEG1, т. е. скорость потока информации должна быть для видеоданных не более 1151929,1 бит/сек, а аудиоданных не более 224 Кбит/сек. Кроме того, Video-CD должен иметь определенную структуру и файловую систему. Только в этом случае такой видеодиск можно с одинаковым качеством воспроизвести, как на экране персонального компьютера, так и на экране телевизора, если вы используете CD-i-плеер с Digital-Video-картриджем, или при воспроизведении на бытовом Video-CD проигрывателе.

Для кодирования видеофайлов по алгоритму MPEG1 можно применить как самостоятельные программы кодеры, так и встроенные в программы создания видеодисков функции кодирования. Рассмотрим процесс создания видеодиска на примере программы WinOnCD 3.6.
Перед началом описания процесса создания видеодиска с помощью этой программы хотим сразу предупредить, что встроенный в программу кодировщик MPEG1 имеет ряд недостатков. Один из них заключается в том, что при сжатии исходного видеофайла с размером кадра больше чем 352x288 точек, кодировщик просто отрезает лишние точки изображения.
Поэтому, если вы захватывали видеосигнал с размером кадра 640x480 точек или больше, то при сжатии значительная часть кадра будет безвозвратно потеряна.
Если этот недостаток можно обойти, установив размер кадра результирующего видеофайла равным 352x288 точек, то от недостатков реализации самого алгоритма сжатия, встроенного в программу WinOnCD 3.6 кодера, избавиться не удастся. Качество полученного после кодирования изображения получается заметно хуже чем у видеокассет, записанных в формате VHS. Поэтому мы рекомендуем использовать для записи на компакт-диск файл, сжатый программой кодера стороннего производителя, например, программой XingMpeg Encoder 2.20, которую мы опишем в одном из следующих знакомств.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * CeQuadrat * WinOnCD (Programs * CeQuadrat * WinOnCD). На экране появится диалог New Project (Новый проект).
Перейдите на вкладку Video (Видео). Вид диалога изменится в соответствии с Рис. 5.39.

Puc. 5.39. Вкладка Video (Видео) диалога New Project (Новый проект)

В окне диалога выберите пиктограмму Video CD 2.0 и нажмите кнопку ОК. На экране появится рабочее окно программы WinOnCD 3.6 (Рис. 5.40) для создания видеодиска.

Puc. 5.40. Рабочее окно программы WinOnCD 3.6 для создания видеодиска

Найдите в дереве файловой системы, отображаемой в верхней левой части рабочего окна, папку, в которой находятся захваченные вами видеофайлы, и выберите ее. Содержимое папки будет отражено в области просмотра имен исходных файлов и папок, расположенной в верхней правой части рабочего окна.
Перетащите мышью любой видеофайл из области просмотра имен исходных файлов и папок в область просмотра дерева каталогов макета компакт-диска. Если исходный видеофайл еще не сжат по алгоритму MPEG1, то на экране появится диалог Video CD editor (Редактор видеокомпакт-дисков) (Рис. 5.41).

В этом диалоге говорится, что выбранный AVI-файл должен быть закодирован по алгоритму MPEG для обеспечения необходимой для формата Video-CD скорости потока видеоданных и предлагается произвести кодирование.

Если же вы хотите перенести на компакт-диск уже закодированный видеофайл, то в области просмотра макета видеодиска сразу появится строка с именем добавленного видеофайла и последующие два шага выполнять не придется.

Рис. 5.41 Диалог Vldeo CD Editor (Редактор видеокомпакт-дисков)

Установите флажок PAL (25 frames per second) (PAL (25 кадров в секунду)), чтобы выбрать стандарт, которому будет соответствовать преобразованный видеофайл.
Нажмите кнопку Yes (Да). Начнется процесс сжатия видеофайла и на экране появится диалог Encoding (Кодирование) (Рис. 5.42).

Puc. 5.42. Диалог Encoding (Кодирование)

Этот диалог отражает процесс сжатия видеофайла, сначала происходит /катие звуковой информации, содержащейся в нем, затем вид диалога изменится в соответствии с Рис. 5.43 и начнется процесс преобразования видеоинформации по алгоритму MPEG, после чего будет произведено мультиплексирование звуковой и видеоинформации в один информационный поток.

Puc. 5.43. Диалог Encoding (Кодирование), отражающий процесс сжатия видеоинформации

Надо отметить, что процесс сжатия может занять много времени, это зависит от размера видеофайла и быстродействия вашего компьютера и может идти часами. Кроме того, AVI-файлы, размер изображения которых больше, чем 352x288 пикселов, будут обрезаны до указанного размера, при этом часть изображения кадра будет утрачена - это следствие, как уже отмечалось, недостатков встроенного кодировщика WinOnCD. По окончанию сжатия в области просмотра дерева каталогов макета компакт-диска появится строка с именем преобразованного видеофайла (Рис. 5.44).

Puc. 5.44. Рабочее окно программы WinOnCD 3.6, отображающее макет будущего видеодиска

Описанным выше способом вы можете добавить в макет создаваемого диска другие видеофайлы в формате AVI или MPEG, до тех пор пока индикатор заполнения диска, расположенный над строкой состояния программы, не будет заполнен. При проигрывании созданного видеодиска видеофайлы будут воспроизводиться в том же порядке, в котором вы добавляли их в макет видеодиска.

Нажмите кнопку Disc (Диск), расположенную на панели с кнопками переключения режимов. Вид рабочего окна изменится в соответствии с Рис. 5.45.

Puc. 5.45. Рабочее окно программы WinOnCD 3.6. в режиме записи видеодиска

Для того чтобы произвести запись созданного макета видеодиска, достаточно нажать кнопку Record (Запись), расположенную в области установок записи. После чего на экран будет выведен диалог, отражающий процесс записи информации на компакт-диск.
Вид и содержание диалога были описаны в предыдущих главах книги и не отличаются от диалога при записи компакт-дисков других типов.


Untitled Document

Знакомство 5. Проигрывание VideoCD на компьютере

Для воспроизведения видеодисков на персональном компьютере существует большое количество программ-плееров. Если в настройках устройства тения компакт-дисков установлен режим автоматического распознавания исков, то при установке видеодиска в привод CD-ROM и закрытии его лотка, диск будет автоматически распознан, как VideoCD, и операционная система запустит программный видеоплеер, установленный на вашем компьютере, если он поддерживает этот формат и используется по умолчанию. Ниже перечислены наиболее известные программы видеоплееров, способные проигрывать VideoCD-диски и видеофайлы в формате MPEG1.

  • Microsoft Media Player 6.4/7.0 - поддерживает воспроизведение файлов в формате MPEG1;
  • Creative PC-DVD Player - поддерживает воспроизведение VideoCD-дисков;
  • CiberLink PowerDVD Player 2.0 - поддерживает воспроизведение VideoCD-дисков;
  • XingMPEG Player 3.30 - поддерживает воспроизведение VideoCD-дисков;
  • XingDVD Player 2.0.3 - поддерживает воспроизведение файлов в формате MPEG1.

Остановимся более подробно на описании программы XingMPEG Player 3.30, разработанной корпорацией Xing Technology Corporation. Пробную версию этой программы вы можете найти в Интернете по адресу: www.xingtech.com/. Установка программы не сложна и представляет из себя несколько простых диалогов. После установки в отдельной папке, чтобы запустить программу, выполните следующие действия.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * XingMPEG Player * XingMPEG Player (Program * XingMPEG Player * XingMPEG Player). При первом запуске программы на экране появится рабочее окно программы XingMPEG Player 3.30 (Рис. 5.48) и диалог XMPLAYER (Рис. 5.46).

Puc. 5.46. Диалог XMPLAYER

В этом диалоге разработчики программы приветствуют вас и предупреждают, что программа использует расширенные функции DirectDraw, т.е. технологии прямого вывода на экран монитора видеоинформации с источника. Однако не все драйверы видеокарт и сами видеокарты поддерживают такие функции. Поэтому, если возникнут такие проблемы, плеер будет отключать режим DirectDraw каждый раз при запуске.

Нажмите кнопку ОК. Диалог XMPLAYER закроется и на экране диалог Registation Details (Подробности регистрации) (Рис. 5.47).

Puc. 5.47. Диалог Registation Details (Подробности регистрации)

В этом диалоге сообщается, что срок использования программы ограничен 30 днями, по истечении которых ее использование без регистрации запрещено. Этот диалог будет появляться каждый раз при запуске программы, а счетчик дней оценочного использования с каждым днем будет уменьшаться.

Нажмите кнопку Evalute (Оценить), диалог закроется и на экране останется рабочее окно программы XingMPEG Player 3.30 (Рис. 5.48).

Puc. 5.48. Рабочее окно программы XingMPEG Player 3.30

Рабочее окно программы состоит из заголовка окна, который содержит название программы, имя воспроизводимого видеофайла и кнопки управления окном; основного меню, с помощью которого можно выбрать любую доступную программе команду; и основной рабочей области, которая содержит органы управления воспроизведением, внешним видом рабочего окна и размером окна просмотра видеофайла.

При первом запуске программы мы рекомендуем произвести настройки режима воспроизведения и выполнить тестирование быстродействия вашего компьютера с целью определения оптимальных настроек программы для качественного воспроизведения видеофайлов и видеодисков. Программа XingMPEG Player 3.30 имеет для этого все необходимые средства. Для установки режима воспроизведения и настройки драйвера воспроизведения программы выполните следующие действия.

Выберите команду основного меню программы Settings * Playback (Настройки * Воспроизведение), на экране появится диалог Playback Options (Настройки воспроизведения) (Рис. 5.49).

Установка флажка Auto Repeat (Автоповтор) заставляет программу циклически воспроизводить проигрываемый видеофайл. При установке флажка Always Open at 100% (Всегда открывать на 100%) любой открываемый видеофайл будет появляться на экране в окне просмотра в свою полную величину. С помощью переключателя, расположенного в группе элементов управления Scale (Шкала) вы можете переключить режим отображения в рабочем окне шкалы длительности видеофайла и индикации текущей точки воспроизведения. Положение переключателя Frame (Кадры) переводит единицы измерения шкалы длительности видеофайла в кадры, а положение Time (Время) - в секунды.

Puc. 5.49. Диалог Playback Options (Настройки воспроизведения)

Нажмите кнопку MPEG Driver Setup (Настройки MPEG-драйвера). На экране появится диалог XingMPEG Driver Configuration (Конфигурация драйвера XingMPEG) (Рис. 5.50).

Puc. 5.50. Диалог XingMPEG Driver Configuration (Конфигурация драйвера XingMPEG)

В группе элементов управления Video (Видео) вы можете задействовать ускоритель вашей видокарты, установив флажок Use Acceleration if Available (Использовать ускорение если доступно), и ММХ команды вашего процессора, установив флажок Use MMX if Available (Использовать ММХ если доступно), если видеокарта и процессор, установленные в вашем компьютере поддерживают эти режимы. Эти настройки влияют на быстродействие драйвера.
Кроме того, имеется переключатель Optimize for (Оптимизировать для позволяющий оптимизировать видеопоток для более качественного воспрс изведения - положение Quality (Качество), или подстроиться при воспрои ведении под производительность вашего оборудования - положение Perfomance (Производительность). В группе элементов управления Audio (Аудио) выбираются параметры воспроизведения звукового сопровождения. С помощью переключателя Quality (Качество) выбирается частота дискретизации - 11, 22 или 44 КГц, а с помощью переключателя Channels (Каналы) - режим воспроизведения Stereo (Стерео) или Mono (Моно). В группе элементов управления Rate Control (Контроль частоты) можно включить - положение переключателя On (Включено) или выключить - положение Off (Выключено), контроль частоты смены кадров при воспроизведении.

Нажмите кнопку ОК после того, как установите параметры драйвера. Диалог XingMPEG Driver Configuration (Конфигурация драйвера XingMPEG) закроется.
Нажмите кнопку ОК в диалоге Playback Options (Настройки воспроизведения), чтобы закрыть его.
Теперь можно провести тестовое воспроизведение, чтобы определить и настроить быстродействие вашей системы. Для этого выполните следующие действия.

Выберите команду меню Settings * Diagnostics (Настройки * Диагностика). На экране появится диалог Diagnostics (Диагностика) (Рис. 5.51).
Нажмите кнопку Video Perfomance (Производительность видео), на экране появится диалог Video Perfomance (Производительность видео) (Рис. 5.52).

Puc. 5.51. Диалог Diagnostics (Диагностика)

Рис 5.52 Video Perfomance (Производительность видео)

В группе элементов управления Test Setup (Настройки теста) установите переключатель Rate Control (Контроль частоты) в положение ON (Включено), а переключатель Select Video Size (Выберите размер видео) - в положение 1х, если хотите протестировать производительность при воспроизведении видеофайла с нормальным размером изображения, или в положение Full Screen (Полный экран) при воспроизведении того же файла во весь экран монитора.

Нажмите кнопку Run Tesт (Запустить тест). Если режим теста был выбран 1х то на экране появится окно просмотра, в которозу будет воспроизводится ко роткий тестовый файл входящий в комплекг программы (Рис. 5.53).

При тестировании в режиме Full Screen (Полный экран этот же файл будет воспроизводиться на полный размер экрана монитора.

Puc. 5.53. Окно просмотра при воспроизведении файла

По окончании воспроизведения файла в диалоге Video Perfomance (Производительность видео) появятся результаты тестирования (Рис. 5.54).

Рис 5.54 Диалог производительность видео с результатами теста

В группе элементов управления Overall Perfomance (fps) (Общая производительность) в виде заполненной шкалы показана измеренная производительность в кадрах/сек. Как следует из Рис. 5.54, производительность компьютера, на котором производилось тестирование, составила 27,9 кадров/сек, что близко к идеалу (Ideal), значение производительности которого - 30 кадров/сек. В группе элементов управления Subsystem Perfomans (ms) (Производительность подсистемы) выводятся в милисе-кундах сравнительные параметры "идеальной" системы - в графе 30 fps Reference System (Система, обеспечивающая производительность 30 кадров/сек, на которую ссылается программа) и системы, на которой производилось тестирование - в графе This System (Эта система).Если нажать на кнопку What if (Что если), то на экране появится диалог What if (Что если) (Рис. 5.55).

Puc. 5.55. Диалог What if (Что если)

С помощью этого диалога, изменяя значения полей ввода Disk (Диск), CPU (Процессор), Display/Bus (Дисплей/Шина), вы можете попытаться при необходимости повысить производительность вашей системы. Закрыть этот диалог можно с помощью кнопки Close (Закрыть).
Закройте диалог Video Perfomance (Производительность видео) с помощью кнопки Close (Закрыть).
Нажмите кнопку Close (Закрыть) в диалоге Diagnostics (Диагностика), чтобы закрыть его.

После выполнения настроек можно приступить к проигрыванию файлов видеодисков. Кратко познакомимся с назначением кнопок и органов управления рабочего окна программы.

Кнопка [image] - включает режим воспроизведения. Кнопки [image] и [image] позволяют воспроизводить видеофайл в no-кадровом режиме назад или вперед. С помощью кнопок [image] I и [image] вы можете уменьшать и увеличивать
окна просмотра видеофайла в пределах от 50% размера изображения исходного файла до полного экрана. Кнопка [image] включает и отключает звуковое сопровождение, а с помощью регулятора [image] вы можете установить желаемую громкость звука. Кнопка [image] выводит на экран диалог File Information (Информация о файле) с информацией о проигрываемом файле (Рис. 5.56).

Puc. 5.56. Диалог File Information (Информация о файле)

С помощью кнопки [image] на экран вызывается контекстное меню, выбирая пункты которого, вы можете изменить внешний вид рабочего окна программы. С помощью команды Advanced Panel (Расширенное окно) контекстного меню можно изменить вид рабочего окна программы в соответствии с Рис. 5.57.
При этом в рабочем окне появляются дополнительные кнопки управления. С помощью кнопок [image] и [image] можно быстро перейти к предыдущему и следующему фрагменту, записанному на видеодиске или видеофайле, а нажав кнопку [image] можно произвести захват текущего кадра и сохранение его на жестком диске вашего компьютера. Кроме того, с помощью описанного выше контекстного меню можно изменить вид рабочего окна программы на Standard Bar (Стандартная панель) (Рис. 5.58) и Advanced Bar (Расширенная панель) (Рис. 5.59), которые могут располагаться в верхней и нижней части экрана.

Puc. 5.59. Рабочее окно программы XingMPEG Player 3.30 в режиме Advaced Bar (Расширенная панель)

Чтобы воспроизвести установленный в устройство чтения CD-ROM видеодиск, необходимо выбрать команду меню File * Open VideoCD (Файл * Открыть видеодиск). На экране появится окно просмотра, и программа начнет воспроизведение видеодиска. Чтобы проиграть любой видеофайл, сжатый по алгоритму MPEG1, необходимо выбрать команду меню File * Open (Файл * Открыть) и с помощью появившегося на экране диалога Открытие файла (Open) (Рис. 5.60) найти интересующий вас файл на компакт-диске или жестком диске вашего компьютера.

Puc. 5.60. Диалог Открытие файла (Open)

После чего выделить мышью найденный файл в окне диалога и нажать лопку Открыть (Open).
Диалог Открытие файла (Open) закроется, а на экране появится окно просмотра видеофайла с первым кадром записаного в нем видеосюжета. Чтобы начать воспроизведение, необходимо нажать кнопку [image], расположенную в рабочем окне программы. С помощью нопки [image], расположенной в заголовке рабочего окна, вы можете закрыть абочее окно и тем самым завершить работу с программой XingMPEGPlayег 3.30.


Untitled Document

Знакомство 6. Компрессия видеофайлов с помощью XingMpeg Encoder

Однако не все программы, предназначенные для создания и записи видеодисков, способны самостоятельно сжимать видеофайлы по алгоритму MPEG. Такой программой является Easy CD Creator Deluxe 4.0, для того, чтобы записать с помощью нее видеодиск, необходимо сначала преобразовать ваш видеофайл в формат MPEG. Для этого необходимо воспользоваться специальной программой сжатия. Рассмотрим процесс преобразования видеофайла в формат MPEG с помощью программы XingMpeg Encoder 2.20. Эту программу можно получить из Интернета по адресу: http://www.xingtech.com/. После получения нужно произвести установку программы, которая не сложна и представляет из себя последовательность диалогов с запросами. Программа установки создаст на указанном вами диске папку, куда скопирует все необходимые для работы файлы, и создаст дополнительный пункт в пусковом меню. Чтобы запустить программу, выполните следующие действия.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * XingMPEG Encoder * XingMPEG Encoder (Programs * XingMPEG Encoder * XingMPEG Encoder). На экране появится рабочее окно программы XingMpeg Encoder 2.20 (Рис. 5.61).

Рис 5.61. Рабочее окно Xing Encoder

Рабочее окно состоит из заголовка, основного меню, кнопок управления, группы элементов управления Preview (Просмотра), группы элементов управления Job Queue (Очередности работ) и строки состояния.

Нажмите кнопку New (Новая), расположенную в группе элементов управления Job Queue (Очередность работ). На экране появится диалог Job Wizard - Select a Stream Profile (Мастер работ - Выберите тип потока) (Рис. 5.62).

Puc. 5.62. Диалог Job Wizard - Select a Stream Profile (Мастер работ - Выберите тип потока)

Программа является универсальной и позволяет сжимать не только видео, но и аудиофайлы, причем кроме уже заранее настроенных параметров потока данных вы можете сами задавать нестандартные параметры потока. Однако сжатые с нестандартными параметрами видеоданные не смогут воспроизводиться бытовыми VideoCD и DVD-плеерами, воспроизведение таких файлов будет возможно лишь на персональном компьютере. Для того, чтобы подготовить видеофайл к записи на видеодиск, выполните следующие действия.

Дважды щелкните мышью на строке VideoCD (Видеодиск), расположенной в левой части диалога, и в открывшейся ветви профилей потока, выберите строку PAL. Вид диалога изменится в соответствии с Рис. 5.63.

Рис. 5.63 Job Wizard - Select a Stream Profile

В правой части диалога в группе элементов Properties (Свойства) будут выведены основные параметры потока данных.
Нажмите кнопку Далее (Next). На экране появится диалог Job Wizard -Source and Target Files (Мастер работ - Исходный и результирующий файлы) (Рис. 5.64).

Puc. 5.64. Диалог Job Wizard- Source and Target Files(Мастер работ - Исходный и результирующий файлы

Нажмите кнопку Browse (Обзор), расположенную справа от строки Video File Name (Имя видеофайла) в группе элементов управления Source Files (Исходные файлы). На экране появится диалог Открытие файла (Open) (Рис. 5.65).

Puc. 5.65. Диалог Открытие файла (Open)

С помощью этого диалога найдите папку, в которой хранится ваш AVI-видеофайл, выделите его и нажмите кнопку Открыть (Open). Диалог закроется, а в диалоге Job Wizard - Source and Target Files (Мастер работ - Исходный и результирующий файлы) (Рис. 5.64) появится информация о местоположении выбранного файла.

Если вас не устраивает местоположение и имя результирующего видеофайла, предложенные по умолчанию, то вы можете изменить их, нажав кнопку Browse (Обзор), распложенную в группе элементов управления Target Files (Результирующий райл). И затем выбрать делаемую папку и имя Файла с помощью диалога Сохранить (Save) (Рис. 5.66).

Puc. 5.66. Диалог Сохранить (Save)

После того, как пути к исходному и результирующему файлам определены, можно продолжить работу с программой. Нажмите кнопку Готово (Finish). Диалог Job Wizard - Source and Target files (Мастер работ - Исходный и результирующий файлы) закроется, а в ппе элементов управления Job Queue (Очередность работ) появится строка с заданием на сжатие выбранного вами файла.

Выберите в группе элементов управления Job Queue (Очередность работ) строку с назначенным заданием и нажмите кнопку Encode Закодировать). В группе элементов управления Preview (Просмотр) появится изменяющееся изображение из видеофайла, а в строке состояния - расчетное время, оставшееся до завершения кодирования (Рис. 5.67).

Puc. 5.67. Рабочее окно программы XingMpeg Encoder 2.20 при кодировании видеофайла

Время преобразования зависит от размера преобразуемого видеофайла и скоростных параметров вашего компьютера. Например, преобразование 20-секундного видеофрагмента размером 41 Мб на компьютере с процессором Pentium II с тактовой частотой 350 МГц и размером оперативной памяти 96 Мб, занимает около 2 минут. Размер полученного в результате преобразования файла составляет около 3,5 Мб. Кроме того, программа XingMpeg Encoder 2.20 не обрезает размер изображения кадра исходного файла, а уменьшает его до 355x288 пикселов, при этом полностью исключается возможность потери части изображения. После того, как ваш видеоролик закодирован по алгоритму MPEG-вы можете записать его на видеодиск любой программой для создания видеодисков.


Untitled Document

Знакомство 7. Создание VideoCD c помощью программы Easy CD Creator

Рассмотрим способ создания видеодиска с помощью программы Easy CD Creator Deluxe 4.0.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * Adaptec Easy CD Creator 4 * Features * Video CD Creator (Programs * Adaptec Easy CD Creator 4 * Features * Video CD Creator). На экране появится диалог Video CD Creator Wizard (Мастер создания видеодисков) (Рис. 5.68).

Puc. 5.68. Диалог Video CD Creator Wizard (Мастер создания видеодисков)

Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодисков (Рис. 5.69).

Рис 5.69. Второй диалог мастера создания видеодисков

В этом диалоге говорится о том, что будущий видеодиск может быть выполнен двумя методами:

  • Simple Video Sequence (Простая видеопоследовательность) - при этом методе видеофрагменты будут проигрываться последовательно в том порядке, в каком были записаны;
  • One Level Menu Structure (Структура одноуровневого меню) - при этом методе на видеодиске будет создано одноуровневое меню, с помощью которого можно будет выбрать отдельные включенные в меню видеофрагменты, используя кнопки пульта дистанционного управления проигрывателя видеодисков.

Мы рассмотрим создание видеодиска с простой видеопоследовательностью.
Установите переключатель в положение Simple Video Sequence (Простая видеопоследовательность) и нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодисков (Рис. 5.70).

Puc. 5.70. Третий диалог мастера создания видеодисков

В этом диалоге предлагается добавить видеофайлы в макет будущего видеодиска, а также содержится информация о том, что видеофайлы должны быть в формате MPEG.

Нажмите кнопку Add (Добавить). На экране появится диалог Add Play Items (Добавить проигрываемые части) (Рис. 5.71).
Найдите с помощью диалога Add Play Items (Добавить проигрываемые части) ваш видеофайл, сжатый по алгоритму MPEG, выделите его и нажмите кнопку Открыть (Open). Диалог закроется и на экране появится диалог Add New Play Item (Добавление новой проигрываемой части) (Рис. 5.72).

Puc. 5.71. Диалог Add Play Items (Добавить проигрываемые части)

В этом диалоге, состоящем из двух вкладок, содержится информация о добавляемом видеофайле.

Puc. 5.72. Диалог Add New Play Item (Добавление новой проигрываемой части)

Накмите кнопку ОК. Диалог Add New Play Item (Добавление новой проиграв мой части) будет закрыт, а выбранный видеофайл добавлен к макету видеодиска. На экране вновь появится третий диалог мастера создания видеодиска (Рис. 5.70). Вы можете добавить выше описанным образом другие видеофайлы, которые собираетесь записать на видеодиск.

Нажмите кнопку Далее (Next) после того, как все видеофрагменты добавлены к макету видеодиска. На экране появится следующий диалог мастера создания видеодиска (Рис. 5.73).

Puc. 5.73. Четвертый диалог мастера создания видеодисков

В этом диалоге говорится о том, что теперь будет создана последовательность воспроизведения видеофрагментов, добавленных в макет видеодиска.

Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодиска (Рис. 5.74).

Puc. 5.74. Пятый диалог мастера создания видеодисков

Этот диалог состоит из двух списков: слева расположен список Play Items i Video Layout (Проигрываемые части в макете видеодиска), в котором содержатся все видеофрагменты, включенные вами в макет будущего видеодиска; справа расположен список Sequence: Start_Sequence (Последовательность: Стартовая_Последовательность), в который необходимо добавить видеофрагменты в той последовательности, в которой они впоследствии должны будут воспроизводиться при проигрывании видеодиска.

Выделите в списке Play Items in Video Layout (Проигрываемые части в макете видеодиска) видеофрагмент, который должен быть воспроизведен первым, и нажмите кнопку Add (Добавить). Пиктограмма с именем выбранного файла будет помещена в список Sequence: Start_Sequence (Последовательность: Стартовая_Последовательность).
Вышеописанным действием добавьте другие видеофрагменты из макета видеодиска в стартовую последовательность.
Если вы забыли добавить какой-нибудь видеофайл в макет, то можете сделать это с помощью кнопки Add File (Добавить файл). После того, как последовательность воспроизведения видеофрагментов определена, выполните следующие действия.
Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодисков (Рис. 5.75).

Puc. 5.75. Шестой диалог мастера создания видеодисков

В этом диалоге говорится, что создание макета видеодиска закончено и вы перед началом записи можете воспроизвести видеоинформацию макета. Для этого вы можете нажать кнопку Playback (Воспроизведение) и просмотреть последовательность видеоклипов. Чтобы завершить создание видеодиска, выполните следующие действия.

Нажмите кнопку Далее (Next). На экране появится заключительный диалог мастера создания видеодиска (Рис. 5.76).

Puc. 5.76. Заключительный диалог мастера создания видеодисков

Этот диалог сообщает, что все готово к созданию видеодиска и предлагает выбрать одно из следующих действий:

  • Сразу создать видеодиск, установив переключатель диалога в положение Create the CD Now (Создать компакт-диск теперь);
  • Создать образ видеодиска, установив переключатель диалога в положение Create a Disk Image File now (Создать файл образа диска теперь);
  • Внести дополнительные изменения перед созданием диска, установив переключатель диалога в положение Make change before creating the CD (Сделать изменения до создания компакт-диска).
  • Установите переключатель в положение Create the CD Now (Создать компакт-диск теперь) и нажмите кнопку Далее (Next). На экране появится диалог Creating Video CD from Layout (Создание видеодиска из макета) (Рис. 5.77).

Puc. 5.77. Диалог Creating Video CD from Layout (Создание видеодиска из макета)

Этот диалог отражает процесс подготовки видеоданных. Информация в диалоге будет изменятся, пока все видеофайлы, включенные в макет, не будут подготовлены к записи. После подготовки всех видеофайлов макета на экране появится диалог CD Creation Setup (Установки устройства записи компакт-дисков) (Рис. 5.78).

Puc. 5.78. Диалог CD Creation Setup (Установки устройства записи компакт-дисков)

Из открывающего списка Target Devices (Результирующие устройства) выберите ваш дисковод для записи компакт-дисков.
Установите в открывающемся списке Write Speed (Скорость записи) скорость записи 2х (300 KB/sec).
В поле ввода Number of Copies (Количество копий) введите количество копий видеодисков, которые хотите записать.
Установите в дисковод для записи компакт-дисков чистую заготовку CD-R.

Нажмите кнопку ОК. На экране появится диалог CD Creation Process (Процесс создания компакт-диска) (Рис. 3.7).

Информация, которая будет отражаться в этом диалоге, подробно описана в одной из глав этой книги, посвященной записи различных типов компакт-дисков с помощью программы Easy CD Creator Deluxe 4.0. По окончанию процесса записи будет создан видеодиск, который вы сможете просмотреть на компьютере или с помощью бытового проигрывателя видеодисков или бытового проигрывателя DVD.
При создании видеодиска с одноуровневым меню вам необходимо создать графический файл в формате BMP, TIFF или JPEG.

Этот файл может содержать на фоне любого изображения пункты меню с названиями или кадрами видеофрагментов и подписи к ним в текстовом виде. Файл меню надо преобразовать в MPEG 1-поток с помощью программы XingMPEG Encoder 2.20 или ее plug-in-модуля, встроенного в программу Adobe Premiere, который можно загрузить из Интернета и установить на компьютере. После чего включить его в макет видеодиска с помощью диалога мастера создания видеодиска (Рис. 5.70). В этом случае четвертый диалог мастера создания видеодиска будет иметь вид, показанный на Рис. 5.80.

Puc. 5.80. Четвертый диалог мастера создания видеодисков с одноуровневым меню

Этот диалог информирует вас о том, что процесс создания видеодиска будет содержать следующие шаги:

  • Создание стартовой последовательности;
  • Создание одной или нескольких страниц меню;
  • Создание последовательностей, связанных с пунктами меню.

Для продолжения создания диска выполните следующие действия.

Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодиска при назначении стартовой видеопоследовательности
В этом диалоге создается стартовая последовательность, она может содержать короткую видеозаставку, несколько видеофрагментов или совсем отсутствовать, и будет воспроизводиться до появления на экране одноуровневого меню.
Выберите в правой части диалога видеофайл, который нужно воспроизвести перед меню и нажмите кнопку Add (Добавить).
После определения стартовой последовательности нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодиска .

Этот диалог информирует о том, что для создания страницы меню вы должны:

Выбрать подходящий фон;
Определить количество пунктов меню на странице;
Связать каждый пункт меню с определенной для него видеопоследовательностью с информацией об этапах создания одноуровневого меню
Нажмите кнопку Далее (Next).

На экране появится очередной диалог мастера создания видеодиска для выбора фона меню Из открывающего списка Play Item (Проигрываемая часть) выберите файл, который будет использоваться в качестве фонового меню и нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодиска для выбора количества пунктов меню
В поле ввода Number of menu choices (Количество пунктов меню) введите количество видеопоследовательностей, которые будут воспроизводиться при нажатии на цифровые кнопки пульта дистанционного управления проигрывателя видеодисков. Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодиска для изменения имени проигрываемой последовательности
В этом диалоге вы можете изменить имя видеопоследовательности с помощью кнопки Edit (Редактировать). Для этого выполните следующие действия.

Выделите в списке пунктов меню видеопоследовательность, имя которой нужно изменить, и нажмите кнопку Edit (Редактировать). На экране появится диалог Edit Sequence Name (Редактировать имя видеопоследовательности).

Вы можете либо ввести с помощью клавиатуры новое имя видеопоследовательности в поле ввода Name (Имя), либо выбрать имя из открывающего списка Available play sequences (Доступные проигрываемые последовательности). Закончить редактирование нужно нажатием кнопки ОК. После переименования проигрываемых последовательностей выполните следующие действия.

Нажмите кнопку Далее (Next).

На экране появится следующий диалог мастера создания видеодиска
С помощью этого диалога вы можете добавить в макет видеодиска дополнительные страницы меню, переключение между которыми будет осуществляться с помощью кнопок пульта управления видеопроигрывателя. При создании дополнительных страниц меню вы, как уже было описано выше, должны выбрать фоновый видеофрагмент, указать количество пунктов меню, при необходимости переименовать и назначить им соответствующие видеопоследовательности.

Когда все страницы меню добавлены, выполните следующие действия.

Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера создания видеодисков при назначении проигрываемых видеопоследовательностей В этом диалоге необходимо задать последовательность воспроизведения видеофайлов для первого пункта меню.
В левом окне Play items in Video CD Layout (Воспроизводимые части в макете видеодиска) последовательно выберите видеофайл макета видеодиска, который должен быть воспроизведен первым, и нажмите кнопку Add (Добавить). В окне Sequence: PLAY_SEQUENCE1 (Последовательность: PLAY_SEQUENCE1) появится выбранный видеофайл.
Повторите предыдущее действие для других видеофайлов макета таким образом, чтобы в окне Sequence: PLAY_SEQUENCE1 (Последовательность: PLAY_SEQUENCE1), видеофрагменты были размещены в том порядке, в котором должны будут воспроизводиться с готового видеодиска.

После того, как вы создадите последовательность воспроизводимых видеофайлов для первого пункта меню, выполните следующие действия.

Нажмите кнопку Далее (Next).

На экране появится диалог мастера создания видеодиска для создания последовательности воспроизведения видеофайлов для следующего пункта меню.

Создайте видеопоследовательности для каждого пункта меню.

После завершения создания видеопоследовательностей на экране появится диалог мастера создания видеодиска, показанный на Рис. 5.75. Дальнейшие действия и диалоги по созданию видеодиска аналогичны вышеописанным.


Untitled Document

ГЛАВА 6. Создаем фотоархив на CD-ROM и VideoCD

Наверняка в каждом доме имеется не один фотоальбом, в котором хранятся семейные фотографии. Со временем они теряют свое качество, выцветают, трескаются, мнутся и рвутся от неосторожного обращения. Но если в доме появился компьютер, то у вас есть возможность сделать свои любимые фотографии практически вечными. В этой главе мы рассмотрим, каким образом перенести фотографии в компьютер, в каком виде лучше всего хранить компьютерные изображения, как записать их на компакт-диск и сделать слайд-шоу, какое оборудование и программы для этого потребуются.


Untitled Document

Знакомство 1.Kaкue фотоальбомы на компакт-дисках мы сможем делать?

В этой главе мы рассмотрим, как создавать электронные фотоальбомы на компакт-дисках, предназначенных для использования в современных IBM-совместимых компьютерах с установленными операционными системами Windows 3.XX/95/NT/2000 и оборудованных цветным монитором, способным работать в режиме более чем 256 цветов, и дисководом для чтения CD-ROM-дисков. Для проигрывания звука компьютер должен быть оснащен звуковой платой и звуковыми колонками. Фотоальбом представляет из себя лазерный диск, на который помещена различная информация:

  • фотоизображения;
  • музыка;
  • текстовые и голосовые пояснения к кадрам и даже видеосюжеты.

Специальная программа, записанная на диске и запускающаяся непосредственно с самого компакт-диска, позволит вам собирать все компоненты вашего фотоальбома в единое целое. Это означает, что диск представляет из себя не просто хранилище фотографий, музыкальных и видеофайлов. Все компоненты фотоальбома взаимосвязаны друг с другом посредством программы просмотра. Так, каждый кадр может сопровождаться выводом на экран текстовой информации, связанной с кадром по смыслу, например, повествованием о месте, где был сделан тот или иной снимок, или рассказом о личных впечатлениях, связанных с кадром. Снимок может быть сопряжен с закадровым голосом, который вы сами запишите с помощью микрофона, автоматически проигрываемым в момент показа кадра на экране. Просматривать кадры можно вручную по отдельности, причем размер окна просмотра определяется вами, и количество окон с разными кадрами не ограничено, либо в автоматическом режиме "пролистывания" кадров.

"Слайд-шоу" - это когда компьютер "листает" кадры через заданный промежуток времени и показывает их, "растягивая" на полный экран. Программа позволяет просматривать миниатюры или уменьшенные изображения фотографий для быстрого нахождения нужного кадра, и дает доступ ко встроенным элементам поиска по ключевым словам, что позволяет быстро найти нужный кадр, зная лишь, скажем, одно из слов в его названии. Вы имеете возможность объединять кадры в смысловые группы, т.е. использовать альбом, как каталог снимков. На диск может быть записана любая, полюбившаяся вам музыка с аудиокассет или компакт-диска, которая будет воспроизводиться в момент просмотра альбома на компьютере. В отдельном окне, параллельно с фотографиями и музыкой может быть запущен проигрыватель видеосюжетов. Видеофрагменты могут быть записаны на компакт-диск с видеокассет. Программа также позволяет выводить любой из кадров на принтер, подключенный к вашему компьютеру. Предусмотрена возможность копирования изображений в буфер обмена для последующего использования в других программах, работающих под управлением операционной системы Windows.

Благодаря "многосессионной" технологии записи информации, вы можете дополнять свой альбом любыми данными (снимками, музыкой, видео) по мере необходимости, правда этой возможности могут быть лишены пользователи устаревших приводов чтения CD-ROM, которые не поддерживают стандарт CD-ROM XA, и работающих в операционной среде DOS/Windows 3.1. Следует также отметить, что если видеокарта, установленная в вашем компьютере, имеет TV-выход, то вы можете показать свой фотоальбом на экране обычного телевизора.
Процесс создания фотоальбома включает в себя три основных этапа:

  • Сканирование изображения с необходимым оптическим разрешением;
  • Временное сохранение изображения в определенном формате в файл на жестком диске, с присвоением ему уникального имени;
  • Запись фотоизображений на компакт-диск и составление фотоальбома с помощью специальной программы.

Познакомимся более подробно с устройствами ввода изображения и рассмотрим их основные характеристики.


Untitled Document

Знакомство 2. Устройства Ввода изображения

Если у вас дома скопилось много фотографий и число их все растет, они пылятся, высыпаются из альбомов, разбросаны по комнате, но вам жалко их выбрасывать, потому что на них запечатлены ваши друзья, знакомые и дорогие вам люди, то потратьте немного своего свободного времени на то, чтобы перенести их на компьютер. При этом вы получите возможность не только быстро находить свои любимые фотографии, но и сможете устроить для своих друзей и знакомых настоящее слайд-шоу, а при необходимости распечатать понравившиеся фотографии на принтере без потери качества.

В настоящее время самым распространенным устройством ввода фотоизображения в компьютер является сканер. Сканер - это внешнее устройство, подключаемое к компьютеру и предназначенное для ввода в компьютер графической информации с листа бумаги, газеты, книги, фотографии, слайда или негатива. Сканеры бывают разные в зависимости от их назначения. Различают следующие виды сканеров:

  • Ручные - сканеры, которые нужно, держа в руке, провести над нужным рисунком или текстом. Им
    удобно сканировать небольшие рисунки и фрагменты текста.
  • Листовые - такие сканеры протягивают сквозь себя отдельные листы документов, точно также, как принтер протягивает бумагу при печати, поэтому на нем нельзя сканировать страницы из книги или журнала .
  • Планшетные - самая распространенная на сегодняшней день группа сканеров. При сканировании на планшетном сканере документ располагается под крышкой на неподвижном прозрачном планшете, вдоль которого с помощью шагового двигателя перемещается сканирующая каретка с лампой подсветки и системой зеркал.

Puc. 6.3. Планшетный сканер

Слайд-сканеры - предназначены для ввода изображения в компьютер с диапозитивов и фотопленки. Негативные кадры автоматически преобразуются самим сканером в позитивные. При сканировании изображение с фотографии, диаграммы, слайда, негатива переносится в память компьютера, где хранится в виде множества составных пикселей (точек). Каждый пиксель имеет свой цвет. Все пиксели в пределах одного компьютерного изображения одинакового размера.
Количество пикселей на единицу длины и высоты - это разрешение сканирования. Для вывода изображения на экран монитора в режиме 640 на 480 точек достаточно минимального разрешения 72 dpi (dots per inch - точек на дюйм), но лучше больше, так как современные мониторы могут поддерживать режимы, например 1024 на 768 точек и более. Для вывода на печать необходимо разрешение как минимум 150 dpi, а для профессионального качества не менее 250 dpi. При выборе режима сканирования следует помнить о том, что все сканеры обладают двумя видами разрешения: оптическим и интерполяционным.

Оптическое разрешение - это такое разрешение, которое получается без применения специальных программ, повышающих разрешающую способность. Интерполяционное разрешение - это искусственное повышение разрешающей способности, когда между двумя соседними точками изображения вставляются дополнительные точки с усредненными значениями яркости и цвета. При создании фотоальбома лучше всего пользоваться только оптическим разрешением сканера, т.к. интерполяционное ухудшает качество изображения, особенно это будет заметно при печати изображения на принтере. Хотим также отметить, что если вы фотографию размером 10x15 см отсканировали с разрешением 300 dpi, а затем захотели распечатать ее размером 20x30 см на принтере, то вам необходимо будет с помощью программы любого графического редактора преобразовать размер изображение в 20x30 см с разрешением 150 dpi. В этом случае сами точки изображения и их количество останется без изменения, но при выводе на принтер изменится интерпретация этих точек: принтер будет растягивать их, чтобы заполнить изображение размером 20x30 см. Таким образом, уменьшение разрешения при выводе на печать ухудшает качество отпечатанного изображения. Поэтому, если вы захотите печатать календари и плакаты, увеличивая отсканированные фотографии, то используйте в качестве исходного изображения фотографии большого формата, например, 18x24 см, и сканируйте их с максимальным оптическим разрешением вашего сканера.

Количество цветов, в диапазоне которого могут быть окрашены пиксели изображения - называется глубиной цвета. Для ее определения используется термин разрядность (например, 8 бит, 24 бит, 36 бит и т.д.). Чем выше разрядность, тем больше оттенков разного цвета способно передавать компьютерное изображение.
Самый простой вариант - монохромное изображение, представленное из пикселей двух цветов: черного или белого. Это так называемая монохромная графика (LineArt). Файлы монохромной графики имеют небольшой размер, но при этом не несут в себе информацию об "оттенках". В монохромном виде часто целесообразно бывает записывать тексты, линейные графики и диаграммы или изображения, предназначенные для печати на принтерах.

В то же время черно-белое изображение может быть отсканировано таким образом, чтобы сохранить все переходы черно-белых оттенков, так называемая графика в оттенках серого. Как правило, речь тогда идет об оцифровке изображений с разрядностью 8 бит. Такое изображение состоит из пикселей в диапазоне 256 оттенков от белого к черному.

И, наконец, при сканировании цветных изображений информация о цвете точки записывается в виде значений нескольких основных цветов, смешивание которых и определяет цвет точки. Существует несколько схем представления цвета, но основных две - это схема RGB (Red-Green-Blue), при которой цвета представлены "смесью" красного, зеленого или синего, и схема CMYK (Cyan-Magenta-Yellow-Black), при которой цвета составлены из "пересечения" пурпурного, голубого, желтого и черного цветов. Первая используется в большинстве сканеров и для вывода изображений на экран. Вторая - в типографской печати и в большинстве современных цветных принтеров. При печати цветного изображения на принтере отсканированное изображение преобразуется в CMYK программно. Для вывода изображения на экран вам достаточно просканировать изображение в режиме Hi Color-16 бит, а для печати на принтере нужно минимум 24 бит (по 8 бит на R, G и В).

Помимо физического разрешения и глубины цвета для профессионального качества сканирования также важен такой технический параметр, как диапазон оптических плотностей (Optical Density - D), в пределах которых сканирующий аппарат способен адекватно различать цветовые оттенки. Оптическая плотность - это способность сканера различать темные и светлые участки изображения. Разные оригиналы изображения имеют различную плотность в пределах от О D (белый цвет) до 4 D (черный цвет). Фотоотпечатки имеют небольшую величину до 2,6 D. Оптическая плотность негативов обычно не превышает 2,8 D. А вот для качественного сканирования диапозитивов величина оптической плотности сканера может быть ключевым фактором, так как именно диапозитивы требуют повышенной чувствительности сканера к оттенкам в теневых областях. Для нормальных слайдов область оптической плотности сканера должна быть не ниже 3,0 D, а в некоторых ситуациях, при выполнении наиболее качественных работ, может требоваться и более высокая величина до 4,0 D.

Основные технические характеристики различных сканеров приведены в таблице.

Сканер | Тип | Формат | Оптическое разрешение, dpi | Глубина цвета, бит | Интерфейс подключения к компьютеру
Plustek FBIII/FBIV | цветной планшетный | А4 | 300x300 600x600 | 30 | параллельный порт (ЕЕР)
Plustek 600P | цветной планшетный | А4 | 300x600 | 30 | параллельный порт (ЕЕР)
Plustek 9630P | цветной планшетный | А4 | 1200x600 | 30 | параллельный порт (ЕЕР)
Plustek Optic Pro ASI | цветной планшетный | А3 | 400x800 | 30 | параллельный порт (ЕЕР)
Microtek ScanMaker III Pro | цветной планшетный | Legal(8,5x14 дюймов) | 600x1200 | 36 | SCSI (Adaptec)
Microtek ScanMaker E6 | цветной планшетный | Legal(8,5x14 дюймов) | 600x1200 | 30 | SCSI (Adaptec)
Microtek ScanMaker X6 | цветной планшетный | А4 | 600x1200 | 30 | параллельный порт (ЕЕР)
Microtek Phantom 336CX | цветной планшетный | А4 | 300x600 | 36 | USB
Mustek Paragon 6000P/6000SP | цветной планшетный | А4 | 300x600 | 24 | параллельный порт (EEP/SPP), SCSI
Mustek Paragon 12000P/12000SP | цветной планшетный | А4 | 600x1200 | 36 | параллельный порт (EEP/SPP), SCSI
Mustek Scan-Express 600СР | цветной планшетный | А4 | 300x600 | 30 | параллельный порт (ЕЕР)

Кроме рассмотренных выше сканеров, в настоящее время существуют и другие устройства ввода изображения в память компьютера - это цифровые фотокамеры, которые завоевывают все большую популярность. Цифровые фотокамеры по внешнему виду и размерам ничем не отличаются от обычных фотоаппаратов, но принципиально - это совсем разные устройства. В цифровых фотокамерах снятое изображение записывается в память аппарата сразу в цифровом виде и может быть просмотрено на встроенном в камеру мониторе или на экране компьютера. Современные цифровые камеры способны хранить до 50 кадров изображения с разрешением 576x436 dpi при глубине цвета 24 бит. Максимальное разрешение цифровой камеры может доходить у некоторых моделей до 1600x1200 dpi. Камера подключается к компьютеру специальным кабелем, соединенным с последовательным или параллельным портом, некоторые модели соединяются с шиной USB (Universal Serial Bus - универсальная последовательная шина), или IEEE-1394 ("FireWire" - "огненный" провод), в этом случае перенос снятых кадров на жесткий диск компьютера занимает значительно меньше времени. Некоторые модели цифровых камер могут работать в режиме непрерывной съемки и обеспечивают ввод изображения в компьютер со скоростью от 4 до 12 кадр/сек. Такие модели, помимо своего прямого назначения, могут использоваться при проведении видеоконференций через сеть Интернет. Отснятые цифровой фотокамерой кадры в любое время могут быть отпечатаны на цветном лазерном или струйном принтере, а при записи отснятого материала на PhotoCD-диск появляется возможность получить обычные фотографии в фотолаборатории Kodak, оснащенной аппаратурой Image Magic (Чудесное изображение).

Любое изображение, введенное в компьютер любым способом, должно быть сохранено на жестком диске в определенном формате. Очень важно правильно выбрать формат, чтобы изображение впоследствии можно было использовать задуманным образом без возможных потерь и искажений. Из следующего знакомства вы узнаете особенности различных форматов хранения изображений.


Untitled Document

Знакомство 3. Основные форматы хранения изображения и их xapaкmepucmuкu

Тем, кто собирается перенести свой домашний фотоальбом на компакт-диск, следует представлять себе, в каком формате будут записаны отсканированные изображения. Неверный выбор формата может повлечь за собой ряд неудобств при последующей обработке файлов, а в некоторых случаях может вызвать утрату части информации из файла, что не позволит полноценно использовать изображение, хранящееся в нем. При составлении своего фотоархива нужно определить, для каких целей вам необходимо сканировать оригиналы: только для просмотра на экране, печати на принтере или использования в полиграфии. Дело в том, что конечная цель применения файлов будет во многом определять то, каким образом необходимо производить сканирование и в каком формате будут позже записаны файлы.
Формат файла, в котором хранится изображение - это по сути компромисс между качеством изображения и размером файла. Так, например, при сканировании фотографий для последующего просмотра на экране монитора или телевизора не требуется высокое разрешение и качество, поэтому здесь идеально подойдет формат JPEG (Joint Photographic Experts Group - стандарт группы экспертов по фотографии), который сжимает изображение, удаляя мелкие детали. Этот формат позволяет сохранить десятки фотографий на стандартной дискете 1,4 Мб, а на компакт-диске их может уместиться несколько тысяч. В то же время файлы формата JPEG с большим сжатием вы не сможете впоследствии использовать в полиграфии, так как часть информации в процессе преобразования в формат JPEG утрачивается из файла. Более того, качество изображения в формате JPEG ухудшается с каждым сохранением файла после некоторой обработки в любом графическом редакторе.
Следует также помнить о том, что файлы, полученные в результате сканирования, могут быть большого размера. Для определения размеров, полученных после сканирования файлов, вы можете воспользоваться следующей формулой:

F = ((А/25,4хВ/25,4)xDхDxC/8,
где:
F - размер файла без сжатия в байтах,
А - ширина исходного изображения в мм,
В - длина исходного изображения в мм,
D - разрешение, с которым предполагается сканировать изображение в dpi,
С - глубина цвета в битах. Таким образом, если вы хотите просканировать фотографию размером 10x15 см с разрешением 150 dpi и глубиной цвета 24 бита, то результирующий файл будет иметь размер 1569378 байт или 1,49 Мб без сжатия.

Не сжатое отсканированное изображение можно сохранить в файле формата BMP (Bit Map - карта битов). Этот формат предполагает хранение информации о каждой точке изображения без предварительного сжатия. Поэтому полноцветные изображения с большим разрешением могут занимать до нескольких десятков мегабайт. Хранить изображения в таком виде неудобно из-за того, что они занимают много места. Однако существует много других форматов, которые устраняют избыточность информации об изображении с помощью различных методов компрессии (сжатия).

Формат TIFF (Tag Image File Format - Универсальный формат файла с изображением) был разработан корпорациями Aldus и Microsoft, как универсальный формат для хранения растровых изображений и, как правило, используется в издательских системах. Он поддерживает множество алгоритмов сжатия, но на практике используется только алгоритм LZW, который сжимает изображение без потерь в качестве, соответственно и степень сжатия получается меньше чем у JPEG. Формат TIFF поддерживает 1-, 2-, 4-, 8-, 24- и 32-битные изображения.

Формат GIF (Graphics Interchange Format - Универсальный графический формат для обмена растровыми изображениями) фирмы CompuServe использует сжатие LZW, может хранить только палитровые изображения с глубиной цвета от 1 до 8 бит и имеет возможность "постепенного" показа (interleaved). Изображение в формате GIF не может состоять из точек более чем 256 цветов, при преобразовании, например, 24-битного изображения в формате GIF все разнообразие цветов "упаковывается" в палитру из 256 цветов, при этом некоторые цвета будут заменены ближайшим цветом из получившейся палитры. И хотя преобразование будет стремиться создать такую палитру, чтобы искажений не было, на практике это не всегда возможно. "Постепенный" показ используется при передаче изображения через Интернет и заключается в том, что при показе специально записанных GIF-файлов строки изображения выводятся на экран не подряд, а в определенном порядке: сначала каждая 8-я, затем - 4-я и т.д., то есть полностью изображение показывается в четыре прохода. Такая система показа позволяет понять, что изображено на картинке еще до того, как она полностью загрузится, что очень важно для медленных телефонных линий. Версия GIF 89a, кроме перечисленных способностей, также поддерживает прозрачный цвет для наложения и анимационные ролики - несколько изображений, которые показываются подряд через определенные промежутки времени.

Патент компании CompuServe на ее формат GIF сделал платным любое использование GIF в программном продукте, кроме бесплатного ПО, без специального на то разрешения, что приводит к постепенному вытеснению GIF с арены популярных графических форматов. На смену GIF приходит PNG. Однако способность формата содержать анимацию все еще держит его на поверхности, анимационные GIF-файлы вовсю используются в Интернете для создания рекламных баннеров.

Формат PNG (Portable Network Graphics - Портативная сетевая графика), поддерживается новыми версиями браузеров, например, Netscape Navigator 4, и вытесняет GIF-формат из Интернета. Этот формат, основанный на вариации алгоритма сжатия без потерь качества, в отличие от GIF или TIFF сжимает растровые изображения и по горизонтали, и по вертикали, что обеспечивает более сильную степень сжатия, кроме того, он поддерживает цветные графические изображения до 48-битных включительно. PNG-формат не дает возможности* создавать анимационные ролики. Поэтому для хранения анимации или нескольких изображений в одном файле используется вариация формата PNG - формат MNG (Multiple Network Graphics), который пока еще находится в состоянии разработки. Формат позволяет создавать изображения с 256 уровнями прозрачности, что ставит его высоко над всеми существующими в данный момент форматами. В настоящее время разработчики формата PNG работают над новым форматом PNP (Portable Network Photography), произносится "пинап", который предназначен для хранения фотографических изображений и обладает мощным алгоритмом сжатия с потерями качества, основанным на технологии Wavelet. Этот формат создавался для Интернета, в его заголовке не предназначено место для дополнительных параметров, поэтому для хранения изображений, подлежащих печати, PNG плохо подходит.

Формат PSD - стандартный формат пакета программ Adobe Photoshop. Этот формат предусматривает хранение слоев (layers) изображений, из которых можно создавать коллажи. Однако он полностью совместим, то есть будет читаться в любом компьютере, где установлена программа Adobe Photoshop или другой пакет программ, поддерживающий формат PSD. Формат содержит много дополнительных параметров, он использует сжатие RLE Packbits. Формат поддерживает любую глубину цвета, вплоть до 16 бит на канал, 48-битные цветные и 16-битные черно-белые, а также маски для обрезки видимых частей изображений, прозрачность и т.п. Формат подойдет для переноса или хранения изображений, созданных из нескольких других изображений и содержащих специфические элементы, свойственные только для обработки программами пакета Adobe Photoshop.

Формат JPEG (Joint Photographic Experts Group) - самый популярный формат для хранения фотографических изображений JPEG является стандартом в Интернете. Хотя алгоритм сжатия формата и ухудшает качество, он может быть легко настроен на минимальные, практически незаметные для человеческих глаз, потери. Существует разновидность формата JPEG, именуемая "прогрессивный JPEG" (p-JPEG).

Прогрессивный JPEG отличается от обычного тем, что при выводе его на экран изображение появляется почти сразу, но плохого качества, а по мере загрузки качество улучшается, аналогично постепенному показу GIF. В формате JPEG можно хранить только полноцветные изображения с глубиной цвета 24 бита. Сушествует также версия JPEG для 32-битных изображений, но она пока мало распространена. Следует отметить, что файлы изображений, сохраненные формате JPEG с небольшим сжатием, вполне подходят для использования в полиграфии. Но для создания полиграфической продукции файл в формате JPEG лучше преобразовать в TIFF или PSD и далее редактировать только этот файл, так как при каждом сохранении JPEG-файла будет происходить его новое сжатие, каждый раз все более ухудшающее его качество.

Кроме вышеперечисленных форматов хранения изображения существует много других, но мало распространенных форматов. Как уже говорилось выше, некоторые форматы такие, как TIFF, BMP, существуют в нескольких вариантах для различных операционных систем. Однако существует универсальный формат, который одинаково хорошо воспроизводится при работе с различными операционными системами, а также может быть воспроизведен с помощью современных игровых приставок: Panasonic 3DO, Sega CD, Goldstar, Philips CD-I, а также на специализированном плеере Kodak PCD. Это формат PCD (PhotoCD). Рассмотрим компакт-диски, созданные в этом формате, более подробно.


Untitled Document

Знакомство 4. Основные параметры и особенности формата PhotoCD

Лазерные диски, записанные в формате PhotoCD, являются самым универсальным средством хранения и демонстрации цифровых изображений высокого качества, которые можно использовать в полиграфии. Они активно применяются такими гигантами, как NASA, Mercedes-Benz, библиотека Конгресса США, Военно-воздушное и Военно-морское ведомства США, Renter, Hewlett-Packard и т.п. Такой диск представляет из себя лазерный диск, объемом 650 Мб, на котором в цифровой форме представлены фотографические изображения в виде набора файлов с расширением *.pcd - PhotoCD. Немаловажен тот факт, что нет необходимости сразу заполнять весь диск изображениями - этот стандарт позволяет добавлять вновь появившиеся у вас кадры к уже существующим изображениям на вашем PhotoCD-диске. Используемый здесь метод компрессии изображений позволяет разместить на одном диске более чем в три раза большее количество изображений, чем при применении любых других форматов хранения цифровых фотографий без потери качества. Так, например, если при сканировании изображения размером 2048x3072 точки и цвете 24 бит в файл в формате TIFF его объем равен 18 Мб, то после преобразования в формат PhotoCD получится файл с расширением *.pcd, объемом не более 5 Мб. Формат PhotoCD сохраняет фотоизображение в одном из основных фиксированных размеров:

BASE - базовый размер изображения 512x768 точек, (качество кадра будет соответствовать телевизионному изображению вещательного качества, т.е. ВЕТАСАМ), размер файла около 0,75 Мб, на один диск помещается до 800 изображений. Такое количество изображений, как правило, попадает на диск в несколько этапов по мере появления новых кадров, благодаря возможности формата пополнять CD-ROM-диск. Базовый размер идеально подходит для просмотра на телевизоре, для создания своего фотоальбома на CD-ROM, для изготовления рекламных, презентационных или обучающих дисков.

4BASE - размер 4-кратный базовому 1024x1536 точек. Размер файла около 1,5 Мб, и на один диск помещается до 400 таких изображений. Общее количество элементов изображения в четыре раза больше по сравнению с базовым размером, и, как следствие, - в четверо лучшее качество изображения. Изображение такого размера уже не поместится на экране компьютерного монитора в масштабе 1:1, если, конечно, не установлен размер изображения монитора 1200x1600 точек. Такое изображение хорошо подходит для архивирования и высококачественной печати фотографий, а в будущем и для демонстрации посредством телевизора высокого разрешения. Это не означает, что кадр невозможно просмотреть на обычном телевизоре, просто в этом случае вы не увидите улучшения качества по сравнению с базовым вариантом. Все преимущества качества изображений, записанных в размере от 4BASE и выше, пока, к сожалению, можно увидеть только на экране компьютерного монитора.

16BASE - размер 16-кратный базовому 2048x3072 точки. Размер одного файла около 4,5 Мб. На один диск помещается до 120 изображений. Этот размер изображения применяется для архивирования кадров высокого качества, используется в полиграфии и для печати фотографий большого формата.

64BASE - размер 64-кратный базовому 4096x6144 точки. Размер файла получается около 20 Мб. На один диск можно записать до 30 изображений. Применяется в высококачественной полиграфии, архивировании и профессиональной печати фотографий. Не всякий компьютер способен достойно справиться с обработкой файла такого размера, т.к. после открытия изображения в RGB или CMYK он будет занимать порядка 72 или 100 Мб соответственно. Редкая узкая фотопленка нуждается в сканировании для создания изображения такого размера, поскольку, обычно, размер зерна 35 мм пленки превышает размер пикселя в изображении, отсканированном для размера 64BASE. Здесь, как правило, используются пленки или слайды большого формата.

После переноса изображений в память компьютера происходит их преобразование в формат PhotoCD и запись на CD-ROM-диск. Затем производится запись каталога, состоящего из изображений очень маленького размера, для предварительного просмотра содержимого диска. После записи каталог занимает от 5 до 10 Мб свободного места на диске, в зависимости от общего количества изображений. Когда к существующим на диске изображениям добавляются новые, создается и новый каталог, который включает в себя информацию как о новых, так и о старых изображениях, а предыдущий каталог не используется, хотя и продолжает занимать место. Записать изображения в формате PhotoCD можно только на специально предназначенных для этого компакт-дисках производства фирмы Kodak, которые в принципе ничем не отличаются от большинства CD-дисков однократной записи других производителей (Verbattim, TDK, Sony и т.д.). Основное отличие заключается в том, что на диски от фирмы Kodak, предназначенные для записи изображений в формате PhotoCD, при производстве на заводе-изготовителе записывается информация, позволяющая программному обеспечению идентифицировать диск, как PhotoCD, определить его разновидность и индивидуальный для каждого диска порядковый номер. Кроме того, такие компакт-диски выпускаются фирмой Kodak в трех вариантах:

Master PhotoCD - позволяет записать до 120 изображений размером не ниже 16BASE. Это значит, что вам не записать на диск изображение размером, например, 4BASE, и никак не затолкать туда 400 кадров, тем более 800. Исходным материалом может служить только пленка или слайды шириной 35 мм.

Pro PhotoCD - позволяет записать до 30 изображений размером 64BASE. Диск разработан специально для профессиональных фотографов и применения в полиграфии очень высокого качества. Исходным материалом могут служить пленки и слайды до 120 мм, а также пленки шириной 35 мм. Для формата "Pro" предусмотрена возможность ввода заголовка, шапки и кода доступа к каждому кадру.

Portfolio PhotoCD - позволяет сохранять изображения в любом размере, кроме 64BASE. До 800 изображений базового размера помещается на один диск. Диск позволяет создавать интерактивные презентации с созданием управляющих кнопок на изображении для управления мышью или джойстиком. Также возможно присвоение звукового фрагмента каждому кадру с качеством AudioCD. В этом случае после записи изображений записываются Audio-треки согласно количеству звуковых фрагментов.

Как уже говорилось выше, для просмотра PhotoCD на экране телевизора можно использовать игровые приставки. Независимо от стандарта - NTS С или PAL, все эти приставки поддерживают работу с PhotoCD-дисками всех типов, но любые изображения из имеющихся на диске они откроют только в размере BASE, т.е. 512x768 точек. Для просмотра PhotoCD на компьютере с любой операционной системой необходимо только устройство для чтения компакт-дисков. Существует множество различных программ для просмотра PhotoCD, версия одного из которых автоматически записывается на диск во время первой записи изображений и работает на платформах IBM PC и Macintosh. Очень хорошая программа просмотра для IBM PC поставляется с пакетом программ EZ-SCSI фирмы Adaptec, в котором вы можете организовать на своем компьютере слайд-шоу, установив порядок демонстрации и частоту смены изображений.

К сожалению, ни одна программа или конвертор графики не сможет сохранить изображение в формате PhotoCD - это можно сделать только на специально оборудованной станции для записи PhotoCD. Это оборудование также не позволит вам произвести запись на компакт-диск любой другой фирмы потому, что он не будет опознан, как PhotoCD. Зато напечатать изображение с PhotoCD-диска можно в любой лаборатории Kodak, где установлено оборудование для цифровой печати фотографий Image Magic или подобное ему, причем качество полученной фотографии будет не хуже, чем у фотографии сделанной классическим методом. Можно также распечатать любой файл, записанный в формате PhotoCD, на цветном струйном или лазерном принтере, подключенном к вашему компьютеру. В настоящее время в продаже имеются шестицветные струйные принтеры, специально созданные для высококачественной печати фотоизображений даже на глянцевой бумаге. Этот формат может быть очень полезен как любителям и профессионалам, придерживающимся методов классической фотографии, так и немногочисленным пока владельцам цифровой аппаратуры, а также тем, кто непосредственно связан с обработкой цифровых изображений.


Untitled Document

Знакомство 5. Формат изображений для нашего фотоальбома

В предыдущих знакомствах мы рассмотрели возможности и преимущества фотоальбомов на CD-ROM, различные устройства ввода изображения в компьютер и наиболее распространенные цифровые форматы хранения изображений. Из всего вышесказанного можно кратко определить следующие критерии, которыми следует руководствоваться при создании собственных фотоархивов на компакт-дисках:

  • При составлении фотоальбома, предназначенного только для просмотра на экране монитора, вполне достаточно отсканировать исходное изображение с разрешением 72-90 dpi и глубиной цвета 16-24 бита и сохранить на диске в формате JPEG с максимальным качеством;
  • При составлении фотоальбома для просмотра на экране монитора с возможностью последующей печати изображения на цветном струйном или лазерном принтере, вам понадобится более качественная оцифровка изображения (сканирование с разрешением 300-600 dpi и глубиной цвета 24-36 бит с последующим сохранением в формате JPEG с максимальным качеством.

И в том, и в другом случае вам потребуется выполнить несколько пробных сканирований и распечаток изображения, чтобы определить наиболее оптимальный режим сканирования и печати, соответствующий конкретному оборудованию, подключенному к вашему компьютеру: монитору, сканеру и принтеру.


Untitled Document

Знакомство 6. Kpamkuй обзор программного обеспечения для создания фотоальбомов и слайд-шоу

Способность компьютера одновременно и непрерывно воспроизводить звуковую и графическую информацию и при этом позволяющую пользователю управлять этим процессом, часто называют мультимедийными возможностями компьютера. Само понятие "мультимедиа" происходит от английского словосочетания Multimedia (многофункциональная среда) и подразумевает наличие определенных программных и аппаратных средств компьютера. С этой точки зрения создание фотоальбома на CD-ROM с возможностями показа слайд-шоу, воспроизведением звуковых и видеофрагментов можно считать созданием настоящего мультимедийного приложения. В этом знакомстве мы рассмотрим краткие характеристики программ, предназначенных для создания таких приложений, и классифицируем их.
Классификация, предложенная Джеми Сигларом, представляется сегодня наиболее полной, поэтому мы и примем за основу.
Согласно этой классификации можно выделить восемь типов программ, предназначенных для создания мультимедийных приложений:

  • Приложения, созданные с помощью языка сценариев (Scripting Language);
  • Приложения, созданные с применением изобразительного управления потоком данных (Icon/Flow Control);
  • Приложения, созданные с использованием метода кадра (Frame);
  • Приложения, созданные по карточкам с языком сценариев (Card/Scripting);
  • Приложения, созданные с использованием временной шкалы (Timeline);
  • Приложения, составленные из иерархических объектов (Hierarchical Object);
  • Приложения, построенные на основе гипермедиа-ссылок (Hypermedia Linkage);
  • Приложения, построенные с использованием маркёров (Taggiftg).

Рассмотрим эти типы систем для создания мультимедийных приложений более подробно.

Язык сценариев - этот метод наиболее близок по форме к традиционному программированию. В основу положен объектно-ориентированный язык программирования, определяющий с помощью специальных операторов взаимодействие элементов мультимедиа, расположение активных зон, назначение кнопок, синхронизацию и т.д. Он является обычно центральной частью такой системы. Редактирование элементов мультимедиа, таких как: графические изображения, видео, звук и т.д., внутри программы представлено либо в минимальном виде, либо отсутствует вообще. Использование этого метода несколько увеличивает период разработки, так как требуется дополнительное время на индивидуальное изучение возможностей системы, но в результате можно получить более качественное взаимодействие элементов. Так как многие языки сценариев являются интерпретирующими, то подобные системы имеют довольно низкое быстродействие по сравнению с другими средствами.

К системам, основанным на языке сценариев, относится Grasp фирмы Paul Mace Software.

Изобразительное управление потоком данных - этот метод обеспечивает минимальное время разработки и лучше всего подходит для быстрого создания прототипа проекта или выполнения задач, которые необходимо завершить в кратчайшие сроки. Он основан на палитре пиктограмм (Icon Palette), которая содержит всевозможные функции взаимодействия элементов программы, и направляющей линии (Flow Line), которая показывает фактические связи между пиктограммами. Мультимедийные приложения, построенные на базе этого метода, имеют самые медленные исполняемые модули, потому что каждое взаимодействие влечет за собой всяческие перестановки. Однако наиболее развитые пакеты программ, такие как Authorware или IconAuthor, являются чрезвычайно мощными и обладают большим потенциалом. Главное достоинство рассматриваемого метода состоит в том, что он позволяет ускорить работу над дизайном приложения. Вы перемещаете пиктограммы из палитры на бланк страницы, и получающийся документ становится проектом вашего приложения. Далее нужно дважды щелкнуть на пиктограммах, и появившиеся диалоговые окна будут ждать от вас команд для связывания составляющих в единое целое и формирования диалога с пользователем. Применение авторских систем этого типа - наиболее подходящий путь для построения мультимедийных приложений со сложными функциями взаимодействия. К системам, основанным на изобразительном управлении потоком данных, относятся: Authorware фирмы Macromedia, IconAuthor фирмы Aim Tech и TIE фирмы Global Information Systems.

Кадр - этот метод подобен методу изобразительного управления потоком данных. В него тоже обычно включается палитра пиктограмм (Icon Palette), однако связи, прорисованные между пиктограммами, могут представлять собой сложные ветвящиеся алгоритмы. Мультимедиа приложения, построенные по этому методу - очень быстрые, но требуют применения хорошего автоматического отладчика, поскольку ошибки визуально неуловимы. К программам, основанным на методе кадра, относятся: Quest фирмы Alien Communication, Ten Core Producer фирмы Computer Teaching, CBT Express фирмы Aim Tech.

Карточка с языком сценариев - это очень мощный по своим возможностям (через включенный язык сценариев) метод, требующий, однако, точной и жесткой структуризации сюжета. Он превосходно подходит для гипертекстовых приложений и особенно для прикладных программ с интенсивным перемещением. Программы, основанные на этом методе, поставляются с множеством шаблонов, примеров и готовых графических элементов пользовательского интерфейса, а также с интерактивными учебными программами. Благодаря этому, освоение происходит достаточно быстро. Очень простые в освоении, они позволяют разрабатывать довольно интересные мультимедийные приложения. Основной недостаток таких программ - невозможность обеспечить точное управление синхронизацией при выполнении параллельных процессов. К примеру, звуковой файл должен запускаться и заканчиваться прежде, чем сможет начаться следующее событие по сценарию. Наилучшее применение для этих авторских систем - подготовка приложений, которые можно логически организовать в виде отдельных карточек с гипертекстовыми связями между ними. К программам, основанным на карточке с языком сценариев, относится Multimedia ToolBook фирмы Asymetrix.

Временная шкала - по структуре пользовательского интерфейса программа на основе этого метода напоминает звуковой редактор для многоканальной записи. Синхронизируемые элементы показываются в различных горизонтальных "дорожках" с рабочими связями, отраженными через вертикальные столбцы. Основными элементами данного метода являются "труппа" (cast) - база данных объектов и партитура (score) - покадровый график событий, происходящих с этими объектами. Главное достоинство метода заключается в том, что он позволяет написать сценарий поведения для любого объекта. Каждое появление объекта из труппы в одном из каналов партитуры называется спрайтом (sprite) и также считается самостоятельным объектом. Для управления спрайтами в зависимости от действий пользователя в такие программы встраивается объектно-событийный язык сценариев (Scripting language). Такие программы используются при создании многих коммерческих прикладных программ. Программы на основе временной шкалы лучше всего подходят для подготовки приложений с интенсивным использованием мультипликации. К основным недостаткам таких программ можно отнести сложность их освоения из-за необходимости изучения достаточно мощного языка сценариев. К программам, использующим метод временной шкалы, относятся: Director фирмы Macromedia, Power Media фирмы RAD Technologie.

Иерархические объекты - в программах, использующих этот метод создания мультимедиа приложений, как и в объектно-ориентированном программировании, применяется понятие объекта. Хотя научиться работать с такими программами разработки непросто, благодаря визуальному представлению объектов и информационных составляющих мультимедийного проекта можно создавать достаточно сложные конструкции с развитым сюжетом. Типичным представителем такого рода программ является mTropolis. Она наиболее перспективна. Подобные программы обычно довольно дорогие и используются в основном профессиональными разработчиками мультимедийных приложений. К программам, основанным на иерархических объектах, относятся: mTropolis фирмы mFactory, для компьютеров на платформе MAC; New Media Studio фирмы Sybase, Fire Walker фирмы Silicon Graphic Studio, для компьютеров на платформе SGI.

Гипермедиа-ссылки - программы на основе этого метода подобны программам, построенным на методе кадра, в котором показываются концептуальные связи между элементами; однако, им недостает визуального представления связей. Программы, основанные на этом методе, весьма просты в освоении, хотя для эффективной работы с ними требуется обучение. С помощью таких программ можно создавать разнообразные гипертекстовые приложения с элементами мультимедиа. К программам, основанным на гипермедиа-ссылках, относятся: HyperMethod фирмы Prog. Systems AI Lab, Formula Graphic фирмы Harrow Media, HM-card, Everest фирмы Intersystem Concepts.

Маркеры (теги) - программы на базе маркеров используют специальные команды - теги в текстовых файлах (например, SGML/HTML и WinHelp), чтобы связать страницы для обеспечения взаимодействия и объединения элементов мультимедиа. Они имеют, как правило, ограниченные возможности по отслеживанию связей и лучше всего подходят для подготовки диалоговых справочных материалов, подобных словарям и руководствам.

С развитием сети Интернет такие программы нашли широкое применение и при создании страниц для узлов этой глобальной компьютерной сети. К этой группе относятся программы: Hot Dog фирмы Sausage Software, We-bAuthor фирмы Quarterdeck, FrontPage фирмы Vermeer, HoTMetaLPro фирмы SoftQuad, Adobe PageMill фирмы Adobe. Несмотря на большое количество программ, предназначенных для создания мультимедийных приложений, для составления собственного фотоальбома на компакт-диске мы рекомендуем воспользоваться программой PowerPoint 2000, входящую в комплект программ Microsoft Office 2000 (фирмы Microsoft). Эта программа предназначена для создания презентаций, имеет все необходимые средства для создания мультимедийных приложений и обладает удобным пользовательским интерфейсом. Все это делает ее доступной для освоения начинающими пользователями, которые захотят создать собственные фотоальбомы на компакт-дисках.


Untitled Document

Знакомство 7. Cкaниpoвaнue u сохранение видеофайлов

Сканирование фотографий и сохранение графических файлов на жестком диске лучше всего производить с помощью программы любого графического редактора. Мы расскажем о том, как отсканировать и сохранить фотографии с помощью программы Adobe Photoshop 5.0. Перед началом сканирования мы рекомендуем создать на любом жестком диске вашего компьютера, на котором имеется достаточно свободного места, папку с именем, например Фотоальбом. Сделать это можно с помощью программы Проводник (Explorer).

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * Adobe * Photoshop 5.0 * Adobe Photoshop 5.0 (Program * Adobe * Photoshop 5.0 * Adobe Photoshop 5.0). На экране появится рабочее окно программы Photoshop 5.0 (Рис. 6.6).

Puc. 6.6. Рабочее окно программы Photoshop 5.0

Чтобы отсканировать фотографию, выполните следующие действия. Выберите команду меню File * Import * Select TWAIN_32 Source (Файл * Импорт * Источник TWAIN_32). На экране появится диалог Select Source (Выберите источник). В окне Sources выберите имя сканера, подключенного к вашему компьютеру, и на жмите кнопку Select (Выбрать). Диалог Select Source (Выберите источник)закроется. Перед началом сканирования убедитесь, что ваш сканер подключен к компьютеру и на нем включено электропитание. Кроме того, на компьютере должны быть установлены управляющие программы (драйверы) для работы с вашим сканером (они обычно входят в комплект поставки).

Выберите команду меню File * Import * TWAIN_32 (Файл * Импорт * TWAIN_32). Будет запущена сканирующая программа, которая входит в комплект поставки вашего сканирующего устройства.

Программа сканирования может состоять из одного или нескольких окон, которые содержат все необходимые элементы управления для установки режима сканирования и предварительного просмотра сканируемого изображения.
При установке режима сканирования следует руководствоваться изложенными выше рекомендациями. А именно, если вы собираетесь отсканировать цветное изображение так, чтобы впоследствии его можно было распечатать на лазерном или струйном принтере с хорошим качеством, то нужно установить тип сканируемого изображения Millions of Colors (Миллион цветов) и разрешение от 300 до 700 dpi (dot per inch - точек на дюйм).
Если вы хотите отсканировать цветную фотографию, чтобы затем показывать ее на экране монитора, телевизора или разместить на www-страничке в Интернете, то вполне достаточно установить режим сканирования Millions of Colors (Миллион цветов) и разрешение от 75 до 100 dpi. И в том, и в другом случае необходимо будет произвести несколько пробных сканирований, преобразований и пробной печати, чтобы определить наиболее подходящий для вашего сканера, монитора и принтера режим сканирования. После того как режим сканирования установлен, необходимо произвести предварительное сканирование.

Установите регуляторы Brightness (Яркость) и Contrast (Контрастность), расположенные в рабочем окне сканирующей программы, в среднее положение.

Поместите исходный сканируемый материал в сканер, и в окне сканирующей программы нажмите кнопку Preview (Предварительный просмотр). Через некоторое время, необходимое для сканирования, в окне предварительного просмотра появится исходное изображение.

Поправьте при необходимости рамку кадра таким образом, чтобы полностью вписать в нее предварительно отсканированное изображение. Рамка кадра обычно представляет собой прямоугольник, состоящий их пунктирных или сплошных тонких линий и располагается в области предварительного просмотра изображения. При установке указателя мыши на рамку кадра указатель мыши принимает другой вид и нажав и удерживая левую кнопку мыши, вы можете ее перемещением, изменять размеры рамки, а при также ее местоположение. Следует отметить, что нужно постараться как можно точнее вписать в рамку предварительно отсканированное изображение, т.к. результатом окончательного сканирования будет изображение, находящееся внутри рамки кадра. Еще очень важно, чтобы после предварительного сканирования местоположение исходного материала в сканере не менялось, что особенно актуально для планшетных сканеров.

После того, как вы наложили рамку на предварительно отсканированное изображение, нажмите кнопку Scan (Сканировать). Сканер отсканирует изображение, заключенное в рамку кадра. Затем на экране появится диалог, отображающий процесс передачи изображения, после чего изображение появится в рабочем окне программы Photoshop 5.0.

При необходимости вы можете отредактировать полученное изображение: отрегулировать яркость, контрастность, цветовую гамму, удалить мелкие дефекты фотографии, устранить дефект "красных глаз" и т.д. Для этого программа Photoshop 5.0 обладает всеми необходимыми инструментами и возможностями.

По окончании редактирования отсканированного изображения необходимо сохранить его на жестком диске в заранее созданной папке. Для этого выполните следующие действия.

Выберите команду меню File * Save as (Файл * Сохранить как), на экране появится диалог Save as (Сохранить как) (Рис. 6.8).

Рис 6.8. Сохранение рисунка

Из открывающегося списка Папка (Folder) выберите имя диска, на котором расположена папка для хранения фотографий. В окне диалога появится список всех папок выбранного диска.

Дважды щелкните мышью на папке Фотоальбом, чтобы открыть ее.

Если вы еще не создали папку для хранения фотографий, то можете создать ее с помощью этого диалога. Для этого достаточно нажать кнопку
jffil, расположенную в верхней части диалога, и ввести с помощью клавиатуры новое имя папки.

В поле ввода Имя файла (File name) введите имя, под которым будет храниться отсканированное изображение.

Из открывающегося списка Save as (Сохранить как) выберите строку с именем формата файла, в котором будет сохранено изображение (о различных форматах хранения изображения было рассказано в одном из предыдущих знакомств), например, JPEG (*.JPG; *.JPE).

Puc. 6.9. Диалог JPEG Options (Параметры JPEG)

Нажмите кнопку Сохранить (Save). На экране появится диалог JPEG Options (Параметры JPEG) (Рис. 6.9).

Как уже отмечалось в предыдущих знакомствах, при сохранении изображения в формате JPEG, устраняется избыточность графической информации, при этом качество изображения теряется в зависимости от степени сжатия исходного изображения. С помощью диалога (Рис. 6.9) вы можете настроить параметры сжатия изображения, находя компромисс между качеством сохраняемого изображения и размером результирующего файла. Если в дальнейшем предполагается печатать изображения с приемлемым качеством, то в группе элементов управления Image Options (Параметры изображения) в поле ввода Quality (Качество) следует ввести значение от 8 до 10, при этом результирующий файл будет большим. Если же печать изображения не планируется, то значение в поле ввода Quality (Качество) можно установить от 4 до 7, что значительно сократит размер результирующего файла.

Нажмите кнопку ОК. Диалог JPEG Options (Параметры JPEG) будет закрыт, а изображение сохранено на жестком диске вашего компьютера.
Если вы собираетесь печатать отсканированные изображения, то мы рекомендуем после сохранения изображения в файл, вновь загрузить его в программу Photoshop 5.0 и выполнить пробную печать. Для этого выполните следующие действия.

Выберите команду меню File * Print (Файл * Печать), на экране появится диалог Print (Печать)

Из открывающегося списка Print Quality (Качество печати) выберите максимально возможное для вашего принтера разрешение и нажмите кнопку ОК. Диалог закроется и принтер начнет печатать изображение.

По завершении печати сравните оригинал с отпечатанной копией и при необходимости измените режимы сканирования или параметры сжатия.


Untitled Document

Знакомство 8. Фотоальбом с помощью программы PowerPoint 2000

Как уже отмечалось выше, программа PowerPoint 2000 входит в состав пакета программ под общим названием Microsoft Office 2000 и располагает большим набором функций для создания презентаций и слайд-шоу. Кроме того, из-за большой популярности пакета программ Microsoft Office 2000 программа PowerPoint 2000 имеет достаточно широкое распространение, что дает возможность просматривать созданные с помощью ее презентации и слайд-шоу на различных компьютерах.
Любой проект, а именно так называются заготовки презентаций и слайд-лоу в программе PowerPoint 2000, лучше всего начинать с создания на жестком диске отдельной папки с обобщенным названием проекта.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * Проводник (Program * Explorer). На экране появится рабочее окно программы Проводник (Explorer) (Рис. 6.11).

Puc. 6.11. Рабочее окно программы Проводник (Explorer)

В списке Папки (Folders), расположенном в левой части рабочего окна, выберите диск, на котором будет находится папка с проектом, например С:. Щелкните правой кнопкой мыши на списке папок диска С:, расположенной в правой части рабочего окна программы Проводник (Explorer). На экране появится контекстное меню для списка папок (Рис. 6.12). Выберите команду контекстного меню Создать * Папку (Create * Folder), в списке папок рабочего окна программы Проводник (Explorer) появится значок папки с выделенной подписью Новая папка (New folder). Введите с помощью клавиатуры имя папки, например, Фотоальбом, и нажмите клавишу "Enter" .

Puc. 6.12. Контекстное меню для списка папок

Скопируйте в эту папку файлы с фотографиями, которые хотите включить в фотоальбом. Можно сразу после сканирования сохранять файлы в этой папке, назначая им оригинальные имена. При выборе режима сканирования вы можете руководствоваться рекомендациями из предыдущих знакомств. Мы рассмотрим основные приемы работы с программой на небольшом примере, состоящем из нескольких изображений, вместо которых вы можете использовать собственные файлы с фотографиями.


Untitled Document

Знакомство 9. Создание CD-ROM со слайд-шоу с помощью программы Фотослайдер
Если вы не собираетесь создавать структурированный фотоальбом с множеством звуковых и анимационных эффектов и вам достаточно простого показа слайдов, то для этого вполне подойдет программа Фотослайдер 1.3. Эта программа обладает следующими возможностями:

  • Работает с графическими файлами формата GIF, BMP, PCX и JPEG;
  • Имеет 150 различных эффектов смены слайдов;
  • Позволяет демонстрировать изображения, как по порядку, определенному в отдельном файле, так и произвольно;
  • Одновременно с демонстрацией слайдов воспроизводить музыку с компакт-диска;
  • Имеет русский пользовательский интерфейс;
  • Может быть использована в качестве хранителя экрана.

Программа распространяется бесплатно и вы можете ее загрузить из Интернета с сервера бесплатных программ по адресу: http://www.freesoft.ru или с www-странички автора Александра Надеева по адресу: http://www.chat.ru/~nadey/. После загрузки программы из Интернета распакуйте полученный архив в отдельной папке с помощью программы WinZip.

Откройте с помощью программы Проводник (Explorer) папку, в которую вы распаковали программу, и двойным щелчком мыши на файле PhotoSlider.exe запустите ее. На экране появится рабочее окно программы Фотослайдер 1.3 (Рис. 6.52).

Puc. 6.52. Рабочее окно программы Фотослапдер 1.3

Рабочее окно состоит из следующих элементов:

  • Открывающегося списка, содержащего имена дисковых накопителей, подключенных к компьютеру, под которым отображается список папок выбранного диска;
  • Открывающегося списка, содержащего типы файлов в выбранной папке, которые могут быть показаны в расположенном ниже окне;
  • Окна предварительного просмотра графического файла;
  • Кнопок управления рабочим окном [image] и [image], с помощью которых можно свернуть или закрыть рабочее окно программы;
  • Кнопки вызова диалога для настройки параметров программы
  • Кнопки запуска слайд-шоу

Перед началом работы можно настроить параметры программы, для этого выполните следующие действия.

Puc. 6.53. Диалог Параметры

Нажмите кнопку [image], на экране появится диалог Параметры (Рис. 6.53).
Установите флажок Играть музыку CD, если хотите, чтобы во время демонстрации слайдов воспроизводилась музыка с компакт-диска.
В поле ввода Пауза между кадрами введите число секунд, через которые будут меняться кадры при демонстрации слайд-шоу.
Установите флажок Автореверс, если хотите, чтобы демонстрация слайдов циклически повторялась и прерывалось только по щелчку мыши или при нажатии клавиши Esc.
Из открывающегося списка Смена фото выберите режим смены кадров при демонстрации слайд-шоу. Возможны установки По очереди и Случайно.
В поле ввода Первый эффект введите номер одного из 150 эффектов, который будет выполнен первым.
Установите флажок Отключить сложные эффекты, если ваш компьютер не обладает большим быстродействием.
Из открывающегося списка Смена эффектов выберите строку Случайно. Возможна также установка режиме смены По очереди и Не менять.
Установите флажок В полный экран, чтобы программа автоматически масштабировала изображения в соответствии с установленным разрешением экрана.
Из открывающегося списка Режим выберите желаемое разрешение, с которым будут демонстрироваться изображения.
Нажмите кнопку ОК. Диалог Параметры будет закрыт.
Чтобы запустить слайд-шоу, необходимо выполнить следующие действия.
Из открывающегося списка, содержащего имена дисковых накопителей, выберите строку с именем диска, на котором находится папка с вашими фотографиями. В окне под открывающимся списком появится список папок, расположенных на нем.
Прокрутите при необходимости вертикальную полосу прокрутки, чтобы найти папку с фотографиями, и откройте ее двойным щелчком мыши.
Из открывающегося списка, находящегося под списком папок, выберите строку Фотографии. В окне, расположенном ниже, появится список графических файлов в формате JPEG, BMP, PCX или GIF.
Нажмите кнопку [image] Будет запущен показ слайдов, который в любой момент можно прервать щелчком мыши или клавишей Esc.

Если программа вам понравилась и удовлетворяет вашим требованиям, можно приступить к созданию фотоархива на компакт-диске. Следует отметить, что графические файлы, которые вы запишете на компакт-диск, могут быть любого размера и отсканированы с любым разрешением, что позволит в дальнейшем распечатывать ваши фотографии на принтере с максимально возможным качеством. Кроме того, можно сохранять файлы с фотографиями, присваивая им понятные вам имена. Желательно сначала создать отдельную папку для временного хранения файлов с отсканированными изображениями на жестком диске вашего компьютера, потом юбавить в эту папку файл PhotoSlider.exe. После чего выполните следующие действия.

Создайте любым текстовым редактором, например Блокнот (Notepad), файл со списком всех имен файлов, которые вы хотите включить в слайд-шоу. При желании к именам файлов можно добавить краткое описание изображения или фотографии, например, как показано на Рис. 6.54.

Puc. 6.54. Рабочее окно текстового редактора Блокнот (Notepad) с текстом

Сохраните созданный файл в папке с отсканированными изображениями с именем playlist.txt.
Создайте программой Блокнот (Notepad) еще один текстовый файл, содержащий две строки:

[Autorun]
open=PhotoSlider.exe \s playlist.txt

Сохраните созданный файл в папке с отсканированными изображениями с именем autorun.inf.
С помощью программ Adaptec Easy CD Creator 4.0 или WinOnCD 3.6 запишите все файлы из папки на компакт-диск.

По окончании записи установите записанный диск в устройство чтения компакт-дисков и закройте лоток дисковода. Через некоторое время, необходимое для раскрутки диска, на экране компьютера будут по очереди или случайно воспроизводиться фотографии, перечисленные в файле playlist.txt. Если этого не произошло, то выполните следующие действия.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Настройка * Панель управления (Settings * Control Panel). На экране появится окно Панель управления (Control Panel) (Рис. 6.55).

Puc. 6.55. Окно Панель управления (Control Panel)

Дважды щелкните мышью на строке Система (System). На экране появится диалог Свойства: Система (Properties: System) и перейдите на вкладку Устройства (Devices) (Рис. 6.56).

Puc. 6.56. Вкладка Устройства (Devices) диалога Свойства: Система (Properties: System)

Щелкните мышью на значке [image], расположенном рядом со строкой Устройства чтения компакт-дисков (CDROM), появится список подключенных дисководов для чтения компакт дисков.
Щелкните правой кнопкой мыши на строке с именем вашего устройства чтения компакт-дисков и нажмите кнопку Свойства (Properties). На экране появится диалог Свойства: (Properties) и перейдите на вкладку Настройка (Settings) (Рис. 6.57).
В группе элементов управления Параметры (Options) установите флажок Автоматическое распознавание диска (Auto insert notification).
Нажмите кнопку ОК. Диалог Свойства: (Properties:) будет закрыт.

Puc. 6.57, Вкладка Настройка (Settings) диалога Свойства:(Properties:)

Нажмите кнопку ОК в диалоге Свойства: Система (Properties: System), чтобы закрыть его. На экране появится диалог Изменение параметров системы (System Setting Change) (Рис. 6.58).

Нажмите кнопку Да (Yes), диалог закроется и произойдет перезагрузка системы.

Puc. 6.58. Диалог Изменение параметров системы (System Setting Change)

После перезагрузки операционной системы при установке созданного вами диска с автозапуском в устройство чтения компакт-дисков должна запуститься программа Фотослайдер, и начнется демонстрация слайдов.

В настоящее время вышла новая версия программы Фотослайдер 2.0. Она имеет англоязычный интерфейс и дополнительные параметры при запуске из командной строки. Кроме того, программа способна во время демонстрации слайдов проигрывать музыкальные фрагменты, записанные на компакт-диск в формате MIDI или WAV. Для этого необходимо в командной строке добавить ключ: /МNимя_файла, где N - тип проигрываемого файла (N = 1 - компакт-диск, N = 2 - файл MIDI или WAV-формата). К сожалению проиграть можно лишь один звуковой файл, и воспроизводиться он будет циклически. Программа Фотослайдер версии 2.0 не распространяется бесплатно, всю информацию о программе, ее цене и порядке регистрации можно получить на сайте разработчика по адресу:

http://www.chat.ru/~nadey/
В заключении рассмотрим еще один вариант создания слайд-шоу на компакт-диске.


Untitled Document

Знакомство 10. Создание слайд-шоу на VideoCD

Для создания слайд-шоу на VideoCD лучше всего использовать программу Adobe Premiere. С этой программой мы кратко знакомились в одной из предыдущих глав.

Процесс создания слайд-шоу похож на процесс создания видеоархива, который был описан ранее, с той лишь разницей, что вместо видеоклипов вы импортируете в программу Adobe Premiere файлы из вашего фотоальбома и размещаете их в нужной последовательности на монтажном столе в строке Видео 1 (Video 1).
При этом существует возможность задать длительность показа каждого фото в результирующем фильме. Затем экспортируете файлы со звуковым сопровождением и монтируете на монтажном столе, совмещая демонстрацию фотографий со звуковым сопровождением. Вы можете использовать различные эффекты (транзакции) смены изображений и звуковых фрагментов, можете вставить свои комментарии, записанные с микрофона, к любой фотографии, или наложить титры.

Все зависит от вашей фантазии и художественного вкуса. По окончании монтажа необходимо экспортировать готовый видеоклип в формате AVI или MPEG на жесткий диск, после чего записать получен ный файл на компакт-диск программой Adaptec Easy CD Creator 4.0 или WinOnCD 3.6 в формате VideoCD, как это было описано в предыдущих главах книги.

В заключении надо отметить, что владельцы современных видеокарт, например, ASUS V3800 TV In/Out, ASUS V6800 TV In/Out и др., имеющих функции ввода и вывода видеосигнала, могут смотреть созданные слайд-шоу и видеодиски на экране обычного телевизора.


Untitled Document

Рабочее oкнo программы Microsoft Power Point 2000

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выберите команду пускового меню Программы * Microsoft Power Point (Program * Microsoft Power Point). На экране появится рабочее окно программы Microsoft Power Point (Рис. 6.13).

Puc. 6.13. Рабочее окно программы Microsoft Power Point

Рабочее окно программы Microsoft Power Point также как и большинство программ, работающих по управлением операционной системы Windows 95/98/NT/2000, состоит из следующих элементов.

  • Заголовок окна - содержит название программы и открытого в настоящий момент проекта, в правой части заголовка расположены кнопки управления окном.
  • Основное меню - содержит названия групп команд, доступных программе. С помощью основного меню можно выполнить любую команду программы.
  • Панели инструментов - содержат кнопки, связанные с наиболее часто выполняемыми командами, и по вашему желанию могут быть расположены в любом месте рабочего окна или совсем скрыты.
  • Рабочая область - состоит из двух частей. Левая часть предназначена для просмотра структуры проекта, а правая - отображает слайд, который добавляется в проект. Под ней расположено поле ввода заметок, в которое вы можете ввести необходимые пояснения к слайду. Размеры и вид рабочей области и ее частей вы можете изменять по своему желанию.
  • Строка состояния - расположена в нижней части рабочего окна и отображает текущее состояние программы.

Добавление слайдов в npoeкm презентации и создание надписей

Основным элементом создаваемой презентации является слайд. Слайды могут содержать текстовую, графическую, звуковую, видеоинформацию, а также иметь кнопки и меню с гиперссылками для управления демонстрацией слайдов. Начать работу по составлению презентации или фотоальбома лучше всего с создания титульного слайда презентации и слайдов, содержащих различные меню.

Щелкните мышью в правой части рабочей области, на экране появится диалог Создание слайда (New Slide) (Рис. 6.14). Этот диалог предназначен для выбора макета слайда.

Puc. 6.14. Диалог Создание слайда (New Slide)
В окне Выберите автомакет (Choose in AutoLayout) выберите пиктограмму [image], при выборе схематичного изображения автомакета его название Титульный слайд (Title slide) отображается в рамке, расположенной в правой части диалога, и нажмите кнопку ОК. Диалог закроется, а в рабочую область программы будет добавлен макет слайда (Рис. 6.15).

Щелкните мышью на надписи Заголовок слайда (Click to add title), расположенном в области отображения макета слайда, и введите текст заголовка альбома, например, Фотоальбом.

Puc. 6.15. Рабочее окно программы Microsoft Power Point с макетом слайда

Щелкните мышью на надписи Подзаголовок слайда (Click to add subtitle) и введите текст подзаголовка, например, Семейный.

Вы можете произвольно изменить цвет и тип шрифта любой надписи. Для этого необходимо выделить мышью надпись, которую вы хотите изменить, и с помощью команды основного меню Формат * Шрифт (Format * Font) вызвать диалог Шрифт (Font) (Рис. 6.16).

Рис 6.16. Диалог Шрифт

Кроме того, с помощью кнопок панели инструментов Рисование (Picture) [image] можно сделать надписи объемными, добавить тень или применить оформление WordArt. Можно применить к надписи различные анимационные эффекты, которые будут выполнятся при демонстрации слайда на экране. Для этого выполните следующие действия.

Щелкните мышью на надписи Фотоальбом и щелкните правой кнопкой мыши. На экране появится контекстное меню для надписи (Рис. 6.17).
Выберите команду контекстного меню Настройка анимации (Custom animation), на экране появится диалог Настройка анимации (Custom animation) (Рис. 6.18).

Puc. 6.17. Контекстное меню для надписи

Puc. 6.18. Диалог Настройка анимации (Custom animation)

Выберите в списке Объекты для анимации (Check to animate slide objects) элемент слайда, к которому хотите применить анимационный эффект, а на вкладке Видоизменение (Effects) в группе элементов управления Выберите эффект и звук (Entry animation and sound) с помощью открывающихся списков укажите желаемый анимационный и сопровождающий его звуковой эффект.

Нажмите кнопку Просмотр (Preview), чтобы просмотреть выбранный вами эффект и звук в правой верхней части диалога.

Нажмите кнопку ОК, чтобы настройки анимации вступили в силу.

Использование готовых шаблонов презентации

Программа Microsoft Power Point 2000 содержит готовые шаблоны оформления для создания презентаций на различные темы. Чтобы воспользоваться готовым шаблоном и не создавать свой, выполните следующие действия.

Щелкните правой кнопкой мыши в любом месте области отображения макета слайда, на экране появится контекстное меню для макета слайда (Рис. 6.19).

Puc. 6.19. Контекстное меню для макета слайда

Выберите команду контекстного меню Применить шаблон оформления (Apply Design Template), на экране появится диалог Применить шаблон оформления (Apply Design Template) (Рис. 6.20).

Puc. 6.20. Диалог Применить шаблон оформления (Apply Design Template)

Из списка доступных шаблонов выберите строку Тетрадь.роt (Notebook.pot) и нажмите кнопку Применить (Apply). Диалог закроется, а в области просмотра слайда изображение изменится в соответствии с Рис. 6.21

Puc. 6.21. Вид рабочего окна программы Microsoft Power Point после применения шаблона Tempaдь.pot (Notebook.pot)

Создание слайда с содержанием презентации

Слайд оглавления содержит надписи с заголовком слайда и списком основных разделов альбома или презентации. В дальнейшем можно будет связать слайды, с которых начинаются разделы альбома, с конкретной строкой списка разделов, находящихся на слайде с оглавлением.

Выберите команду меню Вставка * Новый слайд (Insert * New slide). На экране появится диалог Создание слайда (New slide) (Рис. 6.14).
В списке Выберите автоформат (Choose in AutoLayout) щелкните мышью на пиктограмме [image] - маркированный список (Bulleted list) и нажмите кнопку ОК.
Щелкните мышью на надписи Заголовок слайда (Click to add title) и введите текст: Оглавление
Щелкните мышью на надписи Текст слайда (Click to add text) и введите текст:
Дети "Enter"
Родственники "Enter"
Друзья "Enter"
Слайд-шоу.

Вы можете добавить и другие разделы фотоальбома по вашему желанию. После того, как вы создали слайд-оглавление, можно перейти к добавлению слайдов с фотографиями и рисунками.

Создание слайдов с изображениями

Сначала создадим файл с заголовком раздела альбома и изображением, которое было заранее отсканировано и помещено в созданную папку Фотоальбом.
Создайте слайд, содержащий один только заголовок, с помощью пиктограммы [image] диалога Создание слайда (New slide) (Рис. 6.14)) и замените текст заголовка на название одного из разделов, например, Дети.

Выберите команду меню Вставка * Рисунок * Из файла (Insert * Picture * From file), на экране появится диалог Добавить рисунок (Insert Picture) (Рис. 6.22).

Puc. 6.22. Диалог Добавить рисунок (Insert Picture)

Из открывающегося списка Папка (Look in) выберите папку Фотоальбом, в которой находятся отсканированные фотографии.
Из списка файлов выберите строку, содержащую имя фотографии, которую вы хотите вставить в слайд, и нажмите кнопку Вставка (Insert). Фотография будет помещена в макет слайда.

Для изменения размеров добавленного изображения необходимо выполнить следующие действия.

Щелкните мышью на фотографии, чтобы выделить ее.
Установите указатель мыши в один из угловых квадратов. Нажмите левую кнопку мыши, и удерживая ее нажатой, перемещайте мышь до тех пор, пока изображение не примет желаемый размер.

Чтобы изменить местоположение фотографии на макете слайда, необходимо установить указатель мыши на изображение, нажать левую кнопку мыши, и удерживая ее нажатой, перенести изображение в нужное место макета слайда. Вы можете добавить к слайду надпись с кратким описанием изображения. Это можно сделать с помощью команды меню Вставка * Надпись (Insert * Text box). Затем необходимо указать мышью место на макете слайда, куда вы хотите поместить надпись и ввести текст с клавиатуры.

Если у вас нет заранее отсканированных изображений, то используя команду меню Вставка * Рисунок * Со сканера или камеры (Insert * Picture * From Scanner or Camera), вы можете вставить в слайд изображение непосредственно с цифровой камеры или сканера. При использовании этой команды меню первый раз, на экране появится диалог с информацией о том, что компонент не установлен, и с предложением установить его.

Нажмите кнопку Да, чтобы установить необходимые компоненты. После установки на экране появится диалог Вставка со сканера или камеры (Insert from scanner or camera) (Рис. 6.24).

Puc. 6.24. Диалог Вставка со сканера или камеры
(Insert from scanner or camera)

Из открывающегося списка Устройство (Device) выберите имя сканера или цифровой камеры, подключенной к вашему компьютеру, и нажмите кнопку Специальная вставка (Special Insert).

На экране появится рабочее окно программы, предназначенной для работы со сканером. После окончания сканирования окно сканирующей программы закроется, а отсканированное изображение появится на макете слайда. Описанным выше способом вы можете добавить любое количество слайдов, относящихся к каждому разделу, перечисленному в слайде с оглавлением. Вы можете давать каждому слайду свое оригинальное название, размещать на нем сразу несколько фотографий, снабжая их поясняющими надписями.

Добавление кнoпoк управления

Чтобы обеспечить переход к следующему слайду, вставим кнопки управления. Для этого выполните следующие действия.
Выберите команду меню Показ слайдов * Управляющие кнопки [image] (Slide Show * Action Buttons * [image].)
Установите курсор мыши в любое место макета слайда.

Нажмите клавишу "Shift" и держите ее нажатой, нажмите левую кнопку мыши, и не отпуская ее, перемещайте мышь до тех пор, пока создаваемая кнопка не примет желаемый размер. Клавиша "Shift" удерживается для того, чтобы размеры кнопки изменялись пропорционально. Отпустите левую кнопку мыши, на экране появится диалог Настройка действия (Action Settings) (Рис. 6.25).
Отпустите клавишу "Shift" и в группе элементов управления Действия по щелчку мыши (Action on click) из открывающегося списка Перейти по гиперссылке (Hyperlink to) выберите строку Следующий слайд (Next slide).

Puc. 6.25. Диалог Настройка действия (Action Settings)

Нажмите кнопку ОК, диалог Настройка действия (Action Settings) будет закрыт, а в области просмотра макета слайда появится созданная кнопка.

Подведите указатель мыши к созданной кнопке, нажмите левую кнопку мыши, и не отпуская ее, перетащите мышью изображение кнопки в нижний правый угол макета слайда.

Чтобы изменить цвет фона кнопки, выполните следующие действия.

Щелкните правой кнопкой мыши на изображении кнопки, на экране появится контекстное меню для кнопки (Рис. 6.26).

Puc. 6.26. Контекстное меню для кнопки

Выберите команду контекстного меню Формат автофигуры (Format AutoShape), на экране появится диалог Формат автофигуры (Format AutoShape) (Рис. 6.27).

Puc. 6.27. Диалог Формат автофигуры (Format AutoShape)

На вкладке Цвета и линии (Colors and Lines) в группе элементов управления Заливка (Fill) с помощью открывающегося списка цвет (Color) выберите коричневый цвет фона и установите флажок полупрозрачный (Semitrasporent). Можно предварительно посмотреть, какой будет вид кнопки с помощью кнопки Просмотр (Preview), расположенной в нижней части диалога.

Нажмите кнопку ОК, диалог закроется, а вид кнопки на макете слайда примет заданные параметры.
Добавьте кнопки [image] и [image] самостоятельно, расположив их в один ряд в следующем порядке: , [image], [image].
Кнопке [image] с помощью диалога Настройка действия (Action Settings) (Рис. 6.25) назначьте переход по гиперссылке Предыдущий слайд (Previous slide).
При настройке действия для кнопки [image] в диалоге Настройка действия (Action Settings) (Рис. 6.25) из открывающегося списка Перейти по гиперссылке (Hyperlink to) выберите строку Слайд (Slide), на экране появится диалог Гиперссылка на слайд (Hyperlink to Slide) (Рис. 6.28).

Puc. 6.28. Диалог Гиперссылка на слайд (Hyperlink to Slide)

В списке Слайд (Slide) выберите строку Оглавление и нажмите кнопку ОК. Диалог Гиперссылка на слайд (Hyperlink to Slide) закроется, а в открывающемся списке Перейти по гиперссылке (Hyperlink to) диалога Настройка действия (Action Settings) (Рис. 6.25) появится имя выбранного слайда.
Нажмите кнопку ОК в диалоге Настройка действия (Action Settings) (Рис. 6.25), чтобы закрыть его. Теперь при нажатии на кнопку [image] можно будет быстро перейти к слайду Оглавление. Чтобы не создавать управляющие кнопки каждый раз при создании слайда, вы можете копировать их, используя буфер обмена. Для этого выполните следующие действия.

Нажмите клавишу "Shift" и удерживая ее нажатой, по очереди щелкните мышью на каждой созданной кнопке в области просмотра макета слайда. Кнопки будут выделены белыми квадратами.
На панели инструментов Стандартная(Standard) нажмите кнопку [image] Выделенные кнопки будут скопированы в буфер обмена. Перейдите к просмотру макета другого слайда, используя область отображения структуры презентации, и нажмите кнопку [image].

Кнопки из буфера обмена будут вставлены в макет выбранного слайда, причем все назначенные кнопкам действия останутся прежними.
Следует отметить, что программы, входящие в пакет Microsoft Office 2000, имеют возможность хранить в буфере обмена до 12 различных объектов. Чтобы использовать эту возможность, необходимо вызвать на экран панель инструментов Буфер обмена (Clipboard). Для этого выполните следующие действия.

Puc. 6.29. Контекстное меню для панели инструментов

Щелкните правой кнопкой мыши в любом месте любой панели инструментов, на экране появится контекстное меню для панели инструментов (Рис. 6.29).

Выберите команду контекстного меню Буфер обмена (Clipboard), на экране появится панель инструментов Буфер обмена (1 из 12) (Clipboard (1 to 12)) (Рис. 6.30).

Puc. 6.30. Панель инструментов Буфер обмена (1 из 12) (Clipboard (1 to 12))

Установите указатель мыши на заголовок панели, нажмите левую кнопку мыши, и удерживая ее нажатой, перетащите панель в удобное для работы место. Теперь, каждый раз нажимая кнопку [image] панели инструментов Буфер обмена (Clipboard), вы можете занести в буфер до 12 различных объектов.


Untitled Document

Создание гиперссылок

Для того, чтобы обеспечить переход от слайда с оглавлением к слайду начала раздела фотоальбома, например, Дети, выполните следующие действия.

В области просмотра структуры презентации, расположенной в левой части рабочего окна программы Microsoft Power Point 2000, выберите слайд Оглавление. В правой части будет отображен макет выбранного слайда.
Щелкните мышью на строке, содержащей слово Дети, и нажмите правую кнопку мыши, на экране появится контекстное меню для текста (Рис. 6.31).

Puc. 6.31. Контекстное меню для текста

Выберите команду контекстного меню Гиперссылка (Hyperlink), на экране появится диалог Добавление гиперссылки (Insert Hyperlink) (Рис. 6.32).
В группе элементов управления Связать с: (Link to) нажмите кнопку 2 местом в этом документе (Place in This Document), в окне Выберите место в документе (Select a place in this document) в виде дерева появится список слайдов и произвольных показов, созданных вами.

Puc. 6.32. Диалог Добавление гиперссылки (Insert Hyperlink)

В окне Выберите место в документе (Select a place in this document) укажите мышью строку Дети и нажмите кнопку ОК. Диалог закроется, а текст Дети в области просмотра слайда станет подчеркнутым. Таким же способом создаются гиперссылки на другие разделы фотоальбома, перечисленные в оглавлении.

Создание произвольного показa слайдов

После того, как вы создадите несколько разделов и слайдов с фотографиями, можно будет создать произвольный показ слайдов. Для этого выполните следующие действия.

Выберите команду меню Показ слайдов * Произвольный показ (Slide Show * Custom Shows). На экране появится диалог Произвольный показ (Custom Shows) (Рис. 6.33).

Puc. 6.33. Диалог Произвольный показ (Custom Shows)

Нажмите кнопку Создать (New). На экране появится диалог Задание произвольного показа (Define Custom Show) (Рис. 6.34).

Puc. 6.34. Диалог Задание произвольного показа (Define Custom Show)

В окне диалога Слайды презентации (Slides in presentation) последовательно выбирайте слайды, которые хотите включить в произвольный показ, сопровождая выбор нажатием кнопки Добавить (Add). В окне Слайды произвольного показа (Slides in custom show) будет сформирован список выбранных вами слайдов. Выделив в окне Слайды произвольного показа (Slides in custom show) название слайда и нажимая кнопки [image] и [image], можно изменить порядок появления слайдов при произвольном показе.

Введите в поле ввода Имя произвольного показа (Slide show name) название слайд-шоу и нажмите кнопку ОК. Диалог закроется, а в диалоге Произвольный показ (Custom Shows) (Рис. 6.33) появится имя созданного показа.
Нажмите кнопку Закрыть (Close), диалог Произвольный показ (Custom Shows) будет закрыт.

Теперь вы можете создать гиперссылку для текстовой строки Слайд-шоу слайда Оглавление, чтобы иметь возможность запускать произвольный просмотр слайдов щелчком мыши на этой строке. При создании гиперссылки на произвольный показ слайдов нужно в диалоге Добавление гиперссылки (Insert Hyperlink) (Рис. 6.32) установить флажок Показать и вернуться (Show and Return), чтобы после демонстрации слайдов, включенных в произвольный показ, на экран снова был выведен слайд Оглавление.

Hacmрoйкa режима смены слайдов

Слайды, входящие в созданную вами презентацию, могут сменяться через определенные промежутки времени или вручную по щелчку мыши, при этом сама смена слайдов может сопровождаться различными анимационными и звуковыми эффектами. Например, зададим титульному слайду время показа, равное 10 секундам. Для этого выполните следующие действия.

Щелкните мышью на слайде Фотоальбом в области просмотра структуры презентации и выберите команду меню Показ слайдов * Смена слайдов (Slide Show * Slide Transition). На экране появится диалог Смена слайдов (Slide Transition) (Рис. 6.35).
В группе элементов управления Эффект (Effect) из открывающегося списка выберите строку Открывание влево (Uncover left).
В группе элементов управления Продвижение (Advance) установите флажки по щелчку (On mouse click) и автоматически после (Automatically after).

Puc. 6.35. Диалог Смена слайдов (Slide Transition)

Введите в поле ввода текст 00:10, т.е. 10 секунд.
В группе элементов управления Звук (Sound) из открывающегося списка выберите подходящий для смены слайда звук.
Нажмите кнопку Применить (Apply), диалог закроется, а изменения вступят в силу.

Таким способом можно назначить режим смены слайдов для каждого слайда отдельно. При просмотре слайд-шоу желательно, чтобы слайды менялись автоматически, поэтому, чтобы не задавать каждому слайду свой режим смены, нужно, удерживая нажатой клавишу "Shift" , щелкнуть мышью на первом и последнем слайде произвольного показа в области просмотра структуры презентации, чтобы выделить их. После этого командой меню Показ слайдов * Смена слайдов (Slide Show * Slide Transition) надо вызвать диалог Смена слайдов (Slide Transition) (Рис. 6.35) и указать режим смены, как это было описано выше. После нажатия кнопки Применить (Apply) все выделенные слайды в области просмотра структуры презентации будут иметь одинаковый режим смены.

Работа со звуком

Программа Microsoft Power Point 2000 позволяет вставлять в демонстрируемые слайды фоновые звуковые фрагменты, которые могут воспроизводиться автоматически или вручную по нажатию кнопки. Вставим в слайд Оглавление звуковой фрагмент, который был заранее записан и сохранен в папке Фотоальбом.

Щелкните мышью на строке Оглавление в области просмотра структуры макета презентации.

Рис 6.36. Диалог Вставка звука

Выберите команду меню Вставка * Фильмы и звук * Звук из файла (Insert * Movies and Sounds * Sound from file). На экране появится диалог Вставка звука (Insert Sound) (Рис. 6.36).
Из открывающегося списка Папка (Look in) выберите диск С:, в окне диалога появится список папок, хранящихся на выбранном диске.
Двойным щелчком мыши на папке Фотоальбом откройте ее, в окне диалога отобразятся все звуковые файлы, содержащиеся в ней.
Выберите в окне диалога звуковой файл, который хотите вставить в слайд, и нажмите кнопку ОК. На экране появится диалог для определения режима воспроизведения звукового файла (Рис. 6.37).

Puc. 6.37. Диалог для определения режима воспроизведения звукового файла

Если вы хотите, чтобы звук начал воспроизводиться одновременно с появлением на экране слайда, то нажмите кнопку Да (Yes). При нажатии кнопки Нет (No) звук будет воспроизводиться после нажатия на кнопку [image] которая будет помещена на макет слайда после выбора режима воспроизведения. Кроме того, в программе имеется возможность записи звуковых комментариев к слайдам непосредственно с микрофона, подключенного к звуковой карте. Качество записанного таким образом звука в основном зависит от типа микрофона и параметров звуковой карты, установленной на вашем компьютере. Для получения качественного звука мы рекомендуем использовать дорогой эстрадный микрофон, подключенный к предварительному усилителю с малым уровнем собственных шумов. С выхода предварительного усилителя сигнал надо подать на линейный вход звуковой платы. При использовании дешевых микрофонов, подключенных к микрофонному входу звуковой платы, качество записанного звука будет низким, может появиться посторонний шум и фон.

Сохранение npoeкma презентации на жестком дucкe

В любой момент времени вы можете прервать работу с программой, предварительно сохранив результаты своей работы на жестком диске. Чтобы хранить неоконченный проект выполните следующие действия.

Выберите команду меню Файл * Сохранить как (File * Save as), на экране появится диалог Сохранение документа (Save as) (Рис. 6.38).

Puc. 6.38. Диалог Сохранение документа (Save as)

Из открывающегося списка Папка (Folder) выберите диск С:, в окне диалога появится список папок, хранящихся на диске.
Двойным щелчком мыши на папке Фотоальбом откройте ее.
В поле ввода Имя файла (File name) введите текст Фотоальбом, а из открывающегося списка Тип файла (Save as type) выберите Презентация (*.ppt) (Presentation (*.ppt)), и нажмите кнопку Сохранить (Save).

Диалог закроется, а проект презентации будет сохранен в папке Фотоальбом. После чего можно закрыть рабочее окно программы с помощью кнопки [image], расположенной в правой части заголовка окна. Для того, чтобы продолжить работу по созданию презентации, достаточно открыть с помощью программы Проводник (Explorer) папку Фотоальбом и двойным щелчком мыши на файле Фотоальбом.ppt открыть проект презентации. Программа Microsoft PowerPoint 2000 запустится автоматически.

Предварительный просмотр созданной презентации

Во время работы над проектом презентации вы можете в любой момент просмотреть результат внесенных в проект изменений, переключив программу в режим предварительного просмотра. Для этого выполните следующие действия.

Выберите команду меню Вид * Показ слайдов (View * Slide show), на экране появится титульный слайд Фотоальбом (Рис. 6.39).
Через 10 секунд титульный слайд сменится слайдом Оглавление, который будет сопровождаться проигрыванием звукового файла.

Puc. 6.39. Титульный слайд Фотоальбом

Подведите указатель мыши к строке Слайд-шоу слайда Оглавление, щелкните левой кнопкой мыши. Будет запущено слайд-шоу из слайдов, включенных в произвольный показ.
После демонстрации всех слайдов произвольного показа на экран снова будет выведен слайд Оглавление, и вы сможете проверить работу других ссылок.
Нажмите клавишу ESC, чтобы выйти из режима предварительного просмотра. На экране появится рабочее окно программы Microsoft Power Point 2000.

Мы рассмотрели основные возможности программы Microsoft PowerPoint 2000. Надо отметить, что программа предоставляет достаточно средств для создания презентаций и слайд-шоу, вы можете сами создавать оформление своих проектов, включать в презентации собственные звуковые и видео файлы. Окончательный вариант презентации целиком зависит от вашей фантазии и художественного вкуса.

Сохранение готовой презентации на CD-ROM

Сохранение готовой презентации на CD-ROM-диске возможно четырьмя способами. Прежде чем сохранять свою презентацию, прочитайте данный раздел до конца, чтобы выбрать именно тот способ сохранения, который вам больше подходит.

Первый способ - это полностью скопировать каталог с проектом презентации на CD-ROM с помощью программ Adaptec Easy CD Creator 4.0 или WinOnCD 3.6. В этом случае вы получите возможность впоследствии распечатать отдельные фотографии из вашего альбома с помощью программы любого графического редактора. Дело в том, что программа Microsoft PowerPoint 2000 позволяет распечатывать слайды целиком вместе с оформлением, кнопками управления и прочими графическими элементами слайда и не дает возможности напечатать одну только фотографию, вставленную в слайд. Кроме того, при таком варианте сохранения презентации вы можете быть на сто процентов уверенны, что презентация будет воспроизведена именно в том виде, в котором вы ее создали, без каких-либо потерь и изменений. Однако у такого способа есть один недостаток - сохраненную таким образом презентацию нельзя будет воспроизводить на компьютере, на котором не установлена программа Microsoft PowerPoint 2000.

Второй способ сохранения презентации - это сохранение ее как Web-страницы. Чтобы сохранить таким образом презентацию, необходимо выполнить следующие действия.

Выберите команду меню Файл * Сохранить как (File * Save as). На экране появится диалог Сохранение документа (Save as) (Рис. 6.38).
Из открывающегося списка Папка (Save in) выберите диск С:, в окне диалога появится список папок, хранящихся на диске.
Двойным щелчком мыши на папке Фотоальбом откройте ее.
Из открывающегося списка Тип файла (Save as type) выберите строку Web-страница (*.htm; *.html) (Web Page (*.htm; *.html)). Вид диалога Сохранение документа (Save as) изменится в соответствии с Рис. 6.40.

Puc. 6.40. Вид диалога Сохранение документа (Save as) при сохранении презентации как Web-страницы

Введите в поле ввода Имя файла (File name) название презентации, например Фотоальбом, и нажмите кнопку Сохранить (Save).

Диалог закроется, а в папке Фотоальбом на диске С: будет создан файл с именем Фотоальбом.htm и папка с именем Фотоальбом.files.
Именно эти, созданные при сохранении презентации, как Web-страницы, файл Фотоальбом.htm и папку Фотоальбом.files нужно будет перенести на CD-ROM, используя описанные в предыдущих главах программы Adaptec Easy CD Creator 4.0 или WinOnCD 3.6.

Однако при таком способе сохранения презентации вы можете потерять часть элементов анимации и звукового сопровождения, кроме того, будет невозможно распечатать фотографии альбома с хорошим качеством. Но преимуществом такого способа сохранения является то, что он дает возможность запуска презентации на любом компьютере, на котором установлен любой браузер - программа для просмотра Web-страниц, например, Internet Explorer любой версии. Для запуска просмотра презентации, сохраненной как Web-страница, достаточно найти с помощью программы Проводник (Explorer) на компакт-диске файл Фотоальбoм.htm и двойным щелчком мыши открыть его. На экране появится рабочее окно программы Internet Explorer с презентацией (Рис. 6.41).

Puc. 6.41. Рабочее окно программы Internet Explorer с презентацией

С помощью кнопки [image], расположенной в нижней правой части рабочего окна программы Internet Explorer, можно запустить просмотр презентации в полноэкранном режиме.

Третий способ сохранения презентации - это сохранение ее в упакованном виде. При таком способе сохранения вы сможете воспроизвести свою презентацию на любом компьютере, даже с не установленными программами Microsoft PowerPoint 2000 и Internet Explorer, потому что при упаковке презентации в нее можно включить средство просмотра. Для сохранения презентации таким способом необходимо выполнить следующие действия. Перед началом упаковки презентации для демонстрации на другом компьютере необходимо переименовать все связанные файлы (рисунки, изображения, звуковые файлы), которые вы включили в презентацию, и саму презентацию таким образом, чтобы их имена не содержали символы национальных языков.

Выберите команду меню Файл * Упаковать (File * Pack and Go), если вы до этого не пользовались упаковкой, то на экране появится диалог с предложением установить этот компонент.
Нажмите кнопку Да (Yes). Произойдет установка недостающего компонента, после чего на экране появится первый диалог Мастер упаковки (Pack and Go Wizard) (Рис. 6.43).

Puc. 6.43. Первый диалог Мастера упаковки (Pack and Go Wizard)

Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера (Рис. 6.44).

Установите флажок Активную презентацию (Active presentation), если презентация уже открыта программой Microsoft PowerPoint 2000, и нажмите кнопку Далее (Next). На экране появится следующий диалог мастера (Рис. 6.45).

Puc. 6.45. Третий диалог Мастера упаковки (Pack and Go Wizard)

Установите переключатель Куда вы хотите записать презентацию? (Which drive should the file copied to) в положение Выбрать назначение (Choose destination) и введите в поле ввода путь к папке, в которую будет записана упакованная презентация, например, C:\Windows\Temp. Такая папка обязательно должна существовать на диске или быть заранее подготовлена и иметь имя, не содержащее символы национальных языков.
Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера (Рис. 6.46).

Puc. 6.46. Четвертый диалог Мастера упаковки (Pack and Go Wizard)

Установите флажки Включить связанные файлы (Include linked files) и Внедрить шрифты TrueType (Embed TrueType Fonts). Это необходимо для того, чтобы ваша презентация воспроизводилась на другом компьютере точно также, как на вашем, независимо от шрифтов и связанных файлов, имеющихся на другом компьютере.

Нажмите кнопку Далее (Next). На экране появится следующий диалог мастера (Рис. 6.47).

Puc. 6.47. Пятый диалог Мастера упаковки (Pack and Go Wizard)

Установите переключатель в положение Включить PowerPoint Viewer (Viewer for Windows 95 or NT) для того, чтобы упакованная презентация содержала средство просмотра и могла быть воспроизведена компьютером, на котором не установлена программа Microsoft PowerPoint 2000.
Нажмите кнопку Далее (Next). На экране появится заключительный диалог мастера упаковки (Рис. 6.48).

Puc. 6.48. Последний диалог Мастера упаковки (Pack and Go Wizard)

Нажмите кнопку Готово (Finish). На экране появится окно Состояние упаковки (Pack and Go Status) (Рис. 6.49), в котором будет отражаться выполнение упаковки презентации.

Puc. 6.49. Окно Состояние упаковки (Pack and Go Status)

Если вы забыли переименовать какой-либо из связанных файлов или упаковываемую презентацию, то на экране появится диалог об обнаружении файла с именем, содержащем символы национальных языков (Рис. 6.50).

Puc. 6.50. Диалог об обнаружении файла с именем, содержащем символы национальных языков

Нажмите кнопку ОК, переименуйте указанный в диалоге файл и снова запустите упаковку презентации.

Если все сделано правильно, то по завершении упаковки на экране появится диалог об успешном завершении упаковки (Рис. 6.51).

Puc. 6.51. Диалог об успешном завершении упаковки

В папке, которую вы выбрали для упаковки презентации, будут созданы два файла pngsetup.exe и pres0.ppz, которые вы можете записать на CD-ROM программами Adaptec Easy CD Creator 4.0 или WinOnCD 3,6. Вы также можете создать и записать на компакт-диск файл автозапуска программы pngsetup.exe. Для этого нужно создать любым текстовым редактором файл, состоящий из двух строк:

[Autorun]
open=pngsetup.exe

и сохранить его с именем autorun.inf, а затем записать в корневой каталог компакт-диска вместе с файлами pngsetup.exe и pres0.ppz. При установке такого диска в дисковод любого компьютера будет автоматически запущена программа установки презентации pngsetup.exe, которая распакует презентацию в выбранный вами каталог, после чего запустит программу PowerPoint Viewer для просмотра презентации.
Такой способ сохранения презентации экономит место на компакт-диске, т.к. презентация сжимается мастером упаковки, но имеет ряд недостатков. Во-первых, при распаковке на другом компьютере может потребоваться достаточно много свободного дискового пространства, во-вторых, вы не сможете распечатать фотографии, включенные в презентацию на принтере с хорошим качеством, и в-третьих, вполне возможна потеря части функциональных возможностей презентации.
И, наконец, четвертый способ записи презентации на компакт-диск. Он вытекает из предыдущего, т.е. вы сначала упаковываете презентацию так, как это было описано выше, а затем, запустив программу pngsetup.exe, распаковываете ее в отдельную папку. После чего добавляете в эту папку файл autorun.inf, состоящий из двух строк:

[Autorun]
ореn=РРVIЕW32.ЕХЕ\имя_файла_презентации.ррt

и записываете все содержимое папки на CD-ROM. Этот способ позволит воспроизводить презентацию на другом компьютере непосредственно с компакт-диска, не занимая место на жестком диске. Чтобы иметь возможность распечатать изображения на принтере с хорошим качеством, имеет смысл записать на компакт-диск исходные изображения в отдельной папке. Мы рассказали о способах сохранения презентации на компакт-диске, описали их достоинства и недостатки, но окончательно выбор способа хранения созданной вами презентации полностью остается за вами.

В заключении следует отметить, что с помощью программы Microsoft PowerPoint 2000 вы создаете не просто слайд-шоу, а мультимедийное приложение, т.к. презентация, кроме простого перелистывания слайдов, позволяет вставлять текст и различные элементы управления. Для простого показа сладов есть более простые программы, например Фотослайдер 1.3.


Untitled Document

ГЛАВА 7. Зачем нам дucк кaрaoкe и кaк его сделать?

Караоке - это звучащая музыка и "бегущий" на экране текст песен с подсветкой слога или части слова, которую надо петь в данный момент (Рис. 7.1).

Puc. 7.1. Караоке

Существуют специальные устройства, называемые плеерами караоке, которые подключаются к телевизору и служат для воспроизведения компакт-дисков с записанными файлами караоке. При воспроизведении караоке можно изменять фоновую картинку, размер, цвет и другие характеристики текста песен, темп и тональность музыки. Специальный караоке-диск содержит около 2 000 песен. Основу записанных на такой диск песен составляет музыка в формате MIDI-файлов. В данной главе мы расскажем, как создать диск с музыкой и "бегущим" текстом, который можно проигрывать на компьютере. Кроме этого, мы рассмотрим, как еще можно создать диски с музыкой любимых песен, тексты которых можно раздать гостям в напечатанном виде.

Следует отметить, что данная короткая обзорная глава является лишь иллюстрацией того, как можно использовать ваше устройство записи компакт-дисков, но не содержит описаний новых программ для создания самих дисков караоке. По сути, все, что написано в этой главе, в большей мере посвящено содержанию дисков, а не процессу их создания.

Существуют специальные программы - плееры караоке файлов, одну из них вы можете бесплатно загрузить на сайте www.karaoke.ru. На этом же сайте вы можете найти множество готовых файлов караоке, а также программу, которая позволяет создавать караоке самому. Файлы караоке имеют расширение *.KAR, и их можно найти и на других сайтах Интернета. Кроме этого, для записи и воспроизведения караоке существуют и другие форматы файлов и программы, которые мы в книге рассматривать не будем. Формат *.KAR, по сути, представляет собой формат *.МID, в который включен еще и текст. Вы можете переименовать файл, изменив расширение .KAR на .MID, и слушать музыку с помощью любой программы проигрывания MIDI-файлов.


Untitled Document

Знакомство 1. Проигрывание готовых файлов кapaoкe

Сейчас мы познакомимся с программой Karaoke Player, которую можно бесплатно загрузить с сайта www.karaoke.ru, раздел Soft. Достоинством этой небольшой программы является то, что она допускает настройку практически всех элементов караоке, вплоть до изменения внешнего вида самого плеера караоке; после установки на жесткий диск ее можно переписать на CD-ROM и запускать оттуда. Последнее свойство программы Karaoke Player очень удобно для записи ее вместе с файлами караоке на компакт-диск и автоматического запуска с помощью файла автозапуска. Но об этом чуть позже, а сейчас мы познакомимся с кнопками управления программы Karaoke Player и ее основными возможностями.

Перепишите программу Karaoke Player с сайта www.karaoke.ru.
На той же самой странице Интернета, где находится ссылка для загрузки программы Karaoke Player, есть ее небольшое описание.
Распакуйте полученный с сайта файл karaoke.zip, в котором находятся файлы Setup.exe и readme.txt, во временную папку на жестком диске.
Запустите на выполнение файл Setup.exe для установки программы Karaoke Player.
В процессе установки программы Karaoke Player следуйте инструкциям мастера установки.

По окончании установки на экране появится диалог с вопросом о том, хотите ли вы зарегистрировать программу (Рис. 7.2).

Рис 7.2. Диалог о регистрации программы

Рис 7.3.Диалог с напоминанием о регистрации программы

Нажмите кнопку No (Нет). Диалог Confirm (Подтвердите) исчезнет с экрана, программа Karaoke Player запустится и начнет проигрывать караоке.
Время от времени на экране будет появляться диалог с напоминанием о том, что ваша версия программы не зарегистрирована (Рис. 7.3).
При появлении такого диалога нажмите кнопку Yes (Да), и он исчезнет с экрана.
Чтобы диалог с напоминанием о регистрации не досаждал вам своим появлением, программу необходимо зарегистрировать. Для граждан России регистрация бесплатная и осуществляется следующим образом.
Щелкните правой кнопкой мыши на любой части окна караоке-проигрывателя. На экране появится контекстное меню для рабочего окна программы Karaoke Player.

Выберите из контекстного меню команду Preferences (Параметры). На экране появится диалог (Свойства) (Рис. 7.5).

Puc. 7.5. Диалог Properties (Свойства)

Нажмите кнопку register NOW! (Зарегистрируйте сейчас!). На экране появится диалог Registration (Регистрация) (Рис. 7.6).

В поле ввода Enter your key (Введите ваш ключ) введите с клавиатуры КАРАОКЕ ПО-РУССКИ заглавными буквами и нажмите кнопку ОК. Диалог Registration (Регистрация) исчезнет с экрана.

Puc. 7.6. Диалог Registration (Регистрация)

Нажмите кнопку ОК в диалоге Properties (Свойства). Диалог Properties (Свойства) также закроется.
Программа зарегистрирована, и диалог с напоминанием о регистрации больше не будет вам досаждать. Познакомимся с рабочим окном программы Karaoke Player (Рис. 7.7).

Puc. 7.7. Рабочее окно программы Karaoke Player

Справа от надписи Temp (Темп) расположены кнопки [image] и [image] для повышения и понижения темпа проигрывания караоке. Справа от надписи Tone (Тон) также расположены кнопки [image] и [image] Для повышения и понижения тона проигрываемого караоке. Кнопка [image] предназначена для выбора предыдущей мелодии из списка песен. О формировании списка песен рассказывается чуть позже.
Кнопка [image] предназначена для продолжения воспроизведения мелодии, которая была остановлена с помощью кнопки [image].
Кнопка [image] предназначена для приостановки воспроизведения текущей мелодии.
Кнопка [image] предназначена для прекращения воспроизведения мелодии.
Кнопка [image] предназначена для выбора следующей мелодии из списка песен.
Кнопка [image] предназначена для выбора и воспроизведения файла караоке.
Если задержать указатель мыши на какой-либо из кнопок, то под ней появляется подсказка о ее назначении. Следующие пять кнопок могут быть в нажатом или отжатом состояниях.

При нажатой кнопке Повтор списка (Repeat) воспроизведение списка песен повторяется с начала, если достигнут конец списка.
При нажатой кнопке Перемешать список (Shuffle) мелодии проигрываются не подряд по списку песен, а выбираются из списка случайно. При этом уже проигранные мелодии второй раз из списка не выбираются.
Кнопка Мелодию включить/выключить (Melody On/Off) позволяет отключать воспроизведение мелодии в караоке и наблюдать только за текстом, бегущим на экране. С ее же помощью можно возобновить воспроизведение мелодии снова.
При нажатой кнопке Показать слова (Show Words) на экране отображается окно с текстом проигрываемой мелодии (Рис. 7.1).
При нажатой кнопке Показать список песен (Play List) на экране отображается окно Play list (Список песен) (Рис. 7.8).

Puc. 7.8. Окно Play list (Список песен)

Списки песен хранятся в файлах с расширением .lst. Один список песен с именем SongList.lst загружается по умолчанию при запуске программы Karaoke Player. В загруженный список песен добавляются имена файлов всех проигранных на плеере мелодий.

Чтобы добавить файл в список песен, щелкните правой кнопкой мыши на окне Play list (Список песен). На экране появится контекстное меню окна Play list (Список песен) (Рис. 7.9).
Выберите из контекстного меню команду Open * Open file (Открыть * Открыть файл) и в стандартном диалоге открытия файла выберите файл караоке или MIDI. Выбранный файл добавится в список песен и начнет проигрываться.

Puc. 7.9. Контекстное меню окна Play list (Список песен)

Если вы выберете команду контекстного меню Open * Open dir (Открыть * Открыть папку), то в список песен добавятся все файлы караоке и MIDI, находящиеся в выбранной вами папке. При выборе команды контекстного меню Open * Open list (Открыть * Открыть список) можно открыть сохраненный ранее список песен. Чтобы удалить песню из списка, сначала нужно выделить его мышью, а затем щелкнуть правой кнопкой мыши на окне Play list (Список песен) и выбрать из контекстного меню команду Delete (Удалить). Удалить все песни из списка можно командой контекстного меню Clear (Очистить). Чтобы загрузить другой список песен, надо щелкнуть правой кнопкой мыши на окне Play list (Список песен), выбрать из контекстного меню команду Open * Open list (Открыть * Открыть список) и в стандартном диалоге Open (Открыть) выбрать файл с требуемым списком песен. Текущий список песен можно сохранить на диске под другим именем, выбрав команду контекстного меню Save * Save list (Сохранить * Сохранить список). Список песен можно также упорядочить по алфавиту или случайным образом, выбрав команду контекстного меню Sort * by Title (Отсортировать * По имени) или команду Sort * Random (Отсортировать * Случайно) соответственно.

Puc. 7.10. Контекстное меню окна караоке

Последние два пункта контекстного меню окна Play list (Список песен) относятся к окну, в котором отображается текст песен и фоновая картинка, т.е. само караоке. Но у окна караоке (Рис. 7.1) есть собственное контекстное меню, которое появляется при щелчке правой кнопкой мыши на любой части окна караоке (Рис. 7.10). С помощью команд этого контекстного меню можно управлять размером окна, в котором отображается караоке, выбирать для него фоновую картинку, а также размер, цвет и другие атрибуты шрифта.

При выборе команды контекстного меню Full Screen (Полный экран) окно караоке будет разуто на весь экран, а при выборе команды Full/2 Screen (Пол-экрана) иные размеры окна караоке будут вдвое меньше, т.е. окно караоке по площади будет занимать четверть всего экрана. При выборе команды контекстного меню BackGround (Фон) можно установить цвет фона окна караоке. Это будет цвет окна при отсутствии картинки.
Фон выбирается в стандартном диалоге Color (Цвет). В том же стандартном диалоге Color (Цвет) можно установить цвет закрашиваемой части текста, если выбрать команду контекстного меню Light Font (Светлый шрифт). Сам шрифт, его размер, начертание, цвет незакрашенной части и т.п. устанавливаются в стандартном диалоге Font (Шрифт) при выборе команды контекстного меню Default Font (Шрифт по умолчанию).

По команде контекстного меню Set Picture (Установить картинку) можно выбрать графический файл с картинкой, на фоне которой будет отображаться текст песни. Файл выбирается в стандартном диалоге Open (Открыть). Вы можете использовать или свои собственные картинки, или выбирать уже готовые из папки Picture. Эта папка находится в той папке, которую вы выбрали для программы Karaoke Player при ее установке. Можно отдельно сохранить текст песни в текстовом файле, если выбрать команду контекстного меню Save Lyrics to file (Сохранить стихи в файле).
Интересной особенностью программы Karaoke Player является то, что внешний вид ее рабочего окна, форма, цвет и расположение кнопок управления можно изменять, как бы надевая новый "наряд" на рабочее окно. Это осуществляется при выборе команды Skins (Одежки) контекстного меню, которое появляется при щелчке правой кнопкой мыши на любой части рабочего окна программы Karaoke Player (Рис. 7.4).
Вы можете выбирать уже готовые "одежки" из папки Skins, которая находится в той папке, которую вы выбрали для программы Karaoke Player при ее установке. Можно добавить новые "одежки" для программы Karaoke Player, переписав их из Интернета по адресу www.karaoke.ru, раздел Soft. Чтобы воспользоваться новыми "одежками", необходимо распаковать архивы, содержащие их, в папку Skins.

Чтобы изменить внешний вид рабочего окна программы Karaoke Player, щелкните правой кнопкой мыши на любой части окна караоке-проигрывателя. На экране появится контекстное меню для рабочего окна программы Karaoke Player (Рис. 7.4).

Выберите из контекстного меню команду Skins (Одежки). На экране появится окно Select Skin (Выберите одежку) (Рис. 7.11).
Для выбора новой "одежки" дважды щелкните мышью на ее имени в списке. Внешний вид рабочего окна программы Karaoke Player изменится.

Puc. 7.11. Окно Select Skin (Выберите одежку)

Закройте окно Select Skin (Выберите одежку), нажав кнопку [image] в ее заголовке.

Можно установить количество строк текста в окне караоке, характер их изменения, смены картинок и другие параметры программы Karaoke Player. Чтобы изменить параметры программы Karaoke Player, щелкните правой кнопкой мыши на любой части окна караоке-проигрывателя. На экране появится контекстное меню для рабочего окна программы Karaoke Player (Рис. 7.4).

Выберите из контекстного меню команду Preferences (Параметры). На экране появится диалог Properties (Свойства), но теперь уже без упоминания о том, что программа не зарегистрирована (Рис. 7.12).

Рис 7.12. Диалог Properties (Свойства)

В диалоге Properties (Свойства) выберите вкладку Properties (Свойства) (Рис. 7.13).

Рис 7.13. Вкладка Properties (Свойства) диалога Properties(Свойства)

Если установить флажок Change string after selection (Менять строку после выбора), то как только строка будет пропета, на ее месте будет появляться новая. При таком режиме целесообразно установить счетчик Selected string's count (Счетчик выбранных строк) в 1. Иначе еще не пропетые строки будут появляться на экране выше уже пропетых, и можно запутаться.

В поле со счетчиком Visible string's count (Счетчик видимых строк) устанавливается число строк, которые одновременно отображаются на экране. Рекомендуется устанавливать его на единицу больше, чем счетчик Selected string's count (Счетчик выбранных строк).

При установке флажка Show line (Показать линию) в окне караоке показывается линия под выделяемыми строками. Например, если в поле со счетчиком Visible string's count (Счетчик видимых строк) установлено 5 строк, а в поле со счетчиком Selected string's count (Счетчик выбранных строк) установлено 3 строки, то обновление экрана будет происходить после засвечивания 3-х строк. Чтобы было видно, когда же будет обновление, эти 3 строки отделяются от оставшихся 2-х горизонтальной линией.

Можно установить флажок Delete from playlist after playing (Удалять из списка песен после проигрывания) для того, чтобы не повторять проигранные песни из списка.

При установке переключателя Without picture (Без картинки) слова будут отображаться в пустом окне, а при установке переключателя Load static picture from directory (Загрузить статическую картинку из каталога) для каждой песни в окно караоке загружается картинка, которая не меняется в течение всей песни. Картинка выбирается случайным образом.

Если же установить переключатель Change pictures after (Менять картинки после), то картинки будут меняться после выбора того количества строк, которое указано в поле со счетчиком selected strings (Выбранных строк). В текстовом поле в нижней части диалога указывается папка, из которой выбираются картинки. По умолчанию это папка Picture, которая находится в той папке, которую вы выбрали для программы Karaoke Player при ее установке. Можно установить для картинок другую папку по умолчанию, напечатав полный путь к ней в поле ввода или выбрав папку в диалоге Browse for Folder (Найти папку), который появляется на экране при нажатии кнопки , находящейся справа от поля ввода.

После установки требуемых параметров закройте диалог Properties (Свойства), нажав в нем кнопку ОК. Диалог Properties (Свойства) закроется и новые параметры вступят в силу.
Чтобы завершить работу с программой Karaoke Player, нажмите кнопку [image] в заголовке ее рабочего окна. Окно проигрывателя вместе с окнами караоке и списка песен, если они были открыты, закроются и программа Karaoke Player завершит работу.


Untitled Document

Знакомство 2. Создаем свои файлы кapaoкe

Как уже упоминалось, в Интернете можно найти множество сайтов с файлами караоке, но вы можете очень просто создать караоке сами из MIDI-файла и текста песни. В Интернете можно найти по отдельности музыку в формате MIDI и текст любой песни, а чтобы объединить их вместе в файл караоке, существуют специальные программы, одну из которых вы можете найти на сайте www.karaoke.ru, в разделе Soft. Программа называется KarMaker. Перед созданием караоке слова песни необходимо разбить по слогам, используя символ-разделитель. После того, как слова будут поделены на слоги, программа автоматически разносит слоги по нотам, а если она ошиблась, то можно слоги двигать относительно нот вручную.

Чтобы создать караоке самому, необходимо выполнить следующие действия. Перепишите программу KarMaker с сайта www.karaoke.ru Распакуйте полученный архив karmaker.rar, в котором находится программа KarMaker, в отдельный пустой каталог. Перепишите из Интернета или другого источника текст песни в формате .ТХТ и музыку в формате MIDI. Запустите программу KarMaker, дважды щелкнув мышью на имени файла KarMaker.exe в программе Проводник (Explorer). На экране появится рабочее окно программы KarMaker (Рис. 7.14).

Puc. 7.14. Рабочее окно программы KarMaker

Если загрузить файл караоке (файл с расширением *.kar), то можно его отредактировать. Мы же опишем создание нового караоке.

Загрузите MIDI-файл (файл с расширением *.mid), выбрав команду меню Файл * Открыть и выбрав MIDI-файл в стандартном диалоге Открыть (Open) (Рис. 7.15).

Puc. 7.15. Рабочее окно программы KarMaker с загруженным MWI-файлом

Для успешного создания караоке желательно, чтобы в MIDI-файле имелся трек с темой (мелодией). Программа KarMaker автоматически определяет и показывает трек с мелодией.

Рис 7.16 Вкладка Lyrics (Стихи) рабочего окна программы KarMaker

Выберите вкладку Lyrics (Стихи) в рабочем окне программы KarMaker (Рис. 7.16).
Нажмите кнопку [image] на панели инструментов вкладки Lyrics (Стихи) и в появившемся стандартном диалоге Открыть (Open) выберите текстовый файл со словами песни (Рис. 7.17).

Puc. 7.17. Вкладка Lyrics (Стихи) рабочего окна программы KarMaker с загруженными словами песни

Перед созданием караоке слова песни необходимо разбить по слогам, используя символ-разделитель. По умолчанию в качестве разделителя используется символ "-", но можно выбрать и другой символ из списка Разделитель слогов.

После того, как слова будут поделены на слоги, можно разнести текст по мелодии. Программа автоматически разносит слоги по нотам, а если она ошиблась, то можно слоги двигать относительно нот вручную. Разнесение слогов текста происходит последовательно по определенной сетке. Сетку можно задать 3-х видов - по нотам, по словам л определенной длины. По умолчанию сетка устанавливается по нотам.
Текст по мелодии разносится с помощью следующих кнопок: - разнести текст по всему треку;
- разнести текст по треку, начиная с активной позиции; [image] - разнести текст по мелодии в выделенный блок.
Активная позиция устанавливается щелчком мыши на треке и отмечается вертикальной линией, проходящей через все треки. Блок выделяется с помощью следующих кнопок:
- начало выделения;
- конец выделения;
- выделить от активной позиции до конца;
- выделить от начала до активной позиции.
При редактировании караоке выделенный блок текста можно перемещать
вперед и назад по сетке с помощью кнопок [image] и [image], причем можно добавить элемент сетки в активную позицию с помощью кнопки [image] или удалить сетку в выделенном блоке с помощью кнопки

По окончании создания караоке сохраните его, выбрав команду меню Файл * Сохранить, и завершите работу с программой KarMaker, нажав кнопку [image] в заголовке ее рабочего окна.

Как видим, создать свой собственный файл караоке из готового MIDI-файла и текста песни несложно, но и сделать самому простейший MIDI-файл, содержащий только мелодию, тоже нетрудно. Для этого существует множество программ; часто они поставляются на дискете вместе с аудио-картой. В простых программах создания MIDI-файлов достаточно просто перетаскивать мышью ноты требуемой длительности и другие знаки нотной нотации с панели инструментов на нотный стан. А если у вас есть музыкальная клавиатура или синтезатор, подключенные к компьютеру, то при игре на них MIDI-файл будет записываться на диск автоматически.

Теперь, когда у вас есть караоке-плеер и сами файлы караоке, чтобы создать компакт-диск с караоке, достаточно создать обычный CD-ROM, на котором может быть папка KaraokePlayer, в которой записаны файлы программы Karaoke Player и папка Songs, в которой находятся файлы караоке. Тогда вы сможете запускать программу Karaoke Player прямо с компакт-диска с помощью программы Проводник (Explorer) и проигрывать находящиеся на компакт-диске файлы караоке.

Более того, караоке-плеер для удобства можно запускать автоматически с помощью файла автозагрузки Autorun.inf. Файл автозагрузки Autorun.inf, если он есть, всегда размещается в корневом каталоге компакт-диска и служит для запуска программы, находящейся на компакт-диске. Это обычный текстовый файл, который может быть создан, например, программой Блокнот (Notepad). В нашем случае файл автозагрузки Autorun.inf может быть примерно таким:

[AutoRun]
open= Karaoke Player/KarPlayer.exe

В последней строке после знака равенства указывается полный путь к исполняемому файлу программы на компакт-диске. Тогда, если в свойствах вашего дисковода CD-ROM установлен флажок Автоматическое распознавание диска (Auto insert notification), то при установке компакт-диска с караоке в привод CD-ROM будет автоматически запускаться программа Karaoke Player.

Можно даже сделать так, чтобы при запуске программы Karaoke Player она автоматически начинала проигрывать какую-либо песню. Для этого во второй строке после пробела необходимо указать имя файла караоке в качестве параметра запуска программы:

[AutoRun]
open= Karaoke Player/ KarPlayer.exe
Songs/ABBA/Thank_you_for_the_music.kar

Если ваша видеокарта имеет выход на телевизор, то слова можно вывести на телевизор.


Untitled Document

Знакомство 3. Mузыкa отдельно, слова отдельно

Если вы готовы отказаться от подсказки слов на экране компьютера или телевизора, то вместо файлов караоке можно выбрать и записать на компакт-диск обыкновенные MIDI-файлы, которые в большом количестве можно найти в Интернете и, в частности, на сайте www.midi.ru. Проигрывать их можно будет только на компьютере, но реально сделать из MIDI-файлов музыкальный диск - обыкновенный AudioCD и слушать его на бытовом музыкальном центре или автомобильном CD-плеере.

Чтобы сделать это, вам потребуются MIDI-файлы и программа для преобразования их в формат WAV, например Audio Compositor. Чтобы музыка после преобразования звучала более естественно, потребуются еще файлы с так называемыми сэмплами - образцами естественного звучания музыкальных инструментов. Сэмплы могут храниться в различных форматах, одним из которых является формат SF2 (Sound Font - Звуковой шрифт). Файлы сэмплов в формате SF2 можно купить на компакт-диске или найти и переписать из Интернета. После преобразования MIDI-файлов в WAV-файлы, последние можно записать на AudioCD, как это было описано в одной из предыдущих глав данной книги.

Программу Audio Compositor можно легко найти в Интернете, задав поиск словосочетания Audio Compositor на одном из поисковых серверов, например, на www.yandex.ru. Программа Audio Compositor является условно-бесплатной (shareware) программой, поэтому только зарегистрированная версия программы может преобразовывать MIDI-файлы в WAV-файлы с наивысшим качеством: стерео, размером слова от 16 до 32 бит и частотой дискретизации от 44100 до 48000 Гц. Незарегистрированная же версия программы может создавать WAV-файлы с таким максимальным качеством: моно, размер слова 16 бит и частота дискретизации 22050 Гц. Такое качество вполне приемлемо для того, чтобы петь, при этом мелодий уместится на компакт-диск в 4 раза больше, чем если бы мы создавали их с качеством CD (стерео, размер слова 16 бит и частота дискретизации 44100 Гц).

Рассмотрим кратко процесс преобразования MIDI-файла в WAV-файл на примере.

Запустите программу Audio Compositor (Рис. 7.18).

Puc. 7.18. Рабочее окно программы Audio Compositor

Выберите команду меню File * Open MIDI File (Файл * Открыть MIDI-файл). На экране появится диалог Open MIDI File (Открыть MIDI-файл) (Рис. 7.19).

Puc. 7.19. Диалог Open MIDI File (Открыть MIDI-файл)

В диалоге Open MIDI File (Открыть MIDI-файл) выберите MIDI-файл, который вы хотите преобразовать в WAV-файл, и нажмите кнопку Open (Открыть). Выбранный файл загрузится в программу Audio Compositor (Рис. 7.20).

Puc. 7.20. Рабочее окно программы Audio Compositor с загруженным MIDI-файлом

В нижней части окна MIDI-файла на вкладке Instrument/MIDI input (Инструмент/Вход MIDI) выберите файл сэмплов, который будет использоваться при преобразовании MIDI в WAV.

Выбор файла сэмплов осуществляется в стандартном диалоге открытия файла, который появляется при нажатии кнопки LJ, расположенной справа от поля ввода. Для достижения наивысшего качества преобразования, для каждой мелодии нужно подбирать свой файл сэмплов, который лучше всего к нему подходит. Например, если в мелодии преобладает звучание гитары, то надо загружать сэмплы с образцами звучания гитары, если фортепиано, то сэмплы с образцами звучания фортепиано и т.п. Существуют также универсальные сэмплы с образцами звучания всех инструментов, но так как при этом каждый сэмпл получается коротким, то он не в полной мере воспроизводит естественное звучание инструмента, и качество преобразования получается средним. Как правило, чем больше размер файла сэмплов, тем выше качество преобразования, но скорость преобразования (рендеринга) при этом ниже.

Выберите вкладку Audio output (Аудиовыход) в нижней части окна MIDI-файла (Рис. 7.21).
На вкладке Audio output (Аудиовыход) установите только флажок То file (В файл), чтобы программа работала быстрее; ползунковый регулятор Level (Уровень) для начала поставьте вправо до максимума, выберите Sample Rate (Частота дискретизации) 44100 и установите флажок Stereo (Стерео) - если у вас зарегистрированная версия программы.

Puc. 7.21. Вкладка Audio output (Аудиовыход) окна MlDl-файла

Если ваша программа Audio Compositor не зарегистрирована, то выберите частоту дискретизации 22050. В незарегистрированной программе возможен только режим моно, качество звука при таких параметрах будет ниже, но вполне приемлемо для пения, и на диск AudioCD поместится в 4 раза больше мелодий.

В группе переключателей Anti-alias (Сглаживание) установите переключатель АН (Все), и в группе переключателей Word size (Размер слова) установите переключатель 16 bit (16 бит).
Выберите вкладку Statistics (Статистика) и нажмите кнопку [image] на панели инструментов окна MIDI-файла. Начнется процесс преобразования (Рис. 7.22).

Рис 7.22 Вкладка Statistics (Cтатистика) окна MIDI-файла

По окончании преобразования обратите внимание на строку Peak output level (Пиковый уровень выходного сигнала). Если он больше 0 децибел, при этом уровень выводится красным цветом, то выходной WAV-файл будет содержать неприятные на слух искажения. Например, если Peak output level (Пиковый уровень выходного сигнала) показывает +3,23 dB, то следует уменьшить уровень Level (Уровень) на вкладке Audio output (Аудиовыход) на 4 dB, для того, чтобы результирующий уровень выходного сигнала стал меньше 0 (+3,23 - 4 = -0,77), и снова повторить процесс преобразования, нажав кнопку [image] на панели инструментов. При этом появится диалог с вопросом о том, что делать с существующим файлом (Рис. 7.23).

Puc. 7.23. Диалог с вопросом о том, что делать с существующим файлом

В этом случае следует установить переключатель Delete it and write a new file (Удалить его и записать новый файл) и нажать кнопку ОК. Будет создан новый файл.
Надо стремиться, чтобы уровень у всех файлов, которые вы хотите записать впоследствии на AudioCD, был приблизительно одинаковый, лучше около 0 dB, чтобы при проигрывании такого AudioCD громкость была максимальной и, вместе с тем, одинаковой для всех песен, чтобы не приходилось настраивать громкость для каждой песни отдельно в процессе прослушивания. Из полученных WAV-файлов можно создать AudioCD, как это было описано в одной из предыдущих глав книги.

Еще один способ создания караоке-диска - более трудоемкий - это создавать полноценное видео, в котором подсвеченные или закрашивающиеся цветом слоги надо будет монтировать вручную и синхронизировать со звуком в такой программе видеомонтажа, как Adobe Premiere. Это непросто. Мы не будем подробно рассматривать этот вариант в нашей книге - лишь отметим, что результат может быть очень впечатляющим: текст и музыка на фоне видео - это уже видеоклип, который можно записать на VideoCD или обычную видеокассету.


Untitled Document

ГЛАВА 8
Технология DVD-дuскoв с moчки зрения потребителя

За последние годы стремительное развитие цифровых и информационных технологий способствовало появлению новых носителей различного рода информации и высокоскоростных устройств чтения записанных на этих носителях данных. Так как, объем информации, который можно разместить на обычном компакт-диске (650 Мб) уже не вполне удовлетворяет современным требованиям, в 1995 году был объявлен новый стандарт для хранения информации на оптическом лазерном диске - DVD (Digital Versatile Disc), что в переводе означает цифровой универсальный диск (Часто можно встретить расшифровку DVD как Digital Video Disc, забывая, что DVD-диски могут хранить не только видео.)

Над разработкой нового стандарта работал консорциум из нескольких ведущих компаний мира: Hitachi, JVC, Matsushita, Mitsubishi, Philips, Pioneer, Sony, Thomson, Time Warner и Toshiba. Технология DVD - это новое поколение технологии хранения информации на оптических компакт-дисках, которая обеспечивает хранение фильмов, звукозаписей и компьютерных данных. Она разрабатывалась для того, чтобы вытеснить и заменить AudioCD, видеокассеты популярного VHS-формата, лазерные диски LD компьютерных CD-ROM и, возможно, даже игровых картриджей на рынке домашних развлечений и в компьютерной индустрии. В последнее время DVD получил широкую поддержку всех ведущих компаний микроэлектроники, компьютерных компаний и крупных киностудий и студий звукозаписи, что говорит о широких перспективах данного формата в ближайшем будущем.

Внешне DVD-диск похож на обычный компакт-диск, и без этикетки вы вряд ли отличите их друг от друга. Устройства для чтения DVD-дисков и устройства для чтения обычных компакт-дисков имеют одни и те же габаритные размеры и схожую внешне конструкцию. Устройства для чтения DVD-дисков имеют логотип DVD, отличающий их от дисководов, предназначенных для чтения компакт-дисков. Практически все устройства для чтения DVD-дисков способны читать информацию, записанную на обычный компакт-диск, причем эти диски могут быть разных форматов: CD-ROM, Extra CD, VideoCD и т.д.


Untitled Document

3накомство 1. Подробнее о разных форматах DVD

Как уже отмечалось выше, DVD - это цифровой универсальный диск. Однако на практике слово "универсальный" относится только к данным, которые можно записать на диск, так как существуют, часто несовместимые между собой, различные носители с префиксом DVD: DVD-ROM, DVD-R, DVD-RW, DVD-RAM, DVD-Video и DVD-Audio.

  • DVD-ROM - это некоторое подобие CD-ROM-диска большой емкости, это формат записи на DVD-диск, который содержит компьютерные данные и читается DVD-приводами, подключенными к компьютеру. Причем компьютерные приводы DVD-ROM могут воспроизводить и диски DVD-Video.
  • DVD-Video (или VideoDVD) - формат дисков, которые предназначены для хранения видеофильмов и видеопрограмм и должны проигрываться на бытовом DVD-плейере, и просматриваться на экране телевизора. Различие между DVD-ROM и DVD-Video подобно различию между традиционными CD-ROM и VideoCD.
  • DVD-Audio (или AudioDVD) - это звуковой формат, который еще окончательно не утвержден большей частью из-за звукозаписывающих студий, которые боятся пиратов и требуют более совершенных средств защиты от копирования.
    Существуют четыре разновидности записываемых DVD-дисков: DVD-R, DVD-RAM, DVD-RW и DVD+RW. На диски DVD-R можно записать данные только один раз, в то время, как на диски DVD-RAM, DVD-RW и DVD+RW информация может быть перезаписана многократно. Все указанные устройства и сами диски для них довольно дороги, поэтому речь о видеомагнитофоне на диске DVD пока вести рано, хотя опытные образцы уже есть.
  • DVD-R - при производстве DVD-R используется такая же технология что и для производства CD-R. Эти диски совместимы практически со всеми компьютерными DVD-приводами и бытовыми плеерами. Первые диски DVD-R имели размер 3,95 Гб, сейчас появились DVD-R диски размером 4,7 Гб. Пустые DVD-R диски стоят сегодня от 20 долларов. Формат DVD-R используется для подготовки матриц к тиражированию VideoDVD и DVD-ROM-дисков.
  • DVD-RW (другие названия: DVD-R/W, DVD-ER) - стираемые диски, которые являются развитием технологии DVD-R. Но число приводов и бытовых плееров, которые могут проигрывать эти диски немного меньше, чем для DVD-R. Ситуация напоминает аналогичную с дисками CD-R и CD-RW.
  • DVD-RAM - первые диски DVD-RAM имели емкость 2,58 Гб, сейчас их емкость доведена до 5,2 Гб. Диски DVD-RAM, как правило, вставлены в картридж и напоминают магнитооптические диски как по внешнему виду, так и по технологии записи. Диски DVD-RAM емкостью 5,2 Гб стоят от $40. Существуют привода DVD-ROM способные читать диски DVD-RAM, например, модель SR-8583 компании Panasonic.
  • DVD+RW - еще один перезаписываемый формат. Диски DVD+RW не могут читаться бытовыми плеерами DVD и большинством приводов DVD-ROM, за исключением некоторых моделей разработчиков формата DVD+RW: компаний Philips и Sony, Хотя ситуация может измениться в любой момент.


Untitled Document

Знакомство 2. Видео, звук и титры с VideoDVD-дucкa

В этом разделе мы познакомимся с тем, как записываются видео, звук и титры на VideoDVD-диск. Качество звука и видео, записанных на VideoDVD-диск, может быть разным, но возможности формата VideoDVD позволяют смотреть фильмы со студийным качеством, а звуковое сопровождение слушать с качеством лучшим, чем у AudioCD. В отличие от VideoCD, которые записываются с помощью кодирования в MPEG1, в VideoDVD для получения видео более высокого качества используется кодирование по стандарту MPEG -2. Но результат воспроизведения разумеется зависит от качества исходного видео- и аудиоматериала и качества аппаратуры, с помощью которой этот диск создавался.
VideoDVD-диск может содержать до 8 звуковых дорожек, причем каждая дорожка может быть закодирована в одном из нескольких цифровых форматах.

РСМ - цифровое кодирование, которое используется на AudioCD, но звук может быть записан с частотой дискретизации до 96 кГц. и размером отсчета до 24 бит, против. 44.1 КГц и 16 бит для AudioCD.

Dolby Digital - многоканальный звук, сокращенно DD, сжатый с использованием технологии АС-3 с частотой дискретизации 48 кГц и размером отсчета до 24 бит. Dolby Digital поддерживает до шести каналов звука, один из которых низкочастотный, поэтому шесть каналов Dolby Digital часто обозначаются как 5.1. Данный формат чаще всего используется для записи звука на VideoDVD. Следует отметить, что надпись Dolby Digital на VideoDVD диске не гарантирует воспроизведение объемного звука, и даже не гарантирует воспроизведение стереозвука. В формате Dolby Digital может быть записан как монозвук, так и звук Dolby Surround. Популярность формата объясняется его компактностью, возможностью интегрировать в себе различные способы кодирования объемного звука, требующиеся для воспроизведения внешних декодеров.

MPEG Audio - многоканальный звук, сжатый с частотой дискретизации 48 КГц и размером отсчета 16 бит.

Digital Theater Sound - система объемного звучания, впервые примененная в фильме "Парк Юрского периода", сокращенно DTS. Также как и Dolby Digital, формат DTS поддерживает шестиканальный звук 5.1, но отличается лучшим качеством звучания по сравнению с Dolby Digital за счет меньшего сжатия сигнала, из-за чего звук в формате DTS занимает больше места на диске. Если звуковая дорожка в формате DD оставляет возможность записи звукового сопровождения на разных языках, то с форматом DTS подобной возможности нет. Для декодирования формата DTS нужен внешний декодер, существуют также DTS -совместимые бытовые DVD-плееры, которые имеют логотип DTS Digital Out и встроенный DTS-декодер.

На некоторых VideoDVD-дисках звук на разных дорожках может быть записан в разных форматах и чтобы воспроизвести объемный звук, надо выбрать для воспроизведения нужную звуковую дорожку.

В отношении приводов DVD, предназначенных для установки в персональный компьютер, следует отметить, что они могут иметь два аудиоразъ-ема: один цифровой для высококачественной звуковоспроизводящей аппаратуры и один аналоговый для непосредственного подключения к стерео-усилителю. Некоторые DVD-приводы комплектуются специальной платой для аппаратного декодирования видео и звука, которая, как правило, имеет цифровой разъем Dolby Digital (АС-3) для подключения к внешнему звуковоспроизводящему устройству.

Формат VideoDVD предусматривает 32 дорожки для наложения титров. Таким образом, на одном диске могут быть записаны титры на разных языках - надо лишь выбрать нужный язык. Титры хранятся в виде растровой графики, которая записана на диск в сжатой форме. Это позволяет показывать не только текст, но и простые схемы в любом месте экрана. Титры позволяют создавать на базе VideoDVD-диски для караоке.


Untitled Document

Знакомство 3. Региональная блокировка и защита от копирования

БОЛЬШИНСТВО VideoDVD-дисков имеют систему защиты от несанкционированного копирования и региональную блокировку. В связи с тем, что ведущие киностудии заинтересованы в контроле за сбытом своей продукции, они потребовали, чтобы стандарт VideoDVD включал специальный алгоритм, который мог предотвратить воспроизведение VideoDVD-дисков в определенных географических регионах. Поэтому, практически каждый DVD-плеер или DVD-ROM-дисковод содержит код региона, для которого он предназначен. Код региона записывается на VideoDVD-диске, если код региона диска и плеера или привода не совпадают, вы не сможете увидеть фильм.
Всего для регионального кодирования было определено 8 регионов (или зон).

Между странами региональные коды распределены следующим образом:
1. Канада, США
2. Япония, Европа, Южная Африка, Ближний Восток (включая Египет)
3. Юго-Восточная Азия, Восточная Азия (включая Гонконг)
4. Австралия, Новая Зеландия, Тихоокеанские Острова, Центральная Америка, Южная Америка, Карибские острова
5. Бывший Советский Союз, Индийский полуостров, Африка (также Северная Корея, Монголия)
6. Китай
7. Зарезервировано
8. "Зона для путешественников": самолеты, круизные лайнеры и пр.

Даже на взгляд производителей плееров и приводов это решение является явным "перегибом", оно жутко неудобно и несправедливо по отношению к потребителям. Сейчас с помощью Интернета легко можно покупать VideoDVD-диски, например, в США, но заплатив деньги, вы не сможете его посмотреть на плеере предназначенном для России, с другой стороны вы можете купить плеер или привод, предназначенный для США и спокойно смотреть то, что не хотят давать смотреть киностудии даже за ваши деньги. Разумеется существует более простое решение обхода региональной блокировке и его косвенно предоставляют многие производители плееров и приводов. Об этом вы можете прочитать в следующей главе. Следует отметить, что существуют диски, которые не содержат кода региона и могут воспроизводиться на любом приводе или бытовом DVD-плеере. Региональные коды, наносятся на изображение глобуса на корпусе плеера или привода или коробке VideoDVD-диска.

Помимо региональной защиты VideoDVD-диски имеют защиту от копирования. Эта защита может быть следующих видов:

Analog CPS (фирмы Macrovision) - за основу была взята ASP (Analog Protection System - система аналоговой защиты), построенная на особом способе модуляции видеосигнала. В результате наличие этого сигнала у 95% видеомагнитофонов вызывает сбой в работе системы синхронизации и автоматической регулировки уровня записи, что приводит к значительному ухудшению качества изображения.

CGMS (copy generation management system - система управления созданием копий) - это специфическая информация, которая содержится на диске и определяет сколько копий можно выполнить без потерь качества. Т.е. можно сделать так, чтобы качественные копии получались при записи только с DVD-диска, а копии копий были испорчены, или так, чтобы даже первая копия с диска была некачественной. Информация CGSM присутствует в выходном видеосигнале и записывается вместе с ним при копировании. Только специальное оборудование может определить, содержит ли видеосигнал CGSM информацию. Различают два вида CGSM: CGMS/A - аналоговое кодирование и CGMS/D - цифровое, которое используется для цифровых выходов плееров таких, как IEEE 1394/FireWire.

Content Scrambling System (CSS) - система кодирования содержания используется киностудиями производящими DVD-Video-диски с целью предотвратить возможность копирования фильмов на жесткий диск компьютера для последующего воспроизведения. Начиная с 1999 г., все DVD-ROM-приводы поддерживают региональные коды и CSS. Это значит, что при воспроизведении VideoDVD-диска на DVD-ROM-приводе информация специальным образом дешифрируется, чего не происходит при простом копировании файлов с VideoDVD-диска на жесткий диск компьютера.

Digital Copy Protection System (DCPS) - система защиты от цифрового копирования заключается в использовании специальной DTCP (digital transmission content protection - защиты цифровой передачи содержания), применяемой к протоколам передачи данных, в том числе и шине IEEE 1394/FireWire. Эта система была разработана пятью компаниями Intel, Sony, Hitachi, Matsushita, и Toshiba. При использовании цифрового соединения между DVD-плеерами, цифровыми телевизорами, видеомагнитофонами и камерами, устройства обмениваются специальным ключом и идентификационными сертификатами, с помощью которых производится шифрование и дешифрирование передаваемой информации.

Данная глава содержит лишь краткий обзор основных аспектов технологии DVD-дисков. Этой информации вполне достаточно, что успешно выбрать DVD-привод, воспроизводить, создавать и копировать VideoDVD-диски, но об этом вы узнаете уже из следующей главы.


Untitled Document

ГЛАВА 9 Выбор DVD-npuвoдa, просмотр,создание и кonupoвaнue VideoDVD-дucкoв

Из предыдущей главы вы многое узнали о возможностях технологии DVD, теперь перейдем к рассмотрению практических вопросов, связанных с выбором DVD-привода, аппаратных и программных декодеров и воспроизведением VideoDVD-дисков на вашем персональном компьютере.


Untitled Document

Знакомство 1. Kaк выбрать привод DVD-ROM?

При выборе привода DVD-ROM следует, в первую очередь, обратить внимание на название фирмы, которая его выпустила. Дисководы, произведенные малоизвестными фирмами-изготовителями, могут не только не отвечать техническим характеристикам, указанным в инструкции, но и иметь проблемы с надежностью и совместимостью.
Второе, на что следует обратить внимание при приобретении дисковода DVD это код региона, для которого он был произведен, обычно он указывается на упаковке или в техническом описании на привод. Код региона имеет большое значение при проигрывании VideoDVD-дисков на вашем компьютере, об этом мы рассказывали в одном из предыдущих знакомств. Напомним, что DVD-дисковод может читать VideoDVD-диски, выпущенные только для того же региона, что и сам дисковод, и диски с региональным кодом, равным 0.
Можно поинтересоваться у продавца или технического консультанта магазина о возможности смены кода региона в приводе и о максимальном количестве таких изменений. Следует обратить внимание на скоростные параметры дисковода и размер кэш-памяти (буфера) привода DVD-ROM. Чем большим размером кэш-памяти обладает дисковод, тем быстрее он может передавать данные в компьютер. Это актуально для данных, а не для видео, т.к. приобретая DVD-привод, вы одновременно получаете высокоскоростное устройство для чтения CD-ROM-дисков.
Однако размер кэш-памяти может уменьшить длину паузы при переходе с одного слоя на другой при воспроизведении VideoDVD-дисков.
Выбирая DVD-привод, необходимо поинтересоваться, каким декодером, программным или аппаратным, он комплектуется. Аппаратные декодеры обычно воспроизводят VideoDVD-диски более качественно и в меньшей степени загружают процессор компьютера. Они имеют внешние выходы для подключения телевизора и аудиоаппаратуры высокого качества.
Если используется программный декодер, вывод изображения на экран телевизора возможен только в том случае, когда видеокарта вашего компьютера обладает такой функцией и имеет дополнительный выходной разъем. Кроме того, пользуясь программным декодером, вы сможете прослушивать звуковое сопровождение VideoDVD-диска только в режиме стерео, режим Dolby Digital (АС-3) требует специального декодера и будет недоступен.
Ниже приведена таблица с техническими параметрами DVD-дисководов различных фирм изготовителей.

Скорость передачи данных, Мбайт/с |  | Среднее время доступа, мс |  | Поддерживаемые типы дисков | Размер буфера, Кбайт
DVD-ROM | CD-ROM | DVD-ROM | CD-ROM
Hitachi GD-2500
2.76-5.52 (4Х) | 1.54-3.6 (10.3X-24X) | 180 | 120 | DVD-ROM, CD-ROM, CD-R, CD-RW, CD-DA, PhotoCD, CD-XA, CD-I, CD-Extra | 512
Matsushita SR-8583
2.8-6.76 (5X) | 2.07-4.8 (32X) | 140 | 95 | DVD-ROM, CD-Audio, CD-I, CD Extra, CD-ROM, CD-ROM/XA, PhotoCD, CD-R, DVD-Video | 512
Pioneer DVD- 103S (113)
3.35-8.1 (2.5X-6X) | 2.1-4.8 (14X-32X) | 120 | 90 | DVD ROM & Video (Single & Dual Layer); DVD-R, CD-R, CD-R/W, CD-DA (AudioCD); CD-ROM (Mode 1 & 2); CD-ROM XA, VideoCD, PhotoCD (single or Multi-session); CD-EXTRA, HYBRID CD | 512
Creative Labs DVD2240E
2.7 (2X) | 3 | 170 | 100 | DVD-ROM, CD-Audio, CD-I, CD Extra, CD-ROM, CD-ROM/XA, PhotoCD, CD-R, DVD-Video | 512
Creative Labs DVD5240E
6.76 Max (5X) | 4.8 Max (32X) | 140 | 90 | CD-Audio, CD-I, CD Extra, CD-ROM, CD-ROM/XA, CD-WO, PhotoCD, CD-R, CD-RW, DVD-ROM, DVD-R, DVD-Video | 512
Sony DDU220E
6.75 Max (5X) | 4.8 Max (32X) | 115 | 100 | DVD-ROM, DVD-Video,DVD-R, CD-Digital Audio, CD Extra, CD TEXT, CD-ROM, CD-I Ready, CD-Bridge, VideoCD, CD-R, CD-RW | 512
Toshiba SD-M1202
2.7-6.5 (5X) | 2.0-4.8 (32X) | 105 | 90 | DVD-ROM, VideoDVD,CD-ROM XA, CD-I BRIDGE (PhotoCD, VideoCD), CD-I READY, CD-DA, CD-G and multisession (PhotoCD), CD EXTRA | 256

Еще раз хотим заострить ваше внимание на вопросе выбора DVD-привода с точки зрения региональной защиты. Само по себе наличие или отсутствие такой защиты ни каким образом не сказывается на качестве воспроизведения видеоинформации с VideoDVD-диска, а только запрещает проигрывание дисков с кодом региона, отличным от кода региона привода. Многие приводы позволяют многократно менять код региона или совсем отключить систему региональной защиты.
Однако это не означает, что если ваш привод не имеет региональной защиты, то вы сможете спокойно проигрывать VideoDVD-диски любых регионов. В этом случае проверку соответствия регионального кода будет осуществлять программный плеер или плата аппаратного декодера DVD. Купить DVD-привод без региональной защиты все же предпочтительней, так как в этом случае, при ус-ловии использования только программного DVD-декодера, появляется возможность самому выбрать код региона во время установки программы декодера, и если через какое-то время появится необходимость изменить его, то достаточно будет просто переустановить программу декодера и выбрать нужный код. Если вы используете аппаратный декодер DVD, то обойти региональную защиту без применения специальных программ вы не сможете.
В таблице, приведенной ниже, показаны основные характеристики DVD-приводов, которые не имеют региональной защиты.

Производитель | Модель | Поколение | Скорость чтения DVD | Скорость чтения CD
Pioneer | A01 | 1 | 1x | 10x
Toshiba | SD-C2002 | 2 | 2x | 16x
Toshiba | SD-M1102 | 2 | 2x | 24x
Creative Labs | Encore | 2 | 2x | 24x
Hitachi | GD-2000 | 2 | 2x | 20x
LG | DRD-820B | 2 | 2x | 20x
Matshita | SR-8582 | 2 | 2x | 20x
* Pioneer | A02 IDE | 2 | 2.6x | 20x
* Pioneer | U02 SCSI | 2 | 2.6x | 20x
Toshiba Notebook | SD-C2002 | 3 | 4x | 24x
Hitachi | GD-2500 | 3 | 4x | 24x
Freecom | Taveller | 3 | 4x | 32x
LG Electronics | DRD-840B | 3 | 4x | 32x
Toshiba | SD-M1202 | 3 | 4.8x | 32x
Samsung | SDR-430 | 3 | 4.8x | 24x
Panasonic | SR-8583 | 3 | 5x | 32x
Philips | PCA532 | 3 | 5x | 32x
DVS | DSR-520H | 3 | 5.2x | 24x
*Aopen | 9624 | 3 | 6x | 32x
Vlemorex | 632 | 3 | 6x | 32x
*Aopen | 9632 | 3 | 6x | 32x
Hitachi | GD-2500BX | 3 | 6x | 32x
* Pioneer | A03 IDE | 3 | 6x | 32x
* Pioneer | U03 SCSI | 3 | 6x | 32x
* Pioneer | 103S | 3 | 6x | 32x
* Pioneer | 113 | 3 | 6x | 32x
*Actima | AD05P | 3 | 6x | 32x
Toshiba | SD-M1212 | 3 | 6x | 32x
Hitachi | GD-3000 | 3 | 6x | 32x
JCCom | JCM-632 | 3 | 6x | 32x
DVS | DSR-600H | 3 | 6.2x | 32x
Asus | Е608 | 3 | 8x | 40x
Toshiba DVD-RAM | SD-W 1101 | 1 | 2x | 16x
(*) = He следует изменять положение переключателя кода региона (RPC), т.к. это может привести к блокировке привода.

Однако некоторые производители DVD-приводов всегда устанавливают на них конкретный региональный код без возможности его замены. Список моделей таких приводов приведен в следующей таблице.

Производитель | Модель | Поколение | Скорость чтения DVD | Скорость чтения CD
Ricoh | MP9060A | 3 | 4x | 24x
Toshiba (DELL Inp. 7500) | SD-C2302 | 3 | 6x | 24x
TORiSAN | DD-4008E | 3 | 6x | 24x
Afreey | DD-4008E | 3 | 8x | 32x
Toshiba | SD-M1302 | 3 | 8x | 32x
Hitachi | GD-5000 | 3 | 8x | 40x
*Pioneer | 104 | 3 | 10x | 40x
*Pioneer | 114 | 3 | 10x | 40x
*Acer | DVP 1040A | 3 | 10x | 40x
*Aopen | 1040Pro | 3 | 10x | 40x
NEC | DV-5700a | 3 | 10x | 40x
LG | 8080b | 3 | 8x | 40x
(*) = Привод все таки может быть сделан регионально независимым с помощью перепрограммирования ПЗУ.

Ниже приводится таблица, с помощью которой можно определить, каким способом (программным или аппаратным) возможно изменение кода региона различных DVD-приводов, плееров и плат декодирования.

Устройство или программный плеер DVD | Способ смены кода региона | Web-страница
Acer DVP 1040А (10Х) | замена оборудования | www.7thzone.com
Actima AD05P (6Х/32Х) | аппаратный | perso.club-internet.fr
Affrey DD-3206E; DD-400BE; 4010E | аппаратный | perso.club-internet.fr
ALI MPEGM3309 card | программный | www2.datatestlab.com
Aopen 520S | программный | perso.club-internet.fr
Aopen 1040 (Pro) и 9632 | программный | www.7thzone.com
Aopen DVD-9632 | аппаратный | perso.club-internet.fr
Asus DVD Player | программный | www.inmatrix.com
Compaq GD-2500 (4X) | аппаратный | perso.club-internet.fr
Compaq SR-8582 (5X) | аппаратный | perso.club-internet.fr
Compaq DVD-113 | аппаратный | perso.club-internet.fr
Compaq DVD- 114 | аппаратный | members.xoom.com
Compaq DRD-8080B | аппаратный | www.lgeservice.com
Compaq Presario 1920 | программный | www.inmatrix.com
Creative Labs PC-DVD Encore 2x with Drx2 (CT7120 and CT7160) | программный | www.visualdomain.net
Panasonic DVD5240E | аппаратный | www.visualdomain.net
Creative Labs | программный | www.zhwin.ch
Creative Labs DVD6630E (6X/32X) и Creative Labs DVD8400E (8X/40X) | аппаратный | perso.club-internet.fr
Diamond SoftDVD SoftDVDv2.125_9.01 (оборудованные Diamond МХЗОО и Monster Fusion картами) | программный | www.inmatrix.com
Gateway c-Cube | установка драйверов для региона 1 или 2 | www.pcsndvds.com
Hitachi GF-1040/1055 | изменяется специальной утилитой 5 раз | perso.club-internet.fr
IBM Thinkpad 600Е | программный | www.inmatrix.com
IBM Thinkpad 770 DVD с SoftDVD | программный | www.zhwin.ch
IBM ThinkPad 7700 | программный | www.pcsndvds.com
Jaton Magic DVD | программный | altern.org
Jazz Jammin DVD II | программный | www.pcsndvds.com
Macintosh G3, MacOS 8.6, Mac dvd player 1.2 | программный | perso.club-internet.fr
Matshita (Panasonic) SR-8583 | программный | www.inmatrix.com
Matshita (Panasonic) SR-8584A и Matshita (Panasonic) SR-8585 (8X/40X) | аппаратный | perso.club-internet.fr
Memorex DVD632комплект | программный | altern.org
Packard Bell Platinum 450 | программный | www.inmatrix.com
Panasonic LF-D100/101 (dvd-ram) | изменяется только 5 раз специальной утилитой фирмы Panasonic | perso.club-internet.fr
Philips PCDV104 | программный | www.7thzone.com
Pioneer DVD-U03/303S; Pioneer DVD-113; Pioneer DVD-A03/103S; Pioneer DVD-U02/302; Pioneer DVD-A02/102 | программный | www.inmatrix.com
Ricoh MP9060A | аппаратный | www2.datatestlab.com
Samsung SD-608 | аппаратный | perso.club-internet.fr
Sigma Designs RealMagic Hollywood 1 и Sigma Designs RealMagic Hollywood 2 с dvd-rom приводами без регионального кода | программный | www.pcsndvds.com
Sigma Designs RealMagic Hollywood Plus с dvd-rom приводами без регионального кода | программный | altern.org
Sony SD-C2202 | аппаратный | perso.club-internet.fr
Toshiba SD C2102 | программный | www.inmatrix.com
Toshiba SD C2402 | аппаратный | perso.club-internet.fr
Toshiba SD-M1201 | аппаратный | perso.club-internet.fr
Toshiba SD M1212 | аппаратный | perso.club-internet.fr
Toshiba SD-M1302 | аппаратный | www.geocities.com

Более полную информацию о возможности изменения кода региона привода или программного плеера DVD вы можете получить на странице в Интернете по адресу: http://www2.datatestlab.com/regionhacks/default.htm.


Untitled Document

Знакомство 2.Просмотр DVD-Bugeo u обход региональной защиты

Для обеспечения качественного просмотра VideoDVD-записей персональный компьютер должен обладать следующими свойствами:

  • Иметь привод DVD-ROM;
  • Иметь аппаратный декодер VideoDVD (Sigma Designs Hollywood Plus или Creative Labs Dxr3);
  • Операционную систему компьютера и используемое программное обеспечение для воспроизведения VideoDVD;
  • Видеовыход декодера или видеокарты должен иметь поддержку Macro -vision для воспроизведения защищенных от копирования фильмов;
  • В случае использовании программного декодера MPEG-2 видео и Dolby Digital/ MPEG-2/PCM вместо аппаратного, компьютер должен быть достаточно быстрым (как минимум Pentium II 300 или Mac G3).

Приблизительно 10-30 % новых компьютеров с DVD-ROM-дисководами комплектуются аппаратными, а остальные - программными декодерами. Комплекты модернизации можно приобрести отдельно по цене от 150 долларов. Назначение выводов аппаратного декодера Creative Labs Dxr3 показано на Рис. 9.1.

Puc. 9.1. Назначение выводов декодера Creative Labs Dxr3

Схема подключения видеокарты, аппаратного декодера, SVGA-монитора, TV-приемника и звуковоспроизводящей аппаратуры показана на Рис. 9.2.

Puc. 9.2. Схема подключения для просмотра VideoDVD на мониторе компьютера и телевизора

Операционная система Windows 98 включает в себя компонент DirectShow 5.2, который обеспечивает стандартную поддержку воспроизведения VideoDVD-дисков и видеофайлов в формате MPEG-2. DirectShow может быть также установлен и в Windows 95. Последнюю версию компонента DirectShow 6.0 можно получить из Интернета по адресу: http://www.microsoft.com/directx/homeuser/downloads/. DirectShow обеспечивает стандартную среду для воспроизведения DVD, хотя по-прежнему требуется программный или аппаратный декодер стороннего производителя. В операционной системе Windows NT 4.0 поддерживается чтение данных с DVD-ROM, но очень слаба поддержка воспроизведения VideoDVD (аппаратные декодеры Sigma Designs Hollywood Plus и Creative Labs Dxr3 одни из немногих нормально работающих под управлением Windows NT 4.0). Операционная система Windows 2000 использует ту же модель драйверов, что и в Windows 98, поэтому воспроизведение VideoDVD-дисков под ее управлением не вызывает проблем. Популярный браузер Internet Explorer 5.0 включает в себя новую версию Windows Media Player, который поддерживает воспроизведение DVD на Web-страницах Интернета.

Программы DVD-проигрывателей (в случае программного или аппаратного декодирования) реализуют большинство функциональных возможностей бытового DVD-плеера. Ниже приводится список программных декодеров и проигрывателей VideoDVD для операционной системы Windows:

  • PowerDVD (фирмы CyberLink);
  • WinDVD (фирмы InterVideo);
  • DVD Express (фирмы Mediamatics);
  • Xing DVDPIayer (фирмы Xing) и другие.
    Список аппаратных декодеров, приводов DVD-ROM и комплектов модернизации для компьютера, работающих под управлением операционной системы Windows приводится ниже:
  • Encore Dxr2, Encore Dxr3 (Creative Technology);
  • Cool DVD (E4 Elecede на чипе C-Cube);
  • ThinkPad (IBM на чипе IBM);
  • WinFast 3D S800 (LeadTek, чип Mpact2);
  • DVD-to-Go (Margi);
  • Cinemaster (QI, на чипе C-Cube);
  • Hollywood (Sigma Designs, чип Sigma);
  • DVD Theater (STB, чип Mpact2);
  • Tecra laptops (Toshiba, чип Toshiba) и другие.

Преимущество аппаратных декодеров в том, что они меньше загружают процессор и обеспечивают лучшее качество воспроизведения.
К сожалению, хотя программные системы и обладают огромным потенциалом по воспроизведению DVD, качество воспроизведения оставляет желать лучшего на большинстве систем.

Если вы хотите подключить компьютер с DVD к телевизору, на плате декодера должен быть TV-выход (композитный или S-Video).
Рассмотрим работу аппаратного декодера на примере платы Creative DVD Encore Dxr3. Плата комплектуется программой DVD-плеера PC-DVD Player. После монтажа платы в свободный PCI-разъем вашего компьютера и установки всех необходимых драйверов и программы DVD-плеера можно проверить ее работоспособность, подключив к ней внешние устройства, как показано на Рис. 9.2. Чтобы просмотреть VideoDVD-диск, выполните следующие действия.

Установите в DVD-привод вашего компьютера VideoDVD-диск, код региона которого соответствует коду региона вашей аппаратуры. При установке диска обратите внимание на надписи на сторонах диска. Многие диски имеют на одной стороне широкоэкранную (WideScreen), а на другой стандартную (Standard) копии фильма. Широкоэкранная копия предназначена для воспроизведения на телевизоре с соотношением сторон экрана равным 16:9, а стандартная - для обычного телевизора или монитора с соотношением сторон экрана, равным 4:3.
Закройте лоток привода.
Если в настройках оборудования вашей операционной системы установлен режим автоматического распознавания диска, то программа PC-DVD Player будет запущена автоматически и начнется воспроизведение диска. Если автоматическое распознавание диска отключено, то выполните следующие действия.
Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выполните команду пускового меню Программы * Creative * PC-DVD Encore Dxr3 * PC-DVD Player (Program * Creative * PC-DVD Encore Dxr3 * PC-DVD Player), на экране появится рабочее окно программы PC-DVD Player.

Рабочее окно программы состоит из двух частей. Одна часть представляет собой уменьшенную копию экрана телевизора, в ней будет происходить воспроизведение изображения. Другая часть рабочего окна представляет из себя пульт дистанционного управления DVD-плеером и содержит кнопки, пиктограммы и индикатор режима работы плеера. В правом верхнем углу части рабочего окна, предназначенного для воспроизведения изображения, расположены кнопки управления размером окна. Кнопки позволяют сворачивать экран просмотра и помещает его значок на панель задач, разворачивать изображение на весь экран. Кнопка поиска раздела вызывает на экран диалог Search Chapter (Поиск раздела) вы можете проиграть любой из разделов VideoDVD-диска.

Для этого необходимо выбрать в списке разделов интересующий вас раздел и нажать кнопку Play (Воспроизвести).
Кнопка Search - вызывает на экран диалог Search Time (Поиск по времени).
Этот диалог представляет собой временную шкалу с бегунком-указателем текущего времени. Перемещая мышью бегунок по временной шкале, вы можете быстро перейти к воспроизведению нужного вам фрагмента фильма.

Кнопка Browse вызывает на экран контекстное меню для выбора источника видеоинформации. Это может быть привод DVD, CD-ROM или файл на жестком диске вашего компьютера. Диалог Configuration (Конфигурация) позволяет изменять настройки качества воспроизведения звука и видеоизображения. На вкладке Audio (Звук) можно настроить громкость звукового сопровождения, а с помощью кнопки Advanced (Дополнительно) переключать звуковые выходы платы декодера. На вкладке Video (Видео) вы можете отрегулировать яркость (brightness), контрастность (contrast) и цветовую насыщенность (saturation) изображения и установить формат видеосигнала на телевизионном выходе платы декодера: PAL, NTSС или формат исходного изображения.

С помощью кнопки Advanced (Дополнительно), расположенной на вкладке Video (Видео),вызывается диалог для центрирования изображения на экране монитора или телевизора. На вкладке Language (Язык) выбирается язык основного меню DVD-диска, субтитров и звукового сопровождения, если диск имеет многоязыковую поддержку.

Остальные кнопки аналогичны по назначению кнопкам пульта дистанционного управления бытовым видеомагнитофоном или DVD-плеером.
В нижней части пульта управления расположена панель управления меню VideoDVD-диска, с помощью которой вы можете перемещать курсор и выбирать пункты меню DVD-диска. Кроме перечисленных кнопок управления VideoDVD-плеером, программа проигрывателя имеет еще и набор пиктограмм, которые вызывают на экран контекстные меню. Мы познакомились с воспроизведением VideoDVD-диска с помощью аппаратного декодера и рассмотрели схему подключения его к различным устройствам.

Но кроме аппаратного декодирования, существуют и программные декодеры. Кратко опишем возможности одного из популярных программных декодеров VideoDVD программы PowerDVD. В отличие от аппаратных программные декодеры могут выводить видеоизображение только на экран монитора компьютера, т.е. вы не сможете просматривать VideoDVD-фильм на экране телевизора, если установленная в вашем компьютере видеокарта не имеет такой функции. Если ваша звуковая карта содержит чип Yamaha YMF724, Yamaha YMF744, Cirrus Crystal 4624 или модели Creative SBLive!, то с помощью этой программы вы сможете переназначить цифровой выход звуковой карты для использования в качестве выходного сигнала в формате Dolby Digital (АС-3), для подключения к цифровой звуковоспроизводящей аппаратуре высокого качества. Владельцы звуковых карт других моделей смогут прослушивать звуковое сопровождение VideoDVD-диска только в стереорежиме. Программа PowerDVD 2.0 фирмы CyberLink представляет из себя небольшую программу для проигрывания VideoDVD-дисков. Получить 30-дневную пробную версию программы вы можете, загрузив ее из Интернета с сайта фирмы, расположенного по адресу: http://www.cyberlink.com.tw После загрузки и установки на компьютере программа предложит произвести тест вашей видеокарты на предмет возможности воспроизведения через нее VideoDVD-потока. Чтобы запустить программу PowerDVD 2.0, выполните следующие действия.

Нажмите кнопку Пуск (Start), расположенную на панели задач рабочего стола. На экране появится пусковое меню.
Выполните команду пускового меню Программы CyberLink PowerDVD 4 PowerDVD (Program CyberLink PowerDVD PowerDVD). На экране появится рабочее окно программы PowerDVD 2.0 (Рис. 9.7).

Рабочее окно программы PowerDVD 2.0 состоит из двух частей: окна просмотра и панели управления, выполненной в виде лицевой панели DVD-плеера. Окно просмотра может быть развернуто на весь экран монитора с помощью кнопки [image], расположенной в заголовке. Панель управления содержит кнопки, с помощью которых можно выполнить основные команды управления DVD-приводом. Если навести указатель мыши на любую кнопку панели управления, то на экране на короткое время появится всплывающая подсказка с названием связанной с кнопкой команды.

Puc. 9.7. Рабочее окно программы PowerDVD 2.0

При первой попытке проиграть любой VideoDVD-диск на экране появится диалог Region Playback Control (Управление региональной защитой плеера) (Рис. 9.8).

Puc. 9.8. Диалог Region Playback Control (Управление региональной защитой плеера)

Переключатель, расположенный в группе элементов управления Supported Region(s) of This Disc (Поддерживаемый регион этого диска), автоматически установится в положение, соответствующее коду региона проигрываемого диска.

Нажмите кнопку ОК. Диалог закроется и в программе PowerDVD будет установлен региональный код, соответствующий воспроизводимому диску.
Если при следующем воспроизведении вы установите в привод VideoDVD-диск с другим региональным кодом, то этот диалог появится снова, но в строке Region Setting Counter (Счетчик установок региона) будет надпись remaining 4 time(s) (осталось 4 раза). После того, как счетчик установок региона обнулится, воспроизведение VideoDVD-дисков, защищенных региональным кодом, станет невозможным.

Основные настройки программы вы можете изменить с помощью диалога General Setup (Основные установки). Чтобы вызвать его на экран, выполните следующие действия.

Нажмите кнопку c изображением молоточка и гвоздя, расположенную в левой части панели управления плеером. На экране появится контекстное меню с выбором типа настроек
Выберите команду контекстного меню General (Основные), на экране появится диалог General Setup (Основные установки) (Рис. 9.10).
Из открывающегося списка Default CD-ROM Drive (Устройство CD-ROM по умолчанию) выберите строку с именем привода DVD, который установлен в вашем компьютере. Установленный флажок AutoPlay if Disc present (Автоматически воспроизводить, если диск установлен) включает режим воспроизведения сразу после установки VideoDVD-диска и закрытия лотка DVD-привода. Установленный флажок Run Full Screen (Запустить в полный экран) позволяет сразу запустить воспроизведение DVD-диска в полноэкранном режиме.

Puc. 9.10. Диалог General Setup (Основные установки)

Установленный флажок Keep Screen Aspect Ratio (Сохранять настройки экрана) позволяет сохранять установленный ранее режим работы вашей видеокарты. Переключатель, расположенный в группе элементов управления Default Cupture Mode Setting (Установки режима видеозахвата по умолчанию), позволяет выбрать, куда будет записываться захваченный кадр изображения. Возможно сохранение в буфер обмена, в центре рабочего стола и в файле на жестком диске. Все кнопки панели управления DVD-плеером снабжены значками, соответствующими их функциональному назначению. Основные функции кнопок мы рассматривали при описании программы PC-DVD Player.

Нажмите кнопку расположенную в левой верхней части панели управления DVD-плеером, чтобы закрыть рабочее окно программы PowerDVD 2.0.

В предыдущих знакомствах мы рассказали о том, что все VideoDVD-диски защищены от копирования и имеют код региона, запрещающий просмотр видеофильмов на DVD-плеерах и дисководах с другим кодом региона. При попытке проиграть на дисководе DVD-диск с кодом региона, отличным от кода региона аппаратного декодера Creative PC-DVD Encore Dxr3, на экране появится диалог PC-DVD Region Error (Ошибка региона) (Рис. 9.11).

Puc. 9.11. Диалог PC-DVD Region Error (Ошибка региона)

После появления такого диалога программа DVD-плеера обычно прекращает работу или просто не воспроизводит установленный в дисковод диск.

Существуют два метода, с помощью которых можно просмотреть защищенный региональным кодом DVD-видеодиск на DVD-ROM-приводе персонального компьютера. Первый способ - это изменить код региона установленный в вашем приводе DVD-ROM, аппаратном или программном декодере на код региона, диска, который вы хотите воспроизвести. Следует иметь ввиду, что кодом региона может быть защищен как привод DVD-ROM, так и программный или аппаратный декодер, установленный в вашем компьютере. Чтобы определить, защищен ли ваш привод DVD-ROM региональной защитой, надо воспользоваться программой Drive Region Info 1.02, которую можно загрузить из Интернета по адресу:

http://www.digital-digest.com/dvd/downloads/region.html.

После загрузки программы запустите на выполнение файл driveinfo102.exe. На экране появится рабочее окно программы Drive Region Info 1.02 (Рис. 9.12).
Из открывающегося списка, расположенного в верхней части окна, выберите строку с именем привода DVD-ROM, подключенного к вашему компьютеру.

Если под открывающимся списком появилась надпись THIS DRIVE HAS NO REGION PROTECTION (Это устройство не имеет региональной защиты), то это означает, что ваш привод DVD-ROM не имеет региональной защиты и дешифрация кода региона

Puc. 9.12. Рабочее окно программы Drive Region Info 1.02

производится аппаратным или программным декодером. Если же привод имеет региональную защиту, то в зоне Region Info (Информация о регионе) будет выведена информация о параметрах региональной защиты вашего привода. В этом случае мы рекомендуем вам посетить www-страницу в Интернете по адресу:
http://www.digital-digest.com/dvd/downloads/region_rom.html.
На ней вы найдете таблицу, в которой для различных моделей DVD-ROM-приводов описан способ изменения кода региона. Найдите в таблице свою модель привода и определите, каким способом можно снять с него региональную защиту.

Если ваш DVD-ROM-привод оказался не защищенным региональным кодом или вы сняли с него защиту, и при этом вы используете аппаратный декодер DVD, то, скорее всего, вам придется изменить код региональной защиты вашего аппаратного декодера. Всю информацию об изменении кода региона для вашего типа аппаратного декодера вы можете найти на странице Интернета по адресу:
http://www.digital-digest.com/dvd/downloads/region.html.

Мы опишем процесс снятия региональной защиты с аппаратного декодера Creative Dxr3. Для этого необходимо использовать программу Remote Selector 1.74. Демонстрационную, рассчитанную на использование в течении 14 дней, версию этой программы можно загрузить со страницы Интернета по адресу:
http://www.digital-digest.com/dvd/downloads/region_hard.html#zone.
Дальнейшее использование этой программы требует оплаты.

Запустите на выполнение файл remselec174.exe. На экране появится диалог программы Remote Selector (Рис. 9.13).

Puc. 9.13. Диалог программы Remote Selector

Нажмите кнопку Start Program (Запустить программу). На экране появится рабочее окно программы Remote Selector (Рис. 9.14).

Puc. 9.14. Рабочее окно программы Remote Selector

Перейдите на вкладку Region (Регион). Вид рабочего окна изменится в соответствии с Рис. 9.15.
В группе элементов управления Player (Плеер) установите флажок Disable region check (Удалить проверку региона). После чего программу
можно закрыть с помощью кнопки [image], расположенной в заголовке рабочего окна.
После проведения этой операции вы сможете проигрывать на своем приводе DVD-ROM видеодиски любого региона.

Puc. 9.15. Вкладка Region (Регион) программы Remote Selector


Untitled Document

Знакомство №3. Копирование DVD-Buдeo на жесткий дucк или CD-ROM'ы

Если вы так и не смогли найти подходящего для вашего оборудования программного обеспечения для того, чтобы снять региональную защиту, то существующее в настоящее время программное обеспечение, позволяет все-таки посмотреть видеофильм, предварительно скопировав его на жесткий диск вашего компьютера. Следует отметить, что для этого на жестком диске должно быть достаточно свободного места (фильм продолжительностью 117 минут занимает около 4,3 Гбайт), кроме того, вы потеряете возможность пользоваться некоторыми сервисными функциями, доступными при проигрывании VideoDVD-дисков, например, меню, субтитры и т.п.

Простое копирование файлов с VideoDVD-диска на жесткий диск с помощью программ Проводник (Explorer), DosNavigator или Norton Commander сделает невозможным воспроизведение скопированных на жесткий диск файлов из-за системы защиты CSS, о которой мы рассказывали в предыдущих главах. Поэтому единственный возможный способ воспроизвести видеофильм с VideoDVD-диска через привод DVD-ROM с разными кодами региона - это воспользоваться программами DeCSS, DeMPAA или DOD DVD Speed Ripper. Эти программы можно найти в Интернете.

Однако эти программы могут не работать с разными типами DVD-плееров. Кроме того, при копировании на жесткий диск VideoDVD-файлов с Multiangle-режимом, т.е. с поддержкой просмотра некоторых видеофрагментов с различных углов обзора, может получиться неприятный эффект повтора таких фрагментов по несколько раз. В этом случае лучше всего использовать программу Vobdec+0311, которая автоматически определяет такие файлы и исправляет их. Эту программу вы также можете получить из Интернета. Чтобы проиграть скопированный на жесткий диск файл, необходимо воспользоваться программой DVD-плеера, установленной на вашем компьютере. Мы покажем, как это сделать на примере Creative PC-DVD. Для этого выполните следующие действия.

Нажмите кнопку Пуск (Start), расположенную на панели задач. На экране появится пусковое меню.
Выполните команду пускового меню Программы 4 Creative * PC-DVD Encore Dxr3 * PC-DVD Player (Program * Creative * PC-DVD Encore Dxr3 * PC-DVD Player) на экране появится рабочее окно программы PC-DVD Player (Рис. 9.3).
Нажмите контекстное меню Select Media (Выбор источника).
Выберите строку контекстного меню File (Файл). На экране появится диалог Play File (Проиграть файл) (Рис. 9.16).

Puc. 9.16. Диалог Play File (Проиграть файл)

Из открывающегося списка Папка (Folder) выберите имя диска, на котором находится скопированный Vob-файл. В диалоге появится список папок выбранного диска.
Дважды щелкните мышью на имени папки, в которую был скопирован фильм с VideoDVD-диска, чтобы открыть ее.
Щелкните мышью на имени файла с расширением *.vob и нажмите кнопку Открыть (Open). Диалог Play File (Проиграть файл) будет закрыт, а в окне программы DVD-плеера начнется воспроизведение видеофильма.

Конечно, такой способ воспроизведения требует очень много свободного дискового пространства, и, естественно, возникает вопрос: как сохранить понравившийся фильм и при этом иметь возможность копирования других фильмов с VideoDVD-дисков? Единственное, что можно посоветовать в данной ситуации, это записать скопированный на жесткий диск фильм на компакт-диск. Конечно, весь видеофильм на компакт-диск не поместится, но можно разбить его на несколько частей и записать на несколько компакт-дисков.

Такая операция потребует дополнительного свободного места в 650 Мб на любом из жестких дисков вашего компьютера. Некоторые могут подумать, что дешевле купить VideoDVD-диск с понравившимся фильмом, чем тратить деньги на 6 или 7 компакт-дисков, однако это не так. Стоимость одного VideoDVD-диска составляет около 20-30 долларов, в то время, как 7 простых компакт-дисков обойдутся в 10 долларов. Также вы можете сохранить только выбранные самые любимые фрагменты или переупаковать фильм в другой формат.
Операцию по копированию фильма с VideoDVD-диска на несколько обычных компакт-дисков можно разбить на несколько повторяющихся этапов:

  • Копирование VOB-файлов с VideoDVD-диска на жесткий диск компьютера, например, с помощью программы DeCSS;
  • Разделение первой скопированной части на несколько файлов размером в 650 Мб с помощью программы vobSplitter 1.5;
  • Объединение оставшейся от разделения первого VOB-файла части размером меньше 650 Мб со следующим скопированным с VideoDVD-диска файлом с помощью программы vobMerge;
  • Разделение полученной части на файлы объемом 650 Мб и объединение остатка со следующим VOB-файлом и т.д.

Программы vobSplitter 1.5 и VOBMerge 0.5 вы можете найти в Интернете по адресу: http://www.digital-digest.com/dvd/downloads/. Эти программы очень просты и также, как программа DeCSS, не требуют установки. После получения архива с программами из Интернета вам нужно распаковать их в любую папку на вашем жестком диске.
Покажем весь процесс копирования и разделения фильма с VideoDVD-диска на конкретном примере.

Запустите программу DeCSS. На экране появится рабочее окно программы.
Нажмите клавишу "Ctrl" . и удерживая ее нажатой, выделите файлы, начиная с имени vts_01_1.vob до vts_01_5.vob, щелчком мыши на их названии.
Сбросьте флажок Merge Vob Files (Объединить VOB-файлы).
Нажмите кнопку Select Folder (Выберите папку) и с помощью появившегося диалога Обзор папок (Select folder) выберите папку, в которую будут помещены копируемые файлы.
Нажмите кнопку Transfer (Передача), чтобы начать копирование.
После окончания копирования закройте рабочее окно программы DeCSS с помощью кнопки [image], расположенной в заголовке окна.
Запустите на исполнение файл с именем vobsplit.exe. На экране появится рабочее окно программы vobSplitter (Рис. 9.19).

Puc. 9.19. Рабочее окно программы vobSplitter

В группе элементов управления Split (Раздробить) нажмите кнопку [image] в строке Original VOB: (Исходный VOB-файл). На экране появится диалог Browse files (Обзор файлов) (Рис. 9.20).

Puc. 9.20. Диалог Browse files (Обзор файлов)

Из открывающегося списка Диски (Disks) выберите имя диска, на котором находится папка с видеофайлом. В списке Папки (Folders) появится список всех имеющихся на выбранном диске папок.

Дважды щелкните мышью на строке с именем папки, в которой хранится видеофайл. В списке содержимого папки, расположенном под полем ввода Имя файла (File name), появится список всех VOB-файлов выбранной папки.

В списке содержимого папки выберите скопированный с VideoDVD-диска файл видеофильма с именем vts_01_1.vob и нажмите кнопку ОК. Диалог Browse files (Обзор файлов) закроется, а в строке Original VOB (Исходный VOB-файл) рабочего окна программы появится полный путь до выбранного файла.
В группе элементов управления Split (Раздробить) нажмите кнопку [image] в строке Destination VOB: (Результирующий VOB-файл). На экране появится диалог Browse files (Обзор файлов) (Рис. 9.20).
Если вы хотите, чтобы результирующий файл был создан в той же папке, что и исходный, то просто измените имя файла в поле ввода Имя файла (File name) на другое, например parM.vob.
Нажмите кнопку ОК. Диалог Browse files (Обзор файлов) закроется, а в строке Destination VOB: (Результирующий VOB-файл) рабочего окна программы появится полный путь до выбранного файла.
В поле ввода Starting at: (Начать с:) введите 0.
В поле ввода Size to copy: (Размер копии:) введите число 665600000 байт (1024000x650=665600000 или 650 Мбайт) равное размеру информации, которое можно разместить на одном компакт-диске.
Нажмите кнопку Start Process (Начать процесс), на экране появится шкала, индицирующая процесс дробления файла.
По окончании процесса копирования измените имя файла в строке Destination VOB: (Результирующий VOB-файл) на parMo.vob (файл с остатком первого VOB-файла).
В поле ввода Starting at: (Начать с:) введите число 665600000, а поле ввода Size to copy: (Размер копии:) оставьте введенное число без изменения. Программа сама определит размер остатка.
Нажмите кнопку Start Process (Начать процесс), на экране появится шкала, индицирующая процесс дробления файла.
По окончании процесса копирования удалите файл vts_01_1.vob с помощью программы Проводник (Explorer), так как он больше не понадобится.
Запустите на исполнение файл с именем VOBMerge.exe. На экране появится рабочее окно программы VOBMerge 0.5 (Рис. 9.21).

Рис 9.21. Рабочее окно программы VOBMerge

Нажмите кнопку Add VOB (Добавить VOB). На экране появится диалог Open VOB (Открытие VOB) (Рис. 9.22).

Puc. 9.22. Диалог Open VOB (Открытие VOB)

Из открывающегося списка Папка (Folder) выберите имя диска, на котором находятся Vob-файлы. В диалоге появится список папок выбранного диска.
Дважды щелкните мышью на имени папки, на котором находятся Vob-файлы, чтобы открыть ее.
Удерживая клавишу Ctrl щелкните мышью файлах с именами vts_01_2.vob и partjlo.vob нажмите кнопку Открыть (Open). Диалог Open VOB (Открытие VOB) будет закрыт, а в окне программы VOB-Merge 0.5 появятся имена объединяемых файлов (Рис. 9.23).

Puc. 9.23. Окно программы VOBMerge 0.5 с объединяемыми файлами

Выберите строку с файлом part_1o.vob и с помощью кнопки Up (Вверх) переместите его так, чтобы он располагался первым в списке объединяемых файлов.
Установите флажок Delete files after merge (Удалить файлы после объединения), чтобы программа сама удалила объединяемые файлы после их слияния.
Нажмите кнопку Merge all (Объединить все). На экране появится диалог Сохранение (Save as) (Рис. 9.24).

Puc. 9.24. Диалог Сохранение (Save as)

Из открывающегося списка Папка (Folder) выберите имя диска, на котором находятся Vob-файлы. В диалоге появится список папок выбранного диска.
Дважды щелкните мышью на имени папки, на котором находятся Vob-файлы, чтобы открыть ее.
В поле ввода Имя файла (File name) введите имя объединенного файла, например, part_1ob.vob (объединенная часть).
Нажмите кнопку Сохранить (Save). В строке статуса, расположенной в нижней части рабочего окна, появится информация, отражающая ход объединения.
По окончании процесса объединения перейдите в окно программы vobSplitter (Рис. 9.19) и измените имя файла в строке Original VOB: (Исходный VOB-файл) на part_1ob.vob, оставив без изменения путь к файлу.
В строке Destination VOB: (Результирующий VOB-файл) измените имя результирующего файла на part_2.vob.
В поле ввода Starting at: (Начать с:) введите число 0, а в поле ввода Size to copy: (Размер копии:) оставьте введенное число 665600000.
Нажмите кнопку Start Process (Начать процесс), на экране появится шкала, индицирующая процесс дробления файла.
После завершения копирования второй части, измените в строке Destination VOB: (Результирующий VOB-файл) измените имя результирующего файла на part_3.vob, в поле ввода Starting at: (Начать с:) введите число 665600000, а в поле ввода Size to copy: (Размер копии:) оставьте введенное число 665600000.
Нажмите кнопку Start Process (Начать процесс), на экране появится шкала, индицирующая процесс дробления файла.
После завершения копирования третьей части, измените в строке Destination VOB: (Результирующий VOB-файл) измените имя результирующего файла на part_3o.vob (остаток), в поле ввода Starting at: (Начать с:) введите число 1331200000, а в поле ввода Size to copy: (Размер копии:) оставьте введенное число 665600000.
Нажмите кнопку Start Process (Начать процесс), на экране появится шкала индицирующая процесс дробления файла.
По окончанию процесса копирования удалите файл parMob.vob с помощью программы Проводник (Explorer), так как он больше не понадобится.
Перейдите в окно программы VOBMerge 0.5 и нажмите кнопку Clear list (Очистить список), чтобы очистить список объединяемых ранее файлов.
Описанным выше способом добавьте в список объединяемых файлов файлы с именами part_3o.vob и vts_01_3.vob, таким образом, чтобы файл part_3o.vob был первым в списке.
Нажмите кнопку Merge all (Объединить все). На экране появится диалог Сохранение (Save as) (Рис. 9.24)
В поле ввода Имя файла (File name) введите имя объединенного файла, например, part_3ob.vob (объединенная часть) и нажмите кнопку Сохранить (Save).
После окончания процесса объединения перейдите в окно программы vobSplitter (Рис. 9.19) и разделите объединенный VOB-файл на части по 650 Мб, как это было описано выше, изменяя имя отрезаемой части и стартовую позицию. В результате вы получите одну часть размером 650 Мб и один остаток.
Объедините две оставшиеся часть с остатком, если суммарная длина результирующего файла не будет превышать 2,1 Гб с помощью программы VOB Merge 0.5, как это было описано выше. Обратите внимание на то, что в списке объединяемых файлов первым должен быть остаток от предыдущего дробления, а за ним не обработанные VOB-файлы в порядке возрастания их порядкового номера.
После окончания процесса объединения перейдите в окно программы vobSplitter (Рис. 9.19) и разделите объединенный VOB-файл на части по 650 Мб, как это было описано выше, изменяя имя отрезаемой части и стартовую позицию. В результате вы получите еще две части размером 650 Мб и один остаток.

На этом операция по копированию и делению видеофильма с VideoDVD-диска закончена, вы получили шесть файлов размером 650 Мбайт и один размером 431 Мбайт, которые вы можете записать на семь компакт-дисков, используя программы Easy CD Creator Deluxe 4.0 или WinOnCD 3.6.


Untitled Document

Знакомство 4. Создание собственного VideoDVD-дucкa

Процесс создания собственного VideoDVD можно разбить на 3 главных этапа: подготовка файлов, авторинг (создание образа диска) и мастеринг, т.е. запись на носитель.

Подготовка файлов

Как известно, видео на DVD хранится в формате MPEG2 (допускается MPEG1), а звук может быть в форматах РСМ (несжатый), MPEG1 layer 1&2, MPEG2, Dolby Digital или DTS. Для конвертации AVI-файлов в MPEG-файлы применяются кодировщики (компрессоры, кодеры), обычно обрабатывающие и аудиоинформацию, которая может содержаться в самом файле AVI или импортироваться отдельно в виде *.WAV. Компрессоры могут быть программными или аппаратными, в последнем случает используется специализированный чип на плате, который обычно производит преобразование в реальном времени.

Если кодировщик поддерживает переменный битрейт (скорость передачи данных) (VBR), то рекомендуется пользоваться этой опцией. Применение VBR приводит к повышению качества по сравнению с постоянным битрейтом (CBR) при таком же размере файла или получению более компактных файлов при сохранении такого же качества. Это объясняется тем, что при постоянном потоке на описание изменений в критических для MPEG-компрессии сценах (панорамирование, быстро движущиеся объекты) расходуется столько же информации, как и в сценах с небольшими изменениями. Обычно это приводит к появлению видимых искажений ("квадратов"). Использование VBR позволяет обойти эту проблему, так как поток адаптивно изменяется для сохранения заданного качества, которое описывается так называемой квантизацией (quantization). Величина квантизации равна 1, когда сжатая картинка претерпевает минимум изменений по сравнению с исходной. Увеличение квантизации означает отбрасывание высокочастотной информации в кадре, в малых дозах это незаметно для глаза, а в больших - ведет к появлению блочных артефактов (тех самых "квадратов"). При сжатии в режиме VBR задается еще максимальный битрейт, превышение которого недопустимо, иногда указывается желаемый средний битрейт.

Из программных МРЕС2-кодеров можно порекомендовать Custom Tech. CinemaCraft, Ligos LSX и Tsunami (последний - shareware). Все они поддерживают VBR, имеют встроенные пресеты для разных задач, обеспечивают вывод как мультиплексированного звука (program stream), так и немультиплексированного (elementary stream). На компьютере с двойным PIII-500 под управлением Windows NT 4.0 они показали время сжатия соответственно 4.7:1, 22:1 и 33:1 (первый оптимизирован под набор инструкций SSE). По качеству картинки самым лучшим признан CinemaCraft 2.25, затем Tsunami 0.11e и LSX 3.0.

В качестве примера аппаратного комплекса для подготовки DVD можно привести недавно появившуюся систему DC/DVD2000 производства Pinnacle Systems. Ее отличительной особенностью стала работа в формате MPEG2, содержащем I, В и Р кадры (кадры, которые используются в кодировании MPEG2), то, что раньше было недостижимым. Это решение для двухпотокового видеомонтажа с качеством Betacam (на выносном блоке входов-выходов имеются YUV/RGB, Y/C и композитные видеоразъемы и симметричные/несимметричные аудиокон-некторы, а также есть возможность подключить дочернюю плату для работы с DV/DVCAM). Двухпотоковая обработка видео означает мгновенный просчет 2В-переходов и титров. Плата комплектуется редактором Adobe Premiere, набором трехмерных эффектов HollywoodFX bronze и программой авторинга Minerva Impression 2.0, причем импорт в нее файлов MPEG2 из Premiere может происходить сразу, без предварительного пересчета.
Более дешевое решение для двухпотокового монтажа и подготовки файлов для DVD, сочетающее возможность ввода-вывода цифрового видео и аналогового видео с качеством S-VHS - это плата DV500 той же фирмы, использующая hardware-assisted кодирование в MPEG2, то есть программное кодирование с использованием некоторых инструкций чипа C-Cube DVXpress 25, того же, что применяется в DC/DVD2000. Просто в DV500 микрокод чипа прошит для поддержки real-time DV-компрессии, а в DC/DVD2000 - для real-time МРЕШ-компрессии. Скорость пересчета в IBP MPEG2 на DC500 составляет 2.1:1 при той же конфигурации, когда испытывались программные кодеры (см. выше). Цифровой порт IEEE 1394 находится на самой плате и она также комплектуется выносным блоком аналоговых разъемов для удобства коммутации.

Сжатое видео для DVD должно соответствовать базовым спецификациям MPEG2 MP@ML и MP@LL, где МР (Main Profile) - профиль, задающий кодирование цветовой составляющей как 4:2:0 и структуру потока как IBP, a ML (Main Level) и LL (Low Level) - уровни, задающие разрешение: 720x576 в первом случае и 352x288 во втором для стандарта PAL. Битрейт не должен превышать 9.8 Мб/сек.

Следует отметить, что все упомянутые компрессоры сжимают звук в стандарт MPEG audio. Для подготовки дорожки объемного звука (формат Dolby Digital, он же АС-3) необходимо использовать программу Sonic Foundry Soft Encode. Soft Encode - простая в использовании программа, намного более гибкая в своей работе по сравнению с аппаратными кодировщиками. По большому счету, все что нужно сделать пользователю - это открыть шесть звуковых файлов, заранее приготовленных в каком-нибудь аудиоредакторе, определить для каждого из них свой канал звучания, сбалансировать относительную громкость каналов и нажать на кнопку, запускающую процесс кодирования. Немаловажно, что с помощью Soft Encode можно не только кодировать файлы в формат Dolby Digital, но и декодировать. Программа не требовательна к аппаратной части ПК, однако естественно, что более мощный процессор ускорит (де)кодирование файлов *.АСЗ, на современных компьютерах на это уходит временя, сопоставимое с длительностью самой фонограммы.

Авторинг

Во время авторинга создается структура будущего диска, включающая файлы с расширением .IFO (InFormation Object) - иерархические меню, файлы с расширением .VOB (Video OBject), представляющие собой мультиплексированные (смешанные) потоки видео-, аудио- и навигационной информации, а также опционально файлы .BUP (Back UP) - резервные копии .IFO. Образ DVD является конечным результатом работы программы авторинга. В настоящее время выпущено достаточно много таких программ, наиболее распространенными из которых можно признать Daikin Scenarist NT, Spruce Tech. DVD Virtuoso, Sonic Solutions DVD It!, StreamWeaver CDMotion, Minerva Impression. В качестве примера рассмотрим последнюю упомянутую. Отличительной особенностью Impression 2.0 является простота создания и обкатки проекта. На шкалу времени помещаются в нужном порядке не-мультиплексированные видео- и аудиофайлы (.МР1, .МР2, .M1V, .M2V, .MPV, .WAV, .MPA, .АСЗ), а также картинки для создания меню и титров, затем клипы или их части (главы) "привязываются" к соответствующим кнопкам меню.

Для проверки функционирования диска до создания образа предусмотрен режим предварительного просмотра в окне. Кстати, упоминавшаяся выше DVD2000 отличается от DC2000 наличием LPT-ключа, который включает расширенные возможности Impression: многоуровневые и анимированные меню, множественные звуковые дорожки, субтитры и др. Далее возможны 2 варианта: генерация файлов для стандартного DVD и для CD, в последнем случае программа включает в образ программный комплект для воспроизведения видео на любых современных компьютерах под управлением Windows. Такая же технология реализована в новой, второй версии популярного пакета DVD It!, там на CD помещается популярный плеер CineMaster, и полученный диск называется cDVD. DVD It! SE имеет встроенный компрессор MPEG2 среднего качества и возможность мастеринга, a DVD It! РЕ - еще и Dolby Digital кодер. Итак, сгенерированный образ направляется на следующую стадию.

Мастеринг

Video DVD записывается с использованием файловой системы UDF (Universal Disk Format) и, также как VideoCD, содержит несколько папок. Наличие одной из них, VIDEO_TS, где должны находиться VOB и INF-файлы, проигрыватель DVD проверяет в самом начале. Эти файлы, в принципе, необходимы и достаточны для полноценного просмотра диска (INF задает необходимый порядок следования VOB, которые, кстати, не превышают 1 Гб). На коммерческих дисках VOB-файлы кодируются с применением системы шифрования CSS (Content Scrambling System) для исключения их незаконного копирования, на перезаписываемых дисках она не применяется. Если создать образ DVD, уменьшающийся на CD, то можно будет записать так называемый miniDVD, который будет просматриваться на ПК и на очень ограниченном количестве бытовых проигрывателей. Проблема заключается главным образом в том, что настольные аппараты обычно не читают сам носитель: CD-RW или чаще CD-R, если только в них не встроена система multi-read (как правило, 2 отдельных лазера). Для создания miniDVD подойдут известные пакеты Adaptec Easy CD Creator и Nero Burning ROM, в которых можно выбрать формат UDF и просто записать VOB и INF-файлы в соответствующую директорию или, что предпочтительней, скопировать готовый образ на болванку в формате ISO9660. Существуют и специализированные программы для таких целей: Daikin ReelDVD и Spruce DVD_on_CD.

Наиболее распространенными программами для мастеринга собственно DVD являются Adaptec Toast DVD, Gear ProDVD, МТС ForDVD и Software Architects Write DVD, которыми комплектуются большинство дисководов DVD-RW и DVD-RAM. Стоит иметь в виду, что приводы вышеуказанных стандартов записывают диски, которые не читаются в настольных проигрывателях и в большинстве DVD-ROM, исключая новые модели последних. Для создания стандартных дисков необходимо заиметь дисковод DVD-R 2.0, например внешний Pioneer S201 за 5300$. Пустые болванки к нему тоже недешевы и стоят около 40$. Конечно, такая ситуация не будет продолжаться вечно, нужно только набраться терпения и подождать, пока кто-нибудь из производителей не осчастливит нас подходящими носителями.

В заключении надо отметить, что много полезной информации о работе с DVD-дисками и приводами DVD-ROM вы можете получить, посетив Web-страницу в Интернете по адресу:
http://www.digital-digest.com/dvd/index.html.


Untitled Document

Введение

Современные программы для персональных компьютеров уже не умещаются, как прежде, на одной или нескольких дискетах емкостью 1,44 Мб. Компьютерные игры, обучающие программы, мультимедиа-энциклопедии, базы данных, офисные программы нередко занимают несколько сотен мегабайт или даже гигабайт. Хотя жесткие диски для персональных компьютеров становятся все более емкими и все более дешевыми, они не решают проблему хранения больших массивов данных: любой жесткий диск заполняется на удивление быстро, даже если вы не занимаетесь обработкой звука и видео. Жесткий диск хорошо подходит для оперативного хранения информации, но для долговременного хранения данных лучше использовать более дешевые и надежные носители информации.

Винчестер также не совсем подходит для переноса больших объемов данных на другой компьютер: во-первых, для этого надо разобрать весь компьютер, во-вторых, жесткий диск довольно чувствителен к ударам, и его можно легко повредить при транспортировке и потерять все записанные на нем данные. Единственным решением проблемы хранения и переноса данных является резервное копирование информации на внешний носитель. Создавать резервные копии данных необходимо хотя бы потому, что информация, хранящаяся на жестком диске вашего компьютера, может быть потеряна вследствие его поломки, ошибок оператора или действия программы-вируса.

Данные можно хранить на различных носителях информации, в число которых входят гибкие и жесткие диски, магнитооптические диски, ZIP-диски и т.п. Среди многочисленных носителей одни не обладают достаточной емкостью и надежностью, другие слишком дороги, третьи не имеют достаточно широкого применения. На сегодняшний день самыми удобными внешними носителями информации для хранения и переноса данных являются компактдиски. Они обладают большой вместимостью, надежностью, дешевы и повсеместно распространены: устройство для чтения компактдисков есть практически в каждом современном персональном компьютере. На компактдиске помещается до 650 Мб информации, которую можно читать с достаточно большой скоростью, хотя и не так быстро, как с винчестера.

В этом самоучителе мы расскажем о том, какие аппаратные и программные средства необходимы для самостоятельной записи компактдисков, какие компактдиски можно записывать на персональном компьютере, как создавать собственные архивы программ и данных на компактдисках, как выборочно или полностью переписать на компактдиск данные, музыку или видео с компактдисков и дисков DVD, как самому создать диск с караоке. Мы подробно расскажем о программах, которые лучше всего подходят для выбранной цели, и шаг за шагом опишем все действия, необходимые для создания собственного архива данных, видео и аудио-архива, диска караоке.

Отдельная глава посвящена прогрессивной технологии DVD. В ней рассказывается о том, что это такое, какие бывают DVD-диски, на каком оборудовании их можно проигрывать, как сделать полную или частичную копию DVD-диска, какие программы для этого нужны и как с ними работать.

Самоучитель рассчитан на пользователей, которые хоть немного знакомы с операционной системой Windows 95/98/NT, умеют запускать программы и выбирать команды из меню. Но даже если вы никогда раньше не садились за компьютер, то это не беда - здесь подробно описано, какие кнопки надо нажимать и что будет появляться на экране после каждого нажатия кнопки. Если все-таки у вас будут затруднения при работе с компьютером, то рекомендуем сначала прочитать книгу "Быстро и легко осваиваем работу на компьютере".