Глумление над реестром. Связь.

Глумление над реестром.
Связь.

  • Содержание.
  • Строка инициализации модема.

Строка инициализации модема.
From: Support
...живет тут HKEY_LOCAL_MACHINE\System\СurrentControlSet\Services\Class\Modem\0000\Init


Глумление над реестром. Desktop.

Глумление над реестром.
Desktop.

  • Содержание.
  • Удаление стрелок с ярлыков
  • Изменение имени "Корзины" ("RecycleBin")
  • Изменение значков "Корзины", "Входящие" и т.д.
  • Удаление изображения ладошки с зашареных ресурсов
  • Сохранение состояния рабочего стола.
  • "Обои" в произвольном месте экрана.
  • Имя рядом с системными часами.
  • Растягивание обоев на весь экран.
  • Как побороть глюки с иконками в Active Desktop.
  • Как отключить active desktop в win98.
  • Управление скоростью "выпадания" менюшек
  • Удаление пунктов типа "Настройка" из меню из "Пуск"
  • Анимация при открытии и закрытии окон в Win95.
  • Если Вам не нужна папка RECYCLED.
  • Смена анотаций к языку в панели задач и всплывающей подсказки.
  • Включение 256-цветных значков без Плюсов и прочих приспособлений (для 95-х)
  • Установка бешеных разрешений экрана в Виндах
  • Окно с произвольным текстом перед виндосовским паролем

Удаление стрелок с ярлыков
From: Силыч
Если вам надоели маленькие стрелки, обозначающие ярлыки w'95, то :
1. вызовите редактор реестра REGEDIT найдите подключ HKEY_CLASSES_ROOT\lnkfile
2. удалите значение lsSHortcut
3. найдите подключ HKEY_CLASSES_ROOT\piffile (для этого пониже опуститесь)
4. удалите значение lsSHortcut

Изменение имени "Корзины" ("RecycleBin")
From: 2Bugs
...Я думаю про изменение названия "КОРЗИНА" Вы знаете, но все-же...
- запускаем редактор реестра,
- выбираем "Правка","Найти", пишем в поле для поиска"Корзина"
- везде, где это имя будет найдено, заменяем его на... например "Помойка" ;)

Изменение значков "Корзины", "Входящие" и т.д.
From: Alex Mokhovoy
На примере изменения значка "Корзины". Необходимо пеpебpаться в pаздел pеестpа:
HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B9F08-00AA002F954E}\DefaultIcon
и изменить значение паpаметpа Empty и Full на путь к вашему файлу значка. Кстати цифpа после имени файла означает номеp значка с файле, так напpимеp c:\Windows\System\Shell32.dll,15 означает 15ый значек из библиотеки иконок Shell32.dll. Если же вы используете файл *.ICO то надо пpосто поставить после имени файла значение 0.
Вот CLSID для некоторых других пиктогpамм:
{20D04FE0-3AEA-1069-A2D8-08002B30309D} - "Мой компьютеp"
{208D2C60-3AEA-1069-A2D7-08002B30309D} - "Сетевое окpужение"
{00020D75-0000-0000-C000-000000000046} - "Входящие"
{00028B00-0000-0000-C000-000000000046} - "The Microsoft Network"
{FBF23B42-E3F0-101B-8488-00AA003E56F8} - "Пpоводник"

Удаление изображения ладошки с зашареных ресурсов
From: Support
Чтобы убрать "ладошку" с зашаренных ресурсов достаточно удалить значение ключа
HKEY_CLASSES_ROOT / Network / SharingHandler

Сохранение состояния рабочего стола.
From: Support
Если Вы заметили, что Windows перестала сохранять расположение иконок на рабочем столе, проверьте, не появился ли ключ "NoSaveSettings" в ветви
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer или
HKEY_USERS\[Ваш profile]\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

"Обои" в произвольном месте экрана.
From: lex
Найдите раздел HKEY_CURRENT_USER/Control Panel/Desktop и создайте в нем два строковых параметра WallpaperOriginX и WallpaperOriginY. Задайте их значения, которые соответствуют координатам X и Y левого верхнего угла картинки обоев (предполагается, что Вы установили режим, при котором выбранная картинка выводится на рабочий стол в единственном числе, то есть не размножается).

Имя рядом с системными часами.
From: Стаsик
Если вы хотите, чтобы рядом с системными часами распологалось ваше имя, то в реестре по адресу HKEY_CURRENT_USER\Control panel\International\ создаем 3 строковых параметра:
"s1159" со значением "Ваше имя"(не более 8 символов)
"s2359" со значением "такое же как и у первго"
"sTimeFormat" со значением "HH:mm:ss tt"
Порядок следует соблюдать!
Перезагружаемся и любуемся.
Комментарий: если сделать так как описано, то имя, рядом с часами, будет фигурировать не только на панели в левом нижнем углу Рабочего стола, но и во всех программах которые запрашивают системное время, например в Outlook Express в графе "Отправлено" или "Получено" :-)

Растягивание обоев на весь экран.
From: Марковский Евгений (jeka)
Если вы хотите, чтобы обои на вашем рабочем столе растягивалась на весь экран, то по адресу HKEY_CURRENT_USER\Control Panel\desktop\ в строковом параметре WallpaperStyle надо изменить значение на 2 (а чтобы они центрировались, на 0). Потом просто выберите в настройках экрана ваши обои и они растянуться.

Как побороть глюки с иконками в Active Desktop.
From: Andrey
Если вы используете Windows 95 + IE4.0 или Windows 98, то при включенном Active Desktop иногда бывают глюки с иконками в панели быстрого запуска и на рабочем столе. Коллективный разум сумел побороть это такой поправкой в реестре:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Explorer
"MaxCachedIcons"="1024" (строковый параметр)
Число 1024 при необходимости может быть увеличено.

Как отключить active desktop в win98.
From: Sergey
Чтобы отключить active desktop в win98 нужно в HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
добавить binary value 'NoActiveDesktop' из 4х байт - 01 00 00 00, и тогда из настроек экрана пропадут настройки active desktop.
Чтобы вообще отключить десктоп, нужно туда же добавить значение 'NoDesktop'=01 00 00 00

Управление скоростью "выпадания" менюшек
From: Maniac
Найти и изменить параметр:
HKEY_CURRENT_USER\Control Panel\desktop\MenuShowDelay
Интересно, что параметр ТЕКСТОВЫЙ, а не числовой. Но пишется туда число в миллисекундах.

Удаление пунктов типа "Настройка" из меню из "Пуск"
From: Serrg
Чтобы спрятать из кнопки пуск пункты меню, надо в HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explor
er добавить binary value 01 00 00 00 с именем:
NoClose - завершение работы
NoFavoritesMenu - избранное
NoFind - поиск
NoLogOff - log off
NoRecentDocsMenu - документы
NoRun - выполнить
NoSetFolders - настройки

Анимация при открытии и закрытии окон в Win95.
From: AlexandreKats
Может быть не только меня раздражает анимация при открытии и закрытии окон в Win95?
Лечится следующим образом (рецепт от Д.Рамодин, А.Федоров "Windows95:что, как и почему")

[HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics]
"MinAnimate"="0"

Если эффект не понравился, замените значение на "1" или ввобще удалите параметр.

Если Вам не нужна папка RECYCLED.
From: VADIM
Если Вам не нужна папка RECYCLED,то избавиться от неё можно так:
1. Удалить всю информацию о RECYCLED в реестре (предварительно сохранив его,например,в файле REGISTR.REG).
2. В библиотеке SHELL32.DLL с помощью UEDIT32.EXE (или другого HEX-редактора) по адресу 0005d330h обнулить всю строку (записать 00 00 00...).
Правда,в этом случае будет появляться файл DESKTOP.INI в корневом
каталоге. ! Для SHELL32.DLL,конечно,необходимо предварительно создать копию !
3.Можно не удалять строку, а дать корзине другое, подходящее по размеру,
имя:
в 0005d330h вместо RECYCLED записать, например, C:\TEMP.

Смена анотаций к языку в панели задач и всплывающей подсказки.
From: DEN
1.Запускаем редактор реестра...
2.Заходим в HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\Nls\Locale и ищем там строковые параметры с языками: Русским и Английским или с тем, анотации к которому хотим изменить... Обычно англ. язык стоит под числами 00000409, а русский под цифрами 00000419...Кстати, можно просто в поиске ввести Английский и Вы сразу попадете туда куда нужно...
3.Кликаем на английский и изменяем данные анотации ( Английский (США) ) на любые другие... Потом кликаем на Русский и тоже изменяем анотации на какие-нибудь приятные глазу выражения...
4.Выходим из редактора и перезапускаем Винды...Теперь каждый раз как только Вы наведете мышку на буквы Ru или En в панельке задач Вы увидите свой текст... И если Вы нажмете мышой на смену языка то тоже увидите рядом с Ru и En свой текст...

Включение 256-цветных значков без Плюсов и прочих приспособлений (для 95-х)
From: Artur Schuvalov
Находим ключ "HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics". Там ищем строковой параметр "Shell Icon BPP" (Если не находим - то создаем его).
Присваиваем этому параметру значение "16" и перезагружаемся. Кстати, там же имеется параметр "Shell Icon Size", в котором задаётся размер значков на рабочем столе и в кое-каких других местах :)

Установка бешеных разрешений экрана в Виндах
From: Artur Schuvalov
Ищем ключ "HKEY_LOCAL_MACHINE\Config\0001\Display\Settings". Там есть параметр "Resolution". Ну а дальше вы понимаете - ставим туда, например, "320,200", перезагружаемся и наслаждаемся полученным эффектом :)
Примечание: Мной замечены компьютеры, на которых при применении этого совета изображение выдаётся крайне заглюченное. На них стояли карточки Cirrus Logic 5429 и какая-то старая S3. Глюки наблюдались только с Win95 4.00.950, под OSR2 и Win98 проблем не было. Если глюки возникнут, то перезагружайтесь в Safe Mode и выставляйте своё любимое разрешение.

Окно с произвольным текстом перед виндосовским паролем
From: Антон Маринин
Если Вы хотите, чтобы перед виндосовским паролем появлялось окно с
произвольным текстом, который, как правило, может содержать различные
инструкции, наезды, предупреждения и т.д., то сделайте следующее:
1. Создайте раздел:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Winlogon
2. В нём - два строковых параметра: LegalNoticeCaption и
LegalNoticeText.
3. В значение LegalNoticeCaption впишите заголовок будущего окна.
4. В значение LegalNoticeText впишите сам текст будущего окна.
5. Перезагружаете компьютер - готово!


Глумление над реестром. Файлы, папки и т.п.

Глумление над реестром.
Файлы, папки и т.п.

  • Содержание.
  • Чтобы создать специальную папку...(из секретов Мелкомягких)
  • Хочу ещё спецпапок!!!
  • Как сделать тип файла "Unknown" видимым в диалоговом окне "Типы файлов"
  • Создание новых обьектов в мышином меню «Файл»->«Создать»
  • Иконки BMP-файлов, как миниатюрные картинки с изображением содержимого.
  • Добавление новых "действий" в меню "Файл".
  • Обновление содержимого окна Проводника
  • Как скрыть определенные диски от проводника
  • Открытие зарегистрированного файла другим приложением
  • Присваивание спецпапке (типа "Входящие") выпадающей подсказки
  • Вставка вызова программ в "Мой компьютер"
  • Запрещение записи ссылок на документы в папку "Пуск" -> "Документы"
  • Использование Блокнота для чтения нераспознанных системой файлов.

Чтобы создать специальную папку...(из секретов Мелкомягких)
From: ILja
Щелкните правой кнопкой мыши на рабочем столе или внутри папки (лучше), выберите пункты «Создать» и «Папка».
Дайте новому объекту имя и поставьте после него точку, после чего введите идентификатор класса объекта (CLSID) в фигурных скобках.
Например, для «Панели управления» полное имя папки будет выглядеть таким образом: "Панель мучений.{21EC2020-3AEA-1069-A2DD-08002B30309D}". Имя перед точкой можно давать по собственному усмотрению. Объект идентифицируется как специальная папка точкой и идентификатором CLSID.Не забудьте поставить фигурные скобки!(попробуйте поместить или создать такую папку в "с:\Windows\Главное меню\", и нажать на кнопку "Пуск", увидите что получится...... ;-))) )

Хочу ещё спецпапок!!!
From: ILja
Открываете в REGEDIT раздел "HKLM\Software\CLASSES\CLSID" и выделяете его мышью.
Запускаете в REGEDIT поиск и ищете строку "InfoTip"
Найдя интересный инфотип (например "Удалённый доступ") , смотрите на название вышестоящей по иерархии папки(что-то вроде "{????????-????-????-????-????????????}") создаёте папку с любым именем, точкой и этим идентификатором типа Name.{????????-????-????-????-????????????}
Юзаете спецпапку....(Виндовс глюкав, поэтому не со всеми CLSID это получается ;-))

Как сделать тип файла "Unknown" видимым в диалоговом окне "Типы файлов"
From: ILja
Откройте редактор реестра и разверните раздел "HKEY_ CL\SSES_ROOT".
Прокручивайте список типов файлов до тех пор, пока не найдете "Unknown".
Выделите его, переведите курсор в правое окно редактора и щелкните правой кнопкой мыши в произвольном месте.
Выберите пункт "Новый" из появившегося контекстного меню, затем элемент "Двоичное значение". Будет видно, что выделено "Новое значение #1".
Замените эту метку-заполнитель словом "EditFlags".
Щелкните дважды на пиктограмме "EditFlags" и введите следующую строку в поле "Значение" диалога "Редактирование": 02 00 00 00. (При обращении к этому полю в нем обнаружатся четыре нуля, удалить которые невозможно. Введенные вами цифры прибавятся к ним.)
Закройте Registry Editor. Теперь можно увидеть элемент "Unknown" среди типов файлов в "Проводнике". Этот метод применим к любым другим неизвестным типам файлов.

Создание новых обьектов в мышином меню «Файл»->«Создать»
From: ILja
Создать пустые файлы с нужными расширениями и поместить их в папку «\Windows\ShellNew».
Запустить regedit.exe и обратившись к ключу HKEY_CLASSES_ROOT, найти нужное расширение файла. Выбрав его, нажать правую кнопку мыши и добавить новую группу, назвав ее «ShellNew».
В правом окне редактора щелкнуть правой кнопкой мыши по фоновому изображению и добавить новый строковый параметр.
Назвав его «FileName», дважды щелкнуть на пиктограмме в окне «Редактировать строку» и ввести имя пустого файла, помещенного вами в папку «\Windows\ShellNew».
Закрыть Registry Editor.

Иконки BMP-файлов, как миниатюрные картинки с изображением содержимого.
From: ILja
Откройте раздел реестра «HKEY_CLASSES_ROOT», разверните в нем папку «Paint. Picture» и выберите «Defaulticon».
Дважды щелкнув на правом окне, откройте диалог «Изменение строкового параметра», удалите его содержимое и введите "%1". Тоже самое и ещё кое-что полезное делает и Winhacker 95. v1.1(с этой версией меньше проблем, чем со второй)

Добавление новых "действий" в меню "Файл".
From: рассылка List SOFT
WinRAR - очень хороший архиватор (субъективное мнение :). Но у него есть один недостаток. Возможно поэтому, большинство предпочитают пользоваться WinZip. Чтобы сжать какой либо файл с помощью WinRAR, нужно открывать Start->Program Files->WinRAR->WinRAR или кликнуть его иконку на десктопе. Потом выбрать путь, того файла, который вы хотите сжать... В WinZip такой рутины нет. Достаточно в Explorer кликнуть на нужном файле и добавить его в zip архив.
Но этот недостаток можно исправить. Запустите Regedit.exe. В реестре HKEY_CLASSES_ROOT\* создайте навый ключ:
HKEY_CLASSES_ROOT\*\shell\open
кликните справа (Standart) и напишите: Add to &RAR
Затем добавьте в HKEY_CLASSES_ROOT\*\shell\open ещё один ключ:
HKEY_CLASSES_ROOT\*\shell\open\command
справа введите путь: C:\Programme\WinRAR\winrar95.exe "%1"

Обновление содержимого окна Проводника
From: Support
Чтобы обновление содержимого окна Проводника происходило автоматически, а не по нажатию кнопки F5, в реестре нужно найти ключ HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update и изменить значение величины UpdateMode с 01 на 00.

Как скрыть определенные диски от проводника
From: Support
"Спрятать" некоторые диски от проводника Вам поможет следующая таблица:

A:
B:
C:
D:
E:
F:
J:
H:
I:
J:
K:
L:
M: 		01 00 00 00
02 00 00 00
04 00 00 00
08 00 00 00
10 00 00 00
20 00 00 00
40 00 00 00
80 00 00 00
00 01 00 00
00 02 00 00
00 04 00 00
00 08 00 00
00 10 00 00 		N:
O:
P:
Q:
R:
S:
T:
U:
V:
W:
X:
Y:
Z: 		00 20 00 00
00 40 00 00
00 80 00 00
00 00 01 00
00 00 02 00
00 00 04 00
00 00 08 00
00 00 10 00
00 00 20 00
00 00 40 00
00 00 80 00
00 00 00 01
00 00 00 02

Надо просто добавить к ветви HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer реестра двоичный ключ с именем 'NoDrives' и значением из соответствующей строки. А если надо "спрятать" несколько дисков, то достаточно сложить строки. Только учтите, что значения шестнадцатиричные!

Открытие зарегистрированного файла другим приложением
From: Vadim
Иногда хочется открыть зарегистрированный файл другим приложением, но это приходится делать с помощью кнопки "SHIFT".
Предлагаю дополнительную команду в "мышиное" меню:
- открываем: HKEY_CLASSES_ROOT\*\, добавляем: shell\openas\command
Вместо "Использовать по умолчанию" пишем:
"C:\WINDOWS\rundll32.exe shell32.dll,OpenAs_RunDLL %1"
Чуть ниже удаляем раздел "UNKNOWN" (но это не обязательно)

Присваивание спецпапке (типа "Входящие") выпадающей подсказки
From: TT
1) Запускаем regedit...
2) Жмём "поиск" (так проще) и находим строковый параметр с именем этой папки в HKEY_CLASSES_ROOT/CLSID...
3) Создаём там новый строковый параметр с именем "InfoTip" (если таковой имеется, см. пункт 4)
4) Вводим (изменяем) его значение...теперь при наведении курсора на папку будет выскакивать "подсказка" с вашим текстом

Вставка вызова программ в "Мой компьютер"
From: Igor Makarov makaroff@mtu-net.ru

Не устраивает меня лежание Очень неплохой програмки
Init на рабочем столе, так можно-же ее убрать в папку "Мой компьютер". Вот где
собака порылась (пути, соответственно поменять надо): кроме того, надеюсь, что
данный идентификатор класса никто не использует :)

---- init.reg
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\mycomputer\NameSpace\{FFFFFFFF-C2A7-11CF-BFF4-444553540000}]
[HKEY_CLASSES_ROOT\CLSID\{FFFFFFFF-C2A7-11CF-BFF4-444553540000}]
@="Maniac Modem Init"

[HKEY_CLASSES_ROOT\CLSID\{FFFFFFFF-C2A7-11CF-BFF4-444553540000}\DefaultIcon]
@="C:\\Util\\Windows\\init.exe,0"

[HKEY_CLASSES_ROOT\CLSID\{FFFFFFFF-C2A7-11CF-BFF4-444553540000}\InProcServer32]
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{FFFFFFFF-C2A7-11CF-BFF4-444553540000}\Shell]

[HKEY_CLASSES_ROOT\CLSID\{FFFFFFFF-C2A7-11CF-BFF4-444553540000}\Shell\Open]

[HKEY_CLASSES_ROOT\CLSID\{FFFFFFFF-C2A7-11CF-BFF4-444553540000}\Shell\Open\Command]
@="\"C:\\Util\\Windows\\init.exe\""

------- End of Init.reg -----

Запрещение записи ссылок на документы в папку "Пуск" -> "Документы"
From: Рассылка CNet

  1. Запустите RegEdit.
  2. В ветви HKEY_CURRENT_USER выберите Software/Microsoft/Windows/CurrentVersion/Policies/Explorer.
  3. В правом окне щелкните двойным щелчком параметр NoRecentDocsHistory (если параметр отсутствует, создайте двоичный параметр с таким именем).
  4. Исправте 00,00,00,00 на 01,00,00,00.
  5. Также выберите или создайте двоичный параметр NoRecentDocsMenu.
  6. Также исправте 00,00,00,00 на 01,00,00,00.
  7. Закройте RegEdit, перезапустите Windows.

Использование Блокнота для чтения нераспознанных системой файлов.
From: Костя
Часто нужно прочесть файл с тип read.me или readme.!!! , ну или что-то похожее, включение этого параметра позволит Вам использовать Блокнот для открытия файла, нажатием правой кнопки мыши на нем. Также Блокнот будет использоваться по умолчанию для открытия файла, если никакой ассоциации к нему не существует.

1. Найдите ключ "HKEY_CLASSES_ROOT\*\shell", если он не существует, создайте его.
2. Под ключом shell создайте новый ключ, по имени open, и установите значение параметра "(По умолчанию)", равным строке "Открыть в Блокноте".
3. Под ключом open создайте новый ключ по имени command, и установите значение параметра "(По умолчанию)" равным строке "notepad.exe %1".
Теперь, когда Вы щелкните правой кнопкой мыши на файле, в контекстном меню одним из пунктов будет "Открыть в Блокноте".


Глумление над реестром. Общая информация о реестре.

Глумление над реестром.
Общая информация о реестре.

  • Содержание.
  • Общая информация о файле реестра.
  • Уменьшение размеров файлов реестра.

Общая информация о файле реестра.
From: ILja
Открыв реестр, вы увидите шесть разделов, представленных пиктограммами папок. Каждый раздел имеет название, начинающееся с «НKEY», и содержит десятки настраиваемых параметров, причем разделы взаимосвязаны.
Главными являются HKEY_LOCAL_MACHINE и HKEY_USERS.
В разделе HKEY_CLASSES_ROOT хранятся зарегистрированные расширения и типы файлов, в том числе импортированные из win.ini. В его подразделе CLSID содержатся шестнадцатеричные коды, идентифицирующие различные объекты интерфейса, такие, как «Мой компьютер» и «Корзина». Данные этого раздела являются общими для любого пользователя конкретного ПК.
В разделе HKEY_LOCAL_MACHINE записана информация обо всех установленных аппаратных устройствах и ПО. В нем содержатся как общие для всех пользователей параметры, так и индивидуальные настройки (например, установки рабочего стола).
Раздел HKEY_CURRENT_CONFIG хранит данные о текущей конфигурации подключенных к ПК периферийных устройств.
В разделе HKEY_DYN_DATA располагаются указатели на подраздел HKEY_LOCAL_MACHINE, содержащий информацию о состоянии таких динамически меняющихся параметров, как производительность системы и характеристики устройств plug-and-play.
В разделе HKEY_USERS содержится информация обо всех зарегистрированных пользователях и индивидуальных настройках системы, а в разделе HKEY_ CURRENT_USER - настройки пользователя, работающего в данный момент.
Для большинства пользователей основным «окном» в реестр является закладка «Типы файлов» в настройке параметров «Проводника», с помощью которой можно определить, какую программу следует запускать для работы с файлом конкретного типа. Это хорошо иллюстрирует характер содержимого реестра. Познакомимся с ним поближе.
Если развернуть раздел «HKEY_ CLASSES_ROOT» реестра, то перед нами окажется список расширений файлов (в алфавитном порядке), импортированный из win.ini. За этим списком находится второй перечень, также содержащий типы файлов (в том числе и «Unknown», принимаемый по умолчанию для управления контекстными меню файлов неизвестных типов).
Обратившись к реестру, можно обнаружить множество шестнадцатеричных кодов, предназначенных для идентификации специальных объектов (например, интерфейсной структуре «Мой компьютер» соответствует {20D04FEO-3AEA-1069-A2D8-08002B30309D}). Ряд объектов интерфейса Windows 95 имеет более одного идентификационного номера. Их соотношения с параметрами других объектов не унифицированы. Microsoft не смогла (или не захотела) создать простую среду, в которой все объекты функционировали бы единообразно. Поскольку различные интерфейсные структуры, такие, как «Мой компьютер» или «Корзина», обладают специализированными функциями, каждая из них имеет уникальные параметры. Эти параметры нередко хранятся в динамически подгружаемых библиотеках (DLL), что не позволяет изменить их. Вместо этого можно создать специальные папки, имитирующие функции таких структур Windows, как «Панель управления», «Принтеры» или «Удаленный доступ». Microsoft утаивает от нас самое интересное: если поместить специальные папки в меню «Пуск», то содержащиеся в них элементы расположатся каскадом. Это дает возможность быстро запускать объекты специальных папок, например избранные элементы «Панели управления».
Одна из самых полезных «неофициальных» папок - «Корзина». В ней можно найти все файлы, подлежащие удалению. Создавая «Корзину», вы получаете специальную папку, которую можно переименовывать, перемещать и копировать в любую другую папку, например на рабочий стол. Контекстное меню для этой папки будет включать меню «Корзины», а также обычной папки, что дает возможность производить над вновь созданным объектом операции вырезания, копирования и вставки.
Специальную папку можно создать даже для рабочего стола, однако гораздо проще создать для него ярлык в меню «Пуск». После этого не нужно будет сворачивать активное приложение каждый раз, когда возникает необходимость обратиться к элементам рабочего стола.

Уменьшение размеров файлов реестра.
From: lex
В процессе эксплуатации Windows часто приходится устанавливать и удалять различные программы или изменять их параметры. В результате этих действий (даже после вполне корректной деинсталляции программ) в системном реестре остается много ненужной информации, так как Windows не умеет автоматически сжимать реестр. Для удаления этого мусора и проверки правильности записей в реестре существуют различные утилиты, однако самым простым способом сжать реестр является следующий. Загрузите компьютер в режиме командной строки. На всякий случай сделайте резервные копии файлов реестра. (Не забудьте, что в многопользовательском режиме часть реестра лежит в каталогах пользователей). Запустите из командной строки утилиту REGEDIT:
REGEDIT /E REGTXT.REG
Эта команда создаст текстовую копию Вашего реестра в файле REGTXT.REG. (При запуске со знаком вопроса в командной строке - REGEDIT /? - REGEDIT выводит справку по всем возможным ключам командной строки.) Далее выполните восстановление реестра из этой копии следующей командой:
REGEDIT /C REGTXT.REG
Обычно реестр при этом худеет на несколько сотен килобайт.
Важное замечание! Имейте в виду, что REGEDIT из оригинальной версии Windows 95 - 4.00.950 имеет ошибку, которая не позволяет обрабатывать большие реестры (объемом более 1 Мб), поэтому в данном случае можно лишь посоветовать попробовать найти исправленную версию REGEDIT. В Windows 95 OSR2 такой проблемы нет, однако REGEDIT из OSR2 не станет работать с предыдущей версией без специальных ухищрений.


Замена фона в IE

Задание фона панели инструменотов
в Internet Explorer

Прежде всего надо создать сам фон. Он представляет из себя картинку формата .bmp - 16 colors. Надо учитывать что в качестве прозрачного цвета будет использоваться светло-серый. В качестве системного контрастного - темно-серый.

Результат помещения ее в качестве фона на панель инструментов, показан выше... Теперь, надо поместить ее в доступную директорию. Например, в C:\WINDOWS\SYSTEM. И, для примера, назовем этот файл ie_back.bmp
Запустите программу REGEDIT или подобную и проследуйте в раздел Hkey_Current_User\Software\Microsoft\Internet Explorer\Toolbar. Нам понадобится строковой параметр - BackBitmap. Если там нет такого, то надо будет его создать.
Параметр BackBitmap должен содержать путь к нашему фоновому рисунку. Для приводимого примера, установим этому параметру значение C:\WINDOWS\SYSTEM\ie_back.bmp.

Теперь перезапустите компьютер для того чтобы эти изменения вступили в силу.

Вот и все. Творческих успехов...


Замена логотипа в IE

Замена логотипа в Internet Explorer

Логотип по сути своей представляет собой вертикальную последовательность кадров-картинок в формате BMP-256. Таких лент должно быть две. В одной кадры должны быть 26х26 точек, в другой 38х38. Длина ленты (а стало быть и количество кадров) может быть любой длины. Важно лишь следить, чтобы длина ленты в одном случае была кратной 26 точкам, в другом - 38. Справа представлен пример (рис.1), как могут выглядеть подобные линейки.

Разместите оба файла в легкодоступном месте. Например в C:\WINDOWS\SYSTEM. Для примера назовем эти файлы bg_logo.bmp и sm_logo.bmp.

Теперь запустите программу REEGEDIT или подобную и проследуйте в раздел Hkey_Current_User\Software\Microsoft\Internet Explorer\Toolbar. Нам нужны там два строковых параметра - BrandBitmap и SmBrandBitmap. Если их там нет, то надо будет их создать.
BrandBitmap должен содержать путь к "большому" логотипу (в нашем случае C:\WINDOWS\SYSTEM\bg_logo.bmp).
SmBrandBitmap - путь к "маленькому" логотипу ( C:\WINDOWS\SYSTEM\sm_logo.bmp).

Теперь перезапустите компьютер для того чтобы эти изменения вступили в силу.

Вот и все. Творческих успехов...


Глумление над реестром. IE & OE.

Глумление над реестром.
Internet Explorer и
Outlook Express.

  • Содержание.
  • Смена последних посещенных URL-ов в IE
  • Изменить надпись в шапке Internet Explorer.
  • Изменить надпись в шапке Outlook Express.
  • Надоела картинка при запуске Outlook Express.
  • Замена логотипа в Internet Explorer
  • Задание фона панели инструменотов в Internet Explorer

Смена последних посещенных URL-ов в IE
From: Николай Мильдон
Как поменять или удалить URL-и , выпадающие после нажатия кнопки со стрелкой в правом краю адресной строки.
Для этого надо зайти в HKEY_CURRENT_USER/Software/Microsoft/Internet Explorer/TypedURLs и изменить или удалить то, что не нравится.
Фишка - в последовательности номеров url не должно быть пропусков, т. е. если их было 10 и Вы удалили 4 и 6, то у оставшихся должны быть номера с 1 по 8. При невыполнении этого условия наблюдается глюк -: при нажатии вышеупомянутой кнопки вываливается пустое поле :(

Изменить надпись в шапке Internet Explorer.
From: Support
В шапке IE, после названия странички всегда идет приписочка "- Microsoft Internet Explorer". Это можно легко исправить... Например:
В HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main поставить "Window Title"="MTU Inform"

Изменить надпись в шапке Outlook Express.
From: Стаsик
Для этого в реестре, по адресу HKEY_CURRENT_USER\Software\Microsoft\Outlook Express\ надо создать строковый параметр "window title", в значении которого и должен распологаться желаемый текст.

Надоела картинка при запуске Outlook Express.
From: Стаsик
Если вам надоела картинка при запуске Outlook Express, то всё в том же реестре, по адресу HKEY_CURRENT_USER\Software\Microsoft\Outlook Express\ редактируем ключ "NoSplash" с "0"(картинка появляется) на "1"(картинки нет).


Глумление над реестром
Тут мы собираем всякую информацию о том, как заставить Windows подчиниться некоторым спецефическим настройкам, которые нельзя выполнить обычным путем. Конечно, большинство таких настроек можно выполнить при помощи программы Tweak Ul из пакета Power Toys или другой подобной программой, WinHack, например. Однако иногда применение таких програм нежелательно. И тогда запускается родимый regedit и ручками вносятся изменения...

Оговоримся сразу. Мы не являемся такими уж ушлыми спецами в этой области. Поэтому всецело пологаемся на вас. Если есть какие замечания или вы хотите добавить что нибудь, то... ну, короче, адрес наш тут в конце каждой странички есть - пишите.

1. Общая информация о реестре.
Общая информация о файле реестра.
Уменьшение размеров файлов реестра.

2. Desktop, интерфейс и т.п.
Удаление стрелок с ярлыков
Изменение имени "Корзины" ("RecycleBin")
Изменение значков "Корзины", "Входящие" и т.д.
Удаление изображения ладошки с зашареных ресурсов
Сохранение состояния рабочего стола.
"Обои" в произвольном месте экрана.
Имя рядом с системными часами.
Растягивание обоев на весь экран.
Как побороть глюки с иконками в Active Desktop.
Как отключить active desktop в win98.
Управление скоростью "выпадания" менюшек
Удаление пунктов типа "Настройка" из меню из "Пуск"
Анимация при открытии и закрытии окон в Win95.
Если Вам не нужна папка RECYCLED.
Смена анотаций к языку в панели задач и всплывающей подсказки.
Включение 256-цветных значков без Плюсов и прочих приспособлений (для 95-х)
Установка бешеных разрешений экрана в Виндах
Окно с произвольным текстом перед виндосовским паролем

3. Система.
Длинные имена файлов и каталогов в ДОС
Средняя кнопка мышки.
Автозапуск программ из файла реестра.
Как "изменить" версию Windows.
Изменение содержимого Tip Of The Day
Запрещение AutoRun CD (для NT)
Запрещение различных функций и ресурсов.
Скрытие вкладок в диалоговом окне "Свойства: Экран"
Удаление компонентов из "панели управления"\"установка и удаление..."

4. Файлы, папки и т.п.
Чтобы создать специальную папку...(из секретов Мелкомягких)
Хочу ещё спецпапок!!!
Как сделать тип файла "Unknown" видимым в диалоговом окне "Типы файлов"
Создание новых обьектов в мышином меню «Файл»->«Создать»
Иконки BMP-файлов, как миниатюрные картинки с изображением содержимого.
Добавление новых "действий" в меню "Файл".
Обновление содержимого окна Проводника
Как скрыть определенные диски от проводника
Открытие зарегистрированного файла другим приложением
Присваивание спецпапке (типа "Входящие") выпадающей подсказки
Вставка вызова программ в "Мой компьютер"
Запрещение записи ссылок на документы в папку "Пуск" -> "Документы"
Использование Блокнота для чтения нераспознанных системой файлов.

5. Internet Explorer, Outlook Express.
Смена последних посещенных URL-ов в IE
Изменить надпись в шапке Internet Explorer
Изменить надпись в шапке Outlook Express
Надоела картинка при запуске Outlook Express
Замена логотипа в Internet Explorer
Задание фона панели инструменотов в Internet Explorer

6. Связь.
Строка инициализации модема.

7. Пароли, авторизация и т.п.
Отключение кэша паролей.
"Забыли пароль? Ничего!"
Автоматический вход в Windows NT 4.0
Блокировка значка Passwords в "Панели управления"
Запрещение отключения компьютера через Пуск - Завершение работы
Снятие пароля "Советника по содержимому"
Снятие пароля Screen Saver-а

8. Разное.
Изменение шрифта в Notepad
Назначение звуков для событий в любой программе
Запрещение запуска RegEdit
Удаление записи из файла реестра


Глумление над реестром. Разное.

Глумление над реестром.
Разное.

  • Содержание.
  • Изменение шрифта в Notepad
  • Назначение звуков для событий в любой программе
  • Запрещение запуска RegEdit
  • Удаление записи из файла реестра

Изменение шрифта в Notepad
From: Support
Такой шрифт используется не только программой Notepad, но и в некоторых других местах, например, в окне терминала удаленного доступа к сети. Чтобы изменить его на другой, проделайте следующее. Найдите в Реестре раздел HKEY_LOCAL_MACHINE\config\0001\display\settings. В нем найдите параметр fixedfon.fon, который по умолчанию равен vgafix.fon. Укажите для него другой, установленный на компьютере шрифт (рекомендуется выбирать fon-шрифты, хотя в некоторых случаях могут заработать и шрифты TTF). Перезагрузите компьютер.

Назначение звуков для событий в любой программе
From: Support
Найти в реестре ключ HKEY_CURRENT_USER\AppEvents\Schemes\Apps и добавить подключ с названием исполняемого файла программы, которую требуется "озвучить". Для этого ключа нужно определить строковое значение по умолчанию, в котором задается описание программы, а внутри ключа можно создать разделы для любых стандартных событий:

AppGPFault
Close
Maximize
Minimize
MenuCommand
MenuPopup
Open
RestoreDown
RestoreUp
SystemAsterisk
SystemExclamation
SystemHand
SystemQuestion 		- Фатальная ошибка
- Закрытие
- Максимизация
- Минимизация
- Команда меню
- Всплывающее меню
- Открытие
- Свернуть в окно с полного экрана
- Развернуть в окно из иконки
- Стандартный звук
- Восклицание
- Ошибка
- Вопрос

В принципе, программа может генерировать и другие события, которые регистрируются еще в одном ключе реестра HKEY_CURRENT_USER\AppEvents\EventsLabels. После того как реестр соответствующим образом откорректирован, изменения появятся в Свойствах звука в Панели управления, где новым событиям можно назначить любые звуки.

Запрещение запуска RegEdit
From: Стаsик
Если за вашим компьютером работает ещё кто-то, такой же как и вы любитель покопаться в системном реестре с помощью всем известного Regedit.exe , то вы можете запретить запуск этой программы создав или изменив DWORD ключ по адресу
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
Имя: DisableRegistryTools
Значение:0 = можно, 1 = нельзя
Если у вас нет где-нибудь запрятанного редактора реестра, то вы сами не сможите отредактировать реестр после изменения этого ключа.

Удаление записи из файла реестра
From: ListSoft No52
Многие знают как внести какую-нибудь запись в реестр из файла. Для этого нужно создать файл со следующим содержимым:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Программа]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Dr.Web\command]
@="программа.EXE \"%1\""

Но не все знают как это оттуда с помощью же файла убрать. Для того, чтоб убрать ключ, в большинстве случаев достаточно удалить его значение, но как удалить ветку? Это оказывается также очень просто:

REGEDIT4

[-HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Dr.Web]
[-HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Dr.Web\command]
@=""

Т.е. надо перед именем ветки поставить "-" (без кавычек)


Глумление над реестром. Пароли, авторизация и т.п.

Глумление над реестром.
Пароли, авторизация и т.п.

  • Содержание.
  • Отключение кэша паролей.
  • "Забыли пароль? Ничего!"
  • Автоматический вход в Windows NT 4.0
  • Блокировка значка Passwords в "Панели управления"
  • Запрещение отключения компьютера через Пуск - Завершение работы
  • Снятие пароля "Советника по содержимому"
  • Снятие пароля Screen Saver-а

Отключение кэша паролей.
From: Capricorn
Помогает избавиться от проблемы "утаскивания" и дальнейшего взлома ваших сетевых и интернет паролей. Как известно эти пароли хранятся в файле с расширением PWL. Отключение кеша запрещает запись паролей в это файл. А следовательно его "выкрадывание" и дальнейший взлом не приносят не каких результатов. Единственное неудобство это надобность вводить каждый раз при коннекте в окно DialUp -Password пароль вручную. Но это все-же лутьше чем "подарить" пароль и логин хакеру.
Итак. В регистре ищем строку ( если ее нету пишем ручками)
HKEY_LOCAL_MACHINE
SOFTWARE
Microsoft
Windows
CurrentVersion
Policies
Network
"DisablePwdCaching"=dword:00000001
Запоминаем произведенные изменения. Находим в каталоге Windows файл (или файлы) с расширением PWL. Удаляем их. Перезагружаемся. Файл паролей хоть и создается опять, но он пустой. Хе-хе пусть исчуть на здоровье :)
Для возврата в обратное состояние надо удалить строку параметра "DisablePwdCaching"=dword:00000001

"Забыли пароль? Ничего!"
From: Андрей aka MATAN
Итак, представьте: Вы наконец-то решились снести win95 вместе с Internet Mail (I_M) и поставить win98 (c Outlook, например) и вдруг Вы с ужасом осознаете, что забыли пароль своего почтового адреса. Т.е I_M его помнит и почту по нему забирает, но показывать не хочет.
Не хочет - заставим.
Сам пароль храниться в файле USER.DAT - сделаем на всякий случай резервную копию.
Запускаем regedit -> HKEY_CURRENT_USER-> SOFTWARE->Microsoft ->Internet Mail and News ->MAIL -> POP3 -> "Ваш сервер" - смотрим пароль (в зашифрованном виде) и выписываем его на бумажку.
Запускаем Interner Mail -> Сообщения -> Параметры -> Сервер.
(*) Стираем последний символ пароля, нажимаем ПРИМЕНИТЬ, лезем в regedit - смотрим что получилось (для обновления шифровки переходим выше/ниже) и выписываем это на бумажку. Затем снова возвращаемся к (*) и так пока не сотрем весь пароль.
Теперь начинаем подбирать символы: лезем в I_M подбираем первый символ так, чтобы получившаяся шифровка в regedit соответствовала последней записи в блокноте, потом второй символ - для предпоследней записи... и т. д, пока не подберем весь пароль.
Если Вы начали подбирать символ и результат слишком далек от оригинала (значения отличаются на несколько десятков) попробуйте сменить регистр или набирать цифры.
Вот и все.

Автоматический вход в Windows NT 4.0
From: Алексей Скрипкин (По материалам WinNT Russian Users Group)
HKEY_LOCAL_MACHINE
Software
Microsoft
WinNT
Current Version
WinLogon: AutoAdminLogon: REG_SZ:1
DefaultUserName: Имя
DefaultPassword: Пароль

Блокировка значка Passwords в "Панели управления"
From: Стаsик
Если вы не хотите, чтобы кто-то в ваше отсутсвие менял пароль при входе в Windows, просто зделайте иконку Passwords в Панели управления заблокированной:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
Dword ключ с именим "NoSecCPL"
Значение 0 = доступно, 1 = недоступно

Запрещение отключения компьютера через Пуск - Завершение работы
From: Стаsик
Можно запретить другим пользователям отключать компьютер через Пуск-Завершение работы. (Правда любой догадается отключить питание)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Создаем DWORG ключ с именем "NoClose"
Значение:
0 = завершение разрешено, 1 = завершение заблокировано

Снятие пароля "Советника по содержимому"
From: Anton Marinin
Если Вы забыли или не знали изначально пароль для настройки "Советника по содержимому" (такая фича в Панель управления/Интернет), и из-за этого не имеете доступ к серверам, то Вы можете поступить следующим образом:
1. В Реестре Windows находите строковый параметр "Key" по адресу: HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Ratings\ и удаляете его.
2. Жмёте "Обновить (F5)" и закрываете редактор реестра. Теперь Вы сможете использовать продукты Microsoft Internet Explorer.

Снятие пароля Screen Saver-а
From: Anton Marinin
В Windows имеется возможность вручную снять пароль Screen Saver-а. Для этого открываем Редактор реестра и находим строковый параметр "ScreenSave_Data" по адресу: HKEY_USERS\.Default\Control Panel\desktop и удаляем его. Пароль исчез!


Глумление над реестром. Система.

Глумление над реестром.
Система.

  • Содержание.
  • Длинные имена файлов и каталогов в ДОС
  • Средняя кнопка мышки.
  • Автозапуск программ из файла реестра.
  • Как "изменить" версию Windows.
  • Изменение содержимого Tip Of The Day
  • Запрещение AutoRun CD (для NT)
  • Запрещение различных функций и ресурсов.
  • Скрытие вкладок в диалоговом окне "Свойства: Экран"
  • Удаление компонентов из "панели управления"\"установка и удаление..."

Длинные имена файлов и каталогов в ДОС
From: Victor Zabavin
Как известно, длинные имена файлов и каталогов в ДОС записываются сами знаете в каком виде (например Длинный файл.txt запишется как ДЛИННЫ~1.TXT). Однако не всегда в этом есть необходимость, а иногда это просто неудобно. Например, если в одном каталоге находятся Norton Commander, Norton Utilities, Norton Navigator, Norton Crash Guard, (что там еще у Нортона есть), то в ДОСвском NC это будет выглядеть как:
NORTON~1
NORTON~2
NORTON~3
NORTON~4
что, согласитесь, не очень-то информативно. А можно сделать, чтобы по-умолчанию имя записывалось длиной в 8 символов, и только при необходимости добавлялась тильда. То есть так:
NORTONCO
NORTONCR
NORTONNA
NORTONUT
по крайней мере, ясно, где что. И только если появится еще, скажем Norton Utilities 2.0, то появится запись NORTON~1.

А делается это очень просто. Открываем HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\FileSystem ,
находим двоичный параметр NameNumericTail (а скорее -- не находим, ибо по умолчанию его нет; тогда создаем) и устанавливаем его значение как
'00 00 00 00'. И все. После перезагрузки упомянутый выше Длинный файл.txt можно будет записать как ДЛИННЫЙФ.TXT

Средняя кнопка мышки.
From: рассылка List SOFT
Если у вас стоит драйвер мыши Logitech (для подавляющего большинства мышей винда ставит именно этот драйвер), то на среднюю клавишу мыши (которая по умолчанию не используется) можно назначить например функцию Double click. Для этого нужно в реестре в ключе HKLM\SOFTWARE\Logitech\MouseWare\CurrentVersion\SerialV\DoubleClick прописать значение "001".
Кстати, если Вы туда запишете значение "110" то Double click будет срабатывать на одновременное нажатие левой и правой клавиш.

Автозапуск программ из файла реестра.
From: Support
Как известно, автозапуск программ производится из папки "Автозагрузка" в меню "Пуск". Однако, файл реестра тоже, весьма неплохо справляется с этой задачей.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run"- в этом разделе могут содержится программы, которые автоматически запускаются при старте Windows.
Помимо HKEY_LOCAL_MACHINE, подраздел \SOFTWARE\Microsoft\Windows\CurrentVersion\Run имеет смысл поискать в HKEY_USERS:
HKEY_USERS\.Default\
или HKEY_USERS\<логин при входе>

Как "изменить" версию Windows.
From: Support
Найдите в реестре раздел HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\. Измените значение параметра SubVersionNumber на что угодно. Например yf " MTU Inform". Теперь в окне свойств системы к номеру версии появится соответствующая "добавочка". Типа "4.10.1998 MTU Inform".

Изменение содержимого Tip Of The Day
From: Maniac
Вот тут как-то однажды я удивил одну девушку, тем, что новопоставленные винды в своих Tip Of The Day с ней здоровались, а потом обращались по имени и ласково советовали не те советы, которые в них есть, а немного другие...
Список всех этих советов я нашел в:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Tips

Запрещение AutoRun CD (для NT)
From: Алексей Скрипкин (По материалам WinNT Russian Users Group)
HKEY_LOCAL_MACHINE
System
CurrentControlSet
Services
CDROM : Autorun : 0

Запрещение различных функций и ресурсов.
From: http://www.leader.ru/cgi-bin/go?secure7
Если Вы хотите запретить на клиентских машинах, работающих под управлением Windows 95/98/NT, выполнение некоторых функций, то можете отредактировать соответствующим образом registry. Запустите regedit и используйте следующие имена (установка DWORD значения в 1 включает ограничение, установка в 0 - снимает):

Ключ HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

"NoRun" - Запрещает команду Run/Выполнить
"NoDesktop" - Убирает все значки с рабочего стола
"NoClose" - Запрещает shutdown
"NoSaveSettings" - Запрещает сохранение установок на выходе
"DisableRegistryTools" - Запрет редактирования registry
"NoInternetIcon" - Удаляет значок Internet с рабочего стола
"RestrictRun" - При установке в 1 будет разрешен только запуск программ, определенных в ключе "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun"

Ключ HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp

"Disabled" - Запрет MS-DOS Prompt
"NoRealMode" - Запрет Single-Mode MS-DOS

Ключ HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Network

"NoNetSetupSecurityPage" - Спрятать Network Security Page
"NoNetSetup" - Запрет Network Control Panel
"NoNetSetupIDPage" - Прячет Identification Page
"NoNetSetupSecurityPage" - Прячет Access Control Page
"NoFileSharingControl" - Запрет File Sharing Controls

Скрытие вкладок в диалоговом окне "Свойства: Экран"
From: Стаsик
Оказывается есть возможность скрыть одну или несколко вкладок в диалоговом окне "Свойства: Экран", которое появляется после того как щёлкнув правой кнопкой мыши, вы выбираете "Свойства":
1. Чтобы скрыть вкладку "ФОН" надо в реестре, по адресу
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
создать параметр DWORD, с именем "NoDispBackgroundPage"
и со значением0 = есть, 1 = нет
2. Чтобы скрыть вкладку "ЗАСТАВКА" надо в реестре, по адресу
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
создать параметр DWORD, с именем "NoDispScrSavPage"
и со значением 0 = есть, 1 = нет
3. Чтобы скрыть вкладку "Настройка" надо в реестре, по адресу
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
создать параметр DWORD, с именем "NoDispSettingsPage"
и со значением 0 = есть, 1 = нет
4. Чтобы скрыть вкладку "Оформление" надо в реестре, по адресу
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
создать параметр DWORD, с именем "NoDispAppearancePage"
Значение 0 = доступно, 1 = недоступно

Удаление компонентов из "панели управления"\"установка и удаление..."
From: alexe111
Если вы удалили программу, а в панели управления\установка и удаление программ она еще есть, и удалить ее оттуда не представляется возможным, то поступаем следующим образом:
1. Открываем реестр.
2. Находим
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
3. Находим там папку с ненужной программой и удаляем ее.