Материалы взяты с сайта unattended.oszone.net. Дальнейшее применение материалов в других печатных изданиях, включая электронные статьи, должно сопровождаться указанием имени сайта unattended.OSzone.net и имени автора.

Автоматическая установка

Главная страница (Карта Сайта)

Желаю читателям всех благ и удачи в Новом Году!
(для автоматического наступления Нового Года запускайте его с ключом /2006 :)

  • Введение

  • Новичку

    • Подготовка дистрибутива
    • Интеграция Service Pack 2
    • Интеграция обновлений и заплаток в дистрибутив
      • Поиск и загрузка обновлений
      • Установка обновлений
        • Ключ /integrate
        • Метод svcpack.inf
        • nLite
        • Набор обновлений UpdatePack-XPSP2-Rus для русской Windows XP Pro SP2 new!
    • Создание файла ответов
    • Создание загрузочного ISO/CD

  • Опытному пользователю

    • Способы установки
      • Пакетные файлы
      • RunOnceEx
    • Приложения
      • Tипы инсталляторов
      • Примеры установки приложений
      • Программа Multiset - автоматизация установки приложений new!
      • Оffice 2003 (oбзор)
        • Простой метод
        • Метод административной установочной точки обновлена!
        • Метод SETUP.INI обновлена!
        • Office Shrinker обновлена!
        • Office 2003 MUI
    • Драйверы
      • Установка драйверов из winnt.sif
      • Установка драйверов с CD обновлена!
      • Интеграция SATA/RAID драйверов
        Параметры [SourceDisksFiles]
      • Пакеты драйверов от Bãshrat the Sneaky
    • Tвики реестра
    • Добавление учетных записей
    • Активация
    • Создание загрузочного ISO/CD

  • Эксперту

    • Сложные способы установки
      • Запуск RunOnceEx с CD
      • Выбор устанавливаемых приложений
    • Модификация системных файлов
      • Визуальные стили
      • Больше одновременных соединений
      • Oтключение защиты системных файлов
      • Moдификация других системных файлов
    • Косметические изменения
      • Setup Billboards
        • Классические Setup Billboards
        • Setup Billboards нового стиля
          • Winntbbu Editor
          • Изменение изображений
          • Изменение текста
          • Изменение цветов
      • Boot Screens
      • Tемы
      • Logon Screens
      • Изменение OEM информации и логотипа
    • Экономим место на диске
    • Сетевые технологии new!
      • Особенности автоустановки через Remote Installation Services (RIS)
      • Загрузка компьютера по сети с практически любого образа диска new!
    • Мультизагрузка (обзор)
      • Совмещение нескольких вариантов установки Windows XP на одном диске
      • Совмещение нескольких ОС семейства NT на одном диске
      • Мультизагрузочный CD автоустановки Windows XP с неограниченным количеством конфигураций

  • Справочник

    • Параметры файла ответов
    • $OEM$ Директории
    • Процесс установки по минутам
    • Виртуальные машины
    • Ключи для приложений (основы)
    • GuiRunOnce обновлена!
    • CMDLINES.TXT
    • Локализация: MUI, Шрифты и Региональные настройки new!
    • Cжатые файлы
    • Создание SFX архива
    • Примеры
    • FAQ обновлена!

  • Интересное

    • XPCreate
      • Параметры XPCREATE.INI
      • Директории XPCreate
    • WMP 10 Slipstreamer
    • Windows XPE Live CD (анонс статей)

  • Лог обновлений сайта RSS site updates
  • Оффлайн версия сайта в формате CHM (2.01) CHM

Наш форум

Опубликована- 22.02.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 09.04.05

Спроeктировала и разработала сайт Ginger


Автоматическая установка

Введение

Вы когда-нибудь хотели создать инсталляционный диск Windows XP, который бы автоматически установил систему, не задавая вопросов про имя пользователя, ключ продукта, временнЫе и региональные настройки? А как насчет автоматической установки ваших любимых приложений, ключей реестра, обновленных драйверов, всех обновлений и заплаток от Microsoft? Все это возможно, и мы постараемся рассказать о том, как этого достичь. В английском языке этот процесс называется “unattended installation”, а мы будем использовать термин “автоматическая установка". Эта страница поможет вам сориентироваться в разделе Автоматической устанoвки Windows

Общая информация

Раздел веду я, Vadikan. Изначально львиная доля материалов была взята с сайта http://unattended.msfn.org и переведена мною с английского языка на русский с любезного разрешения авторов ресурса. Таким образом, фактически получилось русское зеркало английского сайта. Однако, с течением времени наш сайт опередил в развитии MSFN, и на данный момент лишь половина статей представляет собой точные переводы англоязычных материалов. Несколько статей были сильно изменены с учетом специфики локализованных версий Windows, а остальные написаны мною и участниками конференции OSZone.

Раздел был создан 17 апреля 2004 года, и ввиду его популярности спустя полгода на конференции OSZone появился форум, посвященный автоматической установке Windows.

Если у вас возникнут вопросы по материалам, то лучше их задать в форуме на конференции Oszone.net. Вы можете связаться со мной по электронной почте, но по ряду причин на вопросы технического характера я предпочитаю отвечать в форуме. Главная идея проста: в случае решения проблемы информация становится доступна всем, а не только тому, кто задал вопрос. Поэтому не обижайтесь, если вместо ответа на вопрос я направлю вас в форум. А вот о проблемах в подаче материалов (битых ссылках, ошибках на страницах и т.д.) действительно лучше сообщать по эл. почте.

Данная оффлайн версия создана по многочисленным просьбам посетителей сайта unattended.oszone.net. Первый выпуск был приурочен к глобальному обновлению содержимого сайта. За ним последовали и другие, однако в первую очередь обновляется онлайн версия. Вы можете следить за обновлениями при помощи RSS (ссылку вы найдете в Логе обновлений сайта).

Целевая аудитория

Домашние пользователи, которые тратят драгоценное время на нудную установку Windows, вручную устанавливают любимые приложения, загружают обновления и заплатки с сайта Microsoft, расходуя Интернет трафик, а потом часами настраивают систему, изменяя многочисленные ключи реестра.

Уровень сложности

Требуется знание операционной системы Windows XP на среднем уровне (не эксперт, но и не новичок). Также пригодится базовое понимание принципов работы пакетных файлов (*.bat или *.cmd).

Базовое знание английского языка - несомненный плюс, т.к. на msfn.org существует очень сильная конференция, где вопросы автоматической установки изучены вдоль и поперек. Владея базовыми навыками английского, можно воспользоваться поиском по форуму и найти ответы, даже не задавая вопросов. Помимо этого на конференции MSFN есть очень интересные проекты, о которых лишь вкратце рассказывается или вообще не упоминается на страницах сайта.

С другой стороны, на динамично развивающемся русском форуме автоустановки на конференции OSZone, тоже можно найти ответы на очень многие вопросы. Так что умение искать по форумам поможет найти ответы на вопросы, которые кажутся сложными на первый взгляд.

Структура и навигация

Сайт разбит на несколько разделов. Такая структура дает возможность изучать информацию постепенно, а не пытаться сразу воплотить в жизнь все, что описано на сайте. Разделение в какой-то мере условное, т.к. вопросы, обсуждаемые в различных разделах, нередко взаимосвязаны.

  • Новичку - рассказывает о создании базового инсталляционного диска для автоматической установки Windows.

  • Oпытному пользователю - рассказывает об установке драйверов и приложений, твиках реестра и добавлении учетных записей.

  • Эксперту - рассказывает о работе с модифицированными системными файлами, косметических изменениях операционной системы, мультизагрузке, установке по сети и других интересных вещах.

  • Справочник - подробно рассказывает о некоторых элементах автоматической установки, на которые регулярно ссылаются статьи из других разделов.

  • Интересное - содержит статьи, которые имеют отношение к автоматической установке Windows, но не вошли в основные разделы сайта.

Чтобы вам легче было ориентироваться на сайте, я выделяю важные примечания, команды и ключи, комментарии и имена файлов.

О чем необходимо помнить

Резервное копирование или бэкап. Самое худшее, что может произойти во время экспериментов с автоматической установкой, это то, что новая система встанет на раздел диска, на котором установлена ваша текущая система. Если вы будете внимательно читать статьи, то этого не произойдет, но о бэкапе рекомендую позаботиться. Ни я, ни авторы оригинальных материалов не несем ответственности за необдуманные действия, которые вы можете совершить.

Если не получится с первого раза, то не отчаивайтесь. Все должно работать. Исправьте ошибки и пробуйте снова – не боги горшки обжигают ;-) Успешных экспериментов!

Автор: Vadikan

Наш форум

Опубликована- 12.03.2005


Автоматическая установка

Новичку (Введение)

Добро пожаловать на первую страницу раздела для Новичков сайта Автоматической установки Windows! Следуя материалам этого раздела вы узнаете как создать полностью обновленный дистрибутив Windows XP и как его установить автоматически без участния пользователя. Это означает, что в дистрибутив будут интегрированы новейший Service Pack и обновления системы, а для установки будет использоваться специальный файл, содержащий информацию, которая обычно вводится пользователем вручную во время установки Windows.

Вам обязательно понадобятся

  • Инсталляционный диск Windows XP. Он может быть как с интегрированными SP1 или SP2, так и без них.

  • XP SP2 Deployment Tools (его также можно найти на установочном диске Windows XP в Support\Tools\deploy.cab)

  • Service Pack 2 для Windows XP

  • Утилита CDImage, которая необходима для записи загрузочного диска на основе вашего дистрибутива автоматической установки. Записи диска посвящена отдельная статья, где есть ссылки на все необходимое.

  • Программа для записи CD (Nero Burning Rom или любая аналогичная ей)

Также, для экспериментов oчень может пригодиться виртуальная машина (VMWare или Virtual PC). Виртуальные машины работают немного медленнеe, чем реальные компьютеры, но зато вам не надо форматировать ваш жесткий диск каждый раз, когда вы хотите протестировать созданный CD.

Мы начинаем с подготовки дистрибутива.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

Интеграция Service Pack 2

Мicrosoft рекомендует использовать Windows Update для установки SP2, т.к. затраты интернет трафика будут значительно меньше, чем при загрузке полнoго (сетевого) пакета (270 Мб). Однако, нас интересует создание инсталляционного диска с интегрированным SP2, и Windows Update нам тут не помощник. SP2 можно заказать и на CD, если вы не можете или не хотите качать его из сети. Процедуры интеграции абсолютно идентичны для всех языковых версий Windows, за исключением, пожалуй, имени файла SP2. Напоминаю, что языковая версия SP2 должна соответствовать языку вашей ОС.

Вам понадобятся

Помимо непосредственно SP2, нужен инсталляционный диск Windows XP. Это может быть как диск с интегрированным SP1/SP1a, так и диск без интегрированного SP1 (так называемый Windows XP Gold). Интеграция SP2 проходит абсолютно безболезненно в обоих случаях.

Интеграцию SP2 можно провести двумя путями: вручную и автоматически. Для автоматической интеграции используется программа nLite. Для работы nLite требуется .NET Framework. Если он у вас не установлен и вы не хотите его устанавливать, то интегрируйте SP2 вручную.

Ручной метод

Я поместил содержимое инсталляционного диска в директорию C:\XPCD, а файл SP2 (WindowsXP-KB835935-SP2-ENU.exe) в директорию C:\SP2. Вы можете использовать другие директории, соответственно меняя пути в приведенной ниже команде.

Идем в Пуск->Выполнить (Start->Run) и вводим в диалоговое окно следующую команду:

C:\SP2\WindowsXP-KB835935-SP2-ENU.exe /integrate:C:\XPCD

В данном случае используется ключ /integrate:path, подробнее о котором тут. Поддерживаемые ключи можно посмотреть запустив файл SP2 с ключом /help.

Если все пути указаны правильно, то начнется процесс интеграции:

А по его успешном окончании вы увидите такое уведомление:

Автоматический метод

Запустите nLite. Жмите Next пока не увидите такое окно:

Нажмите Browse и выберите директорию, в которую вы поместили дистрибутив. Напомню, что я использую C:\XPCD. Выбрав директорию вы увидите такое окно:

Нажмите Select и перейдите в директорию, в которой у вас находится файл Service Pack. Нажмите Open, чтобы выбрать файл. Вы процессе интеграции вы увидите пару окон, отражающих процесс распаковки

и интеграции Service Pack 2

По окончании интеграции вы увидите такое уведомление

Следующая статья содержит вводную информацию о поиске, загрузке и интеграции критических и важных обновлений для Windows XP.

Если у вас есть вопросы по данной статье, то вы их можете задать в этой теме на конференции OSZone. Если же ваш вопрос связан также и с автоматической установкой Windows, то этот форум для вас.

Автор: Vadikan
Иcточник: (часть про nLite переведенa с английского - unattended.msfn.org)

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

Подготовка дистрибутива

Создайте директорию XPCD на жестком диске. Можете поместить ее в корневой каталог – C:\XPCD. Название и расположение директории не играют никакой роли, но я буду придерживаться их на следующих этапах.

Скопируйте содержимое инсталляционного диска Windows XP в C:\XPCD

Теперь вам надо интегрировать новейший Service Pack и обновления, которые вышли после него. Мы начнем с интеграции Service Pack 2. Если копирование дистрибутива на жесткий диск вызывает у вас затруднения, то читайте статью дальше.

Вставьте инсталляционный CD Windows XP в CD-ROM. Сделайте двойной щелчок на иконке "Мой Компьютер" на Рабочем столе, затем правый клик на иконке CD-ROM и выберите Открыть из контекстного меню.

Вы можете просто нажать CTRL+A на клавиатуре, чтобы выделить все содержимое CD

Teперь либо нажмите на клавиатуре CTRL+C либо жмите правую кнопку мыши и выбирайте Копировать из контекстного меню

Teперь создайте директорию на жестком диске. Я создаю директорию в корневом каталоге диска C и называю ее XPCD (C:\XPCD). Откройте директорию и либо нажмите CTRl+V либо жмите правую кнопку мыши и выбирайте Вставить из контекстного меню

Все. Теперь дистрибутив Windows XP у вас на жестком диске. Можно переходить к интеграции Service Pack 2.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

Интеграция обновлений и заплаток в дистрибутив

На момент написания этой статьи Microsoft выпустила порядка 25-35 mb критических обновлений для Windows XP. Вряд ли у вас есть желание загружать обновления каждый раз сразу после установки системы, особенно на модемном соединении. Лучше потратить это время на настройку Windows, установку приложений и бэкап свежеустановленной системы. Существует возможность загрузить обновления с сайта Microsoft и установить их все сразу в процессе инсталляции Windows. О том как это сделать и рассказывают следующие статьи раздела.

Несмотря на то, что в названии статьи фигурирует слово "интеграция", использование этого термина не совсем точно отражает происходящее с обновлениями на самом деле. Я просто следую общепринятым понятиям. Фактически же обновления устанавливаются автоматически и незаметно в течении графического этапа установки системы. Поэтому не удивляйтесь, если установка Windows займет чуть больше времени, чем обычно. В любом случае, разница будет исчисляться несколькими минутами.

Довольно предисловий, займемся делом!

Поиск и загрузка обновлений | Установка обновлений

Автор: Vadikan

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

Поиск и загрузка обновлений

Вы вероятно задумывались над тем, как определить и получить все необходимые для вашей системы обновления и заплатки. Сделать это можно различными способами, и ниже приводятся три.

Способ 1 - Мой список текущих обновлений

Список, расположенный на этой странице, веду я, Vadikan. Список имеет некоторые ограничения, а именно: там перечислены только текущие обновлений для Windows XP SP2 с установленными Windows Media Player 10 и MSN Messenger 7 (WMP9 и старые версии Windows Messenger требуют дополнительных хофтиксов). Помимо списка обновлений со ссылками на соответствующие бюллетени безопасности (Security Bulletins), на странице также есть и список прямых ссылок для загрузки обновлений через менеджеры закачек. Список обновляется по мере выхода бюллетеней безопасности.

Способ 2 - Тема на форуме MSFN.org

Схожий список критических обновлений можно найти в этой теме на форуме MSFN. Тема регулярно обновляется по мере выхода новых заплаток.

Способ 3 - Microsoft Security Bulletin Search

На этой странице сайта Microsoft есть довольно удобный поиск по бюллетеням безопасости Microsoft. Пользоваться им несложно. Достаточно выставить критерии поиска, как показано на скриншоте (или как вам удобно), и кликнуть Go, чтобы получить список бюллетеней.

Security Bulletins Search

В каждом бюллетене есть ссылки на страницу закачки обновлений.

Способ 4 - Windows Update

Установите систему с SP2, но без каких-либо обновлений, и идите на сайт Windows Update. Запишите шестизначные номера каждого из обновлений (например, "329441: Security Update for Microsoft Windows").

С каждым из номеров проделайте следующее. Замените xxxxxx в http://support.microsoft.com/?kbid=xxxxxx на номер обновления, скопируйте URL в адресную строку браузера и идите по ссылке. Вы попадете на статью Базы Знаний Microsoft, описывающей данное обновление. Ссылка на обновление будет либо прямо в статье, либо в соответствующей статье Technet Security Bulletin.

Заключение

Список на MSFN может отличаться от моего, т.к. при составлении используются немного различающиеся критерии. В любом случае, все критические обновления окажутся в каждом из этих списков. Список, полученный третьим способом тоже будет отличаться от списков, указанных в первых двух способах. Это связано, например, с тем, что в бюллетени безопасности включены обновления для различных компонентов операционной системы (таких как Windows Media Player 9 и Windows Messenger), которые впоследствии были заменены более новыми версиями, доступными для загрузки отдельно.

Если вы хотите, чтобы после установки системы Windows Update (Microsoft Update) вообще не предлагал установить ни одного обновления, воспользуйтесь любым из первых трех способов, а затем установите систему и воспользуйтесь четвертым способом. После чего добавьте недостающие обновления в дистрибутив.

Безусловно, поиск и закачка всех обновлений займет немало времени. Однако, эти временнЫе затраты окупятся уже при следующей установке системы. В будущем вам будет намного проще поддерживать список обновлений, т.к. второй вторник (простите за невольную тавтологию) каждого месяца Microsoft выпускает лишь несколько апдейтов.

Следующая статья рассказывает о методах установки обновлений.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 23.02.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 25.11.05


Автоматическая установка

Установка обновлений

Данная страница представляет собой краткий обзор методов установки обновлений (заплаток) к операционной системе.

Ручной метод

Существует два способа установки обновлений вручную. Mетод svcpack.inf универсально подходит для интеграции обновлений Windows 2000-2003. Если у вас Windows XP с интегрированным SP2, то быстрее и проще будет использовать ключ /inegrate для интеграции каждого обновления в дистрибутив. К сожалению, этот способ 100% работает только с обновлениями, вышедшими после SP2 для Windows XP. Выберите подходящий вам способ:

Ключ /integrate | Метод svcpack.inf

Aвтоматический метод

Использование программы nLite позволяет автоматизировать процесс интеграции обновлений. Этот метод опять же можно использовать только для обновлений, вышедших после SP2 для Windows XP. Подробнее...

Набор обновлений UpdatePack-XPSP2-Rus для русской Windows XP Pro SP2

Автор набора - участник конференции OSZone Petya V4sechkin. Пакет предназначен для интеграции обновлений и хотфиксов в дистрибутив Windows. При этом интегрируются непосредственно файлы, извлеченные из хотфиксов (обычные методы добавляют в дистрибутив сами хотфиксы, которые запускаются из svcpack.inf при установке Windows). Очевидно, при таком подходе экономится время и место на CD-диске. Подробнее...

Данный пакет подходит только для русской Windows XP. Если вас интересует набор обновлений для английской ОС, то вам нужен RyanVM's Windows XP Post-SP2 Update Pack.

Другие методы

Участник форума OSZone VseDoFeNi автоматизировал процесс установки обновлений при помощи пакетных файлов. Обновления вам придется скачать самостоятельно, а чтобы обеспечить их установку в процессе инсталляции Windows достаточно будет запустить пакетный файл. Другой пакетный файл может быть использован для установки недостающих обновлений с инсталляционного CD на уже установленную систему. Подробнее вы можете прочитать в этой статье VseDoFeNi. А задать вопросы автору можно в этой теме.

XPCreate - еще одна программа созданная участником форума MSFN, GreenMachine. Работе с программой посвящены отдельные статьи.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

Ключ /integrate

В статье описывается как подготовить автоматическую установку обновлений, которая будет запущена за 13 минут до окончания установки Windows. Процесс установки обновлений может занять от 5 до 20 минут, в зависимости от их количества и конфигурации вашей системы. Сразу скажу, что процесс подготовки обновлений намного упростился по сравнению с pre-SP2 апдейтами.

Обновления и поддерживаемые ключи

Я буду опираться на статью МS Knowledge Base (MS KB) за номером 262841 - Command-Line switches for Windows software update packages. Microsoft использует несколько различных самораспаковывающихся пакетов, которые автоматически запускают программы обновлений содержающиеся внутри пакетов. Все пакеты обновлений для Windows XP и Windows 2003 Server содержат внутри программу Update.exe. Начиная с версии 5.4.15.0 эта программа поддерживает ключ /integrate:path, который нам очень поможет. А поможет он нам тем, что больше не понадобится вручную распаковывать обновления и вносить изменения в файлы svcpack.inf и dosnet.inf. Все это будет проделано автоматически. Для того, чтобы убедиться, что пакет на самом деле содержит Update.exe, загляните в свойства файла на закладку Версия. Там много полезной информации, включая даже ссылку на статью базы данных.

Ключ /integrate:path работает следующим образом. Первая часть его выполняет команду интеграции, а вторая задает путь к дистрибутиву, а точнее к директории содержащей папку i386. Таким образом для интеграции обновления в дистрибтив, находящийся в директории C:\XPCD нужно выполнить примерно такую команду:

WindowsXP-KB886185-x86-enu.exe /integrate:C:\XPCD

Об остальных ключах вы можете прочитать в вышеупомянутой статье МS KB, a я перейду к рассказу о том, что происходит при запуске обновления с ключом /integrate:path.

Интеграция обновлений

При запуске пакета обновления с ключом /integrate:path происходит следующее:

  • Новые версии файлов, содержащиеся в пакете обновлений распаковываются в i386, заменяя старые файлы. При этом они находятся в несжатом виде (*.dll вместо *.dl_)

  • Исполняемый файл обновления переименовывается в формат KBxxxxxx.exe в соответствии с номером статьи MS KB и копируется в директорию i386\svcpack

  • Каталоговый *.cat файл копируется в директорию i386\svcpack

  • В файл dosnet.inf в секцию [OptionalSrcDirs] вносится название каталога, содержащего обновления (svcpack)

  • В файл svcpack.inf добавляются запись для установки *.cat файла и запуска исполняемого файла обновления во время установки системы

После интеграции шести обновлений файл svcpack.inf выглядит следующим образом. В нем, кстати, видны и ключи /q /n /z, с которыми автоматически устанавливаются исполняемые файлы обновлений во время инсталляции системы.

[CatalogHeader]

[Version]
BuildNumber=2600
MinorVersion=1
MajorVersion=5
Signature=" NT$"
[SetupData]
CatalogSubDir="\I386\svcpack"
[SetupHotfixesToRun]
KB886185.exe /q /n /z
KB885626.exe /q /n /z
KB834707.exe /q /n /z
KB885836.exe /q /n /z
KB885835.exe /q /n /z
KB873339.exe /q /n /z
[ProductCatalogsToInstall]
KB886185.cat
KB885626.cat
KB834707.cat
KB885836.cat
KB885835.cat
KB873339.cat

Как видите, все что раньше приходилось делать вручную, теперь выполняется одной командой.

Примечание

В Феврале Microsoft выпустила обновление KB885250, которое не интегрируется при помощи ключа /integrate, если в дистрибутив уже интегрировано обновление KB885835 (и наоборот). Возможно, со временем Microsoft исправит эту проблему, а пока используйте обходной путь, который описан в этой темена конференции OSZone.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 23.02.2005


Мeтод svcpack.inf

Автоматическая установка

Meтод svcpack.inf

В этой статье описывается как подготовить автоматическую установку обновлений, которая будет запущена за 13 минут до окончания установки Windows. Процесс установки обновлений может занять от 5 до 20 минут, в зависимости от их количества и конфигурации вашей системы.

Подготовка обновлений и файла svcpack.inf

Скопируйте все обновления в директорию C:\XPCD\I386\Update\

Все файлы обновлений должны быть переименованы в формат 8.3 (не более 8 знаков в имени файла + 3 знака на расширение). Например, файлы с именами Q819696_WXP_SP2_x86_ENU.exe и WindowsXP-KB824146-x86-ENU.exe должны быть переименованы в Q819696.exe и KB824146.exe соответственно.

Откройте Блокнот и скопируйте туда следующие строки:

[Version]
Signature="$Windows NT$"
MajorVersion=5
MinorVersion=1
BuildNumber=2600
[SetupData]
CatalogSubDir="\i386\Update"
[ProductCatalogsToInstall]
[SetupHotfixesToRun]
Q330994.exe /Q:A /R:N
Q819696.exe /Q /O /N /Z
KB824146.exe /Q /O /N /Z
qchain.exe

Сохраните файл как svcpack.inf in C:\XPCD\I386\. Вы должны удалить svcpack.in_ в директории I386, иначе программа установки Windows XP не будет использовать ваш svcpack.inf.

Примечание: я привел пример svcpack.inf для Windows XP. Если планируете использовать данный метод для Windows 2000/2003, то вам надо внести в сецкию [Version] небольшие изменения. Параметры MinorVersion и BuildNumber должны быть такими:

;Windows 2000
MinorVersion=0
BuildNumber=2195

;Windows 2003
MinorVersion=2
BuildNumber=3790

Строки, приведенные в секции [SetupHotfixesToRun], являются примерами. Все обновления, которые вы скачали, переименовали и скопировали в директорию Update должны быть добавлены в эту секцию файла в числовом порядке. Изображения ниже помогут вам определить какой синстаксис нужно использовать для ключей

Файлы, выглядящие так, должны быть установлены с использованием ключей /Q /O /N /Z | Файлы, выглядящие так, должны быть установлены с использованием ключей /Q:A /R:N
Мы называем их Type I | Мы называем их Type II

Подсказка. Чтобы не мучаться и не печатать вручную имена файлов скопируйте в Блокнот следующую строку:

dir /a /b /-p /o:gen >filelisting.txt

Сохраните файл с расширением .bat и запустите в директории, содержащей обновления, предварительно отсортировав их по имени. Затем откройте сгенерированный файл filelisting.txt и вы увидите, что он содержит имена всех файлов в директории. Ну а в файловых менеджерах типа TotalCommander должна быть функция копирования имен файлов в буфер обмена.

DOSNET.inf

Откройте файл DOSNET.inf в директории I386 в Блокноте и добавьте следующий текст в пустое место (где угодно)

[OptionalSrcDirs]
Update

QCHAIN.exe

Не забудьте добавить утилиту QCHAIN.exe в вашу директорию Update. Эта утилита проконтролирует установку самой свежей версии файла в случае если два обновления содержат одинаковые exe/dll файлы с разными номерами версий.

Скачайте и распакуйте файл, чтобы добраться до самой утилиты QCHAIN.exe внутри архива. Скопируйте QCHAIN.exe в директорию Update и затем добавьте QCHAIN.exe в самую последнюю строку (после всех обновлений) в файл svcpack.inf. Утилите не требуются никакие ключи.

Заключение

После того, как вы запишете ваш инсталляционный диск и проведете установку системы, вам не понадбится загружать критические обновления. Если вы все сделали правильно, то посетив сайт Windows Update, вы увидите примерно такую картину:

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

nLite

Oдним из назначений программы nLite является интеграция обновлений в дистрибутив Windows XP. nLite работает только с обновлениями, вышедшими после SP2 для Windows XP.

Добавление обновлений для интеграции

Запустите nLite и жмите Next пока не увидите такое окно:

Снимите выделение со всех элементов кроме "Integrate Hotfixes" и жмите Next. Вы увидите следующее окно:

Нажмите Browse и укажите путь к вашему дистрибутиву Windows XP. Затем жмите Next.

На следущем шаге вы должны выбрать обновления, которые вы хотите интегрировать в дистрибутив:

Нажмите Insert и выбирайте обновление, которое вы хотите интегрировать. Аналогично поступайте с каждым из желаемых обновлений. По окончании жмите Next

Нажмите Yes и nLite начнет процесс интеграции. Когда кнопка Next внизу экрана станет доступна, нажмите ее и вы попадете на последнее окно nLite. Нажмите Finish. Обновления интегрированы.

Примечание

В Феврале Microsoft выпустила обновление KB885250, с которым, насколько мне известно, не справляется nLite, если в дистрибутив уже интегрировано обновление KB885835 (и наоборот). Возможно, со временем Microsoft исправит эту проблему. Я, честно говоря, nLite не пользуюсь, и рекомендую интегрировать обновления вручную при помощи ключа /integrate. Такой подход позволяет использовать обходной путь, который описан в этой теме на конференции OSZone.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

Набор обновлений UpdatePack-XPSP2-Rus для русской Windows XP Professional SP2

Данный пакет подходит только для русской Windows XP. Если вас интересует набор обновлений для английской ОС, то вам нужен RyanVM's Windows XP Post-SP2 Update Pack.

Автор пакета - участник конференции OSZone Petya V4sechkin
Сайт автора
Обсуждение на конференции OSZone

Пакет предназначен для интеграции обновлений и хотфиксов в дистрибутив Windows. При этом интегрируются непосредственно файлы, извлеченные из хотфиксов (обычные методы добавляют в дистрибутив сами хотфиксы, которые запускаются из svcpack.inf при установке Windows). Очевидно, при таком подходе экономится время и место на CD-диске.

Кроме обновления файлов (в директории I386 и CAB-архивах) в SVCPACK прописываются CAT-файлы (цифровые подписи), а на этапе установки добавляется необходимая информация в реестр.

Использование

  1. Для работы скрипта нужен чистый дистрибутив Windows XP с интегрированным SP2, а также примерно 500 МБ свободного пространства на винчестере (может понадобиться для перепаковки CAB-файлов).
  2. Распаковать архив UpdatePack-XPSP2-Rus.7z в отдельную папку.
  3. В файле DISTR.INI прописать путь к дистрибутиву.
  4. Запустить скрипт __PATCH.CMD

При успешном выполнении скрипта можно увидеть следующее:

Замечания

Нельзя использовать русские буквы и специальные символы в пути к дистрибутиву, например "C:\!\Дистрибутивы\XPSP2".

Содержимое

Текущий список обновлений и компонентов, входящих в пакет, а также историю его изменений, вы можете посмотреть здесь. Обновления, увеличивающие размер дистрибутива, вынесены в отдельные аддоны (дополнения), так что Вы легко можете их удалить, если у Вас не хватает места на CD.

FAQ

Q: Где можно скачать набор обновлений?
A: Ссылки на загрузку есть на главной странице сайта автора.

Q: Есть надежда расчитывать на регулярное обновление?
A: Если люди будут этим пользоваться. Каждый месяц буду выкладывать новую версию + обновление от предыдущей (для тех, кто имеет предыдущую и не хочет качать новую целиком).

Q: Слушай,а когда выйден новое обновление к ОС,то мне как его интегрировать в дистрибутив,чтобы было так же как и с другими обновлениями?Есть ли возможность просто в папку куда-нибудь добавить скачанное обновление и всё?
A: Нет, к сожалению. Используйте стандартные методы интеграции или ждите следующей версии.

Q: Очень интересно,а это сэкономит место как я понял?Вообще это что-то вроде слипстрим windows media player?Т.е. заменяются файлы и в итоге дистрибутив почти не увеличивает размер?
A: Да, так и есть. Конечно, кроме замены файлов еще прописываются CAT-файлы и необходимая информация в реестр.

Q: Что-то много обновлений в него включено,наверно не только критические а все,т.к. когда я ставлю чистую винду и лезу на windowsupdate.com,то вылазит где-то 15 обновлений.
A: Да, не только критические. Скажем так - я постарался собрать все обновления и хотфиксы для русской XP, свободные для скачивания с сайта Microsoft.

Q: Скажите пожалуйста, а почему в наборе обновлений от RyanVM этих самых обновлений больше, чем в наборе сделанным Petya V4sechkin'ым?
A: Действительно, хотфиксов гораздо больше. Однако получить большинство из них можно, только обратившись в службу поддержки Microsoft. У меня нет ни времени, ни желания этим заниматься. Особенно учитывая, что в статьях KB, описывающих эти хотфиксы, обычно есть следующие строки:

Эта проблема может быть решена с помощью исправления, специально выпущенного корпорацией Майкрософт. Оно должно применяться только в системах, в которых наблюдается описанная выше проблема. Исправление находится на стадии дополнительного тестирования. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления Windows.

Q: При установки Windows XP с винта ругается на отсутствие следующих файлов tshoot.dll и bnts.dll приходится вручную указывать на папку с дистрибом
A: Эта проблема решена начиная с версии 5.10.12. Если она у Вас по-прежнему проявляется - значит, Вы используете nLite или WMP10 Slipstreamer, или каким-то иным способом модифицируете подписанные inf-файлы в папке I386.

Q: Очень интересует как это ты делаешь набор обновлений для XP SP2... может есть какой нибудь мануал по этому поводу или ссылка? если это не секрет то помоги мне в этом вопросе...
A: Ознакомьтесь вот с этим. Дополнительная информация для создателей аддонов здесь.

Автор: Petya V4sechkin
Иcточник: http://unattended.nm.ru/

Наш форум

Опубликована- 19.12.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 19.12.05


Автоматическая установка

Создание файла ответов

Файл ответов представляет собой скрипт ответов на серию диалоговых окон графического интерфейса установки системы. Файл ответов говорит программе установки как обращаться со всеми дополнительными файлами и папками, которые вы создали, а также предоставляет программе установки всю информацию, которую пользователь вводит в время стандартной установки Windows.

Загрузите XP SP2 Deployment Tools, и распакуйте содержимое архива. Вам понадобятся два файла: setupmgr.exe (Setup Manager) и ref.chm (справочный файл).

Setup Manager

Setup Manager представляет собой мастер создания файла ответов, и разобраться с ним не очень сложно. Для начала работы задайте мастеру следующие опции:

New or Existing Answer File: Create New

Type of Setup: Unattended Setup

Windows Product: Windows XP Home / Professional

User Interaction: Fully Automated

Distribution Share: Set up from CD

После этого примите лицензионное соглашение и заполните все поля, которые бы вы заполняли во время установки ОС. Если какой-то раздел вам непонятен, то просто пропустите его. Windows использует параметры по умолчанию для этого раздела.

После окончания работы создается файл unattend.txt (одноименный файл с расширением *.bat можно удалить). На файл unattend.txt Microsoft ссылается и в документации, однако это условное имя. Если вы планируете ставить систему с CD, то надо обязательно переименовать файл в winnt.sif. Для всех остальных вариантов установки имя и расширение значения не имеют, главное указать правильный полный путь к файлу.

Контроль над логическими дисками и форматированием

Если в процессе установки вы хотите указать определенный раздел жесткого диска и отформатировать его, то убедитесь, что файл ответов содержит следующие строки в разделах [Data] и [Unattended]:

[Data]
AutoPartition=0

[Unattended]
FileSystem=*

Тогда, во время установки система попросит вас выбрать раздел жесткого диска. Я рекомендую эти параметры указать, иначе вы рискуете установить систему не на тот раздел, на который задумали ;-) Во время текстового этапа инсталляции вы увидите список всех разделов. Если раздел не отформатирован (unpartitioned space), то его можно смело выбирать для установки и на следующем шаге вам будет предложено его отформатировать. Если раздел уже содержит операционную систему, то удалите раздел, чтобы получить возможность отформатировать его в желаемую файловую систему и установить Windows. Если такой раздел не удалять, то опций форматирования предложено не будет.

Контроль над региональными настройками, клавиатурой и локализацией

Теоретически через файл ответов можно задать лишь региональные наастройки. На практике, однако, не все так просто. Все эти вопросы подробно освещены в статье Локализация: MUI, Шрифты и Региональные настройки.

Другие параметры файла ответов

В файле ответов можно указать много различных параметров. Далеко не все, но наиболее важные, можно найти заглянув в Справочник, где есть специальная статья Параметры файла ответов. Если вы не нашли интересующей вас информации, то загляните в ref.chm, который является наиболее полным руководством по параметрам файла ответов.

Куда положить файл ответов

  • Если вы устанавливаете систему с CD, то файл ответов должен называться winnt.sif и находиться в директории i386 инсталляционного диска. При соблюдении этих двух условий файл ответов будет автоматически "подхвачен" программой установки.
  • При запуске инсталяции посредством winnt.exe или winnt32.ехе с ключами для автоматической установки, имя файла ответов может быть любым. Желательно указывать его с полным путем (вида D:\Dir\fileName)
  • Если компьютер оборудован флоппи приводом, то можно положить winnt.sif в корень флоппи диска. В таком случае, даже если в i386 на CD есть файл winnt.sif, он будет проигнорирован, а предпочтение отдано файлу на флоппи диске. Таким образом можно отменить автоматическую установку, разместив на флоппи диске пустой файл winnt.sif.

Важное примечание: инсталляционный диск, созданный при помощи файла ответов winnt.sif не будет содержать возможности восстановления системы посредством функции Repair.

Eсли вы следовали статьям раздела "Новичку" по порядку, то у вас сейчас есть дистрибутив Windows XP с интегрированными SP2 и критическими обновлениями. Есть и файл ответов, который обеспечит автоматическую установку системы. Осталось создать загрузочный диск. Следующая статья вам в этом поможет.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 14.02.2005


Автоматическая установка

Создание загрузочного ISO/CD

После того, как вы подготовите инсталляционный диск, дважды проверьте все ли правильно, включая файл ответов winnt.sif, все пакетные файлы, svcpack.inf и все остальное, что вы захотели туда включить.

Виртуальные машины

Весьма вероятно, что вы сделали ошибки, т.к. с первого раза все не всегда получается, как задумано. Лучшим способом проверить ваш диск будет виртуальная машина (VMWare или VirtualPC). Вы просто сэкономите деньги на CD болванках, а даже если вы пишете на RW, то лишнее форматирование вашему жесткому диску ни к чему. Виртуальные машины – это приложения, эмулирующие «железо» и позволяющие установить операционную систему, не затрагивая ваши существующие логические диски. Подробнее об установке и настройке виртуальных машин вы можете почитать в в этой статье.

Использование утилиты CDImage от Microsoft для создания ISO образа

CDImage – это приложение, работающее из командной строки, разработанное Microsoft для создания ISO образа из директории, содержащей поддиректории и файлы. Мы собрали в один архив CDImage.exe, файл xpboot.img, делающий ваш CD загрузочным и командый файл, который содержит все необходимые ключи для изготовления ISO образа. В итоге, получилась утилита, создающая ISO образ одним кликом мыши.

Скачать: CDImage for Windows XP Professional
Скачать: CDImage for Windows XP Home

Если вы не доверяете моему переводу, то прочитайте readme.txt, содержащий инструкции, которые я излагаю ниже.

  1. ISO Creator for WinXP Pro.cmd предполагает, что ваши файлы находятся в C:\XPCD\. а еще точнее в C:\XPCD\i386\. Если вы положили файлы в другую директорию, то отредактируйте файл в Блокноте соотвествующим образом.
  2. Файл ISO Creator for WinXP Pro.cmd может быть запущен откуда угодно при условии, что CDIMAGE.exe и xpboot.img находятся в одной с ним директории.
  3. После запуска ISO Creator for WinXP Pro.cmd файловые атрибуты "Скрытый" и "Только для чтения" снимаются с директории C:\XPCD, а также всех поддиректорий и файлов, находящихся в ней. По окончании работы программы в корневом каталоге диска C: создается ISO образ WXPFPP_EN.ISO
  4. Либо прожгите образ на CD, используя Nero или Easy CD Creator, либо смонитируйте образ в виртуальной машине для тестирования.

С альтернативным и более долгим методом создания загрузочного диска можно ознакомиться на английском на The Elder Geek или на Windows Help.net, и на русском у Ginger.

Примечания

Не рекомендуется использование программ WinISO, UltraISO и аналогичных им для редактирования ISO образа, т.к. существует риск повредить образ.

На сайте MSFN используется GUI версия CDImage. Фактически, это тот же самый CDImage "обернутый" в графическую оболочку. Конечный результат не зависит от используемой версии. Я уже привык к утилите, работающей из командной строки, и на GUI переходить не спешу. Поэтому статья MSFN о GUI CDImage не входит в число приоритетных обновлений моего сайта. Изучите ее самостоятельно, если есть желание.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 24.02.2005


Автоматическая установка

Опытному пользователю

Добро пожаловать в раздел для Опытных пользователей! Если вы успешно создали CD на основе рекомендаций раздела Новичку, то можете смело считать себя опытным пользователем ;) Материалы данного раздела помогут вам создать CD, устанавливающий также драйверы и приложения в автоматическом режиме. Добавьте к этому твики реестра, и вы получите настроенную на ваш вкус систему с уже установленными приложениями и драйверами сразу по завершении инсталляции.

Вам понадобятся:

  • Диск, созданный на основе статей раздела Новичку
  • Базовые знания пакетных файлов (*.bat или *.cmd)
  • Необходимые драйвры и любимые приложения

Предустановка OEM компонентов

Mы будем использовать $ОЕМ$ директории на инсталляционном диске для установки драйверов, приложений и твиков реестра. Чтобы это все работало, необходимо прописать два параметра в файле winnt.sif в секции [Unattended]. Откройте winnt.sif в любом текстовом редакторе и добавьте следующие строки:

[Unattended]
OemPreinstall=Yes
UnattendSwitch="yes"

OEMPreinstall=Yes сообщает Windows, что на диске находится директория $OEM$. Таким образом во время установки все содержимое директории будет скопировано на раздел жесткого диска, на который устанавливается система.

UnattendSwitch="yes" говорит Windows пропустить этап "Добро пожаловать в Windows XP", который помогает пользователю создать Учетные записи и подключение к сети Интернет.

Не забудьте, что использование виртуальных машин сильно сэкономит вам время и записываемые носители. Пожалуй, единственным недостатком виртуальных машин применительно к этому разделу будут драйверы. Их действительно нельзя протестировать на виртуальной машине. Однако, приложения, твики реестра и все остальное, обсуждаемое в этом разделе, очень удобно тестировать на виртуальной машине.

Мы начинаем с методов установки драйверов и приложений.

Автор: Vadikan
Иcточник: unattended.msfn.org

Наш форум

Опубликована- 27.02.2005


Автоматическая установка

Способы установки

В разделе для Опытных Пользователей будут рассматриваться два способа установки драйверов (если способы применимы) и приложений. Сделано это с целью дать вам общее представление о том, как все это работает. Более сложные методы установки рассматриваются в разделе для Экспертов. Однако, в большинстве случаев рассматриваемых ниже способов будет вполне достаточно.

Прежде чем начать изучение способов установки приложений и драйверов, ознакомьтесь со статьей Ключи для приложений (основы).

Итак, вашему вниманию предлагаются два способа:

  • Пакетные файлы

  • RunOnceEx

  • Автор: Vadikan
    Иcточник: (переведено с английского) unattended.msfn.org

    Наш форум

    Опубликована- 25.02.2005


Автоматическая установка

Пакетные файлы (*. bat или *.cmd)

Прежде чем мы приступим к созданию пакетных файлов для установки любимых приложений и изменений в реестре, вы, вероятно, захотите узнать что же это за файлы и как ими пользоваться.

Пакетные файлы (*.cmd или *.bat) могут быть выполнены на различных стадиях установки Windows. Использование пакетных файлов помогает автоматизировать выполнение нескольких заданий. При этом никакого вмешательства пользователя не требуется.

Эти файлы могут быть выполнены из cmdlines.txt, svcpack.inf, RunOnceEx раздела в Реестре, или из секции [GuiRunOnce] в файле winnt.sif. Мы подробнее разберем различные варианты чуть позже.

Типичное содержимое пакетного файла

Пакетные файлы поддерживают все команды, которые могут быть выполнены из командной строки. Чтобы увидеть командую строку достаточно проделать следующее: Пуск->Выполнить->cmd->ОК

Давайте попробуем сделать простенький пакетный файл. Откройте Блокнот и скопируйте туда следующий текст:

title Batch File Testing
echo Hello World
echo.
echo Starting Notepad
start notepad
echo.
echo Starting Wordpad
start Wordpad
echo.
pause
exit

Сохраните файл с любым именем и в любом месте. Убедитесь, что вы назначили расширение *.cmd (а не .txt, которое Блокнот присвоит по умолчанию). Теперь запустите ваш файл. Вы увидите, что он назначит окну имя "Batch File Testing", запустит Блокнот и WordPad, попросит нажать любую клавишу для продолжения работы и закроет окно.

Что означают команды, использованные в данном файле?

@echo off | Скрывает строку C:\> и все команды, используемые в пакетном файле
echo. | Создает пробел между строками
echo message | Отображает сообщение в окне, исключительно с информационными целями
title | Название окна
start | Запускает приложение или установочный процесс
pause | Отображает сообщение "Press any key to continue..." ("Нажмите любую клавишу для продолжения..."
exit | Закрывает командную строку

Когда вы начнете добавлять приложения для автоматической установки с инсталляционного диска XP, вы увидите, что в большинстве случаев команды будет выглядить примерно так:

start /wait %systemdrive%\install\some_application\setup.exe /ключ /еще ключ

start запустит установку приложения, а /wait дождется ее окончания перед тем, как выполнить установку следующего приложения. Использование /wait очень важно, т.к. в противном случае одновременно запустится установка сразу нескольких приложений и конфликты неизбежны.

Вы всегда можете обратиться к странице Примеров, где можно увидеть различные примеры применения пакетных файлов.

Изменение цветовой гаммы

Во время установки окно, с выполняющимися командами, будет выглядеть так. Несколько мрачновато, но это можно разнообразить, сделав фон и шрифт цветными. Цвета задаются в десятичном (hex) исчислении, и формат назначения цветов выглядит как color хх. Первая цифра означает фон, вторая - шрифт. Допустимы следующие значения цветов:

0 = Black (черный) | 8 = Gray (серый)
1 = Blue (синий) | 9 = Light Blue (голубой)
2 = Green (зеленый) | A = Light Green (светло-зеленый)
3 = Aqua (морской волны) | B = Light Aqua
4 = Red (красный) | C = Light Red
5 = Purple (фиолетовый) | D = Light Purple
6 = Yellow (желтый) | E = Light Yellow
7 = White (белый) | F = Bright White

Таким образом для ярко-белого шрифта и голубого фона вы используете color 9F.

Чтобы посмотреть как это выглядит на практике, скопируйте текст в блокнот и сохраните файл как colors.cmd.

cls
@echo off
Title Graphics group is being installed now
color 9F
ECHO Adobe Photoshop 7.0
ECHO ACDSee 6.0.3
PAUSE
Title Internet group is being installed now
color 57
ECHO Stay Connected! 3.5
ECHO MSN Messenger 6.2
PAUSE
EXIT

Примечание: команда PAUSE дана исключительно для того, чтобы можно было рассмотреть все получше. В реальном файле установка пойдет без остановки. В данном примере подается идея группировки приложений по типу (Графика, Интернет) и назначения им различных цветовых групп. Чтобы очистить экран перед каждой группой можно вставлять @CLS перед строкой Title.

cmdlines.txt, svcpack.inf и [GuiRunOnce]

Пакетные файлы могут быть запущены из cmdlines.txt или svcpack.inf, которые будут исполнены на Т-13/Т-12 этапе установки Windows (Т-13 означает 13 минут до окончания установки).cmdlines.txt удобен для таких задач как Добавление Пользователей, или для импортирования заранее подготовленных ключей реестра HKEY_CURRENT_USER в профиль по умолчанию (Default Profile). Подробнее о cmdlines.txt можно почитать в соответствующей статье в разделе Справочник.

Метод svcpack.inf, как правило, используется для установки обновлений (хотфиксов). Однако ничто не мешает рассматривать пакетный файл как еще один хотфикс.

Пример пакетного файла, запущенного из [GuiRunOnce] (скриншот).

Как вы видите, здесь используется комбинация ECHO и ECHO Message. Делать это не обязательно, но рекомендуется, т.к. дает возможность видеть как происходит процесс инсталляции приложений в реальном времени. [GuiRunOnce] запускается при первом входе в систему.

Пример содержимого пакетного файла:

@echo off
TITLE Windows XP SP2 - Unattended Installation
ECHO.
ECHO Over the next few minutes you will see automated installations
ECHO of various sofware applications, and registry tweaks being
ECHO implemented.
ECHO.
ECHO Removing Wallpapers and Screensavers...
DEL "%systemroot%\*.bmp"
DEL "%systemroot%\Web\Wallpaper\*.jpg"
DEL "%systemroot%\system32\dllcache\*.scr"
DEL "%systemroot%\system32\*.scr"
ECHO.
ECHO Removing useless shortcuts...
DEL "%systemdrive%\Documents and Settings\All Users\Start Menu\Windows
Update.lnk"
DEL "%systemdrive%\Documents and Settings\All Users\Start Menu\Set
Program Access and Defaults.lnk"
DEL "%systemdrive%\Documents and Settings\All Users\Start Menu\Windows
Catalog.lnk"
ECHO.
ECHO Installing TweakUI 2.10 Powertoy
ECHO Please wait...
start /wait %systemdrive%\Install\TweakUI.msi /qn
ECHO.
ECHO Applying Registry Tweaks...
REGEDIT /S %systemdrive%\Install\RegTweaks.reg
ECHO.
ECHO Deleting ASP.NET User Account created by .NET Framework 1.1...
net user aspnet /delete
ECHO.
EXIT

Он производит удаление обоев и скринсэйверов, устанавливаемых по умолчанию системой, а также некоторых ярлыков. Затем устанавливает TweakUI, импортирует ключи реестра и удаляет учетную запись ASP.NET, созданную при установке .NET Framework. Более содержательный файл вы можете посмотреть на странице примеров.

Куда положить пакетные файлы?

O [GuiRunOnce] рассказывает отдельная небольшая статья в разделе Справочник.

cmdlines.txt нужно положить в директорию $OEM$, и Windows автоматически найдет его во время установки. Все пакетные файлы, запускаемые из cmdlines.txt, должны находиться в той же директории, что и cmdlines.txt.

svcpack.inf кладется в директорию I386 на вашем инсталляционном диске (не забудьте удалить svcpack.in_ оттуда). Все пакетные файлы, запускаемые из svcpack.inf, должны находиться в директории I386\svcpack, если только это не прописано иначе в самом файле.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 14.02.2005


Автоматическая установка

RunOnceEx

Установку приложений, импортирование ключей реестра и прочие задачи можно выполнять при помощи пакетных файлов, запускаемых из [GuiRunOnce]. Если вы хотите, чтобы все вышеперечисленные задачи сопровождались элегантным пользовательским интерфейсом, то вникайте в содержимое данной статьи.

С чего начать?

В первую очередь уберите раздел [GuiRunOnce] из winnt.sif, т.к. RunOnceEx его полностью заменит. Можно, в приницпе, и скомбинировать оба метода, но поскольку они будут выполнены одновременно (при первом входе в систему), то возможны конфликты.

Чтобы запустить RunOnceEx при первом входе в систему нам надо импортировать некоторые ключи реестра во время программы установки Windows. Мы можем это проделать при помощи файла cmdlines.txt, который исполняет серию команд за 12 минут до окончания установки системы. Создайте в Блокноте файл cmdlines.txt и скопируйте туда следующие строки:

[COMMANDS]
"RunOnceEx.cmd"

Сохраните файл как cmdlines.txt в C:\XPCD\$OEM$\

Создание вашего RunOnceEx.cmd файла

Файл будет содержать синтаксис REG.exe для импортирования ключей в реестр. Такой способ позволяет использовать системную переменную %systemdrive%.

Ниже приводится пример, на основе которого мы будем разбираться подробнее.

cmdow @ /HID
@echo off

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY% /V TITLE /D "Installing Applications" /f

REG ADD %KEY%\001 /VE /D "Preparing Installation..." /f
REG ADD %KEY%\001 /V 1 /D "%systemdrive%\install\prepare.cmd" /f

REG ADD %KEY%\005 /VE /D "Adobe Reader 6" /f
REG ADD %KEY%\005 /V 1 /D "%systemdrive%\install\AdobeReader6\AR6.msi /qn" /f

REG ADD %KEY%\010 /VE /D "Alcohol 120" /f
REG ADD %KEY%\010 /V 1 /D "%systemdrive%\install\alcohol\setup.exe /qn" /f
REG ADD %KEY%\010 /V 2 /D "REGEDIT /S %systemdrive%\install\alcohol\register.reg" /f

REG ADD %KEY%\015 /VE /D "Diskeeper 8" /f
REG ADD %KEY%\015 /V 1 /D "%systemdrive%\install\DiskeeperPro_8.0.459.exe /s /v/qn" /f

REG ADD %KEY%\020 /VE /D "DU Meter 3" /f
REG ADD %KEY%\020 /V 1 /D "%systemdrive%\install\dumeter3.exe /VERYSILENT /SP-" /f

REG ADD %KEY%\025 /VE /D "IsoBuster 1.5" /f
REG ADD %KEY%\025 /V 1 /D "%systemdrive%\install\IsoBuster1.5.exe /VERYSILENT /SP-" /f
REG ADD %KEY%\025 /V 2 /D "taskkill /F /IM isobuster.exe" /f

REG ADD %KEY%\030 /VE /D "Kerio Personal Firewall 2.1.5" /f
REG ADD %KEY%\030 /V 1 /D "%systemdrive%\install\KPF\Setup.exe -s" /f

REG ADD %KEY%\035 /VE /D "MDAC 2.7 SP1 Hotfix" /f
REG ADD %KEY%\035 /V 1 /D "%systemdrive%\install\mdac\mdac.cmd" /f

REG ADD %KEY%\040 /VE /D "MSN Messenger 6.1" /f
REG ADD %KEY%\040 /V 1 /D "%systemdrive%\install\MSN_Messenger_6.1.0202.msi /qn" /f

REG ADD %KEY%\045 /VE /D "Nero Burning ROM 5.5" /f
REG ADD %KEY%\045 /V 1 /D "REGEDIT /S %systemdrive%\install\nero\register.reg" /f
REG ADD %KEY%\045 /V 2 /D "%systemdrive%\install\Nero\Nero551054.exe /silent /noreboot" /f

REG ADD %KEY%\050 /VE /D "Importing Registry Tweaks" /f
REG ADD %KEY%\050 /V 1 /D "REGEDIT /S %systemdrive%\install\regtweaks.reg" /f

REG ADD %KEY%\055 /VE /D "Cleaning Up and Rebooting" /f
REG ADD %KEY%\055 /V 1 /D "%systemdrive%\install\cleanup.cmd" /f

EXIT

Сохраните файл как RunOnceEx.cmd в директории C:\XPCD\$OEM$\.

Вы наверное заметили, что строки, обозначающие ключи реестра, нумеруются не подряд, а с шагом 5. Это сделано для того, чтобы было легче работать с файлом, в случае если вам надо добавить приложение между двумя существующими ключами. Например, имея 001 и 005 мы легко можем вставить дополнительные ключи 002, 003, 004. Изменяйте как вам удобно. Задачи будут выполняться в цифровом порядке.

RunOnceEx.cmd в деталях

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

Обозначает адрес в реестре HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx как переменную %KEY%. Делая это мы избегаем необходимости указывать полный путь при каждом использовании REG ADD.

REG ADD %KEY% /V TITLE /D "Installing Applications" /f

Обозначает заголовок окна. Слова заключенные в кавычки можно менять по вашему усмотрению.

REG ADD %KEY%\010 /VE /D "Alcohol 120" /f

Обозначает название приложения или задания, которое выполняется. Будет отображаться в окне RunOnceEx. Т.е. вы меняете текст в кавычках в зависимости от исполняемого приложения.

REG ADD %KEY%\010 /V 1 /D "%systemdrive%\install\alcohol\setup.exe /qn" /f
REG ADD %KEY%\010 /V 2 /D "REGEDIT /S %systemdrive%\install\alcohol\register.reg" /f

Вы можете наначить несколько заданий для приложения "Alcohol 120", используя /V 1, 2, 3. Как вы видите на скриншоте, маленькая стрелочка не передвинется к следующему заданию до тех пор, пока текущее не будет выполнено. В данном примере первая строка устанавливает приложение, а вторая вводит регистрационную информацию (серийный номер и т.д.) в реестр при помощи заранее подготовленного *.reg файла. Все что нужно - это продублировать каждую строку REG ADD, но изменить нумерацию и текст, заключенный в кавычки. Для более подробной информации запустите команду REG ADD /? из командной строки.

cmdow.exe

Что такое cmdow @ /HID? Это утилита предназначенная для скрытия командой строки от глаз пользователя. Вы можете скачать cmdow.exe отсюда (14кб). Поместите cmdow.exe в директорию C:\XPCD\$OEM\$$\System32\, чтобы утилита скопировалась в директорию Windows\System32 во время установки. Это позволит использовать утилиту из любой директории без указания прямого пути к ней.

Приложения, использующие кавычки

Вы заметите, что при добавлении дополнительных кавычек (" ") к значениям REG ADD, эти значения не импортируются в реестр. Чтобы обойти это препятствие используйте обратную косую черту (backslash) \" для каждых кавычек, которые вы добавляете. Пример:

%KEY%\005 /V 1 /D "\"%systemdrive%\install\AdobeReader6\Adobe Reader 6.msi\" /qn" /f

Это позволит запускать приложения, которые содержат пробелы в именах файлов (надежнее, правда, переименовать их заранее), а также использовать ключи приложений, которые надо заключать в кавычки.

Prepare.cmd и Cleanup.cmd

Этот пункт необязателен. Вы можете использовать исполняемые файлы для выполнения задач, которые проще запустить отдельно, чем добавлять их в строки REG ADD в файле RunOnceEx.cmd. Чтобы увидеть как они запускаются, посмотрите пример файла RunOnceEx.cmd выше. В принципе, запуск их ничем не отличается от запуска других приложений и *.reg файлов.

Prepare.cmd может содержать все что вы хотите выполнить

cmdow @ /HID

DEL "%systemroot%\*.bmp"
DEL "%systemroot%\Web\Wallpaper\*.jpg"
DEL "%systemroot%\system32\dllcache\*.scr"
DEL "%systemroot%\system32\*.scr"

DEL "%AllUsersProfile%\Start Menu\Windows Update.lnk"
DEL "%AllUsersProfile%\Start Menu\Set Program Access and Defaults.lnk"
DEL "%AllUsersProfile%\Start Menu\Windows Catalog.lnk"

EXIT

Если вы не понимаете, что делает данный файл, то не используйте его. Вкратце, он удаляет все обои и скринсэйверы, используемые в Windows по умолчанию, а также удаляет различные ярлыки из меню Пуск.

Cleanup.cmd может содержать команды для удаления ненужных директорий и перезагрузки компьютера после установки всех приложений.

cmdow @ /HID

shutdown.exe -r -f -t 30 -c "Windows XP will now restart in 30 seconds..."
net user aspnet /delete
RD /S /Q %systemdrive%\drivers\
RD /S /Q %systemdrive%\install\

EXIT

Вы можете объединить оба файла в один, без разницы.

Резюме

RunOnceEx.cmd будет выполнен во время графического этапа установки Windows, когда до конца останется 12 минут. После перезагрузки и первого входа в систему RunOnceEx будет запущен, как показано здесь.

Вы можете протестировать RunOnceEx.cmd, запустив его. Все что он делает - это импортирует ключи реестра в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx\. Вы можете открыть редактор реестра и проверить все ли импортировалось. После того, как вы убедитесь, что все правильно, удалите эти параметры. В противном случае при следующем входе в систему Windows попытается выполнить все команды.

Преимущества использования RunOnceEx:

  • Выглядит красиво и профессионально для конечного пользователя
  • Легко видоизменяется

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 25.02.2005


Автоматическая установка

Приложения

В этой секции мы расскажем как устанавливать приложения автоматически (без участия пользователя). На страницах секции вы увидите различные команды для пакетных файлов, которые вы сможете добавить в свои пакетные файлы, запускаемые из [GuiRunOnce]. Вы можете посмотреть как это сделано у меня на странице Примеры в файле start.cmd. Эти же команды после небольших модификаций можно использовать и для способа RunOnceEx.

С чего начать

Вы хотите установить приложение автоматически, но не знаете какой ключ использовать? Статья Типы инсталляторов рассказывает о пяти наиболее часто используемых типах инсталляторов. На странице Примеры установки приложений рассказывается об установке нескольких программ. MSFN работает над базой данных ключей для автоматической установки приложений, и это будет просто уникальный ресурс. Если ваши поиски еще не увенчались успехом, то попробуйте такие ключи:

  • /silent
  • /s или /S
  • /?
  • /help

Также можно воспользоваться программой Universal Switch Finder, созданной одним из участников форума MSFN. Программа как раз и предназначена для определения ключей.

Все еще не нашли? Попробуйте поиск по названиям тем в форуме Автоматическая Установка конференции OSZone. Более информативным может быть поиск по форуму Application Switches конференции MSFN.

Если ничего не помогает...

Вы можете использовать программы, которые отслеживают все изменения в системе во время установки приложений и создают свой установочный пакет, который включает все изменения файлов и ветвей реестра. Примеры таких программ:

  • WinInstall LE 2003 (Freeware) Используйте `Discover` Wizard
  • InstallRite (Freeware)
  • Symantec AI Snapshot (входит в корпоративную версию Norton Ghost

Eще одно полезное приложение - AutoIT (Freeware). С его помощью можно создать скрипты, эмулирующие действия пользователя при "нормальной" установке приложения. Не забудьте проверить коллекции AutoIt скриптов на MSFN и OSZone.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 26.02.2005


Версия для печати

Автоматическая установка

Типы инсталляторов

В этой статье мы расскажем о наиболее распространенных инсталляторах, используемых производителями программного обеспечения для упаковки своих программ. Все инсталляторы поддерживают те или иные ключи автоматической установки.

InstallShield | Windows Installer Service (*.msi) | InstallShield с MSI

InnoSetup | Nullsoft SuperPiMP Install System (NSIS) | Wise Installer

InstallShield

Чтобы автоматически установить приложение, использующее InstallShield, вам надо предварительно создать файл setup.iss на рабочей ОС.

  1. Запустите приложение приложение из командной строки, используя ключ /r (например, Setup.exe /r)
  2. Пойдет процесс установки, вы будете отвечать на вопросы - все как обычно. Главное, не выбирайте опцию перезагрузки компьютера сразу после установки ("Restart the computer now")
  3. После окончания установки зайдите в вашу системную директорию (C:\Windows) и извлеките оттуда файл setup.iss. Перед автоматической установкой положите файл в директорию, где лежит ваша программа.

В принципе, достаточно запустить автоматическую установку приложения таким образом:

start /wait %systemdrive%\install\setup.exe /s

Проблема в том, что инсталлятор раздваивается на два процесса и закрывает первый, так что start /wait отрабатывает вхолостую. Вы, наверняка, захотите поместить эту команду в пакетный файл, устанавливающий также и другие приложения. В таком случае правильнее использовать еще и ключ /sms, который заставит инстяллятор дождаться окончания установки приложения. Таким образом, команда будет выглядеть так:

start /wait %systemdrive%\install\setup.exe /s /sms

Установка InstallShield приложений методом RunOnceEx с CD

При установке приложений, использующих InstallShild, методом RunOnceEx с CD нужно указывать путь к лог-файлу (*.log). Для примера ниже приводятся команды на установку Kerio Personal Firewall. Путь к лог-файлу выделен.

REG ADD %KEY%\045 /VE /D "Kerio Personal Firewall 2.1.5" /f
REG ADD %KEY%\045 /V 1 /D "%CDROM%\apps\KPF\Setup.exe -s -f2\"%systemdrive%\kerio.log\"" /f

Как узнать используется ли InstallShield для упаковки вашей программы?

Большинство из них может быть извлечено из установщика, в свойствах установочного файла (который, кстати, всегда называется setup.exe) будет что-то типа "InstallShield (R) Setup Launcher", и наконец наличие файла setup.iss в системной директории развеет все сомнения.

Windows Installer Service (*.msi)

Если у вашего файла расширение *.MSI, значит он был запакован при помощи Windows Installer. Эти файлы можно устанавливать с ключами /qb и /qn. Вкратце, /qb и /qn аналогичны. Первый покажет прогресс установки, а второй полностью скроет все окна и незаметно установит приложение. Если вы хотите отобразить прогресс установки, но не показывать кнопку Cancel, исключая возможность прерывания установки пользователем, то используйте ключ /qb-!.

Некоторые приложения требуют перезагрузки компьютера после установки. Чтобы этого избежать испольzуйте свойство REBOOT=ReallySuppress вместе с /qn или /qb, заключая все выражение в кавычки. Например:

setup.msi "/qn REBOOT=ReallySuppress"

Подробнее о ключах Windows Installer можно почитать в этой статье MSDN.

InstallShield с MSI

Начиная с версии 7 InstallShield способен производить MSI файлы. Приложения могут быть в виде отдельных MSI файлов или поставляться с установщиком setup.exe. Последние в свою очередь бывают двух типов: "InstallScript MSI" и "Basic MSI". InstallScript MSI использует традиционные ключи InstallShield. Basic MSI - отдельная история.

Чтобы автоматически установить приложение, использующее Basic MSI, вам нужно указать ключи /s /v"...". Многоточие нужно заменить на ключи, которые вы хотите передать непосредственно Windows Installer (msiexec). Иными словами, если вы хотите установить приложение абсолютно незаметно и избежать перезагрузки, то используйте такую команду

setup.exe /s /v"/qn REBOOT=ReallySuppress"

Inno Setup

Приложения, запакованные Inno Setup, поддерживают ключи /SILENT и /VERYSILENT (разница лишь в том, что второй не показывает полосу прогресса во время установки)

setup.exe /VERYSILENT

Есть небольшая проблемка. Вам захочется избавиться от окна, спрашивающего хотите ли вы продолжить установку:

Чтобы подавить это окошко используйте такой ключ:

setup.exe /VERYSILENT /SP-

Осталась еще одна проблема. Некоторые инсталляторы Inno Setup попытаются запустить программу по окончании установки. ISOBuster как раз такой случай. Тогда приходится убивать процесс, используя встроенную в Windows утилиту Taskkill. Ниже пример кода для установки ISOBuster:

ECHO.
ECHO Installing ISOBuster 1.4
ECHO Please wait...
start /wait %systemdrive%\install\Applications\ISOBuster\IsoBuster14.exe /VERYSILENT /SP-
ECHO.
ECHO Killing ISOBuster.exe process

taskkill.exe /F /IM isobuster.exe
ECHO .

Подробнее о ключах InnoSetup вы можете почитать в этой теме на конференции OSZone (спасибо, Mchik).

Как узнать используется ли Inno Setup для упаковки вашей программы?

При запуске инсталлятора в самом первом окне кликните на иконку в левом верхнем углу и выберите пункт About Setup из меню.

Nullsoft SuperPiMP Install System (NSIS)

Приложения, использущие NSIS, запускаются с ключом -S (например, Setup.exe /S). Вы также можете использовать ключ /D для указания директории установки. Ниже пример установки программы CD-ex:

Setup.exe /S /D=E:\Software\CDex

Приложения Winamp и CDex показывают диалоговое окно, сообщающее об окночании инсталляции. Как это обойти - непонятно, но это не повлияет на остальные пакетные команды. Отмечу, что CD-ex можно устанавливать без инсталлятора.

Как узнать используется ли NSIS для упаковки вашей программы?

Смотрите скриншот, он примерно одинаков для всех приложений

WISE Installer

Программы, запакованные WISE Installer, используют ключ /s. Все что нужно, это

Setup.exe /s

Как узнать используется ли WISE Installer для упаковки вашей программы?

Большинство будет показывать заставку в начале инсталляции

Другие же могут развернуть окно с темно-синим фоном во весь экран, отображая окно установки в центре.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 26.02.2005

© Все права защищены OSzone.net 2001-2005

Распечатано 10.04.05


Автоматическая установка

Примеры установки приложений

Общие принципы

Kак вы уже, вероятно, поняли из предыдущих статей, для автоматической установки приложений их необходимо запускать с определенными ключами. Если вы не в курсе о чем речь, то рекомендую заглянуть в Справочник, где есть статья излагающая принципы использования ключей. Ключи могут различаться в зависимости от типа установщика, который был использован для конкретной программы. Подробнее об установщиках читайте тут.

Некоторые приложения вообще не требуют установки, и могут быть помещены в $OEM$\$Progs. Таким образом они будут скопированы в папку Program Files автоматически во время установки Windows. К таким приложениям относятся

  • Proxomitron 4.5
  • CD-EX 1.51
  • E-dialer
  • IrfanView 3.85 + plugins
  • mIRC 6.12
  • Reget Download Manager 3.3

Их можно распаковать (установить) на тестовой машине, а затем скопировать в $OEM$\$Progs. Наверняка, есть и другие, я лишь перечислил некоторые известные мне.

Ниже я приведу несколько примеров установки программ с использованием ключей. Для примера синтаксиса я возьму приложение TweakUI (198 kb), которое было специально перепаковано для автоматической установки (архив содержит MSI пакет). В зависимости от того, какой метод установки вы используете (GuiRunOnce или RunOnceEx), синтаксис будет отличаться, но основную часть я в обоих случаях выделю, чтобы было понятно как информация будет подаваться в дальнейшем. Учтите, что в некоторых случаях синтаксис ключей учитывает верхний или нижний регистр, так что может оказаться, что -S и -s не одно и тоже. Также, следите за именами файлов приложений, поскольку я использовал те, что были в моем распоряжении, а ваши могут слегка отличаться.

TweakUI

Итак, допустим, что вы запускаете пакетный файл start.cmd из [GuiRunOnce]. Тогда в этот файл надо включить следующие строки

ECHO Installing TweakUI 2.10 Powertoy
ECHO Please wait...
start /wait %systemdrive%\Install\TweakUI.msi /qn
ECHO.

Если же вы используете RunOnceEx, то тогда в этом файле должны быть следующие параметры

REG ADD %KEY%\020 /VE /D "TweakUI" /f
REG ADD %KEY%\020 /V 1 /D "%systemdrive%\Install\TweakUI.msi /qn" /f

Думаю, что понятно, что приложение TweakUI.msi запускается с ключом /qn. Обратите внимание, что во втором методе используются кавычки, впрочем это относится к синтаксису файла RunOnceEx.cmd, а не к ключам приложения.

Теперь посмотрим какие ключи используются для других приложений.

Adobe Acrobat Reader 7

Существует две версии Acrobat Reader 7 - full и basic. Различий в установке фактически нет. Начиная с одного из релизов седьмой версии программа поддерживает ключ /s /v" /qn". Таким образом нерaзбериху с ключами, присущую более ранним версиям Adobe Acrobat, можно считать исчерпанной. Для установки из пакетного файла команда будет выглядеть так:

%systemdrive%\Install\AdbeRdr70_enu_full.exe /s /v" /qn"

Если же вы используете RunOnceEx, то тогда в этом файле должны быть следующие параметры

REG ADD %KEY%\025 /VE /D "Adobe Reader 7" /f
REG ADD %KEY%\025 /V 1 /D "%systemdrive%\Install\AdbeRdr70_enu_full.exe /s /v\" /qn\"" /f

Тем не менее, вы можете захотеть создать безключевой инсталлятор, который установит Adobe Reader без каких-либо видимых диалоговых окон. Созданию таких инсталляторов посвящена отдельная статья.

Microsoft Office 2003 + MUI

Этому посвящен целый ряд статей.

Nero Burning Rom 5.5.10.x

Если у вас есть серийный номер, то можно создать регистрационный файл, и запустить его перед выполнением установки Nero. Скопируйте в блокнот следующие строки

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Ahead\Nero - Burning Rom\Info]
"User"="InsertName"
"Company"="InsertCompanyName"
"Serial5"="InsertSerial"

Вставьте имя пользователя, организацию и номер и сохраните файл как register.reg в той же директории, что и Nero. Тогда установка будет проходить так:

REGEDIT /S %systemdrive%\Install\register.reg
%systemdrive%\Install\Nero551054.exe /silent /noreboot /no_ui

Регистрация позволяет избежать создания папки Nero Demo в меню Пуск.

Nero Burning Rom 6.3.0.x

Принцип такой же. Можно использовать регистрационный файл, а можно добавить серийный номер в виде ключа при запуске приложения. Дело в том, что начиная с версии 6.0.0.15 установщик Nero слегка изменился и стал поддерживать новые ключи. Если вы все-таки используете регистрационный файл, то замените "Serial5" на "Serial6" в примере, приведенном выше. Пример с запуском Nero вместе с вводом серийного номера:

%systemdrive%\Install\nero6303.exe /silent /noreboot /no_ui /sn=xxxx-xxxx-xxxx-xxxx-xxxx-xxxx /write_sn

Nero Language Pack (языковой модуль)

Языковые модули для версий 6.х используют такие же ключи, как и основная программа: /silent /noreboot /no_ui. Впрочем, на MSFN я видел, что язык модуля все равно не ставится языком по умолчанию, и приходится выбирать его вручную или искать обходные пути. Я, лично, этот момент не проверял.

Для версии 5.5.10.х можно сделать следующим образом. Запустите установку языкового модуля, дождитесь распаковки файлов, и отмените установку. Во временной директории профиля пользователя (%TEMP%) создается директория Nero.tmp, куда распаковались все файлы. Оттуда можно удалить файлы setup.cfg и setup.exe, а также файлы справки, если они вам не нужны.

Создайте директорию CoverDesigner и переместите туда файл covered-rus.nls и файл справки. Создайте директорию Nero, в которую переместите файлы NeroRus.nls и nerorus.txt и уже имеющуюся директорию WaveEditor.

Теперь содержимое директории нужно запаковать в самораспаковывающийся RAR архив примерно так, как это описано ниже на примере Adobe Acrobat или любым другим известным вам способом. Например, добавляя в Комментарий к архиву такие строки:

path=Ahead
Silent=1
Overwrite=1

Путь для распаковки архива будет %programfiles%\Ahead\. Последним штрихом будет создание reg файла, для назначения русского языка интерфейса языком по умолчанию.

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Ahead\Nero - Burning Rom\Language]
"Current"="\"RUS,ENG\""

Opera 8.x

Opera без Javа VM устанавливается при помощи ключа /s:

%systemdrive%\Install\ow32enen851.exe /s

Java VM можно установить отдельно. Скачать ее можно с сайта Sun (выберите Windows Offline Installation). А если у вас есть версия Opera с Java, то можно извлечь Java VM из инсталляционного файла Оперы. В любом случае, используйте следующие ключи:

%systemdrive%\Install\j2re-1_4_2_01-windows-i586.exe /s /v/qn

TotalCommander 6.x

С ним я тоже разбирался сам, хотя идея была почерпнута с форума msfn.org. Этому приложению ключи не нужны, однако надо произвести некоторые манипуляции, чтоб оно устанавливалось автоматически. Надо изменить содержание файла INSTALL.INF и перепаковать архив. Проще всего это сделать прямо в TotalCommander (TC), выделив инсталляционный файл и нажав CTRL+PageDown. Затем надо открыть INSTALL.INF и изменить его следующим образом.

[Installation]
program=Total Commander 6.0
progname=Total Commander
copyright=Copyright © 1993-2003 by Christian Ghisler, All Rights reserved

[auto]
;Значение auto=1 обозначает автоматическую установку
auto=1
;Язык установки - английский
lang=1
alllang=0
;Расположение ini файла. Можете изменить на свое.
iniloc="%programfiles%\TotalCmd"
iniall=0
;Параметр mkgroup=1 создаст группу в меню Пуск,
;но тогда в конце установки откроется окно Проводника, показывающее ярлыки
mkgroup=0
;Создает ярлык на Рабочем Столе
mkdesktop=1

[Versioncheck]
Vernum=2

[Not running]
1=WINDOWSCMD,Windows Commander
2=TTOTAL_CMD,Total Commander
3=TAPPLICATION,Windows Commander,Windows Commander
4=TAPPLICATION,Total Commander,Total Commander

[Destination]
;Директория, в которую будет установлена программа. Измените на свою.
Dir="%programfiles%\TotalCmd"
Ini=wincmd.ini,Configuration,InstallDir

[Languages]
;Лишние языки удалены
Count=1
Default=1
1=English

[LangName]
langdir=language
0=wcmd_eng

;Save data the user may have changed!
[Backup data]
1=default.bar
2=no.bar

[Install]
1=install.cab,c

[Installd]
1=install.cab,c

[Desktop]
1=totalcmd.exe","Total Commander.lnk

[Group]
Groupname=Total Commander
1=totalcmd.exe","Total Commander 32
2=totalcmd.hlp","Total Commander Help
3=tcuninst.exe","Uninstall or Repair Total Commander

[ini]
1=wincmd.ini,configuration,languageini
2=wincmd.ini,configuration,Mainmenu

Скопируйте в Блокнот, чтоб лучше рассмотреть. Сделайте необходимые изменения в вашем файле INSTALL.INF в зависимости от вашей конфигурации. После того как вы сконфигурируете файл должным образом, просто закройте его и сохраните изменения, согласившись на предложение TC перепаковать архив. После всех изменений установка TC будет осуществляться так:

%systemdrive%\Install\tcmdr600.exe

А вообще, TotalCommander прекрасно работает и без установки. Его можно просто запаковать в самораспаковывающийся архив.

Windows Media Player 10

%systemdrive%\Install\MP10Setup.exe /q:A /c:"setup_wm.exe /Q /R:N /DisallowSystemRestore"

Windows Multilanguage User Interface (MUI)

Установка MUI подробно рассматривается в статье Локализация: MUI, Шрифты и Региональные настройки.

WinRar 3.x

%systemdrive%\Install\wrar330ru.exe /s

В случае использования ключа /s производится полностью автоматическая установка, WinRar будет ассоциирован со всеми типами архивов, а также создаст группу в меню Пуск и интегрируется в оболочку. Если же использовать ключ /silent, то пользователю будет предложено выбрать какие из вышеперечисленных функций он хочет использовать.

Регистрационный файл rarreg.key нужно поместить в директорию программы. Это можно сделать либо при положив его в $Progs\Winrar или используя команду xcopy в любом пакетном файле.

Настройки архиватора можно заранее сохранить в файл settings.reg из меню Параметры->Импорт/Экспорт (Options-->Import/Export), а во время автоматической установки экспортировать при помощи команды REGEDIT /S.

Резюме

Для того, чтобы протестировать автоматическую установку приложений, совсем необязательно проходить через весь процесс установки Windows. Можно запускать приложения из командной строки со всеми указанными ключами и смотреть, что получится. А можно и пакетный файл создать, для запуска сразу нескольких приложений. Как это делать вы уже знаете.

Как я уже сказал выше, это лишь небольшая часть приложений, которые можно установить автоматически. Где искать ключи к остальным приложениям вы знаете. Другой вопрос насколько стоит увлекаться установкой приложений - ведь новые версии выходят достаточно часто, и установочный диск морально устаревает. В любом случае, это все очень интересно, и я рад возможности об этом рассказать.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 27.02.2005


Автоматическая установка

Программа Multiset - автоматизация установки приложений

Введение

Работа на компьютере немыслима без постоянного процесса установки необходимого софта. Для быстрой установки можно использовать так называемые "образы" дисков, т.е. точные копии физических дисков. В этом случае, необходимо просто копировать образ на нужную машину, при этом естественно, все текущие данные на диске затираются.

А как быть если необходимо установить на каждую машину 3-4 новые программы, без перезаписи всей системы? Второй способ решения может выглядеть так: записать на диск необходимые дистрибутивы и ходить с ним от ПК к ПК, занимаясь рутинными действиями: нажатием кнопочек Next, Finish и расстановкой необходимых отметок в диалогах. Это все хорошо, если обслуживаемых машин не очень много 1 - 5, т.е. терпения должно хватить на проделывание однотипных операций на каждой машине. А если машин 10, 20, 50 и больше, и программ для установки не 3-4 а 30-40!? А что если приходится ставить эти программы на машину клинета, где стирать данные нельзя!? Вот на все эти вопросы отвечает данная статья, в которой рассказывается как просто и элегантно решить задачу автоматической установки программ!

Для решения этой задачи воспользуемся специальной программой: MultiSet. Эта программа уникальна тем, что с ее помощью можно полностью автоматизировать процесс установки программ на ПК! С использованием этой программы, все рутинные действия по установке приложений можно свести к одному нажатию кнопки "Старт установки пакета". После выполнения процедуры "автоматической установки программ", на компьютер пользователя будут установлены все необходимые приложения, как будто вы сами их устанавливали вручную, при этом установка происходит гораздо быстрее чем вручную!

Т.е. происходит двойной выигрыш времени:

  • Во-первых, установку производите не вы, а программа. В это время вы можете попить кофе или перекусить.
  • Во-вторых, установка (процесс воспроизведения) происходит гораздо быстрее, чем аналогичная ручная установка (если поставлен режим "максимальная скорость") ну и в третьих, установка произойдет в точности как вы задумали, т.к. программа не может "забыть" поставить то или иное приложение.

Программа работает следующем образом: сначала вам необходимо установить приложение вручную, т.е. необходимо "научить" MultiSet, как необходимо ставить приложение. При этом, вам не нужно писать не строчки кода! После, при необходимости, когда вам реально потребуется установить это приложение, вы просто нажимаете кнопку "воспроизведение" и программа начинает процесс установки приложения, т.е. полностью копирует ваши действия, сделанные в процессе записи установки приложения!

Созданиe установочного пакета

Перейдем непосредственно к созданию установочного пакета.

Шаг 1 - Подготовка

Запустите MultiSet.

Шаг 2 - Запись дистрибутивов.

Теперь необходимо добавить дистрибутивы приложений, которые будут автоматически устанавливаться. Для этого выберем в пункте меню "Package->New package ...", или в панели инструментов выберем пункт "New package...".

New Package
Диалоговое окно "New package".

В появившемся окне необходимо выбрать дистрибутив для установки. После нажатия кнопки "ОК" начнется процесс записи дистрибутива, т.е. выбранный вами exe-файл запустится на выполнение.

Внимание! Началом записи считается первый клик мышью или нажатие клавиши на клавиатуре. Остановка записи осуществляется нажатием клавиши `Break` или нажатие кнопки "Стоп" на "Панели Записи"

При этом во время процесса записи т.е. установки-приложения необходимо соблюдать следующие правила:

  • Перед использованием MultiSet необходимо закрыть все работающие приложения.
  • Не используйте "Дерево-Список" каталогов для выбора размещения программы!
  • Перед процессом автоматической установки полностью удалите требуемое приложение, используя поставляемый с программой uninstaller или используя средства Windows. Также удалите каталог программы на диске, если uninstaller не удалил его.
  • При вставке длинных регистрационных ключей или выбора каталога установки, сначала необходимо установить фокус на редактируемое поле и нажать клавишу `Break`. После чего появится специальное окно "Pause", вставить из буфера обмена данные в текстовое поле и продолжить процесс записи, нажатием кнопки "Record"
  • Обычно, в конце установки пользователю предлагается запустить файл справки (txt, html) и само приложение. Всегда убирайте эти отметки!
  • Перед установкой убедитесь, что владеете правами администратора, если компьютер находится в сети.

Шаг 3 - Воспроизведение дистрибутивов

Для воспроизведения записанных установочных пакетов, необходимо:

  • отметить нужные дистрибутивы в списке пакетов
  • нажать кнопку "Install" на панели инструментов, или горячую клавишу F5

Во время выполнения программы в верхней части экрана появится специальное окно - "Панель воспроизведения". Оно служит для текущего отображения состояния работы MultiSet.

Панель воспрозведения отображает следующую инфорамацию:

  • номер текущего устанавливаемого дистрибутива
  • количество устанавливаемых дистрибутивов
  • общее время выполнения установки
  • наименование текущего дистрибутива

Шаг 4 - Создание установочного диска

Для создания диска, выберите пункт меню File->Create Universal Database (Создание универсальной БД)

Create Uiversal Database

Укажите путь, где будут располагаться данные для автоматической установки. Нажмите кнопку ОК. MultiSet скопирует установочные пакеты и сами дистрибутивы в эту папку чтобы их можно было использовать как автономную единицу. После завершения создания универсальной БД, запишите эту папку на CD. Установочный диск готов!

Теперь вы можете устанавливать приложения где угодно и сколь угодно раз, при этом от вас будет требоваться только вставить диск в CD-ROM\DVD-ROM, всю рутинную работу по установке и настройке приложений MultiSet выполнит за вас!

Резюме

Итак, MultiSet - это программа для записи действий пользователя, с целью их последующего воспроизведения. MultiSet сократит время установки программ до минимума. Программа полностью копирует ваши действия при проигрывании, так что будьте предельно внимательны при записи процесса установки.

MultiSet окажет неоценимую услугу при многократной установке/переустановке большого количества программного обеспечения.

Для дальнейшего знакомства с MultiSet, рекомендую прочитать следующие статьи:

1. Диск "Мой Золотой Софт" своими руками
2. MultiSet: взгляд изнутри.

Отзывы и предложения направляйте на адрес press@almeza.com
Скачать: MultiSet
Форум обсуждения программы

Допускается без дополнительного согласования с автором публикация в платных/бесплатных интернет-изданиях и бумажных СМИ, при сохранении целостности текста, включая настоящее уведомление, и работающих гиперссылок.

Автор: Иван Абрамовский
Иcточник: www.almeza.com

Наш форум

Опубликована - 18.12.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 18.12.2005


Автоматическая установка

Office 2003 (обзор)

Как известно, установочные файлы Office занимают немало места, и разместить их на том же CD, что Windows XP задача непростая. Полный пакет Office на один CD с системой не поместится ни при каком раскладе. Автоматическая установка Office 2003 вместе с Windows XP осуществима несколькими способами:

  • При наличии пишущего DVD привода, лучше использовать DVD диск, куда все файлы поместятся без проблем.

  • Mожно записывать Office на отдельный CD, и создавать пакетный файл, который по окончании установки Windows и всех компонентов с первого CD, попросит вставить второй CD с Office. О том, как создать такой пакетный файл, вы можете почитать в этой ветке на MSFN.org. Если вы предпочитаете графический интерфейс для этой задачи, то можно также воспользоваться одной из многичисленных утилит для смены CD.

  • Если все-таки очень хочется уместить Office 2003 и Windows XP на одном CD, то придется вырезать "лишние" компоненты из инсталляционных файлов Office при помощи программы Office Shrinker, о которой пойдет речь в отдельной статье.

Для первых двух способов нет никаких различий в подготовке инсталляционных файлов Office для автоматической установки. В обоих случаях вы будете работать с полным дистрибутивом Office. Однако, подготовку к автоматической установке можно осуществить различными методами и мы все их рассмотрим. Office Shrinker - отдельная история. Этот способ для опытных пользователей, и в него легче вникнуть после того, как вы изучите методы работы с полными дистрибутивом. Ниже я изложу краткий обзор каждого метода, а подробные инструкции вы найдете на отдельных страницах.

Простой метод

Используя простой метод, вы установите все компоненты Office по умолчанию (это примерно 700Mb на жестком диске, если мне не изменяет память). Подробнее...

Сложный метод

Если вы чувствуете себя продвинутым пользователем, или просто не хотите устанавливать все компоненты, то сложный метод для вас. Сложный метод позволяет интегрировать (или установить по цепочке) обновления, которые уже вышли к Office, а также полностью сконфигурировать установку (да-да, можно даже указать какие ярлыки установить или избавиться от назойливого Помощника). Если вы избрали сложный метод, то у вас есть два варианта:

  • Mожно создать административную установочную точку и затем интегрировать обновления в дистрибутив Office.

  • Можно сконфигурировать файл setup.ini и осуществить установку обновлений по цепочке вслед за установкой Office.

Kакой из вариантов выбрать - решать вам. Во-первых, админстративную установочную точку можно создать только с версиями Office 2003, которые распространяются через Volume License программы (как правило, коропоративные). Цитата с сайта Office Resource Kit: Only editions of Office 2003 acquired through a Volume License agreement or other non-retail channel allow you to create an administrative installation point. You cannot run Setup.exe in administrative mode ( /a ) with an Office 2003 retail edition. Так что если у вас Retail дистрибутив, то вам скорее всего придется избрать вариант setup.ini.

Вариант I - Админстративная установочная точка

Kaк я уже сказал выше, этот вариант позволяет произвести интеграцию обновлений в дистрибутив Office. Таким образом у вас всегда будет абсолютно обновленный дистрибутив. У этого метода есть свои недостатки. Во-первых, при создании административной точки размер дистрибутива значительно увеличивается. Например, Office 2003 EN увеличивается с примерно с 489 Мб до 645 Мб (с уже интегрированным SP1). Во-вторых, вам придется скачивать административные обновления, а они значительно отличаются от клиентских по размеру. Например, административный Service Pack 1 для Office 2003 весит почти 74 Мб, а клиентский - около 18 Мб. Подробнее...

Вариант II - SETUP.INI

Этот вариант рекомендуется тем, кто не может создать административную точку или хочет сэкономить место на диске. Обновления не будут интегрированы в дистрибутив, но установлены по цепочке вслед за инсталляцией Office 2003. Подробнее...

Office Shrinker

Способ для продвинутых пользователей. Позволяет урезать дистрибутив Office до необходимого минимума. Для работы потребуется создание административной инсталляционной точки. Рекомендуется изучение статьи, в которой описывается ее создание, интеграция обновлений и работа с Custom Installation Wizard. Подробнее...

MUI (Multilanguage User Interface) для Office 2003

Как нетрудно догадаться, это статья об автоматической установке MUI для Office 2003 :) Подробнее...

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 26.02.2005


Автоматическая установка

Office 2003 - простой метод установки

Скопируйте все файлы с диска с Office 2003 в C:\XPCD\$OEM$\$1\install\Applications\Office2003\

Количество файлов и их имена могут различаться от версии к версии, так что не волнуйтесь, если у вас все выглядит несколько иначе.

Добавьте следующие строки к вашему пакетному файлу:

ECHO.
ECHO Installing Office 2003
ECHO Please wait...
start /wait %systemdrive%\install\Applications\Office2003\PRO11.msi /qb

Таким образом будут установлены все компоненты Office 2003: Access, Excel, Frontpage, Outlook, Powerpoint, Publisher, Infopath и Word.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 26.02.2005


Метод административной установочной точки

Автоматическая установка

Office 2003 - метод административной установочной точки

Сначала я расскажу об интеграции обновлений в дистрибутив Office 2003, а затем уже непосредственно об автоматической установке. Я буду излагать перевод оригинальной статьи, а собственный опыт, который вам может пригодиться, приведу в комментариях в конце текста.

Этап 1 - Создание Административной Установочной Точки anchor

Как я уже говорил в обзоре методов установки Office, админстративную установочную точку можно создать только с версиями Office 2003, которые распространяются через Volume License программы (как правило, коропоративные).

Если вы не можете создать админстративную инсталляционную точку, то у вас не получится интегрировать обновления. И хотя все остальные этапы, начиная с четвертого, вам будут доступны, я рекомендую воспользоваться методом setup.ini для установки обновлений.

Итак, создаем админстративную инсталляционную точку. Это нужно проделать всего один раз. Вставьте диск с Office в CD-ROM и запустите следующую команду из окна Выполнить/Run (Пуск->Выполнить или Start->Run).

setup.exe /a

Не забудьте поменять букву CD-ROMа на свою.

Если у вас нет файла Setup.exe или он не запускается с ключом /a, то читайте Примечание 1. Таким образом вы запускаете админстративную установку Office и первое же окно спросит вас куда вы хотите установить файлы.

Здесь вы можете ввести название Организации и ключ продукта. Ключ продукта вводится лишь один раз, и более он вам не понадобится. Укажите директорию для установки C:\XPCD\$OEM$\$1\install\Applications\Office2003\ (создайте ее заранее). Затем нажмите Next, примите лицензионное соглашение и жмите Start. После чего Office должны скопироваться в указанную вами директорию.

Этап 2 - Интеграция Service Pack 2 anchor

Примечание: скриншоты этапов 2 и 3 отображают работу с SP1, которая проводилась аналогичным образом.

Скачайте Service Pack 2 для Office 2003 (для английской версии размер файла 104293 кб). Выберите нужный язык инсталляции и переходите вниз страницы, где вам нужно скачать больший по размеру файл - административный пакет.

Запустите следующую команду из командной строки или из диалога Пуск->Выполнить (в команде не забудьте указать путь к файлу):

Office2003SP2-KB887616-FullFile-ENU.exe /Q /C /T:C:\SP2

Команда извлекает Service Pack 2 для Office 2003 в директорию C:\SP2\

Затем из командной строки запустите следующие команды (должно быть две строки)

msiexec /p C:\SP2\MAINSP2ff.msp /a C:\XPCD\$OEM$\$1\install\Applications\Office2003\PRO11.msi SHORTFILENAMES=TRUE /qb
msiexec /p C:\SP2\OWC11SP2ff.msp /a C:\XPCD\$OEM$\$1\install\Applications\Office2003\OWC11.MSI

На этом процесс интеграции Service Pack 2 завершается, и директория C:\SP2 более не понадобится. Если уже появились другие обновления, то вы, возможно, тоже захотите их интегрировать в Административную Инсталляцию. Читайте ниже как это сделать; в противном случае переходите к Этапу 4.

Этап 3 - Интеграция обновлений anchor

Теперь надо скачать обновления к Office 2003. Лучшим способом будет установить Office2003 SP2, пойти в Office Updates, записать номера статей Базы Знаний Microsoft (MS Knowledge Base), a затем скачать административные обновления. В принципе, все текущие обновления можно найти на этой странице. Кстати, для админстративной инсталляции и интеграции обновлений обязательно нужны административные обновления, а не клиентские. Будьте внимательны при скачивании.

Теперь создайте директории в корневом каталоге диска C:\ и назовите ее "O2003updates" (можете создать в другом месте, но я буду отталкиваться именно от C:\O2003updates). Поместите все файлы обновлений в эту директорию.

Если у вас установлен WinRAR, то вы можете легко распаковать каждый файл. Если WinRARа нет, то выполните следующую команду из командной строки:

FOR %f IN (*.exe) DO %f /Q /C /T:C:\O2003updates

Альтернативно, вы можете скачать пакетный файл Extract_Updates.cmd, который выполнит распаковку автоматически. Поместите файл в директорию, где находятся обновления.

После того, как вы распакуете файлы обновлений, у вас будет несколько *.msp файлов. Теперь вы можете удалить или переместить в другое место *.exe файлы.

Теперь займемся интеграцией обновлений. Если хотите, то можете использовать Office 2003 Slipstreamer, который автоматически интегрирует все обновления, избавляя вас от необходимости печатать команды для каждого апдейта. Нужнo просто запустить файл из директории C:\O2003updates. Это файл предполагает, что установочные файлы Office 2003 находятся в C:\XPCD\$OEM$\$1\install\Applications\Office2003\. Если вы выбрали другое расположение, то либо не используйте файл вовсе, либо сделайте соответствующие изменения, открыв файл в Блокноте.

Если же вы хотите все проделать вручную, то выполните следуюшую команду из командной строки: (должно быть две строки)

cd C:\O2003updates
FOR %f IN (*.msp) DO msiexec /p %f /a C:\XPCD\$OEM$\$1\install\applications\Office2003\pro11.msi SHORTFILENAMES=TRUE /qb

После окночания всех операций у вас будет полностью обновленный дистрибутив Office 2003. Вы можете записать этот дистрибутив на CD, и хранить в укромном месте ;-)

Данное руководство применимо и ко всем будущим обновлениям. Административную точку создавать не понадобится, т.к. это нужно делать всего один раз.

Этап 4 - Custom Installation Wizard anchor

Скачайте Office 2003 Resource Kit Tools

Запустите ork.exe для установки Office 2003 Resource Kit Tools. После окончания установки идите в Start->Programs->Microsoft Office Tools->Microsoft Office 2003 Resource Kit Tools и выберите Custom Installation Wizard.

Вы увидите первое окно из 22. На самом деле, большинство из окон можно пропустить, так что процедура конфигурирования не займет много времени. Кликните на скриншот, чтобы рассмотреть картинку получше.

Custom installation Wizard

На втором шаге выберите MSI файл из вашей директории Office2003. Это будет PROPLUS.msi для Office2003 Professional с Frontpage (и PRO.msi без Frontpage). Примечание 2.

Custom installation Wizard

Шаг 3: Create a new MST file (создайте новый MST файл)

Custom installation Wizard

Шаг 4: Назовите его Unattended.MST в C:\XPCD\$OEM$\$1\install\Applications\Office2003\ (у меня на скриншоте название отличается, но это не суть важно)

Custom installation Wizard

Шаг 5: Ничего не меняйте, если только вы не хотите назначить альтернативную директорию для установки Офиса

На седьмом шаге вы сможете сконфигурировать установку компонентов Office 2003

Custom installation Wizard

Custom installation Wizard

Идите шаг за шагом, изменяя настройки в зависимости от ваших предпочтений, и пропуская шаги, котрорые вам непонятны.

В конце вы увидите окно, с командой для запуска

Custom installation Wizard

Эта команда выполянет автоматическую установку Office 2003 используя Unattended.MST файл, который вы создали. Все указанные вами конфигурации будут выполнены в процессе установки. Но нам не нужна эта команда в том виде, в котором нам предлагают, т.к. при установке с CD у нас будет другой путь. Скопируйте команду в Блокнот. При добавлении команды к нашему пакетному файлу, нужно изменить ее следующим образом:

TRANSFORMS=C:\XPCD\$OEM$\$1\install\Applications\Office2003\Unattended.MST /qb-

меняем на

TRANSFORMS=Unattended.MST /qb-

Этап 5 - Команда для пакетного файла

Как вы уже поняли из четвертого этапа, нам нужно поменять путь в синтаксисе TRANSFORMS, чтобы наша автоматическая установка сработала с CD. Ниже приводятся строки, которые нужно будет добавить к вашему пакетному файлу.

ECHO.
ECHO Installing Office 2003 Professional
ECHO Please wait...
start /wait %systemdrive%\install\Applications\Office2003\setup.exe TRANSFORMS=Unattended.MST /qb-

Вот и все!

Примечание 1

В моем распоряжении находилась версия Office 2003, лицензированная моим университетом. Названия файлов несколько отличались от описанных в руководстве, и для создания административной инсталляционной точки я использовал файл Setuppro.exe. Это было несложно вычислить, однако с первой попытки этот файл не сработал. Ниже я объясню почему, и возможно вам надо будет перечитать Этап 3, где ведется речь об MST файлах. Моя версия была до определенной степени сконфигурирована и уже содержала MST файл (откуда я кстати извлек ключ продукта). При попытке запустить Setuppro.exe /а я получал сообщение об ошибке. Пришлось подойти к проблеме основательно ;-) В итоге я нашел файл setup.ini в директории Files\Setup. В этом файле была прописана строка, указывающая на уже существующий MST файл.

[MST]
; The MST section gives the full path to a transform that should be applied.
MST1=IU.MST
;MST1=D:\transforms\my transform.mst

После ее удаления (ставится ; в начале строки) все заработало, и мне удалось запустить административную установку. Возможно, данная информация поможет тем, у кого сходу не получился запуск setup.exe /a.

Вернуться к тексту ^

Примечание 2

Если ваш случай схож, с описанным в Примечании 1, то имя MSI файла будет отличаться. У меня это Pro11.msi

Вернуться к тексту ^

Автор: Vadikan
Иcточник: (частично перведено с английского - unattended.msfn.org)

Наш форум

Опубликована- 26.02.2005


Автоматическая установка

Office 2003 - метод SETUP.INI

При подготовке автоматической установки Office по методу SETUP.INI обновления не интегрируются в дистрибутив. Их установка осуществляется сразу после установки Office. Параметры установки и команды на запуск обновлений конфигурируются через файл SETUP.INI, расположенный в \FILES\SETUP\.

Этап 1 - Подготовка дистрибутива

Скопируйте все файлы с диска с Office 2003 в C:\XPCD\$OEM$\$1\install\Applications\Office2003

Количество файлов и их имена могут различаться от версии к версии, так что не волнуйтесь, если у вас все выглядит несколько иначе.

Этап 2 - Подготовка SP1 и обновлений

Скачайте Service Pack 2 для Office 2003 (для английской версии размер файла 50536 кб). Выберите нужный язык инсталляции и переходите вниз страницы, где вам нужно скачать меньший по размеру файл - клиентский пакет. Если после выхода SP2 появились обновления, то скачайте и их. Лучшим способом будет установить Office2003 SP2, пойти в Office Updates, записать номера статей Базы Знаний Microsoft (MS Knowledge Base), a затем скачать клиентские обновления. В принципе, все текущие обновления можно найти на этой странице.

Service Pack и обновления находятся в запакованном виде. Их можно распаковать при помощи WinRAR или из командной строки (в примере распаковывается SP1)

Office2003SP1-kb842532-client-enu.exe /Q /C /T:<path>

где <path> путь к директории, в которую вы распаковываете обновление. Допустим, если вы распаковываете в C:\Temp\updates то команда будет Office2003SP1-kb842532-client-enu.exe /Q /C /T:C:\Temp\updates

После распаковки у вас появятся четыре файла: mso-Binary-GLB.msp, ohotfix.exe, ohotfix.ini, ohotfixr.dll.

Для дальнейшей работы понадобится только *.MSP файл. Переименуйте mso-Binary-GLB.msp например в KB887616_mso-Binary-GLB.msp, чтобы было легче идентифицировать обновление по номеру статьи MS Knowledge Base. Переименование преследует еще одну цель: MSP файлы различных обновлений после распаковки могут иметь одинаковые имена. Если вы распаковываете более чем одно обновление в одну и ту же директорию , то вы просто затрете уже распакованные. Аналогичным образом распакуйте остальные обновления.

В директории Office2003 создайте директорию Updates и скопируйте туда файлы KBхххххх_mso-Binary-GLB.msp. Таким образом, обновления будут находиться в C:\XPCD\$OEM$\$1\install\Applications\Office2003\Updates

Этап 3 - SETUP.INI

Oткройте в Блокноте или ином текстовом редакторе файл SETUP.INI, расположенный в C:\XPCD\$OEM$\$1\install\Applications\Office2003\FILES\SETUP. Вы увидите примерно такую картину (перевод выполнил EgOrus):

; Microsoft Office SETUP.EXE settings file.

[MSI]
; Секция MSI указывает установочный файл MSI. Файл д.б. в той же папке что и setup.exe, в свою очередь оба они должны находиться в корне установочного каталога.
MSI=PRO11.MSI

[Product]
ProductCode={90110419-6000-11D3-8CFE-0150048383C9}
ProductName=Microsoft Office 2003
ProductVersion=11.0.5614.0

[MST]
; Путь до файла(ов) автоустановки mst.
;MST1=\\server\share\some transform.mst
;MST1=D:\transforms\my transform.mst

[Options]
; Секция для указания индивидуальных параметров установки.
;USERNAME=Customer
;COMPANYNAME=my company
;INSTALLLOCATION=C:\Program Files\MyApp

[Display]
; В этой секции указываются настройки отображения GUI во время установки.
;       Значение              По умолчанию        Описание
;       DisplayfullОпция для замены значения по умолчанию (none, quiet, basic, reduced, full)
;       CompletionNoticeYesПоказывать ли предупреждение о завершении установки.
;Display=None
;CompletionNotice=Yes

[Logging]
; Установки управляющие детализацией логов.
;       Значение              По умолчанию        Описание
;       Type            vpiwaeo         опции логинга
;a - информация о начале установки,
;c - инфа о параметрах GUI (basic, quit и тд.),
;e - ошибки, i - информационные сообщения,
;m - недостаточно памяти,
;o - недостаточно места,
;p - информация о выбранных значениях в формах при установке,
;r - инф. о других событиях,
;u - сообщения о запросах пользователя,
;v - отладочные сообщения,
;w - предупреждения,
;* - включение всех указанных опций,
;+ - добавить если файл лога уже существует
;       Path            %TEMP%          путь по которому будет создан файл логов
;       Template        SetupLog(*).txt шаблон для файла логов, н-р может заканчиваться на "(*).txt"; где * заменяется четырьмя цыфрами, для обеспечения уникальности имени
Template=Microsoft Office 2003 Setup(*).txt
Type=piwaeo
;Path=\\MyServer\logfiles\
;Template=Product %UserName%(*).txt

[MinOSRequirement]
; минимальные параметры ОС для установки
VersionNT_1=500
WindowsBuild_1=2195
ServicePackLevel_1=3

[Cache]
; Установки по кэшированию дистрибутива локально на жестком диске (применяется только если установка производится не из адм. установки)
;       Значение              По умолчанию        Описание
;       CDCACHE2             Уровень кэширования
;auto - кэширует весь объем дистра на разделе с наибольшим объемом свободного места, если место недостаточно используется уровень кэширования 1, если и для этого места нет, то кэш не создается
;0 - запуск установки напрямую с CD, не создавая кэшфайлов,
;1 - кэширование только необходимых для установки файлов,
;2 - кэширование всего дистра
;       LOCALCACHEDRIVE {predefined)    форсированное указание буквы для кэша
;       DELETABLECACHE  1                выводить ли предложение об удалении кэшфайлов в конце установки
;1 - выводить, 0 - не выводить
;       PURGE           0               очистить форсированно ли кэш после установки
; 0 - не очищать, 1 - очистить
; необходимо помнить что файлы копируются еще до начала обработки файла mst, поэтому нужно осторожно подходить к уровню кэширования, в моем случае (урезанный дистрибутив) пришлось выставлять в 0, в противном случае дистрибутив выдает запрос на недостающие CAB-файлы. Это мне до сих пор не совсем понятно, т.к. каждому уровню соответствует определенный набор файлов, указанный в файле \FILES\SETUP\PRO11.XML

CDCACHE=auto
;LOCALCACHEDRIVE=C:\
DELETABLECACHE=1
PURGE=0

[OfficeWebComponents]
MSI=OWC11.MSI

Здесь вы видите, что можно указать путь к MSI файлу, путь к MST файлу конфигурации компонентов Office (о котором речь пойдет чуть ниже), и ряд других параметров. Например, секция [Display] отвечает за показ интерфейса и прогресса установки. Также можно управлять кэшем (файлы копируемые с CD на жесткий диск для последующего изменения, добавления компонентов или переустановки).

Теперь в этом файле вам надо будет сконфигурировать установку обновлений. Для каждого обновления нужно добавить в конце файла секцию [ChainedInstall_N], где N - порядковый номер секции начиная с 1 (единицы). Например, для первого обновления (SP1) секция будет выглядеть так:

[ChainedInstall_1]
TASKTYPE=exe
PATH=MSIExec.exe

CmdLine=/update Updates\KB887616_mso-Binary-GLB.msp /qb

Для следующего обновления секция будет называться [ChainedInstall_2] и т.д. Подробнее о параметрах секции [ChainedInstall_N] в изложении EgOrus ниже.

[ChainedInstall_1]
TaskName=Update123
; имя, кот. будет выводиться в логах, может быть любым
TASKTYPE=exe
; тип исполняемого файла MSI или EXE (обязательный параметр)
MST=
; путь до файла ответов mst, кот. будет использоваться для установки данного приложения (только для MSI)
PATH=MSIExec.exe
; путь до приложения
CmdLine=/update Updates\KB828041_mso-Binary-GLB.msp /qb
; параметры командной строки
Display=basic
; тоже что и опция Display для установки самого Офиса (если указано то используется именно это значение, а не заданное выше для установки самого Офиса)
Reboot=0
; 1- перегрузить после установки приложения, 0 - не перегружать
IgnoreReturnValue=0
; продолжать ли устанавливать последующие приложения если установка данного приложения не удалась

[ChainedInstall_2]
...
[ChainedInstall_3]
...
и т.д.

Примечание: ключ /update поддерживается Windows Installer начиная только с версии 3.x. Он входит в SP2 для Windows XP, а также доступен отдельно.

Таким образом у вас уже готовы дистрибутив с обновлениями. Осталось выбрать устанавливаемые компоненты Office.

Этап 4 - Custom Installation Wizard

Скачайте Office 2003 Resource Kit Tools

Запустите ork.exe для установки Office 2003 Resource Kit Tools. После окончания установки идите в Start->Programs->Microsoft Office Tools->Microsoft Office 2003 Resource Kit Tools и выберите Custom Installation Wizard.

Вы увидите первое окно из 22. На самом деле, большинство из окон можно пропустить, так что процедура конфигурирования не займет много времени. Кликните на скриншот, чтобы рассмотреть картинку получше.

Custom installation Wizard

На втором шаге выберите MSI файл из вашей директории Office2003. Это будет PROPLUS.msi для Office2003 Professional с Frontpage (и PRO.msi без Frontpage).

Custom installation Wizard

Шаг 3: Create a new MST file (создайте новый MST файл)

Custom installation Wizard

Шаг 4: Назовите его Unattended.MST в C:\XPCD\$OEM$\$1\install\Applications\Office2003\ (у меня на скриншоте название отличается, но это не суть важно)

Custom installation Wizard

Шаг 5: Ничего не меняйте, если только вы не хотите назначить альтернативную директорию для установки Офиса

На седьмом шаге вы сможете сконфигурировать установку компонентов Office 2003

Custom installation Wizard

Custom installation Wizard

Идите шаг за шагом, изменяя настройки в зависимости от ваших предпочтений, и пропуская шаги, котрорые вам непонятны.

В конце вы увидите окно, с командой для запуска

Custom installation Wizard

Эта команда выполянет автоматическую установку Office 2003 используя Unattended.MST файл, который вы создали. Для установки через SETUP.INI эта команда вам не нужна.

Этап 5 - Команда на запуск установки Office 2003

Файл Unattended.MST размещается в корневой директории Office (в нашем случае C:\XPCD\$OEM$\$1\install\Applications\Office2003). Теперь надо указать к нему путь в файле SETUP.INI. Делается это так:

[MST]
MST1=Unattended.MST

Иными словами, путь и указывать-то не надо, если MST файл расположен в одной директории с setup.exe. Теперь при установке надо будет лишь запустить setup.exe без всяких ключей - ведь вы уже все сконфигурировали в SETUP.INI. Команда на запуск установки Office 2003 будет такой:

ECHO.
ECHO Installing Office 2003 Professional
ECHO Please wait...
start /wait %systemdrive%\install\Applications\Office2003\setup.exe

Примечание: Для различных вариантов установки Office вы можете использовать несколько различных MST файлов с разными конфигурациями и файлов SETUP.INI (с разными именами, конечно). Для этого нужно запускать setup.exe с ключом /settings и названием INI файла. Напрмиер:

setup.exe /settings setup.ini
setup.exe /settings setup_unattend.ini

Заключение

В данной статье третий этап написан на основе сообщения в форуме, отправленного EgOrus. Он же перевел на русский язык файл SETUP.INI и снабдил его дополнительными комментариями. За что ему большое спасибо! Кстати, его файл SETUP.INI вы можете посмотреть тут. Вообще, метод SETUP.INI я уже рассматривал применительно к MUI для Office 2003, но не так подробно. Ну и напоследок список литературы:

Setup Settings File
Setup Sequence of Events
Customizing How Setup Runs

Успешных экспериментов!

Автор: Vadikan, EgOrus
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 26.02.2005


Автоматическая установка

Office Shrinker

Данную статью фактически написал участник конференции OSZone TrueAlex. Я не стал делать из статьи подробное руководство, тем более, что многие моменты и так весьма подробно расписаны в других статьях про Office на этом сайте.

Не секрет, что Office состоит из нескольких разных программ (Word, Excel, Access и т.д.). Большинству же людей необходимы лишь Word и Excel... Tаким образом получается, что дистрибутив содержит ненужные нам программы и соответственно занимает кучу бесценного места на болванке. Урезание дистрибутива офиса состоит в том, чтобы оставить только нужные Вам файлы дистрибутива.

Для этого вам понадобятся:

  1. Программа Office shrinker

  2. Дистрибутив Office2003

  3. Office 2003 Resource Kit Tools

  4. Пакет обновления Office 2003 Service Pack 2 (не обязательно)

Для начала нужно создать административную установочную точку и интегрировать в нее Service Pack 2.

Далее необходимо воспользоваться Custom Installation Wizard из Office 2003 Resource Kit для создания файла трансформации (*.MST). Надо сказать, что именно от того насколько тщательно Вы подойдете к его созданию, настолько компактным станет Ваш диструбитив в дальнейшем. Иными словами, необходимо точно отметить все необходимые компоненты, которые Вы хотите оставить в дистибутиве, так что не ленитесь открыть и просмотреть каждую ветку программ. Если в дальнейшем дистрибутив будет использоваться для установки на компьютеры, подключенные к локальной сети, то и имеет смысл создать где-либо в сети (на сервере) расшаренный ресурс с административной установкой офиса и указать путь к ней в файле трансформации на соответствующей странице. Тем самым вы избавите себя от необходимости таскать компакт-диски с офисом к компьютеру, если там вдруг понадобится поставить какое-либо дополнение к офису, которого нет в Вашем урезанном дистрибутиве - офис просто возьмет недостающие файлы по сети.

После того, как вы закончите конфигурацию Office через Custom Installation Wizard, сохраните созданный файл трансформации в корневом каталоге Office под именем setup.mst.

Далее берем программу Office Shrinker. Она не имеет поддержки русского языка, но, благо, вся ее конфигурация размещается в файле shrink.ini. Создайте этот файл самостоятельно в одном каталоге с самой программой (shrink_lang02.exe) со следующим содержанием:

[Language]
lang=russian
dir=1049
retry=Повторить
title=Microsoft Office
error=Ошибка
[Directory]
Office Source=C:\office\
Office Target=C:\office_shrinked\
[Files]
Office Setup EXE file=SETUP.EXE
Office Setup MST file=setup.MST
[Version]
Number=11.0.5510.0

Возможно, Вы, лишь, захотите изменить параметры Office Source и Office Target (соответственно: каталог административной установки и каталог в котором разместится урезанный дистрибутив, созданный программой)

Все! Теперь просто запустите Office Shrinker. В процессе работы будут появляться сообщения об ошибках - это НОРМАЛЬНО! Не надо на них реагировать, Shrinker должен сам о них позаботиться.

Замечу, что запускать программу надо именно на той системе, на которую Вы в дальнейшем планируете устанавливать Office! Т.е. если Вы используйте в своей работе виртуальныю машину, то сначала полностью создайте дистрибутив Windows, установите его, и после этого, не устанавливая никакого дополнительного ПО, а тем более обновлений Windows, скопируйте на виртуальную машину папку административной установки и Shrinker, и на этой же машине запускайте его. После работы возьмите созданный дистрибутив и переписывайте обратно, чтобы записать на CD вместе с тем же Windows.

Запускается установка офиса, вот такой командой:

pro11.msi TRANSFORMS=setup.mst /qn

Не забудьте указать полные пути к файлам. Проверить насколько удачно произошла установка, можно после ее окончания, по записи в журнале системы: Панель управления -> Администрирование -> Просмотр событий -> Журнал приложений.

Автор: Vadikan, TrueAlex
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 26.02.2005


Автоматическая установка

Office 2003 MUI

Подготовка дистрибутива MUI к установке

Microsoft выпустила 6 CD с MUI, на каждом из которых содержится несколько различных языков. CD с MUI не распространяются через розничную сеть, и доступны только корпоративным пользователям. Однако, в сети Internet можно найти MUI для Office 2003. В моем распоряжении была урезанная версия MUI CD 5, из которой было убрано все, кроме Русского языка. В зависимости от вашей версии MUI установка может незначительно отличаться.

После выхода SP1 для Office 2003 появился и SP1 для Office 2003 MUI. Соответственно нам придется обновить файлы MUI, проинтегрировав в них SP1 для MUI, скачать который можно с этой страницы. Обратите внимание, что есть разные файлы SP1 для каждого из CD. Вероятно, вас интересует обновление для CD5, на котором помимо прочих находились Русский и Украинский MUI. Качать надо полную версию SP1, и в нашем случает это MUI2003SP1CD5-kb843187-fullfile-enu.exe.

Далее все будет очень похоже на манипуляции, которые мы проводили с Office 2003.

Этап 1 - Создание Административной Установочной Точки

В зависимости от того, какой версией MUI вы обладаете процедура может незначительно отличаться. Если у вас официальный релиз MUI на CD, то тогда надо из командной строки запустить команду Muisetup.exe /a. В моем варианте команда несколько отличалась. Для этой статьи я поместил файлы MUI в директорию C:\OfficeMUI (название директории на ваше усмотрение, не забудьте внести соответствующие изменения в ваши команды)

Запускаем следующую команду:

C:\OfficeMUI\Setup.exe /a mui.msi

Мы применяем административную установку к пакету mui.msi

Появляется окно Административной установки MUI

Указываем директорию для установки. В данном случае я выбрал C:\OfficeMUI_Admin. Затем надо принять лицензионное соглашение

И нажать Install. Если все прошло как надо, то вы увидите уведомление об успешной установке.

На этом создание Админстративной Установочной Точки можно считать законченным и переходить к следующему этапу.

Этап 2 - Распаковка Office 2003 SP1 для MUI

Здесь все выполняется одной командой. Мы распаковываем SP1 в директорию C:\MUISP1

MUI2003SP1CD5-kb843187-fullfile-enu.exe /Q /C /T:C:\MUISP1

По окончании распаковки у вас в директории C:\MUISP1 должна быть такая картина

Как видно на скриншоте, у нас появились файлы обновлений для различных языков MUI. В дальнейшем я буду работать с файлом для Русского MUI - MUISP1_RUSff.msp. Если вас интересует другой язык, то с помощью этой статьи из KB M$ вы легко определите нужный вам файл.

Этап 3 - Интеграция Office 2003 SP1 для MUI в дистрибутив MUI

Здесь тоже все выполняется одной командой (должно выглядеть как одна строка):

msiexec /p C:\MUISP1\MUISP1_RUSff.msp /a C:\OfficeMUI_Admin\MUI.msi SHORTFILENAMES=TRUE /qb /Lie C:\muilog.txt

На всякий случай я добавил в конце ключи для создания лог-файла. Это необязательно, и вы можете удалить /Lie C:\muilog.txt

Вот в принципе и все. Теперь в директории OfficeMUI_Admin у нас обновленный дистрибутив MUI, который готов для установки на Office 2003 SP1. Скопируйте директорию в C:\XPCD\$OEM$\$1\install\Applications\ и переименуйте в OfficeMUI для краткости.

Установка MUI

Установку можно произвести различными способами. Оставляю выбор на ваше усмотрение.

Способ 1- Custom Installation Wizard

Если хотите, то можете использовать Custom Installation Wizard, применяя его к MUI.MSI. Вероятно, это имеет смысл, когда ваш пакет MUI содержит более одного языка интерфейса. Процедура аналогична конфигурированию Office 2003, и в конце вы получите MST файл, путь к которому нужно указать при запуске MUI.MSI. Команда для запуска будет такой:

ECHO.
ECHO Installing MUI for Office 2003 Professional
ECHO Please wait...
start /wait %systemdrive%\install\Applications\OfficeMUI\setup.exe TRANSFORMS=my_mui.MST /qb-

Способ 2 - SETUP.INI

Альтернативный метод мне показался покороче, тем более язык интерфейса у меня был всего один. В директории Files\Setup есть файл Setup.ini. Я, пожалуй его приведу, чтобы было наглядно и понятно, о чем речь.

; Microsoft Office SETUP.EXE settings file.

[MSI]
; The MSI section gives the name of the MSI file to install. This file must be in
; the same folder as Setup.exe, and both must be in the root of the installation
; tree.
MSI=MUI.MSI

[Product]
ProductCode={901E0419-6000-11D3-8CFE-0150048383C9}
ProductName=Microsoft Office 2003 User Interface Pack
ProductVersion=11.0.5614.0
Recache=1

[MST]
; The MST section gives the full path to a transform that should be applied.
;MST1=\\server\share\some transform.mst
;MST1=D:\transforms\my transform.mst

[Options]
; The option section is used for specifying individual Installer Properties.
;USERNAME=Customer
;COMPANYNAME=my company
;INSTALLLOCATION=C:\Program Files\MyApp
SUPPRESSFINALDIALOG=1

[Display]
; The diplay section is used for overriding the default UI
;       Value           Default         Description
;       Display         full            Option to override the default UI
;                                       [none, quiet, basic, reduced, full]
;       CompletionNotice Yes            Option to display a setup completion
;                                       notice for otherwise quiet setup
;Display=None
;CompletionNotice=Yes

[Logging]
; The logging section provides settings for controlling the Setup log files.
;       Value           Default         Description
;       Type            vpiwaeo         Logging modes
;                                       [a, c, e, i, m, o, p, r, u , v,
;                                       w, *, +]
;       Path            %TEMP%          Path to create logfiles
;       Template        SetupLog(*).txt File name for log file should end in
;                                       "(*).txt"; the * is replaced with a 4
;                                       digit number to make the file name unique
Template=Microsoft Office 2003 User Interface Pack Setup(*).txt
Type=piwaeo
;Path=\\MyServer\logfiles\
;Template=Product %UserName%(*).txt

[MinOSRequirement]
; MinOSRequirement is used for defining the minimal OS requirement for
; installing the product.
VersionNT_1=500
WindowsBuild_1=2195
ServicePackLevel_1=3

[Cache]
; The cache section provides settings for caching the install source locally
;       Value           Default         Description
;       CDCACHE            2             Option to specify cache level
;                                       [auto, 0, 1, 2]
;       LOCALCACHEDRIVE (predefined)    Option to specify a drive to cache
;                                       the install source to
;       DELETABLECACHE  1                Option to display UI to remove the
;                                       cache at the end of setup [0,1]
;       PURGE           0               Option to always remove cache at end of
;                                       setup [0,1]
CDCACHE=auto
;LOCALCACHEDRIVE=C:\
DELETABLECACHE=1
PURGE=0

Автоматическую установку можно организовать, изменяя некоторые параметры файла, о которых речь пойдет ниже. Обратим наш взор на секцию [Display]. По умолчанию все значения там деактивированы с помощью "точки с запятой" в начале строки, и установка без пользователя невозможна. Если привести секцию к такому виду:

то установка пройдет автоматически, и по ее завершении не будет выводится окно, рапортующее об успешной установке MUI.

[Display]
Display=Quiet
CompletionNotice=No

В секции [Options] вы можете указать каталог для установки MUI. Например,

INSTALLLOCATION=%programfiles%\Microsoft Office\MUI

Я рекомендую также обратить внимание на секцию [Cache]. Параметр PURGE отвечает за хранение/удаление инсталляционных файлов на локальном диске. Это может пригодится когда нужно поменять настройки MUI - язык интерфейса. Поскольку у меня MUI содержал всего один язык, то я не видел смысла хранить инсталляционные файлы на диске. Поясняю, что речь идет не об исходных файлах, которые использовались при установке, а о тех, что MUI кэширует отдельно.

[Cache]
PURGE=1

Таким образом файлы удаляются по окончании установки.

После окончания конфигурирования setup.ini команда для запуска будет выглядеть так (ниакие ключи не нужны):

ECHO.
ECHO Installing MUI for Office 2003 Professional
ECHO Please wait...
start /wait %systemdrive%\install\Applications\OfficeMUI\setup.exe

Вот, пожалуй, и все. Если все сделано правильно, то Office 2003 обретет русский язык интерфейса.

Примечание

Честно говоря, я комфортнее себя чувствую с английскими меню, и установка MUI проделывается исключительно ради эксперимента. При тестировании у меня английский так и остался языком по умолчанию для интерфейса Office 2003, и пришлось включать русский язык в Office Language Settings:

Я думаю, что это было связано с тем, что язык интерфейса тестируемой системы (Win XP Pro EN) был английским. Видимо, при таком раскладе язык интерфейса Office 2003 по умолчанию выставляется в соответствии с языком операционной системы. Проверьте самостоятельно, и сообщите мне, если я ошибаюсь.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 26.02.2005


Автоматическая установка

Драйверы (обзор)

Секция Драйверы описывает три типа установки драйверов и упоминает о пакете драйверов Bâshrat the Sneaky, участника конференции MSFN. "Драйверы из winnt.sif" и "Драйверы с CD" следуют примерно одной концепции (по крайней мере в пределах этой секции). Например, подготовка драйверов в обоих случаях проходит одинаково, хотя приемы, используемые для установки, различны. Более подробные объяснения доступны на соответствующих страницах.

Статья "Интеграция SATA/RAID драйверов" рассказывает о том, как включить в инсталляционный диск SATA/RAID драйверы, и обойтись без флоппи диска, который обычно требуется для установки этих драйверов. Данная статья не является переводом статьи MSFN, а основана на руководстве Майкла Холлингера (Michael Hollinger). Принципиальных различий, впрочем, нет. Руководство Майкла более подробно, в то время как статья MSFN основана на статье GreenMachine, автора программы XPCreate. Ссылку на эту статью вы увидите и в моем рассказе.

Выберите статью, с которой вы хотите ознакомиться:

  • Установка драйверов из winnt.sif
  • Установка драйверов с CD
  • Интеграция SATA/RAID драйверов
  • Пакеты драйверов от Bâshrat the Sneaky

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 03.03.2005


Автоматическая установка

Установка драйверов из winnt.sif

Если вам когда-либо доводилось обновлять много драйверов после установки Windows, то эта страница для вас. Я расскажу как подготовить автоматическую установку таким образом, чтобы Windows использовала ваши обновленные драйверы вместо стандартных из drivers.cab на инсталляционном диске. На самом деле, это очень просто.

Замечу, что описываемый мною метод не поможет в установке обновленных SATA/RAID драйверов. О том, как разобраться с драйверами контроллеров SATA/RAID, читайте тут.

Драйверы в winnt.sif

В разделе [Unattended] файла winnt.sif вы должны внести примерно такую строку:

OemPnPDriversPath="Drivers\000_intel_INF;Drivers\001_gigabit_LAN;Drivers\002_monitor"

Таким образом вы указываете программе установки проводить поиск в указанных директориях на предмет более новых драйверов, чем находящиеся в drivers.cab на инсталляционном диске. Если программа установки находит более подходящий драйвер, то он будет установлен вместо драйвера по умолчанию.

Примечание: Разделяйте директории в строке при помощи "точки с запятой" - ;

DriverSigningPolicy=Ignore

Данная строка вынудит программу установки проинсталлировать неподписанные драйверы (not WHQL certified). Эта строка используется в сочетании с OemPnPDriversPath. Впрочем, по информации с форума msfn.org, этот трюк не всегда срабатывает, так что по возможности используйте подписанные драйверы. Или устанавливайте неподписанные вручную в случае проблем.

Вы можете добавить сколько угодно драйверов. Например, если вы используете диск автоматической установки на разных конфигурациях, то это особенно имеет смысл. Риска поставить неправильный драйвер нет, т.к. Windows самостоятельно определяет наиболее подходящий драйвер для устройства.

Подготовка драйверов

Производители драйверов используют разные типы инсталляторов, так что универсального рецепта для каждого драйвера не существует. Большинство драйверов можно извлечь из инсталляционного пакета при помощи WinRAR или аналогичных программ. Иногда, для извлечения достаточно запустить установку, и дождавшись первого экрана пойти во временную папку, отыскать драйверы, распакованные инсталлятором, скопировать их в другую папку, а затем отменить установку. После извлечения вы наверняка найдете один или несколько INF файлов.

Извлеките драйверы в любую директорию, и изучите ее содержимое. Иногда, вы увидите несколько поддиректорий, содержащих INF файлы. В таком случае вам придется указать прямой путь к каждой поддиректории в OemPnPDriversPath. Дело в том, что программа установки Windows не будет искать INF файлы в поддиректориях.

Поименуйте ваши директории таким образом, чтобы имена начинались с номеров. Таким образом установка драйверов будет происходить в числовом порядке. Делается это для того, чтобы обеспечить правильный порядок установки драйверов. Как вы вероятно знаете, драйверы чипсета должны устанавливаться первыми, следовательно директория, содержащая драйверы чипсета должна быть первой, а точнее мы сделаем ее нулевой (000). Таким образом программа установки Windows сначала обратится именно к этой директории. Ниже приводится пример того, как можно поименовать директории и раскидать по ним драйверы:

000_chipset
001_network
002_graphics
003_tv_out
004_sound
005_monitor
006_keyboard
007_mouse
008_and_so_on

Значит сначала у нас пойдут драйверы чипсета, потом сетевой карты, потом видео и звуковые карты, потом монитор, и в конце периферия (мышь, клавиатура и т.д.).

Скопируйте все ваши директории с драйверами в C:\XPCD\$OEM$\$1\drivers\

drivers drivers

Откройте winnt.sif и добавьте следующие строки в раздел [Unattended]. Конечно, пути могут отличаться, так что не забудьте исправить на свои.

OemPnPDriversPath="Drivers\000_intel_INF;Drivers\001_gigabit_LAN;Drivers\002_monitor"
DriverSigningPolicy=Ignore

Обратите внимание, что указываются пути к директориям, а не к конкретным INF файлам. Сохраните winnt.sif и все дела!

Возможные проблемы

Не все драйверы удастся установить используя вышеуказанный метод. Если какой-то не работает, то возможно его получится установить методом, применяемым для автоматической установки приложений. Различные типы инсталляторов описаны на этой странице.

Драйверы ATI Catalyst можно установить методом, описанным на данной странице. Однако, SmartGart установлен не будет. Есть альтернативный метод. Используйте автоматическую установку драйверов как-будто это приложение, запакованное InstallShield, подробнее о котором здесь.

Вы также можете посетить форум на msfn.org, посвященный вопросам автоматической установки драйверов.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 02.03.2005


Автоматическая установка

Установка драйверов с CD

Это вторая редакция статьи, излагающая наиболее простой способ установки драйверов с CD. Способ изложен по-английски в этой теме на MSFN, a на русский для вас его перевел EgOrus.

Набор файлов для установки драйверов с CD

Вам понадобятся несколько файлов, которые необходимы для данного способа установки драйверов с CD. Вы можете загрузить файлы отсюда. Просто распакуйте содержимое архива в корень директории C:\XPCD\$OEM$.

Редактирование файла ответов

В файл ответов нужно добавить строки, приведенные ниже. Есть два варианта в зависимости от того, хотите ли вы видеть консольное окно в процессе установки. Если вы хотите видеть консоль с отработкой командного (cmd) файла, то добавьте эти строчки (при этом консольное окно в процессе установки запускается свернутым левом углу):

[GuiUnattended]
    DetachedProgram=".\system32\cmd.exe"
    Arguments="/Q /C FOR /F %I IN (%SystemRoot%\SYSTEM32\$WINNT$.INF) DO (FOR %J IN (%I$OEM$) DO (IF EXIST %J (start /min /D%J Drivers.cmd)))"

Если вы не желаетe видеть консольное окно, то добавляйте:

[GuiUnattended]
    DetachedProgram=".\system32\cmd.exe"
    Arguments="/Q /C FOR /F %I IN (%SystemRoot%\SYSTEM32\$WINNT$.INF) DO (FOR %J IN (%I$OEM$) DO (IF EXIST %J (start /min /D%J NirCmd.exe exec hide Drivers.cmd)))"

Подготовка драйверов

Для каждого из компонентов вашей системы (чипсет, сетевая карта, и т.д) создайте отдельную директорию. Поименуйте ваши директории таким образом, чтобы имена начинались с номеров. Таким образом установка драйверов будет происходить в числовом порядке. Делается это для того, чтобы обеспечить правильный порядок установки драйверов. Как вы вероятно знаете, драйверы чипсета должны устанавливаться первыми, следовательно директория, содержащая драйверы чипсета должна быть первой, а точнее мы сделаем ее нулевой (000). Таким образом программа установки Windows сначала обратится именно к этой директории. Ниже приводится пример того, как можно поименовать директории:

000_chipset
001_network
002_graphics
003_tv_out
004_sound
005_monitor
006_keyboard
007_mouse
008_and_so_on

Значит сначала у нас пойдут драйверы чипсета, потом сетевой карты, потом видео и звуковые карты, потом монитор, и в конце периферия (мышь, клавиатура и т.д.).

Tеперь надо извлечь драйверы из инсталляционных пакетов. Производители драйверов используют разные типы инсталляторов, так что универсального рецепта для каждого драйвера не существует. Большинство драйверов можно извлечь из инсталляционного пакета при помощи WinRAR или аналогичных программ. Иногда, для извлечения достаточно запустить установку, и дождавшись первого экрана пойти во временную папку, отыскать драйверы, распакованные инсталлятором, скопировать их в другую папку, а затем отменить установку. Итак, извлеките драйверы в соответствущие директории, которые вы создали ранее. Не беспокойтесь, если извлеченные драйверы содержат поддиректории - это ни на что не повлияет.

В $OEM$ директории вашего инсталляционного диска (C:\XPCD\$OEM$) создайте директорию Drivers. Переместите папки с извлеченными драйверами в Drivers. Драйверы будут устанавливаться прямо с CD, никакого копирования на жесткий диск не будет. Конечно, драйверы должны быть в несжатом виде. Если вы хотите сэкономить место на носителе, то ниже описывается как упаковать драйверы. Если упакованные драйверы не используются, файл 7za.exe из папки $OEM$ можно удалить.

Упакованные драйверы

Если вы хотите использовать упакованные драйверы для экономии места, то запакуйте их с помощью 7-zip (можно использовать и любой другой архиватор, но тогда не забудьте изменить в файле Drivers.cmd команду и ключи на распаковку), назовите файл Drivers.7z и разместите его в корне $OEM$\. При установке драйверы автоматически распакуются в %SystemDrive%\Drivers. Не забудьте удалить эту папку впоследствии (из cmdlines.txt или при первом входе в систему), если конечно не планируете ее в использовать в дальнейшем.

Как это все работает

У вас должна получиться примерно такая структура папок и файлов:

На стадии установки T-39 программа установки Windows запускает файл Drivers.cmd, который:

  • прежде всего останавливает процесс установки (используя утилиту Process.exe)
  • затем запускает WatchDriverSigningPolicy.exe, которая позволяет устанавливать неподписанные драйверы
  • после этого определяется есть ли в рабочей папке ($OEM$\Drivers) файл Drivers.7z, если есть то распаковывается в %SystemDrive%\Drivers
  • затем запускается утилита SetupCopyOEMInf.exe, которая сканирует все папки и подпапки в $OEM$\Drivers (или %systemdrive%\Drivers - если используются запакованные драйверы) и копирует все inf файлы в папку %windir%\Inf
  • и наконец, процесс установки возобновляется

Примечания

Этот метод не работает для установки RAID, SATA и SCSI драйверов.

Утилита WatchDriverSigningPolicy.exe, иногда не срабатывает и появляется диалог о неподписанности драйвера.

Если вы используете мультизагрузочный диск (с несколькими дистрибутивами), то при добавлении драйверов у вас не должно быть пробелов в SourcePath (название каталога, расположенного в корне носителя и содержащего дистрибутив). Например, не будет работать:

CD:\XP Pro\$OEM$\Drivers\nVidia ForceWare 77.72\

Замените пробел в XP Pro на какой-нибудь символ и

CD:\XP-Pro_A\$OEM$\Drivers\nVidia ForceWare 77.72\

будет работать.

Вы можете спокойно подправить файл Drivers.cmd под свои нужды (поменять пути, названия файлов и т.д.). Если вы не хотите держать файлы Drivers.cmd, nircmd.exe, Process.exe, SetupCopyOEMInf.exe, WatchDriverSigningPolicy.exe в корне директории $OEM$, то можно переместить их, например, в каталог $OEM$\Drv. В таком случае внутри этой папки нужно создать еще одну папку Drivers, в которой будут лежать незапакованные драйверы и не забыть поменять путь до файла Drivers.cmd в файле winnt.sif в строке Arguments: (%I$OEM$) на (%I$OEM$\Drv).

Автор: Vadikan, EgOrus
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 01.03.2005


Автоматическая установка

Интеграция SATA/RAID драйверов

Описать интеграцию SATA/RAID драйверов я собирался давно. К сожалению, моя конфигурация не позволяет протестировать интеграцию таких драйверов, и следовательно самостоятельное написание статьи исключалось. В первоначальном варианте сайта на странице драйверов была ссылка на хорошую статью GreenMachine, но она требовала от читателя некторой подготовки. Именно на этой статье и основана страница, рассказывающая о SATA/RAID драйверах, на сайте MSFN. Эта страница появилась там относительно недавно, и не существовала на момент написания первой редакции данной статьи.

Так или иначе, нашелся человек по имени Michael Hollinger, который взял на себя труд объединить в одно руководство информацию, разбросанную по форуму MSFN и сайтам участников форума. Его руководство показалось мне несложным и дающим достаточно информации для осуществления процесса интеграции "от и до". Michael любезно разрешил перевести его руководство на русский язык. Оригинальное руководство (PDF, 1.28 Mb) является публично доступной информацией и может быть использовано только в бесплатных или некоммерческих публикациях. Дисклэймер и контактную информацию автора можно найти в тексте руководства. Недавно Мichael прислал мне новую версию своего руководства, которое и выложено сейчас у меня. Руководство стало максимально подробным, с громадным количеством скриншотов (в основном Проводника и Блокнота ;-). Но поскольку суть осталась прежней, я не стал менять содержание своей статьи.

Надеюсь, что статья будет полезна не только людям, интересующимся автоматической установкой, но и всем, кто не имеет возможности установить SATA/RAID драйверы в процессе установки Windows по причине отсутствия флоппи привода. Все вопросы или замечания по данной статье, пожалуйста, задавайте в форуме. Теперь к делу.

Шаг 1 - Создание директорий

Создайте директорию для размещения всех драйверов и промежуточных файлов, которые будут конфигурироваться на предварительном этапе. В данной статье будет использоваться директория C:\preload, в которой надо создать поддиректории следующим образом C:\preload\$OEM$\$1\drivers

Шаг 2 - Распаковка драйверов

Вам понадобятся драйверы для SATA и/или RAID конторллеров. Их можно взять с CD, поставлявшегося в комплекте с материнской платой или ноутбуком. Более новые версии драйверов могут находиться на сайте производителя.

Распакуйте драйверы в директорию, названную по имени контроллера. Например, возможна такая структура

C:\preload\$OEM$\$1\drivers\motherboard\controller

Примечание: названия поддиректорий, содержащих драйверы, должны состоять из не более чем восьми символов. Например, для материнской платы ABIT IC7-MAXIII есть два набора драйверов Silicon Images: Si3112r и Si3114r. В таком случае нужно создать следующие директории

C:\preload\$OEM$\$1\drivers\IC7_MAX3\Si3112r
C:\preload\$OEM$\$1\drivers\IC7_MAX3\Si3114r

Если ваши драйверы находятся внутри установочной программы (нередко встречается у Intel), то распакуйте их из *.ехе при помощи WinRAR, например.

На данном этапе у вас в соответствующих директориях должны быть по крайней мере следующие файлы

*.sys
*.cat
*.inf

Шаг 2а - Распаковка драйверов Intel

Драйверы Intel представляют собой особый случай. Если у вас нет вышеуказанных файлов, то вероятнее всего у вас есть два кабинетных архива (*.cab) и setup.exe. В таком случае выполните следующую команду из командной строки:

c:\setup.exe –a –p c:\path

где path - директория, которую вы выбрали для распаковки. После распаковки ваши драйверы будут либо в поддиректори XP либо drivers. Скопируйте содержимое данной директории. Следуя нашей структуре, вы должны скопировать содержимое в

C:\preload\$OEM$\$1\drivers\motherboard\intel

Шаг 3 - Подбор файлов

Вы можете смело удалить файлы readme и любые директории относящиеся к другим операционным системам (Windows 2000 и Windows 98). Если одни и те же драйверы предназаначются для XP и 2000, то их, понятное дело, удалять не надо. Продолжая пример с ABIT IC7-MAXIII у нас теперь такая картина:

В директории C:\preload\$OEM$\$1\drivers\IC7_MAX3\Intel находятся файлы

TXTSETUP.OEM
iaAHCI.cat
iaStor.cat
iaAHCI.inf
iaStor.inf
iaStor.sys

А в директории C:\preload\$OEM$\$1\drivers\IC7_MAX3\Si3112r находятся файлы

SilSupp.cpl
TxtSetup.oem
si3112r.cat
Si3112r.inf
Si3112r.sys
SIWinAcc.sys
SiiSupp.vxd

и так далее для каждого из контроллеров.

Шаг 4 - Копирование файлов

Если содержимое установочного диска Windows XP у вас еще не скопировано на жесткий диск, но сейчас самое время это сделать. Копируем в C:\XPCD. Затем скопируйте директорию $ОЕМ$ из C:\preload в C:\XPCD.

Теперь нужно сделать сжатые копии всех *.sys файлов и скопировать их в C:\XPCD\i386 при помощи утилиты makecab. Из командной строки запустите следующую команду:

makecab C:\XPCD\$OEM$\$1\drivers\motherboard\controller\controller.sys C:\XPCD\I386\controller.SY_

где motherboard - название директории, которое вы дали по названию материнской платы, controller - соответственно название директории контроллера, а controller.sys и controller.SY_ - названия ваших *.sys файлов. У вас может быть более одного *.sys файла в каждой директории, однако вам нужен только тот, имя которого совпадает с именем *.inf файла. Если взять за пример шаг 6, то из директории Si3112r нам нужен только Si3112r.sys. Аналогичным образом добавьте в i386 все остальные *.sys файлы.

Шаг 5 - Редактирование секции [SourceDisksFiles] файла txtsetup.sif

Откройте в текстовом редакторе файл txtsetup.sif расположенный в C:\XPCD\i386. Блокнот подойдет, хотя и не слишком удобен для данной цели. Главное, чтобы редактор не создавал ненужного форматирования, такого как переносы строк, например.

Найдите первую секцию [SourceDisksFiles], которая располжена в районе 189 строки. В самом начале секции [SourceDisksFiles] добавьте следующую строку

controller.sys = 1,,,,,,3_,4,1

где controller.sys - имя файла, созданного на четвертом шаге. Аналогичным образом добавьте строки, соответствующие остальным *.sys файлам. Каждому файлу должна соответствовать одна строка. В нашем примере:

[SourceDisksFiles]
iaStor.sys = 1,,,,,,3_,4,1
Si3112r.sys = 1,,,,,,3_,4,1
Si3114r.sys = 1,,,,,,3_,4,1
viasraid.sys = 1,,,,,,3_,4,1

Рассказ о формате этих строк я решил вынести на отдельную страницу ввиду сложности материала.

Шаг 6 - Редактирование секции [HardwareIdsDatabase] файла txtsetup.sif

Не закрывайте txtsetup.sif и найдите секцию [HardwareIdsDatabase], находящуюся в районе строки 18800. Мы через минуту вернемся к этой секции, а пока рассмотрим файлы, находящиеся в директориях с драйверами. Там есть файлы, информацию из которых нужно скопировать в txtsetup.sif. Нам понадобится либо *.oem либо *.inf файл из каждой из них. Идем в первую директорию и действуем по следующему принципу: если есть одноименный *.sys файлу *.oem файл, то открываем его, а если нет, то открываем одноименный *.inf файл. Если используете *.oem файл, то найдите все строки, начинающиеся с PCI\VEN_, заключенные в кавычки. Если используете *.inf файл, то найдите секцию [Strings], где есть аналогичные строки (но без кавычек). Проигнорируйте строки начинающиеся с %. Скопируйте каждую строку от начала до первой точки (не включая точку). Например, если строка PCI\VEN_8086&DEV_2652&CC_0104.DeviceDesc = "Intel(R) 82801FR SATA RAID Controller", то скопировать нужно только PCI\VEN_8086&DEV_2652&CC_0104 и больше ничего.

Теперь поместите скопированные строки в секцию [HardwareIdsDatabase] файла txtsetup.sif и добавьте к каждой = “sysfile”, где sysfile - имя вашего *.sys файла одноименного *.oem или *inf. файлу. В нашем примере в секции [HardwareIdsDatabase] это выглядит так:

[HardwareIdsDatabase]
PCI\VEN_8086&DEV_2652&CC_0104 = "iaStor"
PCI\VEN_8086&DEV_2652&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_24DF&CC_0104 = "iaStor"
PCI\VEN_8086&DEV_25B0&CC_0104 = "iaStor"
PCI\VEN_1095&DEV_3112 = "Si3112r"
PCI\VEN_1095&DEV_3512 = "Si3112r"

PCI\VEN_1002&DEV_436E = "Si3112r"
PCI\VEN_1002&DEV_4379 = "Si3112r"
PCI\VEN_1002&DEV_437A = "Si3112r"
PCI\VEN_1095&DEV_3114 = "Si3114r"
PCI\VEN_1106&DEV_3149 = "viasraid"

Шаг 7 - Редактирование секциий [SCSI.load] и [SCSI] файла txtsetup.sif

Теперь найдите секцию [SCSI.load] в районе строки 19266. Добавьте следующую строку для каждого *.sys файла

sysfile = sysfile.sys,4

где sysfile опять же имя вашего *.sys файла. В нашем примере в секции [SCSI.load] это выглядит так:

[SCSI.Load]
iaStor = iaStor.sys,4
Si3112r = Si3112r.sys,4
Si3114r = Si3114r.sys,4
viasraid = viasraid.sys,4

Теперь найдите секцию [SCSI] в районе строки 21613. Добавьте следующие строки для каждого *.sys файла.

sysfile = “Description”

где sysfile - имя вашего *.sys файла, a Description - любое описание, которое вы хотите дать контроллеру. Проще всего использовать описания из *.inf файла. В нашем примере это выглядит так:

[SCSI]
iaStor = "Intel(R) 82801FR/82801ER/6300ESB SATA RAID Controller"
Si3112r = "Silicon Image SiI 3x12 SATARaid Controller"
Si3114r = "Silicon Image SiI 3114 SATARaid Controller"
viasraid = "VIA Serial ATA RAID Controller"

На этом редактирование txtsetup.sif закончено. Закройте и сохраните файл.

Шаг 8 - Редактирование (создание) winnt.sif

Теперь настало время изменить winnt.sif (или создать новый, если у вас его еще нет). Подробнее о winnt.sif я рассказываю тут, поэтому остановлюсь лишь на секции [Unattended]. Для успешной установки драйверов необходимо наличие в секции следующих параметров

[Unattended]
OEMPreinstall=Yes
OemPnPDriversPath=”Drivers\path”

где path - путь к директории с драйверами контроллера. В нашем примере это выглядит так:

[Unattended] OEMPreinstall=Yes
OemPnPDriversPath=”drivers\IC7_MAX3\intel;drivers\IC7_MAX3\Si3112r;drivers\IC7_MAX3\Si3114r;drivers\IC7_MAX3\via”

Поскольку у нас драйвера расположены в нескольких директориях, мы заключаем их перечисление в кавычки и разделяем "точкой с запятой". Все значения параметра OemPnPDriversPath должны быть в одну строку, переносы недопустимы. Закройте winnt.sif и сохраните изменения (или сохраните ваш файл как winnt.sif в i386).

Заключение

В общем, на этом процедуру интеграции SATA/RAID драйверов можно считать законченой. Дальнейшие шаги оригинального руководства рассказывают о том, как создать загрузочный диск Windows XP. Не вижу смысла повторяться.

Благодарности

Остается лишь поблагодарить Майкла Холлингера и отдать должное тем людям, чьи книги, статьи и сообщения в форумах были использованы в его руководстве. Автор следует одному из общепринятых Американских стилей, используемых в научных публикациях. Я, уж извините, стиль выдерживать не буду ;-)

  1. Chandra, Omeeda. (2004 October). Книга Update Your Windows XP CD. Maximum PC, 68-70
  2. GreenMachine. Slipstreaming SATA/RAID Drivers.
  3. Gosh. Txtsetup.sif.
  4. raskren (2004, January 5) Сообщение в теме Unattended install, SATA drivers, and NO Floppy , I finally got it to work!
  5. raskren (2004, February 9) Сообщение в теме Switches in TXTSETUP.SIF.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 02.03.2005


Автоматическая установка

Параметры [SourceDisksFiles]

Параметры строк в секции [SourceDisksFiles] файла txtsetup.sif

Информация о параметрах строк в секции [SourceDisksFiles] файла txtsetup.sif была почерпнута из текста оригинального руководства, а также статей и тем форума MSFN, указанных в разделе References (Благодарности). За основу я взял картинку, созданную raskren (участником форума MSFN), и перевел комментарии на русский язык.

Красным выделены необязательные параметры.

Имя файла.
Статус файла. 100=SP1, 1=Оригинальный или RTM (RTM - released to manufacturer).
Необходимые запятые. Минимум - 6 запятых; 7 запятых для игнорирования следующего параметра (3_ или _х). Я, честно говоря, не очень понял что произойдет в случае игнорирования параметра.
Если файл сжат: 3_, если файл не сжат: _х
Директория назначения. Параметры директорий определены в [WinntDirectories].
Upgrade Code - одна цифра указывающая нужно ли обновлять старую версию файла. Параметр может принимать четыре значения:
  • 0 - Всегда копировать файл
  • 1 - Копировать файл, если он существует в инсталляционной директории
  • 2 - Не копировать файл, если он существует в инсталляционной директории
  • 3 - Не копировать файл
Три запятые обязательны, если используется New Install Code.
New Install Code используется при чистой установке и указывает нужно ли копировать файл во время текстового этапа установки системы. Moжет принимать такие же четыре значения, как и Upgrade code. Если New Install Code не используется, то файл не копируется.
Назначение не выяснено

В общем, данное описание параметров ответило на некоторые вопросы, но породило новые :) Если в описании есть ошибки или необходимы добавления, то сообщите в форуме или по эл. почте.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 14.03.2005


Автоматическая установка

Пакеты драйверов от Bâshrat the Sneaky

Bâshrat the Sneaky, участник конференции MSFN, создал пакеты драйверов с целью включить в них как можно больше различных драйверов. Удобство пакетов в том, что вам не надо искать индивидуальные драйверы - они все включены в пакет. На данный момент существует шесть пакетов драйверов:

  • DriverPack Chipset (чипсет)
  • DriverPack MassStorage (контроллеры жеских дисков)
  • DriverPack Sound (звуковые карты)
  • DriverPack Graphics (видео карты)
  • DriverPack LAN (сетевые адаптеры)
  • DriverPack WLAN (беспроводные сетевые адаптеры)

Вы найдете ссылки на пакеты драйверов в этом форуме на MSFN.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 03.03.2005


Автоматическая установка

Твики реестра

Смысл импортирования ключей реестра заключается в том, что после установки системы вам не понадобится редактировать реестр вручную или при помощи “твикеров”. Во время первого входа в систему все нужные вам ключи будут автоматически импортированы в реестр. Наверное, уже классическим твиком стало ускорение меню Пуск, которое по умолчанию открывает свои элементы слишком медленно. Как известно, для того чтобы его ускорить, нужно открыть редактор реестра, найти ключ HKEY_CURRENT_USER\Control Panel\Desktop и изменить значение параметра MenuShowDelay с 400 до 2 (или любого подходящего вам числа). Собственно говоря, можно создать файлик, выполняющий данное изменение. Если в Блокнот скопировать следующий текст:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Desktop]
"MenuShowDelay"="2"

и сохранить файл с расширением *.reg, то запуск такого файла и произведет нужное вам изменение. Именно таким образом и производится импортирование ключей реестра при установке системы. С той лишь разницей, что в одном файле перечисляется сразу несколько ключей и параметров.

Ниже вы увидите некоторые ключи реестра, которые я обычно изменяю сразу. Можете скопировать их в Блокнот и рассмотреть получше. Если вы не понимаете, за что отвечает тот или иной ключ, то лучше не используйте его. Тот факт, что им пользуюсь я, совсем не означает, что он подойдет вам. Например, у меня отключено Восстановление системы и Автоматические Обновления. Почему я использую раздельные файлы для HKEY_LOCAL_MACHINE (HKLM) и HKEY_CURRENT_USER (HKCU) я объясню чуть позже.

HKLM

Windows Registry Editor Version 5.00
;-----------------------
;Оптимизация операционной системы
;-----------------------

;Отключить автоматическую перезагрузку в случае BSOD
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
"AutoReboot"=dword:00000000

;Ускорить выключение компьютера
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
"WaitToKillServiceTimeout"="3000"

;Отключить сообщения об ошибках, но оставить уведомление о критических ошибках
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting]
"DoReport"=dword:00000000

;Не использовать простое распределение файлов (simple file sharing)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"forceguest"=dword:00000000

;Ускорить работу с сетевыми дисками, убирая запланированные сетевые задания (Network Scheduling Tasks)
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}]

;Убрать стрелки у ярлыков
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons]
"29"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,74,00,\
  25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,\
  00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,35,00,30,00,\
  00,00

;Отключить приглашение на Тур по Windows
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Applets\Tour]
"RunCount"=dword:00000000

;Отключить восстановление системы
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore]
"DisableSR"=dword:00000001

;Корзина использует 3% от доступного места на диске (не 10%)
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\BitBucket]
"Percent"=dword:00000003

;Отключить автоматические обновления системы
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoUpdate"=dword:00000001

;Отключить автоматические обновления системы
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
"AUOptions"=dword:00000001
"AUState"=dword:00000007

;---------------
;Оптимизация служб
;---------------

;Отключить службу Messenger (останавливает спам. не влияет на MSN or Windows Messenger)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Messenger]
"Start"=dword:00000004

;Отключить удаленный доступ к реестру
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteRegistry]
"Start"=dword:00000004

;Отключить поддержку источника бесперебойного питания
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UPS]
"Start"=dword:00000004

;Отключить восстановление системы
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\srservice]
"Start"=dword:00000004

;Отключить индексирование
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CiSvc]
"Start"=dword:00000004

;Отключить беспроводную конфигурацию
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WZCSVC]
"Start"=dword:00000004

;Отключить Smart Card Helper
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SCardDrv"]
"Start"=dword:00000004

;Disable Portable Media Serial Number (хм, даже не знаю как перевести эту глупость :)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WmdmPmSN"]
"Start"=dword:00000004

;Отключить удаленный рабочий стол
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RDSessMgr"]
"Start"=dword:00000004

;Отключить службу записи на оптические носители (IMAPI, нужна только для встроенной в XР записи)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ImapiService]
"Start"=dword:00000004

;----------------------------------------------
;Оптимизация функциональности Windows
;----------------------------------------------

;Убрать Общие Документы из Мой Компьютер
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\DelegateFolders\{59031a47-3f72-44a7-89c5-5595fe6b30ee}]

;Позволить переименовывать Корзину
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:50,01,00,20
"CallForAttributes"=dword:00000000

;Отображать Админстрирование в Панели управления
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]
@="Administrative Tools"

;Не группировать сходные приложения в панели задач
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"TaskbarGlomming"=dword:00000000

;Отключить поиск в сети Интернет при открытии файла с неизвестными расширением
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system]
"NoInternetOpenWith "=dword:00000001

HKCU

Windows Registry Editor Version 5.00
;-----------------------
;Оптимизация операционной системы
;-----------------------

;Убрать автоматический поиск сетевых папок и принтеров
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"NoNetCrawling"=dword:00000001

;Отключить Помощника очистки рабочего стола (Desktop Cleanup Wizard)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Desktop\CleanupWiz]
"NoRun"=dword:00000001

;----------------------------------------------
;Оптимизация функциональности Windows
;----------------------------------------------

;Отключить проверку недостатка места на диске
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoLowDiskSpaceChecks"=dword:00000001

;Ускорить меню Пуск
[HKEY_CURRENT_USER\Control Panel\Desktop]
"MenuShowDelay"="2"

;Отключить все всплывающие уведомления в трее (в том числе и об установке Интернет соединения)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"EnableBalloonTips"=dword:00000000

;Отключить меню Недавние Документы в меню Пуск
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoRecentDocsMenu"=hex:01,00,00,00

;Отключить Недавние Документы
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoRecentDocsHistory"=dword:00000001

;Отключить "Ярлык для" при создании новых ярлыков
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

;Убрать ярлык "Программы по умолчанию" из меню Пуск
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoSMConfigurePrograms"=dword:00000001

;Отключить уведомление о новых программах в меню Пуск (выделение цветом)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"Start_NotifyNewApps"=dword:00000000

;Enable QuickLaunch
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams\Desktop]
"TaskbarWinXP"=hex:0c,00,00,00,08,00,00,00,03,00,00,00,00,00,00,00,b0,e2,2b,d8,\
  64,57,d0,11,a9,6e,00,c0,4f,d7,05,a2,22,00,1c,00,0a,11,00,00,1a,00,00,00,01,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,4c,00,00,00,01,14,02,00,00,00,\
  00,00,c0,00,00,00,00,00,00,46,81,00,00,00,11,00,00,00,10,52,28,ce,e8,c8,c4,\
  01,10,3d,a2,c6,27,d0,c4,01,80,d9,44,28,27,d0,c4,01,00,00,00,00,00,00,00,00,\
  01,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,01,02,14,00,1f,50,e0,4f,d0,\
  20,ea,3a,69,10,a2,d8,08,00,2b,30,30,9d,19,00,2f,43,3a,5c,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,5c,00,31,00,00,00,00,00,6c,31,96,96,\
  10,00,44,4f,43,55,4d,45,7e,31,00,00,44,00,03,00,04,00,ef,be,67,31,67,7a,75,\
  31,80,9b,14,00,00,00,44,00,6f,00,63,00,75,00,6d,00,65,00,6e,00,74,00,73,00,\
  20,00,61,00,6e,00,64,00,20,00,53,00,65,00,74,00,74,00,69,00,6e,00,67,00,73,\
  00,00,00,18,00,36,00,31,00,00,00,00,00,6c,31,97,96,10,00,56,61,64,69,6b,00,\
  22,00,03,00,04,00,ef,be,6c,31,96,96,75,31,86,9b,14,00,00,00,56,00,61,00,64,\
  00,69,00,6b,00,00,00,14,00,64,00,31,00,00,00,00,00,72,31,72,34,13,00,41,50,\
  50,4c,49,43,7e,31,00,00,4c,00,03,00,04,00,ef,be,6c,31,96,96,75,31,87,9b,14,\
  00,36,00,41,00,70,00,70,00,6c,00,69,00,63,00,61,00,74,00,69,00,6f,00,6e,00,\
  20,00,44,00,61,00,74,00,61,00,00,00,40,73,68,65,6c,6c,33,32,2e,64,6c,6c,2c,\
  2d,32,31,37,36,35,00,18,00,42,00,31,00,00,00,00,00,6c,31,97,96,14,00,4d,49,\
  43,52,4f,53,7e,31,00,00,2a,00,03,00,04,00,ef,be,6c,31,96,96,6c,31,99,96,14,\
  00,00,00,4d,00,69,00,63,00,72,00,6f,00,73,00,6f,00,66,00,74,00,00,00,18,00,\
  52,00,31,00,00,00,00,00,6c,31,9a,96,10,00,49,4e,54,45,52,4e,7e,31,00,00,3a,\
  00,03,00,04,00,ef,be,6c,31,96,96,6c,31,9c,96,14,00,00,00,49,00,6e,00,74,00,\
  65,00,72,00,6e,00,65,00,74,00,20,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,\
  00,72,00,00,00,18,00,48,00,31,00,00,00,00,00,6c,31,9c,96,11,00,51,55,49,43,\
  4b,4c,7e,31,00,00,30,00,03,00,04,00,ef,be,6c,31,99,96,6c,31,9c,96,14,00,00,\
  00,51,00,75,00,69,00,63,00,6b,00,20,00,4c,00,61,00,75,00,6e,00,63,00,68,00,\
  00,00,18,00,00,00,60,00,00,00,03,00,00,a0,58,00,00,00,00,00,00,00,76,61,64,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,2c,7c,fa,da,b6,41,5f,44,ad,b6,c9,12,\
  99,70,2f,0a,b6,c1,df,66,dc,34,d9,11,b4,b3,be,8b,67,44,fb,1e,2c,7c,fa,da,b6,\
  41,5f,44,ad,b6,c9,12,99,70,2f,0a,b6,c1,df,66,dc,34,d9,11,b4,b3,be,8b,67,44,\
  fb,1e,10,00,00,00,05,00,00,a0,1a,00,00,00,23,01,00,00,00,00,00,00,08,00,00,\
  00,02,00,00,00,46,03,00,00,01,00,00,00,08,00,00,00,60,00,00,00,02,00,00,00,\
  52,00,32,00,60,02,00,00,67,31,e3,a9,20,00,45,44,49,41,4c,45,7e,31,2e,4c,4e,\
  4b,00,00,36,00,03,00,04,00,ef,be,6c,31,37,99,75,31,50,bc,14,00,00,00,45,00,\
  44,00,69,00,61,00,6c,00,65,00,72,00,2e,00,65,00,78,00,65,00,2e,00,6c,00,6e,\
  00,6b,00,00,00,1c,00,00,00,00,00,00,00,a0,00,00,00,05,00,00,00,92,00,32,00,\
  0b,03,00,00,6c,31,9d,96,20,00,4c,41,55,4e,43,48,7e,31,2e,4c,4e,4b,00,00,76,\
  00,03,00,04,00,ef,be,6c,31,99,96,76,31,d2,00,14,00,5e,00,4c,00,61,00,75,00,\
  6e,00,63,00,68,00,20,00,49,00,6e,00,74,00,65,00,72,00,6e,00,65,00,74,00,20,\
  00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,20,00,42,00,72,00,6f,00,\
  77,00,73,00,65,00,72,00,2e,00,6c,00,6e,00,6b,00,00,00,40,78,70,73,70,31,72,\
  65,73,2e,64,6c,6c,2c,2d,31,31,30,30,33,00,00,1c,00,00,00,00,00,00,00,5e,00,\
  00,00,06,00,00,00,50,00,32,00,cf,02,00,00,6d,31,24,24,20,00,4d,49,52,41,4e,\
  44,7e,31,2e,4c,4e,4b,00,00,34,00,03,00,04,00,ef,be,6d,31,24,24,76,31,d2,00,\
  14,00,00,00,4d,00,69,00,72,00,61,00,6e,00,64,00,61,00,20,00,49,00,4d,00,2e,\
  00,6c,00,6e,00,6b,00,00,00,1c,00,00,00,00,00,00,00,50,00,00,00,03,00,00,00,\
  42,00,32,00,8a,02,00,00,67,31,ad,a5,20,00,4f,70,65,72,61,2e,6c,6e,6b,00,2a,\
  00,03,00,04,00,ef,be,6c,31,49,98,75,31,50,bc,14,00,00,00,4f,00,70,00,65,00,\
  72,00,61,00,2e,00,6c,00,6e,00,6b,00,00,00,18,00,00,00,00,00,00,00,76,00,00,\
  00,00,00,00,00,68,00,32,00,4f,00,00,00,6c,31,9c,96,20,00,53,48,4f,57,44,45,\
  7e,31,2e,53,43,46,00,00,4c,00,03,00,04,00,ef,be,6c,31,9c,96,75,31,50,bc,14,\
  00,36,00,53,00,68,00,6f,00,77,00,20,00,44,00,65,00,73,00,6b,00,74,00,6f,00,\
  70,00,2e,00,73,00,63,00,66,00,00,00,40,78,70,73,70,32,72,65,73,2e,64,6c,6c,\
  2c,2d,36,31,30,30,00,1c,00,00,00,00,00,00,00,5a,00,00,00,07,00,00,00,4c,00,\
  32,00,bc,02,00,00,6f,31,8d,1c,20,00,53,4e,41,47,49,54,7e,31,2e,4c,4e,4b,00,\
  00,30,00,03,00,04,00,ef,be,6f,31,8d,1c,76,31,d2,00,14,00,00,00,53,00,6e,00,\
  61,00,67,00,49,00,74,00,20,00,37,00,2e,00,6c,00,6e,00,6b,00,00,00,1c,00,00,\
  00,00,00,00,00,5a,00,00,00,01,00,00,00,4c,00,32,00,10,09,00,00,76,31,21,01,\
  20,00,54,48,45,42,41,54,7e,31,2e,4c,4e,4b,00,00,30,00,03,00,04,00,ef,be,6c,\
  31,12,98,76,31,21,01,14,00,00,00,54,00,68,00,65,00,20,00,42,00,61,00,74,00,\
  21,00,2e,00,4c,00,4e,00,4b,00,00,00,1c,00,00,00,00,00,00,00,62,00,00,00,04,\
  00,00,00,54,00,32,00,bc,02,00,00,6c,31,fa,96,20,00,54,4f,54,41,4c,43,7e,31,\
  2e,4c,4e,4b,00,00,38,00,03,00,04,00,ef,be,6c,31,eb,96,75,31,50,bc,14,00,00,\
  00,54,00,4f,00,54,00,41,00,4c,00,43,00,4d,00,44,00,2e,00,45,00,58,00,45,00,\
  2e,00,6c,00,6e,00,6b,00,00,00,1c,00,00,00,00,00,00,00,99,00,00,00,e0,06,00,\
  00,00,00,00,00,19,00,00,00,00,00,00,00,00,00,00,00,19,00,00,00,00,00,00,00,\
  01,00,00,00,01,00,00,00,aa,4f,28,68,48,6a,d0,11,8c,78,00,c0,4f,d9,18,b4,f2,\
  02,00,00,e0,0c,00,00,00,00,00,00,19,00,00,00,00,00,00,00,00,00,00,00,19,00,\
  00,00,00,00,00,00,01,00,00,00,02,00,00,00,8b,8a,0d,54,3f,1c,32,4e,81,32,53,\
  0f,6a,50,20,90,1e,00,00,00,e0,04,00,00,00,00,00,00,18,00,00,00,00,00,00,00,\
  00,00,00,00,18,00,00,00,00,00,00,00,01,00,00,00

;----------------------------------------------
;Оптимизация Проводника и Internet Explorer
;----------------------------------------------

;Сортировать меню Пуск и Избранное в алфавитном порядке
[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Favorites]
[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu]
[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu2]

;Отключить отладку скриптов в IE
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Disable Script Debugger"="yes"

;Поиск в Google из строки адреса
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl\G]
@="http://www.google.com/search?q=%s"

;Включить отображение расширений в Проводнике
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"HideFileExt"=dword:00000000

;Показывать скрытые файлы и папки
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"Hidden"=dword:00000002

;------------
;Разное
;------------

;Отключить предпросмотр фильмов в Проводнике (ускоряет работу и позволяет перемещать и удалять файлы)
[-HKEY_CLASSES_ROOT\.avi\ShellEx]
[-HKEY_CLASSES_ROOT\.mpg\ShellEx]
[-HKEY_CLASSES_ROOT\.mpe\ShellEx]
[-HKEY_CLASSES_ROOT\.mpeg\ShellEx]

Скопируйте содержимое файлов в Блокнот, чтобы рассмотреть получше. Потом файлы можно сохранить, но обязательно с расширением *.REG, а не *.TXT, которое Блокнот предложит по умолчанию.

О ветвях реестра и способах импортирования ключей

Читая сообщения в конференциях MSFN и OSZone, я пришел к выводу, что некоторые участники неверно интерпертируют назначение ветвей реестра. Думаю, что не помешает небольшое разъяснение. Я не буду вдаваться в подробности, а лишь обрисую основы применительно к автоматической установке системы. Для общего образования я рекомендую ознакомиться со статьей MS KB Описание реестра Microsoft Windows. Теперь конкретнее о ветвях.

HKEY_LOCAL_MACHINE (HKLM) anchor

Название само по себе информативно: ключи локальной машины. Изменения, которые вы вносите в эту ветку, применяются ко всем учетным записям. Tаким образом, отключив какую-нибудь службу, вы делаете ее недоступной для всех пользователей. Во время автоматической установки Windows лучше всего импортировать HKLM ключи при первом входе в систему, после загрузки оболочки. "Ага!", скажете вы, "Значит можно и раньше?" Можно (об этом ниже), но не нужно. Некоторые HKLM ключи не срабатывают на более раннем этапе.

Типичным способом импортирования ключей является пакетный файл, запускаемый из [GuiRunOnce]. Файл содержит такую команду

ECHO.
ECHO Applying Registry Tweaks...
REGEDIT /S %systemdrive%\install\hklm.reg

HKEY_CURRENT_USER (HKCU) anchor

Опять же, название говорит само за себя: ключи текущего пользователя. В принципе, изменения, которые вы вносите в эту ветку, применяются только к учетной записи, из-под которой делаются изменения. Безусловно, HKCU ключи можно импортировать при первом входе в систему. Если вы работаете из-под встроенной учетной записи Администратор, так, наверное, и следует делать. Я, однако, предпочитаю работать из-под другой учетной записи с правами администратора, оставляя встроенного Администратора на всякий случай нетронутым. Если во время автоустановки первым вход в систему осуществит Администратор, то к его учетной записи все HKCU твики и применятся, а остальные учетные записи останутся ненастроенными.

К счастью, для тех, кто работает более чем с одной учетной записью есть обходной путь. Во время автоматической установки вы можете импортировать ключи на этапе, когда ни один из пользователей еще не вошел в систему. Делается это из файла cmdlines.txt. Такой способ особенно полезен тем, что HKCU ключи фактически импортируются в настройки пользователя по умолчанию (Default User), чья ветвь реестра подключается вместо HKCU во время установки Windows. Когда пользователь входит в систему первый раз, его настройки берутся из профиля Default User. Таким образом, все ключи, импортированные в HKCU из cmdlines.txt, применяются ко всем учетным записям создаваемым впоследствии. Теперь понятно, почему у меня два раздельных файла твиков реестра для HKLM и HKCU? Сколько бы я пользователей не создавал впоследствии, у всех у них интерфейс уже будет максимально настроен (в соответствии с моими предпочтениями :)

Для импортирования HKCU ключей из cmdlines.txt достаточно разместить файл hkcu.reg в корне директории $ОEМ$ и добавить в cmdlines.txt следующие строки:

[Commands]
"REGEDIT /S hkcu.reg"

HKEY_CLASSES_ROOT (HKCR) anchor

Я не буду дублировать весьма подробное описание этой ветви реестра, данное в статье МS KB. Ознакомьтесь с ним самостоятельно. Я его интерпретирую следующим образом. Если вы хотите, чтобы изменения затронули всех пользователей (включая будущих), то либо импортируйте HKCR ключи вместе с HKCU из cmdlines.txt, либо импортируйте ключи в раздел HKEY_LOCAL_MACHINE\Software\Classes при первом входе в систему.

HKEY_USERS (HKU) anchor

Назначение этого ключа нередко интерпретируется неправильно. Видимо то, что он относится ко всем пользователям когда-либо входившим в систему, и является причиной путаницы. Разберем его составляющие чуть подробнее.

HKEY_USERS\.DEFAULT

Я обратил внимание, что участники конференций MSFN и OSZone пытаются использовать этот ключ для импортирования HKCU твиков, рассчитывая применить их ко всем пользователям. Не исключаю, что в некоторых случаях это сработает. Однако, вы уже знаете как это сделать правильнее и надежнее. Более того, HKEY_USERS\.DEFAULT скорее относится к настройкам, регулирующим процессы до входа пользователя в систему (например, раскладка клавиатуры по умолчанию).

HKEY_USERS\S-[длинный-набор-цифр]

Таких ключей может быть несколько. Это зависит от количества пользователей, когда-либо входивших в систему. Если вы попробуете отследить установку какого-нибудь приложения с помощью программ, мониторящих изменения в реестре, то вероятно увидите, что как раз в один из этих ключей вносятся изменения. Это и есть ваш профиль. С практической точки зрения этот ключ неинтересен, т.к. длинный набор цифр уникален для каждой системы, и в новой системе он будет уже другим. Фактически, такие изменения равносильны изменениям в HKCU.

Надеюсь этот небольшой экскурс в реестр будет вам полезен.

Практические советы anchor

Как известно, твики реестра позволяют настроить практически любые параметры системы. Я уже забыл, когда последний раз пользовался твикером, т.к. система уже сразу устанавливается с учетом моих предпочтений. Вероятно, вы захотите сделать тоже самое. Резонный вопрос: как узнать какой твик реестра отвечает за те или иные изменения в системе, произвoдимые через пользовательский интерфейс?

В сети масса сайтов, содержащих информацию о ключах реестра. Начать можете с www.oszone.net. Большая подборка твиков в этой теме на msnf.org. Eсть аналогичная тема и на OSZone. Не копируйте все твики разом, а постарайтесь вникнуть в смысл каждого из них. Сравните со своими настройками системы.

Кстати, экспортирование ключей вашей настроенной системы - отличный вариант. Так, например, изрядное количество настроек меню Пуск и вида папок находится в ключе

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced.

Если вы не уверены за что отвечает тот или иной ключ, вбейте его название в Google, и ответ не заставит себя ждать.

Если ваши поиски не увенчались успехом, то... вы плохо искали :) Можете попробовать произвести мониторинг системы самостоятельно. В этом вам помогут бесплатные программы Regmon (мониторинг в реальном времени) и Regshot (снимок до и после изменений).

Ну и конечно, вы всегда можете задать вопрос на форуме в теме про твики реестра.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 28.02.2005


Автоматическая установка

Добавлeние учетных записей

Одним из кажущихся недостатков автоматической установки является то, что все работает только для дефолтной учетной записи Админстратора. Иными словами, программы устанавливаются для пользователя, который в данный момент вошел в систему (а это и будет Администратор). Таким образом некоторые программы могут быть недоступны для других пользователей, созданных впоследствии. Конечно, большинство программ устанавливаются для всех пользователей, однако если у вас есть любимые приложения, которые работают только для учетной записи, из-под которой они были установлены, то это статья для вас. Вообще, я считаю неплохой идеей пользоваться учетной записью с правами администратора, а учетную запись Администратор использовать лишь в случае крайней необходимости. К примеру, могут возникнуть ситуации, когда ваша единственная учетная запись оказыается заблокирована. Если это был Администратор, то вам придется повозиться. В противном случае разблокировка будет легким и приятным занятием.

Мы рассмотрим два способа добавления пользователей:

  • OOBEINFO.INI
  • NET USER

Также, на этой странице описывается как организовать автоматический вход в систему посредством импортировния ключей реестра. Учтите однако, что если вы создаете только одного пользователя способом OOBEINFO.INI, то для автологона импорт ключей реестра не нужен.

Способ OOBEINFO.INI

Примечание: метод работает только для Windows XP/2003

Используя этот способ вы попросту автоматизируете процесс создания пользователей, который обычно выполняется вручную на одном из графических этапов установки Windows. Это тот же этап, на котором вас просят создать подключение к сети Интернет.

Приступим. Откройте Блокнот и скопируйте туда следущие строки:

[UserInfo]
Identity000="Vadikan"
Identity001="Alex"

Имя пользователя заключено в кавычки; подставьте свое. Если вам нужен только один пользователь, то удалите второго. Eсли вам нужно больше пользователей, то добавляйте строки, увеличивая номер на единицу. Данный способ позволяет создать не более шести учетных записей (вплоть до Identity005). Учтите, что все пользователи будут включены в группу Админстраторы.

По окончании сохраните файл как oobeinfo.ini в директории $ОЕМ$\$$\System32\oobe

Способ NET USER

Данный способ был описан еще в предыдущей версии сайта. Он более универсален, т.к. работает на всех NT платформах и позволяет создавать сколько угодно учетных записей, помещая их в различные группы.

Мы хотим создать учетную запись во время GUI этапа установки Windows (этап когда вы видите отсчет времени). Для этого мы будем использовать файл cmdlines.txt (подробнее о cmdlines.txt в соответствующей статье). Сделав это мы сможем автоматизировать первый вход в систему под вашей новой учетной записью.

Если у вас еще не создан файл cmdlines.txt, то откройте Блокнот и скопируйте туда следуюший текст

[COMMANDS]
"useraccounts.cmd"

Сохраните файл как cmdlines.txt в директории C:\XPCD\$OEM$\.

Обратите внимание, что мы запускаем файл useraccounts.cmd из cmdlines.txt. Следовательно, скопируйте в Блокнот следующий текст:

net user Vadikan asdf1234 /add
net localgroup Administrators Vadikan /add
net accounts /maxpwage:unlimited
REGEDIT /S autologon.reg
EXIT

Таким образом мы добавляем пользователя Vadikan с паролем asdf1234 в группу Administrators. net accounts /maxpwage:unlimited нужно для того, чтобы пароль не истек через 14 дней. Замените имя пользователя и пароль по своему усмотрению и сохраните файл как useraccounts.cmd в директории C:\XPCD\$OEM$\. Внимание: в локализованой русской версии группа Administrators, вероятно, называется Администраторы. Следовательно, вам надо внести соответствующие изменения, и сохранять файл в кодировке DOS 866. Блокнот эту кодировку не поддерживает, и нужен другой редактор. Начать поиск редактора можно отсюда. Пользователям файлового менеджера FAR редактор искать не нужно.

Еще один момент, на который следует обратить внимание: если вы хотите создать пользователя, в имени которого есть пробелы (например, Super Vadikan), то вы должны заключить такое имя в кавычки:

net user "Super Vadikan" asdf1234 /add

Aвтоматический вход в систему

Я рекоменудю вам ознакомиться со статьей MS KB Автоматизация входа в систему Windows, прежде чем приступать к изучению этой секции.

Итак, мы хотим импортировать автоматический вход в систему (auto logon) для вновь созданного пользователя. Для этого мы уже внесли команду "REGEDIT /S autologon.reg" в useraccounts.cmd. Теперь остается создать соответствующий файл. Скопируйте в Блокнот следующие строки

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"DefaultUserName"="Vadikan"
"DefaultPassword"="asdf1234"
"AutoAdminLogon"="1"
"AutoLogonCount"=dword:00000001

Параметр AutoLogonCount задает количество автоматических входов в систему (в данном случае - один). Уберите этот параметр, если вы хотите постоянно входить в систему автоматически. Подставьте свое имя и пароль, и затем сохраните текст как autologon.reg в директории C:\XPCD\$OEM$\.

Заключительный этап

Чтобы все прошло гладко, нужно убедиться, что секция [GuiUnattended] в winnt.sif содержит только две строки, относящиеся к администратору:

AdminPassword=*
EncryptedAdminPassword=No

Уберите все остальное (например, AutoLogon или AutoLogonCount). Замените звездочку в AdminPassword паролем, если вы хотите защитить учетную запись Администратор от постороннего доступа. Вы также можете зашифровать пароль используя Setup Manager, входящий в состав Deployment Tools. Там есть опция EncryptedAdminPassword, значение которой надо установить в Yes.

Необходимо помнить, что все, что вы указываете в winnt.sif (например, AdminPassword) не влияет на учетную запись Vadikan, описываемую на этой странице. Это влияет только на встроенную учетную запись Администратор.

Если вы все сделали правильно, то во время установки вы увидите мигнувшее окно командной строки на Т-12 этапе установки Windows. Именно в этот момент и будет запущен файл useraccounts.cmd из cmdlines.txt.

Примечание

Изучив два метода, вы, возможно, задумались над тем, как создать учетные записи способом OOBEINFO.INI, но лишь одну из них сделать Администратором. В принципе, это возможно. Обратите внимание на файл useraccounts.cmd, в котором для добавления учетных записей использовалась команда NET ADD. Можно применить ее в комбинации с командой для удаления учетных записей NET DELETE. В моем примере я создавал учетные записи Vadikan и Alex. Допустим, я хочу переместить Alex из администраторов, в обычные пользователи:

net localgroup Administrators "Alex" /delete
net localgroup Users "Alex" /add

Данные команды можно добавить в любой пакетный файл, который будет выполнен при первом входе в систему.

Автор: Vadikan
Иcточник: (частично перeведено с англ. - unattended.msfn.org)

Наш форум

Опубликована- 27.02.2005


Автоматическая установка

Активация

Вы еще не устали от различных вариантов? Надеюсь, что нет, т.к. активацию Windows можно выполнить тремя способами (в зависимости от версии).

Для активации retail (коробочныx) версий можно использовать способы WINNT.SIF и бэкап активационного файла. Для активации OEM версий можно использовать еще и способ ОEMBIOS.BIN (если у вас есть OEM CD, предоставленный продавцом компьютера). Ну а корпоративные версии, как известно, активации не требуют.

Какая версия у вас? Если вы приобрели в магазине коробку с Windows XP, то у вас retail версия. Если вы приобрели компьютер с уже предустановленной магазином или команией-сборщиком системой, то у вас OEM версия. Если вы купили диск Windows XP на лотке за пару долларов, то у вас.. правильно, пиратская версия :) Не спрашивайте меня в какую из вышеуказанных категорий ее отнести, т.к. это зависит исключительно от изобретательности пиратов.

Способ WINNT.SIF

Самый простой способ, однако на момент первого входа в систему у вас уже должно быть активное подключение к сети Интернет. Если подключения нет, то и активировать автоматически не получится.

Добавьте в секцию [Unattended] файла winnt.sif следующую строку:

AutoActivate=YES

Способ "бэкап активационного файла"

Для начала у вас должен быть доступ к системе (конфигурации), которую вы планируете активировать, и система должна быть уже активирована. Безусловно, этот способ годится для использования только на одной машине при условии, что конфигурация ее остается неизменной.

В директории Windows\System32 есть файл wpa.dbl. Это и есть ваш активационный файл. Скопируйте его в $OEM$\$$\System32. Вот и все.

На вирутальной машине такой способ активации не сработает опять же по причине различий в конфигурации.

Способ OEMBIOS.BIN

Способ аналогичен бэкапу активационного файла. Разница лишь в копируемых файлах. На вашем инсталляционном OEM диске в директории i386 должны быть следующие файлы:

  • OEMBIOS.BIN
  • OEMBIOS.CAT
  • OEMBIOS.DAT
  • OEMBIOS.SIG

Скопируйте их в директорию i386 вашего инсталляционного диска.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 27.02.2005


Автоматическая установка

Эксперту

Добро пожаловать в раздел для Экспертов! Последнее обновление сайта MSFN оказалось богатым на статьи, большинство из которых и составили данный раздел, который в основном посвящен тюнингу вашего автоматического CD.

Мы рассмотрим широкий спектр вопросов: выбор устанавливаемых приложений, работу с модифицированными системными файлами, изменениe внешнего вида устанавливаемой системы, мультизагрузку и пр. Приготовьтесь потратить немало времени. Доведение автоматического CD до совершенства (предела которому, как изестно, нет) потребует значительных временнЫх затрат. Особенно это касается косметических изменений: визуальных стилей, экранов приветствия, boot screens, и т.д. Наградой за потраченное время будет совершенно уникальный внешний вид устанавливаемой и уже установленной системы.

Вы можете начать изучение раздела со сложных методов установки приложений.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 11.03.2005


Автоматическая установка

Сложные способы установки

Эта секция рассказывает о сложных способах установки приложений. Если вы освоили синтаксис RunOnceEx в разделе для опытных пользователей, то способ "RunOnceEx с CD" у вас никаких затруднений не вызовет. Остальная же часть секции посвящена программам, призванным заменить RunOnceEx. Статья "Выбор устанавливаемых приложнений" достаточно большая (сейчас там три страницы).. Она рассказывает сразу о нескольких программах, как минимум дающих пользователю выбор что устанавливать, а что нет. Однако необходимо понимать, что выбор приложений фактически означает отказ от абсолютно автоматической установки Windows.

Данная секция довольно сильно отличается от аналогичной на MSFN. Статья о выборе приложений появилась у нас намного раньше, чем нечто аналогичное было сделано на MSFN. Более того, вдохновленные первой редакцией статьи, наши соотечественники написали как минимум три программы, которые впоследствии вошли в обзор. Поэтому я решил оставить имеющийся формат статьи, и не подстраиваться под MSFN.

Перейти к статье:

Запуск RunOnceEx с CD | Выбор устанавливаемых приложений

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 11.03.2005


Автоматическая установка

Запуск RunOnceEx с CD

Существует возможность установки приложений с CD без предварительного копирования на жесткий диск с использованием $OEM$\$1\ директорий. Осуществляется это достаточно просто при помощи добавления некоторых строк в RunOnceEx.cmd. Если вы еще не читали статью про RunOnceEx.cmd, то ознакомьтесь с ней.

Изменения в существующем RunOnceEx.cmd

Основным препятствием для установки приложений с CD является "непостоятнство" буквы CD-ROM. В зависимости от конфигурации компьютера это может быть D или E или F и т.д. Таким образом основная задача - назначить переменную %CDROM% независимо от конфигурации компьютера. Существует несколько способов сделать это. Я убрал со страницы самый старый способ, изложенный когда-то на MSFN в угоду другому, o котором сообщил в письме cREoz (creoz(at)canada.com), за что ему большое спасибо.

Откройте RunOnceEx.cmd в Блокноте и добавьте следующую строку сразу после echo off:

SET CDROM=%~d0

Это на самом деле самый короткий и надежный метод назначения переменной %CDROM%. Принцип работы изложен в справочной системе Windows (команда FOR, последний блок документации). Вы также можете почитать объяснения vserd в этой теме на OSZone. Учтите, однако, что этот метод работает только если команда исполняется из пакетного файла, запущенного с CD.

Альтернативный метод, который я использовал ранее и который описан сейчас на MSFN, основан на поиске файла WIN51 и если таковой найден на диске, то ему соответственно назначается переменная %CDROM%. :

FOR %%d IN (c d e f g h i j k l m n o p q r s t u v w x y z) DO IF EXIST %%d:\WIN51 SET CDROM=%%d:

Этот метод сработает откуда бы не запускался пакетный файл с данной командой. Вообще, если вас интересуют различные методы назначения переменной %CDROM%, то рекомендую заглянуть в эту тему на MSFN. Или просто поискать в форуме Unattended Windows по CDROM в названиях тем.

Следующим шагом будет перемещение всех программ из директории C:\XPCD\$OEM$\$1\install\ в C:\XPCD\Software\ (вы можете назвать новую директорию как угодно).

Теперь вернитесь к RunOnceEx.cmd и проделайте следующие изменения:

  • Все значения %systemdrive% меняем %CDROM%

  • Изменяем все пути к установочным файлам программ, чтобы они соответствовали новой директории Software и системной переменной %CDROM%

Это все, что требуется сделать! Теперь RunOnceEx.cmd назначит переменную %CDROM% и экспортирует соответствующую букву диска в реестр. Ваш RunOnceEx.cmd должен выглядеть примерно так:

cmdow @ /HID
@echo off

SET CDROM=%~d0

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY% /V TITLE /D "Installing Applications" /f

REG ADD %KEY%\001 /VE /D "Preparing Installation..." /f
REG ADD %KEY%\001 /V 1 /D "%CDROM%\Software\prepare.cmd" /f

REG ADD %KEY%\015 /VE /D "Alcohol 120 Percent" /f
REG ADD %KEY%\015 /V 1 /D "%CDROM%\Software\alcohol\setup.exe /qn Reboot=Suppress" /f
REG ADD %KEY%\015 /V 2 /D "REGEDIT /S %CDROM%\Software\alcohol\register.reg" /f

REG ADD %KEY%\025 /VE /D "Diskeeper 8.0.478" /f
REG ADD %KEY%\025 /V 1 /D "%CDROM%\Software\Diskeeper\DiskeeperPro_8.0.478.exe /s /v/qn" /f

EXIT

О чем необходимо помнить

Переменная %CDROM% не является постоянной. Она будет существовать только на протяжении сессии, в течении которой запускался RunOnceEx.cmd. Поскольку в этом файле команда на определение буквы CD-ROM находится вместе с параметрами REG ADD, то волноваться не о чем. Однако, если вы запускаете другой пакетный файл, которому что-то нужно на CD, то вы обязательно должны включить в него определение буквы CD-ROM.

Если вы хотите назначить постоянные системные переменные, то воспользуйтесь утилитами DetectCD.exe или setenv.exe.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 04.03.2005


Автоматическая установка

Выбор устанавливаемых приложений

Если вы планируете устанавливать приложения автоматически не только на свой компьютер, то, вероятно, стоит задуматься насколько ваш личный набор приложений устроит клиента (родственника, приятеля). Конечно, можно обойтись минимальным набором "must have", но это совершенно не соответствует unattended духу :) Люди, увлекшиеся автоматической установкой, наоборот хотят иметь как можно больше и сразу после окончания инсталляции системы. Соответственно, возникает вопрос о том, как осуществить выбор только нужных в конкретном случае приложений. Строго говоря, если прерываться на выбор приложений, то установка уже не будет полностью автоматической. Однако, другого пути нет, и чтобы иметь возможность выбора, придется пожертвовать полной автоматизацей. Эта страница посвящена различным способам выбора приложений для их автоматической установки впоследствии. Надеюсь, что она будет пополняться силами участников конференции OSZone.

Примечание: обзоры, представленные на странице, могут слегка устаревать по мере выхода новых версий программ.

Пакетный файл | Installs | Post | WPI | T12 | WIHU | XPlode | Другие

Пакетный файл

Пожалуй самое простое, хотя и не самое удачное решение. Команда на запуск файла прописывается в [GuiRunOnce]. Соответственно запуск файла происходит при первом входе в систему. Пример такого файла:

CLS
@echo off
TITLE Software Installation

:POWERTOY
SET Choice=
SET /P Choice=Install TweakUI 2.10 Powertoy [y/n]?
IF /I `%Choice%`==`n` goto :NERO
IF /I `%Choice%`==`y` (
ECHO Installing TweakUI 2.10 Powertoy
ECHO Please wait...
start /wait %systemdrive%\Install\TweakUI.msi /qn
ECHO. ) else goto :POWERTOY

:NERO
SET Choice=
SET /P Choice=Install Nero Burning ROM v5.5.10.5.54 [y/n]?
IF NOT `%Choice%`==`` SET Choice=%Choice:~0,1%
IF /I `%Choice%`==`n` Goto :EXIT
IF /I `%Choice%`==`y` (
ECHO Installing Nero Burning ROM v5.5.10.5.54
ECHO Please wait...
start /wait %systemdrive%\Install\Nero551054.exe /silent /noreboot
ECHO.) else goto :NERO

:EXIT
EXIT

Перед установкой каждого приложения пользователю задается вопрос с вариантами ответа y(es)/n(o). Если ответ Yes, то производится установка приложения и переход к следущему, предваряемый аналогичным вопросом. Если ответ No, то сразу осуществляется переход к следующему приложению.

Преимущества: простота

Недостатки: отсутствие графического интерфейса, приходится сидеть и ждать установки каждого приложения, чтобы затем определиться с выбором устанавливать или нет следующее приложение.

Installs.exe

(обзор программы - Akufrol)
Сайт программы
Тема на MSFN

Команда на запуск программы прописывается в [GuiRunOnce]. Соответственно запуск происходит при первом входе в систему. Все настройки программы содержатся в файле installs.ini, который должен находиться в одной директории с программой. Файл в ANSI-кодировке. Если его открыть для редактирования (лучше в FARе, поскольку в Блокноте вылезут кракозябры), то в начале есть расшифровка каждой команды на английском. Я постараюсь расписать каждую по-русски и указать примеры на конкретных программах.

install= <путь к файлам установки + можно указать ключи> (поддерживаются системные переменные)
install= c:\install\nero\setup.exe /silent /noreboot /no_ui
или
install= %systemdrive%\install\nero\setup.exe /silent /noreboot /no_ui

selected=0 или 1 (по умолчанию 0)
Если 1, то возле названия программы по умолчанию будет стоять галочка выбора

visible=0 или 1 (по умолчанию 1)
Если 0, то программа вообще не будет видна в списке устанавливаемых программ (будет пустое место), и будет установлена по умолчанию.

active=1 или 0 (по умолчанию 1)
Если 0, то программа будет выглядеть бледным цветом и недоступна для установки, если 1 - то ярко выделена
installorder=##
##-число от 1 до 99. указывает порядок установки програнн в процессе инсталляции

register= C:\install\register.reg, [before/after]
При установке заменяет команду "regedit /s register.reg"
before/after - в зависимости от ключа запись значений в реестр призводится до или после установки приложения

postreboot=0 или 1
перезагрузка после установки (по умолчанию 0)

displayorder=## (число от 1 до 99)
указывает местоположение проги в списке (на installorder не влияет)

saveinstall=0 или 1 (по умолчанию 1)
при 0 удаляет инсталляционную папку

killprocess=processname,wait
удаляет или заканчивает процесс при зависании инсталляции, вместо wait указывается в секундах время задержки (не работает совместно с postreboot)

popdesc=<указывается текст, отбражаемый при наведении курсора на на название приложения>

boxdesc=<текст, отображаемый под названием программы>

параметры popdesc, boxdesc, saveinstall, killprocess являются необязательными

в разделе [Install Window Setup] указываются параметры надписей, заголовков, размеров и координат кнопок (координаты и размер кнопок лучше оставить по умолчанию)

Title=<заголовок окна> (поддерживается кириллица)
Prompt=<титульная надпись> (поддерживается кириллица)
Button=<Надпись на первой кнопке> (поддерживается кириллица)

Надписи на остальных кнопках зашиты в исполнямый файл install.exe, и перекомпиляцией я не занимался.

restart=1 или 0 (по умолчанию 0)
Перезагрузка после установки

autostart=1 или 0 (по умолчанию 0) - автозапуск

Delay=<время задержки в секундах перед запуском>

shutdowntimer=<время задержки в секундах после окончания всех установок и закрытием программы>

Далее идут непосредственно настройки конкретных приложений:

[Acrobat Reader 6.0]
install=C:\soft\Acrobat6\AR6.bat
selected=0
visible=1
active=1
displayorder=1
installorder=1
postreboot=0
popdesc=acrobat

Это означает, что программа Acrobat 6.0 будет стоять первой в списке, первой начнет инсталляцию, установится сразу, а не после перезагрузки

При запуске installs.exe открывается окно в классическом стиле Windows со списком приложений для установки. В верхнем правом углу - кнопки управления (Запуск, Выделить/Снять все, Выход). Возле названия каждой программы отмечаем галочкой, хотим или нет ее устанавливать. После того, как все нужные программы отмечены, делаем Запуск. Очередность установки задается в installs.ini (не ошибитесь и не продублируйте, иначе зависнет). При установке в окне выдается путь установки. Если приложение устанавливается без ключей, то следующая установка начнется после завершения предыдущей.

Преимущества: графический интерфейс; выбор желаемых приложений и запуск их всех одной кнопкой; очередность установки приложений; экспортирование ключей реестра до или после установки приложений.

Недостатки: бедный графический интерфейс; программа не работает из cmdlines.txt (выдает ошибки путей приложений); не поддерживаются две строки "install=" в одном блоке установки.

Post

Сайт программы
(Обзор программы - мой, на основе описания Vics)

Наверное, не слишком уместно писать обзор программы, которую даже не протестировал. Однако Post выглядит весьма несложной, так что я попробую :) Команда на запуск программы прописывается в cmdlines.txt, соответственно она будет выполнена на Т-12 (за 12 минут до конца установки). За основу для работы берется хорошо знакомый файл RunOnceEx.cmd, в который вставляются маркеры. Рассмотрим на примере:

cmdow @ /HID
@echo off
SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx
REG ADD %KEY% /V TITLE /D "Установка выбранных программ" /f
;1
REG ADD %KEY%\005 /VE /D "Adobe Reader 6" /f
REG ADD %KEY%\005 /V 1 /D "%systemdrive%\install\AdobeReader6\AR6.msi /qn" /f
;2
REG ADD %KEY%\010 /VE /D "Diskeeper 8" /f
REG ADD %KEY%\010 /V 2 /D "%systemdrive%\install\Diskeeper\setup.exe /s /v/qn" /f
;3
REG ADD %KEY%\015 /VE /D "Photoshop CS" /f
REG ADD %KEY%\015 /V 1 /D "%systemdrive%\install\Photoshop\setup.exe" /f
;f
EXIT

Примечание: если вы устанавливаете ПО с CD, то для корректной работы Post.exe нужно использовать второй метод для назначения переменной %CDROM% со страницы Запуск RunOnceEx с CD.

Перед каждым параметром, вносящимся в ключ HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx (попросту говоря, перед каждой программой), ставится маркер, который является порядковым номером и выглядит как ;n (где n=1, 2, ... , n). Маркеры обязательно должны идти по порядку, и пропуск цифры недопустим. Перед командой EXIT ставится финализрующий маркер ;f. Вот собственно и все, проще некуда. Остается внести в файл cmdlines.txt команду:

[COMMANDS]
"post.exe"

и убрать оттуда команду на запуск RunOnceEx.cmd во избежания двойного срабатывания.

Преимущества: простота конфигурирования при наличии готового файла RunOnceEx.cmd; графический интерфейс; выбор желаемых приложений и запуск их всех одной кнопкой; запуск на Т-12 плюс все преимущества файла RunOnceEx.cmd.

Недостатки: напрашивается доработка графического интерфейса; порядок установки приложений определяется файлом RuOnceEx.cmd и если добавить в середину приложения; то придется менять порядок маркеров.

Windows Post-Installation Wizard (WPI)

(обзор версии 3.3.5 - мой, при участии EgOrus)
Сайт программы
Форум на MSFN

Я использую именно эту программу.

Если вы будете устанавливать приложения с CD, то совершенно не важно куда распаковывать архив с программой - лишь бы входил в ваш дистрибутив. Для установки с жесткого диска лучше всего распаковать в $OEM$\$1\install\.

Запуск WPI вызывает окно как на скриншоте выше, где пользователь может выбрать желаемые приложения и начать их запуск нажатием на кнопку Begin Install. Ранние версии WPI конфигурировались через *.js файлы. Теперь к этой опции добавлена приятная возможность управления настройками WPI и конфигурацией устанавливаемых приложений прямо через интерфейс WPI.

Русификация

Я дополнил перевод файла lang.js, который делал ранее EgOrus. Также, я перевел на русский язык элементы интерфейса, отвечающие за настройки WPI и конфигурацию приложений. Предлагаю скачать все необходимые файлы сразу. Содержимое архива нужно распаковать в директорию WPI и согласиться на перезапись файлов. Архив также включает мой файл config.js для примера. Oстальное - в readme. Дальнейший рассказ о WPI будет основан на русском интерфейсе. Если вы препочитаете английский, то, вероятно, вы и сами разберетесь с оригинальными настройками WPI.

Настройка

Нажав кнопку Настройка (Options) вы попадете в окно, позволяющее настроить внешний вид WPI. Изменения внесенные через интерфейс WPI сохраняются в файле wpiscripts\useroptions.js при нажатии кнопки Сохранить (Save). Прочесть текущий файл useroptions.js позволяет кнопка Перечитать из файла (Read)

Русский интерфейс включает объяснения элементов настройки, так что я не буду подробно останавливаться на этом. Замечу, впрочем, некорректное отображения списка приложений при разрешении экрана 1152х864. Именно по этой причине в моем примере разрешение выставлено в 1024х768. Проблему мне решить не удалось, даже прописывая 1152х864 специально в конфигурационных файлах. Я не силен в JavaScript, но и на MSFN никто решения проблемы не привел. Вы можете выставить разрешение по умолчанию, и посмотреть правильно ли отображается список приложений.

Конфигурация

Нажав кнопку Конфигурация (Options) вы попадете в окно, позволяющее сконфигурировать устанавливаемые приложения. Изменения внесенные через интерфейс WPI сохраняются в файле wpiscripts\config.js при нажатии кнопки Сохранить (Save) внизу окна. За добавление приложений отвечает кнопка Добавить (Add), а прочесть текущий файл config.js может кнопка Перечитать (Read).

Элементы интерфейса переведны на русский язык, а вот их назначение я постараюсь объяснить ниже. Список сконфигурированных приложений отображается слева. При клике на приложене вы переходите к конфигурационному окну. Рассмотрим его на примере приложения Daemon Tools.

Название | название приложения в списке
Порядковый номер | жестко задает порядковый номер установки приложения
Oписание | описание, отображаемое во всплывающей подсказке при наведении курсора на название
Идентификатор | уникальный идентификатор (нужен для зависимостей и/или исключений)
По умолчанию | приложение выбрано сразу при запуске WPI
Принудительно | приложение будет установлено, даже если пользователь нажал Выход
Kатегория | категория, к которой относится приложение (задается пользователем)
Зависит от | вводятся идентификаторы приложений, от которых будет зависеть устанавливать ли данное приложение. Выбор родительского приложения повлечет установку данного приложения. В моем конфигурационном файле АnyDVD зависит от CloneDVD. Если пользователь выберет CloneDVD, то и AnyDVD будет установлено.
Исключения | вводятся идентификаторы приложений, взаимоисключаемых с данным приложением. В моем конфигурационном файле есть Office Custom и Office Full. Конечно, я не хочу, чтобы пользователь установил оба, следовательно я делаю их взаимоисключаемыми. Если выбран Office Custom, то Office Full уже выбрать нельзя и наоборот.
Условие | условие JavaScript для установки приложения (я с этим не разбирался)
В реестр до | вводится путь к *.REG файлу, который импортируется до установки приложения. По сути встроенная команда REGEDIT /S
Команда 1 | Каждому приложению можно задать до шести команд (не считая импорта ключей реестра). В моем примере команда устанавливает DaemonTools
Команда 2 | устанавливает приложение DaemonScript
Kоманда 3 | через заранее созданный скрипт DaemonScript конфигурируется количество виртуальных дисков
Команда 4 | запускает *.INF файл, добавляющий к контекстному меню ISO файлов опцию Mount (монтируется через DaemonTools)
Kоманда 5 | Удаляет DaemonScript, он мне не очень-то и нужен.
Команда 6 | ну не хватило у меня фантазии на шестую команду для одного приложения :)
В реестр после | вводится путь к *.REG файлу, который импортируется после установки приложения. По сути встроенная команда REGEDIT /S
Удалить | удаляет приложение из списка

Вот таким образом конфигурируются все приложения. В файле config.js они будут отсортированы по алфавиту.

Запуск

После того, как вы настроите внешний вид WPI и устанавливаемые приложения, надо будет прописать команду на запуск WPI, скажем в [GuiRunOnce]. Достаточно указать путь к файлу wpi.cmdt, входящем в архив с программой или запустить wpi.hta иным способом. При первом входе в систему пользователь увидит окно WPI с выбором приложений для установки. Определившись с выбором, пользоватеь жмет Начать установку (Begin Install), после чего появится окошко, которое поблагодарит за пользование WPI.

После нажатия ОК начнется установка приложений. Окно это можно отключить, найдя в файле generate.js строку

window.alert(getText(msgStartInstall));

и откомментировав ее следующим образом (спасибо, EgOrus)

/* window.alert(getText(msgStartInstall)); */

Примечания

Я использовал переменную %cdrom% в командах для установки приложений с CD. WPI умеет назначать переменную %cdrom% самостоятельно, действуя по следующему принципу. Проверяются все диски с типом cdrom на наличие файла WIN51. Если таковой находится, то переменной назначается соответствующая буква, в противном случае считается текущий полный путь файла wpi.hta, и поднимается по папкам до корня диска. Если и там нет файла WIN51, то переменная %cdrom% берется из ключа реестра HKLM\\Software\\Microsoft\\Windows\\CurrentVersion\\Setup\\SourcePath. В старой версии были, впрочем, и грабли, на которые наступили и я и EgOrus - %cdrom% в командах нельзя писать заглавными буквами. Иными словами, WPI не поняла %CDROM%. Насчет других переменных я не проверял, но думаю, что и %systemdrive% тоже лучше заглавными не писать. С тех пор с регистром букв переменных я не экспериментировал.

Преимущества: красивый графический интерфейс; выбор желаемых приложений и запуск их всех одной кнопкой; выбор приложений по умолчанию; запуск WPI с уже выбранными приложениями по умолчанию; "насильственная" установка приложений, даже если пользователь выходит из программы; возможность группировать приложений по категориям и устанавливать порядок установки приложений; экспортирование ключей реестра до или после установки приложений; таймер.

Недостатки: некорректная работа с разрешением 1152х864 (и возможно с другими). Других не замечено. Лично мне теперь трудно себя заставить попробовать другие программы :)

T12

Автор - Вячеслав Ситников (sve(at)kmscom.ru)
Tема на OSZone
Скачать программу и документацию

Обзор основан на документации к версии 1.х программы. Сверьтесь с документацией, т.к. с выходом новой версии возможны расхождения обзора с реальностью :)

30 января 2005. Версия 2.0 бета
(+) Добавлена возможность автоматического генерирования unattended инсталляций приложений. Полностью поддерживает операции с реестром, только добавление файлов и создание каталогов для дисковых операций, не поддерживаются изменения ini и текстовых файлов. Доживем до следующей версии?
(+) Добавлен lng файл для многоязычной поддержки
(+) У программы появилась иконка, спасибо Денису Шиверскому (mustsee(at)mail.ru)
(+) Добавлена проверка на наличие WinRar при генерировании инсталлятора (+) Добавлены предупреждения о том, что программа не зависла и отсутствии WinRar, соответственно изменен lng файл
(*) Удалены ключи /allselectgroup, /noselectgroup и /welcome за ненадобностью.
(*) Ключ /defaultgroup теперь определяет группу по умолчанию при выборе программ
(*) Программа cmdow более не нужна
(*) Изменено описание
(-) Исправление ошибки при запуске файлов по относительному смещению от текущего каталога при запуске T12.exe (..\_Other\other.cmd), так как после запуска программы через /run или при исполнении группы файлов now.cmd, каталог после перемещения на очередной now.cmd не восстанавливался в каталог, с которого была запущена T12.exe (а не в котором T12.exe находится!).

Программа на отсчете T-12 выводит окошко на 60 секунд (настраиваемо) с предложением выбрать приложения, которые необходимо установить. Если сделать выбор, то счетчик обратного отсчета останавливается. Можно выбирать также профили из выпадающего списка. По умолчанию присутствует всегда три профиля - "Default" ( оставляет выделение, как указано в cmd файле, о котором чуть ниже), "All Select" (выделяет все элементы), и "No Select" ( снимает выделение со всех элементов). Можно также добавлять профили пользователя, прописав их в настройках cmd файла.

Программа сканирует файлы в каталога Software в корне диска. Каталог можно изменить в командной строке или ini файле. Допускается любая вложенность (в неразумных пределах не проверял). То есть для инсталляции новой приложения не нужно ничего править и ничего поправлять, просто переписать каталог приложения в каталог Software в корне диска. Порядок установки приложений происходит по алфавитному названию каталога и регистрозависим. То есть установка из каталога abc произойдет позже, чем из каталога aBz.

Каталоги, начинающиеся с подчеркивания, не сканируются. Ну и вложенные в них, соответственно, тоже. Сделано для быстрого отключения элементов.

Для инсталляции программы инсталлятор должен быть сформирован в виде полностью законченного cmd файла, который должен установить приложение, внести изменения в реестр, убрать мусор за собой. При запуске cmd файла выставляются переменные окружения %localpath% (путь к программе без последнего закрывающего обратного слеша, например: "D:\Software\AcdSee") и %CDROM% (буква диска CD-ROM`а с двоеточием в конце, например "F:") и каталог программы становится каталогом по умолчанию. Пример такого cmd файла:

-= Начало файла "D:\Software\Antivirus\Nod 32 Antivirus\v2.12\nod32.cmd" =-

REM DESCRIPTION NOD32 Antivirus v2.12 rus
REM DEFAULT ON
REM VISIBLE ON
REM HINT Best Antivirus
REM GROUP Programming;user;designer
; Настройки

start /wait T12.exe /convert nod32.reg /set
; Конвертируем основной реестр под нужный диск установки

start /wait T12.exe /convert nod32base.reg /set
; Конвертируем реестр, где указывается путь к обновлениям

start /wait T12.exe /convert uninst.xml "%PROGRAMFILES%\Eset\Setup\uninst.xml"
; Конвертируем XML установки, для нормальной деинсталляции.

start /wait nod32.exe
; Распаковываем саму программу

start /wait system32.exe
; Распаковываем системные файлы

start /wait user.exe
; Распаковываем файлы меню и рабочего стола

del "%AllUsersProfile%\Рабочий стол\NOD32.lnk"
; Удаляем иконку со стола

EXIT

-= Конец файла =-

Т12 - единственная программа в обзоре, требующая отдельного конфигурационного файла для каждого приложения. Все настройки содержатся в REM строках. Подробнее о параметрах DESCRIPTION, DEFAULT, VISIBLE, HINT и GROUP можно прочитать в документации к программе.

Начиная с точки отсчета T-12 и до окончания инсталляции приложений (первая перезагрузка после первого входа в систему) программа копирует себя в каталог SYSTEM32 (для облегчения исправления файлов реестра, чтобы не писать путь), а также выставляет переменную окружения CDROM, в которой указывается буква диска с двоеточием с которого ведется инсталляция. После установки удаляет себя из SYSTEM32 и убивает переменную окружения.

Подробнее обо всех функциях Т12, параметрах командной строки и тонкостях работы с программой читайте в документации. Я лично программу не тестировал, но (исходя из документации) по гибкости конфигурирования она заметно превосходит Post. Я пообещал автору попробовать программу, т.к. ее функциональность весьма заманчива.

Преимущества: запуск на Т-12, графический интерфейс; выбор желаемых приложений и запуск их всех одной кнопкой; выбор приложений по умолчанию; возможность задавать категории приложений; таймер; возможность генеририровать автоматические инсталляции приложений, подробная документация на русском языке.

Недостатки: мне неизвестны; возможно, графический интерфейс не слишком впечатляет.

Windows Installer Helper Utility (WIHU)

wihu

(обзор программы - Alanoll, MSFN; oснован на версии 2.1)
Сайт программы
Скачать программу

Прежде чем приступить к обзору, я бы хотел подчеркнуть, что речь пойдет только о базовых настройках программах. Все "продвинутые" задачи, которые можно выполнять с помощью WIHU будут лишь упомянуты. Файл INSTALL.INI, входящий в поставку с программой, хорошо документирован (на англ.) и рекомендуется к прочтению. Он детально рассматривает логические выражения (Boolean), позволяющие задать условия для снятия выбора с приложения при запуске WIHU.

Создание списка программ

Для начала я рекомендую начать с пустого INI файла. Это просто текстовый файл с расширением INI, который можно создать в Блокноте или любом другом текстовом редакторе.

На скриншоте ниже вы видите часть окна WIHU, которое конечный пользователь видит во время инсталляции.

А вот какой INI файл создает такое окно:

[Windows System Files]

; Sub command 0
description.0=Windows Media Player 9 (Current Version is %wmp.dll.version%)
command.0=Wmp9\MPSetupXP.exe /Q:A /R:N
selected.0 = 0

; Sub command 1
description.1=DirectX 9.0b Driver
command.1=DirectX9b\DX9NTopk.exe
selected.1 = 0

; Sub command 2
description.2 = Microsoft .NET Framework 1.1
command.2 = %systemroot%\system32\msiexec.exe /i NetFramework\netfx.msi /qb
selected.2 = 0

[TweakUI 2.10 Powertoy]
description.0 = Windows XP Shell-Tweaker
command.0 = %systemroot%\system32\msiexec.exe /i PowerToys\TweakUI.msi /qb
selected.0 = 0

[Sun Java VM 1.4.2]
description.0 = Java Virtual Machine 1.4.2
command.0 = SunJava\j2re-1_4_2_04-windows-i586-p.exe /s /v"/qn ADDLOCAL=jrecore IEXPLORER=1"
selected.0 = 0

Tеперь используя INI файл и скриншот я откомментирую составляющие INI файла.

[Entry Title] | В обычном INI файле это было бы названием Секции. WIHU придерживается аналогичной концепции. Все, что заключено в квадратные скобки [] будет названием секции. В примере [Sun Java VM 1.4.2] отображается как Sun Java VM 1.4.2 и является заголовком дерева
description.x | Это описание элемента. Оно отображается в секции помеченной [] над ней Если у вас несколько команд в секции, увеличивайте индекс .x на единицу. Самое первое значение должно быть description.0
command.x | Это команда, которая будет выполняться. Можете взять ее из пакетного файла или RunOnceEx..Отсчет всегда начинается с command.0
selected.x | Определяет выбрано ли приложение по умолчанию. Допустимые параметры после знака равенства: 1 (выбрано) и 0 (не выбрано). Если в INI файле выбор никак не обозначен, то приложение выбрано не будет. Отсчет всегда начинается с selected.0

Нужно учесть, для каждого приложения индексы .x должны быть одинаковыми. Обратите внимание как это сделано в секции [System Files]. Первое приложение в секции должно иметь индекс 0 и следоваельно все три параметра (description, commmand и selected) имеют такой индекс. Второе приложение имеет индекс 1, и все его параметры получают такой же индекс. И так далее для остальных приложений секции. Также обратите внимание, что для каждой секции индекс начинается с 0.

Вот таким образом и добавляются приложения в список. По оконачнии файл надо сохранить как INSTALL.INI в директории WIHU.

Другие функции WIHU

Не останавливаясь на них подробно, просто перечислю. WIHU умеет добавлять/изменять учетные записи, а также менять названия компьютера, рабочей группы, зарегистрированного пользователя и организацию.

Запустив исполняемый файл WIHU с ключом /? вы узнаете о возможных ключах командной строки, с которыми можно запускать программу. Обратите внимание на возможность создания лог-файла и указания пути к INI файлу.

XPlode

Сайт программы

В старой версии сайта у нас была статья о первой версии этой программы, но с тех пор утекло немало воды, и на дворе уже четвертая версия (впрочем, не уверен, что промежуточные релизы увидели свет ;) XPlode безусловно заслуживает большего внимания, чем один параграф в обзоре. Не думаю, что по функциональности она уступает фаворитам (Т12, WPI, WIHU), а по возможностям настройки внешнего вида инсталляционных диалогов, возможно, и превосходит их. Программа может "подстраивать" свой внешний вид под диалоговые окна установки Windows (в зависимости от WINNTBBU.DLL) или выглядеть независимо. Все настройки конфигурируются через XML файл, так что любой редактор с подсветкой поможет сконфигурировать программу и найти возможные ошибки в синтаксисе.

Программа использует хитрый инсталлятор. Вы должны прочитать лицензионное соглашение, чтобы распаковать программу (в тексте соглашения есть скрытая ссылка, которая активирует кнопку "Continue"). В пакете с программой идет очень подробное руководство в PDF формате (34 стр.) на английском языке. Если у вас нет проблем с английским, то и конфигурация XPlode не должна вызвать особых затруднений. Если возникнет желание написать подробный обзор XPlode, то вы всегда можете связаться со мной.

Другие программы

С момента публикации первой версии статьи я узнал еще о нескольких программах для выборочной установки приложений. Кстати, некоторые из них был написан под впечатлением от статьи :) Обзоров этих программ у меня нет. Попробуйте программы и если вам что-то приглянется, пришлите мне обзор.

GMinstaller

Автор - mitiya
Скриншоты
Тема на OSZone

SelApp

Автор - AlexVP
Тема на OSZone

kTool

Aвтор - kenedy
Тема на MSFN
Документация на англ. и русском (русский язык у автора не родной, так что возможны ошибки).

Любопытная программа, рекомендую присмотреться внимательнее.

Резюме

В статье рассмотрены несколько способов, позовляющих осуществить выбор устанавливаемых приложений. У каждого из них свои преимущества и недостатки. Надеюсь, что данная статья поможет вам сделать наилучший выбор исходя из ваших запросов. Если у вас есть на примете другие решения или программы, то сообщите мне по по электронной почте или в форуме.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 08.03.2005


Автоматическая установка

Модификация системных файлов

В этой секции мы расскажем о том, как модифицировать системные файлы. Модифицированные файлы заменят оригинальные и будут установлены в обычном порядке.

Визуальные стили - Если вы хотите использовать визуальные стили (visual styles) не подписанные Microsoft, то эта страница для вас.

Больше одновременных соединений - Service Pack 2 ограничивает количество одновременных соединений десятью в секунду. Из статьи вы узнаете как обойти это ограничение.

Oтключение защиты системных файлов - Если вы пытались заменить системный файл и получали диалоговое окно, которое просило вставить диск с ОС, чтобы заменить файл, то вы, возможно, захотите узнать как отключить защиту системных файлов в Windows XP.

Mодификация других системных файлов - Если вы хотите заменить еще какой-нибудь системный файл, то эта статья поможет вам избежать ошибки копирования файла при установке.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 12.03.2005


Автоматическая установка

Визуальные стили

Файл uxtheme.dll, наверное, наиболее часто заменяемый файл в Windows. Целью замены является возможность устанавливать неподписанные визуальные стили (visual styles), которые доступны на различных сайтах (включая коллекцию стилей на OSZone.net). Нередко в сети можно увидеть рекомендации типа "поставь StyleXP". Ничего не имею против этой программы, но если единственной целью является использование неподписанных стилей, то можно обойтись заменой uxtheme.dll.

Мы будем использовать nLite (которому требуется .NET Framework) для хака uxtheme.dll. Eсли вы не хотите устанавливать nLite, то можете воспользоваться готовыми файлами, ссылки на которые вы найдете внизу страницы.

Примечание: я не тестировал хак локализованой русской uxtheme.dll при помощи nLite, т.к. в моем распоряжении нет локализованой Windows XP. Я буду признателен, если вы сообщите мне насколько корректно использование nLite для русской uxtheme.dll.

Хак файла

Запустите nLite и жмите Next пока не увидите такое окно:

Снимите выделение со всех элементов кроме Options and Tweaks. Нажмите Next и в следующем окне укажите путь к вашему дистрибутиву при помощи кнопки Browse

Вы увидите окно, как на скриншоте ниже. Для начала снимите выделение со всех элементов.

Поскольку мы модифицируем файл uxtheme.dll, отметьте следующую опцию

Затем жмите Next и Yes, чтобы подтвердить действие. Хак занимает буквально мгновение.

Жмите Next, потом Finish. Теперь у вас в дистрибутиве замененный файл uxtheme.dll.

Послесловие

Как вы заметили, nLite дает возможность модифицировать не только uxtheme.dll, но и другие файлы. На самом деле, вы можете заодно изменить tcpip.sys и sfc_os.dll. Просто в данном руководстве мы сделали по отдельной статье для каждого файла, чтобы не смешивать все в одну кучу.

Готовые файлы

Оба файла предназначены для использования в системе, с интегрированным/установленным Service Pack 2. Русский uxtheme.dll предоставил VseDoFeni. Oн не задействовал nLite для создания русского uxtheme.dll. Достаточно просто скопировать файл в директорию i386 вашего дистрибутива и согласиться на перезапись.

Windows XP SP2 EN (98 kb) | Windows XP SP2 RU (111 kb)

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 11.03.2005


Автоматическая установка

Больше одновременных соединений

Файл tcpip.sys в Service Pack 2 для Windows XP ограничивает количество одновременных соединенийОбычно это оказывает негативный эффект на онлайновые multiplayer игры или менеджеры закачки, использующие многопоточную закачку. Так или иначе, количество одновременных соединений в каждую секунду не может превышать десяти. Лимит, видимо, введен из соображений безопасности. На самом деле, если в обычных условиях вы обнаружите одновременно 100 активных подключений, то надо немедленно проверить систему на наличие программ-паразитов. Если у вас нет насущной необходимости в большем количестве соединений, то лучше оставьте файл в покое. Впрочем, как я сказал выше, иногда просто необходимо обойти лимит. Так что сейчас мы это поправим.

Мы будем использовать nLite (которому требуется .NET Framework) для хака tcpip.sys. Eсли вы не хотите устанавливать nLite, то можете воспользоваться готовым файлoм, ссылку на который вы найдете внизу страницы.

Хак файла

Запустите nLite и жмите Next пока не увидите такое окно:

Снимите выделение со всех элементов кроме Options and Tweaks. Нажмите Next и в следующем окне укажите путь к вашему дистрибутиву при помощи кнопки Browse

Вы увидите окно, как на скриншоте ниже. Для начала снимите выделение со всех элементов.

Поскольку мы модифицируем файл tcpip.sys, перейдите на вторую закладку и отметьте следующую опцию одновременно со вводом количества желаемых соединений.

Затем жмите Next и Yes, чтобы подтвердить действие. Хак занимает буквально мгновение.

Жмите Next, потом Finish. Теперь у вас в дистрибутиве замененный файл tcpip.sys.

Послесловие

Как вы заметили, nLite дает возможность модифицировать не только tcpip.sys, но и другие файлы. На самом деле, вы можете заодно изменить uxtheme.dll и sfc_os.dll. Просто в данном руководстве мы сделали по отдельной статье для каждого файла, чтобы не смешивать все в одну кучу.

Готовый файл

Готовый файл модифицирован под 100 одновременных соединений. Достаточно просто скопировать файл в директорию i386 вашего дистрибутива и согласиться на перезапись.

Windows XP SP2 (171 kb)

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 11.03.2005


Мoдификация других системных файлов

Автоматическая установка

Moдификация других системных файлов

Три предыдущие статьи секции описывают модификацию файлов uxtheme.dll, tcpip.sys и sfc_os.dll. У вас, наверное, возник вопрос: а что если нужно изменить какой-нибудь другой системный файл (например, экран привествия)? Если вы модифицируете системный файл при помощи редактора ресурсов типа ResEdit или Resource Hacker, и включите его в дистрибутив, то во время инсталляции системы неизбежно получите ошибку копирования. Программа установки Windows проверяет контрольную сумму всех копируемых файлов, и в случае несовпадения отказывается копировать. Утилита ModifyPE корректирует контрольную сумму, и как слдествие файл воспринимается как родной.

Загрузите ModifyPE отсюда и распакуйте утилиту из архива в %windir%\system32 для простоты использования.

Пример использования ModifyPE

В нашем примере модифицируется файл shell32.dll. Из командной строки выполните следующую команду:

modifyPE.exe shell32.dll -c

а затем

makecab shell32.dll

Подробнее об используемых тут командах вы можете прочитать в Справочнике (статья Сжатые файлы). На выходе мы получаем сжатый файл shell32.dl_. Теперь надо просто скопировать его в директорию i386 вашего дистрибутива и согласиться на перезапись.

Несмотря на то, что программа установки Windows допустит копирование файла, по окончании установки в файл setuperr.log вносится запись о том, что файл не имеет цифровой подписи Microsoft. Возможна ситуация, когда при проверке целостности файлов Windows захочет восстановить оригинальный файл. Как отключить проверку системных файлов вы уже знаете.

Примечания

Команда makecab нужна только если вы работаете с изначально сжатым файлом.

ModifyPE можно использовать с любыми системными файлами как английской версии Windows XP, так и прочих локализованых версий.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 12.03.2005


Отключение защиты системных файлов

Автоматическая установка

Oтключение защиты системных файлов

Файл sfc_os.dll отвечает за WFP - Windows File Protection (Защита системных файлов Windows). Если вы попытаетесь удалить защищенный файл/папку, то увидите примерно такое окно:

Если вы действительно хотели заменить файл, то простоe нажатие Cancel решает проблему. А что если вы не хотите каждый раз жать Cancel или защищенный файл уже находится в директории dllcache? Тогда читайте дальше, и вы узнаете как отключить защиту системных файлов.

Мы будем использовать nLite (которому требуется .NET Framework) для хака sfc_os.dll. Eсли вы не хотите устанавливать nLite, то можете воспользоваться готовым файлoм, ссылку на который вы найдете внизу страницы.

Хак файла

Запустите nLite и жмите Next пока не увидите такое окно:

Снимите выделение со всех элементов кроме Options and Tweaks. Нажмите Next и в следующем окне укажите путь к вашему дистрибутиву при помощи кнопки Browse

Вы увидите окно, как на скриншоте ниже. Для начала снимите выделение со всех элементов.

Поскольку мы модифицируем файл отвечающий за WFP, то выберите следующую опцию:

Затем жмите Next и Yes, чтобы подтвердить действие. Хак занимает буквально мгновение.

Жмите Next, потом Finish. Теперь у вас в дистрибутиве замененный файл sfc_os.dll.

Если нужно включить WFP

Скажем, вы хотите отключить WFP, но все-таки иметь возмжность ее включить, если понадобится. Это легко осуществить. Все сводится к несложному твику реестра.

Включает WFP

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"SFCDisable"=dword:00000000

Выключает WFP

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"SFCDisable"=dword:FFFFFF9D

Послесловие

Как вы заметили, nLite дает возможность модифицировать не только sfc_os.dll, но и другие файлы. На самом деле, вы можете заодно изменить uxtheme.dll и tcpip.sys. Просто в данном руководстве мы сделали по отдельной статье для каждого файла, чтобы не смешивать все в одну кучу.

Готовый файл

Достаточно просто скопировать файл в директорию i386 вашего дистрибутива и согласиться на перезапись. При установке системы импортируйте нужный вам ключ в реестр.

Windows XP SP2 (49 kb)

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 12.03.2005


Автоматическая установка

Косметические изменения

Надеюсь, вы уже успешно создали CD, который автоматически устанавливает систему и ваши любимые приложения. Думаете, что на этом все? Нет, веселье только начинается. Теперь можно заняться косметическими изменениями, которые преобразят вид установки Windows и уже установленной системы.

Setup Billboards - это окна, которые пользователь видит во время установки Windows. В случае с Windows XP и Windows 2003 эти окна "рекламируют" свойства и функции операционной системы. Подробнее... | Billboards
Boot Screen - это экран, который вы видите при загрузке системы. Непосредственно изображение содержится в файле ядра Windows ntoskrnl.exe, который находится в директории Windows. Mы будем изменять файл при помощи программы Boot Editor. Подробнее... | Boot Screen
Вы уже заменили файл uxtheme.dll, и теперь, наверное, хотите включить в дистрибутив вашу любимую тему или визуальный стиль? Да еще так, чтобы они отображались прямо после установки системы? Это можно без проблем сделать для Windows XP или 2003 (но не для Windows 2000). Подробнее... | Theme
Вы все видели Logon Screen, а изменять его пытались? Мы рассмотрим как это можно сделать. Подробнее... | Logon Screen
Многие OEM производители (например, Dell, HP, Sony и т.д.) отображают свою информацию и логотип в Свойствах Системы. Хотите отобразить там свою информацию? Это очень просто. Подробнее... | Oeminfo

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 09.04.2005


Автоматическая установка

Setup Billboards

Setup Billboards - это окна, которые пользователь видит во время установки Windows. Я затрудняюсь перевести этот термин корректно и кратко на русский язык. Если у вас есть соображения по этому поводу, то поделитесь со мной.

Windows XP и Windows 2003 демонстрируют Setup Billboards нового стиля. Мы рассмотрим различные аспекты их изменения, включая изображения, шрифты и цвета. | New Style Billboard
Классические Setup Billboards доступны в Windows 2000, Windows XP и Windows 2003. Однако, только в Windows 2000 они демонстрируются по умолчанию. Для того, чтобы включить их в Windows XP или 2003 достаточно отредактировать буквально пару строк текста. | Classic Billboard

Setup Billboards нового стиля | Классические Setup Billboards

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 09.04.2005


Автоматическая установка

Классические Setup Billboards

Статья рассказывает о том, как изменить серые и голубые Setup Billboards в Windows XP и Windows 2003 на классические окна Windows 2000. Никаких изменений в процесс установки Windows не вносится; меняется лишь ее вид. Выглядеть это будет примерно так:

Активируем классические Setup Billboards

В директории i386 вашего дистрибутива найдите и удалите файлы winntbbu.dll и winntbbu.dl_. Либо один, либо оба файла должны быть в этой директории, так что удаляйте все, что найдете :)

Теперь откройте файл txtsetup.sif и удалите строки, содержащие winntbbu.dll. Проделайте тоже самое в файле dosnet.inf.

Изменяем разрешение и глубину цвета

Это необязательный шаг. Выполнив его, вы увеличите разрешение фона и глубину его цвета (color depth). Добавьте следующие шесть строк в файл hivesys.inf, расположенный в директории i386 вашего дистрибутива. Добавлять строки нужно в самое начало секции [AddReg].

HKLM,"SYSTEM\CurrentControlSet\Services\VgaSave\Device0","DefaultSettings.BitsPerPel",0x00010001,32
HKLM,"SYSTEM\CurrentControlSet\Services\VgaSave\Device0","DefaultSettings.XResolution",0x00010001,1024
HKLM,"SYSTEM\CurrentControlSet\Services\VgaSave\Device0","DefaultSettings.YResolution",0x00010001,768
HKLM,"SYSTEM\CurrentControlSet\Control\Video\{23A77BF7-ED96-40EC-AF06-9B1F4867732A}\0000","DefaultSettings.BitsPerPel",0x00010001,32
HKLM,"SYSTEM\CurrentControlSet\Control\Video\{23A77BF7-ED96-40EC-AF06-9B1F4867732A}\0000","DefaultSettings.XResolution",0x00010001,1024
HKLM,"SYSTEM\CurrentControlSet\Control\Video\{23A77BF7-ED96-40EC-AF06-9B1F4867732A}\0000","DefaultSettings.YResolution",0x00010001,768

Данный пример устанавливает разрешение 1024х768 с глубиной цвета 32 бита. Вы можете изменить параметры разрешения на свои. Одако помните, что разрешения 1280х1024 и выше ограничены глубиной цвета в 16 бит.

Изменяем фон

Это легко. Создайте изображение с разрешением 800х600 и 256 цветами. Если вы меняли параметры на предыдущем этапе, то измените разрешение и глубину цвета вашего изображения соответственно. Сохраните файл как setup_w.bmp (для Windows XP) или как setup_s.bmp (для Windows 2003) и замените им оригинальный файл в директории i386 вашего дистрибутива.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 01.04.2005


Автоматическая установка

Setup Billboards нового стиля

Setup Billboards нового стиля предоставляют большое поле для деятельности по изменению их внешнего вида.

В этом разделе представлены четыре статьи.

Winntbbu Editor - самoe удобнoe и простoe средство редактирования Setup Billboards. Остальные статьи содержат больше деталей, которые не столь уж и важны для конечного пользователя. Подробнее...

Изменение изображений. Из этой статьи вы узнаете как изменить фон и другие изображения, являющиеся частью Setup Billboards нового стиля. Помимо фона можно изменить логотип Windows, bullets и анимированную полоску прогресса. В принципе, вид Setup Billboards можно изменить до неузнаваемости. Подробнее...

Изменение текста. Эта статья рассказывает о том, как изменить текст, отображаемый в Setup Billboards во время установки Windows. Конкретнее, рассматривается изменение содержания текста, шрифта и размера. Подробнее...

Изменение цветов. Вы уже изменили фон ваших Setup Billboards, и возможно изменили текст. Но теперь белый текст не очень хорошо смотрится, или, возможно, полоска прогресса выбивается из общей картины? Это все можно поправить. Подробнее...

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 09.04.2005


Автоматическая установка

Winntbbu Editor

Программа WinntbbuED (Winntbbu Editor) является на данный момент самым удобным и простым средством редактирования Setup Billboards. У программы есть тема на MSFN (ссылка на текущую версию в конце первого поста). Более подробную информацию о номерах ресурсов winntbbu.dll и тонкостям их ручного редактирования вы можете почитать в других статьях раздела Setup Billboards. Рекомендую их почитать для общего развития. А в этой статье мы рассмотрим только интерактивное редактирование при помощи WinntbbuED.

Вам нужно взять из дистрибутива файл winntbbu.dll. Если у вас только сжатая версия, то распакуйте ее следуя статье Сжатые файлы из Справочника. Всегда используйте версию файла, соответствующую устанавливаемой версии Windows. Иными словами, не используйте файл от SP1 для дистрибутива Windows XP SP2.

А о программе, собственно, и рассматривать нечего. Она настолько интуитивно проста, что я обойдусь одним параграфом. Программа не требует установки. При запуске вы видите окошко с заставкой (немецкий Setup Billboard).

Все эелементы меню доступны через клавиатуру. Открываете ваш winntbbu.dll по CTRL+O и начинаете редактировать (меню Edit): шрифты по CTRL+F, цвета по CTRL+L, изображения по CTRL+P. Двойной клик по элементу позволяет его изменить или заменить. На скриншоте редактируются шрифты.

Winntbbu Editor
Щелкните чтобы увеличить

А вот на режиме Предпросмотра я остановлюсь подробнее. Видимо, автор получил немало вопросов, так что при попытке Полноэкранного Предпросмотра (Extras | Real Preview) вы обязательно увидите окно Readme First. Перевод его содержимого я и привожу ниже

Несколько вещей, которые вы должны знать, прежде чем начать пользоваться Полноэкранным Предпросмотром (Real Preview)

  1. Выход из Предпросмотра (Preview) по клавише "ESC" !!!

  2. Полноэкранный предпросмотр (Real Preview) требует изменения разрешения экрана и занимает несколько секунд

  3. Разрешение возвращается к исходному при выходе из предпросмотра (но частота развертки экрана может автоматически и не вернуться /Vadikan)

  4. Вы обязаны сохранить все изменения перед входом в режим Полноэкранного Предпросмотра. Этот режим использует внутренний код winntbbu.dll для отрисовки изображения, так что необходимость сохранения перед просмотром должна быть очевидна.

  5. Следствием использования внутреннего кода winntbbu.dll получается наиболее аккуратный предпросмотр. То что вы видите на экране, вы увидите впоследствии при установке системы.

  6. Однако, такой подход подразумевает единственную глубину цвета - TrueColor

  7. 64-битный предпросмотр не поддерживается (вызвано winntbbu.dll)

  8. Отображаемый Setup Billboard помечен галочкой в меню `Bilboard OS`

Вот и все. Приятных экспериментов. Кстати, подборку готовых со скриншотами вы найдете в этой теме на MSFN. Для закачки некоторых может быть понадобиться членство в соответствующей Yahoo Group. Ну а я, по многочисленным просьбам читателей, выкладываю Blue Girl со скриншота. (646 kb, XP EN).

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована - 09.10.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 09.10.05


Автоматическая установка

Изменение изображений

Из этой статьи вы узнаете как изменить фон и другие изображения, являющиеся частью Setup Billboards нового стиля. В принципе, вид Setup Billboards можно изменить до неузнаваемости. Например, так:

Статья состоит из нескольких секций, каждая из которых содержит в чем-то сходные объяснения. Вы можете следовать всем секциям или любой из них. Для редактирования ресурсов в данной статье используется программа ResEdit. Скриншоты программы присутствуют лишь в первой секции, ввиду их аналогичности.

Вам нужно взять из дистрибутива файл winntbbu.dll. Если у вас только сжатая версия, то распакуйте ее следуя статье Сжатые файлы из Справочника. Всегда используйте версию файла, соответствующую устанавливаемой версии Windows. Иными словами, не используйте файл от SP1 для дистрибутива Windows XP SP2.

Примечание для локализованых версий Windows: ResEdit не умеет корректно сохранять кириллические шрифты winntbbu.dll. Используйте Resource Tuner или другой редактор ресурсов.

Итак в этой статье рассматриваются::

Логотип Windows | Фон | Bullets | Полоска прогресса

Логотип Windows

Эта секция рассматривает замену логотипа Windows в левом верхнем углу экрана

Откройте winntbbu.dll в вашем редакторе ресурсов и выберите изображение, которое вы хотите заменить.

Таблица ресурсов:

Номер Ресурса | Описание
100 101 102 | True Color изображение используемое во время установки Windows XP
150 151 152 | True Color изображение используемое во время установки Windows XP, но с альфа-прозрачностью (alpha-transparency).
120 121 122 | True Color изображение используемое во время установки Windows 2003
150 151 152 | True Color изображение используемое во время установки Windows 2003, но с альфа-прозрачностью (alpha-transparency).

Выбрав ресурс жмите кнопку Replace

и выбирайте желаемое изображение. Если вы хотите обойтись без логотипа, то у вас есть два варианта. Можно выбрать изображение размером 1х1 пиксел. Во время установки такое изображение просто будет незаметно. Альтернативно, вы можете удалить ресурс. Выберите изображение для удаления и жмите кнопку Delete Resource

Закончив редактирование ресурса нажмите кнопку Save

Сохраните файл как winntbbu.dll. Вы можете продолжить редактирование файла, следуя остальным секциям статьи, или перейти к заключительному этапу.

Фон

Откройте winntbbu.dll в вашем редакторе ресурсов и выберите изображение, которое вы хотите заменить.

Таблица ресурсов:

Номер Ресурса | Описание
103 | True Color изображение используемое во время установки Windows XP
153 | 16 битное изображение, на случай если VGASAVE драйвер не загрузится во время установки Windows XP
123 | True Color изображение используемое во время установки Windows 2003
163 | 16 битное изображение, на случай если VGASAVE драйвер не загрузится во время установки Windows 2003.

Выбрав ресурс жмите кнопку Replace и выбирайте желаемое изображение. Это могут быть обои или любое другое изображение, которое вы создали. Разрешение изображения должно быть стандартным (800х600, 1024х768 и т.д), а формат - обязательно битмап (*.BMP).

Закончив редактирование ресурса нажмите кнопку Save. Вы можете продолжить редактирование файла, следуя остальным секциям статьи, или перейти к заключительному этапу.

Bullets

Опять же я затрудняюсь корректно перевести термин на русский языке. Ненумерованый список тут не слишком подходит :) Речь идет о значках отображаемых в левой части Setup Billboards рядом с текстом, отражающим этапы установки Windows.

Во время установки Windows XP пользователь видит три типа bullets. Первое изображение означает завершенный этап, второе - незавершенный этап, и третье - текущий этап. Номера ресурсов идут в аналогичном порядке.

Откройте winntbbu.dll в вашем редакторе ресурсов и выберите изображение, которое вы хотите заменить.

Таблица ресурсов:

Номер Ресурса | Описание
104 105 109 | True Color изображение используемое во время установки Windows XP
154 155 156 | 16 бит изображение используемое во время установки Windows XP (эквивалент True Color)
124 125 126 | True Color изображение используемое во время установки Windows 2003
164 165 166 | 16 бит изображение используемое во время установки Windows 2003 (эквивалент True Color)

Выбрав ресурс жмите кнопку Replace и выбирайте желаемое изображение. Если вы хотите обойтись без bullets, то у вас есть два варианта. Можно выбрать изображение размером 1х1 пиксел. Во время установки такое изображение просто будет незаметно. Альтернативно, вы можете удалить ресурс. Выберите изображение для удаления и жмите кнопку Delete Resource.

Закончив редактирование ресурса нажмите кнопку Save и cохраните файл как winntbbu.dll. Вы можете продолжить редактирование файла, следуя остальным секциям статьи, или перейти к заключительному этапу.

Анимированная полоска прогресса

Эта секция рассматривает замену полоски прогресса, отображаемой в правом нижнем углу.

Эффект анимированной полоски прогресса создается поочередным отображением четырех изображений. Если условно пронумеровать изображения от 1 до 4, то во время установки они отображаются по кругу в последовательности 1,2,3,4,3,2,1. Ниже приводятся четыре изображения в порядке их отображения:

progress progress progress progress

Откройте winntbbu.dll в вашем редакторе ресурсов и выберите изображение, которое вы хотите заменить.

Таблица ресурсов:

Номер Ресурса | Описание
185 186 187 188 | True Color изображение используемое во время установки Windows XP
189 190 191 192 | 16 бит изображение используемое во время установки Windows XP (эквивалент True Color)
500 501 502 503 | True Color изображение используемое во время установки Windows 2003
510 511 512 513 | 16 бит изображение используемое во время установки Windows 2003 (эквивалент True Color)

Выбрав ресурс жмите кнопку Replace и выбирайте желаемое изображение. Если вы хотите обойтись без полоски прогресса, то у вас есть два варианта. Можно выбрать изображение размером 1х1 пиксел. Во время установки такое изображение просто будет незаметно. Альтернативно, вы можете удалить ресурс. Выберите изображение для удаления и жмите кнопку Delete Resource

Закончив редактирование ресурса нажмите кнопку Save и сохраните файл как winntbbu.dll. Вы можете продолжить редактирование файла, следуя остальным секциям статьи, или перейти к заключительному этапу.

Заключительный этап

Запакуйте файл winntbbu.dll при помощи makecab, как описано в статье Сжатые файлы, и скопируйте оба файла (*.DLL и *.DL_) в директорию i386 вашего дистрибутива.

Предпросмотр изменений

Просмотреть изменения можно несколькими способами.

Можно использовать программу XPreview, написанную jcarle. Для ее работы требуется .NET Framework. После установки и запуска программы достаточно зайти в меню File | Open и выбрать модифицированный файл winntbbu.dll. В некоторых случаях программа некорректно отображает цвета судя по сообщениям на MSFN.

Альтернативно можно (после замены оригинальных файлов в дистрибутиве своими) запустить winnt32.exe. Начнется установка Windows, которая остановится на первом же экране. Этого будет достаточно, чтобы рассмотреть все как следует.

Ну и наконец, можно запустить установку Windows на виртуальной машине и дождаться ее графического этапа.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 06.04.2005


Автоматическая установка

Изменение текста

Эта статья рассказывает о том, как изменить текст, отображаемый в Setup Billboards во время установки Windows. Конкретнее, рассматривается изменение содержания текста, шрифта и размера.

Статья состоит из нескольких секций, каждая из которых содержит в чем-то сходные объяснения. Вы можете следовать всем секциям или любой из них. Для редактирования ресурсов в данной статье используется бесплатная программа ResEdit.

Большинство манипуляций будет проводиться с файлом winntbbu.dll, который вы можете взять из дистрибутива. Если у вас только сжатая версия, то распакуйте ее следуя статье Сжатые файлы из Справочника. Всегда используйте версию файла, соответствующую устанавливаемой версии Windows. Иными словами, не используйте файл от SP1 для дистрибутива Windows XP SP2.

Примечание для локализованых версий Windows: ResEdit не умеет корректно сохранять кириллические шрифты winntbbu.dll. Используйте Resource Tuner или другой редактор ресурсов.

На протяжении статьи я буду ссылаться на скриншот, приведенный ниже.

Как вы видите, на скриншоте выделены четыре области, каждой из которых будут соответствовать свои ресурсы. Соответственно, говоря об области, обозначенной цифрой 1, я буду использовать термин Область 1. Аналогичной терминологии я буду придерживаться и для остальных трех областей.

Изменяем текст

Откройте winntbbu.dll в вашем редакторе ресурсов и двойным щелчком на String раскройте индекс ресурсов. В ResEdit все ресурсы сосредоточены под индексом 1003. В Resource Tuner они начинаются с единицы и увеличивают нумерацию.

Области 1 и 2

Ввиду большого количества ресурсов, которые к тому же отличаются в разных операционных системах, таблицы ресурсов для Oбластей 1 и 2 вынесены на отдельную страницу.

Oтыщите ресурс, который вы хотите отредактировать. В ResEdit его можно идентифицировать по ID номеру (напрмиер, ID="29"). Затем просто замените текст на свой или удалите вовсе, если не хотите, чтоб он отображался во время установки. Если вы заменяете текст на свой, то имейте в виду, что перед каждым словом (кроме первого) нужно ставить знак |. Т.е. текст должен выглядеть примерно так:

Windows |XP |Professional |sports |a |visual |design |that |combines |a |sleek |look.

Область 3

Процесс редактирования текста в Области 3 абсолютно идентичен процессу для первых двух областей. Ниже приводится таблица ресурсов, соответствующих Области 3.

Номер Ресурса | Описание
23 | Текст "Collecting Information"
24 | Текст "Dynamic Update"
25 | Текст "Preparing Installation"
63 | Текст "Installing Windows"
64 | Текст "Finalizing Installation"

Область 4

В отличиии от первых трех областей, ресурсы отвечающие за текст в Области 4, находятся не в файле winntbbu.dll. Вам понадобятся файлы syssetup.dll и winnt32u.dll. Распакуйте их следуя статье Сжатые файлы из Справочника.Процедура редактирования текста, впрочем, аналогична первым трем областям за одним исключением. Вам не нужно использовать символ | перед каждым словом. Ниже приводятся таблицы ресурсов, соответствующих Области 4.

syssetup.dll (используется на этапе загрузки с CD)

Номер Ресурса | Описание
1179 1180 | Текст "Setup will complete..."

winnt32u.dll (используется на этапе загрузки с HDD)

Номер Ресурса | Описание
1064 1065 | Tекст "Setup will complete..."

Закончив редактирование текста вы можете сохранить изменения, нажав кнопку Save

или продолжить творческий процесс, изменяя тип и размер шрифта.

Изменяем тип и размер шрифта

Откройте winntbbu.dll в вашем редакторе ресурсов и двойным щелчком на String раскройте индекс ресурсов. В ResEdit все ресурсы сосредоточены под индексом 1003. В Resource Tuner они начинаются с единицы и увеличивают нумерацию.

Ниже приводится таблица ресурсов, соответствующая первым трем областям.

Номер Ресурса | Описание
2 3 | Изменяет размер шрифта в левой части экрана (Область 3)
4 | Изменяет тип шрифта в левой части экрана (Область 3)
10 14 | Изменяет размер шрифта в верхней части экрана (Область 1)
5 | Изменяет тип шрифта в верхней части экрана (Область 1)
12 16 | Изменяет размер шрифта в центральной части экрана (Область 2)
19 | Изменяет тип шрифта в центральной части экрана (Область 2)

Учтите, что шрифт, который вы тут используете должен быть загружен и присутствовать в момент установки. Если вы хотите использовать нестандартный шрифт, то вам придется сначала редактировать файл hivesft.inf, добавляя все необходимые ключи реестра, а затем редактировать txtsetup.sif, чтобы нужные файлы скопировались в процессе установки.

Также, примите во винимание, что вы должны указывать название шрифта (например, Comic Sans MS), а не имя файла. Названия шрифтов можно посмотреть хоть в Блокноте в меню Format | Font.

Закончив изменять тип и размер шрифта вы можете сохранить изменения, нажав кнопку Save

Заключительный этап

Запакуйте файл winntbbu.dll при помощи makecab, как описано в статье Сжатые файлы, и скопируйте оба файла (*.DLL и *.DL_) в директорию i386 вашего дистрибутива.

Предпросмотр изменений

Просмотреть изменения можно несколькими способами.

Можно использовать программу XPreview, написанную jcarle. Для ее работы требуется .NET Framework. После установки и запуска программы достаточно зайти в меню File | Open и выбрать модифицированный файл winntbbu.dll. В некоторых случаях программа некорректно отображает цвета судя по сообщениям на MSFN.

Альтернативно можно (после замены оригинальных файлов в дистрибутиве своими) запустить winnt32.exe. Начнется установка Windows, которая остановится на первом же экране. Этого будет достаточно, чтобы рассмотреть все как следует.

Ну и наконец, можно запустить установку Windows на виртуальной машине и дождаться ее графического этапа.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 08.04.2005


Тaблицы ресурсов для Setup Billboards

Автоматическая установка

Taблицы ресурсов для Setup Billboards

На этой странице находятся таблицы ресурсов файла winntbbu.dll, относящиеся к Oбластям 1 и 2, как обозначено на скриншоте ниже.

В каждой из таблиц жирным выделен номер ресурса, относящийся к Области 1.

Примечание: я не стал включать в оффлайн версию сайта 50 скриншотов всех Setup Billboards весом почти в 7 mb. Это увеличило бы размер оффлайн версии практически в четыре раза. Все ссылки на "экраны" ведут на сайт, и для просмотра требуется подключение к сети Internet.

Windows XP Professional | Windows XP Home | Windows 2003 Server

Windows XP Professional

Порядковый номер | Номер ресурса | Описание
1 | 27 28 | Экран 1
2 | 29 30 | Экран 2
3 | 31 32 | Экран 3
4 | 33 34 | Экран 4
5 | 35 36 | Экран 5
6 | 37 38 | Экран 6
7 | 39 40 | Экран 7
8 | 41 42 | Экран 8
9 | 43 44 | Экран 9
10 | 61 62 | Экран 10
11 | 45 46 | Экран 11
12 | 47 48 | Экран 12
13 | 49 50 | Экран 13
14 | 51 52 | Экран 14
15 | 53 54 | Экран 15
16 | 55 56 | Экран 16
17 | 57 58 | Экран 17
18 | 59 60 | Экран 18

Windows XP Home

Порядковый номер | Номер ресурса | Описание
1 | 300 301 | Экран 1
2 | 302 303 | Экран 2
3 | 304 305 | Экран 3
4 | 306 307 | Экран 4
5 | 308 309 | Экран 5
6 | 342 343 | Экран 6
7 | 310 311 | Экран 7
8 | 312 313 | Экран 8
9 | 314 315 | Экран 9
10 | 316 317 | Экран 10
11 | 318 319 | Экран 11
12 | 320 321 | Экран 12
13 | 322 323 | Экран 13
14 | 324 325 | Экран 14
15 | 326 327 | Экран 15
16 | 328 329 | Экран 16
17 | 330 331 | Экран 17
18 | 332 333 | Экран 18
19 | 334 335 | Экран 19
20 | 336 337 | Экран 20
21 | 338 339 | Экран 21
22 | 340 341 | Экран 22

Windows 2003 Server

Порядковый номер | Номер ресурса | Описание
1 | 200 | Экран 1
2 | 202 203 | Экран 2
3 | 204 205 | Экран 3
4 | 206 207 | Экран 4
5 | 208 209 | Экран 5
6 | 210 211 | Экран 6
7 | 212 213 | Экран 7
8 | 214 215 | Экран 8
9 | 216 217 | Экран 9
10 | 218 219 | Экран 10

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 18.03.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 10.04.05


Автоматическая установка

Изменение цветов

Итак, вы уже изменили фон ваших Setup Billboards, и возможно изменили текст. Но теперь белый текст не очень хорошо смотрится, или, возможно, полоска прогресса выбивается из общей картины? Это все можно поправить.

Мы будем использовать программу BBU Color Changer для редактирования файла winntbbu.dll.

Работа с программой

Скачав программу, запустите SFX архив и распакуйте содержимое в любую директорию. Запустите BBU Color Changer и вы увидите примерно такое окно:

Нажмите кнопку Browse и выберите ваш файл winntbbu.dll. Вы можете изменить четыре цвета.

  • Text Color - изменяет цвет любого текста, независимо от расположения.

  • Highlight Text Color - изменяет цвет текста в названии выполняемого процесса в левой части экрана (Область 3).

  • Text Shadow - изменяет цвет тени, отображаемой с текстом заголовка в верхней части экрана (Область 1).

  • Progress Bar - изменяет цвет полоски прогресса.

Нажав кнопку Edit вы увидите стандартное окошко выбора цветов. Дальше, надеюсь, все понятно. По окончании достаточно нажать кнопку Apply, чтобы сохранить изменения.

Заключительный этап

Запакуйте файл winntbbu.dll при помощи makecab, как описано в статье Сжатые файлы, и скопируйте оба файла (*.DLL и *.DL_) в директорию i386 вашего дистрибутива.

Предпросмотр изменений

Просмотреть изменения можно несколькими способами.

Можно использовать программу XPreview, написанную jcarle. Для ее работы требуется .NET Framework. После установки и запуска программы достаточно зайти в меню File | Open и выбрать модифицированный файл winntbbu.dll. В некоторых случаях программа некорректно отображает цвета судя по сообщениям на MSFN.

Альтернативно можно (после замены оригинальных файлов в дистрибутиве своими) запустить winnt32.exe. Начнется установка Windows, которая остановится на первом же экране. Этого будет достаточно, чтобы рассмотреть все как следует.

Ну и наконец, можно запустить установку Windows на виртуальной машине и дождаться ее графического этапа.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 08.04.2005


Автоматическая установка

Boot Screens

Перевод этой статьи выполнил D@nil. От меня - первый параграф и редактирование.

К сожалению, приведенный ниже метод не работает для Windows 2000. Честно говоря, этот метод тестировался только на Windows XP, так что сообщите мне, если у вас он стаботал на Windows 2000.

Boot Screen - это экран, который вы видите при загрузке системы. Непосредственно изображение содержится в файле ядра Windows ntoskrnl.exe. Вообще, Windows использует четыре уникальных файла ядра:

  • ntoskrnl.exe - однопроцессорное ядро Windows
  • ntkrnlmp.exe - многопроцессорное ядро Windows
  • ntkrnlpa.exe- однопроцессорное ядро Windows с более чем 3 Гб оперативной памяти (RAM)
  • ntkrpamp.exe - многопроцессорное ядро Windows с более чем 3 Гб оперативной памяти (RAM)

На момент написания этой статьи все системы, базирующиеся на процессорах AMD, рассматриваются как однопроцессорные. Что же касается Intel Pentium 4, то процессоры с Hyperthreading рассматриваются как многопроцессорные, а процессоры без Hyperthreading как одонопроцессорные.

Данная статья рассказывает как об одно-, так и о мультипроцессорных системах. Для работы вам понадобится программа Boot Editor

Подготовка к созданию файла ядра

Распакуйте BootEditor, и запустите. Если появится ошибка об отсутствующем файле, то скорее всего вам нужны msvbvm60.zip и comctl32.zip. Распакуйте их в ту же папку, что и BootEditor.

После первого запуска вы увидите:

Нажмите NO.

Следующий диалог будет:

Нажмите Close.

Вы вошли в BootEditor. Окно будет выглядеть примерно так:

Щелкните меню File и выберите New Boot Screen.

Должно появиться такое окно:

Напечатайте имя вашего будущего boot screen.

Теперь мы будем изменять изображение. В последней версии ядра Service Pack 2 внутри только 4 рисунка, в то время как в Windows 2003 и более ранних NT системах более 4-х рисунков.

Выберите изображение, которое хотите заменить, нажмите кнопку Load Image.

Выберите ваше изображение, которым вы хотите заменить оригинал. Когда вы заменяете изображение Main - #1, также нажмите Move, чтобы исправить цветoвую гамму файла.

Если вы хотите переместить полосу прогресса то, при просмотре изображения Main - #1, нажмите на изображение полосы прогресса и перетащите вверх или вниз. Вы не можете переместить влево или вправо.

Давайте сохраним то, что у нас уже получилось. Нажмите кнопку Make, расположенную наверху экрана.

Следующий экран предоставит вам больше опций сохранения файла.

Если вы хотите изменить название, сделайте двойной клик на теге Name и напечатайте свое название.

Если вы модифицируете одно из более старых ядер, в котором еще есть различные изображения относящиеся к версии (Professional, Home, Server, Media Center, etc., и т.д.), вы можете удалить их и они просто не будут отображаться в процессе загрузки. Поясняю: речь идет о надписи под полоской прогресса загрузки (или над полоской, не помню уже :); до Service Pack 2 там отображалась версия ОС. В столбце Put it, дважды щелкните и выберите No.

Нажмите OK, когда вы закончите, затем ещё раз OK для подтверждения.

Файл, который вы создали будет сохранен в той же директории, что и Boot Editor. Файл представляет собой zip архив с расширением bootscreen. Вам еще предстоит превратить его в EXE.

Создание исполняемого файла

Теперь надо создать фактический файл ядра. Поскольку мы будем создавать как одно-, так и многопроцессорное ядро, то придется заняться копированием файлов туда-сюда и их переименованием.

Найдите в \XPCD\I386\ файлы ntoskrnl.ex_ и ntkrnlmp.ex_. Распакуйте файлы куда вам удобно. Эти файлы сжаты, как их распаковать смотрите тут.

Войдите в %WINDIR%\system32 и переименуйте ntoskrnl.exe в ntoskrnl.bak. Теперь переименуйте один из ваших распакованных файл в ntoskrnl.exe и скопируйте в директорию system32 вашей ОС.

Вернитесь к BootEditor и нажмите кнопку Test.

Вы увидите такое окно:

Нажмите No, т.к. мы на самом деле ничего не тестируем тут.

Следующие диалоговое окно сообщает вам, где создается новый файл и что если бы вы действительно тестировали его, то он бы стал файлом по умолчанию.

Нажмите OK, и сделайте тоже самое еще раз в заключительном окне.

Теперь вернитесь в каталог system32, скопируйте файл NewBoot.exe в $OEM$\$$\system32. Переименуйте в singkrnl.exe, если вы использовали файл однопроцессорного ядра, или в dualkrnl.exe если вы использовали второй файл. Запомните, где вы сохраняете singkrnl.exe, oн вам понадобится позже.

Теперь такую же процедуру нужно проделать со вторым вашим распакованным файлом. По завершении скопируйте его в тот же самый каталог с именем, которое вы не использовали работая с первым файлом.

Создание Пакетного файла для выбора надлежащего ядра

Следующий пакетный файл, является простым скриптом, который читает параметр NUMBER_OF_PROCESSORS из системного реестра, а затем выбирает соответствующий файл ядра.

FOR /F "tokens=3 delims= " %%A IN (`REG QUERY "HKLM\SYSTEM\ControlSet001\Control\Session Manager\Environment" /v NUMBER_OF_PROCESSORS`) DO SET NUMBER_OF_PROCESSORS=%%A
bootcfg /copy /D "Windows XP Professional" /ID 1
if %NUMBER_OF_PROCESSORS%==2 goto DUAL
REM ----For Single proc
bootcfg /RAW "/Kernel=singkrnl.exe" /A /ID 2
goto End
:DUAL
REM ----For Multiprocess/Hyperthread proc
bootcfg /RAW "/Kernel=dualkrnl.exe" /A /ID 2
:End
bootcfg /Timeout 2
bootcfg /Default /ID 2

Этот скрипт делает копию оригинальных параметров входа в систему, находящихся в boot.ini, и озаглавливает их как "Windows XP Professional". Затем добавляет в конец /kernel, чтобы использовать другой файл ядра, затем устанавливает задержку на 2 секунды, и наконец устанавливает новое ядро по умолчанию.

Если вы хотите использовать другие названия для ваших файлов ядра, я уверен, что вы сообразите, где изменить их. Если вы хотите установить другую задержку, только измените число после ключа /Timeout. Если вам не нужна задержка времени введите 0.

Сохраните этот пакетный файл как bootscreen.cmd, скажем, в $ОЕМ$ директории. Eсли хотите чтобы bootscreen.cmd сработал при первом входе в систему, то запускайте его из [GuiRunOnce].

Возможные проблемы с Boot Editor

Иногда при длительном использовании Boot Editor зависает и не реагирует ни на что. Просто перезапустите Boot Editor и продолжайте работу.

Автор: Vadikan, D@nil
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 17.03.2005


Автоматическая установка

Темы

Из этой статьи вы узнаете как включить вашу любимую тему в инсталляционный CD.

Удобство файлов тем (*.theme) в том, что они контролируют не только визуальный стиль, но и иконки, курсоры, звуки, обои и скринсэйверы. Приступим же к делу!

Создаем файл темы

Настройте вашу систему как вам угодно, включая иконки, курсоры, звуки, обои и скринсэйверы. В Панели Управления выберите Свойства Экрана, на закладке Темы

Chaninja Style RC5
Chaninja Style RC5

выберите Сохранить как... и сохраните ваш файл с расширением *.theme в $OEM$\$$\Resources\Themes\

Это было легко, не так ли?

Копирование необходимых файлов

Теперь более сложная часть. Если вы использовали какие-либо визуальные элементы (иконки, курсоры и т.д.), не входящие в стандартный набор Windows, то вам надо выяснить их расположение на жестком диске. Большинство файлов должно находиться в %WinDir% (вашей директории Windows). Если же они находятся в другом месте, то используйте статью $OEM$ директории на инсталляционном диске, чтобы воссоздать нужное вам расположение во время установки системы.

Если же говорить об $OEM$ директориях применительно к случаю, когда файлы расположены в %WinDir%, то тут все просто. Ваша директория Windows эквивалентна $OEM$\$$\. Следовательно, в ней вам нужно воссоздать точно такую же структуру директорий, как в %WinDir%. Например, если ваши файлы расположены в %WinDir%\Media\MyThemeFiles, то их надо скопировать в $OEM$\$$\Media\MyThemeFiles.

Рассмотрим на конкретном принмере. Я использую тему Ninja, файлы которой расположены в %WinDir%\Resources\Themes\Ninja

Я беру и копирую всю папку Ninja в $ОЕМ$\$$\Resources\Themes\.

Аналогичным образом поступайте с остальными файлами (звуками, иконками, скринсэйверами и т.д.). Однако помните, что вам не всегда будет нужно все содержимое директорий в которых эти файлы содержатся, а лишь непосредственно сами файлы.

Заставляем Windows использовать нашу тему

Осталось лишь сообщить программе установки Windows, что вы хотите использовать свою тему. Делается это через файл ответов winnt.sif. Просто добавьте в файл следующие строки:

[Shell]
CustomDefaultThemeFile = "%WinDir%\Resources\Themes\MyTheme.theme"

Замените MyTheme.theme на имя файла, который вы создали на первом этапе.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 31.03.2005


Автоматическая установка

Logon Screens

Название для статьи я решил оставить английское, не обессудьте. Под термином Logon Screen понимается как классическое приглашение на вход в систему (Classic Logon Screen), так и Экран Приветствия (Welcome Screen). Изменение классического приглашения на вход в систему является совсем несложной задачей и сводится к модификации пары ресурсов. А вот изменить экран приветствия сложнее, т.к. в него включен небольшой HTML подобный скрипт, контролирующий расположение экрана. Для модификации экрана приветствия рекомендуется LogonStudio, однако использование этой программы в этой статье рассматриваться не будет. Со временем, надеюсь, в статью будет добавлены инструкции по ручному изменению экрана приветствия.

Таким образом, мы рассмотрим лишь как измененить классическое приглашение на вход в систему и как заставить Windows использовать любой из модифицированных Logon Screens.

Редактирование классического приглашения на вход в систему

Классическое приглашение на вход в систему находится в файле msgina.dll,. который в свою очередь расположен в %windir%\system32. Откройте файл в вашем любимом редакторе ресурсов (например, платном Resource Tuner или бесплатном ResEdit) и выберите изображение, которое вы хотите заменить. Ниже вы найдете таблицу номеров ресурсов с пояснениями. Выбрав изображение, жмите кнопку Replace

и выбирайте свое изображение, которым вы хотите заменить оригинальное. Рекомендуется использовать изображение с такими же размерами (ширина х высота) во избежание потенциальных конфликтов. После замены изображения войдите в меню File и выберите опцию Save As...

Сохраните файл под любым именем в директории $OEM$\$$\system32

В таблицу сведены опицания наиболее часто изменяемых ресурсов. БОльшее по габаритам (ширина х высота) изображение используется для диалогового окна, ожидающего ввод имени пользователя и пароля. Меньшее изображение отображается непосредственно в процессе входа в систему.

Для краткости, main images = основные изображения

Номер Ресурса | Описание
103 | Полоса прогресса под основным изображением. Присутствует во всех версиях.
101 107 | Windows XP Professional Edition main images
128 129 | Windows XP Home Edition main images
130 131 | Windows 2003 Standard Edition main images
132 133 | Windows 2003 Enterprise Edition main images
134 135 | Windows 2003 Datacenter Edition main images
145 147 | Windows 2003 Web Edition main images

Заставляем Windows использовать наш Logon Screen

Предполагается, что вы сохранили нужные файлы в $OEM$\$$\system32. Все что нужно, это один твик реестра.

Для классического приглашения на вход в систему

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
GinaDll="mygina.dll"

Замените mygina.dll на имя вашего файла.

Для Экрана Приветствия

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
UIHost="%systemroot%\system32\dragon.exe"

Замените dragon.exe на имя вашего файла.

Как вы наверное догадались, файлы можно положить в любую директорию, и указать соответствующий путь в REG файле.

Если путь к Экрану Приветствия указан неверно, то будет использоваться классическое приглашение на вход в систему. Причем не ваше, а стандартное системное.

Если вы используете твик для классического приглашения на вход в систему, то Экран Приветствия автоматически игнорируется, так что вы не можете использовать оба. Однако, вы можете иметь оба файла в системе. Просто не используйте GinaDll твик, если вы хотите использовать экран приветствия.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 31.03.2005


Автоматическая установка

Изменение OEM информации и логотипа

Изменение OEM информации и логотипа

OEM информация и логотип отображаются в свойствах системы, которые можно вызвать из контекстного меню иконки Мой Компьютер на рабочем столе или комбинацией клавиш WIN+PAUSE на клавиатуре. Вы можете импортировать их во время автоматической установки. Вам нужно создать два файла - oeminfo.ini и oemlogo.bmp.

Создание файлов

oeminfo.ini

Откройте Блокнот и скопируйте туда следующие строки

[General]
Manufacturer=Vadikan
Model=Unattended XP SP2 DVD
[OEMSpecific]
SubModel=
SerialNo=
OEM1=
OEM2=
[Support Information]
Line1=Unattended XP SP2 DVD
Line2=unattended.oszone.net

Вы можете изменить текст, стоящий после знака = по своему усмотрению. Сохраните файл как oeminfo.ini.

oemlogo.bmp

Создайте изображение размером 180х114 пикс. (ширина х высота), отредактируйте ваш логотип как вам угодно и сохраните как oemlogo.bmp. Можно сделать его на прозрачном фоне, чтобы он сливался с цветом диалогового окна Свойств Системы.

Тестирование файлов

Чтобы протестировать файлы, скопируйте их в директорию %windir%\System32 и откройте свойства системы. Если результаты вас не устраивают, продолжайте редактирование, пока не достигнете идеала ;-)

Импорт файлов

Для того, чтобы импортировать файлы во время автоматической инсталляции, их надo поместить в директорию $OEM$\$$\System32\. Если такой не существует, то создайте ее (подробнее об $OEM$ директориях читайте в Справочнике. Во время установки системы оба файла будут скопированы в директорию System32 независимо от того, как будет называться установочная директория системы.

Если вы сделали все правильно, то выглядеть это будет примерно как на скриншоте.

Добавление даты установки и списка апдейтов

Я наткнулся на любопытную тему на MSFN и решил поделиться информацией. Возможно, некоторые из вас сочтут полезным внесение в oeminfo.ini даты установки системы и списка интегрированных обновлений. Приведенный ниже пакетный файл как раз и и позволяет все это проделать.

@echo off

SET D=%SYSTEMROOT%\system32\
REM delete oeminfo.ini if exists
if exist "%D%oeminfo.ini" del   "%D%oeminfo.ini" /q
FOR %%d IN (c d e f g h i j k l m n o p q r s t u v w x y z) DO IF EXIST %%d\WIN51IP SET CDROM=%%d:

echo [General] >> "%D%oeminfo.ini"
echo Manufacturer=Vadikan >> "%D%oeminfo.ini"
echo Model=Unattended XP SP2 DVD >> "%D%oeminfo.ini"
echo [Support Information] >> "%D%oeminfo.ini"
echo Line1=Installation Date: %date% >> "%D%oeminfo.ini"
echo Line2= >> "%D%oeminfo.ini"
echo Line3=Installed Hotfixes:>> "%D%oeminfo.ini"
echo Line4= >> "%D%oeminfo.ini"

REM Line Number
SET i=5

REM List  quickfixes without exe extension
For /F "TOKENS=1 delims=.exe"  %%j in ('dir /B %CDROM%\I386\svcpack\KB*.exe') do ((set kbname=%%j) & (call :myprint))
GOTO :EOF

:myprint
echo Line%i%=%kbname%   >> "%D%oeminfo.ini"
SET /A i+=1

:EOF

Примечание: если вы используете такой пакетный файл, то не создавайте заранее oeminfo.ini, т.к. он будет сгенерирован автоматически.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 12.03.2005


Автоматическая установка

Экономим место на диске

По мере добавления драйверов и приложеннй к инсталляционному диску, вы начнете ощущать недостаток свободного места на носителе. Если вы используете DVD носители, то, надеюсь, с нехваткой места еще не столкнулись :) А вот за каждый мегабайт места на CD приходится бороться. Ниже рассказ о папках, которые можно смело удалять с инсталляционного диска.

Mожно смело удалять следующие папки: DOCS, VALUEADD, и SUPPORT. Освободится порядка 22.3 Мб.

Едем дальше. Заглянем в директорию i386. Если вы не планируете апгрейд с более старой ОС, то можете удалить WIN9XMIG, WIN9XUPG и WINNTUPG. Освободится 37.6 Мб.

Если у вас локализованная версия ХР, то можете смело удалять папку LANG. Освободится порядка 99 Мб в зависимости от вашей версии.

После интеграции Service Pack 2 в директории i386 появляется папка cmpnents. В ней содержатся компоненты TabletPC и .NET Framework 1.0, которые можно удалять. Также там могут находиться компоненты Media Center, но насчет них я затрдуняюсь сказать, т.к. не работал с Media Center Edition. На функциональность Windows XP они повлиять не должны. Таким образом удаление папки cmpnents освободит порядка 25.2 Мб.

Примечание: .NET Framework требуется для работы некоторых приложений, о чем разработчики ПО, как правило, предупреждают на своих сайтах. Если он вам нужен, то лучше уж тогда взять перепакованный 1.1 с интегрированными обновлениями: EN и RUS.

Если вы устанавливаете приложения из $OEM$ директорий, то можете поискать там файлы instmsia.exe и instmsiw.exe. Если найдете, то можете удалять. Для Windows XP/2003 они не нужны, т.к. с системой уже поставляется Windows Installer 2.0

Ссылки

nLite позволяет уменьшить размер дистрибутива.
Руководство по уменьшению размера дистрибутива написано gosh, участником форума MSFN.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 16.03.2005


Автоматическая установка

Сетевые технологии

Несмотря на то, что целевой аудиторией сайта unattended.ozone.net являются домашние пользователи, немало полезной информации об автоматической установке Windows могут почерпнуть также и системные администраторы, которым приходится устанавливать операционные системы на десятки и даже сотни машин. В таких случаях установка ОС с оптического носителя на каждую машину отнимает слишком много времени. Кроме того компьютеры могут находиться в разных зданиях или даже городах. К тому же, иногда возникают ситуации, когда компьютер либо не оснащен оптическим приводом и флоппи дисководом, либо и тот и другой просто неисправны. При перечисленные выше условиях установка ОС по сети будет наиболее эффективным, а иногда и единственным способом. Учитывая появление второй статьи на тему установки по сети, было решено выделить обе статьи в отдельную секцию.

Статья Особенности автоустановки через Remote Installation Services (RIS), написанная участником конференции OSZone Akufrol, уже знакома постоянным посетителям ресурса. Она рассчитана на читателей, которым уже известно что такое RIS и с чем его едят. В статье подробно и доступно описан процесс превращения обычной RIS-установки ОС в автоматическую (unattended).

А вот в статье Загрузка компьютера по сети с практически любого образа диска, написанной участником конференции OSZone vserd, на примере личного опыта рассматривается экстремальный случай, когда загрузка по сети является единственной возможностью установить ОС. Статья содержит весьма подробные инструкции, следуя которым даже неискушенный пользователь сможет успешно загрузиться по сети и установить систему.

С большим удовольствием мне хотелось бы подчеркнуть, что обе статьи написаны участниками конференции OSZone. Если у вас возникнет желание поделиться с аудиторией сайта собственными знаниями, я с удовольствием опубликую и ваши статьи.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована - 03.12.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 03.12.05


Автоматическая установка

Особенности автоустановки через Remote Installation Services (RIS)

Представляю статью об автоустановке через RIS, написанную Akufrol, участником конференции OSZone.

Введение

RIS – это процедура удаленной установки Windows, а также офисных приложений с использованием технологии сетевой загрузки. Может оказаться серьезным подспорьем для сетевых администраторов. Используя технологию RIS, клиенты во время загрузки по сети или с помощью RBFG-дискеты через механизм PXE получают IP-адрес и другую информацию, чтобы найти сервер RIS и установить сессию. Затем RIS-сервер и клиент используют протокол TFTP для передачи на станцию клиента программы установки Custom Installation Wizard. С ее помощью пользователь клиентской станции проходит аутентификацию в AD и выбирает образ ОС с сервера RIS. Затем начинается процесс передачи данных, завершающийся установкой на станции клиента полнофункциональной версии Windows, со всеми необходимыми приложениями и специальными настройками.

Я не буду в данной статье рассматривать способы установки и развертывания RIS, поскольку эта тема достаточно обширна и не имеет прямого отношения к автоматической установке Windows. К тому же материалов по RIS достаточно в Интернете, хотя бы по тут, а также в многочисленных руководствах по Windows Server 2000 и 2003. Я лишь постараюсь привести по возможности доступное описание процесса превращения обычной RIS-установки в unattended.

Файл ответов

Файл ответов называется ristndrd.sif и располагается по адресу

\\Remoteinstall\setup\Language\images\winxppro\i386\templates

где language - язык дистрибутива Windows, winxppro - название дистрибутива Windows. Понятно, что язык и названия версии могут быть различными. У меня, например, цепочка такая:

\\RemInst\setup\Russian\images\windows_xp_sp2\i386\templates

Параметры типичного файла ответов имеют жесткую привязку к конкретным условиям установки, поэтому наилучшим выбором будет редактирование существующего, а не создание нового. Синтаксис файла ответов такой же, как и у winnt.sif, так что более подробную информацию по каждому параметру всегда можно найти в ref.chm.

Пример типичного файла ответов:

[data]
floppyless = "1"
msdosinitiated = "1"
OriSrc = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
OriTyp = "4"
LocalSourceOnCD = 1
DisableAdminAccountOnDomainJoin = Yes

[SetupData]
OsLoadOptions = "/noguiboot /fastdetect"
SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

[Unattended]
OemPreinstall = no
FileSystem = LeaveAlone
ExtendOEMPartition = 0
TargetPath = \WINDOWS
OemSkipEula = yes
InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
LegacyNIC = 1

[UserData]
FullName = "%USERFIRSTNAME% %USERLASTNAME%"
OrgName = "%ORGNAME%"
ComputerName = %MACHINENAME%

[GuiUnattended]
OemSkipWelcome = 1
OemSkipRegional = 1
TimeZone = %TIMEZONE%
AdminPassword = "*"

[Display]
BitsPerPel = 16
XResolution = 800
YResolution = 600
VRefresh = 60

[Networking]

[NetServices]
MS_Server=params.MS_PSched

[Identification]
JoinDomain = %MACHINEDOMAIN%
DoOldStyleDomainJoin = Yes

[RemoteInstall]
Repartition = Yes
UseWholeDisk = Yes

[OSChooser]
Description="Windows Professional"
Help="Будет выполнена установка Windows Professional в стандартной конфигурации."
LaunchFile="%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"
ImageType="Плоский"

Рассмотрим секции и параметры типичного файла ответов подробнее. Поскольку лишь некоторые из них специфичны для RIS, с таковых и начнем.

Секция [data]

Параметры по умолчанию являются обязательными, поскольку они задают начальные условия установки. floppyless - поддержка загрузки с дискеты, msdosinitiated - для запуска dos-сессии установки, параметр DisableAdminAccountOnDomainJoin=1 нужен, если установка идет через RIS. Нам сюда требуется лишь добавить строку UnattendedInstall = "Yes". Желающие могут также добавить AutoPartition = 0.

Секция [SetupData]

Оставляем ее неприкосновенной - это способ загрузки Windows и определитель устройства загрузки. Эта секция применяется только при RIS-установке.

Секция [Unattended]

Практически аналогична одноименной секции в winnt.sif. Единственное, что характерно именно для RIS - это строки:

InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
LegacyNIC = 1

поэтому их оставляем в неизменном виде.

Чтобы папка $OEM$ скопировалась на жесткий диск, необходимо добавить строку:

OemFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%\$OEM$\"

и положить папку $OEM$ параллельно i386 в \\RemoteInstall. Остальное - на ваше усмотрение.

Секция [UserData]

Здесь можно поставить свои параметры в соответствующих строках, это не критично. Ну и добавить параметр ProductKey.

Секции [Identification] и [OSChooser]

Обе секции относится именно к RIS, поэтому не трогаем, и оставляем неизменными.

Остальные секции

Все остальные секции и их параметры идентичны файлу winnt.sif.

Установка приложений через RunOnceEx

Удобство RIS-установки состоит еще и в том, что можно не носить с собой диски с софтом, а хранить нужные приложения на сервере RIS и запускать инсталляцию оттуда. Для метода RunOnceEx не составляет труда прописать в файле сетевые пути к приложениям. Работоспособность метода - 100%, проверено :-)

Папку с софтом лучше разместить в папке RemInst из тех соображений, чтобы не создавать слишком длинные пути к приложениям. У меня, например, на длинный путь жутко обругался Office2003. Те программы, которые размещены в соответствующих каталогах папки $OEM$, копируются в обычном порядке точно так же, как они ставились бы с CD.

Пример моего файла ответов

[data]
AutoPartition = 0
floppyless = "1"
msdosinitiated = "1"
UnattendedInstall = "Yes"
OriSrc = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
OriTyp = "4"
LocalSourceOnCD = 1
DisableAdminAccountOnDomainJoin = Yes

[SetupData]
OsLoadOptions = "/noguiboot /fastdetect"
SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

[Unattended]
UnattendMode = FullUnattended
OemPreinstall = Yes
TargetPath = \WINDOWS
OemSkipEula = yes
InstallFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
LegacyNIC = 1
Repartition = No
UnattendSwitch = "Yes"
WaitForReboot = "No"
OemFilesPath = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%\$\"
OemPnPDriversPath = "Drivers\000_Chipset\;Drivers\001_Network\;Drivers\002_Video\;Drivers\003_Sound\"
DriverSingingPolicy = Ignore
ProgramFilesDir = "C:\Program Files"

[UserData]
ProductKey = *****-*****-*****-*****
FullName = "****"
OrgName = "%ORGNAME%"
ComputerName = unattend

[GuiUnattended]
OemSkipWelcome = 1
OemSkipRegional = 1
TimeZone = 180
AdminPassword = "*"

[TapiLocation]
CountryCode = 7
AreaCode = ****

[RegionalSettings]
LanguageGroup = 1,5
SystemLocale = 00000419
UserLocale = 00000419
InputLocale = 0409:00000409,0419:00000419

[Branding]
BrandIEUsingUnattended = Yes

[URL]
Home_Page = http://www.yandex.ru
Help_Page = http://www.yandex.ru
Search_Page = http://www.yandex.ru

[Proxy]
Proxy_Enable = 0
Use_Same_Proxy = 1

[Networking]
InstallDefaultComponents = No

[NetAdapters]
Adapter1 = params.Adapter1

[params.Adapter1]
INFID = *

[NetClients]
MS_MSClient = params.MS_MSClient

[NetServices]
MS_Server=params.MS_PSched

[Identification]
JoinDomain = %MACHINEDOMAIN%
DoOldStyleDomainJoin = Yes

[NetProtocols]
MS_TCPIP = params.MS_TCPIP

[params.MS_TCPIP]
AdapterSections = params.MS_TCPIP.Adapter1

[params.MS_TCPIP.Adapter1]
SpecificTo = Adapter1
DHCP = No
IPAddress = ***.***.***.***
SubnetMask = ***.***.***.***
DNSServerSearchOrder = ***.***.***.***
WINS = No
NetBIOSOptions = 0

[WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

[Components]
msmsgs = off
msnexplr = off
zonegames = off

[Shell]
DefaultStartPanelOff = Yes

[RemoteInstall]
Repartition = No
UseWholeDisk = Yes

[OSChooser]
Description="Microsoft Windows XP Professional RU"
Help="Automatically installs Microsoft Windows XP Professional RU without prompting the user for input."
LaunchFile="%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"
ImageType=Flat
Version="5.1 (0)"

Примечание

В процессе работы с RIS-установкой возможно возникновение проблем с определением драйверов сетевой карты на текстовом этапе установки, а именно: при корректном подключении к RIS-серверу посредством PXE на текстовом этапе выдается сообщение о не найденных драйверах сетевой карты. Соответственно установка прекращается.

Проблема решается достаточно просто и изящно - необходимо *.inf и *.sys файлы проблемных карт скопировать в корень папки i386.

Автор: Akufrol

Опубликована - 04.05.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 07.05.05


Автоматическая установка

Загрузка компьютера по сети с практически любого образа диска

Представляю статью о загрузке по сети, которую написал участник конференции OSZone vserd.

Предисловие

Возникла у меня такая ситуация. Принесли компьютер, еле живой, Asus S200, та еще штучка как оказалось впоследствии. Диск был разбит по грамотному (два раздела), и на втором был дистрибутив Windows, спасибо предыдущему настройщику, облегчил задачку.

Итак, имеем компьютер без флоппа и CDROM. Есть сетевая карта SIS900. В BIOS есть возможность загрузиться с HDD, USB Floppy, USB Flash, USB CDROM и по сети.

На момент начала мучений с ним была только флешка, но грузиться с нее он отказался. Достать USB СD или Floppy не удалось. Оставалась только сетевая загрузка. Кстати, как оказалось впоследствии, что реально помог бы только USB флоп. USB СD не опознался.

Читая доки MS и форумы по Unattended натыкался на сокращение RIS и упоминание что можно загрузиться с сетевой карты и установить ось. Вот и решил проверить. Поставил RIS, создал образ, настроил DHCP и ... получил огромный облом. Система действительно загружалась, проходила текстовую часть установки и вываливалась в BSOD с кодом 0x000000BB. Согласно толкований, найденных на просторах Интернета, для исправления нужно всего ничего, заменить драйвера сетевой карты в дистрибутиве или заменить сетевую карту. Скачал новую версию драйверов, прочитал KB315279 и ссылки по ней, сделал все как описано, и танцы с бубном окончились продолжительным BSOD-ом с тем же кодом.

Ладно, если не получается с наскока давайте читать инструкции. Изучал, изучал и наткнулся на возможность использования практически любого образа диска для загрузки по сети.

Что понадобится

  • Утилита для создания загрузочных сетевых образов из обычных. Загружаем
  • Perl. Загружаем. (эта версия сработала у меня, другие пробуйте сами, я в Perl не игрок)
  • Блокнот из стандартной поставки Windows или любой другой ASCII редактор
  • Thinstation. Сайт, файл (8.86 Мб) (вполне возможно что файл и другой подойдет)
  • Установочный диск с Windows 2000 Server
  • Прямые руки, желание научиться :)

Приступаем

Шаг 1

Скачиваем и распаковываем утилиту преобразования. Для ясности, в D:\BootDisk\.

Шаг 2

Скачиваем и устанавливаем Perl.

Шаг 3

Создаем образ дискеты или используем готовый образ.

  • Если нет образа загрузочной дискеты в виде файла, тогда вставляем загрузочную дискету с MS-DOS и выполняем команду D:\BootDisk\MKIMAGE.BAT DOS. Поддерживаются стандартные 1.44 Mb приводы.
  • Если образ уже есть, тогда модифицируем файл создания загрузочного образа.
    1. Открываем блокнот и копируем/записываем следующий код
      @echo off
      cd mknbi-1.4.1-win
      perl.exe mknbi.pl --nosquash --format=nbi --target=dos ..\image.dos >..\dos.bin
      rem Если хочется универсальности, тогда комментируем верхнюю строчку (дописываем REM)
      rem и раскомментируем нижнюю (удаляем REM) (запуск MKIMAGE2 имя_образа_с_расширением)
      rem perl.exe mknbi.pl --nosquash --format=nbi --target=dos ..\%1 >..\dos.bin
      cd..
      :end
      Сохраняем его под именем MKIMAGE2.BAT
    2. Копируем образ дискеты в имя D:\BootDisk\image.dos
    3. Запускаем файл MKIMAGE2.BAT

Шаг 4

Ожидаем завершения работы батника. Проверяем, что размер dos.bin больше размера image.dos примерно на 4 кб.

Шаг 5

Распаковываем thinstation. Из архива нам нужен файл TFtpdRoot\thinstation.nbi.zpxe. Копируем его в D:\BootDisk\ с именем dos.bin.zpxe. Это загрузчик PXE.

Шаг 6

Настраиваем DHCP (если настроен, то переходим к шагу 7). У меня Win 2000 Server так что буду описывать для него.

Если DHCP не установлен, тогда его сначала нужно установить. (Панель управления> - Установка удаление программ - Добавление и удаление компонент Windows, затем выделить Сетевые службы, Состав и поставить галочку на DHCP).

Настраиваем DHCP. Панель управления - Администрирование, запускаем оснастку DCHP. Выбираем сервер DHCP который мы хотим настраивать. Затем из контекстного меню выбираем Создать область. В появившемся мастере вводим имя области и комментарий. Давайте осмысленные имена, чтобы и через пару-тройку лет с этим мог разобраться другой админ или вы сами. Затем вводим начальный и конечный адрес который хотим раздавать через DHCP. Максимальная емкость зависит от числа одновременно устанавливаемых машин. Если в диапазон адресов попал статический адрес, можете его ввести на следующей странице в список исключаемых. Дальше по вашему усмотрению. После создания области в секции Параметры области, нужно настроить параметры 066 IP сервера и 067 Имя файла для загрузки. В параметр 067 вписываем имя dos.bin.zpxe.

Шаг 7

Устанавливаем и конфигурируем RIS

Панель управления - Установка удаление программ - Добавление и удаление компонент Windows, ставим галочку на Служба удаленной загрузки. После завершения установки идем в Администрирование - Службы и запускаем службу Упрощенный FTP-демон.

Шаг 8

Копируем в C:\ftpdroot файлы dos.bin.zpxe и dos.bin.

Шаг 9

Устанавливаем на компе загрузку с сетевого адаптера по PXE и пробуем загрузиться.
Если все нормально, то на компьютере который загружается, будет идти поиск DHCP сервера, затем загрузчик покажет что присвоен IP адрес, и пошла загрузка с образа.

Общие примечания

Для редактирования/создания образа дискеты можно пользоваться WinImage, плугином к Total Commander Virtual Disk или другими утилитами. Если у вас один компьютер, и нет серверной платформы, вы можете использовать одну из виртуальных машин (например VMWare), установить на ней сервер и настроить на взаимодействие с другим компом. Судя по отзывам на форумах, это вполне реально.

Также в сети можно найти DOS стек TCP/IP. Или настроить NetBios/NetBEUI. В таком случае вы можете загрузить дистрибутив с шары.

Использованные источники

  1. Zetter/tPA. Citrix Metaframe XP - Создание тонкого клиента. Расписано как настроить DHCP и TFTP в картинках
  2. How to create Network Bootable Images under Windows. Название говорит само за себя. Описывается, как можно создать образ сетевого загрузчика. Текст на английском языке.
  3. How to create Network Bootable Images under Windows. Краткое руководство к действию по предыдущему источнику. Текст на русском языке.
  4. Александр Дейтер, Автоматическая сетевая установка Windows (или другие страницы, ссылки на которые находятся через поиск непринужденно). Описывается процесс настройки автоматизации установки Windows на базе Unix систем. Дала старт к дальнейшим поискам.
  5. KB315279: How to add a third-party OEM network adapter to a RIS installation. Статья Базы Знаний Microsoft.
  6. www.google.ru - обобщенный решатель возникших вопросов.
  7. Форумы: Ru-Board, IXBT, OSZone. Eсли подумать и поискать, то форумы сходу снимают до 90% возникших вопросов. Остальные можно попробовать задать на них.

Автор: Владимир Сердюк aka vserd
Иcточник: unattended.oszone.net

Наш форум

Опубликована - 03.12.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 03.12.05


Автоматическая установка

Мультизагрузка (обзор)

Учитывая популярность темы мультизагрузки на форуме Aвтоматической Установки, а также добавления еще одной статьи этой тематики, я решил сделать маленькую секцию Мультизагрузка в разделе Эксперту.

Совмещение нескольких вариантов установки Windows XP на одном диске - знакома посетителям сайта. Это вторая редакция самой первой статьи про мультизагрузку. Я лишь изменил название. В статье также описывается работа с менеджером загрузки BCDW (Bootable CD Wizard).

Совмещение нескольких ОС семейства NT на одном диске - новая статья, которую написал Vovanchik, участник конференции OSZone. Из статьи вы узнаете как совместить на одном носителе установку Windows 2000 и Windows XP. Этот метод также сработает для совмещения нескольких вариантов установки Windows XP и будет альтернативным способу, описанному в первой статье.

Название статьи Мультизагрузочный CD автоустановки Windows XP с неограниченным количеством конфигураций говорит само за себя. Автор статьи, VseDoFeNi, расскажет как подготовить такой диск при помощи его набора UnaCreator. UnaCreator позволит частично автоматизировать процесс процесс подготовки мультизагрузочного диска.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована - 12.07.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 12.07.05


Автоматическая установка

Совмещение нескольких вариантов установки Windows XP на одном диске

Изначально поводом к написанию данной статьи послужил тот факт, что диск, созданный с помощью файла ответов winnt.sif, не содержит функции восстановления системы Repair.

Честно говоря, более развернутых применений автозагрузке лично у меня не было. Я не планировал иметь на компакт-диске несколько операционных систем, а для восстановления образов системы ничем кроме Acronis True Image не пользуюсь. Да и функцию Repair я за все время пользования Windows XP я не применял ни разу. Однако, тема мультизагрузки весьма интересна, т.к. помимо различных операционных систем можно подготовить к установке различные наборы программ.

Итак, единственным способом заполучить функцию Repair будет создание мультизагрузочного диска с выбором загрузки в Автоматическую или Обычную установку. Если же вы хотите подготовить диск с различми операционными системами или наборами устанавливаемых программ, то без мультизагрузочного диска тем более не обойтись.

Ниже излагается способ, предложенный EgOrus, участником конференции Oszone. Данная версия статьи выключает дополнение, описывающее маркерные файлы-пустышки.

Для работы нам понадобятся HEX редактор (я использовал бесплатный xvi32) и менеджер загрузки Bootable CD Wizard.

О процессе загрузки

При создании загрузочного диска (образа) формируется загрузочный сектор, который обращается к файлу SETUPLDR.BIN в директории i386. В свою очередь, SETUPLDR.BIN содержит инструкции об обращении к файлу winnt.sif, и если такой файл существует в i386, то установка происходит автоматически с учетом ответов, обозначенных в winnt.sif. Вкратце, идея мультизагрузки с выбором автоматической и обычной установки состоит в том, чтобы создать два файла SETUPLD*.BIN, один из которых будет обращаться к файлу ответов, а другой – нет. Затем с помощью менеджера загрузки мы пропишем пути к каждому из файлов.

Изменение SETUPLDR.BIN

Внимание: чуть ниже будет описан способ создания мультизагрузочного диска при помощи Bootable CD Wizard (BCDW). Версия BCDW 1.50z несовместима с SETUPLDR.BIN от SP2. Поэтому используйте SETUPLDR.BIN от SP1. Новая версия BCDW 2.0 (официально не вышла) нормально работает с SETUPLDR.BIN от SP2.

В HEX редакторе открываем файл и заменяем все winnt.sif на winn1.sif, а затем сохраняем файл как SETUPLD1.BIN в i386

Tеперь переименовываем файл winnt.sif, находящийся в i386, в winn1.sif. Таким образом, SETUPLDR.BIN не найдя файла winnt.sif запустит обычную установку, а файл SETUPLD1.BIN обратится к winn1.sif для получения ответов для автоматической установки. Нам еще понадобится сторонний менеджер загрузки, который предоставит возможность выбора загрузочного файла. Но об этом чуть позже.

Отступление о различных вариантах установки программ

Если вы хотите создать диск с различными вариантами установки программного обеспечения (ПО), то нужно это спланировать заранее. У меня на сайте описаны несколько методов установки ПО: Выбор устанавливаемых приложений, GuiRunOnce и RunOnceEx. Давайте рассмотрим их подробнее применительно к мультизагрузке.

Выбор устанавливаемых приложений

Если выбор приложений, единственное что вам нужно, то наверное не стоит ради этого затевать мультизагрузку. Подробнее о выборе приложений при установке рассказано в соответствующей статье.

GuiRunOnce

Учитывая, что у нас уже подготовлены разные файлы ответов winn*.sif, логично использовать данный метод. Все что требуется, это включить в каждый файл ответов секцию GuiRunOnce и указать в ней путь к пакетному файлу с командами на установку ПО. Иными словами в winn1.sif у вас должно быть

[GuiRunOnce]
%systemdrive%\Install\batch_file1.cmd

и соответственно в winn2.sif должно быть

[GuiRunOnce]
%systemdrive%\Install\batch_file2.cmd

В этом примере предполагается, что вы поместили пакетные файлы в директорию $OEM$\$1\Install, и они были успешно скопированы на жесткий диск во время текстового этапа установки Windows.

RunOnceEx

Этот метод подразумевает наличие команды на запуск файла RunOnceCmd.cmd в файле cmdlines.txt. Однако, cmdlines.txt, находящийся в корне $OEM$, будет прочитан при любом из вариантов установки независимо от ваших файлов ответов, и следовательно создать различные варианты установки ПО не получится.

Аналогичная ситуация возникает с твиками реестра или MUI, если они устанавливаются из cmdlines.txt на Т-13. Что делать, если нужно применять разные твики или не ставить MUI для каких-то конфигураций? Есть обходной путь, который описан ниже.

Маркерные файлы-пустышки

Если вы используете несколько файлов ответов с OEM установкой (т.е. предположим вам нужны разные наборы настроек и софта), то вам нужны и разные папки $OEM$, но к сожалению при установке с CD (DVD), OEM файлы могут находиться только в корне диска в папке $OEM$ (переменная OemFilesPath= в winnt.sif почему-то игнорируется, видимо используется только при локальных и сетевых установках).

Для того чтобы обойти это ограничение я решил использовать батник, который по маркерному файлу определяет какой из файлов ответов использовался и в соответствии с этим ищет инфу в той или другой папке. Маркерный файл - это файл пустышка, который распаковывается из SFX архива за 39 минут до окончания установки.
Для этого есть специальный ключ:

[GuiUnattended]
DetachedProgram = "%SystemDrive%\Temp\dummy1.exe"

Из примера видно что файл распаковывается с жесткого диска, т.к. все архивы попадают туда во время текстового этапа установки вместе со всеми другими OEM файлами (в моем случае из папки $OEM$\$1\Temp). В это время копируются все архивы содержащие в себе по одному маркерному файлу (dummy1.exe, dummy2.exe и т.д.), а на этапе Т-39 распаковывается только нужный, указанный в файле ответов. Чтобы файл распаковался в нужную директорию (Temp), необходимо задать соответствующие настройки SFX архиву WinRAR. Это можно сделать во время создания архива через закладку Дополнительно) или прямо в закладке Комментарий:

;The comment below contains SFX script commands

Path=%SystemDrive%\Temp
Silent=1
Overwrite=1

Таким образом когда наступает время применения файлов настроек и установки программ, с помощью пакетного файла можно направить установку в нужную папку к нужным файлам. В моем случае используется bat-файл choice.bat, который запускается из cmdlines.txt

[COMMANDS]
"choice.bat"

и содержит следующие условия:

cmdow @ /HID
@echo off

if exist %systemdrive%\Temp\dummy1.fle goto START1
if exist %systemdrive%\Temp\dummy2.fle goto START2
....
goto END
:START1
REGEDIT /S Tweaks1.reg
.\RunOnce1.cmd
.\WinMUI\Muisetup.exe /i 0419 /d 0419 /l /f /r /s
goto END

:START2
REGEDIT /S Tweaks2.reg
.\RunOnce2.cmd
goto END
...

:END

dummy1.fle - это и есть маркерный файл, распакованный из dummy1.exe. Можно использовать и копирование вместо распаковки, но при копировании появляется консольное окно, а я использовал WinRAR SFX архив, поэтому распаковка происходит незаметно. Но как правильно недавно подметил один человек, для того чтобы не появлялась консоль можно компилить батники в исполнимые файлы exe :)

Директория $ОЕМ$ в нашем случае выглядит так:

В данном примере при первом варианте установки (START1) будет использован RunOnce1.cmd для инсталляции ПО, импортированы твики реестра из Tweaks1.reg, а также установлен MUI. При втором варианте установки (START2) соответственно используются RunOnce2.cmd и Tweaks2.reg, а MUI не устанавливается вовсе. Как вы понимаете, это всего лишь пример, приведенный для наглядности. Расположение файлов и команды измените на ваше усмотрение.

Теперь, когда структура диска готова, нужно подготовить мультизагрузку при помощи Bootable CD Wizard)

Создание мультизагрузочного диска с помощью Bootable CD Wizard (BCDW)

Если вы используете другой загрузочный менеджер, то инструкции приведенные ниже вам мало чем помогут. Надеюсь, что поняв идею, вы разберетесь как реализовать ее в другой программе. Честно говоря, я не планирую писать подробное руководство пользования BCDW. Вся необходимая информация содержится в справочных HTML файлах, а многие моменты подробно расписаны на сайте автора программы. Нас в первую очередь интересует файл bootcat.ini, в который мы и должны прописать пути к нашим загрузочным файлам. Распаковав архив с программой вы увидите, что там уже такой файл существует. Вам надо лишь изменить его соответствующим образом или создать новый. Синтакис будет примерно такой

\i386\setupld1.bin ;Windows XP Professional Unattended ;Unattend
\i386\setupldr.bin ;Windows XP Professional Regular ;Regular

В каждой строке вы видите три параметра, разделенные точкой с запятой. Первый указывает путь к загрузчику, второй отобразит текст в меню выбора загрузок, а третий (необязателен) является ключевым словом для описания типа загрузки. Полный текст своего bootcat.ini я привожу ниже (BCDW 1.51). Также, вы можете посмотреть скриншот загрузочного меню, которое получается при использовании такого bootcat.ini. Мой файл имеет пару дополнительных опций (Перезагрузка и запуск Acronis True Image). За перезагрузку отвечает команда :Reboot, а о том как загружаться в True Image можно прочитать в документации к программе.

\i386\setupld1.bin      ;Windows XP Professional Unattended     ;Unattend
\i386\setupldr.bin      ;Windows XP Professional Regular        ;Regular
\bcdw\acronis.wbt       ;Acronis True Image                             ;Acronis
:Reboot         ;Reboot                                         ;Reboot

[Options]

; *** Настройки фона под окнами

BGColors                = 00, 80, 80, 80                ; Цвета фона: бордюр, фон, верхняя строка, нижняя строка
BGSymbol                = 32                            ; Десятичный код символа-заполнителя фона: 32, 176, 177, 178
TopText                 =                               ; Текст верхней строки
BottomText              =                               ; Текст нижней строки

; *** Настройки окна "Вариант загрузки"

MenuPosition            = 02, 05, 76, 13                ; Расположение окна: X, Y, ширина, высота
MenuColors              = f9, 9f, 1f, f0, 0f, fd, f9    ; Цвета окна: рамка, заголовок окна при получении фокуса, заголовок окна при потере фокуса, строки, текущая строка при полученни фокуса, текущая строка при потере фокуса, недоступные строки
MenuBorderStyle         = 5                             ; Стиль рамки окна: 0, 1, 2, 3, 4, 5
MenuShadowStyle         = 2                             ; Стиль тени под окном: 0, 1, 2
MenuTitle               = Вариант загрузки              ; Текст заголовка окна
MenuDefault             = 0                             ; Индекс пункта меню по умолчанию
MenuTimerLabel          = Осталось времени:             ; Подпись таймера
MenuTimer               = 30                            ; Задержка в секундах перед автоматической загрузкой

; *** Настройки окна "О варианте загрузки" (если окно не нужно - удалите строки Help*)

HelpPosition            = 02, 19, 76, 6         ; Расположение окна: X, Y, ширина, высота
HelpColors              = e0, 9f, 1f, e0, 0f, e0        ; Цвета окна: рамка, заголовок окна при получении фокуса, заголовок окна при потере фокуса, строки, текущая строка при полученни фокуса, текущая строка при потере фокуса
HelpBorderStyle         = 5                             ; Стиль рамки окна: 0, 1, 2, 3, 4, 5
HelpShadowStyle         = 2                             ; Стиль тени под окном: 0, 1, 2
HelpTabSkip             = 0                             ; Пропуск окна при переключении по Tab: 0 - выкл., 1 - вкл.
HelpTitle               = О варианте загрузки           ; Заголовок окна

; *** Настройки окна "О компакт-диске" (если окно не нужно - удалите строки About*)

AboutPosition           = 02, 01, 76, 03                ; Расположение окна: X, Y, ширина, высота
AboutColors             = e0, 9f, 1f, e0, 0f, e0        ; Цвета окна: рамка, заголовок окна при получении фокуса, заголовок окна при потере фокуса, строки, текущая строка при полученни фокуса, текущая строка при потере фокуса
AboutBorderStyle        = 5                             ; Стиль рамки окна: 0, 1, 2, 3, 4, 5
AboutShadowStyle        = 2                             ; Стиль тени под окном: 0, 1, 2
AboutTabSkip            = 0                             ; Пропуск окна при переключении по Tab: 0 - выкл., 1 - вкл.
AboutTitle              = О диске               ; Заголовок окна
AboutText               = ~                             ; Содержимое окна
 Установочный диск Windows XP Professional. Июль 2004г. @ Vadikan
~

; *** Комментарии к вариантам загрузки

Unattend                = ~
Aвтоматическая установка Windows XP ENG с рус. интерфейсом и программами:
MS Office 2003, Nero 5.5.10.54 Rus, Opera 7.51, WinRAR 3.30, Java VM
Symantec Antivirus 8.1 (обновления Июль 2004), TweakIU и другими.
В систему интегрированы Service Pack 1 и критические обновления.

~

Regular         = ~
Обычная установка Windows XP. В систему интегрированы Service Pack 1 и
критические обновления на Июль 2004. Диск можно использовать для
восстановления системы функцией Repair.
~

Reboot          = ~
Перезагрузка компьютера

~
Acronis         =~
Загрузка в оболочку Acronis для создания образа системы или
восстановления ранее созданного образа.

Настройку внешнего вида оболочки я оставляю на ваше усмотрение. Для предварительного просмотра можно запустить файл initest.com. Когда вы сочтете, что ваша оболочка достойна номинации на конкурсе красоты загрузочных дисков, можете переходить к следующему шагу.

Создание загрузочного диска на основе BCWD

Существует масса способов для создания загрузочного диска, и они описаны в документации к программе. Я излагаю свой, нисколько не претендуя на уникальность. Он основан на использовании программы CDImage и нравится мне, в первую очередь, простотой. Из директории, в которой находится BCWD скопируйте в C:\XPCD директорию bcdw и файл bootcat.ini. Далее следуйте инструкциям, изложенным на странице Создание CD. Вам надо будет изменить синтаксис файла ISO Creator for WinXP Pro.cmd таким образом, чтобы загрузочный сектор создавался при помощи файла bcdwboot.bin. Проще всего кинуть файл bootcdw.bin в ту же директорию, что и ISO Creator for WinXP Pro.cmd, а затем отредактировать файл, заменив в тексте xpboot.img на bcdwboot.bin. Альтернативно, можно прописать полный путь к bcdwboot.bin.

В итоге у вас получится мультизагрузочный диск с возможностью выбора Автоматической или Обычной установки Windows XP. Аналогичным образом можно поместить на диск другие операционные системы.

Автор: Vadikan, EgOrus
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 09.03.2005


Автоматическая установка

Совмещение нескольких ОС семейства NT на одном диске

Представляю статью, которую написал Vovanchik, участник конференции OSZone.

Данный способ не является оригинальным и содержит в себе всего лишь наработки разных людей собранные воедино.

Создание базовых каталогов

Для начала создаем рабочую папку. Например, D:\work\. Примем эту папку за корень диска, который начинаем создавать. Внутри папки создадим другую, в которой будут лежать дистрибутивы: D:\work\windistrib. Создаем еще два подкаталога: D:\work\windistrib\winxp\ - для Windows XP и D:\work\windistrib\win2k\ - для Windows 2000. Длина каталогов не ограничена 8 символами.

В каждый из каталогов переносим папку i386, папку $OEM$, маркерные файлы и файл bootfont.bin (для локализованных версий) от соответствующего дистрибутива.

Создание каталогов с загрузчиками

Прежде чем выполнять действия, описанные в этом разделе, сделайте резервную копию своего рабочего файла boot.ini.

Windows XP

Сначала создаем каталог с загрузчиком для Windows XР. Выполняем в командной строке

D:\work\windistrib\winxp\winnt32.exe /noreboot

Запустится инсталлятор Windows. Выбираем вариант "Установка новой системы" (скачивать апдейты не надо). На этапе выбора настроек установки можно заглянуть в расширенные настройки и убедиться что галка "Копировать все файлы с диска" отмечена. После окончания работы установщика на системном диске появятся две новых скрытых папки: $WIN_NT$.~BT и $WIN_NT$.~LS. Папку $WIN_NT$.~LS удаляем, она нам не понадобится.

Переименовываем $WIN_NT$.~BT, скажем, в1WXP. Причем название настоятельно рекомендую начинать с буквы максимально более близкой к началу латинского алфавита или цифры, a также ограничивать длину имени папок четырьмя символами. Актуально это только для больших по объему носителей, например DVD. Судя по всему, дело тут в том, что в файловая система распределяет папки с файлами согласно этому самому алфавиту. Иными словами, если поместить загрузчик в папку XPOR, то установшик будет выдавать различные ошибки. от ошибки в первой строке txtsetup.sif и вплоть до зависания самого загрузчика. Если же папку переименовать например в 1WXP, все идет без происшествий. Это наблюдение верно для любого программного продукта Microsoft, который грузится через setupldr.bin.

Удаляем из папки 1WXP следующие файлы: BOOTSECT.DAT, migrate.inf, winnt.sif.

Windows 2000

Процесс создания загрузчика для Windows 2000 абсолютно такой же, как для Windows XP. Единственное отличие: переименовываем $WIN_NT$.~BT в 1W2K.

Теперь восстановите boot.ini из резервной копии, которую вы предусмотрительно создали ранее.

Завершение работы с каталогами

Теперь переименовываем файлы с русскими шрифтами bootfont.bin в btfontxp.bin и btfont2k.bin соответственно для Windows XP и Windows 2000. В папку D:\work\ копируем все маркерные файлы от обоих дистрибутивов, а также btfontxp.bin и btfont2k.bin. На данный момент мы имеем следующую структуру каталогов:

tree

winnt.sif, txtsetup.sif и setupldr.bin

На этом этапе мы удаляем все файлы по маске *.sif из папки D:\work\windistrib\ и всех вложенных в нее.

Windows XP

Переходим в папку D:\work\1WXP и если планируем автоматическую установку с файлом ответов, то копируем в нее заранее подготовленный winnt.sif для Windows XP. В этой же папке находим и открываем файл txtsetup.sif. Находим строку

SetupSourcePath = "\"

и заменяем ее на

SetupSourcePath = "\windistrib\winxp\"

После чего сохраняем файл.

В любом HEX редакторе открываем файл setupldr.bin и заменяем все встречаюшиеся в нем значения bootfont.bin на btfontxp.bin, после чего сохраняем файл.

Windows 2000

Переходим в папку D:\work\1W2K и если планируем автоматическую установку с файлом ответов, то копируем в нее заранее подготовленный winnt.sif для Windows 2000. В этой же папке находим и открываем файл txtsetup.sif. Находим строку

SetupSourcePath = "\"

и заменяем ее на

SetupSourcePath = "\windistrib\win2k\"

После чего сохраняем файл.

В любом HEX редакторе открываем файл setupldr.bin и заменяем все встречаюшиеся в нем значения bootfont.bin на btfont2k.bin, после чего сохраняем файл.

Bootable CD Wizard (BCDW)

Примечание: подробнее о BCDW рассказывается в первой статье про мультизагрузку, а также в этой теме на конференции OSZone.

Осталось только поместить в директорию D:\work\ папку BCDW и подправить файл bcdw.ini в ней таким образом:

\1W2K\setupldr.bin ; Установка Windows 2000
\1WXP\setupldr.bin ; Установка Windows XP

Вот и все!

P.S.

Понятно, что аналогичным образом можно создать несколько различных вариантов установки Windows XP. Для каждого из вариантов понадобится своя папка в каталоге windistrib. Если вы будете создавать дистрибутив при помощи утилиты CDImage как описано в этой статье, то на конечном размере образа это не отразится. Место на жестком диске, однако, все эти папки будут занимать. Альтернативно, можно использовать маркерные файлы, следуя инструкциям в первой статье про мультизагрузку

Автор: Vovanchik
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 09.03.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 12.07.05


Автоматическая установка

Мультизагрузочный CD автоустановки Windows XP с неограниченным количеством конфигураций

Введение

Здесь будет описан способ формирования мультизагрузочного (multiboot) CD Unattended установки Windows XP, обладающий исключительной гибкостью. На сформированном таким способом CD, имеется возможность размещения неограниченного количества, как аппаратных конфигураций, так и пресетов для автоустановки ПО. С легкостью можно создать варианты для бухгалтерии и юридического отдела, для дизайнеров и маркетологов с разными наборами устанавливаемого ПО. Причем установка будет происходить полностью автоматически. Если набор софта определяется в самом начале, отпадает необходимость изменения его в процессе установки, как в случае с WPI, например. Справедливости ради, надо отметить, что при описываемом способе вам ничто не мешает использовать программы выбора ПО, тот же WPI.

UnaCreator

Наиболее простым способом создания подобного CD будет изменение, а вернее дополнение дистрибутива, созданного с помощью UnaCreator v1.4. Дело в том, что UnaCreator собирает немного урезанный вариант такого мультизагрузочного CD, содержащий всего два варианта установки. В остальном такой дистрибутив полностью готов для добавления необходимого количества вариантов конфигураций установки. Именно по этой причине в описании будет использоваться эта сборка.

Для получения исходного дистрибутива соберите его с помощью UnaCreator v1.4. В результате его работы в каталоге UnaCreator_v1.4, помимо существующих файлов и папки появится WXPSP2_RU.ISO и каталог CDRoot, с которым мы и будем работать.

Важно!!! UnaCreator рассчитан на работу с русской версией Windosw XP.
Для английской верси и других локализованных версий нужно изменить Start.cmd, заменим в них имена каталогов и пути к ним на соответствующие.

Итак, в каталоге CDRoot\i386 уже находятся winnt.sif и winn1.sif, а также загрузчики setupldr.bin и setupld1.bin, которые обеспечивают два варианта загрузки. Пары setupldr.bin + winnt.sif и setupld1.bin + winn1.sif обеспечивают по одному варианту соответственно. Нам нужно добавить еще один или несколько вариантов.

Подготовка Драйверов

Так как наша задача максимально автоматизировать процесс установки, подготовим для нашего CD небольшой пакет драйверов.

Чипсеты Intel

Начнем с чипсетов Intel. Официальные драйверы для чипсетов можно найти и загрузить по этой ссылке (текущими официальными драйверами на момент написания статьи являются 7.2.1.1003 и 6.3.0.1007). Дальше нам необходимо распаковать драйверы для дальнейшего применения. Лучше заранее подготовить каталоги для 6 и 7 версии драйверов на диске C:. Далее программу установки драйверов нужно запустить с ключами для извлечения *.inf файлов.

Setup.exe -A -PC:\Intel_7.2.1.1003

для седьмой версии и

Setup.exe -A -P C:\Intel_6.3.0.1007

для шестой. Обратите внимание на пробел после ключа –P, для 6 версии он нужен, для 7 нет. Кстати, если вам нужны драйверы только для новых машин, собранных на чипсетах начиная с 865 и более новых, достаточно взять пакет Intel inf версии 7. Шестая версия нужна для белее старых чипсетов.

Итак, в результате описанных выше действий, мы получим два каталога с драйверами, в каждом из которых будут содержаться вложенные каталоги с файлами для разных версий Windows. Так как нам нужны драйверы только для Windows XP, мы сейчас займемся подготовкой пакета для этой ОС. Процедура не отличается сложностью. В каталоге C:\Intel_6.3.0.1007 во вложенных папках нужно удалить все подкаталоги кроме XP, а драйверы из них переместить в папки с названиями чипсетов следующим образом:

  • ich2XP --> ich2
  • ich2-mXP --> ich2-m
  • ich3-mXP --> ich3-m
  • ich3-sXP --> ich3-s
  • ich4XP --> ich4
  • ich4-mXP --> ich4-m

и скопировать туда папку XP из каталога C:\Intel_7.2.1.1003 для ich5, ich6 и ich7. Теперь каталог C:\Intel_6.3.0.1007 переименуем в C:\I и поместим в папку C:\Ch.Осталось только упаковать ее в 7-zip sfx (обычный, не бесключевой) как ChI.exe. Для 64 битных версий Windows необходим Intel inf версии 7.

Видео Intel

Подготовку драйверов для встроенного видео Intel разберем на примере драйвера версии 14.15.0.4363, предназначенной для 32 битных версий Windows для следующих чипсетов:

  • Intel(R) 855GM Chipset
  • Intel(R) 865G Chipset
  • Intel(R) 852GM Chipset
  • Intel(R) 855GME Chipset
  • Intel(R) 852GME Chipset
  • Intel(R) 910GL Express Chipset
  • Intel(R) 915GV Express Chipset
  • Intel(R) 945G Express Chipset
  • Mobile Intel(R) 915GM Express Chipset
  • Mobile Intel(R) 910GML Express Chipset
  • Mobile Intel(R) 915GMS Express Chipset
  • Intel(R) 915G Chipset

Загрузить драйверы можно по этой ссылке Скачивать лучше ZIP архив, как наиболее подходящий для наших целей. Из распакованного архива мы просто скопируем папку Win2000 в папку C:\Gr и переименуем её в I32. Теперь упакуем каталог Gr в 7-zip sfx как GrI32.exe. Для других чипсетов можно повторить описанную выше процедуру. Важно, чтобы названия каталогов с драйвером было отличное от I32.

Видео ATI Radeon

Скачать драйверы CATALYST 5.8 для 32 битных версий Windows XP для видеокарт на базе видеопроцессоров ATI можно с официального сайта. Нам понадобится два файла: 5-8_xp-2k_dd_25203.exe (собственно Display Driver) и 5-8_xp-2k_cp_25203.exe (Control Panel). Control Panel нам понадобится чуть позднее.

Процедура извлечения драйверов из программы установки несколько отличается от описанной для драйвера Intel. Для распаковки драйвера нужно запустить файл 5-8_xp-2k_dd_25203.exe и после распаковки прервать установку.

В каталоге C:\ATISUPPORT5-8_xp-2k_dd_25203 будет находиться распакованная программа установки. Из нее нужно переместить в каталог C:\Gr с переименованием 2KXP_INF в ATI. Теперь осталось скопировать в каталог C:\GrATI файл 5-8_xp-2k_cp_25203.exe и упаковать все в 7-zip sfx, как GrATI.exe.

Так как в данной статье не преследуется цели подробного описания процесса подготовки драйверов мы на этом и остановимся. По крайней мере у нас есть готовый пакет из трех WHQL драйверов, который без проблем установится в процессе инсталляции Windows.

Подготовка пресетов ПО

Теперь нам нужно подготовить парочку пресетов для установки разных вариантов ПО.

В качестве примера возьмем Nero-6.6.0.16, перепакуем его с помощью Nero Repacking Tool v1.1a в бесключевой sfx архив для тихой установки. Подготовим два пресета.

В первом к базовому набору ПО добавим Nero, во втором добавим Nero и уберем QuickTime Alternative. Чтобы добавить Nero изменим файл RunFromCD.cmd, находящегося в каталоге CDRoot\$OEM$\$1\Temp дистрибутива, подготовленного с помощью UnaCreator, добавим в него следующие строки:

IF EXIST %CDDRIVE%\Install\Nero\Nero-6.6.0.16_all_in_one.exe REG ADD %KEY% 77 /VE /D "Nero-6.6.0.16" /f
IF EXIST %CDDRIVE%\Install\Nero\Nero-6.6.0.16_all_in_one.exe REG ADD %KEY% 77 /V 1 /D "%CDDRIVE%\Install\Nero\Nero-6.6.0.16_all_in_one.exe" /f

Сохраните файл в любом другом каталоге с тем же именем. В этом же каталоге создайте файл drivers.cmd со следующими строками:

IF EXIST %WINDIR%\CMDOW.exe cmdow @ /HID
Start /wait %SystemDrive%\D\ChI.exe x -y -ao
Start /wait %SystemDrive%\D\GrI32.exe x -y -ao
Start /wait %SystemDrive%\D\GrATI.exe x -y -ao
exit

Теперь оба файла надо упаковать WinRAR sfx с именем NeroPlus.exe и добавлением в комментарий следующих строк:

Path=%SystemDrive%\temp
SavePath
Setup=%SystemDrive%\Temp\drivers.cmd
Silent=1
Overwrite=1

Так, первый пресет готов. Сейчас подготовим второй.

Для этого просто уберем строки, определяющие установку QuickTime Alternative в RunFromCD.cmd и упакуем его и drivers.cmd в sfx архив с именем NoQTA.exe. Не забудьте добавить комментарий к архиву.

Подобным образом можно подготовить любые пресеты с нужными вам параметрами для установки приложений или драйверов. Количество пресетов ограничено только объемом CD/DVD диска.

Подготовка загрузчиков (пар *.sif + *.bin )

Для обеспечения возможности загрузки разных вариантов нам нужно подготовить пары загрузчик + файл ответов, по умолчанию это setupldr.bin и winnt.sif. Для изменения возьмем загрузчик setupld1.bin, откроем его в HEX-редакторе и заменим все winn1.sif на NPlus.sif. Можно задавать любые имена соответствующей длины, например NPlus.sif для нашего варианта с добавленным Nero и NoQTA.sif соответственно. На мой взгляд, осмысленные имена файлов предпочтительнее, чем просто цифорки. На скриншоте показано, как это сделать в HEX режиме бесплатного редактора PSPad.

Сам загрузчик можно сохранить, как NPlus.bin и второй, как NoQTA.bin и поместить их в каталог CDRoot\i386.

Подготовка файлов ответов

Файл ответов winnt.sif скопируем в каталог CDRoot\i386 под именем NPlus.sif для первого варианта и NoQTA.sif для второго. Теперь надо открыть файлы в текстовом редакторе и для файла NPlus.sif добавить/изменить параметр

[GuiUnattended]
DetachedProgram = "%systemdrive%\Temp\NPlus.exe"

Для NoQTA.sif параметр будет соответственно

[GuiUnattended]
DetachedProgram = "%systemdrive%\Temp\NoQTA.exe"

В оба файла добавим пути к папкам с драйверами в секции [Unattended], чтобы программа установки могла их найти.

OemPnPDriversPath="D\CH\Iich2;D\CH\Iich2-m;D\CH\Iich3-m;D\CH\Iich3-s;D\CH\Iich4;D\CH\Iich4-m;D\CH\IXP;DGR\I32;DGR\ATI”

Сводим всё вместе

Итак, кроме дистрибутива у нас подготовлено несколько пресетов ПО, пакет драйверов, загрузчики и файлы ответов. Настало время свести все вместе. Для этого все файлы надо разложить на свои места, собрать ISO и прожечь его на CD.

Поместите подготовленные:

Nero-6.6.0.16_all_in_one.exe в каталог CDRoot\Install\Nero
ChI.exe, GrI32.exe и GrATI.exe в CDRoot\$OEM$\$1\D
Загрузчики *.bin и файлы ответов *.sif в CDRoot\i386

Теперь можно пересобрать ISO, запустив ReBuildISO.cmd в каталоге UnaCreator_v1.4, записать образ на диск и установить любой из вариантов.

И в заключение хочется сказать, что данный метод не исчерпывается приведенными здесь вариантами. Пробуйте, экспериментируйте.

Автор: Vse Do Fe`Ni

Наш форум

Опубликована - 13.09.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 09.10.05


Автоматическая установка

Справочник

Справочник состоит из статей, на которые часто ссылаются другие статьи раздела. Вместо того, чтобы повторяться каждый раз, мы будем давать ссылку на соответствующую статью справочника. Ниже приводится краткий обзор статей Справочника.

Процесс установки по минутам расписывает установку Windows по минутам, объясняя что происходит на каждом из этапов.

Параметры файла ответов winnt.sif представляют собой краткую выдержку из файл ref.chm, входящего в пакет SP2 Deployment Tools. Большинства описанных в статье параметров достаточно для успешного создания файла ответов.

$OEM$ Директории используются для автоматического копирования нужных вам файлов в различные директории системного диска во время установки ОС.

Виртуальные машины очень полезны для тестирования автоматической установки. Статья включает в себя руководство по настройке двух типов виртуальных машин.

Ключи для приложений (основы) нужны для понимания процесса автоматической установки приложений.

GuiRunOnce - самый простой способ запуска автоматической установки приложений при первом входе в систему.

CMDLINES.TXT - файл, из которого можно запускать различные команды еще до первого входа в систему. Очень удобен для импортирования твиков реестра и других специфических задач

Локализация: MUI, Шрифты и Региональные настройки- призвана осветить все тонкости локализации и выработать алгоритм применения настроек, срабатывающий на 100%.

Сжатые файлы составляют основу дистирбутива Windows. Статья рассказывает о том, как их распаковывать и создавать.

Создание SFX архива помогает сэкономить место на CD. Такие архивы бывают очень удобны для установки приложений.

Примеры пакетных файлов, файла ответов, твиков реестра и т.д.

FAQ - список часто задаваемых вопросов на форуме. Ответы прилагаются :) Обязательно прочитайте, прежде чем задать свой вопрос.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 14.03.2005


Автоматическая установка

Параметры файла ответов

[Data] | [Unattended] | [GuiUnattended] | [Shell]
[UserData] | [TapiLocation] | [RegionalSettings] | [Display]
[Networking] | [Components] | [Identification] | [GuiRunOnce]
[IEPopupBlocker] | [WindowsFirewall] | [SetupParams]

-------
[Data]

AutoPartition=1 or 0

Если у вас выбрано 1, то система будет установлена на любой свободный раздел жесткого диска. Если вы уберете эту строку или установите параметр равным 0, то программа установки спросит вас на какой раздел вы хотите установить систему, а также предупредит, если на разделе уже установлена ОС.

MsDosInitiated = "0" or "1"

Если установить "0", то это скажет программе установки, что вы используете CD. Если же вы грузитесь с дискет, то поставьте значени "1". (Кавычки важны)

UnattendedInstall = "Yes"

Если выбран "Yes", то это говорит системе, что вы запускаете автоматическую установку.

AutomaticUpdates=yes

Этот параметр говорит программе установки Windows пропустить страницу Help Protect Your PC, которая появляется по окончании графического этапа установки системы.

^Наверх

-------
[Unattended]

UnattendMode=FullUnattended

Установка данного параметра в FullUnattended влечет за собой полностью автоматическую установку, которая будет использовать файл ответов для каждого из графических этапов установки. У вас не будет возможности отвечать на вопросы программы установки. Другие значения этого параметра можно найти в файле ref.chm, который упомянут на странице Файл ответов.

OemSkipEula=Yes or No

Установив опцию Yes, вы пропускаете лицензионное соглашение, которое вы уже прочитали, когда использовали Setup Manager. Если установить No, то придется жать F8 чтобы принять соглашение во время текстового этапа установки системы.

OemPreinstall=Yes or No

По умолчанию этот параметр No, но если вы используете $OEM$ директории, то параметр нужно уставновить в Yes, чтобы программа установки признала наличие директорий и скопировала их на системный раздел. Это происходит в конце текстового этапа установки.

TargetPath=\WINDOWS

Указывает директорию, в которую будет устанавливаться система.

Repartition=No

Указывает удалять ли все разделы на первом диске и форматировать ли его в NTFS.

FileSystem=*

Если вы предпочитаете ручной выбор логического диска и файловой системы для установки Windows, то добавьте этот параметр в файл ответов. Из собственного опыта отмечу, что это не обязательно, если у вас указан Repartition=No.

UnattendSwitch="yes"

Указывает программе установки пропустить шаг "Добро Пожаловать в Windows" или Мини-установку. Установите параметр в "yes", если вы хотите пропустить экраны "Настройка подключения к Интернет" и "Создание учетной записи".

WaitForReboot="No"

Установив параметр в "No" вы указывает компьютеру не ждать 15 секунд до перезагрузки после окончания первого этапа установки.

OemPnPDriversPath="Drivers\Catalyst3_6\2KXP_INF;Drivers\asus\sound\"

Здесь вы указываете программе установки искать директории, содержащие обновленные драйверы, которые вы хотите использовать вместо родных, содержащихся в drivers.cab на инсталляционном диске. Если программа установки найдет драйверы, то она установит их вместо родных. Данный параметр не нужен если вы не планируете указывать на альтернативные драйверы в процессе установки.

DriverSigningPolicy=Ignore

Заставит программу установки поставить драйвера, не сертифицированные WHQL. Используетеся в сочетании с OemPnPDriversPath

AutoActivate = Yes

Автоматически активирует вашу копию Windows XP после установки. Конечно, сначала надо создать подключение к Интернет. Не забудьте указать правильный ProductKey в разделе [UserData]

ProgramFilesDir="C:\My Program Files"

Вы можете изменить расположение директории Program Files, используемое по умолчанию. Замените имя диска и путь на ваше усмотрение, если нужно.

CommonProgramFilesDir="C:\My Program Files\My Common Files"

Вы можете изменить расположение директории CommonProgramFilesDir в директории Program Files, используемое по умолчанию. Замените имя диска и путь на ваше усмотрение, если нужно.

KeyboardLayout="United Kingdom"

Если указать раскладку клавиатуры заранее, то языковая иконка не будет отображаться в Панели Задач после входа в систему. Полный список раскладок можно посмотреть тут.

^Наверх

-------
[GuiUnattended]

AdminPassword=Ваш пароль или *

Этот параметр задает пароль учетной записи Администратор. Если поставить *, то это будет означать пустой пароль.

EncryptedAdminPassword=Yes or No

Параметр говорит программе установки зашифрован ли пароль. Если вы не выбрали пароль Администратора заранее, то установите значение No. Setup Manager зашифрует ваш пароль в вашем файле ответов, если вы выберете такую опцию.

OEMSkipRegional=0 or 1

Если установить 0, то программа установки покажет экран Региональных Настроек. Если поставить 1, то не покажет.

TimeZone=145

Данный параметр задает Временную Зону. Каждая зона имеет свое значение. Значения можно найти в файле ref.chm.

OemSkipWelcome=0 or 1

Этот параметр надо установить в 0, если у вас OemPreinstall=No. Если же OemPreinstall=Yes, то OemSkipWelcome надо установить равным 1, иначе весь процесс работы с $OEM$ директорией не пойдет.

ProfilesDir="C:\Documents and Settings\"

Вы можете изменить расположение директории Documents and Settings, используемое по умолчанию используя данный параметр.

^Наверх

-------
[Display]

BitsPerPel=32

Задает качествно цветов в битах. Возможные параметры: 32, 24, 16 и 8 (256 цветов).

Xresolution=1024

Разрешение по горизонтали.

Yresolution=768

Разрешение по вертикали.

Vrefresh=85

Частота развертки экрана. Не устанавливайте значение выше, чем предусмотрено тех. характеристиками монитора, иначе вы можете его повредить.

^Наверх

-------
[UserData]

ProductKey=xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

Ваш CD-Key

FullName="Вставьте имя "

Задает имя пользователя компьютера.

OrgName="Вставьте название организации "

Задает название организации. Именно эти два параметра будут подставляться по умолчанию при установке большинства программ. Также будут отображаться в свойствах системы в разделе "Зарегистрирован на"

ComputerName=Вставьте название компьютера

Задает название компьютера. Как вы яхту назовете, так она и попывет (с) Приключения Капитана Врунгеля ;-))

^Наверх

-------
[TapiLocation]

CountryCode=7

Код страны, в которой вы живете. 7 - Россия. Для остальных стран - читайте ref.chm.

AreaCode=812

Код города. 812 - Санкт-Петербург

Dialing=Tone or Pulse

Зависит от типа телефонной линии. Тональный или импульсный набор. Если не знаете, то не используйте данную строку.

^Наверх

-------
[RegionalSettings]

LanguageGroup=1,2,3,4,5
SystemLocale=00000419
UserLocale=00000419
InputLocale=0419:00000419,0409:00000409

Подробнее об этой секции, а также о локализации вообще читайте в статье Локализация: MUI, Шрифты и Региональные настройки.

^Наверх

-------
[Identification]

JoinWorkgroup=WORKGROUP

Указывает к какой Рабочей Группе вы хотите присоединиться. Если вы не в локальной сети, то не меняйте этот раздел.

^Наверх

-------
[Networking]

InstallDefaultComponents=Yes or No

Вы можете выбрать устанавливать ли компоненты, необходимые для работы в сети. Если выбрать Yes, то будут установлены все компоненты по умолчанию. Если выбрать No, то тогда можно задать какие протоколы, сервисы и клиенты будут установлены. Легче всего это сделать через Setup Manager.

^Наверх

-------
[Components]

В этом разделе можно заранее задать какие компоненты Windows устанавливать. Параметр off означает, что компонент не будет установлен. Параметр on или отсутствие такового означает, что компонент будет установлен.

msmsgs=off
Не устанавливать Windows Messenger 4.6

msnexplr=off
Не устанавливать MSN Explorer 7.

freecell=off
Не устанавливать игру Свободная ячейка.

hearts=off
Не устанавливать игру Черви.

minesweeper=off
Не устанавливать игру Сапер.

pinball=off
Не устанавливать игру Пинболл.

solitaire=off
Не устанавливать игру Косынка.

spider=off
Не устанавливать игру Паук.

zonegames=off
Не устанавливать Игровую Зону MSN.

Полный список компoнентов можно посмотреть здесь.

^Наверх

-------
[Shell]

CustomDefaultThemeFile = "%WinDir%\Resources\Themes\MyTheme.theme"

Этот параметр устанавливает тему, которую Windows будет использовать по умолчанию. Это может быть тема, входящая в состав Windows, или любая сторонняя тема. Если вы используете этот параметр, то Windows загрузится не с темой Луна, а с той, которую вы укажете. Необхдимо помнить, что для использования сторонних тем, родная библиотека uxtheme.dll должна быть заменена на пропатченную.

DefaultStartPanelOff = Yes

Применение данного параметра говорит Windows использовать Классическое Меню Пуск, и отображать иконки Мой Компьютер, Мои Документы, и др. на Рабочем Столе. Если поставить параметр No, то система загрузится с Меню Пуск, используемым в Windows по умолчанию.

DefaultThemesOff = Yes

Этот параметр заставит Windows использовать Классическую Тему. Внимание: если данный параметр имеет значение Yes, то он преобладает над параметром CustomDefaultThemeFile

^Наверх

-------
[GuiRunOnce]

"%systemdrive%\install\batch_file1.cmd"

Эта секция содержит команды, выполняющиеся при первом входе пользователя в систему. Подробнее о ней можно почитать здесь.

^Наверх

-------
[IEPopupBlocker]

AllowedSites=www.oszone.net;www.microsoft.com;www.amazon.com

Добавляет указанные сайты в список блокировщика всплывающих окон Internet Explorer. Перечисленным сайтам показ всплывающих окон разрешен. Допускается любое количество сайтов, разделенных точкой с запятой.

BlockPopups=Yes или No

Разрешает или запрещает блокировку всплывающих окон. По умолчанию блокировка включена.

FilterLevel=High, Medium или Low

Уровень фильтрации блокировщика можно задать любым из трех значений

  • High блокирует все окна
  • Medium блокирует большинство автоматических окон (так он настроен по умолчанию)
  • Low разрешает всплывающие окна только с сайтов с повышенной безопасностью (https, например)

ShowInformationBar=Yes или No

Регулирует показ информационной панели, которая появляется под адресной панелью и уведомляет о заблокированном всплывающем окне или заблокированной попытке установки ActiveX. По умолчанию информационная панель включена.

^Наверх

-------
[WindowsFirewall]

Добавление следующих строк в любом месте winnt.sif полностью отключает встроенный брэндмауэр Windows.

[WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

Если вы хотите оставить брэндмауэр включенным и сконфигурировать определенные настройки, то читатйте в ref.chm раздел Unattended.txt > [WindowsFirewall], поскольку подробный разбор всех настроек займет слишком много времени и места. Дополнительную информацию o конфигурриовании брэндмауэра также можно почерпнуть из многостраничного документа wfinf_guide.doc, входящего в SP2 Deployment Tools.

^Наверх

-------
[SetupParams]

[SetupParams]
UserExecute = "%systemdrive%\install\cleanup.cmd"

Команда будет выполнена за девять минут до окончания установки Windows. Может быть полезна, например, для удаления временных директорий, которые вам были нужны на более раннем этапе установки.

Это лишь небольшая, хотя и важная, часть параметров, которые могут быть указаны в файле ответов. Об остальных вы можете почитать в ref.chm.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 24.02.2005


Автоматическая установка

$OEM$ директории на инсталляционном диске

$ОЕМ$ директории удобны для автоматического копирования ваших файлов на системный диск в процессе установки. Если файлы скопированы, значит вы легко можете создать пакетные команды для исполнения различных заданий используя переменную %systemdrive%. Например, если система была установлена на диск D:\, то переменная %systemdrive% будет автоматически преобразована в D:\.

Вы можете спросить почему же нельзя устанавливать приложения и запускать комманды прямо с CD? Дело в том, что буквы, назначаемые CD-ROMам различаются от компьютера к компьютеру, поэтому и не существует переменной %CDROM%. Можно, конечно, обойти и эту проблему, но речь сейчас не о ней. К тому же, $ОЕМ$ директории используются не только для копирования инсталляционных файлов приложений.

Как видно на скриншоте, $ОЕМ$ директория находится параллельно директории I386. Все, что находится в $1 будет скопировано в корневой каталог диска, на который будет установлена система (например, C:\). Рассмотрим на простом примере как это работает:

Предварительная подготовка дистрибутива:

C:\XPCD\$OEM$\$1\Install\

После того, как дистрибутив записан на CD (обозначим CD-ROM буквой X:\)

X:\$OEM$\$1\Install\

Когда $OEM$ директории копируются на системный раздел диска во время установки

C:\Install

Понятно? Поэтому если вам доведется составить команду для установки приложения, скопированного таким образом на системный раздел, то это будет выглядеть примерно так:

start /wait %systemdrive%\install\MSN\msnmsgs.msi /qb

Т.е. приложение лежало в директории $1\Install, скопировалось в C:\Install если допустить, что C:\ наш системный диск. Подробнее об установке приложений чуть позже.

Все, что находится в $$ будет скопировано в директорию Windows. При этом не важно как она будет называться: Windows, WINNT, WindowsXP). Используя такой метод можно создавать дополнительные директории внутри $$. Например, можно создать директорию Resources с поддиректорией Themes и положить туда ваши любимые визуальные стили. В итоге, при установке Windows ваша директория будет скопирована в C:\Windows\Resources\Themes автоматически.

Теперь когда вы знаете как это все работает, остальное понять не трудно.

$Docs - Documents and Settings

$Progs - Program Files

$$ - директория Windows

$1 - корневой каталог диска, на который устанавливается система.

Все это позвоялет сохранить время и силы, и пакетные команды типа COPY или XCOPY, для того чтобы скопировать желаемые файлы/директории на жесткий диск в процессе установки системы.

Примечание: в данной статье описано расположение директории $OEM$ для установки с CD. Для сетевой установки или установки с жесткого диска директорию $ОЕМ$ нужно разместить в i386. Подробнее о возможных проблемах с копированием $OEM$ директорий тут.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 14.02.2005


Автоматическая установка

Процесс установки по минутам

Эта страница расписывает установку Windows по минутам, объясняя что происходит на каждом из этапов. Т-39 означает за 39 минут до окончания установки, Т-13 означает за 13 минут до окончания установки и т.д.

Текстовый этап установки

1. Загружаются драйверы

2. На жесткий диск копируются файлы необходимые для установки

3. На жесткий диск копируется содержимое $ОЕМ$ директорий

4. Выполняется перезагрузка компьютера...

Графический этап установки

1. Параметр DetachedProgram выполняется из winnt.sif на Т-39

2. Устанавливается оборудование

3. Устанавливаются сетевые компоненты

4. Устанавливаются элементы меню Пуск

5. Регистрируются компоненты

6. svcpack.inf отрабатывает на Т-13

7. Команды из cmdlines.txt выполняются на Т-12

8. Параметр [SetupParams] выполняется на Т-9

9. Сохраняются настройки

10. Удаляются временные файлы и выполняется перезагрузка компьютера

Первый вход в систему

1. Загружаются личные настройки

2. Одновременно выполняются параметр [GuiRunOnce] из winnt.sif и RunOnceEx (если они используются, конечно)

3. Загружаются Рабочий стол и Панель Задач

Надеюсь, эта информация была вам полезна. Если у вас есть вопросы о параметре [SetupParams], почитайте ref.chm.

Автор: Vadikan
Иcточник: (переведено с англ.) unattended.msfn.org

Наш форум

Опубликована- 18.03.2005

© Все права защищены OSzone.net 2001-2006

Распечатано 10.04.05


Автоматическая установка

Виртуальные машины

В статьях сайта нередко упоминаются виртуальные машины. Эта страница объяснит что такое виртуальные машины и поможет с их установкой.

Виртуальная машина - это программа, которую вы запускаете из своей операционной системы. Программа эмулирует реальную машину. Как и в случае с реальной машиной, вы можете установить на виртуальную машину операционную систему, причем неважно Windows или *nix. Таким образом вы можете тестировать различные операционные системы не покидая своей. У виртуальной машины есть BIOS, жесткий диск (отведенное место на вашем жестком диске), CD-ROM (ваш CD-ROM или подключенный ISO образ), сетевые адаптеры для соединения с вашей реальной машиной, сетевыми ресурсами или другими виртуальными машинам и т.д. Вы можете без проблем обмениваться файлами между хостом (вашей ОС) и клиентом (виртуальной машиной). Это осуществляется простым перетаскиванием файлов из файлового мендежера клиента в окно хоста и наоборот. Удобство виртуальной машины для тестирования автоматической установки просто неоценимо. Достаточно просто подключить загрузочный ISO образ в вместо CD-ROM в настройках виртуальной машины, и установка системы пойдет точно также, как и на реальной машине.

На этой странице рассматириваются две наиболее известные виртуальные машины: VMWare Workstation и Microsoft`s VirtualPC. У каждкой есть свои преимущества и недостатки. VMWare считается побыстрее, а VirtualPC предлагает больше возможностей для интеграции клиента с хостом. Производители обеих виртуальных машин предлагают триальный период для тестирования программ.

VMWare Workstation - Домашняя страница | Скачать
Microsoft VirtualPC 2004 - Домашняя страница | Скачать

Ниже рассматриваются процессы базовой настройки обеих виртуальных машин. Выберите используемую вами:
VMWare Workstation | VirtualPC

Настройка VMWare Workstation

Установите VMWare и запустите программу. В первом же окне выберите опцию создания новой виртуальной машины

На первом шаге кликните Next. Когда увидите следующее окно, выбирайте Typical (обычную) конфигурацию и жмите Next.

Выберите операционную систему, которую вы планируете установить на виртуальную машину.

На следующем шаге вы можете выбрать имя виртуальной машины и расположение ее файлов. Можно оставить значения по умолчанию.

Конфигурация сети зависит от ваших обстоятельств. Я выбираю "Use Network Address Translation (NAT)", т.к. у меня нет LAN, подключение к сети Интернет осуществляется через Dial-up. При таком варианте если хост подключен, то и клиент может выходить в Интернет. Если вы выберете "Bridged Networking", то это равносительно созданию двух отдельных компьютеров с уникальным IP адресом для каждого из них. Иными словами, вам нужно будет назначить клиенту собственный IP адрес.

На следующем шаге вам нужно выбрать размер виртуального жесткого диска. Фактически, это файл на вашем жестком диске с максимальным размером, который вы укажете на данном этапе. Однако, клиент будет видеть его сразу таким, как вы укажете. Иными словами, если вы выберете размер в 4Гб, то виртуальная машина будет "думать", что размер ее жесткого диска 4Гб. На реальном жестком диске размер файла будет зависеть от размера всех файлов на виртуальном диске, но он будет не более 4Гб. Замечу, что 4Гб более чем адекватно для тестирования автоматической установки. Я поддерживаю рекомендацию Alanoll отметить чекбокс "Allocate all disk space now" (Выделить все дисковое пространство сейчас), т.к. это увеличит быстродействие виртуальной машины.

Eсли вы отметили чекбокс "Allocate all disk space now", то VMWare попросит подтвердить решение. Нажмите Yes.

На этом мастер конфигурации завершает свою работу, и вы попадаете в главное окно VMWare. Конфигурирование, однако, на этом не заканчивается.

Осталось проделать всего пару манипуляций и настроить загрузку VMWare с ISO образа. Нажмите "Edit Virtual Machine Settings" слева. Вы увидите окно аналогичное такому:

Кликните на "CD-ROM" слева, а справа выберите опцию "Use ISO image". Найдите загрузочный ISO образ, который вы создали следуя статье Создание загрузочного ISO/CD и нажмите OK, чтобы вернуться к главному окну.

Kликните на кнопку с зеленой стрелкой VMWare наверху для запуска виртуальной машины. Теперь все должно работать так, как будто перед вами реальная машина.

Возможна следующая ситуация. Вы настроили загрузку с ISO, но при запуске виртуальной машины не появляется надпись "Press any key to boot from CD...", и машина не загружается с CD. В таком случае надо выставить загрузку с CD-ROM в BIOS, точно также как на обычной машинте. Перезапустите виртуальную машину и нажмите F2. Вы должны войти в настройки BIOS виртуальной машины, которые выглядят примерно так:

Используйте стрелки Вправо/Влево на клавиатуре, чтобы перейти в меню Boot

Используйте стрелки Вверх/Вниз на клавиатуре, чтобы выбрать CD-ROM, а задем жмите на клавишу "+" до тех пор, пока CD-ROM не окажется в списке над Hard Drive.

Теперь при помощи стрелок Вправо/Влево выберите меню Exit, затем выделите "Exit Saving Changes" и жмите Enter. Подтвердите запрос на изменение настроек, и виртуальная машина перезагрузится с новыми настройками

Настройка Microsoft VirtualPC

Установите VirtualPC и запустите программу. При первом запуске должен появиться мастер настройки. Если он не появился, то в главном окне

кликните New

Кликните Next в первом окне, и следующее окно будет выглядеть так:

Выберите "Create a Virtual Machine" и жмите Next

На следующем шаге вы должны выбрать название виртуальной машины.

Следущее окно позволяет вам выбрать тип операционной системы. Вновь рекомендуется Windows 2000, т.к. это поможет избежать напоминания об активации Windows.

Вы можете выбрать количество оперативной памяти, с которым будет работать виртуальная машина. Можно оставить настройки по умолчанию.

Теперь укажите, что вы хотите создать новый виртуальный жесткий диск.

Следующий этап указывает расположение виртуального жесткого диска. Можно оставить по умолчанию.

Настройка окончена. Вы видите последнее окно мастера. Жмите Finish.

Теперь вы вновь должны оказаться в главном окне программы. Выберите виртуальную машину, которую вы только что создали, и жмите Start.

Когда появится новое окно, выберите CD из ниспадающего меню наверху и кликните "Capture ISO Image..." . Выберите ISO образ, который вы создали слледуя статье Создание загрузочного ISO/CD.

Если программа выдает ошибку, то вероятно ваш образ более 2 Гб, и VirtualPC не поддерживает такие образы. Придется использовать обходной путь. Смонтируйте ISO образ при помощи Daemon Tools (freeware) или Alcohol. После того, как образ смонтирован, в меню CD выберите букву соответствующую образу букву диска вместо "Capture ISO image...".

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 23.02.2005


Автоматическая установка

Ключи для приложений (основы)

На этой странице я постараюсь кратко изложить принцип использования ключей для автоматической установки приложений. Объяснения будут проиллюстрированы парой картинок.

Черный текст представляет собой типичную команду пакетного файла. Можете его проигнорировать, как не относящийся к теме этой страницы.

Синий текст - вызов приложения. Вы видите путь к приложению, завершающийся именем исполняемого файла. Типичное расширение файла - *.EXE, однако могут быть и другие (например, *.MSI). Иногда вы можете увидеть путь, заключенный в кавычки (" "). Это означает, что в пути есть пробелы (C:\Program Files).

Зеленый текст - это как раз и есть ключ, с которым запускается приложение. В большинстве случаев ключи разделяются пробелами. Однако, бывают и исключения. Ниже пример связанного ключа.

На самом деле, связанные ключи встречаются редко. Так что не надо особо о них беспокоиться.

Иногда о ключах можно узнать, запустив программу с ключом /? или /help. Также, каждый из распространенных типов инсталляторов поддерживает определенные ключи.

Сайт unattended.msfn.org планирует запустить базу данных ключей для автоматической установки приложений. Она должна стать уникальным и самым полным ресурсом в сети Интернет.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 25.02.2005


Автоматическая установка

GuiRunOnce

[GuiRunOnce] - это секция файла winnt.sif, которая содержит команды выполняющиеся при первом входе пользователя в систему. Каждая команда занимает одну строку. Само название секции интерпертируется как "запустить один раз из графического интерфейса". В соответствии с ref.chm команды обязательно должны заключаться в кавычки, однако в приведенном там же примере кавычек нет :) Во время установки системы, команды размещенные в [GuiRunOnce] импортируются в ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Runonce.

В общем, [GuiRunOnce] можно использовать, как самый простой метод установки приложений. В [GuiRunOnce] размещается команда на запуск пакетного файла, который в свою очередь содержит команды на установку приложений. Допустим, таким пакетным файлом у нас является install.cmd. Пример команды на его запуск из [GuiRunOnce]

[GuiRunOnce]
"%systemdrive%\install\install.cmd"

Я подразумеваю, что вы знакомы с $ОЕМ$ директориями и понимаете, что если файл install.cmd кладется в $OEM$\$1\install\, то в процессе установки он будет скопирован в %systemdrive%\install и запущен при первом входе систему при помощи вышеуказанной команды.

В секции [GuiRunOnce] можно указать несколько команд:

[GuiRunOnce]
"regedit /s %systemdrive%\install\tweak.reg"
"%systemdrive%\install\install.cmd"
"%systemdrive%\install\cleanup.cmd"

и так далее. Команды будут выполнены последовательно, т.е. по завершении первой указанной команды, будет выполняться вторая и т.д.

Примечание: выполнение команд секции [GuiRunOnce] начинается до загрузки оболочки (explorer), следовательно установка приложения, которому для корректной инстaлляции требуется наличии облочки, может закончиться неудачей (особенно если команда на установку приложения идет в начале списка).

Автор: Vadikan

Наш форум

Опубликована- 24.02.2005


Автоматическая установка

CMDLINES.TXT

Применение cmdlines.txt, вероятно, одна из наиболее сложных концепций для понимания. Именно поэтому мы выделили для нее отдельную страницу.

cmdlines.txt располагается в корне директории $OEM$. Во время установки системы команды, содержащиеся в файле cmdlines.txt передаются командному интерпретатору для исполнения. Происходит это за 12 минут до окончания установки Windows (T-12). Ниже приводится пример файла cmdlines.txt

[COMMANDS]
"REGEDIT /S tweaks.reg"
"batch.cmd"

Файл всегда начинается со строки [COMMANDS]. Затем идут команды, которые и будут выполняться. Файл cmdlines.txt обладает ограниченным интерфейсом командной строки. Это означает, что большинство традиционных DOS команд недоступно. Однако, внешние команды (REGEDIT.EXE, REG.EXE, и т.д) можно выполнять.

Добавляя команды нужно помнить о путях. В приведенном примере путей нет, и сейчас станет понятно почему. Если программа, которую вы хотите выполнить, находится в %PATH% (наберите в командной строке echo %PATH%), тогда вам не нужно указывать путь к программе. Путь также не нужен к файлам или программам, расположенным в той же директории, что и cmdlines.txt. Теперь становится ясно, почему в примере нет путей: REGEDIT.EXE находится в %PATH%, а файлы tweaks.reg и batch.cmd лежат в корне $OEM$ (там же, где и cmdlines.txt).

Если файлы находятся в других директориях, то к ним нужно указывать пути. Делается это следующим образом. Допустим, ваш файл находится в $OEM$\Folder\batch.cmd. Тогда путь к нему прописывается как

".\Folder\batch.cmd"

В этом примере .\ указывает путь относительно текущей директории. При исполнении команды путь превратится в %CDROM%\$OEM$\Folder\batch.cmd. Eсли же ваш файл находится в директории, расположенной в корне диска, скажем, %CDROM%\Unattend\batch.cmd, то путь в cmdlines.txt указывается так:

"..\Unattend\batch.cmd"

В этом примере ..\ указывает на родительскую директорию текущей директории. При исполнении команды путь превратится в %CDROM%\Unattend\batch.cmd

Если вы хотите выполнить обычные команды пакетных файлов (PAUSE, TITLE, START), то создайте пакетный файл, который будет вызываться из cmdlines.txt

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 24.02.2005


Автоматическая установка

Локализация: MUI, Шрифты и Региональные настройки

Вопросы о региональных настройках и локализции возникают на форуме Автоматической установки с завидной регулярностью. В принципе, практически вся информация, позволяющая разобраться с проблемой, на страницах сайта предствлена, хотя и не собрана в одном месте. Кроме того, некорректная отработка секции [RegionalSettings] из файла ответов вносит дополнительную неразбериху. В данной статье я постарался собрать как личный опыт, так и опыт участников форума. Я попытаюсь осветить все тонкости локализации и выработать алгоритм применения настроек, срабатывающий на 100%.

Статья разбита на секции, каждая из которых так или иначе относится к локализации. Для каждой секции приводится работающий метод применения настроек. В конце статьи все методы сводятся воедино для выполнения во время автоматической установки системы.

Multilanguage User Interface (MUI) anchor

Если вы работаете с локализованой версией Windows, то можете пропустить эту секцию.

Для локализации элементов интерфейса используется Multilanguage User Interface (MUI). Вообще, он предназначен для корпоративных пользователей и не доступен для загрузки с сайта Microsoft (где выложен только MUI для Windows Embedded, который не подходит для Windows XP). В данном примере рассматривается русский MUI и выбор русского интерфейса, как интерфейса по умолчанию для всех учетных записей, создаваемых впоследствии.

muisetup.exe /i 0419 /d 0419 /l /f /r /s

Ключ /i указывает какой язык выбирается, и соответственно 0419 - русский, а ключ /d назначает язык интерфейса по умолчанию. Полный список ключей, а также значений языков можно найти в файле muisetup.hlp, входящем в комплект поставки MUI.

Важно! Для наиболее полной локализации интерфейса вам нужно взять muisetup.exe от SP2 и заменить им одноименный файл в дистрибутиве MUI. Также, вам могут понадобиться дополнительные пакеты для локализации Справки, Windows Media Player 10 и Windows Movie Maker 2.1.

Если вы хотите, чтобы русский интерфейс был уже при первом входе в систему, то устанавливайте MUI из cmdlines.txt. В противном случае, вы можете произвести установку при первом входе в систему любым удобным вам способом (пакетный файл из GuiRunOnce, RunOnceEx и т.д.). Ниже пример установки русского MUI и его обновлений из cmdlines.txt

[COMMANDS]
".\WinMUI\muisetup.exe /i 0419 /d 0419 /l /f /r /s"
".\WinMUI\WindowsXP-KB841625-x86MUI-RUS.exe /quiet /norestart"
".\WinMUI\MP10Setup_muiRUS.exe /Q"
".\WinMUI\mm21_muirus.exe /Q"

Понятно, что абсолютный путь к файлам на CD должен быть $OEM$\WinMUI\. Подробнее об $ОЕМ$ директориях читайте в соответствующей статье Справочника.

Корректное отображение кириллицы в меню и диалогах ПО anchor

Как было сказано выше, локализация интерфейса ОС осуществляется при помощи MUI. А вот за корректное отображение кириллических шрифтов в меню и диалогах программного обеспечения отвечает параметр SystemLocale файла ответов. Однако, в некоторых программах все равно наблюдается некорректное отображение кириллических символов (также известное как иероглифы или кракозябры ;-). Стандартной рекомендацией является импортирование следующих ключей в реестр:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
1250="c_1251.nls"
1251="c_1251.nls"
1252="c_1251.nls"
1253="c_1251.nls"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
System,0="Arial,204"
Fixedsys,0="Fixedsys,204"
Small Fonts,0="Small Fonts,204"
MS Serif,0="MS Serif,204"
MS Sans Serif,0="MS Sans Serif,204"
Courier,0="Courier New,204"
Arial Cyr,0="Arial,204"
Courier New Cyr,0="Courier New,204"
Times New Roman Cyr,0="Times New Roman,204"
Helv,0="MS Sans Serif,204"
Tms Rmn,0="MS Serif,204"
Arial,0="Arial,204"

Эти настройки являются системными и распространяются на всех пользователей. Вы можете включить их в уже существующий файл hklm.reg (подробнее в статье Твики реестра) или создать отдельный файл для настроек шрифтов, скажем, fonts.reg, который [из личного опыта] лучше импортировать при входе в систему любым удобным вам способом (пакетный файл из GuiRunOnce, RunOnceEx и т.д.).

Языковые и Региональные настройки

Одной из основных причин неразбeрихи с региональными настройками является [частично] некорректная отработка секции [RegionalSettings]. Почему это происходит не знают, похоже, и в Microsoft, т.к. я пока не видел статьи объясняющей причину или по крайней мере признающей проблему. Кроме того, не все региональные настройки могут быть сконфигурированы через файл ответов.

Секция [RegionalSettings] файла ответов anchor

Я рекомендую внимательно изучить параметры секции [RegionalSettings] файла ответов, т.к. ее мы применим другим способом.

[RegionalSettings]
LanguageGroup=1,2,3,4,5
SystemLocale=00000419
UserLocale=00000419
InputLocale=0409:00000409,0419:00000419

Секцию [ReginalSettings] удобно конфигурировать через Setup Manager. Однако, давайте рассмотрим ее детально, т.к. она содержит много параметров и традиционно вызывает вопросы. Ниже я привожу подробные описания параметров, которые взяты из KB289125 (в статье также перечислены и другие параметры).

  • LanguageGroup - Задает поддержку языковой группы операционной системой, установленной на компьютере. Если данная настройка указана, то она определяет также значения настроек InputLocale, SystemLocale и UserLocale. По умолчанию в любом случае устанавливаются первые пять языковых групп из этого списка, так что для поддержки кириллицы данный параметр вообще необязателен.

  • SystemLocale

    System Locale

    Разрешает программам, не использующим кодировку Юникод (Unicode), выполнять работу, выводить меню и диалоговые окна с использованием локализованных языковых символов. Если в локализованной программе некорректно отображаются языковые символы, настройка языка системы по умолчанию с целью обеспечить соответствие языку локализованной программы может разрешить проблему. Однако данная настройка является сетевой, поэтому невозможно одновременно поддерживать версии локализованных программ, не использующих Юникод, на нескольких языках. Значения параметров должны соответствовать списку Locale IDs.

  • UserLocale

    User Locale

    Управляет способом отображения чисел, времени, денежных сумм и дат.

  • InputLocale

    Input Locale

    Задает код раскладки клавиатуры и комбинации раскладок. Если указано несколько языков ввода, первой используемой раскладкой клавиатуры будет являться та, которая определена для данного компьютера по умолчанию (в том числе и при вводе пароля при входе в систему). Указанные комбинации раскладок клавиатуры должны поддерживаться для языков, либо определенных путем использования настройки LanguageGroup, либо для языка по умолчанию для устанавливаемой локализованной версии операционной системы Windows XP. Если для доступного языка не поддерживается указанная комбинация, будет использоваться комбинация раскладки клавиатуры по умолчанию. Данная настройка игнорируется, если задана настройка Language.

Таким образом, в приведенном выше примере будут установлены:

  • LanguageGroup=1,2,3,4,5
    Пять языковых групп: Western Europe and United States, Central Europe, Baltic, Greek и Cyrillic. Строго говоря можно не указывать данный параметр вообще, т.к. группы 1-5 устанавливаются по умолчанию.

  • SystemLocale=00000419
    Русский язык по умолчанию для программ, не использующих Юникод.

  • UserLocale=00000419
    Русские Стандарты и Форматы.

  • InputLocale=0409:00000409,0419:00000419
    Две раскладки клавиатуры: русская и английская. Английская будет раскладкой по умолчанию (в том числе и при входе в систему, т.к. идет первой в списке).

regopts.txt anchor

Как уже было сказано выше, секция [RegionalSettings] не отрабатывает корректно из файла ответов. Точнее, не срабатывают некоторые параметры (UserLocale и InputLocale, если мне не изменяет память), но это не суть важно, т.к. общий итог все равно неудовлетворительный. Существует альтернативный способ конфигурирования региональных настроек, который описан в этой статье MS KB. Вкратце, секция [RegionalSettings] помещается в текстовый файл regopts.txt, а потом выполняется команда

rundll32.exe shell32,Control_RunDLL intl.cpl,,/f:"c:\regopts.txt"

Кoманду лучше выполнять при первом входе в систему, что косвенно и потдверждает примечание в конце статьи MS KB. Конечно, файл regopts.txt не обязательно должен находиться в корне диска C:\. Вы можете изменить путь соответственно расположению файла. Выполнить команду вы можете любым удобным вам способом (пакетный файл из GuiRunOnce, RunOnceEx и т.д.)

Далее в статье этот способ я буду обозначать как "способ regopts.txt".

Раскладка клавиатуры anchor

Наборы раскладкок клавиатуры и их порядок (приоритет) можно задать при помощи способа regopts.txt, а вот способ переключения между раскладками

Key sequence

конфигурируется через реестр. Достаточно настроить желаемый способ на рабочей системе и экспортировать ветку реестра

HKEY_CURRENT_USER\Keyboard Layout\Toggle

Ниже приводится пример ключа, отвечающего за переключение раскладки левым ALT+SHIFT

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Keyboard Layout\Toggle]
"Hotkey"="1"

Приоритет раскладки клавиатуры при входе в систему (Экран приветствия или классический вход) можно задать следующим образом:

[HKEY_CURRENT_USER\Keyboard Layout\Preload]
"1"="00000409"
"2"="00000419"

В данном случае по умолчанию выставляется английская раскладка клавиатуры.

Поскольку раскладка клавиатуры является пользовательской настройкой, вам нужно обеспечить импорт ключа из cmdlines.txt, если вы хотите применить его для всех пользователей. Вы можете включить экспортированные значения в уже существующий файл hkcu.reg (подробнее в статье Твики реестра) или создать отдельный файл для региональных настроек, скажем, regional.reg, который также будет импортироваться из cmdlines.txt.

Расположение (Location) anchor

Это еще один элемент региональных настроек, который надо конфигурировать через реестр.

Location

За настройку элемента отвечает ключ Geo из ветки

HKEY_CURRENT_USER\Control Panel\International\Geo

Например, расположению Россия соответствует

[HKEY_CURRENT_USER\Control Panel\International\Geo]
"Nation"="203"

Поскольку "Расположение" является пользовательской настройкой, вам нужно обеспечить импорт ключа из cmdlines.txt, если вы хотите применить его для всех пользователей. Вы можете включить экспортированные значения в уже существующий файл hkcu.reg (подробнее в статье Твики реестра) или в regional.reg, который вы, возможно, создали для импорта способа переключения клавиатуры.

Сводим все вместе

Итак, подведем итог. Для наиболее полной и корректной локализации нам понадобится:

  • Установить MUI (если ОС не локализована)
  • Обеспечить корректное отображение кириллицы в меню и диалогах ПО
  • Сконфигурировать языковые и региональные настройки и способ раскладки клавиатуры

Как вы уже поняли из прочтения статьи, часть этих настроек устанавливается при помощи файлов, исполняемых из cmdlines.txt, а оставшиеся настройки задаются при первом входе в систему. Пример содержимого cmdlines.txt:

[COMMANDS]
".\WinMUI\muisetup.exe /i 0419 /d 0419 /l /f /r /s"
".\WinMUI\WindowsXP-KB841625-x86MUI-RUS.exe /quiet /norestart"
".\WinMUI\MP10Setup_muiRUS.exe /Q"
".\WinMUI\mm21_muirus.exe /Q"
"REGEDIT /S regional.reg"

Первые четыре команды последовательно устанавливают MUI, а также обновления Справки, Windows Media Player 10 и Windows Movie Maker. Если вы не устанавливаете MUI, то все строки относящиеся к нему вам не нужны. Последняя команда импортирует regional.reg, содержащий способ переключения расклади клавиатуры и настройки Расположения. Альтернативно, можно включить содержимое regional.reg в состав hkcu.reg, если у вас таковой имеется. Все перечисленные в файле cmdlines.txt команды будут выполнены за 12 минут до окончания установки ОС.

Далее, при первом входе в систему нужно применить "способ regopts.txt" и импортировать настройки кодовой страницы и шрифтов для корректного отображения кириллицы в ПО. Я приведу пример пакетного файла regional.bat, который и совершит нужные действия:

@echo off
REGEDIT /S c:\fonts.reg
rundll32.exe shell32,Control_RunDLL intl.cpl,,/f:"c:\regopts.txt"
exit

В данном примере файлы fonts.reg и regopts.txt должны находиться в корне диска C:\, однако вы можете разместить их где угодно при помощи $OEM$ директорий и изменить пути соответственно.

Надеюсь, данная статья будет вам полезна и поможет обойти подводные камни, препятствующие успешной локализации с первого захода.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 11.09.05

© Все права защищены OSzone.net 2001-2006

Распечатано 11.09.05


Автоматическая установка

Сжатые файлы и ModifyPE

Если вам понадобится модифицировать системные файлы, то вы с большой вероятностью столкнетесь с тем, что в дистрибутиве они находится в сжатом виде. Вам надо будет их распаковать, модифицировать и снова запаковать (сжать). Даже если вы успешно отредактируете и сожмете файлы, вы можете получить ошибку копирования во время установки системы.

Expand распаковывает сжатые файлы, восстанавливая их оригинальную форму.

Makecab перепакует измененные файлы или любые файлы, которые вы заходите добавить в дистрибутив. При этом расширение файлов изменится соответствующим образом (например, с *.dll на *.dl_). Кроме того makecab сжимает файлы, уменьшая их размер.

Утилита ModifyPE исправит контрольную сумму модифицированных файлов и предотвратит ошибку "File was not copied correctly" во время инсталляции системы.

Если работа с командной строкой для вас не в новинку, то можете пропустить следующий параграф и перейти к непосредственно сути статьи.

Expand | Makecab | ModifyPE

Отступление о работе с командной строкой

Мы будем работать с командной строкой. Если запускать ее обычным методом (Пуск | Выполнить | cmd), то придется в ней печатать полный путь к директории, в которой расположены модифицируемые или упаковываемые файлы. В файловых менеджерах FAR и TotalCommander встроенная командная строка вызывается из текущей директории, избавляя пользователя от необходимости печатать пути к файлам.. Если же вы пользуетесь Проводником, то можно добавить вызов командной строки в контекстное меню папки. Достаточно скопировать приведенный ниже текст в Блокнот, сохранить файл с любым именем, но расширением *.REG и запустить. В контекстном меню папки появится опция "Command Prompt".

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Command Prompt]
@="Command Prompt"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\Command Prompt\command]
@="Cmd.exe /k pushd %L"

Если вы хотите назвать опцию иначе, то замените везде "Command Prompt" на ваше название.

Expand

Expand - стандартная команда Windows XP. Запустите командную строку и перейдите к папке, в которой расположен упаковываемый файл. Напечатайте команду

expand.exe -r filename.xxХ

где filename.xxx - имя вашего файла. В примере на скриншоте распаковывается файл C:\winntbbu.dl_.

Если вы все сделали правильно, то вы увидите такое же сообщение, как на скриншоте. Ваш новый файл будет расположен в той же директории, что и старый. Он будет иметь такое же имя, и полное расширение.

Makecab

Makecab, как и makecab, тоже является стандартной командой Windows XP. Запустите командную строку и перейдите к папке, в которой расположен упаковываемый файл. Напечатайте команду

makecab.exe filename.xxx

где filename.xxx - имя вашего файла. В примере на скриншоте упаковывается файл C:\winntbbu.dll.

Если вы все сделали правильно, то вы увидите такое же сообщение, как на скриншоте. Ваш новый файл будет расположен в той же директории, что и старый. Он будет иметь такое же имя, за исключеним последней буквы расширения, которая будет заменена на _.

ModifyPE

Для начала скачайте ModifyPE отсюда. Теперь встает вопрос куда распаковать исполняемый файл из архива. Можно куда угодно, но рекомендую в директорию %windir%\System32, тогда не надо будет указывать путь к утилите при работе с командной строкой.

Работать с утилитой просто. Запустите командную строку и перейдите к папке, в которой расположен модифицируемый файл. Напечатайте команду

modifype.exe filename.xxx -c

где filename.xxx - имя вашего файла. В примере на скриншоте модифицируется файл C:\winntbbu.dll.

Если вы все сделали правильно, то вы увидите такое же сообщение, как на скриншоте.

Автор: Vadikan
Иcточник: (переведено с английского) unattended.msfn.org

Наш форум

Опубликована- 05.03.2005


Автоматическая установка

Создание SFX архива

Нередко при работе над автоматической установкой приложений возникает необходимость создать безключевой самораспаковывающийся архив (в дальнейшем я буду использовать "SFX", так короче). Как правило, SFX архивы позволяют значительно сэкономить место на CD. Например, если приложение не требует установки, то его можно поместить в $OEM$\Progs и оно будет автоматически скопировано в Program Files. Однако, аналогичной цели можно достичь запаковав приложение в SFX, который распакует содержимое в нужную директорию.

Область применения SFX не ограничивается приложениями, не требующими установки. Можно без проблем упаковать приложение, запакованное одним из распространенных инсталляторов и сконфигурировать SFX таким образом, что после распаковки будет запущена инсталляция приложения с нужными ключами. Еще одним преимуществом SFX архивов является то, что в некоторых случаях они дают возможность не просто автоматизировать, но и полностью скрыть процесс и прогресс инстялляции от конечного пользователя. Для примера рассматривается упаковка Adobe Reader 7.0. Несмотря на то, что с относительно недавних пор приложение можно устанавливать с соответствующими ключами без особых проблем, только SFX позволяет установить приложение абсолютно незаметно.

Подготовка к созданию SFX

Вне зависимости от того, что вы будете использовать для создания SFX, различий в подготовке не будет. Если вы просто хотите запаковать директорию с файлами, то никакой подготовки не требуется. А вот приложения иногда приходится распаковывать. В случае с Adobe Reader 7 используется Install Shield с Basic MSI, причем все это еще и запаковано в некий FEAD Optimizer. Надо запустить исполняемый файл Adobe, дождаться пока FEAD Optimizer закончит распаковку и найти директорию с файлом Adobe Reader 7.0.msi (она может быть в %ProgramFiles%\Adobe, например). Теперь нужно запустить файл setup.exe с ключом /a для создания административной установки. В появившемся диалоговом окне нужно указать директорию, в которой по окончани и будут находиться все нужные нам файлы. Теперь можно переименовать Adobe Reader 7.0.msi в, скажем, Adobe7.msi и приступать к упаковке в SFX архив. Мы рассмотрим создание SFX архивов при помощи

WinRAR | 7-Zip

WinRAR

WinRAR - не нуждающийся в представлении архиватор. Он обладает широкими возможностями для создания безключевых SFX. С его помощью можно создать незаметный (silent) инсталлятор, который распакует содержимое SFX в заданую директорию, выполнит заранее указанную команду, а по окончании установки может удалить распакованные файлы. Помимо всего WinRAR умеет добавлять элементы в меню Пуск, помещать ярлыки на Рабочий стол, а также задавать архиву иконку по вашему выбору. Я рассмотрю только базовые возможности программы, а с остальными вы без труда разберетесь при помощи справки.

Итак, запустив архиватор, мы переходим в директорию, в которой находится административная установка Adobe. Выделяем все файлы

и жмем Добавить

Именуем архив по желанию, отмечаем создание SFX и выбираем максимальный уровень сжатия. Теперь надо сконфигурировать параметры SFX. Для этого на закладке Дополнительно жмем Параметры SFX.

На закладке Общие указываем команду для распаковки

и переходим на закладку Режимы:

Здесь мы указываем распаковку во временную папку (что повлечет за собой автоматическое удаление распакованных файлов по окончании инсталляции), скрытый режим и перезапись всех файлов.

Перейдя на закладку Комментарий мы видим все параметры, которые только что сконфигурировали через графический интерфейс. В принципе, можно было сразу перейти на эту закладку и напечатать комментарий вручную или загрузить из заранее подготовленного текстового файла.

Примечание: поскольку мы запаковываем приложение, имеющее собственный инсталлятор, то распаковка во временную директорию вполне оправдана (параметр TempMode). Если же вы просто хотите распаковать файлы в нужную вам директорию, то на закладке Общие нужно указать путь (можно использовать системные переменные), и соответственно, не использовать TempMode.

Вот и все. Теперь осталось нажать ОК пару раз и спустя некоторое время у нас будет SFX, который совершенно незаметно установит Acrobat Reader.

Преимущества: абсолютно незаметная (silent) установка, возможность распаковки файлов в заданную директорию, возможность добавления элементов в меню Пуск и ярлыков на рабочий стол, выбор иконки для архива.
Недостатки: стоит $30.

7-zip

7-zip - бесплатный архиватор, распространяющийся по лицензии GNU LGPL. Если вы с ним не знакомы, то более подробную информацию вы найдете на сайте 7-zip. С его помощью можно создавать безключевые SFX, хотя процесс их создания несколько длиннее, чем у WinRAR.

Для начала нужно запаковать содержимое нашей директории в 7-zip архив. Сделать это можно через 7-zip файл-медеждер. Запустив его, мы переходим в директорию, в которой находится административная установка Adobe. В эту же директорию нужно положить файл StartX.exe (его назначение я объясню ниже). Выделяем все файлы

и жмем Добавить

Именуем архив по желанию (скажем, Adobe7.7z), выбираем формат 7-zip, максимальный уровень сжатия и жмем ОК. На выходе получаем файл Adobe7.7z, из которого нам предстоит сделать SFX.

Теперь нужно создать конфигурационный файл для SFX. Его можно сделать в Блокноте. Единственное, но обязательное условие - он должен быть в кодировке UTF-8. В нашем случае он будет выглядеть так:

;!@Install@!UTF-8!
RunProgram="StartX.exe /WAIT \"msiexec /i Adobe7.msi /qn\""
;!@InstallEnd@!

Выглядит сложно, но сейчас все прояснится. Первая и последние строки просто обозначают начало и конец конфигурационного файла. Средняя строка - команда, которая будет выполнена после распаковки архива. Непосредственно команда заключается в кавычки и помещается после RunProgram=. Утилита StartX.exe является эквивалентом консольной команды START и поддерживает такие же ключи. Ее наличие необходимо для установки MSI пакета, извлеченного из 7-zip SFX. Если попытаться сделать нечто вроде RunProgram="Adobe7.msi /qn", то запуск завершится ошибкой. Два обратных слэша (\) просто предваряют кавычки, находящиеся внутри команды.

Сохраняем конфигурационный файл с именем config.txt в ту же директорию, где Adobe7.7z, и переходим к завершающей стадии создания SFX.

Из инсталляционной директории 7-zip нужно взять SFX модуль 7zS.sfx и скопировать его к файлам Adobe7.7z и config.txt. Рекомендую сжать модуль утилитой UPX. Это уменьшит размер модуля примерно со 131 кб до 58 кб. Делается это командой

upx --best 7zS.sfx

Достаточно это сделать один раз, и можно использовать сжатый модуль в дальнейшем.

Теперь, когда в одной директории собраны все три файла (adobe7.7z, config.txt и 7zS.sfx), нужно из командной строки выполнить следующую команду

COPY /b 7zs.sfx + config.txt + adobe7.7z adobe7.exe

Через мгновение в директории появится файл adobe7.exe. Это и есть наш SFX. Его запуск инициирует распаковку архива во временную директорию, запуск команды из конфигурационного файла, и удаление распакованных файлов по окончании инсталляции.

Модифицированный SFX модуль для 7-zip

Оригинальный 7-zip SFX модуль не дает возможности сделать распаковку абсолютно незаметной. В процессе распаковки пользователь видит вот такое окошко

и даже может прервать инсталляцию нажатием на кнопку Cancel. Этой проблемы можно избежать, воспользовавшись SFX модулем, который модифицировал участник конференции OSZone Oleg_Sch. Вы можете загрузить модицифированный и сжатый UPX модуль отсюда (114 kb) или со страницы автора, где вы также найдете несжатый модуль и исходный код. В архив входит oчень подробный Readme файл, описывающий все новые функции и примеры использования (там много интересного). Так что на этой странице я ограничусь лишь примером конфигурационного файла, который полностью скроет диалоговое окно распаковки.

;!@Install@!UTF-8!
RunProgram="StartX.exe /WAIT \"msiexec /i Adobe7.msi /qn\""
GUIMode="2"
;!@InstallEnd@!

Вообще-то, для модифицированного модуля утилита StartX не нужна, и можно было бы обойтись RunProgram="Adobe7.msi /qn".

---

Любопытно, что в данном случае 7-zip продемонстрировал лучшее сжатие, чем WinRAR. Размер 7-zip SFX (даже с утилитой StartX.exe) оказался 20893 кб против 23825 кб у WinRAR SFX. Oднако, недостатком родного SFX модуля 7-zip является невозможность сконфигурировать безключевую распаковку SFX в заданную директорию. Модифицированный модуль от Oleg_Sch, позволяет указать директорию распаковки в конфигурационном файле и избавляет 7-zip от данного недостатка.

Преимущества: бесплатен, высокая степень сжатия; а с модифицированным SFX модулем доступны абсолютно незаметная (silent) установка и возможность распаковки файлов в заданную директорию, добавление элементов в меню Пуск и ярлыков на рабочий стол, а также многие другие функции.
Недостатки: нет возможности выбора иконки для архива (планируется исправить в будущих версиях модифицированного модуля Олега).

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 27.03.2005


Автоматическая установка

Примеры

На этой странице вы найдете примеры файлов, используемых при создании CD для автоматической установки Windows. Все примеры мои, за исключением start.cmd. Не копируйте файлы вслепую, т.к. пути к приложениям и пакетным файлам могут сильно отличаться. Также, далеко не все изменения в реестре подойдут вам. Используйте файлы исключительно для сравнения со своими.

Winnt.sif (мой вариант)

;SetupMgrTag
[Data]
Autopartition=0
MsDosInitiated="0"
UnattendedInstall="Yes"
AutomaticUpdates=Yes

[Unattended]
UnattendMode=FullUnattended
OemSkipEulA=Yes
OemPreinstall=Yes
TargetPath=\WINDOWS
Repartition=No
Unattendswitch="Yes"
WaitForReboot="No"
AutoActivate = No
Hibernation = No

[GuiUnattended]
AdminPassword="mypassowrd"
EncryptedAdminPassword=No
AutoLogon=Yes
AutoLogonCount=2
OEMSkipRegional=1
TimeZone=40
OemSkipWelcome=1

[Display]
BitsPerPel=32
XResolution=1152
YResolution=864
Vrefresh=85

[UserData]
ProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
FullName=Vadik
OrgName=Home
ComputerName=VAD

[TapiLocation]
CountryCode=1
AreaCode=317

[RegionalSettings]
LanguageGroup=1,2,3,4,5
SystemLocale=00000419
UserLocale=00000409
InputLocale=0409:00000409,0419:00000419

[Identification]
JoinWorkgroup=WORKGROUP

[Networking]
InstallDefaultComponents=Yes

[Components]
msmsgs=Off
msnexplr=Off
freecell=Off
hearts=Off
minesweeper=Off
pinball=Off
solitaire=Off
spider=Off
zonegames=Off

[Shell]
CustomDefaultThemeFile="%Systemroot%\Resources\Themes\ninja.theme"

start.cmd (до того как автор перешел на RunOnceEx способ)

CLS
@echo off
TITLE Windows XP SP1 - Unattended Installation

ECHO.
ECHO Over the next few minutes you will see automated installations
ECHO of various sofware applications, windows updates, and registry
ECHO tweaks being implemented. The computer will restart automatically
ECHO once the whole process has finished!

ECHO.
ECHO Removing Wallpapers and Screensavers...
DEL "%systemroot%\*.bmp"
DEL "%systemroot%\Web\Wallpaper\*.jpg"
DEL "%systemroot%\system32\dllcache\*.scr"
DEL "%systemroot%\system32\*.scr"

ECHO.
ECHO Removing useless shortcuts...
DEL "%systemdrive%\Documents and Settings\All Users\Start Menu\Windows Update.lnk"
DEL "%systemdrive%\Documents and Settings\All Users\Start Menu\Set Program Access and Defaults.lnk"
DEL "%systemdrive%\Documents and Settings\All Users\Start Menu\Windows Catalog.lnk"

ECHO.
ECHO Installing MSN Messenger 6.0.0602 Final
ECHO Please wait...
start /wait %systemdrive%\install\MSN\MsnMsgs.msi /qn

ECHO.
ECHO Installing TweakUI 2.10 Powertoy
ECHO Please wait...
start /wait %systemdrive%\install\Powertoys\TweakUI.msi /qn

ECHO.
ECHO Installing Task Switcher Powertoy
ECHO Please wait...
start /wait %systemdrive%\install\PowerToys\TaskswitchPowertoySetup.exe /s /v/qn

ECHO.
ECHO Applying Registry Tweaks...
REGEDIT /S %systemdrive%\install\RegTweaks.reg

ECHO.
ECHO Deleting ASP.NET User Account created by .NET Framework 1.1...
net user aspnet /delete

ECHO.
ECHO Starting installation of Applications

ECHO.
ECHO Installing Diskeeper 7.0.428
ECHO Please wait...
start /wait %systemdrive%\install\Applications\diskeeper\Setup.exe /s /v/qn

ECHO.
ECHO Installing Flashget 1.4
ECHO Please wait...
start /wait %systemdrive%\install\Applications\flashget\fgf140.exe /S

ECHO.
ECHO Registering Flashget 1.4...
REGEDIT /S %systemdrive%\install\Applications\flashget\register.reg

ECHO.
ECHO Installing Kerio Personal Firewall 2.1.5
ECHO Please wait...
start /wait %systemdrive%\install\Applications\kpf\Setup.exe -s

ECHO.
ECHO Registering Nero Burning ROM...
REGEDIT /S %systemdrive%\install\Applications\Nero\register.reg

ECHO.
ECHO Installing Nero Burning ROM v5.5.10.42
ECHO Please wait...
start /wait %systemdrive%\install\Applications\Nero\Nero551042.exe /silent /noreboot

ECHO.
ECHO Installing Symantec Antivirus Corporate 8.1
ECHO Please wait...
start /wait %systemdrive%\install\Applications\sav\sav810b821.exe /qn

ECHO.
ECHO Updating Symantec Antivirus Virus Definitions (May 14th 2003)...
COPY "%systemdrive%\install\Applications\sav\vd155c08.xdb.xdb" "%systemdrive%\Documents and Settings\All Users\Application Data\Symantec\Norton AntiVirus Corporate Edition\7.5\"

ECHO.
ECHO Restarting the PC in 1 minute...
shutdown.exe -r -f -t 60 -c "Windows XP will now restart in 1 minute, this will give enough time for the shortcuts to update and for the shell to fully load before its ready to restart!"

ECHO.
ECHO Deleting Temp Installation Files...
RD /S /Q %systemdrive%\Drivers
RD /S /Q %systemdrive%\install

EXIT

RunOnceEx.cmd

(* в названии приложения означает специально перепакованный SFX архив)

cmdow @ /HID
@echo off

FOR %%d IN (c d e f g h i j k l m n o p q r s t u v w x y z) DO IF EXIST %%d:\CD.txt SET CDROM=%%d:

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY% /V TITLE /D "Installing Applications" /f

REG ADD %KEY%\001 /VE /D "Preparing Installation" /f
REG ADD %KEY%\001 /V 1 /D "%systemdrive%\install\prepare.cmd" /f

REG ADD %KEY%\005 /VE /D "Phonetic Keyboard*" /f
REG ADD %KEY%\005 /V 1 /D "%CDROM%\Software\phonkbd.exe" /f

REG ADD %KEY%\010 /VE /D "FlashFXP*" /f
REG ADD %KEY%\010 /V 1 /D "%CDROM%\Software\FlashFXP.exe" /f

REG ADD %KEY%\015 /VE /D "Macromedia FlashPlayer" /f
REG ADD %KEY%\015 /V 1 /D "%CDROM%\Software\flashplayer7.exe /q" /f

REG ADD %KEY%\020 /VE /D "Macromedia ShockwavePlayer" /f
REG ADD %KEY%\020 /V 1 /D "%CDROM%\Software\Shockwave.exe /SILENT" /f

REG ADD %KEY%\025 /VE /D "WinRAR 3.30" /f
REG ADD %KEY%\025 /V 1 /D "%CDROM%\Software\wrar330ru.exe /s" /f
REG ADD %KEY%\025 /V 2 /D "REGEDIT /S \"%CDROM%\Software\rar_set.reg\"" /f

REG ADD %KEY%\030 /VE /D "Daemon Tools" /f
REG ADD %KEY%\030 /V 1 /D "%CDROM%\Software\daemon346.msi Reboot=ReallySuppress /qn" /f

REG ADD %KEY%\035 /VE /D "TweakUI" /f
REG ADD %KEY%\035 /V 1 /D "%CDROM%\Software\TweakUI.msi /qb" /f

REG ADD %KEY%\040 /VE /D "Nero 6.3.1.20" /f
REG ADD %KEY%\040 /V 1 /D "REGEDIT /S \"%CDROM%\Software\register_nero.reg\"" /f
REG ADD %KEY%\040 /V 2 /D "%CDROM%\Software\nero63120.exe /silent /noreboot /no_ui" /f

REG ADD %KEY%\045 /VE /D "Adobe Reader*" /f
REG ADD %KEY%\045 /V 1 /D "%CDROM%\Software\adobe6.exe" /f

REG ADD %KEY%\050 /VE /D "Light Alloy 2.6*" /f
REG ADD %KEY%\050 /V 1 /D "%CDROM%\Software\LAlloy.exe" /f

REG ADD %KEY%\055 /VE /D "TotalCommander 6.02*" /f
REG ADD %KEY%\055 /V 1 /D "%CDROM%\Software\tcmdr602.exe" /f

REG ADD %KEY%\060 /VE /D "DVD Decrypter" /f
REG ADD %KEY%\060 /V 1 /D "%CDROM%\Software\DVDDecrypter.exe /S" /f

REG ADD %KEY%\070 /VE /D "Opera 7.5" /f
REG ADD %KEY%\070 /V 1 /D "%CDROM%\Software\opera754_3869.exe /s" /f

REG ADD %KEY%\075 /VE /D "WMP 10" /f
REG ADD %KEY%\075 /V 1 /D "%CDROM%\Software\mp10setup.exe /q:A /c:\"setup_wm.exe /Q /R:N /DisallowSystemRestore\"" /f

REG ADD %KEY%\080 /VE /D "Office 2003" /f
REG ADD %KEY%\080 /V 1 /D "%CDROM%\Software\Office2k3\setuppro.exe /QN TRANSFORMS=my.MST" /f

REG ADD %KEY%\085 /VE /D "Java VM" /f
REG ADD %KEY%\085 /V 1 /D "%CDROM%\Software\java142.exe /s /v/qn" /f

REG ADD %KEY%\090 /VE /D "Symantec AV CE 8.1" /f
REG ADD %KEY%\090 /V 1 /D "%CDROM%\Software\savceclt.exe /qn
REG ADD %KEY%\090 /V 2 /D "%CDROM%\Software\update.exe /q" /f

REG ADD %KEY%\095 /VE /D ".NET Framework 1.1 SP1*" /f
REG ADD %KEY%\095 /V 1 /D "%CDROM%\Software\netfxsp1.exe" /f

REG ADD %KEY%\100 /VE /D "Cleaning Up and Rebooting" /f
REG ADD %KEY%\100 /V 1 /D "%systemdrive%\install\cleanup.cmd" /f

EXIT

prepare.cmd

cmdow @ /HID
@echo off

attrib -r "%programfiles%\cdex\*.*" /s
attrib -r "%programfiles%\Edialer\*.*" /s
attrib -r "%programfiles%\IrfanView\*.*" /s
attrib -r "%programfiles%\Opera75\*.*" /s
attrib -r "%programfiles%\Proxomitron\*.*" /s
attrib -r "%programfiles%\Winamp\*.*" /s

DEL "%systemroot%\*.bmp"
DEL "%systemroot%\Web\Wallpaper\*.jpg"
DEL "%systemroot%\system32\*.scr"

DEL "%AllUsersProfile%\Start Menu\Windows Update.lnk"
DEL "%AllUsersProfile%\Start Menu\Set Program Access and Defaults.lnk"
DEL "%AllUsersProfile%\Start Menu\Windows Catalog.lnk"

regsvr32 /u /s zipfldr.dll

EXIT

cleanup.cmd

cmdow @ /HID
@echo off

shutdown.exe -r -f -t 20 -c "Don`t panic. The system will reboot in 20 seconds."

DEL "%AllUsersProfile%\Desktop\Java Web Start.lnk"
DEL "%AllUsersProfile%\Desktop\Adobe Reader 6.0.lnk"
DEL "%AllUsersProfile%\Desktop\DVD Decrypter.lnk"
DEL "%AllUsersProfile%\Desktop\Nero StartSmart.lnk"
move "%allusersprofile%\Desktop\Daemon Tools.lnk" "%allusersprofile%\Start Menu\Programs"
RD /S /Q "%AllUsersProfile%\Start Menu\Programs\PrintMe Internet Printing"
RD /S /Q "%AllUsersProfile%\Start Menu\Programs\Java Web Start"
xcopy "%systemdrive%\install\TC\wincmd.ini" "%programfiles%\TotalCmd\*.*" /y /q /s

net user aspnet /delete

EXIT

HKLM.reg

Windows Registry Editor Version 5.00
;-----------------------
;Оптимизация операционной системы
;-----------------------

;Отключить автоматическую перезагрузку в случае BSOD
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
"AutoReboot"=dword:00000000

;Ускорить выключение компьютера
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
"WaitToKillServiceTimeout"="3000"

;Отключить сообщения об ошибках, но оставить уведомление о критических ошибках
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting]
"DoReport"=dword:00000000

;Не использовать простое распределение файлов (simple file sharing)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"forceguest"=dword:00000000

;Ускорить работу с сетевыми дисками, убирая запланированные сетевые задания (Network Scheduling Tasks)
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}]

;Убрать стрелки у ярлыков
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons]
"29"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,74,00,\
  25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,\
  00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,35,00,30,00,\
  00,00

;Отключить приглашение на Тур по Windows
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Applets\Tour]
"RunCount"=dword:00000000

;Отключить восстановление системы
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore]
"DisableSR"=dword:00000001

;Корзина использует 3% от доступного места на диске (не 10%)
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\BitBucket]
"Percent"=dword:00000003

;Отключить автоматические обновления системы
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoUpdate"=dword:00000001

;Отключить автоматические обновления системы
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
"AUOptions"=dword:00000001
"AUState"=dword:00000007

;---------------
;Оптимизация служб
;---------------

;Отключить службу Messenger (останавливает спам. не влияет на MSN or Windows Messenger)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Messenger]
"Start"=dword:00000004

;Отключить удаленный доступ к реестру
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteRegistry]
"Start"=dword:00000004

;Отключить поддержку источника бесперебойного питания
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UPS]
"Start"=dword:00000004

;Отключить восстановление системы
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\srservice]
"Start"=dword:00000004

;Отключить индексирование
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CiSvc]
"Start"=dword:00000004

;Отключить беспроводную конфигурацию
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WZCSVC]
"Start"=dword:00000004

;Отключить Smart Card Helper
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SCardDrv"]
"Start"=dword:00000004

;Disable Portable Media Serial Number (хм, даже не знаю как перевести эту глупость :)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WmdmPmSN"]
"Start"=dword:00000004

;Отключить удаленный рабочий стол
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RDSessMgr"]
"Start"=dword:00000004

;Отключить службу записи на оптические носители (IMAPI, нужна только для встроенной в XР записи)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ImapiService]
"Start"=dword:00000004

;----------------------------------------------
;Оптимизация функциональности Windows
;----------------------------------------------

;Убрать Общие Документы из Мой Компьютер
[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\DelegateFolders\{59031a47-3f72-44a7-89c5-5595fe6b30ee}]

;Позволить переименовывать Корзину
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]
"Attributes"=hex:50,01,00,20
"CallForAttributes"=dword:00000000

;Отображать Админстрирование в Панели управления
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{D20EA4E1-3957-11d2-A40B-0C5020524153}]
@="Administrative Tools"

;Не группировать сходные приложения в панели задач
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"TaskbarGlomming"=dword:00000000

;Отключить поиск в сети Интернет при открытии файла с неизвестными расширением
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system]
"NoInternetOpenWith "=dword:00000001

HKCU.reg

Windows Registry Editor Version 5.00
;-----------------------
;Оптимизация операционной системы
;-----------------------

;Убрать автоматический поиск сетевых папок и принтеров
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"NoNetCrawling"=dword:00000001

;Отключить Помощника очистки рабочего стола (Desktop Cleanup Wizard)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Desktop\CleanupWiz]
"NoRun"=dword:00000001

;----------------------------------------------
;Оптимизация функциональности Windows
;----------------------------------------------

;Отключить проверку недостатка места на диске
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoLowDiskSpaceChecks"=dword:00000001

;Ускорить меню Пуск
[HKEY_CURRENT_USER\Control Panel\Desktop]
"MenuShowDelay"="2"

;Отключить все всплывающие уведомления в трее (в том числе и об установке Интернет соединения)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"EnableBalloonTips"=dword:00000000

;Отключить меню Недавние Документы в меню Пуск
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoRecentDocsMenu"=hex:01,00,00,00

;Отключить Недавние Документы
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoRecentDocsHistory"=dword:00000001

;Отключить "Ярлык для" при создании новых ярлыков
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

;Убрать ярлык "Программы по умолчанию" из меню Пуск
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoSMConfigurePrograms"=dword:00000001

;Отключить уведомление о новых программах в меню Пуск (выделение цветом)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"Start_NotifyNewApps"=dword:00000000

;Enable QuickLaunch
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams\Desktop]
"TaskbarWinXP"=hex:0c,00,00,00,08,00,00,00,03,00,00,00,00,00,00,00,b0,e2,2b,d8,\
  64,57,d0,11,a9,6e,00,c0,4f,d7,05,a2,22,00,1c,00,0a,11,00,00,1a,00,00,00,01,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,4c,00,00,00,01,14,02,00,00,00,\
  00,00,c0,00,00,00,00,00,00,46,81,00,00,00,11,00,00,00,10,52,28,ce,e8,c8,c4,\
  01,10,3d,a2,c6,27,d0,c4,01,80,d9,44,28,27,d0,c4,01,00,00,00,00,00,00,00,00,\
  01,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,01,02,14,00,1f,50,e0,4f,d0,\
  20,ea,3a,69,10,a2,d8,08,00,2b,30,30,9d,19,00,2f,43,3a,5c,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,5c,00,31,00,00,00,00,00,6c,31,96,96,\
  10,00,44,4f,43,55,4d,45,7e,31,00,00,44,00,03,00,04,00,ef,be,67,31,67,7a,75,\
  31,80,9b,14,00,00,00,44,00,6f,00,63,00,75,00,6d,00,65,00,6e,00,74,00,73,00,\
  20,00,61,00,6e,00,64,00,20,00,53,00,65,00,74,00,74,00,69,00,6e,00,67,00,73,\
  00,00,00,18,00,36,00,31,00,00,00,00,00,6c,31,97,96,10,00,56,61,64,69,6b,00,\
  22,00,03,00,04,00,ef,be,6c,31,96,96,75,31,86,9b,14,00,00,00,56,00,61,00,64,\
  00,69,00,6b,00,00,00,14,00,64,00,31,00,00,00,00,00,72,31,72,34,13,00,41,50,\
  50,4c,49,43,7e,31,00,00,4c,00,03,00,04,00,ef,be,6c,31,96,96,75,31,87,9b,14,\
  00,36,00,41,00,70,00,70,00,6c,00,69,00,63,00,61,00,74,00,69,00,6f,00,6e,00,\
  20,00,44,00,61,00,74,00,61,00,00,00,40,73,68,65,6c,6c,33,32,2e,64,6c,6c,2c,\
  2d,32,31,37,36,35,00,18,00,42,00,31,00,00,00,00,00,6c,31,97,96,14,00,4d,49,\
  43,52,4f,53,7e,31,00,00,2a,00,03,00,04,00,ef,be,6c,31,96,96,6c,31,99,96,14,\
  00,00,00,4d,00,69,00,63,00,72,00,6f,00,73,00,6f,00,66,00,74,00,00,00,18,00,\
  52,00,31,00,00,00,00,00,6c,31,9a,96,10,00,49,4e,54,45,52,4e,7e,31,00,00,3a,\
  00,03,00,04,00,ef,be,6c,31,96,96,6c,31,9c,96,14,00,00,00,49,00,6e,00,74,00,\
  65,00,72,00,6e,00,65,00,74,00,20,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,\
  00,72,00,00,00,18,00,48,00,31,00,00,00,00,00,6c,31,9c,96,11,00,51,55,49,43,\
  4b,4c,7e,31,00,00,30,00,03,00,04,00,ef,be,6c,31,99,96,6c,31,9c,96,14,00,00,\
  00,51,00,75,00,69,00,63,00,6b,00,20,00,4c,00,61,00,75,00,6e,00,63,00,68,00,\
  00,00,18,00,00,00,60,00,00,00,03,00,00,a0,58,00,00,00,00,00,00,00,76,61,64,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,2c,7c,fa,da,b6,41,5f,44,ad,b6,c9,12,\
  99,70,2f,0a,b6,c1,df,66,dc,34,d9,11,b4,b3,be,8b,67,44,fb,1e,2c,7c,fa,da,b6,\
  41,5f,44,ad,b6,c9,12,99,70,2f,0a,b6,c1,df,66,dc,34,d9,11,b4,b3,be,8b,67,44,\
  fb,1e,10,00,00,00,05,00,00,a0,1a,00,00,00,23,01,00,00,00,00,00,00,08,00,00,\
  00,02,00,00,00,46,03,00,00,01,00,00,00,08,00,00,00,60,00,00,00,02,00,00,00,\
  52,00,32,00,60,02,00,00,67,31,e3,a9,20,00,45,44,49,41,4c,45,7e,31,2e,4c,4e,\
  4b,00,00,36,00,03,00,04,00,ef,be,6c,31,37,99,75,31,50,bc,14,00,00,00,45,00,\
  44,00,69,00,61,00,6c,00,65,00,72,00,2e,00,65,00,78,00,65,00,2e,00,6c,00,6e,\
  00,6b,00,00,00,1c,00,00,00,00,00,00,00,a0,00,00,00,05,00,00,00,92,00,32,00,\
  0b,03,00,00,6c,31,9d,96,20,00,4c,41,55,4e,43,48,7e,31,2e,4c,4e,4b,00,00,76,\
  00,03,00,04,00,ef,be,6c,31,99,96,76,31,d2,00,14,00,5e,00,4c,00,61,00,75,00,\
  6e,00,63,00,68,00,20,00,49,00,6e,00,74,00,65,00,72,00,6e,00,65,00,74,00,20,\
  00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,20,00,42,00,72,00,6f,00,\
  77,00,73,00,65,00,72,00,2e,00,6c,00,6e,00,6b,00,00,00,40,78,70,73,70,31,72,\
  65,73,2e,64,6c,6c,2c,2d,31,31,30,30,33,00,00,1c,00,00,00,00,00,00,00,5e,00,\
  00,00,06,00,00,00,50,00,32,00,cf,02,00,00,6d,31,24,24,20,00,4d,49,52,41,4e,\
  44,7e,31,2e,4c,4e,4b,00,00,34,00,03,00,04,00,ef,be,6d,31,24,24,76,31,d2,00,\
  14,00,00,00,4d,00,69,00,72,00,61,00,6e,00,64,00,61,00,20,00,49,00,4d,00,2e,\
  00,6c,00,6e,00,6b,00,00,00,1c,00,00,00,00,00,00,00,50,00,00,00,03,00,00,00,\
  42,00,32,00,8a,02,00,00,67,31,ad,a5,20,00,4f,70,65,72,61,2e,6c,6e,6b,00,2a,\
  00,03,00,04,00,ef,be,6c,31,49,98,75,31,50,bc,14,00,00,00,4f,00,70,00,65,00,\
  72,00,61,00,2e,00,6c,00,6e,00,6b,00,00,00,18,00,00,00,00,00,00,00,76,00,00,\
  00,00,00,00,00,68,00,32,00,4f,00,00,00,6c,31,9c,96,20,00,53,48,4f,57,44,45,\
  7e,31,2e,53,43,46,00,00,4c,00,03,00,04,00,ef,be,6c,31,9c,96,75,31,50,bc,14,\
  00,36,00,53,00,68,00,6f,00,77,00,20,00,44,00,65,00,73,00,6b,00,74,00,6f,00,\
  70,00,2e,00,73,00,63,00,66,00,00,00,40,78,70,73,70,32,72,65,73,2e,64,6c,6c,\
  2c,2d,36,31,30,30,00,1c,00,00,00,00,00,00,00,5a,00,00,00,07,00,00,00,4c,00,\
  32,00,bc,02,00,00,6f,31,8d,1c,20,00,53,4e,41,47,49,54,7e,31,2e,4c,4e,4b,00,\
  00,30,00,03,00,04,00,ef,be,6f,31,8d,1c,76,31,d2,00,14,00,00,00,53,00,6e,00,\
  61,00,67,00,49,00,74,00,20,00,37,00,2e,00,6c,00,6e,00,6b,00,00,00,1c,00,00,\
  00,00,00,00,00,5a,00,00,00,01,00,00,00,4c,00,32,00,10,09,00,00,76,31,21,01,\
  20,00,54,48,45,42,41,54,7e,31,2e,4c,4e,4b,00,00,30,00,03,00,04,00,ef,be,6c,\
  31,12,98,76,31,21,01,14,00,00,00,54,00,68,00,65,00,20,00,42,00,61,00,74,00,\
  21,00,2e,00,4c,00,4e,00,4b,00,00,00,1c,00,00,00,00,00,00,00,62,00,00,00,04,\
  00,00,00,54,00,32,00,bc,02,00,00,6c,31,fa,96,20,00,54,4f,54,41,4c,43,7e,31,\
  2e,4c,4e,4b,00,00,38,00,03,00,04,00,ef,be,6c,31,eb,96,75,31,50,bc,14,00,00,\
  00,54,00,4f,00,54,00,41,00,4c,00,43,00,4d,00,44,00,2e,00,45,00,58,00,45,00,\
  2e,00,6c,00,6e,00,6b,00,00,00,1c,00,00,00,00,00,00,00,99,00,00,00,e0,06,00,\
  00,00,00,00,00,19,00,00,00,00,00,00,00,00,00,00,00,19,00,00,00,00,00,00,00,\
  01,00,00,00,01,00,00,00,aa,4f,28,68,48,6a,d0,11,8c,78,00,c0,4f,d9,18,b4,f2,\
  02,00,00,e0,0c,00,00,00,00,00,00,19,00,00,00,00,00,00,00,00,00,00,00,19,00,\
  00,00,00,00,00,00,01,00,00,00,02,00,00,00,8b,8a,0d,54,3f,1c,32,4e,81,32,53,\
  0f,6a,50,20,90,1e,00,00,00,e0,04,00,00,00,00,00,00,18,00,00,00,00,00,00,00,\
  00,00,00,00,18,00,00,00,00,00,00,00,01,00,00,00

;----------------------------------------------
;Оптимизация Проводника и Internet Explorer
;----------------------------------------------

;Сортировать меню Пуск и Избранное в алфавитном порядке
[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Favorites]
[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu]
[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu2]

;Отключить отладку скриптов в IE
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Disable Script Debugger"="yes"

;Поиск в Google из строки адреса
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl\G]
@="http://www.google.com/search?q=%s"

;Включить отображение расширений в Проводнике
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"HideFileExt"=dword:00000000

;Показывать скрытые файлы и папки
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"Hidden"=dword:00000002

;------------
;Разное
;------------

;Отключить предпросмотр фильмов в Проводнике (ускоряет работу и позволяет перемещать и удалять файлы)
[-HKEY_CLASSES_ROOT\.avi\ShellEx]
[-HKEY_CLASSES_ROOT\.mpg\ShellEx]
[-HKEY_CLASSES_ROOT\.mpe\ShellEx]
[-HKEY_CLASSES_ROOT\.mpeg\ShellEx]

Автор: Vadikan
Иcточник: частично взято с unattended.msfn.org

Наш форум

Опубликована- 25.02.2005


Автоматическая установка

FAQ (часто задаваемые вопросы)

Q. В процессе установки $ОЕМ$ директории не копируются на жесткий диск. Что делать?

А.

  1. Если вы устанавливаете систему с жесткого или сетевого диска, указывая путь к файлу ответов, то расположение директории $OEM$ нужно изменить. В таком случае директорию нужно поместить в i386. Также, можно указать параметер OemFilesPath = path_to_$OEM$_folder в секции [Unattended] файла winnt.sif.

  2. Проверьте наличие параметра OemPreinstall=Yes в секции [Unattended] файла winnt.sif.

  3. Убедитесь в отсутствии кириллицы в названии директории.

  4. Если загрузочный диск создавался в Nero убедитесь что при записи директория не оказалась переименована в _OEM_. Чтобы этого избежать, в свойствах компиляции на закладке ISO нужно выбрать параметры как на скриншотe.

Q. Как автоматически установить желаемые обои на рабочий стол?

A.

  1. Сохраните ваш графический файл как bliss.jpg (именно этот файл обоев ставится системой по умолчанию).

  2. Запустите из командной строки команду makecab bliss.jpg (не забудьте указать правильный путь к файлу).

  3. Получившийся файл bliss.jp_ скопируйте в директорию i386 вашего дистрибутива и согласитесь на перезапись.

Q. Как задать желаемые раскладки клавиатуры и клавиши переключения между ними?

А. Оба ответа можно найти в статье о локализации. Раскладки клавиатуры можно задать через секцию [RegionalSettings] файла ответов. Там же рассказывается как задать способ переключения раскладок.

Q. После установки в некоторых программах неверно отображается кириллица (в виде вопросительных знаков или иероглифов). Как этого избежать?

А. Ответ включен в статью о локализации.

Q. При загрузке с созданного CD появляется надпись "Вставьте диск Winndows XP Professional CD-ROM в устройство А: и нажмите клавишу Ввод..." Почему это происходит?

А. Скореее всего, в корне CD отсутствуют маркерные файлы WIN51, WIN51IP, WIN51IP.SP2

Продолжение следует...

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 26.02.2005


Автоматическая установка

Интересное

В этот раздел попали статьи, которые "не вписались" в другие разделы. Их нет на сайте unattended.msfn.org, однако это не означает, что статьи не достойны вашего внимания. Никакой концепции у раздела нет; он просто содержит интересные материалы, связанные с автоматической установкой Windows.

На данный момент в разделе представлены статьи о программе XPCreate и об интеграции WMP10 в дистрибутив Windows XP.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 21.03.2005


Автоматическая установка

XPCreate

Что это такое

XPCreate - это программа, позволяющая создать инсталляционный диск Windows XP со всеми текущими обновлениями и сервис паками. В процессе работы программы производится интеграция обновлений и сервис паков в дистрибутив, а по окончании создается образ диска в формате ISO. Таким образом, после инсталляции системы не потребуется установка обновлений (до тех пор пока не будут выпущены новые, конечно). Программа доступна как в бесплатном, так и в коммерческом варианте с чуть более расширенной функциональностью.

Что понадобится для работы

Программа XPCreate, инсталляционный диск Windows XP, ключ (серийный номер) продукта, и возможно сервис пак(и), обновления и заплатки, скачанные с сайта Microsoft.

С чего начать

Начинаем с установки программы. Программа запакована в IExpress инсталлятор (запускается iexpress из командной строки, и не имеет ничего общего с Internet Explorer). После запуска инсталлятора надо принять лицензионное соглашение и выбрать директорию для установки. В директории появится несколько файлов, и для начала надо уделить внимание файлу XPCREATE.INI, в котором содержатся основные настройки программы. Подробнее параметры файла описаны тут, и, наверное, изучать их лучше параллельно с прочтением этой статьи.

Как работать с программой

Для корректной работы программы необходимо установить .NET Framework 1.1. Его можно скачать с сайта Microsoft. Альтернативно, вы можете использовать перепакованную версию, включающую в себя SP1 для .NET Framework 1.1, ссылку на которую можно найти тут. Не забудьте потом удалить "лишнего" пользователя из системы, который устанавливается вместе с .NET Framework.

Первым делом нужно в каталоге программы создать директории, поименованные особым образом, и наполнить их файлами и обновлениями (хотфиксами). Описания директорий вы найдете в отдельной статье. Необязательно наполнять все директории. Насколько я знаю, достаточно создать только те, которые вы будете использовать. Если вы не знаете где взять обновления, то прочитайте эту статью.

Программа XPCreate не имеет графического интерфейса, и вся работа с ней сводится к запуску XPCREATE.CMD. Инсталляционный диск Windows XP должен находиться в CD-ROMе. Альтернативно, вы можете скопировать его на жесткий диск. Обязательно нужно указать один параметр в файле XPCREATE.INI, обозначив месторасположение дистрибутива. По умолчанию параметр указывает на D:

XPSOURCE=D:

Нужно заменить параметр XPSOURCE на путь к вашему дистрибутиву. Например,

XPSOURCE=D:\Distributiv

Теперь запускайте XPCREATE.CMD.

Теперь после того как все обновления и файлы раскиданы по нужным директориям и указан правильный путь к дистрибутиву, можно запускать XPCREATE.CMD. XPCreate интегрирует все обновления в дистрибутив, перепакует кабинетные архивы Windows, создаст ISO образ нового дистрибутива и даже запишет на оптический носитель, если соответствующие параметры были указаны в XPCREATE.INI. Время работы программы зависит от мощности процессора и скорости жесткого диска. У меня на P933 все заняло около часа.

Заключение

XPCreate дает возможность быстро создать обновленный дистрибутив Windows XP. Работа над программой ведется постоянно, чему в немалой степени способствует Microsoft, регулярно выпускающая важные и критические обновления.

Вероятные вопросы

После прочтения материалов об XPCreate у вас, возможно, возник ряд вопросов. Попытаюсь в общих чертах предвосхитить некоторые из них:

Где взять полную (коммерческую) версию программы?

Вы можете приобрести ее. Подробнее - на сайте XPCreate.

Как это все работает?

Очевидно, что за все отвечает один большой пакетный файл XPCREATE.CMD. Однако, XPCreate не является Open Source проектом, и в лицензионном соглашении запрещается не только редактирование, но и изучение файла XPCREATE.CMD.

М$ выпустила свежие обновления. Как их теперь интегрировать в дистрибутив? Неужели все надо делать заново?

GreenMachine (создатель XPCreate) рекомендует проводить весь процесс заново во избежание неисследованых проблем.

Что такое DX9NTopk.exe?

Это DirectX 9 OEM Preinstallation kit. Вообще, DX9c входит в состав SP2, так что актуальность DX9NTopk.exe несколько потеряла смысл.

P.S. Если в процессе работы что-то пошло не так, то изучите XPCREATE.LOG, расположенный в директории Newfiles, которую создает XPCreate. Вы всегда можете задать вопрос на форуме XPCreate, прикрепив лог к сообщению.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 19.03.2005


Автоматическая установка

Директории XPCreate

Ниже приводится описание директорий, которые вы можете создать в директории XPCreate. Системные директории будут созданы в процессе работы, их создавать не надо.

Service Pack

SPACKS Сюда кладется последний Service Pack.

Запускаются из SVCPACK.INF

SVC-CF1 | Файлы, находящиеся здесь, будут запущены сразу после хотфиксов. Они должны поддерживать ключи /Q /U /O /N /Z. Эта папка предназначается для Type I хотфиксов, которые не могут быть интегрированы.
SVC-CF2 | Файлы, находящиеся здесь, будут запущены сразу после хотфиксов. Они должны поддерживать ключи /Q:U /R:N. Эта папка предназначается для Type II хотфиксов, которые не могут быть интегрированы.
SVC-CF3 | Файлы, находящиеся здесь, будут запущены сразу после хотфиксов и после файлов из SVC-CF1. Они должны поддерживать ключи /Q /U /O /N /Z. Эта папка предназначается для Type I хотфиксов, которые не могут быть интегрированы.
SVC-CF4 | Файлы, находящиеся здесь, будут запущены сразу после хотфиксов и после файлов из SVC-CF2. Они должны поддерживать ключи /Q:U /R:N. Эта папка предназначается для Type II хотфиксов, которые не могут быть интегрированы.
SVC-DAH | DA хотфиксы находятся здесь. На данный момент они включают в себя KB832414_MSXML3.0_x86.exe MSXML апдейт.
SVC-DAS | DA инсталляционные файлы находятся здесь. Включая MDAC 2.8 апдейт.
SVC-DX9 | DirectX 9 (directx_9c_redist.EXE) кладется сюда. Пакет будет распакован, лишние файлы убраны, и в итоге будет создан более компактный пакет. DX9c, однако, входит в XP SP2.
SVC-EXE | Исполняемые файлы без ключей здесь. Эти файлы будут запускаться после Type I и Type II хотфиксов
SVC-HF1 | Хотфиксы Type I здесь. Эти файлы будут интегрированы в директорию I386, и вызываться из SVCPACK.INF файла во время установки с /Q /O /U /N /Z ключами.
SVC-HF2 | Хотфиксы Type II здесь (за исключением особых случаев). Эти файлы будут интегрированы в директорию I386, и вызываются из SVCPACK.INF во время установки с /Q:U /R:N ключами.
SVC-MDC | В этой директории содержатся специальные MDAC апдейты.
SVC-MSX | Файлы, находящиеся здесь, будут запущены после хотфиксов. У этих файлов не должно быть никаких ключей.
SVC-OEM | Сюда можно добавить *.OEM файлы, которые используются для интеграции SATA/RAID драйверов. Подробнее на соотв. странице сайта XPCreate.
SVC-PRE | Файлы, находящиеся здесь, будут установлены сразу перед хотфиксами. Эти файлы должны поддерживать /Q:U /R:N ключи. Таким файлом является, например, DirectX 9 OPK
SVC-QCH | Здесь инсталлятор QCHAIN.EXE. Именно инсталлятор, а не распакованная утилита.
SVC-SWF | Последний Shockwave Flash Cab файл (SWFLASH.CAB) кладется сюда.
SVC-WMC | Сюда кладется Windows Media Connect. Он будет перепакован в безключевой инсталлятор и запущен вместе с файлами из SVC-PRE после WMP (ниже).
SVC-WMP | Windows Media Player 9 кладется сюда. Он будет переупакован в безключевой инсталлятор и запущен вместе с файлами из SVC-PRE.
SVC-WMS | Windows Messenger 4.7 апдейт должен быть здесь. Эти файлы будут распакованы во время установки.
SVC-X2M | Microsoft Installer Programs, которые упакованы IExpress, кладутся сюда. MSI и CAB будут распакованы и переупакованы используя IExpress в безключевые инсталлеры и запущены вместе с файлами из SVC-PRE . Включая: DotNetFX и Moviemaker II. MSI тоже можно положить сюда. Они тоже будут перепакованы при помощи IExpress.

Включаются в дистрибутив в самом конце работы программы

FILESCD Файлы и директории, которые не подвергнутся изменениям. Сюда можно положить ваши $OEM$, $OEM$\$$, $OEM$\$1\DRIVERS, I386\WINNT.SIF, $OEM$\CMDLINES.TXT и т. д.

Системные директории XPCreate (создaются в процессе работы)

BOOT | Здесь находится файл для создания загрузочного диска. Если вы указали путь к дистрибутиву на CD, то файл сам появится в директории в процессе работы XPC.
CDROOT | Результат работы XPCreate. Из этой директории и создается ISO образ. Фактически, эта директория содержит обновленный дистрибутив.
NEWFILES | Файлы созданные в процессе работы программы. Перепакованные обновления и пр. Можно удалить, они больше не понадобятся.
TEMP | Временные файлы и директории, созданные в процессе работы. Можно удалить.

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 20.03.2005


Автоматическая установка

Параметры XPCREATE.INI

Параметр | Возможные значения | Значение по умолчанию | Пояснение
BOOTIMGFILE | Путь к файлу | Нет | Прямой или относительный путь к файлу, необходимому для создания загрузочного диска. Не нужен, если исходный дистрибутив (XPSOURCE) является загрузочным инсталляционным CD
CDBURNER | Буква диска | Нет | Буква диска, назначенная пишущему приводу
CDERASE | YES/NO | NO | Стирание CD-RW перед записью
CDLABEL | Не спец. символы | XPCREATE | Метка тома создаваемого диска
CDSPEED | MAX/Speed | 12 | Скорость записи диска
CDTYPE | CD/DVD | CD | Тип записываемого носителя
COPYSOURCE | YES/NO | NO | Копирование дистрибутива с CD на жесткий диск
DELISOS | YES/NO | NO | Удаляет ISO файл после записи
DELROOT | YES/NO | NO | Удаляет директорию CDROOT после создания .ISO образа диска
DELTEMP | YES/NO | NO | Удаляет директорию TEMP, когда необходимость в ней отпадает
DOCABS | YES/NO | YES | Перепаковывает и обновляет кабинетные файлы
DOCD | YES/NO | YES | Создает CD
DOISO | YES/NO | YES | Создает ISO
DOSATA | YES/NO | YES | Производит интеграцию SATA драйверов
DOPATH | YES/NO | NO | Обновляет WINNT.SIF, подставляя значение OEMPnPDriversPath вычисленное на основе DRIVERSDIR
DOSVCPACK | YES/NO | YES | Создает SVCPACK.INF
DRIVERDIR | Путь к директории | $OEM$\$1\DRIVERS | Путь к директории, где расположенны драйверы SATA (относительно FILECD)
DVDPLUS | YES/NO | NO | Запись производитеся на DVD+R
EXITQUIET | YES/NO | NO | Отображает диалоговое окно с текстом "Press Enter to Exit" по завершении работы программы
OVERWRITEOEM | YES/NO | YES | Использутет ключ "/O" при установке Type I хотфиксов
RENAMEF | YES/NO | YES | Переименовывает SVCPACK файлы в последовательном порядке (Страхует от возможного совпадения имен файлов, поскольку они все равно переименовываются в формат 8.3)
SILENTINSTALL | YES/NO | YES | Отображает прогресс инсталляции во время установки хотфиксов/апдейтов за 13 минут до окончания установки Windows
SLIPHF1 | YES/NO | YES | Интеграция Type I хотфиксов
SLIPHF2 | YES/NO | YES | Интеграция Type II хотфиксов
SLIPMDC | YES/NO | YES | Интеграция MDAC
SLIPSPK | YES/NO | YES | Интеграция Сервис Пака
USERFILESCD | Путь к директории | Нет | Файлы в этой директории будут помещены в корневой каталог создаваемого диска. Избавляет от нбх копировать каждый раз файлы в директорию FILESCD
USERWINLANG | Трехбуквенный код | Нет | Трехбуквенный языковой код Windows. Насколько мне известно, русские версии Windows работают и без этого параметра.
XPISO | Путь к файлу | XPCREATE.ISO | Прямой или относительный путь к создаваемому .ISO файлу
XPSOURCE | Путь к директории | Нет | Прямой или относительный путь к исходному дистрибутиву

Plug-In XPCDLHFS.CMD

Плагин поставляется только с коммерческой версией и предназначен для автоматической загрузки обновлений. Значения по умолчанию для параметров wget я опускаю.

DODLF | YES/NO | YES | Запуск плагина
DLURL | URL |  | URL списка загружаемых обновлений.
HTTPUN | Username | нет | Имя пользователя для загрузки списка обновлений
HTTPPW | Password | нет | Пароль пользователя для загрузки списка обновлений
WGHLPARM | Параметр wget |  | Параметр wget для загрузки списка обновлений
WGHFPARM | Параметр wget |  | Параметр wget для загрузки обновлений
WGSPPARM | Параметр wget |  | Параметр wget для загрузки Service Pack

Автор: Vadikan
Иcточник: unattended.oszone.net

Наш форум

Опубликована- 19.03.2005


Автоматическая установка

Песнь о Батнике или интегрируем WMP10 в дистрибутив Win XP SP2

Статью написал VseDoFeni. Оригинальный стиль полностью сохранен :)

На просторах интернета, как-то раз меня носило.
Там наткнулся я на батник и решил его открыть.

Результат его работы очень кстати мне пришелся
Заменить девятый плеер на десятый он позволил.

Так Винды дистрибутива я размер сумел уменьшить
И пускай совсем немного он уменьшился в размере.
Мегабайт эдак на пять лишь, но и это тоже «масло»
На компакте все же место ограничено серьезно.
И помимо уменьшенья той Винды дистрибутива
Он позволил мне и время хоть чуть-чуть, но сэкономить.

…Я, по-моему, отвлекся на проблемы описанье.
Начинать пора рассказ мне, как сей бонус получить.

Надо взять, друзья, нам батник, он по ссылке расположен.
Кроме батника нам нужен ВЭ-ЭМ-ПЭ десятый плеер.
Он в Винду внедряться будет этим батником у нас.
Все почти у нас готово процедуру чтоб начать.

Каталог создать нам надо, где ни будь на жестком диске.
В просторечии «винчестер» жесткий диск еще зовется.
Место нам запомнить надо, где создали каталог.
Файлы мы в него положим, что скачали с Интернета,
А когда они там будут, надо батник запустить.
Указав на батник мышкой, надо кликнуть нам два раза.
Заработает он сразу и зеленый текст покажет нам консоль на черном фоне.
Это значит, батник начал выполнять для нас работу.

Вся работа в три этапа выполняться у нас будет.
Батник первых два этапа сможет выполнить для нас.

На экране монитора ход работы мы увидим.
На консоли черном фоне букв зеленых хоровод.
Вы увидите вначале описание процесса.
А потом нажмете кнопку, имя кнопки – Эникей.
Тут начнется распаковка плеера дистрибутива в каталог на диске Ц.
Снова жать на кнопку надо, снова текст пойдет зеленый,
Упаковку нужных файлов батник нам произведет.
Паковать с перемещеньем эти файлы батник будет.
И создаст пред сим процессом каталог еще один.
А названье каталога не рифмуется вот что-то.
Батник нам его покажет, там название прочтем.

После файлов подготовки, без участья человека
Вам придется поработать, но не много, лишь чуть-чуть.
Подготовленные файлы надо будет передвинуть
Или скажем по-другому, надо их переместить.

Вспоминайте поскорее место, где лежит Виндоза.
То Виндоза не простая – анаттенд дистрибутив.
И туда все наши файлы поспешите положить.
Их скопировать с заменой жизненно необходимо,
Если только вы хотите результаты получить.

Тут согласно описанью, что в консоли мы увидим,
Нам останется всего лишь один файлик изменить.

Все, теперь исошный образ компилировать мы будем.
Скомпилированный образ мы запишем на болванку.

Результатом проведенной работы будет CD с дистрибутивом Windows XP SP2, с интегрированным в него Windows Media Player 10.

Автор: VseDoFeni

Наш форум

Опубликована- 21.03.2005


Автоматическая установка

Лог обновлений сайта

RSS site updates
Teкстовая ссылка

Текущая оффлайн версия сайта в формате CHM - (2.01)
Текущая онлайн версия сайта - посмотреть...

Версии сайта

0.1 - добавлена новая статья; 0.01 - исправлена существующая статья.

19 декабря 2005 (версия 2.01)

Добавлена статья Набор обновлений UpdatePack-XPSP2-Rus для русской Windows XP Pro SP2. Обновлена статья GuiRunOnce.

Добавлена статья Программа Multiset - автоматизация установки приложений, которая вошла только в оффлайн версию сайта.

12 декабря 2005 (версия 1.9)

Обновлено Введение. Внесены мелкие исправления в статьи Создание файла ответов, Твики Реестра, Справочник и Примеры.

03 декабря 2005 (версия 1.85)

В значительной степени обновлена статья Установка драйверов с CD - теперь там описан более простой, но не менее действенный метод. В разделе Эксперту создана секция Сетевые технологии. В которую помимо статьи Особенности автоустановки через Remote Installation Services (RIS) вошла новая статья Загрузка компьютера по сети с практически любого образа диска.

11 ноября 2005 (версия 1.64)

В Справочник добавлена статья Локализация: MUI, Шрифты и Региональные настройки. Обновлены три статьи про Office 2003, в связи с выходом SP2 для него (изменения свелись к ссылкам на новый пакет обновлений и замене SP1 на SP2 в тексте статьи, т.к. процесс не изменился). Обновлен FAQ, в котором ответы на два вопроса теперь входят в состав статьи о локализации. И наконец, подробный рассказ о секции [RegionalSettings] убран из статьи Параметры файла ответов и перенесен все в ту же статью о локализации.

09 октября 2005 (версия 1.5)

Добавлена статья Winntbbu Editor. Обновлены статьи Setup Billboards нового стиля и Параметры файла ответов.

13 сентября 2005 (версия 1.4)

Добавлена статья Мультизагрузочный CD автоустановки Windows XP с неограниченным количеством конфигураций.

12 aвгуста 2005 (версия 1.31)

Добавлено примечание в конце статьи Особенности автоустановки через Remote Installation Services (RIS). Внесено важное исправление в статью Добавлeние учетных записей (последняя строка раздела OOBEINFO.INI).

12 июля 2005 (версия 1.3)

Добавлены статьи Мультизагрузка (обзор) и Совмещение нескольких ОС семейства NT на одном диске. Дополнена статья Создание SFX архива.

07 июня 2005

Дополнена статья Установка обновлений.

04 мая 2005

Добавлена статья Особенности автоустановки через Remote Installation Services (RIS). Также, на протяжении последних трех недель были исправлены мелкие ошибки и опечатки на различных страницах сайта.

12 апреля 2005

Раздел целиком интегрирован в сайт OSZone.net. Переезд совпал с глобальным обновлением содержимого сайта. Переработана структура, отредактированы старые и добавлены новые статьи.

Многочисленные обновления на протяжении года. Детали сейчас не имеют значения.

17 апреля 2004

Открытие раздела unattended.oszone.net.

Наш форум

Опубликована- 18.03.2005