Лабораторный практикум по дисциплине

Лабораторный практикум по дисциплине «Инфоматика»

Технология работы в интегрированном офисном пакете

Microsoft Office 2000

Основные сведения о Microsoft Office 2000

Текстовый процессор МS Word

Табличный процессор MS Excel

Система управления базами данных MS Access

© Тархов С.В., Рамбургер О.Л., Минасов Ш.М., Уфа, кафедра Информатики, УГАТУ, 2004 г.


Access

Технология работы с базами данных
в С истеме Управления Базами Данных
Microsoft Access

Проектирование реляционных баз данных

СУБД MS Access

Лабораторная работа №1

Лабораторная работа №2

[На главную страницу]


Exel

Технология работы с электронными таблицами в табличном процессоре
Microsoft Excel 2000

Табличный процессор MS Excel

Лабораторная работа № 1

Лабораторная работа № 2

[На главную страницу]


Lab1

Лабораторная работа №1: Создание простых текстовых документов

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является практическое освоение технологии подготовки и редактирования простых документов с помощью текстового процессора Microsoft Word.

Порядок выполнения работ

· Запустить Microsoft Word.

· В порядке, описанном в методических указаниях, изучить приемы работы в текстовом процессоре Word.

· Выполнить задания, приведенные в методических указаниях.

· Сохранить результаты работы на личной дискете.

· Показать результаты работы преподавателю.

· Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

· Первичные настройки текстового процессора Microsoft Word 2000

· Настройка параметров печатного документа

· Набор и выделение текста

· Форматирование текста:

Настройка шрифта и выбор метода выравнивания

Настройка параметров абзаца

· Средства создания маркированных и нумерованных списков

· Форматирование с помощью линейки

· Автотекст и автозамена

· Ввод специальных и произвольных символов

· Средства автоматизации проверки правописания

· Поиск и замена в документе Word

· Оформление текста в несколько столбцов

· Оформление текста рамками

· Работа с колонтитулами

· Сноски и перекрестные ссылки

· Создание оглавления

· Приемы и средства автоматизации разработки документов

Работа со стилями

Шаблоны

Требования к отчету

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Текстовый процессор Word

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.

начало

назад

вперед

конец

вопросы

задания


Lab3

Лабораторная работа №1: Работа с электронными таблицами

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является практическое освоение основной технологии работы с электронными таблицами в табличном процессоре Excel: создание и редактирование таблиц, расчеты по формулам, представление данных в виде различных диаграмм, решение задач с помощью электронных таблиц.

Порядок выполнения работ

· Запустить Microsoft Excel.

· В порядке, описанном в методических указаниях, изучить приемы работы в табличном процессоре Excel.

· Выполнить задания, приведенные в методических указаниях.

· Сохранить результаты работы на личной дискете.

· Показать результаты работы преподавателю.

· Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

Ввод, редактирование и форматирование данных

Автоматизация ввода

Копирование содержимого ячеек

Вычисления в электронных таблицах. Формулы

Вычисления в электронных таблицах. Стандартных функций

Вычисления в электронных таблицах. Итоговые вычисления

Построение диаграмм и графиков

Печать документов Exсel

Использование электронных таблиц для решения задач

Требования к отчету

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Табличный процессор Excel

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Lab_2

Лабораторная работа №2: Создание комплексных текстовых документов

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является практическое освоение приемов создания комплексных текстовых документов, содержащих не только текст, но и встроенные объекты иной природы, с помощью текстового процессора Microsoft Word.

Порядок выполнения работ

· Запустить Microsoft Word.

· В порядке, описанном в методических указаниях, изучить приемы работы в текстовом процессоре Word.

· Выполнить задания, приведенные в методических указаниях.

· Сохранить результаты работы на личной дискете.

· Показать результаты работы преподавателю.

· Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Особенности объектов Word.

  • Работа с таблицами.

  • Работа с диаграммами.

  • Ввод формульных выражений.

  • Создание художественных заголовков.

  • Использование графических объектов.

  • Работа с рисунками.

  • Работа с клипартами.

  • Работа с растровыми изображениями.

Требования к отчету

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Текстовый процессор Word

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Microsoft Office 2000

Word

Excel

PowerPoint

Outlook

Access

FrontPage

Binder

Комплект Microsoft Office 2000 (в дальнейшем – Office) рассматривают как набор инструментов, необходимых для организации работы в офисе учебном заведении или дома и применяют его не только как комплект настольных приложений, но и как платформу для создания специализированных решений или средство доступа и обмена данными. MS Office обеспечивает легкость использования, многофункциональность и интеграцию приложений для широкого круга пользователей.

Варианты поставок Microsoft Office 2000

 | Standard Edition | Small Business Edition | Рrofessional Edition | Premium Edition
Word 2000 | O | O | O | O
Excel 2000 | O | O | O | O
PowerPoint 2000 | O |  | O | O
Outlook 2000 | O | O | O | O
Publisher 2000 |  | O | O | O
Microsoft Access 2000 |  |  | O | O
FrontPage 2000 |  |  |  | O
PhotoDraw 2000 |  |  |  | O
Small Business Tools |  | O | O | O

Комплект Microsoft Office 2000 включает следующие приложения.

Microsoft Word 2000 – текстовый процессор, позволяющий создавать документы любой сложности: оформлять их с использованием различных шрифтов, включать в документ рисунки, таблицы, формулы, графики, диаграммы и др. Имеет удобный графический интерфейс и средства автоматизации оформления документов. Создаваемые файлы имеют расширение DOC.

Microsoft Exel 2000 – табличный процессор для представления и обработки данных в виде электронных таблиц, имеющий универсальные возможности решения задач и встроенные средства деловой графики. Microsoft Exel 2000 имеет мощный аппарат математических инструментов для решения задач линейного программирования, оптимизации статистического моделирования и т.п.. Создаваемые файлы имеют расширение XLS.

Microsoft PowerPoint 2000 – графический пакет для создания презентаций и слайд-фильмов. Этот пакет представляет пользователю возможность оформления текста, рисования, построения графиков и диаграмм, а также широкий набор стандартных иллюстраций, стилевых шаблонов и возможность использования звука и видео. Создаваемые файлы имеют расширение PPT.

Microsoft Outlook 2000 – программа управления информацией, которая помогает работать с сообщениями, приходящими по электронной почте, контактными лицами, назначать встречи, ставить задачи, отслеживать деятельность свою и сотрудников, просматривать совместные документы.

Microsoft Publisher 2000 - настольная издательская система, позволяющая легко создавать профессионально оформленные маркетинговые материалы. В нем предлагаются более 2000 профессионально разработанных шаблонов публикаций и сотни элементов дизайна, которые пользователи могут вставлять в собственные публикации.

Microsoft Access 2000 – система управления базами данных позволяющая создавать как автономные базы данных для персонального компьютера, так и базы данных для совместного использования в отделе или на целом предприятии. MS Access обеспечивает простые в использовании и управлении решения для совместной обработки информации. Access 2000 не только содержит традиционно широкий набор простых инструментальных средств обработки данных, но и обеспечивает глубокую интеграцию с Вебом, упрощающую совместное использование информации на разных платформах пользователями с разным уровнем подготовки, а также содержит дополнительные средства автоматизации, повышающие производительность. Создаваемые файлы имеют расширение MDB.

Microsoft FrontPages 2000 - включает все необходимые средства для эффективной разработки и эксплуатации веб-узлов. Пользователи могут легко создавать качественно оформленные веб-страницы, выбирая наиболее удобный способ разработки. MS FrontPage 2000 позволяет придавать законченный и профессиональный вид веб-узлам, импортировать и редактировать код HTML любым из существующих способов и применять новейшие веб-технологии. С помощью FrontPage 2000 можно легко выполнять обновление веб-страниц, а также пользоваться гибкими средствами для управления узлами Интернета и интрасетей.

Microsoft PhotoDraw 2000 - объединяет простые инструментальные средства для создания рисунков и редактирования графики, позволяя создавать профессионально оформленные графические изображения для веб-страниц, печатных документов и презентаций.

Microsoft OfficeBinder 2000 – программа для создания подшивки документов, включенная в состав Small Business Tools (утилиты MS Office), позволяет группировать все необходимые для проекта документы, книги и презентации. При работе с подшивкой можно использовать новые возможности MS Office 2000: поместить подшивку в дневник Outlook, вывести на печать документы с одинаковыми колонтитулами, открывать и сохранять подшивки в Интернете. Создаваемые файлы имеют расширение OBD.

Все офисные приложения имеют несколько почти одинаковых меню и функций. Общие команды открытия, закрытия и создания файлов, общие принципы работы со справкой, использование шаблонов при создании документов, печать и сохранение документов, настройка панелей инструментов и команд меню – все эти функции не зависят от того, обрабатывает ли программа текстовый документ, электронную таблицу презентацию или рисунок.

Запуск программы Microsoft Office

Для запуска нужной программы надо нажать кнопку Пуск, в стартовом меню, и выбрать папку Программы. В открывшемся подменю нужно установить указатель мыши на значок программы и нажать левую кнопку.

Создание, сохранение и открытие документов Office

Создание нового документа

Если приложение уже открыто:

  1. Щелкнуть по кнопке Создать - [image] на Стандартной панели инструментов;
  2. Выбрать из меню Файл команду Создать.

В первом случае будет создан пустой документ на базе стандартного шаблона, в который можно ввести нужный текст, рисунки или данные таблицы.

Во втором случае откроется окно, позволяющее создать документ на базе шаблона (см. раздел шаблоны).

Сохранение документа

Если документ сохраняется впервые, или его надо сохранить под другим именем, необходимо выполнить команду Сохранить как из меню Файл. В появившемся окне нужно выбрать Папку, в которой нужно сохранить документ, и ввести имя документа в поле Имя файла.

Поле Имя файла служит для ввода названия документа. Поле Тип файла позволяет осуществить выбор формата сохраняемого файла (по умолчанию предлагается формат открытого приложения).

С помощью команды Сохранить из меню Файл или кнопки [image] на Стандартной панели инструментов можно сохранить текущий документ с тем же именем.

Открытие документа

Диалоговое окно Открытие документа позволяет открывать документы, располагающиеся в различных областях. Можно открывать документы, хранящиеся на жестком или гибком диске комппьютера или на сетевом диске, к которому имеется доступ. Для вызова этого окна нужно выбрать команду Открыть из меню Файл.

Для каждого приложения в нижней части меню Файл сохраняется список файлов, которые использовались последними. Любой из них можно открыть, выбрав из списка.

Можно открыть любой документ, не открывая приложение, из папки Мой компьютер или в окне программы Проводник. Для этого нужно дважды щелкнуть мышью на его имени.

Шаблоны

Использование шаблонов позволяет экономить время и избегать ошибок при создании стандартных документов. Очень удобно с помощью шаблонов создавать служебные записки, письма, факсимильные сообщения, отчеты, справочники, брошюры, календари, Web-страницы, расписания, повестки дня, резюме, рекламные презентации и выступления для отчетных докладов и т.д.

Шаблон - это совокупность стилей, пользовательских меню, параметров страницы, настроек приложения и некоторых фрагментов оформления документа (текст, рисунки, таблицы, колонтитулы и др.), сохраненная на диске в виде файла. Шаблон можно рассматривать как метод автоматизации создания документа на основе существующих текстовых заготовок и форматирования.

Для текстового процессора MS Word файл шаблона имеет расширение DOT, для табличного процессора MS Excel – расширение XLT.

Часть шаблонов создается при выполнении типичной установки пакета Office 2000 на компьютере, другая часть - только при выборочной установке; некоторые шаблоны поставляются на компакт-дисках с Office 2000 ValuPack и через Microsoft Web.

Пользователь может сам создавать и сохранять на диске необходимые ему шаблоны документов.

Установленные при инсталляции шаблоны хранятся в папке стандартных шаблонов Office 2000 (C:\Program files\MicrosoftOffice\Шаблоны), если для их расположения пользователь не укажит другую (другие) папки (в MS Word меню Сервис/Параметры/Расположение).

Для каждой программы приложения Office 2000 существуют собственные шаблоны документов.

В Office 2000 включено несколько десятков шаблонов для 10 категорий (отчеты, письма и факсы, презентации, шаблоны оформления и др.)

Созданный на основе шаблона документ можно редактировать, вводить нужные данные и сохранять с собственным уникальным именем

Если приложение не открыто, то документ можно создать и с помощью выбора меню Создать документ Microsoft Office при нажатии кнопки Пуск. При этом доступна панель всех шаблонов для приложений Office.

Панели команд, элементы меню

Существенным преимуществом использования Office является единообразная структура панелей инструментов всех программ-приложений, входящих в пакет.

Панели команд, также известные как панели инструментов, состоят из меню команд и/или кнопок, которые можно использовать для выполнения определенных операций. По умолчанию приложения Office отображают панель Главного меню и панели инструментов Стандартная и Форматирование. Главное меню содержит меню и команды. Панели инструментов Стандартная и Форматирование содержат кнопки, используемые для быстрого доступа к командам главного меню.

Можно настроить любую из панелей инструментов для создания собственного набора команд, чтобы облегчить доступ к наиболее часто используемым операциям. Кнопки, которые не используются (или используются редко) можно убрать, чтобы не загромождать экран.

Главное меню позволяет выполнять перечисленные в нем команды как элементы вложенных меню. Некоторые команды меню имеют продолжение в виде диалоговых окон с дальнейшими вариантами.

Значками отмечены элементы меню, соответствующие кнопкам панели инструментов.

Элементы меню, которые недоступны для данной операции, не высвечиваются. Многоточие (...) показывает, что за пунктом меню следует панель диалога. Треугольники внизу окна показывают, что за этим элементом следуют дополнительные строки меню.

Настройка панелей инструментов

В каждом приложение Office для автоматизации работы пользователю предоставляются следующие функции настройки панелей:

· создание собственной панели инструментов,

· создание собственного меню,

· добавление кнопок в существующую панель инструментов.

Использование команды Настройка из меню Сервис позволяет выполнить эти действия и просмотреть список панелей в поле Панели инструментов.

Панели инструментов создаются для макрокоманд, наиболее часто используемых команд и шрифтов.

Чтобы создать собственную панель инструментов нужно:

1. Щелкнуть правой клавишей мыши на панели команд, чтобы открыть всплывающее меню, и выбрать Настройка. Появится диалоговое окно.

2. Выбрать закладку Панели инструментов.

3. Выбрать кнопку Создать и ввести имя панели в текстовом поле Имя панели инструментов.

4. Нажать ОК. Панель инструментов появится на экране.

Чтобы добавить кнопку в существующую панель инструментов нужно:

1. Выбрать закладку Команды.

2. Выбрать нужную категорию из списка Категории.

3. Перетащить нужную команду из списка Команды в существующую или новую панель.

Для удаления кнопки из существующей панели инструментов следует, при появлении диалогового окна Настройка, перетащить кнопку (например, Панель Web, если компьютер не связан с Интернетом,) с панели инструментов на поле окна.

MS Office отличает панели команд пользователя от редактированных панелей команд, существующих по умолчанию. MS Office позволяет привести в исходное состояние только существовавшие по умолчанию панели команд путем их сброса, в то время как панели команд пользователя могут быть удалены.

Чтобы удалить или сбросить панель команд нужно:

1. Открыть панель диалога Настройка и выбератье вкладку Панели инструментов.

2. Выбрать нужную панель инструментов из списка Панели инструментов.

3. Нажать Удалить.

4. Для восстановления панелей команд, существующих по умолчанию, выберать Сброс.

5. Нажать Да, чтобы подтвердить удаление или сброс панели.

Просмотр документов на экране

Окно приложения показывает только часть теста текущего документа. Для просмотра всего документа используются бегунки на вертикальной и горизонтальной линейках прокрутки, а также кнопки перемещения по страницам документа.

Справочная система Microsoft Office

Справка доступна для всех приложений Microsoft Office через меню Справка. Команды меню Справка обеспечивают различные режимы работы со справочной системой.

Выбрав команду Справка по (название приложения) или нажав клавишу F1, можно воспользоваться услугами помощника. По умолчанию Помощник появляется на экране.

Помощник может быть настроен по желанию пользователя (Функциональная клавиша F1 → кнопка Параметры → закладка Коллекция → закладка Параметры для задания необходимых параметров → кнопка ОК). Существуют девять типов помощника.

Для отключения помощника сбросьте флажок Использовать Помощника на вкладке Параметры.

В справке можно осуществить поиск, задав вопрос или по ключевому слову. Для этого нужно выберать меню Справка, затем – Справка по (название приложения), ввести вопрос в текстовое поле и нажать кнопку Найти.

Можно посмотреть содержание справочной системы.

Закладка Содержание представляет список тем справочной системы. Закладка Указатель приводит к списку ключевых терминов или фраз предметной области. Закладка Мастер ответов позволяет найти справку по запросу или по ключевому слову интересующей темы.

[На главную страницу]


Автоматизация ввода

вперед

конец

вопросы

задания

К средствам автоматизации ввода относятся автозавершение и автозаполнение.

Автозавершение. В ходе ввода текста в очередную ячейку программа проверяет соответствие введенных символов строкам, имеющимся в этом столбце выше. Если обнаружено однозначное совпадение, введенный текст автоматически дополняется. Нажатие клавиши Enter подтверждает операцию автозавершения, в противном случае ввод можно продолжать, не обращая внимания на предлагаемый вариант.

Автозаполнение константами. В правом нижнем углу рамки ячейки имеется черный квадратик – это маркер автозаполнения. При наведении на него курсор мыши вместо толстого белого креста принимает вид тонкого черного крестика. Перетаскивание маркера заполнения рассматривается как операция «размножения» содержимого ячейки в горизонтальном и вертикальном направлении.

Если ячейка содержит число, то при перетаскивании маркера происходит либо копирование ячеек, либо их заполнение данными по закону арифметической прогрессии. Для выбора способа автозаполнения применяется специальное перетаскивание по правой кнопке мыши. Например, ячейка А1 содержит число 1. Протяните маркер заполнения с помощью правой кнопки мыши с ячейки А1 до ячейки С1 и отпустите кнопку. Если в появившемся меню выбрать пункт Копировать, то во всех ячейках появится 1, если пункт Заполнить, то в ячейках окажутся числа 1, 2, 3.

Заполнение прогрессией. Чтобы точно сформулировать условия заполнения ячеек, следует выполнить команду Правка → Заполнить → Прогрессия. В открывшемся диалоговом окне Прогрессия выбирается тип прогрессии, величина шага и предельное значение.

ЗАДАНИЕ 2

Продолжите заполнение созданной книги, используя маркер автозаполнения для ячеек C3- D3; C11 - D11; C12 – D12. Измените формат представления данных в ячейках B5:D6; B10:D12 на денежный.

Сохраните книгу.


Автотекст и автозамена

конец

вопросы

задания

Автотекст – это режим автоматического ввода фрагментов текста. Текстовый процессор хранит словарь автотекста, состоящий из слов и фраз, встречающихся в документах довольно часто. При вводе первых четырех символов словарного элемента на экране появляется всплывающая подсказка с полным тестом слова или фразы. Если пользователь согласен, он завершает ввод всего фрагмента нажатием клавиши Enter – так работает функция автозавершения. Пользователь может самостоятельно выбрать необходимый элемент текста из списка – это функция автотекста. Список элементов автотекста открывается с помощью панели инструментов Автотекст (Вид → Панели инструментов → Автотекст)

Настройку словаря автотекста выполняют в диалоговом окне Автозамена (Сервис → Автозамена → Автотекст). Занести в словарь новое содержание можно: выделив текст на экране, затем щелкнув на кнопке Автотекст на Панели инструментов Автотекст и в открывшемся окне использовав кнопку Добавить.

Автозамена позволяет заменить ввод длинных последовательностей символов произвольным сочетанием (коротким) других символов. Настройку средства Автозамена выполняют в диалоговом окне Сервис → Автозамена.

Для этого нужно установить флажок Заменять при вводе, ввести заменяемую комбинацию в поле Заменить, а замещающую комбинацию в поле На, после чего пополнить список кнопкой Добавить.

ЗАДАНИЕ 7

Наберите слово инженер и то же слово с ошибкой (должно произойти автоматическое исправление ошибки). Наберите дробь ½, (уменьшение размера произойдет автоматически). Выполните автозамену аббревиатуры УГАТУ на Уфимский государственный авиационный технический университет.

Сохраните документ.


База данных

Использование электронных таблиц как баз данных

конец

вопросы

задания

Обычно базы данных представляют собой набор взаимосвязанных таблиц. Простейшие базы данных состоят из одной таблицы. В качестве такой базы данных вполне можно использовать списки электронной таблицы Excel. Программа Excel включает набор функций, позволяющих выполнять все основные операции, присущие базам данных.

Информация в базе данных состоит из набора записей, каждая из которых содержит один и тот же набор полей. Записи характеризуются порядковыми номерами, а каждое поле имеет заголовок, описывающий его назначение.

Чтобы список на рабочем листе рассматривался как база данных Excel, необходимо придерживаться строгих правил.

· Каждому полю записи соответствует один столбец рабочего листа. Столбцы базы данных должны идти подряд, без промежутков между ними.

· В первой строке каждого столбца (точнее, в той строке, с которой начинается база данных) должен быть указан заголовок соответствующего поля. Заголовок поля должен занимать не более одной ячейки. Содержимое ячейки заголовка должно быть уникально в пределах рабочего листа.

· Записи базы данных должны идти непосредственно ниже строки заголовков. Пустые строки не допускаются. Вообще, пустая строка рассматривается как признак окончания базы данных, то есть, записи должны идти подряд, без промежутков между ними.

В списках, оформленных таким образом, возможно выполнение большинства операций, характерных для баз данных.


Ввод данных

Ввод, редактирование и форматирование данных

конец

вопросы

задания

Типы данных

Отдельная ячейка может содержать данные: константы или формулы, а также оставаться пустой. Константы могут быть текстовыми, числовыми, логическими или ошибочными значениями. Тип данных, размещаемых в ячейках, определяется автоматически при вводе. Если данные можно интерпретировать как число, Exсel так и делает. В противном случае данные рассматриваются как текст. Текстовые данные по умолчанию выравниваются по левому краю ячейки, а числа – по правому. Ввод формулы всегда начинается с символа =.

Ввод текста и чисел

Ввод данных осуществляют непосредственно в текущую ячейку или в строку формул, располагающуюся в верхней части окна программы непосредственно под панелями инструментов. Место ввода отмечается текстовым курсором.

Если начать ввод нажатием алфавитно-цифровых клавиш, данные из текущей ячейки заменяются вводимым текстом. Если щелкнуть на строке формул или дважды на текущей ячейке, старое содержимое ячейки не удаляется и появляется возможность его редактирования. Вводимые данные отображаются в любом случае, как в ячейке, так и в строке формул. Для завершения ввода данных в ячейку используют клавишу Enter, для отмены ввода данных в ячейку – Esc. Для очистки текущей ячейки или выделенного диапазона проще всего использовать клавишу Delete.

ЗАДАНИЕ 1

Создайте новую книгу и заполните ее как показано ниже.

Сохраните книгу.

Форматирование содержимого ячеек

Числовые форматы. Для экономических расчетов применяют три разных формата записи чисел: обычный числовой, финансовый и формат даты.

Финансовый формат используется для записи денежных сумм, он отличается от числового указанием денежной единицы (например, р.) и фиксированным числом знаков после запятой. Кроме того, программа иначе подходит к округлению чисел в этом формате, чтобы в результате операций с очень большими суммами не потерялась ни одна копейка.

При записи даты можно выбирать разные варианты форматирования, но надо помнить о том, что любая дата это некоторое число, которое можно представить как количество миллисекунд прошедших с некоторой точки отсчета.

Текстовые форматы. Используют для записи текстовых строк и цифровых нечисловых данных (например, почтовых индексов, номеров телефонов и т.п.).

Изменение формата данных в ячейке. Чтобы изменить формат отображения данных в текущей ячейке или в выбранном диапазоне ячеек, используют команду Формат Ячейки. Вкладки открывающегося диалогового окна позволяют выбирать формат записи данных (количество знаков после запятой, указание денежной единицы, способ записи даты и прочее), задавать направление текста и метод его выравнивания, определять шрифт и начертание символов, управлять отображением и видом рамок, задавать фоновый цвет.


Выводы

Заключения и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены технологии работы с электронными таблицами в табличном процессоре Excel: создание и редактирование таблиц, расчеты по формулам, представление данных в виде различных диаграмм, решение задач с помощью электронных таблиц.

Были рассмотрены темы:

По результатам работы должен быть составлен отчет:

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Табличный процессор Excel

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Выводы

Заключения и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены технологии работы с базой данных в СУБД Access.

Были рассмотрены темы:

Создание Базы данных

Работа с таблицами

Создание межтабличных связей

Заполнение таблиц данными

Работа с формами, разработанными на основе таблиц

Редактирование формы

Поиск, сортировка и фильтрация в таблицах и формах

Однотабличные запросы на выборку

Многотабличные запросы на выборку

Формы на основе запросов

По результатам работы должен быть составлен отчет:

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

СУБД Access

Основные понятия реляционной БД

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Выводы

Заключения и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены технологии работы с базой данных электронной таблицы Excel, и создания макросов.

Были рассмотрены темы:

Использование электронных таблиц как баз данных

Заполнение базы данных

Поиск, корректировка, удаление записей

Сортировка базы данных

Фильтрация базы данных

Построение сводной таблицы

Построение сводных диаграмм

Создание макросов

По результатам работы должен быть составлен отчет:

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Табличный процессор Excel

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Выводы

Заключения и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены технологии подготовки и редактирования простых документов с помощью текстового процессора Microsoft Word.

В процессе выполнения лабораторной работы

Были рассмотрены темы:

· Первичные настройки текстового процессора Microsoft Word 2000

· Настройка параметров печатного документа

· Набор и выделение текста

· Форматирование текста:

Настройка шрифта и выбор метода выравнивания

Настройка параметров абзаца

· Средства создания маркированных и нумерованных списков

· Форматирование с помощью линейки

· Автотекст и автозамена

· Ввод специальных и произвольных символов

· Средства автоматизации проверки правописания

· Поиск и замена в документе Word

· Оформление текста в несколько столбцов

· Оформление текста рамками

· Работа с колонтитулами

· Сноски и перекрестные ссылки

· Создание оглавления

· Приемы и средства автоматизации разработки документов

Работа со стилями

Шаблоны

По результатам работы должен быть составлен отчет:

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Текстовый процессор Word

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Выводы

Заключения и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены технологии работы с базой данных в СУБД Access.

Были рассмотрены темы:

Запросы с параметром

Запросы с вычислением

Групповые операции

Перекрестные запросы

Запросы на изменение

Однотабличный отчет

Многотабличный отчет

Мастер отчетов

Кнопочная форма

По результатам работы должен быть составлен отчет:

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

СУБД Access

Основные понятия реляционной БД

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Выводы

Заключения и выводы

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены приемы создания комплексных текстовых документов, содержащих не только текст, но и встроенные объекты иной природы, с помощью текстового процессора Microsoft Word.

В процессе выполнения лабораторной работы

Были рассмотрены темы:

  • Особенности объектов Word.

  • Работа с таблицами.

  • Работа с диаграммами.

  • Ввод формульных выражений.

  • Создание художественных заголовков.

  • Использование графических объектов.

  • Работа с рисунками.

  • Работа с клипартами.

  • Работа с растровыми изображениями.

По результатам работы должен быть составлен отчет:

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы ( вопрос должен быть отражен в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Текстовый процессор Word

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Графика

Использование графических объектов

конец

вопросы

задания

В документы Microsoft Word можно вставлять два типа графических объектов: рисунки и изображения.

Рисунки — объекты векторной природы (линии, прямые и кривые, геометрические фигуры, стандартные и нестандартные). Простейшие средства для их создания и редактирования есть в самом текстовом процессоре. Рисунки всегда внедрены в документ.

Изображения — растровые объекты. Текстовый процессор не имеет средств для их создания, поэтому они вставляются как внешние объекты из файла, подготовленного другими средствами (графическим редактором, с помощью сканера, цифровой фотокамеры, графического планшета). Возможно только управление их положением и методом отображения с учетом яркости и контрастности.

Характерный пример растрового изображения — обычная фотография. Вся она состоит из точек, которые имеют уникальные свойства, такие как: координаты точки, размер точки, форма точки и цвет точки. Важнейшим свойством является цвет.

Характерный пример векторного изображения — чертеж. Он состоит из линий, имеющих уникальные и различимые свойства: толщину, цвет, форму, тип (сплошная, пунктирная и т. п.), заливку (если линия замкнутая). Форма линий играет решающую роль Точки в векторном изображении неразличимы


Групповые операции

Формирование сложных запросов. Групповые операции в запросах

конец

вопросы

задания

Для создания запросов с использованием групповых операций в бланк запроса включаются поля, по которым надо произвести группировку, и поля, по которым надо произвести итоговые (статистические) вычисления. Всего в Access предусматривается девять статистических функций:

Sum | сумма значений некоторого поля для группы
Avg | среднее от всех значений поля в группе
Max, Min | максимальное, минимальное значение поля в группе
Count | число значений поля в группе без учета пустых значений
StDev | среднеквадратичное отклонение от среднего значения поля в группе
Var | дисперсия значений поля в группе
First, Last | значение поля из первой или последней записи в группе

Далее можно нажать кнопку Групповые операции [image] или выполнить команда меню Вид → Групповые операции. В бланке запроса появится строка Групповая операция, в которой для нужного поля слово Группировка заменяется на необходимую статистическую функцию.

ЗАДАНИЕ 3.

Сконструируйте запрос с несколькими групповыми функциями: вычисление фактического числа студентов в группе и среднего проходного балла в группе.

Выполните запрос.

Сохраните запрос под именем Число студ. и сред.балл группы.


Диаграммы

Построение диаграмм и графиков

конец

вопросы

задания

В программе Excel термин диаграмма используется для обозначения всех видов графического представления числовых данных.

Диаграмма представляет собой вставной объект, внедренный на один из листов рабочей книги. Она может располагаться на том же листе, на котором находятся данные, или на любом другом листе. Диаграмма сохраняет связь с данными, на основе которых она построена, и при обновлении этих данных автоматически меняет свой вид.

Для построения диаграммы обычно используют Мастер диаграмм, запускаемый щелчком на кнопке Мастер диаграмм на стандартной панели инструментов [image] . Удобнее заранее выделить область, содержащую данные, которые будут отображаться на диаграмме, но задать эту информацию можно и в ходе работы мастера.

Выбор типа диаграммы

На первом этапе работы мастера выбирают форму диаграммы. Доступные формы перечислены в списке Тип на вкладке Стандартные. Для выбранного типа диаграммы справа имеется несколько вариантов представления данных, из которых следует выбрать наиболее подходящий. На вкладке Нестандартные отображается набор полностью сформированных типов диаграмм с готовым форматированием. После задания формы диаграммы следует щелкнуть на кнопке Далее.

Выбор данных

Второй этап работы мастера служит для выбора данных, по которым будет строиться диаграмма. Если диапазон данных был выбран заранее, то в области предварительного просмотра в верхней части окна мастера появится приблизительное отображение будущей диаграммы. Если данные образуют единый прямоугольный диапазон, то их удобно выбирать при помощи вкладки Диапазон данных. Если данные не образуют единой группы, то информацию для отрисовки отдельных рядов данных задают на вкладке Ряд. Предварительное представление диаграммы автоматически обновляется при изменении набора отображаемых данных.

Оформление диаграммы

Третий этап работы мастера (после щелчка на кнопке Далее) состоит в выборе оформления диаграммы. На вкладках окна мастера задаются:

· название диаграммы, подписи осей (вкладка Заголовки);

· отображение и маркировка осей координат (вкладка Оси);

· отображение сетки линий, параллельных осям координат (вкладка Линии сетки);

· описание построенных графиков (вкладка Легенда);

· отображение надписей, соответствующих отдельным элементам данных на графике (вкладка Подписи данных);

· представление данных, использованных при построении графика, в виде таблицы (вкладка Таблица данных).

В зависимости от типа диаграммы некоторые из перечисленных вкладок могут отсутствовать.

Размещение диаграммы

На последнем этапе работы мастера (после щелчка на кнопке Далее) указывается, следует ли использовать для размещения диаграммы новый рабочий лист или один из имеющихся. После щелчка на кнопке Готово диаграмма строится автоматически и вставляется на указанный рабочий лист.

ЗАДАНИЕ 6

На Листе 1 постройте диаграмму Прихода и расхода на 1 квартал.

Сохраните книгу.

Редактирование диаграммы

Готовую диаграмму можно изменить. Она состоит из набора отдельных элементов, таких, как сами графики (ряды данных), оси координат, заголовок диаграммы, область построения и прочее. При щелчке на элементе диаграммы он выделяется маркерами, а при наведении на него указателя мыши — описывается всплывающей подсказкой. Открыть диалоговое окно для форматирования элемента диаграммы можно через меню формат (для выделенного элемента) или через контекстное меню (команда Формат). Различные вкладки открывшегося диалогового окна позволяют изменять параметры отображения выбранного элемента данных.

Если требуется внести в диаграмму существенные изменения, следует вновь воспользоваться мастером диаграмм. Для этого следует выбрать диаграмму и, запустив мастер диаграмм, можно изменить текущие параметры, которые рассматриваются в окнах мастера, как заданные по умолчанию.

Чтобы удалить диаграмму, можно удалить рабочий лист, на котором она расположена или выбрать диаграмму, внедренную в рабочий лист с данными и нажать клавишу DELETE.

ЗАДАНИЕ 7

На Листе 3 постройте график функции [image] , х изменяется на отрезке [0,2] c шагом 0,2. Чтобы оформить подписи по оси Х, задайте на втором шаге работы с Мастером во вкладке Ряды диапазон изменения Х как Подписи оси Х.

Сохраните книгу.


Диаграммы

Работа с диаграммами

конец

вопросы

задания

Диаграммы являются удобным средством визуального представления данных и наряду с таблицами очень широко используются в отчетной документации. Для создания диаграмм текстовый процессор Microsoft Word имеет подключаемое средство Microsoft Graph. Соответственно, для процессора Microsoft Word 2000 используется программа Microsoft Graph 2000. Эта программа является внешним компонентом, и ее установка должна специально заказываться при установке текстового процессора.

Два метода создания диаграмм

Текстовый процессор Microsoft Word 2000 предоставляет два метода для вставки диаграмм в документ. Более общий метод основан на том, что сначала в документ вставляется произвольная базовая диаграмма, с которой связана некая базовая таблица данных. Создание диаграммы производится командой Вставка → Объект. В открывшемся диалоговом окне Вставка объекта следует выбрать пункт Диаграмма Microsoft Graph 2000, после чего в документ вставляется диаграмма, с которой связана некая базовая таблица. Ее ячейки следует заполнить собственными данными, причем заполнение можно автоматизировать путем импорта данных из какой-либо иной таблицы, например из таблицы Microsoft Excel.

Далее производится настройка диаграммы, которая состоит в настройке внешнего вида и в редактировании содержания.

Второй, частный метод, основан на том, что диаграмма создается на базе конкретной таблицы, уже имеющейся в документе (перед созданием диаграммы таблицу необходимо выделить). В этом случае настройка диаграммы состоит только в настройке внешнего вида.

Настройка внешнего вида диаграммы

Существует множество различных типов диаграмм и графиков, отличающихся способом визуального представления связанных с ними данных. Выбор типа диаграммы производят в диалоговом окне Тип диаграммы (Диаграмма → Тип диаграммы), которое имеет пару вкладок (для стандартных и нестандартных типов диаграмм).

Тип диаграммы выбирают в поле Тип, просматривая при этом внешний вид образца в поле Вид. Выбрав форму диаграммы, приступают к ее настройке. Настройка диаграммы состоит в выборе элементов оформления диаграммы и элементов представления данных и выполняется в диалоговом окне Параметры диаграммы (Диаграмма → Параметры).

Элементы представления данных — это точки на графиках, столбцы гистограмм, секторы круговых диаграмм — в общем, все то, что служит для непосредственного отображения данных. Элементы оформления — это название диаграммы, названия ее осей, «легенда» (специальное поле, в котором приведены условные обозначения для групп элементов данных), подписи к элементам данных и линии координатной сетки. Настройку выполняют подключением или отключением тех или иных элементов.

Элементы диаграммы бывают связанными или присоединенными. Присоединенные элементы можно редактировать, а связанные — нельзя. Так, например, название диаграммы, названия ее осей и легенду можно редактировать отдельно — это присоединенные элементы оформления. Подписи к элементам данных редактировать на диаграмме нельзя — они связаны со значениями в базовой таблице и потому считаются связанными элементами.

Для каждого из присоединенных элементов оформления можно выполнить индивидуальное форматирование. Для этого надо в поле диаграммы щелкнуть дважды на поле присоединенного элемента — откроется соответствующее диалоговое окно форматирования (Формат легенды, Формат оси, Формат названия диаграммы, Формат области построения и т. д.). Состав вкладок и других элементов управления этих диалоговых окон зависит от свойств конкретного присоединенного элемента. Так, например, средства форматирования осей диаграммы отличаются от средств форматирования ее названия.

ЗАДАНИЕ 3

В документе наберите следующий текст с диаграммами:

Сохраните документ.


Заголовки

Создание художественных заголовков

конец

вопросы

задания

Для создания художественных графических надписей, например заголовков, текстовый процессор Microsoft Word 2000 имеет специальное средство WordArt. Доступ к нему осуществляется через специальную панель инструментов WordArt (Вид → Панели инструментов → WordArt).

Ввод текста графического заголовка

Текст будущего заголовка можно ввести двумя разными способами: выделить любой фрагмент текста в документе и использовать его в качестве заготовки или ввести текст вручную. И в том и в другом случае надо использовать кнопку Добавить объект WordArt [image] . Если какой-то текст в документе был предварительно выделен, он будет передан программному средству WordArt, а если текст выделен не был, будет предоставлена возможность ввести его вручную.

В открывшемся диалоговом окне Коллекция WordArt выбирается необходимый стиль оформления.

Выбранный стиль утверждается щелчком на кнопке ОК, после чего открывается диалоговое окно Изменение текста WordArt. В этом окне можно ввести текст заголовка, отредактировать его, задать гарнитуру, размер и начертание шрифта. Избранные параметры утверждаются щелчком на кнопке ОК, и объект вставляется в документ.

Управление заголовком в составе документа

Для определения положения заголовка в документе следует открыть диалоговое окно Формат объекта WordArt, либо с помощью одноименной команды контекстного меню, либо с помощью одноименной командной кнопки на панели инструментов WordArt.

Прежде всего задаются параметры взаимодействия объекта с текстом (параметры обтекания). Затем задается местоположение объекта относительно страницы или текста. Далее настраивается размер объекта. Объекты WordArt отличаются от других объектов Word тем, что их размером можно управлять не только напрямую, но и изменением размера шрифта, использованного при подготовке надписи. Для объектов WordArt этот прием управления размером более предпочтителен.

Редактирование объекта WordArt в составе документа

Инструменты, необходимые для этого, представлены на панели инструментов WordArt. Они позволяют:

изменить текст заголовка | кнопка Изменить текст
изменить стиль оформления | кнопка Коллекция WordArt
изменить форму заголовка | кнопка Форма WordArt
повернуть изображение на произвольный угол | Кнопка Свободное вращение
изменить параметры цвета, свойства линий и характер взаимодействия с окружающим текстом | кнопка Формат объекта WordArt Кнопка Обтекание
задать равную высоту всех символов в заголовке — такое шрифтовое оформление текста называется капителью | кнопка Выровнять буквы WordArt по высоте
расположить текст по вертикали | кнопка Вертикальный текст WordArt
задать горизонтальное положение заголовка относительно страницы | кнопка Выровнять объект WordArt
изменить расстояния между символами без изменения глобальных размеров объекта | кнопка Межсимвольный интервал WordArt


Задания

Индивидуальные задания

конец

вопросы

задания

Расчет суммы ряда

ЗАДАНИЕ 8

На Листе 5 рассчитайте сумму конечного ряда, в соответствии с индивидуальным заданием.

Индивидуальные задания

Сохраните книгу.

Построение графиков

ЗАДАНИЕ 9

На Листе 5, в соответствии с индивидуальным заданием, протабулируйте функцию на отрезке с заданным шагом и постройте ее график.

Индивидуальные задания

Сохраните книгу.


Заполнение БД

Заполнение базы данных

конец

вопросы

задания

Заполнять базу данных можно обычным способом, переходя от ячейки к ячейке. Но Excel предлагает более простой способ ввода данных в базу – форму данных. Вначале обычным способом заполняется первая запись списка, затем активизируется одна из заполненных ячеек и с помощью команды меню Данные → Форма…, открывается окно диалога, которое включает поля ввода значений каждого поля, заполняемой базы. Заголовок окна содержит имя листа, в полях ввода - данные той записи, ячейку которой активизировали.

С помощью полосы прокрутки можно просмотреть уже заполненные записи. В правом верхнем углу формы указывается № просматриваемой записи. Для ввода новой записи нужно нажать кнопку Добавить. Поля ввода очистятся, в правом верхнем углу появится сообщение Новая запись. Для перехода от поля к полю можно использовать клавишу Tab. После ввода в поля всех данных нужно снова нажать кнопку Добавить. Новая запись добавиться в базу, а поля ввода вновь очистятся. Щелчок на кнопке Закрыть закрывает форму ввода. Если поле записи включает формулу, при просмотре это поле присутствует, но не активно, при вводе новой записи оно заполняется автоматически.

ЗАДАНИЕ 1

Создайте новую книгу. Создайте и заполните на первом листе базу данных Итоги сессии.

Поля списка: Специальность, № группы, № в группе, Фамилия, Математика, Физика, Информатика, Средний балл.

Записи списка: Две специальности по две группе в каждой, в каждой группе не менее пяти студентов.

Заполните базу данных оценками, полученными студентами в сессию.

Например, так

Назовите лист - Итоги сессии. Сохраните книгу.


Заполнение таблиц

Работа с таблицами. Заполнение таблиц данными

конец

вопросы

задания

Созданную таблицу открывают в окне База данных двойным щелчком на ее значке. Новая таблица не имеет записей – только названия столбцов, характеризующие структуру таблицы. Заполнение таблицы данными происходит обычным порядком. Курсор ввода устанавливается в нужную ячейку указателем мыши. Переход к следующей ячейке можно выполнить клавишей TAB. Переход к очередной записи выполняется после заполнения последней ячейки.

В нижней части таблицы расположена Панель кнопок перехода. Ее элементами управления удобно пользоваться при навигации по таблице, имеющей большое число записей.

Данные не всегда умещаются в ячейках таблицы. Шириной столбцов можно управлять методом перетаскивания их границ. Удобно использовать автоматическое форматирование столбцов «по содержимому». Для этого надо установить указатель мыши на границу между столбцами (в строке заголовков столбцов), дождаться, когда указатель сменит форму, и выполнить двойной щелчок.

После наполнения таблицы данными сохранять их не надо – все сохраняется автоматически. Однако, если при работе с таблицей произошло редактирование ее макета (изменялась ширина столбцов), СУБД попросит подтвердить сохранение этих изменений.

ЗАДАНИЕ 4

Заполните таблицы Группа, Кафедра, Предмет следующими данными:

Перед заполнением поля Фотография (тип поля объект OLE) подберите или создайте сами графические файлы (например, с расширением .BMP) с дружескими шаржами. При заполнении поля выполните команду меню Вставка → Объект, в появившемся окне отметьте Создать из файла и выберите с помощью кнопки Обзор нужный файл с фотографией. Увидеть содержимое этого поля можно только через Форму, Отчет или в графическом редакторе Paint, щелкнув дважды на поле.

При вводе данных в поле Программа (тип поля МЕМО) можно использовать специальную область ввода, вызываемую нажатием клавиш Shift + F2.


Запросы на изменение

Формирование сложных запросов. Запросы на изменение

конец

вопросы

задания

Запросы на изменение позволяют автоматизировать заполнение полей таблиц:

· за одну операцию внести изменения в несколько записей;

· удалить группу записей, удовлетворяющих заданным условиям, из одной или нескольких таблиц;

· внести общие изменения в группу записей одной или нескольких таблиц;

· добавить группу записей из одной или нескольких таблиц в конец одной или нескольких таблиц;

· создать новую таблицу на основе всех или части данных из одной или нескольких таблиц.

ЗАДАНИЕ 6.

Создайте запрос на отчисление студента гр. 102 Сидорова И.Р.

Для этого:

· на вкладке Запросы щелкните по кнопке Создать;

· выберите Простой запрос;

· выберите таблицу Студент, в ней выберите поля, ШГ (Шифр группы), НС (номер студента, ФИО

· щелкните по кнопке Далее, в появившемся окне введите имя запроса Отчисленные студенты;

· щелкните по переключателю Изменение структуры запроса;

· щелкните по кнопке Готово;

· в строке Условия отбора введите: в поле «ФИО» – Сидоров И.Р., в поле ШГ – 102;

· просмотрите удаляемую запись, щелкнув по кнопке [image] или выполнив команду Вид → Режим таблицы;

· если отчисляемый студент выбран правильно, то перейдите в режим конструктора, откройте пункт меню Запрос и выберите Удаление;

· закройте запрос;

· откройте форму Студенты и удостоверьтесь в удалении записи о студенте Сидорова И.Р.;

· закройте форму.

ЗАДАНИЕ 7.

Создайте запрос на создание таблицы Отличников.

Для этого:

· на вкладке Запросы щелкните по кнопке Создать;

· выберите Простой запрос;

· в таблице Студент выберите поля ФИО, ШГ, НС, а в таблице Успеваемость – поле Оценка;

· щелкните по кнопке Далее, затем в появившемся окне вновь щелкните по кнопке Далее;

· в появившемся окне введите имя запроса Отличники;

· щелкните по переключателю Изменение структуры запроса;

· щелкните по кнопке Готово;

Примечание. Для создания этого запроса надо воспользоваться операцией группировки. Будем считать отличниками тех студентов, которые набрали за четыре экзамена 20 баллов. Операция группировки позволит просуммировать оценки студентов по всем экзаменационным предметам.

· просмотрите создаваемую базу, щелкнув по кнопке [image] или выполнив команду Вид → Режим таблицы;

· перейдите в режим конструктора;

· выполните команду Запрос, Создание таблицы;

· введите имя таблицы Студенты-отличники и щелкните по кнопке ОК;

· подтвердите создание таблицы;

· закройте с сохранением запрос;

· откройте таблицу Студенты-отличники. Удостоверьтесь в ее правильности. Закройте таблицу.


Запросы с вычислением

Формирование сложных запросов. Вычисляемые поля в запросах

конец

вопросы

задания

Вычисляемые поля в запросах

Вычисляемое поле, включенное в запрос, позволяет получить новое поле с результатами вычисления только в таблице запроса и не создает полей в таблицах базы данных. Вычисляемое поле создается в пустой ячейке строки Поле. Туда записывается формула, по которой это поле будет вычисляться. Для изменения имени вычисляемого поля нужно установить курсор на поле, вызвать контекстное меню и выбрать команду Свойства. В открывшемся окне изменить строку Подпись.

ЗАДАНИЕ 2.

Сконструируйте запрос с вычисляемым полем на базе таблицы Предмет для получения информации о предметах, у которых общее число часов не совпадает с суммой часов лекций и практик. Обратите внимание на приведенный выше рисунок.

Выполните запрос.

Сохраните запрос под именем Разность часов по предмету.


Запросы с параметром

Формирование сложных запросов. Запросы с параметром

конец

вопросы

задания

При создании запросов, в которые входят конкретные значения, лучше использовать запросы с параметром. Для вызова окна ввода параметров, необходимо в Условии отбора в квадратных скобках указать имя вводимого параметра.

ЗАДАНИЕ 1.

Сконструируйте запрос с параметром на базе таблиц Студент Успеваемость Предмет для получения информации об оценках, полученных студентами конкретной группы по конкретному предмету. Обратите внимание на приведенный выше рисунок.

Выполните запрос.

Сохраните запрос под именем Запрос с параметрами.


Изображения

Работа с растровыми изображениями

конец

вопросы

задания

Команда для вставки таких объектов — Вставка → Рисунок → Из файла. По этой команде открывается стандартное диалоговое окно Добавить рисунок, в котором и производится выбор файла, содержащего изображение.

Выбор метода вставки. В текстовом процессоре Microsoft Word 2000 избранный рисунок можно вставить в документ тремя способами: внедрением, связыванием и внедрением со связыванием.

1. В первом случае объект войдет в документ и может транспортироваться вместе с ним.

2. Во втором случае объект останется по месту своего хранения, а в документ войдет только указатель на первоисточник.

3. В третьем случае объект войдет в документ, но его связь с первоисточником сохранится.

Выбор метода вставки выполняют в диалоговом окне Добавить рисунок. В его правом нижнем углу есть раскрывающийся список, в котором следует выбрать один метод из трех возможных.

Приемы управления визуализацией изображения и редактирования. В текстовом процессоре Microsoft Word 2000 имеются два средства управления тем, как отображается встроенное растровое изображение. Первое средство внутреннее, а второе — внешнее, подключаемое при установке программы. Внутреннее средство представлено элементами управления панели инструментов Настройка изображения (Вид → Панели инструментов → Настройка изображения).

Кнопка

Действие

Увеличить контрастность, Уменьшить контрастность

Увеличить яркость, Уменьшить яркость

Обрезка

Установить прозрачный цвет

ЗАДАНИЕ 8

Вставьте в документ стандартный рисунок установка.bmp, находящийся в папке Windows. Разместите на нем текст, как показано на рисунке; используя панель Настройка изображения настройте яркость и контрастность изображения, чтобы текст был виден хорошо.

Сохраните документ.

Работа с растровыми изображениями

Внешним средством редактирования изображений является графический редактор Microsoft Photo Editor 3.0. Он должен быть подключен при установке Microsoft Word 2000.

ЗАДАНИЕ 9

Все вставленные графические объекты расположите на одной странице, она будет последней в документе. Ориентацию этой страницы сделайте альбомной и поменяйте Верхний колонтитул: вместо Работа с текстом наберите Работа с графикой.

Сохраните документ.

ЗАДАНИЕ 10

Перестройте оглавление полученного документа, расположив его в конце документа. Оно должно принять вид:

Сохраните документ.


Инд_задание_1

Рассчитать сумму конечного ряда

№ п.п

Ряд

№ п.п

Ряд

№ п.п

Ряд


Инд_задание_2

Протабулировать функцию на отрезке с заданным шагом и построить ее график

№ п.п
Функция

Границы отрезка и шаг

1.

[2,3] 0,1

2.

[0,2] 0,2

3.

[0,4;1] 0,05

4.

[0;1] 0,1

5.

[1;2] 0,1

6.

[2;4] 0,2

7.

[0;1] 0,1

8.

[0;0,8] 0,05

9.

[1;2] 0,1

10.

[0;0,85] 0,05

11.

[0,5;1] 0,05

12.

[1;3] 0,2

13.

[1;3] 0,2

14.

[0;1] 0,1

15.

[1;2] 0,1

16.

[0;1,5] 0,15

17.

[3;4] 0,1

18.

[1,2;2] 0,08

19.

[0;1] 0,1

20.

[1;3] 0,2

21.

[2;3] 0,1

22.

[0;1] 0,1

23.

[1;2] 0,1

24.

[1;2] 0,1

25.

[0,2;1] 0,05

26.

[2;3] 0,1

27.

[-1;0] 0,1

28.

[0,4;1] 0,05

29.

[2;3] 0,1

30.

[0;1] 0,1


Инд_задание_2

Обработка табличных даннных

Вариант | Содержание задания
1 | Составить таблицу успеваемости 5 студентов группы в экзаменационную сессию (4 экзамена). Определить средний балл для каждого студента и средний балл для группы по каждому предмету. Построить гистограмму средних баллов по предметам.
2 | Составить таблицу результатов наблюдений за погодой в течении недели. Ежесуточно фиксируются: максимальные и минимальные значения температуры воздуха и атмосферного давления. Определить среднесуточные значения температуры воздуха и атмосферного давления, а также средние показатели за неделю. Построить круговую диаграмму среднесуточной температуры
3 | Составить таблицу изменения курса иностранных валют - доллара США и немецкой марки по отношению к рублю в течении года. В таблицу включить данные на 1-е число каждого месяца. Определить максимальное, минимальное и среднее в течение года значения курса иностранных валют. Построить линейный график изменения доллара США в течение года.
4 | Составить таблицу, содержащую сведения об имеющейся на складе компьютерной технике - компьютеры, мониторы, принтеры, сканеры, указав наименование товара, его количество, цену и стоимость в рублях и долларах США. Курс доллара США задать в отдельном поле таблицы. Определить общую стоимость всех товаров. Построить гистограмму стоимости различных групп товаров.
5 | Составить таблицу выполнения плана выпуска 2-х наименований продукции на предприятии в течение года. В таблицу вносить показатели: план и фактический выпуск продукции на последнее число каждого месяца. Определить ежемесячное и среднегодовое отклонение от плановых показателей в процентах, а также общий плановых и фактически выполненный объем выпуска продукции. Построить гистограмму ежемесячного выпуска продукции.
6 | Составить таблицу продажи в магазине 4-х наименований товаров (молоко, масло, сметана, кефир) в течение недели. Ежедневно фиксируются количество, цена и рассчитывается стоимость проданного товара. Определить общую стоимость каждого проданного за неделю наименования товара и ее процент к общей стоимости. Построить круговую диаграмму, отражающую процент выручки от продажи каждого наименования товара за неделю.
7 | Составить таблицу годового семейного бюджета, указав по месяцам: общий доход, оплату за квартиру, оплату за питание, прочие расходы, остаток средств. Определить значения указанных статей бюджета в процентах к общему доходу для каждого месяца и за год. Построить гистограмму ежемесячных затрат на питание.
8 | Составить таблицу расчета заработной платы за год для 5 сотрудников предприятия, указав по каждому месяцу: начисленную повременную оплату, удержанный подоходный налог (13%), доплату по уральскому коэффициенту (15%), профсоюзные взносы (1%), сумму, выдаваемую сотруднику. Определить указанные статьи бюджета за год. Построить диаграмму структуры годового бюджета по указанным статьям.


Итоговые вычисления

Вычисления в электронных таблицах. Итоговые вычисления

конец

вопросы

задания

Итоговые вычисления

Итоговые вычисления предполагают получение числовых характеристик, описывающих определенный набор данных в целом. Например, возможно вычисление:

· суммы значений элементов, входящих в набор,

· среднего значения и других статистических характеристик,

· количества или доли элементов набора, удовлетворяющих определенных условиям

Особенность итоговых функций состоит в том, что при их задании программа пытается «угадать», в каких ячейках заключен обрабатываемый набор данных, и задать параметры функции автоматически.

В качестве параметра итоговой функции чаще всего задается прямоугольный диапазон ячеек, размер которого определяется автоматически. Выбранный диапазон рассматривается как отдельный параметр («массив»), и в вычислениях используются все ячейки, составляющие его.

Наиболее типичная из функций, предназначенных для итоговых вычислений, — это функция суммирования (СУММ), для применения которой есть отдельная кнопка на стандартной панели инструментов (кнопка Автосумма [image] ).

ЗАДАНИЕ 5

Перейдите на Лист 2. Вычислите сумму конечного ряда [image] при n=5, должен получиться результат

Сохраните книгу.


Клипарты

Работа с рисунками. Клипарты

конец

вопросы

задания

Существуют готовые библиотеки (коллекции) рисунков (клипартов), в том числе и тематические. Они распространяются на отдельных компакт-дисках, их можно найти в Интернете, но базовая, простейшая коллекция может быть установлена вместе с текстовым процессором — она входит в комплект поставки пакета Microsoft Office 2000.

Для вставки клипартов используют команду Вставка → Рисунок → Картинки. Соответствующая кнопка имеется и на панели инструментов Рисование [image] . Открывающееся при этом диалоговое окно называется Вставка картинки.

Графические клипарты сосредоточены на вкладке. Они классифицированы по категориям. Разыскав нужный клипарт, достаточно выделить его и вставить в документ щелчком на кнопке Вставить клип.

Клипарты — это композиционные объекты. Их можно «разбирать» на составляющие, редактировать их элементы по отдельности, создавать композиции из объектов, взятых из разных клипартов. Все это выполняется путем редактирования.

Обычный порядок редактирования клипартов следующий:

· клипарт выделяют щелчком левой кнопки мыши;

· открывают его контекстное меню щелчком правой кнопки;

· в контекстном меню выбирают команду Изменить рисунок — он открывается в отдельном окне редактирования;

· в этом окне работают с отдельными объектами, составляющими рисунок.

Комбинирование объектов, принадлежащих разным клипартам, выполняют путем копирования через буфер обмена Windows (CTRL+C и CTRL+V). При создании новых объектов из готовых клипартов часто приходится изменять размер итогового рисунка. Простейший способ для этого — воспользоваться кнопкой Восстановить границы рисунка на панели инструментов Изменение рисунка. Более правильное название этой кнопки — Подогнать поля, поскольку при этой операции происходит подгонка границ рисунка по размеру содержимого.

Специальные средства оформления. Эти средства оформления представлены кнопками на панели инструментов Рисование. Они позволяют:

управлять цветом заливки, цветом контура и цветом текста;

управлять толщиной сплошных линий и параметрами штриховых линий;

преобразовывать линии в стрелки и управлять формой их концов;

создавать теневые эффекты;

создавать трехмерные эффекты

ЗАДАНИЕ 6

Создайте следующую надпись, используя объекты рисования и WordArt: Сохраните документ. | Работа с клпартами и объектами WordArt
Создайте следующие графические объекты: Сохраните документ. |

ЗАДАНИЕ 7

В начало документа вставьте рисунок и следующий текст:

Форматирование и обрамление сделайте с помощью таблицы.

Сохраните документ.


Кнопочная форма

Создание кнопочного меню

конец

вопросы

задания

Создание кнопочного меню

Кнопочная форма-меню создается для быстрого доступа к созданным формам и отчетам.

Для создания кнопочного меню необходимо реализовать следующие действия:

· выполнить команду Сервис → Служебные программы → Диспетчер кнопочных форм;

· подтвердить создание кнопочной формы, щелкнув по кнопке Да;

· создать свою страницу кнопочной формы, щелкнув по кнопке Создать в окне Диспетчера кнопочных форм;

· ввести имя в появившемся диалоговом окне Создание, например Меню и щелкнуть по кнопке ОК;

· в окне Диспетчера кнопочных форм выбрать созданную страницу Меню и щелкнуть по кнопке Изменить;

· далее в окне Изменение страницы кнопочной формы создаются ее элементы с помощью кнопки Создать;

Для каждого элемента вводится текст, поясняющий его действие, это делается в строке Текст, в строке Команда из списка выбирается действие, которое будет происходить при нажатии этого элемента-кнопки, в строке Форма указывается имя формы или отчета, с которым будет происходить действие, указанное в строке Команда. Далее нажимается кнопка ОК.

· После определения всех элементов кнопочной формы окно изменения закрывается кнопкой Закрыть;

· Перед закрытием Диспетчера кнопочных форм кнопкой Закрыть нужно выбрать созданную страницу и щелкнуть по кнопке По умолчанию;

· Появившуюся на вкладке Формы форму с именем Switchboard следует переименовать, например, назвать ее Форма-меню;

· Далее нужно открыть эту форму и просмотреть ее возможности. Для возврата из любой открытой формы или отчета в меню достаточно закрыть их.

Примечание. Диспетчер напрямую может связать кнопку с открытием формы или отчета. Чтобы открыть таблицу или запрос, надо создать соответствующий макрос и указать его имя в диспетчере.

ЗАДАНИЕ 13.

Создайте кнопочную форму, которая включает работу со всеми созданными формами и отчетами.


Колонки

Оформление текста в несколько столбцов

конец

вопросы

задания

В газетах и некоторых книгах (обычно в словарях, энциклопедиях) информацию нередко представляют в несколько столбцов.

Для начала, текст вводится обычным образом, затем его выделяют и открывают командой Формат → Колонки диалоговое окно Колонки или нажимают на кнопку [image] Панели инструментов.

На панели Тип можно выбрать стандартный вариант размещения колонок, если число колонок задается с помощью счетчика на панели Ширина и промежуток выбирают размеры колонок и зазоров между ними. Флажок Разделитель позволяет отделить столбцы друг от друга вертикальной линией. Раскрывающийся список Применить указывает, какую часть документа следует разбить на столбцы.

ЗАДАНИЕ 10

В созданном документе, наберите и отформатируйте следующий текст (размер шрифта 12, примените разбивку на колонки):

Сохраните документ.


Контрольные вопросы

конец

вопросы

задания

1. Опишите структуру типового интерфейса электронной таблицы.

2. Перечислите и поясните основные типы входных данных, которые могут быть введены в ячейки электронной таблицы.

3. Поясните основные режимы работы электронной таблицы.

4. Какие типы данных могут содержать электронные таблицы Exсel?

5. Перечислите и поясните существующие форматы представления числовых данных в ячейках электронной таблицы.

6. Перечислите и поясните существующие форматы представления символьных данных в ячейках.

7. Как защитить содержимое ячеек электронной таблицы от несанкционированного доступа и внесения изменений?

8. Как сделать, чтобы текстовые данные, содержащиеся в ячейке, полностью помещались бы по ширине столбца?

9. Что такое маркер заполнения?

10. Что такое формула в электронной таблице и ее типы. Приведите примеры.

11. Как просмотреть и отредактировать формулу, содержащуюся в ячейке?

12. Что такое функция в электронной таблице и ее типы. Приведите примеры.

13. Поясните очередность выполнения операций в арифметических формулах.

14. Как указывается блок (диапазон) ячеек при выполнении какой-либо команды?

15. Поясните, для чего используются абсолютные и относительные адреса ячеек.

16. В чем смысл правил автоматической настройки формул при выполнении операций копирования и перемещения?

17. Покажите на примерах все возможные варианты автоматического изменения адресов в формулах при выполнении операции копирования.

18. Покажите на примерах все возможные варианты автоматического изменения адресов в формулах при выполнении операции перемещения.

19. Расскажите о назначении каждой из основных групп команд электронной таблицы. Приведите примеры типовых команд.

20. Укажите, какие вы знаете типы диаграмм, используемых для интерпретации данных электронных таблиц. Поясните, когда следует ( или не следует) использовать каждый из них.

  21. Перечислите и поясните содержание основных технологических этапов работы с электронной таблицей.


Контрольные вопросы

конец

вопросы

задания

1. Для чего предназначены запросы?

2. Как называется категория запросов, предназначенная для выбора данных из таблиц базы?

3. Как называется бланк, заполнением которого создается структура запроса?

4. Как называется категория запросов, выполняющих итоговые вычисления?

5. Какие итоговые функции вы знаете?

6. Как внести в бланк запроса строку для группировки данных по какому-либо признаку, чтобы выполнить итоговые вычисления?

7. Как сделать четыре итоговых вычисления по одному полю?

8. Как с помощью запроса провести сортировку записей в таблице по какому-либо полю?

9. Для чего предназначены Формы?

10. Какие методы автоматического создания форм вы знаете?

11. Из чего состоят формы?

12. Какие разделы форм вы знаете?

13. Как изменить местоположение присоединенной надписи элемента управления формы?

14. Какой командой можно выровнять элементы управления формы?

15. Как называются элементы управления формы позволяющие выбирать часто повторяющиеся данные из заранее подготовленного списка?

16. Можно ли использовать Формы для вывода данных? Если да, то на какое устройство компьютера?

17. Для чего предназначены Отчеты?

18. Куда происходит вывод данных при работе отчета?

19. Из чего состоят отчеты?

20. Какие разделы отчетов вы знаете?

21. Что общего и в чем различие между разделами отчетов и разделами форм?

22. Какие способы автоматической генерации отчетов вы знаете?

23. На базе чего выполняется отчет?

24. С какими объектами кроме таблиц, запросов, форм и отчетов работает СУБД Access? Для чего они предназначены?


Контрольные вопросы

конец

вопросы

задания

1. Назначение текстового процессора.

2. Из каких структурных элементов состоит интерфейс текстового процессора?

3. Чем отличаются режимы вставки и замены?

4. Расскажите суть операций копирования, перемещения и удаления фрагмента текста.

5. Какова роль буфера промежуточного хранения?

6. Для чего нужна операция откатки?

7. Какова роль окон в организации работы с текстом?

8. Для каких целей производится выделение фрагментов текста?

9. Что составляет минимальный набор типовых операций?

10. Дайте характеристику известного вам варианта расширенного набора типовых операций.

11. В чем сущность режима нахождения и замены?

12. Как производится проверка правописания слов?

13. Для какой цели и как используется словарь синонимов?

14. В чем сущность режима проверки синтаксиса и стиля?

15. Как и для какой цели производится форматирование документа?

16. Каково соотношение физической и логической страницы?

17. В каких случаях используются колонтитулы?

18. Расскажите о возможностях текстового процессора по автоматизации технологии работы.

19. Какие параметры шрифтов вам известны?

20. В чем преимущества использования шаблонов?

21. Что общего и в чем отличия текстовых процессоров и текстовых редакторов?

22. Какие текстовые процессоры и текстовые редакторы вы знаете?

23. В чем разница между текстовым курсором и указателем мыши?

24. Какие средства управления положением курсора вы знаете?

25. Какие режимы представления документа на экране имеет программа Word? В каких случаях применяются эти режимы?

26. В чем состоит редактирование текста? Какие приемы редактирования вы знаете?

27. Относятся ли средства отмены действия ошибочных команд к средствам редактирования? Какие приемы отмены действия команд в текстовом процессоре Word вы знаете?

28. В чем состоит форматирование текста? Какие приемы форматирования вы знаете?

29. Что такое список? Какие виды списков вы знаете?

30. Относятся ли средства создания таблиц к средствам форматирования документов?

31. Какое средство представляет Word для того, чтобы все однотипные абзацы в документе форматировались одинаково?

32. Как с помощью всего двух щелчков кнопками мыши узнать, в чем заключается ошибка, при автоматизированной проверке грамматической и орфографической правильности текстов?

33. Для чего предназначен текстовый процессор в интегрированном пакете MS Office?

34. Как создать новый документ и сохранить его на диске?

35. Как загрузить для редактирования ранее сохраненный файл?

36. Как скопировать в существующий документ информацию из другого документа?

37. Что такое абзац и какими параметрами он характеризуется?

38. Что понимается под выравниванием абзаца?

39. За счет чего выполняется выравнивание текста по ширине абзаца?

40. Для чего нужны табуляторы и как их использовать?

43. Как отформатировать отдельные абзацы документа различными способами?

44. Как выполнить форматирование фрагментов документа с использованием простых форматов?

45. Для чего нужна "Специальная вставка..."?

46. Какие символы называются специальными, можно ли их увидеть в тексте документа?

47. Как найти и заменить в документе фрагмент текста?

48. Как заключить фрагмент текста в рамку?

49. Как изменить параметры шрифта в тексте документа?

50. Как включить в текст документа графические объекты: картинки, рисунки, формулы, фигурный текст WordArt.

51. Для чего нужны колонтитулы?

52. Как вставить в документ верхние и нижние колонтитулы?

53. Как разбить текст на страницы, установив предварительно размеры страниц, их границы и ориентацию?

54. Какие режимы работы с документом предусмотрены в текстовом процессоре MS Word?

55. Как напечатать текст, используя режим предварительного просмотра?


Контрольные вопросы

конец

вопросы

задания

1. Какие данные называются структурированными?

2. Дайте определение и опишите назначение базы данных.

3. Дайте определение и опишите назначение системы управления базой данных.

4. Поясните, в чем заключается различие архитектур баз данных, организованных по принципу клиент-сервер и файл-сервер.

5. Назовите и поясните взаимосвязь структурных элементов базы данных.

6. Дайте понятие ключа. Какие виды ключей вы знаете?

7. Какие характеристики указываются при описании структуры базы данных и каково назначение такого описания?

8. Данные каких типов могут храниться в полях базы данных?

9. Какие модели данных вы знаете?

10. Поясните назначение ключевых полей в реляционной базе данных.

11. Что называется инфологической моделью предметной области?

12. Какие виды связей между объектами вам известны?

13. В чем заключается принцип нормализации отношений?

14. Поясните, каким требованиям должны отвечать отношения, находящиеся в первой, второй и третьей нормальной формах.

15. Каковы основные функциональные возможности СУБД?

16. Какие команды выполнения типовых операций в среде СУБД вы знаете?

17. Назовите и охарактеризуйте основные этапы технологического процесса обработки информации с использованием СУБД.

18. В каких объектах хранятся данные базы?

19. Чем отличаются поля и записи таблицы?

20. Какие типы полей вы знаете?

21. Какое поле можно считать уникальным?

22. Каким должно быть поле первичного ключа?

23. Какую базу данных называют реляционной?

24. В каком диалоговом окне создают связи между полями таблиц БД?


Копирование

Копирование содержимого ячеек

конец

вопросы

задания

Копирование и перемещение ячеек можно осуществлять методом перетаскивания или через буфер обмена.

Для использования метода перетаскивания следует навести указатель мыши на рамку текущей ячейки или выделенного диапазона (он примет вид стрелки), а затем перетащить в любое место рабочего листа. Для выбора способа выполнения операции (копировать или перемещать) следует использовать правую кнопку мыши. При использовании левой кнопки мыши происходит перемещение данных, если при этом нажать кнопку CTRL, то копирование.

Копирование и перемещение данных через буфер обмена происходит аналогично с другими Windows программами, но надо помнить, что вставка данных возможна лишь немедленно после помещения их в буфер обмена. Попытка выполнить любую другую операцию приводит к отмене начатого процесса копирования или перемещения.

ЗАДАНИЕ 3

Скопируйте диапазон ячеек A2:D15 методом перетаскивания, исправьте данные для второго квартала.

Сохраните книгу.


Макросы

Создание макросов

конец

вопросы

задания

Макросы – это маленькие программы, которые заставляют выполнять Excel определенную последовательность действий.

Предположим, в некоторой таблице постоянно приходится форматировать диапазон ячеек определенным образом: располагать содержимое по центру, обрамлять рамкой, выравнивать ширину. Если делать это вручную, уходит слишком много времени. Но эти действия можно записать и выполнять одним щелчком мыши или нажатием комбинации клавиш. Форматирование ячеек пример самого простого макроса. Макрос в один момент может выполнять множество действий, как простых, так и сложных.

ЗАДАНИЕ 6

Создайте в книге по итогам сессии макрос по форматированию ячеек, следуя указаниям, описанным ниже.

Запись макроса. Перейдем на чистый лист, чтобы не испортить случайно лист с заполненными данными. Щелкнем на ячейке, например В2, в выберем команду меню Сервис → Макрос → Начать запись. На экране появится окно диалога

В поле Имя макроса введем ФорматЯчейки, в поле Описание введем Форматирует выделенные ячейки, выравнивает содержимое по центру, устанавливает границу и выравнивает ширину. Этот макрос должен форматировать не одну ячейку, поэтому сделаем его доступным в любое время. Для этого раскроем список Сохранить в: и выберем в нем Личная книга макросов, указав тем самым, что макрос будет глобальным. Щелчком на кнопке ОК начнем запись.

· Щелкнем на ячейке правой кнопкой мыши, в появившемся контекстном меню выберем команду Формат ячеек, в появившемся диалоговом окне перейдем на вкладку Выравнивание в списке по горизонтали выберем По центру, перейдем на вкладку Границы и нажмем кнопку Внешние, нажмем кнопку ОК.

· В меню Формат, выберем команду Столбец, а затем Автоподбор ширины.

· Остановим запись макроса командой Сервис → Макросы → Остановить запись или, нажав соответствующую кнопку на панели макросов [image] .

ЗАДАНИЕ 7

Проверьте выполнение макроса на записях одной группы, следуя указаниям, описанным ниже.

Выполнение макроса. Перейдем на лист Итоги сессии, выделим диапазон ячеек. Выберем в меню команду Сервис → Макрос → Макросы, в появившемся диалоговом окне выберем созданный макрос и нажмем кнопку Выполнить.

Хранение макросов. Макросы хранятся на специальном листе модулей, он похож на обычный лист, но его единственное назначение хранить макросы. Лист модулей может быть сохранен в книге, с которой мы работаем в данный момент, или в Личной книге макросов. Место хранения макросов указывается перед записью. Макрос, сохраненный в текущей книге, является локальным и доступен только для этой книги. Макрос, сохраненный в Личной книге макросов, является глобальным и доступен для любой открытой книги.

Отображение программы макроса. Откроем макрос ФорматЯчейки. Для этого, с помощью команды меню Окно → Отобразить…, откроем окно диалога Вывод на экран скрытого окна книги, где выберем книгу Personal. Excel выведет книгу с единственным листом. С помощью команд меню Сервис → Макрос → Макросы… откроем список макросов, выберем нужный: ФорматЯчейки и щелкнем на кнопке Изменить. Запустится VisualBasic, в одном из его окон приведен текст макроса.

Просмотрите этот текст и закройте VisualBasic.

Назначение макросу команды меню, кнопки, комбинации клавиш.

Макросу можно назначить комбинацию клавиш, при нажатии которых он будет выполняться.

ЗАДАНИЕ 8

Назначьте макросу комбинацию клавиш, следуя указаниям, описанным ниже. Проверьте выполнение макроса на записях другой группы.

Для этого командой меню Сервис → Макрос → Макросы, вызовем окно диалога, в котором отметим нужный макрос и нажмем кнопку Параметры… , в котором зададим один из 26 символов латинского алфавита. Нажмем ОК, а затем закроем окно диалога.

Назначим макросу команду меню.

ЗАДАНИЕ 9

Назначьте макросу команду меню, следуя указаниям, описанным ниже. Проверьте выполнение макроса на записях другой группы.

Для этого откроем командами меню Сервис → Настройка окно диалога, перейдем на вкладку Команды, в списке категорий найдем категорию Макросы, в правом окне выделим команду Настраиваемая команда меню и добавим перетаскиванием эту команду в меню Сервис после команды Макросы.

Нажмем правую кнопку мыши, в контекстном меню изменим поле Имя на По центру, рамка, автовыравнивание и нажмем клавишу Enter. Выберем еще раз, в появившемся диалоговом окне назначим макрос ФорматЯчейки и закроем окно Настройка.

Назначим макросу кнопку.

ЗАДАНИЕ 10

Назначьте макросу кнопку, следуя указаниям, описанным ниже. Проверьте выполнение макроса на записях другой группы.

Сохраните книгу.

Для этого откроем командой меню Сервис → Настройка окно диалога, перейдем на вкладку Команды, в списке категорий найдем категорию Макросы, в правом окне выделим команду Настраиваемая кнопка и отбуксируем ее на панель инструментов, в контекстном меню, открытом правой кнопкой мыши, в поле Имя введем новое – По центру, рамка, автовыравнивание. Выберем в контекстном меню команду Назначить макрос, в появившемся окне диалога выберем нужный макрос и щелкнем на кнопке ОК. Закроем окно Настройка.

Создание плавающей кнопки для макроса. Такую кнопку можно привязать к определенной части листа. Откроем панель инструментов Формы,

щелкнем на кнопке [image] и нарисуем кнопку на незанятой части листа, в открывшемся окне диалога назначим нужный макрос и нажмем кнопку ОК. Пока нарисованная кнопка выделена, можно изменить ее размер, название и шрифт. Назовем кнопку Формат ячеек и щелкнем мышкой на листе за пределами кнопки.


Мастер отчетов

Формирование отчетов. Создание отчетов с помощью Мастера отчетов

начало

назад

вперед

конец

вопросы

задания

Создание отчета на основе запроса с помощью Мастера отчетов

ЗАДАНИЕ 12.

Создайте отчет Итоги сессии, следуя указаниям, описанным ниже:

Просмотрите его, сделайте исправления в режиме Конструктора. Сохраните.

Вначале создайте запрос Итоги сессии. Для этого:

· на вкладке Запросы щелкните по кнопке Создать;

· выберите Простой запрос и щелкните по кнопке ОК;

· из таблицы Студент выберите поля «Фамилия», «Шифр группы», из таблицы Предмет – поле «Название предмета», из таблицы Успеваемость – поле «Оценки» и щелкните по кнопке Далее;

· щелкните еще раз по кнопке Далее;

· введите название запроса Итоги сессии и щелкните по кнопке Готово;

· закройте запрос.

Для создания итогового отчета выполните следующее:

· на вкладке Отчеты щелкните по кнопке Создать;

· выберите Мастер отчетов, из раскрывающегося списка – запрос Итоги сессии и щелкните по кнопке ОК;

· выберите все поля запроса [image] и щелкните по кнопке Далее;

· тип представления данных нас удовлетворяет, поэтому щелкните по кнопке Далее;

· добавьте уровень группировки по номеру группы, выбрав в левом окне ШГ и перенеся его в правое окно, щелкнув по кнопке [image] ;

· щелкните по кнопке Далее;

· щелкните по кнопке Итоги, так как надо вычислять средний балл;

· поставьте "галочку" в ячейке поля «AVG» (эта функция вычисляет среднее) и щелкните по кнопке ОК;

· щелкните по кнопке ОК, так как сортировка не требуется, потому что данными являются название дисциплины и оценки, порядок которых не столь важен;

· выберите макет отчета. Лучше ступенчатый, так как он занимает меньше места и в нем наглядно представлены данные. Щелкните по кнопке Далее;

· выберите стиль отчета и щелкните по кнопке Далее;

· введите название отчета Итоги сессии и щелкните по кнопке Готово.

На экране появится отчет. Его можно просмотреть, изменяя масштаб (щелкнув по листу) и перелистывая страницы в нижней части экрана. После завершения необходимых вам операций закройте окно просмотра отчета.


Многотабличные запросы

Запросы. Многотабличные запросы на выборку

конец

вопросы

задания

Многотабличные запросы на выборку. При создании запроса на основе нескольких взаимосвязанных таблиц в бланк запрос, необходимо поместить все участвующие в запросе таблицы.

ЗАДАНИЕ 13.

Сконструируйте запрос на базе таблиц Студент Успеваемость Предмет для получения информации об оценках, полученных студентами по всем предметам. Обратите внимание на приведенный выше рисунок.

Выполните запрос.

Сохраните запрос под именем Успеваемость студентов.

ЗАДАНИЕ 14.

Сконструируйте запрос на базе таблиц Студент Успеваемость Предмет для получения информации об оценках, полученных конкретными студентами по всем предметам.

В строках Условие отбора запишете фамилии конкретных студенток, в одной “Макова Н.В.”, а в другой “Боярская*” (* вместо инициалов, если они неизвестны). Обратите внимание на приведенный выше рисунок.

Выполните запрос.

Сохраните запрос под именем Успеваемость двух студентов.


Многотабличный отчет

Формирование отчетов. Отчет из нескольких таблиц

конец

вопросы

задания

Создание отчета в режиме конструктора для нескольких таблиц

ЗАДАНИЕ 11.

Откройте отчет Список кафедр в режиме Конструктора. Разместите рядом на экране окно БД, перейдите в него, выберите отчет Преподаватели и перетащите этот отчет в область данных отчета Кафедра.

Просмотрите отчет.

Сделайте корректировки согласно модели

Сохраните отчет под именем Список преподавателей кафедр.


Набор и выделение текста

конец

вопросы

задания

По мере ввода символов маркер конца файла сдвигается вниз. Вводимый пользователем текст отображается на экране, что позволяет видеть ошибки и исправлять их.

Если введенный текст достигает маркера правого поля, то он автоматически переносится на следующую строку; при этом для создания новой строки не требуется нажимать клавишу ENTER. Если окно документа слишком узкое и в нем не виден маркер правого поля, то по мере ввода символов изображение документа прокручивается вправо до тех пор, пока не будет достигнута правая граница документа.

Процесс ввода текста документа, исправления текста, вставки графических объектов, выполнения операций копирования, удаления и перемещения называется редактированием документа.

Перед началом редактирования Вы должны выделить информацию, которую собираетесь редактировать. Выделение – это способ указать MS Word, какую именно область документа следует обработать. При выделении текста, выделенный фрагмент меняет свой цвет.

Чтобы выделить:

Слово – щелкните 2 раза левой кнопкой мыши на слове (или 2 раза нажмите кнопку F-8).

Строку - щелкните по левому полю окна рядом со строкой (или нажмите клавишу SHIFT и не отпуская ее переместите курсор на следующую строку).

Предложение – протащите указатель мыши по предложению (или 3 раза нажмите клавишу F-8).

Несколько строк – в левом поле окна протащите указатель вверх или вниз ( повторите то же самое при нажатой клавише SHIFT).

Абзац – трижды щелкните левой кнопкой мыши по любому месту из этого абзаца (или 4 раза нажмите клавишу F-8).

Весь документ – нажмите клавишу Ctrl+Num 5 ( или 5 раз нажмите клавишу F-8). Можно также выбрать команду Выделить все из меню Правка.

Выделите любую строку текста. В меню Правка выберите команду Вырезать. MS Word удалит указанную строку.

Выберите команду Отменить… в меню Правка или нажмите кнопку [image] на панели инструментов. MS Word восстановит информацию.


Настройки Microsoft Word 2000

Первичные настройки текстового процессора Microsoft Word 2000

начало

назад

вперед

конец

вопросы

задания

Новый документ текстового процессора создается сразу после запуска Word или в любой момент во время работы с MS Word. Для этого: в меню Файл выбирается команда Создать (или нажимается Ctrl+N);

В новом пустом документе курсор находится в верхнем левом углу окна документа.

Первичные настройки текстового процессора Microsoft Word 2000

Настройка текстового процессора Microsoft Word играет очень важную роль. Для настройки используются команды меню Вид и Сервис → Параметры. Для выполнения задания 1 используйте информацию Описание текстового процессора Word.

ЗАДАНИЕ 1

Запустите Word. Включите отображение только двух панелей инструментов Стандартная и Форматирование. В качестве режима отображения документа выберите Режим разметки. Установите масштаб отображения документа 100%.

Настройте следующие параметры:

· Единицы измерения для настройки параметров документа – см;

· Список быстрого открытия файлов – 5шт.;

· Запретите «быстрое» сохранение файлов;

· Автосохранение каждые 10 минут;

· Запретите автоматическую проверку орфографии и грамматики;

· Включите автоматическую замену «прямых» кавычек парными;

· Отключите автоматическую расстановку переносов;

· Отключите Помощника.

Сохраните документ.


Настройки документа 2000

Первичные настройки печатного документа

конец

вопросы

задания

Форматирование документов, предназначенных к печати на принтере, выполняется в «привязке» к параметрам печатной страницы. Поэтому создание документов этой категории необходимо начинать с настройки параметров страницы. К этим параметрам относятся, прежде всего, размер листа бумаги и величина полей.

Различают логическую и физическую страницы. Физическая страница ("размер бумаги") обычно имеет некоторый стандартный размер, например А4 210x297 мм, а логическая страница образуется на поле физической за вычетом установленных пользователем границ. Количество данных на логической странице определяется, с одной стороны, плотностью печати (количеством знаков на строке), а с другой — разреженностью строк (интервалом между строками).

Настройка параметров печатного документа осуществляется с помощью диалогового окна Параметры страницы, вызываемого командой меню Файл → Параметры страницы

ЗАДАНИЕ 2

Установите в созданном документе следующие параметры:

· Размер бумаги А4 (это стандартный размер листа бумаги 210 на 297 мм);

· Ориентацию бумаги – книжная

· Размеры полей листа – левое – 2,75 см; правое 1,25 мм; Верхнее – 2 см; Нижнее – 2,25 см.

Сохраните документ.


Объект_объект

Взаимодействие объектов друг с другом

Если на одной странице имеется несколько встроенных объектов, то они могут взаимодействовать и друг с другом. Характером этого взаимодействия тоже нужно управлять.

Для тех объектов, которым перекрытие разрешено, следует установить флажок Формат объекта → Положение → Дополнительно → Положение объекта → Разрешить перекрытие.

Управление взаимным положением объектов выполняют с помощью операций:

· группирования;

· задания порядка следования;

· выравнивания;

· распределения.

Группирование объектов. Если на странице представлено несколько объектов и при этом важно, чтобы их взаимное расположение между ними было строго зафиксировано, их объединяют в один комплексный (групповой) объект с помощью операции группирования. После этой операции свойства группового объекта можно настраивать точно так же, как мы настраивали свойства простейших объектов, — ему может быть задан характер обтекания текстом, метод привязки к абзацу или к элементам печатной страницы и т. п.

Для группирования нескольких объектов их следует выделить (выделение нескольких объектов выполняют при нажатой клавише SHIFT), щелкнуть на любом из объектов группы правой кнопкой мыши и выбрать в контекстном меню команду Группировка → Группировать. Сгруппированные объекты можно перемещать, как единое целое. Если к группе объектов надо добавить новый объект, следует выделить объект и группу и дать команду Группировка → Перегруппировать. Чтобы разгруппировать объекты и получить доступ к индивидуальным свойствам каждого из них, надо выделить группу и дать команду Группировка → Разгруппировать.

Управление порядком следования объектов. Если на странице документа размещается несколько объектов, то предполагается, что у каждого объекта есть свой слой. По умолчанию порядок следования слоев связан с порядком создания объектов, то есть, те объекты, которые были созданы раньше, лежат на слоях ниже, чем объекты, созданные позже.

Если между объектами нет перекрытия, то мы не замечаем, что существует некий порядок следования объектов, однако, когда объекты перекрывают друг друга, этот порядок становится заметен.

Управляют порядком следования объектов с помощью команды Порядок контекстного меню. Она открывает вложенное меню, средствами которого можно поднять объект на передний план, опустить на задний план, сместить на один слой вверх или вниз и задать положение объекта относительно текста.

Выравнивание объектов. Если объекты, составляющие композицию, не перекрывают друг друга, важно иметь средство их относительного выравнивания между собой. Выравнивание объектов выполняют до группирования, ведь после него объекты уже нельзя сдвинуть друг относительно друга. В этом случае операция группирования выполняет роль закрепляющей операции.

Чтобы исполнить эту операцию, необходимо предварительно открыть дополнительную панель инструментов Рисование (Вид → Панели инструментов → Рисование).

Для выравнивания нескольких объектов между собой их следует выделить при нажатой клавише SHIFT, а затем дать команду Действия → Выровнять/распределить (с помощью кнопки Действия панели инструментов Рисование). Существует шесть методов выравнивания. Им соответствуют три команды горизонтального выравнивания (По левому краю, По правому краю, По центру) и три команды выравнивания вертикального (По верхнему краю, По нижнему краю, По середине). Следует обратить внимание на особенность действия команд выравнивания. Так, например, если два объекта выравниваются по нижнему полю, значит, они выравниваются по нижнему полю нижнего объекта. Выравнивание по правому полю — это выравнивание по правому полю самого правого объекта из числа выделенных и так далее. Если необходимо выполнить выравнивание относительно полей страницы, следует предварительно установить флажок Действия → Выровнять/распределить → Относительно страницы.

Распределение объектов. Как и выравнивание, операцию распределения можно выполнить только с помощью панели инструментов Рисование (Вид → Панели инструментов → Рисование). Суть операции распределения состоит в том, что между объектами устанавливаются равные интервалы по горизонтали или (и) вертикали. Соответственно, в меню команды Действия → Выровнять/распределить имеются две команды: Распределить по горизонтали и Распределить по вертикали.

Равномерное распределение объектов обычно выполняют после операции выравнивания, но, разумеется, до операции группирования. Дополнительное отличие команд распределения от команд выравнивания заключается еще и в том, что для взаимного выравнивания достаточно иметь два выделенных объекта, а для команд распределения должно быть выделено не менее трех объектов.


Объект_страница

Взаимодействие объекта с текстом и страницей

Взаимодействие объекта с текстом можно установить во вкладке Положение диалогового окна Формат объекта. Возможны следующие варианты:

1. Вариант В тексте используют для графических объектов малого размера, сопоставимого с размерами символов текста. В этом случае объект вставляется в текстовую строку на правах графического символа и далее перемещается по странице только вместе с текстом.

2. Вариант Вокруг рамки используют для расположения текста вокруг воображаемой прямоугольной рамки, охватывающей весь контур объекта.

3. Вариант По контуру отличается от предыдущего тем, что текст плавно обтекает контур объекта (если он криволинейный).

4. Вариант Перед текстом используют для вставки объекта без обтекания. Текст и объект лежат на разных слоях, причем объект лежит выше и загораживает часть текста.

5. Вариант За текстом используют также для вставки объекта без обтекания. Текст и объект тоже лежат на разных слоях, но в данном случае объект лежит на нижнем слое и загораживается текстом.

Дополнительные варианты взаимодействия текста со встроенным объектом можно найти в диалоговом окне Дополнительная разметка, которое открывают с помощью кнопки Дополнительно.

6. Вариант Сквозное — аналогичен обтеканию По контуру, но в данном случае текст обтекает объект не только снаружи, но и изнутри.

7. Вариант Сверху и снизу считают основным для объектов, ширина которых составляет более половины ширины страницы.

В диалоговом окне Дополнительная разметка можно с помощью переключателей конкретно указать, с каких сторон объекта происходит обтекание, а с каких — нет, а также указать величину интервала в миллиметрах между текстом и объектом.

Горизонтальное размещение объекта относительно элементов печатной страницы устанавливают с помощью диалогового окна Формат объекта → Положение.

Варианты горизонтального размещения объекта:

· по левому краю;

· по правому краю;

· по центру;

· другое.

Варианты По левому краю и По правому краю обычно используют при обтекании По контуру или Вокруг рамки. Вариант По центру часто сочетают с обтеканием Сверху и снизу, а последний вариант соответствует ручному размещению объекта перетаскиванием с помощью мыши.

Вертикальное размещение объекта относительно элементов печатной страницы.

Объект можно закрепить относительно абзаца, тогда при редактировании он будет перемещаться вместе с текстом; или относительно страницы, тогда объект неподвижен, а текст при редактировании перемещается, обтекая его по заданным правилам.

Настройку выполняют во вкладке Положение рисунка диалогового окна Дополнительная разметка установкой переключателей Положение (относительно текста) или Выравнивание (относительно страницы).

Чтобы объект был связан с элементом страницы и не перемещался вместе с текстом, устанавливают флажок Установить привязку. Чтобы объект мог перемещаться вместе с текстом, устанавливают флажок Перемещать вместе с текстом.


Оглавление

Создание оглавления

конец

вопросы

задания

Для того, чтобы создать оглавление документа автоматически, следует:

· оформить текст, помещаемый в оглавление, специальными стилями (Заголовками 1, 2,... уровня);

· установить курсор в то место, куда будет вставлено оглавление, выбрать команду Вставка → Оглавление и указатели;

· в появившемся диалоговом окне задать формат оглавления и указать какие заголовки в него включить.

ЗАДАНИЕ 13

Создайте следующее оглавление документа:

Сохраните документ.

ЗАДАНИЕ 14

Просмотрите свой документ в разных режимах работы с документом, а также сделайте предварительный просмотр документа перед печатью. (см. Текстовый процессор Word)

Общий вид документа можно посмотреть, выбрав ссылку Результаты работы


Однотабличные запросы

Запросы. Построение запросов в режиме Конструктора

конец

вопросы

задания

Запросы являются мощным средством обработки данных, хранимых в таблицах Access. С помощью запросов можно просматривать, анализировать и изменять данные из нескольких таблиц. Они также используются в качестве источника данных для форм и отчетов. Запросы позволяют вычислять итоговые значения и выводить их в компактном формате, подобном формату электронной таблицы, а также выполнять вычисления над группами записей.

Запросы можно создавать самостоятельно и с помощью мастеров. Мастера запросов автоматически выполняют основные действия в зависимости от ответов пользователя на поставленные вопросы. Самостоятельно разработать запросы можно в режиме конструктора.

Построение запросов в режиме Конструктора

В объекте Запросы есть специальный значок Создание запроса в режиме конструктора, который открывает специальный бланк, называемый бланком запроса по образцу. В верхней области отображается структура таблиц, к которым запрос адресован, а нижняя область разбита на столбцы – по одному на каждое поле будущей результирующей таблицы.

Таблицы, к которым обращен запрос, можно открыть с помощью контекстного меню. Далее, с помощью двойного щелчка мышью на нужном поле, его можно поместить в столбец нижней части бланка.

Если необходимо, чтобы отобранные в результате выполнения запроса данные, были упорядочены по какому либо полю, применяют Сортировку, которую можно увидеть в нижней части бланка. Возможна многоуровневая сортировка – сразу по нескольким полям. Вложенность сортировки идет слева направо.

Бывают случаи, когда некоторое поле необходимо в формировании запроса, но нежелательно, чтобы оно появлялось на экране. В таких случаях сбрасывают флажок для этого поля в строке Вывод на экран в нижней части бланка.

Дополнительным средством, обеспечивающим отбор данных по заданному критерию, является Условие отбора. Соответствующая строка также присутствует в нижней части бланка запроса. Для каждого поля можно задать индивидуальное условие, используя логические отношения, причем, заполнение одной строки для разных полей, означает, что они соединены логической операцией AND. Если для одного поля логические отношения расположены в двух строках, они соединены логической операцией OR.

Для изменения следования полей в столбцах нижней части бланка необходимо:

· выделить столбец щелчком на его заголовке (кнопку мыши отпустить);

· еще раз щелкнуть на заголовке и, не отпуская кнопки, перетащить столбец на нужное место.

Для выполнения запроса нужно нажать кнопку [image] на панели инструментов или перейти в режим таблицы, выполнив команду Вид → Режим таблицы.

При закрытии для сохранения запроса ему дают имя.

Однотабличные запросы на выборку

ЗАДАНИЕ 11.

Сконструируйте простой запрос на базе таблицы Предмет для проверки часов, а именно, нужно выбрать предметы, по которым общее число часов изучения не более 100 и есть лекции, а также предметы, у которых общее число часов больше 150 и число семестров не больше двух. Обратите внимание на приведенный выше рисунок.

Выполните запрос.

Сохраните запрос под именем Часы<100.

Если в Условии отбора надо указать значения разных полей, то название полей указывают в квадратных скобках.

ЗАДАНИЕ 12.

Сконструируйте простой запрос на базе таблицы Предмет для проверки задания общих часов.

Должны отбираться записи, для которых значение в поле ЧАСЫ не равно сумме значений в полях ПР и ЛЕК. Обратите внимание на приведенный выше рисунок.

Выполните запрос.

Сохраните запрос под именем Проверка часов.


Однотабличный отчет

Формирование отчетов. Однотабличный отчет

конец

вопросы

задания

Отчет – это гибкое и эффективное средство для организации просмотра и распечатки итоговой информации. В отчете можно получить результаты сложных расчетов, статистических сравнений, а также поместить в него рисунки и диаграммы.

Пользователь имеет возможность разработать отчет самостоятельно или создать отчет с помощью мастера. Мастер по разработке отчетов выполняет всю рутинную работу и позволяет быстро разработать отчет. После вызова Мастера выводятся диалоговые окна с приглашением ввести необходимые данные, и отчет создается на основании ответов пользователя. Мастер необходим даже для опытных пользователей, так как позволяет быстро разработать макет, служащий основой создаваемого отчета. После этого можно переключиться в режим конструктора и внести изменения в стандартный макет.

Создание отчета в режиме конструктора для одной таблицы

Необходимо получить списки студентов по следующему макету

Выберем объект Отчеты и нажмем кнопку [image] . В появившемся окне выберем таблицу Студент, которая будет источником данных для отчета и режим работы Конструктор

Отчет в конструкторе имеет следующий вид, если отсутствует раздел Заголовок отчета, его можно добавить с помощью команды меню Вид → Заголовок/Примечание отчета.

Размещение данных в разделах отчета. Список студентов должен быть представлен по группам, для этого нужно сгруппировать данные по полю ШГ (шифр группы), внутри группы отсортировать список студентов по НС (номеру студента). Нажмем кнопку Сортировка и группировка [image] панели инструментов конструктора и заполним поля открывшегося окна

Для ШГ (шифр группы) | Для НС (номер студента)

После определения группировки в окне конструктора отчетов появятся дополнительные разделы Заголовок группы ШГ, Примечание группы ШГ. Далее нужно разместить поля из таблицы Студент в разделах отчета. Это делается путем перетаскивания нужных полей из окна списка полей (оно вызывается кнопкой [image] панели инструментов) в разделы отчета. Поле ШГ – в раздел заголовка ШГ, поля НС, ФИО, ГОДР, ПБАЛЛ в область данных. Поле размещается в отчете вместе с подписью из структуры таблицы, подписи можно перенести в раздел заголовка путем вырезания и вставки. Если подписи не совпадают с названиями столбцов в макете, их нужно скорректировать. Названия столбцов можно создать и заново, воспользовавшись кнопкой панели элементов Надпись [image] . Формат и размер шрифта устанавливается с помощью панели инструментов Формат (Форма/Отчет), размер рамки подписи можно установить по команде Формат → Размер → По размеру данных.

Включение в отчет вычисляемого поля. Для включения в отчет расчетного поля Средний проходной балл группы используется кнопка Поле [image] на панели элементов. Элемент Свободный размещается в разделе Примечание группы ШГ. Далее изменяются свойства этого элемента в окне Свойств (это окно открывается из контекстного меню, когда поле выделено). В строку Данные (вкладка Данные) записывается функция =Avg([ПБАЛЛ]), в строке Формат поля (вкладка Макет) выбирается Фиксированный, в строке Число десятичных знаков (вкладка Макет) выбирается 2.

Для редактирования Надписи поля в окне Свойств в строке Подпись (вкладка Макет) записывается Средний проходной балл группы.

Добавление текущей даты и номеров страниц отчета. Добавить в отчет текущую дату можно, выполнив команду меню, Вставка → Дата и время, и установив необходимые флажки в диалоговом окне. Для добавления страниц используют команду меню Вставка → Номер страницы.

Оформление отчета. Заголовок формируется в разделе Заголовок отчета с помощью кнопки Надпись [image] панели элементов. С помощью кнопки Линии [image] панели элементов завершается оформление отчета.

В итоге получается отчет:

В режиме Конструктор | В режиме Просмотр

ЗАДАНИЕ 8.

Согласно всему сказанному выше, создайте отчет Списки групп.

Просмотрите отчет.

ЗАДАНИЕ 9.

Создайте отчет Список кафедр.

Просмотрите отчет.

ЗАДАНИЕ 10.

Создайте отчет Список преподавателей.

Просмотрите отчет.

Перенесите названия столбцов в раздел Заголовка, верхние и нижние колонтитулы уберите с помощью команды Вид → Колонтитулы.

Сохраните отчет.


Основные понятия БД

Под базой данных (БД) понимают хранилище структурированных данных, при этом данные должны быть непротиворечивы, минимально избыточны и целостны.

Реляционные БД представляют связанную между собой совокупность таблиц-сущностей базы данных (ТБД). Связь между таблицами может находить свое отражение в структуре данных, а может только подразумеваться, то есть присутствовать на неформализованном уровне. Каждая таблица БД представляется как совокупность строк и столбцов, где строки соответствуют экземпляру объекта, конкретному событию или явлению, а столбцы - атрибутам (признакам, характеристикам, параметрам) объекта, события, явления.

При практической разработке БД таблицы-сущности зовутся таблицами, строки-экземпляры - записями, столбцы-атрибуты - полями ТБД.

Одно из важнейших достоинств реляционных баз данных состоит в том, что можно хранить логически сгруппированные данные в разных таблицах и задавать связи между ними, объединяя их в единую базу. Такая организация данных позволяет уменьшить избыточность хранимых данных, упрощает их ввод и организацию запросов и отчетов.

Понятие первичного ключа

В каждой таблице БД может существовать первичный ключ. Под первичным ключом понимают поле или набор полей, однозначно (уникально) идентифицирующих запись. Первичный ключ должен быть минимально достаточным: в нем не должно быть полей, удаление которых из первичного ключа не отразится на его уникальности.

Данные таблицы «Преподаватель»

Таб. № | ФИО | Уч. степень | Уч. звание | Код кафедры
101 | Андреев А.П. | Д-р техн. наук | Профессор | 01
102 | Апухтин И.С. | Канд. техн. наук | Доцент | 01
103 | Глухов И.Л. | Канд. техн. наук | Доцент | 01
104 | Сеченов Ю.Б. | Канд. техн. наук | Доцент | 01

В качестве первичного ключа в таблице «Преподаватель» может выступать только «Таб. №», значения других полей могут повторяться внутри данной таблицы.

Правила хорошего тона при разработке структур баз данных, и чисто практические соображения должны побудить разработчика всегда определять первичный ключ для таблицы базы данных.

Реляционные отношения (связи) между таблицами базы данных

Между двумя или более таблицами базы данных могут существовать отношения подчиненности. Отношения подчиненности определяют, что для каждой записи главной таблицы {master, называемой еще родительской} может существовать одна или несколько записей в подчиненной таблице {detail, называемой еще дочерней}.

Существует три разновидности связей между таблицами базы данных:

- «один-ко-многим»,

- «один-к-одному»,

- «многие-ко-многим».

Отношение «один-ко-многим» имеет место, когда одной записи родительской таблицы может соответствовать несколько записей в дочерней таблице.

Связь "один-ко-многим" является самой распространенной для реляционных баз данных.

В широко распространенной нотации структуры баз данных IDEF1X отношение «один-ко-многим» изображается путем соединения таблиц линией, которая на стороне дочерней таблицы оканчивается кружком или иным символом. Поля, входящие в первичный ключ для данной ТБД, всегда расположены вверху и отчеркнуты от прочих полей линией.

Отношение «один-к-одному» имеет место, когда одной записи в родительской таблице соответствует одна запись в дочерней таблице.

Данное отношение используют, если не хотят, чтобы таблица БД «распухала» от второстепенной информации.

Отношение «многие-ко-многим» имеет место, когда:

а) записи в родительской таблице может соответствовать больше одной записи в дочерней таблице;

б) записи в дочерней таблице может соответствовать больше одной записи в родительской таблице.

Например, каждой учебной группе соответствует несколько преподавателей. Каждый преподаватель может вести, во-первых, несколько разных предметов, и, во-вторых, преподавать в разных группах.

Многие СУБД (в частности Access) не поддерживают связи «многие-ко-многим» на уровне индексов и ссылочной целостности. Считается, что всякую связь «многие-ко-многим» можно заменить на одну или более связей «один-ко-многим».

Например,

Ссылочная целостность и каскадные воздействия

Рассмотрим наиболее часто встречающуюся в базах данных связь «один-ко-многим». Как можно заметить, дочерняя и родительская таблицы связаны между собой по общему полю «Шифр группы». Назовем это поле полем связи.

Возможны два вида изменений, которые приведут к утере связей между записями в родительской и дочерней таблицах:

· изменение значения поля связи в записи родительской таблицы без изменения значений полей связи в соответствующих записях дочерней таблицы;

· изменение значения поля связи в одной из записей дочерней таблицы без соответствующего изменения значения полей связи в родительской и дочерней таблицах.

И в первом, и втором случаях наблюдается нарушение целостности базы данных, поскольку информация в ней становится недостоверной. Следовательно, нужно блокировать действия, которые нарушают целостность связей между таблицами, которую называют ссылочной целостностью.

Чтобы предотвратить потерю ссылочной целостности, используется механизм каскадных изменений. Он состоит в обеспечении следующих требований:

· необходимо запретить изменение поля связи в записи дочерней таблицы без синхронного изменения полей связи в родительской таблице;

· при изменении поля связи в записи родительской таблице, следует синхронно изменить значения полей связи в соответствующих записях дочерней таблицы;

· при удалении записи в родительской таблице, следует удалить соответствующие записи в дочерней таблице.

Необходимость разрешения или запрещения каскадных изменений обычно реализуется в СУБД при определении связей между таблицами. Собственно, таким образом, и происходит создание ссылочной целостности.

Понятие внешнего ключа

Для обеспечения ссылочной целостности в дочерней таблице создается внешний ключ. Во внешний ключ входят поля связи дочерней таблицы. Для связей типа "один-ко-многим" внешний ключ по составу полей должен совпадать с первичным ключом родительской таблицы.

Индексы и методы доступа

Индексы представляют собой механизмы быстрого доступа к данным в таблицах БД.

Сущность индексов состоит в том, что они хранят значения индексных поле (т.е. полей, по которым построен индекс) и указатель на запись в таблице.

При последовательном методе доступа для выполнения запроса к таблице БД просматриваются все записи таблицы, от первой до последней.

При индексно-последовательном методе доступа для выполнения запроса к таблице БД указатель в индексе устанавливается на первую строку, удовлетворяющую условию запроса (или его части), и считывается запись из таблицы по хранящемуся на нее в индексе указателю.

Определение первичных и внешних ключей таблиц БД приводят к созданию индексов по полям, объявленным в составе первичных или внешних ключей.

Нормализация таблиц при проектировании БД

При проектировании структуры новой БД определяют сущности (объекты, явления) предметной области, которые должны найти свое отражение в базе данных. В конечном итоге анализ предметной области должен привести к созданию эскиза БД. Сначала желательно изобразить сущности и связи между ними. Как правило, каждой сущности в БД соответствует таблица. Затем - в эскизе второго порядка - для каждой таблицы БД приводится список атрибутов - полей записи.

На этом этапе процесс проектирования структур БД является процессом творческим, неоднозначным, с другой стороны, узловые его моменты могут быть формализованы.

Одной из таких формализаций является требование, согласно которому реляционная база данных должна быть нормализована. Процесс нормализации имеет своей целью устранение избыточности данных и заключается в приведении к третьей нормальной форме (3НФ).

Первая нормальная форма (1НФ) требует, чтобы каждое поле таблицы БД:

· было неделимым;

· не содержало повторяющихся групп.

Неделимость поля означает, что значение поля не должно делиться на более мелкие значения. Например, если в поле "Подразделение" содержится название факультета и название кафедры, требование неделимости не соблюдается и необходимо из данного поля выделить или название факультета, или кафедры в отдельное поле.

Повторяющимися являются поля, содержащие одинаковые по смыслу значения. Например, если требуется получить статистику сдачи экзаменов по предметам, можно создать поля для хранения данных об оценке по каждому предмету. Однако в этом случае мы имеем дело с повторяющимися группами.

Вторая нормальная форма (2НФ) требует, чтобы все поля таблицы зависели от первичного ключа, то есть, чтобы первичный ключ однозначно определял запись и не был избыточен. Те поля, которые зависят только от части первичного ключа, должны быть выделены в составе отдельных таблиц.

Третья нормальная форма (ЗНФ) требует, чтобы значение любого поля таблицы, не входящего в первичный ключ, не зависело от значения другого поля, не входящего в первичный ключ.

Пример логической модели базы данных "Учебный процесс"


Перекрестные запросы

Формирование сложных запросов. Перекрестные запросы

конец

вопросы

задания

В перекрестном запросе отображаются результаты статистических расчетов (такие, как суммы, количество записей, средние значения), выполненных по данным из одного поля таблицы. Эти результаты группируются по двум наборам данных, один из которых расположен в левом столбце таблицы, а второй – в верхней строке.

Создадим перекрестный запрос о среднем балле в группах по предметам. Но такой запрос строится на основе одной таблицы или одного запроса, в связи, с чем надо сначала сформировать запрос, в котором были бы поля «Шифр группы», «Название предмета» и «Оценки».

ЗАДАНИЕ 4.

Сконструируйте запрос, в котором были бы поля «Шифр группы», «Название предмета» и «Оценки».

Выполните запрос.

Сохраните запрос под именем Успеваемость по группам.

Теперь можно создавать перекрестный запрос. Для этого нужно:

· на вкладке Запросы щелкнуть по кнопке [image] ; выбрать Перекрестный запрос и щелкнуть по кнопке ОК;

· щелкнуть по переключателю Запросы, выбрать запрос Успеваемость по группам и щелкнуть по кнопке Далее;

· выбрать поле НП (Название предмета), которое будет использоваться в качестве заголовков строк, и щелкнуть по кнопке Далее;

· выбрать поле ШГ (Шифр группы), которое будет использоваться в качестве заголовков столбцов, и щелкнуть по кнопке Далее;

· выбрать поле Оценка и функцию Среднее, и щелкнуть по кнопке Далее;

· ввести название запроса и щелкнуть по кнопке Готово. Откроется таблица перекрестного запроса. Обратите внимание на то, что Access создает еще итоговое значение средних оценок по группам.

ЗАДАНИЕ 5.

Следуя указаниям, описанным выше, создайте перекрестный запрос Успеваемость по группам. Выполните запрос.

Сохраните запрос под именем Успеваемость по группам перекрестный.


Печать

Печать документов Exсel

конец

вопросы

задания

Экранное представление электронной таблицы в Excel значительно отличается от того, что получается при выводе данных на печать. Это связано с тем, что единый рабочий лист приходится разбивать на фрагменты, размеры которых зависят от формата печатной страницы. Кроме того, элементы оформления рабочего окна программы номера строк и столбцов, условные границы ячеек — обычно не отображаются при печати.

Предварительный просмотр

Перед печатью рабочего листа следует перейти в режим предварительного просмотра (кнопка Предварительный просмотр [image] на стандартной панели инструментов), который позволяет увидеть его на экране точно в таком виде, в каком он будет напечатан. Кроме того, режим предварительного просмотра позволяет изменить свойства печатной страницы и параметры печати.

Управление в режиме предварительного просмотра осуществляется при помощи кнопок, расположенных вдоль верхнего края окна. Кнопка Страница открывает диалоговое окно Параметры страницы, которое служит для задания параметров печатной страницы ориентации листа, масштаба (изменение масштаба позволяет управлять числом печатных страниц, необходимых для документа), размеров полей документа. Здесь же можно задать верхние и нижние колонтитулы для страницы. На вкладке Лист включается или отключается печать сетки и номеров строк и столбцов, а также выбирается последовательность разбиения рабочего листа на страницы, когда рабочий лист превосходит размер печатного листа, как по длине, так и по ширине.

Изменить величину полей страницы, а также ширину ячеек при печати можно также непосредственно в режиме предварительного просмотра при помощи кнопки Поля. При щелчке на этой кнопке на странице появляются маркеры, указывающие границы полей страницы и ячеек. Изменить положение этих границ можно методом перетаскивания.

Завершить работу в режиме предварительного просмотра можно тремя способами, в зависимости от того, что планируется делать дальше. Щелчок на кнопке Закрыть позволяет вернуться к редактированию документа. Щелчок на кнопке Разметка страницы служит для возврата к редактированию документа, но в режиме разметки страницы. В этом режиме документ отображается таким образом, чтобы наиболее удобно показать не содержимое ячеек таблицы, а область печати и границы страниц документа. Переключение между режимом разметки и обычным режимом можно также осуществлять через меню Вид (команды Вид → Обычный и Вид → Разметка страницы). Третий способ — начать печать документа.

Печать документа

Щелчок на кнопке Печать открывает диалоговое окно Печать, используемое для распечатки документа (его можно открыть и без предварительного просмотра — с помощью команды Файл → Печать). Это окно содержит стандартные средства управления, применяемые для печати документов в любых приложениях.

Выбор области печати

Область печати — эта часть рабочего листа, которая должна быть выведена на печать. По умолчанию область печати совпадает с заполненной частью рабочего листа и представляет собой прямоугольник, примыкающий к верхнему левому углу рабочего листа и захватывающий все заполненные ячейки. Если часть данных не должна выводиться на бумагу, область печати можно задать вручную. Для этого надо выделить ячейки, которые должны быть включены в область печати, и дать команду Файл → Область печати → Задать. Если текущей является одна-единственная ячейка, то программа предполагает, что область печати просто не выделена, и выдает предупреждающее сообщение.

Если область печати задана, то программа отображает в режиме предварительного просмотра и распечатывает только ее. Границы области печати выделяются на рабочем листе крупным пунктиром (сплошной линией в режиме разметки). Для изменения области печати можно задать новую область или командой Файл → Область печати → Убрать вернуться к параметрам, используемым по умолчанию.


Поиск и замена

Поиск и замена в документе Word

конец

вопросы

задания

С помощью MS Word Вы можете разыскивать символы и слова в документе, а также заменять их на другие. Для этого:

1. В меню Правка выберите команду Заменить;

2. В окне ‘‘Найти:’’ наберите информацию, которую Вы хотите найти в тексте, например Internet;

3. В окне ‘‘Заменить на:’’ наберите символы, которыми вы хотите заменить найденный текст, например Интернет.

Кроме того, MS Word позволяет находить и заменять специальные символы (конца абзаца, табуляции, перехода на новую строку и др.). Для этого нужно нажать кнопку Больше, затем кнопку Специальный, где выбрать требуемый символ.

ЗАДАНИЕ 9

Расставьте переносы в созданном документе.

Добавьте новый абзац: Длина окружности равна 2π r, π вставьте как специальный символ.

Проверьте правописание. С помощью контекстного меню вызовите встроенный словарь и исправьте неправильно написонное слово. Просмотрите в тезаурусе (Сервис → Язык → Тезаурус) синонимы для слова идти и внесите их в свой документ.

Замените в тексте с помощью Поиска и замены словосочетание Microsoft на аббревиатуру MS.

Сохраните документ.


Поиск сортировка фильтрация

Поиск, сортировка и фильтрация данных в таблицах и формах

конец

вопросы

задания

С помощью кнопок, расположенных на панели инструментов можно организовать Поиск [image] Сортировку [image] и Фильтрацию [image] данных в таблицах и формах. Для этого нужно лишь установить курсор в нужном поле, а затем выполнить операцию, нажав нужную кнопку.

ЗАДАНИЕ 10.

Откройте таблицу Преподаватель в режиме Таблица.

Осуществите поиск преподавателя по фамилии Яковлев П.П.

Отсортируйте таблицу по полю ФИО по алфавиту.

Отфильтруйте таблицу по значению поля Ученое звание доцент.

Отмените фильтр.

Проделайте те же операции для таблицы Преподаватель, открытой в режиме Форма.


Поиск, корректировка, удаление записей

конец

вопросы

задания

Искать, корректировать, удалять записи можно обычным способом, просматривая визуально весь список. Но Excel предлагает и другой способ, с помощь той же формы данных. Этот способ хорош и тем, что в форме можно организовать поиск нужных данных с помощью заданных критериев. Для открытия окна диалога формы данных надо использовать команду меню Данные → Форма… А затем, после щелчка на кнопке Критерии, задать значения полей интересующих нас записей. С помощью кнопок Назад и Далее можно просмотреть все записи, удовлетворяющие заданным критериям. Исправляя значения полей найденной записи, можно ее откорректировать. Нажав кнопку Удалить, можно удалить запись из базы, но при этом надо помнить, что вернуть эту запись будет невозможно.

ЗАДАНИЕ 2

Организуйте в созданной базе Итоги сессии с помощью Формы ввода поиск студентов, имеющих средний балл >= 4. Просмотрите эти записи.


Правописание

Средства автоматизации проверки правописания

конец

вопросы

задания

Эти средства включают проверку орфографии и грамматики. Возможны два режима проверки правописания: автоматический и командный. Неверное слово подчеркивается красной волнистой чертой, а неудачное или неправильное словосочетание – зеленой. Если щелкнуть правой кнопкой мыши, открывается контекстное меню с возможными вариантами исправления ошибки. Можно выбрать любой. Команду Добавить используют в тех случаях, когда слово правильное, но отсутствует в словаре программы. В случае «зеленой» ошибки в контекстном меню приводится правило, которое по мнению Word оказалось нарушено. Провести проверку правописания после создания документа позволяет командная кнопка Правописание [image] на Панели инструментов. Значок книги [image] в строке состояния указывает на состояние режима проверки правописания. Если присутствует крестик, значит проверка не проводилась или были обнаружены ошибки. При отсутствии ошибок используется «галочка».


Редактирование форм

Работа с формами. Редактирование форм

конец

вопросы

задания

Уточнение текста надписей, местоположения, размеров, шрифтов и других параметров отображения элементов формы осуществляется в режиме Конструктора форм.

Для открытия формы в режиме конструктора следует выделить необходимую форму на панели Формы в окне База данных и воспользоваться командной кнопкой [image] .

Если форма уже была открыта, перейти в режим конструктора можно, используя командную кнопку Вид.

Создание заголовка. Для ввода текста заголовка в полученную форму в окне Конструктора расширяется область заголовка формы. Для этого нужно установить курсор мыши на границу области заголовка и области данных, и, когда он примет вид двунаправленной стрелки, перетащить ее на нужное место. После этого создается графический элемент Надпись с помощью кнопки [image] Панели элементов. Элемент может быть перемещен в пределах области заголовка, это возможно, когда курсор принимает форму раскрытой ладони или указательного пальца. Для удаления элемента нужно нажать клавишу Delete после выделения элемента.

Для аккуратного выравнивания элементов управления на форме используют команды меню Формат → Выровнять, Формат → Интервал по горизонтали, Формат → Интервал по вертикали. Можно воспользоваться вспомогательной сеткой, отображение которой включается командой меню Вид → Сетка.

После окончания редактирования формы можно ее закрыть или перейти в режим Вид → Форма для просмотра данных таблицы или ввода новых.

ЗАДАНИЕ 6

Скорректируйте форму Предмет, чтобы она выглядела примерно так:

ЗАДАНИЕ 7

Используя созданные формы, дополните таблицу Предмет данными

таблицу Группа данными

При заполнении связанных таблиц Преподаватель, Студент, Изучение, Успеваемость используются значение полей, определенных в других таблицах. Например, в таблице Преподаватель используется Код кафедры, определенный в таблице Кафедра. Для избежания лишних ошибок можно скорректировать работу формы таким образом, чтобы заполнение производилось выбором из списка значений поля.

Откроем форму Преподаватель в режиме Конструктора. Удалим из формы название и поле Код кафедры. С помощью кнопки Поле со списком [image] Панели элементов вызовем диалоговые окна Создание полей со списком, в которых ответим на необходимые вопросы (смотри рисунки ниже).

ЗАДАНИЕ 8

Используя выше сказанное, скорректируйте форму Преподаватель. Заполните таблицу Преподаватель следующими данными, используя форму или саму таблицу.

ЗАДАНИЕ 9

Откорректируйте созданные формы Студент, Изучение, Успеваемость, заменив заполнение связанных полей Полями со списком.

Заполните таблицы следующими данными:

Студент

Изучение

Успеваемость


Результат работы

Результат выполнения лабораторной работы

конец

вопросы

задания


Результаты работы

Результат выполнения лабораторной работы

конец

вопросы

задания

В процессе выполнения лабораторной работы должно получиться три документа Word. Первый должен содержать задания с 1 по 14. Ниже приведен его общий вид. И два документа, полученные в результате выполнения заданий 15 и 16.


Результаты работы

Задание

конец

вопросы

задания

ЗАДАНИЕ

Создайте сложную форму, в которой представлены оценки студентов по предметам и группам, на форме представлена также диаграмма, отражающая средние оценки групп по предметам.

Создайте отчет на сдачу экзаменов по предметам. Название предмета задается в качестве параметра.


Результаты работы

Результат выполнения лабораторной работы

конец

вопросы

задания

1. Составить таблицу расчета стоимости топлива на пробег автомобиля. Образец таблицы показан на рис.

В таблице выполнить защиту данных, не подлежащих изменению.

Примечание:

  • для вычисления стоимости топлива на пробег (руб.) используйте стандартную функцию ГПР

  • В строке "Итоги" для суммирования с учетом установленного фильтра используйте стандартную функцию ПРОМЕЖУТОЧНЫЕ.ИТОГИ

2. Построить гистограмму стоимости топлива на пробег автомобиля

3. Используя расширенный фильтр выполнить поиск данных в таблицы в зависимости от заданного условия. Результат поиска разместить в другой таблице, расположенной на том же листе рабочей книги.

4. По результатам поиска построить круговую диаграмму гистограмму стоимости топлива на пробег автомобиля.


Результаты работы

Задание

конец

вопросы

задания

ЗАДАНИЕ

Дополните БД данными о студентах второго курса. Группы 201, 202. В каждой группе не менее 5 студентов. (Заполняются таблицы Студент, Изучение, Успеваемость).

Создайте запрос о сдаче сессии студентов второго курса. По этому запросу разработайте форму Успеваемость студентов второго курса.


Решение задач

Использование электронных таблиц для решения задач

конец

вопросы

задания

Возможности электронных таблиц выходят за рамки обычных вычислений. С их помощью можно строить компьютерную модель и анализировать данные при помощи компьютерного эксперимента.

При анализе данных бывает важно определить, как изменение одной из переменных повлияет на результат формулы, как подобрать оптимальное значение переменной. Например, нужно определить, при каком тираже затраты на производство книги совпадут с запланированным доходом, т.е. с какого тиража пойдет прибыль.

В арсенале Excel имеется команда Подбор параметра (меню Сервис), которая позволяет осуществить поиск именно того значения переменной величины, при котором будет достигнут указанный результат. Подбор параметра можно использовать для исследования уравнений и функций.

Рассмотрим пример нахождения корней уравнения

Полином третьей степени имеет не более трех вещественных корней. Начнем с локализации этих корней. Для этого построим график полинома на отрезке [-1;1] с шагом 0,2

Из графика видно, что полином меняет знак на интервалах: [-1; -0,8], [0,2; 0,4], [0,6; 0,8]. Это означает, что на каждом из них имеется корень.

Зададим относительную погрешность вычислений 0.00001 и предельное число итераций 1000 на вкладке Вычисления диалогового окна Параметры, открытого с помощью команды Сервис → Параметры.

В качестве начальных значений приближений к корням выберем любые точки из отрезков локализации корней. Например: -0,9; 0,3 и 0,7. Поместим эти значения в ячейки С2:С4. Скопируем формулу из ячейки В2 и поместим ее в ячейку D2. Маркером заполнения скопируем формулу из ячейки D2 на диапазон D2:D4.

Таким образом, мы вычислим значение полинома для всех начальных значений.

Найдем корни полинома методом последовательных приближений с помощью команды Сервис → Подбор параметра. В диалоговом окне следует установить следующие значения

Параметр Установить в ячейке указывает ячейку, в которую введена формула, вычисляющая значения левой части полинома.

Параметр Значение указывает на правую часть полинома, т.е. 0.

Параметр Изменяя значения ячейки указывает на ячейку, отведенную под переменную.

После нажатия кнопки ОК средство подбора параметра находит приближенное значение корня, которое помещает в ячейку С2. Для рассматриваемого примера оно будет равно –0,92.

ЗАДАНИЕ 10

Найдите корень уравнения, график которого построили в задании 9.

Сохраните книгу.

ЗАДАНИЕ 11

Переименуйте листы в соответствии: Лист 1 – Бюджет на первый квартал, Лист 2 – Сумма ряда, Лист 3 – График функции, Лист 4 – Подбор параметра, Лист 5 – Индивидуальные задания.

Сохраните книгу.


Рисунки

Работа с рисунками

конец

вопросы

задания

Создание и редактирование рисунков

Для работы с векторными рисунками служит панель инструментов Рисование (Вид → Панели инструментов → Рисование).

Векторные объекты создают путем их выбора из категорий списка Автофигуры, в которых представлены заготовки для создания линий, прямых и кривых, простейших геометрических фигур, чертежных элементов для блок-схем и т.п.

Размер редактируют путем перетаскивания маркеров выделенного объекта в поле документа.

Удобным средством, упрощающим создание геометрических фигур, является вспомогательная координатная сетка. Командой Действия → Сетка открывают диалоговое окно Привязка к сетке. В нем задают шаг сетки и способ отображения горизонтальных и вертикальных линий. Флажок Привязать к сетке обеспечивает точное позиционирование узловых точек фигур в узлах координатной сетки.

Все свойства объектов можно редактировать в диалоговом окне Формат автофигуры, которое открывают командой Формат → Автофигура, или через контекстное меню объекта, или двойным щелчком на самом объекте. В этом же окне на вкладке Положение можно задать взаимодействие рисованного объекта с окружающим текстом, на вкладке Размер можно задать поворот нарисованного объекта на фиксированный угол, задав значение угла в поле счетчика Поворот. Для произвольного поворота фигуры используют кнопку Свободное вращение [image] на панели инструментов Рисование.

Создание надписей в поле рисунка. Рисованные объекты могут содержать текстовые элементы, например: заголовки, буквенные или цифровые обозначения на схемах и чертежах.

Для создания текстовых элементов, присоединенных к автофигурам или рисункам, служит специальное средство Надпись (Вставка → Надпись). Создав автофигуру, рядом создают элемент Надпись. В поле надписи вводят необходимый текст, после чего надпись можно редактировать. Ее размер подгоняют под размер содержащегося в ней текста перетаскиванием маркеров. Прочие свойства надписи задают в диалоговом окне Формат надписи, которое для выделенной надписи открывают командой Формат → Надпись. Элементы управления, представленные на вкладках этого окна, позволяют настроить:

· фоновый цвет;

· цвет, тип и толщину обрамляющих линий;

· размеры внутренних полей между текстом и внешней рамкой поля Надпись.

Объект Надпись можно сгруппировать с рисунком, и тогда они будут представлять цельную композицию.

Текст может размещаться также в поле автофигуры. Это выполняют командой Добавить текст в контекстном меню автофигуры.

ЗАДАНИЕ 5

Создайте следующую блок-схему, используя объекты рисования, сгруппируйте элементы блок-схемы.

Сохраните документ.

Использование графических объектов

Создание рисунков

Более сложные рисунки (композиции) создаются путем комбинирования простейших рисунков, в этом случае следует принимать во внимание не только взаимодействие объектов с окружающим текстом, но и их взаимодействие между собой. Смотри взаимодействие объектов друг с другом.


Сводные таблицы

Построение сводных диаграмм

конец

вопросы

задания

Сводная диаграмма представляет собой диаграмму, построенную на основе сводной таблицы. При создании сводной диаграммы соответствующая ей сводная таблица создается автоматически, даже если явного запроса на ее создание не было. Для создания сводной диаграммы по уже существующей сводной таблице проще всего щелкнуть на кнопке Мастер диаграмм на панели инструментов Сводные таблицы.

Информация о полях базы данных отображается на диаграмме точно так же, как и в сводной таблице, — с раскрывающими кнопками. Используя их, можно изменить правила фильтрации или отключить отображение некоторых значений.

Дальнейшее форматирование и настройка диаграммы осуществляется через контекстные меню. Так, чтобы изменить вид диаграммы, надо щелкнуть правой кнопкой мыши на области построения и выбрать в контекстном меню пункт Тип диаграммы. Для изменения формата щелкните на соответствующем элементе диаграммы правой кнопкой мыши и выберите в контекстном меню соответствующий пункт Формат...

ЗАДАНИЕ 5

Создайте сводную таблицу средних оценок по разным предметах, разных специальностей.

По полученной таблице постройте сводную диаграмму.

Сохраните книгу.


Сводные таблицы

Построение сводной таблицы

конец

вопросы

задания

Анализ данных

Подробный анализ данных из таблицы базы данных требует возможности получения сводной информации по записям базы данных. Результаты такого анализа в Excel могут быть представлены в виде сводной таблицы или сводной диаграммы.

Построение сводной таблицы производится с помощью Мастера сводной таблицы. Для его запуска первоначально, как обычно, требуется выделить ячейку, относящуюся к базе данных, далее выполнить команду Данные → Сводная таблица.

На первом шаге работы мастера выбирается тип данных на основе которых строится сводная таблица. Для использования базы данных Excel — это пункт В списке или базе данных Microsoft Excel.

После щелчка на кнопке Далее, на втором шаге надо уточнить, правильно ли был выбран диапазон, охватывающий базу данных.

После очередного щелчка на кнопке Далее, на третьем шаге выбирается вначале местоположение сводной таблицы. В большинстве случаев следует размещать ее на новом рабочем листе (переключатель Новый лист). Затем кнопкой Макет… загружается диалоговое окно макета сводной таблицы, в котором надо сформировать содержание и оформление сводной таблицы.

Содержание сводной таблицы. Сводная таблица состоит из четырех областей: Страница, Строка, Столбец и Данные.

Каждой области сводной таблицы должны соответствовать одно или несколько полей базы данных. Исключение делается только для поля Страница, которое можно оставить пустым. Для заполнения этих полей служат кнопки, названия которых совпадают с названиями полей базы данных. Поместить кнопку в нужное поле можно методом перетаскивания. В сводной таблице можно использовать только те поля, которые необходимы. Незадействованные поля в отборе и вычислениях не участвуют.

Область Страница играет роль внешнего фильтра. Данные в остальной части таблицы относятся к значению, выбранному в этом поле. Область Строка содержит значения, определяющие содержимое строки таблицы, и задает второй уровень сортировки. Аналогичным образом, область Столбец определяет содержимое столбцов. В отличие от области Страница, в сводную таблицу помещаются данные для всех возможных значений полей, указанных в этих областях.

Область Данные определяет собственно содержимое таблицы. В отличие от всех остальных областей, к данным, попадающим в ячейку таблицы, применяется функция для итоговых вычислений (по умолчанию — суммирование). Если необходимо изменить эту функцию, надо дважды щелкнуть на соответствующей кнопке и выбрать нужную операцию из раскрывающегося списка.

Кроме стандартного набора итоговых функций, можно использовать и дополнительные вычисления. Для этого надо щелкнуть на кнопке Дополнительно, выбрать нужное значение из раскрывающегося списка Дополнительные вычисления и, если требуется, указать необходимые параметры. После выбора и настройки данных следует щелкнуть на кнопке ОК.

Оформление сводной таблицы. Для настройки внешнего вида сводной таблицы надо щелкнуть на кнопке Параметры. Здесь можно задать имя листа сводной таблицы, включить режим суммирования данных по строкам и столбцам, разрешить доступ к информации, использованной при вычислении, выполнить другие настройки.

По их завершении требуется щелкнуть на кнопке ОК, а затем на кнопке Готово, и сводная таблица строится автоматически.

Работа со сводной таблицей. При создании сводной таблицы автоматически открывается и панель инструментов Сводные таблицы. В дальнейшем открывать и закрывать эту панель можно, щелкая правой кнопкой мыши на любой из открытых панелей инструментов и выбирая пункт Сводные таблицы из контекстного меню.

Если требуется изменить вид сводной таблицы, это можно сделать с помощью кнопок, помещенных в таблице в соответствующих областях. При щелчке на соответствующей раскрывающей кнопке появляется небольшое окно, в котором можно отключить некоторые из отображаемых показателей. Для области Страница справа отображается раскрывающийся список, позволяющий выбрать разные условия фильтрации. Кроме того, щелкнув в пределах сводной таблицы правой кнопкой мыши и выбрав в контекстном меню пункт Отобразить страницы, можно разделить единую сводную таблицу на набор таблиц, соответствующих разным значениям, которые можно выбрать в области Страница.

Сводная таблица остается динамически связанной с данными, на основании которых она была построена. Это, в частности, означает, что для любого значения, приведенного в сводной таблице, можно выяснить, как оно было получено. Для этого надо дважды щелкнуть на соответствующей ячейке таблицы. При этом автоматически создается новый рабочий лист, содержащий выборку записей, использованных при вычислении данного значения.

Динамическая связь с исходными данными проявляется и в том, что при изменении данных не требуется заново формировать сводную таблицу. Достаточно щелкнуть в пределах таблицы правой кнопкой мыши и выбрать в контекстном меню пункт Обновить данные.

В случае, когда записи базы данных добавляются или удаляются, необходимо снова запустить мастер сводных таблиц (проще всего для этого воспользоваться кнопкой Мастер сводных таблиц на панели инструментов Сводные таблицы), щелкнуть на кнопке Назад и уточнить диапазон ячеек, включающих записи базы данных После щелчка на кнопке Готово данные сводной таблицы будут обновлены с учетом изменения числа записей.


собенности объектов

Особенности объектов Word

конец

вопросы

задания

Среди встроенных объектов нетекстовой природы могут быть стандартные объекты, созданные другими программами (рисунки, анимационные и звуковые клипы и т.п.), а также объекты, созданные средствами самого текстового процессора (геометрические фигуры, художественные заголовки, формульные выражения, готовые векторные иллюстрации – клипарты).

Несмотря на разностороннюю природу объектов, с которыми может работать Word, у них есть общие свойства такие как размер, положение на странице, характер взаимодействия с текстом.

Управление свойствами объектов

Размерами встроенных объектов можно управлять перетаскиванием графических маркеров с помощью мыши. Маркеры видны, когда объект выделен. Угловые маркеры позволяют менять размер объекта пропорционально. Для автоматического управления размером, а также другими свойствами существуют специальные средства. Это диалоговое окно Формат объекта, которое можно вызвать с помощью контекстного меню или с помощью панели инструментов, соответствующей типу объекта.

Взаимодействие объекта с текстом и страницей

Взаимодействие объекта с текстом можно установить во вкладке Положение диалогового окна Формат объекта.

Взаимодействие объектов друг с другом

Если на одной странице имеется несколько встроенных объектов, то они могут взаимодействовать и друг с другом. Характером этого взаимодействия тоже нужно управлять.

Взаимодействие объектов друг с другом


Создание Базы данных

Начало работы в СУБД. Создание базы данных

конец

вопросы

задания

Создание базы данных начинается с выбора переключателя Новая база данных. Далее задается Имя БД и ее местоположение.

Работа с любым объектом начинается с окна База данных. На его левой панели сосредоточены элементы управление для вызова семи типов объектов программы.


Создание межтабличных связей

Работа с таблицами. Создание межтабличных связей

конец

вопросы

задания

Вся необходимая работа осуществляется в специальном окне Схема данных, которое открывается кнопкой на панели инструментов [image] или командой Сервис → Схема данных.

Одновременно с открытием окна Схема данных открывается диалоговое окно Добавление таблицы, из которого выбираются таблицы, между которыми создаются связи.

Добавление таблиц осуществляется выделением их в списке и щелчком на кнопке Добавить. После добавления всех необходимых таблиц, окно Добавление таблиц, закрывается щелчком на кнопке Закрыть.

В итоге в окне Схема данных будут представлены все таблицы, создаваемой базы данных со списками своих полей. Ключевые поля выделены жирным шрифтом.

Определение связи по простому ключу. Установим связь между таблицами Группа (главная таблица) и Студент (подчиненная таблица) по простому ключу ШГ (шифр группы). Для этого, выделим поле ШГ в таблице Группа и перетащим его, не отпуская кнопку мыши, на список полей таблицы Студент. Отпустим кнопку мыши, в появившемся диалоговом окне Изменение связей отметим параметр Обеспечение целостности данных, а также установим Каскадное обновление связанных полей и Каскадное удаление связанных полей.

После нажатия кнопки Создать между таблицами будет установлена связь Один ко многим, обозначенная на схеме как 1 : ¥.

ЗАДАНИЕ 2

Установите также связи между таблицами Кафедра → Преподаватель (ключ ККАФ), Предмет → Изучение (ключ КП), Преподаватель → Изучение (ключ ТАБН), Группа → Изучение (ключ ШГ).

Определение связей по составному ключу. Установим связь между таблицами Студент и Успеваемость по составному ключу ШГ + НС (шифр группы + Номер студента). Для этого в главной таблице Студент, при нажатой кнопке CTRL, выделим оба поля, затем перетащим их на подчиненную таблицу Успеваемость. В правой половине окна Изменение связей выберем соответствующие поля ШГ и НС для связанной таблицы (список полей появится при щелчке мышью на соответствующем поле). Отметим параметр Обеспечение целостности данных, а также установим Каскадное обновление связанных полей и Каскадное удаление связанных полей.

ЗАДАНИЕ 3

Установите также связь между таблицами Изучение → Успеваемость (ключ ШГ + КП + ТАБН +ВИДЗ). В итоге должна получиться такая схема данных:


Создание таблиц

Работа с таблицами. Создание таблиц

конец

вопросы

задания

Создание таблиц. Создание таблицы начинается с выбора элемента управления Таблицы.

Чтобы создать таблицу вручную, следует использовать значок Создание таблицы в режиме конструктора. После чего появится окно Конструктора таблиц в виде графического бланка. В первом столбце в верхней части этого окна вводятся имена полей, во втором столбце из раскрывающегося списка выбирается тип для каждого поля. Открывается список кнопкой выбора типа поля, которая является скрытым элементом управления и отображается только после щелчка на поле бланка. Нижняя часть бланка содержит список свойств поля, выделенного в верхней части. Некоторые свойства заданы по умолчанию. Свойства можно настраивать, а можно и не трогать.

При создании таблицы целесообразно задать ключевое поле, которое впоследствии поможет устанавливать связи между таблицами. Для задания ключевого поля достаточно щелкнуть на его имени правой кнопкой мыши и в контекстном меню выбрать пункт Ключевое поле. Если ни одно из полей не является уникальным, то первичный ключ можно создать на базе двух (или более) полей. Групповое выделение выполняется при нажатой клавише Shift щелчками на квадратных маркерах слева от полей.

После определения всех полей таблицы окно проектировщика можно закрыть, при этом система выдает запрос на сохранение таблицы. Таблице дают имя, и с этого момента она доступна в числе прочих таблиц в основном окне База данных, где ее можно открыть в случае необходимости.

ЗАДАНИЕ 1

Создайте таблицы с указанной ниже структурой.

Таблица 1 Группа

Имя поля | Тип данных | Размер | Число дес. знаков | Подпись | Условие на значение | Сообщ. Об ошибке | Обязательное | Индексированное | Ключевое поле
ШГ | Текстовый | 8 |  | Шифр группы |  |  | Да | Да, совпадения не допускаются | *
КОЛ | Числовой | Байт |  | Кол студ. в группе | >=0 And <=35 | Кол. студ. Больше допустимого | Нет |  |
ПБАЛЛ | Числовой | С пл. тчк. 4 байта | 2 | Проход. балл | >2 And <=5 Or 0 | Ошибка в оценке | Нет |  |

Таблица 2 Кафедра

Имя поля | Тип данных | Размер | Подпись | Обязательное | Индексированное | Ключевое поле
ККАФ | Текстовый | 2 | Код кафедры | Да | Да, совпадения не допускаются | *
НКАФ | Текстовый | 15 | Название каф. | Нет |  |
ТЕЛ | Текстовый | 9 | Телефон | Нет |  |
ЗАВ | Текстовый | 15 | Ф.И.О. зав. каф. | Нет |  |
ФОТО | Поле объекта OLE |  | Фотография заведующего | Нет |  |

Таблица 3 Преподаватель

Имя поля | Тип данных | Размер | Подпись | Обязательное | Индексированное | Ключевое поле
ТАБН | Текстовый | 4 | Табельный номер | Да | Да, совпадения не допускаются | *
ФИО | Текстовый | 30 | ФИО препод. | Да |  |
СТ | Текстовый | 15 | Уч. степень | Нет |  |
ЗВ | Текстовый | 10 | Уч. звание | Нет |  |
ККАФ | Текстовый | 2 | Код кафедры | Да |  |

Таблица 4 Предмет

Имя поля | Тип данных | Размер | Подпись | Условие на значение | Сообщ. Об ошибке | Обязательное | Индексированное | Ключевое поле
КП | Текстовый | 2 | Код предмета |  |  | Да | Да, совпадения не допускаются | *
НП | Текстовый | 15 | Название предмета |  |  | Да |  |
ЧАСЫ | Числовой | Целое | Всего часов | > 0 And <= 300 | Ошиб. число часов | Нет |  |
ЛЕК | Числовой | Целое | Лекции |  |  | Нет |  |
ПР | Числовой | Целое | Практика |  |  | Нет |  |
ЧС | Числовой | Целое | Семестров |  |  | Нет |  |
ПРОГР | Поле МЕМО |  | Программа |  |  | Нет |  |

Таблица 5 Студент

Имя поля | Тип данных | Размер | Число дес. знаков | Подпись | Обязательное | Индексированное | Ключевое поле
ШГ | Текстовый | 8 |  | Шифр группы | Да | Да, совпадения допускаются по каждому полю | *
НС | Текстовый | 2 |  | Номер студента | Да
ФИО | Текстовый | 15 |  | Ф.И.О. | Да |  |
ГОДР | Числовой | Целое |  | Год рожд. | Нет |  |
ПБАЛЛ | Числовой | С пл. тчк. 4 байта | 2 | Прох. балл | Нет |  |

Таблица 6 Изучение

Имя поля | Тип данных | Размер | Подпись | Обязательное | Индексированное | Ключевое поле
ШГ | Текстовый | 8 | Шифр группы | Да | Да, совпадения допускаются по каждому полю | *
КП | Текстовый | 2 | Код предмета | Да
ТАБН | Текстовый | 4 | Таб. номер препод. | Да
ВИДЗ | Текстовый | 3 | Вид занятий | Да
ЧАСЫ | Числовой | Целое |  |  |  |

Таблица 7 Успеваемость

Имя поля | Тип данных | Размер | Подпись | Обязательное | Индексированное | Ключевое поле
ШГ | Текстовый | 8 | Шифр группы | Да | Да, совпадения допускаются по каждому полю | *
НС | Текстовый | 2 | Номер студента | Да
КП | Текстовый | 2 | Код предмета | Да
ТАБН | Текстовый | 4 | Таб. н. препод. | Да
ВИДЗ | Текстовый | 3 | Вид занятия | Да
ОЦЕНКА | Числовой | Целое |  | Нет |  |


Сортировка БД

Сортировка базы данных

конец

вопросы

задания

Для сортировки базы данных используется команда Данные → Сортировка. Диалоговое окно Сортировка диапазона служит для выбора поля, по которому производится сортировка.

Можно использовать несколько порядков сортировки одновременно. Первое из выбранных полей определяет режим первичной сортировки. Если при совпадении значений в этом поле существуют дополнительные критерии, определяющие порядок записей, то можно также задать поля для вторичной и третичной сортировки. По любому из полей сортировка может выполняться в порядке возрастания или убывания. Если сортировка производится по одному критерию, можно использовать кнопки [image] на Панели инструментов.

ЗАДАНИЕ 3

Отсортируйте базу Итоги сессии по полю Специальность, затем по полю Группа, затем по Фамилии.


Специальные символы

Ввод специальных и произвольных символов

конец

вопросы

задания

При вводе текста часто существует необходимость ввода специальных символов, у которых нет клавиши в раскладке клавиатуры или она неизвестна. Для этого используется команда Вставка → Символ. Диалоговое окно Символ имеет две вкладки: Символы и Специальные символы.

На вкладке Специальные символы присутствует список специальных символов, таких, как «длинное» тире, «копирайт», «торговая марка» и других. Многие из них имеют клавиатурные комбинации.

На вкладке Символы представлены элементы управления для ввода произвольных символов любых символьных наборов. Если символ нужно вставить многократно, за ним можно закрепить постоянную комбинацию клавиш (кнопка Клавиша)

ЗАДАНИЕ 8

В документе наберите и сформатируйте следующий текст с применением отступа справа и интервалов перед абзацами. Символ - это символ шрифта Wingdings.

Сохраните документ.


Списки

Средства создания маркированных и нумерованных списков

конец

вопросы

задания

Настройку списков выполняют в диалоговом окне Список, которое открывается командой Формат → Список. Окно имеет три вкладки: Маркированный список, Нумерованный список и Многоуровневый список. Для каждой вкладки представлены образцы оформления.

Можно использовать также кнопки Нумерация [image] и Маркеры [image] на панели Форматирование.

Выделите 4 абзаца. В меню Формат выполните команду Список. В открывшемся окне выберите вкладку Маркированный и тип маркера, нажмите кнопку ОК. Выбранные абзацы будут отмечены маркерами (маркированный список).

Выбрав вкладку Нумерованный Вы можете получить нумерованный список.

ЗАДАНИЕ 5

В созданном документе, наберите и отформатируйте следующий текст (размер шрифта 12, используйте иерархические списки):

Сохраните документ.


Ссылки

Сноски и перекрестные ссылки

конец

вопросы

задания

Сноски

Диалоговое окно для вставки ссылки вызывается с помощью меню Вставка → Сноска.

Перекрестные ссылки

Часто в документе необходимо сослаться на рисунок, таблицу, на источник и т.п. Для этого с помощью меню Вставка → Перекрестная ссылка вызывается диалоговое окно, в котором можно установить тип ссылки и выбрать конкретное значение.

ЗАДАНИЕ 12

Наберите следующий текст и сделайте перекрестные ссылки на соответствующие пункты списка литературы:

Отсортируйте (Таблица → Сортировка) литературу в списке в алфавитном порядке и обновите (функциональная клавиша F9) поля с перекрестными ссылками, а затем отмените две последние операции.

Сохраните документ.


Стили

Приемы и средства автоматизации разработки документов. Стили

конец

вопросы

задания

С рядом приемов автоматизации ввода и редактирования текста вы познакомились выше. К ним относятся средства Автотекст, Автозамена, средства проверки правописания, средства расстановки переносов, средства поиска и замены фрагментов текста, создание оглавления.

К общим средствам автоматизации разработки и оформления документов относятся стили оформления абзацев и шаблоны документов.

Работа со стилями

Абзац — элементарный объект оформления любого документа. Каждый заголовок документа тоже рассматривается как отдельный абзац. В меню Формат → Абзац имеется немало различных элементов управления, и выполнять их настройку для каждого абзаца отдельно — неэффективная и утомительная задача. Она автоматизируется путем использования понятия стиль.

Стиль оформления — это именованная совокупность настроек параметров шрифта, абзаца, языка и некоторых элементов оформления абзацев (линий и рамок). Благодаря использованию стилей обеспечивается простота форматирования абзацев и заголовков текста, а также единство их оформления в рамках всего документа.

Особенностью Microsoft Word является то, что они поддерживают два типа стилей: стили абзаца и знаковые стили (стили символов). С помощью стилей абзаца выполняют форматирование абзацев, а с помощью знаковых стилей можно изменять оформление выделенных фрагментов текста внутри абзаца.

Работа со стилями состоит в создании, настройке и использовании стилей. Некоторое количество стандартных стилей присутствует в настройке программы по умолчанию, сразу после ее установки. Их используют путем выбора нужного стиля из раскрывающегося списка на панели управления Форматирование.

Настройка стиля. Настройку стиля выполняют в диалоговом окне Стиль (Формат → Стиль).

Настраиваемый стиль выбирают в списке Стили (при этом на панелях Абзац и Знаки отображаются образцы применения данного стиля). Для изменения стиля служит командная кнопка Изменить, открывающая диалоговое окно Изменение стиля.

Каждый из компонентов стиля настраивается в отдельном диалоговом окне. Выбор компонента выполняют в меню, открываемом с помощью командной кнопки Формат.

При проведении настройки стиля важно правильно выбрать исходный стиль. Он должен быть как можно ближе к желаемому, чтобы минимизировать количество необходимых настроек.

Создание стиля. Для создания стиля служит командная кнопка Создать в диалоговом окне Стиль (Формат → Стиль) — она открывает диалоговое окно Создание стиля.

В данном окне следует:

· ввести название нового стиля в поле Имя;

· выбрать тип стиля (стиль абзаца или знаковый стиль);

· выбрать стиль, на котором основан новый стиль;

· указать стиль следующего абзаца;

· приступить к настройке элементов стиля щелчком на кнопке формат.

Наследование стиля. Важной чертой является принцип наследования стилей. Он состоит в том, что любой стиль может быть основан на каком-то из существующих стилей. Это позволяет, во-первых, сократить до минимума настройку стиля, сосредоточившись только на его отличиях от базового, а во-вторых, обеспечить принцип единства оформления всего документа в целом. Так, например, при изменении гарнитуры шрифта, использованного в базовом стиле, автоматически произойдут и изменения наследуемых элементов в стилях, созданных на его основе.

Стиль следующего абзаца указывают для обеспечения автоматического применения стиля к следующему абзацу, после того как предыдущий абзац закрывается клавишей ENTER.

ЗАДАНИЕ 15

Создайте новый документа. Настройте его стили по своему усмотрению. Сохраните его.


СУБД Access

Базы данных и системы управления базами данных

База данных – это организационная структура, предназначенная для хранения информации.

Система управления базой данных это комплекс программных средств, который предназначен для создания структуры новой базы, редактирования содержимого и визуализации информации, т.е. отбор отображаемых данных в соответствии с заданным критерием, их упорядочение, оформление и последующая выдача на устройство вывода или передача по каналам связи.

Система управления базой данных MS Access 2000

Access – это реляционная система управления базами данных (СУБД), входящая в пакет MS Office.

Все составляющие базы данных, такие, как таблицы, отчеты, запросы, формы и объекты, в Access хранятся в едином дисковом файле, который имеет расширение .mdb.

Основным структурным компонентом базы данных является таблица. В таблицах хранятся вводимые данные. Каждая таблица состоит из столбцов, называемых полями, и строк, называемых записями. Каждая запись таблицы содержит всю необходимую информацию об отдельном элементе базы данных.

При разработке структуры таблицы, прежде всего, необходимо задать поля, определив их свойства.

Свойства полей базы данных Access

Свойство

Его назначение

Имя поля

Определяет, как следует обращаться к данным этого поля. Должно быть уникальным, желательно таким, чтобы функция поля узнавалась по его имени.

Тип поля

Определяет тип данных, которые содержаться в данном поле.

Размер поля

Определяет предельную длину (в символах) данных, которые могут размещаться в данном поле.

Формат поля

Определяет способ форматирования данных в ячейках, принадлежащих полю.

Маска ввода

Определяет форму, в которой вводятся данные в поле.

Подпись

Определяет заголовок столбца таблицы для данного поля. Если не указана, то в качестве заголовка используется имя поля.

Значение по умолчанию

Значение, которое вводится в ячейки поля автоматически.

Условие на значение

Ограничение, используемое для проверки правильности ввода данных

Сообщение об ошибке

Текстовое сообщение, которое выдается автоматически при попытке ввода в поле ошибочных данных.

Обязательное поле

Определяет обязательность заполнения поля данными.

Пустые строки

Разрешает ввод пустых строковых данных

Индексированное поле

Позволяет ускорять все операции, связанные с поиском или сортировкой данных этого поля. Можно также задать проверку на наличие повторов для этого поля, чтобы исключить дублирование данных.

Необходимо отметить, что свойства полей существенно зависят от типа данных, содержащихся в поле.

Типы данных Access

Тип данных | Описание
Текстовый (Значение по умолчанию) | Текст или числа, не требующие проведения расчетов, например номера телефонов (до 255 знаков)
Числовой | Числовые данные различных форматов, используемые для проведения расчетов
Дата/время | Для хранения календарных дат и текущего времени
Денежный | Для хранения денежных сумм
Поле MEMO | Для хранения больших объемов текста (до 65535 символов)
Счетчик | Специальное числовое поле, в котором Access автоматически присваивает уникальный порядковый номер каждой записи. Значения полей типа счетчика обновлять нельзя
Логический | Может иметь только одно из двух возможных значений (True/False, Да/Нет)
Поле объекта OLE | Объект (например, электронная таблица Microsoft Excel, документ Microsoft Word, рисунок, звукозапись или другие данные в двоичном формате), связанный или внедренный в таблицу Access
Гиперссылка | Для хранения адресов URL Web-объектов Интернета.
Мастер подстановок | Создает поле, в котором предлагается выбор значений из списка или из поля со списком, содержащего набор постоянных значений или значений из другой таблицы. Это в действительности не тип поля, а способ хранения поля

Объекты базы данных

СУБД MS Access 2000 позволяет создавать и использовать объекты семи различных типов.

Таблицы. Это основные объекты любой базы данных. Именно в них хранятся, во-первых, все данные, имеющиеся в базе, а, во-вторых, структура самой базы (поля, их типы и свойства).

Запросы. Это объекты предназначены для извлечения данных из таблиц и предоставления их пользователю в удобном виде. Особенность запросов состоит в том, что берут информацию из базовых таблиц и создают на их основе временную результирующую таблицу, которая не имеет аналога на жестком диске, это только образ отобранных полей и записей.

Формы. Это средства для ввода и просмотра данных. С помощью форм можно закрыть некоторые поля для несанкционированного ввода, можно разместить специальные элементы управления (счетчики, раскрывающиеся списки, переключатели, флажки и пр.) для автоматизации ввода. Можно представить форму с помощью графических средств, в виде бланка, если ввод производится со специальных бланков.

С помощью формы можно не только вводить данные, но и отображать, применяя специальные средства.

Отчеты. Предназначены для вывода данных на печатающее устройство. В них приняты специальные меры для группирования выводимых данных и для вывода специальных элементов оформления, характерных для печатных документов (верхний и нижний колонтитулы, номера страниц и т.п.)

Страницы. Этот объект позволяет создать Web-страницы, компоненты которых осуществляют связь с базой данных. Web-страницу можно передать клиенту, сама же база будет располагаться на сервере.

Макросы и модули. Эти объекты предназначены как для автоматизации повторяющихся операций при работе с СУБД, так и для создания новых функций путем программирования. Макросы состоят из последовательности внутренних команд СУБД Access и являются одним из средств автоматизации работы с базой. Модули создаются средствами внешнего языка программирования Visual Basic for Applications.

Режимы работы с базами данных

Проектировочный. Этот режим работы предназначен для создания или изменения структуры базы, и создания ее объектов. С ним работают проектировщики БД.

Пользовательский. Этот режим предназначен для использования подготовленных ранее объектов для наполнения базы или получения данных из нее. С ним работают пользователи БД.


Схема БД Учебный процесс

Логическая модель базы данных "Учебный процесс"


Таблицы

Работа с таблицами

конец

вопросы

задания

Данные, представленные в табличной форме, отличаются наглядностью.

Ячейки таблиц могут содержать не только текст, но и графические и прочие объекты.

Создание таблиц

Три основные средства создания таблиц — это:

· кнопка Добавить таблицу [image] на панели инструментов Стандартная;

· диалоговое окно Вставка таблицы (Таблица → Добавить → Таблица);

· средство рисования таблиц Таблицы и границы (Таблица → Нарисовать таблицу)

Редактирование таблиц

Редактирование содержимого таблиц осуществляется обычными средствами. Далее под термином редактировании таблиц имеется в виду редактирование их структуры, которое сводится к следующим операциям:

· добавление заданного количества строк;

· добавление заданного количества столбцов;

· удаление выделенных ячеек, строк и столбцов;

· слияние выделенных ячеек;

· разбиение выделенных ячеек.

Комбинируя вышеуказанные операции, можно на основе базовых таблиц с простой структурой готовить таблицы, имеющие сложную структуру. Средства для выполнения этих операций находятся в меню Таблица.

Форматирование таблиц

При работе с таблицами следует различать форматирование таблиц и форматирование содержимого. В первом случае происходит управление размерами структурных элементов таблицы (ячеек, строк, столбцов и т. п.), а во втором — управление размещением содержимого ячеек.

Форматирование таблиц можно выполнять в командном или интерактивном режиме.

В командном режиме для этой цели используют диалоговое окно Свойства таблицы (Таблица → Свойства таблицы). Его можно открыть и из контекстного меню таблицы, если щелкнуть в ее пределах правой кнопкой мыши. Элементы управления вкладок диалогового окна Свойства таблицы позволяют:

· задать метод выравнивания таблицы относительно страницы документа (Таблица → Свойства таблицы → Таблица → Выравнивание);

· задать метод взаимодействия таблицы с окружающим текстом (Таблица → Свойства таблицы → Таблица → Обтекание);

· определить или переопределить вариант оформления внешних и внутренних рамок таблицы, а также настроить характер оформления ячеек (Таблица → Свойства таблицы → Таблица → Границы и заливка);

· задать размеры внутренних полей в ячейках и интервалы между ячейками (Таблица → Свойства таблицы → Таблица → Параметры);

· назначить параметры текущей строки или выделенных строк (Таблица → Свойства таблицы → Строка);

· назначить параметры текущего столбца или выделенных столбцов (Таблица » Свойства таблицы → Столбец);

· назначить параметры текущей ячейки или выделенных ячеек (Таблица → Свойства таблицы → Ячейка).

В интерактивном режиме таблицу форматируют с помощью маркеров, появляющихся при наведении указателя мыши на таблицу или ее элементы. Маркер в левом верхнем углу таблицы позволяет перемещать таблицу по рабочему полю документа. Маркер в правом нижнем углу позволяет управлять общими размерами таблицы. Маркеры изменения размера, появляющиеся при наведении указателя мыши на рамки таблицы, позволяют интерактивно изменять размеры столбцов и строк методом перетаскивания.

Ввод и форматирование содержимого таблиц

Выделение нужной ячейки для ввода текста выполняют с помощью мыши. Отдельную ячейку выделяют тройным щелчком левой кнопки. Перемещение между ячейками выполняют клавишей TAB (к следующей ячейке) или комбинацией SHIFT+TAB (к предыдущей ячейке). Для навигации по ячейкам таблицы можно также использовать клавиши управления курсором. Внутри текстовых фрагментов курсорные клавиши выполняют перемещение курсора, но по достижении границы текста они позволяют переходить к соседним ячейкам.

Все команды форматирования текста относятся к выделенному элементу. Выделенным элементом может быть любая ячейка, строка (группа строк), столбец (группа столбцов) или вся таблица в целом. Группы ячеек выделяют методом протягивания мыши. Большинство команд, связанных с форматированием элементов таблицы и содержащихся в них объектов, можно выполнить с помощью панели инструментов Форматирование.

ЗАДАНИЕ 1.

В документе наберите следующий текст с таблицей.

Обратите внимание, что в тексте есть сноска. Текст сноски следующий:

Сохраните документ.

Автоматическое форматирование таблиц

Автоматическое форматирование таблиц выполняют с помощью встроенного средства Автоформат, которое запускают командой Таблица → Автоформат (при наличии выделенной таблицы). Набор предлагаемых форматов представлен в списке Форматы, а результат, который получается при их использовании, — в поле Образец. Работа по форматированию таблицы полностью автоматизирована и сводится к тому, чтобы выбрать такой формат и так установить сопутствующие элементы управления, чтобы представленный образец наиболее соответствовал запланированному результату.

ЗАДАНИЕ 2.

В документе наберите следующий текст с таблицами:

Сохраните документ.

Скопируйте и вставьте таблицу 1, примените автоформатирование (формат: «Столбцы 1», изменение заливки, шрифта и цвета отключено). Не забудьте вставить автоматическую нумерацию таблиц.

Сохраните документ.


Табличный процессор

Одним из наиболее распространенных средств работы с документами, имеющими табличную структуру, является программа Microsoft Exel. Она предназначена для работы с таблицами данных, преимущественно числовых. При формировании таблицы выполняют ввод, редактирование, форматирование текстовых и числовых данных, а также формул. Наличие средств автоматизации облегчает эти операции.

Основные понятия электронных таблиц

Рабочая книга и рабочий лист. Строки и столбцы

Документы Excel называют рабочими книгами. Рабочие книги записываются как файлы с расширением .XLS.

Рабочая книга может содержать расположенные в произвольном порядке рабочие листы. Имена листов отображаются на ярлыках в нижней части окна книги. Для перехода с одного листа на другой следует щелкнуть мышью по соответствующему ярлыку. Название текущего (активного) листа выделено.

Рабочее поле Excel – это электронная таблица, состоящая из столбцов и строк. Названия столбцов – буква или две буквы латинского алфавита. Каждая строка таблицы пронумерована. Размер таблицы фиксирован: число столбцов – 256, строк – 65536.

Создается рабочая книга командой Файл, Создать или кнопкой <Создать>, при этом используется один из готовых шаблонов.

Ячейки и их адресация

Пересечение конкретного столбца и строки образует ячейку, которая является минимальным элементом хранения данных. Местоположение ячейки задается адресом, образованным из имени столбца и номера строки, на пересечении которых находится эта ячейка, а также при необходимости в адресе указывается имя листа и имя книги. Наряду с понятием адреса в электронной таблице используется понятие ссылки. Ссылка - это элемент формулы и используется тогда, когда надо сослаться на какую-нибудь ячейку таблицы. В этом случае адрес будет использоваться в качестве ссылки.

Одна из ячеек всегда является активной и выделяется рамкой. Эта рамка играет роль табличного курсора. Операции ввода и редактирования всегда производятся в активной ячейке. Переместить рамку активной ячейки можно с помощью курсорных клавиш или указателя мыши.

Диапазон ячеек

На данные, расположенные в соседних ячейках, можно ссылаться в формулах, как на единое целое. Такую группу ячеек называют диапазоном. Наиболее часто используют прямоугольные диапазоны, образующиеся на пересечении группы последовательно идущих строк и группы последовательно идущих столбцов. Диапазон ячеек обозначают, указывая через двоеточие номера ячеек, расположенных в противоположных углах прямоугольника, например A1:C15.

Выделяется прямоугольный диапазон ячеек протягиванием указателя мыши от одной угловой ячейки до противоположной по диагонали. Рамка текущей ячейки при этом растягивается, охватывая весь выбранный диапазон. Чтобы выбрать столбец или строку целиком, достаточно щелкнуть на заголовке столбца (строки). Протягиванием указателя по заголовкам можно выбрать несколько идущих подряд столбцов или строк.

Изменение установок среды

Для изменения установок среды Excel, что повлечет за собой изменение установок текущей (активной) книги, можно воспользоваться командой Сервис, Параметры, вкладка Общие.

На вкладке Общие указывается:

· режим, при котором ссылки записываются в стиле R1C1 (адрес клетки – номер строки и номер столбца);

· максимальное количество элементов в списке (с которыми работали в предыдущих сеансах);

· звуковое сопровождение событий;

· надо ли предлагать заполнение свойств файла (таких, как тематическое назначение рабочей книги, ключевые слова, автор рабочей книги, комментарии);

· надо ли Игнорировать DDE-запросы от других приложений, т.е. для игнорирования запросов с использованием Динамического Обмена Данными (DDE) из других приложений;

· количество листов при создании новой книги;

· тип и размер шрифта, используемого при вводе данных в таблицу;

· рабочий каталог (папку);

· каталог (папку) автозагрузки;

· имя пользователя.

Назначение других вкладок команды Сервис, Параметры:

· Вкладка Вид определяет внешний вид экрана, что обеспечивается заданием режима отображения (да ли нет) строки формул в верхней части окна; строки состояния в нижней части окна; графических объектов; формул или их значений; сетки, заголовков строк и столбцов таблицы; постранично; горизонтальной и вертикальной полос прокрутки, ярлычков листов.

· Вкладка Вычисления управляет процессом вычисления в таблице: задается автоматический либо под управлением пользователя режим изменения значений аргументов в формуле; задается число итераций при поиске решений и для прерывания циклической ссылки; определяется точность вычислений, система дат и пр.

· Вкладка Правка обеспечивает установки для редактирования листа книги с помощью флажков: редактирование непосредственно в ячейке, перемещение и копирование ячеек с использованием перетаскивания, направление перехода после ввода данных в ячейку и др.

· Вкладка Цвет обеспечивает выбор цветовой палитры для оформления диаграмм и других графических объектов.

· Вкладка Диаграмма обеспечивает задание параметров вывода активной диаграммы и режим отображения (названий и значений) во всплывающих подсказках, при установке указателя мыши на элементе диаграммы.

· Вкладка Списки обеспечивает выбор конкретного списка названий для редактирования.

· Вкладка Переход задает установку формата записи файлов Excel, параметры вывода на экран таблицы в режиме просмотра и открытия книги, правила вычислений и преобразования формул при открытии файлов Lotus 1-2-3 в Microsoft Excel.

Типовые технологические операции с рабочими книгами и листами

Название операции

Технология выполнения операции

Создать новую книгу

  1. Выполнить команду Файл, Создать

  2. Указать тип шаблона – Книга

Открыть книгу

1. Выполнить команду Файл, Открыть

2. Указать тип, имя файла, папку

Закрыть рабочую книгу

1. Щелкнуть левой кнопкой мыши на любом листе книги

2. Выполнить команду Файл, Закрыть

Сохранить новую книгу

1. Выполнить команду Файл, Сохранить как

2. Указать тип, имя файла, папку, параметры сохранения (автоматическое создание резервных копий, пароль защиты для открытия и записи, рекомендовать только для чтения).

Сохранить книгу, которая ранее уже сохранялась

Выполнить команду Файл, Сохранить или нажать на панели Стандартная кнопку <Сохранить>

Скрыть рабочую книгу

1. Установить курсор на любом листе книги

3. Выполнить команду Окно, Скрыть

Показать скрытую рабочую книгу

1. Выполнить команду Окно, Отобразить

2. Выбрать книгу из списка скрытых

Поиск файлов

1. Выполнить команду Файл, Открыть, Найти

2. Осуществить расширенный поиск файлов с помощью нажатия кнопки <Отбор> в окне Открытие документа

Выделить рабочий лист

1. Установить курсор мыши на ярлык рабочего листа

2. Нажать левую кнопку мыши

Вызов контекстного меню команд листа

1. Установить курсор мыши на ярлык рабочего листа

2. Нажать правую кнопку мыши

Выделить несколько смежных рабочих листов

1. Выделить первый рабочий лист

2. Выделить последний рабочий лист диапазона листов при нажатой клавише <Shift>

Выделить несколько несмежных рабочих листов

1. Выделить первый рабочий лист

2. Последующие листы выделять при нажатой клавише <Ctrl>

Снять выделение рабочих листов

1. Вызвать контекстное меню команд

2. Выполнить команду Разгруппировать листы

Вставить рабочий лист (несколько рабочих листов

1. Выделить рабочий лист, перед которым надо вставить новый лист

2. Вызвать контекстное меню и выполнить команду Добавить

Переименовать рабочий лист

1. Выделить рабочий лист

2. Выполнить команду Формат, Лист, Переименовать

Альтернатива

Вызвать контекстное меню и выполнить команду Переименовать

Удалить рабочий лист (несколько рабочих листов)

1. Выделить рабочий лист или группу листов

2. Выполнить команду Правка, Удалить лист

Альтернатива

Вызвать контекстное меню и выполнить команду Удалить

Скрыть рабочие листы

1. Выделить рабочие листы

2. Выполнить команду Формат, Лист, Скрыть

Показать скрытый рабочий лист

1. Выполнить команду Формат, Лист, Отобразить

2. Выбрать из списка скрытых листов нужный лист

3. Нажать кнопку <ОК>

Переместить или скопировать рабочий лист (несколько рабочих листов)

1. Выделить рабочий лист, щелкнув по нему левой кнопкой мыши

2. Выполнить команду Правка, Переместить/ скопировать лист или команду Переместить/ скопировать из контекстного меню

3. В диалоговом окне:

  • из списка выбрать имя книги, куда идет перемещение или копирование;

  • выбрать лист, перед которым будет помещена копия;

  • установить (снять) флажок при копировании (перемещении);

  • нажать кнопку <ОК>.

  4. Выбрать переключатель Создавать Копию (при копировании листа)


Тархов Сергей Владимирович

Рамбургер Ольга Леонардовна

старший преподаватель
кафедры информатики
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76

[На главную страницу]


Тархов Сергей Владимирович

Минасов Шамиль Маратович

кандидат технических наук, старший преподаватель.

Кафедра информатики
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76
E-mail: minasov@ufanet.ru

[На главную страницу]


Тархов Сергей Владимирович

докторант, кандидат технических наук, доцент.

Кафедра информатики
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76
E-mail: TarkhovSV@soros.bachedu.ru

С 1990 г. преподает дисциплины "Информатика", "Компьютерные технологии", Электронный офис", "Системы подготовки деловой документации", "Организация интерфейса в человеко-машинных системах" и др.

Один из авторов новой инструментально обеспеченной методики преподавания дисциплины “Информатика” и других дисциплин компьютерного профиля для подготовки бакалавров и магистров, внедренной в учебный процесс в ряде вузов региона.

В 1998 году им получен и успешно выполнен грант "Института Открытое общество" (фонд Сороса) "Музей истории отечественных компьютеров", опубликованный http://www.bashedu.ru/konkurs/tarhov/index.htm и размещенный на CD Московского Центра интернет-образования в разделе "Ресурсы Интернета".

Тархов С.В. является автором более 90 научных и методических работ.

Область научный интересов: проектирование информационно-обучающих сред для образовательных систем.

[На главную страницу]


Текстовый процессор

Технология работы с документами в текстовом процессоре
Microsoft Word 2000

Текстовый процессор MS Word

Лабораторная работа №1

Лабораторная работа №2

[На главную страницу]


Текстовый процессор Word

Общее название программных средств, предназначенных для создания, редактирования, и форматирования текстовых документов – текстовые процессоры.

В настоящее время в России наибольшее распространение имеет текстовый процессор Microsoft Word. Это связано, прежде всего, с тем, что его создатели относительно давно предусмотрели локализацию программы в России путем включения в нее средств поддержки работы с документами, исполненными на русском языке.

Рабочее окно процессора Microsoft Word 2000

Основные элементы управления окна: строка меню, панель инструментов, рабочее поле и строка состояния, включающая индикаторы. Панель инструментов является настраиваемой.

Режимы отображения документов

Microsoft Word 2000 поддерживает несколько режимов представления документов:

В обычном режиме представляется только содержательная часть документа без реквизитных элементов оформления, относящихся к печатным страницам, таких как: колонтитулы, подстраничные сноски и т.п. Этот режим удобен на ранних этапах разработки документа (ввод текста, редактирование, рецензирование), а также во всех случаях, когда содержательная часть документа имеет более высокое значение, чем внешнее представление. В этом режиме операции с объемными документами происходят быстрее.

В режиме Web-документа экранное представление не совпадает с печатным. Оно характерно для электронных публикаций в WWW. Назначенные параметры страницы не учитываются, а форматирование на экране является относительным. В этом режиме разрабатывают электронные публикации.

В режиме разметки экранное представление документа полностью соответствует печатному, вплоть до назначенных параметров страницы. Этот режим удобен для большинства работ, связанных с форматированием текста, предназначенного для печати.

В режиме структуры можно отобразить только заголовки документа. Режим полезен в тех случаях, когда разработку документа начинают с создания плана содержания. Режим отличается тем, что при его включении на панели инструментов автоматически открывается вспомогательная панель Структура

Выбор одного из выше указанных режимов представления документа выполняют с помощью командных кнопок, расположенных в левом нижнем углу окна приложения [image] , или командами меню Вид.

Через меню Файл доступны еще два режима представления документа, используемые для предварительного просмотра. Для электронных документов используют команду Файл → Предварительный просмотр Web-страницы, а для печатных – Файл → Предварительный просмотр.

Масштаб отображения документа

Если шрифт на экране выглядит слишком мелким, нужно настроить масштаб отображения документа командой Вид → Масштаб или использовать раскрывающийся список Масштаб на панели инструментов Стандартная [image] . Если желаемого масштаба нет в списке, его можно ввести непосредственно в поле списка.

Работа с несколькими документами

Текстовый процессор Microsoft Word позволяет работать одновременно с несколькими документами. Каждый из них открывается в своем окне. Эти окна не выходят за пределы общего окна программы, но могут перекрывать друг друга. С помощью меню Окно можно управлять удобным размещением этих окон и переключаться между ними. Команда Окно → Упорядочить все позволяет увидеть в рабочей области все окна документов одновременно. В этом случае окна располагаются друг над другом и принимают одинаковый размер. Каждое окно имеет свои кнопки: свернуть, развернуть, закрыть [image] . После сворачивания окно документа отображается в виде небольшой панели в левом нижнем углу рабочей области.

Панели инструментов Microsoft Word 2000

Подключение необходимых панелей инструментов выполняется с помощью команды меню Вид → Панели инструментов.

Панели инструментов программы Word 2000

Панель инструментов | Состав, назначение | Примечание
Стандартная | Элементы управления файловыми операциями, редактированием, экранным отображением | Устанавливается по умолчанию
Форматирования | Элементы управления форматированием документов | Устанавливается по умолчанию
Visual Basic | Доступ к средствам создания и редактирования макросов и Web-сценариев, а также к настройке средств безопасности при запуске макросов | Макросы служат для автоматизации типовых операций. Web-сценарии обеспечивают динамичный характер просмотра Web-страниц
Web | Элементы управления для навигации в Web-структурах данных | В качестве Web-структур могут выступать WWW, корпаративные сети Internet системы Web-документов локального компьютера
Web-компоненты | Комплект готовых компонентов для создания элементов управления Web-страницы или электронной формы | Применяются для создания обратной связи с потребителем документа
WordArt | Элементы управления для создания художественных заголовков |
Автотекст | Средство быстрого доступа к настройке функции автотекста | Одновременно представляет быстрый доступ к средствам настройки функций автозамены и автоформата
База данных | Элементы управления, характерные для работы с базами данных (сортировка, поиск, управление структурой таблиц и прочее) | В качестве базы данных могут выступать как таблицы Access, так и собственные таблицы Word
Буфер обмена | Средство управления расширенным буфером обмена Word 2000 | Буфер обмена Word 2000 может содержать до 12 объектов
Настройка изображения | Элементы управления для основных функций настройки растровых изображений | Позволяют настраивать яркость, контрастность, Размер, рамку, режимы обтекания текстом и прочие параметры выделенного растрового объекта
Рамки | Элементы управления для создания фреймов (не путать с рамками, создаваемыми с помощью панели инструментов Таблицы и границы) | Word 2000 поддерживает два типа фреймов. Фреймы в электронных документах представляют собой особые прямоугольные области, предназначенные для вывода нескольких Web-документов в рамках одной Web-страницы. Фреймы в печатных документах представляют особые области печатной страницы для вывода специальной информации, например колонтитулов
Рецензирования | Элементы управления для проведения редактирования и комментирования документов без искажения исходного текста | Измененные данные сохраняются в том же документе на правах новых версий. Автор исходного текста имеет возможность просмотреть предлагаемые изменения, после чего принять их или отвергнуть
Рисование | Элементы управления и инструменты для выполнения простейших чертежно-графических работ | Графические объекты, создаваемые инструментами данной панели, имеют характер векторных объектов
Таблицы и границы | Элементы управления для создания таблиц и оформления текстовых блоков рамками | Дополнительно предоставляет средства для сортировки данных и проведения итоговых расчетов в таблицах (Функция Автосумма)
Формы | Элементы управления для разработки стандартных форм | Word 2000 позволяет создавать три типа форм: Web-формы, являющиеся объектами Web-страниц; формы Word, распространяемые и заполняемые как электронный документ; печатные формы
Элементы управления | Набор готовых компонентов ActiveХ для создания элементов управления Web-страниц и Web-форм | Средства данной панели инструментов позволяют использовать около 150 готовых компонентов, а также проводить установку и регистрацию дополнительных компонентов ActiveX

Настройка текстового процессора Word

Первичная настройка текстового процессора осуществляется следующими командами:

· Сервис → Параметры;

· Сервис → Автозамена;

· Сервис → Язык;

· Вид → Панели инструментов;

· Вид → Масштаб.

С помощью команды меню Сервис → Параметры. В окне Параметры во вкладке Общие можно настроить единицы измерения параметров документа, количество документов для быстрого открытия и т.п. Во вкладке Правка можно установить параметры правки, во вкладке Сохранение. настроить функцию автосохранения и т.д.

С помощью команды меню Сервис → Автозамена можно включить или выключить ряд средств автоматического форматирования.

С помощью команды меню Сервис → Язык можно включить или отключить расстановку переносов.


Фильтрация БД

Фильтрация базы данных

конец

вопросы

задания

Так как база данных может включать огромное число записей (в программе Excel естественным пределом служит максимальное число строк рабочего листа — 65536), не всегда требуется отображать все эти записи. Выделение подмножества общего набора записей называется фильтрацией. Наиболее простым способом фильтрации в программе Excel является использование автофильтра.

Применение авюфильтра. Включение режима фильтрации осуществляется командой Данные → Фильтр → Автофильтр. При этом для каждого поля базы данных автоматически создается набор стандартных фильтров, доступных через раскрывающиеся списки. Раскрывающие кнопки этих списков отображаются возле поля заголовка каждого столбца.

По умолчанию используется вариант Все, указывающий, что записи базы данных должны отображаться без фильтрации. Вариант Первые 10… позволяет отобрать определенное число (или процент) записей по какому-либо критерию. Вариант Условие позволяет задать специальное условие фильтрации.

Кроме того, имеется возможность отбора записей, имеющих в нужном поле конкретное значение.

При применении фильтра записи, не попадающие в отобранное подмножество, скрываются и не отображаются. Исходные номера отобранных записей сохраняются, но отображаются голубым цветом. Точно таким же цветом изображается заголовок поля (или нескольких полей), по которому была выполнена фильтрация.

Отфильтрованная база данных может использоваться при печати (печатаются только записи, относящиеся к выбранному подмножеству) и при построении диаграмм (график строится на базе выбранных записей). В последнем случае смена критериев фильтрации автоматически изменяет вид диаграммы.

ЗАДАНИЕ 4

Используя Автофильтр, отфильтруйте базу Итоги сессии, выбрав конкретную специальность и конкретную группу. Затем для поля Средний балл задайте условие таким образом, чтобы отфильтрованный список содержал записи студентов, получивших в сессию положительные оценки и имеющих только одну тройку.


Форматирование абзацев

Форматирование текста (настройка параметров абзаца)

начало

назад

вперед

конец

вопросы

задания

Кроме выравнивания настраиваются следующие параметры абзаца:

· Величина отступа слева;

· Величина отступа справа;

· Красная строка;

· Величина интервала (отбивка) перед абзацем и после него.

Использование различных способов выравнивания абзацев позволяет улучшить вид документа и сделать его понятнее. MS Word выравнивает текст абзаца относительно полей страницы или, если у абзаца есть отступ, относительно краев абзаца. По умолчанию все абзацы выравниваются по левому краю. При желании текст можно выровнять по правому краю, по центру или по обоим краям абзаца. В последнем случае MS Word изменяет интервал между словами таким образом, чтобы и левый, и правый край абзаца был ровным.

Поместите мигающий курсор в тот абзац, который хотите выровнять. Если надо выровнять несколько абзацев - выделите их. Выберите команду Абзац в меню Формат.

Установите необходимые параметры в появившемся окне и нажмите кнопку ОК.

Отформатировать абзац, используя стиль уже готового, подходящего абзаца, можно также, используя форматирование по образцу. Для этого надо установить курсор на абзац, имеющий нужное форматирование, и щелкнуть на кнопке Формат по образцу Панели инструментов [image] . Затем щелкнуть на абзаце, формат которого требуется изменить.

Расстановка переносов

Для расстановки переносов выберите команду Язык → Расстановка переносов… в меню Сервис. Это позволяет уменьшить неровность правого края текста.

ЗАДАНИЕ 4

В созданном документе, наберите и отформатируйте следующий текст (размер шрифта 12):

Сохраните документ.


Форматирование линейкой

Форматирование с помощью линейки

конец

вопросы

задания

Под панелями инструментов располагается линейка, проградуированная в сантиметрах. Она помогает контролировать размещение элементов страницы и управлять операциями форматирования.

Она позволяет управлять боковыми границами и позициями табуляции текущего абзаца. Границы абзаца задают путем перемещения (перетаскивания) специальных маркеров.

1. Треугольный маркер, расположенный слева внизу (острием вверх) задает левую границу для всех строк абзаца, кроме первой.

2. Перевернутый треугольный маркер слева вверху задает линию начала первой строки абзаца и позволяет сформировать абзацный отступ.

3. Квадратный маркер под линейкой – это элемент управления, всегда располагающийся под треугольным маркером левой границы. При его перетаскивании оба маркера левой границы перемещаются вместе, с сохранением их относительного расположения.

4. Треугольный маркер справа задает правую границу текущего абзаца.

5. Маркер табуляции, расположенный в левом углу линейки, задает позиции табуляции. Применяется, когда строка состоит из нескольких полей. По умолчанию позиции табуляции располагаются через каждые 1,27 см и отмечаются на линейке короткими вертикальными засечками.

Виды маркеров табуляции

Позиция табуляции с выравниванием по левому краю.

Текст располагается справа от указанной позиции, начинаясь непосредственного с этого места.

Позиция табуляции с выравниванием по центру.

Текст располагается симметрично относительно указанной позиции.

Позиция табуляции с выравниванием по правому краю.

Текст располагается слева от указанной позиции, заканчиваясь в указанном месте.

Позиция табуляции с выравниванием по символу.

Позволяет, например, расположить столбец чисел разной длины так, что десятичные запятые располагаются друг под другом..

Выбранный маркер табуляции устанавливается щелчком на линейке. Затем его положение можно менять перетаскиванием. Для удаления символа табуляции его перетаскивают за пределы линейки.

Для перехода между позициями табуляции используют клавиши TAB и BACKSPACE.

ЗАДАНИЕ 6

Наберите следующий текст, отформатируйте его, используя линейку и маркер табуляции с выравниванием по символу:

Сохраните документ.


Форматирование шрифта

Форматирование текста (настройка шрифта)

начало

назад

вперед

конец

вопросы

задания

Форматирование текста осуществляется средствами меню Формат или панели Форматирование.

Основные приемы форматирования :

· выбор и изменение гарнитуры, размера, начертания и цвета шрифта;

· выбор метода выравнивания;

· создание маркированных и нумерованных списков;

· управление параметрами абзаца.

Настройка шрифта

Настройку выполняют в диалоговом окне Шрифт (Формат → Шрифт), которое имеет три вкладки Шрифт, Интервал, Анимация.

или с помощью кнопок панели Форматирование [image] .

Настройка методов выравнивания

Поддерживаются четыре метода выравнивания:

· По левому краю;

· По центру;

· По правому краю;

· По ширине.

Выбор метода выполняют соответствующими кнопками панели инструментов Форматирование [image] или из раскрывающегося списка Формат → Абзац → Отступы и интервалы → Выравнивание. Избранный метод действует на текущий и последующие вводимые абзацы. Выбор метода определяется назначением документа.

ЗАДАНИЕ 3

В созданном документе, наберите следующий текст:

Сохраните документ.


Формулы

Вычисления в таблицах программы Exсel осуществляется с помощью формул. Формула может содержать числовые константы, ссылки на ячейки и функции Exсel, соединенных знаками математических операций. Скобки позволяют изменить стандартный порядок выполнения действий. В текущей ячейке отображается результат выполнения формулы, а сама формула отображается в строке формул.

Ссылки на ячейки

Вместо чисел в формуле использованы имена ячеек – ссылки на ячейки. Ссылки выполняют роль адресов ячеек, содержимое которых используется в вычислениях. Результат расчета зависит от того, какие числа находятся в ячейках. Т.е. ячейка, содержащая формулу, является зависимой, и подлежит пересчету всякий раз, когда изменяются значения в ячейках, на которые указывают ссылки, входящие в формулу.

Ссылку можно задать вручную или щелкнуть на нужной ячейке (выбрать нужный диапазон) указателем мыши.

Для редактирования формулы следует дважды щелкнуть на соответствующей ячейке. При этом ячейки, от которых зависит значение формулы, выделяются на рабочем листе цветными рамками, а сами ссылки отображаются в ячейке или в строке формул тем же цветом.

Ссылки абсолютные и относительные

Относительная адресация. От метода адресации ссылок зависит, что будет с ними происходить при копировании формулы из одной ячейки в другую. По умолчанию, ссылки на ячейки в формулах рассматриваются как относительные. Это означает, что ссылки при копировании формулы из одной ячейки в другую автоматически изменяются. Они приводятся в соответствие с относительным расположением исходной ячейки и создаваемой копии.

Например, в ячейке В7 записана формула, в которой имеются две ссылки: одна ссылается на ячейку, которая находится на две строки выше (В5), а другая ссылается на ячейку, которая находится на одну строку выше (В6). При копировании формулы в ячейку С7, относительное указание ссылок сохранится, т.е. формула в этой ячейке будет такой =С5 + С6.

Абсолютная адресация. Однако иногда возникают ситуации, когда при заполнении ячеек формулой необходимо сохранить абсолютный адрес ячейки (т.е. не менять его), если, например, она содержит значение, используемое при последующих вычислениях в других строках и столбцах. Для задания абсолютной ссылки надо задать перед обозначением номера столбца или номера строки символ $.

Для изменения способа адресации можно выделить ячейку в строке формул и нажать клавишу F4. Абсолютной можно сделать ссылку на всю ячейку, отдельно только на столбец или только на строку. При последовательных нажатиях клавиши F4 номер ячейки А1 будет записываться как A1, $A$1, A$1, $A1.

Автозаполнение формулами

Производится аналогично автозаполнению числами. Особенность заключается в необходимости копирования ссылок на другие ячейки. Во внимание принимается характер ссылок в формуле: относительные ссылки автоматически настраиваются на новый адрес, а абсолютные ссылки остаются без изменений.

ЗАДАНИЕ 4

Произведите расчеты в созданной таблице, используя формулы и автозаполнение. Объедините ячейки A1 – E1 c помощью команды меню Формат → Ячейки, выбрав вкладку Выравнивание. Измените цвет ячеек. Пересчитайте итоговые значения за квартал расходов, прихода и прибыли в доллары (используйте абсолютную адресацию). В ячейке F3 разрешите перенос по словам.

Сохраните книгу.


Формулы

Ввод формульных выражений

конец

вопросы

задания

Для ввода формул в текстовом процессоре Microsoft Word 2000 есть специальное средство — редактор формульных выражений Microsoft Equation 3.0. Он позволяет создавать формульные объекты и вставлять их в текстовый документ.

Особенности редактора формул

1. Редактор формул Microsoft Equation 3.0 представляет собой отдельный компонент, поэтому при установке текстового процессора требуется специально указать необходимость его подключения.

2. При работе с редактором формул следует стремиться к максимальной полноте вводимых выражений. Так, например, выражение (формула) может содержать компоненты, ввод которых возможен и без использования редактора формул, но для удобства работы и простоты дальнейшего редактирования следует вводить всю формулу целиком только в редакторе формул, не используя иные средства.

3. При вводе формул и выражений не рекомендуется использовать символы русского алфавита. В тех случаях, когда они необходимы, например, в качестве описательных индексов переменных, им следует назначать стиль Текст.

4. В редакторе формул не работает клавиша ПРОБЕЛ, поскольку необходимые интервалы между символами создаются автоматически. Однако если необходимость ввода пробелов все-таки возникнет, то их можно вводить с помощью кнопки Пробелы и многоточия панели инструментов Формула. Всего предусмотрено пять разновидностей пробелов различной ширины.

Запуск и настройка редактора формул

Для запуска редактора формул служит команда Вставка → Объект. В открывшемся диалоговом окне следует выбрать пункт Microsoft Equation 3.0 — откроется панель управления Формула. При этом строка меню текстового процессора замещается строкой меню редактора формул.

Прежде чем пользоваться редактором формул, следует выполнить его настройку. Настройка состоит в назначении шрифтов для различных элементов, входящих в формулы. Она выполняется в диалоговом окне Стили, открываемом командой Стиль → Определить.

Прочие настройки редактора формул выполняют в диалоговом окне Интервал (Формат → Интервал). Многочисленные средства настройки, присутствующие в нем, предназначены для задания размеров различных элементов формул.

Панель инструментов редактора формул содержит два ряда кнопок. Кнопки нижнего ряда создают своеобразные шаблоны, содержащие поля для ввода символов. Так, например, для ввода обыкновенной дроби следует выбрать соответствующий шаблон, имеющий два поля: числитель и знаменатель. Заполнение этих полей может производиться как с клавиатуры, так и с помощью элементов управления верхней строки. Переходы между полями выполняют с помощью клавиш управления курсором.

Ввод и редактирование формул завершается нажатием клавиши ESC или закрытием панели редактора формул. Можно также щелкнуть левой кнопкой мыши где-либо в поле документа вне области ввода формулы. Введенная формула автоматически вставляется в текст в качестве объекта. Далее ее можно переместить в любое иное место документа через буфер обмена (CTRL+X — вырезать; CTRL+V — вставить).

Для редактирования формулы непосредственно в документе достаточно выполнить на ней двойной щелчок. При этом автоматически открывается окно редактора формул.

ЗАДАНИЕ 4

В документе наберите следующий текст с формулами:

Сохраните документ.


Формы на основе запросов

Запросы. Создание форм, разработанных на основе запросов

конец

вопросы

задания

Автоматизированное средство Мастер форм позволяет создать структуру формы в режиме диалога. Воспользуемся им, чтобы создать форму для просмотра запроса Успеваемость студентов.

Мастер форм можно запустить из окна База данных щелчком на значке Создание формы с помощью мастера на панели Формы.

1. На первом этапе работы Мастера выбирают запросы (таблицы) и поля, которые войдут в будущую форму.

2. На втором, т.к. запрос построен на основе нескольких таблиц, определяется подчиненная таблица.

3. На третьем и четвертом этапах определяется внешний вид и стиль формы.

4. На последнем этапе выполняется сохранение основной и подчиненной форм

После просмотра готовой формы ее можно подкорректировать в режиме Конструктора.

ЗАДАНИЕ 15.

Используя все сказанное выше, создайте форму Успеваемость студентов по предметам, добавив в подчиненную форму шифр группы, для этого скорректируйте запрос Успеваемость студентов.

Просмотрите готовую форму, если надо поправьте ее в режиме Конструктора.


Формы на основе таблиц

Работа с формами. Создание форм на основе таблиц

конец

вопросы

задания

Формы позволяют вводить данные в таблицы базы без непосредственного доступа к самим таблицам.

Автоформы. В отличие от таблиц, структуру которых лучше формировать вручную, формы удобно готовить с помощью средств автоматизации. Существуют три вида автоформ: «в столбец»,

«ленточные»

и «табличные».

Как видно из рисунков, автоформа «в столбец» отображает все поля одной записи – она удобна для ввода и редактирования данных. «Ленточная» автоформа отображает одновременно группу записей – ее удобно использовать для оформления вывода данных. Табличная автоформа по внешнему виду ничем не отличается от таблицы, на которой она основана.

Для создания автоформы следует открыть панель Формы в окне База данных и воспользоваться командной кнопкой [image] . В открывшемся диалоговом окне Новая форма выбирают тип автоформы и таблицу, на которой она основывается. После щелчка на кнопке ОК автоформа формируется автоматически и немедленно готова к работе, т.е. к вводу или отображению данных.

Автоформа основывается только на одном объекте, она называется еще простой формой. Если форма основывается на полях из нескольких связанных таблиц, то она называется сложной. Для ее создания используют другие средства.

ЗАДАНИЕ 5

Создайте автоформы (в столбец) на таблицы Предмет, Кафедра, Преподаватель, Группа, Студент, Изучение, Успеваемость.


Функции

Вычисления в электронных таблицах. Стандартные функции

конец

вопросы

задания

Использование стандартных функций

Стандартные функции используются в программе Excel только в формулах. Вызов функции состоит в указании в формуле имени функции, после которого в скобках указывается список параметров. Отдельные параметры разделяются в списке точкой с запятой. В качестве параметра может использоваться число, адрес ячейки или произвольное выражение, для вычисления которого также могут использоваться функции.

Палитра формул. Если начать ввод формулы щелчком на кнопке Изменить формулу (в строке формул) [image] , то под строкой формул появляется палитра формул, обладающая свойствами диалогового окна. В левой части строки формул, где раньше располагался номер текущей ячейки, теперь появляется раскрывающийся список функций. Он содержит десять функций, которые использовались последними, а также пункт Другие.

Использование мастера функций. При выборе пункта Другие функции… запускается Мастер функций, облегчающий выбор нужной функции. В списке Категория выбирается категория, к которой относится функция (если определить категорию затруднительно, используют пункт Полный алфавитный перечень), а в списке Функция — конкретная функция данной категории.

После щелчка на кнопке ОК имя функции заносится в строку формул вместе со скобками, ограничивающими список параметров. Текстовый курсор устанавливается между этими скобками.

Ввод параметров функции. В ходе ввода параметров функции палитра формул изменяет вид. На ней отображаются поля, предназначенные для ввода параметров. Если название параметра указано полужирным шрифтом, то этот параметр является обязательным и соответствующее поле должно быть заполнено. Параметры, названия которых приводятся обычным шрифтом, можно опускать. В нижней части палитры приводится краткое описание функции, а также назначение изменяемого параметра.

Параметры можно вводить непосредственно в строку формул или в поля палитры формул, а если они являются ссылками — выбирать на рабочем листе. Если параметр задан, в палитре формул указывается его значение, а для опущенных параметров — значения, принятые по умолчанию. Здесь можно также увидеть значение функции, вычисленное при заданных значениях параметров.

В некоторых случаях необходимо использовать функцию как один из аргументов другой функции. Например, следующая формула использует вложенную функцию СРЗНАЧ и сравнивает результат со значением 50.

Возвращение правильного значения. Если вложенная функция используется как аргумент, то она должна возвращать значение, соответствующее типу аргумента. Например, если аргумент принимает значения ИСТИНА или ЛОЖЬ, то и вложенная функция должна возвращать значение ИСТИНА или ЛОЖЬ. Если функция возвращает значение другого типа, отобразится ошибка #ЗНАЧ!.

Ограничение количества уровней вложения функций. В формулах можно использовать до семи уровней вложения функций. Например, функции СРЗНАЧ и СУММ считаются функциями второго уровня, потому что обе являются аргументами функции ЕСЛИ.

Использование функций в качестве аргумента. Чтобы использовать функцию в качестве аргумента, можно воспользоваться панелью формул.


Цель работы

Лабораторная работа №1: Работа с базами данных

конец

вопросы

задания

Цель работы

Целью работы является практическое освоение технологии построения базы данных в СУБД Access.

База данных строится по логической модели представленной на схеме Схема БД Учебный процесс

Порядок выполнения работ

· Запустить Microsoft Access.

· В порядке, описанном в методических указаниях, изучить приемы работы в СУБД Access.

· Выполнить задания, приведенные в методических указаниях.

· Сохранить результаты работы на личной дискете.

· Показать результаты работы преподавателю.

· Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

Создание Базы данных

Работа с таблицами

Создание межтабличных связей

Заполнение таблиц данными

Работа с формами, разработанными на основе таблиц

Редактирование формы

Поиск, сортировка и фильтрация в таблицах и формах

Однотабличные запросы на выборку

Многотабличные запросы на выборку

Формы на основе запросов

Требования к отчету

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы (Суть вопроса должна быть отражена в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

СУБД Access

Основные понятия БД

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Цель работы

Лабораторная работа №2: Работа с базами данных

конец

вопросы

задания

Цель работы

Целью работы является практическое освоение технологии работы с базой данных в СУБД Access.

Порядок выполнения работ

· Запустить Microsoft Access.

· В порядке, описанном в методических указаниях, изучить приемы работы в СУБД Access.

· Выполнить задания, приведенные в методических указаниях.

· Сохранить результаты работы на личной дискете.

· Показать результаты работы преподавателю.

· Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

Запросы с параметром

Запросы с вычислением

Групповые операции

Перекрестные запросы

Запросы на изменение

Однотабличный отчет

Многотабличный отчет

Мастер отчетов

Кнопочная форма

Требования к отчету

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы (Суть вопроса должна быть отражена в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

СУБД Access

Основные понятия БД

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Цель работы

Лабораторная работа №2: Работа с электронными таблицами

конец

вопросы

задания

Цель работы

Целью работы является практическое освоение технологии работы с базой данных электронной таблицы Excel, и создания макросов.

Порядок выполнения работ

· Запустить Microsoft Excel.

· В порядке, описанном в методических указаниях, изучить приемы работы в табличном процессоре Excel.

· Выполнить задания, приведенные в методических указаниях.

· Сохранить результаты работы на личной дискете.

· Показать результаты работы преподавателю.

· Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

Использование электронных таблиц как баз данных

Заполнение базы данных

Поиск, корректировка, удаление записей

Сортировка базы данных

Фильтрация базы данных

Построение сводной таблицы

Построение сводных диаграмм

Создание макросов

Требования к отчету

  • Отчет должен быть оформлен в виде документа Word. Документ должен содержать титульный лист, оглавление, колонтитулы: верхний – название лабораторной работы, нижний - номера страниц. Поля документа: верхнее – 2 см, нижнее – 2 см, правое –3 см, левое – 1,5 см.

  • Отчет должен содержать название, цель и задачи лабораторной работы; краткие ответы на предложенные контрольные вопросы (Суть вопроса должна быть отражена в оглавлении документа), заключения и выводы.

  • На дискете должны быть сохранены файлы с заданиями, выполненными на лабораторной работе. Дискету хранить до конца семестра.

Дополнительный материал

Общие сведения о Microsoft Office 2000

Табличный процессор Excel

Список литературы

  1. Информатика. Базовый курс: Учебник для вузов / Под ред. С.В. Симоновича. –СПб.: Питер. 2001. –640с.: ил.;

  2. Новиков Ф.А., Яценко А.Д. Microsoft Office 2000 в целом. -СПб.: БХВ-Петербург, 2000. -728 с.: ил.


Шаблон

Работа с колонтитулами

конец

вопросы

задания

Верхний колонтитул – это текст, который печатается вверху каждой страницы документа. Нижний колонтитул – это текст, который печатается внизу каждой страницы документа. В MS Word колонтитулы могут содержать одну или несколько строк. Создание колонтитулов выполняется командой меню Вид → Колонтитулы.

В появившейся панели колонтитулов с помощью кнопки [image] можно переходить из нижнего в верхний колонтитул и наоборот.

В колонтитулы можно включить дату [image] , время [image] , номер страницы [image] , рисунок или иллюстрацию.

Размеры колонтитулов можно изменить, выбрав в меню Файл команду Параметры Страницы… , установив в окне Поля необходимые размеры для колонтитулов. MS Word вставит в начало и конец страницы документа место для верхнего и нижнего колонтитулов.

ЗАДАНИЕ 11

В созданном документе оформите верхний и нижний колонтитулы следующим образом:

Сохраните документ.


Шаблон

Индивидуальные задания

конец

вопросы

задания

Рассчитать сумму конечного ряда

Протабулировать функцию на отрезке с заданным шагом и построить ее график

Обработка табличных данных


Шаблоны

Приемы и средства автоматизации разработки документов. Шаблоны

начало

назад

вперед

конец

вопросы

задания

Совокупность удачных стилевых настроек сохраняется вместе с готовым документом. Но можно сохранить их и вне документа в качестве шаблонов и использовать для подготовки новых документов.

Шаблоны — это тоже документы, а точнее говоря, заготовки будущих документов. От обычных документов шаблоны отличаются тем, что в них приняты специальные меры, исключающие возможность их повреждения. Открывая шаблон, мы начинаем новый документ и вносим изменения в содержание шаблона. При сохранении же мы записываем новый документ, а шаблон, использованный в качестве его основы, остается в неизменном виде и пригоден для дальнейшего использования.

Некоторое количество универсальных шаблонов поставляется вместе с программой и устанавливается на компьютере вместе с ней.

Использование шаблона для создания документа. По команде Файл → Создать открывается диалоговое окно Создание документа, в котором можно выбрать шаблон, на базе которого документ будет разрабатываться. В этом случае документ сразу получает несколько готовых стилей оформления, содержавшихся в шаблоне.

Изменение шаблона готового документа. Эта операция выполняется с помощью диалогового окна Шаблоны и настройки (Сервис → Шаблоны и настройки). Для смены текущего шаблона следует использовать кнопку Присоединить и в открывшемся диалоговом окне Присоединение шаблона выбрать нужный шаблон в папке C:\Program Files\Microsoft Office\Шаблоны.

Создание нового шаблона на базе шаблона. По команде Файл → Создать открывается диалоговое окно Создание документа, в котором следует включить переключатель Шаблон и выбрать стандартный шаблон, на базе которого он создается. После настройки стилей и редактирования содержания выполняется сохранение шаблона командой Сохранить как с включением пункта Шаблон документа в поле Тип файла.

Создание нового шаблона на базе документа. Если готовый документ может быть использован в качестве заготовки для создания других документов, его целесообразно сохранить как шаблон. Командой Файл → Открыть открывают готовый документ, в нем правят содержание и настраивают стили, а потом сохраняют документ как шаблон командой Сохранить как с включением пункта Шаблон документа в поле Тип файла.

ЗАДАНИЕ 16

Откройте документ, созданный в предыдущем задании, сохраните его как шаблон.

Создайте новый документ на базе шаблона «Изысканное резюме». Заполните и сохраните его.


Лабораторный комплекс по Office - 14.04.04

предыдущая страница оглавление следующая страница содержание предыдущая страница оглавление следующая страница


Лабораторный комплекс по Office - 15.04.04
№№ | название | размер | дата
список создан 15.04.04 в 14:08:06 |  | утилитой dir2htm.nm.ru